Team Foundation 安裝

Visual Studio Team System
Team Foundation 安裝
DropDown image

＜Team Foundation 安裝指南＞是一本完整的指南，涵蓋使用單一或雙重伺服器以及多重用戶端拓撲的 Team Foundation 安裝方法。此外，您的組織可能想要安裝 Team Foundation Build 和 Team Foundation Server Proxy。請使用這本安裝指南安裝和設定 Team Foundation。

概觀

Visual Studio 2005 Team Foundation Server 提供小組共同作業工具，可以讓組織管理及追蹤軟體專案的進度和健全狀況。Team 總管將專案網站上的專案工作產品整合到 Visual Studio IDE 中，可以提升小組的存取效率。Team Foundation 還提供可擴充的工作項目追蹤以及企業級的版本控制系統。

在這裡開始升級

若要從 Beta 3 Refresh 升級為發行候選，請從 Microsoft 下載中心 (http://go.microsoft.com/fwlink/?LinkID=60341) 下載升級套件，並按照 Team Foundation 伺服器的升級指示執行。如要進行新的安裝，請按照本指南中的指示執行。

在這裡開始安裝

若要在新電腦上成功地安裝 Team Foundation Server，您應該進行下列作業：

  • 下載本指南的最新版本，可從 Microsoft 下載中心 (http://go.microsoft.com/fwlink/?LinkId=40042) 下載。

  • 檢閱必要條件的設定及管理文件。

    • Windows Server 2003

    • Microsoft SQL Server 2005

    • Windows SharePoint Services

    • 其他軟體 (視組織的需要而定)。

  • 在安裝 Team Foundation Server 之前，請先檢閱此安裝指南的適用章節。

  • 列印和使用適用的 Team Foundation Server 安裝檢查清單：

    • 檢查清單：Team Foundation Server 單一伺服器部署

    • 檢查清單：Team Foundation Server 雙重伺服器部署

從這裡開始安裝 MSDN Library

若要安裝 MSDN Library，請在 MSDN 安裝媒體的 MSDN 資料夾中尋找 Setup.chm 檔。MSDN 提供數個安裝選項，例如 [安裝至網路]。這些選項並非本文件涵蓋的範圍。

我們會經常更新 Visual Studio Team System 文件。您可以從 Visual Studio Team System 文件目錄取得包含 Team Foundation Server 文件變更的最新版 MSDN Library，該目錄位於 http://go.microsoft.com/fwlink/?LinkId=62213。

在本節中

Team Foundation 邏輯架構

提供組成邏輯架構的 Team Foundation 各層概觀。

Team Foundation 實體架構

提供 Team System 產品功能及 Team Foundation 實體架構的概觀。

Team Foundation 系統需求

提供不同部署安裝此版本 Team Foundation Server 的硬體和軟體系統需求。

相關章節

Team Foundation Server 安裝程式安全性概觀

提供安全性相關資訊，例如，安裝 Team Foundation Server 的使用者帳戶、服務帳戶、群組及連接埠設定。

Team Foundation Server 單一伺服器部署

請使用本節中的程序，在一台伺服器上同時安裝及設定應用程式層元件與資料層元件 Team Foundation Server。

Team Foundation Server 雙重伺服器部署概觀

請使用本節中的程序，在兩部電腦上安裝和設定 Team Foundation Server：一部用於資料層元件，而另一部用於應用程式層元件。

Team Foundation Build 安裝概觀

請使用本節中的程序來安裝和設定 Team Foundation Build，以便提供組建 Automation 來協助您建置並共用 Visual Studio 2005 方案。

Team Foundation Server Proxy 安裝概觀

請使用本節中的程序安裝 Team Foundation Server Proxy，以便快取之前存取的原始檔控制檔案。

Team 總管安裝概觀

請使用本節中的程序安裝及設定做為用戶端元件的 Team 總管。

線上資源

Visual Studio Team System 開發人員中心 (英文)(http://go.microsoft.com/fwlink/?linkid=37625)。

Visual Studio Team System 首頁。

Visual Studio Team System 論壇 (英文)(http://go.microsoft.com/fwlink/?linkid=53443)。

取得問題的解答，並與 Visual Studio Team System 使用者線上社群進行疑難排解。

Team Foundation Server 讀我檔案 (英文)(http://go.microsoft.com/fwlink/?linkid=53268)。

包含與產品安裝相關的最新問題。

Team Foundation Server 已知問題 (英文)(http://go.microsoft.com/fwlink/?linkid=53095)。

包含與產品使用相關的最新問題。

Team Foundation 系統管理員手冊 (英文)(http://go.microsoft.com/fwlink/?LinkId=52459)。

針對管理使用者和群組，以及設定伺服器和用戶端應用程式的方法提供說明，並且提供軟體開發和 Visual Studio 2005 Team System 元件部署的介紹。

若要對本產品的相關功能或是說明文件的內容提供您寶貴的建議或是指正其中的錯誤，請前往客戶意見網站。


Team Foundation 邏輯架構
請參閱
DropDown image

提供 Team Foundation N-Tier 邏輯架構的概觀。

Team Foundation 邏輯架構

Team Foundation 是根據多層架構而定，包含資料層、應用程式層和用戶層 (Client Tier)。

資料層

Team Foundation 資料層包含 Microsoft SQL Server 2005，後者可以儲存工作項目、版本控制原始程式檔、測試結果和其他的專案度量資訊。

應用程式層

Team Foundation 應用程式層是由整合於網際網路資訊服務 (IIS) 的 Web 架構的前端應用程式所組成。這些應用程式包括 SQL Server 2005 Reporting Services、Team Foundation 核心服務和 Windows SharePoint Services。此外，應用程式層還會裝載 Team Foundation Windows 服務。

Team Foundation 應用程式層還包含 Team Foundation Build 和 Team Foundation Server Proxy。Team Foundation Build 提供建置 (Build) 自動化服務。Team Foundation Server Proxy 會快取之前存取過的原始檔控制檔案，以改善使用低頻寬連接時的原始檔控制作業效能。

用戶層

Team Foundation 用戶層是由 Team 總管所組成，可用來當做獨立應用程式 (Standalone Application)，或與 Visual Studio 2005 整合 (除了 Visual Studio 2005 Express Edition 以外)。用戶層還可與 Microsoft Office Project 2003 和 Microsoft Office Excel 2003 整合，專案管理員可以用這兩者檢視專案資訊，並將該資訊發行到 Team Foundation Server。

請參閱

概念

Team Foundation 安裝
Team Foundation 實體架構


Team Foundation 實體架構
DropDown image

提供 Team Foundation 實體架構的概觀，包括由每項 Team System 產品所提供的功能。

Team Foundation 實體架構

您可以在一或多個實體電腦上安裝 Team Foundation 的邏輯層。

Team Foundation Server

您可以使用單一或雙重伺服器部署來安裝 Team Foundation Server。

單一伺服器

Team Foundation Server 的單一伺服器部署會將資料和應用程式層放置在相同的電腦上。如果選擇將用戶端層安裝在與資料層和應用程式層相同的電腦上，就應該在安裝伺服器元件後，才執行這項作業。否則，您可以用平行方式與其他層一起安裝用戶層。如需詳細資訊，請參閱 Team Foundation Server 單一伺服器部署。

雙重伺服器

Team Foundation Server 的雙重伺服器部署會將資料層和應用程式層放置在不同的電腦上。您可以同時在兩台伺服器電腦上安裝必要條件；不過，在安裝 Team Foundation 應用程式層元件之前，必須先安裝 Team Foundation 資料層元件。如果您選擇在同一部電腦上安裝用戶層與應用程式層，就應該在安裝應用程式層元件後，進行這些動作。否則，您可以用平行方式與其他層一起安裝用戶層。如需詳細資訊，請參閱 Team Foundation Server 雙重伺服器部署概觀。

Team Foundation Build

Team Foundation Server 提供建置 (Build) 自動化，可協助您使用 Team Foundation Build 建置及共用 Visual Studio 2005 方案。可以在不同的電腦或與 Team Foundation 應用程式層相同的電腦上安裝 Team Foundation Build。如需詳細資訊，請參閱 Team Foundation Build 安裝概觀。

Team Foundation Server Proxy

Team Foundation Server Proxy 會快取之前存取過的檔案，可改善 Team Foundation 版本控制的效能。可以在不同的電腦或與 Team Foundation 應用程式層相同的電腦上安裝 Team Foundation Proxy。如需詳細資訊，請參閱 Team Foundation Server Proxy 安裝概觀

Team Explorer

如前所述，用戶層是由 Team 總管所組成，可用來當做獨立應用程式 (Standalone Application)，或與 Visual Studio 2005 整合 (除了 Visual Studio 2005 Express Edition 以外)。若要存取 Team Foundation Server，必須先安裝 Team 總管。Team 總管同時是僅具 Team Foundation 功能的獨立應用程式，也是提供 Team Foundation 整合功能的 Visual Studio 的附加元件。它可以用來存取工作項目追蹤、專案管理以及版本控制等功能。還可以使用 Team 總管存取支援舊版 Visual Studio 開發活動的 Team Foundation Server 功能。如需詳細資訊，請參閱 Team 總管安裝概觀。

請參閱

概念

Team Foundation 安裝
Team Foundation 邏輯架構


Team Foundation 系統需求

Team Foundation 系統需求
DropDown image

提供安裝 Team Foundation Server 的硬體和軟體系統需求。

  • Team Foundation Server (單一伺服器)

  • Team Foundation Server (雙重伺服器)

  • Active Directory 網域需求

  • 網路卡設定

  • 64 位元作業系統支援

  • 軟體

  • Team 總管

  • Team Foundation Build

  • Team Foundation Server Proxy

Team Foundation Server (單一伺服器)

以下是 Team Foundation Server 的系統需求建議清單。您還應該驗證電腦是否符合 Team Foundation Server 必要條件的最低系統需求，例如 Microsoft SQL Server 2005 和 Windows SharePoint Services 的必要需求。

警告事項 警告

Team Foundation Server 不能安裝在網域控制站上，也不能與 Exchange Server 或 Host Integration Server 之類的其他伺服器安裝在同一台電腦上。

單一伺服器部署，小型小組

用於支援使用者人數在 20 位以下之規模的小組以及產品試用：

元件 | 建議配備
處理器 | 2.2 GHz Pentium IV 或 Athlon
作業系統 | Windows Server 2003 Service Pack 1 (SP1) Enterprise Edition Windows Server 2003 Service Pack 1 (SP1) Standard Edition
記憶體 | 1 GB
硬碟 | 8 GB 的可用空間

單一伺服器部署，中型小組

用於支援使用者人數在 50 位以下之規模的小組：

元件 | 建議配備
處理器 | 2.2 GHz Pentium IV 或 Athlon
作業系統 | Windows Server 2003 Service Pack 1 (SP1) Enterprise Edition Windows Server 2003 Service Pack 1 (SP1) Standard Edition
記憶體 | 2 GB
硬碟 | 30 GB 的可用空間

Team Foundation Server (雙重伺服器)

以下是 Team Foundation Server 的系統需求建議清單。您還應該驗證電腦是否符合 Team Foundation Server 必要條件的最低系統需求，例如 Microsoft SQL Server 2005 和 Windows SharePoint Services 的必要需求。

警告事項 警告

Team Foundation Server 不能安裝在網域控制站上，也不能與 Exchange Server 或 Host Integration Server 之類的其他伺服器安裝在同一台電腦上。

雙重伺服器部署，部門

用於支援使用者人數在 250 位以下之規模的部門：

Team Foundation 應用程式層

元件 | 建議配備
處理器 | 2.2 GHz Pentium IV 或 Athlon
作業系統 | Windows Server 2003 Service Pack 1 (SP1) Enterprise Edition Windows Server 2003 Service Pack 1 (SP1) Standard Edition
記憶體 | 1 GB
硬碟 | 20 GB 的可用空間

Team Foundation 資料層

元件 | 建議配備
處理器 | 雙重處理器、2.2 GHz Pentium IV 或 Athlon
作業系統 | Windows Server 2003 Service Pack 1 (SP1) Enterprise Edition Windows Server 2003 Service Pack 1 (SP1) Standard Edition
記憶體 | 2 GB
硬碟 | 80 GB 的可用空間

雙重伺服器部署，事業群

用於支援使用者人數在 500 位以下之規模的事業群：

Team Foundation 應用程式層

元件 | 建議配備
處理器 | 雙重處理器、2.2 GHz Pentium IV 或 Athlon
作業系統 | Windows Server 2003 Service Pack 1 (SP1) Enterprise Edition Windows Server 2003 Service Pack 1 (SP1) Standard Edition
記憶體 | 2 GB
硬碟 | 40 GB 的可用空間

Team Foundation 資料層

元件 | 建議配備
處理器 | 四重處理器、2.2 GHz Pentium IV 或 Athlon
作業系統 | Windows Server 2003 Service Pack 1 (SP1) Enterprise Edition Windows Server 2003 Service Pack 1 (SP1) Standard Edition
記憶體 | 4 GB
硬碟 | 150 GB 的可用空間

Active Directory 網域需求

若要在雙重伺服器部署中安裝及設定 Team Foundation Server，必須使用已加入 Active Directory 網域的電腦。對於單一伺服器部署而言，可以使用工作群組成員的電腦，或者已加入 Active Directory 網域的電腦。在使用已加入 Active Directory 網域的電腦時，Team Foundation Server 所需的是不包含 Windows NT 4.0 網域控制站的 Active Directory 網域。請使用下表判斷 Team Foundation Server 是否支援您的 Active Directory 網域功能等級：

Active Directory 網域功能等級 | 支援
Windows 2000 混合模式 - 支援執行 Windows NT Server 4.0、Windows 2000 和 Windows Server 2003 的網域控制站。 | 否
Windows 2000 原始模式 - 支援執行 Windows 2000 和 Windows Server 2003 的網域控制站。 | 是
Windows Server 2003 過渡模式 - 支援執行 Windows NT Server 4.0 和 Windows Server 2003 的網域控制站。 | 否
Windows Server 2003 模式 - 支援執行 Windows Server 2003 的網域控制站。 | 是

網路卡設定

在進行不同的作業時，Team Foundation Server 會連接至資料層、應用程式層和用戶層上適當的服務和元件。Team Foundation Server 傳送大量資料的完成速度 (例如，建立新的 Team 專案、上載大型文件或將大型檔案簽入原始檔控制)，大部份取決於電腦網路連線的速度。

如果您進行這類作業時遇到效能低落的情形，這有可能是因網路設定的問題，間接限制了系統的工作效率。而網路交換器與電腦網路卡的組態 (例如，是否開啟「自動偵測模式」或　「自動協調」，或者是以全雙工模式或半雙工模式來傳輸資訊) 都有可能會影響網路速度。

許多情況下，只要將網路卡設為全雙工模式，並且明確地設定配接器執行的速率 (例如，100Mbs)，而不倚賴自動偵測，就可以減少資料傳輸所花費的時間。請確認所有電腦上的網路卡都已正確設定。如需詳細資訊，請參閱＜如何疑難排解網路連線問題＞ (http://support.microsoft.com/?scid=kb;CH-TW;Q325487).

64 位元作業系統支援

下表代表 Team Foundation 應用程式所提供的 64 位元作業系統支援：

Team Foundation 應用程式 | 支援
Team Foundation Server1 | 否
Team Foundation Server (資料庫)2 | 是
Team Foundation Server (服務)2 | 否
Team Foundation Server (Proxy) | 否
Team Foundation Server (組建) | 否
Team 總管 | 否

1 Team Foundation Server 單一伺服器部署。

2 Team Foundation Server 雙重伺服器部署。

軟體

Team Foundation Server 需要以下軟體才能安裝成功。若要安裝 Team Foundation Server，需要熟悉並安裝下列軟體：

伺服器軟體 | 內容
Microsoft SQL Server 2005 (Standard 或 Enterprise Edition) | Team Foundation Server 和 Windows SharePoint Services 的資料庫後端。
Microsoft SQL Server 2005 Hotfix | 更新 SQL Server Analysis Services，更有效率地支援報表功能。
.NET Framework 2.0 Hotfix KB913363 | 更新 ASP.NET，使大型檔案的處理更有效率。
安裝有 Service Pack 2 的 Windows SharePoint Services 2.0 | 裝載 Team 專案入口網站。

Team Foundation Server 包含 Microsoft SQL Server 2005 Standard Edition 的授權版本，可與 Team Foundation Server 搭配使用。

Team 總管另外還可以與以下軟體搭配使用，不過就算沒有安裝這些軟體，Team 總管仍然可以使用。如果要使用，請確認在您安裝 Team 總管 之前，先安裝這些軟體。

用戶端軟體 | 內容
Microsoft Office Excel 2003 | 支援選擇性的 Team Foundation 與工作項目追蹤整合。
Microsoft Office Project Professional 2003 | 支援選擇性的 Team Foundation 與工作項目追蹤整合。

如需如何設定讓軟體與 Team 總管 共用，請參閱 HOW TO：安裝 Team 總管必要條件。

下列軟體也可以和 Team Foundation Build 一起使用。您不需要先安裝，就可以使用 Team Foundation Build；但是，這個軟體必須和 Team Foundation Build 安裝在相同的電腦上，才可以使用特定的功能。

用戶端軟體 | 內容
Team Edition for Developers | 支援執行靜態程式碼分析。
Team Edition for Testers | 支援在建置時執行測試。

Team 總管

Team 總管的系統需求與 Visual Studio 2005 的系統需求相同。如需詳細資訊，請參閱 Visual Studio 2005 的讀我檔案。Team 總管的硬體需求建議如下：

元件 | 建議配備
處理器 | 2.0 GHz
作業系統 | Team 總管作業系統的需求與 Visual Studio 2005 作業系統的需求相同。如需詳細資訊，請參閱 Visual Studio 2005 讀我檔案。
記憶體 | 256 MB
硬碟 | 5 GB 的可用空間

Team Foundation Build

Team Foundation Build 的軟體需求與 Visual Studio 2005 的系統需求相同，除了支援僅限於安裝有 SP2 的 Windows XP Professional 和安裝有 SP1 的 Windows Server 2003 Standard 或 Enterprise Edition。如需詳細資訊，請參閱 Visual Studio 2005 的讀我檔案。Team Foundation Build 的硬體需求建議如下：

小型小組

用於建置時間少於 30 分鐘的專案：

元件 | 建議配備
處理器 | 1.5 GHz
作業系統 | Windows Server 2003 Service Pack 1 (SP1) Enterprise Edition Windows Server 2003 Service Pack 1 (SP1) Standard Edition 安裝有 SP2 的 Windows XP Professional (商用版)
記憶體 | 512 MB

中型小組

用於建置時間少於 2 小時的專案：

元件 | 建議配備
處理器 | 2.6 GHz Pentium IV 或 Athlon
作業系統 | Windows Server 2003 Service Pack 1 (SP1) Enterprise Edition Windows Server 2003 Service Pack 1 (SP1) Standard Edition 安裝有 SP2 的 Windows XP Professional (商用版)
記憶體 | 1 GB

大型小組

用於建置時間多於 2 小時的專案：

元件 | 建議配備
處理器 | 雙重處理器、2.8 GHz Pentium IV 或 Athlon
作業系統 | Windows Server 2003 Service Pack 1 (SP1) Enterprise Edition Windows Server 2003 Service Pack 1 (SP1) Standard Edition 安裝有 SP2 的 Windows XP Professional (商用版)
記憶體 | 2 GB

Team Foundation Server Proxy

Team Foundation Server Proxy 的軟體需求包括 Internet Information Services (IIS)、.NET Framework 2.0 以及 Hotfix KB913363。Team Foundation Server Proxy 建議使用的硬體需求如下：

元件 | 建議配備
處理器 | 單一處理器，2.X GHz
作業系統 | Windows Server 2003 Service Pack 1 (SP1) Enterprise Edition Windows Server 2003 Service Pack 1 (SP1) Standard Edition
記憶體 | 2 GB

請參閱

工作

HOW TO：安裝 Team 總管必要條件
HOW TO：安裝 Team Foundation Server Proxy
逐步解說：安裝 Team Foundation Server 單一伺服器部署
逐步解說：安裝 Team Foundation Server 雙重伺服器部署

參考

檢查清單：Team Foundation Server 單一伺服器部署
檢查清單：Team Foundation Server 雙重伺服器部署
檢查清單：Team Foundation Server 叢集部署
檢查清單：待命應用程式層組態

概念

Team Foundation 安裝
Team Foundation 實體架構


Team Foundation Server 安裝程式安全性概觀

Team Foundation Server 安裝程式安全性概觀
DropDown image

提供安裝 Team Foundation Server 的安全性相關資訊。

在本節中

設定 Team Foundation Server 所需的使用者帳戶

描述在安裝和設定 Team Foundation Server 時需要建立的使用者帳戶。

設定 Team Foundation Server 所需的連接埠

提供需要在中間的防火牆上開啟以使 Team Foundation 元件能彼此通訊的通訊埠相關資訊。

Team Foundation Server 安全性群組

描述 Team Foundation Server 用來管理安全性的安全性群組。

HOW TO：將使用者加入到 Team Foundation Administrators 應用程式群組

描述如何將使用者加入至 [Team Foundation Administrators] 群組，此群組所包含的使用者可以在伺服器上執行所有需要權限的 Team Foundation 作業。

管理 Team Foundation Server 的安全性角色

描述 Team Foundation Server 所需的安全性角色，包括 Windows SharePoint Services 和 SQL Server Reporting Services。

相關章節

Team Foundation Server 單一伺服器部署

請使用本節中的程序，在一部伺服器上安裝和設定 Team Foundation Server。

Team Foundation Server 雙重伺服器部署概觀

請使用本節中的程序，在兩部電腦上安裝和設定 Team Foundation Server：一部用於資料層元件，而另一部用於應用程式層元件。

Team Foundation Build 安裝概觀

請使用本節中的程序來安裝和設定 Team Foundation Build，以便提供組建 Automation 來協助您建置並共用 Visual Studio 2005 方案。

Team Foundation Server Proxy 安裝概觀

請使用本節中的程序來安裝 Team Foundation Server Proxy，以便快取之前存取的原始檔控制檔案。

Team 總管安裝概觀

請使用本節中的程序來安裝和設定 Team 總管。

請參閱

概念

Team Foundation 安裝


設定 Team Foundation Server 所需的使用者帳戶

設定 Team Foundation Server 所需的使用者帳戶
DropDown image

描述在安裝和設定 Team Foundation Server 時需要的使用者帳戶。

部署考量

使用者帳戶的需求端視部署模型而定：單一伺服器或雙重伺服器。在單一伺服器部署中，可以選擇使用 Active Directory 網域使用者帳戶或本機使用者帳戶。

單一伺服器部署

若要使用加入 Active Directory 網域的電腦上的單一伺服器部署安裝及設定 Team Foundation Server，就會需要下表描述的三個 Active Directory 網域使用者帳戶。

若要在工作群組成員的電腦上使用單一伺服器部署安裝及設定 Team Foundation Server，可以使用本機使用者帳戶。如果您使用執行安裝程式和服務的本機使用者帳戶安裝 Team Foundation Server，則無法將網域使用者帳戶加入至 Team Foundation Server，且這些帳戶無法建立專案。這些使用者帳戶應是網域使用者帳戶，不過仍允許使用本機使用者帳戶。

雙重伺服器部署

若要使用雙重伺服器部署安裝及設定 Team Foundation Server，則兩台電腦都必須加入 Active Directory 網域，且您需要下表描述的三個 Active Directory 網域使用者帳戶。

必要的帳戶

在安裝 Team Foundation Server 之前，您必須先找出安裝期間要使用的帳戶。本安裝指南會以替代名稱表示這些帳戶，如表中所標註。如果您要使用不同的使用者登入名稱，或者已有可用的現有帳戶，請務必在安裝時依適當方式替代為正確名稱。

範例使用者登入名稱 內容

TFSSETUP

  • 用於執行 Team Foundation Server 安裝程式。

  • 這個帳戶必須是 Team Foundation Server 電腦的系統管理員。

  • 這個帳戶與下列兩個服務帳戶必須屬於相同網域的成員。例如，您不能在某個網域上擁有兩個服務帳戶，卻使用本機帳戶執行安裝程式。

TFSSERVICE

  • 由 Team Foundation Server Windows 服務 ([程式碼涵蓋範圍分析服務] 和 TFSSchedulerService) 以及 SharePoint Timer Service 用來當做服務帳戶。

  • 由 Team Foundation Server 應用程式集區 (VSTF AppPool) 以及 Windows SharePoint Services 應用程式集區 (TFWSS 和 WSS_AppPool) 用來當做應用程式集區識別。

  • 必須具有 Team Foundation Server 電腦的 [本機登入] 權限。

  • 為達最佳安全性，這個服務帳戶：

    • 不應是 Team Foundation Server 電腦的系統管理員。

    • 應選取網域上 Active Directory 的 [這是機密帳戶，無法委派] 選項。

TFSREPORTS

  • 由 SQL Server Reporting Services 資料來源用來做為服務帳戶。

  • 這個帳戶不能是 Team Foundation Server 電腦的系統管理員。

  • 這個帳戶必須具有 Team Foundation Server 電腦的 [本機登入] 權限。

TFSPROXY

  • 由不是 Team Foundation Server 應用程式層和資料層元件同一網域成員的電腦上的 Team Foundation Server Proxy 使用。

  • 這個服務帳戶必須是遠端電腦上 [Administrators] 群組的成員。

  • 這個服務帳戶必須是使用 Proxy 的 Team Foundation Server 中，[Team Foundation Valid Users] 群組的成員。

如需詳細資訊，請參閱設定 Team Foundation Server 所需的使用者帳戶。

請參閱

工作

HOW TO：安裝 Team 總管必要條件
HOW TO：安裝 Team Foundation Server Proxy
逐步解說：安裝 Team Foundation Server 單一伺服器部署
逐步解說：安裝 Team Foundation Server 雙重伺服器部署

參考

檢查清單：Team Foundation Server 單一伺服器部署
檢查清單：Team Foundation Server 雙重伺服器部署
檢查清單：Team Foundation Server 叢集部署
檢查清單：待命應用程式層組態

概念

Team Foundation 安裝

其他資源

Team Foundation Server 安裝程式安全性概觀


設定 Team Foundation Server 所需的連接埠

設定 Team Foundation Server 所需的連接埠
DropDown image

提供需要在中間的防火牆上開啟以使 Team Foundation 元件能彼此通訊的 TCP 通訊埠相關資訊。

必要通訊埠

若要啟動在 Team Foundation Server、其必要條件元件和用戶端之間的通訊，必須確定位於這些元件之間的任何防火牆都允許透過一些 TCP 通訊埠進行通訊。

注意事項 注意事項

Team Foundation Server 和 SQL Server 安裝精靈會自動對 Windows 防火牆的執行個體加入必要 TCP 通訊埠的例外狀況 (Exception)。如果 Windows 防火牆尚未執行，或者其設定不允許例外狀況，就不會加入例外狀況。

SQL Server 2005 的必要通訊埠

Microsoft SQL Server 2005 (Developer、Standard 或 Enterprise Edition) 使用下列的 TCP 通訊埠：

服務或應用程式內容 | TCP 通訊埠
SQL Server Reporting Service | 80
SQL Service | 1433
SQL Browser Service | 1434
SQL Monitoring | 1444
SQL Server Analysis Service Redirector | 2382
SQL Server Analysis Service | 2383

Windows SharePoint Services 的必要通訊埠

Windows SharePoint Services 使用下列的 TCP 通訊埠：

服務或應用程式內容 | TCP 通訊埠
Windows SharePoint Services | 80
SharePoint 管理中心 | 17012

Team Foundation Server 的必要通訊埠

Team Foundation Server 使用下列的 TCP 通訊埠：

服務或應用程式內容 | TCP 通訊埠
Team Foundation Server | 8080
Team Foundation Server Proxy | 8081
Team Foundation Build Remoting1 | 9191

範圍

在 Windows 防火牆中，可以指定要將其通訊埠或服務解除封鎖的一組電腦。根據預設，範圍是設為 [任何電腦 (包括在網際網路上的)]。如果選擇限制將其通訊埠或服務解除封鎖的範圍，請確定所有需要存取該通訊埠或服務的電腦都包含在指定的範圍內。

請參閱

工作

HOW TO：安裝 Team 總管必要條件
HOW TO：安裝 Team Foundation Server Proxy
逐步解說：安裝 Team Foundation Server 單一伺服器部署
逐步解說：安裝 Team Foundation Server 雙重伺服器部署

參考

檢查清單：Team Foundation Server 單一伺服器部署
檢查清單：Team Foundation Server 雙重伺服器部署
檢查清單：Team Foundation Server 叢集部署
檢查清單：待命應用程式層組態

其他資源

Team Foundation Server 安裝程式安全性概觀


Team Foundation Server 安全性群組
DropDown image

描述 Team Foundation Server 用來管理安全性的安全性群組。

Team Foundation Server 安全性群組

Team Foundation Server 安全性是由 Team Foundation Server 安全性群組所管理，這些群組與 Windows 網域或本機安全性群組不同。

Team Foundation Server 安全性群組 描述

Team Foundation Administrators

  • 這個群組所包含的使用者可以執行伺服器上所有具有權限的作業。

  • 根據預設，安裝程式會在這個群組中加入用來執行安裝程式 (例如，Domain\TFSSETUP) 的帳戶。

服務帳戶

  • 這個群組包含 Team Foundation Server 服務帳戶，例如 Team Foundation Server Web 服務的應用程式集區識別 (例如，Domain\TFSSERVICE)。

Team Foundation Valid Users

  • 這個群組包含具有伺服器存取權的所有使用者和群組。

Team Foundation Server 安裝程式會在 [Team Foundation Administrators] 群組中，加入用來執行安裝程式的使用者帳戶，例如 Domain\TFSSETUP。若要在這個群組中加入其他使用者，必須使用已是 [Team Foundation Administrators] 成員的帳戶。在安裝程式完成後，需要使用執行安裝程式的相同帳戶登入 (例如，Domain\TFSSETUP)，才能將初始的新成員加入至 [Team Foundation Administrators] 群組。

Team Foundation Server 安裝程式還會將 Team Foundation Server 服務帳戶 (例如，Domain\TFSSERVICE) 加入至 [Service Accounts] 群組。

請參閱

工作

HOW TO：將使用者加入到 Team Foundation Administrators 應用程式群組

概念

Team Foundation 安裝

其他資源

Team Foundation Server 安裝程式安全性概觀


HOW TO：將使用者加入到 Team Foundation Administrators 應用程式群組

HOW TO：將使用者加入到 Team Foundation Administrators 應用程式群組

Team Foundation Server 安全性是由 Team Foundation Server 安全性群組所管理，該群組與 Windows 網域或本機安全性群組有所區別。[Team Foundation Administrators] 群組所包含的使用者可以在伺服器上，執行所有需要權限的 Team Foundation 作業。

注意事項 注意事項

用來執行 Team Foundation Server 安裝程式的使用者帳戶 (例如，Domain\TFSSETUP) 會自動加入至 [Team Foundation Administrators] 群組。若要在此群組中加入其他使用者，必須使用已是這個安全性群組成員的帳戶，例如 Domain\TFSSETUP。

若要讓使用者能夠建立專案，必須將使用者加入至這個群組，並指派 Windows SharePoint Services 和 SQL Server Reporting Services 中的角色給使用者。您可以使用 Team 總管或 TFSSecurity 命令列公用程式。

若要使用 Team 總管將使用者加入 Team Foundation Administrators 安全性群組

  1. 使用已是 [Team Foundation Administrators] 安全性群組成員之使用者帳戶 (例如，Domain\TFSSETUP) 的認證登入用戶層 (Client Tier) 電腦。

  2. 安裝 Team 總管。如需詳細資訊，請參閱 Team 總管安裝概觀。

  3. 啟動 Visual Studio 並連接到 Team Foundation Server。如需詳細資訊，請參閱 HOW TO：將 Team 總管連接到 Team Foundation Server。

  4. 在 [Team 總管] 中選取要管理的 Team Foundation Server。

  5. 在 [小組] 功能表上，指向 [Team Foundation Server 設定]，然後按一下 [群組成員資格]。

  6. 在 [全域群組] 對話方塊中，選取要加入使用者的群組，然後按一下 [屬性]。

  7. 在 [Team Foundation Server 群組屬性] 對話方塊的 [成員] 索引標籤中，選取 [Windows 使用者或群組]，然後按一下 [加入]。

  8. 在 [選取使用者或群組] 對話方塊中，以下列格式輸入網域名稱以及要加入的使用者名稱：

    domain\username

    若要一次加入一位以上的使用者，請使用分號 (;) 隔開這些項目。

  9. 按一下 [確定]。

使用 Team Foundation 安全性命令列公用程式 (TFSSecurity.EXE) 將使用者加入 Team Foundation Administrators 安全性群組

  1. 使用已是 [Team Foundation Administrators] 安全性群組成員的使用者帳戶 (例如，Domain\TFSSETUP) 的認證登入應用程式層 (Client Tier) 電腦。

  2. 在 Windows 檔案總管中，搜尋 Team Foundation Server 安裝資料夾中的 [Tools] 目錄。

    根據預設，其路徑為 <磁碟機>:\Program Files\Microsoft Visual Studio 2005 Team Foundation Server\Tools。

  3. 在 [開始] 功能表中，按一下 [所有程式]，然後按一下 [命令提示字元]。

  4. 在 [命令提示字元] 視窗中，使用 TFSSecurity 命令列公用程式的 /g+ 選項，將使用者加入至 [Team Foundation Administrators] 群組。

    您必須設定下列識別規範並指出 Team Foundation Server 伺服器。

    • Adm：表示使用者會加入至通用系統管理員群組。

    • n：指定要加入的網域和使用者帳戶

    • /server：指示應用程式層的 Team Foundation Server 伺服器。

    例如，下列命令會使用應用程式層將 ADATUM 網域中 Dieter Zilch 的使用者帳戶，加入至連接到本機電腦的 Team Foundation Server。

    TFSSecurity /g+ adm: n:ADATUM\DZilch /server:http://localhost:8080

讓使用者建立 Team 專案

若要建立 Team 專案，使用者必須獲派 SQL Server Reporting Services 和 Windows Server SharePoint Services 中的角色。以下提供您可以進行指派工作的位置。如需如何使用這些頁面的詳細資訊，請參閱《Team Foundation Server 管理指南》或使用頁面上提供的說明。

指派其他元件中的角色給使用者

  1. 在 http://<application-tier>/_layouts/1033/user.aspx 將使用者加入 Windows SharePoint Services 的 Administrator 角色。

  2. 使用位於 http://<application-tier>/Reports 的 SQL Server Reporting Services 首頁，將使用者加入至 SQL Server Reporting Services 的「內容管理員」角色。

安全性

您必須是 [Team Foundation Administrators] 群組的成員或已將 [編輯伺服器層級資訊] 權限設為 [允許]，才能執行此程序。用來安裝 Team Foundation Server 的使用者帳戶會自動加入至此群組，並且能夠在安裝期間加入使用者。如需詳細資訊，請參閱《Team Foundation Server 管理員手冊》中的＜Team Foundation Server 使用權限＞(http://go.microsoft.com/fwlink/?linkid=52459)。

請參閱

概念

Team Foundation 安裝
設定 Team Foundation Server 所需的使用者帳戶
Team Foundation Server 安全性群組


管理 Team Foundation Server 的安全性角色

管理 Team Foundation Server 的安全性角色
DropDown image

描述 Team Foundation Server 所需的安全性角色，包括 Windows SharePoint Services 和 SQL Server Reporting Services。

安全性角色成員資格

將使用者賬戶加入至 Team Foundation Server 安全性角色時，還必須將該使用者加入至 Window SharePoint Services 和 SQL Server Reporting Services 中適當的安全性角色。

若要在 Team Foundation Server 中建立新的 Team 專案，必須是 [Team Foundation Administrators] 群組的成員、Windows SharePoint Services [Administrator] 角色的成員，以及 SQL Server Reporting Services [內容管理員] 角色的成員。下表指出對於 Team Foundation Server 中的全域安全性群組而言，下列每項產品正確的安全性角色成員資格。

Team Foundation Server 安全性群組 | Windows SharePoint Services 角色 | SQL Server Reporting Services 角色
[Server]\Team Foundation Administrators | Administrator (最上層網站) | 內容管理員 (系統層級角色)
[Server]\Team Foundation Valid Users | n/a1 | n/a1
[Server]\Service Accounts | n/a2 | n/a2

1[Team Foundation Valid Users] 群組包含具有伺服器存取權的所有使用者和群組。這個群組包含的使用者和群組全都是伺服器上 Team 專案的成員。沒有必要管理這個群組的成員資格。

2[Service Accounts] 群組中的帳戶不需具有 Windows SharePoint Services 或 SQL Server Reporting Services 安全性角色的成員資格。

在建立 Team 專案之後，要為使用者指派不同的角色，以根據個別的專案管理其權限。Windows SharePoint Services 網站不會從上層網站繼承安全性設定。相反地，SQL Server Reporting Services 項目層級的安全性會繼承系統層級的角色。下表指出對於 Team Foundation Server 中的專案層級安全性群組而言，下列每項產品正確的安全性角色成員資格。

Team Foundation Server 安全性群組 | Windows SharePoint Services 角色 | SQL Server Reporting Services 角色
[ProjectName]\Project Administrators1 | Administrator | 內容管理員
[ProjectName]\Contributor1 | Contributor | 瀏覽器
[ProjectName]\Reader1 | Reader | 瀏覽器

1這個名稱是衍生自 MSF for Agile Software Development 流程範本。專案層級安全性群組的實際名稱會根據選擇的流程範本而不同。

如需在 Windows SharePoint Services 和 SQL Server Reporting Services 中管理安全性角色成員資格的程序，請參閱每項產品隨附的產品文件。

請參閱

概念

Team Foundation 安裝


Team Foundation 安裝逐步解說

Team Foundation 安裝逐步解說
DropDown image

您可以使用以下的逐步解說，根據部署選項檢視單一主題中的安裝程序。這些逐步解說僅涵蓋設定資料庫和應用程式層服務。如需如何安裝 Team Foundation 用戶層元件的詳細資訊，請參閱相關章節中的連結。

在本節中

逐步解說：安裝 Team Foundation Server 單一伺服器部署

說明在單一電腦上安裝資料層和應用程式層的程序。

檢查清單：Team Foundation Server 單一伺服器部署

提供檢查清單以當做 Team Foundation Server 單一伺服器部署期間的方便參考。

逐步解說：安裝 Team Foundation Server 雙重伺服器部署

說明在一台電腦上安裝資料層，並且在另一台電腦上安裝應用程式層的程序。

檢查清單：Team Foundation Server 雙重伺服器部署

提供檢查清單以當做 Team Foundation Server 雙重伺服器部署期間的方便參考。

參考

Team Foundation 系統需求

設定 Team Foundation Server 所需的使用者帳戶

設定 Team Foundation Server 所需的連接埠

相關章節

Team Foundation Build 安裝概觀

Team Foundation Server Proxy 安裝概觀

Team 總管安裝概觀


逐步解說：安裝 Team Foundation Server 雙重伺服器部署

逐步解說：安裝 Team Foundation Server 雙重伺服器部署
全部折疊影像 展開影像

您可以使用本逐步解說，在兩台電腦上安裝 Team Foundation Server 的伺服器元件。

展開影像 必要條件

您需要具有以下設備和資訊，才能完成安裝。

  • 列印版 檢查清單：Team Foundation Server 雙重伺服器部署。

  • 兩台電腦，而且兩台都必須符合您的小組規模適用的軟硬體需求。如需詳細資訊，請參閱 Team Foundation 系統需求。

  • 兩個 Team Foundation Server 的服務帳戶。如需詳細資訊，請參閱設定 Team Foundation Server 所需的使用者帳戶。

  • 一個用來完成安裝的使用者帳戶，該帳戶必須是兩台電腦上 Administrator 安全性群組的成員。

展開影像 程序摘要

若要安裝資料層元件

  1. 使用安裝媒體上的回應檔案安裝 Microsoft SQL Server 2005 Standard 或 Enterprise Edition。

  2. 安裝 Microsoft SQL Server 2005 的 Hotfix 並啟用，然後重新啟動 SQL Browser 服務。

  3. 安裝 Team Foundation Server (資料庫)。

安裝應用程式層服務

  1. 安裝已啟用 ASP.NET 的 Internet Information Services (IIS)。

  2. 安裝 SQL Server 2005 Reporting Services

  3. 安裝 Microsoft .NET Framework 2.0 的 Hotfix。

  4. 安裝含 Service Pack2 的 Windows SharePoint Services。

  5. 安裝 Team Foundation Server (服務)。

展開影像 在資料層上安裝 Microsoft SQL Server 2005

符合必要條件後，即可安裝 Microsoft SQL Server 2005 Standard 或 Enterprise Edition。

若要以互動方式安裝 Microsoft SQL Server 2005

  1. 在資料層電腦上，使用 Team Foundation Server 設定帳戶 (例如，Domain\TFSSETUP) 登入 Windows。

  2. 放入 Microsoft SQL Server 2005 的光碟片，然後在 [SQL Server 2005 起始] 頁的 [安裝] 下，按一下 [伺服器元件、工具、線上叢書和範例]。

    注意事項 注意事項

    Microsoft SQL Server 2005 Standard Edition 的光碟片會隨 Team Foundation Server 提供。若要安裝 Microsoft SQL Server 2005 Enterprise，您可以使用另外購買之軟體的光碟片。從安裝媒體的 Servers 資料夾中執行 Splash.hta 檔，便會顯示 [起始頁]。

    Microsoft SQL Server 2005 安裝精靈便會啟動。

  3. 在 [使用者授權合約] 頁面中，檢閱授權合約。如果您接受這些條款和條件，請選取 [我接受授權條款和條件]，然後按 [下一步]。

  4. 在 [安裝必要條件] 頁面上，按一下 [安裝]。必要的元件都安裝成功後，請按 [下一步]。

    [Microsoft SQL Server 安裝精靈] 隨即啟動。

  5. 按 [下一步] 啟動 [系統組態檢查]。

  6. 在 [系統組態檢查] 頁面中，檢查任何所需動作的狀態 (例如，所需的系統重新啟動)，然後遵循此頁面上的指引進行，直到所有動作都達到 [成功] 狀態為止。在 [IIS 功能需求] 以外的所有動作都達到 [成功] 狀態後，按 [下一步] 啟動安裝。

    注意事項 注意事項

    資料層電腦上並未安裝 SQL Server 2005 Reporting Services。因此您可以安全無虞地忽略 [IIS 功能需求] 的 [警告] 狀態。安裝程式可能需要數分鐘才會啟動。

  7. 在 [註冊資訊] 頁面中，完成註冊資訊，然後按 [下一步]。

  8. 在 [要安裝的元件] 頁面上選取下列元件，然後按一下 [進階]。

    • SQL Server Database Services

    • Analysis Services

    • Integration Services

    • 工作站元件、線上叢書及開發工具

      注意事項 注意事項

      Reporting Services 應安裝在應用程式層上。Team Foundation Server 不需要 Notification Services。

  9. 在 [功能選擇] 頁面上，展開下列節點並指定下列選項。

    注意事項 注意事項

    除了本節中標註的項目外，您不應變更任何其他功能範圍中的預設選項。

    1. 在 [Database Services] 下，按一下 [複寫] 的圖示，然後選取 [整個功能將無法使用]。

      注意事項 注意事項

      如果您要為資料檔指定不同的位置，請選取 [資料檔]，然後按一下 [瀏覽] 指定一個目錄或另一個實體硬碟。根據預設，SQL Server 2005 會將所有檔案安裝到系統磁碟機。改用其他位置，可以提高系統的效能。您也可以為 [Analysis Services] 下的 [資料檔] 指定其他位置。

    2. 在 [用戶端元件] 下，唯一要安裝的必要功能是 [管理工具]。對於 [用戶端元件] 下的所有其他項目，可以選擇性地按一下圖示，並選取 [整個功能將無法使用]。

    3. 在 [文件集、範例和範例資料庫] 下，可以選擇性地按一下 [SQL Server 線上叢書] 的圖示，然後選取 [整個功能將無法使用]。按 [下一步]。

  10. 在 [執行個體名稱] 頁面中，選取 [預設的執行個體]，然後按 [下一步]。

    注意事項 重要資訊

    如果您指定具名執行個體，Team Foundation Server 安裝程式將會失敗。

  11. 在 [服務帳戶] 頁面上，選取 [使用內建的系統帳戶]，並從清單選取 [本機系統]。在 [在安裝程式結束時啟動服務] 中，選取所有服務：[SQL Server]、[SQL Server Agent]、[Analysis Services] 和 [SQL Browser]，然後按 [下一步]。

    注意事項 注意事項

    這個服務帳戶是 Microsoft SQL Server 2005 專用的，請勿與開始安裝前取得的兩個服務帳戶混淆。

  12. 在 [驗證模式] 頁面中，選取 [Windows 驗證模式]，然後按 [下一步]。

  13. 在 [定序設定] 頁面上，選取適合您語言的定序，然後按 [下一步]。

    注意事項 注意事項

    如果您變更 [定序指示項和排序順序]，則必須選取 [區分腔調字]。

    預設選項是以 Windows Server 2003 中非 Unicode 語言的設定為基礎。大部分語言的預設值都是 Windows 定序，不過，SQL Server 2005 針對 U.S. English 安裝了 SQL Server 定序，以便支援回溯相容性。如果您要變更預設的定序，以支援額外的 U.S. English 字元集，請考慮使用 [Latin1_General]。

    至於其他語言，請考慮 "_90" Windows 定序 (如果有的話)，否則請使用另一種 Windows 定序。

    例如，若要進行日文部署而不使用預設定序，而您使用 Unicode CJK Extension A 字元集或 Unicode Surrogates，請使用 [Japanese_90] 定序，如下所述。

    • Team Foundation Server 物件名稱，例如查詢或專案。

    • 簽入版本控制系統的檔案或路徑。

    • 用於搜尋的任何工作項目欄位。

    為避免發生全形或平假名/片假名這類字元的問題，請在安裝期間選取啟用區分假名和區分全半形的核取方塊。

    Team Foundation Server 不支援下列定序：

    • 不區分腔調字

    • 二進位

    • Binary2

    • 區分大小寫

    如需定序設定的詳細資訊，請參閱《SQL Server 2005 線上叢書》中的＜安裝程式中的定序設定＞。

  14. 在 [錯誤和使用方式報表設定] 頁面上，可選擇性地選取 [自動將 SQL Server 2005 的錯誤報告傳送至 Microsoft 或您的 Corporate Error Reporting 伺服器] 和 [自動將 SQL Server 2005 的功能使用方式資料傳送至 Microsoft]，然後按 [下一步]。

  15. 在 [已完成安裝準備工作] 頁面中，您可以檢閱即將安裝的元件清單，然後按一下 [安裝]。

  16. 在 [安裝進度] 頁面中，您可以監視每個元件的安裝狀態。完成安裝程式後，請按 [下一步]。

    注意事項 注意事項

    在 SQL Server Reporting Services 啟動過程中，安裝程式可能會停止回應幾分鐘。

  17. 按一下 [完成] 結束精靈。

    注意事項 注意事項

    若要在安裝 Team Foundation Server 之前驗證安裝，請參閱 HOW TO：驗證 Microsoft SQL Server 2005 安裝。

展開影像 安裝 Microsoft SQL Server 2005 Hotfix

安裝 Microsoft SQL Server 2005 之後，必須安裝會更新 SQL Server Analysis Services 的 Hotfix，以便更有效地支援報告。

注意事項 注意事項

如需最新的更新，請造訪 Microsoft 網站 (http://go.microsoft.com/fwlink/?LinkId=62015)。

若要安裝 Microsoft SQL Server 2005 Hotfix

  1. 在資料層電腦上，開啟 [SQL Server 組態管理員]，以滑鼠右鍵按一下 [SQL Server Browser 服務]，然後按一下 [停止]。

  2. 在 Team Foundation Server 安裝媒體上，尋找 SQLServerKB 資料夾。

  3. 尋找適用於您作業系統和語言的可執行檔 (.exe)，例如 AS2005-KBnnnnnn-x86-ENU.exe，然後按兩下該檔案啟動 Hotfix 安裝程式。

  4. 在 [Hotfix 安裝程式] 中，接受 [使用者授權合約]，完成頁面以安裝 Hotfix，然後按一下 [完成]。

  5. 在 [SQL Server 組態管理員] 中，用滑鼠右鍵按一下 [SQL Server Browser 服務]，再按一下 [屬性]。

  6. 在 [服務] 索引標籤上，尋找 [啟動模式]，然後選取 [自動]。

  7. 在 [登入] 索引標籤上，按一下 [啟動]。

    注意事項 注意事項

    如果 [登入] 索引標籤中的 [啟動] 未啟用，按一下 [服務] 索引標籤，將 [啟動模式] 設為 [停用]，然後再選取 [自動] 確實地更新 [啟動模式]。

若要在安裝 Windows SharePoint Services 之前驗證安裝，請參閱 HOW TO：驗證 Microsoft SQL Server 2005 安裝。

展開影像 安裝 Team Foundation Server 資料庫

在您安裝 Team Foundation Server 之前，請先確定 Microsoft SQL Server 2005 Standard 或 Enterprise Edition 已經安裝好並啟動執行。如需詳細資訊，請參閱檢查清單：Team Foundation Server 雙重伺服器部署。

若要安裝 Team Foundation Server (資料庫)

  1. 使用逐步進行檢查清單時指定的 Team Foundation Server 設定帳戶 (例如，Domain\TFSSETUP) 登入 Windows。

  2. 放入 Team Foundation Server 安裝媒體，然後在自動執行頁面上按一下 [安裝 Team Foundation Server]，然後按一下 [雙重伺服器安裝]，再按一下 [僅安裝 Team Foundation 資料庫層]。

    如果自動執行頁面並未顯示，請在安裝媒體的根資料夾中找出自動執行檔 (autorun.exe) 並執行。

    Visual Studio 2005 Team Foundation Server (資料庫) 安裝精靈便會啟動。

  3. 在 [歡迎使用安裝程式] 頁面中，按 [下一步]。

  4. 在 [授權條款] 頁面上，檢閱授權合約。如果您接受這些條款和條件，請選取 [我接受授權合約]，然後按 [下一步]。

  5. 在 [目的資料夾] 頁面中，按 [下一步]。

  6. 在 [系統健康檢查] 頁面上，按一下 [報告] 連結檢查所有警告或阻礙情形。

    • 開始安裝之前，一定要先把阻礙情形排除。按一下 [取消]，並在修正所有問題之後再次執行安裝程式。

    • 雖然您應該先處理警告，然後再繼續進行，不過不應該阻礙安裝程式完成。您可以按 [下一步]。

      例如，如果未啟用防火牆，此清單中便會出現警告。您可以繼續進行安裝，但是可能必須手動加入啟用元件之間通訊必要的連接埠和例外狀況。

    • 如果未列出任何項目，請按 [下一步]。

  7. 在 [已完成安裝準備工作] 頁面中，按一下 [安裝]。

  8. 在 [安裝元件] 頁面上，監視 Team Foundation 資料層元件的安裝。

    進行安裝時，系統會提示您重新啟動電腦。按一下 [立即重新啟動]。電腦重新啟動且您使用相同帳戶再次登入之後，安裝程式便會繼續執行。

  9. 在 [安裝成功] 頁面中，按一下 [完成]。

  10. 在自動執行頁面上，按一下 [結束]。

檢視 Team Foundation Server 資料庫

  1. 依序按一下 [開始]、[程式集]、[Microsoft SQL Server 2005]，然後按一下 [SQL Server Management Studio]。

  2. 在 [連接至伺服器] 對話方塊中，選取 [伺服程式類型] 中的 [資料庫引擎]，輸入要連接的伺服器名稱，然後按一下 [連接]。

    注意事項 注意事項

    如果 SQL Server 安裝在叢集上，那麼伺服器名稱應該是這個叢集的名稱，而不是電腦的名稱。

  3. 在 [物件總管] 中展開 [資料庫]，並確認 Team Foundation Server 資料庫存在。

展開影像 將應用程式層設為應用程式伺服器

您的應用程式層電腦可能已設為應用程式伺服器。如果已設定 Windows 元件 Internet Information Services (IIS)，請確認已啟用 ASP.NET (未啟用時則須先啟用)。否則，請遵循此程序安裝 IIS 及啟用 ASP.NET。

若要使用新增或移除程式公用程式啟用 ASP.NET

  1. 在 [控制台] 中，開啟 [新增或移除程式]。

  2. 按一下 [新增/移除 Windows 元件]。

    [Windows 元件精靈] 隨即啟動。

  3. 在 [Windows 元件] 頁面中，選取 [應用程式伺服器]，然後按一下 [詳細資料]。

  4. 如果尚未核取，請選取 [ASP.NET]，然後按一下 [確定]。

    注意事項 重要資訊

    請勿選取 [FrontPage 2002 Server Extensions]。這台伺服器將會裝載與 FrontPage Server Extensions 不相容的 Windows SharePoint Services。

  5. 在 [Windows 元件] 頁面中，按 [下一步]。

    注意事項 注意事項

    您可能會收到放入 Windows Server 2003 安裝媒體的提示。

  6. 按一下 [完成] 關閉精靈。

  7. 請造訪 Windows Update (http://windowsupdate.microsoft.com) 並安裝重大更新和 Service Pack 群組中的所有項目。

展開影像 安裝 Microsoft SQL Server Reporting Services

啟用 ASP.NET 之後，安裝搭配 Team Foundation Server 使用的 SQL Server 2005 Reporting Services (使用 Microsoft SQL Server 2005 Standard 或 Enterprise Edition)。

安裝 Microsoft SQL Server 2005 Reporting Services

  1. 在應用程式層電腦上，使用 Team Foundation Server 設定帳戶 (例如，Domain\TFSSETUP) 登入 Windows。

  2. 放入 Microsoft SQL Server 2005 的光碟片，然後在 [SQL Server 2005 起始] 頁的 [安裝] 下，按一下 [伺服器元件、工具、線上叢書和範例]。

    注意事項 注意事項

    Microsoft SQL Server 2005 Standard Edition 的光碟片會隨 Team Foundation Server 提供。若要安裝 SQL Server Enterprise，您可以使用另外購買之軟體的光碟片。從安裝媒體的 Servers 資料夾中執行 Splash.hta 檔，便會顯示 [起始頁]。

    Microsoft SQL Server 2005 安裝精靈便會啟動。

  3. 在 [使用者授權合約] 頁面中，檢閱授權合約。如果您接受這些條款和條件，請選取 [我接受授權條款和條件]，然後按 [下一步]。

  4. 在 [安裝必要條件] 頁面上，按一下 [安裝]。必要的元件都安裝成功後，請按 [下一步]。

    [Microsoft SQL Server 安裝精靈] 隨即啟動。

  5. 按 [下一步] 啟動 [系統組態檢查]。

  6. 在 [系統組態檢查] 頁面中，檢查任何所需動作的狀態 (例如，所需的系統重新啟動)，然後遵循此頁面上的指引進行，直到所有動作都達到 [成功] 狀態為止。在所有動作都達到 [成功] 狀態後，按 [下一步] 啟動安裝。

    注意事項 注意事項

    安裝程式可能需要幾分鐘才能啟動。

  7. 在 [註冊資訊] 頁面中，完成註冊資訊，然後按 [下一步]。

  8. 在 [要安裝的元件] 頁面中，選取 [Reporting Services]，然後按 [下一步]。

    注意事項 注意事項

    如果按一下 [進階]，請勿移除任何預設的選取項目。

  9. 在 [執行個體名稱] 頁面中，選取 [預設的執行個體]，然後按 [下一步]。

    注意事項 重要資訊

    如果您指定具名執行個體，Team Foundation Server 安裝程式將會失敗。

  10. 在 [服務帳戶] 頁面上，選取 [使用內建的系統帳戶]，並從清單選取 [網路服務]。在 [在安裝程式結束時啟動服務] 中選取 [Reporting Services]，然後按 [下一步]。

  11. 在 [報表伺服器安裝選項] 頁面中，按 [下一步]。

    根據預設，會選取 [安裝但不設定伺服器]。

  12. 在 [錯誤和使用方式報表設定] 頁面上，可選擇性地選取 [自動將 SQL Server 2005 的錯誤報告傳送至 Microsoft 或您的 Corporate Error Reporting 伺服器] 和 [自動將 SQL Server 2005 的功能使用方式資料傳送至 Microsoft]，然後按 [下一步]。

  13. 在 [已完成安裝準備工作] 頁面中，您可以檢閱即將安裝的元件清單，然後按一下 [安裝]。

  14. 在 [安裝進度] 頁面中，您可以監視每個元件的安裝狀態。完成安裝程式後，請按 [下一步]。

    注意事項 注意事項

    在 SQL Server Reporting Services 啟動過程中，安裝程式可能會停止回應幾分鐘。

  15. 按一下 [完成] 結束精靈。

警告事項 警告

請勿使用 [Reporting Services 組態工具] 確認服務正在執行。Team Foundation Server 安裝精靈會自動設定 Reporting Services，因此開啟此工具可能會阻止安裝程式完成。

展開影像 驗證 Reporting Services 安裝

安裝完成後，請確認服務正常執行且設為自動啟動。

若要驗證安裝

  1. 依序按一下 [開始]、[系統管理工具]，然後按一下 [服務]。

  2. 在 [服務管理員] 的 [名稱] 欄中尋找 [SQL Server Reporting Services]，並確認 [狀態] 為 [已啟動] 且 [啟動類型] 為 [自動]。

    注意事項 注意事項

    您可以變更狀態或啟動類型，只要以滑鼠右鍵按一下服務，按一下 [內容] 並進行變更即可。

  3. 關閉 [服務管理員]。

展開影像 安裝 Microsoft .NET Framework 2.0 Hotfix

在您安裝 Microsoft SQL Server 2005 Reporting Services 之後，必須安裝會更新 ASP.NET 的 Hotfix，才能支援更有效地處理大型檔案的功能。

注意事項 注意事項

您可以造訪提供最新 Team Foundation Server 更新的網頁。

若要安裝 Microsoft .NET Framework 2.0 Hotfix

  1. 在應用程式層電腦上，尋找 Team Foundation Server 安裝媒體上的 KB913393 資料夾。

  2. 尋找適合您作業系統 (X86) 的可執行檔 (.exe)，然後按兩下該檔案進行安裝。

展開影像 安裝 Windows SharePoint Services

安裝 Hotfix 之後，必須為 Team Foundation Server 安裝 Microsoft Windows SharePoint Services 及 Service Pack 2。

注意事項 重要資訊

Windows SharePoint Services 需要 NTFS 檔案系統。

若要以互動方式安裝 Windows SharePoint Services

  1. 在應用程式層電腦上，使用 Team Foundation Server 設定帳戶 (例如，Domain\TFSSETUP) 登入 Windows。

  2. 下載 Microsoft Windows SharePoint Services (加上 Service Pack 2)(http://go.microsoft.com/fwlink/?linkid=55087)，並將檔案儲存到本機硬碟。

  3. 執行下載的自解壓縮安裝程式檔案 (stsv2.exe)。

  4. 在 [使用者授權合約] 頁面中，檢閱授權合約。如果您接受這些條款和條件，請選取 [我接受授權合約]，然後按 [下一步]。

  5. 在 [安裝類型] 頁面上選取 [伺服器陣列]，然後按 [下一步]。

    注意事項 重要資訊

    您必須使用 [伺服器陣列] 選項安裝 Windows SharePoint Services。這會將 Windows SharePoint Services 設定為使用遠端 SQL Server。然後，Team Foundation Server 安裝程式會將 Windows SharePoint Services 設定為與 Team Foundation Server 其他部分使用相同的 SQL Server 執行個體。

  6. 在 [摘要] 頁面中按一下 [安裝]。

    當安裝完成時，Web 瀏覽器視窗會開啟並顯示 [設定管理虛擬伺服器] 頁面。在確認該頁面出現後，關閉瀏覽器視窗而不進行任何變更。

    注意事項 重要資訊

    不要在出現的頁面上進行任何變更。然後，Team Foundation Server 安裝程式會將 Windows SharePoint Services 設定為與 Team Foundation Server 其他部分使用相同的 SQL Server 執行個體。

    如果該頁面沒有出現，則應該判斷原因，並使用＜Windows SharePoint Services 系統管理員手冊＞(英文)(http://go.microsoft.com/fwlink/?LinkId=52668)。

  7. 請造訪 Windows Update (http://windowsupdate.microsoft.com) 並安裝重大更新和 Service Pack 群組中的所有項目。

  8. 重新啟動電腦。

若要驗證 Windows SharePoint Services 已安裝

  • 開啟 Internet Explorer 並輸入伺服器名稱做為位址。

    例如，若伺服器名稱為 ADATUM，則輸入 Http://adatum。

    雖然站台尚未設定好，但這台伺服器已經是使用中的 Web 伺服器，因此仍然會傳回 [建構中] 頁面。

展開影像 安裝 Team Foundation Server (服務)

安裝所有相關元件之後，您就可以安裝 Team Foundation Server 應用程式層元件。

注意事項 注意事項

如果您要在 Windows SharePoint Services 的當地語系化版本上安裝 Team Foundation Server，必須先安裝符合 Team Foundation Server 語言的 Windows SharePoint Services 語言套件。例如，如果準備安裝 Windows SharePoint Services 的當地語系化版本以及 Team Foundation Server 的英文版，則必須在安裝 Team Foundation Server 之前先安裝英文的 Windows SharePoint Services 語言套件。

若要安裝 Team Foundation Server (服務)

  1. 在應用程式層電腦上，使用 Team Foundation Server 設定帳戶 (例如，Domain\TFSSETUP) 登入 Windows。

  2. 在放入光碟片之後出現的自動執行頁面上，按一下 [安裝 Team Foundation Server]，按一下 [雙重伺服器安裝]，然後按一下 [僅安裝 Team Foundation 應用程式層]。

    如果自動執行頁面並未顯示，請在安裝媒體的根資料夾中找出自動執行檔 (autorun.exe) 並執行。

    Visual Studio Team Foundation Server (服務) 安裝精靈隨即啟動。

  3. 在 [歡迎使用安裝程式] 頁面中，按 [下一步]。

  4. 在 [授權條款] 頁面上，檢閱授權合約。如果您接受這些條款和條件，請選取 [我接受授權合約]，然後按 [下一步]。

    安裝精靈會進行掃描，找出可能會導致安裝失敗或未來伺服器運作出問題的狀況。

  5. 在 [目的資料夾和資料庫伺服器] 頁面上輸入下列資訊：

    • 在 [目的資料夾] 方塊中，輸入安裝路徑或接受預設值。

    • 在 [資料庫伺服器] 方塊中輸入其上已安裝 Team Foundation Server (資料庫) 的電腦名稱。

      注意事項 注意事項

      必須使用電腦的名稱，而不是 IP 位址。

  6. 在 [系統健康檢查] 頁面上，按一下 [報告] 連結檢查所有警告或阻礙情形。

    • 開始安裝之前，一定要先把阻礙情形排除。按一下 [取消]，並在修正所有問題之後再次執行安裝程式。

    • 雖然您應該先處理警告，然後再繼續進行，不過不應該阻礙安裝程式完成。您可以按 [下一步]。

    • 如果未列出任何項目，請按 [下一步]。

  7. 在 [服務帳戶] 頁面上，輸入 Team Foundation Server 服務帳戶的帳戶資訊 (例如，Domain\TFSSERVICE)，然後按 [下一步]。

  8. 在 [報告資料來源帳戶] 頁面上，輸入 Team Foundation Server 報告帳戶的帳戶資訊 (例如，Domain\TFSREPORTS)，然後按 [下一步]。

    注意事項 注意事項

    這個帳戶不應該與 Team Foundation Server 設定或服務帳戶相同。

  9. 在 [Team Foundation 警示] 頁面上，輸入下列資訊：

    1. 在 [SMTP 服務] 方塊中，輸入要用來傳送 Team Foundation 警示的伺服器名稱。

    2. 在 [寄件者電子郵件地址] 方塊中，輸入傳送 Team Foundation 警示的電子郵件地址名稱，然後按 [下一步]。

      注意事項 注意事項

      如果要在此處啟用警示，則您必須知道組織的 SMTP 伺服器。Team Foundation Server 不需要專門存取 SMTP 的特殊組態設定。安裝和設定 SMTP 並非本文件集涵蓋的範圍。如需詳細資訊，請參閱 Windows Server 2003 的文件。

  10. 在 [已完成安裝準備工作] 頁面中，按一下 [安裝]。

    進行安裝時，系統會提示您重新啟動電腦。按一下 [立即重新啟動]，安裝程式會在電腦重新啟動而您再次登入後繼續。

  11. 在 [安裝成功] 頁面中，按一下 [完成]。

  12. 在 Internet Explorer 中，尋找 http://localhost:8080/services/v1.0/Registration.asmx，然後按一下 [GetRegistrationEntries]。

  13. 在 [GetRegistrationEntries] 頁面中按一下 [叫用]。您不需要輸入 ToolID。

    注意事項 注意事項

    您必須位於應用程式層電腦上，才能使用此 Web 方法。

  14. 在 XML 中，確定有下列顯示的 VSTF 型別存在，然後關閉。

    <?xml version="1.0" encoding="utf-8" ?>

    <Type>vstfs</Type>

展開影像 後續步驟

安裝 Team Foundation Server 之後，必須讓其他使用者管理和建立 Team 專案。如需詳細資訊，請參閱 HOW TO：將使用者加入到 Team Foundation Administrators 應用程式群組。

安裝並執行 Team Foundation Server 元件之後，您就可以安裝下列的其他 Team Foundation 元件。

  • Team 總管

  • Team Foundation Build

  • Team Foundation Server Proxy

建立 Team 專案時不一定要採用下列建議，但這些建議為管理 Team Foundation Server 的最佳作法。

  • 您應該使用 [Reporting Services 組態工具] 將 Reporting Services 加密金鑰備份。如需詳細資訊，請參閱《Team Foundation Server 管理員手冊》中的＜HOW TO：備份 Reporting Services 加密金鑰＞。

  • 您應建立資料庫維護計畫，並排定時程進行完整且漸進式的備份。

Expand image 請參閱

其他資源

Team Foundation Build 安裝概觀
Team Foundation Server Proxy 安裝概觀
Team 總管安裝概觀


逐步解說：安裝 Team Foundation Server 單一伺服器部署

逐步解說：安裝 Team Foundation Server 單一伺服器部署
全部折疊影像 展開影像

您可以使用本逐步解說，在單一電腦上安裝 Team Foundation Server 的伺服器元件。

展開影像 必要條件

您需要具有以下設備和資訊，才能完成安裝。

  • 列印版 檢查清單：Team Foundation Server 單一伺服器部署。

  • 一台電腦，且必須符合您的小組規模適用的軟硬體需求。如需詳細資訊，請參閱 Team Foundation 系統需求。

  • 兩個 Team Foundation Server 的服務帳戶。如需詳細資訊，請參閱設定 Team Foundation Server 所需的使用者帳戶。Microsoft SQL Server 2005 也需要服務帳戶，不過您可以使用內建的帳戶。

  • 一個用來完成安裝的使用者帳戶，該帳戶必須是兩台電腦上 Administrator 安全性群組的成員。

展開影像 安裝程序摘要

若要安裝資料層元件

  1. 安裝已啟用 ASP.NET 的 Internet Information Services (IIS)。

  2. 使用安裝媒體上的回應檔案安裝 Microsoft SQL Server 2005 Standard 或 Enterprise Edition。

  3. 安裝 Microsoft SQL Server 2005 的 Hotfix 並啟用，然後重新啟動 SQL Browser 服務。

  4. 安裝 Microsoft .NET Framework 2.0 的 Hotfix。

  5. 安裝含 Service Pack2 的 Windows SharePoint Services 2.0。

  6. 安裝 Team Foundation Server (服務)。

展開影像 安裝 Internet Information Services (IIS)

您的應用程式層電腦可能已設為應用程式伺服器。如果已設定 Windows 元件 Internet Information Services (IIS)，請確認已啟用 ASP.NET (未啟用時則須先啟用)。否則，請遵循此程序安裝 IIS 及啟用 ASP.NET。

若要使用新增或移除程式公用程式安裝 IIS

  1. 在 [控制台] 中，開啟 [新增或移除程式]。

  2. 按一下 [新增/移除 Windows 元件]。

    [Windows 元件精靈] 隨即啟動。

  3. 在 [Windows 元件] 頁面中，選取 [應用程式伺服器]，然後按一下 [詳細資料]。

  4. 如果尚未選取，請選取 [ASP.NET]，然後按一下 [確定]。

    注意事項 重要資訊

    如果您選取 [Internet Information Services (IIS)]，然後按一下 [詳細資料]，則不要選取 [FrontPage 2002 Server Extensions]。這台伺服器將會裝載與 FrontPage Server Extensions 不相容的 Windows SharePoint Services。

  5. 在 [Windows 元件] 頁面中，按 [下一步]。

    注意事項 注意事項

    您可能會收到放入 Windows Server 2003 安裝媒體的提示。

  6. 按一下 [完成] 關閉精靈。

  7. 請造訪 Windows Update (http://windowsupdate.microsoft.com) 並安裝重大更新和 Service Pack 群組中的所有項目。

請使用這個程序，使用安裝精靈以互動方式或是使用回應檔案，為 Team Foundation Server 安裝及設定 Microsoft SQL Server 2005 Standard 或 Enterprise Edition。

展開影像 安裝 Microsoft SQL Server 2005

符合必要條件之後，您就可以安裝 Microsoft SQL Server 2005 Standard 或 Enterprise Edition。Team Foundation Server 包含 Microsoft SQL Server 2005 Standard Edition 的授權版本。

若要以互動方式安裝 Microsoft SQL Server 2005

  1. 使用 Team Foundation Server 設定帳戶 (例如，Domain\TFSSETUP) 登入 Windows。

  2. 放入 Microsoft SQL Server 2005 的光碟片，然後在 [SQL Server 2005 起始] 頁的 [安裝] 下，按一下 [伺服器元件、工具、線上叢書和範例]。

    注意事項 注意事項

    Microsoft SQL Server 2005 Standard Edition 的光碟片會隨 Team Foundation Server 提供。若要安裝 SQL Server Enterprise，您可以使用另外購買之軟體的光碟片。從安裝媒體的 Servers 資料夾中執行 Splash.hta 檔，便會顯示 [起始頁]。

    Microsoft SQL Server 2005 安裝精靈便會啟動。

  3. 在 [使用者授權合約] 頁面中，檢閱授權合約。如果您接受這些條款和條件，請選取 [我接受授權條款和條件]，然後按 [下一步]。

  4. 在 [安裝必要條件] 頁面上，按一下 [安裝]。必要的元件都安裝成功後，請按 [下一步]。

    [Microsoft SQL Server 安裝精靈] 隨即啟動。

  5. 按 [下一步] 啟動 [系統組態檢查]。

  6. 在 [系統組態檢查] 頁面中，檢查任何所需動作的狀態 (例如，所需的系統重新啟動)，然後遵循此頁面上的指引進行，直到所有動作都達到 [成功] 狀態為止。在所有動作都達到 [成功] 狀態後，按 [下一步] 啟動安裝。

    注意事項 注意事項

    安裝程式可能需要數分鐘才會啟動。

  7. 在 [註冊資訊] 頁面中，完成註冊資訊，然後按 [下一步]。

  8. 在 [要安裝的元件] 頁面上選取下列元件，然後按一下 [進階]。

    • SQL Server Database Services

    • Analysis Services

    • Integration Services

    • Reporting Services

    • 工作站元件、線上叢書及開發工具

      注意事項 注意事項

      Team Foundation Server 不需要 Notification Services。

  9. 在 [功能選擇] 頁面上，展開下列節點並指定下列選項。

    注意事項 注意事項

    除了本節中標註的項目外，您不應變更任何其他功能範圍中的預設選項。

    1. 在 [Database Services] 下，按一下 [複寫] 的圖示，然後選取 [整個功能將無法使用]。

      注意事項 注意事項

      若要最佳化系統效能，請選取 [資料檔]，然後按一下 [瀏覽]，在不同的實體硬碟上指定檔案位置。根據預設，SQL Server 2005 會將所有檔案安裝到系統磁碟機。您也可以為 [Analysis Services] 下的 [資料檔] 指定其他位置。

    2. 在 [用戶端元件] 下，唯一要安裝的必要功能是 [管理工具]。對於 [用戶端元件] 下的所有其他項目，可以選擇性地按一下圖示，並選取 [整個功能將無法使用]。

    3. 在 [文件集、範例和範例資料庫] 下，可以選擇性地按一下 [線上叢書] 的圖示，然後選取 [整個功能將無法使用]。按 [下一步]。

  10. 在 [執行個體名稱] 頁面中，選取 [預設的執行個體]，然後按 [下一步]。

    注意事項 重要資訊

    如果您指定具名執行個體，Team Foundation Server 安裝程式將會失敗。

  11. 在 [服務帳戶] 頁面上，選取 [使用內建的系統帳戶]，並從清單選取 [本機系統]。在 [在安裝程式結束時啟動服務] 中，選取所有服務：[SQL Server]、[SQL Server Agent]、[Analysis Services]、[Reporting Services] 和 [SQL Browser]，然後按 [下一步]。

    注意事項 注意事項

    此服務帳戶用於 Microsoft SQL Server 2005，且應避免與開始安裝之前取得的兩個系統帳戶混淆。

  12. 在 [驗證模式] 頁面中，選取 [Windows 驗證模式]，然後按 [下一步]。

  13. 在 [定序設定] 頁面上，選取適合您語言的定序，然後按 [下一步]。

    注意事項 注意事項

    如果您變更 [定序指示項和排序順序]，則必須選取 [區分腔調字]。

    預設選項是以 Windows Server 2003 中非 Unicode 語言的設定為基礎。大部分語言的預設值都是 Windows 定序，不過，SQL Server 2005 針對 U.S. English 安裝了 SQL Server 定序，以便支援回溯相容性。如果您要變更預設的定序，以支援額外的 U.S. English 字元集，請考慮使用 [Latin1_General]。

    至於其他語言，請考慮 "_90" Windows 定序 (如果有的話)，否則請使用另一種 Windows 定序。

    例如，若要進行日文部署而不使用預設定序，而您使用 Unicode CJK Extension A 字元集或 Unicode Surrogates，請使用 [Japanese_90] 定序，如下所述：

    • Team Foundation Server 物件名稱，例如查詢或專案。

    • 簽入版本控制系統的檔案或路徑。

    • 用於搜尋的任何工作項目欄位。

    為避免發生全形或平假名/片假名這類字元的問題，請在安裝期間選取啟用區分假名和區分全半形的核取方塊。

    Team Foundation Server 不支援下列定序：

    • 不區分腔調字

    • 二進位

    • Binary2

    • 區分大小寫

    如需定序設定的詳細資訊，請參閱《SQL Server 2005 線上叢書》中的＜安裝程式中的定序設定＞。

  14. 在 [報表伺服器安裝選項] 頁面上，選取 [安裝預設組態]，然後按 [下一步]。

  15. 在 [錯誤和使用方式報表設定] 頁面上，可選擇性地選取 [自動將 SQL Server 2005 的錯誤報告傳送至 Microsoft 或您的 Corporate Error Reporting 伺服器] 和 [自動將 SQL Server 2005 的功能使用方式資料傳送至 Microsoft]，然後按 [下一步]。

  16. 在 [已完成安裝準備工作] 頁面中，您可以檢閱即將安裝的元件清單，然後按一下 [安裝]。

  17. 在 [安裝進度] 頁面中，您可以監視每個元件的安裝狀態。完成安裝程式後，請按 [下一步]。

    注意事項 注意事項

    在 SQL Server Reporting Services 啟動過程中，安裝程式可能會停止回應幾分鐘。

  18. 按一下 [完成] 結束精靈。

展開影像 安裝 Microsoft SQL Server 2005 Hotfix

安裝 Microsoft SQL Server 2005 之後，必須安裝會更新 SQL Server Analysis Services 的 Hotfix，以便更有效地支援報告。

注意事項 注意事項

如需最新的更新，請造訪 Microsoft 網站 (http://go.microsoft.com/fwlink/?LinkId=62015)。

若要安裝 Microsoft SQL Server 2005 Hotfix

  1. 在資料層電腦上，開啟 [SQL Server 組態管理員]，以滑鼠右鍵按一下 [SQL Server Browser 服務]，然後按一下 [停止]。

  2. 在 Team Foundation Server 安裝媒體上，尋找 SQLServerKB 資料夾。

  3. 尋找適用於您作業系統和語言的可執行檔 (.exe)，例如 AS2005-KBnnnnnn-x86-ENU.exe，然後按兩下該檔案啟動 Hotfix 安裝程式。

  4. 在 [Hotfix 安裝程式] 中，接受 [使用者授權合約]，完成頁面以安裝 Hotfix，然後按一下 [完成]。

  5. 在 [SQL Server 組態管理員] 中，用滑鼠右鍵按一下 [SQL Server Browser 服務]，再按一下 [屬性]。

  6. 在 [服務] 索引標籤上，尋找 [啟動模式]，然後選取 [自動]。

  7. 在 [登入] 索引標籤上，按一下 [啟動]。

    注意事項 注意事項

    如果 [登入] 索引標籤中的 [啟動] 未啟用，按一下 [服務] 索引標籤，將 [啟動模式] 設為 [停用]，然後再選取 [自動] 確實地更新 [啟動模式]。

若要在安裝 Windows SharePoint Services 之前驗證安裝，請參閱 HOW TO：驗證 Microsoft SQL Server 2005 安裝。

展開影像 安裝 Microsoft .NET Framework 2.0 Hotfix

您必須安裝更新 ASP.NET 的 Hotfix，才能支援更有效率地處理大型檔案的功能。

注意事項 注意事項

您可以造訪提供最新 Team Foundation Server 更新的網頁。

若要安裝 Microsoft .NET Framework 2.0 Hotfix

  1. 在應用程式層電腦上，尋找 Team Foundation Server 安裝媒體上的 KB913393 資料夾。

  2. 尋找適合您作業系統 (X86) 的可執行檔 (.exe)，然後按兩下該檔案進行安裝。

展開影像 安裝 Microsoft Windows SharePoint Services

請按照下列步驟，使用安裝精靈以互動方式或是從命令列以無訊息模式，為 Team Foundation Server 安裝 Microsoft Windows SharePoint Services (加上 Service Pack 2)。

注意事項 重要資訊

Windows SharePoint Services 需要 NTFS 檔案系統。

若要以互動方式安裝 Windows SharePoint Services

  1. 使用 Team Foundation Server 設定帳戶 (例如，Domain\TFSSETUP) 登入 Windows。

  2. 下載 Microsoft Windows SharePoint Services (加上 Service Pack 2)(http://go.microsoft.com/fwlink/?linkid=55087)，並將檔案儲存到本機硬碟。

  3. 執行下載的自解壓縮安裝程式檔案 (stsv2.exe)。

  4. 在 [使用者授權合約] 頁面中，檢閱授權合約。如果您接受這些條款和條件，請選取 [我接受授權合約]，然後按 [下一步]。

  5. 在 [安裝類型] 頁面上選取 [伺服器陣列]，然後按 [下一步]。

    注意事項 重要資訊

    您必須使用 [伺服器陣列] 選項安裝 Windows SharePoint Services。這會將 Windows SharePoint Services 設定為使用遠端 SQL Server。稍後，Team Foundation Server 安裝程式會將 Windows SharePoint Services 設定為與 Team Foundation Server 其他部分使用相同的 SQL Server 執行個體。

  6. 在 [摘要] 頁面中按一下 [安裝]。

    當安裝完成時，Web 瀏覽器視窗會開啟並顯示 [設定管理虛擬伺服器] 頁面。在確認該頁面出現後，關閉瀏覽器視窗而不進行任何變更。

    注意事項 重要資訊

    不要在出現的頁面上進行任何變更。稍後，Team Foundation Server 安裝程式會將 Windows SharePoint Services 設定為與 Team Foundation Server 其他部分使用相同的 SQL Server 執行個體。

    如果該頁面沒有出現，則應該判斷原因，並使用＜Windows SharePoint Services 系統管理員手冊＞(英文)(http://go.microsoft.com/fwlink/?LinkId=52668)。

  7. 請造訪 Windows Update (http://windowsupdate.microsoft.com) 並安裝重大更新和 Service Pack 群組中的所有項目。

  8. 重新啟動電腦。

展開影像 驗證 Windows SharePoint Services 安裝

安裝 Windows SharePoint Services 之後，即使您未安裝 Team Foundation Server，仍可以確認服務正常執行。

若要驗證 Windows SharePoint Services 已安裝

  • 開啟 Internet Explorer 並輸入伺服器名稱做為位址。

    例如，若伺服器名稱為 ADATUM，則輸入 Http://adatum。

    雖然站台尚未設定好，但這台伺服器已經是使用中的 Web 伺服器，因此仍然會傳回 [建構中] 頁面。

    注意事項 注意事項

    在 Windows SharePoint Services 的當地語系化版本上安裝 Team Foundation Server 之前，必須先安裝符合 Team Foundation Server 語言的 Windows SharePoint Services 語言套件。例如，如果準備安裝 Windows SharePoint Services 的當地語系化版本以及 Team Foundation Server 的英文版，則必須在安裝 Team Foundation Server 之前先安裝英文的 Windows SharePoint Services 語言套件。

展開影像 安裝 Team Foundation Server

安裝所有相關元件之後，您就可以安裝 Team Foundation Server。

若要安裝 Team Foundation Server

  1. 使用 Team Foundation Server 設定帳戶 (例如，Domain\TFSSETUP) 登入 Windows。

  2. 在放入光碟片後出現的自動執行頁面上，按一下 [安裝 Team Foundation Server]，然後按一下 [單一伺服器安裝]。

    如果自動執行頁面並未顯示，請在安裝媒體的根資料夾中找出自動執行檔 (autorun.exe) 並執行。

    Visual Studio Team Foundation Server 安裝精靈隨即啟動。

  3. 在 [歡迎使用安裝程式] 頁面中，按 [下一步]。

  4. 檢閱 [授權條款] 頁面上的條款。如果您接受這些條款和條件，請選取 [我接受授權合約]，然後按 [下一步]。

    安裝精靈會進行掃描，找出可能會導致安裝失敗或未來伺服器運作出問題的狀況。

  5. 在 [目的資料夾] 頁面中，接受預設目的資料夾，然後按 [下一步]。

  6. 在 [系統健康檢查] 頁面上，按一下 [報告] 連結檢查所有警告或阻礙情形。

    • 開始安裝之前，一定要先把阻礙情形排除。按一下 [取消]，並在修正所有問題之後再次執行安裝程式。

    • 雖然您應該先處理警告，然後再繼續進行，不過不應該阻礙安裝程式完成。您可以按 [下一步]。

    • 如果未列出任何項目，請按 [下一步]。

  7. 在 [服務帳戶] 頁面中，於 [帳戶名稱] 方塊中輸入您為 Team Foundation Server 服務帳戶 (例如，Domain\TFSSERVICE) 建立的 Windows 網域使用者帳戶、於 [密碼] 方塊中輸入密碼，然後按 [下一步]。如需詳細資訊，請參閱設定 Team Foundation Server 所需的使用者帳戶。

  8. 在 [報告資料來源帳戶] 頁面上，輸入 Team Foundation Server 報告帳戶的帳戶資訊，然後按 [下一步]。

    注意事項 注意事項

    這個帳戶應該與 Team Foundation Server 安裝或服務帳戶不同。例如，請使用 Domain\TFSREPORTS。

  9. 在 [指定警示設定] 頁面上，選取 [啓用 Team Foundation 警示]，然後輸入下列資訊：

    • 在 [SMTP 伺服器] 方塊中，輸入要用來傳送電子郵件通知的伺服器名稱。

    • 在 [寄件者電子郵件地址] 方塊中，輸入發出通知的電子郵件地址名稱，然後按 [下一步]。

  10. 在 [已完成安裝準備工作] 頁面中，按一下 [安裝]。

  11. 在 [安裝元件] 頁面上可以監視 Team Foundation Server 的安裝。

    進行安裝時，系統會提示您重新啟動電腦。按一下 [立即重新啟動]，安裝程式會在電腦重新啟動而您再次登入後繼續。

  12. 在 [安裝成功] 頁面上，確認安裝完成後，按一下 [完成]。

    安裝 Team Foundation Server 之後，應該使用 [Reporting Services 組態工具] 將 Reporting Services 加密金鑰備份。這個步驟雖然不是建立 Team 專案所必須的，但卻是管理 Team Foundation Server 最佳作法的一部分。如需詳細資訊，請參閱《Team Foundation Server 管理員手冊》中的＜HOW TO：備份 Reporting Services 加密金鑰＞(http://go.microsoft.com/fwlink/?LinkID=52459)。

  13. 在 Internet Explorer 中，尋找 http://localhost:8080/services/v1.0/Registration.asmx，然後按一下 [GetRegistrationEntries]。

  14. 在 [GetRegistrationEntries] 頁面中按一下 [叫用]。您不需要輸入 ToolID。

    注意事項 注意事項

    您必須位於應用程式層電腦上，才能使用此 Web 方法。

  15. 在 XML 中，確認 VSTF 型別存在，接著將其關閉。例如：

    <?xml version="1.0" encoding="utf-8" ?>

    <Type>vstfs</Type>

展開影像 後續步驟

安裝 Team Foundation Server 之後，必須讓其他使用者管理和建立 Team 專案。如需詳細資訊，請參閱 HOW TO：將使用者加入到 Team Foundation Administrators 應用程式群組。

安裝並執行 Team Foundation Server 元件之後，您就可以安裝下列的其他 Team Foundation 元件。

  • Team 總管

  • Team Foundation Build

  • Team Foundation Server Proxy

建立 Team 專案時不一定要採用下列建議，但這些建議為管理 Team Foundation Server 的最佳作法。

  • 您應該使用 [Reporting Services 組態工具] 將 Reporting Services 加密金鑰備份。如需詳細資訊，請參閱《Team Foundation Server 管理員手冊》中的＜HOW TO：備份 Reporting Services 加密金鑰＞。

  • 您應建立資料庫維護計畫，並排定時程進行完整且漸進式的備份。

Expand image 請參閱

其他資源

Team Foundation Build 安裝概觀
Team Foundation Server Proxy 安裝概觀
Team 總管安裝概觀


Team Foundation Server 單一伺服器部署

Team Foundation Server 單一伺服器部署
DropDown image

請使用本節中的程序，在一部伺服器上安裝和設定 Team Foundation Server。

在本節中

檢查清單：Team Foundation Server 單一伺服器部署

提供檢查清單以當做 Team Foundation Server 單一伺服器部署期間的方便參考。

安裝 Team Foundation Server

針對如何在一台伺服器上安裝和設定 Team Foundation Server 及其必要條件提供詳細指示。

相關章節

Team Foundation 系統需求

提供安裝 Team Foundation Server 這個版本的硬體和軟體系統需求。

Team Foundation Server 安裝程式安全性概觀

提供安裝 Team Foundation Server 的安全性相關資訊。

Team Foundation Server 雙重伺服器部署概觀

請使用本節中的程序，在兩部電腦上安裝和設定 Team Foundation Server：一部用於資料層元件，而另一部用於應用程式層元件。

Team Foundation Build 安裝概觀

請使用本節中的程序來安裝和設定 Team Foundation Build，以便提供組建 Automation 來協助您建置並共用 Visual Studio 2005 方案。

Team 總管安裝概觀

請使用本節中的程序來安裝和設定 Team 總管。

請參閱

概念

Team Foundation 安裝


檢查清單：Team Foundation Server 單一伺服器部署

檢查清單：Team Foundation Server 單一伺服器部署
全部折疊影像 下拉影像

這份檢查清單是部署單一伺服器 Team Foundation Server 時很有用的參考資料。您應該列印這份檢查清單，並在完成每個步驟後加以標示。

展開影像 單一伺服器部署檢查清單

這份檢查清單大略說明了用單一伺服器部署 Team Foundation Server 時的安裝步驟，且每個步驟都有相關詳細說明的連結。Team Foundation 的單一伺服器部署會將資料和應用程式層放置在相同的電腦上。等 Team Foundation Server 安裝好之後，您可以分別安裝 Team Foundation Build 與 Team 總管。

完成 步驟

下載本指南的最新版本，可從 Microsoft 下載中心 (http://go.microsoft.com/fwlink/?LinkId=40042) 下載。

驗證硬體和軟體需求。如需詳細資訊，請參閱 Team Foundation 系統需求。

找出要用來執行安裝程式的使用者帳戶，並將帳戶加入本機的 [Administrators] 群組。這個帳戶通常會是您的使用者帳戶。在本指南中，這個帳戶是指 Domain\TFSSETUP。如需詳細資訊，請參閱設定 Team Foundation Server 所需的使用者帳戶。

取得能提供 Team Foundation Server 所使用服務之間通訊功能的兩個服務帳戶。

  • 用於執行 Team Foundation 服務的使用者帳戶 (例如，Domain\TFSSERVICE)。

  • 用於存取 SQL Server Reporting Services 資料來源的帳戶 (例如，Domain\TFSREPORTS)。

如需詳細資訊，請參閱設定 Team Foundation Server 所需的使用者帳戶。

安裝 Internet Information Services (IIS) 6.0。啟用 ASP.NET，並重新啟動電腦。

警告事項 警告

請勿安裝 FrontPage Server 2002 Extensions。

如需詳細資訊，請參閱 HOW TO：為 Team Foundation Server 安裝 網際網路資訊服務。

安裝 Microsoft SQL Server 2005 Standard 或 Enterprise Edition，當做這個電腦上預設的 SQL Server 執行個體 (MSSQLSERVER)。請用 Local System 作為服務帳戶。同時請安裝這個安裝主題最後列出的 Hotfix。

如需詳細資訊，請參閱 HOW TO：為 Team Foundation Server (單一伺服器部署) 安裝 Microsoft SQL Server 2005。

依照 HOW TO：驗證 Microsoft SQL Server 2005 安裝 或《SQL Server 線上叢書》中＜HOW TO：驗證 SQL Server 2005 Services 的成功安裝＞(http://go.microsoft.com/fwlink/?linkid=60404) 所敘述的步驟，檢查您的 Microsoft SQL Server 2005 安裝是否正確。

警告事項 警告

此時請勿執行 Reporting Services 組態工具。

安裝 Team Foundation Server 安裝媒體上提供之 Microsoft .NET Framework 2.0 的 Hotfix KB913393。

在安裝媒體上，先找出存放此 hotfix 的 KB913393 資料夾，然後找出適合您平台 (X86) 的執行檔 (.exe)，接著按兩下這個檔案就可以開始安裝。

安裝 Windows SharePoint Services (加上 Service Pack 2) 與 Team Foundation Server 搭配使用，然後重新啟動電腦。

警告事項 警告

此時請勿變更 Windows SharePoint Services。Team Foundation Server 安裝程式會幫您設定 Windows SharePoint Services 的組態。

如需詳細資訊，請參閱 HOW TO：為 Team Foundation Server (單一伺服器部署) 安裝 Microsoft Windows SharePoint Services。

確認適當的通訊埠都已開啟。

如果有使用 Windows 防火牆或協力廠商的防火牆軟體或硬體方案，應該確定開啟必要的通訊埠，以允許元件之間彼此通訊。如需詳細資訊，請參閱設定 Team Foundation Server 所需的連接埠。

安裝 Team Foundation Server。如需詳細資訊，請參閱 HOW TO：安裝 Team Foundation Server。

若要將使用者加入 Team Foundation Administration 群組，請將 Team 總管安裝在本機或另一台電腦上。如需詳細資訊，請參閱 Team 總管安裝概觀。

Expand image 請參閱

其他資源

Team Foundation Server 單一伺服器部署
Team Foundation Build 安裝概觀
Team Foundation Server Proxy 安裝概觀


安裝 Team Foundation Server

安裝 Team Foundation Server
DropDown image

請使用本節中的程序，使用同時安裝了資料層和應用程式層元件的單一電腦安裝和設定 Team Foundation Server 及其必要條件。

在本節中

HOW TO：為 Team Foundation Server 安裝 網際網路資訊服務

描述如何安裝及設定 Internet Information Services (IIS) 6.0。

HOW TO：為 Team Foundation Server (單一伺服器部署) 安裝 Microsoft SQL Server 2005

描述如何為 Team Foundation Server 安裝及設定 SQL Server 2005。

HOW TO：為 Team Foundation Server (單一伺服器部署) 安裝 Microsoft Windows SharePoint Services

描述如何為 Team Foundation Server 安裝及設定 Windows SharePoint Services。

HOW TO：安裝 Team Foundation Server

描述如何安裝及設定 Team Foundation Server 的資料層和應用程式層元件。

請參閱

其他資源

Team Foundation Server 單一伺服器部署


HOW TO：為 Team Foundation Server 安裝 網際網路資訊服務

HOW TO：為 Team Foundation Server 安裝 網際網路資訊服務

請使用這個程序為 Team Foundation Server 安裝及設定 Internet Information Services (IIS) 6.0。

若要使用設定您的伺服器精靈安裝 IIS

  1. 請透過執行下列其中一項動作，啟動 [設定您的伺服器精靈]：

    • 根據預設，當 Windows 啟動時，[管理您的伺服器] 就會自動啟動。在 [管理您的伺服器] 中，按一下 [新增或移除角色]。

    • 在 [控制台] 中，開啟 [系統管理工具]，然後開啟 [設定您的伺服器精靈]。

  2. 在 [歡迎使用設定您的伺服器精靈] 頁面中，按 [下一步]。

  3. 在 [預備步驟] 頁面上，按 [下一步]。

  4. 在 [伺服器角色] 頁面上，按一下 [應用程式伺服器 (IIS，ASP.NET)]，然後按 [下一步]。

  5. 在 [應用程式伺服器選項] 頁面上，選取 [啟用 ASP.NET]，然後按 [下一步]。

    注意事項 重要資訊

    請勿選取 [FrontPage Server Extensions]。這個伺服器將會裝載 Windows SharePoint Services (與 FrontPage Server Extensions 不相容)。

  6. 在 [選取摘要報告] 頁面中，按 [下一步]。

    注意事項 注意事項

    您可能會收到放入 Windows Server 2003 安裝媒體的提示。

  7. 按一下 [完成] 以關閉精靈。

  8. 請造訪 Windows Update (http://windowsupdate.microsoft.com) 並安裝重大更新和 Service Pack 群組中的所有項目。

若要使用新增或移除程式公用程式安裝 IIS

  1. 在 [控制台] 中，開啟 [新增或移除程式]。

  2. 按一下 [新增/移除 Windows 元件]。

    [Windows 元件精靈] 隨即啟動。

  3. 在 [Windows 元件] 頁面中，選取 [應用程式伺服器]，然後按一下 [詳細資料]。

  4. 如果尚未核取，請選取 [ASP.NET]，然後按一下 [確定]。

    注意事項 重要資訊

    如果您選取 [Internet Information Services (IIS)]，然後按一下 [詳細資料]，則不要選取 [FrontPage 2002 Server Extensions]。這個伺服器將會裝載 Windows SharePoint Services (與 FrontPage Server Extensions 不相容)。

  5. 在 [Windows 元件] 頁面中，按 [下一步]。

    注意事項 注意事項

    您可能會收到放入 Windows Server 2003 安裝媒體的提示。

  6. 按一下 [完成] 關閉精靈。

  7. 請造訪 Windows Update (http://windowsupdate.microsoft.com) 並安裝重大更新和 Service Pack 群組中的所有項目。

安全性

您必須是電腦上 [Administrators] 安全性群組的成員，才能執行此程序。本手冊中用來進行安裝的使用者帳戶稱為 Domain\TFSSETUP。如果您使用相同的帳戶安裝 Team Foundation Server，則此帳戶會在安裝期間自動加入至 [Team Foundation Administrators] 安全性群組。如需詳細資訊，請參閱設定 Team Foundation Server 所需的使用者帳戶。

請參閱

其他資源

安裝 Team Foundation Server


HOW TO：為 Team Foundation Server (單一伺服器部署) 安裝 Microsoft SQL Server 2005

HOW TO：為 Team Foundation Server (單一伺服器部署) 安裝 Microsoft SQL Server 2005
請參閱

請使用這個程序，使用安裝精靈以互動方式或是使用回應檔案，為 Team Foundation Server 安裝及設定 Microsoft SQL Server 2005Standard 或 Enterprise Edition。Team Foundation Server 包含 Microsoft SQL Server 2005 Standard Edition 的授權版本。同時您也必須安裝在這個主題最後列出的 Hotfix。

注意事項 注意事項

在安裝 Microsoft SQL Server 2005 之前必須先安裝 Internet Information Services (IIS) 6.0。

自動安裝 Microsoft SQL Server 2005

您可以在命令列使用提供的回應檔案安裝 Microsoft SQL Server 2005。這個回應檔案會自動化安裝程式，以安裝和設定用於 Team Foundation Server 的 Microsoft SQL Server 2005。

警告事項 警告

根據預設，Microsoft SQL Server 會根據作業系統的語言設定，指定定序設定。如需定序設定的詳細資訊，請參閱《SQL Server 2005 線上叢書》中的＜安裝程式中的定序設定＞。

若要使用回應檔案安裝 Microsoft SQL Server 2005

  1. 使用 Team Foundation Server 設定帳戶 (例如，Domain\TFSSETUP) 登入 Windows。

  2. 在 Team Foundation Server 安裝媒體上找出預先設定的自動回應檔案 (SQL2005ForATDT.ini)，並將其複製到本機硬碟 (例如 C:\) 上方便尋找的位置。

  3. 使用下列命令列，執行 Microsoft SQL Server 2005 的安裝程式：

    C:\>SQLServerSetupDirectory\setup.exe /qb /settings AnswerFileDirectory\SQL2005ForATDT.ini PIDKEY=ProductKey

    其中 SQLServerSetupDirectory 是 Microsoft SQL Server 2005 setup.exe 的路徑、AnswerFileDirectory 是回應檔的路徑，而 ProductKey 是 Microsoft SQL Server 2005 的產品金鑰 (不含短破折或空格)。

    注意事項 注意事項

    若要驗證安裝，請參閱 HOW TO：驗證 Microsoft SQL Server 2005 安裝。

以互動方式安裝 Microsoft SQL Server 2005

Team Foundation Server 包含 Microsoft SQL Server 2005 Standard Edition 的授權副本。

注意事項 注意事項

在安裝 Microsoft SQL Server 2005 之前必須先安裝 Internet Information Services (IIS) 6.0。

若要以互動方式安裝 Microsoft SQL Server 2005

  1. 使用 Team Foundation Server 設定帳戶 (例如，Domain\TFSSETUP) 登入 Windows。

  2. 放入 Microsoft SQL Server 2005 的光碟片，然後在 [SQL Server 2005 起始] 頁的 [安裝] 下，按一下 [伺服器元件、工具、線上叢書和範例]。

    注意事項 注意事項

    Microsoft SQL Server 2005 Standard Edition 的光碟片會隨 Team Foundation Server 提供。若要安裝 SQL Server Enterprise，您可以使用另外購買之軟體的光碟片。從安裝媒體的 Servers 資料夾中執行 Splash.hta 檔，便會顯示 [起始頁]。

    Microsoft SQL Server 2005 安裝精靈便會啟動。

  3. 在 [使用者授權合約] 頁面中，檢閱授權合約。如果您接受這些條款和條件，請選取 [我接受授權條款和條件]，然後按 [下一步]。

  4. 在 [安裝必要條件] 頁面上，按一下 [安裝]。必要的元件都安裝成功後，請按 [下一步]。

    [Microsoft SQL Server 安裝精靈] 隨即啟動。

  5. 按 [下一步] 啟動 [系統組態檢查]。

  6. 在 [系統組態檢查] 頁面中，檢查任何所需動作的狀態 (例如，所需的系統重新啟動)，然後遵循此頁面上的指引進行，直到所有動作都達到 [成功] 狀態為止。在所有動作都達到 [成功] 狀態後，按 [下一步] 啟動安裝。

    注意事項 注意事項

    安裝程式可能需要數分鐘才會啟動。

  7. 在 [註冊資訊] 頁面中，完成註冊資訊，然後按 [下一步]。

  8. 在 [要安裝的元件] 頁面上選取下列元件，然後按一下 [進階]。

    • SQL Server Database Services

    • Analysis Services

    • Reporting Services

    • Integration Services

    • 工作站元件、線上叢書及開發工具

      注意事項 注意事項

      Team Foundation Server 不需要 Notification Services。

  9. 在 [功能選擇] 頁面上，展開下列節點並指定下列選項。

    注意事項 注意事項

    除了以下標註的項目外，您不應該變更任何其他功能範圍中的預設選項。

    1. 在 [Database Services] 下，按一下 [複寫] 的圖示，然後選取 [整個功能將無法使用]。

      注意事項 秘訣

      若要最佳化系統效能，請選取 [資料檔]，然後按一下 [瀏覽] 以在不同的實體硬碟上指定檔案位置。根據預設，SQL Server 2005 會將所有檔案安裝到系統磁碟機。您也可以為 [Analysis Services] 下的 [資料檔] 指定其他位置。

    2. 在 [用戶端元件] 下，唯一要安裝的必要功能是 [管理工具]。對於 [用戶端元件] 下的所有其他項目，可以選擇性地按一下圖示，並選取 [整個功能將無法使用]。

    3. 在 [文件集、範例和範例資料庫] 下，可以選擇性地按一下 [SQL Server 線上叢書] 的圖示，然後選取 [整個功能將無法使用]。按 [下一步]。

  10. 在 [執行個體名稱] 頁面中，選取 [預設的執行個體]，然後按 [下一步]。

    注意事項 重要資訊

    如果您指定具名執行個體，Team Foundation Server 安裝程式將會失敗。

  11. 在 [服務帳戶] 頁面上，選取 [使用內建的系統帳戶]，並從清單選取 [本機系統]。在 [在安裝程式結束時啟動服務] 中，選取所有服務：[SQL Server]、[SQL Server Agent]、[Analysis Services]、[Reporting Services] 和 [SQL Browser]，然後按 [下一步]。

    注意事項 注意事項

    此服務帳戶用於 Microsoft SQL Server 2005，且應避免與開始安裝之前取得的兩個系統帳戶混淆。

  12. 在 [驗證模式] 頁面中，選取 [Windows 驗證模式]，然後按 [下一步]。

  13. 在 [定序設定] 頁面上，選取適合您語言的定序，然後按 [下一步]。

    注意事項 注意事項

    如果您變更 [定序指示項和排序順序]，則必須選取 [區分腔調字]。

    預設選項是以 Windows Server 2003 中非 Unicode 語言的設定為基礎。大部分語言的預設值都是 Windows 定序，不過，SQL Server 2005 針對 U.S. English 安裝了 SQL Server 定序，以便支援回溯相容性。如果您要變更預設的定序，以支援額外的 U.S. English 字元集，請考慮使用 [Latin1_General]。

    至於其他語言，請考慮 "_90" Windows 定序 (如果有的話)，否則請使用另一種 Windows 定序。

    例如，若要進行日文部署而不使用預設定序，而您使用 Unicode CJK Extension A 字元集或 Unicode Surrogates，請使用 [Japanese_90] 定序，如下所述。

    • Team Foundation Server 物件名稱，例如查詢或專案。

    • 簽入版本控制系統的檔案或路徑。

    • 用於搜尋的任何工作項目欄位。

    為避免發生全形或平假名/片假名這類字元的問題，請在安裝期間選取啟用區分假名和區分全半形的核取方塊。

    Team Foundation Server 不支援下列定序：

    • 不區分腔調字

    • 二進位

    • Binary2

    • 區分大小寫

    如需定序設定的詳細資訊，請參閱《SQL Server 2005 線上叢書》中的＜安裝程式中的定序設定＞。

  14. 在 [報表伺服器安裝選項] 頁面上，選取 [安裝預設組態]，然後按 [下一步]。

  15. 在 [錯誤和使用方式報表設定] 頁面上，可選擇性地選取 [自動將 SQL Server 2005 的錯誤報告傳送至 Microsoft 或您的 Corporate Error Reporting 伺服器] 和 [自動將 SQL Server 2005 的功能使用方式資料傳送至 Microsoft]，然後按 [下一步]。

  16. 在 [已完成安裝準備工作] 頁面中，您可以檢閱即將安裝的元件清單，然後按一下 [安裝]。

  17. 在 [安裝進度] 頁面中，您可以監視每個元件的安裝狀態。完成安裝程式後，請按 [下一步]。

    注意事項 注意事項

    在 SQL Server Reporting Services 啟動過程中，安裝程式可能會停止回應幾分鐘。

  18. 按一下 [完成] 結束精靈。

    注意事項 注意事項

    若要在安裝 Windows SharePoint Services 之前驗證安裝，請參閱 HOW TO：驗證 Microsoft SQL Server 2005 安裝。

安裝 Microsoft SQL Server 2005 Hotfix

安裝 Microsoft SQL Server 2005 之後，必須安裝會更新 SQL Server Analysis Services 的 Hotfix，以便更有效地支援報告。

注意事項 注意事項

如需最新的更新，請造訪 Microsoft 網站 (http://go.microsoft.com/fwlink/?LinkId=62015)。

若要安裝 Microsoft SQL Server 2005 Hotfix

  1. 在資料層電腦上，開啟 [SQL Server 組態管理員]，以滑鼠右鍵按一下 [SQL Server Browser 服務]，然後按一下 [停止]。

  2. 在 Team Foundation Server 安裝媒體上，尋找 SQLServerKB 資料夾。

  3. 尋找適用於您作業系統和語言的可執行檔 (.exe)，例如 AS2005-KBnnnnnn-x86-ENU.exe，然後按兩下該檔案啟動 Hotfix 安裝程式。

  4. 在 [Hotfix 安裝程式] 中，接受 [使用者授權合約]，完成頁面以安裝 Hotfix，然後按一下 [完成]。

  5. 在 [SQL Server 組態管理員] 中，用滑鼠右鍵按一下 [SQL Server Browser 服務]，再按一下 [屬性]。

  6. 在 [服務] 索引標籤上，尋找 [啟動模式]，然後選取 [自動]。

  7. 在 [登入] 索引標籤上，按一下 [啟動]。

    注意事項 注意事項

    如果 [登入] 索引標籤中的 [啟動] 未啟用，按一下 [服務] 索引標籤，將 [啟動模式] 設為 [停用]，然後再選取 [自動] 確實地更新 [啟動模式]。

若要在安裝 Windows SharePoint Services 之前驗證安裝，請參閱 HOW TO：驗證 Microsoft SQL Server 2005 安裝。

安全性

您必須是電腦上 [Administrators] 安全性群組的成員，才能執行此程序。本手冊中用來進行安裝的使用者帳戶稱為 Domain\TFSSETUP。如果您使用相同的帳戶安裝 Team Foundation Server，則此帳戶會在安裝期間自動加入至 [Team Foundation Administrators] 安全性群組。如需詳細資訊，請參閱設定 Team Foundation Server 所需的使用者帳戶。

請參閱

其他資源

安裝 Team Foundation Server


HOW TO：為 Team Foundation Server (單一伺服器部署) 安裝 Microsoft Windows SharePoint Services

HOW TO：為 Team Foundation Server (單一伺服器部署) 安裝 Microsoft Windows SharePoint Services
請參閱

請依照以下步驟，使用安裝精靈以互動方式或是從命令列以無訊息模式，為 Team Foundation Server 安裝 Microsoft Windows SharePoint Services (加上 Service Pack 2)。

在 Windows SharePoint Services 的當地語系化版本上安裝 Team Foundation Server 之前，必須先安裝符合您想安裝之 Team Foundation Server 語言的 Windows SharePoint Services 語言套件。例如安裝英文版的 Team Foundation Server 之前，必須先安裝英文版的 Windows SharePoint Services 語言套件才行。

注意事項 重要資訊

Windows SharePoint Services 需要 NTFS 檔案系統。

以無訊息模式安裝 Microsoft Windows SharePoint Services

您可以在命令列以無訊息模式安裝 Windows SharePoint Services。

若要以無訊息模式安裝 Windows SharePoint Services

  1. 使用 Team Foundation Server 設定帳戶 (例如，Domain\TFSSETUP) 登入 Windows。

  2. 下載 Microsoft Windows SharePoint Services 2.0 (加上 Service Pack 2)(http://go.microsoft.com/fwlink/?linkid=55087)，並將檔案儲存到本機硬碟上的方便位置。

  3. 使用下列命令列執行下載的自解壓縮安裝程式檔案 (stsv2.exe)：

    C:\>DownloadDirectory\STSV2.EXE /C:"setupsts.exe /remoteSql=yes /provision=no /q"

    其中 DownloadDirectory 是硬碟上儲存下載檔案的位置路徑。

    注意事項 重要資訊

    您必須使用 /remoteSql=yes 選項安裝 Windows SharePoint Services。這會將 Windows SharePoint Services 設定為使用遠端 SQL Server。/provision=no 選項會將 Windows SharePoint Services 的組態設定步驟延後執行。稍後，Team Foundation Server 安裝程式會將 Windows SharePoint Services 設定為與 Team Foundation Server 其他部分使用相同的 SQL Server 執行個體。

    您不會看到安裝完成的訊息。在繼續之前，請等候數分鐘讓安裝完成。

  4. 請造訪 Windows Update (http://windowsupdate.microsoft.com) 並安裝重大更新和 Service Pack 群組中的所有項目。

  5. 重新啟動電腦。

以互動方式安裝 Microsoft Windows SharePoint Services

安裝 Microsoft Windows SharePoint Services (加上 Service Pack 2)。

若要以互動方式安裝 Windows SharePoint Services

  1. 使用 Team Foundation Server 設定帳戶 (例如，Domain\TFSSETUP) 登入 Windows。

  2. 下載 Microsoft Windows SharePoint Services (加上 Service Pack 2)(http://go.microsoft.com/fwlink/?linkid=55087)，並將檔案儲存到本機硬碟。

  3. 執行下載的自解壓縮安裝程式檔案 (stsv2.exe)。

  4. 在 [使用者授權合約] 頁面中，檢閱授權合約。如果您接受這些條款和條件，請選取 [我接受授權合約]，然後按 [下一步]。

  5. 在 [安裝類型] 頁面上選取 [伺服器陣列]，然後按 [下一步]。

    注意事項 重要資訊

    您必須使用 [伺服器陣列] 選項安裝 Windows SharePoint Services。這會將 Windows SharePoint Services 設定為使用遠端 SQL Server。然後，Team Foundation Server 安裝程式會將 Windows SharePoint Services 設定為與 Team Foundation Server 其他部分使用相同的 SQL Server 執行個體。

  6. 在 [摘要] 頁面中按一下 [安裝]。

    當安裝完成時，Web 瀏覽器視窗會開啟並顯示 [設定管理虛擬伺服器] 頁面。在確認該頁面出現後，關閉瀏覽器視窗而不進行任何變更。

    注意事項 重要資訊

    不要在出現的頁面上進行任何變更。稍後，Team Foundation Server 安裝程式會將 Windows SharePoint Services 設定為與 Team Foundation Server 其他部分使用相同的 SQL Server 執行個體。

    如果該頁面沒有出現，則應該判斷原因，並使用＜Windows SharePoint Services 系統管理員手冊＞(英文)(http://go.microsoft.com/fwlink/?LinkId=52668)。

  7. 請造訪 Windows Update (http://windowsupdate.microsoft.com) 並安裝重大更新和 Service Pack 群組中的所有項目。

  8. 重新啟動電腦。

驗證安裝

安裝好 Windows SharePoint Server 後，即使尚未安裝 Team Foundation Server，您也可以確定這些服務都正在執行中。

若要驗證 Windows SharePoint Services 已安裝

  • 開啟 Internet Explorer 並輸入伺服器名稱做為位址。

    例如，若伺服器名稱為 ADATUM，則輸入 Http://adatum。

    雖然站台尚未設定好，但這台伺服器已經是使用中的 Web 伺服器，因此仍然會傳回 [建構中] 頁面。

安全性

您必須是電腦上 [Administrators] 安全性群組的成員，才能執行此程序。本手冊中用來進行安裝的使用者帳戶稱為 Domain\TFSSETUP。如果您使用相同的帳戶安裝 Team Foundation Server，則此帳戶會在安裝期間自動加入至 [Team Foundation Administrators] 安全性群組。如需詳細資訊，請參閱設定 Team Foundation Server 所需的使用者帳戶。

請參閱

其他資源

安裝 Team Foundation Server


HOW TO：安裝 Team Foundation Server

HOW TO：安裝 Team Foundation Server

請使用這個程序安裝 Team Foundation Server。

在您安裝 Team Foundation Server 之前，請先確定 Microsoft SQL Server 2005 Standard 或 Enterprise Edition 已經安裝好並啟動執行。完成所有資料層的必要條件。如需詳細資訊，請參閱檢查清單：Team Foundation Server 單一伺服器部署。

若要安裝 Team Foundation Server

  1. 使用 Team Foundation Server 設定帳戶 (例如，Domain\TFSSETUP) 登入 Windows。

  2. 放入 CD，在顯示出來的自動執行頁面上，按一下 [安裝 Team Foundation Server]，然後再按一下 [單一伺服器安裝]。

    如果自動執行頁面並未顯示，請在安裝媒體的根資料夾中找出自動執行檔 (autorun.exe) 並執行。

    Visual Studio Team Foundation Server 安裝精靈隨即啟動。

  3. 在 [歡迎使用安裝程式] 頁面中，按 [下一步]。

  4. 檢閱 [授權條款] 頁面上的條款。如果您接受這些條款和條件，請選取 [我接受授權合約]，然後按 [下一步]。

    安裝精靈會進行掃描，找出可能會導致安裝失敗或未來伺服器運作出問題的狀況。

  5. 在 [目的資料夾] 頁面中，接受預設目的資料夾，然後按 [下一步]。

  6. 在 [系統健康檢查] 頁面上，按一下 [報告] 連結檢查所有警告或阻礙情形。

    • 開始安裝之前，一定要先把阻礙情形排除。按一下 [取消]，並在修正所有問題之後再次執行安裝程式。

    • 雖然您應該先把警告處理好之後再繼續進行安裝，不過警告應該不會阻礙安裝程式完成。您可以按 [下一步]。

    • 如果未列出任何項目，請按 [下一步]。

  7. 在 [服務帳戶] 頁面中，於 [帳戶名稱] 方塊中輸入您為 Team Foundation Server 服務帳戶 (例如，Domain\TFSSERVICE) 建立的 Windows 網域使用者帳戶、於 [密碼] 方塊中輸入密碼，然後按 [下一步]。如需詳細資訊，請參閱設定 Team Foundation Server 所需的使用者帳戶。

  8. 在 [報告資料來源帳戶] 頁面上，輸入 Team Foundation Server 報告帳戶的帳戶資訊，然後按 [下一步]。

    注意事項 注意事項

    這個帳戶應該與 Team Foundation Server 安裝或服務帳戶不同。例如，請使用 Domain\TFSREPORTS。

  9. 在 [指定警示設定] 頁面上，選取 [啓用 Team Foundation 警示]，然後輸入下列資訊：

    • 在 [SMTP 伺服器] 方塊中，輸入要用來傳送電子郵件通知的伺服器名稱。

    • 在 [寄件者電子郵件地址] 方塊中，輸入發出通知的電子郵件地址名稱，然後按 [下一步]。

  10. 在 [已完成安裝準備工作] 頁面中，按一下 [安裝]。

  11. 在 [安裝元件] 頁面上可以監視 Team Foundation Server 的安裝。

    進行安裝時，系統會提示您重新啟動電腦。按一下 [立即重新啟動]，安裝程式會在電腦重新啟動而您再次登入後繼續。

  12. 在 [安裝成功] 頁面上，確認安裝完成後，按一下 [完成]。

    安裝 Team Foundation Server 之後，您應該使用 [Reporting Services 組態工具] 將 Reporting Services 加密金鑰備份。這個步驟雖然不是建立 Team 專案所必須的，但卻是管理 Team Foundation Server 最佳作法的一部分。如需詳細資訊，請參閱《Team Foundation Server 管理員手冊》中的＜HOW TO：備份 Reporting Services 加密金鑰＞(http://go.microsoft.com/fwlink/?LinkID=52459)。

  13. 在 Internet Explorer 中，尋找 http://localhost:8080/services/v1.0/Registration.asmx，然後按一下 [GetRegistrationEntries]。

  14. 在 [GetRegistrationEntries] 頁面中按一下 [叫用]。您不需要輸入 ToolID。

    注意事項 注意事項

    您必須位於應用程式層電腦上，才能使用此 Web 方法。

  15. 在 XML 中，確認 VSTF 型別存在，接著將其關閉。

    <?xml version="1.0" encoding="utf-8" ?>

    <Type>vstfs</Type>

    注意事項 注意事項

    Team Foundation Server 安裝好之後，接著可以考慮繼續安裝 Team 總管、Team Foundation Build 或 Team Foundation Server Proxy。

安全性

您必須是電腦上 [Administrators] 安全性群組的成員，才能執行此程序。本手冊中用來進行安裝的使用者帳戶稱為 Domain\TFSSETUP。如果您使用相同的帳戶安裝 Team Foundation Server，則此帳戶會在安裝期間自動加入至 [Team Foundation Administrators] 安全性群組。如需詳細資訊，請參閱設定 Team Foundation Server 所需的使用者帳戶。

請參閱

其他資源

安裝 Team Foundation Server
Team Foundation Build 安裝概觀
Team Foundation Server Proxy 安裝概觀


Team Foundation Server 雙重伺服器部署概觀

Team Foundation Server 雙重伺服器部署概觀
DropDown image

請使用本節中的程序，在兩部電腦上安裝和設定 Team Foundation Server：一部用於資料層元件，而另一部用於應用程式層元件。

在本節中

檢查清單：Team Foundation Server 雙重伺服器部署

提供檢查清單，方便您在 Team Foundation Server 雙重伺服器部署期間參考。

安裝 Team Foundation Server (資料庫)

針對如何在與應用程式層元件分開的伺服器上安裝和設定 Team Foundation Server 資料層元件及其必要條件，提供詳細的指示。

安裝 Team Foundation Server (服務)

針對如何在與資料層元件分開的伺服器上安裝和設定 Team Foundation Server 應用程式層元件及其必要條件，提供詳細的指示。

保持伺服器連續運轉

提供將電腦加入 Team Foundation，並設定讓電腦接管資料層或應用程式層服務的詳細說明。

相關章節

Team Foundation 系統需求

提供安裝 Team Foundation Server 這個版本的硬體和軟體系統需求。

Team Foundation Server 安裝程式安全性概觀

提供安裝 Team Foundation Server 的安全性相關資訊。

Team Foundation Server 單一伺服器部署

請使用本節中的程序，在一部伺服器上安裝和設定 Team Foundation Server。

Team Foundation Build 安裝概觀

請使用本節中的程序來安裝和設定 Team Foundation Build，以便提供組建 Automation 來協助您建置並共用 Visual Studio 2005 方案。

Team Foundation Server Proxy 安裝概觀

請使用本節中的程序來安裝 Team Foundation Server Proxy，以便快取之前存取的原始檔控制檔案。

Team 總管安裝概觀

請使用本節中的程序來安裝和設定 Team 總管。

請參閱

概念

Team Foundation 安裝


檢查清單：Team Foundation Server 雙重伺服器部署

檢查清單：Team Foundation Server 雙重伺服器部署
全部折疊影像 下拉影像

這份檢查清單是部署雙重伺服器 Team Foundation Server 時很有用的參考資料。這份檢查清單大略說明了用雙重伺服器部署 Team Foundation Server 時的安裝步驟，且每個步驟都有相關詳細說明的連結。Team Foundation Server 的雙重伺服器部署會將資料層和應用程式層放置在不同的電腦上。您應該列印這份檢查清單，並在完成每個步驟後加以標示。

展開影像 準備作業

安裝 Team Foundation Server 之前，您需要具備下列項目。

完成 步驟

下載本指南的最新版本，可從 Microsoft 下載中心 (http://go.microsoft.com/fwlink/?LinkId=40042) 下載。

驗證硬體和軟體需求。如需詳細資訊，請參閱 Team Foundation 系統需求。

決定執行安裝時要使用的使用者帳戶。這個帳戶通常會是您的使用者帳戶。在本指南中，這個帳戶是指 Domain\TFSSETUP。

取得能提供 Team Foundation Server 所使用服務之間通訊功能的兩個服務帳戶。

  • 用於執行 Team Foundation 服務的使用者帳戶 (例如，Domain\TFSSERVICE)。

  • 用於存取 SQL Server Reporting Services 資料來源的帳戶 (例如，Domain\TFSREPORTS)。

如需這些帳戶需求的詳細資訊，請參閱設定 Team Foundation Server 所需的使用者帳戶。

展開影像 Team Foundation Server 安裝 (資料庫)

完成 | 步驟
 | 在資料層電腦上，將執行 Team Foundation Server 安裝程式的帳戶 (例如，Domain\TFSSETUP) 加入至本機 Administrators 群組。
 | 在資料層電腦上，將 Microsoft SQL Server 2005 Standard 或 Enterprise Edition 安裝到其預設的 SQL Server 執行個體 (Instance) 上。請用 Local System 作為服務帳戶。同時請安裝這個安裝主題最後列出的 Hotfix。 如需詳細資訊，請參閱 HOW TO：為 Team Foundation Server (雙重伺服器部署) 安裝 Microsoft SQL Server 2005。
 | 依照 HOW TO：驗證 Microsoft SQL Server 2005 安裝 或《SQL Server 線上叢書》中＜HOW TO：驗證 SQL Server 2005 Services 的成功安裝＞ (http://go.microsoft.com/fwlink/?linkid=60404) 所敘述的步驟，檢查您的 Microsoft SQL Server 2005 安裝是否正確。
 | 檢查資料層電腦上適當的通訊埠是否已經開放。 如果有使用 Windows 防火牆或協力廠商的防火牆軟體或硬體方案，您應該確定已開啟必要的通訊埠，以允許元件之間彼此通訊。如需詳細資訊，請參閱設定 Team Foundation Server 所需的連接埠。
 | 在資料層電腦上安裝 Team Foundation Server (資料庫)。如需詳細資訊，請參閱 HOW TO：安裝 Team Foundation Server (資料庫)。

展開影像 Team Foundation Server 安裝 (服務)

完成 步驟

在應用程式層電腦上，將執行 Team Foundation Server 安裝程式的帳戶 (例如，Domain\TFSSETUP) 加入至本機 Administrators 群組。

在應用程式層電腦上，安裝 Internet Information Services (IIS) 6.0。啟用 ASP.NET。

警告事項 警告

請勿安裝 FrontPage Server 2002 Extensions。

如需詳細資訊，請參閱 HOW TO：安裝 Team Foundation Server (服務) 的網際網路資訊服務。

在應用程式層電腦上，安裝搭配 Team Foundation Server 使用的 SQL Server 2005 Reporting Services (使用 Microsoft SQL Server 2005 Standard 或 Enterprise Edition)。

警告事項 警告

此時請勿執行 Reporting Services 組態工具。

在應用程式層電腦上安裝 Microsoft .NET Framework 2.0 的 hotfix KB913393，Team Foundation Server 安裝媒體上附有這個 hotfix。

在安裝媒體上，先找出 KB913393 資料夾，然後找出適合您平台 (X86) 的執行檔 (.exe)，接著按兩下這個檔案就可以開始安裝。

在應用程式層電腦上，安裝搭配 Team Foundation Server 使用的 Windows SharePoint Services (加上 Service Pack 2)，然後將此電腦重新啟動。

警告事項 警告

此時請勿變更 Windows SharePoint Services。Team Foundation Server (服務) 安裝程式會幫您設定 Windows SharePoint Services 的組態。如需詳細資訊，請參閱 HOW TO：為 Team Foundation Server (雙重伺服器部署) 安裝 Microsoft Windows SharePoint Services。

在應用程式層電腦上安裝 Team Foundation Server (服務)。如需詳細資訊，請參閱 HOW TO：安裝 Team Foundation Server (服務)。

檢查應用程式層電腦上適當的通訊埠是否已經開放。

如果有使用 Windows 防火牆或協力廠商的防火牆軟體或硬體方案，您應該確定已開啟必要的通訊埠，以允許元件之間彼此通訊。如需詳細資訊，請參閱設定 Team Foundation Server 所需的連接埠。

在本機上或另一台電腦上安裝 Team 總管。如需詳細資訊，請參閱 Team 總管安裝概觀。

Expand image 請參閱

其他資源

Team Foundation Server 雙重伺服器部署概觀
Team Foundation Build 安裝概觀
Team Foundation Server Proxy 安裝概觀


安裝 Team Foundation Server (資料庫)

安裝 Team Foundation Server (資料庫)
請參閱
DropDown image

請使用本節中的程序，在與應用程式層元件分開的伺服器上安裝和設定 Team Foundation Server 資料層元件及其必要條件。

這些必要條件和元件包括：

元件 | 安裝順序
SQL Server 2005 | 第一 (Team Foundation Server 資料層元件的必要條件)
Team Foundation Server 資料層元件 | 第二

在本節中

HOW TO：為 Team Foundation Server (雙重伺服器部署) 安裝 Microsoft SQL Server 2005

描述如何在資料層上安裝 SQL Server 2005。

HOW TO：驗證 Microsoft SQL Server 2005 安裝

描述如何驗證資料層上安裝的 SQL Server 2005。

HOW TO：安裝 Team Foundation Server (資料庫)

描述如何安裝 Team Foundation Server 的資料層元件。

請參閱

其他資源

Team Foundation Server 雙重伺服器部署概觀
安裝 Team Foundation Server (服務)


HOW TO：為 Team Foundation Server (雙重伺服器部署) 安裝 Microsoft SQL Server 2005

HOW TO：為 Team Foundation Server (雙重伺服器部署) 安裝 Microsoft SQL Server 2005
請參閱

這個程序可以用來安裝並設定 Team Foundation Server 所需的 Microsoft SQL Server 2005 Standard 或 Enterprise Edition，您可以使用回應檔案自動進行，也可以透過安裝精靈用互動的方式進行。Team Foundation Server 包含 Microsoft SQL Server 2005 Standard Edition 的授權版本。同時您也必須安裝在這個主題最後列出的 Hotfix。

自動安裝 Microsoft SQL Server 2005

您可以在命令列使用提供的回應檔案安裝 Microsoft SQL Server 2005。這個回應檔案會自動化安裝程式，以安裝和設定用於 Team Foundation Server 的 Microsoft SQL Server 2005。

警告事項 警告

根據預設，Microsoft SQL Server 會根據作業系統的語言設定，指定定序設定。如需定序設定的詳細資訊，請參閱《SQL Server 2005 線上叢書》中的＜安裝程式中的定序設定＞。

若要使用回應檔案安裝 Microsoft SQL Server 2005

  1. 在資料層電腦上，使用 Team Foundation Server 設定帳戶 (例如，Domain\TFSSETUP) 登入。

  2. 在 Team Foundation Server 安裝媒體上找出預先設定的自動回應檔案 (SQL2005ForDT.ini)，並將其複製到本機硬碟 (例如 C:\) 上的方便位置。

  3. 使用下列命令列，執行 Microsoft SQL Server 2005 的安裝程式：

    C:\>SQLServerSetupDirectory\setup.exe /qb /settings AnswerFileDirectory\SQL2005ForDT.ini PIDKEY=ProductKey

    其中 SQLServerSetupDirectory 是 Microsoft SQL Server 2005 setup.exe 的路徑、AnswerFileDirectory 是回應檔的路徑，而 ProductKey 是 Microsoft SQL Server 2005 的產品金鑰 (不含短破折或空格)。

    注意 若要驗證安裝是否正確，請參閱 HOW TO：驗證 Microsoft SQL Server 2005 安裝。

安裝 Microsoft SQL Server 2005

安裝 Microsoft SQL Server 2005 Standard 或 Enterprise Edition

若要以互動方式安裝 Microsoft SQL Server 2005

  1. 在資料層電腦上，使用 Team Foundation Server 設定帳戶 (例如，Domain\TFSSETUP) 登入 Windows。

  2. 放入 Microsoft SQL Server 2005 的光碟片，然後在 [SQL Server 2005 起始] 頁的 [安裝] 下，按一下 [伺服器元件、工具、線上叢書和範例]。

    注意事項 注意事項

    Microsoft SQL Server 2005 Standard Edition 的光碟片會隨 Team Foundation Server 提供。若要安裝 Microsoft SQL Server 2005 Enterprise，您可以使用另外購買之軟體的光碟片。從安裝媒體的 Servers 資料夾中執行 Splash.hta 檔，便會顯示 [起始頁]。

    Microsoft SQL Server 2005 安裝精靈便會啟動。

  3. 在 [使用者授權合約] 頁面中，檢閱授權合約。如果您接受這些條款和條件，請選取 [我接受授權條款和條件]，然後按 [下一步]。

  4. 在 [安裝必要條件] 頁面上，按一下 [安裝]。必要的元件都安裝成功後，請按 [下一步]。

    [Microsoft SQL Server 安裝精靈] 隨即啟動。

  5. 按 [下一步] 啟動 [系統組態檢查]。

  6. 在 [系統組態檢查] 頁面中，檢查任何所需動作的狀態 (例如，所需的系統重新啟動)，然後遵循此頁面上的指引進行，直到所有動作都達到 [成功] 狀態為止。在 [IIS 功能需求] 以外的所有動作都達到 [成功] 狀態後，按 [下一步] 啟動安裝。

    注意事項 注意事項

    資料層電腦上並未安裝 SQL Server 2005 Reporting Services。您可以忽略 [IIS 功能需求] 的 [警告] 狀態。安裝程式可能需要一段時間才會開始。

  7. 在 [註冊資訊] 頁面中，完成註冊資訊，然後按 [下一步]。

  8. 在 [要安裝的元件] 頁面上選取下列元件，然後按一下 [進階]。

    • SQL Server Database Services

    • Analysis Services

    • Integration Services

    • 工作站元件、線上叢書及開發工具

      注意事項 注意事項

      Reporting Services 應安裝在應用程式層上。Team Foundation Server 不需要 Notification Services。

  9. 在 [功能選擇] 頁面上，展開下列節點並指定下列選項。

    注意事項 注意事項

    除了以下標註的項目外，您不應該變更任何其他功能範圍中的預設選項。

    1. 在 [Database Services] 下，按一下 [複寫] 的圖示，然後選取 [整個功能將無法使用]。

      注意事項 秘訣

      如果您想修改資料檔案的位置，請選取 [資料檔]，按一下 [瀏覽] 指定目錄或其他的實體硬碟。根據預設，SQL Server 2005 會將所有檔案安裝到系統磁碟機。改用其他位置，可以提高系統的效能。您也可以為 [Analysis Services] 下的 [資料檔] 指定其他位置。

    2. 在 [用戶端元件] 下，唯一要安裝的必要功能是 [管理工具]。對於 [用戶端元件] 下的所有其他項目，可以選擇性地按一下圖示，並選取 [整個功能將無法使用]。

    3. 在 [文件集、範例和範例資料庫] 下，可以選擇性地按一下 [SQL Server 線上叢書] 的圖示，然後選取 [整個功能將無法使用]。按 [下一步]。

  10. 在 [執行個體名稱] 頁面中，選取 [預設的執行個體]，然後按 [下一步]。

    注意事項 重要資訊

    如果您指定具名執行個體，Team Foundation Server 安裝程式將會失敗。

  11. 在 [服務帳戶] 頁面上，選取 [使用內建的系統帳戶]，並從清單選取 [本機系統]。在 [在安裝程式結束時啟動服務] 中，選取所有服務：[SQL Server]、[SQL Server Agent]、[Analysis Services] 和 [SQL Browser]，然後按 [下一步]。

    注意事項 注意事項

    這個服務帳戶是 Microsoft SQL Server 2005 專用的，請勿與開始安裝前取得的兩個服務帳戶混淆。

  12. 在 [驗證模式] 頁面中，選取 [Windows 驗證模式]，然後按 [下一步]。

  13. 在 [定序設定] 頁面上，選取適合您語言的定序，然後按 [下一步]。

    注意事項 注意事項

    如果您變更 [定序指示項和排序順序]，則必須選取 [區分腔調字]。

    預設選項是以 Windows Server 2003 中非 Unicode 語言的設定為基礎。大部分語言的預設值都是 Windows 定序，不過，SQL Server 2005 針對 U.S. English 安裝了 SQL Server 定序，以便支援回溯相容性。如果您要變更預設的定序，以支援額外的 U.S. English 字元集，請考慮使用 [Latin1_General]。

    至於其他語言，請考慮 "_90" Windows 定序 (如果有的話)，否則請使用另一種 Windows 定序。

    例如，若要進行日文部署而不使用預設定序，而您使用 Unicode CJK Extension A 字元集或 Unicode Surrogates，請使用 [Japanese_90] 定序，如下所述。

    • Team Foundation Server 物件名稱，例如查詢或專案。

    • 簽入版本控制系統的檔案或路徑。

    • 用於搜尋的任何工作項目欄位。

    為避免發生全形或平假名/片假名這類字元的問題，請在安裝期間選取啟用區分假名和區分全半形的核取方塊。

    Team Foundation Server 不支援下列定序：

    • 不區分腔調字

    • 二進位

    • Binary2

    • 區分大小寫

    如需定序設定的詳細資訊，請參閱《SQL Server 2005 線上叢書》中的＜安裝程式中的定序設定＞。

  14. 在 [錯誤和使用方式報表設定] 頁面上，可選擇性地選取 [自動將 SQL Server 2005 的錯誤報告傳送至 Microsoft 或您的 Corporate Error Reporting 伺服器] 和 [自動將 SQL Server 2005 的功能使用方式資料傳送至 Microsoft]，然後按 [下一步]。

  15. 在 [已完成安裝準備工作] 頁面中，您可以檢閱即將安裝的元件清單，然後按一下 [安裝]。

  16. 在 [安裝進度] 頁面中，您可以監視每個元件的安裝狀態。完成安裝程式後，請按 [下一步]。

    注意事項 注意事項

    在 SQL Server Reporting Services 啟動過程中，安裝程式可能會停止回應幾分鐘。

  17. 按一下 [完成] 結束精靈。

    注意事項 注意事項

    若要在安裝 Team Foundation Server 之前先驗證您作的安裝是否正確，請參閱 HOW TO：驗證 Microsoft SQL Server 2005 安裝。

安裝 Microsoft SQL Server 2005 Hotfix

安裝 Microsoft SQL Server 2005 之後，必須安裝會更新 SQL Server Analysis Services 的 Hotfix，以便更有效地支援報告。

注意事項 注意事項

如需最新的更新，請造訪 Microsoft 網站 (http://go.microsoft.com/fwlink/?LinkId=62015)。

若要安裝 Microsoft SQL Server 2005 Hotfix

  1. 在資料層電腦上，開啟 [SQL Server 組態管理員]，以滑鼠右鍵按一下 [SQL Server Browser 服務]，然後按一下 [停止]。

  2. 在 Team Foundation Server 安裝媒體上，尋找 SQLServerKB 資料夾。

  3. 尋找適用於您作業系統和語言的可執行檔 (.exe)，例如 AS2005-KBnnnnnn-x86-ENU.exe，然後按兩下該檔案啟動 Hotfix 安裝程式。

  4. 在 [Hotfix 安裝程式] 中，接受 [使用者授權合約]，完成頁面以安裝 Hotfix，然後按一下 [完成]。

  5. 在 [SQL Server 組態管理員] 中，用滑鼠右鍵按一下 [SQL Server Browser 服務]，再按一下 [屬性]。

  6. 在 [服務] 索引標籤上，尋找 [啟動模式]，然後選取 [自動]。

  7. 在 [登入] 索引標籤上，按一下 [啟動]。

    注意事項 注意事項

    如果 [登入] 索引標籤中的 [啟動] 未啟用，按一下 [服務] 索引標籤，將 [啟動模式] 設為 [停用]，然後再選取 [自動] 確實地更新 [啟動模式]。

若要在安裝 Windows SharePoint Services 之前驗證安裝，請參閱 HOW TO：驗證 Microsoft SQL Server 2005 安裝。

安全性

您必須是電腦上 [Administrators] 安全性群組的成員，才能執行這些程序。本手冊中用來進行安裝的使用者帳戶稱為 Domain\TFSSETUP。如果您使用相同的帳戶安裝 Team Foundation Server，則此帳戶會在安裝期間自動加入至 [Team Foundation Administrators] 安全性群組。如需詳細資訊，請參閱設定 Team Foundation Server 所需的使用者帳戶。

Microsoft SQL Server 2005 服務會要求開啟特定的通訊埠。如需詳細資訊，請參閱設定 Team Foundation Server 所需的連接埠。

請參閱

其他資源

安裝 Team Foundation Server (資料庫)
Team Foundation Build 安裝概觀
Team Foundation Server Proxy 安裝概觀


HOW TO：驗證 Microsoft SQL Server 2005 安裝

HOW TO：驗證 Microsoft SQL Server 2005 安裝

SQL Server 安裝好之後，您可以檢查安裝是否全部完成，以及伺服器是不是已經設定好可以進行 Team Foundation Server 的下一個安裝步驟。以下程序提供驗證以下組態的步驟。

  • 服務執行中。

  • 連線組態已經設定好。

  • 防火牆組態設定正確。

警告事項 警告

Team Foundation Server 安裝精靈在安裝過程中會幫您把元件設定好。您只要依照以下程序檢查應該設定好以及執行中的項目即可。此時若修改 Reporting Services 的組態，可能會導致 Team Foundation Server 的安裝與設定不正確。

驗證服務是否執行中

  1. 在 [開始] 功能表上，依序按一下 [程式集]、[Microsoft SQL Server 2005] 與 [組態工具]，然後按一下 [SQL Server Configuration Manager]。

  2. 選取 [SQL Server 2005 服務]，確認每項服務都有一個綠色的箭頭，代表該項服務正在執行中。

  3. 選取 [SQL Server 2005 網路組態]，按一下 [MSSQLServer 的通訊協定]，確認 [TCP/IP] 已經啟用。

驗證與伺服器的連線

  1. 在 [開始] 功能表上，按一下 [程式集]、[Microsoft SQL Server 2005]，然後按一下 [SQL Server Management Studio]。

  2. 在 [連接至伺服器] 對話方塊中，選取 [伺服程式類型] 中的 [資料庫引擎]，輸入要連接的伺服器名稱，然後按一下 [連接]。

    注意事項 注意事項

    如果 SQL Server 安裝在叢集上，那麼伺服器名稱應該是這個叢集的名稱，而不是電腦的名稱。

  3. 在物件總管中，確認該伺服器名稱旁邊有綠色的箭頭。

    注意事項 注意事項

    如果無法與伺服器建立連線，請檢查防火牆的設定是否正確，然後再試著連線看看。

安全性

您必須是電腦上 [Administrators] 安全性群組的成員，才能執行這些程序。如需詳細資訊，請參閱設定 Team Foundation Server 所需的使用者帳戶。

請參閱

工作

HOW TO：為 Team Foundation Server (單一伺服器部署) 安裝 Microsoft SQL Server 2005
HOW TO：為 Team Foundation Server (雙重伺服器部署) 安裝 Microsoft SQL Server 2005

參考

檢查清單：Team Foundation Server 單一伺服器部署
檢查清單：Team Foundation Server 雙重伺服器部署


HOW TO：安裝 Team Foundation Server (資料庫)

HOW TO：安裝 Team Foundation Server (資料庫)
請參閱

請使用這個程序安裝 Team Foundation Server 資料層元件。

在安裝 Team Foundation Server 之前，請先確定已安裝 Microsoft SQL Server 2005 Standard 或 Enterprise Edition 且正在執行。完成所有資料層的必要條件。如需詳細資訊，請參閱檢查清單：Team Foundation Server 雙重伺服器部署。

若要安裝 Team Foundation Server (資料庫)

  1. 使用逐步進行檢查清單時識別的 Team Foundation Server 設定帳戶 (例如，Domain\TFSSETUP) 登入 Windows。

  2. 放入 Team Foundation Server 安裝媒體，然後在自動執行頁面上按一下 [安裝 Team Foundation Server]，然後按一下 [雙重伺服器安裝]，再按一下 [僅安裝 Team Foundation 資料庫層]。

    如果自動執行頁面並未顯示，請在安裝媒體的根資料夾中找出自動執行檔 (autorun.exe) 並執行。

    Visual Studio 2005 Team Foundation Server (資料庫) 安裝精靈便會啟動。

  3. 在 [歡迎使用安裝程式] 頁面中，按 [下一步]。

  4. 在 [授權條款] 頁面上，檢閱授權合約。如果您接受這些條款和條件，請選取 [我接受授權合約中的條款]，然後按 [下一步]。

  5. 在 [目的資料夾] 頁面中，按 [下一步]。

  6. 在 [系統健康檢查] 頁面上，按一下 [報告] 連結檢查所有警告或阻礙情形。

    • 開始安裝之前，一定要先把阻礙情形排除。按一下 [取消]，並在修正所有問題之後再次執行安裝程式。

    • 雖然您應該先把警告處理好之後再繼續進行安裝，不過警告應該不會阻礙安裝程式完成。您可以按 [下一步]。

      例如，如果未啟用防火牆，此清單中便會出現警告。您可以繼續進行安裝，但是可能必須手動加入啟用元件之間通訊所需的連接埠和例外狀況。

    • 如果未列出任何項目，請按 [下一步]。

  7. 在 [已完成安裝準備工作] 頁面中，按一下 [安裝]。

  8. 在 [安裝元件] 頁面上，監視 Team Foundation 資料層元件的安裝。

    進行安裝時，系統會提示您重新啟動電腦。按一下 [立即重新啟動]。電腦重新啟動且您使用相同帳戶再次登入之後，安裝程式便會繼續執行。

  9. 在 [安裝成功] 頁面中，按一下 [完成]。

  10. 在自動執行頁面上，按一下 [結束]。

檢視 Team Foundation Server 資料庫

  1. 依序按一下 [開始]、[程式集]、[Microsoft SQL Server 2005]，然後按一下 [SQL Server Management Studio]。

  2. 在 [連接至伺服器] 對話方塊中，選取 [伺服器中的資料庫引擎] 類型，輸入要連接的伺服器名稱，然後按一下 [連接]。

    注意事項 注意事項

    如果 SQL Server 安裝在叢集上，那麼伺服器名稱應該是這個叢集的名稱，而不是電腦的名稱。

  3. 在 [物件總管] 中展開 [資料庫]，並確認 Team Foundation Server 資料庫存在。

安全性

您必須是電腦上 [Administrators] 安全性群組的成員，才能執行此程序。本手冊中用來進行安裝的使用者帳戶稱為 Domain\TFSSETUP。如果您使用相同的帳戶安裝 Team Foundation Server，則此帳戶會在安裝期間自動加入至 [Team Foundation Administrators] 安全性群組。如需詳細資訊，請參閱設定 Team Foundation Server 所需的使用者帳戶。

請參閱

其他資源

安裝 Team Foundation Server (資料庫)


安裝 Team Foundation Server (服務)

安裝 Team Foundation Server (服務)
請參閱
DropDown image

請使用本節中的程序，在與資料層元件分開的伺服器上安裝和設定 Team Foundation Server 應用程式層元件及其必要條件。

這些必要條件和元件包括：

元件 | 安裝順序
Internet Information Services (IIS) 6.0 | 第一 (Team Foundation Server 應用程式層元件的必要條件)
SQL Server 2005 Reporting Services | 第二 (Team Foundation Server 應用程式層元件的必要條件)
Windows SharePoint Services 加上 Service Pack 2 | 第三 (Team Foundation Server 應用程式層元件的必要條件)
Team Foundation Server 應用程式層元件 | 第四

如需在兩台電腦上安裝 Team Foundation Server 的完整程序概觀，請參閱逐步解說：安裝 Team Foundation Server 雙重伺服器部署。

在本節中

HOW TO：安裝 Team Foundation Server (服務) 的網際網路資訊服務

描述如何在應用程式層上安裝及設定 Internet Information Services (IIS) 6.0。

HOW TO：為 Team Foundation Server (雙重伺服器部署) 安裝 Microsoft SQL Server 2005 Reporting Services

描述如何在 Team Foundation Server 的雙重伺服器部署中在應用程式層上安裝 SQL Server 2005 Reporting Services。

HOW TO：為 Team Foundation Server (雙重伺服器部署) 安裝 Microsoft Windows SharePoint Services

描述如何在應用程式層上安裝及設定 Windows SharePoint Services。

HOW TO：安裝 Team Foundation Server (服務)

描述如何安裝 Team Foundation Server 的應用程式層元件。

請參閱

其他資源

Team Foundation Server 雙重伺服器部署概觀
安裝 Team Foundation Server (資料庫)


HOW TO：安裝 Team Foundation Server (服務) 的網際網路資訊服務

HOW TO：安裝 Team Foundation Server (服務) 的網際網路資訊服務

使用此程序在 Team Foundation Server 應用程式層上安裝 Internet Information Services (IIS) 6.0。

若要將伺服器設定為應用程式伺服器

  1. 請透過執行下列其中一項動作，啟動 [設定您的伺服器精靈]：

    • 根據預設，當 Windows 啟動時，[管理您的伺服器] 就會自動啟動。在 [管理您的伺服器] 中，按一下 [新增或移除角色]。

    • 在 [控制台] 中，開啟 [系統管理工具]，然後開啟 [設定您的伺服器精靈]。

  2. 在 [歡迎使用設定您的伺服器精靈] 頁面中，按 [下一步]。

  3. 在 [預備步驟] 頁面上，按 [下一步]。

  4. 在 [伺服器角色] 頁面上，按一下 [應用程式伺服器 (IIS，ASP.NET)]，然後按 [下一步]。

  5. 在 [應用程式伺服器選項] 頁面上，選取 [啟用 ASP.NET]，然後按 [下一步]。

    注意事項 重要資訊

    請勿選取 [FrontPage Server Extensions]。這個伺服器將會裝載 Windows SharePoint Services (與 FrontPage Server Extensions 不相容)。

  6. 在 [選取摘要報告] 頁面中，按 [下一步]。

    注意事項 注意事項

    您可能會收到放入 Windows Server 2003 安裝媒體的提示。

  7. 按一下 [完成] 以關閉精靈。

  8. 請造訪 Windows Update (http://windowsupdate.microsoft.com) 並安裝重大更新和 Service Pack 群組中的所有項目。

若要使用新增或移除程式公用程式啟用 ASP.NET

  1. 在 [控制台] 中，開啟 [新增或移除程式]。

  2. 按一下 [新增/移除 Windows 元件]。

    [Windows 元件精靈] 隨即啟動。

  3. 在 [Windows 元件] 頁面中，選取 [應用程式伺服器]，然後按一下 [詳細資料]。

  4. 如果尚未核取，請選取 [ASP.NET]，然後按一下 [確定]。

    注意事項 重要資訊

    請勿選取 [FrontPage 2002 Server Extensions]。這個伺服器將會裝載 Windows SharePoint Services (與 FrontPage Server Extensions 不相容)。

  5. 在 [Windows 元件] 頁面中，按 [下一步]。

    注意事項 注意事項

    您可能會收到放入 Windows Server 2003 安裝媒體的提示。

  6. 按一下 [完成] 關閉精靈。

  7. 請造訪 Windows Update (http://windowsupdate.microsoft.com) 並安裝重大更新和 Service Pack 群組中的所有項目。

安全性

您必須是電腦上 [Administrators] 安全性群組的成員，才能執行這些程序。本手冊中用來進行安裝的使用者帳戶稱為 Domain\TFSSETUP。如果您使用相同的帳戶安裝 Team Foundation Server，則此帳戶會在安裝期間自動加入至 [Team Foundation Administrators] 安全性群組。如需詳細資訊，請參閱設定 Team Foundation Server 所需的使用者帳戶。

請參閱

其他資源

安裝 Team Foundation Server (服務)


HOW TO：為 Team Foundation Server (雙重伺服器部署) 安裝 Microsoft SQL Server 2005 Reporting Services

HOW TO：為 Team Foundation Server (雙重伺服器部署) 安裝 Microsoft SQL Server 2005 Reporting Services
請參閱

請使用這些程序為 Microsoft SQL Server 2005 Standard 或 Enterprise Edition 安裝 Microsoft SQL Server 2005 Reporting Services。您可以使用安裝精靈或回應檔案，以互動的方式進行安裝。

注意事項 注意事項

在安裝之前，電腦必須有已啟用 ASP.NET 的網際網路資訊服務 (IIS)。

若要使用回應檔案安裝 Microsoft SQL Server 2005 Reporting Services

或者，也可以從命令列使用提供的回應檔案安裝 Microsoft SQL Server 2005 Reporting Services。這個回應檔案會自動化安裝程式，以安裝和設定用於 Team Foundation Server 的 Microsoft SQL Server 2005 Reporting Services。

使用回應檔案安裝 Microsoft SQL Server 2005 Reporting Services

  1. 在應用程式層電腦上，使用 Team Foundation Server 設定帳戶 (例如，Domain\TFSSETUP) 登入 Windows。

  2. 在 Team Foundation Server 安裝媒體上找出預先設定的自動回應檔案 (SQL2005ForAT.ini)，並將該檔案複製到本機硬碟 (例如 C:\) 上方便的位置。

  3. 使用下列命令列，執行 Microsoft SQL Server 2005 的安裝程式：

    C:\>SQLServerSetupDirectory\setup.exe /qb /settings AnswerFileDirectory\SQL2005ForAT.ini PIDKEY=ProductKey

    其中 SQLServerSetupDirectory 是 Microsoft SQL Server 2005 setup.exe 的路徑、AnswerFileDirectory 是回應檔的路徑，而 ProductKey 是 Microsoft SQL Server 2005 的產品金鑰 (不含短破折號或空格)。

    注意事項 重要資訊

    [Visual Studio Team Foundation Server (服務) 安裝程式] 精靈會自動將 Reporting Services 設定為使用資料層。在此處使用 [Reporting Service 組態工具] 可能會讓精靈無法正確設定服務。

安裝 Microsoft SQL Server 2005 Reporting Services

使用 Microsoft SQL Server 2005 Standard 或 Enterprise Edition 安裝 SQL Server 2005 Reporting Services。Team Foundation Server 包含 Microsoft SQL Server 2005 Standard Edition 的授權版本。

注意事項 注意事項

在安裝 Microsoft SQL Server 2005 Reporting Services 之前，必須先安裝 Internet Information Services (IIS) 6.0。

若要以互動方式安裝 Microsoft SQL Server 2005 Reporting Services

  1. 在應用程式層電腦上，使用 Team Foundation Server 設定帳戶 (例如，Domain\TFSSETUP) 登入 Windows。

  2. 放入 Microsoft SQL Server 2005 的光碟片，然後在 [SQL Server 2005 起始] 頁的 [安裝] 下，按一下 [伺服器元件、工具、線上叢書和範例]。

    注意事項 注意事項

    Microsoft SQL Server 2005 Standard Edition 的光碟片會隨 Team Foundation Server 提供。若要安裝 SQL Server Enterprise，您可以使用另外購買之軟體的光碟片。從安裝媒體的 Servers 資料夾中執行 Splash.hta 檔，便會顯示 [起始頁]。

    Microsoft SQL Server 2005 安裝精靈便會啟動。

  3. 在 [使用者授權合約] 頁面中，檢閱授權合約。如果您接受這些條款和條件，請選取 [我接受授權條款和條件]，然後按 [下一步]。

  4. 在 [安裝必要條件] 頁面上，按一下 [安裝]。必要的元件都安裝成功後，請按 [下一步]。

    [Microsoft SQL Server 安裝精靈] 隨即啟動。

  5. 按 [下一步] 啟動 [系統組態檢查]。

  6. 在 [系統組態檢查] 頁面中，檢查任何所需動作的狀態 (例如，所需的系統重新啟動)，然後遵循此頁面上的指引進行，直到所有動作都達到 [成功] 狀態為止。在所有動作都達到 [成功] 狀態後，按 [下一步] 啟動安裝。

    注意事項 注意事項

    安裝程式可能需要幾分鐘才能啟動。

  7. 在 [註冊資訊] 頁面中，完成註冊資訊，然後按 [下一步]。

  8. 在 [要安裝的元件] 頁面中，選取 [Reporting Services]，然後按 [下一步]。

    注意事項 注意事項

    如果按一下 [進階]，請勿移除任何預設的選取項目。

  9. 在 [執行個體名稱] 頁面中，選取 [預設的執行個體]，然後按 [下一步]。

    注意事項 重要資訊

    如果您指定具名執行個體，Team Foundation Server 安裝程式將會失敗。

  10. 在 [服務帳戶] 頁面上，選取 [使用內建的系統帳戶]，並從清單選取 [網路服務]。在 [在安裝程式結束時啟動服務] 中選取 [Reporting Services]，然後按 [下一步]。

  11. 在 [報表伺服器安裝選項] 頁面中，按 [下一步]。

    根據預設，會選取 [安裝但不設定伺服器]。

  12. 在 [錯誤和使用方式報表設定] 頁面上，可選擇性地選取 [自動將 SQL Server 2005 的錯誤報告傳送至 Microsoft 或您的 Corporate Error Reporting 伺服器] 和 [自動將 SQL Server 2005 的功能使用方式資料傳送至 Microsoft]，然後按 [下一步]。

  13. 在 [已完成安裝準備工作] 頁面中，您可以檢閱即將安裝的元件清單，然後按一下 [安裝]。

  14. 在 [安裝進度] 頁面中，您可以監視每個元件的安裝狀態。完成安裝程式後，請按 [下一步]。

    注意事項 注意事項

    在 SQL Server Reporting Services 啟動過程中，安裝程式可能會停止回應幾分鐘。

  15. 按一下 [完成] 結束精靈。

警告事項 警告

請勿使用 [Reporting Services 組態工具] 確認服務正在執行。Team Foundation Server 安裝精靈會自動設定 Reporting Services，因此開啟此工具可能會阻止安裝程式完成。

驗證 Report Services 安裝

安裝完成後，請確認服務正常執行且設為自動啟動。

若要驗證安裝

  1. 依序按一下 [開始]、[系統管理工具]，然後按一下 [服務]。

  2. 在 [服務管理員] 的 [名稱] 欄中尋找 [SQL Server Reporting Services]，並確認 [狀態] 為 [已啟動] 且 [啟動類型] 為 [自動]。

    注意事項 注意事項

    您可以變更狀態或啟動類型，只要以滑鼠右鍵按一下服務，按一下 [內容] 並進行變更即可。

  3. 關閉 [服務管理員]。

    驗證服務之後，必須安裝 Microsoft .NET Framework 的 Hotfix。如需詳細資訊，請參閱檢查清單：Team Foundation Server 雙重伺服器部署。

安全性

您必須是電腦上 [Administrators] 安全性群組的成員，才能執行這些程序。本手冊中用來進行安裝的使用者帳戶稱為 Domain\TFSSETUP。如果您使用相同的帳戶安裝 Team Foundation Server，則此帳戶會在安裝期間自動加入至 [Team Foundation Administrators] 安全性群組。如需詳細資訊，請參閱設定 Team Foundation Server 所需的使用者帳戶。Microsoft SQL Server 2005 服務會要求開啟特定的通訊埠。如需詳細資訊，請參閱設定 Team Foundation Server 所需的連接埠。

請參閱

其他資源

安裝 Team Foundation Server (資料庫)


HOW TO：為 Team Foundation Server (雙重伺服器部署) 安裝 Microsoft Windows SharePoint Services

HOW TO：為 Team Foundation Server (雙重伺服器部署) 安裝 Microsoft Windows SharePoint Services
請參閱

請使用下列程序，從命令列以無訊息模式或是使用安裝精靈以互動方式，為 Team Foundation Server 安裝 Microsoft Windows SharePoint Services (加上 Service Pack 2)。

在 Windows SharePoint Services 的當地語系化版本上安裝 Team Foundation Server 之前，必須先安裝符合 Team Foundation Server 語言的 Windows SharePoint Services 語言套件。例如，您必須先安裝英文 Windows SharePoint Services 語言套件，再安裝英文版的 Team Foundation Server。

注意事項 重要資訊

Windows SharePoint Services 需要 NTFS 檔案系統。

以無訊息模式安裝 Microsoft Windows SharePoint Services

您可以在命令列以無訊息模式安裝 Windows SharePoint Services。

若要以無訊息模式安裝 Windows SharePoint Services

  1. 在應用程式層電腦上，使用 Team Foundation Server 設定帳戶 (例如，Domain\TFSSETUP) 登入 Windows。

  2. 下載 Microsoft Windows SharePoint Services 2.0 (加上 Service Pack 2)(http://go.microsoft.com/fwlink/?linkid=55087)，並將檔案儲存到本機硬碟上的方便位置。

  3. 使用下列命令列執行下載的自解壓縮安裝程式檔案 (stsv2.exe)：

    C:\>DownloadDirectory\STSV2.EXE /C:"setupsts.exe /remoteSql=yes /provision=no /q"

    其中 DownloadDirectory 是硬碟上儲存下載檔案的位置路徑。

    注意事項 重要資訊

    您必須使用 /remoteSql=yes 選項安裝 Windows SharePoint Services。這會將 Windows SharePoint Services 設定為使用遠端 SQL Server。/provision=no 選項會將 Windows SharePoint Services 的組態延期。然後，Team Foundation Server 安裝程式會將 Windows SharePoint Services 設定為與 Team Foundation Server 其他部分使用相同的 SQL Server 執行個體。

    您不會接到任何有關安裝完成的提示。在繼續之前，請等候數分鐘讓安裝完成。

  4. 請造訪 Windows Update (http://windowsupdate.microsoft.com) 並安裝重大更新和 Service Pack 群組中的所有項目。

  5. 重新啟動電腦。

以互動方式安裝 Microsoft Windows SharePoint Services

安裝 Microsoft Windows SharePoint Services (加上 Service Pack 2)。

若要以互動方式安裝 Windows SharePoint Services

  1. 在應用程式層電腦上，使用 Team Foundation Server 設定帳戶 (例如，Domain\TFSSETUP) 登入 Windows。

  2. 下載 Microsoft Windows SharePoint Services (加上 Service Pack 2)(http://go.microsoft.com/fwlink/?linkid=55087)，並將檔案儲存到本機硬碟。

  3. 執行下載的自解壓縮安裝程式檔案 (stsv2.exe)。

  4. 在 [使用者授權合約] 頁面中，檢閱授權合約。如果您接受這些條款和條件，請選取 [我接受授權合約]，然後按 [下一步]。

  5. 在 [安裝類型] 頁面上選取 [伺服器陣列]，然後按 [下一步]。

    注意事項 重要資訊

    您必須使用 [伺服器陣列] 選項安裝 Windows SharePoint Services。這會將 Windows SharePoint Services 設定為使用遠端 SQL Server。然後，Team Foundation Server 安裝程式會將 Windows SharePoint Services 設定為與 Team Foundation Server 其他部分使用相同的 SQL Server 執行個體。

  6. 在 [摘要] 頁面中按一下 [安裝]。

    當安裝完成時，Web 瀏覽器視窗會開啟並顯示 [設定管理虛擬伺服器] 頁面。在確認該頁面出現後，關閉瀏覽器視窗而不進行任何變更。

    注意事項 重要資訊

    不要在出現的頁面上進行任何變更。然後，Team Foundation Server 安裝程式會將 Windows SharePoint Services 設定為與 Team Foundation Server 其他部分使用相同的 SQL Server 執行個體。

    如果該頁面沒有出現，則應該判斷原因，並使用＜Windows SharePoint Services 系統管理員手冊＞(英文)(http://go.microsoft.com/fwlink/?LinkId=52668)。

  7. 請造訪 Windows Update (http://windowsupdate.microsoft.com) 並安裝重大更新和 Service Pack 群組中的所有項目。

  8. 重新啟動電腦。

驗證安裝

安裝 Windows SharePoint Server 之後，即使您未安裝 Team Foundation Server，仍可以確認服務是否正常執行。

若要驗證 Windows SharePoint Services 已安裝

  • 開啟 Internet Explorer 並輸入伺服器名稱做為位址。

    例如，若伺服器名稱為 ADATUM，則輸入 Http://adatum。

    雖然站台尚未設定好，但這台伺服器已經是使用中的 Web 伺服器，因此仍然會傳回 [建構中] 頁面。

安全性

您必須是電腦上 [Administrators] 安全性群組的成員，才能執行這些程序。本手冊中用來進行安裝的使用者帳戶稱為 Domain\TFSSETUP。如果您使用相同的帳戶安裝 Team Foundation Server，則此帳戶會在安裝期間自動加入至 [Team Foundation Administrators] 安全性群組。如需詳細資訊，請參閱設定 Team Foundation Server 所需的使用者帳戶。

請參閱

參考

檢查清單：Team Foundation Server 雙重伺服器部署

其他資源

安裝 Team Foundation Server (服務)


HOW TO：安裝 Team Foundation Server (服務)

HOW TO：安裝 Team Foundation Server (服務)
請參閱

請使用此程序安裝 Team Foundation Server 應用程式層元件。在執行此程序之前，請先完成資料層電腦的安裝以及應用程式層的必要條件。

如需詳細資訊，請參閱安裝 Team Foundation Server (服務)。

若要安裝 Team Foundation Server (服務)

  1. 在應用程式層電腦上，使用 Team Foundation Server 設定帳戶 (例如，Domain\TFSSETUP) 登入 Windows。

  2. 在放入光碟片之後出現的自動執行頁面上，按一下 [安裝 Team Foundation Server]，按一下 [雙重伺服器安裝]，然後按一下 [僅安裝 Team Foundation 應用程式層]。

    如果自動執行頁面並未顯示，請在安裝媒體的根資料夾中找出自動執行檔 (autorun.exe) 並執行。

    Visual Studio Team Foundation Server (服務) 安裝精靈隨即啟動。

  3. 在 [歡迎使用安裝程式] 頁面中，按 [下一步]。

  4. 在 [授權條款] 頁面上，檢閱授權合約。如果您接受這些條款和條件，請選取 [我接受授權合約中的條款]，然後按 [下一步]。

    安裝精靈會進行掃描，找出可能會導致安裝失敗或未來伺服器運作出問題的狀況。

  5. 在 [目的資料夾和資料庫伺服器] 頁面上輸入下列資訊：

    • 在 [目的資料夾] 方塊中，輸入安裝路徑或接受預設值。

    • 在 [資料庫伺服器] 方塊中輸入其上已安裝 Team Foundation Server (資料庫) 的電腦名稱。

      注意事項 注意事項

      必須使用電腦的名稱，而不是 IP 位址。

  6. 在 [系統健康檢查] 頁面上，按一下 [報告] 連結檢查所有警告或阻礙情形。

    • 開始安裝之前，一定要先把阻礙情形排除。按一下 [取消]，並在修正所有問題之後再次執行安裝程式。

    • 雖然您應該先把警告處理好之後再繼續進行安裝，不過警告應該不會阻礙安裝程式完成。您可以按 [下一步]。

    • 如果未列出任何項目，請按 [下一步]。

  7. 在 [服務帳戶] 頁面上，輸入 Team Foundation Server 服務帳戶的帳戶資訊 (例如，Domain\TFSSERVICE)，然後按 [下一步]。

  8. 在 [報告資料來源帳戶] 頁面上，輸入 Team Foundation Server 報告帳戶的帳戶資訊 (例如，Domain\TFSREPORTS)，然後按 [下一步]。

    注意事項 注意事項

    這個帳戶不應該與 Team Foundation Server 設定或服務帳戶相同。

  9. 在 [Team Foundation 警示] 頁面上，輸入下列資訊：

    1. 在 [SMTP 服務] 方塊中，輸入要用來傳送 Team Foundation 警示的伺服器名稱。

    2. 在 [寄件者電子郵件地址] 方塊中，輸入傳送 Team Foundation 警示的電子郵件地址名稱，然後按 [下一步]。

      注意事項 注意事項

      如果要在此處啟用警示，則您必須知道組織的 SMTP 伺服器。Team Foundation Server 不需要專門存取 SMTP 的特殊組態設定。安裝和設定 SMTP 並非本文件集涵蓋的範圍。如需詳細資訊，請參閱 Windows Server 2003 的文件。

  10. 在 [已完成安裝準備工作] 頁面中，按一下 [安裝]。

    進行安裝時，系統會提示您重新啟動電腦。按一下 [立即重新啟動]，安裝程式會在電腦重新啟動而您再次登入後繼續。

  11. 在 [安裝成功] 頁面中，按一下 [完成]。

    安裝 Team Foundation Server 之後，您應該使用 [Reporting Services 組態工具] 將 Reporting Services 加密金鑰備份。這個步驟雖然不是建立 Team 專案所必須的，但卻是管理 Team Foundation Server 最佳作法的一部分。如需詳細資訊，請參閱《Team Foundation Server 管理員手冊》中的＜HOW TO：備份 Reporting Services 加密金鑰＞。

  12. 在 Internet Explorer 中，尋找 http://localhost:8080/services/v1.0/Registration.asmx，然後按一下 [GetRegistrationEntries]。

  13. 在 [GetRegistrationEntries] 頁面中按一下 [叫用]。您不需要輸入 ToolID。

    注意事項 注意事項

    您必須位於應用程式層電腦上，才能使用此 Web 方法。

  14. 在 XML 中，確定有下列顯示的 VSTF 類型存在，然後關閉。

    <?xml version="1.0" encoding="utf-8" ?>

    <Type>vstfs</Type>

    注意事項 注意事項

    安裝 Team Foundation Server 之後，您可能想要安裝 Team 總管、Team Team Foundation Build 或 Team Foundation Server Proxy。

安全性

您必須是電腦上 [Administrators] 安全性群組的成員，才能執行此程序。本手冊中用來進行安裝的使用者帳戶稱為 Domain\TFSSETUP。如果您使用相同的帳戶安裝 Team Foundation Server，則此帳戶會在安裝期間自動加入至 [Team Foundation Administrators] 安全性群組。如需詳細資訊，請參閱設定 Team Foundation Server 所需的使用者帳戶。

請參閱

其他資源

安裝 Team Foundation Server (服務)
Team Foundation Build 安裝概觀
Team Foundation Server Proxy 安裝概觀


保持伺服器連續運轉

保持伺服器連續運轉
DropDown image

如果您希望伺服器故障或維修時，還能夠繼續提供服務給系統用戶端，可以多加幾台電腦到 Team Foundation 系統，將它們設定成接手負責資料層或應用程式層的服務即可。

在本節中

檢查清單：Team Foundation Server 叢集部署

摘要說明在叢集中安裝 Team Foundation 資料庫之前的需求。

HOW TO：準備資料層安裝所需的叢集

敘述在叢集中安裝 Team Foundation 資料庫之前應該先完成的步驟。

HOW TO：加速叢集中的伺服器復原

詳列步驟說明如何使用指令碼檔，以明確重新啟動叢集中資料層與應用程式層之間的服務。

檢查清單：待命應用程式層組態

摘要說明應用程式層服務待命電腦的安裝步驟。

HOW TO：將應用程式層設定為待命

敘述 Team Foundation 應用程式層暖待命電腦的安裝步驟。

相關章節

Team Foundation Server 雙重伺服器部署概觀

請使用本節中的程序，在兩部電腦上安裝和設定 Team Foundation Server：一部用於資料層元件，而另一部用於應用程式層元件。

線上資源

Team Foundation 系統管理員手冊 (英文)(http://go.microsoft.com/fwlink/?LinkId=52459)。

請參閱

概念

Team Foundation 安裝


檢查清單：Team Foundation Server 叢集部署

檢查清單：Team Foundation Server 叢集部署
全部折疊影像 下拉影像

為確保 Team Foundation 發揮最大的可用性，您可以將資料層安裝到叢集中。請使用此檢查清單，了解在叢集中安裝 Team Foundation 之前所需準備項目的概觀。

展開影像 Windows 2003 Server 叢集和 SQL Server 2005

完成 | 步驟
 | 下載本指南的最新版本，可從 Microsoft 下載中心 (http://go.microsoft.com/fwlink/?LinkId=40042) 下載。
 | 安裝 Windows Server 2003 Enterprise Edition 或 Windows Server 2003 Datacenter Edition
 | 設定單一仲裁叢集，該叢集支援為主動/被動模式所設定的兩個節點。
 | 安裝 SQL Server 2005，包括以叢集的虛擬伺服器名稱所使用之靜態 IP 位址，以及 SQL Server 的虛擬伺服器名稱所使用之靜態 IP 位址設定的 Analysis 元件。
 | 確認 SQL Server 2005 正常執行。
 | 確認每個 SQL Server 服務都設定為自動啟動。如需詳細資訊，請參閱 HOW TO：準備資料層安裝所需的叢集。
 | 為本機磁碟機上的資料層複製 [NetSetup] 資料夾。
 | 修改 msiproperty.ini，並將 keyname VSTF_DB_SERVER 設為叢集的虛擬伺服器名稱。

展開影像 Team Foundation Server 安裝 (資料庫)

完成 步驟

驗證硬體和軟體需求。如需詳細資訊，請參閱 Team Foundation 系統需求。

找出要用來執行安裝程式的使用者帳戶，並將帳戶加入本機的 [Administrators] 群組。

這個帳戶通常會是您的使用者帳戶。在本指南中，這個帳戶是指 Domain\TFSSETUP。如需詳細資訊，請參閱設定 Team Foundation Server 所需的使用者帳戶。

取得兩個服務帳戶，以提供 Team Foundation Server 用來進行服務之間的通訊。

  • 用於執行 Team Foundation 服務的使用者帳戶 (例如，Domain\TFSSERVICE)。

  • 用於存取 SQL Server Reporting Services 資料來源的帳戶 (例如，Domain\TFSREPORTS)。

如需詳細資訊，請參閱設定 Team Foundation Server 所需的使用者帳戶。

在使用中的節點上，將執行 Team Foundation Server 安裝程式的帳戶 (例如，Domain\TFSSETUP) 加入至本機的 [Administrators] 群組。

在使用中的節點上安裝 Microsoft SQL Server 2005 Standard 或 Enterprise Edition，當做這台電腦上預設的 SQL Server 執行個體。使用本機系統做為服務帳戶。同時請安裝這個安裝主題最後列出的 Hotfix。

如需詳細資訊，請參閱 HOW TO：為 Team Foundation Server (雙重伺服器部署) 安裝 Microsoft SQL Server 2005。

請使用 HOW TO：驗證 Microsoft SQL Server 2005 安裝 主題或《SQL Server 線上叢書》中的＜HOW TO：確認 SQL Server 2005 服務的安裝是否成功＞(http://go.microsoft.com/fwlink/?LinkId=60404) 描述之步驟驗證您的 Microsoft SQL Server 2005 安裝。

在使用中的節點上，確定已開啟適當的通訊埠。

如果有使用 Windows 防火牆或協力廠商的防火牆軟體或硬體方案，您應該確定已開啟必要的通訊埠，以允許元件之間彼此通訊。如需詳細資訊，請參閱設定 Team Foundation Server 所需的連接埠。

在使用中的節點上，安裝 Team Foundation Server (資料庫)。如需詳細資訊，請參閱 HOW TO：安裝 Team Foundation Server (資料庫)。

展開影像 Team Foundation Server 安裝 (服務)

您必須在叢集外的電腦上安裝應用程式服務。只有 Team Foundation 資料庫可以位於叢集內。

完成 步驟

確認應用程式層電腦符合軟硬體需求。如需詳細資訊，請參閱 Team Foundation 系統需求。

將用於執行安裝程式的使用者帳戶加入至本機的 [administrators] 群組。在本指南中，這個帳戶是指 Domain\TFSSETUP。

如需詳細資訊，請參閱設定 Team Foundation Server 所需的使用者帳戶。

安裝 Internet Information Services (IIS) 6.0 並啟用 ASP.NET。

警告事項 警告

請勿安裝 FrontPage Server Extensions。

如需詳細資訊，請參閱 HOW TO：安裝 Team Foundation Server (服務) 的網際網路資訊服務。

安裝搭配 Team Foundation Server 使用的 SQL Server 2005 Reporting Services (使用 Microsoft SQL Server 2005 Standard 版或企業版)。

警告事項 警告

請勿設定 Report Server。Team Foundation Server (服務) 安裝程式會自動完成服務設定。

安裝 Team Foundation Server 安裝媒體上提供之 Microsoft .NET Framework 2.0 的 Hotfix KB913393。

在安裝媒體上尋找 [KB913393] 資料夾及適用您平台的可執行檔 (.exe)，然後按兩下該檔案進行安裝。

安裝搭配 Team Foundation Server 使用的 Windows SharePoint Services (加上 Service Pack 2) 並重新啟動。

警告事項 警告

請勿設定 Windows SharePoint Services。Team Foundation Server (服務) 安裝程式會自動完成 Windows SharePoint Services 的設定。

如需詳細資訊，請參閱 HOW TO：為 Team Foundation Server (雙重伺服器部署) 安裝 Microsoft Windows SharePoint Services。

安裝 Team Foundation Server (服務)。如需詳細資訊，請參閱 HOW TO：安裝 Team Foundation Server (服務)。

確定開啟防火牆所需的適當通訊埠，或已將 SQL Server 加入為例外狀況。

如果有使用 Windows 防火牆或協力廠商的防火牆軟體或硬體方案，您應該確定已開啟必要的通訊埠，以允許元件之間彼此通訊。

如需詳細資訊，請參閱設定 Team Foundation Server 所需的連接埠。

在本機上或另一台電腦上安裝 Team 總管。如需詳細資訊，請參閱 Team 總管安裝概觀。

Expand image 請參閱

工作

HOW TO：準備資料層安裝所需的叢集


HOW TO：準備資料層安裝所需的叢集

HOW TO：準備資料層安裝所需的叢集

將資料層放在叢集中執行，可以為用戶端提供不間斷的服務。但要達到這個目的，執行 Team Foundation Server 安裝精靈前，必須先準備好 Team Foundation 資料庫安裝所需的叢集。

以下程序假設您已經安裝了 SQL Server 2005，而且是放在叢集中執行。如需詳細資訊，請參閱＜HOW TO：建立新的 SQL Server 2005 容錯移轉叢集 (安裝程式)＞(http://msdn2.microsoft.com/zh-tw/library/ms179530.aspx)。

要完成此程序，您必須知道 SQL Server 的虛擬伺服器名稱與 IP 位址。

準備資料層安裝所需的叢集

  1. 以 Cluster Administrator 身分登入叢集內的使用中節點。

  2. 依序按一下 [開始]、[Microsoft SQL Server 2005]、[組態工具]，然後按一下 [SQL Server 組態管理員]。

  3. 針對以下每一個 SQL Server 服務：開啟 [屬性] 對話方塊，將 [服務] 索引標籤上的 [啟動模式] 設定為 [自動]。

    • SQL Server (MSSQLSERVER)

    • SQL Server Agent (MSSQLSERVER)

    • SQL Analysis Services (MSSQLSERVER)

    • SQL Server Integration Services

    • SQL Server Browser

    • SQL Server FullText Search (MSSQLSERVER)

      注意事項 注意事項

      缺少以上任何一項服務，都無法安裝 Team Foundation。您可以用 [新增或移除程式] 新增 SQL Server 2005 缺漏的元件，就可以修改原來所安裝的 SQL Server 2005。

  4. 將安裝媒體上資料層所需的 NetSetup 資料夾，複製到本機磁碟機上的目錄，例如 c:\temp\。

  5. 在複製過來的 NetSetup 中，找出 msiproperty.ini 檔案，並用文字編輯器進行編輯。

  6. 在這個檔案中，找出機碼名稱 VSTF_DB_SERVER，將其中的 ComputerName 換成 SQL Server 的虛擬伺服器名稱。

    以下範例顯示原本設定的語彙基元，以及為了要安裝在 VSTFSQLCLUSTER 上所作的修改。

    原始值 VSTF_DB_SERVER=[ComputerName]

    修改後 VSTF_DB_SERVER=VSTFSQLCLUSTER

    警告事項 警告

    只要更換這個執行個體即可。若將其他語彙基元的 ComputerName 換成虛擬伺服器的名稱，將會更換掉應用程式層服務電腦的名稱，這樣是不對的。

  7. 安裝 Team Foundation 資料庫。如需詳細資訊，請參閱 HOW TO：安裝 Team Foundation Server (資料庫)。

安全性

準備資料層安裝所需的叢集時，您的身分必須是 Cluster Administrator 群組的成員才行。

請參閱

工作

HOW TO：加速叢集中的伺服器復原

參考

檢查清單：Team Foundation Server 叢集部署

概念

保持伺服器連續運轉


HOW TO：加速叢集中的伺服器復原

HOW TO：加速叢集中的伺服器復原
請參閱 範例

Team Foundation Administrator 可以利用指令碼檔明確重新啟動叢集中資料層與應用程式層之間的服務。雖然 SQL Server 2005 最終還是會重新啟動這些服務，但在資料層叢集中多增加一項資源，便可以作到更為及時的復原。要新增一項資源，您必須提供一個指令碼檔。這個指令碼檔執行起來時，會重新啟動服務與控制項，並指引這項資源指向它本身。

以下程序假設您有一個在叢集中執行的資料層伺服器，也有一個運作中的應用程式層伺服器。

新增資源到資料層叢集

  1. 登入此叢集的使用中節點。

    注意事項 注意事項

    被動節點只會接受已經與使用中節點建立起來的連線。如果您嚐試登入被動節點，會出現錯誤訊息。

  2. 在文字編輯器中建立一個指令碼檔，運用 Windows Management Instrumentation (WMI) 查詢應用程式集區程序以及重設每個程序。

    注意事項 注意事項

    在 Visual Studio 中，使用 VBScript 或 JScript 的 Web 範本可以快速建立指令碼檔，然後再將本小節提供的範例指令碼放入該檔案中即可。請一定要將應用程式層伺服器名稱的預留位置替換成適合您系統的伺服器名稱。

  3. 將這個檔案存放到適當的磁碟機與目錄。

  4. 按一下 [開始]、[所有程式]、[管理工具]，然後按一下 [叢集系統管理員]。

  5. 用滑鼠右鍵按一下 [資源] 節點，按一下 [新增]，然後按一下 [資源]。

  6. 在 [新增資源] 精靈內，輸入此資源的名稱，然後按一下這個 [資源類型] 的一般指令檔。

    例如您可以輸入以下資訊。

    • 名稱：TFS IIS 重設

    • 說明：指向重設 IIS 與應用程式層連線的 TFS_IIS_RESET.vbs。

    • 資源類型：一般指令檔

    • 群組：叢集群組

  7. 在 [可能的擁有者] 頁面上，確認叢集中的兩台電腦都已經出現在 [可能的擁有者] 清單內。

  8. 在 [相依性] 頁面上，針對 [可用的資源] 中的每一項資源，都要選取並按一下 [新增]，將這些資源移到 [相依性] 方塊內。

    將所有資源都加入成為新資源的相依對象，這樣就可以確定新資源一定是最後一個上線的資源。

  9. 在 [一般指令檔參數] 頁面上，輸入指令碼的路徑與名稱，然後按一下 [完成]。

    注意事項 注意事項

    如果檔案路徑很長，可以先在 Windows 檔案總管中找出這個檔案，檢視它的屬性，在 [一般] 索引標籤上，選取 [位置] 中的路徑，然後將該段文字複製貼到精靈內即可。至於檔案名稱，則必須由您親自輸入。

  10. 在 [叢集系統管理員] 中，用滑鼠右鍵按一下您新增指令檔的資源，接著按一下 [上線]。

範例

在 Visual Studio 中，您可以用 [新增檔案] 對話方塊中為 VBScript 提供的 Web 範本建立指令碼檔。以下範例使用 WMI 實作控制作業系統的叢集 API 常式。Online 函數會查詢 IIS 應用程式集區，並啟動集區中的每個程序。Offline 函數會查詢 IIS 應用程式集區，將每個程序停止。叢集 API 的 LooksAlive 與 IsAlive 函數負責設定狀態資訊，供資源監視器使用。

注意事項 注意事項

請一定要將應用程式層伺服器名稱的預留位置 TFS AT Name 替換成您系統中應用程式層的伺服器名稱。
複製程式碼圖像 複製程式碼
Sub Open( )
End Sub

Function Close( )
End Function

Function Online( )
strComputer = "TFS AT Name"

Set objWMIService = GetObject _
    ("winmgmts:{authenticationLevel=pktPrivacy}\\" _
        & strComputer & "\root\microsoftiisv2")

Set colItems = objWMIService.ExecQuery _
    ("Select * From IIsApplicationPool")

For Each objItem in colItems
    objItem.Start
Next
End Function

Function Offline( )
strComputer = "TFS AT Name"

Set objWMIService = GetObject _
    ("winmgmts:{authenticationLevel=pktPrivacy}\\" _
        & strComputer & "\root\microsoftiisv2")

Set colItems = objWMIService.ExecQuery _
    ("Select * From IIsApplicationPool")

For Each objItem in colItems
    objItem.Stop
Next
End Function

Function Terminate( )
    Call Offline
End Function

Function LooksAlive ( )
    LooksAlive = True

End Function

Function IsAlive( )
   IsAlive= True
End Function

安全性

您必須是 Cluster Administrator 安全群組的成員，才能執行這項程序。

請參閱

概念

設定 Team Foundation Server 所需的使用者帳戶


檢查清單：待命應用程式層組態

檢查清單：待命應用程式層組態
全部折疊影像 下拉影像

此檢查清單會說明在待命電腦上設定應用程式層的一般步驟。此清單內容是假設您已設定下列實體架構。

  • 一台已安裝 SQL Server 且執行 Team Foundation Server 資料庫元件的伺服器

  • 一台已安裝且執行 Windows SharePoint、SQL Reporting Services 及 Team Foundation Server 服務元件的伺服器。

  • 一台符合應用程式層軟硬體需求的伺服器。

您應該列印這份檢查清單，並在完成每個步驟後加以標示。

展開影像 準備作業

安裝及設定待命電腦之前，您需要先準備下列項目。

完成 步驟

下載本指南的最新版本，可從 Microsoft 下載中心 (http://go.microsoft.com/fwlink/?LinkId=40042) 下載。

確認待命伺服器符合應用程式層的軟硬體需求。如需詳細資訊，請參閱 Team Foundation 系統需求中的＜應用程式層＞一節。

在待命電腦上，加入以下服務帳戶。網域和主要應用程式層電腦上應該已經具有這些帳戶。待命電腦上使用的服務帳戶必須與主要電腦上使用的服務帳戶相同。

  • 用於執行安裝程式的使用者帳戶，例如 Domain\TFSSETUP。

  • 用於執行 Team Foundation 服務的服務帳戶，例如 Domain\TFSSERVICE。

  • 用於存取 SQL Server Reporting Services 資料來源的服務帳戶，例如 Domain\TFSREPORTS。

如需詳細資訊，請參閱設定 Team Foundation Server 所需的使用者帳戶。

展開影像 安裝

完成 步驟

在待命電腦上安裝 Internet Information Services (IIS) 6.0 並啟用 ASP.NET。

警告事項 警告

請勿安裝 FrontPage Server Extensions。

如需詳細資訊，請參閱 HOW TO：安裝 Team Foundation Server (服務) 的網際網路資訊服務。

在待命電腦上，安裝搭配 Team Foundation Server 使用的 SQL Server 2005 Reporting Services (使用 Microsoft SQL Server 2005 Standard 或 Enterprise Edition)。

在待命電腦上，安裝 Team Foundation Server 安裝媒體上提供之 Microsoft .NET Framework 2.0 的 Hotfix KB913393。

在安裝媒體上尋找 [KB913393] 資料夾及適用您平台 (X86) 的可執行檔 (.exe)，然後按兩下該檔案進行安裝。

在待命電腦上安裝搭配 Team Foundation Server 使用的 Windows SharePoint Services (加上 Service Pack 2)，然後重新啟動待命電腦。

警告事項 警告

請勿設定 Windows SharePoint Services 的任何設定。Team Foundation Server (服務) 安裝程式會自動完成服務設定。

如需詳細資訊，請參閱 HOW TO：為 Team Foundation Server (雙重伺服器部署) 安裝 Microsoft Windows SharePoint Services。

在待命電腦上安裝 Team Foundation Server (服務)。如需詳細資訊，請參閱 HOW TO：安裝 Team Foundation Server (服務)。

注意事項 注意事項

如果出現警告，說明您提供的資料層伺服器正在使用，請輸入 Y 繼續進行。

確認適當的通訊埠都已開啟。

如果資料層電腦上有使用 Windows 防火牆或協力廠商的防火牆軟體或硬體方案，則應該確定已開啟必要的通訊埠，以允許元件之間彼此通訊。如需詳細資訊，請參閱設定 Team Foundation Server 所需的連接埠。

安裝 Team 總管。如需詳細資訊，請參閱 Team 總管安裝概觀。

在待命電腦上，將使用者帳戶和群組更新以和主要電腦相同。例如，確認主要電腦上 Team 專案建立者的群組成員資格和角色，在待命電腦上也擁有適當的成員資格和角色。如需詳細資訊，請參閱 HOW TO：將使用者加入到 Team Foundation Administrators 應用程式群組。

展開影像 組態

完成 步驟

選取將 DNS 主機加入至網域的方法。無論使用哪一個應用程式層，您都必須選取指定單一主機名稱的方法，以繫結至用戶端和資料層。

  • 如果 Team Foundation Server 管理員擁有 [網域管理] 權限，請使用 [DNS 主機更新]。

  • 如果 Team Foundation Server 管理員無法進行網域管理，請使用 [專用 IP (DIP) 位址]。此選項會取得主要和待命電腦的靜態 IP 位址，並指定在網域上與主要電腦使用相同 IP 位址的虛擬伺服器名稱。

如需指定主機名稱的詳細資訊，請參閱 HOW TO：將應用程式層設定為待命中關於設定網路介面卡的描述。

如果應用程式層伺服器執行的是 SQL Server Enterprise Edition，請使用 [Reporting Services 組態工具] 設定向外延展部署的 Reporting Services。

如果應用程式層伺服器是執行 SQL Server Standard Edition，請使用 [Reporting Services 組態工具] 將 Reporting Services 加密金鑰備份。

將 Team Foundation Server 應用程式層的伺服器名稱設為虛擬伺服器名稱。此步驟會將原來的電腦名稱變更為透過您使用之網路介面卡方法，所指向之任一台電腦的名稱。

將 Team 總管連接到虛擬伺服器名稱。

Expand image 請參閱

工作

HOW TO：將應用程式層設定為待命

概念

保持伺服器連續運轉

其他資源

Team Foundation Server 雙重伺服器部署概觀


HOW TO：將應用程式層設定為待命

HOW TO：將應用程式層設定為待命

您可以在初次設定 Team Foundation Server 時，為應用程式層設定待命電腦，或者稍後再設定。您必須設定可以設為指向任一應用程式層電腦的虛擬伺服器名稱，用戶端電腦和資料層電腦才能清楚瞭解電腦之間的切換。

此程序會假設您已完成檢查清單：待命應用程式層組態中所述的準備工作及安裝步驟。這些步驟會提供完成檢查清單中所提供之設定步驟的詳細資料。

  • 設定讓網路介面卡提供虛擬伺服器名稱。

  • 設定 SQL Server 2005 供待命時使用。

  • 設定讓 Team Foundation Server 使用虛擬伺服器名稱。

  • 將 Team 總管連接到虛擬伺服器名稱。

設定 DNS 主機

若要提供單一名稱，讓用戶端和資料層在無論使用哪一部應用程式層伺服器時，都能以該名稱進行通訊，則必須指定網域上的主機名稱。您要將應用程式層服務從主伺服器切換至待命伺服器時，必須使用該名稱啟動待命伺服器，並將它繫結至資料層。

以下程序說明指定網域主機名稱的兩個選項。這兩個選項都需要 DNS 管理員權限，因為您必須為虛擬應用程式伺服器建立 DNS 主機記錄。如果您的組織並未提供 [網域管理] 權限給 Team Foundation Server 管理員，則必須使用「固定 IP 位址」，才能更新主機名稱的 IP 位址。

若組織已將網域管理員權限授予 Team Foundation Server 管理員，則建議使用 DNS 主機更新方法。

DNS 主機更新：建立的「DNS 主機 (A)」記錄會包含主要 Team Foundation Server 應用程式層伺服器的 IP 位址。這兩部 Team Foundation Server 應用程式層伺服器上都不需要特定的網路設定，因為 DNS 會將虛擬 Team Foundation Server 應用程式層伺服器的要求，解析為主要應用程式層伺服器的 IP 位址。在容錯移轉過程中，網域管理員必須更新 DNS 主機項目，將流量重新導向新的主要 Team Foundation Server 應用程式層伺服器。

固定 IP (DIP) 位址：此組態中需要三個靜態 IP 位址。將虛擬 Team Foundation Server 應用程式層伺服器名稱對應至其中一個固定 IP 位址的 DNS 主機記錄，是由網域管理員所建立。該靜態 IP 位址和其中一個未使用的 IP 位址，是在主要 Team Foundation Server 應用程式層伺服器上於網路連線的 [TCP/IP] 屬性中手動設定。待命 Team Foundation Server 應用程式層伺服器則是使用其餘的靜態 IP 位址設定。在容錯移轉過程中，Team Foundation Server 管理員會變更新的主要 Team Foundation Server 應用程式層伺服器上的網路設定，讓伺服器回應虛擬 Team Foundation Server 應用程式層伺服器所使用靜態 IP 位址上的要求。

若要實作待命電腦，網域伺服器必須擁有三部伺服器的資源記錄。

  • 主要：使用靜態 IP 位址的主要應用程式層伺服器的電腦名稱。例如，您可能會將主要伺服器命名為 TFS_AT_01。

  • 待命：使用靜態 IP 位址的待命應用程式層伺服器的電腦名稱。例如，您可能會將待命伺服器命名為 TFS_AT_02。

  • 虛擬伺服器：使用靜態 IP 位址之應用程式層的虛擬伺服器名稱，其 IP 位址與主要電腦的 IP 位址相同。例如，您可能會使用 TFS_AT 做為虛擬伺服器的名稱。

    發生錯誤後，必須根據待命電腦手動更新虛擬伺服器名稱的 IP 位址。

    以下程序會假設您已設定並執行資料層伺服器和應用程式層伺服器。

    注意事項 注意事項

    取得靜態 IP 位址和指定虛擬伺服器名稱的步驟，端視您的組織管理網域的方式而定，本文件中並未涵蓋這個部分。如需詳細資訊，請參閱＜網域管理員＞。

指定網域的主機名稱

  1. 在 [開始] 功能表中按一下 [執行]，然後輸入 dnsmgmt.msc，再按一下 [確定]。

  2. 在 [DNS 管理員] 中，按一下 [順向迴圈區域]，然後以滑鼠右鍵按一下網域名稱，再按一下 [新主機 (A)]。

  3. 在 [新主機] 對話方塊中，輸入虛擬伺服器要使用的名稱，例如 TFS_AT。

  4. 檢查並記下主要及待命電腦的靜態 IP 位址。

  5. 選取 [建立關聯的指標 (PTR) 記錄]，根據您選擇使用的方法輸入 IP 位址，然後按一下 [新增主機]。

    • DNS 主機更新：輸入主要電腦的 IP 位址。

    • 固定 IP (DIP) 位址：輸入三個靜態 IP 位址的其中一個，做為應用程式層虛擬伺服器的位址。您必須設定 IP 位址的網路連線。

  6. 確認主要電腦和虛擬伺服器使用您預期的靜態 IP 位址，而且位址相同。

設定固定 IP 位址的網路連線

  1. 在主要電腦上，開啟 [命令提示字元] 視窗並輸入 ipconfig /all。

    注意事項 注意事項

    如果您使用 [DNS 主機更新]，則不需要完成此程序。

    網路組態設定隨即出現。

  2. 在 [開始] 功能表上，按一下 [控制台]，然後按一下 [網路連線]。

  3. 尋找網域的網路連線，然後以滑鼠右鍵按一下 [網際網路內容 (TCP/IP)]，再按一下 [內容]。

  4. 按一下 [使用下列的 IP 位址]，輸入主要電腦的靜態 IP 位址，然後使用 [命令提示字元] 視窗中顯示的資訊輸入 IP 位址的子網路遮罩。

  5. 在 [命令提示字元] 視窗中，尋找預設閘道的名稱。

  6. 在 [網路連線] 對話方塊中，按一下 [使用下列的 DNS 伺服器位址]，輸入列出的第一個 DNS 伺服器位址做為 [慣用 DNS 伺服器]，然後按一下 [進階]。

  7. 在 [進階 TCP/IP 設定] 對話方塊中選取 [DNS] 索引標籤，按一下 [新增]，然後指定網路組態設定中列出的其他 DNS 伺服器。

  8. 選取 [WINS] 索引標籤，按一下 [新增]，然後指定網路組態設定中列出的主要和次要 WINS 伺服器。

  9. 選取 [IP 設定] 索引標籤，按一下 [新增]，然後指定虛擬伺服器的靜態 IP 位址，例如 AT_TFS。

  10. 在待命電腦上重複上述步驟。

設定 SQL Server 2005 供待命時使用

您必須根據您的 Microsoft SQL Server 2005 版本完成下列其中一項作業。

  • 若您使用 SQL Server Standard Edition，則需要 Reporting Services 加密金鑰檔和用來協助保護內容的密碼，才能啟動待命 Team Foundation Server 應用程式層伺服器上的 Reporting Services。

  • 若您使用 SQL Server Reporting Services Enterprise Edition，則必須設定「向外延展」部署。在此情況下，待命 Team Foundation Server 應用程式層伺服器上的 Reporting Services 執行個體必須聯結至向外延展部署 (請參閱＜如何：設定報表伺服器向外延展部署 (Reporting Services 組態)＞http://msdn2.microsoft.com/zh-tw/library/ms159114.aspx)。

設定 SQL Server 2005 Standard Edition

  1. 在主要 Team Foundation Server 應用程式層電腦上，開啟 [命令提示字元] 視窗。

  2. 輸入 cd %Program Files%\Microsoft SQL Server\90\Tools\binn，尋找 binn 目錄。

  3. 執行 rsconfigtool.exe。

  4. 在 [Reporting Services 組態] 工具中，按一下左側巡覽窗格中的 [加密金鑰]，然後按一下 [備份]。

  5. 輸入強式密碼，協助保護加密金鑰檔的內容。

  6. 將檔案儲存到主要伺服器故障時仍能存取的位置。

設定 SQL Server Reporting Services Enterprise Edition

  1. 在待命電腦上，開啟 [Report Server 組態工具]。

  2. 按一下 [確定] 連接到待命伺服器上的 Report Server 執行個體

  3. 按一下左窗格中的 [初始化]，並確認已建立第二個報告伺服器執行個體的項目。[已初始化] 核取方塊應為空白。

  4. 重新連接到主要伺服器上的報告伺服器執行個體。主要報告伺服器已初始化，以便進行可回復的加密作業。因此，該伺服器會用來初始化待命伺服器上新的報告伺服器執行個體，以便進行向外延展部署。

  5. 在 [初始化] 頁面上，選取要聯結至部署的報告伺服器執行個體，然後按一下 [初始化]。所有屬於相同向外延展部署的報告伺服器執行個體的 [已初始化] 核取方塊都應選取，然後按一下 [套用] (您可能需要按一下 [重新整理])。

  6. 在 Internet Explorer 中搜尋 http://TFSAT02/reports，並確認待命伺服器位於向外延展部署中。

設定讓 Team Foundation Server 使用虛擬伺服器名稱

設定讓主要電腦使用虛擬伺服器名稱

  • 在主要電腦上，使用 TfsAdminUtil 命令列公用程式的 ActivateAT 命令啟動虛擬伺服器名稱。

    例如，下列命令會啟動 TFS_AT 做為應用程式層伺服器，該伺服器使用的 IP 位址與主要伺服器相同。

    TfsAdminUtil ActivateAT TFS_AT

設定讓待命電腦使用虛擬伺服器名稱

  • 在待命電腦上，使用 TfsAdminUtil 命令列公用程式的 ActivateAT 命令啟動虛擬伺服器名稱。例如，下列命令會啟動 TFS_AT 做為應用程式層伺服器，該伺服器使用的 IP 位址與主要伺服器相同。

    TfsAdminUtil ActivateAT TFS_AT

將 Team 總管連接到虛擬伺服器

若要將 Team 總管連接到虛擬伺服器

  1. 開啟 Team 總管，按一下 [工具]，然後按一下 [連接到 Team Foundation Server]。

  2. 按一下 [加入]，指定虛擬伺服器名稱，然後按一下 [關閉]，即可將伺服器名稱加入至清單中。

  3. 在 [連接至] 對話方塊中，從清單選取虛擬伺服器名稱，然後按一下 [連接]。

安全性

您必須是 [Team Foundation Administrators] 安全性群組以及 [Cluster Administrator] 安全性群組的成員，才能將應用程式層設定為待命。

請參閱

工作

HOW TO：安裝 Team Foundation Server (服務)

參考

檢查清單：待命應用程式層組態

概念

保持伺服器連續運轉


Team Foundation Build 安裝概觀

Team Foundation Build 安裝概觀
DropDown image

Team Foundation Server 提供建置 (Build) 自動化，可協助您使用 Team Foundation Build 建置及共用 Visual Studio 2005 方案。可以在與 Team Foundation 應用程式層相同的電腦或不同的電腦上安裝 Team Foundation Build。

在本節中

HOW TO：安裝 Team Foundation Build

請使用這個程序安裝 Team Foundation Build。

相關章節

Team Foundation 系統需求

提供安裝 Team Foundation Server 這個版本的硬體和軟體系統需求。

Team Foundation Server 安裝程式安全性概觀

提供安裝 Team Foundation Server 的安全性相關資訊。

Team Foundation Server 單一伺服器部署

請使用本節中的程序，在一部伺服器上安裝和設定 Team Foundation Server。

Team Foundation Server 雙重伺服器部署概觀

請使用本節中的程序，在兩部電腦上安裝和設定 Team Foundation Server：一部用於資料層元件，而另一部用於應用程式層元件。

Team Foundation Server Proxy 安裝概觀

請使用本節中的程序來安裝 Team Foundation Server Proxy，以便快取之前存取的原始檔控制檔案。

Team 總管安裝概觀

請使用本節中的程序來安裝和設定 Team 總管。

請參閱

概念

Team Foundation 安裝


HOW TO：安裝 Team Foundation Build

HOW TO：安裝 Team Foundation Build

請使用這個程序安裝 Team Foundation Build。

如何安裝 Team Foundation Build

  1. 在 Team Foundation Server 安裝媒體上找出 \build 資料夾，然後執行 setup.exe。

    Visual Studio 2005 Team Foundation Build 伺服器安裝精靈隨即啟動。

  2. 在 [歡迎使用安裝程式] 頁面中，按 [下一步]。

  3. 在 [授權條款和產品金鑰] 頁面中，檢閱授權合約。如果您接受這些條款和條件，請選取 [我接受授權合約中的條款]，然後按 [下一步]。

  4. 在 [目的資料夾] 頁面中，接受預設目的資料夾，然後按 [下一步]。

  5. 在 [系統健康檢查] 頁面上，安裝精靈會掃瞄系統，以找出可能造成安裝程式失敗，或在之後的伺服器作業期間造成問題的情況。完成系統掃瞄後，安裝程式將會回報系統健康檢查的狀態。如果系統健康檢查並未找出任何問題，您就可以按一下連結，以便檢閱與特定警告和區塊相關的報告。雖然您應該先處理警告，然後再繼續進行安裝，不過不應該防止安裝程式完成。您必須先處理區塊，才能繼續進行安裝。如果系統健康檢查並未找出任何區塊，請按 [下一步]。否則，請按一下 [取消] 並在修正任何中止原因後，再次執行安裝程式。

  6. 在 [服務帳戶] 頁面中，於 [帳戶名稱] 方塊中輸入您為 Team Foundation Server 服務帳戶建立的 Windows 網域使用者帳戶 (例如，Domain\TFSSERVICE)，並在 [密碼] 方塊中輸入密碼，然後按 [下一步]。如需詳細資訊，請參閱設定 Team Foundation Server 所需的使用者帳戶。

    注意事項 注意事項

    對於這個版本，您必須使用相同的 Windows 網域使用者帳戶做為 Team Foundation Server 服務帳戶。

  7. 在 [已完成安裝準備工作] 頁面中，按一下 [安裝]。

    注意事項 注意事項

    安裝程式會在 Windows 防火牆中為 MSBuild.exe 和 TeamBuildService.exe 建立程式例外，允許它們與 Team Foundation Server 進行通訊。

  8. 在 [安裝元件] 頁面上可以監視 Team Build 的安裝。

  9. 在 [安裝成功] 頁面中，按一下 [完成]。

    注意事項 注意事項

    如果您想建構的專案需要其他項目，例如元件、程式或動態連結程式庫 (DLL)，您必須手動將他們加入建構電腦中才行。

安全性

您必須是電腦上 [Administrators] 安全性群組的成員，才能執行此程序。如需詳細資訊，請參閱設定 Team Foundation Server 所需的使用者帳戶。

請參閱

概念

Team Foundation 實體架構
Team Foundation 系統需求

其他資源

Team Foundation Build 安裝概觀


Team Foundation Server Proxy 安裝概觀

Team Foundation Server Proxy 安裝概觀
DropDown image

請使用本節中的程序來安裝 Team Foundation Server Proxy，以便快取之前存取的原始檔控制檔案。可以在與 Team Foundation 應用程式層相同的電腦或在不同的電腦上安裝 Team Foundation Server Proxy。

在本節中

HOW TO：為 Team Foundation Server Proxy 安裝網際網路資訊服務

描述如何為 Team Foundation Server Proxy 安裝 Internet Information Services (IIS) 6.0。

HOW TO：安裝 Team Foundation Server Proxy

描述如何安裝 Team Foundation Server Proxy，此元件可以快取之前存取過的檔案而改善原始檔控制作業。

HOW TO：設定 Team 總管以使用 Team Foundation Server Proxy

描述如何將 Team 總管設定為使用 Team Foundation Server Proxy。

相關章節

Team Foundation 系統需求

提供安裝 Team Foundation Server 這個版本的硬體和軟體系統需求。

Team Foundation Server 安裝程式安全性概觀

提供安裝 Team Foundation Server 的安全性相關資訊。

Team Foundation Server 單一伺服器部署

請使用本節中的程序，在一部伺服器上安裝和設定 Team Foundation Server。

Team Foundation Server 雙重伺服器部署概觀

請使用本節中的程序，在兩部電腦上安裝和設定 Team Foundation Server：一部用於資料層元件，而另一部用於應用程式層元件。

Team Foundation Build 安裝概觀

請使用本節中的程序來安裝和設定 Team Foundation Build，以便提供組建 Automation 來協助您建置並共用 Visual Studio 2005 方案。

Team 總管安裝概觀

請使用本節中的程序來安裝和設定 Team 總管。

請參閱

概念

Team Foundation 安裝


HOW TO：為 Team Foundation Server Proxy 安裝網際網路資訊服務

HOW TO：為 Team Foundation Server Proxy 安裝網際網路資訊服務

請使用這個程序為 Team Foundation Server Proxy 安裝 Internet Information Services (IIS) 6.0。

您可以到 [新增或移除程式] 中檢查是否已經安裝了 IIS，以及 ASP.NET 是否已經啟用。如果不是，請依照以下程序安裝 IIS 並啟用 ASP.NET。

若要使用新增或移除程式公用程式啟用 ASP.NET

  1. 在 [控制台] 中，開啟 [新增或移除程式]。

  2. 按一下 [新增/移除 Windows 元件]。

    [Windows 元件精靈] 隨即啟動。

  3. 在 [Windows 元件] 頁面中，選取 [應用程式伺服器]，然後按一下 [詳細資料]。

  4. 如果尚未核取，請選取 [ASP.NET]，然後按一下 [確定]。

  5. 在 [Windows 元件] 頁面中，按 [下一步]。

    注意事項 注意事項

    您可能會收到放入 Windows Server 2003 安裝媒體的提示。

  6. 按一下 [完成] 關閉精靈。

  7. 請造訪 Windows Update (http://windowsupdate.microsoft.com) 並安裝重大更新和 Service Pack 群組中的所有項目。

若要將伺服器設定為應用程式伺服器

  1. 請透過執行下列其中一項動作，啟動 [設定您的伺服器精靈]：

    • 根據預設，當 Windows 啟動時，[管理您的伺服器] 就會自動啟動。在 [管理您的伺服器] 中，按一下 [新增或移除角色]。

    • 在 [控制台] 中，開啟 [系統管理工具]，然後開啟 [設定您的伺服器精靈]。

  2. 在 [歡迎使用設定您的伺服器精靈] 頁面中，按 [下一步]。

  3. 在 [預備步驟] 頁面上，按 [下一步]。

  4. 在 [伺服器角色] 頁面上，選取 [應用程式伺服器 (IIS，ASP.NET)]，然後按 [下一步]。

  5. 在 [應用程式伺服器選項] 頁面上，選取 [啟用 ASP.NET]，然後按 [下一步]。

  6. 在 [選取摘要報告] 頁面中，按 [下一步]。

    注意事項 注意事項

    您可能會收到放入 Windows Server 2003 安裝媒體的提示。

  7. 按一下 [完成] 以關閉精靈。

  8. 請造訪 Windows Update (http://windowsupdate.microsoft.com) 並安裝重大更新和 Service Pack 群組中的所有項目。

安全性

您必須是電腦上 [Administrators] 安全性群組的成員，才能執行這些程序。本手冊中用來進行安裝的使用者帳戶稱為 Domain\TFSSETUP。如需詳細資訊，請參閱設定 Team Foundation Server 所需的使用者帳戶。

請參閱

工作

HOW TO：安裝 Team Foundation Server Proxy

其他資源

Team Foundation Server Proxy 安裝概觀


HOW TO：安裝 Team Foundation Server Proxy

HOW TO：安裝 Team Foundation Server Proxy

描述如何安裝 Team 總管 Proxy。Proxy 會藉由快取之前存取的檔案，改善原始檔控制的下載作業。一般而言，您會將 Team Foundation Server Proxy 安裝在分散式小組遠端位置的電腦上。

若要安裝 Team Foundation Server Proxy

  1. 安裝並完成 Team Foundation Server Proxy 電腦的必要條件：

    1. 安裝 Windows Server 2003 Service Pack 1 (SP1)、Enterprise 或 Standard Edition。

    2. 找出要用來執行安裝程式的使用者帳戶，並將帳戶加入本機的 [Administrators] 群組。

      這個帳戶通常會是您的使用者帳戶。在本指南中，這個帳戶是指 Domain\TFSSETUP，因為實際名稱是由您的組織決定。如需此帳戶需求的詳細資訊，請參閱設定 Team Foundation Server 所需的使用者帳戶。

    3. 建立 Proxy 專用的服務帳戶，並將帳戶加入 Team Foundation Server 上，Proxy 所服務之所有應用程式層伺服器中的 Team Foundation Server Valid Users 群組。

    4. 安裝 Internet Information Services 6.0 並啟用 ASP.NET。如需詳細資訊，請參閱 HOW TO：為 Team Foundation Server Proxy 安裝網際網路資訊服務。

    5. 如果您要將 Team Foundation Server Proxy 安裝到與 Team Foundation Server 不同的另一台電腦上，請確定該電腦上已安裝 Microsoft .NET Framework 2.0。

      若要進行確認，請依序按一下 [開始]、[控制台]、[新增或移除程式]，然後檢查 [目前安裝的程式] 清單。

      注意事項 注意事項

      若要安裝 Microsoft .NET Framework 2.0，請尋找安裝媒體上的 [proxy\wcu\dotNetFramework] 資料夾，並執行 dotnetFX。

    6. 請為 Microsoft .NET Framework 2.0 安裝在安裝媒體上提供的 Hotfix KB913393。

      在安裝媒體上尋找 Hotfix 的資料夾如 K913393，尋找適用您作業系統的可執行檔 (.exe)，然後按兩下該檔案安裝 Hotfix。

    7. 如果 Team Foundation Server 透過 Proxy 伺服器連接到網路，請確定已選取 [區域網路 (LAN) 設定] 的 [近端網址不使用 Proxy]。

      若要確認設定，請依序按一下 [開始]、[控制台]，然後按一下 [網際網路選項]。在 [連線] 索引標籤上，按一下 [區域網路設定]。在 [選取區域網路 (LAN) 設定] 對話方塊中，選取 [近端網址不使用 Proxy]。不過，您應清除這兩個選項的自動偵測功能。

      若沒有選取這個設定，Team Foundation Server Proxy 安裝程式就無法使用 Windows SharePoint Services 完成驗證，並且會拒絕存取。

  2. 在 Proxy 伺服器上，使用 Team Foundation Server 設定帳戶 (例如，Domain\TFSSETUP) 登入 Windows。在 Team Foundation Server 安裝媒體上，找出 [\proxy] 資料夾並執行 setup。

    Visual Studio 2005 Team Foundation Server Proxy 安裝精靈隨即啟動。

  3. 在 [歡迎使用安裝程式] 頁面中，按 [下一步]。

  4. 在 [授權條款和產品金鑰] 頁面中，檢閱授權合約。如果您接受這些條款和條件，請選取 [我接受授權合約]，然後按 [下一步]。

  5. 在 [系統健康檢查] 頁面上，按一下 [報告] 連結檢查所有警告或阻礙情形。

    • 開始安裝之前，一定要先把阻礙情形排除。按一下 [取消]，並在修正所有問題之後再次執行安裝程式。

    • 雖然您應該先把警告處理好之後再繼續進行安裝，不過警告應該不會阻礙安裝程式完成。您可以按 [下一步]。

    • 如果未列出任何項目，請按 [下一步]。

  6. 在 [目的資料夾] 頁面中，接受預設目的資料夾，然後按 [下一步]。

  7. 在 [快取資料夾] 頁面中，接受預設路徑和資料夾，然後按 [下一步]。

    注意事項 注意事項

    您指定的資料夾應擁有足夠的可用空間，以便將您預期的檔案快取至此處。

  8. 在 [服務帳戶] 頁面中，於 [帳戶名稱] 方塊中輸入您為 Team Foundation Server 服務帳戶建立的 Windows 網域使用者帳戶 (例如，Domain\TFSSERVICE)，並在 [密碼] 方塊中輸入密碼，然後按 [下一步]。如需詳細資訊，請參閱設定 Team Foundation Server 所需的使用者帳戶。

  9. 在 [已完成安裝準備工作] 頁面中，按一下 [安裝]。

  10. 在 [安裝元件] 頁面上可以監視 Team Foundation Server Proxy 的安裝。

  11. 在 [安裝成功] 頁面中按一下 [完成]，Internet Explorer 隨即出現。

  12. 在 [設定 Team Foundation Version Control Proxy] 頁面上，按照指示設定 Proxy。

    注意事項 注意事項

    必須先設定 Team Foundation Server Proxy，才能加以使用。如果這個頁面未出現，請在安裝媒體上尋找並開啟 ProxyConfig.htm。

安全性

您必須是電腦上 [Administrators] 安全性群組的成員，才能執行此程序。本手冊中用來進行安裝的使用者帳戶稱為 Domain\TFSSETUP。如需詳細資訊，請參閱設定 Team Foundation Server 所需的使用者帳戶。

請參閱

其他資源

Team Foundation Server Proxy 安裝概觀


HOW TO：設定 Team 總管以使用 Team Foundation Server Proxy

HOW TO：設定 Team 總管以使用 Team Foundation Server Proxy

描述如何將 Team 總管 設定為使用 Team Foundation Server Proxy。

設定 Team 總管使用 Team Foundation Server Proxy

  1. 啟動 Microsoft Visual Studio 2005。

  2. 在 [工具] 功能表上按一下 [選項]。

  3. 展開 [原始檔控制]，然後按一下 [Visual Studio Team Foundation]。

  4. 選取 [使用 Proxy 伺服器]。

  5. 在 [Team Foundation Server 名稱] 方塊中，輸入裝載 Team Foundation Server Proxy 的電腦名稱。

  6. 在 [通訊埠] 方塊中，輸入「8081」。

  7. 在 [通訊協定] 中，選取 [Http]。

  8. 按一下 [確定]。

安全性

您必須是該電腦 Users 安全群組的成員，才能進行這個程序。

請參閱

其他資源

Team Foundation Server Proxy 安裝概觀


Team 總管安裝概觀

Team 總管安裝概觀
DropDown image

請使用本節中的程序來安裝和設定 Team 總管。可以在與 Team Foundation 應用程式層相同的電腦或不同的電腦上安裝 Team 總管。

在本節中

HOW TO：安裝 Team 總管必要條件

描述如何安裝 Team 總管必要條件。

HOW TO：安裝 Team 總管

描述如何安裝 Team 總管。

HOW TO：將 Team 總管連接到 Team Foundation Server

描述如何從 Team 總管連接到 Team Foundation Server。

相關章節

Team Foundation 系統需求

提供安裝 Team Foundation Server 這個版本的硬體和軟體系統需求。

Team Foundation Server 安裝程式安全性概觀

提供安裝 Team Foundation Server 的安全性相關資訊。

Team Foundation Server 單一伺服器部署

請使用本節中的程序，在一部伺服器上安裝和設定 Team Foundation Server。

Team Foundation Server 雙重伺服器部署概觀

請使用本節中的程序，在兩部電腦上安裝和設定 Team Foundation Server：一部用於資料層元件，而另一部用於應用程式層元件。

Team Foundation Build 安裝概觀

請使用本節中的程序來安裝和設定 Team Foundation Build，以便提供組建 Automation 來協助您建置並共用 Visual Studio 2005 方案。

Team Foundation Server Proxy 安裝概觀

請使用本節中的程序來安裝 Team Foundation Server Proxy，以便快取之前存取的原始檔控制檔案。

請參閱

概念

Team Foundation 安裝


HOW TO：安裝 Team 總管必要條件

HOW TO：安裝 Team 總管必要條件

請使用這個程序安裝 Team 總管必要條件。

若要安裝用戶層的必要條件

  1. 根據 Visual Studio 2005 Readme 中的指定項目，安裝符合 Visual Studio 2005 系統需求的作業系統。

    注意事項 注意事項

    如果要將 Team Foundation 用戶層安裝在與 Team Foundation 應用程式層相同的電腦上，請在安裝用戶層元件之前完成應用程式層的安裝。

  2. 請造訪 Windows Update (http://windowsupdate.microsoft.com) 並安裝重大更新和 Service Pack 群組中的所有項目。

  3. 安裝 Microsoft Office Excel 2003。在安裝精靈的 [安裝類型] 頁面上，選取 [完整安裝]。

    注意事項 注意事項

    如果選擇要自訂安裝功能，必須安裝 .NET 程式設計支援，才能使用 Visual Studio Team System 整合功能。

  4. 安裝 Microsoft Office Project Professional 2003。在安裝精靈的 [安裝類型] 頁面上，選取 [完整安裝]。

    注意事項 注意事項

    如果選擇要自訂安裝功能，必須安裝 .NET 程式設計支援，才能使用 Visual Studio Team System 整合功能。

  5. 請造訪 Windows Update (http://windowsupdate.microsoft.com) 並安裝重大更新和 Service Pack 群組中的所有項目。

  6. 造訪 Office 更新 (http://office.microsoft.com/officeupdate) 並安裝任何可用的更新。

Internet Explorer Enhanced Security Configuration

如果要在 Windows Server 2003 上安裝 Team 總管，需要套用 Windows 2000 預設的 Internet Explorer 安全性設定，以啟用用戶端的 Team Foundation 功能。若要在 Windows Server 2003 上套用 Windows 2000 的預設 Internet Explorer 安全性設定，就必須停用 Internet Explorer Enhanced Security Configuration。

注意事項 重要資訊

套用 Windows 2000 預設的 Internet Explorer 安全性設定會增加伺服器遭受惡意 Web 架構內容攻擊的可能性。

若要套用 Windows 2000 預設的 Internet Explorer 安全性設定

  1. 在 [控制台] 中，按一下 [新增或移除程式]，然後按一下 [新增/移除 Windows 元件]。

  2. 請清除 [Internet Explorer Enhanced Security Configuration] 核取方塊，然後按 [下一步]。

  3. 按一下 [完成]。

  4. 重新啟動 Internet Explorer 以套用變更。

安全性

您必須是電腦上 [Administrators] 安全性群組的成員，才能執行這些程序。

請參閱

其他資源

Team 總管安裝概觀


HOW TO：安裝 Team 總管

HOW TO：安裝 Team 總管

請使用這個程序安裝 Team 總管。

若要安裝 Team 總管

  1. 完成安裝 Team 總管的必要條件。如需詳細資訊，請參閱 HOW TO：安裝 Team 總管必要條件。

  2. 在 Team Foundation Server 安裝精靈的自動執行頁面上，按一下 [安裝 Team Explorer]。

    如果自動執行頁面並未顯示，請在安裝媒體的上的 \tfc 資料夾中找到並執行自動執行檔 (autorun.exe)。

    Visual Studio 2005 Team 總管安裝精靈隨即啟動。

  3. 在 [歡迎使用安裝程式] 頁面中，按 [下一步]。

  4. 在 [授權合約和產品金鑰] 頁面中，檢閱授權合約。如果您接受這些條款和條件，請選取 [我接受授權合約]，然後按 [下一步]。

  5. 在 [目的資料夾] 頁面中，按 [下一步]。

  6. 在 [已完成安裝準備工作] 頁面中，按一下 [安裝]。

  7. 在 [安裝成功] 頁面中，按一下 [完成]。

注意事項 重要資訊

如果您以前安裝過 MSDN Library for Visual Studio 2005，應該執行最新版的 MSDN Library 安裝程式，確保擁有 Team Foundation 的最新產品文件。如需詳細資訊，請參閱＜Team System 文件目錄＞(http://go.microsoft.com/fwlink/?LinkId=62213)。

安全性

您必須是電腦上 [Administrators] 安全性群組的成員，才能執行此程序。

請參閱

其他資源

Team 總管安裝概觀


HOW TO：將 Team 總管連接到 Team Foundation Server

HOW TO：將 Team 總管連接到 Team Foundation Server

請使用這個程序對 Team 總管加入並連接 Team Foundation Server，或從 Team 總管移除 Team Foundation Server。

若要加入 Team Foundation Server

  1. 啟動 Microsoft Visual Studio 2005。

  2. 在 [工具] 功能表上，按一下 [連接到 Team Foundation Server]。

    [連接到 Team Foundation Server] 對話方塊隨即顯示。

  3. 按一下 [伺服器]。

    [新增/移除 Team Foundation Server] 對話方塊隨即顯示。

  4. 按一下 [加入]。

    [加入 Team Foundation Server] 對話方塊隨即顯示。

  5. 在 [Team Foundation Server 名稱] 方塊中，輸入裝載 Team Foundation Server 應用程式層的電腦名稱。

  6. 在 [通訊埠編號] 方塊中，指定要用於此連接的通訊埠 (預設的 HTTP 通訊埠是 8080)，然後選取對應的通訊協定。

  7. 按一下 [確定] 回到 [新增/移除 Team Foundation Server] 對話方塊。

  8. 按一下 [關閉] 回到 [連接到 Team Foundation Server] 對話方塊。

  9. 如果這個 Team Foundation Server 上有任何 Team 專案存在，請選取您要使用的專案。

  10. 按一下 [確定]。

若要連接到 Team Foundation Server

  1. 啟動 Microsoft Visual Studio 2005。

  2. 在 [工具] 功能表上，按一下 [連接到 Team Foundation Server]。

    [連接到 Team Foundation Server] 對話方塊隨即顯示。

  3. 在 [連接到 Team Foundation Server] 清單中，選取要使用的 Team Foundation Server。

  4. 如果這個 Team Foundation Server 上有任何 Team 專案存在，請選取您要使用的專案。

  5. 按一下 [確定]。

若要移除 Team Foundation Server

  1. 啟動 Microsoft Visual Studio 2005。

    注意事項 注意事項

    如果您目前還與您想要移除的伺服器連線著，請用滑鼠右鍵按一下該伺服器的名稱，然後按一下 [中斷連接] 將連線切斷。

  2. 在 [工具] 功能表上，按一下 [連接到 Team Foundation Server]。

    [連接到 Team Foundation Server] 對話方塊隨即顯示。

  3. 按一下 [伺服器]。

    [新增/移除 Team Foundation Server] 對話方塊隨即顯示。

  4. 在 [Team Foundation Server 清單] 中選取要移除的 [Team Foundation Server]，然後按一下 [移除]。

  5. 按一下 [關閉] 回到 [Team Foundation Server] 對話方塊，然後按一下 [確定]。

安全性

要執行這些程序，您必須是 Readers 安全群組的成員，或至少要有一項 Team 專案使用權限設定為 [允許] 才行。如需詳細資訊，請參閱《Team Foundation Server 管理員手冊》中的＜Team Foundation Server 使用權限＞。

請參閱

其他資源

Team 總管安裝概觀


修復及解除安裝 Team Foundation Server 概觀

修復及解除安裝 Team Foundation Server 概觀
DropDown image

請使用本節中的程序解除安裝 Team Foundation Server 及所有相關元件。

在本節中

HOW TO：解除安裝 Team Foundation Server 單一伺服器部署

說明從伺服器移除 Team Foundation Server 元件的步驟。

HOW TO：解除安裝 Team Foundation Server 雙重伺服器部署

說明將 Team Foundation Server 元件從應用程式層伺服器和資料層伺服器移除的步驟。

HOW TO：解除安裝 Team Foundation Build

說明從伺服器移除 Team Foundation Build 元件的步驟。

HOW TO：修復或解除安裝 Team Foundation Server Proxy

說明還原或將 Team Foundation Server Proxy 從伺服器移除的步驟。

HOW TO：修復或解除安裝 Team 總管

說明還原或移除 Team 總管元件的步驟。

HOW TO：修復 Team Foundation Server

說明將 Team Foundation Server 元件還原為原始狀態的方法。

相關章節

Team Foundation 安裝


HOW TO：解除安裝 Team Foundation Server 單一伺服器部署

HOW TO：解除安裝 Team Foundation Server 單一伺服器部署

如果您必須解除安裝，則應按照安裝元件的相反順序移除 Team Foundation Server 及其相關元件，如下表所示：

順序 | 元件 | 實體位置
1. | Team Foundation Server Proxy | Team Foundation Server 電腦 -或- 不同的電腦
2. | Team Foundation Build | Team Foundation Server 電腦 -或- 不同的電腦
3. | Team 總管 | Team Foundation Server 電腦 -或- 不同的電腦
4. | Team Foundation Server | Team Foundation Server 電腦
5. | Microsoft Windows SharePoint Services | Team Foundation Server 電腦
6. | Microsoft SQL Server 2005 | Team Foundation Server 電腦
7. | Internet Information Services | Team Foundation Server 電腦
注意事項 注意事項

解除安裝 Visual Studio Team System 並不會刪除資料或移除資料庫。

解除安裝 Team Foundation Server 用戶端元件

如果您已在應用程式層電腦上安裝用戶層元件，則應先將這些元件解除安裝。

解除安裝用戶層元件

  1. 解除安裝 Team Foundation Server Proxy。如需詳細資訊，請參閱 HOW TO：修復或解除安裝 Team Foundation Server Proxy。

  2. 解除安裝 Team Foundation Build。如需詳細資訊，請參閱 HOW TO：解除安裝 Team Foundation Build。

  3. 解除安裝 Team 總管。如需詳細資訊，請參閱 HOW TO：修復或解除安裝 Team 總管。

解除安裝 Team Foundation Server (服務)

您必須先解除安裝 Team Foundation Server，才能解除安裝其他相關元件。Team Foundation Server 服務、TFSServer Scheduler 和 [程式碼涵蓋範圍分析] 都會移除。使用者資料和 Windows SharePoint Services 及應用程式集區則會保留。

解除安裝 Team Foundation Server

  1. 按一下 [開始]，選取 [控制台]，再按一下 [新增或移除程式]。

  2. 選取 [Microsoft Visual Studio 2005 Team Foundation Server]，然後按一下 [變更/移除]。

  3. 在 [維護模式選項] 頁面上，選取 [解除安裝]，然後按 [下一步]。

  4. 在訊息方塊中，按一下 [確定]。

  5. 在 [維護 - 解除安裝] 上，監控元件移除的進度。

  6. 在 [維護 - 安裝程式完成] 頁面中，按一下 [完成]。

解除安裝 Microsoft Windows SharePoint Services

解除安裝 Team Foundation Server 之後，即可解除安裝 Windows SharePoint Services (如有需要)。

解除安裝 Microsoft Windows SharePoint Services

  1. 按一下 [開始]，選取 [控制台]，再按一下 [新增或移除程式]。

  2. 選取 [Microsoft Windows SharePoint Services 2.0]，然後按一下 [移除]。

  3. 在訊息方塊中，按一下 [是]。

    對話方塊隨即出現，表示正在進行解除安裝。解除安裝完成後，此對話方塊便會自動關閉。

解除安裝 Microsoft SQL Server 2005

解除安裝 Windows SharePoint Services 之後，就可以移除 Microsoft SQL Server 2005 (如有需要)。

解除安裝 Microsoft SQL Server 2005

  1. 按一下 [開始]，選取 [控制台]，再按一下 [新增或移除程式]。

  2. 選取 [Microsoft SQL Server 2005]，然後按一下 [移除]。

  3. 在 [元件選擇] 頁面中的 [選取執行個體] 下，選擇要移除的伺服器。

    注意事項 注意事項

    按一下 [報告] 按鈕，檢視電腦上安裝的 SQL Server 2005 元件及功能的清單。

  4. 在 [移除 SQL Server 2005 一般元件] 下，選取要解除安裝的元件。

  5. 按 [下一步]。

  6. 在 [確認] 頁面中，檢閱要移除之元件及功能的清單，然後按一下 [完成]。

  7. 在 [完成] 頁面中按一下 [結束]。

解除安裝網際網路資訊服務

解除安裝 Microsoft SQL Server 2005 之後，就可以移除網際網路資訊服務 (如有需要)。

若要解除安裝網際網路資訊服務

  1. 按一下 [開始]，然後按一下 [設定您的伺服器精靈]。

  2. 在 [歡迎使用設定您的伺服器精靈] 頁面中，按 [下一步]。

  3. 在 [預備步驟] 頁面上，按 [下一步]。

  4. 在 [伺服器角色] 頁面上，選取 [應用程式伺服器 (IIS，ASP.NET)]，然後按 [下一步]。

  5. 按一下 [完成]。

安全性

您必須是電腦上 [Administrators] 安全性群組的成員，才能執行此程序。如需詳細資訊，請參閱設定 Team Foundation Server 所需的使用者帳戶。

請參閱

參考

檢查清單：Team Foundation Server 單一伺服器部署

其他資源

修復及解除安裝 Team Foundation Server 概觀


HOW TO：解除安裝 Team Foundation Server 雙重伺服器部署

HOW TO：解除安裝 Team Foundation Server 雙重伺服器部署

如果您必須解除安裝，則應按照安裝元件的相反順序移除 Team Foundation Server 及其相關元件，如下表所示：

順序 | 元件 | 實體位置
1. | Team Foundation Server Proxy | 應用程式層電腦 -或- 不同的電腦
2. | Team Foundation 原始檔控制 | 應用程式層電腦 -或- 不同的電腦
3. | Team 總管 | 應用程式層電腦 -或- 不同的電腦
4. | Team Foundation Server (服務) | 應用程式層電腦
5. | Microsoft SQL Server 2005 Reporting Services | 應用程式層電腦
5. | Team Foundation Server 的 Microsoft Windows SharePoint Services | 應用程式層電腦
6. | Team Foundation Server 的網際網路資訊服務 | 應用程式層電腦
7. | Team Foundation Server (資料庫) | 資料層電腦
8. | Team Foundation Server 的 Microsoft SQL Server 2005 | 資料層電腦
注意事項 注意事項

將 Team Foundation Server 資料庫解除安裝並不會刪除資料或移除資料庫。

按照下列各節的說明執行，即可順利將雙重伺服器上安裝的 Team Foundation Server 解除安裝。

解除安裝 Team Foundation Server 用戶端元件

如果您已在應用程式層電腦上安裝用戶層元件，則應先將這些元件解除安裝。

解除安裝用戶層元件

  1. 解除安裝 Team 總管。如需詳細資訊，請參閱 HOW TO：修復或解除安裝 Team 總管。

  2. 解除安裝 Team Foundation Server Proxy。如需詳細資訊，請參閱 HOW TO：修復或解除安裝 Team Foundation Server Proxy。

  3. 解除安裝 Team Foundation Build。如需詳細資訊，請參閱 HOW TO：解除安裝 Team Foundation Build。

解除安裝 Team Foundation Server (服務)

您必須先將應用程式層服務的所有元件解除安裝，才能將資料庫層電腦上的所有元件解除安裝。

精靈會移除 Team Foundation Server 相關的應用程式集區、網站、檔案、登錄及防火牆設定。使用者資料則不會移除。Windows SharePoint Services 仍會留在原處。Team Foundation Server 服務、TFSServer Scheduler 和 [程式碼涵蓋範圍分析] 都會移除。

解除安裝 Team Foundation Server (服務)

  1. 在應用程式層電腦上按一下 [開始]，按一下 [控制台]，然後按一下 [新增或移除程式]。

  2. 選取 [Microsoft Visual Studio 2005 Team Foundation Server (服務)]，然後按一下 [變更/移除]。

  3. 在 [維護模式選項] 頁面上，選取 [解除安裝]，然後按 [下一步]。

  4. 在訊息方塊中，按一下 [確定]。

  5. 在 [維護 - 解除安裝] 頁面上，查看元件移除的進度。

  6. 在 [維護 - 安裝程式完成] 頁面中，按一下 [完成]。

完成解除安裝 Team Foundation Server (服務) 之後，即可將 Windows SharePoint Services 解除安裝。

解除安裝 Team Foundation Server 的 Microsoft Windows SharePoint Services

  1. 按一下 [開始]，然後按一下 [控制台]，再按一下 [新增或移除程式]。

  2. 選取 [Microsoft Windows SharePoint Services 2.0]，然後按一下 [移除]。

  3. 在訊息方塊中，按一下 [是]。

    解除安裝完成後，此對話方塊便會自動關閉。

將網際網路資訊服務解除安裝也會停用 ASP.NET。

解除安裝 Team Foundation Server 的網際網路資訊服務

  1. 按一下 [開始]，然後按一下 [設定您的伺服器精靈]。

  2. 在 [歡迎使用設定您的伺服器精靈] 頁面中，按 [下一步]。

  3. 在 [預備步驟] 頁面上，按 [下一步]。

  4. 在 [伺服器角色] 頁面上，選取 [應用程式伺服器 (IIS，ASP.NET)]，然後按 [下一步]。

  5. 在 [角色移除確認] 頁面中，按一下 [移除應用程式伺服器角色]，然後按 [下一步]。

  6. 按一下 [完成]。

解除安裝 Team Foundation Server (資料庫)

完成解除安裝應用程式層電腦上所有 Team Foundation Server 相關的軟體後，即可解除安裝 Team Foundation Server (資料庫) 元件。

解除安裝 Team Foundation Server (資料庫)

  1. 在 [開始] 功能表上選取 [控制台]，然後按一下 [新增或移除程式]。

  2. 選取 [Microsoft Microsoft Visual Studio 2005 Team System (資料庫)]，然後按一下 [變更/移除]。

  3. 在 [維護模式選項] 頁面上，選取 [解除安裝]，然後按 [下一步]。

  4. 在 [維護 - 解除安裝] 頁面上，查看元件移除的進度。

  5. 在訊息方塊中，按一下 [確定]。

  6. 在 [完成] 頁面中按一下 [完成]。

解除安裝 Visual Studio Team System Server 並不會刪除資料或移除資料庫。

解除安裝 Team Foundation Server 的 Microsoft SQL Server 2005

  1. 登入資料層電腦。

    警告事項 警告

    如果您要在叢集上進行解除安裝，則需登入使用中的叢集節點。在使用中節點上解除安裝後，叢集會進行容錯移轉，並移轉至另一個節點。您必須登入該節點，才能在該節點上繼續解除安裝。

  2. 按一下 [開始]，選取 [控制台]，再按一下 [新增或移除程式]。

  3. 選取 [Microsoft SQL Server 2005]，然後按一下 [移除]。

  4. 在 [元件選擇] 頁面中的 [選取執行個體] 下，選擇要移除的伺服器。

    注意事項 注意事項

    按一下 [報告] 按鈕，檢視電腦上安裝的 SQL Server 2005 元件及功能的清單。

  5. 在 [移除 SQL Server 2005 一般元件] 下，選取要解除安裝的元件。

  6. 按 [下一步]。

  7. 在 [確認] 頁面中，檢閱要移除之元件及功能的清單，然後按一下 [完成]。

  8. 在 [完成] 頁面中按一下 [結束]。

安全性

您必須是電腦上 [Administrators] 安全性群組的成員，才能執行這些程序。如需詳細資訊，請參閱設定 Team Foundation Server 所需的使用者帳戶。

請參閱

其他資源

修復及解除安裝 Team Foundation Server 概觀


HOW TO：解除安裝 Team Foundation Build

HOW TO：解除安裝 Team Foundation Build

Team Foundation Build 是 Team Foundation Server 的用戶端，因此解除安裝此軟體，只會移除用戶端元件而已。系統安裝完畢後，您加入用來支援組件的其他元件、程式或動態連結程式庫 (DLL) 還是會繼續留著。請用以下程序解除安裝 Team Foundation Build。

若要解除安裝 Team Foundation Build

  1. 按一下 [開始]，選取 [控制台]，再按一下 [新增或移除程式]。

  2. 選取 [Microsoft Visual Studio 2005 Team Foundation Server (組件)]，然後按一下 [變更/移除]。

  3. 在 [維護模式選項] 頁面中，選取 [解除安裝]，然後按 [下一步]。

  4. 在 [維護 - 解除安裝] 頁面中，查看元件移除的進度。

  5. 在 [維護 - 安裝程式完成] 頁面中，按一下 [完成]。

安全性

您必須是電腦上 [Administrators] 安全性群組的成員，才能執行此程序。如需詳細資訊，請參閱設定 Team Foundation Server 所需的使用者帳戶。

請參閱

其他資源

修復及解除安裝 Team Foundation Server 概觀
Team Foundation Build 安裝概觀


HOW TO：修復或解除安裝 Team Foundation Server Proxy

HOW TO：修復或解除安裝 Team Foundation Server Proxy

請用以下程序修復或解除安裝 Team Foundation Server Proxy。

注意事項 注意事項

修復程序需要重新啟動 Proxy 電腦。

修復 Team Foundation Server Proxy

  1. 登入該 Proxy 電腦，在 [開始] 功能表上按一下 [控制台]，然後選取 [新增或移除程式]。

  2. 選取 [Microsoft Visual Studio 2005 Team Foundation Server Proxy]，然後按一下 [變更/移除]。

  3. 在 [維護模式選項] 頁面中，選取 [修復/重新安裝]，然後按 [下一步]。

  4. 在 [服務帳戶] 頁面上，輸入此服務帳戶的密碼。

    注意事項 注意事項

    服務帳戶是指您公司所設定的帳戶。本手冊以 Domain/TFSPROXY 代表此帳戶。

  5. 在 [維護 - 修復/重新安裝] 頁面上，檢查元件清單，並在提示時按一下 [立即重新啟動]。

  6. 登入這台 Proxy 電腦，按一下 [維護 - 安裝程式完成] 頁面上的 [完成]。

    注意事項 注意事項

    如果您先前是從遠端登入，現在必須直接在這台電腦前登入才行。

解除安裝 Team Foundation Server Proxy

  1. 按一下 [開始]，選取 [控制台]，再按一下 [新增或移除程式]。

  2. 在 [新增或移除程式] 對話方塊中，選取 [Microsoft Visual Studio 2005 Team Foundation Server (proxy)]，然後按一下 [變更/移除]。

  3. 按一下 [維護模式選項] 頁面上的 [解除安裝]。

  4. 在提示時按一下 [是]。

  5. 在 [維護 - 安裝程式完成] 頁面中，按一下 [完成]。

安全性

您必須是該 Proxy 電腦 Administrators 安全群組的成員，才能進行這項程序。如需詳細資訊，請參閱設定 Team Foundation Server 所需的使用者帳戶。

請參閱

其他資源

修復及解除安裝 Team Foundation Server 概觀
Team Foundation Server Proxy 安裝概觀


HOW TO：修復或解除安裝 Team 總管

HOW TO：修復或解除安裝 Team 總管

以下程序可以將 Team 總管還原到原來的狀態，也可以解除安裝 Team 總管。

修復 Team 總管

使用 Team 總管時如果遇到非預期的結果，可以試試修復所安裝的軟體。

修復 Team 總管

  1. 在 [開始] 功能表上按一下 [控制台]，然後選取 [新增或移除程式]。

  2. 選取 [Microsoft Visual Studio 2005 Team Foundation Server (資料庫)]，然後按一下 [變更/移除]。

  3. 在 [維護模式選項] 頁面中，選取 [修復/重新安裝]，然後按 [下一步]。

  4. 在 [已完成安裝準備工作] 頁面中，按一下 [安裝]。

  5. 在 [維護 - 修復/重新安裝] 頁面中可以看到安裝進度。

  6. 當系統出現提示時，按一下 [立即重新啟動]，然後等系統重新啟動。

    注意事項 注意事項

    Microsoft .NET Framework 2.0 版是其它元件的必要條件，因此電腦應該重新啟動。

  7. 登入此電腦，讓安裝程式繼續進行。

  8. 在 [維護 - 修復/重新安裝] 頁面中可以看到安裝進度。

  9. 當系統出現提示時，按一下 [立即重新啟動]，然後等系統重新啟動。

  10. 登入此電腦，讓安裝程式繼續進行。

  11. 在 [維護 - 安裝程式完成] 頁面中，按一下 [完成]。

解除安裝 Team 總管

如果您不再需要用到電腦上的 Team 總管，可以將它移除。

若要解除安裝 Team 總管

  1. 在 [開始] 功能表上按一下 [控制台]，然後選取 [新增或移除程式]。

  2. 選取 [Microsoft Visual Studio 2005 Team Foundation Server (資料庫)]，然後按一下 [變更/移除]。

  3. 在 [維護模式選項] 頁面中，選取 [解除安裝]，然後按 [下一步]。

  4. 在訊息方塊中，按一下 [確定]。

  5. 在 [維護 - 解除安裝] 頁面中，查看元件移除的進度。

  6. 在 [維護 - 安裝程式完成] 頁面中，按一下 [完成]。

安全性

您必須是電腦上 [Administrators] 安全性群組的成員，才能執行此程序。如需詳細資訊，請參閱設定 Team Foundation Server 所需的使用者帳戶。

請參閱

其他資源

修復及解除安裝 Team Foundation Server 概觀
Team 總管安裝概觀


HOW TO：修復 Team Foundation Server

HOW TO：修復 Team Foundation Server

以下程序可以將 Team Foundation Server 元件還原成原來的狀態，也可以重新安裝 Team Foundation Server 需要的元件。

修復 Team Foundation Server (資料庫)

修復 Team Foundation Server (資料庫)

  1. 按一下 [開始]，選取 [控制台]，再按一下 [新增或移除程式]。

  2. 選取 [Microsoft Visual Studio 2005 Team Foundation Server (資料庫)]，然後按一下 [變更/移除]。

  3. 在 [維護模式選項] 頁面中，選取 [修復/重新安裝]，然後按 [下一步]。

  4. 在 [服務帳戶] 頁面的 [帳戶名稱] 方塊內，輸入先前您為 Team Foundation Server 服務帳戶建立的網域使用者帳戶，然後按 [下一步]。

    注意事項 注意事項

    服務帳戶是指您公司所設定的帳戶。本手冊以 Domain/TFSSERVICE 代表此帳戶。

  5. 在 [已完成安裝準備工作] 頁面中，確認所有資訊後，按一下 [安裝]。

    畫面上便會出現 [維護 - 修復/重新安裝] 頁面。

  6. 在 [維護 - 安裝程式完成] 頁面中，按一下 [完成]。

修復 Team Foundation Server (服務)

修復 Team Foundation Server (服務)

  1. 登入應用程式層。

  2. 按一下 [開始]，選取 [控制台]，再按一下 [新增或移除程式]。

  3. 選取 [Microsoft Visual Studio 2005 Team Foundation Server (服務)]，然後按一下 [變更/移除]。

  4. 在 [維護模式選項] 頁面中，選取 [修復/重新安裝]，然後按 [下一步]。

  5. 在 [服務帳戶] 頁面上，輸入此服務帳戶的密碼。

    注意事項 注意事項

    服務帳戶是指您公司所設定的帳戶。本手冊以 Domain/TFSSERVICE 代表此帳戶。

  6. 當 [報告資料來源帳戶] 出現時，輸入 Reporting Services 帳戶的密碼。

    注意事項 注意事項

    此帳戶是指您公司所設定的帳戶。本手冊以 Domain/TFSREPORTS 代表此帳戶。

  7. 在 [已完成安裝準備工作] 頁面中，確認所有元件後，按一下 [安裝]。

  8. 在 [維護 - 修復/重新安裝] 頁面上可以看到安裝進度。

  9. 在 [維護 - 安裝程式完成] 頁面中，按一下 [完成]。

安全性

您必須是電腦上 [Administrators] 安全性群組的成員，才能執行此程序。如需詳細資訊，請參閱設定 Team Foundation Server 所需的使用者帳戶。

請參閱

其他資源

修復及解除安裝 Team Foundation Server 概觀


Team Foundation 安裝指南法律注意事項

Team Foundation 安裝指南法律注意事項
全部折疊影像 下拉影像

本節提供與＜Team Foundation 安裝指南＞相關的法律注意事項。

展開影像 法律注意事項

此文件僅做為資訊提供之用，Microsoft 在此文件中不做任何明示或暗示的擔保。本文件之資訊，包括 URL 和其他網際網路的網站參考，修改後不另行通知。由於使用此文件而導致的全部風險或結果，均由使用者承擔。除非特別註明，否則本文件中所述，用來舉例之公司、組織、產品、網域名稱、電子郵件位址、標誌、人物、場所和事件皆為虛構，沒有意圖或不應該推斷為與任何真實存在的公司、組織、產品、網域名稱、電子郵件位址、標誌、人物、場所或事件有所關聯。承諾遵守所有適用的著作權法是使用者的責任。著作權法沒有針對某種權利加以限制，但在未獲得 Microsoft Corporation 書面同意的情況下，本文件的任何部分不得複製、以檢索系統存放或擷取、以任何形式或方法傳送 (電子、機械、影像複製、錄音或其他任何方法)、或基於任何其他不良意圖。

本文件所提及的主要事務，Microsoft 得擁有專利、專利應用程式、商標、著作權或其他智慧財產權。除了 Microsoft 於授權合約書中書面提供的之外，本文件所述內容並未賦予您這些專利、商標、著作權、或其他智慧財產的任何授權或使用權利。

c 2005 Microsoft Corporation.All rights reserved.

Microsoft、Visual Studio、Windows、SharePoint 與 Windows Server 係 Microsoft Corporation 在美國和 (或) 其他國家 (地區) 的註冊商標或商標。

所有其他商標俱為各所有人之財產。