Page d'accueil SQL Server

 SQL Server 2000 (64 bits)

Différences entre les versions 32 bits et 64 bits

Documentation en ligne de SQL Server (64 - bits)

Support technique

  • Microsoft Product Support Services (PSS)
  • Microsoft SQL Server Support
  • Knowledge Base (KB) Search
  • Microsoft TechNet
  • Microsoft Windows Hardware Compatibility List

Site Web d'accessibilité Microsoft

Documentation imprimée de SQL Server

Livres blancs

Commentaires

Liens Internet

  • Microsoft SQL Server Product Web Site
  • Microsoft SQL Server Developer Center
  • Professional Association for SQL Server
  • SQL Server Magazine
  • Microsoft Newsgroups
  • MSDN Online
  • Microsoft SQL Server Web Site, English Query Page
  • Microsoft SQL Server Web Site, Analysis Services Page
  • XML Developer Center


Présentation de SQL Server 2000 (64 bits)

Cette rubrique s'applique uniquement à SQL Server 2000 (64 bits).

Microsoft® SQL Server™ 2000 (64 bits) fournit une prise en charge entièrement native de la version 64 bits du système d'exploitation de Microsoft Windows®. Cette version de SQL Server 2000 comporte non seulement de nombreuses fonctionnalités de la version 32 bits, mais fournit aussi la prise en charge du matériel étendu 64 bits. SQL Server 2000 (64 bits) exploite les fonctionnalités de grande capacité mémoire de la plate-forme Windows 64 bits, notamment une prise en charge pouvant aller jusqu'à 32 teraoctets de mémoire physique. SQL Server 2000 (64 bits) fournit de nouveaux niveaux d'évolutivité tout en offrant une compatibilité complète avec la version 32 bits de SQL Server 2000.

Rubrique | Description
À propos de cette version (64 bits) | Présente les nouveautés de cette version.
Éditions de SQL Server 2000 (64 bits) | Décrit les différentes éditions de SQL Server 2000 (64 bits)
Différences entre les versions 64 bits et 32 bits (64 bits) | Décrit les différences existant dans la version 64 bits de SQL Server 2000.
Envoi de commentaires (64 bits) | Fournit des instructions permettant d'envoyer des commentaires sur cette documentation.
Ressources supplémentaires (64 bits) | Décrit les adresses sur le Web permettant d'obtenir l'Aide et des informations.


À propos de cette version (64 bits)

Cette version de Microsoft® SQL Server™ 2000 (64 bits) inclut SQL Server 2000 (64 bits) Édition Entreprise. Pour l'exécuter, vous devez utiliser le système d'exploitation de Microsoft Windows® 64 bits : les versions 64 bits de la famille Windows ®Server 2003.

Documentation relative à cette version

Pour consulter le fichier de documentation relatif à l'installation, ouvrez le fichier Setupsql.chm qui se trouve à l'emplacement suivant : Systemdrive:\Program Files\Microsoft SQL Server\80\SetupBootstrap\Help\1033\.

Lorsque le programme d'installation aura terminé, vous pourrez consulter la documentation de Microsoft SQL Server en cliquant sur le bouton Aide, en appuyant sur la touche F1 dans les boîtes de dialogue ou les éléments d'interface, ou dans le menu Démarrer en sélectionnant Programmes, Microsoft SQL Server et Documentation en ligne.


Éditions de SQL Server 2000 (64 bits)

Cette version de Microsoft® SQL Server™ 2000 (64 bits) est disponible dans ces éditions :

SQL Server 2000 Édition Entreprise (64 bits)

Cette édition est utilisée en tant que serveur de base de données de production équipé d'un processeur 64 bits. Elle prend en charge la plupart des fonctionnalités disponibles dans la version 32 bits de SQL Server 2000, et s'adapte aux niveaux de performances nécessaires pour la prise en charge des principaux sites Web et des systèmes de traitement des transactions en ligne (OLTP) ainsi que du Data Warehousing. L'Édition Entreprise comporte trois fonctionnalités d'installation, à savoir SQL Server, Analysis Server et Books Online, ainsi que plusieurs sous-fonctionnalités. Par défaut, le programme d'installation installe les trois fonctionnalités et leurs sous-fonctionnalités. Dans la page Sélection des fonctionnalités de l'Assistant Installation, vous pouvez choisir et configurer les fonctionnalités à installer. Pour plus d'informations, reportez-vous à la rubrique Fonctionnalités de SQL Server 2000 (64 bits).


Différences entre les versions 64 bits et 32 bits (64 bits)

Cette section décrit les différences à prendre en considération lors de l'installation et de l'utilisation de la version 64 bits de Microsoft® SQL Server™ 2000.

Configuration et installation

Basée sur Windows Installer

SQL Server 2000 (64 bits) utilise le programme d'installation Windows Installer pour intégrer l'ensemble des fonctionnalités de SQL Server dans une arborescence des fonctionnalités unique. Les modes d'installation minimum et standard ne sont plus implémentés. Dès le départ, l'arborescence contient toutes les fonctionnalités disponibles sélectionnées. Pour personnaliser les installations, les administrateurs peuvent choisir des fonctionnalités dans l'arborescence et modifier les chemins d'installation.

Interaction de l'arborescence des fonctionnalités du programme d'installation avec les fonctionnalités parent/enfant

Dans cette version de SQL Server 2000 (64 bits), la sélection de fonctionnalités enfant est plus limitée que dans la version 32 bits. Par exemple, la fonctionnalité Outils installe tous les outils sans laisser la possibilité de n'en sélectionner que quelques-uns. De même, les composants serveur sont limités à SQL Server et au moteur de recherche de texte intégral. La sélection complète des fonctionnalités enfant sera possible dans la prochaine version majeure. L'option Connectivité uniquement n'est pas prise en charge

L'option Connectivité uniquement n'est pas implémentée pendant l'installation de SQL Server 2000 (64 bits). Dans les versions précédentes, l'option Connectivité uniquement installait JET et les composants MDAC (Microsoft Data Access Components). JET n'est pas disponible pour la version 64 bits de SQL Server 2000. Les composants MDAC 64 bits sont installés par les versions 64 bits de la famille Windows ®Server 2003 dans le cadre de ses composants principaux.

Installation à distance

SQL Server 2000 (64 bits) ne prend pas en charge l'installation à distance.

Mises à niveau de la version précédente

Les versions précédentes de SQL Server pour ordinateurs 32 bits ne sont pas prévues pour s'exécuter sur la plate-forme 64 bits ; les mises à niveau des instances 32 bits ne sont pas prises en charge dans cette version.

Migration de données

La migration des données de Server 2000 vers SQL Server 2000 (64 bits) n'est pas prise en charge. L'attachement d'une base de données 32 bits à une instance 64 bits est possible grâce à l'utilisation d'une procédure de détachement/attachement ou de sauvegarde/restauration dans Enterprise Manager 32 bits. Vous pouvez déplacer des bases de données entre des versions 32 bits et 64 bits de SQL Server. La migration des données à partir de la version SQL Server 7.0 est également prise à charge à l'aide des mêmes méthodes. Le téléchargement des données de la version SQL Server 2000 (64 bits) vers SQL Server 7.0 n'est pas prise en charge.

Documentation regroupée de SQL Server 2000 SP3 et de SQL Server 2000 (64 bits)

Cette documentation en ligne est commune à SQL Server 2000 Service Pack 3 (SP3) et à SQL Server 2000 (64 bits). Le sommaire de la Documentation en ligne est organisée par plate-forme : Le contenu 64 bits est regroupé dans un nœud intitulé "SQL Server 2000 (64 bits)", tandis que les rubriques 32 bits sont regroupées dans un nœud intitulé "SQL Server 2000".

Le contenu spécifique à la plate-forme 64 bits est identifié sous le titre de la rubrique de la façon suivante : "Cette rubrique s'applique uniquement à SQL Server 2000 (64 bits)". Le titre de toutes les rubriques 64 bits contient la mention "64 bits". Les rubriques dont le contenu est propre à SP3 contiennent la balise suivante sous leur titre : "informations nouvelles– SQL Server 2000 SP3". Toutes les rubriques 32 bits n'ont pas été mises à jour pour SP3.

Les entrées d'index présentant du contenu 32 bits et 62 bits ont été regroupées. Par conséquent, les recherches par mot clé peuvent renvoyer une liste associée de rubriques 32 bits et 64 bits. Les rubriques qui s'appliquent à SQL Server 64 bits sont identifiables par la balise "64 bits" figurant dans le titre de la rubrique et par la balise située sous le titre de la rubrique et qui indique "Cette rubrique s'applique uniquement à SQL Server 2000 (64 bits)".

Maintenance

Maintenance des fonctionnalités

SQL Server 2000 (64 bits) utilise l'application Ajout/Suppression de programmes du Panneau de configuration pour prendre intégralement en charge l'ajout et la suppression de fonctionnalités individuelles, ainsi que la suppression d'instances de SQL Server. Vous pouvez également utiliser l'interface utilisateur du programme d'installation ou la ligne de commande pour la maintenance de l'installation. La maintenance des fonctionnalités pour les installations organisées en clusters n'est pas prise en charge.

Maintenance des instances

Les activités de maintenance des installations existantes sont prise en charge par l'application Ajout/Suppression de programmes du Panneau de configuration ainsi que par le programme d'installation. Chaque instance installée (à l'exception des installations organisées en clusters) apparaît dans la boîte de dialogue Ajouter ou supprimer des programmes. Toute instance non organisée en clusters peut être supprimée ou modifiée à l'aide de cette boîte de dialogue. Vous pouvez effectuer la maintenance des instances sur la ligne de commande setup en spécifiant des fonctionnalités sur la ligne de commande ou dans un fichier .ini. Pour plus d'informations sur la maintenance des clusters, consultez la section sur la gestion de clusters avec basculement à la fin de cette rubrique.

Éditions et composants

Éditions prises en charge

Pour cette version, seule l'Édition Entreprise est disponible. SQL Server 2000 (64 bits) Desktop Engine n'est pas disponible.

Bibliothèques réseau

La page de configuration de la bibliothèque réseau ne fait pas partie de SQL Server 2000 (64 bits). Le programme d'installation active la mémoire partagée, les canaux nommés et TCP/IP. Utilisez l'utilitaire réseau SQL Server pour modifier les paramètres qui permettent d'activer ou de désactiver les protocoles. La configuration des bibliothèques réseau n'est pas prise en charge dans le programme d'installation, mais est encore prise en charge par l'utilitaire réseau SQL Server. Configurez les bibliothèques réseau clientes à l'aide de l'utilitaire réseau client (cliconfg.exe) inclus avec les versions 64 bits de la famille Windows Server 2003.

Services

La boîte de dialogue Compte de service prend en charge le compte du service SQL Server (MSSQLSERVER, MSSQL$<nom_instance>), du service Agent SQL (SQLSERVERAGENT, SQLAgent$<nom_instance>) et du service Analysis Services (MSSQLServerOLAPService). La boîte de dialogue Informations sur le compte à distance prend en charge le compte de l'administrateur de configuration du cluster qui sera utilisé lors de l'installation d'un serveur virtuel. La prise en charge de la ligne de commande permettant la configuration de ces comptes est également fournie.

Exemples de code

Le programme d'installation n'installe pas les exemples de code.

English Query

English Query n'est pas pris en charge.

Analysis Services

Analysis Services est intégré au programme d'installation de SQL Server

Analysis Services peut être installé en même temps que le moteur de base de données relationnelle de SQL Server et les autres composants SQL Server. Ce service fait partie de l'arborescence des fonctionnalités du programme d'installation Windows Installer, dans laquelle vous pouvez sélectionner les fonctionnalités que vous souhaitez inclure dans votre installation. Analysis Services apparaît dans l'arborescence des fonctionnalités avec les fonctionnalités enfant Data et SQL Repository.

Analysis Services utilise le référentiel SQL Server

La version 64 bits d'Analysis Services utilise SQL Server à la place de Jet (.MDB) pour son référentiel de métadonnées. Si la version complète de SQL Server n'est pas installée avec Analysis Services, la fonctionnalité enfant SQL Repository installe les principaux fichiers SQL Server et vous permet d'indiquer l'emplacement de ces fichiers.

Outils et utilitaires

Outils de gestion de l'interface utilisateur graphique

Pour administrer un serveur SQL Server 64 bits ou Analysis Server avec des outils de gestion tels qu'Enterprise Manager ou Analysis Manager, vous devez utiliser les outils 32 bits sur un serveur 32 bits afin d'administrer à distance le serveur 64 bits. Les seuls outils 64 bits inclus avec cette version sont l'utilitaire réseau serveur, le gestionnaire des services et les utilitaires de ligne de commande.

DTC (Distributed Transaction Coordinator) est installé avec les versions 64 bits de la famille Windows Server 2003

DTC fait partie des versions 64 bits du système d'exploitation de la famille Windows Server 2003 et n'est donc plus installé dans le cadre de l'installation de SQL Server 2000 (64 bits). Vous ne pouvez plus gérer le service DTC à partir du gestionnaire des services SQL Server. Pour gérer ce service, utilisez Services dans les versions 64 bits des Outils administratifs de la famille Windows Server 2003.

Les composants DTS (Data Transformation Services) pour les serveurs 64 bits ne sont pas disponibles dans cette version bêta 2. Voici les modifications de fonctionnalités qui en résultent :

  • Un lot DTS peut être enregistré sur le serveur 64 bits et exécuter par rapport à un jeu de données SQL Server 2000 (64 bits), à condition qu'il s'exécute sur une machine 32 bits configurée avec les outils SQL Server 2000.

  • L'Assistant Copie de base de données ne peut pas s'exécuter sur un serveur 64 bits ou cibler un serveur 64 bits. La migration des données de Server 2000 vers SQL Server 2000 (64 bits) n'est pas prise en charge. L'attachement d'une base de données 32 bits à une instance 64 bits est possible grâce à l'utilisation de la procédure de détachement/attachement ou de sauvegarde/restauration. Vous pouvez déplacer des bases de données entre des versions 32 bits et 64 bits de SQL Server.

  • Si vous utilisez les services MDS (Meta Data Services) pour stocker un lot DTS, vous devez gérer ce lot et le stocker un serveur 32 bits.

  • Les abonnements envoyés transformables ne sont pas pris en charge. Les abonnements envoyés pour une installation 32 bits SQL Server 2000 doivent fonctionner avec un éditeur ou un distributeur 64 bits.

SQL Mail

Cette version de SQL Server 2000 (64 bits) ne prend pas en charge SQL Mail. De ce fait, les procédures étendues et les procédures stockées suivantes ne sont plus prises en charge, puisqu'elles sont intégrées à la fonctionnalité SQL Mail :

  • xp_startmail

  • xp_stopmail

  • xp_sendmail

  • xp_readmail

  • xp_deletemail

  • xp_findnextmsg

  • sp_processmail

    Vous pouvez toutefois configurer à distance SQL Agent Mail dans SQL Server 2000 (64 bits) à l'aide d'Enterprise Manager, si votre client se connecte à distance à l'aide de SQL Server 2000 Service Pack 3.0 ou ultérieur.

    Pour configurer SQL Agent Mail, vous devez utiliser Microsoft Outlook® Express afin d'utiliser un compte de messagerie existant.

Pour créer un compte de messagerie pour SQL Agent Mail à l'aide d'Outlook Express

1. Dans le menu Démarrer, sélectionnez Outlook Express.

2. Dans le menu Outils, sélectionnez Comptes.

3. Dans la boîte de dialogue Comptes Internet, cliquez sur Ajouter, puis sur Messagerie. Vous avez ainsi la possibilité de créer un compte de messagerie en lançant l'Assistant Connexion Internet.

4. Dans la boîte de dialogue Votre nom de la zone Nom affiché, entrez le nom de l'expéditeur souhaité de tous les messages électroniques de SQL Server Agent.

5. Dans la boîte de dialogue Adresse électronique Internet de la zone Adresse électronique, entrez le compte de messagerie qui sera utilisé pour envoyer les messages électroniques de SQL Server Agent . Par exemple : personne@exemple.com.

6. Dans la boîte de dialogue Noms des serveurs de courrier électronique de la zone Mon serveur de courrier entrant est un, sélectionnez POP3 pour le type de serveur.

7. Dans la zone Serveur de courrier (POP3, IMAP ou HTTP) entrant, entrez le nom du serveur POP3. Si vous utilisez uniquement ce compte pour SQL Agent Mail, vous n'avez pas besoin de sélectionner un nom de serveur POP3 valide, puisque SQL Agent Mail ne reçoit pas de courrier électronique.

8. Dans la zone Serveur de courrier (SMTP) sortant, entrez un nom de serveur SMTP valide qui sera utilisé pour envoyer des messages de SQL Agent.

9. Dans la boîte de dialogue Connexion à la messagerie Internet de la zone Nom du compte, entrez le compte que vous souhaitez utiliser pour envoyer des notifications de SQL Server Agent.

10. Cliquez sur Suivant.

11. Cliquez sur Terminer.

Si vous utilisez Outlook Express 6.0 ou version ultérieure, vous devez configurer cette application de façon à ce qu'aucune alerte ne soit envoyée lorsque SQLAgentMail accède à votre compte Outlook Express.

Pour configurer SQLAgentMail avec Outlook Express 6.0

1. Dans le menu Outils d'Outlook Express, sélectionnez Options...

2. Sélectionnez l'onglet Sécurité, puis désactivez la case à cocher M'avertir lorsque d'autres applications essaient d'envoyer des messages électroniques de ma part.

3. Cliquez sur OK

Si un profil SMTP Outlook Express est déjà créé, vous pouvez l'utiliser pour SQL Agent Mail en le configurant en tant que compte par défaut.

Pour utiliser un compte de messagerie SMTP Outlook Express pour SQL Agent Mail

1. Dans le menu Démarrer, sélectionnez Outlook Express.

2. Dans le menu Outils, sélectionnez Comptes.

3. Dans la boîte de dialogue Comptes Internet, sélectionnez le compte de messagerie qui sera utilisé par défaut, puis cliquez sur le bouton Par défaut. Il doit s'agir d'un compte POP3/SMTP pour que SQL Agent Mail puisse fonctionner.

Si vous souhaitez modifier le nom de votre compte de messagerie après en avoir fait le compte par défaut, vous pouvez le renommer en SQLAgentMail. Le même nom de compte de messagerie sera utilisé pour configurer SQL Agent Mail dans Enterprise Manager.

Pour modifier le nom de votre profil pour SQL Agent Mail

1. Dans le menu Démarrer, sélectionnez Outlook Express.

2. Dans le menu Outils, sélectionnez Comptes.

3. Dans la boîte de dialogue Comptes Internet, sélectionnez le compte par défaut, puis cliquez sur le bouton Propriétés.

4. Dans la boîte de dialogue Propriétés, tapez le nom du profil dans la zone Compte de messagerie.

Dès lors que vous avez crée un compte de messagerie pour SQL Agent Mail, vous pouvez configurer SQL Agent Mail à l'aide d'Enterprise Manager.

Pour sélectionner le compte de messagerie dans Enterprise Manager pour SQL Agent Mail

1. Dans la boîte de dialogue Propriétés de l'Agent, sélectionnez l'onglet Général.

2. Dans la zone Profil de messagerie, sélectionnez le compte de messagerie Outlook Express précédemment configuré.

Pour plus d'informations sur la fonctionnalité SQL Agent Mail, reportez-vous à la documentation en ligne de SQL Server 2000 32 bits.

Outils clients uniquement

L'installation seule de la fonctionnalité Outils à partir de l'arborescence des fonctionnalités peut faciliter l'installation Outils clients uniquement. Notez que les outils de gestion de l'interface utilisateur graphique SQL Server ne font pas partie de cette version, sauf l'utilitaire réseau et le gestionnaire des services SQL Server. Les outils de ligne de commande sont disponibles.

Outils pris en charge

Les outils doivent être installés à partir du CD-ROM RTM de SQL Server 2000 (64 bits). Ceux qui proviennent d'un autre CD-ROM ne peuvent pas être installés dans le cadre d'une instance de SQL Server 2000 (64 bits). Pour utiliser des outils de gestion comme Enterprise Manager, utilisez une instance 32 bits de SQL Server, dans laquelle les outils de gestion sont installés pour administrer à distance les instances de SQL Server 2000 (64 bits).

Fichier d'enregistrement sans surveillance

Le fichier Template.ini fourni peut être modifié dans le cadre d'installations sans surveillance. SQL Server 2000 (64 bits) ne prend pas en charge la fonctionnalité de fichier d'enregistrement sans surveillance.

Outils de développement

La fonctionnalité Outils de développement n'est pas incluse dans l'arborescence des fonctionnalités. L'interface SDI (SQL Debugging Interface) est installée par le programme d'installation, mais n'est pas incluse dans le composant principal SQL Server Engine. Les autres outils de développement disponibles dans SQL Server 2000 (32 bits) (en-têtes et bibliothèques, SDK MDAC et API de sauvegarde/restauration) ne sont pas installés par le programme d'installation.

Pour plus d'informations sur MDAC et le statut de ses composants, reportez-vous à l'introduction à la documentation de MDAC

DB-Library

Le modèle de programmation DB-Library n'est pas pris en charge dans SQL Server 2000 (64 bits) et n'a pas été porté sur le système d'exploitation 64 bits de Windows. L'API DB-Library n'a pas été améliorée au-delà du niveau SQL Server 6.5. Toutes les applications DB-Library peuvent fonctionner avec SQL Server 2000, mais seulement en tant que clients de niveau 6.5. Les fonctions introduites dans SQL Server 2000 et SQL Server version 7.0 ne sont pas prises en charge par les applications DB-Library.

Reconstruction du registre et de la base de données master

Les utilitaires de reconstruction du registre et de la base de données master sont implémentés différemment dans les versions 64 bits de SQL Server 2000 et 32 bits. Dans la version 64 bits, SQL Server 2000 tire parti des fonctionnalités de réparation automatique fournies par le programme d'installation Windows Installer. De plus, les propriétés REINSTALL et REINSTALLMODE de la ligne de commande setup sont disponibles pour reconstruire explicitement le registre, réinstaller des fichiers manquants ou endommagés, réinstaller des raccourcis manquants ou endommagés et reconstruire les bases de données master. Vous pouvez spécifier ces propriétés sur la ligne de commande ou dans un fichier .ini.

Gestion de clusters avec basculement

Prise en charge des clusters

L'installation d'un cluster avec basculement est prise en charge pour une définition de cluster unique. La maintenance des fonctionnalités pour les installations organisées en clusters n'est pas prise en charge. Un fichier modèle .ini activant toutes les fonctionnalités de cluster prises en charge est fourni.

Maintenance des clusters

Puisqu'une seule définition de cluster est prise en charge, la maintenance des fonctionnalités à l'aide de l'application Ajout/Suppression de programmes du Panneau de configuration pour les installations organisées en cluster n'est pas prise en charge. Si l'application Ajout/Suppression de programmes permet d'afficher les instances organisées en cluster, les modifications ne sont pas autorisées. Le programme d'installation prend en charge l'ajout ou la suppression d'un nœud avec l'interface utilisateur graphique ou la ligne de commande. Il prend également en charge la modification ou l'ajout d'une adresse IP, ainsi que la désinstallation des clusters.


Envoi de commentaires (64 bits)

Nous attendons vos commentaires et vos suggestions concernant la documentation relative à cette version de Microsoft® SQL Server™ 2000 (64 bits). Vous pouvez nous adresser vos réactions par courrier électronique en cliquant sur l'icône de message électronique située en haut de l'écran. Les réactions et l'assistance technique générales sur les produits ne font pas partie de cette procédure.


Ressources supplémentaires (64 bits)

Si vous avez des questions concernant l'installation de Microsoft® SQL Server™ 2000 (64 bits), vous pouvez accéder au microsoft.public.sqlserver.setup groupe de discussion sur le serveur de news msnews.microsoft.com pour participer à des forums de discussion. Vous pouvez également y trouver une assistance technique entre homologues.

L'accès aux groupes de discussion spéciaux pour cette version limitée est décrite dans le contrat de licence et les instructions relatives à cette version.

Le tableau suivant fournit les ressources Web permettant de rechercher des informations complémentaires sur Microsoft SQL Server.

Pour plus d'informations | Accédez
Microsoft SQL Server | au site Web de Microsoft SQL Server.
Analysis Services | à la page Web d'Analysis Services Web sur le site Microsoft Web.


Copyright et engagements (64 bits)

Ce document, ainsi que les exemples d'applications inclus, est fourni à titre d'information uniquement et Microsoft Corporation ne fournit aucune garantie, expresse ou implicite dans le cadre du présent document. Les informations contenues dans ce document, notamment les exemples, les URL et autres références de site Internet, pourront faire l'objet de modifications sans préavis. L'utilisateur reconnaît assumer tous les risques liés à l'utilisation de ce document.

Un exemple sert principalement à illustrer un concept ou l'utilisation raisonnable d'une instruction ou d'une clause particulière. La plupart des exemples ne comprennent pas tout le code qui serait normalement utilisé dans un système en production, puisqu'une part importante du traitement de validation des données et des erreurs est retirée pour mettre l'accent sur un concept ou une instruction particulière. Aucun support technique n'est disponible pour ces exemples, ni pour le code source fourni.

Sauf mention contraire, les entreprises, organisations, produits, personnes et événements cités dans les exemples sont fictifs et ne sauraient être identifiés à des entreprises, organisations, produits, personnes ou événements réels. L'utilisateur est tenu d'observer la réglementation relative aux droits d'auteur applicable dans son pays. Sans limitations des droits de copyright, aucune partie de ce document ne peut être reproduite, stockée ou introduite dans un système informatique ou transmise à quelque fin ou par quelque moyen que ce soit (électronique, mécanique, par photocopie, par enregistrement, ou autres moyens) sans l'autorisation expresse et écrite de Microsoft Corporation.

Les produits mentionnés dans ce document peuvent faire l'objet de brevets, de dépôts de brevets en cours, de marques, de droits d'auteur ou d'autres droits de propriété intellectuelle et industrielle de Microsoft. Sauf si stipulation expresse contraire d'un contrat de licence écrit de Microsoft, la fourniture de ce document n'a pas pour effet de vous concéder une licence sur ces brevets, marques, droits d'auteur ou autres droits de propriété intellectuelle.

©1988-2002 Microsoft Corporation. Tous droits réservés.

Active Directory, ActiveX, BackOffice, CodeView, Developer Studio, FoxPro, JScript, Microsoft, Microsoft Press, Microsoft SQL Server, MSDN, MS-DOS, Outlook, PivotChart, PivotTable, PowerPoint, Visual Basic, Visual C++, Visual Studio, Win32, Win64, Windows et Windows NT sont soit des marques commerciales, soit des marques déposées de Microsoft Corporation aux États-Unis et/ou dans les autres pays. Les noms de sociétés et de produits réels mentionnés dans ce document sont des marques de leurs propriétaires respectifs.

Version : 8.00.002


Préparation à l'installation de SQL Server 2000 (64 bits)

Les rubriques de cette section vous renseignent sur l'installation de Microsoft® SQL Server™ 2000 (64 bits).

Rubrique | Description
Configuration matérielle et logicielle requise | Décrit le matériel et les logiciels requis pour installer et exécuter SQL Server 2000 (64 bits).
Spécifications de produits (64 bits) | Donne des spécifications concernant les fonctionnalités, la capacité, la configuration et la mémoire de SQL Server 2000 (64 bits).
Utilisation d'instances nommées et multiples de SQL Server (64 bits) | Fournit des informations d'arrière-plan pour installer une instance nommée ou plusieurs instances de SQL Server.
Chemins d'accès des fichiers de SQL Server 2000 (64 bits) | Fournit les emplacements des fichiers que le programme d'installation a copiés sur le disque.
Création des comptes de service Windows (64 bits) | Décrit les comptes de service Microsoft Windows® requis pour exécuter les services SQL Server.
Fonctionnalités de SQL Server 2000 (64 bits) | Décrit les fonctionnalités susceptibles qu'il est possible d'inclure dans une installation SQL Server 2000 (64 bits).


Configuration matérielle et logicielle requise (64 bits)

La configuration matérielle et logicielle minimale requise pour exécuter Microsoft® SQL Server™ 2000 (64 bits) figure dans les tableaux suivants.

Configuration matérielle requise

Ce tableau comprend la configuration matérielle minimale requise pour l'installation de SQL Server 2000 (64 bits).

Matériel | Configuration minimale requise
Ordinateur | Processeurs Intel® Itanium™ et Itanium II équipés d'UC à 64 bits
Mémoire (RAM)1 | Édition Entreprise : 1 Go
Espace disque2 | Composants de base de données SQL Server : 190 à 320 Mo Analysis Services : 230 Mo Documentation en ligne uniquement : 40 Mo
Moniteur | Affichage VGA 800x600 ou résolution supérieure requise pour les outils graphiques de SQL Server
Dispositif de pointage | Souris Microsoft ou compatible
Lecteur de CD-ROM | Obligatoire

1 Un supplément de mémoire peut s'avérer nécessaire, selon la configuration du système d'exploitation.
2 La configuration requise peut varier selon la configuration du système, les applications et les fonctionnalités installées.

Remarque Microsoft SQL Server 2000 (64 bits) n'a pas de liste de compatibilité matérielle (HCL, Hardware Compatibility List). Si votre système correspond à la configuration minimale requise indiquée dans le tableau ci-dessus, SQL Server 2000 doit normalement fonctionner sur le matériel certifié pour une utilisation avec le système d'exploitation Microsoft Windows®. Pour plus d'informations sur le matériel certifié en vue d'une utilisation avec le système d'exploitation Windows, consultez la liste de compatibilité matérielle Microsoft Windows sur le site Web de Microsoft.

Configuration du système d'exploitation requise

Vous devez utiliser les versions 64 bits du système d'exploitation de la famille Windows® Server 2003.

Configuration Internet requise

Ce tableau indique la configuration Internet requise pour l'utilisation de SQL Server 2000 (64 bits).

Composant | Configuration requise
Logiciel Internet | Microsoft Internet Explorer 6.0 est requis pour afficher la documentation en ligne (Aide HTML). Ce logiciel est inclus dans les versions 64 bits du système d'exploitation de la famille Windows Server 2003.
Internet Information Services | Si vous écrivez des applications XML, reportez-vous à la rubrique "Configuration système requise par IIS Virtual Directory Management" dans la documentation en ligne de SQL Server 2000 32 bits.

Configuration des logiciels réseau requise

Les versions 64 bits de la famille Windows Server 2003 disposent de logiciels réseau intégrés.

Remarque TCP/IP doit être activé au niveau du système d'exploitation, préalablement à l'installation de SQL Server 2000 (64 bits). Pour plus d'informations, reportez-vous à la rubrique Configuration des bibliothèques réseau (64 bits).

SQL Server 2000 (64 bits) active les sockets TCP/IP, la mémoire partagée et les bibliothèques de canaux nommés par défaut. Pour configurer les bibliothèques réseau après l'installation de SQL Server 2000 (64 bits), utilisez l'Utilitaire réseau serveur (pour cela, accédez au menu Démarrer, pointez sur Programmes, puis cliquez sur le groupe de programmes Microsoft SQL Server).

Clients pris en charge

Microsoft SQL Server 2000 (64 bits)prend en charge les clients suivants : Windows XP Professional, Windows 2000 Professional, Windows NT® Workstation, Windows ME, Windows 98, Windows 95, Apple Macintosh®, OS/2 et UNIX. Macintosh, OS/2 et UNIX ne prennent pas en charge les outils graphiques de SQL Server et nécessitent un logiciel client ODBC venant d'un fournisseur tiers.


Spécifications de produits (64 bits)

Rubrique | Description
Fonctionnalités prises en charge par les éditions de SQL Server 2000 (64 bits) | Fonctionnalités de composants prises en charge dans les différentes éditions de Microsoft® SQL Server™ 2000 (64 bits).
Spécifications de capacité maximale (64 bits) | Capacités maximales prises en charge par Microsoft SQL Server 2000 (64 bits).
Spécifications des options de configuration (64 bits) | Limites minimales et maximales des ressources de l'ordinateur gérées par Microsoft SQL Server 2000 (64 bits).
Mémoire utilisée par les spécifications des objets SQL Server (64 bits) | Besoins approximatifs des objets en mémoire.


Fonctionnalités prises en charge par les éditions de SQL Server 2000 (64 bits)

Cette rubrique énumère les fonctions prises en charge par les différentes éditions de Microsoft® SQL Server™ 2000 (64 bits).

Pour plus d'informations sur la quantité de mémoire physique utilisée par SQL Server 2000 et sur le nombre d'UC pris en charge par chaque édition dans des environnements de type multiprocesseur symétrique (SMP), reportez-vous à la rubrique Spécifications de capacité maximale (64 bits).

Fonctionnalités du moteur de base de données prises en charge par les éditions de SQL Server 2000 (64 bits)

Ce tableau énumère les fonctions du moteur de base de données et les éditions de SQL Server 2000 (64 bits) qui les prennent en charge.

Fonctionnalité du moteur de base de données | Édition Entreprise
Instances multiples | Prise en charge
Gestion de clusters avec basculement (jusqu'à quatre nœuds) | Prise en charge
Basculement dans SQL Server Enterprise Manager | Prise en charge
Envoi de journaux | Prise en charge
DBCC parallèle | Prise en charge
CREATE INDEX parallèle | Prise en charge
Amélioration de la lecture anticipée et de l'analyse | Prise en charge
Vues indexées | Prise en charge
Serveur de bases de données fédérées | Prise en charge
Réseau SAN (System Area Network) | Prise en charge
Assistants, utilitaires de développement et DBA graphiques | Prise en charge partielle
Utilitaires graphiques pour les paramètres de langues | Prise en charge partielle
Recherche de texte intégral | Prise en charge

Remarque Cette version de SQL Server 2000 (64 bits) ne prend pas en charge SQL Mail. Vous pouvez toutefois configurer à distance SQL Agent Mail dans SQL Server 2000 (64 bits) à l'aide d'Enterprise Manager, si votre client se connecte à distance à l'aide de SQL Server 2000 Service Pack 3.0 ou ultérieur.

Pour plus d'informations, reportez-vous à la rubrique Différences entre les versions 64 bits et 32 bits (64 bits).

Fonctionnalités de réplication prises en charge par les éditions de SQL Server 2000 (64 bits)

Ce tableau énumère les fonctions de réplication et les éditions de SQL Server 2000 (64 bits) qui les prennent en charge.

Fonctionnalité de réplication | Édition Entreprise
Réplication de capture instantanée | Prise en charge
Réplication transactionnelle | Prise en charge
Réplication de fusion | Prise en charge
Abonnement mis à jour immédiatement | Prise en charge
Mise à jour en attente des abonnés | Prise en charge

Cette édition 64 bits de SQL Server 2000 ne prend pas en charge les éléments suivants :

  • Les abonnements Microsoft Jet envoyés en vue de la réplication de fusion, car une version 64 bits du fournisseur de données Microsoft Jet n'est pas disponible.

  • Les abonnements de capture instantanée ou transactionnels envoyés des fournisseurs ODBC ou OLE DB, sauf si le fournisseur fournit un pilote ODBC ou OLE DB 64 bits. Vérifiez auprès de votre fournisseur la disponibilité d'un pilote 64 bits.

  • Les abonnements envoyés transformables, car les composants DTS (Data Transformation Services) 64 bits nécessaires ne sont pas disponibles actuellement. Les abonnements envoyés pour une installation 32 bits de SQL Server 2000 doivent fonctionner avec un éditeur ou un distributeur 64 bits.
Fonctionnalités d'Analysis Services prises en charge par les éditions de SQL Server 2000 (64 bits)

Ce tableau énumère les fonctionnalités d'Analysis Services et les éditions de SQL Server 2000 (64 bits) qui les prennent en charge.

Fonctionnalité d'Analysis Services | Édition Entreprise
Analysis Services | Prise en charge
Partitions OLAP définies par l'utilisateur | Prise en charge
Cubes OLAP liés | Prise en charge
Dimensions ROLAP | Prise en charge
Internet HTTP | Prise en charge
Cumuls personnalisés | Prise en charge
Cellules calculées | Prise en charge
Écriture en différé dans la dimension | Prise en charge
Dimensions très volumineuses1 | Prise en charge
Actions | Pris en charge
OLAP en temps réel | Prise en charge
Cubes partitionnés distribués | Prise en charge
Data Mining | Prise en charge

1 Avec la version 64 bits d'Analysis Services, il n'est pas nécessaire d'utiliser le gestionnaire VLDM (Very Large Dimension Manager) pour configurer les dimensions volumineuses. Grâce à son espace d'adressage virtuel 64 bits, Analysis Services gère automatiquement les dimensions très volumineuses.


Spécifications de capacité maximale (64 bits)

Le premier tableau présente les capacités maximales qui sont identiques pour toutes les éditions de Microsoft® SQL Server™ 2000. Les deuxième et troisième tableaux présentent les capacités qui varient en fonction de l'édition de SQL Server 2000 et du système d'exploitation utilisés.

Ce tableau présente la taille et le nombre maximal des différents objets définis dans les bases de données Microsoft SQL Server ou mentionnés dans les instructions Transact-SQL. Il ne s'applique pas à l'Édition Windows® CE de SQL Server 2000.

 | Tailles maximales/nombres maximaux
Objet | SQL Server 2000 (32 bits) | SQL Server 2000 (64 bits)
Taille d'un lot d'instructions | 65 536 * Taille des paquets réseau1 | 65 536 * Taille des paquets réseau1
Octets par colonne de chaîne courte | 8,000 | 8,000
Octets par colonne de type text, ntext ou image | 2 Go-2 | 2 Go-2
Octets par clause GROUP BY, ORDER BY | 8,060 | 8,060
Octets par index | 900 | 9002
Octets par clé étrangère | 900 | 900
Octets par clé primaire | 900 | 900
Octets par ligne | 8,060 | 8,060
Octets dans le texte source d'une procédure stockée | Inférieure à la taille du lot d'instructions ou 250 Mo | Inférieure à la taille du lot d'instructions ou 250 Mo
Index ordonnés en clusters par table | 1 | 1
Colonnes dans les clauses GROUP BY, ORDER BY | Limité uniquement par le nombre d'octets | Limité uniquement par le nombre d'octets
Colonnes ou expressions dans une instruction GROUP BY WITH CUBE ou WITH ROLLUP | 10 | 10
Colonnes par index | 16 | 16
Colonnes par clé étrangère | 16 | 16
Colonnes par clé primaire | 16 | 16
Colonnes par table de base | 1,024 | 1,024
Colonnes par instruction SELECT | 4,096 | 4,096
Colonnes par instruction INSERT | 1,024 | 1,024
Connexions par client | Valeur maximale des connexions configurées | Valeur maximale des connexions configurées
Taille de la base de données | 1 048 516 To | 1 048 516 To
Bases de données par instance de SQL Server | 32,767 | 32,767
Groupes de fichiers par base de données | 256 | 256
Fichiers par base de données | 32,767 | 32,767
Taille de fichier (données) | 32 To | 32 To
Taille de fichier (journal) | 32 To | 32 To
Références de table de clé étrangère par table | 253 | 253
Longueur d'identificateur (en caractères) | 128 | 128
Instances par ordinateur | 16 | 16
Longueur d'une chaîne contenant des instructions SQL (taille du lot) | 65 536 * Taille des paquets réseau1 | 65 536 * Taille des paquets réseau1
Verrous par connexion | Verrous maximaux par serveur | Verrous maximaux par serveur
Verrous par instance de SQL Server | Jusqu'à environ 16 000 000 (limité par la mémoire) | Limité uniquement par la mémoire
Niveaux de procédures stockées imbriquées | 32 | 32
Sous-requêtes imbriquées | 32 | 32
Niveaux de déclencheurs imbriqués | 32 | 32
Index non ordonnés en clusters par table | 249 | 249
Objets simultanément ouverts dans une instance de SQL Server4 | 2 147 483 647 par base de données (selon la mémoire disponible) | 2 147 483 647 par base de données (selon la mémoire disponible)
Objets dans une base de données | 2,147,483,6473 | 2,147,483,6473
Paramètres par procédure stockée | 1,024 | 1,024
REFERENCES par table | 253 | 253
Lignes par table | Limité par le stockage disponible | Limité par le stockage disponible
Tables par base de données | Limité par le nombre d'objets dans une base de données3 | Limité par le nombre d'objets dans une base de données3
Tables par instruction SELECT | 256 | 256
Déclencheurs par table | Limité par le nombre d'objets dans une base de données3 | Limité par le nombre d'objets dans une base de données3
Index ou contraintes UNIQUE par table | 249 non ordonnés en clusters et 1 ordonné en clusters | 249 non ordonnés en clusters et 1 ordonné en clusters

1 La taille des paquets réseau représente la taille des paquets TDS (Tabular Data Scheme) utilisés pour communiquer entre des applications et le moteur de base de données relationnelle. La taille par défaut est 4 Ko ; elle est contrôlée par l'option de configuration network packet size.
2 Dans SQL Server 2000, le nombre maximal d'octets dans chaque clé doit être inférieur à 900. Vous pouvez définir une clé à l'aide de colonnes de longueur variable dont la taille maximale ne dépasse pas 900, à condition qu'aucune ligne de plus de 900 octets de données ne soit insérée dans ces colonnes. Pour plus d'informations, reportez-vous à la rubrique "Taille maximale des clés d'index" dans la documentation en ligne de SQL Server 2000 32 bits.
3 Les objets de base de données comprennent l'ensemble des tables, des vues, des procédures stockées, des procédures stockées étendues, des déclencheurs, des règles, des valeurs par défaut et des contraintes. Au total, le nombre de tous ces objets ne peut pas dépasser 2 147 483 647 dans une base de données.

Nombre maximal de processeurs pris en charge par les éditions de SQL Server 2000 (64 bits)

L'Édition Entreprise de SQL Server 2000 prend en charge 32 processeurs sur les ordinateurs SMP (Symmetric Multiprocessing).


Spécifications des options de configuration (64 bits)

Microsoft® SQL Server™ 2000 contient des algorithmes évolués pour le contrôle des ressources de l'ordinateur. La plupart des options qui devaient être configurées manuellement dans les versions précédentes de SQL Server sont désormais gérées dynamiquement dans SQL Server 2000. Vous pouvez afficher ces paramètres de configuration à l'aide de la procédure stockée sp_configure.

Plusieurs options de configuration sont toujours spécifiées dans SQL Server 2000, mais au lieu d'indiquer la taille d'une allocation statique, elles précisent désormais la limite supérieure du nombre d'objets alloués dynamiquement en fonction des besoins. Ces options s'accompagnent d'un astérisque (*) dans ce tableau. Les informations de ce tableau ne s'appliquent pas à l'Édition Windows® CE de SQL Server 2000.

 | SQL Server 2000 (32 bits) |  | SQL Server 2000 (64 bits)
Option de configuration | Minimale | Maximale | Minimale | Maximale
affinity mask | -2,147,483,648 | 2,147,483,647 | -2,147,483,648 | 2,147,483,647
affinity64 mask |  |  | -2,147,483,648 | 2,147,483,647
allow updates | 0 | 1 | 0 | 1
AWE enabled1 | 0 | 1 | 0 | 1
c2 audit mode | 0 | 1 | 0 | 1
cost threshold for parallelism | 0 | 32,767 | 0 | 32,767
Cross DB Ownership Chaining | 0 | 1 | 0 | 1
cursor threshold | -1 | 2,147,483,647 | -1 | 2,147,483,647
default full-text language | 0 | 2,147,483,647 | 0 | 2,147,483,647
default language | 0 | 9,999 | 0 | 9,999
fill factor (percent) | 0 | 100 | 0 | 100
index create memory (K) | 704 | 2,147,483,647 | 704 | 2,147,483,647
IO_affinity_mask2 | -2,147,483,648 | 2,147,483,648 | -2,147,483,648 | 2,147,483,648
lightweight pooling | 0 | 1 | 0 | 1
locks | 5,000* | 2,147,483,647* | 5,000* | 2,147,483,647*
max degree of parallelism | 0 | 32 | 0 | 32
max server memory (Mo) | 4 | 2,147,483,647* | 4* | 2,147,483,647*
max text repl size | 0 | 2,147,483,647 | 0 | 2,147,483,647
max worker threads | 10 | 32,767 | 32 | 32,767
media retention | 0 | 365 | 0 | 365
min memory per query (K) | 512 | 2,147,483,647 | 512 | 2,147,483,647
min server memory (Mo) | 0* | 2,147,483,647* | 0* | 2,147,483,647*
nested triggers (octets) | 0 | 1 | 0 | 1
network packet size | 512 | 65,535 | 512 | 65,536
open objets | 0* | 2,147,483,647* | 0* | 2,147,483,647*
priority boost | 0 | 1 | 0 | 1
query governor cost limit | 0 | 2,147,483,647 | 0 | 2,147,483,647
query wait (sec) | -1 | 2,147,483,647 | -1 | 2,147,483,647
recovery interval (min) | 0 | 32,767 | 0 | 32,767
remote access | 0 | 1 | 0 | 1
remote login timeout (sec) | 0 | 2,147,483,647 | 0 | 2,147,483,647
remote proc trans | 0 | 1 | 0 | 1
remote query timeout (sec) | 0 | 2,147,483,647 | 0 | 2,147,483,647
scan for startup procs | 0 | 1 | 0 | 1
set working set size | 0 | 1 | 0 | 1
show advanced options | 0 | 1 | 0 | 1
two digit year cutoff | 1,752 | 9,999 | 1,753 | 9,999
user connections | 0* | 32 767 (serveur)* 3 | 0* | 32 767 (instance)* 3
user options | 0 | 32,767 | 0 | 32,767

* Limite supérieure ou inférieure des objets alloués dynamiquement.
1 Ce paramètre de configuration existe mais est ignoré par la version 64 bits de SQL Server 2000.
2 L'affinité d'E/S peut être une chaîne hexadécimale, octale ou décimale. Dans Win64™, la plage peut être comprise entre 0 et 0xffffffffffffffff en notation hexadécimale ou entre 1 et 18446744073709551615 en notation décimale. Les représentations non valides seront remises à 0. Remarque : Le commutateur IO_affinity_mask peut être utilisé conjointement avec l'option de configuration du masque d'affinité. Les utilisateurs ne doivent pas activer un processeur pour le commutateur IO_affinity_mask et les options affinity_mask.

Pour plus d'informations, consultez l'article n° Q298402 dans la Base de connaissances Microsoft sur le site Web de Microsoft.

3 SQL Server 2000 Édition Personnelle utilise un administrateur de charges de travail simultanées qui limite les performances lorsque plus de 5 lots sont exécutés simultanément.


Mémoire utilisée par les spécifications des objets SQL Server (64 bits)

Ce tableau répertorie la quantité de mémoire approximative qu'utilisent les différents objets dans Microsoft® SQL Server™ 2000.

 | Taille de l'objet
Objet | SQL Server 2000 (32 bits) | SQL Server 2000 (64 bits)
Verrou | 64 octets plus 32 octets par propriétaire | 88 octets plus 56 octets par propriétaire
Base de données ouverte | 4 848 octets plus 1 648 octets par fichier et 336 octets par groupe de fichiers | 4 984 octets plus 1720 octets par fichier et 384 octets par groupe de fichiers
Objet ouvert1 | 276 octets plus 1 824 octets par index ouvert dans l'objet2 | 376 octets plus 1 872 octets par index ouvert dans l'objet2
Connexion utilisateur | 12 Ko + (3 * Taille des paquets réseau)3 | 12 Ko + (3 * Taille des paquets réseau)3

1 Les objets ouverts comprennent toutes les tables, les vues, les procédures stockées, les procédures stockées étendues, les déclencheurs, les règles, les valeurs par défaut et les contraintes.
2 Les index peuvent être ouverts dans des tables ou des vues.
3 La taille des paquets réseau représente la taille des paquets TDS (Tabular Data Scheme) utilisés pour communiquer entre des applications et le moteur de base de données relationnelle. La taille par défaut est 4 Ko ; elle est contrôlée par l'option de configuration network packet size.


Utilisation d'instances nommées et multiples de SQL Server (64 bits)

Avec Microsoft® SQL Server™ 2000 (64 bits), vous pouvez choisir d'installer plusieurs copies, ou instances, de SQL Server sur un même ordinateur. Lorsque vous procédez à une nouvelle installation de SQL Server 2000 ou lorsque vous procédez à des opérations de maintenance sur une installation existante, vous pouvez indiquer que cette installation est :

  • l'instance par défaut de SQL Server ;

    Il s'agit de l'instance de SQL Server à laquelle vous accédez en fournissant le nom d'ordinateur en tant que nom de SQL Server. Une installation ne doit pas nécessairement comporter une instance par défaut. Si, toutefois, vous installez plusieurs instances sur un ordinateur unique, seule une instance peut faire office d'instance par défaut. Les applications qui utilisent les logiciels clients de versions antérieures de SQL Server peuvent se connecter à une instance par défaut.

  • une instance nommée de SQL Server ;

    un ordinateur peut exécuter simultanément jusqu'à 15 instances nommées de SQL Server (16 instances, instance par défaut comprise), tant qu'il dispose des ressources nécessaires pour leur prise en charge. Une instance nommée est identifiée par le nom réseau de l'ordinateur et du nom d'instance, dans le format nom_ordinateur\<nom_instance, où nom_instance est le nom fourni pour l'instance pendant l'installation. La plupart des applications doivent utiliser les composants clients de SQL Server 2000 pour se connecter à une instance nommée. Pour plus d'informations sur les règles d'appellation, reportez-vous à la rubrique Attribution d'un nom aux instances (64 bits).

Chaque instance possède son propre dossier de fichiers programme du serveur. Quant aux fichiers de données pour chaque instance, vous pouvez les stocker où vous le souhaitez. Chaque instance possède également son propre service de l'Agent SQL Server. Les outils pour toutes les instances sont installés une fois seulement.

Instances multiples

Il y a des instances multiples dès lors que plus d'une instance de SQL Server 2000 (64 bits) est installée sur votre ordinateur. Chaque instance fonctionne indépendamment de toutes les autres instances situées sur même ordinateur, et les applications peuvent se connecter à n'importe laquelle de ces instances. Le nombre d'instances qui peuvent s'exécuter sur un même ordinateur dépend des ressources disponibles. Le nombre maximal d'instances prises en charge dans SQL Server 2000 (64 bits) est 16.

Vous pouvez installer une instance nommée de SQL Server 2000 (64 bits) à tout moment : avant, après l'installation de l'instance par défaut de SQL Server 2000 (64 bits) ou en remplacement de celle-ci. Quand vous installez SQL Server 2000 (64 bits) sur un ordinateur sur lequel SQL Server n'a jamais été installé, le programme d'installation définit l'installation d'une instance par défaut. Vous pouvez choisir d'installer SQL Server 2000 (64 bits) en tant qu'instance nommée en choisissant l'option Instance nommée dans la boîte de dialogue Nom de l'instance.

Chaque instance nommée est constituée d'un ensemble distinct de services et peut comporter des paramètres complètement différents pour les classements et les autres options. La structure des répertoires, la structure du registre et les noms des services reflètent tous le nom de l'instance spécifique que vous avez indiqué.

Noms de service pour les instances par défaut et pour les instances nommées

Quand vous installez une instance par défaut de SQL Server, les noms de service sont MSSQLServer et SQLServerAgent.

Quand vous installez une instance nommée de SQL Server, les noms de service sont modifiés en :

  • MSSQL$nom_instance pour le service MSSQLServer ;

  • SQLAgent$nom_instance pour le service de l'Agent SQL Server.

Les services MSDTC (Microsoft Distributed Transaction Coordinator) et Microsoft Search ne sont installés qu'une seule fois et peuvent être utilisés simultanément par toutes les instances installées de SQL Server.

Voir aussi

Attribution d'un nom aux instances (64 bits)

Protocoles réseau pour les instances nommées (64 bits)


Protocoles réseau pour les instances nommées (64 bits)

Les bibliothèques réseau par défaut de Microsoft® SQL Server™ 2000 (64 bits) sont les canaux nommés, la mémoire partagée et TCP/IP. Il est possible d'ajouter d'autres protocoles, tout en sachant que Multiprotocol, Banyan VINES et AppleTalk ne sont pas pris en charge. Lors de l'installation d'une instance par défaut de SQL Server 2000, les adresses réseau standard sont activées. Par exemple, les canaux nommés utilisent \\.\pipe\sql\query, tandis que les sockets TCP/IP se connectent au port 1433.

Quand vous sélectionnez une instance nommée, seuls les canaux nommés et les protocoles TCP/IP sont pris en charge. L'adresse par défaut des canaux nommés est \.\pipe\MSSQL$nom_instance\Sql\Query. L'adresse de port utilisée par TCP/IP est choisie dynamiquement par défaut, lors du premier démarrage de l'instance.

Cette version 64 bits de SQL Server 2000 fournit la configuration des bibliothèques réseau pendant l'installation. Dès que vous avez installé SQL Server 2000, vous pouvez utiliser l'utilitaire réseau SQL Server pour configurer les bibliothèques réseau. Pour plus d'informations sur la configuration des bibliothèques réseau, reportez-vous à la documentation en ligne de SQL Server 2000.

Voir aussi

Utilisation des instances nommées et multiples de SQL Server (64 bits)

Configuration des bibliothèques réseau (64 bits)


Chemins d'accès des fichiers de SQL Server 2000 (64 bits)

Une installation de Microsoft® SQL Server™ 2000 (64 bits) comprend une ou plusieurs instances distinctes. Il s'agit de l'instance par défaut et/ou d'une ou de plusieurs instances nommées. Une instance, qu'elle soit nommée ou par défaut, dispose de son propre ensemble de fichiers programme et de données, ainsi que de fichiers communs. L'illustration ci-après montre les emplacements de fichiers installés pour l'instance par défaut de SQL Server 2000 (64 bits) et pour l'instance nommée Instance1. Les deux instances possèdent un ensemble complet de fichiers de données et de fichiers exécutables. Les fichiers communs utilisés à la fois par l'instance par défaut et par toutes les instances nommées sont installés dans le dossier lecteur_système\Program Files\Microsoft SQL Server\80.

La figure ci-après montre les emplacements d'installation par défaut de SQL Server dans lecteur_système\Program Files\Microsoft SQL Server (en général, le lecteur C).

L'emplacement des fichiers programme et de données pour l'instance par défaut de SQL Server est lecteur_système\Program Files\Microsoft SQL Server\Mssql. Dans ce cas, l'emplacement par défaut de l'instance nommée est lecteur_système\Program Files\Microsoft SQL Server\Mssql$Instance1. Pendant l'installation, vous pouvez spécifier un autre chemin d'accès aux fichiers programme et de données. Le programme d'installation installe également des fichiers dans le dossier système de Microsoft Windows®. L'emplacement de ces fichiers système n'est pas modifiable.

La suite de cette rubrique montre de façon détaillée les emplacements des fichiers installés par le programme d'installation pour SQL Server 2000 (64 bits).

Emplacement des fichiers programme et de données

Le dossier programme se trouve dans le dossier racine, à l'endroit où le programme d'installation crée les dossiers contenant les fichiers programme et d'autres fichiers qui ne sont généralement pas modifiés lors de l'utilisation de SQL Server. Comme ces dossiers ne contiennent pas de fichiers de données, de fichier journal, de fichiers de sauvegarde ou de données de réplication, l'espace qu'ils requièrent ne change pas de façon significative.

Remarque Vous ne pouvez pas installer les fichiers programme et de données sur un disque amovible.

Le fichier de données est placé dans le dossier racine, à l'endroit où le programme d'installation crée les dossiers contenant les fichiers de base de données et les journaux, ainsi que les répertoires contenant les données du journal système, de sauvegarde et de réplication. Le programme d'installation crée des fichiers de bases de données et des journaux pour les bases de données master, model, tempdb, msdb, pubs et Northwind. Le fichier de données de SQL Server doit se trouver sur un lecteur disposant de suffisamment d'espace disque pour permettre à ces fichiers d'augmenter en taille.

Remarque Vous ne pouvez pas installer les fichiers de données dans un système de fichiers utilisant la compression.

Chaque instance de SQL Server possède ses propres fichiers programme et de données.

Emplacement des fichiers programme et de données pour l'instance par défaut de SQL Server

Pour l'instance par défaut de SQL Server, le nom par défaut du dossier de données et de programmes de SQL Server (Mssql) est utilisé en tant que nom d'instance par défaut dans le dossier que vous spécifiez. Si vous n'indiquez pas d'emplacement, l'emplacement par défaut est lecteur_système\Program Files\Microsoft SQL Server\dossier. Pour l'instance par défaut de SQL Server, les répertoires par défaut sont les suivants :

  • lecteur_système\Program Files\Microsoft SQL Server\Mssql\Binn (pour les fichiers programme)

  • lecteur_système\Program Files\Microsoft SQL Server\Mssql\Data (pour les fichiers de données)

Vous pouvez modifier l'emplacement de l'instance par défaut pendant l'installation. Par exemple, si vous précisez que l'instance par défaut doit être installée dans D:\MySqlDir, les chemins d'accès sont les suivants :

  • D:\MySqlDir\Mssql\Binn (pour les fichiers programme)

  • D:\MySqlDir\Mssql\Data (pour les fichiers de données)
Emplacement des fichiers programme et de données pour une instance nommée de SQL Server

Chaque instance nommée de SQL Server possède un emplacement spécifique pour ses fichiers programme et ses fichiers de données. Ces emplacements sont différents de ceux de l'instance par défaut de SQL Server.

Remarque Une instance nommée n'est pas nécessairement identique à une instance multiple. Vous pouvez disposer d'une seule instance nommée ou de plusieurs instances nommées. Pour plus d'informations, reportez-vous à la rubrique Utilisation des instances nommées et multiples de SQL Server (64 bits).

Pour chaque instance nommée de SQL Server installée, avec le nom nom_instance, les répertoires par défaut sont les suivants :

  • lecteur_système\Program Files\Microsoft SQL Server\MSSQL$nom_instance\Binn (pour les fichiers exécutables).

  • lecteur_système\Program Files\Microsoft SQL Server\MSSQL$nom_instance\Data (pour les fichiers de données).

Vous pouvez spécifier des chemins d'accès qui ne sont pas les emplacements par défaut des fichiers programme et de données pour les instances nommées. Si, par exemple, vous spécifiez que l'instance nommée « AnInstance « doit être installée dans D:\MySqlDir, les chemins d'accès sont les suivants :

  • D:\MySqlDir\MSSQL$AnInstance\Binn (pour les fichiers programme)

  • D:\MySqlDir\MSSQL$AnInstance\Data (pour les fichiers de données)
Emplacement des fichiers pour les outils partagés

Les outils partagés sont installés par défaut dans lecteur_système\Program Files\Microsoft SQL Server\80\Tools. Ce dossier contient les fichiers partagés par toutes les instances de SQL Server 2000, à savoir l'instance par défaut et la ou les instances nommées de SQL Server. Les outils comprennent ce fichier d'aide (Setupsql.chm), les outils de développement et d'autres composants.

Les outils partagés qui sont encore au format 32 bits mais qui sont utilisés par la version 64 bits de SQL Server se trouvent dans lecteur_système\Program Files (x86)\Microsoft SQL Server\80\Tools. Ces fichiers incluent l'ensemble de la documentation en ligne de SQL Server 2000. L'emplacement n'est pas modifiable.

Emplacement des fichiers d'Analysis Services

Analysis Services contient des fichiers programme, des fichiers de données et le référentiel de métadonnées. L'emplacement par défaut des fichiers programme d'Analysis Services est lecteur_système\Program Files\Microsoft Analysis Services\Bin. L'emplacement par défaut des fichiers programme d'Analysis Services est lecteur_système\Program Files\Microsoft Analysis Services\Bin. Le dossier Data stocke les données multidimensionnelles des objets définis sur le serveur d'analyse.

L'emplacement par défaut des dossiers programme et de données peut être modifié pendant l'installation. Il est toutefois préférable de ne pas installer Analysis Services dans un dossier dont le chemin ou le nom comporte des caractères sur deux octets (DBCS, double-byte character set). Installez plutôt Analysis Services dans un dossier dont le chemin et le nom comporte uniquement des caractères sur un octet.

Dans SQL Server 2000 (64 bits), Analysis Services utilise SQL Server pour héberger son référentiel (OLAPRepository.mdf), qui contient les métadonnées des objets stockés sur le serveur d'analyse. L'emplacement par défaut du fichier de base de données du référentiel est lecteur_système\Program Files\Microsoft SQL Server\Mssql$nom_instance\data, où nom_instance désigne le nom de l'instance sur laquelle Analysis Services est installé.

Remarque Le programme d'installation permet l'installation d'une seule copie d'Analysis Services avec une instance unique. Avec l'installation des instances suivantes, Analysis Services n'apparaît pas dans la page Sélection des fonctionnalités du programme d'installation.

Lorsque vous installez Analysis Services, le programme Setup.exe installe également les principaux fichiers programme de SQL Server pour pouvoir prendre en charge le référentiel d'Analysis Services, même si vous n'installez pas les composants de SQL Server. Si vous ne souhaitez pas que SQL Server et Analysis Services partagent les fichiers programme principaux de SQL Server, installez Analysis Services dans une instance et SQL Server dans une autre.

Spécification des chemins d'accès des fichiers

Pendant l'installation, vous pouvez modifier le chemin d'accès de l'installation pour les fonctionnalités suivantes :

Fonctionnalité | Chemin d'accès par défaut1,2
SQL Server |
Composants serveur | \Program Files\Microsoft SQL Server
Fichiers de données | \Program Files\Microsoft SQL Server\Mssql\Data
Analysis Services |
Serveur d'analyse | \Program Files\Microsoft Analysis Services
Fichiers de données | \Program Files\Microsoft Analysis Services\Data
Référentiel SQL3 | \Program Files\Microsoft SQL Server\Mssql\
Fichiers de données4 | Program Files\Microsoft SQL Server\Mssql\Data

1 Les chemins d'accès par défaut mentionnés dans le tableau concernent l'instance par défaut. Pour une instance nommée, Mssql utilise Mssql$nom_instance, où nom_instance désigne le nom de l'instance.
2 Le lecteur par défaut pour ces emplacements est lecteur_système, le lecteur C en général.
3 Définit l'emplacement des fichiers programme de SQL Server (si vous ne choisissez pas d'installer les composants serveur de SQL Server). Pour plus d'informations, reportez-vous à la rubrique Analysis Services (64 bits).
4 Définit l'emplacement de la base de données du référentiel d'Analysis Services. Pour plus d'informations, reportez-vous à la rubrique Analysis Services (64 bits).

Remarque Lors de l'ajout de fonctionnalités à une installation existante, vous ne pouvez ni modifier l'emplacement d'une fonctionnalité précédemment installée, ni spécifier l'emplacement d'une nouvelle fonctionnalité.

Lorsque, pendant l'installation, vous indiquez un chemin d'installation pour les composants serveur ou les fichiers de données, le programme d'installation utilise le nom d'instance, en plus de l'emplacement spécifié pour les fichiers programme et de données. Le programme d'installation n'utilise pas le nom d'instance pour les outils et les autres fichiers partagés. S'il ne l'utilise pas non plus pour les fichiers programme et de données d'Analysis Services, il l'utilise en revanche pour le référentiel d'Analysis Services.

Recherche des emplacements d'installation

Si vous n'êtes pas certain des chemins d'accès des instances, regardez la clé de registre suivante qui vous donne le chemin de n'importe quelle instance nommée.

HKLM\Software\Microsoft\Microsoft SQL Server\nom_instance\Setup\SQLPath

La clé de registre suivante fournit le chemin d'accès de l'instance par défaut :

HKLM\Software\Microsoft\MSSQLServer\Setup\SQLPath

Vous pouvez utiliser l'outil REG QUERY disponible avec les versions 64 bits du système d'exploitation de la famille Windows Server 2003 pour interroger le registre et obtenir ainsi le chemin d'installation d'une instance particulière. Exécutez la commande suivante à l'invite de commande, en y insérant le nom d'instance approprié :

REG QUERY HKLM\Software\Microsoft\Microsoft SQL Server\nom_instance\Setup /v SQLPath

Ou bien, exécutez la commande suivante pour l'instance par défaut :

REG QUERY HKLM\Software\Microsoft\MSSQLServer\Setup /v SQLPath

Pour plus d'informations sur la syntaxe de la commande de l'outil REG QUERY, tapez REG QUERY /? sur la ligne de commande.


Création des comptes de service Windows (64 bits)

Microsoft® SQL Server™ 2000 (64 bits) possède trois comptes de service dans les versions 64 bits du système d'exploitation de la famille Windows ®Server 2003 : Microsoft SQL Server, l'Agent SQL Server et Analysis Services. Ces services figurent dans la liste des services installés, dans les Outils administratifs de la boîte de dialogue Services, qui est accessible via le Panneau de configuration. Le tableau suivant répertorie chaque nom de service ainsi que le terme utilisé pour faire référence aux instances par défaut et nommées de SQL Server, tel que l'affiche la boîte de dialogue Services.

Service | Instance par défaut | Instance nommée
Microsoft SQL Server | MSQLSERVER | MSSQL$nom_instance
Agent SQL Server | SQLSERVERAGENT | SQLAgent$nom_instance
Analysis Services | MSSQLServerOLAPService |

En règle générale, ces services reçoivent le même compte d'utilisateur, à savoir le compte système local ou le compte d'utilisateur de domaine. Vous pouvez toutefois personnaliser les paramètres de chaque service durant le processus d'installation.

Utilisation du compte système local

Le compte système local ne requiert pas de mot de passe, ne dispose pas de droits d'accès réseau dans Windows NT 4.0 et limite l'interaction de l'installation avec d'autres serveurs.

Utilisation d'un compte d'utilisateur de domaine

Un compte d'utilisateur de domaine utilise l'authentification Windows pour que le nom d'utilisateur utilisé pour se connecter au réseau soit également utilisé pour se connecter à SQL Server. Un compte d'utilisateur de domaine est généralement utilisé parce que de nombreuses activités de serveur à serveur ne peuvent être effectuées qu'avec un compte de ce type. Par exemple :

  • appels de procédures distantes ;

  • réplication ;

  • sauvegarde sur des lecteurs réseau ;

  • jointures hétérogènes faisant intervenir des sources de données distantes ;

  • cubes liés d'Analysis Manager.
Contraintes liées au compte d'utilisateur de domaine

Tous les comptes d'utilisateur de domaine doivent disposer des autorisations nécessaires suivantes :

  • accès au dossier SQL Server et modification de ce dernier (\Program Files\Microsoft SQL Server\Mssql) ;

  • accès aux fichiers de base de données .mdf, .ndf et .ldf et modification de ces derniers ;

  • ouverture d'une session en tant que service ;

  • lecture et écriture des clés du registre :
    • HKEY_LOCAL_MACHINE\Software\Microsoft\MSSQLServer (instance par défaut)

    • HKEY_LOCAL_MACHINE\Software\Microsoft\Microsoft SQL Server (toute instance nommée)

    • HKEY_LOCAL_MACHINE\System\CurrentControlset\Services\MSSQLServer (instance par défaut)

    • HKEY_LOCAL_MACHINE\System\CurrentControlset\Services\MSSQL$Instance (toute instance nommée)

    • HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Peflib

Les comptes de domaine d'Analysis Services doivent détenir les autorisations suivantes :

  • accès au dossier Analysis Services et modification de ce dernier (Program Files\Microsoft Analysis Services\) ;

  • ouverture d'une session en tant que service ;

  • lecture et écriture des clés du registre :
    • HKEY_LOCAL_MACHINE\Software\Microsoft\OLAP Server

    • HKEY_LOCAL_MACHINE\System\CurrentControlset\Services\MSSQLServerOLAPService

En outre, un compte d'utilisateur de domaine doit être capable de lire et d'écrire les clés de registre correspondantes pour ces services : SQLAgent$nom_instance, MSSEARCH et MSDTC.

Ce tableau spécifie les autres autorisations qui sont indispensables à certaines fonctionnalités.

Service | Autorisation | Fonctionnalité
SQL Server | Privilèges d'écriture sur le réseau | Écrire sur MailSlot avec xp_sendmail.
SQL Server | Fonctionne comme un composant du système d'exploitation et remplace le jeton de niveau processus | Exécuter xp_cmdshell pour un utilisateur autre qu'un administrateur SQL Server.
SQL Server | Membre du groupe local Utilisateurs avec pouvoir ou groupe Administrateurs local | Ajouter et supprimer des objets SQL Server dans l'annuaire Active Directory.
Agent SQL Server | Membre du groupe Administrateurs local | Créer des travaux CmdExec et ActiveScript appartenant à un utilisateur autre qu'un administrateur SQL Server. Utiliser la fonctionnalité de redémarrage automatique. Utiliser des travaux qui s'exécutent à un moment d'inactivité.
MSSQLServerOLAPService | Membre du groupe Administrateurs OLAP | Utiliser l'outil d'administion Analysis Manager 2000.

Modification des comptes d'utilisateur

Pour modifier le mot de passe ou d'autres propriétés d'un service associé à SQL Server lorsque SQL Server est installé, accédez au Panneau de configuration, cliquez sur Outils administratifs, puis cliquez sur Services. Si vous administrez le serveur 64 bits à distance à partir d'un serveur SQL Server 32 bits, vous pouvez également utiliser SQL Server Enterprise Manager. Si vous modifiez le mot de passe Windows pour un compte de service quelconque, vérifiez que vous modifiez aussi le mot de passe du service. Un service qui se connecte à un compte d'utilisateur ne peut pas démarrer sans le mot de passe actif du compte.


Fonctionnalités de SQL Server 2000 (64 bits)

Pendant l'installation de Microsoft® SQL Server™ 2000 (64 bits), vous pouvez choisir des fonctionnalités et des sous-fonctionnalités à installer, à supprimer ou à ajouter, qui ne font pas partie de l'installation initiale de SQL Server. Avant d'ouvrir l'Assistant Installation, familiarisez-vous avec les fonctionnalités proposées et choisissez uniquement celles qui conviennent à votre installation.

  • Outils de gestion de SQL Server 2000 (64 bits)

  • Composants serveur (64 bits)

  • Analysis Services (64 bits)

  • Documentation en ligne
Choix des fonctionnalités et des options à installer

SQL Server est utilisable dans des contextes très différents ; toutes ses fonctionnalités et ses options ne sont pas indispensables pour chaque installation. Vous possédez un serveur de base de données, un serveur Internet ou vous avez besoin d'installer une base de données sur un ordinateur client. Si vous exécutez des applications de base de données client/serveur, peut-être avez-vous besoin d'une base de données sur votre ordinateur. Vous recherchez des outils pour administrer un serveur de base de données, ou vous souhaitez exécuter des applications accédant à une instance de SQL Server. Vous pouvez avoir besoin d'un serveur d'analyse pour le traitement analytique en ligne (OLAP) et le Data Mining. Les choix d'installation possibles pour ces configurations SQL Server, et bien d'autres, sont décrits dans les prochains paragraphes.

Installation de SQL Server sur un serveur de base de données

Si vous créez un serveur de base de données, installez SQL Server 2000 (64 bits) Édition Entreprise. Sur un serveur de base de données 64 bits, vous pouvez installer une instance par défaut du moteur de base de données relationnelle SQL Server 2000 (64 bits). Vous pouvez également installer une ou plusieurs instances nommées du moteur de base de données relationnelle SQL Server 2000 (64 bits). À part la spécification d'un nom d'instance, les choix d'installation d'une instance nommée sont similaires à ceux de l'installation d'une instance par défaut.

Utilisation de SQL Server avec un serveur Internet

Sur un serveur Internet, tel qu'un serveur exécutant les services IIS (Microsoft Internet Information Services), vous installez généralement les outils clients SQL Server 2000. SQL Server 2000 (64 bits) ne comprend pas d'outils graphiques (autres que l'utilitaire réseau serveur et le gestionnaire des services), mais il prend en charge les outils de ligne de commande qui sont gérés par la version 32 bits de SQL Server 2000. Ces outils incluent les fonctionnalités de connectivité clientes utilisées par une application qui se connecte à une instance de SQL Server. En outre, les outils clients comprennent l'utilitaire de configuration des racines virtuelles nécessaires aux applications pour accéder à SQL Server par l'intermédiaire des URL.

Après avoir installé les outils de SQL Server, configurez les racines virtuelles qui prennent en charge l'accès à une instance de SQL Server via une URL. Pour plus d'informations sur la configuration des racines virtuelles, reportez-vous à la rubrique " Utilisation de l'utilitaire IIS Virtual Directory Management pour SQL Server ".

Remarque Bien que vous puissiez installer une instance de SQL Server sur un ordinateur qui exécute IIS, ceci ne se fait en général que pour des sites Web de petite taille qui ne possèdent qu'un seul ordinateur serveur. La plupart des sites Web disposent de leur système IIS de niveau intermédiaire sur un serveur ou sur un cluster de serveurs, et de leurs bases de données sur un serveur distinct ou sur une fédération distincte de serveurs. Pour plus d'informations sur les fédérations, reportez-vous à la rubrique « Serveurs SQL Server 2000 fédérés « dans la documentation en ligne de SQL Server 2000 32 bits.

Installation d'Analysis Services

Si vous avez besoin d'un serveur d'analyse pour le traitement analytique en ligne (OLAP) et le Data Mining, installez Analysis Services. Vous pouvez choisir d'installer Analysis Server qui accompagne SQL Server. Comme SQL Server 2000 (64 bits) Analysis Services utilise un référentiel SQL Server, le programme d'installation installe toujours Analysis Services avec une instance de SQL Server, notamment les fichiers programme principaux de SQL Server, même si vous choisissez de ne pas installer les composants de base de données de SQL Server. Si vous souhaitez que les serveurs SQL Server et Analysis résident sur le même ordinateur, mais partagent des fichiers serveur de base de données différents, installez-les séparément dans des instances distinctes.


Outils de gestion SQL Server (64 bits)

 SQL Server 2000 (64 bits)

Outils de gestion SQL Server 2000 (64 bits)

Cette rubrique s'applique uniquement à SQL Server 2000 (64 bits).

Ces fonctionnalités peuvent être installés à partir de la catégorie Outils de gestion dans la page Sélection des fonctionnalités de l'Assistant Installation. Les outils de gestion sont inclus lorsque l'option Outils clients uniquement est activée au moment du choix d'installation initial.

Utilitaire réseau serveur

Permet de gérer les bibliothèques serveur Net-Library.

Gestionnaire des services

Permet de démarrer, d'arrêter et d'interrompre les composants Microsoft® SQL Server™ sur le serveur.

Utilitaires de ligne de commande

Permet de gérer les composants et les bases de données SQL Server sur le serveur à partir de la ligne de commande.

Emplacement1 | Utilitaires
\Program Files\Microsoft SQL Server\80\Tools\Binn | Bcp osql scm
\Program Files\Microsoft SQL Server\80\COM | distrib logread qrdrsvc replmerg snapshot
\Program Files\Microsoft SQL Server\MSSQL\Binn également \Program Files\Microsoft SQL Server\MSSQL$nom_instance\Binn | sqlagent sqlmaint sqlsrvr

1 Le lecteur par défaut de ces emplacements est lecteur_système, en général le lecteur C.

Outils non pris en charge

D'autres outils de gestion serveur disponibles avec les versions 32 bits de SQL Server (tels que SQL Server Enterprise Manager, le Gestionnaire de profils SQL Server, l'Analyseur de requêtes SQL, l'utilitaire client MS DTC et l'Affichage des conflits) ne sont pris en charge dans cette version de SQL Server 2000 (64 bits). Vous pouvez les utiliser avec une installation 32 bits de SQL Server 2000 sur un ordinateur 32 bits afin de gérer à distance une installation SQL Server 2000 (64 bits). Pour plus d'informations, reportez-vous à la rubrique Configuration de SQL Server 2000 (64 bits).

Voir aussi

Définition des fonctionnalités de SQL Server (64 bits)


Composants serveur (64 bits)

Le choix d'installation des Composants serveur installe le moteur de base de données relationnelle de Microsoft® SQL Server™ et d'autres outils essentiels. Si un des fichiers programme de SQL Server est installé, le composant SQL Server doit être installé.

Remarque Lors de l'installation du composant SQL Server, le programme d'installation installe également les utilitaires bcp, isql et osql, ODBC, OLE DB et DB-Library.

Fichiers de données

Spécifie l'emplacement des fichiers catalogue de SQL Server. Ces fichiers sont placés dans le dossier racine, là où le programme d'installation crée les dossiers contenant les fichiers de bases de données et les journaux, ainsi que les répertoires contenant les données du journal système, de sauvegarde et de réplication. Le programme d'installation crée des fichiers de base de données et des journaux pour les bases de données master, model, tempdb, msdb, pubs et Northwind. Pour une instance installée avec Analysis Services, cet emplacement peut aussi contenir les bases de données OLAPRepository et Foodmart 2000, de même que le journal des requêtes OLAPQueryLog d'Analysis Services (pour plus d'informations, reportez-vous à la rubrique Analysis Services (64 bits).

Recherche de texte intégral

Installe le moteur de recherche de texte intégral de Microsoft (service Microsoft Search), qui permet d'effectuer une recherche sur des colonnes de caractères, en plus des recherches classiques fondées sur les opérateurs d'égalité et LIKE.

Voir aussi

Définition des fonctionnalités de SQL Server (64 bits)


Analysis Services (64 bits)

Microsoft® SQL Server™ 2000 Analysis Services est un serveur dédié au traitement analytique en ligne (OLAP) et au Data Mining. Analysis Services gère des cubes multidimensionnels de données à analyser et offre un accès client rapide aux informations des cubes.

Le programme Setup.exe installe une seule copie d'Analysis Services avec une seule instance de SQL Server 2000. Si vous le réexécutez pour ajouter une instance supplémentaire de SQL Server 2000, Analysis Services n'apparaît pas dans l'arborescence. Analysis Services utilise cette instance pour prendre en charge son référentiel de métadonnées. En principe, ce composant n'est pas limité à une instance unique de SQL Server 2000. Il peut se connecter non seulement à une instance de SQL Server, mais aussi à une source de données ODBC ou OLE DB.

Cette version de Microsoft SQL Server 2000 (64 bits) n'inclut pas les outils de gestion d'Analysis Services. Pour administrer Analysis Services à distance, utilisez une version 32 bits de SQL Server 2000 Analysis Services installée sur un ordinateur 32 bits.

Fichiers de données

Cette option est nécessaire pour le chemin d'accès des fichiers de données du serveur d'analyse.

Référentiel SQL

Analysis Services utilise SQL Server pour que son référentiel y stocke ses métadonnées d'objets (cubes, dimensions, etc.). Cette base de données se trouve par défaut à l'emplacement suivant :

lecteur_système\Program Files\Microsoft SQL Server\MSSQL$nom_instance\Data\OLAPRepository.mdf

$nom_instance spécifie le nom d'instance d'une instance nommée de SQL Server 2000 (omis pour l'instance par défaut). L'option Référentiel SQL du programme d'installation vous permet de modifier l'emplacement de ces fichiers de données.

Lorsque vous choisissez d'installer Analysis Services, le programme Setup.exe installe les fichiers programme d'Analysis Services et SQL Server Desktop Engine. Si vous choisissez d'installer à la fois les Composants serveur et Analysis Server, le serveur d'analyse utilisera les fichiers programme du serveur de base de données installés avec cette instance de SQL Server pour prendre en charge son référentiel. Si vous ne souhaitez pas que le serveur de base de données SQL Server et Analysis Services partagent les mêmes fichiers programme SQL Server, vous pouvez installer des copies séparées des fichiers programme SQL Server en effectuant deux installations, l'une avec SQL Server seulement et l'autre avec Analysis Services seulement.

SQL Server 2000 (64 bits) Analysis Services n'inclut pas Analysis Manager. Vous pouvez gérer à distance la version 64 bits d'Analysis Services à partir d'une version 32 bits d'Analysis Manager 2000 installée sur un ordinateur 32 bits. Pour cela, votre nom d'utilisateur doit être inscrit dans le groupe Administrateurs ou Administrateurs OLAP du système d'exploitation Windows® 64 bits.

Fichiers de données

L'option Fichiers de données située sous l'option Référentiel SQL du programme d'installation indique l'emplacement du référentiel. Notez que lorsqu'ils sont installés dans la même instance, les fichiers de données des Composants serveur et les fichiers de données du Référentiel SQL d'Analysis Services utilisent le même Chemin d'installation ; la modification du premier entraîne donc celle du second.

Composants clients

Installe les composants clients d'Analysis Services. Il s'agit d'exécutables binaires et de fichiers associés du client Analysis Services.

Voir aussi

Localisation des dossiers et des fichiers (64 bits)

Définition des fonctionnalités de SQL Server (64 bits)


Documentation en ligne (64 bits)

La fonctionnalité Documentation en ligne de SQL Server de l'installation Microsoft® SQL Server™ 2000 (64 bits) englobe la documentation en ligne complète de SQL Server pour SQL Server 2000 et l'Aide en ligne. Pour accéder à l'aide en ligne, cliquez sur le bouton Aide ou appuyez sur la touche F1 dans les boîtes de dialogue et les éléments d'interface. Une autre méthode pour se procurer la documentation en ligne complète de SQL Server pour SQL Server 2000 consiste à la télécharger à partir de la page de la documentation produit de SQL Server sur le site Web de Microsoft.

La sélection de cette fonctionnalité se traduit par l'installation de la documentation complète sur votre disque local aux emplacements par défaut des outils partagés : lecteur_système\Program Files (X80)\Microsoft SQL Server\80\Tools\Books\1033. Pour afficher la documentation en ligne, cliquez sur Démarrer, pointez sur Programmes et sur Microsoft SQL Server, puis cliquez sur Documentation en ligne.

Accès à la documentation en ligne de SQL Server

Installation de SQL

Accès à la documentation en ligne de SQL Server (64 bits)

Remarque Dans cette version de Microsoft SQL Server 2000 (64 bits), la documentation en ligne disponible dans le menu Démarrer provient du produit SQL Server 2000 32 bits. Presque toute la documentation s'applique aux produits 32 bits et 64 bits. La documentation spécifique au produit 64 bits se trouve dans le fichier Setupsql.chm (situé dans lecteur_système\Program Files\Microsoft SQL Server\80\SetupBootstrap\Help\1033\).

Voir aussi

Définition des fonctionnalités de SQL Server (64 bits)


Installation de SQL Server 2000 (64 bits)

Consultez | Description
Présentation (64 bits) | Lire un résumé des étapes du programme d'installation de Microsoft® SQL Server™ 2000 (64 bits) et de la durée du processus. Les autres rubriques figurent dans la procédure d'installation.
Démarrage du programme d'installation (64 bits) | Démarre l'installation de SQL Server ou de n'importe laquelle de ses fonctionnalités.
Définition des fonctionnalités de SQL Server (64 bits) | Définit les fonctionnalités de SQL Server à installer.
Attribution d'un nom aux instances (64 bits) | Définit si l'instance par défaut ou une instance nommée doit être installée et spécifie le nom d'une instance nommée.
Définition des comptes de service (64 bits) | Définit les comptes utilisés pour exécuter les services correspondant aux fonctionnalités que vous installez.
Définition du mode d'authentification (64 bits) | Définit si l'authentification Windows doit être utilisée uniquement ou si l'authentification Windows et l'authentification SQL Server doivent être utilisées conjointement pour vérifier les utilisateurs.
Définition du paramètre de classement (64 bits) | Modifie les paramètres de classement de votre installation SQL Server.
Choix du mode de licence (64 bits) | Permet de choisir le mode de licence, par siège ou par ordinateur.


Présentation (64 bits)

Pour installer tout ou partie des fonctionnalités de Microsoft® SQL Server™ 2000 (64 bits), utilisez le service Windows Installer qui est commun à de nombreux produits Microsoft. Windows Installer vous permet d'utiliser l'option Ajout/Suppression de programmes du Panneau de configuration pour ajouter ou supprimer des fonctionnalités dans une installation existante. Vous pouvez également exécuter Setup.exe sur le CD-ROM de SQL Server 2000 (64 bits) pour installer SQL Server 2000 (64 bits) ou pour modifier une installation existante. Les utilisateurs doivent exécuter Setup.exe dans le cadre d'une installation initiale pour que tous les fichiers de démarrage soient installés sur la machine de destination.

Si vous souhaitez installer une nouvelle instance de SQL Server 2000 (64 bits), précisez dans l'Assistant Installation que vous n'utilisez pas une instance existante de SQL Server mais que vous en installez une nouvelle, entrez les informations d'enregistrement et prenez connaissance du contrat de licence EULA. Ensuite, sélectionnez les fonctionnalités serveur souhaitées. Enfin, en fonction des sélections précédentes, indiquez éventuellement un nom d'instance, des comptes de service et le mode d'authentification, modifiez les paramètres de classement, choisissez le mode de licence approprié et confirmez la configuration de l'installation.

Le processus complet d'installation sur un serveur non ordonné en clusters prend entre 15 et 20 minutes. La partie la plus longue de l'installation, comprenant la copie des fichiers, consiste à générer et à configurer la base de données master de SQL Server. Cette base de données contient des informations sur la configuration et sur toutes les autres bases de données, ainsi que de nombreuses procédures système stockées.

La copie de la base de données master a lieu automatiquement. Par conséquent, si vous acceptez le classement par défaut, l'Assistant Installation copie simplement une base de données master prégénérée en grande partie à partir des fichiers Master.mdf et Mastlog.ldf situés sur le CD-ROM. L'Assistant Installation complète cette tâche avec les configurations complémentaires propres à votre installation. L'installation peut être plus longue si vous n'acceptez pas le classement par défaut. En effet, si vous modifiez le paramètre de classement par défaut, l'Assistant Installation doit réindexer la base de données master.


Démarrage du programme d'installation (64 bits)

Cette rubrique décrit le démarrage de l'installation de Microsoft® SQL Server™ 2000 (64 bits) ou de ses fonctionnalités sur un serveur unique. Pour plus d'informations sur l'installation de SQL Server sur un serveur en clusters, reportez-vous à la rubrique Gestion de clusters avec basculement (64 bits).

Pour démarrer le programme d'installation à l'aide du CD-ROM de SQL Server 2000 (64 bits), insérez le CD-ROM dans le lecteur. Vous pouvez démarrer l'Assistant Installation en exécutant Setup.exe dans le dossier racine qui se trouve sur le CD-ROM du produit. Pour exécuter le programme d'installation à partir d'un lecteur réseau, accédez à l'emplacement d'installation sur le lecteur partagé, puis exécutez Setup.exe.

S'il s'agit de la première installation de SQL Server sur le serveur local, le programme d'installation affiche la page d'accueil. Si le programme d'installation détecte que SQL Server a déjà été installé sur le serveur local, la première page de l'Assistant propose les deux options d'installation suivantes.

Choisissez cette option | Description
Démarrer une nouvelle installation | Installe une instance locale de SQL Server ou, si un cluster est détecté, un cluster avec basculement. Cette version de SQL Server 2000 (64 bits) prend en charge l'installation sur la machine locale uniquement.
Utiliser une installation existante | Modifie ou supprime une instance existante de SQL Server 2000 (64 bits).

Pour plus d'informations sur l'utilisation d'une installation existante, reportez-vous à la rubrique Maintenance d'une installation SQL Server (64 bits).

Pour une nouvelle instance ou une instance supplémentaire de SQL Server ou de n'importe laquelle de ses fonctionnalités, sélectionnez l'option Démarrer une nouvelle installation. Pour installer une instance sur l'ordinateur local, choisissez Instance locale dans la boîte de dialogue, puis cliquez sur Suivant pour afficher la page d'accueil. Sur la page d'accueil, cliquez sur Suivant pour afficher la page Informations d'enregistrement de l'Assistant. Dans la page Informations d'enregistrement, entrez votre nom. Lors d'une installation sur un serveur en réseau, vous pouvez fournir le nom d'un utilisateur chargé de l'utilisation ou de l'administration du serveur. Vous pouvez également entrer le nom de votre société, au choix.

Pour terminer la page Informations d'enregistrement, vous devez entrer la clé du produit sur 25 caractères. (Ce numéro est inscrit sur l'étiquette jaune collée sur la notice ou sur le boîtier du CD-ROM). Pour une installation en réseau, demandez la clé du produit auprès de l'administrateur du réseau ou de SQL Server. Cette option apparaît uniquement lors de la première installation sur un serveur.

Un Contrat de licence de logiciel Microsoft standard apparaît sur la page suivante de l'Assistant. Lisez-le attentivement et cliquez sur Oui pour l'accepter et poursuivre l'installation. Si vous le refusez, cliquez sur Non pour fermer l'Assistant Installation.

Dès lors que vous acceptez les termes du Contrat de licence de logiciel, l'Assistant Installation affiche la page Sélection des fonctionnalités, dans laquelle vous pouvez choisir les fonctionnalités du programme à installer. Pour plus de détails sur vos sélections, reportez-vous à la rubrique Spécification des fonctionnalités de SQL Server (64 bits).

Voir aussi

Utilisation des instances nommées et multiples de SQL Server (64 bits)

Mode d'installation (64 bits)

Informations d'enregistrement (64 bits)


Définition des fonctionnalités de SQL Server (64 bits)

Utilisez la page Sélection des fonctionnalités de l'Assistant Installation pour sélectionner les fonctionnalités devant faire partie d'une installation de SQL Server 2000 (64 bits). Les fonctionnalités sont présentées dans une arborescence affichant les fonctionnalités et les sous-fonctionnalités. Développez les fonctionnalités comportant un signe plus (+) en regard pour en afficher les sous-fonctionnalités. Lorsque vous sélectionnez une fonctionnalité, un volet descriptif donne sur elle des informations détaillées, notamment l'espace disque requis. Ce volet montre également l'espace disque requis par les autres sous-fonctionnalités que vous avez sélectionnées en vue de leur installation avec la fonctionnalité parent.

Pour installer des fonctionnalités spécifiques pendant l'installation, cliquez sur l'icône représentant la fonctionnalité, puis sélectionnez l'une des options suivantes :

Installation sur le disque dur local

Installe la fonctionnalité sélectionnée, mais vous permet de choisir ou non d'installer ses sous-fonctionnalités facultatives.

La totalité de cette fonctionnalité sera installée sur le disque dur local

Installe la fonctionnalité sélectionnée et ses sous-fonctionnalités.

La totalité de cette fonctionnalité ne sera pas disponible

Supprime la fonctionnalité sélectionnée et toutes ses sous-fonctionnalités associées à partir de l'installation. Cette option n'apparaît pas dans le menu lorsqu'une sous-fonctionnalité est requise par sa fonctionnalité parent.

Pour vérifier l'espace disque nécessaire à une fonctionnalité ainsi que l'espace disque disponible sur les différents lecteurs, sélectionnez tout d'abord la fonctionnalité, puis cliquez sur Coût espace disque. Lorsque vous sélectionnez une fonctionnalité associée à un chemin d'accès d'installation, ce chemin apparaît sous Chemin d'installation. Pour modifier l'emplacement de stockage des fichiers de la fonctionnalité, cliquez sur Parcourir et indiquez un autre emplacement.

L'Assistant Installation met à votre disposition les fonctionnalités suivantes. Toutes ces fonctionnalités sont par défaut sélectionnées pour l'installation.

Outils de gestion de SQL Server

Sélectionnez cette fonctionnalité pour installer les outils serveur permettant de créer un serveur de base de données relationnelle doté de fonctionnalités d'administration.

Composants serveurs

Sélectionnez cette fonctionnalité pour installer le moteur de base de données relationnelle de SQL Server, ainsi que d'autres outils essentiels. Si vous sélectionnez soit les sous-fonctionnalités du moteur de recherche de texte intégral, soit les fichiers de données, vous devrez également installer automatiquement la fonctionnalité SQL Server.

Analysis Services

Sélectionnez cette fonctionnalité pour installer Microsoft SQL Server 2000 Analysis Services, qui offre le traitement analytique en ligne (OLAP, Online Analytical Processing) et le Data Mining. Le serveur Analysis Server va installer son propre processus, MSSQLServerOLAPService, distinct du processus SQL Server 64 bits. Bien qu'Analysis Services puisse se connecter à plusieurs instances de SQL Server exécutées sur un seul ordinateur, vous ne pouvez pas installer plusieurs instances d'Analysis Services sur un ordinateur unique. Le service Analysis Services apparaîtra dans l'arborescence des fonctionnalités jusqu'à ce qu'il soit installé sur le serveur. Analysis Services utilise les fichiers programme de SQL Server associés à l'instance avec laquelle il a été installé pour prendre en charge son référentiel.

Documentation en ligne

Sélectionnez cette fonctionnalité pour installer la documentation en ligne de SQL Server 2000. Vous pouvez ouvrir cette documentation dans le menu Démarrer en choisissant Documentation en ligne dans le groupe de programmes de Microsoft SQL Server.

Voir aussi

Sélection de fonctionnalités (64 bits)

Chemins d'accès aux fichiers de SQL Server 2000 (64 bits)


Attribution d'un nom aux instances (64 bits)

Pour pouvoir travailler avec une base de données, les applications clientes doivent tout d'abord se connecter à une instance de Microsoft® SQL Server™ 2000 (64 bits). Chaque instance est constituée d'un ensemble distinct de services et peut comporter des paramètres complètement différents pour les classements et les autres options. La structure des répertoires, la structure du registre et les noms des services reflètent tous le nom de l'instance spécifique que vous avez identifié pendant l'installation. Une instance peut être soit l'instance par défaut, soit une instance nommée.

Utilisez la page Mode d'installation de l'Assistant Installation pour indiquer s'il faut installer l'instance par défaut ou une instance nommée. L'instance par défaut est identifiée uniquement par le nom réseau de l'ordinateur sur lequel elle est exécutée, et elle n'a pas besoin d'un client pour spécifier le nom de l'instance pour établir une connexion. Une instance nommée est identifiée par le nom réseau de l'ordinateur suivi du nom de l'instance, conformément au format <nom_ordinateur>\<nom_instance>.

Instances multiples

SQL Server 2000 (64 bits) prend en charge plusieurs instances sur un serveur ou un processeur unique. Un ordinateur peut exécuter simultanément plusieurs instances de SQL Server, et chaque instance s'exécute indépendamment des autres. Un serveur peut comporter une seule instance par défaut de SQL Server, et plusieurs instances nommées à hauteur des ressources disponibles sur l'ordinateur. Le nombre maximal d'instances prises en charge par SQL Server 2000 (64 bits) est 16.

Remarque Les licences de SQL Server 2000 (64 bits) Édition Entreprise prennent en charge plusieurs instances de SQL Server sans licences supplémentaires. Techniquement, les autres éditions peuvent prendre en charge plusieurs instances mais elles nécessitent une licence propre chaque instance installée sur un serveur. Pour plus d'informations, consultez le contrat de licence de logiciel fourni avec votre produit.

Une instance nommée peut être installée soit en tant que première ou seule instance, soit dans une prochaine installation de SQL Server. Lorsque vous installez pour la première fois SQL Server 2000 (64 bits) sur un ordinateur ne comportant aucune installation SQL Server, le programme d'installation spécifie l'installation de l'instance par défaut, même si vous pouvez choisir d'installer SQL Server en tant qu'instance nommée sans installer d'abord l'instance par défaut.

Création d'une instance nommée

Pour créer une instance nommée, choisissez Instance nommée dans la page Nom d'instance de l'Assistant Installation et tapez un nom d'instance. Un nom d'instance doit commencer par une lettre ou un trait de soulignement (_), et il peut contenir des chiffres, des lettres ou d'autres caractères. Les noms sysnames et les mots clés réservés de SQL Server ne doivent pas être utilisés pour les noms d'instance. Par exemple, le nom « default » ne doit pas être utilisé comme nom d'instance parce qu'il s'agit d'un mot clé réservé au programme d'installation.

Règles de dénomination des instances

Les règles complètes de dénomination d'une instance sont les suivantes :

  • Un nom d'instance ne fait pas la distinction entre les majuscules et les minuscules.

  • Les noms d'instance doivent respecter les règles en vigueur pour les identificateurs SQL Server et ils ne doivent pas être des mots clés réservés (par exemple, un nom d'instance ne peut pas être « default » ou « MSSQLServer »).

  • Les lettres acceptées sont celles définies par Unicode Standard 2.0, qui comprend les caractères latins a-z et A-Z ainsi que des caractères alphabétiques d'autres langues. Pour plus de détails, consultez la page Unicode Standard sur le site Web Unicode.

  • Le premier caractère d'un nom d'instance doit être une lettre Unicode Standard, un trait de soulignement (_) ou un signe dièse (#).

  • Les caractères d'un nom d'instance peuvent être des lettres Unicode Standard, des nombres décimaux provenant de scripts latin ou nationaux, le signe dollar ($), le signe dièse (#) ou le trait de soulignement (_).

  • Les caractères suivants ne sont pas autorisés : espaces imbriqués, caractères spéciaux, barre oblique inverse (\), virgule (,), deux-points (:) ou signe @.

Voir aussi

Nom d'instance (64 bits)

Utilisation des instances nommées et multiples de SQL Server (64 bits)


Spécification des comptes de service (64 bits)

Utilisez la page Compte de service de l'Assistant Installation pour spécifier les comptes de connexion du programme d'installation aux services Microsoft® SQL Server 2000™.

Service | Description
SQL Server (MSSQLSERVER ou MSSQL$nom_instance pour une instance nommée) | Fournit la fonctionnalité de base de données relationnelle principale de SQL Server.
Agent SQL Server (SQLSERVERAGENT ou SQLAgent$nom_instance pour une instance nommée) | Offre la possibilité de planifier des commandes régulières, de planifier la réplication, de fournir une méthode de traitement des erreurs, de contacter des opérateurs SQL Server lorsque des erreurs se produisent, ainsi que d'autres fonctions de support technique.
Analysis Services (MSSQLServerOLAPService) | Fournit le moteur Analysis Services pour la fonctionnalité OLAP et de Data Mining. Bien qu'il soit installé avec une instance et qu'il utilise la fonctionnalité relationnelle principale fournie par cette instance, Analysis Services est installé à un emplacement distinct et n'est pas identifié par le nom d'instance. Vous pouvez installer Analysis Services avec une seule instance de SQL Server 2000 (64 bits) sur un serveur.

Lors de l'installation, vous pouvez configurer ces services de sorte qu'ils utilisent l'un des comptes Microsoft Windows® suivants :

  • Compte système local

  • Compte d'utilisateur local

  • Compte d'utilisateur de domaine

Vous pouvez spécifier le même compte pour tous les services ou bien spécifier un compte différent pour chaque service. La sélection utilisée dépend de la fonctionnalité requise par votre installation SQL Server 2000 (64 bits).

Compte système local

SQL Server 2000 (64 bits) peut s'exécuter à l'aide du compte système local si SQL Server n'a pas besoin d'accéder aux ressources réseau et s'il n'est pas configuré pour la réplication. Vus devez définir les autorisations suivantes pour le compte système local de SQL Server 2000 (64 bits) pour que les tâches soient effectuées correctement :

Pour l'instance par défaut

  • le contrôle total du dossier Microsoft SQL Server, par défaut :
    • lecteur_système\Program Files\Microsoft SQL Server\MSSQL
  • le contrôle total de tous les fichiers de base de données .mdf, .ndf et .ldf ;

  • le contrôle total des clés du registre :
    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSSQLServer

    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server

    • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSSQLSERVER

Pour une instance nommée

  • le contrôle total du dossier SQL Server, par défaut :
    • lecteur_système\Program Files\Microsoft SQL Server\MSSQL$nom_instance
  • le contrôle total de tous les fichiers de base de données .mdf, .ndf et .ldf ;

  • le contrôle total des clés du registre :
    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server

    • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSSQL$

Pour le service Analysis Services

  • le contrôle total du dossier Microsoft Analysis Services, par défaut :
    • lecteur_système\Program Files\Microsoft Analysis Services
  • le contrôle total des clés du registre :
    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\OLAP Server

    • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSSQLServerOLAPService
Compte d'utilisateur local

Si SQL Server 2000 (64 bits) est configuré pour utiliser un compte d'utilisateur local Windows, le compte connaît les mêmes restrictions que pour un compte système local, auxquelles s'ajoute l'autorisation Ouvrir une session en tant que service.

Pour créer ou gérer un cluster avec basculement Microsoft SQL Server 2000 (64 bits), vous devez être connecté à un ordinateur doté de privilèges administrateur : en d'autres termes, vous devez être membre du groupe local Administrateurs de l'ordinateur ou du domaine. Dans le cadre de la gestion de clusters, cela signifie que vous devez être l'administrateur de tous les nœuds du cluster.

Compte d'utilisateur de domaine

La configuration de SQL Server 2000 (64 bits) avec un compte d'utilisateur de domaine apporte la souplesse maximale. Certains exemples de fonctionnalités fournies par un utilisateur de domaine sont les suivants :

  • réplication ;

  • sauvegarde et restauration à partir de lecteurs réseau ;

  • jointures hétérogènes faisant intervenir des sources de données distantes ;

  • possibilité de définir des partitions à distance sur un serveur d'analyse ;

  • possibilité de traiter des cubes liés à l'aide d'un serveur d'analyse.

Afin que SQL Server 2000 (64 bits) puisse effectuer ces tâches, le compte d'utilisateur du domaine doit être configuré de la même façon que le compte local présenté plus haut. De plus, des fonctionnalités étendues sont disponibles par l'ajout d'autorisations supplémentaires décrites dans le tableau suivant.

Service | Autorisation | Fonctionnalité
SQL Server | Autorisations d'écriture sur le réseau | Lecture/écriture sur les sauvegardes distantes, les charges de données, etc.
SQL Server | Fonctionne comme un module du système d'exploitation et remplace le jeton au niveau du traitement | Exécution de xp_cmdshell pour un utilisateur autre qu'un administrateur SQL Server
Agent SQL Server | Membre du groupe Administrateurs locaux | Création de tâches CmdExec et ActiveScript n'appartenant pas à un administrateur SQL Server
Agent SQL Server | Membre du groupe Administrateurs local | Utilisation de la fonction de redémarrage automatique
Agent SQL Server | Membre du groupe Administrateurs local | Exécution des travaux en arrière-plan
Analysis Services | Membre du groupe Administrateurs OLAP sur le serveur distant | Liaison au cube source sur le serveur d'analyse distant
Analysis Services | Autorisations sur les sources de données accessibles par Analysis Services | Obligatoire pour les objets de traitement

Pour que l'utilisateur tire parti d'un maximum de fonctionnalités de SQL Server 2000 (64 bits), le compte d'utilisateur du domaine doit être membre du groupe Administrateurs local.

Si vous spécifiez un emplacement de stockage de données distant pour Analysis Services, vous devez utiliser un compte de domaine disposant d'un accès à cet emplacement.

Voir aussi

Création des comptes de service Windows (64 bits)

Compte de service (64 bits)


Définition du mode d'authentification (64 bits)

Microsoft® SQL Server™ utilise un processus d'authentification permettant de valider les utilisateurs par rapport à des autorisations de compte SQL Server ou Microsoft Windows®. Dans la page Mode d'authentification de l'Assistant Installation, vous pouvez choisir l'un des modes suivants.

Mode d'authentification Windows

Quand un utilisateur se connecte par le biais d'un compte d'utilisateur Windows, SQL Server valide le nom et le mot de passe du compte à partir des informations du système d'exploitation Windows. Ce mode fournit le niveau de sécurité le plus élevé. Il est recommandé lorsque la compatibilité ascendante n'est pas un problème.

Dans le cas de l'authentification Windows, SQL Server réalise l'intégration de la sécurité de connexion d'accès avec Windows en utilisant les attributs de sécurité d'un utilisateur du réseau pour contrôler les droits d'accès. Les attributs de sécurité d'un utilisateur du réseau sont définis lors de la validation du mot de passe et de la connexion au réseau au moyen d'un contrôleur de domaine Windows. Lorsqu'un utilisateur du réseau tente de se connecter, SQL Server utilise Windows pour déterminer le nom d'utilisateur du réseau validé, vérifie l'identité de l'utilisateur, puis accepte ou refuse l'accès en fonction du nom d'utilisateur du réseau. Dans ce mode de sécurité, seules les connexions approuvées sont autorisées.

Les administrateurs de SQL Server se voient accorder l'accès à SQL Server par le biais de l'appartenance au groupe Windows, tandis que ce groupe se voit affecter le rôle de serveur sysadmin. Les administrateurs Windows peuvent toutefois accorder à toute personne les autorisations sysadmin sur SQL Server 2000 (64 bits), puisqu'ils ont la possibilité d'ajouter un utilisateur au groupe Windows approprié. Si les administrateurs Windows ne sont pas en mesure de s'attribuer l'accès sysadmin à SQL Server ou de l'attribuer aux autres, seuls les comptes Windows individuels doivent détenir le rôle sysadmin.

Remarque Pour améliorer la sécurité avec le mode d'authentification Windows, vous pouvez utiliser la procédure stockée sp_password afin de définir un mot de passe pour le compte administrateur système (sa). Cela permet d'éviter que l'installation passe ultérieurement en mode mixte sans mot de passe pour le compte sa.

Remarque importante Utilisez si possible l'authentification Windows.

Mode mixte

Le mode mixte permet aux utilisateurs de se connecter en utilisant l'authentification Windows ou l'authentification SQL Server. Les utilisateurs qui se connectent par l'intermédiaire d'un compte d'utilisateur Windows peuvent utiliser des connexions approuvées (des connexions validées par Windows) soit en mode d'authentification Windows, soit en mode mixte.

L'authentification SQL Server est disponible pour des raisons de compatibilité ascendante car il arrive que des applications écrites pour SQL Server version 7.0 ou antérieure utilisent des connexions d'accès et des mots de passe SQL Server. Certains développeurs d'applications préfèrent l'authentification SQL Server car ils y sont habitués. L'authentification SQL Server peut également être nécessaire pour les connexions établies avec des périphériques clients qui n'exécutent pas les systèmes d'exploitation Windows NT® 4.0, Windows 2000 ou Windows XP.

Si vous choisissez le mode mixte, il est fortement recommandé d'affecter un mot de passe fort à la connexion sa. Il est alors conseillé de ne pas utiliser la connexion sa pour l'administration quotidienne et de verrouiller le mot de passe dans un endroit sûr, accessible en cas d'urgence uniquement.

Pour plus d'informations sur l'authentification, reportez-vous à la section "Gestion de la sécurité" de la rubrique "Administration de SQL Server" dans la documentation en ligne de SQL Server 2000.

Voir aussi

Mode d'authentification (64 bits)


Définition du paramètre de classement (64 bits)

Utilisez la page Paramètres de classement de l'Assistant Installation pour modifier les paramètres de classement par défaut. Utilisez l'option Indicateur de classement pour une mise en correspondance avec les paramètres de classement des instances de Microsoft® SQL Server™ 2000 (64 bits). Utilisez l'option Classements SQL pour une mise en correspondance avec les paramètres compatibles aux ordres de tri des versions antérieures de SQL Server.

Indicateur de classement

Ne modifiez les paramètres par défaut des options Indicateur de classement (classement Microsoft Windows®) et de l'ordre de tri que si votre installation de SQL Server doit correspondre aux paramètres de classement utilisés par une autre instance de SQL Server 2000 ou aux paramètres régionaux d'un autre ordinateur.

Indicateur de classement

Sélectionnez dans la liste le nom d'un classement Windows spécifique. Par exemple :

  • utilisez Latin1_General pour le jeu de caractères anglais É.U. (page de code 1252) ;

  • utilisez Modern_Spanish pour toutes les variantes de l'espagnol, qui utilise également le même jeu de caractères que celui de anglais É.U. (page de code 1252) ;

  • utilisez Arabic pour toutes les variantes de l'arabe, qui utilise le jeu de caractères arabe (page de code 1256) ;

  • utilisez Japanese_Unicode pour la version Unicode du japonais (page de code 932), dont l'ordre de tri est différent de Japanese, mais qui partage la même page de code (932).

    Pour plus d'informations, reportez-vous à la rubrique "Styles de tri des classements Windows" dans la documentation en ligne de SQL Server 2000 32 bits.

Ordre de tri

Sélectionnez les options Ordre de tri à utiliser avec l'Indicateur de classement désigné. L'ordre de tri Binaire est le plus rapide et respecte la casse. Si Binaire est activé, les options Respecter la casse, Respecter les accents, Respecter le jeu de caractère Kana et Respecter la largeur ne sont pas disponibles. Pour plus d'informations, reportez-vous à la rubrique "Styles de tri des classements Windows" dans la documentation en ligne de SQL Server 2000 32 bits.

Classements SQL

L'option Classements SQL permet d'assurer une compatibilité avec les versions précédentes de SQL Server. Activez cette option pour correspondre aux paramètres compatibles avec SQL Server version 7.0, SQL Server version 6.5 ou antérieure. Pour plus d'informations, reportez-vous à la rubrique "Utilisation des classements SQL" dans la documentation en ligne de SQL Server 2000 32 bits.

Pour plus d'informations, reportez-vous à la rubrique "Définition du paramètre de classement" dans la documentation en ligne de SQL Server 2000 32 bits.


Choix du mode de licence (64 bits)

Microsoft® SQL Server™ 2000 (64 bits) prend en charge deux modes de licence d'accès client, l'un basé sur les périphériques et l'autre sur les processeurs.

  • Dans ce contexte, un périphérique désigne une station de travail, un terminal ou tout autre périphérique exécutant une application SQL Server connectée à une instance de SQL Server.

  • Un processeur désigne une unité centrale (UC) installée sur un ordinateur exécutant une instance de SQL Server 2000. Un ordinateur peut disposer de plusieurs processeurs, ce qui implique des licences multiprocesseur.

Une fois le mode de licence défini, vous ne pouvez plus le modifier, à moins de désinstaller et de réinstaller le produit. Lorsque vous avez installé SQL Server, vous pouvez utiliser l'application Gestion des licences SQL Server 2000 dans le Panneau de configuration pour ajouter des licences de processeur ou de périphérique.

Remarque Ne confondez pas l'utilitaire de licence SQL Server avec l'utilitaire de licence Windows qui se trouve également dans le Panneau de configuration.

Etudiez le contrat de licence logiciel fourni avec SQL Server 2000 pour rechercher le type et le nombre de licences qui ont été achetées avec le produit. Ensuite, dans la page Mode de licence de l'Assistant Installation, choisissez l'une des deux options suivantes :

Par siège

Ce mode de licence requiert une licence pour l'ordinateur exécutant SQL Server 2000 (64 bits) et des licences d'accès client (CAL) pour chaque périphérique client qui se connecte au serveur. À titre d'exemple, un périphérique est un ordinateur personnel, une station de travail, un terminal, un assistant numérique personnel ou un téléphone mobile. Un nombre précis de licences d'accès client est inclus avec la licence serveur et les logiciels serveur. Si vous choisissez cette option, en regard de périphériques, tapez le nombre de licences d'accès client pour SQL Server 2000 (64 bits).

Par ordinateur

Ce mode de licence requiert une licence unique pour chaque unité centrale installée sur l'ordinateur exécutant SQL Server. Une licence par ordinateur permet à un nombre illimité d'utilisateurs de se connecter à partir du réseau LAN local de leur entreprise, d'un réseau WAN ou d'Internet. Si vous choisissez cette option, en regard de processeurs, tapez le nombre de licences par processeur achetées pour SQL Server 2000 (64 bits).

Le mode de licence par siège est souvent plus économique pour les réseaux dont les clients se connectent rarement à SQL Server sur votre réseau (par exemple, moins de 75 périphériques pour l'Édition Entreprise). Le mode de licence par ordinateur, en revanche, est plus économique dans le cadre d'une installation qui permet d'accéder aux bases de données SQL Server sur Internet ou qui prend en charge un grand nombre d'utilisateurs dans un réseau LAN ou WAN. Dans ce mode, SQL Server tire parti de chaque processeur installé sur l'ordinateur et prend en charge un nombre illimité de périphériques clients.

Pour plus d'informations sur le prix et les règles de gestion des licences en vigueur, consultez la page Web de Microsoft SQL Server.

Important La gestion des licences de Microsoft SQL Server 2000 (64 bits) est régi par le contrat EULA (End User Licensing Agreement) accompagnant le produit. Le contrat EULA régissant toutes les utilisations, les explications fournies dans le présent document n'ont pas pour but de remplacer les termes de ce contrat.

Voir aussi

Mode de licence (64 bits)


Gestion de clusters avec basculement (64 bits)

Dans Microsoft® SQL Server™ 2000 Édition Entreprise (64 bits), la gestion de clusters avec basculement offre un niveau élevé de disponibilité. Par exemple, lors d'une défaillance du système d'exploitation ou d'une mise à jour planifiée, vous pouvez configurer un nœud d'un cluster avec basculement pour qu'il bascule vers un autre nœud d'un cluster avec basculement configuré à cet effet.

Pour installer, configurer et gérer un cluster avec basculement, utilisez le programme d'installation de SQL Server. Comme il n'existe pas de versions 64 bits antérieures de SQL Server, la mise à jour d'un cluster avec basculement existant vers un cluster avec basculement SQL Server 2000 (64 bits) n'est pas possible. Par ailleurs, sachez que la prise en charge de plusieurs instances de SQL Server diffère dans le scénario de gestion de clusters avec basculement : vous pouvez créer plusieurs serveurs virtuels dans un cluster, mais chacun d'entre eux ne peut avoir qu'une seule d'instance de SQL Server installée.

Utilisez la gestion de clusters avec basculement pour effectuer les opérations suivantes :

  • Installer SQL Server sur plusieurs nœuds dans un cluster avec basculement. Vous n'êtes limité que par le nombre de nœuds pris en charge par le système d'exploitation.

    Pour installer la gestion de clusters avec basculement, vous devez au préalable installer le service MSCS (Microsoft Cluster Service) ainsi que les versions 64 bits de la famille Windows® Server 2003 (des versions 64 bits supplémentaires du système d'exploitation Windows pour les serveurs seront disponibles dans les prochaines versions de SQL Server 2000 [64 bits]). Comme il n'existe pas de version 64 bits de Windows NT® 4.0 ou de Windows 2000, vous ne pouvez pas installer SQL Server 2000 (64 bits) avec Windows NT 4.0 ou Windows 2000.

    Pour utiliser la gestion de clusters avec basculement, suivez les étapes d'installation ci-après. Pour plus d'informations, reportez-vous à la rubrique Gestion d'une installation de clusters avec basculement.

  • Spécifier plusieurs adresses IP pour chaque serveur virtuel.

    Avec SQL Server 2000 (64 bits), vous pouvez spécifier plusieurs adresses IP pour chaque serveur, ce qui vous permet d'utiliser tous les sous-réseaux IP disponibles du réseau. Vous disposez ainsi de solutions de remplacement pour vous connecter en cas d'échec d'un sous-réseau et bénéficiez d'une évolutivité du réseau accrue. Avec une carte réseau unique, par exemple, une défaillance du réseau peut interrompre les communications, mais avec plusieurs cartes réseau sur le serveur, chaque réseau peut se trouver sur un sous-réseau IP différent. En cas d'échec d'un sous-réseau, au moins une connexion peut continuer à fonctionner. Ainsi, si un routeur est défaillant, le service MSCS continue de fonctionner et toutes les adresses IP restent opérationnelles. Si toutefois la défaillance se situe au niveau de la carte réseau de l'ordinateur local, la communication peut être interrompue. Pour plus d'informations, reportez-vous à la rubrique Création d'un cluster avec basculement (64 bits).

  • Administrer un cluster avec basculement à partir de n'importe quel nœud dans la configuration SQL Server organisée en clusters. Pour plus d'informations, reportez-vous à la rubrique Création d'un cluster avec basculement (64 bits).

  • Autoriser le basculement d'un serveur virtuel vers n'importe quel autre nœud de la configuration de cluster avec basculement de serveurs virtuels. Pour plus d'informations, reportez-vous à la rubrique Création d'un cluster avec basculement (64 bits).

  • Ajouter ou supprimer des nœuds à partir de la configuration de cluster avec basculement à l'aide du programme d'installation. Pour plus d'informations, reportez-vous à la rubrique Maintenance d'un cluster avec basculement (64 bits).

  • Réinstaller ou reconstruire un serveur virtuel sur n'importe quel nœud du cluster avec basculement sans affecter les autres nœuds. Pour plus d'informations, reportez-vous à la rubrique Maintenance d'un cluster avec basculement (64 bits).

  • Effectuer des requêtes de texte intégral à l'aide du service Microsoft Search et de la gestion de clusters avec basculement. Pour plus d'informations, reportez-vous à la rubrique Utilisation des outils SQL Server dans la gestion de clusters avec basculement.


Prise en charge de la gestion de clusters avec basculement (64 bits)

Dans Microsoft® SQL Server™ 2000 Édition Entreprise (64 bits), le nombre de nœuds pris en charge pour la gestion de clusters avec basculement dépend du système d'exploitation :

  • Les versions 64 bits de la famille Windows ®Server 2003 prennent en charge jusqu'à quatre noeuds. Les systèmes d'exploitation Windows 64 bits supplémentaires qui seront disponibles dans les prochaines versions de SQL Server 2000 (64 bits) prendront en charge jusqu'à huit nœuds. Ces systèmes d'exploitation requièrent des canaux en fibre optique pour la gestion de clusters.

  • Comme il n'existe pas de version 64 bits de Windows NT® 4.0 ou de Windows 2000, vous ne pouvez pas installer SQL Server 2000 (64 bits) avec Windows NT 4.0 ou Windows 2000.

Les outils, fonctionnalités et services suivants sont pris en charge avec la gestion de clusters avec basculement de SQL Server 2000 (64 bits) :

  • Service Microsoft Search. Pour plus d'informations, reportez-vous à la rubrique Utilisation des outils SQL Server dans la gestion de clusters avec basculement.

  • Réplication. Pour plus d'informations, reportez-vous à la rubrique Création d'un cluster avec basculement (64 bits).

  • Gestionnaire de contrôle de service. Pour plus d'informations, reportez-vous à la rubrique Utilisation des outils SQL Server dans la gestion de clusters avec basculement.

En outre, les outils suivants peuvent être utilisés pour la gestion de clusters avec basculement avec SQL Server 2000 (64 bits), à condition qu'ils soient administrés à distance à partir d'un ordinateur 32 bits. Ces outils ne sont pas exécutables sur un ordinateur SQL Server 2000 (64 bits). Pour bénéficier des outils SQL Server 2000, installez-les impérativement sur un ordinateur 32 bits. Pour plus d'informations, reportez-vous à la rubrique Configuration de SQL Server 2000 (64 bits).

  • SQL Server Enterprise Manager. Pour plus d'informations, reportez-vous à la rubrique Utilisation des outils SQL Server dans la gestion de clusters avec basculement.

  • Générateur de profils SQL Server. Pour plus d'informations, reportez-vous à la rubrique Utilisation des outils SQL Server dans la gestion de clusters avec basculement.

  • Analyseur de requêtes SQL Server. Pour plus d'informations, reportez-vous à la rubrique Utilisation des outils SQL Server dans la gestion de clusters avec basculement.

La fonctionnalité suivante n'est pas prise en charge pour la gestion de clusters avec basculement :

  • SQL Server 2000 Analysis Services


Gestion d'une installation de clusters avec basculement (64 bits)

Lorsque vous installez un cluster avec basculement Microsoft® SQL Server™ 2000 (64 bits), vous devez :

  • vérifier que le système d'exploitation est correctement installé et conçu pour prendre en charge la gestion de clusters avec basculement. Pour plus d'informations sur la préparation nécessaire à l'installation d'un cluster avec basculement, reportez-vous à la rubrique Avant l'installation de la gestion de clusters avec basculement (64 bits) ;

  • déterminer si les outils, fonctionnalités et composants de SQL Server que vous souhaitez utiliser sont pris en charge pour la gestion de clusters avec basculement. Pour plus d'informations, reportez-vous à la rubrique Prise en charge de la gestion de clusters avec basculement (64 bits) ;

  • déterminer si la gestion de clusters avec basculement est dépendante des produits à utiliser. Pour plus d'informations, reportez-vous à la rubrique Dépendances de la gestion de clusters avec basculement (64 bits) ;

  • déterminer le mode de création d'un cluster avec basculement. Pour plus d'informations sur la création d'une configuration de clusters avec basculement, reportez-vous à la rubrique Création d'un cluster avec basculement (64 bits).


Avant l'installation de la gestion de clusters avec basculement (64 bits)

Avant d'installer un cluster avec basculement Microsoft® SQL Server™ 2000 (64 bits), vous devez sélectionner le système d'exploitation utilisé par votre ordinateur. Notez que, pour cette version, seul un système d'exploitation est disponible : les versions 64 bits de la famille Windows Server 2003. Pour les prochaines versions de SQL Server 2000 (64 bits), des systèmes d'exploitation Windows 64 bits supplémentaires seront proposés. Vous devez également installer le service de cluster Microsoft (MSCS).

Liste de contrôle de pré-installation

Avant de démarrer le processus d'installation, vérifiez les éléments suivants :

  • Votre matériel doit figurer dans la liste de compatibilité matérielle des versions 64 bits de la famille Windows Server 2003.

    Le système de matériel doit apparaître sous la catégorie de cluster. Les composants de cluster individuels ajoutés entre eux ne constituent pas un système approuvé. Seuls les systèmes achetés en tant que solution de cluster et figurant dans le groupe de clusters sont approuvés. Lors de la vérification de la liste, indiquez cluster pour la catégorie. Tous les autres types sont réservés à un usage OEM.

    Des tests de compatibilité matérielle spéciaux sont nécessaires lors de l'implémentation d'un cluster de serveurs avec basculement sur un réseau SAN (Storage Area Network). La solution complète doit se trouver dans la liste de compatibilité matérielle des périphériques multiclusters. Cela est également vrai lors de l'implémentation de nœuds de cluster avec basculement dans des emplacements géographiques distincts. La solution complète doit se trouver dans la liste de compatibilité matérielle de clusters géographique.

  • MSCS a fait l'objet d'une installation complète sur au moins un nœud avant que vous n'exécutiez les versions 64 bits de la famille Windows Server 2003 de manière simultanée sur tous les nœuds.

  • WINS est correctement installé. Pour obtenir des instructions, consultez le site Web de Microsoft et recherchez l'article suivant (en anglais) : Q258750 Recommended Private "Heartbeat" Configuration on Cluster Server.

  • Les lettres de lecteur de disque pour les disques de clusters sont identiques sur les deux serveurs.

  • Vous avez désactivé NetBIOS pour toutes les cartes réseau privées avant d'entamer la procédure d'installation de SQL Server.

  • Vous avez effacé les journaux système sur tous les nœuds avant de les afficher à nouveau. Vérifiez que les journaux ne contiennent aucun message d'erreur avant de continuer.

Consultez également le didacticiel relatif à l'installation en cluster Windows à l'adresse suivante : Microsoft Web site. (Pour plus d'informations sur ces étapes, consultez votre documentation sur Windows.)

Pour plus d'informations sur l'installation de la gestion de clusters avec basculement sur SQL Server 2000 (64 bits), reportez-vous à la rubrique Création d'un cluster avec basculement (64 bits).


Création d'un cluster avec basculement (64 bits)

Pour créer un cluster avec basculement Microsoft® SQL Server™ 2000, vous devez créer et configurer un serveur virtuel. Pour y parvenir, exécutez le programme d'installation de SQL Server. Cette rubrique explique les éléments d'un serveur virtuel et fournit des informations importantes sur l'attribution d'un nom à un serveur virtuel. Elle présente également les étapes de la création d'un cluster avec basculement.

Éléments d'un serveur virtuel

Un serveur virtuel contient :

  • un ensemble composé d'un ou de plusieurs disques dans un groupe de clusters Microsoft Cluster Server (MSCS) ;

    chaque groupe de clusters MSCS peut contenir au moins un serveur virtuel SQL Server ;

  • un nom réseau pour chaque serveur virtuel ; ce nom réseau est le nom du serveur virtuel ;

  • une ou plusieurs adresses IP utilisées pour connecter chaque serveur virtuel ;

  • une instance de SQL Server 2000 (64 bits) qui contient une ressource SQL Server, une ressource d'Agent SQL Server et une ressource de texte intégral ;

    si un administrateur désinstalle l'instance de SQL Server 2000 (64 bits), le serveur virtuel, qui contient toutes les adresses IP et le nom du réseau, est également supprimé du groupe de clusters MSCS SQL Server.

Un cluster avec basculement peut s'exécuter sur un ou plusieurs ordinateurs qui sont des nœuds participants du cluster et qui utilisent les versions 64 bits du système d'exploitation de la famille Windows ®Server 2003. Toutefois, un serveur virtuel SQL Server apparaît toujours sur le réseau comme un ordinateur unique.

Dénomination d'un serveur virtuel

SQL Server 2000 (64 bits) dépend de clés de registre et de noms de service différents au sein du cluster avec basculement, de manière à ce que les opérations se poursuivent correctement après un basculement. Par conséquent, le nom choisi pour l'instance de SQL Server 2000 (64 bits), ainsi que pour l'instance par défaut, doit être unique sur tous les nœuds et sur tous les serveurs virtuels du cluster. Si toutes les instances basculaient vers un serveur unique, par exemple, leurs noms de service et clés de registre doivent être bien distincts.

De plus, vous pouvez utiliser le nom du serveur virtuel pour vous connecter à un serveur virtuel SQL Server 2000 (64 bits). Vous ne pouvez pas utiliser le nom de nœud de l'ordinateur sur lequel l'instance s'exécute à ce moment là. Vous êtes ainsi assuré que vous pourrez toujours vous connecter au serveur virtuel à l'aide du même nom. SQL Server 2000 (64 bits) ne prête aucune attention à l'adresse IP sur les serveurs locaux. Il prend uniquement en considération la ou les adresses IP organisées en clusters créées au cours de l'installation d'un serveur virtuel pour SQL Server 2000 (64 bits).

Considérations sur l'utilisation

Avant de créer un cluster avec basculement, vérifiez que les conditions suivantes sont remplies :

  • Dans une configuration de clusters avec basculement, le nom du réseau et l'adresse IP de votre serveur virtuel SQL Server ne doivent pas être utilisés à d'autres fins, telles que le partage de fichiers. Si vous souhaitez créer une ressource de partage de fichier, vous devez utiliser un nom de réseau et une adresse IP différentes.

    Important SQL Server 2000 (64 bits) prend en charge les canaux nommés et les sockets TCP/IP sur TCP/IP au sein d'un cluster avec basculement. Néanmoins, nous vous recommandons fortement d'utiliser les sockets TCP/IP dans une configuration organisée en clusters.

  • Si vous avez besoin de serveurs à haute disponibilité pour la réplication, utilisez un partage de fichier de cluster MSCS comme dossier de capture instantanée lorsque vous configurez un distributeur sur un cluster avec basculement. En cas de panne du serveur, la base de données de distribution restera disponible et la configuration se poursuivra au niveau du distributeur. Pour plus d'informations, reportez-vous aux rubriques "Autres emplacements de capture instantanée" et "Éditeurs, distributeurs et abonnés" dans la documentation en ligne de SQL Server 2000 32 bits

Par ailleurs, lorsque vous créez des publications, spécifiez le partage de fichier MSCS pour le stockage supplémentaire des fichiers de capture instantanée ou en tant qu'emplacement à partir duquel les abonnés appliquent l'instantané. De cette façon, tous les fichiers d'instantanés seront disponibles pour tous les noeuds du cluster et pour tous les abonnés devant y accéder.

  • Pour utiliser le cryptage à l'aide d'un cluster avec basculement, installez le certificat du serveur avec le nom DNS complet du serveur virtuel sur tous les nœuds du cluster avec basculement. Par exemple, si vous disposez d'un cluster à deux nœuds intitulés" test1.redmond.corp.microsoft.com" et "test2.redmond.corp.microsoft.com" et d'un serveur SQL Server virtuel intitulé "Virtsql", vous devez vous procurer un certificat pour "virtsql.redmond.corp.microsoft.com" et installer le certificat sur les deux nœuds. Vous pouvez ensuite activer la case à cocher Forcer le cryptage du protocole dans l'utilitaire réseau serveur pour configurer votre cluster avec basculement à des fins de cryptage. N'activez pas la case à cocher Forcer le cryptage du protocole tant que les certificats n'ont pas été installés sur tous les nœuds participants de votre serveur virtuel.

  • Le service de cluster doit vérifier que le serveur SQL Server virtuel s'exécute à l'aide de la thread IsAlive. Cela signifie qu'il faut se connecter au serveur à l'aide d'une connexion approuvée. Vous devez donc vous assurer que le compte sous lequel les services de cluster doivent s'exécuter est un compte administrateur sur tous les nœuds du cluster et que le groupe BUILTIN\Administrators a l'autorisation de se connecter à SQL Server. Ces autorisations étant définies par défaut, cela ne s'applique que si vous modifiez les autorisations sur les nœuds du cluster.
Création d'un cluster avec basculement

Pour créer un cluster avec basculement, vous devez être un administrateur local avec des autorisations pour se connecter en tant que service et pour agir comme partie du système d'exploitation sur tous les ordinateurs du cluster avec basculement.

Voici les étapes de base de la création d'un cluster avec basculement à l'aide du programme d'installation :

  1. Identifiez les informations dont vous aurez besoin pour créer votre serveur virtuel (une ressource de disque de cluster, des adresses IP et un nom réseau, par exemple) et les nœuds disponibles pour le basculement.

    Cette configuration doit être effectuée avant l'exécution du programme d'installation. Pour cela, utilisez l'Administrateur de clusters dans les versions 64 bits de la famille Windows Server 2003. Vous avez besoin d'un groupe MSCS pour chaque serveur virtuel que vous voulez configurer.

  2. Démarrez le programme d'installation pour commencer l'installation. Lorsque vous avez entré toutes les informations nécessaires, le programme d'installation de SQL Server installe une nouvelle instance des binaires SQL Server sur le disque local de chaque ordinateur du serveur virtuel, puis installe les bases de données système sur le disque de cluster spécifié. Les binaires étant installés avec exactement le même chemin sur chaque nœud du cluster, vous devez vérifier que chaque nœud possède une lettre de lecteur local commune à tous les nœuds du cluster.

    Si, pour quelque raison, une ressource (SQL Server compris) venait à échouer, les ressources redémarreraient sur le même nœud ou le groupe serait déplacé sur un nœud disponible du cluster avec basculement, conformément à la configuration des seuils. Le nœud disponible du cluster avec basculement est l'un des nœuds définis en tant que nœuds disponibles pour le serveur virtuel pendant l'installation de SQL Server.

  3. Installez une instance de SQL Server 2000 (64 bits) en créant un serveur virtuel et toutes les ressources.

Procédure de création d'un cluster avec basculement

Installation de SQL

Programme d'installation de SQL Server (64 bits)

Procédure d'installation d'un cluster avec basculement à un nœud

Installation de SQL

Programme d'installation de SQL Server (64 bits)

Vous pouvez également créer un cluster avec basculement à l'aide du fichier .ini fourni avec le programme d'installation de SQL Server. Pour plus d'informations sur l'installation du fichier .ini, reportez-vous à la rubrique Commande d'installation de SQL Server 2000 (64 bits).


Exemple de gestion de clusters avec basculement (64 bits)

L'exemple suivant illustre la configuration de la gestion de clusters avec basculement de Microsoft® SQL Server™ 2000 (64 bits).

CLUSTERNODEA et CLUSTERNODEB représentent deux ordinateurs dans un cluster avec basculement. Exécutez le programme d'installation de SQL Server sur CLUSTERNODEA pour créer une instance par défaut de SQL Server nommée "SQLCLUSTA". Ce serveur virtuel peut s'exécuter sur CLUSTERNODEA ou sur CLUSTERNODEB. Dès lors, connectez-vous au serveur en spécifiant "SQLCLUSTA" comme nom de serveur dans la chaîne de connexion.

Exécutez à nouveau le programme d'installation sur CLUSTERNODEB. Créez une instance nommée "Inst1" sur un nouveau serveur virtuel nommé "SQLCLUSTB" (l'installation doit avoir lieu dans un autre groupe de clusters MSCS). Ce serveur virtuel peut s'exécuter sur CLUSTERNODEA ou sur CLUSTERNODEB. Dès lors, connectez-vous au serveur en spécifiant "SQLCLUSTB\Inst1" comme chaîne de connexion.

Les deux serveurs virtuels sont exécutés dans le cluster MSCS constitué de CLUSTERNODEA et de CLUSTERNODEB. Sinon, ils sont complètement séparés l'un de l'autre. Chaque serveur virtuel réside dans un groupe de clusters MSCS différent, et chacun possède un ensemble d'adresses IP et un nom de réseau différents. Leurs fichiers de données résident sur un ensemble de disques de clusters partagés séparés.

Lorsqu'un basculement se produit pour n'importe quelle ressource dans un groupe de clusters MSCS, toutes les ressources membres de ce groupe basculent également. Pour SQLCLUSTA, tout échec (des ressources de disque, de l'adresse IP, du nom du réseau ou des installations de SQL Server 2000 64 bits sur le serveur virtuel) entraîne le basculement de l'ensemble des membres du groupe de clusters, lorsque le seuil des clusters avec basculement a été atteint.

L'illustration suivante montre un cluster à deux nœuds avec des binaires et des données. Chaque serveur virtuel de l'illustration doit posséder la propriété exclusive du disque sur lequel se trouvent les fichiers de données et les fichiers journaux.


Dépendances de la gestion de clusters avec basculement (64 bits)

Il existe plusieurs produits qui entrent en interaction avec la gestion de clusters avec basculement Microsoft® SQL Server™ 2000 (64 bits). Pour être sûr que votre cluster avec basculement fonctionne correctement, vous devez comprendre la nature des dépendances sous-jacentes qui existent entre la gestion de clusters avec basculement et les autres produits.

Microsoft Distributed Transaction Coordinator (MS DTC)

SQL Server 2000 (64 bits) requiert MS DTC (Microsoft Distributed Transaction Coordinator) dans le cluster pour les requêtes distribuées et les transactions à deux temps, ainsi que pour certaines fonctionnalités de réplication. Dès lors que vous avez installé les versions 64 bits de la famille Windows ®Server 2003 et configuré votre cluster, vous devez configurer MS DTC pour travailler dans un cluster à l'aide de l'Administrateur de clusters. À l'aide de l'Administrateur de clusters, accédez à Nouvelle/Ressource, puis créez la ressource MS DTC. Il est préférable que la ressource MS DTC ne figure pas dans le groupe de clusters.

Exécution de MS DTC en mode cluster

Lorsque MS DTC est exécuté en mode cluster, vous ne pouvez créer qu'une seule ressource MS DTC sur l'ensemble du cluster.

Tout processus exécuté sur n'importe quel nœud dans le cluster peut utiliser MS DTC. Ces processus appellent simplement le proxy MS DTC et celui-ci transfère automatiquement les appels MS DTC vers le gestionnaire de transactions MS DTC qui contrôle l'intégralité du cluster.

En cas d'échec du gestionnaire de transactions MS DTC, le gestionnaire de transactions MS DTC est automatiquement redémarré sur un autre nœud du cluster. Le gestionnaire de transactions nouvellement redémarré MS DTC lit le fichier journal sur le disque de cluster partagé pour déterminer l'issue des transactions en cours et récemment terminées. Les gestionnaires de ressources se reconnectent au gestionnaire de transactions MS DTC et effectuent une récupération pour déterminer l'issue des transactions en attente. Les applications se reconnectent à MS DTC afin de pouvoir démarrer de nouvelles transactions.

Supposez, par exemple, que le gestionnaire de transactions est actif sur le système B. Le programme de l'application et le gestionnaire de ressources sur le système A appellent le proxy MS DTC. Le proxy MS DTC sur le système A transfère tous les appels MS DTC vers le gestionnaire de transactions MS DTC sur le système B.

Si le système B échoue, le gestionnaire de transactions MS DTC sur le système A assure l'opération. Il lit alors la totalité du fichier journal MS DTC sur le disque de cluster partagé, effectue la récupération et sert de gestionnaire de transactions pour la totalité du cluster.

Remarque Le gestionnaire de transactions MS DTC, le proxy MS DTC et les outils d'administration des services de composants sont installés sur chaque nœud des versions 64 bits du cluster de la famille Windows Server 2003. Le cluster utilise les services MSCS (Microsoft Cluster Services) en tant que partie intégrante des versions 64 bits de la famille Windows Server 2003.

Pour installer manuellement MS DTC sur les versions 64 bits de la famille Windows Server 2003 (exécutant MSCS)

  1. Installez les versions 64 bits de la famille Windows Server 2003 sur chaque nœud du cluster.

  2. Sélectionnez Démarrer, pointez sur Programmes et sur Outils administratifs, puis cliquez sur Administrateur de clusters.

  3. Dans le volet de gauche, sélectionnez le nom du cluster.

  4. Cliquez avec le bouton droit de la souris, puis cliquez sur l'élément de menu Créer un groupe. Un groupe est créé dans le cluster.

Pour plus d'informations sur l'utilisation de MS DTC dans une configuration en clusters, consultez la documentation Windows.


Maintenance d'un cluster avec basculement (64 bits)

Lorsque le cluster avec basculement de Microsoft® SQL Server™ 2000 (64 bits) est installé, vous pouvez modifier ou réparer votre installation. Par exemple, vous pouvez ajouter des nœuds supplémentaires à un serveur virtuel dans un cluster avec basculement, exécuter une instance organisée en clusters en tant qu'instance indépendante, supprimer un nœud d'une instance organisée en clusters ou effectuer une récupération à partir d'un échec de cluster avec basculement.

Ajout d'un nœud à un serveur virtuel existant

Au cours de l'installation de SQL Server, l'option de maintenir un serveur virtuel existant vous est proposée. Si vous choisissez cette option, vous pourrez ajouter ultérieurement d'autres nœuds à votre configuration de clusters avec basculement. Vous pourrez ajouter jusqu'à trois nœuds supplémentaires à un serveur virtuel existant configuré pour s'exécuter sur un seul nœud.

Pour ajouter un nœud à un serveur virtuel existant

Installation de SQL

Programme d'installation de SQL Server (64 bits)

Suppression d'un nœud à partir d'un cluster avec basculement existant

Vous pouvez supprimer un nœud à partir d'un serveur virtuel (si le nœud est endommagé, par exemple). Chaque nœud dans un serveur virtuel SQL Server est considéré comme équivalent, ce qui vous permet de supprimer n'importe quel nœud.

Un nœud supprimé peut être à nouveau ajouté à un cluster avec basculement à tout moment. Par exemple, un nœud supprimé peut être reconstruit après un échec grave, puis ajouté à nouveau au cluster avec basculement. Sinon, si un nœud temporairement indisponible revient ensuite en ligne et qu'une instance de SQL Server 2000 (64 bits) du serveur virtuel affecté est toujours en place, le programme d'installation supprime cette instance de l'ordinateur avant de réinstaller les binaires sur le nœud.

Remarque Un nœud endommagé n'a pas besoin d'être disponible pour être supprimé, mais le processus de suppression ne désinstallera aucun binaire du nœud indisponible.

Pour supprimer un nœud d'un cluster avec basculement existant

Installation de SQL

Programme d'installation de SQL Server (64 bits)

Exécution d'une instance organisée en clusters de SQL Server en tant qu'instance indépendante

En règle générale, vous exécutez une instance organisée en clusters de SQL Server sous le contrôle de MSCS (Microsoft Cluster Service). Cependant, il est parfois nécessaire d'exécuter une instance organisée en clusters de SQL Server en tant qu'instance indépendante (par exemple, lorsque vous souhaitez effectuer des tâches d'administration telles que l'exécution d'une instance de SQL Server en mode mono-utilisateur). Pour se connecter à une instance organisée en clusters de SQL Server 2000 en mode indépendant à l'aide de sockets, les ressources d'adresse IP et de nom réseau doivent être en ligne pour le serveur virtuel sur lequel l'instance a été installée.

Si ces ressources ne peuvent pas être en ligne, connectez-vous à l'aide des canaux nommés. Néanmoins, vous devez créer un alias côté client pour communiquer avec le nom du canal sur lequel SQL Server est à l'écoute. Utilisez l'utilitaire réseau SQL Server pour connaître le nom du canal. Pour plus d'informations, reportez-vous à la rubrique " Utilitaire réseau SQL Server" dans la documentation en ligne de SQL Server 2000 32 bits. Pour plus d'informations, reportez-vous à la rubrique Dépannage de clusters avec basculement (64 bits).

Récupération à partir d'un échec de cluster avec basculement

En règle générale, les causes de l'échec d'un cluster avec basculement sont les suivantes :

  • L'erreur matérielle du Nœud 1 dans un cluster à deux nœuds. Cette erreur peut être due à une défaillance de la carte SCSI ou du système d'exploitation.

    Pour effectuer une procédure de récupération, supprimez tout d'abord le cluster avec basculement à l'aide du programme d'installation.

Pour supprimer une instance organisée en clusters avec basculement

Installation de SQL

Programme d'installation de SQL Server (64 bits)

Pour effectuer une récupération à partir d'un échec de cluster avec basculement dans le scénario 1

Installation de SQL

Programme d'installation de SQL Server (64 bits)
  • Le Nœud 1 est arrêté ou hors ligne, mais il n'est pas endommagé de façon irrémédiable. Cela peut être dû à une défaillance du système d'exploitation. Cependant, la récupération à partir des étapes ci-dessous peut prendre du temps. Si l'échec du système d'exploitation peut être facilement récupéré, évitez toutefois d'utiliser cette technique.

    Pour effectuer une procédure de récupération, supprimez tout d'abord le cluster avec basculement à l'aide du programme d'installation.

Pour supprimer une instance organisée en clusters avec basculement

Installation de SQL

Programme d'installation de SQL Server (64 bits)

Pour effectuer une récupération à partir d'un échec de cluster avec basculement dans le scénario 2

Installation de SQL

Programme d'installation de SQL Server (64 bits)

Modification des comptes de service

Vous ne devez pas modifier les mots de passe des comptes de service SQL Server lorsqu'un nœud en cluster avec basculement est arrêté ou hors ligne. Si vous êtes amené à le faire, il vous faudra redéfinir le mot de passe à l'aide de SQL Server Enterprise Manager lorsque tous les nœuds seront de nouveau en ligne. Vous devez administrer l'outil à distance à partir d'un ordinateur 32 bits pour pouvoir utiliser SQL Server Enterprise Manager sur vos installations SQL Server 2000 (64 bits).

Si le compte de service de SQL Server n'est pas l'administrateur d'un cluster, les partages administratifs ne peuvent pas être supprimés sur les nœuds du cluster. Les droits administratifs doivent être disponibles dans un cluster pour que SQL Server puisse fonctionner.

N'utilisez pas le même compte pour le compte de service SQL Server ou le compte de service du cluster. Si le mot de passe est amené à changer pour le compte de service du cluster, votre installation SQL Server échouera.

Related Topics

Gestion d'une installation de clusters avec basculement (64 bits)


Utilisation des outils SQL Server dans la gestion de clusters avec basculement (64 bits)

Vous pouvez utiliser la gestion de clusters avec basculement Microsoft® SQL Server™ 2000 avec une grande variété d'outils et de services SQL Server. Toutefois, pour bénéficier de certains des outils et services de SQL Server 2000, vous devez installer ces derniers sur un ordinateur 32 bits et les administrer à distance. Vérifiez au préalable les points d'utilisation ci-dessous.

Requêtes de texte intégral : disponibles sur SQL Server 2000 (64 bits)

Pour utiliser le service Microsoft Search et effectuer des requêtes de texte intégral lors de la gestion de clusters avec basculement, tenez compte des éléments suivants :

  • Une instance de SQL Server 2000 (64 bits) doit être exécutée sur le même compte système sur tous les nœuds du cluster avec basculement, afin que les requêtes de texte intégral fonctionnent sur les clusters avec basculement. Notez que cette condition n'est pas propre au service Microsoft Search mais qu'elle est générale à la gestion des clusters avec basculement.

  • Vous devez modifier le compte de démarrage de SQL Server 2000 (64 bits) dans le cluster avec basculement à l'aide de SQL Server Enterprise Manager. Si vous utilisez le Panneau de configuration ou l'application Services dans les versions 64 bits de la famille Microsoft Windows ®Server 2003, vous altérerez la configuration de texte intégral de SQL Server.
SQL Server Enterprise Manager : disponible uniquement sur SQL Server 2000 (32 bits)

Pour utiliser SQL Server Enterprise Manager avec la gestion de clusters avec basculement, tenez compte des éléments suivants :

  • Vous devez modifier le compte de démarrage de SQL Server 2000 (64 bits) dans le cluster avec basculement à l'aide de SQL Server Enterprise Manager. Si vous utilisez le Panneau de configuration ou l'application Services dans les versions 64 bits de la famille Windows Server 2003, vous pouvez altérer la configuration du serveur.

  • Lors de la création ou de la modification de bases de données, vous ne pourrez voir que les disques organisés en clusters sur le serveur virtuel local.

  • Si vous explorez une table à l'aide de SQL Server Enterprise Manager et que vous perdez la connexion à SQL Server durant un basculement, vous verrez s'afficher le message d'erreur : "Échec de la liaison de communication". Vous devez alors appuyer sur la touche ÉCHAP et annuler les modifications avant de quitter la fenêtre de l'application SQL Server Enterprise Manager. Vous ne pouvez pas cliquer sur Exécuter la requête, ni enregistrer les modifications ou modifier la grille.

  • Si vous utilisez SQL Server Enterprise Manager pour redéfinir les propriétés du compte de service de SQL Server, vous serez invité à redémarrer SQL Server. Lorsque SQL Server s'exécute dans une configuration de clusters avec basculement, les ressources de l'Agent SQL Server, le texte intégral et SQL Server sont hors ligne. Néanmoins, lors du redémarrage de SQL Server, les ressources de l'Agent SQL ou le texte intégral ne reviennent pas en ligne. Vous devez démarrer ces ressources manuellement à l'aide de l'utilitaire Administrateur de clusters Windows.
Gestionnaire de contrôle de service : disponible sur SQL Server 2000 (64 bits)

Utilisez le gestionnaire de contrôle de service pour démarrer ou arrêter une instance organisée en clusters de SQL Server. Vous ne pouvez pas suspendre une instance organisée en clusters de SQL Server.

Générateur de profils SQL : disponible uniquement sur SQL Server 2000 (32 bits)

Vous pouvez utiliser le Générateur de profils SQL Server avec la gestion de clusters avec basculement. Cependant, si un basculement a lieu sur un serveur où vous exécutez une trace du Générateur de profils SQL Server, vous devez redémarrer la trace lors du retour en ligne du serveur pour pouvoir poursuivre son exécution.

Analyseur de requêtes SQL : disponible uniquement sur SQL Server 2000 (32 bits)

Vous pouvez utiliser l'Analyseur de requêtes SQL Server avec la gestion de clusters avec basculement. Cependant, si un basculement a lieu sur un serveur où vous exécutez une requête, vous devez redémarrer la requête lors du retour en ligne du serveur pour pouvoir poursuivre son exécution.

SQL Mail : non disponible sur SQL Server 2000 (64 bits)

Cette version de SQL Server 2000 (64 bits) ne prend pas en charge SQL Mail. SQL Agent Mail dans SQL Server 2000 (64 bits) peut toutefois être configuré à distance par le biais d'Enterprise Manager, si votre client se connecte à distance à l'aide de SQL Server 2000 Service Pack 3.0 ou ultérieur. Pour plus d'informations, reportez-vous à la rubrique Différences entre les versions 64 bits et 32 bits (64 bits).


Dépannage de clusters avec basculement (64 bits)

Cette rubrique donne des informations sur les éléments suivants :

  • résolution des problèmes les plus courants liés à l'utilisation de la gestion de clusters avec basculement de Microsoft® SQL Server™ 2000 (64 bits) ;

  • optimisation des performances des clusters avec basculement ;

  • utilisation de la gestion de clusters avec basculement en association avec les procédures stockées étendues utilisant des objets COM.
Résolution des problèmes d'utilisation courants

La liste suivante décrit les problèmes d'utilisation les plus courants et explique comment les résoudre :

  • SQL Server 2000 (64 bits) ne peut pas se connecter au réseau après avoir fait l'objet d'une migration vers un autre nœud.

    Si les mots de passe du compte de service SQL Server ne sont pas identiques sur tous les nœuds, le nœud ne pourra pas redémarrer un service SQL Server qui a fait l'objet d'une migration à partir d'un nœud ayant échoué.

    Il est recommandé de modifier les mots de passe du compte de service SQL Server à l'aide de SQL Server Enterprise Manager (administré à distance à partir d'un ordinateur 32 bits). Si vous n'effectuez pas cette opération et que vous modifiez les mots de passe du compte de service SQL Server sur un nœud, vous devez également modifier les mots de passe sur tous les autres nœuds. SQL Server Enterprise Manager réalise cette opération automatiquement.

  • SQL Server ne peut pas accéder aux disques organisés en clusters.

    Un nœud ne peut pas récupérer des disques de clusters qui ont fait l'objet d'une migration depuis un nœud ayant échoué, si les disques de clusters partagés utilisent une lettre de lecteur différente. Les lettres de lecteur de disque pour les disques de clusters doivent être identiques sur les deux serveurs. Si ce n'est pas le cas, examinez l'installation d'origine du système d'exploitation et MSCS (Microsoft Cluster Service). Pour plus d'informations, reportez-vous aux versions 64 bits de la famille Windows ®Server 2003.

  • Le basculement est provoqué par la défaillance d'un service particulier, tel que la recherche de texte intégral ou l'Agent SQL Server.

    Pour éviter que la défaillance de services spécifiques ne provoque le basculement du groupe SQL Server, configurez ces services à l'aide de l'Administrateur de clusters dans les versions 64 bits de la famille Windows Server 2003. Par exemple, pour éviter que la défaillance du service de recherche de texte intégral n'entraîne un basculement de SQL Server, désactivez la case à cocher Affecter le groupe dans l'onglet Avancé de la boîte de dialogue Propriétés de texte intégral. Si toutefois SQL Server provoque un basculement, le service de recherche de texte intégral redémarre.

  • SQL Server ne démarre pas automatiquement.

    Vous ne pouvez pas démarrer automatiquement un cluster avec basculement avec SQL Server. Pour cela, vous devez utiliser l'Administrateur de clusters dans MSCS.

  • Si le nom de réseau est hors connexion et que vous ne pouvez pas vous connecter avec TCP/IP, vous devez utiliser les canaux nommés.

    Pour vous connecter à l'aide de canaux nommés, créez un alias avec l'utilitaire réseau SQL Server pour vous connecter à l'ordinateur approprié. Par exemple, si vous disposez d'un cluster à deux nœuds (Node A et Node B) et d'un serveur virtuel (Virtsql) avec une instance par défaut, vous pouvez vous connecter au serveur dont la ressource de nom réseau est hors connexion, de la manière suivante :

    1. Déterminez le nœud sur lequel s'exécute le groupe contenant l'instance de SQL Server, à l'aide de l'Administrateur de cluster. Dans cet exemple, il s'agit de Node A.

    2. Démarrez le service SQL Server sur cet ordinateur à l'aide de net start. Pour plus d'informations sur l'utilisation de net start, reportez-vous à la rubrique Démarrage manuel de SQL Server.

    3. Démarrez l'utilitaire réseau SQL Server sur Node A. Examinez le nom du canal sur lequel le serveur est à l'écoute. Il doit être similaire à \\.\$$\VIRTSQL\canal\sql\query.

    4. Sur l'ordinateur client, démarrez l'utilitaire réseau SQL Server.

    5. Créez un alias SQLTEST1 pour vous connecter à ce nom de canal via les canaux nommés. Pour cela, entrez Node A en tant que nom de serveur et modifiez le nom du canal de la manière suivante : \\.\pipe\$$\VIRTSQL\sql\query. Connectez-vous à cette instance à l'aide de l'alias SQLTEST1 comme nom de serveur.

      Pour plus d'informations, reportez-vous à la rubrique Client Net-Libraries and Network Protocols.

Optimisation des performances de la gestion de clusters avec basculement

Pour optimiser les performances lors de l'utilisation de la gestion de clusters avec basculement, respectez les points suivants :

  • Si votre contrôleur de disque n'est pas externe à votre ordinateur organisé en clusters, vous devez désactiver l'écriture en cache au sein du contrôleur pour éviter toute perte de données lors d'un basculement.

  • La mise en cache de l'écriture différée ne peut être utilisée sur des contrôleurs hôtes dans un cluster sans amoindrir les performances. Néanmoins, si vous utilisez des contrôleurs externes, vous continuez à améliorer les performances. Les ensembles de disques externes ne sont pas affectés par le basculement et peuvent synchroniser correctement le cache, même à travers un bus SCSI.

  • Il est recommandé de ne pas utiliser le lecteur en cluster pour les partages de fichiers. L'utilisation de ce type de lecteur peut affecter les temps de récupération et provoquer un basculement du groupe de clusters en raison des échecs des ressources.

  • Déterminez la taille mémoire maximale (mémoire MAX) et définissez-la. La mémoire MAX est égale à la mémoire totale disponible, moins la mémoire pour le système d'exploitation et les autres ressources de clusters. Pour trouver la mémoire MAX de SQL Server, divisez la mémoire restante entre les serveurs SQL Server installés.
Utilisation de procédures stockées étendues et d'objets COM

Lorsque vous utilisez des procédures stockées étendues avec une configuration de gestion de clusters avec basculement, toutes les procédures stockées étendues doivent être installées sur le disque de cluster partagé. Ceci afin d'assurer que lors du basculement d'un nœud, les procédures stockées étendues peuvent toujours être utilisées.

Si les procédures stockées étendues utilisent des composants COM, l'administrateur doit enregistrer les composants COM sur chaque nœud du cluster. Les informations pour le chargement et l'exécution des composants COM doivent figurer dans le registre du nœud actif, afin de créer les composants. Sinon, les informations seront conservées dans le registre de l'ordinateur sur lequel les composants COM ont été enregistrés en premier lieu. Pour plus d'informations, reportez-vous à la rubrique " Architecture de procédure stockée étendue" dans la documentation en ligne de SQL Server 2000 32 bits.


Mise à niveau vers un cluster avec basculement SQL Server 2000 (64 bits)

Comme il n'existe pas de versions 64 bits de SQL Server, vous ne pouvez pas mettre à niveau un cluster avec basculement existant vers un cluster avec basculement SQL Server 2000 (64 bits).


Installation de SQL Server à partir de la ligne de commande (64 bits)

Le programme Setup.exe de Microsoft® SQL Server™ 2000 (64 bits) peut s'exécuter à partir de la ligne de commande.

S'il choisit d'exécuter Setup.exe à partir de la ligne de commande plutôt qu'en double-cliquant sur Setup.exe, l'utilisateur peut spécifier plusieurs commutateurs de ligne de commande. Afin d'exécuter une installation sans surveillance, notez que vous devez spécifier soit /qn, soit /qb, sous peine de voir s'afficher l'interface utilisateur graphique complète. Pour une installation sans surveillance du serveur virtuel, vous devez spécifier /qn.

  • Commande Setup de SQL Server 2000 (64 bits)

  • Exécution du programme d'installation de SQL Server 2000 (64 bits)

  • Réinstallation de SQL Server 2000 (64 bits)

  • Prise en charge de la ligne de commande de cluster (64 bits)


Commande Setup de SQL Server 2000 (64 bits)

Le programme Setup.exe de Microsoft® SQL Server™ 2000 (64 bits) fournit une interface de ligne de commande qui vient s'ajouter à l'interface utilisateur graphique fournie lorsque le programme d'installation est exécuté à partir de My Computer ou de l'Explorateur Windows. Utilisez les propriétés décrites dans cette rubrique pour définir les paramètres de personnalisation de l'installation de SQL Server 2000. Vous pouvez définir ces paramètres de propriété sur la ligne de commande ou dans un fichier .ini spécifié par l'argument /settings.

Important Pour tous les paramètres associés au chemin d'accès du programme d'installation, utilisez une barre oblique inversée (\).

La syntaxe suivante illustre les trois différentes lignes de commande permettant d'afficher l'aide, d'installer une instance ou de la supprimer.

Syntaxe

setup /?

setup

[/i fichier_lot]
{/settings fichier_ini | property1=paramètre1 property2=paramètre2 ...}
[{/qn|/qb}]

[/l*v fichier_journal]

setup /x fichier_définition_lots
[/qn

[/l*v fichier_journal]

Arguments

/?

Affiche un résumé de la syntaxe des commutateurs de setup.

/i fichier_définition_lots

Cet argument n'est pas requis pour l'installation d'une nouvelle instance. Il spécifie le nom du fichier de définition de lot d'installation de Microsoft Windows® (fichier .msi) qui servira à installer une instance de SQL Server 2000 ou n'importe laquelle de ses fonctionnalités. Vous devez spécifier le chemin d'accès complet du fichier après le commutateur /i ou /x. Mettez le fichier .msi dans le même dossier que Setup.exe. Les fichiers msi se trouvent dans le sous-répertoire d'installation situé dans le répertoire racine sur le CD-ROM. Si ce paramètre est omis, le programme d'installation choisit automatiquement le fichier .msi inutilisé suivant pour l'installation. Pour conserver une installation existante, vous pouvez à la place spécifier le code produit indiqué dans la clé du registre ProductCode. Pour l'instance par défaut, utilisez HKEY_Local_Machine\Software\Microsoft\MSSQLServer\Setup:ProductCode. Pour une instance nommée, utilisez HKEY_Local_Machine\Software\Microsoft SQL Server\nom_instance\Setup:ProductCode.

Pour désinstaller un cluster avec basculement, n'utilisez pas cet argument. Utilisez la propriété NODELIST avec une liste vide.

/settings fichier_ini

Définit le nom d'un fichier .ini contenant les paramètres des propriétés d'installation (énumérés plus loin dans cette rubrique). Mettez le fichier .ini dans le même dossier que Setup.exe. Si vous utilisez cet argument, les propriétés doivent être définies dans le fichier .ini et non sur la ligne de commande setup. Pour plus d'informations, reportez-vous à la rubrique Spécification des propriétés d'installation à l'aide d'un fichier .ini (64 bits).

property1=paramètre1 property2=paramètre2 ...

Définit une valeur d'une propriété setup, qui peut avoir un paramètre chaîne ou valeur. N'insérez que les paramètres de propriété requis pour une installation. Les propriétés et leurs paramètres sont abordés plus loin dans cette rubrique. Les espaces sont autorisés dans un paramètre de chaîne de caractère, à condition que la chaîne soit mise entre guillemets : "chaîne". Tout guillemet inclus avec le paramètre de chaîne doit être doublé ("") en tant que code d'échappement. Terminez les emplacements de dossier par une barre oblique inversée :

INSTALLSQLDIR="C:\Program Files\Microsoft SQL Server\"

Si l'argument /settings est utilisé pour spécifier un fichier .ini, vous devez définir les propriétés dans le fichier .ini et non sur la ligne de commande setup.

/x fichier_définition_lots

Définit le fichier .msi d'installation de Windows Installer qui sera utilisé lors de la désinstallation d'une instance de SQL Server 2000. Vous devez spécifier le nom du fichier msi qui a servi à installer l'instance de SQL Server. Spécifiez le chemin d'accès complet du fichier après le commutateur /x.

/qn

Pour effectuer une installation sans surveillance, vous devez spécifier soit /qn, soit /qb. Le commutateur /qn spécifie que le programme d'installation s'exécute sans interface utilisateur. Cet argument est requis pour les installations sans surveillance de cluster avec basculement.

/qb

Pour effectuer une installation sans surveillance, vous devez spécifier soit /qn, soit /qb. Cet argument spécifie que le programme d'installation montre uniquement l'interface utilisateur de base. Seules les boîtes de dialogue présentant des informations de progression s'affichent.

Cet argument ne convient pas aux installations de cluster avec basculement.

/l*v fichier_journal

Définit que le journal détaillé doit être créé. Si cet argument est omis, un journal non détaillé est créé et enregistré à l'emplacement %TEMP%, tout comme Sqlrunn.log (n désignant une énumération pour l'installation). Un autre journal, Sqlstpn.log, est toujours créé pour chaque installation à l'emplacement %TEMP%.

Propriétés

ADDLOCAL="sélection_fonctionnalités"

Définit les fonctionnalités qui doivent être installées avec l'instance en cours soit pour une nouvelle instance, soit pour conserver une instance existante. La liste sélection_fonctionnalités est une liste séparée par des virgules qui comprend les fonctionnalités ci-après :

Caractéristique | Description
SQL_Server, SQL_Tools, SQL_Headers_Libs, SQL_Engine, SQL_Replication, SQL_Data_Files, SQL_DevTools | Fonctionnalités requises lors de l'installation de SQL Server.
SQL_FullText | Moteur de recherche de texte intégral.
AnalysisServices, Analysis_Server, AnalysisDataFiles, AnalysisSQL, AnalysisSQLData, AnalysisClient | Fonctionnalités requises lors de l'installation d'Analysis Services.
Books_Online | Documentation en ligne.

Si ADDLOCAL est omis, le programme d'installation effectue une installation complète de toutes les fonctionnalités. Si vous ajoutez des fonctionnalités à une installation existante, il suffit de les indiquer. Par exemple, pour ajouter Analysis Services à une installation existante, spécifiez le paramètre de propriété suivant :

ADDLOCAL=SqlRun,AnalysisServices,Analysis_Server,AnalysisDataFiles,AnalysisSQL,AnalysisSQLData,AnalysisClient

Cette propriété ne permet pas d'installer SQL Server 2000 Desktop Engine

et ne convient pas aux installations de cluster avec basculement.

AGTACCOUNT="nom_connexion\domaine"

Définit le domaine de compte et le nom de connexion du service de l'Agent SQL Server. Utilisez AGTPASSWORD pour spécifier le mot de passe correspondant au nom de connexion. Si cette propriété est omise, le compte système local est pris par défaut.

Cette propriété est requise pour les installations de cluster avec basculement.

AGTPASSWORD="mot_de_passe"

Définit le mot de mot de passe du compte du service de l'Agent SQL Server correspondant au nom de connexion spécifié par AGTACCOUNT.

Cette propriété est requise pour les installations de cluster avec basculement.

Attention Si cette propriété est omise, le mot de passe sa prendra la valeur NULL. Microsoft recommande l'utilisation du mode de sécurité d'authentification Windows (sécurité intégrée). Si vous utilisez l'authentification SQL Server, vous devez immédiatement changer le mot de passe.

AGTAUTOSTART={1|0}

Définit si le service de l'Agent SQL Server doit démarrer automatiquement au redémarrage du système d'exploitation de Microsoft Windows®. Indiquez 1 pour activer ou 0 pour désactiver le redémarrage automatique. Si cette propriété est omise, la valeur par défaut est 1. Le service de l'Agent SQL Server nécessitant le démarrage du service SQL Server, si vous indiquez 1 pour cette propriété, vous devez également affecter la valeur 1 à la propriété SQLAUTOSTART (même si SQLAUTOSTART=0).

BLANKSAPWD=1

Définit que le mot de passe sa doit prendre la valeur NULL. La chaîne du mot de passe spécifiée par cette propriété est masquée et n'est pas écrite dans le fichier journal.

CALLBACK=nomDll!NomFonctionRappel

Définit le nom de la DLL contenant la fonction de rappel de Windows Installer, ainsi que le nom de la fonction de rappel.

COLLATION="indicateur_classement"

Définit le classement SQL Server qui sera utilisé comme classement par défaut de cette instance de SQL Server. Le classement par défaut est fonction du paramètre régional Windows. Pour obtenir la liste des paramètres régionaux Windows et leurs indicateurs de classement correspondants, reportez-vous à la rubrique "Indicateurs de classement Windows" dans la documentation en ligne de SQL Server 2000 32 bits.

COMPANYNAME="nom_société"

Définit le nom de la société qui enregistre ce produit. Si cette propriété est omise, le nom du système d'exploitation de l'entreprise est utilisé. Si le nom contient des espaces, il doit être écrit entre guillemets.

INSTALLOLAPDIR="chemin_dossier_exécutable_OLAP"

Définit le dossier d'installation des fichiers exécutables d'Analysis Services. Le chemin d'accès par défaut est lecteur_système\Program Files\Microsoft Analysis Services\. Pour tous les paramètres associés au chemin d'accès, l'utilisation d'une barre oblique inversée (\) est obligatoire. Installez Analysis Services dans un dossier utilisant uniquement des caractères sur un octet.

Cette propriété ne convient pas aux installations MSDE ou aux installations de cluster avec basculement.

INSTALLOLAPDATADIR="chemin_dossier_données_OLAP"

Définit le dossier de génération des cubes d'Analysis Services. Le chemin d'accès par défaut est lecteur_système\Program Files\Microsoft Analysis Services\Data\.

Cette propriété ne convient pas aux installations MSDE ou aux installations de clusters avec basculement.

INSTALLSQLDIR="chemin_dossier_exécutable_SQL"

Définit le dossier d'installation des fichiers exécutables de SQL Server. Le chemin d'accès par défaut est lecteur_système\Program Files\Microsoft SQL Server\. SQL Server recherche alors les fichiers programme de l'instance par défaut dans lecteur_système\Program Files\Microsoft SQL Server\MSSQL. Pour une instance nommée, il recherche les fichiers programme dans lecteur_système\Program Files\Microsoft SQL Server\MSSQL$nom_instance.

Cette propriété est requise pour l'installation d'un cluster avec basculement. De plus, chemin_dossier_exécutable_SQL doit se trouver sur un disque local portant une lettre de lecteur qui existe sur tous les nœuds de la définition du cluster.

INSTALLSQLDATADIR="chemin_dossier_données"

Définit le dossier de génération des bases de données système de SQL Server. Le chemin d'accès par défaut est lecteur_système\Program Files\Microsoft SQL Server\. SQL Server recherche alors les fichiers base de données de l'instance par défaut dans lecteur_système\Program Files\Microsoft SQL Server\MSSQL. Pour une instance nommée, il recherche les fichiers programme dans lecteur_système\Program Files\Microsoft SQL Server\MSSQL$nom_instance\Data.

Cette propriété est requise pour l'installation d'un cluster avec basculement. De plus, chemin_dossier_données doit se trouver sur un disque partagé appartenant au groupe de cluster spécifié pour l'installation (reportez-vous à la propriété GROUP).

INSTANCENAME="nom_instance"

Définit le nom de l'instance. Si cette propriété est omise, l'instance est installée en tant qu'instance par défaut. Pour connaître l'ensemble des règles d'affectation d'un nom à une instance, reportez-vous à la rubrique Attribution d'un nom aux instances (64 bits).

Cette propriété est facultative pour les installations de cluster avec basculement. Si vous souhaitez affecter un nom d'instance à votre installation avec cluster, insérez ce paramètre de propriété.

PIDKEY=clé_cdrom

Définit la clé d'identification du produit, composée de 25 caractères, requise pour l'installation de SQL Server 2000. Ce numéro est inscrit sur l'étiquette jaune collée sur la notice ou sur le boîtier du CD-ROM. Cette propriété est obligatoire.

Elle ne permet pas d'installer SQL Server 2000 Desktop Engine.

OLAPACCOUNT="nom_connexion\domaine"

Définit le domaine de compte et le nom de connexion du service MSSQLServerOLAPService. Utilisez OLAPPASSWORD pour définir le mot de passe correspondant au nom de connexion. Si cette propriété est omise, le compte système local est pris par défaut.

Cette propriété ne permet pas d'installer SQL Server 2000 Desktop Engine

et ne convient pas aux installations de cluster avec basculement.

OLAPAUTOSTART={1|0}

Définit si le service MSSQLServerOLAPService démarre automatiquement lors du redémarrage du système d'exploitation Microsoft Windows. Indiquez 1 pour activer le redémarrage automatique ou 0 pour le désactiver. Si cette propriété est omise, la valeur par défaut est 1.

Cette propriété ne permet pas d'installer SQL Server 2000 Desktop Engine

et ne convient pas aux installations de cluster avec basculement.

OLAPPASSWORD="mot_de_passe"

Définit le mot de mot de passe du compte de service MSSQLServerOLAPService qui correspond au nom de connexion spécifié par OLAPACCOUNT.

Cette propriété ne permet pas d'installer SQL Server 2000 Desktop Engine

et ne convient pas aux installations de cluster avec basculement.

Attention Si cette propriété est omise, le mot de passe sa prendra la valeur NULL. Microsoft recommande l'utilisation du mode de sécurité d'authentification Windows (sécurité intégrée). Si vous utilisez l'authentification SQL Server, vous devez immédiatement changer le mot de passe.

PERPROCESSOR="licence_par_ordinateur"

Définit le nombre de licences par ordinateur achetées. N'utilisez pas la propriété PERSEAT avec la propriété PERPROCESSOR.

Cette propriété ne permet pas d'installer SQL Server 2000 Desktop Engine.

PERSEAT="licence_par_siège"

Définit le nombre de licences par siège achetées. N'utilisez pas la propriété PERPROCESSOR avec la propriété PERSEAT.

Cette propriété ne permet pas d'installer SQL Server 2000 Desktop Engine.

REINSTALL=All

Définit que le programme Setup installe toutes les fonctionnalités de SQL Server 2000 (64 bits) précédemment installées. La seule valeur prise en charge est All. Cette propriété doit toujours être utilisée avec REINSTALLMODE.

REINSTALLMODE={omus|amus}

Définit le niveau de traitement effectué par le programme d'installation. Utilisez REINSTALLMODE=omus lors de la reprise d'une installation défaillante. Avec cette option, l'installation complète est vérifiée et terminée. REINSTALLMODE=omus reconstruit également le registre d'une installation Microsoft SQL Server endommagée. Utilisez REINSTALLMODE=amus pour reconstruire les bases de données système (par exemple, pour modifier le classement du serveur ou pour reconstruire la base de données master à la suite d'une défaillance d'un disque dur). Lorsque vous utilisez REINSTALLMODE=amus, vous pouvez modifier les paramètres de sécurité (SECURITY et SAPWD) et le classement (COLLATION).

REMOVE="sélection_fonctionnalités"

Définit les fonctionnalités qui seront supprimées d'une installation existante. La liste sélection_fonctionnalités est une liste séparée par des virgules qui contient les fonctionnalités citées sous ADDLOCAL : Pour supprimer entièrement une instance, utilisez l'argument /x sur la ligne de commande setup.

Cette propriété ne convient pas aux installations de cluster avec basculement.

SAPWD="mot_de_passe_sa"

Définit le mot de passe sa lors de l'utilisation de la propriété SECURITYMODE=SQL. La chaîne du mot de passe spécifiée par cette propriété est masquée et n'est pas écrite dans le fichier journal.

Attention Si cette propriété est omise, le mot de passe sa prendra la valeur NULL. Microsoft recommande l'utilisation du mode de sécurité d'authentification Windows (sécurité intégrée). Si vous utilisez l'authentification SQL Server, vous devez immédiatement changer le mot de passe.

SECURITYMODE=SQL

Configure l'instance installée pour utiliser l'authentification SQL Server (mode mixte). Si vous omettez cette propriété, la valeur par défaut consiste à utiliser l'authentification Windows et à placer le groupe local Administrateurs Windows dans le rôle de serveur fixe sysadmin. Avec cette propriété, vous pouvez utiliser SAPWD afin de spécifier le mot de passe sa pour l'authentification SQL Server.

Remarque Microsoft recommande l'utilisation du mode de sécurité d'authentification Windows (sécurité intégrée). Si vous utilisez l'authentification SQL Server, vous devez immédiatement changer le mot de passe.

SQLACCOUNT="nom_connexion_domaine"

Définit le nom de connexion et le domaine du compte de service SQL Server. Utilisez SQLPASSWORD pour spécifier le mot de passe qui correspond au nom de connexion. Si cette propriété est omise, le compte système local est pris par défaut.

Cette propriété est obligatoire pour les installations de cluster avec basculement.

SQLAUTOSTART={0|1}

Définit si le service SQL Server démarre automatiquement au redémarrage du système d'exploitation Microsoft Windows. Indiquez 1 pour activer le redémarrage automatique ou 0 pour le désactiver. Si cette propriété est omise, la valeur par défaut est 1.

SQLPASSWORD="mot_de_passe"

Définit le mot de mot du compte du service SQL Server qui correspond au nom de connexion spécifié par SQLACCOUNT.

Cette propriété est obligatoire pour les installations en cluster avec basculement.

Attention Si cette propriété est omise, le mot de passe sa prendra la valeur NULL. Microsoft recommande l'utilisation du mode de sécurité d'authentification Windows (sécurité intégrée). Si vous utilisez l'authentification SQL Server, vous devez changer immédiatement le mot de passe.

UPGRADE=1

Définit que Windows Installer met à niveau l'instance spécifiée par INSTANCENAME. Si INSTANCENAME n'est pas spécifié, l'instance par défaut est mise à niveau. La seule valeur prise en charge est 1.

Remarque Les mises à niveau ne sont pas prises en charge pour cette version de SQL Server 2000 (64 bits).

UPGRADEPWD="mot_de_passe"

Définit le mot de passe du compte de connexion spécifié par le paramètre de la propriété UPGRADEUSER. Cette opération peut être omise si le compte de connexion contient un mot de passe vide.

Remarque importante Il est recommandé de ne pas utiliser de mot de passe vide ; préférez plutôt les mots de passe forts.

Cette propriété ne permet pas d'installer SQL Server 2000 Desktop Engine.

UPGRADEUSER="compte_connexion"

Définit que le programme d'installation se connecte à l'instance par le biais de l'authentification SQL Server à l'aide du compte de connexion spécifié. Le compte de connexion doit être un membre du rôle de serveur fixe sysadmin.

Il est recommandé de ne pas utiliser cette propriété pour que le programme d'installation se connecte à l'instance à l'aide de l'authentification Windows. Si vous omettez cette propriété, cela suppose que le programme d'installation s'exécute sous un domaine ou un compte d'ordinateur Windows qui a été inclus dans le rôle de serveur fixe sysadmin de SQL Server.

Cette propriété ne permet pas d'installer SQL Server 2000 Desktop Engine.

USERNAME="nom_utilisateur"

Définit le nom de l'utilisateur qui enregistre ce produit. Si cette propriété est omise, le nom d'utilisateur du système d'exploitation est utilisé. Si le nom contient des espaces, il doit être écrit entre guillemets.

Propriétés spécifiques au cluster

ADMINACCOUNT="nom_connexion/domaine"

Définit le nom du domaine et du compte administrateur utilisé pour lancer les processus vers les nœuds distants pendant l'installation uniquement. Ce compte doit être celui d'un administrateur reconnu sur tous les nœuds du cluster. Cette propriété est facultative uniquement si le seul nœud affecté est le nœud sur lequel le programme d'installation s'exécute.

ADMINPASSWORD="mot_de_passe_admin"

Définit le mot de mot de passe de l'administrateur du cluster qui correspond au nom de connexion spécifié par ADMINACCOUNT.

GROUP="nom_groupe_clusters"

Définit le nom du groupe de clusters. Il s'agit du groupe qui contient le disque sur lequel les fichiers de données partagées sont écrites et qui contient les ressources SQL Server. Le nœud qui possède le groupe de clusters doit être spécifié par la propriété NODELIST.

IP="adresse1_ip,nom1_réseau"

IP="adresse2_ip,nom2_réseau"

Définissez une ou plusieurs adresses IP qui permettent de se connecter à chaque serveur virtuel. Seule une adresse par carte réseau est autorisée, bien que cette propriété puisse être utilisée de nombreuses fois, une fois sur chaque carte réseau.

NODELIST="nom_nœud1,nom_nœud2"

Définit les nœuds de cluster qui font partie de la définition du serveur virtuel. Cette liste est séparée par des virgules. Pour ajouter un nœud à une définition de serveur virtuel existante, exécutez la ligne de commande ou le fichier .ini d'origine avec le nouveau nœud ajouté au paramètre de la propriété NODELIST. Pour supprimer un nœud d'une définition de serveur virtuel existante, exécutez la ligne de commande ou le fichier .ini d'origine avec le nœud supprimé du paramètre de la propriété NODELIST. Pour désinstaller un cluster, il vous suffit de fournir un NODELIST vide ou d'omettre complètement la propriété NODELIST.

VS="nom_serveur_virtuel"

Définit le nom du serveur virtuel. Il s'agit du nom que les utilisateurs voient quand ils se connectent au serveur virtuel. Pour plus d'informations, reportez-vous à la rubrique Création d'un cluster avec basculement (64 bits). Ce nom peut comporter jusqu'à 15 caractères et doit respecter les conventions d'appellation d'un ordinateur.

Voir aussi

Exécution du programme d'installation de SQL Server 2000 (64 bits)

Réinstallation de SQL Server 2000 (64 bits)


Exécution du programme d'installation de SQL Server 2000 (64 bits)

Exécutez la commande Setup pour installer Microsoft® SQL Server™ 2000 (64 bits) ou ses fonctionnalités. Pour cela, procédez de l'une des façons suivantes :

  • Exécutez Setup.exe à partir d'un fichier de commandes par lot ou de l'invite de commande. Avec cette méthode, les commutateurs d'installation sont spécifiés de la même façon qu'avec tout autre utilitaire d'invite de commande.

  • Exécutez Setup.exe dans un fichier exécutable d'installation d'application, à l'aide d'une méthode similaire à la fonction Microsoft Win32® CreateProcess(). Dans ce cas, les commutateurs d'installation sont spécifiés dans une chaîne de caractères passée à l'aide du paramètre lpCommandLine. Pour plus d'informations sur l'utilisation de CreateProcess() pour exécuter Setup.exe, reportez-vous à la rubrique "Desktop Engine Installation Samples" dans la documentation en ligne de SQL Server 2000 32 bits.

Pour effectuer une installation sans surveillance, utilisez l'argument /qn ou /qb. L'argument /qn permet d'effectuer une installation silencieuse en n'affichant aucune boîte de dialogue d'interface utilisateur. L'argument /qb affiche uniquement les boîtes de dialogue présentant des informations de progression, telles que la boîte de dialogue invitant les utilisateurs à redémarrer à la fin de l'installation de SQL Server. Pour une installation sans surveillance d'un cluster avec basculement, vous devez utiliser l'argument /qn.

La méthode privilégiée de suppression d'une instance de SQL Server 2000 consiste à utiliser l'application Ajout/Suppression de programmes du Panneau de configuration ou à exécuter Setup.exe à partir du bureau ou de l'Explorateur Windows. Vous pouvez toutefois utiliser la ligne de commande setup pour désinstaller SQL Server en vue d'une procédure sans assistance ou à partir d'une autre application. Pour désinstaller une instance de SQL Server 2000 à l'aide de la ligne de commande setup, appelez Setup.exe à l'aide du commutateur /x pour spécifier le fichier .msi qui a servi préalablement à installer cette instance. Par exemple, pour désinstaller une instance nommée installée avec un fichier .msi personnalisé nommé MyCustom.msi, exécutez :

Setup /x MyCustom.msi

Au lieu de spécifier un fichier .msi, vous pouvez spécifier le code produit à partir de la clé du registre ProductCode. Pour l'instance par défaut, utilisez HKEY_Local_Machine\Software\Microsoft\MSSQLServer\Setup:ProductCode. Pour une instance nommée, utilisez HKEY_Local_Machine\Software\Microsoft SQL Server\nom_instance\Setup:ProductCode.


Spécification des propriétés d'installation à l'aide d'un fichier .ini (64 bits)

Vous pouvez en option spécifier les propriétés de la ligne de commande setup à l'aide d'un fichier .ini. Sur la ligne de commande setup, utilisez l'argument /settings fichier_ini pour spécifier le fichier .ini. La première ligne du fichier .ini doit contenir la chaîne [Options].

Le fichier \Template.ini qui se trouve sur le CD-ROM d'installation de SQL Server 2000 (64 bits) fournit des instructions détaillées sur la création d'un fichier ini. Le format du fichier .ini est illustré dans l'exemple ci-dessous :

[Options]
USERNAME=MyName
COMPANYNAME=MyCompany
PIDKEY=ABCDE12345FGHIJ67890KLMNO
INSTALLSQLDIR="C:\Program Files\Microsoft SQL Server\"
INSTALLSQLDATADIR="C:\Program Files\Microsoft SQL Server\"
INSTANCENAME=MyInstance
SQLACCOUNT=MyDomain/MyAccount
SQLPASSWORD=MyPassword
...

Important Les paramètres de propriété contenant des espaces doivent figurer entre guillemets. Quant aux chemins d'accès, ils doivent toujours se terminer par une barre oblique inversée (\).

Vous pouvez également spécifier les paramètres de propriété d'une installation existante de SQL Server 2000 à l'aide d'un fichier .ini. Pour conserver une instance existante avec un fichier .ini, vous devez également insérer l'argument /i fichier_lot sur la ligne de commande pour spécifier le fichier de définition de lot de l'instance. Insérez l'argument /i sur la ligne de commande avec l'argument /settings. Exemple :

setup /i sqlrun01.msi /settings myinstance.ini /l*v c:\myinstance.log

Vous pouvez aussi spécifier le code produit à partir de la clé du registre ProductCode. Pour l'instance par défaut, utilisez HKEY_Local_Machine\Software\Microsoft\MSSQLServer\Setup:ProductCode. Pour une instance nommée, utilisez HKEY_Local_Machine\Software\Microsoft SQL Server\nom_instance\Setup:ProductCode.

Voir aussi

Commande Setup de SQL Server 2000 (64 bits)


Réinstallation de SQL Server 2000 (64 bits)

Si une tentative d'installation d'une instance de Microsoft® SQL Server™ 2000 (64 bits) échoue (du fait d'un compte de connexion incorrect ou de l'utilisation d'un compte Microsoft Windows® qui ne possède pas les autorisations de fichier suffisantes, par exemple), vous pouvez vouloir reprendre l'installation après avoir corrigé la condition d'erreur. Cela inclut des installations utilisant soit le programme d'installation de SQL Server 2000 (64 bits), soit les modules de fusion dans un processus d'installation de Windows Installer.

Lors de la reprise du processus d'installation, vous devez spécifier deux options d'installation en plus des options indiquées pendant la tentative d'installation d'origine :

REINSTALL=All

Indique que le programme d'installation de SQL Server 2000 installe toutes les fonctionnalités de SQL Server 2000. La seule valeur prise en charge est All.

REINSTALLMODE={omus|amus}

Indique le niveau de traitement effectué par le programme d'installation de SQL Server 2000. Spécifiez REINSTALLMODE=omus lors de la reprise d'une installation défaillante. Avec cette option, l'installation complète est vérifiée et terminée. Spécifiez REINSTALLMODE=amus lorsque vous devez reconstruire uniquement la base de données principale, comme après une défaillance du disque contenant la base de données principale.

Voir aussi

Commande Setup de SQL Server 2000 (64 bits)

Réparation d'une installation de SQL Server (64 bits)


Prise en charge de la ligne de commande de cluster (64 bits)

La syntaxe suivant montre les arguments et les propriétés utilisées par la ligne de commande setup pour un cluster avec basculement. Pour obtenir une documentation complète sur les arguments et les propriétés, reportez-vous à la rubrique Commande Setup de SQL Server 2000 (64 bits).

Syntaxe

setup /? |

[
{[/i fichier_définition_lots]
{[/settings fichier_ini]
|[USERNAME="nom_utilisateur"]
[COMPANYNAME="nom_société"]
PIDKEY=clé_cdrom
INSTALLSQLDIR="chemin_dossier_exécutable_SQL"
INSTALLSQLDATADIR="chemin_dossier_données"
[REMOVE="sélection_fonctionnalités"]
[INSTANCENAME="nom_instance"]
SQLACCOUNT="nom_connexion/domaine"
SQLPASSWORD="mot_de_passe"]]
AGTACCOUNT="nom_domaine\connexion"
AGTPASSWORD="password"]]
[SQLAUTOSTART={0|1}]
[AGTAUTOSTART={1|0}]
[SECURITYMODE=SQL]
[SAPWD="mot_de_passe_sa"]
[COLLATION="indicateur_classement"]
[PERPROCESSOR="licence_par_ordinateur"
|PERSEAT="licence_par_siège"]
[UPGRADE=1
[UPGRADEUSER="compte_connexion"
[UPGRADEPWD="mot_de_passe"]]
[CALLBACK=nomDll!NomFonctionRappel]
[REINSTALL=All

REINSTALLMODE={omus|amus}]
VS="nom_serveur_virtuel"
IP="adresse1_ip,nom1_réseau"
[IP="adresse2_ip,nom2_réseau" ...]
NODELIST="nom_nœud1,nom_nœud2"
GROUP="nom_groupe_clusters"
ADMINACCOUNT="nom_connexion\domaine"
ADMINPASSWORD="mot_de_passe_admin"]}]
/qn
[/l*v fichier_journal]
]

Pour installer Microsoft® SQL Server™ 2000 (64 bits) sur un cluster avec basculement, vous devez d'abord exécuter la ligne de commande setup sur le cluster. Les paramètres de propriété suivants sont obligatoires (à l'exception de INSTANCENAME, qui est facultatif).

Propriété | Commentaire
VS | Définit le nom du serveur virtuel. Ce nom peut comporter jusqu'à 15 caractères et doit répondre aux règles d'appellation des ordinateurs.
IP | Définit les adresses IP. Utilisez une entrée pour chaque carte réseau. Le format est "adresse IP,réseau", par exemple IP="172.26.16.77, Local Area Connector 2".
NODELIST | Définit les noms du serveur virtuel. Les nœuds doivent déjà exister dans le cluster. Pour ajouter un nœud à la définition de serveur virtuelle, exécutez la ligne de commande d'origine avec le nouveau nœud ajouté au paramètre de la propriété NODELIST. Pour supprimer un nœud, exécutez la ligne de commande d'origine avec le nœud supprimé du paramètre de propriété. Pour désinstaller un cluster, exécutez la NODELIST avec une propriété NODELIST vide (ou omettez-la complètement).
ADMINACCOUNT ADMINPASSWORD | Définit un compte utilisé pour lancer des processus vers les nœuds distants pendant l'installation uniquement. Ce compte d'utilisateur doit se trouver dans le groupe d'administrateurs sur tous les nœuds qui doivent être inclus dans le serveur virtuel. Ce compte doit être défini.
INSTALLSQLDIR | La lettre de lecteur du chemin doit exister sur tous les nœuds du cluster.
INSTALLSQLDATADIR | Définit un emplacement sur un disque partagé qui est un membre du groupe de clusters.
SQLACCOUNT | Obligatoire
SQLPASSWORD | Obligatoire
AGTACCOUNT | Obligatoire
AGTPASSWORD | Obligatoire
INSTANCENAME | Facultatif. Si vous souhaitez affecter un nom d'instance au serveur virtuel, insérez ce paramètre de propriété.


Maintenance d'une installation SQL Server (64 bits)

Les méthodes favorites de maintenance d'une installation Microsoft® SQL Server™ 2000 (64 bits) consistent soit à utiliser l'application Ajout/Suppression de programmes du Panneau de configuration, soit à exécuter le programme d'installation de SQL Server 2000. Ces applications prennent en charge l'ajout et la suppression de fonctionnalités d'une instance installée de SQL Server 2000 (64 bits) ou la suppression complète d'une instance. Vous pouvez également définir des paramètres de propriété sur la ligne de commande setup. Enfin, à l'aide de la ligne de commande, vous pouvez vérifier et réparer une installation existante, de même que réparer la base de données master et les entrées du registre. Ces options de maintenance sont décrites dans les rubriques suivantes.

Consultez | Pour
Ajout ou suppression de fonctionnalités de SQL Server (64 bits) | Ajouter ou supprimer des fonctionnalités SQL Server dans une instance installée de SQL Server 2000 (64 bits).
Suppression d'une installation de SQL Server (64 bits) | Supprimer une instance de SQL Server 2000 (64 bits).
Réparation d'une installation de SQL Server (64 bits) | Réparer une installation endommagée et reconstruire la base de données master ou les clés de registre d'une instance de SQL Server 2000 (64 bits).
Affichage des fichiers journaux d'installation (64 bits) | Trouver les descriptions et les emplacements de répertoire des fichiers journaux d'installation.
Mise à niveau de SQL Server 2000 (64 bits) | Trouver des informations sur la prise en charge de la mise à niveau d'installations existantes sur la plate-forme 64 bits.


Ajout ou suppression de fonctionnalités SQL Server (64 bits)

Vous pouvez ajouter ou supprimer individuellement des fonctionnalités dans une instance de Microsoft® SQL Server™ 2000 (64 bits). Pour ajouter ou supprimer une fonctionnalité, exécutez l'application Ajout/Suppression de programmes dans le Panneau de configuration et choisissez de modifier une instance de SQL Server. L'Assistant Installation démarre alors, ce qui vous permet de modifier les fonctionnalités installées ou de supprimer toutes les fonctionnalités. Dès lors que vous choisissez de modifier les fonctionnalités installées, l'Assistant affiche la page Sélection des fonctionnalités décrite dans la rubrique Définition des fonctionnalités de SQL Server (64 bits). Les étapes suivantes de l'Assistant sont liées aux fonctionnalités que vous choisissez d'installer ou de supprimer.

Remarque S'agissant d'une installation en cluster avec basculement, vous ne pouvez pas utiliser l'application Ajout/Suppression de programmes pour ajouter ou supprimer des fonctionnalités dans une instance. Vous devez pour cela utiliser l'interface graphique Setup.exe ou la ligne de commande.

Vous pouvez également ajouter ou supprimer des fonctionnalités en exécutant le programme d'installation de SQL Server 2000 à partir du bureau ou de l'Explorateur Windows. Lors du démarrage du programme d'installation, vous pouvez choisir d'utiliser une instance existante plutôt que d'en installer une nouvelle. La page Sélection des fonctionnalités ainsi que d'autres pages s'affichent pour achever la tâche. Dans ce mode d'installation, vous ne pouvez ni modifier l'emplacement d'une fonctionnalité précédemment installée, ni spécifier l'emplacement d'une nouvelle fonctionnalité.

Procédure d'ajout ou de suppression de fonctionnalités dans une instance de SQL Server 2000

Installation de SQL

Programme d'installation de SQL Server (64 bits)

Vous pouvez également ajouter ou supprimer des fonctionnalités sur la ligne de commande setup de SQL Server 2000 (64 bits). La ligne de commande est utile dans le cadre d'une procédure silencieuse ou pour conserver SQL Server à l'aide d'une autre application, même s'il est préférable d'ajouter ou de supprimer des fonctionnalités via l'application Ajout/Suppression de programmes ou via l'exécution du programme d'installation à partir du bureau. Sur la ligne de commande setup, utilisez la propriété ADDLOCAL pour indiquer les fonctionnalités à ajouter à une instance de SQL Server 2000. Utilisez la propriété REMOVE pour spécifier les fonctionnalités à supprimer. Pour plus d'informations, reportez-vous à la rubrique Commande d'installation de SQL Server 2000 (64 bits).

Voir aussi

Exécution du programme d'installation de SQL Server 2000 (64 bits)

Suppression d'une installation SQL Server (64 bits)

Réparation d'une installation SQL Server (64 bits)


Suppression d'une installation SQL Server (64 bits)

Utilisez l'application Ajout/Suppression de programmes dans le Panneau de configuration pour modifier ou supprimer une instance de Microsoft® SQL Server™ 2000 (64 bits). Lorsque vous supprimez l'instance par défaut ou une instance nommée de SQL Server 2000, les fichiers de données et les clés du registre relatifs à cette instance sont supprimés. Pour supprimer toutes les instances de SQL Server 2000, chaque instance doit être supprimée séparément.

Remarque S'agissant d'une installation en cluster avec basculement, vous ne pouvez pas utiliser l'application Ajout/Suppression de programmes pour supprimer une instance. Vous devez pour cela utiliser l'interface graphique Setup.exe ou la ligne de commande.

Les outils et les autres fichiers partagés ne peuvent pas être supprimés tant que toutes les instances de SQL Server 2000 n'ont pas été supprimées de l'ordinateur, parce qu'ils sont partagés entre toutes les instances installées. Lorsque SQL Server 2000 est désinstallé, certains fichiers peuvent subsister.

Vous pouvez supprimer SQL Server d'une instance sans supprimer Analysis Services. Toutefois, comme Analysis Services utilise les fichiers programme principaux de SQL Server pour son référentiel, l'application Ajout/Suppression de programmes ne supprime pas les fichiers programme principaux de SQL Server de l'instance tant que vous n'avez pas supprimé aussi Analysis Services. Pour plus d'informations, reportez-vous à la rubrique Analysis Services (64 bits).

Procédure de suppression de SQL Server 2000

Installation de SQL

Procédure de suppression de SQL Server 2000 (64 bits)

Si l'utilisation de l'application Ajout/Suppression de programmes ou l'exécution du programme d'installation à partir du bureau sont les deux méthodes conseillées de suppression de fonctionnalités, la ligne de commande est utile dans le cadre d'une installation silencieuse ou pour maintenir SQL Server à l'aide d'une autre application. Vous pouvez utiliser l'argument /x="fichier_définition_lots" sur la ligne de commande pour supprimer une instance de SQL Server 2000. Indiquez alors le nom du package d'installation (le fichier qui a servi à installer l'instance de SQL Server). Placez le fichier dans le même dossier que Setup.exe. Pour plus d'informations, reportez-vous à la rubrique Commande Setup de SQL Server 2000 (64 bits).

Si vous ne connaissez pas le fichier .msi qui a servi à installer l'instance, utilisez le code produit de l'instance. Le code produit de l'instance par défaut peut s'obtenir à partir de la clé de registre suivante :

HKEY_Local_Machine\Software\Microsoft\MSSQLServer\Setup:ProductCode

Le code produit de toute instance nommée peut s'obtenir à partir de la clé de registre suivante :

HKEY_Local_Machine\Software\Microsoft SQL Server\nom_instance\Setup:ProductCode

Voir aussi

Exécution du programme d'installation de SQL Server 2000 (64 bits)

Ajout ou suppression de fonctionnalités SQL Server (64 bits)


Réparation d'une installation SQL Server (64 bits)

Vous pouvez utiliser la ligne de commande setup avec les propriétés REINSTALL et REINSTALLMODE pour réparer une instance de Microsoft® SQL Server™ 2000 (64 bits). La propriété REINSTALL déclenche la réinstallation des fichiers programme et la propriété REINSTALLMODE spécifie le type de réinstallation. Ses deux paramètres, amus et omus, réparent et vérifient une instance de SQL Server. De plus, le paramètre amus répare une base de données master endommagée tandis que le paramètre omus reconstruit le registre. Vous pouvez spécifier ces propriétés sur la ligne de commande ou dans un fichier .ini.

Reconstruction du registre

Utilisez la ligne de commande setup avec les paramètres de propriété REINSTALL=ALL et REINSTALLMODE=omus pour reconstruire le registre d'une installation SQL Server 2000 (64 bits) endommagée. L'exécution conjointe de Setup.exe et de ces paramètres de propriété permet, outre la reconstruction du registre, de reconstruire, de vérifier et de réparer l'installation d'une instance.

Important Pour reconstruire le registre, vous devez utiliser le même fichier de lot et les mêmes choix que ceux opérés lors de l'installation initiale. Si vous ne connaissez pas ces informations, désinstallez d'abord SQL Server et réinstallez-le, au lieu d'utiliser la ligne de commande.

Reconstruction de la base de données master

Utilisez la ligne de commande setup avec les paramètres de propriété REINSTALL=ALL et REINSTALLMODE=amus pour reconstruire la base de données master d'une installation SQL Server 2000 (64 bits) endommagée. L'exécution conjointe de Setup.exe et de ces paramètres de propriété permet, outre la reconstruction des bases de données système, de reconstruire, de vérifier et de réparer l'installation d'une instance. Avec REINSTALLMODE=amus, vous pouvez modifier les paramètres de sécurité (SECURITYMODE et SAPWD) et le paramètre de classement (COLLATION).

Remarque importante Utilisez si possible l'authentification Windows. Ne laissez jamais le mot de passe sa vide ; utilisez toujours des mots de passe forts.

Voir aussi

Commande Setup de SQL Server 2000 (64 bits)

Exécution du programme d'installation de SQL Server 2000 (64 bits)


Affichage des fichiers journaux d'installation (64 bits)

Le tableau suivant décrit les fichiers journaux créés par les processus d'installation de SQL Server.

Nom de fichier | Description | Emplacement
SqlstpX.log | Chaque installation crée des fichiers sqlstpX.log, où X représente un numéro de séquence. Ce fichier journal contient une sortie provenant du programme d'installation Windows Installer et des informations sur l'installation. | %Temp%
SqlrunX.log (installation autonome) | Un journal non détaillé1 est créé en tant que SqlrunX.log, où X représente une énumération pour l'installation. Ce fichier journal contient des informations sur la procédure d'installation. | %Temp%
SqlrunX.log (installation avec basculement) | Le programme d'installation crée toujours un fichier journal SqlrunX.log non détaillé sur tous les nœuds en basculement, où X représente une énumération pour l'installation. Ce fichier journal contient des informations sur la procédure d'installation. | %Temp% (sur le nœud sur lequel le programme d'installation est lancé) %Windir% (sur les nœuds distants)
Dasetup.log | Il s'agit du fichier journal d'installation des composants MDAC (Microsoft Data Access Components). | %Windir%
Errorlog.log | Il s'agit du journal des erreurs de SQL Server. | L'emplacement par défaut de ce journal d'erreurs est C:\Program Files\Microsoft SQL Server\Mssql\Log\Errorlog. Pour une instance nommée, le journal d'erreurs se trouve dans \Microsoft SQL Server\Mssql$<nom_instance>\Log\Errorlog.

1 Vous pouvez exécuter le programme d'installation à l'aide de l'option de ligne de commande '/L*v' pour créer un fichier journal non détaillé (par exemple, setup.exe /L*v c:\SQL_Server_verbose.log). Les fichiers journaux non détaillés sont utiles pour rechercher les problèmes d'installation.


Mise à niveau de SQL Server 2000 (64 bits)

Les mises à niveau ne sont pas prises en charge pour cette version de SQL Server 2000 (64 bits). Les versions 32 bits de SQL Server n'étant pas prises en charge sur le système d'exploitation 64 bits de Microsoft Windows®, vous ne pouvez pas procéder à une mise à niveau à partir d'une version 32 bits antérieure de SQL Server (y compris SQL Server 2000 [32 bits], SQL Server version 7.0 ou SQL Server version 6.5) vers SQL Server 2000 (64 bits).


Configuration de SQL Server 2000 (64 bits)

Dès lors que le programme d'installation a terminé l'installation de Microsoft® SQL Server™ 2000 (64 bits), vous pouvez configurer SQL Server à l'aide des utilitaires graphiques et d'invite de commande. Tous les utilitaires d'invite de commande disponibles pour la version 32 bits de SQL Server 2000 sont fournis pour la version SQL Server 2000 (64 bits). En revanche, pour les outils graphiques, seuls l'utilitaire réseau SQL Server et le gestionnaire des services SQL Server sont fournis avec la version 64 bits. L'utilitaire réseau client, fourni par le système d'exploitation, est intégré aux composants MDAC (Microsoft Data Access Components). Les autres outils graphiques ne peuvent être installés qu'avec la version 32 bits de SQL Server 2000 sur le système d'exploitation 32 bits de Microsoft Windows®. Ils ne sont pas pris en charge sur le système d'exploitation 64 bits de Windows. Vous pouvez toutefois utiliser les outils graphiques installés avec la version 32 bits de SQL Server 2000 pour gérer à distance les fonctionnalités 64 bits de SQL Server.

Icône | Outil ou Utilitaire | Prise en charge
 | SQL Server Enterprise Manager Groupes SQL Server, enregistrement de serveur, options de serveur (bases de données, objets, connexions, utilisateurs et autorisations), tâches administratives des serveurs, Assistants de gestion | Administration à distance à partir de SQL Server 2000 32 bits. Reportez-vous à la rubrique "SQL Server Enterprise Manager" dans la documentation en ligne de SQL Server.
 | Analysis Manager Serveurs d'analyse, sources de données, cubes, modèles de Data Mining, stockage, sécurité, dimensions et rôles de sécurité | Administration à distance à partir de SQL Server 2000 32 bits. Reportez-vous à la rubrique "Analysis Manager" dans la documentation en ligne de SQL Server.
 | Analyseur de requêtes SQL Server Instructions SQL, lots et scripts | Administration à distance à partir de SQL Server 2000 32 bits. Reportez-vous à l'aide sur l'Analyseur de requêtes SQL Server dans la documentation en ligne de SQL Server.
 | Générateur de profils SQL Server Événements relatifs aux services SQL Server | Administration à distance à partir de SQL Server 2000 32 bits. Reportez-vous à la rubrique "Surveillance à l'aide du Générateur de profils SQL Server" dans la documentation en ligne de SQL Server.
 | Utilitaire réseau client Net-Libraries et noms d'alias des serveurs À partir d'une invite de commande ou de la commande Exécuter, exécutez Cliconfg.exe. | Outil MDAC sur les versions 64 bits du système d'exploitation de la famille Windows ®Server 2003. Reportez-vous à la rubrique "Utilitaire réseau client" dans la documentation en ligne de SQL Server.
 | Utilitaire réseau SQL Server Net-Library serveur | Pris en charge pour SQL Server 2000 (64 bits) La configuration de Net-Library n'est pas réalisée pendant l'installation et, le cas échéant, doit être effectuée avec cet utilitaire. Reportez-vous à la rubrique "Utilitaire réseau serveur" dans la documentation en ligne de SQL Server.
 | Importation et exportation de données Transformation de données | Prise en charge de la ligne de commande uniquement. Reportez-vous à la rubrique "Utilitaire dtsrun" dans la documentation en ligne de SQL Server.
 | Gestionnaire des services SQL Server Services de connexion à SQL Server (Microsoft Search, MSSQLServerOLAPService, SQL Server, Agent SQL Server) | Pris en charge pour SQL Server 2000 (64 bits) Reportez-vous à la rubrique "Gestionnaire des services SQL Server" dans la documentation en ligne de SQL Server.
 | Modes de licences SQL Server 2000 Licences par siège ou par ordinateur | Disponible dans le Panneau de configuration. Reportez-vous aux rubriques Mode de licence (64 bits) et Choix du mode de licence (64 bits).
 | Installation Instances et fonctionnalités de SQL Server | Prise en charge par le programme d'installation Windows Installer de SQL Server 2000 (64 bits).


Utilisation du menu Démarrer (64 bits)

Certains outils d'interface graphique sont accessibles par le biais du groupe de programmes de Microsoft® SQL Server™ dans le groupe Programmes du menu Démarrer. Ces outils sont les suivants :

  • Documentation en ligne

  • Utilitaire réseau serveur

  • Gestionnaire des services

De plus, vous pouvez ouvrir le Panneau de configuration pour démarrer les composants suivants :

  • Modes de licences de SQL Server 2000

Vous pouvez aussi démarrer les outils de ligne de commande à l'aide de la commande Exécuter du menu Démarrer ou à partir d'une invite de commande. Pour plus d'informations, reportez-vous à la rubrique Outils de gestion de SQL Server (64 bits).


Bases de données système et d'exemples (64 bits)

Lorsque Microsoft® SQL Server™ 2000 (64 bits) est installé, le programme d'installation crée les fichiers de base de données et les fichiers journaux répertoriés dans le tableau ci-dessous.

Base de données | Fichier de base de données | Fichier journal
master | Master.mdf | Mastlog.mdf
distmdl | Distmdl.mdf | Distmdl.ldf
model | Model.mdf | Modellog.ldf
msdb | Msdbdata.mdf | Msdblog.ldf
tempdb | Tempdb.mdf | Templog.ldf
pubs | Pubs.mdf | Pubs_log.ldf
Northwind | Northwnd.mdf | Northwnd.ldf

Les fichiers de base de données Analysis Services suivants apparaissent uniquement dans l'instance avec laquelle Analysis Services est installé.

Base de données | Fichier de base de données | Fichier journal
olapquerylog | OLAPQueryLog.mdf | OLAPQueryLog.ldf
olaprepository | OLAPRepository.mdf | OLAPRepository.ldf
Foodmart 2000 | Foodmart 2000.mdf | Foodmart 2000.ldf

L'emplacement par défaut des fichiers de base de données et des fichiers journaux est lecteur_système\Program Files\Microsoft SQL Server\Mssq\Data pour l'instance par défaut et lecteur_système\Program Files\Microsoft SQL Server\Mssq$nom_instance\Data pour une instance nommée. Les bases de données installées avec une instance peuvent ne pas inclure toutes les instances citées ci-dessus, selon les fonctionnalités installées avec l'instance.

Les bases de données système sont master, distmdl, model, msdb et tempdb. Les exemples de bases de données, pubs, Northwind et Foodmart 2000, sont fournies en tant qu'outils d'apprentissage. (Leur nom respecte la casse.) La plupart des exemples donnés dans la documentation en ligne de SQL Server s'appuient sur ces bases de données.


Localisation des dossiers et des fichiers (64 bits)

Les tableaux et illustrations ci-dessous indiquent quels sont les emplacements par défaut des dossiers et des fichiers de Microsoft® SQL Server™ 2000 (64 bits). En fonction des options installées, il est possible que certains fichiers cités dans les tableaux ne se trouvent pas sur votre ordinateur, alors que d'autres fichiers non cités s'y trouvent.

Les chemins d'accès répertoriés ici sont des chemins d'accès par défaut, et peuvent donc varier en cas de modification des emplacements durant l'installation. Les emplacements des fichiers programme et de données peuvent être modifiés, mais pas l'emplacement des outils partagés.

Fichiers partagés pour toutes les instances de SQL Server 2000

Ce tableau montre les emplacements des fichiers partagés pour les instances par défaut et nommées de SQL Server 2000.

Emplacement | Description
\Program Files\Microsoft SQL Server\80\Com | Bibliothèques de liens dynamiques (DLL) pour les objets COM (Component Object Model).
\Program Files\Microsoft SQL Server\80\Com\Binn\Resources\1033 | Fichiers de ressources (RLL) utilisés par les DLL dans ce dossier COM. Remarque : 1033 correspond à l'anglais É.U. ; les versions localisées portent des numéros de dossier différents.
\Program Files\Microsoft SQL Server\80\Setup Bootstrap | Fichiers installés par le programme Setup.exe pour prendre en charge la procédure d'installation.
\Program Files\Microsoft SQL Server\80\Tools\Binn | Versions 64 bits des fichiers exécutables clients de la famille Windows ®Server 2003.
\Program Files\Microsoft SQL Server\80\Tools\Binn\Resources\1033 | Fichiers de ressources utilisés par les DLL dans le dossier Tools\Binn.
\Program Files\Microsoft SQL Server\80\Tools\DevTools\ | Fichiers d'en-tête, fichiers de bibliothèque et exemples de programmes destinés aux développeurs.

1 Le lecteur par défaut de ces emplacements est lecteur_système, en général le lecteur C.

Fichiers programme et de données pour l'instance par défaut de SQL Server 2000

Le tableau suivant montre les emplacements des fichiers programme et des fichiers de données pour l'instance par défaut de SQL Server 2000. Il s'agit d'emplacements par défaut qui sont modifiables pendant l'installation. Pour une instance nommée, ces dossiers se trouvent dans lecteur_système\Program Files\Microsoft SQL Server\Mssql$nom_instance, où nom_instance désigne le nom de l'instance.

Emplacement1 | Description
\Program Files\Microsoft SQL Server\Mssql\Backup | Emplacement par défaut des fichiers de sauvegarde
\Program Files\Microsoft SQL Server\Mssql\Binn | Versions 64 bits des fichiers exécutables serveur de la famille Windows Server 2003 et fichiers DLL des procédures stockées étendues
\Program Files\Microsoft SQL Server\Mssql\Binn\Resources\1033 | Fichiers de ressources utilisés par les DLL dans le dossier Binn
Program Files\Microsoft SQL Server\Mssql\Data | Exemples de fichiers de base de données et fichiers système, notamment le référentiel et les exemples de fichiers de base de données d'Analysis Services (pour l'instance nommée ou par défaut de SQL Server avec laquelle vous installez Analysis Services)
\Program Files\Microsoft SQL Server\Mssql\Ftdata | Fichiers de catalogue de texte intégral
\Program Files\Microsoft SQL Server\Mssql\Install | Scripts exécutés pendant le programme d'installation et fichiers de sortie résultants
\Program Files\Microsoft SQL Server\Mssql\Log | Fichiers journaux des erreurs
\Program Files\Microsoft SQL Server\Mssql\Repldata | Dossier de travail des tâches de réplication

1 Le lecteur par défaut de ces emplacements est lecteur_système, en général le lecteur C.

Fichiers programme et de données d'Analysis Services

Ce tableau illustre les emplacements des fichiers programme et des fichiers de données d'Analysis Services. Il s'agit des emplacements des fichiers par défaut qui peuvent être modifiés pendant l'installation.

Emplacement1 | Description
\Program Files\Analysis Services\Bin | Versions 64 bits des fichiers exécutables serveur de la famille Windows Server 2003 et fichiers DLL de la famille Windows Server 2003
\Program Files\Analysis Services\Data | Bases de données du serveur d'analyse

1 Le lecteur par défaut de ces emplacements est lecteur_système, en général le lecteur C.

Notez que les exemples de fichiers de données et le référentiel d'Analysis Services sont installés dans le dossier SQL Data pour l'instance nommée ou par défaut de SQL Server avec laquelle vous installez Analysis Services. Reportez-vous au tableau précédent, dans la rubrique "Fichiers programme et de données pour l'instance par défaut de SQL Server 2000".

Emplacement des fichiers SQL Server 32 bits

Certains fichiers programme SQL Server 2000 partagés ont été transférés directement sur la plate-forme 64 bits. Ils incluent la documentation en ligne de Microsoft SQL Server.

Ce tableau illustre les emplacements des fichiers partagés pour les instances par défaut et nommées de SQL Server 2000.

Emplacement1 | Description
\Program Files (x86)\Microsoft SQL Server\80\Tools\Binn | Fichiers exécutables et DLL
\Program Files (x86)\Microsoft SQL Server\80\Tools\Binn\Resources\1033 | Fichiers RLL
\Program Files (x86)\Microsoft SQL Server\80\Tools\Books\ | Documentation en ligne de SQL Server 2000

1 Le lecteur par défaut de ces emplacements est lecteur_système, en général le lecteur C.

Emplacements des fichiers pour l'instance par défaut de SQL Server 2000

Cette illustration montre les emplacements de fichiers pour l'instance par défaut de SQL Server 2000 (64 bits).


Modification des mots de passe et des comptes d'utilisateur (64 bits)

Les comptes de service et mots de passe de Microsoft® SQL Server™ 2000 sont liés aux comptes d'utilisateur et aux mots de passe de Microsoft Windows®. Les modifications opérées à un emplacement peuvent nécessiter des modifications à l'autre emplacement.

Modification des comptes de service SQL Server après l'installation

Lorsque vous avez installé SQL Server 2000 (64 bits), utilisez Services dans le dossier Outils d'administration des versions 64 bits de la famille Windows ®Server 2003 pour modifier le mot de passe attribué ou d'autres propriétés d'un service associé à SQL Server. Chaque service doit être modifié séparément. Le nouveau compte d'utilisateur prend effet au redémarrage du service. Vous ne devez pas modifier les mots de passe des comptes de service SQL Server lorsqu'un nœud en cluster avec basculement est arrêté ou hors ligne. Si vous étiez amené à le faire, il vous faudrait redéfinir le mot de passe une fois tous les nœuds revenus en ligne.

Remarque Vous pouvez également gérer les services associés à une instance de SQL Server 2000 (64 bits) à partir de SQL Server Enterprise Manager sur une installation 32 bits de SQL Server 2000.

Si vous choisissez de remplacer le compte de service actuel de SQL Server par un compte non administrateur (le compte de service actuel de SQL Server n'est pas un compte administrateur), la boîte de dialogue Connexion administrateur valide s'affiche. Comme SQL Server doit détenir des droits administrateur pour pouvoir modifier les entrées de sécurité, vous devez entrer le nom utilisateur, le mot de passe et le domaine pour imiter le compte de service non administrateur que vous avez sélectionné.

Lorsque vous avez entré ces informations, tous les objets reçoivent une autorisation de contrôle intégral. L'emplacement des objets est déterminé comme suit :

  • Les autorisations sont définies pour tous les fichiers aux emplacements d'installation des données et des binaires pour les instances spécifiques.

  • Les autorisations de registre dépendent du type de l'instance, par défaut ou nommée :

    Pour une instance par défaut, les autorisations s'appliquent uniquement aux entrées figurant sous l'entrée HKLM\Software\Microsoft\MSSQLServer :

    • Client

    • MSSQLServer

    • Providers

    • Replication

    • Setup

    • SQLServerAgent

    • SQLServerSCP

    • Tracking

    Pour une instance nommée, les autorisations s'appliquent à l'entrée complète HKLM\Software\Microsoft\Microsoft SQL Server\nom_instance :

Les droits suivants sont accordés aux comptes :

  • SeServiceLogonRight, qui permet au compte de s'exécuter en tant que service ;

  • SeLockMemoryPrivilege, qui permet au compte d'utiliser la mémoire AWE de SQL Server ;

  • SeServiceLogonRight, qui permet au compte d'imiter d'autres comptes.

Si vous exécutez SQL Server dans une configuration de clusters avec basculement, des autorisations sont également définies pour tous les fichiers aux emplacements d'installation des données et des binaires pour tous les nœuds du cluster. Une autorisation est également accordée au compte de service de l'objet Cluster.

Le remplacement du compte de service actif de SQL Server par un compte non administrateur entraîne l'inaccessibilité des catalogues de texte intégral existants. Il vous faut alors soit reconstruire et exécuter un remplissage complet de tous les catalogues appartenant à cette instance de SQL Server, soit revenir à un compte détenant des autorisations administrateur.

Pour modifier les informations du compte de connexion des services MSSQLServer

Installation de SQL

Services (64 bits)

Si votre mot de passe Windows est modifié après l'installation de SQL Server 2000 (par exemple, votre mot de passe expire), vous devez également modifier les informations du compte d'utilisateur relatif aux services SQL Server dans Windows.

Pour plus d'informations sur la création de versions 64 bits des comptes d'utilisateur de la famille Windows Server 2003, sur l'octroi de droits d'utilisateur avancés, sur l'expiration des mots de passe et sur la gestion des membres de groupe, consultez les versions 64 bits de la documentation sur la famille Windows Server 2003. Pour obtenir des informations complémentaires, reportez-vous aux rubriques "Création de comptes de sécurité" et "Architecture de la sécurité" dans la documentation en ligne de SQL Server.


Changement de nom d'un serveur (64 bits)

Lorsque vous modifiez le nom de l'ordinateur exécutant Microsoft® SQL Server™ 2000 (64 bits), le nouveau nom est reconnu au démarrage de SQL Server. Vous n'avez pas besoin de réexécuter le programme d'installation pour réinitialiser le nom d'ordinateur.

Vous pouvez vous connecter à SQL Server à l'aide du nouveau nom d'ordinateur après avoir redémarré le serveur. Cependant, pour corriger la table système sysservers, vous devez exécuter manuellement les procédures suivantes :

sp_dropserver ancien_nom
GO
sp_addserver nouveau_nom, local
GO

Lorsque plusieurs instances de SQL Server sont installées sur l'ordinateur, modifiez les informations de la table système sysservers en exécutant les procédures stockées de la façon suivante :

sp_dropserver ancien_nomserveur\nom_instance
GO
sp_addserver nouveau_nomserveur\nom_instance, local
GO
Problèmes liés aux connexions d'accès distant et à la réplication

Si l'ordinateur dispose de connexions d'accès distant, par exemple, s'il s'agit d'un éditeur ou d'un distributeur de réplication, sp_dropserver peut générer une erreur semblable à ceci :

Server : Msg 15190, Level 16, State 1, Procedure sp_dropserver, Line 44
Il reste encore des connexions distantes pour le serveur 'SERVER1'.

Pour résoudre l'erreur, vous devez supprimer les connexions d'accès distant du serveur. Si la réplication est installée, désactivez-la en utilisant SQL Server Enterprise Manager à partir d'une installation 32 bits sur le serveur 64 bits. Exécutez ensuite la procédure stockée sp_dropserver.

Pour désactiver la réplication à l'aide de SQL Server Enterprise Manager

  1. Développez un groupe de serveurs, puis développez le distributeur (le serveur qui contient la base de données de distribution).

  2. Cliquez avec le bouton droit sur le dossier de réplication, puis sélectionnez Désactiver la publication.

  3. Exécutez les étapes de l'Assistant Désactivation de la publication et de la distribution.


Distribution d'images disque d'une installation (64 bits)

Microsoft® SQL Server™ 2000 (64 bits) inclut la même méthode que la version 32 bits de SQL Server 2000 pour la distribution d'une image disque d'une installation. Une installation créée pour la première fois est marquée comme nouvelle installation. Lorsque le serveur redémarre après une installation, SQL Server 2000 vérifie que le nom du serveur n'a pas changé. S'il a changé, une correction automatique est effectuée.

Cette fonctionnalité permet aux prestataires de services indépendants d'installer SQL Server 2000, d'arrêter le serveur, de cloner l'image du disque puis de distribuer cette dernière selon les besoins. Au premier démarrage du serveur distribué, la correction du nom est effectuée.

Ce processus peut s'effectuer en une seule étape. Si vous redémarrez le serveur et que vous l'arrêtez, vous devez créer une installation SQL Server en vue de sa distribution en tant qu'image lors du déploiement.


Configuration des bibliothèques réseau (64 bits)

Contrairement à la version 32 bits, Microsoft® SQL Server™ 2000 (64 bits) n'offre pas la configuration des bibliothèques réseau pendant l'installation. La mémoire partagée, les canaux nommés et TCP/IP sont activés par défaut pendant l'installation. Pour modifier ces paramètres, tels que l'activation ou la désactivation des protocoles, utilisez l'utilitaire réseau SQL Server qui se trouve dans le groupe de programmes Microsoft SQL Server du menu Démarrer.


Définition des options de configuration pour le masque d'affinité (64 bits)

Cette section introduit deux options de masque d'affinité que vous pouvez utiliser avec Microsoft® SQL Server™ 2000 (64 bits) pour contrôler l'affinité des processeurs. SQL Server 2000 (64 bits) prend en charge l'affinité de processeur avec deux options différentes de masques d'affinité : Option affinity mask (64 bits) et Option affinity64 mask (64 bits).


Option affinity mask (64 bits)

L'association entre une thread et un processeur s'appelle "affinité de processeur". En général, une association de ce type permet d'optimiser les performances de Microsoft® SQL Server™. Au niveau du système d'exploitation, toutefois, il peut arriver que Microsoft Windows® déplace les threads de processus entre les différents processeurs afin d'assurer les travaux multitâches. Si le système d'exploitation fonctionne de façon plus efficace grâce à cette technique, les performances de SQL Server peuvent s'en trouver altérées du fait des charges système élevées, puisque des données sont rechargés dans chaque cache de processeur de façon répétée.

SQL Server 2000 (64 bits) prend en charge l'affinité de processeur par le biais de deux options différentes de masques d'affinité : affinity mask et affinity64 mask. Pour plus d'informations sur l'option affinity64, reportez-vous à la rubrique Option affinity64 mask (64 bits).

Remarque L'option affinity64 mask est disponible uniquement sur SQL Server 2000 (64 bits).

L'option affinity mask, également disponible dans les versions précédentes de SQL Server, contrôle dynamiquement l'affinité de processeur. Utilisez-la pour augmenter les performances des systèmes SMP dotés de plus de quatre microprocesseurs fonctionnant avec des charges importantes. Vous pouvez associer une thread à un processeur spécifique et indiquer les processeurs qui seront utilisés par SQL Server. Vous pouvez également exclure l'activité propre à SQL Server des processeurs auxquels le système d'exploitation Windows 2000 ou Windows Server 2003 attribue des charges de travail données.

Si vous attribuez la valeur 1 à l'option affinity mask (autrement dit, si vous définissez un bit qui représente un processeur), ce processeur est sélectionné pour l'affectation des threads. Si vous lui attribuez la valeur 0 (valeur par défaut), les versions 64 bits des algorithmes de planification de la famille Windows ®Server 2003 définissent l'affinité de la thread. Si vous lui attribuez une valeur différente de zéro, SQL Server interprète cette valeur comme étant un masque binaire indiquant que ces processeurs sont ceux sur lesquels doit porter la sélection.

En empêchant les threads SQL Server de s'exécuter sur des processeurs distincts, les versions 64 bits de la famille Windows Server 2003 peuvent mieux évaluer la gestion par le système des processus propres à Windows. Par exemple, vous pouvez utiliser l'option affinity mask pour évaluer si une carte d'interface réseau (Network Interface Card) supplémentaire améliore les performances ou pour calculer les performances d'une carte NIC fortement sollicitée.

Les valeurs de l'option affinity mask sont les suivantes :

  • Un masque d'affinité à un octet prend en charge jusqu'à 8 processeurs sur un ordinateur multiprocesseur.

  • Un masque d'affinité à deux octets prend en charge jusqu'à 16 processeurs sur un ordinateur multiprocesseur.

  • Un masque d'affinité à trois octets prend en charge jusqu'à 24 processeurs sur un ordinateur multiprocesseur.

  • Un masque d'affinité à quatre octets prend en charge jusqu'à 32 processeurs sur un ordinateur multiprocesseur.

Étant donné que la définition de l'option d'affinité de processeur de SQL Server est une opération spécialisée, il est recommandé de n'utiliser cette option que lorsque cela est véritablement nécessaire. Dans la plupart des cas, les versions 64 bits de l'affinité par défaut de la famille Windows Server 2003 offrent les performances optimales.

Remarque Vous pouvez utiliser le Moniteur système Windows pour afficher et analyser l'utilisation des processeurs individuels.

Pour illustrer la définition de l'option affinity mask, prenons l'exemple suivant : si les processeurs 1, 2 et 5 sont sélectionnés comme étant disponibles et que les bits 1, 2 et 5 portent la valeur 1 et que les bits 0, 3, 4, 6 et 7 portent la valeur 0, une valeur hexadécimale égale à 0x26 ou l'équivalent décimal 38 est spécifié. Numérotez les bits de droite à gauche. Le bit situé à l'extrême droite est le bit numéro 0. Mettez les bits 1, 2 et 5 à 1. Le nombre calculé à partir de cette configuration de bits est la valeur binaire 00100110, qui correspond à la valeur décimale 38 ou à la valeur hexadécimale 0x26.

Vous trouverez ci-dessous les valeurs de l'option affinity mask pour un système à huit processeurs :

Valeur décimale | Masque binaire | Autorise les threads SQL Server sur les processeurs
1 | 00000001 | 0
3 | 00000011 | 0 et 1
7 | 00000111 | 0, 1 et 2
15 | 00001111 | 0, 1, 2 et 3
31 | 00011111 | 0, 1, 2, 3 et 4
63 | 00111111 | 0, 1, 2, 3, 4 et 5
127 | 01111111 | 0, 1, 2, 3, 4, 5 et 6 (isole l'activité SQL Server du processeur DPC uniquement)

L'option affinity mask est une option avancée. Si vous utilisez la procédure système stockée sp_configure pour modifier ce paramétrage, vous ne pouvez modifier l'option affinity mask que si l'option show advanced options porte la valeur 1. Ce paramètre est pris en compte immédiatement.

Pour plus d'informations, reportez-vous aux rubriques suivantes dans la documentation en ligne de SQL Server 2000 32 bits.

  • Surveillance avec le Moniteur système

  • RECONFIGURE

  • Paramétrage des options de configuration

  • sp_configure

  • Objets SQL-DMO et Administration de SQL Server


Option affinity64 mask (64 bits)

Une association entre une thread et un processeur s'appelle une affinité de processeur. En général, une association de ce type permet d'optimiser les performances de Microsoft® SQL Server™. Au niveau du système d'exploitation, toutefois, il peut arriver que Microsoft Windows® déplace les threads de processus entre les différents processeurs afin de gérer les travaux multitâches. Si le système d'exploitation fonctionne de façon plus efficace du fait de cette technique, les performances de SQL Server peuvent néanmoins s'en trouver altérées du fait des charges système élevées, puisque chaque cache de processeur est rechargée par des données de façon répétée.

Microsoft SQL Server 2000 (64 bits) prend en charge l'affinité de processeur par le biais de deux options de masques d'affinité : affinity mask et affinity64 mask. Pour plus d'informations sur l'option affinity mask, reportez-vous à la rubrique Option affinity mask (64 bits)

Remarque L'option affinity64 mask est disponible uniquement sur SQL Server 2000 (64 bits).

L'option affinity64 mask, nouvelle dans SQL Server 2000 (64 bits), contrôle dynamiquement l'affinité de processeur sur les systèmes 64 bits. Utilisez-la pour augmenter les performances des systèmes SMP 64 bits dotés de plus de 32 microprocesseurs fonctionnant avec des charges importantes.

Étant donné que c'est une valeur à 32 bits, l'option affinity64 mask contrôle jusqu'à 32 processeurs. Le masque 32 bits que contient l'option affinity64 mask prend en charge les 32 bits de poids faible d'un masque 64 bits, s'il y a 64 processeurs. Ainsi, pour définir l'affinité sur un système 32 bits ou 64 bits équipés de moins de 33 processeurs, vous devez uniquement manipuler l'option affinity mask. Pour définir l'affinité sur un système équipé de 33 à 64 processeurs, vous devez manipuler à la fois l'option affinity mask et l'option affinity64 mask en traitant les deux valeurs à 32 bits comme s'il s'agissait d'une valeur à 64 bits, afin d'identifier votre affinité au système. Pour plus d'informations sur la définition de l'affinité pour les 32 premiers processeurs, reportez-vous à la rubrique Option affinity mask (64 bits).

Si vous attribuez la valeur 1 à l'option affinity64 mask (autrement dit, si vous définissez un bit qui représente un processeur), ce processeur est sélectionné pour l'affectation des threads. Si vous lui attribuez la valeur 0 (valeur par défaut), les versions 64 bits des algorithmes de planification de la famille Windows ®Server 2003 définissent l'affinité de la thread. Si vous lui attribuez une valeur différente de zéro, SQL Server interprète cette valeur comme étant un masque binaire qui indique que ces processeurs sont ceux sur lesquels doit porter la sélection. Empêcher les threads SQL Server de s'exécuter sur des processeurs particuliers permet d'évaluer la gestion par le système des processus propres aux versions 64 bits de la famille Windows Server 2003. Par exemple, vous pouvez utiliser l'option affinity64 mask pour évaluer si une carte d'interface réseau (Network Interface Card) supplémentaire améliore les performances ou pour calculer les performances d'une carte NIC fortement sollicitée.

Étant donné que la définition de l'option d'affinité des processeurs de SQL Server est une opération spécialisée, il est recommandé de n'utiliser cette option que lorsque cela est véritablement nécessaire. Dans la plupart des cas, les versions 64 bits de l'affinité par défaut de la famille Windows Server 2003 offrent les meilleures performances.

Remarque Vous pouvez utiliser le Moniteur système Windows pour afficher et analyser l'utilisation des processeurs individuels.

L'option affinity64 mask est une option avancée. Si vous utilisez la procédure système stockée sp_configure pour modifier ce paramétrage, vous ne pouvez modifier l'option affinity64 mask que si l'option show advanced options porte la valeur 1. Ce paramètre est pris en compte immédiatement.


Procédures (64 bits)

Cet ensemble de rubriques Procédures contient les procédures courantes utilisées pour l'installation de Microsoft® SQL Server™ 2000 (64 bits).

  • Procédure d'installation de SQL Server 2000 (64 bits)

  • Procédure de modification des informations du compte de connexion des services SQL Server (64 bits)

  • Procédure de modification à distance des informations du compte de connexion des services SQL Server (64 bits)

  • Procédure de configuration de SQL Server à partir d'une invite de commande (64 bits)

  • Procédure d'ajout ou de suppression de fonctionnalités dans une instance de SQL Server 2000 (64 bits)

  • Procédure d'accès à la documentation en ligne de SQL Server (64 bits)

  • Procédure de création d'une instance de SQL Server 2000 (64 bits) respectant la casse

  • Procédure de suppression de SQL Server 2000 (64 bits)


Procédure d'installation de SQL Server 2000 (installations non ordonnées en clusters uniquement) (64 bits)

Pour installer SQL Server 2000

  1. Insérez le CD-ROM de Microsoft® SQL Server™ 2000 (64 bits) dans votre lecteur de CD-ROM.

    Si vous procédez à l'installation à partir d'un emplacement réseau, partagez les fichiers d'installation et connectez-vous à l'emplacement à partir de l'ordinateur sur lequel vous souhaitez installer le programme.

  2. Dans le dossier racine qui se trouve sur le CD-ROM ou à l'emplacement d'installation sur le réseau, double-cliquez sur Setup.exe.

  3. Cliquez sur Démarrer une nouvelle installation.

    Instance locale est la seule sélection proposée pour cette version de SQL Server 2000 (64 bits).

    Important Pour installer un cluster avec basculement, n'utilisez pas cette procédure. Reportez-vous à la rubrique Procédure de création d'un cluster avec basculement (programme d'installation) (64 bits).

  4. Dans la page d'accueil, cliquez sur Suivant.

  5. Dans la page Informations d'enregistrement, entrez le nom de l'utilisateur, le nom de la société et la clé du produit.

  6. Dans la page Contrat de licence du logiciel, prenez connaissance du contrat de licence et cliquez sur Oui pour l'accepter. Cliquez sur Non pour mettre fin à l'installation.

  7. Dans la page Sélection des fonctionnalités, vous pouvez non seulement sélectionner ou supprimer des fonctionnalités installées avec SQL Server 2000, mais également modifier les emplacements d'installation de ces fonctionnalités.

    Pour plus d'informations sur les fonctionnalités de SQL Server 2000, reportez-vous à la rubrique Sélection des fonctionnalités (64 bits).

    Remarque Pour installer l'ensemble des fonctionnalités de SQL Server 2000 à leurs emplacements par défaut, ne faites aucune modification et acceptez les paramètres par défaut.

  8. Dans la page Nom de l'instance, si l'option Instance par défaut est disponible, vous pouvez installer soit l'instance par défaut, soit l'instance nommée. Si elle n'est pas disponible, cela signifie qu'une instance par défaut a déjà été installée : vous ne pouvez donc installer qu'une instance nommée.
    • Pour installer l'instance par défaut, activez la case à cocher Instance par défaut.

    • Pour installer une instance nommée, désactivez la case à cocher Instance nommée et tapez le nom d'une instance. Pour plus d'informations, reportez-vous à la rubrique Attribution d'un nom aux instances (64 bits).
  9. Dans la page Compte de service, configurez les options de compte de connexion relatives aux comptes de service de SQL Server 2000.

    Activez la case à cocher Avancé pour configurer séparément les différents comptes de service.

  10. Dans la page Mode d'authentification, acceptez le paramètre par défaut.

    Remarque importante Utilisez si possible l'authentification Windows.

    Pour utiliser le Mode mixte, reportez-vous à la rubrique Définition du mode d'authentification (64 bits).

  11. Dans la page Paramètres de classement, ne modifiez les paramètres de classement et l'ordre de tri par défaut que si votre installation SQL Server doit correspondre aux paramètres de classement utilisés par une autre instance de SQL Server 2000 ou aux paramètres régionaux d'un autre ordinateur.

    Si vous devez être en phase avec les paramètres de classement des instances de SQL Server ou avec les paramètres régionaux Microsoft Windows® d'un autre ordinateur, reportez-vous à la rubrique Définition du paramètre de classement (64 bits).

  12. Dans la page Mode de licence, effectuez vos sélections en fonction de votre contrat de licence.

    Cliquez sur Aide pour en savoir plus sur la licence ou contactez votre administrateur réseau.

  13. Dans la page Prêt pour l'installation, cliquez sur Installer.

Voir aussi

Installation de SQL Server 2000 (64 bits)

Procédure d'ajout ou de suppression de fonctionnalités dans une instance de SQL Server 2000 (Programme d'installation) (64 bits)


Procédure de modification des informations du compte de connexion des services SQL Server (64 bits)

Pour modifier les informations du compte de connexion des services SQL Server

  1. Dans l'option Outils administratifs du Panneau de configuration, double-cliquez sur l'icône Services.

  2. Dans le volet de droite de l'icône Services, double-cliquez sur le service que vous souhaitez configurer.
    Service | Pour
    MSSQLSERVER | L'instance par défaut de Microsoft SQL Server™.
    MSSQL$nom_instance | Une instance nommée de SQL Server, où nom_instance désigne le nom de l'instance.
    SQLSERVERAGENT | L'Agent SQL Server de l'instance par défaut.
    SQLAgent$nom_instance | L'Agent SQL Server d'une instance nommée, où nom_instance désigne le nom de l'instance.
    MSSQLServerOLAPService | SQL Server 2000 Analysis Services.

  3. Dans l'onglet Ouvrir une session, cliquez sur Ce compte, puis modifiez le mot de passe ou les informations du compte.

    Remarque Le compte doit être membre du groupe local Administrateurs pour que SQL Server démarre correctement. Pour fournir l'accès réseau, il doit également être un compte de domaine.

Voir aussi

Procédure de modification à distance des informations du compte de connexion des services SQL Server (64 bits)

Création de comptes de service Windows (64 bits)


Procédure de modification à distance des informations du compte de connexion des services SQL Server (64 bits)

Remarque Cette version de Microsoft® SQL Server™ 2000 (64 bits) n'installe pas SQL Server Enterprise Manager. La procédure qui suit décrit la façon d'utiliser SQL Server Enterprise Manager sur le système d'exploitation de Microsoft Windows® 2000 pour gérer à distance la version 64 bits de SQL Server 2000.

Remarque Si les fichiers Microsoft SQL Server sont cryptés, vous devez les décrypter avant de pouvoir modifier les comptes de service SQL Server. Si vous ne décryptez pas les fichiers et ne redéfinissez pas les comptes de service SQL Server, vous ne pourrez pas décrypter les fichiers.

Pour modifier la connexion du service MSSQLServer (Enterprise Manager)

  1. Développez un groupe de serveurs.

  2. Cliquez avec le bouton droit sur un serveur, puis cliquez sur Propriétés.

  3. Dans la boîte de dialogue Propriétés de SQL Server, cliquez sur l'onglet Sécurité.

  4. Dans la zone Compte du service de démarrage, l'option Ce compte est sélectionnée, indiquant ainsi que le compte du service SQL Server est un compte de domaine Windows. Entrez les modifications à apporter au compte et au mot de passe.

    Remarque Pour que SQL Server démarre correctement, le compte doit être membre du groupe Administrateurs local de l'ordinateur à distance sur lequel SQL Server est installé. Pour fournir l'accès réseau, il doit également être un compte de domaine.

Pour modifier la connexion du service SQLServerAgent (Enterprise Manager)

Remarque Le compte Windows doit être membre du rôle de serveur fixe sysadmin pour pouvoir exécuter l'Agent SQL Server.

  1. Développez un groupe de serveurs, puis un serveur.

  2. Développez Gestion.

  3. Cliquez avec le bouton droit sur Agent SQL Server, puis cliquez sur Propriétés.

  4. Dans la boîte de dialogue Propriétés de l'Agent SQL Server, cliquez sur l'onglet Général.

  5. Dans la zone Compte du service de démarrage, entrez le compte et le mot de passe appropriés.

Voir aussi

Procédure de modification des informations du compte de connexion des services SQL Server (64 bits)

Création de comptes de service Windows (64 bits)

Modification des mots de passe et des comptes d'utilisateur (64 bits)

Création de comptes de service Windows (64 bits)


Procédure de configuration de SQL Server à partir d'une invite de commande (64 bits)

Vous pouvez exécuter directement le programme d'installation de SQL Server 2000 (64 bits) à partir d'une invite de commande ou d'un fichier de commandes.

Pour exécuter directement une installation automatique à partir d'une invite de commande

  1. Sur une invite de commande ou dans un fichier de commandes, utilisez Setup.exe à partir du dossier racine de l'édition de SQL Server que vous voulez installer.

  2. Utilisez les arguments et les propriétés nécessaires.

    Pour plus d'informations sur la syntaxe des commandes, les arguments et les propriétés du programme d'installation, reportez-vous à la rubrique Commande du programme d'installation de SQL Server 2000 (64 bits).

    Pour créer un fichier .ini dans lequel les propriétés seront spécifiées, utilisez le fichier Template.ini qui se trouve dans le dossier racine de votre CD-ROM.

Voir aussi

Exécution du programme d'installation de SQL Server 2000 (64 bits)


Procédure d'ajout ou de suppression de fonctionnalités dans une instance de SQL Server 2000 (64 bits)

Pour ajouter des fonctionnalités à une instance à l'aide de l'application Ajout/Suppression de programmes

  1. Dans le Panneau de configuration, double-cliquez sur l'icône Ajout/Suppression de programmes.

  2. Sous Programmes actuellement installés, cliquez sur l'instance de Microsoft® SQL Server™ pour procéder à la configuration, puis cliquez sur Modifier.

  3. Dans la page Modifier ou Supprimer, cliquez sur Modifier les fonctionnalités installées.

  4. Dans la page Sélection des fonctionnalités, vous pouvez sélectionner ou supprimer des fonctionnalités installées avec SQL Server 2000.

  5. Cliquez sur Suivant, puis suivez les instructions qui s'inscrivent dans les pages suivantes de l'Assistant.

Pour ajouter des fonctionnalités à une instance à l'aide du programme d'installation

  1. À partir du bureau ou de l'Explorateur Windows, démarrez Setup.exe sur le CD-ROM de SQL Server 2000 (64 bits).

  2. Dans la page Mode d'installation de l'Assistant Installation, cliquez sur Utiliser une installation existante.

  3. Dans la liste déroulante, sélectionnez l'instance que vous souhaitez conserver.

  4. Cliquez sur Suivant puis, dans la page Modifier ou Supprimer, cliquez sur Modifier les fonctionnalités installées.

  5. Dans la page Sélection des fonctionnalités, vous pouvez sélectionner ou supprimer des fonctionnalités installées avec SQL Server 2000.

  6. Cliquez sur Suivant, puis suivez les instructions qui s'inscrivent dans les pages suivantes de l'Assistant.

Voir aussi

Procédure de suppression de SQL Server 2000 (64 bits)

Procédure d'installation de SQL Server 2000 (programme d'installation) (64 bits)


Procédure d'accès à la documentation en ligne de SQL Server (64 bits)

Remarque Cette version de Microsoft® SQL Server™ 2000 (64 bits) inclut la documentation en ligne de SQL Server 2000 (32 bits). Pour connaître les différences entre les deux versions en termes d'installation et de documentation, consultez le fichier Lisezmoi.txt qui se trouve sur le disque d'installation, ainsi que ce fichier d'aide relatif à l'installation de SQL Server (Setupsql.chm) situé dans le dossier d'installation de SQL Server 2000 (64 bits).

Pour accéder à la documentation en ligne de SQL Server à partir du menu Démarrer

  • Dans le menu Démarrer, pointez sur Programmes et sur Microsoft SQL Server, puis cliquez sur Documentation en ligne.

    La documentation en ligne de Microsoft SQL Server 2000 (32 bits) s'affiche.

Pour créer un raccourci vers le fichier d'aide du programme d'installation de SQL Server 64 bits

  1. Recherchez le fichier Setup Bootstrap Setupsql.chm sur votre ordinateur. (L'emplacement par défaut est lecteur_système\Program Files\Microsoft SQL Server\80\SetupBootstrap\Help\1033.)

  2. Cliquez avec le bouton droit sur Setupsql.chm, puis cliquez sur Créer un raccourci.

  3. Copiez le raccourci sur votre bureau, d'où vous pourrez l'utiliser pour accéder à l'Aide du programme d'installation de SQL Server 64 bits.


Procédure de création d'une instance de SQL Server 2000 (64 bits) respectant la casse

Important Ne modifiez les paramètres de classement et l'ordre de tri par défaut que si votre installation SQL Server doit correspondre aux paramètres de classement utilisés par une autre instance de SQL Server 2000, ou aux paramètres régionaux Windows d'un autre ordinateur.

Pour créer une instance de SQL Server 2000 respectant la casse

  1. Exécutez le programme d'installation de Microsoft® SQL Server™.

  2. Cliquez sur Démarrer une nouvelle installation.

  3. Suivez les instructions qui s'inscrivent dans les pages d'accueil, d'informations d'enregistrement et de contrat de licence logiciel.

  4. Dans la page Sélection des fonctionnalités, choisissez d'installer les Composants serveur (il s'agit du paramètre par défaut). Vous pouvez modifier les autres paramètres par défaut ou les conserver.

  5. Dans la page Nom de l'instance :
    • Pour créer une instance par défaut respectant la casse, cliquez sur Instance par défaut (cette option est disponible uniquement si aucune autre instance par défaut n'est installée).

    • Pour créer une instance nommée respectant la casse, cliquez sur Instance nommée, puis tapez un nom d'instance.
  6. Dans les pages Compte de service et Mode d'authentification, modifiez ou acceptez les paramètres par défaut.

    Remarque importante Utilisez si possible l'authentification Windows.

  7. Dans la page Paramètres de classement, vous avez deux possibilités :
    • Pour qu'un classement correspondant à des paramètres régionaux Windows respecte la casse, sélectionnez Indicateur de classement, puis choisissez l'indicateur de classement approprié dans la liste. Activez la case à cocher Respecter la casse. Si la case à cocher Binaire est activée, désactivez-la.

    • Pour qu'un classement SQL respecte la casse, sélectionnez Classements SQL, puis choisissez le nom du classement approprié.

    Pour plus d'informations sur les options de classement, cliquez sur Aide. Lorsque vous avez terminé la spécification des options, cliquez sur Suivant.

  8. Dans la page Mode de licence, effectuez vos sélections en fonction de votre contrat de licence.

  9. Dans la page Prêt pour l'installation, cliquez sur Installer.

Voir aussi

Définition du paramètre de classement (64 bits)


Procédure de suppression de SQL Server 2000 (64 bits)

Pour supprimer une instance de SQL Server 2000

  1. Dans le Panneau de configuration, double-cliquez sur l'icône Ajout/Suppression de programmes.

  2. Sélectionnez l'instance nommée ou par défaut de Microsoft® SQL Server™ 2000, puis cliquez sur Supprimer.

Pour supprimer toutes les instances de SQL Server 2000

  1. Dans le Panneau de configuration, cliquez sur Ajout/Suppression de programmes.

  2. Répétez le processus de suppression pour chacune des instances de SQL Server 2000 installée.

Pour supprimer une instance à l'aide du programme d'installation

  1. À partir de My Computer ou de l'Explorateur Windows, démarrez Setup.exe qui se trouve sur le CD-ROM de SQL Server 2000 (64 bits).

  2. Dans la page Mode d'installation de l'Assistant Installation, cliquez sur Utiliser une installation existante.

  3. Dans la liste déroulante, sélectionnez l'instance que vous souhaitez supprimer.

  4. Cliquez sur Suivant puis, dans la page Modifier ou Supprimer, cliquez sur Supprimer Microsoft SQL Server.

  5. Suivez les instructions qui s'inscrivent dans les pages suivantes de l'Assistant.


Procédure de création ou de gestion d'un cluster avec basculement (64 bits)

Les rubriques Procédures de cette section contiennent des informations sur la création ou la gestion d'un cluster avec basculement. Pour créer un cluster avec basculement Microsoft® SQL Server™ 2000 (64 bits), vous devez d'abord configurer les services MSCS (Microsoft Cluster Services) à l'aide de l'Administrateur de clusters.


Procédure de création d'un cluster avec basculement (64 bits)

Important Pour créer un cluster avec basculement Microsoft® SQL Server™ 2000 (64 bits), vous devez au préalable configurer le service MSCS (Microsoft Cluster Service) à l'aide de l'Administrateur de clusters dans les versions 64 bits de la famille Windows® Server 2003 (d'autres systèmes d'exploitation Windows 64 bits seront disponibles dans les prochaines versions de SQL Server 2000 [64 bits]). Avant d'exécuter le programme d'installation de SQL Server, notez le groupe contenant le lecteur en cluster que SQL Server devra utiliser en faisant appel à l'Administrateur de clusters. Vous aurez besoin de cette information pour créer un cluster avec basculement.

Pour créer un cluster avec basculement

  1. Dans la page Mode d'installation, sélectionnez Démarrer une nouvelle installation. Dans la zone de liste déroulante, sélectionnez Serveur virtuel. Cliquez sur Suivant.

  2. Dans la page d'accueil de l'Assistant Installation de Microsoft SQL Server, cliquez sur Suivant.

  3. Dans la page Informations d'enregistrement, entrez le nom de l'utilisateur et le nom de la société. Cliquez sur Suivant.

  4. Dans la page Contrat de licence du logiciel, prenez connaissance du contrat de licence. Si vous l'acceptez, cliquez sur Oui.

  5. Dans la page Nom du serveur virtuel, entrez le nom d'un serveur virtuel. Ce nom est celui du serveur virtuel que vous créez. Il doit donc être unique sur l'ensemble du réseau. Cliquez sur Suivant.

  6. Dans la page Sélection du groupe de clusters, sélectionnez le groupe contenant le lecteur que vous souhaitez utiliser pour SQL Server dans Groupes de clusters disponibles. Le groupe de clusters sélectionné désigne l'emplacement dans lequel les ressources du serveur virtuel SQL Server seront placées. Si vous sélectionnez le groupe contenant la ressource quorum du cluster, un avertissement s'affichera pour vous recommander de ne pas procéder à l'installation dans cette ressource. Cliquez sur Suivant.

  7. Dans la page Gestion de clusters avec basculement, entrez une adresse IP pour chaque réseau que vous souhaitez configurer pour l'accès client. En d'autres termes, entrez une adresse IP pour chaque réseau sur lequel le serveur virtuel sera disponible pour les clients d'un réseau public (ou mixte). Sélectionnez le réseau pour lequel vous voulez entrer une adresse IP, puis entrez cette adresse IP. Cliquez sur Ajouter.

    L'adresse du réseau et le sous-réseau s'affichent. Le sous-réseau est fourni par MSCS. Continuez à entrer des adresses IP pour chaque réseau installé jusqu'à ce que vous ayez indiqué une adresse IP pour tous les réseaux souhaités. Cliquez sur Suivant.

  8. Dans la page Nom de l'instance, choisissez une instance par défaut ou spécifiez une instance nommée. Pour spécifier une instance nommée, sélectionnez Instance nommée, puis entrez le nom de l'instance nommée. Cliquez sur Suivant.

    Important Vous ne pouvez pas nommer une instance DEFAULT ou MSSQLSERVER. Pour plus d'informations, voir la rubrique "Travail avec des instances nommées et multiples de SQL Server 2000" dans la documentation en ligne de SQL Server 2000 32 bits. Les noms doivent se conformer aux règles applicables aux identificateurs SQL Server. Pour plus d'informations, reportez-vous à la rubrique "Utilisation des identificateurs" dans la documentation en ligne de SQL Server 2000 32 bits.

  9. Dans la page Configurer les nœuds, sélectionnez les nœuds à inclure dans la définition de cluster de serveurs virtuels. Tous les nœuds disponibles (par défaut) sont inclus dans la liste Nœuds sélectionnés. Vous pouvez supprimer tous les nœuds que vous ne souhaitez pas inclure en cliquant sur Supprimer jusqu'à ce que seuls les nœuds voulus apparaissent dans la liste Nœuds sélectionnés. Tous les nœuds indisponibles s'affichent dans la liste Nœuds indisponibles, de même que la raison de l'indisponibilité. Cliquez sur Suivant.

    Remarque Les versions 64 bits de la famille Windows Server 2003 prennent en charge jusqu'à quatre noeuds. Les systèmes d'exploitation Windows 64 bits supplémentaires qui seront disponibles dans les prochaines versions de SQL Server 2000 (64 bits) prendront en charge jusqu'à huit noeuds.

  10. Dans la page Informations sur le compte à distance, entrez les informations de connexion pour le nœud de cluster distant, notamment le Nom d'utilisateur, le Mot de passe et le Domaine. Les informations de connexion doivent disposer de privilèges d'administrateur locaux sur les nœuds du cluster et ses ressources. Cette boîte de dialogue apparaît uniquement lors de l'installation d'un ou de plusieurs nœuds distants. Cliquez sur Suivant.

  11. Dans la page Dossier d'installation, choisissez le lecteur de destination et le nom de répertoire des fichiers programme de SQL Server. Par défaut, tous les lecteurs disponibles apparaissent dans les listes déroulantes Fichiers programme et Fichiers de données. Vous devez sélectionner un lecteur disponible sur chaque nœud du cluster. Ensuite, vous devez choisir le lecteur de destination et le nom de répertoire des fichiers programme de SQL Server. Vous serez invité à sélectionner une ressource de lecteur en cluster contenue dans le groupe de clusters que vous avez choisi auparavant. Cliquez sur Suivant.

  12. Dans la page Compte de service, sélectionnez les informations de connexion des comptes de service. Entrez le Nom d'utilisateur, le Mot de passe et le Domaine du compte d'utilisateur de domaine pour le serveur virtuel. Tous les comptes de service d'un serveur virtuel doivent être des comptes de domaine. Activez la case à cocher Avancé pour spécifier le Nom d'utilisateur, le Mot de passe et le Domaine des services spécifiques. Sélectionnez le service dans la liste Service. Le compte de service de l'Agent SQL Server doit être l'administrateur de tous les nœuds du cluster. N'utilisez pas le compte qui a été affecté au service de cluster. Cliquez sur Suivant.

  13. Dans la page Mode d'authentification, choisissez le mode d'authentification à utiliser. Si vous remplacez la sélection Mode d'authentification Windows par Mode mixte (authentification Windows et authentification SQL Server), vous devez entrer un mot de passe pour la connexion sa et le confirmer, ou bien définir un mot de passe vide. La définition d'un mot de passe vide est déconseillée. Cliquez sur Suivant.

    Remarque importante Le cas échéant, utilisez l'authentification Windows.

    Remarque importante N'utilisez pas de mot de passe vide mais un mot de passe fort.

  14. Dans la page Paramètres de classement, choisissez le comportement de tri de votre serveur. Cliquez sur Suivant.

  15. Dans la page Mode de licence, sélectionnez Par siège ou Par ordinateur pour SQL Server. Entrez le nombre de licences approprié. Cliquez sur Suivant.

  16. Dans la page Prêt pour l'installation, cliquez sur Installer pour poursuivre l'installation.

  17. Dans la page Fin de l'exécution de l'Assistant Installation de Microsoft SQL Server.

    Redémarrez l'ordinateur si vous êtes invité à le faire. Il est important de lire le message émanant du programme d'installation à la fin de l'installation. Si vous ne redémarrez pas tous les nœuds spécifiés, des erreurs risquent de se produire lorsque vous exécuterez à nouveau le programme d'installation sur l'un des nœuds du cluster avec basculement.


Procédure de création d'un cluster avec basculement à un nœud (64 bits)

  1. Dans la page Mode d'installation, sélectionnez Démarrer une nouvelle installation. Dans la zone de liste déroulante, sélectionnez Serveur virtuel. Cliquez sur Suivant.

  2. Dans la page d'accueil de l'Assistant Installation de Microsoft SQL Server, cliquez sur Suivant.

  3. Dans la page Informations d'enregistrement, entrez le nom de l'utilisateur et le nom de la société. Cliquez sur Suivant.

  4. Dans la page Contrat de licence du logiciel, prenez connaissance du contrat de licence. Si vous l'acceptez, cliquez sur Oui.

  5. Dans la page Nom du serveur virtuel, entrez le nom d'un serveur virtuel. Ce nom est celui du serveur virtuel que vous créez. Il doit donc être unique sur l'ensemble du réseau. Cliquez sur Suivant.

  6. Dans la page Sélection du groupe de clusters, sélectionnez le groupe contenant le lecteur que vous souhaitez utiliser pour SQL Server dans Groupes de clusters disponibles. Le groupe de clusters sélectionné désigne l'emplacement dans lequel les ressources du serveur virtuel SQL Server seront placées. Si vous sélectionnez le groupe contenant la ressource quorum du cluster, un avertissement s'affichera pour vous recommander de ne pas procéder à l'installation dans cette ressource. Cliquez sur Suivant.

  7. Dans la page Gestion de clusters avec basculement, entrez une adresse IP pour chaque réseau que vous souhaitez configurer pour l'accès client. En d'autres termes, entrez une adresse IP pour chaque réseau sur lequel le serveur virtuel sera disponible pour les clients d'un réseau public (ou mixte). Sélectionnez le réseau pour lequel vous voulez entrer une adresse IP, puis entrez cette adresse IP. Cliquez sur Ajouter.

    L'adresse du réseau et le sous-réseau s'affichent. Le sous-réseau est fourni par MSCS. Continuez à entrer des adresses IP pour chaque réseau installé jusqu'à ce que vous ayez indiqué une adresse IP pour tous les réseaux souhaités. Cliquez sur Suivant.

  8. Dans la page Nom de l'instance, choisissez une instance par défaut ou spécifiez une instance nommée. Pour spécifier un nom d'instance, sélectionnez Instance nommée, puis entrez le nom de l'instance nommée. Cliquez sur Suivant.

    Important Vous ne pouvez pas nommer une instance DEFAULT ou MSSQLSERVER. Pour plus d'informations sur l'appellation des instances de SQL Server 2000, reportez-vous à la rubrique "Travail avec des instances nommées et multiples de SQL Server 2000". Les noms doivent suivre les règles des identificateurs de SQL Server. Pour plus d'informations sur les conventions d'appellation des identificateurs, reportez-vous à la rubrique Utilisation des identificateurs.

  9. Dans la page Configurer les nœuds, supprimez tous les nœuds de la liste Nœuds sélectionnés en cliquant sur Supprimer. Le seul nœud qui sera installé avec le serveur virtuel doit être répertorié dans la liste Nœud requis. Tous les nœuds indisponibles s'affichent dans la liste Nœuds indisponibles, de même que la raison de l'indisponibilité. Cliquez sur Suivant.

  10. Dans la page Informations sur le compte à distance, entrez les informations de connexion pour le nœud de cluster distant, notamment le Nom d'utilisateur, le Mot de passe et le Domaine. Les références de connexion doivent disposer de privilèges d'administrateur locaux. Cette boîte de dialogue apparaîtra uniquement si vous procédez à l'installation sur un nœud distant. Cliquez sur Suivant.

  11. Dans la page Dossiers d'installation, choisissez le lecteur de destination et le nom de répertoire des fichiers programme de SQL Server. Par défaut, tous les lecteurs disponibles apparaissent dans les listes déroulantes Fichiers programme et Fichiers de données. Vous devez sélectionner un lecteur disponible sur chaque nœud du cluster. Ensuite, vous devez choisir le lecteur de destination et le nom de répertoire des fichiers programme de SQL Server. Vous serez invité à sélectionner une ressource de lecteur en cluster contenue dans le groupe de clusters que vous avez choisi auparavant. Cliquez sur Suivant.

  12. Dans la page Compte de service, sélectionnez les informations de connexion des comptes de service. Entrez le Nom d'utilisateur, le Mot de passe et le Domaine du compte d'utilisateur de domaine pour le serveur virtuel. Tous les comptes de service d'un serveur virtuel doivent être des comptes de domaine. Activez la case à cocher Avancé pour spécifier le Nom d'utilisateur, le Mot de passe et le Domaine des services spécifiques. Sélectionnez le service dans la liste Service. Le compte de service de l'Agent SQL Server doit être l'administrateur du nœud du cluster. N'utilisez pas le compte qui a été affecté au service de cluster.

  13. Dans la page Mode d'authentification, choisissez le mode d'authentification à utiliser. Si vous remplacez la sélection Mode d'authentification Windows par Mode mixte (authentification Windows et authentification SQL Server), vous devez entrer un mot de passe pour la connexion sa et le confirmer, ou bien définir un mot de passe vide. La définition d'un mot de passe vide est déconseillée. Cliquez sur Suivant.

    Remarque importante Utilisez si possible l'authentification Windows.

  14. Dans la page Paramètres de classement, choisissez le comportement de tri de votre serveur. Cliquez sur Suivant.

  15. Dans la page Mode de licence, sélectionnez Par siège ou Par ordinateur pour SQL Server. Entrez le nombre de licences approprié. Cliquez sur Suivant.

  16. Dans la page Prêt pour l'installation, cliquez sur Installer pour poursuivre l'installation.

  17. Dans la page Fin de l'exécution de l'Assistant Installation de Microsoft SQL Server, cliquez sur Terminer.

    Redémarrez l'ordinateur si vous êtes invité à le faire. Il est important de lire le message émanant du programme d'installation à la fin de l'installation. Si vous ne redémarrez pas tous les nœuds spécifiés, des erreurs risquent de se produire lorsque vous exécuterez à nouveau le programme d'installation sur l'un des nœuds du cluster avec basculement.


Procédure d'ajout d'un nœud à un serveur virtuel existant (64 bits)

  1. Dans la page Mode d'installation, sélectionnez Utiliser une installation existante. Dans la zone de liste déroulante, sélectionnez le serveur virtuel auquel ajouter des nœuds. Cliquez sur Suivant.

  2. Dans la page Modifier ou Supprimer, cliquez sur Gérer le serveur virtuel.

  3. Dans la page Gestion de clusters avec basculement, cliquez sur Suivant.

    Il n'est pas nécessaire d'entrer une adresse IP, sauf si vous souhaitez modifier une adresse existante ou en ajouter une nouvelle.

  4. Dans la page Configurer les nœuds, vérifiez que tous les nœuds à ajouter au serveur virtuel figurent dans la liste Nœuds sélectionnés. Cliquez sur Suivant.

  5. Dans la page Informations sur le compte à distance, entrez les informations de connexion pour le nœud de cluster distant, notamment le Nom d'utilisateur, le Mot de passe et le Domaine. Les informations de connexion doivent disposer de privilèges d'administrateur locaux sur tous les nœuds du cluster et ses ressources. Cette boîte de dialogue apparaîtra uniquement si vous installez des nœuds distants. Cliquez sur Suivant.

  6. Dans la page Compte de service, sélectionnez les informations de connexion des comptes de service. Entrez le Nom d'utilisateur, le Mot de passe et le Domaine du compte d'utilisateur de domaine pour le serveur virtuel. Tous les comptes de service d'un serveur virtuel doivent être des comptes de domaine. Activez la case à cocher Avancé pour spécifier le Nom d'utilisateur, le Mot de passe et le Domaine des services spécifiques. Sélectionnez le service dans la liste Service. Le compte du service de l'Agent SQL Server doit être l'administrateur local de tous les nœuds du cluster. N'utilisez pas le compte qui a été affecté au service de cluster.

  7. Dans la page Prêt pour la mise à jour, cliquez sur Installer pour commencer la mise à jour de votre serveur virtuel.

  8. Dans la page Fin de l'exécution de l'Assistant Installation de Microsoft SQL Server, cliquez sur Terminer.

    Redémarrez l'ordinateur si vous êtes invité à le faire. Il est important de lire le message émanant du programme d'installation à la fin de l'installation. Si vous ne redémarrez pas tous les nœuds spécifiés, des erreurs risquent de se produire lorsque vous exécuterez à nouveau le programme d'installation sur l'un des nœuds du cluster avec basculement.


Procédure de suppression d'un nœud d'un cluster avec basculement existant (64 bits)

  1. Dans la page Mode d'installation, sélectionnez Utiliser une installation existante. Dans la zone de liste déroulante, sélectionnez l'installation à partir de laquelle supprimer un nœud. Cliquez sur Suivant.

  2. Dans la page Modifier ou Supprimer, cliquez sur Gérer le serveur virtuel.

  3. Dans la page Gestion de clusters avec basculement, cliquez sur Suivant. Vous ne devez pas entrer une adresse IP.

  4. Dans la page Configurer les nœuds, supprimez le nœud à supprimer de la liste Nœuds sélectionnés. Cliquez sur Supprimer, puis sur Suivant.

  5. Dans la page Informations sur le compte à distance, entrez les informations de connexion pour le nœud de cluster distant, notamment le Nom d'utilisateur, le Mot de passe et le Domaine. Les références de connexion doivent disposer de privilèges d'administrateur sur tous les nœuds du cluster. Cette boîte de dialogue apparaîtra uniquement si vous supprimez des nœuds distants. Cliquez sur Suivant.

  6. Dans la page Prêt pour la mise à jour, cliquez sur Installer pour commencer la mise à jour de votre serveur virtuel et supprimer le nœud sélectionné de votre cluster avec basculement.

  7. Dans la page Fin de l'exécution de l'Assistant Installation de Microsoft SQL Server, cliquez sur Terminer.

    Redémarrez l'ordinateur si vous êtes invité à le faire. Il est important de lire le message émanant du programme d'installation à la fin de l'installation. Si vous ne redémarrez pas tous les nœuds spécifiés, des erreurs risquent de se produire lorsque vous exécuterez à nouveau le programme d'installation sur l'un des nœuds du cluster avec basculement.


Procédure de suppression d'une instance organisée en clusters avec basculement (64 bits)

  1. Dans la page Mode d'installation, sélectionnez Utiliser une installation existante. Dans la zone de liste déroulante, sélectionnez l'installation à supprimer. Cliquez sur Suivant.

  2. Dans la page Modifier ou Supprimer, cliquez sur Supprimer Microsoft SQL Server.

  3. Dans la page Supprimer Microsoft SQL Server, cliquez sur Supprimer.


Procédure de récupération dans le cas d'une défaillance d'un cluster avec basculement dans le scénario 1 (64 bits)

Dans ce scénario, la défaillance est due à une défaillance matérielle dans le nœud 1 d'un cluster à deux nœuds. Cette défaillance matérielle peut être provoquée, par exemple, par la défaillance d'un contrôleur de disque ou du système d'exploitation.

  1. Après la défaillance du nœud 1, le cluster Microsoft ®SQL Server™ 2000 (64 bits) bascule sur le nœud 2.

  2. Exécutez le programme d'installation de SQL Server et supprimez le nœud 1. Pour plus d'informations, reportez-vous à la rubrique Procédure de suppression d'une instance organisée en clusters avec basculement (64 bits).

  3. Supprimez le nœud 1 du service MSCS (Microsoft Cluster Service). Pour supprimer un nœud de MSCS, à partir du nœud 2, ouvrez l'Administrateur de clusters, cliquez avec le bouton droit sur le nœud à supprimer, puis cliquez sur Supprimer le nœud.

  4. Installez le nouveau matériel pour remplacer le matériel défaillant dans le nœud 1.

  5. Installez le système d'exploitation. Pour plus d'informations sur le choix du système d'exploitation à installer et pour des instructions spécifiques sur la façon d'y procéder, reportez-vous à la rubrique Avant l'installation de la gestion de clusters avec basculement (64 bits).

  6. Installez le service MSCS et faites le lien avec le cluster existant à l'aide de l'Administrateur de clusters. Pour plus d'informations, reportez-vous à la rubrique Avant l'installation de la gestion de clusters avec basculement .

  7. Exécutez le programme d'installation sur le nœud 2 et réintégrez le nœud 1 au cluster avec basculement. Pour plus d'informations, reportez-vous à la rubrique Procédure d'ajout de nœuds à un serveur virtuel existant (64 bits).


Procédure de récupération dans le cas d'une défaillance d'un cluster avec basculement dans le scénario 2 (64 bits)

Dans le scénario 2, l'échec est causé par le nœud 1, défectueux ou hors connexion, mais il n'est pas rompu de manière irrémédiable. Cela peut être dû, par exemple, à une défaillance du système d'exploitation.

  1. Après la défaillance du nœud 1, le cluster Microsoft ®SQL Server™ 2000 (64 bits) bascule sur le nœud 2.

  2. Exécutez le programme d'installation de SQL Server et supprimez le nœud 1. Pour plus d'informations, reportez-vous à la rubrique Procédure de suppression d'une instance organisée en clusters avec basculement (64 bits).

  3. Résolvez le problème du nœud 1.

  4. Vérifiez que le cluster MSCS (Microsoft Cluster Service) fonctionne et que tous les nœuds sont en ligne.

  5. Exécutez le programme d'installation sur le nœud 2 et réintégrez le nœud 1 dans le cluster avec basculement. Pour plus d'informations, reportez-vous à la rubrique Procédure d'ajout de nœuds à un serveur virtuel existant (64 bits). Si vous devez modifier les domaines d'un cluster avec basculement SQL Server, recherchez l'article numéro Q319016 (en anglais) dans la Base de connaissances Microsoft sur le site Web de Microsoft.


Référence de l'interface utilisateur (64 bits)

Cette section décrit les options de l'Assistant Installation de Microsoft® SQL Server™ 2000 (64 bits). Ces options comprennent l'installation du moteur de base de données relationnelle SQL Server, l'installation du composant Analysis Services, l'installation d'un cluster avec basculement, ou encore la modification ou la suppression d'une installation actuelle. L'Assistant Installation contient les pages suivantes :

Rubrique | Description
Mode d'installation (64 bits) | Décrit le choix entre une installation existante et une nouvelle installation
Informations d'enregistrement (64 bits) | Aborde les options d'enregistrement de produits pour SQL Server
Sélection de fonctionnalités (64 bits) | Décrit l'ajout ou la suppression des fonctionnalités de SQL Server
Nom d'instance (64 bits) | Donne des consignes d'appellation des instances
Compte de service (64 bits) | Décrit la façon d'affecter des comptes de connexion aux services SQL Server
Mode d'authentification (64 bits) | Présente les options de sécurité concernant une installation
Paramètre de classement (64 bits) | Décrit les options de contrôle de la langue et de l'ordre de tri dans SQL Server
Mode de licence (64 bits) | Décrit les options du mode de licence
Compatibilité ascendante (64 bits) | Décrit les problèmes de compatibilité ascendante concernant le chaînage d'appartenance des bases de données
Signalisation des erreurs (64 bits) | Décrit les options de signalisation des erreurs pour les composants SQL Server
Nom du serveur virtuel (64 bits) | Décrit les conventions d'appellation d'un cluster avec basculement
Sélection de groupes de clusters (64 bits) | Aborde la sélection d'options de groupes de clusters
Gestion de clusters avec basculement (64 bits) | Présente les options de la gestion de clusters avec basculement
Configuration de nœuds (64 bits) | Définit les options de configuration des nœuds de cluster
Informations sur les comptes distants (64 bits) | Présente les options de configuration d'un compte distant pour le serveur virtuel dans un cluster avec basculement
Dossiers d'installation (64 bits) | Présente les options permettant de définir l'emplacement des fichiers programme et de données de SQL Server


Mode d'installation (64 bits)

Utilisez la page Mode d'installation de l'Assistant Installation de Microsoft® SQL Server™ 2000 (64 bits) pour créer une installation ou pour utiliser une instance existante de SQL Server.

Options

Démarrer une nouvelle installation

Crée une installation de SQL Server 2000. Choisissez cette option pour créer soit une instance nommée ou par défaut de SQL Server, soit un cluster avec basculement SQL Server. Cette option permet d'installer l'ensemble des fonctionnalités suivantes ou quelques-unes d'entre elles : le moteur de base de données relationnelle SQL Server, Analysis Services ou la Documentation en ligne. Si un cluster est détecté, l'option Serveur virtuel est sélectionnée par défaut. Si aucun cluster n'est détecté, l'option Instance locale est la seule sélection proposée pour cette version de SQL Server 2000 (64 bits).

Utiliser une installation existante

Vous permet d'ajouter ou de supprimer des fonctionnalités de SQL Server. Si une instance de la version bêta de SQL Server 2000 (64 bits) est déjà installée sur votre ordinateur, les options d'utilisation d'une base de données existante consisteront à utiliser des processus de sauvegarde/restauration ou d'attachement/détachement pour conserver vos bases de données actuelles.

Voir aussi

Démarrage du programme d'installation (64 bits)


Informations d'enregistrement (64 bits)

Utilisez la page Informations d'enregistrement de l'Assistant Installation de Microsoft® SQL Server™ 2000 (64 bits) pour entrer les informations d'identification utilisées pour enregistrer votre copie de SQL Server (64 bits).

Options

Nom

Tapez votre nom. Lors de l'installation de SQL Server sur un serveur en réseau, indiquez le nom d'un utilisateur chargé de l'administration du serveur. La mention de ce nom est obligatoire pour pouvoir continuer.

Société

Entrez le nom de votre société. Pour obtenir une copie personnelle du produit, vous pouvez entrer à nouveau votre nom. Cette information est facultative.

Clé du produit

Si les champs Clé du produit ne sont pas complétés automatiquement, entrez la clé du produit sur 25 caractères pour obtenir la copie d'installation de SQL Server 2000 (64 bits). Ce numéro est inscrit sur l'étiquette jaune collée sur la notice ou sur le boîtier du CD-ROM. Si vous procédez à l'installation à partir d'un réseau, procurez-vous la clé du produit auprès de votre administrateur réseau ou SQL Server. Vous devez indiquer la clé du produit pour pouvoir continuer.

Voir aussi

Démarrage du programme d'installation (64 bits)


Sélection de fonctionnalités (64 bits)

Utilisez la page Sélection des fonctionnalités de l'Assistant Installation de Microsoft® SQL Server™ 2000 (64 bits) pour déterminer les fonctionnalités SQL Server qui seront installées. Cette boîte de dialogue s'affiche à la fois lors de l'exécution du programme d'installation de SQL Server et après le choix de l'application Ajout/Suppression de programmes dans le Panneau de configuration. Pour une installation existante, cette page permet d'ajouter ou de supprimer des fonctionnalités.

Options

La page Sélection de fonctionnalités se compose de deux volets. Le volet gauche présente dans une arborescence les fonctionnalités que vous pouvez installer. Développez une fonctionnalité pour en afficher les sous-fonctionnalités. Lorsque vous cliquez sur une fonctionnalité ou sur une sous-fonctionnalité, la zone Description de la fonctionnalité décrit la sélection et affiche l'espace disque requis dans le volet de droite.

Pour ajouter ou supprimer une fonctionnalité, cliquez sur l'icône représentant la fonctionnalité et choisissez l'une des options suivantes dans la liste déroulante :

Installation sur le disque dur local
Installe la fonctionnalité sélectionnée à l'emplacement qui se trouve sous Chemin d'installation.
Installation sur le disque dur local
Installe la fonctionnalité sélectionnée et toutes ses sous-fonctionnalités. Développez la fonctionnalité pour en afficher les sous-fonctionnalités.
La totalité de cette fonctionnalité ne sera pas disponible
Pour une nouvelle installation de SQL Server, choisissez cette option pour ne pas installer la fonctionnalité sélectionnée. Pour une installation existante, choisissez cette option pour supprimer la fonctionnalité de l'installation. Lorsque cette option est sélectionnée, un X de couleur rouge apparaît dans l'icône de menu représentant la fonctionnalité, tandis que l'icône des fonctionnalités parentes apparaît en grisé dans l'arborescence.

La page Sélection des fonctionnalités offre également les options suivantes :

Chemin d'installation

Affiche le dossier d'installation des fichiers de la fonctionnalité sélectionnée. Cette option s'affiche uniquement pour les fonctionnalités dotées d'un chemin d'installation que les utilisateurs peuvent configurer.

Parcourir

Cliquez sur ce bouton pour modifier l'emplacement d'installation de la fonctionnalité sélectionnée.

Coût espace disque

Cliquez sur cette option pour vérifier l'espace disque disponible pour l'installation sur les différents disques de l'ordinateur. Lorsque vous avez vérifié l'espace disque disponible sur votre ordinateur dans la boîte de dialogue Coût espace disque, vous pouvez cliquer sur Reprendre pour continuer l'installation de SQL Server ou cliquer sur Quitter pour quitter le programme d'installation.

Voir aussi

Définition des fonctionnalités de SQL Server (64 bits)


Nom d'instance (64 bits)

Utilisez la page Nom d'instance de l'Assistant Installation de Microsoft® SQL Server™ 2000 (64 bits) pour déterminer si une instance par défaut ou une instance nommée de SQL Server doit être créée. Un nom d'instance par défaut sera utilisé jusqu'à ce que vous choisissiez une instance nommée.

Options

Instance par défaut

Sélectionnez cette option pour installer une instance par défaut de SQL Server 2000. Si cette option est désactivée, cela signifie que le programme d'installation a détecté une instance par défaut de SQL Server déjà installée sur l'ordinateur. Un ordinateur ne peut héberger qu'une instance par défaut ; toutes les autres instances doivent être nommées.

Instance nommée

Sélectionnez cette option pour entrer un nouveau nom d'instance. Lorsque vous affectez un nom à une instance de SQL Server, prenez les points suivants en considération :

  • Les noms d'instance ne respectent pas les majuscules/minuscules.

  • Les noms d'instance ne peuvent pas contenir la mention "Default "ou "MSSQLServer".

  • Le premier caractère d'un nom d'instance doit être une lettre, un trait de soulignement (_) ou un signe dièse (#). Les lettres acceptées sont celles définies par Unicode Standard 2.0, qui comprend les caractères latins a-z et A-Z ainsi que des caractères alphabétiques d'autres langues. Les chiffres et le symbole "et "commercial (&) ne sont pas autorisés.

  • Les autres caractères d'un nom d'instance peuvent être des lettres Unicode Standard 2.0, des nombres décimaux provenant de scripts latin ou nationaux, le signe dollar ($), le signe dièse (#) ou le trait de soulignement (_).

  • Les espaces imbriqués, les caractères spéciaux, la barre oblique inverse (\), la virgule (,), les deux-points (:) ou le signe @ ne sont pas autorisés dans les noms d'instance.

  • L'identificateur ne doit pas être un mot réservé. Si vous entrez un mot réservé dans un nom d'instance, une erreur se produit avec le message suivant : "Le nom d'instance spécifié est incorrect".

    Remarque Seuls les caractères identifiés dans la page de code de Microsoft Windows® sont autorisés dans les noms d'instance de SQL Server. En cas d'utilisation d'un caractère Unicode non pris en charge, une erreur se produit.


Compte de service (64 bits)

Utilisez la page Compte de service de l'Assistant Installation de Microsoft® SQL Server™ 2000 (64 bits) pour affecter un compte de connexion à ces services SQL Server : SQL Server, Agent SQL Server et Analysis Services. Les services actuels configurés dans cette page dépendent des fonctionnalités que vous avez sélectionnées.

Vous pouvez affecter soit le compte système local, soit un compte d'utilisateur de domaine à tous les services de SQL Server. Vous pouvez également configurer chaque compte de service individuellement et préciser si les services doivent démarrer automatiquement. Le paramètre par défaut est d'utiliser le même compte pour chaque service, et à démarrer automatiquement chaque service. Pour l'utiliser, entrez le nom de domaine, le nom d'utilisateur et le mot de passe, puis cliquez sur Suivant.

Si vous souhaitez personnaliser les paramètres, activez la case à cocher Avancés, puis modifiez les paramètres de chaque service dans la liste Service.

Remarque Pour modifier ultérieurement les options définies dans la page Compte de service, exécutez l'application Services du Panneau de configuration.

Options

Avancées

Activez cette case à cocher pour affecter des comptes de connexion spécifiques aux différents services.

Si cette case à cocher n'est pas activée, le même compte et les mêmes paramètres sont utilisés pour tous les services SQL Server 2000.

Service

Sélectionnez l'un des services suivants pour en personnaliser les paramètres.

Sélectionnez le service | Pour configurer
SQL Server | Les paramètres de service du moteur de base de données relationnelle Microsoft SQL Server
Agent SQL Server | Les paramètres de service de l'Agent Microsoft SQL Server
Analysis Services | Les paramètres de service de Microsoft SQL Server Analysis Services

Paramètres de service

Sélectionnez les paramètres de service nécessaires.

Utiliser le compte système local
Le compte système local ne requiert pas de mot de passe pour se connecter à SQL Server sur le même ordinateur. En utilisant ce type de compte, vous empêchez toutefois SQL Server d'interagir avec d'autres serveurs.
Utiliser un compte d'utilisateur de domaine
Un compte d'utilisateur de domaine utilise l'authentification Windows pour la configuration et la connexion à SQL Server. Par défaut, les informations de compte s'affichent pour le compte d'utilisateur de domaine actuellement connecté à l'ordinateur.
Nom d'utilisateur
Acceptez ou modifiez le nom d'utilisateur de domaine.
Mot de passe
Entrez le mot de passe du domaine.
Domaine
Acceptez ou modifiez le nom de domaine affecté au compte.
Démarrage automatique de service
Activez cette case à cocher pour démarrer automatiquement les services en même temps que votre système d'exploitation. Si la case à cocher Avancées est désactivée, l'option s'applique à tous les services ; si elle est activée, l'option s'applique uniquement au service affiché dans le champ Service.

Remarque Le service de l'Agent SQL Server dépend de SQL Server. Si vous activez cette case à cocher indépendamment de l'Agent SQL Server, celle-ci sera également sélectionnée pour SQL Server et apparaîtra en grisé.

Voir aussi

Définition des comptes de service (64 bits)


Mode d'authentification (64 bits)

Utilisez la page Mode d'authentification de l'Assistant Installation de Microsoft® SQL Server™ 2000 (64 bits) pour sélectionner le mode de sécurité (d'authentification) de cette installation. Si vous sélectionnez Mode mixte, vous pouvez entrer et confirmer le mot de passe de l'administrateur système (sa) SQL Server. Lorsque la connexion à SQL Server est établie, le mécanisme de sécurité est le même pour les deux modes.

Options

Mode d'authentification Windows

Quand un utilisateur se connecte par le biais d'un compte d'utilisateur Microsoft Windows®, SQL Server valide le nom et le mot de passe du compte à partir des informations du système d'exploitation Windows. Il s'agit du mode d'authentification par défaut.

Remarque importante Utilisez si possible l'authentification Windows.

Mode mixte (authentification Windows ou authentification SQL Server)

Le mode mixte permet aux utilisateurs de se connecter en utilisant l'authentification Windows ou l'authentification SQL Server. Les utilisateurs qui se connectent par l'intermédiaire d'un compte d'utilisateur Windows peuvent utiliser des connexions approuvées (des connexions validées par Windows) en mode d'authentification Windows ou en mode mixte.

Remarque L'authentification SQL Server permet de valider des comptes de connexion SQL Server. L'authentification SQL Server est fournie dans le seul but d'assurer la compatibilité ascendante. Microsoft recommande l'utilisation du mode d'authentification Windows.

Entrer le mot de passe

Entrez et confirmez la connexion de l'administrateur système (sa) pour l'authentification SQL Server. Les mots de passe SQL Server peuvent contenir de 1 à 128 caractères, notamment des lettres, des symboles et des chiffres. Si vous choisissez l'authentification en mode mixte, vous devez d'abord entrer un mot de passe avant de passer à la page suivante de l'Assistant Installation.

Si vous ne complétez pas le champ du mot de passe sa, l'Assistant Installation ouvre une boîte de dialogue de confirmation. Vous y êtes invité à définir un mot de passe fort pour sécuriser votre serveur de base de données, même si vous utilisez l'authentification Windows. Pour définir un mot de passe, cliquez sur Non dans la boîte de dialogue de confirmation. La page Mode d'authentification s'affiche alors pour vous permettre de définir votre mot de passe sa. Si vous souhaitez laisser le mot de passe sa vide et poursuivre l'installation, cliquez sur Oui dans la boîte de dialogue de confirmation. L'Assistant Installation se poursuit.

Attention Il est fortement déconseillé de ne pas spécifier de mot de passe de connexion sa car les utilisateurs peuvent alors se connecter à SQL Server en tant qu'administrateurs, ce qui peut entraîner une altération ou une perte des données par malveillance ou par inadvertance.

Voir aussi

Définition du mode d'authentification (64 bits)


Paramètres de classement (64 bits)

Utilisez la page Paramètres de classement de l'Assistant Installation de Microsoft® SQL Server™ 2000 (64 bits) pour modifier les paramètres de classement qu'utilise SQL Server pour les langues et de tri. Ne modifiez l'option Indicateur de classement que si votre installation SQL Server doit correspondre aux paramètres de classement utilisés par une autre instance de SQL Server 2000, ou doit correspondre aux paramètres régionaux Windows d'un autre ordinateur. Utilisez l'option Classements SQL pour une mise en correspondance avec les paramètres compatibles aux ordres de tri des versions antérieures de SQL Server.

Options

Indicateur de classement

Désigne le classement qui sera utilisé par cette instance de SQL Server 2000. Le paramètre par défaut de cette option est le paramètre régional Microsoft Windows® de votre ordinateur (le paramètre Langue pour les programmes non Unicode ou l'équivalent le plus proche dans les Options régionales et linguistiques du Panneau de configuration). Ne modifiez les paramètres de classement et l'ordre de tri par défaut que si votre installation SQL Server doit correspondre aux paramètres de classement utilisés par une autre instance de SQL Server 2000, ou aux paramètres régionaux Windows d'un autre ordinateur.

Sélectionnez dans la liste le nom d'un classement Windows spécifique. Par exemple :

  • utilisez Latin1_General pour le jeu de caractères anglais É.U. (page de code 1252) ;

  • utilisez Modern_Spanish pour toutes les variantes de l'espagnol, qui utilise également le même jeu de caractères que celui de anglais É.U. (page de code 1252) ;

  • utilisez Arabic pour toutes les variantes de l'arabe, qui utilise le jeu de caractères arabe (page de code 1256) ;

  • utilisez Japanese_Unicode pour la version Unicode du japonais (page de code 932), dont l'ordre de tri est différent de Japanese, mais qui partage la même page de code (932).

Pour plus d'informations, reportez-vous à la rubrique "Styles de tri des classements Windows" dans la documentation en ligne de SQL Server 2000 32 bits.

Ordre de tri

Définit l'ordre de tri qui sera utilisé avec l'Indicateur de classement sélectionné. L'ordre de tri Binaire est le plus rapide et respecte la casse. Si Binaire est sélectionné, les options Respecter la casse, Respecter les accents, Respecter le jeu de caractère Kana et Respecter la largeur ne sont pas disponibles. Pour plus d'informations, reportez-vous à la rubrique "Styles de tri des classements Windows" dans la documentation en ligne de SQL Server 2000 32 bits.

Classements SQL

L'option Classements SQL permet d'assurer la compatibilité avec les versions précédentes de SQL Server. Activez-la pour correspondre aux paramètres compatibles avec SQL Server version 7.0 et SQL Server version 6.5 ou antérieure. Pour plus d'informations, reportez-vous à la rubrique "Utilisation des classements SQL" dans la documentation en ligne de SQL Server 2000 32 bits.

Pour plus d'informations, reportez-vous à la rubrique "Définition du paramètre de classement"dans la documentation en ligne de SQL Server 2000 32 bits.


Mode de licence (64 bits)

Utilisez la page Mode de licence de l'Assistant Installation de Microsoft® SQL Server™ 2000 (64 bits) pour définir le mode de licence qui permet à vos clients d'accéder à SQL Server.

Options

Lisez le contrat de licence du logiciel fourni avec SQL Server 2000 pour rechercher le type et le nombre de licences qui ont été achetées avec le produit. Ensuite, dans la page Mode de licence de l'Assistant Installation, choisissez l'une des deux options suivantes :

Par siège

Ce mode de licence nécessite une licence pour l'ordinateur exécutant SQL Server 2000 et une licence d'accès client (CAL) pour chaque périphérique client qui se connecte au serveur. Un périphérique est, par exemple, un ordinateur personnel, une station de travail, un terminal, un assistant numérique personnel ou un téléphone mobile. Un nombre défini de licences d'accès client est fourni avec la licence du serveur et les logiciels serveur. Si vous choisissez cette option, en regard de Périphériques, tapez le nombre de licences d'accès client achetées pour SQL Server 2000.

Licence par ordinateur

Ce mode de licence nécessite une licence unique pour chaque unité centrale installée sur l'ordinateur exécutant SQL Server. Une licence par ordinateur permet la connexion d'un nombre illimité d'utilisateurs à partir d'un réseau local d'entreprise (LAN), d'un réseau étendu (WAN) ou d'Internet. Si vous choisissez cette option, en regard de l'option Ordinateurs, tapez le nombre de licences par ordinateur achetées pour SQL Server 2000.

Voir aussi

Choix du mode de licence (64 bits)


Compatibilité ascendante (64 bits)

Microsoft® SQL Server™ 2000 (64 bits) fournit des options de configuration pour le chaînage d'appartenance entre plusieurs bases de données. Les informations suivantes vont vous aider à déterminer si vous devez appliquer le comportement par défaut de chaînage d'appartenance entre plusieurs bases de données pendant l'installation, ou si vous devez passer outre les modifications et autoriser ce comportement pour toutes les bases de données utilisateur. En outre, cette rubrique fournit des informations sur la configuration de la prise en charge du chaînage d'appartenance entre plusieurs bases de données après l'installation.

Chaînage d'appartenance

Tous les objets de base de données ont des propriétaires. Lorsqu'un objet, tel qu'une procédure stockée, une vue ou une fonction définie par l'utilisateur, référence d'autres objets, une "chaîne de propriété" est établie. SQL Server utilise cette chaîne pour déterminer le mode de vérification des autorisations.

Lorsque le même utilisateur possède l'objet source (la vue, la procédure stockée ou la fonction définie par l'utilisateur) et tous les objets cible (les tables sous-jacentes, les vues ou d'autres objets), la chaîne de propriété est dite "ininterrompue". Dans ce cas, SQL Server vérifie les autorisations sur l'objet source mais pas sur les objets cible.

Le chaînage d'appartenance simplifie la gestion de la sécurité en permettant aux utilisateurs d'accorder des autorisations sur les vues, les procédures stockées et les fonctions définies par l'utilisateur, et non sur les objets individuels de la base de données. Par exemple, un utilisateur possédant plusieurs tables peut créer une vue intégrant des données issues des tables. L'utilisateur peut ensuite accorder des autorisations sur la vue et non sur les tables individuelles.

Chaînage d'appartenance entre plusieurs bases de données

Le chaînage d'appartenance entre plusieurs bases de données se produit lorsqu'un objet source dépend des objets contenus dans d'autres bases de données.

La chaîne de propriété entre les bases de données fonctionne de la même façon que le chaînage d'appartenance au sein d'une base de données, à ceci près qu'une chaîne de propriété ininterrompue repose sur tous les propriétaires d'objets mappés sur le même compte de connexion.

Si, dans une chaîne de propriété entre les bases de données, l'objet source de la base de données source et les objets cible des bases de données cible sont détenus par le même compte de connexion, SQL Server ne vérifie pas les autorisations sur les objets cible.

Ainsi, si deux bases de données sont détenues par le même compte de connexion, les utilisateurs dbo de ces bases de données sont mappés sur le même compte de connexion. Si le chaînage d'appartenance entre plusieurs bases de données est activé pour ces bases de données, les objets source du schéma dbo peuvent accéder aux objets cible du schéma dbo des deux bases de données.

Risques afférents au chaînage d'appartenance entre plusieurs bases de données

Le chaînage dappartenance dans une base de données est une technique de conception d'applications utile ; néanmoins, Microsoft ne recommande pas l'utilisation du chaînage d'appartenance entre plusieurs bases de données du fait des risques possibles liés à la sécurité. Ces risques sont dus aux actions que peuvent réaliser les utilisateurs dotés de privilèges élevés :

  • Les propriétaires de bases de données et les membres des rôles de bases de données db_ddladmin ou db_owners peuvent créer des objets détenus par d'autres utilisateurs. Ces objets peuvent potentiellement cibler des objets d'autres bases de données. Cela signifie que si vous activez le chaînage d'appartenance entre plusieurs bases de données, vous devez totalement approuver ces utilisateurs avec les données de l'ensemble des bases.

  • Les utilisateurs détenant l'autorisation CREATE DATABASE peuvent créer des bases de données et attacher des bases de données existantes. Si le chaînage d'appartenance entre plusieurs bases de données est activé, ces utilisateurs peuvent accéder aux objets des autres bases de données à partir de bases de données attachées ou récemment créées.

S Microsoft recommande la désactivation du chaînage d'appartenance entre plusieurs bases de données dans un souci de sécurité maximal, il existe certains environnements où vous pouvez approuver totalement vos utilisateurs détenant des privilèges élevés ; pour les applications qui se trouvent dans ces environnements, vous pouvez alors activer le chaînage d'appartenance entre plusieurs bases de données au niveau de la base de données ou de l'instance.

Options de la boîte de dialogue d'installation

Utilisez les informations suivantes pour déterminer si vous devez activer ou désactiver la case à cocher Activer le chaînage d'appartenance des bases de données :

  • Lorsque cette case est désactivée, le programme d'installation applique une modification qui, par défaut, désactive le chaînage d'appartenance entre les bases de données pour toutes les bases de données utilisateur. Après l'installation, vous pouvez activer le chaînage d'appartenance entre plusieurs bases de données pour des bases de données utilisateur individuelles à l'aide de la procédure système stockée db_option. Cette amélioration de la sécurité entre les bases de données vous permet de configurer les bases de données qui seront accessibles dans d'autres bases de données.

  • Si vous activez cette case à cocher, vous ignorez l'amélioration de sécurité et activez le chaînage d'appartenance entre plusieurs bases de données pour toutes les bases de données. Vous exposez ainsi votre système aux risques de sécurité décrits ci-dessus.

Quelle que soit l'option sélectionnée pendant le programme d'installation, vous pourrez ensuite modifier la prise en charge des serveurs et des bases de données pour le chaînage d'appartenance entre plusieurs bases de données.

Configuration du chaînage de la propriété entre les bases de données après l'installation

Si, après l'exécution du programme d'installation, vous devez modifier la configuration du chaînage d'appartenance entre plusieurs bases de données, utilisez les nouvelles options des procédures stockées sp_configure et sp_dboption :

  • Configurez la prise en charge du chaînage d'appartenance entre plusieurs bases de données pour l'instance de SQL Server avec la nouvelle option Chaînage d'appartenance des bases de données de sp_configure. Lorsque cette option prend la valeur 0, vous pouvez contrôler le chaînage d'appartenance entre les bases de données au niveau de la base de données à l'aide de la procédure stockée sp_dboption. Lorsque cette option prend la valeur 1, le chaînage d'appartenance entre plusieurs bases de données est activé sur toutes les bases de données utilisateur.

    Si vous modifiez cette option, insérez l'option RECONFIGURE pour reconfigurer l'instance sans avoir à la redémarrer. Par exemple, utilisez la commande suivante pour permettre le chaînage d'appartenance entre plusieurs bases de données pour toutes les bases de données :

    EXEC sp_configure 'Cross DB Ownership Chaining', '1'; RECONFIGURE
  • Configurez le chaînage d'appartenance des bases de données au niveau de la base de données à l'aide de la nouvelle option db chaining de sp_dboption. Lorsque cette option prend la valeur false, la base de données ne peut pas faire partie du chaînage d'appartenance entre plusieurs bases de données soit en tant que base de données source, soit en tant que base de données cible. Lorsque cette option prend la valeur true, la base de données peut faire partie du chaînage d'appartenance entre plusieurs bases de données. Par défaut, cette option prend la valeur false pour toutes les bases de données utilisateur après l'installation.

    La commande suivante active le chaînage d'appartenance entre plusieurs bases de données pour la base de données Northwind :

    EXEC sp_dboption 'Northwind', 'db chaining', 'true'

    Vous ne pouvez pas désactiver le chaînage d'appartenance entre plusieurs bases de données pour les bases de données master, tempdb et msdb. Vous ne pouvez pas désactiver le chaînage d'appartenance entre plusieurs bases de données pour la base de données model, qui sert de modèle aux bases de données utilisateur.

    Les effets de sp_dboption se manifestent uniquement lorsque l'option Chaînage d'appartenance des bases de données de sp_configure prend la valeur 0.

Pour plus d'informations, reportez-vous aux rubriques suivantes dans la documentation en ligne de SQL Server 2000 32 bits :

  • "Utilisation des chaînes d'appartenance"

  • "sp_configure"

  • "Paramétrage des options de configuration"

  • "sp_dboption"


Signalisation des erreurs (64 bits)

Utilisez la page Rapport des erreurs de l'Assistant Installation de Microsoft® SQL Server™ 2000 (64 bits) pour activer la génération de rapports d'erreurs.

La signalisation des erreurs de Microsoft SQL Server est désactivée par défaut. Vous pouvez l'activer pendant l'installation par le biais du programme d'installation de SQL Server ou d'Analysis Services, ou après l'installation via la boîte de dialogue

Propriétés de SQL Server Enterprise Manager Server ou de la boîte de dialogue Propriétés d'Analysis Manager Server (à partir d'un client distant exécutant le Service Pack 3 de SQL Server 2000).

L'activation de la signalisation des erreurs pendant l'exécution du programme d'installation de SQL Server ou d'Analysis Services active aussi la signalisation des erreurs pour le moteur de base de données SQL Server, l'Agent SQL Server et SQL Server Analysis Services. Si vous exécutez le programme d'installation de SQL Server et activez la signalisation des erreurs, puis que vous exécutez par la suite le programme d'installation d'Analysis Services, la signalisation des erreurs sera automatiquement activée pour Analysis Services, le moteur de base de données SQL Server et l'Agent SQL Server.

Si vous activez cette fonctionnalité, SQL Server est configuré pour envoyer automatiquement un rapport à Microsoft en cas de survenue d'une erreur irrécupérable dans le moteur de base de données SQL Server, l'Agent SQL Server ou SQL Server Analysis Services. Microsoft se sert des rapports d'erreurs pour améliorer les fonctionnalités de SQL Server. Toutes les informations traitées sont confidentielles.

Des informations sur les erreurs sont envoyées à Microsoft par le biais d'une connexion sécurisée (https) et sont stockées avec un accès limité. Ces informations peuvent également être envoyées sur votre propre serveur d'entreprise de signalisation des erreurs. Pour plus d'informations sur la configuration d'un serveur d'entreprise de signalisation des erreurs, consultez le site Web de Microsoft. Le rapport d'erreurs contient les informations suivantes :

  • la condition de SQL Server lorsque le problème s'est produit ;

  • des informations sur la version du système d'exploitation et le matériel ;

  • votre ID produit numérique, qui permet d'identifier votre licence ;

  • l'adresse IP réseau de votre ordinateur ;

  • des informations provenant de la mémoire ou des fichiers du processus qui a provoqué l'erreur.

Microsoft ne regroupe pas intentionnellement vos fichiers, nom, adresse, adresse de messagerie ou toute autre forme d'informations personnelles. Le rapport d'erreurs peut toutefois contenir des informations propres au client qui proviennent de la mémoire ou des fichiers du processus à l'origine de l'erreur. Bien que ces informations permettent à priori de déterminer votre identité, Microsoft ne les exploite pas à cette fin. Pour en savoir plus sur la stratégie de regroupement des données de signalisation des erreurs, consultez ce Microsoft Web site.

Si vous activez la signalisation des erreurs et qu'une erreur irrémédiable se produit, vous pouvez voir une réponse de Microsoft dans le journal des événements Windows, qui pointe sur un article de la Base de connaissance de Microsoft traitant cette erreur. Une réponse ressemble à ceci :

Source = MSSQLServerOlapServicesDW

EventID = 1010

data =http://support.microsoft.com/support/misc/kblookup.asp?id=

Pour désactiver la signalisation des erreurs pour le moteur de base de données SQL Server et l'Agent SQL Server, accédez aux Propriétés de SQL Server (onglet Général) dans Enterprise Manager (à partir d'un client distant exécutant le Service Pack 3 de SQL Server 2000), puis désactivez la case à cocher Activer la fonctionnalité de rapport d'erreurs. Pour désactiver la signalisation des erreurs pour Analysis Services, accédez aux Propriétés du serveur dans Enterprise Manager (à partir d'un client distant exécutant le Service Pack 3 de SQL Server 2000), puis désactivez la case à cocher Activer la fonctionnalité de rapport d'erreurs. Si la signalisation des erreurs est activée pour SQL Server (moteur de base de données et Agent SQL Server) et pour Analysis Services, vous devez désactiver individuellement la signalisation des erreurs pour SQL Server et Analysis Services.


Nom du serveur virtuel (64 bits)

Utilisez la page Nom de serveur virtuel de l'Assistant Installation de Microsoft® SQL Server™ 2000 (64 bits) pour indiquer le nom du serveur virtuel.

Options

Nom du serveur virtuel

Entrez le nom d'un serveur virtuel. Ce nom doit être unique dans votre domaine réseau.

Voir aussi

Création d'un cluster avec basculement (64 bits)


Sélection de groupes de clusters (64 bits)

Utilisez la page Sélection du groupe de clusters de l'Assistant Installation de Microsoft® SQL Server™ 2000 (64 bits) pour sélectionner le groupe de clusters MSCS (Microsoft Cluster Service). Le groupe de clusters sélectionné désigne l'emplacement dans lequel les ressources du serveur virtuel SQL Server seront placées.

Options

Groupes de clusters disponibles

Sélectionnez le groupe de clusters MSCS dans lequel les ressources du serveur virtuel SQL Server seront placées. Si vous sélectionnez le groupe contenant la ressource quorum du cluster, un avertissement s'affichera. Il est recommandé de ne pas procéder à l'installation dans cette ressource.

Groupes de clusters indisponibles

Tous les groupes de clusters MSCS indisponibles sont cités, accompagnés de la raison de leur indisponibilité.

Voir aussi

Création d'un cluster avec basculement (64 bits)


Gestion de clusters avec basculement (64 bits)

Utilisez la page Gestion de clusters avec basculement de l'Assistant Installation de Microsoft® SQL Server™ 2000 (64 bits) pour définir la configuration de l'adresse IP du serveur virtuel.

Options

Nom du serveur virtuel

Affiche le nom du serveur virtuel pour lequel vous définissez une adresse IP.

Réseau à utiliser

Sélectionnez le réseau pour lequel vous souhaitez entrer une adresse IP.

Adresse IP

Entrez l'adresse IP pour chaque réseau que vous souhaitez configurer pour l'accès client. En d'autres termes, entrez une adresse IP pour chaque réseau sur lequel le serveur virtuel sera disponible pour les clients d'un réseau public (ou mixte).

Adresse réseau

Affiche l'adresse du réseau fournie par le service MSCS (Microsoft Cluster Service).

Sous-réseau

Affiche le sous-réseau fourni par le service MSCS (Microsoft Cluster Service).

Ajouter

Sélectionnez cette option pour ajouter une adresse réseau et une adresse IP pour chaque réseau installé, jusqu'à ce que vous ayez indiqué une adresse IP pour tous les réseaux souhaités.

Supprimer

Sélectionnez cette option pour supprimer le réseau et l'adresse IP sélectionnés dans la zone Réseaux et adresses IP sélectionnés pour un réseau installé.

Réseaux et adresses IP sélectionnés

Affiche tous les réseaux et adresses IP sélectionnés qui sont configurés pour le serveur virtuel.

Voir aussi

Création d'un cluster avec basculement (64 bits)


Configuration de nœuds (64 bits)

Utilisez la page Configurer les nœuds de l'Assistant Installation de Microsoft® SQL Server™ 2000 (64 bits) pour sélectionner les nœuds du cluster à insérer dans la définition de cluster du serveur virtuel.

Options

Nœuds disponibles

Affiche les nœuds disponibles à inclure dans la définition de serveur virtuel. Cliquez sur Ajouter pour déplacer un nœud disponible dans la liste Nœuds sélectionnés.

Nœuds sélectionnés

Affiche les nœuds sélectionnés à inclure dans la définition de serveur virtuel.

Ajouter

Sélectionnez cette option pour amener le nœud sélectionné de la liste Nœuds disponibles dans la liste Nœuds sélectionnés, ce qui a pour effet d'ajouter le nœud à la définition de serveur virtuel.

Supprimer

Sélectionnez cette option pour supprimer un nœud sélectionné de la liste Nœuds sélectionnés. Le nœud est supprimé du serveur virtuel.

Nœud requis

Affiche le nœud requis. Le nœud obligatoire possède le groupe de clusters dans lequel les fichiers de données de SQL Server sont installés.

Nœuds indisponibles

Affiche une liste des nœuds indisponibles ainsi que la raison de l'indisponibilité de chaque nœud.

Voir aussi

Création d'un cluster avec basculement (64 bits)


Informations sur les comptes distants (64 bits)

Utilisez la page Informations sur le compte à distance de l'Assistant Installation de Microsoft® SQL Server™ 2000 (64 bits) pour entrer des informations sur les comptes distants concernant le serveur virtuel.

Options

Nom d'utilisateur

Entrez un nom d'utilisateur qui soit un compte administrateur local valide sur tous les nœuds du cluster.

Mot de passe

Entrez un mot de passe pour le compte administrateur local valide sélectionné sur tous les nœuds du cluster.

Domaine

Entrez le domaine du compte d'utilisateur de domaine sélectionné, qui soit un compte administrateur local valide sur tous les nœuds du cluster.

Voir aussi

Création d'un cluster avec basculement (64 bits)


Dossiers d'installation (64 bits)

Utilisez la page Dossiers d'installation de l'Assistant Installation de Microsoft® SQL Server™ 2000 (64 bits) pour spécifier les dossiers dans lesquels les fichiers programme et les fichiers de données de SQL Server seront installés.

Options

Fichiers programme

Sélectionnez le lecteur de destination et le nom de dossier des fichiers programme de SQL Server. Pour les configurations en cluster, vous devez sélectionner un lecteur local disponible sur chaque nœud du cluster.

Espace disponible

Affiche l'espace disponible pour le lecteur sélectionné.

Espace requis

Affiche l'espace requis pour les fichiers programme de SQL Server.

Fichiers de données

Sélectionnez le lecteur de destination et le nom de dossier des fichiers de données de SQL Server. Pour les configurations en cluster, vous devez sélectionner un lecteur de cluster dans le groupe que vous avez précédemment sélectionné.

Espace disponible

Affiche l'espace disponible pour le lecteur sélectionné.

Espace requis

Affiche l'espace requis pour les fichiers de données de SQL Server.

Voir aussi

Création d'un cluster avec basculement (64 bits)