Installation de Team Foundation

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Installation de Team Foundation
Image de liste déroulante

Le Guide d'installation Team Foundation est un document complet qui couvre l'installation de base de Team Foundation avec une topologie à un ou deux serveurs et à plusieurs clients. En outre, votre organisation peut décider d'installer Team Foundation Build et Team Foundation Server Proxy. Utilisez ce guide d'installation pour installer et configurer Team Foundation.

Vue d'ensemble

Visual Studio 2005 Team Foundation Server fournit des outils de collaboration en équipe qui permettent aux organisations de gérer et suivre la progression et l'état de leurs projets logiciels. Team Explorer intègre les produits de travail sur les projets recherchés sur le site des projets dans l'IDE de Visual Studio pour un accès d'équipe efficace. Team Foundation fournit également un suivi des éléments de travail extensible et des systèmes de contrôle de version de classe entreprise.

Démarrer ici pour la mise à niveau

Pour effectuer la mise à niveau de la version Beta 3 Refresh vers la version finale candidate, téléchargez le package de mise à niveau à partir du Centre de téléchargement Microsoft (http://go.microsoft.com/fwlink/?LinkID=60341) et suivez les instructions de mise à niveau pour les serveurs Team Foundation. Dans le cadre de nouvelles installations, suivez les instructions de ce guide.

Démarrer ici pour l'installation

Pour installer correctement Team Foundation Server sur les nouveaux ordinateurs, vous devez :

  • Récupérer la version la plus actuelle de ce guide, qui est téléchargeable à partir du Centre de téléchargement Microsoft (http://go.microsoft.com/fwlink/?LinkId=40042).

  • Passer en revue la documentation relative à l'installation et à l'administration des composants requis.

    • Windows Server 2003

    • Microsoft SQL Server 2005

    • Windows SharePoint Services

    • Autres logiciels en fonction des besoins de votre organisation.

  • Parcourez les sections applicables de ce guide d'installation avant d'installer Team Foundation Server.

  • Imprimez et utilisez la liste de vérification applicable pour l'installation de Team Foundation Server :

    • Liste de vérification : déploiement sur un serveur de Team Foundation Server

    • Liste de vérification : déploiement de Team Foundation Server sur deux serveurs

Démarrer ici pour MSDN Library

Pour installer MSDN Library, recherchez le fichier Setup.chm dans le dossier MSDN du support d'installation MSDN. MSDN propose plusieurs options d'installation, telles que l'installation sur le réseau. Ces options ne sont pas traitées dans cette documentation.

Nous mettons fréquemment à jour la documentation de Visual Studio Team System. Vous pouvez obtenir la dernière version de MSDN Library avec les modifications apportées à la documentation de Team Foundation Server à partir du site de documentation de Visual Studio Team System (http://go.microsoft.com/fwlink/?LinkId=62213).

Dans cette section

Architecture logique de Team Foundation

Propose une vue d'ensemble des couches de Team Foundation qui constituent l'architecture logique.

Architecture physique de Team Foundation

Propose une vue d'ensemble des fonctionnalités des produits Team System et de l'architecture physique de Team Foundation.

Configuration de Team Foundation System

Indique la configuration système nécessaire relative au matériel et aux logiciels pour installer cette version de Team Foundation Server pour chaque déploiement.

Rubriques connexes

Vue d'ensemble de la sécurité de Team Foundation Server pour l'installation

Fournit des informations liées à la sécurité, par exemple les comptes d'utilisateurs, comptes de service, groupes et paramètres de port pour l'installation de Team Foundation Server.

Vue d'ensemble du déploiement sur un serveur de Team Foundation Server

Utilisez les procédures de cette section pour installer et configurer à la fois les composants de la couche Application et ceux de la couche Données de Team Foundation Server sur un serveur.

Vue d'ensemble du déploiement de Team Foundation Server sur deux serveurs

Utilisez les procédures de cette section pour installer et configurer Team Foundation Server à l'aide de deux ordinateurs, un pour les composants de la couche Données et un autre pour les composants de la couche Application.

Vue d'ensemble de l'installation de Team Foundation Build

Utilisez les procédures de cette section pour installer et configurer Team Foundation Build, qui fournit l'automation de la génération pour vous aider à générer et partager les solutions Visual Studio 2005.

Vue d'ensemble de l'installation de Team Foundation Server Proxy

Utilisez les procédures de cette section pour installer Team Foundation Server Proxy, qui met en cache les fichiers du contrôle de code source auxquels vous avez précédemment accédé.

Vue d'ensemble de l'installation de Team Explorer

Utilisez les procédures de cette section pour installer et configurer Team Explorer qui joue le rôle de composant client.

Ressources en ligne

Centre de développement Visual Studio Team System (http://go.microsoft.com/fwlink/?linkid=37625).

La page d'accueil de Visual Studio Team System.

Forums de Visual Studio Team System (http://go.microsoft.com/fwlink/?linkid=53443).

Obtenez des réponses à vos questions et résolvez vos problèmes avec la communauté en ligne des utilisateurs de Visual Studio Team System.

Lisez-moi de Team Foundation Server (http://go.microsoft.com/fwlink/?linkid=53268).

Contient les problèmes de dernière minute concernant l'installation du produit.

Problèmes connus de Team Foundation Server (http://go.microsoft.com/fwlink/?linkid=53095).

Contient les problèmes de dernière minute concernant l'utilisation du produit.

Guide de l'administrateur Team Foundation (http://go.microsoft.com/fwlink/?LinkId=52459).

Fournit une aide pour gérer des utilisateurs et des groupes, configurer les applications serveur et clientes, ainsi qu'une description à la fois du développement du logiciel et du déploiement des composants Visual Studio 2005 Team System.

Image de pied de page
Pour faire une suggestion ou rapporter un bogue éventuel à propos de l'aide ou de toute autre fonctionnalité, accédez au site de commentaires.


Architecture logique de Team Foundation
Voir aussi
Image de liste déroulante

Fournit une vue d'ensemble de l'architecture logique multicouche de Team Foundation.

Architecture logique de Team Foundation

Team Foundation est basé sur une architecture multicouche, qui comprend une couche Données, une couche Application et une couche cliente.

Couche Données

La couche Données Team Foundation se compose de Microsoft SQL Server 2005, qui stocke des éléments de travail, des fichiers sources sous contrôle de version, des résultats des tests et d'autres métriques de projet.

Couche Application

La couche Application de Team Foundation est composée d'applications basées sur le Web, des applications frontales qui sont intégrées avec Internet Information Services (IIS). Ces applications incluent SQL Server 2005 Reporting Services, Team Foundation Core Services et Windows SharePoint Services. De plus, la couche Application héberge les services Windows Team Foundation.

La couche Application de Team Foundation inclut également Team Foundation Build et Team Foundation Server Proxy. Team Foundation Build fournit des services d'automation de la génération. Team Foundation Server Proxy met en cache les fichiers de contrôle de code source auxquels vous avez précédemment accédé afin d'améliorer la performance des opérations de contrôle de code source sur les connexions de faible bande passante.

Couche cliente

La couche cliente de Team Foundation se compose de Team Explorer, qui peut être utilisé comme application autonome ou intégrée avec Visual Studio 2005 (sauf pour Visual Studio 2005 Express). La couche cliente s'intègre également avec Microsoft Office Project 2003 et Microsoft Office Excel 2003, que les chefs de projet peuvent utiliser pour consulter des informations sur le projet et publier ces informations dans Team Foundation Server.

Voir aussi

Concepts

Installation de Team Foundation
Architecture physique de Team Foundation


Architecture physique de Team Foundation
Image de liste déroulante

Fournit une vue d'ensemble de l'architecture physique de Team Foundation, y compris les fonctionnalités fournies par chacun des produits Team System.

Architecture physique de Team Foundation

Vous pouvez installer les couches logiques de Team Foundation sur un ou plusieurs ordinateurs physiques.

Team Foundation Server

Vous pouvez installer Team Foundation Server via un déploiement sur un serveur ou sur deux serveurs.

Serveur unique

Le déploiement de Team Foundation Server sur un serveur unique place les couches Données et Application sur le même ordinateur. Si vous choisissez d'installer la couche cliente sur le même ordinateur que les couches Données et Application, vous ne devez le faire qu'après avoir installé les composants serveur. Sinon, vous pouvez installer la couche cliente en parallèle avec les autres couches. Pour plus d'informations, consultez Vue d'ensemble du déploiement sur un serveur de Team Foundation Server.

Deux serveurs

Le déploiement de Team Foundation Server sur deux serveurs place les couches Données et Application sur des ordinateurs séparés. Vous pouvez installer simultanément les composants requis sur les deux ordinateurs serveur ; toutefois, vous devez installer les composants de la couche Données de Team Foundation avant d'installer les composants de la couche Application de Team Foundation. Si vous choisissez d'installer la couche cliente sur le même ordinateur que la couche Application, vous ne devez le faire qu'après avoir installé les composants de la couche Application. Sinon, vous pouvez installer la couche cliente en parallèle avec les autres couches. Pour plus d'informations, consultez Vue d'ensemble du déploiement de Team Foundation Server sur deux serveurs.

Team Foundation Build

Team Foundation Server offre des services d'automation de la génération afin de vous aider à générer et à partager des solutions Visual Studio 2005 à l'aide de Team Foundation Build. Vous pouvez installer Team Foundation Build sur un ordinateur séparé, ou sur le même ordinateur que la couche Application de Team Foundation. Pour plus d'informations, consultez Vue d'ensemble de l'installation de Team Foundation Build.

Team Foundation Server Proxy

Team Foundation Server Proxy améliore la performance de contrôle de version de Team Foundation en mettant en cache les fichiers auxquels vous avez précédemment accédé. Vous pouvez installer Team Foundation Proxy sur un ordinateur séparé, ou sur le même ordinateur que la couche Application de Team Foundation. Pour plus d'informations, consultez Vue d'ensemble de l'installation de Team Foundation Server Proxy

Team Explorer

Comme indiqué précédemment, la couche cliente comprend Team Explorer, qui peut être utilisé en tant qu'application autonome ou intégrée avec Visual Studio 2005 (sauf pour les éditions Visual Studio 2005 Express). Pour accéder à Team Foundation Server, vous devez installer en premier Team Explorer. Team Explorer est à la fois une application autonome avec les fonctionnalités de Team Foundation uniquement, et une addition à Visual Studio qui fournit les fonctionnalités Team Foundation intégrées. Il donne accès aux fonctionnalités de suivi des éléments de travail, de gestion de projet et de contrôle de version. Vous pouvez également utiliser Team Explorer pour accéder aux fonctionnalités de Team Foundation Server afin de prendre en charge des activités de développement avec les versions antérieures de Visual Studio. Pour plus d'informations, consultez Vue d'ensemble de l'installation de Team Explorer.

Voir aussi

Concepts

Installation de Team Foundation
Architecture logique de Team Foundation


Configuration de Team Foundation System

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Configuration de Team Foundation System
Voir aussi
Image de liste déroulante

Indique la configuration système nécessaire relative au matériel et aux logiciels pour installer Team Foundation Server.

  • Team Foundation Server (Single Server)

  • Team Foundation Server (Dual Server)

  • Active Directory Domain Requirement

  • Network Card Settings

  • 64-Bit Operating System Support

  • Software

  • Team Explorer

  • Team Foundation Build

  • Team Foundation Server Proxy

Team Foundation Server (serveur unique)

Les éléments suivants constituent une liste de configuration système requise recommandée pour Team Foundation Server. Vous devez également vérifier que vos ordinateurs répondent aux configurations minimales requises pour les composants requis de Team Foundation Server, comme ceux requis par Microsoft SQL Server 2005 et Windows SharePoint Services.

Attention Attention

Team Foundation Server ne peut pas être installé sur un contrôleur de domaine et ne prend pas en charge l'installation d'autres serveurs, par exemple Exchange Server ou Host Integration Server, sur le même ordinateur.

Déploiement sur un serveur, petite équipe

Pour une utilisation au niveau d'une équipe qui prend en charge 20 utilisateurs ou moins, et pour une évaluation de produit :

Composant | Recommandé
Processeur | Processeur Pentium IV ou Athlon 2,2 GHz
Système d'exploitation | Windows Server 2003 Service Pack 1 (SP1), Enterprise Edition Windows Server 2003 Service Pack 1 (SP1), Standard Edition
RAM | 1 Go
Disque dur | 8 Go d'espace disponible

Déploiement sur un serveur, équipe de taille moyenne

Pour une utilisation au niveau d'une équipe qui prend en charge 50 utilisateurs ou moins :

Composant | Recommandé
Processeur | Processeur Pentium IV ou Athlon 2,2 GHz
Système d'exploitation | Windows Server 2003 Service Pack 1 (SP1), Enterprise Edition Windows Server 2003 Service Pack 1 (SP1), Standard Edition
RAM | 2 Go
Disque dur | 30 Go d'espace disponible

Team Foundation Server (deux serveurs)

Les éléments suivants constituent une liste de configuration système requise recommandée pour Team Foundation Server. Vous devez également vérifier que vos ordinateurs répondent aux configurations minimales requises pour les composants requis de Team Foundation Server, comme ceux requis par Microsoft SQL Server 2005 et Windows SharePoint Services.

Attention Attention

Team Foundation Server ne peut pas être installé sur un contrôleur de domaine et ne prend pas en charge l'installation d'autres serveurs, par exemple Exchange Server ou Host Integration Server, sur le même ordinateur.

Déploiement sur deux serveurs, département

Pour une utilisation au niveau d'un département qui prend en charge 250 utilisateurs ou moins :

Couche Application Team Foundation

Composant | Recommandé
Processeur | Processeur Pentium IV ou Athlon 2,2 GHz
Système d'exploitation | Windows Server 2003 Service Pack 1 (SP1), Enterprise Edition Windows Server 2003 Service Pack 1 (SP1), Standard Edition
RAM | 1 Go
Disque dur | 20 Go d'espace disponible

Couche Données Team Foundation

Composant | Recommandé
Processeur | Biprocesseur Pentium IV ou Athlon 2,2 GHz
Système d'exploitation | Windows Server 2003 Service Pack 1 (SP1), Enterprise Edition Windows Server 2003 Service Pack 1 (SP1), Standard Edition
RAM | 2 Go
Disque dur | 80 Go d'espace disponible

Déploiement sur deux serveurs, division

Pour une utilisation au niveau d'une division qui prend en charge 500 utilisateurs ou moins :

Couche Application Team Foundation

Composant | Recommandé
Processeur | Biprocesseur Pentium IV ou Athlon 2,2 GHz
Système d'exploitation | Windows Server 2003 Service Pack 1 (SP1), Enterprise Edition Windows Server 2003 Service Pack 1 (SP1), Standard Edition
RAM | 2 Go
Disque dur | 40 Go d'espace disponible

Couche Données Team Foundation

Composant | Recommandé
Processeur | Quadriprocesseur Pentium IV ou Athlon 2,2 GHz
Système d'exploitation | Windows Server 2003 Service Pack 1 (SP1), Enterprise Edition Windows Server 2003 Service Pack 1 (SP1), Standard Edition
RAM | 4 Go
Disque dur | 150 Go d'espace disponible

Configuration du domaine Active Directory

Pour installer et configurer Team Foundation Server dans le cadre d'un déploiement sur deux serveurs, vous devez utiliser des ordinateurs qui sont rattachés à un domaine Active Directory. Pour le déploiement sur un seul serveur, vous pouvez utiliser un ordinateur qui est un membre d'un groupe de travail, ou un ordinateur qui est rattaché à un domaine Active Directory. Lors de l'utilisation d'ordinateurs qui sont rattachés à un domaine Active Directory, Team Foundation Server requiert un domaine Active Directory qui ne contient pas de contrôleurs de domaine Windows NT Server 4.0. Utilisez le tableau suivant pour déterminer si Team Foundation Server prend en charge votre niveau fonctionnel de domaine Active Directory.

Niveau fonctionnel de domaine Active Directory | Pris en charge
Mode mixte Windows 2000 - Prend en charge des contrôleurs de domaine qui exécutent Windows NT Server 4.0, Windows 2000 et Windows Server 2003. | Non
Mode natif Windows 2000 - Prend en charge des contrôleurs de domaine qui exécutent Windows 2000 et Windows Server 2003. | Oui
Mode intérimaire Windows Server 2003 - Prend en charge des contrôleurs de domaine qui exécutent Windows NT Server 4.0 et Windows Server 2003. | Non
Mode Windows Server 2003 - Prend en charge des contrôleurs de domaine qui exécutent Windows Server 2003. | Oui

Paramètres de carte réseau

Pendant différentes opérations, Team Foundation Server se connecte aux services et composants appropriés des couches Données, Application et Client. La vitesse à laquelle Team Foundation Server effectue le transfert de grande quantité de données (par exemple, la création de projets d'équipe, le téléchargement de documents de grande taille ou l'archivage de fichiers de grande taille dans le contrôle de code source) dépend en grande partie de la vitesse du réseau.

Si pour de telles opérations, vos performances ne sont pas suffisantes, il se peut que des problèmes de configuration réseau limitent de façon artificielle le débit du système. La configuration des commutateurs de réseau et de la carte réseau de vos ordinateurs (par exemple, si le « mode de détection automatique » ou « négociation automatique » est activé, ou si les informations sont transmises en mode de duplex intégral ou de semi-duplex) peut affecter la vitesse du trafic réseau.

Dans de nombreux cas, la définition du mode de duplex intégral pour la carte réseau et la configuration explicite des cartes pour une exécution à une vitesse fixe (par exemple, 100Mbits/s) plutôt que le mode de détection automatique, peuvent réduire le temps nécessaire au transfert des données. Vérifiez que les paramètres de la carte réseau pour chaque ordinateur sont corrects. Pour plus d'informations, consultez l'article « Résolution des problèmes de connectivité réseau » à l'adresse (http://support.microsoft.com/?scid=kb;EN-US;Q325487).

Prise en charge de système d'exploitation 64 bits

Le tableau suivant représente l'étendue de la prise en charge de système d'exploitation 64 bits par les applications de Team Foundation :

Application Team Foundation | Pris en charge
Team Foundation Server1 | Non
Team Foundation Server (bases de données)2 | Oui
Team Foundation Server (services)2 | Non
Team Foundation Server (proxy) | Non
Team Foundation Server (build) | Non
Team Explorer | Non

1 déploiement de Team Foundation Server sur un seul serveur.

2 déploiement de Team Foundation Server sur deux serveurs.

Logiciel

Team Foundation Server nécessite les logiciels suivants pour que l'installation soit réussie. Pour installer Team Foundation Server, vous devrez être familiarisé avec le logiciel suivant (que vous aurez installé) :

Logiciel serveur | Objet
Microsoft SQL Server 2005 (Standard ou Enterprise Edition) | Base de données principale pour Team Foundation Server et Windows SharePoint Services.
Correctif Microsoft SQL Server 2005 | Met à jour SQL Server Analysis Services pour prendre plus efficacement en charge la création de rapports.
Correctif KB913363 pour .NET Framework 2.0 | Met à jour ASP.NET pour prendre en charge de manière plus efficace la gestion des fichiers volumineux.
Windows SharePoint Services 2.0 avec Service Pack 2 | Héberge des sites portails de projets d'équipes.

Team Foundation Server inclut une copie sous licence de Microsoft SQL Server 2005 Standard Edition pour une utilisation avec Team Foundation Server.

Vous pouvez utiliser Team Explorer avec les logiciels supplémentaires suivants, mais vous n'avez pas à les installer afin d'utiliser Team Explorer. Si vous voulez les utiliser, assurez-vous de les installer avant d'installer Team Explorer.

Logiciel client | Objet
Microsoft Office Excel 2003 | Prend en charge l'intégration facultative de Team Foundation pour le suivi des éléments de travail.
Microsoft Office Project Professionnel 2003 | Prend en charge l'intégration facultative de Team Foundation pour le suivi des éléments de travail.

Pour plus d'informations sur la configuration des logiciels à utiliser avec Team Explorer, consultez Comment : installer les composants requis de Team Explorer.

Vous pouvez utiliser le logiciel complémentaire suivant avec Team Foundation Build. Vous n'avez pas besoin de l'installer afin d'utiliser Team Foundation Build ; cependant, ce logiciel doit être installé sur le même ordinateur que Team Foundation Build afin de pouvoir utiliser certaines fonctionnalités.

Logiciel client | Objet
Team Edition for Developers | Prend en charge l'exécution de l'analyse du code statique.
Team Edition for Testers | Prend en charge l'exécution des tests lors d'une génération.

Team Explorer

La configuration système requise de Team Explorer est la même que la configuration système requise de Visual Studio 2005. Pour plus d'informations, consultez le fichier Lisezmoi de Visual Studio 2005. La configuration matérielle recommandée pour Team Explorer est la suivante :

Composant | Recommandé
Processeur | 2,0 GHz
Système d'exploitation | La configuration requise pour le système d'exploitation de Team Explorer est la même que la configuration requise pour le système d'exploitation de Visual Studio 2005. Pour plus d'informations, consultez le fichier Lisezmoi de Visual Studio 2005.
RAM | 256 Mo
Disque dur | 5 Go d'espace disponible

Team Foundation Build

La configuration logicielle requise de Team Foundation Build est la même que la configuration système requise de Visual Studio 2005, mais la prise en charge est limitée à Windows XP Professionnel avec SP2 et à Windows Server 2003 avec Service Pack 1 (SP1) Standard ou Enterprise Edition. Pour plus d'informations, consultez le fichier Lisezmoi de Visual Studio 2005. La configuration matérielle recommandée pour Team Foundation Build est la suivante :

Petite équipe

Pour l'utilisation avec les projets qui prennent moins de 30 minutes à générer :

Composant | Recommandé
Processeur | 1,5 GHz
Système d'exploitation | Windows Server 2003 Service Pack 1 (SP1), Enterprise Edition Windows Server 2003 Service Pack 1 (SP1), Standard Edition Windows XP Professionnel avec SP2
RAM | 512 Mo

Équipe de taille moyenne

Pour l'utilisation avec des projets qui prennent moins de 2 minutes à générer :

Composant | Recommandé
Processeur | Processeur Pentium IV ou Athlon 2,6 GHz
Système d'exploitation | Windows Server 2003 Service Pack 1 (SP1), Enterprise Edition Windows Server 2003 Service Pack 1 (SP1), Standard Edition Windows XP Professionnel avec SP2
RAM | 1 Go

Grande équipe

Pour une utilisation avec des projets qui prennent plus de 2 heures à générer :

Composant | Recommandé
Processeur | Biprocesseur Pentium IV ou Athlon 2,8 GHz
Système d'exploitation | Windows Server 2003 Service Pack 1 (SP1), Enterprise Edition Windows Server 2003 Service Pack 1 (SP1), Standard Edition Windows XP Professionnel avec SP2
RAM | 2 Go

Proxy Team Foundation Server

La configuration logicielle requise de Team Foundation Server Proxy comprend les services IIS (Internet Information Services), .NET Framework 2.0 et le correctif KB913363. La configuration matérielle recommandée pour Team Foundation Server Proxy est la suivante :

Composant | Recommandé
Processeur | Processeur unique, 2.X GHz
Système d'exploitation | Windows Server 2003 Service Pack 1 (SP1), Enterprise Edition Windows Server 2003 Service Pack 1 (SP1), Standard Edition
RAM | 2 Go

Voir aussi

Tâches

Comment : installer les composants requis de Team Explorer
Comment : installer Team Foundation Server Proxy
Procédure pas à pas : installation du déploiement de Team Foundation Server sur un serveur
Procédure pas à pas : installation du déploiement de Team Foundation Server sur deux serveurs

Référence

Liste de vérification : déploiement sur un serveur de Team Foundation Server
Liste de vérification : déploiement de Team Foundation Server sur deux serveurs
Liste de vérification : déploiement de Team Foundation Server dans un cluster
Liste de vérification : configuration d'une couche Application de secours

Concepts

Installation de Team Foundation
Architecture physique de Team Foundation


Vue d'ensemble de la sécurité de Team Foundation Server pour l'installation

Vue d'ensemble de la sécurité de Team Foundation Server pour l'installation
Voir aussi
DropDown image

Fournit des informations liées à la sécurité pour l'installation de Team Foundation Server.

Dans cette section

Comptes d'utilisateurs requis pour l'installation de Team Foundation Server

Décrit les comptes d'utilisateurs que vous devez créer pour installer et configurer Team Foundation Server.

Ports requis pour l'installation de Team Foundation Server

Fournit des informations à propos des ports que vous devez ouvrir sur les pare-feu existants afin que les composants Team Foundation puissent communiquer entre eux.

Groupes de sécurité de Team Foundation Server

Décrit les groupes de sécurité que Team Foundation Server utilise pour gérer la sécurité.

Comment : ajouter des utilisateurs au groupe d'applications Team Foundation Administrators

Décrit comment ajouter des utilisateurs au groupe Team Foundation Administrators, qui contient des utilisateurs qui peuvent exécuter toutes les opérations Team Foundation privilégiées sur le serveur.

Gestion des rôles de sécurité pour Team Foundation Server

Décrit les rôles de sécurité requis pour Team Foundation Server, y compris Windows SharePoint Services et SQL Server Reporting Services.

Rubriques connexes

Vue d'ensemble du déploiement sur un serveur de Team Foundation Server

Utilisez les procédures de cette section pour installer et configurer Team Foundation Server sur un serveur.

Vue d'ensemble du déploiement de Team Foundation Server sur deux serveurs

Utilisez les procédures de cette section pour installer et configurer Team Foundation Server à l'aide de deux ordinateurs, un pour les composants de la couche Données et un autre pour les composants de la couche Application.

Vue d'ensemble de l'installation de Team Foundation Build

Utilisez les procédures de cette section pour installer et configurer Team Foundation Build, qui fournit l'automation de la génération pour vous aider à générer et partager les solutions Visual Studio 2005.

Vue d'ensemble de l'installation de Team Foundation Server Proxy

Utilisez les procédures de cette section pour installer Team Foundation Server Proxy, qui met en cache les fichiers du contrôle de code source auxquels vous avez précédemment accédé.

Vue d'ensemble de l'installation de Team Explorer

Utilisez les procédures de cette section pour installer et configurer Team Explorer.

Voir aussi

Concepts

Installation de Team Foundation


Comptes d'utilisateurs requis pour l'installation de Team Foundation Server

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Comptes d'utilisateurs requis pour l'installation de Team Foundation Server
Voir aussi
Image de liste déroulante

Décrit les comptes d'utilisateurs nécessaires pour installer et configurer Team Foundation Server.

Considérations sur le déploiement

Les impératifs de compte d'utilisateur varient en fonction du modèle de déploiement : un ou deux serveurs. Dans un déploiement sur un serveur, vous avez l'option d'utiliser des comptes d'utilisateurs de domaine Active Directory ou des comptes d'utilisateurs locaux.

Déploiement sur un serveur

Pour installer et configurer Team Foundation Server via un déploiement sur un seul serveur sur un ordinateur rattaché à un domaine Active Directory, vous aurez besoin de trois comptes d'utilisateurs de domaine Active Directory, comme indiqué dans le tableau ci-dessous.

Pour installer et configurer Team Foundation Server via un déploiement sur un seul serveur sur un ordinateur qui est membre d'un groupe de travail, vous pouvez utiliser des comptes d'utilisateurs locaux. Si vous installez Team Foundation Server en utilisant des comptes d'utilisateurs locaux pour exécuter le programme d'installation et les services, vous ne pouvez pas ajouter des comptes d'utilisateurs de domaine à Team Foundation Server et la création de projets est impossible. Ces comptes d'utilisateurs doivent être des comptes d'utilisateurs de domaine, mais les comptes d'utilisateurs locaux sont autorisés.

Déploiement sur deux serveurs

Pour installer et configurer Team Foundation Server via un déploiement sur deux serveurs, les deux ordinateurs doivent être rattachés à un domaine Active Directory et vous aurez besoin de trois comptes d'utilisateurs de domaine Active Directory, comme indiqué dans le tableau ci-dessous.

Comptes requis

Avant d'installer Team Foundation Server, vous devez identifier les comptes que vous allez utiliser pendant l'installation. Ce guide d'installation fait référence à ces comptes par un nom d'espace réservé comme indiqué dans le tableau. Si vous voulez utiliser des noms de connexions d'utilisateurs différents, ou si vous avez des comptes existants que vous pouvez utiliser, veillez à remplacer le nom approprié correctement pendant l'installation.

Exemple de nom de connexion d'utilisateur Fonction

TFSSETUP

  • Sert à exécuter le programme d'installation de Team Foundation Server.

  • Ce compte doit être administrateur sur les ordinateurs Team Foundation Server.

  • Ce compte doit être membre du même domaine que les deux comptes de service suivants. Par exemple, vous ne pouvez pas avoir les deux comptes de service dans un domaine et utiliser un compte local pour exécuter le programme d'installation.

TFSSERVICE

  • Utilisé comme compte de service par les services Windows de Team Foundation Server (services d'analyse de couverture du code et Planificateur de serveur TFS) et service du minuteur SharePoint.

  • Utilisé comme identité de pool d'applications par le pool d'applications de Team Foundation Server (VSTF AppPool) et les pools d'applications Windows SharePoint Services (TFWSS et WSS_AppPool).

  • Doit disposer de l'autorisation d'ouverture d'une session locale sur les ordinateurs Team Foundation Server.

  • Pour une sécurité optimale, ce compte de service :

    • Ne doit pas être administrateur sur les ordinateurs Team Foundation Server.

    • Doit avoir l'option Le compte est sensible et ne peut pas être délégué sélectionnée pour Active Directory sur le domaine.

TFSREPORTS

  • Utilisé comme compte de service par les sources de données SQL Server Reporting Services.

  • Ce compte doit être administrateur sur les ordinateurs Team Foundation Server.

  • Ce compte doit disposer de l'autorisation d'ouverture d'une session locale sur les ordinateurs Team Foundation Server.

TFSPROXY

  • Utilisé par Team Foundation Server Proxy sur un ordinateur qui n'est pas membre du même domaine que les composants de la couche Application et de la couche Données Team Foundation Server.

  • Ce compte de service doit être membre du groupe Administrateurs sur l'ordinateur distant.

  • Ce compte de service doit être membre du groupe Team Foundation Valid Users pour l'ordinateur Team Foundation Server qui utilise le proxy.

Pour plus d'informations, consultez Comptes d'utilisateurs requis pour l'installation de Team Foundation Server.

Voir aussi

Tâches

Comment : installer les composants requis de Team Explorer
Comment : installer Team Foundation Server Proxy
Procédure pas à pas : installation du déploiement de Team Foundation Server sur un serveur
Procédure pas à pas : installation du déploiement de Team Foundation Server sur deux serveurs

Référence

Liste de vérification : déploiement sur un serveur de Team Foundation Server
Liste de vérification : déploiement de Team Foundation Server sur deux serveurs
Liste de vérification : déploiement de Team Foundation Server dans un cluster
Liste de vérification : configuration d'une couche Application de secours

Concepts

Installation de Team Foundation

Autres ressources

Vue d'ensemble de la sécurité de Team Foundation Server pour l'installation


Ports requis pour l'installation de Team Foundation Server

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Ports requis pour l'installation de Team Foundation Server
Voir aussi
Image de liste déroulante

Fournit des informations à propos des ports TCP que vous devez ouvrir sur les pare-feu existants afin que les composants de Team Foundation puissent communiquer entre eux.

Ports Requis

Pour activer la communication entre Team Foundation Server, ses composants requis et ses clients, vous devez faire en sorte que tous les pare-feu situés entre ces composants autorisent la communication via un certain nombre de ports TCP.

Remarque Remarque

Les Assistants Installation de Team Foundation Server et de SQL Server ajouteront automatiquement des exceptions pour les ports TCP requis lors de l'exécution des instances du Pare-feu Windows. Si le Pare-feu Windows ne s'exécute pas, ou s'il est configuré de façon à ne pas autoriser d'exceptions, les exceptions ne seront pas ajoutées.

Ports requis pour SQL Server 2005

Microsoft SQL Server 2005 (Developer, Standard ou Enterprise Edition) utilise les ports TCP suivants :

Contexte de service ou de l'application | Port TCP
SQL Server Reporting Services | 80
Service SQL | 1433
Service SQL Browser | 1434
SQL Monitoring | 1444
SQL Server Analysis Service Redirector | 2382
SQL Server Analysis Service | 2383

Ports requis pour Windows SharePoint Services

Windows SharePoint Services utilise les ports TCP suivants :

Contexte de service ou de l'application | Port TCP
Windows SharePoint Services | 80
Administration centrale de SharePoint | 17012

Ports requis pour Team Foundation Server

Team Foundation Server utilise les ports TCP suivants :

Contexte de service ou de l'application | Port TCP
Team Foundation Server | 8080
Team Foundation Server Proxy | 8081
Team Foundation Build Remoting1 | 9191

Portée

Dans le Pare-feu Windows, vous pouvez spécifier le jeu d'ordinateurs pour lequel un port ou un service est débloqué. Par défaut, la portée a la valeur N'importe quel ordinateur (y compris ceux présents sur Internet). Si vous choisissez de limiter la portée pour laquelle un port ou un service est débloqué, faites en sorte que tous les ordinateurs qui doivent accéder à ce port ou à ce service figurent dans la portée spécifiée.

Voir aussi

Tâches

Comment : installer les composants requis de Team Explorer
Comment : installer Team Foundation Server Proxy
Procédure pas à pas : installation du déploiement de Team Foundation Server sur un serveur
Procédure pas à pas : installation du déploiement de Team Foundation Server sur deux serveurs

Référence

Liste de vérification : déploiement sur un serveur de Team Foundation Server
Liste de vérification : déploiement de Team Foundation Server sur deux serveurs
Liste de vérification : déploiement de Team Foundation Server dans un cluster
Liste de vérification : configuration d'une couche Application de secours

Autres ressources

Vue d'ensemble de la sécurité de Team Foundation Server pour l'installation


Groupes de sécurité de Team Foundation Server
Image de liste déroulante

Décrit les groupes de sécurité que Team Foundation Server utilise pour gérer la sécurité.

Groupes de sécurité de Team Foundation Server

la sécurité de Team Foundation Server est gérée par les groupes de sécurité de Team Foundation Server, qui ne sont pas les mêmes que les groupes de sécurité locaux ou domaine Windows.

Groupe de sécurité de Team Foundation Server Description

Team Foundation Administrators

  • Ce groupe contient des utilisateurs qui peuvent exécuter toutes les opérations privilégiées sur le serveur.

  • Par défaut, l'installation ajoute le compte utilisé pour exécuter le programme d'installation (par exemple, Domaine\TFSSETUP) à ce groupe.

Service Accounts

  • Ce groupe contient des comptes de service de Team Foundation Server, tels que les identités de pool d'applications pour les services Web de Team Foundation Server (par exemple, Domaine\TFSSERVICE).

Team Foundation Valid Users

  • Ce groupe contient tous les utilisateurs et les groupes qui ont accès au serveur.

Le programme d'installation de Team Foundation Server ajoute le compte d'utilisateur utilisé pour exécuter le programme d'installation (par exemple, Domaine\TFSSETUP) au groupe Team Foundation Administrators. Pour ajouter d'autres utilisateurs à ce groupe, vous devez utiliser un compte qui est déjà membre de Team Foundation Administrators. Au terme de l'installation, vous devrez vous connecter en réutilisant le compte utilisé pour exécuter le programme d'installation (par exemple, Domaine\TFSSETUP) pour ajouter les nouveaux membres initiaux au groupe Team Foundation Administrators.

Le programme d'installation de Team Foundation Server ajoute également le compte de service Team Foundation Server (par exemple, Domaine\TFSSERVICE) au groupe Service Accounts.

Voir aussi

Tâches

Comment : ajouter des utilisateurs au groupe d'applications Team Foundation Administrators

Concepts

Installation de Team Foundation

Autres ressources

Vue d'ensemble de la sécurité de Team Foundation Server pour l'installation


Comment : ajouter des utilisateurs au groupe d'applications Team Foundation Administrators

Comment : ajouter des utilisateurs au groupe d'applications Team Foundation Administrators
Voir aussi

La sécurité de Team Foundation Server est gérée par les groupes de sécurité de Team Foundation Server qui sont différents des groupes de sécurité locaux ou de domaine Windows. Le groupe Team Foundation Administrators contient des utilisateurs qui peuvent exécuter toutes les opérations privilégiées de Team Foundation sur le serveur.

Remarque Remarque

Le compte d'utilisateur utilisé pour exécuter l'installation de Team Foundation Server (par exemple, Domaine\TFSSETUP) est ajouté automatiquement au groupe Team Foundation Administrators. Pour ajouter d'autres utilisateurs à ce groupe, vous devez utiliser un compte qui est déjà un membre de ce groupe de sécurité (par exemple, Domaine\TFSSETUP).

Pour permettre aux utilisateurs de créer des projets, vous devez les ajouter à ce groupe et les assigner à des rôles dans Windows SharePoint Services et SQL Server Reporting Services. Vous pouvez utiliser Team Explorer ou l'utilitaire en ligne de commande TFSSecurity.

Pour ajouter un utilisateur au groupe de sécurité Team Foundation Administrators à l'aide de l'Explorateur d'équipes

  1. Ouvrez une session sur l'ordinateur de la couche cliente à l'aide des informations d'identification d'un compte d'utilisateur qui est déjà un membre du groupe de sécurité Team Foundation Administrators (par exemple, Domaine\TFSSETUP).

  2. Installez Team Explorer. Pour plus d'informations, consultez Vue d'ensemble de l'installation de Team Explorer.

  3. Démarrez Visual Studio et connectez-vous à Team Foundation Server. Pour plus d'informations, consultez Comment : connecter Team Explorer à Team Foundation Server.

  4. Dans l'Explorateur d'équipes, sélectionnez le serveur Team Foundation Server à gérer.

  5. Dans le menu Équipe, pointez sur Paramètres Team Foundation Server, puis cliquez sur Appartenance au groupe.

  6. Dans la boîte de dialogue Groupes globaux, sélectionnez le groupe auquel vous souhaitez ajouter des utilisateurs, puis cliquez sur Propriétés.

  7. Sous l'onglet Membres de la boîte de dialogue Propriétés du groupe Team Foundation Server, sélectionnez Utilisateur ou groupe Windows, puis cliquez sur Ajouter.

  8. Dans la boîte de dialogue Sélectionner les utilisateurs ou les groupes, entrez le nom de domaine et le nom d'utilisateur des utilisateurs que vous souhaitez ajouter au format suivant :

    domain\username

    Pour ajouter plusieurs utilisateurs à la fois, séparez les entrées par un point-virgule (;).

  9. Cliquez sur OK.

Pour ajouter un utilisateur au groupe de sécurité Team Foundation Administrators à l'aide de l'utilitaire en ligne de commande de la sécurité de Team Foundation (TFSSecurity.EXE)

  1. Ouvrez une session sur l'ordinateur de la couche Application à l'aide des informations d'identification d'un compte d'utilisateur qui est déjà un membre du groupe de sécurité Team Foundation Administrators (par exemple, Domaine\TFSSETUP).

  2. Dans l'Explorateur Windows, recherchez le répertoire Tools dans le dossier d'installation de Team Foundation Server.

    Par défaut, le chemin d'accès est <lecteur>:\Program Files\Microsoft Visual Studio 2005 Team Foundation Server\Tools.

  3. Dans le menu Démarrer, cliquez sur Tous les programmes, puis sur Invite de commandes.

  4. Dans la fenêtre d'invite de commandes, ajoutez un utilisateur au groupe Team Foundation Administrators à l'aide de l'option /g+ de l'utilitaire en ligne de commande TFSSecurity.

    Vous devez définir les spécificateurs d'identité suivants et désigner le serveur Team Foundation Server.

    • Adm indique que l'utilisateur est ajouté au groupe global des administrateurs.

    • n désigne le domaine et le compte d'utilisateur à ajouter.

    • /server désigne le serveur Team Foundation Server de la couche Application.

    Par exemple, la commande suivante ajoute le compte de l'utilisateur Dieter Zilch qui figure dans le domaine ADATUM au serveur Team Foundation Server connecté à un ordinateur local à l'aide de la couche Application.

    TFSSecurity /g+ adm: n:ADATUM\DZilch /server:http://localhost:8080

Création de projets d'équipe par les utilisateurs

Pour créer des projets d'équipe, les utilisateurs doivent également recevoir des rôles dans SQL Server Reporting Services et Windows Server SharePoint Services. Ci-dessous figure l'emplacement où les assignations sont effectuées. Pour plus d'informations sur l'utilisation des pages, consultez le Guide d'administration Team Foundation Server ou utilisez l'aide fournie sur la page.

Pour assigner les utilisateurs à des rôles dans d'autres composants

  1. Ajoutez les utilisateurs au rôle Administrateur pour Windows SharePoint Services à l'adresse http://<application-tier>/_layouts/1033/user.aspx.

  2. Ajoutez les utilisateurs au rôle Gestionnaire de contenu pour SQL Server Reporting Services en utilisant la page d'accueil SQL Server Reporting Services située à l'adresse http://<application-tier>/Reports.

Sécurité

Pour effectuer cette procédure, vous devez être membre du groupe Team Foundation Administrators ou disposer de l'autorisation Modifier les informations au niveau du serveur avec la valeur Autoriser. Le compte d'utilisateur employé pour installer Team Foundation Server est automatiquement ajouté à ce groupe et en mesure d'ajouter des utilisateurs au cours de l'installation. Pour plus d'informations, consultez « Autorisations de Team Foundation Server » dans le Guide de l'administrateur Team Foundation Server (http://go.microsoft.com/fwlink/?linkid=52459).

Voir aussi

Concepts

Installation de Team Foundation
Comptes d'utilisateurs requis pour l'installation de Team Foundation Server
Groupes de sécurité de Team Foundation Server


Gestion des rôles de sécurité pour Team Foundation Server

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Gestion des rôles de sécurité pour Team Foundation Server
Voir aussi
Image de liste déroulante

Décrit les rôles de sécurité requis pour Team Foundation Server, y compris Windows SharePoint Services et SQL Server Reporting Services.

Appartenance au rôle de sécurité

Lorsque vous ajoutez un compte d'utilisateur à un rôle de sécurité Team Foundation Server, vous devez également ajouter cet utilisateur au rôle de sécurité approprié dans Windows SharePoint Services et SQL Server Reporting Services.

Pour créer un nouveau projet d'équipe dans Team Foundation Server, vous devez être un membre du groupe Team Foundation Administrators, un membre du rôle Administrateur Windows SharePoint Services et un membre du rôle Gestionnaire de contenu SQL Server Reporting Services. Le tableau suivant indique l'appartenance au rôle de sécurité approprié dans chacun de ces produits pour les groupes de sécurité globaux dans Team Foundation Server.

Groupe de sécurité de Team Foundation Server | Rôle Windows SharePoint Services | Rôle SQL Server Reporting Services
[Serveur]\Team Foundation Administrators | Administrateur (site de niveau supérieur) | Gestionnaire de contenu (rôle de niveau système)
[Serveur]\Team Foundation Valid Users | n/a1 | n/a1
[Serveur]\Service Accounts | n/a2 | n/a2

1Le groupe Team Foundation Valid Users contient tous les utilisateurs et les groupes qui ont accès au serveur. Ce groupe contient tous les utilisateurs et les groupes qui sont membres des projets d'équipe qui existent sur le serveur. Il n'est pas nécessaire de gérer l'appartenance de ce groupe.

2Les comptes dans le groupe Service Accounts ne nécessitent pas d'appartenance aux rôles de sécurité sur Windows SharePoint Services ou SQL Server Reporting Services.

Après avoir créé un projet d'équipe, vous assignez les utilisateurs à différents rôles afin de gérer leurs autorisations sur une base par projet. Les sites Windows SharePoint Services n'héritent pas des paramètres de sécurité du site de niveau supérieur. Inversement, la sécurité de niveau élément de SQL Server Reporting Services hérite des rôles de niveau système. Le tableau suivant indique l'appartenance au rôle de sécurité approprié dans chacun de ces produits pour les groupes de sécurité de niveau projet dans Team Foundation Server.

Groupe de sécurité de Team Foundation Server | Rôle Windows SharePoint Services | Rôle SQL Server Reporting Services
[NomProjet]\Project Administrators1 | Administrateur | Gestionnaire de contenu
[NomProjet]\Contributor1 | Collaborateur | Lecteur
[NomProjet]\Reader1 | Lecteur | Lecteur

1Ce nom est dérivé du modèle de processus MSF for Agile Software Development. Le nom réel des groupes de sécurité de niveau projet variera selon le modèle de processus choisi.

Les procédures pour gérer l'appartenance aux rôles de sécurité dans Windows SharePoint Services et SQL Server Reporting Services se trouvent la documentation qui accompagne chaque produit.

Voir aussi

Concepts

Installation de Team Foundation


Procédures pas à pas relatives à l'installation de Team Foundation

Procédures pas à pas relatives à l'installation de Team Foundation
DropDown image

Les procédures pas à pas suivantes vous permettent d'afficher les procédures d'installation dans une seule rubrique en fonction de votre choix de déploiement. Ces procédures pas à pas portent uniquement sur la configuration des bases de données et des services de couche Application. Pour plus d'informations sur l'installation des composants de la couche cliente de Team Foundation, consultez les liens de la section « Rubriques connexes ».

Dans cette section

Procédure pas à pas : installation du déploiement de Team Foundation Server sur un serveur

Décrit le processus d'installation des couches Application et Données sur un seul ordinateur.

Liste de vérification : déploiement sur un serveur de Team Foundation Server

Fournit une liste de vérification à utiliser comme référence pratique pendant le déploiement de Team Foundation Server sur un serveur.

Procédure pas à pas : installation du déploiement de Team Foundation Server sur deux serveurs

Décrit le processus d'installation de la couche Données sur un ordinateur et de la couche Application sur un autre ordinateur.

Liste de vérification : déploiement de Team Foundation Server sur deux serveurs

Fournit une liste de vérification à utiliser comme référence pratique pendant le déploiement de Team Foundation Server sur deux serveurs.

Référence

Configuration de Team Foundation System

Comptes d'utilisateurs requis pour l'installation de Team Foundation Server

Ports requis pour l'installation de Team Foundation Server

Rubriques connexes

Vue d'ensemble de l'installation de Team Foundation Build

Vue d'ensemble de l'installation de Team Foundation Server Proxy

Vue d'ensemble de l'installation de Team Explorer


Procédure pas à pas : installation du déploiement de Team Foundation Server sur deux serveurs

 Image de liste déroulante Image de pointage sur liste déroulante Image de réduction Image de développement Image Réduire tout Image Développer tout Copier l'image de pointage
Visual Studio Team System
Procédure pas à pas : installation du déploiement de Team Foundation Server sur deux serveurs
Voir aussi
Image Réduire tout Image de liste déroulante

Vous pouvez utiliser cette procédure pas à pas pour configurer les composants serveur pour Team Foundation Server sur deux ordinateurs.

Image de développement Composants requis

Vous avez besoin des informations et équipements suivants afin d'effectuer l'installation.

  • Version imprimée de Liste de vérification : déploiement de Team Foundation Server sur deux serveurs.

  • Deux ordinateurs qui répondent à la configuration matérielle et logicielle requise pour la taille de votre équipe. Pour plus d'informations, consultez Configuration de Team Foundation System.

  • Deux comptes de service pour Team Foundation Server. Pour plus d'informations, consultez Comptes d'utilisateurs requis pour l'installation de Team Foundation Server.

  • Compte d'utilisateur permettant de terminer l'installation qui est membre du groupe de sécurité Administrateurs sur les deux ordinateurs.

Image de développement Récapitulatif des procédures

Pour installer les composants de la couche Données

  1. Installez Microsoft SQL Server 2005 Standard Edition ou Enterprise Edition à l'aide du fichier de réponses sur le support d'installation.

  2. Installez le correctif pour Microsoft SQL Server 2005, activez, puis redémarrez le service SQL Browser.

  3. Installez Team Foundation Server (bases de données).

Pour installer les services de couche Application

  1. Installez les services IIS (Internet Information Services), ASP.NET étant activé.

  2. Installer SQL Server 2005 Reporting Services

  3. Installez le correctif pour Microsoft .NET Framework 2.0.

  4. Installez Windows SharePoint Services avec Service Pack 2.

  5. Installez Team Foundation Server (services).

Image de développement Installation de Microsoft SQL Server 2005 sur la couche Données

Après avoir obtenu les composants requis, vous pouvez installer Microsoft SQL Server 2005 Standard ou Enterprise Edition.

Pour installer Microsoft SQL Server 2005 de façon interactive

  1. Sur l'ordinateur de couche Données, ouvrez une session Windows à l'aide du compte utilisé pour l'installation de Team Foundation Server (par exemple, Domaine\TFSSETUP).

  2. Insérez le CD-ROM pour Microsoft SQL Server 2005 et, sous Installer à la page Démarrage de SQL Server 2005, cliquez sur Composants serveur, documentation en ligne et exemples.

    Remarque Remarque

    Le CD-ROM de Microsoft SQL Server 2005 Standard Edition est disponible avec Team Foundation Server. Pour installer Microsoft SQL Server 2005 Enterprise Edition, vous pouvez utiliser le CD-ROM du logiciel que vous avez acheté séparément. La page de démarrage est disponible en exécutant le fichier Splash.hta situé dans le dossier Servers du support d'installation.

    L'Assistant Installation de Microsoft SQL Server 2005 démarre.

  3. À la page Contrat de Licence Utilisateur Final, passez en revue le contrat de licence. Si vous acceptez les termes et conditions mentionnés, sélectionnez J'accepte les termes et conditions du contrat de licence, puis cliquez sur Suivant.

  4. À la page Installation de la configuration requise, cliquez sur Installer. Une fois les composants requis correctement installés, cliquez sur Suivant.

    L'Assistant Installation de Microsoft SQL Server démarre.

  5. Cliquez sur Suivant pour démarrer l'analyse de la configuration système.

  6. Sur la page Analyse de la configuration système, examinez l'état de toutes les actions requises, par exemple les redémarrages du système requis, et suivez les consignes qui figurent sur cette page jusqu'à ce que toutes les actions obtiennent l'état Opérations réussies. Une fois que vous avez obtenu l'état Succès pour toutes les actions à l'exception de Fonctionnalité IIS requise, cliquez sur Suivant pour démarrer l'installation.

    Remarque Remarque

    SQL Server 2005 Reporting Services n'est pas installé sur l'ordinateur de couche Données. Vous pouvez ignorer en toute sécurité l'état Avertissement pour Fonctionnalité IIS requise. Le démarrage du programme d'installation peut prendre un certain temps.

  7. À la page Informations d'inscription, complétez les informations d'inscription, puis cliquez sur Suivant.

  8. Sur la page Composants à installer, sélectionnez les composants suivants, puis cliquez sur Avancé.

    • SQL Server Database Services

    • Analysis Services

    • Integration Services

    • Composants de la station de travail, documentation en ligne et outils de développement

      Remarque Remarque

      Reporting Services doit être installé sur la couche Application. Team Foundation Server ne nécessite pas Notification Services.

  9. Sur la page Sélection de composant, développez les nœuds ci-après et spécifiez les options suivantes.

    Remarque Remarque

    En dehors des cas indiqués dans cette section, vous ne devez pas modifier les sélections par défaut dans les autres zones de fonctionnalités.

    1. Sous Services de base de données, cliquez sur l'icône de Réplication et sélectionnez Ce composant ne sera pas disponible.

      Remarque Remarque

      Si vous voulez spécifier un autre emplacement pour les fichiers de données, sélectionnez Fichiers de données, puis cliquez sur Parcourir pour spécifier un répertoire ou un disque dur physique différent. Par défaut, SQL Server 2005 installe tous les fichiers sur le lecteur système. Vous pouvez optimiser les performances du système en utilisant un emplacement distinct. Vous pouvez effectuer la même opération pour Fichiers de données sous Analysis Services.

    2. Sous Composants clients, le seul composant à installer obligatoirement est Outils de gestion. Pour tous les autres éléments sous Composants clients, vous pouvez cliquer le cas échéant sur l'icône et sélectionner Ce composant ne sera pas disponible.

    3. Sous Documentation, Exemples et Exemples de bases de données, vous pouvez cliquer le cas échéant sur l'icône Documentation en ligne puis sélectionner Ce composant ne sera pas disponible. Cliquez sur Next.

  10. À la page Nom de l'instance, sélectionnez Instance par défaut, puis cliquez sur Suivant.

    Remarque Important

    L'installation de Team Foundation Server échoue si vous spécifiez une instance nommée.

  11. Sur la page Compte de service, sélectionnez Utiliser le compte système par défaut, puis Système local dans la liste. Dans Démarrer les services une fois l'installation terminée, sélectionnez tous les services : SQL Server, SQL Server Agent, Analysis Services et SQL Browser, puis cliquez sur Suivant.

    Remarque Remarque

    Ce compte de service est associé à Microsoft SQL Server 2005 et ne doit pas être confondu avec les deux comptes de service que vous avez obtenus avant de commencer l'installation.

  12. Sur la page Mode d'authentification, sélectionnez Mode d'authentification Windows, puis cliquez sur Suivant.

  13. Sur la page Paramètres de classement, sélectionnez le classement approprié à votre langue, puis cliquez sur Suivant.

    Remarque Remarque

    Si vous modifiez Indicateur de classement et Ordre de tri, vous devez sélectionner Respecter les accents.

    La sélection par défaut est basée sur le paramètre du langage non-Unicode dans Windows Server 2003. Le classement Windows est le classement par défaut pour la plupart des langues ; toutefois, pour l'anglais des États-Unis, SQL Server 2005 est installé avec un classement SQL Server pour des raisons de compatibilité descendante. Si vous souhaitez modifier le classement par défaut afin que d'autres caractères anglais des États-Unis soient pris en charge, envisagez d'utiliser Latin1_General.

    Pour les autres langues, envisagez d'utiliser un classement Windows « _90 » si celui-ci est disponible, sinon utilisez un autre classement Windows.

    Par exemple, pour les déploiements japonais, employez le classement Japanese_90 à la place du classement par défaut si vous utilisez les blocs de caractères Extension A CJC Unicode ou les substituts Unicode comme indiqué ci-après.

    • Noms d'objets Team Foundation Server, tels que Requêtes ou Projets.

    • Fichiers ou chemins d'accès qui sont vérifiés dans le système de contrôle de version.

    • Tout champ des éléments de travail utilisé pour les recherches.

    Pour éviter tout problème avec les caractères à double largeur ou Hiragana/Katakana équivalents, lors de l'installation, activez les cases à cocher pour activer le respect des caractères Kana et de la largeur.

    Team Foundation Server ne prend pas en charge les classements suivants :

    • Non-respect des accents

    • Binary

    • Binary2

    • Respecter la casse

    Pour plus d'informations sur les paramètres de classement, consultez « Collation Settings in Setup » (Paramètres de classement lors de l'installation) dans la documentation en ligne de SQL Server 2005.

  14. À la page Paramètres de rapports d'erreurs et d'utilisation, vous pouvez éventuellement sélectionner Envoyer des rapports d'erreurs pour SQL Server 2005 à Microsoft ou votre serveur de rapports d'erreurs d'entreprise et Envoyer automatiquement des données d'utilisation des fonctionnalités de SQL Server 2005 à Microsoft, puis cliquer sur Suivant.

  15. À la page Prêt pour l'installation, vous pouvez passer en revue la liste des composants à installer, puis cliquer sur Installer.

  16. À la page Installation en cours, vous pouvez contrôler l'état de l'installation de chaque composant. Une fois l'installation terminée, cliquez sur Suivant.

    Remarque Remarque

    L'installation peut sembler bloquée pendant plusieurs minutes pendant l'activation de SQL Server Reporting Services.

  17. Cliquez sur Terminer pour quitter l'Assistant.

    Remarque Remarque

    Pour vérifier votre installation avant d'installer Team Foundation Server, consultez Comment : vérifier l'installation de Microsoft SQL Server 2005.

Image de développement Installation du correctif pour Microsoft SQL Server 2005

Après avoir installé Microsoft SQL Server 2005, vous devez installer le correctif de mise à jour de SQL Server Analysis Services qui prend plus efficacement en charge la création de rapports.

Remarque Remarque

Pour obtenir les mises à jour les plus récentes, visitez le site Web de Microsoft (http://go.microsoft.com/fwlink/?LinkId=62015).

Pour installer le correctif pour Microsoft SQL Server 2005

  1. Sur l'ordinateur de couche Données, ouvrez le Gestionnaire de configuration SQL Server, cliquez avec le bouton droit sur Service SQL Server Browser, puis cliquez sur Arrêter.

  2. Sur le support d'installation de Team Foundation Server, recherchez le dossier SQLServerKB.

  3. Recherchez le fichier exécutable (.exe) pour vos système d'exploitation et langue, par exemple AS2005-KBnnnnnn-x86-ENU.exe, puis double-cliquez sur le fichier pour démarrer le programme d'installation du correctif.

  4. Dans Programme d'installation de correctifs, acceptez le Contrat de Licence Utilisateur Final, terminez la procédure pour installer le correctif, puis cliquez sur Terminer.

  5. Dans Gestionnaire de configuration SQL Server, cliquez avec le bouton droit sur Service SQL Server Browser, puis cliquez sur Propriétés.

  6. Sous l'onglet Service, recherchez Mode de démarrage et sélectionnez Automatique.

  7. Sous l'onglet Ouvrir une session, cliquez sur Démarrer.

    Remarque Remarque

    Si Démarrer n'est pas activité sous l'onglet Ouvrir une session, cliquez sur l'onglet Service, définissez Mode de démarrage à Désactivé, puis sélectionnez de nouveau Automatique pour mettre à jour explicitement le Mode de démarrage.

Pour vérifier votre installation avant d'installer Windows SharePoint Services, consultez Comment : vérifier l'installation de Microsoft SQL Server 2005.

Image de développement Installation des bases de données Team Foundation Server

Avant d'installer Team Foundation Server, assurez-vous que Microsoft SQL Server 2005 Standard Edition ou Enterprise Edition est installé et en cours d'exécution. Pour plus d'informations, consultez Liste de vérification : déploiement de Team Foundation Server sur deux serveurs.

Pour installer Team Foundation Server (bases de données)

  1. Ouvrez une session Windows à l'aide du compte que vous avez utilisé pour l'installation de Team Foundation Server (par exemple, Domaine\TFSSETUP) et identifié lors de l'utilisation de la liste de vérification.

  2. Insérez le support d'installation de Team Foundation Server et, à la page d'exécution automatique, cliquez sur Installez Team Foundation Server, sur Installation sur deux serveurs, puis sur Installez UNIQUEMENT la couche de base de données de Team Foundation.

    Si la page d'exécution automatique ne s'affiche pas, localisez et exécutez le fichier d'exécution automatique (autorun.exe) situé dans le dossier racine du support d'installation.

    L'Assistant Installation de Visual Studio 2005 Team Foundation Server (bases de données) démarre.

  3. À la page Bienvenue dans le programme d'installation, cliquez sur Suivant.

  4. Sur la page Termes de Licence, examinez le contrat de licence. Si vous acceptez les termes et conditions mentionnés, sélectionnez J'accepte les termes du contrat de licence, puis cliquez sur Suivant.

  5. À la page Dossier de destination, cliquez sur Suivant.

  6. Sur la page Vérification de la santé du système, examinez les avertissements ou blocs éventuels en cliquant sur le lien de rapport.

    • Les blocs doivent être traités avant de pouvoir poursuivre l'installation. Cliquez sur Annuler et réexécutez le programme d'installation après avoir corrigé les problèmes.

    • Les avertissements doivent être traités avant de continuer, mais ne doivent pas empêcher le déroulement de l'installation. Vous pouvez cliquer sur Suivant.

      Par exemple, si aucun pare-feu n'est activé, un avertissement apparaît dans la liste. Vous pouvez continuer l'installation, mais il est possible que vous deviez ajouter manuellement les ports et exceptions nécessaires à l'activation des communications entre les composants.

    • Si rien n'est répertorié, cliquez sur Suivant.

  7. À la page Prêt pour l'installation, cliquez sur Installer.

  8. Sur la page Installation des composants, surveillez l'installation des composants de la couche Données de Team Foundation.

    Pendant l'installation, vous pouvez être invité à redémarrer l'ordinateur. Cliquez sur Redémarrer maintenant. L'installation reprend après le redémarrage de l'ordinateur et vous ouvrez une nouvelle session à l'aide du même compte.

  9. À la page L'installation s'est terminée avec succès, cliquez sur Terminer.

  10. Sur la page d'exécution automatique, cliquez sur Quitter.

Pour afficher les bases de données Team Foundation Server

  1. Cliquez sur Démarrer, sur Program Files, sur Microsoft SQL Server 2005, puis sur SQL Server Management Studio.

  2. Dans la boîte de dialogue Se connecter au serveur, sélectionnez Moteur de base de données dans Type de serveur, tapez le nom du serveur auquel vous souhaitez vous connecter, puis cliquez sur Se connecter.

    Remarque Remarque

    Si SQL Server est installé sur un cluster, le nom du serveur est le nom du cluster et non de l'ordinateur.

  3. Dans l'Explorateur d'objets, développez Bases de données et vérifiez que les bases de données Team Foundation Server existent.

Image de développement Configuration de la couche Application en tant que serveur d'applications

Votre ordinateur de couche Application doit déjà être configuré en tant que serveur d'applications. Si le composant Windows, à savoir les services IIS (Internet Information Services), est déjà configuré, vérifiez qu'ASP.NET est activé ; si tel n'est pas le cas, activez-le. Sinon, suivez cette procédure pour installer IIS et activer ASP.NET.

Pour activer ASP.NET à l'aide de l'utilitaire Ajout/Suppression de programmes

  1. Dans le Panneau de configuration, ouvrez Ajout/Suppression de programmes.

  2. Cliquez sur Ajouter/Supprimer des composants Windows.

    L'Assistant Composants de Windows démarre.

  3. À la page Composants Windows, sélectionnez Serveur d'applications, puis cliquez sur Détails.

  4. Le cas échéant, sélectionnez ASP.NET, puis cliquez sur OK.

    Remarque Important

    Ne sélectionnez pas Extensions serveur FrontPage 2002 n'importe quand. Ce serveur héberge Windows SharePoint Services, qui est incompatible avec les extensions serveur FrontPage.

  5. À la page Composants Windows, cliquez sur Suivant.

    Remarque Remarque

    Votre support d'installation de Windows Server 2003 peut vous être demandé.

  6. Cliquez sur Terminer pour fermer l'Assistant.

  7. Visitez le site Windows Update (http://windowsupdate.microsoft.com) et installez tous les éléments du groupe Critical Updates and Service Packs.

Image de développement Installation de SQL Server Reporting Services

Après avoir activé ASP.NET, installez SQL Server 2005 Reporting Services (à l'aide de Microsoft SQL Server 2005 Standard ou Enterprise Edition) pour une utilisation avec Team Foundation Server.

Pour installer Microsoft SQL Server 2005 Reporting Services

  1. Sur l'ordinateur de couche Application, ouvrez une session Windows à l'aide du compte utilisé pour l'installation de Team Foundation Server (par exemple, Domaine\TFSSETUP).

  2. Insérez le CD-ROM pour Microsoft SQL Server 2005 et, sous Installer à la page Démarrage de SQL Server 2005, cliquez sur Composants serveur, documentation en ligne et exemples.

    Remarque Remarque

    Le CD-ROM de Microsoft SQL Server 2005 Standard Edition est disponible avec Team Foundation Server. Pour installer SQL Server Enterprise Edition, vous pouvez utiliser le CD-ROM du logiciel que vous avez acheté séparément. La page de démarrage est disponible en exécutant le fichier Splash.hta situé dans le dossier Servers du support d'installation.

    L'Assistant Installation de Microsoft SQL Server 2005 démarre.

  3. À la page Contrat de Licence Utilisateur Final, passez en revue le contrat de licence. Si vous acceptez les termes et conditions mentionnés, sélectionnez J'accepte les termes et conditions du contrat de licence, puis cliquez sur Suivant.

  4. À la page Installation de la configuration requise, cliquez sur Installer. Une fois les composants requis correctement installés, cliquez sur Suivant.

    L'Assistant Installation de Microsoft SQL Server démarre.

  5. Cliquez sur Suivant pour démarrer l'analyse de la configuration système.

  6. Sur la page Analyse de la configuration système, examinez l'état de toutes les actions requises, par exemple les redémarrages du système requis, et suivez les consignes qui figurent sur cette page jusqu'à ce que toutes les actions obtiennent l'état Opérations réussies. Une fois que toutes les actions ont obtenu l'état Succès, cliquez sur Suivant pour démarrer l'installation.

    Remarque Remarque

    Le démarrage du programme d'installation peut prendre un certain temps.

  7. À la page Informations d'inscription, complétez les informations d'inscription, puis cliquez sur Suivant.

  8. À la page Composants à installer, sélectionnez Reporting Services, puis cliquez sur Suivant.

    Remarque Remarque

    Si vous cliquez sur Avancé, ne supprimez aucune sélection par défaut.

  9. À la page Nom de l'instance, sélectionnez Instance par défaut, puis cliquez sur Suivant.

    Remarque Important

    L'installation de Team Foundation Server échouera si vous spécifiez une instance nommée.

  10. Sur la page Compte de service, sélectionnez Utiliser le compte système par défaut, puis Service réseau dans la liste. Dans Démarrer les services une fois l'installation terminée, sélectionnez Reporting Services, puis cliquez sur Suivant.

  11. Sur la page Options d'installation du serveur de rapports, cliquez sur Suivant.

    Par défaut, l'option Installer mais ne pas configurer le serveur est sélectionnée.

  12. À la page Paramètres de rapports d'erreurs et d'utilisation, vous pouvez éventuellement sélectionner Envoyer des rapports d'erreurs pour SQL Server 2005 à Microsoft ou votre serveur de rapports d'erreurs d'entreprise et Envoyer automatiquement des données d'utilisation des fonctionnalités de SQL Server 2005 à Microsoft, puis cliquer sur Suivant.

  13. À la page Prêt pour l'installation, vous pouvez passer en revue la liste des composants à installer, puis cliquer sur Installer.

  14. À la page Installation en cours, vous pouvez contrôler l'état de l'installation de chaque composant. Une fois l'installation terminée, cliquez sur Suivant.

    Remarque Remarque

    L'installation peut sembler bloquée pendant plusieurs minutes pendant l'activation de SQL Server Reporting Services.

  15. Cliquez sur Terminer pour quitter l'Assistant.

Attention Attention

N'utilisez pas l'outil de configuration de Reporting Services pour vérifier que les services fonctionnent. L'Assistant Installation de Team Foundation Server configure Reporting Services pour vous et l'ouverture de l'outil peut interrompre l'installation.

Image de développement Vérification de l'installation de Reporting Services

Après l'installation, vérifiez que les services fonctionnent et sont configurés pour démarrer automatiquement.

Pour vérifier l'installation

  1. Cliquez sur Démarrer, sur Outils d'administration, puis sur Services.

  2. Dans la colonne Nom du Gestionnaire des services, recherchez SQL Server Reporting Services et vérifiez que l'option État a la valeur Démarré et que le Type de démarrage est Automatique.

    Remarque Remarque

    Vous pouvez modifier l'état ou le type de démarrage en cliquant avec le bouton droit sur le service, en cliquant sur Propriétés, puis en apportant les modifications.

  3. Fermez le Gestionnaire des services.

Image de développement Installation du correctif pour Microsoft .NET Framework 2.0

Après avoir installé Microsoft SQL Server 2005 Reporting Services, vous devez installer le correctif de mise à jour d'ASP.NET pour prendre en charge de manière plus efficace la gestion des fichiers volumineux.

Remarque Remarque

Vous pouvez naviguer sur le Web à la recherche des dernières mises à jour de Team Foundation Server.

Pour installer le correctif pour Microsoft .NET Framework 2.0

  1. Sur l'ordinateur de couche Application, recherchez le dossier KB913393 sur le support d'installation de Team Foundation Server.

  2. Recherchez le fichier exécutable (.exe) pour votre système d'exploitation (X86), puis double-cliquez sur le fichier à installer.

Image de développement Installation de Windows SharePoint Services

Après avoir installé le correctif, vous devez installer Microsoft Windows SharePoint Services avec Service Pack 2 pour Team Foundation Server.

Remarque Important

Windows SharePoint Services nécessite un système de fichiers NTFS.

Pour installer Windows SharePoint Services de façon interactive

  1. Sur l'ordinateur de couche Application, ouvrez une session Windows à l'aide du compte utilisé pour l'installation de Team Foundation Server (par exemple, Domaine\TFSSETUP).

  2. Téléchargez Microsoft Windows SharePoint Services avec Service Pack 2 (http://go.microsoft.com/fwlink/?linkid=55087) et enregistrez le fichier sur le disque dur local.

  3. Exécutez le fichier d'installation à exécution automatique téléchargé (stsv2.exe).

  4. À la page Contrat de Licence Utilisateur Final, prenez connaissance du contrat de licence. Si vous acceptez les termes et conditions mentionnés, sélectionnez J'accepte les termes du contrat de licence, puis cliquez sur Suivant.

  5. À la page Type d'instance, sélectionnez Batterie de serveurs, puis cliquez sur Suivant.

    Remarque Important

    Vous devez installer Windows SharePoint Services à l'aide de l'option Batterie de serveurs. Windows SharePoint Services est ainsi configuré pour utiliser un serveur SQL Server distant. Plus tard, le programme d'installation de Team Foundation Server configure Windows SharePoint Services pour utiliser la même instance de SQL Server que le reste de Team Foundation Server.

  6. À la page Résumé, cliquez sur Installer.

    Lorsque l'installation est terminée, une fenêtre de navigateur Web s'ouvre et affiche la page Configurer le serveur virtuel d'administration Après avoir confirmé que la page apparaît, fermez la fenêtre du navigateur sans apporter de modifications.

    Remarque Important

    N'apportez pas de modifications sur la page qui apparaît. Plus tard, le programme d'installation de Team Foundation Server configure Windows SharePoint Services pour utiliser la même instance de SQL Server que le reste de Team Foundation Server.

    Si la page n'apparaît pas, vous devez déterminer la cause et résoudre le problème à l'aide du Guide de l'administrateur Windows SharePoint Services (http://go.microsoft.com/fwlink/?LinkId=52668).

  7. Visitez le site Windows Update (http://windowsupdate.microsoft.com) et installez tous les éléments du groupe Critical Updates and Service Packs.

  8. Redémarrez l'ordinateur.

Pour vérifier que Windows SharePoint Services est installé

  • Ouvrez Internet Explorer et tapez le nom de serveur en tant qu'adresse.

    Par exemple, pour un serveur nommé ADATUM, vous tapez Http://adatum.

    Même si un site n'est pas configuré, le serveur est un serveur Web actif et propose une page En construction.

Image de développement Installation de Team Foundation Server (services)

Après avoir installé tous les composants associés, vous pouvez installer les composants Team Foundation Server de la couche Application.

Remarque Remarque

Si vous installez Team Foundation Server sur une version localisée de Windows SharePoint Services, vous devez d'abord installer le module de prise en charge linguistique de Windows SharePoint Services qui correspond à la langue de Team Foundation Server. Par exemple, si vous projetez d'installer une version localisée de Windows SharePoint Services et la version anglaise de Team Foundation Server, vous devez installer le module de prise en charge linguistique en anglais de Windows SharePoint Services avant d'installer Team Foundation Server.

Pour installer Team Foundation Server (services)

  1. Sur l'ordinateur de couche Application, ouvrez une session Windows à l'aide du compte utilisé pour l'installation de Team Foundation Server (par exemple, Domaine\TFSSETUP).

  2. Insérez le CD-ROM et, à la page d'exécution automatique, cliquez sur Installez Team Foundation Server, sur Installation sur deux serveurs, puis sur Installez UNIQUEMENT la couche d'application de Team Foundation.

    Si la page d'exécution automatique ne s'affiche pas, localisez et exécutez le fichier d'exécution automatique (autorun.exe) situé dans le dossier racine du support d'installation.

    L'Assistant Installation de Visual Studio Team Foundation Server (services) démarre.

  3. À la page Bienvenue dans le programme d'installation, cliquez sur Suivant.

  4. Sur la page Termes de Licence, examinez le contrat de licence. Si vous acceptez les termes et conditions mentionnés, sélectionnez J'accepte les termes du contrat de licence, puis cliquez sur Suivant.

    L'Assistant Installation analyse votre système à la recherche de conditions qui peuvent provoquer l'échec de l'installation ou des problèmes par la suite lors du fonctionnement du serveur.

  5. À la page Dossier de destination et serveur de base de données, tapez les informations suivantes :

    • Dans la zone Dossier de destination, tapez le chemin d'installation ou acceptez la valeur par défaut.

    • Dans la zone Serveur de base de données, tapez le nom de l'ordinateur sur lequel vous avez installé Team Foundation Server (bases de données).

      Remarque Remarque

      Vous devez utiliser le nom de l'ordinateur, et non pas l'adresse IP.

  6. Sur la page Vérification de la santé du système, examinez les avertissements ou blocs éventuels en cliquant sur le lien de rapport.

    • Les blocs doivent être traités avant de pouvoir poursuivre l'installation. Cliquez sur Annuler et réexécutez le programme d'installation après avoir corrigé les problèmes.

    • Les avertissements doivent être traités avant de continuer, mais ne doivent pas empêcher le déroulement de l'installation. Vous pouvez cliquer sur Suivant.

    • Si rien n'est répertorié, cliquez sur Suivant.

  7. À la page Compte de service, entrez les informations sur le compte pour le compte de service Team Foundation Server (par exemple,Domaine\TFSSERVICE), puis cliquez sur Suivant.

  8. À la page Compte d'ouverture de session de création de rapports, entrez les informations sur le compte pour le compte de rapports de Team Foundation Server (par exemple,Domaine\TFSREPORTS), puis cliquez sur Suivant.

    Remarque Remarque

    Ce compte ne doit pas être le même que les comptes de service ou d'installation de Team Foundation Server.

  9. À la page Alertes Team Foundation, tapez les informations suivantes :

    1. Dans la zone Serveur SMTP, tapez le nom du serveur que vous utiliserez pour envoyer des alertes Team Foundation.

    2. Dans la zone Adresse de messagerie De, tapez le nom de l'adresse de messagerie pour l'envoi des alertes Team Foundation, puis cliquez sur Suivant.

      Remarque Remarque

      Si vous voulez activer les alertes à ce stade, vous devez connaître le serveur SMTP de votre organisation. Team Foundation Server ne nécessite aucun paramètre de configuration spécifique pour un accès à SMTP uniquement. L'installation et la configuration de SMTP ne sont pas traitées dans cette documentation. Pour plus d'informations, consultez la documentation de Windows Server 2003.

  10. À la page Prêt pour l'installation, cliquez sur Installer.

    Pendant l'installation, vous pouvez être invité à redémarrer l'ordinateur. Cliquez sur Redémarrer maintenant pour que l'installation reprenne après le redémarrage de l'ordinateur et l'ouverture d'une nouvelle session.

  11. À la page L'installation s'est terminée avec succès, cliquez sur Terminer.

  12. Dans Internet Explorer, recherchez http://localhost:8080/services/v1.0/Registration.asmx, puis cliquez sur GetRegistrationEntries.

  13. Sur la page GetRegistrationEntries, cliquez sur Appeler. Vous n'avez pas à entrer de ToolID.

    Remarque Remarque

    Pour utiliser cette méthode Web, vous devez vous trouver sur l'ordinateur de couche Application.

  14. Dans le document XML, vérifiez que le type VSTF se présente comme illustré ici, puis fermez.

    <?xml version="1.0" encoding="utf-8" ?>

    <Type>vstfs</Type>

Image de développement Étapes suivantes

Après avoir installé Team Foundation Server, vous devez permettre à d'autres utilisateurs d'administrer et de créer des projets d'équipe. Pour plus d'informations, consultez Comment : ajouter des utilisateurs au groupe d'applications Team Foundation Administrators.

Une fois les composants Team Foundation Server installés et en cours d'exécution, vous pouvez installer les autres composants Team Foundation suivants.

  • Explorateur d'équipes

  • Team Foundation Build

  • Proxy Team Foundation Server

Les suggestions suivantes ne sont pas obligatoires pour la création de projets d'équipe, mais font partie des méthodes conseillées pour la gestion de Team Foundation Server.

  • Vous devez sauvegarder la clé de chiffrement de Reporting Services à l'aide de l'outil de configuration de Reporting Services. Pour plus d'informations, consultez « Comment : sauvegarder la clé de chiffrement de Reporting Services » dans le Guide de l'administrateur Team Foundation Server.

  • Vous devez configurer des plans de maintenance de la base de données et planifier des sauvegardes complètes et incrémentielles.

Image de développement Voir aussi

Autres ressources

Vue d'ensemble de l'installation de Team Foundation Build
Vue d'ensemble de l'installation de Team Foundation Server Proxy
Vue d'ensemble de l'installation de Team Explorer


Procédure pas à pas : installation du déploiement de Team Foundation Server sur un serveur

 Image de liste déroulante Image de pointage sur liste déroulante Image de réduction Image de développement Image Réduire tout Image Développer tout Copier l'image de pointage
Visual Studio Team System
Procédure pas à pas : installation du déploiement de Team Foundation Server sur un serveur
Voir aussi
Image Réduire tout Image de liste déroulante

Vous pouvez utiliser cette procédure pas à pas pour configurer les composants serveur pour Team Foundation Server sur un seul ordinateur.

Image de développement Composants requis

Vous avez besoin des informations et équipements suivants afin d'effectuer l'installation.

  • Version imprimée de Liste de vérification : déploiement sur un serveur de Team Foundation Server.

  • Ordinateur qui répond à la configuration matérielle et logicielle requise pour la taille de votre équipe. Pour plus d'informations, consultez Configuration de Team Foundation System.

  • Deux comptes de service pour Team Foundation Server. Pour plus d'informations, consultez Comptes d'utilisateurs requis pour l'installation de Team Foundation Server. Microsoft SQL Server 2005 nécessite également un compte de service, mais vous pouvez utiliser les comptes intégrés.

  • Compte d'utilisateur permettant de terminer l'installation qui est membre du groupe de sécurité Administrateurs sur les deux ordinateurs.

Image de développement Récapitulatif des procédures d'installation

Pour installer les composants de la couche Données

  1. Installez les services IIS (Internet Information Services), ASP.NET étant activé.

  2. Installez Microsoft SQL Server 2005 Standard Edition ou Enterprise Edition à l'aide du fichier de réponses sur le support d'installation.

  3. Installez le correctif pour Microsoft SQL Server 2005, activez, puis redémarrez le service SQL Browser.

  4. Installez le correctif pour Microsoft .NET Framework 2.0.

  5. Installez Windows SharePoint Services 2.0 avec Service Pack 2.

  6. Installez Team Foundation Server (services).

Image de développement Installation des services IIS (Internet Information Services).

Votre ordinateur de couche Application doit déjà être configuré en tant que serveur d'applications. Si le composant Windows, à savoir les services IIS (Internet Information Services), est déjà configuré, vérifiez qu'ASP.NET est activé ; si tel n'est pas le cas, activez-le. Sinon, suivez cette procédure pour installer IIS et activer ASP.NET.

Pour installer les services IIS à l'aide de l'utilitaire Ajout/Suppression de programmes

  1. Dans le Panneau de configuration, ouvrez Ajout/Suppression de programmes.

  2. Cliquez sur Ajouter/Supprimer des composants Windows.

    L'Assistant Composants de Windows démarre.

  3. À la page Composants Windows, sélectionnez Serveur d'applications, puis cliquez sur Détails.

  4. Le cas échéant, sélectionnez ASP.NET, puis cliquez sur OK.

    Remarque Important

    Si vous sélectionnez Internet Information Services (IIS), puis cliquez sur Détails, ne sélectionnez pas Extensions serveur FrontPage 2002. Ce serveur héberge Windows SharePoint Services, qui est incompatible avec les extensions serveur FrontPage.

  5. À la page Composants Windows, cliquez sur Suivant.

    Remarque Remarque

    Votre support d'installation de Windows Server 2003 peut vous être demandé.

  6. Cliquez sur Terminer pour fermer l'Assistant.

  7. Visitez le site Windows Update (http://windowsupdate.microsoft.com) et installez tous les éléments du groupe Critical Updates and Service Packs.

Utilisez cette procédure pour installer et configurer de façon interactive Microsoft SQL Server 2005 Standard ou Enterprise Edition pour Team Foundation Server à l'aide de l'Assistant Installation, ou à l'aide d'un fichier de réponses.

Image de développement Installation de Microsoft SQL Server 2005

Après avoir obtenu les composants requis, vous pouvez installer Microsoft SQL Server 2005 Standard ou Enterprise Edition. Team Foundation Server inclut une copie sous licence de Microsoft SQL Server 2005 Standard Edition.

Pour installer Microsoft SQL Server 2005 de façon interactive

  1. Ouvrez une session Windows à l'aide du compte utilisé pour l'installation de Team Foundation Server (par exemple, Domaine\TFSSETUP).

  2. Insérez le CD-ROM pour Microsoft SQL Server 2005 et, sous Installer à la page Démarrage de SQL Server 2005, cliquez sur Composants serveur, documentation en ligne et exemples.

    Remarque Remarque

    Le CD-ROM de Microsoft SQL Server 2005 Standard Edition est disponible avec Team Foundation Server. Pour installer SQL Server Enterprise Edition, vous pouvez utiliser le CD-ROM du logiciel que vous avez acheté séparément. La page de démarrage est disponible en exécutant le fichier Splash.hta situé dans le dossier Servers du support d'installation.

    L'Assistant Installation de Microsoft SQL Server 2005 démarre.

  3. À la page Contrat de Licence Utilisateur Final, passez en revue le contrat de licence. Si vous acceptez les termes et conditions mentionnés, sélectionnez J'accepte les termes et conditions du contrat de licence, puis cliquez sur Suivant.

  4. À la page Installation de la configuration requise, cliquez sur Installer. Une fois les composants requis correctement installés, cliquez sur Suivant.

    L'Assistant Installation de Microsoft SQL Server démarre.

  5. Cliquez sur Suivant pour démarrer l'analyse de la configuration système.

  6. Sur la page Analyse de la configuration système, examinez l'état de toutes les actions requises, par exemple les redémarrages du système requis, et suivez les consignes qui figurent sur cette page jusqu'à ce que toutes les actions obtiennent l'état Opérations réussies. Une fois que toutes les actions ont obtenu l'état Succès, cliquez sur Suivant pour démarrer l'installation.

    Remarque Remarque

    Le démarrage du programme d'installation peut prendre un certain temps.

  7. À la page Informations d'inscription, complétez les informations d'inscription, puis cliquez sur Suivant.

  8. Sur la page Composants à installer, sélectionnez les composants suivants, puis cliquez sur Avancé.

    • SQL Server Database Services

    • Analysis Services

    • Integration Services

    • Reporting Services

    • Composants de la station de travail, documentation en ligne et outils de développement

      Remarque Remarque

      Team Foundation Server ne nécessite pas Notification Services.

  9. Sur la page Sélection de composant, développez les nœuds ci-après et spécifiez les options suivantes.

    Remarque Remarque

    En dehors des cas indiqués dans cette section, vous ne devez pas modifier les sélections par défaut dans les autres zones de fonctionnalités.

    1. Sous Services de base de données, cliquez sur l'icône de Réplication et sélectionnez Ce composant ne sera pas disponible.

      Remarque Remarque

      Pour optimiser les performances système, sélectionnez Fichiers de données et cliquez sur Parcourir pour spécifier un emplacement de fichier sur un disque dur physique différent. Par défaut, SQL Server 2005 installe tous les fichiers sur le lecteur système. Vous pouvez effectuer la même opération pour Fichiers de données sous Analysis Services.

    2. Sous Composants clients, le seul composant à installer obligatoirement est Outils de gestion. Pour tous les autres éléments sous Composants clients, vous pouvez cliquer le cas échéant sur l'icône et sélectionner Ce composant ne sera pas disponible.

    3. Sous Documentation, Exemples et Exemples de bases de données, vous pouvez cliquer le cas échéant sur l'icône Documentation en ligne, puis sélectionner Ce composant ne sera pas disponible. Cliquez sur Suivant.

  10. À la page Nom de l'instance, sélectionnez Instance par défaut, puis cliquez sur Suivant.

    Remarque Important

    L'installation de Team Foundation Server échoue si vous spécifiez une instance nommée.

  11. Sur la page Compte de service, sélectionnez Utiliser le compte système par défaut et dans la liste sélectionnez Système local. Dans Démarrer les services une fois l'installation terminée, sélectionnez tous les services : SQL Server, SQL Server Agent, Analysis Services, Reporting Services et SQL Browser, puis cliquez sur Suivant.

    Remarque Remarque

    Le compte de service est associé à Microsoft SQL Server 2005 et ne doit pas être confondu avec les deux comptes de service que vous avez obtenus avant de commencer l'installation.

  12. Sur la page Mode d'authentification, sélectionnez Mode d'authentification Windows, puis cliquez sur Suivant.

  13. Sur la page Paramètres de classement, sélectionnez le classement approprié à votre langue, puis cliquez sur Suivant.

    Remarque Remarque

    Si vous modifiez Indicateur de classement et ordre de tri, vous devez sélectionner Respecter les accents.

    La sélection par défaut est basée sur le paramètre du langage non-Unicode dans Windows Server 2003. Le classement Windows est le classement par défaut pour la plupart des langues ; toutefois, pour l'anglais des États-Unis, SQL Server 2005 est installé avec un classement SQL Server pour des raisons de compatibilité descendante. Si vous souhaitez modifier le classement par défaut afin que d'autres caractères anglais des États-Unis soient pris en charge, envisagez d'utiliser Latin1_General.

    Pour les autres langues, envisagez d'utiliser un classement Windows « _90 » si celui-ci est disponible, sinon utilisez un autre classement Windows.

    Par exemple, pour les déploiements japonais, employez le classement Japanese_90 à la place du classement par défaut si vous utilisez les blocs de caractères Extension A CJC Unicode ou les substituts Unicode comme indiqué ci-après :

    • Noms d'objets Team Foundation Server, tels que Requêtes ou Projets.

    • Fichiers ou chemins d'accès qui sont vérifiés dans le système de contrôle de version.

    • Tout champ des éléments de travail utilisé pour les recherches.

    Pour éviter tout problème avec les caractères à double largeur ou Hiragana/Katakana équivalents, lors de l'installation, activez les cases à cocher pour activer le respect des caractères Kana et de la largeur.

    Team Foundation Server ne prend pas en charge les classements suivants :

    • Non-respect des accents

    • Binary

    • Binary2

    • Respecter la casse

    Pour plus d'informations sur les paramètres de classement, consultez « Collation Settings in Setup » (Paramètres de classement lors de l'installation) dans la documentation en ligne de SQL Server 2005.

  14. À la page Options d'installation du serveur de rapports, sélectionnez Installer la configuration par défaut, puis cliquez sur Suivant.

  15. À la page Paramètres de rapports d'erreurs et d'utilisation, vous pouvez éventuellement sélectionner Envoyer des rapports d'erreurs pour SQL Server 2005 à Microsoft ou votre serveur de rapports d'erreurs d'entreprise et Envoyer automatiquement des données d'utilisation des fonctionnalités de SQL Server 2005 à Microsoft, puis cliquer sur Suivant.

  16. À la page Prêt pour l'installation, vous pouvez passer en revue la liste des composants à installer, puis cliquer sur Installer.

  17. À la page Installation en cours, vous pouvez contrôler l'état de l'installation de chaque composant. Une fois l'installation terminée, cliquez sur Suivant.

    Remarque Remarque

    L'installation peut sembler bloquée pendant plusieurs minutes pendant l'activation de SQL Server Reporting Services.

  18. Cliquez sur Terminer pour quitter l'Assistant.

Image de développement Installation du correctif pour Microsoft SQL Server 2005

Après avoir installé Microsoft SQL Server 2005, vous devez installer le correctif de mise à jour de SQL Server Analysis Services qui prend plus efficacement en charge la création de rapports.

Remarque Remarque

Pour obtenir les mises à jour les plus récentes, visitez le site Web de Microsoft (http://go.microsoft.com/fwlink/?LinkId=62015).

Pour installer le correctif pour Microsoft SQL Server 2005

  1. Sur l'ordinateur de couche Données, ouvrez le Gestionnaire de configuration SQL Server, cliquez avec le bouton droit sur Service SQL Server Browser, puis cliquez sur Arrêter.

  2. Sur le support d'installation de Team Foundation Server, recherchez le dossier SQLServerKB.

  3. Recherchez le fichier exécutable (.exe) pour vos système d'exploitation et langue, par exemple AS2005-KBnnnnnn-x86-ENU.exe, puis double-cliquez sur le fichier pour démarrer le programme d'installation du correctif.

  4. Dans Programme d'installation de correctifs, acceptez le Contrat de Licence Utilisateur Final, terminez la procédure pour installer le correctif, puis cliquez sur Terminer.

  5. Dans Gestionnaire de configuration SQL Server, cliquez avec le bouton droit sur Service SQL Server Browser, puis cliquez sur Propriétés.

  6. Sous l'onglet Service, recherchez Mode de démarrage et sélectionnez Automatique.

  7. Sous l'onglet Ouvrir une session, cliquez sur Démarrer.

    Remarque Remarque

    Si Démarrer n'est pas activité sous l'onglet Ouvrir une session, cliquez sur l'onglet Service, définissez Mode de démarrage à Désactivé, puis sélectionnez de nouveau Automatique pour mettre à jour explicitement le Mode de démarrage.

Pour vérifier votre installation avant d'installer Windows SharePoint Services, consultez Comment : vérifier l'installation de Microsoft SQL Server 2005.

Image de développement Installation du correctif pour Microsoft .NET Framework 2.0

Vous devez installer le correctif de mise à jour d'ASP.NET pour prendre en charge de manière plus efficace la gestion des fichiers volumineux.

Remarque Remarque

Vous pouvez naviguer sur le Web à la recherche des dernières mises à jour de Team Foundation Server.

Pour installer le correctif pour Microsoft .NET Framework 2.0

  1. Sur l'ordinateur de couche Application, recherchez le dossier KB913393 sur le support d'installation de Team Foundation Server.

  2. Recherchez le fichier exécutable (.exe) pour votre système d'exploitation (X86), puis double-cliquez sur le fichier à installer.

Image de développement Installation de Microsoft Windows SharePoint Services

Procédez comme suit pour installer Microsoft Windows SharePoint Services avec Service Pack 2 pour Team Foundation Server pour qu'il utilise de façon interactive l'Assistant Installation ou qu'il s'exécute en mode silencieux à partir de la ligne de commande.

Remarque Important

Windows SharePoint Services nécessite un système de fichiers NTFS.

Pour installer Windows SharePoint Services de façon interactive

  1. Ouvrez une session Windows à l'aide du compte utilisé pour l'installation de Team Foundation Server (par exemple, Domaine\TFSSETUP).

  2. Téléchargez Microsoft Windows SharePoint Services avec Service Pack 2 (http://go.microsoft.com/fwlink/?linkid=55087) et enregistrez le fichier sur le disque dur local.

  3. Exécutez le fichier d'installation à exécution automatique téléchargé (stsv2.exe).

  4. À la page Contrat de Licence Utilisateur Final, prenez connaissance du contrat de licence. Si vous acceptez les termes et conditions mentionnés, sélectionnez J'accepte les termes du contrat de licence, puis cliquez sur Suivant.

  5. À la page Type d'instance, sélectionnez Batterie de serveurs, puis cliquez sur Suivant.

    Remarque Important

    Vous devez installer Windows SharePoint Services à l'aide de l'option Batterie de serveurs. Windows SharePoint Services est ainsi configuré pour utiliser un serveur SQL Server distant. Plus tard, le programme d'installation de Team Foundation Server configure Windows SharePoint Services pour utiliser la même instance de SQL Server que le reste de Team Foundation Server.

  6. À la page Résumé, cliquez sur Installer.

    Lorsque l'installation est terminée, une fenêtre de navigateur Web s'ouvre et affiche la page Configurer le serveur virtuel d'administration. Après avoir confirmé que la page apparaît, fermez la fenêtre du navigateur sans apporter de modifications.

    Remarque Important

    N'apportez pas de modifications sur la page qui apparaît. Plus tard, le programme d'installation de Team Foundation Server configure Windows SharePoint Services pour utiliser la même instance de SQL Server que le reste de Team Foundation Server.

    Si la page n'apparaît pas, vous devez déterminer la cause et résoudre le problème à l'aide du Guide de l'administrateur Windows SharePoint Services (http://go.microsoft.com/fwlink/?LinkId=52668).

  7. Visitez le site Windows Update (http://windowsupdate.microsoft.com) et installez tous les éléments du groupe Critical Updates and Service Packs.

  8. Redémarrez l'ordinateur.

Image de développement Vérification de l'installation de Windows SharePoint Services

Après avoir installé Windows SharePoint Services, vous pouvez vous assurer que les services fonctionnent même si vous n'avez pas installé Team Foundation Server.

Pour vérifier que Windows SharePoint Services est installé

  • Ouvrez Internet Explorer et tapez le nom de serveur en tant qu'adresse.

    Par exemple, pour un serveur nommé ADATUM, vous tapez Http://adatum.

    Même si un site n'est pas configuré, le serveur est un serveur Web actif et propose une page En construction.

    Remarque Remarque

    Avant d'installer Team Foundation Server sur une version localisée de Windows SharePoint Services, vous devez installer le module de prise en charge linguistique de Windows SharePoint Services qui correspond à la langue de Team Foundation Server. Par exemple, si vous projetez d'installer une version localisée de Windows SharePoint Services et la version anglaise de Team Foundation Server, vous devez installer le module de prise en charge linguistique en anglais de Windows SharePoint Services avant d'installer Team Foundation Server.

Image de développement Installation de Team Foundation Server

Après avoir installé tous les composants associés, vous pouvez installer Team Foundation Server.

Pour installer Team Foundation Server

  1. Ouvrez une session Windows à l'aide du compte utilisé pour l'installation de Team Foundation Server (par exemple, Domaine\TFSSETUP).

  2. Insérez le CD-ROM et, lorsque la page d'exécution automatique s'affiche, cliquez sur Installez Team Foundation Server , puis sur Installation sur un serveur.

    Si la page d'exécution automatique ne s'affiche pas, localisez et exécutez le fichier d'exécution automatique (autorun.exe) situé dans le dossier racine du support d'installation.

    L'Assistant Installation de Visual Studio Team Foundation Server démarre.

  3. À la page Bienvenue dans le programme d'installation, cliquez sur Suivant.

  4. Sur la page Termes de Licence, examinez les termes. Si vous acceptez les termes et conditions mentionnés, sélectionnez J'accepte les termes du contrat de licence, puis cliquez sur Suivant.

    L'Assistant Installation analyse votre système à la recherche de conditions qui peuvent provoquer l'échec de l'installation ou des problèmes par la suite lors du fonctionnement du serveur.

  5. Sur la page Dossier de destination, acceptez le dossier de destination par défaut, puis cliquez sur Suivant.

  6. Sur la page Vérification de la santé du système, examinez les avertissements ou blocs éventuels en cliquant sur le lien de rapport.

    • Les blocs doivent être traités avant de pouvoir poursuivre l'installation. Cliquez sur Annuler et réexécutez le programme d'installation après avoir corrigé les problèmes.

    • Les avertissements doivent être traités avant de continuer, mais ne doivent pas empêcher le déroulement de l'installation. Vous pouvez cliquer sur Suivant.

    • Si rien n'est répertorié, cliquez sur Suivant.

  7. À la page Compte d'ouverture de session du service, tapez le compte d'utilisateur de domaine Windows que vous avez créé pour le compte de service Team Foundation Server (par exemple, Domaine\TFSSERVICE) dans la zone Nom du compte, tapez le mot de passe dans la zone Mot de passe, puis cliquez sur Suivant. Pour plus d'informations, consultez Comptes d'utilisateurs requis pour l'installation de Team Foundation Server.

  8. Sur la page Compte d'ouverture de session de création de rapports, tapez les informations sur le compte de rapports de Team Foundation Server, puis cliquez sur Suivant.

    Remarque Remarque

    Ce compte doit être différent des comptes de service ou utilisé pour l'installation de Team Foundation Server. Par exemple, utilisez Domaine\TFSREPORTS.

  9. À la page Spécifier les paramètres d'alerte, sélectionnez Activer les alertes Team Foundation, et tapez les informations suivantes :

    • Dans la zone Serveur SMTP, tapez le nom du serveur que vous utiliserez pour envoyer des notifications par courrier électronique.

    • Dans la zone Adresse de messagerie De, tapez le nom de l'adresse de messagerie à partir de laquelle les notifications semblent venir, puis cliquez sur Suivant.

  10. À la page Prêt pour l'installation, cliquez sur Installer.

  11. À la page Installation des composants, vous pouvez surveiller l'installation de Team Foundation Server.

    Pendant l'installation, vous pouvez être invité à redémarrer l'ordinateur. Cliquez sur Redémarrer maintenant pour que l'installation reprenne après le redémarrage de l'ordinateur et l'ouverture d'une nouvelle session.

  12. Sur la page L'installation s'est terminée avec succès, vérifiez que l'installation est terminée, puis cliquez sur Terminer.

    Après avoir installé Team Foundation Server, vous devez sauvegarder la clé de chiffrement de Reporting Services à l'aide de l'outil de configuration de Reporting Services. Cette étape n'est pas obligatoire pour la création de projets d'équipe, mais fait partie des méthodes conseillées pour la gestion de Team Foundation Server. Pour plus d'informations, consultez « Comment : sauvegarder la clé de chiffrement de Reporting Services » dans le Guide de l'administrateur Team Foundation Server (http://go.microsoft.com/fwlink/?LinkID=52459).

  13. Dans Internet Explorer, recherchez http://localhost:8080/services/v1.0/Registration.asmx, puis cliquez sur GetRegistrationEntries.

  14. Sur la page GetRegistrationEntries, cliquez sur Appeler. Vous n'avez pas à entrer de ToolID.

    Remarque Remarque

    Pour utiliser cette méthode Web, vous devez vous trouver sur l'ordinateur de couche Application.

  15. Dans le document XML, vérifiez que le type VSTF existe, puis fermez. Par exemple :

    <?xml version="1.0" encoding="utf-8" ?>

    <Type>vstfs</Type>

Image de développement Étapes suivantes

Après avoir installé Team Foundation Server, vous devez permettre à d'autres utilisateurs d'administrer et de créer des projets d'équipe. Pour plus d'informations, consultez Comment : ajouter des utilisateurs au groupe d'applications Team Foundation Administrators.

Une fois les composants Team Foundation Server installés et en cours d'exécution, vous pouvez installer les autres composants Team Foundation suivants.

  • Explorateur d'équipes

  • Team Foundation Build

  • Proxy Team Foundation Server

Les suggestions suivantes ne sont pas obligatoires pour la création de projets d'équipe, mais font partie des méthodes conseillées pour la gestion de Team Foundation Server.

  • Vous devez sauvegarder la clé de chiffrement de Reporting Services à l'aide de l'outil de configuration de Reporting Services. Pour plus d'informations, consultez « Comment : sauvegarder la clé de chiffrement de Reporting Services » dans le Guide de l'administrateur Team Foundation Server.

  • Vous devez configurer des plans de maintenance de la base de données et planifier des sauvegardes complètes et incrémentielles.

Image de développement Voir aussi

Autres ressources

Vue d'ensemble de l'installation de Team Foundation Build
Vue d'ensemble de l'installation de Team Foundation Server Proxy
Vue d'ensemble de l'installation de Team Explorer


Vue d'ensemble du déploiement sur un serveur de Team Foundation Server

Vue d'ensemble du déploiement sur un serveur de Team Foundation Server
Voir aussi
DropDown image

Utilisez les procédures de cette section pour installer et configurer Team Foundation Server sur un serveur.

Dans cette section

Liste de vérification : déploiement sur un serveur de Team Foundation Server

Fournit une liste de vérification à utiliser comme référence pratique pendant le déploiement de Team Foundation Server sur un serveur.

Installation de Team Foundation Server

Fournit des instructions détaillées pour installer et configurer Team Foundation Server et ses composants requis sur un serveur unique.

Rubriques connexes

Configuration de Team Foundation System

Indique la configuration système nécessaire relative au matériel et aux logiciels pour installer cette version de Team Foundation Server.

Vue d'ensemble de la sécurité de Team Foundation Server pour l'installation

Fournit des informations liées à la sécurité pour l'installation de Team Foundation Server.

Vue d'ensemble du déploiement de Team Foundation Server sur deux serveurs

Utilisez les procédures de cette section pour installer et configurer Team Foundation Server à l'aide de deux ordinateurs, un pour les composants de la couche Données et un autre pour les composants de la couche Application.

Vue d'ensemble de l'installation de Team Foundation Build

Utilisez les procédures de cette section pour installer et configurer Team Foundation Build, qui fournit l'automation de la génération pour vous aider à générer et partager les solutions Visual Studio 2005.

Vue d'ensemble de l'installation de Team Explorer

Utilisez les procédures de cette section pour installer et configurer Team Explorer.

Voir aussi

Concepts

Installation de Team Foundation


Liste de vérification : déploiement sur un serveur de Team Foundation Server

 Image de liste déroulante Image de pointage sur liste déroulante Image de réduction Image de développement Image Réduire tout Image Développer tout Copier l'image de pointage
Visual Studio Team System
Liste de vérification : déploiement sur un serveur de Team Foundation Server
Voir aussi
Image Réduire tout Image de liste déroulante

Utilisez cette liste de vérification en tant que référence utile lors du déploiement sur un seul serveur de Team Foundation Server. Vous devez imprimer cette liste de vérification et marquer chaque étape que vous terminez.

Image de développement Liste de vérification de déploiement sur un serveur

Cette liste de vérification expose les étapes générales pour installer Team Foundation Server à l'aide d'un déploiement sur un seul serveur et fournit des liens vers des informations détaillées pour chaque étape. Un déploiement sur un seul serveur place les couches Application et Données de Team Foundation sur le même ordinateur. Vous pouvez installer Team Foundation Build et Team Explorer en utilisant des procédures distinctes après l'installation de Team Foundation Server.

Done (Terminé) Étape

Récupérez la version la plus actuelle de ce guide, qui est téléchargeable à partir du Centre de téléchargement Microsoft (http://go.microsoft.com/fwlink/?LinkId=40042).

Vérifiez les configurations matérielle et logicielle requises. Pour plus d'informations, consultez Configuration de Team Foundation System.

Identifiez le compte d'utilisateur à employer pour exécuter le programme d'installation et ajoutez le compte au groupe Administrateurs local. Il s'agit en général de votre compte d'utilisateur. Dans ce guide, ce compte est désigné sous le nom de Domain\TFSSETUP. Pour plus d'informations, consultez Comptes d'utilisateurs requis pour l'installation de Team Foundation Server.

Obtenez deux comptes de service qui assurent les communications entre les services utilisés par Team Foundation Server.

  • Compte pour exécuter les services Team Foundation (par exemple, Domain\TFSSERVICE).

  • Compte pour accéder aux sources de données SQL Server Reporting Services (par exemple, Domain\TFSREPORTS.

Pour plus d'informations, consultez Comptes d'utilisateurs requis pour l'installation de Team Foundation Server.

Installez les services IIS version 6.0. Activez ASP.NET et redémarrez l'ordinateur.

Attention Attention

N'installez pas les extensions serveur FrontPage 2002.

Pour plus d'informations, consultez Comment : installer les services IIS (Internet Information Services) pour Team Foundation Server.

Installez Microsoft SQL Server 2005 Standard ou Enterprise Edition comme instance par défaut de SQL Server (MSSQLSERVER) sur cet ordinateur. Utilisez Système local comme compte de service. Installez le correctif indiqué à la fin de cette rubrique.

Pour plus d'informations, consultez Comment : installer Microsoft SQL Server 2005 pour Team Foundation Server (déploiement sur un serveur).

Vérifiez votre installation de Microsoft SQL Server 2005 à l'aide des étapes décrites dans la rubrique Comment : vérifier l'installation de Microsoft SQL Server 2005 ou « Comment : vérifier une installation réussie des services SQL Server 2005 » dans la documentation en ligne de SQL Server (http://go.microsoft.com/fwlink/?LinkId=60404).

Attention Attention

N'exécutez pas l'outil de configuration de Reporting Services à ce stade.

Installez le correctif KB913393 pour Microsoft .NET Framework 2.0 disponible sur le support d'installation de Team Foundation Server.

Sur le support d'installation, recherchez le dossier pour le correctif, KB913393, recherchez le fichier exécutable (.exe) pour votre plate-forme (X86), puis double-cliquez sur le fichier à installer.

Installez Windows SharePoint Services avec Service Pack 2 en vue d'une utilisation avec Team Foundation Server et redémarrez l'ordinateur.

Attention Attention

Ne modifiez pas Windows SharePoint Services à ce stade. Le programme d'installation de Team Foundation Server effectue cette configuration pour vous.

Pour plus d'informations, consultez Comment : installer Microsoft Windows SharePoint Services pour Team Foundation Server (déploiement sur un serveur).

Vérifiez que les ports appropriés sont ouverts.

Si vous utilisez le Pare-feu Windows, ou un logiciel de pare-feu ou une solution matérielle d'un tiers, vous devez faire en sorte que les ports requis soient ouverts pour autoriser la communication entre les composants. Pour plus d'informations, consultez Ports requis pour l'installation de Team Foundation Server.

Installez Team Foundation Server. Pour plus d'informations, consultez Comment : installer Team Foundation Server.

Pour ajouter des utilisateurs au groupe Team Foundation Administration, installez Team Explorer en local ou sur un autre ordinateur. Pour plus d'informations, consultez Vue d'ensemble de l'installation de Team Explorer.

Image de développement Voir aussi

Autres ressources

Vue d'ensemble du déploiement sur un serveur de Team Foundation Server
Vue d'ensemble de l'installation de Team Foundation Build
Vue d'ensemble de l'installation de Team Foundation Server Proxy


Installation de Team Foundation Server

Installation de Team Foundation Server
DropDown image

Utilisez les procédures de cette section pour installer et configurer Team Foundation Server et ses composants requis qui utilisent un ordinateur pour à la fois les composants de la couche Données et les composants de la couche Application.

Dans cette section

Comment : installer les services IIS (Internet Information Services) pour Team Foundation Server

Décrit comment installer et configurer Internet Information Services (IIS) 6.0.

Comment : installer Microsoft SQL Server 2005 pour Team Foundation Server (déploiement sur un serveur)

Décrit comment installer et configurer SQL Server 2005 pour Team Foundation Server.

Comment : installer Microsoft Windows SharePoint Services pour Team Foundation Server (déploiement sur un serveur)

Décrit comment installer et configurer Windows SharePoint Services pour Team Foundation Server.

Comment : installer Team Foundation Server

Décrit comment installer et configurer les composants des couches Données et Application de Team Foundation Server.

Voir aussi

Autres ressources

Vue d'ensemble du déploiement sur un serveur de Team Foundation Server


Comment : installer les services IIS (Internet Information Services) pour Team Foundation Server

Comment : installer les services IIS (Internet Information Services) pour Team Foundation Server
Voir aussi

Utilisez cette procédure pour installer et configurer les services IIS (Internet Information Services) version 6.0 pour Team Foundation Server.

Pour installer les services IIS à l'aide de l'Assistant Configurer votre serveur

  1. Démarrez l'Assistant Configurer votre serveur en effectuant l'une des opérations suivantes :

    • Par défaut, Gérer votre serveur démarre automatiquement au démarrage de Windows. Dans Gérer votre serveur, cliquez sur Ajouter ou supprimer un rôle.

    • Dans le Panneau de configuration, ouvrez Outils d'administration, puis Assistant Configurer votre serveur.

  2. À la page Bienvenue dans l'Assistant Configurer votre serveur, cliquez sur Suivant.

  3. À la page Étapes préliminaires, cliquez sur Suivant.

  4. Sur la page Rôle du serveur, cliquez sur Serveur d'applications (IIS, ASP.NET), puis sur Suivant.

  5. À la page Options du serveur d'applications, sélectionnez Activer ASP.NET, puis cliquez sur Suivant.

    Remarque Important

    Ne sélectionnez pas Extensions serveur FrontPage. Ce serveur héberge Windows SharePoint Services, qui est incompatible avec les extensions serveur FrontPage.

  6. À la page Aperçu des sélections, cliquez sur Suivant.

    Remarque Remarque

    Votre support d'installation de Windows Server 2003 peut vous être demandé.

  7. Cliquez sur Terminer pour interrompre l'Assistant.

  8. Visitez le site Windows Update (http://windowsupdate.microsoft.com) et installez tous les éléments du groupe Critical Updates and Service Packs.

Pour installer les services IIS à l'aide de l'utilitaire Ajout/Suppression de programmes

  1. Dans le Panneau de configuration, ouvrez Ajout/Suppression de programmes.

  2. Cliquez sur Ajouter/Supprimer des composants Windows.

    L'Assistant Composants de Windows démarre.

  3. À la page Composants Windows, sélectionnez Serveur d'applications, puis cliquez sur Détails.

  4. Le cas échéant, sélectionnez ASP.NET, puis cliquez sur OK.

    Remarque Important

    Si vous sélectionnez Internet Information Services (IIS), puis cliquez sur Détails, ne sélectionnez pas Extensions serveur FrontPage 2002. Ce serveur héberge Windows SharePoint Services, qui est incompatible avec les extensions serveur FrontPage.

  5. À la page Composants Windows, cliquez sur Suivant.

    Remarque Remarque

    Votre support d'installation de Windows Server 2003 peut vous être demandé.

  6. Cliquez sur Terminer pour fermer l'Assistant.

  7. Visitez le site Windows Update (http://windowsupdate.microsoft.com) et installez tous les éléments du groupe Critical Updates and Service Packs.

Sécurité

Pour effectuer cette procédure, vous devez être membre du groupe de sécurité Administrateurs sur l'ordinateur. Le compte d'utilisateur employé pour l'installation est désigné sous le nom de Domaine\\TFSSETUP dans ce guide. Si vous utilisez le même compte pour installer Team Foundation Server, ce compte est automatiquement ajouté au groupe de sécurité Team Foundation Administrators lors de l'installation. Pour plus d'informations, consultez Comptes d'utilisateurs requis pour l'installation de Team Foundation Server.

Voir aussi

Autres ressources

Installation de Team Foundation Server


Comment : installer Microsoft SQL Server 2005 pour Team Foundation Server (déploiement sur un serveur)

Comment : installer Microsoft SQL Server 2005 pour Team Foundation Server (déploiement sur un serveur)
Voir aussi

Utilisez cette procédure pour installer et configurer Microsoft SQL Server 2005 Standard Edition ou Enterprise Edition pour Team Foundation Server à l'aide d'un fichier de réponses ou de façon interactive à l'aide de l'Assistant Installation. Team Foundation Server inclut une copie sous licence de Microsoft SQL Server 2005 Standard Edition. Vous devez également installer le correctif indiqué à la fin de cette rubrique.

Remarque Remarque

Vous devez installer les services IIS (Internet Information Services) 6.0 avant d'installer Microsoft SQL Server 2005.

Installer automatiquement Microsoft SQL Server 2005

Vous pouvez installer Microsoft SQL Server 2005 à partir de la ligne de commande à l'aide du fichier de réponses fourni. Ce fichier de réponses automatise le programme d'installation pour installer et configurer Microsoft SQL Server 2005 pour une utilisation avec Team Foundation Server.

Attention Attention

Par défaut, Microsoft SQL Server indique un paramètre de classement en fonction des paramètres de langue pour le système d'exploitation. Pour plus d'informations sur les paramètres de classement, consultez « Collation Settings in Setup » (Paramètres de classement lors de l'installation) dans la documentation en ligne de SQL Server 2005.

Pour installer Microsoft SQL Server 2005 à l'aide d'un fichier de réponses

  1. Ouvrez une session Windows à l'aide du compte utilisé pour l'installation de Team Foundation Server (par exemple, Domaine\TFSSETUP).

  2. Sur le support d'installation de Team Foundation Server, localisez et copiez le fichier de réponses automatique et préconfiguré (SQL2005ForATDT.ini) dans un emplacement commode sur votre disque dur local (par exemple, C:\).

  3. Exécutez le programme d'installation pour Microsoft SQL Server 2005 en utilisant la ligne de commande suivante :

    C:\>SQLServerSetupDirectory\setup.exe /qb /settings AnswerFileDirectory\SQL2005ForATDT.ini PIDKEY=ProductKey

    Où SQLServerSetupDirectory est le chemin d'accès à setup.exe pour Microsoft SQL Server 2005, AnswerFileDirectory est le chemin d'accès au fichier de réponses et ProductKey est la clé du produit pour Microsoft SQL Server 2005 sans tirets ni espaces.

    Remarque Remarque

    Pour vérifier votre installation, consultez Comment : vérifier l'installation de Microsoft SQL Server 2005.

Installer Microsoft SQL Server 2005 de façon interactive

Team Foundation Server inclut une copie sous licence de Microsoft SQL Server 2005 Standard Edition.

Remarque Remarque

Vous devez installer les services IIS (Internet Information Services) 6.0 avant d'installer Microsoft SQL Server 2005.

Pour installer Microsoft SQL Server 2005 de façon interactive

  1. Ouvrez une session Windows à l'aide du compte utilisé pour l'installation de Team Foundation Server (par exemple, Domaine\TFSSETUP).

  2. Insérez le CD-ROM pour Microsoft SQL Server 2005 et, sous Installer à la page Démarrage de SQL Server 2005, cliquez sur Composants serveur, documentation en ligne et exemples.

    Remarque Remarque

    Le CD-ROM de Microsoft SQL Server 2005 Standard Edition est disponible avec Team Foundation Server. Pour installer SQL Server Enterprise Edition, vous pouvez utiliser le CD-ROM du logiciel que vous avez acheté séparément. La page de démarrage est disponible en exécutant le fichier Splash.hta situé dans le dossier Servers du support d'installation.

    L'Assistant Installation de Microsoft SQL Server 2005 démarre.

  3. À la page Contrat de Licence Utilisateur Final, passez en revue le contrat de licence. Si vous acceptez les termes et conditions mentionnés, sélectionnez J'accepte les termes et conditions du contrat de licence, puis cliquez sur Suivant.

  4. À la page Installation de la configuration requise, cliquez sur Installer. Une fois les composants requis correctement installés, cliquez sur Suivant.

    L'Assistant Installation de Microsoft SQL Server démarre.

  5. Cliquez sur Suivant pour démarrer l'analyse de la configuration système.

  6. À la page Analyse de la configuration système, vérifiez l'état de toutes les actions requises, par exemple les redémarrages du système requis, et suivez les consignes qui figurent sur cette page jusqu'à ce que toutes les actions obtiennent l'état Opération réussie. Une fois que toutes les actions ont obtenu l'état Succès, cliquez sur Suivant pour démarrer l'installation.

    Remarque Remarque

    Le démarrage du programme d'installation peut prendre un certain temps.

  7. À la page Informations d'inscription, complétez les informations d'inscription, puis cliquez sur Suivant.

  8. Sur la page Composants à installer, sélectionnez les composants suivants, puis cliquez sur Avancé.

    • SQL Server Database Services

    • Analysis Services

    • Reporting Services

    • Integration Services

    • Composants de la station de travail, documentation en ligne et outils de développement

      Remarque Remarque

      Team Foundation Server ne nécessite pas Notification Services.

  9. Sur la page Sélection de composant, développez les nœuds ci-après et spécifiez les options suivantes.

    Remarque Remarque

    En dehors des cas indiqués ci-dessous, vous ne devez pas modifier les sélections par défaut dans les autres zones de fonctionnalités.

    1. Sous Services de base de données, cliquez sur l'icône de Réplication et sélectionnez Ce composant ne sera pas disponible.

      Remarque Conseil

      Pour optimiser les performances système, sélectionnez Fichiers de données et cliquez sur Parcourir pour spécifier un emplacement de fichier sur un disque dur physique différent. Par défaut, SQL Server 2005 installe tous les fichiers sur le lecteur système. Vous pouvez effectuer la même opération pour Fichiers de données sous Analysis Services.

    2. Sous Composants clients, le seul composant à installer obligatoirement est Outils de gestion. Pour tous les autres éléments sous Composants clients, vous pouvez cliquer le cas échéant sur l'icône et sélectionner Ce composant ne sera pas disponible.

    3. Sous Documentation, Exemples et Exemples de bases de données, vous pouvez cliquer le cas échéant sur l'icône Documentation en ligne puis sélectionner Ce composant ne sera pas disponible. Cliquez sur Suivant.

  10. À la page Nom de l'instance, sélectionnez Instance par défaut, puis cliquez sur Suivant.

    Remarque Important

    L'installation de Team Foundation Server échoue si vous spécifiez une instance nommée.

  11. À la page Compte de service, sélectionnez Utiliser le compte système par défaut et dans la liste sélectionnez Système local. Dans Démarrer les services une fois l'installation terminée, sélectionnez tous les services : SQL Server, SQL Server Agent, Analysis Services, Reporting Services et SQL Browser, puis cliquez sur Suivant.

    Remarque Remarque

    Le compte de service est associé à Microsoft SQL Server 2005 et ne doit pas être confondu avec les deux comptes de service que vous avez obtenus avant de commencer l'installation.

  12. À la page Mode d'authentification, sélectionnez Mode d'authentification Windows, puis cliquez sur Suivant.

  13. Sur la page Paramètres de classement, sélectionnez le classement approprié à votre langue, puis cliquez sur Suivant.

    Remarque Remarque

    Si vous modifiez Indicateur de classement et ordre de tri, vous devez sélectionner Respecter les accents.

    La sélection par défaut est basée sur le paramètre du langage non-Unicode dans Windows Server 2003. Le classement Windows est le classement par défaut pour la plupart des langues ; toutefois, pour l'anglais des États-Unis, SQL Server 2005 est installé avec un classement SQL Server pour des raisons de compatibilité descendante. Si vous souhaitez modifier le classement par défaut afin que d'autres caractères anglais des États-Unis soient pris en charge, envisagez d'utiliser Latin1_General.

    Pour les autres langues, envisagez d'utiliser un classement Windows « _90 » si celui-ci est disponible, sinon utilisez un autre classement Windows.

    Par exemple, pour les déploiements japonais, employez le classement Japanese_90 à la place du classement par défaut si vous utilisez les blocs de caractères Extension A CJC Unicode ou les substituts Unicode comme indiqué ci-après.

    • Noms d'objets Team Foundation Server, tels que Requêtes ou Projets.

    • Fichiers ou chemins d'accès qui sont vérifiés dans le système de contrôle de version.

    • Tout champ des éléments de travail utilisé pour les recherches.

    Pour éviter tout problème avec les caractères à double largeur ou Hiragana/Katakana équivalents, lors de l'installation, activez les cases à cocher pour activer le respect des caractères Kana et de la largeur.

    Team Foundation Server ne prend pas en charge les classements suivants :

    • Non-respect des accents

    • Binary

    • Binary2

    • Respecter la casse

    Pour plus d'informations sur les paramètres de classement, consultez « Collation Settings in Setup » (Paramètres de classement lors de l'installation) dans la documentation en ligne de SQL Server 2005.

  14. À la page Options d'installation du serveur de rapports, sélectionnez Installer la configuration par défaut, puis cliquez sur Suivant.

  15. À la page Paramètres de rapports d'erreurs et d'utilisation, vous pouvez éventuellement sélectionner Envoyer des rapports d'erreurs pour SQL Server 2005 à Microsoft ou votre serveur de rapports d'erreurs d'entreprise et Envoyer automatiquement des données d'utilisation des fonctionnalités de SQL Server 2005 à Microsoft, puis cliquer sur Suivant.

  16. À la page Prêt pour l'installation, vous pouvez passer en revue la liste des composants à installer, puis cliquer sur Installer.

  17. À la page Installation en cours, vous pouvez contrôler l'état de l'installation de chaque composant. Une fois l'installation terminée, cliquez sur Suivant.

    Remarque Remarque

    L'installation peut sembler bloquée pendant plusieurs minutes pendant l'activation de SQL Server Reporting Services.

  18. Cliquez sur Terminer pour quitter l'Assistant.

    Remarque Remarque

    Pour vérifier votre installation avant d'installer Windows SharePoint Services, consultez Comment : vérifier l'installation de Microsoft SQL Server 2005.

Installer le correctif pour Microsoft SQL Server 2005

Après avoir installé Microsoft SQL Server 2005, vous devez installer le correctif de mise à jour de SQL Server Analysis Services qui prend plus efficacement en charge la création de rapports.

Remarque Remarque

Pour obtenir les mises à jour les plus récentes, visitez le site Web de Microsoft (http://go.microsoft.com/fwlink/?LinkId=62015).

Pour installer le correctif pour Microsoft SQL Server 2005

  1. Sur l'ordinateur de couche Données, ouvrez le Gestionnaire de configuration SQL Server, cliquez avec le bouton droit sur Service SQL Server Browser, puis cliquez sur Arrêter.

  2. Sur le support d'installation de Team Foundation Server, recherchez le dossier SQLServerKB.

  3. Recherchez le fichier exécutable (.exe) pour vos système d'exploitation et langue, par exemple AS2005-KBnnnnnn-x86-ENU.exe, puis double-cliquez sur le fichier pour démarrer le programme d'installation du correctif.

  4. Dans Programme d'installation de correctifs, acceptez le Contrat de Licence Utilisateur Final, terminez la procédure pour installer le correctif, puis cliquez sur Terminer.

  5. Dans Gestionnaire de configuration SQL Server, cliquez avec le bouton droit sur Service SQL Server Browser, puis cliquez sur Propriétés.

  6. Sous l'onglet Service, recherchez Mode de démarrage et sélectionnez Automatique.

  7. Sous l'onglet Ouvrir une session, cliquez sur Démarrer.

    Remarque Remarque

    Si Démarrer n'est pas activité sous l'onglet Ouvrir une session, cliquez sur l'onglet Service, définissez Mode de démarrage à Désactivé, puis sélectionnez de nouveau Automatique pour mettre à jour explicitement le Mode de démarrage.

Pour vérifier votre installation avant d'installer Windows SharePoint Services, consultez Comment : vérifier l'installation de Microsoft SQL Server 2005.

Sécurité

Pour effectuer cette procédure, vous devez être membre du groupe de sécurité Administrateurs sur l'ordinateur. Le compte d'utilisateur employé pour l'installation est désigné sous le nom de Domaine\\TFSSETUP dans ce guide. Si vous utilisez le même compte pour installer Team Foundation Server, ce compte est automatiquement ajouté au groupe de sécurité Team Foundation Administrators lors de l'installation. Pour plus d'informations, consultez Comptes d'utilisateurs requis pour l'installation de Team Foundation Server.

Voir aussi

Autres ressources

Installation de Team Foundation Server


Comment : installer Microsoft Windows SharePoint Services pour Team Foundation Server (déploiement sur un serveur)

Comment : installer Microsoft Windows SharePoint Services pour Team Foundation Server (déploiement sur un serveur)
Voir aussi

Procédez comme suit pour installer Microsoft Windows SharePoint Services avec Service Pack 2 pour Team Foundation Server pour qu'il s'exécute en mode silencieux à partir de la ligne de commande ou qu'il utilise de façon interactive l'Assistant Installation.

Avant d'installer Team Foundation Server sur une version localisée de Windows SharePoint Services, vous devez installer le module de prise en charge linguistique de Windows SharePoint Services qui correspond à la langue de Team Foundation Server que vous allez installer. Par exemple, vous devez installer le module de prise en charge linguistique en anglais de Windows SharePoint Services avant d'installer la version anglaise de Team Foundation Server.

Remarque Important

Windows SharePoint Services nécessite un système de fichiers NTFS.

Installer Microsoft Windows SharePoint Services en mode silencieux

Vous pouvez installer Windows SharePoint Services en mode silencieux à partir de la ligne de commande.

Pour installer Windows SharePoint Services silencieusement

  1. Ouvrez une session Windows à l'aide du compte utilisé pour l'installation de Team Foundation Server (par exemple, Domaine\\TFSSETUP).

  2. Téléchargez Microsoft Windows SharePoint Services avec Service Pack 2 (http://go.microsoft.com/fwlink/?linkid=55087) et enregistrez le fichier dans un emplacement pratique du disque dur local.

  3. Exécutez le fichier programme d'installation à extraction automatique téléchargé (stsv2.exe) à l'aide de la ligne de commande suivante :

    C:\>DownloadDirectory\STSV2.EXE /C:"setupsts.exe /remoteSql=yes /provision=no /q"

    Où DownloadDirectory est le chemin d'accès à l'emplacement sur votre disque dur où vous avez enregistré le fichier téléchargé.

    Remarque Important

    Vous devez installer Windows SharePoint Services à l'aide de l'option /remoteSql=yes. Windows SharePoint Services est ainsi configuré pour utiliser un serveur SQL Server distant. L'option /provision=no diffère la configuration de Windows SharePoint Services. Plus tard, le programme d'installation de Team Foundation Server configure Windows SharePoint Services pour utiliser la même instance de SQL Server que le reste de Team Foundation Server.

    Vous ne recevrez aucun message de fin de l'installation. À la place, attendez plusieurs minutes que l'installation se termine avant de continuer.

  4. Visitez le site Windows Update (http://windowsupdate.microsoft.com) et installez tous les éléments du groupe Critical Updates and Service Packs.

  5. Redémarrez l'ordinateur.

Installer Microsoft Windows SharePoint Services de manière interactive

Installez Microsoft Windows SharePoint Services avec Service Pack 2.

Pour installer Windows SharePoint Services de façon interactive

  1. Ouvrez une session Windows à l'aide du compte utilisé pour l'installation de Team Foundation Server (par exemple, Domaine\\TFSSETUP).

  2. Téléchargez Microsoft Windows SharePoint Services avec Service Pack 2 (http://go.microsoft.com/fwlink/?linkid=55087) et enregistrez le fichier sur le disque dur local.

  3. Exécutez le fichier d'installation à exécution automatique téléchargé (stsv2.exe).

  4. À la page Contrat de Licence Utilisateur Final, prenez connaissance du contrat de licence. Si vous acceptez les termes et conditions mentionnés, sélectionnez J'accepte les termes du contrat de licence, puis cliquez sur Suivant.

  5. À la page Type d'instance, sélectionnez Batterie de serveurs, puis cliquez sur Suivant.

    Remarque Important

    Vous devez installer Windows SharePoint Services à l'aide de l'option Batterie de serveurs. Windows SharePoint Services est ainsi configuré pour utiliser un serveur SQL Server distant. Plus tard, le programme d'installation de Team Foundation Server configurera Windows SharePoint Services pour utiliser la même instance de SQL Server que le reste de Team Foundation Server.

  6. À la page Résumé, cliquez sur Installer.

    Lorsque l'installation est terminée, une fenêtre de navigateur Web s'ouvre et affiche la page Configurer le serveur virtuel d'administration. Après avoir confirmé que la page apparaît, fermez la fenêtre du navigateur sans apporter de modifications.

    Remarque Important

    N'apportez pas de modifications sur la page qui apparaît. Plus tard, le programme d'installation de Team Foundation Server configure Windows SharePoint Services pour utiliser la même instance de SQL Server que le reste de Team Foundation Server.

    Si la page n'apparaît pas, vous devez déterminer la cause et résoudre le problème à l'aide du Guide de l'administrateur Windows SharePoint Services (http://go.microsoft.com/fwlink/?LinkId=52668).

  7. Visitez le site Windows Update (http://windowsupdate.microsoft.com) et installez tous les éléments du groupe Critical Updates and Service Packs.

  8. Redémarrez l'ordinateur.

Vérification de l'installation

Après avoir installé Windows SharePoint Server, vous pouvez vous assurer que les services fonctionnent même si vous n'avez pas installé Team Foundation Server.

Pour vérifier que Windows SharePoint Services est installé

  • Ouvrez Internet Explorer et tapez le nom de serveur en tant qu'adresse.

    Par exemple, pour un serveur nommé ADATUM, vous tapez Http://adatum.

    Même si un site n'est pas configuré, le serveur est un serveur Web actif et propose une page En construction.

Sécurité

Pour effectuer cette procédure, vous devez être membre du groupe de sécurité Administrateurs sur l'ordinateur. Le compte d'utilisateur employé pour l'installation est désigné sous le nom de Domaine\\TFSSETUP dans ce guide. Si vous utilisez le même compte pour installer Team Foundation Server, ce compte est automatiquement ajouté au groupe de sécurité Team Foundation Administrators lors de l'installation. Pour plus d'informations, consultez Comptes d'utilisateurs requis pour l'installation de Team Foundation Server.

Voir aussi

Autres ressources

Installation de Team Foundation Server


Comment : installer Team Foundation Server

Comment : installer Team Foundation Server

Utilisez cette procédure pour installer Team Foundation Server.

Avant d'installer Team Foundation Server, assurez-vous que Microsoft SQL Server 2005 Standard Edition ou Enterprise Edition est installé et en cours d'exécution. Remplissez toutes les conditions préalables de la couche Données. Pour plus d'informations, consultez Liste de vérification : déploiement sur un serveur de Team Foundation Server.

Pour installer Team Foundation Server

  1. Ouvrez une session Windows à l'aide du compte utilisé pour l'installation de Team Foundation Server (par exemple, Domaine\\TFSSETUP).

  2. Insérez le CD-ROM et, lorsque la page d'exécution automatique s'affiche, cliquez sur Installez Team Foundation Server , puis sur Installation sur un serveur.

    Si la page d'exécution automatique ne s'affiche pas, localisez et exécutez le fichier d'exécution automatique (autorun.exe) situé dans le dossier racine du support d'installation.

    L'Assistant Installation de Visual Studio Team Foundation Server démarre.

  3. À la page Bienvenue dans le programme d'installation, cliquez sur Suivant.

  4. Sur la page Termes de Licence, examinez les termes. Si vous acceptez les termes et conditions mentionnés, sélectionnez J'accepte les termes du contrat de licence, puis cliquez sur Suivant.

    L'Assistant Installation analyse votre système à la recherche de conditions qui peuvent provoquer l'échec de l'installation ou des problèmes par la suite lors du fonctionnement du serveur.

  5. Sur la page Dossier de destination, acceptez le dossier de destination par défaut, puis cliquez sur Suivant.

  6. Sur la page Vérification de la santé du système, examinez les avertissements ou blocs éventuels en cliquant sur le lien de rapport.

    • Les blocs doivent être traités avant de pouvoir poursuivre l'installation. Cliquez sur Annuler et réexécutez le programme d'installation après avoir corrigé les problèmes.

    • Les avertissements doivent être traités avant de continuer, mais ne doivent pas empêcher le déroulement de l'installation. Vous pouvez cliquer sur Suivant.

    • Si rien n'est répertorié, cliquez sur Suivant.

  7. À la page Compte d'ouverture de session du service, tapez le compte d'utilisateur de domaine Windows que vous avez créé pour le compte de service Team Foundation Server (par exemple, Domaine\TFSSERVICE) dans la zone Nom du compte, tapez le mot de passe dans la zone Mot de passe, puis cliquez sur Suivant. Pour plus d'informations, consultez Comptes d'utilisateurs requis pour l'installation de Team Foundation Server.

  8. Sur la page Compte d'ouverture de session de création de rapports, tapez les informations sur le compte de rapports de Team Foundation Server, puis cliquez sur Suivant.

    Remarque Remarque

    Ce compte doit être différent des comptes de service ou utilisé pour l'installation de Team Foundation Server. Par exemple, utilisez Domaine\TFSREPORTS.

  9. À la page Spécifier les paramètres d'alerte, sélectionnez Activer les alertes Team Foundation, et tapez les informations suivantes :

    • Dans la zone Serveur SMTP, tapez le nom du serveur que vous utiliserez pour envoyer des notifications par courrier électronique.

    • Dans la zone Adresse de messagerie De, tapez le nom de l'adresse de messagerie à partir de laquelle les notifications semblent venir, puis cliquez sur Suivant.

  10. À la page Prêt pour l'installation, cliquez sur Installer.

  11. À la page Installation des composants, vous pouvez surveiller l'installation de Team Foundation Server.

    Pendant l'installation, vous pouvez être invité à redémarrer l'ordinateur. Cliquez sur Redémarrer maintenant pour que l'installation reprenne après le redémarrage de l'ordinateur et l'ouverture d'une nouvelle session.

  12. Sur la page L'installation s'est terminée avec succès, vérifiez que l'installation est terminée, puis cliquez sur Terminer.

    Après avoir installé Team Foundation Server, vous devez sauvegarder la clé de chiffrement de Reporting Services à l'aide de l'outil de configuration de Reporting Services. Cette étape n'est pas obligatoire pour la création de projets d'équipe, mais fait partie des méthodes conseillées pour la gestion de Team Foundation Server. Pour plus d'informations, consultez « Comment : sauvegarder la clé de chiffrement de Reporting Services » dans le Guide de l'administrateur Team Foundation Server (http://go.microsoft.com/fwlink/?LinkID=52459).

  13. Dans Internet Explorer, recherchez http://localhost:8080/services/v1.0/Registration.asmx, puis cliquez sur GetRegistrationEntries.

  14. Sur la page GetRegistrationEntries, cliquez sur Appeler. Vous n'avez pas à entrer de ToolID.

    Remarque Remarque

    Pour utiliser cette méthode Web, vous devez vous trouver sur l'ordinateur de couche Application.

  15. Dans le document XML, vérifiez que le type VSTF existe, puis fermez.

    <?xml version="1.0" encoding="utf-8" ?>

    <Type>vstfs</Type>

    Remarque Remarque

    Après avoir installé Team Foundation Server, vous pouvez installer Team Explorer, Team Foundation Build ou Team Foundation Server Proxy.

Sécurité

Pour effectuer cette procédure, vous devez être membre du groupe de sécurité Administrateurs sur l'ordinateur. Le compte d'utilisateur employé pour l'installation est désigné sous le nom de Domaine\\TFSSETUP dans ce guide. Si vous utilisez le même compte pour installer Team Foundation Server, ce compte est automatiquement ajouté au groupe de sécurité Team Foundation Administrators lors de l'installation. Pour plus d'informations, consultez Comptes d'utilisateurs requis pour l'installation de Team Foundation Server.

Voir aussi

Autres ressources

Installation de Team Foundation Server
Vue d'ensemble de l'installation de Team Foundation Build
Vue d'ensemble de l'installation de Team Foundation Server Proxy


Vue d'ensemble du déploiement de Team Foundation Server sur deux serveurs

Vue d'ensemble du déploiement de Team Foundation Server sur deux serveurs
Voir aussi
DropDown image

Utilisez les procédures de cette section pour installer et configurer Team Foundation Server à l'aide de deux ordinateurs, un pour les composants de la couche Données et un autre pour les composants de la couche Application.

Dans cette section

Liste de vérification : déploiement de Team Foundation Server sur deux serveurs

Fournit une liste de vérification à utiliser comme référence pratique pendant le déploiement de Team Foundation Server sur deux serveurs.

Installation de Team Foundation Server (bases de données)

Fournit des instructions détaillées pour installer et configurer les composants de la couche Données de Team Foundation Server et leurs composants requis sur un serveur séparé des composants de la couche Application.

Installation de Team Foundation Server (services)

Fournit des instructions détaillées pour installer et configurer les composants de la couche Application de Team Foundation Server et leurs composants requis sur un serveur séparé des composants de la couche Données.

Garantie de la disponibilité continue des serveurs

Fournit des instructions détaillées pour ajouter des ordinateurs à Team Foundation et pour les configurer afin de prendre le contrôle des services de couche Application ou de couche Données.

Rubriques connexes

Configuration de Team Foundation System

Indique la configuration système nécessaire relative au matériel et aux logiciels pour installer cette version de Team Foundation Server.

Vue d'ensemble de la sécurité de Team Foundation Server pour l'installation

Fournit des informations liées à la sécurité pour l'installation de Team Foundation Server.

Vue d'ensemble du déploiement sur un serveur de Team Foundation Server

Utilisez les procédures de cette section pour installer et configurer Team Foundation Server sur un seul serveur.

Vue d'ensemble de l'installation de Team Foundation Build

Utilisez les procédures de cette section pour installer et configurer Team Foundation Build, qui fournit l'automation de la génération pour vous aider à générer et partager les solutions Visual Studio 2005.

Vue d'ensemble de l'installation de Team Foundation Server Proxy

Utilisez les procédures de cette section pour installer Team Foundation Server Proxy, qui met en cache les fichiers du contrôle de code source auxquels vous avez précédemment accédé.

Vue d'ensemble de l'installation de Team Explorer

Utilisez les procédures de cette section pour installer et configurer Team Explorer.

Voir aussi

Concepts

Installation de Team Foundation


Liste de vérification : déploiement de Team Foundation Server sur deux serveurs

 Image de liste déroulante Image de pointage sur liste déroulante Image de réduction Image de développement Image Réduire tout Image Développer tout Copier l'image de pointage
Visual Studio Team System
Liste de vérification : déploiement de Team Foundation Server sur deux serveurs
Voir aussi
Image Réduire tout Image de liste déroulante

Utilisez cette liste de vérification en tant que référence utile lors du déploiement sur deux serveurs de Team Foundation Server. Cette liste de vérification expose les étapes générales pour installer Team Foundation Server à l'aide d'un déploiement sur deux serveurs et fournit des liens vers des informations détaillées pour chaque étape. Un déploiement sur deux serveurs place les couches Application et Données de Team Foundation sur des ordinateurs distincts. Vous devez imprimer cette liste de vérification et marquer chaque étape que vous effectuez.

Image de développement Préparation

Vous devez disposer des éléments suivants avant d'installer Team Foundation Server.

Done (Terminé) Étape

Récupérez la version la plus actuelle de ce guide, qui est téléchargeable à partir du Centre de téléchargement Microsoft (http://go.microsoft.com/fwlink/?LinkId=40042).

Vérifiez les configurations matérielle et logicielle requises. Pour plus d'informations, consultez Configuration de Team Foundation System.

Identifiez le compte d'utilisateur à employer pour exécuter le programme d'installation. Il s'agit en général de votre compte d'utilisateur. Dans ce guide, ce compte est désigné sous le nom de Domaine\TFSSETUP.

Obtenez deux comptes de service qui assurent les communications entre les services utilisés par Team Foundation Server.

  • Compte pour exécuter les services Team Foundation (par exemple, Domain\TFSSERVICE).

  • Compte pour accéder aux sources de données SQL Server Reporting Services (par exemple, Domain\TFSREPORTS.

Pour plus d'informations sur les conditions requises pour ces comptes, consultez Comptes d'utilisateurs requis pour l'installation de Team Foundation Server.

Image de développement Installation de Team Foundation Server (bases de données)

Done (Terminé) Étape

Sur l'ordinateur de la couche Données, ajoutez le compte utilisé pour l'exécution du programme d'installation de Team Foundation Server (par exemple, Domain\TFSSETUP) au groupe local Administrateurs.

Sur l'ordinateur de couche Données, installez Microsoft SQL Server 2005 Standard ou Enterprise Edition sur l'instance par défaut de SQL Server sur cet ordinateur. Utilisez Système local comme compte de service. Installez le correctif indiqué à la fin de la rubrique d'installation.

Pour plus d'informations, consultez Comment : installer Microsoft SQL Server 2005 pour Team Foundation Server (déploiement sur deux serveurs).

Vérifiez votre installation de Microsoft SQL Server 2005 à l'aide des étapes décrites dans la rubrique Comment : vérifier l'installation de Microsoft SQL Server 2005 ou « Comment : vérifier une installation réussie des services SQL Server 2005 » dans la documentation en ligne de SQL Server (http://go.microsoft.com/fwlink/?LinkId=60404).

Sur l'ordinateur de la couche Données, vérifiez que les ports appropriés sont ouverts.

Si vous utilisez le Pare-feu Windows, ou un logiciel de pare-feu ou une solution matérielle d'un tiers, vous devez faire en sorte que les ports requis soient ouverts pour autoriser la communication entre les composants. Pour plus d'informations, consultez Ports requis pour l'installation de Team Foundation Server.

Sur l'ordinateur de couche Données, installez Team Foundation Server (bases de données). Pour plus d'informations, consultez Comment : installer Team Foundation Server (bases de données).

Image de développement Installation de Team Foundation Server (services)

Done (Terminé) Étape

Sur l'ordinateur de la couche Application, ajoutez le compte utilisé pour l'exécution du programme d'installation de Team Foundation Server (par exemple, Domain\TFSSETUP) au groupe local Administrateurs.

Sur l'ordinateur de couche Application, installez les services IIS (Internet Information Services) 6.0. Activez ASP.NET.

Attention Attention

N'installez pas les extensions serveur FrontPage 2002.

Pour plus d'informations, consultez Comment : installer les services IIS (Internet Information Services) pour Team Foundation Server.

Sur l'ordinateur de couche Application, installez SQL Server 2005 Reporting Services (à l'aide de Microsoft SQL Server 2005 Standard ou Enterprise Edition) pour une utilisation avec Team Foundation Server.

Attention Attention

N'exécutez pas l'outil de configuration de Reporting Services à ce stade.

Sur l'ordinateur de couche Application, installez le correctif KB913393 pour Microsoft .NET Framework 2.0 disponible sur le support d'installation de Team Foundation Server.

Sur le support d'installation, recherchez le dossier KB913393, recherchez le fichier exécutable (.exe) pour votre plate-forme ( X86), puis double-cliquez sur le fichier à installer.

Sur l'ordinateur de couche Application, installez Windows SharePoint Services avec Service Pack 2 pour une utilisation avec Team Foundation Server et redémarrez-le.

Attention Attention

Ne modifiez pas Windows SharePoint Services à ce stade. Le programme d'installation de Team Foundation Server (services) effectue cette configuration pour vous. Pour plus d'informations, consultez Comment : installer Microsoft Windows SharePoint Services pour Team Foundation Server (déploiement sur deux serveurs).

Sur l'ordinateur de couche Application, installez Team Foundation Server (services). Pour plus d'informations, consultez Comment : installer Team Foundation Server (services).

Sur l'ordinateur de couche Application, vérifiez que les ports appropriés sont ouverts.

Si vous utilisez le Pare-feu Windows, ou un logiciel de pare-feu ou une solution matérielle d'un tiers, vous devez faire en sorte que les ports requis soient ouverts pour autoriser la communication entre les composants. Pour plus d'informations, consultez Ports requis pour l'installation de Team Foundation Server.

Installez Team Explorer en local ou sur un autre ordinateur. Pour plus d'informations, consultez Vue d'ensemble de l'installation de Team Explorer.

Image de développement Voir aussi

Autres ressources

Vue d'ensemble du déploiement de Team Foundation Server sur deux serveurs
Vue d'ensemble de l'installation de Team Foundation Build
Vue d'ensemble de l'installation de Team Foundation Server Proxy


Installation de Team Foundation Server (bases de données)

Installation de Team Foundation Server (bases de données)
Voir aussi
DropDown image

Utilisez les procédures de cette section pour installer et configurer les composants de la couche Données de Team Foundation Server et leurs composants requis sur un serveur distinct de celui des composants de la couche Application.

Ces composants et composants requis sont les suivants :

Composant | Ordre d'installation
SQL Server 2005 | Premièrement (composant requis pour les composants Team Foundation Server de la couche Données)
composants de la couche Données de Team Foundation Server | Deuxièmement

Dans cette section

Comment : installer Microsoft SQL Server 2005 pour Team Foundation Server (déploiement sur deux serveurs)

Décrit comment installer SQL Server 2005 sur la couche Données.

Comment : vérifier l'installation de Microsoft SQL Server 2005

Décrit comment vérifier l'installation de SQL Server 2005 sur la couche Données.

Comment : installer Team Foundation Server (bases de données)

Décrit comment installer les composants Team Foundation Server de la couche Données.

Voir aussi

Autres ressources

Vue d'ensemble du déploiement de Team Foundation Server sur deux serveurs
Installation de Team Foundation Server (services)


Comment : installer Microsoft SQL Server 2005 pour Team Foundation Server (déploiement sur deux serveurs)

Comment : installer Microsoft SQL Server 2005 pour Team Foundation Server (déploiement sur deux serveurs)
Voir aussi

Utilisez cette procédure pour installer et configurer Microsoft SQL Server 2005 Standard Edition ou Enterprise Edition pour Team Foundation Server automatiquement à l'aide d'un fichier de réponses ou de façon interactive à l'aide de l'Assistant Installation. Team Foundation Server inclut une copie sous licence de Microsoft SQL Server 2005 Standard Edition. Vous devez également installer le correctif indiqué à la fin de cette rubrique.

Installation automatique de Microsoft SQL Server 2005

Vous pouvez installer Microsoft SQL Server 2005 à partir de la ligne de commande à l'aide du fichier de réponses fourni. Ce fichier de réponses automatise le programme d'installation pour installer et configurer Microsoft SQL Server 2005 pour une utilisation avec Team Foundation Server.

Attention Attention

Par défaut, Microsoft SQL Server indique un paramètre de classement en fonction des paramètres de langue pour le système d'exploitation. Pour plus d'informations sur les paramètres de classement, consultez « Collation Settings in Setup » (Paramètres de classement lors de l'installation) dans la documentation en ligne de SQL Server 2005.

Pour installer Microsoft SQL Server 2005 à l'aide d'un fichier de réponses

  1. Sur l'ordinateur de couche Données, ouvrez une session à l'aide du compte utilisé pour l'installation de Team Foundation Server (par exemple, Domaine\TFSSETUP).

  2. Sur le support d'installation de Team Foundation Server, localisez et copiez le fichier de réponses automatique et préconfiguré (SQL2005ForDT.ini) dans un emplacement commode sur votre disque dur local (par exemple, C:\).

  3. Exécutez le programme d'installation pour Microsoft SQL Server 2005 en utilisant la ligne de commande suivante :

    C:\>SQLServerSetupDirectory\setup.exe /qb /settings AnswerFileDirectory\SQL2005ForDT.ini PIDKEY=ProductKey

    Où SQLServerSetupDirectory est le chemin d'accès à setup.exe pour Microsoft SQL Server 2005, AnswerFileDirectory est le chemin d'accès au fichier de réponses et ProductKey est la clé du produit pour Microsoft SQL Server 2005 sans tirets ni espaces.

    Remarque Pour vérifier votre installation, consultez Comment : vérifier l'installation de Microsoft SQL Server 2005.

Installer Microsoft SQL Server 2005

Installez Microsoft SQL Server 2005 Standard Edition ou Enterprise Edition.

Pour installer Microsoft SQL Server 2005 de façon interactive

  1. Sur l'ordinateur de couche Données, ouvrez une session Windows à l'aide du compte utilisé pour l'installation de Team Foundation Server (par exemple, Domaine\TFSSETUP).

  2. Insérez le CD-ROM pour Microsoft SQL Server 2005 et, sous Installer à la page Démarrage de SQL Server 2005, cliquez sur Composants serveur, documentation en ligne et exemples.

    Remarque Remarque

    Le CD-ROM de Microsoft SQL Server 2005 Standard Edition est disponible avec Team Foundation Server. Pour installer Microsoft SQL Server 2005 Enterprise Edition, vous pouvez utiliser le CD-ROM du logiciel que vous avez acheté séparément. La page de démarrage est disponible en exécutant le fichier Splash.hta situé dans le dossier Servers du support d'installation.

    L'Assistant Installation de Microsoft SQL Server 2005 démarre.

  3. À la page Contrat de Licence Utilisateur Final, passez en revue le contrat de licence. Si vous acceptez les termes et conditions mentionnés, sélectionnez J'accepte les termes et conditions du contrat de licence, puis cliquez sur Suivant.

  4. À la page Installation de la configuration requise, cliquez sur Installer. Une fois les composants requis correctement installés, cliquez sur Suivant.

    L'Assistant Installation de Microsoft SQL Server démarre.

  5. Cliquez sur Suivant pour démarrer l'analyse de la configuration système.

  6. À la page Analyse de la configuration système, vérifiez l'état de toutes les actions requises, par exemple les redémarrages du système requis, et suivez les consignes qui figurent sur cette page jusqu'à ce que toutes les actions obtiennent l'état Succès. Une fois que vous avez obtenu l'état Succès pour toutes les actions à l'exception de Fonctionnalité IIS requise, cliquez sur Suivant pour démarrer l'installation.

    Remarque Remarque

    SQL Server 2005 Reporting Services n'est pas installé sur l'ordinateur de couche Données. Vous pouvez ignorer l'état Avertissement pour Fonctionnalité IIS requise. Le démarrage du programme d'installation peut prendre un certain temps.

  7. À la page Informations d'inscription, complétez les informations d'inscription, puis cliquez sur Suivant.

  8. Sur la page Composants à installer, sélectionnez les composants suivants, puis cliquez sur Avancé.

    • SQL Server Database Services

    • Analysis Services

    • Integration Services

    • Composants de la station de travail, documentation en ligne et outils de développement

      Remarque Remarque

      Reporting Services doit être installé sur la couche Application. Team Foundation Server ne nécessite pas Notification Services.

  9. Sur la page Sélection de composant, développez les nœuds ci-après et spécifiez les options suivantes.

    Remarque Remarque

    En dehors des cas indiqués ci-dessous, vous ne devez pas modifier les sélections par défaut dans les autres zones de fonctionnalités.

    1. Sous Services de base de données, cliquez sur l'icône de Réplication et sélectionnez Ce composant ne sera pas disponible.

      Remarque Conseil

      Si vous voulez spécifier un autre emplacement pour les fichiers de données, sélectionnez Fichiers de données, puis cliquez sur Parcourir pour spécifier un répertoire ou un disque dur physique différent. Par défaut, SQL Server 2005 installe tous les fichiers sur le lecteur système. Vous pouvez optimiser les performances du système en utilisant un emplacement distinct. Vous pouvez effectuer la même opération pour Fichiers de données sous Analysis Services.

    2. Sous Composants clients, le seul composant à installer obligatoirement est Outils de gestion. Pour tous les autres éléments sous Composants clients, vous pouvez cliquer le cas échéant sur l'icône et sélectionner Ce composant ne sera pas disponible.

    3. Sous Documentation, Exemples et Exemples de bases de données, vous pouvez cliquer le cas échéant sur l'icône Documentation en ligne puis sélectionner Ce composant ne sera pas disponible. Click Suivant.

  10. À la page Nom de l'instance, sélectionnez Instance par défaut, puis cliquez sur Suivant.

    Remarque Important

    L'installation de Team Foundation Server échoue si vous spécifiez une instance nommée.

  11. Sur la page Compte de service, sélectionnez Utiliser le compte système par défaut, puis Système local dans la liste. Dans Démarrer les services une fois l'installation terminée, sélectionnez tous les services : SQL Server, SQL Server Agent, Analysis Services et SQL Browser, puis cliquez sur Suivant.

    Remarque Remarque

    Ce compte de service est associé à Microsoft SQL Server 2005 et ne doit pas être confondu avec les deux comptes de service que vous avez obtenus avant de commencer l'installation.

  12. Sur la page Mode d'authentification, sélectionnez Mode d'authentification Windows, puis cliquez sur Suivant.

  13. Sur la page Paramètres de classement, sélectionnez le classement approprié à votre langue, puis cliquez sur Suivant.

    Remarque Remarque

    Si vous modifiez Indicateur de classement et Ordre de tri, vous devez sélectionner Respecter les accents.

    La sélection par défaut est basée sur le paramètre du langage non-Unicode dans Windows Server 2003. Le classement Windows est le classement par défaut pour la plupart des langues ; toutefois, pour l'anglais des États-Unis, SQL Server 2005 est installé avec un classement SQL Server pour des raisons de compatibilité descendante. Si vous souhaitez modifier le classement par défaut afin que d'autres caractères anglais des États-Unis soient pris en charge, envisagez d'utiliser Latin1_General.

    Pour les autres langues, envisagez d'utiliser un classement Windows « _90 » si celui-ci est disponible, sinon utilisez un autre classement Windows.

    Par exemple, pour les déploiements japonais, employez le classement Japanese_90 à la place du classement par défaut si vous utilisez les blocs de caractères Extension A CJC Unicode ou les substituts Unicode comme indiqué ci-après.

    • Noms d'objets Team Foundation Server, tels que Requêtes ou Projets.

    • Fichiers ou chemins d'accès qui sont vérifiés dans le système de contrôle de version.

    • Tout champ des éléments de travail utilisé pour les recherches.

    Pour éviter tout problème avec les caractères à double largeur ou Hiragana/Katakana équivalents, lors de l'installation, activez les cases à cocher pour activer le respect des caractères Kana et de la largeur.

    Team Foundation Server ne prend pas en charge les classements suivants :

    • Non-respect des accents

    • Binary

    • Binary2

    • Respecter la casse

    Pour plus d'informations sur les paramètres de classement, consultez « Collation Settings in Setup » (Paramètres de classement lors de l'installation) dans la documentation en ligne de SQL Server 2005.

  14. À la page Paramètres de rapports d'erreurs et d'utilisation, vous pouvez éventuellement sélectionner Envoyer des rapports d'erreurs pour SQL Server 2005 à Microsoft ou votre serveur de rapports d'erreurs d'entreprise et Envoyer automatiquement des données d'utilisation des fonctionnalités de SQL Server 2005 à Microsoft., puis cliquer sur Suivant.

  15. À la page Prêt pour l'installation, vous pouvez passer en revue la liste des composants à installer, puis cliquer sur Installer.

  16. À la page Installation en cours, vous pouvez contrôler l'état de l'installation de chaque composant. Une fois l'installation terminée, cliquez sur Suivant.

    Remarque Remarque

    L'installation peut sembler bloquée pendant plusieurs minutes pendant l'activation de SQL Server Reporting Services.

  17. Cliquez sur Terminer pour quitter l'Assistant.

    Remarque Remarque

    Pour vérifier votre installation avant d'installer Team Foundation Server, consultez Comment : vérifier l'installation de Microsoft SQL Server 2005.

Installation du correctif pour Microsoft SQL Server 2005

Après avoir installé Microsoft SQL Server 2005, vous devez installer le correctif de mise à jour de SQL Server Analysis Services qui prend plus efficacement en charge la création de rapports.

Remarque Remarque

Pour obtenir les mises à jour les plus récentes, visitez le site Web de Microsoft (http://go.microsoft.com/fwlink/?LinkId=62015).

Pour installer le correctif pour Microsoft SQL Server 2005

  1. Sur l'ordinateur de couche Données, ouvrez le Gestionnaire de configuration SQL Server, cliquez avec le bouton droit sur Service SQL Server Browser, puis cliquez sur Arrêter.

  2. Sur le support d'installation de Team Foundation Server, recherchez le dossier SQLServerKB.

  3. Recherchez le fichier exécutable (.exe) pour vos système d'exploitation et langue, par exemple AS2005-KBnnnnnn-x86-ENU.exe, puis double-cliquez sur le fichier pour démarrer le programme d'installation du correctif.

  4. Dans Programme d'installation de correctifs, acceptez le Contrat de Licence Utilisateur Final, terminez la procédure pour installer le correctif, puis cliquez sur Terminer.

  5. Dans Gestionnaire de configuration SQL Server, cliquez avec le bouton droit sur Service SQL Server Browser, puis cliquez sur Propriétés.

  6. Sous l'onglet Service, recherchez Mode de démarrage et sélectionnez Automatique.

  7. Sous l'onglet Ouvrir une session, cliquez sur Démarrer.

    Remarque Remarque

    Si Démarrer n'est pas activité sous l'onglet Ouvrir une session, cliquez sur l'onglet Service, définissez Mode de démarrage à Désactivé, puis sélectionnez de nouveau Automatique pour mettre à jour explicitement le Mode de démarrage.

Pour vérifier votre installation avant d'installer Windows SharePoint Services, consultez Comment : vérifier l'installation de Microsoft SQL Server 2005.

Sécurité

Pour effectuer ces procédures, vous devez être membre du groupe de sécurité Administrateurs sur l'ordinateur. Le compte d'utilisateur employé pour l'installation est désigné sous le nom de Domaine\\TFSSETUP dans ce guide. Si vous utilisez le même compte pour installer Team Foundation Server, ce compte est automatiquement ajouté au groupe de sécurité Team Foundation Administrators lors de l'installation. Pour plus d'informations, consultez Comptes d'utilisateurs requis pour l'installation de Team Foundation Server.

Les services Microsoft SQL Server 2005 nécessitent l'ouverture de certains ports. Pour plus d'informations, consultez Ports requis pour l'installation de Team Foundation Server.

Voir aussi

Autres ressources

Installation de Team Foundation Server (bases de données)
Vue d'ensemble de l'installation de Team Foundation Build
Vue d'ensemble de l'installation de Team Foundation Server Proxy


Comment : vérifier l'installation de Microsoft SQL Server 2005

Comment : vérifier l'installation de Microsoft SQL Server 2005
Voir aussi

Après avoir installé SQL Server, vous pouvez vérifier que l'installation est terminée et que le serveur est configuré pour l'étape suivante de l'installation de Team Foundation Server. Les procédures suivantes présentent les étapes permettant de vérifier les configurations suivantes.

  • Les services fonctionnent.

  • Les paramètres de connexion sont configurés.

  • Le pare-feu est correctement configuré.

Attention Attention

L'Assistant Installation de Team Foundation Server configure les composants pour vous au cours de l'installation. Limitez votre vérification à l'examen des éléments qui fonctionnent et sont définis comme indiqué dans les procédures suivantes. Si vous essayez de configurer Reporting Services à ce stade, vous pouvez empêcher le bon déroulement de l'installation et de la configuration de Team Foundation Server.

Pour vérifier que les services fonctionnent

  1. Dans le menu Démarrer, cliquez sur Tous les programmes, Microsoft SQL Server 2005, Outils de configuration, puis sur Gestionnaire de configuration SQL Server.

  2. Sélectionnez Services SQL Server 2005 et vérifiez que chaque service comporte une flèche de couleur verte qui indique que le service fonctionne.

  3. Sélectionnez Configuration du réseau SQL Server 2005, cliquez sur Protocoles pour MSSQLServer, puis vérifiez que TCP/IP est activé.

Pour vérifier une connexion au serveur

  1. Dans le menu Démarrer, cliquez sur Tous les programmes, sur Microsoft SQL Server 2005, puis sur SQL Server Management Studio.

  2. Dans la boîte de dialogue Se connecter au serveur, sélectionnez Moteur de base de données dans Type de serveur, tapez le nom du serveur auquel vous souhaitez vous connecter, puis cliquez sur Se connecter.

    Remarque Remarque

    Si SQL Server est installé sur un cluster, le nom du serveur est le nom du cluster et non de l'ordinateur.

  3. Dans l'Explorateur d'objets, vérifiez qu'une flèche de couleur verte apparaît en regard du nom de serveur.

    Remarque Remarque

    Si vous ne parvenez pas à vous connecter au serveur, vérifiez les paramètres du pare-feu, puis essayez à nouveau de vous connecter.

Sécurité

Pour effectuer ces procédures, vous devez être membre du groupe de sécurité Administrateurs sur l'ordinateur. Pour plus d'informations, consultez Comptes d'utilisateurs requis pour l'installation de Team Foundation Server.

Voir aussi

Tâches

Comment : installer Microsoft SQL Server 2005 pour Team Foundation Server (déploiement sur un serveur)
Comment : installer Microsoft SQL Server 2005 pour Team Foundation Server (déploiement sur deux serveurs)

Référence

Liste de vérification : déploiement sur un serveur de Team Foundation Server
Liste de vérification : déploiement de Team Foundation Server sur deux serveurs


Comment : installer Team Foundation Server (bases de données)

Comment : installer Team Foundation Server (bases de données)
Voir aussi

Utilisez cette procédure pour installer les composants de la couche Données de Team Foundation Server.

Avant d'installer Team Foundation Server, assurez-vous que Microsoft SQL Server 2005 Standard Edition ou Enterprise Edition est installé et en cours d'exécution. Remplissez toutes les conditions préalables de la couche Données. Pour plus d'informations, consultez Liste de vérification : déploiement de Team Foundation Server sur deux serveurs.

Pour installer Team Foundation Server (bases de données)

  1. Ouvrez une session Windows à l'aide du compte que vous avez utilisé pour l'installation de Team Foundation Server (par exemple, Domaine\TFSSETUP) et identifié lors de l'utilisation de la liste de vérification.

  2. Insérez le support d'installation de Team Foundation Server et, à la page d'exécution automatique, cliquez sur Installez Team Foundation Server, sur Installation sur deux serveurs, puis sur Installez UNIQUEMENT la couche de base de données de Team Foundation.

    Si la page d'exécution automatique ne s'affiche pas, localisez et exécutez le fichier d'exécution automatique (autorun.exe) situé dans le dossier racine du support d'installation.

    L'Assistant Installation de Visual Studio 2005 Team Foundation Server (bases de données) démarre.

  3. À la page Bienvenue dans le programme d'installation, cliquez sur Suivant.

  4. Sur la page Termes de Licence, examinez le contrat de licence. Si vous acceptez les termes et conditions mentionnés, sélectionnez J'accepte les termes du contrat de licence, puis cliquez sur Suivant.

  5. À la page Dossier de destination, cliquez sur Suivant.

  6. Sur la page Vérification de la santé du système, examinez les avertissements ou blocs éventuels en cliquant sur le lien de rapport.

    • Les blocs doivent être traités avant de pouvoir poursuivre l'installation. Cliquez sur Annuler et réexécutez le programme d'installation après avoir corrigé les problèmes.

    • Les avertissements doivent être traités avant de continuer, mais ne doivent pas empêcher le déroulement de l'installation. Vous pouvez cliquer sur Suivant.

      Par exemple, si aucun pare-feu n'est activé, un avertissement apparaît dans la liste. Vous pouvez continuer l'installation, mais il est possible que vous deviez ajouter manuellement les ports et exceptions nécessaires à l'activation des communications entre les composants.

    • Si rien n'est répertorié, cliquez sur Suivant.

  7. À la page Prêt pour l'installation, cliquez sur Installer.

  8. Sur la page Installation des composants, surveillez l'installation des composants de la couche Données de Team Foundation.

    Pendant l'installation, vous pouvez être invité à redémarrer votre ordinateur. Cliquez sur Redémarrer maintenant. L'installation reprend après le redémarrage de l'ordinateur et vous ouvrez une nouvelle session à l'aide du même compte.

  9. À la page L'installation s'est terminée avec succès, cliquez sur Terminer.

  10. Sur la page d'exécution automatique, cliquez sur Quitter.

Pour afficher les bases de données Team Foundation Server

  1. Cliquez sur Démarrer, sur Program Files, sur Microsoft SQL Server 2005, puis sur SQL Server Management Studio.

  2. Dans la boîte de dialogue Se connecter au serveur, sélectionnez Moteur de base de données dans Type de serveur, tapez le nom du serveur auquel vous souhaitez vous connecter, puis cliquez sur Se connecter.

    Remarque Remarque

    Si SQL Server est installé sur un cluster, le nom du serveur est le nom du cluster et non de l'ordinateur.

  3. Dans l'Explorateur d'objets, développez Bases de données et vérifiez que les bases de données Team Foundation Server existent.

Sécurité

Pour effectuer cette procédure, vous devez être membre du groupe de sécurité Administrateurs sur l'ordinateur. Le compte d'utilisateur employé pour l'installation est désigné sous le nom de Domaine\\TFSSETUP dans ce guide. Si vous utilisez le même compte pour installer Team Foundation Server, ce compte est automatiquement ajouté au groupe de sécurité Team Foundation Administrators lors de l'installation. Pour plus d'informations, consultez Comptes d'utilisateurs requis pour l'installation de Team Foundation Server.

Voir aussi

Autres ressources

Installation de Team Foundation Server (bases de données)


Installation de Team Foundation Server (services)

Installation de Team Foundation Server (services)
Voir aussi
DropDown image

Utilisez les procédures de cette section pour installer et configurer des composants de la couche Application de Team Foundation Server et leurs composants requis sur un serveur distinct de celui des composants de la couche Données.

Ces composants et composants requis sont les suivants :

Composant | Ordre d'installation
Internet Information Services (IIS) 6.0 | Premièrement (composant requis pour les composants Team Foundation Server de la couche Application)
SQL Server 2005 Reporting Services | Deuxièmement (composant requis pour les composants Team Foundation Server de la couche Application)
Windows SharePoint Services avec Service Pack 2 | Troisièmement (composant requis pour les composants Team Foundation Server de la couche Application)
Composants Team Foundation Server de la couche Application | Quatrièmement

Pour une vue d'ensemble du processus entier d'installation de Team Foundation Server sur deux ordinateurs, consultez Procédure pas à pas : installation du déploiement de Team Foundation Server sur deux serveurs.

Dans cette section

Comment : installer les services IIS (Internet Information Services) pour Team Foundation Server

Décrit comment installer et configurer Internet Information Services (IIS) 6.0 sur la couche Application.

Comment : installer Microsoft SQL Server 2005 Reporting Services pour Team Foundation Server (déploiement sur deux serveurs)

Décrit comment installer SQL Server 2005 Reporting Services sur la couche Application lors d'un déploiement de Team Foundation Server sur deux serveurs.

Comment : installer Microsoft Windows SharePoint Services pour Team Foundation Server (déploiement sur deux serveurs)

Décrit comment installer et configurer Windows SharePoint Services sur la couche Application.

Comment : installer Team Foundation Server (services)

Décrit comment installer les composants Team Foundation Server de la couche Application.

Voir aussi

Autres ressources

Vue d'ensemble du déploiement de Team Foundation Server sur deux serveurs
Installation de Team Foundation Server (bases de données)


Comment : installer les services IIS (Internet Information Services) pour Team Foundation Server

Comment : installer les services IIS (Internet Information Services) pour Team Foundation Server
Voir aussi

Utilisez cette procédure pour installer les services IIS (Internet Information Services) version 6.0 sur la couche Application de Team Foundation Server.

Pour configurer le serveur comme un serveur d'applications

  1. Démarrez l'Assistant Configurer votre serveur en effectuant l'une des opérations suivantes :

    • Par défaut, Gérer votre serveur démarre automatiquement au démarrage de Windows. Dans Gérer votre serveur, cliquez sur Ajouter ou supprimer un rôle.

    • Dans le Panneau de configuration, ouvrez Outils d'administration, puis Assistant Configurer votre serveur.

  2. À la page Bienvenue dans l'Assistant Configurer votre serveur, cliquez sur Suivant.

  3. À la page Étapes préliminaires, cliquez sur Suivant.

  4. Sur la page Rôle du serveur, cliquez sur Serveur d'applications (IIS, ASP.NET), puis sur Suivant.

  5. À la page Options du serveur d'applications, sélectionnez Activer ASP.NET, puis cliquez sur Suivant.

    Remarque Important

    Ne sélectionnez pas Extensions serveur FrontPage. Ce serveur héberge Windows SharePoint Services, qui est incompatible avec les extensions serveur FrontPage.

  6. À la page Aperçu des sélections, cliquez sur Suivant.

    Remarque Remarque

    Votre support d'installation de Windows Server 2003 peut vous être demandé.

  7. Cliquez sur Terminer pour interrompre l'Assistant.

  8. Visitez le site Windows Update (http://windowsupdate.microsoft.com) et installez tous les éléments du groupe Critical Updates and Service Packs.

Pour activer ASP.NET à l'aide de l'utilitaire Ajout/Suppression de programmes

  1. Dans le Panneau de configuration, ouvrez Ajout/Suppression de programmes.

  2. Cliquez sur Ajouter/Supprimer des composants Windows.

    L'Assistant Composants de Windows démarre.

  3. À la page Composants Windows, sélectionnez Serveur d'applications, puis cliquez sur Détails.

  4. Le cas échéant, sélectionnez ASP.NET, puis cliquez sur OK.

    Remarque Important

    Ne sélectionnez pas Extensions serveur FrontPage 2002 n'importe quand. Ce serveur héberge Windows SharePoint Services, qui est incompatible avec les extensions serveur FrontPage.

  5. À la page Composants Windows, cliquez sur Suivant.

    Remarque Remarque

    Votre support d'installation de Windows Server 2003 peut vous être demandé.

  6. Cliquez sur Terminer pour fermer l'Assistant.

  7. Visitez le site Windows Update (http://windowsupdate.microsoft.com) et installez tous les éléments du groupe Critical Updates and Service Packs.

Sécurité

Pour effectuer ces procédures, vous devez être membre du groupe de sécurité Administrateurs sur l'ordinateur. Le compte d'utilisateur employé pour l'installation est désigné sous le nom de Domaine\\TFSSETUP dans ce guide. Si vous utilisez le même compte pour installer Team Foundation Server, ce compte est automatiquement ajouté au groupe de sécurité Team Foundation Administrators lors de l'installation. Pour plus d'informations, consultez Comptes d'utilisateurs requis pour l'installation de Team Foundation Server.

Voir aussi

Autres ressources

Installation de Team Foundation Server (services)


Comment : installer Microsoft SQL Server 2005 Reporting Services pour Team Foundation Server (déploiement sur deux serveurs)

Comment : installer Microsoft SQL Server 2005 Reporting Services pour Team Foundation Server (déploiement sur deux serveurs)
Voir aussi

Utilisez ces procédures pour installer Microsoft SQL Server 2005 Reporting Services pour Microsoft SQL Server 2005 Standard ou Enterprise Edition. Vous pouvez effectuer l'installation de façon interactive à l'aide de l'Assistant Installation ou d'un fichier de réponses.

Remarque Remarque

Avant l'installation, l'ordinateur doit disposer des services IIS et ASP.NET doit être activé.

Installer Microsoft SQL Server 2005 Reporting Services à l'aide d'un fichier de réponses

Vous pouvez installer Microsoft SQL Server 2005 Reporting Services à l'aide du fichier de réponses fourni à partir de la ligne de commande. Ce fichier de réponses automatise l'installation pour installer et configurer Microsoft SQL Server 2005 Reporting Services en vue d'une utilisation avec Team Foundation Server.

Pour installer Microsoft SQL Server 2005 Reporting Services à l'aide d'un fichier de réponses

  1. Sur l'ordinateur de couche Application, ouvrez une session Windows à l'aide du compte utilisé pour l'installation de Team Foundation Server (par exemple, Domaine\TFSSETUP).

  2. Sur le support d'installation de Team Foundation Server, localisez et copiez le fichier de réponses automatique et préconfiguré (SQL2005ForAT.ini) dans un emplacement commode sur le disque dur local (par exemple, C:\).

  3. Exécutez le programme d'installation pour Microsoft SQL Server 2005 en utilisant la ligne de commande suivante :

    C:\>SQLServerSetupDirectory\setup.exe /qb /settings AnswerFileDirectory\SQL2005ForAT.ini PIDKEY=ProductKey

    Où SQLServerSetupDirectory est le chemin d'accès à setup.exe pour Microsoft SQL Server 2005, AnswerFileDirectory est le chemin d'accès au fichier de réponses et ProductKey est la clé du produit pour Microsoft SQL Server 2005 sans tirets ni espaces.

    Remarque Important

    L'Assistant Installation de Visual Studio Team Foundation Server (services) configure Reporting Services pour une utilisation avec la couche Données pour vous. L'emploi de l'outil de configuration de Reporting Services à ce stade peut empêcher l'Assistant de configurer correctement les services.

Installer Microsoft SQL Server 2005 Reporting Services de façon interactive

Installez SQL Server 2005 Reporting Services à l'aide de Microsoft SQL Server 2005 Standard ou Enterprise Edition. Team Foundation Server inclut une copie sous licence de Microsoft SQL Server 2005 Standard Edition.

Remarque Remarque

Vous devez installer les services IIS (Internet Information Services) version 6.0 avant d'installer Microsoft SQL Server 2005 Reporting Services.

Pour installer Microsoft SQL Server 2005 Reporting Services de façon interactive

  1. Sur l'ordinateur de couche Application, ouvrez une session Windows à l'aide du compte utilisé pour l'installation de Team Foundation Server (par exemple, Domaine\TFSSETUP).

  2. Insérez le CD-ROM pour Microsoft SQL Server 2005 et, sous Installer à la page Démarrage de SQL Server 2005, cliquez sur Composants serveur, documentation en ligne et exemples.

    Remarque Remarque

    Le CD-ROM de Microsoft SQL Server 2005 Standard Edition est disponible avec Team Foundation Server. Pour installer SQL Server Enterprise Edition, vous pouvez utiliser le CD-ROM du logiciel que vous avez acheté séparément. La page de démarrage est disponible en exécutant le fichier Splash.hta situé dans le dossier Servers du support d'installation.

    L'Assistant Installation de Microsoft SQL Server 2005 démarre.

  3. À la page Contrat de Licence Utilisateur Final, passez en revue le contrat de licence. Si vous acceptez les termes et conditions mentionnés, sélectionnez J'accepte les termes et conditions du contrat de licence, puis cliquez sur Suivant.

  4. À la page Installation de la configuration requise, cliquez sur Installer. Une fois les composants requis correctement installés, cliquez sur Suivant.

    L'Assistant Installation de Microsoft SQL Server démarre.

  5. Cliquez sur Suivant pour démarrer l'analyse de la configuration système.

  6. Sur la page Analyse de la configuration système, examinez l'état de toutes les actions requises, par exemple les redémarrages du système requis, et suivez les consignes qui figurent sur cette page jusqu'à ce que toutes les actions obtiennent l'état Opérations réussies. Une fois que toutes les actions ont obtenu l'état Succès, cliquez sur Suivant pour démarrer l'installation.

    Remarque Remarque

    Le démarrage du programme d'installation peut prendre un certain temps.

  7. À la page Informations d'inscription, complétez les informations d'inscription, puis cliquez sur Suivant.

  8. À la page Composants à installer, sélectionnez Reporting Services, puis cliquez sur Suivant.

    Remarque Remarque

    Si vous cliquez sur Avancé, ne supprimez aucune sélection par défaut.

  9. À la page Nom de l'instance, sélectionnez Instance par défaut, puis cliquez sur Suivant.

    Remarque Important

    L'installation de Team Foundation Server échouera si vous spécifiez une instance nommée.

  10. Sur la page Compte de service, sélectionnez Utiliser le compte système par défaut, puis Service réseau dans la liste. Dans Démarrer les services une fois l'installation terminée, sélectionnez Reporting Services, puis cliquez sur Suivant.

  11. Sur la page Options d'installation du serveur de rapports, cliquez sur Suivant.

    Par défaut, l'option Installer mais ne pas configurer le serveur est sélectionnée.

  12. À la page Paramètres de rapports d'erreurs et d'utilisation, vous pouvez éventuellement sélectionner Envoyer des rapports d'erreurs pour SQL Server 2005 à Microsoft ou votre serveur de rapports d'erreurs d'entreprise et Envoyer automatiquement des données d'utilisation des fonctionnalités de SQL Server 2005 à Microsoft., puis cliquer sur Suivant.

  13. À la page Prêt pour l'installation, vous pouvez passer en revue la liste des composants à installer, puis cliquer sur Installer.

  14. À la page Installation en cours, vous pouvez contrôler l'état de l'installation de chaque composant. Une fois l'installation terminée, cliquez sur Suivant.

    Remarque Remarque

    L'installation peut sembler bloquée pendant plusieurs minutes pendant l'activation de SQL Server Reporting Services.

  15. Cliquez sur Terminer pour quitter l'Assistant.

Attention Attention

N'utilisez pas l'outil de configuration de Reporting Services pour vérifier que les services fonctionnent. L'Assistant Installation de Team Foundation Server configure Reporting Services pour vous et l'ouverture de l'outil peut interrompre l'installation.

Vérification de l'installation de Reporting Services

Après l'installation, vérifiez que les services fonctionnent et sont configurés pour démarrer automatiquement.

Pour vérifier l'installation

  1. Cliquez sur Démarrer, sur Outils d'administration, puis sur Services.

  2. Dans la colonne Nom du Gestionnaire des services, recherchez SQL Server Reporting Services et vérifiez que l'option État a la valeur Démarré et que le Type de démarrage est Automatique.

    Remarque Remarque

    Vous pouvez modifier l'état ou le type de démarrage en cliquant avec le bouton droit sur le service, en cliquant sur Propriétés, puis en apportant les modifications.

  3. Fermez le Gestionnaire des services.

    Après avoir vérifié les services, vous devez installer le correctif pour Microsoft .NET Framework. Pour plus d'informations, consultez Liste de vérification : déploiement de Team Foundation Server sur deux serveurs.

Sécurité

Pour effectuer ces procédures, vous devez être membre du groupe de sécurité Administrateurs sur l'ordinateur. Le compte d'utilisateur employé pour l'installation est désigné sous le nom de Domaine\\TFSSETUP dans ce guide. Si vous utilisez le même compte pour installer Team Foundation Server, ce compte est automatiquement ajouté au groupe de sécurité Team Foundation Administrators lors de l'installation. Pour plus d'informations, consultez Comptes d'utilisateurs requis pour l'installation de Team Foundation Server. Les services Microsoft SQL Server 2005 nécessitent l'ouverture de certains ports. Pour plus d'informations, consultez Ports requis pour l'installation de Team Foundation Server.

Voir aussi

Autres ressources

Installation de Team Foundation Server (bases de données)


Comment : installer Microsoft Windows SharePoint Services pour Team Foundation Server (déploiement sur deux serveurs)

Comment : installer Microsoft Windows SharePoint Services pour Team Foundation Server (déploiement sur deux serveurs)
Voir aussi

Utilisez la procédure suivante pour installer Microsoft Windows SharePoint Services avec Service Pack 2 pour Team Foundation Server en mode silencieux à partir de la ligne de commande ou de façon interactive à l'aide de l'Assistant Installation.

Avant d'installer Team Foundation Server sur une version localisée de Windows SharePoint Services, vous devez installer le module de prise en charge linguistique de Windows SharePoint Services qui correspond à la langue de Team Foundation Server. Par exemple, vous devez installer le module de prise en charge linguistique en anglais de Windows SharePoint Services avant d'installer la version anglaise de Team Foundation Server.

Remarque Important

Windows SharePoint Services nécessite un système de fichiers NTFS.

Installer Microsoft Windows SharePoint Services en mode silencieux

Vous pouvez installer Windows SharePoint Services en mode silencieux à partir de la ligne de commande.

Pour installer Windows SharePoint Services silencieusement

  1. Sur l'ordinateur de couche Application, ouvrez une session Windows à l'aide du compte utilisé pour l'installation de Team Foundation Server (par exemple, Domaine\TFSSETUP).

  2. Téléchargez Microsoft Windows SharePoint Services avec Service Pack 2 (http://go.microsoft.com/fwlink/?linkid=55087) et enregistrez le fichier dans un emplacement pratique de votre disque dur local.

  3. Exécutez le fichier programme d'installation à extraction automatique téléchargé (stsv2.exe) à l'aide de la ligne de commande suivante :

    C:\>DownloadDirectory\STSV2.EXE /C:"setupsts.exe /remoteSql=yes /provision=no /q"

    Où DownloadDirectory est le chemin d'accès à l'emplacement sur votre disque dur où vous avez enregistré le fichier téléchargé.

    Remarque Important

    Vous devez installer Windows SharePoint Services à l'aide de l'option /remoteSql=yes. Windows SharePoint Services est ainsi configuré pour utiliser un serveur SQL Server distant. L'option /provision=no différera la configuration de Windows SharePoint Services. Plus tard, le programme d'installation de Team Foundation Server configurera Windows SharePoint Services pour utiliser la même instance de SQL Server que le reste de Team Foundation Server.

    Vous ne recevrez aucune indication de fin de l'installation. À la place, attendez plusieurs minutes que l'installation se termine avant de continuer.

  4. Visitez le site Windows Update (http://windowsupdate.microsoft.com) et installez tous les éléments du groupe Critical Updates and Service Packs.

  5. Redémarrez l'ordinateur.

Installer Microsoft Windows SharePoint Services de manière interactive

Installez Microsoft Windows SharePoint Services avec Service Pack 2.

Pour installer Windows SharePoint Services de façon interactive

  1. Sur l'ordinateur de couche Application, ouvrez une session Windows à l'aide du compte utilisé pour l'installation de Team Foundation Server (par exemple, Domaine\TFSSETUP).

  2. Téléchargez Microsoft Windows SharePoint Services avec Service Pack 2 (http://go.microsoft.com/fwlink/?linkid=55087) et enregistrez le fichier sur votre disque dur local.

  3. Exécutez le fichier programme d'installation à extraction automatique téléchargé (stsv2.exe).

  4. À la page Contrat de Licence Utilisateur Final, prenez connaissance du contrat de licence. Si vous acceptez les termes et conditions mentionnés, sélectionnez J'accepte les termes du contrat de licence, puis cliquez sur Suivant.

  5. À la page Type d'instance, sélectionnez Batterie de serveurs, puis cliquez sur Suivant.

    Remarque Important

    Vous devez installer Windows SharePoint Services à l'aide de l'option Batterie de serveurs. Windows SharePoint Services est ainsi configuré pour utiliser un serveur SQL Server distant. Plus tard, le programme d'installation de Team Foundation Server configurera Windows SharePoint Services pour utiliser la même instance de SQL Server que le reste de Team Foundation Server.

  6. À la page Résumé, cliquez sur Installer.

    Lorsque l'installation est terminée, une fenêtre de navigateur Web s'ouvre et affiche la page Configurer le serveur virtuel d'administration. Après avoir confirmé que la page apparaît, fermez la fenêtre du navigateur sans apporter de modifications.

    Remarque Important

    N'apportez pas de modifications sur la page qui apparaît. Plus tard, le programme d'installation de Team Foundation Server configurera Windows SharePoint Services pour utiliser la même instance de SQL Server que le reste de Team Foundation Server.

    Si la page n'apparaît pas, vous devez déterminer la cause et résoudre le problème à l'aide du Guide de l'administrateur Windows SharePoint Services (http://go.microsoft.com/fwlink/?LinkId=52668).

  7. Visitez le site Windows Update (http://windowsupdate.microsoft.com) et installez tous les éléments du groupe Critical Updates and Service Packs.

  8. Redémarrez l'ordinateur.

Vérification de l'installation

Après avoir installé Windows SharePoint Server, vous pouvez vous assurer que les services fonctionnent même si vous n'avez pas installé Team Foundation Server.

Pour vérifier que Windows SharePoint Services est installé

  • Ouvrez Internet Explorer et tapez le nom de serveur en tant qu'adresse.

    Par exemple, pour un serveur nommé ADATUM, vous tapez Http://adatum.

    Même si un site n'est pas configuré, le serveur est un serveur Web actif et propose une page En construction.

Sécurité

Pour effectuer ces procédures, vous devez être membre du groupe de sécurité Administrateurs sur l'ordinateur. Le compte d'utilisateur employé pour l'installation est désigné sous le nom de Domaine\\TFSSETUP dans ce guide. Si vous utilisez le même compte pour installer Team Foundation Server, ce compte est automatiquement ajouté au groupe de sécurité Team Foundation Administrators lors de l'installation. Pour plus d'informations, consultez Comptes d'utilisateurs requis pour l'installation de Team Foundation Server.

Voir aussi

Référence

Liste de vérification : déploiement de Team Foundation Server sur deux serveurs

Autres ressources

Installation de Team Foundation Server (services)


Comment : installer Team Foundation Server (services)

Comment : installer Team Foundation Server (services)
Voir aussi

Utilisez cette procédure pour installer les composants de la couche Application de Team Foundation Server. Avant d'effectuer cette procédure, installez l'ordinateur de couche Données ainsi que les composants requis de la couche Application.

Pour plus d'informations, consultez Installation de Team Foundation Server (services).

Pour installer Team Foundation Server (services)

  1. Sur l'ordinateur de couche Application, ouvrez une session Windows à l'aide du compte utilisé pour l'installation de Team Foundation Server (par exemple, Domaine\TFSSETUP).

  2. Insérez le CD-ROM et, à la page d'exécution automatique, cliquez sur Installez Team Foundation Server, sur Installation sur deux serveurs, puis sur Installez UNIQUEMENT la couche d'application de Team Foundation.

    Si la page d'exécution automatique ne s'affiche pas, localisez et exécutez le fichier d'exécution automatique (autorun.exe) situé dans le dossier racine du support d'installation.

    L'Assistant Installation de Visual Studio Team Foundation Server (services) démarre.

  3. À la page Bienvenue dans le programme d'installation, cliquez sur Suivant.

  4. Sur la page Termes de Licence, examinez le contrat de licence. Si vous acceptez les termes et conditions mentionnés, sélectionnez J'accepte les termes du contrat de licence, puis cliquez sur Suivant.

    L'Assistant Installation analyse votre système à la recherche de conditions qui peuvent provoquer l'échec de l'installation ou des problèmes par la suite lors du fonctionnement du serveur.

  5. À la page Dossier de destination et serveur de base de données, tapez les informations suivantes :

    • Dans la zone Dossier de destination, tapez le chemin d'installation ou acceptez la valeur par défaut.

    • Dans la zone Serveur de base de données, tapez le nom de l'ordinateur sur lequel vous avez installé Team Foundation Server (bases de données).

      Remarque Remarque

      Vous devez utiliser le nom de l'ordinateur, et non pas l'adresse IP.

  6. Sur la page Vérification de la santé du système, examinez les avertissements ou blocs éventuels en cliquant sur le lien de rapport.

    • Les blocs doivent être traités avant de pouvoir poursuivre l'installation. Cliquez sur Annuler et réexécutez le programme d'installation après avoir corrigé les problèmes.

    • Les avertissements doivent être traités avant de continuer, mais ne doivent pas empêcher le déroulement de l'installation. Vous pouvez cliquer sur Suivant.

    • Si rien n'est répertorié, cliquez sur Suivant.

  7. À la page Compte de service, entrez les informations sur le compte pour le compte de service Team Foundation Server (par exemple,Domaine\TFSSERVICE), puis cliquez sur Suivant.

  8. À la page Compte d'ouverture de session de création de rapports, entrez les informations sur le compte pour le compte de rapports de Team Foundation Server (par exemple,Domaine\TFSREPORTS), puis cliquez sur Suivant.

    Remarque Remarque

    Ce compte ne doit pas être le même que les comptes de service ou d'installation de Team Foundation Server.

  9. À la page Alertes Team Foundation, tapez les informations suivantes :

    1. Dans la zone Serveur SMTP, tapez le nom du serveur que vous utiliserez pour envoyer des alertes Team Foundation.

    2. Dans la zone Adresse de messagerie De, tapez le nom de l'adresse de messagerie pour l'envoi des alertes Team Foundation, puis cliquez sur Suivant.

      Remarque Remarque

      Si vous voulez activer les alertes à ce stade, vous devez connaître le serveur SMTP de votre organisation. Team Foundation Server ne nécessite aucun paramètre de configuration spécifique pour un accès à SMTP uniquement. L'installation et la configuration de SMTP ne sont pas traitées dans cette documentation. Pour plus d'informations, consultez la documentation de Windows Server 2003.

  10. À la page Prêt pour l'installation, cliquez sur Installer.

    Pendant l'installation, vous pouvez être invité à redémarrer l'ordinateur. Cliquez sur Redémarrer maintenant pour que l'installation reprenne après le redémarrage de l'ordinateur et l'ouverture d'une nouvelle session.

  11. À la page L'installation s'est terminée avec succès, cliquez sur Terminer.

    Après avoir installé Team Foundation Server, vous devez sauvegarder la clé de chiffrement de Reporting Services à l'aide de l'outil de configuration de Reporting Services. Cette étape n'est pas obligatoire pour la création de projets d'équipe, mais fait partie des méthodes conseillées pour la gestion de Team Foundation Server. Pour plus d'informations, consultez « Comment : sauvegarder la clé de chiffrement de Reporting Services » dans le Guide de l'administrateur Team Foundation Server.

  12. Dans Internet Explorer, recherchez http://localhost:8080/services/v1.0/Registration.asmx, puis cliquez sur GetRegistrationEntries.

  13. Sur la page GetRegistrationEntries, cliquez sur Appeler. Vous n'avez pas à entrer de ToolID.

    Remarque Remarque

    Pour utiliser cette méthode Web, vous devez vous trouver sur l'ordinateur de couche Application.

  14. Dans le document XML, vérifiez que le type VSTF se présente comme illustré ici, puis fermez.

    <?xml version="1.0" encoding="utf-8" ?>

    <Type>vstfs</Type>

    Remarque Remarque

    Après avoir installé Team Foundation Server, vous pouvez installer Team Explorer, Team Team Foundation Build ou Team Foundation Server Proxy.

Sécurité

Pour effectuer cette procédure, vous devez être membre du groupe de sécurité Administrateurs sur l'ordinateur. Le compte d'utilisateur employé pour l'installation est désigné sous le nom de Domaine\\TFSSETUP dans ce guide. Si vous utilisez le même compte pour installer Team Foundation Server, ce compte est automatiquement ajouté au groupe de sécurité Team Foundation Administrators lors de l'installation. Pour plus d'informations, consultez Comptes d'utilisateurs requis pour l'installation de Team Foundation Server.

Voir aussi

Autres ressources

Installation de Team Foundation Server (services)
Vue d'ensemble de l'installation de Team Foundation Build
Vue d'ensemble de l'installation de Team Foundation Server Proxy


Garantie de la disponibilité continue des serveurs

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Garantie de la disponibilité continue des serveurs
Voir aussi
Image de liste déroulante

Afin de fournir un service continu aux clients du système lors des opérations de maintenance ou dans le cas d'une défaillance du serveur, vous pouvez ajouter des ordinateurs au système Team Foundation et les configurer afin qu'ils prennent le contrôle des services de couche Application ou de couche Données.

Dans cette section

Liste de vérification : déploiement de Team Foundation Server dans un cluster

Fournit un résumé des éléments requis avant d'installer les bases de données Team Foundation dans un cluster.

Comment : préparer un cluster pour l'installation de la couche Données

Présente les étapes que vous devez effectuer avant d'installer les bases de données Team Foundation dans un cluster.

Comment : accélérer la récupération d'un serveur dans un cluster

Fournit la procédure d'utilisation d'un fichier de script pour redémarrer de façon explicite les services entre la couche Données d'un cluster et la couche Application.

Liste de vérification : configuration d'une couche Application de secours

Fournit un résumé des étapes que vous devez effectuer pour configurer un ordinateur de secours afin de prendre en charge les services de la couche Application.

Comment : configurer une couche Application de secours

Décrit les étapes que vous devez effectuer pour configurer un ordinateur de secours automatique pour la couche Application de Team Foundation.

Rubriques connexes

Vue d'ensemble du déploiement de Team Foundation Server sur deux serveurs

Utilisez les procédures de cette section pour installer et configurer Team Foundation Server à l'aide de deux ordinateurs, un pour les composants de la couche Données et un autre pour les composants de la couche Application.

Ressources en ligne

Guide de l'administrateur Team Foundation (http://go.microsoft.com/fwlink/?LinkId=52459).

Voir aussi

Concepts

Installation de Team Foundation


Liste de vérification : déploiement de Team Foundation Server dans un cluster

 Image de liste déroulante Image de pointage sur liste déroulante Image de réduction Image de développement Image Réduire tout Image Développer tout Copier l'image de pointage
Visual Studio Team System
Liste de vérification : déploiement de Team Foundation Server dans un cluster
Voir aussi
Image Réduire tout Image de liste déroulante

Pour garantir une disponibilité maximale pour Team Foundation, vous pouvez installer la couche Données dans un cluster. Utilisez cette liste de vérification comme vue d'ensemble des éléments dont vous avez besoin avant d'installer Team Foundation dans un cluster.

Image de développement Cluster de serveurs Windows 2003 et SQL Server 2005

Done (Terminé) | Étape
 | Récupérez la version la plus actuelle de ce guide, qui est téléchargeable à partir du Centre de téléchargement Microsoft (http://go.microsoft.com/fwlink/?LinkId=40042).
 | Installez Windows Server 2003 Enterprise Edition ou Windows Server 2003 Datacenter Edition
 | Configurez un seul cluster quorum qui prend en charge deux nœuds configurés pour le mode actif/passif.
 | Installez SQL Server 2005 y compris les composants d'analyse avec une adresse IP statique pour le nom de serveur virtuel du cluster et une adresse IP statique pour le nom de serveur virtuel de SQL Server.
 | Vérifiez que SQL Server 2005 est en cours d'exécution.
 | Vérifiez que chaque service SQL Server est configuré pour démarrer automatiquement. Pour plus d'informations, consultez Comment : préparer un cluster pour l'installation de la couche Données.
 | Effectuez une copie du dossier NetSetup pour la couche Données sur le lecteur local.
 | Modifiez le fichier msiproperty.ini en affectant au nom de clé VSTF_DB_SERVER le nom de serveur virtuel du cluster.

Image de développement Installation de Team Foundation Server (bases de données)

Done (Terminé) Étape

Vérifiez les configurations matérielle et logicielle requises. Pour plus d'informations, consultez Configuration de Team Foundation System.

Identifiez le compte d'utilisateur à employer pour exécuter le programme d'installation et ajoutez le compte au groupe Administrateurs local.

Il s'agit en général de votre compte d'utilisateur. Dans ce guide, ce compte est désigné sous le nom de Domain\TFSSETUP. Pour plus d'informations, consultez Comptes d'utilisateurs requis pour l'installation de Team Foundation Server.

Obtenez deux comptes de service pour assurer les communications entre les services utilisés par Team Foundation Server.

  • Compte pour exécuter les services Team Foundation (par exemple, Domain\TFSSERVICE).

  • Compte pour accéder aux sources de données SQL Server Reporting Services (par exemple, Domain\TFSREPORTS.

Pour plus d'informations, consultez Comptes d'utilisateurs requis pour l'installation de Team Foundation Server.

Sur le nœud actif, ajoutez le compte utilisé pour l'exécution du programme d'installation de Team Foundation Server (par exemple, Domain\TFSSETUP) au groupe local Administrateurs.

Sur le nœud actif, installez Microsoft SQL Server 2005 Standard ou Enterprise Edition comme instance par défaut de SQL Server sur cet ordinateur. Utilisez Système local comme compte de service. Installez le correctif indiqué à la fin de la rubrique d'installation.

Pour plus d'informations, consultez Comment : installer Microsoft SQL Server 2005 pour Team Foundation Server (déploiement sur deux serveurs).

Vérifiez votre installation de Microsoft SQL Server 2005 à l'aide des étapes décrites dans la rubrique Comment : vérifier l'installation de Microsoft SQL Server 2005 ou « Comment : vérifier une installation réussie des services SQL Server 2005 » dans la documentation en ligne de SQL Server (http://go.microsoft.com/fwlink/?LinkId=60404).

Sur le nœud actif, vérifiez que les ports appropriés sont ouverts.

Si vous utilisez le Pare-feu Windows, ou un logiciel de pare-feu ou une solution matérielle d'un tiers, vous devez faire en sorte que les ports requis soient ouverts pour autoriser la communication entre les composants. Pour plus d'informations, consultez Ports requis pour l'installation de Team Foundation Server.

Sur le nœud actif, installez Team Foundation Server (bases de données). Pour plus d'informations, consultez Comment : installer Team Foundation Server (bases de données).

Image de développement Installation de Team Foundation Server (services)

Vous devez installer les services d'application sur un ordinateur situé hors du cluster. Seules les bases de données Team Foundation peuvent se trouver dans un cluster.

Done (Terminé) Étape

Vérifiez que l'ordinateur de la couche Application répond à la configuration matérielle et logicielle requise. Pour plus d'informations, consultez Configuration de Team Foundation System.

Ajoutez le compte d'utilisateur pour exécuter le programme d'installation dans le groupe local des administrateurs. Dans ce guide, le compte est désigné sous le nom de Domain\TFSSETUP.

Pour plus d'informations, consultez Comptes d'utilisateurs requis pour l'installation de Team Foundation Server.

Installez les services IIS (Internet Information Services) 6.0 et activez ASP.NET.

Attention Attention

N'installez pas les extensions serveur FrontPage.

Pour plus d'informations, consultez Comment : installer les services IIS (Internet Information Services) pour Team Foundation Server.

Installez SQL Server 2005 Reporting Services (à l'aide de Microsoft SQL Server 2005 Standard ou Enterprise Edition) pour une utilisation avec Team Foundation Server.

Attention Attention

Ne configurez pas le serveur de rapports. Le programme d'installation de Team Foundation Server (services) termine la configuration des services pour vous.

Installez le correctif KB913393 pour Microsoft .NET Framework 2.0 disponible sur le support d'installation de Team Foundation Server.

Sur le support d'installation, recherchez le dossier KB913393, recherchez le fichier exécutable (.exe) pour votre plate-forme, puis double-cliquez sur le fichier à installer.

Installez Windows SharePoint Services avec Service Pack 2 en vue d'une utilisation avec Team Foundation Server et redémarrez.

Attention Attention

Ne configurez pas Windows SharePoint Services. Le programme d'installation de Team Foundation Server (services) effectue cette configuration pour vous.

Pour plus d'informations, consultez Comment : installer Microsoft Windows SharePoint Services pour Team Foundation Server (déploiement sur deux serveurs).

Installez Team Foundation Server (services). Pour plus d'informations, consultez Comment : installer Team Foundation Server (services).

Vérifiez pour le Pare-feu que les ports appropriés sont ouverts ou que SQL Server est fourni en tant qu'exception.

Si vous utilisez le Pare-feu Windows, ou un logiciel de pare-feu ou une solution matérielle d'un tiers, vous devez faire en sorte que les ports requis soient ouverts pour autoriser la communication entre les composants.

Pour plus d'informations, consultez Ports requis pour l'installation de Team Foundation Server.

Installez Team Explorer en local ou sur un autre ordinateur. Pour plus d'informations, consultez Vue d'ensemble de l'installation de Team Explorer.

Image de développement Voir aussi

Tâches

Comment : préparer un cluster pour l'installation de la couche Données


Comment : préparer un cluster pour l'installation de la couche Données

Comment : préparer un cluster pour l'installation de la couche Données
Voir aussi

Vous pouvez offrir un service ininterrompu à vos clients en exécutant la couche Données dans un cluster. Avant d'exécuter l'Assistant Installation de Team Foundation Server, vous devez préparer le cluster en vue de l'installation des bases de données Team Foundation.

Les procédures suivantes supposent que SQL Server 2005 est installé et en cours d'exécution dans un cluster. Pour plus d'informations, consultez « How to: Create a New SQL Server 2005 Failover Cluster (Setup) » [Comment : créer un nouveau cluster avec basculement SQL Server 2005 (Installation)] à l'adresse http://msdn2.microsoft.com/fr-fr/library/ms179530.aspx .

Pour effectuer cette procédure, vous devez connaître le nom de serveur virtuel et l'adresse IP pour SQL Server.

Pour préparer un cluster pour l'installation de la couche Données

  1. Ouvrez une session sur le nœud actif du cluster en tant qu'administrateur de cluster.

  2. Cliquez sur Démarrer, Microsoft SQL Server 2005, Outils de configuration, puis sur Gestionnaire de configuration SQL Server.

  3. Pour chaque service SQL Server ci-dessous, ouvrez la boîte de dialogue Propriétés et, sous l'onglet Service, affectez au Mode de démarrage la valeur Automatique.

    • SQL Server (MSSQLSERVER)

    • SQL Server Agent (MSSQLSERVER)

    • SQL Analysis Services (MSSQLSERVER)

    • SQL Server Integration Services

    • SQL Server Browser

    • SQL Server FullText Search (MSSQLSERVER)

      Remarque Remarque

      Si l'un de ces services est manquant, vous ne pouvez pas installer Team Foundation. Vous pouvez modifier l'installation de SQL Server 2005 à l'aide de la fonction Ajout/Suppression de programmes pour ajouter les composants manquants pour SQL Server 2005.

  4. Copiez le dossier NetSetup pour la couche Données à partir du support d'installation vers un répertoire situé sur le lecteur local, par exemple c:\temp\.

  5. Dans la copie de NetSetup, recherchez et modifiez le fichier msiproperty.ini dans un éditeur de texte.

  6. Dans le fichier, recherchez le nom de clé VSTF_DB_SERVER, puis remplacez NomOrdinateur par le nom de serveur virtuel pour SQL Server.

    Les exemples suivants illustrent la spécification de jeton d'origine et celle qui a été modifiée pour l'installation sur VSTFSQLCLUSTER.

    D'origine VSTF_DB_SERVER=[ComputerName]

    Modifiée VSTF_DB_SERVER=VSTFSQLCLUSTER

    Attention Attention

    Remplacez uniquement cette instance. Si vous remplacez NomOrdinateur par le nom de serveur virtuel pour les autres jetons, vous mettez à jour de façon incorrecte le nom d'ordinateur des services de couche Application.

  7. Installez les bases de données Team Foundation. Pour plus d'informations, consultez Comment : installer Team Foundation Server (bases de données).

Sécurité

Pour préparer un cluster pour l'installation de la couche Données, vous devez être membre du groupe Cluster Administrator.

Voir aussi

Tâches

Comment : accélérer la récupération d'un serveur dans un cluster

Référence

Liste de vérification : déploiement de Team Foundation Server dans un cluster

Concepts

Garantie de la disponibilité continue des serveurs


Comment : accélérer la récupération d'un serveur dans un cluster

Comment : accélérer la récupération d'un serveur dans un cluster
Voir aussi Exemple

En tant qu'administrateur Team Foundation, vous pouvez utiliser un fichier de script pour redémarrrer de façon explicite les services entre la couche Données d'un cluster et la couche Application. Même si SQL Server 2005 finit par redémarrer les services, vous pouvez les récupérer de façon plus opportune en ajoutant une ressource au cluster de couche Données. Pour ajouter une ressource, vous devez fournir un fichier de script qui redémarre les services et contrôles lorsque ce script est exécuté, et indiquer à la ressource de pointer vers ce fichier.

Les procédures suivantes supposent que vous disposez d'un serveur de couche Données en cours d'exécution dans un cluster et d'un serveur de couche Application qui fonctionne.

Pour ajouter une ressource au cluster de couche Données

  1. Ouvrez une session sur le nœud actif du cluster.

    Remarque Remarque

    Le nœud passif accepte uniquement les connexions établies avec le nœud actif. Si vous essayez d'ouvrir une session sur le nœud passif, un message d'erreur s'affiche.

  2. Dans un éditeur de texte, créez un fichier de script qui implémente WMI (Windows Management Instrumentation) pour interroger les processus du pool d'applications et réinitialiser chaque processus.

    Remarque Remarque

    Dans Visual Studio, vous pouvez rapidement créer le fichier de script à l'aide des modèles Web VBScript ou JScript, puis en ajoutant le script de l'exemple fourni dans cette rubrique. Vous devez remplacer l'espace réservé relatif au nom du serveur de couche Application par le nom de serveur approprié à votre système.

  3. Enregistrez le fichier sur un lecteur et dans un répertoire appropriés.

  4. Cliquez sur Démarrer, sur Programmes, sur Outils d'administration, puis sur Administrateur de cluster.

  5. Cliquez avec le bouton droit sur le nœud Ressources, cliquez sur Nouveau, puis sur Ressources.

  6. Dans l'Assistant Nouvelle ressource, tapez le nom de la ressource, puis cliquez sur Script générique pour le Type de ressource.

    Par exemple, vous pouvez spécifier les informations suivantes.

    • Nom : Réinitialisation des services IIS TFS

    • Description : Pointe vers TFS_IIS_RESET.vbs qui réinitialise les connexions IIS sur la couche Application.

    • Type de ressource : Script générique

    • Groupe : Groupe de cluster

  7. Sur la page Propriétaires possibles, vérifiez que les deux ordinateurs du cluster figurent dans la liste Propriétaires possibles.

  8. Sur la page Dépendances, cliquez sur Ajouter pour chaque ressource de la zone Ressources disponibles pour déplacer les ressources vers la zone Dépendances.

    En ajoutant toutes les ressources en tant que dépendances, vous vous assurez que la nouvelle ressource est la dernière à être mise en ligne.

  9. Sur la page Paramètres de script générique, tapez le chemin d'accès et le nom du fichier de script, puis cliquez sur Terminer.

    Remarque Remarque

    Si le chemin d'accès au fichier est long, vous pouvez rechercher le fichier dans l'Explorateur Windows, puis afficher les propriétés du fichier. Sous l'onglet Général, vous pouvez sélectionner et copier le chemin d'accès à partir de la zone Emplacement et coller le texte dans l'Assistant. Vous devez taper le nom de fichier.

  10. Dans Administrateur de cluster, cliquez avec le bouton droit sur la ressource associée au script que vous avez ajouté, puis cliquez sur Mettre en ligne.

Exemple

Dans Visual Studio, vous pouvez créer un fichier de script à l'aide du modèle Web VBScript disponible dans la boîte de dialogue Nouveau fichier. L'exemple suivant implémente les routines de l'API de cluster pour contrôler le système d'exploitation à l'aide de WMI, la fonction Online interroge le pool d'applications IIS et démarre chaque processus du pool. La fonction Offline interroge le pool d'applications IIS et arrête chaque processus. Les fonctions LooksAlive et IsAlive de l'API de cluster définissent les informations d'état utilisées par le Moniteur de ressource.

Remarque Remarque

Veillez à remplacer l'espace réservé relatif au nom du serveur de couche Application, TFS AT Name, par le nom de serveur pour la couche Application de votre système.
Image Copier le code Copier le code
Sub Open( )
End Sub

Function Close( )
End Function

Function Online( )
strComputer = "TFS AT Name"

Set objWMIService = GetObject _
    ("winmgmts:{authenticationLevel=pktPrivacy}\\" _
        & strComputer & "\root\microsoftiisv2")

Set colItems = objWMIService.ExecQuery _
    ("Select * From IIsApplicationPool")

For Each objItem in colItems
    objItem.Start
Next
End Function

Function Offline( )
strComputer = "TFS AT Name"

Set objWMIService = GetObject _
    ("winmgmts:{authenticationLevel=pktPrivacy}\\" _
        & strComputer & "\root\microsoftiisv2")

Set colItems = objWMIService.ExecQuery _
    ("Select * From IIsApplicationPool")

For Each objItem in colItems
    objItem.Stop
Next
End Function

Function Terminate( )
    Call Offline
End Function

Function LooksAlive ( )
    LooksAlive = True

End Function

Function IsAlive( )
   IsAlive= True
End Function

Sécurité

Pour effectuer cette procédure, vous devez être membre du groupe de sécurité Cluster Administrator.

Voir aussi

Concepts

Comptes d'utilisateurs requis pour l'installation de Team Foundation Server


Liste de vérification : configuration d'une couche Application de secours

 Image de liste déroulante Image de pointage sur liste déroulante Image de réduction Image de développement Image Réduire tout Image Développer tout Copier l'image de pointage
Visual Studio Team System
Liste de vérification : configuration d'une couche Application de secours
Voir aussi
Image Réduire tout Image de liste déroulante

Cette liste de vérification expose les étapes générales pour configurer une couche Application sur un ordinateur de secours. La liste part du principe que l'architecture physique suivante est configurée.

  • Serveur sur lequel les composants de base de données SQL Server et Team Foundation Server sont en cours d'exécution.

  • Serveur sur lequel les composants des services Windows SharePoint, SQL Reporting Services et Team Foundation Server sont installés et en cours d'exécution.

  • Serveur qui répond à la configuration matérielle et logicielle requise pour la couche Application.

Vous devez imprimer cette liste de vérification et marquer chaque étape que vous terminez.

Image de développement Préparation

Les éléments suivants doivent être prêts avant d'installer et de configurer l'ordinateur de secours.

Terminé Étape

Récupérez la version la plus actuelle de ce guide, qui est téléchargeable à partir du Centre de téléchargement Microsoft (http://go.microsoft.com/fwlink/?LinkId=40042).

Vérifiez que l'ordinateur de secours répond à la configuration matérielle et logicielle requise pour la couche Application. Pour plus d'informations, consultez la section Couche Application dans Configuration de Team Foundation System.

Sur l'ordinateur de secours, ajoutez les comptes de service suivants. Ces comptes doivent déjà exister sur le domaine et l'ordinateur de couche Application principal. Vous devez utiliser les mêmes comptes de service sur l'ordinateur de secours que sur l'ordinateur principal.

  • Compte d'utilisateur pour exécuter le programme d'installation (par exemple, Domain\TFSSETUP).

  • Compte de service pour exécuter les services Team Foundation (par exemple, Domain\TFSSERVICE).

  • Compte de service pour accéder aux sources de données SQL Server Reporting Services (par exemple, Domain\TFSREPORTS.

Pour plus d'informations, consultez Comptes d'utilisateurs requis pour l'installation de Team Foundation Server.

Image de développement Installation

Terminé Étape

Sur l'ordinateur de secours, installez les services IIS (Internet Information Services) 6.0 et activez ASP.NET.

Attention Attention

N'installez pas les extensions serveur FrontPage.

Pour plus d'informations, consultez Comment : installer les services IIS (Internet Information Services) pour Team Foundation Server.

Sur l'ordinateur de secours, installez SQL Server 2005 Reporting Services (à l'aide de Microsoft SQL Server 2005 Standard ou Enterprise Edition) pour une utilisation avec Team Foundation Server.

Sur l'ordinateur de secours, installez le correctif KB913393 pour Microsoft .NET Framework 2.0 disponible sur le support d'installation de Team Foundation Server.

Sur le support d'installation, recherchez le dossier KB913393, recherchez le fichier exécutable (.exe) pour votre plate-forme (X86), puis double-cliquez sur le fichier à installer.

Sur l'ordinateur de secours, installez Windows SharePoint Services avec Service Pack 2 pour une utilisation avec Team Foundation Server et redémarrez-le

Attention Attention

Ne configurez aucun paramètre pour Windows SharePoint Services. Le programme d'installation de Team Foundation Server (services) termine la configuration des services pour vous.

Pour plus d'informations, consultez Comment : installer Microsoft Windows SharePoint Services pour Team Foundation Server (déploiement sur deux serveurs).

Sur l'ordinateur de secours, installez Team Foundation Server (services). Pour plus d'informations, consultez Comment : installer Team Foundation Server (services).

Remarque Remarque

Lorsque l'avertissement indiquant que le serveur de couche Données que vous avez fourni est en cours d'utilisation s'affiche, entrez Y pour continuer.

Vérifiez que les ports appropriés sont ouverts.

Sur l'ordinateur de couche Données, si vous utilisez le Pare-feu Windows, ou un logiciel de pare-feu ou une solution matérielle d'un tiers, vous devez vous assurer que les ports requis sont ouverts pour autoriser la communication entre les composants. Pour plus d'informations, consultez Ports requis pour l'installation de Team Foundation Server.

Installez Team Explorer. Pour plus d'informations, consultez Vue d'ensemble de l'installation de Team Explorer.

Sur l'ordinateur de secours, mettez à jour les groupes et comptes d'utilisateurs en fonction de l'ordinateur principal. Par exemple, assurez-vous que les appartenances au groupe et les rôles des créateurs de projets d'équipe sur l'ordinateur principal ont les appartenances et les rôles appropriés sur l'ordinateur de secours. Pour plus d'informations, consultez Comment : ajouter des utilisateurs au groupe d'applications Team Foundation Administrators.

Image de développement Configuration

Terminé Étape

Sélectionnez une méthode pour l'ajout d'un hôte DNS au domaine. Vous devez sélectionner une méthode pour la spécification d'un nom d'hôte unique pour la liaison aux clients et à la couche Données, quelle que soit la couche Application qui est active.

  • Si l'administrateur Team Foundation Server a des droits d'administration de domaine, utilisez la mise à jour des hôtes DNS.

  • Si l'administration de domaine n'est pas disponible pour l'administrateur Team Foundation Server, utilisez des adresses IP dédiées. Pour utiliser cette option, procurez-vous des adresses IP statiques pour les ordinateurs principal et de secours, et spécifiez un nom de serveur virtuel sur le domaine qui utilise la même adresse IP que l'ordinateur principal.

Pour plus d'informations sur la spécification d'un nom d'hôte, consultez la description de la configuration d'une carte réseau dans Comment : configurer une couche Application de secours.

Si le serveur de couche Application exécute SQL Server Enterprise Edition, configurez Reporting Services pour un déploiement évolutif à l'aide de l'outil de configuration de Reporting Services.

Si le serveur de couche Application exécute SQL Server Standard Edition, sauvegardez la clé de chiffrement de Reporting Services à l'aide de l'outil de configuration de Reporting Services.

Affectez le nom de serveur virtuel comme nom de serveur pour la couche Application Team Foundation Server. Cette étape permet de remplacer le nom de l'ordinateur par le nom qui peut pointer vers l'un ou l'autre ordinateur par le biais de la méthode de carte réseau que vous avez utilisée.

Connectez Team Explorer au nom de serveur virtuel.

Image de développement Voir aussi

Tâches

Comment : configurer une couche Application de secours

Concepts

Garantie de la disponibilité continue des serveurs

Autres ressources

Vue d'ensemble du déploiement de Team Foundation Server sur deux serveurs


Comment : configurer une couche Application de secours

Comment : configurer une couche Application de secours

Vous pouvez configurer un ordinateur de secours pour la couche Application lorsque vous configurez pour la première fois Team Foundation Server ou vous pouvez le configurer ultérieurement. Vous devez définir un nom de serveur virtuel qui peut être configuré pour pointer vers l'un ou l'autre ordinateur de couche Application afin que le passage d'un ordinateur à l'autre soit transparent pour les ordinateurs clients et le serveur de couche Données.

Cette procédure suppose que vous avez déjà effectué les étapes de préparation et d'installation décrites dans la Liste de vérification : configuration d'une couche Application de secours. Ces procédures contiennent les détails pour l'exécution des étapes de configuration fournies dans la liste de vérification.

  • Configuration d'une carte réseau pour fournir un nom de serveur virtuel.

  • Configuration de SQL Server 2005 pour une utilisation de secours.

  • Configuration de Team Foundation Server pour utiliser le nom de serveur virtuel.

  • Connexion de Team Explorer au nom de serveur virtuel.

Configuration d'un hôte DNS

Pour fournir un seul nom que les clients et la couche Données peuvent utiliser pour les communications, quel que soit le serveur de couche Application qui est actif, vous devez spécifier un nom d'hôte sur le domaine. Lorsque vous souhaitez basculer les services de couche Application du serveur principal au serveur de secours, vous devez utiliser ce nom pour activer l'ordinateur de secours et le lier à la couche Données.

Les procédures suivantes décrivent deux options permettant de spécifier un nom d'hôte sur le domaine. Les deux options nécessitent des droits d'administrateur DNS, car vous devez créer un enregistrement d'hôte DNS pour le serveur d'application virtuel. Si votre organisation ne fournit aucune autorisation d'administration de domaine aux administrateurs Team Foundation Server, vous devez utiliser des adresses IP dédiées afin de pouvoir mettre à jour l'adresse IP du nom d'hôte.

Dans une organisation où les autorisations d'administration de domaine sont accordées à l'administrateur Team Foundation Server, l'approche de mise à jour des hôtes DNS est conseillée.

Mise à jour des hôtes DNS Un enregistrement d'hôte DNS (A) est créé, qui dispose de l'adresse IP du serveur de couche Application Team Foundation Server principal. Aucune configuration réseau spéciale n'est nécessaire sur l'un ou l'autre des serveurs de couche Application Team Foundation Server, car DNS convertit les requêtes pour le serveur de couche Application Team Foundation Server virtuel en adresse IP du serveur de couche Application principal. Lors du basculement, un administrateur de domaine doit mettre à jour l'entrée de l'hôte DNS pour rediriger le trafic vers le nouveau serveur de couche Application Team Foundation Server principal.

Adresses IP dédiées Dans cette configuration, trois adresses IP statiques sont requises. Un enregistrement d'hôte DNS qui mappe le nom du serveur de couche Application Team Foundation Server virtuel à l'une des adresses IP dédiées est créé par un administrateur de domaine. Cette adresse IP statique et l'une des adresses inutilisées sont définies manuellement dans les propriétés TCP/IP pour la connexion réseau sur le serveur de couche Application Team Foundation Server principal. Le serveur de couche Application Team Foundation Server de secours est configuré à l'aide de l'adresse IP statique restante. Lors du basculement, l'administrateur Team Foundation Server modifie les paramètres réseau sur le nouveau serveur de couche Application Team Foundation Server principal afin qu'il réponde à présent aux requêtes sur l'adresse IP statique utilisée pour le serveur de couche Application Team Foundation Server virtuel.

Pour implémenter un ordinateur de secours, le serveur de domaine doit disposer d'enregistrements de ressources pour trois serveurs.

  • Principal Nom d'ordinateur du serveur de couche Application principal qui utilise une adresse IP statique. Par exemple, vous pouvez nommer le serveur principal TFS_AT_01.

  • De secours Nom d'ordinateur du serveur de couche Application de secours qui utilise une adresse IP statique. Par exemple, vous pouvez nommer le serveur de secours TFS_AT_02.

  • Serveur virtuel Nom de serveur virtuel du serveur de couche Application dont l'adresse IP statique est la même que l'adresse IP pour l'ordinateur principal. Par exemple, vous pouvez utiliser le nom TFS_AT comme nom de serveur virtuel.

    Après une défaillance, l'adresse IP du nom de serveur virtuel doit être mise à jour manuellement en fonction de l'ordinateur de secours.

    Les procédures suivantes supposent que vous disposez déjà d'un serveur de couche Données et d'un serveur de couche Application qui sont configurés et en cours d'exécution.

    Remarque Remarque

    Les étapes nécessaires pour obtenir des adresses IP statiques et spécifier un nom de serveur virtuel dépendent de la façon dont votre organisation gère le domaine et ne sont pas traitées dans cette documentation. Pour plus d'informations, consultez l'administrateur de domaine.

Pour spécifier un nom d'hôte sur le domaine

  1. Dans le menu Démarrer, cliquez sur Exécuter, tapez dnsmgmt.msc, et cliquez sur OK.

  2. Dans le Gestionnaire DNS, cliquez sur Zones de recherche directes, cliquez avec le bouton droit sur le nom de domaine, puis cliquez sur Nouvel hôte (A).

  3. Dans la boîte de dialogue Nouvel hôte, tapez le nom à utiliser pour le serveur virtuel, par exemple TFS_AT.

  4. Examinez et notez les adresses IP statiques pour les ordinateurs principal et de secours.

  5. Sélectionnez Créer un pointeur d'enregistrement PTR associé, tapez l'adresse IP en fonction de la méthode que vous avez choisi d'utiliser, puis cliquez sur Ajouter un hôte.

    • Mise à jour des hôtes DNS Entrez l'adresse IP de l'ordinateur principal.

    • Adresses IP dédiées Entrez l'une des trois adresses IP statiques en tant qu'adresse du serveur virtuel pour la couche Application. Vous devez configurer les connexions réseau pour les adresses IP.

  6. Vérifiez que l'ordinateur principal et le serveur virtuel utilisent l'adresse IP statique prévue et que les adresses sont identiques.

Pour configurer les connexions réseau pour les adresses IP dédiées

  1. Sur l'ordinateur principal, ouvrez une fenêtre d'invite de commandes et tapez ipconfig /all.

    Remarque Remarque

    Si vous utilisez la mise à jour des hôtes DNS, vous n'avez pas à effectuer cette procédure.

    Les paramètres de configuration réseau s'affichent.

  2. Dans le menu Démarrer, cliquez sur Panneau de configuration, puis sur Connexions réseau.

  3. Recherchez la connexion réseau du domaine, cliquez avec le bouton droit sur Propriétés Internet (TCP/IP), puis cliquez sur Propriétés.

  4. Cliquez sur Utiliser l'adresse IP suivante, tapez l'adresse IP statique de l'ordinateur principal, puis le masque de sous-réseau de cette adresse IP à l'aide des informations affichées dans la fenêtre d'invite de commandes.

  5. Dans la fenêtre d'invite de commandes, recherchez le nom de la passerelle par défaut.

  6. Dans la boîte de dialogue Connexions réseau, cliquez sur Utiliser l'adresse de serveur DNS suivante, tapez la première adresse de serveur DNS répertoriée en tant que serveur DNS préféré, puis cliquez sur Paramètres avancés.

  7. Dans la boîte de dialogue Paramètres TCP/IP avancés, sélectionnez l'onglet DNS, cliquez sur Ajouter, puis spécifiez un autre serveur DNS répertorié dans les paramètres de configuration réseau.

  8. Sélectionnez l'onglet WINS, cliquez sur Ajouter, puis spécifiez les serveurs WINS principal et secondaire répertoriés dans les paramètres de configuration réseau.

  9. Sélectionnez l'onglet Paramètres IP, cliquez sur Ajouter, puis spécifiez les adresses IP statiques pour le serveur virtuel, par exemple AT_TFS.

  10. Répétez les étapes précédentes sur l'ordinateur de secours.

Configuration de SQL Server 2005 pour une utilisation de secours

Vous devez effectuer l'une des opérations suivantes selon votre version de Microsoft SQL Server 2005.

  • Lorsque vous utilisez SQL Server Standard Edition, le fichier de la clé de chiffrement de Reporting Services et le mot de passe utilisés pour la protection du contenu sont nécessaires au démarrage de Reporting Services sur le serveur de couche Application Team Foundation Server de secours.

  • Lorsque vous utilisez SQL Server Reporting Services Enterprise Edition, vous devez procéder à une configuration pour un déploiement évolutif. Dans ce cas, l'instance de Reporting Services sur le serveur de couche Application Team Foundation Server de secours doit être associée à un déploiement évolutif (consultez « Procédure : configurer un déploiement évolutif Report Server » http://msdn2.microsoft.com/fr-fr/library/ms159114.aspx).

Pour configurer SQL Server 2005 Standard Edition

  1. Sur l'ordinateur de couche Application Team Foundation Server principal, ouvrez une fenêtre d'invite de commandes.

  2. Recherchez le répertoire binn en tapant cd %Program Files%\Microsoft SQL Server\90\Tools\binn.

  3. Exécutez rsconfigtool.exe.

  4. Dans l'outil de configuration de Reporting Services, cliquez sur Clés de chiffrement dans le volet de navigation gauche, puis sur Sauvegarder.

  5. Entrez un mot de passe fort pour protéger le contenu du fichier de la clé de chiffrement.

  6. Enregistrez le fichier à un emplacement disponible en cas de défaillance du serveur principal.

Pour configurer SQL Server Reporting Services Enterprise Edition

  1. Sur l'ordinateur de secours, ouvrez l'outil de configuration de Report Server.

  2. Cliquez sur OK pour vous connecter à l'instance de serveur de rapports sur le serveur de secours.

  3. Cliquez sur Initialisation dans le volet gauche et vérifiez qu'une entrée est créée pour la deuxième instance de serveur de rapports. La case à cocher Initialisé doit être vide.

  4. Reconnectez-vous à l'instance de serveur de rapports sur le serveur principal. Le serveur de rapports principal est déjà initialisé pour les opérations de chiffrement réversibles. Il est par conséquent utilisé pour initialiser le nouvelle instance de serveur de rapports sur le serveur de secours pour un déploiement évolutif.

  5. Sur la page Initialisation, sélectionnez l'instance de serveur de rapports que vous associez au déploiement, puis cliquez sur Initialiser. Vous devez activer la case à cocher Initialisé pour toutes les instances de serveur de rapports qui font partie du même déploiement évolutif ; cliquez ensuite sur Appliquer (il est possible que vous deviez cliquer sur Actualiser).

  6. Dans Internet Explorer, recherchez http://TFSAT02/reports, puis vérifiez que le serveur de secours figure dans le déploiement évolutif.

Configuration de Team Foundation Server pour utiliser le nom de serveur virtuel

Pour configurer l'ordinateur principal pour utiliser le nom de serveur virtuel

  • Sur l'ordinateur principal, activez le nom de serveur virtuel à l'aide de la commande ActivateAT de l'utilitaire en ligne de commande TfsAdminUtil.

    Par exemple, la commande suivante active TFS_AT en tant que serveur de couche Application qui utilise la même adresse IP que le serveur principal.

    TfsAdminUtil ActivateAT TFS_AT

Pour configurer l'ordinateur de secours pour utiliser le nom de serveur virtuel

  • Sur l'ordinateur de secours, activez le nom de serveur virtuel à l'aide de la commande ActivateAT de l'utilitaire en ligne de commande TfsAdminUtil. Par exemple, la commande suivante active TFS_AT en tant que serveur de couche Application qui utilise la même adresse IP que le serveur principal.

    TfsAdminUtil ActivateAT TFS_AT

Connexion de Team Explorer au serveur virtuel

Pour connecter Team Explorer au serveur virtuel

  1. Ouvrez Team Explorer, cliquez sur Outils, puis sur Se connecter à Team Foundation Server.

  2. Ajoutez un nom de serveur à la liste en cliquant sur Ajouter, en spécifiant le nom de serveur virtuel, puis en cliquant sur Fermer.

  3. Dans la boîte de dialogue Se connecter à, sélectionnez le nom de serveur virtuel dans la liste, puis cliquez sur Se conn..

Sécurité

Pour configurer une couche Application de secours, vous devez être membre des groupes de sécurité Team Foundation Administrators et Cluster Administrator.

Voir aussi

Tâches

Comment : installer Team Foundation Server (services)

Référence

Liste de vérification : configuration d'une couche Application de secours

Concepts

Garantie de la disponibilité continue des serveurs


Vue d'ensemble de l'installation de Team Foundation Build

Vue d'ensemble de l'installation de Team Foundation Build
DropDown image

Team Foundation Server offre des services d'automation de la génération afin de vous aider à générer et à partager des solutions Visual Studio 2005 à l'aide de Team Foundation Build. Vous pouvez installer Team Foundation Build sur le même ordinateur que la couche Application de Team Foundation, ou sur un ordinateur distinct.

Dans cette section

Comment : installer Team Foundation Build

Utilisez cette procédure pour installer Team Foundation Build.

Rubriques connexes

Configuration de Team Foundation System

Indique la configuration système nécessaire relative au matériel et aux logiciels pour installer cette version de Team Foundation Server.

Vue d'ensemble de la sécurité de Team Foundation Server pour l'installation

Fournit des informations liées à la sécurité pour l'installation de Team Foundation Server.

Vue d'ensemble du déploiement sur un serveur de Team Foundation Server

Utilisez les procédures de cette section pour installer et configurer Team Foundation Server sur un serveur.

Vue d'ensemble du déploiement de Team Foundation Server sur deux serveurs

Utilisez les procédures de cette section pour installer et configurer Team Foundation Server à l'aide de deux ordinateurs, un pour les composants de la couche Données et un autre pour les composants de la couche Application.

Vue d'ensemble de l'installation de Team Foundation Server Proxy

Utilisez les procédures de cette section pour installer Team Foundation Server Proxy, qui met en cache les fichiers du contrôle de code source auxquels vous avez précédemment accédé.

Vue d'ensemble de l'installation de Team Explorer

Utilisez les procédures de cette section pour installer et configurer Team Explorer.

Voir aussi

Concepts

Installation de Team Foundation


Comment : installer Team Foundation Build

Comment : installer Team Foundation Build

Utilisez cette procédure pour installer Team Foundation Build.

Comment installer Team Foundation Build

  1. Sur le support d'installation de Team Foundation Server, localisez le dossier \build et exécutez setup.exe.

    L'Assistant Installation de Visual Studio 2005 Team Foundation Build Server démarre.

  2. À la page Bienvenue dans le programme d'installation, cliquez sur Suivant.

  3. Sur la page Termes de Licence et clé du produit, examinez le contrat de licence. Si vous acceptez les termes et conditions mentionnés, sélectionnez J'accepte les termes du contrat de licence, puis cliquez sur Suivant.

  4. Sur la page Dossier de destination, acceptez le dossier de destination par défaut, puis cliquez sur Suivant.

  5. À la page Vérification de la santé du système, l'Assistant Installation analyse votre système à la recherche de conditions qui peuvent provoquer l'échec de l'installation ou des problèmes par la suite lors du fonctionnement du serveur. Une fois l'analyse du système terminée, le programme d'installation indique l'état de la vérification de la santé du système. Si la vérification de la santé du système détecte des problèmes, vous pouvez cliquer sur un lien pour examiner un rapport relatif à des blocs et des avertissements spécifiques. Les avertissements doivent être traités avant de continuer l'installation, mais ne doivent pas empêcher le déroulement de l'installation. Les blocs doivent être traités avant de poursuivre l'installation. Si la vérification de la santé du système n'a trouvé aucun bloc, cliquez sur Suivant. Sinon, cliquez sur Annuler et réexécutez le programme d'installation après avoir corrigé les problèmes de blocage.

  6. À la page Compte de service, tapez le compte d'utilisateur de domaine Windows que vous avez créé pour le compte de service Team Foundation Server (par exemple, Domaine\TFSSERVICE) dans la zone Nom du compte, tapez le mot de passe dans la zone Mot de passe, puis cliquez sur Suivant. Pour plus d'informations, consultez Comptes d'utilisateurs requis pour l'installation de Team Foundation Server.

    Remarque Remarque

    Pour cette version, vous devez utiliser le même compte d'utilisateur de domaine Windows que le compte de service Team Foundation Server.

  7. À la page Prêt pour l'installation, cliquez sur Installer.

    Remarque Remarque

    Le programme d'installation crée des exceptions de programmes pour MSBuild.exe et TeamBuildService.exe dans le Pare-feu Windows pour autoriser la communication avec Team Foundation Server.

  8. À la page Installation des composants, vous pouvez surveiller l'installation de Team Build.

  9. À la page L'installation s'est terminée avec succès, cliquez sur Terminer.

    Remarque Remarque

    Si les projets que vous souhaitez générer nécessitent d'autres éléments, par exemple des composants, des programmes ou des bibliothèques de liens dynamiques (.dll), vous devez les ajouter manuellement à l'ordinateur de génération.

Sécurité

Pour effectuer cette procédure, vous devez être membre du groupe de sécurité Administrateurs sur l'ordinateur. Pour plus d'informations, consultez Comptes d'utilisateurs requis pour l'installation de Team Foundation Server.

Voir aussi

Concepts

Architecture physique de Team Foundation
Configuration de Team Foundation System

Autres ressources

Vue d'ensemble de l'installation de Team Foundation Build


Vue d'ensemble de l'installation de Team Foundation Server Proxy

Vue d'ensemble de l'installation de Team Foundation Server Proxy
Voir aussi
DropDown image

Utilisez les procédures de cette section pour installer Team Foundation Server Proxy, qui met en cache les fichiers du contrôle de code source auxquels vous avez précédemment accédé. Vous pouvez installer Team Foundation Server Proxy sur le même ordinateur que la couche Application de Team Foundation, ou sur un ordinateur séparé.

Dans cette section

Comment : installer les services IIS (Internet Information Services) pour Team Foundation Server Proxy

Décrit comment installer les services IIS (Internet Information Services) version 6.0 pour le proxy de Team Foundation Server.

Comment : installer Team Foundation Server Proxy

Décrit comment installer Team Foundation Server Proxy qui peut améliorer des opérations de contrôle de code source en mettant en cache les fichiers auxquels vous avez précédemment accédé.

Comment : configurer Team Explorer pour utiliser Team Foundation Server Proxy

Décrit comment configurer Team Explorer pour utiliser un proxy de Team Foundation Server.

Rubriques connexes

Configuration de Team Foundation System

Indique la configuration système nécessaire relative au matériel et aux logiciels pour installer cette version de Team Foundation Server.

Vue d'ensemble de la sécurité de Team Foundation Server pour l'installation

Fournit des informations liées à la sécurité pour l'installation de Team Foundation Server.

Vue d'ensemble du déploiement sur un serveur de Team Foundation Server

Utilisez les procédures de cette section pour installer et configurer Team Foundation Server sur un serveur.

Vue d'ensemble du déploiement de Team Foundation Server sur deux serveurs

Utilisez les procédures de cette section pour installer et configurer Team Foundation Server à l'aide de deux ordinateurs, un pour les composants de la couche Données et un autre pour les composants de la couche Application.

Vue d'ensemble de l'installation de Team Foundation Build

Utilisez les procédures de cette section pour installer et configurer Team Foundation Build, qui fournit l'automation de la génération pour vous aider à générer et partager les solutions Visual Studio 2005.

Vue d'ensemble de l'installation de Team Explorer

Utilisez les procédures de cette section pour installer et configurer Team Explorer.

Voir aussi

Concepts

Installation de Team Foundation


Comment : installer les services IIS (Internet Information Services) pour Team Foundation Server Proxy

Comment : installer les services IIS (Internet Information Services) pour Team Foundation Server Proxy
Voir aussi

Utilisez cette procédure pour installer Internet Information Services (IIS) 6.0 pour Team Foundation Server Proxy.

Vous pouvez consulter Ajout/Suppression de programmes pour vérifier si IIS a été précédemment installé et si ASP.NET est activé. Dans le cas contraire, suivez cette procédure pour installer IIS et activer ASP.NET.

Pour activer ASP.NET à l'aide de l'utilitaire Ajout/Suppression de programmes

  1. Dans le Panneau de configuration, ouvrez Ajout/Suppression de programmes.

  2. Cliquez sur Ajouter/Supprimer des composants Windows.

    L'Assistant Composants de Windows démarre.

  3. À la page Composants Windows, sélectionnez Serveur d'applications, puis cliquez sur Détails.

  4. Le cas échéant, sélectionnez ASP.NET, puis cliquez sur OK.

  5. À la page Composants Windows, cliquez sur Suivant.

    Remarque Remarque

    Votre support d'installation de Windows Server 2003 peut vous être demandé.

  6. Cliquez sur Terminer pour fermer l'Assistant.

  7. Visitez le site Windows Update (http://windowsupdate.microsoft.com) et installez tous les éléments du groupe Critical Updates and Service Packs.

Pour configurer le serveur comme un serveur d'applications

  1. Démarrez l'Assistant Configurer votre serveur en effectuant l'une des opérations suivantes :

    • Par défaut, Gérer votre serveur démarre automatiquement au démarrage de Windows. Dans Gérer votre serveur, cliquez sur Ajouter ou supprimer un rôle.

    • Dans le Panneau de configuration, ouvrez Outils d'administration, puis Assistant Configurer votre serveur.

  2. À la page Bienvenue dans l'Assistant Configurer votre serveur, cliquez sur Suivant.

  3. À la page Étapes préliminaires, cliquez sur Suivant.

  4. À la page Rôle du serveur, sélectionnez Serveur d'applications (IIS, ASP.NET), puis cliquez sur Suivant.

  5. À la page Options du serveur d'applications, sélectionnez Activer ASP.NET, puis cliquez sur Suivant.

  6. À la page Aperçu des sélections, cliquez sur Suivant.

    Remarque Remarque

    Votre support d'installation de Windows Server 2003 peut vous être demandé.

  7. Cliquez sur Terminer pour interrompre l'Assistant.

  8. Visitez le site Windows Update (http://windowsupdate.microsoft.com) et installez tous les éléments du groupe Critical Updates and Service Packs.

Sécurité

Pour effectuer ces procédures, vous devez être membre du groupe de sécurité Administrateurs sur l'ordinateur. Le compte d'utilisateur employé pour l'installation est désigné sous le nom de Domaine\\TFSSETUP dans ce guide. Pour plus d'informations, consultez Comptes d'utilisateurs requis pour l'installation de Team Foundation Server.

Voir aussi

Tâches

Comment : installer Team Foundation Server Proxy

Autres ressources

Vue d'ensemble de l'installation de Team Foundation Server Proxy


Comment : installer Team Foundation Server Proxy

Comment : installer Team Foundation Server Proxy

Décrit comment installer Team Foundation Server Proxy. Le proxy améliore les opérations de téléchargement de contrôle de code source en mettant en cache les fichiers auxquels vous avez précédemment accédé. En général, vous installez Team Foundation Server Proxy sur un ordinateur dans l'emplacement distant d'une équipe multisite.

Pour installer Team Foundation Server Proxy

  1. Installez et implémentez les composants requis pour un ordinateur Team Foundation Server Proxy :

    1. Installez Windows Server 2003 Service Pack 1 (SP1), Enterprise ou Standard Edition.

    2. Identifiez le compte d'utilisateur à employer pour exécuter le programme d'installation et ajoutez le compte au groupe Administrateurs local.

      Il s'agit en général de votre compte d'utilisateur. Dans ce guide, ce compte est désigné sous le nom de Domaine\TFSSETUP, car le nom exact dépend de votre organisation. Pour plus d'informations sur les conditions requises pour ce compte, consultez Comptes d'utilisateurs requis pour l'installation de Team Foundation Server.

    3. Créez un compte de service dédié pour le proxy et ajoutez le compte au groupe Team Foundation Server Valid Users sur tous les serveurs de la couche Application Team Foundation Server que le proxy sert.

    4. Installez Internet Information Services 6. et activez ASP.NET. Pour plus d'informations, consultez Comment : installer les services IIS (Internet Information Services) pour Team Foundation Server Proxy.

    5. Si vous installez Team Foundation Server Proxy sur un ordinateur distinct de Team Foundation Server, vérifiez que Microsoft .NET Framework 2.0 est installé.

      Pour vérifier, cliquez sur Démarrer, sur Panneau de configuration, sur Ajout/Suppression de programmes, puis examinez la liste des Programmes actuellement installés.

      Remarque Remarque

      Pour installer Microsoft .NET Framework 2.0, recherchez le dossier proxy\wcu\dotNetFramework sur le support d'installation et exécutez dotnetFX.

    6. Installez le correctif KB913393 pour Microsoft .NET Framework 2.0 disponible sur le support d'installation.

      Sur le support d'installation, recherchez le dossier pour le correctif, tel que KB913393, recherchez le fichier exécutable (.exe) pour le système d'exploitation, puis double-cliquez sur le fichier pour installer le correctif.

    7. Si Team Foundation Server est connecté au réseau par le biais d'un serveur proxy, vérifiez que l'option Ne pas utiliser de serveur proxy pour les adresses locales est sélectionnée pour les paramètres du réseau local.

      Pour vérifier les paramètres, cliquez sur Démarrer, sur Panneau de configuration, puis sur Options Internet. Sous l'onglet Connexions, cliquez sur Paramètres LAN. Dans la boîte de dialogue Paramètres du réseau local, sélectionnez Ne pas utiliser de serveur proxy pour les adresses locales. Les deux options de détection automatique doivent être désactivées.

      Si ce paramètre n'est pas sélectionné, le programme d'installation de Team Foundation Server Proxy ne peut pas utiliser Windows SharePoint Services pour effectuer l'authentification et l'accès est refusé.

  2. Sur le serveur proxy, ouvrez une session Windows à l'aide du compte utilisé pour l'installation de Team Foundation Server (par exemple, Domaine\TFSSETUP). Sur le support d'installation de Team Foundation Server, recherchez le dossier \proxy et exécutez setup.

    L'Assistant Installation de Visual Studio 2005 Team Foundation Server Proxy démarre.

  3. À la page Bienvenue dans le programme d'installation, cliquez sur Suivant.

  4. Sur la page Termes de Licence et clé du produit, examinez le contrat de licence. Si vous acceptez les termes et conditions mentionnés, sélectionnez J'accepte les termes du contrat de licence, puis cliquez sur Suivant.

  5. Sur la page Vérification de la santé du système, examinez les avertissements ou blocs éventuels en cliquant sur le lien de rapport.

    • Les blocs doivent être traités avant de pouvoir poursuivre l'installation. Cliquez sur Annuler et réexécutez le programme d'installation après avoir corrigé les problèmes.

    • Les avertissements doivent être traités avant de continuer, mais ne doivent pas empêcher le déroulement de l'installation. Vous pouvez cliquer sur Suivant.

    • Si rien n'est répertorié, cliquez sur Suivant.

  6. Sur la page Dossier de destination, acceptez le dossier de destination par défaut, puis cliquez sur Suivant.

  7. Sur la page Dossier du cache, acceptez le chemin d'accès et le dossier par défaut, puis cliquez sur Suivant.

    Remarque Remarque

    Le dossier que vous spécifiez doit avoir suffisamment d'espace libre pour permettre la mise en cache des fichiers.

  8. À la page Compte de service, tapez le compte d'utilisateur de domaine Windows que vous avez créé pour le compte proxy Team Foundation Server (par exemple, Domaine\TFSPROXY) dans la zone Nom du compte, tapez le mot de passe dans la zone Mot de passe, puis cliquez sur Suivant. Pour plus d'informations, consultez Comptes d'utilisateurs requis pour l'installation de Team Foundation Server.

  9. À la page Prêt pour l'installation, cliquez sur Installer.

  10. Sur la page Installation des composants, vous pouvez surveiller l'installation de Team Foundation Server Proxy.

  11. Sur la page L'installation s'est terminée avec succès, cliquez sur Terminer et Internet Explorer apparaît

  12. Sur la page Configuration du proxy de contrôle de version Team Foundation, suivez les instructions pour configurer le proxy.

    Remarque Remarque

    Vous devez configurer Team Foundation Server Proxy avant de pouvoir l'utiliser. Si cette page ne s'affiche pas, recherchez et ouvrez ProxyConfig.htm sur le support d'installation.

Sécurité

Pour effectuer cette procédure, vous devez être membre du groupe de sécurité Administrateurs sur l'ordinateur. Le compte d'utilisateur employé pour l'installation est désigné sous le nom de Domaine\\TFSSETUP dans ce guide. Pour plus d'informations, consultez Comptes d'utilisateurs requis pour l'installation de Team Foundation Server.

Voir aussi

Autres ressources

Vue d'ensemble de l'installation de Team Foundation Server Proxy


Comment : configurer Team Explorer pour utiliser Team Foundation Server Proxy

Comment : configurer Team Explorer pour utiliser Team Foundation Server Proxy
Voir aussi

Décrit comment configurer Team Explorer pour utiliser un proxy de Team Foundation Server.

Pour configurer Team Explorer afin d'utiliser Team Foundation Server Proxy

  1. Démarrez Microsoft Visual Studio 2005.

  2. Dans le menu Outils, cliquez sur Options.

  3. Développez Contrôle de code source, puis cliquez sur Visual Studio Team Foundation.

  4. Sélectionnez Utiliser un serveur proxy.

  5. Dans la zone Nom Team Foundation Server, tapez le nom de l'ordinateur qui héberge Team Foundation Server Proxy.

  6. Dans la zone Port, tapez 8081.

  7. Sous Protocole, sélectionnez Http.

  8. Cliquez sur OK.

Sécurité

Pour effectuer cette procédure, vous devez être membre du groupe de sécurité Utilisateurs sur l'ordinateur.

Voir aussi

Autres ressources

Vue d'ensemble de l'installation de Team Foundation Server Proxy


Vue d'ensemble de l'installation de Team Explorer

Vue d'ensemble de l'installation de Team Explorer
DropDown image

Utilisez les procédures de cette section pour installer et configurer Team Explorer. Vous pouvez installer Team Explorer sur le même ordinateur que la couche Application de Team Foundation, ou sur un ordinateur distinct.

Dans cette section

Comment : installer les composants requis de Team Explorer

Décrit comment installer les composants requis de Team Explorer.

Comment : installer Team Explorer

Décrit comment installer Team Explorer.

Comment : connecter Team Explorer à Team Foundation Server

Décrit comment se connecter à Team Foundation Server à partir de Team Explorer.

Rubriques connexes

Configuration de Team Foundation System

Indique la configuration système nécessaire relative au matériel et aux logiciels pour installer cette version de Team Foundation Server.

Vue d'ensemble de la sécurité de Team Foundation Server pour l'installation

Fournit des informations liées à la sécurité pour l'installation de Team Foundation Server.

Vue d'ensemble du déploiement sur un serveur de Team Foundation Server

Utilisez les procédures de cette section pour installer et configurer Team Foundation Server sur un serveur.

Vue d'ensemble du déploiement de Team Foundation Server sur deux serveurs

Utilisez les procédures de cette section pour installer et configurer Team Foundation Server à l'aide de deux ordinateurs, un pour les composants de la couche Données et un autre pour les composants de la couche Application.

Vue d'ensemble de l'installation de Team Foundation Build

Utilisez les procédures de cette section pour installer et configurer Team Foundation Build, qui fournit l'automation de la génération pour vous aider à générer et partager les solutions Visual Studio 2005.

Vue d'ensemble de l'installation de Team Foundation Server Proxy

Utilisez les procédures de cette section pour installer Team Foundation Server Proxy, qui met en cache les fichiers du contrôle de code source auxquels vous avez précédemment accédé.

Voir aussi

Concepts

Installation de Team Foundation


Comment : installer les composants requis de Team Explorer

Comment : installer les composants requis de Team Explorer

Utilisez cette procédure pour installer les composants requis de Team Explorer.

Pour installer les composants requis pour la couche cliente

  1. Installez un système d'exploitation qui répond à la configuration requise pour Visual Studio 2005 telle que spécifiée dans le fichier Readme de Visual Studio 2005.

    Remarque Remarque

    Lors de l'installation de la couche cliente de Team Foundation sur le même ordinateur que la couche Application de Team Foundation, effectuez l'installation de la couche Application avant d'installer les composants de la couche cliente.

  2. Visitez le site Windows Update (http://windowsupdate.microsoft.com) et installez tous les éléments du groupe Critical Updates and Service Packs.

  3. Installez Microsoft Office Excel 2003. À la page Type d'installation de l'Assistant Installation, sélectionnez Installation complète.

    Remarque Remarque

    Si vous avez choisi de personnaliser les fonctionnalités d'installation, vous devez installer la Prise en charge de la programmabilité .NET pour utiliser les fonctionnalités d'intégration Visual Studio Team System.

  4. Installez Microsoft Office Project Professionnel 2003. À la page Type d'installation de l'Assistant Installation, sélectionnez Installation complète.

    Remarque Remarque

    Si vous avez choisi de personnaliser les fonctionnalités d'installation, vous devez installer la Prise en charge de la programmabilité .NET pour utiliser les fonctionnalités d'intégration Visual Studio Team System.

  5. Visitez le site Windows Update (http://windowsupdate.microsoft.com) et installez tous les éléments du groupe Critical Updates and Service Packs.

  6. Visitez Office Update (http://office.microsoft.com/officeupdate) et installez toutes les mises à jour disponibles.

Configuration de sécurité renforcée d'Internet Explorer

Si vous installez Team Explorer sur Windows Server 2003, vous devez appliquer les paramètres de sécurité Internet Explorer par défaut de Windows 2000 pour activer les fonctionnalités Team Foundation pour le client. Pour appliquer les paramètres de sécurité Internet Explorer par défaut de Windows 2000 sur Windows Server 2003, vous devez désactiver la configuration de sécurité renforcée d'Internet Explorer.

Remarque Important

L'application des paramètres de sécurité Internet Explorer par défaut de Windows 2000 augmente l'exposition de votre serveur aux attaques potentielles par contenu Web malveillant.

Pour appliquer les paramètres de sécurité Internet Explorer par défaut de Windows 2000

  1. Dans le Panneau de configuration, cliquez sur Ajout/Suppression de programmes, puis sur Ajouter ou supprimer des composants Windows.

  2. Désactivez la case à cocher Configuration de sécurité renforcée d'Internet Explorer, puis cliquez sur Suivant.

  3. Cliquez sur Terminer.

  4. Redémarrez Internet Explorer pour appliquer les modifications.

Sécurité

Pour effectuer ces procédures, vous devez être membre du groupe de sécurité Administrateurs sur l'ordinateur.

Voir aussi

Autres ressources

Vue d'ensemble de l'installation de Team Explorer


Comment : installer Team Explorer

Comment : installer Team Explorer

Utilisez cette procédure pour installer Team Explorer.

Pour installer Team Explorer

  1. Implémentez les composants requis pour installer Team Explorer. Pour plus d'informations, consultez Comment : installer les composants requis de Team Explorer.

  2. Sur la page d'exécution automatique de l'Assistant Installation de Team Foundation Server, cliquez sur Installer Team Explorer.

    Si la page d'exécution automatique ne s'affiche pas, localisez et exécutez le fichier d'exécution automatique (autorun.exe) situé dans le dossier \vs sur le support d'installation.

    L'Assistant Installation de Visual Studio 2005 Team Explorer démarre.

  3. À la page Bienvenue dans le programme d'installation, cliquez sur Suivant.

  4. Sur la page Termes de Licence et clé du produit, examinez le contrat de licence. Si vous acceptez les termes et conditions mentionnés, sélectionnez J'accepte les termes du contrat de licence, puis cliquez sur Suivant.

  5. À la page Dossier de destination, cliquez sur Suivant.

  6. À la page Prêt pour l'installation, cliquez sur Installer.

  7. À la page L'installation s'est terminée avec succès, cliquez sur Terminer.

Remarque Important

Si vous avez auparavant installé MSDN Library pour Visual Studio 2005, vous devez exécuter le programme d'installation pour la version la plus récente de MSDN Library pour vous assurer que vous disposez de la dernière documentation du produit pour Team Foundation. Pour plus d'informations, visitez le site de documentation de Team System situé à l'adresse http://go.microsoft.com/fwlink/?LinkId=62213.

Sécurité

Pour effectuer cette procédure, vous devez être membre du groupe de sécurité Administrateurs sur l'ordinateur.

Voir aussi

Autres ressources

Vue d'ensemble de l'installation de Team Explorer


Comment : connecter Team Explorer à Team Foundation Server

Comment : connecter Team Explorer à Team Foundation Server

Utilisez cette procédure pour ajouter un serveur Team Foundation Server et vous y connecter, à partir de Team Explorer, ou pour supprimer un serveur Team Foundation Server à partir de Team Explorer.

Pour ajouter un serveur Team Foundation Server

  1. Démarrez Microsoft Visual Studio 2005.

  2. Dans le menu Outils, cliquez sur Se connecter à Team Foundation Server.

    La boîte de dialogue Se connecter à Team Foundation Server s'affiche.

  3. Cliquez sur Serveurs.

    La boîte de dialogue Ajouter/supprimer Team Foundation Server s'affiche.

  4. Cliquez sur Ajouter.

    La boîte de dialogue Ajouter Team Foundation Server s'affiche.

  5. Dans la zone Nom Team Foundation Server, tapez le nom de l'ordinateur qui héberge la couche Application de Team Foundation Server.

  6. Dans la zone Numéro de port, spécifiez le port à utiliser pour cette connexion (le port par défaut est 8080 pour HTTP) et sélectionnez le protocole correspondant.

  7. Cliquez sur OK pour retourner à la boîte de dialogue Ajouter/supprimer Team Foundation Server.

  8. Cliquez sur Fermer pour retourner à la boîte de dialogue Se connecter à Team Foundation Server.

  9. Si des projets d'équipe existent sur ce serveur Team Foundation Server, sélectionnez ceux que vous souhaitez utiliser.

  10. Cliquez sur OK.

Pour se connecter à un serveur Team Foundation Server

  1. Démarrez Microsoft Visual Studio 2005.

  2. Dans le menu Outils, cliquez sur Se connecter à Team Foundation Server.

    La boîte de dialogue Se connecter à Team Foundation Server s'affiche.

  3. Dans la liste Se connecter à un Team Foundation Server, sélectionnez le serveur Team Foundation Server que vous souhaitez utiliser.

  4. Si des projets d'équipe existent sur ce serveur Team Foundation Server, sélectionnez ceux que vous souhaitez utiliser.

  5. Cliquez sur OK.

Pour supprimer un serveur Team Foundation Server

  1. Démarrez Microsoft Visual Studio 2005.

    Remarque Remarque

    Si vous êtes actuellement connecté au serveur que vous voulez supprimer, vous devez vous déconnecter en cliquant avec le bouton droit sur le nom du serveur, puis en cliquant sur Déconnecter.

  2. Dans le menu Outils, cliquez sur Se connecter à Team Foundation Server.

    La boîte de dialogue Se connecter à Team Foundation Server s'affiche.

  3. Cliquez sur Serveurs.

    La boîte de dialogue Ajouter/supprimer Team Foundation Server s'affiche.

  4. Dans la liste Team Foundation Server, sélectionnez le serveur Team Foundation Server à supprimer, puis cliquez sur Supprimer.

  5. Cliquez sur Fermer pour retourner à la boîte de dialogue Team Foundation Server, puis cliquez sur OK.

Sécurité

Pour effectuer ces procédures, vous devez être membre du groupe de sécurité Readers ou disposer d'au moins une autorisation sur un projet d'équipe ayant la valeur Autoriser. Pour plus d'informations, consultez « Autorisations de Team Foundation Server » dans le Guide de l'administrateur Team Foundation Server.

Voir aussi

Autres ressources

Vue d'ensemble de l'installation de Team Explorer


Vue d'ensemble de la réparation et de la désinstallation de Team Foundation Server

Vue d'ensemble de la réparation et de la désinstallation de Team Foundation Server
DropDown image

Utilisez les procédures de cette section pour désinstaller Team Foundation Server et tous les composants associés.

Dans cette section

Comment : désinstaller le déploiement de Team Foundation Server sur un serveur

Décrit les étapes permettant de supprimer les composants Team Foundation Server du serveur.

Comment : désinstaller le déploiement de Team Foundation Server sur deux serveurs

Décrit les étapes permettant de supprimer les composants Team Foundation Server des serveurs de couche Application et de couche Données.

Comment : désinstaller Team Foundation Build

Décrit les étapes permettant de supprimer les composants Team Foundation Build du serveur.

Comment : réparer ou installer Team Foundation Server Proxy

Décrit les étapes permettant de restaurer ou de supprimer Team Foundation Server Proxy du serveur.

Comment : réparer ou désinstaller Team Explorer

Décrit les étapes permettant de restaurer ou de supprimer le composant Team Explorer.

Comment : réparer Team Foundation Server

Décrit la façon de rétablir l'état d'origine des composants Team Foundation Server.

Rubriques connexes

Installation de Team Foundation


Comment : désinstaller le déploiement de Team Foundation Server sur un serveur

Comment : désinstaller le déploiement de Team Foundation Server sur un serveur
Voir aussi

Si vous devez procéder à la désinstallation, vous devez supprimer Team Foundation Server et ses composants associés dans l'ordre contraire à celui dans lequel les composants ont été installés, comme illustré dans le tableau suivant :

Ordre | Composant | Emplacement physique
1. | Team Foundation Server Proxy | Ordinateur Team Foundation Server - ou - Ordinateur distinct
2. | Team Foundation Build | Ordinateur Team Foundation Server - ou - Ordinateur distinct
3. | Team Explorer | Ordinateur Team Foundation Server - ou - Ordinateur distinct
4. | Team Foundation Server | Ordinateur Team Foundation Server
5. | Microsoft Windows SharePoint Services | Ordinateur Team Foundation Server
6. | Microsoft SQL Server 2005 | Ordinateur Team Foundation Server
7. | Services IIS | Ordinateur Team Foundation Server
Remarque Remarque

La désinstallation de Visual Studio Team System ne supprime pas les données ni les bases de données.

Désinstallation des composants clients Team Foundation Server

Si vous avez installé les composants de la couche cliente sur l'ordinateur de couche Application, vous devez d'abord désinstaller ces composants.

Pour désinstaller les composants de la couche cliente

  1. Désinstallez Team Foundation Server Proxy. Pour plus d'informations, consultez Comment : réparer ou installer Team Foundation Server Proxy.

  2. Désinstallez Team Foundation Build. Pour plus d'informations, consultez Comment : désinstaller Team Foundation Build.

  3. Désinstallez Team Explorer. Pour plus d'informations, consultez Comment : réparer ou désinstaller Team Explorer.

Désinstallation de Team Foundation Server (services)

Vous devez désinstaller Team Foundation Server avant les autres composants associés. Les services Team Foundation Server, le Planificateur de serveur TFS et l'analyse de couverture du code sont supprimés. Les données utilisateur, Windows SharePoint Services et les pools d'applications sont conservés.

Pour désinstaller Team Foundation Server

  1. Cliquez sur Démarrer, sur Panneau de configuration, puis sur Ajout/Suppression de programmes.

  2. Sélectionnez Microsoft Visual Studio 2005 Team Foundation Server et cliquez sur Modifier/Supprimer.

  3. Sur la page Options du mode Maintenance, sélectionnez Désinstaller, puis cliquez sur Suivant.

  4. Dans le message, cliquez sur OK.

  5. Sur la page Maintenance - Désinstaller, surveillez l'avancement de la suppression des composants.

  6. Sur la page Maintenance - Installation terminée, cliquez sur Terminer.

Désinstallation de Microsoft Windows SharePoint Services

Après avoir désinstallé Team Foundation Server, vous pouvez désinstaller Windows SharePoint Services, si nécessaire.

Pour désinstaller Microsoft Windows SharePoint Services

  1. Cliquez sur Démarrer, sur Panneau de configuration, puis sur Ajout/Suppression de programmes.

  2. Sélectionnez Microsoft Windows SharePoint Services 2.0, puis cliquez sur Supprimer.

  3. Dans le message, cliquez sur Oui.

    Une boîte de dialogue qui indique que la désinstallation est en cours s'affiche. Cette boîte de dialogue se ferme automatiquement à la fin de la désinstallation.

Désinstallation de Microsoft SQL Server 2005

Après avoir désinstallé Windows SharePoint Services, vous pouvez supprimer Microsoft SQL Server 2005, si nécessaire.

Pour désinstaller Microsoft SQL Server 2005

  1. Cliquez sur Démarrer, sur Panneau de configuration, puis sur Ajout/Suppression de programmes.

  2. Sélectionnez Microsoft SQL Server 2005, puis cliquez sur Supprimer.

  3. Sur la page de sélection des composants, sous Sélectionner une instance, choisissez le serveur à supprimer.

    Remarque Remarque

    Cliquez sur le bouton Rapport pour afficher une liste des fonctionnalités et composants SQL Server 2005 installés sur votre ordinateur.

  4. Sous Supprimer les composants communs SQL Server 2005, sélectionnez les composants que vous envisagez de désinstaller.

  5. Cliquez sur Suivant.

  6. Sur la page Confirmation, passez en revue la liste des composants et fonctionnalités à supprimer, puis cliquez sur Terminer.

  7. Sur la page Terminer, cliquez sur Quitter.

Désinstallation des services IIS

Après avoir désinstallé Microsoft SQL Server 2005, vous pouvez supprimer les services IIS, si nécessaire.

Pour désinstaller les services IIS

  1. Cliquez sur Démarrer, puis sur Assistant Configurer votre serveur.

  2. Sur la page Bienvenue dans l'Assistant Configurer votre serveur, cliquez sur Suivant.

  3. À la page Étapes préliminaires, cliquez sur Suivant.

  4. Sur la page Rôle du serveur, sélectionnez Serveur d'applications (IIS, ASP.NET), puis cliquez sur Suivant.

  5. Cliquez sur Terminer.

Sécurité

Pour effectuer cette procédure, vous devez être membre du groupe de sécurité Administrateurs sur l'ordinateur. Pour plus d'informations, consultez Comptes d'utilisateurs requis pour l'installation de Team Foundation Server.

Voir aussi

Référence

Liste de vérification : déploiement sur un serveur de Team Foundation Server

Autres ressources

Vue d'ensemble de la réparation et de la désinstallation de Team Foundation Server


Comment : désinstaller le déploiement de Team Foundation Server sur deux serveurs

Comment : désinstaller le déploiement de Team Foundation Server sur deux serveurs
Voir aussi

Si vous devez procéder à la désinstallation, vous devez supprimer Team Foundation Server et ses composants associés dans l'ordre contraire à celui dans lequel les composants ont été installés, comme illustré dans le tableau suivant :

Ordre | Composant | Emplacement physique
1. | Team Foundation Server Proxy | Ordinateur de couche Application - ou - Ordinateur distinct
2. | contrôle de code source Team Foundation | Ordinateur de couche Application - ou - Ordinateur distinct
3. | Team Explorer | Ordinateur de couche Application - ou - Ordinateur distinct
4. | Team Foundation Server (services) | Ordinateur de couche Application
5. | Microsoft SQL Server 2005 Reporting Services | Ordinateur de couche Application
5. | Microsoft Windows SharePoint Services pour Team Foundation Server | Ordinateur de couche Application
6. | Services IIS (Internet Information Services) pour Team Foundation Server | Ordinateur de couche Application
7. | Team Foundation Server (bases de données) | Ordinateur de couche Données
8. | Microsoft SQL Server 2005 pour Team Foundation Server | Ordinateur de couche Données
Remarque Remarque

La désinstallation des bases de données Team Foundation Server ne supprime pas les données ni les bases de données.

Utilisez les sections ci-dessous pour désinstaller correctement Team Foundation Server sur deux serveurs.

Désinstallation des composants clients Team Foundation Server

Si vous avez installé les composants de la couche cliente sur l'ordinateur de couche Application, vous devez d'abord désinstaller ces composants.

Pour désinstaller les composants de la couche cliente

  1. Désinstallez Team Explorer. Pour plus d'informations, consultez Comment : réparer ou désinstaller Team Explorer.

  2. Désinstallez Team Foundation Server Proxy. Pour plus d'informations, consultez Comment : réparer ou installer Team Foundation Server Proxy.

  3. Désinstallez Team Foundation Build. Pour plus d'informations, consultez Comment : désinstaller Team Foundation Build.

Désinstallation de Team Foundation Server (services)

Vous devez désinstaller tous les composants des services de couche Application avant de désinstaller tous les composants de l'ordinateur de couche Base de données.

L'Assistant supprime les pools d'applications, le site Web, les fichiers, le Registre ainsi que les paramètres du pare-feu associés à Team Foundation Server. Les données utilisateur ne sont pas supprimées. Windows SharePoint Services est conservé. Les services Team Foundation Server, le Planificateur de serveur TFS et l'analyse de couverture du code sont supprimés.

Pour désinstaller Team Foundation Server (services)

  1. Sur l'ordinateur de couche Application, cliquez sur Démarrer, sur Panneau de configuration, puis sur Ajout/Suppression de programmes.

  2. Sélectionnez Microsoft Visual Studio 2005 Team Foundation Server (services) et cliquez sur Modifier/Supprimer.

  3. Sur la page Options du mode Maintenance, sélectionnez Désinstaller, puis cliquez sur Suivant.

  4. Dans le message, cliquez sur OK.

  5. Sur la page Maintenance - Désinstaller, examinez l'avancement de la suppression des composants.

  6. Sur la page Maintenance - Installation terminée, cliquez sur Terminer.

Après avoir désinstallé Team Foundation Server (services), vous pouvez désinstaller Windows SharePoint Services.

Pour désinstaller Microsoft Windows SharePoint Services pour Team Foundation Server

  1. Cliquez sur Démarrer, sur Panneau de configuration, puis sur Ajout/Suppression de programmes.

  2. Sélectionnez Microsoft Windows SharePoint Services 2.0, puis cliquez sur Supprimer.

  3. Dans le message, cliquez sur Oui.

    Cette boîte de dialogue se ferme automatiquement à la fin de la désinstallation.

La désinstallation des services IIS désactive également ASP.NET.

Pour désinstaller les services IIS pour Team Foundation Server

  1. Cliquez sur Démarrer, puis sur Assistant Configurer votre serveur.

  2. Sur la page Bienvenue dans l'Assistant Configurer votre serveur, cliquez sur Suivant.

  3. À la page Étapes préliminaires, cliquez sur Suivant.

  4. À la page Rôle du serveur, sélectionnez Serveur d'applications (IIS, ASP.NET), puis cliquez sur Suivant.

  5. Sur la page Confirmation de suppression de rôle, cliquez sur Supprimer le rôle du serveur d'applications, puis sur Suivant.

  6. Cliquez sur Terminer.

Désinstaller Team Foundation Server (bases de données)

Après avoir désinstallé tous les logiciels associés à Team Foundation Server sur l'ordinateur de couche Application, vous pouvez désinstaller les composants Team Foundation Server (bases de données).

Pour désinstaller Team Foundation Server (bases de données)

  1. Dans le menu Démarrer, cliquez sur Panneau de configuration, puis sur Ajout/Suppression de programmes.

  2. Sélectionnez Microsoft Microsoft Visual Studio 2005 Team System (bases de données), puis cliquez sur Modifier/Supprimer.

  3. Sur la page Options du mode Maintenance, sélectionnez Désinstaller, puis cliquez sur Suivant.

  4. Sur la page Maintenance - Désinstaller, surveillez l'avancement de la suppression des composants.

  5. Dans le message, cliquez sur OK.

  6. Sur la page de fin, cliquez sur Terminer.

La désinstallation du serveur Visual Studio Team System ne supprime pas les données ni les bases de données.

Pour désinstaller Microsoft SQL Server 2005 pour Team Foundation Server

  1. Ouvrez une session sur l'ordinateur de couche Données.

    Attention Attention

    Si vous procédez à la désinstallation sur un cluster, vous devez ouvrir une session sur le nœud actif du cluster. Une fois la désinstallation terminée sur le nœud actif, le cluster bascule sur le second nœud. Vous devez ouvrir une session sur le second nœud pour y continuer la désinstallation.

  2. Cliquez sur Démarrer, sur Panneau de configuration, puis sur Ajout/Suppression de programmes.

  3. Sélectionnez Microsoft SQL Server 2005, puis cliquez sur Supprimer.

  4. Sur la page de sélection des composants, sous Sélectionner une instance, choisissez le serveur à supprimer.

    Remarque Remarque

    Cliquez sur le bouton Rapport pour afficher une liste des fonctionnalités et composants SQL Server 2005 installés sur votre ordinateur.

  5. Sous Supprimer les composants communs SQL Server 2005, sélectionnez les composants que vous envisagez de désinstaller.

  6. Cliquez sur Next.

  7. Sur la page Confirmation, passez en revue la liste des composants et fonctionnalités à supprimer, puis cliquez sur Terminer.

  8. Sur la page Terminer, cliquez sur Quitter.

Sécurité

Pour effectuer ces procédures, vous devez être membre du groupe de sécurité Administrateurs sur l'ordinateur. Pour plus d'informations, consultez Comptes d'utilisateurs requis pour l'installation de Team Foundation Server.

Voir aussi

Autres ressources

Vue d'ensemble de la réparation et de la désinstallation de Team Foundation Server


Comment : désinstaller Team Foundation Build

Comment : désinstaller Team Foundation Build

Team Foundation Build étant un client de Team Foundation Server, sa désinstallation supprime uniquement le composant client. Les autres composants, programmes ou bibliothèques de liens dynamiques (.dll) que vous avez ajoutés pour prendre en charge les générations sont conservés après l'installation. Utilisez la procédure suivante pour désinstaller Team Foundation Build.

Pour désinstaller Team Foundation Build

  1. Cliquez sur Démarrer, sur Panneau de configuration, puis sur Ajout/Suppression de programmes.

  2. Sélectionnez Microsoft Visual Studio 2005 Team Foundation Server (build) et cliquez sur Modifier/Supprimer.

  3. Sur la page Options du mode Maintenance, sélectionnez Désinstaller, puis cliquez sur Suivant.

  4. Sur la page Maintenance - Désinstaller, surveillez l'avancement de la suppression des composants.

  5. Sur la page Maintenance - Installation terminée, cliquez sur Terminer.

Sécurité

Pour effectuer cette procédure, vous devez être membre du groupe de sécurité Administrateurs sur l'ordinateur. Pour plus d'informations, consultez Comptes d'utilisateurs requis pour l'installation de Team Foundation Server.

Voir aussi

Autres ressources

Vue d'ensemble de la réparation et de la désinstallation de Team Foundation Server
Vue d'ensemble de l'installation de Team Foundation Build


Comment : réparer ou installer Team Foundation Server Proxy

Comment : réparer ou installer Team Foundation Server Proxy

Utilisez les procédures suivantes pour réparer ou désinstaller Team Foundation Server Proxy.

Remarque Remarque

La procédure de réparation exige que vous redémarriez l'ordinateur proxy.

Pour réparer Team Foundation Server Proxy

  1. Ouvrez une session sur l'ordinateur proxy, cliquez sur Démarrer, sur Panneau de configuration, puis sur Ajout/Suppression de programmes.

  2. Sélectionnez Microsoft Visual Studio 2005 Team Foundation Server Proxy et cliquez sur Modifier/Supprimer.

  3. Sur la page Options du mode Maintenance, sélectionnez Réparer/Réinstaller, puis cliquez sur Suivant.

  4. Sur la page Compte de service, tapez le mot de passe du compte de service.

    Remarque Remarque

    Le compte de service est spécifique à votre organisation. Ce guide utilise Domaine/TFSPROXY en tant qu'espace réservé pour ce compte.

  5. Sur la page Maintenance - Réparer/Réinstaller, examinez la liste des composants, puis cliquez sur Redémarrer maintenant à l'invite.

  6. Ouvrez une session sur l'ordinateur proxy et, sur la page Maintenance - Installation terminée, cliquez sur Terminer.

    Remarque Remarque

    Si vous avez ouvert une session à distance, vous devez ouvrir une session en tant que console.

Pour désinstaller Team Foundation Server Proxy

  1. Cliquez sur Démarrer, sur Panneau de configuration, puis sur Ajout/Suppression de programmes.

  2. Dans la boîte de dialogue Ajout/Suppression de programmes, sélectionnez Microsoft Visual Studio 2005 Team Foundation Server (proxy), puis cliquez sur Modifier/Supprimer.

  3. Sur la page Options du mode Maintenance, cliquez sur Désinstaller.

  4. À l'invite, cliquez sur Oui.

  5. Sur la page Maintenance - Installation terminée, cliquez sur Terminer.

Sécurité

Pour effectuer cette procédure, vous devez être membre du groupe de sécurité Administrateurs sur l'ordinateur proxy. Pour plus d'informations, consultez Comptes d'utilisateurs requis pour l'installation de Team Foundation Server.

Voir aussi

Autres ressources

Vue d'ensemble de la réparation et de la désinstallation de Team Foundation Server
Vue d'ensemble de l'installation de Team Foundation Server Proxy


Comment : réparer ou désinstaller Team Explorer

Comment : réparer ou désinstaller Team Explorer

Utilisez les procédures suivantes pour rétablir l'état d'origine de Team Explorer ou désinstaller Team Explorer.

Réparation de Team Explorer

Si vous obtenez des résultats imprévus lorsque vous utilisez Team Explorer, vous pouvez réparer l'installation.

Pour réparer Team Explorer

  1. Cliquez sur Démarrer, sur Panneau de configuration, puis sur Ajout/Suppression de programmes.

  2. Sélectionnez Microsoft Visual Studio 2005 Team Explorer, puis cliquez sur Modifier/Supprimer.

  3. Sur la page Options du mode Maintenance, sélectionnez Réparer/Réinstaller, puis cliquez sur Suivant.

  4. À la page Prêt pour l'installation, cliquez sur Installer.

  5. Sur la page Maintenance - Réparer/Réinstaller, examinez l'avancement de l'installation.

  6. À l'invite, cliquez sur Redémarrer maintenant, puis laissez le temps au serveur de redémarrer.

    Remarque Remarque

    Microsoft .NET Framework version 2.0 est nécessaire aux autres composants pour que l'ordinateur soit redémarré.

  7. Ouvrez une session sur l'ordinateur et laissez l'installation se poursuivre.

  8. Sur la page Maintenance - Réparer/Réinstaller, examinez l'avancement de l'installation.

  9. À l'invite, cliquez sur Redémarrer maintenant, puis laissez le temps au serveur de redémarrer.

  10. Ouvrez une session sur l'ordinateur et laissez l'installation se poursuivre.

  11. Sur la page Maintenance - Installation terminée, cliquez sur Terminer.

Désinstallation de Team Explorer

Si Team Explorer est devenu inutile sur votre ordinateur, vous pouvez le supprimer.

Pour désinstaller Team Explorer

  1. Cliquez sur Démarrer, sur Panneau de configuration, puis sur Ajout/Suppression de programmes.

  2. Sélectionnez Microsoft Visual Studio 2005 Team Explorer, puis cliquez sur Modifier/Supprimer.

  3. Sur la page Options du mode Maintenance, sélectionnez Désinstaller, puis cliquez sur Suivant.

  4. Dans le message, cliquez sur OK.

  5. Sur la page Maintenance - Désinstaller, examinez l'avancement de la suppression des composants.

  6. Sur la page Maintenance - Installation terminée, cliquez sur Terminer.

Sécurité

Pour effectuer cette procédure, vous devez être membre du groupe de sécurité Administrateurs sur l'ordinateur. Pour plus d'informations, consultez Comptes d'utilisateurs requis pour l'installation de Team Foundation Server.

Voir aussi

Autres ressources

Vue d'ensemble de la réparation et de la désinstallation de Team Foundation Server
Vue d'ensemble de l'installation de Team Explorer


Comment : réparer Team Foundation Server

Comment : réparer Team Foundation Server

Utilisez les procédures suivantes pour rétablir l'état d'origine des composants Team Foundation Server et réinstaller les composants requis par Team Foundation Server.

Réparation de Team Foundation Server (bases de données)

Pour réparer Team Foundation Server (bases de données)

  1. Cliquez sur Démarrer, sur Panneau de configuration, puis sur Ajout/Suppression de programmes.

  2. Sélectionnez Microsoft Visual Studio 2005 Team Foundation Server (bases de données) et cliquez sur Modifier/Supprimer.

  3. Sur la page Options du mode Maintenance, sélectionnez Réparer/Réinstaller, puis cliquez sur Suivant.

  4. Sur la page Compte de service, tapez le compte d'utilisateur de domaine que vous avez créé pour le compte de service Team Foundation Server dans la zone Nom du compte, puis cliquez sur Suivant.

    Remarque Remarque

    Le compte de service est spécifique à votre organisation. Ce guide utilise Domaine/TFSSERVICE en tant qu'espace réservé pour ce compte.

  5. Sur la page Prêt pour l'installation, vérifiez les informations, puis cliquez sur Installer.

    La page Maintenance - Réparer/Réinstaller s'affiche.

  6. Sur la page Maintenance - Installation terminée, cliquez sur Terminer.

Réparation de Team Foundation Server (services)

Pour réparer Team Foundation Server (services)

  1. Ouvrez une session sur la couche Application.

  2. Cliquez sur Démarrer, sur Panneau de configuration, puis sur Ajout/Suppression de programmes.

  3. Sélectionnez Microsoft Visual Studio 2005 Team Foundation Server (services) et cliquez sur Modifier/Supprimer.

  4. Sur la page Options du mode Maintenance, sélectionnez Réparer/Réinstaller, puis cliquez sur Suivant.

  5. Sur la page Compte de service, tapez le mot de passe du compte de service.

    Remarque Remarque

    Le compte de service est spécifique à votre organisation. Ce guide utilise Domaine/TFSSERVICE en tant qu'espace réservé pour ce compte.

  6. Dans Compte de source de données de création de rapports, tapez le mot de passe du compte Reporting Services.

    Remarque Remarque

    Le compte est spécifique à votre organisation. Ce guide utilise Domaine/TFSREPORTS en tant qu'espace réservé pour ce compte.

  7. Sur la page Prêt pour l'installation, vérifiez les composants, les comptes, puis cliquez sur Installer.

  8. Sur la page Maintenance - Réparer/Réinstaller, examinez l'avancement de l'installation.

  9. Sur la page Maintenance - Installation terminée, cliquez sur Terminer.

Sécurité

Pour effectuer cette procédure, vous devez être membre du groupe de sécurité Administrateurs sur l'ordinateur. Pour plus d'informations, consultez Comptes d'utilisateurs requis pour l'installation de Team Foundation Server.

Voir aussi

Autres ressources

Vue d'ensemble de la réparation et de la désinstallation de Team Foundation Server


Notices légales relatives au Guide d'installation Team Foundation

 Image de liste déroulante Image de pointage sur liste déroulante Image de réduction Image de développement Image Réduire tout Image Développer tout Copier l'image de pointage
Visual Studio Team System
Notices légales relatives au Guide d'installation Team Foundation
Image Réduire tout Image de liste déroulante

Cette section contient des mentions légales qui se rapportent au Guide d'installation Team Foundation.

Image de développement Mentions légales

Ce document est fourni à titre d'information uniquement et Microsoft exclut toute garantie, expresse ou implicite, en ce qui concerne ce document. Les informations contenues dans ce document, y compris les adresses URL et les autres références à des sites Internet, pourront faire l'objet de modifications sans préavis. Le risque lié à l'utilisation ou aux résultats d'utilisation de ce document incombe entièrement à l'utilisateur. Sauf mention contraire, les noms de sociétés, d'organisations, de produits et de domaines, les adresses de messagerie, les logos, et les noms de personnes et de lieux, ou les événements utilisés dans les exemples, sont fictifs et toute ressemblance avec des noms ou des événements réels est purement fortuite et involontaire. L'utilisateur est tenu d'observer la réglementation relative aux droits d'auteur applicable dans son pays. Aucune partie de ce document ne peut être reproduite, stockée ou introduite dans un système de restitution, ou transmise à quelque fin ou par quelque moyen que ce soit (électronique, mécanique, photocopie, enregistrement ou autre) sans la permission expresse et écrite de Microsoft Corporation.

Microsoft peut détenir des brevets, avoir déposé des demandes d'enregistrement de brevets ou être titulaire de marques, droits d'auteur ou autres droits de propriété intellectuelle portant sur tout ou partie des éléments qui font l'objet du présent document. Sauf stipulation expresse contraire d'un contrat de licence écrit de Microsoft, la fourniture de ce document n'a pas pour effet de vous concéder une licence sur ces brevets, marques, droits d'auteur ou autres droits de propriété intellectuelle.

© 2005 Microsoft Corporation. Tous droits réservés.

Microsoft, Visual Studio, Windows, SharePoint et Windows Server sont soit des marques de Microsoft Corporation, soit des marques déposées de Microsoft Corporation, aux États-Unis d'Amérique et/ou dans d'autres pays.

Toutes les autres marques sont la propriété de leurs propriétaires respectifs.