Namespaces
Microsoft.VisualBasic
AppWinStyle
Collection
CompareMethod
Constants
ControlChars
Conversion
DateAndTime
DateFormat
DateInterval
DueDate
ErrObject
Financial
FirstDayOfWeek
FirstWeekOfYear
Information
Interaction
MsgBoxResult
MsgBoxStyle
SpcInfo
Strings
TabInfo
TriState
VBFixedArrayAttribute
VBFixedStringAttribute
VBMath
Microsoft.VisualBasic.CompilerServices
BooleanType
ByteType
CharArrayType
CharType
DateType
DecimalType
DoubleType
ExceptionUtils
FlowControl
HostServices
IncompleteInitialization
IntegerType
IVbHost
LongType
ObjectType
OptionCompareAttribute
OptionTextAttribute
ProjectData
ShortType
SingleType
StandardModuleAttribute
StaticLocalInitFlag
StringType
UnsafeNativeMethods+tagDESCKIND
UnsafeNativeMethods+tagFUNCDESC
UnsafeNativeMethods+tagINVOKEKIND
UnsafeNativeMethods+tagPARAMDESC
UnsafeNativeMethods+tagSYSKIND
UnsafeNativeMethods+tagTLIBATTR
UnsafeNativeMethods+tagTYPEDESC
UnsafeNativeMethods+tagTYPEKIND
UnsafeNativeMethods+tagVARDESC
UnsafeNativeMethods+value_tagELEMDESC
Utils
Microsoft.WindowsCE.Forms
InputPanel
Message
MessageWindow
System
Activator
AppDomain
ApplicationException
ArgumentException
ArgumentNullException
ArgumentOutOfRangeException
ArithmeticException
Array
ArrayTypeMismatchException
AsyncCallback
Attribute
AttributeTargets
AttributeUsageAttribute
BitConverter
Boolean
Buffer
Byte
Char
CharEnumerator
CLSCompliantAttribute
Console
Convert
DateTime
DayOfWeek
DBNull
Decimal
Delegate
DivideByZeroException
DllNotFoundException
Double
EntryPointNotFoundException
Enum
Environment
EventArgs
EventHandler
Exception
FlagsAttribute
FormatException
GC
Guid
IAsyncResult
ICloneable
IComparable
IConvertible
ICustomFormatter
IDisposable
IFormatProvider
IFormattable
IndexOutOfRangeException
Int16
Int32
Int64
IntPtr
InvalidCastException
InvalidOperationException
InvalidProgramException
IServiceProvider
LocalDataStoreSlot
MarshalByRefObject
Math
MemberAccessException
MissingFieldException
MissingMemberException
MissingMethodException
MulticastDelegate
MulticastNotSupportedException
NonSerializedAttribute
NotFiniteNumberException
NotSupportedException
NullReferenceException
Object
ObjectDisposedException
ObsoleteAttribute
OperatingSystem
OutOfMemoryException
OverflowException
ParamArrayAttribute
PlatformID
PlatformNotSupportedException
Random
RankException
RuntimeFieldHandle
RuntimeMethodHandle
RuntimeTypeHandle
SByte
Single
StackOverflowException
String
SystemException
TimeSpan
TimeZone
Type
TypeCode
TypedReference
TypeLoadException
UInt16
UInt32
UInt64
UIntPtr
UnauthorizedAccessException
Uri
UriFormatException
UriHostNameType
UriPartial
ValueType
Version
Void
WeakReference
System.Collections
ArrayList
BitArray
CaseInsensitiveComparer
CaseInsensitiveHashCodeProvider
CollectionBase
Comparer
DictionaryEntry
Hashtable
ICollection
IComparer
IDictionary
IDictionaryEnumerator
IEnumerable
IEnumerator
IHashCodeProvider
IList
Queue
Stack
System.Collections.Specialized
BitVector32
BitVector32+Section
HybridDictionary
ListDictionary
NameObjectCollectionBase
NameObjectCollectionBase+KeysCollection
NameValueCollection
System.ComponentModel
AttributeCollection
CancelEventArgs
CancelEventHandler
CollectionChangeAction
CollectionChangeEventArgs
CollectionChangeEventHandler
Component
ComponentResourceManager
Container
DefaultValueAttribute
DesignerCategoryAttribute
EditorBrowsableAttribute
EditorBrowsableState
EventDescriptor
EventDescriptorCollection
EventHandlerList
IBindingList
IComponent
IContainer
ICustomTypeDescriptor
IDataErrorInfo
IEditableObject
IListSource
ISite
ITypedList
ListChangedEventArgs
ListChangedEventHandler
ListChangedType
ListSortDirection
MarshalByValueComponent
MemberDescriptor
PropertyChangedEventArgs
PropertyChangedEventHandler
PropertyDescriptor
PropertyDescriptorCollection
TypeConverter
TypeDescriptor
Win32Exception
System.Configuration.Assemblies
AssemblyHashAlgorithm
AssemblyVersionCompatibility
System.Data
AcceptRejectRule
CommandBehavior
CommandType
ConnectionState
Constraint
ConstraintCollection
ConstraintException
DataColumn
DataColumnChangeEventArgs
DataColumnChangeEventHandler
DataColumnCollection
DataException
DataRelation
DataRelationCollection
DataRow
DataRowAction
DataRowBuilder
DataRowChangeEventArgs
DataRowChangeEventHandler
DataRowCollection
DataRowState
DataRowVersion
DataRowView
DataSet
DataTable
DataTableCollection
DataView
DataViewManager
DataViewRowState
DataViewSetting
DataViewSettingCollection
DBConcurrencyException
DbType
DeletedRowInaccessibleException
DuplicateNameException
EvaluateException
FillErrorEventArgs
FillErrorEventHandler
ForeignKeyConstraint
IColumnMapping
IColumnMappingCollection
IDataAdapter
IDataParameter
IDataParameterCollection
IDataReader
IDataRecord
IDbCommand
IDbConnection
IDbDataAdapter
IDbDataParameter
IDbTransaction
InRowChangingEventException
InternalDataCollectionBase
InvalidConstraintException
InvalidExpressionException
IsolationLevel
ITableMapping
ITableMappingCollection
MappingType
MissingMappingAction
MissingPrimaryKeyException
MissingSchemaAction
NoNullAllowedException
ParameterDirection
PropertyAttributes
PropertyCollection
ReadOnlyException
RowNotInTableException
Rule
SchemaType
SqlDbType
StateChangeEventArgs
StateChangeEventHandler
StatementType
SyntaxErrorException
UniqueConstraint
UpdateRowSource
UpdateStatus
VersionNotFoundException
XmlReadMode
XmlWriteMode
System.Data.Common
DataAdapter
DataColumnMapping
DataColumnMappingCollection
DataTableMapping
DataTableMappingCollection
DbDataAdapter
DbDataRecord
DbEnumerator
RowUpdatedEventArgs
RowUpdatingEventArgs
System.Data.SqlClient
SqlCommand
SqlCommandBuilder
SqlConnection
SqlDataAdapter
SqlDataReader
SqlError
SqlErrorCollection
SqlException
SqlInfoMessageEventArgs
SqlInfoMessageEventHandler
SqlParameter
SqlParameterCollection
SqlRowUpdatedEventArgs
SqlRowUpdatedEventHandler
SqlRowUpdatingEventArgs
SqlRowUpdatingEventHandler
SqlTransaction
System.Data.SqlServerCe
AddOption
DbRangeOptions
DbSeekOptions
DropOption
ExchangeType
NetworkType
RdaBatchOption
RdaTrackOption
SecurityType
SqlCeCommand
SqlCeCommandBuilder
SqlCeConnection
SqlCeDataAdapter
SqlCeDataReader
SqlCeEngine
SqlCeError
SqlCeErrorCollection
SqlCeException
SqlCeInfoMessageEventArgs
SqlCeInfoMessageEventHandler
SqlCeParameter
SqlCeParameterCollection
SqlCeRemoteDataAccess
SqlCeReplication
SqlCeRowUpdatedEventArgs
SqlCeRowUpdatedEventHandler
SqlCeRowUpdatingEventArgs
SqlCeRowUpdatingEventHandler
SqlCeTransaction
ValidateType
System.Data.SqlTypes
INullable
SqlBinary
SqlBoolean
SqlByte
SqlCompareOptions
SqlDateTime
SqlDecimal
SqlDouble
SqlGuid
SqlInt16
SqlInt32
SqlInt64
SqlMoney
SqlNullValueException
SqlSingle
SqlString
SqlTruncateException
SqlTypeException
System.Diagnostics
ConditionalAttribute
Debug
DebuggableAttribute
Debugger
DebuggerStepThroughAttribute
DefaultTraceListener
Trace
TraceListener
TraceListenerCollection
System.Drawing
Bitmap
Brush
Color
ContentAlignment
Font
FontFamily
FontStyle
Graphics
GraphicsUnit
Icon
Image
Pen
Point
Rectangle
RectangleF
Region
Size
SizeF
SolidBrush
SystemColors
System.Drawing.Drawing2D
CombineMode
System.Drawing.Imaging
ImageAttributes
System.Globalization
Calendar
CalendarWeekRule
CompareInfo
CompareOptions
CultureInfo
CultureTypes
DateTimeFormatInfo
DateTimeStyles
DaylightTime
GregorianCalendar
GregorianCalendarTypes
JapaneseCalendar
KoreanCalendar
NumberFormatInfo
NumberStyles
RegionInfo
StringInfo
TaiwanCalendar
TextElementEnumerator
TextInfo
ThaiBuddhistCalendar
UnicodeCategory
System.IO
BinaryReader
BinaryWriter
Directory
DirectoryInfo
DirectoryNotFoundException
EndOfStreamException
File
FileAccess
FileAttributes
FileInfo
FileMode
FileNotFoundException
FileShare
FileStream
FileSystemInfo
IOException
MemoryStream
Path
PathTooLongException
SeekOrigin
Stream
StreamReader
StreamWriter
StringReader
StringWriter
TextReader
TextWriter
System.Net
AuthenticationManager
Authorization
Dns
EndPoint
GlobalProxySelection
HttpContinueDelegate
HttpStatusCode
HttpVersion
HttpWebRequest
HttpWebResponse
IAuthenticationModule
ICertificatePolicy
ICredentials
IPAddress
IPEndPoint
IPHostEntry
IrDAEndPoint
IWebProxy
IWebRequestCreate
NetworkCredential
ProtocolViolationException
ServicePoint
ServicePointManager
SocketAddress
WebException
WebExceptionStatus
WebHeaderCollection
WebProxy
WebRequest
WebResponse
System.Net.Sockets
AddressFamily
IrDACharacterSet
IrDAClient
IrDADeviceInfo
IrDAHints
IrDAListener
LingerOption
MulticastOption
NetworkStream
ProtocolFamily
ProtocolType
SelectMode
Socket
SocketException
SocketFlags
SocketOptionLevel
SocketOptionName
SocketShutdown
SocketType
TcpClient
TcpListener
UdpClient
System.Reflection
AmbiguousMatchException
Assembly
AssemblyAlgorithmIdAttribute
AssemblyCompanyAttribute
AssemblyConfigurationAttribute
AssemblyCopyrightAttribute
AssemblyCultureAttribute
AssemblyDefaultAliasAttribute
AssemblyDelaySignAttribute
AssemblyDescriptionAttribute
AssemblyFlagsAttribute
AssemblyInformationalVersionAttribute
AssemblyKeyFileAttribute
AssemblyKeyNameAttribute
AssemblyName
AssemblyNameFlags
AssemblyProductAttribute
AssemblyTitleAttribute
AssemblyTrademarkAttribute
AssemblyVersionAttribute
Binder
BindingFlags
CallingConventions
ConstructorInfo
CustomAttributeFormatException
DefaultMemberAttribute
EventAttributes
EventInfo
FieldAttributes
FieldInfo
ICustomAttributeProvider
MemberInfo
MemberTypes
MethodAttributes
MethodBase
MethodImplAttributes
MethodInfo
Missing
Module
ParameterAttributes
ParameterInfo
ParameterModifier
PropertyAttributes
PropertyInfo
TargetInvocationException
TargetParameterCountException
TypeAttributes
System.Resources
IResourceReader
MissingManifestResourceException
NeutralResourcesLanguageAttribute
ResourceManager
ResourceReader
ResourceSet
SatelliteContractVersionAttribute
System.Runtime.CompilerServices
AccessedThroughPropertyAttribute
CustomConstantAttribute
DateTimeConstantAttribute
DecimalConstantAttribute
IndexerNameAttribute
MethodCodeType
MethodImplAttribute
MethodImplOptions
RuntimeHelpers
System.Runtime.InteropServices
CallingConvention
CharSet
ComVisibleAttribute
DispIdAttribute
DllImportAttribute
ExternalException
GCHandle
GCHandleType
GuidAttribute
InAttribute
LayoutKind
Marshal
OutAttribute
StructLayoutAttribute
UnmanagedType
System.Security
SecurityException
VerificationException
System.Security.Cryptography.X509Certificates
X509Certificate
System.Security.Policy
Evidence
System.Text
ASCIIEncoding
Decoder
Encoder
Encoding
MLangCodePageEncoding
StringBuilder
UnicodeEncoding
UTF7Encoding
UTF8Encoding
System.Text.RegularExpressions
Capture
CaptureCollection
Group
GroupCollection
Match
MatchCollection
MatchEvaluator
Regex
RegexOptions
RegexRunner
RegexRunnerFactory
System.Threading
AutoResetEvent
Interlocked
ManualResetEvent
Monitor
Mutex
Thread
ThreadPool
ThreadPriority
ThreadStart
ThreadStateException
Timeout
Timer
TimerCallback
WaitCallback
WaitHandle
System.Web.Services
WebMethodAttribute
WebServiceBindingAttribute
System.Web.Services.Description
SoapBindingUse
System.Web.Services.Protocols
HttpWebClientProtocol
LogicalMethodInfo
LogicalMethodTypes
SoapClientMessage
SoapDocumentMethodAttribute
SoapDocumentServiceAttribute
SoapException
SoapExtension
SoapExtensionAttribute
SoapHeader
SoapHeaderAttribute
SoapHeaderCollection
SoapHeaderDirection
SoapHeaderException
SoapHttpClientProtocol
SoapMessage
SoapMessageStage
SoapParameterStyle
SoapRpcMethodAttribute
SoapServiceRoutingStyle
SoapUnknownHeader
WebClientAsyncResult
WebClientProtocol
System.Windows.Forms
Application
BaseCollection
Binding
BindingContext
BindingManagerBase
BindingMemberInfo
BindingsCollection
BorderStyle
Button
ButtonBase
CheckBox
CheckState
ColumnClickEventArgs
ColumnClickEventHandler
ColumnHeader
ColumnHeaderStyle
ComboBox
ComboBox+ObjectCollection
ComboBoxStyle
CommonDialog
ContainerControl
ContextMenu
Control
Control+ControlCollection
ControlBindingsCollection
ConvertEventArgs
ConvertEventHandler
CurrencyManager
Cursor
Cursors
DataGrid
DataGrid+HitTestInfo
DataGrid+HitTestType
DataGridCell
DataGridColumnStyle
DataGridTableStyle
DataGridTextBoxColumn
DialogResult
DomainUpDown
DomainUpDown+DomainUpDownItemCollection
FileDialog
Form
FormBorderStyle
FormWindowState
GridColumnStylesCollection
GridTableStylesCollection
HorizontalAlignment
HScrollBar
ImageList
ImageList+ImageCollection
ItemActivation
ItemChangedEventArgs
ItemChangedEventHandler
ItemCheckEventArgs
ItemCheckEventHandler
KeyEventArgs
KeyEventHandler
KeyPressEventArgs
KeyPressEventHandler
Keys
Label
ListBox
ListBox+ObjectCollection
ListControl
ListView
ListView+ColumnHeaderCollection
ListView+ListViewItemCollection
ListView+SelectedIndexCollection
ListViewItem
ListViewItem+ListViewSubItem
ListViewItem+ListViewSubItemCollection
MainMenu
Menu
Menu+MenuItemCollection
MenuItem
MessageBox
MessageBoxButtons
MessageBoxDefaultButton
MessageBoxIcon
MouseButtons
MouseEventArgs
MouseEventHandler
NumericUpDown
OpenFileDialog
Orientation
PaintEventArgs
PaintEventHandler
Panel
PictureBox
PictureBoxSizeMode
ProgressBar
PropertyManager
RadioButton
SaveFileDialog
Screen
ScrollableControl
ScrollBar
ScrollBars
StatusBar
SystemInformation
TabControl
TabControl+TabPageCollection
TabPage
TextBox
TextBoxBase
Timer
ToolBar
ToolBar+ToolBarButtonCollection
ToolBarButton
ToolBarButtonClickEventArgs
ToolBarButtonClickEventHandler
ToolBarButtonStyle
TrackBar
TreeNode
TreeNodeCollection
TreeView
TreeViewAction
TreeViewCancelEventArgs
TreeViewCancelEventHandler
TreeViewEventArgs
TreeViewEventHandler
UpDownBase
View
VScrollBar
System.Xml
EntityHandling
Formatting
IXmlLineInfo
NameTable
ReadState
WhitespaceHandling
WriteState
XmlAttribute
XmlAttributeCollection
XmlCDataSection
XmlCharacterData
XmlComment
XmlConvert
XmlDeclaration
XmlDocument
XmlDocumentFragment
XmlElement
XmlEntityReference
XmlException
XmlImplementation
XmlLinkedNode
XmlNamedNodeMap
XmlNamespaceManager
XmlNameTable
XmlNode
XmlNodeChangedAction
XmlNodeChangedEventArgs
XmlNodeChangedEventHandler
XmlNodeList
XmlNodeReader
XmlNodeReaderNavigator+VirtualAttribute
XmlNodeType
XmlParserContext
XmlProcessingInstruction
XmlQualifiedName
XmlReader
XmlResolver
XmlSignificantWhitespace
XmlSpace
XmlText
XmlTextReader
XmlTextWriter
XmlUrlResolver
XmlWhitespace
XmlWriter
System.Xml.Schema
XmlSchema
XmlSchemaException
XmlSchemaObject
System.Xml.Serialization
IXmlSerializable
SoapAttributeAttribute
SoapElementAttribute
SoapEnumAttribute
SoapIgnoreAttribute
SoapIncludeAttribute
SoapTypeAttribute
XmlAnyAttributeAttribute
XmlAnyElementAttribute
XmlArrayAttribute
XmlArrayItemAttribute
XmlAttributeAttribute
XmlChoiceIdentifierAttribute
XmlElementAttribute
XmlEnumAttribute
XmlIgnoreAttribute
XmlIncludeAttribute
XmlNamespaceDeclarationsAttribute
XmlRootAttribute
XmlSerializerNamespaces
XmlTextAttribute
XmlTypeAttribute


Display options
Show members

Both frameworks
Appears in both the .NET Compact Framework and the full .NET Framework (desktop) class libraries.

.NET Framework only
Appears only in the full .NET Framework (desktop) class library.

.NET Compact Framework only
Appears only in the .NET Compact Framework class library.

Modifiers

Show public members

Show protected members

System.Security.SecurityException

Module:mscorlib.dll

Hierarchy
Object
Exception
SystemException
SecurityException

Type declaration

[C#] public class SecurityException : SystemException;

Constructor
public SecurityException();
protected SecurityException(SerializationInfo info, StreamingContext context);
public SecurityException(string message);
public SecurityException(string message, Exception innerException);
public SecurityException(string message, Type type);
public SecurityException(string message, Type type, string state);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public override void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public string GrantedSet {get;}
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public virtual string Message {get;}
public string PermissionState {get;}
public Type PermissionType {get;}
public string RefusedSet {get;}
public string Source {get; set;}
public string StackTrace {get;}
public MethodBase TargetSite {get;}

System.Security.VerificationException

Module:mscorlib.dll

Hierarchy
Object
Exception
SystemException
VerificationException

Type declaration

[C#] public class VerificationException : SystemException;

Constructor
public VerificationException();
protected VerificationException(SerializationInfo info, StreamingContext context);
public VerificationException(string message);
public VerificationException(string message, Exception innerException);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public virtual string Message {get;}
public string Source {get; set;}
public string StackTrace {get;}
public MethodBase TargetSite {get;}

System.Security.Cryptography.X509Certificates.X509Certificate

Module:mscorlib.dll

Hierarchy
Object
X509Certificate

Type declaration

[C#] public class X509Certificate;

Constructor
public X509Certificate(byte[] data);
public X509Certificate(IntPtr handle);
public X509Certificate(X509Certificate cert);

Method
public static X509Certificate CreateFromCertFile(string filename);
public static X509Certificate CreateFromSignedFile(string filename);
public virtual bool Equals(object obj);
public virtual bool Equals(X509Certificate other);
protected override void Finalize();
public virtual byte[] GetCertHash();
public virtual string GetCertHashString();
public virtual string GetEffectiveDateString();
public virtual string GetExpirationDateString();
public virtual string GetFormat();
public override int GetHashCode();
public virtual string GetIssuerName();
public virtual string GetKeyAlgorithm();
public virtual byte[] GetKeyAlgorithmParameters();
public virtual string GetKeyAlgorithmParametersString();
public virtual string GetName();
public virtual byte[] GetPublicKey();
public virtual string GetPublicKeyString();
public virtual byte[] GetRawCertData();
public virtual string GetRawCertDataString();
public virtual byte[] GetSerialNumber();
public virtual string GetSerialNumberString();
public Type GetType();
protected object MemberwiseClone();
public override string ToString();
public virtual string ToString(bool fVerbose);

System.Collections.DictionaryEntry

Module:mscorlib.dll

Hierarchy
Object
ValueType
DictionaryEntry

Type declaration

[C#] public struct DictionaryEntry : ValueType;

Constructor
public DictionaryEntry(object key, object value);

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public object Key {get; set;}
public object Value {get; set;}

System.Collections.Queue

Module:mscorlib.dll

Hierarchy
Object
Queue : ICollection, IEnumerable, ICloneable

Type declaration

[C#] public class Queue: ICollection, IEnumerable, ICloneable;

Constructor
public Queue();
public Queue(ICollection col);
public Queue(int capacity);
public Queue(int capacity, float growFactor);

Method
public virtual void Clear();
public virtual object Clone();
public virtual bool Contains(object obj);
public virtual void CopyTo(Array array, int index);
public virtual object Dequeue();
public virtual void Enqueue(object obj);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual IEnumerator GetEnumerator();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual object Peek();
public static Queue Synchronized(Queue queue);
public virtual object[] ToArray();
public virtual string ToString();
public virtual void TrimToSize();

Property
public virtual int Count {get;}
public virtual bool IsSynchronized {get;}
public virtual object SyncRoot {get;}

System.Collections.Stack

Module:mscorlib.dll

Hierarchy
Object
Stack : IEnumerable

Type declaration

[C#] public class Stack: IEnumerable;

Constructor
public Stack();
public Stack(ICollection col);
public Stack(int initialCapacity);

Method
public virtual void Clear();
public virtual object Clone();
public virtual bool Contains(object obj);
public virtual void CopyTo(Array array, int index);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual IEnumerator GetEnumerator();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual object Peek();
public virtual object Pop();
public virtual void Push(object obj);
public static Stack Synchronized(Stack stack);
public virtual object[] ToArray();
public virtual string ToString();

Property
public virtual int Count {get;}
public virtual bool IsSynchronized {get;}
public virtual object SyncRoot {get;}

System.Collections.BitArray

Module:mscorlib.dll

Hierarchy
Object
BitArray : ICollection, IEnumerable

Type declaration

[C#] public sealed class BitArray: ICollection, IEnumerable;

Constructor
public BitArray(BitArray bits);
public BitArray(bool[] values);
public BitArray(byte[] bytes);
public BitArray(int length);
public BitArray(int length, bool defaultValue);
public BitArray(int[] values);

Method
public BitArray And(BitArray value);
public object Clone();
public virtual void CopyTo(Array array, int index);
public virtual bool Equals(object obj);
protected override void Finalize();
public bool Get(int index);
public virtual IEnumerator GetEnumerator();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public BitArray Not();
public BitArray Or(BitArray value);
public void Set(int index, bool value);
public void SetAll(bool value);
public virtual string ToString();
public BitArray Xor(BitArray value);

Property
public virtual int Count {get;}
public bool IsReadOnly {get;}
public virtual bool IsSynchronized {get;}
public bool this[int index] {get; set;}
public int Length {get; set;}
public virtual object SyncRoot {get;}

System.Collections.ArrayList

Module:mscorlib.dll

Hierarchy
Object
ArrayList : IList, ICollection, IEnumerable, ICloneable

Type declaration

[C#] public class ArrayList: IList, ICollection, IEnumerable, ICloneable;

Constructor
public ArrayList();
public ArrayList(ICollection c);
public ArrayList(int capacity);

Method
public static ArrayList Adapter(IList list);
public virtual int Add(object value);
public virtual void AddRange(ICollection c);
public virtual int BinarySearch(int index, int count, object value, IComparer comparer);
public virtual int BinarySearch(object value);
public virtual int BinarySearch(object value, IComparer comparer);
public virtual void Clear();
public virtual object Clone();
public virtual bool Contains(object item);
public virtual void CopyTo(Array array);
public virtual void CopyTo(Array array, int arrayIndex);
public virtual void CopyTo(int index, Array array, int arrayIndex, int count);
public virtual bool Equals(object obj);
protected override void Finalize();
public static ArrayList FixedSize(ArrayList list);
public static IList FixedSize(IList list);
public virtual IEnumerator GetEnumerator();
public virtual IEnumerator GetEnumerator(int index, int count);
public virtual int GetHashCode();
public virtual ArrayList GetRange(int index, int count);
public Type GetType();
public virtual int IndexOf(object value);
public virtual int IndexOf(object value, int startIndex);
public virtual int IndexOf(object value, int startIndex, int count);
public virtual void Insert(int index, object value);
public virtual void InsertRange(int index, ICollection c);
public virtual int LastIndexOf(object value);
public virtual int LastIndexOf(object value, int startIndex);
public virtual int LastIndexOf(object value, int startIndex, int count);
protected object MemberwiseClone();
public static ArrayList ReadOnly(ArrayList list);
public static IList ReadOnly(IList list);
public virtual void Remove(object obj);
public virtual void RemoveAt(int index);
public virtual void RemoveRange(int index, int count);
public static ArrayList Repeat(object value, int count);
public virtual void Reverse();
public virtual void Reverse(int index, int count);
public virtual void SetRange(int index, ICollection c);
public virtual void Sort();
public virtual void Sort(IComparer comparer);
public virtual void Sort(int index, int count, IComparer comparer);
public static ArrayList Synchronized(ArrayList list);
public static IList Synchronized(IList list);
public virtual object[] ToArray();
public virtual Array ToArray(Type type);
public virtual string ToString();
public virtual void TrimToSize();

Property
public virtual int Capacity {get; set;}
public virtual int Count {get;}
public virtual bool IsFixedSize {get;}
public virtual bool IsReadOnly {get;}
public virtual bool IsSynchronized {get;}
public virtual object this[int index] {get; set;}
public virtual object SyncRoot {get;}

System.Collections.Comparer

Module:mscorlib.dll

Hierarchy
Object
Comparer : IComparer

Type declaration

[C#] public sealed class Comparer: IComparer;

Constructor
public Comparer(CultureInfo culture);

Method
public virtual int Compare(object a, object b);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Field
public readonly static Comparer Default;
public readonly static Comparer DefaultInvariant;

System.Collections.CaseInsensitiveHashCodeProvider

Module:mscorlib.dll

Hierarchy
Object
CaseInsensitiveHashCodeProvider : IHashCodeProvider

Type declaration

[C#] public class CaseInsensitiveHashCodeProvider: IHashCodeProvider;

Constructor
public CaseInsensitiveHashCodeProvider();
public CaseInsensitiveHashCodeProvider(CultureInfo culture);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public virtual int GetHashCode(object obj);
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public static CaseInsensitiveHashCodeProvider Default {get;}
public static CaseInsensitiveHashCodeProvider DefaultInvariant {get;}

System.Collections.IHashCodeProvider

Module:mscorlib.dll

Hierarchy
IHashCodeProvider

Type declaration

[C#] public interface IHashCodeProvider;

Method
public int GetHashCode(object obj);

System.Collections.CaseInsensitiveComparer

Module:mscorlib.dll

Hierarchy
Object
CaseInsensitiveComparer : IComparer

Type declaration

[C#] public class CaseInsensitiveComparer: IComparer;

Constructor
public CaseInsensitiveComparer();
public CaseInsensitiveComparer(CultureInfo culture);

Method
public virtual int Compare(object a, object b);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public static CaseInsensitiveComparer Default {get;}
public static CaseInsensitiveComparer DefaultInvariant {get;}

System.Collections.IComparer

Module:mscorlib.dll

Hierarchy
IComparer

Type declaration

[C#] public interface IComparer;

Method
public int Compare(object x, object y);

System.Collections.CollectionBase

Module:mscorlib.dll

Hierarchy
Object
CollectionBase : IList, ICollection, IEnumerable

Type declaration

[C#] public abstract class CollectionBase: IList, ICollection, IEnumerable;

Constructor
protected CollectionBase();

Method
public virtual void Clear();
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual IEnumerator GetEnumerator();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
protected virtual void OnClear();
protected virtual void OnClearComplete();
protected virtual void OnInsert(int index, object value);
protected virtual void OnInsertComplete(int index, object value);
protected virtual void OnRemove(int index, object value);
protected virtual void OnRemoveComplete(int index, object value);
protected virtual void OnSet(int index, object oldValue, object newValue);
protected virtual void OnSetComplete(int index, object oldValue, object newValue);
protected virtual void OnValidate(object value);
public virtual void RemoveAt(int index);
public virtual string ToString();

Property
public virtual int Count {get;}
protected ArrayList InnerList {get;}
protected IList List {get;}

System.Collections.IDictionaryEnumerator

Module:mscorlib.dll

Hierarchy
IDictionaryEnumerator : IEnumerator

Type declaration

[C#] public interface IDictionaryEnumerator: IEnumerator;

Property
public DictionaryEntry Entry {get;}
public object Key {get;}
public object Value {get;}

System.Collections.Hashtable

Module:mscorlib.dll

Hierarchy
Object
Hashtable : IDictionary, ICollection, IEnumerable

Type declaration

[C#] public class Hashtable: IDictionary, ICollection, IEnumerable;

Constructor
public Hashtable();
public Hashtable(IDictionary d);
public Hashtable(IDictionary d, IHashCodeProvider hcp, IComparer comparer);
public Hashtable(IDictionary d, float loadFactor);
public Hashtable(IDictionary d, float loadFactor, IHashCodeProvider hcp, IComparer comparer);
public Hashtable(IHashCodeProvider hcp, IComparer comparer);
public Hashtable(int capacity);
public Hashtable(int capacity, IHashCodeProvider hcp, IComparer comparer);
public Hashtable(int capacity, float loadFactor);
public Hashtable(int capacity, float loadFactor, IHashCodeProvider hcp, IComparer comparer);
protected Hashtable(SerializationInfo info, StreamingContext context);

Method
public virtual void Add(object key, object value);
public virtual void Clear();
public virtual object Clone();
public virtual bool Contains(object key);
public virtual bool ContainsKey(object key);
public virtual bool ContainsValue(object value);
public virtual void CopyTo(Array array, int arrayIndex);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual IDictionaryEnumerator GetEnumerator();
protected virtual int GetHash(object key);
public virtual int GetHashCode();
public virtual void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected virtual bool KeyEquals(object item, object key);
protected object MemberwiseClone();
public virtual void OnDeserialization(object sender);
public virtual void Remove(object key);
public static Hashtable Synchronized(Hashtable table);
public virtual string ToString();

Property
protected IComparer comparer {get; set;}
public virtual int Count {get;}
protected IHashCodeProvider hcp {get; set;}
public virtual bool IsFixedSize {get;}
public virtual bool IsReadOnly {get;}
public virtual bool IsSynchronized {get;}
public virtual object this[object key] {get; set;}
public virtual ICollection Keys {get;}
public virtual object SyncRoot {get;}
public virtual ICollection Values {get;}

System.Collections.IDictionary

Module:mscorlib.dll

Hierarchy
IDictionary : ICollection, IEnumerable

Type declaration

[C#] public interface IDictionary: ICollection, IEnumerable;

Method
public void Add(object key, object value);
public void Clear();
public bool Contains(object key);
public IDictionaryEnumerator GetEnumerator();
public void Remove(object key);

Property
public bool IsFixedSize {get;}
public bool IsReadOnly {get;}
public object this[object key] {get; set;}
public ICollection Keys {get;}
public ICollection Values {get;}

System.Collections.IList

Module:mscorlib.dll

Hierarchy
IList : ICollection, IEnumerable

Type declaration

[C#] public interface IList: ICollection, IEnumerable;

Method
public int Add(object value);
public void Clear();
public bool Contains(object value);
public int IndexOf(object value);
public void Insert(int index, object value);
public void Remove(object value);
public void RemoveAt(int index);

Property
public bool IsFixedSize {get;}
public bool IsReadOnly {get;}
public object this[int index] {get; set;}

System.Collections.ICollection

Module:mscorlib.dll

Hierarchy
ICollection : IEnumerable

Type declaration

[C#] public interface ICollection: IEnumerable;

Method
public void CopyTo(Array array, int index);

Property
public int Count {get;}
public bool IsSynchronized {get;}
public object SyncRoot {get;}

System.Collections.IEnumerator

Module:mscorlib.dll

Hierarchy
IEnumerator

Type declaration

[C#] public interface IEnumerator;

Method
public bool MoveNext();
public void Reset();

Property
public object Current {get;}

System.Collections.IEnumerable

Module:mscorlib.dll

Hierarchy
IEnumerable

Type declaration

[C#] public interface IEnumerable;

Method
public IEnumerator GetEnumerator();

System.Text.MLangCodePageEncoding

Module:mscorlib.dll

Hierarchy
Object
Encoding
MLangCodePageEncoding

Type declaration

[C#] public class MLangCodePageEncoding : Encoding;

Constructor
public MLangCodePageEncoding(int codePage, int byteSize);

Method
public override bool Equals(object value);
protected override void Finalize();
public virtual int GetByteCount(char[] chars);
public override int GetByteCount(char[] chars, int index, int count);
public virtual int GetByteCount(string s);
public virtual byte[] GetBytes(char[] chars);
public virtual byte[] GetBytes(char[] chars, int index, int count);
public override int GetBytes(char[] chars, int charIndex, int charCount, byte[] bytes, int byteIndex);
public virtual byte[] GetBytes(string s);
public virtual int GetBytes(string s, int charIndex, int charCount, byte[] bytes, int byteIndex);
public virtual int GetCharCount(byte[] bytes);
public override int GetCharCount(byte[] bytes, int index, int count);
public virtual char[] GetChars(byte[] bytes);
public virtual char[] GetChars(byte[] bytes, int index, int count);
public override int GetChars(byte[] bytes, int byteIndex, int byteCount, char[] chars, int charIndex);
public override Decoder GetDecoder();
public override Encoder GetEncoder();
public override int GetHashCode();
public override int GetMaxByteCount(int charCount);
public override int GetMaxCharCount(int byteCount);
public virtual byte[] GetPreamble();
public virtual string GetString(byte[] bytes, int index, int count);
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public virtual int CodePage {get;}
public virtual string WebName {get;}

Field
protected int m_maxByteSize;

System.Text.UTF8Encoding

Module:mscorlib.dll

Hierarchy
Object
Encoding
UTF8Encoding

Type declaration

[C#] public class UTF8Encoding : Encoding;

Constructor
public UTF8Encoding();
public UTF8Encoding(bool encoderShouldEmitUTF8Identifier);
public UTF8Encoding(bool encoderShouldEmitUTF8Identifier, bool throwOnInvalidBytes);

Method
public override bool Equals(object value);
protected override void Finalize();
public virtual int GetByteCount(char[] chars);
public override int GetByteCount(char[] chars, int index, int count);
public override int GetByteCount(string str);
public virtual byte[] GetBytes(char[] chars);
public virtual byte[] GetBytes(char[] chars, int index, int count);
public override int GetBytes(char[] chars, int charIndex, int charCount, byte[] bytes, int byteIndex);
public override byte[] GetBytes(string s);
public override int GetBytes(string s, int charIndex, int charCount, byte[] bytes, int byteIndex);
public virtual int GetCharCount(byte[] bytes);
public override int GetCharCount(byte[] bytes, int index, int count);
public virtual char[] GetChars(byte[] bytes);
public virtual char[] GetChars(byte[] bytes, int index, int count);
public override int GetChars(byte[] bytes, int byteIndex, int byteCount, char[] chars, int charIndex);
public override Decoder GetDecoder();
public override Encoder GetEncoder();
public override int GetHashCode();
public override int GetMaxByteCount(int charCount);
public override int GetMaxCharCount(int byteCount);
public override byte[] GetPreamble();
public string GetString(byte[] bytes);
public virtual string GetString(byte[] bytes, int index, int count);
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public string BodyName {get;}
public virtual int CodePage {get;}
public string EncodingName {get;}
public string HeaderName {get;}
public bool IsBrowserDisplay {get;}
public bool IsBrowserSave {get;}
public bool IsMailNewsDisplay {get;}
public bool IsMailNewsSave {get;}
public virtual string WebName {get;}
public int WindowsCodePage {get;}

System.Text.UTF7Encoding

Module:mscorlib.dll

Hierarchy
Object
Encoding
UTF7Encoding

Type declaration

[C#] public class UTF7Encoding : Encoding;

Constructor
public UTF7Encoding();
public UTF7Encoding(bool allowOptionals);

Method
public override bool Equals(object value);
protected override void Finalize();
public virtual int GetByteCount(char[] chars);
public override int GetByteCount(char[] chars, int index, int count);
public virtual int GetByteCount(string s);
public virtual byte[] GetBytes(char[] chars);
public virtual byte[] GetBytes(char[] chars, int index, int count);
public override int GetBytes(char[] chars, int charIndex, int charCount, byte[] bytes, int byteIndex);
public virtual byte[] GetBytes(string s);
public virtual int GetBytes(string s, int charIndex, int charCount, byte[] bytes, int byteIndex);
public virtual int GetCharCount(byte[] bytes);
public override int GetCharCount(byte[] bytes, int index, int count);
public virtual char[] GetChars(byte[] bytes);
public virtual char[] GetChars(byte[] bytes, int index, int count);
public override int GetChars(byte[] bytes, int byteIndex, int byteCount, char[] chars, int charIndex);
public override Decoder GetDecoder();
public override Encoder GetEncoder();
public override int GetHashCode();
public override int GetMaxByteCount(int charCount);
public override int GetMaxCharCount(int byteCount);
public virtual byte[] GetPreamble();
public string GetString(byte[] bytes);
public virtual string GetString(byte[] bytes, int index, int count);
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public string BodyName {get;}
public virtual int CodePage {get;}
public string EncodingName {get;}
public string HeaderName {get;}
public bool IsBrowserDisplay {get;}
public bool IsBrowserSave {get;}
public bool IsMailNewsDisplay {get;}
public bool IsMailNewsSave {get;}
public virtual string WebName {get;}
public int WindowsCodePage {get;}

System.Text.UnicodeEncoding

Module:mscorlib.dll

Hierarchy
Object
Encoding
UnicodeEncoding

Type declaration

[C#] public class UnicodeEncoding : Encoding;

Constructor
public UnicodeEncoding();
public UnicodeEncoding(bool bigEndian, bool byteOrderMark);

Method
public override bool Equals(object value);
protected override void Finalize();
public virtual int GetByteCount(char[] chars);
public override int GetByteCount(char[] chars, int index, int count);
public override int GetByteCount(string s);
public virtual byte[] GetBytes(char[] chars);
public virtual byte[] GetBytes(char[] chars, int index, int count);
public override int GetBytes(char[] chars, int charIndex, int charCount, byte[] bytes, int byteIndex);
public virtual byte[] GetBytes(string s);
public override int GetBytes(string chars, int charIndex, int charCount, byte[] bytes, int byteIndex);
public virtual int GetCharCount(byte[] bytes);
public override int GetCharCount(byte[] bytes, int index, int count);
public virtual char[] GetChars(byte[] bytes);
public virtual char[] GetChars(byte[] bytes, int index, int count);
public override int GetChars(byte[] bytes, int byteIndex, int byteCount, char[] chars, int charIndex);
public override Decoder GetDecoder();
public virtual Encoder GetEncoder();
public override int GetHashCode();
public override int GetMaxByteCount(int charCount);
public override int GetMaxCharCount(int byteCount);
public override byte[] GetPreamble();
public string GetString(byte[] bytes);
public virtual string GetString(byte[] bytes, int index, int count);
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public string BodyName {get;}
public virtual int CodePage {get;}
public string EncodingName {get;}
public string HeaderName {get;}
public bool IsBrowserDisplay {get;}
public bool IsBrowserSave {get;}
public bool IsMailNewsDisplay {get;}
public bool IsMailNewsSave {get;}
public virtual string WebName {get;}
public int WindowsCodePage {get;}

Field
public const int CharSize = 2;

System.Text.ASCIIEncoding

Module:mscorlib.dll

Hierarchy
Object
Encoding
ASCIIEncoding

Type declaration

[C#] public class ASCIIEncoding : Encoding;

Constructor
public ASCIIEncoding();

Method
public override bool Equals(object value);
protected override void Finalize();
public virtual int GetByteCount(char[] chars);
public override int GetByteCount(char[] chars, int index, int count);
public override int GetByteCount(string chars);
public virtual byte[] GetBytes(char[] chars);
public virtual byte[] GetBytes(char[] chars, int index, int count);
public override int GetBytes(char[] chars, int charIndex, int charCount, byte[] bytes, int byteIndex);
public virtual byte[] GetBytes(string s);
public override int GetBytes(string chars, int charIndex, int charCount, byte[] bytes, int byteIndex);
public virtual int GetCharCount(byte[] bytes);
public override int GetCharCount(byte[] bytes, int index, int count);
public virtual char[] GetChars(byte[] bytes);
public virtual char[] GetChars(byte[] bytes, int index, int count);
public override int GetChars(byte[] bytes, int byteIndex, int byteCount, char[] chars, int charIndex);
public virtual Decoder GetDecoder();
public virtual Encoder GetEncoder();
public override int GetHashCode();
public override int GetMaxByteCount(int charCount);
public override int GetMaxCharCount(int byteCount);
public virtual byte[] GetPreamble();
public override string GetString(byte[] bytes);
public virtual string GetString(byte[] bytes, int index, int count);
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public string BodyName {get;}
public virtual int CodePage {get;}
public string EncodingName {get;}
public string HeaderName {get;}
public bool IsBrowserDisplay {get;}
public bool IsBrowserSave {get;}
public bool IsMailNewsDisplay {get;}
public bool IsMailNewsSave {get;}
public virtual string WebName {get;}
public int WindowsCodePage {get;}

System.Text.Encoder

Module:mscorlib.dll

Hierarchy
Object
Encoder

Type declaration

[C#] public abstract class Encoder;

Constructor
protected Encoder();

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public abstract int GetByteCount(char[] chars, int index, int count, bool flush);
public abstract int GetBytes(char[] chars, int charIndex, int charCount, byte[] bytes, int byteIndex, bool flush);
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

System.Text.Decoder

Module:mscorlib.dll

Hierarchy
Object
Decoder

Type declaration

[C#] public abstract class Decoder;

Constructor
protected Decoder();

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public abstract int GetCharCount(byte[] bytes, int index, int count);
public abstract int GetChars(byte[] bytes, int byteIndex, int byteCount, char[] chars, int charIndex);
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

System.Text.Encoding

Module:mscorlib.dll

Hierarchy
Object
Encoding

Type declaration

[C#] public abstract class Encoding;

Constructor
protected Encoding();
protected Encoding(int codePage);

Method
public static byte[] Convert(Encoding srcEncoding, Encoding dstEncoding, byte[] bytes);
public static byte[] Convert(Encoding srcEncoding, Encoding dstEncoding, byte[] bytes, int index, int count);
public override bool Equals(object value);
protected override void Finalize();
public virtual int GetByteCount(char[] chars);
public abstract int GetByteCount(char[] chars, int index, int count);
public virtual int GetByteCount(string s);
public virtual byte[] GetBytes(char[] chars);
public virtual byte[] GetBytes(char[] chars, int index, int count);
public abstract int GetBytes(char[] chars, int charIndex, int charCount, byte[] bytes, int byteIndex);
public virtual byte[] GetBytes(string s);
public virtual int GetBytes(string s, int charIndex, int charCount, byte[] bytes, int byteIndex);
public virtual int GetCharCount(byte[] bytes);
public abstract int GetCharCount(byte[] bytes, int index, int count);
public virtual char[] GetChars(byte[] bytes);
public virtual char[] GetChars(byte[] bytes, int index, int count);
public abstract int GetChars(byte[] bytes, int byteIndex, int byteCount, char[] chars, int charIndex);
public virtual Decoder GetDecoder();
public virtual Encoder GetEncoder();
public static Encoding GetEncoding(int codepage);
public static Encoding GetEncoding(string name);
public override int GetHashCode();
public abstract int GetMaxByteCount(int charCount);
public abstract int GetMaxCharCount(int byteCount);
public virtual byte[] GetPreamble();
public virtual string GetString(byte[] bytes);
public virtual string GetString(byte[] bytes, int index, int count);
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public static Encoding ASCII {get;}
public static Encoding BigEndianUnicode {get;}
public virtual string BodyName {get;}
public virtual int CodePage {get;}
public static Encoding Default {get;}
public virtual string EncodingName {get;}
public virtual string HeaderName {get;}
public virtual bool IsBrowserDisplay {get;}
public virtual bool IsBrowserSave {get;}
public virtual bool IsMailNewsDisplay {get;}
public virtual bool IsMailNewsSave {get;}
public static Encoding Unicode {get;}
public static Encoding UTF7 {get;}
public static Encoding UTF8 {get;}
public virtual string WebName {get;}
public virtual int WindowsCodePage {get;}

System.Text.StringBuilder

Module:mscorlib.dll

Hierarchy
Object
StringBuilder

Type declaration

[C#] public sealed class StringBuilder;

Constructor
public StringBuilder();
public StringBuilder(int capacity);
public StringBuilder(int capacity, int maxCapacity);
public StringBuilder(string value);
public StringBuilder(string value, int capacity);
public StringBuilder(string value, int startIndex, int length, int capacity);

Method
public StringBuilder Append(bool value);
public StringBuilder Append(byte value);
public StringBuilder Append(char value);
public StringBuilder Append(char value, int repeatCount);
public StringBuilder Append(char[] value);
public StringBuilder Append(char[] value, int startIndex, int charCount);
public StringBuilder Append(decimal value);
public StringBuilder Append(double value);
public StringBuilder Append(short value);
public StringBuilder Append(int value);
public StringBuilder Append(long value);
public StringBuilder Append(object value);
public StringBuilder Append(SByte value);
public StringBuilder Append(float value);
public StringBuilder Append(string value);
public StringBuilder Append(string value, int startIndex, int count);
public StringBuilder Append(ushort value);
public StringBuilder Append(uint value);
public StringBuilder Append(ulong value);
public StringBuilder AppendFormat(IFormatProvider provider, string format, params object[] args);
public StringBuilder AppendFormat(string format, params object[] args);
public StringBuilder AppendFormat(string format, object arg0);
public StringBuilder AppendFormat(string format, object arg0, object arg1);
public StringBuilder AppendFormat(string format, object arg0, object arg1, object arg2);
public int EnsureCapacity(int capacity);
public virtual bool Equals(object obj);
public bool Equals(StringBuilder sb);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
public StringBuilder Insert(int index, bool value);
public StringBuilder Insert(int index, byte value);
public StringBuilder Insert(int index, char value);
public StringBuilder Insert(int index, char[] value);
public StringBuilder Insert(int index, char[] value, int startIndex, int charCount);
public StringBuilder Insert(int index, decimal value);
public StringBuilder Insert(int index, double value);
public StringBuilder Insert(int index, short value);
public StringBuilder Insert(int index, int value);
public StringBuilder Insert(int index, long value);
public StringBuilder Insert(int index, object value);
public StringBuilder Insert(int index, SByte value);
public StringBuilder Insert(int index, float value);
public StringBuilder Insert(int index, string value);
public StringBuilder Insert(int index, string value, int count);
public StringBuilder Insert(int index, ushort value);
public StringBuilder Insert(int index, uint value);
public StringBuilder Insert(int index, ulong value);
protected object MemberwiseClone();
public StringBuilder Remove(int startIndex, int length);
public StringBuilder Replace(char oldChar, char newChar);
public StringBuilder Replace(char oldChar, char newChar, int startIndex, int count);
public StringBuilder Replace(string oldValue, string newValue);
public StringBuilder Replace(string oldValue, string newValue, int startIndex, int count);
public override string ToString();
public string ToString(int startIndex, int length);

Property
public int Capacity {get; set;}
public char Chars[int index] {get; set;}
public int Length {get; set;}
public int MaxCapacity {get;}

System.Globalization.CultureTypes

Module:mscorlib.dll

Hierarchy
Object
ValueType
Enum
CultureTypes

Type declaration

[C#] public enum CultureTypes;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const CultureTypes AllCultures = 7;
public const CultureTypes InstalledWin32Cultures = 4;
public const CultureTypes NeutralCultures = 1;
public const CultureTypes SpecificCultures = 2;
public int value__;

System.Globalization.DateTimeFormatInfo

Module:mscorlib.dll

Hierarchy
Object
DateTimeFormatInfo : ICloneable, IFormatProvider

Type declaration

[C#] public sealed class DateTimeFormatInfo: ICloneable, IFormatProvider;

Constructor
public DateTimeFormatInfo();

Method
public virtual object Clone();
public virtual bool Equals(object obj);
protected override void Finalize();
public string GetAbbreviatedDayName(DayOfWeek dayofweek);
public string GetAbbreviatedEraName(int era);
public string GetAbbreviatedMonthName(int month);
public string[] GetAllDateTimePatterns();
public string[] GetAllDateTimePatterns(char format);
public string GetDayName(DayOfWeek dayofweek);
public int GetEra(string eraName);
public string GetEraName(int era);
public virtual object GetFormat(Type formatType);
public virtual int GetHashCode();
public static DateTimeFormatInfo GetInstance(IFormatProvider provider);
public string GetMonthName(int month);
public Type GetType();
protected object MemberwiseClone();
public static DateTimeFormatInfo ReadOnly(DateTimeFormatInfo dtfi);
public virtual string ToString();

Property
public string[] AbbreviatedDayNames {get; set;}
public string[] AbbreviatedMonthNames {get; set;}
public string AMDesignator {get; set;}
public Calendar Calendar {get; set;}
public CalendarWeekRule CalendarWeekRule {get; set;}
public static DateTimeFormatInfo CurrentInfo {get;}
public string DateSeparator {get; set;}
public string[] DayNames {get; set;}
public DayOfWeek FirstDayOfWeek {get; set;}
public string FullDateTimePattern {get; set;}
public static DateTimeFormatInfo InvariantInfo {get;}
public bool IsReadOnly {get;}
public string LongDatePattern {get; set;}
public string LongTimePattern {get; set;}
public string MonthDayPattern {get; set;}
public string[] MonthNames {get; set;}
public string PMDesignator {get; set;}
public string RFC1123Pattern {get;}
public string ShortDatePattern {get; set;}
public string ShortTimePattern {get; set;}
public string SortableDateTimePattern {get;}
public string TimeSeparator {get; set;}
public string UniversalSortableDateTimePattern {get;}
public string YearMonthPattern {get; set;}

System.Globalization.TaiwanCalendar

Module:mscorlib.dll

Hierarchy
Object
Calendar
TaiwanCalendar

Type declaration

[C#] public class TaiwanCalendar : Calendar;

Constructor
public TaiwanCalendar();

Method
public virtual DateTime AddDays(DateTime time, int days);
public virtual DateTime AddHours(DateTime time, int hours);
public virtual DateTime AddMilliseconds(DateTime time, double milliseconds);
public virtual DateTime AddMinutes(DateTime time, int minutes);
public override DateTime AddMonths(DateTime time, int months);
public virtual DateTime AddSeconds(DateTime time, int seconds);
public virtual DateTime AddWeeks(DateTime time, int weeks);
public override DateTime AddYears(DateTime time, int years);
public virtual bool Equals(object obj);
protected override void Finalize();
public override int GetDayOfMonth(DateTime time);
public override DayOfWeek GetDayOfWeek(DateTime time);
public override int GetDayOfYear(DateTime time);
public virtual int GetDaysInMonth(int year, int month);
public override int GetDaysInMonth(int year, int month, int era);
public virtual int GetDaysInYear(int year);
public override int GetDaysInYear(int year, int era);
public override int GetEra(DateTime time);
public virtual int GetHashCode();
public virtual int GetHour(DateTime time);
public virtual double GetMilliseconds(DateTime time);
public virtual int GetMinute(DateTime time);
public override int GetMonth(DateTime time);
public virtual int GetMonthsInYear(int year);
public override int GetMonthsInYear(int year, int era);
public virtual int GetSecond(DateTime time);
public Type GetType();
public virtual int GetWeekOfYear(DateTime time, CalendarWeekRule rule, DayOfWeek firstDayOfWeek);
public override int GetYear(DateTime time);
public virtual bool IsLeapDay(int year, int month, int day);
public override bool IsLeapDay(int year, int month, int day, int era);
public virtual bool IsLeapMonth(int year, int month);
public override bool IsLeapMonth(int year, int month, int era);
public virtual bool IsLeapYear(int year);
public override bool IsLeapYear(int year, int era);
protected object MemberwiseClone();
public virtual DateTime ToDateTime(int year, int month, int day, int hour, int minute, int second, int millisecond);
public override DateTime ToDateTime(int year, int month, int day, int hour, int minute, int second, int millisecond, int era);
public override int ToFourDigitYear(int year);
public virtual string ToString();

Property
public override int[] Eras {get;}
public override int TwoDigitYearMax {get; set;}

System.Globalization.ThaiBuddhistCalendar

Module:mscorlib.dll

Hierarchy
Object
Calendar
ThaiBuddhistCalendar

Type declaration

[C#] public class ThaiBuddhistCalendar : Calendar;

Constructor
public ThaiBuddhistCalendar();

Method
public virtual DateTime AddDays(DateTime time, int days);
public virtual DateTime AddHours(DateTime time, int hours);
public virtual DateTime AddMilliseconds(DateTime time, double milliseconds);
public virtual DateTime AddMinutes(DateTime time, int minutes);
public override DateTime AddMonths(DateTime time, int months);
public virtual DateTime AddSeconds(DateTime time, int seconds);
public virtual DateTime AddWeeks(DateTime time, int weeks);
public override DateTime AddYears(DateTime time, int years);
public virtual bool Equals(object obj);
protected override void Finalize();
public override int GetDayOfMonth(DateTime time);
public override DayOfWeek GetDayOfWeek(DateTime time);
public override int GetDayOfYear(DateTime time);
public virtual int GetDaysInMonth(int year, int month);
public override int GetDaysInMonth(int year, int month, int era);
public virtual int GetDaysInYear(int year);
public override int GetDaysInYear(int year, int era);
public override int GetEra(DateTime time);
public virtual int GetHashCode();
public virtual int GetHour(DateTime time);
public virtual double GetMilliseconds(DateTime time);
public virtual int GetMinute(DateTime time);
public override int GetMonth(DateTime time);
public virtual int GetMonthsInYear(int year);
public override int GetMonthsInYear(int year, int era);
public virtual int GetSecond(DateTime time);
public Type GetType();
public virtual int GetWeekOfYear(DateTime time, CalendarWeekRule rule, DayOfWeek firstDayOfWeek);
public override int GetYear(DateTime time);
public virtual bool IsLeapDay(int year, int month, int day);
public override bool IsLeapDay(int year, int month, int day, int era);
public virtual bool IsLeapMonth(int year, int month);
public override bool IsLeapMonth(int year, int month, int era);
public virtual bool IsLeapYear(int year);
public override bool IsLeapYear(int year, int era);
protected object MemberwiseClone();
public virtual DateTime ToDateTime(int year, int month, int day, int hour, int minute, int second, int millisecond);
public override DateTime ToDateTime(int year, int month, int day, int hour, int minute, int second, int millisecond, int era);
public override int ToFourDigitYear(int year);
public virtual string ToString();

Property
public override int[] Eras {get;}
public override int TwoDigitYearMax {get; set;}

Field
public const int ThaiBuddhistEra = 1;

System.Globalization.KoreanCalendar

Module:mscorlib.dll

Hierarchy
Object
Calendar
KoreanCalendar

Type declaration

[C#] public class KoreanCalendar : Calendar;

Constructor
public KoreanCalendar();

Method
public virtual DateTime AddDays(DateTime time, int days);
public virtual DateTime AddHours(DateTime time, int hours);
public virtual DateTime AddMilliseconds(DateTime time, double milliseconds);
public virtual DateTime AddMinutes(DateTime time, int minutes);
public override DateTime AddMonths(DateTime time, int months);
public virtual DateTime AddSeconds(DateTime time, int seconds);
public virtual DateTime AddWeeks(DateTime time, int weeks);
public override DateTime AddYears(DateTime time, int years);
public virtual bool Equals(object obj);
protected override void Finalize();
public override int GetDayOfMonth(DateTime time);
public override DayOfWeek GetDayOfWeek(DateTime time);
public override int GetDayOfYear(DateTime time);
public virtual int GetDaysInMonth(int year, int month);
public override int GetDaysInMonth(int year, int month, int era);
public virtual int GetDaysInYear(int year);
public override int GetDaysInYear(int year, int era);
public override int GetEra(DateTime time);
public virtual int GetHashCode();
public virtual int GetHour(DateTime time);
public virtual double GetMilliseconds(DateTime time);
public virtual int GetMinute(DateTime time);
public override int GetMonth(DateTime time);
public virtual int GetMonthsInYear(int year);
public override int GetMonthsInYear(int year, int era);
public virtual int GetSecond(DateTime time);
public Type GetType();
public virtual int GetWeekOfYear(DateTime time, CalendarWeekRule rule, DayOfWeek firstDayOfWeek);
public override int GetYear(DateTime time);
public virtual bool IsLeapDay(int year, int month, int day);
public override bool IsLeapDay(int year, int month, int day, int era);
public virtual bool IsLeapMonth(int year, int month);
public override bool IsLeapMonth(int year, int month, int era);
public virtual bool IsLeapYear(int year);
public override bool IsLeapYear(int year, int era);
protected object MemberwiseClone();
public virtual DateTime ToDateTime(int year, int month, int day, int hour, int minute, int second, int millisecond);
public override DateTime ToDateTime(int year, int month, int day, int hour, int minute, int second, int millisecond, int era);
public override int ToFourDigitYear(int year);
public virtual string ToString();

Property
public override int[] Eras {get;}
public override int TwoDigitYearMax {get; set;}

Field
public const int KoreanEra = 1;

System.Globalization.JapaneseCalendar

Module:mscorlib.dll

Hierarchy
Object
Calendar
JapaneseCalendar

Type declaration

[C#] public class JapaneseCalendar : Calendar;

Constructor
public JapaneseCalendar();

Method
public virtual DateTime AddDays(DateTime time, int days);
public virtual DateTime AddHours(DateTime time, int hours);
public virtual DateTime AddMilliseconds(DateTime time, double milliseconds);
public virtual DateTime AddMinutes(DateTime time, int minutes);
public override DateTime AddMonths(DateTime time, int months);
public virtual DateTime AddSeconds(DateTime time, int seconds);
public virtual DateTime AddWeeks(DateTime time, int weeks);
public override DateTime AddYears(DateTime time, int years);
public virtual bool Equals(object obj);
protected override void Finalize();
public override int GetDayOfMonth(DateTime time);
public override DayOfWeek GetDayOfWeek(DateTime time);
public override int GetDayOfYear(DateTime time);
public virtual int GetDaysInMonth(int year, int month);
public override int GetDaysInMonth(int year, int month, int era);
public virtual int GetDaysInYear(int year);
public override int GetDaysInYear(int year, int era);
public override int GetEra(DateTime time);
public virtual int GetHashCode();
public virtual int GetHour(DateTime time);
public virtual double GetMilliseconds(DateTime time);
public virtual int GetMinute(DateTime time);
public override int GetMonth(DateTime time);
public virtual int GetMonthsInYear(int year);
public override int GetMonthsInYear(int year, int era);
public virtual int GetSecond(DateTime time);
public Type GetType();
public virtual int GetWeekOfYear(DateTime time, CalendarWeekRule rule, DayOfWeek firstDayOfWeek);
public override int GetYear(DateTime time);
public virtual bool IsLeapDay(int year, int month, int day);
public override bool IsLeapDay(int year, int month, int day, int era);
public virtual bool IsLeapMonth(int year, int month);
public override bool IsLeapMonth(int year, int month, int era);
public virtual bool IsLeapYear(int year);
public override bool IsLeapYear(int year, int era);
protected object MemberwiseClone();
public virtual DateTime ToDateTime(int year, int month, int day, int hour, int minute, int second, int millisecond);
public override DateTime ToDateTime(int year, int month, int day, int hour, int minute, int second, int millisecond, int era);
public override int ToFourDigitYear(int year);
public virtual string ToString();

Property
public override int[] Eras {get;}
public override int TwoDigitYearMax {get; set;}

System.Globalization.GregorianCalendar

Module:mscorlib.dll

Hierarchy
Object
Calendar
GregorianCalendar

Type declaration

[C#] public class GregorianCalendar : Calendar;

Constructor
public GregorianCalendar();
public GregorianCalendar(GregorianCalendarTypes type);

Method
public virtual DateTime AddDays(DateTime time, int days);
public virtual DateTime AddHours(DateTime time, int hours);
public virtual DateTime AddMilliseconds(DateTime time, double milliseconds);
public virtual DateTime AddMinutes(DateTime time, int minutes);
public override DateTime AddMonths(DateTime time, int months);
public virtual DateTime AddSeconds(DateTime time, int seconds);
public override DateTime AddWeeks(DateTime time, int weeks);
public override DateTime AddYears(DateTime time, int years);
public virtual bool Equals(object obj);
protected override void Finalize();
public override int GetDayOfMonth(DateTime time);
public override DayOfWeek GetDayOfWeek(DateTime time);
public override int GetDayOfYear(DateTime time);
public virtual int GetDaysInMonth(int year, int month);
public override int GetDaysInMonth(int year, int month, int era);
public virtual int GetDaysInYear(int year);
public override int GetDaysInYear(int year, int era);
public override int GetEra(DateTime time);
public virtual int GetHashCode();
public virtual int GetHour(DateTime time);
public virtual double GetMilliseconds(DateTime time);
public virtual int GetMinute(DateTime time);
public override int GetMonth(DateTime time);
public virtual int GetMonthsInYear(int year);
public override int GetMonthsInYear(int year, int era);
public virtual int GetSecond(DateTime time);
public Type GetType();
public virtual int GetWeekOfYear(DateTime time, CalendarWeekRule rule, DayOfWeek firstDayOfWeek);
public override int GetYear(DateTime time);
public virtual bool IsLeapDay(int year, int month, int day);
public override bool IsLeapDay(int year, int month, int day, int era);
public virtual bool IsLeapMonth(int year, int month);
public override bool IsLeapMonth(int year, int month, int era);
public virtual bool IsLeapYear(int year);
public override bool IsLeapYear(int year, int era);
protected object MemberwiseClone();
public virtual DateTime ToDateTime(int year, int month, int day, int hour, int minute, int second, int millisecond);
public override DateTime ToDateTime(int year, int month, int day, int hour, int minute, int second, int millisecond, int era);
public override int ToFourDigitYear(int year);
public virtual string ToString();

Property
public virtual GregorianCalendarTypes CalendarType {get; set;}
public override int[] Eras {get;}
public override int TwoDigitYearMax {get; set;}

Field
public const int ADEra = 1;

System.Globalization.GregorianCalendarTypes

Module:mscorlib.dll

Hierarchy
Object
ValueType
Enum
GregorianCalendarTypes

Type declaration

[C#] public enum GregorianCalendarTypes;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const GregorianCalendarTypes Arabic = 10;
public const GregorianCalendarTypes Localized = 1;
public const GregorianCalendarTypes MiddleEastFrench = 9;
public const GregorianCalendarTypes TransliteratedEnglish = 11;
public const GregorianCalendarTypes TransliteratedFrench = 12;
public const GregorianCalendarTypes USEnglish = 2;
public int value__;

System.Globalization.DaylightTime

Module:mscorlib.dll

Hierarchy
Object
DaylightTime

Type declaration

[C#] public class DaylightTime;

Constructor
public DaylightTime(DateTime start, DateTime end, TimeSpan delta);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public TimeSpan Delta {get;}
public DateTime End {get;}
public DateTime Start {get;}

System.Globalization.DateTimeStyles

Module:mscorlib.dll

Hierarchy
Object
ValueType
Enum
DateTimeStyles

Type declaration

[C#] public enum DateTimeStyles;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const DateTimeStyles AdjustToUniversal = 16;
public const DateTimeStyles AllowInnerWhite = 4;
public const DateTimeStyles AllowLeadingWhite = 1;
public const DateTimeStyles AllowTrailingWhite = 2;
public const DateTimeStyles AllowWhiteSpaces = 7;
public const DateTimeStyles NoCurrentDateDefault = 8;
public const DateTimeStyles None = 0;
public int value__;

System.Globalization.Calendar

Module:mscorlib.dll

Hierarchy
Object
Calendar

Type declaration

[C#] public abstract class Calendar;

Constructor
protected Calendar();

Method
public virtual DateTime AddDays(DateTime time, int days);
public virtual DateTime AddHours(DateTime time, int hours);
public virtual DateTime AddMilliseconds(DateTime time, double milliseconds);
public virtual DateTime AddMinutes(DateTime time, int minutes);
public abstract DateTime AddMonths(DateTime time, int months);
public virtual DateTime AddSeconds(DateTime time, int seconds);
public virtual DateTime AddWeeks(DateTime time, int weeks);
public abstract DateTime AddYears(DateTime time, int years);
public virtual bool Equals(object obj);
protected override void Finalize();
public abstract int GetDayOfMonth(DateTime time);
public abstract DayOfWeek GetDayOfWeek(DateTime time);
public abstract int GetDayOfYear(DateTime time);
public virtual int GetDaysInMonth(int year, int month);
public abstract int GetDaysInMonth(int year, int month, int era);
public virtual int GetDaysInYear(int year);
public abstract int GetDaysInYear(int year, int era);
public abstract int GetEra(DateTime time);
public virtual int GetHashCode();
public virtual int GetHour(DateTime time);
public virtual double GetMilliseconds(DateTime time);
public virtual int GetMinute(DateTime time);
public abstract int GetMonth(DateTime time);
public virtual int GetMonthsInYear(int year);
public abstract int GetMonthsInYear(int year, int era);
public virtual int GetSecond(DateTime time);
public Type GetType();
public virtual int GetWeekOfYear(DateTime time, CalendarWeekRule rule, DayOfWeek firstDayOfWeek);
public abstract int GetYear(DateTime time);
public virtual bool IsLeapDay(int year, int month, int day);
public abstract bool IsLeapDay(int year, int month, int day, int era);
public virtual bool IsLeapMonth(int year, int month);
public abstract bool IsLeapMonth(int year, int month, int era);
public virtual bool IsLeapYear(int year);
public abstract bool IsLeapYear(int year, int era);
protected object MemberwiseClone();
public virtual DateTime ToDateTime(int year, int month, int day, int hour, int minute, int second, int millisecond);
public abstract DateTime ToDateTime(int year, int month, int day, int hour, int minute, int second, int millisecond, int era);
public virtual int ToFourDigitYear(int year);
public virtual string ToString();

Property
public abstract int[] Eras {get;}
public virtual int TwoDigitYearMax {get; set;}

Field
public const int CurrentEra = 0;

System.Globalization.CalendarWeekRule

Module:mscorlib.dll

Hierarchy
Object
ValueType
Enum
CalendarWeekRule

Type declaration

[C#] public enum CalendarWeekRule;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const CalendarWeekRule FirstDay = 0;
public const CalendarWeekRule FirstFourDayWeek = 2;
public const CalendarWeekRule FirstFullWeek = 1;
public int value__;

System.Globalization.TextElementEnumerator

Module:mscorlib.dll

Hierarchy
Object
TextElementEnumerator : IEnumerator

Type declaration

[C#] public class TextElementEnumerator: IEnumerator;

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public string GetTextElement();
public Type GetType();
protected object MemberwiseClone();
public virtual bool MoveNext();
public virtual void Reset();
public virtual string ToString();

Property
public virtual object Current {get;}
public int ElementIndex {get;}

System.Globalization.StringInfo

Module:mscorlib.dll

Hierarchy
Object
StringInfo

Type declaration

[C#] public class StringInfo;

Constructor
public StringInfo();

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public static string GetNextTextElement(string str);
public static string GetNextTextElement(string str, int index);
public static TextElementEnumerator GetTextElementEnumerator(string str);
public static TextElementEnumerator GetTextElementEnumerator(string str, int index);
public Type GetType();
protected object MemberwiseClone();
public static int[] ParseCombiningCharacters(string str);
public virtual string ToString();

System.Globalization.RegionInfo

Module:mscorlib.dll

Hierarchy
Object
RegionInfo

Type declaration

[C#] public class RegionInfo;

Constructor
public RegionInfo(int culture);
public RegionInfo(string name);

Method
public override bool Equals(object value);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public virtual string CurrencySymbol {get;}
public static RegionInfo CurrentRegion {get;}
public virtual string DisplayName {get;}
public virtual string EnglishName {get;}
public virtual bool IsMetric {get;}
public virtual string ISOCurrencySymbol {get;}
public virtual string Name {get;}
public virtual string ThreeLetterISORegionName {get;}
public virtual string ThreeLetterWindowsRegionName {get;}
public virtual string TwoLetterISORegionName {get;}

System.Globalization.NumberStyles

Module:mscorlib.dll

Hierarchy
Object
ValueType
Enum
NumberStyles

Type declaration

[C#] public enum NumberStyles;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const NumberStyles AllowCurrencySymbol = 256;
public const NumberStyles AllowDecimalPoint = 32;
public const NumberStyles AllowExponent = 128;
public const NumberStyles AllowHexSpecifier = 512;
public const NumberStyles AllowLeadingSign = 4;
public const NumberStyles AllowLeadingWhite = 1;
public const NumberStyles AllowParentheses = 16;
public const NumberStyles AllowThousands = 64;
public const NumberStyles AllowTrailingSign = 8;
public const NumberStyles AllowTrailingWhite = 2;
public const NumberStyles Any = 511;
public const NumberStyles Currency = 383;
public const NumberStyles Float = 167;
public const NumberStyles HexNumber = 515;
public const NumberStyles Integer = 7;
public const NumberStyles None = 0;
public const NumberStyles Number = 111;
public int value__;

System.Globalization.NumberFormatInfo

Module:mscorlib.dll

Hierarchy
Object
NumberFormatInfo : ICloneable, IFormatProvider

Type declaration

[C#] public sealed class NumberFormatInfo: ICloneable, IFormatProvider;

Constructor
public NumberFormatInfo();

Method
public virtual object Clone();
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual object GetFormat(Type formatType);
public virtual int GetHashCode();
public static NumberFormatInfo GetInstance(IFormatProvider formatProvider);
public Type GetType();
protected object MemberwiseClone();
public static NumberFormatInfo ReadOnly(NumberFormatInfo nfi);
public virtual string ToString();

Property
public int CurrencyDecimalDigits {get; set;}
public string CurrencyDecimalSeparator {get; set;}
public string CurrencyGroupSeparator {get; set;}
public int[] CurrencyGroupSizes {get; set;}
public int CurrencyNegativePattern {get; set;}
public int CurrencyPositivePattern {get; set;}
public string CurrencySymbol {get; set;}
public static NumberFormatInfo CurrentInfo {get;}
public static NumberFormatInfo InvariantInfo {get;}
public bool IsReadOnly {get;}
public string NaNSymbol {get; set;}
public string NegativeInfinitySymbol {get; set;}
public string NegativeSign {get; set;}
public int NumberDecimalDigits {get; set;}
public string NumberDecimalSeparator {get; set;}
public string NumberGroupSeparator {get; set;}
public int[] NumberGroupSizes {get; set;}
public int NumberNegativePattern {get; set;}
public int PercentDecimalDigits {get; set;}
public string PercentDecimalSeparator {get; set;}
public string PercentGroupSeparator {get; set;}
public int[] PercentGroupSizes {get; set;}
public int PercentNegativePattern {get; set;}
public int PercentPositivePattern {get; set;}
public string PercentSymbol {get; set;}
public string PerMilleSymbol {get; set;}
public string PositiveInfinitySymbol {get; set;}
public string PositiveSign {get; set;}

System.Globalization.CompareInfo

Module:mscorlib.dll

Hierarchy
Object
CompareInfo

Type declaration

[C#] public class CompareInfo;

Method
public virtual int Compare(string string1, int offset1, int length1, string string2, int offset2, int length2);
public virtual int Compare(string string1, int offset1, int length1, string string2, int offset2, int length2, CompareOptions options);
public virtual int Compare(string string1, int offset1, string string2, int offset2);
public virtual int Compare(string string1, int offset1, string string2, int offset2, CompareOptions options);
public virtual int Compare(string string1, string string2);
public virtual int Compare(string string1, string string2, CompareOptions options);
public override bool Equals(object value);
protected override void Finalize();
public static CompareInfo GetCompareInfo(int culture);
public static CompareInfo GetCompareInfo(int culture, Assembly assembly);
public static CompareInfo GetCompareInfo(string name);
public static CompareInfo GetCompareInfo(string name, Assembly assembly);
public override int GetHashCode();
public virtual SortKey GetSortKey(string source);
public virtual SortKey GetSortKey(string source, CompareOptions options);
public Type GetType();
public virtual int IndexOf(string source, char value);
public virtual int IndexOf(string source, char value, CompareOptions options);
public virtual int IndexOf(string source, char value, int startIndex);
public virtual int IndexOf(string source, char value, int startIndex, CompareOptions options);
public virtual int IndexOf(string source, char value, int startIndex, int count);
public virtual int IndexOf(string source, char value, int startIndex, int count, CompareOptions options);
public virtual int IndexOf(string source, string value);
public virtual int IndexOf(string source, string value, CompareOptions options);
public virtual int IndexOf(string source, string value, int startIndex);
public virtual int IndexOf(string source, string value, int startIndex, CompareOptions options);
public virtual int IndexOf(string source, string value, int startIndex, int count);
public virtual int IndexOf(string source, string value, int startIndex, int count, CompareOptions options);
public virtual bool IsPrefix(string source, string prefix);
public virtual bool IsPrefix(string source, string prefix, CompareOptions options);
public virtual bool IsSuffix(string source, string suffix);
public virtual bool IsSuffix(string source, string suffix, CompareOptions options);
public virtual int LastIndexOf(string source, char value);
public virtual int LastIndexOf(string source, char value, CompareOptions options);
public virtual int LastIndexOf(string source, char value, int startIndex);
public virtual int LastIndexOf(string source, char value, int startIndex, CompareOptions options);
public virtual int LastIndexOf(string source, char value, int startIndex, int count);
public virtual int LastIndexOf(string source, char value, int startIndex, int count, CompareOptions options);
public virtual int LastIndexOf(string source, string value);
public virtual int LastIndexOf(string source, string value, CompareOptions options);
public virtual int LastIndexOf(string source, string value, int startIndex);
public virtual int LastIndexOf(string source, string value, int startIndex, CompareOptions options);
public virtual int LastIndexOf(string source, string value, int startIndex, int count);
public virtual int LastIndexOf(string source, string value, int startIndex, int count, CompareOptions options);
protected object MemberwiseClone();
public override string ToString();

Property
public int LCID {get;}

System.Globalization.CompareOptions

Module:mscorlib.dll

Hierarchy
Object
ValueType
Enum
CompareOptions

Type declaration

[C#] public enum CompareOptions;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const CompareOptions IgnoreCase = 1;
public const CompareOptions IgnoreKanaType = 8;
public const CompareOptions IgnoreNonSpace = 2;
public const CompareOptions IgnoreSymbols = 4;
public const CompareOptions IgnoreWidth = 16;
public const CompareOptions None = 0;
public const CompareOptions Ordinal = 1073741824;
public const CompareOptions StringSort = 536870912;
public int value__;

System.Globalization.TextInfo

Module:mscorlib.dll

Hierarchy
Object
TextInfo

Type declaration

[C#] public class TextInfo;

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual char ToLower(char c);
public virtual string ToLower(string str);
public override string ToString();
public string ToTitleCase(string str);
public virtual char ToUpper(char c);
public virtual string ToUpper(string str);

Property
public int ANSICodePage {get;}
public virtual int EBCDICCodePage {get;}
public virtual string ListSeparator {get;}
public virtual int MacCodePage {get;}
public virtual int OEMCodePage {get;}

System.Globalization.UnicodeCategory

Module:mscorlib.dll

Hierarchy
Object
ValueType
Enum
UnicodeCategory

Type declaration

[C#] public enum UnicodeCategory;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const UnicodeCategory ClosePunctuation = 21;
public const UnicodeCategory ConnectorPunctuation = 18;
public const UnicodeCategory Control = 14;
public const UnicodeCategory CurrencySymbol = 26;
public const UnicodeCategory DashPunctuation = 19;
public const UnicodeCategory DecimalDigitNumber = 8;
public const UnicodeCategory EnclosingMark = 7;
public const UnicodeCategory FinalQuotePunctuation = 23;
public const UnicodeCategory Format = 15;
public const UnicodeCategory InitialQuotePunctuation = 22;
public const UnicodeCategory LetterNumber = 9;
public const UnicodeCategory LineSeparator = 12;
public const UnicodeCategory LowercaseLetter = 1;
public const UnicodeCategory MathSymbol = 25;
public const UnicodeCategory ModifierLetter = 3;
public const UnicodeCategory ModifierSymbol = 27;
public const UnicodeCategory NonSpacingMark = 5;
public const UnicodeCategory OpenPunctuation = 20;
public const UnicodeCategory OtherLetter = 4;
public const UnicodeCategory OtherNotAssigned = 29;
public const UnicodeCategory OtherNumber = 10;
public const UnicodeCategory OtherPunctuation = 24;
public const UnicodeCategory OtherSymbol = 28;
public const UnicodeCategory ParagraphSeparator = 13;
public const UnicodeCategory PrivateUse = 17;
public const UnicodeCategory SpaceSeparator = 11;
public const UnicodeCategory SpacingCombiningMark = 6;
public const UnicodeCategory Surrogate = 16;
public const UnicodeCategory TitlecaseLetter = 2;
public const UnicodeCategory UppercaseLetter = 0;
public int value__;

System.Globalization.CultureInfo

Module:mscorlib.dll

Hierarchy
Object
CultureInfo : ICloneable, IFormatProvider

Type declaration

[C#] public class CultureInfo: ICloneable, IFormatProvider;

Constructor
public CultureInfo(int culture);
public CultureInfo(int culture, bool useUserOverride);
public CultureInfo(string name);
public CultureInfo(string name, bool useUserOverride);

Method
public void ClearCachedData();
public virtual object Clone();
public static CultureInfo CreateSpecificCulture(string name);
public override bool Equals(object value);
protected override void Finalize();
public static CultureInfo[] GetCultures(CultureTypes types);
public virtual object GetFormat(Type formatType);
public override int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public static CultureInfo ReadOnly(CultureInfo ci);
public override string ToString();

Property
public virtual Calendar Calendar {get;}
public virtual CompareInfo CompareInfo {get;}
public static CultureInfo CurrentCulture {get;}
public static CultureInfo CurrentUICulture {get;}
public virtual DateTimeFormatInfo DateTimeFormat {get; set;}
public virtual string DisplayName {get;}
public virtual string EnglishName {get;}
public static CultureInfo InstalledUICulture {get;}
public static CultureInfo InvariantCulture {get;}
public virtual bool IsNeutralCulture {get;}
public virtual bool IsReadOnly {get;}
public virtual int LCID {get;}
public virtual string Name {get;}
public virtual string NativeName {get;}
public virtual NumberFormatInfo NumberFormat {get; set;}
public virtual Calendar[] OptionalCalendars {get;}
public virtual CultureInfo Parent {get;}
public virtual TextInfo TextInfo {get;}
public virtual string ThreeLetterISOLanguageName {get;}
public virtual string ThreeLetterWindowsLanguageName {get;}
public virtual string TwoLetterISOLanguageName {get;}
public bool UseUserOverride {get;}

System.Configuration.Assemblies.AssemblyVersionCompatibility

Module:mscorlib.dll

Hierarchy
Object
ValueType
Enum
AssemblyVersionCompatibility

Type declaration

[C#] public enum AssemblyVersionCompatibility;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const AssemblyVersionCompatibility SameDomain = 3;
public const AssemblyVersionCompatibility SameMachine = 1;
public const AssemblyVersionCompatibility SameProcess = 2;
public int value__;

System.Configuration.Assemblies.AssemblyHashAlgorithm

Module:mscorlib.dll

Hierarchy
Object
ValueType
Enum
AssemblyHashAlgorithm

Type declaration

[C#] public enum AssemblyHashAlgorithm;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const AssemblyHashAlgorithm MD5 = 32771;
public const AssemblyHashAlgorithm None = 0;
public const AssemblyHashAlgorithm SHA1 = 32772;
public int value__;

System.Security.Policy.Evidence

Module:mscorlib.dll

Hierarchy
Object
Evidence

Type declaration

[C#] public sealed class Evidence;

Constructor
public Evidence();
public Evidence(Evidence evidence);
public Evidence(object[] hostEvidence, object[] assemblyEvidence);

Method
public void AddAssembly(object id);
public void AddHost(object id);
public virtual void CopyTo(Array array, int index);
public virtual bool Equals(object obj);
protected override void Finalize();
public IEnumerator GetAssemblyEnumerator();
public virtual IEnumerator GetEnumerator();
public virtual int GetHashCode();
public IEnumerator GetHostEnumerator();
public Type GetType();
protected object MemberwiseClone();
public void Merge(Evidence evidence);
public virtual string ToString();

Property
public virtual int Count {get;}
public bool IsReadOnly {get;}
public virtual bool IsSynchronized {get;}
public bool Locked {get; set;}
public virtual object SyncRoot {get;}

System.IO.MemoryStream

Module:mscorlib.dll

Hierarchy
Object
MarshalByRefObject
Stream
MemoryStream

Type declaration

[C#] public class MemoryStream : Stream;

Constructor
public MemoryStream();
public MemoryStream(byte[] buffer);
public MemoryStream(byte[] buffer, bool writable);
public MemoryStream(byte[] buffer, int index, int count);
public MemoryStream(byte[] buffer, int index, int count, bool writable);
public MemoryStream(byte[] buffer, int index, int count, bool writable, bool publiclyVisible);
public MemoryStream(int capacity);

Method
public virtual IAsyncResult BeginRead(byte[] buffer, int offset, int count, AsyncCallback callback, object state);
public virtual IAsyncResult BeginWrite(byte[] buffer, int offset, int count, AsyncCallback callback, object state);
public override void Close();
public ObjRef CreateObjRef(Type requestedType);
protected virtual WaitHandle CreateWaitHandle();
public virtual int EndRead(IAsyncResult asyncResult);
public virtual void EndWrite(IAsyncResult asyncResult);
public virtual bool Equals(object obj);
protected override void Finalize();
public override void Flush();
public virtual byte[] GetBuffer();
public virtual int GetHashCode();
public object GetLifetimeService();
public Type GetType();
public object InitializeLifetimeService();
protected object MemberwiseClone();
public override int Read(byte[] buffer, int offset, int count);
public override int ReadByte();
public override long Seek(long offset, SeekOrigin loc);
public override void SetLength(long value);
public virtual byte[] ToArray();
public virtual string ToString();
public override void Write(byte[] buffer, int offset, int count);
public override void WriteByte(byte value);
public virtual void WriteTo(Stream stream);

Property
public override bool CanRead {get;}
public override bool CanSeek {get;}
public override bool CanWrite {get;}
public virtual int Capacity {get; set;}
public override long Length {get;}
public override long Position {get; set;}

System.IO.StringWriter

Module:mscorlib.dll

Hierarchy
Object
MarshalByRefObject
TextWriter
StringWriter

Type declaration

[C#] public class StringWriter : TextWriter;

Constructor
public StringWriter();
public StringWriter(IFormatProvider formatProvider);
public StringWriter(StringBuilder sb);
public StringWriter(StringBuilder sb, IFormatProvider formatProvider);

Method
public override void Close();
public ObjRef CreateObjRef(Type requestedType);
protected override void Dispose(bool disposing);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual void Flush();
public virtual int GetHashCode();
public object GetLifetimeService();
public virtual StringBuilder GetStringBuilder();
public Type GetType();
public object InitializeLifetimeService();
protected object MemberwiseClone();
public override string ToString();
public virtual void Write(bool value);
public override void Write(char value);
public virtual void Write(char[] buffer);
public override void Write(char[] buffer, int index, int count);
public virtual void Write(decimal value);
public virtual void Write(double value);
public virtual void Write(int value);
public virtual void Write(long value);
public virtual void Write(object value);
public virtual void Write(float value);
public override void Write(string value);
public virtual void Write(string format, params object[] arg);
public virtual void Write(string format, object arg0);
public virtual void Write(string format, object arg0, object arg1);
public void Write(string format, object arg0, object arg1, object arg2);
public virtual void Write(uint value);
public virtual void Write(ulong value);
public virtual void WriteLine();
public virtual void WriteLine(bool value);
public virtual void WriteLine(char value);
public virtual void WriteLine(char[] buffer);
public virtual void WriteLine(char[] buffer, int index, int count);
public virtual void WriteLine(decimal value);
public virtual void WriteLine(double value);
public virtual void WriteLine(int value);
public virtual void WriteLine(long value);
public virtual void WriteLine(object value);
public virtual void WriteLine(float value);
public virtual void WriteLine(string value);
public virtual void WriteLine(string format, params object[] arg);
public virtual void WriteLine(string format, object arg0);
public virtual void WriteLine(string format, object arg0, object arg1);
public void WriteLine(string format, object arg0, object arg1, object arg2);
public virtual void WriteLine(uint value);
public virtual void WriteLine(ulong value);

Property
public override Encoding Encoding {get;}
public virtual IFormatProvider FormatProvider {get;}
public virtual string NewLine {get; set;}

Field
protected char[] CoreNewLine;

System.IO.StringReader

Module:mscorlib.dll

Hierarchy
Object
MarshalByRefObject
TextReader
StringReader

Type declaration

[C#] public class StringReader : TextReader;

Constructor
public StringReader(string s);

Method
public override void Close();
public ObjRef CreateObjRef(Type requestedType);
protected override void Dispose(bool disposing);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public object GetLifetimeService();
public Type GetType();
public object InitializeLifetimeService();
protected object MemberwiseClone();
public override int Peek();
public override int Read();
public override int Read(char[] buffer, int index, int count);
public virtual int ReadBlock(char[] buffer, int index, int count);
public override string ReadLine();
public override string ReadToEnd();
public virtual string ToString();

System.IO.FileShare

Module:mscorlib.dll

Hierarchy
Object
ValueType
Enum
FileShare

Type declaration

[C#] public enum FileShare;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const FileShare Inheritable = 16;
public const FileShare None = 0;
public const FileShare Read = 1;
public const FileShare ReadWrite = 3;
public int value__;
public const FileShare Write = 2;

System.IO.FileMode

Module:mscorlib.dll

Hierarchy
Object
ValueType
Enum
FileMode

Type declaration

[C#] public enum FileMode;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const FileMode Append = 6;
public const FileMode Create = 2;
public const FileMode CreateNew = 1;
public const FileMode Open = 3;
public const FileMode OpenOrCreate = 4;
public const FileMode Truncate = 5;
public int value__;

System.IO.FileStream

Module:mscorlib.dll

Hierarchy
Object
MarshalByRefObject
Stream
FileStream

Type declaration

[C#] public class FileStream : Stream;

Constructor
public FileStream(IntPtr handle, FileAccess access);
public FileStream(IntPtr handle, FileAccess access, bool ownsHandle);
public FileStream(IntPtr handle, FileAccess access, bool ownsHandle, int bufferSize);
public FileStream(IntPtr handle, FileAccess access, bool ownsHandle, int bufferSize, bool isAsync);
public FileStream(string path, FileMode mode);
public FileStream(string path, FileMode mode, FileAccess access);
public FileStream(string path, FileMode mode, FileAccess access, FileShare share);
public FileStream(string path, FileMode mode, FileAccess access, FileShare share, int bufferSize);
public FileStream(string path, FileMode mode, FileAccess access, FileShare share, int bufferSize, bool useAsync);

Method
public virtual IAsyncResult BeginRead(byte[] buffer, int offset, int count, AsyncCallback callback, object state);
public virtual IAsyncResult BeginWrite(byte[] buffer, int offset, int count, AsyncCallback callback, object state);
public override void Close();
public ObjRef CreateObjRef(Type requestedType);
protected virtual WaitHandle CreateWaitHandle();
protected virtual void Dispose(bool disposing);
public virtual int EndRead(IAsyncResult asyncResult);
public virtual void EndWrite(IAsyncResult asyncResult);
public virtual bool Equals(object obj);
protected override void Finalize();
public override void Flush();
public virtual int GetHashCode();
public object GetLifetimeService();
public Type GetType();
public object InitializeLifetimeService();
public virtual void Lock(long position, long length);
protected object MemberwiseClone();
public override int Read(byte[] array, int offset, int count);
public override int ReadByte();
public override long Seek(long offset, SeekOrigin origin);
public override void SetLength(long value);
public virtual string ToString();
public virtual void Unlock(long position, long length);
public override void Write(byte[] array, int offset, int count);
public override void WriteByte(byte value);

Property
public override bool CanRead {get;}
public override bool CanSeek {get;}
public override bool CanWrite {get;}
public virtual IntPtr Handle {get;}
public virtual bool IsAsync {get;}
public override long Length {get;}
public string Name {get;}
public override long Position {get; set;}

System.IO.FileAttributes

Module:mscorlib.dll

Hierarchy
Object
ValueType
Enum
FileAttributes

Type declaration

[C#] public enum FileAttributes;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const FileAttributes Archive = 32;
public const FileAttributes Compressed = 2048;
public const FileAttributes Device = 64;
public const FileAttributes Directory = 16;
public const FileAttributes Encrypted = 16384;
public const FileAttributes Hidden = 2;
public const FileAttributes Normal = 128;
public const FileAttributes NotContentIndexed = 8192;
public const FileAttributes Offline = 4096;
public const FileAttributes ReadOnly = 1;
public const FileAttributes ReparsePoint = 1024;
public const FileAttributes SparseFile = 512;
public const FileAttributes System = 4;
public const FileAttributes Temporary = 256;
public int value__;

System.IO.DirectoryInfo

Module:mscorlib.dll

Hierarchy
Object
MarshalByRefObject
FileSystemInfo
DirectoryInfo

Type declaration

[C#] public sealed class DirectoryInfo : FileSystemInfo;

Constructor
public DirectoryInfo(string path);

Method
public void Create();
public ObjRef CreateObjRef(Type requestedType);
public DirectoryInfo CreateSubdirectory(string path);
public override void Delete();
public void Delete(bool recursive);
public virtual bool Equals(object obj);
protected override void Finalize();
public DirectoryInfo[] GetDirectories();
public DirectoryInfo[] GetDirectories(string searchPattern);
public FileInfo[] GetFiles();
public FileInfo[] GetFiles(string searchPattern);
public FileSystemInfo[] GetFileSystemInfos();
public FileSystemInfo[] GetFileSystemInfos(string searchPattern);
public virtual int GetHashCode();
public object GetLifetimeService();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
public object InitializeLifetimeService();
protected object MemberwiseClone();
public void MoveTo(string destDirName);
public void Refresh();
public override string ToString();

Property
public FileAttributes Attributes {get; set;}
public DateTime CreationTime {get;}
public DateTime CreationTime {get; set;}
public DateTime CreationTimeUtc {get; set;}
public override bool Exists {get;}
public string Extension {get;}
public virtual string FullName {get;}
public DateTime LastAccessTime {get;}
public DateTime LastAccessTime {get; set;}
public DateTime LastAccessTimeUtc {get; set;}
public DateTime LastWriteTime {get;}
public DateTime LastWriteTime {get; set;}
public DateTime LastWriteTimeUtc {get; set;}
public override string Name {get;}
public DirectoryInfo Parent {get;}
public DirectoryInfo Root {get;}

Field
protected string FullPath;
protected string OriginalPath;

System.IO.Directory

Module:mscorlib.dll

Hierarchy
Object
Directory

Type declaration

[C#] public sealed class Directory;

Method
public static DirectoryInfo CreateDirectory(string path);
public static void Delete(string path);
public static void Delete(string path, bool recursive);
public virtual bool Equals(object obj);
public static bool Exists(string path);
protected override void Finalize();
public static DateTime GetCreationTime(string path);
public static DateTime GetCreationTimeUtc(string path);
public static string GetCurrentDirectory();
public static string[] GetDirectories(string path);
public static string[] GetDirectories(string path, string searchPattern);
public static string GetDirectoryRoot(string path);
public static string[] GetFiles(string path);
public static string[] GetFiles(string path, string searchPattern);
public static string[] GetFileSystemEntries(string path);
public static string[] GetFileSystemEntries(string path, string searchPattern);
public virtual int GetHashCode();
public static DateTime GetLastAccessTime(string path);
public static DateTime GetLastAccessTimeUtc(string path);
public static DateTime GetLastWriteTime(string path);
public static DateTime GetLastWriteTimeUtc(string path);
public static string[] GetLogicalDrives();
public static DirectoryInfo GetParent(string path);
public Type GetType();
protected object MemberwiseClone();
public static void Move(string sourceDirName, string destDirName);
public static void SetCreationTime(string path, DateTime creationTime);
public static void SetCreationTimeUtc(string path, DateTime creationTimeUtc);
public static void SetCurrentDirectory(string path);
public static void SetLastAccessTime(string path, DateTime lastAccessTime);
public static void SetLastAccessTimeUtc(string path, DateTime lastAccessTimeUtc);
public static void SetLastWriteTime(string path, DateTime lastWriteTime);
public static void SetLastWriteTimeUtc(string path, DateTime lastWriteTimeUtc);
public virtual string ToString();

System.IO.Path

Module:mscorlib.dll

Hierarchy
Object
Path

Type declaration

[C#] public sealed class Path;

Method
public static string ChangeExtension(string path, string extension);
public static string Combine(string path1, string path2);
public virtual bool Equals(object obj);
protected override void Finalize();
public static string GetDirectoryName(string path);
public static string GetExtension(string path);
public static string GetFileName(string path);
public static string GetFileNameWithoutExtension(string path);
public static string GetFullPath(string path);
public virtual int GetHashCode();
public static string GetPathRoot(string path);
public static string GetTempFileName();
public static string GetTempPath();
public Type GetType();
public static bool HasExtension(string path);
public static bool IsPathRooted(string path);
protected object MemberwiseClone();
public virtual string ToString();

Field
public readonly static char AltDirectorySeparatorChar;
public readonly static char DirectorySeparatorChar;
public readonly static char[] InvalidPathChars;
public readonly static char PathSeparator;
public readonly static char VolumeSeparatorChar;

System.IO.FileInfo

Module:mscorlib.dll

Hierarchy
Object
MarshalByRefObject
FileSystemInfo
FileInfo

Type declaration

[C#] public sealed class FileInfo : FileSystemInfo;

Constructor
public FileInfo(string fileName);

Method
public StreamWriter AppendText();
public FileInfo CopyTo(string destFileName);
public FileInfo CopyTo(string destFileName, bool overwrite);
public FileStream Create();
public ObjRef CreateObjRef(Type requestedType);
public StreamWriter CreateText();
public override void Delete();
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public object GetLifetimeService();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
public object InitializeLifetimeService();
protected object MemberwiseClone();
public void MoveTo(string destFileName);
public FileStream Open(FileMode mode);
public FileStream Open(FileMode mode, FileAccess access);
public FileStream Open(FileMode mode, FileAccess access, FileShare share);
public FileStream OpenRead();
public StreamReader OpenText();
public FileStream OpenWrite();
public void Refresh();
public override string ToString();

Property
public FileAttributes Attributes {get; set;}
public DateTime CreationTime {get;}
public DateTime CreationTime {get; set;}
public DateTime CreationTimeUtc {get; set;}
public DirectoryInfo Directory {get;}
public string DirectoryName {get;}
public override bool Exists {get;}
public string Extension {get;}
public virtual string FullName {get;}
public DateTime LastAccessTime {get;}
public DateTime LastAccessTime {get; set;}
public DateTime LastAccessTimeUtc {get; set;}
public DateTime LastWriteTime {get;}
public DateTime LastWriteTime {get; set;}
public DateTime LastWriteTimeUtc {get; set;}
public long Length {get;}
public override string Name {get;}

Field
protected string FullPath;
protected string OriginalPath;

System.IO.FileSystemInfo

Module:mscorlib.dll

Hierarchy
Object
MarshalByRefObject
FileSystemInfo

Type declaration

[C#] public abstract class FileSystemInfo : MarshalByRefObject;

Constructor
protected FileSystemInfo();
protected FileSystemInfo(SerializationInfo info, StreamingContext context);

Method
public ObjRef CreateObjRef(Type requestedType);
public abstract void Delete();
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public object GetLifetimeService();
public virtual void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
public object InitializeLifetimeService();
protected object MemberwiseClone();
public void Refresh();
public virtual string ToString();

Property
public FileAttributes Attributes {get; set;}
public DateTime CreationTime {get;}
public DateTime CreationTime {get; set;}
public DateTime CreationTimeUtc {get; set;}
public abstract bool Exists {get;}
public string Extension {get;}
public virtual string FullName {get;}
public DateTime LastAccessTime {get;}
public DateTime LastAccessTime {get; set;}
public DateTime LastAccessTimeUtc {get; set;}
public DateTime LastWriteTime {get;}
public DateTime LastWriteTime {get; set;}
public DateTime LastWriteTimeUtc {get; set;}
public abstract string Name {get;}

Field
protected string FullPath;
protected string OriginalPath;

System.IO.File

Module:mscorlib.dll

Hierarchy
Object
File

Type declaration

[C#] public sealed class File;

Method
public static StreamWriter AppendText(string path);
public static void Copy(string sourceFileName, string destFileName);
public static void Copy(string sourceFileName, string destFileName, bool overwrite);
public static FileStream Create(string path);
public static FileStream Create(string path, int bufferSize);
public static StreamWriter CreateText(string path);
public static void Delete(string path);
public virtual bool Equals(object obj);
public static bool Exists(string path);
protected override void Finalize();
public static FileAttributes GetAttributes(string path);
public static DateTime GetCreationTime(string path);
public static DateTime GetCreationTimeUtc(string path);
public virtual int GetHashCode();
public static DateTime GetLastAccessTime(string path);
public static DateTime GetLastAccessTimeUtc(string path);
public static DateTime GetLastWriteTime(string path);
public static DateTime GetLastWriteTimeUtc(string path);
public Type GetType();
protected object MemberwiseClone();
public static void Move(string sourceFileName, string destFileName);
public static FileStream Open(string path, FileMode mode);
public static FileStream Open(string path, FileMode mode, FileAccess access);
public static FileStream Open(string path, FileMode mode, FileAccess access, FileShare share);
public static FileStream OpenRead(string path);
public static StreamReader OpenText(string path);
public static FileStream OpenWrite(string path);
public static void SetAttributes(string path, FileAttributes fileAttributes);
public static void SetCreationTime(string path, DateTime creationTime);
public static void SetCreationTimeUtc(string path, DateTime creationTimeUtc);
public static void SetLastAccessTime(string path, DateTime lastAccessTime);
public static void SetLastAccessTimeUtc(string path, DateTime lastAccessTimeUtc);
public static void SetLastWriteTime(string path, DateTime lastWriteTime);
public static void SetLastWriteTimeUtc(string path, DateTime lastWriteTimeUtc);
public virtual string ToString();

System.IO.StreamWriter

Module:mscorlib.dll

Hierarchy
Object
MarshalByRefObject
TextWriter
StreamWriter

Type declaration

[C#] public class StreamWriter : TextWriter;

Constructor
public StreamWriter(Stream stream);
public StreamWriter(Stream stream, Encoding encoding);
public StreamWriter(Stream stream, Encoding encoding, int bufferSize);
public StreamWriter(string path);
public StreamWriter(string path, bool append);
public StreamWriter(string path, bool append, Encoding encoding);
public StreamWriter(string path, bool append, Encoding encoding, int bufferSize);

Method
public override void Close();
public ObjRef CreateObjRef(Type requestedType);
protected override void Dispose(bool disposing);
public virtual bool Equals(object obj);
protected override void Finalize();
public override void Flush();
public virtual int GetHashCode();
public object GetLifetimeService();
public Type GetType();
public object InitializeLifetimeService();
protected object MemberwiseClone();
public virtual string ToString();
public virtual void Write(bool value);
public override void Write(char value);
public override void Write(char[] buffer);
public override void Write(char[] buffer, int index, int count);
public virtual void Write(decimal value);
public virtual void Write(double value);
public virtual void Write(int value);
public virtual void Write(long value);
public virtual void Write(object value);
public virtual void Write(float value);
public override void Write(string value);
public virtual void Write(string format, params object[] arg);
public virtual void Write(string format, object arg0);
public virtual void Write(string format, object arg0, object arg1);
public void Write(string format, object arg0, object arg1, object arg2);
public virtual void Write(uint value);
public virtual void Write(ulong value);
public virtual void WriteLine();
public virtual void WriteLine(bool value);
public virtual void WriteLine(char value);
public virtual void WriteLine(char[] buffer);
public virtual void WriteLine(char[] buffer, int index, int count);
public virtual void WriteLine(decimal value);
public virtual void WriteLine(double value);
public virtual void WriteLine(int value);
public virtual void WriteLine(long value);
public virtual void WriteLine(object value);
public virtual void WriteLine(float value);
public virtual void WriteLine(string value);
public virtual void WriteLine(string format, params object[] arg);
public virtual void WriteLine(string format, object arg0);
public virtual void WriteLine(string format, object arg0, object arg1);
public void WriteLine(string format, object arg0, object arg1, object arg2);
public virtual void WriteLine(uint value);
public virtual void WriteLine(ulong value);

Property
public virtual bool AutoFlush {get; set;}
public virtual Stream BaseStream {get;}
public override Encoding Encoding {get;}
public virtual IFormatProvider FormatProvider {get;}
public virtual string NewLine {get; set;}

Field
protected char[] CoreNewLine;
public readonly static StreamWriter Null;

System.IO.TextWriter

Module:mscorlib.dll

Hierarchy
Object
MarshalByRefObject
TextWriter : IDisposable

Type declaration

[C#] public abstract class TextWriter : MarshalByRefObject, IDisposable;

Constructor
protected TextWriter();
protected TextWriter(IFormatProvider formatProvider);

Method
public virtual void Close();
public ObjRef CreateObjRef(Type requestedType);
protected virtual void Dispose(bool disposing);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual void Flush();
public virtual int GetHashCode();
public object GetLifetimeService();
public Type GetType();
public object InitializeLifetimeService();
protected object MemberwiseClone();
public static TextWriter Synchronized(TextWriter writer);
public virtual string ToString();
public virtual void Write(bool value);
public virtual void Write(char value);
public virtual void Write(char[] buffer);
public virtual void Write(char[] buffer, int index, int count);
public virtual void Write(decimal value);
public virtual void Write(double value);
public virtual void Write(int value);
public virtual void Write(long value);
public virtual void Write(object value);
public virtual void Write(float value);
public virtual void Write(string value);
public virtual void Write(string format, params object[] arg);
public virtual void Write(string format, object arg0);
public virtual void Write(string format, object arg0, object arg1);
public virtual void Write(string format, object arg0, object arg1, object arg2);
public virtual void Write(uint value);
public virtual void Write(ulong value);
public virtual void WriteLine();
public virtual void WriteLine(bool value);
public virtual void WriteLine(char value);
public virtual void WriteLine(char[] buffer);
public virtual void WriteLine(char[] buffer, int index, int count);
public virtual void WriteLine(decimal value);
public virtual void WriteLine(double value);
public virtual void WriteLine(int value);
public virtual void WriteLine(long value);
public virtual void WriteLine(object value);
public virtual void WriteLine(float value);
public virtual void WriteLine(string value);
public virtual void WriteLine(string format, params object[] arg);
public virtual void WriteLine(string format, object arg0);
public virtual void WriteLine(string format, object arg0, object arg1);
public virtual void WriteLine(string format, object arg0, object arg1, object arg2);
public virtual void WriteLine(uint value);
public virtual void WriteLine(ulong value);

Property
public abstract Encoding Encoding {get;}
public virtual IFormatProvider FormatProvider {get;}
public virtual string NewLine {get; set;}

Field
protected char[] CoreNewLine;
public readonly static TextWriter Null;

System.IO.StreamReader

Module:mscorlib.dll

Hierarchy
Object
MarshalByRefObject
TextReader
StreamReader

Type declaration

[C#] public class StreamReader : TextReader;

Constructor
public StreamReader(Stream stream);
public StreamReader(Stream stream, bool detectEncodingFromByteOrderMarks);
public StreamReader(Stream stream, Encoding encoding);
public StreamReader(Stream stream, Encoding encoding, bool detectEncodingFromByteOrderMarks);
public StreamReader(Stream stream, Encoding encoding, bool detectEncodingFromByteOrderMarks, int bufferSize);
public StreamReader(string path);
public StreamReader(string path, bool detectEncodingFromByteOrderMarks);
public StreamReader(string path, Encoding encoding);
public StreamReader(string path, Encoding encoding, bool detectEncodingFromByteOrderMarks);
public StreamReader(string path, Encoding encoding, bool detectEncodingFromByteOrderMarks, int bufferSize);

Method
public override void Close();
public ObjRef CreateObjRef(Type requestedType);
public void DiscardBufferedData();
protected override void Dispose(bool disposing);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public object GetLifetimeService();
public Type GetType();
public object InitializeLifetimeService();
protected object MemberwiseClone();
public override int Peek();
public override int Read();
public override int Read(char[] buffer, int index, int count);
public virtual int ReadBlock(char[] buffer, int index, int count);
public override string ReadLine();
public override string ReadToEnd();
public virtual string ToString();

Property
public virtual Stream BaseStream {get;}
public virtual Encoding CurrentEncoding {get;}

Field
public readonly static StreamReader Null;

System.IO.TextReader

Module:mscorlib.dll

Hierarchy
Object
MarshalByRefObject
TextReader : IDisposable

Type declaration

[C#] public abstract class TextReader : MarshalByRefObject, IDisposable;

Constructor
protected TextReader();

Method
public virtual void Close();
public ObjRef CreateObjRef(Type requestedType);
protected virtual void Dispose(bool disposing);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public object GetLifetimeService();
public Type GetType();
public object InitializeLifetimeService();
protected object MemberwiseClone();
public virtual int Peek();
public virtual int Read();
public virtual int Read(char[] buffer, int index, int count);
public virtual int ReadBlock(char[] buffer, int index, int count);
public virtual string ReadLine();
public virtual string ReadToEnd();
public static TextReader Synchronized(TextReader reader);
public virtual string ToString();

Field
public readonly static TextReader Null;

System.IO.BinaryWriter

Module:mscorlib.dll

Hierarchy
Object
BinaryWriter

Type declaration

[C#] public class BinaryWriter;

Constructor
protected BinaryWriter();
public BinaryWriter(Stream output);
public BinaryWriter(Stream output, Encoding encoding);

Method
public virtual void Close();
protected virtual void Dispose(bool disposing);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual void Flush();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual long Seek(int offset, SeekOrigin origin);
public virtual string ToString();
public virtual void Write(bool value);
public virtual void Write(byte value);
public virtual void Write(byte[] buffer);
public virtual void Write(byte[] buffer, int index, int count);
public virtual void Write(char ch);
public virtual void Write(char[] chars);
public virtual void Write(char[] chars, int index, int count);
public virtual void Write(decimal value);
public virtual void Write(double value);
public virtual void Write(short value);
public virtual void Write(int value);
public virtual void Write(long value);
public virtual void Write(SByte value);
public virtual void Write(float value);
public virtual void Write(string value);
public virtual void Write(ushort value);
public virtual void Write(uint value);
public virtual void Write(ulong value);
protected void Write7BitEncodedInt(int value);

Property
public virtual Stream BaseStream {get;}

Field
public readonly static BinaryWriter Null;
protected Stream OutStream;

System.IO.BinaryReader

Module:mscorlib.dll

Hierarchy
Object
BinaryReader

Type declaration

[C#] public class BinaryReader;

Constructor
public BinaryReader(Stream input);
public BinaryReader(Stream input, Encoding encoding);

Method
public virtual void Close();
protected virtual void Dispose(bool disposing);
public virtual bool Equals(object obj);
protected virtual void FillBuffer(int numBytes);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual int PeekChar();
public virtual int Read();
public virtual int Read(byte[] buffer, int index, int count);
public virtual int Read(char[] buffer, int index, int count);
protected int Read7BitEncodedInt();
public virtual bool ReadBoolean();
public virtual byte ReadByte();
public virtual byte[] ReadBytes(int count);
public virtual char ReadChar();
public virtual char[] ReadChars(int count);
public virtual decimal ReadDecimal();
public virtual double ReadDouble();
public virtual short ReadInt16();
public virtual int ReadInt32();
public virtual long ReadInt64();
public virtual SByte ReadSByte();
public virtual float ReadSingle();
public virtual string ReadString();
public virtual ushort ReadUInt16();
public virtual uint ReadUInt32();
public virtual ulong ReadUInt64();
public virtual string ToString();

Property
public virtual Stream BaseStream {get;}

System.IO.PathTooLongException

Module:mscorlib.dll

Hierarchy
Object
Exception
SystemException
IOException
PathTooLongException

Type declaration

[C#] public class PathTooLongException : IOException;

Constructor
public PathTooLongException();
protected PathTooLongException(SerializationInfo info, StreamingContext context);
public PathTooLongException(string message);
public PathTooLongException(string message, Exception innerException);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public virtual string Message {get;}
public string Source {get; set;}
public string StackTrace {get;}
public MethodBase TargetSite {get;}

System.IO.DirectoryNotFoundException

Module:mscorlib.dll

Hierarchy
Object
Exception
SystemException
IOException
DirectoryNotFoundException

Type declaration

[C#] public class DirectoryNotFoundException : IOException;

Constructor
public DirectoryNotFoundException();
protected DirectoryNotFoundException(SerializationInfo info, StreamingContext context);
public DirectoryNotFoundException(string message);
public DirectoryNotFoundException(string message, Exception innerException);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public virtual string Message {get;}
public string Source {get; set;}
public string StackTrace {get;}
public MethodBase TargetSite {get;}

System.IO.FileNotFoundException

Module:mscorlib.dll

Hierarchy
Object
Exception
SystemException
IOException
FileNotFoundException

Type declaration

[C#] public class FileNotFoundException : IOException;

Constructor
public FileNotFoundException();
protected FileNotFoundException(SerializationInfo info, StreamingContext context);
public FileNotFoundException(string message);
public FileNotFoundException(string message, Exception innerException);
public FileNotFoundException(string message, string fileName);
public FileNotFoundException(string message, string fileName, Exception innerException);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public override void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public string FileName {get;}
public string FusionLog {get;}
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public virtual string Message {get;}
public string Source {get; set;}
public string StackTrace {get;}
public MethodBase TargetSite {get;}

System.IO.FileAccess

Module:mscorlib.dll

Hierarchy
Object
ValueType
Enum
FileAccess

Type declaration

[C#] public enum FileAccess;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const FileAccess Read = 1;
public const FileAccess ReadWrite = 3;
public int value__;
public const FileAccess Write = 2;

System.IO.Stream

Module:mscorlib.dll

Hierarchy
Object
MarshalByRefObject
Stream : IDisposable

Type declaration

[C#] public abstract class Stream : MarshalByRefObject, IDisposable;

Constructor
protected Stream();

Method
public virtual IAsyncResult BeginRead(byte[] buffer, int offset, int count, AsyncCallback callback, object state);
public virtual IAsyncResult BeginWrite(byte[] buffer, int offset, int count, AsyncCallback callback, object state);
public virtual void Close();
public ObjRef CreateObjRef(Type requestedType);
protected virtual WaitHandle CreateWaitHandle();
public virtual int EndRead(IAsyncResult asyncResult);
public virtual void EndWrite(IAsyncResult asyncResult);
public virtual bool Equals(object obj);
protected override void Finalize();
public abstract void Flush();
public virtual int GetHashCode();
public object GetLifetimeService();
public Type GetType();
public object InitializeLifetimeService();
protected object MemberwiseClone();
public abstract int Read(byte[] buffer, int offset, int count);
public virtual int ReadByte();
public abstract long Seek(long offset, SeekOrigin origin);
public abstract void SetLength(long value);
public virtual string ToString();
public abstract void Write(byte[] buffer, int offset, int count);
public virtual void WriteByte(byte value);

Property
public abstract bool CanRead {get;}
public abstract bool CanSeek {get;}
public abstract bool CanWrite {get;}
public abstract long Length {get;}
public abstract long Position {get; set;}

Field
public readonly static Stream Null;

System.IO.SeekOrigin

Module:mscorlib.dll

Hierarchy
Object
ValueType
Enum
SeekOrigin

Type declaration

[C#] public enum SeekOrigin;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const SeekOrigin Begin = 0;
public const SeekOrigin Current = 1;
public const SeekOrigin End = 2;
public int value__;

System.IO.EndOfStreamException

Module:mscorlib.dll

Hierarchy
Object
Exception
SystemException
IOException
EndOfStreamException

Type declaration

[C#] public class EndOfStreamException : IOException;

Constructor
public EndOfStreamException();
protected EndOfStreamException(SerializationInfo info, StreamingContext context);
public EndOfStreamException(string message);
public EndOfStreamException(string message, Exception innerException);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public virtual string Message {get;}
public string Source {get; set;}
public string StackTrace {get;}
public MethodBase TargetSite {get;}

System.IO.IOException

Module:mscorlib.dll

Hierarchy
Object
Exception
SystemException
IOException

Type declaration

[C#] public class IOException : SystemException;

Constructor
public IOException();
protected IOException(SerializationInfo info, StreamingContext context);
public IOException(string message);
public IOException(string message, Exception inner);
public IOException(string message, int hresult);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public virtual string Message {get;}
public string Source {get; set;}
public string StackTrace {get;}
public MethodBase TargetSite {get;}

System.Resources.NeutralResourcesLanguageAttribute

Module:mscorlib.dll

Hierarchy
Object
Attribute
NeutralResourcesLanguageAttribute

Type declaration

[C#] public sealed class NeutralResourcesLanguageAttribute : Attribute;

Constructor
public NeutralResourcesLanguageAttribute(string cultureName);

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public string CultureName {get;}
public object TypeId {get;}

System.Resources.ResourceReader

Module:mscorlib.dll

Hierarchy
Object
ResourceReader : IResourceReader, IEnumerable, IDisposable

Type declaration

[C#] public sealed class ResourceReader: IResourceReader, IEnumerable, IDisposable;

Constructor
public ResourceReader(Stream stream);
public ResourceReader(string fileName);

Method
public virtual void Close();
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual IDictionaryEnumerator GetEnumerator();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

System.Resources.IResourceReader

Module:mscorlib.dll

Hierarchy
IResourceReader : IEnumerable, IDisposable

Type declaration

[C#] public interface IResourceReader: IEnumerable, IDisposable;

Method
public void Close();
public IDictionaryEnumerator GetEnumerator();

System.Resources.ResourceSet

Module:mscorlib.dll

Hierarchy
Object
ResourceSet : IDisposable, IEnumerable

Type declaration

[C#] public class ResourceSet: IDisposable, IEnumerable;

Constructor
protected ResourceSet();
public ResourceSet(IResourceReader reader);
public ResourceSet(Stream stream);
public ResourceSet(string fileName);

Method
public virtual void Close();
public virtual void Dispose();
protected virtual void Dispose(bool disposing);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Type GetDefaultReader();
public virtual Type GetDefaultWriter();
public virtual IDictionaryEnumerator GetEnumerator();
public virtual int GetHashCode();
public virtual object GetObject(string name);
public virtual object GetObject(string name, bool ignoreCase);
public virtual string GetString(string name);
public virtual string GetString(string name, bool ignoreCase);
public Type GetType();
protected object MemberwiseClone();
protected virtual void ReadResources();
public virtual string ToString();

Field
protected IResourceReader Reader;
protected Hashtable Table;

System.Resources.ResourceManager

Module:mscorlib.dll

Hierarchy
Object
ResourceManager

Type declaration

[C#] public class ResourceManager;

Constructor
protected ResourceManager();
public ResourceManager(string baseName, Assembly assembly);
public ResourceManager(string baseName, Assembly assembly, Type usingResourceSet);
public ResourceManager(Type resourceSource);

Method
public static ResourceManager CreateFileBasedResourceManager(string baseName, string resourceDir, Type usingResourceSet);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
protected static CultureInfo GetNeutralResourcesLanguage(Assembly a);
public virtual object GetObject(string name);
public virtual object GetObject(string name, CultureInfo culture);
protected virtual string GetResourceFileName(CultureInfo culture);
public virtual ResourceSet GetResourceSet(CultureInfo culture, bool createIfNotExists, bool tryParents);
protected static Version GetSatelliteContractVersion(Assembly a);
public virtual string GetString(string name);
public virtual string GetString(string name, CultureInfo culture);
public Type GetType();
protected virtual ResourceSet InternalGetResourceSet(CultureInfo culture, bool createIfNotExists, bool tryParents);
protected object MemberwiseClone();
public virtual void ReleaseAllResources();
public virtual string ToString();

Property
public virtual string BaseName {get;}
public virtual bool IgnoreCase {get; set;}
public virtual Type ResourceSetType {get;}

Field
protected string BaseNameField;
public readonly static int HeaderVersionNumber;
public readonly static int MagicNumber;
protected Assembly MainAssembly;
protected Hashtable ResourceSets;

System.Resources.SatelliteContractVersionAttribute

Module:mscorlib.dll

Hierarchy
Object
Attribute
SatelliteContractVersionAttribute

Type declaration

[C#] public sealed class SatelliteContractVersionAttribute : Attribute;

Constructor
public SatelliteContractVersionAttribute(string version);

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public object TypeId {get;}
public string Version {get;}

System.Resources.MissingManifestResourceException

Module:mscorlib.dll

Hierarchy
Object
Exception
SystemException
MissingManifestResourceException

Type declaration

[C#] public class MissingManifestResourceException : SystemException;

Constructor
public MissingManifestResourceException();
protected MissingManifestResourceException(SerializationInfo info, StreamingContext context);
public MissingManifestResourceException(string message);
public MissingManifestResourceException(string message, Exception innerException);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public virtual string Message {get;}
public string Source {get; set;}
public string StackTrace {get;}
public MethodBase TargetSite {get;}

System.Runtime.CompilerServices.DateTimeConstantAttribute

Module:mscorlib.dll

Hierarchy
Object
Attribute
CustomConstantAttribute
DateTimeConstantAttribute

Type declaration

[C#] public sealed class DateTimeConstantAttribute : CustomConstantAttribute;

Constructor
public DateTimeConstantAttribute(long ticks);

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public object TypeId {get;}
public override object Value {get;}

System.Runtime.CompilerServices.CustomConstantAttribute

Module:mscorlib.dll

Hierarchy
Object
Attribute
CustomConstantAttribute

Type declaration

[C#] public abstract class CustomConstantAttribute : Attribute;

Constructor
protected CustomConstantAttribute();

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public object TypeId {get;}
public abstract object Value {get;}

System.Runtime.CompilerServices.AccessedThroughPropertyAttribute

Module:mscorlib.dll

Hierarchy
Object
Attribute
AccessedThroughPropertyAttribute

Type declaration

[C#] public sealed class AccessedThroughPropertyAttribute : Attribute;

Constructor
public AccessedThroughPropertyAttribute(string propertyName);

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public string PropertyName {get;}
public object TypeId {get;}

System.Runtime.CompilerServices.DecimalConstantAttribute

Module:mscorlib.dll

Hierarchy
Object
Attribute
DecimalConstantAttribute

Type declaration

[C#] public sealed class DecimalConstantAttribute : Attribute;

Constructor
public DecimalConstantAttribute(byte scale, byte sign, uint hi, uint mid, uint low);

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public object TypeId {get;}
public decimal Value {get;}

System.Runtime.CompilerServices.MethodImplAttribute

Module:mscorlib.dll

Hierarchy
Object
Attribute
MethodImplAttribute

Type declaration

[C#] public sealed class MethodImplAttribute : Attribute;

Constructor
public MethodImplAttribute();
public MethodImplAttribute(short value);
public MethodImplAttribute(MethodImplOptions methodImplOptions);

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public object TypeId {get;}
public MethodImplOptions Value {get;}

Field
public MethodCodeType MethodCodeType;

System.Runtime.CompilerServices.MethodCodeType

Module:mscorlib.dll

Hierarchy
Object
ValueType
Enum
MethodCodeType

Type declaration

[C#] public enum MethodCodeType;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const MethodCodeType IL = 0;
public const MethodCodeType Native = 1;
public const MethodCodeType OPTIL = 2;
public const MethodCodeType Runtime = 3;
public int value__;

System.Runtime.CompilerServices.MethodImplOptions

Module:mscorlib.dll

Hierarchy
Object
ValueType
Enum
MethodImplOptions

Type declaration

[C#] public enum MethodImplOptions;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const MethodImplOptions ForwardRef = 16;
public const MethodImplOptions InternalCall = 4096;
public const MethodImplOptions NoInlining = 8;
public const MethodImplOptions PreserveSig = 128;
public const MethodImplOptions Synchronized = 32;
public const MethodImplOptions Unmanaged = 4;
public int value__;

System.Runtime.CompilerServices.IndexerNameAttribute

Module:mscorlib.dll

Hierarchy
Object
Attribute
IndexerNameAttribute

Type declaration

[C#] public sealed class IndexerNameAttribute : Attribute;

Constructor
public IndexerNameAttribute(string indexerName);

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public object TypeId {get;}

System.Runtime.CompilerServices.RuntimeHelpers

Module:mscorlib.dll

Hierarchy
Object
RuntimeHelpers

Type declaration

[C#] public sealed class RuntimeHelpers;

Method
public virtual bool Equals(object obj);
public static bool Equals(object o1, object o2);
protected override void Finalize();
public virtual int GetHashCode();
public static int GetHashCode(object o);
public static object GetObjectValue(object obj);
public Type GetType();
public static void InitializeArray(Array array, RuntimeFieldHandle fldHandle);
protected object MemberwiseClone();
public static void RunClassConstructor(RuntimeTypeHandle type);
public virtual string ToString();

Property
public static int OffsetToStringData {get;}

System.Threading.Monitor

Module:mscorlib.dll

Hierarchy
Object
Monitor

Type declaration

[C#] public sealed class Monitor;

Method
public static void Enter(object obj);
public virtual bool Equals(object obj);
public static void Exit(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public static void Pulse(object obj);
public static void PulseAll(object obj);
public virtual string ToString();
public static bool TryEnter(object obj);
public static bool TryEnter(object obj, int millisecondsTimeout);
public static bool TryEnter(object obj, TimeSpan timeout);
public static bool Wait(object obj);
public static bool Wait(object obj, int millisecondsTimeout);
public static bool Wait(object obj, int millisecondsTimeout, bool exitContext);
public static bool Wait(object obj, TimeSpan timeout);
public static bool Wait(object obj, TimeSpan timeout, bool exitContext);

System.Threading.Interlocked

Module:mscorlib.dll

Hierarchy
Object
Interlocked

Type declaration

[C#] public sealed class Interlocked;

Method
public static int CompareExchange(ref int location1, int value, int comparand);
public static object CompareExchange(ref object location1, object value, object comparand);
public static float CompareExchange(ref float location1, float value, float comparand);
public static int Decrement(ref int location);
public static long Decrement(ref long location);
public virtual bool Equals(object obj);
public static int Exchange(ref int location1, int value);
public static object Exchange(ref object location1, object value);
public static float Exchange(ref float location1, float value);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
public static int Increment(ref int location);
public static long Increment(ref long location);
protected object MemberwiseClone();
public virtual string ToString();

System.Threading.ManualResetEvent

Module:mscorlib.dll

Hierarchy
Object
MarshalByRefObject
WaitHandle
ManualResetEvent

Type declaration

[C#] public sealed class ManualResetEvent : WaitHandle;

Constructor
public ManualResetEvent(bool initialState);

Method
public override void Close();
public ObjRef CreateObjRef(Type requestedType);
protected virtual void Dispose(bool explicitDisposing);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public object GetLifetimeService();
public Type GetType();
public object InitializeLifetimeService();
protected object MemberwiseClone();
public bool Reset();
public bool Set();
public virtual string ToString();
public override bool WaitOne();
public bool WaitOne(int millisecondsTimeout, bool exitContext);
public bool WaitOne(TimeSpan timeout, bool exitContext);

Property
public virtual IntPtr Handle {get; set;}

System.Threading.AutoResetEvent

Module:mscorlib.dll

Hierarchy
Object
MarshalByRefObject
WaitHandle
AutoResetEvent

Type declaration

[C#] public sealed class AutoResetEvent : WaitHandle;

Constructor
public AutoResetEvent(bool initialState);

Method
public override void Close();
public ObjRef CreateObjRef(Type requestedType);
protected virtual void Dispose(bool explicitDisposing);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public object GetLifetimeService();
public Type GetType();
public object InitializeLifetimeService();
protected object MemberwiseClone();
public bool Reset();
public bool Set();
public virtual string ToString();
public override bool WaitOne();
public bool WaitOne(int millisecondsTimeout, bool exitContext);
public bool WaitOne(TimeSpan timeout, bool exitContext);

Property
public virtual IntPtr Handle {get; set;}

System.Threading.Mutex

Module:mscorlib.dll

Hierarchy
Object
MarshalByRefObject
WaitHandle
Mutex

Type declaration

[C#] public sealed class Mutex : WaitHandle;

Constructor
public Mutex();
public Mutex(bool initiallyOwned);
public Mutex(bool initiallyOwned, string name);
public Mutex(bool initiallyOwned, string name, ref bool createdNew);

Method
public override void Close();
public ObjRef CreateObjRef(Type requestedType);
protected virtual void Dispose(bool explicitDisposing);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public object GetLifetimeService();
public Type GetType();
public object InitializeLifetimeService();
protected object MemberwiseClone();
public void ReleaseMutex();
public virtual string ToString();
public override bool WaitOne();
public bool WaitOne(int millisecondsTimeout, bool exitContext);
public bool WaitOne(TimeSpan timeout, bool exitContext);

Property
public virtual IntPtr Handle {get; set;}

System.Threading.WaitHandle

Module:mscorlib.dll

Hierarchy
Object
MarshalByRefObject
WaitHandle

Type declaration

[C#] public abstract class WaitHandle : MarshalByRefObject;

Constructor
public WaitHandle();

Method
public virtual void Close();
public ObjRef CreateObjRef(Type requestedType);
protected virtual void Dispose(bool explicitDisposing);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public object GetLifetimeService();
public Type GetType();
public object InitializeLifetimeService();
protected object MemberwiseClone();
public virtual string ToString();
public static bool WaitAll(WaitHandle[] waitHandles);
public static bool WaitAll(WaitHandle[] waitHandles, int millisecondsTimeout, bool exitContext);
public static bool WaitAll(WaitHandle[] waitHandles, TimeSpan timeout, bool exitContext);
public static int WaitAny(WaitHandle[] waitHandles);
public static int WaitAny(WaitHandle[] waitHandles, int millisecondsTimeout, bool exitContext);
public static int WaitAny(WaitHandle[] waitHandles, TimeSpan timeout, bool exitContext);
public virtual bool WaitOne();
public virtual bool WaitOne(int millisecondsTimeout, bool exitContext);
public virtual bool WaitOne(TimeSpan timeout, bool exitContext);

Property
public virtual IntPtr Handle {get; set;}

Field
protected readonly static IntPtr InvalidHandle;
public const int WaitTimeout = 258;

System.Threading.ThreadStart

Module:mscorlib.dll

Hierarchy
Object
Delegate
MulticastDelegate
ThreadStart

Type declaration

[C#] public delegate void ThreadStart();

Constructor
public ThreadStart(object object, IntPtr method);

Method
public virtual IAsyncResult BeginInvoke(AsyncCallback callback, object object);
public object Clone();
protected override Delegate CombineImpl(Delegate follow);
public object DynamicInvoke(object[] args);
protected virtual object DynamicInvokeImpl(object[] args);
public virtual void EndInvoke(IAsyncResult result);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public override Delegate[] GetInvocationList();
protected virtual MethodInfo GetMethodImpl();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
public override void Invoke();
protected object MemberwiseClone();
protected override Delegate RemoveImpl(Delegate value);
public virtual string ToString();

Property
public MethodInfo Method {get;}
public object Target {get;}

System.Threading.Timer

Module:mscorlib.dll

Hierarchy
Object
MarshalByRefObject
Timer : IDisposable

Type declaration

[C#] public sealed class Timer : MarshalByRefObject, IDisposable;

Constructor
public Timer(TimerCallback callback, object state, int dueTime, int period);
public Timer(TimerCallback callback, object state, long dueTime, long period);
public Timer(TimerCallback callback, object state, TimeSpan dueTime, TimeSpan period);
public Timer(TimerCallback callback, object state, uint dueTime, uint period);

Method
public bool Change(int dueTime, int period);
public bool Change(long dueTime, long period);
public bool Change(TimeSpan dueTime, TimeSpan period);
public bool Change(uint dueTime, uint period);
public ObjRef CreateObjRef(Type requestedType);
public virtual void Dispose();
public bool Dispose(WaitHandle notifyObject);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public object GetLifetimeService();
public Type GetType();
public object InitializeLifetimeService();
protected object MemberwiseClone();
public virtual string ToString();

System.Threading.TimerCallback

Module:mscorlib.dll

Hierarchy
Object
Delegate
MulticastDelegate
TimerCallback

Type declaration

[C#] public delegate void TimerCallback(object state);

Constructor
public TimerCallback(object object, IntPtr method);

Method
public virtual IAsyncResult BeginInvoke(object state, AsyncCallback callback, object object);
public object Clone();
protected override Delegate CombineImpl(Delegate follow);
public object DynamicInvoke(object[] args);
protected virtual object DynamicInvokeImpl(object[] args);
public virtual void EndInvoke(IAsyncResult result);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public override Delegate[] GetInvocationList();
protected virtual MethodInfo GetMethodImpl();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
public override void Invoke(object state);
protected object MemberwiseClone();
protected override Delegate RemoveImpl(Delegate value);
public virtual string ToString();

Property
public MethodInfo Method {get;}
public object Target {get;}

System.Threading.Timeout

Module:mscorlib.dll

Hierarchy
Object
Timeout

Type declaration

[C#] public sealed class Timeout;

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Field
public const int Infinite = -1;

System.Threading.ThreadPool

Module:mscorlib.dll

Hierarchy
Object
ThreadPool

Type declaration

[C#] public sealed class ThreadPool;

Method
public static bool BindHandle(IntPtr osHandle);
public virtual bool Equals(object obj);
protected override void Finalize();
public static void GetAvailableThreads(ref int workerThreads, ref int completionPortThreads);
public virtual int GetHashCode();
public static void GetMaxThreads(ref int workerThreads, ref int completionPortThreads);
public Type GetType();
protected object MemberwiseClone();
public static bool QueueUserWorkItem(WaitCallback callBack);
public static bool QueueUserWorkItem(WaitCallback callBack, object state);
public static RegisteredWaitHandle RegisterWaitForSingleObject(WaitHandle waitObject, WaitOrTimerCallback callBack, object state, int millisecondsTimeOutInterval, bool executeOnlyOnce);
public static RegisteredWaitHandle RegisterWaitForSingleObject(WaitHandle waitObject, WaitOrTimerCallback callBack, object state, long millisecondsTimeOutInterval, bool executeOnlyOnce);
public static RegisteredWaitHandle RegisterWaitForSingleObject(WaitHandle waitObject, WaitOrTimerCallback callBack, object state, TimeSpan timeout, bool executeOnlyOnce);
public static RegisteredWaitHandle RegisterWaitForSingleObject(WaitHandle waitObject, WaitOrTimerCallback callBack, object state, uint millisecondsTimeOutInterval, bool executeOnlyOnce);
public virtual string ToString();
public static bool UnsafeQueueUserWorkItem(WaitCallback callBack, object state);
public static RegisteredWaitHandle UnsafeRegisterWaitForSingleObject(WaitHandle waitObject, WaitOrTimerCallback callBack, object state, int millisecondsTimeOutInterval, bool executeOnlyOnce);
public static RegisteredWaitHandle UnsafeRegisterWaitForSingleObject(WaitHandle waitObject, WaitOrTimerCallback callBack, object state, long millisecondsTimeOutInterval, bool executeOnlyOnce);
public static RegisteredWaitHandle UnsafeRegisterWaitForSingleObject(WaitHandle waitObject, WaitOrTimerCallback callBack, object state, TimeSpan timeout, bool executeOnlyOnce);
public static RegisteredWaitHandle UnsafeRegisterWaitForSingleObject(WaitHandle waitObject, WaitOrTimerCallback callBack, object state, uint millisecondsTimeOutInterval, bool executeOnlyOnce);

System.Threading.WaitCallback

Module:mscorlib.dll

Hierarchy
Object
Delegate
MulticastDelegate
WaitCallback

Type declaration

[C#] public delegate void WaitCallback(object state);

Constructor
public WaitCallback(object object, IntPtr method);

Method
public virtual IAsyncResult BeginInvoke(object state, AsyncCallback callback, object object);
public object Clone();
protected override Delegate CombineImpl(Delegate follow);
public object DynamicInvoke(object[] args);
protected virtual object DynamicInvokeImpl(object[] args);
public virtual void EndInvoke(IAsyncResult result);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public override Delegate[] GetInvocationList();
protected virtual MethodInfo GetMethodImpl();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
public override void Invoke(object state);
protected object MemberwiseClone();
protected override Delegate RemoveImpl(Delegate value);
public virtual string ToString();

Property
public MethodInfo Method {get;}
public object Target {get;}

System.Threading.ThreadPriority

Module:mscorlib.dll

Hierarchy
Object
ValueType
Enum
ThreadPriority

Type declaration

[C#] public enum ThreadPriority;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const ThreadPriority AboveNormal = 3;
public const ThreadPriority BelowNormal = 1;
public const ThreadPriority Highest = 4;
public const ThreadPriority Lowest = 0;
public const ThreadPriority Normal = 2;
public int value__;

System.Threading.Thread

Module:mscorlib.dll

Hierarchy
Object
Thread

Type declaration

[C#] public sealed class Thread;

Constructor
public Thread(ThreadStart start);

Method
public void Abort();
public void Abort(object stateInfo);
public static LocalDataStoreSlot AllocateDataSlot();
public static LocalDataStoreSlot AllocateNamedDataSlot(string name);
public virtual bool Equals(object obj);
protected override void Finalize();
public static void FreeNamedDataSlot(string name);
public static object GetData(LocalDataStoreSlot slot);
public static AppDomain GetDomain();
public static int GetDomainID();
public virtual int GetHashCode();
public static LocalDataStoreSlot GetNamedDataSlot(string name);
public Type GetType();
public void Interrupt();
public void Join();
public bool Join(int millisecondsTimeout);
public bool Join(TimeSpan timeout);
protected object MemberwiseClone();
public static void MemoryBarrier();
public static void ResetAbort();
public void Resume();
public static void SetData(LocalDataStoreSlot slot, object data);
public static void Sleep(int millisecondsTimeout);
public static void Sleep(TimeSpan timeout);
public static void SpinWait(int iterations);
public void Start();
public void Suspend();
public virtual string ToString();
public static byte VolatileRead(ref byte address);
public static double VolatileRead(ref double address);
public static short VolatileRead(ref short address);
public static int VolatileRead(ref int address);
public static long VolatileRead(ref long address);
public static IntPtr VolatileRead(ref IntPtr address);
public static object VolatileRead(ref object address);
public static SByte VolatileRead(ref SByte address);
public static float VolatileRead(ref float address);
public static ushort VolatileRead(ref ushort address);
public static uint VolatileRead(ref uint address);
public static ulong VolatileRead(ref ulong address);
public static UIntPtr VolatileRead(ref UIntPtr address);
public static void VolatileWrite(ref byte address, byte value);
public static void VolatileWrite(ref double address, double value);
public static void VolatileWrite(ref short address, short value);
public static void VolatileWrite(ref int address, int value);
public static void VolatileWrite(ref long address, long value);
public static void VolatileWrite(ref IntPtr address, IntPtr value);
public static void VolatileWrite(ref object address, object value);
public static void VolatileWrite(ref SByte address, SByte value);
public static void VolatileWrite(ref float address, float value);
public static void VolatileWrite(ref ushort address, ushort value);
public static void VolatileWrite(ref uint address, uint value);
public static void VolatileWrite(ref ulong address, ulong value);
public static void VolatileWrite(ref UIntPtr address, UIntPtr value);

Property
public ApartmentState ApartmentState {get; set;}
public static Context CurrentContext {get;}
public CultureInfo CurrentCulture {get; set;}
public static IPrincipal CurrentPrincipal {get; set;}
public static Thread CurrentThread {get;}
public CultureInfo CurrentUICulture {get; set;}
public bool IsAlive {get;}
public bool IsBackground {get; set;}
public bool IsThreadPoolThread {get;}
public string Name {get; set;}
public ThreadPriority Priority {get; set;}
public ThreadState ThreadState {get;}

System.Threading.ThreadStateException

Module:mscorlib.dll

Hierarchy
Object
Exception
SystemException
ThreadStateException

Type declaration

[C#] public class ThreadStateException : SystemException;

Constructor
public ThreadStateException();
protected ThreadStateException(SerializationInfo info, StreamingContext context);
public ThreadStateException(string message);
public ThreadStateException(string message, Exception innerException);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public virtual string Message {get;}
public string Source {get; set;}
public string StackTrace {get;}
public MethodBase TargetSite {get;}

System.Runtime.InteropServices.Marshal

Module:mscorlib.dll

Hierarchy
Object
Marshal

Type declaration

[C#] public sealed class Marshal;

Method
public static int AddRef(IntPtr pUnk);
public static IntPtr AllocCoTaskMem(int cb);
public static IntPtr AllocHGlobal(int cb);
public static IntPtr AllocHGlobal(IntPtr cb);
public static object BindToMoniker(string monikerName);
public static void ChangeWrapperHandleStrength(object otp, bool fIsWeak);
public static void Copy(byte[] source, int startIndex, IntPtr destination, int length);
public static void Copy(char[] source, int startIndex, IntPtr destination, int length);
public static void Copy(double[] source, int startIndex, IntPtr destination, int length);
public static void Copy(short[] source, int startIndex, IntPtr destination, int length);
public static void Copy(int[] source, int startIndex, IntPtr destination, int length);
public static void Copy(long[] source, int startIndex, IntPtr destination, int length);
public static void Copy(IntPtr source, byte[] destination, int startIndex, int length);
public static void Copy(IntPtr source, char[] destination, int startIndex, int length);
public static void Copy(IntPtr source, double[] destination, int startIndex, int length);
public static void Copy(IntPtr source, short[] destination, int startIndex, int length);
public static void Copy(IntPtr source, int[] destination, int startIndex, int length);
public static void Copy(IntPtr source, long[] destination, int startIndex, int length);
public static void Copy(IntPtr source, float[] destination, int startIndex, int length);
public static void Copy(float[] source, int startIndex, IntPtr destination, int length);
public static object CreateWrapperOfType(object o, Type t);
public static void DestroyStructure(IntPtr ptr, Type structuretype);
public virtual bool Equals(object obj);
protected override void Finalize();
public static void FreeBSTR(IntPtr ptr);
public static void FreeCoTaskMem(IntPtr ptr);
public static void FreeHGlobal(IntPtr hglobal);
public static Guid GenerateGuidForType(Type type);
public static string GenerateProgIdForType(Type type);
public static object GetActiveObject(string progID);
public static IntPtr GetComInterfaceForObject(object o, Type T);
public static object GetComObjectData(object obj, object key);
public static int GetComSlotForMethodInfo(MemberInfo m);
public static int GetEndComSlot(Type t);
public static int GetExceptionCode();
public static IntPtr GetExceptionPointers();
public virtual int GetHashCode();
public static IntPtr GetHINSTANCE(Module m);
public static int GetHRForException(Exception e);
public static int GetHRForLastWin32Error();
public static IntPtr GetIDispatchForObject(object o);
public static IntPtr GetITypeInfoForType(Type t);
public static IntPtr GetIUnknownForObject(object o);
public static int GetLastWin32Error();
public static IntPtr GetManagedThunkForUnmanagedMethodPtr(IntPtr pfnMethodToWrap, IntPtr pbSignature, int cbSignature);
public static MemberInfo GetMethodInfoForComSlot(Type t, int slot, ref ComMemberType memberType);
public static void GetNativeVariantForObject(object obj, IntPtr pDstNativeVariant);
public static object GetObjectForIUnknown(IntPtr pUnk);
public static object GetObjectForNativeVariant(IntPtr pSrcNativeVariant);
public static object[] GetObjectsForNativeVariants(IntPtr aSrcNativeVariant, int cVars);
public static int GetStartComSlot(Type t);
public static Thread GetThreadFromFiberCookie(int cookie);
public Type GetType();
public static object GetTypedObjectForIUnknown(IntPtr pUnk, Type t);
public static Type GetTypeForITypeInfo(IntPtr piTypeInfo);
public static string GetTypeInfoName(UCOMITypeInfo pTI);
public static Guid GetTypeLibGuid(UCOMITypeLib pTLB);
public static Guid GetTypeLibGuidForAssembly(Assembly asm);
public static int GetTypeLibLcid(UCOMITypeLib pTLB);
public static string GetTypeLibName(UCOMITypeLib pTLB);
public static IntPtr GetUnmanagedThunkForManagedMethodPtr(IntPtr pfnMethodToWrap, IntPtr pbSignature, int cbSignature);
public static bool IsComObject(object o);
public static bool IsTypeVisibleFromCom(Type t);
protected object MemberwiseClone();
public static int NumParamBytes(MethodInfo m);
public static IntPtr OffsetOf(Type t, string fieldName);
public static void Prelink(MethodInfo m);
public static void PrelinkAll(Type c);
public static string PtrToStringAnsi(IntPtr ptr);
public static string PtrToStringAnsi(IntPtr ptr, int len);
public static string PtrToStringAuto(IntPtr ptr);
public static string PtrToStringAuto(IntPtr ptr, int len);
public static string PtrToStringBSTR(IntPtr ptr);
public static string PtrToStringUni(IntPtr ptr);
public static string PtrToStringUni(IntPtr ptr, int len);
public static void PtrToStructure(IntPtr ptr, object obj);
public static object PtrToStructure(IntPtr ptr, Type structuretype);
public static int QueryInterface(IntPtr pUnk, ref Guid iid, ref IntPtr ppv);
public static byte ReadByte(IntPtr ptr);
public static byte ReadByte(IntPtr ptr, int ofs);
public static byte ReadByte(object ptr, int ofs);
public static short ReadInt16(IntPtr ptr);
public static short ReadInt16(IntPtr ptr, int ofs);
public static short ReadInt16(object ptr, int ofs);
public static int ReadInt32(IntPtr ptr);
public static int ReadInt32(IntPtr ptr, int ofs);
public static int ReadInt32(object ptr, int ofs);
public static long ReadInt64(IntPtr ptr);
public static long ReadInt64(IntPtr ptr, int ofs);
public static long ReadInt64(object ptr, int ofs);
public static IntPtr ReadIntPtr(IntPtr ptr);
public static IntPtr ReadIntPtr(IntPtr ptr, int ofs);
public static IntPtr ReadIntPtr(object ptr, int ofs);
public static IntPtr ReAllocCoTaskMem(IntPtr pv, int cb);
public static IntPtr ReAllocHGlobal(IntPtr pv, IntPtr cb);
public static int Release(IntPtr pUnk);
public static int ReleaseComObject(object o);
public static void ReleaseThreadCache();
public static bool SetComObjectData(object obj, object key, object data);
public static int SizeOf(object structure);
public static int SizeOf(Type t);
public static IntPtr StringToBSTR(string s);
public static IntPtr StringToCoTaskMemAnsi(string s);
public static IntPtr StringToCoTaskMemAuto(string s);
public static IntPtr StringToCoTaskMemUni(string s);
public static IntPtr StringToHGlobalAnsi(string s);
public static IntPtr StringToHGlobalAuto(string s);
public static IntPtr StringToHGlobalUni(string s);
public static void StructureToPtr(object structure, IntPtr ptr, bool fDeleteOld);
public static void ThrowExceptionForHR(int errorCode);
public static void ThrowExceptionForHR(int errorCode, IntPtr errorInfo);
public virtual string ToString();
public static IntPtr UnsafeAddrOfPinnedArrayElement(Array arr, int index);
public static void WriteByte(IntPtr ptr, byte val);
public static void WriteByte(IntPtr ptr, int ofs, byte val);
public static void WriteByte(object ptr, int ofs, byte val);
public static void WriteInt16(IntPtr ptr, char val);
public static void WriteInt16(IntPtr ptr, short val);
public static void WriteInt16(IntPtr ptr, int ofs, char val);
public static void WriteInt16(IntPtr ptr, int ofs, short val);
public static void WriteInt16(object ptr, int ofs, char val);
public static void WriteInt16(object ptr, int ofs, short val);
public static void WriteInt32(IntPtr ptr, int val);
public static void WriteInt32(IntPtr ptr, int ofs, int val);
public static void WriteInt32(object ptr, int ofs, int val);
public static void WriteInt64(IntPtr ptr, int ofs, long val);
public static void WriteInt64(IntPtr ptr, long val);
public static void WriteInt64(object ptr, int ofs, long val);
public static void WriteIntPtr(IntPtr ptr, int ofs, IntPtr val);
public static void WriteIntPtr(IntPtr ptr, IntPtr val);
public static void WriteIntPtr(object ptr, int ofs, IntPtr val);

Field
public readonly static int SystemDefaultCharSize;
public readonly static int SystemMaxDBCSCharSize;

System.Runtime.InteropServices.ComVisibleAttribute

Module:mscorlib.dll

Hierarchy
Object
Attribute
ComVisibleAttribute

Type declaration

[C#] public sealed class ComVisibleAttribute : Attribute;

Constructor
public ComVisibleAttribute(bool visibility);

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public object TypeId {get;}
public bool Value {get;}

System.Runtime.InteropServices.LayoutKind

Module:mscorlib.dll

Hierarchy
Object
ValueType
Enum
LayoutKind

Type declaration

[C#] public enum LayoutKind;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const LayoutKind Auto = 3;
public const LayoutKind Explicit = 2;
public const LayoutKind Sequential = 0;
public int value__;

System.Runtime.InteropServices.CallingConvention

Module:mscorlib.dll

Hierarchy
Object
ValueType
Enum
CallingConvention

Type declaration

[C#] public enum CallingConvention;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const CallingConvention Cdecl = 2;
public const CallingConvention FastCall = 5;
public const CallingConvention StdCall = 3;
public const CallingConvention ThisCall = 4;
public int value__;
public const CallingConvention Winapi = 1;

System.Runtime.InteropServices.CharSet

Module:mscorlib.dll

Hierarchy
Object
ValueType
Enum
CharSet

Type declaration

[C#] public enum CharSet;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const CharSet Ansi = 2;
public const CharSet Auto = 4;
public const CharSet None = 1;
public const CharSet Unicode = 3;
public int value__;

System.Runtime.InteropServices.StructLayoutAttribute

Module:mscorlib.dll

Hierarchy
Object
Attribute
StructLayoutAttribute

Type declaration

[C#] public sealed class StructLayoutAttribute : Attribute;

Constructor
public StructLayoutAttribute(short layoutKind);
public StructLayoutAttribute(LayoutKind layoutKind);

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public object TypeId {get;}
public LayoutKind Value {get;}

Field
public CharSet CharSet;
public int Pack;
public int Size;

System.Runtime.InteropServices.DllImportAttribute

Module:mscorlib.dll

Hierarchy
Object
Attribute
DllImportAttribute

Type declaration

[C#] public sealed class DllImportAttribute : Attribute;

Constructor
public DllImportAttribute(string dllName);

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public object TypeId {get;}
public string Value {get;}

Field
public bool BestFitMapping;
public CallingConvention CallingConvention;
public CharSet CharSet;
public string EntryPoint;
public bool ExactSpelling;
public bool PreserveSig;
public bool SetLastError;
public bool ThrowOnUnmappableChar;

System.Runtime.InteropServices.OutAttribute

Module:mscorlib.dll

Hierarchy
Object
Attribute
OutAttribute

Type declaration

[C#] public sealed class OutAttribute : Attribute;

Constructor
public OutAttribute();

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public object TypeId {get;}

System.Runtime.InteropServices.InAttribute

Module:mscorlib.dll

Hierarchy
Object
Attribute
InAttribute

Type declaration

[C#] public sealed class InAttribute : Attribute;

Constructor
public InAttribute();

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public object TypeId {get;}

System.Runtime.InteropServices.GuidAttribute

Module:mscorlib.dll

Hierarchy
Object
Attribute
GuidAttribute

Type declaration

[C#] public sealed class GuidAttribute : Attribute;

Constructor
public GuidAttribute(string val);

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public object TypeId {get;}
public string Value {get;}

System.Runtime.InteropServices.UnmanagedType

Module:mscorlib.dll

Hierarchy
Object
ValueType
Enum
UnmanagedType

Type declaration

[C#] public enum UnmanagedType;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const UnmanagedType AnsiBStr = 35;
public const UnmanagedType AsAny = 40;
public const UnmanagedType Bool = 2;
public const UnmanagedType BStr = 19;
public const UnmanagedType ByValArray = 30;
public const UnmanagedType ByValTStr = 23;
public const UnmanagedType Currency = 15;
public const UnmanagedType CustomMarshaler = 44;
public const UnmanagedType Error = 45;
public const UnmanagedType FunctionPtr = 38;
public const UnmanagedType I1 = 3;
public const UnmanagedType I2 = 5;
public const UnmanagedType I4 = 7;
public const UnmanagedType I8 = 9;
public const UnmanagedType IDispatch = 26;
public const UnmanagedType Interface = 28;
public const UnmanagedType IUnknown = 25;
public const UnmanagedType LPArray = 42;
public const UnmanagedType LPStr = 20;
public const UnmanagedType LPStruct = 43;
public const UnmanagedType LPTStr = 22;
public const UnmanagedType LPWStr = 21;
public const UnmanagedType R4 = 11;
public const UnmanagedType R8 = 12;
public const UnmanagedType SafeArray = 29;
public const UnmanagedType Struct = 27;
public const UnmanagedType SysInt = 31;
public const UnmanagedType SysUInt = 32;
public const UnmanagedType TBStr = 36;
public const UnmanagedType U1 = 4;
public const UnmanagedType U2 = 6;
public const UnmanagedType U4 = 8;
public const UnmanagedType U8 = 10;
public int value__;
public const UnmanagedType VariantBool = 37;
public const UnmanagedType VBByRefStr = 34;

System.Runtime.InteropServices.DispIdAttribute

Module:mscorlib.dll

Hierarchy
Object
Attribute
DispIdAttribute

Type declaration

[C#] public sealed class DispIdAttribute : Attribute;

Constructor
public DispIdAttribute(int dispId);

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public object TypeId {get;}
public int Value {get;}

System.Runtime.InteropServices.GCHandle

Module:mscorlib.dll

Hierarchy
Object
ValueType
GCHandle

Type declaration

[C#] public struct GCHandle : ValueType;

Method
public IntPtr AddrOfPinnedObject();
public static GCHandle Alloc(object value);
public static GCHandle Alloc(object value, GCHandleType type);
public override bool Equals(object obj);
protected override void Finalize();
public void Free();
public override int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public static IntPtr op_Explicit(GCHandle value);
public static GCHandle op_Explicit(IntPtr value);
public virtual string ToString();

Property
public bool IsAllocated {get;}
public object Target {get; set;}

System.Runtime.InteropServices.GCHandleType

Module:mscorlib.dll

Hierarchy
Object
ValueType
Enum
GCHandleType

Type declaration

[C#] public enum GCHandleType;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const GCHandleType Normal = 2;
public const GCHandleType Pinned = 3;
public int value__;
public const GCHandleType Weak = 0;
public const GCHandleType WeakTrackResurrection = 1;

System.Runtime.InteropServices.ExternalException

Module:mscorlib.dll

Hierarchy
Object
Exception
SystemException
ExternalException

Type declaration

[C#] public class ExternalException : SystemException;

Constructor
public ExternalException();
protected ExternalException(SerializationInfo info, StreamingContext context);
public ExternalException(string message);
public ExternalException(string message, Exception innerException);
public ExternalException(string message, int errorCode);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public virtual int ErrorCode {get;}
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public virtual string Message {get;}
public string Source {get; set;}
public string StackTrace {get;}
public MethodBase TargetSite {get;}

System.Reflection.ParameterInfo

Module:mscorlib.dll

Hierarchy
Object
ParameterInfo : ICustomAttributeProvider

Type declaration

[C#] public class ParameterInfo: ICustomAttributeProvider;

Constructor
protected ParameterInfo();

Method
public override bool Equals(object obj);
protected override void Finalize();
public virtual object[] GetCustomAttributes(bool inherit);
public virtual object[] GetCustomAttributes(Type attributeType, bool inherit);
public override int GetHashCode();
public Type GetType();
public virtual bool IsDefined(Type attributeType, bool inherit);
protected object MemberwiseClone();
public virtual string ToString();

Property
public virtual ParameterAttributes Attributes {get;}
public virtual object DefaultValue {get;}
public bool IsIn {get;}
public bool IsLcid {get;}
public bool IsOptional {get;}
public bool IsOut {get;}
public bool IsRetval {get;}
public virtual MemberInfo Member {get;}
public virtual string Name {get;}
public virtual Type ParameterType {get;}
public virtual int Position {get;}

Field
protected ParameterAttributes AttrsImpl;
protected Type ClassImpl;
protected object DefaultValueImpl;
protected MemberInfo MemberImpl;
protected string NameImpl;
protected int PositionImpl;

System.Reflection.Assembly

Module:mscorlib.dll

Hierarchy
Object
Assembly

Type declaration

[C#] public class Assembly;

Method
public void add_ModuleResolve(ModuleResolveEventHandler value);
public object CreateInstance(string name);
public object CreateInstance(string typeName, bool ignoreCase);
public object CreateInstance(string typeName, bool ignoreCase, BindingFlags bindingAttr, Binder binder, object[] args, CultureInfo culture, object[] activationAttributes);
public static string CreateQualifiedName(string assemblyName, string typeName);
public virtual bool Equals(object obj);
protected override void Finalize();
public static Assembly GetAssembly(Type type);
public static Assembly GetCallingAssembly();
public virtual object[] GetCustomAttributes(bool inherit);
public virtual object[] GetCustomAttributes(Type attributeType, bool inherit);
public static Assembly GetEntryAssembly();
public static Assembly GetExecutingAssembly();
public virtual Type[] GetExportedTypes();
public virtual FileStream GetFile(string name);
public virtual FileStream[] GetFiles();
public virtual FileStream[] GetFiles(bool getResourceModules);
public virtual int GetHashCode();
public Module[] GetLoadedModules();
public Module[] GetLoadedModules(bool getResourceModules);
public virtual ManifestResourceInfo GetManifestResourceInfo(string resourceName);
public string[] GetManifestResourceNames();
public virtual Stream GetManifestResourceStream(string name);
public virtual Stream GetManifestResourceStream(Type type, string name);
public Module GetModule(string name);
public Module[] GetModules();
public Module[] GetModules(bool getResourceModules);
public virtual AssemblyName GetName();
public virtual AssemblyName GetName(bool copiedName);
public virtual void GetObjectData(SerializationInfo info, StreamingContext context);
public AssemblyName[] GetReferencedAssemblies();
public Assembly GetSatelliteAssembly(CultureInfo culture);
public Assembly GetSatelliteAssembly(CultureInfo culture, Version version);
public Type GetType();
public virtual Type GetType(string name);
public virtual Type GetType(string name, bool throwOnError);
public Type GetType(string name, bool throwOnError, bool ignoreCase);
public virtual Type[] GetTypes();
public virtual bool IsDefined(Type attributeType, bool inherit);
public static Assembly Load(AssemblyName assemblyRef);
public static Assembly Load(AssemblyName assemblyRef, Evidence assemblySecurity);
public static Assembly Load(byte[] rawAssembly);
public static Assembly Load(byte[] rawAssembly, byte[] rawSymbolStore);
public static Assembly Load(byte[] rawAssembly, byte[] rawSymbolStore, Evidence securityEvidence);
public static Assembly Load(string assemblyString);
public static Assembly Load(string assemblyString, Evidence assemblySecurity);
public static Assembly LoadFile(string path);
public static Assembly LoadFile(string path, Evidence securityEvidence);
public static Assembly LoadFrom(string assemblyFile);
public static Assembly LoadFrom(string assemblyFile, Evidence securityEvidence);
public static Assembly LoadFrom(string assemblyFile, Evidence securityEvidence, byte[] hashValue, AssemblyHashAlgorithm hashAlgorithm);
public Module LoadModule(string moduleName, byte[] rawModule);
public Module LoadModule(string moduleName, byte[] rawModule, byte[] rawSymbolStore);
public static Assembly LoadWithPartialName(string partialName);
public static Assembly LoadWithPartialName(string partialName, Evidence securityEvidence);
protected object MemberwiseClone();
public void remove_ModuleResolve(ModuleResolveEventHandler value);
public override string ToString();

Property
public virtual string CodeBase {get;}
public virtual MethodInfo EntryPoint {get;}
public virtual string EscapedCodeBase {get;}
public virtual Evidence Evidence {get;}
public virtual string FullName {get;}
public bool GlobalAssemblyCache {get;}
public virtual string ImageRuntimeVersion {get;}
public virtual string Location {get;}

System.Reflection.Module

Module:mscorlib.dll

Hierarchy
Object
Module

Type declaration

[C#] public class Module;

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Type[] FindTypes(TypeFilter filter, object filterCriteria);
public virtual object[] GetCustomAttributes(bool inherit);
public virtual object[] GetCustomAttributes(Type attributeType, bool inherit);
public FieldInfo GetField(string name);
public FieldInfo GetField(string name, BindingFlags bindingAttr);
public FieldInfo[] GetFields();
public virtual int GetHashCode();
public MethodInfo GetMethod(string name);
public MethodInfo GetMethod(string name, BindingFlags bindingAttr, Binder binder, CallingConventions callConvention, Type[] types, ParameterModifier[] modifiers);
public MethodInfo GetMethod(string name, Type[] types);
protected virtual MethodInfo GetMethodImpl(string name, BindingFlags bindingAttr, Binder binder, CallingConventions callConvention, Type[] types, ParameterModifier[] modifiers);
public MethodInfo[] GetMethods();
public virtual void GetObjectData(SerializationInfo info, StreamingContext context);
public X509Certificate GetSignerCertificate();
public Type GetType();
public Type GetType(string className);
public virtual Type GetType(string className, bool ignoreCase);
public virtual Type GetType(string className, bool throwOnError, bool ignoreCase);
public Type[] GetTypes();
public virtual bool IsDefined(Type attributeType, bool inherit);
public bool IsResource();
protected object MemberwiseClone();
public override string ToString();

Property
public Assembly Assembly {get;}
public string FullyQualifiedName {get;}
public string Name {get;}
public string ScopeName {get;}

Field
public readonly static TypeFilter FilterTypeName;
public readonly static TypeFilter FilterTypeNameIgnoreCase;

System.Reflection.AssemblyInformationalVersionAttribute

Module:mscorlib.dll

Hierarchy
Object
Attribute
AssemblyInformationalVersionAttribute

Type declaration

[C#] public sealed class AssemblyInformationalVersionAttribute : Attribute;

Constructor
public AssemblyInformationalVersionAttribute(string informationalVersion);

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public string InformationalVersion {get;}
public object TypeId {get;}

System.Reflection.AssemblyDefaultAliasAttribute

Module:mscorlib.dll

Hierarchy
Object
Attribute
AssemblyDefaultAliasAttribute

Type declaration

[C#] public sealed class AssemblyDefaultAliasAttribute : Attribute;

Constructor
public AssemblyDefaultAliasAttribute(string defaultAlias);

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public string DefaultAlias {get;}
public object TypeId {get;}

System.Reflection.AssemblyConfigurationAttribute

Module:mscorlib.dll

Hierarchy
Object
Attribute
AssemblyConfigurationAttribute

Type declaration

[C#] public sealed class AssemblyConfigurationAttribute : Attribute;

Constructor
public AssemblyConfigurationAttribute(string configuration);

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public string Configuration {get;}
public object TypeId {get;}

System.Reflection.AssemblyTitleAttribute

Module:mscorlib.dll

Hierarchy
Object
Attribute
AssemblyTitleAttribute

Type declaration

[C#] public sealed class AssemblyTitleAttribute : Attribute;

Constructor
public AssemblyTitleAttribute(string title);

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public string Title {get;}
public object TypeId {get;}

System.Reflection.AssemblyDescriptionAttribute

Module:mscorlib.dll

Hierarchy
Object
Attribute
AssemblyDescriptionAttribute

Type declaration

[C#] public sealed class AssemblyDescriptionAttribute : Attribute;

Constructor
public AssemblyDescriptionAttribute(string description);

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public string Description {get;}
public object TypeId {get;}

System.Reflection.AssemblyCompanyAttribute

Module:mscorlib.dll

Hierarchy
Object
Attribute
AssemblyCompanyAttribute

Type declaration

[C#] public sealed class AssemblyCompanyAttribute : Attribute;

Constructor
public AssemblyCompanyAttribute(string company);

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public string Company {get;}
public object TypeId {get;}

System.Reflection.AssemblyProductAttribute

Module:mscorlib.dll

Hierarchy
Object
Attribute
AssemblyProductAttribute

Type declaration

[C#] public sealed class AssemblyProductAttribute : Attribute;

Constructor
public AssemblyProductAttribute(string product);

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public string Product {get;}
public object TypeId {get;}

System.Reflection.AssemblyTrademarkAttribute

Module:mscorlib.dll

Hierarchy
Object
Attribute
AssemblyTrademarkAttribute

Type declaration

[C#] public sealed class AssemblyTrademarkAttribute : Attribute;

Constructor
public AssemblyTrademarkAttribute(string trademark);

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public string Trademark {get;}
public object TypeId {get;}

System.Reflection.AssemblyCopyrightAttribute

Module:mscorlib.dll

Hierarchy
Object
Attribute
AssemblyCopyrightAttribute

Type declaration

[C#] public sealed class AssemblyCopyrightAttribute : Attribute;

Constructor
public AssemblyCopyrightAttribute(string copyright);

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public string Copyright {get;}
public object TypeId {get;}

System.Reflection.ParameterModifier

Module:mscorlib.dll

Hierarchy
Object
ValueType
ParameterModifier

Type declaration

[C#] public struct ParameterModifier : ValueType;

Constructor
public ParameterModifier(int paramaterCount);

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public bool this[int index] {get; set;}

System.Reflection.ParameterAttributes

Module:mscorlib.dll

Hierarchy
Object
ValueType
Enum
ParameterAttributes

Type declaration

[C#] public enum ParameterAttributes;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const ParameterAttributes HasDefault = 4096;
public const ParameterAttributes HasFieldMarshal = 8192;
public const ParameterAttributes In = 1;
public const ParameterAttributes Lcid = 4;
public const ParameterAttributes None = 0;
public const ParameterAttributes Optional = 16;
public const ParameterAttributes Out = 2;
public const ParameterAttributes Reserved3 = 16384;
public const ParameterAttributes Reserved4 = 32768;
public const ParameterAttributes ReservedMask = 61440;
public const ParameterAttributes Retval = 8;
public int value__;

System.Reflection.PropertyAttributes

Module:mscorlib.dll

Hierarchy
Object
ValueType
Enum
PropertyAttributes

Type declaration

[C#] public enum PropertyAttributes;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const PropertyAttributes HasDefault = 4096;
public const PropertyAttributes None = 0;
public const PropertyAttributes Reserved2 = 8192;
public const PropertyAttributes Reserved3 = 16384;
public const PropertyAttributes Reserved4 = 32768;
public const PropertyAttributes ReservedMask = 62464;
public const PropertyAttributes RTSpecialName = 1024;
public const PropertyAttributes SpecialName = 512;
public int value__;

System.Reflection.PropertyInfo

Module:mscorlib.dll

Hierarchy
Object
MemberInfo
PropertyInfo

Type declaration

[C#] public abstract class PropertyInfo : MemberInfo;

Constructor
protected PropertyInfo();

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public MethodInfo[] GetAccessors();
public abstract MethodInfo[] GetAccessors(bool nonPublic);
public abstract object[] GetCustomAttributes(bool inherit);
public abstract object[] GetCustomAttributes(Type attributeType, bool inherit);
public MethodInfo GetGetMethod();
public abstract MethodInfo GetGetMethod(bool nonPublic);
public virtual int GetHashCode();
public abstract ParameterInfo[] GetIndexParameters();
public MethodInfo GetSetMethod();
public abstract MethodInfo GetSetMethod(bool nonPublic);
public Type GetType();
public abstract object GetValue(object obj, BindingFlags invokeAttr, Binder binder, object[] index, CultureInfo culture);
public virtual object GetValue(object obj, object[] index);
public abstract bool IsDefined(Type attributeType, bool inherit);
protected object MemberwiseClone();
public abstract void SetValue(object obj, object value, BindingFlags invokeAttr, Binder binder, object[] index, CultureInfo culture);
public virtual void SetValue(object obj, object value, object[] index);
public virtual string ToString();

Property
public abstract PropertyAttributes Attributes {get;}
public abstract bool CanRead {get;}
public abstract bool CanWrite {get;}
public abstract Type DeclaringType {get;}
public bool IsSpecialName {get;}
public override MemberTypes MemberType {get;}
public abstract string Name {get;}
public abstract Type PropertyType {get;}
public abstract Type ReflectedType {get;}

System.Reflection.ConstructorInfo

Module:mscorlib.dll

Hierarchy
Object
MemberInfo
MethodBase
ConstructorInfo

Type declaration

[C#] public abstract class ConstructorInfo : MethodBase;

Constructor
protected ConstructorInfo();

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public abstract object[] GetCustomAttributes(bool inherit);
public abstract object[] GetCustomAttributes(Type attributeType, bool inherit);
public virtual int GetHashCode();
public abstract MethodImplAttributes GetMethodImplementationFlags();
public abstract ParameterInfo[] GetParameters();
public Type GetType();
public abstract object Invoke(BindingFlags invokeAttr, Binder binder, object[] parameters, CultureInfo culture);
public abstract object Invoke(object obj, BindingFlags invokeAttr, Binder binder, object[] parameters, CultureInfo culture);
public object Invoke(object obj, object[] parameters);
public object Invoke(object[] parameters);
public abstract bool IsDefined(Type attributeType, bool inherit);
protected object MemberwiseClone();
public virtual string ToString();

Property
public abstract MethodAttributes Attributes {get;}
public virtual CallingConventions CallingConvention {get;}
public abstract Type DeclaringType {get;}
public bool IsAbstract {get;}
public bool IsAssembly {get;}
public bool IsConstructor {get;}
public bool IsFamily {get;}
public bool IsFamilyAndAssembly {get;}
public bool IsFamilyOrAssembly {get;}
public bool IsFinal {get;}
public bool IsHideBySig {get;}
public bool IsPrivate {get;}
public bool IsPublic {get;}
public bool IsSpecialName {get;}
public bool IsStatic {get;}
public bool IsVirtual {get;}
public override MemberTypes MemberType {get;}
public abstract RuntimeMethodHandle MethodHandle {get;}
public abstract string Name {get;}
public abstract Type ReflectedType {get;}

Field
public readonly static string ConstructorName;
public readonly static string TypeConstructorName;

System.Reflection.MethodInfo

Module:mscorlib.dll

Hierarchy
Object
MemberInfo
MethodBase
MethodInfo

Type declaration

[C#] public abstract class MethodInfo : MethodBase;

Constructor
protected MethodInfo();

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public abstract MethodInfo GetBaseDefinition();
public abstract object[] GetCustomAttributes(bool inherit);
public abstract object[] GetCustomAttributes(Type attributeType, bool inherit);
public virtual int GetHashCode();
public abstract MethodImplAttributes GetMethodImplementationFlags();
public abstract ParameterInfo[] GetParameters();
public Type GetType();
public abstract object Invoke(object obj, BindingFlags invokeAttr, Binder binder, object[] parameters, CultureInfo culture);
public object Invoke(object obj, object[] parameters);
public abstract bool IsDefined(Type attributeType, bool inherit);
protected object MemberwiseClone();
public virtual string ToString();

Property
public abstract MethodAttributes Attributes {get;}
public virtual CallingConventions CallingConvention {get;}
public abstract Type DeclaringType {get;}
public bool IsAbstract {get;}
public bool IsAssembly {get;}
public bool IsConstructor {get;}
public bool IsFamily {get;}
public bool IsFamilyAndAssembly {get;}
public bool IsFamilyOrAssembly {get;}
public bool IsFinal {get;}
public bool IsHideBySig {get;}
public bool IsPrivate {get;}
public bool IsPublic {get;}
public bool IsSpecialName {get;}
public bool IsStatic {get;}
public bool IsVirtual {get;}
public override MemberTypes MemberType {get;}
public abstract RuntimeMethodHandle MethodHandle {get;}
public abstract string Name {get;}
public abstract Type ReflectedType {get;}
public abstract Type ReturnType {get;}
public abstract ICustomAttributeProvider ReturnTypeCustomAttributes {get;}

System.Reflection.EventAttributes

Module:mscorlib.dll

Hierarchy
Object
ValueType
Enum
EventAttributes

Type declaration

[C#] public enum EventAttributes;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const EventAttributes None = 0;
public const EventAttributes ReservedMask = 1024;
public const EventAttributes RTSpecialName = 1024;
public const EventAttributes SpecialName = 512;
public int value__;

System.Reflection.EventInfo

Module:mscorlib.dll

Hierarchy
Object
MemberInfo
EventInfo

Type declaration

[C#] public abstract class EventInfo : MemberInfo;

Constructor
protected EventInfo();

Method
public void AddEventHandler(object target, Delegate handler);
public virtual bool Equals(object obj);
protected override void Finalize();
public MethodInfo GetAddMethod();
public abstract MethodInfo GetAddMethod(bool nonPublic);
public abstract object[] GetCustomAttributes(bool inherit);
public abstract object[] GetCustomAttributes(Type attributeType, bool inherit);
public virtual int GetHashCode();
public MethodInfo GetRaiseMethod();
public abstract MethodInfo GetRaiseMethod(bool nonPublic);
public MethodInfo GetRemoveMethod();
public abstract MethodInfo GetRemoveMethod(bool nonPublic);
public Type GetType();
public abstract bool IsDefined(Type attributeType, bool inherit);
protected object MemberwiseClone();
public void RemoveEventHandler(object target, Delegate handler);
public virtual string ToString();

Property
public abstract EventAttributes Attributes {get;}
public abstract Type DeclaringType {get;}
public Type EventHandlerType {get;}
public bool IsMulticast {get;}
public bool IsSpecialName {get;}
public override MemberTypes MemberType {get;}
public abstract string Name {get;}
public abstract Type ReflectedType {get;}

System.Reflection.FieldAttributes

Module:mscorlib.dll

Hierarchy
Object
ValueType
Enum
FieldAttributes

Type declaration

[C#] public enum FieldAttributes;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const FieldAttributes Assembly = 3;
public const FieldAttributes FamANDAssem = 2;
public const FieldAttributes Family = 4;
public const FieldAttributes FamORAssem = 5;
public const FieldAttributes FieldAccessMask = 7;
public const FieldAttributes HasDefault = 32768;
public const FieldAttributes HasFieldMarshal = 4096;
public const FieldAttributes HasFieldRVA = 256;
public const FieldAttributes InitOnly = 32;
public const FieldAttributes Literal = 64;
public const FieldAttributes NotSerialized = 128;
public const FieldAttributes PinvokeImpl = 8192;
public const FieldAttributes Private = 1;
public const FieldAttributes PrivateScope = 0;
public const FieldAttributes Public = 6;
public const FieldAttributes ReservedMask = 38144;
public const FieldAttributes RTSpecialName = 1024;
public const FieldAttributes SpecialName = 512;
public const FieldAttributes Static = 16;
public int value__;

System.Reflection.FieldInfo

Module:mscorlib.dll

Hierarchy
Object
MemberInfo
FieldInfo

Type declaration

[C#] public abstract class FieldInfo : MemberInfo;

Constructor
protected FieldInfo();

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public abstract object[] GetCustomAttributes(bool inherit);
public abstract object[] GetCustomAttributes(Type attributeType, bool inherit);
public static FieldInfo GetFieldFromHandle(RuntimeFieldHandle handle);
public virtual int GetHashCode();
public Type GetType();
public abstract object GetValue(object obj);
public virtual object GetValueDirect(TypedReference obj);
public abstract bool IsDefined(Type attributeType, bool inherit);
protected object MemberwiseClone();
public void SetValue(object obj, object value);
public abstract void SetValue(object obj, object value, BindingFlags invokeAttr, Binder binder, CultureInfo culture);
public virtual void SetValueDirect(TypedReference obj, object value);
public virtual string ToString();

Property
public abstract FieldAttributes Attributes {get;}
public abstract Type DeclaringType {get;}
public abstract RuntimeFieldHandle FieldHandle {get;}
public abstract Type FieldType {get;}
public bool IsAssembly {get;}
public bool IsFamily {get;}
public bool IsFamilyAndAssembly {get;}
public bool IsFamilyOrAssembly {get;}
public bool IsInitOnly {get;}
public bool IsLiteral {get;}
public bool IsNotSerialized {get;}
public bool IsPinvokeImpl {get;}
public bool IsPrivate {get;}
public bool IsPublic {get;}
public bool IsSpecialName {get;}
public bool IsStatic {get;}
public override MemberTypes MemberType {get;}
public abstract string Name {get;}
public abstract Type ReflectedType {get;}

System.Reflection.CallingConventions

Module:mscorlib.dll

Hierarchy
Object
ValueType
Enum
CallingConventions

Type declaration

[C#] public enum CallingConventions;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const CallingConventions Any = 3;
public const CallingConventions ExplicitThis = 64;
public const CallingConventions HasThis = 32;
public const CallingConventions Standard = 1;
public int value__;
public const CallingConventions VarArgs = 2;

System.Reflection.Binder

Module:mscorlib.dll

Hierarchy
Object
Binder

Type declaration

[C#] public abstract class Binder;

Constructor
protected Binder();

Method
public abstract FieldInfo BindToField(BindingFlags bindingAttr, FieldInfo[] match, object value, CultureInfo culture);
public abstract MethodBase BindToMethod(BindingFlags bindingAttr, MethodBase[] match, ref object[] args, ParameterModifier[] modifiers, CultureInfo culture, string[] names, ref object state);
public abstract object ChangeType(object value, Type type, CultureInfo culture);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public abstract void ReorderArgumentArray(ref object[] args, object state);
public abstract MethodBase SelectMethod(BindingFlags bindingAttr, MethodBase[] match, Type[] types, ParameterModifier[] modifiers);
public abstract PropertyInfo SelectProperty(BindingFlags bindingAttr, PropertyInfo[] match, Type returnType, Type[] indexes, ParameterModifier[] modifiers);
public virtual string ToString();

System.Reflection.BindingFlags

Module:mscorlib.dll

Hierarchy
Object
ValueType
Enum
BindingFlags

Type declaration

[C#] public enum BindingFlags;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const BindingFlags CreateInstance = 512;
public const BindingFlags DeclaredOnly = 2;
public const BindingFlags Default = 0;
public const BindingFlags ExactBinding = 65536;
public const BindingFlags FlattenHierarchy = 64;
public const BindingFlags GetField = 1024;
public const BindingFlags GetProperty = 4096;
public const BindingFlags IgnoreCase = 1;
public const BindingFlags IgnoreReturn = 16777216;
public const BindingFlags Instance = 4;
public const BindingFlags InvokeMethod = 256;
public const BindingFlags NonPublic = 32;
public const BindingFlags OptionalParamBinding = 262144;
public const BindingFlags Public = 16;
public const BindingFlags PutDispProperty = 16384;
public const BindingFlags PutRefDispProperty = 32768;
public const BindingFlags SetField = 2048;
public const BindingFlags SetProperty = 8192;
public const BindingFlags Static = 8;
public const BindingFlags SuppressChangeType = 131072;
public int value__;

System.Reflection.MethodAttributes

Module:mscorlib.dll

Hierarchy
Object
ValueType
Enum
MethodAttributes

Type declaration

[C#] public enum MethodAttributes;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const MethodAttributes Abstract = 1024;
public const MethodAttributes Assembly = 3;
public const MethodAttributes CheckAccessOnOverride = 512;
public const MethodAttributes FamANDAssem = 2;
public const MethodAttributes Family = 4;
public const MethodAttributes FamORAssem = 5;
public const MethodAttributes Final = 32;
public const MethodAttributes HasSecurity = 16384;
public const MethodAttributes HideBySig = 128;
public const MethodAttributes MemberAccessMask = 7;
public const MethodAttributes NewSlot = 256;
public const MethodAttributes PinvokeImpl = 8192;
public const MethodAttributes Private = 1;
public const MethodAttributes PrivateScope = 0;
public const MethodAttributes Public = 6;
public const MethodAttributes RequireSecObject = 32768;
public const MethodAttributes ReservedMask = 53248;
public const MethodAttributes ReuseSlot = 0;
public const MethodAttributes RTSpecialName = 4096;
public const MethodAttributes SpecialName = 2048;
public const MethodAttributes Static = 16;
public const MethodAttributes UnmanagedExport = 8;
public int value__;
public const MethodAttributes Virtual = 64;
public const MethodAttributes VtableLayoutMask = 256;

System.Reflection.MethodBase

Module:mscorlib.dll

Hierarchy
Object
MemberInfo
MethodBase

Type declaration

[C#] public abstract class MethodBase : MemberInfo;

Constructor
protected MethodBase();

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public static MethodBase GetCurrentMethod();
public abstract object[] GetCustomAttributes(bool inherit);
public abstract object[] GetCustomAttributes(Type attributeType, bool inherit);
public virtual int GetHashCode();
public static MethodBase GetMethodFromHandle(RuntimeMethodHandle handle);
public abstract MethodImplAttributes GetMethodImplementationFlags();
public abstract ParameterInfo[] GetParameters();
public Type GetType();
public abstract object Invoke(object obj, BindingFlags invokeAttr, Binder binder, object[] parameters, CultureInfo culture);
public object Invoke(object obj, object[] parameters);
public abstract bool IsDefined(Type attributeType, bool inherit);
protected object MemberwiseClone();
public virtual string ToString();

Property
public abstract MethodAttributes Attributes {get;}
public virtual CallingConventions CallingConvention {get;}
public abstract Type DeclaringType {get;}
public bool IsAbstract {get;}
public bool IsAssembly {get;}
public bool IsConstructor {get;}
public bool IsFamily {get;}
public bool IsFamilyAndAssembly {get;}
public bool IsFamilyOrAssembly {get;}
public bool IsFinal {get;}
public bool IsHideBySig {get;}
public bool IsPrivate {get;}
public bool IsPublic {get;}
public bool IsSpecialName {get;}
public bool IsStatic {get;}
public bool IsVirtual {get;}
public abstract MemberTypes MemberType {get;}
public abstract RuntimeMethodHandle MethodHandle {get;}
public abstract string Name {get;}
public abstract Type ReflectedType {get;}

System.Reflection.MemberTypes

Module:mscorlib.dll

Hierarchy
Object
ValueType
Enum
MemberTypes

Type declaration

[C#] public enum MemberTypes;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const MemberTypes All = 191;
public const MemberTypes Constructor = 1;
public const MemberTypes Custom = 64;
public const MemberTypes Event = 2;
public const MemberTypes Field = 4;
public const MemberTypes Method = 8;
public const MemberTypes NestedType = 128;
public const MemberTypes Property = 16;
public const MemberTypes TypeInfo = 32;
public int value__;

System.Reflection.Missing

Module:mscorlib.dll

Hierarchy
Object
Missing

Type declaration

[C#] public sealed class Missing;

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Field
public readonly static Missing Value;

System.Reflection.AssemblyNameFlags

Module:mscorlib.dll

Hierarchy
Object
ValueType
Enum
AssemblyNameFlags

Type declaration

[C#] public enum AssemblyNameFlags;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const AssemblyNameFlags None = 0;
public const AssemblyNameFlags PublicKey = 1;
public const AssemblyNameFlags Retargetable = 256;
public int value__;

System.Reflection.AssemblyName

Module:mscorlib.dll

Hierarchy
Object
AssemblyName : ICloneable

Type declaration

[C#] public sealed class AssemblyName: ICloneable;

Constructor
public AssemblyName();

Method
public virtual object Clone();
public virtual bool Equals(object obj);
protected override void Finalize();
public static AssemblyName GetAssemblyName(string assemblyFile);
public virtual int GetHashCode();
public virtual void GetObjectData(SerializationInfo info, StreamingContext context);
public byte[] GetPublicKey();
public byte[] GetPublicKeyToken();
public Type GetType();
protected object MemberwiseClone();
public virtual void OnDeserialization(object sender);
public void SetPublicKey(byte[] publicKey);
public void SetPublicKeyToken(byte[] publicKeyToken);
public override string ToString();

Property
public string CodeBase {get; set;}
public CultureInfo CultureInfo {get; set;}
public string EscapedCodeBase {get;}
public AssemblyNameFlags Flags {get; set;}
public string FullName {get;}
public AssemblyHashAlgorithm HashAlgorithm {get; set;}
public StrongNameKeyPair KeyPair {get; set;}
public string Name {get; set;}
public Version Version {get; set;}
public AssemblyVersionCompatibility VersionCompatibility {get; set;}

System.Reflection.TypeAttributes

Module:mscorlib.dll

Hierarchy
Object
ValueType
Enum
TypeAttributes

Type declaration

[C#] public enum TypeAttributes;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const TypeAttributes Abstract = 128;
public const TypeAttributes AnsiClass = 0;
public const TypeAttributes AutoClass = 131072;
public const TypeAttributes AutoLayout = 0;
public const TypeAttributes BeforeFieldInit = 1048576;
public const TypeAttributes Class = 0;
public const TypeAttributes ClassSemanticsMask = 32;
public const TypeAttributes ExplicitLayout = 16;
public const TypeAttributes HasSecurity = 262144;
public const TypeAttributes Import = 4096;
public const TypeAttributes Interface = 32;
public const TypeAttributes LayoutMask = 24;
public const TypeAttributes NestedAssembly = 5;
public const TypeAttributes NestedFamANDAssem = 6;
public const TypeAttributes NestedFamily = 4;
public const TypeAttributes NestedFamORAssem = 7;
public const TypeAttributes NestedPrivate = 3;
public const TypeAttributes NestedPublic = 2;
public const TypeAttributes NotPublic = 0;
public const TypeAttributes Public = 1;
public const TypeAttributes ReservedMask = 264192;
public const TypeAttributes RTSpecialName = 2048;
public const TypeAttributes Sealed = 256;
public const TypeAttributes SequentialLayout = 8;
public const TypeAttributes Serializable = 8192;
public const TypeAttributes SpecialName = 1024;
public const TypeAttributes StringFormatMask = 196608;
public const TypeAttributes UnicodeClass = 65536;
public int value__;
public const TypeAttributes VisibilityMask = 7;

System.Reflection.MethodImplAttributes

Module:mscorlib.dll

Hierarchy
Object
ValueType
Enum
MethodImplAttributes

Type declaration

[C#] public enum MethodImplAttributes;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const MethodImplAttributes CodeTypeMask = 3;
public const MethodImplAttributes ForwardRef = 16;
public const MethodImplAttributes IL = 0;
public const MethodImplAttributes InternalCall = 4096;
public const MethodImplAttributes Managed = 0;
public const MethodImplAttributes ManagedMask = 4;
public const MethodImplAttributes MaxMethodImplVal = 65535;
public const MethodImplAttributes Native = 1;
public const MethodImplAttributes NoInlining = 8;
public const MethodImplAttributes OPTIL = 2;
public const MethodImplAttributes PreserveSig = 128;
public const MethodImplAttributes Runtime = 3;
public const MethodImplAttributes Synchronized = 32;
public const MethodImplAttributes Unmanaged = 4;
public int value__;

System.Reflection.AssemblyFlagsAttribute

Module:mscorlib.dll

Hierarchy
Object
Attribute
AssemblyFlagsAttribute

Type declaration

[C#] public sealed class AssemblyFlagsAttribute : Attribute;

Constructor
public AssemblyFlagsAttribute(int flags);
public AssemblyFlagsAttribute(uint flags);

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public int AssemblyFlags {get;}
public uint Flags {get;}
public object TypeId {get;}

System.Reflection.AssemblyAlgorithmIdAttribute

Module:mscorlib.dll

Hierarchy
Object
Attribute
AssemblyAlgorithmIdAttribute

Type declaration

[C#] public sealed class AssemblyAlgorithmIdAttribute : Attribute;

Constructor
public AssemblyAlgorithmIdAttribute(AssemblyHashAlgorithm algorithmId);
public AssemblyAlgorithmIdAttribute(uint algorithmId);

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public uint AlgorithmId {get;}
public object TypeId {get;}

System.Reflection.AssemblyDelaySignAttribute

Module:mscorlib.dll

Hierarchy
Object
Attribute
AssemblyDelaySignAttribute

Type declaration

[C#] public sealed class AssemblyDelaySignAttribute : Attribute;

Constructor
public AssemblyDelaySignAttribute(bool delaySign);

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public bool DelaySign {get;}
public object TypeId {get;}

System.Reflection.AssemblyKeyNameAttribute

Module:mscorlib.dll

Hierarchy
Object
Attribute
AssemblyKeyNameAttribute

Type declaration

[C#] public sealed class AssemblyKeyNameAttribute : Attribute;

Constructor
public AssemblyKeyNameAttribute(string keyName);

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public string KeyName {get;}
public object TypeId {get;}

System.Reflection.AssemblyKeyFileAttribute

Module:mscorlib.dll

Hierarchy
Object
Attribute
AssemblyKeyFileAttribute

Type declaration

[C#] public sealed class AssemblyKeyFileAttribute : Attribute;

Constructor
public AssemblyKeyFileAttribute(string keyFile);

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public string KeyFile {get;}
public object TypeId {get;}

System.Reflection.AssemblyVersionAttribute

Module:mscorlib.dll

Hierarchy
Object
Attribute
AssemblyVersionAttribute

Type declaration

[C#] public sealed class AssemblyVersionAttribute : Attribute;

Constructor
public AssemblyVersionAttribute(string version);

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public object TypeId {get;}
public string Version {get;}

System.Reflection.AssemblyCultureAttribute

Module:mscorlib.dll

Hierarchy
Object
Attribute
AssemblyCultureAttribute

Type declaration

[C#] public sealed class AssemblyCultureAttribute : Attribute;

Constructor
public AssemblyCultureAttribute(string culture);

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public string Culture {get;}
public object TypeId {get;}

System.Reflection.DefaultMemberAttribute

Module:mscorlib.dll

Hierarchy
Object
Attribute
DefaultMemberAttribute

Type declaration

[C#] public sealed class DefaultMemberAttribute : Attribute;

Constructor
public DefaultMemberAttribute(string memberName);

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public string MemberName {get;}
public object TypeId {get;}

System.Reflection.MemberInfo

Module:mscorlib.dll

Hierarchy
Object
MemberInfo : ICustomAttributeProvider

Type declaration

[C#] public abstract class MemberInfo: ICustomAttributeProvider;

Constructor
protected MemberInfo();

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public abstract object[] GetCustomAttributes(bool inherit);
public abstract object[] GetCustomAttributes(Type attributeType, bool inherit);
public virtual int GetHashCode();
public Type GetType();
public abstract bool IsDefined(Type attributeType, bool inherit);
protected object MemberwiseClone();
public virtual string ToString();

Property
public abstract Type DeclaringType {get;}
public abstract MemberTypes MemberType {get;}
public abstract string Name {get;}
public abstract Type ReflectedType {get;}

System.Reflection.ICustomAttributeProvider

Module:mscorlib.dll

Hierarchy
ICustomAttributeProvider

Type declaration

[C#] public interface ICustomAttributeProvider;

Method
public object[] GetCustomAttributes(bool inherit);
public object[] GetCustomAttributes(Type attributeType, bool inherit);
public bool IsDefined(Type attributeType, bool inherit);

System.Reflection.TargetInvocationException

Module:mscorlib.dll

Hierarchy
Object
Exception
ApplicationException
TargetInvocationException

Type declaration

[C#] public sealed class TargetInvocationException : ApplicationException;

Constructor
public TargetInvocationException(Exception innerException);
public TargetInvocationException(string message, Exception innerException);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public virtual string Message {get;}
public string Source {get; set;}
public string StackTrace {get;}
public MethodBase TargetSite {get;}

System.Reflection.TargetParameterCountException

Module:mscorlib.dll

Hierarchy
Object
Exception
ApplicationException
TargetParameterCountException

Type declaration

[C#] public sealed class TargetParameterCountException : ApplicationException;

Constructor
public TargetParameterCountException();
public TargetParameterCountException(string message);
public TargetParameterCountException(string message, Exception innerException);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public virtual string Message {get;}
public string Source {get; set;}
public string StackTrace {get;}
public MethodBase TargetSite {get;}

System.Reflection.CustomAttributeFormatException

Module:mscorlib.dll

Hierarchy
Object
Exception
SystemException
FormatException
CustomAttributeFormatException

Type declaration

[C#] public class CustomAttributeFormatException : FormatException;

Constructor
public CustomAttributeFormatException();
protected CustomAttributeFormatException(SerializationInfo info, StreamingContext context);
public CustomAttributeFormatException(string message);
public CustomAttributeFormatException(string message, Exception innerException);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public virtual string Message {get;}
public string Source {get; set;}
public string StackTrace {get;}
public MethodBase TargetSite {get;}

System.Reflection.AmbiguousMatchException

Module:mscorlib.dll

Hierarchy
Object
Exception
SystemException
AmbiguousMatchException

Type declaration

[C#] public sealed class AmbiguousMatchException : SystemException;

Constructor
public AmbiguousMatchException();
public AmbiguousMatchException(string message);
public AmbiguousMatchException(string message, Exception innerException);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public virtual string Message {get;}
public string Source {get; set;}
public string StackTrace {get;}
public MethodBase TargetSite {get;}

System.UriFormatException

Module:System.dll

Hierarchy
Object
Exception
SystemException
FormatException
UriFormatException

Type declaration

[C#] public class UriFormatException : FormatException;

Constructor
public UriFormatException();
protected UriFormatException(SerializationInfo serializationInfo, StreamingContext streamingContext);
public UriFormatException(string S);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public virtual string Message {get;}
public string Source {get; set;}
public string StackTrace {get;}
public MethodBase TargetSite {get;}

System.UriPartial

Module:System.dll

Hierarchy
Object
ValueType
Enum
UriPartial

Type declaration

[C#] public enum UriPartial;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const UriPartial Authority = 1;
public const UriPartial Path = 2;
public const UriPartial Scheme = 0;
public int value__;

System.UriHostNameType

Module:System.dll

Hierarchy
Object
ValueType
Enum
UriHostNameType

Type declaration

[C#] public enum UriHostNameType;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const UriHostNameType Basic = 1;
public const UriHostNameType Dns = 2;
public const UriHostNameType IPv4 = 3;
public const UriHostNameType IPv6 = 4;
public const UriHostNameType Unknown = 0;
public int value__;

System.Uri

Module:System.dll

Hierarchy
Object
MarshalByRefObject
Uri

Type declaration

[C#] public class Uri : MarshalByRefObject;

Constructor
protected Uri(SerializationInfo serializationInfo, StreamingContext streamingContext);
public Uri(string uriString);
public Uri(string uriString, bool dontEscape);
public Uri(Uri baseUri, string relativeUri);
public Uri(Uri baseUri, string relativeUri, bool dontEscape);

Method
protected virtual void Canonicalize();
public static UriHostNameType CheckHostName(string name);
public static bool CheckSchemeName(string schemeName);
protected virtual void CheckSecurity();
public ObjRef CreateObjRef(Type requestedType);
public override bool Equals(object comparand);
protected virtual void Escape();
protected static string EscapeString(string str);
protected override void Finalize();
public static int FromHex(char digit);
public override int GetHashCode();
public string GetLeftPart(UriPartial part);
public object GetLifetimeService();
public Type GetType();
public static string HexEscape(char character);
public static char HexUnescape(string pattern, ref int index);
public object InitializeLifetimeService();
protected virtual bool IsBadFileSystemCharacter(char character);
protected static bool IsExcludedCharacter(char character);
public static bool IsHexDigit(char character);
public static bool IsHexEncoding(string pattern, int index);
protected virtual bool IsReservedCharacter(char character);
public string MakeRelative(Uri toUri);
protected object MemberwiseClone();
protected virtual void Parse();
public override string ToString();
protected virtual string Unescape(string path);

Property
public string AbsolutePath {get;}
public string AbsoluteUri {get;}
public string Authority {get;}
public string Fragment {get;}
public string Host {get;}
public UriHostNameType HostNameType {get;}
public bool IsDefaultPort {get;}
public bool IsFile {get;}
public bool IsLoopback {get;}
public bool IsUnc {get;}
public string LocalPath {get;}
public string PathAndQuery {get;}
public int Port {get;}
public string Query {get;}
public string Scheme {get;}
public string[] Segments {get;}
public bool UserEscaped {get;}
public string UserInfo {get;}

Field
public readonly static string SchemeDelimiter;
public readonly static string UriSchemeFile;
public readonly static string UriSchemeFtp;
public readonly static string UriSchemeGopher;
public readonly static string UriSchemeHttp;
public readonly static string UriSchemeHttps;
public readonly static string UriSchemeMailto;
public readonly static string UriSchemeNews;
public readonly static string UriSchemeNntp;

System.Environment

Module:mscorlib.dll

Hierarchy
Object
Environment

Type declaration

[C#] public sealed class Environment;

Method
public virtual bool Equals(object obj);
public static void Exit(int exitCode);
public static string ExpandEnvironmentVariables(string name);
protected override void Finalize();
public static string[] GetCommandLineArgs();
public static string GetEnvironmentVariable(string variable);
public static IDictionary GetEnvironmentVariables();
public static string GetFolderPath(SpecialFolder folder);
public virtual int GetHashCode();
public static string[] GetLogicalDrives();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public static string CommandLine {get;}
public static string CurrentDirectory {get; set;}
public static int ExitCode {get; set;}
public static bool HasShutdownStarted {get;}
public static string MachineName {get;}
public static string NewLine {get;}
public static OperatingSystem OSVersion {get;}
public static string StackTrace {get;}
public static string SystemDirectory {get;}
public static int TickCount {get;}
public static string UserDomainName {get;}
public static bool UserInteractive {get;}
public static string UserName {get;}
public static Version Version {get;}
public static long WorkingSet {get;}

System.Buffer

Module:mscorlib.dll

Hierarchy
Object
Buffer

Type declaration

[C#] public sealed class Buffer;

Method
public static void BlockCopy(Array src, int srcOffset, Array dst, int dstOffset, int count);
public static int ByteLength(Array array);
public virtual bool Equals(object obj);
protected override void Finalize();
public static byte GetByte(Array array, int index);
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public static void SetByte(Array array, int index, byte value);
public virtual string ToString();

System.LocalDataStoreSlot

Module:mscorlib.dll

Hierarchy
Object
LocalDataStoreSlot

Type declaration

[C#] public sealed class LocalDataStoreSlot;

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

System.Guid

Module:mscorlib.dll

Hierarchy
Object
ValueType
Guid : IFormattable, IComparable

Type declaration

[C#] public struct Guid : ValueType, IFormattable, IComparable;

Constructor
public Guid(byte[] b);
public Guid(int a, short b, short c, byte d, byte e, byte f, byte g, byte h, byte i, byte j, byte k);
public Guid(int a, short b, short c, byte[] d);
public Guid(string g);
public Guid(uint a, ushort b, ushort c, byte d, byte e, byte f, byte g, byte h, byte i, byte j, byte k);

Method
public virtual int CompareTo(object value);
public override bool Equals(object o);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public static Guid NewGuid();
public static bool op_Equality(Guid a, Guid b);
public static bool op_Inequality(Guid a, Guid b);
public byte[] ToByteArray();
public override string ToString();
public string ToString(string format);
public virtual string ToString(string format, IFormatProvider provider);

Field
public readonly static Guid Empty;

System.IServiceProvider

Module:mscorlib.dll

Hierarchy
IServiceProvider

Type declaration

[C#] public interface IServiceProvider;

Method
public object GetService(Type serviceType);

System.Activator

Module:mscorlib.dll

Hierarchy
Object
Activator

Type declaration

[C#] public sealed class Activator;

Method
public static ObjectHandle CreateComInstanceFrom(string assemblyName, string typeName);
public static ObjectHandle CreateComInstanceFrom(string assemblyName, string typeName, byte[] hashValue, AssemblyHashAlgorithm hashAlgorithm);
public static ObjectHandle CreateInstance(string assemblyName, string typeName);
public static ObjectHandle CreateInstance(string assemblyName, string typeName, bool ignoreCase, BindingFlags bindingAttr, Binder binder, object[] args, CultureInfo culture, object[] activationAttributes, Evidence securityInfo);
public static ObjectHandle CreateInstance(string assemblyName, string typeName, object[] activationAttributes);
public static object CreateInstance(Type type);
public static object CreateInstance(Type type, BindingFlags bindingAttr, Binder binder, object[] args, CultureInfo culture);
public static object CreateInstance(Type type, BindingFlags bindingAttr, Binder binder, object[] args, CultureInfo culture, object[] activationAttributes);
public static object CreateInstance(Type type, bool nonPublic);
public static object CreateInstance(Type type, object[] args);
public static object CreateInstance(Type type, object[] args, object[] activationAttributes);
public static ObjectHandle CreateInstanceFrom(string assemblyFile, string typeName);
public static ObjectHandle CreateInstanceFrom(string assemblyFile, string typeName, bool ignoreCase, BindingFlags bindingAttr, Binder binder, object[] args, CultureInfo culture, object[] activationAttributes, Evidence securityInfo);
public static ObjectHandle CreateInstanceFrom(string assemblyFile, string typeName, object[] activationAttributes);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public static object GetObject(Type type, string url);
public static object GetObject(Type type, string url, object state);
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

System.RuntimeMethodHandle

Module:mscorlib.dll

Hierarchy
Object
ValueType
RuntimeMethodHandle

Type declaration

[C#] public struct RuntimeMethodHandle : ValueType;

Method
public override bool Equals(object obj);
protected override void Finalize();
public IntPtr GetFunctionPointer();
public override int GetHashCode();
public virtual void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public IntPtr Value {get;}

System.DBNull

Module:mscorlib.dll

Hierarchy
Object
DBNull : IConvertible

Type declaration

[C#] public sealed class DBNull: IConvertible;

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public virtual void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public virtual string ToString(IFormatProvider provider);

Field
public readonly static DBNull Value;

System.AppDomain

Module:mscorlib.dll

Hierarchy
Object
MarshalByRefObject
AppDomain

Type declaration

[C#] public sealed class AppDomain : MarshalByRefObject;

Method
public virtual void add_AssemblyLoad(AssemblyLoadEventHandler value);
public virtual void add_AssemblyResolve(ResolveEventHandler value);
public virtual void add_DomainUnload(EventHandler value);
public virtual void add_ProcessExit(EventHandler value);
public virtual void add_ResourceResolve(ResolveEventHandler value);
public virtual void add_TypeResolve(ResolveEventHandler value);
public virtual void add_UnhandledException(UnhandledExceptionEventHandler value);
public virtual void AppendPrivatePath(string path);
public virtual void ClearPrivatePath();
public virtual void ClearShadowCopyPath();
public ObjectHandle CreateComInstanceFrom(string assemblyName, string typeName);
public ObjectHandle CreateComInstanceFrom(string assemblyFile, string typeName, byte[] hashValue, AssemblyHashAlgorithm hashAlgorithm);
public static AppDomain CreateDomain(string friendlyName);
public static AppDomain CreateDomain(string friendlyName, Evidence securityInfo);
public static AppDomain CreateDomain(string friendlyName, Evidence securityInfo, AppDomainSetup info);
public static AppDomain CreateDomain(string friendlyName, Evidence securityInfo, string appBasePath, string appRelativeSearchPath, bool shadowCopyFiles);
public virtual ObjectHandle CreateInstance(string assemblyName, string typeName);
public virtual ObjectHandle CreateInstance(string assemblyName, string typeName, bool ignoreCase, BindingFlags bindingAttr, Binder binder, object[] args, CultureInfo culture, object[] activationAttributes, Evidence securityAttributes);
public virtual ObjectHandle CreateInstance(string assemblyName, string typeName, object[] activationAttributes);
public object CreateInstanceAndUnwrap(string assemblyName, string typeName);
public object CreateInstanceAndUnwrap(string assemblyName, string typeName, bool ignoreCase, BindingFlags bindingAttr, Binder binder, object[] args, CultureInfo culture, object[] activationAttributes, Evidence securityAttributes);
public object CreateInstanceAndUnwrap(string assemblyName, string typeName, object[] activationAttributes);
public virtual ObjectHandle CreateInstanceFrom(string assemblyFile, string typeName);
public virtual ObjectHandle CreateInstanceFrom(string assemblyFile, string typeName, bool ignoreCase, BindingFlags bindingAttr, Binder binder, object[] args, CultureInfo culture, object[] activationAttributes, Evidence securityAttributes);
public virtual ObjectHandle CreateInstanceFrom(string assemblyFile, string typeName, object[] activationAttributes);
public object CreateInstanceFromAndUnwrap(string assemblyName, string typeName);
public object CreateInstanceFromAndUnwrap(string assemblyName, string typeName, bool ignoreCase, BindingFlags bindingAttr, Binder binder, object[] args, CultureInfo culture, object[] activationAttributes, Evidence securityAttributes);
public object CreateInstanceFromAndUnwrap(string assemblyName, string typeName, object[] activationAttributes);
public ObjRef CreateObjRef(Type requestedType);
public virtual AssemblyBuilder DefineDynamicAssembly(AssemblyName name, AssemblyBuilderAccess access);
public virtual AssemblyBuilder DefineDynamicAssembly(AssemblyName name, AssemblyBuilderAccess access, Evidence evidence);
public virtual AssemblyBuilder DefineDynamicAssembly(AssemblyName name, AssemblyBuilderAccess access, Evidence evidence, PermissionSet requiredPermissions, PermissionSet optionalPermissions, PermissionSet refusedPermissions);
public virtual AssemblyBuilder DefineDynamicAssembly(AssemblyName name, AssemblyBuilderAccess access, PermissionSet requiredPermissions, PermissionSet optionalPermissions, PermissionSet refusedPermissions);
public virtual AssemblyBuilder DefineDynamicAssembly(AssemblyName name, AssemblyBuilderAccess access, string dir);
public virtual AssemblyBuilder DefineDynamicAssembly(AssemblyName name, AssemblyBuilderAccess access, string dir, Evidence evidence);
public virtual AssemblyBuilder DefineDynamicAssembly(AssemblyName name, AssemblyBuilderAccess access, string dir, Evidence evidence, PermissionSet requiredPermissions, PermissionSet optionalPermissions, PermissionSet refusedPermissions);
public virtual AssemblyBuilder DefineDynamicAssembly(AssemblyName name, AssemblyBuilderAccess access, string dir, Evidence evidence, PermissionSet requiredPermissions, PermissionSet optionalPermissions, PermissionSet refusedPermissions, bool isSynchronized);
public virtual AssemblyBuilder DefineDynamicAssembly(AssemblyName name, AssemblyBuilderAccess access, string dir, PermissionSet requiredPermissions, PermissionSet optionalPermissions, PermissionSet refusedPermissions);
public virtual void DoCallBack(CrossAppDomainDelegate callBackDelegate);
public virtual bool Equals(object obj);
public int ExecuteAssembly(string assemblyFile);
public virtual int ExecuteAssembly(string assemblyFile, Evidence assemblySecurity);
public int ExecuteAssembly(string assemblyFile, Evidence assemblySecurity, string[] args);
public int ExecuteAssembly(string assemblyFile, Evidence assemblySecurity, string[] args, byte[] hashValue, AssemblyHashAlgorithm hashAlgorithm);
protected override void Finalize();
public virtual Assembly[] GetAssemblies();
public static int GetCurrentThreadId();
public virtual object GetData(string name);
public virtual int GetHashCode();
public object GetLifetimeService();
public Type GetType();
public override object InitializeLifetimeService();
public bool IsFinalizingForUnload();
public virtual Assembly Load(AssemblyName assemblyRef);
public virtual Assembly Load(AssemblyName assemblyRef, Evidence assemblySecurity);
public virtual Assembly Load(byte[] rawAssembly);
public virtual Assembly Load(byte[] rawAssembly, byte[] rawSymbolStore);
public virtual Assembly Load(byte[] rawAssembly, byte[] rawSymbolStore, Evidence securityEvidence);
public virtual Assembly Load(string assemblyString);
public virtual Assembly Load(string assemblyString, Evidence assemblySecurity);
protected object MemberwiseClone();
public virtual void remove_AssemblyLoad(AssemblyLoadEventHandler value);
public virtual void remove_AssemblyResolve(ResolveEventHandler value);
public virtual void remove_DomainUnload(EventHandler value);
public virtual void remove_ProcessExit(EventHandler value);
public virtual void remove_ResourceResolve(ResolveEventHandler value);
public virtual void remove_TypeResolve(ResolveEventHandler value);
public virtual void remove_UnhandledException(UnhandledExceptionEventHandler value);
public virtual void SetAppDomainPolicy(PolicyLevel domainPolicy);
public virtual void SetCachePath(string path);
public virtual void SetData(string name, object data);
public void SetDynamicBase(string path);
public virtual void SetPrincipalPolicy(PrincipalPolicy policy);
public void SetShadowCopyFiles();
public virtual void SetShadowCopyPath(string path);
public virtual void SetThreadPrincipal(IPrincipal principal);
public virtual string ToString();
public static void Unload(AppDomain domain);

Property
public virtual string BaseDirectory {get;}
public static AppDomain CurrentDomain {get;}
public virtual string DynamicDirectory {get;}
public virtual Evidence Evidence {get;}
public string FriendlyName {get;}
public virtual string RelativeSearchPath {get;}
public AppDomainSetup SetupInformation {get;}
public virtual bool ShadowCopyFiles {get;}

System.Version

Module:mscorlib.dll

Hierarchy
Object
Version : ICloneable, IComparable

Type declaration

[C#] public sealed class Version: ICloneable, IComparable;

Constructor
public Version();
public Version(int major, int minor);
public Version(int major, int minor, int build);
public Version(int major, int minor, int build, int revision);
public Version(string version);

Method
public virtual object Clone();
public virtual int CompareTo(object version);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public static bool op_Equality(Version v1, Version v2);
public static bool op_GreaterThan(Version v1, Version v2);
public static bool op_GreaterThanOrEqual(Version v1, Version v2);
public static bool op_Inequality(Version v1, Version v2);
public static bool op_LessThan(Version v1, Version v2);
public static bool op_LessThanOrEqual(Version v1, Version v2);
public override string ToString();
public string ToString(int fieldCount);

Property
public int Build {get;}
public int Major {get;}
public int Minor {get;}
public int Revision {get;}

System.RuntimeFieldHandle

Module:mscorlib.dll

Hierarchy
Object
ValueType
RuntimeFieldHandle

Type declaration

[C#] public struct RuntimeFieldHandle : ValueType;

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public virtual void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public IntPtr Value {get;}

System.Convert

Module:mscorlib.dll

Hierarchy
Object
Convert

Type declaration

[C#] public sealed class Convert;

Method
public static object ChangeType(object value, Type conversionType);
public static object ChangeType(object value, Type conversionType, IFormatProvider provider);
public static object ChangeType(object value, TypeCode typeCode);
public static object ChangeType(object value, TypeCode typeCode, IFormatProvider provider);
public virtual bool Equals(object obj);
protected override void Finalize();
public static byte[] FromBase64CharArray(char[] inArray, int offset, int length);
public static byte[] FromBase64String(string s);
public virtual int GetHashCode();
public Type GetType();
public static TypeCode GetTypeCode(object value);
public static bool IsDBNull(object value);
protected object MemberwiseClone();
public static int ToBase64CharArray(byte[] inArray, int offsetIn, int length, char[] outArray, int offsetOut);
public static string ToBase64String(byte[] inArray);
public static string ToBase64String(byte[] inArray, int offset, int length);
public static bool ToBoolean(bool value);
public static bool ToBoolean(byte value);
public static bool ToBoolean(char value);
public static bool ToBoolean(DateTime value);
public static bool ToBoolean(decimal value);
public static bool ToBoolean(double value);
public static bool ToBoolean(short value);
public static bool ToBoolean(int value);
public static bool ToBoolean(long value);
public static bool ToBoolean(object value);
public static bool ToBoolean(object value, IFormatProvider provider);
public static bool ToBoolean(SByte value);
public static bool ToBoolean(float value);
public static bool ToBoolean(string value);
public static bool ToBoolean(string value, IFormatProvider provider);
public static bool ToBoolean(ushort value);
public static bool ToBoolean(uint value);
public static bool ToBoolean(ulong value);
public static byte ToByte(bool value);
public static byte ToByte(byte value);
public static byte ToByte(char value);
public static byte ToByte(DateTime value);
public static byte ToByte(decimal value);
public static byte ToByte(double value);
public static byte ToByte(short value);
public static byte ToByte(int value);
public static byte ToByte(long value);
public static byte ToByte(object value);
public static byte ToByte(object value, IFormatProvider provider);
public static byte ToByte(SByte value);
public static byte ToByte(float value);
public static byte ToByte(string value);
public static byte ToByte(string value, IFormatProvider provider);
public static byte ToByte(string value, int fromBase);
public static byte ToByte(ushort value);
public static byte ToByte(uint value);
public static byte ToByte(ulong value);
public static char ToChar(bool value);
public static char ToChar(byte value);
public static char ToChar(char value);
public static char ToChar(DateTime value);
public static char ToChar(decimal value);
public static char ToChar(double value);
public static char ToChar(short value);
public static char ToChar(int value);
public static char ToChar(long value);
public static char ToChar(object value);
public static char ToChar(object value, IFormatProvider provider);
public static char ToChar(SByte value);
public static char ToChar(float value);
public static char ToChar(string value);
public static char ToChar(string value, IFormatProvider provider);
public static char ToChar(ushort value);
public static char ToChar(uint value);
public static char ToChar(ulong value);
public static DateTime ToDateTime(bool value);
public static DateTime ToDateTime(byte value);
public static DateTime ToDateTime(char value);
public static DateTime ToDateTime(DateTime value);
public static DateTime ToDateTime(decimal value);
public static DateTime ToDateTime(double value);
public static DateTime ToDateTime(short value);
public static DateTime ToDateTime(int value);
public static DateTime ToDateTime(long value);
public static DateTime ToDateTime(object value);
public static DateTime ToDateTime(object value, IFormatProvider provider);
public static DateTime ToDateTime(SByte value);
public static DateTime ToDateTime(float value);
public static DateTime ToDateTime(string value);
public static DateTime ToDateTime(string value, IFormatProvider provider);
public static DateTime ToDateTime(ushort value);
public static DateTime ToDateTime(uint value);
public static DateTime ToDateTime(ulong value);
public static decimal ToDecimal(bool value);
public static decimal ToDecimal(byte value);
public static decimal ToDecimal(char value);
public static decimal ToDecimal(DateTime value);
public static decimal ToDecimal(decimal value);
public static decimal ToDecimal(double value);
public static decimal ToDecimal(short value);
public static decimal ToDecimal(int value);
public static decimal ToDecimal(long value);
public static decimal ToDecimal(object value);
public static decimal ToDecimal(object value, IFormatProvider provider);
public static decimal ToDecimal(SByte value);
public static decimal ToDecimal(float value);
public static decimal ToDecimal(string value);
public static decimal ToDecimal(string value, IFormatProvider isop);
public static decimal ToDecimal(ushort value);
public static decimal ToDecimal(uint value);
public static decimal ToDecimal(ulong value);
public static double ToDouble(bool value);
public static double ToDouble(byte value);
public static double ToDouble(char value);
public static double ToDouble(DateTime value);
public static double ToDouble(decimal value);
public static double ToDouble(double value);
public static double ToDouble(short value);
public static double ToDouble(int value);
public static double ToDouble(long value);
public static double ToDouble(object value);
public static double ToDouble(object value, IFormatProvider provider);
public static double ToDouble(SByte value);
public static double ToDouble(float value);
public static double ToDouble(string value);
public static double ToDouble(string value, IFormatProvider isop);
public static double ToDouble(ushort value);
public static double ToDouble(uint value);
public static double ToDouble(ulong value);
public static short ToInt16(bool value);
public static short ToInt16(byte value);
public static short ToInt16(char value);
public static short ToInt16(DateTime value);
public static short ToInt16(decimal value);
public static short ToInt16(double value);
public static short ToInt16(short value);
public static short ToInt16(int value);
public static short ToInt16(long value);
public static short ToInt16(object value);
public static short ToInt16(object value, IFormatProvider provider);
public static short ToInt16(SByte value);
public static short ToInt16(float value);
public static short ToInt16(string value);
public static short ToInt16(string value, IFormatProvider provider);
public static short ToInt16(string value, int fromBase);
public static short ToInt16(ushort value);
public static short ToInt16(uint value);
public static short ToInt16(ulong value);
public static int ToInt32(bool value);
public static int ToInt32(byte value);
public static int ToInt32(char value);
public static int ToInt32(DateTime value);
public static int ToInt32(decimal value);
public static int ToInt32(double value);
public static int ToInt32(short value);
public static int ToInt32(int value);
public static int ToInt32(long value);
public static int ToInt32(object value);
public static int ToInt32(object value, IFormatProvider provider);
public static int ToInt32(SByte value);
public static int ToInt32(float value);
public static int ToInt32(string value);
public static int ToInt32(string value, IFormatProvider provider);
public static int ToInt32(string value, int fromBase);
public static int ToInt32(ushort value);
public static int ToInt32(uint value);
public static int ToInt32(ulong value);
public static long ToInt64(bool value);
public static long ToInt64(byte value);
public static long ToInt64(char value);
public static long ToInt64(DateTime value);
public static long ToInt64(decimal value);
public static long ToInt64(double value);
public static long ToInt64(short value);
public static long ToInt64(int value);
public static long ToInt64(long value);
public static long ToInt64(object value);
public static long ToInt64(object value, IFormatProvider provider);
public static long ToInt64(SByte value);
public static long ToInt64(float value);
public static long ToInt64(string value);
public static long ToInt64(string value, IFormatProvider provider);
public static long ToInt64(string value, int fromBase);
public static long ToInt64(ushort value);
public static long ToInt64(uint value);
public static long ToInt64(ulong value);
public static SByte ToSByte(bool value);
public static SByte ToSByte(byte value);
public static SByte ToSByte(char value);
public static SByte ToSByte(DateTime value);
public static SByte ToSByte(decimal value);
public static SByte ToSByte(double value);
public static SByte ToSByte(short value);
public static SByte ToSByte(int value);
public static SByte ToSByte(long value);
public static SByte ToSByte(object value);
public static SByte ToSByte(object value, IFormatProvider provider);
public static SByte ToSByte(SByte value);
public static SByte ToSByte(float value);
public static SByte ToSByte(string value);
public static SByte ToSByte(string value, IFormatProvider provider);
public static SByte ToSByte(string value, int fromBase);
public static SByte ToSByte(ushort value);
public static SByte ToSByte(uint value);
public static SByte ToSByte(ulong value);
public static float ToSingle(bool value);
public static float ToSingle(byte value);
public static float ToSingle(char value);
public static float ToSingle(DateTime value);
public static float ToSingle(decimal value);
public static float ToSingle(double value);
public static float ToSingle(short value);
public static float ToSingle(int value);
public static float ToSingle(long value);
public static float ToSingle(object value);
public static float ToSingle(object value, IFormatProvider provider);
public static float ToSingle(SByte value);
public static float ToSingle(float value);
public static float ToSingle(string value);
public static float ToSingle(string value, IFormatProvider isop);
public static float ToSingle(ushort value);
public static float ToSingle(uint value);
public static float ToSingle(ulong value);
public virtual string ToString();
public static string ToString(bool value);
public static string ToString(bool value, IFormatProvider provider);
public static string ToString(byte value);
public static string ToString(byte value, IFormatProvider provider);
public static string ToString(byte value, int toBase);
public static string ToString(char value);
public static string ToString(char value, IFormatProvider provider);
public static string ToString(DateTime value);
public static string ToString(DateTime value, IFormatProvider provider);
public static string ToString(decimal value);
public static string ToString(decimal value, IFormatProvider isop);
public static string ToString(double value);
public static string ToString(double value, IFormatProvider isop);
public static string ToString(short value);
public static string ToString(short value, IFormatProvider provider);
public static string ToString(short value, int toBase);
public static string ToString(int value);
public static string ToString(int value, IFormatProvider provider);
public static string ToString(int value, int toBase);
public static string ToString(long value);
public static string ToString(long value, IFormatProvider provider);
public static string ToString(long value, int toBase);
public static string ToString(object value);
public static string ToString(object value, IFormatProvider provider);
public static string ToString(SByte value);
public static string ToString(SByte value, IFormatProvider provider);
public static string ToString(float value);
public static string ToString(float value, IFormatProvider isop);
public static string ToString(string value);
public static string ToString(string value, IFormatProvider provider);
public static string ToString(ushort value);
public static string ToString(ushort value, IFormatProvider provider);
public static string ToString(uint value);
public static string ToString(uint value, IFormatProvider provider);
public static string ToString(ulong value);
public static string ToString(ulong value, IFormatProvider provider);
public static ushort ToUInt16(bool value);
public static ushort ToUInt16(byte value);
public static ushort ToUInt16(char value);
public static ushort ToUInt16(DateTime value);
public static ushort ToUInt16(decimal value);
public static ushort ToUInt16(double value);
public static ushort ToUInt16(short value);
public static ushort ToUInt16(int value);
public static ushort ToUInt16(long value);
public static ushort ToUInt16(object value);
public static ushort ToUInt16(object value, IFormatProvider provider);
public static ushort ToUInt16(SByte value);
public static ushort ToUInt16(float value);
public static ushort ToUInt16(string value);
public static ushort ToUInt16(string value, IFormatProvider provider);
public static ushort ToUInt16(string value, int fromBase);
public static ushort ToUInt16(ushort value);
public static ushort ToUInt16(uint value);
public static ushort ToUInt16(ulong value);
public static uint ToUInt32(bool value);
public static uint ToUInt32(byte value);
public static uint ToUInt32(char value);
public static uint ToUInt32(DateTime value);
public static uint ToUInt32(decimal value);
public static uint ToUInt32(double value);
public static uint ToUInt32(short value);
public static uint ToUInt32(int value);
public static uint ToUInt32(long value);
public static uint ToUInt32(object value);
public static uint ToUInt32(object value, IFormatProvider provider);
public static uint ToUInt32(SByte value);
public static uint ToUInt32(float value);
public static uint ToUInt32(string value);
public static uint ToUInt32(string value, IFormatProvider provider);
public static uint ToUInt32(string value, int fromBase);
public static uint ToUInt32(ushort value);
public static uint ToUInt32(uint value);
public static uint ToUInt32(ulong value);
public static ulong ToUInt64(bool value);
public static ulong ToUInt64(byte value);
public static ulong ToUInt64(char value);
public static ulong ToUInt64(DateTime value);
public static ulong ToUInt64(decimal value);
public static ulong ToUInt64(double value);
public static ulong ToUInt64(short value);
public static ulong ToUInt64(int value);
public static ulong ToUInt64(long value);
public static ulong ToUInt64(object value);
public static ulong ToUInt64(object value, IFormatProvider provider);
public static ulong ToUInt64(SByte value);
public static ulong ToUInt64(float value);
public static ulong ToUInt64(string value);
public static ulong ToUInt64(string value, IFormatProvider provider);
public static ulong ToUInt64(string value, int fromBase);
public static ulong ToUInt64(ushort value);
public static ulong ToUInt64(uint value);
public static ulong ToUInt64(ulong value);

Field
public readonly static object DBNull;

System.TimeZone

Module:mscorlib.dll

Hierarchy
Object
TimeZone

Type declaration

[C#] public abstract class TimeZone;

Constructor
protected TimeZone();

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public abstract DaylightTime GetDaylightChanges(int year);
public virtual int GetHashCode();
public Type GetType();
public abstract TimeSpan GetUtcOffset(DateTime time);
public virtual bool IsDaylightSavingTime(DateTime time);
public static bool IsDaylightSavingTime(DateTime time, DaylightTime daylightTimes);
protected object MemberwiseClone();
public virtual DateTime ToLocalTime(DateTime time);
public virtual string ToString();
public virtual DateTime ToUniversalTime(DateTime time);

Property
public static TimeZone CurrentTimeZone {get;}
public abstract string DaylightName {get;}
public abstract string StandardName {get;}

System.DateTime

Module:mscorlib.dll

Hierarchy
Object
ValueType
DateTime : IComparable, IConvertible, IFormattable

Type declaration

[C#] public struct DateTime : ValueType, IComparable, IConvertible, IFormattable;

Constructor
public DateTime(int year, int month, int day);
public DateTime(int year, int month, int day, Calendar calendar);
public DateTime(int year, int month, int day, int hour, int minute, int second);
public DateTime(int year, int month, int day, int hour, int minute, int second, Calendar calendar);
public DateTime(int year, int month, int day, int hour, int minute, int second, int millisecond);
public DateTime(int year, int month, int day, int hour, int minute, int second, int millisecond, Calendar calendar);
public DateTime(long ticks);

Method
public DateTime Add(TimeSpan value);
public DateTime AddDays(double value);
public DateTime AddHours(double value);
public DateTime AddMilliseconds(double value);
public DateTime AddMinutes(double value);
public DateTime AddMonths(int months);
public DateTime AddSeconds(double value);
public DateTime AddTicks(long value);
public DateTime AddYears(int value);
public static int Compare(DateTime t1, DateTime t2);
public virtual int CompareTo(object value);
public static int DaysInMonth(int year, int month);
public static bool Equals(DateTime t1, DateTime t2);
public override bool Equals(object value);
protected override void Finalize();
public static DateTime FromFileTime(long fileTime);
public static DateTime FromFileTimeUtc(long fileTime);
public static DateTime FromOADate(double d);
public string[] GetDateTimeFormats();
public string[] GetDateTimeFormats(char format);
public string[] GetDateTimeFormats(char format, IFormatProvider provider);
public string[] GetDateTimeFormats(IFormatProvider provider);
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
public static bool IsLeapYear(int year);
protected object MemberwiseClone();
public static DateTime op_Addition(DateTime d, TimeSpan t);
public static bool op_Equality(DateTime d1, DateTime d2);
public static bool op_GreaterThan(DateTime t1, DateTime t2);
public static bool op_GreaterThanOrEqual(DateTime t1, DateTime t2);
public static bool op_Inequality(DateTime d1, DateTime d2);
public static bool op_LessThan(DateTime t1, DateTime t2);
public static bool op_LessThanOrEqual(DateTime t1, DateTime t2);
public static TimeSpan op_Subtraction(DateTime d1, DateTime d2);
public static DateTime op_Subtraction(DateTime d, TimeSpan t);
public static DateTime Parse(string s);
public static DateTime Parse(string s, IFormatProvider provider);
public static DateTime Parse(string s, IFormatProvider provider, DateTimeStyles styles);
public static DateTime ParseExact(string s, string format, IFormatProvider provider);
public static DateTime ParseExact(string s, string format, IFormatProvider provider, DateTimeStyles style);
public static DateTime ParseExact(string s, string[] formats, IFormatProvider provider, DateTimeStyles style);
public TimeSpan Subtract(DateTime value);
public DateTime Subtract(TimeSpan value);
public long ToFileTime();
public long ToFileTimeUtc();
public DateTime ToLocalTime();
public string ToLongDateString();
public string ToLongTimeString();
public double ToOADate();
public string ToShortDateString();
public string ToShortTimeString();
public override string ToString();
public virtual string ToString(IFormatProvider provider);
public string ToString(string format);
public virtual string ToString(string format, IFormatProvider provider);
public DateTime ToUniversalTime();

Property
public DateTime Date {get;}
public int Day {get;}
public DayOfWeek DayOfWeek {get;}
public int DayOfYear {get;}
public int Hour {get;}
public int Millisecond {get;}
public int Minute {get;}
public int Month {get;}
public static DateTime Now {get;}
public int Second {get;}
public long Ticks {get;}
public TimeSpan TimeOfDay {get;}
public static DateTime Today {get;}
public static DateTime UtcNow {get;}
public int Year {get;}

Field
public readonly static DateTime MaxValue;
public readonly static DateTime MinValue;

System.TimeSpan

Module:mscorlib.dll

Hierarchy
Object
ValueType
TimeSpan : IComparable

Type declaration

[C#] public struct TimeSpan : ValueType, IComparable;

Constructor
public TimeSpan(int hours, int minutes, int seconds);
public TimeSpan(int days, int hours, int minutes, int seconds);
public TimeSpan(int days, int hours, int minutes, int seconds, int milliseconds);
public TimeSpan(long ticks);

Method
public TimeSpan Add(TimeSpan ts);
public static int Compare(TimeSpan t1, TimeSpan t2);
public virtual int CompareTo(object value);
public TimeSpan Duration();
public override bool Equals(object value);
public static bool Equals(TimeSpan t1, TimeSpan t2);
protected override void Finalize();
public static TimeSpan FromDays(double value);
public static TimeSpan FromHours(double value);
public static TimeSpan FromMilliseconds(double value);
public static TimeSpan FromMinutes(double value);
public static TimeSpan FromSeconds(double value);
public static TimeSpan FromTicks(long value);
public override int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public TimeSpan Negate();
public static TimeSpan op_Addition(TimeSpan t1, TimeSpan t2);
public static bool op_Equality(TimeSpan t1, TimeSpan t2);
public static bool op_GreaterThan(TimeSpan t1, TimeSpan t2);
public static bool op_GreaterThanOrEqual(TimeSpan t1, TimeSpan t2);
public static bool op_Inequality(TimeSpan t1, TimeSpan t2);
public static bool op_LessThan(TimeSpan t1, TimeSpan t2);
public static bool op_LessThanOrEqual(TimeSpan t1, TimeSpan t2);
public static TimeSpan op_Subtraction(TimeSpan t1, TimeSpan t2);
public static TimeSpan op_UnaryNegation(TimeSpan t);
public static TimeSpan op_UnaryPlus(TimeSpan t);
public static TimeSpan Parse(string s);
public TimeSpan Subtract(TimeSpan ts);
public override string ToString();

Property
public int Days {get;}
public int Hours {get;}
public int Milliseconds {get;}
public int Minutes {get;}
public int Seconds {get;}
public long Ticks {get;}
public double TotalDays {get;}
public double TotalHours {get;}
public double TotalMilliseconds {get;}
public double TotalMinutes {get;}
public double TotalSeconds {get;}

Field
public readonly static TimeSpan MaxValue;
public readonly static TimeSpan MinValue;
public const long TicksPerDay = 864000000000;
public const long TicksPerHour = 36000000000;
public const long TicksPerMillisecond = 10000;
public const long TicksPerMinute = 600000000;
public const long TicksPerSecond = 10000000;
public readonly static TimeSpan Zero;

System.ICustomFormatter

Module:mscorlib.dll

Hierarchy
ICustomFormatter

Type declaration

[C#] public interface ICustomFormatter;

Method
public string Format(string format, object arg, IFormatProvider formatProvider);

System.EventArgs

Module:mscorlib.dll

Hierarchy
Object
EventArgs

Type declaration

[C#] public class EventArgs;

Constructor
public EventArgs();

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Field
public readonly static EventArgs Empty;

System.EventHandler

Module:mscorlib.dll

Hierarchy
Object
Delegate
MulticastDelegate
EventHandler

Type declaration

[C#] public delegate void EventHandler(object sender, EventArgs e);

Constructor
public EventHandler(object object, IntPtr method);

Method
public virtual IAsyncResult BeginInvoke(object sender, EventArgs e, AsyncCallback callback, object object);
public object Clone();
protected override Delegate CombineImpl(Delegate follow);
public object DynamicInvoke(object[] args);
protected virtual object DynamicInvokeImpl(object[] args);
public virtual void EndInvoke(IAsyncResult result);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public override Delegate[] GetInvocationList();
protected virtual MethodInfo GetMethodImpl();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
public override void Invoke(object sender, EventArgs e);
protected object MemberwiseClone();
protected override Delegate RemoveImpl(Delegate value);
public virtual string ToString();

Property
public MethodInfo Method {get;}
public object Target {get;}

System.GC

Module:mscorlib.dll

Hierarchy
Object
GC

Type declaration

[C#] public sealed class GC;

Method
public static void Collect();
public static void Collect(int generation);
public virtual bool Equals(object obj);
protected override void Finalize();
public static int GetGeneration(object obj);
public static int GetGeneration(WeakReference wo);
public virtual int GetHashCode();
public static long GetTotalMemory(bool forceFullCollection);
public Type GetType();
public static void KeepAlive(object obj);
protected object MemberwiseClone();
public static void ReRegisterForFinalize(object obj);
public static void SuppressFinalize(object obj);
public virtual string ToString();
public static void WaitForPendingFinalizers();

Property
public static int MaxGeneration {get;}

System.Void

Module:mscorlib.dll

Hierarchy
Object
ValueType
Void

Type declaration

[C#] public struct Void : ValueType;

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

System.Math

Module:mscorlib.dll

Hierarchy
Object
Math

Type declaration

[C#] public sealed class Math;

Method
public static decimal Abs(decimal value);
public static double Abs(double a);
public static short Abs(short value);
public static int Abs(int value);
public static long Abs(long value);
public static SByte Abs(SByte value);
public static float Abs(float a);
public static double Acos(double d);
public static double Asin(double d);
public static double Atan(double d);
public static double Atan2(double y, double x);
public static long BigMul(int a, int b);
public static double Ceiling(double a);
public static double Cos(double d);
public static double Cosh(double value);
public static int DivRem(int a, int b, ref int result);
public static long DivRem(long a, long b, ref long result);
public virtual bool Equals(object obj);
public static double Exp(double a);
protected override void Finalize();
public static double Floor(double a);
public virtual int GetHashCode();
public Type GetType();
public static double IEEERemainder(double x, double y);
public static double Log(double a);
public static double Log(double a, double newBase);
public static double Log10(double a);
public static byte Max(byte val1, byte val2);
public static decimal Max(decimal val1, decimal val2);
public static double Max(double val1, double val2);
public static short Max(short val1, short val2);
public static int Max(int val1, int val2);
public static long Max(long val1, long val2);
public static SByte Max(SByte val1, SByte val2);
public static float Max(float val1, float val2);
public static ushort Max(ushort val1, ushort val2);
public static uint Max(uint val1, uint val2);
public static ulong Max(ulong val1, ulong val2);
protected object MemberwiseClone();
public static byte Min(byte val1, byte val2);
public static decimal Min(decimal val1, decimal val2);
public static double Min(double val1, double val2);
public static short Min(short val1, short val2);
public static int Min(int val1, int val2);
public static long Min(long val1, long val2);
public static SByte Min(SByte val1, SByte val2);
public static float Min(float val1, float val2);
public static ushort Min(ushort val1, ushort val2);
public static uint Min(uint val1, uint val2);
public static ulong Min(ulong val1, ulong val2);
public static double Pow(double x, double y);
public static decimal Round(decimal d);
public static decimal Round(decimal d, int decimals);
public static double Round(double a);
public static double Round(double value, int digits);
public static int Sign(decimal value);
public static int Sign(double value);
public static int Sign(short value);
public static int Sign(int value);
public static int Sign(long value);
public static int Sign(SByte value);
public static int Sign(float value);
public static double Sin(double a);
public static double Sinh(double value);
public static double Sqrt(double a);
public static double Tan(double a);
public static double Tanh(double value);
public virtual string ToString();

Field
public const double E = 2.71828182845905;
public const double PI = 3.14159265358979;

System.Random

Module:mscorlib.dll

Hierarchy
Object
Random

Type declaration

[C#] public class Random;

Constructor
public Random();
public Random(int Seed);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual int Next();
public virtual int Next(int maxValue);
public virtual int Next(int minValue, int maxValue);
public virtual void NextBytes(byte[] buffer);
public virtual double NextDouble();
protected virtual double Sample();
public virtual string ToString();

System.AsyncCallback

Module:mscorlib.dll

Hierarchy
Object
Delegate
MulticastDelegate
AsyncCallback

Type declaration

[C#] public delegate void AsyncCallback(IAsyncResult ar);

Constructor
public AsyncCallback(object object, IntPtr method);

Method
public virtual IAsyncResult BeginInvoke(IAsyncResult ar, AsyncCallback callback, object object);
public object Clone();
protected override Delegate CombineImpl(Delegate follow);
public object DynamicInvoke(object[] args);
protected virtual object DynamicInvokeImpl(object[] args);
public virtual void EndInvoke(IAsyncResult result);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public override Delegate[] GetInvocationList();
protected virtual MethodInfo GetMethodImpl();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
public override void Invoke(IAsyncResult ar);
protected object MemberwiseClone();
protected override Delegate RemoveImpl(Delegate value);
public virtual string ToString();

Property
public MethodInfo Method {get;}
public object Target {get;}

System.NonSerializedAttribute

Module:mscorlib.dll

Hierarchy
Object
Attribute
NonSerializedAttribute

Type declaration

[C#] public sealed class NonSerializedAttribute : Attribute;

Constructor
public NonSerializedAttribute();

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public object TypeId {get;}

System.BitConverter

Module:mscorlib.dll

Hierarchy
Object
BitConverter

Type declaration

[C#] public sealed class BitConverter;

Method
public static long DoubleToInt64Bits(double value);
public virtual bool Equals(object obj);
protected override void Finalize();
public static byte[] GetBytes(bool value);
public static byte[] GetBytes(char value);
public static byte[] GetBytes(double value);
public static byte[] GetBytes(short value);
public static byte[] GetBytes(int value);
public static byte[] GetBytes(long value);
public static byte[] GetBytes(float value);
public static byte[] GetBytes(ushort value);
public static byte[] GetBytes(uint value);
public static byte[] GetBytes(ulong value);
public virtual int GetHashCode();
public Type GetType();
public static double Int64BitsToDouble(long value);
protected object MemberwiseClone();
public static bool ToBoolean(byte[] value, int startIndex);
public static char ToChar(byte[] value, int startIndex);
public static double ToDouble(byte[] value, int startIndex);
public static short ToInt16(byte[] value, int startIndex);
public static int ToInt32(byte[] value, int startIndex);
public static long ToInt64(byte[] value, int startIndex);
public static float ToSingle(byte[] value, int startIndex);
public virtual string ToString();
public static string ToString(byte[] value);
public static string ToString(byte[] value, int startIndex);
public static string ToString(byte[] value, int startIndex, int length);
public static ushort ToUInt16(byte[] value, int startIndex);
public static uint ToUInt32(byte[] value, int startIndex);
public static ulong ToUInt64(byte[] value, int startIndex);

Field
public readonly static bool IsLittleEndian;

System.IAsyncResult

Module:mscorlib.dll

Hierarchy
IAsyncResult

Type declaration

[C#] public interface IAsyncResult;

Property
public object AsyncState {get;}
public WaitHandle AsyncWaitHandle {get;}
public bool CompletedSynchronously {get;}
public bool IsCompleted {get;}

System.WeakReference

Module:mscorlib.dll

Hierarchy
Object
WeakReference

Type declaration

[C#] public class WeakReference;

Constructor
public WeakReference(object target);
public WeakReference(object target, bool trackResurrection);
protected WeakReference(SerializationInfo info, StreamingContext context);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public virtual void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public virtual bool IsAlive {get;}
public virtual object Target {get; set;}
public virtual bool TrackResurrection {get;}

System.IFormatProvider

Module:mscorlib.dll

Hierarchy
IFormatProvider

Type declaration

[C#] public interface IFormatProvider;

Method
public object GetFormat(Type formatType);

System.IDisposable

Module:mscorlib.dll

Hierarchy
IDisposable

Type declaration

[C#] public interface IDisposable;

Method
public void Dispose();

System.ParamArrayAttribute

Module:mscorlib.dll

Hierarchy
Object
Attribute
ParamArrayAttribute

Type declaration

[C#] public sealed class ParamArrayAttribute : Attribute;

Constructor
public ParamArrayAttribute();

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public object TypeId {get;}

System.TypedReference

Module:mscorlib.dll

Hierarchy
Object
ValueType
TypedReference

Type declaration

[C#] public struct TypedReference : ValueType;

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public static Type GetTargetType(TypedReference value);
public Type GetType();
public static TypedReference MakeTypedReference(object target, FieldInfo[] flds);
protected object MemberwiseClone();
public static void SetTypedReference(TypedReference target, object value);
public static RuntimeTypeHandle TargetTypeToken(TypedReference value);
public static object ToObject(TypedReference value);
public virtual string ToString();

System.CLSCompliantAttribute

Module:mscorlib.dll

Hierarchy
Object
Attribute
CLSCompliantAttribute

Type declaration

[C#] public sealed class CLSCompliantAttribute : Attribute;

Constructor
public CLSCompliantAttribute(bool isCompliant);

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public bool IsCompliant {get;}
public object TypeId {get;}

System.AttributeTargets

Module:mscorlib.dll

Hierarchy
Object
ValueType
Enum
AttributeTargets

Type declaration

[C#] public enum AttributeTargets;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const AttributeTargets All = 16383;
public const AttributeTargets Assembly = 1;
public const AttributeTargets Class = 4;
public const AttributeTargets Constructor = 32;
public const AttributeTargets Delegate = 4096;
public const AttributeTargets Enum = 16;
public const AttributeTargets Event = 512;
public const AttributeTargets Field = 256;
public const AttributeTargets Interface = 1024;
public const AttributeTargets Method = 64;
public const AttributeTargets Module = 2;
public const AttributeTargets Parameter = 2048;
public const AttributeTargets Property = 128;
public const AttributeTargets ReturnValue = 8192;
public const AttributeTargets Struct = 8;
public int value__;

System.AttributeUsageAttribute

Module:mscorlib.dll

Hierarchy
Object
Attribute
AttributeUsageAttribute

Type declaration

[C#] public sealed class AttributeUsageAttribute : Attribute;

Constructor
public AttributeUsageAttribute(AttributeTargets validOn);

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public bool AllowMultiple {get; set;}
public bool Inherited {get; set;}
public object TypeId {get;}
public AttributeTargets ValidOn {get;}

System.Console

Module:mscorlib.dll

Hierarchy
Object
Console

Type declaration

[C#] public sealed class Console;

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public static Stream OpenStandardError();
public static Stream OpenStandardError(int bufferSize);
public static Stream OpenStandardInput();
public static Stream OpenStandardInput(int bufferSize);
public static Stream OpenStandardOutput();
public static Stream OpenStandardOutput(int bufferSize);
public static int Read();
public static string ReadLine();
public static void SetError(TextWriter newError);
public static void SetIn(TextReader newIn);
public static void SetOut(TextWriter newOut);
public virtual string ToString();
public static void Write(bool value);
public static void Write(char value);
public static void Write(char[] buffer);
public static void Write(char[] buffer, int index, int count);
public static void Write(decimal value);
public static void Write(double value);
public static void Write(int value);
public static void Write(long value);
public static void Write(object value);
public static void Write(float value);
public static void Write(string value);
public static void Write(string format, params object[] arg);
public static void Write(string format, object arg0);
public static void Write(string format, object arg0, object arg1);
public static void Write(string format, object arg0, object arg1, object arg2);
public static void Write(string format, object arg0, object arg1, object arg2, object arg3);
public static void Write(uint value);
public static void Write(ulong value);
public static void WriteLine();
public static void WriteLine(bool value);
public static void WriteLine(char value);
public static void WriteLine(char[] buffer);
public static void WriteLine(char[] buffer, int index, int count);
public static void WriteLine(decimal value);
public static void WriteLine(double value);
public static void WriteLine(int value);
public static void WriteLine(long value);
public static void WriteLine(object value);
public static void WriteLine(float value);
public static void WriteLine(string value);
public static void WriteLine(string format, params object[] arg);
public static void WriteLine(string format, object arg0);
public static void WriteLine(string format, object arg0, object arg1);
public static void WriteLine(string format, object arg0, object arg1, object arg2);
public static void WriteLine(string format, object arg0, object arg1, object arg2, object arg3);
public static void WriteLine(uint value);
public static void WriteLine(ulong value);

Property
public static TextWriter Error {get;}
public static TextReader In {get;}
public static TextWriter Out {get;}

System.RuntimeTypeHandle

Module:mscorlib.dll

Hierarchy
Object
ValueType
RuntimeTypeHandle

Type declaration

[C#] public struct RuntimeTypeHandle : ValueType;

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public virtual void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public IntPtr Value {get;}

System.DayOfWeek

Module:mscorlib.dll

Hierarchy
Object
ValueType
Enum
DayOfWeek

Type declaration

[C#] public enum DayOfWeek;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const DayOfWeek Friday = 5;
public const DayOfWeek Monday = 1;
public const DayOfWeek Saturday = 6;
public const DayOfWeek Sunday = 0;
public const DayOfWeek Thursday = 4;
public const DayOfWeek Tuesday = 2;
public int value__;
public const DayOfWeek Wednesday = 3;

System.ObsoleteAttribute

Module:mscorlib.dll

Hierarchy
Object
Attribute
ObsoleteAttribute

Type declaration

[C#] public sealed class ObsoleteAttribute : Attribute;

Constructor
public ObsoleteAttribute();
public ObsoleteAttribute(string message);
public ObsoleteAttribute(string message, bool error);

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public bool IsError {get;}
public string Message {get;}
public object TypeId {get;}

System.MarshalByRefObject

Module:mscorlib.dll

Hierarchy
Object
MarshalByRefObject

Type declaration

[C#] public abstract class MarshalByRefObject;

Constructor
protected MarshalByRefObject();

Method
public virtual ObjRef CreateObjRef(Type requestedType);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public virtual object GetLifetimeService();
public Type GetType();
public virtual object InitializeLifetimeService();
protected object MemberwiseClone();
public virtual string ToString();

System.FlagsAttribute

Module:mscorlib.dll

Hierarchy
Object
Attribute
FlagsAttribute

Type declaration

[C#] public class FlagsAttribute : Attribute;

Constructor
public FlagsAttribute();

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public object TypeId {get;}

System.Attribute

Module:mscorlib.dll

Hierarchy
Object
Attribute

Type declaration

[C#] public abstract class Attribute;

Constructor
protected Attribute();

Method
public override bool Equals(object obj);
protected override void Finalize();
public static Attribute GetCustomAttribute(Assembly element, Type attributeType);
public static Attribute GetCustomAttribute(Assembly element, Type attributeType, bool inherit);
public static Attribute GetCustomAttribute(MemberInfo element, Type attributeType);
public static Attribute GetCustomAttribute(MemberInfo element, Type attributeType, bool inherit);
public static Attribute GetCustomAttribute(Module element, Type attributeType);
public static Attribute GetCustomAttribute(Module element, Type attributeType, bool inherit);
public static Attribute GetCustomAttribute(ParameterInfo element, Type attributeType);
public static Attribute GetCustomAttribute(ParameterInfo element, Type attributeType, bool inherit);
public static Attribute[] GetCustomAttributes(Assembly element);
public static Attribute[] GetCustomAttributes(Assembly element, bool inherit);
public static Attribute[] GetCustomAttributes(Assembly element, Type attributeType);
public static Attribute[] GetCustomAttributes(Assembly element, Type attributeType, bool inherit);
public static Attribute[] GetCustomAttributes(MemberInfo element);
public static Attribute[] GetCustomAttributes(MemberInfo element, bool inherit);
public static Attribute[] GetCustomAttributes(MemberInfo element, Type type);
public static Attribute[] GetCustomAttributes(MemberInfo element, Type type, bool inherit);
public static Attribute[] GetCustomAttributes(Module element);
public static Attribute[] GetCustomAttributes(Module element, bool inherit);
public static Attribute[] GetCustomAttributes(Module element, Type attributeType);
public static Attribute[] GetCustomAttributes(Module element, Type attributeType, bool inherit);
public static Attribute[] GetCustomAttributes(ParameterInfo element);
public static Attribute[] GetCustomAttributes(ParameterInfo element, bool inherit);
public static Attribute[] GetCustomAttributes(ParameterInfo element, Type attributeType);
public static Attribute[] GetCustomAttributes(ParameterInfo element, Type attributeType, bool inherit);
public override int GetHashCode();
public Type GetType();
public virtual bool IsDefaultAttribute();
public static bool IsDefined(Assembly element, Type attributeType);
public static bool IsDefined(Assembly element, Type attributeType, bool inherit);
public static bool IsDefined(MemberInfo element, Type attributeType);
public static bool IsDefined(MemberInfo element, Type attributeType, bool inherit);
public static bool IsDefined(Module element, Type attributeType);
public static bool IsDefined(Module element, Type attributeType, bool inherit);
public static bool IsDefined(ParameterInfo element, Type attributeType);
public static bool IsDefined(ParameterInfo element, Type attributeType, bool inherit);
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public virtual object TypeId {get;}

System.TypeCode

Module:mscorlib.dll

Hierarchy
Object
ValueType
Enum
TypeCode

Type declaration

[C#] public enum TypeCode;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const TypeCode Boolean = 3;
public const TypeCode Byte = 6;
public const TypeCode Char = 4;
public const TypeCode DateTime = 16;
public const TypeCode DBNull = 2;
public const TypeCode Decimal = 15;
public const TypeCode Double = 14;
public const TypeCode Empty = 0;
public const TypeCode Int16 = 7;
public const TypeCode Int32 = 9;
public const TypeCode Int64 = 11;
public const TypeCode Object = 1;
public const TypeCode SByte = 5;
public const TypeCode Single = 13;
public const TypeCode String = 18;
public const TypeCode UInt16 = 8;
public const TypeCode UInt32 = 10;
public const TypeCode UInt64 = 12;
public int value__;

System.Type

Module:mscorlib.dll

Hierarchy
Object
MemberInfo
Type

Type declaration

[C#] public abstract class Type : MemberInfo;

Constructor
protected Type();

Method
public override bool Equals(object o);
public bool Equals(Type o);
protected override void Finalize();
public virtual Type[] FindInterfaces(TypeFilter filter, object filterCriteria);
public virtual MemberInfo[] FindMembers(MemberTypes memberType, BindingFlags bindingAttr, MemberFilter filter, object filterCriteria);
public virtual int GetArrayRank();
protected abstract TypeAttributes GetAttributeFlagsImpl();
public ConstructorInfo GetConstructor(BindingFlags bindingAttr, Binder binder, CallingConventions callConvention, Type[] types, ParameterModifier[] modifiers);
public ConstructorInfo GetConstructor(BindingFlags bindingAttr, Binder binder, Type[] types, ParameterModifier[] modifiers);
public ConstructorInfo GetConstructor(Type[] types);
protected abstract ConstructorInfo GetConstructorImpl(BindingFlags bindingAttr, Binder binder, CallingConventions callConvention, Type[] types, ParameterModifier[] modifiers);
public ConstructorInfo[] GetConstructors();
public abstract ConstructorInfo[] GetConstructors(BindingFlags bindingAttr);
public abstract object[] GetCustomAttributes(bool inherit);
public abstract object[] GetCustomAttributes(Type attributeType, bool inherit);
public virtual MemberInfo[] GetDefaultMembers();
public abstract Type GetElementType();
public EventInfo GetEvent(string name);
public abstract EventInfo GetEvent(string name, BindingFlags bindingAttr);
public virtual EventInfo[] GetEvents();
public abstract EventInfo[] GetEvents(BindingFlags bindingAttr);
public FieldInfo GetField(string name);
public abstract FieldInfo GetField(string name, BindingFlags bindingAttr);
public FieldInfo[] GetFields();
public abstract FieldInfo[] GetFields(BindingFlags bindingAttr);
public override int GetHashCode();
public Type GetInterface(string name);
public abstract Type GetInterface(string name, bool ignoreCase);
public virtual InterfaceMapping GetInterfaceMap(Type interfaceType);
public abstract Type[] GetInterfaces();
public MemberInfo[] GetMember(string name);
public abstract MemberInfo[] GetMember(string name, BindingFlags bindingAttr);
public virtual MemberInfo[] GetMember(string name, MemberTypes type, BindingFlags bindingAttr);
public MemberInfo[] GetMembers();
public abstract MemberInfo[] GetMembers(BindingFlags bindingAttr);
public MethodInfo GetMethod(string name);
public MethodInfo GetMethod(string name, BindingFlags bindingAttr);
public MethodInfo GetMethod(string name, BindingFlags bindingAttr, Binder binder, CallingConventions callConvention, Type[] types, ParameterModifier[] modifiers);
public MethodInfo GetMethod(string name, BindingFlags bindingAttr, Binder binder, Type[] types, ParameterModifier[] modifiers);
public MethodInfo GetMethod(string name, Type[] types);
public MethodInfo GetMethod(string name, Type[] types, ParameterModifier[] modifiers);
protected abstract MethodInfo GetMethodImpl(string name, BindingFlags bindingAttr, Binder binder, CallingConventions callConvention, Type[] types, ParameterModifier[] modifiers);
public MethodInfo[] GetMethods();
public abstract MethodInfo[] GetMethods(BindingFlags bindingAttr);
public Type GetNestedType(string name);
public abstract Type GetNestedType(string name, BindingFlags bindingAttr);
public Type[] GetNestedTypes();
public abstract Type[] GetNestedTypes(BindingFlags bindingAttr);
public PropertyInfo[] GetProperties();
public abstract PropertyInfo[] GetProperties(BindingFlags bindingAttr);
public PropertyInfo GetProperty(string name);
public PropertyInfo GetProperty(string name, BindingFlags bindingAttr);
public PropertyInfo GetProperty(string name, BindingFlags bindingAttr, Binder binder, Type returnType, Type[] types, ParameterModifier[] modifiers);
public PropertyInfo GetProperty(string name, Type returnType);
public PropertyInfo GetProperty(string name, Type returnType, Type[] types);
public PropertyInfo GetProperty(string name, Type returnType, Type[] types, ParameterModifier[] modifiers);
public PropertyInfo GetProperty(string name, Type[] types);
protected abstract PropertyInfo GetPropertyImpl(string name, BindingFlags bindingAttr, Binder binder, Type returnType, Type[] types, ParameterModifier[] modifiers);
public Type GetType();
public static Type GetType(string typeName);
public static Type GetType(string typeName, bool throwOnError);
public static Type GetType(string typeName, bool throwOnError, bool ignoreCase);
public static Type[] GetTypeArray(object[] args);
public static TypeCode GetTypeCode(Type type);
public static Type GetTypeFromCLSID(Guid clsid);
public static Type GetTypeFromCLSID(Guid clsid, bool throwOnError);
public static Type GetTypeFromCLSID(Guid clsid, string server);
public static Type GetTypeFromCLSID(Guid clsid, string server, bool throwOnError);
public static Type GetTypeFromHandle(RuntimeTypeHandle handle);
public static Type GetTypeFromProgID(string progID);
public static Type GetTypeFromProgID(string progID, bool throwOnError);
public static Type GetTypeFromProgID(string progID, string server);
public static Type GetTypeFromProgID(string progID, string server, bool throwOnError);
public static RuntimeTypeHandle GetTypeHandle(object o);
protected abstract bool HasElementTypeImpl();
public object InvokeMember(string name, BindingFlags invokeAttr, Binder binder, object target, object[] args);
public object InvokeMember(string name, BindingFlags invokeAttr, Binder binder, object target, object[] args, CultureInfo culture);
public abstract object InvokeMember(string name, BindingFlags invokeAttr, Binder binder, object target, object[] args, ParameterModifier[] modifiers, CultureInfo culture, string[] namedParameters);
protected abstract bool IsArrayImpl();
public virtual bool IsAssignableFrom(Type c);
protected abstract bool IsByRefImpl();
protected abstract bool IsCOMObjectImpl();
protected virtual bool IsContextfulImpl();
public abstract bool IsDefined(Type attributeType, bool inherit);
public virtual bool IsInstanceOfType(object o);
protected virtual bool IsMarshalByRefImpl();
protected abstract bool IsPointerImpl();
protected abstract bool IsPrimitiveImpl();
public virtual bool IsSubclassOf(Type c);
protected virtual bool IsValueTypeImpl();
protected object MemberwiseClone();
public override string ToString();

Property
public abstract Assembly Assembly {get;}
public abstract string AssemblyQualifiedName {get;}
public TypeAttributes Attributes {get;}
public abstract Type BaseType {get;}
public override Type DeclaringType {get;}
public static Binder DefaultBinder {get;}
public abstract string FullName {get;}
public abstract Guid GUID {get;}
public bool HasElementType {get;}
public bool IsAbstract {get;}
public bool IsAnsiClass {get;}
public bool IsArray {get;}
public bool IsAutoClass {get;}
public bool IsAutoLayout {get;}
public bool IsByRef {get;}
public bool IsClass {get;}
public bool IsCOMObject {get;}
public bool IsContextful {get;}
public bool IsEnum {get;}
public bool IsExplicitLayout {get;}
public bool IsImport {get;}
public bool IsInterface {get;}
public bool IsLayoutSequential {get;}
public bool IsMarshalByRef {get;}
public bool IsNestedAssembly {get;}
public bool IsNestedFamANDAssem {get;}
public bool IsNestedFamily {get;}
public bool IsNestedFamORAssem {get;}
public bool IsNestedPrivate {get;}
public bool IsNestedPublic {get;}
public bool IsNotPublic {get;}
public bool IsPointer {get;}
public bool IsPrimitive {get;}
public bool IsPublic {get;}
public bool IsSealed {get;}
public bool IsSerializable {get;}
public bool IsSpecialName {get;}
public bool IsUnicodeClass {get;}
public bool IsValueType {get;}
public override MemberTypes MemberType {get;}
public abstract Module Module {get;}
public abstract string Name {get;}
public abstract string Namespace {get;}
public override Type ReflectedType {get;}
public abstract RuntimeTypeHandle TypeHandle {get;}
public ConstructorInfo TypeInitializer {get;}
public Type UnderlyingSystemType {get;}

Field
public readonly static char Delimiter;
public readonly static Type[] EmptyTypes;
public readonly static MemberFilter FilterAttribute;
public readonly static MemberFilter FilterName;
public readonly static MemberFilter FilterNameIgnoreCase;
public readonly static object Missing;

System.RankException

Module:mscorlib.dll

Hierarchy
Object
Exception
SystemException
RankException

Type declaration

[C#] public class RankException : SystemException;

Constructor
public RankException();
protected RankException(SerializationInfo info, StreamingContext context);
public RankException(string message);
public RankException(string message, Exception inner);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public virtual string Message {get;}
public string Source {get; set;}
public string StackTrace {get;}
public MethodBase TargetSite {get;}

System.DllNotFoundException

Module:mscorlib.dll

Hierarchy
Object
Exception
SystemException
TypeLoadException
DllNotFoundException

Type declaration

[C#] public class DllNotFoundException : TypeLoadException;

Constructor
public DllNotFoundException();
protected DllNotFoundException(SerializationInfo info, StreamingContext context);
public DllNotFoundException(string message);
public DllNotFoundException(string message, Exception innerException);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public virtual string Message {get;}
public string Source {get; set;}
public string StackTrace {get;}
public MethodBase TargetSite {get;}
public string TypeName {get;}

System.NotFiniteNumberException

Module:mscorlib.dll

Hierarchy
Object
Exception
SystemException
ArithmeticException
NotFiniteNumberException

Type declaration

[C#] public class NotFiniteNumberException : ArithmeticException;

Constructor
public NotFiniteNumberException();
public NotFiniteNumberException(double offendingNumber);
protected NotFiniteNumberException(SerializationInfo info, StreamingContext context);
public NotFiniteNumberException(string message);
public NotFiniteNumberException(string message, double offendingNumber);
public NotFiniteNumberException(string message, double offendingNumber, Exception innerException);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public override void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public virtual string Message {get;}
public double OffendingNumber {get;}
public string Source {get; set;}
public string StackTrace {get;}
public MethodBase TargetSite {get;}

System.MissingFieldException

Module:mscorlib.dll

Hierarchy
Object
Exception
SystemException
MemberAccessException
MissingMemberException
MissingFieldException

Type declaration

[C#] public class MissingFieldException : MissingMemberException;

Constructor
public MissingFieldException();
protected MissingFieldException(SerializationInfo info, StreamingContext context);
public MissingFieldException(string message);
public MissingFieldException(string message, Exception innerException);
public MissingFieldException(string className, string fieldName);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public virtual string Message {get;}
public string Source {get; set;}
public string StackTrace {get;}
public MethodBase TargetSite {get;}

Field
protected string ClassName;
protected string MemberName;
protected byte[] Signature;

System.StackOverflowException

Module:mscorlib.dll

Hierarchy
Object
Exception
SystemException
StackOverflowException

Type declaration

[C#] public sealed class StackOverflowException : SystemException;

Constructor
public StackOverflowException();
public StackOverflowException(string message);
public StackOverflowException(string message, Exception innerException);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public virtual string Message {get;}
public string Source {get; set;}
public string StackTrace {get;}
public MethodBase TargetSite {get;}

System.MulticastNotSupportedException

Module:mscorlib.dll

Hierarchy
Object
Exception
SystemException
MulticastNotSupportedException

Type declaration

[C#] public sealed class MulticastNotSupportedException : SystemException;

Constructor
public MulticastNotSupportedException();
public MulticastNotSupportedException(string message);
public MulticastNotSupportedException(string message, Exception innerException);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public virtual string Message {get;}
public string Source {get; set;}
public string StackTrace {get;}
public MethodBase TargetSite {get;}

System.EntryPointNotFoundException

Module:mscorlib.dll

Hierarchy
Object
Exception
SystemException
TypeLoadException
EntryPointNotFoundException

Type declaration

[C#] public class EntryPointNotFoundException : TypeLoadException;

Constructor
public EntryPointNotFoundException();
protected EntryPointNotFoundException(SerializationInfo info, StreamingContext context);
public EntryPointNotFoundException(string message);
public EntryPointNotFoundException(string message, Exception innerException);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public virtual string Message {get;}
public string Source {get; set;}
public string StackTrace {get;}
public MethodBase TargetSite {get;}
public string TypeName {get;}

System.MissingMethodException

Module:mscorlib.dll

Hierarchy
Object
Exception
SystemException
MemberAccessException
MissingMemberException
MissingMethodException

Type declaration

[C#] public class MissingMethodException : MissingMemberException;

Constructor
public MissingMethodException();
protected MissingMethodException(SerializationInfo info, StreamingContext context);
public MissingMethodException(string message);
public MissingMethodException(string message, Exception innerException);
public MissingMethodException(string className, string methodName);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public virtual string Message {get;}
public string Source {get; set;}
public string StackTrace {get;}
public MethodBase TargetSite {get;}

Field
protected string ClassName;
protected string MemberName;
protected byte[] Signature;

System.MissingMemberException

Module:mscorlib.dll

Hierarchy
Object
Exception
SystemException
MemberAccessException
MissingMemberException

Type declaration

[C#] public class MissingMemberException : MemberAccessException;

Constructor
public MissingMemberException();
protected MissingMemberException(SerializationInfo info, StreamingContext context);
public MissingMemberException(string message);
public MissingMemberException(string message, Exception innerException);
public MissingMemberException(string className, string memberName);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public override void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public virtual string Message {get;}
public string Source {get; set;}
public string StackTrace {get;}
public MethodBase TargetSite {get;}

Field
protected string ClassName;
protected string MemberName;
protected byte[] Signature;

System.MemberAccessException

Module:mscorlib.dll

Hierarchy
Object
Exception
SystemException
MemberAccessException

Type declaration

[C#] public class MemberAccessException : SystemException;

Constructor
public MemberAccessException();
protected MemberAccessException(SerializationInfo info, StreamingContext context);
public MemberAccessException(string message);
public MemberAccessException(string message, Exception innerException);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public virtual string Message {get;}
public string Source {get; set;}
public string StackTrace {get;}
public MethodBase TargetSite {get;}

System.TypeLoadException

Module:mscorlib.dll

Hierarchy
Object
Exception
SystemException
TypeLoadException

Type declaration

[C#] public class TypeLoadException : SystemException;

Constructor
public TypeLoadException();
protected TypeLoadException(SerializationInfo info, StreamingContext context);
public TypeLoadException(string message);
public TypeLoadException(string message, Exception innerException);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public override void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public virtual string Message {get;}
public string Source {get; set;}
public string StackTrace {get;}
public MethodBase TargetSite {get;}
public string TypeName {get;}

System.UnauthorizedAccessException

Module:mscorlib.dll

Hierarchy
Object
Exception
SystemException
UnauthorizedAccessException

Type declaration

[C#] public class UnauthorizedAccessException : SystemException;

Constructor
public UnauthorizedAccessException();
protected UnauthorizedAccessException(SerializationInfo info, StreamingContext context);
public UnauthorizedAccessException(string message);
public UnauthorizedAccessException(string message, Exception innerException);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public virtual string Message {get;}
public string Source {get; set;}
public string StackTrace {get;}
public MethodBase TargetSite {get;}

System.InvalidProgramException

Module:mscorlib.dll

Hierarchy
Object
Exception
SystemException
InvalidProgramException

Type declaration

[C#] public sealed class InvalidProgramException : SystemException;

Constructor
public InvalidProgramException();
public InvalidProgramException(string message);
public InvalidProgramException(string message, Exception innerException);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public virtual string Message {get;}
public string Source {get; set;}
public string StackTrace {get;}
public MethodBase TargetSite {get;}

System.FormatException

Module:mscorlib.dll

Hierarchy
Object
Exception
SystemException
FormatException

Type declaration

[C#] public class FormatException : SystemException;

Constructor
public FormatException();
protected FormatException(SerializationInfo info, StreamingContext context);
public FormatException(string message);
public FormatException(string message, Exception innerException);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public virtual string Message {get;}
public string Source {get; set;}
public string StackTrace {get;}
public MethodBase TargetSite {get;}

System.ApplicationException

Module:mscorlib.dll

Hierarchy
Object
Exception
ApplicationException

Type declaration

[C#] public class ApplicationException : Exception;

Constructor
public ApplicationException();
protected ApplicationException(SerializationInfo info, StreamingContext context);
public ApplicationException(string message);
public ApplicationException(string message, Exception innerException);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public virtual string Message {get;}
public string Source {get; set;}
public string StackTrace {get;}
public MethodBase TargetSite {get;}

System.ObjectDisposedException

Module:mscorlib.dll

Hierarchy
Object
Exception
SystemException
InvalidOperationException
ObjectDisposedException

Type declaration

[C#] public class ObjectDisposedException : InvalidOperationException;

Constructor
protected ObjectDisposedException(SerializationInfo info, StreamingContext context);
public ObjectDisposedException(string objectName);
public ObjectDisposedException(string objectName, string message);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public override void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public virtual string Message {get;}
public string ObjectName {get;}
public string Source {get; set;}
public string StackTrace {get;}
public MethodBase TargetSite {get;}

System.InvalidOperationException

Module:mscorlib.dll

Hierarchy
Object
Exception
SystemException
InvalidOperationException

Type declaration

[C#] public class InvalidOperationException : SystemException;

Constructor
public InvalidOperationException();
protected InvalidOperationException(SerializationInfo info, StreamingContext context);
public InvalidOperationException(string message);
public InvalidOperationException(string message, Exception inner);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public virtual string Message {get;}
public string Source {get; set;}
public string StackTrace {get;}
public MethodBase TargetSite {get;}

System.PlatformNotSupportedException

Module:mscorlib.dll

Hierarchy
Object
Exception
SystemException
NotSupportedException
PlatformNotSupportedException

Type declaration

[C#] public class PlatformNotSupportedException : NotSupportedException;

Constructor
public PlatformNotSupportedException();
protected PlatformNotSupportedException(SerializationInfo info, StreamingContext context);
public PlatformNotSupportedException(string message);
public PlatformNotSupportedException(string message, Exception innerException);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public virtual string Message {get;}
public string Source {get; set;}
public string StackTrace {get;}
public MethodBase TargetSite {get;}

System.NotSupportedException

Module:mscorlib.dll

Hierarchy
Object
Exception
SystemException
NotSupportedException

Type declaration

[C#] public class NotSupportedException : SystemException;

Constructor
public NotSupportedException();
protected NotSupportedException(SerializationInfo info, StreamingContext context);
public NotSupportedException(string message);
public NotSupportedException(string message, Exception innerException);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public virtual string Message {get;}
public string Source {get; set;}
public string StackTrace {get;}
public MethodBase TargetSite {get;}

System.ArgumentNullException

Module:mscorlib.dll

Hierarchy
Object
Exception
SystemException
ArgumentException
ArgumentNullException

Type declaration

[C#] public class ArgumentNullException : ArgumentException;

Constructor
public ArgumentNullException();
protected ArgumentNullException(SerializationInfo info, StreamingContext context);
public ArgumentNullException(string paramName);
public ArgumentNullException(string paramName, string message);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public virtual string Message {get;}
public string ParamName {get;}
public string Source {get; set;}
public string StackTrace {get;}
public MethodBase TargetSite {get;}

System.ArgumentOutOfRangeException

Module:mscorlib.dll

Hierarchy
Object
Exception
SystemException
ArgumentException
ArgumentOutOfRangeException

Type declaration

[C#] public class ArgumentOutOfRangeException : ArgumentException;

Constructor
public ArgumentOutOfRangeException();
protected ArgumentOutOfRangeException(SerializationInfo info, StreamingContext context);
public ArgumentOutOfRangeException(string message);
public ArgumentOutOfRangeException(string paramName, object actualValue, string message);
public ArgumentOutOfRangeException(string paramName, string message);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public override void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public virtual object ActualValue {get;}
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public virtual string Message {get;}
public string ParamName {get;}
public string Source {get; set;}
public string StackTrace {get;}
public MethodBase TargetSite {get;}

System.ArgumentException

Module:mscorlib.dll

Hierarchy
Object
Exception
SystemException
ArgumentException

Type declaration

[C#] public class ArgumentException : SystemException;

Constructor
public ArgumentException();
protected ArgumentException(SerializationInfo info, StreamingContext context);
public ArgumentException(string message);
public ArgumentException(string message, Exception innerException);
public ArgumentException(string message, string paramName);
public ArgumentException(string message, string paramName, Exception innerException);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public override void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public virtual string Message {get;}
public virtual string ParamName {get;}
public string Source {get; set;}
public string StackTrace {get;}
public MethodBase TargetSite {get;}

System.ArrayTypeMismatchException

Module:mscorlib.dll

Hierarchy
Object
Exception
SystemException
ArrayTypeMismatchException

Type declaration

[C#] public class ArrayTypeMismatchException : SystemException;

Constructor
public ArrayTypeMismatchException();
protected ArrayTypeMismatchException(SerializationInfo info, StreamingContext context);
public ArrayTypeMismatchException(string message);
public ArrayTypeMismatchException(string message, Exception innerException);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public virtual string Message {get;}
public string Source {get; set;}
public string StackTrace {get;}
public MethodBase TargetSite {get;}

System.DivideByZeroException

Module:mscorlib.dll

Hierarchy
Object
Exception
SystemException
ArithmeticException
DivideByZeroException

Type declaration

[C#] public class DivideByZeroException : ArithmeticException;

Constructor
public DivideByZeroException();
protected DivideByZeroException(SerializationInfo info, StreamingContext context);
public DivideByZeroException(string message);
public DivideByZeroException(string message, Exception innerException);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public virtual string Message {get;}
public string Source {get; set;}
public string StackTrace {get;}
public MethodBase TargetSite {get;}

System.OverflowException

Module:mscorlib.dll

Hierarchy
Object
Exception
SystemException
ArithmeticException
OverflowException

Type declaration

[C#] public class OverflowException : ArithmeticException;

Constructor
public OverflowException();
protected OverflowException(SerializationInfo info, StreamingContext context);
public OverflowException(string message);
public OverflowException(string message, Exception innerException);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public virtual string Message {get;}
public string Source {get; set;}
public string StackTrace {get;}
public MethodBase TargetSite {get;}

System.ArithmeticException

Module:mscorlib.dll

Hierarchy
Object
Exception
SystemException
ArithmeticException

Type declaration

[C#] public class ArithmeticException : SystemException;

Constructor
public ArithmeticException();
protected ArithmeticException(SerializationInfo info, StreamingContext context);
public ArithmeticException(string message);
public ArithmeticException(string message, Exception innerException);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public virtual string Message {get;}
public string Source {get; set;}
public string StackTrace {get;}
public MethodBase TargetSite {get;}

System.IndexOutOfRangeException

Module:mscorlib.dll

Hierarchy
Object
Exception
SystemException
IndexOutOfRangeException

Type declaration

[C#] public sealed class IndexOutOfRangeException : SystemException;

Constructor
public IndexOutOfRangeException();
public IndexOutOfRangeException(string message);
public IndexOutOfRangeException(string message, Exception innerException);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public virtual string Message {get;}
public string Source {get; set;}
public string StackTrace {get;}
public MethodBase TargetSite {get;}

System.InvalidCastException

Module:mscorlib.dll

Hierarchy
Object
Exception
SystemException
InvalidCastException

Type declaration

[C#] public class InvalidCastException : SystemException;

Constructor
public InvalidCastException();
protected InvalidCastException(SerializationInfo info, StreamingContext context);
public InvalidCastException(string message);
public InvalidCastException(string message, Exception innerException);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public virtual string Message {get;}
public string Source {get; set;}
public string StackTrace {get;}
public MethodBase TargetSite {get;}

System.OutOfMemoryException

Module:mscorlib.dll

Hierarchy
Object
Exception
SystemException
OutOfMemoryException

Type declaration

[C#] public class OutOfMemoryException : SystemException;

Constructor
public OutOfMemoryException();
protected OutOfMemoryException(SerializationInfo info, StreamingContext context);
public OutOfMemoryException(string message);
public OutOfMemoryException(string message, Exception innerException);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public virtual string Message {get;}
public string Source {get; set;}
public string StackTrace {get;}
public MethodBase TargetSite {get;}

System.NullReferenceException

Module:mscorlib.dll

Hierarchy
Object
Exception
SystemException
NullReferenceException

Type declaration

[C#] public class NullReferenceException : SystemException;

Constructor
public NullReferenceException();
protected NullReferenceException(SerializationInfo info, StreamingContext context);
public NullReferenceException(string message);
public NullReferenceException(string message, Exception innerException);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public virtual string Message {get;}
public string Source {get; set;}
public string StackTrace {get;}
public MethodBase TargetSite {get;}

System.SystemException

Module:mscorlib.dll

Hierarchy
Object
Exception
SystemException

Type declaration

[C#] public class SystemException : Exception;

Constructor
public SystemException();
protected SystemException(SerializationInfo info, StreamingContext context);
public SystemException(string message);
public SystemException(string message, Exception innerException);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public virtual string Message {get;}
public string Source {get; set;}
public string StackTrace {get;}
public MethodBase TargetSite {get;}

System.Exception

Module:mscorlib.dll

Hierarchy
Object
Exception

Type declaration

[C#] public class Exception;

Constructor
public Exception();
protected Exception(SerializationInfo info, StreamingContext context);
public Exception(string message);
public Exception(string message, Exception innerException);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public virtual void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public virtual string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public virtual string Message {get;}
public virtual string Source {get; set;}
public virtual string StackTrace {get;}
public MethodBase TargetSite {get;}

System.Array

Module:mscorlib.dll

Hierarchy
Object
Array : ICloneable, IList, ICollection, IEnumerable

Type declaration

[C#] public abstract class Array: ICloneable, IList, ICollection, IEnumerable;

Method
public static int BinarySearch(Array array, int index, int length, object value);
public static int BinarySearch(Array array, int index, int length, object value, IComparer comparer);
public static int BinarySearch(Array array, object value);
public static int BinarySearch(Array array, object value, IComparer comparer);
public static void Clear(Array array, int index, int length);
public virtual object Clone();
public static void Copy(Array sourceArray, Array destinationArray, int length);
public static void Copy(Array sourceArray, Array destinationArray, long length);
public static void Copy(Array sourceArray, int sourceIndex, Array destinationArray, int destinationIndex, int length);
public static void Copy(Array sourceArray, long sourceIndex, Array destinationArray, long destinationIndex, long length);
public virtual void CopyTo(Array array, int index);
public virtual void CopyTo(Array array, long index);
public static Array CreateInstance(Type elementType, params int[] lengths);
public static Array CreateInstance(Type elementType, params long[] lengths);
public static Array CreateInstance(Type elementType, int length);
public static Array CreateInstance(Type elementType, int length1, int length2);
public static Array CreateInstance(Type elementType, int length1, int length2, int length3);
public static Array CreateInstance(Type elementType, int[] lengths, int[] lowerBounds);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual IEnumerator GetEnumerator();
public virtual int GetHashCode();
public int GetLength(int dimension);
public long GetLongLength(int dimension);
public int GetLowerBound(int dimension);
public Type GetType();
public int GetUpperBound(int dimension);
public object GetValue(params int[] indices);
public object GetValue(params long[] indices);
public object GetValue(int index);
public object GetValue(int index1, int index2);
public object GetValue(int index1, int index2, int index3);
public object GetValue(long index);
public object GetValue(long index1, long index2);
public object GetValue(long index1, long index2, long index3);
public static int IndexOf(Array array, object value);
public static int IndexOf(Array array, object value, int startIndex);
public static int IndexOf(Array array, object value, int startIndex, int count);
public void Initialize();
public static int LastIndexOf(Array array, object value);
public static int LastIndexOf(Array array, object value, int startIndex);
public static int LastIndexOf(Array array, object value, int startIndex, int count);
protected object MemberwiseClone();
public static void Reverse(Array array);
public static void Reverse(Array array, int index, int length);
public void SetValue(object value, params int[] indices);
public void SetValue(object value, params long[] indices);
public void SetValue(object value, int index);
public void SetValue(object value, int index1, int index2);
public void SetValue(object value, int index1, int index2, int index3);
public void SetValue(object value, long index);
public void SetValue(object value, long index1, long index2);
public void SetValue(object value, long index1, long index2, long index3);
public static void Sort(Array array);
public static void Sort(Array keys, Array items);
public static void Sort(Array keys, Array items, IComparer comparer);
public static void Sort(Array keys, Array items, int index, int length);
public static void Sort(Array keys, Array items, int index, int length, IComparer comparer);
public static void Sort(Array array, IComparer comparer);
public static void Sort(Array array, int index, int length);
public static void Sort(Array array, int index, int length, IComparer comparer);
public virtual string ToString();

Property
public virtual bool IsFixedSize {get;}
public virtual bool IsReadOnly {get;}
public virtual bool IsSynchronized {get;}
public int Length {get;}
public long LongLength {get;}
public int Rank {get;}
public virtual object SyncRoot {get;}

System.MulticastDelegate

Module:mscorlib.dll

Hierarchy
Object
Delegate
MulticastDelegate

Type declaration

[C#] public abstract class MulticastDelegate : Delegate;

Constructor
protected MulticastDelegate(object target, string method);
protected MulticastDelegate(Type target, string method);

Method
public object Clone();
protected override Delegate CombineImpl(Delegate follow);
public object DynamicInvoke(object[] args);
protected virtual object DynamicInvokeImpl(object[] args);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public override Delegate[] GetInvocationList();
protected virtual MethodInfo GetMethodImpl();
public override void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public static bool op_Equality(MulticastDelegate d1, MulticastDelegate d2);
public static bool op_Inequality(MulticastDelegate d1, MulticastDelegate d2);
protected override Delegate RemoveImpl(Delegate value);
public virtual string ToString();

Property
public MethodInfo Method {get;}
public object Target {get;}

System.Delegate

Module:mscorlib.dll

Hierarchy
Object
Delegate

Type declaration

[C#] public abstract class Delegate;

Constructor
protected Delegate(object target, string method);
protected Delegate(Type target, string method);

Method
public virtual object Clone();
public static Delegate Combine(Delegate a, Delegate b);
public static Delegate Combine(Delegate[] delegates);
protected virtual Delegate CombineImpl(Delegate d);
public static Delegate CreateDelegate(Type type, MethodInfo method);
public static Delegate CreateDelegate(Type type, object target, string method);
public static Delegate CreateDelegate(Type type, object target, string method, bool ignoreCase);
public static Delegate CreateDelegate(Type type, Type target, string method);
public object DynamicInvoke(object[] args);
protected virtual object DynamicInvokeImpl(object[] args);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public virtual Delegate[] GetInvocationList();
protected virtual MethodInfo GetMethodImpl();
public virtual void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public static bool op_Equality(Delegate d1, Delegate d2);
public static bool op_Inequality(Delegate d1, Delegate d2);
public static Delegate Remove(Delegate source, Delegate value);
public static Delegate RemoveAll(Delegate source, Delegate value);
protected virtual Delegate RemoveImpl(Delegate d);
public virtual string ToString();

Property
public MethodInfo Method {get;}
public object Target {get;}

System.CharEnumerator

Module:mscorlib.dll

Hierarchy
Object
CharEnumerator : IEnumerator, ICloneable

Type declaration

[C#] public sealed class CharEnumerator: IEnumerator, ICloneable;

Method
public virtual object Clone();
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual bool MoveNext();
public virtual void Reset();
public virtual string ToString();

Property
public char Current {get;}

System.String

Module:mscorlib.dll

Hierarchy
Object
String : IComparable, IConvertible, IEnumerable

Type declaration

[C#] public sealed class String: IComparable, IConvertible, IEnumerable;

Constructor
public String(char* value);
public String(char* value, int startIndex, int length);
public String(char c, int count);
public String(char[] value);
public String(char[] value, int startIndex, int length);
public String(SByte* value);
public String(SByte* value, int startIndex, int length);
public String(SByte* value, int startIndex, int length, Encoding enc);

Method
public object Clone();
public static int Compare(string strA, int indexA, string strB, int indexB, int length);
public static int Compare(string strA, int indexA, string strB, int indexB, int length, bool ignoreCase);
public static int Compare(string strA, int indexA, string strB, int indexB, int length, bool ignoreCase, CultureInfo culture);
public static int Compare(string strA, string strB);
public static int Compare(string strA, string strB, bool ignoreCase);
public static int Compare(string strA, string strB, bool ignoreCase, CultureInfo culture);
public static int CompareOrdinal(string strA, int indexA, string strB, int indexB, int length);
public static int CompareOrdinal(string strA, string strB);
public virtual int CompareTo(object value);
public int CompareTo(string strB);
public static string Concat(params object[] args);
public static string Concat(params string[] values);
public static string Concat(object arg0);
public static string Concat(object arg0, object arg1);
public static string Concat(object arg0, object arg1, object arg2);
public static string Concat(object arg0, object arg1, object arg2, object arg3);
public static string Concat(string str0, string str1);
public static string Concat(string str0, string str1, string str2);
public static string Concat(string str0, string str1, string str2, string str3);
public static string Copy(string str);
public void CopyTo(int sourceIndex, char[] destination, int destinationIndex, int count);
public bool EndsWith(string value);
public override bool Equals(object obj);
public bool Equals(string value);
public static bool Equals(string a, string b);
protected override void Finalize();
public static string Format(IFormatProvider provider, string format, params object[] args);
public static string Format(string format, params object[] args);
public static string Format(string format, object arg0);
public static string Format(string format, object arg0, object arg1);
public static string Format(string format, object arg0, object arg1, object arg2);
public CharEnumerator GetEnumerator();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
public int IndexOf(char value);
public int IndexOf(char value, int startIndex);
public int IndexOf(char value, int startIndex, int count);
public int IndexOf(string value);
public int IndexOf(string value, int startIndex);
public int IndexOf(string value, int startIndex, int count);
public int IndexOfAny(char[] anyOf);
public int IndexOfAny(char[] anyOf, int startIndex);
public int IndexOfAny(char[] anyOf, int startIndex, int count);
public string Insert(int startIndex, string value);
public static string Intern(string str);
public static string IsInterned(string str);
public static string Join(string separator, string[] value);
public static string Join(string separator, string[] value, int startIndex, int count);
public int LastIndexOf(char value);
public int LastIndexOf(char value, int startIndex);
public int LastIndexOf(char value, int startIndex, int count);
public int LastIndexOf(string value);
public int LastIndexOf(string value, int startIndex);
public int LastIndexOf(string value, int startIndex, int count);
public int LastIndexOfAny(char[] anyOf);
public int LastIndexOfAny(char[] anyOf, int startIndex);
public int LastIndexOfAny(char[] value, int startIndex, int count);
protected object MemberwiseClone();
public static bool op_Equality(string a, string b);
public static bool op_Inequality(string a, string b);
public string PadLeft(int totalWidth);
public string PadLeft(int totalWidth, char paddingChar);
public string PadRight(int totalWidth);
public string PadRight(int totalWidth, char paddingChar);
public string Remove(int startIndex, int count);
public string Replace(char oldChar, char newChar);
public string Replace(string oldValue, string newValue);
public string[] Split(params char[] separator);
public string[] Split(char[] separator, int count);
public bool StartsWith(string value);
public string Substring(int startIndex);
public string Substring(int startIndex, int length);
public char[] ToCharArray();
public char[] ToCharArray(int startIndex, int length);
public string ToLower();
public string ToLower(CultureInfo culture);
public override string ToString();
public virtual string ToString(IFormatProvider provider);
public string ToUpper();
public string ToUpper(CultureInfo culture);
public string Trim();
public string Trim(params char[] trimChars);
public string TrimEnd(params char[] trimChars);
public string TrimStart(params char[] trimChars);

Property
public char Chars[int index] {get;}
public int Length {get;}

Field
public readonly static string Empty;

System.PlatformID

Module:mscorlib.dll

Hierarchy
Object
ValueType
Enum
PlatformID

Type declaration

[C#] public enum PlatformID;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public int value__;
public const PlatformID Win32NT = 2;
public const PlatformID Win32S = 0;
public const PlatformID Win32Windows = 1;
public const PlatformID WinCE = 3;

System.Enum

Module:mscorlib.dll

Hierarchy
Object
ValueType
Enum : IConvertible

Type declaration

[C#] public abstract class Enum : ValueType, IConvertible;

Constructor
protected Enum();

Method
public virtual int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public static string Format(Type enumType, object value, string format);
public override int GetHashCode();
public static string GetName(Type enumType, object value);
public static string[] GetNames(Type enumType);
public Type GetType();
public virtual TypeCode GetTypeCode();
public static Type GetUnderlyingType(Type enumType);
public static Array GetValues(Type enumType);
public static bool IsDefined(Type enumType, object value);
protected object MemberwiseClone();
public static object Parse(Type enumType, string value);
public static object Parse(Type enumType, string value, bool ignoreCase);
public static object ToObject(Type enumType, byte value);
public static object ToObject(Type enumType, short value);
public static object ToObject(Type enumType, int value);
public static object ToObject(Type enumType, long value);
public static object ToObject(Type enumType, object value);
public static object ToObject(Type enumType, SByte value);
public static object ToObject(Type enumType, ushort value);
public static object ToObject(Type enumType, uint value);
public static object ToObject(Type enumType, ulong value);
public override string ToString();
public virtual string ToString(IFormatProvider provider);
public string ToString(string format);
public virtual string ToString(string format, IFormatProvider provider);

System.OperatingSystem

Module:mscorlib.dll

Hierarchy
Object
OperatingSystem : ICloneable

Type declaration

[C#] public sealed class OperatingSystem: ICloneable;

Constructor
public OperatingSystem(PlatformID platform, Version version);

Method
public virtual object Clone();
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public PlatformID Platform {get;}
public Version Version {get;}

System.ICloneable

Module:mscorlib.dll

Hierarchy
ICloneable

Type declaration

[C#] public interface ICloneable;

Method
public object Clone();

System.UIntPtr

Module:mscorlib.dll

Hierarchy
Object
ValueType
UIntPtr

Type declaration

[C#] public struct UIntPtr : ValueType;

Constructor
public UIntPtr(uint value);
public UIntPtr(ulong value);
public UIntPtr(void* value);

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public static bool op_Equality(UIntPtr value1, UIntPtr value2);
public static UIntPtr op_Explicit(uint value);
public static UIntPtr op_Explicit(ulong value);
public static uint op_Explicit(UIntPtr value);
public static ulong op_Explicit(UIntPtr value);
public static void* op_Explicit(UIntPtr value);
public static UIntPtr op_Explicit(void* value);
public static bool op_Inequality(UIntPtr value1, UIntPtr value2);
public void* ToPointer();
public override string ToString();
public uint ToUInt32();
public ulong ToUInt64();

Property
public static int Size {get;}

Field
public readonly static UIntPtr Zero;

System.UInt64

Module:mscorlib.dll

Hierarchy
Object
ValueType
UInt64 : IFormattable, IConvertible, IComparable

Type declaration

[C#] public struct UInt64 : ValueType, IFormattable, IConvertible, IComparable;

Method
public virtual int CompareTo(object value);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public static ulong Parse(string s);
public static ulong Parse(string s, IFormatProvider provider);
public static ulong Parse(string s, NumberStyles style);
public static ulong Parse(string s, NumberStyles style, IFormatProvider provider);
public override string ToString();
public virtual string ToString(IFormatProvider provider);
public string ToString(string format);
public virtual string ToString(string format, IFormatProvider provider);

Field
public const ulong MaxValue = 18446744073709551615;
public const ulong MinValue = 0;

System.UInt32

Module:mscorlib.dll

Hierarchy
Object
ValueType
UInt32 : IFormattable, IConvertible, IComparable

Type declaration

[C#] public struct UInt32 : ValueType, IFormattable, IConvertible, IComparable;

Method
public virtual int CompareTo(object value);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public static uint Parse(string s);
public static uint Parse(string s, IFormatProvider provider);
public static uint Parse(string s, NumberStyles style);
public static uint Parse(string s, NumberStyles style, IFormatProvider provider);
public override string ToString();
public virtual string ToString(IFormatProvider provider);
public string ToString(string format);
public virtual string ToString(string format, IFormatProvider provider);

Field
public const uint MaxValue = 4294967295;
public const uint MinValue = 0;

System.UInt16

Module:mscorlib.dll

Hierarchy
Object
ValueType
UInt16 : IFormattable, IConvertible, IComparable

Type declaration

[C#] public struct UInt16 : ValueType, IFormattable, IConvertible, IComparable;

Method
public virtual int CompareTo(object value);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public static ushort Parse(string s);
public static ushort Parse(string s, IFormatProvider provider);
public static ushort Parse(string s, NumberStyles style);
public static ushort Parse(string s, NumberStyles style, IFormatProvider provider);
public override string ToString();
public virtual string ToString(IFormatProvider provider);
public string ToString(string format);
public virtual string ToString(string format, IFormatProvider provider);

Field
public const ushort MaxValue = 65535;
public const ushort MinValue = 0;

System.SByte

Module:mscorlib.dll

Hierarchy
Object
ValueType
SByte : IFormattable, IConvertible, IComparable

Type declaration

[C#] public struct SByte : ValueType, IFormattable, IConvertible, IComparable;

Method
public virtual int CompareTo(object obj);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public static SByte Parse(string s);
public static SByte Parse(string s, IFormatProvider provider);
public static SByte Parse(string s, NumberStyles style);
public static SByte Parse(string s, NumberStyles style, IFormatProvider provider);
public override string ToString();
public virtual string ToString(IFormatProvider provider);
public string ToString(string format);
public virtual string ToString(string format, IFormatProvider provider);

Field
public const SByte MaxValue = 127;
public const SByte MinValue = -128;

System.Boolean

Module:mscorlib.dll

Hierarchy
Object
ValueType
Boolean : IComparable, IConvertible

Type declaration

[C#] public struct Boolean : ValueType, IComparable, IConvertible;

Method
public virtual int CompareTo(object obj);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public static bool Parse(string value);
public override string ToString();
public virtual string ToString(IFormatProvider provider);

Field
public readonly static string FalseString;
public readonly static string TrueString;

System.Char

Module:mscorlib.dll

Hierarchy
Object
ValueType
Char : IConvertible, IComparable

Type declaration

[C#] public struct Char : ValueType, IConvertible, IComparable;

Method
public virtual int CompareTo(object value);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public static double GetNumericValue(char c);
public static double GetNumericValue(string s, int index);
public Type GetType();
public virtual TypeCode GetTypeCode();
public static UnicodeCategory GetUnicodeCategory(char c);
public static UnicodeCategory GetUnicodeCategory(string s, int index);
public static bool IsControl(char c);
public static bool IsControl(string s, int index);
public static bool IsDigit(char c);
public static bool IsDigit(string s, int index);
public static bool IsLetter(char c);
public static bool IsLetter(string s, int index);
public static bool IsLetterOrDigit(char c);
public static bool IsLetterOrDigit(string s, int index);
public static bool IsLower(char c);
public static bool IsLower(string s, int index);
public static bool IsNumber(char c);
public static bool IsNumber(string s, int index);
public static bool IsPunctuation(char c);
public static bool IsPunctuation(string s, int index);
public static bool IsSeparator(char c);
public static bool IsSeparator(string s, int index);
public static bool IsSurrogate(char c);
public static bool IsSurrogate(string s, int index);
public static bool IsSymbol(char c);
public static bool IsSymbol(string s, int index);
public static bool IsUpper(char c);
public static bool IsUpper(string s, int index);
public static bool IsWhiteSpace(char c);
public static bool IsWhiteSpace(string s, int index);
protected object MemberwiseClone();
public static char Parse(string s);
public static char ToLower(char c);
public static char ToLower(char c, CultureInfo culture);
public override string ToString();
public static string ToString(char c);
public virtual string ToString(IFormatProvider provider);
public static char ToUpper(char c);
public static char ToUpper(char c, CultureInfo culture);

Field
public const char MaxValue = 0xFFFF;
public const char MinValue = 0x0000;

System.Decimal

Module:mscorlib.dll

Hierarchy
Object
ValueType
Decimal : IFormattable, IComparable, IConvertible

Type declaration

[C#] public struct Decimal : ValueType, IFormattable, IComparable, IConvertible;

Constructor
public Decimal(double value);
public Decimal(int value);
public Decimal(int lo, int mid, int hi, bool isNegative, byte scale);
public Decimal(int[] bits);
public Decimal(long value);
public Decimal(float value);
public Decimal(uint value);
public Decimal(ulong value);

Method
public static decimal Add(decimal d1, decimal d2);
public static int Compare(decimal d1, decimal d2);
public virtual int CompareTo(object value);
public static decimal Divide(decimal d1, decimal d2);
public static bool Equals(decimal d1, decimal d2);
public override bool Equals(object value);
protected override void Finalize();
public static decimal Floor(decimal d);
public static decimal FromOACurrency(long cy);
public static int[] GetBits(decimal d);
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public static decimal Multiply(decimal d1, decimal d2);
public static decimal Negate(decimal d);
public static decimal op_Addition(decimal d1, decimal d2);
public static decimal op_Decrement(decimal d);
public static decimal op_Division(decimal d1, decimal d2);
public static bool op_Equality(decimal d1, decimal d2);
public static byte op_Explicit(decimal value);
public static char op_Explicit(decimal value);
public static double op_Explicit(decimal value);
public static short op_Explicit(decimal value);
public static int op_Explicit(decimal value);
public static long op_Explicit(decimal value);
public static SByte op_Explicit(decimal value);
public static float op_Explicit(decimal value);
public static ushort op_Explicit(decimal value);
public static uint op_Explicit(decimal value);
public static ulong op_Explicit(decimal value);
public static decimal op_Explicit(double value);
public static decimal op_Explicit(float value);
public static bool op_GreaterThan(decimal d1, decimal d2);
public static bool op_GreaterThanOrEqual(decimal d1, decimal d2);
public static decimal op_Implicit(byte value);
public static decimal op_Implicit(char value);
public static decimal op_Implicit(short value);
public static decimal op_Implicit(int value);
public static decimal op_Implicit(long value);
public static decimal op_Implicit(SByte value);
public static decimal op_Implicit(ushort value);
public static decimal op_Implicit(uint value);
public static decimal op_Implicit(ulong value);
public static decimal op_Increment(decimal d);
public static bool op_Inequality(decimal d1, decimal d2);
public static bool op_LessThan(decimal d1, decimal d2);
public static bool op_LessThanOrEqual(decimal d1, decimal d2);
public static decimal op_Modulus(decimal d1, decimal d2);
public static decimal op_Multiply(decimal d1, decimal d2);
public static decimal op_Subtraction(decimal d1, decimal d2);
public static decimal op_UnaryNegation(decimal d);
public static decimal op_UnaryPlus(decimal d);
public static decimal Parse(string s);
public static decimal Parse(string s, IFormatProvider provider);
public static decimal Parse(string s, NumberStyles style);
public static decimal Parse(string s, NumberStyles style, IFormatProvider provider);
public static decimal Remainder(decimal d1, decimal d2);
public static decimal Round(decimal d, int decimals);
public static decimal Subtract(decimal d1, decimal d2);
public static byte ToByte(decimal value);
public static double ToDouble(decimal d);
public static short ToInt16(decimal value);
public static int ToInt32(decimal d);
public static long ToInt64(decimal d);
public static long ToOACurrency(decimal value);
public static SByte ToSByte(decimal value);
public static float ToSingle(decimal d);
public override string ToString();
public virtual string ToString(IFormatProvider provider);
public string ToString(string format);
public virtual string ToString(string format, IFormatProvider provider);
public static ushort ToUInt16(decimal value);
public static uint ToUInt32(decimal d);
public static ulong ToUInt64(decimal d);
public static decimal Truncate(decimal d);

Field
public readonly static decimal MaxValue;
public readonly static decimal MinusOne;
public readonly static decimal MinValue;
public readonly static decimal One;
public readonly static decimal Zero;

System.Double

Module:mscorlib.dll

Hierarchy
Object
ValueType
Double : IComparable, IFormattable, IConvertible

Type declaration

[C#] public struct Double : ValueType, IComparable, IFormattable, IConvertible;

Method
public virtual int CompareTo(object value);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
public static bool IsInfinity(double d);
public static bool IsNaN(double d);
public static bool IsNegativeInfinity(double d);
public static bool IsPositiveInfinity(double d);
protected object MemberwiseClone();
public static double Parse(string s);
public static double Parse(string s, IFormatProvider provider);
public static double Parse(string s, NumberStyles style);
public static double Parse(string s, NumberStyles style, IFormatProvider provider);
public override string ToString();
public virtual string ToString(IFormatProvider provider);
public string ToString(string format);
public virtual string ToString(string format, IFormatProvider provider);
public static bool TryParse(string s, NumberStyles style, IFormatProvider provider, ref double result);

Field
public const double Epsilon = 4.94065645841247E-324;
public const double MaxValue = 1.79769313486232E+308;
public const double MinValue = -1.79769313486232E+308;
public const double NaN = NaN;
public const double NegativeInfinity = -Infinity;
public const double PositiveInfinity = Infinity;

System.Single

Module:mscorlib.dll

Hierarchy
Object
ValueType
Single : IComparable, IFormattable, IConvertible

Type declaration

[C#] public struct Single : ValueType, IComparable, IFormattable, IConvertible;

Method
public virtual int CompareTo(object value);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
public static bool IsInfinity(float f);
public static bool IsNaN(float f);
public static bool IsNegativeInfinity(float f);
public static bool IsPositiveInfinity(float f);
protected object MemberwiseClone();
public static float Parse(string s);
public static float Parse(string s, IFormatProvider provider);
public static float Parse(string s, NumberStyles style);
public static float Parse(string s, NumberStyles style, IFormatProvider provider);
public override string ToString();
public virtual string ToString(IFormatProvider provider);
public string ToString(string format);
public virtual string ToString(string format, IFormatProvider provider);

Field
public const float Epsilon = 1.401298E-45;
public const float MaxValue = 3.402823E+38;
public const float MinValue = -3.402823E+38;
public const float NaN = NaN;
public const float NegativeInfinity = -Infinity;
public const float PositiveInfinity = Infinity;

System.IntPtr

Module:mscorlib.dll

Hierarchy
Object
ValueType
IntPtr

Type declaration

[C#] public struct IntPtr : ValueType;

Constructor
public IntPtr(int value);
public IntPtr(long value);
public IntPtr(void* value);

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public static bool op_Equality(IntPtr value1, IntPtr value2);
public static IntPtr op_Explicit(int value);
public static IntPtr op_Explicit(long value);
public static int op_Explicit(IntPtr value);
public static long op_Explicit(IntPtr value);
public static void* op_Explicit(IntPtr value);
public static IntPtr op_Explicit(void* value);
public static bool op_Inequality(IntPtr value1, IntPtr value2);
public int ToInt32();
public long ToInt64();
public void* ToPointer();
public override string ToString();

Property
public static int Size {get;}

Field
public readonly static IntPtr Zero;

System.Int64

Module:mscorlib.dll

Hierarchy
Object
ValueType
Int64 : IFormattable, IConvertible, IComparable

Type declaration

[C#] public struct Int64 : ValueType, IFormattable, IConvertible, IComparable;

Method
public virtual int CompareTo(object value);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public static long Parse(string s);
public static long Parse(string s, IFormatProvider provider);
public static long Parse(string s, NumberStyles style);
public static long Parse(string s, NumberStyles style, IFormatProvider provider);
public override string ToString();
public virtual string ToString(IFormatProvider provider);
public string ToString(string format);
public virtual string ToString(string format, IFormatProvider provider);

Field
public const long MaxValue = 9223372036854775807;
public const long MinValue = -9223372036854775808;

System.Int32

Module:mscorlib.dll

Hierarchy
Object
ValueType
Int32 : IComparable, IFormattable, IConvertible

Type declaration

[C#] public struct Int32 : ValueType, IComparable, IFormattable, IConvertible;

Method
public virtual int CompareTo(object value);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public static int Parse(string s);
public static int Parse(string s, IFormatProvider provider);
public static int Parse(string s, NumberStyles style);
public static int Parse(string s, NumberStyles style, IFormatProvider provider);
public override string ToString();
public virtual string ToString(IFormatProvider provider);
public string ToString(string format);
public virtual string ToString(string format, IFormatProvider provider);

Field
public const int MaxValue = 2147483647;
public const int MinValue = -2147483648;

System.Int16

Module:mscorlib.dll

Hierarchy
Object
ValueType
Int16 : IFormattable, IConvertible, IComparable

Type declaration

[C#] public struct Int16 : ValueType, IFormattable, IConvertible, IComparable;

Method
public virtual int CompareTo(object value);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public static short Parse(string s);
public static short Parse(string s, IFormatProvider provider);
public static short Parse(string s, NumberStyles style);
public static short Parse(string s, NumberStyles style, IFormatProvider provider);
public override string ToString();
public virtual string ToString(IFormatProvider provider);
public string ToString(string format);
public virtual string ToString(string format, IFormatProvider provider);

Field
public const short MaxValue = 32767;
public const short MinValue = -32768;

System.Byte

Module:mscorlib.dll

Hierarchy
Object
ValueType
Byte : IComparable, IFormattable, IConvertible

Type declaration

[C#] public struct Byte : ValueType, IComparable, IFormattable, IConvertible;

Method
public virtual int CompareTo(object value);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public static byte Parse(string s);
public static byte Parse(string s, IFormatProvider provider);
public static byte Parse(string s, NumberStyles style);
public static byte Parse(string s, NumberStyles style, IFormatProvider provider);
public override string ToString();
public virtual string ToString(IFormatProvider provider);
public string ToString(string format);
public virtual string ToString(string format, IFormatProvider provider);

Field
public const byte MaxValue = 255;
public const byte MinValue = 0;

System.IConvertible

Module:mscorlib.dll

Hierarchy
IConvertible

Type declaration

[C#] public interface IConvertible;

Method
public TypeCode GetTypeCode();
public bool ToBoolean(IFormatProvider provider);
public byte ToByte(IFormatProvider provider);
public char ToChar(IFormatProvider provider);
public DateTime ToDateTime(IFormatProvider provider);
public decimal ToDecimal(IFormatProvider provider);
public double ToDouble(IFormatProvider provider);
public short ToInt16(IFormatProvider provider);
public int ToInt32(IFormatProvider provider);
public long ToInt64(IFormatProvider provider);
public SByte ToSByte(IFormatProvider provider);
public float ToSingle(IFormatProvider provider);
public string ToString(IFormatProvider provider);
public object ToType(Type conversionType, IFormatProvider provider);
public ushort ToUInt16(IFormatProvider provider);
public uint ToUInt32(IFormatProvider provider);
public ulong ToUInt64(IFormatProvider provider);

System.IFormattable

Module:mscorlib.dll

Hierarchy
IFormattable

Type declaration

[C#] public interface IFormattable;

Method
public string ToString(string format, IFormatProvider formatProvider);

System.IComparable

Module:mscorlib.dll

Hierarchy
IComparable

Type declaration

[C#] public interface IComparable;

Method
public int CompareTo(object obj);

System.ValueType

Module:mscorlib.dll

Hierarchy
Object
ValueType

Type declaration

[C#] public abstract class ValueType;

Constructor
protected ValueType();

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

System.Object

Module:mscorlib.dll

Hierarchy
Object

Type declaration

[C#] public class Object;

Constructor
public Object();

Method
public virtual bool Equals(object obj);
public static bool Equals(object objA, object objB);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public static bool ReferenceEquals(object objA, object objB);
public virtual string ToString();

System.Collections.Specialized.BitVector32+Section

Module:System.dll

Hierarchy
Object
ValueType
BitVector32+Section

Type declaration

[C#] public struct Section : ValueType;

Method
public override bool Equals(object o);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public override string ToString();
public static string ToString(Section value);

Property
public short Mask {get;}
public short Offset {get;}

System.Collections.Specialized.BitVector32

Module:System.dll

Hierarchy
Object
ValueType
BitVector32

Type declaration

[C#] public struct BitVector32 : ValueType;

Constructor
public BitVector32(BitVector32 value);
public BitVector32(int data);

Method
public static int CreateMask();
public static int CreateMask(int previous);
public static Section CreateSection(short maxValue);
public static Section CreateSection(short maxValue, Section previous);
public override bool Equals(object o);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public override string ToString();
public static string ToString(BitVector32 value);

Property
public int Data {get;}
public bool this[int bit] {get; set;}
public int this[Section section] {get; set;}

System.Collections.Specialized.ListDictionary

Module:System.dll

Hierarchy
Object
ListDictionary : IDictionary, ICollection, IEnumerable

Type declaration

[C#] public class ListDictionary: IDictionary, ICollection, IEnumerable;

Constructor
public ListDictionary();
public ListDictionary(IComparer comparer);

Method
public virtual void Add(object key, object value);
public virtual void Clear();
public virtual bool Contains(object key);
public virtual void CopyTo(Array array, int index);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual IDictionaryEnumerator GetEnumerator();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual void Remove(object key);
public virtual string ToString();

Property
public virtual int Count {get;}
public virtual bool IsFixedSize {get;}
public virtual bool IsReadOnly {get;}
public virtual bool IsSynchronized {get;}
public virtual object this[object key] {get; set;}
public virtual ICollection Keys {get;}
public virtual object SyncRoot {get;}
public virtual ICollection Values {get;}

System.Collections.Specialized.HybridDictionary

Module:System.dll

Hierarchy
Object
HybridDictionary : IDictionary, ICollection, IEnumerable

Type declaration

[C#] public class HybridDictionary: IDictionary, ICollection, IEnumerable;

Constructor
public HybridDictionary();
public HybridDictionary(bool caseInsensitive);
public HybridDictionary(int initialSize);
public HybridDictionary(int initialSize, bool caseInsensitive);

Method
public virtual void Add(object key, object value);
public virtual void Clear();
public virtual bool Contains(object key);
public virtual void CopyTo(Array array, int index);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual IDictionaryEnumerator GetEnumerator();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual void Remove(object key);
public virtual string ToString();

Property
public virtual int Count {get;}
public virtual bool IsFixedSize {get;}
public virtual bool IsReadOnly {get;}
public virtual bool IsSynchronized {get;}
public virtual object this[object key] {get; set;}
public virtual ICollection Keys {get;}
public virtual object SyncRoot {get;}
public virtual ICollection Values {get;}

System.Collections.Specialized.NameValueCollection

Module:System.dll

Hierarchy
Object
NameObjectCollectionBase
NameValueCollection

Type declaration

[C#] public class NameValueCollection : NameObjectCollectionBase;

Constructor
public NameValueCollection();
public NameValueCollection(IHashCodeProvider hashProvider, IComparer comparer);
public NameValueCollection(int capacity);
public NameValueCollection(int capacity, IHashCodeProvider hashProvider, IComparer comparer);
public NameValueCollection(int capacity, NameValueCollection col);
public NameValueCollection(NameValueCollection col);
protected NameValueCollection(SerializationInfo info, StreamingContext context);

Method
public void Add(NameValueCollection c);
public virtual void Add(string name, string value);
protected void BaseAdd(string name, object value);
protected void BaseClear();
protected object BaseGet(int index);
protected object BaseGet(string name);
protected string[] BaseGetAllKeys();
protected object[] BaseGetAllValues();
protected object[] BaseGetAllValues(Type type);
protected string BaseGetKey(int index);
protected bool BaseHasKeys();
protected void BaseRemove(string name);
protected void BaseRemoveAt(int index);
protected void BaseSet(int index, object value);
protected void BaseSet(string name, object value);
public void Clear();
public void CopyTo(Array dest, int index);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual string Get(int index);
public virtual string Get(string name);
public virtual IEnumerator GetEnumerator();
public virtual int GetHashCode();
public virtual string GetKey(int index);
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
public virtual string[] GetValues(int index);
public virtual string[] GetValues(string name);
public bool HasKeys();
protected void InvalidateCachedArrays();
protected object MemberwiseClone();
public void OnDeserialization(object sender);
public virtual void Remove(string name);
public virtual void Set(string name, string value);
public virtual string ToString();

Property
public virtual string[] AllKeys {get;}
public virtual int Count {get;}
protected bool IsReadOnly {get; set;}
public string this[int index] {get;}
public string this[string name] {get; set;}
public virtual KeysCollection Keys {get;}

System.Collections.Specialized.NameObjectCollectionBase+KeysCollection

Module:System.dll

Hierarchy
Object
NameObjectCollectionBase+KeysCollection : ICollection, IEnumerable

Type declaration

[C#] public class KeysCollection: ICollection, IEnumerable;

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual string Get(int index);
public virtual IEnumerator GetEnumerator();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public virtual int Count {get;}
public string this[int index] {get;}

System.Collections.Specialized.NameObjectCollectionBase

Module:System.dll

Hierarchy
Object
NameObjectCollectionBase : ICollection, IEnumerable

Type declaration

[C#] public abstract class NameObjectCollectionBase: ICollection, IEnumerable;

Constructor
public NameObjectCollectionBase();
public NameObjectCollectionBase(IHashCodeProvider hashProvider, IComparer comparer);
public NameObjectCollectionBase(int capacity);
public NameObjectCollectionBase(int capacity, IHashCodeProvider hashProvider, IComparer comparer);
protected NameObjectCollectionBase(SerializationInfo info, StreamingContext context);

Method
protected void BaseAdd(string name, object value);
protected void BaseClear();
protected object BaseGet(int index);
protected object BaseGet(string name);
protected string[] BaseGetAllKeys();
protected object[] BaseGetAllValues();
protected object[] BaseGetAllValues(Type type);
protected string BaseGetKey(int index);
protected bool BaseHasKeys();
protected void BaseRemove(string name);
protected void BaseRemoveAt(int index);
protected void BaseSet(int index, object value);
protected void BaseSet(string name, object value);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual IEnumerator GetEnumerator();
public virtual int GetHashCode();
public virtual void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public virtual void OnDeserialization(object sender);
public virtual string ToString();

Property
public virtual int Count {get;}
protected bool IsReadOnly {get; set;}
public virtual KeysCollection Keys {get;}

System.ComponentModel.ComponentResourceManager

Module:System.dll

Hierarchy
Object
ResourceManager
ComponentResourceManager

Type declaration

[C#] public class ComponentResourceManager : ResourceManager;

Constructor
public ComponentResourceManager();
public ComponentResourceManager(Type t);

Method
public void ApplyResources(object value, string objectName);
public virtual void ApplyResources(object value, string objectName, CultureInfo culture);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public virtual object GetObject(string name);
public virtual object GetObject(string name, CultureInfo culture);
protected virtual string GetResourceFileName(CultureInfo culture);
public virtual ResourceSet GetResourceSet(CultureInfo culture, bool createIfNotExists, bool tryParents);
public virtual string GetString(string name);
public virtual string GetString(string name, CultureInfo culture);
public Type GetType();
protected virtual ResourceSet InternalGetResourceSet(CultureInfo culture, bool createIfNotExists, bool tryParents);
protected object MemberwiseClone();
public virtual void ReleaseAllResources();
public virtual string ToString();

Property
public virtual string BaseName {get;}
public virtual bool IgnoreCase {get; set;}
public virtual Type ResourceSetType {get;}

Field
protected string BaseNameField;
protected Assembly MainAssembly;
protected Hashtable ResourceSets;

System.ComponentModel.EditorBrowsableState

Module:System.dll

Hierarchy
Object
ValueType
Enum
EditorBrowsableState

Type declaration

[C#] public enum EditorBrowsableState;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const EditorBrowsableState Advanced = 2;
public const EditorBrowsableState Always = 0;
public const EditorBrowsableState Never = 1;
public int value__;

System.ComponentModel.EditorBrowsableAttribute

Module:System.dll

Hierarchy
Object
Attribute
EditorBrowsableAttribute

Type declaration

[C#] public sealed class EditorBrowsableAttribute : Attribute;

Constructor
public EditorBrowsableAttribute();
public EditorBrowsableAttribute(EditorBrowsableState state);

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public EditorBrowsableState State {get;}
public object TypeId {get;}

System.ComponentModel.MarshalByValueComponent

Module:System.dll

Hierarchy
Object
MarshalByValueComponent

Type declaration

[C#] public class MarshalByValueComponent;

Constructor
public MarshalByValueComponent();

Method
public virtual void add_Disposed(EventHandler value);
public virtual void Dispose();
protected virtual void Dispose(bool disposing);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public virtual object GetService(Type service);
public Type GetType();
protected object MemberwiseClone();
public virtual void remove_Disposed(EventHandler value);
public virtual string ToString();

Property
public virtual IContainer Container {get;}
public virtual bool DesignMode {get;}
protected EventHandlerList Events {get;}
public virtual ISite Site {get; set;}

System.ComponentModel.Container

Module:System.dll

Hierarchy
Object
Container : IContainer, IDisposable

Type declaration

[C#] public class Container: IContainer, IDisposable;

Constructor
public Container();

Method
public virtual void Add(IComponent component);
public virtual void Add(IComponent component, string name);
protected virtual ISite CreateSite(IComponent component, string name);
public virtual void Dispose();
protected virtual void Dispose(bool disposing);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
protected virtual object GetService(Type service);
public Type GetType();
protected object MemberwiseClone();
public virtual void Remove(IComponent component);
public virtual string ToString();

Property
public virtual ComponentCollection Components {get;}

System.ComponentModel.ISite

Module:System.dll

Hierarchy
ISite : IServiceProvider

Type declaration

[C#] public interface ISite: IServiceProvider;

Property
public IComponent Component {get;}
public IContainer Container {get;}
public bool DesignMode {get;}
public string Name {get; set;}

System.ComponentModel.IContainer

Module:System.dll

Hierarchy
IContainer : IDisposable

Type declaration

[C#] public interface IContainer: IDisposable;

Method
public void Add(IComponent component);
public void Add(IComponent component, string name);
public void Remove(IComponent component);

Property
public ComponentCollection Components {get;}

System.ComponentModel.IComponent

Module:System.dll

Hierarchy
IComponent : IDisposable

Type declaration

[C#] public interface IComponent: IDisposable;

Method
public void add_Disposed(EventHandler value);
public void remove_Disposed(EventHandler value);

Property
public ISite Site {get; set;}

System.ComponentModel.EventHandlerList

Module:System.dll

Hierarchy
Object
EventHandlerList : IDisposable

Type declaration

[C#] public sealed class EventHandlerList: IDisposable;

Constructor
public EventHandlerList();

Method
public void AddHandler(object key, Delegate value);
public virtual void Dispose();
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public void RemoveHandler(object key, Delegate value);
public virtual string ToString();

Property
public Delegate this[object key] {get; set;}

System.ComponentModel.CancelEventArgs

Module:System.dll

Hierarchy
Object
EventArgs
CancelEventArgs

Type declaration

[C#] public class CancelEventArgs : EventArgs;

Constructor
public CancelEventArgs();
public CancelEventArgs(bool cancel);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public bool Cancel {get; set;}

System.ComponentModel.Component

Module:System.dll

Hierarchy
Object
MarshalByRefObject
Component

Type declaration

[C#] public class Component : MarshalByRefObject;

Constructor
public Component();

Method
public void add_Disposed(EventHandler value);
public ObjRef CreateObjRef(Type requestedType);
public virtual void Dispose();
protected virtual void Dispose(bool disposing);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public object GetLifetimeService();
protected virtual object GetService(Type service);
public Type GetType();
public object InitializeLifetimeService();
protected object MemberwiseClone();
public void remove_Disposed(EventHandler value);
public virtual string ToString();

Property
public IContainer Container {get;}
protected bool DesignMode {get;}
protected EventHandlerList Events {get;}
public virtual ISite Site {get; set;}

System.ComponentModel.CancelEventHandler

Module:System.dll

Hierarchy
Object
Delegate
MulticastDelegate
CancelEventHandler

Type declaration

[C#] public delegate void CancelEventHandler(object sender, CancelEventArgs e);

Constructor
public CancelEventHandler(object object, IntPtr method);

Method
public virtual IAsyncResult BeginInvoke(object sender, CancelEventArgs e, AsyncCallback callback, object object);
public object Clone();
protected override Delegate CombineImpl(Delegate follow);
public object DynamicInvoke(object[] args);
protected virtual object DynamicInvokeImpl(object[] args);
public virtual void EndInvoke(IAsyncResult result);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public override Delegate[] GetInvocationList();
protected virtual MethodInfo GetMethodImpl();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
public override void Invoke(object sender, CancelEventArgs e);
protected object MemberwiseClone();
protected override Delegate RemoveImpl(Delegate value);
public virtual string ToString();

Property
public MethodInfo Method {get;}
public object Target {get;}

System.ComponentModel.IEditableObject

Module:System.dll

Hierarchy
IEditableObject

Type declaration

[C#] public interface IEditableObject;

Method
public void BeginEdit();
public void CancelEdit();
public void EndEdit();

System.ComponentModel.IListSource

Module:System.dll

Hierarchy
IListSource

Type declaration

[C#] public interface IListSource;

Method
public IList GetList();

Property
public bool ContainsListCollection {get;}

System.ComponentModel.ITypedList

Module:System.dll

Hierarchy
ITypedList

Type declaration

[C#] public interface ITypedList;

Method
public PropertyDescriptorCollection GetItemProperties(PropertyDescriptor[] listAccessors);
public string GetListName(PropertyDescriptor[] listAccessors);

System.ComponentModel.ICustomTypeDescriptor

Module:System.dll

Hierarchy
ICustomTypeDescriptor

Type declaration

[C#] public interface ICustomTypeDescriptor;

Method
public AttributeCollection GetAttributes();
public string GetClassName();
public string GetComponentName();
public TypeConverter GetConverter();
public EventDescriptor GetDefaultEvent();
public PropertyDescriptor GetDefaultProperty();
public object GetEditor(Type editorBaseType);
public EventDescriptorCollection GetEvents();
public EventDescriptorCollection GetEvents(Attribute[] attributes);
public PropertyDescriptorCollection GetProperties();
public PropertyDescriptorCollection GetProperties(Attribute[] attributes);
public object GetPropertyOwner(PropertyDescriptor pd);

System.ComponentModel.TypeConverter

Module:System.dll

Hierarchy
Object
TypeConverter

Type declaration

[C#] public class TypeConverter;

Constructor
public TypeConverter();

Method
public virtual bool CanConvertFrom(ITypeDescriptorContext context, Type sourceType);
public bool CanConvertFrom(Type sourceType);
public virtual bool CanConvertTo(ITypeDescriptorContext context, Type destinationType);
public bool CanConvertTo(Type destinationType);
public virtual object ConvertFrom(ITypeDescriptorContext context, CultureInfo culture, object value);
public object ConvertFrom(object value);
public object ConvertFromInvariantString(ITypeDescriptorContext context, string text);
public object ConvertFromInvariantString(string text);
public object ConvertFromString(ITypeDescriptorContext context, CultureInfo culture, string text);
public object ConvertFromString(ITypeDescriptorContext context, string text);
public object ConvertFromString(string text);
public virtual object ConvertTo(ITypeDescriptorContext context, CultureInfo culture, object value, Type destinationType);
public object ConvertTo(object value, Type destinationType);
public string ConvertToInvariantString(ITypeDescriptorContext context, object value);
public string ConvertToInvariantString(object value);
public string ConvertToString(ITypeDescriptorContext context, CultureInfo culture, object value);
public string ConvertToString(ITypeDescriptorContext context, object value);
public string ConvertToString(object value);
public object CreateInstance(IDictionary propertyValues);
public virtual object CreateInstance(ITypeDescriptorContext context, IDictionary propertyValues);
public virtual bool Equals(object obj);
protected override void Finalize();
protected Exception GetConvertFromException(object value);
protected Exception GetConvertToException(object value, Type destinationType);
public bool GetCreateInstanceSupported();
public virtual bool GetCreateInstanceSupported(ITypeDescriptorContext context);
public virtual int GetHashCode();
public PropertyDescriptorCollection GetProperties(ITypeDescriptorContext context, object value);
public virtual PropertyDescriptorCollection GetProperties(ITypeDescriptorContext context, object value, Attribute[] attributes);
public PropertyDescriptorCollection GetProperties(object value);
public bool GetPropertiesSupported();
public virtual bool GetPropertiesSupported(ITypeDescriptorContext context);
public ICollection GetStandardValues();
public virtual StandardValuesCollection GetStandardValues(ITypeDescriptorContext context);
public bool GetStandardValuesExclusive();
public virtual bool GetStandardValuesExclusive(ITypeDescriptorContext context);
public bool GetStandardValuesSupported();
public virtual bool GetStandardValuesSupported(ITypeDescriptorContext context);
public Type GetType();
public virtual bool IsValid(ITypeDescriptorContext context, object value);
public bool IsValid(object value);
protected object MemberwiseClone();
protected PropertyDescriptorCollection SortProperties(PropertyDescriptorCollection props, string[] names);
public virtual string ToString();

System.ComponentModel.EventDescriptorCollection

Module:System.dll

Hierarchy
Object
EventDescriptorCollection : IList, ICollection, IEnumerable

Type declaration

[C#] public class EventDescriptorCollection: IList, ICollection, IEnumerable;

Constructor
public EventDescriptorCollection(EventDescriptor[] events);

Method
public int Add(EventDescriptor value);
public void Clear();
public bool Contains(EventDescriptor value);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual EventDescriptor Find(string name, bool ignoreCase);
public IEnumerator GetEnumerator();
public virtual int GetHashCode();
public Type GetType();
public int IndexOf(EventDescriptor value);
public void Insert(int index, EventDescriptor value);
protected void InternalSort(IComparer sorter);
protected void InternalSort(string[] names);
protected object MemberwiseClone();
public void Remove(EventDescriptor value);
public void RemoveAt(int index);
public virtual EventDescriptorCollection Sort();
public virtual EventDescriptorCollection Sort(IComparer comparer);
public virtual EventDescriptorCollection Sort(string[] names);
public virtual EventDescriptorCollection Sort(string[] names, IComparer comparer);
public virtual string ToString();

Property
public int Count {get;}
public virtual EventDescriptor this[int index] {get;}
public virtual EventDescriptor this[string name] {get;}

Field
public readonly static EventDescriptorCollection Empty;

System.ComponentModel.ListChangedType

Module:System.dll

Hierarchy
Object
ValueType
Enum
ListChangedType

Type declaration

[C#] public enum ListChangedType;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const ListChangedType ItemAdded = 1;
public const ListChangedType ItemChanged = 4;
public const ListChangedType ItemDeleted = 2;
public const ListChangedType ItemMoved = 3;
public const ListChangedType PropertyDescriptorAdded = 5;
public const ListChangedType PropertyDescriptorChanged = 7;
public const ListChangedType PropertyDescriptorDeleted = 6;
public const ListChangedType Reset = 0;
public int value__;

System.ComponentModel.ListChangedEventArgs

Module:System.dll

Hierarchy
Object
EventArgs
ListChangedEventArgs

Type declaration

[C#] public class ListChangedEventArgs : EventArgs;

Constructor
public ListChangedEventArgs(ListChangedType listChangedType, int newIndex);
public ListChangedEventArgs(ListChangedType listChangedType, int newIndex, int oldIndex);
public ListChangedEventArgs(ListChangedType listChangedType, PropertyDescriptor propDesc);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public ListChangedType ListChangedType {get;}
public int NewIndex {get;}
public int OldIndex {get;}

System.ComponentModel.ListChangedEventHandler

Module:System.dll

Hierarchy
Object
Delegate
MulticastDelegate
ListChangedEventHandler

Type declaration

[C#] public delegate void ListChangedEventHandler(object sender, ListChangedEventArgs e);

Constructor
public ListChangedEventHandler(object object, IntPtr method);

Method
public virtual IAsyncResult BeginInvoke(object sender, ListChangedEventArgs e, AsyncCallback callback, object object);
public object Clone();
protected override Delegate CombineImpl(Delegate follow);
public object DynamicInvoke(object[] args);
protected virtual object DynamicInvokeImpl(object[] args);
public virtual void EndInvoke(IAsyncResult result);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public override Delegate[] GetInvocationList();
protected virtual MethodInfo GetMethodImpl();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
public override void Invoke(object sender, ListChangedEventArgs e);
protected object MemberwiseClone();
protected override Delegate RemoveImpl(Delegate value);
public virtual string ToString();

Property
public MethodInfo Method {get;}
public object Target {get;}

System.ComponentModel.IBindingList

Module:System.dll

Hierarchy
IBindingList : IList, ICollection, IEnumerable

Type declaration

[C#] public interface IBindingList: IList, ICollection, IEnumerable;

Method
public void add_ListChanged(ListChangedEventHandler value);
public void AddIndex(PropertyDescriptor property);
public object AddNew();
public void ApplySort(PropertyDescriptor property, ListSortDirection direction);
public int Find(PropertyDescriptor property, object key);
public void remove_ListChanged(ListChangedEventHandler value);
public void RemoveIndex(PropertyDescriptor property);
public void RemoveSort();

Property
public bool AllowEdit {get;}
public bool AllowNew {get;}
public bool AllowRemove {get;}
public bool IsSorted {get;}
public ListSortDirection SortDirection {get;}
public PropertyDescriptor SortProperty {get;}
public bool SupportsChangeNotification {get;}
public bool SupportsSearching {get;}
public bool SupportsSorting {get;}

System.ComponentModel.ListSortDirection

Module:System.dll

Hierarchy
Object
ValueType
Enum
ListSortDirection

Type declaration

[C#] public enum ListSortDirection;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const ListSortDirection Ascending = 0;
public const ListSortDirection Descending = 1;
public int value__;

System.ComponentModel.TypeDescriptor

Module:System.dll

Hierarchy
Object
TypeDescriptor

Type declaration

[C#] public sealed class TypeDescriptor;

Method
public static void add_Refreshed(RefreshEventHandler value);
public static void AddEditorTable(Type editorBaseType, Hashtable table);
public static IDesigner CreateDesigner(IComponent component, Type designerBaseType);
public static EventDescriptor CreateEvent(Type componentType, EventDescriptor oldEventDescriptor, params Attribute[] attributes);
public static EventDescriptor CreateEvent(Type componentType, string name, Type type, params Attribute[] attributes);
public static PropertyDescriptor CreateProperty(Type componentType, PropertyDescriptor oldPropertyDescriptor, params Attribute[] attributes);
public static PropertyDescriptor CreateProperty(Type componentType, string name, Type type, params Attribute[] attributes);
public virtual bool Equals(object obj);
protected override void Finalize();
public static AttributeCollection GetAttributes(object component);
public static AttributeCollection GetAttributes(object component, bool noCustomTypeDesc);
public static AttributeCollection GetAttributes(Type componentType);
public static string GetClassName(object component);
public static string GetClassName(object component, bool noCustomTypeDesc);
public static string GetComponentName(object component);
public static string GetComponentName(object component, bool noCustomTypeDesc);
public static TypeConverter GetConverter(object component);
public static TypeConverter GetConverter(object component, bool noCustomTypeDesc);
public static TypeConverter GetConverter(Type type);
public static EventDescriptor GetDefaultEvent(object component);
public static EventDescriptor GetDefaultEvent(object component, bool noCustomTypeDesc);
public static EventDescriptor GetDefaultEvent(Type componentType);
public static PropertyDescriptor GetDefaultProperty(object component);
public static PropertyDescriptor GetDefaultProperty(object component, bool noCustomTypeDesc);
public static PropertyDescriptor GetDefaultProperty(Type componentType);
public static object GetEditor(object component, Type editorBaseType);
public static object GetEditor(object component, Type editorBaseType, bool noCustomTypeDesc);
public static object GetEditor(Type type, Type editorBaseType);
public static EventDescriptorCollection GetEvents(object component);
public static EventDescriptorCollection GetEvents(object component, Attribute[] attributes);
public static EventDescriptorCollection GetEvents(object component, Attribute[] attributes, bool noCustomTypeDesc);
public static EventDescriptorCollection GetEvents(object component, bool noCustomTypeDesc);
public static EventDescriptorCollection GetEvents(Type componentType);
public static EventDescriptorCollection GetEvents(Type componentType, Attribute[] attributes);
public virtual int GetHashCode();
public static PropertyDescriptorCollection GetProperties(object component);
public static PropertyDescriptorCollection GetProperties(object component, Attribute[] attributes);
public static PropertyDescriptorCollection GetProperties(object component, Attribute[] attributes, bool noCustomTypeDesc);
public static PropertyDescriptorCollection GetProperties(object component, bool noCustomTypeDesc);
public static PropertyDescriptorCollection GetProperties(Type componentType);
public static PropertyDescriptorCollection GetProperties(Type componentType, Attribute[] attributes);
public Type GetType();
protected object MemberwiseClone();
public static void Refresh(Assembly assembly);
public static void Refresh(Module module);
public static void Refresh(object component);
public static void Refresh(Type type);
public static void remove_Refreshed(RefreshEventHandler value);
public static void SortDescriptorArray(IList infos);
public virtual string ToString();

Property
public static IComNativeDescriptorHandler ComNativeDescriptorHandler {get; set;}

System.ComponentModel.EventDescriptor

Module:System.dll

Hierarchy
Object
MemberDescriptor
EventDescriptor

Type declaration

[C#] public abstract class EventDescriptor : MemberDescriptor;

Constructor
protected EventDescriptor(MemberDescriptor descr);
protected EventDescriptor(MemberDescriptor descr, Attribute[] attrs);
protected EventDescriptor(string name, Attribute[] attrs);

Method
public abstract void AddEventHandler(object component, Delegate value);
protected virtual AttributeCollection CreateAttributeCollection();
public virtual bool Equals(object obj);
protected virtual void FillAttributes(IList attributeList);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public abstract void RemoveEventHandler(object component, Delegate value);
public virtual string ToString();

Property
protected virtual Attribute[] AttributeArray {get; set;}
public AttributeCollection Attributes {get;}
public string Category {get;}
public abstract Type ComponentType {get;}
public string Description {get;}
public bool DesignTimeOnly {get;}
public virtual string DisplayName {get;}
public abstract Type EventType {get;}
public bool IsBrowsable {get;}
public abstract bool IsMulticast {get;}
public virtual string Name {get;}
protected virtual int NameHashCode {get;}

System.ComponentModel.PropertyDescriptorCollection

Module:System.dll

Hierarchy
Object
PropertyDescriptorCollection : IList, IDictionary, ICollection, IEnumerable

Type declaration

[C#] public class PropertyDescriptorCollection: IList, IDictionary, ICollection, IEnumerable;

Constructor
public PropertyDescriptorCollection(PropertyDescriptor[] properties);

Method
public int Add(PropertyDescriptor value);
public void Clear();
public bool Contains(PropertyDescriptor value);
public virtual void CopyTo(Array array, int index);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual PropertyDescriptor Find(string name, bool ignoreCase);
public virtual IEnumerator GetEnumerator();
public virtual int GetHashCode();
public Type GetType();
public int IndexOf(PropertyDescriptor value);
public void Insert(int index, PropertyDescriptor value);
protected void InternalSort(IComparer sorter);
protected void InternalSort(string[] names);
protected object MemberwiseClone();
public void Remove(PropertyDescriptor value);
public void RemoveAt(int index);
public virtual PropertyDescriptorCollection Sort();
public virtual PropertyDescriptorCollection Sort(IComparer comparer);
public virtual PropertyDescriptorCollection Sort(string[] names);
public virtual PropertyDescriptorCollection Sort(string[] names, IComparer comparer);
public virtual string ToString();

Property
public int Count {get;}
public virtual PropertyDescriptor this[int index] {get;}
public virtual PropertyDescriptor this[string name] {get;}

Field
public readonly static PropertyDescriptorCollection Empty;

System.ComponentModel.PropertyDescriptor

Module:System.dll

Hierarchy
Object
MemberDescriptor
PropertyDescriptor

Type declaration

[C#] public abstract class PropertyDescriptor : MemberDescriptor;

Constructor
protected PropertyDescriptor(MemberDescriptor descr);
protected PropertyDescriptor(MemberDescriptor descr, Attribute[] attrs);
protected PropertyDescriptor(string name, Attribute[] attrs);

Method
public virtual void AddValueChanged(object component, EventHandler handler);
public abstract bool CanResetValue(object component);
protected virtual AttributeCollection CreateAttributeCollection();
protected object CreateInstance(Type type);
public virtual bool Equals(object obj);
protected virtual void FillAttributes(IList attributeList);
protected override void Finalize();
public PropertyDescriptorCollection GetChildProperties();
public PropertyDescriptorCollection GetChildProperties(Attribute[] filter);
public PropertyDescriptorCollection GetChildProperties(object instance);
public virtual PropertyDescriptorCollection GetChildProperties(object instance, Attribute[] filter);
public virtual object GetEditor(Type editorBaseType);
public override int GetHashCode();
public Type GetType();
protected Type GetTypeFromName(string typeName);
public abstract object GetValue(object component);
protected object MemberwiseClone();
protected virtual void OnValueChanged(object component, EventArgs e);
public virtual void RemoveValueChanged(object component, EventHandler handler);
public abstract void ResetValue(object component);
public abstract void SetValue(object component, object value);
public abstract bool ShouldSerializeValue(object component);
public virtual string ToString();

Property
protected virtual Attribute[] AttributeArray {get; set;}
public AttributeCollection Attributes {get;}
public string Category {get;}
public abstract Type ComponentType {get;}
public virtual TypeConverter Converter {get;}
public string Description {get;}
public bool DesignTimeOnly {get;}
public virtual string DisplayName {get;}
public bool IsBrowsable {get;}
public virtual bool IsLocalizable {get;}
public abstract bool IsReadOnly {get;}
public virtual string Name {get;}
protected virtual int NameHashCode {get;}
public abstract Type PropertyType {get;}
public DesignerSerializationVisibility SerializationVisibility {get;}

System.ComponentModel.PropertyChangedEventHandler

Module:System.dll

Hierarchy
Object
Delegate
MulticastDelegate
PropertyChangedEventHandler

Type declaration

[C#] public delegate void PropertyChangedEventHandler(object sender, PropertyChangedEventArgs e);

Constructor
public PropertyChangedEventHandler(object object, IntPtr method);

Method
public virtual IAsyncResult BeginInvoke(object sender, PropertyChangedEventArgs e, AsyncCallback callback, object object);
public object Clone();
protected override Delegate CombineImpl(Delegate follow);
public object DynamicInvoke(object[] args);
protected virtual object DynamicInvokeImpl(object[] args);
public virtual void EndInvoke(IAsyncResult result);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public override Delegate[] GetInvocationList();
protected virtual MethodInfo GetMethodImpl();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
public override void Invoke(object sender, PropertyChangedEventArgs e);
protected object MemberwiseClone();
protected override Delegate RemoveImpl(Delegate value);
public virtual string ToString();

Property
public MethodInfo Method {get;}
public object Target {get;}

System.ComponentModel.PropertyChangedEventArgs

Module:System.dll

Hierarchy
Object
EventArgs
PropertyChangedEventArgs

Type declaration

[C#] public class PropertyChangedEventArgs : EventArgs;

Constructor
public PropertyChangedEventArgs(string propertyName);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public virtual string PropertyName {get;}

System.ComponentModel.MemberDescriptor

Module:System.dll

Hierarchy
Object
MemberDescriptor

Type declaration

[C#] public abstract class MemberDescriptor;

Constructor
protected MemberDescriptor(MemberDescriptor descr);
protected MemberDescriptor(MemberDescriptor oldMemberDescriptor, Attribute[] newAttributes);
protected MemberDescriptor(string name);
protected MemberDescriptor(string name, Attribute[] attributes);

Method
protected virtual AttributeCollection CreateAttributeCollection();
public virtual bool Equals(object obj);
protected virtual void FillAttributes(IList attributeList);
protected override void Finalize();
protected static MethodInfo FindMethod(Type componentClass, string name, Type[] args, Type returnType);
protected static MethodInfo FindMethod(Type componentClass, string name, Type[] args, Type returnType, bool publicOnly);
public override int GetHashCode();
protected static object GetInvokee(Type componentClass, object component);
protected static ISite GetSite(object component);
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
protected virtual Attribute[] AttributeArray {get;}
protected virtual Attribute[] AttributeArray {get; set;}
public virtual AttributeCollection Attributes {get;}
public virtual string Category {get;}
public virtual string Description {get;}
public virtual bool DesignTimeOnly {get;}
public virtual string DisplayName {get;}
public virtual bool IsBrowsable {get;}
public virtual string Name {get;}
protected virtual int NameHashCode {get;}

System.ComponentModel.IDataErrorInfo

Module:System.dll

Hierarchy
IDataErrorInfo

Type declaration

[C#] public interface IDataErrorInfo;

Property
public string Error {get;}
public string this[string columnName] {get;}

System.ComponentModel.AttributeCollection

Module:System.dll

Hierarchy
Object
AttributeCollection : ICollection, IEnumerable

Type declaration

[C#] public class AttributeCollection: ICollection, IEnumerable;

Constructor
public AttributeCollection(Attribute[] attributes);

Method
public bool Contains(Attribute attribute);
public bool Contains(Attribute[] attributes);
public virtual void CopyTo(Array array, int index);
public virtual bool Equals(object obj);
protected override void Finalize();
protected Attribute GetDefaultAttribute(Type attributeType);
public IEnumerator GetEnumerator();
public virtual int GetHashCode();
public Type GetType();
public bool Matches(Attribute attribute);
public bool Matches(Attribute[] attributes);
protected object MemberwiseClone();
public virtual string ToString();

Property
public int Count {get;}
public virtual Attribute this[int index] {get;}
public virtual Attribute this[Type attributeType] {get;}

Field
public readonly static AttributeCollection Empty;

System.ComponentModel.CollectionChangeEventHandler

Module:System.dll

Hierarchy
Object
Delegate
MulticastDelegate
CollectionChangeEventHandler

Type declaration

[C#] public delegate void CollectionChangeEventHandler(object sender, CollectionChangeEventArgs e);

Constructor
public CollectionChangeEventHandler(object object, IntPtr method);

Method
public virtual IAsyncResult BeginInvoke(object sender, CollectionChangeEventArgs e, AsyncCallback callback, object object);
public object Clone();
protected override Delegate CombineImpl(Delegate follow);
public object DynamicInvoke(object[] args);
protected virtual object DynamicInvokeImpl(object[] args);
public virtual void EndInvoke(IAsyncResult result);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public override Delegate[] GetInvocationList();
protected virtual MethodInfo GetMethodImpl();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
public override void Invoke(object sender, CollectionChangeEventArgs e);
protected object MemberwiseClone();
protected override Delegate RemoveImpl(Delegate value);
public virtual string ToString();

Property
public MethodInfo Method {get;}
public object Target {get;}

System.ComponentModel.CollectionChangeEventArgs

Module:System.dll

Hierarchy
Object
EventArgs
CollectionChangeEventArgs

Type declaration

[C#] public class CollectionChangeEventArgs : EventArgs;

Constructor
public CollectionChangeEventArgs(CollectionChangeAction action, object element);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public virtual CollectionChangeAction Action {get;}
public virtual object Element {get;}

System.ComponentModel.CollectionChangeAction

Module:System.dll

Hierarchy
Object
ValueType
Enum
CollectionChangeAction

Type declaration

[C#] public enum CollectionChangeAction;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const CollectionChangeAction Add = 1;
public const CollectionChangeAction Refresh = 3;
public const CollectionChangeAction Remove = 2;
public int value__;

System.ComponentModel.DesignerCategoryAttribute

Module:System.dll

Hierarchy
Object
Attribute
DesignerCategoryAttribute

Type declaration

[C#] public sealed class DesignerCategoryAttribute : Attribute;

Constructor
public DesignerCategoryAttribute();
public DesignerCategoryAttribute(string category);

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public override bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public string Category {get;}
public override object TypeId {get;}

Field
public readonly static DesignerCategoryAttribute Component;
public readonly static DesignerCategoryAttribute Default;
public readonly static DesignerCategoryAttribute Form;
public readonly static DesignerCategoryAttribute Generic;

System.ComponentModel.DefaultValueAttribute

Module:System.dll

Hierarchy
Object
Attribute
DefaultValueAttribute

Type declaration

[C#] public sealed class DefaultValueAttribute : Attribute;

Constructor
public DefaultValueAttribute(bool value);
public DefaultValueAttribute(byte value);
public DefaultValueAttribute(char value);
public DefaultValueAttribute(double value);
public DefaultValueAttribute(short value);
public DefaultValueAttribute(int value);
public DefaultValueAttribute(long value);
public DefaultValueAttribute(object value);
public DefaultValueAttribute(float value);
public DefaultValueAttribute(string value);
public DefaultValueAttribute(Type type, string value);

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public object TypeId {get;}
public object Value {get;}

System.ComponentModel.Win32Exception

Module:System.dll

Hierarchy
Object
Exception
SystemException
ExternalException
Win32Exception

Type declaration

[C#] public class Win32Exception : ExternalException;

Constructor
public Win32Exception();
public Win32Exception(int error);
public Win32Exception(int error, string message);
protected Win32Exception(SerializationInfo info, StreamingContext context);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public override void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public int ErrorCode {get;}
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public virtual string Message {get;}
public int NativeErrorCode {get;}
public string Source {get; set;}
public string StackTrace {get;}
public MethodBase TargetSite {get;}

System.Text.RegularExpressions.CaptureCollection

Module:System.dll

Hierarchy
Object
CaptureCollection : ICollection, IEnumerable

Type declaration

[C#] public class CaptureCollection: ICollection, IEnumerable;

Method
public virtual void CopyTo(Array array, int arrayIndex);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual IEnumerator GetEnumerator();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public virtual int Count {get;}
public bool IsReadOnly {get;}
public virtual bool IsSynchronized {get;}
public Capture this[int i] {get;}
public virtual object SyncRoot {get;}

System.Text.RegularExpressions.MatchCollection

Module:System.dll

Hierarchy
Object
MatchCollection : ICollection, IEnumerable

Type declaration

[C#] public class MatchCollection: ICollection, IEnumerable;

Method
public virtual void CopyTo(Array array, int arrayIndex);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual IEnumerator GetEnumerator();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public virtual int Count {get;}
public bool IsReadOnly {get;}
public virtual bool IsSynchronized {get;}
public virtual Match this[int i] {get;}
public virtual object SyncRoot {get;}

System.Text.RegularExpressions.RegexRunner

Module:System.dll

Hierarchy
Object
RegexRunner

Type declaration

[C#] public abstract class RegexRunner;

Method
protected void Capture(int capnum, int start, int end);
protected static bool CharInSet(char ch, string set, string category);
protected void Crawl(int i);
protected int Crawlpos();
protected void DoubleCrawl();
protected void DoubleStack();
protected void DoubleTrack();
protected void EnsureStorage();
public virtual bool Equals(object obj);
protected override void Finalize();
protected abstract bool FindFirstChar();
public virtual int GetHashCode();
public Type GetType();
protected abstract void Go();
protected abstract void InitTrackCount();
protected bool IsBoundary(int index, int startpos, int endpos);
protected bool IsECMABoundary(int index, int startpos, int endpos);
protected bool IsMatched(int cap);
protected int MatchIndex(int cap);
protected int MatchLength(int cap);
protected object MemberwiseClone();
protected int Popcrawl();
public virtual string ToString();
protected void TransferCapture(int capnum, int uncapnum, int start, int end);
protected void Uncapture();

System.Text.RegularExpressions.RegexOptions

Module:System.dll

Hierarchy
Object
ValueType
Enum
RegexOptions

Type declaration

[C#] public enum RegexOptions;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const RegexOptions Compiled = 8;
public const RegexOptions CultureInvariant = 512;
public const RegexOptions ECMAScript = 256;
public const RegexOptions ExplicitCapture = 4;
public const RegexOptions IgnoreCase = 1;
public const RegexOptions IgnorePatternWhitespace = 32;
public const RegexOptions Multiline = 2;
public const RegexOptions None = 0;
public const RegexOptions RightToLeft = 64;
public const RegexOptions Singleline = 16;
public int value__;

System.Text.RegularExpressions.GroupCollection

Module:System.dll

Hierarchy
Object
GroupCollection : ICollection, IEnumerable

Type declaration

[C#] public class GroupCollection: ICollection, IEnumerable;

Method
public virtual void CopyTo(Array array, int arrayIndex);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual IEnumerator GetEnumerator();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public virtual int Count {get;}
public bool IsReadOnly {get;}
public virtual bool IsSynchronized {get;}
public Group this[int groupnum] {get;}
public Group this[string groupname] {get;}
public virtual object SyncRoot {get;}

System.Text.RegularExpressions.Match

Module:System.dll

Hierarchy
Object
Capture
Group
Match

Type declaration

[C#] public class Match : Group;

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public Match NextMatch();
public virtual string Result(string replacement);
public static Match Synchronized(Match inner);
public override string ToString();

Property
public CaptureCollection Captures {get;}
public static Match Empty {get;}
public virtual GroupCollection Groups {get;}
public int Index {get;}
public int Length {get;}
public bool Success {get;}
public string Value {get;}

System.Text.RegularExpressions.Group

Module:System.dll

Hierarchy
Object
Capture
Group

Type declaration

[C#] public class Group : Capture;

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public static Group Synchronized(Group inner);
public override string ToString();

Property
public CaptureCollection Captures {get;}
public int Index {get;}
public int Length {get;}
public bool Success {get;}
public string Value {get;}

System.Text.RegularExpressions.Capture

Module:System.dll

Hierarchy
Object
Capture

Type declaration

[C#] public class Capture;

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public int Index {get;}
public int Length {get;}
public string Value {get;}

System.Text.RegularExpressions.RegexRunnerFactory

Module:System.dll

Hierarchy
Object
RegexRunnerFactory

Type declaration

[C#] public abstract class RegexRunnerFactory;

Constructor
protected RegexRunnerFactory();

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

System.Text.RegularExpressions.MatchEvaluator

Module:System.dll

Hierarchy
Object
Delegate
MulticastDelegate
MatchEvaluator

Type declaration

[C#] public delegate string MatchEvaluator(Match match);

Constructor
public MatchEvaluator(object object, IntPtr method);

Method
public virtual IAsyncResult BeginInvoke(Match match, AsyncCallback callback, object object);
public object Clone();
protected override Delegate CombineImpl(Delegate follow);
public object DynamicInvoke(object[] args);
protected virtual object DynamicInvokeImpl(object[] args);
public virtual string EndInvoke(IAsyncResult result);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public override Delegate[] GetInvocationList();
protected virtual MethodInfo GetMethodImpl();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
public override string Invoke(Match match);
protected object MemberwiseClone();
protected override Delegate RemoveImpl(Delegate value);
public virtual string ToString();

Property
public MethodInfo Method {get;}
public object Target {get;}

System.Text.RegularExpressions.Regex

Module:System.dll

Hierarchy
Object
Regex

Type declaration

[C#] public class Regex;

Constructor
protected Regex();
public Regex(string pattern);
public Regex(string pattern, RegexOptions options);

Method
public static void CompileToAssembly(RegexCompilationInfo[] regexinfos, AssemblyName assemblyname);
public static void CompileToAssembly(RegexCompilationInfo[] regexinfos, AssemblyName assemblyname, CustomAttributeBuilder[] attributes);
public static void CompileToAssembly(RegexCompilationInfo[] regexinfos, AssemblyName assemblyname, CustomAttributeBuilder[] attributes, string resourceFile);
public virtual bool Equals(object obj);
public static string Escape(string str);
protected override void Finalize();
public string[] GetGroupNames();
public int[] GetGroupNumbers();
public virtual int GetHashCode();
public Type GetType();
public string GroupNameFromNumber(int i);
public int GroupNumberFromName(string name);
protected void InitializeReferences();
public bool IsMatch(string input);
public bool IsMatch(string input, int startat);
public static bool IsMatch(string input, string pattern);
public static bool IsMatch(string input, string pattern, RegexOptions options);
public Match Match(string input);
public Match Match(string input, int startat);
public Match Match(string input, int beginning, int length);
public static Match Match(string input, string pattern);
public static Match Match(string input, string pattern, RegexOptions options);
public MatchCollection Matches(string input);
public MatchCollection Matches(string input, int startat);
public static MatchCollection Matches(string input, string pattern);
public static MatchCollection Matches(string input, string pattern, RegexOptions options);
protected object MemberwiseClone();
public string Replace(string input, MatchEvaluator evaluator);
public string Replace(string input, MatchEvaluator evaluator, int count);
public string Replace(string input, MatchEvaluator evaluator, int count, int startat);
public string Replace(string input, string replacement);
public string Replace(string input, string replacement, int count);
public string Replace(string input, string replacement, int count, int startat);
public static string Replace(string input, string pattern, MatchEvaluator evaluator);
public static string Replace(string input, string pattern, MatchEvaluator evaluator, RegexOptions options);
public static string Replace(string input, string pattern, string replacement);
public static string Replace(string input, string pattern, string replacement, RegexOptions options);
public string[] Split(string input);
public string[] Split(string input, int count);
public string[] Split(string input, int count, int startat);
public static string[] Split(string input, string pattern);
public static string[] Split(string input, string pattern, RegexOptions options);
public override string ToString();
public static string Unescape(string str);
protected bool UseOptionC();
protected bool UseOptionR();

Property
public RegexOptions Options {get;}
public bool RightToLeft {get;}

System.Diagnostics.DefaultTraceListener

Module:System.dll

Hierarchy
Object
MarshalByRefObject
TraceListener
DefaultTraceListener

Type declaration

[C#] public class DefaultTraceListener : TraceListener;

Constructor
public DefaultTraceListener();

Method
public virtual void Close();
public ObjRef CreateObjRef(Type requestedType);
public void Dispose();
protected virtual void Dispose(bool disposing);
public virtual bool Equals(object obj);
public virtual void Fail(string message);
public virtual void Fail(string message, string detailMessage);
protected override void Finalize();
public virtual void Flush();
public virtual int GetHashCode();
public object GetLifetimeService();
public Type GetType();
public object InitializeLifetimeService();
protected object MemberwiseClone();
public virtual string ToString();
public virtual void Write(object o);
public virtual void Write(object o, string category);
public override void Write(string message);
public virtual void Write(string message, string category);
protected virtual void WriteIndent();
public virtual void WriteLine(object o);
public virtual void WriteLine(object o, string category);
public override void WriteLine(string message);
public virtual void WriteLine(string message, string category);

Property
public bool AssertUiEnabled {get; set;}
public int IndentLevel {get; set;}
public int IndentSize {get; set;}
public string LogFileName {get; set;}
public virtual string Name {get; set;}
protected bool NeedIndent {get; set;}

System.Diagnostics.Debug

Module:System.dll

Hierarchy
Object
Debug

Type declaration

[C#] public sealed class Debug;

Method
public static void Assert(bool condition);
public static void Assert(bool condition, string message);
public static void Assert(bool condition, string message, string detailMessage);
public static void Close();
public virtual bool Equals(object obj);
public static void Fail(string message);
public static void Fail(string message, string detailMessage);
protected override void Finalize();
public static void Flush();
public virtual int GetHashCode();
public Type GetType();
public static void Indent();
protected object MemberwiseClone();
public virtual string ToString();
public static void Unindent();
public static void Write(object value);
public static void Write(object value, string category);
public static void Write(string message);
public static void Write(string message, string category);
public static void WriteIf(bool condition, object value);
public static void WriteIf(bool condition, object value, string category);
public static void WriteIf(bool condition, string message);
public static void WriteIf(bool condition, string message, string category);
public static void WriteLine(object value);
public static void WriteLine(object value, string category);
public static void WriteLine(string message);
public static void WriteLine(string message, string category);
public static void WriteLineIf(bool condition, object value);
public static void WriteLineIf(bool condition, object value, string category);
public static void WriteLineIf(bool condition, string message);
public static void WriteLineIf(bool condition, string message, string category);

Property
public static bool AutoFlush {get; set;}
public static int IndentLevel {get; set;}
public static int IndentSize {get; set;}
public static TraceListenerCollection Listeners {get;}

System.Diagnostics.TraceListenerCollection

Module:System.dll

Hierarchy
Object
TraceListenerCollection : IList, ICollection, IEnumerable

Type declaration

[C#] public class TraceListenerCollection: IList, ICollection, IEnumerable;

Method
public int Add(TraceListener listener);
public void AddRange(TraceListener[] value);
public void AddRange(TraceListenerCollection value);
public virtual void Clear();
public bool Contains(TraceListener listener);
public void CopyTo(TraceListener[] array, int index);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual IEnumerator GetEnumerator();
public virtual int GetHashCode();
public Type GetType();
public int IndexOf(TraceListener listener);
public void Insert(int index, TraceListener listener);
protected object MemberwiseClone();
public void Remove(string name);
public void Remove(TraceListener listener);
public virtual void RemoveAt(int index);
public virtual string ToString();

Property
public virtual int Count {get;}
public TraceListener this[int i] {get; set;}
public TraceListener this[string name] {get;}

System.Diagnostics.TraceListener

Module:System.dll

Hierarchy
Object
MarshalByRefObject
TraceListener

Type declaration

[C#] public abstract class TraceListener : MarshalByRefObject;

Constructor
protected TraceListener();
protected TraceListener(string name);

Method
public virtual void Close();
public ObjRef CreateObjRef(Type requestedType);
public virtual void Dispose();
protected virtual void Dispose(bool disposing);
public virtual bool Equals(object obj);
public virtual void Fail(string message);
public virtual void Fail(string message, string detailMessage);
protected override void Finalize();
public virtual void Flush();
public virtual int GetHashCode();
public object GetLifetimeService();
public Type GetType();
public object InitializeLifetimeService();
protected object MemberwiseClone();
public virtual string ToString();
public virtual void Write(object o);
public virtual void Write(object o, string category);
public abstract void Write(string message);
public virtual void Write(string message, string category);
protected virtual void WriteIndent();
public virtual void WriteLine(object o);
public virtual void WriteLine(object o, string category);
public abstract void WriteLine(string message);
public virtual void WriteLine(string message, string category);

Property
public int IndentLevel {get; set;}
public int IndentSize {get; set;}
public virtual string Name {get; set;}
protected bool NeedIndent {get; set;}

System.Diagnostics.Trace

Module:System.dll

Hierarchy
Object
Trace

Type declaration

[C#] public sealed class Trace;

Method
public static void Assert(bool condition);
public static void Assert(bool condition, string message);
public static void Assert(bool condition, string message, string detailMessage);
public static void Close();
public virtual bool Equals(object obj);
public static void Fail(string message);
public static void Fail(string message, string detailMessage);
protected override void Finalize();
public static void Flush();
public virtual int GetHashCode();
public Type GetType();
public static void Indent();
protected object MemberwiseClone();
public virtual string ToString();
public static void Unindent();
public static void Write(object value);
public static void Write(object value, string category);
public static void Write(string message);
public static void Write(string message, string category);
public static void WriteIf(bool condition, object value);
public static void WriteIf(bool condition, object value, string category);
public static void WriteIf(bool condition, string message);
public static void WriteIf(bool condition, string message, string category);
public static void WriteLine(object value);
public static void WriteLine(object value, string category);
public static void WriteLine(string message);
public static void WriteLine(string message, string category);
public static void WriteLineIf(bool condition, object value);
public static void WriteLineIf(bool condition, object value, string category);
public static void WriteLineIf(bool condition, string message);
public static void WriteLineIf(bool condition, string message, string category);

Property
public static bool AutoFlush {get; set;}
public static int IndentLevel {get; set;}
public static int IndentSize {get; set;}
public static TraceListenerCollection Listeners {get;}

System.Diagnostics.Debugger

Module:mscorlib.dll

Hierarchy
Object
Debugger

Type declaration

[C#] public sealed class Debugger;

Constructor
public Debugger();

Method
public static void Break();
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
public static bool IsLogging();
public static bool Launch();
public static void Log(int level, string category, string message);
protected object MemberwiseClone();
public virtual string ToString();

Property
public static bool IsAttached {get;}

Field
public readonly static string DefaultCategory;

System.Diagnostics.DebuggableAttribute

Module:mscorlib.dll

Hierarchy
Object
Attribute
DebuggableAttribute

Type declaration

[C#] public sealed class DebuggableAttribute : Attribute;

Constructor
public DebuggableAttribute(bool isJITTrackingEnabled, bool isJITOptimizerDisabled);

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public bool IsJITOptimizerDisabled {get;}
public bool IsJITTrackingEnabled {get;}
public object TypeId {get;}

System.Diagnostics.DebuggerStepThroughAttribute

Module:mscorlib.dll

Hierarchy
Object
Attribute
DebuggerStepThroughAttribute

Type declaration

[C#] public sealed class DebuggerStepThroughAttribute : Attribute;

Constructor
public DebuggerStepThroughAttribute();

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public object TypeId {get;}

System.Diagnostics.ConditionalAttribute

Module:mscorlib.dll

Hierarchy
Object
Attribute
ConditionalAttribute

Type declaration

[C#] public sealed class ConditionalAttribute : Attribute;

Constructor
public ConditionalAttribute(string conditionString);

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public string ConditionString {get;}
public object TypeId {get;}

System.Data.SqlDbType

Module:System.Data.Common.dll
Module:system.data.dll

Hierarchy
Object
ValueType
Enum
SqlDbType

Type declaration

[C#] public enum SqlDbType;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const SqlDbType BigInt = 0;
public const SqlDbType Binary = 1;
public const SqlDbType Bit = 2;
public const SqlDbType Char = 3;
public const SqlDbType DateTime = 4;
public const SqlDbType Decimal = 5;
public const SqlDbType Float = 6;
public const SqlDbType Image = 7;
public const SqlDbType Int = 8;
public const SqlDbType Money = 9;
public const SqlDbType NChar = 10;
public const SqlDbType NText = 11;
public const SqlDbType NVarChar = 12;
public const SqlDbType Real = 13;
public const SqlDbType SmallDateTime = 15;
public const SqlDbType SmallInt = 16;
public const SqlDbType SmallMoney = 17;
public const SqlDbType Text = 18;
public const SqlDbType Timestamp = 19;
public const SqlDbType TinyInt = 20;
public const SqlDbType UniqueIdentifier = 14;
public int value__;
public const SqlDbType VarBinary = 21;
public const SqlDbType VarChar = 22;
public const SqlDbType Variant = 23;

System.Data.UniqueConstraint

Module:System.Data.dll

Hierarchy
Object
Constraint
UniqueConstraint

Type declaration

[C#] public class UniqueConstraint : Constraint;

Constructor
public UniqueConstraint(DataColumn column);
public UniqueConstraint(DataColumn column, bool isPrimaryKey);
public UniqueConstraint(DataColumn[] columns);
public UniqueConstraint(DataColumn[] columns, bool isPrimaryKey);
public UniqueConstraint(string name, DataColumn column);
public UniqueConstraint(string name, DataColumn column, bool isPrimaryKey);
public UniqueConstraint(string name, DataColumn[] columns);
public UniqueConstraint(string name, DataColumn[] columns, bool isPrimaryKey);
public UniqueConstraint(string name, string[] columnNames, bool isPrimaryKey);

Method
protected void CheckStateForProperty();
public override bool Equals(object key2);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public virtual DataColumn[] Columns {get;}
public virtual string ConstraintName {get; set;}
public PropertyCollection ExtendedProperties {get;}
public bool IsPrimaryKey {get;}
public override DataTable Table {get;}

System.Data.ForeignKeyConstraint

Module:System.Data.dll

Hierarchy
Object
Constraint
ForeignKeyConstraint

Type declaration

[C#] public class ForeignKeyConstraint : Constraint;

Constructor
public ForeignKeyConstraint(DataColumn parentColumn, DataColumn childColumn);
public ForeignKeyConstraint(DataColumn[] parentColumns, DataColumn[] childColumns);
public ForeignKeyConstraint(string constraintName, DataColumn parentColumn, DataColumn childColumn);
public ForeignKeyConstraint(string constraintName, DataColumn[] parentColumns, DataColumn[] childColumns);
public ForeignKeyConstraint(string constraintName, string parentTableName, string[] parentColumnNames, string[] childColumnNames, AcceptRejectRule acceptRejectRule, Rule deleteRule, Rule updateRule);

Method
protected void CheckStateForProperty();
public override bool Equals(object key);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public virtual AcceptRejectRule AcceptRejectRule {get; set;}
public virtual DataColumn[] Columns {get;}
public virtual string ConstraintName {get; set;}
public virtual Rule DeleteRule {get; set;}
public PropertyCollection ExtendedProperties {get;}
public virtual DataColumn[] RelatedColumns {get;}
public virtual DataTable RelatedTable {get;}
public override DataTable Table {get;}
public virtual Rule UpdateRule {get; set;}

System.Data.DataViewSettingCollection

Module:System.Data.dll

Hierarchy
Object
DataViewSettingCollection : ICollection, IEnumerable

Type declaration

[C#] public class DataViewSettingCollection: ICollection, IEnumerable;

Method
public virtual void CopyTo(Array ar, int index);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual IEnumerator GetEnumerator();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public virtual int Count {get;}
public bool IsReadOnly {get;}
public virtual bool IsSynchronized {get;}
public virtual DataViewSetting this[DataTable table] {get; set;}
public virtual DataViewSetting this[int index] {get; set;}
public virtual DataViewSetting this[string tableName] {get;}
public virtual object SyncRoot {get;}

System.Data.DataViewManager

Module:System.Data.dll

Hierarchy
Object
MarshalByValueComponent
DataViewManager : IBindingList, IList, ICollection, IEnumerable, ITypedList

Type declaration

[C#] public class DataViewManager : MarshalByValueComponent, IBindingList, IList, ICollection, IEnumerable, ITypedList;

Constructor
public DataViewManager();
public DataViewManager(DataSet dataSet);

Method
public void add_Disposed(EventHandler value);
public virtual void add_ListChanged(ListChangedEventHandler value);
public DataView CreateDataView(DataTable table);
public void Dispose();
protected virtual void Dispose(bool disposing);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public object GetService(Type service);
public Type GetType();
protected object MemberwiseClone();
protected virtual void OnListChanged(ListChangedEventArgs e);
protected virtual void RelationCollectionChanged(object sender, CollectionChangeEventArgs e);
public void remove_Disposed(EventHandler value);
public virtual void remove_ListChanged(ListChangedEventHandler value);
protected virtual void TableCollectionChanged(object sender, CollectionChangeEventArgs e);
public virtual string ToString();

Property
public IContainer Container {get;}
public DataSet DataSet {get; set;}
public string DataViewSettingCollectionString {get; set;}
public DataViewSettingCollection DataViewSettings {get;}
public bool DesignMode {get;}
protected EventHandlerList Events {get;}
public ISite Site {get; set;}

System.Data.DataTableCollection

Module:System.Data.dll

Hierarchy
Object
InternalDataCollectionBase
DataTableCollection

Type declaration

[C#] public class DataTableCollection : InternalDataCollectionBase;

Method
public virtual DataTable Add();
public virtual void Add(DataTable table);
public virtual DataTable Add(string name);
public void add_CollectionChanged(CollectionChangeEventHandler value);
public void add_CollectionChanging(CollectionChangeEventHandler value);
public void AddRange(DataTable[] tables);
public bool CanRemove(DataTable table);
public void Clear();
public bool Contains(string name);
public virtual void CopyTo(Array ar, int index);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual IEnumerator GetEnumerator();
public virtual int GetHashCode();
public Type GetType();
public virtual int IndexOf(DataTable table);
public virtual int IndexOf(string tableName);
protected object MemberwiseClone();
protected virtual void OnCollectionChanged(CollectionChangeEventArgs ccevent);
public void Remove(DataTable table);
public void Remove(string name);
public void remove_CollectionChanged(CollectionChangeEventHandler value);
public void remove_CollectionChanging(CollectionChangeEventHandler value);
public void RemoveAt(int index);
public virtual string ToString();

Property
public virtual int Count {get;}
public bool IsReadOnly {get;}
public virtual bool IsSynchronized {get;}
public DataTable this[int index] {get;}
public DataTable this[string name] {get;}
protected override ArrayList List {get;}
public virtual object SyncRoot {get;}

System.Data.DataTable

Module:System.Data.dll

Hierarchy
Object
MarshalByValueComponent
DataTable : IListSource

Type declaration

[C#] public class DataTable : MarshalByValueComponent, IListSource;

Constructor
public DataTable();
protected DataTable(SerializationInfo info, StreamingContext context);
public DataTable(string tableName);

Method
public void AcceptChanges();
public void add_ColumnChanged(DataColumnChangeEventHandler value);
public void add_ColumnChanging(DataColumnChangeEventHandler value);
public void add_Disposed(EventHandler value);
public void add_RowChanged(DataRowChangeEventHandler value);
public void add_RowChanging(DataRowChangeEventHandler value);
public void add_RowDeleted(DataRowChangeEventHandler value);
public void add_RowDeleting(DataRowChangeEventHandler value);
public void BeginInit();
public void BeginLoadData();
public void Clear();
public virtual DataTable Clone();
public object Compute(string expression, string filter);
public DataTable Copy();
protected virtual DataTable CreateInstance();
public void Dispose();
protected virtual void Dispose(bool disposing);
public void EndInit();
public void EndLoadData();
public virtual bool Equals(object obj);
protected override void Finalize();
public DataTable GetChanges();
public DataTable GetChanges(DataRowState rowStates);
public DataRow[] GetErrors();
public virtual int GetHashCode();
protected virtual Type GetRowType();
public object GetService(Type service);
public Type GetType();
public void ImportRow(DataRow row);
public DataRow LoadDataRow(object[] values, bool fAcceptChanges);
protected object MemberwiseClone();
public DataRow NewRow();
protected virtual DataRow NewRowFromBuilder(DataRowBuilder builder);
protected virtual void OnColumnChanged(DataColumnChangeEventArgs e);
protected virtual void OnColumnChanging(DataColumnChangeEventArgs e);
protected virtual void OnRowChanged(DataRowChangeEventArgs e);
protected virtual void OnRowChanging(DataRowChangeEventArgs e);
protected virtual void OnRowDeleted(DataRowChangeEventArgs e);
protected virtual void OnRowDeleting(DataRowChangeEventArgs e);
public void RejectChanges();
public void remove_ColumnChanged(DataColumnChangeEventHandler value);
public void remove_ColumnChanging(DataColumnChangeEventHandler value);
public void remove_Disposed(EventHandler value);
public void remove_RowChanged(DataRowChangeEventHandler value);
public void remove_RowChanging(DataRowChangeEventHandler value);
public void remove_RowDeleted(DataRowChangeEventHandler value);
public void remove_RowDeleting(DataRowChangeEventHandler value);
public virtual void Reset();
public DataRow[] Select();
public DataRow[] Select(string filterExpression);
public DataRow[] Select(string filterExpression, string sort);
public DataRow[] Select(string filterExpression, string sort, DataViewRowState recordStates);
public override string ToString();

Property
public bool CaseSensitive {get; set;}
public DataRelationCollection ChildRelations {get;}
public DataColumnCollection Columns {get;}
public ConstraintCollection Constraints {get;}
public IContainer Container {get;}
public DataSet DataSet {get;}
public DataView DefaultView {get;}
public bool DesignMode {get;}
public string DisplayExpression {get; set;}
protected EventHandlerList Events {get;}
public PropertyCollection ExtendedProperties {get;}
public bool HasErrors {get;}
public CultureInfo Locale {get; set;}
public int MinimumCapacity {get; set;}
public string Namespace {get; set;}
public DataRelationCollection ParentRelations {get;}
public string Prefix {get; set;}
public DataColumn[] PrimaryKey {get; set;}
public DataRowCollection Rows {get;}
public override ISite Site {get; set;}
public string TableName {get; set;}

System.Data.DataSet

Module:System.Data.dll

Hierarchy
Object
MarshalByValueComponent
DataSet : IListSource, IXmlSerializable

Type declaration

[C#] public class DataSet : MarshalByValueComponent, IListSource, IXmlSerializable;

Constructor
public DataSet();
protected DataSet(SerializationInfo info, StreamingContext context);
public DataSet(string dataSetName);

Method
public void AcceptChanges();
public void add_Disposed(EventHandler value);
public void add_MergeFailed(MergeFailedEventHandler value);
public void BeginInit();
public void Clear();
public virtual DataSet Clone();
public DataSet Copy();
public void Dispose();
protected virtual void Dispose(bool disposing);
public void EndInit();
public virtual bool Equals(object obj);
protected override void Finalize();
public DataSet GetChanges();
public DataSet GetChanges(DataRowState rowStates);
public virtual int GetHashCode();
protected virtual XmlSchema GetSchemaSerializable();
protected void GetSerializationData(SerializationInfo info, StreamingContext context);
public object GetService(Type service);
public Type GetType();
public string GetXml();
public string GetXmlSchema();
public bool HasChanges();
public bool HasChanges(DataRowState rowStates);
public void InferXmlSchema(Stream stream, string[] nsArray);
public void InferXmlSchema(string fileName, string[] nsArray);
public void InferXmlSchema(TextReader reader, string[] nsArray);
public void InferXmlSchema(XmlReader reader, string[] nsArray);
protected object MemberwiseClone();
public void Merge(DataRow[] rows);
public void Merge(DataRow[] rows, bool preserveChanges, MissingSchemaAction missingSchemaAction);
public void Merge(DataSet dataSet);
public void Merge(DataSet dataSet, bool preserveChanges);
public void Merge(DataSet dataSet, bool preserveChanges, MissingSchemaAction missingSchemaAction);
public void Merge(DataTable table);
public void Merge(DataTable table, bool preserveChanges, MissingSchemaAction missingSchemaAction);
protected virtual void OnRemoveRelation(DataRelation relation);
protected virtual void OnRemoveTable(DataTable table);
public XmlReadMode ReadXml(Stream stream);
public XmlReadMode ReadXml(Stream stream, XmlReadMode mode);
public XmlReadMode ReadXml(string fileName);
public XmlReadMode ReadXml(string fileName, XmlReadMode mode);
public XmlReadMode ReadXml(TextReader reader);
public XmlReadMode ReadXml(TextReader reader, XmlReadMode mode);
public XmlReadMode ReadXml(XmlReader reader);
public XmlReadMode ReadXml(XmlReader reader, XmlReadMode mode);
public void ReadXmlSchema(Stream stream);
public void ReadXmlSchema(string fileName);
public void ReadXmlSchema(TextReader reader);
public void ReadXmlSchema(XmlReader reader);
protected virtual void ReadXmlSerializable(XmlReader reader);
public virtual void RejectChanges();
public void remove_Disposed(EventHandler value);
public void remove_MergeFailed(MergeFailedEventHandler value);
public virtual void Reset();
protected virtual bool ShouldSerializeRelations();
protected virtual bool ShouldSerializeTables();
public virtual string ToString();
public void WriteXml(Stream stream);
public void WriteXml(Stream stream, XmlWriteMode mode);
public void WriteXml(string fileName);
public void WriteXml(string fileName, XmlWriteMode mode);
public void WriteXml(TextWriter writer);
public void WriteXml(TextWriter writer, XmlWriteMode mode);
public void WriteXml(XmlWriter writer);
public void WriteXml(XmlWriter writer, XmlWriteMode mode);
public void WriteXmlSchema(Stream stream);
public void WriteXmlSchema(string fileName);
public void WriteXmlSchema(TextWriter writer);
public void WriteXmlSchema(XmlWriter writer);

Property
public bool CaseSensitive {get; set;}
public IContainer Container {get;}
public string DataSetName {get; set;}
public DataViewManager DefaultViewManager {get;}
public bool DesignMode {get;}
public bool EnforceConstraints {get; set;}
protected EventHandlerList Events {get;}
public PropertyCollection ExtendedProperties {get;}
public bool HasErrors {get;}
public CultureInfo Locale {get; set;}
public string Namespace {get; set;}
public string Prefix {get; set;}
public DataRelationCollection Relations {get;}
public override ISite Site {get; set;}
public DataTableCollection Tables {get;}

System.Data.DataRowView

Module:System.Data.dll

Hierarchy
Object
DataRowView : IEditableObject, IDataErrorInfo

Type declaration

[C#] public class DataRowView: IEditableObject, IDataErrorInfo;

Method
public virtual void BeginEdit();
public virtual void CancelEdit();
public DataView CreateChildView(DataRelation relation);
public DataView CreateChildView(string relationName);
public void Delete();
public virtual void EndEdit();
public override bool Equals(object other);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public DataView DataView {get;}
public bool IsEdit {get;}
public bool IsNew {get;}
public object this[int ndx] {get; set;}
public object this[string property] {get; set;}
public DataRow Row {get;}
public DataRowVersion RowVersion {get;}

System.Data.DataRowCollection

Module:System.Data.dll

Hierarchy
Object
InternalDataCollectionBase
DataRowCollection

Type declaration

[C#] public class DataRowCollection : InternalDataCollectionBase;

Method
public void Add(DataRow row);
public virtual DataRow Add(object[] values);
public void Clear();
public bool Contains(object key);
public bool Contains(object[] keys);
public virtual void CopyTo(Array ar, int index);
public virtual bool Equals(object obj);
protected override void Finalize();
public DataRow Find(object key);
public DataRow Find(object[] keys);
public virtual IEnumerator GetEnumerator();
public virtual int GetHashCode();
public Type GetType();
public void InsertAt(DataRow row, int pos);
protected object MemberwiseClone();
public void Remove(DataRow row);
public void RemoveAt(int index);
public virtual string ToString();

Property
public virtual int Count {get;}
public bool IsReadOnly {get;}
public virtual bool IsSynchronized {get;}
public DataRow this[int index] {get;}
protected override ArrayList List {get;}
public virtual object SyncRoot {get;}

System.Data.DataRowBuilder

Module:System.Data.dll

Hierarchy
Object
DataRowBuilder

Type declaration

[C#] public class DataRowBuilder;

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

System.Data.DataRow

Module:System.Data.dll

Hierarchy
Object
DataRow

Type declaration

[C#] public class DataRow;

Method
public void AcceptChanges();
public void BeginEdit();
public void CancelEdit();
public void ClearErrors();
public void Delete();
public void EndEdit();
public virtual bool Equals(object obj);
protected override void Finalize();
public DataRow[] GetChildRows(DataRelation relation);
public DataRow[] GetChildRows(DataRelation relation, DataRowVersion version);
public DataRow[] GetChildRows(string relationName);
public DataRow[] GetChildRows(string relationName, DataRowVersion version);
public string GetColumnError(DataColumn column);
public string GetColumnError(int columnIndex);
public string GetColumnError(string columnName);
public DataColumn[] GetColumnsInError();
public virtual int GetHashCode();
public DataRow GetParentRow(DataRelation relation);
public DataRow GetParentRow(DataRelation relation, DataRowVersion version);
public DataRow GetParentRow(string relationName);
public DataRow GetParentRow(string relationName, DataRowVersion version);
public DataRow[] GetParentRows(DataRelation relation);
public DataRow[] GetParentRows(DataRelation relation, DataRowVersion version);
public DataRow[] GetParentRows(string relationName);
public DataRow[] GetParentRows(string relationName, DataRowVersion version);
public Type GetType();
public bool HasVersion(DataRowVersion version);
public bool IsNull(DataColumn column);
public bool IsNull(DataColumn column, DataRowVersion version);
public bool IsNull(int columnIndex);
public bool IsNull(string columnName);
protected object MemberwiseClone();
public void RejectChanges();
public void SetColumnError(DataColumn column, string error);
public void SetColumnError(int columnIndex, string error);
public void SetColumnError(string columnName, string error);
protected void SetNull(DataColumn column);
public void SetParentRow(DataRow parentRow);
public void SetParentRow(DataRow parentRow, DataRelation relation);
public virtual string ToString();

Property
public bool HasErrors {get;}
public object this[DataColumn column, DataRowVersion version] {get;}
public object this[DataColumn column] {get; set;}
public object this[int columnIndex, DataRowVersion version] {get;}
public object this[int columnIndex] {get; set;}
public object this[string columnName, DataRowVersion version] {get;}
public object this[string columnName] {get; set;}
public object[] ItemArray {get; set;}
public string RowError {get; set;}
public DataRowState RowState {get;}
public DataTable Table {get;}

System.Data.DataRelationCollection

Module:System.Data.dll

Hierarchy
Object
InternalDataCollectionBase
DataRelationCollection

Type declaration

[C#] public abstract class DataRelationCollection : InternalDataCollectionBase;

Constructor
protected DataRelationCollection();

Method
public virtual DataRelation Add(DataColumn parentColumn, DataColumn childColumn);
public virtual DataRelation Add(DataColumn[] parentColumns, DataColumn[] childColumns);
public void Add(DataRelation relation);
public virtual DataRelation Add(string name, DataColumn parentColumn, DataColumn childColumn);
public virtual DataRelation Add(string name, DataColumn parentColumn, DataColumn childColumn, bool createConstraints);
public virtual DataRelation Add(string name, DataColumn[] parentColumns, DataColumn[] childColumns);
public virtual DataRelation Add(string name, DataColumn[] parentColumns, DataColumn[] childColumns, bool createConstraints);
public void add_CollectionChanged(CollectionChangeEventHandler value);
protected virtual void AddCore(DataRelation relation);
public virtual void AddRange(DataRelation[] relations);
public virtual bool CanRemove(DataRelation relation);
public virtual void Clear();
public virtual bool Contains(string name);
public virtual void CopyTo(Array ar, int index);
public virtual bool Equals(object obj);
protected override void Finalize();
protected abstract DataSet GetDataSet();
public virtual IEnumerator GetEnumerator();
public virtual int GetHashCode();
public Type GetType();
public virtual int IndexOf(DataRelation relation);
public virtual int IndexOf(string relationName);
protected object MemberwiseClone();
protected virtual void OnCollectionChanged(CollectionChangeEventArgs ccevent);
public void Remove(DataRelation relation);
public void Remove(string name);
public void remove_CollectionChanged(CollectionChangeEventHandler value);
public void RemoveAt(int index);
protected virtual void RemoveCore(DataRelation relation);
public virtual string ToString();

Property
public virtual int Count {get;}
public bool IsReadOnly {get;}
public virtual bool IsSynchronized {get;}
public abstract DataRelation this[int index] {get;}
public abstract DataRelation this[string name] {get;}
protected virtual ArrayList List {get;}
public virtual object SyncRoot {get;}

System.Data.DataRelation

Module:System.Data.dll

Hierarchy
Object
DataRelation

Type declaration

[C#] public class DataRelation;

Constructor
public DataRelation(string relationName, DataColumn parentColumn, DataColumn childColumn);
public DataRelation(string relationName, DataColumn parentColumn, DataColumn childColumn, bool createConstraints);
public DataRelation(string relationName, DataColumn[] parentColumns, DataColumn[] childColumns);
public DataRelation(string relationName, DataColumn[] parentColumns, DataColumn[] childColumns, bool createConstraints);
public DataRelation(string relationName, string parentTableName, string childTableName, string[] parentColumnNames, string[] childColumnNames, bool nested);

Method
protected void CheckStateForProperty();
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public virtual DataColumn[] ChildColumns {get;}
public virtual ForeignKeyConstraint ChildKeyConstraint {get;}
public virtual DataTable ChildTable {get;}
public virtual DataSet DataSet {get;}
public PropertyCollection ExtendedProperties {get;}
public virtual bool Nested {get; set;}
public virtual DataColumn[] ParentColumns {get;}
public virtual UniqueConstraint ParentKeyConstraint {get;}
public virtual DataTable ParentTable {get;}
public virtual string RelationName {get; set;}

System.Data.DataColumnCollection

Module:System.Data.dll

Hierarchy
Object
InternalDataCollectionBase
DataColumnCollection

Type declaration

[C#] public class DataColumnCollection : InternalDataCollectionBase;

Method
public virtual DataColumn Add();
public void Add(DataColumn column);
public virtual DataColumn Add(string columnName);
public virtual DataColumn Add(string columnName, Type type);
public virtual DataColumn Add(string columnName, Type type, string expression);
public void add_CollectionChanged(CollectionChangeEventHandler value);
public void AddRange(DataColumn[] columns);
public bool CanRemove(DataColumn column);
public void Clear();
public bool Contains(string name);
public virtual void CopyTo(Array ar, int index);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual IEnumerator GetEnumerator();
public virtual int GetHashCode();
public Type GetType();
public virtual int IndexOf(DataColumn column);
public int IndexOf(string columnName);
protected object MemberwiseClone();
protected virtual void OnCollectionChanged(CollectionChangeEventArgs ccevent);
public void Remove(DataColumn column);
public void Remove(string name);
public void remove_CollectionChanged(CollectionChangeEventHandler value);
public void RemoveAt(int index);
public virtual string ToString();

Property
public virtual int Count {get;}
public bool IsReadOnly {get;}
public virtual bool IsSynchronized {get;}
public virtual DataColumn this[int index] {get;}
public virtual DataColumn this[string name] {get;}
protected override ArrayList List {get;}
public virtual object SyncRoot {get;}

System.Data.DataColumn

Module:System.Data.dll

Hierarchy
Object
MarshalByValueComponent
DataColumn

Type declaration

[C#] public class DataColumn : MarshalByValueComponent;

Constructor
public DataColumn();
public DataColumn(string columnName);
public DataColumn(string columnName, Type dataType);
public DataColumn(string columnName, Type dataType, string expr);
public DataColumn(string columnName, Type dataType, string expr, MappingType type);

Method
public void add_Disposed(EventHandler value);
protected void CheckUnique();
public void Dispose();
protected virtual void Dispose(bool disposing);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public object GetService(Type service);
public Type GetType();
protected object MemberwiseClone();
public void remove_Disposed(EventHandler value);
public override string ToString();

Property
public bool AllowDBNull {get; set;}
public bool AutoIncrement {get; set;}
public long AutoIncrementSeed {get; set;}
public long AutoIncrementStep {get; set;}
public string Caption {get; set;}
public virtual MappingType ColumnMapping {get; set;}
public string ColumnName {get; set;}
public IContainer Container {get;}
public Type DataType {get; set;}
public object DefaultValue {get; set;}
public bool DesignMode {get;}
protected EventHandlerList Events {get;}
public string Expression {get; set;}
public PropertyCollection ExtendedProperties {get;}
public int MaxLength {get; set;}
public string Namespace {get; set;}
public int Ordinal {get;}
public string Prefix {get; set;}
public bool ReadOnly {get; set;}
public ISite Site {get; set;}
public DataTable Table {get;}
public bool Unique {get; set;}

System.Data.ConstraintCollection

Module:System.Data.dll

Hierarchy
Object
InternalDataCollectionBase
ConstraintCollection

Type declaration

[C#] public class ConstraintCollection : InternalDataCollectionBase;

Method
public void Add(Constraint constraint);
public virtual Constraint Add(string name, DataColumn column, bool primaryKey);
public virtual Constraint Add(string name, DataColumn primaryKeyColumn, DataColumn foreignKeyColumn);
public virtual Constraint Add(string name, DataColumn[] columns, bool primaryKey);
public virtual Constraint Add(string name, DataColumn[] primaryKeyColumns, DataColumn[] foreignKeyColumns);
public void add_CollectionChanged(CollectionChangeEventHandler value);
public void AddRange(Constraint[] constraints);
public bool CanRemove(Constraint constraint);
public void Clear();
public bool Contains(string name);
public virtual void CopyTo(Array ar, int index);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual IEnumerator GetEnumerator();
public virtual int GetHashCode();
public Type GetType();
public int IndexOf(Constraint constraint);
public virtual int IndexOf(string constraintName);
protected object MemberwiseClone();
protected virtual void OnCollectionChanged(CollectionChangeEventArgs ccevent);
public void Remove(Constraint constraint);
public void Remove(string name);
public void remove_CollectionChanged(CollectionChangeEventHandler value);
public void RemoveAt(int index);
public virtual string ToString();

Property
public virtual int Count {get;}
public bool IsReadOnly {get;}
public virtual bool IsSynchronized {get;}
public virtual Constraint this[int index] {get;}
public virtual Constraint this[string name] {get;}
protected override ArrayList List {get;}
public virtual object SyncRoot {get;}

System.Data.Constraint

Module:System.Data.dll

Hierarchy
Object
Constraint

Type declaration

[C#] public abstract class Constraint;

Constructor
protected Constraint();

Method
protected void CheckStateForProperty();
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public virtual string ConstraintName {get; set;}
public PropertyCollection ExtendedProperties {get;}
public abstract DataTable Table {get;}

System.Data.SyntaxErrorException

Module:System.Data.dll

Hierarchy
Object
Exception
SystemException
DataException
InvalidExpressionException
SyntaxErrorException

Type declaration

[C#] public class SyntaxErrorException : InvalidExpressionException;

Constructor
public SyntaxErrorException();
protected SyntaxErrorException(SerializationInfo info, StreamingContext context);
public SyntaxErrorException(string s);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public virtual string Message {get;}
public string Source {get; set;}
public string StackTrace {get;}
public MethodBase TargetSite {get;}

System.Data.EvaluateException

Module:System.Data.dll

Hierarchy
Object
Exception
SystemException
DataException
InvalidExpressionException
EvaluateException

Type declaration

[C#] public class EvaluateException : InvalidExpressionException;

Constructor
public EvaluateException();
protected EvaluateException(SerializationInfo info, StreamingContext context);
public EvaluateException(string s);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public virtual string Message {get;}
public string Source {get; set;}
public string StackTrace {get;}
public MethodBase TargetSite {get;}

System.Data.InvalidExpressionException

Module:System.Data.dll

Hierarchy
Object
Exception
SystemException
DataException
InvalidExpressionException

Type declaration

[C#] public class InvalidExpressionException : DataException;

Constructor
public InvalidExpressionException();
protected InvalidExpressionException(SerializationInfo info, StreamingContext context);
public InvalidExpressionException(string s);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public virtual string Message {get;}
public string Source {get; set;}
public string StackTrace {get;}
public MethodBase TargetSite {get;}

System.Data.XmlWriteMode

Module:System.Data.dll

Hierarchy
Object
ValueType
Enum
XmlWriteMode

Type declaration

[C#] public enum XmlWriteMode;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const XmlWriteMode DiffGram = 2;
public const XmlWriteMode IgnoreSchema = 1;
public int value__;
public const XmlWriteMode WriteSchema = 0;

System.Data.XmlReadMode

Module:System.Data.dll

Hierarchy
Object
ValueType
Enum
XmlReadMode

Type declaration

[C#] public enum XmlReadMode;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const XmlReadMode Auto = 0;
public const XmlReadMode DiffGram = 4;
public const XmlReadMode Fragment = 5;
public const XmlReadMode IgnoreSchema = 2;
public const XmlReadMode InferSchema = 3;
public const XmlReadMode ReadSchema = 1;
public int value__;

System.Data.UpdateStatus

Module:System.Data.dll

Hierarchy
Object
ValueType
Enum
UpdateStatus

Type declaration

[C#] public enum UpdateStatus;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const UpdateStatus Continue = 0;
public const UpdateStatus ErrorsOccurred = 1;
public const UpdateStatus SkipAllRemainingRows = 3;
public const UpdateStatus SkipCurrentRow = 2;
public int value__;

System.Data.UpdateRowSource

Module:System.Data.dll

Hierarchy
Object
ValueType
Enum
UpdateRowSource

Type declaration

[C#] public enum UpdateRowSource;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const UpdateRowSource Both = 3;
public const UpdateRowSource FirstReturnedRecord = 2;
public const UpdateRowSource None = 0;
public const UpdateRowSource OutputParameters = 1;
public int value__;

System.Data.StatementType

Module:System.Data.dll

Hierarchy
Object
ValueType
Enum
StatementType

Type declaration

[C#] public enum StatementType;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const StatementType Delete = 3;
public const StatementType Insert = 1;
public const StatementType Select = 0;
public const StatementType Update = 2;
public int value__;

System.Data.StateChangeEventHandler

Module:System.Data.dll

Hierarchy
Object
Delegate
MulticastDelegate
StateChangeEventHandler

Type declaration

[C#] public delegate void StateChangeEventHandler(object sender, StateChangeEventArgs e);

Constructor
public StateChangeEventHandler(object object, IntPtr method);

Method
public virtual IAsyncResult BeginInvoke(object sender, StateChangeEventArgs e, AsyncCallback callback, object object);
public object Clone();
protected override Delegate CombineImpl(Delegate follow);
public object DynamicInvoke(object[] args);
protected virtual object DynamicInvokeImpl(object[] args);
public virtual void EndInvoke(IAsyncResult result);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public override Delegate[] GetInvocationList();
protected virtual MethodInfo GetMethodImpl();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
public override void Invoke(object sender, StateChangeEventArgs e);
protected object MemberwiseClone();
protected override Delegate RemoveImpl(Delegate value);
public virtual string ToString();

Property
public MethodInfo Method {get;}
public object Target {get;}

System.Data.StateChangeEventArgs

Module:System.Data.dll

Hierarchy
Object
EventArgs
StateChangeEventArgs

Type declaration

[C#] public sealed class StateChangeEventArgs : EventArgs;

Constructor
public StateChangeEventArgs(ConnectionState originalState, ConnectionState currentState);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public ConnectionState CurrentState {get;}
public ConnectionState OriginalState {get;}

System.Data.SchemaType

Module:System.Data.dll

Hierarchy
Object
ValueType
Enum
SchemaType

Type declaration

[C#] public enum SchemaType;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const SchemaType Mapped = 2;
public const SchemaType Source = 1;
public int value__;

System.Data.Rule

Module:System.Data.dll

Hierarchy
Object
ValueType
Enum
Rule

Type declaration

[C#] public enum Rule;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const Rule Cascade = 1;
public const Rule None = 0;
public const Rule SetDefault = 3;
public const Rule SetNull = 2;
public int value__;

System.Data.DataView

Module:System.Data.dll

Hierarchy
Object
MarshalByValueComponent
DataView : IBindingList, IList, ICollection, IEnumerable, ITypedList

Type declaration

[C#] public class DataView : MarshalByValueComponent, IBindingList, IList, ICollection, IEnumerable, ITypedList;

Constructor
public DataView();
public DataView(DataTable table);
public DataView(DataTable table, string RowFilter, string Sort, DataViewRowState RowState);

Method
public void add_Disposed(EventHandler value);
public virtual void add_ListChanged(ListChangedEventHandler value);
public virtual DataRowView AddNew();
public void BeginInit();
protected void Close();
protected virtual void ColumnCollectionChanged(object sender, CollectionChangeEventArgs e);
public virtual void CopyTo(Array array, int index);
public void Delete(int index);
public void Dispose();
protected virtual void Dispose(bool disposing);
public void EndInit();
public virtual bool Equals(object obj);
protected override void Finalize();
public int Find(object key);
public int Find(object[] key);
public DataRowView[] FindRows(object key);
public DataRowView[] FindRows(object[] key);
public virtual IEnumerator GetEnumerator();
public virtual int GetHashCode();
public object GetService(Type service);
public Type GetType();
protected virtual void IndexListChanged(object sender, ListChangedEventArgs e);
protected object MemberwiseClone();
protected virtual void OnListChanged(ListChangedEventArgs e);
protected void Open();
public void remove_Disposed(EventHandler value);
public virtual void remove_ListChanged(ListChangedEventHandler value);
protected void Reset();
public virtual string ToString();
protected void UpdateIndex();
protected virtual void UpdateIndex(bool force);

Property
public bool AllowDelete {get; set;}
public bool AllowEdit {get; set;}
public bool AllowNew {get; set;}
public bool ApplyDefaultSort {get; set;}
public IContainer Container {get;}
public virtual int Count {get;}
public DataViewManager DataViewManager {get;}
public bool DesignMode {get;}
protected EventHandlerList Events {get;}
protected bool IsOpen {get;}
public DataRowView this[int recordIndex] {get;}
public virtual string RowFilter {get; set;}
public DataViewRowState RowStateFilter {get; set;}
public ISite Site {get; set;}
public string Sort {get; set;}
public DataTable Table {get; set;}

System.Data.PropertyAttributes

Module:System.Data.dll

Hierarchy
Object
ValueType
Enum
PropertyAttributes

Type declaration

[C#] public enum PropertyAttributes;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const PropertyAttributes NotSupported = 0;
public const PropertyAttributes Optional = 2;
public const PropertyAttributes Read = 512;
public const PropertyAttributes Required = 1;
public int value__;
public const PropertyAttributes Write = 1024;

System.Data.PropertyCollection

Module:System.Data.dll

Hierarchy
Object
Hashtable
PropertyCollection

Type declaration

[C#] public class PropertyCollection : Hashtable;

Constructor
public PropertyCollection();

Method
public virtual void Add(object key, object value);
public virtual void Clear();
public virtual object Clone();
public virtual bool Contains(object key);
public virtual bool ContainsKey(object key);
public virtual bool ContainsValue(object value);
public virtual void CopyTo(Array array, int arrayIndex);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual IDictionaryEnumerator GetEnumerator();
protected virtual int GetHash(object key);
public virtual int GetHashCode();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected virtual bool KeyEquals(object item, object key);
protected object MemberwiseClone();
public void OnDeserialization(object sender);
public virtual void Remove(object key);
public virtual string ToString();

Property
protected IComparer comparer {get; set;}
public virtual int Count {get;}
protected IHashCodeProvider hcp {get; set;}
public virtual bool IsFixedSize {get;}
public virtual bool IsReadOnly {get;}
public virtual bool IsSynchronized {get;}
public virtual object this[object key] {get; set;}
public virtual ICollection Keys {get;}
public virtual object SyncRoot {get;}
public virtual ICollection Values {get;}

System.Data.ParameterDirection

Module:System.Data.dll

Hierarchy
Object
ValueType
Enum
ParameterDirection

Type declaration

[C#] public enum ParameterDirection;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const ParameterDirection Input = 1;
public const ParameterDirection InputOutput = 3;
public const ParameterDirection Output = 2;
public const ParameterDirection ReturnValue = 6;
public int value__;

System.Data.MissingSchemaAction

Module:System.Data.dll

Hierarchy
Object
ValueType
Enum
MissingSchemaAction

Type declaration

[C#] public enum MissingSchemaAction;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const MissingSchemaAction Add = 1;
public const MissingSchemaAction AddWithKey = 4;
public const MissingSchemaAction Error = 3;
public const MissingSchemaAction Ignore = 2;
public int value__;

System.Data.MissingMappingAction

Module:System.Data.dll

Hierarchy
Object
ValueType
Enum
MissingMappingAction

Type declaration

[C#] public enum MissingMappingAction;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const MissingMappingAction Error = 3;
public const MissingMappingAction Ignore = 2;
public const MissingMappingAction Passthrough = 1;
public int value__;

System.Data.MappingType

Module:System.Data.dll

Hierarchy
Object
ValueType
Enum
MappingType

Type declaration

[C#] public enum MappingType;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const MappingType Attribute = 2;
public const MappingType Element = 1;
public const MappingType Hidden = 4;
public const MappingType SimpleContent = 3;
public int value__;

System.Data.ITableMappingCollection

Module:System.Data.dll

Hierarchy
ITableMappingCollection : IList, ICollection, IEnumerable

Type declaration

[C#] public interface ITableMappingCollection: IList, ICollection, IEnumerable;

Method
public ITableMapping Add(string sourceTableName, string dataSetTableName);
public bool Contains(string sourceTableName);
public ITableMapping GetByDataSetTable(string dataSetTableName);
public int IndexOf(string sourceTableName);
public void RemoveAt(string sourceTableName);

Property
public object this[string index] {get; set;}

System.Data.ITableMapping

Module:System.Data.dll

Hierarchy
ITableMapping

Type declaration

[C#] public interface ITableMapping;

Property
public IColumnMappingCollection ColumnMappings {get;}
public string DataSetTable {get; set;}
public string SourceTable {get; set;}

System.Data.IsolationLevel

Module:System.Data.dll

Hierarchy
Object
ValueType
Enum
IsolationLevel

Type declaration

[C#] public enum IsolationLevel;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const IsolationLevel Chaos = 16;
public const IsolationLevel ReadCommitted = 4096;
public const IsolationLevel ReadUncommitted = 256;
public const IsolationLevel RepeatableRead = 65536;
public const IsolationLevel Serializable = 1048576;
public const IsolationLevel Unspecified = -1;
public int value__;

System.Data.IDbTransaction

Module:System.Data.dll

Hierarchy
IDbTransaction

Type declaration

[C#] public interface IDbTransaction;

Method
public void Commit();
public void Rollback();

Property
public IDbConnection Connection {get;}
public IsolationLevel IsolationLevel {get;}

System.Data.IDbDataAdapter

Module:System.Data.dll

Hierarchy
IDbDataAdapter : IDataAdapter

Type declaration

[C#] public interface IDbDataAdapter: IDataAdapter;

Property
public IDbCommand DeleteCommand {get; set;}
public IDbCommand InsertCommand {get; set;}
public IDbCommand SelectCommand {get; set;}
public IDbCommand UpdateCommand {get; set;}

System.Data.IDbConnection

Module:System.Data.dll

Hierarchy
IDbConnection

Type declaration

[C#] public interface IDbConnection;

Method
public IDbTransaction BeginTransaction();
public IDbTransaction BeginTransaction(IsolationLevel il);
public void ChangeDatabase(string databaseName);
public void Close();
public IDbCommand CreateCommand();
public void Open();

Property
public string ConnectionString {get; set;}
public int ConnectionTimeout {get;}
public string Database {get;}
public ConnectionState State {get;}

System.Data.IDbCommand

Module:System.Data.dll

Hierarchy
IDbCommand : IDisposable

Type declaration

[C#] public interface IDbCommand: IDisposable;

Method
public void Cancel();
public IDbDataParameter CreateParameter();
public int ExecuteNonQuery();
public IDataReader ExecuteReader();
public IDataReader ExecuteReader(CommandBehavior behavior);
public object ExecuteScalar();
public void Prepare();

Property
public string CommandText {get; set;}
public int CommandTimeout {get; set;}
public CommandType CommandType {get; set;}
public IDbConnection Connection {get; set;}
public IDataParameterCollection Parameters {get;}
public IDbTransaction Transaction {get; set;}
public UpdateRowSource UpdatedRowSource {get; set;}

System.Data.IDbDataParameter

Module:System.Data.dll

Hierarchy
IDbDataParameter : IDataParameter

Type declaration

[C#] public interface IDbDataParameter: IDataParameter;

Property
public byte Precision {get; set;}
public byte Scale {get; set;}
public int Size {get; set;}

System.Data.IDataAdapter

Module:System.Data.dll

Hierarchy
IDataAdapter

Type declaration

[C#] public interface IDataAdapter;

Method
public int Fill(DataSet dataSet);
public DataTable[] FillSchema(DataSet dataSet, SchemaType schemaType);
public IDataParameter[] GetFillParameters();
public int Update(DataSet dataSet);

Property
public MissingMappingAction MissingMappingAction {get; set;}
public MissingSchemaAction MissingSchemaAction {get; set;}
public ITableMappingCollection TableMappings {get;}

System.Data.IDataReader

Module:System.Data.dll

Hierarchy
IDataReader : IDisposable, IDataRecord

Type declaration

[C#] public interface IDataReader: IDisposable, IDataRecord;

Method
public void Close();
public DataTable GetSchemaTable();
public bool NextResult();
public bool Read();

Property
public int Depth {get;}
public bool IsClosed {get;}
public int RecordsAffected {get;}

System.Data.IDataRecord

Module:System.Data.dll

Hierarchy
IDataRecord

Type declaration

[C#] public interface IDataRecord;

Method
public bool GetBoolean(int i);
public byte GetByte(int i);
public long GetBytes(int i, long fieldOffset, byte[] buffer, int bufferoffset, int length);
public char GetChar(int i);
public long GetChars(int i, long fieldoffset, char[] buffer, int bufferoffset, int length);
public IDataReader GetData(int i);
public string GetDataTypeName(int i);
public DateTime GetDateTime(int i);
public decimal GetDecimal(int i);
public double GetDouble(int i);
public Type GetFieldType(int i);
public float GetFloat(int i);
public Guid GetGuid(int i);
public short GetInt16(int i);
public int GetInt32(int i);
public long GetInt64(int i);
public string GetName(int i);
public int GetOrdinal(string name);
public string GetString(int i);
public object GetValue(int i);
public int GetValues(object[] values);
public bool IsDBNull(int i);

Property
public int FieldCount {get;}
public object this[int i] {get;}
public object this[string name] {get;}

System.Data.IDataParameterCollection

Module:System.Data.dll

Hierarchy
IDataParameterCollection : IList, ICollection, IEnumerable

Type declaration

[C#] public interface IDataParameterCollection: IList, ICollection, IEnumerable;

Method
public bool Contains(string parameterName);
public int IndexOf(string parameterName);
public void RemoveAt(string parameterName);

Property
public object this[string parameterName] {get; set;}

System.Data.IDataParameter

Module:System.Data.dll

Hierarchy
IDataParameter

Type declaration

[C#] public interface IDataParameter;

Property
public DbType DbType {get; set;}
public ParameterDirection Direction {get; set;}
public bool IsNullable {get;}
public string ParameterName {get; set;}
public string SourceColumn {get; set;}
public DataRowVersion SourceVersion {get; set;}
public object Value {get; set;}

System.Data.IColumnMappingCollection

Module:System.Data.dll

Hierarchy
IColumnMappingCollection : IList, ICollection, IEnumerable

Type declaration

[C#] public interface IColumnMappingCollection: IList, ICollection, IEnumerable;

Method
public IColumnMapping Add(string sourceColumnName, string dataSetColumnName);
public bool Contains(string sourceColumnName);
public IColumnMapping GetByDataSetColumn(string dataSetColumnName);
public int IndexOf(string sourceColumnName);
public void RemoveAt(string sourceColumnName);

Property
public object this[string index] {get; set;}

System.Data.IColumnMapping

Module:System.Data.dll

Hierarchy
IColumnMapping

Type declaration

[C#] public interface IColumnMapping;

Property
public string DataSetColumn {get; set;}
public string SourceColumn {get; set;}

System.Data.FillErrorEventHandler

Module:System.Data.dll

Hierarchy
Object
Delegate
MulticastDelegate
FillErrorEventHandler

Type declaration

[C#] public delegate void FillErrorEventHandler(object sender, FillErrorEventArgs e);

Constructor
public FillErrorEventHandler(object object, IntPtr method);

Method
public virtual IAsyncResult BeginInvoke(object sender, FillErrorEventArgs e, AsyncCallback callback, object object);
public object Clone();
protected override Delegate CombineImpl(Delegate follow);
public object DynamicInvoke(object[] args);
protected virtual object DynamicInvokeImpl(object[] args);
public virtual void EndInvoke(IAsyncResult result);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public override Delegate[] GetInvocationList();
protected virtual MethodInfo GetMethodImpl();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
public override void Invoke(object sender, FillErrorEventArgs e);
protected object MemberwiseClone();
protected override Delegate RemoveImpl(Delegate value);
public virtual string ToString();

Property
public MethodInfo Method {get;}
public object Target {get;}

System.Data.FillErrorEventArgs

Module:System.Data.dll

Hierarchy
Object
EventArgs
FillErrorEventArgs

Type declaration

[C#] public class FillErrorEventArgs : EventArgs;

Constructor
public FillErrorEventArgs(DataTable dataTable, object[] values);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public bool Continue {get; set;}
public DataTable DataTable {get;}
public Exception Errors {get; set;}
public object[] Values {get;}

System.Data.DbType

Module:System.Data.dll

Hierarchy
Object
ValueType
Enum
DbType

Type declaration

[C#] public enum DbType;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const DbType AnsiString = 0;
public const DbType AnsiStringFixedLength = 22;
public const DbType Binary = 1;
public const DbType Boolean = 3;
public const DbType Byte = 2;
public const DbType Currency = 4;
public const DbType Date = 5;
public const DbType DateTime = 6;
public const DbType Decimal = 7;
public const DbType Double = 8;
public const DbType Guid = 9;
public const DbType Int16 = 10;
public const DbType Int32 = 11;
public const DbType Int64 = 12;
public const DbType Object = 13;
public const DbType SByte = 14;
public const DbType Single = 15;
public const DbType String = 16;
public const DbType StringFixedLength = 23;
public const DbType Time = 17;
public const DbType UInt16 = 18;
public const DbType UInt32 = 19;
public const DbType UInt64 = 20;
public int value__;
public const DbType VarNumeric = 21;

System.Data.DBConcurrencyException

Module:System.Data.dll

Hierarchy
Object
Exception
SystemException
DBConcurrencyException

Type declaration

[C#] public sealed class DBConcurrencyException : SystemException;

Constructor
public DBConcurrencyException();
public DBConcurrencyException(string message);
public DBConcurrencyException(string message, Exception inner);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public override void GetObjectData(SerializationInfo si, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public virtual string Message {get;}
public DataRow Row {get; set;}
public string Source {get; set;}
public string StackTrace {get;}
public MethodBase TargetSite {get;}

System.Data.DataViewSetting

Module:System.Data.dll

Hierarchy
Object
DataViewSetting

Type declaration

[C#] public class DataViewSetting;

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public bool ApplyDefaultSort {get; set;}
public DataViewManager DataViewManager {get;}
public string RowFilter {get; set;}
public DataViewRowState RowStateFilter {get; set;}
public string Sort {get; set;}
public DataTable Table {get;}

System.Data.DataViewRowState

Module:System.Data.dll

Hierarchy
Object
ValueType
Enum
DataViewRowState

Type declaration

[C#] public enum DataViewRowState;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const DataViewRowState Added = 4;
public const DataViewRowState CurrentRows = 22;
public const DataViewRowState Deleted = 8;
public const DataViewRowState ModifiedCurrent = 16;
public const DataViewRowState ModifiedOriginal = 32;
public const DataViewRowState None = 0;
public const DataViewRowState OriginalRows = 42;
public const DataViewRowState Unchanged = 2;
public int value__;

System.Data.DataRowVersion

Module:System.Data.dll

Hierarchy
Object
ValueType
Enum
DataRowVersion

Type declaration

[C#] public enum DataRowVersion;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const DataRowVersion Current = 512;
public const DataRowVersion Default = 1536;
public const DataRowVersion Original = 256;
public const DataRowVersion Proposed = 1024;
public int value__;

System.Data.DataRowState

Module:System.Data.dll

Hierarchy
Object
ValueType
Enum
DataRowState

Type declaration

[C#] public enum DataRowState;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const DataRowState Added = 4;
public const DataRowState Deleted = 8;
public const DataRowState Detached = 1;
public const DataRowState Modified = 16;
public const DataRowState Unchanged = 2;
public int value__;

System.Data.DataRowChangeEventHandler

Module:System.Data.dll

Hierarchy
Object
Delegate
MulticastDelegate
DataRowChangeEventHandler

Type declaration

[C#] public delegate void DataRowChangeEventHandler(object sender, DataRowChangeEventArgs e);

Constructor
public DataRowChangeEventHandler(object object, IntPtr method);

Method
public virtual IAsyncResult BeginInvoke(object sender, DataRowChangeEventArgs e, AsyncCallback callback, object object);
public object Clone();
protected override Delegate CombineImpl(Delegate follow);
public object DynamicInvoke(object[] args);
protected virtual object DynamicInvokeImpl(object[] args);
public virtual void EndInvoke(IAsyncResult result);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public override Delegate[] GetInvocationList();
protected virtual MethodInfo GetMethodImpl();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
public override void Invoke(object sender, DataRowChangeEventArgs e);
protected object MemberwiseClone();
protected override Delegate RemoveImpl(Delegate value);
public virtual string ToString();

Property
public MethodInfo Method {get;}
public object Target {get;}

System.Data.DataRowChangeEventArgs

Module:System.Data.dll

Hierarchy
Object
EventArgs
DataRowChangeEventArgs

Type declaration

[C#] public class DataRowChangeEventArgs : EventArgs;

Constructor
public DataRowChangeEventArgs(DataRow row, DataRowAction action);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public DataRowAction Action {get;}
public DataRow Row {get;}

System.Data.DataRowAction

Module:System.Data.dll

Hierarchy
Object
ValueType
Enum
DataRowAction

Type declaration

[C#] public enum DataRowAction;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const DataRowAction Add = 16;
public const DataRowAction Change = 2;
public const DataRowAction Commit = 8;
public const DataRowAction Delete = 1;
public const DataRowAction Nothing = 0;
public const DataRowAction Rollback = 4;
public int value__;

System.Data.VersionNotFoundException

Module:System.Data.dll

Hierarchy
Object
Exception
SystemException
DataException
VersionNotFoundException

Type declaration

[C#] public class VersionNotFoundException : DataException;

Constructor
public VersionNotFoundException();
protected VersionNotFoundException(SerializationInfo info, StreamingContext context);
public VersionNotFoundException(string s);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public virtual string Message {get;}
public string Source {get; set;}
public string StackTrace {get;}
public MethodBase TargetSite {get;}

System.Data.RowNotInTableException

Module:System.Data.dll

Hierarchy
Object
Exception
SystemException
DataException
RowNotInTableException

Type declaration

[C#] public class RowNotInTableException : DataException;

Constructor
public RowNotInTableException();
protected RowNotInTableException(SerializationInfo info, StreamingContext context);
public RowNotInTableException(string s);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public virtual string Message {get;}
public string Source {get; set;}
public string StackTrace {get;}
public MethodBase TargetSite {get;}

System.Data.ReadOnlyException

Module:System.Data.dll

Hierarchy
Object
Exception
SystemException
DataException
ReadOnlyException

Type declaration

[C#] public class ReadOnlyException : DataException;

Constructor
public ReadOnlyException();
protected ReadOnlyException(SerializationInfo info, StreamingContext context);
public ReadOnlyException(string s);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public virtual string Message {get;}
public string Source {get; set;}
public string StackTrace {get;}
public MethodBase TargetSite {get;}

System.Data.NoNullAllowedException

Module:System.Data.dll

Hierarchy
Object
Exception
SystemException
DataException
NoNullAllowedException

Type declaration

[C#] public class NoNullAllowedException : DataException;

Constructor
public NoNullAllowedException();
protected NoNullAllowedException(SerializationInfo info, StreamingContext context);
public NoNullAllowedException(string s);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public virtual string Message {get;}
public string Source {get; set;}
public string StackTrace {get;}
public MethodBase TargetSite {get;}

System.Data.MissingPrimaryKeyException

Module:System.Data.dll

Hierarchy
Object
Exception
SystemException
DataException
MissingPrimaryKeyException

Type declaration

[C#] public class MissingPrimaryKeyException : DataException;

Constructor
public MissingPrimaryKeyException();
protected MissingPrimaryKeyException(SerializationInfo info, StreamingContext context);
public MissingPrimaryKeyException(string s);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public virtual string Message {get;}
public string Source {get; set;}
public string StackTrace {get;}
public MethodBase TargetSite {get;}

System.Data.InvalidConstraintException

Module:System.Data.dll

Hierarchy
Object
Exception
SystemException
DataException
InvalidConstraintException

Type declaration

[C#] public class InvalidConstraintException : DataException;

Constructor
public InvalidConstraintException();
protected InvalidConstraintException(SerializationInfo info, StreamingContext context);
public InvalidConstraintException(string s);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public virtual string Message {get;}
public string Source {get; set;}
public string StackTrace {get;}
public MethodBase TargetSite {get;}

System.Data.InRowChangingEventException

Module:System.Data.dll

Hierarchy
Object
Exception
SystemException
DataException
InRowChangingEventException

Type declaration

[C#] public class InRowChangingEventException : DataException;

Constructor
public InRowChangingEventException();
protected InRowChangingEventException(SerializationInfo info, StreamingContext context);
public InRowChangingEventException(string s);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public virtual string Message {get;}
public string Source {get; set;}
public string StackTrace {get;}
public MethodBase TargetSite {get;}

System.Data.DuplicateNameException

Module:System.Data.dll

Hierarchy
Object
Exception
SystemException
DataException
DuplicateNameException

Type declaration

[C#] public class DuplicateNameException : DataException;

Constructor
public DuplicateNameException();
protected DuplicateNameException(SerializationInfo info, StreamingContext context);
public DuplicateNameException(string s);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public virtual string Message {get;}
public string Source {get; set;}
public string StackTrace {get;}
public MethodBase TargetSite {get;}

System.Data.DeletedRowInaccessibleException

Module:System.Data.dll

Hierarchy
Object
Exception
SystemException
DataException
DeletedRowInaccessibleException

Type declaration

[C#] public class DeletedRowInaccessibleException : DataException;

Constructor
public DeletedRowInaccessibleException();
protected DeletedRowInaccessibleException(SerializationInfo info, StreamingContext context);
public DeletedRowInaccessibleException(string s);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public virtual string Message {get;}
public string Source {get; set;}
public string StackTrace {get;}
public MethodBase TargetSite {get;}

System.Data.ConstraintException

Module:System.Data.dll

Hierarchy
Object
Exception
SystemException
DataException
ConstraintException

Type declaration

[C#] public class ConstraintException : DataException;

Constructor
public ConstraintException();
protected ConstraintException(SerializationInfo info, StreamingContext context);
public ConstraintException(string s);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public virtual string Message {get;}
public string Source {get; set;}
public string StackTrace {get;}
public MethodBase TargetSite {get;}

System.Data.DataException

Module:System.Data.dll

Hierarchy
Object
Exception
SystemException
DataException

Type declaration

[C#] public class DataException : SystemException;

Constructor
public DataException();
protected DataException(SerializationInfo info, StreamingContext context);
public DataException(string s);
public DataException(string s, Exception innerException);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public virtual string Message {get;}
public string Source {get; set;}
public string StackTrace {get;}
public MethodBase TargetSite {get;}

System.Data.DataColumnChangeEventHandler

Module:System.Data.dll

Hierarchy
Object
Delegate
MulticastDelegate
DataColumnChangeEventHandler

Type declaration

[C#] public delegate void DataColumnChangeEventHandler(object sender, DataColumnChangeEventArgs e);

Constructor
public DataColumnChangeEventHandler(object object, IntPtr method);

Method
public virtual IAsyncResult BeginInvoke(object sender, DataColumnChangeEventArgs e, AsyncCallback callback, object object);
public object Clone();
protected override Delegate CombineImpl(Delegate follow);
public object DynamicInvoke(object[] args);
protected virtual object DynamicInvokeImpl(object[] args);
public virtual void EndInvoke(IAsyncResult result);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public override Delegate[] GetInvocationList();
protected virtual MethodInfo GetMethodImpl();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
public override void Invoke(object sender, DataColumnChangeEventArgs e);
protected object MemberwiseClone();
protected override Delegate RemoveImpl(Delegate value);
public virtual string ToString();

Property
public MethodInfo Method {get;}
public object Target {get;}

System.Data.DataColumnChangeEventArgs

Module:System.Data.dll

Hierarchy
Object
EventArgs
DataColumnChangeEventArgs

Type declaration

[C#] public class DataColumnChangeEventArgs : EventArgs;

Constructor
public DataColumnChangeEventArgs(DataRow row, DataColumn column, object value);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public DataColumn Column {get;}
public object ProposedValue {get; set;}
public DataRow Row {get;}

System.Data.ConnectionState

Module:System.Data.dll

Hierarchy
Object
ValueType
Enum
ConnectionState

Type declaration

[C#] public enum ConnectionState;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const ConnectionState Broken = 16;
public const ConnectionState Closed = 0;
public const ConnectionState Connecting = 2;
public const ConnectionState Executing = 4;
public const ConnectionState Fetching = 8;
public const ConnectionState Open = 1;
public int value__;

System.Data.CommandType

Module:System.Data.dll

Hierarchy
Object
ValueType
Enum
CommandType

Type declaration

[C#] public enum CommandType;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const CommandType StoredProcedure = 4;
public const CommandType TableDirect = 512;
public const CommandType Text = 1;
public int value__;

System.Data.CommandBehavior

Module:System.Data.dll

Hierarchy
Object
ValueType
Enum
CommandBehavior

Type declaration

[C#] public enum CommandBehavior;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const CommandBehavior CloseConnection = 32;
public const CommandBehavior Default = 0;
public const CommandBehavior KeyInfo = 4;
public const CommandBehavior SchemaOnly = 2;
public const CommandBehavior SequentialAccess = 16;
public const CommandBehavior SingleResult = 1;
public const CommandBehavior SingleRow = 8;
public int value__;

System.Data.InternalDataCollectionBase

Module:System.Data.dll

Hierarchy
Object
InternalDataCollectionBase : ICollection, IEnumerable

Type declaration

[C#] public class InternalDataCollectionBase: ICollection, IEnumerable;

Constructor
public InternalDataCollectionBase();

Method
public virtual void CopyTo(Array ar, int index);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual IEnumerator GetEnumerator();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public virtual int Count {get;}
public bool IsReadOnly {get;}
public virtual bool IsSynchronized {get;}
protected virtual ArrayList List {get;}
public virtual object SyncRoot {get;}

System.Data.AcceptRejectRule

Module:System.Data.dll

Hierarchy
Object
ValueType
Enum
AcceptRejectRule

Type declaration

[C#] public enum AcceptRejectRule;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const AcceptRejectRule Cascade = 1;
public const AcceptRejectRule None = 0;
public int value__;

System.Data.SqlTypes.SqlTruncateException

Module:System.Data.Common.dll
Module:system.data.dll

Hierarchy
Object
Exception
SystemException
SqlTypeException
SqlTruncateException

Type declaration

[C#] public sealed class SqlTruncateException : SqlTypeException;

Constructor
public SqlTruncateException();
public SqlTruncateException(string message);
public SqlTruncateException(string message, Exception e);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public virtual string Message {get;}
public string Source {get; set;}
public string StackTrace {get;}
public MethodBase TargetSite {get;}

System.Data.SqlTypes.SqlNullValueException

Module:System.Data.Common.dll
Module:system.data.dll

Hierarchy
Object
Exception
SystemException
SqlTypeException
SqlNullValueException

Type declaration

[C#] public sealed class SqlNullValueException : SqlTypeException;

Constructor
public SqlNullValueException();
public SqlNullValueException(string message);
public SqlNullValueException(string message, Exception e);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public virtual string Message {get;}
public string Source {get; set;}
public string StackTrace {get;}
public MethodBase TargetSite {get;}

System.Data.SqlTypes.SqlTypeException

Module:System.Data.Common.dll
Module:system.data.dll

Hierarchy
Object
Exception
SystemException
SqlTypeException

Type declaration

[C#] public class SqlTypeException : SystemException;

Constructor
public SqlTypeException();
protected SqlTypeException(SerializationInfo si, StreamingContext sc);
public SqlTypeException(string message);
public SqlTypeException(string message, Exception e);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public virtual string Message {get;}
public string Source {get; set;}
public string StackTrace {get;}
public MethodBase TargetSite {get;}

System.Data.SqlTypes.SqlString

Module:System.Data.Common.dll
Module:system.data.dll

Hierarchy
Object
ValueType
SqlString : INullable, IComparable

Type declaration

[C#] public struct SqlString : ValueType, INullable, IComparable;

Constructor
public SqlString(int lcid, SqlCompareOptions compareOptions, byte[] data);
public SqlString(int lcid, SqlCompareOptions compareOptions, byte[] data, bool fUnicode);
public SqlString(int lcid, SqlCompareOptions compareOptions, byte[] data, int index, int count);
public SqlString(int lcid, SqlCompareOptions compareOptions, byte[] data, int index, int count, bool fUnicode);
public SqlString(string data);
public SqlString(string data, int lcid);
public SqlString(string data, int lcid, SqlCompareOptions compareOptions);

Method
public SqlString Clone();
public static CompareOptions CompareOptionsFromSqlCompareOptions(SqlCompareOptions compareOptions);
public virtual int CompareTo(object value);
public static SqlString Concat(SqlString x, SqlString y);
public override bool Equals(object value);
public static SqlBoolean Equals(SqlString x, SqlString y);
protected override void Finalize();
public override int GetHashCode();
public byte[] GetNonUnicodeBytes();
public Type GetType();
public byte[] GetUnicodeBytes();
public static SqlBoolean GreaterThan(SqlString x, SqlString y);
public static SqlBoolean GreaterThanOrEqual(SqlString x, SqlString y);
public static SqlBoolean LessThan(SqlString x, SqlString y);
public static SqlBoolean LessThanOrEqual(SqlString x, SqlString y);
protected object MemberwiseClone();
public static SqlBoolean NotEquals(SqlString x, SqlString y);
public static SqlString op_Addition(SqlString x, SqlString y);
public static SqlBoolean op_Equality(SqlString x, SqlString y);
public static SqlString op_Explicit(SqlBoolean x);
public static SqlString op_Explicit(SqlByte x);
public static SqlString op_Explicit(SqlDateTime x);
public static SqlString op_Explicit(SqlDecimal x);
public static SqlString op_Explicit(SqlDouble x);
public static SqlString op_Explicit(SqlGuid x);
public static SqlString op_Explicit(SqlInt16 x);
public static SqlString op_Explicit(SqlInt32 x);
public static SqlString op_Explicit(SqlInt64 x);
public static SqlString op_Explicit(SqlMoney x);
public static SqlString op_Explicit(SqlSingle x);
public static string op_Explicit(SqlString x);
public static SqlBoolean op_GreaterThan(SqlString x, SqlString y);
public static SqlBoolean op_GreaterThanOrEqual(SqlString x, SqlString y);
public static SqlString op_Implicit(string x);
public static SqlBoolean op_Inequality(SqlString x, SqlString y);
public static SqlBoolean op_LessThan(SqlString x, SqlString y);
public static SqlBoolean op_LessThanOrEqual(SqlString x, SqlString y);
public SqlBoolean ToSqlBoolean();
public SqlByte ToSqlByte();
public SqlDateTime ToSqlDateTime();
public SqlDecimal ToSqlDecimal();
public SqlDouble ToSqlDouble();
public SqlGuid ToSqlGuid();
public SqlInt16 ToSqlInt16();
public SqlInt32 ToSqlInt32();
public SqlInt64 ToSqlInt64();
public SqlMoney ToSqlMoney();
public SqlSingle ToSqlSingle();
public override string ToString();

Property
public CompareInfo CompareInfo {get;}
public CultureInfo CultureInfo {get;}
public virtual bool IsNull {get;}
public int LCID {get;}
public SqlCompareOptions SqlCompareOptions {get;}
public string Value {get;}

Field
public readonly static int BinarySort;
public readonly static int IgnoreCase;
public readonly static int IgnoreKanaType;
public readonly static int IgnoreNonSpace;
public readonly static int IgnoreWidth;
public readonly static SqlString Null;

System.Data.SqlTypes.SqlCompareOptions

Module:System.Data.Common.dll
Module:system.data.dll

Hierarchy
Object
ValueType
Enum
SqlCompareOptions

Type declaration

[C#] public enum SqlCompareOptions;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const SqlCompareOptions BinarySort = 32768;
public const SqlCompareOptions IgnoreCase = 1;
public const SqlCompareOptions IgnoreKanaType = 8;
public const SqlCompareOptions IgnoreNonSpace = 2;
public const SqlCompareOptions IgnoreWidth = 16;
public const SqlCompareOptions None = 0;
public int value__;

System.Data.SqlTypes.SqlSingle

Module:System.Data.Common.dll
Module:system.data.dll

Hierarchy
Object
ValueType
SqlSingle : INullable, IComparable

Type declaration

[C#] public struct SqlSingle : ValueType, INullable, IComparable;

Constructor
public SqlSingle(double value);
public SqlSingle(float value);

Method
public static SqlSingle Add(SqlSingle x, SqlSingle y);
public virtual int CompareTo(object value);
public static SqlSingle Divide(SqlSingle x, SqlSingle y);
public override bool Equals(object value);
public static SqlBoolean Equals(SqlSingle x, SqlSingle y);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public static SqlBoolean GreaterThan(SqlSingle x, SqlSingle y);
public static SqlBoolean GreaterThanOrEqual(SqlSingle x, SqlSingle y);
public static SqlBoolean LessThan(SqlSingle x, SqlSingle y);
public static SqlBoolean LessThanOrEqual(SqlSingle x, SqlSingle y);
protected object MemberwiseClone();
public static SqlSingle Multiply(SqlSingle x, SqlSingle y);
public static SqlBoolean NotEquals(SqlSingle x, SqlSingle y);
public static SqlSingle op_Addition(SqlSingle x, SqlSingle y);
public static SqlSingle op_Division(SqlSingle x, SqlSingle y);
public static SqlBoolean op_Equality(SqlSingle x, SqlSingle y);
public static SqlSingle op_Explicit(SqlBoolean x);
public static SqlSingle op_Explicit(SqlDouble x);
public static float op_Explicit(SqlSingle x);
public static SqlSingle op_Explicit(SqlString x);
public static SqlBoolean op_GreaterThan(SqlSingle x, SqlSingle y);
public static SqlBoolean op_GreaterThanOrEqual(SqlSingle x, SqlSingle y);
public static SqlSingle op_Implicit(float x);
public static SqlSingle op_Implicit(SqlByte x);
public static SqlSingle op_Implicit(SqlDecimal x);
public static SqlSingle op_Implicit(SqlInt16 x);
public static SqlSingle op_Implicit(SqlInt32 x);
public static SqlSingle op_Implicit(SqlInt64 x);
public static SqlSingle op_Implicit(SqlMoney x);
public static SqlBoolean op_Inequality(SqlSingle x, SqlSingle y);
public static SqlBoolean op_LessThan(SqlSingle x, SqlSingle y);
public static SqlBoolean op_LessThanOrEqual(SqlSingle x, SqlSingle y);
public static SqlSingle op_Multiply(SqlSingle x, SqlSingle y);
public static SqlSingle op_Subtraction(SqlSingle x, SqlSingle y);
public static SqlSingle op_UnaryNegation(SqlSingle x);
public static SqlSingle Parse(string s);
public static SqlSingle Subtract(SqlSingle x, SqlSingle y);
public SqlBoolean ToSqlBoolean();
public SqlByte ToSqlByte();
public SqlDecimal ToSqlDecimal();
public SqlDouble ToSqlDouble();
public SqlInt16 ToSqlInt16();
public SqlInt32 ToSqlInt32();
public SqlInt64 ToSqlInt64();
public SqlMoney ToSqlMoney();
public SqlString ToSqlString();
public override string ToString();

Property
public virtual bool IsNull {get;}
public float Value {get;}

Field
public readonly static SqlSingle MaxValue;
public readonly static SqlSingle MinValue;
public readonly static SqlSingle Null;
public readonly static SqlSingle Zero;

System.Data.SqlTypes.SqlDecimal

Module:System.Data.Common.dll
Module:system.data.dll

Hierarchy
Object
ValueType
SqlDecimal : INullable, IComparable

Type declaration

[C#] public struct SqlDecimal : ValueType, INullable, IComparable;

Constructor
public SqlDecimal(byte bPrecision, byte bScale, bool fPositive, int data1, int data2, int data3, int data4);
public SqlDecimal(byte bPrecision, byte bScale, bool fPositive, int[] bits);
public SqlDecimal(decimal value);
public SqlDecimal(double dVal);
public SqlDecimal(int value);
public SqlDecimal(long value);

Method
public static SqlDecimal Abs(SqlDecimal n);
public static SqlDecimal Add(SqlDecimal x, SqlDecimal y);
public static SqlDecimal AdjustScale(SqlDecimal n, int digits, bool fRound);
public static SqlDecimal Ceiling(SqlDecimal n);
public virtual int CompareTo(object value);
public static SqlDecimal ConvertToPrecScale(SqlDecimal n, int precision, int scale);
public static SqlDecimal Divide(SqlDecimal x, SqlDecimal y);
public override bool Equals(object value);
public static SqlBoolean Equals(SqlDecimal x, SqlDecimal y);
protected override void Finalize();
public static SqlDecimal Floor(SqlDecimal n);
public override int GetHashCode();
public Type GetType();
public static SqlBoolean GreaterThan(SqlDecimal x, SqlDecimal y);
public static SqlBoolean GreaterThanOrEqual(SqlDecimal x, SqlDecimal y);
public static SqlBoolean LessThan(SqlDecimal x, SqlDecimal y);
public static SqlBoolean LessThanOrEqual(SqlDecimal x, SqlDecimal y);
protected object MemberwiseClone();
public static SqlDecimal Multiply(SqlDecimal x, SqlDecimal y);
public static SqlBoolean NotEquals(SqlDecimal x, SqlDecimal y);
public static SqlDecimal op_Addition(SqlDecimal x, SqlDecimal y);
public static SqlDecimal op_Division(SqlDecimal x, SqlDecimal y);
public static SqlBoolean op_Equality(SqlDecimal x, SqlDecimal y);
public static SqlDecimal op_Explicit(SqlBoolean x);
public static decimal op_Explicit(SqlDecimal x);
public static SqlDecimal op_Explicit(SqlDouble x);
public static SqlDecimal op_Explicit(SqlSingle x);
public static SqlDecimal op_Explicit(SqlString x);
public static SqlBoolean op_GreaterThan(SqlDecimal x, SqlDecimal y);
public static SqlBoolean op_GreaterThanOrEqual(SqlDecimal x, SqlDecimal y);
public static SqlDecimal op_Implicit(decimal x);
public static SqlDecimal op_Implicit(SqlByte x);
public static SqlDecimal op_Implicit(SqlInt16 x);
public static SqlDecimal op_Implicit(SqlInt32 x);
public static SqlDecimal op_Implicit(SqlInt64 x);
public static SqlDecimal op_Implicit(SqlMoney x);
public static SqlBoolean op_Inequality(SqlDecimal x, SqlDecimal y);
public static SqlBoolean op_LessThan(SqlDecimal x, SqlDecimal y);
public static SqlBoolean op_LessThanOrEqual(SqlDecimal x, SqlDecimal y);
public static SqlDecimal op_Multiply(SqlDecimal x, SqlDecimal y);
public static SqlDecimal op_Subtraction(SqlDecimal x, SqlDecimal y);
public static SqlDecimal op_UnaryNegation(SqlDecimal x);
public static SqlDecimal Parse(string s);
public static SqlDecimal Power(SqlDecimal n, double exp);
public static SqlDecimal Round(SqlDecimal n, int position);
public static SqlInt32 Sign(SqlDecimal n);
public static SqlDecimal Subtract(SqlDecimal x, SqlDecimal y);
public double ToDouble();
public SqlBoolean ToSqlBoolean();
public SqlByte ToSqlByte();
public SqlDouble ToSqlDouble();
public SqlInt16 ToSqlInt16();
public SqlInt32 ToSqlInt32();
public SqlInt64 ToSqlInt64();
public SqlMoney ToSqlMoney();
public SqlSingle ToSqlSingle();
public SqlString ToSqlString();
public override string ToString();
public static SqlDecimal Truncate(SqlDecimal n, int position);

Property
public byte[] BinData {get;}
public int[] Data {get;}
public virtual bool IsNull {get;}
public bool IsPositive {get;}
public byte Precision {get;}
public byte Scale {get;}
public decimal Value {get;}

Field
public readonly static byte MaxPrecision;
public readonly static byte MaxScale;
public readonly static SqlDecimal MaxValue;
public readonly static SqlDecimal MinValue;
public readonly static SqlDecimal Null;

System.Data.SqlTypes.SqlMoney

Module:System.Data.Common.dll
Module:system.data.dll

Hierarchy
Object
ValueType
SqlMoney : INullable, IComparable

Type declaration

[C#] public struct SqlMoney : ValueType, INullable, IComparable;

Constructor
public SqlMoney(decimal value);
public SqlMoney(double value);
public SqlMoney(int value);
public SqlMoney(long value);

Method
public static SqlMoney Add(SqlMoney x, SqlMoney y);
public virtual int CompareTo(object value);
public static SqlMoney Divide(SqlMoney x, SqlMoney y);
public override bool Equals(object value);
public static SqlBoolean Equals(SqlMoney x, SqlMoney y);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public static SqlBoolean GreaterThan(SqlMoney x, SqlMoney y);
public static SqlBoolean GreaterThanOrEqual(SqlMoney x, SqlMoney y);
public static SqlBoolean LessThan(SqlMoney x, SqlMoney y);
public static SqlBoolean LessThanOrEqual(SqlMoney x, SqlMoney y);
protected object MemberwiseClone();
public static SqlMoney Multiply(SqlMoney x, SqlMoney y);
public static SqlBoolean NotEquals(SqlMoney x, SqlMoney y);
public static SqlMoney op_Addition(SqlMoney x, SqlMoney y);
public static SqlMoney op_Division(SqlMoney x, SqlMoney y);
public static SqlBoolean op_Equality(SqlMoney x, SqlMoney y);
public static SqlMoney op_Explicit(SqlBoolean x);
public static SqlMoney op_Explicit(SqlDecimal x);
public static SqlMoney op_Explicit(SqlDouble x);
public static decimal op_Explicit(SqlMoney x);
public static SqlMoney op_Explicit(SqlSingle x);
public static SqlMoney op_Explicit(SqlString x);
public static SqlBoolean op_GreaterThan(SqlMoney x, SqlMoney y);
public static SqlBoolean op_GreaterThanOrEqual(SqlMoney x, SqlMoney y);
public static SqlMoney op_Implicit(decimal x);
public static SqlMoney op_Implicit(SqlByte x);
public static SqlMoney op_Implicit(SqlInt16 x);
public static SqlMoney op_Implicit(SqlInt32 x);
public static SqlMoney op_Implicit(SqlInt64 x);
public static SqlBoolean op_Inequality(SqlMoney x, SqlMoney y);
public static SqlBoolean op_LessThan(SqlMoney x, SqlMoney y);
public static SqlBoolean op_LessThanOrEqual(SqlMoney x, SqlMoney y);
public static SqlMoney op_Multiply(SqlMoney x, SqlMoney y);
public static SqlMoney op_Subtraction(SqlMoney x, SqlMoney y);
public static SqlMoney op_UnaryNegation(SqlMoney x);
public static SqlMoney Parse(string s);
public static SqlMoney Subtract(SqlMoney x, SqlMoney y);
public decimal ToDecimal();
public double ToDouble();
public int ToInt32();
public long ToInt64();
public SqlBoolean ToSqlBoolean();
public SqlByte ToSqlByte();
public SqlDecimal ToSqlDecimal();
public SqlDouble ToSqlDouble();
public SqlInt16 ToSqlInt16();
public SqlInt32 ToSqlInt32();
public SqlInt64 ToSqlInt64();
public SqlSingle ToSqlSingle();
public SqlString ToSqlString();
public override string ToString();

Property
public virtual bool IsNull {get;}
public decimal Value {get;}

Field
public readonly static SqlMoney MaxValue;
public readonly static SqlMoney MinValue;
public readonly static SqlMoney Null;
public readonly static SqlMoney Zero;

System.Data.SqlTypes.SqlInt64

Module:System.Data.Common.dll
Module:system.data.dll

Hierarchy
Object
ValueType
SqlInt64 : INullable, IComparable

Type declaration

[C#] public struct SqlInt64 : ValueType, INullable, IComparable;

Constructor
public SqlInt64(long value);

Method
public static SqlInt64 Add(SqlInt64 x, SqlInt64 y);
public static SqlInt64 BitwiseAnd(SqlInt64 x, SqlInt64 y);
public static SqlInt64 BitwiseOr(SqlInt64 x, SqlInt64 y);
public virtual int CompareTo(object value);
public static SqlInt64 Divide(SqlInt64 x, SqlInt64 y);
public override bool Equals(object value);
public static SqlBoolean Equals(SqlInt64 x, SqlInt64 y);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public static SqlBoolean GreaterThan(SqlInt64 x, SqlInt64 y);
public static SqlBoolean GreaterThanOrEqual(SqlInt64 x, SqlInt64 y);
public static SqlBoolean LessThan(SqlInt64 x, SqlInt64 y);
public static SqlBoolean LessThanOrEqual(SqlInt64 x, SqlInt64 y);
protected object MemberwiseClone();
public static SqlInt64 Mod(SqlInt64 x, SqlInt64 y);
public static SqlInt64 Multiply(SqlInt64 x, SqlInt64 y);
public static SqlBoolean NotEquals(SqlInt64 x, SqlInt64 y);
public static SqlInt64 OnesComplement(SqlInt64 x);
public static SqlInt64 op_Addition(SqlInt64 x, SqlInt64 y);
public static SqlInt64 op_BitwiseAnd(SqlInt64 x, SqlInt64 y);
public static SqlInt64 op_BitwiseOr(SqlInt64 x, SqlInt64 y);
public static SqlInt64 op_Division(SqlInt64 x, SqlInt64 y);
public static SqlBoolean op_Equality(SqlInt64 x, SqlInt64 y);
public static SqlInt64 op_ExclusiveOr(SqlInt64 x, SqlInt64 y);
public static SqlInt64 op_Explicit(SqlBoolean x);
public static SqlInt64 op_Explicit(SqlDecimal x);
public static SqlInt64 op_Explicit(SqlDouble x);
public static long op_Explicit(SqlInt64 x);
public static SqlInt64 op_Explicit(SqlMoney x);
public static SqlInt64 op_Explicit(SqlSingle x);
public static SqlInt64 op_Explicit(SqlString x);
public static SqlBoolean op_GreaterThan(SqlInt64 x, SqlInt64 y);
public static SqlBoolean op_GreaterThanOrEqual(SqlInt64 x, SqlInt64 y);
public static SqlInt64 op_Implicit(long x);
public static SqlInt64 op_Implicit(SqlByte x);
public static SqlInt64 op_Implicit(SqlInt16 x);
public static SqlInt64 op_Implicit(SqlInt32 x);
public static SqlBoolean op_Inequality(SqlInt64 x, SqlInt64 y);
public static SqlBoolean op_LessThan(SqlInt64 x, SqlInt64 y);
public static SqlBoolean op_LessThanOrEqual(SqlInt64 x, SqlInt64 y);
public static SqlInt64 op_Modulus(SqlInt64 x, SqlInt64 y);
public static SqlInt64 op_Multiply(SqlInt64 x, SqlInt64 y);
public static SqlInt64 op_OnesComplement(SqlInt64 x);
public static SqlInt64 op_Subtraction(SqlInt64 x, SqlInt64 y);
public static SqlInt64 op_UnaryNegation(SqlInt64 x);
public static SqlInt64 Parse(string s);
public static SqlInt64 Subtract(SqlInt64 x, SqlInt64 y);
public SqlBoolean ToSqlBoolean();
public SqlByte ToSqlByte();
public SqlDecimal ToSqlDecimal();
public SqlDouble ToSqlDouble();
public SqlInt16 ToSqlInt16();
public SqlInt32 ToSqlInt32();
public SqlMoney ToSqlMoney();
public SqlSingle ToSqlSingle();
public SqlString ToSqlString();
public override string ToString();
public static SqlInt64 Xor(SqlInt64 x, SqlInt64 y);

Property
public virtual bool IsNull {get;}
public long Value {get;}

Field
public readonly static SqlInt64 MaxValue;
public readonly static SqlInt64 MinValue;
public readonly static SqlInt64 Null;
public readonly static SqlInt64 Zero;

System.Data.SqlTypes.SqlInt32

Module:System.Data.Common.dll
Module:system.data.dll

Hierarchy
Object
ValueType
SqlInt32 : INullable, IComparable

Type declaration

[C#] public struct SqlInt32 : ValueType, INullable, IComparable;

Constructor
public SqlInt32(int value);

Method
public static SqlInt32 Add(SqlInt32 x, SqlInt32 y);
public static SqlInt32 BitwiseAnd(SqlInt32 x, SqlInt32 y);
public static SqlInt32 BitwiseOr(SqlInt32 x, SqlInt32 y);
public virtual int CompareTo(object value);
public static SqlInt32 Divide(SqlInt32 x, SqlInt32 y);
public override bool Equals(object value);
public static SqlBoolean Equals(SqlInt32 x, SqlInt32 y);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public static SqlBoolean GreaterThan(SqlInt32 x, SqlInt32 y);
public static SqlBoolean GreaterThanOrEqual(SqlInt32 x, SqlInt32 y);
public static SqlBoolean LessThan(SqlInt32 x, SqlInt32 y);
public static SqlBoolean LessThanOrEqual(SqlInt32 x, SqlInt32 y);
protected object MemberwiseClone();
public static SqlInt32 Mod(SqlInt32 x, SqlInt32 y);
public static SqlInt32 Multiply(SqlInt32 x, SqlInt32 y);
public static SqlBoolean NotEquals(SqlInt32 x, SqlInt32 y);
public static SqlInt32 OnesComplement(SqlInt32 x);
public static SqlInt32 op_Addition(SqlInt32 x, SqlInt32 y);
public static SqlInt32 op_BitwiseAnd(SqlInt32 x, SqlInt32 y);
public static SqlInt32 op_BitwiseOr(SqlInt32 x, SqlInt32 y);
public static SqlInt32 op_Division(SqlInt32 x, SqlInt32 y);
public static SqlBoolean op_Equality(SqlInt32 x, SqlInt32 y);
public static SqlInt32 op_ExclusiveOr(SqlInt32 x, SqlInt32 y);
public static SqlInt32 op_Explicit(SqlBoolean x);
public static SqlInt32 op_Explicit(SqlDecimal x);
public static SqlInt32 op_Explicit(SqlDouble x);
public static int op_Explicit(SqlInt32 x);
public static SqlInt32 op_Explicit(SqlInt64 x);
public static SqlInt32 op_Explicit(SqlMoney x);
public static SqlInt32 op_Explicit(SqlSingle x);
public static SqlInt32 op_Explicit(SqlString x);
public static SqlBoolean op_GreaterThan(SqlInt32 x, SqlInt32 y);
public static SqlBoolean op_GreaterThanOrEqual(SqlInt32 x, SqlInt32 y);
public static SqlInt32 op_Implicit(int x);
public static SqlInt32 op_Implicit(SqlByte x);
public static SqlInt32 op_Implicit(SqlInt16 x);
public static SqlBoolean op_Inequality(SqlInt32 x, SqlInt32 y);
public static SqlBoolean op_LessThan(SqlInt32 x, SqlInt32 y);
public static SqlBoolean op_LessThanOrEqual(SqlInt32 x, SqlInt32 y);
public static SqlInt32 op_Modulus(SqlInt32 x, SqlInt32 y);
public static SqlInt32 op_Multiply(SqlInt32 x, SqlInt32 y);
public static SqlInt32 op_OnesComplement(SqlInt32 x);
public static SqlInt32 op_Subtraction(SqlInt32 x, SqlInt32 y);
public static SqlInt32 op_UnaryNegation(SqlInt32 x);
public static SqlInt32 Parse(string s);
public static SqlInt32 Subtract(SqlInt32 x, SqlInt32 y);
public SqlBoolean ToSqlBoolean();
public SqlByte ToSqlByte();
public SqlDecimal ToSqlDecimal();
public SqlDouble ToSqlDouble();
public SqlInt16 ToSqlInt16();
public SqlInt64 ToSqlInt64();
public SqlMoney ToSqlMoney();
public SqlSingle ToSqlSingle();
public SqlString ToSqlString();
public override string ToString();
public static SqlInt32 Xor(SqlInt32 x, SqlInt32 y);

Property
public virtual bool IsNull {get;}
public int Value {get;}

Field
public readonly static SqlInt32 MaxValue;
public readonly static SqlInt32 MinValue;
public readonly static SqlInt32 Null;
public readonly static SqlInt32 Zero;

System.Data.SqlTypes.SqlInt16

Module:System.Data.Common.dll
Module:system.data.dll

Hierarchy
Object
ValueType
SqlInt16 : INullable, IComparable

Type declaration

[C#] public struct SqlInt16 : ValueType, INullable, IComparable;

Constructor
public SqlInt16(short value);

Method
public static SqlInt16 Add(SqlInt16 x, SqlInt16 y);
public static SqlInt16 BitwiseAnd(SqlInt16 x, SqlInt16 y);
public static SqlInt16 BitwiseOr(SqlInt16 x, SqlInt16 y);
public virtual int CompareTo(object value);
public static SqlInt16 Divide(SqlInt16 x, SqlInt16 y);
public override bool Equals(object value);
public static SqlBoolean Equals(SqlInt16 x, SqlInt16 y);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public static SqlBoolean GreaterThan(SqlInt16 x, SqlInt16 y);
public static SqlBoolean GreaterThanOrEqual(SqlInt16 x, SqlInt16 y);
public static SqlBoolean LessThan(SqlInt16 x, SqlInt16 y);
public static SqlBoolean LessThanOrEqual(SqlInt16 x, SqlInt16 y);
protected object MemberwiseClone();
public static SqlInt16 Mod(SqlInt16 x, SqlInt16 y);
public static SqlInt16 Multiply(SqlInt16 x, SqlInt16 y);
public static SqlBoolean NotEquals(SqlInt16 x, SqlInt16 y);
public static SqlInt16 OnesComplement(SqlInt16 x);
public static SqlInt16 op_Addition(SqlInt16 x, SqlInt16 y);
public static SqlInt16 op_BitwiseAnd(SqlInt16 x, SqlInt16 y);
public static SqlInt16 op_BitwiseOr(SqlInt16 x, SqlInt16 y);
public static SqlInt16 op_Division(SqlInt16 x, SqlInt16 y);
public static SqlBoolean op_Equality(SqlInt16 x, SqlInt16 y);
public static SqlInt16 op_ExclusiveOr(SqlInt16 x, SqlInt16 y);
public static SqlInt16 op_Explicit(SqlBoolean x);
public static SqlInt16 op_Explicit(SqlDecimal x);
public static SqlInt16 op_Explicit(SqlDouble x);
public static short op_Explicit(SqlInt16 x);
public static SqlInt16 op_Explicit(SqlInt32 x);
public static SqlInt16 op_Explicit(SqlInt64 x);
public static SqlInt16 op_Explicit(SqlMoney x);
public static SqlInt16 op_Explicit(SqlSingle x);
public static SqlInt16 op_Explicit(SqlString x);
public static SqlBoolean op_GreaterThan(SqlInt16 x, SqlInt16 y);
public static SqlBoolean op_GreaterThanOrEqual(SqlInt16 x, SqlInt16 y);
public static SqlInt16 op_Implicit(short x);
public static SqlInt16 op_Implicit(SqlByte x);
public static SqlBoolean op_Inequality(SqlInt16 x, SqlInt16 y);
public static SqlBoolean op_LessThan(SqlInt16 x, SqlInt16 y);
public static SqlBoolean op_LessThanOrEqual(SqlInt16 x, SqlInt16 y);
public static SqlInt16 op_Modulus(SqlInt16 x, SqlInt16 y);
public static SqlInt16 op_Multiply(SqlInt16 x, SqlInt16 y);
public static SqlInt16 op_OnesComplement(SqlInt16 x);
public static SqlInt16 op_Subtraction(SqlInt16 x, SqlInt16 y);
public static SqlInt16 op_UnaryNegation(SqlInt16 x);
public static SqlInt16 Parse(string s);
public static SqlInt16 Subtract(SqlInt16 x, SqlInt16 y);
public SqlBoolean ToSqlBoolean();
public SqlByte ToSqlByte();
public SqlDecimal ToSqlDecimal();
public SqlDouble ToSqlDouble();
public SqlInt32 ToSqlInt32();
public SqlInt64 ToSqlInt64();
public SqlMoney ToSqlMoney();
public SqlSingle ToSqlSingle();
public SqlString ToSqlString();
public override string ToString();
public static SqlInt16 Xor(SqlInt16 x, SqlInt16 y);

Property
public virtual bool IsNull {get;}
public short Value {get;}

Field
public readonly static SqlInt16 MaxValue;
public readonly static SqlInt16 MinValue;
public readonly static SqlInt16 Null;
public readonly static SqlInt16 Zero;

System.Data.SqlTypes.SqlGuid

Module:System.Data.Common.dll
Module:system.data.dll

Hierarchy
Object
ValueType
SqlGuid : INullable, IComparable

Type declaration

[C#] public struct SqlGuid : ValueType, INullable, IComparable;

Constructor
public SqlGuid(byte[] value);
public SqlGuid(Guid g);
public SqlGuid(int a, short b, short c, byte d, byte e, byte f, byte g, byte h, byte i, byte j, byte k);
public SqlGuid(string s);

Method
public virtual int CompareTo(object value);
public override bool Equals(object value);
public static SqlBoolean Equals(SqlGuid x, SqlGuid y);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public static SqlBoolean GreaterThan(SqlGuid x, SqlGuid y);
public static SqlBoolean GreaterThanOrEqual(SqlGuid x, SqlGuid y);
public static SqlBoolean LessThan(SqlGuid x, SqlGuid y);
public static SqlBoolean LessThanOrEqual(SqlGuid x, SqlGuid y);
protected object MemberwiseClone();
public static SqlBoolean NotEquals(SqlGuid x, SqlGuid y);
public static SqlBoolean op_Equality(SqlGuid x, SqlGuid y);
public static SqlGuid op_Explicit(SqlBinary x);
public static Guid op_Explicit(SqlGuid x);
public static SqlGuid op_Explicit(SqlString x);
public static SqlBoolean op_GreaterThan(SqlGuid x, SqlGuid y);
public static SqlBoolean op_GreaterThanOrEqual(SqlGuid x, SqlGuid y);
public static SqlGuid op_Implicit(Guid x);
public static SqlBoolean op_Inequality(SqlGuid x, SqlGuid y);
public static SqlBoolean op_LessThan(SqlGuid x, SqlGuid y);
public static SqlBoolean op_LessThanOrEqual(SqlGuid x, SqlGuid y);
public static SqlGuid Parse(string s);
public byte[] ToByteArray();
public SqlBinary ToSqlBinary();
public SqlString ToSqlString();
public override string ToString();

Property
public virtual bool IsNull {get;}
public Guid Value {get;}

Field
public readonly static SqlGuid Null;

System.Data.SqlTypes.SqlDouble

Module:System.Data.Common.dll
Module:system.data.dll

Hierarchy
Object
ValueType
SqlDouble : INullable, IComparable

Type declaration

[C#] public struct SqlDouble : ValueType, INullable, IComparable;

Constructor
public SqlDouble(double value);

Method
public static SqlDouble Add(SqlDouble x, SqlDouble y);
public virtual int CompareTo(object value);
public static SqlDouble Divide(SqlDouble x, SqlDouble y);
public override bool Equals(object value);
public static SqlBoolean Equals(SqlDouble x, SqlDouble y);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public static SqlBoolean GreaterThan(SqlDouble x, SqlDouble y);
public static SqlBoolean GreaterThanOrEqual(SqlDouble x, SqlDouble y);
public static SqlBoolean LessThan(SqlDouble x, SqlDouble y);
public static SqlBoolean LessThanOrEqual(SqlDouble x, SqlDouble y);
protected object MemberwiseClone();
public static SqlDouble Multiply(SqlDouble x, SqlDouble y);
public static SqlBoolean NotEquals(SqlDouble x, SqlDouble y);
public static SqlDouble op_Addition(SqlDouble x, SqlDouble y);
public static SqlDouble op_Division(SqlDouble x, SqlDouble y);
public static SqlBoolean op_Equality(SqlDouble x, SqlDouble y);
public static SqlDouble op_Explicit(SqlBoolean x);
public static double op_Explicit(SqlDouble x);
public static SqlDouble op_Explicit(SqlString x);
public static SqlBoolean op_GreaterThan(SqlDouble x, SqlDouble y);
public static SqlBoolean op_GreaterThanOrEqual(SqlDouble x, SqlDouble y);
public static SqlDouble op_Implicit(double x);
public static SqlDouble op_Implicit(SqlByte x);
public static SqlDouble op_Implicit(SqlDecimal x);
public static SqlDouble op_Implicit(SqlInt16 x);
public static SqlDouble op_Implicit(SqlInt32 x);
public static SqlDouble op_Implicit(SqlInt64 x);
public static SqlDouble op_Implicit(SqlMoney x);
public static SqlDouble op_Implicit(SqlSingle x);
public static SqlBoolean op_Inequality(SqlDouble x, SqlDouble y);
public static SqlBoolean op_LessThan(SqlDouble x, SqlDouble y);
public static SqlBoolean op_LessThanOrEqual(SqlDouble x, SqlDouble y);
public static SqlDouble op_Multiply(SqlDouble x, SqlDouble y);
public static SqlDouble op_Subtraction(SqlDouble x, SqlDouble y);
public static SqlDouble op_UnaryNegation(SqlDouble x);
public static SqlDouble Parse(string s);
public static SqlDouble Subtract(SqlDouble x, SqlDouble y);
public SqlBoolean ToSqlBoolean();
public SqlByte ToSqlByte();
public SqlDecimal ToSqlDecimal();
public SqlInt16 ToSqlInt16();
public SqlInt32 ToSqlInt32();
public SqlInt64 ToSqlInt64();
public SqlMoney ToSqlMoney();
public SqlSingle ToSqlSingle();
public SqlString ToSqlString();
public override string ToString();

Property
public virtual bool IsNull {get;}
public double Value {get;}

Field
public readonly static SqlDouble MaxValue;
public readonly static SqlDouble MinValue;
public readonly static SqlDouble Null;
public readonly static SqlDouble Zero;

System.Data.SqlTypes.SqlDateTime

Module:System.Data.Common.dll
Module:system.data.dll

Hierarchy
Object
ValueType
SqlDateTime : INullable, IComparable

Type declaration

[C#] public struct SqlDateTime : ValueType, INullable, IComparable;

Constructor
public SqlDateTime(DateTime value);
public SqlDateTime(int dayTicks, int timeTicks);
public SqlDateTime(int year, int month, int day);
public SqlDateTime(int year, int month, int day, int hour, int minute, int second);
public SqlDateTime(int year, int month, int day, int hour, int minute, int second, double millisecond);
public SqlDateTime(int year, int month, int day, int hour, int minute, int second, int bilisecond);

Method
public virtual int CompareTo(object value);
public override bool Equals(object value);
public static SqlBoolean Equals(SqlDateTime x, SqlDateTime y);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public static SqlBoolean GreaterThan(SqlDateTime x, SqlDateTime y);
public static SqlBoolean GreaterThanOrEqual(SqlDateTime x, SqlDateTime y);
public static SqlBoolean LessThan(SqlDateTime x, SqlDateTime y);
public static SqlBoolean LessThanOrEqual(SqlDateTime x, SqlDateTime y);
protected object MemberwiseClone();
public static SqlBoolean NotEquals(SqlDateTime x, SqlDateTime y);
public static SqlDateTime op_Addition(SqlDateTime x, TimeSpan t);
public static SqlBoolean op_Equality(SqlDateTime x, SqlDateTime y);
public static DateTime op_Explicit(SqlDateTime x);
public static SqlDateTime op_Explicit(SqlString x);
public static SqlBoolean op_GreaterThan(SqlDateTime x, SqlDateTime y);
public static SqlBoolean op_GreaterThanOrEqual(SqlDateTime x, SqlDateTime y);
public static SqlDateTime op_Implicit(DateTime value);
public static SqlBoolean op_Inequality(SqlDateTime x, SqlDateTime y);
public static SqlBoolean op_LessThan(SqlDateTime x, SqlDateTime y);
public static SqlBoolean op_LessThanOrEqual(SqlDateTime x, SqlDateTime y);
public static SqlDateTime op_Subtraction(SqlDateTime x, TimeSpan t);
public static SqlDateTime Parse(string s);
public SqlString ToSqlString();
public override string ToString();

Property
public int DayTicks {get;}
public virtual bool IsNull {get;}
public int TimeTicks {get;}
public DateTime Value {get;}

Field
public readonly static SqlDateTime MaxValue;
public readonly static SqlDateTime MinValue;
public readonly static SqlDateTime Null;
public readonly static int SQLTicksPerHour;
public readonly static int SQLTicksPerMinute;
public readonly static int SQLTicksPerSecond;

System.Data.SqlTypes.SqlByte

Module:System.Data.Common.dll
Module:system.data.dll

Hierarchy
Object
ValueType
SqlByte : INullable, IComparable

Type declaration

[C#] public struct SqlByte : ValueType, INullable, IComparable;

Constructor
public SqlByte(byte value);

Method
public static SqlByte Add(SqlByte x, SqlByte y);
public static SqlByte BitwiseAnd(SqlByte x, SqlByte y);
public static SqlByte BitwiseOr(SqlByte x, SqlByte y);
public virtual int CompareTo(object value);
public static SqlByte Divide(SqlByte x, SqlByte y);
public override bool Equals(object value);
public static SqlBoolean Equals(SqlByte x, SqlByte y);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public static SqlBoolean GreaterThan(SqlByte x, SqlByte y);
public static SqlBoolean GreaterThanOrEqual(SqlByte x, SqlByte y);
public static SqlBoolean LessThan(SqlByte x, SqlByte y);
public static SqlBoolean LessThanOrEqual(SqlByte x, SqlByte y);
protected object MemberwiseClone();
public static SqlByte Mod(SqlByte x, SqlByte y);
public static SqlByte Multiply(SqlByte x, SqlByte y);
public static SqlBoolean NotEquals(SqlByte x, SqlByte y);
public static SqlByte OnesComplement(SqlByte x);
public static SqlByte op_Addition(SqlByte x, SqlByte y);
public static SqlByte op_BitwiseAnd(SqlByte x, SqlByte y);
public static SqlByte op_BitwiseOr(SqlByte x, SqlByte y);
public static SqlByte op_Division(SqlByte x, SqlByte y);
public static SqlBoolean op_Equality(SqlByte x, SqlByte y);
public static SqlByte op_ExclusiveOr(SqlByte x, SqlByte y);
public static SqlByte op_Explicit(SqlBoolean x);
public static byte op_Explicit(SqlByte x);
public static SqlByte op_Explicit(SqlDecimal x);
public static SqlByte op_Explicit(SqlDouble x);
public static SqlByte op_Explicit(SqlInt16 x);
public static SqlByte op_Explicit(SqlInt32 x);
public static SqlByte op_Explicit(SqlInt64 x);
public static SqlByte op_Explicit(SqlMoney x);
public static SqlByte op_Explicit(SqlSingle x);
public static SqlByte op_Explicit(SqlString x);
public static SqlBoolean op_GreaterThan(SqlByte x, SqlByte y);
public static SqlBoolean op_GreaterThanOrEqual(SqlByte x, SqlByte y);
public static SqlByte op_Implicit(byte x);
public static SqlBoolean op_Inequality(SqlByte x, SqlByte y);
public static SqlBoolean op_LessThan(SqlByte x, SqlByte y);
public static SqlBoolean op_LessThanOrEqual(SqlByte x, SqlByte y);
public static SqlByte op_Modulus(SqlByte x, SqlByte y);
public static SqlByte op_Multiply(SqlByte x, SqlByte y);
public static SqlByte op_OnesComplement(SqlByte x);
public static SqlByte op_Subtraction(SqlByte x, SqlByte y);
public static SqlByte Parse(string s);
public static SqlByte Subtract(SqlByte x, SqlByte y);
public SqlBoolean ToSqlBoolean();
public SqlDecimal ToSqlDecimal();
public SqlDouble ToSqlDouble();
public SqlInt16 ToSqlInt16();
public SqlInt32 ToSqlInt32();
public SqlInt64 ToSqlInt64();
public SqlMoney ToSqlMoney();
public SqlSingle ToSqlSingle();
public SqlString ToSqlString();
public override string ToString();
public static SqlByte Xor(SqlByte x, SqlByte y);

Property
public virtual bool IsNull {get;}
public byte Value {get;}

Field
public readonly static SqlByte MaxValue;
public readonly static SqlByte MinValue;
public readonly static SqlByte Null;
public readonly static SqlByte Zero;

System.Data.SqlTypes.SqlBoolean

Module:System.Data.Common.dll
Module:system.data.dll

Hierarchy
Object
ValueType
SqlBoolean : INullable, IComparable

Type declaration

[C#] public struct SqlBoolean : ValueType, INullable, IComparable;

Constructor
public SqlBoolean(bool value);
public SqlBoolean(int value);

Method
public static SqlBoolean And(SqlBoolean x, SqlBoolean y);
public virtual int CompareTo(object value);
public override bool Equals(object value);
public static SqlBoolean Equals(SqlBoolean x, SqlBoolean y);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public static SqlBoolean NotEquals(SqlBoolean x, SqlBoolean y);
public static SqlBoolean OnesComplement(SqlBoolean x);
public static SqlBoolean op_BitwiseAnd(SqlBoolean x, SqlBoolean y);
public static SqlBoolean op_BitwiseOr(SqlBoolean x, SqlBoolean y);
public static SqlBoolean op_Equality(SqlBoolean x, SqlBoolean y);
public static SqlBoolean op_ExclusiveOr(SqlBoolean x, SqlBoolean y);
public static bool op_Explicit(SqlBoolean x);
public static SqlBoolean op_Explicit(SqlByte x);
public static SqlBoolean op_Explicit(SqlDecimal x);
public static SqlBoolean op_Explicit(SqlDouble x);
public static SqlBoolean op_Explicit(SqlInt16 x);
public static SqlBoolean op_Explicit(SqlInt32 x);
public static SqlBoolean op_Explicit(SqlInt64 x);
public static SqlBoolean op_Explicit(SqlMoney x);
public static SqlBoolean op_Explicit(SqlSingle x);
public static SqlBoolean op_Explicit(SqlString x);
public static bool op_False(SqlBoolean x);
public static SqlBoolean op_Implicit(bool x);
public static SqlBoolean op_Inequality(SqlBoolean x, SqlBoolean y);
public static SqlBoolean op_LogicalNot(SqlBoolean x);
public static SqlBoolean op_OnesComplement(SqlBoolean x);
public static bool op_True(SqlBoolean x);
public static SqlBoolean Or(SqlBoolean x, SqlBoolean y);
public static SqlBoolean Parse(string s);
public SqlByte ToSqlByte();
public SqlDecimal ToSqlDecimal();
public SqlDouble ToSqlDouble();
public SqlInt16 ToSqlInt16();
public SqlInt32 ToSqlInt32();
public SqlInt64 ToSqlInt64();
public SqlMoney ToSqlMoney();
public SqlSingle ToSqlSingle();
public SqlString ToSqlString();
public override string ToString();
public static SqlBoolean Xor(SqlBoolean x, SqlBoolean y);

Property
public byte ByteValue {get;}
public bool IsFalse {get;}
public virtual bool IsNull {get;}
public bool IsTrue {get;}
public bool Value {get;}

Field
public readonly static SqlBoolean False;
public readonly static SqlBoolean Null;
public readonly static SqlBoolean One;
public readonly static SqlBoolean True;
public readonly static SqlBoolean Zero;

System.Data.SqlTypes.SqlBinary

Module:System.Data.Common.dll
Module:system.data.dll

Hierarchy
Object
ValueType
SqlBinary : INullable, IComparable

Type declaration

[C#] public struct SqlBinary : ValueType, INullable, IComparable;

Constructor
public SqlBinary(byte[] value);

Method
public virtual int CompareTo(object value);
public static SqlBinary Concat(SqlBinary x, SqlBinary y);
public override bool Equals(object value);
public static SqlBoolean Equals(SqlBinary x, SqlBinary y);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public static SqlBoolean GreaterThan(SqlBinary x, SqlBinary y);
public static SqlBoolean GreaterThanOrEqual(SqlBinary x, SqlBinary y);
public static SqlBoolean LessThan(SqlBinary x, SqlBinary y);
public static SqlBoolean LessThanOrEqual(SqlBinary x, SqlBinary y);
protected object MemberwiseClone();
public static SqlBoolean NotEquals(SqlBinary x, SqlBinary y);
public static SqlBinary op_Addition(SqlBinary x, SqlBinary y);
public static SqlBoolean op_Equality(SqlBinary x, SqlBinary y);
public static byte[] op_Explicit(SqlBinary x);
public static SqlBinary op_Explicit(SqlGuid x);
public static SqlBoolean op_GreaterThan(SqlBinary x, SqlBinary y);
public static SqlBoolean op_GreaterThanOrEqual(SqlBinary x, SqlBinary y);
public static SqlBinary op_Implicit(byte[] x);
public static SqlBoolean op_Inequality(SqlBinary x, SqlBinary y);
public static SqlBoolean op_LessThan(SqlBinary x, SqlBinary y);
public static SqlBoolean op_LessThanOrEqual(SqlBinary x, SqlBinary y);
public SqlGuid ToSqlGuid();
public override string ToString();

Property
public virtual bool IsNull {get;}
public byte this[int index] {get;}
public int Length {get;}
public byte[] Value {get;}

Field
public readonly static SqlBinary Null;

System.Data.SqlTypes.INullable

Module:System.Data.Common.dll
Module:system.data.dll

Hierarchy
INullable

Type declaration

[C#] public interface INullable;

Property
public bool IsNull {get;}

System.Data.Common.DbDataRecord

Module:System.Data.SqlClient.dll
Module:system.data.dll

Hierarchy
Object
DbDataRecord : IDataRecord, ICustomTypeDescriptor

Type declaration

[C#] public class DbDataRecord: IDataRecord, ICustomTypeDescriptor;

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual bool GetBoolean(int i);
public virtual byte GetByte(int i);
public virtual long GetBytes(int i, long dataIndex, byte[] buffer, int bufferIndex, int length);
public virtual char GetChar(int i);
public virtual long GetChars(int i, long dataIndex, char[] buffer, int bufferIndex, int length);
public virtual IDataReader GetData(int i);
public virtual string GetDataTypeName(int i);
public virtual DateTime GetDateTime(int i);
public virtual decimal GetDecimal(int i);
public virtual double GetDouble(int i);
public virtual Type GetFieldType(int i);
public virtual float GetFloat(int i);
public virtual Guid GetGuid(int i);
public virtual int GetHashCode();
public virtual short GetInt16(int i);
public virtual int GetInt32(int i);
public virtual long GetInt64(int i);
public virtual string GetName(int i);
public virtual int GetOrdinal(string name);
public virtual string GetString(int i);
public Type GetType();
public virtual object GetValue(int i);
public virtual int GetValues(object[] values);
public virtual bool IsDBNull(int i);
protected object MemberwiseClone();
public virtual string ToString();

Property
public virtual int FieldCount {get;}
public virtual object this[int i] {get;}
public virtual object this[string name] {get;}

System.Data.Common.DbEnumerator

Module:System.Data.SqlClient.dll
Module:system.data.dll

Hierarchy
Object
DbEnumerator : IEnumerator

Type declaration

[C#] public class DbEnumerator: IEnumerator;

Constructor
public DbEnumerator(IDataReader reader);
public DbEnumerator(IDataReader reader, bool closeReader);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual bool MoveNext();
public virtual void Reset();
public virtual string ToString();

Property
public virtual object Current {get;}

System.Data.Common.RowUpdatingEventArgs

Module:System.Data.Common.dll
Module:system.data.dll

Hierarchy
Object
EventArgs
RowUpdatingEventArgs

Type declaration

[C#] public abstract class RowUpdatingEventArgs : EventArgs;

Constructor
protected RowUpdatingEventArgs(DataRow dataRow, IDbCommand command, StatementType statementType, DataTableMapping tableMapping);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public IDbCommand Command {get; set;}
public Exception Errors {get; set;}
public DataRow Row {get;}
public StatementType StatementType {get;}
public UpdateStatus Status {get; set;}
public DataTableMapping TableMapping {get;}

System.Data.Common.RowUpdatedEventArgs

Module:System.Data.Common.dll
Module:system.data.dll

Hierarchy
Object
EventArgs
RowUpdatedEventArgs

Type declaration

[C#] public abstract class RowUpdatedEventArgs : EventArgs;

Constructor
protected RowUpdatedEventArgs(DataRow dataRow, IDbCommand command, StatementType statementType, DataTableMapping tableMapping);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public IDbCommand Command {get;}
public Exception Errors {get; set;}
public int RecordsAffected {get;}
public DataRow Row {get;}
public StatementType StatementType {get;}
public UpdateStatus Status {get; set;}
public DataTableMapping TableMapping {get;}

System.Data.Common.DbDataAdapter

Module:System.Data.Common.dll
Module:system.data.dll

Hierarchy
Object
MarshalByRefObject
Component
DataAdapter
DbDataAdapter : ICloneable

Type declaration

[C#] public abstract class DbDataAdapter : DataAdapter, ICloneable;

Constructor
protected DbDataAdapter();
protected DbDataAdapter(DbDataAdapter adapter);

Method
public void add_Disposed(EventHandler value);
public void add_FillError(FillErrorEventHandler value);
protected virtual DataAdapter CloneInternals();
public ObjRef CreateObjRef(Type requestedType);
protected abstract RowUpdatedEventArgs CreateRowUpdatedEvent(DataRow dataRow, IDbCommand command, StatementType statementType, DataTableMapping tableMapping);
protected abstract RowUpdatingEventArgs CreateRowUpdatingEvent(DataRow dataRow, IDbCommand command, StatementType statementType, DataTableMapping tableMapping);
protected virtual DataTableMappingCollection CreateTableMappings();
public void Dispose();
protected virtual void Dispose(bool disposing);
public virtual bool Equals(object obj);
public override int Fill(DataSet dataSet);
public int Fill(DataSet dataSet, int startRecord, int maxRecords, string srcTable);
protected virtual int Fill(DataSet dataSet, int startRecord, int maxRecords, string srcTable, IDbCommand command, CommandBehavior behavior);
public int Fill(DataSet dataSet, string srcTable);
protected virtual int Fill(DataSet dataSet, string srcTable, IDataReader dataReader, int startRecord, int maxRecords);
public int Fill(DataTable dataTable);
protected virtual int Fill(DataTable dataTable, IDataReader dataReader);
protected virtual int Fill(DataTable dataTable, IDbCommand command, CommandBehavior behavior);
public override DataTable[] FillSchema(DataSet dataSet, SchemaType schemaType);
protected virtual DataTable[] FillSchema(DataSet dataSet, SchemaType schemaType, IDbCommand command, string srcTable, CommandBehavior behavior);
public DataTable[] FillSchema(DataSet dataSet, SchemaType schemaType, string srcTable);
public DataTable FillSchema(DataTable dataTable, SchemaType schemaType);
protected virtual DataTable FillSchema(DataTable dataTable, SchemaType schemaType, IDbCommand command, CommandBehavior behavior);
protected override void Finalize();
public override IDataParameter[] GetFillParameters();
public virtual int GetHashCode();
public object GetLifetimeService();
protected virtual object GetService(Type service);
public Type GetType();
public object InitializeLifetimeService();
protected object MemberwiseClone();
protected virtual void OnFillError(FillErrorEventArgs value);
protected abstract void OnRowUpdated(RowUpdatedEventArgs value);
protected abstract void OnRowUpdating(RowUpdatingEventArgs value);
public void remove_Disposed(EventHandler value);
public void remove_FillError(FillErrorEventHandler value);
protected virtual bool ShouldSerializeTableMappings();
public virtual string ToString();
public int Update(DataRow[] dataRows);
protected virtual int Update(DataRow[] dataRows, DataTableMapping tableMapping);
public override int Update(DataSet dataSet);
public int Update(DataSet dataSet, string srcTable);
public int Update(DataTable dataTable);

Property
public bool AcceptChangesDuringFill {get; set;}
public IContainer Container {get;}
public bool ContinueUpdateOnError {get; set;}
protected bool DesignMode {get;}
protected EventHandlerList Events {get;}
public virtual MissingMappingAction MissingMappingAction {get; set;}
public virtual MissingSchemaAction MissingSchemaAction {get; set;}
public ISite Site {get; set;}
public DataTableMappingCollection TableMappings {get;}

Field
public const string DefaultSourceTableName = "Table";

System.Data.Common.DataTableMappingCollection

Module:System.Data.Common.dll
Module:system.data.dll

Hierarchy
Object
MarshalByRefObject
DataTableMappingCollection : ITableMappingCollection, IList, ICollection, IEnumerable

Type declaration

[C#] public sealed class DataTableMappingCollection : MarshalByRefObject, ITableMappingCollection, IList, ICollection, IEnumerable;

Constructor
public DataTableMappingCollection();

Method
public virtual int Add(object value);
public DataTableMapping Add(string sourceTable, string dataSetTable);
public void AddRange(DataTableMapping[] values);
public virtual void Clear();
public virtual bool Contains(object value);
public virtual bool Contains(string value);
public virtual void CopyTo(Array array, int index);
public ObjRef CreateObjRef(Type requestedType);
public virtual bool Equals(object obj);
protected override void Finalize();
public DataTableMapping GetByDataSetTable(string dataSetTable);
public virtual IEnumerator GetEnumerator();
public virtual int GetHashCode();
public object GetLifetimeService();
public static DataTableMapping GetTableMappingBySchemaAction(DataTableMappingCollection tableMappings, string sourceTable, string dataSetTable, MissingMappingAction mappingAction);
public Type GetType();
public virtual int IndexOf(object value);
public virtual int IndexOf(string sourceTable);
public int IndexOfDataSetTable(string dataSetTable);
public object InitializeLifetimeService();
public virtual void Insert(int index, object value);
protected object MemberwiseClone();
public virtual void Remove(object value);
public virtual void RemoveAt(int index);
public virtual void RemoveAt(string sourceTable);
public virtual string ToString();

Property
public virtual int Count {get;}
public DataTableMapping this[int index] {get; set;}
public DataTableMapping this[string sourceTable] {get; set;}

System.Data.Common.DataTableMapping

Module:System.Data.Common.dll
Module:system.data.dll

Hierarchy
Object
MarshalByRefObject
DataTableMapping : ITableMapping, ICloneable

Type declaration

[C#] public sealed class DataTableMapping : MarshalByRefObject, ITableMapping, ICloneable;

Constructor
public DataTableMapping();
public DataTableMapping(string sourceTable, string dataSetTable);
public DataTableMapping(string sourceTable, string dataSetTable, DataColumnMapping[] columnMappings);

Method
public ObjRef CreateObjRef(Type requestedType);
public virtual bool Equals(object obj);
protected override void Finalize();
public DataColumnMapping GetColumnMappingBySchemaAction(string sourceColumn, MissingMappingAction mappingAction);
public DataTable GetDataTableBySchemaAction(DataSet dataSet, MissingSchemaAction schemaAction);
public virtual int GetHashCode();
public object GetLifetimeService();
public Type GetType();
public object InitializeLifetimeService();
protected object MemberwiseClone();
public override string ToString();

Property
public DataColumnMappingCollection ColumnMappings {get;}
public virtual string DataSetTable {get; set;}
public virtual string SourceTable {get; set;}

System.Data.Common.DataColumnMappingCollection

Module:System.Data.Common.dll
Module:system.data.dll

Hierarchy
Object
MarshalByRefObject
DataColumnMappingCollection : IColumnMappingCollection, IList, ICollection, IEnumerable

Type declaration

[C#] public sealed class DataColumnMappingCollection : MarshalByRefObject, IColumnMappingCollection, IList, ICollection, IEnumerable;

Constructor
public DataColumnMappingCollection();

Method
public virtual int Add(object value);
public DataColumnMapping Add(string sourceColumn, string dataSetColumn);
public void AddRange(DataColumnMapping[] values);
public virtual void Clear();
public virtual bool Contains(object value);
public virtual bool Contains(string value);
public virtual void CopyTo(Array array, int index);
public ObjRef CreateObjRef(Type requestedType);
public virtual bool Equals(object obj);
protected override void Finalize();
public DataColumnMapping GetByDataSetColumn(string value);
public static DataColumnMapping GetColumnMappingBySchemaAction(DataColumnMappingCollection columnMappings, string sourceColumn, MissingMappingAction mappingAction);
public virtual IEnumerator GetEnumerator();
public virtual int GetHashCode();
public object GetLifetimeService();
public Type GetType();
public virtual int IndexOf(object value);
public virtual int IndexOf(string sourceColumn);
public int IndexOfDataSetColumn(string dataSetColumn);
public object InitializeLifetimeService();
public virtual void Insert(int index, object value);
protected object MemberwiseClone();
public virtual void Remove(object value);
public virtual void RemoveAt(int index);
public virtual void RemoveAt(string sourceColumn);
public virtual string ToString();

Property
public virtual int Count {get;}
public DataColumnMapping this[int index] {get; set;}
public DataColumnMapping this[string sourceColumn] {get; set;}

System.Data.Common.DataColumnMapping

Module:System.Data.Common.dll
Module:system.data.dll

Hierarchy
Object
MarshalByRefObject
DataColumnMapping : IColumnMapping, ICloneable

Type declaration

[C#] public sealed class DataColumnMapping : MarshalByRefObject, IColumnMapping, ICloneable;

Constructor
public DataColumnMapping();
public DataColumnMapping(string sourceColumn, string dataSetColumn);

Method
public ObjRef CreateObjRef(Type requestedType);
public virtual bool Equals(object obj);
protected override void Finalize();
public DataColumn GetDataColumnBySchemaAction(DataTable dataTable, Type dataType, MissingSchemaAction schemaAction);
public virtual int GetHashCode();
public object GetLifetimeService();
public Type GetType();
public object InitializeLifetimeService();
protected object MemberwiseClone();
public override string ToString();

Property
public virtual string DataSetColumn {get; set;}
public virtual string SourceColumn {get; set;}

System.Data.Common.DataAdapter

Module:System.Data.Common.dll
Module:system.data.dll

Hierarchy
Object
MarshalByRefObject
Component
DataAdapter : IDataAdapter

Type declaration

[C#] public abstract class DataAdapter : Component, IDataAdapter;

Constructor
protected DataAdapter();
protected DataAdapter(DataAdapter adapter);

Method
public void add_Disposed(EventHandler value);
protected virtual DataAdapter CloneInternals();
public ObjRef CreateObjRef(Type requestedType);
protected virtual DataTableMappingCollection CreateTableMappings();
public void Dispose();
protected virtual void Dispose(bool disposing);
public virtual bool Equals(object obj);
public abstract int Fill(DataSet dataSet);
public abstract DataTable[] FillSchema(DataSet dataSet, SchemaType schemaType);
protected override void Finalize();
public abstract IDataParameter[] GetFillParameters();
public virtual int GetHashCode();
public object GetLifetimeService();
protected virtual object GetService(Type service);
public Type GetType();
public object InitializeLifetimeService();
protected object MemberwiseClone();
public void remove_Disposed(EventHandler value);
protected virtual bool ShouldSerializeTableMappings();
public virtual string ToString();
public abstract int Update(DataSet dataSet);

Property
public bool AcceptChangesDuringFill {get; set;}
public IContainer Container {get;}
public bool ContinueUpdateOnError {get; set;}
protected bool DesignMode {get;}
protected EventHandlerList Events {get;}
public virtual MissingMappingAction MissingMappingAction {get; set;}
public virtual MissingSchemaAction MissingSchemaAction {get; set;}
public ISite Site {get; set;}
public DataTableMappingCollection TableMappings {get;}

System.Data.SqlClient.SqlTransaction

Module:System.Data.SqlClient.dll
Module:system.data.dll

Hierarchy
Object
MarshalByRefObject
SqlTransaction : IDbTransaction, IDisposable

Type declaration

[C#] public sealed class SqlTransaction : MarshalByRefObject, IDbTransaction, IDisposable;

Method
public virtual void Commit();
public ObjRef CreateObjRef(Type requestedType);
public virtual void Dispose();
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public object GetLifetimeService();
public Type GetType();
public object InitializeLifetimeService();
protected object MemberwiseClone();
public virtual void Rollback();
public void Rollback(string transactionName);
public void Save(string savePointName);
public virtual string ToString();

Property
public SqlConnection Connection {get;}
public virtual IsolationLevel IsolationLevel {get;}

System.Data.SqlClient.SqlParameterCollection

Module:System.Data.SqlClient.dll
Module:system.data.dll

Hierarchy
Object
MarshalByRefObject
SqlParameterCollection : IDataParameterCollection, IList, ICollection, IEnumerable

Type declaration

[C#] public sealed class SqlParameterCollection : MarshalByRefObject, IDataParameterCollection, IList, ICollection, IEnumerable;

Method
public virtual int Add(object value);
public SqlParameter Add(SqlParameter value);
public SqlParameter Add(string parameterName, object value);
public SqlParameter Add(string parameterName, SqlDbType sqlDbType);
public SqlParameter Add(string parameterName, SqlDbType sqlDbType, int size);
public SqlParameter Add(string parameterName, SqlDbType sqlDbType, int size, string sourceColumn);
public virtual void Clear();
public virtual bool Contains(object value);
public virtual bool Contains(string value);
public virtual void CopyTo(Array array, int index);
public ObjRef CreateObjRef(Type requestedType);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual IEnumerator GetEnumerator();
public virtual int GetHashCode();
public object GetLifetimeService();
public Type GetType();
public virtual int IndexOf(object value);
public virtual int IndexOf(string parameterName);
public object InitializeLifetimeService();
public virtual void Insert(int index, object value);
protected object MemberwiseClone();
public virtual void Remove(object value);
public virtual void RemoveAt(int index);
public virtual void RemoveAt(string parameterName);
public virtual string ToString();

Property
public virtual int Count {get;}
public SqlParameter this[int index] {get; set;}
public SqlParameter this[string parameterName] {get; set;}

System.Data.SqlClient.SqlParameter

Module:System.Data.SqlClient.dll
Module:system.data.dll

Hierarchy
Object
MarshalByRefObject
SqlParameter : IDbDataParameter, IDataParameter, ICloneable

Type declaration

[C#] public sealed class SqlParameter : MarshalByRefObject, IDbDataParameter, IDataParameter, ICloneable;

Constructor
public SqlParameter();
public SqlParameter(string parameterName, object value);
public SqlParameter(string parameterName, SqlDbType dbType);
public SqlParameter(string parameterName, SqlDbType dbType, int size);
public SqlParameter(string parameterName, SqlDbType dbType, int size, ParameterDirection direction, bool isNullable, byte precision, byte scale, string sourceColumn, DataRowVersion sourceVersion, object value);
public SqlParameter(string parameterName, SqlDbType dbType, int size, string sourceColumn);

Method
public ObjRef CreateObjRef(Type requestedType);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public object GetLifetimeService();
public Type GetType();
public object InitializeLifetimeService();
protected object MemberwiseClone();
public override string ToString();

Property
public virtual DbType DbType {get; set;}
public virtual ParameterDirection Direction {get; set;}
public virtual bool IsNullable {get; set;}
public int Offset {get; set;}
public virtual string ParameterName {get; set;}
public virtual byte Precision {get; set;}
public virtual byte Scale {get; set;}
public virtual int Size {get; set;}
public virtual string SourceColumn {get; set;}
public virtual DataRowVersion SourceVersion {get; set;}
public SqlDbType SqlDbType {get; set;}
public virtual object Value {get; set;}

System.Data.SqlClient.SqlDataReader

Module:System.Data.SqlClient.dll
Module:system.data.dll

Hierarchy
Object
MarshalByRefObject
SqlDataReader : IEnumerable, IDataReader, IDisposable, IDataRecord

Type declaration

[C#] public sealed class SqlDataReader : MarshalByRefObject, IEnumerable, IDataReader, IDisposable, IDataRecord;

Method
public virtual void Close();
public ObjRef CreateObjRef(Type requestedType);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual bool GetBoolean(int i);
public virtual byte GetByte(int i);
public virtual long GetBytes(int i, long dataIndex, byte[] buffer, int bufferIndex, int length);
public virtual char GetChar(int i);
public virtual long GetChars(int i, long dataIndex, char[] buffer, int bufferIndex, int length);
public virtual IDataReader GetData(int i);
public virtual string GetDataTypeName(int i);
public virtual DateTime GetDateTime(int i);
public virtual decimal GetDecimal(int i);
public virtual double GetDouble(int i);
public virtual Type GetFieldType(int i);
public virtual float GetFloat(int i);
public virtual Guid GetGuid(int i);
public virtual int GetHashCode();
public virtual short GetInt16(int i);
public virtual int GetInt32(int i);
public virtual long GetInt64(int i);
public object GetLifetimeService();
public virtual string GetName(int i);
public virtual int GetOrdinal(string name);
public virtual DataTable GetSchemaTable();
public SqlBinary GetSqlBinary(int i);
public SqlBoolean GetSqlBoolean(int i);
public SqlByte GetSqlByte(int i);
public SqlDateTime GetSqlDateTime(int i);
public SqlDecimal GetSqlDecimal(int i);
public SqlDouble GetSqlDouble(int i);
public SqlGuid GetSqlGuid(int i);
public SqlInt16 GetSqlInt16(int i);
public SqlInt32 GetSqlInt32(int i);
public SqlInt64 GetSqlInt64(int i);
public SqlMoney GetSqlMoney(int i);
public SqlSingle GetSqlSingle(int i);
public SqlString GetSqlString(int i);
public object GetSqlValue(int i);
public int GetSqlValues(object[] values);
public virtual string GetString(int i);
public Type GetType();
public virtual object GetValue(int i);
public virtual int GetValues(object[] values);
public object InitializeLifetimeService();
public virtual bool IsDBNull(int i);
protected object MemberwiseClone();
public virtual bool NextResult();
public virtual bool Read();
public virtual string ToString();

Property
public virtual int Depth {get;}
public virtual int FieldCount {get;}
public bool HasRows {get;}
public virtual bool IsClosed {get;}
public virtual object this[int i] {get;}
public virtual object this[string name] {get;}
public virtual int RecordsAffected {get;}

System.Data.SqlClient.SqlCommandBuilder

Module:System.Data.SqlClient.dll
Module:system.data.dll

Hierarchy
Object
MarshalByRefObject
Component
SqlCommandBuilder

Type declaration

[C#] public sealed class SqlCommandBuilder : Component;

Constructor
public SqlCommandBuilder();
public SqlCommandBuilder(SqlDataAdapter adapter);

Method
public void add_Disposed(EventHandler value);
public ObjRef CreateObjRef(Type requestedType);
public static void DeriveParameters(SqlCommand command);
public void Dispose();
protected virtual void Dispose(bool disposing);
public virtual bool Equals(object obj);
protected override void Finalize();
public SqlCommand GetDeleteCommand();
public virtual int GetHashCode();
public SqlCommand GetInsertCommand();
public object GetLifetimeService();
protected virtual object GetService(Type service);
public Type GetType();
public SqlCommand GetUpdateCommand();
public object InitializeLifetimeService();
protected object MemberwiseClone();
public void RefreshSchema();
public void remove_Disposed(EventHandler value);
public virtual string ToString();

Property
public IContainer Container {get;}
public SqlDataAdapter DataAdapter {get; set;}
protected bool DesignMode {get;}
protected EventHandlerList Events {get;}
public string QuotePrefix {get; set;}
public string QuoteSuffix {get; set;}
public ISite Site {get; set;}

System.Data.SqlClient.SqlConnection

Module:System.Data.SqlClient.dll
Module:system.data.dll

Hierarchy
Object
MarshalByRefObject
Component
SqlConnection : IDbConnection, ICloneable, IDisposable

Type declaration

[C#] public sealed class SqlConnection : Component, IDbConnection, ICloneable, IDisposable;

Constructor
public SqlConnection();
public SqlConnection(string connectionString);

Method
public void add_Disposed(EventHandler value);
public void add_InfoMessage(SqlInfoMessageEventHandler value);
public void add_StateChange(StateChangeEventHandler value);
public SqlTransaction BeginTransaction();
public SqlTransaction BeginTransaction(IsolationLevel iso);
public SqlTransaction BeginTransaction(IsolationLevel iso, string transactionName);
public SqlTransaction BeginTransaction(string transactionName);
public virtual void ChangeDatabase(string database);
public virtual void Close();
public SqlCommand CreateCommand();
public ObjRef CreateObjRef(Type requestedType);
public void Dispose();
protected virtual void Dispose(bool disposing);
public void EnlistDistributedTransaction(ITransaction transaction);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public object GetLifetimeService();
protected virtual object GetService(Type service);
public Type GetType();
public object InitializeLifetimeService();
protected object MemberwiseClone();
public virtual void Open();
public void remove_Disposed(EventHandler value);
public void remove_InfoMessage(SqlInfoMessageEventHandler value);
public void remove_StateChange(StateChangeEventHandler value);
public virtual string ToString();

Property
public virtual string ConnectionString {get; set;}
public virtual int ConnectionTimeout {get;}
public IContainer Container {get;}
public virtual string Database {get;}
public string DataSource {get;}
protected bool DesignMode {get;}
protected EventHandlerList Events {get;}
public int PacketSize {get;}
public string ServerVersion {get;}
public ISite Site {get; set;}
public virtual ConnectionState State {get;}
public string WorkstationId {get;}

System.Data.SqlClient.SqlCommand

Module:System.Data.SqlClient.dll
Module:system.data.dll

Hierarchy
Object
MarshalByRefObject
Component
SqlCommand : IDbCommand, IDisposable, ICloneable

Type declaration

[C#] public sealed class SqlCommand : Component, IDbCommand, IDisposable, ICloneable;

Constructor
public SqlCommand();
public SqlCommand(string cmdText);
public SqlCommand(string cmdText, SqlConnection connection);
public SqlCommand(string cmdText, SqlConnection connection, SqlTransaction transaction);

Method
public void add_Disposed(EventHandler value);
public virtual void Cancel();
public ObjRef CreateObjRef(Type requestedType);
public SqlParameter CreateParameter();
public void Dispose();
protected virtual void Dispose(bool disposing);
public virtual bool Equals(object obj);
public virtual int ExecuteNonQuery();
public SqlDataReader ExecuteReader();
public SqlDataReader ExecuteReader(CommandBehavior behavior);
public virtual object ExecuteScalar();
public XmlReader ExecuteXmlReader();
protected override void Finalize();
public virtual int GetHashCode();
public object GetLifetimeService();
protected virtual object GetService(Type service);
public Type GetType();
public object InitializeLifetimeService();
protected object MemberwiseClone();
public virtual void Prepare();
public void remove_Disposed(EventHandler value);
public void ResetCommandTimeout();
public virtual string ToString();

Property
public virtual string CommandText {get; set;}
public virtual int CommandTimeout {get; set;}
public virtual CommandType CommandType {get; set;}
public SqlConnection Connection {get; set;}
public IContainer Container {get;}
protected bool DesignMode {get;}
public bool DesignTimeVisible {get; set;}
protected EventHandlerList Events {get;}
public SqlParameterCollection Parameters {get;}
public ISite Site {get; set;}
public SqlTransaction Transaction {get; set;}
public virtual UpdateRowSource UpdatedRowSource {get; set;}

System.Data.SqlClient.SqlRowUpdatingEventHandler

Module:System.Data.SqlClient.dll
Module:system.data.dll

Hierarchy
Object
Delegate
MulticastDelegate
SqlRowUpdatingEventHandler

Type declaration

[C#] public delegate void SqlRowUpdatingEventHandler(object sender, SqlRowUpdatingEventArgs e);

Constructor
public SqlRowUpdatingEventHandler(object object, IntPtr method);

Method
public virtual IAsyncResult BeginInvoke(object sender, SqlRowUpdatingEventArgs e, AsyncCallback callback, object object);
public object Clone();
protected override Delegate CombineImpl(Delegate follow);
public object DynamicInvoke(object[] args);
protected virtual object DynamicInvokeImpl(object[] args);
public virtual void EndInvoke(IAsyncResult result);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public override Delegate[] GetInvocationList();
protected virtual MethodInfo GetMethodImpl();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
public override void Invoke(object sender, SqlRowUpdatingEventArgs e);
protected object MemberwiseClone();
protected override Delegate RemoveImpl(Delegate value);
public virtual string ToString();

Property
public MethodInfo Method {get;}
public object Target {get;}

System.Data.SqlClient.SqlRowUpdatingEventArgs

Module:System.Data.SqlClient.dll
Module:system.data.dll

Hierarchy
Object
EventArgs
RowUpdatingEventArgs
SqlRowUpdatingEventArgs

Type declaration

[C#] public sealed class SqlRowUpdatingEventArgs : RowUpdatingEventArgs;

Constructor
public SqlRowUpdatingEventArgs(DataRow row, IDbCommand command, StatementType statementType, DataTableMapping tableMapping);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public IDbCommand Command {get; set;}
public SqlCommand Command {get; set;}
public Exception Errors {get; set;}
public DataRow Row {get;}
public StatementType StatementType {get;}
public UpdateStatus Status {get; set;}
public DataTableMapping TableMapping {get;}

System.Data.SqlClient.SqlRowUpdatedEventHandler

Module:System.Data.SqlClient.dll
Module:system.data.dll

Hierarchy
Object
Delegate
MulticastDelegate
SqlRowUpdatedEventHandler

Type declaration

[C#] public delegate void SqlRowUpdatedEventHandler(object sender, SqlRowUpdatedEventArgs e);

Constructor
public SqlRowUpdatedEventHandler(object object, IntPtr method);

Method
public virtual IAsyncResult BeginInvoke(object sender, SqlRowUpdatedEventArgs e, AsyncCallback callback, object object);
public object Clone();
protected override Delegate CombineImpl(Delegate follow);
public object DynamicInvoke(object[] args);
protected virtual object DynamicInvokeImpl(object[] args);
public virtual void EndInvoke(IAsyncResult result);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public override Delegate[] GetInvocationList();
protected virtual MethodInfo GetMethodImpl();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
public override void Invoke(object sender, SqlRowUpdatedEventArgs e);
protected object MemberwiseClone();
protected override Delegate RemoveImpl(Delegate value);
public virtual string ToString();

Property
public MethodInfo Method {get;}
public object Target {get;}

System.Data.SqlClient.SqlRowUpdatedEventArgs

Module:System.Data.SqlClient.dll
Module:system.data.dll

Hierarchy
Object
EventArgs
RowUpdatedEventArgs
SqlRowUpdatedEventArgs

Type declaration

[C#] public sealed class SqlRowUpdatedEventArgs : RowUpdatedEventArgs;

Constructor
public SqlRowUpdatedEventArgs(DataRow row, IDbCommand command, StatementType statementType, DataTableMapping tableMapping);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public IDbCommand Command {get;}
public SqlCommand Command {get;}
public Exception Errors {get; set;}
public int RecordsAffected {get;}
public DataRow Row {get;}
public StatementType StatementType {get;}
public UpdateStatus Status {get; set;}
public DataTableMapping TableMapping {get;}

System.Data.SqlClient.SqlInfoMessageEventHandler

Module:System.Data.SqlClient.dll
Module:system.data.dll

Hierarchy
Object
Delegate
MulticastDelegate
SqlInfoMessageEventHandler

Type declaration

[C#] public delegate void SqlInfoMessageEventHandler(object sender, SqlInfoMessageEventArgs e);

Constructor
public SqlInfoMessageEventHandler(object object, IntPtr method);

Method
public virtual IAsyncResult BeginInvoke(object sender, SqlInfoMessageEventArgs e, AsyncCallback callback, object object);
public object Clone();
protected override Delegate CombineImpl(Delegate follow);
public object DynamicInvoke(object[] args);
protected virtual object DynamicInvokeImpl(object[] args);
public virtual void EndInvoke(IAsyncResult result);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public override Delegate[] GetInvocationList();
protected virtual MethodInfo GetMethodImpl();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
public override void Invoke(object sender, SqlInfoMessageEventArgs e);
protected object MemberwiseClone();
protected override Delegate RemoveImpl(Delegate value);
public virtual string ToString();

Property
public MethodInfo Method {get;}
public object Target {get;}

System.Data.SqlClient.SqlInfoMessageEventArgs

Module:System.Data.SqlClient.dll
Module:system.data.dll

Hierarchy
Object
EventArgs
SqlInfoMessageEventArgs

Type declaration

[C#] public sealed class SqlInfoMessageEventArgs : EventArgs;

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public SqlErrorCollection Errors {get;}
public string Message {get;}
public string Source {get;}

System.Data.SqlClient.SqlException

Module:System.Data.SqlClient.dll
Module:system.data.dll

Hierarchy
Object
Exception
SystemException
SqlException

Type declaration

[C#] public sealed class SqlException : SystemException;

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public override void GetObjectData(SerializationInfo si, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public byte Class {get;}
public SqlErrorCollection Errors {get;}
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public int LineNumber {get;}
public string Message {get;}
public int Number {get;}
public string Procedure {get;}
public string Server {get;}
public string Source {get;}
public string StackTrace {get;}
public byte State {get;}
public MethodBase TargetSite {get;}

System.Data.SqlClient.SqlErrorCollection

Module:System.Data.SqlClient.dll
Module:system.data.dll

Hierarchy
Object
SqlErrorCollection : ICollection, IEnumerable

Type declaration

[C#] public sealed class SqlErrorCollection: ICollection, IEnumerable;

Method
public virtual void CopyTo(Array array, int index);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual IEnumerator GetEnumerator();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public virtual int Count {get;}
public SqlError this[int index] {get;}

System.Data.SqlClient.SqlError

Module:System.Data.SqlClient.dll
Module:system.data.dll

Hierarchy
Object
SqlError

Type declaration

[C#] public sealed class SqlError;

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public byte Class {get;}
public int LineNumber {get;}
public string Message {get;}
public int Number {get;}
public string Procedure {get;}
public string Server {get;}
public string Source {get;}
public byte State {get;}

System.Data.SqlClient.SqlDataAdapter

Module:System.Data.SqlClient.dll
Module:system.data.dll

Hierarchy
Object
MarshalByRefObject
Component
DataAdapter
DbDataAdapter
SqlDataAdapter : IDbDataAdapter, IDataAdapter

Type declaration

[C#] public sealed class SqlDataAdapter : DbDataAdapter, IDbDataAdapter, IDataAdapter;

Constructor
public SqlDataAdapter();
public SqlDataAdapter(SqlCommand selectCommand);
public SqlDataAdapter(string selectCommandText, SqlConnection selectConnection);
public SqlDataAdapter(string selectCommandText, string selectConnectionString);

Method
public void add_Disposed(EventHandler value);
public void add_FillError(FillErrorEventHandler value);
public void add_RowUpdated(SqlRowUpdatedEventHandler value);
public void add_RowUpdating(SqlRowUpdatingEventHandler value);
protected override DataAdapter CloneInternals();
public ObjRef CreateObjRef(Type requestedType);
protected override RowUpdatedEventArgs CreateRowUpdatedEvent(DataRow dataRow, IDbCommand command, StatementType statementType, DataTableMapping tableMapping);
protected override RowUpdatingEventArgs CreateRowUpdatingEvent(DataRow dataRow, IDbCommand command, StatementType statementType, DataTableMapping tableMapping);
protected virtual DataTableMappingCollection CreateTableMappings();
public void Dispose();
protected virtual void Dispose(bool disposing);
public virtual bool Equals(object obj);
public override int Fill(DataSet dataSet);
public int Fill(DataSet dataSet, int startRecord, int maxRecords, string srcTable);
protected virtual int Fill(DataSet dataSet, int startRecord, int maxRecords, string srcTable, IDbCommand command, CommandBehavior behavior);
public int Fill(DataSet dataSet, string srcTable);
protected virtual int Fill(DataSet dataSet, string srcTable, IDataReader dataReader, int startRecord, int maxRecords);
public int Fill(DataTable dataTable);
protected virtual int Fill(DataTable dataTable, IDataReader dataReader);
protected virtual int Fill(DataTable dataTable, IDbCommand command, CommandBehavior behavior);
public override DataTable[] FillSchema(DataSet dataSet, SchemaType schemaType);
protected virtual DataTable[] FillSchema(DataSet dataSet, SchemaType schemaType, IDbCommand command, string srcTable, CommandBehavior behavior);
public DataTable[] FillSchema(DataSet dataSet, SchemaType schemaType, string srcTable);
public DataTable FillSchema(DataTable dataTable, SchemaType schemaType);
protected virtual DataTable FillSchema(DataTable dataTable, SchemaType schemaType, IDbCommand command, CommandBehavior behavior);
protected override void Finalize();
public override IDataParameter[] GetFillParameters();
public virtual int GetHashCode();
public object GetLifetimeService();
protected virtual object GetService(Type service);
public Type GetType();
public object InitializeLifetimeService();
protected object MemberwiseClone();
protected virtual void OnFillError(FillErrorEventArgs value);
protected override void OnRowUpdated(RowUpdatedEventArgs value);
protected override void OnRowUpdating(RowUpdatingEventArgs value);
public void remove_Disposed(EventHandler value);
public void remove_FillError(FillErrorEventHandler value);
public void remove_RowUpdated(SqlRowUpdatedEventHandler value);
public void remove_RowUpdating(SqlRowUpdatingEventHandler value);
protected virtual bool ShouldSerializeTableMappings();
public virtual string ToString();
public int Update(DataRow[] dataRows);
protected virtual int Update(DataRow[] dataRows, DataTableMapping tableMapping);
public override int Update(DataSet dataSet);
public int Update(DataSet dataSet, string srcTable);
public int Update(DataTable dataTable);

Property
public bool AcceptChangesDuringFill {get; set;}
public IContainer Container {get;}
public bool ContinueUpdateOnError {get; set;}
public SqlCommand DeleteCommand {get; set;}
protected bool DesignMode {get;}
protected EventHandlerList Events {get;}
public SqlCommand InsertCommand {get; set;}
public virtual MissingMappingAction MissingMappingAction {get; set;}
public virtual MissingSchemaAction MissingSchemaAction {get; set;}
public SqlCommand SelectCommand {get; set;}
public ISite Site {get; set;}
public DataTableMappingCollection TableMappings {get;}
public SqlCommand UpdateCommand {get; set;}

System.Data.SqlServerCe.SqlCeTransaction

Module:System.Data.SqlServerCe.dll

Hierarchy
Object
MarshalByRefObject
SqlCeTransaction : IDbTransaction, IDisposable

Type declaration

[C#] public sealed class SqlCeTransaction : MarshalByRefObject, IDbTransaction, IDisposable;

Method
public virtual void Commit();
public virtual void Dispose();
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual void Rollback();
public virtual string ToString();

Property
public SqlCeConnection Connection {get;}
public virtual IsolationLevel IsolationLevel {get;}

System.Data.SqlServerCe.SqlCeParameterCollection

Module:System.Data.SqlServerCe.dll

Hierarchy
Object
MarshalByRefObject
SqlCeParameterCollection : IDataParameterCollection, IList, ICollection, IEnumerable

Type declaration

[C#] public sealed class SqlCeParameterCollection : MarshalByRefObject, IDataParameterCollection, IList, ICollection, IEnumerable;

Method
public virtual int Add(object value);
public SqlCeParameter Add(SqlCeParameter value);
public SqlCeParameter Add(string parameterName, object value);
public SqlCeParameter Add(string parameterName, SqlDbType type);
public SqlCeParameter Add(string parameterName, SqlDbType type, int size);
public SqlCeParameter Add(string parameterName, SqlDbType type, int size, string sourceColumn);
public virtual void Clear();
public virtual bool Contains(object value);
public virtual bool Contains(string value);
public virtual void CopyTo(Array array, int index);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual IEnumerator GetEnumerator();
public virtual int GetHashCode();
public Type GetType();
public virtual int IndexOf(object value);
public virtual int IndexOf(string parameterName);
public virtual void Insert(int index, object value);
protected object MemberwiseClone();
public virtual void Remove(object value);
public virtual void RemoveAt(int index);
public virtual void RemoveAt(string parameterName);
public virtual string ToString();

Property
public virtual int Count {get;}
public SqlCeParameter this[int index] {get; set;}
public SqlCeParameter this[string parameterName] {get; set;}

System.Data.SqlServerCe.SqlCeParameter

Module:System.Data.SqlServerCe.dll

Hierarchy
Object
MarshalByRefObject
SqlCeParameter : IDbDataParameter, IDataParameter, ICloneable

Type declaration

[C#] public sealed class SqlCeParameter : MarshalByRefObject, IDbDataParameter, IDataParameter, ICloneable;

Constructor
public SqlCeParameter();
public SqlCeParameter(string name, object value);
public SqlCeParameter(string name, SqlDbType dataType);
public SqlCeParameter(string name, SqlDbType dataType, int size);
public SqlCeParameter(string parameterName, SqlDbType dbType, int size, bool isNullable, byte precision, byte scale, string srcColumn, DataRowVersion srcVersion, object value);
public SqlCeParameter(string name, SqlDbType dataType, int size, string srcColumn);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public virtual DbType DbType {get; set;}
public virtual ParameterDirection Direction {get; set;}
public virtual bool IsNullable {get; set;}
public virtual string ParameterName {get; set;}
public virtual byte Precision {get; set;}
public virtual byte Scale {get; set;}
public virtual int Size {get; set;}
public virtual string SourceColumn {get; set;}
public virtual DataRowVersion SourceVersion {get; set;}
public SqlDbType SqlDbType {get; set;}
public virtual object Value {get; set;}

System.Data.SqlServerCe.SqlCeDataReader

Module:System.Data.SqlServerCe.dll

Hierarchy
Object
MarshalByRefObject
SqlCeDataReader : IDataReader, IDisposable, IDataRecord

Type declaration

[C#] public sealed class SqlCeDataReader : MarshalByRefObject, IDataReader, IDisposable, IDataRecord;

Method
public virtual void Close();
public virtual void Dispose();
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual bool GetBoolean(int ordinal);
public virtual byte GetByte(int ordinal);
public virtual long GetBytes(int ordinal, long dataIndex, byte[] buffer, int bufferIndex, int length);
public virtual char GetChar(int ordinal);
public virtual long GetChars(int ordinal, long dataIndex, char[] buffer, int bufferIndex, int length);
public virtual string GetDataTypeName(int index);
public virtual DateTime GetDateTime(int ordinal);
public virtual decimal GetDecimal(int ordinal);
public virtual double GetDouble(int ordinal);
public virtual Type GetFieldType(int index);
public virtual float GetFloat(int ordinal);
public virtual Guid GetGuid(int ordinal);
public virtual int GetHashCode();
public virtual short GetInt16(int ordinal);
public virtual int GetInt32(int ordinal);
public virtual long GetInt64(int ordinal);
public virtual string GetName(int index);
public virtual int GetOrdinal(string name);
public virtual DataTable GetSchemaTable();
public SqlBinary GetSqlBinary(int ordinal);
public SqlBoolean GetSqlBoolean(int ordinal);
public SqlByte GetSqlByte(int ordinal);
public SqlDateTime GetSqlDateTime(int ordinal);
public SqlDecimal GetSqlDecimal(int ordinal);
public SqlDouble GetSqlDouble(int ordinal);
public SqlGuid GetSqlGuid(int ordinal);
public SqlInt16 GetSqlInt16(int ordinal);
public SqlInt32 GetSqlInt32(int ordinal);
public SqlInt64 GetSqlInt64(int ordinal);
public SqlMoney GetSqlMoney(int ordinal);
public SqlSingle GetSqlSingle(int ordinal);
public SqlString GetSqlString(int ordinal);
public virtual string GetString(int ordinal);
public Type GetType();
public virtual object GetValue(int ordinal);
public virtual int GetValues(object[] values);
public virtual bool IsDBNull(int ordinal);
protected object MemberwiseClone();
public virtual bool NextResult();
public virtual bool Read();
public void Seek(DbSeekOptions dbSeekOptions, params object[] index);
public virtual string ToString();

Property
public virtual int Depth {get;}
public virtual int FieldCount {get;}
public virtual bool IsClosed {get;}
public virtual object this[int index] {get;}
public virtual object this[string name] {get;}
public virtual int RecordsAffected {get;}

System.Data.SqlServerCe.SqlCeConnection

Module:System.Data.SqlServerCe.dll

Hierarchy
Object
MarshalByRefObject
SqlCeConnection : IDbConnection, IDisposable

Type declaration

[C#] public sealed class SqlCeConnection : MarshalByRefObject, IDbConnection, IDisposable;

Constructor
public SqlCeConnection();
public SqlCeConnection(string connectionString);

Method
public void add_InfoMessage(SqlCeInfoMessageEventHandler value);
public void add_StateChange(StateChangeEventHandler value);
public SqlCeTransaction BeginTransaction();
public SqlCeTransaction BeginTransaction(IsolationLevel isolationLevel);
public virtual void ChangeDatabase(string value);
public virtual void Close();
public SqlCeCommand CreateCommand();
public virtual void Dispose();
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual void Open();
public void remove_InfoMessage(SqlCeInfoMessageEventHandler value);
public void remove_StateChange(StateChangeEventHandler value);
public virtual string ToString();

Property
public virtual string ConnectionString {get; set;}
public virtual int ConnectionTimeout {get;}
public virtual string Database {get;}
public string DataSource {get;}
public virtual ConnectionState State {get;}

System.Data.SqlServerCe.SqlCeCommandBuilder

Module:System.Data.SqlServerCe.dll

Hierarchy
Object
MarshalByRefObject
Component
SqlCeCommandBuilder

Type declaration

[C#] public sealed class SqlCeCommandBuilder : Component;

Constructor
public SqlCeCommandBuilder();
public SqlCeCommandBuilder(SqlCeDataAdapter adapter);

Method
public void add_Disposed(EventHandler value);
public void Dispose();
protected virtual void Dispose(bool disposing);
public virtual bool Equals(object obj);
protected override void Finalize();
public SqlCeCommand GetDeleteCommand();
public virtual int GetHashCode();
public SqlCeCommand GetInsertCommand();
public Type GetType();
public SqlCeCommand GetUpdateCommand();
protected object MemberwiseClone();
public void RefreshSchema();
public void remove_Disposed(EventHandler value);
public virtual string ToString();

Property
public SqlCeDataAdapter DataAdapter {get; set;}
public string QuotePrefix {get; set;}
public string QuoteSuffix {get; set;}

System.Data.SqlServerCe.SqlCeCommand

Module:System.Data.SqlServerCe.dll

Hierarchy
Object
MarshalByRefObject
SqlCeCommand : ICloneable, IDbCommand, IDisposable

Type declaration

[C#] public sealed class SqlCeCommand : MarshalByRefObject, ICloneable, IDbCommand, IDisposable;

Constructor
public SqlCeCommand();
public SqlCeCommand(string cmdText);
public SqlCeCommand(string cmdText, SqlCeConnection connection);
public SqlCeCommand(string cmdText, SqlCeConnection connection, SqlCeTransaction transaction);

Method
public virtual void Cancel();
public SqlCeParameter CreateParameter();
public virtual void Dispose();
public virtual bool Equals(object obj);
public virtual int ExecuteNonQuery();
public SqlCeDataReader ExecuteReader();
public SqlCeDataReader ExecuteReader(CommandBehavior behavior);
public virtual object ExecuteScalar();
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual void Prepare();
public void SetRange(DbRangeOptions dbRangeOptions, object[] startData, object[] endData);
public virtual string ToString();

Property
public virtual string CommandText {get; set;}
public virtual int CommandTimeout {get; set;}
public virtual CommandType CommandType {get; set;}
public SqlCeConnection Connection {get; set;}
public string IndexName {get; set;}
public SqlCeParameterCollection Parameters {get;}
public SqlCeTransaction Transaction {get; set;}
public virtual UpdateRowSource UpdatedRowSource {get; set;}

System.Data.SqlServerCe.SqlCeRowUpdatingEventHandler

Module:System.Data.SqlServerCe.dll

Hierarchy
Object
Delegate
MulticastDelegate
SqlCeRowUpdatingEventHandler

Type declaration

[C#] public delegate void SqlCeRowUpdatingEventHandler(object sender, SqlCeRowUpdatingEventArgs e);

Constructor
public SqlCeRowUpdatingEventHandler(object object, IntPtr method);

Method
public virtual IAsyncResult BeginInvoke(object sender, SqlCeRowUpdatingEventArgs e, AsyncCallback callback, object object);
protected override Delegate CombineImpl(Delegate follow);
public virtual void EndInvoke(IAsyncResult result);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public override Delegate[] GetInvocationList();
public Type GetType();
public override void Invoke(object sender, SqlCeRowUpdatingEventArgs e);
protected object MemberwiseClone();
protected override Delegate RemoveImpl(Delegate value);
public virtual string ToString();

System.Data.SqlServerCe.SqlCeRowUpdatingEventArgs

Module:System.Data.SqlServerCe.dll

Hierarchy
Object
EventArgs
RowUpdatingEventArgs
SqlCeRowUpdatingEventArgs

Type declaration

[C#] public sealed class SqlCeRowUpdatingEventArgs : RowUpdatingEventArgs;

Constructor
public SqlCeRowUpdatingEventArgs(DataRow dataRow, IDbCommand command, StatementType statementType, DataTableMapping tableMapping);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public IDbCommand Command {get; set;}
public SqlCeCommand Command {get; set;}
public Exception Errors {get; set;}
public DataRow Row {get;}
public StatementType StatementType {get;}
public UpdateStatus Status {get; set;}
public DataTableMapping TableMapping {get;}

System.Data.SqlServerCe.SqlCeRowUpdatedEventHandler

Module:System.Data.SqlServerCe.dll

Hierarchy
Object
Delegate
MulticastDelegate
SqlCeRowUpdatedEventHandler

Type declaration

[C#] public delegate void SqlCeRowUpdatedEventHandler(object sender, SqlCeRowUpdatedEventArgs e);

Constructor
public SqlCeRowUpdatedEventHandler(object object, IntPtr method);

Method
public virtual IAsyncResult BeginInvoke(object sender, SqlCeRowUpdatedEventArgs e, AsyncCallback callback, object object);
protected override Delegate CombineImpl(Delegate follow);
public virtual void EndInvoke(IAsyncResult result);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public override Delegate[] GetInvocationList();
public Type GetType();
public override void Invoke(object sender, SqlCeRowUpdatedEventArgs e);
protected object MemberwiseClone();
protected override Delegate RemoveImpl(Delegate value);
public virtual string ToString();

System.Data.SqlServerCe.SqlCeRowUpdatedEventArgs

Module:System.Data.SqlServerCe.dll

Hierarchy
Object
EventArgs
RowUpdatedEventArgs
SqlCeRowUpdatedEventArgs

Type declaration

[C#] public sealed class SqlCeRowUpdatedEventArgs : RowUpdatedEventArgs;

Constructor
public SqlCeRowUpdatedEventArgs(DataRow dataRow, IDbCommand command, StatementType statementType, DataTableMapping tableMapping);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public IDbCommand Command {get;}
public SqlCeCommand Command {get;}
public Exception Errors {get; set;}
public int RecordsAffected {get;}
public DataRow Row {get;}
public StatementType StatementType {get;}
public UpdateStatus Status {get; set;}
public DataTableMapping TableMapping {get;}

System.Data.SqlServerCe.SqlCeInfoMessageEventHandler

Module:System.Data.SqlServerCe.dll

Hierarchy
Object
Delegate
MulticastDelegate
SqlCeInfoMessageEventHandler

Type declaration

[C#] public delegate void SqlCeInfoMessageEventHandler(object sender, SqlCeInfoMessageEventArgs e);

Constructor
public SqlCeInfoMessageEventHandler(object object, IntPtr method);

Method
public virtual IAsyncResult BeginInvoke(object sender, SqlCeInfoMessageEventArgs e, AsyncCallback callback, object object);
protected override Delegate CombineImpl(Delegate follow);
public virtual void EndInvoke(IAsyncResult result);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public override Delegate[] GetInvocationList();
public Type GetType();
public override void Invoke(object sender, SqlCeInfoMessageEventArgs e);
protected object MemberwiseClone();
protected override Delegate RemoveImpl(Delegate value);
public virtual string ToString();

System.Data.SqlServerCe.SqlCeInfoMessageEventArgs

Module:System.Data.SqlServerCe.dll

Hierarchy
Object
EventArgs
SqlCeInfoMessageEventArgs

Type declaration

[C#] public sealed class SqlCeInfoMessageEventArgs : EventArgs;

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public int ErrorCode {get;}
public SqlCeErrorCollection Errors {get;}
public string Message {get;}

System.Data.SqlServerCe.SqlCeException

Module:System.Data.SqlServerCe.dll

Hierarchy
Object
Exception
SystemException
SqlCeException

Type declaration

[C#] public sealed class SqlCeException : SystemException;

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public SqlCeErrorCollection Errors {get;}
public int HResult {get;}
public Exception InnerException {get;}
public virtual string Message {get;}
public string Message {get;}
public int NativeError {get;}
public string Source {get;}

System.Data.SqlServerCe.SqlCeErrorCollection

Module:System.Data.SqlServerCe.dll

Hierarchy
Object
SqlCeErrorCollection : ICollection, IEnumerable

Type declaration

[C#] public sealed class SqlCeErrorCollection: ICollection, IEnumerable;

Method
public virtual void CopyTo(Array array, int index);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual IEnumerator GetEnumerator();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public virtual int Count {get;}
public SqlCeError this[int index] {get;}

System.Data.SqlServerCe.SqlCeError

Module:System.Data.SqlServerCe.dll

Hierarchy
Object
SqlCeError

Type declaration

[C#] public sealed class SqlCeError;

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public string[] ErrorParameters {get;}
public int HResult {get;}
public string Message {get;}
public int NativeError {get;}
public int[] NumericErrorParameters {get;}
public string Source {get;}

System.Data.SqlServerCe.SqlCeDataAdapter

Module:System.Data.SqlServerCe.dll

Hierarchy
Object
MarshalByRefObject
Component
DataAdapter
DbDataAdapter
SqlCeDataAdapter : IDbDataAdapter, IDataAdapter

Type declaration

[C#] public sealed class SqlCeDataAdapter : DbDataAdapter, IDbDataAdapter, IDataAdapter;

Constructor
public SqlCeDataAdapter();
public SqlCeDataAdapter(SqlCeCommand selectCommand);
public SqlCeDataAdapter(string selectCommandText, SqlCeConnection selectConnection);
public SqlCeDataAdapter(string selectCommandText, string selectConnectionString);

Method
public void add_Disposed(EventHandler value);
public void add_FillError(FillErrorEventHandler value);
public void add_RowUpdated(SqlCeRowUpdatedEventHandler value);
public void add_RowUpdating(SqlCeRowUpdatingEventHandler value);
protected virtual DataAdapter CloneInternals();
protected override DataAdapter CloneInternals();
protected override RowUpdatedEventArgs CreateRowUpdatedEvent(DataRow dataRow, IDbCommand command, StatementType statementType, DataTableMapping tableMapping);
protected override RowUpdatingEventArgs CreateRowUpdatingEvent(DataRow dataRow, IDbCommand command, StatementType statementType, DataTableMapping tableMapping);
protected virtual DataTableMappingCollection CreateTableMappings();
public void Dispose();
protected virtual void Dispose(bool disposing);
public virtual bool Equals(object obj);
public override int Fill(DataSet dataSet);
public int Fill(DataSet dataSet, int startRecord, int maxRecords, string srcTable);
protected virtual int Fill(DataSet dataSet, int startRecord, int maxRecords, string srcTable, IDbCommand command, CommandBehavior behavior);
public int Fill(DataSet dataSet, string srcTable);
protected virtual int Fill(DataSet dataSet, string srcTable, IDataReader dataReader, int startRecord, int maxRecords);
public int Fill(DataTable dataTable);
protected virtual int Fill(DataTable dataTable, IDataReader dataReader);
protected virtual int Fill(DataTable dataTable, IDbCommand command, CommandBehavior behavior);
public override DataTable[] FillSchema(DataSet dataSet, SchemaType schemaType);
protected virtual DataTable[] FillSchema(DataSet dataSet, SchemaType schemaType, IDbCommand command, string srcTable, CommandBehavior behavior);
public DataTable[] FillSchema(DataSet dataSet, SchemaType schemaType, string srcTable);
public DataTable FillSchema(DataTable dataTable, SchemaType schemaType);
protected virtual DataTable FillSchema(DataTable dataTable, SchemaType schemaType, IDbCommand command, CommandBehavior behavior);
protected override void Finalize();
public override IDataParameter[] GetFillParameters();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
protected virtual void OnFillError(FillErrorEventArgs value);
protected abstract void OnRowUpdated(RowUpdatedEventArgs value);
protected override void OnRowUpdated(RowUpdatedEventArgs value);
protected abstract void OnRowUpdating(RowUpdatingEventArgs value);
protected override void OnRowUpdating(RowUpdatingEventArgs value);
public void remove_Disposed(EventHandler value);
public void remove_FillError(FillErrorEventHandler value);
public void remove_RowUpdated(SqlCeRowUpdatedEventHandler value);
public void remove_RowUpdating(SqlCeRowUpdatingEventHandler value);
public virtual string ToString();
public int Update(DataRow[] dataRows);
protected virtual int Update(DataRow[] dataRows, DataTableMapping tableMapping);
public abstract int Update(DataSet dataSet);
public override int Update(DataSet dataSet);
public int Update(DataSet dataSet, string srcTable);
public int Update(DataTable dataTable);

Property
public bool AcceptChangesDuringFill {get; set;}
public bool ContinueUpdateOnError {get; set;}
public SqlCeCommand DeleteCommand {get; set;}
public SqlCeCommand InsertCommand {get; set;}
public virtual MissingMappingAction MissingMappingAction {get; set;}
public virtual MissingSchemaAction MissingSchemaAction {get; set;}
public SqlCeCommand SelectCommand {get; set;}
public DataTableMappingCollection TableMappings {get;}
public SqlCeCommand UpdateCommand {get; set;}

System.Data.SqlServerCe.SqlCeReplication

Module:System.Data.SqlServerCe.dll

Hierarchy
Object
MarshalByRefObject
SqlCeReplication : IDisposable

Type declaration

[C#] public sealed class SqlCeReplication : MarshalByRefObject, IDisposable;

Constructor
public SqlCeReplication();
public SqlCeReplication(string internetUrl, string internetLogin, string internetPassword, string publisher, string publisherDatabase, string publication, string subscriber, string subscriberConnectionString);
public SqlCeReplication(string internetUrl, string internetLogin, string internetPassword, string publisher, string publisherDatabase, string publisherLogin, string publisherPassword, string publication, string subscriber, string subscriberConnectionString);

Method
public void AddSubscription(AddOption addOption);
public virtual void Dispose();
public void DropSubscription(DropOption dropOption);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public void ReinitializeSubscription(bool uploadBeforeReinit);
public void Synchronize();
public virtual string ToString();

Property
public string Distributor {get; set;}
public string DistributorAddress {get; set;}
public string DistributorLogin {get; set;}
public NetworkType DistributorNetwork {get; set;}
public string DistributorPassword {get; set;}
public SecurityType DistributorSecurityMode {get; set;}
public ExchangeType ExchangeType {get; set;}
public string HostName {get; set;}
public string InternetLogin {get; set;}
public string InternetPassword {get; set;}
public string InternetProxyLogin {get; set;}
public string InternetProxyPassword {get; set;}
public string InternetProxyServer {get; set;}
public string InternetUrl {get; set;}
public short LoginTimeout {get; set;}
public string ProfileName {get; set;}
public string Publication {get; set;}
public string Publisher {get; set;}
public string PublisherAddress {get; set;}
public int PublisherChanges {get;}
public int PublisherConflicts {get;}
public string PublisherDatabase {get; set;}
public string PublisherLogin {get; set;}
public NetworkType PublisherNetwork {get; set;}
public string PublisherPassword {get; set;}
public SecurityType PublisherSecurityMode {get; set;}
public short QueryTimeout {get; set;}
public string Subscriber {get; set;}
public int SubscriberChanges {get;}
public string SubscriberConnectionString {get; set;}
public ValidateType Validate {get; set;}

System.Data.SqlServerCe.ValidateType

Module:System.Data.SqlServerCe.dll

Hierarchy
Object
ValueType
Enum
ValidateType

Type declaration

[C#] public enum ValidateType;

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();

Field
public const ValidateType NoValidation = 0;
public const ValidateType RowCountOnly = 1;
public int value__;

System.Data.SqlServerCe.ExchangeType

Module:System.Data.SqlServerCe.dll

Hierarchy
Object
ValueType
Enum
ExchangeType

Type declaration

[C#] public enum ExchangeType;

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();

Field
public const ExchangeType BiDirectional = 3;
public const ExchangeType Upload = 1;
public int value__;

System.Data.SqlServerCe.SecurityType

Module:System.Data.SqlServerCe.dll

Hierarchy
Object
ValueType
Enum
SecurityType

Type declaration

[C#] public enum SecurityType;

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();

Field
public const SecurityType DBAuthentication = 0;
public const SecurityType NTAuthentication = 1;
public int value__;

System.Data.SqlServerCe.NetworkType

Module:System.Data.SqlServerCe.dll

Hierarchy
Object
ValueType
Enum
NetworkType

Type declaration

[C#] public enum NetworkType;

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();

Field
public const NetworkType DefaultNetwork = 0;
public const NetworkType MultiProtocol = 2;
public const NetworkType TcpIpSockets = 1;
public int value__;

System.Data.SqlServerCe.DropOption

Module:System.Data.SqlServerCe.dll

Hierarchy
Object
ValueType
Enum
DropOption

Type declaration

[C#] public enum DropOption;

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();

Field
public const DropOption DropDatabase = 1;
public const DropOption LeaveDatabase = 0;
public int value__;

System.Data.SqlServerCe.AddOption

Module:System.Data.SqlServerCe.dll

Hierarchy
Object
ValueType
Enum
AddOption

Type declaration

[C#] public enum AddOption;

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();

Field
public const AddOption CreateDatabase = 1;
public const AddOption ExistingDatabase = 0;
public int value__;

System.Data.SqlServerCe.SqlCeRemoteDataAccess

Module:System.Data.SqlServerCe.dll

Hierarchy
Object
MarshalByRefObject
SqlCeRemoteDataAccess : IDisposable

Type declaration

[C#] public sealed class SqlCeRemoteDataAccess : MarshalByRefObject, IDisposable;

Constructor
public SqlCeRemoteDataAccess();
public SqlCeRemoteDataAccess(string internetUrl, string localConnectionString);
public SqlCeRemoteDataAccess(string internetUrl, string internetLogin, string internetPassword, string localConnectionString);

Method
public virtual void Dispose();
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public void Pull(string localTableName, string sqlSelectString, string oledbConnectionString);
public void Pull(string localTableName, string sqlSelectString, string oledbConnectionString, RdaTrackOption trackOption);
public void Pull(string localTableName, string sqlSelectString, string oledbConnectionString, RdaTrackOption trackOption, string errorTable);
public void Push(string localTableName, string oledbConnectionString);
public void Push(string localTableName, string oledbConnectionString, RdaBatchOption batchOption);
public void SubmitSql(string sqlString, string oledbConnectionString);
public virtual string ToString();

Property
public string InternetLogin {get; set;}
public string InternetPassword {get; set;}
public string InternetProxyLogin {get; set;}
public string InternetProxyPassword {get; set;}
public string InternetProxyServer {get; set;}
public string InternetUrl {get; set;}
public string LocalConnectionString {get; set;}

System.Data.SqlServerCe.RdaBatchOption

Module:System.Data.SqlServerCe.dll

Hierarchy
Object
ValueType
Enum
RdaBatchOption

Type declaration

[C#] public enum RdaBatchOption;

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();

Field
public const RdaBatchOption BatchingOff = 0;
public const RdaBatchOption BatchingOn = 1;
public int value__;

System.Data.SqlServerCe.RdaTrackOption

Module:System.Data.SqlServerCe.dll

Hierarchy
Object
ValueType
Enum
RdaTrackOption

Type declaration

[C#] public enum RdaTrackOption;

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();

Field
public const RdaTrackOption TrackingOff = 0;
public const RdaTrackOption TrackingOffWithIndexes = 3;
public const RdaTrackOption TrackingOn = 1;
public const RdaTrackOption TrackingOnWithIndexes = 2;
public int value__;

System.Data.SqlServerCe.DbSeekOptions

Module:System.Data.SqlServerCe.dll

Hierarchy
Object
ValueType
Enum
DbSeekOptions

Type declaration

[C#] public enum DbSeekOptions;

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();

Field
public const DbSeekOptions After = 8;
public const DbSeekOptions AfterEqual = 4;
public const DbSeekOptions Before = 32;
public const DbSeekOptions BeforeEqual = 16;
public const DbSeekOptions FirstEqual = 1;
public const DbSeekOptions LastEqual = 2;
public int value__;

System.Data.SqlServerCe.DbRangeOptions

Module:System.Data.SqlServerCe.dll

Hierarchy
Object
ValueType
Enum
DbRangeOptions

Type declaration

[C#] public enum DbRangeOptions;

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();

Field
public const DbRangeOptions Default = 0;
public const DbRangeOptions ExcludeNulls = 4;
public const DbRangeOptions ExclusiveEnd = 2;
public const DbRangeOptions ExclusiveStart = 1;
public const DbRangeOptions InclusiveEnd = 0;
public const DbRangeOptions InclusiveStart = 0;
public const DbRangeOptions Match = 16;
public const DbRangeOptions Prefix = 8;
public int value__;

System.Data.SqlServerCe.SqlCeEngine

Module:System.Data.SqlServerCe.dll

Hierarchy
Object
MarshalByRefObject
SqlCeEngine : IDisposable

Type declaration

[C#] public sealed class SqlCeEngine : MarshalByRefObject, IDisposable;

Constructor
public SqlCeEngine();
public SqlCeEngine(string localConnectionString);

Method
public void Compact(string destConnect);
public void CreateDatabase();
public virtual void Dispose();
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public string LocalConnectionString {get; set;}

System.Drawing.Drawing2D.CombineMode

Module:System.Drawing.dll

Hierarchy
Object
ValueType
Enum
CombineMode

Type declaration

[C#] public enum CombineMode;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const CombineMode Complement = 5;
public const CombineMode Exclude = 4;
public const CombineMode Intersect = 1;
public const CombineMode Replace = 0;
public const CombineMode Union = 2;
public int value__;
public const CombineMode Xor = 3;

System.Drawing.SystemColors

Module:System.Drawing.dll

Hierarchy
Object
SystemColors

Type declaration

[C#] public sealed class SystemColors;

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public static Color ActiveBorder {get;}
public static Color ActiveCaption {get;}
public static Color ActiveCaptionText {get;}
public static Color AppWorkspace {get;}
public static Color Control {get;}
public static Color ControlDark {get;}
public static Color ControlDarkDark {get;}
public static Color ControlLight {get;}
public static Color ControlLightLight {get;}
public static Color ControlText {get;}
public static Color Desktop {get;}
public static Color GrayText {get;}
public static Color Highlight {get;}
public static Color HighlightText {get;}
public static Color HotTrack {get;}
public static Color InactiveBorder {get;}
public static Color InactiveCaption {get;}
public static Color InactiveCaptionText {get;}
public static Color Info {get;}
public static Color InfoText {get;}
public static Color Menu {get;}
public static Color MenuText {get;}
public static Color ScrollBar {get;}
public static Color Window {get;}
public static Color WindowFrame {get;}
public static Color WindowText {get;}

System.Drawing.Pen

Module:System.Drawing.dll

Hierarchy
Object
MarshalByRefObject
Pen : IDisposable

Type declaration

[C#] public sealed class Pen : MarshalByRefObject, IDisposable;

Constructor
public Pen(Brush brush);
public Pen(Brush brush, float width);
public Pen(Color color);
public Pen(Color color, float width);

Method
public virtual object Clone();
public ObjRef CreateObjRef(Type requestedType);
public virtual void Dispose();
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public object GetLifetimeService();
public Type GetType();
public object InitializeLifetimeService();
protected object MemberwiseClone();
public void MultiplyTransform(Matrix matrix);
public void MultiplyTransform(Matrix matrix, MatrixOrder order);
public void ResetTransform();
public void RotateTransform(float angle);
public void RotateTransform(float angle, MatrixOrder order);
public void ScaleTransform(float sx, float sy);
public void ScaleTransform(float sx, float sy, MatrixOrder order);
public void SetLineCap(LineCap startCap, LineCap endCap, DashCap dashCap);
public virtual string ToString();
public void TranslateTransform(float dx, float dy);
public void TranslateTransform(float dx, float dy, MatrixOrder order);

Property
public PenAlignment Alignment {get; set;}
public Brush Brush {get; set;}
public Color Color {get; set;}
public float[] CompoundArray {get; set;}
public CustomLineCap CustomEndCap {get; set;}
public CustomLineCap CustomStartCap {get; set;}
public DashCap DashCap {get; set;}
public float DashOffset {get; set;}
public float[] DashPattern {get; set;}
public DashStyle DashStyle {get; set;}
public LineCap EndCap {get; set;}
public LineJoin LineJoin {get; set;}
public float MiterLimit {get; set;}
public PenType PenType {get;}
public LineCap StartCap {get; set;}
public Matrix Transform {get; set;}
public float Width {get; set;}

System.Drawing.FontStyle

Module:System.Drawing.dll

Hierarchy
Object
ValueType
Enum
FontStyle

Type declaration

[C#] public enum FontStyle;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const FontStyle Bold = 1;
public const FontStyle Italic = 2;
public const FontStyle Regular = 0;
public const FontStyle Strikeout = 8;
public const FontStyle Underline = 4;
public int value__;

System.Drawing.FontFamily

Module:System.Drawing.dll

Hierarchy
Object
MarshalByRefObject
FontFamily : IDisposable

Type declaration

[C#] public sealed class FontFamily : MarshalByRefObject, IDisposable;

Constructor
public FontFamily(GenericFontFamilies genericFamily);
public FontFamily(string name);
public FontFamily(string name, FontCollection fontCollection);

Method
public ObjRef CreateObjRef(Type requestedType);
public virtual void Dispose();
public virtual bool Equals(object obj);
protected override void Finalize();
public int GetCellAscent(FontStyle style);
public int GetCellDescent(FontStyle style);
public int GetEmHeight(FontStyle style);
public static FontFamily[] GetFamilies(Graphics graphics);
public virtual int GetHashCode();
public object GetLifetimeService();
public int GetLineSpacing(FontStyle style);
public string GetName(int language);
public Type GetType();
public object InitializeLifetimeService();
public bool IsStyleAvailable(FontStyle style);
protected object MemberwiseClone();
public virtual string ToString();

Property
public static FontFamily[] Families {get;}
public static FontFamily GenericMonospace {get;}
public static FontFamily GenericSansSerif {get;}
public static FontFamily GenericSerif {get;}
public string Name {get;}

System.Drawing.Font

Module:System.Drawing.dll

Hierarchy
Object
MarshalByRefObject
Font : IDisposable

Type declaration

[C#] public sealed class Font : MarshalByRefObject, IDisposable;

Constructor
public Font(Font prototype, FontStyle newStyle);
public Font(FontFamily family, float emSize);
public Font(FontFamily family, float emSize, FontStyle style);
public Font(FontFamily family, float emSize, FontStyle style, GraphicsUnit unit);
public Font(FontFamily family, float emSize, FontStyle style, GraphicsUnit unit, byte gdiCharSet);
public Font(FontFamily family, float emSize, FontStyle style, GraphicsUnit unit, byte gdiCharSet, bool gdiVerticalFont);
public Font(FontFamily family, float emSize, GraphicsUnit unit);
public Font(IntPtr htx);
public Font(string familyName, float emSize);
public Font(string name, float emSize, FontStyle style);
public Font(string familyName, float emSize, FontStyle style, GraphicsUnit unit);
public Font(string familyName, float emSize, FontStyle style, GraphicsUnit unit, byte gdiCharSet);
public Font(string familyName, float emSize, FontStyle style, GraphicsUnit unit, byte gdiCharSet, bool gdiVerticalFont);
public Font(string familyName, float emSize, GraphicsUnit unit);

Method
public virtual object Clone();
public ObjRef CreateObjRef(Type requestedType);
public virtual void Dispose();
public virtual bool Equals(object obj);
protected override void Finalize();
public static Font FromHdc(IntPtr hdc);
public static Font FromHfont(IntPtr hfont);
public static Font FromLogFont(object lf);
public static Font FromLogFont(object lf, IntPtr hdc);
public virtual int GetHashCode();
public float GetHeight();
public float GetHeight(Graphics graphics);
public float GetHeight(float dpi);
public IntPtr GetHtx();
public object GetLifetimeService();
public Type GetType();
public object InitializeLifetimeService();
protected object MemberwiseClone();
public IntPtr ToHfont();
public void ToLogFont(object logFont);
public void ToLogFont(object logFont, Graphics graphics);
public virtual string ToString();

Property
public bool Bold {get;}
public FontFamily FontFamily {get;}
public byte GdiCharSet {get;}
public bool GdiVerticalFont {get;}
public int Height {get;}
public bool Italic {get;}
public string Name {get;}
public float Size {get;}
public float SizeInPoints {get;}
public bool Strikeout {get;}
public FontStyle Style {get;}
public bool Underline {get;}
public GraphicsUnit Unit {get;}

System.Drawing.SizeF

Module:System.Drawing.dll

Hierarchy
Object
ValueType
SizeF

Type declaration

[C#] public struct SizeF : ValueType;

Constructor
public SizeF(PointF pt);
public SizeF(float width, float height);
public SizeF(SizeF size);

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public static SizeF op_Addition(SizeF sz1, SizeF sz2);
public static bool op_Equality(SizeF sizef1, SizeF sizef2);
public static PointF op_Explicit(SizeF size);
public static bool op_Inequality(SizeF sizef1, SizeF sizef2);
public static SizeF op_Subtraction(SizeF sz1, SizeF sz2);
public PointF ToPointF();
public Size ToSize();
public virtual string ToString();

Property
public float Height {get; set;}
public bool IsEmpty {get;}
public float Width {get; set;}

Field
public readonly static SizeF Empty;

System.Drawing.Size

Module:System.Drawing.dll

Hierarchy
Object
ValueType
Size

Type declaration

[C#] public struct Size : ValueType;

Constructor
public Size(int width, int height);
public Size(Point pt);

Method
public static Size Ceiling(SizeF value);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public static Size op_Addition(Size sz1, Size sz2);
public static bool op_Equality(Size left, Size right);
public static Point op_Explicit(Size size);
public static SizeF op_Implicit(Size p);
public static bool op_Inequality(Size left, Size right);
public static Size op_Subtraction(Size sz1, Size sz2);
public static Size Round(SizeF value);
public virtual string ToString();
public static Size Truncate(SizeF value);

Property
public int Height {get; set;}
public bool IsEmpty {get;}
public int Width {get; set;}

Field
public readonly static Size Empty;

System.Drawing.Region

Module:System.Drawing.dll

Hierarchy
Object
MarshalByRefObject
Region : IDisposable

Type declaration

[C#] public sealed class Region : MarshalByRefObject, IDisposable;

Constructor
public Region();
public Region(GraphicsPath path);
public Region(Rectangle rect);
public Region(RectangleF rect);
public Region(RegionData rgnData);

Method
public Region Clone();
public void Complement(GraphicsPath path);
public void Complement(Rectangle rect);
public void Complement(RectangleF rect);
public void Complement(Region region);
public ObjRef CreateObjRef(Type requestedType);
public virtual void Dispose();
public virtual bool Equals(object obj);
public bool Equals(Region region, Graphics g);
public void Exclude(GraphicsPath path);
public void Exclude(Rectangle rect);
public void Exclude(RectangleF rect);
public void Exclude(Region region);
protected override void Finalize();
public static Region FromHrgn(IntPtr hrgn);
public RectangleF GetBounds(Graphics g);
public virtual int GetHashCode();
public IntPtr GetHrgn(Graphics g);
public object GetLifetimeService();
public RegionData GetRegionData();
public RectangleF[] GetRegionScans(Matrix matrix);
public Type GetType();
public object InitializeLifetimeService();
public void Intersect(GraphicsPath path);
public void Intersect(Rectangle rect);
public void Intersect(RectangleF rect);
public void Intersect(Region region);
public bool IsEmpty(Graphics g);
public bool IsInfinite(Graphics g);
public bool IsVisible(int x, int y, Graphics g);
public bool IsVisible(int x, int y, int width, int height);
public bool IsVisible(int x, int y, int width, int height, Graphics g);
public bool IsVisible(Point point);
public bool IsVisible(Point point, Graphics g);
public bool IsVisible(PointF point);
public bool IsVisible(PointF point, Graphics g);
public bool IsVisible(Rectangle rect);
public bool IsVisible(Rectangle rect, Graphics g);
public bool IsVisible(RectangleF rect);
public bool IsVisible(RectangleF rect, Graphics g);
public bool IsVisible(float x, float y);
public bool IsVisible(float x, float y, Graphics g);
public bool IsVisible(float x, float y, float width, float height);
public bool IsVisible(float x, float y, float width, float height, Graphics g);
public void MakeEmpty();
public void MakeInfinite();
protected object MemberwiseClone();
public virtual string ToString();
public void Transform(Matrix matrix);
public void Translate(int dx, int dy);
public void Translate(float dx, float dy);
public void Union(GraphicsPath path);
public void Union(Rectangle rect);
public void Union(RectangleF rect);
public void Union(Region region);
public void Xor(GraphicsPath path);
public void Xor(Rectangle rect);
public void Xor(RectangleF rect);
public void Xor(Region region);

System.Drawing.RectangleF

Module:System.Drawing.dll

Hierarchy
Object
ValueType
RectangleF

Type declaration

[C#] public struct RectangleF : ValueType;

Constructor
public RectangleF(PointF location, SizeF size);
public RectangleF(float x, float y, float width, float height);

Method
public bool Contains(PointF pt);
public bool Contains(RectangleF rect);
public bool Contains(float x, float y);
public override bool Equals(object obj);
protected override void Finalize();
public static RectangleF FromLTRB(float left, float top, float right, float bottom);
public override int GetHashCode();
public Type GetType();
public static RectangleF Inflate(RectangleF rect, float x, float y);
public void Inflate(float x, float y);
public void Inflate(SizeF size);
public void Intersect(RectangleF rect);
public static RectangleF Intersect(RectangleF a, RectangleF b);
public bool IntersectsWith(RectangleF rect);
protected object MemberwiseClone();
public void Offset(PointF pos);
public void Offset(float x, float y);
public static bool op_Equality(RectangleF left, RectangleF right);
public static RectangleF op_Implicit(Rectangle r);
public static bool op_Inequality(RectangleF left, RectangleF right);
public virtual string ToString();
public static RectangleF Union(RectangleF a, RectangleF b);

Property
public float Bottom {get;}
public float Height {get; set;}
public bool IsEmpty {get;}
public float Left {get;}
public PointF Location {get; set;}
public float Right {get;}
public SizeF Size {get; set;}
public float Top {get;}
public float Width {get; set;}
public float X {get; set;}
public float Y {get; set;}

Field
public readonly static RectangleF Empty;

System.Drawing.Rectangle

Module:System.Drawing.dll

Hierarchy
Object
ValueType
Rectangle

Type declaration

[C#] public struct Rectangle : ValueType;

Constructor
public Rectangle(int x, int y, int width, int height);
public Rectangle(Point location, Size size);

Method
public static Rectangle Ceiling(RectangleF value);
public bool Contains(int x, int y);
public bool Contains(Point pt);
public bool Contains(Rectangle rc);
public override bool Equals(object obj);
protected override void Finalize();
public static Rectangle FromLTRB(int left, int top, int right, int bottom);
public override int GetHashCode();
public Type GetType();
public void Inflate(int width, int height);
public static Rectangle Inflate(Rectangle rect, int x, int y);
public void Inflate(Size size);
public void Intersect(Rectangle rect);
public static Rectangle Intersect(Rectangle a, Rectangle b);
public bool IntersectsWith(Rectangle rect);
protected object MemberwiseClone();
public void Offset(int x, int y);
public void Offset(Point pos);
public static bool op_Equality(Rectangle left, Rectangle right);
public static bool op_Inequality(Rectangle left, Rectangle right);
public static Rectangle Round(RectangleF value);
public virtual string ToString();
public static Rectangle Truncate(RectangleF value);
public static Rectangle Union(Rectangle a, Rectangle b);

Property
public int Bottom {get;}
public int Height {get; set;}
public bool IsEmpty {get;}
public int Left {get;}
public Point Location {get; set;}
public int Right {get;}
public Size Size {get; set;}
public int Top {get;}
public int Width {get; set;}
public int X {get; set;}
public int Y {get; set;}

Field
public readonly static Rectangle Empty;

System.Drawing.Point

Module:System.Drawing.dll

Hierarchy
Object
ValueType
Point

Type declaration

[C#] public struct Point : ValueType;

Constructor
public Point(int dw);
public Point(int x, int y);
public Point(Size sz);

Method
public static Point Ceiling(PointF value);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public void Offset(int dx, int dy);
public static Point op_Addition(Point pt, Size sz);
public static bool op_Equality(Point left, Point right);
public static Size op_Explicit(Point p);
public static PointF op_Implicit(Point p);
public static bool op_Inequality(Point left, Point right);
public static Point op_Subtraction(Point pt, Size sz);
public static Point Round(PointF value);
public virtual string ToString();
public static Point Truncate(PointF value);

Property
public bool IsEmpty {get;}
public int X {get; set;}
public int Y {get; set;}

Field
public readonly static Point Empty;

System.Drawing.Icon

Module:System.Drawing.dll

Hierarchy
Object
MarshalByRefObject
Icon : IDisposable

Type declaration

[C#] public sealed class Icon : MarshalByRefObject, IDisposable;

Constructor
public Icon(Icon original, int width, int height);
public Icon(Icon original, Size size);
public Icon(Stream stream);
public Icon(Stream stream, int width, int height);
public Icon(string fileName);
public Icon(Type type, string resource);

Method
public virtual object Clone();
public ObjRef CreateObjRef(Type requestedType);
public virtual void Dispose();
public virtual bool Equals(object obj);
protected override void Finalize();
public static Icon FromHandle(IntPtr handle);
public virtual int GetHashCode();
public static IntPtr GetHicnFromIcon(Icon icn);
public object GetLifetimeService();
public Type GetType();
public object InitializeLifetimeService();
protected object MemberwiseClone();
public void Save(Stream outputStream);
public Bitmap ToBitmap();
public virtual string ToString();

Property
public IntPtr Handle {get;}
public int Height {get;}
public Size Size {get;}
public int Width {get;}

System.Drawing.GraphicsUnit

Module:System.Drawing.dll

Hierarchy
Object
ValueType
Enum
GraphicsUnit

Type declaration

[C#] public enum GraphicsUnit;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const GraphicsUnit Display = 1;
public const GraphicsUnit Document = 5;
public const GraphicsUnit Inch = 4;
public const GraphicsUnit Millimeter = 6;
public const GraphicsUnit Pixel = 2;
public const GraphicsUnit Point = 3;
public int value__;
public const GraphicsUnit World = 0;

System.Drawing.Graphics

Module:System.Drawing.dll

Hierarchy
Object
MarshalByRefObject
Graphics : IDisposable

Type declaration

[C#] public sealed class Graphics : MarshalByRefObject, IDisposable;

Method
public void AddMetafileComment(byte[] data);
public GraphicsContainer BeginContainer();
public GraphicsContainer BeginContainer(Rectangle dstrect, Rectangle srcrect, GraphicsUnit unit);
public GraphicsContainer BeginContainer(RectangleF dstrect, RectangleF srcrect, GraphicsUnit unit);
public void Clear(Color color);
public ObjRef CreateObjRef(Type requestedType);
public virtual void Dispose();
public void DrawArc(Pen pen, int x, int y, int width, int height, int startAngle, int sweepAngle);
public void DrawArc(Pen pen, Rectangle rect, float startAngle, float sweepAngle);
public void DrawArc(Pen pen, RectangleF rect, float startAngle, float sweepAngle);
public void DrawArc(Pen pen, float x, float y, float width, float height, float startAngle, float sweepAngle);
public void DrawBezier(Pen pen, Point pt1, Point pt2, Point pt3, Point pt4);
public void DrawBezier(Pen pen, PointF pt1, PointF pt2, PointF pt3, PointF pt4);
public void DrawBezier(Pen pen, float x1, float y1, float x2, float y2, float x3, float y3, float x4, float y4);
public void DrawBeziers(Pen pen, Point[] points);
public void DrawBeziers(Pen pen, PointF[] points);
public void DrawClosedCurve(Pen pen, Point[] points);
public void DrawClosedCurve(Pen pen, Point[] points, float tension, FillMode fillmode);
public void DrawClosedCurve(Pen pen, PointF[] points);
public void DrawClosedCurve(Pen pen, PointF[] points, float tension, FillMode fillmode);
public void DrawCurve(Pen pen, Point[] points);
public void DrawCurve(Pen pen, Point[] points, int offset, int numberOfSegments, float tension);
public void DrawCurve(Pen pen, Point[] points, float tension);
public void DrawCurve(Pen pen, PointF[] points);
public void DrawCurve(Pen pen, PointF[] points, int offset, int numberOfSegments);
public void DrawCurve(Pen pen, PointF[] points, int offset, int numberOfSegments, float tension);
public void DrawCurve(Pen pen, PointF[] points, float tension);
public void DrawEllipse(Pen pen, int x, int y, int cx, int cy);
public void DrawEllipse(Pen pen, Rectangle rc);
public void DrawEllipse(Pen pen, RectangleF rect);
public void DrawEllipse(Pen pen, float x, float y, float width, float height);
public void DrawIcon(Icon icon, int x, int y);
public void DrawIcon(Icon icon, Rectangle targetRect);
public void DrawIconUnstretched(Icon icon, Rectangle targetRect);
public void DrawImage(Image image, int x, int y);
public void DrawImage(Image image, int x, int y, int width, int height);
public void DrawImage(Image image, int x, int y, Rectangle srcRect, GraphicsUnit srcUnit);
public void DrawImage(Image image, Point point);
public void DrawImage(Image image, Point[] destPoints);
public void DrawImage(Image image, Point[] destPoints, Rectangle srcRect, GraphicsUnit srcUnit);
public void DrawImage(Image image, Point[] destPoints, Rectangle srcRect, GraphicsUnit srcUnit, ImageAttributes imageAttr);
public void DrawImage(Image image, Point[] destPoints, Rectangle srcRect, GraphicsUnit srcUnit, ImageAttributes imageAttr, DrawImageAbort callback);
public void DrawImage(Image image, Point[] destPoints, Rectangle srcRect, GraphicsUnit srcUnit, ImageAttributes imageAttr, DrawImageAbort callback, int callbackData);
public void DrawImage(Image image, PointF point);
public void DrawImage(Image image, PointF[] destPoints);
public void DrawImage(Image image, PointF[] destPoints, RectangleF srcRect, GraphicsUnit srcUnit);
public void DrawImage(Image image, PointF[] destPoints, RectangleF srcRect, GraphicsUnit srcUnit, ImageAttributes imageAttr);
public void DrawImage(Image image, PointF[] destPoints, RectangleF srcRect, GraphicsUnit srcUnit, ImageAttributes imageAttr, DrawImageAbort callback);
public void DrawImage(Image image, PointF[] destPoints, RectangleF srcRect, GraphicsUnit srcUnit, ImageAttributes imageAttr, DrawImageAbort callback, int callbackData);
public void DrawImage(Image image, Rectangle rect);
public void DrawImage(Image image, Rectangle destRect, int srcX, int srcY, int srcWidth, int srcHeight, GraphicsUnit srcUnit);
public void DrawImage(Image image, Rectangle destRect, int srcX, int srcY, int srcWidth, int srcHeight, GraphicsUnit srcUnit, ImageAttributes imageAttr);
public void DrawImage(Image image, Rectangle destRect, int srcX, int srcY, int srcWidth, int srcHeight, GraphicsUnit srcUnit, ImageAttributes imageAttr, DrawImageAbort callback);
public void DrawImage(Image image, Rectangle destRect, int srcX, int srcY, int srcWidth, int srcHeight, GraphicsUnit srcUnit, ImageAttributes imageAttrs, DrawImageAbort callback, IntPtr callbackData);
public void DrawImage(Image image, Rectangle destRect, Rectangle srcRect, GraphicsUnit srcUnit);
public void DrawImage(Image image, Rectangle destRect, float srcX, float srcY, float srcWidth, float srcHeight, GraphicsUnit srcUnit);
public void DrawImage(Image image, Rectangle destRect, float srcX, float srcY, float srcWidth, float srcHeight, GraphicsUnit srcUnit, ImageAttributes imageAttrs);
public void DrawImage(Image image, Rectangle destRect, float srcX, float srcY, float srcWidth, float srcHeight, GraphicsUnit srcUnit, ImageAttributes imageAttrs, DrawImageAbort callback);
public void DrawImage(Image image, Rectangle destRect, float srcX, float srcY, float srcWidth, float srcHeight, GraphicsUnit srcUnit, ImageAttributes imageAttrs, DrawImageAbort callback, IntPtr callbackData);
public void DrawImage(Image image, RectangleF rect);
public void DrawImage(Image image, RectangleF destRect, RectangleF srcRect, GraphicsUnit srcUnit);
public void DrawImage(Image image, float x, float y);
public void DrawImage(Image image, float x, float y, RectangleF srcRect, GraphicsUnit srcUnit);
public void DrawImage(Image image, float x, float y, float width, float height);
public void DrawImageUnscaled(Image image, int x, int y);
public void DrawImageUnscaled(Image image, int x, int y, int width, int height);
public void DrawImageUnscaled(Image image, Point point);
public void DrawImageUnscaled(Image image, Rectangle rect);
public void DrawLine(Pen pen, int xStart, int yStart, int xEnd, int yEnd);
public void DrawLine(Pen pen, Point pt1, Point pt2);
public void DrawLine(Pen pen, PointF pt1, PointF pt2);
public void DrawLine(Pen pen, float x1, float y1, float x2, float y2);
public void DrawLines(Pen pen, Point[] points);
public void DrawLines(Pen pen, PointF[] points);
public void DrawPath(Pen pen, GraphicsPath path);
public void DrawPie(Pen pen, int x, int y, int width, int height, int startAngle, int sweepAngle);
public void DrawPie(Pen pen, Rectangle rect, float startAngle, float sweepAngle);
public void DrawPie(Pen pen, RectangleF rect, float startAngle, float sweepAngle);
public void DrawPie(Pen pen, float x, float y, float width, float height, float startAngle, float sweepAngle);
public void DrawPolygon(Pen pen, Point[] points);
public void DrawPolygon(Pen pen, PointF[] points);
public void DrawRectangle(Pen pen, int x, int y, int cx, int cy);
public void DrawRectangle(Pen pen, Rectangle rc);
public void DrawRectangle(Pen pen, float x, float y, float width, float height);
public void DrawRectangles(Pen pen, Rectangle[] rects);
public void DrawRectangles(Pen pen, RectangleF[] rects);
public void DrawString(string s, Font font, Brush brush, PointF point);
public void DrawString(string s, Font font, Brush brush, PointF point, StringFormat format);
public void DrawString(string s, Font font, Brush brush, RectangleF rcf);
public void DrawString(string s, Font font, Brush brush, RectangleF layoutRectangle, StringFormat format);
public void DrawString(string s, Font font, Brush brush, float x, float y);
public void DrawString(string s, Font font, Brush brush, float x, float y, StringFormat format);
public void EndContainer(GraphicsContainer container);
public void EnumerateMetafile(Metafile metafile, Point destPoint, EnumerateMetafileProc callback);
public void EnumerateMetafile(Metafile metafile, Point destPoint, EnumerateMetafileProc callback, IntPtr callbackData);
public void EnumerateMetafile(Metafile metafile, Point destPoint, EnumerateMetafileProc callback, IntPtr callbackData, ImageAttributes imageAttr);
public void EnumerateMetafile(Metafile metafile, Point destPoint, Rectangle srcRect, GraphicsUnit srcUnit, EnumerateMetafileProc callback);
public void EnumerateMetafile(Metafile metafile, Point destPoint, Rectangle srcRect, GraphicsUnit srcUnit, EnumerateMetafileProc callback, IntPtr callbackData);
public void EnumerateMetafile(Metafile metafile, Point destPoint, Rectangle srcRect, GraphicsUnit unit, EnumerateMetafileProc callback, IntPtr callbackData, ImageAttributes imageAttr);
public void EnumerateMetafile(Metafile metafile, Point[] destPoints, EnumerateMetafileProc callback);
public void EnumerateMetafile(Metafile metafile, Point[] destPoints, EnumerateMetafileProc callback, IntPtr callbackData);
public void EnumerateMetafile(Metafile metafile, Point[] destPoints, EnumerateMetafileProc callback, IntPtr callbackData, ImageAttributes imageAttr);
public void EnumerateMetafile(Metafile metafile, Point[] destPoints, Rectangle srcRect, GraphicsUnit srcUnit, EnumerateMetafileProc callback);
public void EnumerateMetafile(Metafile metafile, Point[] destPoints, Rectangle srcRect, GraphicsUnit srcUnit, EnumerateMetafileProc callback, IntPtr callbackData);
public void EnumerateMetafile(Metafile metafile, Point[] destPoints, Rectangle srcRect, GraphicsUnit unit, EnumerateMetafileProc callback, IntPtr callbackData, ImageAttributes imageAttr);
public void EnumerateMetafile(Metafile metafile, PointF destPoint, EnumerateMetafileProc callback);
public void EnumerateMetafile(Metafile metafile, PointF destPoint, EnumerateMetafileProc callback, IntPtr callbackData);
public void EnumerateMetafile(Metafile metafile, PointF destPoint, EnumerateMetafileProc callback, IntPtr callbackData, ImageAttributes imageAttr);
public void EnumerateMetafile(Metafile metafile, PointF destPoint, RectangleF srcRect, GraphicsUnit srcUnit, EnumerateMetafileProc callback);
public void EnumerateMetafile(Metafile metafile, PointF destPoint, RectangleF srcRect, GraphicsUnit srcUnit, EnumerateMetafileProc callback, IntPtr callbackData);
public void EnumerateMetafile(Metafile metafile, PointF destPoint, RectangleF srcRect, GraphicsUnit unit, EnumerateMetafileProc callback, IntPtr callbackData, ImageAttributes imageAttr);
public void EnumerateMetafile(Metafile metafile, PointF[] destPoints, EnumerateMetafileProc callback);
public void EnumerateMetafile(Metafile metafile, PointF[] destPoints, EnumerateMetafileProc callback, IntPtr callbackData);
public void EnumerateMetafile(Metafile metafile, PointF[] destPoints, EnumerateMetafileProc callback, IntPtr callbackData, ImageAttributes imageAttr);
public void EnumerateMetafile(Metafile metafile, PointF[] destPoints, RectangleF srcRect, GraphicsUnit srcUnit, EnumerateMetafileProc callback);
public void EnumerateMetafile(Metafile metafile, PointF[] destPoints, RectangleF srcRect, GraphicsUnit srcUnit, EnumerateMetafileProc callback, IntPtr callbackData);
public void EnumerateMetafile(Metafile metafile, PointF[] destPoints, RectangleF srcRect, GraphicsUnit unit, EnumerateMetafileProc callback, IntPtr callbackData, ImageAttributes imageAttr);
public void EnumerateMetafile(Metafile metafile, Rectangle destRect, EnumerateMetafileProc callback);
public void EnumerateMetafile(Metafile metafile, Rectangle destRect, EnumerateMetafileProc callback, IntPtr callbackData);
public void EnumerateMetafile(Metafile metafile, Rectangle destRect, EnumerateMetafileProc callback, IntPtr callbackData, ImageAttributes imageAttr);
public void EnumerateMetafile(Metafile metafile, Rectangle destRect, Rectangle srcRect, GraphicsUnit srcUnit, EnumerateMetafileProc callback);
public void EnumerateMetafile(Metafile metafile, Rectangle destRect, Rectangle srcRect, GraphicsUnit srcUnit, EnumerateMetafileProc callback, IntPtr callbackData);
public void EnumerateMetafile(Metafile metafile, Rectangle destRect, Rectangle srcRect, GraphicsUnit unit, EnumerateMetafileProc callback, IntPtr callbackData, ImageAttributes imageAttr);
public void EnumerateMetafile(Metafile metafile, RectangleF destRect, EnumerateMetafileProc callback);
public void EnumerateMetafile(Metafile metafile, RectangleF destRect, EnumerateMetafileProc callback, IntPtr callbackData);
public void EnumerateMetafile(Metafile metafile, RectangleF destRect, EnumerateMetafileProc callback, IntPtr callbackData, ImageAttributes imageAttr);
public void EnumerateMetafile(Metafile metafile, RectangleF destRect, RectangleF srcRect, GraphicsUnit srcUnit, EnumerateMetafileProc callback);
public void EnumerateMetafile(Metafile metafile, RectangleF destRect, RectangleF srcRect, GraphicsUnit srcUnit, EnumerateMetafileProc callback, IntPtr callbackData);
public void EnumerateMetafile(Metafile metafile, RectangleF destRect, RectangleF srcRect, GraphicsUnit unit, EnumerateMetafileProc callback, IntPtr callbackData, ImageAttributes imageAttr);
public virtual bool Equals(object obj);
public void ExcludeClip(Rectangle rect);
public void ExcludeClip(Region region);
public void FillClosedCurve(Brush brush, Point[] points);
public void FillClosedCurve(Brush brush, Point[] points, FillMode fillmode);
public void FillClosedCurve(Brush brush, Point[] points, FillMode fillmode, float tension);
public void FillClosedCurve(Brush brush, PointF[] points);
public void FillClosedCurve(Brush brush, PointF[] points, FillMode fillmode);
public void FillClosedCurve(Brush brush, PointF[] points, FillMode fillmode, float tension);
public void FillEllipse(Brush brush, int x, int y, int cx, int cy);
public void FillEllipse(Brush brush, Rectangle rc);
public void FillEllipse(Brush brush, RectangleF rect);
public void FillEllipse(Brush brush, float x, float y, float width, float height);
public void FillPath(Brush brush, GraphicsPath path);
public void FillPie(Brush brush, int x, int y, int width, int height, int startAngle, int sweepAngle);
public void FillPie(Brush brush, Rectangle rect, float startAngle, float sweepAngle);
public void FillPie(Brush brush, float x, float y, float width, float height, float startAngle, float sweepAngle);
public void FillPolygon(Brush brush, Point[] points);
public void FillPolygon(Brush brush, Point[] points, FillMode fillMode);
public void FillPolygon(Brush brush, PointF[] points);
public void FillPolygon(Brush brush, PointF[] points, FillMode fillMode);
public void FillRectangle(Brush brush, int x, int y, int cx, int cy);
public void FillRectangle(Brush brush, Rectangle rc);
public void FillRectangle(Brush brush, RectangleF rect);
public void FillRectangle(Brush brush, float x, float y, float width, float height);
public void FillRectangles(Brush brush, Rectangle[] rects);
public void FillRectangles(Brush brush, RectangleF[] rects);
public void FillRegion(Brush brush, Region region);
protected override void Finalize();
public void Flush();
public void Flush(FlushIntention intention);
public static Graphics FromHdc(IntPtr hdc);
public static Graphics FromHdc(IntPtr hdc, IntPtr hdevice);
public static Graphics FromHdcInternal(IntPtr hdc);
public static Graphics FromHow(IntPtr how, bool fFree);
public static Graphics FromHwnd(IntPtr hwnd);
public static Graphics FromHwndInternal(IntPtr hwnd);
public static Graphics FromImage(Image img);
public static IntPtr GetHalftonePalette();
public virtual int GetHashCode();
public IntPtr GetHdc();
public object GetLifetimeService();
public Color GetNearestColor(Color color);
public Type GetType();
public object InitializeLifetimeService();
public void IntersectClip(Rectangle rect);
public void IntersectClip(RectangleF rect);
public void IntersectClip(Region region);
public bool IsVisible(int x, int y);
public bool IsVisible(int x, int y, int width, int height);
public bool IsVisible(Point point);
public bool IsVisible(PointF point);
public bool IsVisible(Rectangle rect);
public bool IsVisible(RectangleF rect);
public bool IsVisible(float x, float y);
public bool IsVisible(float x, float y, float width, float height);
public Region[] MeasureCharacterRanges(string text, Font font, RectangleF layoutRect, StringFormat stringFormat);
public SizeF MeasureString(string text, Font font);
public SizeF MeasureString(string text, Font font, int width);
public SizeF MeasureString(string text, Font font, int width, StringFormat format);
public SizeF MeasureString(string text, Font font, PointF origin, StringFormat stringFormat);
public SizeF MeasureString(string text, Font font, SizeF layoutArea);
public SizeF MeasureString(string text, Font font, SizeF layoutArea, StringFormat stringFormat);
public SizeF MeasureString(string text, Font font, SizeF layoutArea, StringFormat stringFormat, ref int charactersFitted, ref int linesFilled);
protected object MemberwiseClone();
public void MultiplyTransform(Matrix matrix);
public void MultiplyTransform(Matrix matrix, MatrixOrder order);
public void ReleaseHdc(IntPtr hdc);
public void ReleaseHdcInternal(IntPtr hdc);
public void ResetClip();
public void ResetTransform();
public void Restore(GraphicsState gstate);
public void RotateTransform(float angle);
public void RotateTransform(float angle, MatrixOrder order);
public GraphicsState Save();
public void ScaleTransform(float sx, float sy);
public void ScaleTransform(float sx, float sy, MatrixOrder order);
public void SetClip(Graphics g);
public void SetClip(Graphics g, CombineMode combineMode);
public void SetClip(GraphicsPath path);
public void SetClip(GraphicsPath path, CombineMode combineMode);
public void SetClip(Rectangle rect);
public void SetClip(Rectangle rect, CombineMode combineMode);
public void SetClip(RectangleF rect);
public void SetClip(RectangleF rect, CombineMode combineMode);
public void SetClip(Region region, CombineMode combineMode);
public virtual string ToString();
public void TransformPoints(CoordinateSpace destSpace, CoordinateSpace srcSpace, Point[] pts);
public void TransformPoints(CoordinateSpace destSpace, CoordinateSpace srcSpace, PointF[] pts);
public void TranslateClip(int dx, int dy);
public void TranslateClip(float dx, float dy);
public void TranslateTransform(float dx, float dy);
public void TranslateTransform(float dx, float dy, MatrixOrder order);

Property
public Region Clip {get; set;}
public RectangleF ClipBounds {get;}
public CompositingMode CompositingMode {get; set;}
public CompositingQuality CompositingQuality {get; set;}
public float DpiX {get;}
public float DpiY {get;}
public InterpolationMode InterpolationMode {get; set;}
public bool IsClipEmpty {get;}
public bool IsVisibleClipEmpty {get;}
public float PageScale {get; set;}
public GraphicsUnit PageUnit {get; set;}
public PixelOffsetMode PixelOffsetMode {get; set;}
public Point RenderingOrigin {get; set;}
public SmoothingMode SmoothingMode {get; set;}
public int TextContrast {get; set;}
public TextRenderingHint TextRenderingHint {get; set;}
public Matrix Transform {get; set;}
public RectangleF VisibleClipBounds {get;}

System.Drawing.ContentAlignment

Module:System.Drawing.dll

Hierarchy
Object
ValueType
Enum
ContentAlignment

Type declaration

[C#] public enum ContentAlignment;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const ContentAlignment BottomCenter = 512;
public const ContentAlignment BottomLeft = 256;
public const ContentAlignment BottomRight = 1024;
public const ContentAlignment MiddleCenter = 32;
public const ContentAlignment MiddleLeft = 16;
public const ContentAlignment MiddleRight = 64;
public const ContentAlignment TopCenter = 2;
public const ContentAlignment TopLeft = 1;
public const ContentAlignment TopRight = 4;
public int value__;

System.Drawing.Color

Module:System.Drawing.dll

Hierarchy
Object
ValueType
Color

Type declaration

[C#] public struct Color : ValueType;

Method
public override bool Equals(object obj);
protected override void Finalize();
public static Color FromArgb(int val);
public static Color FromArgb(int alpha, Color baseColor);
public static Color FromArgb(int red, int green, int blue);
public static Color FromArgb(int alpha, int red, int green, int blue);
public static Color FromKnownColor(KnownColor color);
public static Color FromName(string name);
public static Color FromSysIcv(int icv);
public float GetBrightness();
public override int GetHashCode();
public float GetHue();
public float GetSaturation();
public Type GetType();
protected object MemberwiseClone();
public static bool op_Equality(Color left, Color right);
public static bool op_Inequality(Color left, Color right);
public int ToArgb();
public KnownColor ToKnownColor();
public virtual string ToString();

Property
public byte A {get;}
public static Color AliceBlue {get;}
public static Color AntiqueWhite {get;}
public static Color Aqua {get;}
public static Color Aquamarine {get;}
public static Color Azure {get;}
public byte B {get;}
public static Color Beige {get;}
public static Color Bisque {get;}
public static Color Black {get;}
public static Color BlanchedAlmond {get;}
public static Color Blue {get;}
public static Color BlueViolet {get;}
public static Color Brown {get;}
public static Color BurlyWood {get;}
public static Color CadetBlue {get;}
public static Color Chartreuse {get;}
public static Color Chocolate {get;}
public static Color Coral {get;}
public static Color CornflowerBlue {get;}
public static Color Cornsilk {get;}
public static Color Crimson {get;}
public static Color Cyan {get;}
public static Color DarkBlue {get;}
public static Color DarkCyan {get;}
public static Color DarkGoldenrod {get;}
public static Color DarkGray {get;}
public static Color DarkGreen {get;}
public static Color DarkKhaki {get;}
public static Color DarkMagenta {get;}
public static Color DarkOliveGreen {get;}
public static Color DarkOrange {get;}
public static Color DarkOrchid {get;}
public static Color DarkRed {get;}
public static Color DarkSalmon {get;}
public static Color DarkSeaGreen {get;}
public static Color DarkSlateBlue {get;}
public static Color DarkSlateGray {get;}
public static Color DarkTurquoise {get;}
public static Color DarkViolet {get;}
public static Color DeepPink {get;}
public static Color DeepSkyBlue {get;}
public static Color DimGray {get;}
public static Color DodgerBlue {get;}
public static Color Firebrick {get;}
public static Color FloralWhite {get;}
public static Color ForestGreen {get;}
public static Color Fuchsia {get;}
public byte G {get;}
public static Color Gainsboro {get;}
public static Color GhostWhite {get;}
public static Color Gold {get;}
public static Color Goldenrod {get;}
public static Color Gray {get;}
public static Color Green {get;}
public static Color GreenYellow {get;}
public static Color Honeydew {get;}
public static Color HotPink {get;}
public static Color IndianRed {get;}
public static Color Indigo {get;}
public bool IsEmpty {get;}
public bool IsKnownColor {get;}
public bool IsNamedColor {get;}
public bool IsSystemColor {get;}
public static Color Ivory {get;}
public static Color Khaki {get;}
public static Color Lavender {get;}
public static Color LavenderBlush {get;}
public static Color LawnGreen {get;}
public static Color LemonChiffon {get;}
public static Color LightBlue {get;}
public static Color LightCoral {get;}
public static Color LightCyan {get;}
public static Color LightGoldenrodYellow {get;}
public static Color LightGray {get;}
public static Color LightGreen {get;}
public static Color LightPink {get;}
public static Color LightSalmon {get;}
public static Color LightSeaGreen {get;}
public static Color LightSkyBlue {get;}
public static Color LightSlateGray {get;}
public static Color LightSteelBlue {get;}
public static Color LightYellow {get;}
public static Color Lime {get;}
public static Color LimeGreen {get;}
public static Color Linen {get;}
public static Color Magenta {get;}
public static Color Maroon {get;}
public static Color MediumAquamarine {get;}
public static Color MediumBlue {get;}
public static Color MediumOrchid {get;}
public static Color MediumPurple {get;}
public static Color MediumSeaGreen {get;}
public static Color MediumSlateBlue {get;}
public static Color MediumSpringGreen {get;}
public static Color MediumTurquoise {get;}
public static Color MediumVioletRed {get;}
public static Color MidnightBlue {get;}
public static Color MintCream {get;}
public static Color MistyRose {get;}
public static Color Moccasin {get;}
public string Name {get;}
public static Color NavajoWhite {get;}
public static Color Navy {get;}
public static Color OldLace {get;}
public static Color Olive {get;}
public static Color OliveDrab {get;}
public static Color Orange {get;}
public static Color OrangeRed {get;}
public static Color Orchid {get;}
public static Color PaleGoldenrod {get;}
public static Color PaleGreen {get;}
public static Color PaleTurquoise {get;}
public static Color PaleVioletRed {get;}
public static Color PapayaWhip {get;}
public static Color PeachPuff {get;}
public static Color Peru {get;}
public static Color Pink {get;}
public static Color Plum {get;}
public static Color PowderBlue {get;}
public static Color Purple {get;}
public byte R {get;}
public static Color Red {get;}
public static Color RosyBrown {get;}
public static Color RoyalBlue {get;}
public static Color SaddleBrown {get;}
public static Color Salmon {get;}
public static Color SandyBrown {get;}
public static Color SeaGreen {get;}
public static Color SeaShell {get;}
public static Color Sienna {get;}
public static Color Silver {get;}
public static Color SkyBlue {get;}
public static Color SlateBlue {get;}
public static Color SlateGray {get;}
public static Color Snow {get;}
public static Color SpringGreen {get;}
public static Color SteelBlue {get;}
public static Color Tan {get;}
public static Color Teal {get;}
public static Color Thistle {get;}
public static Color Tomato {get;}
public static Color Transparent {get;}
public static Color Turquoise {get;}
public static Color Violet {get;}
public static Color Wheat {get;}
public static Color White {get;}
public static Color WhiteSmoke {get;}
public static Color Yellow {get;}
public static Color YellowGreen {get;}

Field
public readonly static Color Empty;

System.Drawing.SolidBrush

Module:System.Drawing.dll

Hierarchy
Object
MarshalByRefObject
Brush
SolidBrush

Type declaration

[C#] public sealed class SolidBrush : Brush;

Constructor
public SolidBrush(Color color);

Method
public override object Clone();
public ObjRef CreateObjRef(Type requestedType);
public void Dispose();
protected virtual void Dispose(bool disposing);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public object GetLifetimeService();
public Type GetType();
public object InitializeLifetimeService();
protected object MemberwiseClone();
public virtual string ToString();

Property
public Color Color {get; set;}

System.Drawing.Brush

Module:System.Drawing.dll

Hierarchy
Object
MarshalByRefObject
Brush

Type declaration

[C#] public abstract class Brush : MarshalByRefObject;

Method
public abstract object Clone();
public ObjRef CreateObjRef(Type requestedType);
public void Dispose();
protected virtual void Dispose(bool disposing);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public object GetLifetimeService();
public Type GetType();
public object InitializeLifetimeService();
protected object MemberwiseClone();
public virtual string ToString();

System.Drawing.Bitmap

Module:System.Drawing.dll

Hierarchy
Object
MarshalByRefObject
Image
Bitmap

Type declaration

[C#] public sealed class Bitmap : Image;

Constructor
public Bitmap(Image image);
public Bitmap(Image original, int width, int height);
public Bitmap(Image original, Size newSize);
public Bitmap(int width, int height);
public Bitmap(int width, int height, Graphics g);
public Bitmap(int width, int height, int stride, PixelFormat format, IntPtr scan0);
public Bitmap(int width, int height, PixelFormat format);
public Bitmap(Stream stream);
public Bitmap(Stream stream, bool useIcm);
public Bitmap(string filename);
public Bitmap(string filename, bool useIcm);
public Bitmap(Type type, string resource);

Method
public object Clone();
public Bitmap Clone(Rectangle rect, PixelFormat format);
public Bitmap Clone(RectangleF rect, PixelFormat format);
public ObjRef CreateObjRef(Type requestedType);
public virtual void Dispose();
protected virtual void Dispose(bool disposing);
public virtual bool Equals(object obj);
protected override void Finalize();
public static Bitmap FromHicon(IntPtr hicon);
public static Bitmap FromResource(IntPtr hinstance, string bitmapName);
public RectangleF GetBounds(ref GraphicsUnit pageUnit);
public EncoderParameters GetEncoderParameterList(Guid encoder);
public int GetFrameCount(FrameDimension dimension);
public virtual int GetHashCode();
public IntPtr GetHbitmap();
public IntPtr GetHbitmap(Color background);
public IntPtr GetHicon();
public object GetLifetimeService();
public Color GetPixel(int x, int y);
public PropertyItem GetPropertyItem(int propid);
public Image GetThumbnailImage(int thumbWidth, int thumbHeight, GetThumbnailImageAbort callback, IntPtr callbackData);
public Type GetType();
public object InitializeLifetimeService();
public BitmapData LockBits(Rectangle rect, ImageLockMode flags, PixelFormat format);
public void MakeTransparent();
public void MakeTransparent(Color transparentColor);
protected object MemberwiseClone();
public void RemovePropertyItem(int propid);
public void RotateFlip(RotateFlipType rotateFlipType);
public void Save(Stream stream, ImageCodecInfo encoder, EncoderParameters encoderParams);
public void Save(Stream stream, ImageFormat format);
public void Save(string filename);
public void Save(string filename, ImageCodecInfo encoder, EncoderParameters encoderParams);
public void Save(string filename, ImageFormat format);
public void SaveAdd(EncoderParameters encoderParams);
public void SaveAdd(Image image, EncoderParameters encoderParams);
public int SelectActiveFrame(FrameDimension dimension, int frameIndex);
public void SetPixel(int x, int y, Color color);
public void SetPropertyItem(PropertyItem propitem);
public void SetResolution(float xDpi, float yDpi);
public virtual string ToString();
public void UnlockBits(BitmapData bitmapdata);

Property
public int Flags {get;}
public Guid[] FrameDimensionsList {get;}
public int Height {get;}
public float HorizontalResolution {get;}
public ColorPalette Palette {get; set;}
public SizeF PhysicalDimension {get;}
public PixelFormat PixelFormat {get;}
public int[] PropertyIdList {get;}
public PropertyItem[] PropertyItems {get;}
public ImageFormat RawFormat {get;}
public Size Size {get;}
public float VerticalResolution {get;}
public int Width {get;}

System.Drawing.Image

Module:System.Drawing.dll

Hierarchy
Object
MarshalByRefObject
Image

Type declaration

[C#] public abstract class Image : MarshalByRefObject;

Method
public virtual object Clone();
public ObjRef CreateObjRef(Type requestedType);
public virtual void Dispose();
protected virtual void Dispose(bool disposing);
public virtual bool Equals(object obj);
protected override void Finalize();
public static Image FromFile(string filename);
public static Image FromFile(string filename, bool useEmbeddedColorManagement);
public static Bitmap FromHbitmap(IntPtr hbitmap);
public static Bitmap FromHbitmap(IntPtr hbitmap, IntPtr hpalette);
public static Image FromStream(Stream stream);
public static Image FromStream(Stream stream, bool useEmbeddedColorManagement);
public RectangleF GetBounds(ref GraphicsUnit pageUnit);
public EncoderParameters GetEncoderParameterList(Guid encoder);
public int GetFrameCount(FrameDimension dimension);
public virtual int GetHashCode();
public static IntPtr GetHowFromImage(Image img);
public object GetLifetimeService();
public static int GetPixelFormatSize(PixelFormat pixfmt);
public PropertyItem GetPropertyItem(int propid);
public Image GetThumbnailImage(int thumbWidth, int thumbHeight, GetThumbnailImageAbort callback, IntPtr callbackData);
public Type GetType();
public object InitializeLifetimeService();
public static bool IsAlphaPixelFormat(PixelFormat pixfmt);
public static bool IsCanonicalPixelFormat(PixelFormat pixfmt);
public static bool IsExtendedPixelFormat(PixelFormat pixfmt);
protected object MemberwiseClone();
public void RemovePropertyItem(int propid);
public void RotateFlip(RotateFlipType rotateFlipType);
public void Save(Stream stream, ImageCodecInfo encoder, EncoderParameters encoderParams);
public void Save(Stream stream, ImageFormat format);
public void Save(string filename);
public void Save(string filename, ImageCodecInfo encoder, EncoderParameters encoderParams);
public void Save(string filename, ImageFormat format);
public void SaveAdd(EncoderParameters encoderParams);
public void SaveAdd(Image image, EncoderParameters encoderParams);
public int SelectActiveFrame(FrameDimension dimension, int frameIndex);
public void SetPropertyItem(PropertyItem propitem);
public virtual string ToString();

Property
public int Flags {get;}
public Guid[] FrameDimensionsList {get;}
public int Height {get;}
public float HorizontalResolution {get;}
public ColorPalette Palette {get; set;}
public SizeF PhysicalDimension {get;}
public PixelFormat PixelFormat {get;}
public int[] PropertyIdList {get;}
public PropertyItem[] PropertyItems {get;}
public ImageFormat RawFormat {get;}
public Size Size {get;}
public float VerticalResolution {get;}
public int Width {get;}

System.Drawing.Imaging.ImageAttributes

Module:System.Drawing.dll

Hierarchy
Object
ImageAttributes

Type declaration

[C#] public sealed class ImageAttributes;

Constructor
public ImageAttributes();

Method
public void ClearBrushRemapTable();
public void ClearColorKey();
public void ClearColorKey(ColorAdjustType type);
public void ClearColorMatrix();
public void ClearColorMatrix(ColorAdjustType type);
public void ClearGamma();
public void ClearGamma(ColorAdjustType type);
public void ClearNoOp();
public void ClearNoOp(ColorAdjustType type);
public void ClearOutputChannel();
public void ClearOutputChannel(ColorAdjustType type);
public void ClearOutputChannelColorProfile();
public void ClearOutputChannelColorProfile(ColorAdjustType type);
public void ClearRemapTable();
public void ClearRemapTable(ColorAdjustType type);
public void ClearThreshold();
public void ClearThreshold(ColorAdjustType type);
public virtual object Clone();
public virtual void Dispose();
public virtual bool Equals(object obj);
protected override void Finalize();
public void GetAdjustedPalette(ColorPalette palette, ColorAdjustType type);
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public void SetBrushRemapTable(ColorMap[] map);
public void SetColorKey(Color colorLow, Color colorHigh);
public void SetColorKey(Color colorLow, Color colorHigh, ColorAdjustType type);
public void SetColorMatrices(ColorMatrix newColorMatrix, ColorMatrix grayMatrix);
public void SetColorMatrices(ColorMatrix newColorMatrix, ColorMatrix grayMatrix, ColorMatrixFlag flags);
public void SetColorMatrices(ColorMatrix newColorMatrix, ColorMatrix grayMatrix, ColorMatrixFlag mode, ColorAdjustType type);
public void SetColorMatrix(ColorMatrix newColorMatrix);
public void SetColorMatrix(ColorMatrix newColorMatrix, ColorMatrixFlag flags);
public void SetColorMatrix(ColorMatrix newColorMatrix, ColorMatrixFlag mode, ColorAdjustType type);
public void SetGamma(float gamma);
public void SetGamma(float gamma, ColorAdjustType type);
public void SetNoOp();
public void SetNoOp(ColorAdjustType type);
public void SetOutputChannel(ColorChannelFlag flags);
public void SetOutputChannel(ColorChannelFlag flags, ColorAdjustType type);
public void SetOutputChannelColorProfile(string colorProfileFilename);
public void SetOutputChannelColorProfile(string colorProfileFilename, ColorAdjustType type);
public void SetRemapTable(ColorMap[] map);
public void SetRemapTable(ColorMap[] map, ColorAdjustType type);
public void SetThreshold(float threshold);
public void SetThreshold(float threshold, ColorAdjustType type);
public void SetWrapMode(WrapMode mode);
public void SetWrapMode(WrapMode mode, Color color);
public void SetWrapMode(WrapMode mode, Color color, bool clamp);
public virtual string ToString();

System.Net.Sockets.IrDAListener

Module:System.Net.IrDA.dll

Hierarchy
Object
IrDAListener

Type declaration

[C#] public class IrDAListener;

Constructor
public IrDAListener(IrDAEndPoint ep);
public IrDAListener(string service);

Method
public IrDAClient AcceptIrDAClient();
public Socket AcceptSocket();
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public bool Pending();
public void Start();
public void Stop();
public virtual string ToString();

Property
public IrDAEndPoint LocalEndpoint {get;}

System.Net.Sockets.IrDAClient

Module:System.Net.IrDA.dll

Hierarchy
Object
IrDAClient

Type declaration

[C#] public class IrDAClient;

Constructor
public IrDAClient();
public IrDAClient(IrDAEndPoint remoteEP);
public IrDAClient(string service);

Method
public void Close();
public void Connect(IrDAEndPoint remoteEP);
public void Connect(string service);
public IrDADeviceInfo[] DiscoverDevices(int maxDevices);
public static IrDADeviceInfo[] DiscoverDevices(int maxDevices, Socket irdaSocket);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public static string GetRemoteMachineName(Socket s);
public Stream GetStream();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public string RemoteMachineName {get;}

System.Net.Sockets.IrDADeviceInfo

Module:System.Net.IrDA.dll

Hierarchy
Object
IrDADeviceInfo

Type declaration

[C#] public class IrDADeviceInfo;

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public IrDACharacterSet CharacterSet {get;}
public byte[] DeviceID {get;}
public string DeviceName {get;}
public IrDAHints Hints {get;}

System.Net.Sockets.IrDACharacterSet

Module:System.Net.IrDA.dll

Hierarchy
Object
ValueType
Enum
IrDACharacterSet

Type declaration

[C#] public enum IrDACharacterSet;

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();

Field
public const IrDACharacterSet ASCII = 0;
public const IrDACharacterSet ISO8859Arabic = 6;
public const IrDACharacterSet ISO8859Cyrillic = 5;
public const IrDACharacterSet ISO8859Greek = 7;
public const IrDACharacterSet ISO8859Hebrew = 8;
public const IrDACharacterSet ISO8859Latin1 = 1;
public const IrDACharacterSet ISO8859Latin2 = 2;
public const IrDACharacterSet ISO8859Latin3 = 3;
public const IrDACharacterSet ISO8859Latin4 = 4;
public const IrDACharacterSet ISO8859Latin5 = 9;
public const IrDACharacterSet Unicode = 10;
public int value__;

System.Net.Sockets.IrDAHints

Module:System.Net.IrDA.dll

Hierarchy
Object
ValueType
Enum
IrDAHints

Type declaration

[C#] public enum IrDAHints;

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();

Field
public const IrDAHints Computer = 4;
public const IrDAHints Fax = 32;
public const IrDAHints FileServer = 512;
public const IrDAHints LanAccess = 64;
public const IrDAHints Modem = 16;
public const IrDAHints None = 0;
public const IrDAHints PdaAndPalmtop = 2;
public const IrDAHints PnP = 1;
public const IrDAHints Printer = 8;
public const IrDAHints Telephony = 256;
public int value__;

System.Net.Sockets.NetworkStream

Module:System.dll

Hierarchy
Object
MarshalByRefObject
Stream
NetworkStream : IDisposable

Type declaration

[C#] public class NetworkStream : Stream, IDisposable;

Constructor
public NetworkStream(Socket socket);
public NetworkStream(Socket socket, bool ownsSocket);
public NetworkStream(Socket socket, FileAccess access);
public NetworkStream(Socket socket, FileAccess access, bool ownsSocket);

Method
public override IAsyncResult BeginRead(byte[] buffer, int offset, int size, AsyncCallback callback, object state);
public override IAsyncResult BeginWrite(byte[] buffer, int offset, int size, AsyncCallback callback, object state);
public override void Close();
public ObjRef CreateObjRef(Type requestedType);
protected virtual WaitHandle CreateWaitHandle();
protected virtual void Dispose(bool disposing);
public override int EndRead(IAsyncResult asyncResult);
public override void EndWrite(IAsyncResult asyncResult);
public virtual bool Equals(object obj);
protected override void Finalize();
public override void Flush();
public virtual int GetHashCode();
public object GetLifetimeService();
public Type GetType();
public object InitializeLifetimeService();
protected object MemberwiseClone();
public override int Read(byte[] buffer, int offset, int size);
public virtual int ReadByte();
public override long Seek(long offset, SeekOrigin origin);
public override void SetLength(long value);
public virtual string ToString();
public override void Write(byte[] buffer, int offset, int size);
public virtual void WriteByte(byte value);

Property
public override bool CanRead {get;}
public override bool CanSeek {get;}
public override bool CanWrite {get;}
public virtual bool DataAvailable {get;}
public override long Length {get;}
public override long Position {get; set;}
protected bool Readable {get; set;}
protected Socket Socket {get;}
protected bool Writeable {get; set;}

System.Net.Sockets.UdpClient

Module:System.dll

Hierarchy
Object
UdpClient

Type declaration

[C#] public class UdpClient;

Constructor
public UdpClient();
public UdpClient(AddressFamily family);
public UdpClient(int port);
public UdpClient(int port, AddressFamily family);
public UdpClient(IPEndPoint localEP);
public UdpClient(string hostname, int port);

Method
public void Close();
public void Connect(IPAddress addr, int port);
public void Connect(IPEndPoint endPoint);
public void Connect(string hostname, int port);
public void DropMulticastGroup(IPAddress multicastAddr);
public void DropMulticastGroup(IPAddress multicastAddr, int ifindex);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
public void JoinMulticastGroup(int ifindex, IPAddress multicastAddr);
public void JoinMulticastGroup(IPAddress multicastAddr);
public void JoinMulticastGroup(IPAddress multicastAddr, int timeToLive);
protected object MemberwiseClone();
public byte[] Receive(ref IPEndPoint remoteEP);
public int Send(byte[] dgram, int bytes);
public int Send(byte[] dgram, int bytes, IPEndPoint endPoint);
public int Send(byte[] dgram, int bytes, string hostname, int port);
public virtual string ToString();

Property
protected bool Active {get; set;}
protected Socket Client {get; set;}

System.Net.Sockets.TcpListener

Module:System.dll

Hierarchy
Object
TcpListener

Type declaration

[C#] public class TcpListener;

Constructor
public TcpListener(int port);
public TcpListener(IPAddress localaddr, int port);
public TcpListener(IPEndPoint localEP);

Method
public Socket AcceptSocket();
public TcpClient AcceptTcpClient();
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public bool Pending();
public void Start();
public void Stop();
public virtual string ToString();

Property
protected bool Active {get;}
public EndPoint LocalEndpoint {get;}
protected Socket Server {get;}

System.Net.Sockets.TcpClient

Module:System.dll

Hierarchy
Object
TcpClient : IDisposable

Type declaration

[C#] public class TcpClient: IDisposable;

Constructor
public TcpClient();
public TcpClient(AddressFamily family);
public TcpClient(IPEndPoint localEP);
public TcpClient(string hostname, int port);

Method
public void Close();
public void Connect(IPAddress address, int port);
public void Connect(IPEndPoint remoteEP);
public void Connect(string hostname, int port);
protected virtual void Dispose(bool disposing);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public NetworkStream GetStream();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
protected bool Active {get; set;}
protected Socket Client {get; set;}
public LingerOption LingerState {get; set;}
public bool NoDelay {get; set;}
public int ReceiveBufferSize {get; set;}
public int ReceiveTimeout {get; set;}
public int SendBufferSize {get; set;}
public int SendTimeout {get; set;}

System.Net.Sockets.Socket

Module:System.dll

Hierarchy
Object
Socket : IDisposable

Type declaration

[C#] public class Socket: IDisposable;

Constructor
public Socket(AddressFamily addressFamily, SocketType socketType, ProtocolType protocolType);

Method
public Socket Accept();
public IAsyncResult BeginAccept(AsyncCallback callback, object state);
public IAsyncResult BeginConnect(EndPoint remoteEP, AsyncCallback callback, object state);
public IAsyncResult BeginReceive(byte[] buffer, int offset, int size, SocketFlags socketFlags, AsyncCallback callback, object state);
public IAsyncResult BeginReceiveFrom(byte[] readBuffer, int index, int size, SocketFlags flags, ref EndPoint EP, AsyncCallback callback, object state);
public IAsyncResult BeginSend(byte[] buffer, int offset, int size, SocketFlags socketFlags, AsyncCallback callback, object state);
public IAsyncResult BeginSendTo(byte[] writeBuffer, int index, int size, SocketFlags flags, EndPoint remoteEP, AsyncCallback callback, object state);
public void Bind(EndPoint localEP);
public void Close();
public void Connect(EndPoint remoteEP);
protected virtual void Dispose(bool disposing);
public Socket EndAccept(IAsyncResult asyncResult);
public void EndConnect(IAsyncResult asyncResult);
public int EndReceive(IAsyncResult asyncResult);
public int EndReceiveFrom(IAsyncResult asyncResult, ref EndPoint endPoint);
public int EndSend(IAsyncResult asyncResult);
public int EndSendTo(IAsyncResult asyncResult);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public object GetSocketOption(SocketOptionLevel optionLevel, SocketOptionName optionName);
public void GetSocketOption(SocketOptionLevel optionLevel, SocketOptionName optionName, byte[] optionValue);
public byte[] GetSocketOption(SocketOptionLevel optionLevel, SocketOptionName optionName, int optionLength);
public Type GetType();
public int IOControl(int ioControlCode, byte[] optionInValue, byte[] optionOutValue);
public void Listen(int backlog);
protected object MemberwiseClone();
public bool Poll(int microSeconds, SelectMode mode);
public int Receive(byte[] buffer);
public int Receive(byte[] buffer, int offset, int size, SocketFlags socketFlags);
public int Receive(byte[] buffer, int size, SocketFlags socketFlags);
public int Receive(byte[] buffer, SocketFlags flags);
public int ReceiveFrom(byte[] buffer, ref EndPoint remoteEP);
public int ReceiveFrom(byte[] buffer, int index, int request, SocketFlags flags, ref EndPoint EP);
public int ReceiveFrom(byte[] buffer, int size, SocketFlags socketFlags, ref EndPoint remoteEP);
public int ReceiveFrom(byte[] buffer, SocketFlags socketFlags, ref EndPoint remoteEP);
public static void Select(IList checkRead, IList checkWrite, IList checkError, int microSeconds);
public int Send(byte[] buffer);
public int Send(byte[] buffer, int offset, int size, SocketFlags socketFlags);
public int Send(byte[] buffer, int size, SocketFlags socketFlags);
public int Send(byte[] buffer, SocketFlags flags);
public int SendTo(byte[] buffer, EndPoint remoteEP);
public int SendTo(byte[] buffer, int index, int size, SocketFlags flags, EndPoint remoteEP);
public int SendTo(byte[] buffer, int size, SocketFlags socketFlags, EndPoint remoteEP);
public int SendTo(byte[] buffer, SocketFlags flags, EndPoint remoteEP);
public void SetSocketOption(SocketOptionLevel optionLevel, SocketOptionName optionName, byte[] optionValue);
public void SetSocketOption(SocketOptionLevel optionLevel, SocketOptionName optionName, int optionValue);
public void SetSocketOption(SocketOptionLevel optionLevel, SocketOptionName optionName, object optionValue);
public void Shutdown(SocketShutdown how);
public virtual string ToString();

Property
public AddressFamily AddressFamily {get;}
public int Available {get;}
public bool Blocking {get; set;}
public bool Connected {get;}
public IntPtr Handle {get;}
public EndPoint LocalEndPoint {get;}
public ProtocolType ProtocolType {get;}
public EndPoint RemoteEndPoint {get;}
public SocketType SocketType {get;}
public static bool SupportsIPv4 {get;}
public static bool SupportsIPv6 {get;}

System.Net.Sockets.SocketShutdown

Module:System.dll

Hierarchy
Object
ValueType
Enum
SocketShutdown

Type declaration

[C#] public enum SocketShutdown;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const SocketShutdown Both = 2;
public const SocketShutdown Receive = 0;
public const SocketShutdown Send = 1;
public int value__;

System.Net.Sockets.SelectMode

Module:System.dll

Hierarchy
Object
ValueType
Enum
SelectMode

Type declaration

[C#] public enum SelectMode;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const SelectMode SelectError = 2;
public const SelectMode SelectRead = 0;
public const SelectMode SelectWrite = 1;
public int value__;

System.Net.Sockets.MulticastOption

Module:System.dll

Hierarchy
Object
MulticastOption

Type declaration

[C#] public class MulticastOption;

Constructor
public MulticastOption(IPAddress group);
public MulticastOption(IPAddress group, IPAddress mcint);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public IPAddress Group {get; set;}
public IPAddress LocalAddress {get; set;}

System.Net.Sockets.LingerOption

Module:System.dll

Hierarchy
Object
LingerOption

Type declaration

[C#] public class LingerOption;

Constructor
public LingerOption(bool enable, int seconds);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public bool Enabled {get; set;}
public int LingerTime {get; set;}

System.Net.Sockets.SocketType

Module:System.dll

Hierarchy
Object
ValueType
Enum
SocketType

Type declaration

[C#] public enum SocketType;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const SocketType Dgram = 2;
public const SocketType Raw = 3;
public const SocketType Rdm = 4;
public const SocketType Seqpacket = 5;
public const SocketType Stream = 1;
public const SocketType Unknown = -1;
public int value__;

System.Net.Sockets.SocketOptionName

Module:System.dll

Hierarchy
Object
ValueType
Enum
SocketOptionName

Type declaration

[C#] public enum SocketOptionName;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const SocketOptionName AcceptConnection = 2;
public const SocketOptionName AddMembership = 12;
public const SocketOptionName AddSourceMembership = 15;
public const SocketOptionName BlockSource = 17;
public const SocketOptionName Broadcast = 32;
public const SocketOptionName BsdUrgent = 2;
public const SocketOptionName ChecksumCoverage = 20;
public const SocketOptionName Debug = 1;
public const SocketOptionName DontFragment = 14;
public const SocketOptionName DontLinger = -129;
public const SocketOptionName DontRoute = 16;
public const SocketOptionName DropMembership = 13;
public const SocketOptionName DropSourceMembership = 16;
public const SocketOptionName Error = 4103;
public const SocketOptionName ExclusiveAddressUse = -5;
public const SocketOptionName Expedited = 2;
public const SocketOptionName HeaderIncluded = 2;
public const SocketOptionName IPOptions = 1;
public const SocketOptionName IpTimeToLive = 4;
public const SocketOptionName KeepAlive = 8;
public const SocketOptionName Linger = 128;
public const SocketOptionName MaxConnections = 2147483647;
public const SocketOptionName MulticastInterface = 9;
public const SocketOptionName MulticastLoopback = 11;
public const SocketOptionName MulticastTimeToLive = 10;
public const SocketOptionName NoChecksum = 1;
public const SocketOptionName NoDelay = 1;
public const SocketOptionName OutOfBandInline = 256;
public const SocketOptionName PacketInformation = 19;
public const SocketOptionName ReceiveBuffer = 4098;
public const SocketOptionName ReceiveLowWater = 4100;
public const SocketOptionName ReceiveTimeout = 4102;
public const SocketOptionName ReuseAddress = 4;
public const SocketOptionName SendBuffer = 4097;
public const SocketOptionName SendLowWater = 4099;
public const SocketOptionName SendTimeout = 4101;
public const SocketOptionName Type = 4104;
public const SocketOptionName TypeOfService = 3;
public const SocketOptionName UnblockSource = 18;
public const SocketOptionName UseLoopback = 64;
public int value__;

System.Net.Sockets.SocketOptionLevel

Module:System.dll

Hierarchy
Object
ValueType
Enum
SocketOptionLevel

Type declaration

[C#] public enum SocketOptionLevel;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const SocketOptionLevel IP = 0;
public const SocketOptionLevel IPv6 = 41;
public const SocketOptionLevel Socket = 65535;
public const SocketOptionLevel Tcp = 6;
public const SocketOptionLevel Udp = 17;
public int value__;

System.Net.Sockets.ProtocolFamily

Module:System.dll

Hierarchy
Object
ValueType
Enum
ProtocolFamily

Type declaration

[C#] public enum ProtocolFamily;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const ProtocolFamily AppleTalk = 16;
public const ProtocolFamily Atm = 22;
public const ProtocolFamily Banyan = 21;
public const ProtocolFamily Ccitt = 10;
public const ProtocolFamily Chaos = 5;
public const ProtocolFamily Cluster = 24;
public const ProtocolFamily DataKit = 9;
public const ProtocolFamily DataLink = 13;
public const ProtocolFamily DecNet = 12;
public const ProtocolFamily Ecma = 8;
public const ProtocolFamily FireFox = 19;
public const ProtocolFamily HyperChannel = 15;
public const ProtocolFamily Ieee12844 = 25;
public const ProtocolFamily ImpLink = 3;
public const ProtocolFamily InterNetwork = 2;
public const ProtocolFamily InterNetworkV6 = 23;
public const ProtocolFamily Ipx = 6;
public const ProtocolFamily Irda = 26;
public const ProtocolFamily Iso = 7;
public const ProtocolFamily Lat = 14;
public const ProtocolFamily Max = 29;
public const ProtocolFamily NetBios = 17;
public const ProtocolFamily NetworkDesigners = 28;
public const ProtocolFamily NS = 6;
public const ProtocolFamily Osi = 7;
public const ProtocolFamily Pup = 4;
public const ProtocolFamily Sna = 11;
public const ProtocolFamily Unix = 1;
public const ProtocolFamily Unknown = -1;
public const ProtocolFamily Unspecified = 0;
public int value__;
public const ProtocolFamily VoiceView = 18;

System.Net.Sockets.ProtocolType

Module:System.dll

Hierarchy
Object
ValueType
Enum
ProtocolType

Type declaration

[C#] public enum ProtocolType;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const ProtocolType Ggp = 3;
public const ProtocolType Icmp = 1;
public const ProtocolType Idp = 22;
public const ProtocolType Igmp = 2;
public const ProtocolType IP = 0;
public const ProtocolType IPv6 = 41;
public const ProtocolType Ipx = 1000;
public const ProtocolType ND = 77;
public const ProtocolType Pup = 12;
public const ProtocolType Raw = 255;
public const ProtocolType Spx = 1256;
public const ProtocolType SpxII = 1257;
public const ProtocolType Tcp = 6;
public const ProtocolType Udp = 17;
public const ProtocolType Unknown = -1;
public const ProtocolType Unspecified = 0;
public int value__;

System.Net.Sockets.AddressFamily

Module:System.dll

Hierarchy
Object
ValueType
Enum
AddressFamily

Type declaration

[C#] public enum AddressFamily;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const AddressFamily AppleTalk = 16;
public const AddressFamily Atm = 22;
public const AddressFamily Banyan = 21;
public const AddressFamily Ccitt = 10;
public const AddressFamily Chaos = 5;
public const AddressFamily Cluster = 24;
public const AddressFamily DataKit = 9;
public const AddressFamily DataLink = 13;
public const AddressFamily DecNet = 12;
public const AddressFamily Ecma = 8;
public const AddressFamily FireFox = 19;
public const AddressFamily HyperChannel = 15;
public const AddressFamily Ieee12844 = 25;
public const AddressFamily ImpLink = 3;
public const AddressFamily InterNetwork = 2;
public const AddressFamily InterNetworkV6 = 23;
public const AddressFamily Ipx = 6;
public const AddressFamily Irda = 26;
public const AddressFamily Iso = 7;
public const AddressFamily Lat = 14;
public const AddressFamily Max = 29;
public const AddressFamily NetBios = 17;
public const AddressFamily NetworkDesigners = 28;
public const AddressFamily NS = 6;
public const AddressFamily Osi = 7;
public const AddressFamily Pup = 4;
public const AddressFamily Sna = 11;
public const AddressFamily Unix = 1;
public const AddressFamily Unknown = -1;
public const AddressFamily Unspecified = 0;
public int value__;
public const AddressFamily VoiceView = 18;

System.Net.Sockets.SocketFlags

Module:System.dll

Hierarchy
Object
ValueType
Enum
SocketFlags

Type declaration

[C#] public enum SocketFlags;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const SocketFlags DontRoute = 4;
public const SocketFlags MaxIOVectorLength = 16;
public const SocketFlags None = 0;
public const SocketFlags OutOfBand = 1;
public const SocketFlags Partial = 32768;
public const SocketFlags Peek = 2;
public int value__;

System.Net.Sockets.SocketException

Module:System.dll

Hierarchy
Object
Exception
SystemException
ExternalException
Win32Exception
SocketException

Type declaration

[C#] public class SocketException : Win32Exception;

Constructor
public SocketException();
public SocketException(int errorCode);
protected SocketException(SerializationInfo serializationInfo, StreamingContext streamingContext);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public int ErrorCode {get;}
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public virtual string Message {get;}
public int NativeErrorCode {get;}
public string Source {get; set;}
public string StackTrace {get;}
public MethodBase TargetSite {get;}

System.Net.IrDAEndPoint

Module:System.Net.IrDA.dll

Hierarchy
Object
EndPoint
IrDAEndPoint

Type declaration

[C#] public class IrDAEndPoint : EndPoint;

Constructor
public IrDAEndPoint(byte[] irdaDeviceID, string serviceName);

Method
public override EndPoint Create(SocketAddress sockaddr);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public override SocketAddress Serialize();
public virtual string ToString();

Property
public virtual AddressFamily AddressFamily {get;}
public override AddressFamily AddressFamily {get;}
public byte[] DeviceID {get; set;}
public string ServiceName {get; set;}

System.Net.NetworkCredential

Module:System.dll

Hierarchy
Object
NetworkCredential : ICredentials

Type declaration

[C#] public class NetworkCredential: ICredentials;

Constructor
public NetworkCredential();
public NetworkCredential(string userName, string password);
public NetworkCredential(string userName, string password, string domain);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual NetworkCredential GetCredential(Uri uri, string authType);
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public string Domain {get; set;}
public string Password {get; set;}
public string UserName {get; set;}

System.Net.ICredentials

Module:System.dll

Hierarchy
ICredentials

Type declaration

[C#] public interface ICredentials;

Method
public NetworkCredential GetCredential(Uri uri, string authType);

System.Net.IAuthenticationModule

Module:System.dll

Hierarchy
IAuthenticationModule

Type declaration

[C#] public interface IAuthenticationModule;

Method
public Authorization Authenticate(string challenge, WebRequest request, ICredentials credentials);
public Authorization PreAuthenticate(WebRequest request, ICredentials credentials);

Property
public string AuthenticationType {get;}
public bool CanPreAuthenticate {get;}

System.Net.AuthenticationManager

Module:System.dll

Hierarchy
Object
AuthenticationManager

Type declaration

[C#] public class AuthenticationManager;

Method
public static Authorization Authenticate(string challenge, WebRequest request, ICredentials credentials);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public static Authorization PreAuthenticate(WebRequest request, ICredentials credentials);
public static void Register(IAuthenticationModule authenticationModule);
public virtual string ToString();
public static void Unregister(IAuthenticationModule authenticationModule);
public static void Unregister(string authenticationScheme);

Property
public static IEnumerator RegisteredModules {get;}

System.Net.Authorization

Module:System.dll

Hierarchy
Object
Authorization

Type declaration

[C#] public class Authorization;

Constructor
public Authorization(string token);
public Authorization(string token, bool finished);
public Authorization(string token, bool finished, string connectionGroupId);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public bool Complete {get;}
public string ConnectionGroupId {get;}
public string Message {get;}
public string[] ProtectionRealm {get; set;}

System.Net.HttpWebResponse

Module:System.dll

Hierarchy
Object
MarshalByRefObject
WebResponse
HttpWebResponse

Type declaration

[C#] public class HttpWebResponse : WebResponse;

Constructor
protected HttpWebResponse(SerializationInfo serializationInfo, StreamingContext streamingContext);

Method
public override void Close();
public ObjRef CreateObjRef(Type requestedType);
protected virtual void Dispose(bool disposing);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public object GetLifetimeService();
public string GetResponseHeader(string headerName);
public override Stream GetResponseStream();
public Type GetType();
public object InitializeLifetimeService();
protected object MemberwiseClone();
public virtual string ToString();

Property
public string CharacterSet {get;}
public string ContentEncoding {get;}
public override long ContentLength {get;}
public override string ContentType {get;}
public CookieCollection Cookies {get; set;}
public override WebHeaderCollection Headers {get;}
public DateTime LastModified {get;}
public string Method {get;}
public Version ProtocolVersion {get;}
public override Uri ResponseUri {get;}
public string Server {get;}
public HttpStatusCode StatusCode {get;}
public string StatusDescription {get;}

System.Net.HttpWebRequest

Module:System.dll

Hierarchy
Object
MarshalByRefObject
WebRequest
HttpWebRequest

Type declaration

[C#] public class HttpWebRequest : WebRequest;

Constructor
protected HttpWebRequest(SerializationInfo serializationInfo, StreamingContext streamingContext);

Method
public override void Abort();
public void AddRange(int range);
public void AddRange(int from, int to);
public void AddRange(string rangeSpecifier, int range);
public void AddRange(string rangeSpecifier, int from, int to);
public override IAsyncResult BeginGetRequestStream(AsyncCallback callback, object state);
public override IAsyncResult BeginGetResponse(AsyncCallback callback, object state);
public ObjRef CreateObjRef(Type requestedType);
public override Stream EndGetRequestStream(IAsyncResult asyncResult);
public override WebResponse EndGetResponse(IAsyncResult asyncResult);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public object GetLifetimeService();
public override Stream GetRequestStream();
public override WebResponse GetResponse();
public Type GetType();
public object InitializeLifetimeService();
protected object MemberwiseClone();
public virtual string ToString();

Property
public string Accept {get; set;}
public Uri Address {get;}
public bool AllowAutoRedirect {get; set;}
public bool AllowWriteStreamBuffering {get; set;}
public X509CertificateCollection ClientCertificates {get;}
public string Connection {get; set;}
public virtual string ConnectionGroupName {get; set;}
public override long ContentLength {get; set;}
public override string ContentType {get; set;}
public HttpContinueDelegate ContinueDelegate {get; set;}
public CookieContainer CookieContainer {get; set;}
public override ICredentials Credentials {get; set;}
public static int DefaultMaximumResponseHeadersLength {get; set;}
public string Expect {get; set;}
public bool HaveResponse {get;}
public override WebHeaderCollection Headers {get; set;}
public DateTime IfModifiedSince {get; set;}
public bool KeepAlive {get; set;}
public int MaximumAutomaticRedirections {get; set;}
public int MaximumResponseHeadersLength {get; set;}
public string MediaType {get; set;}
public override string Method {get; set;}
public bool Pipelined {get; set;}
public override bool PreAuthenticate {get; set;}
public Version ProtocolVersion {get; set;}
public override IWebProxy Proxy {get; set;}
public int ReadWriteTimeout {get; set;}
public string Referer {get; set;}
public override Uri RequestUri {get;}
public bool SendChunked {get; set;}
public ServicePoint ServicePoint {get;}
public override int Timeout {get; set;}
public string TransferEncoding {get; set;}
public bool UnsafeAuthenticatedConnectionSharing {get; set;}
public string UserAgent {get; set;}

System.Net.ServicePointManager

Module:System.dll

Hierarchy
Object
ServicePointManager

Type declaration

[C#] public class ServicePointManager;

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public static ServicePoint FindServicePoint(string uriString, IWebProxy proxy);
public static ServicePoint FindServicePoint(Uri address);
public static ServicePoint FindServicePoint(Uri address, IWebProxy proxy);
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public static ICertificatePolicy CertificatePolicy {get; set;}
public static bool CheckCertificateRevocationList {get; set;}
public static int DefaultConnectionLimit {get; set;}
public static int MaxServicePointIdleTime {get; set;}
public static int MaxServicePoints {get; set;}

Field
public const int DefaultNonPersistentConnectionLimit = 4;
public const int DefaultPersistentConnectionLimit = 2;

System.Net.GlobalProxySelection

Module:System.dll

Hierarchy
Object
GlobalProxySelection

Type declaration

[C#] public class GlobalProxySelection;

Constructor
public GlobalProxySelection();

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public static IWebProxy GetEmptyWebProxy();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public static IWebProxy Select {get; set;}

System.Net.ProtocolViolationException

Module:System.dll

Hierarchy
Object
Exception
SystemException
InvalidOperationException
ProtocolViolationException

Type declaration

[C#] public class ProtocolViolationException : InvalidOperationException;

Constructor
public ProtocolViolationException();
protected ProtocolViolationException(SerializationInfo serializationInfo, StreamingContext streamingContext);
public ProtocolViolationException(string message);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public virtual string Message {get;}
public string Source {get; set;}
public string StackTrace {get;}
public MethodBase TargetSite {get;}

System.Net.ServicePoint

Module:System.dll

Hierarchy
Object
ServicePoint

Type declaration

[C#] public class ServicePoint;

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public Uri Address {get;}
public X509Certificate Certificate {get;}
public X509Certificate ClientCertificate {get;}
public int ConnectionLimit {get; set;}
public string ConnectionName {get;}
public int CurrentConnections {get;}
public DateTime IdleSince {get;}
public int MaxIdleTime {get; set;}
public Version ProtocolVersion {get;}
public bool SupportsPipelining {get;}

System.Net.WebProxy

Module:System.dll

Hierarchy
Object
WebProxy : IWebProxy

Type declaration

[C#] public class WebProxy: IWebProxy;

Constructor
public WebProxy();
protected WebProxy(SerializationInfo serializationInfo, StreamingContext streamingContext);
public WebProxy(string Address);
public WebProxy(string Address, bool BypassOnLocal);
public WebProxy(string Address, bool BypassOnLocal, string[] BypassList);
public WebProxy(string Address, bool BypassOnLocal, string[] BypassList, ICredentials Credentials);
public WebProxy(string Host, int Port);
public WebProxy(Uri Address);
public WebProxy(Uri Address, bool BypassOnLocal);
public WebProxy(Uri Address, bool BypassOnLocal, string[] BypassList);
public WebProxy(Uri Address, bool BypassOnLocal, string[] BypassList, ICredentials Credentials);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public static WebProxy GetDefaultProxy();
public virtual int GetHashCode();
public virtual Uri GetProxy(Uri destination);
public Type GetType();
public virtual bool IsBypassed(Uri host);
protected object MemberwiseClone();
public virtual string ToString();

Property
public Uri Address {get; set;}
public ArrayList BypassArrayList {get;}
public string[] BypassList {get; set;}
public bool BypassProxyOnLocal {get; set;}
public virtual ICredentials Credentials {get; set;}

System.Net.IWebProxy

Module:System.dll

Hierarchy
IWebProxy

Type declaration

[C#] public interface IWebProxy;

Method
public Uri GetProxy(Uri destination);
public bool IsBypassed(Uri host);

Property
public ICredentials Credentials {get; set;}

System.Net.WebExceptionStatus

Module:System.dll

Hierarchy
Object
ValueType
Enum
WebExceptionStatus

Type declaration

[C#] public enum WebExceptionStatus;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const WebExceptionStatus ConnectFailure = 2;
public const WebExceptionStatus ConnectionClosed = 8;
public const WebExceptionStatus KeepAliveFailure = 12;
public const WebExceptionStatus MessageLengthLimitExceeded = 17;
public const WebExceptionStatus NameResolutionFailure = 1;
public const WebExceptionStatus Pending = 13;
public const WebExceptionStatus PipelineFailure = 5;
public const WebExceptionStatus ProtocolError = 7;
public const WebExceptionStatus ProxyNameResolutionFailure = 15;
public const WebExceptionStatus ReceiveFailure = 3;
public const WebExceptionStatus RequestCanceled = 6;
public const WebExceptionStatus SecureChannelFailure = 10;
public const WebExceptionStatus SendFailure = 4;
public const WebExceptionStatus ServerProtocolViolation = 11;
public const WebExceptionStatus Success = 0;
public const WebExceptionStatus Timeout = 14;
public const WebExceptionStatus TrustFailure = 9;
public const WebExceptionStatus UnknownError = 16;
public int value__;

System.Net.WebException

Module:System.dll

Hierarchy
Object
Exception
SystemException
InvalidOperationException
WebException

Type declaration

[C#] public class WebException : InvalidOperationException;

Constructor
public WebException();
protected WebException(SerializationInfo serializationInfo, StreamingContext streamingContext);
public WebException(string message);
public WebException(string message, Exception innerException);
public WebException(string message, Exception inner, WebExceptionStatus status, WebResponse response);
public WebException(string message, WebExceptionStatus status);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public virtual string Message {get;}
public WebResponse Response {get;}
public string Source {get; set;}
public string StackTrace {get;}
public WebExceptionStatus Status {get;}
public MethodBase TargetSite {get;}

System.Net.HttpStatusCode

Module:System.dll

Hierarchy
Object
ValueType
Enum
HttpStatusCode

Type declaration

[C#] public enum HttpStatusCode;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const HttpStatusCode Accepted = 202;
public const HttpStatusCode Ambiguous = 300;
public const HttpStatusCode BadGateway = 502;
public const HttpStatusCode BadRequest = 400;
public const HttpStatusCode Conflict = 409;
public const HttpStatusCode Continue = 100;
public const HttpStatusCode Created = 201;
public const HttpStatusCode ExpectationFailed = 417;
public const HttpStatusCode Forbidden = 403;
public const HttpStatusCode Found = 302;
public const HttpStatusCode GatewayTimeout = 504;
public const HttpStatusCode Gone = 410;
public const HttpStatusCode HttpVersionNotSupported = 505;
public const HttpStatusCode InternalServerError = 500;
public const HttpStatusCode LengthRequired = 411;
public const HttpStatusCode MethodNotAllowed = 405;
public const HttpStatusCode Moved = 301;
public const HttpStatusCode MovedPermanently = 301;
public const HttpStatusCode MultipleChoices = 300;
public const HttpStatusCode NoContent = 204;
public const HttpStatusCode NonAuthoritativeInformation = 203;
public const HttpStatusCode NotAcceptable = 406;
public const HttpStatusCode NotFound = 404;
public const HttpStatusCode NotImplemented = 501;
public const HttpStatusCode NotModified = 304;
public const HttpStatusCode OK = 200;
public const HttpStatusCode PartialContent = 206;
public const HttpStatusCode PaymentRequired = 402;
public const HttpStatusCode PreconditionFailed = 412;
public const HttpStatusCode ProxyAuthenticationRequired = 407;
public const HttpStatusCode Redirect = 302;
public const HttpStatusCode RedirectKeepVerb = 307;
public const HttpStatusCode RedirectMethod = 303;
public const HttpStatusCode RequestedRangeNotSatisfiable = 416;
public const HttpStatusCode RequestEntityTooLarge = 413;
public const HttpStatusCode RequestTimeout = 408;
public const HttpStatusCode RequestUriTooLong = 414;
public const HttpStatusCode ResetContent = 205;
public const HttpStatusCode SeeOther = 303;
public const HttpStatusCode ServiceUnavailable = 503;
public const HttpStatusCode SwitchingProtocols = 101;
public const HttpStatusCode TemporaryRedirect = 307;
public const HttpStatusCode Unauthorized = 401;
public const HttpStatusCode UnsupportedMediaType = 415;
public const HttpStatusCode Unused = 306;
public const HttpStatusCode UseProxy = 305;
public int value__;

System.Net.HttpVersion

Module:System.dll

Hierarchy
Object
HttpVersion

Type declaration

[C#] public class HttpVersion;

Constructor
public HttpVersion();

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Field
public readonly static Version Version10;
public readonly static Version Version11;

System.Net.ICertificatePolicy

Module:System.dll

Hierarchy
ICertificatePolicy

Type declaration

[C#] public interface ICertificatePolicy;

Method
public bool CheckValidationResult(ServicePoint srvPoint, X509Certificate certificate, WebRequest request, int certificateProblem);

System.Net.HttpContinueDelegate

Module:System.dll

Hierarchy
Object
Delegate
MulticastDelegate
HttpContinueDelegate

Type declaration

[C#] public delegate void HttpContinueDelegate(int StatusCode, WebHeaderCollection httpHeaders);

Constructor
public HttpContinueDelegate(object object, IntPtr method);

Method
public virtual IAsyncResult BeginInvoke(int StatusCode, WebHeaderCollection httpHeaders, AsyncCallback callback, object object);
public object Clone();
protected override Delegate CombineImpl(Delegate follow);
public object DynamicInvoke(object[] args);
protected virtual object DynamicInvokeImpl(object[] args);
public virtual void EndInvoke(IAsyncResult result);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public override Delegate[] GetInvocationList();
protected virtual MethodInfo GetMethodImpl();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
public override void Invoke(int StatusCode, WebHeaderCollection httpHeaders);
protected object MemberwiseClone();
protected override Delegate RemoveImpl(Delegate value);
public virtual string ToString();

Property
public MethodInfo Method {get;}
public object Target {get;}

System.Net.IWebRequestCreate

Module:System.dll

Hierarchy
IWebRequestCreate

Type declaration

[C#] public interface IWebRequestCreate;

Method
public WebRequest Create(Uri uri);

System.Net.WebResponse

Module:System.dll

Hierarchy
Object
MarshalByRefObject
WebResponse

Type declaration

[C#] public abstract class WebResponse : MarshalByRefObject;

Constructor
protected WebResponse();
protected WebResponse(SerializationInfo serializationInfo, StreamingContext streamingContext);

Method
public virtual void Close();
public ObjRef CreateObjRef(Type requestedType);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public object GetLifetimeService();
public virtual Stream GetResponseStream();
public Type GetType();
public object InitializeLifetimeService();
protected object MemberwiseClone();
public virtual string ToString();

Property
public virtual long ContentLength {get; set;}
public virtual string ContentType {get; set;}
public virtual WebHeaderCollection Headers {get;}
public virtual Uri ResponseUri {get;}

System.Net.WebHeaderCollection

Module:System.dll

Hierarchy
Object
NameObjectCollectionBase
NameValueCollection
WebHeaderCollection

Type declaration

[C#] public class WebHeaderCollection : NameValueCollection;

Constructor
public WebHeaderCollection();
protected WebHeaderCollection(SerializationInfo serializationInfo, StreamingContext streamingContext);

Method
public void Add(NameValueCollection c);
public void Add(string header);
public override void Add(string name, string value);
protected void AddWithoutValidate(string headerName, string headerValue);
protected void BaseAdd(string name, object value);
protected void BaseClear();
protected object BaseGet(int index);
protected object BaseGet(string name);
protected string[] BaseGetAllKeys();
protected object[] BaseGetAllValues();
protected object[] BaseGetAllValues(Type type);
protected string BaseGetKey(int index);
protected bool BaseHasKeys();
protected void BaseRemove(string name);
protected void BaseRemoveAt(int index);
protected void BaseSet(int index, object value);
protected void BaseSet(string name, object value);
public void Clear();
public void CopyTo(Array dest, int index);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual string Get(int index);
public virtual string Get(string name);
public virtual IEnumerator GetEnumerator();
public virtual int GetHashCode();
public virtual string GetKey(int index);
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
public virtual string[] GetValues(int index);
public override string[] GetValues(string header);
public bool HasKeys();
protected void InvalidateCachedArrays();
public static bool IsRestricted(string headerName);
protected object MemberwiseClone();
public override void OnDeserialization(object sender);
public override void Remove(string name);
public override void Set(string name, string value);
public byte[] ToByteArray();
public override string ToString();

Property
public virtual string[] AllKeys {get;}
public virtual int Count {get;}
protected bool IsReadOnly {get; set;}
public string this[int index] {get;}
public string this[string name] {get; set;}
public virtual KeysCollection Keys {get;}

System.Net.WebRequest

Module:System.dll

Hierarchy
Object
MarshalByRefObject
WebRequest

Type declaration

[C#] public abstract class WebRequest : MarshalByRefObject;

Constructor
protected WebRequest();
protected WebRequest(SerializationInfo serializationInfo, StreamingContext streamingContext);

Method
public virtual void Abort();
public virtual IAsyncResult BeginGetRequestStream(AsyncCallback callback, object state);
public virtual IAsyncResult BeginGetResponse(AsyncCallback callback, object state);
public static WebRequest Create(string url);
public static WebRequest Create(Uri requestUri);
public static WebRequest CreateDefault(Uri requestUri);
public ObjRef CreateObjRef(Type requestedType);
public virtual Stream EndGetRequestStream(IAsyncResult asyncResult);
public virtual WebResponse EndGetResponse(IAsyncResult asyncResult);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public object GetLifetimeService();
public virtual Stream GetRequestStream();
public virtual WebResponse GetResponse();
public Type GetType();
public object InitializeLifetimeService();
protected object MemberwiseClone();
public static bool RegisterPrefix(string prefix, IWebRequestCreate creator);
public virtual string ToString();

Property
public virtual string ConnectionGroupName {get; set;}
public virtual long ContentLength {get; set;}
public virtual string ContentType {get; set;}
public virtual ICredentials Credentials {get; set;}
public virtual WebHeaderCollection Headers {get; set;}
public virtual string Method {get; set;}
public virtual bool PreAuthenticate {get; set;}
public virtual IWebProxy Proxy {get; set;}
public virtual Uri RequestUri {get;}
public virtual int Timeout {get; set;}

System.Net.Dns

Module:System.dll

Hierarchy
Object
Dns

Type declaration

[C#] public sealed class Dns;

Method
public static IAsyncResult BeginGetHostByName(string hostName, AsyncCallback requestCallback, object stateObject);
public static IAsyncResult BeginResolve(string hostName, AsyncCallback requestCallback, object stateObject);
public static IPHostEntry EndGetHostByName(IAsyncResult iar);
public static IPHostEntry EndResolve(IAsyncResult iar);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public static IPHostEntry GetHostByAddress(IPAddress address);
public static IPHostEntry GetHostByAddress(string address);
public static IPHostEntry GetHostByName(string hostName);
public static string GetHostName();
public Type GetType();
protected object MemberwiseClone();
public static IPHostEntry Resolve(string hostName);
public virtual string ToString();

System.Net.IPHostEntry

Module:System.dll

Hierarchy
Object
IPHostEntry

Type declaration

[C#] public class IPHostEntry;

Constructor
public IPHostEntry();

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public IPAddress[] AddressList {get; set;}
public string[] Aliases {get; set;}
public string HostName {get; set;}

System.Net.SocketAddress

Module:System.dll

Hierarchy
Object
SocketAddress

Type declaration

[C#] public class SocketAddress;

Constructor
public SocketAddress(AddressFamily family);
public SocketAddress(AddressFamily family, int size);

Method
public override bool Equals(object comparand);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public AddressFamily Family {get;}
public byte this[int offset] {get; set;}
public int Size {get;}

System.Net.IPEndPoint

Module:System.dll

Hierarchy
Object
EndPoint
IPEndPoint

Type declaration

[C#] public class IPEndPoint : EndPoint;

Constructor
public IPEndPoint(long address, int port);
public IPEndPoint(IPAddress address, int port);

Method
public override EndPoint Create(SocketAddress socketAddress);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public override SocketAddress Serialize();
public override string ToString();

Property
public IPAddress Address {get; set;}
public override AddressFamily AddressFamily {get;}
public int Port {get; set;}

Field
public const int MaxPort = 65535;
public const int MinPort = 0;

System.Net.IPAddress

Module:System.dll

Hierarchy
Object
IPAddress

Type declaration

[C#] public class IPAddress;

Constructor
public IPAddress(byte[] address);
public IPAddress(byte[] address, long scopeid);
public IPAddress(long newAddress);

Method
public override bool Equals(object rhs);
protected override void Finalize();
public byte[] GetAddressBytes();
public override int GetHashCode();
public Type GetType();
public static short HostToNetworkOrder(short host);
public static int HostToNetworkOrder(int host);
public static long HostToNetworkOrder(long host);
public static bool IsLoopback(IPAddress address);
protected object MemberwiseClone();
public static short NetworkToHostOrder(short network);
public static int NetworkToHostOrder(int network);
public static long NetworkToHostOrder(long network);
public static IPAddress Parse(string ipString);
public override string ToString();

Property
public long Address {get; set;}
public AddressFamily AddressFamily {get;}
public long ScopeId {get; set;}

Field
public readonly static IPAddress Any;
public readonly static IPAddress Broadcast;
public readonly static IPAddress IPv6Any;
public readonly static IPAddress IPv6Loopback;
public readonly static IPAddress IPv6None;
public readonly static IPAddress Loopback;
public readonly static IPAddress None;

System.Net.EndPoint

Module:System.dll

Hierarchy
Object
EndPoint

Type declaration

[C#] public abstract class EndPoint;

Constructor
protected EndPoint();

Method
public virtual EndPoint Create(SocketAddress socketAddress);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual SocketAddress Serialize();
public virtual string ToString();

Property
public virtual AddressFamily AddressFamily {get;}

System.Web.Services.WebServiceBindingAttribute

Module:System.Web.Services.dll

Hierarchy
Object
Attribute
WebServiceBindingAttribute

Type declaration

[C#] public sealed class WebServiceBindingAttribute : Attribute;

Constructor
public WebServiceBindingAttribute();
public WebServiceBindingAttribute(string name);
public WebServiceBindingAttribute(string name, string ns);
public WebServiceBindingAttribute(string name, string ns, string location);

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public string Location {get; set;}
public string Name {get; set;}
public string Namespace {get; set;}
public object TypeId {get;}

System.Web.Services.WebMethodAttribute

Module:System.Web.Services.dll

Hierarchy
Object
Attribute
WebMethodAttribute

Type declaration

[C#] public sealed class WebMethodAttribute : Attribute;

Constructor
public WebMethodAttribute();
public WebMethodAttribute(bool enableSession);
public WebMethodAttribute(bool enableSession, TransactionOption transactionOption);
public WebMethodAttribute(bool enableSession, TransactionOption transactionOption, int cacheDuration);
public WebMethodAttribute(bool enableSession, TransactionOption transactionOption, int cacheDuration, bool bufferResponse);

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public bool BufferResponse {get; set;}
public int CacheDuration {get; set;}
public string Description {get; set;}
public bool EnableSession {get; set;}
public string MessageName {get; set;}
public TransactionOption TransactionOption {get; set;}
public object TypeId {get;}

System.Web.Services.Description.SoapBindingUse

Module:System.Web.Services.dll

Hierarchy
Object
ValueType
Enum
SoapBindingUse

Type declaration

[C#] public enum SoapBindingUse;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const SoapBindingUse Default = 0;
public const SoapBindingUse Encoded = 1;
public const SoapBindingUse Literal = 2;
public int value__;

System.Web.Services.Protocols.SoapHeaderCollection

Module:System.Web.Services.dll

Hierarchy
Object
CollectionBase
SoapHeaderCollection

Type declaration

[C#] public class SoapHeaderCollection : CollectionBase;

Constructor
public SoapHeaderCollection();

Method
public int Add(SoapHeader header);
public virtual void Clear();
public bool Contains(SoapHeader header);
public void CopyTo(SoapHeader[] array, int index);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual IEnumerator GetEnumerator();
public virtual int GetHashCode();
public Type GetType();
public int IndexOf(SoapHeader header);
public void Insert(int index, SoapHeader header);
protected object MemberwiseClone();
protected virtual void OnClear();
protected virtual void OnClearComplete();
protected virtual void OnInsert(int index, object value);
protected virtual void OnInsertComplete(int index, object value);
protected virtual void OnRemove(int index, object value);
protected virtual void OnRemoveComplete(int index, object value);
protected virtual void OnSet(int index, object oldValue, object newValue);
protected virtual void OnSetComplete(int index, object oldValue, object newValue);
protected virtual void OnValidate(object value);
public void Remove(SoapHeader header);
public virtual void RemoveAt(int index);
public virtual string ToString();

Property
public virtual int Count {get;}
protected ArrayList InnerList {get;}
public SoapHeader this[int index] {get; set;}
protected IList List {get;}

System.Web.Services.Protocols.LogicalMethodInfo

Module:System.Web.Services.dll

Hierarchy
Object
LogicalMethodInfo

Type declaration

[C#] public sealed class LogicalMethodInfo;

Constructor
public LogicalMethodInfo(MethodInfo methodInfo);

Method
public IAsyncResult BeginInvoke(object target, object[] values, AsyncCallback callback, object asyncState);
public static LogicalMethodInfo[] Create(MethodInfo[] methodInfos);
public static LogicalMethodInfo[] Create(MethodInfo[] methodInfos, LogicalMethodTypes types);
public object[] EndInvoke(object target, IAsyncResult asyncResult);
public virtual bool Equals(object obj);
protected override void Finalize();
public object GetCustomAttribute(Type type);
public object[] GetCustomAttributes(Type type);
public virtual int GetHashCode();
public Type GetType();
public object[] Invoke(object target, object[] values);
public static bool IsBeginMethod(MethodInfo methodInfo);
public static bool IsEndMethod(MethodInfo methodInfo);
protected object MemberwiseClone();
public override string ToString();

Property
public ParameterInfo AsyncCallbackParameter {get;}
public ParameterInfo AsyncResultParameter {get;}
public ParameterInfo AsyncStateParameter {get;}
public MethodInfo BeginMethodInfo {get;}
public ICustomAttributeProvider CustomAttributeProvider {get;}
public Type DeclaringType {get;}
public MethodInfo EndMethodInfo {get;}
public ParameterInfo[] InParameters {get;}
public bool IsAsync {get;}
public bool IsVoid {get;}
public MethodInfo MethodInfo {get;}
public string Name {get;}
public ParameterInfo[] OutParameters {get;}
public ParameterInfo[] Parameters {get;}
public Type ReturnType {get;}
public ICustomAttributeProvider ReturnTypeCustomAttributeProvider {get;}

System.Web.Services.Protocols.LogicalMethodTypes

Module:System.Web.Services.dll

Hierarchy
Object
ValueType
Enum
LogicalMethodTypes

Type declaration

[C#] public enum LogicalMethodTypes;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const LogicalMethodTypes Async = 2;
public const LogicalMethodTypes Sync = 1;
public int value__;

System.Web.Services.Protocols.SoapClientMessage

Module:System.Web.Services.dll

Hierarchy
Object
SoapMessage
SoapClientMessage

Type declaration

[C#] public sealed class SoapClientMessage : SoapMessage;

Method
protected override void EnsureInStage();
protected override void EnsureOutStage();
protected void EnsureStage(SoapMessageStage stage);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public object GetInParameterValue(int index);
public object GetOutParameterValue(int index);
public object GetReturnValue();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public override string Action {get;}
public SoapHttpClientProtocol Client {get;}
public string ContentEncoding {get; set;}
public string ContentType {get; set;}
public SoapException Exception {get;}
public SoapHeaderCollection Headers {get;}
public override LogicalMethodInfo MethodInfo {get;}
public override bool OneWay {get;}
public SoapMessageStage Stage {get;}
public Stream Stream {get;}
public override string Url {get;}

System.Web.Services.Protocols.SoapMessage

Module:System.Web.Services.dll

Hierarchy
Object
SoapMessage

Type declaration

[C#] public abstract class SoapMessage;

Method
protected abstract void EnsureInStage();
protected abstract void EnsureOutStage();
protected void EnsureStage(SoapMessageStage stage);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public object GetInParameterValue(int index);
public object GetOutParameterValue(int index);
public object GetReturnValue();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public abstract string Action {get;}
public string ContentEncoding {get; set;}
public string ContentType {get; set;}
public SoapException Exception {get;}
public SoapHeaderCollection Headers {get;}
public abstract LogicalMethodInfo MethodInfo {get;}
public abstract bool OneWay {get;}
public SoapMessageStage Stage {get;}
public Stream Stream {get;}
public abstract string Url {get;}

System.Web.Services.Protocols.SoapMessageStage

Module:System.Web.Services.dll

Hierarchy
Object
ValueType
Enum
SoapMessageStage

Type declaration

[C#] public enum SoapMessageStage;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const SoapMessageStage AfterDeserialize = 8;
public const SoapMessageStage AfterSerialize = 2;
public const SoapMessageStage BeforeDeserialize = 4;
public const SoapMessageStage BeforeSerialize = 1;
public int value__;

System.Web.Services.Protocols.SoapExtension

Module:System.Web.Services.dll

Hierarchy
Object
SoapExtension

Type declaration

[C#] public abstract class SoapExtension;

Constructor
protected SoapExtension();

Method
public virtual Stream ChainStream(Stream stream);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public abstract object GetInitializer(LogicalMethodInfo methodInfo, SoapExtensionAttribute attribute);
public abstract object GetInitializer(Type serviceType);
public Type GetType();
public abstract void Initialize(object initializer);
protected object MemberwiseClone();
public abstract void ProcessMessage(SoapMessage message);
public virtual string ToString();

System.Web.Services.Protocols.SoapExtensionAttribute

Module:System.Web.Services.dll

Hierarchy
Object
Attribute
SoapExtensionAttribute

Type declaration

[C#] public abstract class SoapExtensionAttribute : Attribute;

Constructor
protected SoapExtensionAttribute();

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public abstract Type ExtensionType {get;}
public abstract int Priority {get; set;}
public object TypeId {get;}

System.Web.Services.Protocols.WebClientAsyncResult

Module:System.Web.Services.dll

Hierarchy
Object
WebClientAsyncResult : IAsyncResult

Type declaration

[C#] public class WebClientAsyncResult: IAsyncResult;

Method
public void Abort();
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public virtual object AsyncState {get;}
public virtual WaitHandle AsyncWaitHandle {get;}
public virtual bool CompletedSynchronously {get;}
public virtual bool IsCompleted {get;}

System.Web.Services.Protocols.SoapHttpClientProtocol

Module:System.Web.Services.dll

Hierarchy
Object
MarshalByRefObject
Component
WebClientProtocol
HttpWebClientProtocol
SoapHttpClientProtocol

Type declaration

[C#] public class SoapHttpClientProtocol : HttpWebClientProtocol;

Constructor
public SoapHttpClientProtocol();

Method
public virtual void Abort();
public void add_Disposed(EventHandler value);
protected IAsyncResult BeginInvoke(string methodName, object[] parameters, AsyncCallback callback, object asyncState);
public ObjRef CreateObjRef(Type requestedType);
public void Discover();
public void Dispose();
protected virtual void Dispose(bool disposing);
protected object[] EndInvoke(IAsyncResult asyncResult);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public object GetLifetimeService();
protected virtual object GetService(Type service);
public Type GetType();
protected virtual WebRequest GetWebRequest(Uri uri);
protected virtual WebResponse GetWebResponse(WebRequest request);
protected virtual WebResponse GetWebResponse(WebRequest request, IAsyncResult result);
public object InitializeLifetimeService();
protected object[] Invoke(string methodName, object[] parameters);
protected object MemberwiseClone();
public void remove_Disposed(EventHandler value);
public virtual string ToString();

Property
public bool AllowAutoRedirect {get; set;}
public X509CertificateCollection ClientCertificates {get;}
public string ConnectionGroupName {get; set;}
public IContainer Container {get;}
public CookieContainer CookieContainer {get; set;}
public ICredentials Credentials {get; set;}
protected bool DesignMode {get;}
protected EventHandlerList Events {get;}
public bool PreAuthenticate {get; set;}
public IWebProxy Proxy {get; set;}
public Encoding RequestEncoding {get; set;}
public ISite Site {get; set;}
public int Timeout {get; set;}
public bool UnsafeAuthenticatedConnectionSharing {get; set;}
public string Url {get; set;}
public string UserAgent {get; set;}

System.Web.Services.Protocols.HttpWebClientProtocol

Module:System.Web.Services.dll

Hierarchy
Object
MarshalByRefObject
Component
WebClientProtocol
HttpWebClientProtocol

Type declaration

[C#] public abstract class HttpWebClientProtocol : WebClientProtocol;

Constructor
protected HttpWebClientProtocol();

Method
public virtual void Abort();
public void add_Disposed(EventHandler value);
public ObjRef CreateObjRef(Type requestedType);
public void Dispose();
protected virtual void Dispose(bool disposing);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public object GetLifetimeService();
protected virtual object GetService(Type service);
public Type GetType();
protected virtual WebRequest GetWebRequest(Uri uri);
protected virtual WebResponse GetWebResponse(WebRequest request);
protected virtual WebResponse GetWebResponse(WebRequest request, IAsyncResult result);
public object InitializeLifetimeService();
protected object MemberwiseClone();
public void remove_Disposed(EventHandler value);
public virtual string ToString();

Property
public bool AllowAutoRedirect {get; set;}
public X509CertificateCollection ClientCertificates {get;}
public string ConnectionGroupName {get; set;}
public IContainer Container {get;}
public CookieContainer CookieContainer {get; set;}
public ICredentials Credentials {get; set;}
protected bool DesignMode {get;}
protected EventHandlerList Events {get;}
public bool PreAuthenticate {get; set;}
public IWebProxy Proxy {get; set;}
public Encoding RequestEncoding {get; set;}
public ISite Site {get; set;}
public int Timeout {get; set;}
public bool UnsafeAuthenticatedConnectionSharing {get; set;}
public string Url {get; set;}
public string UserAgent {get; set;}

System.Web.Services.Protocols.WebClientProtocol

Module:System.Web.Services.dll

Hierarchy
Object
MarshalByRefObject
Component
WebClientProtocol

Type declaration

[C#] public abstract class WebClientProtocol : Component;

Constructor
protected WebClientProtocol();

Method
public virtual void Abort();
public void add_Disposed(EventHandler value);
protected static void AddToCache(Type type, object value);
public ObjRef CreateObjRef(Type requestedType);
public void Dispose();
protected virtual void Dispose(bool disposing);
public virtual bool Equals(object obj);
protected override void Finalize();
protected static object GetFromCache(Type type);
public virtual int GetHashCode();
public object GetLifetimeService();
protected virtual object GetService(Type service);
public Type GetType();
protected virtual WebRequest GetWebRequest(Uri uri);
protected virtual WebResponse GetWebResponse(WebRequest request);
protected virtual WebResponse GetWebResponse(WebRequest request, IAsyncResult result);
public object InitializeLifetimeService();
protected object MemberwiseClone();
public void remove_Disposed(EventHandler value);
public virtual string ToString();

Property
public string ConnectionGroupName {get; set;}
public IContainer Container {get;}
public ICredentials Credentials {get; set;}
protected bool DesignMode {get;}
protected EventHandlerList Events {get;}
public bool PreAuthenticate {get; set;}
public Encoding RequestEncoding {get; set;}
public ISite Site {get; set;}
public int Timeout {get; set;}
public string Url {get; set;}

System.Web.Services.Protocols.SoapDocumentServiceAttribute

Module:System.Web.Services.dll

Hierarchy
Object
Attribute
SoapDocumentServiceAttribute

Type declaration

[C#] public sealed class SoapDocumentServiceAttribute : Attribute;

Constructor
public SoapDocumentServiceAttribute();
public SoapDocumentServiceAttribute(SoapBindingUse use);
public SoapDocumentServiceAttribute(SoapBindingUse use, SoapParameterStyle paramStyle);

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public SoapParameterStyle ParameterStyle {get; set;}
public SoapServiceRoutingStyle RoutingStyle {get; set;}
public object TypeId {get;}
public SoapBindingUse Use {get; set;}

System.Web.Services.Protocols.SoapDocumentMethodAttribute

Module:System.Web.Services.dll

Hierarchy
Object
Attribute
SoapDocumentMethodAttribute

Type declaration

[C#] public sealed class SoapDocumentMethodAttribute : Attribute;

Constructor
public SoapDocumentMethodAttribute();
public SoapDocumentMethodAttribute(string action);

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public string Action {get; set;}
public string Binding {get; set;}
public bool OneWay {get; set;}
public SoapParameterStyle ParameterStyle {get; set;}
public string RequestElementName {get; set;}
public string RequestNamespace {get; set;}
public string ResponseElementName {get; set;}
public string ResponseNamespace {get; set;}
public object TypeId {get;}
public SoapBindingUse Use {get; set;}

System.Web.Services.Protocols.SoapServiceRoutingStyle

Module:System.Web.Services.dll

Hierarchy
Object
ValueType
Enum
SoapServiceRoutingStyle

Type declaration

[C#] public enum SoapServiceRoutingStyle;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const SoapServiceRoutingStyle RequestElement = 1;
public const SoapServiceRoutingStyle SoapAction = 0;
public int value__;

System.Web.Services.Protocols.SoapRpcMethodAttribute

Module:System.Web.Services.dll

Hierarchy
Object
Attribute
SoapRpcMethodAttribute

Type declaration

[C#] public sealed class SoapRpcMethodAttribute : Attribute;

Constructor
public SoapRpcMethodAttribute();
public SoapRpcMethodAttribute(string action);

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public string Action {get; set;}
public string Binding {get; set;}
public bool OneWay {get; set;}
public string RequestElementName {get; set;}
public string RequestNamespace {get; set;}
public string ResponseElementName {get; set;}
public string ResponseNamespace {get; set;}
public object TypeId {get;}

System.Web.Services.Protocols.SoapParameterStyle

Module:System.Web.Services.dll

Hierarchy
Object
ValueType
Enum
SoapParameterStyle

Type declaration

[C#] public enum SoapParameterStyle;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const SoapParameterStyle Bare = 1;
public const SoapParameterStyle Default = 0;
public int value__;
public const SoapParameterStyle Wrapped = 2;

System.Web.Services.Protocols.SoapHeaderException

Module:System.Web.Services.dll

Hierarchy
Object
Exception
SystemException
SoapException
SoapHeaderException

Type declaration

[C#] public class SoapHeaderException : SoapException;

Constructor
public SoapHeaderException(string message, XmlQualifiedName code);
public SoapHeaderException(string message, XmlQualifiedName code, Exception innerException);
public SoapHeaderException(string message, XmlQualifiedName code, string actor);
public SoapHeaderException(string message, XmlQualifiedName code, string actor, Exception innerException);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public string Actor {get;}
public XmlQualifiedName Code {get;}
public XmlNode Detail {get;}
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public virtual string Message {get;}
public string Source {get; set;}
public string StackTrace {get;}
public MethodBase TargetSite {get;}

System.Web.Services.Protocols.SoapHeaderDirection

Module:System.Web.Services.dll

Hierarchy
Object
ValueType
Enum
SoapHeaderDirection

Type declaration

[C#] public enum SoapHeaderDirection;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const SoapHeaderDirection Fault = 4;
public const SoapHeaderDirection In = 1;
public const SoapHeaderDirection InOut = 3;
public const SoapHeaderDirection Out = 2;
public int value__;

System.Web.Services.Protocols.SoapHeaderAttribute

Module:System.Web.Services.dll

Hierarchy
Object
Attribute
SoapHeaderAttribute

Type declaration

[C#] public sealed class SoapHeaderAttribute : Attribute;

Constructor
public SoapHeaderAttribute(string memberName);

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public SoapHeaderDirection Direction {get; set;}
public string MemberName {get; set;}
public bool Required {get; set;}
public object TypeId {get;}

System.Web.Services.Protocols.SoapUnknownHeader

Module:System.Web.Services.dll

Hierarchy
Object
SoapHeader
SoapUnknownHeader

Type declaration

[C#] public sealed class SoapUnknownHeader : SoapHeader;

Constructor
public SoapUnknownHeader();

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public string Actor {get; set;}
public bool DidUnderstand {get; set;}
public XmlElement Element {get; set;}
public string EncodedMustUnderstand {get; set;}
public bool MustUnderstand {get; set;}

System.Web.Services.Protocols.SoapHeader

Module:System.Web.Services.dll

Hierarchy
Object
SoapHeader

Type declaration

[C#] public abstract class SoapHeader;

Constructor
protected SoapHeader();

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public string Actor {get; set;}
public bool DidUnderstand {get; set;}
public string EncodedMustUnderstand {get; set;}
public bool MustUnderstand {get; set;}

System.Web.Services.Protocols.SoapException

Module:System.Web.Services.dll

Hierarchy
Object
Exception
SystemException
SoapException

Type declaration

[C#] public class SoapException : SystemException;

Constructor
public SoapException(string message, XmlQualifiedName code);
public SoapException(string message, XmlQualifiedName code, Exception innerException);
public SoapException(string message, XmlQualifiedName code, string actor);
public SoapException(string message, XmlQualifiedName code, string actor, Exception innerException);
public SoapException(string message, XmlQualifiedName code, string actor, XmlNode detail);
public SoapException(string message, XmlQualifiedName code, string actor, XmlNode detail, Exception innerException);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public string Actor {get;}
public XmlQualifiedName Code {get;}
public XmlNode Detail {get;}
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public virtual string Message {get;}
public string Source {get; set;}
public string StackTrace {get;}
public MethodBase TargetSite {get;}

Field
public readonly static XmlQualifiedName ClientFaultCode;
public readonly static XmlQualifiedName DetailElementName;
public readonly static XmlQualifiedName MustUnderstandFaultCode;
public readonly static XmlQualifiedName ServerFaultCode;
public readonly static XmlQualifiedName VersionMismatchFaultCode;

System.Windows.Forms.GridTableStylesCollection

Module:System.Windows.Forms.DataGrid.dll
Module:system.windows.forms.dll

Hierarchy
Object
MarshalByRefObject
BaseCollection
GridTableStylesCollection : IList, ICollection, IEnumerable

Type declaration

[C#] public class GridTableStylesCollection : BaseCollection, IList, ICollection, IEnumerable;

Method
public int Add(DataGridTableStyle tabstyNew);
public void add_CollectionChanged(CollectionChangeEventHandler value);
public virtual void AddRange(DataGridTableStyle[] tables);
public void Clear();
public bool Contains(DataGridTableStyle tabstyContains);
public bool Contains(string strMapping);
public virtual void CopyTo(Array ar, int index);
public ObjRef CreateObjRef(Type requestedType);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual IEnumerator GetEnumerator();
public virtual int GetHashCode();
public object GetLifetimeService();
public Type GetType();
public object InitializeLifetimeService();
protected object MemberwiseClone();
protected void OnCollectionChanged(CollectionChangeEventArgs ccevent);
public void Remove(DataGridTableStyle tabstyRemove);
public void remove_CollectionChanged(CollectionChangeEventHandler value);
public void RemoveAt(int itabstyRemove);
public virtual string ToString();

Property
public virtual int Count {get;}
public bool IsReadOnly {get;}
public virtual bool IsSynchronized {get;}
public DataGridTableStyle this[int i] {get;}
public DataGridTableStyle this[string strMapping] {get;}
protected override ArrayList List {get;}
public virtual object SyncRoot {get;}

System.Windows.Forms.DataGridTableStyle

Module:System.Windows.Forms.DataGrid.dll
Module:system.windows.forms.dll

Hierarchy
Object
MarshalByRefObject
Component
DataGridTableStyle

Type declaration

[C#] public class DataGridTableStyle : Component;

Constructor
public DataGridTableStyle();
public DataGridTableStyle(bool isDefaultTableStyle);
public DataGridTableStyle(CurrencyManager listManager);

Method
public void add_AllowSortingChanged(EventHandler value);
public void add_AlternatingBackColorChanged(EventHandler value);
public void add_BackColorChanged(EventHandler value);
public void add_ColumnHeadersVisibleChanged(EventHandler value);
public void add_Disposed(EventHandler value);
public void add_ForeColorChanged(EventHandler value);
public void add_GridLineColorChanged(EventHandler value);
public void add_GridLineStyleChanged(EventHandler value);
public void add_HeaderBackColorChanged(EventHandler value);
public void add_HeaderFontChanged(EventHandler value);
public void add_HeaderForeColorChanged(EventHandler value);
public void add_LinkColorChanged(EventHandler value);
public void add_LinkHoverColorChanged(EventHandler value);
public void add_MappingNameChanged(EventHandler value);
public void add_PreferredColumnWidthChanged(EventHandler value);
public void add_PreferredRowHeightChanged(EventHandler value);
public void add_ReadOnlyChanged(EventHandler value);
public void add_RowHeadersVisibleChanged(EventHandler value);
public void add_RowHeaderWidthChanged(EventHandler value);
public void add_SelectionBackColorChanged(EventHandler value);
public void add_SelectionForeColorChanged(EventHandler value);
public virtual bool BeginEdit(DataGridColumnStyle gridColumn, int rowNumber);
public ObjRef CreateObjRef(Type requestedType);
public void Dispose();
protected virtual void Dispose(bool disposing);
public virtual bool EndEdit(DataGridColumnStyle gridColumn, int rowNumber, bool shouldAbort);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public object GetLifetimeService();
protected virtual object GetService(Type service);
public Type GetType();
public object InitializeLifetimeService();
protected object MemberwiseClone();
protected virtual void OnAllowSortingChanged(EventArgs e);
protected virtual void OnAlternatingBackColorChanged(EventArgs e);
protected virtual void OnBackColorChanged(EventArgs e);
protected virtual void OnColumnHeadersVisibleChanged(EventArgs e);
protected virtual void OnForeColorChanged(EventArgs e);
protected virtual void OnGridLineColorChanged(EventArgs e);
protected virtual void OnGridLineStyleChanged(EventArgs e);
protected virtual void OnHeaderBackColorChanged(EventArgs e);
protected virtual void OnHeaderFontChanged(EventArgs e);
protected virtual void OnHeaderForeColorChanged(EventArgs e);
protected virtual void OnLinkColorChanged(EventArgs e);
protected virtual void OnLinkHoverColorChanged(EventArgs e);
protected virtual void OnMappingNameChanged(EventArgs e);
protected virtual void OnPreferredColumnWidthChanged(EventArgs e);
protected virtual void OnPreferredRowHeightChanged(EventArgs e);
protected virtual void OnReadOnlyChanged(EventArgs e);
protected virtual void OnRowHeadersVisibleChanged(EventArgs e);
protected virtual void OnRowHeaderWidthChanged(EventArgs e);
protected virtual void OnSelectionBackColorChanged(EventArgs e);
protected virtual void OnSelectionForeColorChanged(EventArgs e);
public void remove_AllowSortingChanged(EventHandler value);
public void remove_AlternatingBackColorChanged(EventHandler value);
public void remove_BackColorChanged(EventHandler value);
public void remove_ColumnHeadersVisibleChanged(EventHandler value);
public void remove_Disposed(EventHandler value);
public void remove_ForeColorChanged(EventHandler value);
public void remove_GridLineColorChanged(EventHandler value);
public void remove_GridLineStyleChanged(EventHandler value);
public void remove_HeaderBackColorChanged(EventHandler value);
public void remove_HeaderFontChanged(EventHandler value);
public void remove_HeaderForeColorChanged(EventHandler value);
public void remove_LinkColorChanged(EventHandler value);
public void remove_LinkHoverColorChanged(EventHandler value);
public void remove_MappingNameChanged(EventHandler value);
public void remove_PreferredColumnWidthChanged(EventHandler value);
public void remove_PreferredRowHeightChanged(EventHandler value);
public void remove_ReadOnlyChanged(EventHandler value);
public void remove_RowHeadersVisibleChanged(EventHandler value);
public void remove_RowHeaderWidthChanged(EventHandler value);
public void remove_SelectionBackColorChanged(EventHandler value);
public void remove_SelectionForeColorChanged(EventHandler value);
public void ResetAlternatingBackColor();
public void ResetBackColor();
public void ResetForeColor();
public void ResetGridLineColor();
public void ResetHeaderBackColor();
public void ResetHeaderFont();
public void ResetHeaderForeColor();
public void ResetLinkColor();
public void ResetLinkHoverColor();
public void ResetSelectionBackColor();
public void ResetSelectionForeColor();
protected virtual bool ShouldSerializeAlternatingBackColor();
protected bool ShouldSerializeBackColor();
protected bool ShouldSerializeForeColor();
protected virtual bool ShouldSerializeGridLineColor();
protected virtual bool ShouldSerializeHeaderBackColor();
protected virtual bool ShouldSerializeHeaderForeColor();
protected virtual bool ShouldSerializeLinkColor();
protected virtual bool ShouldSerializeLinkHoverColor();
protected bool ShouldSerializePreferredRowHeight();
protected bool ShouldSerializeSelectionBackColor();
protected virtual bool ShouldSerializeSelectionForeColor();
public virtual string ToString();

Property
public bool AllowSorting {get; set;}
public Color AlternatingBackColor {get; set;}
public Color BackColor {get; set;}
public bool ColumnHeadersVisible {get; set;}
public IContainer Container {get;}
public virtual DataGrid DataGrid {get; set;}
protected bool DesignMode {get;}
protected EventHandlerList Events {get;}
public Color ForeColor {get; set;}
public virtual GridColumnStylesCollection GridColumnStyles {get;}
public Color GridLineColor {get; set;}
public DataGridLineStyle GridLineStyle {get; set;}
public Color HeaderBackColor {get; set;}
public Font HeaderFont {get; set;}
public Color HeaderForeColor {get; set;}
public Color LinkColor {get; set;}
public Color LinkHoverColor {get; set;}
public string MappingName {get; set;}
public int PreferredColumnWidth {get; set;}
public int PreferredRowHeight {get; set;}
public virtual bool ReadOnly {get; set;}
public bool RowHeadersVisible {get; set;}
public int RowHeaderWidth {get; set;}
public Color SelectionBackColor {get; set;}
public Color SelectionForeColor {get; set;}
public ISite Site {get; set;}

Field
public static DataGridTableStyle DefaultTableStyle;

System.Windows.Forms.DataGridTextBoxColumn

Module:System.Windows.Forms.DataGrid.dll
Module:system.windows.forms.dll

Hierarchy
Object
MarshalByRefObject
Component
DataGridColumnStyle
DataGridTextBoxColumn

Type declaration

[C#] public class DataGridTextBoxColumn : DataGridColumnStyle;

Constructor
public DataGridTextBoxColumn();
public DataGridTextBoxColumn(PropertyDescriptor prop);
public DataGridTextBoxColumn(PropertyDescriptor prop, bool isDefault);
public DataGridTextBoxColumn(PropertyDescriptor prop, string format);
public DataGridTextBoxColumn(PropertyDescriptor prop, string format, bool isDefault);

Method
public void add_AlignmentChanged(EventHandler value);
public void add_Disposed(EventHandler value);
public void add_FontChanged(EventHandler value);
public void add_HeaderTextChanged(EventHandler value);
public void add_MappingNameChanged(EventHandler value);
public void add_NullTextChanged(EventHandler value);
public void add_PropertyDescriptorChanged(EventHandler value);
public void add_ReadOnlyChanged(EventHandler value);
public void add_WidthChanged(EventHandler value);
protected void BeginUpdate();
protected void CheckValidDataSource(CurrencyManager value);
protected virtual AccessibleObject CreateHeaderAccessibleObject();
public ObjRef CreateObjRef(Type requestedType);
public void Dispose();
protected virtual void Dispose(bool disposing);
protected void EndEdit();
protected void EndUpdate();
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public object GetLifetimeService();
protected virtual object GetService(Type service);
public Type GetType();
protected void HideEditBox();
public object InitializeLifetimeService();
protected virtual void Invalidate();
protected object MemberwiseClone();
protected void PaintText(Graphics g, Rectangle bounds, string text, bool alignToRight);
protected void PaintText(Graphics g, Rectangle textBounds, string text, Brush backBrush, Brush foreBrush, bool alignToRight);
public void remove_AlignmentChanged(EventHandler value);
public void remove_Disposed(EventHandler value);
public void remove_FontChanged(EventHandler value);
public void remove_HeaderTextChanged(EventHandler value);
public void remove_MappingNameChanged(EventHandler value);
public void remove_NullTextChanged(EventHandler value);
public void remove_PropertyDescriptorChanged(EventHandler value);
public void remove_ReadOnlyChanged(EventHandler value);
public void remove_WidthChanged(EventHandler value);
public void ResetHeaderText();
protected virtual void SetDataGrid(DataGrid value);
protected virtual void SetDataGridInColumn(DataGrid value);
public virtual string ToString();

Property
public HorizontalAlignment Alignment {get; set;}
public IContainer Container {get;}
public DataGridTableStyle DataGridTableStyle {get;}
protected bool DesignMode {get;}
protected EventHandlerList Events {get;}
protected int FontHeight {get;}
public string Format {get; set;}
public IFormatProvider FormatInfo {get; set;}
public AccessibleObject HeaderAccessibleObject {get;}
public virtual string HeaderText {get; set;}
public virtual string MappingName {get; set;}
public virtual string NullText {get; set;}
public override PropertyDescriptor PropertyDescriptor { set;}
public override bool ReadOnly {get; set;}
public ISite Site {get; set;}
public virtual TextBox TextBox {get;}
public virtual int Width {get; set;}

System.Windows.Forms.DataGridColumnStyle

Module:System.Windows.Forms.DataGrid.dll
Module:system.windows.forms.dll

Hierarchy
Object
MarshalByRefObject
Component
DataGridColumnStyle

Type declaration

[C#] public abstract class DataGridColumnStyle : Component;

Constructor
public DataGridColumnStyle();
public DataGridColumnStyle(PropertyDescriptor prop);

Method
public void add_AlignmentChanged(EventHandler value);
public void add_Disposed(EventHandler value);
public void add_FontChanged(EventHandler value);
public void add_HeaderTextChanged(EventHandler value);
public void add_MappingNameChanged(EventHandler value);
public void add_NullTextChanged(EventHandler value);
public void add_PropertyDescriptorChanged(EventHandler value);
public void add_ReadOnlyChanged(EventHandler value);
public void add_WidthChanged(EventHandler value);
protected void BeginUpdate();
protected void CheckValidDataSource(CurrencyManager value);
protected virtual AccessibleObject CreateHeaderAccessibleObject();
public ObjRef CreateObjRef(Type requestedType);
public void Dispose();
protected virtual void Dispose(bool disposing);
protected void EndUpdate();
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public object GetLifetimeService();
protected virtual object GetService(Type service);
public Type GetType();
public object InitializeLifetimeService();
protected virtual void Invalidate();
protected object MemberwiseClone();
public void remove_AlignmentChanged(EventHandler value);
public void remove_Disposed(EventHandler value);
public void remove_FontChanged(EventHandler value);
public void remove_HeaderTextChanged(EventHandler value);
public void remove_MappingNameChanged(EventHandler value);
public void remove_NullTextChanged(EventHandler value);
public void remove_PropertyDescriptorChanged(EventHandler value);
public void remove_ReadOnlyChanged(EventHandler value);
public void remove_WidthChanged(EventHandler value);
public void ResetHeaderText();
protected virtual void SetDataGrid(DataGrid value);
protected virtual void SetDataGridInColumn(DataGrid value);
public virtual string ToString();

Property
public virtual HorizontalAlignment Alignment {get; set;}
public IContainer Container {get;}
public virtual DataGridTableStyle DataGridTableStyle {get;}
protected bool DesignMode {get;}
protected EventHandlerList Events {get;}
protected int FontHeight {get;}
public AccessibleObject HeaderAccessibleObject {get;}
public virtual string HeaderText {get; set;}
public virtual string MappingName {get; set;}
public virtual string NullText {get; set;}
public virtual PropertyDescriptor PropertyDescriptor {get; set;}
public virtual bool ReadOnly {get; set;}
public ISite Site {get; set;}
public virtual int Width {get; set;}

System.Windows.Forms.GridColumnStylesCollection

Module:System.Windows.Forms.DataGrid.dll
Module:system.windows.forms.dll

Hierarchy
Object
MarshalByRefObject
BaseCollection
GridColumnStylesCollection : IList, ICollection, IEnumerable

Type declaration

[C#] public class GridColumnStylesCollection : BaseCollection, IList, ICollection, IEnumerable;

Method
public int Add(DataGridColumnStyle dgcolstyNew);
public void add_CollectionChanged(CollectionChangeEventHandler value);
public void AddRange(DataGridColumnStyle[] columns);
public void Clear();
public bool Contains(DataGridColumnStyle dgcolstyContains);
public bool Contains(PropertyDescriptor propDesc);
public bool Contains(string strMapping);
public virtual void CopyTo(Array ar, int index);
public ObjRef CreateObjRef(Type requestedType);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual IEnumerator GetEnumerator();
public virtual int GetHashCode();
public object GetLifetimeService();
public Type GetType();
public int IndexOf(DataGridColumnStyle dgcolstyIndexOf);
public object InitializeLifetimeService();
protected object MemberwiseClone();
protected void OnCollectionChanged(CollectionChangeEventArgs ccevent);
public void Remove(DataGridColumnStyle dgcolstyRemove);
public void remove_CollectionChanged(CollectionChangeEventHandler value);
public void RemoveAt(int idgcolstyRemove);
public void ResetPropertyDescriptors();
public virtual string ToString();

Property
public virtual int Count {get;}
public bool IsReadOnly {get;}
public virtual bool IsSynchronized {get;}
public DataGridColumnStyle this[int idgcolsty] {get;}
public DataGridColumnStyle this[PropertyDescriptor propDesc] {get;}
public DataGridColumnStyle this[string strColumn] {get;}
protected override ArrayList List {get;}
public virtual object SyncRoot {get;}

System.Windows.Forms.DataGridCell

Module:System.Windows.Forms.DataGrid.dll
Module:system.windows.forms.dll

Hierarchy
Object
ValueType
DataGridCell

Type declaration

[C#] public struct DataGridCell : ValueType;

Constructor
public DataGridCell(int irow, int icol);

Method
public override bool Equals(object objRhs);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public int ColumnNumber {get; set;}
public int RowNumber {get; set;}

System.Windows.Forms.DataGrid+HitTestInfo

Module:System.Windows.Forms.DataGrid.dll
Module:system.windows.forms.dll

Hierarchy
Object
DataGrid+HitTestInfo

Type declaration

[C#] public sealed class HitTestInfo;

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public int Column {get;}
public int Row {get;}
public HitTestType Type {get;}

Field
public readonly static HitTestInfo Nowhere;

System.Windows.Forms.DataGrid+HitTestType

Module:System.Windows.Forms.DataGrid.dll
Module:system.windows.forms.dll

Hierarchy
Object
ValueType
Enum
DataGrid+HitTestType

Type declaration

[C#] public enum HitTestType;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const HitTestType Caption = 32;
public const HitTestType Cell = 1;
public const HitTestType ColumnHeader = 2;
public const HitTestType ColumnResize = 8;
public const HitTestType None = 0;
public const HitTestType ParentRows = 64;
public const HitTestType RowHeader = 4;
public const HitTestType RowResize = 16;
public int value__;

System.Windows.Forms.DataGrid

Module:System.Windows.Forms.DataGrid.dll
Module:system.windows.forms.dll

Hierarchy
Object
MarshalByRefObject
Component
Control
DataGrid

Type declaration

[C#] public class DataGrid : Control;

Constructor
public DataGrid();

Method
protected void AccessibilityNotifyClients(AccessibleEvents accEvent, int childID);
public void add_AllowNavigationChanged(EventHandler value);
public void add_BackButtonClick(EventHandler value);
public void add_BackColorChanged(EventHandler value);
public void add_BackgroundColorChanged(EventHandler value);
public void add_BackgroundImageChanged(EventHandler value);
public void add_BindingContextChanged(EventHandler value);
public void add_BorderStyleChanged(EventHandler value);
public void add_CaptionVisibleChanged(EventHandler value);
public void add_CausesValidationChanged(EventHandler value);
public void add_ChangeUICues(UICuesEventHandler value);
public void add_Click(EventHandler value);
public void add_ContextMenuChanged(EventHandler value);
public void add_ControlAdded(ControlEventHandler value);
public void add_ControlRemoved(ControlEventHandler value);
public void add_CurrentCellChanged(EventHandler value);
public void add_CursorChanged(EventHandler value);
public void add_DataSourceChanged(EventHandler value);
public void add_Disposed(EventHandler value);
public void add_DockChanged(EventHandler value);
public void add_DoubleClick(EventHandler value);
public void add_DragDrop(DragEventHandler value);
public void add_DragEnter(DragEventHandler value);
public void add_DragLeave(EventHandler value);
public void add_DragOver(DragEventHandler value);
public void add_EnabledChanged(EventHandler value);
public void add_Enter(EventHandler value);
public void add_FlatModeChanged(EventHandler value);
public void add_FontChanged(EventHandler value);
public void add_ForeColorChanged(EventHandler value);
public void add_GiveFeedback(GiveFeedbackEventHandler value);
public void add_GotFocus(EventHandler value);
public void add_HandleCreated(EventHandler value);
public void add_HandleDestroyed(EventHandler value);
public void add_HelpRequested(HelpEventHandler value);
public void add_ImeModeChanged(EventHandler value);
public void add_Invalidated(InvalidateEventHandler value);
public void add_KeyDown(KeyEventHandler value);
public void add_KeyPress(KeyPressEventHandler value);
public void add_KeyUp(KeyEventHandler value);
public void add_Layout(LayoutEventHandler value);
public void add_Leave(EventHandler value);
public void add_LocationChanged(EventHandler value);
public void add_LostFocus(EventHandler value);
public void add_MouseDown(MouseEventHandler value);
public void add_MouseEnter(EventHandler value);
public void add_MouseHover(EventHandler value);
public void add_MouseLeave(EventHandler value);
public void add_MouseMove(MouseEventHandler value);
public void add_MouseUp(MouseEventHandler value);
public void add_MouseWheel(MouseEventHandler value);
public void add_Move(EventHandler value);
public void add_Navigate(NavigateEventHandler value);
public void add_Paint(PaintEventHandler value);
public void add_ParentChanged(EventHandler value);
public void add_ParentRowsLabelStyleChanged(EventHandler value);
public void add_ParentRowsVisibleChanged(EventHandler value);
public void add_QueryAccessibilityHelp(QueryAccessibilityHelpEventHandler value);
public void add_QueryContinueDrag(QueryContinueDragEventHandler value);
public void add_ReadOnlyChanged(EventHandler value);
public void add_Resize(EventHandler value);
public void add_RightToLeftChanged(EventHandler value);
protected void add_RowHeaderClick(EventHandler value);
public void add_Scroll(EventHandler value);
public void add_ShowParentDetailsButtonClick(EventHandler value);
public void add_SizeChanged(EventHandler value);
public void add_StyleChanged(EventHandler value);
public void add_SystemColorsChanged(EventHandler value);
public void add_TabIndexChanged(EventHandler value);
public void add_TabStopChanged(EventHandler value);
public void add_TextChanged(EventHandler value);
public void add_Validated(EventHandler value);
public void add_Validating(CancelEventHandler value);
public void add_VisibleChanged(EventHandler value);
public virtual bool BeginEdit(DataGridColumnStyle gridColumn, int rowNumber);
public virtual void BeginInit();
public IAsyncResult BeginInvoke(Delegate method);
public IAsyncResult BeginInvoke(Delegate method, object[] args);
public void BringToFront();
protected virtual void CancelEditing();
public void Collapse(int row);
public bool Contains(Control ctl);
protected virtual AccessibleObject CreateAccessibilityInstance();
public void CreateControl();
protected virtual ControlCollection CreateControlsInstance();
public Graphics CreateGraphics();
protected virtual DataGridColumnStyle CreateGridColumn(PropertyDescriptor prop);
protected virtual DataGridColumnStyle CreateGridColumn(PropertyDescriptor prop, bool isDefault);
protected virtual void CreateHandle();
public ObjRef CreateObjRef(Type requestedType);
protected virtual void DefWndProc(ref Message m);
protected virtual void DestroyHandle();
public void Dispose();
protected override void Dispose(bool disposing);
public DragDropEffects DoDragDrop(object data, DragDropEffects allowedEffects);
public virtual bool EndEdit(DataGridColumnStyle gridColumn, int rowNumber, bool shouldAbort);
public virtual void EndInit();
public object EndInvoke(IAsyncResult asyncResult);
public virtual bool Equals(object obj);
public void Expand(int row);
protected override void Finalize();
public Form FindForm();
public bool Focus();
public Rectangle GetCellBounds(DataGridCell dgc);
public Rectangle GetCellBounds(int irow, int icol);
public Control GetChildAtPoint(Point pt);
public IContainerControl GetContainerControl();
public Rectangle GetCurrentCellBounds();
public virtual int GetHashCode();
public object GetLifetimeService();
public Control GetNextControl(Control ctl, bool forward);
protected virtual string GetOutputTextDelimiter();
protected virtual object GetService(Type service);
protected bool GetStyle(ControlStyles flag);
protected bool GetTopLevel();
public Type GetType();
protected virtual void GridHScrolled(object sender, ScrollEventArgs se);
protected virtual void GridVScrolled(object sender, ScrollEventArgs se);
public void Hide();
public HitTestInfo HitTest(int x, int y);
public HitTestInfo HitTest(Point position);
public object InitializeLifetimeService();
protected virtual void InitLayout();
public void Invalidate();
public void Invalidate(bool invalidateChildren);
public void Invalidate(Rectangle rect);
public void Invalidate(Rectangle rc, bool invalidateChildren);
public void Invalidate(Region region);
public void Invalidate(Region region, bool invalidateChildren);
public object Invoke(Delegate method);
public object Invoke(Delegate method, object[] args);
protected void InvokeGotFocus(Control toInvoke, EventArgs e);
protected void InvokeLostFocus(Control toInvoke, EventArgs e);
protected void InvokeOnClick(Control toInvoke, EventArgs e);
protected void InvokePaint(Control c, PaintEventArgs e);
protected void InvokePaintBackground(Control c, PaintEventArgs e);
public bool IsExpanded(int rowNumber);
protected virtual bool IsInputChar(char charCode);
protected virtual bool IsInputKey(Keys keyData);
public bool IsSelected(int irowTest);
protected object MemberwiseClone();
public void NavigateBack();
public void NavigateTo(int rowNumber, string relationName);
protected virtual void NotifyInvalidate(Rectangle invalidatedArea);
protected virtual void OnAllowNavigationChanged(EventArgs e);
protected void OnBackButtonClicked(object sender, EventArgs e);
protected virtual void OnBackColorChanged(EventArgs e);
protected virtual void OnBackgroundColorChanged(EventArgs e);
protected virtual void OnBackgroundImageChanged(EventArgs e);
protected override void OnBindingContextChanged(EventArgs e);
protected virtual void OnBorderStyleChanged(EventArgs e);
protected virtual void OnCaptionVisibleChanged(EventArgs e);
protected virtual void OnCausesValidationChanged(EventArgs e);
protected virtual void OnChangeUICues(UICuesEventArgs e);
protected virtual void OnClick(EventArgs e);
protected virtual void OnContextMenuChanged(EventArgs e);
protected virtual void OnControlAdded(ControlEventArgs e);
protected virtual void OnControlRemoved(ControlEventArgs e);
protected virtual void OnCreateControl();
protected virtual void OnCurrentCellChanged(EventArgs e);
protected virtual void OnCursorChanged(EventArgs e);
protected virtual void OnDataSourceChanged(EventArgs e);
protected virtual void OnDockChanged(EventArgs e);
protected virtual void OnDoubleClick(EventArgs e);
protected virtual void OnDragDrop(DragEventArgs drgevent);
protected virtual void OnDragEnter(DragEventArgs drgevent);
protected virtual void OnDragLeave(EventArgs e);
protected virtual void OnDragOver(DragEventArgs drgevent);
protected virtual void OnEnabledChanged(EventArgs e);
protected virtual void OnEnter(EventArgs e);
protected virtual void OnFlatModeChanged(EventArgs e);
protected virtual void OnFontChanged(EventArgs e);
protected virtual void OnForeColorChanged(EventArgs e);
protected virtual void OnGiveFeedback(GiveFeedbackEventArgs gfbevent);
protected override void OnGotFocus(EventArgs e);
protected virtual void OnHandleCreated(EventArgs e);
protected virtual void OnHandleDestroyed(EventArgs e);
protected virtual void OnHelpRequested(HelpEventArgs hevent);
protected virtual void OnImeModeChanged(EventArgs e);
protected virtual void OnInvalidated(InvalidateEventArgs e);
protected override void OnKeyDown(KeyEventArgs kea);
protected virtual void OnKeyPress(KeyPressEventArgs e);
protected virtual void OnKeyUp(KeyEventArgs e);
protected virtual void OnLayout(LayoutEventArgs levent);
protected virtual void OnLeave(EventArgs e);
protected virtual void OnLocationChanged(EventArgs e);
protected override void OnLostFocus(EventArgs e);
protected override void OnMouseDown(MouseEventArgs mea);
protected virtual void OnMouseEnter(EventArgs e);
protected virtual void OnMouseHover(EventArgs e);
protected virtual void OnMouseLeave(EventArgs e);
protected override void OnMouseMove(MouseEventArgs mea);
protected override void OnMouseUp(MouseEventArgs mea);
protected virtual void OnMouseWheel(MouseEventArgs e);
protected virtual void OnMove(EventArgs e);
protected void OnNavigate(NavigateEventArgs e);
protected virtual void OnNotifyMessage(Message m);
protected override void OnPaint(PaintEventArgs pea);
protected override void OnPaintBackground(PaintEventArgs pea);
protected virtual void OnParentBackColorChanged(EventArgs e);
protected virtual void OnParentBackgroundImageChanged(EventArgs e);
protected virtual void OnParentBindingContextChanged(EventArgs e);
protected virtual void OnParentChanged(EventArgs e);
protected virtual void OnParentEnabledChanged(EventArgs e);
protected virtual void OnParentFontChanged(EventArgs e);
protected virtual void OnParentForeColorChanged(EventArgs e);
protected virtual void OnParentRightToLeftChanged(EventArgs e);
protected virtual void OnParentRowsLabelStyleChanged(EventArgs e);
protected virtual void OnParentRowsVisibleChanged(EventArgs e);
protected virtual void OnParentVisibleChanged(EventArgs e);
protected virtual void OnQueryContinueDrag(QueryContinueDragEventArgs qcdevent);
protected virtual void OnReadOnlyChanged(EventArgs e);
protected override void OnResize(EventArgs ea);
protected virtual void OnRightToLeftChanged(EventArgs e);
protected void OnRowHeaderClick(EventArgs e);
protected void OnScroll(EventArgs e);
protected void OnShowParentDetailsButtonClicked(object sender, EventArgs e);
protected virtual void OnSizeChanged(EventArgs e);
protected virtual void OnStyleChanged(EventArgs e);
protected virtual void OnSystemColorsChanged(EventArgs e);
protected virtual void OnTabIndexChanged(EventArgs e);
protected virtual void OnTabStopChanged(EventArgs e);
protected virtual void OnTextChanged(EventArgs e);
protected virtual void OnValidated(EventArgs e);
protected virtual void OnValidating(CancelEventArgs e);
protected virtual void OnVisibleChanged(EventArgs e);
public void PerformLayout();
public void PerformLayout(Control affectedControl, string affectedProperty);
public Point PointToClient(Point p);
public Point PointToScreen(Point p);
public bool PreProcessMessage(ref Message msg);
protected virtual bool ProcessCmdKey(ref Message msg, Keys keyData);
protected virtual bool ProcessDialogChar(char charCode);
protected virtual bool ProcessDialogKey(Keys keyData);
protected bool ProcessGridKey(KeyEventArgs ke);
protected virtual bool ProcessKeyEventArgs(ref Message m);
protected virtual bool ProcessKeyPreview(ref Message m);
protected virtual bool ProcessMnemonic(char charCode);
protected bool ProcessTabKey(Keys keyData);
protected void RaiseDragEvent(object key, DragEventArgs e);
protected void RaiseKeyEvent(object key, KeyEventArgs e);
protected void RaiseMouseEvent(object key, MouseEventArgs e);
protected void RaisePaintEvent(object key, PaintEventArgs e);
protected void RecreateHandle();
public Rectangle RectangleToClient(Rectangle r);
public Rectangle RectangleToScreen(Rectangle r);
public virtual void Refresh();
public void remove_AllowNavigationChanged(EventHandler value);
public void remove_BackButtonClick(EventHandler value);
public void remove_BackColorChanged(EventHandler value);
public void remove_BackgroundColorChanged(EventHandler value);
public void remove_BackgroundImageChanged(EventHandler value);
public void remove_BindingContextChanged(EventHandler value);
public void remove_BorderStyleChanged(EventHandler value);
public void remove_CaptionVisibleChanged(EventHandler value);
public void remove_CausesValidationChanged(EventHandler value);
public void remove_ChangeUICues(UICuesEventHandler value);
public void remove_Click(EventHandler value);
public void remove_ContextMenuChanged(EventHandler value);
public void remove_ControlAdded(ControlEventHandler value);
public void remove_ControlRemoved(ControlEventHandler value);
public void remove_CurrentCellChanged(EventHandler value);
public void remove_CursorChanged(EventHandler value);
public void remove_DataSourceChanged(EventHandler value);
public void remove_Disposed(EventHandler value);
public void remove_DockChanged(EventHandler value);
public void remove_DoubleClick(EventHandler value);
public void remove_DragDrop(DragEventHandler value);
public void remove_DragEnter(DragEventHandler value);
public void remove_DragLeave(EventHandler value);
public void remove_DragOver(DragEventHandler value);
public void remove_EnabledChanged(EventHandler value);
public void remove_Enter(EventHandler value);
public void remove_FlatModeChanged(EventHandler value);
public void remove_FontChanged(EventHandler value);
public void remove_ForeColorChanged(EventHandler value);
public void remove_GiveFeedback(GiveFeedbackEventHandler value);
public void remove_GotFocus(EventHandler value);
public void remove_HandleCreated(EventHandler value);
public void remove_HandleDestroyed(EventHandler value);
public void remove_HelpRequested(HelpEventHandler value);
public void remove_ImeModeChanged(EventHandler value);
public void remove_Invalidated(InvalidateEventHandler value);
public void remove_KeyDown(KeyEventHandler value);
public void remove_KeyPress(KeyPressEventHandler value);
public void remove_KeyUp(KeyEventHandler value);
public void remove_Layout(LayoutEventHandler value);
public void remove_Leave(EventHandler value);
public void remove_LocationChanged(EventHandler value);
public void remove_LostFocus(EventHandler value);
public void remove_MouseDown(MouseEventHandler value);
public void remove_MouseEnter(EventHandler value);
public void remove_MouseHover(EventHandler value);
public void remove_MouseLeave(EventHandler value);
public void remove_MouseMove(MouseEventHandler value);
public void remove_MouseUp(MouseEventHandler value);
public void remove_MouseWheel(MouseEventHandler value);
public void remove_Move(EventHandler value);
public void remove_Navigate(NavigateEventHandler value);
public void remove_Paint(PaintEventHandler value);
public void remove_ParentChanged(EventHandler value);
public void remove_ParentRowsLabelStyleChanged(EventHandler value);
public void remove_ParentRowsVisibleChanged(EventHandler value);
public void remove_QueryAccessibilityHelp(QueryAccessibilityHelpEventHandler value);
public void remove_QueryContinueDrag(QueryContinueDragEventHandler value);
public void remove_ReadOnlyChanged(EventHandler value);
public void remove_Resize(EventHandler value);
public void remove_RightToLeftChanged(EventHandler value);
protected void remove_RowHeaderClick(EventHandler value);
public void remove_Scroll(EventHandler value);
public void remove_ShowParentDetailsButtonClick(EventHandler value);
public void remove_SizeChanged(EventHandler value);
public void remove_StyleChanged(EventHandler value);
public void remove_SystemColorsChanged(EventHandler value);
public void remove_TabIndexChanged(EventHandler value);
public void remove_TabStopChanged(EventHandler value);
public void remove_TextChanged(EventHandler value);
public void remove_Validated(EventHandler value);
public void remove_Validating(CancelEventHandler value);
public void remove_VisibleChanged(EventHandler value);
public void ResetAlternatingBackColor();
public override void ResetBackColor();
public void ResetBindings();
public void ResetCursor();
public void ResetFont();
public override void ResetForeColor();
public void ResetGridLineColor();
public void ResetHeaderBackColor();
public void ResetHeaderFont();
public void ResetHeaderForeColor();
public void ResetImeMode();
public void ResetLinkColor();
public void ResetLinkHoverColor();
protected void ResetMouseEventArgs();
public void ResetRightToLeft();
protected void ResetSelection();
public void ResetSelectionBackColor();
public void ResetSelectionForeColor();
public void ResetText();
public void ResumeLayout();
public void ResumeLayout(bool performLayout);
protected ContentAlignment RtlTranslateAlignment(ContentAlignment align);
protected HorizontalAlignment RtlTranslateAlignment(HorizontalAlignment align);
protected LeftRightAlignment RtlTranslateAlignment(LeftRightAlignment align);
protected ContentAlignment RtlTranslateContent(ContentAlignment align);
protected HorizontalAlignment RtlTranslateHorizontal(HorizontalAlignment align);
protected LeftRightAlignment RtlTranslateLeftRight(LeftRightAlignment align);
public void Scale(float ratio);
public void Scale(float dx, float dy);
protected virtual void ScaleCore(float dx, float dy);
public void Select();
protected virtual void Select(bool directed, bool forward);
public void Select(int irowSel);
public bool SelectNextControl(Control ctl, bool forward, bool tabStopOnly, bool nested, bool wrap);
public void SendToBack();
public void SetBounds(int x, int y, int width, int height);
public void SetBounds(int x, int y, int width, int height, BoundsSpecified specified);
protected virtual void SetBoundsCore(int x, int y, int width, int height, BoundsSpecified specified);
protected virtual void SetClientSizeCore(int x, int y);
public void SetDataBinding(object dataSource, string dataMember);
protected void SetStyle(ControlStyles flag, bool value);
protected void SetTopLevel(bool value);
protected virtual void SetVisibleCore(bool value);
protected virtual bool ShouldSerializeAlternatingBackColor();
protected virtual bool ShouldSerializeBackgroundColor();
protected virtual bool ShouldSerializeCaptionBackColor();
protected virtual bool ShouldSerializeCaptionForeColor();
protected virtual bool ShouldSerializeGridLineColor();
protected virtual bool ShouldSerializeHeaderBackColor();
protected bool ShouldSerializeHeaderFont();
protected virtual bool ShouldSerializeHeaderForeColor();
protected virtual bool ShouldSerializeLinkHoverColor();
protected virtual bool ShouldSerializeParentRowsBackColor();
protected virtual bool ShouldSerializeParentRowsForeColor();
protected bool ShouldSerializePreferredRowHeight();
protected bool ShouldSerializeSelectionBackColor();
protected virtual bool ShouldSerializeSelectionForeColor();
public void Show();
public void SubObjectsSiteChange(bool site);
public void SuspendLayout();
public virtual string ToString();
public void UnSelect(int irowUnsel);
public void Update();
protected void UpdateBounds();
protected void UpdateBounds(int x, int y, int width, int height);
protected void UpdateBounds(int x, int y, int width, int height, int clientWidth, int clientHeight);
protected void UpdateStyles();
protected void UpdateZOrder();
protected virtual void WndProc(ref Message m);

Property
public AccessibleObject AccessibilityObject {get;}
public string AccessibleDefaultActionDescription {get; set;}
public string AccessibleDescription {get; set;}
public string AccessibleName {get; set;}
public AccessibleRole AccessibleRole {get; set;}
public bool AllowDrop {get; set;}
public bool AllowNavigation {get; set;}
public bool AllowSorting {get; set;}
public Color AlternatingBackColor {get; set;}
public AnchorStyles Anchor {get; set;}
public override Color BackColor {get; set;}
public Color BackgroundColor {get; set;}
public override Image BackgroundImage {get; set;}
public virtual BindingContext BindingContext {get; set;}
public BorderStyle BorderStyle {get; set;}
public int Bottom {get;}
public Rectangle Bounds {get; set;}
public bool CanFocus {get;}
public bool CanSelect {get;}
public Color CaptionBackColor {get; set;}
public Font CaptionFont {get; set;}
public Color CaptionForeColor {get; set;}
public string CaptionText {get; set;}
public bool CaptionVisible {get; set;}
public bool Capture {get; set;}
public bool CausesValidation {get; set;}
public Rectangle ClientRectangle {get;}
public Size ClientSize {get; set;}
public bool ColumnHeadersVisible {get; set;}
public string CompanyName {get;}
public IContainer Container {get;}
public bool ContainsFocus {get;}
public ContextMenu ContextMenu {get; set;}
public ControlCollection Controls {get;}
public bool Created {get;}
protected virtual CreateParams CreateParams {get;}
public DataGridCell CurrentCell {get; set;}
public int CurrentRowIndex {get; set;}
public override Cursor Cursor {get; set;}
public ControlBindingsCollection DataBindings {get;}
public string DataMember {get; set;}
public object DataSource {get; set;}
protected virtual ImeMode DefaultImeMode {get;}
protected virtual Size DefaultSize {get;}
protected bool DesignMode {get;}
public Rectangle DisplayRectangle {get;}
public bool Disposing {get;}
public DockStyle Dock {get; set;}
public bool Enabled {get; set;}
protected EventHandlerList Events {get;}
public int FirstVisibleColumn {get;}
public bool FlatMode {get; set;}
public bool Focused {get;}
public override Font Font {get; set;}
public override Color ForeColor {get; set;}
public Color GridLineColor {get; set;}
public DataGridLineStyle GridLineStyle {get; set;}
public IntPtr Handle {get;}
public bool HasChildren {get;}
public Color HeaderBackColor {get; set;}
public Font HeaderFont {get; set;}
public Color HeaderForeColor {get; set;}
public int Height {get; set;}
protected ScrollBar HorizScrollBar {get;}
public ImeMode ImeMode {get; set;}
public bool InvokeRequired {get;}
public bool IsAccessible {get; set;}
public bool IsDisposed {get;}
public bool IsHandleCreated {get;}
public object this[DataGridCell cell] {get; set;}
public object this[int irow, int icol] {get; set;}
public int Left {get; set;}
public Color LinkColor {get; set;}
public Color LinkHoverColor {get; set;}
public Point Location {get; set;}
public string Name {get; set;}
public Control Parent {get; set;}
public Color ParentRowsBackColor {get; set;}
public Color ParentRowsForeColor {get; set;}
public DataGridParentRowsLabelStyle ParentRowsLabelStyle {get; set;}
public bool ParentRowsVisible {get; set;}
public int PreferredColumnWidth {get; set;}
public int PreferredRowHeight {get; set;}
public string ProductName {get;}
public string ProductVersion {get;}
public bool ReadOnly {get; set;}
public bool RecreatingHandle {get;}
public Region Region {get; set;}
protected bool RenderRightToLeft {get;}
protected bool ResizeRedraw {get; set;}
public int Right {get;}
public RightToLeft RightToLeft {get; set;}
public bool RowHeadersVisible {get; set;}
public int RowHeaderWidth {get; set;}
public Color SelectionBackColor {get; set;}
public Color SelectionForeColor {get; set;}
protected virtual bool ShowFocusCues {get;}
protected bool ShowKeyboardCues {get;}
public override ISite Site {get; set;}
public Size Size {get; set;}
public int TabIndex {get; set;}
public GridTableStylesCollection TableStyles {get;}
public bool TabStop {get; set;}
public object Tag {get; set;}
public virtual string Text {get; set;}
public int Top {get; set;}
public Control TopLevelControl {get;}
protected ScrollBar VertScrollBar {get;}
public bool Visible {get; set;}
public int VisibleColumnCount {get;}
public int VisibleRowCount {get;}
public int Width {get; set;}
public IWindowTarget WindowTarget {get; set;}

System.Windows.Forms.TreeViewEventHandler

Module:System.Windows.Forms.dll

Hierarchy
Object
Delegate
MulticastDelegate
TreeViewEventHandler

Type declaration

[C#] public delegate void TreeViewEventHandler(object sender, TreeViewEventArgs e);

Constructor
public TreeViewEventHandler(object object, IntPtr method);

Method
public virtual IAsyncResult BeginInvoke(object sender, TreeViewEventArgs e, AsyncCallback callback, object object);
public object Clone();
protected override Delegate CombineImpl(Delegate follow);
public object DynamicInvoke(object[] args);
protected virtual object DynamicInvokeImpl(object[] args);
public virtual void EndInvoke(IAsyncResult result);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public override Delegate[] GetInvocationList();
protected virtual MethodInfo GetMethodImpl();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
public override void Invoke(object sender, TreeViewEventArgs e);
protected object MemberwiseClone();
protected override Delegate RemoveImpl(Delegate value);
public virtual string ToString();

Property
public MethodInfo Method {get;}
public object Target {get;}

System.Windows.Forms.TreeViewEventArgs

Module:System.Windows.Forms.dll

Hierarchy
Object
EventArgs
TreeViewEventArgs

Type declaration

[C#] public class TreeViewEventArgs : EventArgs;

Constructor
public TreeViewEventArgs(TreeNode node);
public TreeViewEventArgs(TreeNode tn, TreeViewAction tva);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public TreeViewAction Action {get;}
public TreeNode Node {get;}

System.Windows.Forms.TreeViewCancelEventHandler

Module:System.Windows.Forms.dll

Hierarchy
Object
Delegate
MulticastDelegate
TreeViewCancelEventHandler

Type declaration

[C#] public delegate void TreeViewCancelEventHandler(object sender, TreeViewCancelEventArgs e);

Constructor
public TreeViewCancelEventHandler(object object, IntPtr method);

Method
public virtual IAsyncResult BeginInvoke(object sender, TreeViewCancelEventArgs e, AsyncCallback callback, object object);
public object Clone();
protected override Delegate CombineImpl(Delegate follow);
public object DynamicInvoke(object[] args);
protected virtual object DynamicInvokeImpl(object[] args);
public virtual void EndInvoke(IAsyncResult result);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public override Delegate[] GetInvocationList();
protected virtual MethodInfo GetMethodImpl();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
public override void Invoke(object sender, TreeViewCancelEventArgs e);
protected object MemberwiseClone();
protected override Delegate RemoveImpl(Delegate value);
public virtual string ToString();

Property
public MethodInfo Method {get;}
public object Target {get;}

System.Windows.Forms.TreeViewCancelEventArgs

Module:System.Windows.Forms.dll

Hierarchy
Object
EventArgs
CancelEventArgs
TreeViewCancelEventArgs

Type declaration

[C#] public class TreeViewCancelEventArgs : CancelEventArgs;

Constructor
public TreeViewCancelEventArgs(TreeNode tn, bool fCancel, TreeViewAction tva);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public TreeViewAction Action {get;}
public bool Cancel {get; set;}
public TreeNode Node {get;}

System.Windows.Forms.TreeViewAction

Module:System.Windows.Forms.dll

Hierarchy
Object
ValueType
Enum
TreeViewAction

Type declaration

[C#] public enum TreeViewAction;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const TreeViewAction ByKeyboard = 1;
public const TreeViewAction ByMouse = 2;
public const TreeViewAction Collapse = 3;
public const TreeViewAction Expand = 4;
public const TreeViewAction Unknown = 0;
public int value__;

System.Windows.Forms.TreeView

Module:System.Windows.Forms.dll

Hierarchy
Object
MarshalByRefObject
Component
Control
TreeView

Type declaration

[C#] public class TreeView : Control;

Constructor
public TreeView();

Method
protected void AccessibilityNotifyClients(AccessibleEvents accEvent, int childID);
public void add_AfterCheck(TreeViewEventHandler value);
public void add_AfterCollapse(TreeViewEventHandler value);
public void add_AfterExpand(TreeViewEventHandler value);
public void add_AfterLabelEdit(NodeLabelEditEventHandler value);
public void add_AfterSelect(TreeViewEventHandler value);
public void add_BackColorChanged(EventHandler value);
public void add_BackgroundImageChanged(EventHandler value);
public void add_BeforeCheck(TreeViewCancelEventHandler value);
public void add_BeforeCollapse(TreeViewCancelEventHandler value);
public void add_BeforeExpand(TreeViewCancelEventHandler value);
public void add_BeforeLabelEdit(NodeLabelEditEventHandler value);
public void add_BeforeSelect(TreeViewCancelEventHandler value);
public void add_BindingContextChanged(EventHandler value);
public void add_CausesValidationChanged(EventHandler value);
public void add_ChangeUICues(UICuesEventHandler value);
public void add_Click(EventHandler value);
public void add_ContextMenuChanged(EventHandler value);
public void add_ControlAdded(ControlEventHandler value);
public void add_ControlRemoved(ControlEventHandler value);
public void add_CursorChanged(EventHandler value);
public void add_Disposed(EventHandler value);
public void add_DockChanged(EventHandler value);
public void add_DoubleClick(EventHandler value);
public void add_DragDrop(DragEventHandler value);
public void add_DragEnter(DragEventHandler value);
public void add_DragLeave(EventHandler value);
public void add_DragOver(DragEventHandler value);
public void add_EnabledChanged(EventHandler value);
public void add_Enter(EventHandler value);
public void add_FontChanged(EventHandler value);
public void add_ForeColorChanged(EventHandler value);
public void add_GiveFeedback(GiveFeedbackEventHandler value);
public void add_GotFocus(EventHandler value);
public void add_HandleCreated(EventHandler value);
public void add_HandleDestroyed(EventHandler value);
public void add_HelpRequested(HelpEventHandler value);
public void add_ImeModeChanged(EventHandler value);
public void add_Invalidated(InvalidateEventHandler value);
public void add_ItemDrag(ItemDragEventHandler value);
public void add_KeyDown(KeyEventHandler value);
public void add_KeyPress(KeyPressEventHandler value);
public void add_KeyUp(KeyEventHandler value);
public void add_Layout(LayoutEventHandler value);
public void add_Leave(EventHandler value);
public void add_LocationChanged(EventHandler value);
public void add_LostFocus(EventHandler value);
public void add_MouseDown(MouseEventHandler value);
public void add_MouseEnter(EventHandler value);
public void add_MouseHover(EventHandler value);
public void add_MouseLeave(EventHandler value);
public void add_MouseMove(MouseEventHandler value);
public void add_MouseUp(MouseEventHandler value);
public void add_MouseWheel(MouseEventHandler value);
public void add_Move(EventHandler value);
public void add_Paint(PaintEventHandler value);
public void add_ParentChanged(EventHandler value);
public void add_QueryAccessibilityHelp(QueryAccessibilityHelpEventHandler value);
public void add_QueryContinueDrag(QueryContinueDragEventHandler value);
public void add_Resize(EventHandler value);
public void add_RightToLeftChanged(EventHandler value);
public void add_SizeChanged(EventHandler value);
public void add_StyleChanged(EventHandler value);
public void add_SystemColorsChanged(EventHandler value);
public void add_TabIndexChanged(EventHandler value);
public void add_TabStopChanged(EventHandler value);
public void add_TextChanged(EventHandler value);
public void add_Validated(EventHandler value);
public void add_Validating(CancelEventHandler value);
public void add_VisibleChanged(EventHandler value);
public IAsyncResult BeginInvoke(Delegate method);
public IAsyncResult BeginInvoke(Delegate method, object[] args);
public void BeginUpdate();
public void BringToFront();
public void CollapseAll();
public bool Contains(Control ctl);
protected virtual AccessibleObject CreateAccessibilityInstance();
public void CreateControl();
protected virtual ControlCollection CreateControlsInstance();
public Graphics CreateGraphics();
protected virtual void CreateHandle();
public ObjRef CreateObjRef(Type requestedType);
protected virtual void DefWndProc(ref Message m);
protected virtual void DestroyHandle();
public void Dispose();
protected override void Dispose(bool disposing);
public DragDropEffects DoDragDrop(object data, DragDropEffects allowedEffects);
public object EndInvoke(IAsyncResult asyncResult);
public void EndUpdate();
public virtual bool Equals(object obj);
public void ExpandAll();
protected override void Finalize();
public Form FindForm();
public bool Focus();
public Control GetChildAtPoint(Point pt);
public IContainerControl GetContainerControl();
public virtual int GetHashCode();
protected OwnerDrawPropertyBag GetItemRenderStyles(TreeNode node, int state);
public object GetLifetimeService();
public Control GetNextControl(Control ctl, bool forward);
public TreeNode GetNodeAt(int x, int y);
public TreeNode GetNodeAt(Point pt);
public int GetNodeCount(bool fIncludeSubTrees);
protected virtual object GetService(Type service);
protected bool GetStyle(ControlStyles flag);
protected bool GetTopLevel();
public Type GetType();
public void Hide();
public object InitializeLifetimeService();
protected virtual void InitLayout();
public void Invalidate();
public void Invalidate(bool invalidateChildren);
public void Invalidate(Rectangle rect);
public void Invalidate(Rectangle rc, bool invalidateChildren);
public void Invalidate(Region region);
public void Invalidate(Region region, bool invalidateChildren);
public object Invoke(Delegate method);
public object Invoke(Delegate method, object[] args);
protected void InvokeGotFocus(Control toInvoke, EventArgs e);
protected void InvokeLostFocus(Control toInvoke, EventArgs e);
protected void InvokeOnClick(Control toInvoke, EventArgs e);
protected void InvokePaint(Control c, PaintEventArgs e);
protected void InvokePaintBackground(Control c, PaintEventArgs e);
protected virtual bool IsInputChar(char charCode);
protected virtual bool IsInputKey(Keys keyData);
protected object MemberwiseClone();
protected virtual void NotifyInvalidate(Rectangle invalidatedArea);
protected virtual void OnAfterCheck(TreeViewEventArgs e);
protected virtual void OnAfterCollapse(TreeViewEventArgs e);
protected virtual void OnAfterExpand(TreeViewEventArgs e);
protected virtual void OnAfterLabelEdit(NodeLabelEditEventArgs e);
protected virtual void OnAfterSelect(TreeViewEventArgs e);
protected virtual void OnBackColorChanged(EventArgs e);
protected virtual void OnBackgroundImageChanged(EventArgs e);
protected virtual void OnBeforeCheck(TreeViewCancelEventArgs e);
protected virtual void OnBeforeCollapse(TreeViewCancelEventArgs e);
protected virtual void OnBeforeExpand(TreeViewCancelEventArgs e);
protected virtual void OnBeforeLabelEdit(NodeLabelEditEventArgs e);
protected virtual void OnBeforeSelect(TreeViewCancelEventArgs e);
protected virtual void OnBindingContextChanged(EventArgs e);
protected virtual void OnCausesValidationChanged(EventArgs e);
protected virtual void OnChangeUICues(UICuesEventArgs e);
protected virtual void OnClick(EventArgs e);
protected virtual void OnContextMenuChanged(EventArgs e);
protected virtual void OnControlAdded(ControlEventArgs e);
protected virtual void OnControlRemoved(ControlEventArgs e);
protected virtual void OnCreateControl();
protected virtual void OnCursorChanged(EventArgs e);
protected virtual void OnDockChanged(EventArgs e);
protected virtual void OnDoubleClick(EventArgs e);
protected virtual void OnDragDrop(DragEventArgs drgevent);
protected virtual void OnDragEnter(DragEventArgs drgevent);
protected virtual void OnDragLeave(EventArgs e);
protected virtual void OnDragOver(DragEventArgs drgevent);
protected virtual void OnEnabledChanged(EventArgs e);
protected virtual void OnEnter(EventArgs e);
protected virtual void OnFontChanged(EventArgs e);
protected virtual void OnForeColorChanged(EventArgs e);
protected virtual void OnGiveFeedback(GiveFeedbackEventArgs gfbevent);
protected virtual void OnGotFocus(EventArgs e);
protected virtual void OnHandleCreated(EventArgs e);
protected virtual void OnHandleDestroyed(EventArgs e);
protected virtual void OnHelpRequested(HelpEventArgs hevent);
protected virtual void OnImeModeChanged(EventArgs e);
protected virtual void OnInvalidated(InvalidateEventArgs e);
protected virtual void OnItemDrag(ItemDragEventArgs e);
protected virtual void OnKeyDown(KeyEventArgs e);
protected virtual void OnKeyPress(KeyPressEventArgs e);
protected virtual void OnKeyUp(KeyEventArgs e);
protected virtual void OnLayout(LayoutEventArgs levent);
protected virtual void OnLeave(EventArgs e);
protected virtual void OnLocationChanged(EventArgs e);
protected virtual void OnLostFocus(EventArgs e);
protected virtual void OnMouseDown(MouseEventArgs e);
protected virtual void OnMouseEnter(EventArgs e);
protected virtual void OnMouseHover(EventArgs e);
protected virtual void OnMouseLeave(EventArgs e);
protected virtual void OnMouseMove(MouseEventArgs e);
protected virtual void OnMouseUp(MouseEventArgs e);
protected virtual void OnMouseWheel(MouseEventArgs e);
protected virtual void OnMove(EventArgs e);
protected virtual void OnNotifyMessage(Message m);
protected virtual void OnPaint(PaintEventArgs e);
protected virtual void OnPaintBackground(PaintEventArgs e);
protected virtual void OnParentBackColorChanged(EventArgs e);
protected virtual void OnParentBackgroundImageChanged(EventArgs e);
protected virtual void OnParentBindingContextChanged(EventArgs e);
protected virtual void OnParentChanged(EventArgs e);
protected virtual void OnParentEnabledChanged(EventArgs e);
protected virtual void OnParentFontChanged(EventArgs e);
protected virtual void OnParentForeColorChanged(EventArgs e);
protected virtual void OnParentRightToLeftChanged(EventArgs e);
protected virtual void OnParentVisibleChanged(EventArgs e);
protected virtual void OnQueryContinueDrag(QueryContinueDragEventArgs qcdevent);
protected virtual void OnResize(EventArgs e);
protected virtual void OnRightToLeftChanged(EventArgs e);
protected virtual void OnSizeChanged(EventArgs e);
protected virtual void OnStyleChanged(EventArgs e);
protected virtual void OnSystemColorsChanged(EventArgs e);
protected virtual void OnTabIndexChanged(EventArgs e);
protected virtual void OnTabStopChanged(EventArgs e);
protected virtual void OnTextChanged(EventArgs e);
protected virtual void OnValidated(EventArgs e);
protected virtual void OnValidating(CancelEventArgs e);
protected virtual void OnVisibleChanged(EventArgs e);
public void PerformLayout();
public void PerformLayout(Control affectedControl, string affectedProperty);
public Point PointToClient(Point p);
public Point PointToScreen(Point p);
public bool PreProcessMessage(ref Message msg);
protected virtual bool ProcessCmdKey(ref Message msg, Keys keyData);
protected virtual bool ProcessDialogChar(char charCode);
protected virtual bool ProcessDialogKey(Keys keyData);
protected virtual bool ProcessKeyEventArgs(ref Message m);
protected virtual bool ProcessKeyPreview(ref Message m);
protected virtual bool ProcessMnemonic(char charCode);
protected void RaiseDragEvent(object key, DragEventArgs e);
protected void RaiseKeyEvent(object key, KeyEventArgs e);
protected void RaiseMouseEvent(object key, MouseEventArgs e);
protected void RaisePaintEvent(object key, PaintEventArgs e);
protected void RecreateHandle();
public Rectangle RectangleToClient(Rectangle r);
public Rectangle RectangleToScreen(Rectangle r);
public virtual void Refresh();
public void remove_AfterCheck(TreeViewEventHandler value);
public void remove_AfterCollapse(TreeViewEventHandler value);
public void remove_AfterExpand(TreeViewEventHandler value);
public void remove_AfterLabelEdit(NodeLabelEditEventHandler value);
public void remove_AfterSelect(TreeViewEventHandler value);
public void remove_BackColorChanged(EventHandler value);
public void remove_BackgroundImageChanged(EventHandler value);
public void remove_BeforeCheck(TreeViewCancelEventHandler value);
public void remove_BeforeCollapse(TreeViewCancelEventHandler value);
public void remove_BeforeExpand(TreeViewCancelEventHandler value);
public void remove_BeforeLabelEdit(NodeLabelEditEventHandler value);
public void remove_BeforeSelect(TreeViewCancelEventHandler value);
public void remove_BindingContextChanged(EventHandler value);
public void remove_CausesValidationChanged(EventHandler value);
public void remove_ChangeUICues(UICuesEventHandler value);
public void remove_Click(EventHandler value);
public void remove_ContextMenuChanged(EventHandler value);
public void remove_ControlAdded(ControlEventHandler value);
public void remove_ControlRemoved(ControlEventHandler value);
public void remove_CursorChanged(EventHandler value);
public void remove_Disposed(EventHandler value);
public void remove_DockChanged(EventHandler value);
public void remove_DoubleClick(EventHandler value);
public void remove_DragDrop(DragEventHandler value);
public void remove_DragEnter(DragEventHandler value);
public void remove_DragLeave(EventHandler value);
public void remove_DragOver(DragEventHandler value);
public void remove_EnabledChanged(EventHandler value);
public void remove_Enter(EventHandler value);
public void remove_FontChanged(EventHandler value);
public void remove_ForeColorChanged(EventHandler value);
public void remove_GiveFeedback(GiveFeedbackEventHandler value);
public void remove_GotFocus(EventHandler value);
public void remove_HandleCreated(EventHandler value);
public void remove_HandleDestroyed(EventHandler value);
public void remove_HelpRequested(HelpEventHandler value);
public void remove_ImeModeChanged(EventHandler value);
public void remove_Invalidated(InvalidateEventHandler value);
public void remove_ItemDrag(ItemDragEventHandler value);
public void remove_KeyDown(KeyEventHandler value);
public void remove_KeyPress(KeyPressEventHandler value);
public void remove_KeyUp(KeyEventHandler value);
public void remove_Layout(LayoutEventHandler value);
public void remove_Leave(EventHandler value);
public void remove_LocationChanged(EventHandler value);
public void remove_LostFocus(EventHandler value);
public void remove_MouseDown(MouseEventHandler value);
public void remove_MouseEnter(EventHandler value);
public void remove_MouseHover(EventHandler value);
public void remove_MouseLeave(EventHandler value);
public void remove_MouseMove(MouseEventHandler value);
public void remove_MouseUp(MouseEventHandler value);
public void remove_MouseWheel(MouseEventHandler value);
public void remove_Move(EventHandler value);
public void remove_Paint(PaintEventHandler value);
public void remove_ParentChanged(EventHandler value);
public void remove_QueryAccessibilityHelp(QueryAccessibilityHelpEventHandler value);
public void remove_QueryContinueDrag(QueryContinueDragEventHandler value);
public void remove_Resize(EventHandler value);
public void remove_RightToLeftChanged(EventHandler value);
public void remove_SizeChanged(EventHandler value);
public void remove_StyleChanged(EventHandler value);
public void remove_SystemColorsChanged(EventHandler value);
public void remove_TabIndexChanged(EventHandler value);
public void remove_TabStopChanged(EventHandler value);
public void remove_TextChanged(EventHandler value);
public void remove_Validated(EventHandler value);
public void remove_Validating(CancelEventHandler value);
public void remove_VisibleChanged(EventHandler value);
public void ResetBackColor();
public void ResetBindings();
public void ResetCursor();
public void ResetFont();
public void ResetForeColor();
public void ResetImeMode();
protected void ResetMouseEventArgs();
public void ResetRightToLeft();
public void ResetText();
public void ResumeLayout();
public void ResumeLayout(bool performLayout);
protected ContentAlignment RtlTranslateAlignment(ContentAlignment align);
protected HorizontalAlignment RtlTranslateAlignment(HorizontalAlignment align);
protected LeftRightAlignment RtlTranslateAlignment(LeftRightAlignment align);
protected ContentAlignment RtlTranslateContent(ContentAlignment align);
protected HorizontalAlignment RtlTranslateHorizontal(HorizontalAlignment align);
protected LeftRightAlignment RtlTranslateLeftRight(LeftRightAlignment align);
public void Scale(float ratio);
public void Scale(float dx, float dy);
protected virtual void ScaleCore(float dx, float dy);
public void Select();
protected virtual void Select(bool directed, bool forward);
public bool SelectNextControl(Control ctl, bool forward, bool tabStopOnly, bool nested, bool wrap);
public void SendToBack();
public void SetBounds(int x, int y, int width, int height);
public void SetBounds(int x, int y, int width, int height, BoundsSpecified specified);
protected virtual void SetBoundsCore(int x, int y, int width, int height, BoundsSpecified specified);
protected virtual void SetClientSizeCore(int x, int y);
protected void SetStyle(ControlStyles flag, bool value);
protected void SetTopLevel(bool value);
protected virtual void SetVisibleCore(bool value);
public void Show();
public void SuspendLayout();
public virtual string ToString();
public void Update();
protected void UpdateBounds();
protected void UpdateBounds(int x, int y, int width, int height);
protected void UpdateBounds(int x, int y, int width, int height, int clientWidth, int clientHeight);
protected void UpdateStyles();
protected void UpdateZOrder();
protected virtual void WndProc(ref Message m);

Property
public AccessibleObject AccessibilityObject {get;}
public string AccessibleDefaultActionDescription {get; set;}
public string AccessibleDescription {get; set;}
public string AccessibleName {get; set;}
public AccessibleRole AccessibleRole {get; set;}
public bool AllowDrop {get; set;}
public AnchorStyles Anchor {get; set;}
public virtual Color BackColor {get; set;}
public override Image BackgroundImage {get; set;}
public virtual BindingContext BindingContext {get; set;}
public BorderStyle BorderStyle {get; set;}
public int Bottom {get;}
public Rectangle Bounds {get; set;}
public bool CanFocus {get;}
public bool CanSelect {get;}
public bool Capture {get; set;}
public bool CausesValidation {get; set;}
public bool CheckBoxes {get; set;}
public Rectangle ClientRectangle {get;}
public Size ClientSize {get; set;}
public string CompanyName {get;}
public IContainer Container {get;}
public bool ContainsFocus {get;}
public ContextMenu ContextMenu {get; set;}
public ControlCollection Controls {get;}
public bool Created {get;}
protected virtual CreateParams CreateParams {get;}
public Cursor Cursor {get; set;}
public ControlBindingsCollection DataBindings {get;}
protected virtual ImeMode DefaultImeMode {get;}
protected virtual Size DefaultSize {get;}
protected bool DesignMode {get;}
public Rectangle DisplayRectangle {get;}
public bool Disposing {get;}
public DockStyle Dock {get; set;}
public bool Enabled {get; set;}
protected EventHandlerList Events {get;}
public bool Focused {get;}
public virtual Font Font {get; set;}
protected int FontHeight {get; set;}
public virtual Color ForeColor {get; set;}
public bool FullRowSelect {get; set;}
public IntPtr Handle {get;}
public bool HasChildren {get;}
public int Height {get; set;}
public bool HideSelection {get; set;}
public bool HotTracking {get; set;}
public int ImageIndex {get; set;}
public ImageList ImageList {get; set;}
public ImeMode ImeMode {get; set;}
public int Indent {get; set;}
public bool InvokeRequired {get;}
public bool IsAccessible {get; set;}
public bool IsDisposed {get;}
public bool IsHandleCreated {get;}
public int ItemHeight {get; set;}
public bool LabelEdit {get; set;}
public int Left {get; set;}
public Point Location {get; set;}
public string Name {get; set;}
public TreeNodeCollection Nodes {get;}
public Control Parent {get; set;}
public string PathSeparator {get; set;}
public string ProductName {get;}
public string ProductVersion {get;}
public bool RecreatingHandle {get;}
public Region Region {get; set;}
protected bool RenderRightToLeft {get;}
protected bool ResizeRedraw {get; set;}
public int Right {get;}
public RightToLeft RightToLeft {get; set;}
public bool Scrollable {get; set;}
public int SelectedImageIndex {get; set;}
public TreeNode SelectedNode {get; set;}
protected virtual bool ShowFocusCues {get;}
protected bool ShowKeyboardCues {get;}
public bool ShowLines {get; set;}
public bool ShowPlusMinus {get; set;}
public bool ShowRootLines {get; set;}
public ISite Site {get; set;}
public Size Size {get; set;}
public bool Sorted {get; set;}
public int TabIndex {get; set;}
public bool TabStop {get; set;}
public object Tag {get; set;}
public virtual string Text {get; set;}
public int Top {get; set;}
public Control TopLevelControl {get;}
public TreeNode TopNode {get;}
public bool Visible {get; set;}
public int VisibleCount {get;}
public int Width {get; set;}
public IWindowTarget WindowTarget {get; set;}

System.Windows.Forms.TreeNodeCollection

Module:System.Windows.Forms.dll

Hierarchy
Object
TreeNodeCollection : IList, ICollection, IEnumerable

Type declaration

[C#] public class TreeNodeCollection: IList, ICollection, IEnumerable;

Method
public virtual TreeNode Add(string strText);
public virtual int Add(TreeNode tn);
public virtual void AddRange(TreeNode[] rgtn);
public virtual void Clear();
public bool Contains(TreeNode tn);
public virtual void CopyTo(Array rgDest, int index);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual IEnumerator GetEnumerator();
public virtual int GetHashCode();
public Type GetType();
public int IndexOf(TreeNode tn);
public virtual void Insert(int index, TreeNode tnNew);
protected object MemberwiseClone();
public void Remove(TreeNode tn);
public virtual void RemoveAt(int index);
public virtual string ToString();

Property
public virtual int Count {get;}
public virtual bool IsReadOnly {get;}
public virtual TreeNode this[int index] {get; set;}

System.Windows.Forms.TreeNode

Module:System.Windows.Forms.dll

Hierarchy
Object
MarshalByRefObject
TreeNode

Type declaration

[C#] public class TreeNode : MarshalByRefObject;

Constructor
public TreeNode();
public TreeNode(string strText);
public TreeNode(string text, int imageIndex, int selectedImageIndex);
public TreeNode(string text, int imageIndex, int selectedImageIndex, TreeNode[] children);
public TreeNode(string text, TreeNode[] children);

Method
public void BeginEdit();
public virtual object Clone();
public void Collapse();
public ObjRef CreateObjRef(Type requestedType);
public void EndEdit(bool cancel);
public void EnsureVisible();
public virtual bool Equals(object obj);
public void Expand();
public void ExpandAll();
protected override void Finalize();
public static TreeNode FromHandle(TreeView tree, IntPtr handle);
public virtual int GetHashCode();
public object GetLifetimeService();
public int GetNodeCount(bool fIncludeSubTrees);
public Type GetType();
public object InitializeLifetimeService();
protected object MemberwiseClone();
public void Remove();
public void Toggle();
public override string ToString();

Property
public Color BackColor {get; set;}
public Rectangle Bounds {get;}
public bool Checked {get; set;}
public TreeNode FirstNode {get;}
public Color ForeColor {get; set;}
public string FullPath {get;}
public IntPtr Handle {get;}
public int ImageIndex {get; set;}
public int Index {get;}
public bool IsEditing {get;}
public bool IsExpanded {get;}
public bool IsSelected {get;}
public bool IsVisible {get;}
public TreeNode LastNode {get;}
public TreeNode NextNode {get;}
public TreeNode NextVisibleNode {get;}
public Font NodeFont {get; set;}
public TreeNodeCollection Nodes {get;}
public TreeNode Parent {get;}
public TreeNode PrevNode {get;}
public TreeNode PrevVisibleNode {get;}
public int SelectedImageIndex {get; set;}
public object Tag {get; set;}
public string Text {get; set;}
public TreeView TreeView {get;}

System.Windows.Forms.ColumnClickEventHandler

Module:System.Windows.Forms.dll

Hierarchy
Object
Delegate
MulticastDelegate
ColumnClickEventHandler

Type declaration

[C#] public delegate void ColumnClickEventHandler(object sender, ColumnClickEventArgs e);

Constructor
public ColumnClickEventHandler(object object, IntPtr method);

Method
public virtual IAsyncResult BeginInvoke(object sender, ColumnClickEventArgs e, AsyncCallback callback, object object);
public object Clone();
protected override Delegate CombineImpl(Delegate follow);
public object DynamicInvoke(object[] args);
protected virtual object DynamicInvokeImpl(object[] args);
public virtual void EndInvoke(IAsyncResult result);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public override Delegate[] GetInvocationList();
protected virtual MethodInfo GetMethodImpl();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
public override void Invoke(object sender, ColumnClickEventArgs e);
protected object MemberwiseClone();
protected override Delegate RemoveImpl(Delegate value);
public virtual string ToString();

Property
public MethodInfo Method {get;}
public object Target {get;}

System.Windows.Forms.ColumnClickEventArgs

Module:System.Windows.Forms.dll

Hierarchy
Object
EventArgs
ColumnClickEventArgs

Type declaration

[C#] public class ColumnClickEventArgs : EventArgs;

Constructor
public ColumnClickEventArgs(int column);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public int Column {get;}

System.Windows.Forms.ColumnHeader

Module:System.Windows.Forms.dll

Hierarchy
Object
MarshalByRefObject
Component
ColumnHeader

Type declaration

[C#] public class ColumnHeader : Component;

Constructor
public ColumnHeader();

Method
public void add_Disposed(EventHandler value);
public virtual object Clone();
public ObjRef CreateObjRef(Type requestedType);
public void Dispose();
protected virtual void Dispose(bool disposing);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public object GetLifetimeService();
protected virtual object GetService(Type service);
public Type GetType();
public object InitializeLifetimeService();
protected object MemberwiseClone();
public void remove_Disposed(EventHandler value);
public virtual string ToString();

Property
public IContainer Container {get;}
protected bool DesignMode {get;}
protected EventHandlerList Events {get;}
public int Index {get;}
public ListView ListView {get;}
public ISite Site {get; set;}
public string Text {get; set;}
public HorizontalAlignment TextAlign {get; set;}
public int Width {get; set;}

System.Windows.Forms.ItemCheckEventHandler

Module:System.Windows.Forms.dll

Hierarchy
Object
Delegate
MulticastDelegate
ItemCheckEventHandler

Type declaration

[C#] public delegate void ItemCheckEventHandler(object sender, ItemCheckEventArgs e);

Constructor
public ItemCheckEventHandler(object object, IntPtr method);

Method
public virtual IAsyncResult BeginInvoke(object sender, ItemCheckEventArgs e, AsyncCallback callback, object object);
public object Clone();
protected override Delegate CombineImpl(Delegate follow);
public object DynamicInvoke(object[] args);
protected virtual object DynamicInvokeImpl(object[] args);
public virtual void EndInvoke(IAsyncResult result);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public override Delegate[] GetInvocationList();
protected virtual MethodInfo GetMethodImpl();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
public override void Invoke(object sender, ItemCheckEventArgs e);
protected object MemberwiseClone();
protected override Delegate RemoveImpl(Delegate value);
public virtual string ToString();

Property
public MethodInfo Method {get;}
public object Target {get;}

System.Windows.Forms.ItemCheckEventArgs

Module:System.Windows.Forms.dll

Hierarchy
Object
EventArgs
ItemCheckEventArgs

Type declaration

[C#] public class ItemCheckEventArgs : EventArgs;

Constructor
public ItemCheckEventArgs(int index, CheckState newCheckValue, CheckState currentValue);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public CheckState CurrentValue {get;}
public int Index {get;}
public CheckState NewValue {get; set;}

System.Windows.Forms.ListViewItem+ListViewSubItemCollection

Module:System.Windows.Forms.dll

Hierarchy
Object
ListViewItem+ListViewSubItemCollection : IList, ICollection, IEnumerable

Type declaration

[C#] public class ListViewSubItemCollection: IList, ICollection, IEnumerable;

Constructor
public ListViewSubItemCollection(ListViewItem owner);

Method
public ListViewSubItem Add(ListViewSubItem lvsi);
public ListViewSubItem Add(string text);
public ListViewSubItem Add(string text, Color foreColor, Color backColor, Font font);
public void AddRange(ListViewSubItem[] items);
public void AddRange(string[] items);
public void AddRange(string[] items, Color foreColor, Color backColor, Font font);
public virtual void Clear();
public bool Contains(ListViewSubItem lvsi);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual IEnumerator GetEnumerator();
public virtual int GetHashCode();
public Type GetType();
public int IndexOf(ListViewSubItem lvsi);
public void Insert(int index, ListViewSubItem lvsi);
protected object MemberwiseClone();
public void Remove(ListViewSubItem lvsi);
public virtual void RemoveAt(int index);
public virtual string ToString();

Property
public virtual int Count {get;}
public virtual bool IsReadOnly {get;}
public ListViewSubItem this[int index] {get; set;}

System.Windows.Forms.ListViewItem+ListViewSubItem

Module:System.Windows.Forms.dll

Hierarchy
Object
ListViewItem+ListViewSubItem

Type declaration

[C#] public class ListViewSubItem;

Constructor
public ListViewSubItem();
public ListViewSubItem(ListViewItem owner, string text);
public ListViewSubItem(ListViewItem owner, string text, Color foreColor, Color backColor, Font font);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public void ResetStyle();
public virtual string ToString();

Property
public Color BackColor {get; set;}
public Font Font {get; set;}
public Color ForeColor {get; set;}
public string Text {get; set;}

System.Windows.Forms.ListViewItem

Module:System.Windows.Forms.dll

Hierarchy
Object
ListViewItem

Type declaration

[C#] public class ListViewItem;

Constructor
public ListViewItem();
public ListViewItem(ListViewSubItem[] subItems, int imageIndex);
public ListViewItem(string text);
public ListViewItem(string text, int imageIndex);
public ListViewItem(string[] items);
public ListViewItem(string[] items, int imageIndex);
public ListViewItem(string[] items, int imageIndex, Color foreColor, Color backColor, Font font);

Method
public void BeginEdit();
public virtual object Clone();
protected virtual void Deserialize(SerializationInfo info, StreamingContext context);
public virtual void EnsureVisible();
public virtual bool Equals(object obj);
protected override void Finalize();
public Rectangle GetBounds(ItemBoundsPortion portion);
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual void Remove();
protected virtual void Serialize(SerializationInfo info, StreamingContext context);
public virtual string ToString();

Property
public Color BackColor {get; set;}
public Rectangle Bounds {get;}
public bool Checked {get; set;}
public bool Focused {get; set;}
public Font Font {get; set;}
public Color ForeColor {get; set;}
public int ImageIndex {get; set;}
public ImageList ImageList {get;}
public int Index {get;}
public ListView ListView {get;}
public bool Selected {get; set;}
public int StateImageIndex {get; set;}
public ListViewSubItemCollection SubItems {get;}
public object Tag {get; set;}
public string Text {get; set;}
public bool UseItemStyleForSubItems {get; set;}

System.Windows.Forms.ItemActivation

Module:System.Windows.Forms.dll

Hierarchy
Object
ValueType
Enum
ItemActivation

Type declaration

[C#] public enum ItemActivation;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const ItemActivation OneClick = 1;
public const ItemActivation Standard = 0;
public const ItemActivation TwoClick = 2;
public int value__;

System.Windows.Forms.ColumnHeaderStyle

Module:System.Windows.Forms.dll

Hierarchy
Object
ValueType
Enum
ColumnHeaderStyle

Type declaration

[C#] public enum ColumnHeaderStyle;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const ColumnHeaderStyle Clickable = 2;
public const ColumnHeaderStyle Nonclickable = 1;
public const ColumnHeaderStyle None = 0;
public int value__;

System.Windows.Forms.View

Module:System.Windows.Forms.dll

Hierarchy
Object
ValueType
Enum
View

Type declaration

[C#] public enum View;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const View Details = 1;
public const View LargeIcon = 0;
public const View List = 3;
public const View SmallIcon = 2;
public int value__;

System.Windows.Forms.ListView+SelectedIndexCollection

Module:System.Windows.Forms.dll

Hierarchy
Object
ListView+SelectedIndexCollection : IList, ICollection, IEnumerable

Type declaration

[C#] public class SelectedIndexCollection: IList, ICollection, IEnumerable;

Constructor
public SelectedIndexCollection(ListView owner);

Method
public bool Contains(int selectedIndex);
public virtual void CopyTo(Array dest, int index);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual IEnumerator GetEnumerator();
public virtual int GetHashCode();
public Type GetType();
public int IndexOf(int selectedIndex);
protected object MemberwiseClone();
public virtual string ToString();

Property
public virtual int Count {get;}
public virtual bool IsReadOnly {get;}
public int this[int index] {get;}

System.Windows.Forms.ListView+ColumnHeaderCollection

Module:System.Windows.Forms.dll

Hierarchy
Object
ListView+ColumnHeaderCollection : IList, ICollection, IEnumerable

Type declaration

[C#] public class ColumnHeaderCollection: IList, ICollection, IEnumerable;

Constructor
public ColumnHeaderCollection(ListView owner);

Method
public int Add(ColumnHeader ch);
public ColumnHeader Add(string str, int width, HorizontalAlignment textAlign);
public virtual void AddRange(ColumnHeader[] values);
public virtual void Clear();
public bool Contains(ColumnHeader ch);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual IEnumerator GetEnumerator();
public virtual int GetHashCode();
public Type GetType();
public int IndexOf(ColumnHeader ch);
public void Insert(int index, ColumnHeader ch);
public void Insert(int index, string str, int width, HorizontalAlignment textAlign);
protected object MemberwiseClone();
public void Remove(ColumnHeader ch);
public virtual void RemoveAt(int index);
public virtual string ToString();

Property
public virtual int Count {get;}
public virtual bool IsReadOnly {get;}
public ColumnHeader this[int index] {get;}

System.Windows.Forms.ListView+ListViewItemCollection

Module:System.Windows.Forms.dll

Hierarchy
Object
ListView+ListViewItemCollection : IList, ICollection, IEnumerable

Type declaration

[C#] public class ListViewItemCollection: IList, ICollection, IEnumerable;

Constructor
public ListViewItemCollection(ListView owner);

Method
public ListViewItem Add(ListViewItem lvi);
public virtual ListViewItem Add(string text);
public virtual ListViewItem Add(string text, int imageIndex);
public void AddRange(ListViewItem[] values);
public virtual void Clear();
public bool Contains(ListViewItem lvi);
public virtual void CopyTo(Array array, int index);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual IEnumerator GetEnumerator();
public virtual int GetHashCode();
public Type GetType();
public int IndexOf(ListViewItem lvi);
public ListViewItem Insert(int index, ListViewItem lvi);
public ListViewItem Insert(int index, string text);
public ListViewItem Insert(int index, string text, int imageIndex);
protected object MemberwiseClone();
public void Remove(ListViewItem lvi);
public virtual void RemoveAt(int index);
public virtual string ToString();

Property
public virtual int Count {get;}
public virtual bool IsReadOnly {get;}
public ListViewItem this[int index] {get; set;}

System.Windows.Forms.ListView

Module:System.Windows.Forms.dll

Hierarchy
Object
MarshalByRefObject
Component
Control
ListView

Type declaration

[C#] public class ListView : Control;

Constructor
public ListView();

Method
protected void AccessibilityNotifyClients(AccessibleEvents accEvent, int childID);
public void add_AfterLabelEdit(LabelEditEventHandler value);
public void add_BackColorChanged(EventHandler value);
public void add_BackgroundImageChanged(EventHandler value);
public void add_BeforeLabelEdit(LabelEditEventHandler value);
public void add_BindingContextChanged(EventHandler value);
public void add_CausesValidationChanged(EventHandler value);
public void add_ChangeUICues(UICuesEventHandler value);
public void add_Click(EventHandler value);
public void add_ColumnClick(ColumnClickEventHandler value);
public void add_ContextMenuChanged(EventHandler value);
public void add_ControlAdded(ControlEventHandler value);
public void add_ControlRemoved(ControlEventHandler value);
public void add_CursorChanged(EventHandler value);
public void add_Disposed(EventHandler value);
public void add_DockChanged(EventHandler value);
public void add_DoubleClick(EventHandler value);
public void add_DragDrop(DragEventHandler value);
public void add_DragEnter(DragEventHandler value);
public void add_DragLeave(EventHandler value);
public void add_DragOver(DragEventHandler value);
public void add_EnabledChanged(EventHandler value);
public void add_Enter(EventHandler value);
public void add_FontChanged(EventHandler value);
public void add_ForeColorChanged(EventHandler value);
public void add_GiveFeedback(GiveFeedbackEventHandler value);
public void add_GotFocus(EventHandler value);
public void add_HandleCreated(EventHandler value);
public void add_HandleDestroyed(EventHandler value);
public void add_HelpRequested(HelpEventHandler value);
public void add_ImeModeChanged(EventHandler value);
public void add_Invalidated(InvalidateEventHandler value);
public void add_ItemActivate(EventHandler value);
public void add_ItemCheck(ItemCheckEventHandler value);
public void add_ItemDrag(ItemDragEventHandler value);
public void add_KeyDown(KeyEventHandler value);
public void add_KeyPress(KeyPressEventHandler value);
public void add_KeyUp(KeyEventHandler value);
public void add_Layout(LayoutEventHandler value);
public void add_Leave(EventHandler value);
public void add_LocationChanged(EventHandler value);
public void add_LostFocus(EventHandler value);
public void add_MouseDown(MouseEventHandler value);
public void add_MouseEnter(EventHandler value);
public void add_MouseHover(EventHandler value);
public void add_MouseLeave(EventHandler value);
public void add_MouseMove(MouseEventHandler value);
public void add_MouseUp(MouseEventHandler value);
public void add_MouseWheel(MouseEventHandler value);
public void add_Move(EventHandler value);
public void add_Paint(PaintEventHandler value);
public void add_ParentChanged(EventHandler value);
public void add_QueryAccessibilityHelp(QueryAccessibilityHelpEventHandler value);
public void add_QueryContinueDrag(QueryContinueDragEventHandler value);
public void add_Resize(EventHandler value);
public void add_RightToLeftChanged(EventHandler value);
public void add_SelectedIndexChanged(EventHandler value);
public void add_SizeChanged(EventHandler value);
public void add_StyleChanged(EventHandler value);
public void add_SystemColorsChanged(EventHandler value);
public void add_TabIndexChanged(EventHandler value);
public void add_TabStopChanged(EventHandler value);
public void add_TextChanged(EventHandler value);
public void add_Validated(EventHandler value);
public void add_Validating(CancelEventHandler value);
public void add_VisibleChanged(EventHandler value);
public void ArrangeIcons();
public void ArrangeIcons(ListViewAlignment value);
public IAsyncResult BeginInvoke(Delegate method);
public IAsyncResult BeginInvoke(Delegate method, object[] args);
public void BeginUpdate();
public void BringToFront();
public void Clear();
public bool Contains(Control ctl);
protected virtual AccessibleObject CreateAccessibilityInstance();
public void CreateControl();
protected virtual ControlCollection CreateControlsInstance();
public Graphics CreateGraphics();
protected virtual void CreateHandle();
public ObjRef CreateObjRef(Type requestedType);
protected virtual void DefWndProc(ref Message m);
protected virtual void DestroyHandle();
public void Dispose();
protected override void Dispose(bool disposing);
public DragDropEffects DoDragDrop(object data, DragDropEffects allowedEffects);
public object EndInvoke(IAsyncResult asyncResult);
public void EndUpdate();
public void EnsureVisible(int iItem);
public virtual bool Equals(object obj);
protected override void Finalize();
public Form FindForm();
public bool Focus();
public Control GetChildAtPoint(Point pt);
public IContainerControl GetContainerControl();
public virtual int GetHashCode();
public ListViewItem GetItemAt(int x, int y);
public Rectangle GetItemRect(int index);
public Rectangle GetItemRect(int index, ItemBoundsPortion portion);
public object GetLifetimeService();
public Control GetNextControl(Control ctl, bool forward);
protected virtual object GetService(Type service);
protected bool GetStyle(ControlStyles flag);
protected bool GetTopLevel();
public Type GetType();
public void Hide();
public object InitializeLifetimeService();
protected virtual void InitLayout();
public void Invalidate();
public void Invalidate(bool invalidateChildren);
public void Invalidate(Rectangle rect);
public void Invalidate(Rectangle rc, bool invalidateChildren);
public void Invalidate(Region region);
public void Invalidate(Region region, bool invalidateChildren);
public object Invoke(Delegate method);
public object Invoke(Delegate method, object[] args);
protected void InvokeGotFocus(Control toInvoke, EventArgs e);
protected void InvokeLostFocus(Control toInvoke, EventArgs e);
protected void InvokeOnClick(Control toInvoke, EventArgs e);
protected void InvokePaint(Control c, PaintEventArgs e);
protected void InvokePaintBackground(Control c, PaintEventArgs e);
protected virtual bool IsInputChar(char charCode);
protected virtual bool IsInputKey(Keys keyData);
protected object MemberwiseClone();
protected virtual void NotifyInvalidate(Rectangle invalidatedArea);
protected virtual void OnAfterLabelEdit(LabelEditEventArgs e);
protected virtual void OnBackColorChanged(EventArgs e);
protected virtual void OnBackgroundImageChanged(EventArgs e);
protected virtual void OnBeforeLabelEdit(LabelEditEventArgs e);
protected virtual void OnBindingContextChanged(EventArgs e);
protected virtual void OnCausesValidationChanged(EventArgs e);
protected virtual void OnChangeUICues(UICuesEventArgs e);
protected virtual void OnClick(EventArgs e);
protected virtual void OnColumnClick(ColumnClickEventArgs e);
protected virtual void OnContextMenuChanged(EventArgs e);
protected virtual void OnControlAdded(ControlEventArgs e);
protected virtual void OnControlRemoved(ControlEventArgs e);
protected virtual void OnCreateControl();
protected virtual void OnCursorChanged(EventArgs e);
protected virtual void OnDockChanged(EventArgs e);
protected virtual void OnDoubleClick(EventArgs e);
protected virtual void OnDragDrop(DragEventArgs drgevent);
protected virtual void OnDragEnter(DragEventArgs drgevent);
protected virtual void OnDragLeave(EventArgs e);
protected virtual void OnDragOver(DragEventArgs drgevent);
protected virtual void OnEnabledChanged(EventArgs e);
protected virtual void OnEnter(EventArgs e);
protected virtual void OnFontChanged(EventArgs e);
protected virtual void OnForeColorChanged(EventArgs e);
protected virtual void OnGiveFeedback(GiveFeedbackEventArgs gfbevent);
protected virtual void OnGotFocus(EventArgs e);
protected virtual void OnHandleCreated(EventArgs e);
protected virtual void OnHandleDestroyed(EventArgs e);
protected virtual void OnHelpRequested(HelpEventArgs hevent);
protected virtual void OnImeModeChanged(EventArgs e);
protected virtual void OnInvalidated(InvalidateEventArgs e);
protected virtual void OnItemActivate(EventArgs e);
protected virtual void OnItemCheck(ItemCheckEventArgs e);
protected virtual void OnItemDrag(ItemDragEventArgs e);
protected virtual void OnKeyDown(KeyEventArgs e);
protected virtual void OnKeyPress(KeyPressEventArgs e);
protected virtual void OnKeyUp(KeyEventArgs e);
protected virtual void OnLayout(LayoutEventArgs levent);
protected virtual void OnLeave(EventArgs e);
protected virtual void OnLocationChanged(EventArgs e);
protected virtual void OnLostFocus(EventArgs e);
protected virtual void OnMouseDown(MouseEventArgs e);
protected virtual void OnMouseEnter(EventArgs e);
protected virtual void OnMouseHover(EventArgs e);
protected virtual void OnMouseLeave(EventArgs e);
protected virtual void OnMouseMove(MouseEventArgs e);
protected virtual void OnMouseUp(MouseEventArgs e);
protected virtual void OnMouseWheel(MouseEventArgs e);
protected virtual void OnMove(EventArgs e);
protected virtual void OnNotifyMessage(Message m);
protected virtual void OnPaint(PaintEventArgs e);
protected virtual void OnPaintBackground(PaintEventArgs e);
protected virtual void OnParentBackColorChanged(EventArgs e);
protected virtual void OnParentBackgroundImageChanged(EventArgs e);
protected virtual void OnParentBindingContextChanged(EventArgs e);
protected virtual void OnParentChanged(EventArgs e);
protected virtual void OnParentEnabledChanged(EventArgs e);
protected virtual void OnParentFontChanged(EventArgs e);
protected virtual void OnParentForeColorChanged(EventArgs e);
protected virtual void OnParentRightToLeftChanged(EventArgs e);
protected virtual void OnParentVisibleChanged(EventArgs e);
protected virtual void OnQueryContinueDrag(QueryContinueDragEventArgs qcdevent);
protected virtual void OnResize(EventArgs e);
protected virtual void OnRightToLeftChanged(EventArgs e);
protected virtual void OnSelectedIndexChanged(EventArgs e);
protected virtual void OnSizeChanged(EventArgs e);
protected virtual void OnStyleChanged(EventArgs e);
protected virtual void OnSystemColorsChanged(EventArgs e);
protected virtual void OnTabIndexChanged(EventArgs e);
protected virtual void OnTabStopChanged(EventArgs e);
protected virtual void OnTextChanged(EventArgs e);
protected virtual void OnValidated(EventArgs e);
protected virtual void OnValidating(CancelEventArgs e);
protected virtual void OnVisibleChanged(EventArgs e);
public void PerformLayout();
public void PerformLayout(Control affectedControl, string affectedProperty);
public Point PointToClient(Point p);
public Point PointToScreen(Point p);
public bool PreProcessMessage(ref Message msg);
protected virtual bool ProcessCmdKey(ref Message msg, Keys keyData);
protected virtual bool ProcessDialogChar(char charCode);
protected virtual bool ProcessDialogKey(Keys keyData);
protected virtual bool ProcessKeyEventArgs(ref Message m);
protected virtual bool ProcessKeyPreview(ref Message m);
protected virtual bool ProcessMnemonic(char charCode);
protected void RaiseDragEvent(object key, DragEventArgs e);
protected void RaiseKeyEvent(object key, KeyEventArgs e);
protected void RaiseMouseEvent(object key, MouseEventArgs e);
protected void RaisePaintEvent(object key, PaintEventArgs e);
protected void RealizeProperties();
protected void RecreateHandle();
public Rectangle RectangleToClient(Rectangle r);
public Rectangle RectangleToScreen(Rectangle r);
public virtual void Refresh();
public void remove_AfterLabelEdit(LabelEditEventHandler value);
public void remove_BackColorChanged(EventHandler value);
public void remove_BackgroundImageChanged(EventHandler value);
public void remove_BeforeLabelEdit(LabelEditEventHandler value);
public void remove_BindingContextChanged(EventHandler value);
public void remove_CausesValidationChanged(EventHandler value);
public void remove_ChangeUICues(UICuesEventHandler value);
public void remove_Click(EventHandler value);
public void remove_ColumnClick(ColumnClickEventHandler value);
public void remove_ContextMenuChanged(EventHandler value);
public void remove_ControlAdded(ControlEventHandler value);
public void remove_ControlRemoved(ControlEventHandler value);
public void remove_CursorChanged(EventHandler value);
public void remove_Disposed(EventHandler value);
public void remove_DockChanged(EventHandler value);
public void remove_DoubleClick(EventHandler value);
public void remove_DragDrop(DragEventHandler value);
public void remove_DragEnter(DragEventHandler value);
public void remove_DragLeave(EventHandler value);
public void remove_DragOver(DragEventHandler value);
public void remove_EnabledChanged(EventHandler value);
public void remove_Enter(EventHandler value);
public void remove_FontChanged(EventHandler value);
public void remove_ForeColorChanged(EventHandler value);
public void remove_GiveFeedback(GiveFeedbackEventHandler value);
public void remove_GotFocus(EventHandler value);
public void remove_HandleCreated(EventHandler value);
public void remove_HandleDestroyed(EventHandler value);
public void remove_HelpRequested(HelpEventHandler value);
public void remove_ImeModeChanged(EventHandler value);
public void remove_Invalidated(InvalidateEventHandler value);
public void remove_ItemActivate(EventHandler value);
public void remove_ItemCheck(ItemCheckEventHandler value);
public void remove_ItemDrag(ItemDragEventHandler value);
public void remove_KeyDown(KeyEventHandler value);
public void remove_KeyPress(KeyPressEventHandler value);
public void remove_KeyUp(KeyEventHandler value);
public void remove_Layout(LayoutEventHandler value);
public void remove_Leave(EventHandler value);
public void remove_LocationChanged(EventHandler value);
public void remove_LostFocus(EventHandler value);
public void remove_MouseDown(MouseEventHandler value);
public void remove_MouseEnter(EventHandler value);
public void remove_MouseHover(EventHandler value);
public void remove_MouseLeave(EventHandler value);
public void remove_MouseMove(MouseEventHandler value);
public void remove_MouseUp(MouseEventHandler value);
public void remove_MouseWheel(MouseEventHandler value);
public void remove_Move(EventHandler value);
public void remove_Paint(PaintEventHandler value);
public void remove_ParentChanged(EventHandler value);
public void remove_QueryAccessibilityHelp(QueryAccessibilityHelpEventHandler value);
public void remove_QueryContinueDrag(QueryContinueDragEventHandler value);
public void remove_Resize(EventHandler value);
public void remove_RightToLeftChanged(EventHandler value);
public void remove_SelectedIndexChanged(EventHandler value);
public void remove_SizeChanged(EventHandler value);
public void remove_StyleChanged(EventHandler value);
public void remove_SystemColorsChanged(EventHandler value);
public void remove_TabIndexChanged(EventHandler value);
public void remove_TabStopChanged(EventHandler value);
public void remove_TextChanged(EventHandler value);
public void remove_Validated(EventHandler value);
public void remove_Validating(CancelEventHandler value);
public void remove_VisibleChanged(EventHandler value);
public void ResetBackColor();
public void ResetBindings();
public void ResetCursor();
public void ResetFont();
public void ResetForeColor();
public void ResetImeMode();
protected void ResetMouseEventArgs();
public void ResetRightToLeft();
public void ResetText();
public void ResumeLayout();
public void ResumeLayout(bool performLayout);
protected ContentAlignment RtlTranslateAlignment(ContentAlignment align);
protected HorizontalAlignment RtlTranslateAlignment(HorizontalAlignment align);
protected LeftRightAlignment RtlTranslateAlignment(LeftRightAlignment align);
protected ContentAlignment RtlTranslateContent(ContentAlignment align);
protected HorizontalAlignment RtlTranslateHorizontal(HorizontalAlignment align);
protected LeftRightAlignment RtlTranslateLeftRight(LeftRightAlignment align);
public void Scale(float ratio);
public void Scale(float dx, float dy);
protected virtual void ScaleCore(float dx, float dy);
public void Select();
protected virtual void Select(bool directed, bool forward);
public bool SelectNextControl(Control ctl, bool forward, bool tabStopOnly, bool nested, bool wrap);
public void SendToBack();
public void SetBounds(int x, int y, int width, int height);
public void SetBounds(int x, int y, int width, int height, BoundsSpecified specified);
protected virtual void SetBoundsCore(int x, int y, int width, int height, BoundsSpecified specified);
protected virtual void SetClientSizeCore(int x, int y);
protected void SetStyle(ControlStyles flag, bool value);
protected void SetTopLevel(bool value);
protected virtual void SetVisibleCore(bool value);
public void Show();
public void Sort();
public void SuspendLayout();
public virtual string ToString();
public void Update();
protected void UpdateBounds();
protected void UpdateBounds(int x, int y, int width, int height);
protected void UpdateBounds(int x, int y, int width, int height, int clientWidth, int clientHeight);
protected void UpdateExtendedStyles();
protected void UpdateStyles();
protected void UpdateZOrder();
protected virtual void WndProc(ref Message m);

Property
public AccessibleObject AccessibilityObject {get;}
public string AccessibleDefaultActionDescription {get; set;}
public string AccessibleDescription {get; set;}
public string AccessibleName {get; set;}
public AccessibleRole AccessibleRole {get; set;}
public ItemActivation Activation {get; set;}
public ListViewAlignment Alignment {get; set;}
public bool AllowColumnReorder {get; set;}
public bool AllowDrop {get; set;}
public AnchorStyles Anchor {get; set;}
public bool AutoArrange {get; set;}
public virtual Color BackColor {get; set;}
public override Image BackgroundImage {get; set;}
public virtual BindingContext BindingContext {get; set;}
public BorderStyle BorderStyle {get; set;}
public int Bottom {get;}
public Rectangle Bounds {get; set;}
public bool CanFocus {get;}
public bool CanSelect {get;}
public bool Capture {get; set;}
public bool CausesValidation {get; set;}
public bool CheckBoxes {get; set;}
public CheckedIndexCollection CheckedIndices {get;}
public CheckedListViewItemCollection CheckedItems {get;}
public Rectangle ClientRectangle {get;}
public Size ClientSize {get; set;}
public ColumnHeaderCollection Columns {get;}
public string CompanyName {get;}
public IContainer Container {get;}
public bool ContainsFocus {get;}
public ContextMenu ContextMenu {get; set;}
public ControlCollection Controls {get;}
public bool Created {get;}
protected virtual CreateParams CreateParams {get;}
public Cursor Cursor {get; set;}
public ControlBindingsCollection DataBindings {get;}
protected virtual ImeMode DefaultImeMode {get;}
protected virtual Size DefaultSize {get;}
protected bool DesignMode {get;}
public Rectangle DisplayRectangle {get;}
public bool Disposing {get;}
public DockStyle Dock {get; set;}
public bool Enabled {get; set;}
protected EventHandlerList Events {get;}
public bool Focused {get;}
public ListViewItem FocusedItem {get;}
public virtual Font Font {get; set;}
protected int FontHeight {get; set;}
public virtual Color ForeColor {get; set;}
public bool FullRowSelect {get; set;}
public bool GridLines {get; set;}
public IntPtr Handle {get;}
public bool HasChildren {get;}
public ColumnHeaderStyle HeaderStyle {get; set;}
public int Height {get; set;}
public bool HideSelection {get; set;}
public bool HoverSelection {get; set;}
public ImeMode ImeMode {get; set;}
public bool InvokeRequired {get;}
public bool IsAccessible {get; set;}
public bool IsDisposed {get;}
public bool IsHandleCreated {get;}
public ListViewItemCollection Items {get;}
public bool LabelEdit {get; set;}
public bool LabelWrap {get; set;}
public ImageList LargeImageList {get; set;}
public int Left {get; set;}
public IComparer ListViewItemSorter {get; set;}
public Point Location {get; set;}
public bool MultiSelect {get; set;}
public string Name {get; set;}
public Control Parent {get; set;}
public string ProductName {get;}
public string ProductVersion {get;}
public bool RecreatingHandle {get;}
public Region Region {get; set;}
protected bool RenderRightToLeft {get;}
protected bool ResizeRedraw {get; set;}
public int Right {get;}
public RightToLeft RightToLeft {get; set;}
public bool Scrollable {get; set;}
public SelectedIndexCollection SelectedIndices {get;}
public SelectedListViewItemCollection SelectedItems {get;}
protected virtual bool ShowFocusCues {get;}
protected bool ShowKeyboardCues {get;}
public ISite Site {get; set;}
public Size Size {get; set;}
public ImageList SmallImageList {get; set;}
public SortOrder Sorting {get; set;}
public ImageList StateImageList {get; set;}
public int TabIndex {get; set;}
public bool TabStop {get; set;}
public object Tag {get; set;}
public virtual string Text {get; set;}
public int Top {get; set;}
public ListViewItem TopItem {get;}
public Control TopLevelControl {get;}
public View View {get; set;}
public bool Visible {get; set;}
public int Width {get; set;}
public IWindowTarget WindowTarget {get; set;}

System.Windows.Forms.ScrollBars

Module:System.Windows.Forms.dll

Hierarchy
Object
ValueType
Enum
ScrollBars

Type declaration

[C#] public enum ScrollBars;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const ScrollBars Both = 3;
public const ScrollBars Horizontal = 1;
public const ScrollBars None = 0;
public int value__;
public const ScrollBars Vertical = 2;

System.Windows.Forms.PropertyManager

Module:System.Windows.Forms.dll

Hierarchy
Object
BindingManagerBase
PropertyManager

Type declaration

[C#] public class PropertyManager : BindingManagerBase;

Constructor
public PropertyManager();

Method
public void add_CurrentChanged(EventHandler value);
public void add_PositionChanged(EventHandler value);
public override void AddNew();
public override void CancelCurrentEdit();
public override void EndCurrentEdit();
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public override PropertyDescriptorCollection GetItemProperties();
protected virtual PropertyDescriptorCollection GetItemProperties(Type listType, int offset, ArrayList dataSources, ArrayList listAccessors);
public Type GetType();
protected object MemberwiseClone();
protected void PullData();
protected void PushData();
public void remove_CurrentChanged(EventHandler value);
public void remove_PositionChanged(EventHandler value);
public override void RemoveAt(int index);
public override void ResumeBinding();
public override void SuspendBinding();
public virtual string ToString();
protected override void UpdateIsBinding();

Property
public BindingsCollection Bindings {get;}
public override int Count {get;}
public override object Current {get;}
public override int Position {get; set;}

Field
protected EventHandler onCurrentChangedHandler;
protected EventHandler onPositionChangedHandler;

System.Windows.Forms.ItemChangedEventHandler

Module:System.Windows.Forms.dll

Hierarchy
Object
Delegate
MulticastDelegate
ItemChangedEventHandler

Type declaration

[C#] public delegate void ItemChangedEventHandler(object sender, ItemChangedEventArgs e);

Constructor
public ItemChangedEventHandler(object object, IntPtr method);

Method
public virtual IAsyncResult BeginInvoke(object sender, ItemChangedEventArgs e, AsyncCallback callback, object object);
public object Clone();
protected override Delegate CombineImpl(Delegate follow);
public object DynamicInvoke(object[] args);
protected virtual object DynamicInvokeImpl(object[] args);
public virtual void EndInvoke(IAsyncResult result);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public override Delegate[] GetInvocationList();
protected virtual MethodInfo GetMethodImpl();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
public override void Invoke(object sender, ItemChangedEventArgs e);
protected object MemberwiseClone();
protected override Delegate RemoveImpl(Delegate value);
public virtual string ToString();

Property
public MethodInfo Method {get;}
public object Target {get;}

System.Windows.Forms.ItemChangedEventArgs

Module:System.Windows.Forms.dll

Hierarchy
Object
EventArgs
ItemChangedEventArgs

Type declaration

[C#] public class ItemChangedEventArgs : EventArgs;

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public int Index {get;}

System.Windows.Forms.CurrencyManager

Module:System.Windows.Forms.dll

Hierarchy
Object
BindingManagerBase
CurrencyManager

Type declaration

[C#] public class CurrencyManager : BindingManagerBase;

Method
public void add_CurrentChanged(EventHandler value);
public void add_ItemChanged(ItemChangedEventHandler value);
public void add_MetaDataChanged(EventHandler value);
public void add_PositionChanged(EventHandler value);
public override void AddNew();
public override void CancelCurrentEdit();
protected void CheckEmpty();
public override void EndCurrentEdit();
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public override PropertyDescriptorCollection GetItemProperties();
protected virtual PropertyDescriptorCollection GetItemProperties(Type listType, int offset, ArrayList dataSources, ArrayList listAccessors);
public Type GetType();
protected object MemberwiseClone();
protected virtual void OnItemChanged(ItemChangedEventArgs e);
protected virtual void OnPositionChanged(EventArgs e);
protected void PullData();
protected void PushData();
public void Refresh();
public void remove_CurrentChanged(EventHandler value);
public void remove_ItemChanged(ItemChangedEventHandler value);
public void remove_MetaDataChanged(EventHandler value);
public void remove_PositionChanged(EventHandler value);
public override void RemoveAt(int index);
public override void ResumeBinding();
public override void SuspendBinding();
public virtual string ToString();
protected override void UpdateIsBinding();

Property
public BindingsCollection Bindings {get;}
public override int Count {get;}
public override object Current {get;}
public IList List {get;}
public override int Position {get; set;}

Field
protected Type finalType;
protected int listposition;
protected EventHandler onCurrentChangedHandler;
protected EventHandler onPositionChangedHandler;

System.Windows.Forms.ConvertEventHandler

Module:System.Windows.Forms.dll

Hierarchy
Object
Delegate
MulticastDelegate
ConvertEventHandler

Type declaration

[C#] public delegate void ConvertEventHandler(object sender, ConvertEventArgs e);

Constructor
public ConvertEventHandler(object object, IntPtr method);

Method
public virtual IAsyncResult BeginInvoke(object sender, ConvertEventArgs e, AsyncCallback callback, object object);
public object Clone();
protected override Delegate CombineImpl(Delegate follow);
public object DynamicInvoke(object[] args);
protected virtual object DynamicInvokeImpl(object[] args);
public virtual void EndInvoke(IAsyncResult result);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public override Delegate[] GetInvocationList();
protected virtual MethodInfo GetMethodImpl();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
public override void Invoke(object sender, ConvertEventArgs e);
protected object MemberwiseClone();
protected override Delegate RemoveImpl(Delegate value);
public virtual string ToString();

Property
public MethodInfo Method {get;}
public object Target {get;}

System.Windows.Forms.ConvertEventArgs

Module:System.Windows.Forms.dll

Hierarchy
Object
EventArgs
ConvertEventArgs

Type declaration

[C#] public class ConvertEventArgs : EventArgs;

Constructor
public ConvertEventArgs(object value, Type desiredType);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public Type DesiredType {get;}
public object Value {get; set;}

System.Windows.Forms.ControlBindingsCollection

Module:System.Windows.Forms.dll

Hierarchy
Object
MarshalByRefObject
BaseCollection
BindingsCollection
ControlBindingsCollection

Type declaration

[C#] public class ControlBindingsCollection : BindingsCollection;

Method
public void Add(Binding bdgNew);
public Binding Add(string strPropertyName, object objDataSource, string strDataMember);
public void add_CollectionChanged(CollectionChangeEventHandler value);
protected override void AddCore(Binding bdgNew);
public void Clear();
protected override void ClearCore();
public virtual void CopyTo(Array ar, int index);
public ObjRef CreateObjRef(Type requestedType);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual IEnumerator GetEnumerator();
public virtual int GetHashCode();
public object GetLifetimeService();
public Type GetType();
public object InitializeLifetimeService();
protected object MemberwiseClone();
protected virtual void OnCollectionChanged(CollectionChangeEventArgs ccevent);
public void Remove(Binding bdgRemove);
public void remove_CollectionChanged(CollectionChangeEventHandler value);
public void RemoveAt(int index);
protected override void RemoveCore(Binding bdgRemove);
public virtual string ToString();

Property
public Control Control {get;}
public override int Count {get;}
public bool IsReadOnly {get;}
public virtual bool IsSynchronized {get;}
public Binding this[int index] {get;}
public Binding this[string strPropertyName] {get;}
protected virtual ArrayList List {get;}
public virtual object SyncRoot {get;}

System.Windows.Forms.BindingManagerBase

Module:System.Windows.Forms.dll

Hierarchy
Object
BindingManagerBase

Type declaration

[C#] public abstract class BindingManagerBase;

Constructor
public BindingManagerBase();

Method
public void add_CurrentChanged(EventHandler value);
public void add_PositionChanged(EventHandler value);
public abstract void AddNew();
public abstract void CancelCurrentEdit();
public abstract void EndCurrentEdit();
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public abstract PropertyDescriptorCollection GetItemProperties();
protected virtual PropertyDescriptorCollection GetItemProperties(Type listType, int offset, ArrayList dataSources, ArrayList listAccessors);
public Type GetType();
protected object MemberwiseClone();
protected void PullData();
protected void PushData();
public void remove_CurrentChanged(EventHandler value);
public void remove_PositionChanged(EventHandler value);
public abstract void RemoveAt(int index);
public abstract void ResumeBinding();
public abstract void SuspendBinding();
public virtual string ToString();
protected abstract void UpdateIsBinding();

Property
public BindingsCollection Bindings {get;}
public abstract int Count {get;}
public abstract object Current {get;}
public abstract int Position {get; set;}

Field
protected EventHandler onCurrentChangedHandler;
protected EventHandler onPositionChangedHandler;

System.Windows.Forms.BindingsCollection

Module:System.Windows.Forms.dll

Hierarchy
Object
MarshalByRefObject
BaseCollection
BindingsCollection

Type declaration

[C#] public class BindingsCollection : BaseCollection;

Method
public void add_CollectionChanged(CollectionChangeEventHandler value);
protected virtual void AddCore(Binding bdgNew);
protected virtual void ClearCore();
public virtual void CopyTo(Array ar, int index);
public ObjRef CreateObjRef(Type requestedType);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual IEnumerator GetEnumerator();
public virtual int GetHashCode();
public object GetLifetimeService();
public Type GetType();
public object InitializeLifetimeService();
protected object MemberwiseClone();
protected virtual void OnCollectionChanged(CollectionChangeEventArgs ccevent);
public void remove_CollectionChanged(CollectionChangeEventHandler value);
protected virtual void RemoveCore(Binding bdgRemove);
public virtual string ToString();

Property
public override int Count {get;}
public bool IsReadOnly {get;}
public virtual bool IsSynchronized {get;}
public Binding this[int index] {get;}
protected override ArrayList List {get;}
public virtual object SyncRoot {get;}

System.Windows.Forms.BindingMemberInfo

Module:System.Windows.Forms.dll

Hierarchy
Object
ValueType
BindingMemberInfo

Type declaration

[C#] public struct BindingMemberInfo : ValueType;

Constructor
public BindingMemberInfo(string strDataMember);

Method
public override bool Equals(object objOther);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public string BindingField {get;}
public string BindingMember {get;}
public string BindingPath {get;}

System.Windows.Forms.BindingContext

Module:System.Windows.Forms.dll

Hierarchy
Object
BindingContext : ICollection, IEnumerable

Type declaration

[C#] public class BindingContext: ICollection, IEnumerable;

Constructor
public BindingContext();

Method
public void add_CollectionChanged(CollectionChangeEventHandler value);
protected virtual void AddCore(object objDataSource, BindingManagerBase bdgmgrbase);
protected virtual void ClearCore();
public bool Contains(object objDataSource);
public bool Contains(object objDataSource, string strDataMember);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
protected virtual void OnCollectionChanged(CollectionChangeEventArgs ccevent);
public void remove_CollectionChanged(CollectionChangeEventHandler value);
protected virtual void RemoveCore(object objDataSource);
public virtual string ToString();

Property
public bool IsReadOnly {get;}
public BindingManagerBase this[object objDataSource, string strDataMember] {get;}
public BindingManagerBase this[object objDataSource] {get;}

System.Windows.Forms.Binding

Module:System.Windows.Forms.dll

Hierarchy
Object
Binding

Type declaration

[C#] public class Binding;

Constructor
public Binding(string strPropertyName, object datasrc, string strDataMember);

Method
public void add_Format(ConvertEventHandler value);
public void add_Parse(ConvertEventHandler value);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
protected virtual void OnFormat(ConvertEventArgs cevent);
protected virtual void OnParse(ConvertEventArgs cevent);
public void remove_Format(ConvertEventHandler value);
public void remove_Parse(ConvertEventHandler value);
public virtual string ToString();

Property
public BindingManagerBase BindingManagerBase {get;}
public BindingMemberInfo BindingMemberInfo {get;}
public Control Control {get;}
public object DataSource {get;}
public bool IsBinding {get;}
public string PropertyName {get;}

System.Windows.Forms.BaseCollection

Module:System.Windows.Forms.dll

Hierarchy
Object
MarshalByRefObject
BaseCollection : ICollection, IEnumerable

Type declaration

[C#] public class BaseCollection : MarshalByRefObject, ICollection, IEnumerable;

Constructor
public BaseCollection();

Method
public virtual void CopyTo(Array ar, int index);
public ObjRef CreateObjRef(Type requestedType);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual IEnumerator GetEnumerator();
public virtual int GetHashCode();
public object GetLifetimeService();
public Type GetType();
public object InitializeLifetimeService();
protected object MemberwiseClone();
public virtual string ToString();

Property
public virtual int Count {get;}
public bool IsReadOnly {get;}
public virtual bool IsSynchronized {get;}
protected virtual ArrayList List {get;}
public virtual object SyncRoot {get;}

System.Windows.Forms.OpenFileDialog

Module:System.Windows.Forms.dll

Hierarchy
Object
MarshalByRefObject
Component
CommonDialog
FileDialog
OpenFileDialog

Type declaration

[C#] public sealed class OpenFileDialog : FileDialog;

Constructor
public OpenFileDialog();

Method
public void add_Disposed(EventHandler value);
public void add_FileOk(CancelEventHandler value);
public void add_HelpRequest(EventHandler value);
public ObjRef CreateObjRef(Type requestedType);
public void Dispose();
protected virtual void Dispose(bool disposing);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public object GetLifetimeService();
protected virtual object GetService(Type service);
public Type GetType();
protected virtual IntPtr HookProc(IntPtr hWnd, int msg, IntPtr wparam, IntPtr lparam);
public object InitializeLifetimeService();
protected object MemberwiseClone();
protected void OnFileOk(CancelEventArgs e);
protected virtual void OnHelpRequest(EventArgs e);
public Stream OpenFile();
protected virtual IntPtr OwnerWndProc(IntPtr hWnd, int msg, IntPtr wparam, IntPtr lparam);
public void remove_Disposed(EventHandler value);
public void remove_FileOk(CancelEventHandler value);
public void remove_HelpRequest(EventHandler value);
public override void Reset();
protected virtual bool RunDialog(IntPtr hWndOwner);
public DialogResult ShowDialog();
public DialogResult ShowDialog(IWin32Window owner);
public virtual string ToString();

Property
public bool AddExtension {get; set;}
public override bool CheckFileExists {get; set;}
public bool CheckPathExists {get; set;}
public IContainer Container {get;}
public string DefaultExt {get; set;}
public bool DereferenceLinks {get; set;}
protected bool DesignMode {get;}
protected EventHandlerList Events {get;}
public string FileName {get; set;}
public string[] FileNames {get;}
public string Filter {get; set;}
public int FilterIndex {get; set;}
public string InitialDirectory {get; set;}
protected virtual IntPtr Instance {get;}
public bool Multiselect {get; set;}
protected int Options {get;}
public bool ReadOnlyChecked {get; set;}
public bool RestoreDirectory {get; set;}
public bool ShowHelp {get; set;}
public bool ShowReadOnly {get; set;}
public ISite Site {get; set;}
public string Title {get; set;}
public bool ValidateNames {get; set;}

System.Windows.Forms.Orientation

Module:System.Windows.Forms.dll

Hierarchy
Object
ValueType
Enum
Orientation

Type declaration

[C#] public enum Orientation;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const Orientation Horizontal = 0;
public int value__;
public const Orientation Vertical = 1;

System.Windows.Forms.TrackBar

Module:System.Windows.Forms.dll

Hierarchy
Object
MarshalByRefObject
Component
Control
TrackBar

Type declaration

[C#] public class TrackBar : Control;

Constructor
public TrackBar();

Method
protected void AccessibilityNotifyClients(AccessibleEvents accEvent, int childID);
public void add_BackColorChanged(EventHandler value);
public void add_BackgroundImageChanged(EventHandler value);
public void add_BindingContextChanged(EventHandler value);
public void add_CausesValidationChanged(EventHandler value);
public void add_ChangeUICues(UICuesEventHandler value);
public void add_Click(EventHandler value);
public void add_ContextMenuChanged(EventHandler value);
public void add_ControlAdded(ControlEventHandler value);
public void add_ControlRemoved(ControlEventHandler value);
public void add_CursorChanged(EventHandler value);
public void add_Disposed(EventHandler value);
public void add_DockChanged(EventHandler value);
public void add_DoubleClick(EventHandler value);
public void add_DragDrop(DragEventHandler value);
public void add_DragEnter(DragEventHandler value);
public void add_DragLeave(EventHandler value);
public void add_DragOver(DragEventHandler value);
public void add_EnabledChanged(EventHandler value);
public void add_Enter(EventHandler value);
public void add_FontChanged(EventHandler value);
public void add_ForeColorChanged(EventHandler value);
public void add_GiveFeedback(GiveFeedbackEventHandler value);
public void add_GotFocus(EventHandler value);
public void add_HandleCreated(EventHandler value);
public void add_HandleDestroyed(EventHandler value);
public void add_HelpRequested(HelpEventHandler value);
public void add_ImeModeChanged(EventHandler value);
public void add_Invalidated(InvalidateEventHandler value);
public void add_KeyDown(KeyEventHandler value);
public void add_KeyPress(KeyPressEventHandler value);
public void add_KeyUp(KeyEventHandler value);
public void add_Layout(LayoutEventHandler value);
public void add_Leave(EventHandler value);
public void add_LocationChanged(EventHandler value);
public void add_LostFocus(EventHandler value);
public void add_MouseDown(MouseEventHandler value);
public void add_MouseEnter(EventHandler value);
public void add_MouseHover(EventHandler value);
public void add_MouseLeave(EventHandler value);
public void add_MouseMove(MouseEventHandler value);
public void add_MouseUp(MouseEventHandler value);
public void add_MouseWheel(MouseEventHandler value);
public void add_Move(EventHandler value);
public void add_Paint(PaintEventHandler value);
public void add_ParentChanged(EventHandler value);
public void add_QueryAccessibilityHelp(QueryAccessibilityHelpEventHandler value);
public void add_QueryContinueDrag(QueryContinueDragEventHandler value);
public void add_Resize(EventHandler value);
public void add_RightToLeftChanged(EventHandler value);
public void add_Scroll(EventHandler value);
public void add_SizeChanged(EventHandler value);
public void add_StyleChanged(EventHandler value);
public void add_SystemColorsChanged(EventHandler value);
public void add_TabIndexChanged(EventHandler value);
public void add_TabStopChanged(EventHandler value);
public void add_TextChanged(EventHandler value);
public void add_Validated(EventHandler value);
public void add_Validating(CancelEventHandler value);
public void add_ValueChanged(EventHandler value);
public void add_VisibleChanged(EventHandler value);
public virtual void BeginInit();
public IAsyncResult BeginInvoke(Delegate method);
public IAsyncResult BeginInvoke(Delegate method, object[] args);
public void BringToFront();
public bool Contains(Control ctl);
protected virtual AccessibleObject CreateAccessibilityInstance();
public void CreateControl();
protected virtual ControlCollection CreateControlsInstance();
public Graphics CreateGraphics();
protected virtual void CreateHandle();
public ObjRef CreateObjRef(Type requestedType);
protected virtual void DefWndProc(ref Message m);
protected virtual void DestroyHandle();
public void Dispose();
protected override void Dispose(bool disposing);
public DragDropEffects DoDragDrop(object data, DragDropEffects allowedEffects);
public virtual void EndInit();
public object EndInvoke(IAsyncResult asyncResult);
public virtual bool Equals(object obj);
protected override void Finalize();
public Form FindForm();
public bool Focus();
public Control GetChildAtPoint(Point pt);
public IContainerControl GetContainerControl();
public virtual int GetHashCode();
public object GetLifetimeService();
public Control GetNextControl(Control ctl, bool forward);
protected virtual object GetService(Type service);
protected bool GetStyle(ControlStyles flag);
protected bool GetTopLevel();
public Type GetType();
public void Hide();
public object InitializeLifetimeService();
protected virtual void InitLayout();
public void Invalidate();
public void Invalidate(bool invalidateChildren);
public void Invalidate(Rectangle rect);
public void Invalidate(Rectangle rc, bool invalidateChildren);
public void Invalidate(Region region);
public void Invalidate(Region region, bool invalidateChildren);
public object Invoke(Delegate method);
public object Invoke(Delegate method, object[] args);
protected void InvokeGotFocus(Control toInvoke, EventArgs e);
protected void InvokeLostFocus(Control toInvoke, EventArgs e);
protected void InvokeOnClick(Control toInvoke, EventArgs e);
protected void InvokePaint(Control c, PaintEventArgs e);
protected void InvokePaintBackground(Control c, PaintEventArgs e);
protected virtual bool IsInputChar(char charCode);
protected virtual bool IsInputKey(Keys keyData);
protected object MemberwiseClone();
protected virtual void NotifyInvalidate(Rectangle invalidatedArea);
protected virtual void OnBackColorChanged(EventArgs e);
protected virtual void OnBackgroundImageChanged(EventArgs e);
protected virtual void OnBindingContextChanged(EventArgs e);
protected virtual void OnCausesValidationChanged(EventArgs e);
protected virtual void OnChangeUICues(UICuesEventArgs e);
protected virtual void OnClick(EventArgs e);
protected virtual void OnContextMenuChanged(EventArgs e);
protected virtual void OnControlAdded(ControlEventArgs e);
protected virtual void OnControlRemoved(ControlEventArgs e);
protected virtual void OnCreateControl();
protected virtual void OnCursorChanged(EventArgs e);
protected virtual void OnDockChanged(EventArgs e);
protected virtual void OnDoubleClick(EventArgs e);
protected virtual void OnDragDrop(DragEventArgs drgevent);
protected virtual void OnDragEnter(DragEventArgs drgevent);
protected virtual void OnDragLeave(EventArgs e);
protected virtual void OnDragOver(DragEventArgs drgevent);
protected virtual void OnEnabledChanged(EventArgs e);
protected virtual void OnEnter(EventArgs e);
protected virtual void OnFontChanged(EventArgs e);
protected virtual void OnForeColorChanged(EventArgs e);
protected virtual void OnGiveFeedback(GiveFeedbackEventArgs gfbevent);
protected virtual void OnGotFocus(EventArgs e);
protected virtual void OnHandleCreated(EventArgs e);
protected virtual void OnHandleDestroyed(EventArgs e);
protected virtual void OnHelpRequested(HelpEventArgs hevent);
protected virtual void OnImeModeChanged(EventArgs e);
protected virtual void OnInvalidated(InvalidateEventArgs e);
protected virtual void OnKeyDown(KeyEventArgs e);
protected virtual void OnKeyPress(KeyPressEventArgs e);
protected virtual void OnKeyUp(KeyEventArgs e);
protected virtual void OnLayout(LayoutEventArgs levent);
protected virtual void OnLeave(EventArgs e);
protected virtual void OnLocationChanged(EventArgs e);
protected virtual void OnLostFocus(EventArgs e);
protected virtual void OnMouseDown(MouseEventArgs e);
protected virtual void OnMouseEnter(EventArgs e);
protected virtual void OnMouseHover(EventArgs e);
protected virtual void OnMouseLeave(EventArgs e);
protected virtual void OnMouseMove(MouseEventArgs e);
protected virtual void OnMouseUp(MouseEventArgs e);
protected virtual void OnMouseWheel(MouseEventArgs e);
protected virtual void OnMove(EventArgs e);
protected virtual void OnNotifyMessage(Message m);
protected virtual void OnPaint(PaintEventArgs e);
protected virtual void OnPaintBackground(PaintEventArgs e);
protected virtual void OnParentBackColorChanged(EventArgs e);
protected virtual void OnParentBackgroundImageChanged(EventArgs e);
protected virtual void OnParentBindingContextChanged(EventArgs e);
protected virtual void OnParentChanged(EventArgs e);
protected virtual void OnParentEnabledChanged(EventArgs e);
protected virtual void OnParentFontChanged(EventArgs e);
protected virtual void OnParentForeColorChanged(EventArgs e);
protected virtual void OnParentRightToLeftChanged(EventArgs e);
protected virtual void OnParentVisibleChanged(EventArgs e);
protected virtual void OnQueryContinueDrag(QueryContinueDragEventArgs qcdevent);
protected virtual void OnResize(EventArgs e);
protected virtual void OnRightToLeftChanged(EventArgs e);
protected virtual void OnScroll(EventArgs e);
protected virtual void OnSizeChanged(EventArgs e);
protected virtual void OnStyleChanged(EventArgs e);
protected virtual void OnSystemColorsChanged(EventArgs e);
protected virtual void OnTabIndexChanged(EventArgs e);
protected virtual void OnTabStopChanged(EventArgs e);
protected virtual void OnTextChanged(EventArgs e);
protected virtual void OnValidated(EventArgs e);
protected virtual void OnValidating(CancelEventArgs e);
protected virtual void OnValueChanged(EventArgs eventg);
protected virtual void OnVisibleChanged(EventArgs e);
public void PerformLayout();
public void PerformLayout(Control affectedControl, string affectedProperty);
public Point PointToClient(Point p);
public Point PointToScreen(Point p);
public bool PreProcessMessage(ref Message msg);
protected virtual bool ProcessCmdKey(ref Message msg, Keys keyData);
protected virtual bool ProcessDialogChar(char charCode);
protected virtual bool ProcessDialogKey(Keys keyData);
protected virtual bool ProcessKeyEventArgs(ref Message m);
protected virtual bool ProcessKeyPreview(ref Message m);
protected virtual bool ProcessMnemonic(char charCode);
protected void RaiseDragEvent(object key, DragEventArgs e);
protected void RaiseKeyEvent(object key, KeyEventArgs e);
protected void RaiseMouseEvent(object key, MouseEventArgs e);
protected void RaisePaintEvent(object key, PaintEventArgs e);
protected void RecreateHandle();
public Rectangle RectangleToClient(Rectangle r);
public Rectangle RectangleToScreen(Rectangle r);
public virtual void Refresh();
public void remove_BackColorChanged(EventHandler value);
public void remove_BackgroundImageChanged(EventHandler value);
public void remove_BindingContextChanged(EventHandler value);
public void remove_CausesValidationChanged(EventHandler value);
public void remove_ChangeUICues(UICuesEventHandler value);
public void remove_Click(EventHandler value);
public void remove_ContextMenuChanged(EventHandler value);
public void remove_ControlAdded(ControlEventHandler value);
public void remove_ControlRemoved(ControlEventHandler value);
public void remove_CursorChanged(EventHandler value);
public void remove_Disposed(EventHandler value);
public void remove_DockChanged(EventHandler value);
public void remove_DoubleClick(EventHandler value);
public void remove_DragDrop(DragEventHandler value);
public void remove_DragEnter(DragEventHandler value);
public void remove_DragLeave(EventHandler value);
public void remove_DragOver(DragEventHandler value);
public void remove_EnabledChanged(EventHandler value);
public void remove_Enter(EventHandler value);
public void remove_FontChanged(EventHandler value);
public void remove_ForeColorChanged(EventHandler value);
public void remove_GiveFeedback(GiveFeedbackEventHandler value);
public void remove_GotFocus(EventHandler value);
public void remove_HandleCreated(EventHandler value);
public void remove_HandleDestroyed(EventHandler value);
public void remove_HelpRequested(HelpEventHandler value);
public void remove_ImeModeChanged(EventHandler value);
public void remove_Invalidated(InvalidateEventHandler value);
public void remove_KeyDown(KeyEventHandler value);
public void remove_KeyPress(KeyPressEventHandler value);
public void remove_KeyUp(KeyEventHandler value);
public void remove_Layout(LayoutEventHandler value);
public void remove_Leave(EventHandler value);
public void remove_LocationChanged(EventHandler value);
public void remove_LostFocus(EventHandler value);
public void remove_MouseDown(MouseEventHandler value);
public void remove_MouseEnter(EventHandler value);
public void remove_MouseHover(EventHandler value);
public void remove_MouseLeave(EventHandler value);
public void remove_MouseMove(MouseEventHandler value);
public void remove_MouseUp(MouseEventHandler value);
public void remove_MouseWheel(MouseEventHandler value);
public void remove_Move(EventHandler value);
public void remove_Paint(PaintEventHandler value);
public void remove_ParentChanged(EventHandler value);
public void remove_QueryAccessibilityHelp(QueryAccessibilityHelpEventHandler value);
public void remove_QueryContinueDrag(QueryContinueDragEventHandler value);
public void remove_Resize(EventHandler value);
public void remove_RightToLeftChanged(EventHandler value);
public void remove_Scroll(EventHandler value);
public void remove_SizeChanged(EventHandler value);
public void remove_StyleChanged(EventHandler value);
public void remove_SystemColorsChanged(EventHandler value);
public void remove_TabIndexChanged(EventHandler value);
public void remove_TabStopChanged(EventHandler value);
public void remove_TextChanged(EventHandler value);
public void remove_Validated(EventHandler value);
public void remove_Validating(CancelEventHandler value);
public void remove_ValueChanged(EventHandler value);
public void remove_VisibleChanged(EventHandler value);
public void ResetBackColor();
public void ResetBindings();
public void ResetCursor();
public void ResetFont();
public void ResetForeColor();
public void ResetImeMode();
protected void ResetMouseEventArgs();
public void ResetRightToLeft();
public void ResetText();
public void ResumeLayout();
public void ResumeLayout(bool performLayout);
protected ContentAlignment RtlTranslateAlignment(ContentAlignment align);
protected HorizontalAlignment RtlTranslateAlignment(HorizontalAlignment align);
protected LeftRightAlignment RtlTranslateAlignment(LeftRightAlignment align);
protected ContentAlignment RtlTranslateContent(ContentAlignment align);
protected HorizontalAlignment RtlTranslateHorizontal(HorizontalAlignment align);
protected LeftRightAlignment RtlTranslateLeftRight(LeftRightAlignment align);
public void Scale(float ratio);
public void Scale(float dx, float dy);
protected virtual void ScaleCore(float dx, float dy);
public void Select();
protected virtual void Select(bool directed, bool forward);
public bool SelectNextControl(Control ctl, bool forward, bool tabStopOnly, bool nested, bool wrap);
public void SendToBack();
public void SetBounds(int x, int y, int width, int height);
public void SetBounds(int x, int y, int width, int height, BoundsSpecified specified);
protected virtual void SetBoundsCore(int x, int y, int width, int height, BoundsSpecified specified);
protected virtual void SetClientSizeCore(int x, int y);
public void SetRange(int minValue, int maxValue);
protected void SetStyle(ControlStyles flag, bool value);
protected void SetTopLevel(bool value);
protected virtual void SetVisibleCore(bool value);
public void Show();
public void SuspendLayout();
public virtual string ToString();
public void Update();
protected void UpdateBounds();
protected void UpdateBounds(int x, int y, int width, int height);
protected void UpdateBounds(int x, int y, int width, int height, int clientWidth, int clientHeight);
protected void UpdateStyles();
protected void UpdateZOrder();
protected virtual void WndProc(ref Message m);

Property
public AccessibleObject AccessibilityObject {get;}
public string AccessibleDefaultActionDescription {get; set;}
public string AccessibleDescription {get; set;}
public string AccessibleName {get; set;}
public AccessibleRole AccessibleRole {get; set;}
public bool AllowDrop {get; set;}
public AnchorStyles Anchor {get; set;}
public bool AutoSize {get; set;}
public virtual Color BackColor {get; set;}
public override Image BackgroundImage {get; set;}
public virtual BindingContext BindingContext {get; set;}
public int Bottom {get;}
public Rectangle Bounds {get; set;}
public bool CanFocus {get;}
public bool CanSelect {get;}
public bool Capture {get; set;}
public bool CausesValidation {get; set;}
public Rectangle ClientRectangle {get;}
public Size ClientSize {get; set;}
public string CompanyName {get;}
public IContainer Container {get;}
public bool ContainsFocus {get;}
public ContextMenu ContextMenu {get; set;}
public ControlCollection Controls {get;}
public bool Created {get;}
protected virtual CreateParams CreateParams {get;}
public Cursor Cursor {get; set;}
public ControlBindingsCollection DataBindings {get;}
protected virtual ImeMode DefaultImeMode {get;}
protected virtual Size DefaultSize {get;}
protected bool DesignMode {get;}
public Rectangle DisplayRectangle {get;}
public bool Disposing {get;}
public DockStyle Dock {get; set;}
public bool Enabled {get; set;}
protected EventHandlerList Events {get;}
public bool Focused {get;}
public virtual Font Font {get; set;}
protected int FontHeight {get; set;}
public virtual Color ForeColor {get; set;}
public IntPtr Handle {get;}
public bool HasChildren {get;}
public int Height {get; set;}
public ImeMode ImeMode {get; set;}
public bool InvokeRequired {get;}
public bool IsAccessible {get; set;}
public bool IsDisposed {get;}
public bool IsHandleCreated {get;}
public int LargeChange {get; set;}
public int Left {get; set;}
public Point Location {get; set;}
public int Maximum {get; set;}
public int Minimum {get; set;}
public string Name {get; set;}
public Orientation Orientation {get; set;}
public Control Parent {get; set;}
public string ProductName {get;}
public string ProductVersion {get;}
public bool RecreatingHandle {get;}
public Region Region {get; set;}
protected bool RenderRightToLeft {get;}
protected bool ResizeRedraw {get; set;}
public int Right {get;}
public RightToLeft RightToLeft {get; set;}
protected virtual bool ShowFocusCues {get;}
protected bool ShowKeyboardCues {get;}
public ISite Site {get; set;}
public Size Size {get; set;}
public int SmallChange {get; set;}
public int TabIndex {get; set;}
public bool TabStop {get; set;}
public object Tag {get; set;}
public virtual string Text {get; set;}
public int TickFrequency {get; set;}
public TickStyle TickStyle {get; set;}
public int Top {get; set;}
public Control TopLevelControl {get;}
public int Value {get; set;}
public bool Visible {get; set;}
public int Width {get; set;}
public IWindowTarget WindowTarget {get; set;}

System.Windows.Forms.ToolBarButtonClickEventHandler

Module:System.Windows.Forms.dll

Hierarchy
Object
Delegate
MulticastDelegate
ToolBarButtonClickEventHandler

Type declaration

[C#] public delegate void ToolBarButtonClickEventHandler(object sender, ToolBarButtonClickEventArgs e);

Constructor
public ToolBarButtonClickEventHandler(object object, IntPtr method);

Method
public virtual IAsyncResult BeginInvoke(object sender, ToolBarButtonClickEventArgs e, AsyncCallback callback, object object);
public object Clone();
protected override Delegate CombineImpl(Delegate follow);
public object DynamicInvoke(object[] args);
protected virtual object DynamicInvokeImpl(object[] args);
public virtual void EndInvoke(IAsyncResult result);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public override Delegate[] GetInvocationList();
protected virtual MethodInfo GetMethodImpl();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
public override void Invoke(object sender, ToolBarButtonClickEventArgs e);
protected object MemberwiseClone();
protected override Delegate RemoveImpl(Delegate value);
public virtual string ToString();

Property
public MethodInfo Method {get;}
public object Target {get;}

System.Windows.Forms.ToolBarButtonClickEventArgs

Module:System.Windows.Forms.dll

Hierarchy
Object
EventArgs
ToolBarButtonClickEventArgs

Type declaration

[C#] public class ToolBarButtonClickEventArgs : EventArgs;

Constructor
public ToolBarButtonClickEventArgs(ToolBarButton button);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public ToolBarButton Button {get; set;}

System.Windows.Forms.ToolBarButtonStyle

Module:System.Windows.Forms.dll

Hierarchy
Object
ValueType
Enum
ToolBarButtonStyle

Type declaration

[C#] public enum ToolBarButtonStyle;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const ToolBarButtonStyle DropDownButton = 4;
public const ToolBarButtonStyle PushButton = 1;
public const ToolBarButtonStyle Separator = 3;
public const ToolBarButtonStyle ToggleButton = 2;
public int value__;

System.Windows.Forms.ToolBarButton

Module:System.Windows.Forms.dll

Hierarchy
Object
MarshalByRefObject
Component
ToolBarButton

Type declaration

[C#] public class ToolBarButton : Component;

Constructor
public ToolBarButton();
public ToolBarButton(string text);

Method
public void add_Disposed(EventHandler value);
public ObjRef CreateObjRef(Type requestedType);
public void Dispose();
protected virtual void Dispose(bool disposing);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public object GetLifetimeService();
protected virtual object GetService(Type service);
public Type GetType();
public object InitializeLifetimeService();
protected object MemberwiseClone();
public void remove_Disposed(EventHandler value);
public virtual string ToString();

Property
public IContainer Container {get;}
protected bool DesignMode {get;}
public Menu DropDownMenu {get; set;}
public bool Enabled {get; set;}
protected EventHandlerList Events {get;}
public int ImageIndex {get; set;}
public ToolBar Parent {get;}
public bool PartialPush {get; set;}
public bool Pushed {get; set;}
public Rectangle Rectangle {get;}
public ISite Site {get; set;}
public ToolBarButtonStyle Style {get; set;}
public object Tag {get; set;}
public string Text {get; set;}
public string ToolTipText {get; set;}
public bool Visible {get; set;}

System.Windows.Forms.ToolBar+ToolBarButtonCollection

Module:System.Windows.Forms.dll

Hierarchy
Object
ToolBar+ToolBarButtonCollection : IList, ICollection, IEnumerable

Type declaration

[C#] public class ToolBarButtonCollection: IList, ICollection, IEnumerable;

Constructor
public ToolBarButtonCollection(ToolBar owner);

Method
public int Add(string text);
public int Add(ToolBarButton tbrb);
public void AddRange(ToolBarButton[] buttons);
public virtual void Clear();
public bool Contains(ToolBarButton tbrb);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual IEnumerator GetEnumerator();
public virtual int GetHashCode();
public Type GetType();
public int IndexOf(ToolBarButton tbrb);
public void Insert(int index, ToolBarButton value);
protected object MemberwiseClone();
public void Remove(ToolBarButton tbrb);
public virtual void RemoveAt(int index);
public virtual string ToString();

Property
public virtual int Count {get;}
public virtual bool IsReadOnly {get;}
public virtual ToolBarButton this[int index] {get; set;}

System.Windows.Forms.ToolBar

Module:System.Windows.Forms.dll

Hierarchy
Object
MarshalByRefObject
Component
Control
ToolBar

Type declaration

[C#] public class ToolBar : Control;

Constructor
public ToolBar();

Method
protected void AccessibilityNotifyClients(AccessibleEvents accEvent, int childID);
public void add_BackColorChanged(EventHandler value);
public void add_BackgroundImageChanged(EventHandler value);
public void add_BindingContextChanged(EventHandler value);
public void add_ButtonClick(ToolBarButtonClickEventHandler value);
public void add_ButtonDropDown(ToolBarButtonClickEventHandler value);
public void add_CausesValidationChanged(EventHandler value);
public void add_ChangeUICues(UICuesEventHandler value);
public void add_Click(EventHandler value);
public void add_ContextMenuChanged(EventHandler value);
public void add_ControlAdded(ControlEventHandler value);
public void add_ControlRemoved(ControlEventHandler value);
public void add_CursorChanged(EventHandler value);
public void add_Disposed(EventHandler value);
public void add_DockChanged(EventHandler value);
public void add_DoubleClick(EventHandler value);
public void add_DragDrop(DragEventHandler value);
public void add_DragEnter(DragEventHandler value);
public void add_DragLeave(EventHandler value);
public void add_DragOver(DragEventHandler value);
public void add_EnabledChanged(EventHandler value);
public void add_Enter(EventHandler value);
public void add_FontChanged(EventHandler value);
public void add_ForeColorChanged(EventHandler value);
public void add_GiveFeedback(GiveFeedbackEventHandler value);
public void add_GotFocus(EventHandler value);
public void add_HandleCreated(EventHandler value);
public void add_HandleDestroyed(EventHandler value);
public void add_HelpRequested(HelpEventHandler value);
public void add_ImeModeChanged(EventHandler value);
public void add_Invalidated(InvalidateEventHandler value);
public void add_KeyDown(KeyEventHandler value);
public void add_KeyPress(KeyPressEventHandler value);
public void add_KeyUp(KeyEventHandler value);
public void add_Layout(LayoutEventHandler value);
public void add_Leave(EventHandler value);
public void add_LocationChanged(EventHandler value);
public void add_LostFocus(EventHandler value);
public void add_MouseDown(MouseEventHandler value);
public void add_MouseEnter(EventHandler value);
public void add_MouseHover(EventHandler value);
public void add_MouseLeave(EventHandler value);
public void add_MouseMove(MouseEventHandler value);
public void add_MouseUp(MouseEventHandler value);
public void add_MouseWheel(MouseEventHandler value);
public void add_Move(EventHandler value);
public void add_Paint(PaintEventHandler value);
public void add_ParentChanged(EventHandler value);
public void add_QueryAccessibilityHelp(QueryAccessibilityHelpEventHandler value);
public void add_QueryContinueDrag(QueryContinueDragEventHandler value);
public void add_Resize(EventHandler value);
public void add_RightToLeftChanged(EventHandler value);
public void add_SizeChanged(EventHandler value);
public void add_StyleChanged(EventHandler value);
public void add_SystemColorsChanged(EventHandler value);
public void add_TabIndexChanged(EventHandler value);
public void add_TabStopChanged(EventHandler value);
public void add_TextChanged(EventHandler value);
public void add_Validated(EventHandler value);
public void add_Validating(CancelEventHandler value);
public void add_VisibleChanged(EventHandler value);
public IAsyncResult BeginInvoke(Delegate method);
public IAsyncResult BeginInvoke(Delegate method, object[] args);
public void BringToFront();
public bool Contains(Control ctl);
protected virtual AccessibleObject CreateAccessibilityInstance();
public void CreateControl();
protected virtual ControlCollection CreateControlsInstance();
public Graphics CreateGraphics();
protected virtual void CreateHandle();
public ObjRef CreateObjRef(Type requestedType);
protected virtual void DefWndProc(ref Message m);
protected virtual void DestroyHandle();
public void Dispose();
protected override void Dispose(bool disposing);
public DragDropEffects DoDragDrop(object data, DragDropEffects allowedEffects);
public object EndInvoke(IAsyncResult asyncResult);
public virtual bool Equals(object obj);
protected override void Finalize();
public Form FindForm();
public bool Focus();
public Control GetChildAtPoint(Point pt);
public IContainerControl GetContainerControl();
public virtual int GetHashCode();
public object GetLifetimeService();
public Control GetNextControl(Control ctl, bool forward);
protected virtual object GetService(Type service);
protected bool GetStyle(ControlStyles flag);
protected bool GetTopLevel();
public Type GetType();
public void Hide();
public object InitializeLifetimeService();
protected virtual void InitLayout();
public void Invalidate();
public void Invalidate(bool invalidateChildren);
public void Invalidate(Rectangle rect);
public void Invalidate(Rectangle rc, bool invalidateChildren);
public void Invalidate(Region region);
public void Invalidate(Region region, bool invalidateChildren);
public object Invoke(Delegate method);
public object Invoke(Delegate method, object[] args);
protected void InvokeGotFocus(Control toInvoke, EventArgs e);
protected void InvokeLostFocus(Control toInvoke, EventArgs e);
protected void InvokeOnClick(Control toInvoke, EventArgs e);
protected void InvokePaint(Control c, PaintEventArgs e);
protected void InvokePaintBackground(Control c, PaintEventArgs e);
protected virtual bool IsInputChar(char charCode);
protected virtual bool IsInputKey(Keys keyData);
protected object MemberwiseClone();
protected virtual void NotifyInvalidate(Rectangle invalidatedArea);
protected virtual void OnBackColorChanged(EventArgs e);
protected virtual void OnBackgroundImageChanged(EventArgs e);
protected virtual void OnBindingContextChanged(EventArgs e);
protected virtual void OnButtonClick(ToolBarButtonClickEventArgs e);
protected virtual void OnButtonDropDown(ToolBarButtonClickEventArgs e);
protected virtual void OnCausesValidationChanged(EventArgs e);
protected virtual void OnChangeUICues(UICuesEventArgs e);
protected virtual void OnClick(EventArgs e);
protected virtual void OnContextMenuChanged(EventArgs e);
protected virtual void OnControlAdded(ControlEventArgs e);
protected virtual void OnControlRemoved(ControlEventArgs e);
protected virtual void OnCreateControl();
protected virtual void OnCursorChanged(EventArgs e);
protected virtual void OnDockChanged(EventArgs e);
protected virtual void OnDoubleClick(EventArgs e);
protected virtual void OnDragDrop(DragEventArgs drgevent);
protected virtual void OnDragEnter(DragEventArgs drgevent);
protected virtual void OnDragLeave(EventArgs e);
protected virtual void OnDragOver(DragEventArgs drgevent);
protected virtual void OnEnabledChanged(EventArgs e);
protected virtual void OnEnter(EventArgs e);
protected virtual void OnFontChanged(EventArgs e);
protected virtual void OnForeColorChanged(EventArgs e);
protected virtual void OnGiveFeedback(GiveFeedbackEventArgs gfbevent);
protected virtual void OnGotFocus(EventArgs e);
protected virtual void OnHandleCreated(EventArgs e);
protected virtual void OnHandleDestroyed(EventArgs e);
protected virtual void OnHelpRequested(HelpEventArgs hevent);
protected virtual void OnImeModeChanged(EventArgs e);
protected virtual void OnInvalidated(InvalidateEventArgs e);
protected virtual void OnKeyDown(KeyEventArgs e);
protected virtual void OnKeyPress(KeyPressEventArgs e);
protected virtual void OnKeyUp(KeyEventArgs e);
protected virtual void OnLayout(LayoutEventArgs levent);
protected virtual void OnLeave(EventArgs e);
protected virtual void OnLocationChanged(EventArgs e);
protected virtual void OnLostFocus(EventArgs e);
protected virtual void OnMouseDown(MouseEventArgs e);
protected virtual void OnMouseEnter(EventArgs e);
protected virtual void OnMouseHover(EventArgs e);
protected virtual void OnMouseLeave(EventArgs e);
protected virtual void OnMouseMove(MouseEventArgs e);
protected virtual void OnMouseUp(MouseEventArgs e);
protected virtual void OnMouseWheel(MouseEventArgs e);
protected virtual void OnMove(EventArgs e);
protected virtual void OnNotifyMessage(Message m);
protected virtual void OnPaint(PaintEventArgs e);
protected virtual void OnPaintBackground(PaintEventArgs e);
protected virtual void OnParentBackColorChanged(EventArgs e);
protected virtual void OnParentBackgroundImageChanged(EventArgs e);
protected virtual void OnParentBindingContextChanged(EventArgs e);
protected virtual void OnParentChanged(EventArgs e);
protected virtual void OnParentEnabledChanged(EventArgs e);
protected virtual void OnParentFontChanged(EventArgs e);
protected virtual void OnParentForeColorChanged(EventArgs e);
protected virtual void OnParentRightToLeftChanged(EventArgs e);
protected virtual void OnParentVisibleChanged(EventArgs e);
protected virtual void OnQueryContinueDrag(QueryContinueDragEventArgs qcdevent);
protected virtual void OnResize(EventArgs e);
protected virtual void OnRightToLeftChanged(EventArgs e);
protected virtual void OnSizeChanged(EventArgs e);
protected virtual void OnStyleChanged(EventArgs e);
protected virtual void OnSystemColorsChanged(EventArgs e);
protected virtual void OnTabIndexChanged(EventArgs e);
protected virtual void OnTabStopChanged(EventArgs e);
protected virtual void OnTextChanged(EventArgs e);
protected virtual void OnValidated(EventArgs e);
protected virtual void OnValidating(CancelEventArgs e);
protected virtual void OnVisibleChanged(EventArgs e);
public void PerformLayout();
public void PerformLayout(Control affectedControl, string affectedProperty);
public Point PointToClient(Point p);
public Point PointToScreen(Point p);
public bool PreProcessMessage(ref Message msg);
protected virtual bool ProcessCmdKey(ref Message msg, Keys keyData);
protected virtual bool ProcessDialogChar(char charCode);
protected virtual bool ProcessDialogKey(Keys keyData);
protected virtual bool ProcessKeyEventArgs(ref Message m);
protected virtual bool ProcessKeyPreview(ref Message m);
protected virtual bool ProcessMnemonic(char charCode);
protected void RaiseDragEvent(object key, DragEventArgs e);
protected void RaiseKeyEvent(object key, KeyEventArgs e);
protected void RaiseMouseEvent(object key, MouseEventArgs e);
protected void RaisePaintEvent(object key, PaintEventArgs e);
protected void RecreateHandle();
public Rectangle RectangleToClient(Rectangle r);
public Rectangle RectangleToScreen(Rectangle r);
public virtual void Refresh();
public void remove_BackColorChanged(EventHandler value);
public void remove_BackgroundImageChanged(EventHandler value);
public void remove_BindingContextChanged(EventHandler value);
public void remove_ButtonClick(ToolBarButtonClickEventHandler value);
public void remove_ButtonDropDown(ToolBarButtonClickEventHandler value);
public void remove_CausesValidationChanged(EventHandler value);
public void remove_ChangeUICues(UICuesEventHandler value);
public void remove_Click(EventHandler value);
public void remove_ContextMenuChanged(EventHandler value);
public void remove_ControlAdded(ControlEventHandler value);
public void remove_ControlRemoved(ControlEventHandler value);
public void remove_CursorChanged(EventHandler value);
public void remove_Disposed(EventHandler value);
public void remove_DockChanged(EventHandler value);
public void remove_DoubleClick(EventHandler value);
public void remove_DragDrop(DragEventHandler value);
public void remove_DragEnter(DragEventHandler value);
public void remove_DragLeave(EventHandler value);
public void remove_DragOver(DragEventHandler value);
public void remove_EnabledChanged(EventHandler value);
public void remove_Enter(EventHandler value);
public void remove_FontChanged(EventHandler value);
public void remove_ForeColorChanged(EventHandler value);
public void remove_GiveFeedback(GiveFeedbackEventHandler value);
public void remove_GotFocus(EventHandler value);
public void remove_HandleCreated(EventHandler value);
public void remove_HandleDestroyed(EventHandler value);
public void remove_HelpRequested(HelpEventHandler value);
public void remove_ImeModeChanged(EventHandler value);
public void remove_Invalidated(InvalidateEventHandler value);
public void remove_KeyDown(KeyEventHandler value);
public void remove_KeyPress(KeyPressEventHandler value);
public void remove_KeyUp(KeyEventHandler value);
public void remove_Layout(LayoutEventHandler value);
public void remove_Leave(EventHandler value);
public void remove_LocationChanged(EventHandler value);
public void remove_LostFocus(EventHandler value);
public void remove_MouseDown(MouseEventHandler value);
public void remove_MouseEnter(EventHandler value);
public void remove_MouseHover(EventHandler value);
public void remove_MouseLeave(EventHandler value);
public void remove_MouseMove(MouseEventHandler value);
public void remove_MouseUp(MouseEventHandler value);
public void remove_MouseWheel(MouseEventHandler value);
public void remove_Move(EventHandler value);
public void remove_Paint(PaintEventHandler value);
public void remove_ParentChanged(EventHandler value);
public void remove_QueryAccessibilityHelp(QueryAccessibilityHelpEventHandler value);
public void remove_QueryContinueDrag(QueryContinueDragEventHandler value);
public void remove_Resize(EventHandler value);
public void remove_RightToLeftChanged(EventHandler value);
public void remove_SizeChanged(EventHandler value);
public void remove_StyleChanged(EventHandler value);
public void remove_SystemColorsChanged(EventHandler value);
public void remove_TabIndexChanged(EventHandler value);
public void remove_TabStopChanged(EventHandler value);
public void remove_TextChanged(EventHandler value);
public void remove_Validated(EventHandler value);
public void remove_Validating(CancelEventHandler value);
public void remove_VisibleChanged(EventHandler value);
public void ResetBackColor();
public void ResetBindings();
public void ResetCursor();
public void ResetFont();
public void ResetForeColor();
public void ResetImeMode();
protected void ResetMouseEventArgs();
public void ResetRightToLeft();
public void ResetText();
public void ResumeLayout();
public void ResumeLayout(bool performLayout);
protected ContentAlignment RtlTranslateAlignment(ContentAlignment align);
protected HorizontalAlignment RtlTranslateAlignment(HorizontalAlignment align);
protected LeftRightAlignment RtlTranslateAlignment(LeftRightAlignment align);
protected ContentAlignment RtlTranslateContent(ContentAlignment align);
protected HorizontalAlignment RtlTranslateHorizontal(HorizontalAlignment align);
protected LeftRightAlignment RtlTranslateLeftRight(LeftRightAlignment align);
public void Scale(float ratio);
public void Scale(float dx, float dy);
protected virtual void ScaleCore(float dx, float dy);
public void Select();
protected virtual void Select(bool directed, bool forward);
public bool SelectNextControl(Control ctl, bool forward, bool tabStopOnly, bool nested, bool wrap);
public void SendToBack();
public void SetBounds(int x, int y, int width, int height);
public void SetBounds(int x, int y, int width, int height, BoundsSpecified specified);
protected virtual void SetBoundsCore(int x, int y, int width, int height, BoundsSpecified specified);
protected virtual void SetClientSizeCore(int x, int y);
protected void SetStyle(ControlStyles flag, bool value);
protected void SetTopLevel(bool value);
protected virtual void SetVisibleCore(bool value);
public void Show();
public void SuspendLayout();
public virtual string ToString();
public void Update();
protected void UpdateBounds();
protected void UpdateBounds(int x, int y, int width, int height);
protected void UpdateBounds(int x, int y, int width, int height, int clientWidth, int clientHeight);
protected void UpdateStyles();
protected void UpdateZOrder();
protected virtual void WndProc(ref Message m);

Property
public AccessibleObject AccessibilityObject {get;}
public string AccessibleDefaultActionDescription {get; set;}
public string AccessibleDescription {get; set;}
public string AccessibleName {get; set;}
public AccessibleRole AccessibleRole {get; set;}
public bool AllowDrop {get; set;}
public AnchorStyles Anchor {get; set;}
public ToolBarAppearance Appearance {get; set;}
public bool AutoSize {get; set;}
public virtual Color BackColor {get; set;}
public override Image BackgroundImage {get; set;}
public virtual BindingContext BindingContext {get; set;}
public BorderStyle BorderStyle {get; set;}
public int Bottom {get;}
public Rectangle Bounds {get; set;}
public ToolBarButtonCollection Buttons {get;}
public Size ButtonSize {get; set;}
public bool CanFocus {get;}
public bool CanSelect {get;}
public bool Capture {get; set;}
public bool CausesValidation {get; set;}
public Rectangle ClientRectangle {get;}
public Size ClientSize {get; set;}
public string CompanyName {get;}
public IContainer Container {get;}
public bool ContainsFocus {get;}
public ContextMenu ContextMenu {get; set;}
public ControlCollection Controls {get;}
public bool Created {get;}
protected virtual CreateParams CreateParams {get;}
public Cursor Cursor {get; set;}
public ControlBindingsCollection DataBindings {get;}
protected virtual ImeMode DefaultImeMode {get;}
protected virtual Size DefaultSize {get;}
protected bool DesignMode {get;}
public Rectangle DisplayRectangle {get;}
public bool Disposing {get;}
public bool Divider {get; set;}
public override DockStyle Dock {get; set;}
public bool DropDownArrows {get; set;}
public bool Enabled {get; set;}
protected EventHandlerList Events {get;}
public bool Focused {get;}
public virtual Font Font {get; set;}
protected int FontHeight {get; set;}
public virtual Color ForeColor {get; set;}
public IntPtr Handle {get;}
public bool HasChildren {get;}
public int Height {get; set;}
public ImageList ImageList {get; set;}
public Size ImageSize {get;}
public ImeMode ImeMode {get; set;}
public bool InvokeRequired {get;}
public bool IsAccessible {get; set;}
public bool IsDisposed {get;}
public bool IsHandleCreated {get;}
public int Left {get; set;}
public Point Location {get; set;}
public string Name {get; set;}
public Control Parent {get; set;}
public string ProductName {get;}
public string ProductVersion {get;}
public bool RecreatingHandle {get;}
public Region Region {get; set;}
protected bool RenderRightToLeft {get;}
protected bool ResizeRedraw {get; set;}
public int Right {get;}
public override RightToLeft RightToLeft {get; set;}
protected virtual bool ShowFocusCues {get;}
protected bool ShowKeyboardCues {get;}
public bool ShowToolTips {get; set;}
public ISite Site {get; set;}
public Size Size {get; set;}
public int TabIndex {get; set;}
public bool TabStop {get; set;}
public object Tag {get; set;}
public virtual string Text {get; set;}
public ToolBarTextAlign TextAlign {get; set;}
public int Top {get; set;}
public Control TopLevelControl {get;}
public bool Visible {get; set;}
public int Width {get; set;}
public IWindowTarget WindowTarget {get; set;}
public bool Wrappable {get; set;}

System.Windows.Forms.Timer

Module:System.Windows.Forms.dll

Hierarchy
Object
MarshalByRefObject
Component
Timer

Type declaration

[C#] public class Timer : Component;

Constructor
public Timer();
public Timer(IContainer container);

Method
public void add_Disposed(EventHandler value);
public void add_Tick(EventHandler value);
public ObjRef CreateObjRef(Type requestedType);
public void Dispose();
protected virtual void Dispose(bool disposing);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public object GetLifetimeService();
protected virtual object GetService(Type service);
public Type GetType();
public object InitializeLifetimeService();
protected object MemberwiseClone();
protected virtual void OnTick(EventArgs e);
public void remove_Disposed(EventHandler value);
public void remove_Tick(EventHandler value);
public void Start();
public void Stop();
public virtual string ToString();

Property
public IContainer Container {get;}
protected bool DesignMode {get;}
public bool Enabled {get; set;}
protected EventHandlerList Events {get;}
public int Interval {get; set;}
public ISite Site {get; set;}

System.Windows.Forms.TextBox

Module:System.Windows.Forms.dll

Hierarchy
Object
MarshalByRefObject
Component
Control
TextBoxBase
TextBox

Type declaration

[C#] public class TextBox : TextBoxBase;

Constructor
public TextBox();

Method
protected void AccessibilityNotifyClients(AccessibleEvents accEvent, int childID);
public void add_AcceptsTabChanged(EventHandler value);
public void add_AutoSizeChanged(EventHandler value);
public void add_BackColorChanged(EventHandler value);
public void add_BackgroundImageChanged(EventHandler value);
public void add_BindingContextChanged(EventHandler value);
public void add_BorderStyleChanged(EventHandler value);
public void add_CausesValidationChanged(EventHandler value);
public void add_ChangeUICues(UICuesEventHandler value);
public void add_Click(EventHandler value);
public void add_ContextMenuChanged(EventHandler value);
public void add_ControlAdded(ControlEventHandler value);
public void add_ControlRemoved(ControlEventHandler value);
public void add_CursorChanged(EventHandler value);
public void add_Disposed(EventHandler value);
public void add_DockChanged(EventHandler value);
public void add_DoubleClick(EventHandler value);
public void add_DragDrop(DragEventHandler value);
public void add_DragEnter(DragEventHandler value);
public void add_DragLeave(EventHandler value);
public void add_DragOver(DragEventHandler value);
public void add_EnabledChanged(EventHandler value);
public void add_Enter(EventHandler value);
public void add_FontChanged(EventHandler value);
public void add_ForeColorChanged(EventHandler value);
public void add_GiveFeedback(GiveFeedbackEventHandler value);
public void add_GotFocus(EventHandler value);
public void add_HandleCreated(EventHandler value);
public void add_HandleDestroyed(EventHandler value);
public void add_HelpRequested(HelpEventHandler value);
public void add_HideSelectionChanged(EventHandler value);
public void add_ImeModeChanged(EventHandler value);
public void add_Invalidated(InvalidateEventHandler value);
public void add_KeyDown(KeyEventHandler value);
public void add_KeyPress(KeyPressEventHandler value);
public void add_KeyUp(KeyEventHandler value);
public void add_Layout(LayoutEventHandler value);
public void add_Leave(EventHandler value);
public void add_LocationChanged(EventHandler value);
public void add_LostFocus(EventHandler value);
public void add_ModifiedChanged(EventHandler value);
public void add_MouseDown(MouseEventHandler value);
public void add_MouseEnter(EventHandler value);
public void add_MouseHover(EventHandler value);
public void add_MouseLeave(EventHandler value);
public void add_MouseMove(MouseEventHandler value);
public void add_MouseUp(MouseEventHandler value);
public void add_MouseWheel(MouseEventHandler value);
public void add_Move(EventHandler value);
public void add_MultilineChanged(EventHandler value);
public void add_Paint(PaintEventHandler value);
public void add_ParentChanged(EventHandler value);
public void add_QueryAccessibilityHelp(QueryAccessibilityHelpEventHandler value);
public void add_QueryContinueDrag(QueryContinueDragEventHandler value);
public void add_ReadOnlyChanged(EventHandler value);
public void add_Resize(EventHandler value);
public void add_RightToLeftChanged(EventHandler value);
public void add_SizeChanged(EventHandler value);
public void add_StyleChanged(EventHandler value);
public void add_SystemColorsChanged(EventHandler value);
public void add_TabIndexChanged(EventHandler value);
public void add_TabStopChanged(EventHandler value);
public void add_TextAlignChanged(EventHandler value);
public void add_TextChanged(EventHandler value);
public void add_Validated(EventHandler value);
public void add_Validating(CancelEventHandler value);
public void add_VisibleChanged(EventHandler value);
public void AppendText(string text);
public IAsyncResult BeginInvoke(Delegate method);
public IAsyncResult BeginInvoke(Delegate method, object[] args);
public void BringToFront();
public void Clear();
public void ClearUndo();
public bool Contains(Control ctl);
public void Copy();
protected virtual AccessibleObject CreateAccessibilityInstance();
public void CreateControl();
protected virtual ControlCollection CreateControlsInstance();
public Graphics CreateGraphics();
protected virtual void CreateHandle();
public ObjRef CreateObjRef(Type requestedType);
public void Cut();
protected virtual void DefWndProc(ref Message m);
protected virtual void DestroyHandle();
public void Dispose();
protected override void Dispose(bool disposing);
public DragDropEffects DoDragDrop(object data, DragDropEffects allowedEffects);
public object EndInvoke(IAsyncResult asyncResult);
public virtual bool Equals(object obj);
protected override void Finalize();
public Form FindForm();
public bool Focus();
public Control GetChildAtPoint(Point pt);
public IContainerControl GetContainerControl();
public virtual int GetHashCode();
public object GetLifetimeService();
public Control GetNextControl(Control ctl, bool forward);
protected virtual object GetService(Type service);
protected bool GetStyle(ControlStyles flag);
protected bool GetTopLevel();
public Type GetType();
public void Hide();
public object InitializeLifetimeService();
protected virtual void InitLayout();
public void Invalidate();
public void Invalidate(bool invalidateChildren);
public void Invalidate(Rectangle rect);
public void Invalidate(Rectangle rc, bool invalidateChildren);
public void Invalidate(Region region);
public void Invalidate(Region region, bool invalidateChildren);
public object Invoke(Delegate method);
public object Invoke(Delegate method, object[] args);
protected void InvokeGotFocus(Control toInvoke, EventArgs e);
protected void InvokeLostFocus(Control toInvoke, EventArgs e);
protected void InvokeOnClick(Control toInvoke, EventArgs e);
protected void InvokePaint(Control c, PaintEventArgs e);
protected void InvokePaintBackground(Control c, PaintEventArgs e);
protected virtual bool IsInputChar(char charCode);
protected virtual bool IsInputKey(Keys keyData);
protected object MemberwiseClone();
protected virtual void NotifyInvalidate(Rectangle invalidatedArea);
protected virtual void OnAcceptsTabChanged(EventArgs e);
protected virtual void OnAutoSizeChanged(EventArgs e);
protected virtual void OnBackColorChanged(EventArgs e);
protected virtual void OnBackgroundImageChanged(EventArgs e);
protected virtual void OnBindingContextChanged(EventArgs e);
protected virtual void OnBorderStyleChanged(EventArgs e);
protected virtual void OnCausesValidationChanged(EventArgs e);
protected virtual void OnChangeUICues(UICuesEventArgs e);
protected virtual void OnClick(EventArgs e);
protected virtual void OnContextMenuChanged(EventArgs e);
protected virtual void OnControlAdded(ControlEventArgs e);
protected virtual void OnControlRemoved(ControlEventArgs e);
protected virtual void OnCreateControl();
protected virtual void OnCursorChanged(EventArgs e);
protected virtual void OnDockChanged(EventArgs e);
protected virtual void OnDoubleClick(EventArgs e);
protected virtual void OnDragDrop(DragEventArgs drgevent);
protected virtual void OnDragEnter(DragEventArgs drgevent);
protected virtual void OnDragLeave(EventArgs e);
protected virtual void OnDragOver(DragEventArgs drgevent);
protected virtual void OnEnabledChanged(EventArgs e);
protected virtual void OnEnter(EventArgs e);
protected virtual void OnFontChanged(EventArgs e);
protected virtual void OnForeColorChanged(EventArgs e);
protected virtual void OnGiveFeedback(GiveFeedbackEventArgs gfbevent);
protected virtual void OnGotFocus(EventArgs e);
protected virtual void OnHandleCreated(EventArgs e);
protected virtual void OnHandleDestroyed(EventArgs e);
protected virtual void OnHelpRequested(HelpEventArgs hevent);
protected virtual void OnHideSelectionChanged(EventArgs e);
protected virtual void OnImeModeChanged(EventArgs e);
protected virtual void OnInvalidated(InvalidateEventArgs e);
protected virtual void OnKeyDown(KeyEventArgs e);
protected virtual void OnKeyPress(KeyPressEventArgs e);
protected virtual void OnKeyUp(KeyEventArgs e);
protected virtual void OnLayout(LayoutEventArgs levent);
protected virtual void OnLeave(EventArgs e);
protected virtual void OnLocationChanged(EventArgs e);
protected virtual void OnLostFocus(EventArgs e);
protected virtual void OnModifiedChanged(EventArgs e);
protected virtual void OnMouseDown(MouseEventArgs e);
protected virtual void OnMouseEnter(EventArgs e);
protected virtual void OnMouseHover(EventArgs e);
protected virtual void OnMouseLeave(EventArgs e);
protected virtual void OnMouseMove(MouseEventArgs e);
protected virtual void OnMouseUp(MouseEventArgs e);
protected virtual void OnMouseWheel(MouseEventArgs e);
protected virtual void OnMove(EventArgs e);
protected virtual void OnMultilineChanged(EventArgs e);
protected virtual void OnNotifyMessage(Message m);
protected virtual void OnPaint(PaintEventArgs e);
protected virtual void OnPaintBackground(PaintEventArgs e);
protected virtual void OnParentBackColorChanged(EventArgs e);
protected virtual void OnParentBackgroundImageChanged(EventArgs e);
protected virtual void OnParentBindingContextChanged(EventArgs e);
protected virtual void OnParentChanged(EventArgs e);
protected virtual void OnParentEnabledChanged(EventArgs e);
protected virtual void OnParentFontChanged(EventArgs e);
protected virtual void OnParentForeColorChanged(EventArgs e);
protected virtual void OnParentRightToLeftChanged(EventArgs e);
protected virtual void OnParentVisibleChanged(EventArgs e);
protected virtual void OnQueryContinueDrag(QueryContinueDragEventArgs qcdevent);
protected virtual void OnReadOnlyChanged(EventArgs e);
protected virtual void OnResize(EventArgs e);
protected virtual void OnRightToLeftChanged(EventArgs e);
protected virtual void OnSizeChanged(EventArgs e);
protected virtual void OnStyleChanged(EventArgs e);
protected virtual void OnSystemColorsChanged(EventArgs e);
protected virtual void OnTabIndexChanged(EventArgs e);
protected virtual void OnTabStopChanged(EventArgs e);
protected virtual void OnTextAlignChanged(EventArgs e);
protected virtual void OnTextChanged(EventArgs e);
protected virtual void OnValidated(EventArgs e);
protected virtual void OnValidating(CancelEventArgs e);
protected virtual void OnVisibleChanged(EventArgs e);
public void Paste();
public void PerformLayout();
public void PerformLayout(Control affectedControl, string affectedProperty);
public Point PointToClient(Point p);
public Point PointToScreen(Point p);
public bool PreProcessMessage(ref Message msg);
protected virtual bool ProcessCmdKey(ref Message msg, Keys keyData);
protected virtual bool ProcessDialogChar(char charCode);
protected virtual bool ProcessDialogKey(Keys keyData);
protected virtual bool ProcessKeyEventArgs(ref Message m);
protected virtual bool ProcessKeyPreview(ref Message m);
protected virtual bool ProcessMnemonic(char charCode);
protected void RaiseDragEvent(object key, DragEventArgs e);
protected void RaiseKeyEvent(object key, KeyEventArgs e);
protected void RaiseMouseEvent(object key, MouseEventArgs e);
protected void RaisePaintEvent(object key, PaintEventArgs e);
protected void RecreateHandle();
public Rectangle RectangleToClient(Rectangle r);
public Rectangle RectangleToScreen(Rectangle r);
public virtual void Refresh();
public void remove_AcceptsTabChanged(EventHandler value);
public void remove_AutoSizeChanged(EventHandler value);
public void remove_BackColorChanged(EventHandler value);
public void remove_BackgroundImageChanged(EventHandler value);
public void remove_BindingContextChanged(EventHandler value);
public void remove_BorderStyleChanged(EventHandler value);
public void remove_CausesValidationChanged(EventHandler value);
public void remove_ChangeUICues(UICuesEventHandler value);
public void remove_Click(EventHandler value);
public void remove_ContextMenuChanged(EventHandler value);
public void remove_ControlAdded(ControlEventHandler value);
public void remove_ControlRemoved(ControlEventHandler value);
public void remove_CursorChanged(EventHandler value);
public void remove_Disposed(EventHandler value);
public void remove_DockChanged(EventHandler value);
public void remove_DoubleClick(EventHandler value);
public void remove_DragDrop(DragEventHandler value);
public void remove_DragEnter(DragEventHandler value);
public void remove_DragLeave(EventHandler value);
public void remove_DragOver(DragEventHandler value);
public void remove_EnabledChanged(EventHandler value);
public void remove_Enter(EventHandler value);
public void remove_FontChanged(EventHandler value);
public void remove_ForeColorChanged(EventHandler value);
public void remove_GiveFeedback(GiveFeedbackEventHandler value);
public void remove_GotFocus(EventHandler value);
public void remove_HandleCreated(EventHandler value);
public void remove_HandleDestroyed(EventHandler value);
public void remove_HelpRequested(HelpEventHandler value);
public void remove_HideSelectionChanged(EventHandler value);
public void remove_ImeModeChanged(EventHandler value);
public void remove_Invalidated(InvalidateEventHandler value);
public void remove_KeyDown(KeyEventHandler value);
public void remove_KeyPress(KeyPressEventHandler value);
public void remove_KeyUp(KeyEventHandler value);
public void remove_Layout(LayoutEventHandler value);
public void remove_Leave(EventHandler value);
public void remove_LocationChanged(EventHandler value);
public void remove_LostFocus(EventHandler value);
public void remove_ModifiedChanged(EventHandler value);
public void remove_MouseDown(MouseEventHandler value);
public void remove_MouseEnter(EventHandler value);
public void remove_MouseHover(EventHandler value);
public void remove_MouseLeave(EventHandler value);
public void remove_MouseMove(MouseEventHandler value);
public void remove_MouseUp(MouseEventHandler value);
public void remove_MouseWheel(MouseEventHandler value);
public void remove_Move(EventHandler value);
public void remove_MultilineChanged(EventHandler value);
public void remove_Paint(PaintEventHandler value);
public void remove_ParentChanged(EventHandler value);
public void remove_QueryAccessibilityHelp(QueryAccessibilityHelpEventHandler value);
public void remove_QueryContinueDrag(QueryContinueDragEventHandler value);
public void remove_ReadOnlyChanged(EventHandler value);
public void remove_Resize(EventHandler value);
public void remove_RightToLeftChanged(EventHandler value);
public void remove_SizeChanged(EventHandler value);
public void remove_StyleChanged(EventHandler value);
public void remove_SystemColorsChanged(EventHandler value);
public void remove_TabIndexChanged(EventHandler value);
public void remove_TabStopChanged(EventHandler value);
public void remove_TextAlignChanged(EventHandler value);
public void remove_TextChanged(EventHandler value);
public void remove_Validated(EventHandler value);
public void remove_Validating(CancelEventHandler value);
public void remove_VisibleChanged(EventHandler value);
public void ResetBackColor();
public void ResetBindings();
public void ResetCursor();
public void ResetFont();
public void ResetForeColor();
public void ResetImeMode();
protected void ResetMouseEventArgs();
public void ResetRightToLeft();
public void ResetText();
public void ResumeLayout();
public void ResumeLayout(bool performLayout);
protected ContentAlignment RtlTranslateAlignment(ContentAlignment align);
protected HorizontalAlignment RtlTranslateAlignment(HorizontalAlignment align);
protected LeftRightAlignment RtlTranslateAlignment(LeftRightAlignment align);
protected ContentAlignment RtlTranslateContent(ContentAlignment align);
protected HorizontalAlignment RtlTranslateHorizontal(HorizontalAlignment align);
protected LeftRightAlignment RtlTranslateLeftRight(LeftRightAlignment align);
public void Scale(float ratio);
public void Scale(float dx, float dy);
protected virtual void ScaleCore(float dx, float dy);
public void ScrollToCaret();
public void Select();
protected virtual void Select(bool directed, bool forward);
public void Select(int start, int length);
public void SelectAll();
public bool SelectNextControl(Control ctl, bool forward, bool tabStopOnly, bool nested, bool wrap);
public void SendToBack();
public void SetBounds(int x, int y, int width, int height);
public void SetBounds(int x, int y, int width, int height, BoundsSpecified specified);
protected virtual void SetBoundsCore(int x, int y, int width, int height, BoundsSpecified specified);
protected virtual void SetClientSizeCore(int x, int y);
protected void SetStyle(ControlStyles flag, bool value);
protected void SetTopLevel(bool value);
protected virtual void SetVisibleCore(bool value);
public void Show();
public void SuspendLayout();
public virtual string ToString();
public void Undo();
public void Update();
protected void UpdateBounds();
protected void UpdateBounds(int x, int y, int width, int height);
protected void UpdateBounds(int x, int y, int width, int height, int clientWidth, int clientHeight);
protected void UpdateStyles();
protected void UpdateZOrder();
protected virtual void WndProc(ref Message m);

Property
public bool AcceptsReturn {get; set;}
public bool AcceptsTab {get; set;}
public AccessibleObject AccessibilityObject {get;}
public string AccessibleDefaultActionDescription {get; set;}
public string AccessibleDescription {get; set;}
public string AccessibleName {get; set;}
public AccessibleRole AccessibleRole {get; set;}
public bool AllowDrop {get; set;}
public AnchorStyles Anchor {get; set;}
public bool AutoSize {get; set;}
public virtual Color BackColor {get; set;}
public Image BackgroundImage {get; set;}
public virtual BindingContext BindingContext {get; set;}
public BorderStyle BorderStyle {get; set;}
public int Bottom {get;}
public Rectangle Bounds {get; set;}
public bool CanFocus {get;}
public bool CanSelect {get;}
public bool CanUndo {get;}
public bool Capture {get; set;}
public bool CausesValidation {get; set;}
public CharacterCasing CharacterCasing {get; set;}
public Rectangle ClientRectangle {get;}
public Size ClientSize {get; set;}
public string CompanyName {get;}
public IContainer Container {get;}
public bool ContainsFocus {get;}
public ContextMenu ContextMenu {get; set;}
public ControlCollection Controls {get;}
public bool Created {get;}
protected virtual CreateParams CreateParams {get;}
public Cursor Cursor {get; set;}
public ControlBindingsCollection DataBindings {get;}
protected virtual ImeMode DefaultImeMode {get;}
protected virtual Size DefaultSize {get;}
protected bool DesignMode {get;}
public Rectangle DisplayRectangle {get;}
public bool Disposing {get;}
public DockStyle Dock {get; set;}
public bool Enabled {get; set;}
protected EventHandlerList Events {get;}
public bool Focused {get;}
public virtual Font Font {get; set;}
protected int FontHeight {get; set;}
public virtual Color ForeColor {get; set;}
public IntPtr Handle {get;}
public bool HasChildren {get;}
public int Height {get; set;}
public bool HideSelection {get; set;}
public ImeMode ImeMode {get; set;}
public bool InvokeRequired {get;}
public bool IsAccessible {get; set;}
public bool IsDisposed {get;}
public bool IsHandleCreated {get;}
public int Left {get; set;}
public string[] Lines {get; set;}
public Point Location {get; set;}
public int MaxLength {get; set;}
public bool Modified {get; set;}
public bool Multiline {get; set;}
public string Name {get; set;}
public Control Parent {get; set;}
public char PasswordChar {get; set;}
public int PreferredHeight {get;}
public string ProductName {get;}
public string ProductVersion {get;}
public bool ReadOnly {get; set;}
public bool RecreatingHandle {get;}
public Region Region {get; set;}
protected bool RenderRightToLeft {get;}
protected bool ResizeRedraw {get; set;}
public int Right {get;}
public RightToLeft RightToLeft {get; set;}
public ScrollBars ScrollBars {get; set;}
public string SelectedText {get; set;}
public int SelectionLength {get; set;}
public int SelectionStart {get; set;}
protected virtual bool ShowFocusCues {get;}
protected bool ShowKeyboardCues {get;}
public ISite Site {get; set;}
public Size Size {get; set;}
public int TabIndex {get; set;}
public bool TabStop {get; set;}
public object Tag {get; set;}
public virtual string Text {get; set;}
public HorizontalAlignment TextAlign {get; set;}
public int TextLength {get;}
public int Top {get; set;}
public Control TopLevelControl {get;}
public bool Visible {get; set;}
public int Width {get; set;}
public IWindowTarget WindowTarget {get; set;}
public bool WordWrap {get; set;}

System.Windows.Forms.TextBoxBase

Module:System.Windows.Forms.dll

Hierarchy
Object
MarshalByRefObject
Component
Control
TextBoxBase

Type declaration

[C#] public abstract class TextBoxBase : Control;

Method
protected void AccessibilityNotifyClients(AccessibleEvents accEvent, int childID);
public void add_AcceptsTabChanged(EventHandler value);
public void add_AutoSizeChanged(EventHandler value);
public void add_BackColorChanged(EventHandler value);
public void add_BackgroundImageChanged(EventHandler value);
public void add_BindingContextChanged(EventHandler value);
public void add_BorderStyleChanged(EventHandler value);
public void add_CausesValidationChanged(EventHandler value);
public void add_ChangeUICues(UICuesEventHandler value);
public void add_Click(EventHandler value);
public void add_ContextMenuChanged(EventHandler value);
public void add_ControlAdded(ControlEventHandler value);
public void add_ControlRemoved(ControlEventHandler value);
public void add_CursorChanged(EventHandler value);
public void add_Disposed(EventHandler value);
public void add_DockChanged(EventHandler value);
public void add_DoubleClick(EventHandler value);
public void add_DragDrop(DragEventHandler value);
public void add_DragEnter(DragEventHandler value);
public void add_DragLeave(EventHandler value);
public void add_DragOver(DragEventHandler value);
public void add_EnabledChanged(EventHandler value);
public void add_Enter(EventHandler value);
public void add_FontChanged(EventHandler value);
public void add_ForeColorChanged(EventHandler value);
public void add_GiveFeedback(GiveFeedbackEventHandler value);
public void add_GotFocus(EventHandler value);
public void add_HandleCreated(EventHandler value);
public void add_HandleDestroyed(EventHandler value);
public void add_HelpRequested(HelpEventHandler value);
public void add_HideSelectionChanged(EventHandler value);
public void add_ImeModeChanged(EventHandler value);
public void add_Invalidated(InvalidateEventHandler value);
public void add_KeyDown(KeyEventHandler value);
public void add_KeyPress(KeyPressEventHandler value);
public void add_KeyUp(KeyEventHandler value);
public void add_Layout(LayoutEventHandler value);
public void add_Leave(EventHandler value);
public void add_LocationChanged(EventHandler value);
public void add_LostFocus(EventHandler value);
public void add_ModifiedChanged(EventHandler value);
public void add_MouseDown(MouseEventHandler value);
public void add_MouseEnter(EventHandler value);
public void add_MouseHover(EventHandler value);
public void add_MouseLeave(EventHandler value);
public void add_MouseMove(MouseEventHandler value);
public void add_MouseUp(MouseEventHandler value);
public void add_MouseWheel(MouseEventHandler value);
public void add_Move(EventHandler value);
public void add_MultilineChanged(EventHandler value);
public void add_Paint(PaintEventHandler value);
public void add_ParentChanged(EventHandler value);
public void add_QueryAccessibilityHelp(QueryAccessibilityHelpEventHandler value);
public void add_QueryContinueDrag(QueryContinueDragEventHandler value);
public void add_ReadOnlyChanged(EventHandler value);
public void add_Resize(EventHandler value);
public void add_RightToLeftChanged(EventHandler value);
public void add_SizeChanged(EventHandler value);
public void add_StyleChanged(EventHandler value);
public void add_SystemColorsChanged(EventHandler value);
public void add_TabIndexChanged(EventHandler value);
public void add_TabStopChanged(EventHandler value);
public void add_TextChanged(EventHandler value);
public void add_Validated(EventHandler value);
public void add_Validating(CancelEventHandler value);
public void add_VisibleChanged(EventHandler value);
public void AppendText(string text);
public IAsyncResult BeginInvoke(Delegate method);
public IAsyncResult BeginInvoke(Delegate method, object[] args);
public void BringToFront();
public void Clear();
public void ClearUndo();
public bool Contains(Control ctl);
public void Copy();
protected virtual AccessibleObject CreateAccessibilityInstance();
public void CreateControl();
protected virtual ControlCollection CreateControlsInstance();
public Graphics CreateGraphics();
protected virtual void CreateHandle();
public ObjRef CreateObjRef(Type requestedType);
public void Cut();
protected virtual void DefWndProc(ref Message m);
protected virtual void DestroyHandle();
public void Dispose();
protected override void Dispose(bool disposing);
public DragDropEffects DoDragDrop(object data, DragDropEffects allowedEffects);
public object EndInvoke(IAsyncResult asyncResult);
public virtual bool Equals(object obj);
protected override void Finalize();
public Form FindForm();
public bool Focus();
public Control GetChildAtPoint(Point pt);
public IContainerControl GetContainerControl();
public virtual int GetHashCode();
public object GetLifetimeService();
public Control GetNextControl(Control ctl, bool forward);
protected virtual object GetService(Type service);
protected bool GetStyle(ControlStyles flag);
protected bool GetTopLevel();
public Type GetType();
public void Hide();
public object InitializeLifetimeService();
protected virtual void InitLayout();
public void Invalidate();
public void Invalidate(bool invalidateChildren);
public void Invalidate(Rectangle rect);
public void Invalidate(Rectangle rc, bool invalidateChildren);
public void Invalidate(Region region);
public void Invalidate(Region region, bool invalidateChildren);
public object Invoke(Delegate method);
public object Invoke(Delegate method, object[] args);
protected void InvokeGotFocus(Control toInvoke, EventArgs e);
protected void InvokeLostFocus(Control toInvoke, EventArgs e);
protected void InvokeOnClick(Control toInvoke, EventArgs e);
protected void InvokePaint(Control c, PaintEventArgs e);
protected void InvokePaintBackground(Control c, PaintEventArgs e);
protected virtual bool IsInputChar(char charCode);
protected virtual bool IsInputKey(Keys keyData);
protected object MemberwiseClone();
protected virtual void NotifyInvalidate(Rectangle invalidatedArea);
protected virtual void OnAcceptsTabChanged(EventArgs e);
protected virtual void OnAutoSizeChanged(EventArgs e);
protected virtual void OnBackColorChanged(EventArgs e);
protected virtual void OnBackgroundImageChanged(EventArgs e);
protected virtual void OnBindingContextChanged(EventArgs e);
protected virtual void OnBorderStyleChanged(EventArgs e);
protected virtual void OnCausesValidationChanged(EventArgs e);
protected virtual void OnChangeUICues(UICuesEventArgs e);
protected virtual void OnClick(EventArgs e);
protected virtual void OnContextMenuChanged(EventArgs e);
protected virtual void OnControlAdded(ControlEventArgs e);
protected virtual void OnControlRemoved(ControlEventArgs e);
protected virtual void OnCreateControl();
protected virtual void OnCursorChanged(EventArgs e);
protected virtual void OnDockChanged(EventArgs e);
protected virtual void OnDoubleClick(EventArgs e);
protected virtual void OnDragDrop(DragEventArgs drgevent);
protected virtual void OnDragEnter(DragEventArgs drgevent);
protected virtual void OnDragLeave(EventArgs e);
protected virtual void OnDragOver(DragEventArgs drgevent);
protected virtual void OnEnabledChanged(EventArgs e);
protected virtual void OnEnter(EventArgs e);
protected virtual void OnFontChanged(EventArgs e);
protected virtual void OnForeColorChanged(EventArgs e);
protected virtual void OnGiveFeedback(GiveFeedbackEventArgs gfbevent);
protected virtual void OnGotFocus(EventArgs e);
protected virtual void OnHandleCreated(EventArgs e);
protected virtual void OnHandleDestroyed(EventArgs e);
protected virtual void OnHelpRequested(HelpEventArgs hevent);
protected virtual void OnHideSelectionChanged(EventArgs e);
protected virtual void OnImeModeChanged(EventArgs e);
protected virtual void OnInvalidated(InvalidateEventArgs e);
protected virtual void OnKeyDown(KeyEventArgs e);
protected virtual void OnKeyPress(KeyPressEventArgs e);
protected virtual void OnKeyUp(KeyEventArgs e);
protected virtual void OnLayout(LayoutEventArgs levent);
protected virtual void OnLeave(EventArgs e);
protected virtual void OnLocationChanged(EventArgs e);
protected virtual void OnLostFocus(EventArgs e);
protected virtual void OnModifiedChanged(EventArgs e);
protected virtual void OnMouseDown(MouseEventArgs e);
protected virtual void OnMouseEnter(EventArgs e);
protected virtual void OnMouseHover(EventArgs e);
protected virtual void OnMouseLeave(EventArgs e);
protected virtual void OnMouseMove(MouseEventArgs e);
protected virtual void OnMouseUp(MouseEventArgs e);
protected virtual void OnMouseWheel(MouseEventArgs e);
protected virtual void OnMove(EventArgs e);
protected virtual void OnMultilineChanged(EventArgs e);
protected virtual void OnNotifyMessage(Message m);
protected virtual void OnPaint(PaintEventArgs e);
protected virtual void OnPaintBackground(PaintEventArgs e);
protected virtual void OnParentBackColorChanged(EventArgs e);
protected virtual void OnParentBackgroundImageChanged(EventArgs e);
protected virtual void OnParentBindingContextChanged(EventArgs e);
protected virtual void OnParentChanged(EventArgs e);
protected virtual void OnParentEnabledChanged(EventArgs e);
protected virtual void OnParentFontChanged(EventArgs e);
protected virtual void OnParentForeColorChanged(EventArgs e);
protected virtual void OnParentRightToLeftChanged(EventArgs e);
protected virtual void OnParentVisibleChanged(EventArgs e);
protected virtual void OnQueryContinueDrag(QueryContinueDragEventArgs qcdevent);
protected virtual void OnReadOnlyChanged(EventArgs e);
protected virtual void OnResize(EventArgs e);
protected virtual void OnRightToLeftChanged(EventArgs e);
protected virtual void OnSizeChanged(EventArgs e);
protected virtual void OnStyleChanged(EventArgs e);
protected virtual void OnSystemColorsChanged(EventArgs e);
protected virtual void OnTabIndexChanged(EventArgs e);
protected virtual void OnTabStopChanged(EventArgs e);
protected virtual void OnTextChanged(EventArgs e);
protected virtual void OnValidated(EventArgs e);
protected virtual void OnValidating(CancelEventArgs e);
protected virtual void OnVisibleChanged(EventArgs e);
public void Paste();
public void PerformLayout();
public void PerformLayout(Control affectedControl, string affectedProperty);
public Point PointToClient(Point p);
public Point PointToScreen(Point p);
public bool PreProcessMessage(ref Message msg);
protected virtual bool ProcessCmdKey(ref Message msg, Keys keyData);
protected virtual bool ProcessDialogChar(char charCode);
protected virtual bool ProcessDialogKey(Keys keyData);
protected virtual bool ProcessKeyEventArgs(ref Message m);
protected virtual bool ProcessKeyPreview(ref Message m);
protected virtual bool ProcessMnemonic(char charCode);
protected void RaiseDragEvent(object key, DragEventArgs e);
protected void RaiseKeyEvent(object key, KeyEventArgs e);
protected void RaiseMouseEvent(object key, MouseEventArgs e);
protected void RaisePaintEvent(object key, PaintEventArgs e);
protected void RecreateHandle();
public Rectangle RectangleToClient(Rectangle r);
public Rectangle RectangleToScreen(Rectangle r);
public virtual void Refresh();
public void remove_AcceptsTabChanged(EventHandler value);
public void remove_AutoSizeChanged(EventHandler value);
public void remove_BackColorChanged(EventHandler value);
public void remove_BackgroundImageChanged(EventHandler value);
public void remove_BindingContextChanged(EventHandler value);
public void remove_BorderStyleChanged(EventHandler value);
public void remove_CausesValidationChanged(EventHandler value);
public void remove_ChangeUICues(UICuesEventHandler value);
public void remove_Click(EventHandler value);
public void remove_ContextMenuChanged(EventHandler value);
public void remove_ControlAdded(ControlEventHandler value);
public void remove_ControlRemoved(ControlEventHandler value);
public void remove_CursorChanged(EventHandler value);
public void remove_Disposed(EventHandler value);
public void remove_DockChanged(EventHandler value);
public void remove_DoubleClick(EventHandler value);
public void remove_DragDrop(DragEventHandler value);
public void remove_DragEnter(DragEventHandler value);
public void remove_DragLeave(EventHandler value);
public void remove_DragOver(DragEventHandler value);
public void remove_EnabledChanged(EventHandler value);
public void remove_Enter(EventHandler value);
public void remove_FontChanged(EventHandler value);
public void remove_ForeColorChanged(EventHandler value);
public void remove_GiveFeedback(GiveFeedbackEventHandler value);
public void remove_GotFocus(EventHandler value);
public void remove_HandleCreated(EventHandler value);
public void remove_HandleDestroyed(EventHandler value);
public void remove_HelpRequested(HelpEventHandler value);
public void remove_HideSelectionChanged(EventHandler value);
public void remove_ImeModeChanged(EventHandler value);
public void remove_Invalidated(InvalidateEventHandler value);
public void remove_KeyDown(KeyEventHandler value);
public void remove_KeyPress(KeyPressEventHandler value);
public void remove_KeyUp(KeyEventHandler value);
public void remove_Layout(LayoutEventHandler value);
public void remove_Leave(EventHandler value);
public void remove_LocationChanged(EventHandler value);
public void remove_LostFocus(EventHandler value);
public void remove_ModifiedChanged(EventHandler value);
public void remove_MouseDown(MouseEventHandler value);
public void remove_MouseEnter(EventHandler value);
public void remove_MouseHover(EventHandler value);
public void remove_MouseLeave(EventHandler value);
public void remove_MouseMove(MouseEventHandler value);
public void remove_MouseUp(MouseEventHandler value);
public void remove_MouseWheel(MouseEventHandler value);
public void remove_Move(EventHandler value);
public void remove_MultilineChanged(EventHandler value);
public void remove_Paint(PaintEventHandler value);
public void remove_ParentChanged(EventHandler value);
public void remove_QueryAccessibilityHelp(QueryAccessibilityHelpEventHandler value);
public void remove_QueryContinueDrag(QueryContinueDragEventHandler value);
public void remove_ReadOnlyChanged(EventHandler value);
public void remove_Resize(EventHandler value);
public void remove_RightToLeftChanged(EventHandler value);
public void remove_SizeChanged(EventHandler value);
public void remove_StyleChanged(EventHandler value);
public void remove_SystemColorsChanged(EventHandler value);
public void remove_TabIndexChanged(EventHandler value);
public void remove_TabStopChanged(EventHandler value);
public void remove_TextChanged(EventHandler value);
public void remove_Validated(EventHandler value);
public void remove_Validating(CancelEventHandler value);
public void remove_VisibleChanged(EventHandler value);
public void ResetBackColor();
public void ResetBindings();
public void ResetCursor();
public void ResetFont();
public void ResetForeColor();
public void ResetImeMode();
protected void ResetMouseEventArgs();
public void ResetRightToLeft();
public void ResetText();
public void ResumeLayout();
public void ResumeLayout(bool performLayout);
protected ContentAlignment RtlTranslateAlignment(ContentAlignment align);
protected HorizontalAlignment RtlTranslateAlignment(HorizontalAlignment align);
protected LeftRightAlignment RtlTranslateAlignment(LeftRightAlignment align);
protected ContentAlignment RtlTranslateContent(ContentAlignment align);
protected HorizontalAlignment RtlTranslateHorizontal(HorizontalAlignment align);
protected LeftRightAlignment RtlTranslateLeftRight(LeftRightAlignment align);
public void Scale(float ratio);
public void Scale(float dx, float dy);
protected virtual void ScaleCore(float dx, float dy);
public void ScrollToCaret();
public void Select();
protected virtual void Select(bool directed, bool forward);
public void Select(int start, int length);
public void SelectAll();
public bool SelectNextControl(Control ctl, bool forward, bool tabStopOnly, bool nested, bool wrap);
public void SendToBack();
public void SetBounds(int x, int y, int width, int height);
public void SetBounds(int x, int y, int width, int height, BoundsSpecified specified);
protected virtual void SetBoundsCore(int x, int y, int width, int height, BoundsSpecified specified);
protected virtual void SetClientSizeCore(int x, int y);
protected void SetStyle(ControlStyles flag, bool value);
protected void SetTopLevel(bool value);
protected virtual void SetVisibleCore(bool value);
public void Show();
public void SuspendLayout();
public virtual string ToString();
public void Undo();
public void Update();
protected void UpdateBounds();
protected void UpdateBounds(int x, int y, int width, int height);
protected void UpdateBounds(int x, int y, int width, int height, int clientWidth, int clientHeight);
protected void UpdateStyles();
protected void UpdateZOrder();
protected virtual void WndProc(ref Message m);

Property
public bool AcceptsTab {get; set;}
public AccessibleObject AccessibilityObject {get;}
public string AccessibleDefaultActionDescription {get; set;}
public string AccessibleDescription {get; set;}
public string AccessibleName {get; set;}
public AccessibleRole AccessibleRole {get; set;}
public bool AllowDrop {get; set;}
public AnchorStyles Anchor {get; set;}
public virtual bool AutoSize {get; set;}
public virtual Color BackColor {get; set;}
public override Image BackgroundImage {get; set;}
public virtual BindingContext BindingContext {get; set;}
public BorderStyle BorderStyle {get; set;}
public int Bottom {get;}
public Rectangle Bounds {get; set;}
public bool CanFocus {get;}
public bool CanSelect {get;}
public bool CanUndo {get;}
public bool Capture {get; set;}
public bool CausesValidation {get; set;}
public Rectangle ClientRectangle {get;}
public Size ClientSize {get; set;}
public string CompanyName {get;}
public IContainer Container {get;}
public bool ContainsFocus {get;}
public ContextMenu ContextMenu {get; set;}
public ControlCollection Controls {get;}
public bool Created {get;}
protected virtual CreateParams CreateParams {get;}
public Cursor Cursor {get; set;}
public ControlBindingsCollection DataBindings {get;}
protected virtual ImeMode DefaultImeMode {get;}
protected virtual Size DefaultSize {get;}
protected bool DesignMode {get;}
public Rectangle DisplayRectangle {get;}
public bool Disposing {get;}
public DockStyle Dock {get; set;}
public bool Enabled {get; set;}
protected EventHandlerList Events {get;}
public bool Focused {get;}
public virtual Font Font {get; set;}
protected int FontHeight {get; set;}
public virtual Color ForeColor {get; set;}
public IntPtr Handle {get;}
public bool HasChildren {get;}
public int Height {get; set;}
public bool HideSelection {get; set;}
public ImeMode ImeMode {get; set;}
public bool InvokeRequired {get;}
public bool IsAccessible {get; set;}
public bool IsDisposed {get;}
public bool IsHandleCreated {get;}
public int Left {get; set;}
public string[] Lines {get; set;}
public Point Location {get; set;}
public int MaxLength {get; set;}
public bool Modified {get; set;}
public bool Multiline {get; set;}
public string Name {get; set;}
public Control Parent {get; set;}
public int PreferredHeight {get;}
public string ProductName {get;}
public string ProductVersion {get;}
public bool ReadOnly {get; set;}
public bool RecreatingHandle {get;}
public Region Region {get; set;}
protected bool RenderRightToLeft {get;}
protected bool ResizeRedraw {get; set;}
public int Right {get;}
public RightToLeft RightToLeft {get; set;}
public string SelectedText {get; set;}
public int SelectionLength {get; set;}
public int SelectionStart {get; set;}
protected virtual bool ShowFocusCues {get;}
protected bool ShowKeyboardCues {get;}
public ISite Site {get; set;}
public Size Size {get; set;}
public int TabIndex {get; set;}
public bool TabStop {get; set;}
public object Tag {get; set;}
public virtual string Text {get; set;}
public int TextLength {get;}
public int Top {get; set;}
public Control TopLevelControl {get;}
public bool Visible {get; set;}
public int Width {get; set;}
public IWindowTarget WindowTarget {get; set;}
public bool WordWrap {get; set;}

System.Windows.Forms.TabPage

Module:System.Windows.Forms.dll

Hierarchy
Object
MarshalByRefObject
Component
Control
ScrollableControl
Panel
TabPage

Type declaration

[C#] public class TabPage : Panel;

Constructor
public TabPage();
public TabPage(string text);

Method
protected void AccessibilityNotifyClients(AccessibleEvents accEvent, int childID);
public void add_BackColorChanged(EventHandler value);
public void add_BackgroundImageChanged(EventHandler value);
public void add_BindingContextChanged(EventHandler value);
public void add_CausesValidationChanged(EventHandler value);
public void add_ChangeUICues(UICuesEventHandler value);
public void add_Click(EventHandler value);
public void add_ContextMenuChanged(EventHandler value);
public void add_ControlAdded(ControlEventHandler value);
public void add_ControlRemoved(ControlEventHandler value);
public void add_CursorChanged(EventHandler value);
public void add_Disposed(EventHandler value);
public void add_DockChanged(EventHandler value);
public void add_DoubleClick(EventHandler value);
public void add_DragDrop(DragEventHandler value);
public void add_DragEnter(DragEventHandler value);
public void add_DragLeave(EventHandler value);
public void add_DragOver(DragEventHandler value);
public void add_EnabledChanged(EventHandler value);
public void add_Enter(EventHandler value);
public void add_FontChanged(EventHandler value);
public void add_ForeColorChanged(EventHandler value);
public void add_GiveFeedback(GiveFeedbackEventHandler value);
public void add_GotFocus(EventHandler value);
public void add_HandleCreated(EventHandler value);
public void add_HandleDestroyed(EventHandler value);
public void add_HelpRequested(HelpEventHandler value);
public void add_ImeModeChanged(EventHandler value);
public void add_Invalidated(InvalidateEventHandler value);
public void add_KeyDown(KeyEventHandler value);
public void add_KeyPress(KeyPressEventHandler value);
public void add_KeyUp(KeyEventHandler value);
public void add_Layout(LayoutEventHandler value);
public void add_Leave(EventHandler value);
public void add_LocationChanged(EventHandler value);
public void add_LostFocus(EventHandler value);
public void add_MouseDown(MouseEventHandler value);
public void add_MouseEnter(EventHandler value);
public void add_MouseHover(EventHandler value);
public void add_MouseLeave(EventHandler value);
public void add_MouseMove(MouseEventHandler value);
public void add_MouseUp(MouseEventHandler value);
public void add_MouseWheel(MouseEventHandler value);
public void add_Move(EventHandler value);
public void add_Paint(PaintEventHandler value);
public void add_ParentChanged(EventHandler value);
public void add_QueryAccessibilityHelp(QueryAccessibilityHelpEventHandler value);
public void add_QueryContinueDrag(QueryContinueDragEventHandler value);
public void add_Resize(EventHandler value);
public void add_RightToLeftChanged(EventHandler value);
public void add_SizeChanged(EventHandler value);
public void add_StyleChanged(EventHandler value);
public void add_SystemColorsChanged(EventHandler value);
public void add_TabIndexChanged(EventHandler value);
public void add_TabStopChanged(EventHandler value);
public void add_TextChanged(EventHandler value);
public void add_Validated(EventHandler value);
public void add_Validating(CancelEventHandler value);
public void add_VisibleChanged(EventHandler value);
protected virtual void AdjustFormScrollbars(bool displayScrollbars);
public IAsyncResult BeginInvoke(Delegate method);
public IAsyncResult BeginInvoke(Delegate method, object[] args);
public void BringToFront();
public bool Contains(Control ctl);
protected virtual AccessibleObject CreateAccessibilityInstance();
public void CreateControl();
protected virtual ControlCollection CreateControlsInstance();
public Graphics CreateGraphics();
protected virtual void CreateHandle();
public ObjRef CreateObjRef(Type requestedType);
protected virtual void DefWndProc(ref Message m);
protected virtual void DestroyHandle();
public void Dispose();
protected override void Dispose(bool disposing);
public DragDropEffects DoDragDrop(object data, DragDropEffects allowedEffects);
public object EndInvoke(IAsyncResult asyncResult);
public virtual bool Equals(object obj);
protected override void Finalize();
public Form FindForm();
public bool Focus();
public Control GetChildAtPoint(Point pt);
public IContainerControl GetContainerControl();
public virtual int GetHashCode();
public object GetLifetimeService();
public Control GetNextControl(Control ctl, bool forward);
protected bool GetScrollState(int bit);
protected virtual object GetService(Type service);
protected bool GetStyle(ControlStyles flag);
public static TabPage GetTabPageOfComponent(object comp);
protected bool GetTopLevel();
public Type GetType();
public void Hide();
public object InitializeLifetimeService();
protected virtual void InitLayout();
public void Invalidate();
public void Invalidate(bool invalidateChildren);
public void Invalidate(Rectangle rect);
public void Invalidate(Rectangle rc, bool invalidateChildren);
public void Invalidate(Region region);
public void Invalidate(Region region, bool invalidateChildren);
public object Invoke(Delegate method);
public object Invoke(Delegate method, object[] args);
protected void InvokeGotFocus(Control toInvoke, EventArgs e);
protected void InvokeLostFocus(Control toInvoke, EventArgs e);
protected void InvokeOnClick(Control toInvoke, EventArgs e);
protected void InvokePaint(Control c, PaintEventArgs e);
protected void InvokePaintBackground(Control c, PaintEventArgs e);
protected virtual bool IsInputChar(char charCode);
protected virtual bool IsInputKey(Keys keyData);
protected object MemberwiseClone();
protected virtual void NotifyInvalidate(Rectangle invalidatedArea);
protected virtual void OnBackColorChanged(EventArgs e);
protected virtual void OnBackgroundImageChanged(EventArgs e);
protected virtual void OnBindingContextChanged(EventArgs e);
protected virtual void OnCausesValidationChanged(EventArgs e);
protected virtual void OnChangeUICues(UICuesEventArgs e);
protected virtual void OnClick(EventArgs e);
protected virtual void OnContextMenuChanged(EventArgs e);
protected virtual void OnControlAdded(ControlEventArgs e);
protected virtual void OnControlRemoved(ControlEventArgs e);
protected virtual void OnCreateControl();
protected virtual void OnCursorChanged(EventArgs e);
protected virtual void OnDockChanged(EventArgs e);
protected virtual void OnDoubleClick(EventArgs e);
protected virtual void OnDragDrop(DragEventArgs drgevent);
protected virtual void OnDragEnter(DragEventArgs drgevent);
protected virtual void OnDragLeave(EventArgs e);
protected virtual void OnDragOver(DragEventArgs drgevent);
protected virtual void OnEnabledChanged(EventArgs e);
protected virtual void OnEnter(EventArgs e);
protected virtual void OnFontChanged(EventArgs e);
protected virtual void OnForeColorChanged(EventArgs e);
protected virtual void OnGiveFeedback(GiveFeedbackEventArgs gfbevent);
protected virtual void OnGotFocus(EventArgs e);
protected virtual void OnHandleCreated(EventArgs e);
protected virtual void OnHandleDestroyed(EventArgs e);
protected virtual void OnHelpRequested(HelpEventArgs hevent);
protected virtual void OnImeModeChanged(EventArgs e);
protected virtual void OnInvalidated(InvalidateEventArgs e);
protected virtual void OnKeyDown(KeyEventArgs e);
protected virtual void OnKeyPress(KeyPressEventArgs e);
protected virtual void OnKeyUp(KeyEventArgs e);
protected virtual void OnLayout(LayoutEventArgs levent);
protected virtual void OnLeave(EventArgs e);
protected virtual void OnLocationChanged(EventArgs e);
protected virtual void OnLostFocus(EventArgs e);
protected virtual void OnMouseDown(MouseEventArgs e);
protected virtual void OnMouseEnter(EventArgs e);
protected virtual void OnMouseHover(EventArgs e);
protected virtual void OnMouseLeave(EventArgs e);
protected virtual void OnMouseMove(MouseEventArgs e);
protected virtual void OnMouseUp(MouseEventArgs e);
protected virtual void OnMouseWheel(MouseEventArgs e);
protected virtual void OnMove(EventArgs e);
protected virtual void OnNotifyMessage(Message m);
protected virtual void OnPaint(PaintEventArgs e);
protected virtual void OnPaintBackground(PaintEventArgs e);
protected virtual void OnParentBackColorChanged(EventArgs e);
protected virtual void OnParentBackgroundImageChanged(EventArgs e);
protected virtual void OnParentBindingContextChanged(EventArgs e);
protected virtual void OnParentChanged(EventArgs e);
protected virtual void OnParentEnabledChanged(EventArgs e);
protected virtual void OnParentFontChanged(EventArgs e);
protected virtual void OnParentForeColorChanged(EventArgs e);
protected virtual void OnParentRightToLeftChanged(EventArgs e);
protected virtual void OnParentVisibleChanged(EventArgs e);
protected virtual void OnQueryContinueDrag(QueryContinueDragEventArgs qcdevent);
protected virtual void OnResize(EventArgs e);
protected virtual void OnRightToLeftChanged(EventArgs e);
protected virtual void OnSizeChanged(EventArgs e);
protected virtual void OnStyleChanged(EventArgs e);
protected virtual void OnSystemColorsChanged(EventArgs e);
protected virtual void OnTabIndexChanged(EventArgs e);
protected virtual void OnTabStopChanged(EventArgs e);
protected virtual void OnTextChanged(EventArgs e);
protected virtual void OnValidated(EventArgs e);
protected virtual void OnValidating(CancelEventArgs e);
protected virtual void OnVisibleChanged(EventArgs e);
public void PerformLayout();
public void PerformLayout(Control affectedControl, string affectedProperty);
public Point PointToClient(Point p);
public Point PointToScreen(Point p);
public bool PreProcessMessage(ref Message msg);
protected virtual bool ProcessCmdKey(ref Message msg, Keys keyData);
protected virtual bool ProcessDialogChar(char charCode);
protected virtual bool ProcessDialogKey(Keys keyData);
protected virtual bool ProcessKeyEventArgs(ref Message m);
protected virtual bool ProcessKeyPreview(ref Message m);
protected virtual bool ProcessMnemonic(char charCode);
protected void RaiseDragEvent(object key, DragEventArgs e);
protected void RaiseKeyEvent(object key, KeyEventArgs e);
protected void RaiseMouseEvent(object key, MouseEventArgs e);
protected void RaisePaintEvent(object key, PaintEventArgs e);
protected void RecreateHandle();
public Rectangle RectangleToClient(Rectangle r);
public Rectangle RectangleToScreen(Rectangle r);
public virtual void Refresh();
public void remove_BackColorChanged(EventHandler value);
public void remove_BackgroundImageChanged(EventHandler value);
public void remove_BindingContextChanged(EventHandler value);
public void remove_CausesValidationChanged(EventHandler value);
public void remove_ChangeUICues(UICuesEventHandler value);
public void remove_Click(EventHandler value);
public void remove_ContextMenuChanged(EventHandler value);
public void remove_ControlAdded(ControlEventHandler value);
public void remove_ControlRemoved(ControlEventHandler value);
public void remove_CursorChanged(EventHandler value);
public void remove_Disposed(EventHandler value);
public void remove_DockChanged(EventHandler value);
public void remove_DoubleClick(EventHandler value);
public void remove_DragDrop(DragEventHandler value);
public void remove_DragEnter(DragEventHandler value);
public void remove_DragLeave(EventHandler value);
public void remove_DragOver(DragEventHandler value);
public void remove_EnabledChanged(EventHandler value);
public void remove_Enter(EventHandler value);
public void remove_FontChanged(EventHandler value);
public void remove_ForeColorChanged(EventHandler value);
public void remove_GiveFeedback(GiveFeedbackEventHandler value);
public void remove_GotFocus(EventHandler value);
public void remove_HandleCreated(EventHandler value);
public void remove_HandleDestroyed(EventHandler value);
public void remove_HelpRequested(HelpEventHandler value);
public void remove_ImeModeChanged(EventHandler value);
public void remove_Invalidated(InvalidateEventHandler value);
public void remove_KeyDown(KeyEventHandler value);
public void remove_KeyPress(KeyPressEventHandler value);
public void remove_KeyUp(KeyEventHandler value);
public void remove_Layout(LayoutEventHandler value);
public void remove_Leave(EventHandler value);
public void remove_LocationChanged(EventHandler value);
public void remove_LostFocus(EventHandler value);
public void remove_MouseDown(MouseEventHandler value);
public void remove_MouseEnter(EventHandler value);
public void remove_MouseHover(EventHandler value);
public void remove_MouseLeave(EventHandler value);
public void remove_MouseMove(MouseEventHandler value);
public void remove_MouseUp(MouseEventHandler value);
public void remove_MouseWheel(MouseEventHandler value);
public void remove_Move(EventHandler value);
public void remove_Paint(PaintEventHandler value);
public void remove_ParentChanged(EventHandler value);
public void remove_QueryAccessibilityHelp(QueryAccessibilityHelpEventHandler value);
public void remove_QueryContinueDrag(QueryContinueDragEventHandler value);
public void remove_Resize(EventHandler value);
public void remove_RightToLeftChanged(EventHandler value);
public void remove_SizeChanged(EventHandler value);
public void remove_StyleChanged(EventHandler value);
public void remove_SystemColorsChanged(EventHandler value);
public void remove_TabIndexChanged(EventHandler value);
public void remove_TabStopChanged(EventHandler value);
public void remove_TextChanged(EventHandler value);
public void remove_Validated(EventHandler value);
public void remove_Validating(CancelEventHandler value);
public void remove_VisibleChanged(EventHandler value);
public void ResetBackColor();
public void ResetBindings();
public void ResetCursor();
public void ResetFont();
public void ResetForeColor();
public void ResetImeMode();
protected void ResetMouseEventArgs();
public void ResetRightToLeft();
public void ResetText();
public void ResumeLayout();
public void ResumeLayout(bool performLayout);
protected ContentAlignment RtlTranslateAlignment(ContentAlignment align);
protected HorizontalAlignment RtlTranslateAlignment(HorizontalAlignment align);
protected LeftRightAlignment RtlTranslateAlignment(LeftRightAlignment align);
protected ContentAlignment RtlTranslateContent(ContentAlignment align);
protected HorizontalAlignment RtlTranslateHorizontal(HorizontalAlignment align);
protected LeftRightAlignment RtlTranslateLeftRight(LeftRightAlignment align);
public void Scale(float ratio);
public void Scale(float dx, float dy);
protected virtual void ScaleCore(float dx, float dy);
public void ScrollControlIntoView(Control activeControl);
public void Select();
protected virtual void Select(bool directed, bool forward);
public bool SelectNextControl(Control ctl, bool forward, bool tabStopOnly, bool nested, bool wrap);
public void SendToBack();
public void SetAutoScrollMargin(int x, int y);
public void SetBounds(int x, int y, int width, int height);
public void SetBounds(int x, int y, int width, int height, BoundsSpecified specified);
protected virtual void SetBoundsCore(int x, int y, int width, int height, BoundsSpecified specified);
protected virtual void SetClientSizeCore(int x, int y);
protected void SetDisplayRectLocation(int x, int y);
protected void SetScrollState(int bit, bool value);
protected void SetStyle(ControlStyles flag, bool value);
protected void SetTopLevel(bool value);
protected virtual void SetVisibleCore(bool value);
public void Show();
public void SuspendLayout();
public virtual string ToString();
public void Update();
protected void UpdateBounds();
protected void UpdateBounds(int x, int y, int width, int height);
protected void UpdateBounds(int x, int y, int width, int height, int clientWidth, int clientHeight);
protected void UpdateStyles();
protected void UpdateZOrder();
protected virtual void WndProc(ref Message m);

Property
public AccessibleObject AccessibilityObject {get;}
public string AccessibleDefaultActionDescription {get; set;}
public string AccessibleDescription {get; set;}
public string AccessibleName {get; set;}
public AccessibleRole AccessibleRole {get; set;}
public bool AllowDrop {get; set;}
public override AnchorStyles Anchor {get; set;}
public bool AutoScroll {get; set;}
public Size AutoScrollMargin {get; set;}
public Size AutoScrollMinSize {get; set;}
public Point AutoScrollPosition {get; set;}
public virtual Color BackColor {get; set;}
public Image BackgroundImage {get; set;}
public virtual BindingContext BindingContext {get; set;}
public BorderStyle BorderStyle {get; set;}
public int Bottom {get;}
public Rectangle Bounds {get; set;}
public bool CanFocus {get;}
public bool CanSelect {get;}
public bool Capture {get; set;}
public bool CausesValidation {get; set;}
public Rectangle ClientRectangle {get;}
public Size ClientSize {get; set;}
public string CompanyName {get;}
public IContainer Container {get;}
public bool ContainsFocus {get;}
public ContextMenu ContextMenu {get; set;}
public ControlCollection Controls {get;}
public bool Created {get;}
protected virtual CreateParams CreateParams {get;}
public Cursor Cursor {get; set;}
public ControlBindingsCollection DataBindings {get;}
protected virtual ImeMode DefaultImeMode {get;}
protected virtual Size DefaultSize {get;}
protected bool DesignMode {get;}
public Rectangle DisplayRectangle {get;}
public bool Disposing {get;}
public override DockStyle Dock {get; set;}
public DockPaddingEdges DockPadding {get;}
public bool Enabled {get; set;}
protected EventHandlerList Events {get;}
public bool Focused {get;}
public virtual Font Font {get; set;}
protected int FontHeight {get; set;}
public virtual Color ForeColor {get; set;}
public IntPtr Handle {get;}
public bool HasChildren {get;}
public int Height {get; set;}
protected bool HScroll {get; set;}
public int ImageIndex {get; set;}
public ImeMode ImeMode {get; set;}
public bool InvokeRequired {get;}
public bool IsAccessible {get; set;}
public bool IsDisposed {get;}
public bool IsHandleCreated {get;}
public int Left {get; set;}
public Point Location {get; set;}
public string Name {get; set;}
public Control Parent {get; set;}
public string ProductName {get;}
public string ProductVersion {get;}
public bool RecreatingHandle {get;}
public Region Region {get; set;}
protected bool RenderRightToLeft {get;}
protected bool ResizeRedraw {get; set;}
public int Right {get;}
public RightToLeft RightToLeft {get; set;}
protected virtual bool ShowFocusCues {get;}
protected bool ShowKeyboardCues {get;}
public ISite Site {get; set;}
public Size Size {get; set;}
public int TabIndex {get; set;}
public bool TabStop {get; set;}
public object Tag {get; set;}
public override string Text {get; set;}
public string ToolTipText {get; set;}
public int Top {get; set;}
public Control TopLevelControl {get;}
public bool Visible {get; set;}
protected bool VScroll {get; set;}
public int Width {get; set;}
public IWindowTarget WindowTarget {get; set;}

System.Windows.Forms.TabControl+TabPageCollection

Module:System.Windows.Forms.dll

Hierarchy
Object
TabControl+TabPageCollection : IList, ICollection, IEnumerable

Type declaration

[C#] public class TabPageCollection: IList, ICollection, IEnumerable;

Constructor
public TabPageCollection(TabControl owner);

Method
public void Add(TabPage value);
public void AddRange(TabPage[] pages);
public virtual void Clear();
public bool Contains(TabPage page);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual IEnumerator GetEnumerator();
public virtual int GetHashCode();
public Type GetType();
public int IndexOf(TabPage page);
protected object MemberwiseClone();
public void Remove(TabPage value);
public virtual void RemoveAt(int index);
public virtual string ToString();

Property
public int Count {get;}
public virtual bool IsReadOnly {get;}
public TabPage this[int index] {get; set;}

System.Windows.Forms.TabControl

Module:System.Windows.Forms.dll

Hierarchy
Object
MarshalByRefObject
Component
Control
TabControl

Type declaration

[C#] public class TabControl : Control;

Constructor
public TabControl();

Method
protected void AccessibilityNotifyClients(AccessibleEvents accEvent, int childID);
public void add_BackColorChanged(EventHandler value);
public void add_BackgroundImageChanged(EventHandler value);
public void add_BindingContextChanged(EventHandler value);
public void add_CausesValidationChanged(EventHandler value);
public void add_ChangeUICues(UICuesEventHandler value);
public void add_Click(EventHandler value);
public void add_ContextMenuChanged(EventHandler value);
public void add_ControlAdded(ControlEventHandler value);
public void add_ControlRemoved(ControlEventHandler value);
public void add_CursorChanged(EventHandler value);
public void add_Disposed(EventHandler value);
public void add_DockChanged(EventHandler value);
public void add_DoubleClick(EventHandler value);
public void add_DragDrop(DragEventHandler value);
public void add_DragEnter(DragEventHandler value);
public void add_DragLeave(EventHandler value);
public void add_DragOver(DragEventHandler value);
public void add_DrawItem(DrawItemEventHandler value);
public void add_EnabledChanged(EventHandler value);
public void add_Enter(EventHandler value);
public void add_FontChanged(EventHandler value);
public void add_ForeColorChanged(EventHandler value);
public void add_GiveFeedback(GiveFeedbackEventHandler value);
public void add_GotFocus(EventHandler value);
public void add_HandleCreated(EventHandler value);
public void add_HandleDestroyed(EventHandler value);
public void add_HelpRequested(HelpEventHandler value);
public void add_ImeModeChanged(EventHandler value);
public void add_Invalidated(InvalidateEventHandler value);
public void add_KeyDown(KeyEventHandler value);
public void add_KeyPress(KeyPressEventHandler value);
public void add_KeyUp(KeyEventHandler value);
public void add_Layout(LayoutEventHandler value);
public void add_Leave(EventHandler value);
public void add_LocationChanged(EventHandler value);
public void add_LostFocus(EventHandler value);
public void add_MouseDown(MouseEventHandler value);
public void add_MouseEnter(EventHandler value);
public void add_MouseHover(EventHandler value);
public void add_MouseLeave(EventHandler value);
public void add_MouseMove(MouseEventHandler value);
public void add_MouseUp(MouseEventHandler value);
public void add_MouseWheel(MouseEventHandler value);
public void add_Move(EventHandler value);
public void add_Paint(PaintEventHandler value);
public void add_ParentChanged(EventHandler value);
public void add_QueryAccessibilityHelp(QueryAccessibilityHelpEventHandler value);
public void add_QueryContinueDrag(QueryContinueDragEventHandler value);
public void add_Resize(EventHandler value);
public void add_RightToLeftChanged(EventHandler value);
public void add_SelectedIndexChanged(EventHandler value);
public void add_SizeChanged(EventHandler value);
public void add_StyleChanged(EventHandler value);
public void add_SystemColorsChanged(EventHandler value);
public void add_TabIndexChanged(EventHandler value);
public void add_TabStopChanged(EventHandler value);
public void add_TextChanged(EventHandler value);
public void add_Validated(EventHandler value);
public void add_Validating(CancelEventHandler value);
public void add_VisibleChanged(EventHandler value);
public IAsyncResult BeginInvoke(Delegate method);
public IAsyncResult BeginInvoke(Delegate method, object[] args);
public void BringToFront();
public bool Contains(Control ctl);
protected virtual AccessibleObject CreateAccessibilityInstance();
public void CreateControl();
protected virtual ControlCollection CreateControlsInstance();
public Graphics CreateGraphics();
protected virtual void CreateHandle();
public ObjRef CreateObjRef(Type requestedType);
protected virtual void DefWndProc(ref Message m);
protected virtual void DestroyHandle();
public void Dispose();
protected override void Dispose(bool disposing);
public DragDropEffects DoDragDrop(object data, DragDropEffects allowedEffects);
public object EndInvoke(IAsyncResult asyncResult);
public virtual bool Equals(object obj);
protected override void Finalize();
public Form FindForm();
public bool Focus();
public Control GetChildAtPoint(Point pt);
public IContainerControl GetContainerControl();
public Control GetControl(int index);
public virtual int GetHashCode();
protected virtual object[] GetItems();
protected virtual object[] GetItems(Type baseType);
public object GetLifetimeService();
public Control GetNextControl(Control ctl, bool forward);
protected virtual object GetService(Type service);
protected bool GetStyle(ControlStyles flag);
public Rectangle GetTabRect(int index);
protected string GetToolTipText(object item);
protected bool GetTopLevel();
public Type GetType();
public void Hide();
public object InitializeLifetimeService();
protected virtual void InitLayout();
public void Invalidate();
public void Invalidate(bool invalidateChildren);
public void Invalidate(Rectangle rect);
public void Invalidate(Rectangle rc, bool invalidateChildren);
public void Invalidate(Region region);
public void Invalidate(Region region, bool invalidateChildren);
public object Invoke(Delegate method);
public object Invoke(Delegate method, object[] args);
protected void InvokeGotFocus(Control toInvoke, EventArgs e);
protected void InvokeLostFocus(Control toInvoke, EventArgs e);
protected void InvokeOnClick(Control toInvoke, EventArgs e);
protected void InvokePaint(Control c, PaintEventArgs e);
protected void InvokePaintBackground(Control c, PaintEventArgs e);
protected virtual bool IsInputChar(char charCode);
protected virtual bool IsInputKey(Keys keyData);
protected object MemberwiseClone();
protected virtual void NotifyInvalidate(Rectangle invalidatedArea);
protected virtual void OnBackColorChanged(EventArgs e);
protected virtual void OnBackgroundImageChanged(EventArgs e);
protected virtual void OnBindingContextChanged(EventArgs e);
protected virtual void OnCausesValidationChanged(EventArgs e);
protected virtual void OnChangeUICues(UICuesEventArgs e);
protected virtual void OnClick(EventArgs e);
protected virtual void OnContextMenuChanged(EventArgs e);
protected virtual void OnControlAdded(ControlEventArgs e);
protected virtual void OnControlRemoved(ControlEventArgs e);
protected virtual void OnCreateControl();
protected virtual void OnCursorChanged(EventArgs e);
protected virtual void OnDockChanged(EventArgs e);
protected virtual void OnDoubleClick(EventArgs e);
protected virtual void OnDragDrop(DragEventArgs drgevent);
protected virtual void OnDragEnter(DragEventArgs drgevent);
protected virtual void OnDragLeave(EventArgs e);
protected virtual void OnDragOver(DragEventArgs drgevent);
protected virtual void OnDrawItem(DrawItemEventArgs e);
protected virtual void OnEnabledChanged(EventArgs e);
protected virtual void OnEnter(EventArgs e);
protected virtual void OnFontChanged(EventArgs e);
protected virtual void OnForeColorChanged(EventArgs e);
protected virtual void OnGiveFeedback(GiveFeedbackEventArgs gfbevent);
protected virtual void OnGotFocus(EventArgs e);
protected virtual void OnHandleCreated(EventArgs e);
protected virtual void OnHandleDestroyed(EventArgs e);
protected virtual void OnHelpRequested(HelpEventArgs hevent);
protected virtual void OnImeModeChanged(EventArgs e);
protected virtual void OnInvalidated(InvalidateEventArgs e);
protected virtual void OnKeyDown(KeyEventArgs e);
protected virtual void OnKeyPress(KeyPressEventArgs e);
protected virtual void OnKeyUp(KeyEventArgs e);
protected virtual void OnLayout(LayoutEventArgs levent);
protected virtual void OnLeave(EventArgs e);
protected virtual void OnLocationChanged(EventArgs e);
protected virtual void OnLostFocus(EventArgs e);
protected virtual void OnMouseDown(MouseEventArgs e);
protected virtual void OnMouseEnter(EventArgs e);
protected virtual void OnMouseHover(EventArgs e);
protected virtual void OnMouseLeave(EventArgs e);
protected virtual void OnMouseMove(MouseEventArgs e);
protected virtual void OnMouseUp(MouseEventArgs e);
protected virtual void OnMouseWheel(MouseEventArgs e);
protected virtual void OnMove(EventArgs e);
protected virtual void OnNotifyMessage(Message m);
protected virtual void OnPaint(PaintEventArgs e);
protected virtual void OnPaintBackground(PaintEventArgs e);
protected virtual void OnParentBackColorChanged(EventArgs e);
protected virtual void OnParentBackgroundImageChanged(EventArgs e);
protected virtual void OnParentBindingContextChanged(EventArgs e);
protected virtual void OnParentChanged(EventArgs e);
protected virtual void OnParentEnabledChanged(EventArgs e);
protected virtual void OnParentFontChanged(EventArgs e);
protected virtual void OnParentForeColorChanged(EventArgs e);
protected virtual void OnParentRightToLeftChanged(EventArgs e);
protected virtual void OnParentVisibleChanged(EventArgs e);
protected virtual void OnQueryContinueDrag(QueryContinueDragEventArgs qcdevent);
protected virtual void OnResize(EventArgs e);
protected virtual void OnRightToLeftChanged(EventArgs e);
protected void OnSelectedIndexChanged(EventArgs e);
protected virtual void OnSizeChanged(EventArgs e);
protected virtual void OnStyleChanged(EventArgs e);
protected virtual void OnSystemColorsChanged(EventArgs e);
protected virtual void OnTabIndexChanged(EventArgs e);
protected virtual void OnTabStopChanged(EventArgs e);
protected virtual void OnTextChanged(EventArgs e);
protected virtual void OnValidated(EventArgs e);
protected virtual void OnValidating(CancelEventArgs e);
protected virtual void OnVisibleChanged(EventArgs e);
public void PerformLayout();
public void PerformLayout(Control affectedControl, string affectedProperty);
public Point PointToClient(Point p);
public Point PointToScreen(Point p);
public bool PreProcessMessage(ref Message msg);
protected virtual bool ProcessCmdKey(ref Message msg, Keys keyData);
protected virtual bool ProcessDialogChar(char charCode);
protected virtual bool ProcessDialogKey(Keys keyData);
protected virtual bool ProcessKeyEventArgs(ref Message m);
protected virtual bool ProcessKeyPreview(ref Message m);
protected virtual bool ProcessMnemonic(char charCode);
protected void RaiseDragEvent(object key, DragEventArgs e);
protected void RaiseKeyEvent(object key, KeyEventArgs e);
protected void RaiseMouseEvent(object key, MouseEventArgs e);
protected void RaisePaintEvent(object key, PaintEventArgs e);
protected void RecreateHandle();
public Rectangle RectangleToClient(Rectangle r);
public Rectangle RectangleToScreen(Rectangle r);
public virtual void Refresh();
public void remove_BackColorChanged(EventHandler value);
public void remove_BackgroundImageChanged(EventHandler value);
public void remove_BindingContextChanged(EventHandler value);
public void remove_CausesValidationChanged(EventHandler value);
public void remove_ChangeUICues(UICuesEventHandler value);
public void remove_Click(EventHandler value);
public void remove_ContextMenuChanged(EventHandler value);
public void remove_ControlAdded(ControlEventHandler value);
public void remove_ControlRemoved(ControlEventHandler value);
public void remove_CursorChanged(EventHandler value);
public void remove_Disposed(EventHandler value);
public void remove_DockChanged(EventHandler value);
public void remove_DoubleClick(EventHandler value);
public void remove_DragDrop(DragEventHandler value);
public void remove_DragEnter(DragEventHandler value);
public void remove_DragLeave(EventHandler value);
public void remove_DragOver(DragEventHandler value);
public void remove_DrawItem(DrawItemEventHandler value);
public void remove_EnabledChanged(EventHandler value);
public void remove_Enter(EventHandler value);
public void remove_FontChanged(EventHandler value);
public void remove_ForeColorChanged(EventHandler value);
public void remove_GiveFeedback(GiveFeedbackEventHandler value);
public void remove_GotFocus(EventHandler value);
public void remove_HandleCreated(EventHandler value);
public void remove_HandleDestroyed(EventHandler value);
public void remove_HelpRequested(HelpEventHandler value);
public void remove_ImeModeChanged(EventHandler value);
public void remove_Invalidated(InvalidateEventHandler value);
public void remove_KeyDown(KeyEventHandler value);
public void remove_KeyPress(KeyPressEventHandler value);
public void remove_KeyUp(KeyEventHandler value);
public void remove_Layout(LayoutEventHandler value);
public void remove_Leave(EventHandler value);
public void remove_LocationChanged(EventHandler value);
public void remove_LostFocus(EventHandler value);
public void remove_MouseDown(MouseEventHandler value);
public void remove_MouseEnter(EventHandler value);
public void remove_MouseHover(EventHandler value);
public void remove_MouseLeave(EventHandler value);
public void remove_MouseMove(MouseEventHandler value);
public void remove_MouseUp(MouseEventHandler value);
public void remove_MouseWheel(MouseEventHandler value);
public void remove_Move(EventHandler value);
public void remove_Paint(PaintEventHandler value);
public void remove_ParentChanged(EventHandler value);
public void remove_QueryAccessibilityHelp(QueryAccessibilityHelpEventHandler value);
public void remove_QueryContinueDrag(QueryContinueDragEventHandler value);
public void remove_Resize(EventHandler value);
public void remove_RightToLeftChanged(EventHandler value);
public void remove_SelectedIndexChanged(EventHandler value);
public void remove_SizeChanged(EventHandler value);
public void remove_StyleChanged(EventHandler value);
public void remove_SystemColorsChanged(EventHandler value);
public void remove_TabIndexChanged(EventHandler value);
public void remove_TabStopChanged(EventHandler value);
public void remove_TextChanged(EventHandler value);
public void remove_Validated(EventHandler value);
public void remove_Validating(CancelEventHandler value);
public void remove_VisibleChanged(EventHandler value);
protected void RemoveAll();
public void ResetBackColor();
public void ResetBindings();
public void ResetCursor();
public void ResetFont();
public void ResetForeColor();
public void ResetImeMode();
protected void ResetMouseEventArgs();
public void ResetRightToLeft();
public void ResetText();
public void ResumeLayout();
public void ResumeLayout(bool performLayout);
protected ContentAlignment RtlTranslateAlignment(ContentAlignment align);
protected HorizontalAlignment RtlTranslateAlignment(HorizontalAlignment align);
protected LeftRightAlignment RtlTranslateAlignment(LeftRightAlignment align);
protected ContentAlignment RtlTranslateContent(ContentAlignment align);
protected HorizontalAlignment RtlTranslateHorizontal(HorizontalAlignment align);
protected LeftRightAlignment RtlTranslateLeftRight(LeftRightAlignment align);
public void Scale(float ratio);
public void Scale(float dx, float dy);
protected virtual void ScaleCore(float dx, float dy);
public void Select();
protected virtual void Select(bool directed, bool forward);
public bool SelectNextControl(Control ctl, bool forward, bool tabStopOnly, bool nested, bool wrap);
public void SendToBack();
public void SetBounds(int x, int y, int width, int height);
public void SetBounds(int x, int y, int width, int height, BoundsSpecified specified);
protected virtual void SetBoundsCore(int x, int y, int width, int height, BoundsSpecified specified);
protected virtual void SetClientSizeCore(int x, int y);
protected void SetStyle(ControlStyles flag, bool value);
protected void SetTopLevel(bool value);
protected virtual void SetVisibleCore(bool value);
public void Show();
public void SuspendLayout();
public virtual string ToString();
public void Update();
protected void UpdateBounds();
protected void UpdateBounds(int x, int y, int width, int height);
protected void UpdateBounds(int x, int y, int width, int height, int clientWidth, int clientHeight);
protected void UpdateStyles();
protected void UpdateTabSelection(bool uiselected);
protected void UpdateZOrder();
protected virtual void WndProc(ref Message m);

Property
public AccessibleObject AccessibilityObject {get;}
public string AccessibleDefaultActionDescription {get; set;}
public string AccessibleDescription {get; set;}
public string AccessibleName {get; set;}
public AccessibleRole AccessibleRole {get; set;}
public TabAlignment Alignment {get; set;}
public bool AllowDrop {get; set;}
public AnchorStyles Anchor {get; set;}
public TabAppearance Appearance {get; set;}
public virtual Color BackColor {get; set;}
public override Image BackgroundImage {get; set;}
public virtual BindingContext BindingContext {get; set;}
public int Bottom {get;}
public Rectangle Bounds {get; set;}
public bool CanFocus {get;}
public bool CanSelect {get;}
public bool Capture {get; set;}
public bool CausesValidation {get; set;}
public Rectangle ClientRectangle {get;}
public Size ClientSize {get; set;}
public string CompanyName {get;}
public IContainer Container {get;}
public bool ContainsFocus {get;}
public ContextMenu ContextMenu {get; set;}
public ControlCollection Controls {get;}
public bool Created {get;}
protected virtual CreateParams CreateParams {get;}
public Cursor Cursor {get; set;}
public ControlBindingsCollection DataBindings {get;}
protected virtual ImeMode DefaultImeMode {get;}
protected virtual Size DefaultSize {get;}
protected bool DesignMode {get;}
public override Rectangle DisplayRectangle {get;}
public bool Disposing {get;}
public DockStyle Dock {get; set;}
public TabDrawMode DrawMode {get; set;}
public bool Enabled {get; set;}
protected EventHandlerList Events {get;}
public bool Focused {get;}
public virtual Font Font {get; set;}
protected int FontHeight {get; set;}
public virtual Color ForeColor {get; set;}
public IntPtr Handle {get;}
public bool HasChildren {get;}
public int Height {get; set;}
public bool HotTrack {get; set;}
public ImageList ImageList {get; set;}
public ImeMode ImeMode {get; set;}
public bool InvokeRequired {get;}
public bool IsAccessible {get; set;}
public bool IsDisposed {get;}
public bool IsHandleCreated {get;}
public Size ItemSize {get; set;}
public int Left {get; set;}
public Point Location {get; set;}
public bool Multiline {get; set;}
public string Name {get; set;}
public Point Padding {get; set;}
public Control Parent {get; set;}
public string ProductName {get;}
public string ProductVersion {get;}
public bool RecreatingHandle {get;}
public Region Region {get; set;}
protected bool RenderRightToLeft {get;}
protected bool ResizeRedraw {get; set;}
public int Right {get;}
public RightToLeft RightToLeft {get; set;}
public int RowCount {get;}
public int SelectedIndex {get; set;}
public TabPage SelectedTab {get; set;}
protected virtual bool ShowFocusCues {get;}
protected bool ShowKeyboardCues {get;}
public bool ShowToolTips {get; set;}
public ISite Site {get; set;}
public Size Size {get; set;}
public TabSizeMode SizeMode {get; set;}
public int TabCount {get;}
public int TabIndex {get; set;}
public TabPageCollection TabPages {get;}
public bool TabStop {get; set;}
public object Tag {get; set;}
public virtual string Text {get; set;}
public int Top {get; set;}
public Control TopLevelControl {get;}
public bool Visible {get; set;}
public int Width {get; set;}
public IWindowTarget WindowTarget {get; set;}

System.Windows.Forms.SystemInformation

Module:System.Windows.Forms.dll

Hierarchy
Object
SystemInformation

Type declaration

[C#] public class SystemInformation;

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public static ArrangeDirection ArrangeDirection {get;}
public static ArrangeStartingPosition ArrangeStartingPosition {get;}
public static BootMode BootMode {get;}
public static Size Border3DSize {get;}
public static Size BorderSize {get;}
public static Size CaptionButtonSize {get;}
public static int CaptionHeight {get;}
public static string ComputerName {get;}
public static Size CursorSize {get;}
public static bool DbcsEnabled {get;}
public static bool DebugOS {get;}
public static Size DoubleClickSize {get;}
public static int DoubleClickTime {get;}
public static bool DragFullWindows {get;}
public static Size DragSize {get;}
public static Size FixedFrameBorderSize {get;}
public static Size FrameBorderSize {get;}
public static bool HighContrast {get;}
public static int HorizontalScrollBarArrowWidth {get;}
public static int HorizontalScrollBarHeight {get;}
public static int HorizontalScrollBarThumbWidth {get;}
public static Size IconSize {get;}
public static Size IconSpacingSize {get;}
public static int KanjiWindowHeight {get;}
public static Size MaxWindowTrackSize {get;}
public static Size MenuButtonSize {get;}
public static Size MenuCheckSize {get;}
public static Font MenuFont {get;}
public static int MenuHeight {get;}
public static bool MidEastEnabled {get;}
public static Size MinimizedWindowSize {get;}
public static Size MinimizedWindowSpacingSize {get;}
public static Size MinimumWindowSize {get;}
public static Size MinWindowTrackSize {get;}
public static int MonitorCount {get;}
public static bool MonitorsSameDisplayFormat {get;}
public static int MouseButtons {get;}
public static bool MouseButtonsSwapped {get;}
public static bool MousePresent {get;}
public static bool MouseWheelPresent {get;}
public static int MouseWheelScrollLines {get;}
public static bool NativeMouseWheelSupport {get;}
public static bool Network {get;}
public static bool PenWindows {get;}
public static Size PrimaryMonitorMaximizedWindowSize {get;}
public static Size PrimaryMonitorSize {get;}
public static bool RightAlignedMenus {get;}
public static bool Secure {get;}
public static bool ShowSounds {get;}
public static Size SmallIconSize {get;}
public static Size ToolWindowCaptionButtonSize {get;}
public static int ToolWindowCaptionHeight {get;}
public static string UserDomainName {get;}
public static bool UserInteractive {get;}
public static string UserName {get;}
public static int VerticalScrollBarArrowHeight {get;}
public static int VerticalScrollBarThumbHeight {get;}
public static int VerticalScrollBarWidth {get;}
public static Rectangle VirtualScreen {get;}
public static Rectangle WorkingArea {get;}

System.Windows.Forms.StatusBar

Module:System.Windows.Forms.dll

Hierarchy
Object
MarshalByRefObject
Component
Control
StatusBar

Type declaration

[C#] public class StatusBar : Control;

Constructor
public StatusBar();

Method
protected void AccessibilityNotifyClients(AccessibleEvents accEvent, int childID);
public void add_BackColorChanged(EventHandler value);
public void add_BackgroundImageChanged(EventHandler value);
public void add_BindingContextChanged(EventHandler value);
public void add_CausesValidationChanged(EventHandler value);
public void add_ChangeUICues(UICuesEventHandler value);
public void add_Click(EventHandler value);
public void add_ContextMenuChanged(EventHandler value);
public void add_ControlAdded(ControlEventHandler value);
public void add_ControlRemoved(ControlEventHandler value);
public void add_CursorChanged(EventHandler value);
public void add_Disposed(EventHandler value);
public void add_DockChanged(EventHandler value);
public void add_DoubleClick(EventHandler value);
public void add_DragDrop(DragEventHandler value);
public void add_DragEnter(DragEventHandler value);
public void add_DragLeave(EventHandler value);
public void add_DragOver(DragEventHandler value);
public void add_DrawItem(StatusBarDrawItemEventHandler value);
public void add_EnabledChanged(EventHandler value);
public void add_Enter(EventHandler value);
public void add_FontChanged(EventHandler value);
public void add_ForeColorChanged(EventHandler value);
public void add_GiveFeedback(GiveFeedbackEventHandler value);
public void add_GotFocus(EventHandler value);
public void add_HandleCreated(EventHandler value);
public void add_HandleDestroyed(EventHandler value);
public void add_HelpRequested(HelpEventHandler value);
public void add_ImeModeChanged(EventHandler value);
public void add_Invalidated(InvalidateEventHandler value);
public void add_KeyDown(KeyEventHandler value);
public void add_KeyPress(KeyPressEventHandler value);
public void add_KeyUp(KeyEventHandler value);
public void add_Layout(LayoutEventHandler value);
public void add_Leave(EventHandler value);
public void add_LocationChanged(EventHandler value);
public void add_LostFocus(EventHandler value);
public void add_MouseDown(MouseEventHandler value);
public void add_MouseEnter(EventHandler value);
public void add_MouseHover(EventHandler value);
public void add_MouseLeave(EventHandler value);
public void add_MouseMove(MouseEventHandler value);
public void add_MouseUp(MouseEventHandler value);
public void add_MouseWheel(MouseEventHandler value);
public void add_Move(EventHandler value);
public void add_Paint(PaintEventHandler value);
public void add_PanelClick(StatusBarPanelClickEventHandler value);
public void add_ParentChanged(EventHandler value);
public void add_QueryAccessibilityHelp(QueryAccessibilityHelpEventHandler value);
public void add_QueryContinueDrag(QueryContinueDragEventHandler value);
public void add_Resize(EventHandler value);
public void add_RightToLeftChanged(EventHandler value);
public void add_SizeChanged(EventHandler value);
public void add_StyleChanged(EventHandler value);
public void add_SystemColorsChanged(EventHandler value);
public void add_TabIndexChanged(EventHandler value);
public void add_TabStopChanged(EventHandler value);
public void add_TextChanged(EventHandler value);
public void add_Validated(EventHandler value);
public void add_Validating(CancelEventHandler value);
public void add_VisibleChanged(EventHandler value);
public IAsyncResult BeginInvoke(Delegate method);
public IAsyncResult BeginInvoke(Delegate method, object[] args);
public void BringToFront();
public bool Contains(Control ctl);
protected virtual AccessibleObject CreateAccessibilityInstance();
public void CreateControl();
protected virtual ControlCollection CreateControlsInstance();
public Graphics CreateGraphics();
protected virtual void CreateHandle();
public ObjRef CreateObjRef(Type requestedType);
protected virtual void DefWndProc(ref Message m);
protected virtual void DestroyHandle();
public void Dispose();
protected override void Dispose(bool disposing);
public DragDropEffects DoDragDrop(object data, DragDropEffects allowedEffects);
public object EndInvoke(IAsyncResult asyncResult);
public virtual bool Equals(object obj);
protected override void Finalize();
public Form FindForm();
public bool Focus();
public Control GetChildAtPoint(Point pt);
public IContainerControl GetContainerControl();
public virtual int GetHashCode();
public object GetLifetimeService();
public Control GetNextControl(Control ctl, bool forward);
protected virtual object GetService(Type service);
protected bool GetStyle(ControlStyles flag);
protected bool GetTopLevel();
public Type GetType();
public void Hide();
public object InitializeLifetimeService();
protected virtual void InitLayout();
public void Invalidate();
public void Invalidate(bool invalidateChildren);
public void Invalidate(Rectangle rect);
public void Invalidate(Rectangle rc, bool invalidateChildren);
public void Invalidate(Region region);
public void Invalidate(Region region, bool invalidateChildren);
public object Invoke(Delegate method);
public object Invoke(Delegate method, object[] args);
protected void InvokeGotFocus(Control toInvoke, EventArgs e);
protected void InvokeLostFocus(Control toInvoke, EventArgs e);
protected void InvokeOnClick(Control toInvoke, EventArgs e);
protected void InvokePaint(Control c, PaintEventArgs e);
protected void InvokePaintBackground(Control c, PaintEventArgs e);
protected virtual bool IsInputChar(char charCode);
protected virtual bool IsInputKey(Keys keyData);
protected object MemberwiseClone();
protected virtual void NotifyInvalidate(Rectangle invalidatedArea);
protected virtual void OnBackColorChanged(EventArgs e);
protected virtual void OnBackgroundImageChanged(EventArgs e);
protected virtual void OnBindingContextChanged(EventArgs e);
protected virtual void OnCausesValidationChanged(EventArgs e);
protected virtual void OnChangeUICues(UICuesEventArgs e);
protected virtual void OnClick(EventArgs e);
protected virtual void OnContextMenuChanged(EventArgs e);
protected virtual void OnControlAdded(ControlEventArgs e);
protected virtual void OnControlRemoved(ControlEventArgs e);
protected virtual void OnCreateControl();
protected virtual void OnCursorChanged(EventArgs e);
protected virtual void OnDockChanged(EventArgs e);
protected virtual void OnDoubleClick(EventArgs e);
protected virtual void OnDragDrop(DragEventArgs drgevent);
protected virtual void OnDragEnter(DragEventArgs drgevent);
protected virtual void OnDragLeave(EventArgs e);
protected virtual void OnDragOver(DragEventArgs drgevent);
protected virtual void OnDrawItem(StatusBarDrawItemEventArgs sbdievent);
protected virtual void OnEnabledChanged(EventArgs e);
protected virtual void OnEnter(EventArgs e);
protected virtual void OnFontChanged(EventArgs e);
protected virtual void OnForeColorChanged(EventArgs e);
protected virtual void OnGiveFeedback(GiveFeedbackEventArgs gfbevent);
protected virtual void OnGotFocus(EventArgs e);
protected virtual void OnHandleCreated(EventArgs e);
protected virtual void OnHandleDestroyed(EventArgs e);
protected virtual void OnHelpRequested(HelpEventArgs hevent);
protected virtual void OnImeModeChanged(EventArgs e);
protected virtual void OnInvalidated(InvalidateEventArgs e);
protected virtual void OnKeyDown(KeyEventArgs e);
protected virtual void OnKeyPress(KeyPressEventArgs e);
protected virtual void OnKeyUp(KeyEventArgs e);
protected virtual void OnLayout(LayoutEventArgs levent);
protected virtual void OnLeave(EventArgs e);
protected virtual void OnLocationChanged(EventArgs e);
protected virtual void OnLostFocus(EventArgs e);
protected virtual void OnMouseDown(MouseEventArgs e);
protected virtual void OnMouseEnter(EventArgs e);
protected virtual void OnMouseHover(EventArgs e);
protected virtual void OnMouseLeave(EventArgs e);
protected virtual void OnMouseMove(MouseEventArgs e);
protected virtual void OnMouseUp(MouseEventArgs e);
protected virtual void OnMouseWheel(MouseEventArgs e);
protected virtual void OnMove(EventArgs e);
protected virtual void OnNotifyMessage(Message m);
protected virtual void OnPaint(PaintEventArgs e);
protected virtual void OnPaintBackground(PaintEventArgs e);
protected virtual void OnPanelClick(StatusBarPanelClickEventArgs e);
protected virtual void OnParentBackColorChanged(EventArgs e);
protected virtual void OnParentBackgroundImageChanged(EventArgs e);
protected virtual void OnParentBindingContextChanged(EventArgs e);
protected virtual void OnParentChanged(EventArgs e);
protected virtual void OnParentEnabledChanged(EventArgs e);
protected virtual void OnParentFontChanged(EventArgs e);
protected virtual void OnParentForeColorChanged(EventArgs e);
protected virtual void OnParentRightToLeftChanged(EventArgs e);
protected virtual void OnParentVisibleChanged(EventArgs e);
protected virtual void OnQueryContinueDrag(QueryContinueDragEventArgs qcdevent);
protected virtual void OnResize(EventArgs e);
protected virtual void OnRightToLeftChanged(EventArgs e);
protected virtual void OnSizeChanged(EventArgs e);
protected virtual void OnStyleChanged(EventArgs e);
protected virtual void OnSystemColorsChanged(EventArgs e);
protected virtual void OnTabIndexChanged(EventArgs e);
protected virtual void OnTabStopChanged(EventArgs e);
protected virtual void OnTextChanged(EventArgs e);
protected virtual void OnValidated(EventArgs e);
protected virtual void OnValidating(CancelEventArgs e);
protected virtual void OnVisibleChanged(EventArgs e);
public void PerformLayout();
public void PerformLayout(Control affectedControl, string affectedProperty);
public Point PointToClient(Point p);
public Point PointToScreen(Point p);
public bool PreProcessMessage(ref Message msg);
protected virtual bool ProcessCmdKey(ref Message msg, Keys keyData);
protected virtual bool ProcessDialogChar(char charCode);
protected virtual bool ProcessDialogKey(Keys keyData);
protected virtual bool ProcessKeyEventArgs(ref Message m);
protected virtual bool ProcessKeyPreview(ref Message m);
protected virtual bool ProcessMnemonic(char charCode);
protected void RaiseDragEvent(object key, DragEventArgs e);
protected void RaiseKeyEvent(object key, KeyEventArgs e);
protected void RaiseMouseEvent(object key, MouseEventArgs e);
protected void RaisePaintEvent(object key, PaintEventArgs e);
protected void RecreateHandle();
public Rectangle RectangleToClient(Rectangle r);
public Rectangle RectangleToScreen(Rectangle r);
public virtual void Refresh();
public void remove_BackColorChanged(EventHandler value);
public void remove_BackgroundImageChanged(EventHandler value);
public void remove_BindingContextChanged(EventHandler value);
public void remove_CausesValidationChanged(EventHandler value);
public void remove_ChangeUICues(UICuesEventHandler value);
public void remove_Click(EventHandler value);
public void remove_ContextMenuChanged(EventHandler value);
public void remove_ControlAdded(ControlEventHandler value);
public void remove_ControlRemoved(ControlEventHandler value);
public void remove_CursorChanged(EventHandler value);
public void remove_Disposed(EventHandler value);
public void remove_DockChanged(EventHandler value);
public void remove_DoubleClick(EventHandler value);
public void remove_DragDrop(DragEventHandler value);
public void remove_DragEnter(DragEventHandler value);
public void remove_DragLeave(EventHandler value);
public void remove_DragOver(DragEventHandler value);
public void remove_DrawItem(StatusBarDrawItemEventHandler value);
public void remove_EnabledChanged(EventHandler value);
public void remove_Enter(EventHandler value);
public void remove_FontChanged(EventHandler value);
public void remove_ForeColorChanged(EventHandler value);
public void remove_GiveFeedback(GiveFeedbackEventHandler value);
public void remove_GotFocus(EventHandler value);
public void remove_HandleCreated(EventHandler value);
public void remove_HandleDestroyed(EventHandler value);
public void remove_HelpRequested(HelpEventHandler value);
public void remove_ImeModeChanged(EventHandler value);
public void remove_Invalidated(InvalidateEventHandler value);
public void remove_KeyDown(KeyEventHandler value);
public void remove_KeyPress(KeyPressEventHandler value);
public void remove_KeyUp(KeyEventHandler value);
public void remove_Layout(LayoutEventHandler value);
public void remove_Leave(EventHandler value);
public void remove_LocationChanged(EventHandler value);
public void remove_LostFocus(EventHandler value);
public void remove_MouseDown(MouseEventHandler value);
public void remove_MouseEnter(EventHandler value);
public void remove_MouseHover(EventHandler value);
public void remove_MouseLeave(EventHandler value);
public void remove_MouseMove(MouseEventHandler value);
public void remove_MouseUp(MouseEventHandler value);
public void remove_MouseWheel(MouseEventHandler value);
public void remove_Move(EventHandler value);
public void remove_Paint(PaintEventHandler value);
public void remove_PanelClick(StatusBarPanelClickEventHandler value);
public void remove_ParentChanged(EventHandler value);
public void remove_QueryAccessibilityHelp(QueryAccessibilityHelpEventHandler value);
public void remove_QueryContinueDrag(QueryContinueDragEventHandler value);
public void remove_Resize(EventHandler value);
public void remove_RightToLeftChanged(EventHandler value);
public void remove_SizeChanged(EventHandler value);
public void remove_StyleChanged(EventHandler value);
public void remove_SystemColorsChanged(EventHandler value);
public void remove_TabIndexChanged(EventHandler value);
public void remove_TabStopChanged(EventHandler value);
public void remove_TextChanged(EventHandler value);
public void remove_Validated(EventHandler value);
public void remove_Validating(CancelEventHandler value);
public void remove_VisibleChanged(EventHandler value);
public void ResetBackColor();
public void ResetBindings();
public void ResetCursor();
public void ResetFont();
public void ResetForeColor();
public void ResetImeMode();
protected void ResetMouseEventArgs();
public void ResetRightToLeft();
public void ResetText();
public void ResumeLayout();
public void ResumeLayout(bool performLayout);
protected ContentAlignment RtlTranslateAlignment(ContentAlignment align);
protected HorizontalAlignment RtlTranslateAlignment(HorizontalAlignment align);
protected LeftRightAlignment RtlTranslateAlignment(LeftRightAlignment align);
protected ContentAlignment RtlTranslateContent(ContentAlignment align);
protected HorizontalAlignment RtlTranslateHorizontal(HorizontalAlignment align);
protected LeftRightAlignment RtlTranslateLeftRight(LeftRightAlignment align);
public void Scale(float ratio);
public void Scale(float dx, float dy);
protected virtual void ScaleCore(float dx, float dy);
public void Select();
protected virtual void Select(bool directed, bool forward);
public bool SelectNextControl(Control ctl, bool forward, bool tabStopOnly, bool nested, bool wrap);
public void SendToBack();
public void SetBounds(int x, int y, int width, int height);
public void SetBounds(int x, int y, int width, int height, BoundsSpecified specified);
protected virtual void SetBoundsCore(int x, int y, int width, int height, BoundsSpecified specified);
protected virtual void SetClientSizeCore(int x, int y);
protected void SetStyle(ControlStyles flag, bool value);
protected void SetTopLevel(bool value);
protected virtual void SetVisibleCore(bool value);
public void Show();
public void SuspendLayout();
public virtual string ToString();
public void Update();
protected void UpdateBounds();
protected void UpdateBounds(int x, int y, int width, int height);
protected void UpdateBounds(int x, int y, int width, int height, int clientWidth, int clientHeight);
protected void UpdateStyles();
protected void UpdateZOrder();
protected virtual void WndProc(ref Message m);

Property
public AccessibleObject AccessibilityObject {get;}
public string AccessibleDefaultActionDescription {get; set;}
public string AccessibleDescription {get; set;}
public string AccessibleName {get; set;}
public AccessibleRole AccessibleRole {get; set;}
public bool AllowDrop {get; set;}
public AnchorStyles Anchor {get; set;}
public virtual Color BackColor {get; set;}
public override Image BackgroundImage {get; set;}
public virtual BindingContext BindingContext {get; set;}
public int Bottom {get;}
public Rectangle Bounds {get; set;}
public bool CanFocus {get;}
public bool CanSelect {get;}
public bool Capture {get; set;}
public bool CausesValidation {get; set;}
public Rectangle ClientRectangle {get;}
public Size ClientSize {get; set;}
public string CompanyName {get;}
public IContainer Container {get;}
public bool ContainsFocus {get;}
public ContextMenu ContextMenu {get; set;}
public ControlCollection Controls {get;}
public bool Created {get;}
protected virtual CreateParams CreateParams {get;}
public Cursor Cursor {get; set;}
public ControlBindingsCollection DataBindings {get;}
protected virtual ImeMode DefaultImeMode {get;}
protected virtual Size DefaultSize {get;}
protected bool DesignMode {get;}
public Rectangle DisplayRectangle {get;}
public bool Disposing {get;}
public override DockStyle Dock {get; set;}
public bool Enabled {get; set;}
protected EventHandlerList Events {get;}
public bool Focused {get;}
public virtual Font Font {get; set;}
protected int FontHeight {get; set;}
public virtual Color ForeColor {get; set;}
public IntPtr Handle {get;}
public bool HasChildren {get;}
public int Height {get; set;}
public ImeMode ImeMode {get; set;}
public bool InvokeRequired {get;}
public bool IsAccessible {get; set;}
public bool IsDisposed {get;}
public bool IsHandleCreated {get;}
public int Left {get; set;}
public Point Location {get; set;}
public string Name {get; set;}
public StatusBarPanelCollection Panels {get;}
public Control Parent {get; set;}
public string ProductName {get;}
public string ProductVersion {get;}
public bool RecreatingHandle {get;}
public Region Region {get; set;}
protected bool RenderRightToLeft {get;}
protected bool ResizeRedraw {get; set;}
public int Right {get;}
public RightToLeft RightToLeft {get; set;}
protected virtual bool ShowFocusCues {get;}
protected bool ShowKeyboardCues {get;}
public bool ShowPanels {get; set;}
public ISite Site {get; set;}
public Size Size {get; set;}
public bool SizingGrip {get; set;}
public int TabIndex {get; set;}
public bool TabStop {get; set;}
public object Tag {get; set;}
public virtual string Text {get; set;}
public int Top {get; set;}
public Control TopLevelControl {get;}
public bool Visible {get; set;}
public int Width {get; set;}
public IWindowTarget WindowTarget {get; set;}

System.Windows.Forms.VScrollBar

Module:System.Windows.Forms.dll

Hierarchy
Object
MarshalByRefObject
Component
Control
ScrollBar
VScrollBar

Type declaration

[C#] public class VScrollBar : ScrollBar;

Constructor
public VScrollBar();

Method
protected void AccessibilityNotifyClients(AccessibleEvents accEvent, int childID);
public void add_BackColorChanged(EventHandler value);
public void add_BackgroundImageChanged(EventHandler value);
public void add_BindingContextChanged(EventHandler value);
public void add_CausesValidationChanged(EventHandler value);
public void add_ChangeUICues(UICuesEventHandler value);
public void add_Click(EventHandler value);
public void add_ContextMenuChanged(EventHandler value);
public void add_ControlAdded(ControlEventHandler value);
public void add_ControlRemoved(ControlEventHandler value);
public void add_CursorChanged(EventHandler value);
public void add_Disposed(EventHandler value);
public void add_DockChanged(EventHandler value);
public void add_DoubleClick(EventHandler value);
public void add_DragDrop(DragEventHandler value);
public void add_DragEnter(DragEventHandler value);
public void add_DragLeave(EventHandler value);
public void add_DragOver(DragEventHandler value);
public void add_EnabledChanged(EventHandler value);
public void add_Enter(EventHandler value);
public void add_FontChanged(EventHandler value);
public void add_ForeColorChanged(EventHandler value);
public void add_GiveFeedback(GiveFeedbackEventHandler value);
public void add_GotFocus(EventHandler value);
public void add_HandleCreated(EventHandler value);
public void add_HandleDestroyed(EventHandler value);
public void add_HelpRequested(HelpEventHandler value);
public void add_ImeModeChanged(EventHandler value);
public void add_Invalidated(InvalidateEventHandler value);
public void add_KeyDown(KeyEventHandler value);
public void add_KeyPress(KeyPressEventHandler value);
public void add_KeyUp(KeyEventHandler value);
public void add_Layout(LayoutEventHandler value);
public void add_Leave(EventHandler value);
public void add_LocationChanged(EventHandler value);
public void add_LostFocus(EventHandler value);
public void add_MouseDown(MouseEventHandler value);
public void add_MouseEnter(EventHandler value);
public void add_MouseHover(EventHandler value);
public void add_MouseLeave(EventHandler value);
public void add_MouseMove(MouseEventHandler value);
public void add_MouseUp(MouseEventHandler value);
public void add_MouseWheel(MouseEventHandler value);
public void add_Move(EventHandler value);
public void add_Paint(PaintEventHandler value);
public void add_ParentChanged(EventHandler value);
public void add_QueryAccessibilityHelp(QueryAccessibilityHelpEventHandler value);
public void add_QueryContinueDrag(QueryContinueDragEventHandler value);
public void add_Resize(EventHandler value);
public void add_RightToLeftChanged(EventHandler value);
public void add_Scroll(ScrollEventHandler value);
public void add_SizeChanged(EventHandler value);
public void add_StyleChanged(EventHandler value);
public void add_SystemColorsChanged(EventHandler value);
public void add_TabIndexChanged(EventHandler value);
public void add_TabStopChanged(EventHandler value);
public void add_TextChanged(EventHandler value);
public void add_Validated(EventHandler value);
public void add_Validating(CancelEventHandler value);
public void add_ValueChanged(EventHandler value);
public void add_VisibleChanged(EventHandler value);
public IAsyncResult BeginInvoke(Delegate method);
public IAsyncResult BeginInvoke(Delegate method, object[] args);
public void BringToFront();
public bool Contains(Control ctl);
protected virtual AccessibleObject CreateAccessibilityInstance();
public void CreateControl();
protected virtual ControlCollection CreateControlsInstance();
public Graphics CreateGraphics();
protected virtual void CreateHandle();
public ObjRef CreateObjRef(Type requestedType);
protected virtual void DefWndProc(ref Message m);
protected virtual void DestroyHandle();
public void Dispose();
protected override void Dispose(bool disposing);
public DragDropEffects DoDragDrop(object data, DragDropEffects allowedEffects);
public object EndInvoke(IAsyncResult asyncResult);
public virtual bool Equals(object obj);
protected override void Finalize();
public Form FindForm();
public bool Focus();
public Control GetChildAtPoint(Point pt);
public IContainerControl GetContainerControl();
public virtual int GetHashCode();
public object GetLifetimeService();
public Control GetNextControl(Control ctl, bool forward);
protected virtual object GetService(Type service);
protected bool GetStyle(ControlStyles flag);
protected bool GetTopLevel();
public Type GetType();
public void Hide();
public object InitializeLifetimeService();
protected virtual void InitLayout();
public void Invalidate();
public void Invalidate(bool invalidateChildren);
public void Invalidate(Rectangle rect);
public void Invalidate(Rectangle rc, bool invalidateChildren);
public void Invalidate(Region region);
public void Invalidate(Region region, bool invalidateChildren);
public object Invoke(Delegate method);
public object Invoke(Delegate method, object[] args);
protected void InvokeGotFocus(Control toInvoke, EventArgs e);
protected void InvokeLostFocus(Control toInvoke, EventArgs e);
protected void InvokeOnClick(Control toInvoke, EventArgs e);
protected void InvokePaint(Control c, PaintEventArgs e);
protected void InvokePaintBackground(Control c, PaintEventArgs e);
protected virtual bool IsInputChar(char charCode);
protected virtual bool IsInputKey(Keys keyData);
protected object MemberwiseClone();
protected virtual void NotifyInvalidate(Rectangle invalidatedArea);
protected virtual void OnBackColorChanged(EventArgs e);
protected virtual void OnBackgroundImageChanged(EventArgs e);
protected virtual void OnBindingContextChanged(EventArgs e);
protected virtual void OnCausesValidationChanged(EventArgs e);
protected virtual void OnChangeUICues(UICuesEventArgs e);
protected virtual void OnClick(EventArgs e);
protected virtual void OnContextMenuChanged(EventArgs e);
protected virtual void OnControlAdded(ControlEventArgs e);
protected virtual void OnControlRemoved(ControlEventArgs e);
protected virtual void OnCreateControl();
protected virtual void OnCursorChanged(EventArgs e);
protected virtual void OnDockChanged(EventArgs e);
protected virtual void OnDoubleClick(EventArgs e);
protected virtual void OnDragDrop(DragEventArgs drgevent);
protected virtual void OnDragEnter(DragEventArgs drgevent);
protected virtual void OnDragLeave(EventArgs e);
protected virtual void OnDragOver(DragEventArgs drgevent);
protected virtual void OnEnabledChanged(EventArgs e);
protected virtual void OnEnter(EventArgs e);
protected virtual void OnFontChanged(EventArgs e);
protected virtual void OnForeColorChanged(EventArgs e);
protected virtual void OnGiveFeedback(GiveFeedbackEventArgs gfbevent);
protected virtual void OnGotFocus(EventArgs e);
protected virtual void OnHandleCreated(EventArgs e);
protected virtual void OnHandleDestroyed(EventArgs e);
protected virtual void OnHelpRequested(HelpEventArgs hevent);
protected virtual void OnImeModeChanged(EventArgs e);
protected virtual void OnInvalidated(InvalidateEventArgs e);
protected virtual void OnKeyDown(KeyEventArgs e);
protected virtual void OnKeyPress(KeyPressEventArgs e);
protected virtual void OnKeyUp(KeyEventArgs e);
protected virtual void OnLayout(LayoutEventArgs levent);
protected virtual void OnLeave(EventArgs e);
protected virtual void OnLocationChanged(EventArgs e);
protected virtual void OnLostFocus(EventArgs e);
protected virtual void OnMouseDown(MouseEventArgs e);
protected virtual void OnMouseEnter(EventArgs e);
protected virtual void OnMouseHover(EventArgs e);
protected virtual void OnMouseLeave(EventArgs e);
protected virtual void OnMouseMove(MouseEventArgs e);
protected virtual void OnMouseUp(MouseEventArgs e);
protected virtual void OnMouseWheel(MouseEventArgs e);
protected virtual void OnMove(EventArgs e);
protected virtual void OnNotifyMessage(Message m);
protected virtual void OnPaint(PaintEventArgs e);
protected virtual void OnPaintBackground(PaintEventArgs e);
protected virtual void OnParentBackColorChanged(EventArgs e);
protected virtual void OnParentBackgroundImageChanged(EventArgs e);
protected virtual void OnParentBindingContextChanged(EventArgs e);
protected virtual void OnParentChanged(EventArgs e);
protected virtual void OnParentEnabledChanged(EventArgs e);
protected virtual void OnParentFontChanged(EventArgs e);
protected virtual void OnParentForeColorChanged(EventArgs e);
protected virtual void OnParentRightToLeftChanged(EventArgs e);
protected virtual void OnParentVisibleChanged(EventArgs e);
protected virtual void OnQueryContinueDrag(QueryContinueDragEventArgs qcdevent);
protected virtual void OnResize(EventArgs e);
protected virtual void OnRightToLeftChanged(EventArgs e);
protected virtual void OnScroll(ScrollEventArgs se);
protected virtual void OnSizeChanged(EventArgs e);
protected virtual void OnStyleChanged(EventArgs e);
protected virtual void OnSystemColorsChanged(EventArgs e);
protected virtual void OnTabIndexChanged(EventArgs e);
protected virtual void OnTabStopChanged(EventArgs e);
protected virtual void OnTextChanged(EventArgs e);
protected virtual void OnValidated(EventArgs e);
protected virtual void OnValidating(CancelEventArgs e);
protected virtual void OnValueChanged(EventArgs e);
protected virtual void OnVisibleChanged(EventArgs e);
public void PerformLayout();
public void PerformLayout(Control affectedControl, string affectedProperty);
public Point PointToClient(Point p);
public Point PointToScreen(Point p);
public bool PreProcessMessage(ref Message msg);
protected virtual bool ProcessCmdKey(ref Message msg, Keys keyData);
protected virtual bool ProcessDialogChar(char charCode);
protected virtual bool ProcessDialogKey(Keys keyData);
protected virtual bool ProcessKeyEventArgs(ref Message m);
protected virtual bool ProcessKeyPreview(ref Message m);
protected virtual bool ProcessMnemonic(char charCode);
protected void RaiseDragEvent(object key, DragEventArgs e);
protected void RaiseKeyEvent(object key, KeyEventArgs e);
protected void RaiseMouseEvent(object key, MouseEventArgs e);
protected void RaisePaintEvent(object key, PaintEventArgs e);
protected void RecreateHandle();
public Rectangle RectangleToClient(Rectangle r);
public Rectangle RectangleToScreen(Rectangle r);
public virtual void Refresh();
public void remove_BackColorChanged(EventHandler value);
public void remove_BackgroundImageChanged(EventHandler value);
public void remove_BindingContextChanged(EventHandler value);
public void remove_CausesValidationChanged(EventHandler value);
public void remove_ChangeUICues(UICuesEventHandler value);
public void remove_Click(EventHandler value);
public void remove_ContextMenuChanged(EventHandler value);
public void remove_ControlAdded(ControlEventHandler value);
public void remove_ControlRemoved(ControlEventHandler value);
public void remove_CursorChanged(EventHandler value);
public void remove_Disposed(EventHandler value);
public void remove_DockChanged(EventHandler value);
public void remove_DoubleClick(EventHandler value);
public void remove_DragDrop(DragEventHandler value);
public void remove_DragEnter(DragEventHandler value);
public void remove_DragLeave(EventHandler value);
public void remove_DragOver(DragEventHandler value);
public void remove_EnabledChanged(EventHandler value);
public void remove_Enter(EventHandler value);
public void remove_FontChanged(EventHandler value);
public void remove_ForeColorChanged(EventHandler value);
public void remove_GiveFeedback(GiveFeedbackEventHandler value);
public void remove_GotFocus(EventHandler value);
public void remove_HandleCreated(EventHandler value);
public void remove_HandleDestroyed(EventHandler value);
public void remove_HelpRequested(HelpEventHandler value);
public void remove_ImeModeChanged(EventHandler value);
public void remove_Invalidated(InvalidateEventHandler value);
public void remove_KeyDown(KeyEventHandler value);
public void remove_KeyPress(KeyPressEventHandler value);
public void remove_KeyUp(KeyEventHandler value);
public void remove_Layout(LayoutEventHandler value);
public void remove_Leave(EventHandler value);
public void remove_LocationChanged(EventHandler value);
public void remove_LostFocus(EventHandler value);
public void remove_MouseDown(MouseEventHandler value);
public void remove_MouseEnter(EventHandler value);
public void remove_MouseHover(EventHandler value);
public void remove_MouseLeave(EventHandler value);
public void remove_MouseMove(MouseEventHandler value);
public void remove_MouseUp(MouseEventHandler value);
public void remove_MouseWheel(MouseEventHandler value);
public void remove_Move(EventHandler value);
public void remove_Paint(PaintEventHandler value);
public void remove_ParentChanged(EventHandler value);
public void remove_QueryAccessibilityHelp(QueryAccessibilityHelpEventHandler value);
public void remove_QueryContinueDrag(QueryContinueDragEventHandler value);
public void remove_Resize(EventHandler value);
public void remove_RightToLeftChanged(EventHandler value);
public void remove_Scroll(ScrollEventHandler value);
public void remove_SizeChanged(EventHandler value);
public void remove_StyleChanged(EventHandler value);
public void remove_SystemColorsChanged(EventHandler value);
public void remove_TabIndexChanged(EventHandler value);
public void remove_TabStopChanged(EventHandler value);
public void remove_TextChanged(EventHandler value);
public void remove_Validated(EventHandler value);
public void remove_Validating(CancelEventHandler value);
public void remove_ValueChanged(EventHandler value);
public void remove_VisibleChanged(EventHandler value);
public void ResetBackColor();
public void ResetBindings();
public void ResetCursor();
public void ResetFont();
public void ResetForeColor();
public void ResetImeMode();
protected void ResetMouseEventArgs();
public void ResetRightToLeft();
public void ResetText();
public void ResumeLayout();
public void ResumeLayout(bool performLayout);
protected ContentAlignment RtlTranslateAlignment(ContentAlignment align);
protected HorizontalAlignment RtlTranslateAlignment(HorizontalAlignment align);
protected LeftRightAlignment RtlTranslateAlignment(LeftRightAlignment align);
protected ContentAlignment RtlTranslateContent(ContentAlignment align);
protected HorizontalAlignment RtlTranslateHorizontal(HorizontalAlignment align);
protected LeftRightAlignment RtlTranslateLeftRight(LeftRightAlignment align);
public void Scale(float ratio);
public void Scale(float dx, float dy);
protected virtual void ScaleCore(float dx, float dy);
public void Select();
protected virtual void Select(bool directed, bool forward);
public bool SelectNextControl(Control ctl, bool forward, bool tabStopOnly, bool nested, bool wrap);
public void SendToBack();
public void SetBounds(int x, int y, int width, int height);
public void SetBounds(int x, int y, int width, int height, BoundsSpecified specified);
protected virtual void SetBoundsCore(int x, int y, int width, int height, BoundsSpecified specified);
protected virtual void SetClientSizeCore(int x, int y);
protected void SetStyle(ControlStyles flag, bool value);
protected void SetTopLevel(bool value);
protected virtual void SetVisibleCore(bool value);
public void Show();
public void SuspendLayout();
public virtual string ToString();
public void Update();
protected void UpdateBounds();
protected void UpdateBounds(int x, int y, int width, int height);
protected void UpdateBounds(int x, int y, int width, int height, int clientWidth, int clientHeight);
protected void UpdateScrollInfo();
protected void UpdateStyles();
protected void UpdateZOrder();
protected virtual void WndProc(ref Message m);

Property
public AccessibleObject AccessibilityObject {get;}
public string AccessibleDefaultActionDescription {get; set;}
public string AccessibleDescription {get; set;}
public string AccessibleName {get; set;}
public AccessibleRole AccessibleRole {get; set;}
public bool AllowDrop {get; set;}
public AnchorStyles Anchor {get; set;}
public virtual Color BackColor {get; set;}
public Image BackgroundImage {get; set;}
public virtual BindingContext BindingContext {get; set;}
public int Bottom {get;}
public Rectangle Bounds {get; set;}
public bool CanFocus {get;}
public bool CanSelect {get;}
public bool Capture {get; set;}
public bool CausesValidation {get; set;}
public Rectangle ClientRectangle {get;}
public Size ClientSize {get; set;}
public string CompanyName {get;}
public IContainer Container {get;}
public bool ContainsFocus {get;}
public ContextMenu ContextMenu {get; set;}
public ControlCollection Controls {get;}
public bool Created {get;}
protected virtual CreateParams CreateParams {get;}
public Cursor Cursor {get; set;}
public ControlBindingsCollection DataBindings {get;}
protected virtual ImeMode DefaultImeMode {get;}
protected virtual Size DefaultSize {get;}
protected bool DesignMode {get;}
public Rectangle DisplayRectangle {get;}
public bool Disposing {get;}
public DockStyle Dock {get; set;}
public bool Enabled {get; set;}
protected EventHandlerList Events {get;}
public bool Focused {get;}
public virtual Font Font {get; set;}
protected int FontHeight {get; set;}
public virtual Color ForeColor {get; set;}
public IntPtr Handle {get;}
public bool HasChildren {get;}
public int Height {get; set;}
public ImeMode ImeMode {get; set;}
public bool InvokeRequired {get;}
public bool IsAccessible {get; set;}
public bool IsDisposed {get;}
public bool IsHandleCreated {get;}
public int LargeChange {get; set;}
public int Left {get; set;}
public Point Location {get; set;}
public int Maximum {get; set;}
public int Minimum {get; set;}
public string Name {get; set;}
public Control Parent {get; set;}
public string ProductName {get;}
public string ProductVersion {get;}
public bool RecreatingHandle {get;}
public Region Region {get; set;}
protected bool RenderRightToLeft {get;}
protected bool ResizeRedraw {get; set;}
public int Right {get;}
public override RightToLeft RightToLeft {get; set;}
protected virtual bool ShowFocusCues {get;}
protected bool ShowKeyboardCues {get;}
public ISite Site {get; set;}
public Size Size {get; set;}
public int SmallChange {get; set;}
public int TabIndex {get; set;}
public bool TabStop {get; set;}
public object Tag {get; set;}
public virtual string Text {get; set;}
public int Top {get; set;}
public Control TopLevelControl {get;}
public int Value {get; set;}
public bool Visible {get; set;}
public int Width {get; set;}
public IWindowTarget WindowTarget {get; set;}

System.Windows.Forms.HScrollBar

Module:System.Windows.Forms.dll

Hierarchy
Object
MarshalByRefObject
Component
Control
ScrollBar
HScrollBar

Type declaration

[C#] public class HScrollBar : ScrollBar;

Constructor
public HScrollBar();

Method
protected void AccessibilityNotifyClients(AccessibleEvents accEvent, int childID);
public void add_BackColorChanged(EventHandler value);
public void add_BackgroundImageChanged(EventHandler value);
public void add_BindingContextChanged(EventHandler value);
public void add_CausesValidationChanged(EventHandler value);
public void add_ChangeUICues(UICuesEventHandler value);
public void add_Click(EventHandler value);
public void add_ContextMenuChanged(EventHandler value);
public void add_ControlAdded(ControlEventHandler value);
public void add_ControlRemoved(ControlEventHandler value);
public void add_CursorChanged(EventHandler value);
public void add_Disposed(EventHandler value);
public void add_DockChanged(EventHandler value);
public void add_DoubleClick(EventHandler value);
public void add_DragDrop(DragEventHandler value);
public void add_DragEnter(DragEventHandler value);
public void add_DragLeave(EventHandler value);
public void add_DragOver(DragEventHandler value);
public void add_EnabledChanged(EventHandler value);
public void add_Enter(EventHandler value);
public void add_FontChanged(EventHandler value);
public void add_ForeColorChanged(EventHandler value);
public void add_GiveFeedback(GiveFeedbackEventHandler value);
public void add_GotFocus(EventHandler value);
public void add_HandleCreated(EventHandler value);
public void add_HandleDestroyed(EventHandler value);
public void add_HelpRequested(HelpEventHandler value);
public void add_ImeModeChanged(EventHandler value);
public void add_Invalidated(InvalidateEventHandler value);
public void add_KeyDown(KeyEventHandler value);
public void add_KeyPress(KeyPressEventHandler value);
public void add_KeyUp(KeyEventHandler value);
public void add_Layout(LayoutEventHandler value);
public void add_Leave(EventHandler value);
public void add_LocationChanged(EventHandler value);
public void add_LostFocus(EventHandler value);
public void add_MouseDown(MouseEventHandler value);
public void add_MouseEnter(EventHandler value);
public void add_MouseHover(EventHandler value);
public void add_MouseLeave(EventHandler value);
public void add_MouseMove(MouseEventHandler value);
public void add_MouseUp(MouseEventHandler value);
public void add_MouseWheel(MouseEventHandler value);
public void add_Move(EventHandler value);
public void add_Paint(PaintEventHandler value);
public void add_ParentChanged(EventHandler value);
public void add_QueryAccessibilityHelp(QueryAccessibilityHelpEventHandler value);
public void add_QueryContinueDrag(QueryContinueDragEventHandler value);
public void add_Resize(EventHandler value);
public void add_RightToLeftChanged(EventHandler value);
public void add_Scroll(ScrollEventHandler value);
public void add_SizeChanged(EventHandler value);
public void add_StyleChanged(EventHandler value);
public void add_SystemColorsChanged(EventHandler value);
public void add_TabIndexChanged(EventHandler value);
public void add_TabStopChanged(EventHandler value);
public void add_TextChanged(EventHandler value);
public void add_Validated(EventHandler value);
public void add_Validating(CancelEventHandler value);
public void add_ValueChanged(EventHandler value);
public void add_VisibleChanged(EventHandler value);
public IAsyncResult BeginInvoke(Delegate method);
public IAsyncResult BeginInvoke(Delegate method, object[] args);
public void BringToFront();
public bool Contains(Control ctl);
protected virtual AccessibleObject CreateAccessibilityInstance();
public void CreateControl();
protected virtual ControlCollection CreateControlsInstance();
public Graphics CreateGraphics();
protected virtual void CreateHandle();
public ObjRef CreateObjRef(Type requestedType);
protected virtual void DefWndProc(ref Message m);
protected virtual void DestroyHandle();
public void Dispose();
protected override void Dispose(bool disposing);
public DragDropEffects DoDragDrop(object data, DragDropEffects allowedEffects);
public object EndInvoke(IAsyncResult asyncResult);
public virtual bool Equals(object obj);
protected override void Finalize();
public Form FindForm();
public bool Focus();
public Control GetChildAtPoint(Point pt);
public IContainerControl GetContainerControl();
public virtual int GetHashCode();
public object GetLifetimeService();
public Control GetNextControl(Control ctl, bool forward);
protected virtual object GetService(Type service);
protected bool GetStyle(ControlStyles flag);
protected bool GetTopLevel();
public Type GetType();
public void Hide();
public object InitializeLifetimeService();
protected virtual void InitLayout();
public void Invalidate();
public void Invalidate(bool invalidateChildren);
public void Invalidate(Rectangle rect);
public void Invalidate(Rectangle rc, bool invalidateChildren);
public void Invalidate(Region region);
public void Invalidate(Region region, bool invalidateChildren);
public object Invoke(Delegate method);
public object Invoke(Delegate method, object[] args);
protected void InvokeGotFocus(Control toInvoke, EventArgs e);
protected void InvokeLostFocus(Control toInvoke, EventArgs e);
protected void InvokeOnClick(Control toInvoke, EventArgs e);
protected void InvokePaint(Control c, PaintEventArgs e);
protected void InvokePaintBackground(Control c, PaintEventArgs e);
protected virtual bool IsInputChar(char charCode);
protected virtual bool IsInputKey(Keys keyData);
protected object MemberwiseClone();
protected virtual void NotifyInvalidate(Rectangle invalidatedArea);
protected virtual void OnBackColorChanged(EventArgs e);
protected virtual void OnBackgroundImageChanged(EventArgs e);
protected virtual void OnBindingContextChanged(EventArgs e);
protected virtual void OnCausesValidationChanged(EventArgs e);
protected virtual void OnChangeUICues(UICuesEventArgs e);
protected virtual void OnClick(EventArgs e);
protected virtual void OnContextMenuChanged(EventArgs e);
protected virtual void OnControlAdded(ControlEventArgs e);
protected virtual void OnControlRemoved(ControlEventArgs e);
protected virtual void OnCreateControl();
protected virtual void OnCursorChanged(EventArgs e);
protected virtual void OnDockChanged(EventArgs e);
protected virtual void OnDoubleClick(EventArgs e);
protected virtual void OnDragDrop(DragEventArgs drgevent);
protected virtual void OnDragEnter(DragEventArgs drgevent);
protected virtual void OnDragLeave(EventArgs e);
protected virtual void OnDragOver(DragEventArgs drgevent);
protected virtual void OnEnabledChanged(EventArgs e);
protected virtual void OnEnter(EventArgs e);
protected virtual void OnFontChanged(EventArgs e);
protected virtual void OnForeColorChanged(EventArgs e);
protected virtual void OnGiveFeedback(GiveFeedbackEventArgs gfbevent);
protected virtual void OnGotFocus(EventArgs e);
protected virtual void OnHandleCreated(EventArgs e);
protected virtual void OnHandleDestroyed(EventArgs e);
protected virtual void OnHelpRequested(HelpEventArgs hevent);
protected virtual void OnImeModeChanged(EventArgs e);
protected virtual void OnInvalidated(InvalidateEventArgs e);
protected virtual void OnKeyDown(KeyEventArgs e);
protected virtual void OnKeyPress(KeyPressEventArgs e);
protected virtual void OnKeyUp(KeyEventArgs e);
protected virtual void OnLayout(LayoutEventArgs levent);
protected virtual void OnLeave(EventArgs e);
protected virtual void OnLocationChanged(EventArgs e);
protected virtual void OnLostFocus(EventArgs e);
protected virtual void OnMouseDown(MouseEventArgs e);
protected virtual void OnMouseEnter(EventArgs e);
protected virtual void OnMouseHover(EventArgs e);
protected virtual void OnMouseLeave(EventArgs e);
protected virtual void OnMouseMove(MouseEventArgs e);
protected virtual void OnMouseUp(MouseEventArgs e);
protected virtual void OnMouseWheel(MouseEventArgs e);
protected virtual void OnMove(EventArgs e);
protected virtual void OnNotifyMessage(Message m);
protected virtual void OnPaint(PaintEventArgs e);
protected virtual void OnPaintBackground(PaintEventArgs e);
protected virtual void OnParentBackColorChanged(EventArgs e);
protected virtual void OnParentBackgroundImageChanged(EventArgs e);
protected virtual void OnParentBindingContextChanged(EventArgs e);
protected virtual void OnParentChanged(EventArgs e);
protected virtual void OnParentEnabledChanged(EventArgs e);
protected virtual void OnParentFontChanged(EventArgs e);
protected virtual void OnParentForeColorChanged(EventArgs e);
protected virtual void OnParentRightToLeftChanged(EventArgs e);
protected virtual void OnParentVisibleChanged(EventArgs e);
protected virtual void OnQueryContinueDrag(QueryContinueDragEventArgs qcdevent);
protected virtual void OnResize(EventArgs e);
protected virtual void OnRightToLeftChanged(EventArgs e);
protected virtual void OnScroll(ScrollEventArgs se);
protected virtual void OnSizeChanged(EventArgs e);
protected virtual void OnStyleChanged(EventArgs e);
protected virtual void OnSystemColorsChanged(EventArgs e);
protected virtual void OnTabIndexChanged(EventArgs e);
protected virtual void OnTabStopChanged(EventArgs e);
protected virtual void OnTextChanged(EventArgs e);
protected virtual void OnValidated(EventArgs e);
protected virtual void OnValidating(CancelEventArgs e);
protected virtual void OnValueChanged(EventArgs e);
protected virtual void OnVisibleChanged(EventArgs e);
public void PerformLayout();
public void PerformLayout(Control affectedControl, string affectedProperty);
public Point PointToClient(Point p);
public Point PointToScreen(Point p);
public bool PreProcessMessage(ref Message msg);
protected virtual bool ProcessCmdKey(ref Message msg, Keys keyData);
protected virtual bool ProcessDialogChar(char charCode);
protected virtual bool ProcessDialogKey(Keys keyData);
protected virtual bool ProcessKeyEventArgs(ref Message m);
protected virtual bool ProcessKeyPreview(ref Message m);
protected virtual bool ProcessMnemonic(char charCode);
protected void RaiseDragEvent(object key, DragEventArgs e);
protected void RaiseKeyEvent(object key, KeyEventArgs e);
protected void RaiseMouseEvent(object key, MouseEventArgs e);
protected void RaisePaintEvent(object key, PaintEventArgs e);
protected void RecreateHandle();
public Rectangle RectangleToClient(Rectangle r);
public Rectangle RectangleToScreen(Rectangle r);
public virtual void Refresh();
public void remove_BackColorChanged(EventHandler value);
public void remove_BackgroundImageChanged(EventHandler value);
public void remove_BindingContextChanged(EventHandler value);
public void remove_CausesValidationChanged(EventHandler value);
public void remove_ChangeUICues(UICuesEventHandler value);
public void remove_Click(EventHandler value);
public void remove_ContextMenuChanged(EventHandler value);
public void remove_ControlAdded(ControlEventHandler value);
public void remove_ControlRemoved(ControlEventHandler value);
public void remove_CursorChanged(EventHandler value);
public void remove_Disposed(EventHandler value);
public void remove_DockChanged(EventHandler value);
public void remove_DoubleClick(EventHandler value);
public void remove_DragDrop(DragEventHandler value);
public void remove_DragEnter(DragEventHandler value);
public void remove_DragLeave(EventHandler value);
public void remove_DragOver(DragEventHandler value);
public void remove_EnabledChanged(EventHandler value);
public void remove_Enter(EventHandler value);
public void remove_FontChanged(EventHandler value);
public void remove_ForeColorChanged(EventHandler value);
public void remove_GiveFeedback(GiveFeedbackEventHandler value);
public void remove_GotFocus(EventHandler value);
public void remove_HandleCreated(EventHandler value);
public void remove_HandleDestroyed(EventHandler value);
public void remove_HelpRequested(HelpEventHandler value);
public void remove_ImeModeChanged(EventHandler value);
public void remove_Invalidated(InvalidateEventHandler value);
public void remove_KeyDown(KeyEventHandler value);
public void remove_KeyPress(KeyPressEventHandler value);
public void remove_KeyUp(KeyEventHandler value);
public void remove_Layout(LayoutEventHandler value);
public void remove_Leave(EventHandler value);
public void remove_LocationChanged(EventHandler value);
public void remove_LostFocus(EventHandler value);
public void remove_MouseDown(MouseEventHandler value);
public void remove_MouseEnter(EventHandler value);
public void remove_MouseHover(EventHandler value);
public void remove_MouseLeave(EventHandler value);
public void remove_MouseMove(MouseEventHandler value);
public void remove_MouseUp(MouseEventHandler value);
public void remove_MouseWheel(MouseEventHandler value);
public void remove_Move(EventHandler value);
public void remove_Paint(PaintEventHandler value);
public void remove_ParentChanged(EventHandler value);
public void remove_QueryAccessibilityHelp(QueryAccessibilityHelpEventHandler value);
public void remove_QueryContinueDrag(QueryContinueDragEventHandler value);
public void remove_Resize(EventHandler value);
public void remove_RightToLeftChanged(EventHandler value);
public void remove_Scroll(ScrollEventHandler value);
public void remove_SizeChanged(EventHandler value);
public void remove_StyleChanged(EventHandler value);
public void remove_SystemColorsChanged(EventHandler value);
public void remove_TabIndexChanged(EventHandler value);
public void remove_TabStopChanged(EventHandler value);
public void remove_TextChanged(EventHandler value);
public void remove_Validated(EventHandler value);
public void remove_Validating(CancelEventHandler value);
public void remove_ValueChanged(EventHandler value);
public void remove_VisibleChanged(EventHandler value);
public void ResetBackColor();
public void ResetBindings();
public void ResetCursor();
public void ResetFont();
public void ResetForeColor();
public void ResetImeMode();
protected void ResetMouseEventArgs();
public void ResetRightToLeft();
public void ResetText();
public void ResumeLayout();
public void ResumeLayout(bool performLayout);
protected ContentAlignment RtlTranslateAlignment(ContentAlignment align);
protected HorizontalAlignment RtlTranslateAlignment(HorizontalAlignment align);
protected LeftRightAlignment RtlTranslateAlignment(LeftRightAlignment align);
protected ContentAlignment RtlTranslateContent(ContentAlignment align);
protected HorizontalAlignment RtlTranslateHorizontal(HorizontalAlignment align);
protected LeftRightAlignment RtlTranslateLeftRight(LeftRightAlignment align);
public void Scale(float ratio);
public void Scale(float dx, float dy);
protected virtual void ScaleCore(float dx, float dy);
public void Select();
protected virtual void Select(bool directed, bool forward);
public bool SelectNextControl(Control ctl, bool forward, bool tabStopOnly, bool nested, bool wrap);
public void SendToBack();
public void SetBounds(int x, int y, int width, int height);
public void SetBounds(int x, int y, int width, int height, BoundsSpecified specified);
protected virtual void SetBoundsCore(int x, int y, int width, int height, BoundsSpecified specified);
protected virtual void SetClientSizeCore(int x, int y);
protected void SetStyle(ControlStyles flag, bool value);
protected void SetTopLevel(bool value);
protected virtual void SetVisibleCore(bool value);
public void Show();
public void SuspendLayout();
public virtual string ToString();
public void Update();
protected void UpdateBounds();
protected void UpdateBounds(int x, int y, int width, int height);
protected void UpdateBounds(int x, int y, int width, int height, int clientWidth, int clientHeight);
protected void UpdateScrollInfo();
protected void UpdateStyles();
protected void UpdateZOrder();
protected virtual void WndProc(ref Message m);

Property
public AccessibleObject AccessibilityObject {get;}
public string AccessibleDefaultActionDescription {get; set;}
public string AccessibleDescription {get; set;}
public string AccessibleName {get; set;}
public AccessibleRole AccessibleRole {get; set;}
public bool AllowDrop {get; set;}
public AnchorStyles Anchor {get; set;}
public virtual Color BackColor {get; set;}
public Image BackgroundImage {get; set;}
public virtual BindingContext BindingContext {get; set;}
public int Bottom {get;}
public Rectangle Bounds {get; set;}
public bool CanFocus {get;}
public bool CanSelect {get;}
public bool Capture {get; set;}
public bool CausesValidation {get; set;}
public Rectangle ClientRectangle {get;}
public Size ClientSize {get; set;}
public string CompanyName {get;}
public IContainer Container {get;}
public bool ContainsFocus {get;}
public ContextMenu ContextMenu {get; set;}
public ControlCollection Controls {get;}
public bool Created {get;}
protected virtual CreateParams CreateParams {get;}
public Cursor Cursor {get; set;}
public ControlBindingsCollection DataBindings {get;}
protected virtual ImeMode DefaultImeMode {get;}
protected virtual Size DefaultSize {get;}
protected bool DesignMode {get;}
public Rectangle DisplayRectangle {get;}
public bool Disposing {get;}
public DockStyle Dock {get; set;}
public bool Enabled {get; set;}
protected EventHandlerList Events {get;}
public bool Focused {get;}
public virtual Font Font {get; set;}
protected int FontHeight {get; set;}
public virtual Color ForeColor {get; set;}
public IntPtr Handle {get;}
public bool HasChildren {get;}
public int Height {get; set;}
public ImeMode ImeMode {get; set;}
public bool InvokeRequired {get;}
public bool IsAccessible {get; set;}
public bool IsDisposed {get;}
public bool IsHandleCreated {get;}
public int LargeChange {get; set;}
public int Left {get; set;}
public Point Location {get; set;}
public int Maximum {get; set;}
public int Minimum {get; set;}
public string Name {get; set;}
public Control Parent {get; set;}
public string ProductName {get;}
public string ProductVersion {get;}
public bool RecreatingHandle {get;}
public Region Region {get; set;}
protected bool RenderRightToLeft {get;}
protected bool ResizeRedraw {get; set;}
public int Right {get;}
public RightToLeft RightToLeft {get; set;}
protected virtual bool ShowFocusCues {get;}
protected bool ShowKeyboardCues {get;}
public ISite Site {get; set;}
public Size Size {get; set;}
public int SmallChange {get; set;}
public int TabIndex {get; set;}
public bool TabStop {get; set;}
public object Tag {get; set;}
public virtual string Text {get; set;}
public int Top {get; set;}
public Control TopLevelControl {get;}
public int Value {get; set;}
public bool Visible {get; set;}
public int Width {get; set;}
public IWindowTarget WindowTarget {get; set;}

System.Windows.Forms.ScrollBar

Module:System.Windows.Forms.dll

Hierarchy
Object
MarshalByRefObject
Component
Control
ScrollBar

Type declaration

[C#] public abstract class ScrollBar : Control;

Constructor
public ScrollBar();

Method
protected void AccessibilityNotifyClients(AccessibleEvents accEvent, int childID);
public void add_BackColorChanged(EventHandler value);
public void add_BackgroundImageChanged(EventHandler value);
public void add_BindingContextChanged(EventHandler value);
public void add_CausesValidationChanged(EventHandler value);
public void add_ChangeUICues(UICuesEventHandler value);
public void add_Click(EventHandler value);
public void add_ContextMenuChanged(EventHandler value);
public void add_ControlAdded(ControlEventHandler value);
public void add_ControlRemoved(ControlEventHandler value);
public void add_CursorChanged(EventHandler value);
public void add_Disposed(EventHandler value);
public void add_DockChanged(EventHandler value);
public void add_DoubleClick(EventHandler value);
public void add_DragDrop(DragEventHandler value);
public void add_DragEnter(DragEventHandler value);
public void add_DragLeave(EventHandler value);
public void add_DragOver(DragEventHandler value);
public void add_EnabledChanged(EventHandler value);
public void add_Enter(EventHandler value);
public void add_FontChanged(EventHandler value);
public void add_ForeColorChanged(EventHandler value);
public void add_GiveFeedback(GiveFeedbackEventHandler value);
public void add_GotFocus(EventHandler value);
public void add_HandleCreated(EventHandler value);
public void add_HandleDestroyed(EventHandler value);
public void add_HelpRequested(HelpEventHandler value);
public void add_ImeModeChanged(EventHandler value);
public void add_Invalidated(InvalidateEventHandler value);
public void add_KeyDown(KeyEventHandler value);
public void add_KeyPress(KeyPressEventHandler value);
public void add_KeyUp(KeyEventHandler value);
public void add_Layout(LayoutEventHandler value);
public void add_Leave(EventHandler value);
public void add_LocationChanged(EventHandler value);
public void add_LostFocus(EventHandler value);
public void add_MouseDown(MouseEventHandler value);
public void add_MouseEnter(EventHandler value);
public void add_MouseHover(EventHandler value);
public void add_MouseLeave(EventHandler value);
public void add_MouseMove(MouseEventHandler value);
public void add_MouseUp(MouseEventHandler value);
public void add_MouseWheel(MouseEventHandler value);
public void add_Move(EventHandler value);
public void add_Paint(PaintEventHandler value);
public void add_ParentChanged(EventHandler value);
public void add_QueryAccessibilityHelp(QueryAccessibilityHelpEventHandler value);
public void add_QueryContinueDrag(QueryContinueDragEventHandler value);
public void add_Resize(EventHandler value);
public void add_RightToLeftChanged(EventHandler value);
public void add_Scroll(ScrollEventHandler value);
public void add_SizeChanged(EventHandler value);
public void add_StyleChanged(EventHandler value);
public void add_SystemColorsChanged(EventHandler value);
public void add_TabIndexChanged(EventHandler value);
public void add_TabStopChanged(EventHandler value);
public void add_TextChanged(EventHandler value);
public void add_Validated(EventHandler value);
public void add_Validating(CancelEventHandler value);
public void add_ValueChanged(EventHandler value);
public void add_VisibleChanged(EventHandler value);
public IAsyncResult BeginInvoke(Delegate method);
public IAsyncResult BeginInvoke(Delegate method, object[] args);
public void BringToFront();
public bool Contains(Control ctl);
protected virtual AccessibleObject CreateAccessibilityInstance();
public void CreateControl();
protected virtual ControlCollection CreateControlsInstance();
public Graphics CreateGraphics();
protected virtual void CreateHandle();
public ObjRef CreateObjRef(Type requestedType);
protected virtual void DefWndProc(ref Message m);
protected virtual void DestroyHandle();
public void Dispose();
protected override void Dispose(bool disposing);
public DragDropEffects DoDragDrop(object data, DragDropEffects allowedEffects);
public object EndInvoke(IAsyncResult asyncResult);
public virtual bool Equals(object obj);
protected override void Finalize();
public Form FindForm();
public bool Focus();
public Control GetChildAtPoint(Point pt);
public IContainerControl GetContainerControl();
public virtual int GetHashCode();
public object GetLifetimeService();
public Control GetNextControl(Control ctl, bool forward);
protected virtual object GetService(Type service);
protected bool GetStyle(ControlStyles flag);
protected bool GetTopLevel();
public Type GetType();
public void Hide();
public object InitializeLifetimeService();
protected virtual void InitLayout();
public void Invalidate();
public void Invalidate(bool invalidateChildren);
public void Invalidate(Rectangle rect);
public void Invalidate(Rectangle rc, bool invalidateChildren);
public void Invalidate(Region region);
public void Invalidate(Region region, bool invalidateChildren);
public object Invoke(Delegate method);
public object Invoke(Delegate method, object[] args);
protected void InvokeGotFocus(Control toInvoke, EventArgs e);
protected void InvokeLostFocus(Control toInvoke, EventArgs e);
protected void InvokeOnClick(Control toInvoke, EventArgs e);
protected void InvokePaint(Control c, PaintEventArgs e);
protected void InvokePaintBackground(Control c, PaintEventArgs e);
protected virtual bool IsInputChar(char charCode);
protected virtual bool IsInputKey(Keys keyData);
protected object MemberwiseClone();
protected virtual void NotifyInvalidate(Rectangle invalidatedArea);
protected virtual void OnBackColorChanged(EventArgs e);
protected virtual void OnBackgroundImageChanged(EventArgs e);
protected virtual void OnBindingContextChanged(EventArgs e);
protected virtual void OnCausesValidationChanged(EventArgs e);
protected virtual void OnChangeUICues(UICuesEventArgs e);
protected virtual void OnClick(EventArgs e);
protected virtual void OnContextMenuChanged(EventArgs e);
protected virtual void OnControlAdded(ControlEventArgs e);
protected virtual void OnControlRemoved(ControlEventArgs e);
protected virtual void OnCreateControl();
protected virtual void OnCursorChanged(EventArgs e);
protected virtual void OnDockChanged(EventArgs e);
protected virtual void OnDoubleClick(EventArgs e);
protected virtual void OnDragDrop(DragEventArgs drgevent);
protected virtual void OnDragEnter(DragEventArgs drgevent);
protected virtual void OnDragLeave(EventArgs e);
protected virtual void OnDragOver(DragEventArgs drgevent);
protected virtual void OnEnabledChanged(EventArgs e);
protected virtual void OnEnter(EventArgs e);
protected virtual void OnFontChanged(EventArgs e);
protected virtual void OnForeColorChanged(EventArgs e);
protected virtual void OnGiveFeedback(GiveFeedbackEventArgs gfbevent);
protected virtual void OnGotFocus(EventArgs e);
protected virtual void OnHandleCreated(EventArgs e);
protected virtual void OnHandleDestroyed(EventArgs e);
protected virtual void OnHelpRequested(HelpEventArgs hevent);
protected virtual void OnImeModeChanged(EventArgs e);
protected virtual void OnInvalidated(InvalidateEventArgs e);
protected virtual void OnKeyDown(KeyEventArgs e);
protected virtual void OnKeyPress(KeyPressEventArgs e);
protected virtual void OnKeyUp(KeyEventArgs e);
protected virtual void OnLayout(LayoutEventArgs levent);
protected virtual void OnLeave(EventArgs e);
protected virtual void OnLocationChanged(EventArgs e);
protected virtual void OnLostFocus(EventArgs e);
protected virtual void OnMouseDown(MouseEventArgs e);
protected virtual void OnMouseEnter(EventArgs e);
protected virtual void OnMouseHover(EventArgs e);
protected virtual void OnMouseLeave(EventArgs e);
protected virtual void OnMouseMove(MouseEventArgs e);
protected virtual void OnMouseUp(MouseEventArgs e);
protected virtual void OnMouseWheel(MouseEventArgs e);
protected virtual void OnMove(EventArgs e);
protected virtual void OnNotifyMessage(Message m);
protected virtual void OnPaint(PaintEventArgs e);
protected virtual void OnPaintBackground(PaintEventArgs e);
protected virtual void OnParentBackColorChanged(EventArgs e);
protected virtual void OnParentBackgroundImageChanged(EventArgs e);
protected virtual void OnParentBindingContextChanged(EventArgs e);
protected virtual void OnParentChanged(EventArgs e);
protected virtual void OnParentEnabledChanged(EventArgs e);
protected virtual void OnParentFontChanged(EventArgs e);
protected virtual void OnParentForeColorChanged(EventArgs e);
protected virtual void OnParentRightToLeftChanged(EventArgs e);
protected virtual void OnParentVisibleChanged(EventArgs e);
protected virtual void OnQueryContinueDrag(QueryContinueDragEventArgs qcdevent);
protected virtual void OnResize(EventArgs e);
protected virtual void OnRightToLeftChanged(EventArgs e);
protected virtual void OnScroll(ScrollEventArgs se);
protected virtual void OnSizeChanged(EventArgs e);
protected virtual void OnStyleChanged(EventArgs e);
protected virtual void OnSystemColorsChanged(EventArgs e);
protected virtual void OnTabIndexChanged(EventArgs e);
protected virtual void OnTabStopChanged(EventArgs e);
protected virtual void OnTextChanged(EventArgs e);
protected virtual void OnValidated(EventArgs e);
protected virtual void OnValidating(CancelEventArgs e);
protected virtual void OnValueChanged(EventArgs e);
protected virtual void OnVisibleChanged(EventArgs e);
public void PerformLayout();
public void PerformLayout(Control affectedControl, string affectedProperty);
public Point PointToClient(Point p);
public Point PointToScreen(Point p);
public bool PreProcessMessage(ref Message msg);
protected virtual bool ProcessCmdKey(ref Message msg, Keys keyData);
protected virtual bool ProcessDialogChar(char charCode);
protected virtual bool ProcessDialogKey(Keys keyData);
protected virtual bool ProcessKeyEventArgs(ref Message m);
protected virtual bool ProcessKeyPreview(ref Message m);
protected virtual bool ProcessMnemonic(char charCode);
protected void RaiseDragEvent(object key, DragEventArgs e);
protected void RaiseKeyEvent(object key, KeyEventArgs e);
protected void RaiseMouseEvent(object key, MouseEventArgs e);
protected void RaisePaintEvent(object key, PaintEventArgs e);
protected void RecreateHandle();
public Rectangle RectangleToClient(Rectangle r);
public Rectangle RectangleToScreen(Rectangle r);
public virtual void Refresh();
public void remove_BackColorChanged(EventHandler value);
public void remove_BackgroundImageChanged(EventHandler value);
public void remove_BindingContextChanged(EventHandler value);
public void remove_CausesValidationChanged(EventHandler value);
public void remove_ChangeUICues(UICuesEventHandler value);
public void remove_Click(EventHandler value);
public void remove_ContextMenuChanged(EventHandler value);
public void remove_ControlAdded(ControlEventHandler value);
public void remove_ControlRemoved(ControlEventHandler value);
public void remove_CursorChanged(EventHandler value);
public void remove_Disposed(EventHandler value);
public void remove_DockChanged(EventHandler value);
public void remove_DoubleClick(EventHandler value);
public void remove_DragDrop(DragEventHandler value);
public void remove_DragEnter(DragEventHandler value);
public void remove_DragLeave(EventHandler value);
public void remove_DragOver(DragEventHandler value);
public void remove_EnabledChanged(EventHandler value);
public void remove_Enter(EventHandler value);
public void remove_FontChanged(EventHandler value);
public void remove_ForeColorChanged(EventHandler value);
public void remove_GiveFeedback(GiveFeedbackEventHandler value);
public void remove_GotFocus(EventHandler value);
public void remove_HandleCreated(EventHandler value);
public void remove_HandleDestroyed(EventHandler value);
public void remove_HelpRequested(HelpEventHandler value);
public void remove_ImeModeChanged(EventHandler value);
public void remove_Invalidated(InvalidateEventHandler value);
public void remove_KeyDown(KeyEventHandler value);
public void remove_KeyPress(KeyPressEventHandler value);
public void remove_KeyUp(KeyEventHandler value);
public void remove_Layout(LayoutEventHandler value);
public void remove_Leave(EventHandler value);
public void remove_LocationChanged(EventHandler value);
public void remove_LostFocus(EventHandler value);
public void remove_MouseDown(MouseEventHandler value);
public void remove_MouseEnter(EventHandler value);
public void remove_MouseHover(EventHandler value);
public void remove_MouseLeave(EventHandler value);
public void remove_MouseMove(MouseEventHandler value);
public void remove_MouseUp(MouseEventHandler value);
public void remove_MouseWheel(MouseEventHandler value);
public void remove_Move(EventHandler value);
public void remove_Paint(PaintEventHandler value);
public void remove_ParentChanged(EventHandler value);
public void remove_QueryAccessibilityHelp(QueryAccessibilityHelpEventHandler value);
public void remove_QueryContinueDrag(QueryContinueDragEventHandler value);
public void remove_Resize(EventHandler value);
public void remove_RightToLeftChanged(EventHandler value);
public void remove_Scroll(ScrollEventHandler value);
public void remove_SizeChanged(EventHandler value);
public void remove_StyleChanged(EventHandler value);
public void remove_SystemColorsChanged(EventHandler value);
public void remove_TabIndexChanged(EventHandler value);
public void remove_TabStopChanged(EventHandler value);
public void remove_TextChanged(EventHandler value);
public void remove_Validated(EventHandler value);
public void remove_Validating(CancelEventHandler value);
public void remove_ValueChanged(EventHandler value);
public void remove_VisibleChanged(EventHandler value);
public void ResetBackColor();
public void ResetBindings();
public void ResetCursor();
public void ResetFont();
public void ResetForeColor();
public void ResetImeMode();
protected void ResetMouseEventArgs();
public void ResetRightToLeft();
public void ResetText();
public void ResumeLayout();
public void ResumeLayout(bool performLayout);
protected ContentAlignment RtlTranslateAlignment(ContentAlignment align);
protected HorizontalAlignment RtlTranslateAlignment(HorizontalAlignment align);
protected LeftRightAlignment RtlTranslateAlignment(LeftRightAlignment align);
protected ContentAlignment RtlTranslateContent(ContentAlignment align);
protected HorizontalAlignment RtlTranslateHorizontal(HorizontalAlignment align);
protected LeftRightAlignment RtlTranslateLeftRight(LeftRightAlignment align);
public void Scale(float ratio);
public void Scale(float dx, float dy);
protected virtual void ScaleCore(float dx, float dy);
public void Select();
protected virtual void Select(bool directed, bool forward);
public bool SelectNextControl(Control ctl, bool forward, bool tabStopOnly, bool nested, bool wrap);
public void SendToBack();
public void SetBounds(int x, int y, int width, int height);
public void SetBounds(int x, int y, int width, int height, BoundsSpecified specified);
protected virtual void SetBoundsCore(int x, int y, int width, int height, BoundsSpecified specified);
protected virtual void SetClientSizeCore(int x, int y);
protected void SetStyle(ControlStyles flag, bool value);
protected void SetTopLevel(bool value);
protected virtual void SetVisibleCore(bool value);
public void Show();
public void SuspendLayout();
public virtual string ToString();
public void Update();
protected void UpdateBounds();
protected void UpdateBounds(int x, int y, int width, int height);
protected void UpdateBounds(int x, int y, int width, int height, int clientWidth, int clientHeight);
protected void UpdateScrollInfo();
protected void UpdateStyles();
protected void UpdateZOrder();
protected virtual void WndProc(ref Message m);

Property
public AccessibleObject AccessibilityObject {get;}
public string AccessibleDefaultActionDescription {get; set;}
public string AccessibleDescription {get; set;}
public string AccessibleName {get; set;}
public AccessibleRole AccessibleRole {get; set;}
public bool AllowDrop {get; set;}
public AnchorStyles Anchor {get; set;}
public virtual Color BackColor {get; set;}
public override Image BackgroundImage {get; set;}
public virtual BindingContext BindingContext {get; set;}
public int Bottom {get;}
public Rectangle Bounds {get; set;}
public bool CanFocus {get;}
public bool CanSelect {get;}
public bool Capture {get; set;}
public bool CausesValidation {get; set;}
public Rectangle ClientRectangle {get;}
public Size ClientSize {get; set;}
public string CompanyName {get;}
public IContainer Container {get;}
public bool ContainsFocus {get;}
public ContextMenu ContextMenu {get; set;}
public ControlCollection Controls {get;}
public bool Created {get;}
protected virtual CreateParams CreateParams {get;}
public Cursor Cursor {get; set;}
public ControlBindingsCollection DataBindings {get;}
protected virtual ImeMode DefaultImeMode {get;}
protected virtual Size DefaultSize {get;}
protected bool DesignMode {get;}
public Rectangle DisplayRectangle {get;}
public bool Disposing {get;}
public DockStyle Dock {get; set;}
public bool Enabled {get; set;}
protected EventHandlerList Events {get;}
public bool Focused {get;}
public virtual Font Font {get; set;}
protected int FontHeight {get; set;}
public virtual Color ForeColor {get; set;}
public IntPtr Handle {get;}
public bool HasChildren {get;}
public int Height {get; set;}
public ImeMode ImeMode {get; set;}
public bool InvokeRequired {get;}
public bool IsAccessible {get; set;}
public bool IsDisposed {get;}
public bool IsHandleCreated {get;}
public int LargeChange {get; set;}
public int Left {get; set;}
public Point Location {get; set;}
public int Maximum {get; set;}
public int Minimum {get; set;}
public string Name {get; set;}
public Control Parent {get; set;}
public string ProductName {get;}
public string ProductVersion {get;}
public bool RecreatingHandle {get;}
public Region Region {get; set;}
protected bool RenderRightToLeft {get;}
protected bool ResizeRedraw {get; set;}
public int Right {get;}
public RightToLeft RightToLeft {get; set;}
protected virtual bool ShowFocusCues {get;}
protected bool ShowKeyboardCues {get;}
public ISite Site {get; set;}
public Size Size {get; set;}
public int SmallChange {get; set;}
public int TabIndex {get; set;}
public bool TabStop {get; set;}
public object Tag {get; set;}
public virtual string Text {get; set;}
public int Top {get; set;}
public Control TopLevelControl {get;}
public int Value {get; set;}
public bool Visible {get; set;}
public int Width {get; set;}
public IWindowTarget WindowTarget {get; set;}

System.Windows.Forms.Screen

Module:System.Windows.Forms.dll

Hierarchy
Object
Screen

Type declaration

[C#] public class Screen;

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public static Screen FromControl(Control control);
public static Screen FromHandle(IntPtr hwnd);
public static Screen FromPoint(Point point);
public static Screen FromRectangle(Rectangle rect);
public static Rectangle GetBounds(Control ctl);
public static Rectangle GetBounds(Point pt);
public static Rectangle GetBounds(Rectangle rect);
public virtual int GetHashCode();
public Type GetType();
public static Rectangle GetWorkingArea(Control ctl);
public static Rectangle GetWorkingArea(Point pt);
public static Rectangle GetWorkingArea(Rectangle rect);
protected object MemberwiseClone();
public virtual string ToString();

Property
public static Screen[] AllScreens {get;}
public Rectangle Bounds {get;}
public string DeviceName {get;}
public bool Primary {get;}
public static Screen PrimaryScreen {get;}
public Rectangle WorkingArea {get;}

System.Windows.Forms.SaveFileDialog

Module:System.Windows.Forms.dll

Hierarchy
Object
MarshalByRefObject
Component
CommonDialog
FileDialog
SaveFileDialog

Type declaration

[C#] public sealed class SaveFileDialog : FileDialog;

Constructor
public SaveFileDialog();

Method
public void add_Disposed(EventHandler value);
public void add_FileOk(CancelEventHandler value);
public void add_HelpRequest(EventHandler value);
public ObjRef CreateObjRef(Type requestedType);
public void Dispose();
protected virtual void Dispose(bool disposing);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public object GetLifetimeService();
protected virtual object GetService(Type service);
public Type GetType();
protected virtual IntPtr HookProc(IntPtr hWnd, int msg, IntPtr wparam, IntPtr lparam);
public object InitializeLifetimeService();
protected object MemberwiseClone();
protected void OnFileOk(CancelEventArgs e);
protected virtual void OnHelpRequest(EventArgs e);
public Stream OpenFile();
protected virtual IntPtr OwnerWndProc(IntPtr hWnd, int msg, IntPtr wparam, IntPtr lparam);
public void remove_Disposed(EventHandler value);
public void remove_FileOk(CancelEventHandler value);
public void remove_HelpRequest(EventHandler value);
public override void Reset();
protected virtual bool RunDialog(IntPtr hWndOwner);
public DialogResult ShowDialog();
public DialogResult ShowDialog(IWin32Window owner);
public virtual string ToString();

Property
public bool AddExtension {get; set;}
public bool CheckFileExists {get; set;}
public bool CheckPathExists {get; set;}
public IContainer Container {get;}
public bool CreatePrompt {get; set;}
public string DefaultExt {get; set;}
public bool DereferenceLinks {get; set;}
protected bool DesignMode {get;}
protected EventHandlerList Events {get;}
public string FileName {get; set;}
public string[] FileNames {get;}
public string Filter {get; set;}
public int FilterIndex {get; set;}
public string InitialDirectory {get; set;}
protected virtual IntPtr Instance {get;}
protected int Options {get;}
public bool OverwritePrompt {get; set;}
public bool RestoreDirectory {get; set;}
public bool ShowHelp {get; set;}
public ISite Site {get; set;}
public string Title {get; set;}
public bool ValidateNames {get; set;}

System.Windows.Forms.RadioButton

Module:System.Windows.Forms.dll

Hierarchy
Object
MarshalByRefObject
Component
Control
ButtonBase
RadioButton

Type declaration

[C#] public class RadioButton : ButtonBase;

Constructor
public RadioButton();

Method
protected void AccessibilityNotifyClients(AccessibleEvents accEvent, int childID);
public void add_AppearanceChanged(EventHandler value);
public void add_BackColorChanged(EventHandler value);
public void add_BackgroundImageChanged(EventHandler value);
public void add_BindingContextChanged(EventHandler value);
public void add_CausesValidationChanged(EventHandler value);
public void add_ChangeUICues(UICuesEventHandler value);
public void add_CheckedChanged(EventHandler value);
public void add_Click(EventHandler value);
public void add_ContextMenuChanged(EventHandler value);
public void add_ControlAdded(ControlEventHandler value);
public void add_ControlRemoved(ControlEventHandler value);
public void add_CursorChanged(EventHandler value);
public void add_Disposed(EventHandler value);
public void add_DockChanged(EventHandler value);
public void add_DoubleClick(EventHandler value);
public void add_DragDrop(DragEventHandler value);
public void add_DragEnter(DragEventHandler value);
public void add_DragLeave(EventHandler value);
public void add_DragOver(DragEventHandler value);
public void add_EnabledChanged(EventHandler value);
public void add_Enter(EventHandler value);
public void add_FontChanged(EventHandler value);
public void add_ForeColorChanged(EventHandler value);
public void add_GiveFeedback(GiveFeedbackEventHandler value);
public void add_GotFocus(EventHandler value);
public void add_HandleCreated(EventHandler value);
public void add_HandleDestroyed(EventHandler value);
public void add_HelpRequested(HelpEventHandler value);
public void add_ImeModeChanged(EventHandler value);
public void add_Invalidated(InvalidateEventHandler value);
public void add_KeyDown(KeyEventHandler value);
public void add_KeyPress(KeyPressEventHandler value);
public void add_KeyUp(KeyEventHandler value);
public void add_Layout(LayoutEventHandler value);
public void add_Leave(EventHandler value);
public void add_LocationChanged(EventHandler value);
public void add_LostFocus(EventHandler value);
public void add_MouseDown(MouseEventHandler value);
public void add_MouseEnter(EventHandler value);
public void add_MouseHover(EventHandler value);
public void add_MouseLeave(EventHandler value);
public void add_MouseMove(MouseEventHandler value);
public void add_MouseUp(MouseEventHandler value);
public void add_MouseWheel(MouseEventHandler value);
public void add_Move(EventHandler value);
public void add_Paint(PaintEventHandler value);
public void add_ParentChanged(EventHandler value);
public void add_QueryAccessibilityHelp(QueryAccessibilityHelpEventHandler value);
public void add_QueryContinueDrag(QueryContinueDragEventHandler value);
public void add_Resize(EventHandler value);
public void add_RightToLeftChanged(EventHandler value);
public void add_SizeChanged(EventHandler value);
public void add_StyleChanged(EventHandler value);
public void add_SystemColorsChanged(EventHandler value);
public void add_TabIndexChanged(EventHandler value);
public void add_TabStopChanged(EventHandler value);
public void add_TextChanged(EventHandler value);
public void add_Validated(EventHandler value);
public void add_Validating(CancelEventHandler value);
public void add_VisibleChanged(EventHandler value);
public IAsyncResult BeginInvoke(Delegate method);
public IAsyncResult BeginInvoke(Delegate method, object[] args);
public void BringToFront();
public bool Contains(Control ctl);
protected virtual AccessibleObject CreateAccessibilityInstance();
public void CreateControl();
protected virtual ControlCollection CreateControlsInstance();
public Graphics CreateGraphics();
protected virtual void CreateHandle();
public ObjRef CreateObjRef(Type requestedType);
protected virtual void DefWndProc(ref Message m);
protected virtual void DestroyHandle();
public void Dispose();
protected override void Dispose(bool disposing);
public DragDropEffects DoDragDrop(object data, DragDropEffects allowedEffects);
public object EndInvoke(IAsyncResult asyncResult);
public virtual bool Equals(object obj);
protected override void Finalize();
public Form FindForm();
public bool Focus();
public Control GetChildAtPoint(Point pt);
public IContainerControl GetContainerControl();
public virtual int GetHashCode();
public object GetLifetimeService();
public Control GetNextControl(Control ctl, bool forward);
protected virtual object GetService(Type service);
protected bool GetStyle(ControlStyles flag);
protected bool GetTopLevel();
public Type GetType();
public void Hide();
public object InitializeLifetimeService();
protected virtual void InitLayout();
public void Invalidate();
public void Invalidate(bool invalidateChildren);
public void Invalidate(Rectangle rect);
public void Invalidate(Rectangle rc, bool invalidateChildren);
public void Invalidate(Region region);
public void Invalidate(Region region, bool invalidateChildren);
public object Invoke(Delegate method);
public object Invoke(Delegate method, object[] args);
protected void InvokeGotFocus(Control toInvoke, EventArgs e);
protected void InvokeLostFocus(Control toInvoke, EventArgs e);
protected void InvokeOnClick(Control toInvoke, EventArgs e);
protected void InvokePaint(Control c, PaintEventArgs e);
protected void InvokePaintBackground(Control c, PaintEventArgs e);
protected virtual bool IsInputChar(char charCode);
protected virtual bool IsInputKey(Keys keyData);
protected object MemberwiseClone();
protected virtual void NotifyInvalidate(Rectangle invalidatedArea);
protected virtual void OnBackColorChanged(EventArgs e);
protected virtual void OnBackgroundImageChanged(EventArgs e);
protected virtual void OnBindingContextChanged(EventArgs e);
protected virtual void OnCausesValidationChanged(EventArgs e);
protected virtual void OnChangeUICues(UICuesEventArgs e);
protected virtual void OnCheckedChanged(EventArgs e);
protected virtual void OnClick(EventArgs e);
protected virtual void OnContextMenuChanged(EventArgs e);
protected virtual void OnControlAdded(ControlEventArgs e);
protected virtual void OnControlRemoved(ControlEventArgs e);
protected virtual void OnCreateControl();
protected virtual void OnCursorChanged(EventArgs e);
protected virtual void OnDockChanged(EventArgs e);
protected virtual void OnDoubleClick(EventArgs e);
protected virtual void OnDragDrop(DragEventArgs drgevent);
protected virtual void OnDragEnter(DragEventArgs drgevent);
protected virtual void OnDragLeave(EventArgs e);
protected virtual void OnDragOver(DragEventArgs drgevent);
protected virtual void OnEnabledChanged(EventArgs e);
protected virtual void OnEnter(EventArgs e);
protected virtual void OnFontChanged(EventArgs e);
protected virtual void OnForeColorChanged(EventArgs e);
protected virtual void OnGiveFeedback(GiveFeedbackEventArgs gfbevent);
protected virtual void OnGotFocus(EventArgs e);
protected virtual void OnHandleCreated(EventArgs e);
protected virtual void OnHandleDestroyed(EventArgs e);
protected virtual void OnHelpRequested(HelpEventArgs hevent);
protected virtual void OnImeModeChanged(EventArgs e);
protected virtual void OnInvalidated(InvalidateEventArgs e);
protected virtual void OnKeyDown(KeyEventArgs e);
protected virtual void OnKeyPress(KeyPressEventArgs e);
protected virtual void OnKeyUp(KeyEventArgs e);
protected virtual void OnLayout(LayoutEventArgs levent);
protected virtual void OnLeave(EventArgs e);
protected virtual void OnLocationChanged(EventArgs e);
protected virtual void OnLostFocus(EventArgs e);
protected virtual void OnMouseDown(MouseEventArgs e);
protected virtual void OnMouseEnter(EventArgs eventargs);
protected virtual void OnMouseHover(EventArgs e);
protected virtual void OnMouseLeave(EventArgs eventargs);
protected virtual void OnMouseMove(MouseEventArgs e);
protected virtual void OnMouseUp(MouseEventArgs e);
protected virtual void OnMouseWheel(MouseEventArgs e);
protected virtual void OnMove(EventArgs e);
protected virtual void OnNotifyMessage(Message m);
protected virtual void OnPaint(PaintEventArgs e);
protected virtual void OnPaintBackground(PaintEventArgs e);
protected virtual void OnParentBackColorChanged(EventArgs e);
protected virtual void OnParentBackgroundImageChanged(EventArgs e);
protected virtual void OnParentBindingContextChanged(EventArgs e);
protected virtual void OnParentChanged(EventArgs e);
protected virtual void OnParentEnabledChanged(EventArgs e);
protected virtual void OnParentFontChanged(EventArgs e);
protected virtual void OnParentForeColorChanged(EventArgs e);
protected virtual void OnParentRightToLeftChanged(EventArgs e);
protected virtual void OnParentVisibleChanged(EventArgs e);
protected virtual void OnQueryContinueDrag(QueryContinueDragEventArgs qcdevent);
protected virtual void OnResize(EventArgs e);
protected virtual void OnRightToLeftChanged(EventArgs e);
protected virtual void OnSizeChanged(EventArgs e);
protected virtual void OnStyleChanged(EventArgs e);
protected virtual void OnSystemColorsChanged(EventArgs e);
protected virtual void OnTabIndexChanged(EventArgs e);
protected virtual void OnTabStopChanged(EventArgs e);
protected virtual void OnTextChanged(EventArgs e);
protected virtual void OnValidated(EventArgs e);
protected virtual void OnValidating(CancelEventArgs e);
protected virtual void OnVisibleChanged(EventArgs e);
public void PerformClick();
public void PerformLayout();
public void PerformLayout(Control affectedControl, string affectedProperty);
public Point PointToClient(Point p);
public Point PointToScreen(Point p);
public bool PreProcessMessage(ref Message msg);
protected virtual bool ProcessCmdKey(ref Message msg, Keys keyData);
protected virtual bool ProcessDialogChar(char charCode);
protected virtual bool ProcessDialogKey(Keys keyData);
protected virtual bool ProcessKeyEventArgs(ref Message m);
protected virtual bool ProcessKeyPreview(ref Message m);
protected virtual bool ProcessMnemonic(char charCode);
protected void RaiseDragEvent(object key, DragEventArgs e);
protected void RaiseKeyEvent(object key, KeyEventArgs e);
protected void RaiseMouseEvent(object key, MouseEventArgs e);
protected void RaisePaintEvent(object key, PaintEventArgs e);
protected void RecreateHandle();
public Rectangle RectangleToClient(Rectangle r);
public Rectangle RectangleToScreen(Rectangle r);
public virtual void Refresh();
public void remove_AppearanceChanged(EventHandler value);
public void remove_BackColorChanged(EventHandler value);
public void remove_BackgroundImageChanged(EventHandler value);
public void remove_BindingContextChanged(EventHandler value);
public void remove_CausesValidationChanged(EventHandler value);
public void remove_ChangeUICues(UICuesEventHandler value);
public void remove_CheckedChanged(EventHandler value);
public void remove_Click(EventHandler value);
public void remove_ContextMenuChanged(EventHandler value);
public void remove_ControlAdded(ControlEventHandler value);
public void remove_ControlRemoved(ControlEventHandler value);
public void remove_CursorChanged(EventHandler value);
public void remove_Disposed(EventHandler value);
public void remove_DockChanged(EventHandler value);
public void remove_DoubleClick(EventHandler value);
public void remove_DragDrop(DragEventHandler value);
public void remove_DragEnter(DragEventHandler value);
public void remove_DragLeave(EventHandler value);
public void remove_DragOver(DragEventHandler value);
public void remove_EnabledChanged(EventHandler value);
public void remove_Enter(EventHandler value);
public void remove_FontChanged(EventHandler value);
public void remove_ForeColorChanged(EventHandler value);
public void remove_GiveFeedback(GiveFeedbackEventHandler value);
public void remove_GotFocus(EventHandler value);
public void remove_HandleCreated(EventHandler value);
public void remove_HandleDestroyed(EventHandler value);
public void remove_HelpRequested(HelpEventHandler value);
public void remove_ImeModeChanged(EventHandler value);
public void remove_Invalidated(InvalidateEventHandler value);
public void remove_KeyDown(KeyEventHandler value);
public void remove_KeyPress(KeyPressEventHandler value);
public void remove_KeyUp(KeyEventHandler value);
public void remove_Layout(LayoutEventHandler value);
public void remove_Leave(EventHandler value);
public void remove_LocationChanged(EventHandler value);
public void remove_LostFocus(EventHandler value);
public void remove_MouseDown(MouseEventHandler value);
public void remove_MouseEnter(EventHandler value);
public void remove_MouseHover(EventHandler value);
public void remove_MouseLeave(EventHandler value);
public void remove_MouseMove(MouseEventHandler value);
public void remove_MouseUp(MouseEventHandler value);
public void remove_MouseWheel(MouseEventHandler value);
public void remove_Move(EventHandler value);
public void remove_Paint(PaintEventHandler value);
public void remove_ParentChanged(EventHandler value);
public void remove_QueryAccessibilityHelp(QueryAccessibilityHelpEventHandler value);
public void remove_QueryContinueDrag(QueryContinueDragEventHandler value);
public void remove_Resize(EventHandler value);
public void remove_RightToLeftChanged(EventHandler value);
public void remove_SizeChanged(EventHandler value);
public void remove_StyleChanged(EventHandler value);
public void remove_SystemColorsChanged(EventHandler value);
public void remove_TabIndexChanged(EventHandler value);
public void remove_TabStopChanged(EventHandler value);
public void remove_TextChanged(EventHandler value);
public void remove_Validated(EventHandler value);
public void remove_Validating(CancelEventHandler value);
public void remove_VisibleChanged(EventHandler value);
public void ResetBackColor();
public void ResetBindings();
public void ResetCursor();
protected void ResetFlagsandPaint();
public void ResetFont();
public void ResetForeColor();
public void ResetImeMode();
protected void ResetMouseEventArgs();
public void ResetRightToLeft();
public void ResetText();
public void ResumeLayout();
public void ResumeLayout(bool performLayout);
protected ContentAlignment RtlTranslateAlignment(ContentAlignment align);
protected HorizontalAlignment RtlTranslateAlignment(HorizontalAlignment align);
protected LeftRightAlignment RtlTranslateAlignment(LeftRightAlignment align);
protected ContentAlignment RtlTranslateContent(ContentAlignment align);
protected HorizontalAlignment RtlTranslateHorizontal(HorizontalAlignment align);
protected LeftRightAlignment RtlTranslateLeftRight(LeftRightAlignment align);
public void Scale(float ratio);
public void Scale(float dx, float dy);
protected virtual void ScaleCore(float dx, float dy);
public void Select();
protected virtual void Select(bool directed, bool forward);
public bool SelectNextControl(Control ctl, bool forward, bool tabStopOnly, bool nested, bool wrap);
public void SendToBack();
public void SetBounds(int x, int y, int width, int height);
public void SetBounds(int x, int y, int width, int height, BoundsSpecified specified);
protected virtual void SetBoundsCore(int x, int y, int width, int height, BoundsSpecified specified);
protected virtual void SetClientSizeCore(int x, int y);
protected void SetStyle(ControlStyles flag, bool value);
protected void SetTopLevel(bool value);
protected virtual void SetVisibleCore(bool value);
public void Show();
public void SuspendLayout();
public virtual string ToString();
public void Update();
protected void UpdateBounds();
protected void UpdateBounds(int x, int y, int width, int height);
protected void UpdateBounds(int x, int y, int width, int height, int clientWidth, int clientHeight);
protected void UpdateStyles();
protected void UpdateZOrder();
protected virtual void WndProc(ref Message m);

Property
public AccessibleObject AccessibilityObject {get;}
public string AccessibleDefaultActionDescription {get; set;}
public string AccessibleDescription {get; set;}
public string AccessibleName {get; set;}
public AccessibleRole AccessibleRole {get; set;}
public bool AllowDrop {get; set;}
public AnchorStyles Anchor {get; set;}
public Appearance Appearance {get; set;}
public bool AutoCheck {get; set;}
public virtual Color BackColor {get; set;}
public Image BackgroundImage {get; set;}
public virtual BindingContext BindingContext {get; set;}
public int Bottom {get;}
public Rectangle Bounds {get; set;}
public bool CanFocus {get;}
public bool CanSelect {get;}
public bool Capture {get; set;}
public bool CausesValidation {get; set;}
public ContentAlignment CheckAlign {get; set;}
public bool Checked {get; set;}
public Rectangle ClientRectangle {get;}
public Size ClientSize {get; set;}
public string CompanyName {get;}
public IContainer Container {get;}
public bool ContainsFocus {get;}
public ContextMenu ContextMenu {get; set;}
public ControlCollection Controls {get;}
public bool Created {get;}
protected virtual CreateParams CreateParams {get;}
public Cursor Cursor {get; set;}
public ControlBindingsCollection DataBindings {get;}
protected virtual ImeMode DefaultImeMode {get;}
protected virtual Size DefaultSize {get;}
protected bool DesignMode {get;}
public Rectangle DisplayRectangle {get;}
public bool Disposing {get;}
public DockStyle Dock {get; set;}
public bool Enabled {get; set;}
protected EventHandlerList Events {get;}
public FlatStyle FlatStyle {get; set;}
public bool Focused {get;}
public virtual Font Font {get; set;}
protected int FontHeight {get; set;}
public virtual Color ForeColor {get; set;}
public IntPtr Handle {get;}
public bool HasChildren {get;}
public int Height {get; set;}
public Image Image {get; set;}
public ContentAlignment ImageAlign {get; set;}
public int ImageIndex {get; set;}
public ImageList ImageList {get; set;}
public ImeMode ImeMode {get; set;}
public bool InvokeRequired {get;}
public bool IsAccessible {get; set;}
protected bool IsDefault {get; set;}
public bool IsDisposed {get;}
public bool IsHandleCreated {get;}
public int Left {get; set;}
public Point Location {get; set;}
public string Name {get; set;}
public Control Parent {get; set;}
public string ProductName {get;}
public string ProductVersion {get;}
public bool RecreatingHandle {get;}
public Region Region {get; set;}
protected bool RenderRightToLeft {get;}
protected bool ResizeRedraw {get; set;}
public int Right {get;}
public RightToLeft RightToLeft {get; set;}
protected virtual bool ShowFocusCues {get;}
protected bool ShowKeyboardCues {get;}
public ISite Site {get; set;}
public Size Size {get; set;}
public int TabIndex {get; set;}
public bool TabStop {get; set;}
public object Tag {get; set;}
public virtual string Text {get; set;}
public override ContentAlignment TextAlign {get; set;}
public int Top {get; set;}
public Control TopLevelControl {get;}
public bool Visible {get; set;}
public int Width {get; set;}
public IWindowTarget WindowTarget {get; set;}

System.Windows.Forms.ProgressBar

Module:System.Windows.Forms.dll

Hierarchy
Object
MarshalByRefObject
Component
Control
ProgressBar

Type declaration

[C#] public sealed class ProgressBar : Control;

Constructor
public ProgressBar();

Method
protected void AccessibilityNotifyClients(AccessibleEvents accEvent, int childID);
public void add_BackColorChanged(EventHandler value);
public void add_BackgroundImageChanged(EventHandler value);
public void add_BindingContextChanged(EventHandler value);
public void add_CausesValidationChanged(EventHandler value);
public void add_ChangeUICues(UICuesEventHandler value);
public void add_Click(EventHandler value);
public void add_ContextMenuChanged(EventHandler value);
public void add_ControlAdded(ControlEventHandler value);
public void add_ControlRemoved(ControlEventHandler value);
public void add_CursorChanged(EventHandler value);
public void add_Disposed(EventHandler value);
public void add_DockChanged(EventHandler value);
public void add_DoubleClick(EventHandler value);
public void add_DragDrop(DragEventHandler value);
public void add_DragEnter(DragEventHandler value);
public void add_DragLeave(EventHandler value);
public void add_DragOver(DragEventHandler value);
public void add_EnabledChanged(EventHandler value);
public void add_Enter(EventHandler value);
public void add_FontChanged(EventHandler value);
public void add_ForeColorChanged(EventHandler value);
public void add_GiveFeedback(GiveFeedbackEventHandler value);
public void add_GotFocus(EventHandler value);
public void add_HandleCreated(EventHandler value);
public void add_HandleDestroyed(EventHandler value);
public void add_HelpRequested(HelpEventHandler value);
public void add_ImeModeChanged(EventHandler value);
public void add_Invalidated(InvalidateEventHandler value);
public void add_KeyDown(KeyEventHandler value);
public void add_KeyPress(KeyPressEventHandler value);
public void add_KeyUp(KeyEventHandler value);
public void add_Layout(LayoutEventHandler value);
public void add_Leave(EventHandler value);
public void add_LocationChanged(EventHandler value);
public void add_LostFocus(EventHandler value);
public void add_MouseDown(MouseEventHandler value);
public void add_MouseEnter(EventHandler value);
public void add_MouseHover(EventHandler value);
public void add_MouseLeave(EventHandler value);
public void add_MouseMove(MouseEventHandler value);
public void add_MouseUp(MouseEventHandler value);
public void add_MouseWheel(MouseEventHandler value);
public void add_Move(EventHandler value);
public void add_Paint(PaintEventHandler value);
public void add_ParentChanged(EventHandler value);
public void add_QueryAccessibilityHelp(QueryAccessibilityHelpEventHandler value);
public void add_QueryContinueDrag(QueryContinueDragEventHandler value);
public void add_Resize(EventHandler value);
public void add_RightToLeftChanged(EventHandler value);
public void add_SizeChanged(EventHandler value);
public void add_StyleChanged(EventHandler value);
public void add_SystemColorsChanged(EventHandler value);
public void add_TabIndexChanged(EventHandler value);
public void add_TabStopChanged(EventHandler value);
public void add_TextChanged(EventHandler value);
public void add_Validated(EventHandler value);
public void add_Validating(CancelEventHandler value);
public void add_VisibleChanged(EventHandler value);
public IAsyncResult BeginInvoke(Delegate method);
public IAsyncResult BeginInvoke(Delegate method, object[] args);
public void BringToFront();
public bool Contains(Control ctl);
protected virtual AccessibleObject CreateAccessibilityInstance();
public void CreateControl();
protected virtual ControlCollection CreateControlsInstance();
public Graphics CreateGraphics();
protected virtual void CreateHandle();
public ObjRef CreateObjRef(Type requestedType);
protected virtual void DefWndProc(ref Message m);
protected virtual void DestroyHandle();
public void Dispose();
protected override void Dispose(bool disposing);
public DragDropEffects DoDragDrop(object data, DragDropEffects allowedEffects);
public object EndInvoke(IAsyncResult asyncResult);
public virtual bool Equals(object obj);
protected override void Finalize();
public Form FindForm();
public bool Focus();
public Control GetChildAtPoint(Point pt);
public IContainerControl GetContainerControl();
public virtual int GetHashCode();
public object GetLifetimeService();
public Control GetNextControl(Control ctl, bool forward);
protected virtual object GetService(Type service);
protected bool GetStyle(ControlStyles flag);
protected bool GetTopLevel();
public Type GetType();
public void Hide();
public void Increment(int value);
public object InitializeLifetimeService();
protected virtual void InitLayout();
public void Invalidate();
public void Invalidate(bool invalidateChildren);
public void Invalidate(Rectangle rect);
public void Invalidate(Rectangle rc, bool invalidateChildren);
public void Invalidate(Region region);
public void Invalidate(Region region, bool invalidateChildren);
public object Invoke(Delegate method);
public object Invoke(Delegate method, object[] args);
protected void InvokeGotFocus(Control toInvoke, EventArgs e);
protected void InvokeLostFocus(Control toInvoke, EventArgs e);
protected void InvokeOnClick(Control toInvoke, EventArgs e);
protected void InvokePaint(Control c, PaintEventArgs e);
protected void InvokePaintBackground(Control c, PaintEventArgs e);
protected virtual bool IsInputChar(char charCode);
protected virtual bool IsInputKey(Keys keyData);
protected object MemberwiseClone();
protected virtual void NotifyInvalidate(Rectangle invalidatedArea);
protected virtual void OnBackColorChanged(EventArgs e);
protected virtual void OnBackgroundImageChanged(EventArgs e);
protected virtual void OnBindingContextChanged(EventArgs e);
protected virtual void OnCausesValidationChanged(EventArgs e);
protected virtual void OnChangeUICues(UICuesEventArgs e);
protected virtual void OnClick(EventArgs e);
protected virtual void OnContextMenuChanged(EventArgs e);
protected virtual void OnControlAdded(ControlEventArgs e);
protected virtual void OnControlRemoved(ControlEventArgs e);
protected virtual void OnCreateControl();
protected virtual void OnCursorChanged(EventArgs e);
protected virtual void OnDockChanged(EventArgs e);
protected virtual void OnDoubleClick(EventArgs e);
protected virtual void OnDragDrop(DragEventArgs drgevent);
protected virtual void OnDragEnter(DragEventArgs drgevent);
protected virtual void OnDragLeave(EventArgs e);
protected virtual void OnDragOver(DragEventArgs drgevent);
protected virtual void OnEnabledChanged(EventArgs e);
protected virtual void OnEnter(EventArgs e);
protected virtual void OnFontChanged(EventArgs e);
protected virtual void OnForeColorChanged(EventArgs e);
protected virtual void OnGiveFeedback(GiveFeedbackEventArgs gfbevent);
protected virtual void OnGotFocus(EventArgs e);
protected virtual void OnHandleCreated(EventArgs e);
protected virtual void OnHandleDestroyed(EventArgs e);
protected virtual void OnHelpRequested(HelpEventArgs hevent);
protected virtual void OnImeModeChanged(EventArgs e);
protected virtual void OnInvalidated(InvalidateEventArgs e);
protected virtual void OnKeyDown(KeyEventArgs e);
protected virtual void OnKeyPress(KeyPressEventArgs e);
protected virtual void OnKeyUp(KeyEventArgs e);
protected virtual void OnLayout(LayoutEventArgs levent);
protected virtual void OnLeave(EventArgs e);
protected virtual void OnLocationChanged(EventArgs e);
protected virtual void OnLostFocus(EventArgs e);
protected virtual void OnMouseDown(MouseEventArgs e);
protected virtual void OnMouseEnter(EventArgs e);
protected virtual void OnMouseHover(EventArgs e);
protected virtual void OnMouseLeave(EventArgs e);
protected virtual void OnMouseMove(MouseEventArgs e);
protected virtual void OnMouseUp(MouseEventArgs e);
protected virtual void OnMouseWheel(MouseEventArgs e);
protected virtual void OnMove(EventArgs e);
protected virtual void OnNotifyMessage(Message m);
protected virtual void OnPaint(PaintEventArgs e);
protected virtual void OnPaintBackground(PaintEventArgs e);
protected virtual void OnParentBackColorChanged(EventArgs e);
protected virtual void OnParentBackgroundImageChanged(EventArgs e);
protected virtual void OnParentBindingContextChanged(EventArgs e);
protected virtual void OnParentChanged(EventArgs e);
protected virtual void OnParentEnabledChanged(EventArgs e);
protected virtual void OnParentFontChanged(EventArgs e);
protected virtual void OnParentForeColorChanged(EventArgs e);
protected virtual void OnParentRightToLeftChanged(EventArgs e);
protected virtual void OnParentVisibleChanged(EventArgs e);
protected virtual void OnQueryContinueDrag(QueryContinueDragEventArgs qcdevent);
protected virtual void OnResize(EventArgs e);
protected virtual void OnRightToLeftChanged(EventArgs e);
protected virtual void OnSizeChanged(EventArgs e);
protected virtual void OnStyleChanged(EventArgs e);
protected virtual void OnSystemColorsChanged(EventArgs e);
protected virtual void OnTabIndexChanged(EventArgs e);
protected virtual void OnTabStopChanged(EventArgs e);
protected virtual void OnTextChanged(EventArgs e);
protected virtual void OnValidated(EventArgs e);
protected virtual void OnValidating(CancelEventArgs e);
protected virtual void OnVisibleChanged(EventArgs e);
public void PerformLayout();
public void PerformLayout(Control affectedControl, string affectedProperty);
public void PerformStep();
public Point PointToClient(Point p);
public Point PointToScreen(Point p);
public bool PreProcessMessage(ref Message msg);
protected virtual bool ProcessCmdKey(ref Message msg, Keys keyData);
protected virtual bool ProcessDialogChar(char charCode);
protected virtual bool ProcessDialogKey(Keys keyData);
protected virtual bool ProcessKeyEventArgs(ref Message m);
protected virtual bool ProcessKeyPreview(ref Message m);
protected virtual bool ProcessMnemonic(char charCode);
protected void RaiseDragEvent(object key, DragEventArgs e);
protected void RaiseKeyEvent(object key, KeyEventArgs e);
protected void RaiseMouseEvent(object key, MouseEventArgs e);
protected void RaisePaintEvent(object key, PaintEventArgs e);
protected void RecreateHandle();
public Rectangle RectangleToClient(Rectangle r);
public Rectangle RectangleToScreen(Rectangle r);
public virtual void Refresh();
public void remove_BackColorChanged(EventHandler value);
public void remove_BackgroundImageChanged(EventHandler value);
public void remove_BindingContextChanged(EventHandler value);
public void remove_CausesValidationChanged(EventHandler value);
public void remove_ChangeUICues(UICuesEventHandler value);
public void remove_Click(EventHandler value);
public void remove_ContextMenuChanged(EventHandler value);
public void remove_ControlAdded(ControlEventHandler value);
public void remove_ControlRemoved(ControlEventHandler value);
public void remove_CursorChanged(EventHandler value);
public void remove_Disposed(EventHandler value);
public void remove_DockChanged(EventHandler value);
public void remove_DoubleClick(EventHandler value);
public void remove_DragDrop(DragEventHandler value);
public void remove_DragEnter(DragEventHandler value);
public void remove_DragLeave(EventHandler value);
public void remove_DragOver(DragEventHandler value);
public void remove_EnabledChanged(EventHandler value);
public void remove_Enter(EventHandler value);
public void remove_FontChanged(EventHandler value);
public void remove_ForeColorChanged(EventHandler value);
public void remove_GiveFeedback(GiveFeedbackEventHandler value);
public void remove_GotFocus(EventHandler value);
public void remove_HandleCreated(EventHandler value);
public void remove_HandleDestroyed(EventHandler value);
public void remove_HelpRequested(HelpEventHandler value);
public void remove_ImeModeChanged(EventHandler value);
public void remove_Invalidated(InvalidateEventHandler value);
public void remove_KeyDown(KeyEventHandler value);
public void remove_KeyPress(KeyPressEventHandler value);
public void remove_KeyUp(KeyEventHandler value);
public void remove_Layout(LayoutEventHandler value);
public void remove_Leave(EventHandler value);
public void remove_LocationChanged(EventHandler value);
public void remove_LostFocus(EventHandler value);
public void remove_MouseDown(MouseEventHandler value);
public void remove_MouseEnter(EventHandler value);
public void remove_MouseHover(EventHandler value);
public void remove_MouseLeave(EventHandler value);
public void remove_MouseMove(MouseEventHandler value);
public void remove_MouseUp(MouseEventHandler value);
public void remove_MouseWheel(MouseEventHandler value);
public void remove_Move(EventHandler value);
public void remove_Paint(PaintEventHandler value);
public void remove_ParentChanged(EventHandler value);
public void remove_QueryAccessibilityHelp(QueryAccessibilityHelpEventHandler value);
public void remove_QueryContinueDrag(QueryContinueDragEventHandler value);
public void remove_Resize(EventHandler value);
public void remove_RightToLeftChanged(EventHandler value);
public void remove_SizeChanged(EventHandler value);
public void remove_StyleChanged(EventHandler value);
public void remove_SystemColorsChanged(EventHandler value);
public void remove_TabIndexChanged(EventHandler value);
public void remove_TabStopChanged(EventHandler value);
public void remove_TextChanged(EventHandler value);
public void remove_Validated(EventHandler value);
public void remove_Validating(CancelEventHandler value);
public void remove_VisibleChanged(EventHandler value);
public void ResetBackColor();
public void ResetBindings();
public void ResetCursor();
public void ResetFont();
public void ResetForeColor();
public void ResetImeMode();
protected void ResetMouseEventArgs();
public void ResetRightToLeft();
public void ResetText();
public void ResumeLayout();
public void ResumeLayout(bool performLayout);
protected ContentAlignment RtlTranslateAlignment(ContentAlignment align);
protected HorizontalAlignment RtlTranslateAlignment(HorizontalAlignment align);
protected LeftRightAlignment RtlTranslateAlignment(LeftRightAlignment align);
protected ContentAlignment RtlTranslateContent(ContentAlignment align);
protected HorizontalAlignment RtlTranslateHorizontal(HorizontalAlignment align);
protected LeftRightAlignment RtlTranslateLeftRight(LeftRightAlignment align);
public void Scale(float ratio);
public void Scale(float dx, float dy);
protected virtual void ScaleCore(float dx, float dy);
public void Select();
protected virtual void Select(bool directed, bool forward);
public bool SelectNextControl(Control ctl, bool forward, bool tabStopOnly, bool nested, bool wrap);
public void SendToBack();
public void SetBounds(int x, int y, int width, int height);
public void SetBounds(int x, int y, int width, int height, BoundsSpecified specified);
protected virtual void SetBoundsCore(int x, int y, int width, int height, BoundsSpecified specified);
protected virtual void SetClientSizeCore(int x, int y);
protected void SetStyle(ControlStyles flag, bool value);
protected void SetTopLevel(bool value);
protected virtual void SetVisibleCore(bool value);
public void Show();
public void SuspendLayout();
public virtual string ToString();
public void Update();
protected void UpdateBounds();
protected void UpdateBounds(int x, int y, int width, int height);
protected void UpdateBounds(int x, int y, int width, int height, int clientWidth, int clientHeight);
protected void UpdateStyles();
protected void UpdateZOrder();
protected virtual void WndProc(ref Message m);

Property
public AccessibleObject AccessibilityObject {get;}
public string AccessibleDefaultActionDescription {get; set;}
public string AccessibleDescription {get; set;}
public string AccessibleName {get; set;}
public AccessibleRole AccessibleRole {get; set;}
public override bool AllowDrop {get; set;}
public AnchorStyles Anchor {get; set;}
public virtual Color BackColor {get; set;}
public override Image BackgroundImage {get; set;}
public virtual BindingContext BindingContext {get; set;}
public int Bottom {get;}
public Rectangle Bounds {get; set;}
public bool CanFocus {get;}
public bool CanSelect {get;}
public bool Capture {get; set;}
public bool CausesValidation {get; set;}
public Rectangle ClientRectangle {get;}
public Size ClientSize {get; set;}
public string CompanyName {get;}
public IContainer Container {get;}
public bool ContainsFocus {get;}
public ContextMenu ContextMenu {get; set;}
public ControlCollection Controls {get;}
public bool Created {get;}
protected virtual CreateParams CreateParams {get;}
public Cursor Cursor {get; set;}
public ControlBindingsCollection DataBindings {get;}
protected virtual ImeMode DefaultImeMode {get;}
protected virtual Size DefaultSize {get;}
protected bool DesignMode {get;}
public Rectangle DisplayRectangle {get;}
public bool Disposing {get;}
public DockStyle Dock {get; set;}
public bool Enabled {get; set;}
protected EventHandlerList Events {get;}
public bool Focused {get;}
public virtual Font Font {get; set;}
protected int FontHeight {get; set;}
public virtual Color ForeColor {get; set;}
public IntPtr Handle {get;}
public bool HasChildren {get;}
public int Height {get; set;}
public ImeMode ImeMode {get; set;}
public bool InvokeRequired {get;}
public bool IsAccessible {get; set;}
public bool IsDisposed {get;}
public bool IsHandleCreated {get;}
public int Left {get; set;}
public Point Location {get; set;}
public int Maximum {get; set;}
public int Minimum {get; set;}
public string Name {get; set;}
public Control Parent {get; set;}
public string ProductName {get;}
public string ProductVersion {get;}
public bool RecreatingHandle {get;}
public Region Region {get; set;}
protected bool RenderRightToLeft {get;}
protected bool ResizeRedraw {get; set;}
public int Right {get;}
public override RightToLeft RightToLeft {get; set;}
protected virtual bool ShowFocusCues {get;}
protected bool ShowKeyboardCues {get;}
public ISite Site {get; set;}
public Size Size {get; set;}
public int Step {get; set;}
public int TabIndex {get; set;}
public bool TabStop {get; set;}
public object Tag {get; set;}
public virtual string Text {get; set;}
public int Top {get; set;}
public Control TopLevelControl {get;}
public int Value {get; set;}
public bool Visible {get; set;}
public int Width {get; set;}
public IWindowTarget WindowTarget {get; set;}

System.Windows.Forms.PictureBoxSizeMode

Module:System.Windows.Forms.dll

Hierarchy
Object
ValueType
Enum
PictureBoxSizeMode

Type declaration

[C#] public enum PictureBoxSizeMode;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const PictureBoxSizeMode AutoSize = 2;
public const PictureBoxSizeMode CenterImage = 3;
public const PictureBoxSizeMode Normal = 0;
public const PictureBoxSizeMode StretchImage = 1;
public int value__;

System.Windows.Forms.PictureBox

Module:System.Windows.Forms.dll

Hierarchy
Object
MarshalByRefObject
Component
Control
PictureBox

Type declaration

[C#] public class PictureBox : Control;

Constructor
public PictureBox();

Method
protected void AccessibilityNotifyClients(AccessibleEvents accEvent, int childID);
public void add_BackColorChanged(EventHandler value);
public void add_BackgroundImageChanged(EventHandler value);
public void add_BindingContextChanged(EventHandler value);
public void add_CausesValidationChanged(EventHandler value);
public void add_ChangeUICues(UICuesEventHandler value);
public void add_Click(EventHandler value);
public void add_ContextMenuChanged(EventHandler value);
public void add_ControlAdded(ControlEventHandler value);
public void add_ControlRemoved(ControlEventHandler value);
public void add_CursorChanged(EventHandler value);
public void add_Disposed(EventHandler value);
public void add_DockChanged(EventHandler value);
public void add_DoubleClick(EventHandler value);
public void add_DragDrop(DragEventHandler value);
public void add_DragEnter(DragEventHandler value);
public void add_DragLeave(EventHandler value);
public void add_DragOver(DragEventHandler value);
public void add_EnabledChanged(EventHandler value);
public void add_Enter(EventHandler value);
public void add_FontChanged(EventHandler value);
public void add_ForeColorChanged(EventHandler value);
public void add_GiveFeedback(GiveFeedbackEventHandler value);
public void add_GotFocus(EventHandler value);
public void add_HandleCreated(EventHandler value);
public void add_HandleDestroyed(EventHandler value);
public void add_HelpRequested(HelpEventHandler value);
public void add_ImeModeChanged(EventHandler value);
public void add_Invalidated(InvalidateEventHandler value);
public void add_KeyDown(KeyEventHandler value);
public void add_KeyPress(KeyPressEventHandler value);
public void add_KeyUp(KeyEventHandler value);
public void add_Layout(LayoutEventHandler value);
public void add_Leave(EventHandler value);
public void add_LocationChanged(EventHandler value);
public void add_LostFocus(EventHandler value);
public void add_MouseDown(MouseEventHandler value);
public void add_MouseEnter(EventHandler value);
public void add_MouseHover(EventHandler value);
public void add_MouseLeave(EventHandler value);
public void add_MouseMove(MouseEventHandler value);
public void add_MouseUp(MouseEventHandler value);
public void add_MouseWheel(MouseEventHandler value);
public void add_Move(EventHandler value);
public void add_Paint(PaintEventHandler value);
public void add_ParentChanged(EventHandler value);
public void add_QueryAccessibilityHelp(QueryAccessibilityHelpEventHandler value);
public void add_QueryContinueDrag(QueryContinueDragEventHandler value);
public void add_Resize(EventHandler value);
public void add_RightToLeftChanged(EventHandler value);
public void add_SizeChanged(EventHandler value);
public void add_SizeModeChanged(EventHandler value);
public void add_StyleChanged(EventHandler value);
public void add_SystemColorsChanged(EventHandler value);
public void add_TabIndexChanged(EventHandler value);
public void add_TabStopChanged(EventHandler value);
public void add_TextChanged(EventHandler value);
public void add_Validated(EventHandler value);
public void add_Validating(CancelEventHandler value);
public void add_VisibleChanged(EventHandler value);
public IAsyncResult BeginInvoke(Delegate method);
public IAsyncResult BeginInvoke(Delegate method, object[] args);
public void BringToFront();
public bool Contains(Control ctl);
protected virtual AccessibleObject CreateAccessibilityInstance();
public void CreateControl();
protected virtual ControlCollection CreateControlsInstance();
public Graphics CreateGraphics();
protected virtual void CreateHandle();
public ObjRef CreateObjRef(Type requestedType);
protected virtual void DefWndProc(ref Message m);
protected virtual void DestroyHandle();
public void Dispose();
protected override void Dispose(bool disposing);
public DragDropEffects DoDragDrop(object data, DragDropEffects allowedEffects);
public object EndInvoke(IAsyncResult asyncResult);
public virtual bool Equals(object obj);
protected override void Finalize();
public Form FindForm();
public bool Focus();
public Control GetChildAtPoint(Point pt);
public IContainerControl GetContainerControl();
public virtual int GetHashCode();
public object GetLifetimeService();
public Control GetNextControl(Control ctl, bool forward);
protected virtual object GetService(Type service);
protected bool GetStyle(ControlStyles flag);
protected bool GetTopLevel();
public Type GetType();
public void Hide();
public object InitializeLifetimeService();
protected virtual void InitLayout();
public void Invalidate();
public void Invalidate(bool invalidateChildren);
public void Invalidate(Rectangle rect);
public void Invalidate(Rectangle rc, bool invalidateChildren);
public void Invalidate(Region region);
public void Invalidate(Region region, bool invalidateChildren);
public object Invoke(Delegate method);
public object Invoke(Delegate method, object[] args);
protected void InvokeGotFocus(Control toInvoke, EventArgs e);
protected void InvokeLostFocus(Control toInvoke, EventArgs e);
protected void InvokeOnClick(Control toInvoke, EventArgs e);
protected void InvokePaint(Control c, PaintEventArgs e);
protected void InvokePaintBackground(Control c, PaintEventArgs e);
protected virtual bool IsInputChar(char charCode);
protected virtual bool IsInputKey(Keys keyData);
protected object MemberwiseClone();
protected virtual void NotifyInvalidate(Rectangle invalidatedArea);
protected virtual void OnBackColorChanged(EventArgs e);
protected virtual void OnBackgroundImageChanged(EventArgs e);
protected virtual void OnBindingContextChanged(EventArgs e);
protected virtual void OnCausesValidationChanged(EventArgs e);
protected virtual void OnChangeUICues(UICuesEventArgs e);
protected virtual void OnClick(EventArgs e);
protected virtual void OnContextMenuChanged(EventArgs e);
protected virtual void OnControlAdded(ControlEventArgs e);
protected virtual void OnControlRemoved(ControlEventArgs e);
protected virtual void OnCreateControl();
protected virtual void OnCursorChanged(EventArgs e);
protected virtual void OnDockChanged(EventArgs e);
protected virtual void OnDoubleClick(EventArgs e);
protected virtual void OnDragDrop(DragEventArgs drgevent);
protected virtual void OnDragEnter(DragEventArgs drgevent);
protected virtual void OnDragLeave(EventArgs e);
protected virtual void OnDragOver(DragEventArgs drgevent);
protected virtual void OnEnabledChanged(EventArgs e);
protected virtual void OnEnter(EventArgs e);
protected virtual void OnFontChanged(EventArgs e);
protected virtual void OnForeColorChanged(EventArgs e);
protected virtual void OnGiveFeedback(GiveFeedbackEventArgs gfbevent);
protected virtual void OnGotFocus(EventArgs e);
protected virtual void OnHandleCreated(EventArgs e);
protected virtual void OnHandleDestroyed(EventArgs e);
protected virtual void OnHelpRequested(HelpEventArgs hevent);
protected virtual void OnImeModeChanged(EventArgs e);
protected virtual void OnInvalidated(InvalidateEventArgs e);
protected virtual void OnKeyDown(KeyEventArgs e);
protected virtual void OnKeyPress(KeyPressEventArgs e);
protected virtual void OnKeyUp(KeyEventArgs e);
protected virtual void OnLayout(LayoutEventArgs levent);
protected virtual void OnLeave(EventArgs e);
protected virtual void OnLocationChanged(EventArgs e);
protected virtual void OnLostFocus(EventArgs e);
protected virtual void OnMouseDown(MouseEventArgs e);
protected virtual void OnMouseEnter(EventArgs e);
protected virtual void OnMouseHover(EventArgs e);
protected virtual void OnMouseLeave(EventArgs e);
protected virtual void OnMouseMove(MouseEventArgs e);
protected virtual void OnMouseUp(MouseEventArgs e);
protected virtual void OnMouseWheel(MouseEventArgs e);
protected virtual void OnMove(EventArgs e);
protected virtual void OnNotifyMessage(Message m);
protected override void OnPaint(PaintEventArgs e);
protected override void OnPaintBackground(PaintEventArgs e);
protected virtual void OnParentBackColorChanged(EventArgs e);
protected virtual void OnParentBackgroundImageChanged(EventArgs e);
protected virtual void OnParentBindingContextChanged(EventArgs e);
protected virtual void OnParentChanged(EventArgs e);
protected virtual void OnParentEnabledChanged(EventArgs e);
protected virtual void OnParentFontChanged(EventArgs e);
protected virtual void OnParentForeColorChanged(EventArgs e);
protected virtual void OnParentRightToLeftChanged(EventArgs e);
protected virtual void OnParentVisibleChanged(EventArgs e);
protected virtual void OnQueryContinueDrag(QueryContinueDragEventArgs qcdevent);
protected override void OnResize(EventArgs eventg);
protected virtual void OnRightToLeftChanged(EventArgs e);
protected virtual void OnSizeChanged(EventArgs e);
protected virtual void OnSizeModeChanged(EventArgs e);
protected virtual void OnStyleChanged(EventArgs e);
protected virtual void OnSystemColorsChanged(EventArgs e);
protected virtual void OnTabIndexChanged(EventArgs e);
protected virtual void OnTabStopChanged(EventArgs e);
protected virtual void OnTextChanged(EventArgs e);
protected virtual void OnValidated(EventArgs e);
protected virtual void OnValidating(CancelEventArgs e);
protected virtual void OnVisibleChanged(EventArgs e);
public void PerformLayout();
public void PerformLayout(Control affectedControl, string affectedProperty);
public Point PointToClient(Point p);
public Point PointToScreen(Point p);
public bool PreProcessMessage(ref Message msg);
protected virtual bool ProcessCmdKey(ref Message msg, Keys keyData);
protected virtual bool ProcessDialogChar(char charCode);
protected virtual bool ProcessDialogKey(Keys keyData);
protected virtual bool ProcessKeyEventArgs(ref Message m);
protected virtual bool ProcessKeyPreview(ref Message m);
protected virtual bool ProcessMnemonic(char charCode);
protected void RaiseDragEvent(object key, DragEventArgs e);
protected void RaiseKeyEvent(object key, KeyEventArgs e);
protected void RaiseMouseEvent(object key, MouseEventArgs e);
protected void RaisePaintEvent(object key, PaintEventArgs e);
protected void RecreateHandle();
public Rectangle RectangleToClient(Rectangle r);
public Rectangle RectangleToScreen(Rectangle r);
public virtual void Refresh();
public void remove_BackColorChanged(EventHandler value);
public void remove_BackgroundImageChanged(EventHandler value);
public void remove_BindingContextChanged(EventHandler value);
public void remove_CausesValidationChanged(EventHandler value);
public void remove_ChangeUICues(UICuesEventHandler value);
public void remove_Click(EventHandler value);
public void remove_ContextMenuChanged(EventHandler value);
public void remove_ControlAdded(ControlEventHandler value);
public void remove_ControlRemoved(ControlEventHandler value);
public void remove_CursorChanged(EventHandler value);
public void remove_Disposed(EventHandler value);
public void remove_DockChanged(EventHandler value);
public void remove_DoubleClick(EventHandler value);
public void remove_DragDrop(DragEventHandler value);
public void remove_DragEnter(DragEventHandler value);
public void remove_DragLeave(EventHandler value);
public void remove_DragOver(DragEventHandler value);
public void remove_EnabledChanged(EventHandler value);
public void remove_Enter(EventHandler value);
public void remove_FontChanged(EventHandler value);
public void remove_ForeColorChanged(EventHandler value);
public void remove_GiveFeedback(GiveFeedbackEventHandler value);
public void remove_GotFocus(EventHandler value);
public void remove_HandleCreated(EventHandler value);
public void remove_HandleDestroyed(EventHandler value);
public void remove_HelpRequested(HelpEventHandler value);
public void remove_ImeModeChanged(EventHandler value);
public void remove_Invalidated(InvalidateEventHandler value);
public void remove_KeyDown(KeyEventHandler value);
public void remove_KeyPress(KeyPressEventHandler value);
public void remove_KeyUp(KeyEventHandler value);
public void remove_Layout(LayoutEventHandler value);
public void remove_Leave(EventHandler value);
public void remove_LocationChanged(EventHandler value);
public void remove_LostFocus(EventHandler value);
public void remove_MouseDown(MouseEventHandler value);
public void remove_MouseEnter(EventHandler value);
public void remove_MouseHover(EventHandler value);
public void remove_MouseLeave(EventHandler value);
public void remove_MouseMove(MouseEventHandler value);
public void remove_MouseUp(MouseEventHandler value);
public void remove_MouseWheel(MouseEventHandler value);
public void remove_Move(EventHandler value);
public void remove_Paint(PaintEventHandler value);
public void remove_ParentChanged(EventHandler value);
public void remove_QueryAccessibilityHelp(QueryAccessibilityHelpEventHandler value);
public void remove_QueryContinueDrag(QueryContinueDragEventHandler value);
public void remove_Resize(EventHandler value);
public void remove_RightToLeftChanged(EventHandler value);
public void remove_SizeChanged(EventHandler value);
public void remove_SizeModeChanged(EventHandler value);
public void remove_StyleChanged(EventHandler value);
public void remove_SystemColorsChanged(EventHandler value);
public void remove_TabIndexChanged(EventHandler value);
public void remove_TabStopChanged(EventHandler value);
public void remove_TextChanged(EventHandler value);
public void remove_Validated(EventHandler value);
public void remove_Validating(CancelEventHandler value);
public void remove_VisibleChanged(EventHandler value);
public void ResetBackColor();
public void ResetBindings();
public void ResetCursor();
public void ResetFont();
public void ResetForeColor();
public void ResetImeMode();
protected void ResetMouseEventArgs();
public void ResetRightToLeft();
public void ResetText();
public void ResumeLayout();
public void ResumeLayout(bool performLayout);
protected ContentAlignment RtlTranslateAlignment(ContentAlignment align);
protected HorizontalAlignment RtlTranslateAlignment(HorizontalAlignment align);
protected LeftRightAlignment RtlTranslateAlignment(LeftRightAlignment align);
protected ContentAlignment RtlTranslateContent(ContentAlignment align);
protected HorizontalAlignment RtlTranslateHorizontal(HorizontalAlignment align);
protected LeftRightAlignment RtlTranslateLeftRight(LeftRightAlignment align);
public void Scale(float ratio);
public void Scale(float dx, float dy);
protected virtual void ScaleCore(float dx, float dy);
public void Select();
protected virtual void Select(bool directed, bool forward);
public bool SelectNextControl(Control ctl, bool forward, bool tabStopOnly, bool nested, bool wrap);
public void SendToBack();
public void SetBounds(int x, int y, int width, int height);
public void SetBounds(int x, int y, int width, int height, BoundsSpecified specified);
protected virtual void SetBoundsCore(int x, int y, int width, int height, BoundsSpecified specified);
protected virtual void SetClientSizeCore(int x, int y);
protected void SetStyle(ControlStyles flag, bool value);
protected void SetTopLevel(bool value);
protected virtual void SetVisibleCore(bool value);
public void Show();
public void SuspendLayout();
public virtual string ToString();
public void Update();
protected void UpdateBounds();
protected void UpdateBounds(int x, int y, int width, int height);
protected void UpdateBounds(int x, int y, int width, int height, int clientWidth, int clientHeight);
protected void UpdateStyles();
protected void UpdateZOrder();
protected virtual void WndProc(ref Message m);

Property
public AccessibleObject AccessibilityObject {get;}
public string AccessibleDefaultActionDescription {get; set;}
public string AccessibleDescription {get; set;}
public string AccessibleName {get; set;}
public AccessibleRole AccessibleRole {get; set;}
public override bool AllowDrop {get; set;}
public AnchorStyles Anchor {get; set;}
public virtual Color BackColor {get; set;}
public Image BackgroundImage {get; set;}
public virtual BindingContext BindingContext {get; set;}
public BorderStyle BorderStyle {get; set;}
public int Bottom {get;}
public Rectangle Bounds {get; set;}
public bool CanFocus {get;}
public bool CanSelect {get;}
public bool Capture {get; set;}
public bool CausesValidation {get; set;}
public Rectangle ClientRectangle {get;}
public Size ClientSize {get; set;}
public string CompanyName {get;}
public IContainer Container {get;}
public bool ContainsFocus {get;}
public ContextMenu ContextMenu {get; set;}
public ControlCollection Controls {get;}
public bool Created {get;}
protected virtual CreateParams CreateParams {get;}
public Cursor Cursor {get; set;}
public ControlBindingsCollection DataBindings {get;}
protected virtual ImeMode DefaultImeMode {get;}
protected virtual Size DefaultSize {get;}
protected bool DesignMode {get;}
public Rectangle DisplayRectangle {get;}
public bool Disposing {get;}
public DockStyle Dock {get; set;}
public bool Enabled {get; set;}
protected EventHandlerList Events {get;}
public bool Focused {get;}
public virtual Font Font {get; set;}
protected int FontHeight {get; set;}
public virtual Color ForeColor {get; set;}
public IntPtr Handle {get;}
public bool HasChildren {get;}
public int Height {get; set;}
public Image Image {get; set;}
public ImeMode ImeMode {get; set;}
public bool InvokeRequired {get;}
public bool IsAccessible {get; set;}
public bool IsDisposed {get;}
public bool IsHandleCreated {get;}
public int Left {get; set;}
public Point Location {get; set;}
public string Name {get; set;}
public Control Parent {get; set;}
public string ProductName {get;}
public string ProductVersion {get;}
public bool RecreatingHandle {get;}
public Region Region {get; set;}
protected bool RenderRightToLeft {get;}
protected bool ResizeRedraw {get; set;}
public int Right {get;}
public override RightToLeft RightToLeft {get; set;}
protected virtual bool ShowFocusCues {get;}
protected bool ShowKeyboardCues {get;}
public ISite Site {get; set;}
public Size Size {get; set;}
public PictureBoxSizeMode SizeMode {get; set;}
public int TabIndex {get; set;}
public bool TabStop {get; set;}
public object Tag {get; set;}
public virtual string Text {get; set;}
public int Top {get; set;}
public Control TopLevelControl {get;}
public bool Visible {get; set;}
public int Width {get; set;}
public IWindowTarget WindowTarget {get; set;}

System.Windows.Forms.Panel

Module:System.Windows.Forms.dll

Hierarchy
Object
MarshalByRefObject
Component
Control
ScrollableControl
Panel

Type declaration

[C#] public class Panel : ScrollableControl;

Constructor
public Panel();

Method
protected void AccessibilityNotifyClients(AccessibleEvents accEvent, int childID);
public void add_BackColorChanged(EventHandler value);
public void add_BackgroundImageChanged(EventHandler value);
public void add_BindingContextChanged(EventHandler value);
public void add_CausesValidationChanged(EventHandler value);
public void add_ChangeUICues(UICuesEventHandler value);
public void add_Click(EventHandler value);
public void add_ContextMenuChanged(EventHandler value);
public void add_ControlAdded(ControlEventHandler value);
public void add_ControlRemoved(ControlEventHandler value);
public void add_CursorChanged(EventHandler value);
public void add_Disposed(EventHandler value);
public void add_DockChanged(EventHandler value);
public void add_DoubleClick(EventHandler value);
public void add_DragDrop(DragEventHandler value);
public void add_DragEnter(DragEventHandler value);
public void add_DragLeave(EventHandler value);
public void add_DragOver(DragEventHandler value);
public void add_EnabledChanged(EventHandler value);
public void add_Enter(EventHandler value);
public void add_FontChanged(EventHandler value);
public void add_ForeColorChanged(EventHandler value);
public void add_GiveFeedback(GiveFeedbackEventHandler value);
public void add_GotFocus(EventHandler value);
public void add_HandleCreated(EventHandler value);
public void add_HandleDestroyed(EventHandler value);
public void add_HelpRequested(HelpEventHandler value);
public void add_ImeModeChanged(EventHandler value);
public void add_Invalidated(InvalidateEventHandler value);
public void add_KeyDown(KeyEventHandler value);
public void add_KeyPress(KeyPressEventHandler value);
public void add_KeyUp(KeyEventHandler value);
public void add_Layout(LayoutEventHandler value);
public void add_Leave(EventHandler value);
public void add_LocationChanged(EventHandler value);
public void add_LostFocus(EventHandler value);
public void add_MouseDown(MouseEventHandler value);
public void add_MouseEnter(EventHandler value);
public void add_MouseHover(EventHandler value);
public void add_MouseLeave(EventHandler value);
public void add_MouseMove(MouseEventHandler value);
public void add_MouseUp(MouseEventHandler value);
public void add_MouseWheel(MouseEventHandler value);
public void add_Move(EventHandler value);
public void add_Paint(PaintEventHandler value);
public void add_ParentChanged(EventHandler value);
public void add_QueryAccessibilityHelp(QueryAccessibilityHelpEventHandler value);
public void add_QueryContinueDrag(QueryContinueDragEventHandler value);
public void add_Resize(EventHandler value);
public void add_RightToLeftChanged(EventHandler value);
public void add_SizeChanged(EventHandler value);
public void add_StyleChanged(EventHandler value);
public void add_SystemColorsChanged(EventHandler value);
public void add_TabIndexChanged(EventHandler value);
public void add_TabStopChanged(EventHandler value);
public void add_TextChanged(EventHandler value);
public void add_Validated(EventHandler value);
public void add_Validating(CancelEventHandler value);
public void add_VisibleChanged(EventHandler value);
protected virtual void AdjustFormScrollbars(bool displayScrollbars);
public IAsyncResult BeginInvoke(Delegate method);
public IAsyncResult BeginInvoke(Delegate method, object[] args);
public void BringToFront();
public bool Contains(Control ctl);
protected virtual AccessibleObject CreateAccessibilityInstance();
public void CreateControl();
protected virtual ControlCollection CreateControlsInstance();
public Graphics CreateGraphics();
protected virtual void CreateHandle();
public ObjRef CreateObjRef(Type requestedType);
protected virtual void DefWndProc(ref Message m);
protected virtual void DestroyHandle();
public void Dispose();
protected override void Dispose(bool disposing);
public DragDropEffects DoDragDrop(object data, DragDropEffects allowedEffects);
public object EndInvoke(IAsyncResult asyncResult);
public virtual bool Equals(object obj);
protected override void Finalize();
public Form FindForm();
public bool Focus();
public Control GetChildAtPoint(Point pt);
public IContainerControl GetContainerControl();
public virtual int GetHashCode();
public object GetLifetimeService();
public Control GetNextControl(Control ctl, bool forward);
protected bool GetScrollState(int bit);
protected virtual object GetService(Type service);
protected bool GetStyle(ControlStyles flag);
protected bool GetTopLevel();
public Type GetType();
public void Hide();
public object InitializeLifetimeService();
protected virtual void InitLayout();
public void Invalidate();
public void Invalidate(bool invalidateChildren);
public void Invalidate(Rectangle rect);
public void Invalidate(Rectangle rc, bool invalidateChildren);
public void Invalidate(Region region);
public void Invalidate(Region region, bool invalidateChildren);
public object Invoke(Delegate method);
public object Invoke(Delegate method, object[] args);
protected void InvokeGotFocus(Control toInvoke, EventArgs e);
protected void InvokeLostFocus(Control toInvoke, EventArgs e);
protected void InvokeOnClick(Control toInvoke, EventArgs e);
protected void InvokePaint(Control c, PaintEventArgs e);
protected void InvokePaintBackground(Control c, PaintEventArgs e);
protected virtual bool IsInputChar(char charCode);
protected virtual bool IsInputKey(Keys keyData);
protected object MemberwiseClone();
protected virtual void NotifyInvalidate(Rectangle invalidatedArea);
protected virtual void OnBackColorChanged(EventArgs e);
protected virtual void OnBackgroundImageChanged(EventArgs e);
protected virtual void OnBindingContextChanged(EventArgs e);
protected virtual void OnCausesValidationChanged(EventArgs e);
protected virtual void OnChangeUICues(UICuesEventArgs e);
protected virtual void OnClick(EventArgs e);
protected virtual void OnContextMenuChanged(EventArgs e);
protected virtual void OnControlAdded(ControlEventArgs e);
protected virtual void OnControlRemoved(ControlEventArgs e);
protected virtual void OnCreateControl();
protected virtual void OnCursorChanged(EventArgs e);
protected virtual void OnDockChanged(EventArgs e);
protected virtual void OnDoubleClick(EventArgs e);
protected virtual void OnDragDrop(DragEventArgs drgevent);
protected virtual void OnDragEnter(DragEventArgs drgevent);
protected virtual void OnDragLeave(EventArgs e);
protected virtual void OnDragOver(DragEventArgs drgevent);
protected virtual void OnEnabledChanged(EventArgs e);
protected virtual void OnEnter(EventArgs e);
protected virtual void OnFontChanged(EventArgs e);
protected virtual void OnForeColorChanged(EventArgs e);
protected virtual void OnGiveFeedback(GiveFeedbackEventArgs gfbevent);
protected virtual void OnGotFocus(EventArgs e);
protected virtual void OnHandleCreated(EventArgs e);
protected virtual void OnHandleDestroyed(EventArgs e);
protected virtual void OnHelpRequested(HelpEventArgs hevent);
protected virtual void OnImeModeChanged(EventArgs e);
protected virtual void OnInvalidated(InvalidateEventArgs e);
protected virtual void OnKeyDown(KeyEventArgs e);
protected virtual void OnKeyPress(KeyPressEventArgs e);
protected virtual void OnKeyUp(KeyEventArgs e);
protected virtual void OnLayout(LayoutEventArgs levent);
protected virtual void OnLeave(EventArgs e);
protected virtual void OnLocationChanged(EventArgs e);
protected virtual void OnLostFocus(EventArgs e);
protected virtual void OnMouseDown(MouseEventArgs e);
protected virtual void OnMouseEnter(EventArgs e);
protected virtual void OnMouseHover(EventArgs e);
protected virtual void OnMouseLeave(EventArgs e);
protected virtual void OnMouseMove(MouseEventArgs e);
protected virtual void OnMouseUp(MouseEventArgs e);
protected virtual void OnMouseWheel(MouseEventArgs e);
protected virtual void OnMove(EventArgs e);
protected virtual void OnNotifyMessage(Message m);
protected virtual void OnPaint(PaintEventArgs e);
protected virtual void OnPaintBackground(PaintEventArgs e);
protected virtual void OnParentBackColorChanged(EventArgs e);
protected virtual void OnParentBackgroundImageChanged(EventArgs e);
protected virtual void OnParentBindingContextChanged(EventArgs e);
protected virtual void OnParentChanged(EventArgs e);
protected virtual void OnParentEnabledChanged(EventArgs e);
protected virtual void OnParentFontChanged(EventArgs e);
protected virtual void OnParentForeColorChanged(EventArgs e);
protected virtual void OnParentRightToLeftChanged(EventArgs e);
protected virtual void OnParentVisibleChanged(EventArgs e);
protected virtual void OnQueryContinueDrag(QueryContinueDragEventArgs qcdevent);
protected virtual void OnResize(EventArgs e);
protected virtual void OnRightToLeftChanged(EventArgs e);
protected virtual void OnSizeChanged(EventArgs e);
protected virtual void OnStyleChanged(EventArgs e);
protected virtual void OnSystemColorsChanged(EventArgs e);
protected virtual void OnTabIndexChanged(EventArgs e);
protected virtual void OnTabStopChanged(EventArgs e);
protected virtual void OnTextChanged(EventArgs e);
protected virtual void OnValidated(EventArgs e);
protected virtual void OnValidating(CancelEventArgs e);
protected virtual void OnVisibleChanged(EventArgs e);
public void PerformLayout();
public void PerformLayout(Control affectedControl, string affectedProperty);
public Point PointToClient(Point p);
public Point PointToScreen(Point p);
public bool PreProcessMessage(ref Message msg);
protected virtual bool ProcessCmdKey(ref Message msg, Keys keyData);
protected virtual bool ProcessDialogChar(char charCode);
protected virtual bool ProcessDialogKey(Keys keyData);
protected virtual bool ProcessKeyEventArgs(ref Message m);
protected virtual bool ProcessKeyPreview(ref Message m);
protected virtual bool ProcessMnemonic(char charCode);
protected void RaiseDragEvent(object key, DragEventArgs e);
protected void RaiseKeyEvent(object key, KeyEventArgs e);
protected void RaiseMouseEvent(object key, MouseEventArgs e);
protected void RaisePaintEvent(object key, PaintEventArgs e);
protected void RecreateHandle();
public Rectangle RectangleToClient(Rectangle r);
public Rectangle RectangleToScreen(Rectangle r);
public virtual void Refresh();
public void remove_BackColorChanged(EventHandler value);
public void remove_BackgroundImageChanged(EventHandler value);
public void remove_BindingContextChanged(EventHandler value);
public void remove_CausesValidationChanged(EventHandler value);
public void remove_ChangeUICues(UICuesEventHandler value);
public void remove_Click(EventHandler value);
public void remove_ContextMenuChanged(EventHandler value);
public void remove_ControlAdded(ControlEventHandler value);
public void remove_ControlRemoved(ControlEventHandler value);
public void remove_CursorChanged(EventHandler value);
public void remove_Disposed(EventHandler value);
public void remove_DockChanged(EventHandler value);
public void remove_DoubleClick(EventHandler value);
public void remove_DragDrop(DragEventHandler value);
public void remove_DragEnter(DragEventHandler value);
public void remove_DragLeave(EventHandler value);
public void remove_DragOver(DragEventHandler value);
public void remove_EnabledChanged(EventHandler value);
public void remove_Enter(EventHandler value);
public void remove_FontChanged(EventHandler value);
public void remove_ForeColorChanged(EventHandler value);
public void remove_GiveFeedback(GiveFeedbackEventHandler value);
public void remove_GotFocus(EventHandler value);
public void remove_HandleCreated(EventHandler value);
public void remove_HandleDestroyed(EventHandler value);
public void remove_HelpRequested(HelpEventHandler value);
public void remove_ImeModeChanged(EventHandler value);
public void remove_Invalidated(InvalidateEventHandler value);
public void remove_KeyDown(KeyEventHandler value);
public void remove_KeyPress(KeyPressEventHandler value);
public void remove_KeyUp(KeyEventHandler value);
public void remove_Layout(LayoutEventHandler value);
public void remove_Leave(EventHandler value);
public void remove_LocationChanged(EventHandler value);
public void remove_LostFocus(EventHandler value);
public void remove_MouseDown(MouseEventHandler value);
public void remove_MouseEnter(EventHandler value);
public void remove_MouseHover(EventHandler value);
public void remove_MouseLeave(EventHandler value);
public void remove_MouseMove(MouseEventHandler value);
public void remove_MouseUp(MouseEventHandler value);
public void remove_MouseWheel(MouseEventHandler value);
public void remove_Move(EventHandler value);
public void remove_Paint(PaintEventHandler value);
public void remove_ParentChanged(EventHandler value);
public void remove_QueryAccessibilityHelp(QueryAccessibilityHelpEventHandler value);
public void remove_QueryContinueDrag(QueryContinueDragEventHandler value);
public void remove_Resize(EventHandler value);
public void remove_RightToLeftChanged(EventHandler value);
public void remove_SizeChanged(EventHandler value);
public void remove_StyleChanged(EventHandler value);
public void remove_SystemColorsChanged(EventHandler value);
public void remove_TabIndexChanged(EventHandler value);
public void remove_TabStopChanged(EventHandler value);
public void remove_TextChanged(EventHandler value);
public void remove_Validated(EventHandler value);
public void remove_Validating(CancelEventHandler value);
public void remove_VisibleChanged(EventHandler value);
public void ResetBackColor();
public void ResetBindings();
public void ResetCursor();
public void ResetFont();
public void ResetForeColor();
public void ResetImeMode();
protected void ResetMouseEventArgs();
public void ResetRightToLeft();
public void ResetText();
public void ResumeLayout();
public void ResumeLayout(bool performLayout);
protected ContentAlignment RtlTranslateAlignment(ContentAlignment align);
protected HorizontalAlignment RtlTranslateAlignment(HorizontalAlignment align);
protected LeftRightAlignment RtlTranslateAlignment(LeftRightAlignment align);
protected ContentAlignment RtlTranslateContent(ContentAlignment align);
protected HorizontalAlignment RtlTranslateHorizontal(HorizontalAlignment align);
protected LeftRightAlignment RtlTranslateLeftRight(LeftRightAlignment align);
public void Scale(float ratio);
public void Scale(float dx, float dy);
protected virtual void ScaleCore(float dx, float dy);
public void ScrollControlIntoView(Control activeControl);
public void Select();
protected virtual void Select(bool directed, bool forward);
public bool SelectNextControl(Control ctl, bool forward, bool tabStopOnly, bool nested, bool wrap);
public void SendToBack();
public void SetAutoScrollMargin(int x, int y);
public void SetBounds(int x, int y, int width, int height);
public void SetBounds(int x, int y, int width, int height, BoundsSpecified specified);
protected virtual void SetBoundsCore(int x, int y, int width, int height, BoundsSpecified specified);
protected virtual void SetClientSizeCore(int x, int y);
protected void SetDisplayRectLocation(int x, int y);
protected void SetScrollState(int bit, bool value);
protected void SetStyle(ControlStyles flag, bool value);
protected void SetTopLevel(bool value);
protected virtual void SetVisibleCore(bool value);
public void Show();
public void SuspendLayout();
public virtual string ToString();
public void Update();
protected void UpdateBounds();
protected void UpdateBounds(int x, int y, int width, int height);
protected void UpdateBounds(int x, int y, int width, int height, int clientWidth, int clientHeight);
protected void UpdateStyles();
protected void UpdateZOrder();
protected virtual void WndProc(ref Message m);

Property
public AccessibleObject AccessibilityObject {get;}
public string AccessibleDefaultActionDescription {get; set;}
public string AccessibleDescription {get; set;}
public string AccessibleName {get; set;}
public AccessibleRole AccessibleRole {get; set;}
public bool AllowDrop {get; set;}
public AnchorStyles Anchor {get; set;}
public bool AutoScroll {get; set;}
public Size AutoScrollMargin {get; set;}
public Size AutoScrollMinSize {get; set;}
public Point AutoScrollPosition {get; set;}
public virtual Color BackColor {get; set;}
public Image BackgroundImage {get; set;}
public virtual BindingContext BindingContext {get; set;}
public BorderStyle BorderStyle {get; set;}
public int Bottom {get;}
public Rectangle Bounds {get; set;}
public bool CanFocus {get;}
public bool CanSelect {get;}
public bool Capture {get; set;}
public bool CausesValidation {get; set;}
public Rectangle ClientRectangle {get;}
public Size ClientSize {get; set;}
public string CompanyName {get;}
public IContainer Container {get;}
public bool ContainsFocus {get;}
public ContextMenu ContextMenu {get; set;}
public ControlCollection Controls {get;}
public bool Created {get;}
protected virtual CreateParams CreateParams {get;}
public Cursor Cursor {get; set;}
public ControlBindingsCollection DataBindings {get;}
protected virtual ImeMode DefaultImeMode {get;}
protected virtual Size DefaultSize {get;}
protected bool DesignMode {get;}
public Rectangle DisplayRectangle {get;}
public bool Disposing {get;}
public DockStyle Dock {get; set;}
public DockPaddingEdges DockPadding {get;}
public bool Enabled {get; set;}
protected EventHandlerList Events {get;}
public bool Focused {get;}
public virtual Font Font {get; set;}
protected int FontHeight {get; set;}
public virtual Color ForeColor {get; set;}
public IntPtr Handle {get;}
public bool HasChildren {get;}
public int Height {get; set;}
protected bool HScroll {get; set;}
public ImeMode ImeMode {get; set;}
public bool InvokeRequired {get;}
public bool IsAccessible {get; set;}
public bool IsDisposed {get;}
public bool IsHandleCreated {get;}
public int Left {get; set;}
public Point Location {get; set;}
public string Name {get; set;}
public Control Parent {get; set;}
public string ProductName {get;}
public string ProductVersion {get;}
public bool RecreatingHandle {get;}
public Region Region {get; set;}
protected bool RenderRightToLeft {get;}
protected bool ResizeRedraw {get; set;}
public int Right {get;}
public RightToLeft RightToLeft {get; set;}
protected virtual bool ShowFocusCues {get;}
protected bool ShowKeyboardCues {get;}
public ISite Site {get; set;}
public Size Size {get; set;}
public int TabIndex {get; set;}
public bool TabStop {get; set;}
public object Tag {get; set;}
public virtual string Text {get; set;}
public int Top {get; set;}
public Control TopLevelControl {get;}
public bool Visible {get; set;}
protected bool VScroll {get; set;}
public int Width {get; set;}
public IWindowTarget WindowTarget {get; set;}

System.Windows.Forms.PaintEventHandler

Module:System.Windows.Forms.dll

Hierarchy
Object
Delegate
MulticastDelegate
PaintEventHandler

Type declaration

[C#] public delegate void PaintEventHandler(object sender, PaintEventArgs e);

Constructor
public PaintEventHandler(object object, IntPtr method);

Method
public virtual IAsyncResult BeginInvoke(object sender, PaintEventArgs e, AsyncCallback callback, object object);
public object Clone();
protected override Delegate CombineImpl(Delegate follow);
public object DynamicInvoke(object[] args);
protected virtual object DynamicInvokeImpl(object[] args);
public virtual void EndInvoke(IAsyncResult result);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public override Delegate[] GetInvocationList();
protected virtual MethodInfo GetMethodImpl();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
public override void Invoke(object sender, PaintEventArgs e);
protected object MemberwiseClone();
protected override Delegate RemoveImpl(Delegate value);
public virtual string ToString();

Property
public MethodInfo Method {get;}
public object Target {get;}

System.Windows.Forms.PaintEventArgs

Module:System.Windows.Forms.dll

Hierarchy
Object
EventArgs
PaintEventArgs

Type declaration

[C#] public class PaintEventArgs : EventArgs;

Constructor
public PaintEventArgs(Graphics graphics, Rectangle clipRect);

Method
public virtual void Dispose();
protected virtual void Dispose(bool disposing);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public Rectangle ClipRectangle {get;}
public Graphics Graphics {get;}

System.Windows.Forms.NumericUpDown

Module:System.Windows.Forms.dll

Hierarchy
Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UpDownBase
NumericUpDown

Type declaration

[C#] public class NumericUpDown : UpDownBase;

Constructor
public NumericUpDown();

Method
protected void AccessibilityNotifyClients(AccessibleEvents accEvent, int childID);
public void add_BackColorChanged(EventHandler value);
public void add_BackgroundImageChanged(EventHandler value);
public void add_BindingContextChanged(EventHandler value);
public void add_CausesValidationChanged(EventHandler value);
public void add_ChangeUICues(UICuesEventHandler value);
public void add_Click(EventHandler value);
public void add_ContextMenuChanged(EventHandler value);
public void add_ControlAdded(ControlEventHandler value);
public void add_ControlRemoved(ControlEventHandler value);
public void add_CursorChanged(EventHandler value);
public void add_Disposed(EventHandler value);
public void add_DockChanged(EventHandler value);
public void add_DoubleClick(EventHandler value);
public void add_DragDrop(DragEventHandler value);
public void add_DragEnter(DragEventHandler value);
public void add_DragLeave(EventHandler value);
public void add_DragOver(DragEventHandler value);
public void add_EnabledChanged(EventHandler value);
public void add_Enter(EventHandler value);
public void add_FontChanged(EventHandler value);
public void add_ForeColorChanged(EventHandler value);
public void add_GiveFeedback(GiveFeedbackEventHandler value);
public void add_GotFocus(EventHandler value);
public void add_HandleCreated(EventHandler value);
public void add_HandleDestroyed(EventHandler value);
public void add_HelpRequested(HelpEventHandler value);
public void add_ImeModeChanged(EventHandler value);
public void add_Invalidated(InvalidateEventHandler value);
public void add_KeyDown(KeyEventHandler value);
public void add_KeyPress(KeyPressEventHandler value);
public void add_KeyUp(KeyEventHandler value);
public void add_Layout(LayoutEventHandler value);
public void add_Leave(EventHandler value);
public void add_LocationChanged(EventHandler value);
public void add_LostFocus(EventHandler value);
public void add_MouseDown(MouseEventHandler value);
public void add_MouseEnter(EventHandler value);
public void add_MouseHover(EventHandler value);
public void add_MouseLeave(EventHandler value);
public void add_MouseMove(MouseEventHandler value);
public void add_MouseUp(MouseEventHandler value);
public void add_MouseWheel(MouseEventHandler value);
public void add_Move(EventHandler value);
public void add_Paint(PaintEventHandler value);
public void add_ParentChanged(EventHandler value);
public void add_QueryAccessibilityHelp(QueryAccessibilityHelpEventHandler value);
public void add_QueryContinueDrag(QueryContinueDragEventHandler value);
public void add_Resize(EventHandler value);
public void add_RightToLeftChanged(EventHandler value);
public void add_SizeChanged(EventHandler value);
public void add_StyleChanged(EventHandler value);
public void add_SystemColorsChanged(EventHandler value);
public void add_TabIndexChanged(EventHandler value);
public void add_TabStopChanged(EventHandler value);
public void add_TextChanged(EventHandler value);
public void add_Validated(EventHandler value);
public void add_Validating(CancelEventHandler value);
public void add_ValueChanged(EventHandler value);
public void add_VisibleChanged(EventHandler value);
protected virtual void AdjustFormScrollbars(bool displayScrollbars);
public virtual void BeginInit();
public IAsyncResult BeginInvoke(Delegate method);
public IAsyncResult BeginInvoke(Delegate method, object[] args);
public void BringToFront();
public bool Contains(Control ctl);
protected virtual AccessibleObject CreateAccessibilityInstance();
public void CreateControl();
protected virtual ControlCollection CreateControlsInstance();
public Graphics CreateGraphics();
protected virtual void CreateHandle();
public ObjRef CreateObjRef(Type requestedType);
protected virtual void DefWndProc(ref Message m);
protected virtual void DestroyHandle();
public void Dispose();
protected override void Dispose(bool disposing);
public DragDropEffects DoDragDrop(object data, DragDropEffects allowedEffects);
public override void DownButton();
public virtual void EndInit();
public object EndInvoke(IAsyncResult asyncResult);
public virtual bool Equals(object obj);
protected override void Finalize();
public Form FindForm();
public bool Focus();
public Control GetChildAtPoint(Point pt);
public IContainerControl GetContainerControl();
public virtual int GetHashCode();
public object GetLifetimeService();
public Control GetNextControl(Control ctl, bool forward);
protected bool GetScrollState(int bit);
protected virtual object GetService(Type service);
protected bool GetStyle(ControlStyles flag);
protected bool GetTopLevel();
public Type GetType();
public void Hide();
public object InitializeLifetimeService();
protected virtual void InitLayout();
public void Invalidate();
public void Invalidate(bool invalidateChildren);
public void Invalidate(Rectangle rect);
public void Invalidate(Rectangle rc, bool invalidateChildren);
public void Invalidate(Region region);
public void Invalidate(Region region, bool invalidateChildren);
public object Invoke(Delegate method);
public object Invoke(Delegate method, object[] args);
protected void InvokeGotFocus(Control toInvoke, EventArgs e);
protected void InvokeLostFocus(Control toInvoke, EventArgs e);
protected void InvokeOnClick(Control toInvoke, EventArgs e);
protected void InvokePaint(Control c, PaintEventArgs e);
protected void InvokePaintBackground(Control c, PaintEventArgs e);
protected virtual bool IsInputChar(char charCode);
protected virtual bool IsInputKey(Keys keyData);
protected object MemberwiseClone();
protected virtual void NotifyInvalidate(Rectangle invalidatedArea);
protected virtual void OnBackColorChanged(EventArgs e);
protected virtual void OnBackgroundImageChanged(EventArgs e);
protected virtual void OnBindingContextChanged(EventArgs e);
protected virtual void OnCausesValidationChanged(EventArgs e);
protected virtual void OnChanged(object source, EventArgs e);
protected virtual void OnChangeUICues(UICuesEventArgs e);
protected virtual void OnClick(EventArgs e);
protected virtual void OnContextMenuChanged(EventArgs e);
protected virtual void OnControlAdded(ControlEventArgs e);
protected virtual void OnControlRemoved(ControlEventArgs e);
protected virtual void OnCreateControl();
protected virtual void OnCursorChanged(EventArgs e);
protected virtual void OnDockChanged(EventArgs e);
protected virtual void OnDoubleClick(EventArgs e);
protected virtual void OnDragDrop(DragEventArgs drgevent);
protected virtual void OnDragEnter(DragEventArgs drgevent);
protected virtual void OnDragLeave(EventArgs e);
protected virtual void OnDragOver(DragEventArgs drgevent);
protected virtual void OnEnabledChanged(EventArgs e);
protected virtual void OnEnter(EventArgs e);
protected virtual void OnFontChanged(EventArgs e);
protected virtual void OnForeColorChanged(EventArgs e);
protected virtual void OnGiveFeedback(GiveFeedbackEventArgs gfbevent);
protected virtual void OnGotFocus(EventArgs e);
protected virtual void OnHandleCreated(EventArgs e);
protected virtual void OnHandleDestroyed(EventArgs e);
protected virtual void OnHelpRequested(HelpEventArgs hevent);
protected virtual void OnImeModeChanged(EventArgs e);
protected virtual void OnInvalidated(InvalidateEventArgs e);
protected virtual void OnKeyDown(KeyEventArgs e);
protected virtual void OnKeyPress(KeyPressEventArgs e);
protected virtual void OnKeyUp(KeyEventArgs e);
protected virtual void OnLayout(LayoutEventArgs e);
protected virtual void OnLeave(EventArgs e);
protected virtual void OnLocationChanged(EventArgs e);
protected virtual void OnLostFocus(EventArgs e);
protected virtual void OnMouseDown(MouseEventArgs e);
protected virtual void OnMouseEnter(EventArgs e);
protected virtual void OnMouseHover(EventArgs e);
protected virtual void OnMouseLeave(EventArgs e);
protected virtual void OnMouseMove(MouseEventArgs e);
protected virtual void OnMouseUp(MouseEventArgs e);
protected virtual void OnMouseWheel(MouseEventArgs e);
protected virtual void OnMove(EventArgs e);
protected virtual void OnNotifyMessage(Message m);
protected virtual void OnPaint(PaintEventArgs e);
protected virtual void OnPaintBackground(PaintEventArgs e);
protected virtual void OnParentBackColorChanged(EventArgs e);
protected virtual void OnParentBackgroundImageChanged(EventArgs e);
protected virtual void OnParentBindingContextChanged(EventArgs e);
protected virtual void OnParentChanged(EventArgs e);
protected virtual void OnParentEnabledChanged(EventArgs e);
protected virtual void OnParentFontChanged(EventArgs e);
protected virtual void OnParentForeColorChanged(EventArgs e);
protected virtual void OnParentRightToLeftChanged(EventArgs e);
protected virtual void OnParentVisibleChanged(EventArgs e);
protected virtual void OnQueryContinueDrag(QueryContinueDragEventArgs qcdevent);
protected virtual void OnResize(EventArgs e);
protected virtual void OnRightToLeftChanged(EventArgs e);
protected virtual void OnSizeChanged(EventArgs e);
protected virtual void OnStyleChanged(EventArgs e);
protected virtual void OnSystemColorsChanged(EventArgs e);
protected virtual void OnTabIndexChanged(EventArgs e);
protected virtual void OnTabStopChanged(EventArgs e);
protected virtual void OnTextBoxKeyDown(object source, KeyEventArgs e);
protected virtual void OnTextBoxKeyPress(object source, KeyPressEventArgs e);
protected virtual void OnTextBoxLostFocus(object source, EventArgs e);
protected virtual void OnTextBoxResize(object source, EventArgs e);
protected virtual void OnTextBoxTextChanged(object source, EventArgs e);
protected virtual void OnTextChanged(EventArgs e);
protected virtual void OnValidated(EventArgs e);
protected virtual void OnValidating(CancelEventArgs e);
protected virtual void OnValueChanged(EventArgs eventg);
protected virtual void OnVisibleChanged(EventArgs e);
protected void ParseEditText();
public void PerformLayout();
public void PerformLayout(Control affectedControl, string affectedProperty);
public Point PointToClient(Point p);
public Point PointToScreen(Point p);
public bool PreProcessMessage(ref Message msg);
protected virtual bool ProcessCmdKey(ref Message msg, Keys keyData);
protected virtual bool ProcessDialogChar(char charCode);
protected virtual bool ProcessDialogKey(Keys keyData);
protected virtual bool ProcessKeyEventArgs(ref Message m);
protected virtual bool ProcessKeyPreview(ref Message m);
protected virtual bool ProcessMnemonic(char charCode);
protected virtual bool ProcessTabKey(bool forward);
protected void RaiseDragEvent(object key, DragEventArgs e);
protected void RaiseKeyEvent(object key, KeyEventArgs e);
protected void RaiseMouseEvent(object key, MouseEventArgs e);
protected void RaisePaintEvent(object key, PaintEventArgs e);
protected void RecreateHandle();
public Rectangle RectangleToClient(Rectangle r);
public Rectangle RectangleToScreen(Rectangle r);
public virtual void Refresh();
public void remove_BackColorChanged(EventHandler value);
public void remove_BackgroundImageChanged(EventHandler value);
public void remove_BindingContextChanged(EventHandler value);
public void remove_CausesValidationChanged(EventHandler value);
public void remove_ChangeUICues(UICuesEventHandler value);
public void remove_Click(EventHandler value);
public void remove_ContextMenuChanged(EventHandler value);
public void remove_ControlAdded(ControlEventHandler value);
public void remove_ControlRemoved(ControlEventHandler value);
public void remove_CursorChanged(EventHandler value);
public void remove_Disposed(EventHandler value);
public void remove_DockChanged(EventHandler value);
public void remove_DoubleClick(EventHandler value);
public void remove_DragDrop(DragEventHandler value);
public void remove_DragEnter(DragEventHandler value);
public void remove_DragLeave(EventHandler value);
public void remove_DragOver(DragEventHandler value);
public void remove_EnabledChanged(EventHandler value);
public void remove_Enter(EventHandler value);
public void remove_FontChanged(EventHandler value);
public void remove_ForeColorChanged(EventHandler value);
public void remove_GiveFeedback(GiveFeedbackEventHandler value);
public void remove_GotFocus(EventHandler value);
public void remove_HandleCreated(EventHandler value);
public void remove_HandleDestroyed(EventHandler value);
public void remove_HelpRequested(HelpEventHandler value);
public void remove_ImeModeChanged(EventHandler value);
public void remove_Invalidated(InvalidateEventHandler value);
public void remove_KeyDown(KeyEventHandler value);
public void remove_KeyPress(KeyPressEventHandler value);
public void remove_KeyUp(KeyEventHandler value);
public void remove_Layout(LayoutEventHandler value);
public void remove_Leave(EventHandler value);
public void remove_LocationChanged(EventHandler value);
public void remove_LostFocus(EventHandler value);
public void remove_MouseDown(MouseEventHandler value);
public void remove_MouseEnter(EventHandler value);
public void remove_MouseHover(EventHandler value);
public void remove_MouseLeave(EventHandler value);
public void remove_MouseMove(MouseEventHandler value);
public void remove_MouseUp(MouseEventHandler value);
public void remove_MouseWheel(MouseEventHandler value);
public void remove_Move(EventHandler value);
public void remove_Paint(PaintEventHandler value);
public void remove_ParentChanged(EventHandler value);
public void remove_QueryAccessibilityHelp(QueryAccessibilityHelpEventHandler value);
public void remove_QueryContinueDrag(QueryContinueDragEventHandler value);
public void remove_Resize(EventHandler value);
public void remove_RightToLeftChanged(EventHandler value);
public void remove_SizeChanged(EventHandler value);
public void remove_StyleChanged(EventHandler value);
public void remove_SystemColorsChanged(EventHandler value);
public void remove_TabIndexChanged(EventHandler value);
public void remove_TabStopChanged(EventHandler value);
public void remove_TextChanged(EventHandler value);
public void remove_Validated(EventHandler value);
public void remove_Validating(CancelEventHandler value);
public void remove_ValueChanged(EventHandler value);
public void remove_VisibleChanged(EventHandler value);
public void ResetBackColor();
public void ResetBindings();
public void ResetCursor();
public void ResetFont();
public void ResetForeColor();
public void ResetImeMode();
protected void ResetMouseEventArgs();
public void ResetRightToLeft();
public void ResetText();
public void ResumeLayout();
public void ResumeLayout(bool performLayout);
protected ContentAlignment RtlTranslateAlignment(ContentAlignment align);
protected HorizontalAlignment RtlTranslateAlignment(HorizontalAlignment align);
protected LeftRightAlignment RtlTranslateAlignment(LeftRightAlignment align);
protected ContentAlignment RtlTranslateContent(ContentAlignment align);
protected HorizontalAlignment RtlTranslateHorizontal(HorizontalAlignment align);
protected LeftRightAlignment RtlTranslateLeftRight(LeftRightAlignment align);
public void Scale(float ratio);
public void Scale(float dx, float dy);
protected virtual void ScaleCore(float dx, float dy);
public void ScrollControlIntoView(Control activeControl);
public void Select();
protected virtual void Select(bool directed, bool forward);
public void Select(int start, int length);
public bool SelectNextControl(Control ctl, bool forward, bool tabStopOnly, bool nested, bool wrap);
public void SendToBack();
public void SetAutoScrollMargin(int x, int y);
public void SetBounds(int x, int y, int width, int height);
public void SetBounds(int x, int y, int width, int height, BoundsSpecified specified);
protected virtual void SetBoundsCore(int x, int y, int width, int height, BoundsSpecified specified);
protected virtual void SetClientSizeCore(int x, int y);
protected void SetDisplayRectLocation(int x, int y);
protected void SetScrollState(int bit, bool value);
protected void SetStyle(ControlStyles flag, bool value);
protected void SetTopLevel(bool value);
protected virtual void SetVisibleCore(bool value);
public void Show();
public void SuspendLayout();
public virtual string ToString();
public override void UpButton();
public void Update();
protected void UpdateBounds();
protected void UpdateBounds(int x, int y, int width, int height);
protected void UpdateBounds(int x, int y, int width, int height, int clientWidth, int clientHeight);
protected virtual void UpdateDefaultButton();
protected virtual void UpdateEditText();
protected void UpdateStyles();
protected void UpdateZOrder();
public bool Validate();
protected virtual void ValidateEditText();
protected virtual void WndProc(ref Message m);

Property
public AccessibleObject AccessibilityObject {get;}
public string AccessibleDefaultActionDescription {get; set;}
public string AccessibleDescription {get; set;}
public string AccessibleName {get; set;}
public AccessibleRole AccessibleRole {get; set;}
public Control ActiveControl {get; set;}
public bool AllowDrop {get; set;}
public AnchorStyles Anchor {get; set;}
public bool AutoScroll {get; set;}
public Size AutoScrollMargin {get; set;}
public Size AutoScrollMinSize {get; set;}
public Point AutoScrollPosition {get; set;}
public virtual Color BackColor {get; set;}
public Image BackgroundImage {get; set;}
public override BindingContext BindingContext {get; set;}
public BorderStyle BorderStyle {get; set;}
public int Bottom {get;}
public Rectangle Bounds {get; set;}
public bool CanFocus {get;}
public bool CanSelect {get;}
public bool Capture {get; set;}
public bool CausesValidation {get; set;}
protected bool ChangingText {get; set;}
public Rectangle ClientRectangle {get;}
public Size ClientSize {get; set;}
public string CompanyName {get;}
public IContainer Container {get;}
public bool ContainsFocus {get;}
public ContextMenu ContextMenu {get; set;}
public ControlCollection Controls {get;}
public bool Created {get;}
protected virtual CreateParams CreateParams {get;}
public Cursor Cursor {get; set;}
public ControlBindingsCollection DataBindings {get;}
public int DecimalPlaces {get; set;}
protected virtual ImeMode DefaultImeMode {get;}
protected virtual Size DefaultSize {get;}
protected bool DesignMode {get;}
public Rectangle DisplayRectangle {get;}
public bool Disposing {get;}
public DockStyle Dock {get; set;}
public DockPaddingEdges DockPadding {get;}
public bool Enabled {get; set;}
protected EventHandlerList Events {get;}
public bool Focused {get;}
public virtual Font Font {get; set;}
protected int FontHeight {get; set;}
public virtual Color ForeColor {get; set;}
public IntPtr Handle {get;}
public bool HasChildren {get;}
public int Height {get; set;}
public bool Hexadecimal {get; set;}
protected bool HScroll {get; set;}
public ImeMode ImeMode {get; set;}
public decimal Increment {get; set;}
public bool InterceptArrowKeys {get; set;}
public bool InvokeRequired {get;}
public bool IsAccessible {get; set;}
public bool IsDisposed {get;}
public bool IsHandleCreated {get;}
public int Left {get; set;}
public Point Location {get; set;}
public decimal Maximum {get; set;}
public decimal Minimum {get; set;}
public string Name {get; set;}
public Control Parent {get; set;}
public Form ParentForm {get;}
public int PreferredHeight {get;}
public string ProductName {get;}
public string ProductVersion {get;}
public bool ReadOnly {get; set;}
public bool RecreatingHandle {get;}
public Region Region {get; set;}
protected bool RenderRightToLeft {get;}
protected bool ResizeRedraw {get; set;}
public int Right {get;}
public RightToLeft RightToLeft {get; set;}
protected virtual bool ShowFocusCues {get;}
protected bool ShowKeyboardCues {get;}
public ISite Site {get; set;}
public Size Size {get; set;}
public int TabIndex {get; set;}
public bool TabStop {get; set;}
public object Tag {get; set;}
public virtual string Text {get; set;}
public HorizontalAlignment TextAlign {get; set;}
public bool ThousandsSeparator {get; set;}
public int Top {get; set;}
public Control TopLevelControl {get;}
public LeftRightAlignment UpDownAlign {get; set;}
protected bool UserEdit {get; set;}
public decimal Value {get; set;}
public bool Visible {get; set;}
protected bool VScroll {get; set;}
public int Width {get; set;}
public IWindowTarget WindowTarget {get; set;}

System.Windows.Forms.MouseEventHandler

Module:System.Windows.Forms.dll

Hierarchy
Object
Delegate
MulticastDelegate
MouseEventHandler

Type declaration

[C#] public delegate void MouseEventHandler(object sender, MouseEventArgs e);

Constructor
public MouseEventHandler(object object, IntPtr method);

Method
public virtual IAsyncResult BeginInvoke(object sender, MouseEventArgs e, AsyncCallback callback, object object);
public object Clone();
protected override Delegate CombineImpl(Delegate follow);
public object DynamicInvoke(object[] args);
protected virtual object DynamicInvokeImpl(object[] args);
public virtual void EndInvoke(IAsyncResult result);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public override Delegate[] GetInvocationList();
protected virtual MethodInfo GetMethodImpl();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
public override void Invoke(object sender, MouseEventArgs e);
protected object MemberwiseClone();
protected override Delegate RemoveImpl(Delegate value);
public virtual string ToString();

Property
public MethodInfo Method {get;}
public object Target {get;}

System.Windows.Forms.MouseEventArgs

Module:System.Windows.Forms.dll

Hierarchy
Object
EventArgs
MouseEventArgs

Type declaration

[C#] public class MouseEventArgs : EventArgs;

Constructor
public MouseEventArgs(MouseButtons button, int clicks, int x, int y, int delta);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public MouseButtons Button {get;}
public int Clicks {get;}
public int Delta {get;}
public int X {get;}
public int Y {get;}

System.Windows.Forms.MouseButtons

Module:System.Windows.Forms.dll

Hierarchy
Object
ValueType
Enum
MouseButtons

Type declaration

[C#] public enum MouseButtons;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const MouseButtons Left = 1048576;
public const MouseButtons Middle = 4194304;
public const MouseButtons None = 0;
public const MouseButtons Right = 2097152;
public int value__;
public const MouseButtons XButton1 = 8388608;
public const MouseButtons XButton2 = 16777216;

System.Windows.Forms.MessageBoxIcon

Module:System.Windows.Forms.dll

Hierarchy
Object
ValueType
Enum
MessageBoxIcon

Type declaration

[C#] public enum MessageBoxIcon;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const MessageBoxIcon Asterisk = 64;
public const MessageBoxIcon Error = 16;
public const MessageBoxIcon Exclamation = 48;
public const MessageBoxIcon Hand = 16;
public const MessageBoxIcon Information = 64;
public const MessageBoxIcon None = 0;
public const MessageBoxIcon Question = 32;
public const MessageBoxIcon Stop = 16;
public int value__;
public const MessageBoxIcon Warning = 48;

System.Windows.Forms.MessageBoxDefaultButton

Module:System.Windows.Forms.dll

Hierarchy
Object
ValueType
Enum
MessageBoxDefaultButton

Type declaration

[C#] public enum MessageBoxDefaultButton;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const MessageBoxDefaultButton Button1 = 0;
public const MessageBoxDefaultButton Button2 = 256;
public const MessageBoxDefaultButton Button3 = 512;
public int value__;

System.Windows.Forms.MessageBoxButtons

Module:System.Windows.Forms.dll

Hierarchy
Object
ValueType
Enum
MessageBoxButtons

Type declaration

[C#] public enum MessageBoxButtons;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const MessageBoxButtons AbortRetryIgnore = 2;
public const MessageBoxButtons OK = 0;
public const MessageBoxButtons OKCancel = 1;
public const MessageBoxButtons RetryCancel = 5;
public int value__;
public const MessageBoxButtons YesNo = 4;
public const MessageBoxButtons YesNoCancel = 3;

System.Windows.Forms.MessageBox

Module:System.Windows.Forms.dll

Hierarchy
Object
MessageBox

Type declaration

[C#] public class MessageBox;

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public static DialogResult Show(IWin32Window owner, string text);
public static DialogResult Show(IWin32Window owner, string text, string caption);
public static DialogResult Show(IWin32Window owner, string text, string caption, MessageBoxButtons buttons);
public static DialogResult Show(IWin32Window owner, string text, string caption, MessageBoxButtons buttons, MessageBoxIcon icon);
public static DialogResult Show(IWin32Window owner, string text, string caption, MessageBoxButtons buttons, MessageBoxIcon icon, MessageBoxDefaultButton defaultButton);
public static DialogResult Show(IWin32Window owner, string text, string caption, MessageBoxButtons buttons, MessageBoxIcon icon, MessageBoxDefaultButton defaultButton, MessageBoxOptions options);
public static DialogResult Show(string text);
public static DialogResult Show(string text, string caption);
public static DialogResult Show(string text, string caption, MessageBoxButtons buttons);
public static DialogResult Show(string text, string caption, MessageBoxButtons buttons, MessageBoxIcon icon);
public static DialogResult Show(string text, string caption, MessageBoxButtons buttons, MessageBoxIcon icon, MessageBoxDefaultButton defaultButton);
public static DialogResult Show(string text, string caption, MessageBoxButtons buttons, MessageBoxIcon icon, MessageBoxDefaultButton defaultButton, MessageBoxOptions options);
public virtual string ToString();

System.Windows.Forms.MenuItem

Module:System.Windows.Forms.dll

Hierarchy
Object
MarshalByRefObject
Component
Menu
MenuItem

Type declaration

[C#] public class MenuItem : Menu;

Constructor
public MenuItem();
public MenuItem(MenuMerge mergeType, int mergeOrder, Shortcut shortcut, string text, EventHandler onClick, EventHandler onPopup, EventHandler onSelect, MenuItem[] items);
public MenuItem(string text);
public MenuItem(string text, EventHandler onClick);
public MenuItem(string text, EventHandler onClick, Shortcut shortcut);
public MenuItem(string text, MenuItem[] items);

Method
public void add_Click(EventHandler value);
public void add_Disposed(EventHandler value);
public void add_DrawItem(DrawItemEventHandler value);
public void add_MeasureItem(MeasureItemEventHandler value);
public void add_Popup(EventHandler value);
public void add_Select(EventHandler value);
public virtual MenuItem CloneMenu();
protected void CloneMenu(Menu menuSrc);
protected void CloneMenu(MenuItem itemSrc);
protected virtual IntPtr CreateMenuHandle();
public ObjRef CreateObjRef(Type requestedType);
public void Dispose();
protected virtual void Dispose(bool disposing);
public virtual bool Equals(object obj);
protected override void Finalize();
public MenuItem FindMenuItem(int type, IntPtr value);
protected int FindMergePosition(int mergeOrder);
public ContextMenu GetContextMenu();
public virtual int GetHashCode();
public object GetLifetimeService();
public MainMenu GetMainMenu();
protected virtual object GetService(Type service);
public Type GetType();
public object InitializeLifetimeService();
protected object MemberwiseClone();
public virtual MenuItem MergeMenu();
public void MergeMenu(Menu menuSrc);
public void MergeMenu(MenuItem itemSrc);
protected virtual void OnClick(EventArgs e);
protected virtual void OnDrawItem(DrawItemEventArgs e);
protected virtual void OnInitMenuPopup(EventArgs e);
protected virtual void OnMeasureItem(MeasureItemEventArgs e);
protected virtual void OnPopup(EventArgs e);
protected virtual void OnSelect(EventArgs e);
public void PerformClick();
public virtual void PerformSelect();
public void remove_Click(EventHandler value);
public void remove_Disposed(EventHandler value);
public void remove_DrawItem(DrawItemEventHandler value);
public void remove_MeasureItem(MeasureItemEventHandler value);
public void remove_Popup(EventHandler value);
public void remove_Select(EventHandler value);
public virtual string ToString();

Property
public bool BarBreak {get; set;}
public bool Break {get; set;}
public bool Checked {get; set;}
public IContainer Container {get;}
public bool DefaultItem {get; set;}
protected bool DesignMode {get;}
public bool Enabled {get; set;}
protected EventHandlerList Events {get;}
public IntPtr Handle {get;}
public int Index {get; set;}
public override bool IsParent {get;}
public bool MdiList {get; set;}
public MenuItem MdiListItem {get;}
protected int MenuID {get;}
public MenuItemCollection MenuItems {get;}
public int MergeOrder {get; set;}
public MenuMerge MergeType {get; set;}
public char Mnemonic {get;}
public bool OwnerDraw {get; set;}
public Menu Parent {get;}
public bool RadioCheck {get; set;}
public Shortcut Shortcut {get; set;}
public bool ShowShortcut {get; set;}
public ISite Site {get; set;}
public string Text {get; set;}
public bool Visible {get; set;}

System.Windows.Forms.MainMenu

Module:System.Windows.Forms.dll

Hierarchy
Object
MarshalByRefObject
Component
Menu
MainMenu

Type declaration

[C#] public class MainMenu : Menu;

Constructor
public MainMenu();
public MainMenu(MenuItem[] items);

Method
public void add_Disposed(EventHandler value);
public virtual MainMenu CloneMenu();
protected void CloneMenu(Menu menuSrc);
protected virtual IntPtr CreateMenuHandle();
public ObjRef CreateObjRef(Type requestedType);
public void Dispose();
protected virtual void Dispose(bool disposing);
public virtual bool Equals(object obj);
protected override void Finalize();
public MenuItem FindMenuItem(int type, IntPtr value);
protected int FindMergePosition(int mergeOrder);
public ContextMenu GetContextMenu();
public Form GetForm();
public virtual int GetHashCode();
public object GetLifetimeService();
public MainMenu GetMainMenu();
protected virtual object GetService(Type service);
public Type GetType();
public object InitializeLifetimeService();
protected object MemberwiseClone();
public void MergeMenu(Menu menuSrc);
public void remove_Disposed(EventHandler value);
public virtual string ToString();

Property
public IContainer Container {get;}
protected bool DesignMode {get;}
protected EventHandlerList Events {get;}
public IntPtr Handle {get;}
public bool IsParent {get;}
public MenuItem MdiListItem {get;}
public MenuItemCollection MenuItems {get;}
public virtual RightToLeft RightToLeft {get; set;}
public ISite Site {get; set;}

System.Windows.Forms.ListBox+ObjectCollection

Module:System.Windows.Forms.dll

Hierarchy
Object
ListBox+ObjectCollection : IList, ICollection, IEnumerable

Type declaration

[C#] public class ObjectCollection: IList, ICollection, IEnumerable;

Constructor
public ObjectCollection(ListBox owner);
public ObjectCollection(ListBox owner, object[] value);
public ObjectCollection(ListBox owner, ObjectCollection value);

Method
public virtual int Add(object obj);
public void AddRange(object[] items);
public void AddRange(ObjectCollection value);
public virtual void Clear();
public virtual bool Contains(object obj);
public void CopyTo(object[] dest, int arrayIndex);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual IEnumerator GetEnumerator();
public virtual int GetHashCode();
public Type GetType();
public virtual int IndexOf(object obj);
public virtual void Insert(int index, object obj);
protected object MemberwiseClone();
public virtual void Remove(object obj);
public virtual void RemoveAt(int index);
public virtual string ToString();

Property
public virtual int Count {get;}
public virtual bool IsReadOnly {get;}
public virtual object this[int index] {get; set;}

System.Windows.Forms.ListBox

Module:System.Windows.Forms.dll

Hierarchy
Object
MarshalByRefObject
Component
Control
ListControl
ListBox

Type declaration

[C#] public class ListBox : ListControl;

Constructor
public ListBox();

Method
protected void AccessibilityNotifyClients(AccessibleEvents accEvent, int childID);
public void add_BackColorChanged(EventHandler value);
public void add_BackgroundImageChanged(EventHandler value);
public void add_BindingContextChanged(EventHandler value);
public void add_CausesValidationChanged(EventHandler value);
public void add_ChangeUICues(UICuesEventHandler value);
public void add_Click(EventHandler value);
public void add_ContextMenuChanged(EventHandler value);
public void add_ControlAdded(ControlEventHandler value);
public void add_ControlRemoved(ControlEventHandler value);
public void add_CursorChanged(EventHandler value);
public void add_DataSourceChanged(EventHandler value);
public void add_DisplayMemberChanged(EventHandler value);
public void add_Disposed(EventHandler value);
public void add_DockChanged(EventHandler value);
public void add_DoubleClick(EventHandler value);
public void add_DragDrop(DragEventHandler value);
public void add_DragEnter(DragEventHandler value);
public void add_DragLeave(EventHandler value);
public void add_DragOver(DragEventHandler value);
public void add_DrawItem(DrawItemEventHandler value);
public void add_EnabledChanged(EventHandler value);
public void add_Enter(EventHandler value);
public void add_FontChanged(EventHandler value);
public void add_ForeColorChanged(EventHandler value);
public void add_GiveFeedback(GiveFeedbackEventHandler value);
public void add_GotFocus(EventHandler value);
public void add_HandleCreated(EventHandler value);
public void add_HandleDestroyed(EventHandler value);
public void add_HelpRequested(HelpEventHandler value);
public void add_ImeModeChanged(EventHandler value);
public void add_Invalidated(InvalidateEventHandler value);
public void add_KeyDown(KeyEventHandler value);
public void add_KeyPress(KeyPressEventHandler value);
public void add_KeyUp(KeyEventHandler value);
public void add_Layout(LayoutEventHandler value);
public void add_Leave(EventHandler value);
public void add_LocationChanged(EventHandler value);
public void add_LostFocus(EventHandler value);
public void add_MeasureItem(MeasureItemEventHandler value);
public void add_MouseDown(MouseEventHandler value);
public void add_MouseEnter(EventHandler value);
public void add_MouseHover(EventHandler value);
public void add_MouseLeave(EventHandler value);
public void add_MouseMove(MouseEventHandler value);
public void add_MouseUp(MouseEventHandler value);
public void add_MouseWheel(MouseEventHandler value);
public void add_Move(EventHandler value);
public void add_Paint(PaintEventHandler value);
public void add_ParentChanged(EventHandler value);
public void add_QueryAccessibilityHelp(QueryAccessibilityHelpEventHandler value);
public void add_QueryContinueDrag(QueryContinueDragEventHandler value);
public void add_Resize(EventHandler value);
public void add_RightToLeftChanged(EventHandler value);
public void add_SelectedIndexChanged(EventHandler value);
public void add_SelectedValueChanged(EventHandler value);
public void add_SizeChanged(EventHandler value);
public void add_StyleChanged(EventHandler value);
public void add_SystemColorsChanged(EventHandler value);
public void add_TabIndexChanged(EventHandler value);
public void add_TabStopChanged(EventHandler value);
public void add_TextChanged(EventHandler value);
public void add_Validated(EventHandler value);
public void add_Validating(CancelEventHandler value);
public void add_ValueMemberChanged(EventHandler value);
public void add_VisibleChanged(EventHandler value);
protected virtual void AddItemsCore(object[] value);
public IAsyncResult BeginInvoke(Delegate method);
public IAsyncResult BeginInvoke(Delegate method, object[] args);
public void BeginUpdate();
public void BringToFront();
public void ClearSelected();
public bool Contains(Control ctl);
protected virtual AccessibleObject CreateAccessibilityInstance();
public void CreateControl();
protected virtual ControlCollection CreateControlsInstance();
public Graphics CreateGraphics();
protected virtual void CreateHandle();
protected virtual ObjectCollection CreateItemCollection();
public ObjRef CreateObjRef(Type requestedType);
protected virtual void DefWndProc(ref Message m);
protected virtual void DestroyHandle();
public void Dispose();
protected override void Dispose(bool disposing);
public DragDropEffects DoDragDrop(object data, DragDropEffects allowedEffects);
public object EndInvoke(IAsyncResult asyncResult);
public void EndUpdate();
public virtual bool Equals(object obj);
protected object FilterItemOnProperty(object item);
protected object FilterItemOnProperty(object item, string strField);
protected override void Finalize();
public Form FindForm();
public int FindString(string s);
public int FindString(string s, int startIndex);
public int FindStringExact(string s);
public int FindStringExact(string s, int startIndex);
public bool Focus();
public Control GetChildAtPoint(Point pt);
public IContainerControl GetContainerControl();
public virtual int GetHashCode();
public int GetItemHeight(int index);
public Rectangle GetItemRectangle(int index);
public string GetItemText(object item);
public object GetLifetimeService();
public Control GetNextControl(Control ctl, bool forward);
public bool GetSelected(int index);
protected virtual object GetService(Type service);
protected bool GetStyle(ControlStyles flag);
protected bool GetTopLevel();
public Type GetType();
public void Hide();
public int IndexFromPoint(int x, int y);
public int IndexFromPoint(Point p);
public object InitializeLifetimeService();
protected virtual void InitLayout();
public void Invalidate();
public void Invalidate(bool invalidateChildren);
public void Invalidate(Rectangle rect);
public void Invalidate(Rectangle rc, bool invalidateChildren);
public void Invalidate(Region region);
public void Invalidate(Region region, bool invalidateChildren);
public object Invoke(Delegate method);
public object Invoke(Delegate method, object[] args);
protected void InvokeGotFocus(Control toInvoke, EventArgs e);
protected void InvokeLostFocus(Control toInvoke, EventArgs e);
protected void InvokeOnClick(Control toInvoke, EventArgs e);
protected void InvokePaint(Control c, PaintEventArgs e);
protected void InvokePaintBackground(Control c, PaintEventArgs e);
protected virtual bool IsInputChar(char charCode);
protected virtual bool IsInputKey(Keys keyData);
protected object MemberwiseClone();
protected virtual void NotifyInvalidate(Rectangle invalidatedArea);
protected virtual void OnBackColorChanged(EventArgs e);
protected virtual void OnBackgroundImageChanged(EventArgs e);
protected override void OnBindingContextChanged(EventArgs e);
protected virtual void OnCausesValidationChanged(EventArgs e);
protected virtual void OnChangeUICues(UICuesEventArgs e);
protected virtual void OnClick(EventArgs e);
protected virtual void OnContextMenuChanged(EventArgs e);
protected virtual void OnControlAdded(ControlEventArgs e);
protected virtual void OnControlRemoved(ControlEventArgs e);
protected virtual void OnCreateControl();
protected virtual void OnCursorChanged(EventArgs e);
protected override void OnDataSourceChanged(EventArgs e);
protected override void OnDisplayMemberChanged(EventArgs e);
protected virtual void OnDockChanged(EventArgs e);
protected virtual void OnDoubleClick(EventArgs e);
protected virtual void OnDragDrop(DragEventArgs drgevent);
protected virtual void OnDragEnter(DragEventArgs drgevent);
protected virtual void OnDragLeave(EventArgs e);
protected virtual void OnDragOver(DragEventArgs drgevent);
protected virtual void OnDrawItem(DrawItemEventArgs e);
protected virtual void OnEnabledChanged(EventArgs e);
protected virtual void OnEnter(EventArgs e);
protected virtual void OnFontChanged(EventArgs e);
protected virtual void OnForeColorChanged(EventArgs e);
protected virtual void OnGiveFeedback(GiveFeedbackEventArgs gfbevent);
protected virtual void OnGotFocus(EventArgs e);
protected virtual void OnHandleCreated(EventArgs e);
protected virtual void OnHandleDestroyed(EventArgs e);
protected virtual void OnHelpRequested(HelpEventArgs hevent);
protected virtual void OnImeModeChanged(EventArgs e);
protected virtual void OnInvalidated(InvalidateEventArgs e);
protected virtual void OnKeyDown(KeyEventArgs e);
protected virtual void OnKeyPress(KeyPressEventArgs e);
protected virtual void OnKeyUp(KeyEventArgs e);
protected virtual void OnLayout(LayoutEventArgs levent);
protected virtual void OnLeave(EventArgs e);
protected virtual void OnLocationChanged(EventArgs e);
protected virtual void OnLostFocus(EventArgs e);
protected virtual void OnMeasureItem(MeasureItemEventArgs e);
protected virtual void OnMouseDown(MouseEventArgs e);
protected virtual void OnMouseEnter(EventArgs e);
protected virtual void OnMouseHover(EventArgs e);
protected virtual void OnMouseLeave(EventArgs e);
protected virtual void OnMouseMove(MouseEventArgs e);
protected virtual void OnMouseUp(MouseEventArgs e);
protected virtual void OnMouseWheel(MouseEventArgs e);
protected virtual void OnMove(EventArgs e);
protected virtual void OnNotifyMessage(Message m);
protected virtual void OnPaint(PaintEventArgs e);
protected virtual void OnPaintBackground(PaintEventArgs e);
protected virtual void OnParentBackColorChanged(EventArgs e);
protected virtual void OnParentBackgroundImageChanged(EventArgs e);
protected virtual void OnParentBindingContextChanged(EventArgs e);
protected virtual void OnParentChanged(EventArgs e);
protected virtual void OnParentEnabledChanged(EventArgs e);
protected virtual void OnParentFontChanged(EventArgs e);
protected virtual void OnParentForeColorChanged(EventArgs e);
protected virtual void OnParentRightToLeftChanged(EventArgs e);
protected virtual void OnParentVisibleChanged(EventArgs e);
protected virtual void OnQueryContinueDrag(QueryContinueDragEventArgs qcdevent);
protected virtual void OnResize(EventArgs e);
protected virtual void OnRightToLeftChanged(EventArgs e);
protected override void OnSelectedIndexChanged(EventArgs e);
protected virtual void OnSelectedValueChanged(EventArgs e);
protected virtual void OnSizeChanged(EventArgs e);
protected virtual void OnStyleChanged(EventArgs e);
protected virtual void OnSystemColorsChanged(EventArgs e);
protected virtual void OnTabIndexChanged(EventArgs e);
protected virtual void OnTabStopChanged(EventArgs e);
protected virtual void OnTextChanged(EventArgs e);
protected virtual void OnValidated(EventArgs e);
protected virtual void OnValidating(CancelEventArgs e);
protected virtual void OnValueMemberChanged(EventArgs e);
protected virtual void OnVisibleChanged(EventArgs e);
public void PerformLayout();
public void PerformLayout(Control affectedControl, string affectedProperty);
public Point PointToClient(Point p);
public Point PointToScreen(Point p);
public bool PreProcessMessage(ref Message msg);
protected virtual bool ProcessCmdKey(ref Message msg, Keys keyData);
protected virtual bool ProcessDialogChar(char charCode);
protected virtual bool ProcessDialogKey(Keys keyData);
protected virtual bool ProcessKeyEventArgs(ref Message m);
protected virtual bool ProcessKeyPreview(ref Message m);
protected virtual bool ProcessMnemonic(char charCode);
protected void RaiseDragEvent(object key, DragEventArgs e);
protected void RaiseKeyEvent(object key, KeyEventArgs e);
protected void RaiseMouseEvent(object key, MouseEventArgs e);
protected void RaisePaintEvent(object key, PaintEventArgs e);
protected void RecreateHandle();
public Rectangle RectangleToClient(Rectangle r);
public Rectangle RectangleToScreen(Rectangle r);
public virtual void Refresh();
protected virtual void RefreshItem(int index);
public void remove_BackColorChanged(EventHandler value);
public void remove_BackgroundImageChanged(EventHandler value);
public void remove_BindingContextChanged(EventHandler value);
public void remove_CausesValidationChanged(EventHandler value);
public void remove_ChangeUICues(UICuesEventHandler value);
public void remove_Click(EventHandler value);
public void remove_ContextMenuChanged(EventHandler value);
public void remove_ControlAdded(ControlEventHandler value);
public void remove_ControlRemoved(ControlEventHandler value);
public void remove_CursorChanged(EventHandler value);
public void remove_DataSourceChanged(EventHandler value);
public void remove_DisplayMemberChanged(EventHandler value);
public void remove_Disposed(EventHandler value);
public void remove_DockChanged(EventHandler value);
public void remove_DoubleClick(EventHandler value);
public void remove_DragDrop(DragEventHandler value);
public void remove_DragEnter(DragEventHandler value);
public void remove_DragLeave(EventHandler value);
public void remove_DragOver(DragEventHandler value);
public void remove_DrawItem(DrawItemEventHandler value);
public void remove_EnabledChanged(EventHandler value);
public void remove_Enter(EventHandler value);
public void remove_FontChanged(EventHandler value);
public void remove_ForeColorChanged(EventHandler value);
public void remove_GiveFeedback(GiveFeedbackEventHandler value);
public void remove_GotFocus(EventHandler value);
public void remove_HandleCreated(EventHandler value);
public void remove_HandleDestroyed(EventHandler value);
public void remove_HelpRequested(HelpEventHandler value);
public void remove_ImeModeChanged(EventHandler value);
public void remove_Invalidated(InvalidateEventHandler value);
public void remove_KeyDown(KeyEventHandler value);
public void remove_KeyPress(KeyPressEventHandler value);
public void remove_KeyUp(KeyEventHandler value);
public void remove_Layout(LayoutEventHandler value);
public void remove_Leave(EventHandler value);
public void remove_LocationChanged(EventHandler value);
public void remove_LostFocus(EventHandler value);
public void remove_MeasureItem(MeasureItemEventHandler value);
public void remove_MouseDown(MouseEventHandler value);
public void remove_MouseEnter(EventHandler value);
public void remove_MouseHover(EventHandler value);
public void remove_MouseLeave(EventHandler value);
public void remove_MouseMove(MouseEventHandler value);
public void remove_MouseUp(MouseEventHandler value);
public void remove_MouseWheel(MouseEventHandler value);
public void remove_Move(EventHandler value);
public void remove_Paint(PaintEventHandler value);
public void remove_ParentChanged(EventHandler value);
public void remove_QueryAccessibilityHelp(QueryAccessibilityHelpEventHandler value);
public void remove_QueryContinueDrag(QueryContinueDragEventHandler value);
public void remove_Resize(EventHandler value);
public void remove_RightToLeftChanged(EventHandler value);
public void remove_SelectedIndexChanged(EventHandler value);
public void remove_SelectedValueChanged(EventHandler value);
public void remove_SizeChanged(EventHandler value);
public void remove_StyleChanged(EventHandler value);
public void remove_SystemColorsChanged(EventHandler value);
public void remove_TabIndexChanged(EventHandler value);
public void remove_TabStopChanged(EventHandler value);
public void remove_TextChanged(EventHandler value);
public void remove_Validated(EventHandler value);
public void remove_Validating(CancelEventHandler value);
public void remove_ValueMemberChanged(EventHandler value);
public void remove_VisibleChanged(EventHandler value);
public void ResetBackColor();
public void ResetBindings();
public void ResetCursor();
public void ResetFont();
public void ResetForeColor();
public void ResetImeMode();
protected void ResetMouseEventArgs();
public void ResetRightToLeft();
public void ResetText();
public void ResumeLayout();
public void ResumeLayout(bool performLayout);
protected ContentAlignment RtlTranslateAlignment(ContentAlignment align);
protected HorizontalAlignment RtlTranslateAlignment(HorizontalAlignment align);
protected LeftRightAlignment RtlTranslateAlignment(LeftRightAlignment align);
protected ContentAlignment RtlTranslateContent(ContentAlignment align);
protected HorizontalAlignment RtlTranslateHorizontal(HorizontalAlignment align);
protected LeftRightAlignment RtlTranslateLeftRight(LeftRightAlignment align);
public void Scale(float ratio);
public void Scale(float dx, float dy);
protected virtual void ScaleCore(float dx, float dy);
public void Select();
protected virtual void Select(bool directed, bool forward);
public bool SelectNextControl(Control ctl, bool forward, bool tabStopOnly, bool nested, bool wrap);
public void SendToBack();
public void SetBounds(int x, int y, int width, int height);
public void SetBounds(int x, int y, int width, int height, BoundsSpecified specified);
protected virtual void SetBoundsCore(int x, int y, int width, int height, BoundsSpecified specified);
protected virtual void SetClientSizeCore(int x, int y);
protected virtual void SetItemCore(int index, object value);
protected override void SetItemsCore(IList value);
public void SetSelected(int index, bool value);
protected void SetStyle(ControlStyles flag, bool value);
protected void SetTopLevel(bool value);
protected virtual void SetVisibleCore(bool value);
public void Show();
protected virtual void Sort();
public void SuspendLayout();
public virtual string ToString();
public void Update();
protected void UpdateBounds();
protected void UpdateBounds(int x, int y, int width, int height);
protected void UpdateBounds(int x, int y, int width, int height, int clientWidth, int clientHeight);
protected void UpdateStyles();
protected void UpdateZOrder();
protected virtual void WmReflectCommand(ref Message m);
protected virtual void WndProc(ref Message m);

Property
public AccessibleObject AccessibilityObject {get;}
public string AccessibleDefaultActionDescription {get; set;}
public string AccessibleDescription {get; set;}
public string AccessibleName {get; set;}
public AccessibleRole AccessibleRole {get; set;}
public bool AllowDrop {get; set;}
public AnchorStyles Anchor {get; set;}
public virtual Color BackColor {get; set;}
public override Image BackgroundImage {get; set;}
public virtual BindingContext BindingContext {get; set;}
public BorderStyle BorderStyle {get; set;}
public int Bottom {get;}
public Rectangle Bounds {get; set;}
public bool CanFocus {get;}
public bool CanSelect {get;}
public bool Capture {get; set;}
public bool CausesValidation {get; set;}
public Rectangle ClientRectangle {get;}
public Size ClientSize {get; set;}
public int ColumnWidth {get; set;}
public string CompanyName {get;}
public IContainer Container {get;}
public bool ContainsFocus {get;}
public ContextMenu ContextMenu {get; set;}
public ControlCollection Controls {get;}
public bool Created {get;}
protected virtual CreateParams CreateParams {get;}
public Cursor Cursor {get; set;}
public ControlBindingsCollection DataBindings {get;}
protected CurrencyManager DataManager {get;}
public object DataSource {get; set;}
protected virtual ImeMode DefaultImeMode {get;}
protected virtual Size DefaultSize {get;}
protected bool DesignMode {get;}
public string DisplayMember {get; set;}
public Rectangle DisplayRectangle {get;}
public bool Disposing {get;}
public DockStyle Dock {get; set;}
public virtual DrawMode DrawMode {get; set;}
public bool Enabled {get; set;}
protected EventHandlerList Events {get;}
public bool Focused {get;}
public virtual Font Font {get; set;}
protected int FontHeight {get; set;}
public virtual Color ForeColor {get; set;}
public IntPtr Handle {get;}
public bool HasChildren {get;}
public int Height {get; set;}
public int HorizontalExtent {get; set;}
public bool HorizontalScrollbar {get; set;}
public ImeMode ImeMode {get; set;}
public bool IntegralHeight {get; set;}
public bool InvokeRequired {get;}
public bool IsAccessible {get; set;}
public bool IsDisposed {get;}
public bool IsHandleCreated {get;}
public virtual int ItemHeight {get; set;}
public ObjectCollection Items {get;}
public int Left {get; set;}
public Point Location {get; set;}
public bool MultiColumn {get; set;}
public string Name {get; set;}
public Control Parent {get; set;}
public int PreferredHeight {get;}
public string ProductName {get;}
public string ProductVersion {get;}
public bool RecreatingHandle {get;}
public Region Region {get; set;}
protected bool RenderRightToLeft {get;}
protected bool ResizeRedraw {get; set;}
public int Right {get;}
public override RightToLeft RightToLeft {get; set;}
public bool ScrollAlwaysVisible {get; set;}
public override int SelectedIndex {get; set;}
public SelectedIndexCollection SelectedIndices {get;}
public object SelectedItem {get; set;}
public SelectedObjectCollection SelectedItems {get;}
public object SelectedValue {get; set;}
public virtual SelectionMode SelectionMode {get; set;}
protected virtual bool ShowFocusCues {get;}
protected bool ShowKeyboardCues {get;}
public ISite Site {get; set;}
public Size Size {get; set;}
public bool Sorted {get; set;}
public int TabIndex {get; set;}
public bool TabStop {get; set;}
public object Tag {get; set;}
public override string Text {get; set;}
public int Top {get; set;}
public int TopIndex {get; set;}
public Control TopLevelControl {get;}
public bool UseTabStops {get; set;}
public string ValueMember {get; set;}
public bool Visible {get; set;}
public int Width {get; set;}
public IWindowTarget WindowTarget {get; set;}

Field
public const int DefaultItemHeight = 13;
public const int NoMatches = -1;

System.Windows.Forms.Label

Module:System.Windows.Forms.dll

Hierarchy
Object
MarshalByRefObject
Component
Control
Label

Type declaration

[C#] public class Label : Control;

Constructor
public Label();

Method
protected void AccessibilityNotifyClients(AccessibleEvents accEvent, int childID);
public void add_AutoSizeChanged(EventHandler value);
public void add_BackColorChanged(EventHandler value);
public void add_BackgroundImageChanged(EventHandler value);
public void add_BindingContextChanged(EventHandler value);
public void add_CausesValidationChanged(EventHandler value);
public void add_ChangeUICues(UICuesEventHandler value);
public void add_Click(EventHandler value);
public void add_ContextMenuChanged(EventHandler value);
public void add_ControlAdded(ControlEventHandler value);
public void add_ControlRemoved(ControlEventHandler value);
public void add_CursorChanged(EventHandler value);
public void add_Disposed(EventHandler value);
public void add_DockChanged(EventHandler value);
public void add_DoubleClick(EventHandler value);
public void add_DragDrop(DragEventHandler value);
public void add_DragEnter(DragEventHandler value);
public void add_DragLeave(EventHandler value);
public void add_DragOver(DragEventHandler value);
public void add_EnabledChanged(EventHandler value);
public void add_Enter(EventHandler value);
public void add_FontChanged(EventHandler value);
public void add_ForeColorChanged(EventHandler value);
public void add_GiveFeedback(GiveFeedbackEventHandler value);
public void add_GotFocus(EventHandler value);
public void add_HandleCreated(EventHandler value);
public void add_HandleDestroyed(EventHandler value);
public void add_HelpRequested(HelpEventHandler value);
public void add_ImeModeChanged(EventHandler value);
public void add_Invalidated(InvalidateEventHandler value);
public void add_KeyDown(KeyEventHandler value);
public void add_KeyPress(KeyPressEventHandler value);
public void add_KeyUp(KeyEventHandler value);
public void add_Layout(LayoutEventHandler value);
public void add_Leave(EventHandler value);
public void add_LocationChanged(EventHandler value);
public void add_LostFocus(EventHandler value);
public void add_MouseDown(MouseEventHandler value);
public void add_MouseEnter(EventHandler value);
public void add_MouseHover(EventHandler value);
public void add_MouseLeave(EventHandler value);
public void add_MouseMove(MouseEventHandler value);
public void add_MouseUp(MouseEventHandler value);
public void add_MouseWheel(MouseEventHandler value);
public void add_Move(EventHandler value);
public void add_Paint(PaintEventHandler value);
public void add_ParentChanged(EventHandler value);
public void add_QueryAccessibilityHelp(QueryAccessibilityHelpEventHandler value);
public void add_QueryContinueDrag(QueryContinueDragEventHandler value);
public void add_Resize(EventHandler value);
public void add_RightToLeftChanged(EventHandler value);
public void add_SizeChanged(EventHandler value);
public void add_StyleChanged(EventHandler value);
public void add_SystemColorsChanged(EventHandler value);
public void add_TabIndexChanged(EventHandler value);
public void add_TabStopChanged(EventHandler value);
public void add_TextAlignChanged(EventHandler value);
public void add_TextChanged(EventHandler value);
public void add_Validated(EventHandler value);
public void add_Validating(CancelEventHandler value);
public void add_VisibleChanged(EventHandler value);
public IAsyncResult BeginInvoke(Delegate method);
public IAsyncResult BeginInvoke(Delegate method, object[] args);
public void BringToFront();
protected Rectangle CalcImageRenderBounds(Image image, Rectangle r, ContentAlignment align);
public bool Contains(Control ctl);
protected virtual AccessibleObject CreateAccessibilityInstance();
public void CreateControl();
protected virtual ControlCollection CreateControlsInstance();
public Graphics CreateGraphics();
protected virtual void CreateHandle();
public ObjRef CreateObjRef(Type requestedType);
protected virtual void DefWndProc(ref Message m);
protected virtual void DestroyHandle();
public void Dispose();
protected override void Dispose(bool disposing);
public DragDropEffects DoDragDrop(object data, DragDropEffects allowedEffects);
protected void DrawImage(Graphics g, Image image, Rectangle r, ContentAlignment align);
public object EndInvoke(IAsyncResult asyncResult);
public virtual bool Equals(object obj);
protected override void Finalize();
public Form FindForm();
public bool Focus();
public Control GetChildAtPoint(Point pt);
public IContainerControl GetContainerControl();
public virtual int GetHashCode();
public object GetLifetimeService();
public Control GetNextControl(Control ctl, bool forward);
protected virtual object GetService(Type service);
protected bool GetStyle(ControlStyles flag);
protected bool GetTopLevel();
public Type GetType();
public void Hide();
public object InitializeLifetimeService();
protected virtual void InitLayout();
public void Invalidate();
public void Invalidate(bool invalidateChildren);
public void Invalidate(Rectangle rect);
public void Invalidate(Rectangle rc, bool invalidateChildren);
public void Invalidate(Region region);
public void Invalidate(Region region, bool invalidateChildren);
public object Invoke(Delegate method);
public object Invoke(Delegate method, object[] args);
protected void InvokeGotFocus(Control toInvoke, EventArgs e);
protected void InvokeLostFocus(Control toInvoke, EventArgs e);
protected void InvokeOnClick(Control toInvoke, EventArgs e);
protected void InvokePaint(Control c, PaintEventArgs e);
protected void InvokePaintBackground(Control c, PaintEventArgs e);
protected virtual bool IsInputChar(char charCode);
protected virtual bool IsInputKey(Keys keyData);
protected object MemberwiseClone();
protected virtual void NotifyInvalidate(Rectangle invalidatedArea);
protected virtual void OnAutoSizeChanged(EventArgs e);
protected virtual void OnBackColorChanged(EventArgs e);
protected virtual void OnBackgroundImageChanged(EventArgs e);
protected virtual void OnBindingContextChanged(EventArgs e);
protected virtual void OnCausesValidationChanged(EventArgs e);
protected virtual void OnChangeUICues(UICuesEventArgs e);
protected virtual void OnClick(EventArgs e);
protected virtual void OnContextMenuChanged(EventArgs e);
protected virtual void OnControlAdded(ControlEventArgs e);
protected virtual void OnControlRemoved(ControlEventArgs e);
protected virtual void OnCreateControl();
protected virtual void OnCursorChanged(EventArgs e);
protected virtual void OnDockChanged(EventArgs e);
protected virtual void OnDoubleClick(EventArgs e);
protected virtual void OnDragDrop(DragEventArgs drgevent);
protected virtual void OnDragEnter(DragEventArgs drgevent);
protected virtual void OnDragLeave(EventArgs e);
protected virtual void OnDragOver(DragEventArgs drgevent);
protected virtual void OnEnabledChanged(EventArgs e);
protected virtual void OnEnter(EventArgs e);
protected virtual void OnFontChanged(EventArgs e);
protected virtual void OnForeColorChanged(EventArgs e);
protected virtual void OnGiveFeedback(GiveFeedbackEventArgs gfbevent);
protected virtual void OnGotFocus(EventArgs e);
protected virtual void OnHandleCreated(EventArgs e);
protected virtual void OnHandleDestroyed(EventArgs e);
protected virtual void OnHelpRequested(HelpEventArgs hevent);
protected virtual void OnImeModeChanged(EventArgs e);
protected virtual void OnInvalidated(InvalidateEventArgs e);
protected virtual void OnKeyDown(KeyEventArgs e);
protected virtual void OnKeyPress(KeyPressEventArgs e);
protected virtual void OnKeyUp(KeyEventArgs e);
protected virtual void OnLayout(LayoutEventArgs levent);
protected virtual void OnLeave(EventArgs e);
protected virtual void OnLocationChanged(EventArgs e);
protected virtual void OnLostFocus(EventArgs e);
protected virtual void OnMouseDown(MouseEventArgs e);
protected virtual void OnMouseEnter(EventArgs e);
protected virtual void OnMouseHover(EventArgs e);
protected virtual void OnMouseLeave(EventArgs e);
protected virtual void OnMouseMove(MouseEventArgs e);
protected virtual void OnMouseUp(MouseEventArgs e);
protected virtual void OnMouseWheel(MouseEventArgs e);
protected virtual void OnMove(EventArgs e);
protected virtual void OnNotifyMessage(Message m);
protected virtual void OnPaint(PaintEventArgs e);
protected virtual void OnPaintBackground(PaintEventArgs e);
protected virtual void OnParentBackColorChanged(EventArgs e);
protected virtual void OnParentBackgroundImageChanged(EventArgs e);
protected virtual void OnParentBindingContextChanged(EventArgs e);
protected virtual void OnParentChanged(EventArgs e);
protected virtual void OnParentEnabledChanged(EventArgs e);
protected virtual void OnParentFontChanged(EventArgs e);
protected virtual void OnParentForeColorChanged(EventArgs e);
protected virtual void OnParentRightToLeftChanged(EventArgs e);
protected virtual void OnParentVisibleChanged(EventArgs e);
protected virtual void OnQueryContinueDrag(QueryContinueDragEventArgs qcdevent);
protected virtual void OnResize(EventArgs e);
protected virtual void OnRightToLeftChanged(EventArgs e);
protected virtual void OnSizeChanged(EventArgs e);
protected virtual void OnStyleChanged(EventArgs e);
protected virtual void OnSystemColorsChanged(EventArgs e);
protected virtual void OnTabIndexChanged(EventArgs e);
protected virtual void OnTabStopChanged(EventArgs e);
protected virtual void OnTextAlignChanged(EventArgs e);
protected virtual void OnTextChanged(EventArgs e);
protected virtual void OnValidated(EventArgs e);
protected virtual void OnValidating(CancelEventArgs e);
protected virtual void OnVisibleChanged(EventArgs e);
public void PerformLayout();
public void PerformLayout(Control affectedControl, string affectedProperty);
public Point PointToClient(Point p);
public Point PointToScreen(Point p);
public bool PreProcessMessage(ref Message msg);
protected virtual bool ProcessCmdKey(ref Message msg, Keys keyData);
protected virtual bool ProcessDialogChar(char charCode);
protected virtual bool ProcessDialogKey(Keys keyData);
protected virtual bool ProcessKeyEventArgs(ref Message m);
protected virtual bool ProcessKeyPreview(ref Message m);
protected virtual bool ProcessMnemonic(char charCode);
protected void RaiseDragEvent(object key, DragEventArgs e);
protected void RaiseKeyEvent(object key, KeyEventArgs e);
protected void RaiseMouseEvent(object key, MouseEventArgs e);
protected void RaisePaintEvent(object key, PaintEventArgs e);
protected void RecreateHandle();
public Rectangle RectangleToClient(Rectangle r);
public Rectangle RectangleToScreen(Rectangle r);
public virtual void Refresh();
public void remove_AutoSizeChanged(EventHandler value);
public void remove_BackColorChanged(EventHandler value);
public void remove_BackgroundImageChanged(EventHandler value);
public void remove_BindingContextChanged(EventHandler value);
public void remove_CausesValidationChanged(EventHandler value);
public void remove_ChangeUICues(UICuesEventHandler value);
public void remove_Click(EventHandler value);
public void remove_ContextMenuChanged(EventHandler value);
public void remove_ControlAdded(ControlEventHandler value);
public void remove_ControlRemoved(ControlEventHandler value);
public void remove_CursorChanged(EventHandler value);
public void remove_Disposed(EventHandler value);
public void remove_DockChanged(EventHandler value);
public void remove_DoubleClick(EventHandler value);
public void remove_DragDrop(DragEventHandler value);
public void remove_DragEnter(DragEventHandler value);
public void remove_DragLeave(EventHandler value);
public void remove_DragOver(DragEventHandler value);
public void remove_EnabledChanged(EventHandler value);
public void remove_Enter(EventHandler value);
public void remove_FontChanged(EventHandler value);
public void remove_ForeColorChanged(EventHandler value);
public void remove_GiveFeedback(GiveFeedbackEventHandler value);
public void remove_GotFocus(EventHandler value);
public void remove_HandleCreated(EventHandler value);
public void remove_HandleDestroyed(EventHandler value);
public void remove_HelpRequested(HelpEventHandler value);
public void remove_ImeModeChanged(EventHandler value);
public void remove_Invalidated(InvalidateEventHandler value);
public void remove_KeyDown(KeyEventHandler value);
public void remove_KeyPress(KeyPressEventHandler value);
public void remove_KeyUp(KeyEventHandler value);
public void remove_Layout(LayoutEventHandler value);
public void remove_Leave(EventHandler value);
public void remove_LocationChanged(EventHandler value);
public void remove_LostFocus(EventHandler value);
public void remove_MouseDown(MouseEventHandler value);
public void remove_MouseEnter(EventHandler value);
public void remove_MouseHover(EventHandler value);
public void remove_MouseLeave(EventHandler value);
public void remove_MouseMove(MouseEventHandler value);
public void remove_MouseUp(MouseEventHandler value);
public void remove_MouseWheel(MouseEventHandler value);
public void remove_Move(EventHandler value);
public void remove_Paint(PaintEventHandler value);
public void remove_ParentChanged(EventHandler value);
public void remove_QueryAccessibilityHelp(QueryAccessibilityHelpEventHandler value);
public void remove_QueryContinueDrag(QueryContinueDragEventHandler value);
public void remove_Resize(EventHandler value);
public void remove_RightToLeftChanged(EventHandler value);
public void remove_SizeChanged(EventHandler value);
public void remove_StyleChanged(EventHandler value);
public void remove_SystemColorsChanged(EventHandler value);
public void remove_TabIndexChanged(EventHandler value);
public void remove_TabStopChanged(EventHandler value);
public void remove_TextAlignChanged(EventHandler value);
public void remove_TextChanged(EventHandler value);
public void remove_Validated(EventHandler value);
public void remove_Validating(CancelEventHandler value);
public void remove_VisibleChanged(EventHandler value);
public void ResetBackColor();
public void ResetBindings();
public void ResetCursor();
public void ResetFont();
public void ResetForeColor();
public void ResetImeMode();
protected void ResetMouseEventArgs();
public void ResetRightToLeft();
public void ResetText();
public void ResumeLayout();
public void ResumeLayout(bool performLayout);
protected ContentAlignment RtlTranslateAlignment(ContentAlignment align);
protected HorizontalAlignment RtlTranslateAlignment(HorizontalAlignment align);
protected LeftRightAlignment RtlTranslateAlignment(LeftRightAlignment align);
protected ContentAlignment RtlTranslateContent(ContentAlignment align);
protected HorizontalAlignment RtlTranslateHorizontal(HorizontalAlignment align);
protected LeftRightAlignment RtlTranslateLeftRight(LeftRightAlignment align);
public void Scale(float ratio);
public void Scale(float dx, float dy);
protected virtual void ScaleCore(float dx, float dy);
public void Select();
protected virtual void Select(bool directed, bool forward);
public bool SelectNextControl(Control ctl, bool forward, bool tabStopOnly, bool nested, bool wrap);
public void SendToBack();
public void SetBounds(int x, int y, int width, int height);
public void SetBounds(int x, int y, int width, int height, BoundsSpecified specified);
protected virtual void SetBoundsCore(int x, int y, int width, int height, BoundsSpecified specified);
protected virtual void SetClientSizeCore(int x, int y);
protected void SetStyle(ControlStyles flag, bool value);
protected void SetTopLevel(bool value);
protected virtual void SetVisibleCore(bool value);
public void Show();
public void SuspendLayout();
public virtual string ToString();
public void Update();
protected void UpdateBounds();
protected void UpdateBounds(int x, int y, int width, int height);
protected void UpdateBounds(int x, int y, int width, int height, int clientWidth, int clientHeight);
protected void UpdateStyles();
protected void UpdateZOrder();
protected virtual void WndProc(ref Message m);

Property
public AccessibleObject AccessibilityObject {get;}
public string AccessibleDefaultActionDescription {get; set;}
public string AccessibleDescription {get; set;}
public string AccessibleName {get; set;}
public AccessibleRole AccessibleRole {get; set;}
public bool AllowDrop {get; set;}
public AnchorStyles Anchor {get; set;}
public virtual bool AutoSize {get; set;}
public virtual Color BackColor {get; set;}
public override Image BackgroundImage {get; set;}
public virtual BindingContext BindingContext {get; set;}
public virtual BorderStyle BorderStyle {get; set;}
public int Bottom {get;}
public Rectangle Bounds {get; set;}
public bool CanFocus {get;}
public bool CanSelect {get;}
public bool Capture {get; set;}
public bool CausesValidation {get; set;}
public Rectangle ClientRectangle {get;}
public Size ClientSize {get; set;}
public string CompanyName {get;}
public IContainer Container {get;}
public bool ContainsFocus {get;}
public ContextMenu ContextMenu {get; set;}
public ControlCollection Controls {get;}
public bool Created {get;}
protected virtual CreateParams CreateParams {get;}
public Cursor Cursor {get; set;}
public ControlBindingsCollection DataBindings {get;}
protected virtual ImeMode DefaultImeMode {get;}
protected virtual Size DefaultSize {get;}
protected bool DesignMode {get;}
public Rectangle DisplayRectangle {get;}
public bool Disposing {get;}
public DockStyle Dock {get; set;}
public bool Enabled {get; set;}
protected EventHandlerList Events {get;}
public FlatStyle FlatStyle {get; set;}
public bool Focused {get;}
public virtual Font Font {get; set;}
protected int FontHeight {get; set;}
public virtual Color ForeColor {get; set;}
public IntPtr Handle {get;}
public bool HasChildren {get;}
public int Height {get; set;}
public Image Image {get; set;}
public ContentAlignment ImageAlign {get; set;}
public int ImageIndex {get; set;}
public ImageList ImageList {get; set;}
public ImeMode ImeMode {get; set;}
public bool InvokeRequired {get;}
public bool IsAccessible {get; set;}
public bool IsDisposed {get;}
public bool IsHandleCreated {get;}
public int Left {get; set;}
public Point Location {get; set;}
public string Name {get; set;}
public Control Parent {get; set;}
public virtual int PreferredHeight {get;}
public virtual int PreferredWidth {get;}
public string ProductName {get;}
public string ProductVersion {get;}
public bool RecreatingHandle {get;}
public Region Region {get; set;}
protected bool RenderRightToLeft {get;}
protected virtual bool RenderTransparent {get; set;}
protected bool ResizeRedraw {get; set;}
public int Right {get;}
public RightToLeft RightToLeft {get; set;}
protected virtual bool ShowFocusCues {get;}
protected bool ShowKeyboardCues {get;}
public ISite Site {get; set;}
public Size Size {get; set;}
public int TabIndex {get; set;}
public bool TabStop {get; set;}
public object Tag {get; set;}
public virtual string Text {get; set;}
public ContentAlignment TextAlign {get; set;}
public int Top {get; set;}
public Control TopLevelControl {get;}
public bool UseMnemonic {get; set;}
public bool Visible {get; set;}
public int Width {get; set;}
public IWindowTarget WindowTarget {get; set;}

System.Windows.Forms.Keys

Module:System.Windows.Forms.dll

Hierarchy
Object
ValueType
Enum
Keys

Type declaration

[C#] public enum Keys;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const Keys A = 65;
public const Keys Add = 107;
public const Keys Alt = 262144;
public const Keys Apps = 93;
public const Keys Attn = 246;
public const Keys B = 66;
public const Keys Back = 8;
public const Keys BrowserBack = 166;
public const Keys BrowserFavorites = 171;
public const Keys BrowserForward = 167;
public const Keys BrowserHome = 172;
public const Keys BrowserRefresh = 168;
public const Keys BrowserSearch = 170;
public const Keys BrowserStop = 169;
public const Keys C = 67;
public const Keys Cancel = 3;
public const Keys Capital = 20;
public const Keys CapsLock = 20;
public const Keys Clear = 12;
public const Keys Control = 131072;
public const Keys ControlKey = 17;
public const Keys Crsel = 247;
public const Keys D = 68;
public const Keys D0 = 48;
public const Keys D1 = 49;
public const Keys D2 = 50;
public const Keys D3 = 51;
public const Keys D4 = 52;
public const Keys D5 = 53;
public const Keys D6 = 54;
public const Keys D7 = 55;
public const Keys D8 = 56;
public const Keys D9 = 57;
public const Keys Decimal = 110;
public const Keys Delete = 46;
public const Keys Divide = 111;
public const Keys Down = 40;
public const Keys E = 69;
public const Keys End = 35;
public const Keys Enter = 13;
public const Keys EraseEof = 249;
public const Keys Escape = 27;
public const Keys Execute = 43;
public const Keys Exsel = 248;
public const Keys F = 70;
public const Keys F1 = 112;
public const Keys F10 = 121;
public const Keys F11 = 122;
public const Keys F12 = 123;
public const Keys F13 = 124;
public const Keys F14 = 125;
public const Keys F15 = 126;
public const Keys F16 = 127;
public const Keys F17 = 128;
public const Keys F18 = 129;
public const Keys F19 = 130;
public const Keys F2 = 113;
public const Keys F20 = 131;
public const Keys F21 = 132;
public const Keys F22 = 133;
public const Keys F23 = 134;
public const Keys F24 = 135;
public const Keys F3 = 114;
public const Keys F4 = 115;
public const Keys F5 = 116;
public const Keys F6 = 117;
public const Keys F7 = 118;
public const Keys F8 = 119;
public const Keys F9 = 120;
public const Keys FinalMode = 24;
public const Keys G = 71;
public const Keys H = 72;
public const Keys HanguelMode = 21;
public const Keys HangulMode = 21;
public const Keys HanjaMode = 25;
public const Keys Help = 47;
public const Keys Home = 36;
public const Keys I = 73;
public const Keys IMEAceept = 30;
public const Keys IMEConvert = 28;
public const Keys IMEModeChange = 31;
public const Keys IMENonconvert = 29;
public const Keys Insert = 45;
public const Keys J = 74;
public const Keys JunjaMode = 23;
public const Keys K = 75;
public const Keys KanaMode = 21;
public const Keys KanjiMode = 25;
public const Keys KeyCode = 65535;
public const Keys L = 76;
public const Keys LaunchApplication1 = 182;
public const Keys LaunchApplication2 = 183;
public const Keys LaunchMail = 180;
public const Keys LButton = 1;
public const Keys LControlKey = 162;
public const Keys Left = 37;
public const Keys LineFeed = 10;
public const Keys LMenu = 164;
public const Keys LShiftKey = 160;
public const Keys LWin = 91;
public const Keys M = 77;
public const Keys MButton = 4;
public const Keys MediaNextTrack = 176;
public const Keys MediaPlayPause = 179;
public const Keys MediaPreviousTrack = 177;
public const Keys MediaStop = 178;
public const Keys Menu = 18;
public const Keys Modifiers = -65536;
public const Keys Multiply = 106;
public const Keys N = 78;
public const Keys Next = 34;
public const Keys NoName = 252;
public const Keys None = 0;
public const Keys NumLock = 144;
public const Keys NumPad0 = 96;
public const Keys NumPad1 = 97;
public const Keys NumPad2 = 98;
public const Keys NumPad3 = 99;
public const Keys NumPad4 = 100;
public const Keys NumPad5 = 101;
public const Keys NumPad6 = 102;
public const Keys NumPad7 = 103;
public const Keys NumPad8 = 104;
public const Keys NumPad9 = 105;
public const Keys O = 79;
public const Keys Oem8 = 223;
public const Keys OemBackslash = 226;
public const Keys OemClear = 254;
public const Keys OemCloseBrackets = 221;
public const Keys Oemcomma = 188;
public const Keys OemMinus = 189;
public const Keys OemOpenBrackets = 219;
public const Keys OemPeriod = 190;
public const Keys OemPipe = 220;
public const Keys Oemplus = 187;
public const Keys OemQuestion = 191;
public const Keys OemQuotes = 222;
public const Keys OemSemicolon = 186;
public const Keys Oemtilde = 192;
public const Keys P = 80;
public const Keys Pa1 = 253;
public const Keys PageDown = 34;
public const Keys PageUp = 33;
public const Keys Pause = 19;
public const Keys Play = 250;
public const Keys Print = 42;
public const Keys PrintScreen = 44;
public const Keys Prior = 33;
public const Keys ProcessKey = 229;
public const Keys Q = 81;
public const Keys R = 82;
public const Keys RButton = 2;
public const Keys RControlKey = 163;
public const Keys Return = 13;
public const Keys Right = 39;
public const Keys RMenu = 165;
public const Keys RShiftKey = 161;
public const Keys RWin = 92;
public const Keys S = 83;
public const Keys Scroll = 145;
public const Keys Select = 41;
public const Keys SelectMedia = 181;
public const Keys Separator = 108;
public const Keys Shift = 65536;
public const Keys ShiftKey = 16;
public const Keys Snapshot = 44;
public const Keys Space = 32;
public const Keys Subtract = 109;
public const Keys T = 84;
public const Keys Tab = 9;
public const Keys U = 85;
public const Keys Up = 38;
public const Keys V = 86;
public int value__;
public const Keys VolumeDown = 174;
public const Keys VolumeMute = 173;
public const Keys VolumeUp = 175;
public const Keys W = 87;
public const Keys X = 88;
public const Keys XButton1 = 5;
public const Keys XButton2 = 6;
public const Keys Y = 89;
public const Keys Z = 90;
public const Keys Zoom = 251;

System.Windows.Forms.KeyPressEventHandler

Module:System.Windows.Forms.dll

Hierarchy
Object
Delegate
MulticastDelegate
KeyPressEventHandler

Type declaration

[C#] public delegate void KeyPressEventHandler(object sender, KeyPressEventArgs e);

Constructor
public KeyPressEventHandler(object object, IntPtr method);

Method
public virtual IAsyncResult BeginInvoke(object sender, KeyPressEventArgs e, AsyncCallback callback, object object);
public object Clone();
protected override Delegate CombineImpl(Delegate follow);
public object DynamicInvoke(object[] args);
protected virtual object DynamicInvokeImpl(object[] args);
public virtual void EndInvoke(IAsyncResult result);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public override Delegate[] GetInvocationList();
protected virtual MethodInfo GetMethodImpl();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
public override void Invoke(object sender, KeyPressEventArgs e);
protected object MemberwiseClone();
protected override Delegate RemoveImpl(Delegate value);
public virtual string ToString();

Property
public MethodInfo Method {get;}
public object Target {get;}

System.Windows.Forms.KeyPressEventArgs

Module:System.Windows.Forms.dll

Hierarchy
Object
EventArgs
KeyPressEventArgs

Type declaration

[C#] public class KeyPressEventArgs : EventArgs;

Constructor
public KeyPressEventArgs(char keyChar);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public bool Handled {get; set;}
public char KeyChar {get;}

System.Windows.Forms.KeyEventHandler

Module:System.Windows.Forms.dll

Hierarchy
Object
Delegate
MulticastDelegate
KeyEventHandler

Type declaration

[C#] public delegate void KeyEventHandler(object sender, KeyEventArgs e);

Constructor
public KeyEventHandler(object object, IntPtr method);

Method
public virtual IAsyncResult BeginInvoke(object sender, KeyEventArgs e, AsyncCallback callback, object object);
public object Clone();
protected override Delegate CombineImpl(Delegate follow);
public object DynamicInvoke(object[] args);
protected virtual object DynamicInvokeImpl(object[] args);
public virtual void EndInvoke(IAsyncResult result);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public override Delegate[] GetInvocationList();
protected virtual MethodInfo GetMethodImpl();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
public override void Invoke(object sender, KeyEventArgs e);
protected object MemberwiseClone();
protected override Delegate RemoveImpl(Delegate value);
public virtual string ToString();

Property
public MethodInfo Method {get;}
public object Target {get;}

System.Windows.Forms.KeyEventArgs

Module:System.Windows.Forms.dll

Hierarchy
Object
EventArgs
KeyEventArgs

Type declaration

[C#] public class KeyEventArgs : EventArgs;

Constructor
public KeyEventArgs(Keys keyData);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public virtual bool Alt {get;}
public bool Control {get;}
public bool Handled {get; set;}
public Keys KeyCode {get;}
public Keys KeyData {get;}
public int KeyValue {get;}
public Keys Modifiers {get;}
public virtual bool Shift {get;}

System.Windows.Forms.HorizontalAlignment

Module:System.Windows.Forms.dll

Hierarchy
Object
ValueType
Enum
HorizontalAlignment

Type declaration

[C#] public enum HorizontalAlignment;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const HorizontalAlignment Center = 2;
public const HorizontalAlignment Left = 0;
public const HorizontalAlignment Right = 1;
public int value__;

System.Windows.Forms.FormWindowState

Module:System.Windows.Forms.dll

Hierarchy
Object
ValueType
Enum
FormWindowState

Type declaration

[C#] public enum FormWindowState;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const FormWindowState Maximized = 2;
public const FormWindowState Minimized = 1;
public const FormWindowState Normal = 0;
public int value__;

System.Windows.Forms.FormBorderStyle

Module:System.Windows.Forms.dll

Hierarchy
Object
ValueType
Enum
FormBorderStyle

Type declaration

[C#] public enum FormBorderStyle;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const FormBorderStyle Fixed3D = 2;
public const FormBorderStyle FixedDialog = 3;
public const FormBorderStyle FixedSingle = 1;
public const FormBorderStyle FixedToolWindow = 5;
public const FormBorderStyle None = 0;
public const FormBorderStyle Sizable = 4;
public const FormBorderStyle SizableToolWindow = 6;
public int value__;

System.Windows.Forms.Form

Module:System.Windows.Forms.dll

Hierarchy
Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form

Type declaration

[C#] public class Form : ContainerControl;

Constructor
public Form();

Method
protected void AccessibilityNotifyClients(AccessibleEvents accEvent, int childID);
public void Activate();
protected void ActivateMdiChild(Form form);
public void add_Activated(EventHandler value);
public void add_BackColorChanged(EventHandler value);
public void add_BackgroundImageChanged(EventHandler value);
public void add_BindingContextChanged(EventHandler value);
public void add_CausesValidationChanged(EventHandler value);
public void add_ChangeUICues(UICuesEventHandler value);
public void add_Click(EventHandler value);
public void add_Closed(EventHandler value);
public void add_Closing(CancelEventHandler value);
public void add_ContextMenuChanged(EventHandler value);
public void add_ControlAdded(ControlEventHandler value);
public void add_ControlRemoved(ControlEventHandler value);
public void add_CursorChanged(EventHandler value);
public void add_Deactivate(EventHandler value);
public void add_Disposed(EventHandler value);
public void add_DockChanged(EventHandler value);
public void add_DoubleClick(EventHandler value);
public void add_DragDrop(DragEventHandler value);
public void add_DragEnter(DragEventHandler value);
public void add_DragLeave(EventHandler value);
public void add_DragOver(DragEventHandler value);
public void add_EnabledChanged(EventHandler value);
public void add_Enter(EventHandler value);
public void add_FontChanged(EventHandler value);
public void add_ForeColorChanged(EventHandler value);
public void add_GiveFeedback(GiveFeedbackEventHandler value);
public void add_GotFocus(EventHandler value);
public void add_HandleCreated(EventHandler value);
public void add_HandleDestroyed(EventHandler value);
public void add_HelpRequested(HelpEventHandler value);
public void add_ImeModeChanged(EventHandler value);
public void add_InputLanguageChanged(InputLanguageChangedEventHandler value);
public void add_InputLanguageChanging(InputLanguageChangingEventHandler value);
public void add_Invalidated(InvalidateEventHandler value);
public void add_KeyDown(KeyEventHandler value);
public void add_KeyPress(KeyPressEventHandler value);
public void add_KeyUp(KeyEventHandler value);
public void add_Layout(LayoutEventHandler value);
public void add_Leave(EventHandler value);
public void add_Load(EventHandler value);
public void add_LocationChanged(EventHandler value);
public void add_LostFocus(EventHandler value);
public void add_MaximizedBoundsChanged(EventHandler value);
public void add_MaximumSizeChanged(EventHandler value);
public void add_MdiChildActivate(EventHandler value);
public void add_MenuComplete(EventHandler value);
public void add_MenuStart(EventHandler value);
public void add_MinimumSizeChanged(EventHandler value);
public void add_MouseDown(MouseEventHandler value);
public void add_MouseEnter(EventHandler value);
public void add_MouseHover(EventHandler value);
public void add_MouseLeave(EventHandler value);
public void add_MouseMove(MouseEventHandler value);
public void add_MouseUp(MouseEventHandler value);
public void add_MouseWheel(MouseEventHandler value);
public void add_Move(EventHandler value);
public void add_Paint(PaintEventHandler value);
public void add_ParentChanged(EventHandler value);
public void add_QueryAccessibilityHelp(QueryAccessibilityHelpEventHandler value);
public void add_QueryContinueDrag(QueryContinueDragEventHandler value);
public void add_Resize(EventHandler value);
public void add_RightToLeftChanged(EventHandler value);
public void add_SizeChanged(EventHandler value);
public void add_StyleChanged(EventHandler value);
public void add_SystemColorsChanged(EventHandler value);
public void add_TabIndexChanged(EventHandler value);
public void add_TabStopChanged(EventHandler value);
public void add_TextChanged(EventHandler value);
public void add_Validated(EventHandler value);
public void add_Validating(CancelEventHandler value);
public void add_VisibleChanged(EventHandler value);
public void AddOwnedForm(Form ownedForm);
protected virtual void AdjustFormScrollbars(bool displayScrollbars);
protected void ApplyAutoScaling();
public IAsyncResult BeginInvoke(Delegate method);
public IAsyncResult BeginInvoke(Delegate method, object[] args);
public void BringToFront();
protected void CenterToParent();
protected void CenterToScreen();
public void Close();
public bool Contains(Control ctl);
protected virtual AccessibleObject CreateAccessibilityInstance();
public void CreateControl();
protected virtual ControlCollection CreateControlsInstance();
public Graphics CreateGraphics();
protected virtual void CreateHandle();
public ObjRef CreateObjRef(Type requestedType);
protected virtual void DefWndProc(ref Message m);
protected virtual void DestroyHandle();
public void Dispose();
protected override void Dispose(bool disposing);
public DragDropEffects DoDragDrop(object data, DragDropEffects allowedEffects);
public object EndInvoke(IAsyncResult asyncResult);
public virtual bool Equals(object obj);
protected override void Finalize();
public Form FindForm();
public bool Focus();
public static SizeF GetAutoScaleSize(Font font);
public Control GetChildAtPoint(Point pt);
public IContainerControl GetContainerControl();
public virtual int GetHashCode();
public object GetLifetimeService();
public Control GetNextControl(Control ctl, bool forward);
protected bool GetScrollState(int bit);
protected virtual object GetService(Type service);
protected bool GetStyle(ControlStyles flag);
protected bool GetTopLevel();
public Type GetType();
public void Hide();
public object InitializeLifetimeService();
protected virtual void InitLayout();
public void Invalidate();
public void Invalidate(bool invalidateChildren);
public void Invalidate(Rectangle rect);
public void Invalidate(Rectangle rc, bool invalidateChildren);
public void Invalidate(Region region);
public void Invalidate(Region region, bool invalidateChildren);
public object Invoke(Delegate method);
public object Invoke(Delegate method, object[] args);
protected void InvokeGotFocus(Control toInvoke, EventArgs e);
protected void InvokeLostFocus(Control toInvoke, EventArgs e);
protected void InvokeOnClick(Control toInvoke, EventArgs e);
protected void InvokePaint(Control c, PaintEventArgs e);
protected void InvokePaintBackground(Control c, PaintEventArgs e);
protected virtual bool IsInputChar(char charCode);
protected virtual bool IsInputKey(Keys keyData);
public void LayoutMdi(MdiLayout value);
protected object MemberwiseClone();
protected virtual void NotifyInvalidate(Rectangle invalidatedArea);
protected virtual void OnActivated(EventArgs e);
protected virtual void OnBackColorChanged(EventArgs e);
protected virtual void OnBackgroundImageChanged(EventArgs e);
protected virtual void OnBindingContextChanged(EventArgs e);
protected virtual void OnCausesValidationChanged(EventArgs e);
protected virtual void OnChangeUICues(UICuesEventArgs e);
protected virtual void OnClick(EventArgs e);
protected virtual void OnClosed(EventArgs e);
protected virtual void OnClosing(CancelEventArgs e);
protected virtual void OnContextMenuChanged(EventArgs e);
protected virtual void OnControlAdded(ControlEventArgs e);
protected virtual void OnControlRemoved(ControlEventArgs e);
protected virtual void OnCreateControl();
protected virtual void OnCursorChanged(EventArgs e);
protected virtual void OnDeactivate(EventArgs e);
protected virtual void OnDockChanged(EventArgs e);
protected virtual void OnDoubleClick(EventArgs e);
protected virtual void OnDragDrop(DragEventArgs drgevent);
protected virtual void OnDragEnter(DragEventArgs drgevent);
protected virtual void OnDragLeave(EventArgs e);
protected virtual void OnDragOver(DragEventArgs drgevent);
protected virtual void OnEnabledChanged(EventArgs e);
protected virtual void OnEnter(EventArgs e);
protected virtual void OnFontChanged(EventArgs e);
protected virtual void OnForeColorChanged(EventArgs e);
protected virtual void OnGiveFeedback(GiveFeedbackEventArgs gfbevent);
protected virtual void OnGotFocus(EventArgs e);
protected virtual void OnHandleCreated(EventArgs e);
protected virtual void OnHandleDestroyed(EventArgs e);
protected virtual void OnHelpRequested(HelpEventArgs hevent);
protected virtual void OnImeModeChanged(EventArgs e);
protected virtual void OnInputLanguageChanged(InputLanguageChangedEventArgs e);
protected virtual void OnInputLanguageChanging(InputLanguageChangingEventArgs e);
protected virtual void OnInvalidated(InvalidateEventArgs e);
protected virtual void OnKeyDown(KeyEventArgs e);
protected virtual void OnKeyPress(KeyPressEventArgs e);
protected virtual void OnKeyUp(KeyEventArgs e);
protected virtual void OnLayout(LayoutEventArgs levent);
protected virtual void OnLeave(EventArgs e);
protected virtual void OnLoad(EventArgs e);
protected virtual void OnLocationChanged(EventArgs e);
protected virtual void OnLostFocus(EventArgs e);
protected virtual void OnMaximizedBoundsChanged(EventArgs e);
protected virtual void OnMaximumSizeChanged(EventArgs e);
protected virtual void OnMdiChildActivate(EventArgs e);
protected virtual void OnMenuComplete(EventArgs e);
protected virtual void OnMenuStart(EventArgs e);
protected virtual void OnMinimumSizeChanged(EventArgs e);
protected virtual void OnMouseDown(MouseEventArgs e);
protected virtual void OnMouseEnter(EventArgs e);
protected virtual void OnMouseHover(EventArgs e);
protected virtual void OnMouseLeave(EventArgs e);
protected virtual void OnMouseMove(MouseEventArgs e);
protected virtual void OnMouseUp(MouseEventArgs e);
protected virtual void OnMouseWheel(MouseEventArgs e);
protected virtual void OnMove(EventArgs e);
protected virtual void OnNotifyMessage(Message m);
protected virtual void OnPaint(PaintEventArgs e);
protected virtual void OnPaintBackground(PaintEventArgs e);
protected virtual void OnParentBackColorChanged(EventArgs e);
protected virtual void OnParentBackgroundImageChanged(EventArgs e);
protected virtual void OnParentBindingContextChanged(EventArgs e);
protected virtual void OnParentChanged(EventArgs e);
protected virtual void OnParentEnabledChanged(EventArgs e);
protected virtual void OnParentFontChanged(EventArgs e);
protected virtual void OnParentForeColorChanged(EventArgs e);
protected virtual void OnParentRightToLeftChanged(EventArgs e);
protected virtual void OnParentVisibleChanged(EventArgs e);
protected virtual void OnQueryContinueDrag(QueryContinueDragEventArgs qcdevent);
protected virtual void OnResize(EventArgs e);
protected virtual void OnRightToLeftChanged(EventArgs e);
protected virtual void OnSizeChanged(EventArgs e);
protected virtual void OnStyleChanged(EventArgs e);
protected virtual void OnSystemColorsChanged(EventArgs e);
protected virtual void OnTabIndexChanged(EventArgs e);
protected virtual void OnTabStopChanged(EventArgs e);
protected virtual void OnTextChanged(EventArgs e);
protected virtual void OnValidated(EventArgs e);
protected virtual void OnValidating(CancelEventArgs e);
protected virtual void OnVisibleChanged(EventArgs e);
public void PerformLayout();
public void PerformLayout(Control affectedControl, string affectedProperty);
public Point PointToClient(Point p);
public Point PointToScreen(Point p);
public bool PreProcessMessage(ref Message msg);
protected virtual bool ProcessCmdKey(ref Message msg, Keys keyData);
protected virtual bool ProcessDialogChar(char charCode);
protected virtual bool ProcessDialogKey(Keys keyData);
protected virtual bool ProcessKeyEventArgs(ref Message m);
protected virtual bool ProcessKeyPreview(ref Message m);
protected virtual bool ProcessMnemonic(char charCode);
protected virtual bool ProcessTabKey(bool forward);
protected void RaiseDragEvent(object key, DragEventArgs e);
protected void RaiseKeyEvent(object key, KeyEventArgs e);
protected void RaiseMouseEvent(object key, MouseEventArgs e);
protected void RaisePaintEvent(object key, PaintEventArgs e);
protected void RecreateHandle();
public Rectangle RectangleToClient(Rectangle r);
public Rectangle RectangleToScreen(Rectangle r);
public virtual void Refresh();
public void remove_Activated(EventHandler value);
public void remove_BackColorChanged(EventHandler value);
public void remove_BackgroundImageChanged(EventHandler value);
public void remove_BindingContextChanged(EventHandler value);
public void remove_CausesValidationChanged(EventHandler value);
public void remove_ChangeUICues(UICuesEventHandler value);
public void remove_Click(EventHandler value);
public void remove_Closed(EventHandler value);
public void remove_Closing(CancelEventHandler value);
public void remove_ContextMenuChanged(EventHandler value);
public void remove_ControlAdded(ControlEventHandler value);
public void remove_ControlRemoved(ControlEventHandler value);
public void remove_CursorChanged(EventHandler value);
public void remove_Deactivate(EventHandler value);
public void remove_Disposed(EventHandler value);
public void remove_DockChanged(EventHandler value);
public void remove_DoubleClick(EventHandler value);
public void remove_DragDrop(DragEventHandler value);
public void remove_DragEnter(DragEventHandler value);
public void remove_DragLeave(EventHandler value);
public void remove_DragOver(DragEventHandler value);
public void remove_EnabledChanged(EventHandler value);
public void remove_Enter(EventHandler value);
public void remove_FontChanged(EventHandler value);
public void remove_ForeColorChanged(EventHandler value);
public void remove_GiveFeedback(GiveFeedbackEventHandler value);
public void remove_GotFocus(EventHandler value);
public void remove_HandleCreated(EventHandler value);
public void remove_HandleDestroyed(EventHandler value);
public void remove_HelpRequested(HelpEventHandler value);
public void remove_ImeModeChanged(EventHandler value);
public void remove_InputLanguageChanged(InputLanguageChangedEventHandler value);
public void remove_InputLanguageChanging(InputLanguageChangingEventHandler value);
public void remove_Invalidated(InvalidateEventHandler value);
public void remove_KeyDown(KeyEventHandler value);
public void remove_KeyPress(KeyPressEventHandler value);
public void remove_KeyUp(KeyEventHandler value);
public void remove_Layout(LayoutEventHandler value);
public void remove_Leave(EventHandler value);
public void remove_Load(EventHandler value);
public void remove_LocationChanged(EventHandler value);
public void remove_LostFocus(EventHandler value);
public void remove_MaximizedBoundsChanged(EventHandler value);
public void remove_MaximumSizeChanged(EventHandler value);
public void remove_MdiChildActivate(EventHandler value);
public void remove_MenuComplete(EventHandler value);
public void remove_MenuStart(EventHandler value);
public void remove_MinimumSizeChanged(EventHandler value);
public void remove_MouseDown(MouseEventHandler value);
public void remove_MouseEnter(EventHandler value);
public void remove_MouseHover(EventHandler value);
public void remove_MouseLeave(EventHandler value);
public void remove_MouseMove(MouseEventHandler value);
public void remove_MouseUp(MouseEventHandler value);
public void remove_MouseWheel(MouseEventHandler value);
public void remove_Move(EventHandler value);
public void remove_Paint(PaintEventHandler value);
public void remove_ParentChanged(EventHandler value);
public void remove_QueryAccessibilityHelp(QueryAccessibilityHelpEventHandler value);
public void remove_QueryContinueDrag(QueryContinueDragEventHandler value);
public void remove_Resize(EventHandler value);
public void remove_RightToLeftChanged(EventHandler value);
public void remove_SizeChanged(EventHandler value);
public void remove_StyleChanged(EventHandler value);
public void remove_SystemColorsChanged(EventHandler value);
public void remove_TabIndexChanged(EventHandler value);
public void remove_TabStopChanged(EventHandler value);
public void remove_TextChanged(EventHandler value);
public void remove_Validated(EventHandler value);
public void remove_Validating(CancelEventHandler value);
public void remove_VisibleChanged(EventHandler value);
public void RemoveOwnedForm(Form ownedForm);
public void ResetBackColor();
public void ResetBindings();
public void ResetCursor();
public void ResetFont();
public void ResetForeColor();
public void ResetImeMode();
protected void ResetMouseEventArgs();
public void ResetRightToLeft();
public void ResetText();
public void ResumeLayout();
public void ResumeLayout(bool performLayout);
protected ContentAlignment RtlTranslateAlignment(ContentAlignment align);
protected HorizontalAlignment RtlTranslateAlignment(HorizontalAlignment align);
protected LeftRightAlignment RtlTranslateAlignment(LeftRightAlignment align);
protected ContentAlignment RtlTranslateContent(ContentAlignment align);
protected HorizontalAlignment RtlTranslateHorizontal(HorizontalAlignment align);
protected LeftRightAlignment RtlTranslateLeftRight(LeftRightAlignment align);
public void Scale(float ratio);
public void Scale(float dx, float dy);
protected virtual void ScaleCore(float x, float y);
public void ScrollControlIntoView(Control activeControl);
public void Select();
protected virtual void Select(bool directed, bool forward);
public bool SelectNextControl(Control ctl, bool forward, bool tabStopOnly, bool nested, bool wrap);
public void SendToBack();
public void SetAutoScrollMargin(int x, int y);
public void SetBounds(int x, int y, int width, int height);
public void SetBounds(int x, int y, int width, int height, BoundsSpecified specified);
protected virtual void SetBoundsCore(int x, int y, int width, int height, BoundsSpecified specified);
protected virtual void SetClientSizeCore(int x, int y);
public void SetDesktopBounds(int x, int y, int width, int height);
public void SetDesktopLocation(int x, int y);
protected void SetDisplayRectLocation(int x, int y);
protected void SetScrollState(int bit, bool value);
protected void SetStyle(ControlStyles flag, bool value);
protected void SetTopLevel(bool value);
protected virtual void SetVisibleCore(bool value);
public void Show();
public DialogResult ShowDialog();
public DialogResult ShowDialog(IWin32Window owner);
public void SuspendLayout();
public virtual string ToString();
public void Update();
protected void UpdateBounds();
protected void UpdateBounds(int x, int y, int width, int height);
protected void UpdateBounds(int x, int y, int width, int height, int clientWidth, int clientHeight);
protected virtual void UpdateDefaultButton();
protected void UpdateStyles();
protected void UpdateZOrder();
public bool Validate();
protected virtual void WndProc(ref Message m);

Property
public IButtonControl AcceptButton {get; set;}
public AccessibleObject AccessibilityObject {get;}
public string AccessibleDefaultActionDescription {get; set;}
public string AccessibleDescription {get; set;}
public string AccessibleName {get; set;}
public AccessibleRole AccessibleRole {get; set;}
public Control ActiveControl {get; set;}
public static Form ActiveForm {get;}
public Form ActiveMdiChild {get;}
public bool AllowDrop {get; set;}
public bool AllowTransparency {get; set;}
public AnchorStyles Anchor {get; set;}
public bool AutoScale {get; set;}
public virtual Size AutoScaleBaseSize {get; set;}
public override bool AutoScroll {get; set;}
public Size AutoScrollMargin {get; set;}
public Size AutoScrollMinSize {get; set;}
public Point AutoScrollPosition {get; set;}
public virtual Color BackColor {get; set;}
public Image BackgroundImage {get; set;}
public override BindingContext BindingContext {get; set;}
public int Bottom {get;}
public Rectangle Bounds {get; set;}
public IButtonControl CancelButton {get; set;}
public bool CanFocus {get;}
public bool CanSelect {get;}
public bool Capture {get; set;}
public bool CausesValidation {get; set;}
public Rectangle ClientRectangle {get;}
public Size ClientSize {get; set;}
public string CompanyName {get;}
public IContainer Container {get;}
public bool ContainsFocus {get;}
public ContextMenu ContextMenu {get; set;}
public bool ControlBox {get; set;}
public ControlCollection Controls {get;}
public bool Created {get;}
protected virtual CreateParams CreateParams {get;}
public Cursor Cursor {get; set;}
public ControlBindingsCollection DataBindings {get;}
protected virtual ImeMode DefaultImeMode {get;}
protected virtual Size DefaultSize {get;}
protected bool DesignMode {get;}
public Rectangle DesktopBounds {get; set;}
public Point DesktopLocation {get; set;}
public DialogResult DialogResult {get; set;}
public Rectangle DisplayRectangle {get;}
public bool Disposing {get;}
public DockStyle Dock {get; set;}
public DockPaddingEdges DockPadding {get;}
public bool Enabled {get; set;}
protected EventHandlerList Events {get;}
public bool Focused {get;}
public virtual Font Font {get; set;}
protected int FontHeight {get; set;}
public virtual Color ForeColor {get; set;}
public FormBorderStyle FormBorderStyle {get; set;}
public IntPtr Handle {get;}
public bool HasChildren {get;}
public int Height {get; set;}
public bool HelpButton {get; set;}
protected bool HScroll {get; set;}
public Icon Icon {get; set;}
public ImeMode ImeMode {get; set;}
public bool InvokeRequired {get;}
public bool IsAccessible {get; set;}
public bool IsDisposed {get;}
public bool IsHandleCreated {get;}
public bool IsMdiChild {get;}
public bool IsMdiContainer {get; set;}
public bool IsRestrictedWindow {get;}
public bool KeyPreview {get; set;}
public int Left {get; set;}
public Point Location {get; set;}
public bool MaximizeBox {get; set;}
protected Rectangle MaximizedBounds {get; set;}
public Size MaximumSize {get; set;}
public Form[] MdiChildren {get;}
public Form MdiParent {get; set;}
public MainMenu Menu {get; set;}
public MainMenu MergedMenu {get;}
public bool MinimizeBox {get; set;}
public Size MinimumSize {get; set;}
public bool Modal {get;}
public string Name {get; set;}
public double Opacity {get; set;}
public Form[] OwnedForms {get;}
public Form Owner {get; set;}
public Control Parent {get; set;}
public Form ParentForm {get;}
public string ProductName {get;}
public string ProductVersion {get;}
public bool RecreatingHandle {get;}
public Region Region {get; set;}
protected bool RenderRightToLeft {get;}
protected bool ResizeRedraw {get; set;}
public int Right {get;}
public RightToLeft RightToLeft {get; set;}
protected virtual bool ShowFocusCues {get;}
public bool ShowInTaskbar {get; set;}
protected bool ShowKeyboardCues {get;}
public ISite Site {get; set;}
public Size Size {get; set;}
public SizeGripStyle SizeGripStyle {get; set;}
public FormStartPosition StartPosition {get; set;}
public int TabIndex {get; set;}
public bool TabStop {get; set;}
public object Tag {get; set;}
public virtual string Text {get; set;}
public int Top {get; set;}
public bool TopLevel {get; set;}
public Control TopLevelControl {get;}
public bool TopMost {get; set;}
public Color TransparencyKey {get; set;}
public bool Visible {get; set;}
protected bool VScroll {get; set;}
public int Width {get; set;}
public FormWindowState WindowState {get; set;}
public IWindowTarget WindowTarget {get; set;}

System.Windows.Forms.FileDialog

Module:System.Windows.Forms.dll

Hierarchy
Object
MarshalByRefObject
Component
CommonDialog
FileDialog

Type declaration

[C#] public abstract class FileDialog : CommonDialog;

Method
public void add_Disposed(EventHandler value);
public void add_FileOk(CancelEventHandler value);
public void add_HelpRequest(EventHandler value);
public ObjRef CreateObjRef(Type requestedType);
public void Dispose();
protected virtual void Dispose(bool disposing);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public object GetLifetimeService();
protected virtual object GetService(Type service);
public Type GetType();
protected virtual IntPtr HookProc(IntPtr hWnd, int msg, IntPtr wparam, IntPtr lparam);
public object InitializeLifetimeService();
protected object MemberwiseClone();
protected void OnFileOk(CancelEventArgs e);
protected virtual void OnHelpRequest(EventArgs e);
protected virtual IntPtr OwnerWndProc(IntPtr hWnd, int msg, IntPtr wparam, IntPtr lparam);
public void remove_Disposed(EventHandler value);
public void remove_FileOk(CancelEventHandler value);
public void remove_HelpRequest(EventHandler value);
public override void Reset();
protected virtual bool RunDialog(IntPtr hWndOwner);
public DialogResult ShowDialog();
public DialogResult ShowDialog(IWin32Window owner);
public virtual string ToString();

Property
public bool AddExtension {get; set;}
public virtual bool CheckFileExists {get; set;}
public bool CheckPathExists {get; set;}
public IContainer Container {get;}
public string DefaultExt {get; set;}
public bool DereferenceLinks {get; set;}
protected bool DesignMode {get;}
protected EventHandlerList Events {get;}
public string FileName {get; set;}
public string[] FileNames {get;}
public string Filter {get; set;}
public int FilterIndex {get; set;}
public string InitialDirectory {get; set;}
protected virtual IntPtr Instance {get;}
protected int Options {get;}
public bool RestoreDirectory {get; set;}
public bool ShowHelp {get; set;}
public ISite Site {get; set;}
public string Title {get; set;}
public bool ValidateNames {get; set;}

Field
protected readonly static object EventFileOk;

System.Windows.Forms.ImageList+ImageCollection

Module:System.Windows.Forms.dll

Hierarchy
Object
ImageList+ImageCollection : IList, ICollection, IEnumerable

Type declaration

[C#] public sealed class ImageCollection: IList, ICollection, IEnumerable;

Method
public void Add(Icon icn);
public void Add(Image img);
public int Add(Image value, Color transparentColor);
public int AddStrip(Image value);
public virtual void Clear();
public bool Contains(Image image);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual IEnumerator GetEnumerator();
public virtual int GetHashCode();
public Type GetType();
public int IndexOf(Image image);
protected object MemberwiseClone();
public void Remove(Image image);
public virtual void RemoveAt(int index);
public virtual string ToString();

Property
public virtual int Count {get;}
public bool Empty {get;}
public virtual bool IsReadOnly {get;}
public Image this[int index] {get; set;}

System.Windows.Forms.ImageList

Module:System.Windows.Forms.dll

Hierarchy
Object
MarshalByRefObject
Component
ImageList

Type declaration

[C#] public sealed class ImageList : Component;

Constructor
public ImageList();
public ImageList(IContainer container);

Method
public void add_Disposed(EventHandler value);
public void add_RecreateHandle(EventHandler value);
public ObjRef CreateObjRef(Type requestedType);
public void Dispose();
protected virtual void Dispose(bool disposing);
public void Draw(Graphics g, int x, int y, int index);
public void Draw(Graphics g, int x, int y, int width, int height, int index);
public void Draw(Graphics g, Point pt, int index);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public object GetLifetimeService();
protected virtual object GetService(Type service);
public Type GetType();
public object InitializeLifetimeService();
protected object MemberwiseClone();
public void remove_Disposed(EventHandler value);
public void remove_RecreateHandle(EventHandler value);
public virtual string ToString();

Property
public ColorDepth ColorDepth {get; set;}
public IContainer Container {get;}
protected bool DesignMode {get;}
protected EventHandlerList Events {get;}
public IntPtr Handle {get;}
public bool HandleCreated {get;}
public ImageCollection Images {get;}
public Size ImageSize {get; set;}
public ImageListStreamer ImageStream {get; set;}
public ISite Site {get; set;}
public Color TransparentColor {get; set;}

System.Windows.Forms.DomainUpDown+DomainUpDownItemCollection

Module:System.Windows.Forms.dll

Hierarchy
Object
ArrayList
DomainUpDown+DomainUpDownItemCollection

Type declaration

[C#] public class DomainUpDownItemCollection : ArrayList;

Method
public virtual int Add(object value);
public virtual void AddRange(ICollection c);
public virtual int BinarySearch(int index, int count, object value, IComparer comparer);
public int BinarySearch(object value);
public int BinarySearch(object value, IComparer comparer);
public virtual void Clear();
public virtual object Clone();
public virtual bool Contains(object item);
public virtual void CopyTo(Array array);
public virtual void CopyTo(Array array, int arrayIndex);
public virtual void CopyTo(int index, Array array, int arrayIndex, int count);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual IEnumerator GetEnumerator();
public IEnumerator GetEnumerator(int index, int count);
public virtual int GetHashCode();
public ArrayList GetRange(int index, int count);
public Type GetType();
public virtual int IndexOf(object value);
public int IndexOf(object value, int startIndex);
public virtual int IndexOf(object value, int startIndex, int count);
public virtual void Insert(int index, object value);
public virtual void InsertRange(int index, ICollection c);
public int LastIndexOf(object value);
public int LastIndexOf(object value, int startIndex);
public int LastIndexOf(object value, int startIndex, int count);
protected object MemberwiseClone();
public virtual void Remove(object obj);
public override void RemoveAt(int item);
public virtual void RemoveRange(int index, int count);
public virtual void Reverse();
public virtual void Reverse(int index, int count);
public void SetRange(int index, ICollection c);
public virtual void Sort();
public virtual void Sort(IComparer comparer);
public virtual void Sort(int index, int count, IComparer comparer);
public virtual object[] ToArray();
public virtual Array ToArray(Type type);
public virtual string ToString();
public virtual void TrimToSize();

Property
public virtual int Capacity {get; set;}
public virtual int Count {get;}
public virtual bool IsFixedSize {get;}
public virtual bool IsReadOnly {get;}
public virtual bool IsSynchronized {get;}
public override object this[int index] {get; set;}
public virtual object SyncRoot {get;}

System.Windows.Forms.DomainUpDown

Module:System.Windows.Forms.dll

Hierarchy
Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UpDownBase
DomainUpDown

Type declaration

[C#] public class DomainUpDown : UpDownBase;

Constructor
public DomainUpDown();

Method
protected void AccessibilityNotifyClients(AccessibleEvents accEvent, int childID);
public void add_BackColorChanged(EventHandler value);
public void add_BackgroundImageChanged(EventHandler value);
public void add_BindingContextChanged(EventHandler value);
public void add_CausesValidationChanged(EventHandler value);
public void add_ChangeUICues(UICuesEventHandler value);
public void add_Click(EventHandler value);
public void add_ContextMenuChanged(EventHandler value);
public void add_ControlAdded(ControlEventHandler value);
public void add_ControlRemoved(ControlEventHandler value);
public void add_CursorChanged(EventHandler value);
public void add_Disposed(EventHandler value);
public void add_DockChanged(EventHandler value);
public void add_DoubleClick(EventHandler value);
public void add_DragDrop(DragEventHandler value);
public void add_DragEnter(DragEventHandler value);
public void add_DragLeave(EventHandler value);
public void add_DragOver(DragEventHandler value);
public void add_EnabledChanged(EventHandler value);
public void add_Enter(EventHandler value);
public void add_FontChanged(EventHandler value);
public void add_ForeColorChanged(EventHandler value);
public void add_GiveFeedback(GiveFeedbackEventHandler value);
public void add_GotFocus(EventHandler value);
public void add_HandleCreated(EventHandler value);
public void add_HandleDestroyed(EventHandler value);
public void add_HelpRequested(HelpEventHandler value);
public void add_ImeModeChanged(EventHandler value);
public void add_Invalidated(InvalidateEventHandler value);
public void add_KeyDown(KeyEventHandler value);
public void add_KeyPress(KeyPressEventHandler value);
public void add_KeyUp(KeyEventHandler value);
public void add_Layout(LayoutEventHandler value);
public void add_Leave(EventHandler value);
public void add_LocationChanged(EventHandler value);
public void add_LostFocus(EventHandler value);
public void add_MouseDown(MouseEventHandler value);
public void add_MouseEnter(EventHandler value);
public void add_MouseHover(EventHandler value);
public void add_MouseLeave(EventHandler value);
public void add_MouseMove(MouseEventHandler value);
public void add_MouseUp(MouseEventHandler value);
public void add_MouseWheel(MouseEventHandler value);
public void add_Move(EventHandler value);
public void add_Paint(PaintEventHandler value);
public void add_ParentChanged(EventHandler value);
public void add_QueryAccessibilityHelp(QueryAccessibilityHelpEventHandler value);
public void add_QueryContinueDrag(QueryContinueDragEventHandler value);
public void add_Resize(EventHandler value);
public void add_RightToLeftChanged(EventHandler value);
public void add_SelectedItemChanged(EventHandler value);
public void add_SizeChanged(EventHandler value);
public void add_StyleChanged(EventHandler value);
public void add_SystemColorsChanged(EventHandler value);
public void add_TabIndexChanged(EventHandler value);
public void add_TabStopChanged(EventHandler value);
public void add_TextChanged(EventHandler value);
public void add_Validated(EventHandler value);
public void add_Validating(CancelEventHandler value);
public void add_VisibleChanged(EventHandler value);
protected virtual void AdjustFormScrollbars(bool displayScrollbars);
public IAsyncResult BeginInvoke(Delegate method);
public IAsyncResult BeginInvoke(Delegate method, object[] args);
public void BringToFront();
public bool Contains(Control ctl);
protected virtual AccessibleObject CreateAccessibilityInstance();
public void CreateControl();
protected virtual ControlCollection CreateControlsInstance();
public Graphics CreateGraphics();
protected virtual void CreateHandle();
public ObjRef CreateObjRef(Type requestedType);
protected virtual void DefWndProc(ref Message m);
protected virtual void DestroyHandle();
public void Dispose();
protected override void Dispose(bool disposing);
public DragDropEffects DoDragDrop(object data, DragDropEffects allowedEffects);
public override void DownButton();
public object EndInvoke(IAsyncResult asyncResult);
public virtual bool Equals(object obj);
protected override void Finalize();
public Form FindForm();
public bool Focus();
public Control GetChildAtPoint(Point pt);
public IContainerControl GetContainerControl();
public virtual int GetHashCode();
public object GetLifetimeService();
public Control GetNextControl(Control ctl, bool forward);
protected bool GetScrollState(int bit);
protected virtual object GetService(Type service);
protected bool GetStyle(ControlStyles flag);
protected bool GetTopLevel();
public Type GetType();
public void Hide();
public object InitializeLifetimeService();
protected virtual void InitLayout();
public void Invalidate();
public void Invalidate(bool invalidateChildren);
public void Invalidate(Rectangle rect);
public void Invalidate(Rectangle rc, bool invalidateChildren);
public void Invalidate(Region region);
public void Invalidate(Region region, bool invalidateChildren);
public object Invoke(Delegate method);
public object Invoke(Delegate method, object[] args);
protected void InvokeGotFocus(Control toInvoke, EventArgs e);
protected void InvokeLostFocus(Control toInvoke, EventArgs e);
protected void InvokeOnClick(Control toInvoke, EventArgs e);
protected void InvokePaint(Control c, PaintEventArgs e);
protected void InvokePaintBackground(Control c, PaintEventArgs e);
protected virtual bool IsInputChar(char charCode);
protected virtual bool IsInputKey(Keys keyData);
protected object MemberwiseClone();
protected virtual void NotifyInvalidate(Rectangle invalidatedArea);
protected virtual void OnBackColorChanged(EventArgs e);
protected virtual void OnBackgroundImageChanged(EventArgs e);
protected virtual void OnBindingContextChanged(EventArgs e);
protected virtual void OnCausesValidationChanged(EventArgs e);
protected virtual void OnChanged(object source, EventArgs e);
protected virtual void OnChangeUICues(UICuesEventArgs e);
protected virtual void OnClick(EventArgs e);
protected virtual void OnContextMenuChanged(EventArgs e);
protected virtual void OnControlAdded(ControlEventArgs e);
protected virtual void OnControlRemoved(ControlEventArgs e);
protected virtual void OnCreateControl();
protected virtual void OnCursorChanged(EventArgs e);
protected virtual void OnDockChanged(EventArgs e);
protected virtual void OnDoubleClick(EventArgs e);
protected virtual void OnDragDrop(DragEventArgs drgevent);
protected virtual void OnDragEnter(DragEventArgs drgevent);
protected virtual void OnDragLeave(EventArgs e);
protected virtual void OnDragOver(DragEventArgs drgevent);
protected virtual void OnEnabledChanged(EventArgs e);
protected virtual void OnEnter(EventArgs e);
protected virtual void OnFontChanged(EventArgs e);
protected virtual void OnForeColorChanged(EventArgs e);
protected virtual void OnGiveFeedback(GiveFeedbackEventArgs gfbevent);
protected virtual void OnGotFocus(EventArgs e);
protected virtual void OnHandleCreated(EventArgs e);
protected virtual void OnHandleDestroyed(EventArgs e);
protected virtual void OnHelpRequested(HelpEventArgs hevent);
protected virtual void OnImeModeChanged(EventArgs e);
protected virtual void OnInvalidated(InvalidateEventArgs e);
protected virtual void OnKeyDown(KeyEventArgs e);
protected virtual void OnKeyPress(KeyPressEventArgs e);
protected virtual void OnKeyUp(KeyEventArgs e);
protected virtual void OnLayout(LayoutEventArgs e);
protected virtual void OnLeave(EventArgs e);
protected virtual void OnLocationChanged(EventArgs e);
protected virtual void OnLostFocus(EventArgs e);
protected virtual void OnMouseDown(MouseEventArgs e);
protected virtual void OnMouseEnter(EventArgs e);
protected virtual void OnMouseHover(EventArgs e);
protected virtual void OnMouseLeave(EventArgs e);
protected virtual void OnMouseMove(MouseEventArgs e);
protected virtual void OnMouseUp(MouseEventArgs e);
protected virtual void OnMouseWheel(MouseEventArgs e);
protected virtual void OnMove(EventArgs e);
protected virtual void OnNotifyMessage(Message m);
protected virtual void OnPaint(PaintEventArgs e);
protected virtual void OnPaintBackground(PaintEventArgs e);
protected virtual void OnParentBackColorChanged(EventArgs e);
protected virtual void OnParentBackgroundImageChanged(EventArgs e);
protected virtual void OnParentBindingContextChanged(EventArgs e);
protected virtual void OnParentChanged(EventArgs e);
protected virtual void OnParentEnabledChanged(EventArgs e);
protected virtual void OnParentFontChanged(EventArgs e);
protected virtual void OnParentForeColorChanged(EventArgs e);
protected virtual void OnParentRightToLeftChanged(EventArgs e);
protected virtual void OnParentVisibleChanged(EventArgs e);
protected virtual void OnQueryContinueDrag(QueryContinueDragEventArgs qcdevent);
protected virtual void OnResize(EventArgs e);
protected virtual void OnRightToLeftChanged(EventArgs e);
protected void OnSelectedItemChanged(object source, EventArgs e);
protected virtual void OnSizeChanged(EventArgs e);
protected virtual void OnStyleChanged(EventArgs e);
protected virtual void OnSystemColorsChanged(EventArgs e);
protected virtual void OnTabIndexChanged(EventArgs e);
protected virtual void OnTabStopChanged(EventArgs e);
protected virtual void OnTextBoxKeyDown(object source, KeyEventArgs e);
protected virtual void OnTextBoxKeyPress(object source, KeyPressEventArgs e);
protected virtual void OnTextBoxLostFocus(object source, EventArgs e);
protected virtual void OnTextBoxResize(object source, EventArgs e);
protected virtual void OnTextBoxTextChanged(object source, EventArgs e);
protected virtual void OnTextChanged(EventArgs e);
protected virtual void OnValidated(EventArgs e);
protected virtual void OnValidating(CancelEventArgs e);
protected virtual void OnVisibleChanged(EventArgs e);
public void PerformLayout();
public void PerformLayout(Control affectedControl, string affectedProperty);
public Point PointToClient(Point p);
public Point PointToScreen(Point p);
public bool PreProcessMessage(ref Message msg);
protected virtual bool ProcessCmdKey(ref Message msg, Keys keyData);
protected virtual bool ProcessDialogChar(char charCode);
protected virtual bool ProcessDialogKey(Keys keyData);
protected virtual bool ProcessKeyEventArgs(ref Message m);
protected virtual bool ProcessKeyPreview(ref Message m);
protected virtual bool ProcessMnemonic(char charCode);
protected virtual bool ProcessTabKey(bool forward);
protected void RaiseDragEvent(object key, DragEventArgs e);
protected void RaiseKeyEvent(object key, KeyEventArgs e);
protected void RaiseMouseEvent(object key, MouseEventArgs e);
protected void RaisePaintEvent(object key, PaintEventArgs e);
protected void RecreateHandle();
public Rectangle RectangleToClient(Rectangle r);
public Rectangle RectangleToScreen(Rectangle r);
public virtual void Refresh();
public void remove_BackColorChanged(EventHandler value);
public void remove_BackgroundImageChanged(EventHandler value);
public void remove_BindingContextChanged(EventHandler value);
public void remove_CausesValidationChanged(EventHandler value);
public void remove_ChangeUICues(UICuesEventHandler value);
public void remove_Click(EventHandler value);
public void remove_ContextMenuChanged(EventHandler value);
public void remove_ControlAdded(ControlEventHandler value);
public void remove_ControlRemoved(ControlEventHandler value);
public void remove_CursorChanged(EventHandler value);
public void remove_Disposed(EventHandler value);
public void remove_DockChanged(EventHandler value);
public void remove_DoubleClick(EventHandler value);
public void remove_DragDrop(DragEventHandler value);
public void remove_DragEnter(DragEventHandler value);
public void remove_DragLeave(EventHandler value);
public void remove_DragOver(DragEventHandler value);
public void remove_EnabledChanged(EventHandler value);
public void remove_Enter(EventHandler value);
public void remove_FontChanged(EventHandler value);
public void remove_ForeColorChanged(EventHandler value);
public void remove_GiveFeedback(GiveFeedbackEventHandler value);
public void remove_GotFocus(EventHandler value);
public void remove_HandleCreated(EventHandler value);
public void remove_HandleDestroyed(EventHandler value);
public void remove_HelpRequested(HelpEventHandler value);
public void remove_ImeModeChanged(EventHandler value);
public void remove_Invalidated(InvalidateEventHandler value);
public void remove_KeyDown(KeyEventHandler value);
public void remove_KeyPress(KeyPressEventHandler value);
public void remove_KeyUp(KeyEventHandler value);
public void remove_Layout(LayoutEventHandler value);
public void remove_Leave(EventHandler value);
public void remove_LocationChanged(EventHandler value);
public void remove_LostFocus(EventHandler value);
public void remove_MouseDown(MouseEventHandler value);
public void remove_MouseEnter(EventHandler value);
public void remove_MouseHover(EventHandler value);
public void remove_MouseLeave(EventHandler value);
public void remove_MouseMove(MouseEventHandler value);
public void remove_MouseUp(MouseEventHandler value);
public void remove_MouseWheel(MouseEventHandler value);
public void remove_Move(EventHandler value);
public void remove_Paint(PaintEventHandler value);
public void remove_ParentChanged(EventHandler value);
public void remove_QueryAccessibilityHelp(QueryAccessibilityHelpEventHandler value);
public void remove_QueryContinueDrag(QueryContinueDragEventHandler value);
public void remove_Resize(EventHandler value);
public void remove_RightToLeftChanged(EventHandler value);
public void remove_SelectedItemChanged(EventHandler value);
public void remove_SizeChanged(EventHandler value);
public void remove_StyleChanged(EventHandler value);
public void remove_SystemColorsChanged(EventHandler value);
public void remove_TabIndexChanged(EventHandler value);
public void remove_TabStopChanged(EventHandler value);
public void remove_TextChanged(EventHandler value);
public void remove_Validated(EventHandler value);
public void remove_Validating(CancelEventHandler value);
public void remove_VisibleChanged(EventHandler value);
public void ResetBackColor();
public void ResetBindings();
public void ResetCursor();
public void ResetFont();
public void ResetForeColor();
public void ResetImeMode();
protected void ResetMouseEventArgs();
public void ResetRightToLeft();
public void ResetText();
public void ResumeLayout();
public void ResumeLayout(bool performLayout);
protected ContentAlignment RtlTranslateAlignment(ContentAlignment align);
protected HorizontalAlignment RtlTranslateAlignment(HorizontalAlignment align);
protected LeftRightAlignment RtlTranslateAlignment(LeftRightAlignment align);
protected ContentAlignment RtlTranslateContent(ContentAlignment align);
protected HorizontalAlignment RtlTranslateHorizontal(HorizontalAlignment align);
protected LeftRightAlignment RtlTranslateLeftRight(LeftRightAlignment align);
public void Scale(float ratio);
public void Scale(float dx, float dy);
protected virtual void ScaleCore(float dx, float dy);
public void ScrollControlIntoView(Control activeControl);
public void Select();
protected virtual void Select(bool directed, bool forward);
public void Select(int start, int length);
public bool SelectNextControl(Control ctl, bool forward, bool tabStopOnly, bool nested, bool wrap);
public void SendToBack();
public void SetAutoScrollMargin(int x, int y);
public void SetBounds(int x, int y, int width, int height);
public void SetBounds(int x, int y, int width, int height, BoundsSpecified specified);
protected virtual void SetBoundsCore(int x, int y, int width, int height, BoundsSpecified specified);
protected virtual void SetClientSizeCore(int x, int y);
protected void SetDisplayRectLocation(int x, int y);
protected void SetScrollState(int bit, bool value);
protected void SetStyle(ControlStyles flag, bool value);
protected void SetTopLevel(bool value);
protected virtual void SetVisibleCore(bool value);
public void Show();
public void SuspendLayout();
public virtual string ToString();
public override void UpButton();
public void Update();
protected void UpdateBounds();
protected void UpdateBounds(int x, int y, int width, int height);
protected void UpdateBounds(int x, int y, int width, int height, int clientWidth, int clientHeight);
protected virtual void UpdateDefaultButton();
protected virtual void UpdateEditText();
protected void UpdateStyles();
protected void UpdateZOrder();
public bool Validate();
protected virtual void ValidateEditText();
protected virtual void WndProc(ref Message m);

Property
public AccessibleObject AccessibilityObject {get;}
public string AccessibleDefaultActionDescription {get; set;}
public string AccessibleDescription {get; set;}
public string AccessibleName {get; set;}
public AccessibleRole AccessibleRole {get; set;}
public Control ActiveControl {get; set;}
public bool AllowDrop {get; set;}
public AnchorStyles Anchor {get; set;}
public bool AutoScroll {get; set;}
public Size AutoScrollMargin {get; set;}
public Size AutoScrollMinSize {get; set;}
public Point AutoScrollPosition {get; set;}
public virtual Color BackColor {get; set;}
public Image BackgroundImage {get; set;}
public override BindingContext BindingContext {get; set;}
public BorderStyle BorderStyle {get; set;}
public int Bottom {get;}
public Rectangle Bounds {get; set;}
public bool CanFocus {get;}
public bool CanSelect {get;}
public bool Capture {get; set;}
public bool CausesValidation {get; set;}
protected bool ChangingText {get; set;}
public Rectangle ClientRectangle {get;}
public Size ClientSize {get; set;}
public string CompanyName {get;}
public IContainer Container {get;}
public bool ContainsFocus {get;}
public ContextMenu ContextMenu {get; set;}
public ControlCollection Controls {get;}
public bool Created {get;}
protected virtual CreateParams CreateParams {get;}
public Cursor Cursor {get; set;}
public ControlBindingsCollection DataBindings {get;}
protected virtual ImeMode DefaultImeMode {get;}
protected virtual Size DefaultSize {get;}
protected bool DesignMode {get;}
public Rectangle DisplayRectangle {get;}
public bool Disposing {get;}
public DockStyle Dock {get; set;}
public DockPaddingEdges DockPadding {get;}
public bool Enabled {get; set;}
protected EventHandlerList Events {get;}
public bool Focused {get;}
public virtual Font Font {get; set;}
protected int FontHeight {get; set;}
public virtual Color ForeColor {get; set;}
public IntPtr Handle {get;}
public bool HasChildren {get;}
public int Height {get; set;}
protected bool HScroll {get; set;}
public ImeMode ImeMode {get; set;}
public bool InterceptArrowKeys {get; set;}
public bool InvokeRequired {get;}
public bool IsAccessible {get; set;}
public bool IsDisposed {get;}
public bool IsHandleCreated {get;}
public DomainUpDownItemCollection Items {get;}
public int Left {get; set;}
public Point Location {get; set;}
public string Name {get; set;}
public Control Parent {get; set;}
public Form ParentForm {get;}
public int PreferredHeight {get;}
public string ProductName {get;}
public string ProductVersion {get;}
public bool ReadOnly {get; set;}
public bool RecreatingHandle {get;}
public Region Region {get; set;}
protected bool RenderRightToLeft {get;}
protected bool ResizeRedraw {get; set;}
public int Right {get;}
public RightToLeft RightToLeft {get; set;}
public int SelectedIndex {get; set;}
public object SelectedItem {get; set;}
protected virtual bool ShowFocusCues {get;}
protected bool ShowKeyboardCues {get;}
public ISite Site {get; set;}
public Size Size {get; set;}
public bool Sorted {get; set;}
public int TabIndex {get; set;}
public bool TabStop {get; set;}
public object Tag {get; set;}
public virtual string Text {get; set;}
public HorizontalAlignment TextAlign {get; set;}
public int Top {get; set;}
public Control TopLevelControl {get;}
public LeftRightAlignment UpDownAlign {get; set;}
protected bool UserEdit {get; set;}
public bool Visible {get; set;}
protected bool VScroll {get; set;}
public int Width {get; set;}
public IWindowTarget WindowTarget {get; set;}
public bool Wrap {get; set;}

System.Windows.Forms.UpDownBase

Module:System.Windows.Forms.dll

Hierarchy
Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UpDownBase

Type declaration

[C#] public abstract class UpDownBase : ContainerControl;

Constructor
public UpDownBase();

Method
protected void AccessibilityNotifyClients(AccessibleEvents accEvent, int childID);
public void add_BackColorChanged(EventHandler value);
public void add_BackgroundImageChanged(EventHandler value);
public void add_BindingContextChanged(EventHandler value);
public void add_CausesValidationChanged(EventHandler value);
public void add_ChangeUICues(UICuesEventHandler value);
public void add_Click(EventHandler value);
public void add_ContextMenuChanged(EventHandler value);
public void add_ControlAdded(ControlEventHandler value);
public void add_ControlRemoved(ControlEventHandler value);
public void add_CursorChanged(EventHandler value);
public void add_Disposed(EventHandler value);
public void add_DockChanged(EventHandler value);
public void add_DoubleClick(EventHandler value);
public void add_DragDrop(DragEventHandler value);
public void add_DragEnter(DragEventHandler value);
public void add_DragLeave(EventHandler value);
public void add_DragOver(DragEventHandler value);
public void add_EnabledChanged(EventHandler value);
public void add_Enter(EventHandler value);
public void add_FontChanged(EventHandler value);
public void add_ForeColorChanged(EventHandler value);
public void add_GiveFeedback(GiveFeedbackEventHandler value);
public void add_GotFocus(EventHandler value);
public void add_HandleCreated(EventHandler value);
public void add_HandleDestroyed(EventHandler value);
public void add_HelpRequested(HelpEventHandler value);
public void add_ImeModeChanged(EventHandler value);
public void add_Invalidated(InvalidateEventHandler value);
public void add_KeyDown(KeyEventHandler value);
public void add_KeyPress(KeyPressEventHandler value);
public void add_KeyUp(KeyEventHandler value);
public void add_Layout(LayoutEventHandler value);
public void add_Leave(EventHandler value);
public void add_LocationChanged(EventHandler value);
public void add_LostFocus(EventHandler value);
public void add_MouseDown(MouseEventHandler value);
public void add_MouseEnter(EventHandler value);
public void add_MouseHover(EventHandler value);
public void add_MouseLeave(EventHandler value);
public void add_MouseMove(MouseEventHandler value);
public void add_MouseUp(MouseEventHandler value);
public void add_MouseWheel(MouseEventHandler value);
public void add_Move(EventHandler value);
public void add_Paint(PaintEventHandler value);
public void add_ParentChanged(EventHandler value);
public void add_QueryAccessibilityHelp(QueryAccessibilityHelpEventHandler value);
public void add_QueryContinueDrag(QueryContinueDragEventHandler value);
public void add_Resize(EventHandler value);
public void add_RightToLeftChanged(EventHandler value);
public void add_SizeChanged(EventHandler value);
public void add_StyleChanged(EventHandler value);
public void add_SystemColorsChanged(EventHandler value);
public void add_TabIndexChanged(EventHandler value);
public void add_TabStopChanged(EventHandler value);
public void add_TextChanged(EventHandler value);
public void add_Validated(EventHandler value);
public void add_Validating(CancelEventHandler value);
public void add_VisibleChanged(EventHandler value);
protected virtual void AdjustFormScrollbars(bool displayScrollbars);
public IAsyncResult BeginInvoke(Delegate method);
public IAsyncResult BeginInvoke(Delegate method, object[] args);
public void BringToFront();
public bool Contains(Control ctl);
protected virtual AccessibleObject CreateAccessibilityInstance();
public void CreateControl();
protected virtual ControlCollection CreateControlsInstance();
public Graphics CreateGraphics();
protected virtual void CreateHandle();
public ObjRef CreateObjRef(Type requestedType);
protected virtual void DefWndProc(ref Message m);
protected virtual void DestroyHandle();
public void Dispose();
protected override void Dispose(bool disposing);
public DragDropEffects DoDragDrop(object data, DragDropEffects allowedEffects);
public abstract void DownButton();
public object EndInvoke(IAsyncResult asyncResult);
public virtual bool Equals(object obj);
protected override void Finalize();
public Form FindForm();
public bool Focus();
public Control GetChildAtPoint(Point pt);
public IContainerControl GetContainerControl();
public virtual int GetHashCode();
public object GetLifetimeService();
public Control GetNextControl(Control ctl, bool forward);
protected bool GetScrollState(int bit);
protected virtual object GetService(Type service);
protected bool GetStyle(ControlStyles flag);
protected bool GetTopLevel();
public Type GetType();
public void Hide();
public object InitializeLifetimeService();
protected virtual void InitLayout();
public void Invalidate();
public void Invalidate(bool invalidateChildren);
public void Invalidate(Rectangle rect);
public void Invalidate(Rectangle rc, bool invalidateChildren);
public void Invalidate(Region region);
public void Invalidate(Region region, bool invalidateChildren);
public object Invoke(Delegate method);
public object Invoke(Delegate method, object[] args);
protected void InvokeGotFocus(Control toInvoke, EventArgs e);
protected void InvokeLostFocus(Control toInvoke, EventArgs e);
protected void InvokeOnClick(Control toInvoke, EventArgs e);
protected void InvokePaint(Control c, PaintEventArgs e);
protected void InvokePaintBackground(Control c, PaintEventArgs e);
protected virtual bool IsInputChar(char charCode);
protected virtual bool IsInputKey(Keys keyData);
protected object MemberwiseClone();
protected virtual void NotifyInvalidate(Rectangle invalidatedArea);
protected virtual void OnBackColorChanged(EventArgs e);
protected virtual void OnBackgroundImageChanged(EventArgs e);
protected virtual void OnBindingContextChanged(EventArgs e);
protected virtual void OnCausesValidationChanged(EventArgs e);
protected virtual void OnChanged(object source, EventArgs e);
protected virtual void OnChangeUICues(UICuesEventArgs e);
protected virtual void OnClick(EventArgs e);
protected virtual void OnContextMenuChanged(EventArgs e);
protected virtual void OnControlAdded(ControlEventArgs e);
protected virtual void OnControlRemoved(ControlEventArgs e);
protected virtual void OnCreateControl();
protected virtual void OnCursorChanged(EventArgs e);
protected virtual void OnDockChanged(EventArgs e);
protected virtual void OnDoubleClick(EventArgs e);
protected virtual void OnDragDrop(DragEventArgs drgevent);
protected virtual void OnDragEnter(DragEventArgs drgevent);
protected virtual void OnDragLeave(EventArgs e);
protected virtual void OnDragOver(DragEventArgs drgevent);
protected virtual void OnEnabledChanged(EventArgs e);
protected virtual void OnEnter(EventArgs e);
protected virtual void OnFontChanged(EventArgs e);
protected virtual void OnForeColorChanged(EventArgs e);
protected virtual void OnGiveFeedback(GiveFeedbackEventArgs gfbevent);
protected virtual void OnGotFocus(EventArgs e);
protected virtual void OnHandleCreated(EventArgs e);
protected virtual void OnHandleDestroyed(EventArgs e);
protected virtual void OnHelpRequested(HelpEventArgs hevent);
protected virtual void OnImeModeChanged(EventArgs e);
protected virtual void OnInvalidated(InvalidateEventArgs e);
protected virtual void OnKeyDown(KeyEventArgs e);
protected virtual void OnKeyPress(KeyPressEventArgs e);
protected virtual void OnKeyUp(KeyEventArgs e);
protected virtual void OnLayout(LayoutEventArgs e);
protected virtual void OnLeave(EventArgs e);
protected virtual void OnLocationChanged(EventArgs e);
protected virtual void OnLostFocus(EventArgs e);
protected virtual void OnMouseDown(MouseEventArgs e);
protected virtual void OnMouseEnter(EventArgs e);
protected virtual void OnMouseHover(EventArgs e);
protected virtual void OnMouseLeave(EventArgs e);
protected virtual void OnMouseMove(MouseEventArgs e);
protected virtual void OnMouseUp(MouseEventArgs e);
protected virtual void OnMouseWheel(MouseEventArgs e);
protected virtual void OnMove(EventArgs e);
protected virtual void OnNotifyMessage(Message m);
protected virtual void OnPaint(PaintEventArgs e);
protected virtual void OnPaintBackground(PaintEventArgs e);
protected virtual void OnParentBackColorChanged(EventArgs e);
protected virtual void OnParentBackgroundImageChanged(EventArgs e);
protected virtual void OnParentBindingContextChanged(EventArgs e);
protected virtual void OnParentChanged(EventArgs e);
protected virtual void OnParentEnabledChanged(EventArgs e);
protected virtual void OnParentFontChanged(EventArgs e);
protected virtual void OnParentForeColorChanged(EventArgs e);
protected virtual void OnParentRightToLeftChanged(EventArgs e);
protected virtual void OnParentVisibleChanged(EventArgs e);
protected virtual void OnQueryContinueDrag(QueryContinueDragEventArgs qcdevent);
protected virtual void OnResize(EventArgs e);
protected virtual void OnRightToLeftChanged(EventArgs e);
protected virtual void OnSizeChanged(EventArgs e);
protected virtual void OnStyleChanged(EventArgs e);
protected virtual void OnSystemColorsChanged(EventArgs e);
protected virtual void OnTabIndexChanged(EventArgs e);
protected virtual void OnTabStopChanged(EventArgs e);
protected virtual void OnTextBoxKeyDown(object source, KeyEventArgs e);
protected virtual void OnTextBoxKeyPress(object source, KeyPressEventArgs e);
protected virtual void OnTextBoxLostFocus(object source, EventArgs e);
protected virtual void OnTextBoxResize(object source, EventArgs e);
protected virtual void OnTextBoxTextChanged(object source, EventArgs e);
protected virtual void OnTextChanged(EventArgs e);
protected virtual void OnValidated(EventArgs e);
protected virtual void OnValidating(CancelEventArgs e);
protected virtual void OnVisibleChanged(EventArgs e);
public void PerformLayout();
public void PerformLayout(Control affectedControl, string affectedProperty);
public Point PointToClient(Point p);
public Point PointToScreen(Point p);
public bool PreProcessMessage(ref Message msg);
protected virtual bool ProcessCmdKey(ref Message msg, Keys keyData);
protected virtual bool ProcessDialogChar(char charCode);
protected virtual bool ProcessDialogKey(Keys keyData);
protected virtual bool ProcessKeyEventArgs(ref Message m);
protected virtual bool ProcessKeyPreview(ref Message m);
protected virtual bool ProcessMnemonic(char charCode);
protected virtual bool ProcessTabKey(bool forward);
protected void RaiseDragEvent(object key, DragEventArgs e);
protected void RaiseKeyEvent(object key, KeyEventArgs e);
protected void RaiseMouseEvent(object key, MouseEventArgs e);
protected void RaisePaintEvent(object key, PaintEventArgs e);
protected void RecreateHandle();
public Rectangle RectangleToClient(Rectangle r);
public Rectangle RectangleToScreen(Rectangle r);
public virtual void Refresh();
public void remove_BackColorChanged(EventHandler value);
public void remove_BackgroundImageChanged(EventHandler value);
public void remove_BindingContextChanged(EventHandler value);
public void remove_CausesValidationChanged(EventHandler value);
public void remove_ChangeUICues(UICuesEventHandler value);
public void remove_Click(EventHandler value);
public void remove_ContextMenuChanged(EventHandler value);
public void remove_ControlAdded(ControlEventHandler value);
public void remove_ControlRemoved(ControlEventHandler value);
public void remove_CursorChanged(EventHandler value);
public void remove_Disposed(EventHandler value);
public void remove_DockChanged(EventHandler value);
public void remove_DoubleClick(EventHandler value);
public void remove_DragDrop(DragEventHandler value);
public void remove_DragEnter(DragEventHandler value);
public void remove_DragLeave(EventHandler value);
public void remove_DragOver(DragEventHandler value);
public void remove_EnabledChanged(EventHandler value);
public void remove_Enter(EventHandler value);
public void remove_FontChanged(EventHandler value);
public void remove_ForeColorChanged(EventHandler value);
public void remove_GiveFeedback(GiveFeedbackEventHandler value);
public void remove_GotFocus(EventHandler value);
public void remove_HandleCreated(EventHandler value);
public void remove_HandleDestroyed(EventHandler value);
public void remove_HelpRequested(HelpEventHandler value);
public void remove_ImeModeChanged(EventHandler value);
public void remove_Invalidated(InvalidateEventHandler value);
public void remove_KeyDown(KeyEventHandler value);
public void remove_KeyPress(KeyPressEventHandler value);
public void remove_KeyUp(KeyEventHandler value);
public void remove_Layout(LayoutEventHandler value);
public void remove_Leave(EventHandler value);
public void remove_LocationChanged(EventHandler value);
public void remove_LostFocus(EventHandler value);
public void remove_MouseDown(MouseEventHandler value);
public void remove_MouseEnter(EventHandler value);
public void remove_MouseHover(EventHandler value);
public void remove_MouseLeave(EventHandler value);
public void remove_MouseMove(MouseEventHandler value);
public void remove_MouseUp(MouseEventHandler value);
public void remove_MouseWheel(MouseEventHandler value);
public void remove_Move(EventHandler value);
public void remove_Paint(PaintEventHandler value);
public void remove_ParentChanged(EventHandler value);
public void remove_QueryAccessibilityHelp(QueryAccessibilityHelpEventHandler value);
public void remove_QueryContinueDrag(QueryContinueDragEventHandler value);
public void remove_Resize(EventHandler value);
public void remove_RightToLeftChanged(EventHandler value);
public void remove_SizeChanged(EventHandler value);
public void remove_StyleChanged(EventHandler value);
public void remove_SystemColorsChanged(EventHandler value);
public void remove_TabIndexChanged(EventHandler value);
public void remove_TabStopChanged(EventHandler value);
public void remove_TextChanged(EventHandler value);
public void remove_Validated(EventHandler value);
public void remove_Validating(CancelEventHandler value);
public void remove_VisibleChanged(EventHandler value);
public void ResetBackColor();
public void ResetBindings();
public void ResetCursor();
public void ResetFont();
public void ResetForeColor();
public void ResetImeMode();
protected void ResetMouseEventArgs();
public void ResetRightToLeft();
public void ResetText();
public void ResumeLayout();
public void ResumeLayout(bool performLayout);
protected ContentAlignment RtlTranslateAlignment(ContentAlignment align);
protected HorizontalAlignment RtlTranslateAlignment(HorizontalAlignment align);
protected LeftRightAlignment RtlTranslateAlignment(LeftRightAlignment align);
protected ContentAlignment RtlTranslateContent(ContentAlignment align);
protected HorizontalAlignment RtlTranslateHorizontal(HorizontalAlignment align);
protected LeftRightAlignment RtlTranslateLeftRight(LeftRightAlignment align);
public void Scale(float ratio);
public void Scale(float dx, float dy);
protected virtual void ScaleCore(float dx, float dy);
public void ScrollControlIntoView(Control activeControl);
public void Select();
protected virtual void Select(bool directed, bool forward);
public void Select(int start, int length);
public bool SelectNextControl(Control ctl, bool forward, bool tabStopOnly, bool nested, bool wrap);
public void SendToBack();
public void SetAutoScrollMargin(int x, int y);
public void SetBounds(int x, int y, int width, int height);
public void SetBounds(int x, int y, int width, int height, BoundsSpecified specified);
protected virtual void SetBoundsCore(int x, int y, int width, int height, BoundsSpecified specified);
protected virtual void SetClientSizeCore(int x, int y);
protected void SetDisplayRectLocation(int x, int y);
protected void SetScrollState(int bit, bool value);
protected void SetStyle(ControlStyles flag, bool value);
protected void SetTopLevel(bool value);
protected virtual void SetVisibleCore(bool value);
public void Show();
public void SuspendLayout();
public virtual string ToString();
public abstract void UpButton();
public void Update();
protected void UpdateBounds();
protected void UpdateBounds(int x, int y, int width, int height);
protected void UpdateBounds(int x, int y, int width, int height, int clientWidth, int clientHeight);
protected virtual void UpdateDefaultButton();
protected abstract void UpdateEditText();
protected void UpdateStyles();
protected void UpdateZOrder();
public bool Validate();
protected virtual void ValidateEditText();
protected virtual void WndProc(ref Message m);

Property
public AccessibleObject AccessibilityObject {get;}
public string AccessibleDefaultActionDescription {get; set;}
public string AccessibleDescription {get; set;}
public string AccessibleName {get; set;}
public AccessibleRole AccessibleRole {get; set;}
public Control ActiveControl {get; set;}
public bool AllowDrop {get; set;}
public AnchorStyles Anchor {get; set;}
public override bool AutoScroll {get; set;}
public Size AutoScrollMargin {get; set;}
public Size AutoScrollMinSize {get; set;}
public Point AutoScrollPosition {get; set;}
public virtual Color BackColor {get; set;}
public override Image BackgroundImage {get; set;}
public override BindingContext BindingContext {get; set;}
public BorderStyle BorderStyle {get; set;}
public int Bottom {get;}
public Rectangle Bounds {get; set;}
public bool CanFocus {get;}
public bool CanSelect {get;}
public bool Capture {get; set;}
public bool CausesValidation {get; set;}
protected bool ChangingText {get; set;}
public Rectangle ClientRectangle {get;}
public Size ClientSize {get; set;}
public string CompanyName {get;}
public IContainer Container {get;}
public bool ContainsFocus {get;}
public ContextMenu ContextMenu {get; set;}
public ControlCollection Controls {get;}
public bool Created {get;}
protected virtual CreateParams CreateParams {get;}
public Cursor Cursor {get; set;}
public ControlBindingsCollection DataBindings {get;}
protected virtual ImeMode DefaultImeMode {get;}
protected virtual Size DefaultSize {get;}
protected bool DesignMode {get;}
public Rectangle DisplayRectangle {get;}
public bool Disposing {get;}
public DockStyle Dock {get; set;}
public DockPaddingEdges DockPadding {get;}
public bool Enabled {get; set;}
protected EventHandlerList Events {get;}
public bool Focused {get;}
public virtual Font Font {get; set;}
protected int FontHeight {get; set;}
public virtual Color ForeColor {get; set;}
public IntPtr Handle {get;}
public bool HasChildren {get;}
public int Height {get; set;}
protected bool HScroll {get; set;}
public ImeMode ImeMode {get; set;}
public bool InterceptArrowKeys {get; set;}
public bool InvokeRequired {get;}
public bool IsAccessible {get; set;}
public bool IsDisposed {get;}
public bool IsHandleCreated {get;}
public int Left {get; set;}
public Point Location {get; set;}
public string Name {get; set;}
public Control Parent {get; set;}
public Form ParentForm {get;}
public int PreferredHeight {get;}
public string ProductName {get;}
public string ProductVersion {get;}
public bool ReadOnly {get; set;}
public bool RecreatingHandle {get;}
public Region Region {get; set;}
protected bool RenderRightToLeft {get;}
protected bool ResizeRedraw {get; set;}
public int Right {get;}
public RightToLeft RightToLeft {get; set;}
protected virtual bool ShowFocusCues {get;}
protected bool ShowKeyboardCues {get;}
public ISite Site {get; set;}
public Size Size {get; set;}
public int TabIndex {get; set;}
public bool TabStop {get; set;}
public object Tag {get; set;}
public virtual string Text {get; set;}
public HorizontalAlignment TextAlign {get; set;}
public int Top {get; set;}
public Control TopLevelControl {get;}
public LeftRightAlignment UpDownAlign {get; set;}
protected bool UserEdit {get; set;}
public bool Visible {get; set;}
protected bool VScroll {get; set;}
public int Width {get; set;}
public IWindowTarget WindowTarget {get; set;}

System.Windows.Forms.DialogResult

Module:System.Windows.Forms.dll

Hierarchy
Object
ValueType
Enum
DialogResult

Type declaration

[C#] public enum DialogResult;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const DialogResult Abort = 3;
public const DialogResult Cancel = 2;
public const DialogResult Ignore = 5;
public const DialogResult No = 7;
public const DialogResult None = 0;
public const DialogResult OK = 1;
public const DialogResult Retry = 4;
public int value__;
public const DialogResult Yes = 6;

System.Windows.Forms.Cursors

Module:System.Windows.Forms.dll

Hierarchy
Object
Cursors

Type declaration

[C#] public sealed class Cursors;

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public static Cursor AppStarting {get;}
public static Cursor Arrow {get;}
public static Cursor Cross {get;}
public static Cursor Default {get;}
public static Cursor Hand {get;}
public static Cursor Help {get;}
public static Cursor HSplit {get;}
public static Cursor IBeam {get;}
public static Cursor No {get;}
public static Cursor NoMove2D {get;}
public static Cursor NoMoveHoriz {get;}
public static Cursor NoMoveVert {get;}
public static Cursor PanEast {get;}
public static Cursor PanNE {get;}
public static Cursor PanNorth {get;}
public static Cursor PanNW {get;}
public static Cursor PanSE {get;}
public static Cursor PanSouth {get;}
public static Cursor PanSW {get;}
public static Cursor PanWest {get;}
public static Cursor SizeAll {get;}
public static Cursor SizeNESW {get;}
public static Cursor SizeNS {get;}
public static Cursor SizeNWSE {get;}
public static Cursor SizeWE {get;}
public static Cursor UpArrow {get;}
public static Cursor VSplit {get;}
public static Cursor WaitCursor {get;}

System.Windows.Forms.Cursor

Module:System.Windows.Forms.dll

Hierarchy
Object
Cursor

Type declaration

[C#] public sealed class Cursor;

Constructor
public Cursor(IntPtr handle);
public Cursor(Stream stream);
public Cursor(string fileName);
public Cursor(Type type, string resource);

Method
public IntPtr CopyHandle();
public virtual void Dispose();
public void Draw(Graphics g, Rectangle targetRect);
public void DrawStretched(Graphics g, Rectangle targetRect);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
public static void Hide();
protected object MemberwiseClone();
public static bool op_Equality(Cursor left, Cursor right);
public static bool op_Inequality(Cursor left, Cursor right);
public static void Show();
public virtual string ToString();

Property
public static Rectangle Clip {get; set;}
public static Cursor Current {get; set;}
public IntPtr Handle {get;}
public static Point Position {get; set;}
public Size Size {get;}

System.Windows.Forms.ContextMenu

Module:System.Windows.Forms.dll

Hierarchy
Object
MarshalByRefObject
Component
Menu
ContextMenu

Type declaration

[C#] public class ContextMenu : Menu;

Constructor
public ContextMenu();
public ContextMenu(MenuItem[] menuItems);

Method
public void add_Disposed(EventHandler value);
public void add_Popup(EventHandler value);
protected void CloneMenu(Menu menuSrc);
protected virtual IntPtr CreateMenuHandle();
public ObjRef CreateObjRef(Type requestedType);
public void Dispose();
protected virtual void Dispose(bool disposing);
public virtual bool Equals(object obj);
protected override void Finalize();
public MenuItem FindMenuItem(int type, IntPtr value);
protected int FindMergePosition(int mergeOrder);
public ContextMenu GetContextMenu();
public virtual int GetHashCode();
public object GetLifetimeService();
public MainMenu GetMainMenu();
protected virtual object GetService(Type service);
public Type GetType();
public object InitializeLifetimeService();
protected object MemberwiseClone();
public void MergeMenu(Menu menuSrc);
public void remove_Disposed(EventHandler value);
public void remove_Popup(EventHandler value);
public virtual void Show(Control ctrl, Point pos);
public virtual string ToString();

Property
public IContainer Container {get;}
protected bool DesignMode {get;}
protected EventHandlerList Events {get;}
public IntPtr Handle {get;}
public bool IsParent {get;}
public MenuItem MdiListItem {get;}
public MenuItemCollection MenuItems {get;}
public virtual RightToLeft RightToLeft {get; set;}
public ISite Site {get; set;}
public Control SourceControl {get;}

System.Windows.Forms.Menu+MenuItemCollection

Module:System.Windows.Forms.dll

Hierarchy
Object
Menu+MenuItemCollection : IList, ICollection, IEnumerable

Type declaration

[C#] public class MenuItemCollection: IList, ICollection, IEnumerable;

Constructor
public MenuItemCollection(Menu owner);

Method
public virtual int Add(int index, MenuItem item);
public int Add(MenuItem mnue);
public virtual MenuItem Add(string caption);
public virtual MenuItem Add(string caption, EventHandler onClick);
public virtual MenuItem Add(string caption, MenuItem[] items);
public virtual void AddRange(MenuItem[] items);
public virtual void Clear();
public bool Contains(MenuItem mnue);
public virtual void CopyTo(Array array, int index);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual IEnumerator GetEnumerator();
public virtual int GetHashCode();
public Type GetType();
public int IndexOf(MenuItem mnue);
protected object MemberwiseClone();
public void Remove(MenuItem mnue);
public virtual void RemoveAt(int index);
public virtual string ToString();

Property
public virtual int Count {get;}
public virtual bool IsReadOnly {get;}
public MenuItem this[int index] {get;}

System.Windows.Forms.Menu

Module:System.Windows.Forms.dll

Hierarchy
Object
MarshalByRefObject
Component
Menu

Type declaration

[C#] public abstract class Menu : Component;

Constructor
protected Menu(MenuItem[] items);

Method
public void add_Disposed(EventHandler value);
protected void CloneMenu(Menu menuSrc);
protected virtual IntPtr CreateMenuHandle();
public ObjRef CreateObjRef(Type requestedType);
public void Dispose();
protected virtual void Dispose(bool disposing);
public virtual bool Equals(object obj);
protected override void Finalize();
public MenuItem FindMenuItem(int type, IntPtr value);
protected int FindMergePosition(int mergeOrder);
public ContextMenu GetContextMenu();
public virtual int GetHashCode();
public object GetLifetimeService();
public MainMenu GetMainMenu();
protected virtual object GetService(Type service);
public Type GetType();
public object InitializeLifetimeService();
protected object MemberwiseClone();
public virtual void MergeMenu(Menu menuSrc);
public void remove_Disposed(EventHandler value);
public virtual string ToString();

Property
public IContainer Container {get;}
protected bool DesignMode {get;}
protected EventHandlerList Events {get;}
public IntPtr Handle {get;}
public virtual bool IsParent {get;}
public MenuItem MdiListItem {get;}
public MenuItemCollection MenuItems {get;}
public ISite Site {get; set;}

Field
public const int FindHandle = 0;
public const int FindShortcut = 1;

System.Windows.Forms.ContainerControl

Module:System.Windows.Forms.dll

Hierarchy
Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl

Type declaration

[C#] public class ContainerControl : ScrollableControl;

Constructor
public ContainerControl();

Method
protected void AccessibilityNotifyClients(AccessibleEvents accEvent, int childID);
public void add_BackColorChanged(EventHandler value);
public void add_BackgroundImageChanged(EventHandler value);
public void add_BindingContextChanged(EventHandler value);
public void add_CausesValidationChanged(EventHandler value);
public void add_ChangeUICues(UICuesEventHandler value);
public void add_Click(EventHandler value);
public void add_ContextMenuChanged(EventHandler value);
public void add_ControlAdded(ControlEventHandler value);
public void add_ControlRemoved(ControlEventHandler value);
public void add_CursorChanged(EventHandler value);
public void add_Disposed(EventHandler value);
public void add_DockChanged(EventHandler value);
public void add_DoubleClick(EventHandler value);
public void add_DragDrop(DragEventHandler value);
public void add_DragEnter(DragEventHandler value);
public void add_DragLeave(EventHandler value);
public void add_DragOver(DragEventHandler value);
public void add_EnabledChanged(EventHandler value);
public void add_Enter(EventHandler value);
public void add_FontChanged(EventHandler value);
public void add_ForeColorChanged(EventHandler value);
public void add_GiveFeedback(GiveFeedbackEventHandler value);
public void add_GotFocus(EventHandler value);
public void add_HandleCreated(EventHandler value);
public void add_HandleDestroyed(EventHandler value);
public void add_HelpRequested(HelpEventHandler value);
public void add_ImeModeChanged(EventHandler value);
public void add_Invalidated(InvalidateEventHandler value);
public void add_KeyDown(KeyEventHandler value);
public void add_KeyPress(KeyPressEventHandler value);
public void add_KeyUp(KeyEventHandler value);
public void add_Layout(LayoutEventHandler value);
public void add_Leave(EventHandler value);
public void add_LocationChanged(EventHandler value);
public void add_LostFocus(EventHandler value);
public void add_MouseDown(MouseEventHandler value);
public void add_MouseEnter(EventHandler value);
public void add_MouseHover(EventHandler value);
public void add_MouseLeave(EventHandler value);
public void add_MouseMove(MouseEventHandler value);
public void add_MouseUp(MouseEventHandler value);
public void add_MouseWheel(MouseEventHandler value);
public void add_Move(EventHandler value);
public void add_Paint(PaintEventHandler value);
public void add_ParentChanged(EventHandler value);
public void add_QueryAccessibilityHelp(QueryAccessibilityHelpEventHandler value);
public void add_QueryContinueDrag(QueryContinueDragEventHandler value);
public void add_Resize(EventHandler value);
public void add_RightToLeftChanged(EventHandler value);
public void add_SizeChanged(EventHandler value);
public void add_StyleChanged(EventHandler value);
public void add_SystemColorsChanged(EventHandler value);
public void add_TabIndexChanged(EventHandler value);
public void add_TabStopChanged(EventHandler value);
public void add_TextChanged(EventHandler value);
public void add_Validated(EventHandler value);
public void add_Validating(CancelEventHandler value);
public void add_VisibleChanged(EventHandler value);
protected virtual void AdjustFormScrollbars(bool displayScrollbars);
public IAsyncResult BeginInvoke(Delegate method);
public IAsyncResult BeginInvoke(Delegate method, object[] args);
public void BringToFront();
public bool Contains(Control ctl);
protected virtual AccessibleObject CreateAccessibilityInstance();
public void CreateControl();
protected virtual ControlCollection CreateControlsInstance();
public Graphics CreateGraphics();
protected virtual void CreateHandle();
public ObjRef CreateObjRef(Type requestedType);
protected virtual void DefWndProc(ref Message m);
protected virtual void DestroyHandle();
public void Dispose();
protected override void Dispose(bool disposing);
public DragDropEffects DoDragDrop(object data, DragDropEffects allowedEffects);
public object EndInvoke(IAsyncResult asyncResult);
public virtual bool Equals(object obj);
protected override void Finalize();
public Form FindForm();
public bool Focus();
public Control GetChildAtPoint(Point pt);
public IContainerControl GetContainerControl();
public virtual int GetHashCode();
public object GetLifetimeService();
public Control GetNextControl(Control ctl, bool forward);
protected bool GetScrollState(int bit);
protected virtual object GetService(Type service);
protected bool GetStyle(ControlStyles flag);
protected bool GetTopLevel();
public Type GetType();
public void Hide();
public object InitializeLifetimeService();
protected virtual void InitLayout();
public void Invalidate();
public void Invalidate(bool invalidateChildren);
public void Invalidate(Rectangle rect);
public void Invalidate(Rectangle rc, bool invalidateChildren);
public void Invalidate(Region region);
public void Invalidate(Region region, bool invalidateChildren);
public object Invoke(Delegate method);
public object Invoke(Delegate method, object[] args);
protected void InvokeGotFocus(Control toInvoke, EventArgs e);
protected void InvokeLostFocus(Control toInvoke, EventArgs e);
protected void InvokeOnClick(Control toInvoke, EventArgs e);
protected void InvokePaint(Control c, PaintEventArgs e);
protected void InvokePaintBackground(Control c, PaintEventArgs e);
protected virtual bool IsInputChar(char charCode);
protected virtual bool IsInputKey(Keys keyData);
protected object MemberwiseClone();
protected virtual void NotifyInvalidate(Rectangle invalidatedArea);
protected virtual void OnBackColorChanged(EventArgs e);
protected virtual void OnBackgroundImageChanged(EventArgs e);
protected virtual void OnBindingContextChanged(EventArgs e);
protected virtual void OnCausesValidationChanged(EventArgs e);
protected virtual void OnChangeUICues(UICuesEventArgs e);
protected virtual void OnClick(EventArgs e);
protected virtual void OnContextMenuChanged(EventArgs e);
protected virtual void OnControlAdded(ControlEventArgs e);
protected virtual void OnControlRemoved(ControlEventArgs e);
protected virtual void OnCreateControl();
protected virtual void OnCursorChanged(EventArgs e);
protected virtual void OnDockChanged(EventArgs e);
protected virtual void OnDoubleClick(EventArgs e);
protected virtual void OnDragDrop(DragEventArgs drgevent);
protected virtual void OnDragEnter(DragEventArgs drgevent);
protected virtual void OnDragLeave(EventArgs e);
protected virtual void OnDragOver(DragEventArgs drgevent);
protected virtual void OnEnabledChanged(EventArgs e);
protected virtual void OnEnter(EventArgs e);
protected virtual void OnFontChanged(EventArgs e);
protected virtual void OnForeColorChanged(EventArgs e);
protected virtual void OnGiveFeedback(GiveFeedbackEventArgs gfbevent);
protected virtual void OnGotFocus(EventArgs e);
protected virtual void OnHandleCreated(EventArgs e);
protected virtual void OnHandleDestroyed(EventArgs e);
protected virtual void OnHelpRequested(HelpEventArgs hevent);
protected virtual void OnImeModeChanged(EventArgs e);
protected virtual void OnInvalidated(InvalidateEventArgs e);
protected virtual void OnKeyDown(KeyEventArgs e);
protected virtual void OnKeyPress(KeyPressEventArgs e);
protected virtual void OnKeyUp(KeyEventArgs e);
protected virtual void OnLayout(LayoutEventArgs levent);
protected virtual void OnLeave(EventArgs e);
protected virtual void OnLocationChanged(EventArgs e);
protected virtual void OnLostFocus(EventArgs e);
protected virtual void OnMouseDown(MouseEventArgs e);
protected virtual void OnMouseEnter(EventArgs e);
protected virtual void OnMouseHover(EventArgs e);
protected virtual void OnMouseLeave(EventArgs e);
protected virtual void OnMouseMove(MouseEventArgs e);
protected virtual void OnMouseUp(MouseEventArgs e);
protected virtual void OnMouseWheel(MouseEventArgs e);
protected virtual void OnMove(EventArgs e);
protected virtual void OnNotifyMessage(Message m);
protected virtual void OnPaint(PaintEventArgs e);
protected virtual void OnPaintBackground(PaintEventArgs e);
protected virtual void OnParentBackColorChanged(EventArgs e);
protected virtual void OnParentBackgroundImageChanged(EventArgs e);
protected virtual void OnParentBindingContextChanged(EventArgs e);
protected virtual void OnParentChanged(EventArgs e);
protected virtual void OnParentEnabledChanged(EventArgs e);
protected virtual void OnParentFontChanged(EventArgs e);
protected virtual void OnParentForeColorChanged(EventArgs e);
protected virtual void OnParentRightToLeftChanged(EventArgs e);
protected virtual void OnParentVisibleChanged(EventArgs e);
protected virtual void OnQueryContinueDrag(QueryContinueDragEventArgs qcdevent);
protected virtual void OnResize(EventArgs e);
protected virtual void OnRightToLeftChanged(EventArgs e);
protected virtual void OnSizeChanged(EventArgs e);
protected virtual void OnStyleChanged(EventArgs e);
protected virtual void OnSystemColorsChanged(EventArgs e);
protected virtual void OnTabIndexChanged(EventArgs e);
protected virtual void OnTabStopChanged(EventArgs e);
protected virtual void OnTextChanged(EventArgs e);
protected virtual void OnValidated(EventArgs e);
protected virtual void OnValidating(CancelEventArgs e);
protected virtual void OnVisibleChanged(EventArgs e);
public void PerformLayout();
public void PerformLayout(Control affectedControl, string affectedProperty);
public Point PointToClient(Point p);
public Point PointToScreen(Point p);
public bool PreProcessMessage(ref Message msg);
protected virtual bool ProcessCmdKey(ref Message msg, Keys keyData);
protected virtual bool ProcessDialogChar(char charCode);
protected virtual bool ProcessDialogKey(Keys keyData);
protected virtual bool ProcessKeyEventArgs(ref Message m);
protected virtual bool ProcessKeyPreview(ref Message m);
protected virtual bool ProcessMnemonic(char charCode);
protected virtual bool ProcessTabKey(bool forward);
protected void RaiseDragEvent(object key, DragEventArgs e);
protected void RaiseKeyEvent(object key, KeyEventArgs e);
protected void RaiseMouseEvent(object key, MouseEventArgs e);
protected void RaisePaintEvent(object key, PaintEventArgs e);
protected void RecreateHandle();
public Rectangle RectangleToClient(Rectangle r);
public Rectangle RectangleToScreen(Rectangle r);
public virtual void Refresh();
public void remove_BackColorChanged(EventHandler value);
public void remove_BackgroundImageChanged(EventHandler value);
public void remove_BindingContextChanged(EventHandler value);
public void remove_CausesValidationChanged(EventHandler value);
public void remove_ChangeUICues(UICuesEventHandler value);
public void remove_Click(EventHandler value);
public void remove_ContextMenuChanged(EventHandler value);
public void remove_ControlAdded(ControlEventHandler value);
public void remove_ControlRemoved(ControlEventHandler value);
public void remove_CursorChanged(EventHandler value);
public void remove_Disposed(EventHandler value);
public void remove_DockChanged(EventHandler value);
public void remove_DoubleClick(EventHandler value);
public void remove_DragDrop(DragEventHandler value);
public void remove_DragEnter(DragEventHandler value);
public void remove_DragLeave(EventHandler value);
public void remove_DragOver(DragEventHandler value);
public void remove_EnabledChanged(EventHandler value);
public void remove_Enter(EventHandler value);
public void remove_FontChanged(EventHandler value);
public void remove_ForeColorChanged(EventHandler value);
public void remove_GiveFeedback(GiveFeedbackEventHandler value);
public void remove_GotFocus(EventHandler value);
public void remove_HandleCreated(EventHandler value);
public void remove_HandleDestroyed(EventHandler value);
public void remove_HelpRequested(HelpEventHandler value);
public void remove_ImeModeChanged(EventHandler value);
public void remove_Invalidated(InvalidateEventHandler value);
public void remove_KeyDown(KeyEventHandler value);
public void remove_KeyPress(KeyPressEventHandler value);
public void remove_KeyUp(KeyEventHandler value);
public void remove_Layout(LayoutEventHandler value);
public void remove_Leave(EventHandler value);
public void remove_LocationChanged(EventHandler value);
public void remove_LostFocus(EventHandler value);
public void remove_MouseDown(MouseEventHandler value);
public void remove_MouseEnter(EventHandler value);
public void remove_MouseHover(EventHandler value);
public void remove_MouseLeave(EventHandler value);
public void remove_MouseMove(MouseEventHandler value);
public void remove_MouseUp(MouseEventHandler value);
public void remove_MouseWheel(MouseEventHandler value);
public void remove_Move(EventHandler value);
public void remove_Paint(PaintEventHandler value);
public void remove_ParentChanged(EventHandler value);
public void remove_QueryAccessibilityHelp(QueryAccessibilityHelpEventHandler value);
public void remove_QueryContinueDrag(QueryContinueDragEventHandler value);
public void remove_Resize(EventHandler value);
public void remove_RightToLeftChanged(EventHandler value);
public void remove_SizeChanged(EventHandler value);
public void remove_StyleChanged(EventHandler value);
public void remove_SystemColorsChanged(EventHandler value);
public void remove_TabIndexChanged(EventHandler value);
public void remove_TabStopChanged(EventHandler value);
public void remove_TextChanged(EventHandler value);
public void remove_Validated(EventHandler value);
public void remove_Validating(CancelEventHandler value);
public void remove_VisibleChanged(EventHandler value);
public void ResetBackColor();
public void ResetBindings();
public void ResetCursor();
public void ResetFont();
public void ResetForeColor();
public void ResetImeMode();
protected void ResetMouseEventArgs();
public void ResetRightToLeft();
public void ResetText();
public void ResumeLayout();
public void ResumeLayout(bool performLayout);
protected ContentAlignment RtlTranslateAlignment(ContentAlignment align);
protected HorizontalAlignment RtlTranslateAlignment(HorizontalAlignment align);
protected LeftRightAlignment RtlTranslateAlignment(LeftRightAlignment align);
protected ContentAlignment RtlTranslateContent(ContentAlignment align);
protected HorizontalAlignment RtlTranslateHorizontal(HorizontalAlignment align);
protected LeftRightAlignment RtlTranslateLeftRight(LeftRightAlignment align);
public void Scale(float ratio);
public void Scale(float dx, float dy);
protected virtual void ScaleCore(float dx, float dy);
public void ScrollControlIntoView(Control activeControl);
public void Select();
protected virtual void Select(bool directed, bool forward);
public bool SelectNextControl(Control ctl, bool forward, bool tabStopOnly, bool nested, bool wrap);
public void SendToBack();
public void SetAutoScrollMargin(int x, int y);
public void SetBounds(int x, int y, int width, int height);
public void SetBounds(int x, int y, int width, int height, BoundsSpecified specified);
protected virtual void SetBoundsCore(int x, int y, int width, int height, BoundsSpecified specified);
protected virtual void SetClientSizeCore(int x, int y);
protected void SetDisplayRectLocation(int x, int y);
protected void SetScrollState(int bit, bool value);
protected void SetStyle(ControlStyles flag, bool value);
protected void SetTopLevel(bool value);
protected virtual void SetVisibleCore(bool value);
public void Show();
public void SuspendLayout();
public virtual string ToString();
public void Update();
protected void UpdateBounds();
protected void UpdateBounds(int x, int y, int width, int height);
protected void UpdateBounds(int x, int y, int width, int height, int clientWidth, int clientHeight);
protected virtual void UpdateDefaultButton();
protected void UpdateStyles();
protected void UpdateZOrder();
public bool Validate();
protected virtual void WndProc(ref Message m);

Property
public AccessibleObject AccessibilityObject {get;}
public string AccessibleDefaultActionDescription {get; set;}
public string AccessibleDescription {get; set;}
public string AccessibleName {get; set;}
public AccessibleRole AccessibleRole {get; set;}
public virtual Control ActiveControl {get; set;}
public bool AllowDrop {get; set;}
public AnchorStyles Anchor {get; set;}
public bool AutoScroll {get; set;}
public Size AutoScrollMargin {get; set;}
public Size AutoScrollMinSize {get; set;}
public Point AutoScrollPosition {get; set;}
public virtual Color BackColor {get; set;}
public Image BackgroundImage {get; set;}
public override BindingContext BindingContext {get; set;}
public int Bottom {get;}
public Rectangle Bounds {get; set;}
public bool CanFocus {get;}
public bool CanSelect {get;}
public bool Capture {get; set;}
public bool CausesValidation {get; set;}
public Rectangle ClientRectangle {get;}
public Size ClientSize {get; set;}
public string CompanyName {get;}
public IContainer Container {get;}
public bool ContainsFocus {get;}
public ContextMenu ContextMenu {get; set;}
public ControlCollection Controls {get;}
public bool Created {get;}
protected virtual CreateParams CreateParams {get;}
public Cursor Cursor {get; set;}
public ControlBindingsCollection DataBindings {get;}
protected virtual ImeMode DefaultImeMode {get;}
protected virtual Size DefaultSize {get;}
protected bool DesignMode {get;}
public Rectangle DisplayRectangle {get;}
public bool Disposing {get;}
public DockStyle Dock {get; set;}
public DockPaddingEdges DockPadding {get;}
public bool Enabled {get; set;}
protected EventHandlerList Events {get;}
public bool Focused {get;}
public virtual Font Font {get; set;}
protected int FontHeight {get; set;}
public virtual Color ForeColor {get; set;}
public IntPtr Handle {get;}
public bool HasChildren {get;}
public int Height {get; set;}
protected bool HScroll {get; set;}
public ImeMode ImeMode {get; set;}
public bool InvokeRequired {get;}
public bool IsAccessible {get; set;}
public bool IsDisposed {get;}
public bool IsHandleCreated {get;}
public int Left {get; set;}
public Point Location {get; set;}
public string Name {get; set;}
public Control Parent {get; set;}
public Form ParentForm {get;}
public string ProductName {get;}
public string ProductVersion {get;}
public bool RecreatingHandle {get;}
public Region Region {get; set;}
protected bool RenderRightToLeft {get;}
protected bool ResizeRedraw {get; set;}
public int Right {get;}
public RightToLeft RightToLeft {get; set;}
protected virtual bool ShowFocusCues {get;}
protected bool ShowKeyboardCues {get;}
public ISite Site {get; set;}
public Size Size {get; set;}
public int TabIndex {get; set;}
public bool TabStop {get; set;}
public object Tag {get; set;}
public virtual string Text {get; set;}
public int Top {get; set;}
public Control TopLevelControl {get;}
public bool Visible {get; set;}
protected bool VScroll {get; set;}
public int Width {get; set;}
public IWindowTarget WindowTarget {get; set;}

System.Windows.Forms.ScrollableControl

Module:System.Windows.Forms.dll

Hierarchy
Object
MarshalByRefObject
Component
Control
ScrollableControl

Type declaration

[C#] public class ScrollableControl : Control;

Constructor
public ScrollableControl();

Method
protected void AccessibilityNotifyClients(AccessibleEvents accEvent, int childID);
public void add_BackColorChanged(EventHandler value);
public void add_BackgroundImageChanged(EventHandler value);
public void add_BindingContextChanged(EventHandler value);
public void add_CausesValidationChanged(EventHandler value);
public void add_ChangeUICues(UICuesEventHandler value);
public void add_Click(EventHandler value);
public void add_ContextMenuChanged(EventHandler value);
public void add_ControlAdded(ControlEventHandler value);
public void add_ControlRemoved(ControlEventHandler value);
public void add_CursorChanged(EventHandler value);
public void add_Disposed(EventHandler value);
public void add_DockChanged(EventHandler value);
public void add_DoubleClick(EventHandler value);
public void add_DragDrop(DragEventHandler value);
public void add_DragEnter(DragEventHandler value);
public void add_DragLeave(EventHandler value);
public void add_DragOver(DragEventHandler value);
public void add_EnabledChanged(EventHandler value);
public void add_Enter(EventHandler value);
public void add_FontChanged(EventHandler value);
public void add_ForeColorChanged(EventHandler value);
public void add_GiveFeedback(GiveFeedbackEventHandler value);
public void add_GotFocus(EventHandler value);
public void add_HandleCreated(EventHandler value);
public void add_HandleDestroyed(EventHandler value);
public void add_HelpRequested(HelpEventHandler value);
public void add_ImeModeChanged(EventHandler value);
public void add_Invalidated(InvalidateEventHandler value);
public void add_KeyDown(KeyEventHandler value);
public void add_KeyPress(KeyPressEventHandler value);
public void add_KeyUp(KeyEventHandler value);
public void add_Layout(LayoutEventHandler value);
public void add_Leave(EventHandler value);
public void add_LocationChanged(EventHandler value);
public void add_LostFocus(EventHandler value);
public void add_MouseDown(MouseEventHandler value);
public void add_MouseEnter(EventHandler value);
public void add_MouseHover(EventHandler value);
public void add_MouseLeave(EventHandler value);
public void add_MouseMove(MouseEventHandler value);
public void add_MouseUp(MouseEventHandler value);
public void add_MouseWheel(MouseEventHandler value);
public void add_Move(EventHandler value);
public void add_Paint(PaintEventHandler value);
public void add_ParentChanged(EventHandler value);
public void add_QueryAccessibilityHelp(QueryAccessibilityHelpEventHandler value);
public void add_QueryContinueDrag(QueryContinueDragEventHandler value);
public void add_Resize(EventHandler value);
public void add_RightToLeftChanged(EventHandler value);
public void add_SizeChanged(EventHandler value);
public void add_StyleChanged(EventHandler value);
public void add_SystemColorsChanged(EventHandler value);
public void add_TabIndexChanged(EventHandler value);
public void add_TabStopChanged(EventHandler value);
public void add_TextChanged(EventHandler value);
public void add_Validated(EventHandler value);
public void add_Validating(CancelEventHandler value);
public void add_VisibleChanged(EventHandler value);
protected virtual void AdjustFormScrollbars(bool displayScrollbars);
public IAsyncResult BeginInvoke(Delegate method);
public IAsyncResult BeginInvoke(Delegate method, object[] args);
public void BringToFront();
public bool Contains(Control ctl);
protected virtual AccessibleObject CreateAccessibilityInstance();
public void CreateControl();
protected virtual ControlCollection CreateControlsInstance();
public Graphics CreateGraphics();
protected virtual void CreateHandle();
public ObjRef CreateObjRef(Type requestedType);
protected virtual void DefWndProc(ref Message m);
protected virtual void DestroyHandle();
public void Dispose();
protected override void Dispose(bool disposing);
public DragDropEffects DoDragDrop(object data, DragDropEffects allowedEffects);
public object EndInvoke(IAsyncResult asyncResult);
public virtual bool Equals(object obj);
protected override void Finalize();
public Form FindForm();
public bool Focus();
public Control GetChildAtPoint(Point pt);
public IContainerControl GetContainerControl();
public virtual int GetHashCode();
public object GetLifetimeService();
public Control GetNextControl(Control ctl, bool forward);
protected bool GetScrollState(int bit);
protected virtual object GetService(Type service);
protected bool GetStyle(ControlStyles flag);
protected bool GetTopLevel();
public Type GetType();
public void Hide();
public object InitializeLifetimeService();
protected virtual void InitLayout();
public void Invalidate();
public void Invalidate(bool invalidateChildren);
public void Invalidate(Rectangle rect);
public void Invalidate(Rectangle rc, bool invalidateChildren);
public void Invalidate(Region region);
public void Invalidate(Region region, bool invalidateChildren);
public object Invoke(Delegate method);
public object Invoke(Delegate method, object[] args);
protected void InvokeGotFocus(Control toInvoke, EventArgs e);
protected void InvokeLostFocus(Control toInvoke, EventArgs e);
protected void InvokeOnClick(Control toInvoke, EventArgs e);
protected void InvokePaint(Control c, PaintEventArgs e);
protected void InvokePaintBackground(Control c, PaintEventArgs e);
protected virtual bool IsInputChar(char charCode);
protected virtual bool IsInputKey(Keys keyData);
protected object MemberwiseClone();
protected virtual void NotifyInvalidate(Rectangle invalidatedArea);
protected virtual void OnBackColorChanged(EventArgs e);
protected virtual void OnBackgroundImageChanged(EventArgs e);
protected virtual void OnBindingContextChanged(EventArgs e);
protected virtual void OnCausesValidationChanged(EventArgs e);
protected virtual void OnChangeUICues(UICuesEventArgs e);
protected virtual void OnClick(EventArgs e);
protected virtual void OnContextMenuChanged(EventArgs e);
protected virtual void OnControlAdded(ControlEventArgs e);
protected virtual void OnControlRemoved(ControlEventArgs e);
protected virtual void OnCreateControl();
protected virtual void OnCursorChanged(EventArgs e);
protected virtual void OnDockChanged(EventArgs e);
protected virtual void OnDoubleClick(EventArgs e);
protected virtual void OnDragDrop(DragEventArgs drgevent);
protected virtual void OnDragEnter(DragEventArgs drgevent);
protected virtual void OnDragLeave(EventArgs e);
protected virtual void OnDragOver(DragEventArgs drgevent);
protected virtual void OnEnabledChanged(EventArgs e);
protected virtual void OnEnter(EventArgs e);
protected virtual void OnFontChanged(EventArgs e);
protected virtual void OnForeColorChanged(EventArgs e);
protected virtual void OnGiveFeedback(GiveFeedbackEventArgs gfbevent);
protected virtual void OnGotFocus(EventArgs e);
protected virtual void OnHandleCreated(EventArgs e);
protected virtual void OnHandleDestroyed(EventArgs e);
protected virtual void OnHelpRequested(HelpEventArgs hevent);
protected virtual void OnImeModeChanged(EventArgs e);
protected virtual void OnInvalidated(InvalidateEventArgs e);
protected virtual void OnKeyDown(KeyEventArgs e);
protected virtual void OnKeyPress(KeyPressEventArgs e);
protected virtual void OnKeyUp(KeyEventArgs e);
protected virtual void OnLayout(LayoutEventArgs levent);
protected virtual void OnLeave(EventArgs e);
protected virtual void OnLocationChanged(EventArgs e);
protected virtual void OnLostFocus(EventArgs e);
protected virtual void OnMouseDown(MouseEventArgs e);
protected virtual void OnMouseEnter(EventArgs e);
protected virtual void OnMouseHover(EventArgs e);
protected virtual void OnMouseLeave(EventArgs e);
protected virtual void OnMouseMove(MouseEventArgs e);
protected virtual void OnMouseUp(MouseEventArgs e);
protected virtual void OnMouseWheel(MouseEventArgs e);
protected virtual void OnMove(EventArgs e);
protected virtual void OnNotifyMessage(Message m);
protected virtual void OnPaint(PaintEventArgs e);
protected virtual void OnPaintBackground(PaintEventArgs e);
protected virtual void OnParentBackColorChanged(EventArgs e);
protected virtual void OnParentBackgroundImageChanged(EventArgs e);
protected virtual void OnParentBindingContextChanged(EventArgs e);
protected virtual void OnParentChanged(EventArgs e);
protected virtual void OnParentEnabledChanged(EventArgs e);
protected virtual void OnParentFontChanged(EventArgs e);
protected virtual void OnParentForeColorChanged(EventArgs e);
protected virtual void OnParentRightToLeftChanged(EventArgs e);
protected virtual void OnParentVisibleChanged(EventArgs e);
protected virtual void OnQueryContinueDrag(QueryContinueDragEventArgs qcdevent);
protected virtual void OnResize(EventArgs e);
protected virtual void OnRightToLeftChanged(EventArgs e);
protected virtual void OnSizeChanged(EventArgs e);
protected virtual void OnStyleChanged(EventArgs e);
protected virtual void OnSystemColorsChanged(EventArgs e);
protected virtual void OnTabIndexChanged(EventArgs e);
protected virtual void OnTabStopChanged(EventArgs e);
protected virtual void OnTextChanged(EventArgs e);
protected virtual void OnValidated(EventArgs e);
protected virtual void OnValidating(CancelEventArgs e);
protected virtual void OnVisibleChanged(EventArgs e);
public void PerformLayout();
public void PerformLayout(Control affectedControl, string affectedProperty);
public Point PointToClient(Point p);
public Point PointToScreen(Point p);
public bool PreProcessMessage(ref Message msg);
protected virtual bool ProcessCmdKey(ref Message msg, Keys keyData);
protected virtual bool ProcessDialogChar(char charCode);
protected virtual bool ProcessDialogKey(Keys keyData);
protected virtual bool ProcessKeyEventArgs(ref Message m);
protected virtual bool ProcessKeyPreview(ref Message m);
protected virtual bool ProcessMnemonic(char charCode);
protected void RaiseDragEvent(object key, DragEventArgs e);
protected void RaiseKeyEvent(object key, KeyEventArgs e);
protected void RaiseMouseEvent(object key, MouseEventArgs e);
protected void RaisePaintEvent(object key, PaintEventArgs e);
protected void RecreateHandle();
public Rectangle RectangleToClient(Rectangle r);
public Rectangle RectangleToScreen(Rectangle r);
public virtual void Refresh();
public void remove_BackColorChanged(EventHandler value);
public void remove_BackgroundImageChanged(EventHandler value);
public void remove_BindingContextChanged(EventHandler value);
public void remove_CausesValidationChanged(EventHandler value);
public void remove_ChangeUICues(UICuesEventHandler value);
public void remove_Click(EventHandler value);
public void remove_ContextMenuChanged(EventHandler value);
public void remove_ControlAdded(ControlEventHandler value);
public void remove_ControlRemoved(ControlEventHandler value);
public void remove_CursorChanged(EventHandler value);
public void remove_Disposed(EventHandler value);
public void remove_DockChanged(EventHandler value);
public void remove_DoubleClick(EventHandler value);
public void remove_DragDrop(DragEventHandler value);
public void remove_DragEnter(DragEventHandler value);
public void remove_DragLeave(EventHandler value);
public void remove_DragOver(DragEventHandler value);
public void remove_EnabledChanged(EventHandler value);
public void remove_Enter(EventHandler value);
public void remove_FontChanged(EventHandler value);
public void remove_ForeColorChanged(EventHandler value);
public void remove_GiveFeedback(GiveFeedbackEventHandler value);
public void remove_GotFocus(EventHandler value);
public void remove_HandleCreated(EventHandler value);
public void remove_HandleDestroyed(EventHandler value);
public void remove_HelpRequested(HelpEventHandler value);
public void remove_ImeModeChanged(EventHandler value);
public void remove_Invalidated(InvalidateEventHandler value);
public void remove_KeyDown(KeyEventHandler value);
public void remove_KeyPress(KeyPressEventHandler value);
public void remove_KeyUp(KeyEventHandler value);
public void remove_Layout(LayoutEventHandler value);
public void remove_Leave(EventHandler value);
public void remove_LocationChanged(EventHandler value);
public void remove_LostFocus(EventHandler value);
public void remove_MouseDown(MouseEventHandler value);
public void remove_MouseEnter(EventHandler value);
public void remove_MouseHover(EventHandler value);
public void remove_MouseLeave(EventHandler value);
public void remove_MouseMove(MouseEventHandler value);
public void remove_MouseUp(MouseEventHandler value);
public void remove_MouseWheel(MouseEventHandler value);
public void remove_Move(EventHandler value);
public void remove_Paint(PaintEventHandler value);
public void remove_ParentChanged(EventHandler value);
public void remove_QueryAccessibilityHelp(QueryAccessibilityHelpEventHandler value);
public void remove_QueryContinueDrag(QueryContinueDragEventHandler value);
public void remove_Resize(EventHandler value);
public void remove_RightToLeftChanged(EventHandler value);
public void remove_SizeChanged(EventHandler value);
public void remove_StyleChanged(EventHandler value);
public void remove_SystemColorsChanged(EventHandler value);
public void remove_TabIndexChanged(EventHandler value);
public void remove_TabStopChanged(EventHandler value);
public void remove_TextChanged(EventHandler value);
public void remove_Validated(EventHandler value);
public void remove_Validating(CancelEventHandler value);
public void remove_VisibleChanged(EventHandler value);
public void ResetBackColor();
public void ResetBindings();
public void ResetCursor();
public void ResetFont();
public void ResetForeColor();
public void ResetImeMode();
protected void ResetMouseEventArgs();
public void ResetRightToLeft();
public void ResetText();
public void ResumeLayout();
public void ResumeLayout(bool performLayout);
protected ContentAlignment RtlTranslateAlignment(ContentAlignment align);
protected HorizontalAlignment RtlTranslateAlignment(HorizontalAlignment align);
protected LeftRightAlignment RtlTranslateAlignment(LeftRightAlignment align);
protected ContentAlignment RtlTranslateContent(ContentAlignment align);
protected HorizontalAlignment RtlTranslateHorizontal(HorizontalAlignment align);
protected LeftRightAlignment RtlTranslateLeftRight(LeftRightAlignment align);
public void Scale(float ratio);
public void Scale(float dx, float dy);
protected virtual void ScaleCore(float dx, float dy);
public void ScrollControlIntoView(Control activeControl);
public void Select();
protected virtual void Select(bool directed, bool forward);
public bool SelectNextControl(Control ctl, bool forward, bool tabStopOnly, bool nested, bool wrap);
public void SendToBack();
public void SetAutoScrollMargin(int x, int y);
public void SetBounds(int x, int y, int width, int height);
public void SetBounds(int x, int y, int width, int height, BoundsSpecified specified);
protected virtual void SetBoundsCore(int x, int y, int width, int height, BoundsSpecified specified);
protected virtual void SetClientSizeCore(int x, int y);
protected void SetDisplayRectLocation(int x, int y);
protected void SetScrollState(int bit, bool value);
protected void SetStyle(ControlStyles flag, bool value);
protected void SetTopLevel(bool value);
protected virtual void SetVisibleCore(bool value);
public void Show();
public void SuspendLayout();
public virtual string ToString();
public void Update();
protected void UpdateBounds();
protected void UpdateBounds(int x, int y, int width, int height);
protected void UpdateBounds(int x, int y, int width, int height, int clientWidth, int clientHeight);
protected void UpdateStyles();
protected void UpdateZOrder();
protected virtual void WndProc(ref Message m);

Property
public AccessibleObject AccessibilityObject {get;}
public string AccessibleDefaultActionDescription {get; set;}
public string AccessibleDescription {get; set;}
public string AccessibleName {get; set;}
public AccessibleRole AccessibleRole {get; set;}
public bool AllowDrop {get; set;}
public AnchorStyles Anchor {get; set;}
public virtual bool AutoScroll {get; set;}
public Size AutoScrollMargin {get; set;}
public Size AutoScrollMinSize {get; set;}
public Point AutoScrollPosition {get; set;}
public virtual Color BackColor {get; set;}
public Image BackgroundImage {get; set;}
public virtual BindingContext BindingContext {get; set;}
public int Bottom {get;}
public Rectangle Bounds {get; set;}
public bool CanFocus {get;}
public bool CanSelect {get;}
public bool Capture {get; set;}
public bool CausesValidation {get; set;}
public Rectangle ClientRectangle {get;}
public Size ClientSize {get; set;}
public string CompanyName {get;}
public IContainer Container {get;}
public bool ContainsFocus {get;}
public ContextMenu ContextMenu {get; set;}
public ControlCollection Controls {get;}
public bool Created {get;}
protected virtual CreateParams CreateParams {get;}
public Cursor Cursor {get; set;}
public ControlBindingsCollection DataBindings {get;}
protected virtual ImeMode DefaultImeMode {get;}
protected virtual Size DefaultSize {get;}
protected bool DesignMode {get;}
public override Rectangle DisplayRectangle {get;}
public bool Disposing {get;}
public DockStyle Dock {get; set;}
public DockPaddingEdges DockPadding {get;}
public bool Enabled {get; set;}
protected EventHandlerList Events {get;}
public bool Focused {get;}
public virtual Font Font {get; set;}
protected int FontHeight {get; set;}
public virtual Color ForeColor {get; set;}
public IntPtr Handle {get;}
public bool HasChildren {get;}
public int Height {get; set;}
protected bool HScroll {get; set;}
public ImeMode ImeMode {get; set;}
public bool InvokeRequired {get;}
public bool IsAccessible {get; set;}
public bool IsDisposed {get;}
public bool IsHandleCreated {get;}
public int Left {get; set;}
public Point Location {get; set;}
public string Name {get; set;}
public Control Parent {get; set;}
public string ProductName {get;}
public string ProductVersion {get;}
public bool RecreatingHandle {get;}
public Region Region {get; set;}
protected bool RenderRightToLeft {get;}
protected bool ResizeRedraw {get; set;}
public int Right {get;}
public RightToLeft RightToLeft {get; set;}
protected virtual bool ShowFocusCues {get;}
protected bool ShowKeyboardCues {get;}
public ISite Site {get; set;}
public Size Size {get; set;}
public int TabIndex {get; set;}
public bool TabStop {get; set;}
public object Tag {get; set;}
public virtual string Text {get; set;}
public int Top {get; set;}
public Control TopLevelControl {get;}
public bool Visible {get; set;}
protected bool VScroll {get; set;}
public int Width {get; set;}
public IWindowTarget WindowTarget {get; set;}

Field
protected const int ScrollStateAutoScrolling = 1;
protected const int ScrollStateFullDrag = 16;
protected const int ScrollStateHScrollVisible = 2;
protected const int ScrollStateUserHasScrolled = 8;
protected const int ScrollStateVScrollVisible = 4;

System.Windows.Forms.CommonDialog

Module:System.Windows.Forms.dll

Hierarchy
Object
MarshalByRefObject
Component
CommonDialog

Type declaration

[C#] public abstract class CommonDialog : Component;

Constructor
public CommonDialog();

Method
public void add_Disposed(EventHandler value);
public void add_HelpRequest(EventHandler value);
public ObjRef CreateObjRef(Type requestedType);
public void Dispose();
protected virtual void Dispose(bool disposing);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public object GetLifetimeService();
protected virtual object GetService(Type service);
public Type GetType();
protected virtual IntPtr HookProc(IntPtr hWnd, int msg, IntPtr wparam, IntPtr lparam);
public object InitializeLifetimeService();
protected object MemberwiseClone();
protected virtual void OnHelpRequest(EventArgs e);
protected virtual IntPtr OwnerWndProc(IntPtr hWnd, int msg, IntPtr wparam, IntPtr lparam);
public void remove_Disposed(EventHandler value);
public void remove_HelpRequest(EventHandler value);
public abstract void Reset();
protected abstract bool RunDialog(IntPtr hwndOwner);
public DialogResult ShowDialog();
public DialogResult ShowDialog(IWin32Window owner);
public virtual string ToString();

Property
public IContainer Container {get;}
protected bool DesignMode {get;}
protected EventHandlerList Events {get;}
public ISite Site {get; set;}

System.Windows.Forms.ComboBoxStyle

Module:System.Windows.Forms.dll

Hierarchy
Object
ValueType
Enum
ComboBoxStyle

Type declaration

[C#] public enum ComboBoxStyle;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const ComboBoxStyle DropDown = 1;
public const ComboBoxStyle DropDownList = 2;
public const ComboBoxStyle Simple = 0;
public int value__;

System.Windows.Forms.ComboBox+ObjectCollection

Module:System.Windows.Forms.dll

Hierarchy
Object
ComboBox+ObjectCollection : IList, ICollection, IEnumerable

Type declaration

[C#] public class ObjectCollection: IList, ICollection, IEnumerable;

Constructor
public ObjectCollection(ComboBox owner);

Method
public virtual int Add(object obj);
public void AddRange(object[] items);
public virtual void Clear();
public virtual bool Contains(object obj);
public void CopyTo(object[] dest, int arrayIndex);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual IEnumerator GetEnumerator();
public virtual int GetHashCode();
public Type GetType();
public virtual int IndexOf(object obj);
public virtual void Insert(int index, object obj);
protected object MemberwiseClone();
public virtual void Remove(object obj);
public virtual void RemoveAt(int index);
public virtual string ToString();

Property
public virtual int Count {get;}
public virtual bool IsReadOnly {get;}
public virtual object this[int index] {get; set;}

System.Windows.Forms.ComboBox

Module:System.Windows.Forms.dll

Hierarchy
Object
MarshalByRefObject
Component
Control
ListControl
ComboBox

Type declaration

[C#] public class ComboBox : ListControl;

Constructor
public ComboBox();

Method
protected void AccessibilityNotifyClients(AccessibleEvents accEvent, int childID);
public void add_BackColorChanged(EventHandler value);
public void add_BackgroundImageChanged(EventHandler value);
public void add_BindingContextChanged(EventHandler value);
public void add_CausesValidationChanged(EventHandler value);
public void add_ChangeUICues(UICuesEventHandler value);
public void add_Click(EventHandler value);
public void add_ContextMenuChanged(EventHandler value);
public void add_ControlAdded(ControlEventHandler value);
public void add_ControlRemoved(ControlEventHandler value);
public void add_CursorChanged(EventHandler value);
public void add_DataSourceChanged(EventHandler value);
public void add_DisplayMemberChanged(EventHandler value);
public void add_Disposed(EventHandler value);
public void add_DockChanged(EventHandler value);
public void add_DoubleClick(EventHandler value);
public void add_DragDrop(DragEventHandler value);
public void add_DragEnter(DragEventHandler value);
public void add_DragLeave(EventHandler value);
public void add_DragOver(DragEventHandler value);
public void add_DrawItem(DrawItemEventHandler value);
public void add_DropDown(EventHandler value);
public void add_DropDownStyleChanged(EventHandler value);
public void add_EnabledChanged(EventHandler value);
public void add_Enter(EventHandler value);
public void add_FontChanged(EventHandler value);
public void add_ForeColorChanged(EventHandler value);
public void add_GiveFeedback(GiveFeedbackEventHandler value);
public void add_GotFocus(EventHandler value);
public void add_HandleCreated(EventHandler value);
public void add_HandleDestroyed(EventHandler value);
public void add_HelpRequested(HelpEventHandler value);
public void add_ImeModeChanged(EventHandler value);
public void add_Invalidated(InvalidateEventHandler value);
public void add_KeyDown(KeyEventHandler value);
public void add_KeyPress(KeyPressEventHandler value);
public void add_KeyUp(KeyEventHandler value);
public void add_Layout(LayoutEventHandler value);
public void add_Leave(EventHandler value);
public void add_LocationChanged(EventHandler value);
public void add_LostFocus(EventHandler value);
public void add_MeasureItem(MeasureItemEventHandler value);
public void add_MouseDown(MouseEventHandler value);
public void add_MouseEnter(EventHandler value);
public void add_MouseHover(EventHandler value);
public void add_MouseLeave(EventHandler value);
public void add_MouseMove(MouseEventHandler value);
public void add_MouseUp(MouseEventHandler value);
public void add_MouseWheel(MouseEventHandler value);
public void add_Move(EventHandler value);
public void add_Paint(PaintEventHandler value);
public void add_ParentChanged(EventHandler value);
public void add_QueryAccessibilityHelp(QueryAccessibilityHelpEventHandler value);
public void add_QueryContinueDrag(QueryContinueDragEventHandler value);
public void add_Resize(EventHandler value);
public void add_RightToLeftChanged(EventHandler value);
public void add_SelectedIndexChanged(EventHandler value);
public void add_SelectedValueChanged(EventHandler value);
public void add_SelectionChangeCommitted(EventHandler value);
public void add_SizeChanged(EventHandler value);
public void add_StyleChanged(EventHandler value);
public void add_SystemColorsChanged(EventHandler value);
public void add_TabIndexChanged(EventHandler value);
public void add_TabStopChanged(EventHandler value);
public void add_TextChanged(EventHandler value);
public void add_Validated(EventHandler value);
public void add_Validating(CancelEventHandler value);
public void add_ValueMemberChanged(EventHandler value);
public void add_VisibleChanged(EventHandler value);
protected virtual void AddItemsCore(object[] value);
public IAsyncResult BeginInvoke(Delegate method);
public IAsyncResult BeginInvoke(Delegate method, object[] args);
public void BeginUpdate();
public void BringToFront();
public bool Contains(Control ctl);
protected virtual AccessibleObject CreateAccessibilityInstance();
public void CreateControl();
protected virtual ControlCollection CreateControlsInstance();
public Graphics CreateGraphics();
protected virtual void CreateHandle();
public ObjRef CreateObjRef(Type requestedType);
protected virtual void DefWndProc(ref Message m);
protected virtual void DestroyHandle();
public void Dispose();
protected override void Dispose(bool disposing);
public DragDropEffects DoDragDrop(object data, DragDropEffects allowedEffects);
public object EndInvoke(IAsyncResult asyncResult);
public void EndUpdate();
public virtual bool Equals(object obj);
protected object FilterItemOnProperty(object item);
protected object FilterItemOnProperty(object item, string strField);
protected override void Finalize();
public Form FindForm();
public int FindString(string s);
public int FindString(string s, int startIndex);
public int FindStringExact(string s);
public int FindStringExact(string s, int startIndex);
public bool Focus();
public Control GetChildAtPoint(Point pt);
public IContainerControl GetContainerControl();
public virtual int GetHashCode();
public int GetItemHeight(int index);
public string GetItemText(object item);
public object GetLifetimeService();
public Control GetNextControl(Control ctl, bool forward);
protected virtual object GetService(Type service);
protected bool GetStyle(ControlStyles flag);
protected bool GetTopLevel();
public Type GetType();
public void Hide();
public object InitializeLifetimeService();
protected virtual void InitLayout();
public void Invalidate();
public void Invalidate(bool invalidateChildren);
public void Invalidate(Rectangle rect);
public void Invalidate(Rectangle rc, bool invalidateChildren);
public void Invalidate(Region region);
public void Invalidate(Region region, bool invalidateChildren);
public object Invoke(Delegate method);
public object Invoke(Delegate method, object[] args);
protected void InvokeGotFocus(Control toInvoke, EventArgs e);
protected void InvokeLostFocus(Control toInvoke, EventArgs e);
protected void InvokeOnClick(Control toInvoke, EventArgs e);
protected void InvokePaint(Control c, PaintEventArgs e);
protected void InvokePaintBackground(Control c, PaintEventArgs e);
protected virtual bool IsInputChar(char charCode);
protected virtual bool IsInputKey(Keys keyData);
protected object MemberwiseClone();
protected virtual void NotifyInvalidate(Rectangle invalidatedArea);
protected virtual void OnBackColorChanged(EventArgs e);
protected virtual void OnBackgroundImageChanged(EventArgs e);
protected override void OnBindingContextChanged(EventArgs e);
protected virtual void OnCausesValidationChanged(EventArgs e);
protected virtual void OnChangeUICues(UICuesEventArgs e);
protected virtual void OnClick(EventArgs e);
protected virtual void OnContextMenuChanged(EventArgs e);
protected virtual void OnControlAdded(ControlEventArgs e);
protected virtual void OnControlRemoved(ControlEventArgs e);
protected virtual void OnCreateControl();
protected virtual void OnCursorChanged(EventArgs e);
protected override void OnDataSourceChanged(EventArgs e);
protected override void OnDisplayMemberChanged(EventArgs e);
protected virtual void OnDockChanged(EventArgs e);
protected virtual void OnDoubleClick(EventArgs e);
protected virtual void OnDragDrop(DragEventArgs drgevent);
protected virtual void OnDragEnter(DragEventArgs drgevent);
protected virtual void OnDragLeave(EventArgs e);
protected virtual void OnDragOver(DragEventArgs drgevent);
protected virtual void OnDrawItem(DrawItemEventArgs e);
protected virtual void OnDropDown(EventArgs e);
protected virtual void OnDropDownStyleChanged(EventArgs e);
protected virtual void OnEnabledChanged(EventArgs e);
protected virtual void OnEnter(EventArgs e);
protected virtual void OnFontChanged(EventArgs e);
protected virtual void OnForeColorChanged(EventArgs e);
protected virtual void OnGiveFeedback(GiveFeedbackEventArgs gfbevent);
protected virtual void OnGotFocus(EventArgs e);
protected virtual void OnHandleCreated(EventArgs e);
protected virtual void OnHandleDestroyed(EventArgs e);
protected virtual void OnHelpRequested(HelpEventArgs hevent);
protected virtual void OnImeModeChanged(EventArgs e);
protected virtual void OnInvalidated(InvalidateEventArgs e);
protected virtual void OnKeyDown(KeyEventArgs e);
protected virtual void OnKeyPress(KeyPressEventArgs e);
protected virtual void OnKeyUp(KeyEventArgs e);
protected virtual void OnLayout(LayoutEventArgs levent);
protected virtual void OnLeave(EventArgs e);
protected virtual void OnLocationChanged(EventArgs e);
protected virtual void OnLostFocus(EventArgs e);
protected virtual void OnMeasureItem(MeasureItemEventArgs e);
protected virtual void OnMouseDown(MouseEventArgs e);
protected virtual void OnMouseEnter(EventArgs e);
protected virtual void OnMouseHover(EventArgs e);
protected virtual void OnMouseLeave(EventArgs e);
protected virtual void OnMouseMove(MouseEventArgs e);
protected virtual void OnMouseUp(MouseEventArgs e);
protected virtual void OnMouseWheel(MouseEventArgs e);
protected virtual void OnMove(EventArgs e);
protected virtual void OnNotifyMessage(Message m);
protected virtual void OnPaint(PaintEventArgs e);
protected virtual void OnPaintBackground(PaintEventArgs e);
protected virtual void OnParentBackColorChanged(EventArgs e);
protected virtual void OnParentBackgroundImageChanged(EventArgs e);
protected virtual void OnParentBindingContextChanged(EventArgs e);
protected virtual void OnParentChanged(EventArgs e);
protected virtual void OnParentEnabledChanged(EventArgs e);
protected virtual void OnParentFontChanged(EventArgs e);
protected virtual void OnParentForeColorChanged(EventArgs e);
protected virtual void OnParentRightToLeftChanged(EventArgs e);
protected virtual void OnParentVisibleChanged(EventArgs e);
protected virtual void OnQueryContinueDrag(QueryContinueDragEventArgs qcdevent);
protected virtual void OnResize(EventArgs e);
protected virtual void OnRightToLeftChanged(EventArgs e);
protected override void OnSelectedIndexChanged(EventArgs e);
protected virtual void OnSelectedItemChanged(EventArgs e);
protected virtual void OnSelectedValueChanged(EventArgs e);
protected virtual void OnSelectionChangeCommitted(EventArgs e);
protected virtual void OnSizeChanged(EventArgs e);
protected virtual void OnStyleChanged(EventArgs e);
protected virtual void OnSystemColorsChanged(EventArgs e);
protected virtual void OnTabIndexChanged(EventArgs e);
protected virtual void OnTabStopChanged(EventArgs e);
protected virtual void OnTextChanged(EventArgs e);
protected virtual void OnValidated(EventArgs e);
protected virtual void OnValidating(CancelEventArgs e);
protected virtual void OnValueMemberChanged(EventArgs e);
protected virtual void OnVisibleChanged(EventArgs e);
public void PerformLayout();
public void PerformLayout(Control affectedControl, string affectedProperty);
public Point PointToClient(Point p);
public Point PointToScreen(Point p);
public bool PreProcessMessage(ref Message msg);
protected virtual bool ProcessCmdKey(ref Message msg, Keys keyData);
protected virtual bool ProcessDialogChar(char charCode);
protected virtual bool ProcessDialogKey(Keys keyData);
protected virtual bool ProcessKeyEventArgs(ref Message m);
protected virtual bool ProcessKeyPreview(ref Message m);
protected virtual bool ProcessMnemonic(char charCode);
protected void RaiseDragEvent(object key, DragEventArgs e);
protected void RaiseKeyEvent(object key, KeyEventArgs e);
protected void RaiseMouseEvent(object key, MouseEventArgs e);
protected void RaisePaintEvent(object key, PaintEventArgs e);
protected void RecreateHandle();
public Rectangle RectangleToClient(Rectangle r);
public Rectangle RectangleToScreen(Rectangle r);
public virtual void Refresh();
protected virtual void RefreshItem(int index);
public void remove_BackColorChanged(EventHandler value);
public void remove_BackgroundImageChanged(EventHandler value);
public void remove_BindingContextChanged(EventHandler value);
public void remove_CausesValidationChanged(EventHandler value);
public void remove_ChangeUICues(UICuesEventHandler value);
public void remove_Click(EventHandler value);
public void remove_ContextMenuChanged(EventHandler value);
public void remove_ControlAdded(ControlEventHandler value);
public void remove_ControlRemoved(ControlEventHandler value);
public void remove_CursorChanged(EventHandler value);
public void remove_DataSourceChanged(EventHandler value);
public void remove_DisplayMemberChanged(EventHandler value);
public void remove_Disposed(EventHandler value);
public void remove_DockChanged(EventHandler value);
public void remove_DoubleClick(EventHandler value);
public void remove_DragDrop(DragEventHandler value);
public void remove_DragEnter(DragEventHandler value);
public void remove_DragLeave(EventHandler value);
public void remove_DragOver(DragEventHandler value);
public void remove_DrawItem(DrawItemEventHandler value);
public void remove_DropDown(EventHandler value);
public void remove_DropDownStyleChanged(EventHandler value);
public void remove_EnabledChanged(EventHandler value);
public void remove_Enter(EventHandler value);
public void remove_FontChanged(EventHandler value);
public void remove_ForeColorChanged(EventHandler value);
public void remove_GiveFeedback(GiveFeedbackEventHandler value);
public void remove_GotFocus(EventHandler value);
public void remove_HandleCreated(EventHandler value);
public void remove_HandleDestroyed(EventHandler value);
public void remove_HelpRequested(HelpEventHandler value);
public void remove_ImeModeChanged(EventHandler value);
public void remove_Invalidated(InvalidateEventHandler value);
public void remove_KeyDown(KeyEventHandler value);
public void remove_KeyPress(KeyPressEventHandler value);
public void remove_KeyUp(KeyEventHandler value);
public void remove_Layout(LayoutEventHandler value);
public void remove_Leave(EventHandler value);
public void remove_LocationChanged(EventHandler value);
public void remove_LostFocus(EventHandler value);
public void remove_MeasureItem(MeasureItemEventHandler value);
public void remove_MouseDown(MouseEventHandler value);
public void remove_MouseEnter(EventHandler value);
public void remove_MouseHover(EventHandler value);
public void remove_MouseLeave(EventHandler value);
public void remove_MouseMove(MouseEventHandler value);
public void remove_MouseUp(MouseEventHandler value);
public void remove_MouseWheel(MouseEventHandler value);
public void remove_Move(EventHandler value);
public void remove_Paint(PaintEventHandler value);
public void remove_ParentChanged(EventHandler value);
public void remove_QueryAccessibilityHelp(QueryAccessibilityHelpEventHandler value);
public void remove_QueryContinueDrag(QueryContinueDragEventHandler value);
public void remove_Resize(EventHandler value);
public void remove_RightToLeftChanged(EventHandler value);
public void remove_SelectedIndexChanged(EventHandler value);
public void remove_SelectedValueChanged(EventHandler value);
public void remove_SelectionChangeCommitted(EventHandler value);
public void remove_SizeChanged(EventHandler value);
public void remove_StyleChanged(EventHandler value);
public void remove_SystemColorsChanged(EventHandler value);
public void remove_TabIndexChanged(EventHandler value);
public void remove_TabStopChanged(EventHandler value);
public void remove_TextChanged(EventHandler value);
public void remove_Validated(EventHandler value);
public void remove_Validating(CancelEventHandler value);
public void remove_ValueMemberChanged(EventHandler value);
public void remove_VisibleChanged(EventHandler value);
public void ResetBackColor();
public void ResetBindings();
public void ResetCursor();
public void ResetFont();
public void ResetForeColor();
public void ResetImeMode();
protected void ResetMouseEventArgs();
public void ResetRightToLeft();
public void ResetText();
public void ResumeLayout();
public void ResumeLayout(bool performLayout);
protected ContentAlignment RtlTranslateAlignment(ContentAlignment align);
protected HorizontalAlignment RtlTranslateAlignment(HorizontalAlignment align);
protected LeftRightAlignment RtlTranslateAlignment(LeftRightAlignment align);
protected ContentAlignment RtlTranslateContent(ContentAlignment align);
protected HorizontalAlignment RtlTranslateHorizontal(HorizontalAlignment align);
protected LeftRightAlignment RtlTranslateLeftRight(LeftRightAlignment align);
public void Scale(float ratio);
public void Scale(float dx, float dy);
protected virtual void ScaleCore(float dx, float dy);
public void Select();
protected virtual void Select(bool directed, bool forward);
public void Select(int start, int length);
public void SelectAll();
public bool SelectNextControl(Control ctl, bool forward, bool tabStopOnly, bool nested, bool wrap);
public void SendToBack();
public void SetBounds(int x, int y, int width, int height);
public void SetBounds(int x, int y, int width, int height, BoundsSpecified specified);
protected virtual void SetBoundsCore(int x, int y, int width, int height, BoundsSpecified specified);
protected virtual void SetClientSizeCore(int x, int y);
protected virtual void SetItemCore(int index, object value);
protected override void SetItemsCore(IList value);
protected void SetStyle(ControlStyles flag, bool value);
protected void SetTopLevel(bool value);
protected virtual void SetVisibleCore(bool value);
public void Show();
public void SuspendLayout();
public virtual string ToString();
public void Update();
protected void UpdateBounds();
protected void UpdateBounds(int x, int y, int width, int height);
protected void UpdateBounds(int x, int y, int width, int height, int clientWidth, int clientHeight);
protected void UpdateStyles();
protected void UpdateZOrder();
protected virtual void WndProc(ref Message m);

Property
public AccessibleObject AccessibilityObject {get;}
public string AccessibleDefaultActionDescription {get; set;}
public string AccessibleDescription {get; set;}
public string AccessibleName {get; set;}
public AccessibleRole AccessibleRole {get; set;}
public bool AllowDrop {get; set;}
public AnchorStyles Anchor {get; set;}
public virtual Color BackColor {get; set;}
public override Image BackgroundImage {get; set;}
public virtual BindingContext BindingContext {get; set;}
public int Bottom {get;}
public Rectangle Bounds {get; set;}
public bool CanFocus {get;}
public bool CanSelect {get;}
public bool Capture {get; set;}
public bool CausesValidation {get; set;}
public Rectangle ClientRectangle {get;}
public Size ClientSize {get; set;}
public string CompanyName {get;}
public IContainer Container {get;}
public bool ContainsFocus {get;}
public ContextMenu ContextMenu {get; set;}
public ControlCollection Controls {get;}
public bool Created {get;}
protected virtual CreateParams CreateParams {get;}
public Cursor Cursor {get; set;}
public ControlBindingsCollection DataBindings {get;}
protected CurrencyManager DataManager {get;}
public object DataSource {get; set;}
protected virtual ImeMode DefaultImeMode {get;}
protected virtual Size DefaultSize {get;}
protected bool DesignMode {get;}
public string DisplayMember {get; set;}
public Rectangle DisplayRectangle {get;}
public bool Disposing {get;}
public DockStyle Dock {get; set;}
public DrawMode DrawMode {get; set;}
public ComboBoxStyle DropDownStyle {get; set;}
public int DropDownWidth {get; set;}
public bool DroppedDown {get; set;}
public bool Enabled {get; set;}
protected EventHandlerList Events {get;}
public bool Focused {get;}
public virtual Font Font {get; set;}
protected int FontHeight {get; set;}
public virtual Color ForeColor {get; set;}
public IntPtr Handle {get;}
public bool HasChildren {get;}
public int Height {get; set;}
public ImeMode ImeMode {get; set;}
public bool IntegralHeight {get; set;}
public bool InvokeRequired {get;}
public bool IsAccessible {get; set;}
public bool IsDisposed {get;}
public bool IsHandleCreated {get;}
public int ItemHeight {get; set;}
public ObjectCollection Items {get;}
public int Left {get; set;}
public Point Location {get; set;}
public int MaxDropDownItems {get; set;}
public int MaxLength {get; set;}
public string Name {get; set;}
public Control Parent {get; set;}
public int PreferredHeight {get;}
public string ProductName {get;}
public string ProductVersion {get;}
public bool RecreatingHandle {get;}
public Region Region {get; set;}
protected bool RenderRightToLeft {get;}
protected bool ResizeRedraw {get; set;}
public int Right {get;}
public RightToLeft RightToLeft {get; set;}
public override int SelectedIndex {get; set;}
public object SelectedItem {get; set;}
public string SelectedText {get; set;}
public object SelectedValue {get; set;}
public int SelectionLength {get; set;}
public int SelectionStart {get; set;}
protected virtual bool ShowFocusCues {get;}
protected bool ShowKeyboardCues {get;}
public ISite Site {get; set;}
public Size Size {get; set;}
public bool Sorted {get; set;}
public int TabIndex {get; set;}
public bool TabStop {get; set;}
public object Tag {get; set;}
public override string Text {get; set;}
public int Top {get; set;}
public Control TopLevelControl {get;}
public string ValueMember {get; set;}
public bool Visible {get; set;}
public int Width {get; set;}
public IWindowTarget WindowTarget {get; set;}

System.Windows.Forms.ListControl

Module:System.Windows.Forms.dll

Hierarchy
Object
MarshalByRefObject
Component
Control
ListControl

Type declaration

[C#] public abstract class ListControl : Control;

Constructor
protected ListControl();

Method
protected void AccessibilityNotifyClients(AccessibleEvents accEvent, int childID);
public void add_BackColorChanged(EventHandler value);
public void add_BackgroundImageChanged(EventHandler value);
public void add_BindingContextChanged(EventHandler value);
public void add_CausesValidationChanged(EventHandler value);
public void add_ChangeUICues(UICuesEventHandler value);
public void add_Click(EventHandler value);
public void add_ContextMenuChanged(EventHandler value);
public void add_ControlAdded(ControlEventHandler value);
public void add_ControlRemoved(ControlEventHandler value);
public void add_CursorChanged(EventHandler value);
public void add_DataSourceChanged(EventHandler value);
public void add_DisplayMemberChanged(EventHandler value);
public void add_Disposed(EventHandler value);
public void add_DockChanged(EventHandler value);
public void add_DoubleClick(EventHandler value);
public void add_DragDrop(DragEventHandler value);
public void add_DragEnter(DragEventHandler value);
public void add_DragLeave(EventHandler value);
public void add_DragOver(DragEventHandler value);
public void add_EnabledChanged(EventHandler value);
public void add_Enter(EventHandler value);
public void add_FontChanged(EventHandler value);
public void add_ForeColorChanged(EventHandler value);
public void add_GiveFeedback(GiveFeedbackEventHandler value);
public void add_GotFocus(EventHandler value);
public void add_HandleCreated(EventHandler value);
public void add_HandleDestroyed(EventHandler value);
public void add_HelpRequested(HelpEventHandler value);
public void add_ImeModeChanged(EventHandler value);
public void add_Invalidated(InvalidateEventHandler value);
public void add_KeyDown(KeyEventHandler value);
public void add_KeyPress(KeyPressEventHandler value);
public void add_KeyUp(KeyEventHandler value);
public void add_Layout(LayoutEventHandler value);
public void add_Leave(EventHandler value);
public void add_LocationChanged(EventHandler value);
public void add_LostFocus(EventHandler value);
public void add_MouseDown(MouseEventHandler value);
public void add_MouseEnter(EventHandler value);
public void add_MouseHover(EventHandler value);
public void add_MouseLeave(EventHandler value);
public void add_MouseMove(MouseEventHandler value);
public void add_MouseUp(MouseEventHandler value);
public void add_MouseWheel(MouseEventHandler value);
public void add_Move(EventHandler value);
public void add_Paint(PaintEventHandler value);
public void add_ParentChanged(EventHandler value);
public void add_QueryAccessibilityHelp(QueryAccessibilityHelpEventHandler value);
public void add_QueryContinueDrag(QueryContinueDragEventHandler value);
public void add_Resize(EventHandler value);
public void add_RightToLeftChanged(EventHandler value);
public void add_SelectedValueChanged(EventHandler value);
public void add_SizeChanged(EventHandler value);
public void add_StyleChanged(EventHandler value);
public void add_SystemColorsChanged(EventHandler value);
public void add_TabIndexChanged(EventHandler value);
public void add_TabStopChanged(EventHandler value);
public void add_TextChanged(EventHandler value);
public void add_Validated(EventHandler value);
public void add_Validating(CancelEventHandler value);
public void add_ValueMemberChanged(EventHandler value);
public void add_VisibleChanged(EventHandler value);
public IAsyncResult BeginInvoke(Delegate method);
public IAsyncResult BeginInvoke(Delegate method, object[] args);
public void BringToFront();
public bool Contains(Control ctl);
protected virtual AccessibleObject CreateAccessibilityInstance();
public void CreateControl();
protected virtual ControlCollection CreateControlsInstance();
public Graphics CreateGraphics();
protected virtual void CreateHandle();
public ObjRef CreateObjRef(Type requestedType);
protected virtual void DefWndProc(ref Message m);
protected virtual void DestroyHandle();
public void Dispose();
protected override void Dispose(bool disposing);
public DragDropEffects DoDragDrop(object data, DragDropEffects allowedEffects);
public object EndInvoke(IAsyncResult asyncResult);
public virtual bool Equals(object obj);
protected object FilterItemOnProperty(object item);
protected object FilterItemOnProperty(object item, string strField);
protected override void Finalize();
public Form FindForm();
public bool Focus();
public Control GetChildAtPoint(Point pt);
public IContainerControl GetContainerControl();
public virtual int GetHashCode();
public string GetItemText(object item);
public object GetLifetimeService();
public Control GetNextControl(Control ctl, bool forward);
protected virtual object GetService(Type service);
protected bool GetStyle(ControlStyles flag);
protected bool GetTopLevel();
public Type GetType();
public void Hide();
public object InitializeLifetimeService();
protected virtual void InitLayout();
public void Invalidate();
public void Invalidate(bool invalidateChildren);
public void Invalidate(Rectangle rect);
public void Invalidate(Rectangle rc, bool invalidateChildren);
public void Invalidate(Region region);
public void Invalidate(Region region, bool invalidateChildren);
public object Invoke(Delegate method);
public object Invoke(Delegate method, object[] args);
protected void InvokeGotFocus(Control toInvoke, EventArgs e);
protected void InvokeLostFocus(Control toInvoke, EventArgs e);
protected void InvokeOnClick(Control toInvoke, EventArgs e);
protected void InvokePaint(Control c, PaintEventArgs e);
protected void InvokePaintBackground(Control c, PaintEventArgs e);
protected virtual bool IsInputChar(char charCode);
protected virtual bool IsInputKey(Keys keyData);
protected object MemberwiseClone();
protected virtual void NotifyInvalidate(Rectangle invalidatedArea);
protected virtual void OnBackColorChanged(EventArgs e);
protected virtual void OnBackgroundImageChanged(EventArgs e);
protected override void OnBindingContextChanged(EventArgs e);
protected virtual void OnCausesValidationChanged(EventArgs e);
protected virtual void OnChangeUICues(UICuesEventArgs e);
protected virtual void OnClick(EventArgs e);
protected virtual void OnContextMenuChanged(EventArgs e);
protected virtual void OnControlAdded(ControlEventArgs e);
protected virtual void OnControlRemoved(ControlEventArgs e);
protected virtual void OnCreateControl();
protected virtual void OnCursorChanged(EventArgs e);
protected virtual void OnDataSourceChanged(EventArgs e);
protected virtual void OnDisplayMemberChanged(EventArgs e);
protected virtual void OnDockChanged(EventArgs e);
protected virtual void OnDoubleClick(EventArgs e);
protected virtual void OnDragDrop(DragEventArgs drgevent);
protected virtual void OnDragEnter(DragEventArgs drgevent);
protected virtual void OnDragLeave(EventArgs e);
protected virtual void OnDragOver(DragEventArgs drgevent);
protected virtual void OnEnabledChanged(EventArgs e);
protected virtual void OnEnter(EventArgs e);
protected virtual void OnFontChanged(EventArgs e);
protected virtual void OnForeColorChanged(EventArgs e);
protected virtual void OnGiveFeedback(GiveFeedbackEventArgs gfbevent);
protected virtual void OnGotFocus(EventArgs e);
protected virtual void OnHandleCreated(EventArgs e);
protected virtual void OnHandleDestroyed(EventArgs e);
protected virtual void OnHelpRequested(HelpEventArgs hevent);
protected virtual void OnImeModeChanged(EventArgs e);
protected virtual void OnInvalidated(InvalidateEventArgs e);
protected virtual void OnKeyDown(KeyEventArgs e);
protected virtual void OnKeyPress(KeyPressEventArgs e);
protected virtual void OnKeyUp(KeyEventArgs e);
protected virtual void OnLayout(LayoutEventArgs levent);
protected virtual void OnLeave(EventArgs e);
protected virtual void OnLocationChanged(EventArgs e);
protected virtual void OnLostFocus(EventArgs e);
protected virtual void OnMouseDown(MouseEventArgs e);
protected virtual void OnMouseEnter(EventArgs e);
protected virtual void OnMouseHover(EventArgs e);
protected virtual void OnMouseLeave(EventArgs e);
protected virtual void OnMouseMove(MouseEventArgs e);
protected virtual void OnMouseUp(MouseEventArgs e);
protected virtual void OnMouseWheel(MouseEventArgs e);
protected virtual void OnMove(EventArgs e);
protected virtual void OnNotifyMessage(Message m);
protected virtual void OnPaint(PaintEventArgs e);
protected virtual void OnPaintBackground(PaintEventArgs e);
protected virtual void OnParentBackColorChanged(EventArgs e);
protected virtual void OnParentBackgroundImageChanged(EventArgs e);
protected virtual void OnParentBindingContextChanged(EventArgs e);
protected virtual void OnParentChanged(EventArgs e);
protected virtual void OnParentEnabledChanged(EventArgs e);
protected virtual void OnParentFontChanged(EventArgs e);
protected virtual void OnParentForeColorChanged(EventArgs e);
protected virtual void OnParentRightToLeftChanged(EventArgs e);
protected virtual void OnParentVisibleChanged(EventArgs e);
protected virtual void OnQueryContinueDrag(QueryContinueDragEventArgs qcdevent);
protected virtual void OnResize(EventArgs e);
protected virtual void OnRightToLeftChanged(EventArgs e);
protected virtual void OnSelectedIndexChanged(EventArgs e);
protected virtual void OnSelectedValueChanged(EventArgs e);
protected virtual void OnSizeChanged(EventArgs e);
protected virtual void OnStyleChanged(EventArgs e);
protected virtual void OnSystemColorsChanged(EventArgs e);
protected virtual void OnTabIndexChanged(EventArgs e);
protected virtual void OnTabStopChanged(EventArgs e);
protected virtual void OnTextChanged(EventArgs e);
protected virtual void OnValidated(EventArgs e);
protected virtual void OnValidating(CancelEventArgs e);
protected virtual void OnValueMemberChanged(EventArgs e);
protected virtual void OnVisibleChanged(EventArgs e);
public void PerformLayout();
public void PerformLayout(Control affectedControl, string affectedProperty);
public Point PointToClient(Point p);
public Point PointToScreen(Point p);
public bool PreProcessMessage(ref Message msg);
protected virtual bool ProcessCmdKey(ref Message msg, Keys keyData);
protected virtual bool ProcessDialogChar(char charCode);
protected virtual bool ProcessDialogKey(Keys keyData);
protected virtual bool ProcessKeyEventArgs(ref Message m);
protected virtual bool ProcessKeyPreview(ref Message m);
protected virtual bool ProcessMnemonic(char charCode);
protected void RaiseDragEvent(object key, DragEventArgs e);
protected void RaiseKeyEvent(object key, KeyEventArgs e);
protected void RaiseMouseEvent(object key, MouseEventArgs e);
protected void RaisePaintEvent(object key, PaintEventArgs e);
protected void RecreateHandle();
public Rectangle RectangleToClient(Rectangle r);
public Rectangle RectangleToScreen(Rectangle r);
public virtual void Refresh();
protected abstract void RefreshItem(int index);
public void remove_BackColorChanged(EventHandler value);
public void remove_BackgroundImageChanged(EventHandler value);
public void remove_BindingContextChanged(EventHandler value);
public void remove_CausesValidationChanged(EventHandler value);
public void remove_ChangeUICues(UICuesEventHandler value);
public void remove_Click(EventHandler value);
public void remove_ContextMenuChanged(EventHandler value);
public void remove_ControlAdded(ControlEventHandler value);
public void remove_ControlRemoved(ControlEventHandler value);
public void remove_CursorChanged(EventHandler value);
public void remove_DataSourceChanged(EventHandler value);
public void remove_DisplayMemberChanged(EventHandler value);
public void remove_Disposed(EventHandler value);
public void remove_DockChanged(EventHandler value);
public void remove_DoubleClick(EventHandler value);
public void remove_DragDrop(DragEventHandler value);
public void remove_DragEnter(DragEventHandler value);
public void remove_DragLeave(EventHandler value);
public void remove_DragOver(DragEventHandler value);
public void remove_EnabledChanged(EventHandler value);
public void remove_Enter(EventHandler value);
public void remove_FontChanged(EventHandler value);
public void remove_ForeColorChanged(EventHandler value);
public void remove_GiveFeedback(GiveFeedbackEventHandler value);
public void remove_GotFocus(EventHandler value);
public void remove_HandleCreated(EventHandler value);
public void remove_HandleDestroyed(EventHandler value);
public void remove_HelpRequested(HelpEventHandler value);
public void remove_ImeModeChanged(EventHandler value);
public void remove_Invalidated(InvalidateEventHandler value);
public void remove_KeyDown(KeyEventHandler value);
public void remove_KeyPress(KeyPressEventHandler value);
public void remove_KeyUp(KeyEventHandler value);
public void remove_Layout(LayoutEventHandler value);
public void remove_Leave(EventHandler value);
public void remove_LocationChanged(EventHandler value);
public void remove_LostFocus(EventHandler value);
public void remove_MouseDown(MouseEventHandler value);
public void remove_MouseEnter(EventHandler value);
public void remove_MouseHover(EventHandler value);
public void remove_MouseLeave(EventHandler value);
public void remove_MouseMove(MouseEventHandler value);
public void remove_MouseUp(MouseEventHandler value);
public void remove_MouseWheel(MouseEventHandler value);
public void remove_Move(EventHandler value);
public void remove_Paint(PaintEventHandler value);
public void remove_ParentChanged(EventHandler value);
public void remove_QueryAccessibilityHelp(QueryAccessibilityHelpEventHandler value);
public void remove_QueryContinueDrag(QueryContinueDragEventHandler value);
public void remove_Resize(EventHandler value);
public void remove_RightToLeftChanged(EventHandler value);
public void remove_SelectedValueChanged(EventHandler value);
public void remove_SizeChanged(EventHandler value);
public void remove_StyleChanged(EventHandler value);
public void remove_SystemColorsChanged(EventHandler value);
public void remove_TabIndexChanged(EventHandler value);
public void remove_TabStopChanged(EventHandler value);
public void remove_TextChanged(EventHandler value);
public void remove_Validated(EventHandler value);
public void remove_Validating(CancelEventHandler value);
public void remove_ValueMemberChanged(EventHandler value);
public void remove_VisibleChanged(EventHandler value);
public void ResetBackColor();
public void ResetBindings();
public void ResetCursor();
public void ResetFont();
public void ResetForeColor();
public void ResetImeMode();
protected void ResetMouseEventArgs();
public void ResetRightToLeft();
public void ResetText();
public void ResumeLayout();
public void ResumeLayout(bool performLayout);
protected ContentAlignment RtlTranslateAlignment(ContentAlignment align);
protected HorizontalAlignment RtlTranslateAlignment(HorizontalAlignment align);
protected LeftRightAlignment RtlTranslateAlignment(LeftRightAlignment align);
protected ContentAlignment RtlTranslateContent(ContentAlignment align);
protected HorizontalAlignment RtlTranslateHorizontal(HorizontalAlignment align);
protected LeftRightAlignment RtlTranslateLeftRight(LeftRightAlignment align);
public void Scale(float ratio);
public void Scale(float dx, float dy);
protected virtual void ScaleCore(float dx, float dy);
public void Select();
protected virtual void Select(bool directed, bool forward);
public bool SelectNextControl(Control ctl, bool forward, bool tabStopOnly, bool nested, bool wrap);
public void SendToBack();
public void SetBounds(int x, int y, int width, int height);
public void SetBounds(int x, int y, int width, int height, BoundsSpecified specified);
protected virtual void SetBoundsCore(int x, int y, int width, int height, BoundsSpecified specified);
protected virtual void SetClientSizeCore(int x, int y);
protected virtual void SetItemCore(int index, object value);
protected abstract void SetItemsCore(IList items);
protected void SetStyle(ControlStyles flag, bool value);
protected void SetTopLevel(bool value);
protected virtual void SetVisibleCore(bool value);
public void Show();
public void SuspendLayout();
public virtual string ToString();
public void Update();
protected void UpdateBounds();
protected void UpdateBounds(int x, int y, int width, int height);
protected void UpdateBounds(int x, int y, int width, int height, int clientWidth, int clientHeight);
protected void UpdateStyles();
protected void UpdateZOrder();
protected virtual void WndProc(ref Message m);

Property
public AccessibleObject AccessibilityObject {get;}
public string AccessibleDefaultActionDescription {get; set;}
public string AccessibleDescription {get; set;}
public string AccessibleName {get; set;}
public AccessibleRole AccessibleRole {get; set;}
public bool AllowDrop {get; set;}
public AnchorStyles Anchor {get; set;}
public virtual Color BackColor {get; set;}
public Image BackgroundImage {get; set;}
public virtual BindingContext BindingContext {get; set;}
public int Bottom {get;}
public Rectangle Bounds {get; set;}
public bool CanFocus {get;}
public bool CanSelect {get;}
public bool Capture {get; set;}
public bool CausesValidation {get; set;}
public Rectangle ClientRectangle {get;}
public Size ClientSize {get; set;}
public string CompanyName {get;}
public IContainer Container {get;}
public bool ContainsFocus {get;}
public ContextMenu ContextMenu {get; set;}
public ControlCollection Controls {get;}
public bool Created {get;}
protected virtual CreateParams CreateParams {get;}
public Cursor Cursor {get; set;}
public ControlBindingsCollection DataBindings {get;}
protected CurrencyManager DataManager {get;}
public object DataSource {get; set;}
protected virtual ImeMode DefaultImeMode {get;}
protected virtual Size DefaultSize {get;}
protected bool DesignMode {get;}
public string DisplayMember {get; set;}
public Rectangle DisplayRectangle {get;}
public bool Disposing {get;}
public DockStyle Dock {get; set;}
public bool Enabled {get; set;}
protected EventHandlerList Events {get;}
public bool Focused {get;}
public virtual Font Font {get; set;}
protected int FontHeight {get; set;}
public virtual Color ForeColor {get; set;}
public IntPtr Handle {get;}
public bool HasChildren {get;}
public int Height {get; set;}
public ImeMode ImeMode {get; set;}
public bool InvokeRequired {get;}
public bool IsAccessible {get; set;}
public bool IsDisposed {get;}
public bool IsHandleCreated {get;}
public int Left {get; set;}
public Point Location {get; set;}
public string Name {get; set;}
public Control Parent {get; set;}
public string ProductName {get;}
public string ProductVersion {get;}
public bool RecreatingHandle {get;}
public Region Region {get; set;}
protected bool RenderRightToLeft {get;}
protected bool ResizeRedraw {get; set;}
public int Right {get;}
public RightToLeft RightToLeft {get; set;}
public abstract int SelectedIndex {get; set;}
public object SelectedValue {get; set;}
protected virtual bool ShowFocusCues {get;}
protected bool ShowKeyboardCues {get;}
public ISite Site {get; set;}
public Size Size {get; set;}
public int TabIndex {get; set;}
public bool TabStop {get; set;}
public object Tag {get; set;}
public virtual string Text {get; set;}
public int Top {get; set;}
public Control TopLevelControl {get;}
public string ValueMember {get; set;}
public bool Visible {get; set;}
public int Width {get; set;}
public IWindowTarget WindowTarget {get; set;}

System.Windows.Forms.CheckState

Module:System.Windows.Forms.dll

Hierarchy
Object
ValueType
Enum
CheckState

Type declaration

[C#] public enum CheckState;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const CheckState Checked = 1;
public const CheckState Indeterminate = 2;
public const CheckState Unchecked = 0;
public int value__;

System.Windows.Forms.CheckBox

Module:System.Windows.Forms.dll

Hierarchy
Object
MarshalByRefObject
Component
Control
ButtonBase
CheckBox

Type declaration

[C#] public class CheckBox : ButtonBase;

Constructor
public CheckBox();

Method
protected void AccessibilityNotifyClients(AccessibleEvents accEvent, int childID);
public void add_AppearanceChanged(EventHandler value);
public void add_BackColorChanged(EventHandler value);
public void add_BackgroundImageChanged(EventHandler value);
public void add_BindingContextChanged(EventHandler value);
public void add_CausesValidationChanged(EventHandler value);
public void add_ChangeUICues(UICuesEventHandler value);
public void add_CheckedChanged(EventHandler value);
public void add_CheckStateChanged(EventHandler value);
public void add_Click(EventHandler value);
public void add_ContextMenuChanged(EventHandler value);
public void add_ControlAdded(ControlEventHandler value);
public void add_ControlRemoved(ControlEventHandler value);
public void add_CursorChanged(EventHandler value);
public void add_Disposed(EventHandler value);
public void add_DockChanged(EventHandler value);
public void add_DoubleClick(EventHandler value);
public void add_DragDrop(DragEventHandler value);
public void add_DragEnter(DragEventHandler value);
public void add_DragLeave(EventHandler value);
public void add_DragOver(DragEventHandler value);
public void add_EnabledChanged(EventHandler value);
public void add_Enter(EventHandler value);
public void add_FontChanged(EventHandler value);
public void add_ForeColorChanged(EventHandler value);
public void add_GiveFeedback(GiveFeedbackEventHandler value);
public void add_GotFocus(EventHandler value);
public void add_HandleCreated(EventHandler value);
public void add_HandleDestroyed(EventHandler value);
public void add_HelpRequested(HelpEventHandler value);
public void add_ImeModeChanged(EventHandler value);
public void add_Invalidated(InvalidateEventHandler value);
public void add_KeyDown(KeyEventHandler value);
public void add_KeyPress(KeyPressEventHandler value);
public void add_KeyUp(KeyEventHandler value);
public void add_Layout(LayoutEventHandler value);
public void add_Leave(EventHandler value);
public void add_LocationChanged(EventHandler value);
public void add_LostFocus(EventHandler value);
public void add_MouseDown(MouseEventHandler value);
public void add_MouseEnter(EventHandler value);
public void add_MouseHover(EventHandler value);
public void add_MouseLeave(EventHandler value);
public void add_MouseMove(MouseEventHandler value);
public void add_MouseUp(MouseEventHandler value);
public void add_MouseWheel(MouseEventHandler value);
public void add_Move(EventHandler value);
public void add_Paint(PaintEventHandler value);
public void add_ParentChanged(EventHandler value);
public void add_QueryAccessibilityHelp(QueryAccessibilityHelpEventHandler value);
public void add_QueryContinueDrag(QueryContinueDragEventHandler value);
public void add_Resize(EventHandler value);
public void add_RightToLeftChanged(EventHandler value);
public void add_SizeChanged(EventHandler value);
public void add_StyleChanged(EventHandler value);
public void add_SystemColorsChanged(EventHandler value);
public void add_TabIndexChanged(EventHandler value);
public void add_TabStopChanged(EventHandler value);
public void add_TextChanged(EventHandler value);
public void add_Validated(EventHandler value);
public void add_Validating(CancelEventHandler value);
public void add_VisibleChanged(EventHandler value);
public IAsyncResult BeginInvoke(Delegate method);
public IAsyncResult BeginInvoke(Delegate method, object[] args);
public void BringToFront();
public bool Contains(Control ctl);
protected virtual AccessibleObject CreateAccessibilityInstance();
public void CreateControl();
protected virtual ControlCollection CreateControlsInstance();
public Graphics CreateGraphics();
protected virtual void CreateHandle();
public ObjRef CreateObjRef(Type requestedType);
protected virtual void DefWndProc(ref Message m);
protected virtual void DestroyHandle();
public void Dispose();
protected override void Dispose(bool disposing);
public DragDropEffects DoDragDrop(object data, DragDropEffects allowedEffects);
public object EndInvoke(IAsyncResult asyncResult);
public virtual bool Equals(object obj);
protected override void Finalize();
public Form FindForm();
public bool Focus();
public Control GetChildAtPoint(Point pt);
public IContainerControl GetContainerControl();
public virtual int GetHashCode();
public object GetLifetimeService();
public Control GetNextControl(Control ctl, bool forward);
protected virtual object GetService(Type service);
protected bool GetStyle(ControlStyles flag);
protected bool GetTopLevel();
public Type GetType();
public void Hide();
public object InitializeLifetimeService();
protected virtual void InitLayout();
public void Invalidate();
public void Invalidate(bool invalidateChildren);
public void Invalidate(Rectangle rect);
public void Invalidate(Rectangle rc, bool invalidateChildren);
public void Invalidate(Region region);
public void Invalidate(Region region, bool invalidateChildren);
public object Invoke(Delegate method);
public object Invoke(Delegate method, object[] args);
protected void InvokeGotFocus(Control toInvoke, EventArgs e);
protected void InvokeLostFocus(Control toInvoke, EventArgs e);
protected void InvokeOnClick(Control toInvoke, EventArgs e);
protected void InvokePaint(Control c, PaintEventArgs e);
protected void InvokePaintBackground(Control c, PaintEventArgs e);
protected virtual bool IsInputChar(char charCode);
protected virtual bool IsInputKey(Keys keyData);
protected object MemberwiseClone();
protected virtual void NotifyInvalidate(Rectangle invalidatedArea);
protected virtual void OnAppearanceChanged(EventArgs e);
protected virtual void OnBackColorChanged(EventArgs e);
protected virtual void OnBackgroundImageChanged(EventArgs e);
protected virtual void OnBindingContextChanged(EventArgs e);
protected virtual void OnCausesValidationChanged(EventArgs e);
protected virtual void OnChangeUICues(UICuesEventArgs e);
protected virtual void OnCheckedChanged(EventArgs e);
protected virtual void OnCheckStateChanged(EventArgs e);
protected virtual void OnClick(EventArgs e);
protected virtual void OnContextMenuChanged(EventArgs e);
protected virtual void OnControlAdded(ControlEventArgs e);
protected virtual void OnControlRemoved(ControlEventArgs e);
protected virtual void OnCreateControl();
protected virtual void OnCursorChanged(EventArgs e);
protected virtual void OnDockChanged(EventArgs e);
protected virtual void OnDoubleClick(EventArgs e);
protected virtual void OnDragDrop(DragEventArgs drgevent);
protected virtual void OnDragEnter(DragEventArgs drgevent);
protected virtual void OnDragLeave(EventArgs e);
protected virtual void OnDragOver(DragEventArgs drgevent);
protected virtual void OnEnabledChanged(EventArgs e);
protected virtual void OnEnter(EventArgs e);
protected virtual void OnFontChanged(EventArgs e);
protected virtual void OnForeColorChanged(EventArgs e);
protected virtual void OnGiveFeedback(GiveFeedbackEventArgs gfbevent);
protected virtual void OnGotFocus(EventArgs e);
protected virtual void OnHandleCreated(EventArgs e);
protected virtual void OnHandleDestroyed(EventArgs e);
protected virtual void OnHelpRequested(HelpEventArgs hevent);
protected virtual void OnImeModeChanged(EventArgs e);
protected virtual void OnInvalidated(InvalidateEventArgs e);
protected virtual void OnKeyDown(KeyEventArgs e);
protected virtual void OnKeyPress(KeyPressEventArgs e);
protected virtual void OnKeyUp(KeyEventArgs e);
protected virtual void OnLayout(LayoutEventArgs levent);
protected virtual void OnLeave(EventArgs e);
protected virtual void OnLocationChanged(EventArgs e);
protected virtual void OnLostFocus(EventArgs e);
protected virtual void OnMouseDown(MouseEventArgs e);
protected virtual void OnMouseEnter(EventArgs eventargs);
protected virtual void OnMouseHover(EventArgs e);
protected virtual void OnMouseLeave(EventArgs eventargs);
protected virtual void OnMouseMove(MouseEventArgs e);
protected virtual void OnMouseUp(MouseEventArgs e);
protected virtual void OnMouseWheel(MouseEventArgs e);
protected virtual void OnMove(EventArgs e);
protected virtual void OnNotifyMessage(Message m);
protected virtual void OnPaint(PaintEventArgs e);
protected virtual void OnPaintBackground(PaintEventArgs e);
protected virtual void OnParentBackColorChanged(EventArgs e);
protected virtual void OnParentBackgroundImageChanged(EventArgs e);
protected virtual void OnParentBindingContextChanged(EventArgs e);
protected virtual void OnParentChanged(EventArgs e);
protected virtual void OnParentEnabledChanged(EventArgs e);
protected virtual void OnParentFontChanged(EventArgs e);
protected virtual void OnParentForeColorChanged(EventArgs e);
protected virtual void OnParentRightToLeftChanged(EventArgs e);
protected virtual void OnParentVisibleChanged(EventArgs e);
protected virtual void OnQueryContinueDrag(QueryContinueDragEventArgs qcdevent);
protected virtual void OnResize(EventArgs e);
protected virtual void OnRightToLeftChanged(EventArgs e);
protected virtual void OnSizeChanged(EventArgs e);
protected virtual void OnStyleChanged(EventArgs e);
protected virtual void OnSystemColorsChanged(EventArgs e);
protected virtual void OnTabIndexChanged(EventArgs e);
protected virtual void OnTabStopChanged(EventArgs e);
protected virtual void OnTextChanged(EventArgs e);
protected virtual void OnValidated(EventArgs e);
protected virtual void OnValidating(CancelEventArgs e);
protected virtual void OnVisibleChanged(EventArgs e);
public void PerformLayout();
public void PerformLayout(Control affectedControl, string affectedProperty);
public Point PointToClient(Point p);
public Point PointToScreen(Point p);
public bool PreProcessMessage(ref Message msg);
protected virtual bool ProcessCmdKey(ref Message msg, Keys keyData);
protected virtual bool ProcessDialogChar(char charCode);
protected virtual bool ProcessDialogKey(Keys keyData);
protected virtual bool ProcessKeyEventArgs(ref Message m);
protected virtual bool ProcessKeyPreview(ref Message m);
protected virtual bool ProcessMnemonic(char charCode);
protected void RaiseDragEvent(object key, DragEventArgs e);
protected void RaiseKeyEvent(object key, KeyEventArgs e);
protected void RaiseMouseEvent(object key, MouseEventArgs e);
protected void RaisePaintEvent(object key, PaintEventArgs e);
protected void RecreateHandle();
public Rectangle RectangleToClient(Rectangle r);
public Rectangle RectangleToScreen(Rectangle r);
public virtual void Refresh();
public void remove_AppearanceChanged(EventHandler value);
public void remove_BackColorChanged(EventHandler value);
public void remove_BackgroundImageChanged(EventHandler value);
public void remove_BindingContextChanged(EventHandler value);
public void remove_CausesValidationChanged(EventHandler value);
public void remove_ChangeUICues(UICuesEventHandler value);
public void remove_CheckedChanged(EventHandler value);
public void remove_CheckStateChanged(EventHandler value);
public void remove_Click(EventHandler value);
public void remove_ContextMenuChanged(EventHandler value);
public void remove_ControlAdded(ControlEventHandler value);
public void remove_ControlRemoved(ControlEventHandler value);
public void remove_CursorChanged(EventHandler value);
public void remove_Disposed(EventHandler value);
public void remove_DockChanged(EventHandler value);
public void remove_DoubleClick(EventHandler value);
public void remove_DragDrop(DragEventHandler value);
public void remove_DragEnter(DragEventHandler value);
public void remove_DragLeave(EventHandler value);
public void remove_DragOver(DragEventHandler value);
public void remove_EnabledChanged(EventHandler value);
public void remove_Enter(EventHandler value);
public void remove_FontChanged(EventHandler value);
public void remove_ForeColorChanged(EventHandler value);
public void remove_GiveFeedback(GiveFeedbackEventHandler value);
public void remove_GotFocus(EventHandler value);
public void remove_HandleCreated(EventHandler value);
public void remove_HandleDestroyed(EventHandler value);
public void remove_HelpRequested(HelpEventHandler value);
public void remove_ImeModeChanged(EventHandler value);
public void remove_Invalidated(InvalidateEventHandler value);
public void remove_KeyDown(KeyEventHandler value);
public void remove_KeyPress(KeyPressEventHandler value);
public void remove_KeyUp(KeyEventHandler value);
public void remove_Layout(LayoutEventHandler value);
public void remove_Leave(EventHandler value);
public void remove_LocationChanged(EventHandler value);
public void remove_LostFocus(EventHandler value);
public void remove_MouseDown(MouseEventHandler value);
public void remove_MouseEnter(EventHandler value);
public void remove_MouseHover(EventHandler value);
public void remove_MouseLeave(EventHandler value);
public void remove_MouseMove(MouseEventHandler value);
public void remove_MouseUp(MouseEventHandler value);
public void remove_MouseWheel(MouseEventHandler value);
public void remove_Move(EventHandler value);
public void remove_Paint(PaintEventHandler value);
public void remove_ParentChanged(EventHandler value);
public void remove_QueryAccessibilityHelp(QueryAccessibilityHelpEventHandler value);
public void remove_QueryContinueDrag(QueryContinueDragEventHandler value);
public void remove_Resize(EventHandler value);
public void remove_RightToLeftChanged(EventHandler value);
public void remove_SizeChanged(EventHandler value);
public void remove_StyleChanged(EventHandler value);
public void remove_SystemColorsChanged(EventHandler value);
public void remove_TabIndexChanged(EventHandler value);
public void remove_TabStopChanged(EventHandler value);
public void remove_TextChanged(EventHandler value);
public void remove_Validated(EventHandler value);
public void remove_Validating(CancelEventHandler value);
public void remove_VisibleChanged(EventHandler value);
public void ResetBackColor();
public void ResetBindings();
public void ResetCursor();
protected void ResetFlagsandPaint();
public void ResetFont();
public void ResetForeColor();
public void ResetImeMode();
protected void ResetMouseEventArgs();
public void ResetRightToLeft();
public void ResetText();
public void ResumeLayout();
public void ResumeLayout(bool performLayout);
protected ContentAlignment RtlTranslateAlignment(ContentAlignment align);
protected HorizontalAlignment RtlTranslateAlignment(HorizontalAlignment align);
protected LeftRightAlignment RtlTranslateAlignment(LeftRightAlignment align);
protected ContentAlignment RtlTranslateContent(ContentAlignment align);
protected HorizontalAlignment RtlTranslateHorizontal(HorizontalAlignment align);
protected LeftRightAlignment RtlTranslateLeftRight(LeftRightAlignment align);
public void Scale(float ratio);
public void Scale(float dx, float dy);
protected virtual void ScaleCore(float dx, float dy);
public void Select();
protected virtual void Select(bool directed, bool forward);
public bool SelectNextControl(Control ctl, bool forward, bool tabStopOnly, bool nested, bool wrap);
public void SendToBack();
public void SetBounds(int x, int y, int width, int height);
public void SetBounds(int x, int y, int width, int height, BoundsSpecified specified);
protected virtual void SetBoundsCore(int x, int y, int width, int height, BoundsSpecified specified);
protected virtual void SetClientSizeCore(int x, int y);
protected void SetStyle(ControlStyles flag, bool value);
protected void SetTopLevel(bool value);
protected virtual void SetVisibleCore(bool value);
public void Show();
public void SuspendLayout();
public virtual string ToString();
public void Update();
protected void UpdateBounds();
protected void UpdateBounds(int x, int y, int width, int height);
protected void UpdateBounds(int x, int y, int width, int height, int clientWidth, int clientHeight);
protected void UpdateStyles();
protected void UpdateZOrder();
protected virtual void WndProc(ref Message m);

Property
public AccessibleObject AccessibilityObject {get;}
public string AccessibleDefaultActionDescription {get; set;}
public string AccessibleDescription {get; set;}
public string AccessibleName {get; set;}
public AccessibleRole AccessibleRole {get; set;}
public bool AllowDrop {get; set;}
public AnchorStyles Anchor {get; set;}
public Appearance Appearance {get; set;}
public bool AutoCheck {get; set;}
public virtual Color BackColor {get; set;}
public Image BackgroundImage {get; set;}
public virtual BindingContext BindingContext {get; set;}
public int Bottom {get;}
public Rectangle Bounds {get; set;}
public bool CanFocus {get;}
public bool CanSelect {get;}
public bool Capture {get; set;}
public bool CausesValidation {get; set;}
public ContentAlignment CheckAlign {get; set;}
public bool Checked {get; set;}
public CheckState CheckState {get; set;}
public Rectangle ClientRectangle {get;}
public Size ClientSize {get; set;}
public string CompanyName {get;}
public IContainer Container {get;}
public bool ContainsFocus {get;}
public ContextMenu ContextMenu {get; set;}
public ControlCollection Controls {get;}
public bool Created {get;}
protected virtual CreateParams CreateParams {get;}
public Cursor Cursor {get; set;}
public ControlBindingsCollection DataBindings {get;}
protected virtual ImeMode DefaultImeMode {get;}
protected virtual Size DefaultSize {get;}
protected bool DesignMode {get;}
public Rectangle DisplayRectangle {get;}
public bool Disposing {get;}
public DockStyle Dock {get; set;}
public bool Enabled {get; set;}
protected EventHandlerList Events {get;}
public FlatStyle FlatStyle {get; set;}
public bool Focused {get;}
public virtual Font Font {get; set;}
protected int FontHeight {get; set;}
public virtual Color ForeColor {get; set;}
public IntPtr Handle {get;}
public bool HasChildren {get;}
public int Height {get; set;}
public Image Image {get; set;}
public ContentAlignment ImageAlign {get; set;}
public int ImageIndex {get; set;}
public ImageList ImageList {get; set;}
public ImeMode ImeMode {get; set;}
public bool InvokeRequired {get;}
public bool IsAccessible {get; set;}
protected bool IsDefault {get; set;}
public bool IsDisposed {get;}
public bool IsHandleCreated {get;}
public int Left {get; set;}
public Point Location {get; set;}
public string Name {get; set;}
public Control Parent {get; set;}
public string ProductName {get;}
public string ProductVersion {get;}
public bool RecreatingHandle {get;}
public Region Region {get; set;}
protected bool RenderRightToLeft {get;}
protected bool ResizeRedraw {get; set;}
public int Right {get;}
public RightToLeft RightToLeft {get; set;}
protected virtual bool ShowFocusCues {get;}
protected bool ShowKeyboardCues {get;}
public ISite Site {get; set;}
public Size Size {get; set;}
public int TabIndex {get; set;}
public bool TabStop {get; set;}
public object Tag {get; set;}
public virtual string Text {get; set;}
public override ContentAlignment TextAlign {get; set;}
public bool ThreeState {get; set;}
public int Top {get; set;}
public Control TopLevelControl {get;}
public bool Visible {get; set;}
public int Width {get; set;}
public IWindowTarget WindowTarget {get; set;}

System.Windows.Forms.Button

Module:System.Windows.Forms.dll

Hierarchy
Object
MarshalByRefObject
Component
Control
ButtonBase
Button

Type declaration

[C#] public class Button : ButtonBase;

Constructor
public Button();

Method
protected void AccessibilityNotifyClients(AccessibleEvents accEvent, int childID);
public void add_BackColorChanged(EventHandler value);
public void add_BackgroundImageChanged(EventHandler value);
public void add_BindingContextChanged(EventHandler value);
public void add_CausesValidationChanged(EventHandler value);
public void add_ChangeUICues(UICuesEventHandler value);
public void add_Click(EventHandler value);
public void add_ContextMenuChanged(EventHandler value);
public void add_ControlAdded(ControlEventHandler value);
public void add_ControlRemoved(ControlEventHandler value);
public void add_CursorChanged(EventHandler value);
public void add_Disposed(EventHandler value);
public void add_DockChanged(EventHandler value);
public void add_DoubleClick(EventHandler value);
public void add_DragDrop(DragEventHandler value);
public void add_DragEnter(DragEventHandler value);
public void add_DragLeave(EventHandler value);
public void add_DragOver(DragEventHandler value);
public void add_EnabledChanged(EventHandler value);
public void add_Enter(EventHandler value);
public void add_FontChanged(EventHandler value);
public void add_ForeColorChanged(EventHandler value);
public void add_GiveFeedback(GiveFeedbackEventHandler value);
public void add_GotFocus(EventHandler value);
public void add_HandleCreated(EventHandler value);
public void add_HandleDestroyed(EventHandler value);
public void add_HelpRequested(HelpEventHandler value);
public void add_ImeModeChanged(EventHandler value);
public void add_Invalidated(InvalidateEventHandler value);
public void add_KeyDown(KeyEventHandler value);
public void add_KeyPress(KeyPressEventHandler value);
public void add_KeyUp(KeyEventHandler value);
public void add_Layout(LayoutEventHandler value);
public void add_Leave(EventHandler value);
public void add_LocationChanged(EventHandler value);
public void add_LostFocus(EventHandler value);
public void add_MouseDown(MouseEventHandler value);
public void add_MouseEnter(EventHandler value);
public void add_MouseHover(EventHandler value);
public void add_MouseLeave(EventHandler value);
public void add_MouseMove(MouseEventHandler value);
public void add_MouseUp(MouseEventHandler value);
public void add_MouseWheel(MouseEventHandler value);
public void add_Move(EventHandler value);
public void add_Paint(PaintEventHandler value);
public void add_ParentChanged(EventHandler value);
public void add_QueryAccessibilityHelp(QueryAccessibilityHelpEventHandler value);
public void add_QueryContinueDrag(QueryContinueDragEventHandler value);
public void add_Resize(EventHandler value);
public void add_RightToLeftChanged(EventHandler value);
public void add_SizeChanged(EventHandler value);
public void add_StyleChanged(EventHandler value);
public void add_SystemColorsChanged(EventHandler value);
public void add_TabIndexChanged(EventHandler value);
public void add_TabStopChanged(EventHandler value);
public void add_TextChanged(EventHandler value);
public void add_Validated(EventHandler value);
public void add_Validating(CancelEventHandler value);
public void add_VisibleChanged(EventHandler value);
public IAsyncResult BeginInvoke(Delegate method);
public IAsyncResult BeginInvoke(Delegate method, object[] args);
public void BringToFront();
public bool Contains(Control ctl);
protected virtual AccessibleObject CreateAccessibilityInstance();
public void CreateControl();
protected virtual ControlCollection CreateControlsInstance();
public Graphics CreateGraphics();
protected virtual void CreateHandle();
public ObjRef CreateObjRef(Type requestedType);
protected virtual void DefWndProc(ref Message m);
protected virtual void DestroyHandle();
public void Dispose();
protected override void Dispose(bool disposing);
public DragDropEffects DoDragDrop(object data, DragDropEffects allowedEffects);
public object EndInvoke(IAsyncResult asyncResult);
public virtual bool Equals(object obj);
protected override void Finalize();
public Form FindForm();
public bool Focus();
public Control GetChildAtPoint(Point pt);
public IContainerControl GetContainerControl();
public virtual int GetHashCode();
public object GetLifetimeService();
public Control GetNextControl(Control ctl, bool forward);
protected virtual object GetService(Type service);
protected bool GetStyle(ControlStyles flag);
protected bool GetTopLevel();
public Type GetType();
public void Hide();
public object InitializeLifetimeService();
protected virtual void InitLayout();
public void Invalidate();
public void Invalidate(bool invalidateChildren);
public void Invalidate(Rectangle rect);
public void Invalidate(Rectangle rc, bool invalidateChildren);
public void Invalidate(Region region);
public void Invalidate(Region region, bool invalidateChildren);
public object Invoke(Delegate method);
public object Invoke(Delegate method, object[] args);
protected void InvokeGotFocus(Control toInvoke, EventArgs e);
protected void InvokeLostFocus(Control toInvoke, EventArgs e);
protected void InvokeOnClick(Control toInvoke, EventArgs e);
protected void InvokePaint(Control c, PaintEventArgs e);
protected void InvokePaintBackground(Control c, PaintEventArgs e);
protected virtual bool IsInputChar(char charCode);
protected virtual bool IsInputKey(Keys keyData);
protected object MemberwiseClone();
public virtual void NotifyDefault(bool value);
protected virtual void NotifyInvalidate(Rectangle invalidatedArea);
protected virtual void OnBackColorChanged(EventArgs e);
protected virtual void OnBackgroundImageChanged(EventArgs e);
protected virtual void OnBindingContextChanged(EventArgs e);
protected virtual void OnCausesValidationChanged(EventArgs e);
protected virtual void OnChangeUICues(UICuesEventArgs e);
protected override void OnClick(EventArgs e);
protected virtual void OnContextMenuChanged(EventArgs e);
protected virtual void OnControlAdded(ControlEventArgs e);
protected virtual void OnControlRemoved(ControlEventArgs e);
protected virtual void OnCreateControl();
protected virtual void OnCursorChanged(EventArgs e);
protected virtual void OnDockChanged(EventArgs e);
protected virtual void OnDoubleClick(EventArgs e);
protected virtual void OnDragDrop(DragEventArgs drgevent);
protected virtual void OnDragEnter(DragEventArgs drgevent);
protected virtual void OnDragLeave(EventArgs e);
protected virtual void OnDragOver(DragEventArgs drgevent);
protected virtual void OnEnabledChanged(EventArgs e);
protected virtual void OnEnter(EventArgs e);
protected virtual void OnFontChanged(EventArgs e);
protected virtual void OnForeColorChanged(EventArgs e);
protected virtual void OnGiveFeedback(GiveFeedbackEventArgs gfbevent);
protected virtual void OnGotFocus(EventArgs e);
protected virtual void OnHandleCreated(EventArgs e);
protected virtual void OnHandleDestroyed(EventArgs e);
protected virtual void OnHelpRequested(HelpEventArgs hevent);
protected virtual void OnImeModeChanged(EventArgs e);
protected virtual void OnInvalidated(InvalidateEventArgs e);
protected virtual void OnKeyDown(KeyEventArgs e);
protected virtual void OnKeyPress(KeyPressEventArgs e);
protected virtual void OnKeyUp(KeyEventArgs e);
protected virtual void OnLayout(LayoutEventArgs levent);
protected virtual void OnLeave(EventArgs e);
protected virtual void OnLocationChanged(EventArgs e);
protected virtual void OnLostFocus(EventArgs e);
protected virtual void OnMouseDown(MouseEventArgs e);
protected virtual void OnMouseEnter(EventArgs eventargs);
protected virtual void OnMouseHover(EventArgs e);
protected virtual void OnMouseLeave(EventArgs eventargs);
protected virtual void OnMouseMove(MouseEventArgs e);
protected virtual void OnMouseUp(MouseEventArgs e);
protected virtual void OnMouseWheel(MouseEventArgs e);
protected virtual void OnMove(EventArgs e);
protected virtual void OnNotifyMessage(Message m);
protected virtual void OnPaint(PaintEventArgs e);
protected virtual void OnPaintBackground(PaintEventArgs e);
protected virtual void OnParentBackColorChanged(EventArgs e);
protected virtual void OnParentBackgroundImageChanged(EventArgs e);
protected virtual void OnParentBindingContextChanged(EventArgs e);
protected virtual void OnParentChanged(EventArgs e);
protected virtual void OnParentEnabledChanged(EventArgs e);
protected virtual void OnParentFontChanged(EventArgs e);
protected virtual void OnParentForeColorChanged(EventArgs e);
protected virtual void OnParentRightToLeftChanged(EventArgs e);
protected virtual void OnParentVisibleChanged(EventArgs e);
protected virtual void OnQueryContinueDrag(QueryContinueDragEventArgs qcdevent);
protected virtual void OnResize(EventArgs e);
protected virtual void OnRightToLeftChanged(EventArgs e);
protected virtual void OnSizeChanged(EventArgs e);
protected virtual void OnStyleChanged(EventArgs e);
protected virtual void OnSystemColorsChanged(EventArgs e);
protected virtual void OnTabIndexChanged(EventArgs e);
protected virtual void OnTabStopChanged(EventArgs e);
protected virtual void OnTextChanged(EventArgs e);
protected virtual void OnValidated(EventArgs e);
protected virtual void OnValidating(CancelEventArgs e);
protected virtual void OnVisibleChanged(EventArgs e);
public virtual void PerformClick();
public void PerformLayout();
public void PerformLayout(Control affectedControl, string affectedProperty);
public Point PointToClient(Point p);
public Point PointToScreen(Point p);
public bool PreProcessMessage(ref Message msg);
protected virtual bool ProcessCmdKey(ref Message msg, Keys keyData);
protected virtual bool ProcessDialogChar(char charCode);
protected virtual bool ProcessDialogKey(Keys keyData);
protected virtual bool ProcessKeyEventArgs(ref Message m);
protected virtual bool ProcessKeyPreview(ref Message m);
protected virtual bool ProcessMnemonic(char charCode);
protected void RaiseDragEvent(object key, DragEventArgs e);
protected void RaiseKeyEvent(object key, KeyEventArgs e);
protected void RaiseMouseEvent(object key, MouseEventArgs e);
protected void RaisePaintEvent(object key, PaintEventArgs e);
protected void RecreateHandle();
public Rectangle RectangleToClient(Rectangle r);
public Rectangle RectangleToScreen(Rectangle r);
public virtual void Refresh();
public void remove_BackColorChanged(EventHandler value);
public void remove_BackgroundImageChanged(EventHandler value);
public void remove_BindingContextChanged(EventHandler value);
public void remove_CausesValidationChanged(EventHandler value);
public void remove_ChangeUICues(UICuesEventHandler value);
public void remove_Click(EventHandler value);
public void remove_ContextMenuChanged(EventHandler value);
public void remove_ControlAdded(ControlEventHandler value);
public void remove_ControlRemoved(ControlEventHandler value);
public void remove_CursorChanged(EventHandler value);
public void remove_Disposed(EventHandler value);
public void remove_DockChanged(EventHandler value);
public void remove_DoubleClick(EventHandler value);
public void remove_DragDrop(DragEventHandler value);
public void remove_DragEnter(DragEventHandler value);
public void remove_DragLeave(EventHandler value);
public void remove_DragOver(DragEventHandler value);
public void remove_EnabledChanged(EventHandler value);
public void remove_Enter(EventHandler value);
public void remove_FontChanged(EventHandler value);
public void remove_ForeColorChanged(EventHandler value);
public void remove_GiveFeedback(GiveFeedbackEventHandler value);
public void remove_GotFocus(EventHandler value);
public void remove_HandleCreated(EventHandler value);
public void remove_HandleDestroyed(EventHandler value);
public void remove_HelpRequested(HelpEventHandler value);
public void remove_ImeModeChanged(EventHandler value);
public void remove_Invalidated(InvalidateEventHandler value);
public void remove_KeyDown(KeyEventHandler value);
public void remove_KeyPress(KeyPressEventHandler value);
public void remove_KeyUp(KeyEventHandler value);
public void remove_Layout(LayoutEventHandler value);
public void remove_Leave(EventHandler value);
public void remove_LocationChanged(EventHandler value);
public void remove_LostFocus(EventHandler value);
public void remove_MouseDown(MouseEventHandler value);
public void remove_MouseEnter(EventHandler value);
public void remove_MouseHover(EventHandler value);
public void remove_MouseLeave(EventHandler value);
public void remove_MouseMove(MouseEventHandler value);
public void remove_MouseUp(MouseEventHandler value);
public void remove_MouseWheel(MouseEventHandler value);
public void remove_Move(EventHandler value);
public void remove_Paint(PaintEventHandler value);
public void remove_ParentChanged(EventHandler value);
public void remove_QueryAccessibilityHelp(QueryAccessibilityHelpEventHandler value);
public void remove_QueryContinueDrag(QueryContinueDragEventHandler value);
public void remove_Resize(EventHandler value);
public void remove_RightToLeftChanged(EventHandler value);
public void remove_SizeChanged(EventHandler value);
public void remove_StyleChanged(EventHandler value);
public void remove_SystemColorsChanged(EventHandler value);
public void remove_TabIndexChanged(EventHandler value);
public void remove_TabStopChanged(EventHandler value);
public void remove_TextChanged(EventHandler value);
public void remove_Validated(EventHandler value);
public void remove_Validating(CancelEventHandler value);
public void remove_VisibleChanged(EventHandler value);
public void ResetBackColor();
public void ResetBindings();
public void ResetCursor();
protected void ResetFlagsandPaint();
public void ResetFont();
public void ResetForeColor();
public void ResetImeMode();
protected void ResetMouseEventArgs();
public void ResetRightToLeft();
public void ResetText();
public void ResumeLayout();
public void ResumeLayout(bool performLayout);
protected ContentAlignment RtlTranslateAlignment(ContentAlignment align);
protected HorizontalAlignment RtlTranslateAlignment(HorizontalAlignment align);
protected LeftRightAlignment RtlTranslateAlignment(LeftRightAlignment align);
protected ContentAlignment RtlTranslateContent(ContentAlignment align);
protected HorizontalAlignment RtlTranslateHorizontal(HorizontalAlignment align);
protected LeftRightAlignment RtlTranslateLeftRight(LeftRightAlignment align);
public void Scale(float ratio);
public void Scale(float dx, float dy);
protected virtual void ScaleCore(float dx, float dy);
public void Select();
protected virtual void Select(bool directed, bool forward);
public bool SelectNextControl(Control ctl, bool forward, bool tabStopOnly, bool nested, bool wrap);
public void SendToBack();
public void SetBounds(int x, int y, int width, int height);
public void SetBounds(int x, int y, int width, int height, BoundsSpecified specified);
protected virtual void SetBoundsCore(int x, int y, int width, int height, BoundsSpecified specified);
protected virtual void SetClientSizeCore(int x, int y);
protected void SetStyle(ControlStyles flag, bool value);
protected void SetTopLevel(bool value);
protected virtual void SetVisibleCore(bool value);
public void Show();
public void SuspendLayout();
public virtual string ToString();
public void Update();
protected void UpdateBounds();
protected void UpdateBounds(int x, int y, int width, int height);
protected void UpdateBounds(int x, int y, int width, int height, int clientWidth, int clientHeight);
protected void UpdateStyles();
protected void UpdateZOrder();
protected virtual void WndProc(ref Message m);

Property
public AccessibleObject AccessibilityObject {get;}
public string AccessibleDefaultActionDescription {get; set;}
public string AccessibleDescription {get; set;}
public string AccessibleName {get; set;}
public AccessibleRole AccessibleRole {get; set;}
public bool AllowDrop {get; set;}
public AnchorStyles Anchor {get; set;}
public virtual Color BackColor {get; set;}
public Image BackgroundImage {get; set;}
public virtual BindingContext BindingContext {get; set;}
public int Bottom {get;}
public Rectangle Bounds {get; set;}
public bool CanFocus {get;}
public bool CanSelect {get;}
public bool Capture {get; set;}
public bool CausesValidation {get; set;}
public Rectangle ClientRectangle {get;}
public Size ClientSize {get; set;}
public string CompanyName {get;}
public IContainer Container {get;}
public bool ContainsFocus {get;}
public ContextMenu ContextMenu {get; set;}
public ControlCollection Controls {get;}
public bool Created {get;}
protected virtual CreateParams CreateParams {get;}
public Cursor Cursor {get; set;}
public ControlBindingsCollection DataBindings {get;}
protected virtual ImeMode DefaultImeMode {get;}
protected virtual Size DefaultSize {get;}
protected bool DesignMode {get;}
public virtual DialogResult DialogResult {get; set;}
public Rectangle DisplayRectangle {get;}
public bool Disposing {get;}
public DockStyle Dock {get; set;}
public bool Enabled {get; set;}
protected EventHandlerList Events {get;}
public FlatStyle FlatStyle {get; set;}
public bool Focused {get;}
public virtual Font Font {get; set;}
protected int FontHeight {get; set;}
public virtual Color ForeColor {get; set;}
public IntPtr Handle {get;}
public bool HasChildren {get;}
public int Height {get; set;}
public Image Image {get; set;}
public ContentAlignment ImageAlign {get; set;}
public int ImageIndex {get; set;}
public ImageList ImageList {get; set;}
public ImeMode ImeMode {get; set;}
public bool InvokeRequired {get;}
public bool IsAccessible {get; set;}
protected bool IsDefault {get; set;}
public bool IsDisposed {get;}
public bool IsHandleCreated {get;}
public int Left {get; set;}
public Point Location {get; set;}
public string Name {get; set;}
public Control Parent {get; set;}
public string ProductName {get;}
public string ProductVersion {get;}
public bool RecreatingHandle {get;}
public Region Region {get; set;}
protected bool RenderRightToLeft {get;}
protected bool ResizeRedraw {get; set;}
public int Right {get;}
public RightToLeft RightToLeft {get; set;}
protected virtual bool ShowFocusCues {get;}
protected bool ShowKeyboardCues {get;}
public ISite Site {get; set;}
public Size Size {get; set;}
public int TabIndex {get; set;}
public bool TabStop {get; set;}
public object Tag {get; set;}
public virtual string Text {get; set;}
public ContentAlignment TextAlign {get; set;}
public int Top {get; set;}
public Control TopLevelControl {get;}
public bool Visible {get; set;}
public int Width {get; set;}
public IWindowTarget WindowTarget {get; set;}

System.Windows.Forms.ButtonBase

Module:System.Windows.Forms.dll

Hierarchy
Object
MarshalByRefObject
Component
Control
ButtonBase

Type declaration

[C#] public abstract class ButtonBase : Control;

Constructor
protected ButtonBase();

Method
protected void AccessibilityNotifyClients(AccessibleEvents accEvent, int childID);
public void add_BackColorChanged(EventHandler value);
public void add_BackgroundImageChanged(EventHandler value);
public void add_BindingContextChanged(EventHandler value);
public void add_CausesValidationChanged(EventHandler value);
public void add_ChangeUICues(UICuesEventHandler value);
public void add_Click(EventHandler value);
public void add_ContextMenuChanged(EventHandler value);
public void add_ControlAdded(ControlEventHandler value);
public void add_ControlRemoved(ControlEventHandler value);
public void add_CursorChanged(EventHandler value);
public void add_Disposed(EventHandler value);
public void add_DockChanged(EventHandler value);
public void add_DoubleClick(EventHandler value);
public void add_DragDrop(DragEventHandler value);
public void add_DragEnter(DragEventHandler value);
public void add_DragLeave(EventHandler value);
public void add_DragOver(DragEventHandler value);
public void add_EnabledChanged(EventHandler value);
public void add_Enter(EventHandler value);
public void add_FontChanged(EventHandler value);
public void add_ForeColorChanged(EventHandler value);
public void add_GiveFeedback(GiveFeedbackEventHandler value);
public void add_GotFocus(EventHandler value);
public void add_HandleCreated(EventHandler value);
public void add_HandleDestroyed(EventHandler value);
public void add_HelpRequested(HelpEventHandler value);
public void add_ImeModeChanged(EventHandler value);
public void add_Invalidated(InvalidateEventHandler value);
public void add_KeyDown(KeyEventHandler value);
public void add_KeyPress(KeyPressEventHandler value);
public void add_KeyUp(KeyEventHandler value);
public void add_Layout(LayoutEventHandler value);
public void add_Leave(EventHandler value);
public void add_LocationChanged(EventHandler value);
public void add_LostFocus(EventHandler value);
public void add_MouseDown(MouseEventHandler value);
public void add_MouseEnter(EventHandler value);
public void add_MouseHover(EventHandler value);
public void add_MouseLeave(EventHandler value);
public void add_MouseMove(MouseEventHandler value);
public void add_MouseUp(MouseEventHandler value);
public void add_MouseWheel(MouseEventHandler value);
public void add_Move(EventHandler value);
public void add_Paint(PaintEventHandler value);
public void add_ParentChanged(EventHandler value);
public void add_QueryAccessibilityHelp(QueryAccessibilityHelpEventHandler value);
public void add_QueryContinueDrag(QueryContinueDragEventHandler value);
public void add_Resize(EventHandler value);
public void add_RightToLeftChanged(EventHandler value);
public void add_SizeChanged(EventHandler value);
public void add_StyleChanged(EventHandler value);
public void add_SystemColorsChanged(EventHandler value);
public void add_TabIndexChanged(EventHandler value);
public void add_TabStopChanged(EventHandler value);
public void add_TextChanged(EventHandler value);
public void add_Validated(EventHandler value);
public void add_Validating(CancelEventHandler value);
public void add_VisibleChanged(EventHandler value);
public IAsyncResult BeginInvoke(Delegate method);
public IAsyncResult BeginInvoke(Delegate method, object[] args);
public void BringToFront();
public bool Contains(Control ctl);
protected virtual AccessibleObject CreateAccessibilityInstance();
public void CreateControl();
protected virtual ControlCollection CreateControlsInstance();
public Graphics CreateGraphics();
protected virtual void CreateHandle();
public ObjRef CreateObjRef(Type requestedType);
protected virtual void DefWndProc(ref Message m);
protected virtual void DestroyHandle();
public void Dispose();
protected override void Dispose(bool disposing);
public DragDropEffects DoDragDrop(object data, DragDropEffects allowedEffects);
public object EndInvoke(IAsyncResult asyncResult);
public virtual bool Equals(object obj);
protected override void Finalize();
public Form FindForm();
public bool Focus();
public Control GetChildAtPoint(Point pt);
public IContainerControl GetContainerControl();
public virtual int GetHashCode();
public object GetLifetimeService();
public Control GetNextControl(Control ctl, bool forward);
protected virtual object GetService(Type service);
protected bool GetStyle(ControlStyles flag);
protected bool GetTopLevel();
public Type GetType();
public void Hide();
public object InitializeLifetimeService();
protected virtual void InitLayout();
public void Invalidate();
public void Invalidate(bool invalidateChildren);
public void Invalidate(Rectangle rect);
public void Invalidate(Rectangle rc, bool invalidateChildren);
public void Invalidate(Region region);
public void Invalidate(Region region, bool invalidateChildren);
public object Invoke(Delegate method);
public object Invoke(Delegate method, object[] args);
protected void InvokeGotFocus(Control toInvoke, EventArgs e);
protected void InvokeLostFocus(Control toInvoke, EventArgs e);
protected void InvokeOnClick(Control toInvoke, EventArgs e);
protected void InvokePaint(Control c, PaintEventArgs e);
protected void InvokePaintBackground(Control c, PaintEventArgs e);
protected virtual bool IsInputChar(char charCode);
protected virtual bool IsInputKey(Keys keyData);
protected object MemberwiseClone();
protected virtual void NotifyInvalidate(Rectangle invalidatedArea);
protected virtual void OnBackColorChanged(EventArgs e);
protected virtual void OnBackgroundImageChanged(EventArgs e);
protected virtual void OnBindingContextChanged(EventArgs e);
protected virtual void OnCausesValidationChanged(EventArgs e);
protected virtual void OnChangeUICues(UICuesEventArgs e);
protected virtual void OnClick(EventArgs e);
protected virtual void OnContextMenuChanged(EventArgs e);
protected virtual void OnControlAdded(ControlEventArgs e);
protected virtual void OnControlRemoved(ControlEventArgs e);
protected virtual void OnCreateControl();
protected virtual void OnCursorChanged(EventArgs e);
protected virtual void OnDockChanged(EventArgs e);
protected virtual void OnDoubleClick(EventArgs e);
protected virtual void OnDragDrop(DragEventArgs drgevent);
protected virtual void OnDragEnter(DragEventArgs drgevent);
protected virtual void OnDragLeave(EventArgs e);
protected virtual void OnDragOver(DragEventArgs drgevent);
protected virtual void OnEnabledChanged(EventArgs e);
protected virtual void OnEnter(EventArgs e);
protected virtual void OnFontChanged(EventArgs e);
protected virtual void OnForeColorChanged(EventArgs e);
protected virtual void OnGiveFeedback(GiveFeedbackEventArgs gfbevent);
protected virtual void OnGotFocus(EventArgs e);
protected virtual void OnHandleCreated(EventArgs e);
protected virtual void OnHandleDestroyed(EventArgs e);
protected virtual void OnHelpRequested(HelpEventArgs hevent);
protected virtual void OnImeModeChanged(EventArgs e);
protected virtual void OnInvalidated(InvalidateEventArgs e);
protected virtual void OnKeyDown(KeyEventArgs e);
protected virtual void OnKeyPress(KeyPressEventArgs e);
protected virtual void OnKeyUp(KeyEventArgs e);
protected virtual void OnLayout(LayoutEventArgs levent);
protected virtual void OnLeave(EventArgs e);
protected virtual void OnLocationChanged(EventArgs e);
protected virtual void OnLostFocus(EventArgs e);
protected virtual void OnMouseDown(MouseEventArgs e);
protected virtual void OnMouseEnter(EventArgs eventargs);
protected virtual void OnMouseHover(EventArgs e);
protected virtual void OnMouseLeave(EventArgs eventargs);
protected virtual void OnMouseMove(MouseEventArgs e);
protected virtual void OnMouseUp(MouseEventArgs e);
protected virtual void OnMouseWheel(MouseEventArgs e);
protected virtual void OnMove(EventArgs e);
protected virtual void OnNotifyMessage(Message m);
protected virtual void OnPaint(PaintEventArgs e);
protected virtual void OnPaintBackground(PaintEventArgs e);
protected virtual void OnParentBackColorChanged(EventArgs e);
protected virtual void OnParentBackgroundImageChanged(EventArgs e);
protected virtual void OnParentBindingContextChanged(EventArgs e);
protected virtual void OnParentChanged(EventArgs e);
protected virtual void OnParentEnabledChanged(EventArgs e);
protected virtual void OnParentFontChanged(EventArgs e);
protected virtual void OnParentForeColorChanged(EventArgs e);
protected virtual void OnParentRightToLeftChanged(EventArgs e);
protected virtual void OnParentVisibleChanged(EventArgs e);
protected virtual void OnQueryContinueDrag(QueryContinueDragEventArgs qcdevent);
protected virtual void OnResize(EventArgs e);
protected virtual void OnRightToLeftChanged(EventArgs e);
protected virtual void OnSizeChanged(EventArgs e);
protected virtual void OnStyleChanged(EventArgs e);
protected virtual void OnSystemColorsChanged(EventArgs e);
protected virtual void OnTabIndexChanged(EventArgs e);
protected virtual void OnTabStopChanged(EventArgs e);
protected virtual void OnTextChanged(EventArgs e);
protected virtual void OnValidated(EventArgs e);
protected virtual void OnValidating(CancelEventArgs e);
protected virtual void OnVisibleChanged(EventArgs e);
public void PerformLayout();
public void PerformLayout(Control affectedControl, string affectedProperty);
public Point PointToClient(Point p);
public Point PointToScreen(Point p);
public bool PreProcessMessage(ref Message msg);
protected virtual bool ProcessCmdKey(ref Message msg, Keys keyData);
protected virtual bool ProcessDialogChar(char charCode);
protected virtual bool ProcessDialogKey(Keys keyData);
protected virtual bool ProcessKeyEventArgs(ref Message m);
protected virtual bool ProcessKeyPreview(ref Message m);
protected virtual bool ProcessMnemonic(char charCode);
protected void RaiseDragEvent(object key, DragEventArgs e);
protected void RaiseKeyEvent(object key, KeyEventArgs e);
protected void RaiseMouseEvent(object key, MouseEventArgs e);
protected void RaisePaintEvent(object key, PaintEventArgs e);
protected void RecreateHandle();
public Rectangle RectangleToClient(Rectangle r);
public Rectangle RectangleToScreen(Rectangle r);
public virtual void Refresh();
public void remove_BackColorChanged(EventHandler value);
public void remove_BackgroundImageChanged(EventHandler value);
public void remove_BindingContextChanged(EventHandler value);
public void remove_CausesValidationChanged(EventHandler value);
public void remove_ChangeUICues(UICuesEventHandler value);
public void remove_Click(EventHandler value);
public void remove_ContextMenuChanged(EventHandler value);
public void remove_ControlAdded(ControlEventHandler value);
public void remove_ControlRemoved(ControlEventHandler value);
public void remove_CursorChanged(EventHandler value);
public void remove_Disposed(EventHandler value);
public void remove_DockChanged(EventHandler value);
public void remove_DoubleClick(EventHandler value);
public void remove_DragDrop(DragEventHandler value);
public void remove_DragEnter(DragEventHandler value);
public void remove_DragLeave(EventHandler value);
public void remove_DragOver(DragEventHandler value);
public void remove_EnabledChanged(EventHandler value);
public void remove_Enter(EventHandler value);
public void remove_FontChanged(EventHandler value);
public void remove_ForeColorChanged(EventHandler value);
public void remove_GiveFeedback(GiveFeedbackEventHandler value);
public void remove_GotFocus(EventHandler value);
public void remove_HandleCreated(EventHandler value);
public void remove_HandleDestroyed(EventHandler value);
public void remove_HelpRequested(HelpEventHandler value);
public void remove_ImeModeChanged(EventHandler value);
public void remove_Invalidated(InvalidateEventHandler value);
public void remove_KeyDown(KeyEventHandler value);
public void remove_KeyPress(KeyPressEventHandler value);
public void remove_KeyUp(KeyEventHandler value);
public void remove_Layout(LayoutEventHandler value);
public void remove_Leave(EventHandler value);
public void remove_LocationChanged(EventHandler value);
public void remove_LostFocus(EventHandler value);
public void remove_MouseDown(MouseEventHandler value);
public void remove_MouseEnter(EventHandler value);
public void remove_MouseHover(EventHandler value);
public void remove_MouseLeave(EventHandler value);
public void remove_MouseMove(MouseEventHandler value);
public void remove_MouseUp(MouseEventHandler value);
public void remove_MouseWheel(MouseEventHandler value);
public void remove_Move(EventHandler value);
public void remove_Paint(PaintEventHandler value);
public void remove_ParentChanged(EventHandler value);
public void remove_QueryAccessibilityHelp(QueryAccessibilityHelpEventHandler value);
public void remove_QueryContinueDrag(QueryContinueDragEventHandler value);
public void remove_Resize(EventHandler value);
public void remove_RightToLeftChanged(EventHandler value);
public void remove_SizeChanged(EventHandler value);
public void remove_StyleChanged(EventHandler value);
public void remove_SystemColorsChanged(EventHandler value);
public void remove_TabIndexChanged(EventHandler value);
public void remove_TabStopChanged(EventHandler value);
public void remove_TextChanged(EventHandler value);
public void remove_Validated(EventHandler value);
public void remove_Validating(CancelEventHandler value);
public void remove_VisibleChanged(EventHandler value);
public void ResetBackColor();
public void ResetBindings();
public void ResetCursor();
protected void ResetFlagsandPaint();
public void ResetFont();
public void ResetForeColor();
public void ResetImeMode();
protected void ResetMouseEventArgs();
public void ResetRightToLeft();
public void ResetText();
public void ResumeLayout();
public void ResumeLayout(bool performLayout);
protected ContentAlignment RtlTranslateAlignment(ContentAlignment align);
protected HorizontalAlignment RtlTranslateAlignment(HorizontalAlignment align);
protected LeftRightAlignment RtlTranslateAlignment(LeftRightAlignment align);
protected ContentAlignment RtlTranslateContent(ContentAlignment align);
protected HorizontalAlignment RtlTranslateHorizontal(HorizontalAlignment align);
protected LeftRightAlignment RtlTranslateLeftRight(LeftRightAlignment align);
public void Scale(float ratio);
public void Scale(float dx, float dy);
protected virtual void ScaleCore(float dx, float dy);
public void Select();
protected virtual void Select(bool directed, bool forward);
public bool SelectNextControl(Control ctl, bool forward, bool tabStopOnly, bool nested, bool wrap);
public void SendToBack();
public void SetBounds(int x, int y, int width, int height);
public void SetBounds(int x, int y, int width, int height, BoundsSpecified specified);
protected virtual void SetBoundsCore(int x, int y, int width, int height, BoundsSpecified specified);
protected virtual void SetClientSizeCore(int x, int y);
protected void SetStyle(ControlStyles flag, bool value);
protected void SetTopLevel(bool value);
protected virtual void SetVisibleCore(bool value);
public void Show();
public void SuspendLayout();
public virtual string ToString();
public void Update();
protected void UpdateBounds();
protected void UpdateBounds(int x, int y, int width, int height);
protected void UpdateBounds(int x, int y, int width, int height, int clientWidth, int clientHeight);
protected void UpdateStyles();
protected void UpdateZOrder();
protected virtual void WndProc(ref Message m);

Property
public AccessibleObject AccessibilityObject {get;}
public string AccessibleDefaultActionDescription {get; set;}
public string AccessibleDescription {get; set;}
public string AccessibleName {get; set;}
public AccessibleRole AccessibleRole {get; set;}
public bool AllowDrop {get; set;}
public AnchorStyles Anchor {get; set;}
public virtual Color BackColor {get; set;}
public Image BackgroundImage {get; set;}
public virtual BindingContext BindingContext {get; set;}
public int Bottom {get;}
public Rectangle Bounds {get; set;}
public bool CanFocus {get;}
public bool CanSelect {get;}
public bool Capture {get; set;}
public bool CausesValidation {get; set;}
public Rectangle ClientRectangle {get;}
public Size ClientSize {get; set;}
public string CompanyName {get;}
public IContainer Container {get;}
public bool ContainsFocus {get;}
public ContextMenu ContextMenu {get; set;}
public ControlCollection Controls {get;}
public bool Created {get;}
protected virtual CreateParams CreateParams {get;}
public Cursor Cursor {get; set;}
public ControlBindingsCollection DataBindings {get;}
protected virtual ImeMode DefaultImeMode {get;}
protected virtual Size DefaultSize {get;}
protected bool DesignMode {get;}
public Rectangle DisplayRectangle {get;}
public bool Disposing {get;}
public DockStyle Dock {get; set;}
public bool Enabled {get; set;}
protected EventHandlerList Events {get;}
public FlatStyle FlatStyle {get; set;}
public bool Focused {get;}
public virtual Font Font {get; set;}
protected int FontHeight {get; set;}
public virtual Color ForeColor {get; set;}
public IntPtr Handle {get;}
public bool HasChildren {get;}
public int Height {get; set;}
public Image Image {get; set;}
public ContentAlignment ImageAlign {get; set;}
public int ImageIndex {get; set;}
public ImageList ImageList {get; set;}
public ImeMode ImeMode {get; set;}
public bool InvokeRequired {get;}
public bool IsAccessible {get; set;}
protected bool IsDefault {get; set;}
public bool IsDisposed {get;}
public bool IsHandleCreated {get;}
public int Left {get; set;}
public Point Location {get; set;}
public string Name {get; set;}
public Control Parent {get; set;}
public string ProductName {get;}
public string ProductVersion {get;}
public bool RecreatingHandle {get;}
public Region Region {get; set;}
protected bool RenderRightToLeft {get;}
protected bool ResizeRedraw {get; set;}
public int Right {get;}
public RightToLeft RightToLeft {get; set;}
protected virtual bool ShowFocusCues {get;}
protected bool ShowKeyboardCues {get;}
public ISite Site {get; set;}
public Size Size {get; set;}
public int TabIndex {get; set;}
public bool TabStop {get; set;}
public object Tag {get; set;}
public virtual string Text {get; set;}
public virtual ContentAlignment TextAlign {get; set;}
public int Top {get; set;}
public Control TopLevelControl {get;}
public bool Visible {get; set;}
public int Width {get; set;}
public IWindowTarget WindowTarget {get; set;}

System.Windows.Forms.Control+ControlCollection

Module:System.Windows.Forms.dll

Hierarchy
Object
Control+ControlCollection : IList, ICollection, IEnumerable

Type declaration

[C#] public class ControlCollection: IList, ICollection, IEnumerable;

Constructor
public ControlCollection(Control owner);

Method
public virtual void Add(Control value);
public virtual void AddRange(Control[] controls);
public virtual void Clear();
public bool Contains(Control control);
public virtual void CopyTo(Array dest, int index);
public virtual bool Equals(object obj);
protected override void Finalize();
public int GetChildIndex(Control child);
public int GetChildIndex(Control child, bool throwException);
public virtual IEnumerator GetEnumerator();
public virtual int GetHashCode();
public Type GetType();
public int IndexOf(Control control);
protected object MemberwiseClone();
public virtual void Remove(Control value);
public virtual void RemoveAt(int index);
public void SetChildIndex(Control child, int newIndex);
public virtual string ToString();

Property
public virtual int Count {get;}
public virtual bool IsReadOnly {get;}
public virtual Control this[int index] {get;}

System.Windows.Forms.Control

Module:System.Windows.Forms.dll

Hierarchy
Object
MarshalByRefObject
Component
Control

Type declaration

[C#] public class Control : Component;

Constructor
public Control();
public Control(Control parent, string text);
public Control(Control parent, string text, int left, int top, int width, int height);
public Control(string text);
public Control(string text, int left, int top, int width, int height);

Method
protected void AccessibilityNotifyClients(AccessibleEvents accEvent, int childID);
public void add_BackColorChanged(EventHandler value);
public void add_BackgroundImageChanged(EventHandler value);
public void add_BindingContextChanged(EventHandler value);
public void add_CausesValidationChanged(EventHandler value);
public void add_ChangeUICues(UICuesEventHandler value);
public void add_Click(EventHandler value);
public void add_ContextMenuChanged(EventHandler value);
public void add_ControlAdded(ControlEventHandler value);
public void add_ControlRemoved(ControlEventHandler value);
public void add_CursorChanged(EventHandler value);
public void add_Disposed(EventHandler value);
public void add_DockChanged(EventHandler value);
public void add_DoubleClick(EventHandler value);
public void add_DragDrop(DragEventHandler value);
public void add_DragEnter(DragEventHandler value);
public void add_DragLeave(EventHandler value);
public void add_DragOver(DragEventHandler value);
public void add_EnabledChanged(EventHandler value);
public void add_Enter(EventHandler value);
public void add_FontChanged(EventHandler value);
public void add_ForeColorChanged(EventHandler value);
public void add_GiveFeedback(GiveFeedbackEventHandler value);
public void add_GotFocus(EventHandler value);
public void add_HandleCreated(EventHandler value);
public void add_HandleDestroyed(EventHandler value);
public void add_HelpRequested(HelpEventHandler value);
public void add_ImeModeChanged(EventHandler value);
public void add_Invalidated(InvalidateEventHandler value);
public void add_KeyDown(KeyEventHandler value);
public void add_KeyPress(KeyPressEventHandler value);
public void add_KeyUp(KeyEventHandler value);
public void add_Layout(LayoutEventHandler value);
public void add_Leave(EventHandler value);
public void add_LocationChanged(EventHandler value);
public void add_LostFocus(EventHandler value);
public void add_MouseDown(MouseEventHandler value);
public void add_MouseEnter(EventHandler value);
public void add_MouseHover(EventHandler value);
public void add_MouseLeave(EventHandler value);
public void add_MouseMove(MouseEventHandler value);
public void add_MouseUp(MouseEventHandler value);
public void add_MouseWheel(MouseEventHandler value);
public void add_Move(EventHandler value);
public void add_Paint(PaintEventHandler value);
public void add_ParentChanged(EventHandler value);
public void add_QueryAccessibilityHelp(QueryAccessibilityHelpEventHandler value);
public void add_QueryContinueDrag(QueryContinueDragEventHandler value);
public void add_Resize(EventHandler value);
public void add_RightToLeftChanged(EventHandler value);
public void add_SizeChanged(EventHandler value);
public void add_StyleChanged(EventHandler value);
public void add_SystemColorsChanged(EventHandler value);
public void add_TabIndexChanged(EventHandler value);
public void add_TabStopChanged(EventHandler value);
public void add_TextChanged(EventHandler value);
public void add_Validated(EventHandler value);
public void add_Validating(CancelEventHandler value);
public void add_VisibleChanged(EventHandler value);
public IAsyncResult BeginInvoke(Delegate method);
public virtual IAsyncResult BeginInvoke(Delegate method, object[] args);
public void BringToFront();
public bool Contains(Control ctl);
protected virtual AccessibleObject CreateAccessibilityInstance();
public void CreateControl();
protected virtual ControlCollection CreateControlsInstance();
public Graphics CreateGraphics();
protected virtual void CreateHandle();
public ObjRef CreateObjRef(Type requestedType);
protected virtual void DefWndProc(ref Message m);
protected virtual void DestroyHandle();
public void Dispose();
protected override void Dispose(bool disposing);
public DragDropEffects DoDragDrop(object data, DragDropEffects allowedEffects);
public virtual object EndInvoke(IAsyncResult asyncResult);
public virtual bool Equals(object obj);
protected override void Finalize();
public Form FindForm();
public bool Focus();
public static Control FromChildHandle(IntPtr handle);
public static Control FromHandle(IntPtr handle);
public Control GetChildAtPoint(Point pt);
public IContainerControl GetContainerControl();
public virtual int GetHashCode();
public object GetLifetimeService();
public Control GetNextControl(Control ctl, bool forward);
protected virtual object GetService(Type service);
protected bool GetStyle(ControlStyles flag);
protected bool GetTopLevel();
public Type GetType();
public void Hide();
public object InitializeLifetimeService();
protected virtual void InitLayout();
public void Invalidate();
public void Invalidate(bool invalidateChildren);
public void Invalidate(Rectangle rect);
public void Invalidate(Rectangle rc, bool invalidateChildren);
public void Invalidate(Region region);
public void Invalidate(Region region, bool invalidateChildren);
public object Invoke(Delegate method);
public virtual object Invoke(Delegate method, object[] args);
protected void InvokeGotFocus(Control toInvoke, EventArgs e);
protected void InvokeLostFocus(Control toInvoke, EventArgs e);
protected void InvokeOnClick(Control toInvoke, EventArgs e);
protected void InvokePaint(Control c, PaintEventArgs e);
protected void InvokePaintBackground(Control c, PaintEventArgs e);
protected virtual bool IsInputChar(char charCode);
protected virtual bool IsInputKey(Keys keyData);
public static bool IsMnemonic(char charCode, string text);
protected object MemberwiseClone();
protected virtual void NotifyInvalidate(Rectangle invalidatedArea);
protected virtual void OnBackColorChanged(EventArgs e);
protected virtual void OnBackgroundImageChanged(EventArgs e);
protected virtual void OnBindingContextChanged(EventArgs e);
protected virtual void OnCausesValidationChanged(EventArgs e);
protected virtual void OnChangeUICues(UICuesEventArgs e);
protected virtual void OnClick(EventArgs e);
protected virtual void OnContextMenuChanged(EventArgs e);
protected virtual void OnControlAdded(ControlEventArgs e);
protected virtual void OnControlRemoved(ControlEventArgs e);
protected virtual void OnCreateControl();
protected virtual void OnCursorChanged(EventArgs e);
protected virtual void OnDockChanged(EventArgs e);
protected virtual void OnDoubleClick(EventArgs e);
protected virtual void OnDragDrop(DragEventArgs drgevent);
protected virtual void OnDragEnter(DragEventArgs drgevent);
protected virtual void OnDragLeave(EventArgs e);
protected virtual void OnDragOver(DragEventArgs drgevent);
protected virtual void OnEnabledChanged(EventArgs e);
protected virtual void OnEnter(EventArgs e);
protected virtual void OnFontChanged(EventArgs e);
protected virtual void OnForeColorChanged(EventArgs e);
protected virtual void OnGiveFeedback(GiveFeedbackEventArgs gfbevent);
protected virtual void OnGotFocus(EventArgs e);
protected virtual void OnHandleCreated(EventArgs e);
protected virtual void OnHandleDestroyed(EventArgs e);
protected virtual void OnHelpRequested(HelpEventArgs hevent);
protected virtual void OnImeModeChanged(EventArgs e);
protected virtual void OnInvalidated(InvalidateEventArgs e);
protected virtual void OnKeyDown(KeyEventArgs e);
protected virtual void OnKeyPress(KeyPressEventArgs e);
protected virtual void OnKeyUp(KeyEventArgs e);
protected virtual void OnLayout(LayoutEventArgs levent);
protected virtual void OnLeave(EventArgs e);
protected virtual void OnLocationChanged(EventArgs e);
protected virtual void OnLostFocus(EventArgs e);
protected virtual void OnMouseDown(MouseEventArgs e);
protected virtual void OnMouseEnter(EventArgs e);
protected virtual void OnMouseHover(EventArgs e);
protected virtual void OnMouseLeave(EventArgs e);
protected virtual void OnMouseMove(MouseEventArgs e);
protected virtual void OnMouseUp(MouseEventArgs e);
protected virtual void OnMouseWheel(MouseEventArgs e);
protected virtual void OnMove(EventArgs e);
protected virtual void OnNotifyMessage(Message m);
protected virtual void OnPaint(PaintEventArgs e);
protected virtual void OnPaintBackground(PaintEventArgs e);
protected virtual void OnParentBackColorChanged(EventArgs e);
protected virtual void OnParentBackgroundImageChanged(EventArgs e);
protected virtual void OnParentBindingContextChanged(EventArgs e);
protected virtual void OnParentChanged(EventArgs e);
protected virtual void OnParentEnabledChanged(EventArgs e);
protected virtual void OnParentFontChanged(EventArgs e);
protected virtual void OnParentForeColorChanged(EventArgs e);
protected virtual void OnParentRightToLeftChanged(EventArgs e);
protected virtual void OnParentVisibleChanged(EventArgs e);
protected virtual void OnQueryContinueDrag(QueryContinueDragEventArgs qcdevent);
protected virtual void OnResize(EventArgs e);
protected virtual void OnRightToLeftChanged(EventArgs e);
protected virtual void OnSizeChanged(EventArgs e);
protected virtual void OnStyleChanged(EventArgs e);
protected virtual void OnSystemColorsChanged(EventArgs e);
protected virtual void OnTabIndexChanged(EventArgs e);
protected virtual void OnTabStopChanged(EventArgs e);
protected virtual void OnTextChanged(EventArgs e);
protected virtual void OnValidated(EventArgs e);
protected virtual void OnValidating(CancelEventArgs e);
protected virtual void OnVisibleChanged(EventArgs e);
public void PerformLayout();
public void PerformLayout(Control affectedControl, string affectedProperty);
public Point PointToClient(Point p);
public Point PointToScreen(Point p);
public virtual bool PreProcessMessage(ref Message msg);
protected virtual bool ProcessCmdKey(ref Message msg, Keys keyData);
protected virtual bool ProcessDialogChar(char charCode);
protected virtual bool ProcessDialogKey(Keys keyData);
protected virtual bool ProcessKeyEventArgs(ref Message m);
protected virtual bool ProcessKeyPreview(ref Message m);
protected virtual bool ProcessMnemonic(char charCode);
protected void RaiseDragEvent(object key, DragEventArgs e);
protected void RaiseKeyEvent(object key, KeyEventArgs e);
protected void RaiseMouseEvent(object key, MouseEventArgs e);
protected void RaisePaintEvent(object key, PaintEventArgs e);
protected void RecreateHandle();
public Rectangle RectangleToClient(Rectangle r);
public Rectangle RectangleToScreen(Rectangle r);
protected static bool ReflectMessage(IntPtr hWnd, ref Message m);
public virtual void Refresh();
public void remove_BackColorChanged(EventHandler value);
public void remove_BackgroundImageChanged(EventHandler value);
public void remove_BindingContextChanged(EventHandler value);
public void remove_CausesValidationChanged(EventHandler value);
public void remove_ChangeUICues(UICuesEventHandler value);
public void remove_Click(EventHandler value);
public void remove_ContextMenuChanged(EventHandler value);
public void remove_ControlAdded(ControlEventHandler value);
public void remove_ControlRemoved(ControlEventHandler value);
public void remove_CursorChanged(EventHandler value);
public void remove_Disposed(EventHandler value);
public void remove_DockChanged(EventHandler value);
public void remove_DoubleClick(EventHandler value);
public void remove_DragDrop(DragEventHandler value);
public void remove_DragEnter(DragEventHandler value);
public void remove_DragLeave(EventHandler value);
public void remove_DragOver(DragEventHandler value);
public void remove_EnabledChanged(EventHandler value);
public void remove_Enter(EventHandler value);
public void remove_FontChanged(EventHandler value);
public void remove_ForeColorChanged(EventHandler value);
public void remove_GiveFeedback(GiveFeedbackEventHandler value);
public void remove_GotFocus(EventHandler value);
public void remove_HandleCreated(EventHandler value);
public void remove_HandleDestroyed(EventHandler value);
public void remove_HelpRequested(HelpEventHandler value);
public void remove_ImeModeChanged(EventHandler value);
public void remove_Invalidated(InvalidateEventHandler value);
public void remove_KeyDown(KeyEventHandler value);
public void remove_KeyPress(KeyPressEventHandler value);
public void remove_KeyUp(KeyEventHandler value);
public void remove_Layout(LayoutEventHandler value);
public void remove_Leave(EventHandler value);
public void remove_LocationChanged(EventHandler value);
public void remove_LostFocus(EventHandler value);
public void remove_MouseDown(MouseEventHandler value);
public void remove_MouseEnter(EventHandler value);
public void remove_MouseHover(EventHandler value);
public void remove_MouseLeave(EventHandler value);
public void remove_MouseMove(MouseEventHandler value);
public void remove_MouseUp(MouseEventHandler value);
public void remove_MouseWheel(MouseEventHandler value);
public void remove_Move(EventHandler value);
public void remove_Paint(PaintEventHandler value);
public void remove_ParentChanged(EventHandler value);
public void remove_QueryAccessibilityHelp(QueryAccessibilityHelpEventHandler value);
public void remove_QueryContinueDrag(QueryContinueDragEventHandler value);
public void remove_Resize(EventHandler value);
public void remove_RightToLeftChanged(EventHandler value);
public void remove_SizeChanged(EventHandler value);
public void remove_StyleChanged(EventHandler value);
public void remove_SystemColorsChanged(EventHandler value);
public void remove_TabIndexChanged(EventHandler value);
public void remove_TabStopChanged(EventHandler value);
public void remove_TextChanged(EventHandler value);
public void remove_Validated(EventHandler value);
public void remove_Validating(CancelEventHandler value);
public void remove_VisibleChanged(EventHandler value);
public virtual void ResetBackColor();
public void ResetBindings();
public virtual void ResetCursor();
public virtual void ResetFont();
public virtual void ResetForeColor();
public void ResetImeMode();
protected void ResetMouseEventArgs();
public virtual void ResetRightToLeft();
public virtual void ResetText();
public void ResumeLayout();
public void ResumeLayout(bool performLayout);
protected ContentAlignment RtlTranslateAlignment(ContentAlignment align);
protected HorizontalAlignment RtlTranslateAlignment(HorizontalAlignment align);
protected LeftRightAlignment RtlTranslateAlignment(LeftRightAlignment align);
protected ContentAlignment RtlTranslateContent(ContentAlignment align);
protected HorizontalAlignment RtlTranslateHorizontal(HorizontalAlignment align);
protected LeftRightAlignment RtlTranslateLeftRight(LeftRightAlignment align);
public void Scale(float ratio);
public void Scale(float dx, float dy);
protected virtual void ScaleCore(float dx, float dy);
public void Select();
protected virtual void Select(bool directed, bool forward);
public bool SelectNextControl(Control ctl, bool forward, bool tabStopOnly, bool nested, bool wrap);
public void SendToBack();
public void SetBounds(int x, int y, int width, int height);
public void SetBounds(int x, int y, int width, int height, BoundsSpecified specified);
protected virtual void SetBoundsCore(int x, int y, int width, int height, BoundsSpecified specified);
protected virtual void SetClientSizeCore(int x, int y);
protected void SetStyle(ControlStyles flag, bool value);
protected void SetTopLevel(bool value);
protected virtual void SetVisibleCore(bool value);
public void Show();
public void SuspendLayout();
public virtual string ToString();
public void Update();
protected void UpdateBounds();
protected void UpdateBounds(int x, int y, int width, int height);
protected void UpdateBounds(int x, int y, int width, int height, int clientWidth, int clientHeight);
protected void UpdateStyles();
protected void UpdateZOrder();
protected virtual void WndProc(ref Message m);

Property
public AccessibleObject AccessibilityObject {get;}
public string AccessibleDefaultActionDescription {get; set;}
public string AccessibleDescription {get; set;}
public string AccessibleName {get; set;}
public AccessibleRole AccessibleRole {get; set;}
public virtual bool AllowDrop {get; set;}
public virtual AnchorStyles Anchor {get; set;}
public virtual Color BackColor {get; set;}
public virtual Image BackgroundImage {get; set;}
public virtual BindingContext BindingContext {get; set;}
public int Bottom {get;}
public Rectangle Bounds {get; set;}
public bool CanFocus {get;}
public bool CanSelect {get;}
public bool Capture {get; set;}
public bool CausesValidation {get; set;}
public Rectangle ClientRectangle {get;}
public Size ClientSize {get; set;}
public string CompanyName {get;}
public IContainer Container {get;}
public bool ContainsFocus {get;}
public ContextMenu ContextMenu {get; set;}
public ControlCollection Controls {get;}
public bool Created {get;}
protected virtual CreateParams CreateParams {get;}
public virtual Cursor Cursor {get; set;}
public ControlBindingsCollection DataBindings {get;}
public static Color DefaultBackColor {get;}
public static Font DefaultFont {get;}
public static Color DefaultForeColor {get;}
protected virtual ImeMode DefaultImeMode {get;}
protected virtual Size DefaultSize {get;}
protected bool DesignMode {get;}
public virtual Rectangle DisplayRectangle {get;}
public bool Disposing {get;}
public virtual DockStyle Dock {get; set;}
public bool Enabled {get; set;}
protected EventHandlerList Events {get;}
public bool Focused {get;}
public virtual Font Font {get; set;}
protected int FontHeight {get; set;}
public virtual Color ForeColor {get; set;}
public virtual IntPtr Handle {get;}
public bool HasChildren {get;}
public int Height {get; set;}
public ImeMode ImeMode {get; set;}
public virtual bool InvokeRequired {get;}
public bool IsAccessible {get; set;}
public bool IsDisposed {get;}
public bool IsHandleCreated {get;}
public int Left {get; set;}
public Point Location {get; set;}
public static Keys ModifierKeys {get;}
public static MouseButtons MouseButtons {get;}
public static Point MousePosition {get;}
public string Name {get; set;}
public Control Parent {get; set;}
public string ProductName {get;}
public string ProductVersion {get;}
public bool RecreatingHandle {get;}
public Region Region {get; set;}
protected bool RenderRightToLeft {get;}
protected bool ResizeRedraw {get; set;}
public int Right {get;}
public virtual RightToLeft RightToLeft {get; set;}
protected virtual bool ShowFocusCues {get;}
protected bool ShowKeyboardCues {get;}
public override ISite Site {get; set;}
public Size Size {get; set;}
public int TabIndex {get; set;}
public bool TabStop {get; set;}
public object Tag {get; set;}
public virtual string Text {get; set;}
public int Top {get; set;}
public Control TopLevelControl {get;}
public bool Visible {get; set;}
public int Width {get; set;}
public IWindowTarget WindowTarget {get; set;}

System.Windows.Forms.BorderStyle

Module:System.Windows.Forms.dll

Hierarchy
Object
ValueType
Enum
BorderStyle

Type declaration

[C#] public enum BorderStyle;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const BorderStyle Fixed3D = 2;
public const BorderStyle FixedSingle = 1;
public const BorderStyle None = 0;
public int value__;

System.Windows.Forms.Application

Module:System.Windows.Forms.dll

Hierarchy
Object
Application

Type declaration

[C#] public sealed class Application;

Method
public static void add_ApplicationExit(EventHandler value);
public static void add_Idle(EventHandler value);
public static void add_ThreadException(ThreadExceptionEventHandler value);
public static void add_ThreadExit(EventHandler value);
public static void AddMessageFilter(IMessageFilter value);
public static void DoEvents();
public static void EnableVisualStyles();
public virtual bool Equals(object obj);
public static void Exit();
public static void ExitThread();
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public static ApartmentState OleRequired();
public static void OnThreadException(Exception t);
public static void remove_ApplicationExit(EventHandler value);
public static void remove_Idle(EventHandler value);
public static void remove_ThreadException(ThreadExceptionEventHandler value);
public static void remove_ThreadExit(EventHandler value);
public static void RemoveMessageFilter(IMessageFilter value);
public static void Run();
public static void Run(ApplicationContext context);
public static void Run(Form fm);
public virtual string ToString();

Property
public static bool AllowQuit {get;}
public static string CommonAppDataPath {get;}
public static RegistryKey CommonAppDataRegistry {get;}
public static string CompanyName {get;}
public static CultureInfo CurrentCulture {get; set;}
public static InputLanguage CurrentInputLanguage {get; set;}
public static string ExecutablePath {get;}
public static string LocalUserAppDataPath {get;}
public static bool MessageLoop {get;}
public static string ProductName {get;}
public static string ProductVersion {get;}
public static string SafeTopLevelCaptionFormat {get; set;}
public static string StartupPath {get;}
public static string UserAppDataPath {get;}
public static RegistryKey UserAppDataRegistry {get;}

System.Xml.XmlWhitespace

Module:System.Xml.dll

Hierarchy
Object
XmlNode
XmlLinkedNode
XmlCharacterData
XmlWhitespace

Type declaration

[C#] public class XmlWhitespace : XmlCharacterData;

Method
public virtual XmlNode AppendChild(XmlNode newChild);
public virtual void AppendData(string strData);
public virtual XmlNode Clone();
public override XmlNode CloneNode(bool deep);
public XPathNavigator CreateNavigator();
public virtual void DeleteData(int offset, int count);
public virtual bool Equals(object obj);
protected override void Finalize();
public IEnumerator GetEnumerator();
public virtual int GetHashCode();
public virtual string GetNamespaceOfPrefix(string prefix);
public virtual string GetPrefixOfNamespace(string namespaceUri);
public Type GetType();
public virtual XmlNode InsertAfter(XmlNode newChild, XmlNode refChild);
public virtual XmlNode InsertBefore(XmlNode newChild, XmlNode refChild);
public virtual void InsertData(int offset, string strData);
protected object MemberwiseClone();
public virtual void Normalize();
public virtual XmlNode PrependChild(XmlNode newChild);
public virtual void RemoveAll();
public virtual XmlNode RemoveChild(XmlNode oldChild);
public virtual XmlNode ReplaceChild(XmlNode newChild, XmlNode oldChild);
public virtual void ReplaceData(int offset, int count, string strData);
public XmlNodeList SelectNodes(string xpath);
public XmlNodeList SelectNodes(string xpath, XmlNamespaceManager nsmgr);
public XmlNode SelectSingleNode(string xpath);
public XmlNode SelectSingleNode(string xpath, XmlNamespaceManager nsmgr);
public virtual string Substring(int offset, int count);
public virtual bool Supports(string feature, string version);
public virtual string ToString();
public override void WriteContentTo(XmlWriter w);
public override void WriteTo(XmlWriter w);

Property
public virtual XmlAttributeCollection Attributes {get;}
public virtual string BaseURI {get;}
public virtual XmlNodeList ChildNodes {get;}
public virtual string Data {get; set;}
public virtual XmlNode FirstChild {get;}
public virtual bool HasChildNodes {get;}
public override string InnerText {get; set;}
public virtual string InnerXml {get; set;}
public virtual bool IsReadOnly {get;}
public virtual XmlElement this[string localname, string ns] {get;}
public virtual XmlElement this[string name] {get;}
public virtual XmlNode LastChild {get;}
public virtual int Length {get;}
public override string LocalName {get;}
public override string Name {get;}
public virtual string NamespaceURI {get;}
public override XmlNode NextSibling {get;}
public override XmlNodeType NodeType {get;}
public virtual string OuterXml {get;}
public virtual XmlDocument OwnerDocument {get;}
public virtual XmlNode ParentNode {get;}
public virtual string Prefix {get; set;}
public override XmlNode PreviousSibling {get;}
public override string Value {get; set;}

System.Xml.XmlText

Module:System.Xml.dll

Hierarchy
Object
XmlNode
XmlLinkedNode
XmlCharacterData
XmlText

Type declaration

[C#] public class XmlText : XmlCharacterData;

Method
public virtual XmlNode AppendChild(XmlNode newChild);
public virtual void AppendData(string strData);
public virtual XmlNode Clone();
public override XmlNode CloneNode(bool deep);
public XPathNavigator CreateNavigator();
public virtual void DeleteData(int offset, int count);
public virtual bool Equals(object obj);
protected override void Finalize();
public IEnumerator GetEnumerator();
public virtual int GetHashCode();
public virtual string GetNamespaceOfPrefix(string prefix);
public virtual string GetPrefixOfNamespace(string namespaceUri);
public Type GetType();
public virtual XmlNode InsertAfter(XmlNode newChild, XmlNode refChild);
public virtual XmlNode InsertBefore(XmlNode newChild, XmlNode refChild);
public virtual void InsertData(int offset, string strData);
protected object MemberwiseClone();
public virtual void Normalize();
public virtual XmlNode PrependChild(XmlNode newChild);
public virtual void RemoveAll();
public virtual XmlNode RemoveChild(XmlNode oldChild);
public virtual XmlNode ReplaceChild(XmlNode newChild, XmlNode oldChild);
public virtual void ReplaceData(int offset, int count, string strData);
public XmlNodeList SelectNodes(string xpath);
public XmlNodeList SelectNodes(string xpath, XmlNamespaceManager nsmgr);
public XmlNode SelectSingleNode(string xpath);
public XmlNode SelectSingleNode(string xpath, XmlNamespaceManager nsmgr);
public virtual XmlText SplitText(int offset);
public virtual string Substring(int offset, int count);
public virtual bool Supports(string feature, string version);
public virtual string ToString();
public override void WriteContentTo(XmlWriter w);
public override void WriteTo(XmlWriter w);

Property
public virtual XmlAttributeCollection Attributes {get;}
public virtual string BaseURI {get;}
public virtual XmlNodeList ChildNodes {get;}
public virtual string Data {get; set;}
public virtual XmlNode FirstChild {get;}
public virtual bool HasChildNodes {get;}
public override string InnerText {get; set;}
public virtual string InnerXml {get; set;}
public virtual bool IsReadOnly {get;}
public virtual XmlElement this[string localname, string ns] {get;}
public virtual XmlElement this[string name] {get;}
public virtual XmlNode LastChild {get;}
public virtual int Length {get;}
public override string LocalName {get;}
public override string Name {get;}
public virtual string NamespaceURI {get;}
public override XmlNode NextSibling {get;}
public override XmlNodeType NodeType {get;}
public virtual string OuterXml {get;}
public virtual XmlDocument OwnerDocument {get;}
public virtual XmlNode ParentNode {get;}
public virtual string Prefix {get; set;}
public override XmlNode PreviousSibling {get;}
public override string Value {get; set;}

System.Xml.XmlSignificantWhitespace

Module:System.Xml.dll

Hierarchy
Object
XmlNode
XmlLinkedNode
XmlCharacterData
XmlSignificantWhitespace

Type declaration

[C#] public class XmlSignificantWhitespace : XmlCharacterData;

Method
public virtual XmlNode AppendChild(XmlNode newChild);
public virtual void AppendData(string strData);
public virtual XmlNode Clone();
public override XmlNode CloneNode(bool deep);
public XPathNavigator CreateNavigator();
public virtual void DeleteData(int offset, int count);
public virtual bool Equals(object obj);
protected override void Finalize();
public IEnumerator GetEnumerator();
public virtual int GetHashCode();
public virtual string GetNamespaceOfPrefix(string prefix);
public virtual string GetPrefixOfNamespace(string namespaceUri);
public Type GetType();
public virtual XmlNode InsertAfter(XmlNode newChild, XmlNode refChild);
public virtual XmlNode InsertBefore(XmlNode newChild, XmlNode refChild);
public virtual void InsertData(int offset, string strData);
protected object MemberwiseClone();
public virtual void Normalize();
public virtual XmlNode PrependChild(XmlNode newChild);
public virtual void RemoveAll();
public virtual XmlNode RemoveChild(XmlNode oldChild);
public virtual XmlNode ReplaceChild(XmlNode newChild, XmlNode oldChild);
public virtual void ReplaceData(int offset, int count, string strData);
public XmlNodeList SelectNodes(string xpath);
public XmlNodeList SelectNodes(string xpath, XmlNamespaceManager nsmgr);
public XmlNode SelectSingleNode(string xpath);
public XmlNode SelectSingleNode(string xpath, XmlNamespaceManager nsmgr);
public virtual string Substring(int offset, int count);
public virtual bool Supports(string feature, string version);
public virtual string ToString();
public override void WriteContentTo(XmlWriter w);
public override void WriteTo(XmlWriter w);

Property
public virtual XmlAttributeCollection Attributes {get;}
public virtual string BaseURI {get;}
public virtual XmlNodeList ChildNodes {get;}
public virtual string Data {get; set;}
public virtual XmlNode FirstChild {get;}
public virtual bool HasChildNodes {get;}
public override string InnerText {get; set;}
public virtual string InnerXml {get; set;}
public virtual bool IsReadOnly {get;}
public virtual XmlElement this[string localname, string ns] {get;}
public virtual XmlElement this[string name] {get;}
public virtual XmlNode LastChild {get;}
public virtual int Length {get;}
public override string LocalName {get;}
public override string Name {get;}
public virtual string NamespaceURI {get;}
public override XmlNode NextSibling {get;}
public override XmlNodeType NodeType {get;}
public virtual string OuterXml {get;}
public virtual XmlDocument OwnerDocument {get;}
public virtual XmlNode ParentNode {get;}
public virtual string Prefix {get; set;}
public override XmlNode PreviousSibling {get;}
public override string Value {get; set;}

System.Xml.XmlProcessingInstruction

Module:System.Xml.dll

Hierarchy
Object
XmlNode
XmlLinkedNode
XmlProcessingInstruction

Type declaration

[C#] public class XmlProcessingInstruction : XmlLinkedNode;

Method
public virtual XmlNode AppendChild(XmlNode newChild);
public virtual XmlNode Clone();
public override XmlNode CloneNode(bool deep);
public XPathNavigator CreateNavigator();
public virtual bool Equals(object obj);
protected override void Finalize();
public IEnumerator GetEnumerator();
public virtual int GetHashCode();
public virtual string GetNamespaceOfPrefix(string prefix);
public virtual string GetPrefixOfNamespace(string namespaceUri);
public Type GetType();
public virtual XmlNode InsertAfter(XmlNode newChild, XmlNode refChild);
public virtual XmlNode InsertBefore(XmlNode newChild, XmlNode refChild);
protected object MemberwiseClone();
public virtual void Normalize();
public virtual XmlNode PrependChild(XmlNode newChild);
public virtual void RemoveAll();
public virtual XmlNode RemoveChild(XmlNode oldChild);
public virtual XmlNode ReplaceChild(XmlNode newChild, XmlNode oldChild);
public XmlNodeList SelectNodes(string xpath);
public XmlNodeList SelectNodes(string xpath, XmlNamespaceManager nsmgr);
public XmlNode SelectSingleNode(string xpath);
public XmlNode SelectSingleNode(string xpath, XmlNamespaceManager nsmgr);
public virtual bool Supports(string feature, string version);
public virtual string ToString();
public override void WriteContentTo(XmlWriter w);
public override void WriteTo(XmlWriter w);

Property
public virtual XmlAttributeCollection Attributes {get;}
public virtual string BaseURI {get;}
public virtual XmlNodeList ChildNodes {get;}
public string Data {get; set;}
public virtual XmlNode FirstChild {get;}
public virtual bool HasChildNodes {get;}
public override string InnerText {get; set;}
public virtual string InnerXml {get; set;}
public virtual bool IsReadOnly {get;}
public virtual XmlElement this[string localname, string ns] {get;}
public virtual XmlElement this[string name] {get;}
public virtual XmlNode LastChild {get;}
public override string LocalName {get;}
public override string Name {get;}
public virtual string NamespaceURI {get;}
public override XmlNode NextSibling {get;}
public override XmlNodeType NodeType {get;}
public virtual string OuterXml {get;}
public virtual XmlDocument OwnerDocument {get;}
public virtual XmlNode ParentNode {get;}
public virtual string Prefix {get; set;}
public override XmlNode PreviousSibling {get;}
public string Target {get;}
public override string Value {get; set;}

System.Xml.XmlNodeReader

Module:System.Xml.dll

Hierarchy
Object
XmlReader
XmlNodeReader

Type declaration

[C#] public class XmlNodeReader : XmlReader;

Constructor
public XmlNodeReader(XmlNode node);

Method
public override void Close();
public virtual bool Equals(object obj);
protected override void Finalize();
public override string GetAttribute(int attributeIndex);
public override string GetAttribute(string name);
public override string GetAttribute(string name, string namespaceUri);
public virtual int GetHashCode();
public Type GetType();
public virtual bool IsStartElement();
public virtual bool IsStartElement(string name);
public virtual bool IsStartElement(string localname, string ns);
public override string LookupNamespace(string prefix);
protected object MemberwiseClone();
public override void MoveToAttribute(int attributeIndex);
public override bool MoveToAttribute(string name);
public override bool MoveToAttribute(string name, string namespaceUri);
public virtual XmlNodeType MoveToContent();
public override bool MoveToElement();
public override bool MoveToFirstAttribute();
public override bool MoveToNextAttribute();
public override bool Read();
public override bool ReadAttributeValue();
public virtual string ReadElementString();
public virtual string ReadElementString(string name);
public virtual string ReadElementString(string localname, string ns);
public virtual void ReadEndElement();
public override string ReadInnerXml();
public override string ReadOuterXml();
public virtual void ReadStartElement();
public virtual void ReadStartElement(string name);
public virtual void ReadStartElement(string localname, string ns);
public override string ReadString();
public override void ResolveEntity();
public override void Skip();
public virtual string ToString();

Property
public override int AttributeCount {get;}
public override string BaseURI {get;}
public virtual bool CanResolveEntity {get;}
public override int Depth {get;}
public override bool EOF {get;}
public override bool HasAttributes {get;}
public override bool HasValue {get;}
public override bool IsDefault {get;}
public override bool IsEmptyElement {get;}
public override string this[int i] {get;}
public override string this[string name, string namespaceUri] {get;}
public override string this[string name] {get;}
public override string LocalName {get;}
public override string Name {get;}
public override string NamespaceURI {get;}
public override XmlNameTable NameTable {get;}
public override XmlNodeType NodeType {get;}
public override string Prefix {get;}
public override char QuoteChar {get;}
public override ReadState ReadState {get;}
public override string Value {get;}
public override string XmlLang {get;}
public override XmlSpace XmlSpace {get;}

System.Xml.XmlNodeReaderNavigator+VirtualAttribute

Module:System.Xml.dll

Hierarchy
Object
ValueType
XmlNodeReaderNavigator+VirtualAttribute

Type declaration

[C#] public struct VirtualAttribute : ValueType;

Constructor
public VirtualAttribute(string name, string value);

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Field
public string name;
public string value;

System.Xml.XmlNodeChangedEventHandler

Module:System.Xml.dll

Hierarchy
Object
Delegate
MulticastDelegate
XmlNodeChangedEventHandler

Type declaration

[C#] public delegate void XmlNodeChangedEventHandler(object sender, XmlNodeChangedEventArgs e);

Constructor
public XmlNodeChangedEventHandler(object object, IntPtr method);

Method
public virtual IAsyncResult BeginInvoke(object sender, XmlNodeChangedEventArgs e, AsyncCallback callback, object object);
public object Clone();
protected override Delegate CombineImpl(Delegate follow);
public object DynamicInvoke(object[] args);
protected virtual object DynamicInvokeImpl(object[] args);
public virtual void EndInvoke(IAsyncResult result);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public override Delegate[] GetInvocationList();
protected virtual MethodInfo GetMethodImpl();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
public override void Invoke(object sender, XmlNodeChangedEventArgs e);
protected object MemberwiseClone();
protected override Delegate RemoveImpl(Delegate value);
public virtual string ToString();

Property
public MethodInfo Method {get;}
public object Target {get;}

System.Xml.XmlNodeChangedEventArgs

Module:System.Xml.dll

Hierarchy
Object
XmlNodeChangedEventArgs

Type declaration

[C#] public class XmlNodeChangedEventArgs;

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public XmlNodeChangedAction Action {get;}
public XmlNode NewParent {get;}
public XmlNode Node {get;}
public XmlNode OldParent {get;}

System.Xml.XmlImplementation

Module:System.Xml.dll

Hierarchy
Object
XmlImplementation

Type declaration

[C#] public class XmlImplementation;

Constructor
public XmlImplementation();

Method
public virtual XmlDocument CreateDocument();
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
public bool HasFeature(string strFeature, string strVersion);
protected object MemberwiseClone();
public virtual string ToString();

System.Xml.XmlNodeChangedAction

Module:System.Xml.dll

Hierarchy
Object
ValueType
Enum
XmlNodeChangedAction

Type declaration

[C#] public enum XmlNodeChangedAction;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const XmlNodeChangedAction Change = 2;
public const XmlNodeChangedAction Insert = 0;
public const XmlNodeChangedAction Remove = 1;
public int value__;

System.Xml.XmlEntityReference

Module:System.Xml.dll

Hierarchy
Object
XmlNode
XmlLinkedNode
XmlEntityReference

Type declaration

[C#] public class XmlEntityReference : XmlLinkedNode;

Method
public virtual XmlNode AppendChild(XmlNode newChild);
public virtual XmlNode Clone();
public override XmlNode CloneNode(bool deep);
public XPathNavigator CreateNavigator();
public virtual bool Equals(object obj);
protected override void Finalize();
public IEnumerator GetEnumerator();
public virtual int GetHashCode();
public virtual string GetNamespaceOfPrefix(string prefix);
public virtual string GetPrefixOfNamespace(string namespaceUri);
public Type GetType();
public virtual XmlNode InsertAfter(XmlNode newChild, XmlNode refChild);
public virtual XmlNode InsertBefore(XmlNode newChild, XmlNode refChild);
protected object MemberwiseClone();
public virtual void Normalize();
public virtual XmlNode PrependChild(XmlNode newChild);
public virtual void RemoveAll();
public virtual XmlNode RemoveChild(XmlNode oldChild);
public virtual XmlNode ReplaceChild(XmlNode newChild, XmlNode oldChild);
public XmlNodeList SelectNodes(string xpath);
public XmlNodeList SelectNodes(string xpath, XmlNamespaceManager nsmgr);
public XmlNode SelectSingleNode(string xpath);
public XmlNode SelectSingleNode(string xpath, XmlNamespaceManager nsmgr);
public virtual bool Supports(string feature, string version);
public virtual string ToString();
public override void WriteContentTo(XmlWriter w);
public override void WriteTo(XmlWriter w);

Property
public virtual XmlAttributeCollection Attributes {get;}
public override string BaseURI {get;}
public virtual XmlNodeList ChildNodes {get;}
public virtual XmlNode FirstChild {get;}
public virtual bool HasChildNodes {get;}
public virtual string InnerText {get; set;}
public virtual string InnerXml {get; set;}
public override bool IsReadOnly {get;}
public virtual XmlElement this[string localname, string ns] {get;}
public virtual XmlElement this[string name] {get;}
public virtual XmlNode LastChild {get;}
public override string LocalName {get;}
public override string Name {get;}
public virtual string NamespaceURI {get;}
public override XmlNode NextSibling {get;}
public override XmlNodeType NodeType {get;}
public virtual string OuterXml {get;}
public virtual XmlDocument OwnerDocument {get;}
public virtual XmlNode ParentNode {get;}
public virtual string Prefix {get; set;}
public override XmlNode PreviousSibling {get;}
public override string Value {get; set;}

System.Xml.XmlElement

Module:System.Xml.dll

Hierarchy
Object
XmlNode
XmlLinkedNode
XmlElement

Type declaration

[C#] public class XmlElement : XmlLinkedNode;

Method
public virtual XmlNode AppendChild(XmlNode newChild);
public virtual XmlNode Clone();
public override XmlNode CloneNode(bool deep);
public XPathNavigator CreateNavigator();
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual string GetAttribute(string name);
public virtual string GetAttribute(string localName, string namespaceUri);
public virtual XmlAttribute GetAttributeNode(string name);
public virtual XmlAttribute GetAttributeNode(string localName, string namespaceUri);
public virtual XmlNodeList GetElementsByTagName(string name);
public virtual XmlNodeList GetElementsByTagName(string localName, string namespaceUri);
public IEnumerator GetEnumerator();
public virtual int GetHashCode();
public virtual string GetNamespaceOfPrefix(string prefix);
public virtual string GetPrefixOfNamespace(string namespaceUri);
public Type GetType();
public virtual bool HasAttribute(string name);
public virtual bool HasAttribute(string localName, string namespaceUri);
public virtual XmlNode InsertAfter(XmlNode newChild, XmlNode refChild);
public virtual XmlNode InsertBefore(XmlNode newChild, XmlNode refChild);
protected object MemberwiseClone();
public virtual void Normalize();
public virtual XmlNode PrependChild(XmlNode newChild);
public override void RemoveAll();
public virtual void RemoveAllAttributes();
public virtual void RemoveAttribute(string name);
public virtual void RemoveAttribute(string localName, string namespaceUri);
public virtual XmlNode RemoveAttributeAt(int i);
public virtual XmlAttribute RemoveAttributeNode(string localName, string namespaceUri);
public virtual XmlAttribute RemoveAttributeNode(XmlAttribute oldAttr);
public virtual XmlNode RemoveChild(XmlNode oldChild);
public virtual XmlNode ReplaceChild(XmlNode newChild, XmlNode oldChild);
public XmlNodeList SelectNodes(string xpath);
public XmlNodeList SelectNodes(string xpath, XmlNamespaceManager nsmgr);
public XmlNode SelectSingleNode(string xpath);
public XmlNode SelectSingleNode(string xpath, XmlNamespaceManager nsmgr);
public virtual void SetAttribute(string name, string value);
public virtual string SetAttribute(string localName, string namespaceUri, string value);
public virtual XmlAttribute SetAttributeNode(string localName, string namespaceUri);
public virtual XmlAttribute SetAttributeNode(XmlAttribute newAttr);
public virtual bool Supports(string feature, string version);
public virtual string ToString();
public override void WriteContentTo(XmlWriter w);
public override void WriteTo(XmlWriter w);

Property
public override XmlAttributeCollection Attributes {get;}
public virtual string BaseURI {get;}
public virtual XmlNodeList ChildNodes {get;}
public virtual XmlNode FirstChild {get;}
public virtual bool HasAttributes {get;}
public virtual bool HasChildNodes {get;}
public override string InnerText {get; set;}
public override string InnerXml {get; set;}
public bool IsEmpty {get; set;}
public virtual bool IsReadOnly {get;}
public virtual XmlElement this[string localname, string ns] {get;}
public virtual XmlElement this[string name] {get;}
public virtual XmlNode LastChild {get;}
public override string LocalName {get;}
public override string Name {get;}
public override string NamespaceURI {get;}
public override XmlNode NextSibling {get;}
public override XmlNodeType NodeType {get;}
public virtual string OuterXml {get;}
public override XmlDocument OwnerDocument {get;}
public virtual XmlNode ParentNode {get;}
public override string Prefix {get; set;}
public override XmlNode PreviousSibling {get;}
public virtual string Value {get; set;}

System.Xml.XmlDocumentFragment

Module:System.Xml.dll

Hierarchy
Object
XmlNode
XmlDocumentFragment

Type declaration

[C#] public class XmlDocumentFragment : XmlNode;

Method
public virtual XmlNode AppendChild(XmlNode newChild);
public virtual XmlNode Clone();
public override XmlNode CloneNode(bool deep);
public XPathNavigator CreateNavigator();
public virtual bool Equals(object obj);
protected override void Finalize();
public IEnumerator GetEnumerator();
public virtual int GetHashCode();
public virtual string GetNamespaceOfPrefix(string prefix);
public virtual string GetPrefixOfNamespace(string namespaceUri);
public Type GetType();
public virtual XmlNode InsertAfter(XmlNode newChild, XmlNode refChild);
public virtual XmlNode InsertBefore(XmlNode newChild, XmlNode refChild);
protected object MemberwiseClone();
public virtual void Normalize();
public virtual XmlNode PrependChild(XmlNode newChild);
public virtual void RemoveAll();
public virtual XmlNode RemoveChild(XmlNode oldChild);
public virtual XmlNode ReplaceChild(XmlNode newChild, XmlNode oldChild);
public XmlNodeList SelectNodes(string xpath);
public XmlNodeList SelectNodes(string xpath, XmlNamespaceManager nsmgr);
public XmlNode SelectSingleNode(string xpath);
public XmlNode SelectSingleNode(string xpath, XmlNamespaceManager nsmgr);
public virtual bool Supports(string feature, string version);
public virtual string ToString();
public override void WriteContentTo(XmlWriter w);
public override void WriteTo(XmlWriter w);

Property
public virtual XmlAttributeCollection Attributes {get;}
public virtual string BaseURI {get;}
public virtual XmlNodeList ChildNodes {get;}
public virtual XmlNode FirstChild {get;}
public virtual bool HasChildNodes {get;}
public virtual string InnerText {get; set;}
public override string InnerXml {get; set;}
public virtual bool IsReadOnly {get;}
public virtual XmlElement this[string localname, string ns] {get;}
public virtual XmlElement this[string name] {get;}
public virtual XmlNode LastChild {get;}
public override string LocalName {get;}
public override string Name {get;}
public virtual string NamespaceURI {get;}
public virtual XmlNode NextSibling {get;}
public override XmlNodeType NodeType {get;}
public virtual string OuterXml {get;}
public override XmlDocument OwnerDocument {get;}
public override XmlNode ParentNode {get;}
public virtual string Prefix {get; set;}
public virtual XmlNode PreviousSibling {get;}
public virtual string Value {get; set;}

System.Xml.XmlDocument

Module:System.Xml.dll

Hierarchy
Object
XmlNode
XmlDocument

Type declaration

[C#] public class XmlDocument : XmlNode;

Constructor
public XmlDocument();
public XmlDocument(XmlNameTable nt);

Method
public void add_NodeChanged(XmlNodeChangedEventHandler value);
public void add_NodeChanging(XmlNodeChangedEventHandler value);
public void add_NodeInserted(XmlNodeChangedEventHandler value);
public void add_NodeInserting(XmlNodeChangedEventHandler value);
public void add_NodeRemoved(XmlNodeChangedEventHandler value);
public void add_NodeRemoving(XmlNodeChangedEventHandler value);
public virtual XmlNode AppendChild(XmlNode newChild);
public virtual XmlNode Clone();
public override XmlNode CloneNode(bool deep);
public XmlAttribute CreateAttribute(string name);
public XmlAttribute CreateAttribute(string qualifiedName, string namespaceUri);
public virtual XmlAttribute CreateAttribute(string prefix, string localName, string namespaceUri);
public virtual XmlCDataSection CreateCDataSection(string data);
public virtual XmlComment CreateComment(string data);
public virtual XmlDocumentFragment CreateDocumentFragment();
public virtual XmlDocumentType CreateDocumentType(string name, string publicId, string systemId, string internalSubset);
public XmlElement CreateElement(string name);
public XmlElement CreateElement(string qualifiedName, string namespaceUri);
public virtual XmlElement CreateElement(string prefix, string localName, string namespaceUri);
public virtual XmlEntityReference CreateEntityReference(string name);
public XPathNavigator CreateNavigator();
public virtual XmlNode CreateNode(string nodeTypeString, string name, string namespaceUri);
public virtual XmlNode CreateNode(XmlNodeType type, string name, string namespaceUri);
public virtual XmlNode CreateNode(XmlNodeType type, string prefix, string name, string namespaceUri);
public virtual XmlProcessingInstruction CreateProcessingInstruction(string target, string data);
public virtual XmlSignificantWhitespace CreateSignificantWhitespace(string text);
public virtual XmlText CreateTextNode(string text);
public virtual XmlWhitespace CreateWhitespace(string text);
public virtual XmlDeclaration CreateXmlDeclaration(string version, string encoding, string standalone);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual XmlElement GetElementById(string elementId);
public virtual XmlNodeList GetElementsByTagName(string name);
public virtual XmlNodeList GetElementsByTagName(string localName, string namespaceUri);
public IEnumerator GetEnumerator();
public virtual int GetHashCode();
public virtual string GetNamespaceOfPrefix(string prefix);
public virtual string GetPrefixOfNamespace(string namespaceUri);
public Type GetType();
public virtual XmlNode ImportNode(XmlNode node, bool deep);
public virtual XmlNode InsertAfter(XmlNode newChild, XmlNode refChild);
public virtual XmlNode InsertBefore(XmlNode newChild, XmlNode refChild);
public virtual void Load(Stream inStream);
public virtual void Load(string filename);
public virtual void Load(TextReader txtReader);
public virtual void Load(XmlReader reader);
public virtual void LoadXml(string xml);
protected object MemberwiseClone();
public virtual void Normalize();
public virtual XmlNode PrependChild(XmlNode newChild);
public virtual XmlNode ReadNode(XmlReader reader);
public void remove_NodeChanged(XmlNodeChangedEventHandler value);
public void remove_NodeChanging(XmlNodeChangedEventHandler value);
public void remove_NodeInserted(XmlNodeChangedEventHandler value);
public void remove_NodeInserting(XmlNodeChangedEventHandler value);
public void remove_NodeRemoved(XmlNodeChangedEventHandler value);
public void remove_NodeRemoving(XmlNodeChangedEventHandler value);
public virtual void RemoveAll();
public virtual XmlNode RemoveChild(XmlNode oldChild);
public virtual XmlNode ReplaceChild(XmlNode newChild, XmlNode oldChild);
public virtual void Save(Stream outStream);
public virtual void Save(string filename);
public virtual void Save(TextWriter writer);
public virtual void Save(XmlWriter w);
public XmlNodeList SelectNodes(string xpath);
public XmlNodeList SelectNodes(string xpath, XmlNamespaceManager nsmgr);
public XmlNode SelectSingleNode(string xpath);
public XmlNode SelectSingleNode(string xpath, XmlNamespaceManager nsmgr);
public virtual bool Supports(string feature, string version);
public virtual string ToString();
public override void WriteContentTo(XmlWriter w);
public override void WriteTo(XmlWriter w);

Property
public virtual XmlAttributeCollection Attributes {get;}
public override string BaseURI {get;}
public virtual XmlNodeList ChildNodes {get;}
public XmlElement DocumentElement {get;}
public virtual XmlDocumentType DocumentType {get;}
public virtual XmlNode FirstChild {get;}
public virtual bool HasChildNodes {get;}
public XmlImplementation Implementation {get;}
public virtual string InnerText {get; set;}
public override string InnerXml {get; set;}
public override bool IsReadOnly {get;}
public virtual XmlElement this[string localname, string ns] {get;}
public virtual XmlElement this[string name] {get;}
public virtual XmlNode LastChild {get;}
public override string LocalName {get;}
public override string Name {get;}
public virtual string NamespaceURI {get;}
public XmlNameTable NameTable {get;}
public virtual XmlNode NextSibling {get;}
public override XmlNodeType NodeType {get;}
public virtual string OuterXml {get;}
public override XmlDocument OwnerDocument {get;}
public virtual XmlNode ParentNode {get;}
public virtual string Prefix {get; set;}
public bool PreserveWhitespace {get; set;}
public virtual XmlNode PreviousSibling {get;}
public virtual string Value {get; set;}
public virtual XmlResolver XmlResolver {set;}

System.Xml.XmlDeclaration

Module:System.Xml.dll

Hierarchy
Object
XmlNode
XmlLinkedNode
XmlDeclaration

Type declaration

[C#] public class XmlDeclaration : XmlLinkedNode;

Method
public virtual XmlNode AppendChild(XmlNode newChild);
public virtual XmlNode Clone();
public override XmlNode CloneNode(bool deep);
public XPathNavigator CreateNavigator();
public virtual bool Equals(object obj);
protected override void Finalize();
public IEnumerator GetEnumerator();
public virtual int GetHashCode();
public virtual string GetNamespaceOfPrefix(string prefix);
public virtual string GetPrefixOfNamespace(string namespaceUri);
public Type GetType();
public virtual XmlNode InsertAfter(XmlNode newChild, XmlNode refChild);
public virtual XmlNode InsertBefore(XmlNode newChild, XmlNode refChild);
protected object MemberwiseClone();
public virtual void Normalize();
public virtual XmlNode PrependChild(XmlNode newChild);
public virtual void RemoveAll();
public virtual XmlNode RemoveChild(XmlNode oldChild);
public virtual XmlNode ReplaceChild(XmlNode newChild, XmlNode oldChild);
public XmlNodeList SelectNodes(string xpath);
public XmlNodeList SelectNodes(string xpath, XmlNamespaceManager nsmgr);
public XmlNode SelectSingleNode(string xpath);
public XmlNode SelectSingleNode(string xpath, XmlNamespaceManager nsmgr);
public virtual bool Supports(string feature, string version);
public virtual string ToString();
public override void WriteContentTo(XmlWriter w);
public override void WriteTo(XmlWriter w);

Property
public virtual XmlAttributeCollection Attributes {get;}
public virtual string BaseURI {get;}
public virtual XmlNodeList ChildNodes {get;}
public string Encoding {get; set;}
public virtual XmlNode FirstChild {get;}
public virtual bool HasChildNodes {get;}
public override string InnerText {get; set;}
public virtual string InnerXml {get; set;}
public virtual bool IsReadOnly {get;}
public virtual XmlElement this[string localname, string ns] {get;}
public virtual XmlElement this[string name] {get;}
public virtual XmlNode LastChild {get;}
public override string LocalName {get;}
public override string Name {get;}
public virtual string NamespaceURI {get;}
public override XmlNode NextSibling {get;}
public override XmlNodeType NodeType {get;}
public virtual string OuterXml {get;}
public virtual XmlDocument OwnerDocument {get;}
public virtual XmlNode ParentNode {get;}
public virtual string Prefix {get; set;}
public override XmlNode PreviousSibling {get;}
public string Standalone {get; set;}
public override string Value {get; set;}
public string Version {get;}

System.Xml.XmlComment

Module:System.Xml.dll

Hierarchy
Object
XmlNode
XmlLinkedNode
XmlCharacterData
XmlComment

Type declaration

[C#] public class XmlComment : XmlCharacterData;

Method
public virtual XmlNode AppendChild(XmlNode newChild);
public virtual void AppendData(string strData);
public virtual XmlNode Clone();
public override XmlNode CloneNode(bool deep);
public XPathNavigator CreateNavigator();
public virtual void DeleteData(int offset, int count);
public virtual bool Equals(object obj);
protected override void Finalize();
public IEnumerator GetEnumerator();
public virtual int GetHashCode();
public virtual string GetNamespaceOfPrefix(string prefix);
public virtual string GetPrefixOfNamespace(string namespaceUri);
public Type GetType();
public virtual XmlNode InsertAfter(XmlNode newChild, XmlNode refChild);
public virtual XmlNode InsertBefore(XmlNode newChild, XmlNode refChild);
public virtual void InsertData(int offset, string strData);
protected object MemberwiseClone();
public virtual void Normalize();
public virtual XmlNode PrependChild(XmlNode newChild);
public virtual void RemoveAll();
public virtual XmlNode RemoveChild(XmlNode oldChild);
public virtual XmlNode ReplaceChild(XmlNode newChild, XmlNode oldChild);
public virtual void ReplaceData(int offset, int count, string strData);
public XmlNodeList SelectNodes(string xpath);
public XmlNodeList SelectNodes(string xpath, XmlNamespaceManager nsmgr);
public XmlNode SelectSingleNode(string xpath);
public XmlNode SelectSingleNode(string xpath, XmlNamespaceManager nsmgr);
public virtual string Substring(int offset, int count);
public virtual bool Supports(string feature, string version);
public virtual string ToString();
public override void WriteContentTo(XmlWriter w);
public override void WriteTo(XmlWriter w);

Property
public virtual XmlAttributeCollection Attributes {get;}
public virtual string BaseURI {get;}
public virtual XmlNodeList ChildNodes {get;}
public virtual string Data {get; set;}
public virtual XmlNode FirstChild {get;}
public virtual bool HasChildNodes {get;}
public override string InnerText {get; set;}
public virtual string InnerXml {get; set;}
public virtual bool IsReadOnly {get;}
public virtual XmlElement this[string localname, string ns] {get;}
public virtual XmlElement this[string name] {get;}
public virtual XmlNode LastChild {get;}
public virtual int Length {get;}
public override string LocalName {get;}
public override string Name {get;}
public virtual string NamespaceURI {get;}
public override XmlNode NextSibling {get;}
public override XmlNodeType NodeType {get;}
public virtual string OuterXml {get;}
public virtual XmlDocument OwnerDocument {get;}
public virtual XmlNode ParentNode {get;}
public virtual string Prefix {get; set;}
public override XmlNode PreviousSibling {get;}
public override string Value {get; set;}

System.Xml.XmlNodeList

Module:System.Xml.dll

Hierarchy
Object
XmlNodeList : IEnumerable

Type declaration

[C#] public abstract class XmlNodeList: IEnumerable;

Constructor
protected XmlNodeList();

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public abstract IEnumerator GetEnumerator();
public virtual int GetHashCode();
public Type GetType();
public abstract XmlNode Item(int index);
protected object MemberwiseClone();
public virtual string ToString();

Property
public abstract int Count {get;}
public virtual XmlNode ItemOf[int i] {get;}

System.Xml.XmlCDataSection

Module:System.Xml.dll

Hierarchy
Object
XmlNode
XmlLinkedNode
XmlCharacterData
XmlCDataSection

Type declaration

[C#] public class XmlCDataSection : XmlCharacterData;

Method
public virtual XmlNode AppendChild(XmlNode newChild);
public virtual void AppendData(string strData);
public virtual XmlNode Clone();
public override XmlNode CloneNode(bool deep);
public XPathNavigator CreateNavigator();
public virtual void DeleteData(int offset, int count);
public virtual bool Equals(object obj);
protected override void Finalize();
public IEnumerator GetEnumerator();
public virtual int GetHashCode();
public virtual string GetNamespaceOfPrefix(string prefix);
public virtual string GetPrefixOfNamespace(string namespaceUri);
public Type GetType();
public virtual XmlNode InsertAfter(XmlNode newChild, XmlNode refChild);
public virtual XmlNode InsertBefore(XmlNode newChild, XmlNode refChild);
public virtual void InsertData(int offset, string strData);
protected object MemberwiseClone();
public virtual void Normalize();
public virtual XmlNode PrependChild(XmlNode newChild);
public virtual void RemoveAll();
public virtual XmlNode RemoveChild(XmlNode oldChild);
public virtual XmlNode ReplaceChild(XmlNode newChild, XmlNode oldChild);
public virtual void ReplaceData(int offset, int count, string strData);
public XmlNodeList SelectNodes(string xpath);
public XmlNodeList SelectNodes(string xpath, XmlNamespaceManager nsmgr);
public XmlNode SelectSingleNode(string xpath);
public XmlNode SelectSingleNode(string xpath, XmlNamespaceManager nsmgr);
public virtual string Substring(int offset, int count);
public virtual bool Supports(string feature, string version);
public virtual string ToString();
public override void WriteContentTo(XmlWriter w);
public override void WriteTo(XmlWriter w);

Property
public virtual XmlAttributeCollection Attributes {get;}
public virtual string BaseURI {get;}
public virtual XmlNodeList ChildNodes {get;}
public virtual string Data {get; set;}
public virtual XmlNode FirstChild {get;}
public virtual bool HasChildNodes {get;}
public override string InnerText {get; set;}
public virtual string InnerXml {get; set;}
public virtual bool IsReadOnly {get;}
public virtual XmlElement this[string localname, string ns] {get;}
public virtual XmlElement this[string name] {get;}
public virtual XmlNode LastChild {get;}
public virtual int Length {get;}
public override string LocalName {get;}
public override string Name {get;}
public virtual string NamespaceURI {get;}
public override XmlNode NextSibling {get;}
public override XmlNodeType NodeType {get;}
public virtual string OuterXml {get;}
public virtual XmlDocument OwnerDocument {get;}
public virtual XmlNode ParentNode {get;}
public virtual string Prefix {get; set;}
public override XmlNode PreviousSibling {get;}
public override string Value {get; set;}

System.Xml.XmlCharacterData

Module:System.Xml.dll

Hierarchy
Object
XmlNode
XmlLinkedNode
XmlCharacterData

Type declaration

[C#] public abstract class XmlCharacterData : XmlLinkedNode;

Method
public virtual XmlNode AppendChild(XmlNode newChild);
public virtual void AppendData(string strData);
public virtual XmlNode Clone();
public abstract XmlNode CloneNode(bool deep);
public XPathNavigator CreateNavigator();
public virtual void DeleteData(int offset, int count);
public virtual bool Equals(object obj);
protected override void Finalize();
public IEnumerator GetEnumerator();
public virtual int GetHashCode();
public virtual string GetNamespaceOfPrefix(string prefix);
public virtual string GetPrefixOfNamespace(string namespaceUri);
public Type GetType();
public virtual XmlNode InsertAfter(XmlNode newChild, XmlNode refChild);
public virtual XmlNode InsertBefore(XmlNode newChild, XmlNode refChild);
public virtual void InsertData(int offset, string strData);
protected object MemberwiseClone();
public virtual void Normalize();
public virtual XmlNode PrependChild(XmlNode newChild);
public virtual void RemoveAll();
public virtual XmlNode RemoveChild(XmlNode oldChild);
public virtual XmlNode ReplaceChild(XmlNode newChild, XmlNode oldChild);
public virtual void ReplaceData(int offset, int count, string strData);
public XmlNodeList SelectNodes(string xpath);
public XmlNodeList SelectNodes(string xpath, XmlNamespaceManager nsmgr);
public XmlNode SelectSingleNode(string xpath);
public XmlNode SelectSingleNode(string xpath, XmlNamespaceManager nsmgr);
public virtual string Substring(int offset, int count);
public virtual bool Supports(string feature, string version);
public virtual string ToString();
public abstract void WriteContentTo(XmlWriter w);
public abstract void WriteTo(XmlWriter w);

Property
public virtual XmlAttributeCollection Attributes {get;}
public virtual string BaseURI {get;}
public virtual XmlNodeList ChildNodes {get;}
public virtual string Data {get; set;}
public virtual XmlNode FirstChild {get;}
public virtual bool HasChildNodes {get;}
public override string InnerText {get; set;}
public virtual string InnerXml {get; set;}
public virtual bool IsReadOnly {get;}
public virtual XmlElement this[string localname, string ns] {get;}
public virtual XmlElement this[string name] {get;}
public virtual XmlNode LastChild {get;}
public virtual int Length {get;}
public abstract string LocalName {get;}
public abstract string Name {get;}
public virtual string NamespaceURI {get;}
public override XmlNode NextSibling {get;}
public abstract XmlNodeType NodeType {get;}
public virtual string OuterXml {get;}
public virtual XmlDocument OwnerDocument {get;}
public virtual XmlNode ParentNode {get;}
public virtual string Prefix {get; set;}
public override XmlNode PreviousSibling {get;}
public override string Value {get; set;}

System.Xml.XmlLinkedNode

Module:System.Xml.dll

Hierarchy
Object
XmlNode
XmlLinkedNode

Type declaration

[C#] public abstract class XmlLinkedNode : XmlNode;

Method
public virtual XmlNode AppendChild(XmlNode newChild);
public virtual XmlNode Clone();
public abstract XmlNode CloneNode(bool deep);
public XPathNavigator CreateNavigator();
public virtual bool Equals(object obj);
protected override void Finalize();
public IEnumerator GetEnumerator();
public virtual int GetHashCode();
public virtual string GetNamespaceOfPrefix(string prefix);
public virtual string GetPrefixOfNamespace(string namespaceUri);
public Type GetType();
public virtual XmlNode InsertAfter(XmlNode newChild, XmlNode refChild);
public virtual XmlNode InsertBefore(XmlNode newChild, XmlNode refChild);
protected object MemberwiseClone();
public virtual void Normalize();
public virtual XmlNode PrependChild(XmlNode newChild);
public virtual void RemoveAll();
public virtual XmlNode RemoveChild(XmlNode oldChild);
public virtual XmlNode ReplaceChild(XmlNode newChild, XmlNode oldChild);
public XmlNodeList SelectNodes(string xpath);
public XmlNodeList SelectNodes(string xpath, XmlNamespaceManager nsmgr);
public XmlNode SelectSingleNode(string xpath);
public XmlNode SelectSingleNode(string xpath, XmlNamespaceManager nsmgr);
public virtual bool Supports(string feature, string version);
public virtual string ToString();
public abstract void WriteContentTo(XmlWriter w);
public abstract void WriteTo(XmlWriter w);

Property
public virtual XmlAttributeCollection Attributes {get;}
public virtual string BaseURI {get;}
public virtual XmlNodeList ChildNodes {get;}
public virtual XmlNode FirstChild {get;}
public virtual bool HasChildNodes {get;}
public virtual string InnerText {get; set;}
public virtual string InnerXml {get; set;}
public virtual bool IsReadOnly {get;}
public virtual XmlElement this[string localname, string ns] {get;}
public virtual XmlElement this[string name] {get;}
public virtual XmlNode LastChild {get;}
public abstract string LocalName {get;}
public abstract string Name {get;}
public virtual string NamespaceURI {get;}
public override XmlNode NextSibling {get;}
public abstract XmlNodeType NodeType {get;}
public virtual string OuterXml {get;}
public virtual XmlDocument OwnerDocument {get;}
public virtual XmlNode ParentNode {get;}
public virtual string Prefix {get; set;}
public override XmlNode PreviousSibling {get;}
public virtual string Value {get; set;}

System.Xml.XmlAttributeCollection

Module:System.Xml.dll

Hierarchy
Object
XmlNamedNodeMap
XmlAttributeCollection : ICollection, IEnumerable

Type declaration

[C#] public class XmlAttributeCollection : XmlNamedNodeMap, ICollection, IEnumerable;

Method
public virtual XmlAttribute Append(XmlAttribute node);
public void CopyTo(XmlAttribute[] array, int index);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual IEnumerator GetEnumerator();
public virtual int GetHashCode();
public virtual XmlNode GetNamedItem(string name);
public virtual XmlNode GetNamedItem(string localName, string namespaceUri);
public Type GetType();
public virtual XmlAttribute InsertAfter(XmlAttribute newNode, XmlAttribute refNode);
public virtual XmlAttribute InsertBefore(XmlAttribute newNode, XmlAttribute refNode);
public virtual XmlNode Item(int index);
protected object MemberwiseClone();
public virtual XmlAttribute Prepend(XmlAttribute node);
public virtual XmlAttribute Remove(XmlAttribute node);
public virtual void RemoveAll();
public virtual XmlAttribute RemoveAt(int i);
public virtual XmlNode RemoveNamedItem(string name);
public virtual XmlNode RemoveNamedItem(string localName, string namespaceUri);
public override XmlNode SetNamedItem(XmlNode node);
public virtual string ToString();

Property
public virtual int Count {get;}
public virtual XmlAttribute ItemOf[int i] {get;}
public virtual XmlAttribute ItemOf[string localName, string namespaceUri] {get;}
public virtual XmlAttribute ItemOf[string name] {get;}

System.Xml.XmlNamedNodeMap

Module:System.Xml.dll

Hierarchy
Object
XmlNamedNodeMap : IEnumerable

Type declaration

[C#] public class XmlNamedNodeMap: IEnumerable;

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual IEnumerator GetEnumerator();
public virtual int GetHashCode();
public virtual XmlNode GetNamedItem(string name);
public virtual XmlNode GetNamedItem(string localName, string namespaceUri);
public Type GetType();
public virtual XmlNode Item(int index);
protected object MemberwiseClone();
public virtual XmlNode RemoveNamedItem(string name);
public virtual XmlNode RemoveNamedItem(string localName, string namespaceUri);
public virtual XmlNode SetNamedItem(XmlNode node);
public virtual string ToString();

Property
public virtual int Count {get;}

System.Xml.XmlAttribute

Module:System.Xml.dll

Hierarchy
Object
XmlNode
XmlAttribute

Type declaration

[C#] public class XmlAttribute : XmlNode;

Method
public virtual XmlNode AppendChild(XmlNode newChild);
public virtual XmlNode Clone();
public override XmlNode CloneNode(bool deep);
public XPathNavigator CreateNavigator();
public virtual bool Equals(object obj);
protected override void Finalize();
public IEnumerator GetEnumerator();
public virtual int GetHashCode();
public virtual string GetNamespaceOfPrefix(string prefix);
public virtual string GetPrefixOfNamespace(string namespaceUri);
public Type GetType();
public virtual XmlNode InsertAfter(XmlNode newChild, XmlNode refChild);
public virtual XmlNode InsertBefore(XmlNode newChild, XmlNode refChild);
protected object MemberwiseClone();
public virtual void Normalize();
public virtual XmlNode PrependChild(XmlNode newChild);
public virtual void RemoveAll();
public virtual XmlNode RemoveChild(XmlNode oldChild);
public virtual XmlNode ReplaceChild(XmlNode newChild, XmlNode oldChild);
public XmlNodeList SelectNodes(string xpath);
public XmlNodeList SelectNodes(string xpath, XmlNamespaceManager nsmgr);
public XmlNode SelectSingleNode(string xpath);
public XmlNode SelectSingleNode(string xpath, XmlNamespaceManager nsmgr);
public virtual bool Supports(string feature, string version);
public virtual string ToString();
public override void WriteContentTo(XmlWriter w);
public override void WriteTo(XmlWriter w);

Property
public virtual XmlAttributeCollection Attributes {get;}
public override string BaseURI {get;}
public virtual XmlNodeList ChildNodes {get;}
public virtual XmlNode FirstChild {get;}
public virtual bool HasChildNodes {get;}
public override string InnerText {get; set;}
public override string InnerXml {get; set;}
public virtual bool IsReadOnly {get;}
public virtual XmlElement this[string localname, string ns] {get;}
public virtual XmlElement this[string name] {get;}
public virtual XmlNode LastChild {get;}
public override string LocalName {get;}
public override string Name {get;}
public override string NamespaceURI {get;}
public virtual XmlNode NextSibling {get;}
public override XmlNodeType NodeType {get;}
public virtual string OuterXml {get;}
public override XmlDocument OwnerDocument {get;}
public virtual XmlElement OwnerElement {get;}
public override XmlNode ParentNode {get;}
public override string Prefix {get; set;}
public virtual XmlNode PreviousSibling {get;}
public virtual bool Specified {get;}
public override string Value {get; set;}

System.Xml.XmlNode

Module:System.Xml.dll

Hierarchy
Object
XmlNode : ICloneable, IEnumerable

Type declaration

[C#] public abstract class XmlNode: ICloneable, IEnumerable;

Method
public virtual XmlNode AppendChild(XmlNode newChild);
public virtual XmlNode Clone();
public abstract XmlNode CloneNode(bool deep);
public virtual XPathNavigator CreateNavigator();
public virtual bool Equals(object obj);
protected override void Finalize();
public IEnumerator GetEnumerator();
public virtual int GetHashCode();
public virtual string GetNamespaceOfPrefix(string prefix);
public virtual string GetPrefixOfNamespace(string namespaceUri);
public Type GetType();
public virtual XmlNode InsertAfter(XmlNode newChild, XmlNode refChild);
public virtual XmlNode InsertBefore(XmlNode newChild, XmlNode refChild);
protected object MemberwiseClone();
public virtual void Normalize();
public virtual XmlNode PrependChild(XmlNode newChild);
public virtual void RemoveAll();
public virtual XmlNode RemoveChild(XmlNode oldChild);
public virtual XmlNode ReplaceChild(XmlNode newChild, XmlNode oldChild);
public XmlNodeList SelectNodes(string xpath);
public XmlNodeList SelectNodes(string xpath, XmlNamespaceManager nsmgr);
public XmlNode SelectSingleNode(string xpath);
public XmlNode SelectSingleNode(string xpath, XmlNamespaceManager nsmgr);
public virtual bool Supports(string feature, string version);
public virtual string ToString();
public abstract void WriteContentTo(XmlWriter w);
public abstract void WriteTo(XmlWriter w);

Property
public virtual XmlAttributeCollection Attributes {get;}
public virtual string BaseURI {get;}
public virtual XmlNodeList ChildNodes {get;}
public virtual XmlNode FirstChild {get;}
public virtual bool HasChildNodes {get;}
public virtual string InnerText {get; set;}
public virtual string InnerXml {get; set;}
public virtual bool IsReadOnly {get;}
public virtual XmlElement this[string localname, string ns] {get;}
public virtual XmlElement this[string name] {get;}
public virtual XmlNode LastChild {get;}
public abstract string LocalName {get;}
public abstract string Name {get;}
public virtual string NamespaceURI {get;}
public virtual XmlNode NextSibling {get;}
public abstract XmlNodeType NodeType {get;}
public virtual string OuterXml {get;}
public virtual XmlDocument OwnerDocument {get;}
public virtual XmlNode ParentNode {get;}
public virtual string Prefix {get; set;}
public virtual XmlNode PreviousSibling {get;}
public virtual string Value {get; set;}

System.Xml.XmlConvert

Module:System.Xml.dll

Hierarchy
Object
XmlConvert

Type declaration

[C#] public class XmlConvert;

Constructor
public XmlConvert();

Method
public static string DecodeName(string name);
public static string EncodeLocalName(string name);
public static string EncodeName(string name);
public static string EncodeNmToken(string name);
public virtual bool Equals(object obj);
protected override void Finalize();
public static byte[] FromBinHexString(string s);
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public static string ToBinHexString(byte[] inArray);
public static bool ToBoolean(string s);
public static byte ToByte(string s);
public static char ToChar(string s);
public static DateTime ToDateTime(string s);
public static DateTime ToDateTime(string s, string format);
public static DateTime ToDateTime(string s, string[] formats);
public static decimal ToDecimal(string s);
public static double ToDouble(string s);
public static Guid ToGuid(string s);
public static short ToInt16(string s);
public static int ToInt32(string s);
public static long ToInt64(string s);
public static SByte ToSByte(string s);
public static float ToSingle(string s);
public virtual string ToString();
public static string ToString(bool value);
public static string ToString(byte value);
public static string ToString(char value);
public static string ToString(DateTime value);
public static string ToString(DateTime value, string format);
public static string ToString(decimal value);
public static string ToString(double value);
public static string ToString(Guid value);
public static string ToString(short value);
public static string ToString(int value);
public static string ToString(long value);
public static string ToString(SByte value);
public static string ToString(float value);
public static string ToString(TimeSpan value);
public static string ToString(ushort value);
public static string ToString(uint value);
public static string ToString(ulong value);
public static TimeSpan ToTimeSpan(string s);
public static ushort ToUInt16(string s);
public static uint ToUInt32(string s);
public static ulong ToUInt64(string s);
public static string VerifyName(string name);
public static string VerifyNCName(string name);

System.Xml.XmlQualifiedName

Module:System.Xml.dll

Hierarchy
Object
XmlQualifiedName

Type declaration

[C#] public class XmlQualifiedName;

Constructor
public XmlQualifiedName();
public XmlQualifiedName(string name);
public XmlQualifiedName(string name, string ns);

Method
public override bool Equals(object other);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public static bool op_Equality(XmlQualifiedName a, XmlQualifiedName b);
public static bool op_Inequality(XmlQualifiedName a, XmlQualifiedName b);
public override string ToString();
public static string ToString(string name, string ns);

Property
public bool IsEmpty {get;}
public string Name {get;}
public string Namespace {get;}

Field
public readonly static XmlQualifiedName Empty;

System.Xml.XmlUrlResolver

Module:System.Xml.dll

Hierarchy
Object
XmlResolver
XmlUrlResolver

Type declaration

[C#] public class XmlUrlResolver : XmlResolver;

Constructor
public XmlUrlResolver();

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public override object GetEntity(Uri absoluteUri, string role, Type ofObjectToReturn);
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public override Uri ResolveUri(Uri baseUri, string relativeUri);
public virtual string ToString();

Property
public override ICredentials Credentials {set;}

System.Xml.XmlResolver

Module:System.Xml.dll

Hierarchy
Object
XmlResolver

Type declaration

[C#] public abstract class XmlResolver;

Constructor
protected XmlResolver();

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public abstract object GetEntity(Uri absoluteUri, string role, Type ofObjectToReturn);
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public abstract Uri ResolveUri(Uri baseUri, string relativeUri);
public virtual string ToString();

Property
public abstract ICredentials Credentials {set;}

System.Xml.NameTable

Module:System.Xml.dll

Hierarchy
Object
XmlNameTable
NameTable

Type declaration

[C#] public class NameTable : XmlNameTable;

Constructor
public NameTable();

Method
public override string Add(char[] key, int start, int len);
public override string Add(string key);
public virtual bool Equals(object obj);
protected override void Finalize();
public override string Get(char[] key, int start, int len);
public override string Get(string value);
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

System.Xml.XmlParserContext

Module:System.Xml.dll

Hierarchy
Object
XmlParserContext

Type declaration

[C#] public class XmlParserContext;

Constructor
public XmlParserContext(XmlNameTable nt, XmlNamespaceManager nsMgr, string docTypeName, string pubId, string sysId, string internalSubset, string baseUri, string xmlLang, XmlSpace xmlSpace);
public XmlParserContext(XmlNameTable nt, XmlNamespaceManager nsMgr, string docTypeName, string pubId, string sysId, string internalSubset, string baseUri, string xmlLang, XmlSpace xmlSpace, Encoding enc);
public XmlParserContext(XmlNameTable nt, XmlNamespaceManager nsMgr, string xmlLang, XmlSpace xmlSpace);
public XmlParserContext(XmlNameTable nt, XmlNamespaceManager nsMgr, string xmlLang, XmlSpace xmlSpace, Encoding enc);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public string BaseURI {get; set;}
public string DocTypeName {get; set;}
public Encoding Encoding {get; set;}
public string InternalSubset {get; set;}
public XmlNamespaceManager NamespaceManager {get; set;}
public XmlNameTable NameTable {get; set;}
public string PublicId {get; set;}
public string SystemId {get; set;}
public string XmlLang {get; set;}
public XmlSpace XmlSpace {get; set;}

System.Xml.WhitespaceHandling

Module:System.Xml.dll

Hierarchy
Object
ValueType
Enum
WhitespaceHandling

Type declaration

[C#] public enum WhitespaceHandling;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const WhitespaceHandling All = 0;
public const WhitespaceHandling None = 2;
public const WhitespaceHandling Significant = 1;
public int value__;

System.Xml.EntityHandling

Module:System.Xml.dll

Hierarchy
Object
ValueType
Enum
EntityHandling

Type declaration

[C#] public enum EntityHandling;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const EntityHandling ExpandCharEntities = 2;
public const EntityHandling ExpandEntities = 1;
public int value__;

System.Xml.XmlTextReader

Module:System.Xml.dll

Hierarchy
Object
XmlReader
XmlTextReader : IXmlLineInfo

Type declaration

[C#] public class XmlTextReader : XmlReader, IXmlLineInfo;

Constructor
protected XmlTextReader();
public XmlTextReader(Stream input);
public XmlTextReader(Stream input, XmlNameTable nt);
public XmlTextReader(Stream xmlFragment, XmlNodeType fragType, XmlParserContext context);
public XmlTextReader(string url);
public XmlTextReader(string url, Stream input);
public XmlTextReader(string url, Stream input, XmlNameTable nt);
public XmlTextReader(string url, TextReader input);
public XmlTextReader(string url, TextReader input, XmlNameTable nt);
public XmlTextReader(string url, XmlNameTable nt);
public XmlTextReader(string xmlFragment, XmlNodeType fragType, XmlParserContext context);
public XmlTextReader(TextReader input);
public XmlTextReader(TextReader input, XmlNameTable nt);
protected XmlTextReader(XmlNameTable nt);

Method
public override void Close();
public virtual bool Equals(object obj);
protected override void Finalize();
public override string GetAttribute(int i);
public override string GetAttribute(string name);
public override string GetAttribute(string localName, string namespaceUri);
public virtual int GetHashCode();
public TextReader GetRemainder();
public Type GetType();
public virtual bool IsStartElement();
public virtual bool IsStartElement(string name);
public virtual bool IsStartElement(string localname, string ns);
public override string LookupNamespace(string prefix);
protected object MemberwiseClone();
public override void MoveToAttribute(int i);
public override bool MoveToAttribute(string name);
public override bool MoveToAttribute(string localName, string namespaceUri);
public virtual XmlNodeType MoveToContent();
public override bool MoveToElement();
public override bool MoveToFirstAttribute();
public override bool MoveToNextAttribute();
public override bool Read();
public override bool ReadAttributeValue();
public int ReadBase64(byte[] array, int offset, int len);
public int ReadBinHex(byte[] array, int offset, int len);
public int ReadChars(char[] buffer, int index, int count);
public virtual string ReadElementString();
public virtual string ReadElementString(string name);
public virtual string ReadElementString(string localname, string ns);
public virtual void ReadEndElement();
public override string ReadInnerXml();
public override string ReadOuterXml();
public virtual void ReadStartElement();
public virtual void ReadStartElement(string name);
public virtual void ReadStartElement(string localname, string ns);
public override string ReadString();
public void ResetState();
public override void ResolveEntity();
public virtual void Skip();
public virtual string ToString();

Property
public override int AttributeCount {get;}
public override string BaseURI {get;}
public virtual bool CanResolveEntity {get;}
public override int Depth {get;}
public Encoding Encoding {get;}
public override bool EOF {get;}
public virtual bool HasAttributes {get;}
public override bool HasValue {get;}
public override bool IsDefault {get;}
public override bool IsEmptyElement {get;}
public override string this[int i] {get;}
public override string this[string name, string namespaceUri] {get;}
public override string this[string name] {get;}
public virtual int LineNumber {get;}
public virtual int LinePosition {get;}
public override string LocalName {get;}
public override string Name {get;}
public bool Namespaces {get; set;}
public override string NamespaceURI {get;}
public override XmlNameTable NameTable {get;}
public override XmlNodeType NodeType {get;}
public bool Normalization {get; set;}
public override string Prefix {get;}
public override char QuoteChar {get;}
public override ReadState ReadState {get;}
public override string Value {get;}
public WhitespaceHandling WhitespaceHandling {get; set;}
public override string XmlLang {get;}
public XmlResolver XmlResolver {set;}
public override XmlSpace XmlSpace {get;}

System.Xml.IXmlLineInfo

Module:System.Xml.dll

Hierarchy
IXmlLineInfo

Type declaration

[C#] public interface IXmlLineInfo;

Method
public bool HasLineInfo();

Property
public int LineNumber {get;}
public int LinePosition {get;}

System.Xml.XmlTextWriter

Module:System.Xml.dll

Hierarchy
Object
XmlWriter
XmlTextWriter

Type declaration

[C#] public class XmlTextWriter : XmlWriter;

Constructor
public XmlTextWriter(Stream w, Encoding encoding);
public XmlTextWriter(string filename, Encoding encoding);
public XmlTextWriter(TextWriter w);

Method
public override void Close();
public virtual bool Equals(object obj);
protected override void Finalize();
public override void Flush();
public virtual int GetHashCode();
public Type GetType();
public override string LookupPrefix(string ns);
protected object MemberwiseClone();
public virtual string ToString();
public virtual void WriteAttributes(XmlReader reader, bool defattr);
public void WriteAttributeString(string localName, string value);
public void WriteAttributeString(string localName, string ns, string value);
public void WriteAttributeString(string prefix, string localName, string ns, string value);
public override void WriteBase64(byte[] buffer, int index, int count);
public override void WriteBinHex(byte[] buffer, int index, int count);
public override void WriteCData(string text);
public override void WriteCharEntity(char ch);
public override void WriteChars(char[] buffer, int index, int count);
public override void WriteComment(string text);
public override void WriteDocType(string name, string pubid, string sysid, string subset);
public void WriteElementString(string localName, string value);
public void WriteElementString(string localName, string ns, string value);
public override void WriteEndAttribute();
public override void WriteEndDocument();
public override void WriteEndElement();
public override void WriteEntityRef(string name);
public override void WriteFullEndElement();
public override void WriteName(string name);
public override void WriteNmToken(string name);
public virtual void WriteNode(XmlReader reader, bool defattr);
public override void WriteProcessingInstruction(string name, string text);
public override void WriteQualifiedName(string localName, string ns);
public override void WriteRaw(char[] buffer, int index, int count);
public override void WriteRaw(string data);
public void WriteStartAttribute(string localName, string ns);
public override void WriteStartAttribute(string prefix, string localName, string ns);
public override void WriteStartDocument();
public override void WriteStartDocument(bool standalone);
public void WriteStartElement(string localName);
public void WriteStartElement(string localName, string ns);
public override void WriteStartElement(string prefix, string localName, string ns);
public override void WriteString(string text);
public override void WriteSurrogateCharEntity(char lowChar, char highChar);
public override void WriteWhitespace(string ws);

Property
public Stream BaseStream {get;}
public Formatting Formatting {get; set;}
public int Indentation {get; set;}
public char IndentChar {get; set;}
public bool Namespaces {get; set;}
public char QuoteChar {get; set;}
public override WriteState WriteState {get;}
public override string XmlLang {get;}
public override XmlSpace XmlSpace {get;}

System.Xml.XmlWriter

Module:System.Xml.dll

Hierarchy
Object
XmlWriter

Type declaration

[C#] public abstract class XmlWriter;

Constructor
protected XmlWriter();

Method
public abstract void Close();
public virtual bool Equals(object obj);
protected override void Finalize();
public abstract void Flush();
public virtual int GetHashCode();
public Type GetType();
public abstract string LookupPrefix(string ns);
protected object MemberwiseClone();
public virtual string ToString();
public virtual void WriteAttributes(XmlReader reader, bool defattr);
public void WriteAttributeString(string localName, string value);
public void WriteAttributeString(string localName, string ns, string value);
public void WriteAttributeString(string prefix, string localName, string ns, string value);
public abstract void WriteBase64(byte[] buffer, int index, int count);
public abstract void WriteBinHex(byte[] buffer, int index, int count);
public abstract void WriteCData(string text);
public abstract void WriteCharEntity(char ch);
public abstract void WriteChars(char[] buffer, int index, int count);
public abstract void WriteComment(string text);
public abstract void WriteDocType(string name, string pubid, string sysid, string subset);
public void WriteElementString(string localName, string value);
public void WriteElementString(string localName, string ns, string value);
public abstract void WriteEndAttribute();
public abstract void WriteEndDocument();
public abstract void WriteEndElement();
public abstract void WriteEntityRef(string name);
public abstract void WriteFullEndElement();
public abstract void WriteName(string name);
public abstract void WriteNmToken(string name);
public virtual void WriteNode(XmlReader reader, bool defattr);
public abstract void WriteProcessingInstruction(string name, string text);
public abstract void WriteQualifiedName(string localName, string ns);
public abstract void WriteRaw(char[] buffer, int index, int count);
public abstract void WriteRaw(string data);
public void WriteStartAttribute(string localName, string ns);
public abstract void WriteStartAttribute(string prefix, string localName, string ns);
public abstract void WriteStartDocument();
public abstract void WriteStartDocument(bool standalone);
public void WriteStartElement(string localName);
public void WriteStartElement(string localName, string ns);
public abstract void WriteStartElement(string prefix, string localName, string ns);
public abstract void WriteString(string text);
public abstract void WriteSurrogateCharEntity(char lowChar, char highChar);
public abstract void WriteWhitespace(string ws);

Property
public abstract WriteState WriteState {get;}
public abstract string XmlLang {get;}
public abstract XmlSpace XmlSpace {get;}

System.Xml.WriteState

Module:System.Xml.dll

Hierarchy
Object
ValueType
Enum
WriteState

Type declaration

[C#] public enum WriteState;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const WriteState Attribute = 3;
public const WriteState Closed = 5;
public const WriteState Content = 4;
public const WriteState Element = 2;
public const WriteState Prolog = 1;
public const WriteState Start = 0;
public int value__;

System.Xml.Formatting

Module:System.Xml.dll

Hierarchy
Object
ValueType
Enum
Formatting

Type declaration

[C#] public enum Formatting;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const Formatting Indented = 1;
public const Formatting None = 0;
public int value__;

System.Xml.XmlException

Module:System.Xml.dll

Hierarchy
Object
Exception
SystemException
XmlException

Type declaration

[C#] public class XmlException : SystemException;

Constructor
public XmlException();
protected XmlException(SerializationInfo info, StreamingContext context);
public XmlException(string message);
public XmlException(string message, Exception innerException);
public XmlException(string message, Exception innerException, int lineNumber, int linePosition);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public override void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public int LineNumber {get;}
public int LinePosition {get;}
public override string Message {get;}
public string Source {get; set;}
public string StackTrace {get;}
public MethodBase TargetSite {get;}

System.Xml.ReadState

Module:System.Xml.dll

Hierarchy
Object
ValueType
Enum
ReadState

Type declaration

[C#] public enum ReadState;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const ReadState Closed = 4;
public const ReadState EndOfFile = 3;
public const ReadState Error = 2;
public const ReadState Initial = 0;
public const ReadState Interactive = 1;
public int value__;

System.Xml.XmlNamespaceManager

Module:System.Xml.dll

Hierarchy
Object
XmlNamespaceManager : IEnumerable

Type declaration

[C#] public class XmlNamespaceManager: IEnumerable;

Constructor
public XmlNamespaceManager(XmlNameTable nameTable);

Method
public virtual void AddNamespace(string prefix, string uri);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual IEnumerator GetEnumerator();
public virtual int GetHashCode();
public Type GetType();
public virtual bool HasNamespace(string prefix);
public virtual string LookupNamespace(string prefix);
public virtual string LookupPrefix(string uri);
protected object MemberwiseClone();
public virtual bool PopScope();
public virtual void PushScope();
public virtual void RemoveNamespace(string prefix, string uri);
public virtual string ToString();

Property
public virtual string DefaultNamespace {get;}
public XmlNameTable NameTable {get;}

System.Xml.XmlNameTable

Module:System.Xml.dll

Hierarchy
Object
XmlNameTable

Type declaration

[C#] public abstract class XmlNameTable;

Constructor
protected XmlNameTable();

Method
public abstract string Add(char[] array, int offset, int length);
public abstract string Add(string array);
public virtual bool Equals(object obj);
protected override void Finalize();
public abstract string Get(char[] array, int offset, int length);
public abstract string Get(string array);
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

System.Xml.XmlSpace

Module:System.Xml.dll

Hierarchy
Object
ValueType
Enum
XmlSpace

Type declaration

[C#] public enum XmlSpace;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const XmlSpace Default = 1;
public const XmlSpace None = 0;
public const XmlSpace Preserve = 2;
public int value__;

System.Xml.XmlNodeType

Module:System.Xml.dll

Hierarchy
Object
ValueType
Enum
XmlNodeType

Type declaration

[C#] public enum XmlNodeType;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const XmlNodeType Attribute = 2;
public const XmlNodeType CDATA = 4;
public const XmlNodeType Comment = 8;
public const XmlNodeType Document = 9;
public const XmlNodeType DocumentFragment = 11;
public const XmlNodeType DocumentType = 10;
public const XmlNodeType Element = 1;
public const XmlNodeType EndElement = 15;
public const XmlNodeType EndEntity = 16;
public const XmlNodeType Entity = 6;
public const XmlNodeType EntityReference = 5;
public const XmlNodeType None = 0;
public const XmlNodeType Notation = 12;
public const XmlNodeType ProcessingInstruction = 7;
public const XmlNodeType SignificantWhitespace = 14;
public const XmlNodeType Text = 3;
public int value__;
public const XmlNodeType Whitespace = 13;
public const XmlNodeType XmlDeclaration = 17;

System.Xml.XmlReader

Module:System.Xml.dll

Hierarchy
Object
XmlReader

Type declaration

[C#] public abstract class XmlReader;

Constructor
protected XmlReader();

Method
public abstract void Close();
public virtual bool Equals(object obj);
protected override void Finalize();
public abstract string GetAttribute(int i);
public abstract string GetAttribute(string name);
public abstract string GetAttribute(string name, string namespaceUri);
public virtual int GetHashCode();
public Type GetType();
public static bool IsName(string str);
public static bool IsNameToken(string str);
public virtual bool IsStartElement();
public virtual bool IsStartElement(string name);
public virtual bool IsStartElement(string localname, string ns);
public abstract string LookupNamespace(string prefix);
protected object MemberwiseClone();
public abstract void MoveToAttribute(int i);
public abstract bool MoveToAttribute(string name);
public abstract bool MoveToAttribute(string name, string ns);
public virtual XmlNodeType MoveToContent();
public abstract bool MoveToElement();
public abstract bool MoveToFirstAttribute();
public abstract bool MoveToNextAttribute();
public abstract bool Read();
public abstract bool ReadAttributeValue();
public virtual string ReadElementString();
public virtual string ReadElementString(string name);
public virtual string ReadElementString(string localname, string ns);
public virtual void ReadEndElement();
public abstract string ReadInnerXml();
public abstract string ReadOuterXml();
public virtual void ReadStartElement();
public virtual void ReadStartElement(string name);
public virtual void ReadStartElement(string localname, string ns);
public abstract string ReadString();
public abstract void ResolveEntity();
public virtual void Skip();
public virtual string ToString();

Property
public abstract int AttributeCount {get;}
public abstract string BaseURI {get;}
public virtual bool CanResolveEntity {get;}
public abstract int Depth {get;}
public abstract bool EOF {get;}
public virtual bool HasAttributes {get;}
public abstract bool HasValue {get;}
public abstract bool IsDefault {get;}
public abstract bool IsEmptyElement {get;}
public abstract string this[int i] {get;}
public abstract string this[string name, string namespaceUri] {get;}
public abstract string this[string name] {get;}
public abstract string LocalName {get;}
public abstract string Name {get;}
public abstract string NamespaceURI {get;}
public abstract XmlNameTable NameTable {get;}
public abstract XmlNodeType NodeType {get;}
public abstract string Prefix {get;}
public abstract char QuoteChar {get;}
public abstract ReadState ReadState {get;}
public abstract string Value {get;}
public abstract string XmlLang {get;}
public abstract XmlSpace XmlSpace {get;}

System.Xml.Serialization.XmlAnyElementAttribute

Module:System.Xml.dll

Hierarchy
Object
Attribute
XmlAnyElementAttribute

Type declaration

[C#] public class XmlAnyElementAttribute : Attribute;

Constructor
public XmlAnyElementAttribute();
public XmlAnyElementAttribute(string name);
public XmlAnyElementAttribute(string name, string ns);

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public string Name {get; set;}
public string Namespace {get; set;}
public object TypeId {get;}

System.Xml.Serialization.XmlAnyAttributeAttribute

Module:System.Xml.dll

Hierarchy
Object
Attribute
XmlAnyAttributeAttribute

Type declaration

[C#] public class XmlAnyAttributeAttribute : Attribute;

Constructor
public XmlAnyAttributeAttribute();

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public object TypeId {get;}

System.Xml.Serialization.XmlTypeAttribute

Module:System.Xml.dll

Hierarchy
Object
Attribute
XmlTypeAttribute

Type declaration

[C#] public class XmlTypeAttribute : Attribute;

Constructor
public XmlTypeAttribute();
public XmlTypeAttribute(string typeName);

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public bool IncludeInSchema {get; set;}
public string Namespace {get; set;}
public object TypeId {get;}
public string TypeName {get; set;}

System.Xml.Serialization.XmlTextAttribute

Module:System.Xml.dll

Hierarchy
Object
Attribute
XmlTextAttribute

Type declaration

[C#] public class XmlTextAttribute : Attribute;

Constructor
public XmlTextAttribute();
public XmlTextAttribute(Type type);

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public string DataType {get; set;}
public Type Type {get; set;}
public object TypeId {get;}

System.Xml.Serialization.XmlSerializerNamespaces

Module:System.Xml.dll

Hierarchy
Object
XmlSerializerNamespaces

Type declaration

[C#] public class XmlSerializerNamespaces;

Constructor
public XmlSerializerNamespaces();
public XmlSerializerNamespaces(XmlQualifiedName[] namespaces);
public XmlSerializerNamespaces(XmlSerializerNamespaces namespaces);

Method
public void Add(string prefix, string ns);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public XmlQualifiedName[] ToArray();
public virtual string ToString();

Property
public int Count {get;}

System.Xml.Serialization.XmlRootAttribute

Module:System.Xml.dll

Hierarchy
Object
Attribute
XmlRootAttribute

Type declaration

[C#] public class XmlRootAttribute : Attribute;

Constructor
public XmlRootAttribute();
public XmlRootAttribute(string elementName);

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public string DataType {get; set;}
public string ElementName {get; set;}
public bool IsNullable {get; set;}
public bool IsNullableSpecified {get;}
public string Namespace {get; set;}
public object TypeId {get;}

System.Xml.Serialization.XmlNamespaceDeclarationsAttribute

Module:System.Xml.dll

Hierarchy
Object
Attribute
XmlNamespaceDeclarationsAttribute

Type declaration

[C#] public class XmlNamespaceDeclarationsAttribute : Attribute;

Constructor
public XmlNamespaceDeclarationsAttribute();

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public object TypeId {get;}

System.Xml.Serialization.XmlIncludeAttribute

Module:System.Xml.dll

Hierarchy
Object
Attribute
XmlIncludeAttribute

Type declaration

[C#] public class XmlIncludeAttribute : Attribute;

Constructor
public XmlIncludeAttribute(Type type);

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public Type Type {get; set;}
public object TypeId {get;}

System.Xml.Serialization.XmlIgnoreAttribute

Module:System.Xml.dll

Hierarchy
Object
Attribute
XmlIgnoreAttribute

Type declaration

[C#] public class XmlIgnoreAttribute : Attribute;

Constructor
public XmlIgnoreAttribute();

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public object TypeId {get;}

System.Xml.Serialization.XmlEnumAttribute

Module:System.Xml.dll

Hierarchy
Object
Attribute
XmlEnumAttribute

Type declaration

[C#] public class XmlEnumAttribute : Attribute;

Constructor
public XmlEnumAttribute();
public XmlEnumAttribute(string name);

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public string Name {get; set;}
public object TypeId {get;}

System.Xml.Serialization.XmlElementAttribute

Module:System.Xml.dll

Hierarchy
Object
Attribute
XmlElementAttribute

Type declaration

[C#] public class XmlElementAttribute : Attribute;

Constructor
public XmlElementAttribute();
public XmlElementAttribute(string elementName);
public XmlElementAttribute(string elementName, Type type);
public XmlElementAttribute(Type type);

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public string DataType {get; set;}
public string ElementName {get; set;}
public XmlSchemaForm Form {get; set;}
public bool IsNullable {get; set;}
public string Namespace {get; set;}
public Type Type {get; set;}
public object TypeId {get;}

System.Xml.Serialization.XmlChoiceIdentifierAttribute

Module:System.Xml.dll

Hierarchy
Object
Attribute
XmlChoiceIdentifierAttribute

Type declaration

[C#] public class XmlChoiceIdentifierAttribute : Attribute;

Constructor
public XmlChoiceIdentifierAttribute();
public XmlChoiceIdentifierAttribute(string name);

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public string MemberName {get; set;}
public object TypeId {get;}

System.Xml.Serialization.XmlAttributeAttribute

Module:System.Xml.dll

Hierarchy
Object
Attribute
XmlAttributeAttribute

Type declaration

[C#] public class XmlAttributeAttribute : Attribute;

Constructor
public XmlAttributeAttribute();
public XmlAttributeAttribute(string attributeName);
public XmlAttributeAttribute(string attributeName, Type type);
public XmlAttributeAttribute(Type type);

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public string AttributeName {get; set;}
public string DataType {get; set;}
public XmlSchemaForm Form {get; set;}
public string Namespace {get; set;}
public Type Type {get; set;}
public object TypeId {get;}

System.Xml.Serialization.XmlArrayItemAttribute

Module:System.Xml.dll

Hierarchy
Object
Attribute
XmlArrayItemAttribute

Type declaration

[C#] public class XmlArrayItemAttribute : Attribute;

Constructor
public XmlArrayItemAttribute();
public XmlArrayItemAttribute(string elementName);
public XmlArrayItemAttribute(string elementName, Type type);
public XmlArrayItemAttribute(Type type);

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public string DataType {get; set;}
public string ElementName {get; set;}
public XmlSchemaForm Form {get; set;}
public bool IsNullable {get; set;}
public bool IsNullableSpecified {get;}
public string Namespace {get; set;}
public int NestingLevel {get; set;}
public Type Type {get; set;}
public object TypeId {get;}

System.Xml.Serialization.XmlArrayAttribute

Module:System.Xml.dll

Hierarchy
Object
Attribute
XmlArrayAttribute

Type declaration

[C#] public class XmlArrayAttribute : Attribute;

Constructor
public XmlArrayAttribute();
public XmlArrayAttribute(string elementName);

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public string ElementName {get; set;}
public XmlSchemaForm Form {get; set;}
public bool IsNullable {get; set;}
public string Namespace {get; set;}
public object TypeId {get;}

System.Xml.Serialization.SoapTypeAttribute

Module:System.Xml.dll

Hierarchy
Object
Attribute
SoapTypeAttribute

Type declaration

[C#] public class SoapTypeAttribute : Attribute;

Constructor
public SoapTypeAttribute();
public SoapTypeAttribute(string typeName);
public SoapTypeAttribute(string typeName, string ns);

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public bool IncludeInSchema {get; set;}
public string Namespace {get; set;}
public object TypeId {get;}
public string TypeName {get; set;}

System.Xml.Serialization.SoapIncludeAttribute

Module:System.Xml.dll

Hierarchy
Object
Attribute
SoapIncludeAttribute

Type declaration

[C#] public class SoapIncludeAttribute : Attribute;

Constructor
public SoapIncludeAttribute(Type type);

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public Type Type {get; set;}
public object TypeId {get;}

System.Xml.Serialization.SoapIgnoreAttribute

Module:System.Xml.dll

Hierarchy
Object
Attribute
SoapIgnoreAttribute

Type declaration

[C#] public class SoapIgnoreAttribute : Attribute;

Constructor
public SoapIgnoreAttribute();

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public object TypeId {get;}

System.Xml.Serialization.SoapEnumAttribute

Module:System.Xml.dll

Hierarchy
Object
Attribute
SoapEnumAttribute

Type declaration

[C#] public class SoapEnumAttribute : Attribute;

Constructor
public SoapEnumAttribute();
public SoapEnumAttribute(string name);

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public string Name {get; set;}
public object TypeId {get;}

System.Xml.Serialization.SoapElementAttribute

Module:System.Xml.dll

Hierarchy
Object
Attribute
SoapElementAttribute

Type declaration

[C#] public class SoapElementAttribute : Attribute;

Constructor
public SoapElementAttribute();
public SoapElementAttribute(string elementName);

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public string DataType {get; set;}
public string ElementName {get; set;}
public bool IsNullable {get; set;}
public object TypeId {get;}

System.Xml.Serialization.SoapAttributeAttribute

Module:System.Xml.dll

Hierarchy
Object
Attribute
SoapAttributeAttribute

Type declaration

[C#] public class SoapAttributeAttribute : Attribute;

Constructor
public SoapAttributeAttribute();
public SoapAttributeAttribute(string attrName);

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public string AttributeName {get; set;}
public string DataType {get; set;}
public string Namespace {get; set;}
public object TypeId {get;}

System.Xml.Serialization.IXmlSerializable

Module:System.Xml.dll

Hierarchy
IXmlSerializable

Type declaration

[C#] public interface IXmlSerializable;

Method
public XmlSchema GetSchema();
public void ReadXml(XmlReader reader);
public void WriteXml(XmlWriter writer);

System.Xml.Schema.XmlSchemaException

Module:System.Xml.dll

Hierarchy
Object
Exception
SystemException
XmlSchemaException

Type declaration

[C#] public class XmlSchemaException : SystemException;

Constructor
public XmlSchemaException();
protected XmlSchemaException(SerializationInfo info, StreamingContext context);
public XmlSchemaException(string s);
public XmlSchemaException(string s, Exception innerException);

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public override void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public int LineNumber {get;}
public int LinePosition {get;}
public virtual string Message {get;}
public string Source {get; set;}
public XmlSchemaObject SourceSchemaObject {get;}
public string SourceUri {get;}
public string StackTrace {get;}
public MethodBase TargetSite {get;}

System.Xml.Schema.XmlSchema

Module:System.Xml.dll

Hierarchy
Object
XmlSchemaObject
XmlSchema

Type declaration

[C#] public class XmlSchema : XmlSchemaObject;

Constructor
public XmlSchema();

Method
public void Compile(ValidationEventHandler validationEventHandler);
public void Compile(ValidationEventHandler validationEventHandler, XmlResolver resolver);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public static XmlSchema Read(Stream stream, ValidationEventHandler validationEventHandler);
public static XmlSchema Read(TextReader reader, ValidationEventHandler validationEventHandler);
public static XmlSchema Read(XmlReader reader, ValidationEventHandler validationEventHandler);
public virtual string ToString();
public void Write(Stream stream);
public void Write(Stream stream, XmlNamespaceManager namespaceManager);
public void Write(TextWriter writer);
public void Write(TextWriter writer, XmlNamespaceManager namespaceManager);
public void Write(XmlWriter writer);
public void Write(XmlWriter writer, XmlNamespaceManager namespaceManager);

Property
public XmlSchemaForm AttributeFormDefault {get; set;}
public XmlSchemaObjectTable AttributeGroups {get;}
public XmlSchemaObjectTable Attributes {get;}
public XmlSchemaDerivationMethod BlockDefault {get; set;}
public XmlSchemaForm ElementFormDefault {get; set;}
public XmlSchemaObjectTable Elements {get;}
public XmlSchemaDerivationMethod FinalDefault {get; set;}
public XmlSchemaObjectTable Groups {get;}
public string Id {get; set;}
public XmlSchemaObjectCollection Includes {get;}
public bool IsCompiled {get;}
public XmlSchemaObjectCollection Items {get;}
public int LineNumber {get; set;}
public int LinePosition {get; set;}
public XmlSerializerNamespaces Namespaces {get; set;}
public XmlSchemaObjectTable Notations {get;}
public XmlSchemaObjectTable SchemaTypes {get;}
public string SourceUri {get; set;}
public string TargetNamespace {get; set;}
public XmlAttribute[] UnhandledAttributes {get; set;}
public string Version {get; set;}

Field
public const string InstanceNamespace = "http://www.w3.org/2001/XMLSchema-instance";
public const string Namespace = "http://www.w3.org/2001/XMLSchema";

System.Xml.Schema.XmlSchemaObject

Module:System.Xml.dll

Hierarchy
Object
XmlSchemaObject

Type declaration

[C#] public abstract class XmlSchemaObject;

Constructor
protected XmlSchemaObject();

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public int LineNumber {get; set;}
public int LinePosition {get; set;}
public XmlSerializerNamespaces Namespaces {get; set;}
public string SourceUri {get; set;}

Microsoft.VisualBasic.CompilerServices.ProjectData

Module:Microsoft.VisualBasic.dll

Hierarchy
Object
ProjectData

Type declaration

[C#] public sealed class ProjectData;

Method
public static void ClearProjectError();
public static Exception CreateProjectError(int hr);
public static void EndApp();
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public static void SetProjectError(Exception ex);
public static void SetProjectError(Exception ex, int lErl);
public virtual string ToString();

Microsoft.VisualBasic.CompilerServices.IncompleteInitialization

Module:Microsoft.VisualBasic.dll

Hierarchy
Object
Exception
IncompleteInitialization

Type declaration

[C#] public sealed class IncompleteInitialization : Exception;

Constructor
public IncompleteInitialization();

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual Exception GetBaseException();
public virtual int GetHashCode();
public void GetObjectData(SerializationInfo info, StreamingContext context);
public Type GetType();
protected object MemberwiseClone();
public override string ToString();

Property
public string HelpLink {get; set;}
protected int HResult {get; set;}
public Exception InnerException {get;}
public virtual string Message {get;}
public string Source {get; set;}
public string StackTrace {get;}
public MethodBase TargetSite {get;}

Microsoft.VisualBasic.CompilerServices.StaticLocalInitFlag

Module:Microsoft.VisualBasic.dll

Hierarchy
Object
StaticLocalInitFlag

Type declaration

[C#] public sealed class StaticLocalInitFlag;

Constructor
public StaticLocalInitFlag();

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Field
public short State;

Microsoft.VisualBasic.CompilerServices.UnsafeNativeMethods+tagVARDESC

Module:Microsoft.VisualBasic.dll

Hierarchy
Object
ValueType
UnsafeNativeMethods+tagVARDESC

Type declaration

[C#] public struct tagVARDESC : ValueType;

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Field
public value_tagELEMDESC elemdescVar;
public IntPtr lpstrSchema;
public int memid;
public IntPtr unionMember;
public int varkind;
public short wVarFlags;

Microsoft.VisualBasic.CompilerServices.UnsafeNativeMethods+tagPARAMDESC

Module:Microsoft.VisualBasic.dll

Hierarchy
Object
ValueType
UnsafeNativeMethods+tagPARAMDESC

Type declaration

[C#] public struct tagPARAMDESC : ValueType;

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Field
public IntPtr pparamdescex;
public short wParamFlags;

Microsoft.VisualBasic.CompilerServices.UnsafeNativeMethods+tagTYPEDESC

Module:Microsoft.VisualBasic.dll

Hierarchy
Object
UnsafeNativeMethods+tagTYPEDESC

Type declaration

[C#] public sealed class tagTYPEDESC;

Constructor
public tagTYPEDESC();

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Field
public IntPtr unionMember;
public short vt;

Microsoft.VisualBasic.CompilerServices.UnsafeNativeMethods+value_tagELEMDESC

Module:Microsoft.VisualBasic.dll

Hierarchy
Object
ValueType
UnsafeNativeMethods+value_tagELEMDESC

Type declaration

[C#] public struct value_tagELEMDESC : ValueType;

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Field
public tagPARAMDESC paramdesc;
public tagTYPEDESC tdesc;

Microsoft.VisualBasic.CompilerServices.UnsafeNativeMethods+tagFUNCDESC

Module:Microsoft.VisualBasic.dll

Hierarchy
Object
ValueType
UnsafeNativeMethods+tagFUNCDESC

Type declaration

[C#] public struct tagFUNCDESC : ValueType;

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Field
public int callconv;
public short cParams;
public short cParamsOpt;
public short cScodes;
public value_tagELEMDESC elemdescFunc;
public int funckind;
public int invkind;
public IntPtr lprgelemdescParam;
public short lprgscode;
public int memid;
public short oVft;
public short wFuncFlags;

Microsoft.VisualBasic.CompilerServices.UnsafeNativeMethods+tagTLIBATTR

Module:Microsoft.VisualBasic.dll

Hierarchy
Object
ValueType
UnsafeNativeMethods+tagTLIBATTR

Type declaration

[C#] public struct tagTLIBATTR : ValueType;

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Field
public Guid guid;
public int lcid;
public tagSYSKIND syskind;
public short wLibFlags;
public short wMajorVerNum;
public short wMinorVerNum;

Microsoft.VisualBasic.CompilerServices.UnsafeNativeMethods+tagSYSKIND

Module:Microsoft.VisualBasic.dll

Hierarchy
Object
ValueType
Enum
UnsafeNativeMethods+tagSYSKIND

Type declaration

[C#] public enum tagSYSKIND;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const tagSYSKIND SYS_MAC = 2;
public const tagSYSKIND SYS_WIN16 = 0;
public int value__;

Microsoft.VisualBasic.CompilerServices.UnsafeNativeMethods+tagTYPEKIND

Module:Microsoft.VisualBasic.dll

Hierarchy
Object
ValueType
Enum
UnsafeNativeMethods+tagTYPEKIND

Type declaration

[C#] public enum tagTYPEKIND;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const tagTYPEKIND TKIND_ALIAS = 6;
public const tagTYPEKIND TKIND_COCLASS = 5;
public const tagTYPEKIND TKIND_DISPATCH = 4;
public const tagTYPEKIND TKIND_ENUM = 0;
public const tagTYPEKIND TKIND_INTERFACE = 3;
public const tagTYPEKIND TKIND_MAX = 8;
public const tagTYPEKIND TKIND_MODULE = 2;
public const tagTYPEKIND TKIND_RECORD = 1;
public const tagTYPEKIND TKIND_UNION = 7;
public int value__;

Microsoft.VisualBasic.CompilerServices.UnsafeNativeMethods+tagDESCKIND

Module:Microsoft.VisualBasic.dll

Hierarchy
Object
ValueType
Enum
UnsafeNativeMethods+tagDESCKIND

Type declaration

[C#] public enum tagDESCKIND;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const tagDESCKIND DESCKIND_FUNCDESC = 1;
public const tagDESCKIND DESCKIND_IMPLICITAPPOBJ = 4;
public const tagDESCKIND DESCKIND_MAX = 5;
public const tagDESCKIND DESCKIND_NONE = 0;
public const tagDESCKIND DESCKIND_TYPECOMP = 3;
public const tagDESCKIND DESCKIND_VARDESC = 2;
public int value__;

Microsoft.VisualBasic.CompilerServices.UnsafeNativeMethods+tagINVOKEKIND

Module:Microsoft.VisualBasic.dll

Hierarchy
Object
ValueType
Enum
UnsafeNativeMethods+tagINVOKEKIND

Type declaration

[C#] public enum tagINVOKEKIND;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const tagINVOKEKIND INVOKE_FUNC = 1;
public const tagINVOKEKIND INVOKE_PROPERTYGET = 2;
public const tagINVOKEKIND INVOKE_PROPERTYPUT = 4;
public const tagINVOKEKIND INVOKE_PROPERTYPUTREF = 8;
public int value__;

Microsoft.VisualBasic.CompilerServices.HostServices

Module:Microsoft.VisualBasic.dll

Hierarchy
Object
HostServices

Type declaration

[C#] public sealed class HostServices;

Constructor
public HostServices();

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Property
public static IVbHost VBHost {get; set;}

Microsoft.VisualBasic.CompilerServices.IVbHost

Module:Microsoft.VisualBasic.dll

Hierarchy
IVbHost

Type declaration

[C#] public interface IVbHost;

Method
public IWin32Window GetParentWindow();
public string GetWindowTitle();

Microsoft.VisualBasic.CompilerServices.OptionCompareAttribute

Module:Microsoft.VisualBasic.dll

Hierarchy
Object
Attribute
OptionCompareAttribute

Type declaration

[C#] public sealed class OptionCompareAttribute : Attribute;

Constructor
public OptionCompareAttribute();

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public object TypeId {get;}

Microsoft.VisualBasic.CompilerServices.OptionTextAttribute

Module:Microsoft.VisualBasic.dll

Hierarchy
Object
Attribute
OptionTextAttribute

Type declaration

[C#] public sealed class OptionTextAttribute : Attribute;

Constructor
public OptionTextAttribute();

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public object TypeId {get;}

Microsoft.VisualBasic.CompilerServices.StandardModuleAttribute

Module:Microsoft.VisualBasic.dll

Hierarchy
Object
Attribute
StandardModuleAttribute

Type declaration

[C#] public sealed class StandardModuleAttribute : Attribute;

Constructor
public StandardModuleAttribute();

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public object TypeId {get;}

Microsoft.VisualBasic.CompilerServices.Utils

Module:Microsoft.VisualBasic.dll

Hierarchy
Object
Utils

Type declaration

[C#] public sealed class Utils;

Method
public static Array CopyArray(Array arySrc, Array aryDest);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public static string MethodToString(MethodBase Method);
public static object SetCultureInfo(CultureInfo Culture);
public static void ThrowException(int hr);
public virtual string ToString();

Microsoft.VisualBasic.CompilerServices.StringType

Module:Microsoft.VisualBasic.dll

Hierarchy
Object
StringType

Type declaration

[C#] public sealed class StringType;

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public static string FromBoolean(bool Value);
public static string FromByte(byte Value);
public static string FromChar(char Value);
public static string FromDate(DateTime Value);
public static string FromDecimal(decimal Value);
public static string FromDecimal(decimal Value, NumberFormatInfo NumberFormat);
public static string FromDouble(double Value);
public static string FromDouble(double Value, NumberFormatInfo NumberFormat);
public static string FromInteger(int Value);
public static string FromLong(long Value);
public static string FromObject(object Value);
public static string FromShort(short Value);
public static string FromSingle(float Value);
public static string FromSingle(float Value, NumberFormatInfo NumberFormat);
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public static void MidStmtStr(ref string sDest, int StartPosition, int MaxInsertLength, string sInsert);
public static int StrCmp(string sLeft, string sRight, bool TextCompare);
public static bool StrLike(string Source, string Pattern, CompareMethod CompareOption);
public static bool StrLikeBinary(string Source, string Pattern);
public static bool StrLikeText(string Source, string Pattern);
public virtual string ToString();

Microsoft.VisualBasic.CompilerServices.CharType

Module:Microsoft.VisualBasic.dll

Hierarchy
Object
CharType

Type declaration

[C#] public sealed class CharType;

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public static char FromObject(object Value);
public static char FromString(string Value);
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Microsoft.VisualBasic.CompilerServices.ExceptionUtils

Module:Microsoft.VisualBasic.dll

Hierarchy
Object
ExceptionUtils

Type declaration

[C#] public sealed class ExceptionUtils;

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Microsoft.VisualBasic.CompilerServices.DecimalType

Module:Microsoft.VisualBasic.dll

Hierarchy
Object
DecimalType

Type declaration

[C#] public sealed class DecimalType;

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public static decimal FromBoolean(bool Value);
public static decimal FromObject(object Value);
public static decimal FromObject(object Value, NumberFormatInfo NumberFormat);
public static decimal FromString(string Value);
public static decimal FromString(string Value, NumberFormatInfo NumberFormat);
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public static decimal Parse(string Value, NumberFormatInfo NumberFormat);
public virtual string ToString();

Microsoft.VisualBasic.CompilerServices.FlowControl

Module:Microsoft.VisualBasic.dll

Hierarchy
Object
FlowControl

Type declaration

[C#] public sealed class FlowControl;

Method
public static void CheckForSyncLockOnValueType(object obj);
public virtual bool Equals(object obj);
protected override void Finalize();
public static IEnumerator ForEachInArr(Array ary);
public static IEnumerator ForEachInObj(object obj);
public static bool ForEachNextObj(ref object obj, IEnumerator enumerator);
public static bool ForLoopInitObj(object Counter, object Start, object Limit, object StepValue, ref object LoopForResult, ref object CounterResult);
public static bool ForNextCheckDec(decimal count, decimal limit, decimal StepValue);
public static bool ForNextCheckObj(object Counter, object LoopObj, ref object CounterResult);
public static bool ForNextCheckR4(float count, float limit, float StepValue);
public static bool ForNextCheckR8(double count, double limit, double StepValue);
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Microsoft.VisualBasic.CompilerServices.BooleanType

Module:Microsoft.VisualBasic.dll

Hierarchy
Object
BooleanType

Type declaration

[C#] public sealed class BooleanType;

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public static bool FromObject(object Value);
public static bool FromString(string Value);
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Microsoft.VisualBasic.CompilerServices.ByteType

Module:Microsoft.VisualBasic.dll

Hierarchy
Object
ByteType

Type declaration

[C#] public sealed class ByteType;

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public static byte FromObject(object Value);
public static byte FromString(string Value);
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Microsoft.VisualBasic.CompilerServices.CharArrayType

Module:Microsoft.VisualBasic.dll

Hierarchy
Object
CharArrayType

Type declaration

[C#] public sealed class CharArrayType;

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public static char[] FromObject(object Value);
public static char[] FromString(string Value);
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Microsoft.VisualBasic.CompilerServices.DateType

Module:Microsoft.VisualBasic.dll

Hierarchy
Object
DateType

Type declaration

[C#] public sealed class DateType;

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public static DateTime FromObject(object Value);
public static DateTime FromString(string Value);
public static DateTime FromString(string Value, CultureInfo culture);
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Microsoft.VisualBasic.CompilerServices.IntegerType

Module:Microsoft.VisualBasic.dll

Hierarchy
Object
IntegerType

Type declaration

[C#] public sealed class IntegerType;

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public static int FromObject(object Value);
public static int FromString(string Value);
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Microsoft.VisualBasic.CompilerServices.ShortType

Module:Microsoft.VisualBasic.dll

Hierarchy
Object
ShortType

Type declaration

[C#] public sealed class ShortType;

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public static short FromObject(object Value);
public static short FromString(string Value);
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Microsoft.VisualBasic.CompilerServices.LongType

Module:Microsoft.VisualBasic.dll

Hierarchy
Object
LongType

Type declaration

[C#] public sealed class LongType;

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public static long FromObject(object Value);
public static long FromString(string Value);
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Microsoft.VisualBasic.CompilerServices.SingleType

Module:Microsoft.VisualBasic.dll

Hierarchy
Object
SingleType

Type declaration

[C#] public sealed class SingleType;

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public static float FromObject(object Value);
public static float FromObject(object Value, NumberFormatInfo NumberFormat);
public static float FromString(string Value);
public static float FromString(string Value, NumberFormatInfo NumberFormat);
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Microsoft.VisualBasic.CompilerServices.DoubleType

Module:Microsoft.VisualBasic.dll

Hierarchy
Object
DoubleType

Type declaration

[C#] public sealed class DoubleType;

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public static double FromObject(object Value);
public static double FromObject(object Value, NumberFormatInfo NumberFormat);
public static double FromString(string Value);
public static double FromString(string Value, NumberFormatInfo NumberFormat);
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public static double Parse(string Value);
public static double Parse(string Value, NumberFormatInfo NumberFormat);
public virtual string ToString();

Microsoft.VisualBasic.CompilerServices.ObjectType

Module:Microsoft.VisualBasic.dll

Hierarchy
Object
ObjectType

Type declaration

[C#] public sealed class ObjectType;

Constructor
public ObjectType();

Method
public static object AddObj(object o1, object o2);
public static object BitAndObj(object obj1, object obj2);
public static object BitOrObj(object obj1, object obj2);
public static object BitXorObj(object obj1, object obj2);
public static object DivObj(object o1, object o2);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public static object GetObjectValuePrimitive(object o);
public Type GetType();
public static object IDivObj(object o1, object o2);
public static bool LikeObj(object vLeft, object vRight, CompareMethod CompareOption);
protected object MemberwiseClone();
public static object ModObj(object o1, object o2);
public static object MulObj(object o1, object o2);
public static object NegObj(object obj);
public static object NotObj(object obj);
public static int ObjTst(object o1, object o2, bool TextCompare);
public static object PlusObj(object obj);
public static object PowObj(object obj1, object obj2);
public static object ShiftLeftObj(object o1, int amount);
public static object ShiftRightObj(object o1, int amount);
public static object StrCatObj(object vLeft, object vRight);
public static object SubObj(object o1, object o2);
public virtual string ToString();
public static object XorObj(object obj1, object obj2);

Microsoft.VisualBasic.ControlChars

Module:Microsoft.VisualBasic.dll

Hierarchy
Object
ControlChars

Type declaration

[C#] public sealed class ControlChars;

Constructor
public ControlChars();

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Field
public const char Back = 0x0008;
public const char Cr = 0x000D;
public const string CrLf = "__";
public const char FormFeed = 0x000C;
public const char Lf = 0x000A;
public const string NewLine = "__";
public const char NullChar = 0x0000;
public const char Quote = 0x0022;
public const char Tab = 0x0009;
public const char VerticalTab = 0x000B;

Microsoft.VisualBasic.Constants

Module:Microsoft.VisualBasic.dll

Hierarchy
Object
Constants

Type declaration

[C#] public sealed class Constants;

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Field
public const MsgBoxResult vbAbort = 3;
public const MsgBoxStyle vbAbortRetryIgnore = 2;
public const MsgBoxStyle vbApplicationModal = 0;
public const FileAttribute vbArchive = 32;
public const VariantType vbArray = 8192;
public const string vbBack = "_";
public const CompareMethod vbBinaryCompare = 0;
public const VariantType vbBoolean = 11;
public const VariantType vbByte = 17;
public const MsgBoxResult vbCancel = 2;
public const string vbCr = "_";
public const MsgBoxStyle vbCritical = 16;
public const string vbCrLf = "__";
public const VariantType vbCurrency = 6;
public const VariantType vbDate = 7;
public const VariantType vbDecimal = 14;
public const MsgBoxStyle vbDefaultButton1 = 0;
public const MsgBoxStyle vbDefaultButton2 = 256;
public const MsgBoxStyle vbDefaultButton3 = 512;
public const FileAttribute vbDirectory = 16;
public const VariantType vbDouble = 5;
public const VariantType vbEmpty = 0;
public const MsgBoxStyle vbExclamation = 48;
public const TriState vbFalse = 0;
public const FirstWeekOfYear vbFirstFourDays = 2;
public const FirstWeekOfYear vbFirstFullWeek = 3;
public const FirstWeekOfYear vbFirstJan1 = 1;
public const string vbFormFeed = "_";
public const FirstDayOfWeek vbFriday = 6;
public const DateFormat vbGeneralDate = 0;
public const CallType vbGet = 2;
public const FileAttribute vbHidden = 2;
public const AppWinStyle vbHide = 0;
public const VbStrConv vbHiragana = 32;
public const MsgBoxResult vbIgnore = 5;
public const MsgBoxStyle vbInformation = 64;
public const VariantType vbInteger = 3;
public const VbStrConv vbKatakana = 16;
public const CallType vbLet = 4;
public const string vbLf = "_";
public const VbStrConv vbLinguisticCasing = 1024;
public const VariantType vbLong = 20;
public const DateFormat vbLongDate = 1;
public const DateFormat vbLongTime = 3;
public const VbStrConv vbLowerCase = 2;
public const AppWinStyle vbMaximizedFocus = 3;
public const CallType vbMethod = 1;
public const AppWinStyle vbMinimizedFocus = 2;
public const AppWinStyle vbMinimizedNoFocus = 6;
public const FirstDayOfWeek vbMonday = 2;
public const MsgBoxStyle vbMsgBoxHelp = 16384;
public const MsgBoxStyle vbMsgBoxRight = 524288;
public const MsgBoxStyle vbMsgBoxRtlReading = 1048576;
public const MsgBoxStyle vbMsgBoxSetForeground = 65536;
public const VbStrConv vbNarrow = 8;
public const string vbNewLine = "__";
public const MsgBoxResult vbNo = 7;
public const FileAttribute vbNormal = 0;
public const AppWinStyle vbNormalFocus = 1;
public const AppWinStyle vbNormalNoFocus = 4;
public const VariantType vbNull = 1;
public const string vbNullChar = "";
public const string vbNullString;
public const VariantType vbObject = 9;
public const int vbObjectError = -2147221504;
public const MsgBoxResult vbOK = 1;
public const MsgBoxStyle vbOKCancel = 1;
public const MsgBoxStyle vbOKOnly = 0;
public const VbStrConv vbProperCase = 3;
public const MsgBoxStyle vbQuestion = 32;
public const FileAttribute vbReadOnly = 1;
public const MsgBoxResult vbRetry = 4;
public const MsgBoxStyle vbRetryCancel = 5;
public const FirstDayOfWeek vbSaturday = 7;
public const CallType vbSet = 8;
public const DateFormat vbShortDate = 2;
public const DateFormat vbShortTime = 4;
public const VbStrConv vbSimplifiedChinese = 256;
public const VariantType vbSingle = 4;
public const VariantType vbString = 8;
public const FirstDayOfWeek vbSunday = 1;
public const FileAttribute vbSystem = 4;
public const MsgBoxStyle vbSystemModal = 4096;
public const string vbTab = "_";
public const CompareMethod vbTextCompare = 1;
public const FirstDayOfWeek vbThursday = 5;
public const VbStrConv vbTraditionalChinese = 512;
public const TriState vbTrue = -1;
public const FirstDayOfWeek vbTuesday = 3;
public const VbStrConv vbUpperCase = 1;
public const TriState vbUseDefault = -2;
public const VariantType vbUserDefinedType = 36;
public const FirstWeekOfYear vbUseSystem = 0;
public const FirstDayOfWeek vbUseSystemDayOfWeek = 0;
public const VariantType vbVariant = 12;
public const string vbVerticalTab = "_";
public const FileAttribute vbVolume = 8;
public const FirstDayOfWeek vbWednesday = 4;
public const VbStrConv vbWide = 4;
public const MsgBoxResult vbYes = 6;
public const MsgBoxStyle vbYesNo = 4;
public const MsgBoxStyle vbYesNoCancel = 3;

Microsoft.VisualBasic.VBMath

Module:Microsoft.VisualBasic.dll

Hierarchy
Object
VBMath

Type declaration

[C#] public sealed class VBMath;

Method
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public static void Randomize();
public static void Randomize(double Number);
public static float Rnd();
public static float Rnd(float Number);
public virtual string ToString();

Microsoft.VisualBasic.Strings

Module:Microsoft.VisualBasic.dll

Hierarchy
Object
Strings

Type declaration

[C#] public sealed class Strings;

Method
public static int Asc(char String);
public static int Asc(string String);
public static int AscW(char String);
public static int AscW(string String);
public static char Chr(int CharCode);
public static char ChrW(int CharCode);
public virtual bool Equals(object obj);
public static string[] Filter(object[] Source, string Match, bool Include, CompareMethod Compare);
public static string[] Filter(string[] Source, string Match, bool Include, CompareMethod Compare);
protected override void Finalize();
public static string Format(object Expression, string Style);
public static string FormatCurrency(object Expression, int NumDigitsAfterDecimal, TriState IncludeLeadingDigit, TriState UseParensForNegativeNumbers, TriState GroupDigits);
public static string FormatDateTime(DateTime Expression, DateFormat NamedFormat);
public static string FormatNumber(object Expression, int NumDigitsAfterDecimal, TriState IncludeLeadingDigit, TriState UseParensForNegativeNumbers, TriState GroupDigits);
public static string FormatPercent(object Expression, int NumDigitsAfterDecimal, TriState IncludeLeadingDigit, TriState UseParensForNegativeNumbers, TriState GroupDigits);
public static char GetChar(string str, int Index);
public virtual int GetHashCode();
public Type GetType();
public static int InStr(int Start, string String1, string String2, CompareMethod Compare);
public static int InStr(string String1, string String2, CompareMethod Compare);
public static int InStrRev(string StringCheck, string StringMatch, int Start, CompareMethod Compare);
public static string Join(object[] SourceArray, string Delimiter);
public static string Join(string[] SourceArray, string Delimiter);
public static char LCase(char Value);
public static string LCase(string Value);
public static string Left(string str, int Length);
public static int Len(bool Expression);
public static int Len(byte Expression);
public static int Len(char Expression);
public static int Len(DateTime Expression);
public static int Len(decimal Expression);
public static int Len(double Expression);
public static int Len(short Expression);
public static int Len(int Expression);
public static int Len(long Expression);
public static int Len(object Expression);
public static int Len(float Expression);
public static int Len(string Expression);
public static string LSet(string Source, int Length);
public static string LTrim(string str);
protected object MemberwiseClone();
public static string Mid(string str, int Start);
public static string Mid(string str, int Start, int Length);
public static string Replace(string Expression, string Find, string Replacement, int Start, int Count, CompareMethod Compare);
public static string Right(string str, int Length);
public static string RSet(string Source, int Length);
public static string RTrim(string str);
public static string Space(int Number);
public static string[] Split(string Expression, string Delimiter, int Limit, CompareMethod Compare);
public static int StrComp(string String1, string String2, CompareMethod Compare);
public static string StrConv(string str, VbStrConv Conversion, int LocaleID);
public static string StrDup(int Number, char Character);
public static object StrDup(int Number, object Character);
public static string StrDup(int Number, string Character);
public static string StrReverse(string Expression);
public virtual string ToString();
public static string Trim(string str);
public static char UCase(char Value);
public static string UCase(string Value);

Microsoft.VisualBasic.Conversion

Module:Microsoft.VisualBasic.dll

Hierarchy
Object
Conversion

Type declaration

[C#] public sealed class Conversion;

Method
public virtual bool Equals(object obj);
public static string ErrorToString();
public static string ErrorToString(int ErrorNumber);
protected override void Finalize();
public static decimal Fix(decimal Number);
public static double Fix(double Number);
public static short Fix(short Number);
public static int Fix(int Number);
public static long Fix(long Number);
public static object Fix(object Number);
public static float Fix(float Number);
public virtual int GetHashCode();
public Type GetType();
public static string Hex(byte Number);
public static string Hex(short Number);
public static string Hex(int Number);
public static string Hex(long Number);
public static string Hex(object Number);
public static decimal Int(decimal Number);
public static double Int(double Number);
public static short Int(short Number);
public static int Int(int Number);
public static long Int(long Number);
public static object Int(object Number);
public static float Int(float Number);
protected object MemberwiseClone();
public static string Oct(byte Number);
public static string Oct(short Number);
public static string Oct(int Number);
public static string Oct(long Number);
public static string Oct(object Number);
public static string Str(object Number);
public virtual string ToString();
public static int Val(char Expression);
public static double Val(object Expression);
public static double Val(string InputStr);

Microsoft.VisualBasic.Interaction

Module:Microsoft.VisualBasic.dll

Hierarchy
Object
Interaction

Type declaration

[C#] public sealed class Interaction;

Method
public static void AppActivate(int ProcessId);
public static void AppActivate(string Title);
public static void Beep();
public static object CallByName(object ObjectRef, string ProcName, CallType UseCallType, params object[] Args);
public static object Choose(double Index, params object[] Choice);
public static string Command();
public static object CreateObject(string ProgId, string ServerName);
public static void DeleteSetting(string AppName, string Section, string Key);
public static string Environ(int Expression);
public static string Environ(string Expression);
public virtual bool Equals(object obj);
protected override void Finalize();
public static string[] GetAllSettings(string AppName, string Section);
public virtual int GetHashCode();
public static object GetObject(string PathName, string Class);
public static string GetSetting(string AppName, string Section, string Key, string Default);
public Type GetType();
public static object IIf(bool Expression, object TruePart, object FalsePart);
public static string InputBox(string Prompt, string Title, string DefaultResponse, int XPos, int YPos);
protected object MemberwiseClone();
public static MsgBoxResult MsgBox(object Prompt, MsgBoxStyle Buttons, object Title);
public static string Partition(long Number, long Start, long Stop, long Interval);
public static void SaveSetting(string AppName, string Section, string Key, string Setting);
public static int Shell(string Pathname, AppWinStyle Style, bool Wait, int Timeout);
public static object Switch(params object[] VarExpr);
public virtual string ToString();

Microsoft.VisualBasic.ErrObject

Module:Microsoft.VisualBasic.dll

Hierarchy
Object
ErrObject

Type declaration

[C#] public sealed class ErrObject;

Method
public void Clear();
public virtual bool Equals(object obj);
protected override void Finalize();
public Exception GetException();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public void Raise(int Number, object Source, object Description, object HelpFile, object HelpContext);
public virtual string ToString();

Property
public string Description {get; set;}
public int Erl {get;}
public int HelpContext {get; set;}
public string HelpFile {get; set;}
public int LastDllError {get;}
public int Number {get; set;}
public string Source {get; set;}

Microsoft.VisualBasic.Collection

Module:Microsoft.VisualBasic.dll

Hierarchy
Object
Collection : ICollection, IList

Type declaration

[C#] public sealed class Collection: ICollection, IList;

Constructor
public Collection();

Method
public void Add(object Item, string Key, object Before, object After);
public virtual bool Equals(object obj);
protected override void Finalize();
public IEnumerator GetEnumerator();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public void Remove(int Index);
public void Remove(string Key);
public virtual string ToString();

Property
public int Count {get;}
public object this[int Index] {get;}
public object this[object Index] {get;}

Microsoft.VisualBasic.DateAndTime

Module:Microsoft.VisualBasic.dll

Hierarchy
Object
DateAndTime

Type declaration

[C#] public sealed class DateAndTime;

Method
public static DateTime DateAdd(DateInterval Interval, double Number, DateTime DateValue);
public static DateTime DateAdd(string Interval, double Number, object DateValue);
public static long DateDiff(DateInterval Interval, DateTime Date1, DateTime Date2, FirstDayOfWeek DayOfWeek, FirstWeekOfYear WeekOfYear);
public static long DateDiff(string Interval, object Date1, object Date2, FirstDayOfWeek DayOfWeek, FirstWeekOfYear WeekOfYear);
public static int DatePart(DateInterval Interval, DateTime DateValue, FirstDayOfWeek FirstDayOfWeekValue, FirstWeekOfYear FirstWeekOfYearValue);
public static int DatePart(string Interval, object DateValue, FirstDayOfWeek DayOfWeek, FirstWeekOfYear WeekOfYear);
public static DateTime DateSerial(int Year, int Month, int Day);
public static DateTime DateValue(string StringDate);
public static int Day(DateTime DateValue);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
public static int Hour(DateTime TimeValue);
protected object MemberwiseClone();
public static int Minute(DateTime TimeValue);
public static int Month(DateTime DateValue);
public static string MonthName(int Month, bool Abbreviate);
public static int Second(DateTime TimeValue);
public static DateTime TimeSerial(int Hour, int Minute, int Second);
public static DateTime TimeValue(string StringTime);
public virtual string ToString();
public static int Weekday(DateTime DateValue, FirstDayOfWeek DayOfWeek);
public static string WeekdayName(int Weekday, bool Abbreviate, FirstDayOfWeek FirstDayOfWeekValue);
public static int Year(DateTime DateValue);

Property
public static string DateString {get; set;}
public static DateTime Now {get;}
public static DateTime TimeOfDay {get; set;}
public static double Timer {get;}
public static string TimeString {get; set;}
public static DateTime Today {get; set;}

Microsoft.VisualBasic.Information

Module:Microsoft.VisualBasic.dll

Hierarchy
Object
Information

Type declaration

[C#] public sealed class Information;

Method
public virtual bool Equals(object obj);
public static int Erl();
public static ErrObject Err();
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
public static bool IsArray(object VarName);
public static bool IsDate(object Expression);
public static bool IsDBNull(object Expression);
public static bool IsError(object Expression);
public static bool IsNothing(object Expression);
public static bool IsNumeric(object Expression);
public static bool IsReference(object Expression);
public static int LBound(Array Array, int Rank);
protected object MemberwiseClone();
public static int QBColor(int Color);
public static int RGB(int Red, int Green, int Blue);
public static string SystemTypeName(string VbName);
public virtual string ToString();
public static string TypeName(object VarName);
public static int UBound(Array Array, int Rank);
public static VariantType VarType(object VarName);
public static string VbTypeName(string UrtName);

Microsoft.VisualBasic.Financial

Module:Microsoft.VisualBasic.dll

Hierarchy
Object
Financial

Type declaration

[C#] public sealed class Financial;

Method
public static double DDB(double Cost, double Salvage, double Life, double Period, double Factor);
public virtual bool Equals(object obj);
protected override void Finalize();
public static double FV(double Rate, double NPer, double Pmt, double PV, DueDate Due);
public virtual int GetHashCode();
public Type GetType();
public static double IPmt(double Rate, double Per, double NPer, double PV, double FV, DueDate Due);
public static double IRR(ref double[] ValueArray, double Guess);
protected object MemberwiseClone();
public static double MIRR(ref double[] ValueArray, double FinanceRate, double ReinvestRate);
public static double NPer(double Rate, double Pmt, double PV, double FV, DueDate Due);
public static double NPV(double Rate, ref double[] ValueArray);
public static double Pmt(double Rate, double NPer, double PV, double FV, DueDate Due);
public static double PPmt(double Rate, double Per, double NPer, double PV, double FV, DueDate Due);
public static double PV(double Rate, double NPer, double Pmt, double FV, DueDate Due);
public static double Rate(double NPer, double Pmt, double PV, double FV, DueDate Due, double Guess);
public static double SLN(double Cost, double Salvage, double Life);
public static double SYD(double Cost, double Salvage, double Life, double Period);
public virtual string ToString();

Microsoft.VisualBasic.VBFixedArrayAttribute

Module:Microsoft.VisualBasic.dll

Hierarchy
Object
Attribute
VBFixedArrayAttribute

Type declaration

[C#] public sealed class VBFixedArrayAttribute : Attribute;

Constructor
public VBFixedArrayAttribute(int UpperBound1);
public VBFixedArrayAttribute(int UpperBound1, int UpperBound2);

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public int[] Bounds {get;}
public int Length {get;}
public object TypeId {get;}

Microsoft.VisualBasic.VBFixedStringAttribute

Module:Microsoft.VisualBasic.dll

Hierarchy
Object
Attribute
VBFixedStringAttribute

Type declaration

[C#] public sealed class VBFixedStringAttribute : Attribute;

Constructor
public VBFixedStringAttribute(int Length);

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public bool IsDefaultAttribute();
public virtual bool Match(object obj);
protected object MemberwiseClone();
public virtual string ToString();

Property
public int Length {get;}
public object TypeId {get;}

Microsoft.VisualBasic.MsgBoxStyle

Module:Microsoft.VisualBasic.dll

Hierarchy
Object
ValueType
Enum
MsgBoxStyle

Type declaration

[C#] public enum MsgBoxStyle;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const MsgBoxStyle AbortRetryIgnore = 2;
public const MsgBoxStyle ApplicationModal = 0;
public const MsgBoxStyle Critical = 16;
public const MsgBoxStyle DefaultButton1 = 0;
public const MsgBoxStyle DefaultButton2 = 256;
public const MsgBoxStyle DefaultButton3 = 512;
public const MsgBoxStyle Exclamation = 48;
public const MsgBoxStyle Information = 64;
public const MsgBoxStyle MsgBoxHelp = 16384;
public const MsgBoxStyle MsgBoxRight = 524288;
public const MsgBoxStyle MsgBoxRtlReading = 1048576;
public const MsgBoxStyle MsgBoxSetForeground = 65536;
public const MsgBoxStyle OKCancel = 1;
public const MsgBoxStyle OKOnly = 0;
public const MsgBoxStyle Question = 32;
public const MsgBoxStyle RetryCancel = 5;
public const MsgBoxStyle SystemModal = 4096;
public int value__;
public const MsgBoxStyle YesNo = 4;
public const MsgBoxStyle YesNoCancel = 3;

Microsoft.VisualBasic.MsgBoxResult

Module:Microsoft.VisualBasic.dll

Hierarchy
Object
ValueType
Enum
MsgBoxResult

Type declaration

[C#] public enum MsgBoxResult;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const MsgBoxResult Abort = 3;
public const MsgBoxResult Cancel = 2;
public const MsgBoxResult Ignore = 5;
public const MsgBoxResult No = 7;
public const MsgBoxResult OK = 1;
public const MsgBoxResult Retry = 4;
public int value__;
public const MsgBoxResult Yes = 6;

Microsoft.VisualBasic.SpcInfo

Module:Microsoft.VisualBasic.dll

Hierarchy
Object
ValueType
SpcInfo

Type declaration

[C#] public struct SpcInfo : ValueType;

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Field
public short Count;

Microsoft.VisualBasic.TabInfo

Module:Microsoft.VisualBasic.dll

Hierarchy
Object
ValueType
TabInfo

Type declaration

[C#] public struct TabInfo : ValueType;

Method
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public virtual string ToString();

Field
public short Column;

Microsoft.VisualBasic.DueDate

Module:Microsoft.VisualBasic.dll

Hierarchy
Object
ValueType
Enum
DueDate

Type declaration

[C#] public enum DueDate;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const DueDate BegOfPeriod = 1;
public const DueDate EndOfPeriod = 0;
public int value__;

Microsoft.VisualBasic.DateInterval

Module:Microsoft.VisualBasic.dll

Hierarchy
Object
ValueType
Enum
DateInterval

Type declaration

[C#] public enum DateInterval;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const DateInterval Day = 4;
public const DateInterval DayOfYear = 3;
public const DateInterval Hour = 7;
public const DateInterval Minute = 8;
public const DateInterval Month = 2;
public const DateInterval Quarter = 1;
public const DateInterval Second = 9;
public int value__;
public const DateInterval Weekday = 6;
public const DateInterval WeekOfYear = 5;
public const DateInterval Year = 0;

Microsoft.VisualBasic.TriState

Module:Microsoft.VisualBasic.dll

Hierarchy
Object
ValueType
Enum
TriState

Type declaration

[C#] public enum TriState;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const TriState False = 0;
public const TriState True = -1;
public const TriState UseDefault = -2;
public int value__;

Microsoft.VisualBasic.FirstWeekOfYear

Module:Microsoft.VisualBasic.dll

Hierarchy
Object
ValueType
Enum
FirstWeekOfYear

Type declaration

[C#] public enum FirstWeekOfYear;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const FirstWeekOfYear FirstFourDays = 2;
public const FirstWeekOfYear FirstFullWeek = 3;
public const FirstWeekOfYear Jan1 = 1;
public const FirstWeekOfYear System = 0;
public int value__;

Microsoft.VisualBasic.FirstDayOfWeek

Module:Microsoft.VisualBasic.dll

Hierarchy
Object
ValueType
Enum
FirstDayOfWeek

Type declaration

[C#] public enum FirstDayOfWeek;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const FirstDayOfWeek Friday = 6;
public const FirstDayOfWeek Monday = 2;
public const FirstDayOfWeek Saturday = 7;
public const FirstDayOfWeek Sunday = 1;
public const FirstDayOfWeek System = 0;
public const FirstDayOfWeek Thursday = 5;
public const FirstDayOfWeek Tuesday = 3;
public int value__;
public const FirstDayOfWeek Wednesday = 4;

Microsoft.VisualBasic.DateFormat

Module:Microsoft.VisualBasic.dll

Hierarchy
Object
ValueType
Enum
DateFormat

Type declaration

[C#] public enum DateFormat;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const DateFormat GeneralDate = 0;
public const DateFormat LongDate = 1;
public const DateFormat LongTime = 3;
public const DateFormat ShortDate = 2;
public const DateFormat ShortTime = 4;
public int value__;

Microsoft.VisualBasic.CompareMethod

Module:Microsoft.VisualBasic.dll

Hierarchy
Object
ValueType
Enum
CompareMethod

Type declaration

[C#] public enum CompareMethod;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const CompareMethod Binary = 0;
public const CompareMethod Text = 1;
public int value__;

Microsoft.VisualBasic.AppWinStyle

Module:Microsoft.VisualBasic.dll

Hierarchy
Object
ValueType
Enum
AppWinStyle

Type declaration

[C#] public enum AppWinStyle;

Method
public int CompareTo(object target);
public override bool Equals(object obj);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
public virtual TypeCode GetTypeCode();
protected object MemberwiseClone();
public override string ToString();
public string ToString(IFormatProvider provider);
public string ToString(string format);
public string ToString(string format, IFormatProvider provider);

Field
public const AppWinStyle Hide = 0;
public const AppWinStyle MaximizedFocus = 3;
public const AppWinStyle MinimizedFocus = 2;
public const AppWinStyle MinimizedNoFocus = 6;
public const AppWinStyle NormalFocus = 1;
public const AppWinStyle NormalNoFocus = 4;
public short value__;

Microsoft.WindowsCE.Forms.MessageWindow

Module:Microsoft.WindowsCE.Forms.dll

Hierarchy
Object
MessageWindow : IDisposable

Type declaration

[C#] public class MessageWindow: IDisposable;

Constructor
public MessageWindow();

Method
public virtual void Dispose();
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public static void PostMessage(ref Message m);
public static void SendMessage(ref Message m);
public virtual string ToString();
protected virtual void WndProc(ref Message m);

Property
public IntPtr Hwnd {get;}

Microsoft.WindowsCE.Forms.Message

Module:Microsoft.WindowsCE.Forms.dll

Hierarchy
Object
ValueType
Message

Type declaration

[C#] public struct Message : ValueType;

Method
public static Message Create(IntPtr hwnd, int msg, IntPtr wparam, IntPtr lparam);
public override bool Equals(object o);
protected override void Finalize();
public override int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public static bool op_Equality(Message left, Message right);
public static bool op_Inequality(Message left, Message right);
public virtual string ToString();

Property
public IntPtr HWnd {get; set;}
public IntPtr LParam {get; set;}
public int Msg {get; set;}
public IntPtr Result {get; set;}
public IntPtr WParam {get; set;}

Microsoft.WindowsCE.Forms.InputPanel

Module:Microsoft.WindowsCE.Forms.dll

Hierarchy
Object
MarshalByRefObject
Component
InputPanel

Type declaration

[C#] public class InputPanel : Component;

Constructor
public InputPanel();

Method
public void add_Disposed(EventHandler value);
public void add_EnabledChanged(EventHandler value);
public void Dispose();
protected virtual void Dispose(bool disposing);
public virtual bool Equals(object obj);
protected override void Finalize();
public virtual int GetHashCode();
public Type GetType();
protected object MemberwiseClone();
public void remove_Disposed(EventHandler value);
public void remove_EnabledChanged(EventHandler value);
public virtual string ToString();

Property
public Rectangle Bounds {get;}
public bool Enabled {get; set;}
public Rectangle VisibleDesktop {get;}