Administrateurs Team Foundation

Visual Studio Team System
Administrateurs Team Foundation
Voir aussi
DropDown image

Les administrateurs Team Foundation Server sont chargés d'installer et de maintenir Team Foundation Server. Ils sont également chargés d'administrer les autorisations et la sécurité pour les autres rôles. Les administrateurs Team Foundation Server peuvent également personnaliser des modèles de processus.

Un administrateur Team Foundation Server doit être un membre des groupes suivants.

Le rôle doit être un membre de | Rôle d'administrateur Team Foundation Server
Groupes d'ordinateurs des couches Application et Données | Administrateurs Windows
Groupes Team Foundation Server par défaut | Administrateurs Team Foundation
Groupes Windows SharePoint Services | Administrateur de site
Groupes Reporting Services | Gestionnaire de contenu, Administrateur de site
Remarque Remarque

La version la plus récente du Guide de l'administrateur Team Foundation est disponible sur le Web sur le site MSDN Online (http://go.microsoft.com/fwlink/?linkid=52459).

Dans cette section

Planification de Team Foundation Server

Fournit les informations nécessaires aux administrateurs et décideurs d'entreprise pour réaliser des plans pour Team Foundation Server, notamment des informations sur les configurations matérielles requises, les configurations logicielles requises, les topologies de déploiement, le guide de processus et l'intégration avec les autres logiciels.

Migration vers Team Foundation

Répertorie les rubriques permettant d'effectuer une migration vers Team Foundation.

Administration de Team Foundation Server

Répertorie des rubriques permettant d'administrer Team Foundation.

Administration du contrôle de code source Team Foundation

Répertorie des rubriques permettant d'administrer le contrôle de code source à l'aide de Team Foundation.

Administration de Team Foundation Build

Répertorie des rubriques permettant d'administrer Team Foundation Build.

Administration des types d'éléments de travail

Répertorie des rubriques permettant d'administrer des types d'élément de travail.

Personnalisation des modèles de processus

Répertorie des rubriques permettant de personnaliser des modèles de processus.

Voir aussi

Concepts

Sécurité de Team Foundation Server pour les utilisateurs et les groupes

Image de pied de page
Pour faire une suggestion ou rapporter un bogue éventuel à propos de l'aide ou de toute autre fonctionnalité, accédez au site de commentaires.


Migration vers Team Foundation

Migration vers Team Foundation
DropDown image

Les rubriques de cette section décrivent la migration vers Team Foundation.

Dans cette section

Migration vers Visual Studio Team System

Fournit une vue d'ensemble de la migration vers Visual Studio Team System.

Processus de migration

Explique les étapes pour réussir une migration vers Team Foundation.

Procédures pas à pas relatives à la migration

Contient les procédures pas à pas qui vous guident à travers le processus de migration vers Visual Studio Team System.

Migration à partir de Visual SourceSafe

Décrit la migration d'un environnement de contrôle de code source Visual SourceSafe vers Team Foundation.

Migration à partir de ClearQuest

Décrit la migration d'un environnement de suivi des éléments de travail ClearQuest vers Team Foundation.

Référence

Commande VSSConverter pour la migration du contrôle de code source

Référence de la ligne de commande pour la migration des éléments de travail

Voir aussi

Autres ressources

Documentation Team Foundation


Migration vers Visual Studio Team System

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Migration vers Visual Studio Team System
Voir aussi
Image de liste déroulante

Visual Studio Team System fournit des convertisseurs vous assistant dans la conversion des informations de vos systèmes traditionnels en systèmes Visual Studio Team System.

  • ClearQuest en Suivi des éléments de travail Team Foundation Convertit le schéma de ClearQuest et les éléments de travail de ClearQuest en suivi des éléments de travail Team Foundation.

  • Visual SourceSafe en contrôle de code source Team Foundation Convertit des projets de contrôle de code source de Visual SourceSafe en contrôle de code source Team Foundation.

  • Les liens indiqués dans les sections suivantes fournissent plus d'informations sur l'utilisation de ces convertisseurs pour déplacer vos données dans Visual Studio Team System. Pour plus d'informations sur la migration, consultez Processus de migration.

Migration vers le suivi des éléments de travail Team Foundation

Les procédures pas à pas suivantes permettent la migration vers le suivi des éléments de travail Team Foundation :

  • Procédure pas à pas : migration d'éléments de travail ClearQuest vers Team Foundation Vous accompagne pas à pas tout au long d'une migration de ClearQuest vers le suivi des éléments de travail Team Foundation.

Les rubriques suivantes expliquent le processus de migration vers le suivi des éléments de travail Team Foundation de manière plus détaillée :

  • Planification de la migration des éléments de travail Describes comment planifier une migration de ClearQuest vers Team Foundation.

  • Migration des éléments de travail Describes comment effectuer une migration de ClearQuest vers Team Foundation.

  • Après la migration des éléments de travail Describes les tâches à effectuer après la migration pour vérifier si elle a réussi et dépanné les problèmes de migration.

  • Référence de la ligne de commande pour la migration des éléments de travail Répertorie toutes les options de ligne de commande pour le convertisseur de la migration de l'élément de travail.

Migration vers un contrôle de code source Team Foundation

Les procédures pas à pas suivantes permettent la migration vers le contrôle de code source Team Foundation :

  • Procédure pas à pas : préparation pour effectuer une migration de Visual SourceSafe vers Team Foundation Vous accompagne pas à pas tout au long de la préparation d'une base de données Visual SourceSafe pour la migration vers le contrôle de code source Team Foundation.

  • Procédure pas à pas : migration de Visual SourceSafe vers Team Foundation Vous accompagne pas à pas tout au long de la migration d'une base de données Visual SourceSafe vers le contrôle de code source Team Foundation.

Les rubriques suivantes expliquent le processus de migration vers le contrôle de code source Team Foundation de manière plus détaillée :

  • Planification de la migration du contrôle de code source Décrit comment planifier une migration de Visual SourceSafe vers un contrôle de code source Team Foundation.

  • Migration du contrôle de code source Décrit comment effectuer une migration de Visual SourceSafe vers un contrôle de code source Team Foundation.

  • Après la migration du contrôle de code source Describes les tâches à effectuer après la migration pour vérifier si elle a réussi et dépanné les problèmes de migration.

  • Commande VSSConverter pour la migration du contrôle de code source Répertorie toutes les options de ligne de commande pour le convertisseur de la migration du contrôle de code source.

Voir aussi

Concepts

Contrôle de code source Team Foundation
Gestion d'éléments de travail Team Foundation

Autres ressources

Démarrage avec Team Foundation


Processus de migration
Image de liste déroulante

La migration est le processus de déplacement de vos éléments de travail ou fichiers de code source dans Team Foundation. Team Foundation comporte des convertisseurs vous aidant à migrer les données dans Team Foundation. L'un des convertisseurs permet de migrer des données de Visual SourceSafe vers le contrôle de code source Team Foundation et l'autre permet de migrer des données de ClearQuest vers le suivi des éléments de travail Team Foundation.

Processus de migration

La migration de tous les types de données suit le même processus :

  1. Préparation de la migration.

  2. Préparation des données pour la migration.

  3. Migration des données.

    Le processus de migration est représenté dans l'illustration suivante :

    Image du processus de migration

Préparation de la migration

Pour préparer la migration, vous devez procéder comme suit :

  • Sélectionner le moment de la migration Planifiez la migration pour qu'elle s'effectue lorsque les utilisateurs n'ont pas besoin d'accéder aux données que vous souhaitez migrer. Vous pouvez également verrouiller les données afin de vous assurer qu'aucune tâche n'est effectuée lors de la migration.

  • Mettre en place un projet d'équipe Team Foundation Vous devez créer un projet d'équipe vers lequel migrer les données. Pour plus d'informations, consultez Comment : créer un projet d'équipe.

  • Créer une définition du type d'élément de travail Si vous migrez des éléments de travail, il est possible que vous deviez créer un type d'élément de travail qui vous permette de migrer toutes les données que vous souhaitez conserver de votre précédent logiciel de suivi des éléments de travail. Pour plus d'informations, consultez Personnalisation des types d'éléments de travail sur Team Foundation Server.

Préparation des données pour la migration

Pour préparer les données pour la migration, vous devez procéder comme suit :

  • Sauvegarder les données Suivez les instructions pour que le logiciel source sauvegarde vos données.

  • Analyser les données Analysez la migration des données. Les deux convertisseurs disposent d'une fonction d'analyse qui vous permet de voir comment les données sont migrées et d'effectuer les réglages appropriés. Lors de l'analyse, les convertisseurs créent des fichiers qui contiennent les paramètres qui sont utilisés pendant la migration pour contrôler la migration.

  • Apporter les modifications requises pour une migration réussie Si vous remarquez des problèmes pendant l'analyse, vous pouvez modifier les fichiers de paramètres ou le projet d'équipe pour améliorer la migration des données.

Migration des données

Pour migrer les données, vous devez procéder comme suit :

  • Modifier les fichiers de paramètres pour contrôler la migration Plusieurs fichiers sont créés pendant l'analyse. Il est possible que vous deviez les modifier. Par exemple, pour la migration des éléments de travail, vous devez modifier le fichier de mappage utilisateur, le fichier de mappage de champ et le fichier de mappage de schéma.

  • Migrer les données Utilisez le convertisseur pour migrer les données. Pour plus d'informations, consultez Migration à partir de Visual SourceSafe ou Migration à partir de ClearQuest.

  • Vérifier la migration Vérifiez vos données dans Team Foundation et assurez-vous que les données de migration ont été correctement transférées.

Voir aussi

Concepts

Migration à partir de Visual SourceSafe
Migration à partir de ClearQuest


Migration à partir de Visual SourceSafe

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Migration à partir de Visual SourceSafe
Voir aussi
Image de liste déroulante

L'outil de conversion Visual SourceSafe Team Foundation transfère des fichiers, des dossiers, un historique des versions, des étiquettes et des informations utilisateur d'une base de données Visual SourceSafe vers le contrôle de code source Team Foundation. Avant de déplacer des fichiers et des informations sur l'historique vers Team Foundation, vous devez analyser une copie de sauvegarde de la base de données Visual SourceSafe, archiver autant de fichiers que possible et savoir quelles informations ne peuvent pas être transférées de Visual SourceSafe vers Team Foundation. Pour plus d'informations, consultez les sections suivantes :

Introduction à Team Foundation pour les utilisateurs Visual SourceSafe

Fournit des informations pour aider les utilisateurs de Visual SourceSafe à démarrer avec le contrôle de code source Team Foundation.

Limites du convertisseur Visual SourceSafe

Décrit les limitations du convertisseur.

Migration des événements d'historique

Décrit comment certains événements historiques particuliers dans Visual SourceSafe sont migrés vers le contrôle de code source Team Foundation.

Planification de la migration du contrôle de code source

Décrit comment planifier une migration de Visual SourceSafe vers le contrôle de code source Team Foundation.

Migration du contrôle de code source

Décrit comment effectuer une migration de Visual SourceSafe vers le contrôle de code source Team Foundation.

Après la migration du contrôle de code source

Décrit les tâches à effectuer après la migration pour vérifier si elle a réussi et dépanné les problèmes de migration.

Commande VSSConverter pour la migration du contrôle de code source

Répertorie toutes les options de ligne de commande pour le convertisseur de la migration du contrôle de code source.

Voir aussi

Tâches

Procédure pas à pas : préparation pour effectuer une migration de Visual SourceSafe vers Team Foundation
Procédure pas à pas : migration de Visual SourceSafe vers Team Foundation

Concepts

Processus de migration


Limites du convertisseur Visual SourceSafe

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Limites du convertisseur Visual SourceSafe
Voir aussi
Image de liste déroulante

Le convertisseur Visual SourceSafe conserve la plupart des informations de l'historique de votre base de données Visual SourceSafe. Les sections suivantes indiquent les types d'informations conservés, non conservés et où les informations apparaissent dans le contrôle de code source Team Foundation après la migration.

Informations conservées

L'outil Convertisseur copie les informations de l'historique suivantes de Visual SourceSafe vers le contrôle de code source Team Foundation pour les éléments que vous migrez :

  • Ajouter un fichier ou un dossier Enregistre le nom du fichier ou du dossier, la date et l'heure de l'ajout et le nom d'utilisateur.

  • Supprimer un fichier ou un dossier Enregistre le nom du fichier ou du dossier, la date et l'heure de suppression et le nom d'utilisateur.

  • Restaurer un fichier ou un dossier Enregistre le nom du fichier ou du dossier, la date et l'heure de la restauration et le nom d'utilisateur.

  • Renommer un fichier ou un dossier Enregistre l'ancien nom, le nouveau nom, la date et l'heure du changement de nom et le nom d'utilisateur.

  • Modifier le fichier Enregistre la date et l'heure d'archivage et le nom d'utilisateur.

  • Modifier l'étiquette Enregistre le nom de l'étiquette, les données modifiées et l'heure de la modification et le nom d'utilisateur.

  • Déplacer un dossier Enregistre l'ancien emplacement, le nouvel emplacement, la date et l'heure du déplacement et le nom d'utilisateur.

    Remarque Remarque

    Les informations relatives au déplacement des dossiers dans une base de données Visual SourceSafe sont uniquement conservées dans le contrôle de code source Team Foundation si lesdossiers source et de destination sont migrés en même temps.

Informations non conservées

L'outil Convertisseur ne conserve pas les informations de l'historique relatives aux actions Visual SourceSafe suivantes :

  • Partage Le partage n'est pas pris en charge dans le contrôle de code source Team Foundation. Par conséquent, les fichiers partagés sont migrés en copiant la version du fichier au début du partage avec un dossier de destination. Par la suite, les modifications apportées au fichier partagé sont répliquées sur les deux copies.

  • Branchement Parce que le partage est une condition préalable au branchement, la migration d'un fichier partagé crée une copie du fichier dans le dossier de destination. Après l'événement de branche, les modifications apportées à une branche sont migrées vers la copie respective dans le contrôle de code source Team Foundation.

  • Épinglage Le contrôle de code source Team Foundation ne prend pas en charge l'épinglage. Par conséquent, tous les fichiers en attente sont migrés en créant deux étiquettes. L'étiquette PINNED_LATEST est appliquée aux versions en attente des fichiers en attente et à la version la plus récente des fichiers sans attente. L'étiquette PINNED est uniquement appliquée aux versions en attente des fichiers en attente. Après la migration, l'étiquette PINNED_LATEST récupérera les mêmes fichiers qu'une commande Obtenir la dernière version dans Visual SourceSafe. Toutefois, l'étiquette PINNED_LATEST peut retourner des fichiers différents, si des événements autres qu'un archivage ont eu lieu après l'épinglage d'un fichier, tel qu'un changement de nom ou une suppression du fichier.

Horodatages

L'horodatage associé à une action n'est pas conservé pendant la migration. À la place, l'horodatage qui correspond à une action est remplacé par l'horodatage de l'heure de la conversion. Toutefois, l'horodatage d'origine d'une action de l'utilisateur est ajouté au commentaire.

Par exemple, cette action de l'utilisateur s'affiche dans Visual SourceSafe sous la forme :

Action de l'utilisateur | Version | Horodatage | Commentaire
$/ProjectA/a.c checkin | 5 | 3 juin 2002 12h30 | Bogue résolu dans l'écran "Accueil"

La même action de l'utilisateur s'affiche dans le contrôle de code source Team Foundation sous la forme :

Action de l'utilisateur | Version | Horodatage | Commentaire
$/ProjectA/a.c checkin | 5 | 2 mai 2005 15h30 | {03/06/2002 12h30} Bogue résolu dans l'écran « Accueil »

Voir aussi

Concepts

Migration des événements d'historique


Migration des événements d'historique

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Migration des événements d'historique
Voir aussi
Image de liste déroulante

Cette rubrique décrit comment les événements d'historique consignés par Visual SourceSafe sont migrés dans Team Foundation.

Événements d'historique

Les événements d'historique sont migrés dans la zone équivalente de Team Foundation. Cela permet de conserver l'historique de vos fichiers sources. L'historique des versions de fichiers est créé en relisant les événements qui ont créé l'historique. Le tableau suivant décrit le mode de migration de chaque événement d'historique :

Événement Mode de migration

Ajouter un fichier ou un dossier

L'événement d'ajout de fichier crée la première version du fichier dans Team Foundation. L'événement d'ajout de dossier crée la première version du dossier dans Team Foundation. Si le dossier contenait des fichiers ou des dossiers lors de son ajout, ces fichiers et ces dossiers sont ajoutés séparément.

Modifier le fichier

L'événement de modification de fichier crée une version du fichier dans Team Foundation.

Étiqueter un fichier

Dans Team Foundation, vous appliquez une étiquette à une version d'un fichier ou d'un dossier. Dans Visual SourceSafe, vous pouvez étiqueter explicitement ou implicitement un fichier. Lorsqu'un fichier est étiqueté explicitement dans Visual SourceSafe, une nouvelle version du fichier est créée et si effectuez une opération d'obtention sur cette étiquette, vous obtenez le contenu du fichier qui correspond à la version antérieure du fichier. Pour migrer explicitement des étiquettes, le convertisseur applique dans Team Foundation l'étiquette à la version qui correspond à la version étiquetée dans Visual SourceSafe. Toutefois, il ne crée pas de nouvelle version.

Lorsque vous appliquez une étiquette d'un dossier dans Visual SourceSafe, l'étiquette est appliquée implicitement à tous les fichiers et les dossiers situés sous le dossier et ne crée pas de nouvelles versions. Pour les étiquettes implicites, le convertisseur ne fait rien parce que les versions correspondantes dans Team Foundation sont étiquetées automatiquement pendant la migration des étiquettes explicites sur le dossier.

Étiqueter un dossier

Dans Visual SourceSafe, lorsque vous appliquez une étiquette à un dossier, tous les fichiers et les dossiers de ce dossier sont implicitement étiquetés et aucune nouvelle version n'est créée. Pendant la migration de ces dossiers, le convertisseur applique l'étiquette à la version correspondante du dossier dans Team Foundation. Cela applique automatiquement l'étiquette aux versions actuelles des fichiers et des dossiers du dossier étiqueté.

Renommer, supprimer ou restaurer un fichier ou un dossier

Pendant la migration d'événements renommées, supprimés et restaurés d'un fichier ou d'un dossier, le convertisseur relit l'événement pour créer une nouvelle version du fichier et du dossier dans Team Foundation.

Déplacer un dossier

L'événement Déplacer un dossier crée une nouvelle version du dossier dans Team Foundation. Dans Visual SourceSafe, la commande de déplacement ne change pas le contenu ou l'historique du dossier ; elle est plutôt enregistrée dans l'historique du nouveau ou de l'ancien dossier parent. Lorsque vous déplacez un dossier, Visual SourceSafe ne peut pas reconstruire une ancienne version du dossier parent.

Après la migration, vous pourrez reconstruire une ancienne version en raison du mode de migration de l'événement Déplacer un dossier. Par exemple, si vous avez appliqué l'étiquette « ÉTIQUETTE1 » au dossier $/A qui possède un sous-dossier /B et que vous déplacez ensuite /B vers un autre dossier $/C. Dans Visual SourceSafe, si vous effectuez une opération d'obtention sur « ÉTIQUETTE1 » sur $/A, vous n'obtiendrez pas $/A/B. Après la migration vers Team Foundation, vous obtiendrez le dossier déplacé ($/A/B) si vous effectuez une opération d'obtention sur l'étiquette.

Lorsque vous migrez des dossiers déplacés, trois scénarios possibles peuvent se présenter avec des résultats différents selon le contenu migré :

  • Les dossiers source et de destination sont migrés. Aucune perte de données. Dans le précédent exemple, les dossiers source $/A et de destination $/C sont migrés.

  • Seul le dossier de destination est migré. Après la migration, le dossier déplacé apparaît dans le dossier de destination comme s'il avait été ajouté lors de son déplacement. L'historique du dossier déplacé et les éléments qu'il contenait avant l'événement de déplacement ne sont pas migrés dans Team Foundation. À l'aide de l'exemple précédent, l'événement de déplacement du sous-dossier /B apparaîtra dans $/C comme un événement d'ajout de dossier. Pour éviter de perdre l'historique, migrez simultanément les dossiers source et de destination du dossier déplacé. Lorsque vous exécutez l'analyse de migration, le rapport contient une section qui vous avertit de cette perte de données.

  • Seul le dossier source est migré. Pendant la migration, l'historique du dossier déplacé et les éléments qu'il contient ne sont pas migrés vers Team Foundation. Pour éviter de perdre l'historique, migrez simultanément les dossiers source et de destination du dossier Visual SourceSafe déplacé. Lorsque vous exécutez l'analyse de migration, le rapport contient une section qui vous avertit de cette perte de données.

Partager des fichiers

Dans Visual SourceSafe, vous pouvez partager un fichier dans plusieurs dossiers. Les modifications que vous apportez dans un fichier partagé sont répliquées dans les dossiers où il est partagé. Visual SourceSafe crée en interne des liens souples entre des fichiers partagés. Les dossiers ne sont pas partagés techniquement dans Visual SourceSafe. Lorsque vous partagez un dossier dans Visual SourceSafe, une copie du dossier est créée et tous les fichiers du dossier sont partagés.

Team Foundation ne possède pas d'équivalent pour le partage. Les fichiers partagés sont migrés en créant une version dans le dossier de destination avec le même contenu que la version du fichier au début du partage. À partir de ce point, les modifications apportées au fichier partagé sont répliquées aux deux emplacements par le convertisseur.

Partager et supprimer un fichier

Un fichier qui est partagé puis supprimé est traité comme un fichier partagé, mais toutes les actions consécutives à la suppression sont ignorées.

Si le fichier partagé supprimé est restauré ultérieurement, le convertisseur rapporte les erreurs qui ont eu lieu pendant la migration pour chaque action, telle que la modification ou le changement de nom. Toutefois, pendant la migration de l'action de restauration, le convertisseur effectue une opération de restauration-modification sur le fichier afin qu'il ait le même contenu que celui du fichier restauré dans Visual SourceSafe.

Si le fichier partagé supprimé est renommé ultérieurement, le convertisseur rapporte les erreurs qui ont eu lieu pendant la migration de l'action de changement de nom. Les actions effectuées après le changement de nom ne seront pas migrées et le convertisseur rapporte l'erreur pour chaque action.

Fichiers branche

Le partage est une condition préalable au branchement. Le convertisseur ne peut pas associer une branche Visual SourceSafe à une branche de contrôle de code source Team Foundation. La migration d'un fichier partagé crée un réplica du fichier dans le dossier de destination. La migration d'événements de branche signifie que les modifications apportées à un fichier partagé ne sont plus répliquées dans les deux emplacements. Par conséquent, les modifications apportées à une branche sont migrées vers la copie respective dans Team Foundation. Le rapport de migration fournit une liste des dossiers qui contiennent des fichiers qui sont partagés ou comportent des branches dans Visual SourceSafe.

Archiver

Lorsque vous archivez des fichiers ou des dossiers dans Visual SourceSafe, vous pouvez supprimer complètement l'historique d'un fichier ou d'un dossier ou supprimer des versions de l'historique d'un fichier ou d'un dossier. Si vous avez supprimé l'historique, le convertisseur migre les versions supprimées. Le convertisseur ignore l'événement d'archivage.

Restaurer

Lorsque vous effectuez une restauration dans Visual SourceSafe, vous restaurez l'historique d'un fichier ou d'un dossier archivé. Le convertisseur migre l'historique restauré des fichiers et des dossiers. Le convertisseur ignore l'événement de restauration.

EN ATTENTE et SANS ATTENTE

Le contrôle de code source Team Foundation ne prend pas en charge l'épinglage. Par conséquent, tous les fichiers en attente sont migrés en créant deux étiquettes. L'étiquette PINNED_LATEST est appliquée aux versions en attente des fichiers en attente et à la version la plus récente des fichiers sans attente. L'étiquette PINNED est uniquement appliquée aux versions en attente des fichiers en attente. Après la migration, l'étiquette PINNED_LATEST récupérera les mêmes fichiers qu'une commande Obtenir la dernière version dans Visual SourceSafe. Toutefois, l'étiquette PINNED_LATEST peut retourner des fichiers différents, si des événements autres qu'un archivage ont eu lieu après l'épinglage d'un fichier, tel qu'un changement de nom ou une suppression du fichier.

Voir aussi

Concepts

Comment le convertisseur groupe les ensembles de modifications pour améliorer les performances

Autres ressources

Planification de la migration du contrôle de code source


Comment le convertisseur groupe les ensembles de modifications pour améliorer les performances

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Comment le convertisseur groupe les ensembles de modifications pour améliorer les performances
Voir aussi
Image de liste déroulante

Dans le contrôle de code source Team Foundation, les ensembles de modifications sont utilisés pour grouper des informations à propos d'un archivage. Un ensemble de modifications est composé des éléments suivants :

  • révisions de fichiers sources et de dossiers ; tel que des ajouts, attributions de nouveaux noms, modifications, suppressions et déplacements ;

  • éléments de travail connexes ;

  • métadonnées système ; tel que le propriétaire, la date et l'heure de l'archivage ;

  • remarques et commentaires sur l'archivage.

Dans Visual SourceSafe, chaque action dans un fichier et un dossier crée une nouvelle version dans l'historique du fichier, du dossier ou des deux à la fois. Pendant la migration, les actions séparées dans l'historique de Visual SourceSafe sont rassemblées dans un ensemble de modifications unique en fonction des éléments suivants :

  1. Les actions sont consécutives.

  2. Les actions ne sont pas en conflit. Par exemple, deux actions n'affectent pas le même fichier ou dossier.

  3. Les actions ont le même commentaire d'archivage.

  4. Toutes les actions sont effectuées par le même utilisateur.

Le regroupement d'actions dans un ensemble de modifications unique permet d'augmenter les performances de la migration.

Voir aussi

Concepts

Limites du convertisseur Visual SourceSafe
Migration des événements d'historique


Planification de la migration du contrôle de code source

Planification de la migration du contrôle de code source
DropDown image

Cette section contient des informations relatives à la planification de la migration de vos projets de contrôle de code source Visual SourceSafe vers le contrôle de code source Team Foundation. Le processus de migration prend du temps car vous effectuez une migration d'années de données de contrôle de code source. Le convertisseur fournit des options de migration qui peuvent réduire la durée de la migration en réduisant le temps de migration ou en permettant à vos équipes de travailler sur le contrôle de code source pendant la migration. Déterminez l'option de migration la mieux adaptée à votre équipe :

  • Migration projet par projet Utilisez cette option pour migrer les sources d'une équipe ou d'un projet à la fois ; en général un dossier dans Visual SourceSafe. Cette option garantit que les autres équipes ne sont pas bloquées pendant la migration ; toutefois, si deux équipes ont des dépendances entre leurs sources, vous devez migrer conjointement les sources des deux équipes, c'est-à-dire les dossiers du projet. Les deux dossiers peuvent avoir quelques dépendances qui pourraient provoquer la perte de données si seuls certains dossiers sont migrés. La phase d'analyse permet d'identifier les dépendances entre des dossiers.

  • Migration incrémentielle Utilisez cette option pour migrer votre base de données Visual SourceSafe par phases. La migration d'une base de données Visual SourceSafe par phases garantit que les utilisateurs peuvent continuer à utiliser Visual SourceSafe pendant le processus de migration. Pour plus d'informations, consultez Comment : effectuer une migration par incrément vers Team Foundation

  • Utiliser la fonction d'archivage de VSS pour migrer partiellement l'historique Utilisez cette option si vous ne souhaitez pas migrer l'ancien historique. En utilisant cette fonctionnalité vous supprimez l'historique des versions de fichiers et de dossier antérieur à une date spécifique. Pour plus d'informations, consultez Comment : effectuer la migration partielle d'un historique à l'aide des archives dans Visual SourceSafe.

Dans la deuxième phase, vous effectuez une analyse de la base de données Visual SourceSafe à migrer et vous migrez ensuite réellement la base de données Visual SourceSafe vers le contrôle de code source Team Foundation. La phase d'analyse génère un rapport qui fournit des informations relatives à la perte de données potentielle pendant la migration. Vous pouvez limiter la perte de données potentielle en effectuant quelques étapes de pré-migration. Toutefois, la perte de données est inévitable parce que certaines données Visual SourceSafe ne peuvent pas être mappées au contrôle de code source Team Foundation. Après la migration, vous recevez un rapport qui vous fournit des informations relatives à l'état et aux éventuelles pertes de données pendant la migration. Après la migration, quelques étapes peuvent s'avérer nécessaires afin de s'assurer que vous pouvez utiliser les sources migrées.

Dans cette section

Comment : préparer votre base de données Visual SourceSafe avant l'exécution du convertisseur

Décrit comment préparer Visual SourceSafe pour la migration.

Comment : créer un fichier de paramètres pour l'analyse et la migration du contrôle de code source

Décrit comment créer un fichier de paramètres pour contrôler votre migration.

Comment : analyser le processus de migration de votre base de données VSS

Décrit comment générer un rapport d'analyse de pré-migration.

Comment : configurer SQL Express pour la migration

Décrit comment configurer SQL Express pour la migration.

Comment : préparer Team Foundation pour la migration

Décrit comment préparer le contrôle de code source Team Foundation pour la migration.

Voir aussi

Référence

Commande VSSConverter pour la migration du contrôle de code source

Autres ressources

Migration du contrôle de code source
Après la migration du contrôle de code source


Comment : préparer votre base de données Visual SourceSafe avant l'exécution du convertisseur

Comment : préparer votre base de données Visual SourceSafe avant l'exécution du convertisseur
Voir aussi

Avant d'analyser ou d'effectuer une migration de vos fichiers sous contrôle de code source de Visual SourceSafe vers Visual Studio 2005, vous pouvez préparer votre base de données Visual SourceSafe.

Préparation de votre base de données Visual SourceSafe pour exécuter le convertisseur

Pour préparer votre base de données Visual SourceSafe pour la migration, vous devez archiver tous les fichiers, résoudre les erreurs d'intégrité des données, sauvegarder la base de données et décider quels sont les projets à migrer :

Pour préparer des utilisateurs pour la migration

  • Demandez à tous les utilisateurs de la base de données Visual SourceSafe d'archiver leurs fichiers.

Pour préparer des projets pour la migration

  1. Installez Visual SourceSafe 2005 sur l'ordinateur sur lequel vous exécutez le convertisseur. Visual SourceSafe 2005 n'est pas installé par défaut lorsque vous installez Visual Studio.

  2. Copiez votre base de données Visual SourceSafe dans un dossier local sur l'ordinateur sur lequel vous exécutez le convertisseur. Vous pouvez migrer une base de données Visual SourceSafe dans un dossier partagé sur un ordinateur distant, mais la migration prend plus longtemps.

  3. Si la version de votre base de données Visual SourceSafe est antérieure à Visual SourceSafe 6.0, effectuez une mise à niveau vers la version 6.0 à l'aide de l'utilitaire DDUPD de Visual SourceSafe.

  4. Corrigez les erreurs d'intégrité des données. Utilisez l'outil d'analyse de Visual SourceSafe pour rechercher et pour corriger si possible tous les problèmes d'intégrité des données dans votre base de données.

Sécurité

Vous devez être un membre du groupe Administrateurs Team Foundation sur Team Foundation pour effectuer cette procédure. Vous devez également être administrateur de systèmes pour SQL Express.

Voir aussi

Tâches

Procédure pas à pas : préparation pour effectuer une migration de Visual SourceSafe vers Team Foundation
Procédure pas à pas : migration de Visual SourceSafe vers Team Foundation


Comment : créer un fichier de paramètres pour l'analyse et la migration du contrôle de code source

Comment : créer un fichier de paramètres pour l'analyse et la migration du contrôle de code source
Voir aussi

Vous créez un fichier de paramètres pour contrôler le mode de migration et d'analyse des données de contrôle de code source dans Team Foundation. Vous créez un fichier de paramètres pour analyser le processus de migration en identifiant d'abord tous les problèmes qui peuvent se produire pendant la migration, puis en modifiant ce fichier de paramètres afin d'exécuter réellement la migration.

Avant de créer le fichier de paramètres, vous devez :

  • Identifier les dossiers dans Visual SourceSafe que vous souhaitez migrer.

  • Pour la migration, identifiez l'emplacement où vous souhaitez migrer vos dossiers Visual SourceSafe : dossiers vides ou dossiers de destination où le convertisseur peut créer des dossiers dans le contrôle de code source Team Foundation. Le convertisseur ne crée pas un dossier de destination si le dossier se trouve dans le dossier racine ($/) dans le contrôle de code source Team Foundation.

  • Pour mapper des utilisateurs Visual SourceSafe à des utilisateurs Team Foundation Server, utilisez le fichier de mappage utilisateur généré pendant l'analyse. Pour plus d'informations, consultez Comment : modifier le fichier de mappage utilisateur relatif à la migration du contrôle de code source.

Le format du fichier de paramètres est légèrement différent lorsque vous exécutez l'analyse de celui utilisé pour la migration. Les différences sont soulignées dans les sections suivantes.

Pour créer un fichier de paramètres pour l'analyse

  1. Créez un fichier XML en utilisant un éditeur, tel que le Bloc-notes.

  2. Copiez le texte de la section Format du fichier de paramètres pour l'analyse du fichier d'exemple de paramètres pour la migration du contrôle de code source dans le fichier XML.

  3. Dans la section <VSSDatabase>, spécifiez l'emplacement de la base de données Visual SourceSafe sur laquelle vous exécutez l'analyse.

  4. Vous pouvez éventuellement spécifier un nom et un emplacement pour le fichier de mappage utilisateur dans la section <UserMap>. Si vous ne fournissez pas de nom de fichier, le convertisseur génère le fichier nommé UserMap.xml dans le dossier actif.

  5. Dans la section <ProjectMap>, spécifiez les dossiers Visual SourceSafe à analyser.

  6. Sous la section <Settings>, dans la section <Output>, vous pouvez spécifier le nom de fichier et l'emplacement du rapport d'analyse. Si vous ne spécifiez pas de nom de fichier, le convertisseur génère le fichier nommé VSSAnalysisReport.xml.

  7. Enregistrez le fichier de paramètres en tant que fichier XML (avec une extension de fichier .xml).

Pour créer un fichier de paramètres pour la migration

  1. Copiez le fichier de paramètres que vous avez créé pour l'analyse et enregistrez-le sous un nouveau nom. Pour référence, consultez « Format du fichier de paramètres pour la migration » dans Fichier des paramètres du convertisseur VSS, exemple.

  2. Modifiez le fichier de paramètres de migration comme suit.

    • Dans la section <ProjectMap>, pour chaque dossier Visual SourceSafe migré, ajoutez les dossiers de destination dans le contrôle de code source Team Foundation. Utilisez le format suivant pour ajouter une section Destination :

      Image Copier le code Copier le code
      <Project Source="$/FolderA" Destination="$/TeamProjectA"></Project>

    • Sous la section <Settings>, ajoutez une section <TeamFoundationServer> et spécifiez le nom, le port et le protocole du serveur Team Foundation Server vers lequel vous migrez. Utilisez le format suivant :

      Image Copier le code Copier le code
      <TeamFoundationServer name="TFS_server_name" port="port_number" protocol="http"></TeamFoundationServer>

      Par exemple :

      Image Copier le code Copier le code
      <TeamFoundationServer name="My_TFS_server" port="8080" protocol="http"></TeamFoundationServer>

    • Vous pouvez éventuellement spécifier le nom de fichier et l'emplacement du rapport d'analyse sous la section <Settings>, dans la section <Output>. Si vous ne fournissez pas de nom de fichier, le convertisseur génère le fichier nommé VSSMigrationReport.xml.

    Remarque Remarque

    Le convertisseur utilise SQLExpress pendant la migration pour stocker des métadonnées. Ces métadonnées prennent en général un pourcentage réduit de données pendant la migration. In the unlikely event that your migration fails because of the 4GB limit of SQLExpress, you can set the converter to use SQLServer instead by adding the following line to the <Source name="VSS"> section of the settings file: <SQL Server="SQL_Server_name"></SQL>. Par exemple :

  3. Enregistrez le fichier de paramètres en tant que fichier XML (avec une extension de fichier .xml).

Voir aussi

Tâches

Procédure pas à pas : préparation pour effectuer une migration de Visual SourceSafe vers Team Foundation
Procédure pas à pas : migration de Visual SourceSafe vers Team Foundation
Comment : créer un projet d'équipe
Comment : ajouter un projet ou une solution au contrôle de code source

Référence

Commande VSSConverter pour la migration du contrôle de code source

Concepts

Fichier des paramètres du convertisseur VSS, exemple


Fichier des paramètres du convertisseur VSS, exemple

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Fichier des paramètres du convertisseur VSS, exemple
Voir aussi
Image de liste déroulante

Le fichier des paramètres du convertisseur VSS est un fichier XML dans lequel vous indiquez la configuration pour l'analyse ou la migration. Les sections du fichier de paramètres sont décrites ultérieurement dans cette rubrique et elles sont suivies par un exemple de fichier de paramètres pour l'analyse et la migration que vous pouvez utiliser pour créer votre fichier de paramètres.

Sections du fichier de paramètres

Le fichier XML des paramètres du convertisseur VSS contient plusieurs sections qui spécifient les configurations que vous devez indiquer pour analyser une base de données Visual SourceSafe pour la migration ou pour effectuer une migration vers Team Foundation. Les sections sont décrites plus en détail dans cette rubrique.

<ConverterSpecificSetting>

Le nœud XML <ConverterSpecificSetting> contient des informations de paramètres à propos de la base de données Visual SourceSafe que vous souhaitez faire migrer. Le convertisseur utilise les informations pour la migration.

  • La section <name> sous le nœud <VSSDatabase> contient le chemin d'accès du dossier dans lequel se trouve le fichier srcsafe.ini.

  • La section <name> sous le nœud <UserMap> contient le fichier de mappage utilisateur. Pour plus d'informations, consultez Comment : modifier le fichier de mappage utilisateur relatif à la migration du contrôle de code source.

  • Sous le nœud <Project> sous le nœud <ProjectMap>, spécifiez le dossier Visual SourceSafe pour l'analyse ou la migration et pour la migration, le dossier vers lequel effectuer une migration dans le contrôle de code source Team Foundation. Vous pouvez ajouter plusieurs nœuds <Project> pour analyser ou faire migrer plusieurs dossiers Visual SourceSafe.

    Remarque Remarque

    Le convertisseur utilise SQL Express pendant la migration. Si votre migration échoue à cause de la limite de 4 Go de SQL Express, vous pouvez configurer le convertisseur pour qu'il utilise SQL Server à la place en ajoutant la ligne suivante à la section <Source name="VSS"> : <SQL Server="SQL_Server_name"></SQL>

<Settings>

Sous le nœud <Settings>, <file> dans la section <Output>, vous pouvez spécifier le nom et l'emplacement du fichier de rapport de l'analyse ou de la migration. Si vous ne spécifiez pas de nom de fichier, le convertisseur génère le fichier qui utilise le nom VSSAnalysisReport.xml pendant l'analyse et VSSMigrationReport.xml pendant la migration.

Format du fichier de paramètres pour l'analyse

Le fichier de paramètres contient les informations que le Convertisseur Visual SourceSafe doit posséder pour analyser la base de données Visual SourceSafe à migrer. Vous pouvez copier le XML représenté ultérieurement dans cette rubrique et le modifier pour créer votre propre fichier de paramètres.

Image Copier le code Copier le code
<?xml version="1.0" encoding="utf-8"?>
<SourceControlConverter>
<ConverterSpecificSetting>
     <Source name="VSS">
          <VSSDatabase name="c:\VSSDatabase"></VSSDatabase>
          <UserMap name="c:\Migrate\Usermap.xml"></UserMap>
     </Source>
     <ProjectMap>
          <Project Source="$/FolderA"></Project>
          <Project Source="$/FolderB"></Project>
     </ProjectMap>
</ConverterSpecificSetting>
<Settings>
     <Output file="Analysis.xml"></Output>
</Settings>
</SourceControlConverter>
Remarque Remarque

S'il manque une des sections précédentes, vous recevez une erreur de validation XML.

Format du fichier de paramètres pour la migration

Le fichier de paramètres contient les informations que le Convertisseur Visual SourceSafe doit posséder pour migrer votre base de données Visual SourceSafe vers le contrôle de code source Team Foundation. Vous pouvez copier le XML représenté ultérieurement dans cette rubrique et le modifier pour créer votre propre fichier de paramètres ou utiliser les procédures précédentes de cette rubrique pour modifier le fichier de paramètres que vous avez créé pour l'analyse.

Image Copier le code Copier le code
<?xml version="1.0" encoding="utf-8"?>
<SourceControlConverter>
<ConverterSpecificSetting>
     <Source name="VSS">
          <VSSDatabase name="c:\VSSDatabase"></VSSDatabase>
          <UserMap name="c:\Migrate\Usermap.xml"></UserMap>
     </Source>
     <ProjectMap>
          <Project Source="$/FolderA" Destination="$/TeamProjectA"></Project>
          <Project Source="$/FolderB" Destination ="$/TeamProjectB/ProjectB"></Project>
     </ProjectMap>
</ConverterSpecificSetting>
<Settings>
     <TeamFoundationServer name="My_TFS_Server" port="8080" protocol="http"></TeamFoundationServer>
     <Output file="Migration.xml"></Output>
</Settings>
</SourceControlConverter>

Voir aussi

Tâches

Comment : créer un fichier de paramètres pour l'analyse et la migration du contrôle de code source


Comment : analyser le processus de migration de votre base de données VSS

Comment : analyser le processus de migration de votre base de données VSS
Voir aussi

Le processus de migration prend du temps car vous effectuez une migration d'années de données de contrôle de code source. Pour réduire le temps nécessaire pour effectuer une migration et vous assurer que d'autres équipes ne sont pas bloquées pendant la migration, vous devez effectuer une migration des sources d'une équipe à la fois. Si les sources de deux équipes ont des dépendances entre elles, effectuez une migration combinée des sources des deux équipes, parce que si vous ne le faites pas, la migration peut provoquer la perte de données. La phase d'analyse mettra en avant les zones où il y a des dépendances.

Le rapport d'analyse vous donne une idée de la perte de données potentielle. Une partie de la perte de données potentielle peut être empêchée en prenant des dispositions avant de procéder à la migration. Toutefois, une partie de la perte de données ne peut être empêchée car les données de Visual SourceSafe ne peuvent pas être mappées au contrôle de code source Team Foundation.

Remarque Remarque

Avant de pouvoir analyser votre base de données Visual SourceSafe, vous devez créer un fichier de paramètres.

Pour analyser un projet avec le convertisseur

  1. À l'invite de commandes, tapez ce qui suit :

    VSSConverter Analyze settings.xml

  2. Lorsque vous y êtes invité, fournissez le mot de passe administrateur de Visual SourceSafe.

    L'outil Convertisseur affiche l'état de l'analyse de préconversion. Lorsqu'il a terminé, il génère un rapport et un fichier de mappage utilisateur et les enregistre dans le répertoire actif.

Voir aussi

Tâches

Comment : créer un fichier de paramètres pour l'analyse et la migration du contrôle de code source
Comment : configurer SQL Express pour la migration


Comment : configurer SQL Express pour la migration

Comment : configurer SQL Express pour la migration

Vous devez installer SQL Express sur l'ordinateur sur lequel vous exécutez le convertisseur pour la migration. Le convertisseur VSS lit l'historique des fichiers et des dossiers dans la base de données Visual SourceSafe et stocke cet historique dans SQL Express. Le convertisseur trie ensuite l'historique et effectue quelques traitements supplémentaires. Enfin, il lit l'historique de SQL Express et démarre la migration.

Vous devez vous assurer que vous avez les droits d'administrateur sur SQL Express. Si vous installez Visual Studio 2005, vous avez automatiquement les droits d'administrateur.

Remarque Remarque

Le convertisseur peut s'arrêter dans la phase de préparation de migration d'une très grande base de données Visual SourceSafe à cause de la limite de 4 Go de SQL Express. Pour continuer, vous devez soit configurer le convertisseur pour qu'il utilise SQL Server à la place de SQL Express, soit essayer de migrer des plus petits dossiers ou un historique partiel à l'aide de la fonction Archiver de Visual SourceSafe. Vous pouvez configurer le convertisseur pour qu'il utilise le serveur SQL dans le fichier de paramètres.

Pour exécuter l'analyse de la migration du contrôle de code source, vous devez être administrateur système de SQLExpress. Par défaut, si vous avez installé Visual Studio, vous avez déjà les privilèges requis pour SQLExpress. Si vous n'êtes pas administrateur système pour le SQLExpress installé, un administrateur système doit vous ajouter en tant qu'administrateur système.

Pour ajouter un administrateur système pour SQLExpress

  1. Installez SQL Express sur l'ordinateur sur lequel vous exécuterez le convertisseur Visual SourceSafe. Lorsque vous installez Visual Studio 2005, SQL Express est installé par défaut.

  2. À l'invite de commandes, tapez les commandes suivantes :

    Image Copier le code Copier le code
                SQLCMD.exe -S localhost\SQLExpress -E
EXEC sp_grantlogin <username> -- add as user
GO
EXEC sp_addsrvrolemember <username>, 'sysadmin'
GO

Sécurité

Vous devez être membre des groupes Administrateurs d'espace de noms et Administrateurs Team Foundation sur Team Foundation pour effectuer cette procédure. Vous devez également être administrateur de systèmes pour SQL Express.

Voir aussi

Tâches

Comment : analyser le processus de migration de votre base de données VSS


Comment : préparer Team Foundation pour la migration

Comment : préparer Team Foundation pour la migration

Avant de démarrer votre migration, vous devez préparer Team Foundation pour la migration.

Pour préparer Team Foundation pour la migration

  1. Installez Team Explorer sur l'ordinateur sur lequel vous souhaitez exécuter le convertisseur VSS. Le convertisseur Visual SourceSafe fait partie du client Team Foundation qui est appelé Team Explorer.

  2. Contactez un administrateur Team Foundation pour vous ajouter au groupe Team Foundation Administrators sur Team Foundation avant de démarrer la migration. Pour plus d'informations, consultez Comment : ajouter un utilisateur.

Voir aussi

Tâches

Comment : créer un fichier de paramètres pour l'analyse et la migration du contrôle de code source
Comment : configurer SQL Express pour la migration
Comment : ajouter un utilisateur


Migration du contrôle de code source

Migration du contrôle de code source
DropDown image

Cette section contient des informations sur la migration de vos sources dans les projets Visual SourceSafe vers le contrôle de code source Team Foundation. Avant la migration, vous devez identifier les dossiers de destination dans Team Foundation pour chaque dossier Visual SourceSafe. Le dossier de destination doit être vide s'il existe. Si les dossiers de destination n'existent pas, le convertisseur crée le dossier. Cette rubrique suppose que vous avez consulté la section Planification de la migration du contrôle de code source.

Dans cette section

Comment : modifier le fichier de mappage utilisateur relatif à la migration du contrôle de code source

Décrit comment contrôler la migration des informations utilisateur vers le contrôle de code source Team Foundation.

Comment : effectuer une migration par incrément vers Team Foundation

Décrit comment effectuer une migration incrémentielle si votre migration a été interrompue ou comment effectuer une migration des modifications qui ont été apportées après la fin de votre migration d'origine.

Comment : effectuer une migration de Visual SourceSafe vers Team Foundation

Décrit comment effectuer une migration de la source de Visual SourceSafe vers le contrôle de code source Team Foundation.

Comment : effectuer la migration partielle d'un historique à l'aide des archives dans Visual SourceSafe

Décrit comment effectuer une migration de l'historique à partir des archives Visual SourceSafe.

Voir aussi

Référence

Commande VSSConverter pour la migration du contrôle de code source

Autres ressources

Planification de la migration du contrôle de code source
Après la migration du contrôle de code source


Comment : modifier le fichier de mappage utilisateur relatif à la migration du contrôle de code source

Comment : modifier le fichier de mappage utilisateur relatif à la migration du contrôle de code source
Voir aussi

La phase d'analyse génère un fichier de mappage utilisateur. Ce fichier inclut tous les utilisateurs Visual SourceSafe qui ont exécuté une opération de contrôle de code source sur les dossiers migrés. Vous pouvez utiliser ce fichier pour mapper des utilisateurs Visual SourceSafe aux utilisateurs Team Foundation. Si vous ne mappez pas d'utilisateurs, le convertisseur utilise le nom de l'utilisateur Visual SourceSafe dans le contrôle de code source Team Foundation.

Pour personnaliser le fichier de mappage utilisateur

  1. Dans le dossier où vous avez exécuté l'analyse, tapez notepad usermap.xml à l'invite de commandes et appuyez sur Entrée.

    Le fichier XML suivant apparaît :

    Image Copier le code Copier le code
    <?xml version="1.0" encoding="utf-8"?>
<UserMappings>
<UserMap From="Admin" To=""></UserMap>
<UserMap From="guest" To=""></UserMap>
<UserMap From="Jane" To=""></UserMap>
<UserMap From="Mike" To=""></UserMap>
</UserMappings>

  2. Pour chaque nom d'utilisateur Visual SourceSafeà mapper, ajoutez un nom d'utilisateur Windows NT valide ou un nom d'utilisateur Team Foundation Server dans le champ « À », comme indiqué dans cet exemple :

    Image Copier le code Copier le code
    <?xml version="1.0" encoding="utf-8"?>
<UserMappings>
<UserMap From="Admin" To="MYDOMAIN\Jennifer"></UserMap>
<UserMap From="guest" To="TestAlias1"></UserMap>
<UserMap From="Jane" To="Jane"></UserMap>
<UserMap From="Mike" To=""></UserMap>
</UserMappings>
    Remarque Conseil

    Assignez le compte invité Visual SourceSafe à un compte d'utilisateur Windows ou à un utilisateur Team Foundation si vous le pouvez afin d'éviter de perdre un enregistrement d'actions de versioning effectuées au nom de l'utilisateur invité.

  3. Enregistrez vos modifications et fermez le Bloc-notes.

Voir aussi

Tâches

Comment : créer un fichier de paramètres pour l'analyse et la migration du contrôle de code source
Comment : préparer votre base de données Visual SourceSafe avant l'exécution du convertisseur
Comment : effectuer une migration de Visual SourceSafe vers Team Foundation
Procédure pas à pas : préparation pour effectuer une migration de Visual SourceSafe vers Team Foundation
Procédure pas à pas : migration de Visual SourceSafe vers Team Foundation


Comment : effectuer une migration par incrément vers Team Foundation

Comment : effectuer une migration par incrément vers Team Foundation
Voir aussi

Cette rubrique décrit comment effectuer une migration incrémentielle si vous souhaitez migrer votre base de données Visual SourceSafe par phases ou si votre migration a été interrompue et que vous souhaitez reprendre la migration là où elle s'est arrêtée. La migration d'une base de données Visual SourceSafe par phases garantit que les utilisateurs peuvent continuer à utiliser Visual SourceSafe pendant le processus de migration. Au cours d'une migration incrémentielle, le convertisseur migrera uniquement le delta des modifications qui n'ont pas été migrées précédemment.

Restrictions relatives à la migration incrémentielle

Tenez compte des restrictions suivantes qui s'appliquent au début de la migration incrémentielle et tout au long des phases de la migration incrémentielle.

  • Vous ne devez pas modifier le mappage existant des dossiers Visual SourceSafe en dossiers de contrôle de code source Team Foundation. Vous ne devez également pas ajouter ou supprimer des mappages.

  • N'effectuez aucune action de destruction, de purge, d'archivage ou de restauration sur la base de données Visual SourceSafe.

  • N'utilisez pas les dossiers de contrôle de code source Team Foundation migrés.

Pour effectuer une migration par phases

  1. Demandez aux utilisateurs de cesser d'utiliser la base de données Visual SourceSafe.

  2. Copiez la base de données Visual SourceSafe vers un autre ordinateur dédié à l'exécution de la migration.

  3. Informez des utilisateurs Visual SourceSafe qu'ils peuvent continuer à utiliser la base de données Visual SourceSafe.

  4. Exécutez la migration normale sur la base de données Visual SourceSafe copiée sur l'ordinateur de migration.

  5. Attendez la fin de la migration.

  6. Lorsque la migration est terminée, demandez aux utilisateurs de cesser d'utiliser la base de données Visual SourceSafe. Copiez la base de données Visual SourceSafe vers l'ordinateur de migration.

  7. Faites une copie de sauvegarde du fichier de rapport généré par le processus de migration antérieur pour référence future.

  8. Redémarrez la migration sur la base de données Visual SourceSafe copiée. Le convertisseur VSS déterminera automatiquement qu'il s'agit d'une migration incrémentielle et commencera à migrer les modifications qui se sont produites après la migration initiale.

    1. Dans le menu Démarrer, cliquez sur Tous les programmes, puis sur Microsoft Visual Studio 2005, Visual Studio Tools et cliquez sur Invite de commandes de Visual Studio 2005.

    2. À l'invite de commandes, tapez la commande suivante en utilisant le même fichier de paramètres que celui que vous avez utilisé au cours du processus de migration antérieur :

      VSSConverter Migrate settings.xml

      Remarque Conseil

      Utilisez le commutateur /? pour afficher les options de ligne de commande disponibles.

    3. Le convertisseur détecte automatiquement qu'il s'agit d'une migration incrémentielle et vous invite à confirmer que vous souhaitez effectuer une migration incrémentielle. Tapez Y pour confirmer que vous souhaitez effectuer une migration incrémentielle.

    4. L'outil de conversion affiche l'état de migration. Lorsque le processus de conversion est terminé, l'outil enregistre un rapport de post-migration dans le répertoire actif. Vous pouvez utiliser Microsoft Internet Explorer pour afficher le contenu du fichier.

    5. Lorsque vous y êtes invités, saisissez le mot de passe de l'utilisateur Admin de Visual SourceSafe.

  9. Lorsque vous avez terminé toutes les phases incrémentielles de la migration de la base de données Visual SourceSafe, vous pouvez basculer les utilisateurs vers la source migrée sur le contrôle de code source Team Foundation.

Pour redémarrer la migration après son interruption

  1. Résolvez le problème à l'origine de l'interruption de la migration.

  2. Faites une copie de sauvegarde du fichier de rapport généré par le processus de migration antérieur pour référence future.

  3. Suivez l'étape 8 de la précédente procédure « Pour effectuer une migration par phases ».

Sécurité

Vous devez être membre des groupes Administrateurs Team Foundation sur Team Foundation Server pour terminer cette procédure. Vous devez également être administrateur de systèmes pour SQL Express.

Voir aussi

Tâches

Comment : créer un fichier de paramètres pour l'analyse et la migration du contrôle de code source
Comment : préparer votre base de données Visual SourceSafe avant l'exécution du convertisseur
Procédure pas à pas : préparation pour effectuer une migration de Visual SourceSafe vers Team Foundation
Procédure pas à pas : migration de Visual SourceSafe vers Team Foundation
Comment : effectuer une migration de Visual SourceSafe vers Team Foundation


Comment : effectuer une migration de Visual SourceSafe vers Team Foundation

Comment : effectuer une migration de Visual SourceSafe vers Team Foundation
Voir aussi

Avant d'effectuer une migration d'utilisateurs de Visual SourceSafe vers le contrôle de code source Team Foundation, vous devez effectuer les opérations suivantes :

  • préparer votre base de données pour la migration ; Pour plus d'informations, consultez Comment : préparer votre base de données Visual SourceSafe avant l'exécution du convertisseur.

  • vous connecter à un serveur Team Foundation Server et créer un projet d'équipe ; Pour plus d'informations, consultez Procédure pas à pas : rejoindre d'un projet d'équipe et Comment : créer un projet d'équipe.

  • créer ou modifier votre fichier de paramètres de la migration ; Pour plus d'informations, consultez Comment : créer un fichier de paramètres pour l'analyse et la migration du contrôle de code source

  • modifier le fichier de mappage utilisateur créé pendant l'analyse de base de données. Pour plus d'informations, consultez Comment : modifier le fichier de mappage utilisateur relatif à la migration du contrôle de code source.

Remarque Remarque

Reprise de la migration. Si la migration échoue pour une raison quelconque, vous pouvez reprendre la migration à partir du point auquel le processus de migration s'est arrêté. Réexécutez le convertisseur et lorsque vous êtes invité à spécifier si vous souhaitez effectuer une migration incrémentielle, sélectionnez O pour poursuivre la migration. Pour plus d'informations, consultez Comment : effectuer une migration par incrément vers Team Foundation.

Pour exécuter le convertisseur

  1. Dans le menu Démarrer, cliquez sur Tous les programmes, puis sur Microsoft Visual Studio 2005, Visual Studio Tools et cliquez sur Invite de commandes de Visual Studio 2005.

  2. À l'invite de commandes, tapez ce qui suit :

    VSSConverter Migrate settings.xml

    Remarque Conseil

    Utilisez le commutateur /? pour afficher les options de ligne de commande disponibles.

  3. Tapez Y pour confirmer la migration.

    L'outil de conversion affiche l'état de migration. Lorsque le processus de conversion est terminé, l'outil enregistre un rapport de post-migration dans le répertoire actif. Vous pouvez utiliser Internet Explorer pour afficher le fichier du rapport contenant des informations détaillées.

  4. Lorsque vous y êtes invité, saisissez le mot de passe de l'utilisateur Admin de Visual SourceSafe.

Sécurité

Vous devez être un membre des groupes Administrateurs Team Foundation sur Team Foundation pour effectuer cette procédure. Vous devez également être administrateur de systèmes pour SQL Express.

Voir aussi

Tâches

Comment : effectuer une migration par incrément vers Team Foundation
Comment : créer un fichier de paramètres pour l'analyse et la migration du contrôle de code source
Comment : préparer votre base de données Visual SourceSafe avant l'exécution du convertisseur
Procédure pas à pas : préparation pour effectuer une migration de Visual SourceSafe vers Team Foundation
Procédure pas à pas : migration de Visual SourceSafe vers Team Foundation


Comment : effectuer la migration partielle d'un historique à l'aide des archives dans Visual SourceSafe

Comment : effectuer la migration partielle d'un historique à l'aide des archives dans Visual SourceSafe
Voir aussi

Si vous migrez des sources de Visual SourceSafe vers le contrôle de code source Team Foundation et que vous ne souhaitez pas l'ensemble de l'historique stocké dans Visual SourceSafe, vous pouvez migrer l'historique après une date spécifique à l'aide de la fonctionnalité d'archivage dans Visual SourceSafe.

Attention Attention

L'utilisation de cette méthode supprime définitivement l'historique des versions de la base de données Visual SourceSafe, c'est pourquoi vous devez exécuter l'archivage sur une copie de la base de données.

Remarque Remarque

L'archive Visual SourceSafe a une limitation de 2 Go pour la taille du fichier d'archive. Si vous obtenez une erreur, archivez séparément des plus petits dossiers.

Pour migrer un historique partiel à l'aide de l'archive dans Visual SourceSafe

  1. Copiez votre base de données Visual SourceSafe sur l'ordinateur sur lequel vous allez exécuter la migration.

  2. Utilisez les fonctionnalités d'archive dans Visual SourceSafe pour supprimer l'historique des versions antérieur à votre horodatage souhaité. Pour déterminer l'horodatage, vous pouvez utiliser l'une des méthodes suivantes :

    • Étiquette

    • Version d'un dossier

    • Date

    Pour plus d'informations sur l'archivage dans Visual SourceSafe, consultez Archiver les bases de données Visual SourceSafe.

  3. Terminez la migration à l'aide de la copie de la base de données Visual SourceSafe pour laquelle vous avez archivé l'historique.

Sécurité

Vous devez être administrateur Visual SourceSafe pour archiver la base de données Visual SourceSafe.

Voir aussi

Tâches

Procédure pas à pas : préparation pour effectuer une migration de Visual SourceSafe vers Team Foundation
Procédure pas à pas : migration de Visual SourceSafe vers Team Foundation

Autres ressources

Migration du contrôle de code source


Après la migration du contrôle de code source

Après la migration du contrôle de code source
DropDown image

Après avoir réussi la migration du contrôle de code source, vous devez vérifier que les sources ont été migrées vers le contrôle de code source Team Foundation. Après une migration réussie, vous devez voir s'il existe des différences entre les dernières versions de fichiers et de dossiers dans Visual SourceSafe et les dernières versions des sources migrées dans le contrôle de code source Team Foundation à l'aide d'un utilitaire de comparaison de fichier tel que l'outil WinDiff. Si vous recherchez des différences entre les fichiers, les dossiers ou leurs versions, vous devez migrer la dernière version manuellement.

Remarque Remarque

Vous trouverez toujours des fichiers supplémentaires côté Visual SourceSafe finissant par l'extension *. * scc. Ces fichiers sont temporairement générés par Visual SourceSafe dans votre dossier local lorsque vous utilisez une commande Obtenir pour obtenir version la plus récente dans Visual SourceSafe. Les fichiers supplémentaires ne sont pas des fichiers sources.

Dans cette section

Comment : effectuer la migration des liaisons du contrôle de code source provenant de Visual SourceSafe

Décrit comment migrer des liaisons de contrôle de code source dans Visual Studio à partir de Visual SourceSafe vers le contrôle de code source Team Foundation.

Interprétation du rapport de migration du contrôle de code source

Contient des informations sur les messages que vous pouvez voir dans votre rapport de migration.

Dépannage de la migration du contrôle de code source

Contient les rubriques qui vous aident à résoudre les problèmes de migration.

Voir aussi

Autres ressources

Démarrage avec Team Foundation
Procédures pas à pas relatives au contrôle de code source Team Foundation
Utilisation du contrôle de code source Team Foundation


Comment : effectuer la migration des liaisons du contrôle de code source provenant de Visual SourceSafe

Comment : effectuer la migration des liaisons du contrôle de code source provenant de Visual SourceSafe
Voir aussi

Après la migration de votre projet soumis au contrôle de code source de Visual SourceSafe vers Team Foundation, vous devez migrer les liaisons de contrôle de code source vers Team Foundation pour exécuter des opérations de contrôle de code source dans l'environnement Visual Studio. Vous pouvez utiliser la procédure suivante pour convertir au format Visual Studio 2005 des solutions et des projets qui ont été développés dans les versions Visual Studio antérieures à Visual Studio 2005. Vous pouvez également modifier leurs liaisons de contrôle de code source.

Pour convertir et modifier la liaison de contrôle de code source

  1. Dans Explorateur du contrôle de code source, cliquez avec le bouton droit sur le dossier qui contient la solution puis choisissez Obtenir la dernière version.

  2. Si le dossier n'est pas mappé à votre espace de travail, la boîte de dialogue Rechercher un dossier s'ouvre. Sélectionnez un dossier approprié sur votre ordinateur local et cliquez sur OK.

    Une copie du dossier et des fichiers est récupérée dans le dossier local mappé.

  3. Cliquez avec le bouton droit sur le dossier qui contient la solution puis choisissez Extraire pour modification.

  4. Dans la boîte de dialogue Extraire, cliquez sur Extraire.

  5. Dans le menu Fichier, cliquez sur Ouvrir, puis sur Projet/Solution.

  6. Dans la boîte de dialogue Ouvrir un projet, recherchez et sélectionnez le fichier solution que vous avez extrait et cliquez sur Ouvrir.

  7. Dans l'Assistant Conversion de Visual Studio, cliquez sur Terminer.

    Team Foundation convertit automatiquement les fichiers solution (.sln) et projet (.proj) au format Visual Studio 2005. La solution est également liée à Team Foundation.

  8. Lorsque la conversion est terminée, cliquez sur Fermer.

  9. Dans l'Explorateur du contrôle de code source, cliquez avec le bouton droit sur le dossier qui contient la solution, puis choisissez Archiver les modifications en attente.

  10. Indiquez les détails requis dans la boîte de dialogue Archiver, sélectionnez tous les fichiers et cliquez sur Archiver.

Voir aussi

Tâches

Procédure pas à pas : migration de Visual SourceSafe vers Team Foundation

Autres ressources

Migration du contrôle de code source


Interprétation du rapport de migration du contrôle de code source

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Interprétation du rapport de migration du contrôle de code source
Voir aussi
Image de liste déroulante

Vous pouvez consulter le rapport de migration du contrôle de code source à l'aide d'Internet Explorer. Le rapport est généré sous la forme d'un fichier XML. Les fichiers de prise en charge, par exemple, des fichiers graphiques et .XSLT, sont utilisés pour restituer ces fichiers à l'utilisateur.

Rapport d'analyse et de migration

Le rapport est divisé en sections et certaines sections sont elles-mêmes divisées en sous-sections. Les sections Erreur critique, Erreur et Avertissement apparaissent uniquement si des erreurs ou des avertissements ont été détectés lors de la migration. Chaque section du rapport est réductible. Vous pouvez cliquer sur l'icône dans l'en-tête de la section pour développer ou réduire celle-ci.

La plupart des sections et le contenu sont les mêmes pour le rapport d'analyse et le rapport de migration.

Le rapport peut contenir les sections de la liste suivante. Chacune de ces sections est expliquée de façon plus approfondie dans cette rubrique.

  • Résumé Résume les résultats de l'analyse ou de la migration.

    Remarque Remarque

    Le nombre d'actions analysées peut être différent du nombre d'actions migrées car toutes les actions analysées ne sont pas forcément migrées, par exemple, les actions d'archivage, de restauration, de purge et de destruction.

  • Erreur critique Si l'analyse ou la migration est interrompue à cause d'une erreur irrécupérable, cette section sera incluse dans le rapport et fournira une description de l'erreur qui a causé l'échec de l'analyse ou de la migration.

  • Erreur Le convertisseur n'est pas toujours capable d'analyser ou d'effectuer une migration des fichiers et des dossiers ou des versions spécifiques de fichiers et de dossiers parce que la base de données Visual SourceSafe dont vous effectuez une migration est endommagée ou parce qu'il se produit un cas non pris en charge dans le convertisseur. Cette section répertorie ce type d'erreurs de perte de données.

  • Avertissements Cette section contient des informations sur la perte ou la modification d'informations due au fait que les données de Visual SourceSafe n'ont pas pu être migrées vers le contrôle de code source Team Foundation. Pendant l'analyse, le convertisseur signalera cette perte d'informations potentielle. Vous pouvez choisir de prendre des mesures pour prévenir la perte d'informations ou accepter que les informations soient perdues lors de la migration.

  • Entrée d'utilisateur La section d'entrée d'utilisateur décrit les options de ligne de commande fournies par l'utilisateur au convertisseur.

Résumé

Le tableau suivant décrit les entrées de la section Résumé du rapport:

Entrée | Description
État | Affiche si la migration ou l'analyse était réussie ou pas et indique le nombre d'erreurs ou d'avertissements. Cliquez sur le numéro d'erreur ou d'avertissement pour afficher ces sections.
Version du contrôle de code source | Programme et version du contrôle de code source à partir desquels la source a été migrée ou pour lequel l'analyse de migration a été réalisée.
Base de données VSS | Chemin d'accès à la base de données Visual SourceSafe.
Team Foundation Server (rapport de migration uniquement) | Team Foundation Server vers lequel la source a été migrée.
Actions migrées/analysées | Nombre des actions qui ont été migrées ou analysées.
Heure de début | Heure de début de la migration ou de l'analyse.
Heure de fin | Heure de fin de la migration ou de l'analyse.
Durée totale | Durée totale effective de l'exécution de la migration ou de l'analyse.
Migration/Analyse réalisée par | Alias de la personne qui a exécuté la migration ou analyse.
Dossiers migrés/analysés | Répertorie les dossiers qui ont été migrés ou analysés.

Erreur critique

Si l'analyse ou la migration est interrompue à cause d'une erreur irrécupérable, cette section sera incluse dans le rapport et fournira une description de l'erreur qui a causé l'échec de l'analyse ou de la migration.

Erreur

La section d'erreurs contient des informations sur les problèmes qui se sont produits lors de la migration ou de l'analyse, par exemple, des versions de fichiers et de dossiers qui n'ont pas pu être migrées. Chaque message d'erreur donne une brève description des erreurs détectées lors de la migration ou de l'analyse et contient un lien vers un document qui donne des détails concernant l'erreur.

Pour plus d'informations sur les erreurs de migration et d'analyse, consultez Messages de rapport de migration du contrôle de code source.

Avertissements

La section Avertissements contient des informations sur les problèmes qui se sont produits lors de la migration ou de l'analyse, par exemple, une perte de données lors de la migration. Chaque avertissement donne une brève description de la perte des données potentielle ou effective lors de la migration ou de l'analyse et contient un lien vers un document qui donne des détails concernant l'erreur.

Pour plus d'informations sur les avertissements de migration et d'analyse, consultez Messages de rapport de migration du contrôle de code source.

Entrée d'utilisateur

La section d'entrées d'utilisateur indique les options de ligne de commande qui ont été utilisées pour exécuter la conversion.

Entrée | Description
Commande | Indique l'entrée de ligne de commande utilisée pour exécuter la migration ou l'analyse.
Options utilisateur | Détails des options spécifiées sur la ligne de commande par l'utilisateur.

Voir aussi

Concepts

Messages de rapport de migration du contrôle de code source


Dépannage de la migration du contrôle de code source

Dépannage de la migration du contrôle de code source
DropDown image

Si vous rencontrez des problèmes lorsque vous migrez votre base de données contenant le contrôle de code source, les rubriques de cette section peuvent vous aider à corriger les problèmes et à terminer votre migration.

Dans cette section

Messages de rapport de migration du contrôle de code source

Cette rubrique fournit des informations à propos des messages de rapport de migration que vous pouvez consulter dans les rapports de migration.

Erreurs de migration critiques

Cette rubrique répertorie les raisons pour lesquelles les erreurs critiques se produisent lors de la migration et propose des solutions permettant de les corriger.

Erreurs de migration

Cette rubrique répertorie les raisons courantes pour lesquelles les erreurs non critiques et les avertissements se produisent lors de la migration et propose des solutions de contournement.

Voir aussi

Référence

Commande VSSConverter pour la migration du contrôle de code source


Messages de rapport de migration du contrôle de code source

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Messages de rapport de migration du contrôle de code source
Voir aussi
Image de liste déroulante

Le rapport de migration du contrôle de code source comporte une section Erreurs et une section Avertissements. Une section Erreur critique est ajoutée si une erreur irrécupérable arrête la migration ou l'analyse. Cette rubrique explique les messages qui apparaissent dans ces sections.

Remarque Remarque

Le nombre d'actions analysées peut être différent du nombre d'actions migrées car toutes les actions analysées ne sont pas forcément migrées, par exemple, les actions d'archivage, de restauration, de purge et de destruction.

Erreur critique

Si l'analyse ou la migration est interrompue à cause d'une erreur irrécupérable, cette section est incluse dans le rapport et fournie une description de l'erreur qui a provoqué l'échec de l'analyse ou de la migration. Pour plus d'informations, consultez Erreurs de migration critiques.

Erreurs

Si vous rencontrez des erreurs pendant l'analyse ou la migration, cela signifie que certains fichiers ou dossiers n'ont pas été migrés. Les erreurs ne signifient pas que la base de données migrée n'est pas utilisable. Vous pouvez choisir d'ignorer les fichiers qui n'ont pas été migrés et de commencer à utiliser les sources migrées dans Team Foundation.

Les erreurs de migration des fichiers et des dossiers sont générées lorsque le convertisseur ne peut pas migrer ou analyser des versions de fichiers ou de dossiers parce qu'il y a un cas non pris en charge dans le convertisseur Visual SourceSafe. Cette section contient des informations sur ces fichiers et dossiers non migrés que le convertisseur ne pouvait pas signaler pendant l'analyse. Chaque message d'erreur donne une brève description de l'erreur qui a été rencontrée pendant la migration ou l'analyse.

Pour plus d'informations, consultez Erreurs de migration.

Avertissements

Cette section contient des informations sur la perte ou la modification d'informations parce que des données dans Visual SourceSafe ne peuvent pas être migrées vers le contrôle de code source Team Foundation pour une raison connue. Pendant l'analyse, le convertisseur avertit de cette perte d'informations potentielle, à l'exception des avertissements de perte de données provoquée par endommagement de la base de données Visual SourceSafe. Fréquemment, lorsque la base de données Visual SourceSafe est endommagée, vous ne serez pas en mesure de récupérer la version via la ligne de commande VSS ou l'Explorateur VSS. Parfois, vous pouvez prendre des mesures pour empêcher la perte d'informations ou choisir d'accepter la perte d'informations et de tout de même exécuter le convertisseur.

Chaque message d'avertissement donne une brève description des avertissements détectés lors de la migration ou de l'analyse et contient un lien vers un document qui donne des détails concernant l'avertissement.

Avertissements de perte de données

La liste suivante présente les avertissements de perte de données que le convertisseur peut rencontrer pendant la migration ou l'analyse :

  • Perte de données due au déplacement d'un dossier source qui n'est pas en cours de migration vers un dossier de destination en cours de migration

  • Perte de données due au déplacement d'un dossier source qui est en cours de migration vers un dossier de destination qui n'est pas en cours de migration

  • Le partage n'est pas pris en charge dans le contrôle de code source Team Foundation.

  • Versions ou historique des fichiers et dossiers VSS non extraits par le convertisseur

Autres avertissements

Le tableau suivant répertorie les autres avertissements que le convertisseur peut rencontrer pendant la migration ou l'analyse :

  • Risque potentiel de perte de données en raison de problèmes de fuseau horaire avec la base de données Visual SourceSafe en cours de migration.

  • Liste des fichiers extraits.

  • Noms d'étiquettes qui seront modifiés en raison de la migration

  • Liste des fichiers dont la propriété Visual SourceSafe de 'conservation de la dernière version uniquement' est activée.

Voir aussi

Concepts

Interprétation du rapport de migration du contrôle de code source


Erreurs de migration critiques

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Erreurs de migration critiques
Voir aussi
Image de liste déroulante

Si une analyse ou une migration est interrompue, vous recevrez une erreur critique qui indique la cause de l'échec de l'analyse ou de la migration. Le convertisseur vous permet de redémarrer la migration au point où la migration avait été interrompue. Pour plus d'informations sur la migration incrémentielle, consultez la remarque en haut de la rubrique Comment : effectuer une migration de Visual SourceSafe vers Team Foundation.

Sont exposées ci-dessous les raisons les plus courantes de réception d'une erreur critique pendant la migration :

  • Vous annulez la migration Pendant la migration ou l'analyse, vous avez forcé l'arrêt en mettant fin au processus d'application. Vous pouvez redémarrer la migration au point où elle s'est arrêtée à l'aide de la migration incrémentielle. Pour plus d'informations sur la migration incrémentielle, consultez Comment : effectuer une migration de Visual SourceSafe vers Team Foundation.

  • La migration s'est interrompue en raison d'une erreur dans la base de données SQL utilisée par le convertisseur Le convertisseur VSS utilise SQL Express ou SQL Server pour traiter les données pendant la migration. Lorsque vous recevez cette erreur, la migration est interrompue à cause d'une erreur irrécupérable qui se produit avec la base de données SQL. Le message d'erreur reçu par le convertisseur est ajouté à la description de l'erreur critique. En vous référant aux informations du message d'erreur, résolvez le problème et redémarrez la migration au point où elle a cessé à l'aide de la migration incrémentielle. Pour plus d'informations sur la migration incrémentielle, consultez Comment : effectuer une migration de Visual SourceSafe vers Team Foundation.

  • L'application est incapable de gérer l'exception Le convertisseur VSS est incapable de gérer une exception irrécupérable pendant l'analyse ou la migration. Le message d'erreur reçu par le convertisseur est ajouté à la description de l'erreur critique. À l'aide du message d'erreur, essayez de résoudre le problème. Dès que le problème est résolu, l'analyse doit être démarrée à partir du commencement ; toutefois, si vous effectuez une migration, vous pouvez redémarrer la migration au point où elle a cessé à l'aide de la migration incrémentielle. Pour plus d'informations sur la migration incrémentielle, consultez Comment : effectuer une migration par incrément vers Team Foundation.

Voir aussi

Concepts

Messages de rapport de migration du contrôle de code source


Erreurs de migration

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Erreurs de migration
Voir aussi
Image de liste déroulante

Si vous rencontrez des erreurs pendant l'analyse ou la migration, cela signifie que certains fichiers ou dossiers n'ont pas été migrés. Cela ne signifie pas que la base de données migrée est inutilisable. Vous pouvez choisir d'ignorer les fichiers qui n'ont pas été migrés et de commencer à utiliser les sources migrées dans Team Foundation.

Les erreurs de migration des fichiers et des dossiers sont générées lorsque le convertisseur ne peut pas migrer ou analyser des versions de fichiers ou de dossiers parce qu'il y a un cas non pris en charge dans le convertisseur Visual SourceSafe. Cette section contient des informations d'avertissement sur les fichiers et les dossiers non migrés qui ne s'afficheraient sur le convertisseur pendant l'analyse. Chaque message d'erreur donne une brève description de l'erreur qui a été rencontrée pendant la migration ou l'analyse.

Les éléments suivants représentent des erreurs et des solutions courantes :

  • Impossible de migrer Le convertisseur a détecté un scénario de l'historique des versions qui n'est pas pris en charge. Par conséquent, les fichiers et les dossiers concernés dans le scénario de l'historique des versions n'ont pas pu être migrés correctement. Utilisez un utilitaire de comparaison de fichiers, tel que WinDiff, pour rechercher les différences entre les dernières versions des fichiers et des dossiers contenus dans Visual SourceSafe et les dernières versions des fichiers et des dossiers migrés dans le contrôle de code source Team Foundation. S'il existe des différences entre les fichiers, les dossiers ou leurs versions, migrez manuellement la version la plus récente des fichiers et des dossiers.

Remarque Remarque

Vous pouvez effectuer une migration manuelle d'un fichier ou d'un dossier en obtenant la version la plus récente à partir de Visual SourceSafe et l'ajoutant au contrôle de code source Team Foundation à l'aide de l'Explorateur du contrôle de code source ou du client de la ligne de commande tf.

  • Impossible de migrer le dossier de manière récursive en raison d'une erreur d'E/S Au cours de la migration, le convertisseur n'a pas pu ajouter de dossier à Team Foundation à cause d'une erreur d'entrée/sortie. Le message d'erreur est ajouté à la brève description de l'erreur. Après la migration, vous pouvez ajouter la dernière version du dossier en obtenant la version la plus récente des fichiers et des dossiers dans Visual SourceSafe, puis en effectuant un archivage unique de ces versions.

  • Impossible d'effectuer une migration en raison d'une erreur Team Foundation Le convertisseur ne peut pas migrer de version du fichier ou du dossier en raison de problèmes connus, ou inconnus, avec Team Foundation. Le message d'erreur reçu de Team Foundation par le convertisseur est ajouté à la brève description de l'erreur. Essayez de résoudre le problème en obtenant une copie du fichier ou du dossier à partir de Visual SourceSafe et l'archivant manuellement dans Team Foundation.

  • Impossible de migrer l'étiquette en raison d'une erreur Team Foundation Le convertisseur ne peut pas appliquer d'étiquette de contrôle de code source Team Foundation. Le message d'erreur reçu de Team Foundation par le convertisseur est ajouté à la brève description de l'erreur.

  • Impossible d'effectuer une migration. Le chemin d'accès contient plus de caractères que les 260 autorisés La longueur maximale du chemin d'accès au serveur prise en charge par le contrôle de code source Team Foundation est de 260 caractères. Le convertisseur ne peut pas migrer la version du fichier ou du dossier à cause de cette contrainte.

Voir aussi

Concepts

Erreurs de migration critiques
Messages de rapport de migration du contrôle de code source


Commande VSSConverter pour la migration du contrôle de code source

 Image de liste déroulante Image de pointage sur liste déroulante Image de réduction Image de développement Image Réduire tout Image Développer tout Copier l'image de pointage
Visual Studio Team System
Commande VSSConverter pour la migration du contrôle de code source
Voir aussi
Image Réduire tout Image de liste déroulante

La commande VSSConverter permet d'analyser et de migrer des bases de données Visual SourceSafe pour la migration vers le contrôle de code source Team Foundation.

Image de développement Syntaxe

VSSConverter [/? /h /help ] [analyze | migrate ] settings_file

analyze

Analyse les résultats de migration attendus pour une base de données Visual SourceSafe.

migrate

Fait migrer une base de données Visual SourceSafe.

settings_file

Fichier XML spécifiant les paramètres d'analyse ou de migration.

/?, /h, /help

Affiche l'aide.

Image de développement Notes

Avant d'exécuter le convertisseur Visual SourceSafe (VSS), vous devez procéder comme suit :

  • Créer un fichier de paramètres qui contient les informations suivantes :

    • L'emplacement de la base de données Visual SourceSafe.

    • L'emplacement et le nom du fichier de rapport de sortie (facultatif).

    • L'emplacement et le nom du fichier de mappage utilisateur (facultatif).

    Pour plus d'informations, consultez Comment : créer un fichier de paramètres pour l'analyse et la migration du contrôle de code source.

Le nom de fichier par défaut du rapport d'analyse est VSSAnalysisReport.xml. Le nom de fichier par défaut du rapport de migration est VSSMigrationReport.xml. Ces fichiers sont créés dans le même répertoire que celui d'exécution du convertisseur.

Si vous spécifiez un fichier de sortie qui existe déjà, le convertisseur s'arrête avec le message d'erreur suivant :

Error: Output file VSSMigration.xml already exist

Lors de l'analyse, si vous n'indiquez pas de fichier de mappage utilisateur, le convertisseur créera un fichier UserMap.xml dans le répertoire actif.

Image de développement Limitations

Vous pouvez exécuter une seule instance de convertisseur VSS sur un ordinateur.

Image de développement Exemples

Dans cet exemple, la commande exécute une analyse sur la base de données Visual SourceSafe à l'aide de la configuration présente dans le fichier settings.xml.

Image Copier le code Copier le code
VSSConverter analyze settings.xml

Dans cet exemple, la commande exécute une migration sur une base de données Visual SourceSafe à l'aide de la configuration présente dans le fichier settings.xml.

Image Copier le code Copier le code
VSSConverter migrate settings.xml

Image de développement Voir aussi

Tâches

Procédure pas à pas : préparation pour effectuer une migration de Visual SourceSafe vers Team Foundation
Procédure pas à pas : migration de Visual SourceSafe vers Team Foundation
Comment : créer un fichier de paramètres pour l'analyse et la migration du contrôle de code source
Comment : créer un fichier de paramètres pour l'analyse et la migration du contrôle de code source
Comment : créer un projet d'équipe
Comment : ajouter un projet ou une solution au contrôle de code source


Migration à partir de ClearQuest

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Migration à partir de ClearQuest
Voir aussi
Image de liste déroulante

Le convertisseur de la migration de l'élément de travail :

  • lit les éléments de travail à partir de ClearQuest ;

  • écrit les données dans Team Foundation à l'aide des services Web du suivi des éléments de travail de Visual Studio Team System ;

  • effectue une migration des pièces jointes et des liens ;

  • effectue une migration des informations sur l'élément de travail en double.

Pour écrire les données dans Team Foundation, le convertisseur relit les actions que les utilisateurs ont exécutées dans le système de suivi des éléments de travail d'origine. Par exemple, si un élément de travail était ouvert, résolu, puis fermé, le convertisseur ouvrirait l'élément de travail dans Team Foundation, le résoudrait, puis le fermerait et l'enregistrerait à chaque fois. Le convertisseur conserve les noms d'utilisateurs et dates de ces actions.

Vous pouvez contrôler comment les données sont mappées à partir de ClearQuest vers Team Foundation, notamment la modification des valeurs de champ et le mappage des utilisateurs. Vous spécifiez les paramètres du convertisseur en modifiant les fichiers XML qui contrôlent la migration des données.

Les sections suivantes peuvent vous aider à effectuer une migration de vos éléments de travail vers Team Foundation.

Limites du convertisseur ClearQuest

Décrit des limitations du convertisseur ClearQuest qui comprend la liste des éléments qui ne sont pas migrés.

Planification de la migration des éléments de travail

Décrit comment planifier une migration à partir de ClearQuest vers Team Foundation.

Migration des éléments de travail

Décrit comment migrer les éléments de travail de ClearQuest vers Team Foundation.

Après la migration des éléments de travail

Décrit les tâches à effectuer après la migration pour vérifier si elle a réussi et dépanné les problèmes de migration.

Référence de la ligne de commande pour la migration des éléments de travail

Répertorie toutes les options de ligne de commande pour le convertisseur de la migration de l'élément de travail.

Schéma du suivi des éléments de travail

Le schéma du suivi des éléments de travail de Team Foundation définit un type d'élément de travail spécifique. Le schéma définit :

  • les champs, les noms de champs et les types de champs sur un formulaire d'élément de travail ;

  • les règles associées à un élément de travail. Par exemple, un élément de travail peut avoir une règle selon laquelle la date d'ouverture a pour valeur la date du jour au moment de la création d'un nouvel élément de travail.

  • la liste de valeurs prises en charge pour un champ ;

  • les caractéristiques des champs, Facultatif/Lecture seule/Obligatoire ;

  • le flux de travail, dans les états où le bogue peut l'effectuer ; ouvrir, résoudre, fermer ;

  • le formulaire d'élément de travail, formulaire utilisé pour suivre des éléments de travail pour votre projet.

Voir aussi

Tâches

Procédure pas à pas : migration d'éléments de travail ClearQuest vers Team Foundation

Concepts

Processus de migration


Limites du convertisseur ClearQuest

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Limites du convertisseur ClearQuest
Voir aussi
Image de liste déroulante

Avant de démarrer votre migration, examinez les limitations du convertisseur ClearQuest et comment ces limitations peuvent affecter les utilisateurs de votre organisation :

  • Le convertisseur ClearQuest ne génère pas les champs d'élément de travail utilisés pour s'intégrer aux autres fonctionnalités de Visual Studio Team System. Si vous souhaitez utiliser les fonctionnalités d'intégration, vous devez ajouter des champs aux éléments de travail après la migration. Pour plus d'informations, consultez Ajout de champs d'intégration dans des types d'éléments de travail.

  • Le convertisseur ne conserve pas le comportement de champ basé sur l'état.

  • Le contenu de fichiers XML utilisé par le convertisseur respecte la casse. Par exemple, "USERMAP" et "UserMap" sont deux chaînes différentes.

  • Le convertisseur ne conserve pas le comportement sans état d'enregistrements sans état. Lorsque les enregistrements sans état sont migrés, un seul état par défaut leur est attribué.

  • Le convertisseur effectue une migration l'action non dupliquée dans ClearQuest en ajoutant une action d'annulation de <Action> explicite dans la matrice de transition d'état pour chaque <Action> de type « Dupliqué ». Cette implémentation vous permet d'annuler les transitions d'état afin que l'élément de travail reprenne son état initial avant d'être marqué comme doublon.

  • Le convertisseur effectue une migration des règles de messagerie électronique, mais la sémantique de messagerie électronique n'est pas migrée. Vous devez installer des règles de notification par courrier électronique (appelées « alertes ») dans Team Foundation. Pour plus d'informations, consultez Définition d'alertes.

Ce qui n'est pas migré

Le convertisseur ne prendra pas en charge la migration des éléments suivants:

  • Règles des champs basées sur le script Perl ou Basic dans ClearQuest.

  • Notification par courrier électronique indiquant les modifications apportées dans les valeurs de champ.

  • Comportement de champ défini sur la transition d'état. Sont inclus des éléments tels que les champs obligatoires ou en lecture seule se trouvant dans certains états.

  • Supprimez, importez ou modifiez Action dans le schéma ClearQuest.

  • Familles de type d'enregistrement dans ClearQuest.

  • Éléments d'interface utilisateur de type de case à cocher. Le convertisseur mappe ces champs comme des champs de type entier. Vous devez restreindre manuellement les valeurs à 0 et 1 dans le schéma.

  • Option obligatoire pour les entités référencées.

  • Champs système internes que ClearQuest définit automatiquement. Ces champs sont utilisés par ClearQuest pour la gestion interne et contiennent des données qui seraient inutiles si elles étaient migrées.

  • Règles qui spécifient le jeu de valeurs autorisées pour les champs qui identifient des personnes.

  • Le convertisseur ne suit pas les entités référencées pour la migration. Par exemple, si une défaillance d'entité ClearQuest fait référence à un client d'entité, le client d'entité a une référence arrière à la défaillance d'entité. Si la requête de migration est basée sur le client d'entité, la défaillance d'entité référencée n'est pas migrée.

  • Le convertisseur ne peut pas effectuer une migration des éléments de travail dans lesquels les champs de texte contiennent des caractères non pris en charge. Les caractères non pris en charge dans le code hexadécimal sont #x0-#x8, #x10, #xB, #xC et #xE-#x1F. Il s'agit de caractères de contrôle qui n'apparaissent pas dans les champs de texte utilisés normalement. Lorsque le convertisseur rencontre ces caractères, l'erreur, « Erreur lors de la génération du document XML » est déclenchée. Le convertisseur ignorera l'élément de travail et continuera la migration sur l'élément de travail suivant.

Voir aussi

Concepts

Planification de la migration des éléments de travail
Ajout de champs d'intégration dans des types d'éléments de travail

Autres ressources

Migration des éléments de travail
Après la migration des éléments de travail


Planification de la migration des éléments de travail

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Planification de la migration des éléments de travail
Voir aussi
Image de liste déroulante

Avant d'effectuer une migration des éléments de travail de ClearQuest vers le suivi des éléments de travail Team Foundation, vous devez songer à :

  • installer les logiciels requis pour exécuter le convertisseur ;

  • réunir les informations requises afin d'exécuter la migration ;

  • planifier la migration ;

  • préparer Team Foundation pour la migration.

Ces étapes sont décrites plus en détail dans les sections suivantes.

Installation du logiciel requis pour exécuter le convertisseur

Avant de pouvoir effectuer une migration de vos éléments de travail ClearQuest vers le suivi des éléments de travail Team Foundation, il est nécessaire que le logiciel suivant soit installé sur l'ordinateur sur lequel vous souhaitez exécuter le convertisseur:

  • Team Explorer Pour plus d'informations sur l'installation de Team Explorer, consultez le Guide d'installation Team Foundation. La version la plus récente du Guide d'installation Team Foundation est disponible en ligne à l'adresse http://go.microsoft.com/fwlink/?linkid=40042.

  • Client autonome ClearQuest version 2003.06.00.

    Remarque Remarque

    Il est possible que les versions 2002.05.20 et 2003.05.00 fonctionnent également, mais n'ont pas été testées.

Informations nécessaires à l'exécution de la migration

Vous devez réunir les éléments suivants :

  • Noms d'utilisateurs souhaités dans ClearQuest mappés aux noms de domaines Windows utilisés par le suivi des éléments de travail Team Foundation, y compris les noms d'utilisateurs qui ne sont plus utilisés.

  • Liste des champs d'éléments de travail souhaités dans ClearQuest mappés au suivi des éléments de travail Team Foundation, y compris les informations sur les transformations requises ; par exemple, entre un champ de type chaîne dans ClearQuest et un champ de type entier dans le suivi des éléments de travail Team Foundation.

Planification de la migration

Planifiez un moment auquel vous pouvez demander aux utilisateurs de ne pas utiliser ClearQuest. Cela garantit que les modifications apportées pendant l'exécution du convertisseur ne sont pas perdues. Les week-ends sont généralement un bon moment pour exécuter la migration car la migration de bases de données volumineuses peut prendre beaucoup de temps. Le taux de migration type du convertisseur est environ de 3 500 éléments de travail par heure. Le temps nécessaire à la migration dépend de nombreux facteurs tels que la taille des pièces jointes, le nombre d'entités référencées et la configuration de l'ordinateur utilisé pour la conversion.

Préparation du suivi des éléments de travail Team Foundation pour la migration

Pour préparer le suivi des éléments de travail Team Foundation pour la migration, vous devez procéder comme suit :

  • Créez des projets d'équipe de suivi des éléments de travail Team Foundation Créez des projets d'équipe et déterminez les éléments de travail qui seront associés à chaque projet d'équipe. Pour plus d'informations sur la création de projets d'équipe pour le suivi des éléments de travail Team Foundation, consultez Procédure pas à pas : création d'un nouveau projet d'équipe.

  • Ajoutez le compte d'utilisateur qui exécute la conversion aux Comptes de service Autorisations de compte de service CQConverter requises pour l'exécution. Ajoutez le compte d'utilisateur qui exécutera le convertisseur au groupe Comptes de service sur votre serveur Team Foundation Server en utilisant TFSSecurity. Pour plus d'informations, consultez Commandes de l'utilitaire en ligne de commande TFSSecurity.

  • Vous pouvez également créer ou modifier les types d'éléments de travail Le convertisseur génère des types d'éléments de travail qui correspondent au schéma de types d'éléments de travail dans ClearQuest pendant la phase d'analyse. Toute fois, ces types d'éléments de travail générés nécessitent généralement des modifications ayant pour but d'ajouter des fonctionnalités telles que des règles. Au minimum, vous devez modifier le formulaire d'élément de travail généré afin de spécifier la disposition visuelle des champs car le formulaire généré manque de mise en forme visuelle. Pour plus d'informations, consultez Procédure pas à pas : apporter des personnalisations de base à un type d'élément de travail.

Dans cette section

Comment : modifier le fichier de mappage de schéma

Explique comment spécifier les fichiers à utiliser dans la migration d'éléments de travail en modifiant le fichier Schemamap.xml.

Comment : générer le fichier de configuration du convertisseur

Explique comment créer le fichier XML qui fournit des informations de paramètres à la base de données ClearQuest dont vous souhaitez effectuer une migration.

Fichiers de mappage de champ, mappage de valeur et valeurs par défaut

Fournit des liens vers les rubriques qui expliquent comment spécifier comment les champs dans ClearQuest sont mappés aux champs dans Team Foundation.

Fichier de configuration du convertisseur d'éléments de travail

Fournit des informations supplémentaires sur le fichier de configuration du convertisseur.

Voir aussi

Tâches

Procédure pas à pas : migration d'éléments de travail ClearQuest vers Team Foundation

Référence

Référence de la ligne de commande pour la migration des éléments de travail


Comment : modifier le fichier de mappage de schéma

Comment : modifier le fichier de mappage de schéma

Le fichier de mappage de schéma pour la migration d'éléments de travail spécifie les fichiers à utiliser pendant la migration d'éléments de travail, y compris :

  • Le mappage de chaque entité ClearQuest à un fichier de définition du type d'élément de travail défini.

  • Le fichier de mappage de champ pour mapper les champs d'entité aux champs d'élément de travail.

  • Le fichier de mappage utilisateur pour mapper des utilisateurs ClearQuest aux utilisateurs Team Foundation.

Le fichier de mappage de schéma est généré par le convertisseur pendant la phase d'analyse. Vous devez examiner ce fichier avant la migration et apporter toutes les modifications dont vous avez besoin, telles que la non-migration d'un type d'élément de travail particulier ou la spécification d'un fichier de mappage utilisateur différent.

Pour modifier le fichier schemamap.xml

  1. Ouvrez le fichier Schemamap.xml. Un fichier d'exemple est fourni.

    Image Copier le code Copier le code
    <Mappings>
  <SchemaMaps>
    <SchemaMap SourceEntity="Defect" TargetWIT="Defect"
      WITDFile="Defect.xml" FieldMapFile="DefectFieldMap.xml"/>
    <SchemaMap SourceEntity="Customer" TargetWIT="Customer"
      WITDFile="Customer.xml" FieldMapFile="CustomerFieldMap.xml"/>
  </SchemaMaps>
  <UserMap File="UserMap.xml" />
</Mappings>

  2. Apportez les modifications appropriées aux sections du fichier.

    • SourceEntity S'assure que cette section contient l'entité ClearQuest correcte.

    • TargetWIT S'assure que cette section pointe vers le type d'élément de travail correct devant être créé dans le suivi des éléments de travail Team Foundation.

    • WITDFile Cette section spécifie le fichier XML de définition du type d'élément de travail (WITD).

    • FieldMapFile Cette section spécifie le fichier XML de mappage de champ.

    • UserMap Cette section spécifie le fichier XML de mappage utilisateur.

Voir aussi

Tâches

Procédure pas à pas : migration d'éléments de travail ClearQuest vers Team Foundation
Comment : modifier le fichier de mappage utilisateur

Autres ressources

Personnalisation des types d'éléments de travail sur Team Foundation Server
Fichiers de mappage de champ, mappage de valeur et valeurs par défaut


Comment : générer le fichier de configuration du convertisseur

Comment : générer le fichier de configuration du convertisseur
Voir aussi

Le fichier de configuration du convertisseur est un fichier XML qui fournit des paramètres pour le convertisseur ClearQuest. Les paramètres sont spécifiés dans les sections du fichier XML comme suit :

<ClearQuest>

La section ClearQuest contient des informations à propos de la base de données ClearQuest que vous souhaitez migrer.

  • ConnectionName Nom de la connexion ClearQuest.

  • UserDatabase Nom de la base de données ClearQuest.

  • QueryName Nom d'une requête enregistrée dans ClearQuest.

  • UserID ID d'utilisateur ClearQuest. Vous devez utiliser l'ID d'utilisateur « Admin ».

<VSTS>

La section VSTS contient des informations à propos du serveur de suivi des éléments de travail Team Foundation et du projet d'équipe vers lequel vous effectuez une migration.

  • URI Nom convivial du serveur Team Foundation ou URI complet qui se présente sous la forme http://MonServeur:MonPort.

    Si vous utilisez des noms conviviaux, assurez-vous que vous avez ajouté le serveur Team Foundation Server à l'aide de l'Explorateur d'équipes avant d'exécuter le convertisseur.

  • ProjectName Nom du projet d'équipe pour le suivi des éléments de travail Team Foundation.

Autres paramètres de configuration

Les autres sections du fichier XML vous permettent de contrôler les éléments suivants :

  • ExitOnError Cette section accepte une valeur True ou False. Sélectionnez True pour quitter en cas d'erreur. Une valeur True indique que si des erreurs sont rencontrées lors de la migration de certains éléments de travail, le convertisseur ClearQuest s'arrête.

    Remarque Remarque

    Ce paramètre s'applique uniquement aux erreurs récupérables. Pour les erreurs irrécupérables, telles que l'impossibilité du convertisseur ClearQuest à se connecter à ClearQuest, le convertisseur s'arrêtera toujours même si le paramètre est False.

  • OutputDirectory Spécifiez le répertoire de destination des fichiers migrés. Si vous ne spécifiez pas de répertoire de sortie, le convertisseur crée un répertoire portant le nom Entité de base, destiné à la génération des fichiers de sorties. Si le répertoire existe déjà, le convertisseur remplace les fichiers contenus dans ce répertoire.

Pour créer le fichier de configuration

  1. Collecte les informations suivantes :

    • Nom de la connexion ClearQuest.

    • Nom de la base de données ClearQuest.

    • ID d'utilisateur et mot de passe de l'administrateur ClearQuest. Assurez-vous que cet utilisateur possède les autorisations pour soumettre des problèmes dans ClearQuest.

    • Nom de serveur Team Foundation.

    • Nom du projet d'équipe pour le suivi des éléments de travail Team Foundation (projet d'équipe vers lequel vous souhaitez migrer les éléments de travail).

  2. Créez une requête dans ClearQuest pour sélectionner les éléments de travail que vous souhaitez migrer vers le suivi des éléments de travail Team Foundation et enregistrez la requête. Enregistrez la requête sous un nom quelconque, par exemple RequêteTransition.

  3. Choisissez un répertoire pour stocker les fichiers qui sont produits pendant la phase d'analyse.

  4. Copiez le fichier de configuration XML suivant dans un éditeur de texte :

    Image Copier le code Copier le code
    <?xml version="1.0" encoding="utf-8"?>
<WorkItemConverter>
  <Source id="ClearQuest">
    <ClearQuest>
      <ConnectionName>CQRep</ConnectionName>
      <UserDatabase>TEST</UserDatabase>
      <QueryName>Public Queries/All Defects</QueryName>
      <UserID>admin</UserID>
    </ClearQuest>
  </Source>
  <VSTS>
    <URI>JoseLugo</URI>
    <ProjectName>JoseLugoProjectX</ProjectName>
  </VSTS>
  <ExitOnError>true</ExitOnError>
  <OutputDirectory>DefectSchema</OutputDirectory>
</WorkItemConverter>

  5. Modifiez le fichier pour spécifier vos paramètres avec les informations rassemblées au cours des étapes précédentes. Par exemple, sous <NomRequête>, spécifiez RequêteTransition comme nom de requête avec le chemin d'accès à la requête. Consultez la section « Fichier de configuration » ci-dessus pour plus d'informations sur le contenu de chaque section.

    Remarque Remarque

    Le mot de passe n'est pas entré dans le fichier, l'outil de conversion ClearQuest le demande ultérieurement dans le processus de migration.

  6. Enregistrez le fichier, par exemple sous le nom CqConverterConfig.xml.

Voir aussi

Référence

Work Item Type Definition Schema


Fichiers de mappage de champ, mappage de valeur et valeurs par défaut

Fichiers de mappage de champ, mappage de valeur et valeurs par défaut
Voir aussi
DropDown image

Lorsque vous effectuez une migration d'éléments de travail de ClearQuest vers Team Foundation, le convertisseur vous permet de contrôler comment les champs dans ClearQuest sont mappés aux champs dans Team Foundation.

Dans cette section

Les rubriques de cette section décrivent comment modifier les fichiers XML qui contrôlent la migration des éléments de travail.

Comment : modifier le fichier de mappage utilisateur

Décrit comment modifier le fichier de mappage utilisateur pour effectuer une migration des utilisateurs de ClearQuest aux utilisateurs de Team Foundation.

Comment : spécifier le mappage de valeurs de champs

Décrit comment modifier le fichier de mappage de champ pour effectuer une migration des champs de ClearQuest aux champs d'éléments de travail de Team Foundation.

Schéma de fichier de mappage de champ

Permet de comprendre le XML qui spécifie le mappage entre les champs de ClearQuest et les champs d'éléments de travail de Team Foundation.

Schéma de fichier de mappage utilisateur

Permet de comprendre le XML qui spécifie le mappage entre les utilisateurs de ClearQuest et les utilisateurs de Team Foundation.

Voir aussi

Tâches

Procédure pas à pas : migration d'éléments de travail ClearQuest vers Team Foundation


Comment : modifier le fichier de mappage utilisateur

Comment : modifier le fichier de mappage utilisateur

Le convertisseur ClearQuest utilise le fichier de mappage utilisateur pour mapper des ID d'utilisateur dans la base de données ClearQuest à un ID d'utilisateur de suivi des éléments de travail Team Foundation équivalent. Il permet de conserver l'historique des éléments de travail en convertissant les valeurs de champ d'ID d'utilisateur pour les rendre valides dans le suivi des éléments de travail Team Foundation. Le suivi des éléments de travail Team Foundation utilise des ID d'utilisateur de domaine Windows.

Une version par défaut de ce fichier est générée par le convertisseur ClearQuest pendant la phase d'analyse. Vérifiez que ce fichier est exact avant de continuer la conversion, car le convertisseur vérifie en premier ce fichier et échouera en cas de problèmes.

Pour modifier le fichier de mappage utilisateur

  1. Ouvrez le fichier usermap.xml. Exemple de fichier de mappage :

    Image Copier le code Copier le code
    <UserMappings">
  <UserMap From="admin" To="admin" />
  <UserMap From="user" To="user" />
  <UserMap From="QE" To="QE" />
  <UserMap From="lead" To="lead" />
  <UserMap From="engineer" To="engineer" />
</UserMappings>

  2. Vérifiez les mappages de l'utilisateur pour effectuer des corrections, des ajouts et des suppressions, si nécessaire. Le destinataire du mappage de l'utilisateur doit être un utilisateur existant de Team Foundation Server.

  3. Dans le suivi des éléments de travail Team Foundation, ajoutez tous les utilisateurs spécifiés dans le fichier de mappage utilisateur. Pour plus d'informations sur l'ajout d'utilisateurs, consultez Gestion des utilisateurs et groupes.

Voir aussi

Tâches

Procédure pas à pas : migration d'éléments de travail ClearQuest vers Team Foundation

Référence

Schéma de fichier de mappage utilisateur

Autres ressources

Personnalisation des types d'éléments de travail sur Team Foundation Server
Gestion des utilisateurs et groupes


Comment : spécifier le mappage de valeurs de champs

Comment : spécifier le mappage de valeurs de champs

Le convertisseur ClearQuest utilise les fichiers de mappage de champ pour associer les champs de chaque entité ClearQuest à un champ de l'élément de travail de suivi des éléments de travail Team Foundation équivalent. Le convertisseur crée un fichier de mappage de champ pour chaque entité ClearQuest pendant l'analyse.

Pour modifier le fichier de mappage de champ

  1. Ouvrez l'un des fichiers de mappage de champ. Par exemple, ouvrez DefectFieldMap.xml. Un exemple est fourni.

    Image Copier le code Copier le code
    <FieldMap from="Criticality" to="Severity">
  <ValueMaps>
        <ValueMap from="1-Critical" to = "1"/>
        <ValueMap from="2-Major" to = "2"/>
  </ValueMaps>
</FieldMap>

  2. Examinez les lignes de mappage de champ (commençant par ValueMap) et vérifiez que le champ indiqué après « de » est mappé au champ approprié après « jusqu'au ». Vous pouvez ajouter plus de mappages de champ en ajoutant plus de lignes ValueMap. Les valeurs doivent figurer dans la liste des valeurs autorisées si cela a été spécifié dans le fichier de schéma, ici defect.xml.

    Remarque Remarque

    Si vous modifiez les mappages de champ, assurez-vous d'apporter les modifications correspondantes dans les fichiers de type d'élément de travail. Par exemple, si vous modifiez un nom de champ dans le fichier de mappage de champ, vous devez vérifier que le champ est présent dans le fichier de type d'élément de travail.

  3. Ouvrez les autres fichiers de mappage de champ et apportez les modifications appropriées.

Voir aussi

Tâches

Procédure pas à pas : migration d'éléments de travail ClearQuest vers Team Foundation

Référence

Schéma de fichier de mappage de champ
Work Item Type Definition Schema

Concepts

Vue d'ensemble des éléments de travail et des types d'éléments de travail


Schéma de fichier de mappage de champ
Image Réduire tout Image de liste déroulante

Le fichier de mappage de champ vous permet de spécifier comment les champs ClearQuest sont mappés aux champs d'élément de travail.

Image de développement Schéma de fichier de mappage de champ

Exemple de fichier de mappage de champ :

Image Copier le code Copier le code
<FieldMaps>
<FieldMap from="Criticality" to="Severity">
  <ValueMaps defaultValue="3">
        <ValueMap from="1-Critical" to = "1"/>
        <ValueMap from="2-Major" to = "2"/>
  </ValueMaps>
</FieldMap>
</FieldMaps>

Les nœuds et attributs que vous pouvez utiliser dans ce fichier sont les suivants :

  • <FieldMaps> Nœud de niveau supérieur qui contient tous les mappages. Il y a une seule instance de ce nœud par fichier.

  • <FieldMap> Nœud enfant de <FieldMaps>. Spécifie un seul mappage de champ. Utilisez plusieurs nœuds pour spécifier plusieurs mappages. Les mappages sont spécifiés en tant qu'attributs de ce nœud. Les attributs sont :

    • from Nom de champ dans ClearQuest. Définissez la valeur du nom de champ dans ClearQuest pour lequel vous souhaitez spécifier le mappage.

    • to Nom de champ dans Team Foundation. Définissez la valeur du nom convivial du champ dans Team Foundation vers lequel le champ ClearQuest doit être mappé. Vous devez utiliser le nom de champ convivial, non le nom de champ de référence.

    • exclude Permet d'inclure ou d'exclure ce champ dans la migration. Affectez-lui la valeur false.

  • <ValueMaps> Facultatif, sauf si vous spécifiez des nœuds <ValueMap> enfants. Le nœud enfant de <FieldMap> et un seul nœud <ValueMaps> sont pris en charge par nœud <FieldMap>. Contient tous les mappages de valeurs pour le champ spécifié dans le nœud <FieldMap>.

  • <ValueMap> Facultatif. Nœud enfant de <ValueMaps>. Spécifie un mappage de valeurs. Créez plusieurs nœuds pour spécifier plusieurs mappages. Le mappage de valeurs est spécifié avec les attributs suivants :

    • from Valeur de champ dans ClearQuest. Définissez la valeur de champ dans ClearQuest pour lequel vous souhaitez créer le mappage.

    • to Valeur de champ dans Team Foundation. Définissez la valeur permettant au convertisseur de remplacer la valeur ClearQuest spécifiée en effectuant une migration de données vers Team Foundation.

Image de développement Voir aussi

Tâches

Comment : spécifier le mappage de valeurs de champs


Schéma de fichier de mappage utilisateur
Image Réduire tout Image de liste déroulante

Le fichier de mappage utilisateur spécifie comment les utilisateurs sont mappés entre ClearQuest et Team Foundation. ClearQuest possède sa propre base de données utilisateur et Team Foundation Server utilise des noms d'utilisateurs Windows. Les noms d'utilisateurs dans ClearQuest et Windows ne peuvent pas correspondre et le fichier de mappage utilisateur vous donne la possibilité de spécifier des mappages appropriés. Vous ne devez pas spécifier de mappages utilisateur. Si vous ne spécifiez pas de mappage, le convertisseur transférera les noms d'utilisateurs de votre base de données ClearQuest dans les éléments de travail de Team Foundation. Le convertisseur peut effectuer ce transfert parce qu'il s'exécute en mode "Règles souples". Après la migration, lorsque vous commencez à modifier ces éléments de travail, certains champs peuvent avoir des utilisateurs qui ne sont pas valides dans Team Foundation. Si vous avez des règles obligeant ce champ à contenir uniquement des utilisateurs valides, vous devrez puis fournir un utilisateur valide avant de pouvoir enregistrer l'élément de travail.

Pour prendre une décision, vous devez tenir compte des scénarios suivants :

  • Les noms d'utilisateurs Windows sont les mêmes pour ClearQuest et Team Foundation. Vous ne devez pas spécifier de mappages.

  • Les noms d'utilisateurs Windows sont différents pour ClearQuest et Team Foundation. Plusieurs choix sont possibles :

    • Mappez les utilisateurs ClearQuest aux utilisateurs de Team Foundation dans ce fichier pour que le convertisseur puisse effectuer les mappages au cours de la migration.

    • Choisissez de ne pas spécifier les mappages lors de la migration. Si vous avez des règles obligeant certains champs à avoir uniquement des utilisateurs valides, vous devez fournir des utilisateurs valides lorsque vous modifiez ces éléments de travail après la migration.

    • Choisissez de ne pas spécifier de mappage et supprimez les règles qui obligent un champ à contenir uniquement des utilisateurs valides. Cela n'est pas recommandé.

    • Choisissez de ne pas spécifier de mappage, mais vous pouvez ajouter <ALLOWEXISTINGVALUE/> pour spécifier que les champs contenant des valeurs existantes doivent être autorisés à conserver les valeurs existantes, même s'ils violent certaines règles.

Ne pas mapper les utilisateurs peut provoquer quelque confusion. Vos éléments de travail migrés contiendraient les noms d'utilisateurs ClearQuest et les nouveaux éléments de travail, ou les éléments de travail modifiés par les utilisateurs, afficheraient des noms d'utilisateurs TFS. Nous vous recommandons de fournir des mappages là où le nom d'utilisateur ClearQuest porte un nom d'utilisateur associé, différent du nom d'utilisateur de connexion Windows, et laisse tous les noms d'utilisateurs qui ne portent pas de nom d'utilisateur de connexion Windows associé.

Image de développement Schéma de fichier de mappage utilisateur

Les nœuds et attributs que vous pouvez utiliser dans ce fichier sont les suivants :

  • <UserMappings> Nœud de niveau supérieur qui contient tous les mappages. Une seule instance de ce nœud par fichier.

  • <UserMap> Nœud enfant de <UserMappings>. Spécifie un seul mappage d'utilisateur. Utilisez plusieurs nœuds pour spécifier plusieurs mappages. Les mappages sont spécifiés en tant qu'attributs de ce nœud. Les attributs sont :

    • From Le nom d'utilisateur dans ClearQuest. Renseignez le nom de ClearQuest que vous souhaitez mapper à un nom d'utilisateur de Team Foundation.

    • To Nom d'utilisateur dans Team Foundation. Renseignez le nom d'utilisateur de Team Foundation auquel le nom ClearQuest spécifié doit être mappé.

Image de développement Voir aussi

Tâches

Comment : modifier le fichier de mappage utilisateur


Fichier de configuration du convertisseur d'éléments de travail

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Fichier de configuration du convertisseur d'éléments de travail
Voir aussi
Image de liste déroulante

Le fichier de configuration des éléments de travail est un fichier XML qui fournit les paramètres pour le convertisseur ClearQuest. Les sections de ce fichier sont décrites ultérieurement dans cette rubrique et sont suivies par un exemple de fichier de configuration que vous pouvez utiliser pour créer votre propre fichier de configuration.

Section du fichier de configuration

Le fichier XML de configuration du convertisseur des éléments de travail contient plusieurs sections qui spécifient la manière dont les éléments de travail sont migrés de ClearQuest vers Team Foundation. Les sections sont décrites plus en détail ultérieurement dans cette rubrique.

<ClearQuest>

La section ClearQuest contient des informations à propos de la base de données ClearQuest que vous souhaitez migrer.

  • ConnectionName Nom de la connexion ClearQuest.

  • UserDatabase Nom de la base de données utilisateur ClearQuest.

  • QueryName Nom d'une requête enregistrée dans ClearQuest.

  • UserID ID d'utilisateur ClearQuest. Vous devez utiliser l'ID d'utilisateur "Admin". Cet utilisateur doit avoir l'autorisation de créer tous les types d'élément de travail.

<VSTS>

La section VSTS contient des informations à propos du serveur de suivi des éléments de travail Team Foundation et du projet d'équipe vers lequel vous effectuez une migration.

  • URI Nom convivial Team Foundation Server ou URI complet. Par exemple, "MyAtServer" ou "http://MyAtServer:8080."

  • ProjectName Nom du projet d'équipe pour le suivi des éléments de travail Team Foundation.

Autres paramètres de configuration

Les autres sections du fichier XML vous permettent d'effectuer des contrôles

  • ExitOnError Cette section accepte une valeur true ou false. Sélectionnez True pour quitter en cas d'erreur. Cela signifie que le convertisseur ClearQuest s'arrête lorsque des erreurs sont rencontrées lors de la migration de certains éléments de travail.

    Remarque Remarque

    Ce paramètre s'applique uniquement aux erreurs récupérables. Pour les erreurs irrécupérables, telles que le convertisseur ClearQuest ne peut pas se connecter à ClearQuest, le convertisseur s'arrêtera toujours même si ce paramètre est False.

  • OutputDirectory Spécifie le répertoire de destination des fichiers générés. Si vous ne spécifiez pas de répertoire de sortie, le convertisseur crée un répertoire portant le nom Entité de base, destiné à la génération des fichiers de sorties. Si le répertoire existe déjà, le convertisseur remplace les fichiers contenus dans ce répertoire.

Exemple de fichier de configuration du convertisseur d'éléments de travail

Les éléments suivants sont un exemple de fichier de configuration du convertisseur des éléments de travail qui permet de faire migrer la base de données TEST ClearQuest via la connexion CQRep à l'aide de la requête All Defects dans le projet d'équipe JoseLugoProjectX dans Team Foundation. Cet exemple spécifie également que le convertisseur doit s'arrêter s'il y a des erreurs et spécifie le répertoire pour les fichiers de sortie créés par le convertisseur.

Image Copier le code Copier le code
<?xml version="1.0" encoding="utf-8"?>
<WorkItemConverter>
  <Source id="ClearQuest">
    <ClearQuest>
      <ConnectionName>CQRep</ConnectionName>
      <UserDatabase>TEST</UserDatabase>
      <QueryName>Public Queries/All Defects</QueryName>
      <UserID>admin</UserID>
    </ClearQuest>
  </Source>
  <VSTS>
    <URI>JoseLugo</URI>
    <ProjectName>JoseLugoProjectX</ProjectName>
  </VSTS>
  <ExitOnError>true</ExitOnError>
  <OutputDirectory>DefectSchema</OutputDirectory>
</WorkItemConverter>

Voir aussi

Tâches

Comment : générer le fichier de configuration du convertisseur
Procédure pas à pas : migration d'éléments de travail ClearQuest vers Team Foundation

Référence

Work Item Type Definition Schema


Migration des éléments de travail

Migration des éléments de travail
DropDown image

Lorsque vous avez terminé l'organisation de votre migration et que vous avez exécuté l'analyse sur votre base de données ClearQuest, vous êtes prêt à migrer les éléments de travail vers le suivi des éléments de travail Team Foundation.

Dans cette section

Analyse d'une base de données ClearQuest

Décrit la phase d'analyse et les fichiers sont générés.

Comment : effectuer la migration des éléments de travail

Décrit comment migrer les éléments de travail de ClearQuest vers le suivi des éléments de travail Team Foundation.

Comment : effectuer la migration des éléments de travail vers une base de données existante dans Team Foundation

Contient des rubriques qui décrivent comment migrer les éléments de travail vers une base de données existante.

Voir aussi

Tâches

Procédure pas à pas : migration d'éléments de travail ClearQuest vers Team Foundation


Analyse d'une base de données ClearQuest

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Analyse d'une base de données ClearQuest
Voir aussi
Image de liste déroulante

Dans la phase d'analyse, le convertisseur lit le schéma de la base de données ClearQuest et génère des fichiers qui représentent ce schéma au format Team Foundation. Le convertisseur utilise la requête ClearQuest pour déterminer le type d'entité de base ClearQuest ; une requête dans ClearQuest est basée sur un type d'entité. Le convertisseur recherche également des types d'entité associés au type d'entité de base. Les entités associées à l'entité de base sont les entités auxquelles l'entité de base fait référence. Cela signifie que les entités présentes dans le type d'entité de base le sont en tant que référence ou liste de références. Cette liste des entités référencées exclut toutefois les éléments suivants :

  • Types d'entité qui peuvent être référencés en tant que doublon de.

  • Entité Utilisateur Les utilisateurs sont migrés conformément à la gestion des utilisateurs dans Team Foundation. Team Foundation ne gère pas les utilisateurs comme une entité.

  • Entité Pièce jointe Les pièces jointes sont migrées conformément à la gestion des pièces jointes principales de Team Foundation. Team Foundation ne gère pas les pièces jointes comme une entité.

  • Historique L'historique est migré conformément à la gestion de l'historique principale de Team Foundation. Team Foundation ne gère pas l'historique comme une entité.

  • Groupes Le convertisseur n'effectue pas une migration des groupes ClearQuest. Les groupes sont gérés différemment dans Team Foundation.

  • Ratl_replicas Cette référence d'entité n'est pas utile pour la migration et n'a aucun concept équivalent dans Team Foundation.

Phase d'analyse

À l'invite de commandes de Visual Studio 2005, exécutez la commande suivante :

CQConverter.exe /c:analyze /m:CqConverterConfig.xml

Le convertisseur ClearQuest peut prendre plusieurs minutes pour terminer l'exécution. Plusieurs fichiers sont générés à la fin de la phase d'analyse.

Fichier de configuration du convertisseur

Vous devez spécifier des entrées au convertisseur dans un fichier de configuration. Pour plus d'informations, consultez Fichier de configuration du convertisseur d'éléments de travail.

Fichiers de sortie

La phase d'analyse génère plusieurs fichiers de sortie. Les fichiers sont enregistrés dans le dossier qui est spécifié par l'élément <Outputdirectory> dans le fichier de paramètres de la migration. Si aucun répertoire n'est spécifié, le convertisseur crée un dossier qui porte le même nom que le type d'entité de base ClearQuest. Si le dossier existe déjà, le contenu de ce dossier est remplacé par les nouveaux fichiers xml générés.

À la fin de la phase d'analyse, les fichiers suivants sont créés :

  • Fichier(s) xml de définition du type d'élément de travail Ces fichiers représentent les types d'éléments de travail au format Team Foundation et sont utilisés pour créer des types d'éléments de travail dans Team Foundation. Un fichier est généré pour l'entité principale et chaque entité référencée. Ces fichiers sont nommés <TypeEntité>.xml. Par exemple, un type d'élément de travail de défaut génère le fichier Defect.xml.

  • Fichier(s) xml de mappage des champs Ces fichiers spécifient comment les champs sont mappés de types d'enregistrement ClearQuest aux types d'éléments de travail Team Foundation, ainsi que toutes les conversions de données à appliquer pendant la migration des données. Ces fichiers entretiennent une relation un-à-un avec les fichiers de type d'élément de travail. Chaque fichier de mappage des champs spécifie le mappage pour le type d'élément de travail correspondant. Ces fichiers sont nommés <NomEntité>FieldMap.xml. Par exemple, le type d'élément de travail de défaut génère le fichier DefectFieldMap.xml.

  • Fichier xml de mappage utilisateur Ce fichier est nommé UserMap.xml. Il spécifie comment les utilisateurs de ClearQuest sont mappés aux utilisateurs de Team Foundation. Ce fichier peut s'avérer nécessaire car ClearQuest possède une base de données utilisateur séparée et les noms d'utilisateurs de ClearQuest peuvent ne pas être semblables aux comptes d'utilisateur Windows. Team Foundation nécessite les comptes d'utilisateur Windows.

  • Fichier xml de mappage de schéma Ce fichier est nommé Schemamap.xml. Le fichier contient les noms de tous les fichiers décrits précédemment et spécifie les mappages supplémentaires entre les types d'éléments de travail et les fichiers associés.

  • Fichier xml du rapport d'analyse Ce fichier est nommé CQAnalysisReport.xml. Un dossier associé qui est généré avec ce fichier est nommé _AnalysisReport_Files et contient des images et une feuille de style pour permettre d'afficher correctement ce fichier dans un navigateur.

  • Fichier journal nommé CQConverter.log

    Remarque Remarque

    Indépendamment des champs numériques d'un élément de travail particulier sélectionnés dans une requête, tous les champs présents dans un type d'élément de travail sont sélectionnés par le convertisseur pour analyse. Les fichiers de sortie contiennent les références de tous les champs.

Fichier de définition du type d'élément de travail

Les fichiers de définition du type d'élément de travail (WITD) comprennent le schéma d'un type d'élément de travail au format Team Foundation. Vous pouvez utiliser un fichier WITD pour créer un nouveau type d'élément de travail dans Team Foundation. Un fichier WITD spécifie les champs dans le type, les états, les transitions d'état et les règles d'élément de travail et dans l'interface utilisateur permettant d'afficher l'élément de travail. Pour plus d'informations sur les fichiers de définition du type d'élément de travail, consultez Administration des types d'éléments de travail.

Les sections suivantes expliquent comment ces types d'éléments de travail sont générés.

Mappages de type de champ

Le convertisseur mappe les types de champs dans ClearQuest aux types de champs appropriés dans Team Foundation. Le tableau suivant spécifie comment les champs sont mappés.

Type de champ ClearQuest | Type de champ Team Foundation
ATTACHMENT_LIST | Non applicable. Ce type de champ est migré comme des pièces jointes plutôt que comme un champ dans Team Foundation.
DATE_TIME | DateTime
INT | Entier
MULTILINE_STRING | Texte brut
REFERENCE | Non applicable. Ce type de champ est migré comme des liens plutôt que comme un champ dans Team Foundation.
REFERENCE_LIST | Non applicable. Ce type de champ est migré comme des liens plutôt que comme un champ dans Team Foundation.
SHORT STRING | Chaîne
DBID | Non migré. Ce type de champ est réservé aux champs système de ClearQuest et n'est pas obligatoire dans les éléments de travail migrés.
ID | Chaîne. Ce type de champ est migré comme un champ id source vsts dans Team Foundation.
JOURNAL | Non applicable. Ce type de champ est réservé aux champs système de ClearQuest et est migré comme un historique dans Team Foundation.
État | Chaîne. Ce type de champ est réservé aux champs système de ClearQuest et est migré comme le champ État système dans Team Foundation.

Mappages de champ

Dans ClearQuest, chaque type d'élément de travail utilise des champs système et, de la même façon, il existe des champs système dans les types de l'élément de travail Team Foundation. Le convertisseur mappe les champs système de ClearQuest aux champs système de Team Foundation, selon les besoins. Outre les champs système, il existe également des champs qui figurent généralement dans les types d'éléments de travail ClearQuest. Le convertisseur les mappe aux champs Team Foundation, selon les besoins.

Le tableau suivant spécifie comment le convertisseur mappe les champs système.

Champ système ClearQuest | Champ système Team Foundation
ID | vsts sourceid
État | État

Le tableau suivant spécifie comment le convertisseur mappe les champs communs.

Champ ClearQuest | Champ système Team Foundation
Headline | Title
Description | Description
Submitter | Created By
Submit_Date | Created Date
Owner | Assigned To
User_name (Historique) | Changed By
action_timestamp (Historique) | Changed Date

Gestion de comportement de champ

Vous pouvez spécifier le comportement des champs dans ClearQuest. Vous pouvez également spécifier un comportement différent des champs selon les différents états d'un élément de travail. Le convertisseur connaît des restrictions de migration du comportement dans les éléments de travail ClearQuest. Par exemple, le convertisseur effectue une migration du comportement de champ spécifié uniquement sur l'état initial, autrement dit, l'état d'un élément de travail créé récemment.

Le comportement défini pour les différents états n'est ni analysé, ni généré dans la phase d'analyse. Toutefois, Team Foundation prend en charge la spécification de ces comportements et vous pouvez ajouter manuellement ces comportements dans les types d'éléments de travail après la phase d'analyse. Pour plus d'informations sur la personnalisation du comportement des types d'éléments de travail dans Team Foundation, consultez Définition du flux de travail des éléments de travail.

Le comportement d'élément de travail est migré comme spécifié dans le tableau suivant.

Comportement | Description
Obligatoire | Ce comportement est migré vers Team Foundation. Obligatoire est spécifié dans Team Foundation en appliquant l'élément <REQUIRED> dans la définition du type d'élément de travail.
Facultatif | Ce comportement est migré vers Team Foundation. Facultatif est le comportement par défaut d'un champ dans Team Foundation afin qu'aucun élément supplémentaire ne soit nécessaire dans la définition du type d'élément de travail.
En lecture seule | Ce comportement n'est pas migré.
Use_hook | Ce comportement n'est pas migré.

Champs ajoutés par le convertisseur dans les types d'éléments de travail

Le convertisseur génère les champs suivants dans chaque type d'élément de travail en plus des champs présents dans vos types d'éléments de travail ClearQuest.

Champs obligatoires pour le fonctionnement du convertisseur.

Ne supprimez pas ces champs. La suppression de ces champs de types d'éléments de travail conduit à l'échec de la migration. Vous pouvez les supprimer de l'interface utilisateur d'élément de travail (formulaire) si vous ne souhaitez pas qu'ils s'affichent. Nous recommandons que vous conserviez ces champs en lecture seule pour empêcher les utilisateurs de les modifier. Les champs sont les suivants :

  • Champ de l'ID ClearQuest d'un élément de travail migré.

    Image Copier le code Copier le code
    <FIELD name="vsts sourceid" refname="Microsoft.TeamFoundation.Converters.vsts_sourceid" type="String"/>

  • Champ de la base de données ClearQuest dont un élément de travail migré provient.

    Image Copier le code Copier le code
    <FIELD name="vsts sourcedb" refname="Microsoft.TeamFoundation.Converters.vsts_sourcedb" type="String"/>

  • Champ utilisé pour suivre l'état de migration d'un élément de travail particulier.

    Image Copier le code Copier le code
    <FIELD name="Migration Status" refname="Microsoft.TeamFoundation.Converters.Migration_Status" type="String"/>

  • Champs système dans Team Foundation. Lorsque les champs système dans Team Foundation mappent aux champs système dans ClearQuest, le xml de mappage approprié est généré. Certains champs système dans Team Foundation ne mappent pas vers des champs système dans ClearQuest et génèrent des champs supplémentaires dans chaque type d'élément de travail. Ces champs sont identifiés à l'aide d'un commentaire semblable au xml suivant :

    Image Copier le code Copier le code
    <!--State is a core field in Team Foundation Work Item Tracking and we recommend that you use this field because it best suits the purpose-->

Gestion des champs Liste

Les champs dans ClearQuest peuvent disposer d'un jeu de valeurs valides ou suggérées défini pour eux. Lorsque le convertisseur lit les champs et leurs types, il établit également si le champ est un type de champ de liste ou non. Si le champ est un type de champ de liste, le convertisseur rassemble également les valeurs de liste valides suggérées. Ces informations sont incluses dans les fichiers de définition du type d'élément de travail dans la section de champ correspondante. Recherchez les éléments <AllowedValues> ou <SugggestedValues>.

Gestion des états et transitions d'état

Les définitions de type d'entités basées sur l'état dans le schéma ClearQuest prennent en charge les éléments suivants :

  • un ensemble d'états ;

  • les transitions entre états appelées Actions ;

  • le comportement de champ associé aux états.

Le convertisseur récupère les états et les actions ClearQuest comme des états et des transitions d'état dans les définitions du type d'élément de travail Team Foundation.

Gestion du formulaire d'élément de travail

Le convertisseur n'effectue pas une migration des informations de formulaire de votre base de données ClearQuest vers Team Foundation. Le convertisseur génère un formulaire d'élément de travail par défaut qui fait partie du schéma généré pendant la phase d'analyse ; toutefois, ce formulaire par défaut ne ressemble pas au formulaire d'origine dans ClearQuest. Le formulaire par défaut contient une mise en forme minimale et nécessite presque toujours des modifications afin de faciliter l'utilisation de la disposition des éléments de travail. Pour plus d'informations sur la modification de formulaires d'élément de travail, consultez Définition du formulaire d'élément de travail.

Contrôles sur le formulaire

Vous pouvez mettre différents contrôles sur un formulaire d'élément de travail dans ClearQuest, outre Team Foundation. Team Foundation prend en charge un jeu prédéfini de contrôles que vous pouvez utiliser. Certains contrôles disponibles dans ClearQuest ne sont pas disponibles dans Team Foundation. Bien qu'une quantité maximale de données soit conservée pendant la migration, les différences au niveau des contrôles disponibles affectent l'affichage des données sur le formulaire dans Team Foundation. Les contrôles suivants ne sont pas pris en charge dans Team Foundation.

  • Contrôles ActiveX

  • Contrôle Calendar

  • Contrôle Check Box

  • Contrôle Combo Box

  • Contrôle Duplicate Base

  • Contrôle Duplicate Dependents

  • Contrôle Parent/Child

  • Contrôle Picture

  • Contrôle Push Button

  • Contrôle List Box

  • Contrôle List view

  • Contrôle Option Button

  • Contrôle Static Text Box

Dans le cadre de la planification de la migration, vous devez évaluer les conséquences que l'absence de ces contrôles peuvent avoir sur les utilisateurs.

Fichier(s) de mappage de champ

Le fichier des mappages de champs spécifie comment les champs sont mappés et comment les valeurs sont mappées.

Mappage de champ

Les fichiers de mappage de champ spécifient comment les champs dans ClearQuest sont mappés aux champs Team Foundation. La plupart des champs dans ClearQuest, à l'exception des champs système et communs, sont mappés un-à-un à Team Foundation. Vous devez garder ces fichiers de mappage de champ synchronisés avec toutes les modifications que vous apportez aux champs dans les fichiers de définition du type d'élément de travail. Par exemple, si vous renommez un champ dans le fichier de définition du type d'élément de travail, vous devez modifier le fichier de mappage pour spécifier le même mappage. De la même façon, si vous supprimez des champs du fichier de définition du type d'élément de travail, vous devez supprimer ces champs du fichier de mappage de champ correspondant.

Mappage de valeurs

Les fichiers de mappage de champ spécifient également comment les données du champ seront transformées pendant la migration. Par défaut, aucun mappage de valeurs n'est généré. Vous pouvez spécifier les mappages de valeurs si vous souhaitez transformer les données pendant la migration. Vous spécifiez ces transformations à l'aide de mappages de valeurs pour établir qu'une valeur telle que "Pri1" doit être mappée à "1".

Le fichier de mappage de champ est un fichier XML. L'exemple suivant indique comment associer des champs et des valeurs :

<?xml version="1.0"?>

<FieldMaps xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">

  <!-- Title is a core field in Team Foundation Work Item Tracking and we recommend that you use this field because it best suits the purpose-->

  <FieldMap from="Headline" to="Title" />

  <FieldMap from="Submitter" to="Submitter">

    <ValueMaps refer="UserMap" />

  </FieldMap>

  <!-- Created Date is a core field in Team Foundation Work Item Tracking and we recommend that you use this field because it best suits the purpose-->

  <FieldMap from="Submit_Date" to="Created Date" />

  <!-- Assigned To is a core field in Team Foundation Work Item Tracking and we recommend that you use this field because it best suits the purpose-->

  <FieldMap from="Owner" to="Assigned To">

    <ValueMaps refer="UserMap" />

  </FieldMap>

</FieldMaps>

Pour plus d'informations sur les mappages de champ, consultez Schéma de fichier de mappage de champ.

Mappage à des champs Chemin de la zone et Chemin de l'itération

Le suivi des éléments de travail Team Foundation organise les éléments de travail en une hiérarchie de zones et d'itérations structurelles. Pour plus d'informations, consultez Comment : modifier la structure du projet d'équipe et Comment : modifier les itérations du projet d'équipe.

Les chemins d'accès sont utilisés pour aider à rassembler les éléments de travail de manière structurelle afin de représenter les différents composants, projets ou applications sur lesquels travaille votre équipe. Les itérations sont utilisées pour aider à rassembler les éléments de travail en fonction des événements principaux tels que les jalons et les phases de projet. Les champs système Chemin de la zone et Chemin de l'itération définissent ces informations dans Team Foundation. Étant donné que ClearQuest ne possède aucun concept de ce type, le convertisseur fournit une valeur par défaut pour ces champs ; la valeur par défaut consiste en ce que tous les éléments de travail vont à la racine du chemin de la zone et du chemin de l'itération.

Bien que ClearQuest ne fournisse pas de chemin de la zone et de chemin de l'itération, il est possible que vous utilisiez les concepts d'une autre façon. Par exemple, dans vos types d'éléments de travail, vous pouvez avoir un champ qui désigne le projet particulier auquel un élément de travail appartient. Cela correspond approximativement au concept de Chemin de la zone. De la même façon, vous pouvez avoir un autre champ tel que "Fix By" qui désigne le jalon par lequel vous souhaitez qu'un élément de travail particulier soit résolu. Songez à associer ces champs au Chemin de la zone et au Chemin de l'itération afin que les éléments de travail apparaissent à des nœuds différents au lieu d'apparaître tous à un seul nœud racine. Les mappages sont spécifiés dans les fichiers de mappage de champ du type d'élément de travail comme expliqué précédemment.

L'exemple de xml suivant illustre comment associer un champ ClearQuest nommé Tree Path aux valeurs possibles Area1 et Area2.

<FieldMap from="Tree Path" to="Area Path" exclude="false">

<ValueMaps>

  <ValueMap from="Area1" to="Area1" />

  <ValueMap from="Area2" to="Area2" />

</ValueMaps>

</FieldMap>

L'exemple de xml suivant illustre comment associer un champ ClearQuest nommé Fix By aux valeurs possibles Alpha et Beta.

<FieldMap from="Fix By" to="Iteration Path" exclude="false">

<ValueMaps>

  <ValueMap from= "Alpha" to="Alpha"/>

  <ValueMap from= "Beta" to="Beta"/>

</ValueMaps>

</FieldMap>

Fichier de mappage utilisateur

Le fichier de mappage utilisateur spécifie comment les utilisateurs sont mappés entre ClearQuest et Team Foundation. Pour plus d'informations, consultez Schéma de fichier de mappage utilisateur.

Fichier de mappage de schéma

Le fichier de mappage de schéma spécifie le type de l'élément de travail de la source, le type d'élément de travail de la cible, le fichier de définition d'élément de travail et le fichier de mappage de champ. Pour plus d'informations, consultez Comment : modifier le fichier de mappage de schéma.

Fichier de rapport d'analyse

Un fichier de rapport d'analyse est généré à la fin de la migration. Le rapport de migration est nommé CQAnalysisReport.xml et est généré dans le dossier à partir duquel CQConverter a été exécuté. Un dossier associé nommé _MigrationReport_Files contient les fichiers image et une feuille de style permettant d'afficher le rapport dans un navigateur. À la fin de l'analyse, vous devez ouvrir ce fichier pour afficher toutes les erreurs ou les avertissements détectés pendant la phase d'analyse. Le rapport d'analyse affiche les éléments suivants :

  • Résumé Informations résumées sur l'opération d'analyse.

  • Erreurs Toutes les erreurs détectées au cours de l'opération d'analyse. Vous devez prendre des mesures appropriées pour toutes les erreurs répertoriées.

  • Avertissements Tous les avertissements détectés au cours de l'opération d'analyse. Les avertissements requièrent votre attention, mais les problèmes qu'ils décrivent ne doivent pas nécessairement être résolus.

  • Sortie Cette section répertorie les fichiers de sortie qui ont été générés.

Fichier journal

Le convertisseur génère un fichier journal nommé CQConverter.log. Ce fichier est utilisé pour le débogage et en général, vous ne devez pas examiner ce fichier. Le fichier journal est créé dans le dossier à partir duquel CQConverter a été exécuté. Il contient des messages de trace et peut être utile pour le débogage des problèmes détectés lors de l'exécution du convertisseur.

Le niveau du traçage est contrôlé en définissant la valeur de l'attribut MinLevelForAllSource dans le fichier CQConverter.exe.config. Le fichier CQConverter.exe.config se trouve dans le même dossier que CQConverter.exe. Vous pouvez définir une valeur de 1, qui représente l'importance la plus faible du traçage, jusqu'à 4, qui représente l'importance la plus haute.

Remarque Remarque

Sachez que les performances du convertisseur sont plus lentes à des niveaux de traçage supérieurs et le fichier journal peut devenir très volumineux.

Fichier d'erreurs

Le convertisseur génère également un fichier qui contient toutes les erreurs détectées lors de l'exécution du convertisseur. Le fichier est nommé ConverterErrors.txt et est généré dans le même dossier à partir duquel CQConverter a été exécuté.

Voir aussi

Tâches

Comment : modifier le fichier de mappage de schéma

Référence

Schéma de fichier de mappage utilisateur

Concepts

Fichier de configuration du convertisseur d'éléments de travail

Autres ressources

Administration des types d'éléments de travail
Définition du flux de travail des éléments de travail
Définition du formulaire d'élément de travail


Comment : effectuer la migration des éléments de travail

Comment : effectuer la migration des éléments de travail

Après la phase d'analyse, le convertisseur génère des définitions de type d'élément de travail (WITD) pour chaque type d'enregistrement ClearQuest. Par exemple, un fichier pour le type d'enregistrement Defect de ClearQuest est nommé Defect.xml. Le convertisseur génère un formulaire d'élément de travail par défaut dans le cadre de la génération de schéma pendant la phase d'analyse. Toutefois, ce formulaire par défaut contient la mise en forme minimale et il est probable que vous deviez le modifier pour obtenir la disposition d'éléments de travail que vous souhaitez. Pour plus d'informations sur la modification du fichier de définition du type d'élément de travail, consultez Personnalisation des types d'éléments de travail sur Team Foundation Server.

Après avoir modifié la disposition d'éléments de travail, vous êtes prêt à effectuer une migration de vos éléments de travail de ClearQuest vers le suivi des éléments de travail Team Foundation.

Migration des éléments de travail ClearQuest

Pour effectuer une migration des éléments de travail

  1. À l'invite de commandes, exécutez la commande suivante :

    CQConverter.exe /c:migrate /m:CqConverterConfig.xml /s: path \Schemamap.xml

    Où path est le nom du répertoire de sortie spécifié dans le fichier CQConverterConfig.xml.

    Remarque Remarque

    L'exécution du convertisseur ClearQuest peut durer des heures pour les bases de données volumineuses.

    Remarque Remarque

    Pour plus d'informations sur les commandes du convertisseur ClearQuest, consultez Référence de la ligne de commande pour la migration des éléments de travail.

  2. Lorsque la migration est terminée, examinez le rapport de migration pour obtenir l'état de migration et, le cas échéant, d'autres problèmes, tels que les défaillances qui ne sont pas migrées en raison de quelques incohérences de mappage de champ.

    Le rapport de migration est nommé CQMigrationReport.xml et créé dans le dossier à partir duquel vous avez exécuté le convertisseur ClearQuest.

    Remarque Remarque

    Étant donnée que le convertisseur convertit tous les éléments de travail inclus dans la requête que vous spécifiez, plus tous les éléments de travail qui y sont liés, le nombre réel des éléments de travail migrés peut être différent du nombre des éléments de travail de la requête.

  3. Si tous les éléments de travail ne sont pas migrés, vous pouvez encore exécuter la conversion après avoir résolu les problèmes décrits dans le rapport de migration.

Pour migrer davantage d'éléments de travail de ClearQuest vers le suivi des éléments de travail Team Foundation, vous pouvez à nouveau exécuter le processus de migration.

Pour exécuter à nouveau une migration sur la même base de données ClearQuest

  1. Corrigez tous les problèmes décrits dans le rapport de la migration précédente.

  2. Créez une requête dans ClearQuest qui retourne les éléments de travail souhaités ou exécutez la même requête si vous devez seulement effectuer une migration des éléments de travail dont la migration a échoué la première fois.

  3. Modifiez la section <QueryName> dans le fichier de configuration pour spécifier le nouveau nom de la requête.

  4. Ouvrez l'invite de commandes et tapez la commande pour la migration :

    CQConverter.exe /c:migrate /m:CqConverterConfig.xml /s: path \Schemamap.xml

    L'exécution du convertisseur ClearQuest peut durer des heures pour les bases de données volumineuses.

    Remarque Remarque

    Pour plus d'informations sur les commandes du convertisseur ClearQuest, consultez Référence de la ligne de commande pour la migration des éléments de travail.

  5. Lorsque la migration est terminée, examinez le rapport de migration pour l'état de la migration. Le rapport de migration est nommé CQMigrationReport.xml et créé dans le dossier à partir duquel vous avez exécuté le convertisseur ClearQuest.

Sécurité

Vous devez être membre du groupe Comptes de service dans Team Foundation et avoir l'autorisation suffisante dans ClearQuest pour créer des éléments de travail de chaque type

Voir aussi

Tâches

Procédure pas à pas : migration d'éléments de travail ClearQuest vers Team Foundation

Autres ressources

Après la migration des éléments de travail


Comment : effectuer la migration des éléments de travail vers une base de données existante dans Team Foundation

Comment : effectuer la migration des éléments de travail vers une base de données existante dans Team Foundation
Voir aussi

Le convertisseur permet un mappage facile des champs du système de suivi des éléments de travail de la source vers le suivi des éléments de travail Team Foundation à l'aide du mappage de champ et de fichiers de mappage d'utilisateur.

Pour effectuer une migration de données vers un type d'élément de travail Team Foundation existant

  1. Exécutez le convertisseur avec la commande d'analyse pour générer le mappage et les fichiers de mappage de schéma. Cette étape permet de générer tous les fichiers de définition du type d'élément de travail (WITD), le fichier de mappage de schéma, les fichiers de mappage de champ et le fichier de mappage d'utilisateur.

    CQConverter.exe /c:analyze /m:cqconverterconfig.xml

    Remarque Remarque

    Les fichiers WITD générés capturent le schéma de type d'élément de travail de votre base de données ClearQuest. Comme vous effectuez une migration vers types d'élément de travail existants, vous n'utilisez pas les fichiers WITD générés pendant la migration. Cependant, ne les supprimez pas, car vous en aurez besoin ultérieurement pour terminer cette procédure.

  2. Modifiez le fichier de mappage de schéma pour spécifier les types d'élément de travail cibles pour les types d'élément de travail que vous souhaitez migrer.

  3. Si vous effectuez une migration vers des types d'élément de travail qui sont déjà dans le suivi des éléments de travail Team Foundation, laissez l'attribut de fichier WITDFile tel quel ; le convertisseur ne configure pas le type d'élément de travail si l'élément est déjà présent dans le suivi des éléments de travail Team Foundation.

    Si vous effectuez une migration vers les types d'élément de travail qui n'ont pas été créés dans le suivi des éléments de travail Team Foundation, et que vous avez déjà créé des fichiers WITD, modifiez l'attribut du fichier WITDFile pour pointer vers ces fichiers. Assurez-vous que vous spécifiez le chemin d'accès complet des fichiers. Le convertisseur configure ensuite les types d'élément de travail spécifiés dans les fichiers WITD pendant la phase de migration.

  4. Modifiez les fichiers de mappage de champ pour spécifier les mappages de champ vers les types d'élément de travail de suivi des éléments de travail Team Foundation. Les fichiers de mappage de champ générés contiennent des noms de champs provenant des schémas générés par convertisseur. Puisque vous utilisez votre propre type d'élément de travail pour ces mappages de champ, vous devez fournir les mappages vers vos champs d'élément de travail de suivi des éléments de travail Team Foundation. Pour la description de fichiers de mappage de champ, consultez Fichiers de mappage de champ, mappage de valeur et valeurs par défaut.

    S'il existe des champs que vous ne souhaitez migrer, vous pouvez supprimer sans risque les mappages de ces champs.

  5. Modifiez le fichier de mappage d'utilisateur, si nécessaire, tel que décrit dans Comment : modifier le fichier de mappage utilisateur.

  6. Exécutez le convertisseur avec la commande de migration pour migrer les données.

Sécurité

Vous devez être membre du groupe Administrators Team Foundation sur Team Foundation pour terminer cette procédure.

Voir aussi

Tâches

Comment : effectuer la migration des éléments de travail
Comment : modifier le fichier de mappage utilisateur

Autres ressources

Fichiers de mappage de champ, mappage de valeur et valeurs par défaut


Après la migration des éléments de travail

Après la migration des éléments de travail
DropDown image

Après la migration des éléments de travail, vous souhaitez vérifier que la migration est réussie, puis commencer à utiliser les éléments de travail. Si vous avez rencontré des problèmes pendant la migration, vous pouvez également souhaiter résoudre quelques problèmes et réexécuter la migration ou corriger les éléments de travail migrés.

Dans cette section

Comment : vérifier que la migration des éléments de travail a réussi

Contient des informations relatives à la vérification que de vos éléments de travail ont été correctement migrés de ClearQuest vers le suivi des éléments de travail Team Foundation.

Utilisation des éléments de travail migrés

Contient des informations et des liens relatifs à l'utilisation de vos éléments de travail migrés, y compris des liens destinés à vous aider à commencer à utiliser le suivi des éléments de travail Team Foundation.

Voir aussi

Concepts

Interrogation d'éléments de travail

Autres ressources

Démarrage avec Team Foundation
Procédures pas à pas relatives au suivi des éléments de travail Team Foundation
Ajout et modification d'éléments de travail


Comment : vérifier que la migration des éléments de travail a réussi

Comment : vérifier que la migration des éléments de travail a réussi
Voir aussi

Après avoir effectué la migration, vous pouvez examiner certains des éléments de travail migrés pour vérifier que les informations ont bien été migrées.

Pour vérifier les éléments de travail migrés

  1. Ouvrez un élément de travail migré dans le suivi des éléments de travail Team Foundation.

  2. Examinez le nombre dans le champ d'ID ClearQuest et comparez l'élément de travail de suivi des éléments de travail Team Foundation à l'élément Bogue de ClearQuest avec cet ID.

Pour rechercher l'élément de travail Team Foundation qui correspond à un élément de travail ClearQuest spécifique

  1. Créez une requête d'élément de travail avec la clause de requête suivante :

    And/Or Champ Opérateur Valeur

    ID source VSTS

    =

    ClearQuest work item ID

    Le champ ID source VSTS correspond à l'étiquette du champ d'ID ClearQuest que vous voyez sur votre formulaire d'élément de travail.

    Pour plus d'informations sur la création de requêtes d'éléments de travail, consultez Comment : ajouter de nouvelles requêtes d'élément de travail.

  2. Exécutez la requête.

Voir aussi

Tâches

Comment : ajouter de nouvelles requêtes d'élément de travail
Procédure pas à pas : migration d'éléments de travail ClearQuest vers Team Foundation
Procédure pas à pas : suivi des éléments de travail


Utilisation des éléments de travail migrés

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Utilisation des éléments de travail migrés
Voir aussi
Image de liste déroulante

Après avoir effectué une migration des éléments de travail, vous pouvez commencer à utiliser les éléments de travail migrés dans le suivi des éléments de travail Team Foundation. Pour commencer à vous familiariser avec Team Foundation, consultez Démarrage avec Team Foundation et Procédures pas à pas relatives au suivi des éléments de travail Team Foundation. Pour plus d'informations sur l'utilisation des éléments de travail, consultez les rubriques suivantes.

  • Pour rechercher des éléments de travail migrés, consultez Interrogation d'éléments de travail.

  • Certains des éléments de travail migrés peuvent nécessiter des modifications. Pour plus d'informations sur la modification des éléments de travail, consultez Ajout et modification d'éléments de travail.

  • Si vous devez modifier plusieurs éléments de travail rapidement, consultez Comment : modifier plusieurs éléments de travail dans Microsoft Excel.

Voir aussi

Concepts

Interrogation d'éléments de travail

Autres ressources

Démarrage avec Team Foundation
Procédures pas à pas relatives au suivi des éléments de travail Team Foundation
Ajout et modification d'éléments de travail


Référence de la ligne de commande pour la migration des éléments de travail

 Image de liste déroulante Image de pointage sur liste déroulante Image de réduction Image de développement Image Réduire tout Image Développer tout Copier l'image de pointage
Visual Studio Team System
Référence de la ligne de commande pour la migration des éléments de travail
Voir aussi
Image Réduire tout Image de liste déroulante

La commande CQConverter est utilisée pour convertir des bases de données ClearQuest pour l'utiliser avec le suivi des éléments de travail de Team Foundation.

Image de développement Syntaxe

CQConverter [/?] {/c[ommand]:Analyze|Migrate} < cqconverterconfig.xml > /s[chema]: < schemamap.xml /m[igration settings]: <migration settings>

/c[ommand]: analyze < cqconverterconfig.xml >

Analysez la base de données ClearQuest telle que configurée dans cqconverterconfig.xml.

/c[ommand]: migrate < cqconverterconfig.xml >

Migrez la base de données ClearQuest telle que configurée dans cqconverterconfig.xml.

/s[chema]: < schemamap.xml >

Schéma de migration mappant le fichier XML.

/m[igration settings]: < migration settings >

Fichier XML de paramètres migration.

/?, /h, /help

Affichage de l'aide.

Image de développement Exemples

Dans cet exemple, le convertisseur exécute une analyse à l'aide des paramètres de configuration définis dans le fichier cqconverterconfig.xml.

Image Copier le code Copier le code
        CQConverter /c:analyze /m:
        cqconverterconfig.xml

Dans cet exemple, le convertisseur exécute une migration en utilisant des paramètres de configuration définis dans le fichier cqconverterconfig.xml et le mappage défini dans le fichier schemamap.xml.

Image Copier le code Copier le code
        CQConverter /c:migrate /m:
        cqconverterconfig.xml /s:schemamap.xml

Image de développement Notes

Les paramètres de configuration CQConverter sont configurés dans un fichier XML de configuration. Spécifiez ce fichier au niveau de la ligne de commande en utilisant l'option de ligne de commande /m: ou /migrationsettings: en tant que formulaire développé, par exemple : /m:cqconverterconfig.xml

Remarque Remarque

Lors de la connexion à ClearQuest ou du suivi des éléments de travail de Team Foundation, le convertisseur vous invitera à entrer un mot de passe. Le convertisseur se connecte au Team Foundation à l'aide des informations d'identification de connexion.

Image de développement Voir aussi

Tâches

Procédure pas à pas : migration d'éléments de travail ClearQuest vers Team Foundation


Administration de Team Foundation Server

Administration de Team Foundation Server
DropDown image

L'administration de Team Foundation nécessite une gestion des utilisateurs et des groupes, la configuration de serveur et d'applications clientes et une compréhension à la fois du développement de logiciel et de votre déploiement de composants Visual Studio Team System.

Remarque Remarque

La version la plus récente du Guide de l'administrateur Team Foundation est disponible sur le Web sur le site MSDN Online (http://go.microsoft.com/fwlink/?linkid=52459).

Pour plus d'informations sur l'installation de Team Foundation, consultez le Guide d'installation Team Foundation. La version la plus récente du Guide d'installation Team Foundation est disponible sur le Web sur le site MSDN Online (http://go.microsoft.com/fwlink/?linkid=40042).

Dans cette section

Administration de Team Foundation Server

Présente des concepts clés et fournit des liens vers d'autres informations sur Team Foundation Server, telles que la planification et la documentation de l'installation.

Gestion de Team Foundation Server

Apporte une aide conceptuelle et procédurale pour gérer Team Foundation Server, incluant la gestion des utilisateurs, des groupes et des autorisations.

Contrôle de Team Foundation Server

Apporte une aide conceptuelle et procédurale pour contrôler Team Foundation Server, incluant les performances.

Sécurisation de Team Foundation Server

Fournit des vues d'ensemble conceptuelles sur l'architecture et la sécurité de Team Foundation Server, davantage d'informations sur la sécurité des utilisateurs, des groupes et des services.

Utilisation des outils de ligne de commande Team Foundation Server

Décrit tous les outils de ligne de commande pour Team Foundation Server et fournit des informations sur leur utilisation.

Voir aussi

Autres ressources

Planification de Team Foundation Server
Procédures pas à pas relatives à l'administration de Team Foundation Server


Administration de Team Foundation Server

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Administration de Team Foundation Server
Voir aussi
Image de liste déroulante

L'administration effective de Team Foundation Server est importante pour la réussite de vos projets d'équipe. Les tâches d'administration de Team Foundation Server dépendent des fonctionnalités de gestion de projet requises par votre organisation. Pour administrer Team Foundation Server, vous souhaitez connaître les utilisateurs, les groupes, les autorisations de sécurité et l'héritage et les portails du projet de Team Foundation Server. En général, les autres aspects de l'administration de Team Foundation Server, tels que la configuration, la surveillance et la maintenance quotidiennes et préparation de récupération d'urgence sont familiers à l'administrateur du serveur expérimenté.

Avant de pouvoir commencer à administrer Team Foundation Server, vous devez d'abord planifier et installer Team Foundation Server.

Remarque Remarque

Vous pouvez télécharger la version la plus récente du Guide de l'administrateur Team Foundation à partir du site Web Microsoft (http://go.microsoft.com/fwlink/?linkid=52459)..

Dans cette section

Vue d'ensemble de la planification de Team Foundation Server

Introduit des concepts clés et fournit un lien vers la documentation de planification Team Foundation Server.

Vue d'ensemble de l'installation de Team Foundation Server

Introduit des concepts clés et fournit un lien vers la documentation d'installation Team Foundation Server.

Planification et préparation de Team Foundation

Fournit une aide conceptuelle relative à la planification pour Team Foundation.

Configuration de Visual Studio 2005 Team System

Décrit les configurations matérielle et logicielle requises pour Visual Studio Team System.

Référence

Planification de Team Foundation Server

Voir aussi

Autres ressources

Procédures pas à pas relatives à l'administration de Team Foundation Server
Documentation Team Foundation


Vue d'ensemble de la planification de Team Foundation Server

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Vue d'ensemble de la planification de Team Foundation Server
Voir aussi
Image de liste déroulante

Le Guide de planification Team Foundation Server fournit des informations nécessaires aux administrateurs et aux décideurs d'entreprise pour prévoir la configuration matérielle et logicielle requise Team Foundation Server, les topologies de déploiement, la sélection d'un modèle de processus et l'intégration à un autre logiciel. Ce guide n'aborde pas spécifiquement les informations d'exploitation du produit, mais fournit une infrastructure de planification afin que vous puissiez déterminer ce que vous pouvez intégrer à Team Foundation Server dans votre infrastructure d'entreprise.

Téléchargement de la dernière version

Le Guide de planification Team Foundation Server est disponible via le système d'aide de Visual Studio 2005. Vous pouvez télécharger la version la plus récente du Guide de planification Team Foundation à partir du Centre de téléchargement Microsoft à l'adresse suivante http://go.microsoft.com/fwlink/?linkid=55995 http://go.microsoft.com/fwlink/?linkid=55995

Voir aussi

Concepts

Planification et préparation de Team Foundation


Vue d'ensemble de l'installation de Team Foundation Server

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Vue d'ensemble de l'installation de Team Foundation Server
Voir aussi
Image de liste déroulante

Le Guide d'installation Team Foundation Server fournit des informations requises pour que les administrateurs installent Team Foundation Server. Cela inclut des étapes spécifiques d'installation et de configuration pour des installations de Team Foundation Server sur un serveur et sur deux serveurs.

Téléchargement de la dernière version

Si vous avez installé Team Foundation Server, le Guide d'installation Team Foundation Server est disponible sur le disque dur en tant que fichier TFSInstall.chm. Vous pouvez télécharger la version la plus récente du Guide d'installation Team Foundation à partir du Centre de téléchargement Microsoft à http://go.microsoft.com/fwlink/?linkid=40042

Voir aussi

Concepts

Vue d'ensemble de la planification de Team Foundation Server
Planification et préparation de Team Foundation

Autres ressources

Documentation Team Foundation


Planification et préparation de Team Foundation

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Planification et préparation de Team Foundation
Voir aussi
Image de liste déroulante

La planification Team Foundation inclut la prise en compte sérieuse de vos besoins de développement. En fonction de ces besoins, vous pouvez sélectionner les fonctionnalités de Visual Studio Team System les mieux adaptées à votre environnement de développement, garantir que vous possédez les ressources matérielles et logicielles requises et préparer l'installation.

Planification des serveurs Team Foundation

Le serveur Visual Studio Team System principal est Team Foundation Server qui fournit un contrôle de version, un suivi des éléments de travail, Team Foundation Build,un site Web de projet d'équipe et des fonctionnalités de gestion de projets et de création de rapports. Les autres serveurs Visual Studio Team System incluent des serveurs de builds et des serveurs de test. En fonction des besoins de votre entreprise, vous pouvez choisir de déployer certains de ces serveurs, ou tous. Vous devez évaluer avec soin les fonctionnalités ainsi que les configurations matérielle et logicielle des serveurs Visual Studio Team System dans le cadre de votre planification de Visual Studio Team System.

Planification des clients Team Foundation

Visual Studio Team System possède quatre applications clientes principales : Visual Studio Team Edition for Architects, Visual Studio Team Edition for Developers, Visual Studio Team Edition for Testers et Visual Studio 2005 Team Suite qui inclut les fonctionnalités de toutes les éditions basées sur les rôles.

En cas d'utilisation avec les serveurs Visual Studio Team System, ces applications clientes fournissent des interfaces utilisateur Visual Studio supplémentaires aux fonctions telles que le contrôle de version, le suivi des éléments de travail, les sites Web d'équipe, la création de rapports, le guide de processus, la gestion de la génération et l'exécution de tests.

Schéma illustratif des serveurs et des clients Team Foundation

Le schéma suivant présente un exemple de déploiement Team Foundation de client et de serveurs.

Serveurs et clients Foundation Team

Voir aussi

Concepts

Guide de processus de Team Foundation

Autres ressources

Planification du client et du serveur
Documentation Team Foundation


Configuration de Visual Studio 2005 Team System

Configuration de Visual Studio 2005 Team System
DropDown image

Un déploiement réussi de Visual Studio Team System inclut le déploiement du matériel et du logiciel nécessaire à l'exécution de Visual Studio Team System. La section suivante présente les différentes configurations matérielle et logicielle requises des composants Visual Studio Team System.

Dans cette section

Configuration de Team Build pour Team System

Décrit les configurations matérielle et logicielle requises pour Team Foundation Build.

Configuration des plates-formes de test pour Team System

Décrit les configurations matérielle et logicielle requises pour Team Edition for Testers.

Configuration requise pour le serveur Team System

Décrit les configurations matérielle et logicielle requises pour Team Foundation Server.

Spécifications du client pour Team System

Décrit les configurations matérielle et logicielle requises pour les clients de Team Foundation et Team Explorer.

Référence

Planification de Team Foundation Server

Rubriques connexes

Administration du contrôle de code source Team Foundation

Administration de Team Foundation Build

Voir aussi

Concepts

Topologies prises en charge pour Team Foundation Server

Autres ressources

Documentation Team Foundation


Configuration de Team Build pour Team System

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Configuration de Team Build pour Team System
Voir aussi
Image de liste déroulante

Pour tirer parti de la fonctionnalité Team Foundation Build, un ou plusieurs ordinateurs de l'environnement Visual Studio Team System peuvent être désignés comme serveurs de builds. Team Foundation Build possède des configurations matérielle et logicielle requises spécifiques. Lorsque vous prévoyez de déployer des serveurs Team Foundation Build, il est important de connaître les besoins spécifiques à votre entreprise.

Configurations matérielle et logicielle requises

Team Foundation Build fournit les fonctionnalités d'un laboratoire de génération public. Avec Team Foundation Build, les gestionnaires de génération d'entreprise peuvent synchroniser les sources, générer l'application, exécuter des tests unitaires associés, effectuer une analyse du code, générer des builds sur un serveur de fichiers et publier des rapports de build. Les données de résultat de la génération sont propagées à l'entrepôt pour rendre compte de l'historique. Team Foundation Build fonctionne avec d'autres outils de Visual Studio Team System pendant le processus de génération, notamment le contrôle de code source et le suivi des éléments de travail. Un certain nombre de configurations serveur recommandées sont présentés dans les sections précédentes. De plus, si vous souhaitez déployer dans plusieurs langues, vous devrez prévoir quelles langues vous souhaitez prendre en charge dans votre déploiement.

Configuration matérielle requise

Le tableau suivant affiche les configurations matérielles recommandées pour déployer Team Foundation Build, selon le nombre d'utilisateurs et le nombre des fichiers générés.

Configuration | Temps de génération | CPU | Disque dur | Mémoire
Minimale, 1 à 2 projets, 5 à 20 utilisateurs | 30 minutes | processeur seul, 766 GHz | 8 Go | 256 Mo
Réduite, 2 à 20 projets, 20 à 100 utilisateurs | 30 minutes à 2 heures | processeur seul, 1,5 GHz | 30 Go | 512 Mo
Moyenne, plus de 20 projets, 100 à 250 utilisateurs | 2 heures à 5 heures | processeur seul, 2,6 GHz | 50 Go | 1 Go
Étendue, plus de 50 projets, 250 à 500 utilisateurs | 3 heures à 7 heures | biprocesseurs, 2,8 GHz | 80 Go | 2 Go

Les indications présentées ici fournissent une aide générale en matière de planification de matériel. Les performances de génération seront très différentes selon la quantité de code source présent sur un serveur donné et la complexité du processus de génération.

Le serveur qui exécute Team Foundation Build doit disposer d'une connexion réseau fiable avec une bande passante d'au moins 1 Mbit/s et une latence maximale de 350 ms. Il ne doit y avoir aucun pare-feu entre le serveur Team Foundation Build et les serveurs Team Foundation Server. Si vos performances de génération ne répondent pas à vos attentes, songez à mettre votre configuration matérielle à niveau.

Considérations sur le matériel supplémentaire

Outre le matériel recommandé, vous devez envisager d'acquérir du matériel supplémentaire pour les serveurs critiques, tels qu'une alimentation et des ventilateurs supplémentaires.

Vous ne devez pas utiliser votre serveur Team Foundation Server comme serveur de builds. Les générations doivent être exécutées sur des ordinateurs séparés. En raison des fortes demandes placées sur les serveurs de builds au moment de la génération, l'exécution des générations sur un serveur Team Foundation pourrait entraîner une indisponibilité du serveur et réduire les performances.

Configurations logicielles requises

Le tableau suivant indique les logiciels requis pour les serveurs Team Foundation Build.

Logiciels | Version
Microsoft Windows Server 2003 avec SP1 ou Windows XP Professionnel | Toutes les éditions et versions
.NET Framework | 2.0

Outre les logiciels requis, vous devez déterminer si vous souhaitez installer un logiciel de gestion ou de sécurité supplémentaire, tel qu'un logiciel de sauvegarde ou des pare-feu.

Spécifications de la langue

Pour éviter la confusion et simplifier l'opération, un déploiement Team Foundation Build doit être configuré afin qu'il utilise le même langage que le système d'exploitation de l'ordinateur et que celui du serveur Team Foundation Server. Toutefois, vous pouvez installer une autre version linguistique de Team Foundation Build sur un serveur en langue anglaise, tant que ce langage correspond à celui du déploiement de Team Foundation Server.

Voir aussi

Concepts

Configuration requise pour le serveur Team System
Configuration des plates-formes de test pour Team System
Spécifications du client pour Team System

Autres ressources

Configuration de Visual Studio 2005 Team System
Planification du client et du serveur


Configuration des plates-formes de test pour Team System

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Configuration des plates-formes de test pour Team System
Voir aussi
Image de liste déroulante

Visual Studio intègre, outre la mesure de couverture du code, plusieurs types de tests, notamment les tests manuels, les tests de charge, les tests Web, et les tests unitaires. Team Edition for Testers permet aux utilisateurs de Visual Studio Team System d'effectuer des tests sur les ordinateurs distants, appelés « plate-forme de test ». Les plates-formes de test de Team Edition for Testers ont des configurations matérielle et logicielle requises spécifiques. Lorsque vous prévoyez de déployer des plates-formes de test, il est important de comprendre les besoins spécifiques à votre entreprise.

Configurations matérielle et logicielle requises

Team Edition for Testers vous permet de créer, de gérer, de modifier et d'exécuter des tests, mais aussi d'obtenir et de stocker les résultats des tests. Une plate-forme de test est composée d'un contrôleur de test et d'un ou plusieurs agents. Le contrôleur et l'agent de test peuvent être installés sur un ordinateur ou sur deux ordinateurs différents. Un contrôleur de test peut coordonner l'exécution de plusieurs séries de tests sur des ordinateurs sur lesquels l'agent de test est installé. À la fois les ordinateurs du contrôleur de test et de l'agent de test ont des configurations matérielle et logicielle requises spécifiques. De plus, si vous souhaitez déployer une plate-forme de test dans plusieurs langues, vous devez prévoir la prise en charge de ces langues.

Configuration matérielle requise

Le tableau suivant affiche la configuration matérielle requise recommandée pour déployer des plates-formes de test Team Edition for Testers.

Configuration | Composant | CPU | Disque dur | Mémoire
Minimale, 1 à 2 projets, 5 à 20 utilisateurs | agent de test | processeur seul, 600 GHz | 1 Go | 256 Mo
Minimale, 1 à 2 projets, 5 à 20 utilisateurs | contrôleur de tests | processeur seul, 600 MHz | 1 Go | 256 Mo
Minimale, 1 à 2 projets, 5 à 20 utilisateurs | les deux | processeur seul, 600 MHz | 1 Go | 512 Mo
Réduite, 2 à 20 projets, 20 à 100 utilisateurs | agent de test | processeur seul, 2,0 GHz | 5 Go | 512 Mo
Réduite, 2 à 20 projets, 20 à 100 utilisateurs | contrôleur de test | processeur seul, 1,0 GHz | 8 Go | 512 Mo
Réduite, 2 à 20 projets, 20 à 100 utilisateurs | les deux | processeur seul, 2,0 GHz | 8 Go | 1 Go
Moyenne, plus de 20 projets, 100 à 250 utilisateurs | agent de test | processeur seul, 2,6 GHz | 5 Go | 2 Go
Moyenne, plus de 20 projets, 100 à 250 utilisateurs | contrôleur de test | processeur seul, 2,0 GHz | 40 Go | 1 Go
Moyenne, plus de 20 projets, 100 à 250 utilisateurs | les deux | processeur seul, 2,6 GHz | 40 Go | 2 Go
Étendue, plus de 50 projets, 250 à 500 utilisateurs | agent de test | biprocesseurs, 2,8 GHz | 8 Go | 2 Go
Étendue, plus de 50 projets, 250 à 500 utilisateurs | contrôleur de test | processeur seul, 2,6 GHz | 48 Go | 1 Go
Étendue, plus de 50 projets, 250 à 500 utilisateurs | les deux | biprocesseurs, 2,8 GHz | 48 Go | 2 Go

Les indications présentées ici fournissent une aide générale en matière de planification de matériel. Les performances des tests seront très différentes selon la quantité de données des tests et le nombre d'agents de test. Pour les agents de test, la vitesse du processeur et la mémoire disponible limiteront la charge du test. Les contrôleurs de test ont besoin de plus grandes ressources selon le nombre d'agents de test et la quantité de données qui interviennent dans les tests.

Le serveur qui exécute Team Edition for Testers doit disposer d'une connexion réseau fiable avec une bande passante d'au moins 1 Mbit/s et une latence maximale de 350 ms. Il ne doit y avoir aucun pare-feu entre les agents de test et le contrôleur de test. Si vos performances de tests ne répondent pas à vos attentes, songez à mettre votre configuration matérielle à niveau.

Considérations sur le matériel supplémentaire

Les plates-formes de test génèrent une quantité considérable de données sur les contrôleurs de test, selon la durée du test et la taille du test. En général, vous devez prévoir 10 Go supplémentaires de stockage de disque dur pour 24 heures de données de test.

Outre le matériel recommandé ici, vous devez envisager d'acquérir du matériel supplémentaire pour les serveurs critiques, tels qu'une alimentation et des ventilateurs supplémentaires.

Configurations logicielles requises

Le tableau suivant affiche les logiciels requis pour les agents de test.

Logiciels | Version
Microsoft Windows Server 2003 avec Service Pack 1, Windows XP Professionnel avec Service Pack 2 ou Windows 2000 avec Service Pack 4 | Toutes les éditions et versions
SQL Express | 2005
.NET Framework | 2.0

Le tableau suivant présente les logiciels requis pour les contrôleurs de test.

Logiciels | Version
Microsoft Windows Server 2003 avec SP1 | Toutes les éditions et versions
SQL Express | 2005
.NET Framework | 2.0

Outre les logiciels requis répertoriés ici, vous devez déterminer si vous souhaitez installer un logiciel de gestion ou de sécurité supplémentaire, tel qu'un logiciel de sauvegarde ou des pare-feu.

Spécifications de la langue

Pour éviter la confusion et simplifier l'opération, une plate-forme de test doit être configurée afin qu'elle utilise le même langage que le système d'exploitation de l'ordinateur et que celui du serveur Team Foundation Server. Si l'agent de test et le contrôleur de test sont installés sur des ordinateurs différents, ils doivent être configurés afin d'utiliser le même langage. Toutefois, vous pouvez installer une autre version linguistique de Team Edition for Testers sur un système d'exploitation en langue anglaise, tant que ce langage correspond à celui du déploiement de Team Foundation Server.

Voir aussi

Concepts

Configuration requise pour le serveur Team System
Configuration de Team Build pour Team System
Spécifications du client pour Team System

Autres ressources

Configuration de Visual Studio 2005 Team System
Planification du client et du serveur


Configuration requise pour le serveur Team System

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Configuration requise pour le serveur Team System
Voir aussi
Image de liste déroulante

Team Foundation Server a des configurations matérielle et logicielle requises spécifiques. En outre, la configuration matérielle requise peut varier selon vos prévisions de déploiement et d'utilisation de Visual Studio Team System. Lorsque vous planifiez un déploiement de Team Foundation Server, il est important de bien définir les besoins spécifiques de votre entreprise.

Configurations matérielle et logicielle requises

Un serveur Team Foundation Server logique se compose de deux composants : un serveur de couche Application, composé principalement de services Web, et un serveur de couche Données, composé principalement d'une base de données SQL Server 2005. Le serveur de couche Application et le serveur de couche Données peuvent être déployés sur un ou deux serveurs, ce qui affecte l'organisation des configurations requises pour le serveur. Les configurations minimales et recommandées requises pour le serveur sont traitées ultérieurement dans cette rubrique. De plus, si vous souhaitez déployer dans plusieurs langues, vous devez prévoir quelles langues vous souhaitez prendre en charge dans votre déploiement.

Configuration matérielle requise

Le tableau suivant présente la configuration matérielle requise recommandée pour déployer Team Foundation Server sur un serveur unique et la configuration recommandée pour déployer Team Foundation Server sur deux serveurs, selon le nombre d'utilisateurs.

Configuration | Couches | CPU | Disque dur | Mémoire
Un serveur, moins de 20 utilisateurs. | serveur de couches Données et Application | processeur seul, 2,2 GHz | 8 Go | 1 Go
Un serveur ; 20 à 100 utilisateurs. | serveur de couches Données et Application | biprocesseurs, 2,2 GHz | 30 Go | 2 Go
Deux serveurs ; 100 à 250 utilisateurs. | serveur de couche Application | processeur seul, 2,2 GHz | 20 Go | 1 Go
Deux serveurs ; 100 à 250 utilisateurs. | serveur de couche Données | biprocesseurs, 2,2 GHz | 80 Go | 2 Go
Deux serveurs ; 250 à 500 utilisateurs. | serveur de couche Application | biprocesseurs, 2,2 GHz | 40 Go | 2 Go
Deux serveurs ; 250 à 500 utilisateurs. | serveur de couche Données | quadriprocesseurs, 2,2 GHz | 150 Go | 4 Go

Les indications présentées ici sont appropriées pour la plupart des déploiements. Elles sont conçues pour les environnements qui contiennent moins de 500 utilisateurs sur un serveur Team Foundation Server unique. Le serveur qui exécute Team Foundation Server doit disposer d'une connexion réseau fiable avec une bande passante d'au moins 1 Mbit/s et une latence maximale de 350 ms.

Si votre environnement ne répond pas à ces critères, vous devez étudier avec soin les implications avant de déployer Team Foundation Server. Vous devez envisager d'inclure un matériel plus puissant que celui qui est recommandé ici, permettant ainsi d'améliorer la fiabilité et la bande passante du réseau, et d'utiliser plusieurs serveurs qui exécutent Team Foundation Server.

Matériel supplémentaire

Outre le matériel recommandé ici, vous devez envisager d'acquérir du matériel supplémentaire pour les serveurs critiques, tels qu'une alimentation et des ventilateurs supplémentaires.

Configurations logicielles requises

Les configurations logicielles requises pour Team Foundation Server sont présentées dans le Guide d'installation Team Foundation Server. Vous pouvez télécharger la version la plus récente du Guide d'installation Team Foundation sur le site Web de Microsoft à l'adresse http://go.microsoft.com/fwlink/?linkid=40042.

Outre les logiciels requis répertoriés dans le guide d'installation, vous devez déterminer si vous souhaitez installer un logiciel de gestion ou de sécurité supplémentaire, tel qu'un logiciel de sauvegarde ou des pare-feu.

Spécifications de la langue

Le déploiement d'un serveur Team Foundation Server logique, sur un ou deux serveurs, peut être configuré pour prendre en charge une, et une seule, langue. Si Team Foundation Server est déployé sur deux serveurs, les deux serveurs requièrent la même configuration pour la langue de Team Foundation Server et la langue du système d'exploitation. Les seules exceptions sont les versions anglaises de Windows Server 2003. Vous pouvez installer une autre version linguistique de Team Foundation Server sur un serveur de langue anglaise.

Par exemple, un serveur Team Foundation Server anglais peut être installé sur un système d'exploitation anglais ou japonais. Une version localisée de Team Foundation Server doit être installée sur un système d'exploitation de même langue ou sur un système d'exploitation anglais. Si vous déployez un serveur Team Foundation Server japonais, il peut uniquement être installé sur une version japonaise ou anglaise du système d'exploitation.

Vous devez également installer le module de prise en charge linguistique Windows SharePoint Services qui correspond à la langue de Team Foundation Server. Par exemple, si vous déployez la version anglaise de Team Foundation Server sur un système d'exploitation localisé en une autre langue, vous devez installer le module de prise en charge linguistique anglais pour Windows SharePoint Services. Si vous déployez un serveur Team Foundation Server japonais sur un système d'exploitation anglais, vous devez installer le module de prise en charge linguistique japonais de Windows SharePoint Services.

Voir aussi

Concepts

Configuration de Team Build pour Team System
Configuration des plates-formes de test pour Team System
Spécifications du client pour Team System

Autres ressources

Configuration de Visual Studio 2005 Team System
Planification du client et du serveur


Spécifications du client pour Team System

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Spécifications du client pour Team System
Voir aussi
Image de liste déroulante

Comme pour Team Foundation Server, les clients de Team Foundation ont également des impératifs spécifiques relatifs au matériel et aux logiciels. Lors de la planification d'un déploiement de Visual Studio Team System, il est également important de comprendre les besoins spécifiques à votre entreprise. Les impératifs matériels peuvent varier selon vos projets de déploiement et d'utilisation de Visual Studio Team System : quelles éditions basées sur les rôles vous projetez d'utiliser, le nombre de projets différents sur lesquels travailleront vos utilisateurs et le nombre de rôles différents que vos utilisateurs devront exécuter pendant vos projets.

Configurations matérielle et logicielle requises

Lorsque vous déterminez vos configurations matérielle et logicielle requises, examinez les points suivants :

  • Quelles éditions basées sur les rôles vous souhaitez installer sur vos ordinateurs clients.

  • Quel logiciel est déjà installé sur vos ordinateurs clients.

Pour une vue d'ensemble sur les différentes éditions basées sur les rôles de Team Foundation et Team Explorer, consultez Planification du client.

Configuration matérielle requise

La configuration matérielle requise suivante s'applique aux clients basés sur les rôles de Visual Studio Team System et de Team Explorer.

Client | CPU | Mémoire | Disque dur
Configuration minimale requise | 2,0 GHz | 512 Mo | 8 Go
Configuration recommandée | 2,6 GHz | 1 Go | 20 Go

Les administrateurs qui souhaitent installer Visual Studio Team Edition for Testers et inclure une plate-forme de test disposeront d'une configuration matérielle requise supplémentaire. Pour plus d'informations sur Visual Studio Team Edition for Testers, consultez Configuration des plates-formes de test pour Team System.

Configurations logicielles requises

Tous les clients de Visual Studio Team System disposent de configurations logicielles requises spécifiques.

Configuration du système d'exploitation client

Les systèmes d'exploitation clients suivants sont pris en charge pour les clients de Visual Studio Team System :

  • Windows XP Professionnel avec le Service Pack 2 installé.

  • Windows Server 2003

Composants logiciels clients requis

En plus du système d'exploitation, vous devez installer le logiciel suivant sur vos ordinateurs clients avant d'installer des clients de Visual Studio Team System.

Composant | Version
Internet Explorer | 6.0 avec le Service Pack 1
Microsoft Office | 11 avec le Service Pack 1
MDAC | 9.0
.NET Framework | 2.0

Installation d'Explorateur d'équipes avec un autre logiciel comprenant un environnement de développement intégré

L'Explorateur d'équipes peut être installé et exécuté côte à côte avec d'autres IDE (integrated development environments, environnements de développement intégré), s'ils disposent de l'autorisation d'accès clients aux fonctionnalités de Team Foundation Server, tels que :

  • Développeurs utilisant Visual Studio 2005 éditions Professional ou Standard.

    L'Explorateur d'équipes peut être installé sur Visual Studio 2005 éditions Professional, s'il dispose de l'autorisation d'accès aux fonctionnalités de Team Foundation Server. L'Explorateur d'équipes doit être installé sur ces éditions et ne peut pas être installé côte à côte avec Visual Studio 2005 éditions Professional.

  • Développeurs utilisant Visual Studio 2005 éditions Express.

    L'Explorateur d'équipes peut être installé et exécuté côte à côte avec Visual Studio 2005 éditions Express, s'il dispose de l'autorisation d'accès aux fonctionnalités de Team Foundation Server.

  • Développeurs utilisant des versions de Visual Studio plus anciennes, telles que Visual Studio 6.

    L'Explorateur d'équipes peut être installé et exécuté côte à côte avec des versions antérieures de Visual Studio (y compris les versions antérieures de Visual Studio .NET), s'il dispose de l'autorisation d'accès clients aux fonctionnalités de Team Foundation Server.

  • Développeurs utilisant des environnements de développement intégré autres que Visual Studio.

    L'Explorateur d'équipes peut être installé et exécuté côte à côte avec d'autres IDE, s'il dispose de l'autorisation d'accès clients aux fonctionnalités de Team Foundation Server.

Microsoft Project et Microsoft Excel comme clients de Visual Studio Team System

Les utilisateurs peuvent également accéder aux fonctionnalités de Team Foundation Server via Microsoft Project et Microsoft Excel en installant un client basé sur les rôles de Visual Studio Team System ou Team Explorer sur l'ordinateur client.

Windows SharePoint Services

Aucune condition supplémentaire pour l'installation n'est exigée pour accéder aux fonctionnalités de Visual Studio Team System autres qu'Internet Explorer. Les fonctionnalités de Team Foundation Server se trouvent à disposition sur le Web, y compris l'accès au portail Web projet d'équipe basé sur Windows SharePoint Services, les rapports basés SQL Analysis Service et les fonctionnalités de suivi des éléments de travail.

Considérations sur la langue

Vous pouvez installer la version anglaise de Visual Studio Team System si la version d'un système d'exploitation pris en charge est localisée. Vous pouvez installer une version localisée de Visual Studio Team System sur un système d'exploitation dont la langue correspond ou un système d'exploitation en anglais. Par exemple, une version japonaise de Visual Studio peut être installée sur une version japonaise de Windows XP ou sur une version anglaise de Windows XP, mais pas sur une version allemande de Windows XP.

Si une version localisée de Team Foundation Server est installée sur un système d'exploitation anglais, vous aurez besoin d'un pack d'interface multi-utilisateurs ou au moins d'une installation des polices appropriées pour ce langage.

Visual Studio Team System et Microsoft Office

L'utilisation simultanée de Visual Studio Team System et de Microsoft Office entraîne des contraintes de langage supplémentaires à considérer. Le langage du système d'exploitation peut être n'importe quel langage pris en charge, et le langage de Visual Studio peut être n'importe quel langage pris en charge, sauf si Microsoft Office est installé. Si Microsoft Office est installé, ces contraintes s'appliquent.

Version de la langue d'Office | Visual Studio anglais | Visual Studio autre langue
Office anglais | Pris en charge | Pris en charge
Office autre langue | Pris en charge | La langue doit correspondre à la langue de Visual Studio

Autres considérations

Les clients basés sur les rôles de Visual Studio Team System et de Team Explorer peuvent être gérés à distance et virtuellement.

PC virtuels

Les clients basés sur les rôles de Visual Studio Team System et de Team Explorer fonctionneront correctement sur un PC virtuel. Cette configuration n'est pas recommandée pour les environnements de production.

Remarque Remarque

Le profilage ne fonctionnera pas sur un PC virtuel en raison des restrictions du pilote.

Serveurs Terminal Servers

Les clients basés sur les rôles de Visual Studio Team System et de Team Explorer fonctionneront correctement avec Terminal Server.

Voir aussi

Concepts

Planification du client
Planification du serveur

Autres ressources

Configuration de Visual Studio 2005 Team System


Gestion de Team Foundation Server

Gestion de Team Foundation Server
DropDown image

En tant qu'administrateur Team Foundation Server, vous devez être familier avec les outils d'administration de Windows Server 2003, SQL Server 2005 et Windows SharePoint Services. Les rubriques suivantes vous donnent les informations spécifiques que vous possédez pour gérer Team Foundation Server.

Dans cette section

Gestion des utilisateurs et groupes

Décrit comment ajouter, supprimer et modifier des utilisateurs et des groupes dans Team Foundation Server.

Gestion des autorisations

Décrit les groupes et les autorisations par défaut et la manière de modifier ces autorisations.

Gestion des services et comptes de service Team Foundation Server

Décrit les services et les comptes de service qui s'exécutent sur la couche Données ou sur la couche Application de Team Foundation Server.

Gestion des données

Décrit les outils, les procédures et les indications permettant de gérer les données utilisées et stockées dans Team Foundation Server.

Gestion des services SQL Server

Fournit des liens vers les rubriques appropriées dans la documentation en ligne SQL Server 2005 pour gérer la base de données, l'analyse et les services de rapports utilisés par Team Foundation.

Gestion des composants Team Foundation Server

Décrit les procédures pour regrouper, basculer, réparer et renommer les serveurs de couche Application et de couche Données.

Gestion de Team Foundation Server dans un domaine Active Directory

Décrit le déploiement stable et sécurisé de Team Foundation Server dans un environnement Active Directory et fournit des exemples de configurations de domaine non prises en charge.

Gestion de Team Foundation Server dans un groupe de travail

Identifie les avantages et les inconvénients de l'utilisation de Team Foundation Server dans un groupe de travail.

Gestion des connexions à distance avec Team Foundation Server Proxy

Décrit le fonctionnement du proxy Team Foundation Server et les procédures pour le configurer.

Gestion des sites Team Foundation Server dans Windows SharePoint Services

Décrit les tâches qui affectent la connectivité et les performances d'un serveur qui exécute Windows SharePoint Services qui est également configuré pour Team Foundation.

Gestion des paramètres de configuration de Team Foundation Server

Décrit les procédures pour configurer l'environnement Team Foundation Server à l'aide des services Web et des fichiers Web.config.

Voir aussi

Autres ressources

Administration de Team Foundation Server


Gestion des utilisateurs et groupes

Gestion des utilisateurs et groupes
DropDown image

La sécurité de Team Foundation est basée sur les utilisateurs et les groupes. Vous pouvez gérer les utilisateurs et les groupes pour implémenter un modèle de sécurité pour votre organisation qui permet aux utilisateurs d'accéder aux données et aux fonctionnalités dont ils ont besoin en protégeant les informations confidentielles.

Dans cette section

Gestion des groupes

Décrit les procédures de création, d'affichage, de changement de nom, de suppression ou d'enregistrement des groupes dans Team Foundation Server.

Gestion des utilisateurs

Décrit les procédures d'ajout, de désactivation, de réactivation ou de suppression de comptes d'utilisateur individuels dans Team Foundation Server.

Rubriques connexes

Administration de Team Foundation Server

Voir aussi

Autres ressources

Gestion des sites Team Foundation Server dans Windows SharePoint Services
Utilisation des outils de ligne de commande Team Foundation Server


Gestion des groupes

Gestion des groupes
DropDown image

Un groupe est une collection d'utilisateurs qui ont les mêmes conditions de sécurité dans Team Foundation Server. En ajoutant des utilisateurs aux groupes, vous pouvez réduire considérablement le temps passé à la gestion des autorisations utilisateur. Les utilisateurs héritent automatiquement des autorisations de tout groupe auquel ils appartiennent.

Remarque Remarque

Cela peut prendre quelques minutes pour qu'une nouvelle appartenance à un groupe se propage à un compte d'utilisateur individuel.

Dans cette section

Groupes par défaut

Décrit les groupes globaux par défaut et les groupes de projets d'équipe créés lors de l'installation de Team Foundation Server.

Groupes personnalisés

Décrit les groupes de projets d'équipe et de niveau serveur que vous pouvez créer.

Ajout et suppression d'utilisateurs dans des groupes

Fournit des liens vers des rubriques sur l'ajout ou la suppression d'utilisateurs de différents groupes de niveau serveur, de projet d'équipe ou par défaut.

Voir aussi

Autres ressources

Gestion des utilisateurs


Groupes par défaut

Groupes par défaut
DropDown image

Lorsque Team Foundation Server est installé, les groupes globaux suivants sont créés. Vous pouvez utiliser ces groupes globaux pour contrôler les autorisations pour les utilisateurs de Team Foundation.

Group | Autorisations
Team Foundation Administrators | Peuvent exécuter toutes les opérations privilégiées sur le serveur Team Foundation Server.
Team Foundation Valid Users | Ont accès au serveur Team Foundation Server. Vous ne pouvez pas ajouter ou supprimer manuellement des utilisateurs ou des groupes de ce groupe dans l'interface utilisateur de Team Foundation Server.
Team Foundation Service Accounts | Contient des comptes de service.

Lorsque vous créez un nouveau projet d'équipe, Team Foundation crée les groupes de projets d'équipe suivants.

Group | Autorisations
Administrateurs de projet (Project administrators) | Peuvent gérer le projet d'équipe.
Lecteur de projet (Readers) | Peut consulter le projet d'équipe (accès en lecture).
Collaborateur de projet (Contributors) | Peut modifier le projet d'équipe (accès en lecture et en écriture).
Services de build de projet (Build Services) | Peut générer le projet.

Vous pouvez utiliser ces groupes de projets d'équipe pour contrôler les autorisations pour les membres des projets d'équipe.

Dans cette section

Comment : afficher les groupes par défaut

Explique comment afficher les appartenances et autorisations de groupe.

Comment : supprimer des utilisateurs d'un groupe par défaut

Explique comment supprimer des utilisateurs ou des groupes des groupes par défaut Team Foundation Server.

Comment : modifier les autorisations d'un groupe par défaut

Explique comment modifier les autorisations pour un groupe de niveau serveur ou de niveau projet par défaut.

Comment : ajouter des utilisateurs à un groupe par défaut

Explique comment ajouter des utilisateurs ou un groupe Team Foundation Server à un groupe déjà associé à un projet d'équipe.

Voir aussi

Tâches

Comment : modifier des autorisations pour un groupe ou un utilisateur


Comment : afficher les groupes par défaut

Comment : afficher les groupes par défaut

Vous pouvez consulter l'appartenance et les informations de groupe de chaque groupe de sécurité pour votre serveur Team Foundation Server. Examinez régulièrement l'appartenance et les informations de groupe pour les groupes de sécurité intégrés ainsi que les informations relatives aux groupes que vous créez. Si vous souhaitez créer un groupe qui possède des autorisations dans plusieurs projets, consultez Comment : créer un groupe de niveau serveur. Si vous souhaitez créer un groupe de sécurité pour votre projet d'équipe, consultez Comment : créer un groupe de projets d'équipe.

Pour afficher l'appartenance au groupe pour les groupes de niveau serveur

  1. Dans Team Explorer, sélectionnez le serveur Team Foundation Server pour lequel vous souhaitez afficher les informations d'appartenance au groupe.

  2. Dans le menu Équipe, pointez sur Paramètres Team Foundation Server, puis cliquez sur Appartenance au groupe.

  3. Dans la boîte de dialogue Groupes globaux, sélectionnez le groupe pour lequel vous souhaitez afficher l'appartenance au groupe, puis cliquez sur Propriétés.

  4. Dans Utilisateur ou groupe, examinez la liste des utilisateurs et des groupes membres sous l'onglet Membre. Pour connaître les groupes auxquels ce groupe appartient, cliquez sur l'onglet Membre de.

  5. Lorsque vous avez terminé, cliquez sur OK.

Pour afficher les autorisations du groupe pour les groupes de niveau serveur

  1. Dans Team Explorer, sélectionnez le serveur Team Foundation Server pour lequel vous souhaitez afficher les informations d'autorisations de groupe.

  2. Dans le menu Équipe, pointez sur Paramètres Team Foundation Server, puis cliquez sur Sécurité.

  3. Dans la boîte de dialogue Autorisations, sélectionnez dans Utilisateurs et groupes, le groupe pour lequel vous souhaitez afficher les autorisations.

  4. Examinez la liste d'éléments sélectionnés dans la liste d'autorisations. Si un élément est ombré et qu'il ne peut pas être sélectionné, cette autorisation a été définie par défaut et ne peut pas être modifiée.

  5. Lorsque vous avez terminé, cliquez sur Fermer.

Pour afficher l'appartenance au groupe des groupes de projets d'équipe

  1. Dans Team Foundation Server, sélectionnez le projet d'équipe pour lequel vous souhaitez afficher les informations d'appartenance au groupe.

  2. Dans le menu Équipe, pointez sur Paramètres du projet d'équipe, puis cliquez sur Appartenance au groupe.

  3. Dans la boîte de dialogue Groupes de projets, sélectionnez le groupe pour lequel vous souhaitez afficher l'appartenance au groupe, puis cliquez sur Propriétés.

  4. Dans Utilisateur ou groupe, examinez la liste des utilisateurs et des groupes membres sous l'onglet Membre. Pour connaître les groupes auxquels ce groupe appartient, cliquez sur l'onglet Membre de.

  5. Lorsque vous avez terminé, cliquez sur OK.

Pour afficher les autorisations de groupe pour les groupes de projets d'équipe

  1. Dans Team Explorer, sélectionnez le projet d'équipe pour lequel vous souhaitez afficher les informations d'appartenance au groupe.

  2. Dans le menu Équipe, pointez sur Paramètres du projet d'équipe, puis cliquez sur Sécurité.

  3. Dans la boîte de dialogue Autorisations, sélectionnez dans Utilisateurs et groupes, le groupe pour lequel vous souhaitez afficher les autorisations.

  4. Examinez la liste d'éléments sélectionnés dans la liste d'autorisations. Si un élément est ombré et qu'il ne peut pas être sélectionné, cette autorisation a été définie par défaut et ne peut pas être modifiée.

  5. Lorsque vous avez terminé, cliquez sur Fermer.

Sécurité

Vous devez être un membre du groupe Team Foundation Valid Users pour afficher les autorisations assignées à un groupe. Les membres du groupe Team Foundation Valid Users ne peuvent pas modifier ces autorisations, mais ils peuvent les consulter.

Voir aussi

Concepts

Ajout et suppression d'utilisateurs dans des groupes

Autres ressources

Gestion de Team Foundation Server dans un domaine Active Directory
Groupes par défaut
Affichage et modification des autorisations


Comment : supprimer des utilisateurs d'un groupe par défaut

Comment : supprimer des utilisateurs d'un groupe par défaut

Les modifications d'appartenance apportées à un groupe de niveau serveur par défaut réalisées au niveau du projet d'équipe seront répercutées au niveau du serveur.

L'appartenance de certains groupes par défaut ne peut pas être modifiée. Pour plus d'informations, consultez Groupes par défaut.

Pour supprimer des utilisateurs ou des groupes d'un groupe par défaut de niveau projet

  1. Dans Team Explorer, sélectionnez le projet d'équipe dans lequel se trouve le groupe.

  2. Dans le menu Équipe, pointez sur Paramètres du projet d'équipe, puis cliquez sur Appartenance au groupe.

  3. Dans la boîte de dialogue Groupes de projets, sélectionnez le groupe par défaut duquel vous souhaitez supprimer des utilisateurs, puis cliquez sur Propriétés.

  4. Dans la boîte de dialogue Propriétés du groupe Team Foundation Server, dans l'onglet Membres, sélectionnez les utilisateurs ou les groupes que vous souhaitez supprimer.

  5. Cliquez sur Supprimer.

  6. Cliquez sur OK.

Pour supprimer des utilisateurs ou des groupes d'un groupe par défaut de niveau serveur

  1. Dans Team Explorer, sélectionnez le serveur Team Foundation.

  2. Dans le menu Équipe, pointez sur Paramètres Team Foundation Server, puis cliquez sur Appartenance au groupe.

  3. Dans la boîte de dialogue Groupes globaux, sélectionnez le groupe par défaut duquel vous souhaitez supprimer des utilisateurs, puis cliquez sur Propriétés.

  4. Dans la boîte de dialogue Propriétés du groupe Team Foundation Server, dans l'onglet Membres, sélectionnez les utilisateurs ou les groupes que vous souhaitez supprimer.

  5. Cliquez sur Supprimer.

  6. Cliquez sur OK.

Sécurité

Vous devez être administrateur Team Foundation Server ou administrateur de projet pour ajouter ou supprimer des utilisateurs dans un projet Team Foundation Server. Pour plus d'informations sur les autorisations requises pour ajouter et supprimer des utilisateurs dans des projets, ainsi que des descriptions d'autorisations au niveau du serveur et d'autorisations au niveau du projet, consultez Autorisations de Team Foundation Server.

Voir aussi

Tâches

Comment : supprimer un groupe de niveau serveur

Concepts

Concepts sur la sécurité de Team Foundation Server
Sécurité de Team Foundation Server pour les utilisateurs et les groupes
Autorisations de Team Foundation Server


Comment : modifier les autorisations d'un groupe par défaut

Comment : modifier les autorisations d'un groupe par défaut

Certains groupes par défaut sont définis au niveau du serveur, alors que d'autres sont définis au niveau du projet d'équipe. Il existe des autorisations différentes au niveau du serveur et au niveau du projet d'équipe. Pour obtenir une liste complète des autorisations de serveur et des autorisations de projet, consultez Autorisations de Team Foundation Server. Utilisez cette liste pour décider si vous devez accepter ou refuser une autorisation et consultez les procédures suivantes.

Remarque Remarque

Certains groupes par défaut sont dérivés d'autres appartenances aux groupes et il n'est pas possible de modifier directement leurs autorisations. Pour plus d'informations, consultez Groupes par défaut.

Pour modifier les autorisations pour un groupe de niveau serveur par défaut

  1. Dans Team Explorer, sélectionnez le serveur Team Foundation Server pour lequel vous souhaitez afficher les informations d'autorisation de groupe.

  2. Dans le menu Équipe, pointez sur Paramètres Team Foundation Server, puis cliquez sur Sécurité.

  3. Dans la boîte de dialogue Sécurité globale, sélectionnez dans Utilisateurs et Groupes le groupe par défaut pour lequel vous souhaitez afficher les autorisations.

  4. Examinez la liste des autorisations sélectionnées au bas de la boîte de dialogue. Si un élément est ombré et qu'il ne peut pas être sélectionné, cette autorisation a été définie par défaut et ne peut pas être modifiée.

  5. Pour les autorisations appropriées au bas de la boîte de dialogue, sélectionnez ou désactivez Autoriser ou Refuser selon le cas. Cliquez sur Fermer lorsque vous avez terminé.

Pour modifier les autorisations pour un groupe de niveau projet par défaut

  1. Dans Team Explorer, sélectionnez le projet pour lequel vous souhaitez afficher les informations d'autorisation de groupe.

  2. Dans le menu Équipe, pointez sur Paramètres du projet d'équipe, puis cliquez sur Sécurité.

  3. Dans la boîte de dialogue Sécurité du projet, sélectionnez dans Utilisateurs et Groupes le groupe par défaut pour lequel vous souhaitez afficher les autorisations.

  4. Examinez la liste des autorisations sélectionnées au bas de la boîte de dialogue. Si un élément est ombré et qu'il ne peut pas être sélectionné, cette autorisation a été définie par défaut et ne peut pas être modifiée.

  5. Pour les autorisations appropriées au bas de la boîte de dialogue, sélectionnez ou désactivez Autoriser ou Refuser selon le cas. Cliquez sur Fermer lorsque vous avez terminé.

Sécurité

Vous devez être administrateur Team Foundation Server pour modifier les groupes de niveau serveur Team Foundation Server par défaut. Pour plus d'informations sur les autorisations requises pour ajouter et supprimer des utilisateurs dans des projets, ainsi que des descriptions d'autorisations au niveau du serveur et d'autorisations au niveau du projet, consultez Autorisations de Team Foundation Server.

Voir aussi

Concepts

Concepts sur la sécurité de Team Foundation Server
Sécurité de Team Foundation Server pour les utilisateurs et les groupes
Autorisations de Team Foundation Server


Comment : ajouter des utilisateurs à un groupe par défaut

Comment : ajouter des utilisateurs à un groupe par défaut

Cette procédure explique comment ajouter un nouveau membre à l'un des groupes prédéfinis par Team Foundation Server. Vous pouvez ajouter un utilisateur ou un groupe défini dans Team Foundation Server ou un utilisateur ou un groupe défini par votre réseau Windows.

Les modifications d'appartenance apportées à un groupe de niveau serveur par défaut réalisées au niveau du projet d'équipe sont répercutées au niveau du serveur.

Pour ajouter des utilisateurs à un groupe a associé à un projet d'équipe

  1. Dans Team Explorer, sélectionnez le projet d'équipe dans lequel se trouve le groupe ou, pour ajouter un groupe de niveau serveur, sélectionnez le serveur Team Foundation Server dans lequel se trouve le groupe.

  2. Dans le menu Équipe, pointez sur Paramètres du projet d'équipe, puis cliquez sur Appartenance au groupe.

  3. Dans la boîte de dialogue Groupes de projets, sélectionnez le groupe par défaut auquel vous souhaitez ajouter des utilisateurs, puis cliquez sur Propriétés.

  4. Sous l'onglet Membres de la boîte de dialogue Propriétés du groupe Team Foundation Server, sous Ajouter un membre, sélectionnez Utilisateur ou groupe Windows.

  5. Cliquez sur Add.

  6. Dans la boîte de dialogue Sélectionner les utilisateurs ou les groupes, sous Entrez les noms des objets à sélectionner, entrez le nom de domaine et les alias des utilisateurs que vous souhaitez ajouter au format suivant :

    domaine\aliasutilisateur

    Pour ajouter plusieurs utilisateurs à la fois, séparez les entrées par un point-virgule (;).

  7. Cliquez sur OK.

Pour ajouter un groupe Team Foundation Server à un groupe associé à un projet d'équipe

  1. Dans Team Explorer, sélectionnez le projet d'équipe dans lequel se trouve le groupe ou, pour ajouter un groupe de niveau serveur, sélectionnez le serveur Team Foundation Server dans lequel se trouve le groupe.

  2. Dans le menu Équipe, pointez sur Paramètres du projet d'équipe, puis cliquez sur Appartenance au groupe.

  3. Dans la boîte de dialogue Groupes de projets, sélectionnez le groupe par défaut auquel vous souhaitez ajouter un groupe Team Foundation Server, puis cliquez sur Propriétés.

  4. Sous l'onglet Membres de la boîte de dialogue Propriétés du groupe Team Foundation Server, sous Ajouter un membre, sélectionnez Groupe Team Foundation Server.

  5. Cliquez sur Add.

  6. Dans la boîte de dialogue Sélectionner les groupes, sous Groupes, sélectionnez le groupe que vous souhaitez ajouter et cliquez sur OK.

Sécurité

Vous devez être administrateur Team Foundation Server ou administrateur de projet pour ajouter ou supprimer des utilisateurs dans un projet Team Foundation Server. Pour plus d'informations sur les autorisations requises pour ajouter et supprimer des utilisateurs dans des projets, ainsi que des descriptions d'autorisations au niveau du serveur et d'autorisations au niveau du projet, consultez Autorisations de Team Foundation Server.

Voir aussi

Concepts

Concepts sur la sécurité de Team Foundation Server
Sécurité de Team Foundation Server pour les utilisateurs et les groupes
Autorisations de Team Foundation Server

Autres ressources

Gestion des utilisateurs et groupes


Groupes personnalisés

Groupes personnalisés
DropDown image

Un groupe personnalisé est un groupe que vous créez en dehors des groupes par défaut qui sont installés en même temps que votre serveur ou assignés à un nouveau projet.

Un groupe personnalisé peut être un groupe de niveau serveur ou un groupe de projets d'équipe. Les groupes de niveau serveur peuvent disposer d'autorisations au niveau du serveur et au niveau du projet d'équipe. Les autorisations de niveau serveur incluent la capacité à créer de nouveaux projets, d'administrer les modifications réservées et de modifier le modèle de processus, entre autres. Les groupes de projets d'équipe peuvent disposer uniquement d'autorisations permettant d'exécuter des opérations de projet, telles que le démarrage d'une génération ou la publication des résultats de tests.

Pour plus d'informations sur les différentes autorisations accessibles aux groupes Team Foundation Server, consultez Autorisations de Team Foundation Server.

Dans cette section

Groupes de niveau serveur

Décrit les groupes de niveau serveur ainsi que leur création et leur gestion.

Groupes de projets d'équipe

Décrit les groupes de projets d'équipe ainsi que leur création et leur gestion.

Voir aussi

Autres ressources

Groupes par défaut


Groupes de niveau serveur

Groupes de niveau serveur
DropDown image

Les groupes de niveau serveur sont des groupes créés directement sur le serveur Team Foundation Server. Ils s'opposent aux groupes de projets d'équipe qui sont associés à un projet spécifique. Les groupes de niveau serveur peuvent se voir assigner des autorisations afin d'effectuer des tâches sur le serveur Team Foundation lui-même, telles que la création de projets ou l'administration des utilisateurs. Ils peuvent également être assignés à des projets et se voir accorder des autorisations spécifiques au projet, telles que l'autorisation de commencer une build ou de supprimer un projet.

Dans cette section

Comment : créer un groupe de niveau serveur

Décrit comment créer un groupe de niveau serveur personnalisé.

Comment : ajouter des utilisateurs à un groupe de niveau serveur

Décrit comment remplir un groupe de niveau serveur personnalisé avec des utilisateurs.

Comment : supprimer des utilisateurs d'un groupe de niveau serveur

Décrit comment sortir un utilisateur d'un groupe de niveau serveur personnalisé.

Comment : supprimer un groupe de niveau serveur

Décrit comment supprimer un groupe de niveau serveur personnalisé.

Comment : renommer un groupe de niveau serveur

Décrit comment assigner un nouveau nom à un groupe de niveau serveur personnalisé.

Rubriques connexes

Groupes par défaut

Groupes de projets d'équipe

Voir aussi

Concepts

Groupes, autorisations et rôles par défaut de Team Foundation Server


Comment : créer un groupe de niveau serveur

Comment : créer un groupe de niveau serveur

La création d'un groupe de sécurité de niveau serveur est une façon efficace d'accorder un jeu spécifique d'autorisations à un groupe de personnes pour Team Foundation Server. Si vous souhaitez créer un groupe de sécurité pour votre projet d'équipe, consultez Comment : créer un groupe de projets d'équipe. Assurez-vous d'octroyer uniquement les autorisations minimales nécessaires pour les besoins du groupe et d'ajouter uniquement les utilisateurs ou les groupes qui doivent appartenir à ce nouveau groupe global. Si ce groupe requiert un niveau supérieur d'autorisations, mais est spécifique au projet, songez à créer un groupe de projets d'équipe à la place.

Pour créer un groupe de niveau serveur

  1. Dans Team Explorer, sélectionnez le serveur Team Foundation Server pour lequel vous souhaitez créer un groupe de niveau serveur.

  2. Dans le menu Équipe, pointez sur Paramètres Team Foundation Server, puis cliquez sur Appartenance au groupe.

  3. Dans la boîte de dialogue Appartenance au groupe global, cliquez sur Nouveau.

  4. Dans la boîte de dialogue Créer un groupe Team Foundation Server, dans la zone Nom du groupe, entrez le nouveau nom du groupe de projets d'équipe.

  5. Dans la zone Description, saisissez une description du contrôle.

  6. Cliquez sur OK.

Remarque Important

Après avoir créé un groupe de niveau serveur, vous devez ajouter ce groupe à Team Foundation Server dans la boîte de dialogue Sécurité, octroyer les autorisations appropriées au groupe, puis ajouter des membres au groupe. Par défaut, un groupe est créé sans autorisation.

Sécurité

Vous devez être membre du groupe Administrateur Team Foundation pour créer des groupes de niveau serveur.

Voir aussi

Tâches

Comment : créer un groupe de projets d'équipe
Comment : modifier des autorisations pour un utilisateur

Concepts

Ajout et suppression d'utilisateurs dans des groupes

Autres ressources

Affichage et modification des autorisations


Comment : ajouter des utilisateurs à un groupe de niveau serveur

Comment : ajouter des utilisateurs à un groupe de niveau serveur
Voir aussi

Vous pouvez ajouter des utilisateurs aux groupes de projets d'équipe existants ou aux groupes de niveau serveur. Vous devrez également ajouter des membres aux groupes que vous créez. Pour ajouter des utilisateurs aux groupes, vous devez avoir l'accès en lecture/écriture aux groupes que vous modifiez.

Pour ajouter des utilisateurs à un groupe

  1. Dans Team Explorer, sélectionnez le projet d'équipe ou le serveur Team Foundation Server dans lequel le groupe auquel vous souhaitez ajouter des utilisateurs se trouve.

  2. Dans le menu Équipe, pointez sur Paramètres du projet d'équipe, puis cliquez sur Appartenance au groupe, ou, pour ajouter des utilisateurs à un groupe de niveau serveur, pointez sur Paramètres Team Foundation Server, puis cliquez sur Appartenance au groupe.

  3. Dans la boîte de dialogue Groupes de projets, sélectionnez le groupe auquel vous souhaitez ajouter des utilisateurs, puis cliquez sur Propriétés.

  4. Sous l'onglet Membres de la boîte de dialogue Propriétés du groupe Team Foundation Server, sous Ajouter un membre, sélectionnez Utilisateur ou groupe Windows.

  5. Cliquez sur Ajouter.

  6. Dans la boîte de dialogue Sélectionner les utilisateurs ou les groupes, sous Entrez les noms des objets à sélectionner, entrez le nom de domaine et les alias des utilisateurs que vous souhaitez ajouter au format suivant :

    domaine\aliasutilisateur

    Pour ajouter plusieurs utilisateurs à la fois, séparez les entrées par un point-virgule (;).

  7. Cliquez sur OK.

Pour ajouter un groupe Team Foundation Server à un groupe

  1. Dans Team Explorer, sélectionnez le projet d'équipe dans lequel se trouve le groupe ou, pour ajouter un groupe de niveau serveur, sélectionnez le serveur Team Foundation Server dans lequel se trouve le groupe.

  2. Dans le menu Équipe, pointez sur Paramètres du projet d'équipe, puis cliquez sur Appartenance au groupe, ou, pour ajouter des utilisateurs à un groupe de niveau serveur, pointez sur Paramètres Team Foundation Server, puis cliquez sur Appartenance au groupe.

  3. Dans la boîte de dialogue Groupes de projets, sélectionnez le groupe auquel vous souhaitez ajouter un groupe Team Foundation Server, puis cliquez sur Propriétés.

  4. Sous l'onglet Membres de la boîte de dialogue Propriétés du groupe Team Foundation Server, sous Ajouter un membre, sélectionnez Groupe Team Foundation Server.

  5. Cliquez sur Ajouter.

  6. Dans la boîte de dialogue Sélectionner les groupes, sous Groupes, sélectionnez le groupe que vous souhaitez ajouter et cliquez sur Fermer.

Voir aussi

Tâches

Comment : créer un groupe de projets d'équipe
Comment : créer un groupe de niveau serveur

Concepts

Autorisations de Team Foundation Server
Groupes, autorisations et rôles par défaut de Team Foundation Server

Autres ressources

Groupes de niveau serveur
Groupes par défaut


Comment : supprimer des utilisateurs d'un groupe de niveau serveur

Comment : supprimer des utilisateurs d'un groupe de niveau serveur
Voir aussi

Lorsque les utilisateurs ou les groupes ne font plus partie du projet d'équipe ou n'ont plus besoin d'accéder aux ressources de projet d'équipe, vous pouvez supprimer leur compte d'utilisateur du groupe de niveau serveur.

Pour supprimer des utilisateurs d'un groupe de niveau serveur

  1. Dans Team Explorer, sélectionnez le serveur Team Foundation Server dans lequel se trouve le groupe.

  2. Dans le menu Équipe, pointez sur Paramètres Team Foundation Server, puis cliquez sur Appartenance au groupe.

  3. Dans la boîte de dialogue Groupes globaux, sélectionnez le groupe duquel vous souhaitez supprimer des utilisateurs, puis cliquez sur Propriétés.

  4. Dans la boîte de dialogue Propriétés du groupe Team Foundation Server, dans l'onglet Membres, sélectionnez les utilisateurs ou les groupes que vous souhaitez supprimer.

  5. Cliquez sur Supprimer.

  6. Cliquez sur OK.

Sécurité

Vous devez être membre du groupe Administrateurs Team Foundation pour supprimer des membres d'un groupe de niveau serveur.

Voir aussi

Tâches

Comment : supprimer un groupe de niveau serveur


Comment : supprimer un groupe de niveau serveur

Comment : supprimer un groupe de niveau serveur

Si un de vos groupes de niveau serveur n'est plus utilisé, vous pouvez le supprimer. Avant de supprimer un groupe, assurez-vous qu'aucun autre utilisateur ou groupe n'est dépendant de ce groupe pour les autorisations requises. Vous pouvez également ajouter ou supprimer des autorisations pour un groupe et ajouter ou supprimer des membres. Vous ne pouvez pas supprimer les groupes de niveau serveur par défaut.

Pour supprimer un groupe de niveau serveur

  1. Dans Team Explorer, sélectionnez le serveur Team Foundation Server dans lequel se trouve le groupe.

  2. Dans le menu Équipe, pointez sur Paramètres Team Foundation Server, puis cliquez sur Appartenance au groupe.

  3. Dans la boîte de dialogue Groupes globaux, sélectionnez le groupe que vous souhaitez supprimer, puis cliquez sur Supprimer.

  4. Dans la boîte de dialogue de confirmation de suppression, cliquez sur Oui, puis sur Fermer.

Sécurité

Vous devez être membre du groupe Administrateurs Team Foundation pour supprimer un groupe de niveau serveur.

Voir aussi

Tâches

Comment : supprimer des utilisateurs d'un groupe de niveau serveur

Concepts

Autorisations de Team Foundation Server

Autres ressources

Affichage et modification des autorisations


Comment : renommer un groupe de niveau serveur

Comment : renommer un groupe de niveau serveur

Vous pouvez choisir de renommer un groupe pour indiquer plus explicitement son rôle. Pour renommer un groupe, vous devez avoir un accès en lecture/écriture au groupe que vous renommez. Vous ne pouvez pas renommer les groupes de niveau serveur par défaut, tels que Team Foundation Administrators.

Pour renommer un groupe de niveau serveur

  1. Dans Team Explorer, sélectionnez le serveur Team Foundation Server dans lequel se trouve le groupe.

  2. Dans le menu Équipe, pointez sur Paramètres Team Foundation Server, puis cliquez sur Appartenance au groupe.

  3. Dans la boîte de dialogue Groupes globaux, sélectionnez le groupe que vous souhaitez renommer, puis cliquez sur Propriétés.

    Remarque Remarque

    Vous ne pouvez pas renommer de groupes par défaut.

  4. Dans la boîte de dialogue Propriétés du groupe Team Foundation Server, dans la zone Nom du groupe, entrez le nouveau nom du groupe de projets d'équipe.

  5. Cliquez sur OK, puis sur Fermer.

Sécurité

Vous devez être membre du groupe Administrateurs Team Foundation pour renommer un groupe de niveau serveur.

Voir aussi

Tâches

Comment : supprimer des utilisateurs d'un groupe de niveau serveur

Autres ressources

Affichage et modification des autorisations


Groupes de projets d'équipe

Groupes de projets d'équipe
DropDown image

Un groupe de projets d'équipe est un groupe associé à un projet d'équipe spécifique. Vous pouvez créer autant de groupes que vous souhaitez pour votre projet et accorder aux membres du groupe des autorisations spécifiques au projet.

Certains groupes de projets d'équipe sont définis dès la création de votre projet. Les groupes par défaut qui sont inclus dans Team Foundation Server sont ajoutés à votre projet à son démarrage. De plus, tous les groupes de niveau serveur par défaut sont ajoutés au projet ; tous les groupes de niveau serveur personnalisés que vous avez créés doivent être ajoutés manuellement. Toutes les modifications de l'appartenance apportées aux groupes de niveau serveur faisant partie du projet d'équipe seront effectives pour tous les projets auxquels ce groupe est assigné. Toutefois, toutes les modifications d'autorisations sont spécifiques au projet d'équipe actuel.

Pour plus d'informations sur la modification des groupes par défaut et des groupes de niveau serveur, consultez Groupes par défaut et Groupes de niveau serveur.

Dans cette section

Comment : créer un groupe de projets d'équipe

Décrit comment créer votre propre groupe de projets d'équipe personnalisé et assigner les autorisations que ses membres doivent posséder.

Comment : ajouter des utilisateurs à un groupe de projets d'équipe

Décrit comment ajouter des utilisateurs ou des groupes à un groupe de projets d'équipe nouveau ou existant.

Comment : supprimer des utilisateurs d'un groupe de projets d'équipe

Décrit comment supprimer un utilisateur ou un groupe des groupes d'équipe.

Comment : supprimer un groupe de projets d'équipe

Décrit comment supprimer un projet d'équipe lorsque vous ne l'utilisez plus.

Comment : renommer un groupe de projets d'équipe

Décrit comment renommer un projet d'équipe existant pour mieux refléter sa fonction.

Rubriques connexes

Concepts sur la sécurité de Team Foundation Server

Décrit les concepts de base décrivant la sécurité de Team Foundation Server.

Sécurité de Team Foundation Server pour les utilisateurs et les groupes

Décrit comment la sécurité de Team Foundation Server s'applique aux utilisateurs et aux groupes.

Autorisations de Team Foundation Server

Décrit les types d'autorisations dans Team Foundation Server, leur fonction et leur gestion.

Voir aussi

Autres ressources

Groupes par défaut
Groupes de niveau serveur
Groupes personnalisés


Comment : créer un groupe de projets d'équipe

Comment : créer un groupe de projets d'équipe

Vous pouvez créer des groupes de sécurité pour votre projet d'équipe afin de mieux répondre aux exigences de sécurité de votre organisation. La création d'un groupe de sécurité est une façon efficace d'accorder un jeu spécifique d'autorisations à un groupe d'utilisateurs sur votre projet d'équipe. Assurez-vous d'octroyer uniquement les autorisations minimales nécessaires pour les besoins du groupe et d'ajouter uniquement les utilisateurs ou les groupes qui doivent appartenir à ce nouveau groupe de projets d'équipe. Si vous devez créer un groupe qui n'est pas spécifique au projet, envisagez plutôt de créer un groupe de niveau serveur. Si vous devez créer un groupe avec des autorisations pour plusieurs projets, consultez Comment : créer un groupe de niveau serveur.

Pour créer un groupe de projets d'équipe

  1. Dans Team Explorer, sélectionnez le projet d'équipe pour lequel vous souhaitez créer un groupe.

  2. Dans le menu Équipe, pointez sur Paramètres du projet d'équipe, puis cliquez sur Appartenance au groupe.

  3. Dans la boîte de dialogue Groupes de projets, cliquez sur Nouveau.

  4. Dans la boîte de dialogue Créer un groupe Team Foundation Server, dans la zone Nom du groupe, entrez le nouveau nom du groupe de projets d'équipe.

  5. Dans la zone Description, saisissez une description du contrôle.

  6. Cliquez sur OK.

Remarque Important

Après avoir créé un groupe de projets d'équipe, vous devez ajouter le nouveau groupe, donner les autorisations appropriées au groupe et ajouter des membres au groupe. Par défaut, un groupe de projets d'équipe est créé sans aucune autorisation accordée.

Sécurité

Vous devez être un membre du groupe Administrators ou du groupe Project Administrators Team Foundation pour créer un groupe de niveau projet.

Voir aussi

Tâches

Comment : créer un groupe de niveau serveur

Concepts

Ajout et suppression d'utilisateurs dans des groupes
Autorisations de Team Foundation Server
Groupes, autorisations et rôles par défaut de Team Foundation Server

Autres ressources

Affichage et modification des autorisations


Comment : ajouter des utilisateurs à un groupe de projets d'équipe

Comment : ajouter des utilisateurs à un groupe de projets d'équipe
Voir aussi

L'ajout des utilisateurs à des groupes existants pour votre projet d'équipe est une façon simple de gérer des utilisateurs et les autorisations dont ils ont besoin. L'ajout d'utilisateurs à un groupe de sécurité est une façon efficace d'accorder un jeu spécifique d'autorisations à un groupe d'utilisateurs sur votre projet d'équipe.

L'ajout d'utilisateurs à un groupe de projets d'équipe donnera les autorisations de ce groupe aux utilisateurs uniquement au niveau de ce projet particulier. Pour apporter des modifications globales à un groupe par défaut, consultez Comment : ajouter des utilisateurs à un groupe par défaut.

Pour ajouter des utilisateurs à un groupe

  1. Dans Team Explorer, sélectionnez le projet d'équipe dans lequel se trouve le groupe.

  2. Dans le menu Équipe, pointez sur Paramètres du projet d'équipe, puis cliquez sur Appartenance au groupe.

  3. Dans la boîte de dialogue Groupes de projets, sélectionnez le groupe de projets d'équipe auquel vous souhaitez ajouter des utilisateurs, puis cliquez sur Propriétés.

  4. Sous l'onglet Membres de la boîte de dialogue Propriétés du groupe Team Foundation Server, sous Ajouter un membre, sélectionnez Utilisateur ou groupe Windows.

  5. Cliquez sur Ajouter.

    Dans la boîte de dialogue Sélectionner les utilisateurs ou les groupes, sous Entrez les noms des objets à sélectionner, tapez l'utilisateur que vous souhaitez ajouter dans le format approprié pour votre réseau.

    Pour ajouter plusieurs utilisateurs à la fois, séparez les entrées par un point-virgule (;).

  6. Cliquez sur OK, puis sur Fermer.

Pour ajouter un groupe Team Foundation Server à un groupe

  1. Dans Team Explorer, sélectionnez le projet d'équipe dans lequel se trouve le groupe ou, pour ajouter un groupe de niveau serveur, sélectionnez le serveur Team Foundation Server dans lequel se trouve le groupe.

  2. Dans le menu Équipe, pointez sur Paramètres du projet d'équipe, puis cliquez sur Appartenance au groupe.

  3. Dans la boîte de dialogue Groupes de projets, sélectionnez le groupe par défaut auquel vous souhaitez ajouter un groupe Team Foundation Server, puis cliquez sur Propriétés.

  4. Sous l'onglet Membres de la boîte de dialogue Propriétés du groupe Team Foundation Server, sous Ajouter un membre, sélectionnez Groupe Team Foundation Server.

  5. Cliquez sur Ajouter.

  6. Dans la boîte de dialogue Sélectionner les groupes, sous Groupes, sélectionnez le groupe que vous souhaitez ajouter, puis cliquez sur OK.

Sécurité

Vous devez être administrateur Team Foundation Server ou administrateur de projet pour ajouter ou supprimer des utilisateurs dans un projet Team Foundation Server. Pour plus d'informations sur les autorisations requises pour ajouter et supprimer des utilisateurs dans des projets, ainsi que des descriptions d'autorisations au niveau du serveur et d'autorisations au niveau du projet, consultez Autorisations de Team Foundation Server.

Voir aussi

Concepts

Concepts sur la sécurité de Team Foundation Server
Sécurité de Team Foundation Server pour les utilisateurs et les groupes
Autorisations de Team Foundation Server
Groupes, autorisations et rôles par défaut de Team Foundation Server

Autres ressources

Gestion des utilisateurs et groupes


Comment : supprimer des utilisateurs d'un groupe de projets d'équipe

Comment : supprimer des utilisateurs d'un groupe de projets d'équipe
Voir aussi

La procédure suivante décrit comment supprimer un utilisateur ou un groupe qui existe actuellement dans un groupe de projets d'équipe.

Pour supprimer des utilisateurs ou des groupes d'un groupe de projets d'équipe

  1. Dans Team Explorer, sélectionnez le projet d'équipe dans lequel se trouve le groupe.

  2. Dans le menu Équipe, pointez sur Paramètres du projet d'équipe, puis cliquez sur Appartenance au groupe.

  3. Dans la boîte de dialogue Groupes de projets, sélectionnez le groupe duquel vous souhaitez supprimer des utilisateurs, puis cliquez sur Propriétés.

  4. Dans la boîte de dialogue Propriétés du groupe Team Foundation Server, dans l'onglet Membres, sélectionnez les utilisateurs ou les groupes que vous souhaitez supprimer.

  5. Cliquez sur Supprimer.

  6. Cliquez sur OK.

Sécurité

Vous devez être administrateur Team Foundation Server ou administrateur de projet pour ajouter ou supprimer des utilisateurs dans un projet Team Foundation Server. Pour plus d'informations sur les autorisations requises pour ajouter et supprimer des utilisateurs dans des projets, ainsi que des descriptions d'autorisations au niveau du serveur et d'autorisations au niveau du projet, consultez Autorisations de Team Foundation Server.

Voir aussi

Concepts

Concepts sur la sécurité de Team Foundation Server
Sécurité de Team Foundation Server pour les utilisateurs et les groupes
Autorisations de Team Foundation Server
Groupes, autorisations et rôles par défaut de Team Foundation Server

Autres ressources

Gestion des utilisateurs et groupes


Comment : supprimer un groupe de projets d'équipe

Comment : supprimer un groupe de projets d'équipe

Si un de vos groupes de sécurité n'est plus utilisé, vous pouvez le supprimer. Avant de supprimer un groupe, assurez-vous qu'aucun autre utilisateur ou groupe n'est dépendant de ce groupe pour les autorisations requises. Vous pouvez également ajouter ou supprimer des autorisations pour un groupe et ajouter ou supprimer des membres.

Pour supprimer un groupe de projets d'équipe

  1. Dans Team Explorer, sélectionnez le projet d'équipe dans lequel se trouve le groupe.

  2. Dans le menu Équipe, pointez sur Paramètres du projet d'équipe, puis cliquez sur Appartenance au groupe.

  3. Dans la boîte de dialogue Groupes de projets, sélectionnez le groupe que vous souhaitez supprimer, puis cliquez sur Supprimer.

  4. Dans la boîte de dialogue de confirmation de la suppression, cliquez sur Oui.

Sécurité

Vous devez être administrateur Team Foundation Server ou administrateur de projet pour ajouter ou supprimer un groupe dans un projet Team Foundation Server. Pour plus d'informations sur les autorisations requises pour supprimer des groupes dans des projets, ainsi que des descriptions d'autorisations au niveau du serveur et d'autorisations au niveau du projet, consultez Autorisations de Team Foundation Server.

Voir aussi

Concepts

Concepts sur la sécurité de Team Foundation Server
Sécurité de Team Foundation Server pour les utilisateurs et les groupes
Autorisations de Team Foundation Server
Groupes, autorisations et rôles par défaut de Team Foundation Server

Autres ressources

Gestion des utilisateurs et groupes


Comment : renommer un groupe de projets d'équipe

Comment : renommer un groupe de projets d'équipe

Vous pouvez choisir de renommer un groupe pour indiquer plus explicitement son rôle. Pour renommer un groupe, vous devez avoir un accès en lecture/écriture au groupe que vous renommez

Pour renommer un groupe de projets d'équipe

  1. Dans Team Explorer, sélectionnez le projet d'équipe dans lequel se trouve le groupe.

  2. Dans le menu Équipe, pointez sur Paramètres du projet d'équipe, puis cliquez sur Appartenance au groupe.

  3. Dans la boîte de dialogue Groupes de projets, sélectionnez le groupe que vous souhaitez renommer, puis cliquez sur Propriétés.

  4. Dans la boîte de dialogue Propriétés du groupe Team Foundation Server, dans la zone Nom du groupe, entrez le nouveau nom du groupe de projets d'équipe.

  5. Cliquez sur OK.

Sécurité

Vous devez être administrateur Team Foundation Server ou administrateur de projet pour ajouter ou supprimer des utilisateurs dans un projet Team Foundation Server. Pour plus d'informations sur les autorisations requises pour ajouter et supprimer des utilisateurs dans des projets, ainsi que des descriptions d'autorisations au niveau du serveur et d'autorisations au niveau du projet, consultez Autorisations de Team Foundation Server.

Voir aussi

Concepts

Concepts sur la sécurité de Team Foundation Server
Sécurité de Team Foundation Server pour les utilisateurs et les groupes
Autorisations de Team Foundation Server
Groupes, autorisations et rôles par défaut de Team Foundation Server

Autres ressources

Gestion des utilisateurs et groupes


Ajout et suppression d'utilisateurs dans des groupes

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Ajout et suppression d'utilisateurs dans des groupes
Voir aussi
Image de liste déroulante

Lors de l'utilisation de projets d'équipe, vous devez ajouter des utilisateurs à vos groupes de sécurité et gérer la liste afin qu'elle fournisse l'accès aux utilisateurs tout en garantissant la sécurité de vos données.

Remarque Remarque

Cela peut prendre quelques minutes pour qu'une nouvelle appartenance à un groupe se propage à un compte d'utilisateur individuel.

Voir aussi

Tâches

Comment : créer un groupe de projets d'équipe
Comment : créer un groupe de niveau serveur
Comment : afficher les groupes par défaut
Comment : ajouter des utilisateurs à un groupe par défaut
Comment : ajouter des utilisateurs à un groupe de niveau serveur
Comment : ajouter des utilisateurs à un groupe de projets d'équipe
Comment : supprimer des utilisateurs d'un groupe par défaut
Comment : supprimer des utilisateurs d'un groupe de niveau serveur
Comment : supprimer des utilisateurs d'un groupe de projets d'équipe


Gestion des utilisateurs

Gestion des utilisateurs
DropDown image

Vous pouvez directement ajouter, modifier et supprimer des utilisateurs dans et à partir d'un serveur Team Foundation Server. Lorsque vous gérez des utilisateurs, vous devez déterminer les rôles des utilisateurs et les autorisations dont les utilisateurs ont besoin dans le cadre de leur rôle. Contrairement aux groupes Team Foundation Server pour lesquels les autorisations sont prédéfinies, vous devez définir expressément des autorisations lors de l'ajout de comptes d'utilisateur individuels. La gestion de groupes est moins complexe que la gestion individuelle de chaque utilisateur. Songez à ajouter des utilisateurs aux groupes Team Foundation Server au lieu de les ajouter individuellement.

Dans cette section

Utilisateurs de Team Foundation Server

Décrit des situations dans lesquelles vous pouvez assigner directement des autorisations à un utilisateur au lieu de l'ajouter à un groupe.

Comment : afficher les utilisateurs existants

Explique les étapes permettant de déterminer les utilisateurs et les groupes qui sont directement associés à un projet ou au serveur Team Foundation.

Comment : ajouter un utilisateur

Explique les étapes permettant d'ajouter directement un compte d'utilisateur dans Team Foundation Server.

Comment : modifier des autorisations pour un utilisateur

Explique les étapes permettant de modifier les autorisations assignées à un compte d'utilisateur.

Comment : désactiver ou réactiver un utilisateur

Explique les étapes permettant de suspendre ou de rétablir un compte d'utilisateur.

Comment : supprimer un utilisateur

Explique les étapes permettant de supprimer complètement un compte d'utilisateur d'un serveur Team Foundation Server ou d'un projet d'équipe.

Rubriques connexes

Gestion des groupes

Gestion de Team Foundation Server dans un domaine Active Directory

Authenticating Users

Voir aussi

Concepts

Groupes de sécurité de Team Foundation

Autres ressources

Configuring Team Foundation Server


Utilisateurs de Team Foundation Server

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Utilisateurs de Team Foundation Server
Voir aussi
Image de liste déroulante

Habituellement, vous souhaitez assigner des utilisateurs individuels aux groupes et assigner des autorisations selon ces groupes. Les autorisations sont gérées plus facilement pour les groupes que pour les utilisateurs individuels comme ils consolident des autorisations dans un jeu optimal de rôles précis.

Toutefois, dans les certaines situations, vous pouvez préférer assigner directement des autorisations à un utilisateur sur le serveur ou sur un projet. Cela peut s'avérer utile lorsque vous devez assigner un utilisateur à une fonction de sauvegarde, comme accorder l'autorisation Publier les résultats des tests pendant l'absence du responsable des tests. Pour des raisons de sécurité, les telles autorisations temporaires doivent être supprimées lorsque le besoin ne s'en fait plus ressentir.

Voir aussi

Tâches

Comment : afficher les utilisateurs existants
Comment : ajouter un utilisateur
Comment : modifier des autorisations pour un utilisateur

Concepts

Groupes, autorisations et rôles par défaut de Team Foundation Server
Autorisations de Team Foundation Server


Comment : afficher les utilisateurs existants

Comment : afficher les utilisateurs existants

Vous pouvez afficher les utilisateurs et les groupes qui sont directement associés à un projet ou au serveur Team Foundation Server.

Pour afficher tous les utilisateurs au niveau du projet

  1. Dans Team Explorer, sélectionnez le projet d'équipe dans lequel se trouve le groupe ou, pour ajouter un groupe de niveau serveur, sélectionnez le serveur Team Foundation Server dans lequel se trouve le groupe.

  2. Dans le menu Équipe, pointez sur Paramètres du projet d'équipe, puis cliquez sur Sécurité.

  3. Dans la boîte de dialogue Sécurité du projet, une liste des utilisateurs et des groupes associés au projet s'affiche dans la fenêtre Utilisateurs et groupes.

  4. Lorsque vous avez terminé de consulter les utilisateurs et les groupes pour le projet, cliquez sur Fermer.

Remarque Remarque

Pour examiner les membres d'un groupe de niveau projet, dans le menu Équipe, pointez sur Paramètres du projet d'équipe, cliquez sur Appartenance au groupe et sur le groupe dont vous souhaitez consulter l'appartenance, puis cliquez sur Propriétés.

Pour afficher tous les utilisateurs au niveau du serveur

  1. Dans Team Explorer, sélectionnez le serveur Team Foundation Server.

  2. Dans le menu Équipe, pointez sur Paramètres Team Foundation Server, puis cliquez sur Sécurité.

  3. Dans la boîte de dialogue Sécurité globale, une liste des utilisateurs et des groupes associés au projet s'affiche dans la fenêtre Utilisateurs et groupes.

  4. Lorsque vous avez terminé de consulter les utilisateurs et les groupes pour le projet, cliquez sur Fermer. Remarque : pour examiner les membres d'un groupe de niveau serveur, dans le menu Équipe, pointez sur Paramètres Team Foundation Server, cliquez sur Appartenance au groupe et sur le groupe dont vous souhaitez consulter l'appartenance, puis cliquez sur Propriétés.

Sécurité

Vous devez être administrateur Team Foundation Server ou administrateur de projet pour ajouter ou supprimer des utilisateurs dans un projet Team Foundation Server. Pour plus d'informations sur les autorisations requises pour ajouter et supprimer des utilisateurs dans des projets, ainsi que des descriptions d'autorisations au niveau du serveur et d'autorisations au niveau du projet, consultez Autorisations de Team Foundation Server.

Voir aussi

Concepts

Utilisateurs de Team Foundation Server


Comment : ajouter un utilisateur

Comment : ajouter un utilisateur

Contrairement à l'ajout d'utilisateurs aux groupes, l'ajout direct d'utilisateurs à un serveur Team Foundation Server n'est pas une tâche administrative courante. Avant d'ajouter l'utilisateur, vous devez déterminer le role de l'utilisateur et les autorisations nécessaires à l'utilisateur pour remplir ce rôle. Si l'utilisateur exécute un rôle courant, vous pouvez envisager d'ajouter l'utilisateur à un groupe, plutôt que de l'ajouter directement. Pour plus d'informations sur les utilisateurs, les groupes et les rôles, consultez Groupes, autorisations et rôles par défaut de Team Foundation Server.

Pour ajouter un utilisateur à un serveur Team Foundation Server

  1. Dans Visual Studio, ouvrez Team Explorer et connectez-vous au serveur Team Foundation Server pour lequel vous ajoutez un utilisateur.

  2. Cliquez avec le bouton droit sur le serveur Team Foundation Server, pointez sur Paramètres Team Foundation Server, puis cliquez sur Sécurité.

  3. Dans la boîte de dialogue Sécurité globale, dans Ajouter des utilisateurs et des groupes, sélectionnez Utilisateur ou groupe Windows et cliquez sur Ajouter.

  4. Vérifiez que le type d'objet et l'emplacement sont corrects.

  5. Dans Entrez les noms des objets à sélectionner, tapez l'alias de l'utilisateur ou du groupe que vous souhaitez ajouter au serveur Team Foundation Server.

  6. Cliquez sur OK.

  7. Dans la boîte de dialogue Sécurité globale, vérifiez que l'utilisateur que vous venez d'ajouter est mis en surbrillance dans Utilisateurs et Groupes. Dans Autorisations, activez ou désactivez les autorisations que vous souhaitez autoriser ou refuser à l'utilisateur ou au groupe que vous ajoutez. Par défaut, aucune autorisation n'est accordée ou refusée à un nouvel utilisateur ou groupe. Si vous n'accordez ni refusez des autorisations, l'utilisateur ou le groupe ne sera pas créé et n'apparaîtra pas si vous cliquez sur Fermer.

  8. Cliquez sur Fermer.

Sécurité

Vous devez être membre du groupe Administrateurs Team Foundation pour pouvoir ajouter directement un utilisateur à un serveur Team Foundation Server. N'ajoutez pas directement d'utilisateur à un serveur Team Foundation Server sauf si l'utilisateur a besoin d'une autorisation hors de la portée de vos groupes Team Foundation Server.

Lorsque vous ajoutez des utilisateurs ou des groupes, autorisez uniquement les autorisations dont l'utilisateur ou le groupe a besoin pour exécuter son rôle avec succès.

Voir aussi

Tâches

Comment : ajouter des utilisateurs à un groupe de niveau serveur

Concepts

Autorisations de Team Foundation Server

Autres ressources

Gestion des utilisateurs
Gestion des groupes


Comment : modifier des autorisations pour un utilisateur

Comment : modifier des autorisations pour un utilisateur

Avec le temps, changer les besoins administratifs et du projet peut nécessiter une modification des autorisations d'utilisateur de Team Foundation Server au niveau du serveur ou au niveau du projet. Avant de modifier les autorisations, vérifiez s'il n'est pas plus efficace de supprimer l'utilisateur individuel et de l'ajouter un groupe qui possède déjà les autorisations appropriées.

Pour modifier les autorisations d'un utilisateur au niveau du serveur

  1. Dans Visual Studio, ouvrez Team Explorer et connectez-vous au serveur Team Foundation Server pour lequel vous modifiez un utilisateur.

  2. Cliquez avec le bouton droit sur le serveur Team Foundation Server, pointez sur Paramètres Team Foundation Server, puis cliquez sur Sécurité. Vous pouvez également sélectionner le serveur Team Foundation Server, puis dans le menu Équipe, pointez sur Paramètres Team Foundation Server, puis cliquez sur Sécurité.

  3. Dans la boîte de dialogue Sécurité globale, dans Utilisateurs et Groupes, sélectionnez l'utilisateur auquel vous souhaitez modifier les autorisations.

  4. Dans Autorisations, activez ou désactivez les autorisations que vous souhaitez autoriser ou refuser à l'utilisateur que vous modifiez. Si vous souhaitez que les autorisations de l'utilisateur soient contrôlées par un groupe au niveau du serveur ou du projet auquel ils appartiennent également, désactivez Autoriser et Refuser.

  5. Cliquez sur Fermer.

Pour modifier les autorisations d'un utilisateur au niveau du projet

  1. Dans Visual Studio, ouvrez Team Explorer et connectez-vous au serveur Team Foundation Server pour lequel vous modifiez un utilisateur.

  2. Cliquez avec le bouton droit sur le projet, pointez sur Paramètres du projet d'équipe, puis cliquez sur Sécurité. Vous pouvez également sélectionner le projet dans le menu Équipe, pointer sur Paramètres du projet d'équipe, puis cliquer sur Sécurité.

  3. Dans la boîte de dialogue Sécurité du projet, dans Utilisateurs et Groupes, sélectionnez l'utilisateur auquel vous souhaitez modifier les autorisations.

  4. Dans Autorisations, activez ou désactivez les autorisations que vous souhaitez autoriser ou refuser à l'utilisateur que vous modifiez. Si vous souhaitez que les autorisations de l'utilisateur soient contrôlées par un groupe au niveau du serveur ou du projet auquel ils appartiennent également, désactivez Autoriser et Refuser.

  5. Cliquez sur Fermer.

Sécurité

Lorsque vous modifiez des utilisateurs ou des groupes, autorisez uniquement les autorisations dont l'utilisateur ou le groupe a besoin pour exécuter son rôle avec succès.

Voir aussi

Tâches

Comment : ajouter un utilisateur

Concepts

Autorisations de Team Foundation Server
Groupes, autorisations et rôles par défaut de Team Foundation Server

Autres ressources

Gestion des utilisateurs
Gestion des groupes


Comment : désactiver ou réactiver un utilisateur

Comment : désactiver ou réactiver un utilisateur

Les changements des besoins de projet ou administratifs peuvent requérir la désactivation ou la réactivation d'un compte d'utilisateur Team Foundation Server. La désactivation et la réactivation du compte peut aider à conserver l'historique et la continuité du rôle d'un utilisateur.

Pour désactiver un utilisateur sur un serveur Team Foundation Server

  1. Dans Visual Studio, ouvrez Team Explorer et connectez-vous au serveur Team Foundation Server pour lequel vous désactivez un utilisateur.

  2. Cliquez avec le bouton droit sur le serveur Team Foundation Server, pointez sur Paramètres Team Foundation Server, puis cliquez sur Sécurité.

  3. Dans Utilisateurs et groupes, sélectionnez l'utilisateur ou le groupe que vous souhaitez désactiver.

  4. Dans Sécurité, désélectionnez toutes les autorisations Autoriser pour l'utilisateur et affectez Refuser à toutes les autorisations.

  5. Cliquez sur Fermer.

Pour réactiver un utilisateur sur un serveur Team Foundation Server

  1. Dans Visual Studio, ouvrez Team Explorer et connectez-vous au serveur Team Foundation Server pour lequel vous réactivez un utilisateur.

  2. Cliquez avec le bouton droit sur le serveur Team Foundation Server, pointez sur Paramètres Team Foundation Server, puis cliquez sur Sécurité.

  3. Dans Utilisateurs et groupes, sélectionnez l'utilisateur ou le groupe que vous souhaitez réactiver.

  4. Dans Sécurité, sélectionnez toutes les autorisations que vous souhaitez autoriser ou refuser à l'utilisateur.

  5. Cliquez sur Fermer.

Sécurité

Vous devez être un membre du groupe Administrateurs Team Foundation pour activer ou désactiver un utilisateur sur le serveur Team Foundation Server. Lorsque vous réactivez des utilisateurs ou des groupes, autorisez uniquement les autorisations dont l'utilisateur ou le groupe a besoin pour exécuter son rôle avec succès.

Voir aussi

Tâches

Comment : ajouter un utilisateur
Comment : modifier des autorisations pour un utilisateur
Comment : ajouter des utilisateurs à un groupe de niveau serveur

Autres ressources

Gestion des utilisateurs
Gestion des groupes


Comment : supprimer un utilisateur

Comment : supprimer un utilisateur

Si vous avez ajouté directement un utilisateur à un serveur ou à un projet, vous pouvez supprimer cet utilisateur une fois que la tâche qu'il devait effectuer est terminée.

Pour réduire la charge d'administration, il est recommandé que vous assigniez aussi souvent que possible des utilisateurs aux groupes. Si vous avez besoin que l'utilisateur effectue des tâches courantes lors du projet, vous devez envisager d'ajouter cet utilisateur à un groupe existant ou à un nouveau groupe. Pour plus d'informations sur la création de nouveaux groupes, consultez Groupes personnalisés.

Si vous souhaitez déplacer dans un groupe un utilisateur directement assigné à un serveur ou à un projet, vous devez tout d'abord le supprimer, puis l'ajouter au groupe désiré.

Pour supprimer un utilisateur d'un serveur Team Foundation Server

  1. Dans Visual Studio, ouvrez Team Explorer et connectez-vous au serveur Team Foundation Server pour lequel vous supprimez un utilisateur.

  2. Cliquez avec le bouton droit sur le serveur Team Foundation Server, pointez sur Paramètres Team Foundation Server, puis cliquez sur Sécurité.

  3. Dans la boîte de dialogue Sécurité globale, sélectionnez l'utilisateur que vous souhaitez supprimer dans la liste Utilisateurs et groupes.

  4. Cliquez sur le bouton Supprimer.

  5. Cliquez sur Fermer dans la boîte de dialogue Sécurité globale.

Pour supprimer un utilisateur d'un projet

  1. Dans Visual Studio, ouvrez Team Explorer et connectez-vous au serveur Team Foundation Server pour lequel vous supprimez un utilisateur.

  2. Cliquez avec le bouton droit sur le projet, pointez sur Paramètres du projet d'équipe, puis cliquez sur Sécurité.

  3. Dans la boîte de dialogue Sécurité du projet, sélectionnez l'utilisateur que vous souhaitez supprimer dans la liste Utilisateurs et groupes.

  4. Cliquez sur le bouton Supprimer.

  5. Cliquez sur Fermer dans la boîte de dialogue Sécurité du projet.

Sécurité

Vous devez être un membre du groupe Administrateurs Team Foundation pour supprimer un utilisateur au niveau du serveur. Vous devez être un membre du groupe Administrators ou du groupe Project Administrators Team Foundation pour supprimer un utilisateur au niveau du projet. Si vous avez assigné directement des autorisations à un utilisateur pour accomplir un rôle temporaire, vous devez le supprimer dès que la tâche est terminée.

Voir aussi

Tâches

Comment : ajouter des utilisateurs à un groupe par défaut
Comment : ajouter des utilisateurs à un groupe de niveau serveur
Comment : ajouter des utilisateurs à un groupe de projets d'équipe

Concepts

Utilisateurs de Team Foundation Server


Gestion des autorisations

Gestion des autorisations
DropDown image

En tant qu'administrateur, vous contrôlez les opérations effectuées par les utilisateurs en spécifiant des autorisations. Pour simplifier cette tâche, Team Foundation fournit des groupes par défaut et des paramètres d'autorisations. Vous pouvez également personnaliser ces paramètres par défaut ou en créer. Les rubriques de cette section vous fournit des détails sur les autorisations.

Dans cette section

Autorisations de Team Foundation Server

Décrit les différentes autorisations qui peuvent être définies pour les utilisateurs et les groupes dans Team Foundation Server.

Groupes, autorisations et rôles par défaut de Team Foundation Server

Décrit les groupes et les autorisations créées par défaut lors de l'installation de Team Foundation Server ou lorsque vous créez un projet d'équipe.

Autorisations d'administrateur de Team Foundation Server

Décrit les autorisations requises pour un administrateur Team Foundation Server et explique où rechercher des informations sur la définition de ces autorisations.

Autorisations des coordinateurs de projet Team Foundation Server

Décrit les autorisations requises pour un coordinateur de projet Team Foundation Server et explique où rechercher des informations sur la définition de ces autorisations.

Autorisations de collaborateur de Team Foundation Server

Décrit les autorisations requises pour un collaborateur de projet Team Foundation Server et explique où rechercher des informations sur la définition de ces autorisations.

Autorisations du contrôle de code source Team Foundation

Décrit les droits et les autorisations de sécurité pour le contrôle de code source, les builds, ainsi que la vérification avec la commande tf.

Affichage et modification des autorisations

Décrit les procédures d'affichage ou de modification des autorisations de niveau serveur ou de niveau projet pour les utilisateurs et les groupes.

Rubriques connexes

Gestion des utilisateurs et groupes

Gestion des services et comptes de service Team Foundation Server

Audit et autorisations de l'utilisateur

Droits et autorisations relatifs à la sécurité du contrôle de code source

Voir aussi

Autres ressources

Sécurisation de Team Foundation Server


Autorisations de Team Foundation Server

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Autorisations de Team Foundation Server
Voir aussi
Image de liste déroulante

L'autorisation d'effectuer les actions de l'utilisateur, telles que l'administration de l'espace de travail et la création de projet, sont déterminées par les autorisations. Lorsque vous créez un projet dans Team Foundation Server, quatre groupes par défaut sont créés pour ce projet indépendamment de votre choix de modèle de processus. Par défaut, chacun de ces groupes possède un jeu d'autorisations défini qui détermine les actions autorisées pour leurs membres.

  • Project Administrator

  • Contributor

  • Reader

  • Build Services.

Pour gérer des groupes par défaut et créer des groupes personnalisés, les administrateurs doivent connaître la signification des autorisations et les implications en matière de sécurité afin de définir explicitement des autorisations.

Remarque Remarque

Cette rubrique ne décrit pas les autorisations pour Windows SharePoint Services ou SQL Reporting Services. Elle aborde uniquement les autorisations définies dans Team Foundation Server.

Paramètres des autorisations

Deux paramètres d'autorisation explicites sont disponibles dans Team Foundation Server pour les autorisations : Deny et Allow. Une autorisation implicite est également disponible et permet de ne pas affecter la valeur Allow ou Deny à l'autorisation. Cette autorisation est un paramètre de refus implicite connu sous le nom d'Unset.

Deny

Deny n'autorise pas l'utilisateur ou le groupe à exécuter les actions indiquées dans la description d'autorisation. Il s'agit du paramètre d'autorisation le plus puissant de Team Foundation Server. Si un utilisateur appartient à un groupe Team Foundation Server qui possède un jeu d'autorisations spécifique avec la valeur Deny, cet utilisateur ne peut pas exécuter cette fonction, même si il ou elle appartient à un autre groupe dans lequel ce jeu d'autorisations possède la valeur Allow.

Allow

Allow autorise l'utilisateur ou le groupe à exécuter les actions indiquées dans la description d'autorisation. Il s'agit du deuxième paramètre d'autorisation le plus puissant de Team Foundation Server et celui le plus fréquemment défini, parce que sans une autorisation explicitement définie à Allow, un utilisateur ou un groupe ne peut exécuter aucune action dans Team Foundation Server.

Unset

Par défaut, la plupart des autorisations dans Team Foundation Server ne possèdent pas la valeur Deny ou Allow. Les autorisations ne sont pas définies, ce qui n'autorise implicitement pas les utilisateurs et les groupes à exécuter les actions comme spécifié dans la description d'autorisation. Toutefois, étant donné que l'autorisation ne possède pas explicitement la valeur Deny ou Allow, l'autorisation pour cette autorisation peut être héritée d'autres groupes auxquels l'utilisateur appartient.

Héritage

Lorsque l'autorisation possède la valeur Unset pour un utilisateur ou un groupe, l'utilisateur ou le groupe peut être affecté par le paramètre d'autorisation explicite défini pour les groupes auxquels il appartient dans la mesure où les autorisations dans Team Foundation Server peuvent être héritées. Si une autorisation est définie explicitement pour un groupe auquel un utilisateur appartient et n'est pas définie dans un autre groupe auquel l'utilisateur appartient, l'utilisateur hérite de la valeur Allow ou Deny affectée à cette autorisation à partir de l'autre groupe.

Remarque Remarque

Les autorisations qui sont définies à l'extérieur de Team Foundation Server, comme dans Windows SharePoint Services, ne sont pas héritées dans Team Foundation Server et ne sont pas abordées dans cette rubrique.

Certains paramètres d'autorisation sont prioritaires sur les autres. Dans Team Foundation Server, l'autorisation Deny est prioritaire sur tous les autres paramètres d'autorisation, y compris sur Allow. Par exemple, un utilisateur peut appartenir à deux groupes dans un projet. Dans un groupe, l'autorisation Publier les résultats des tests possède la valeur Deny et la valeur Allow dans l'autre groupe. Le paramètre Deny est prioritaire et l'utilisateur n'est pas autorisé à publier les résultats des tests.

Autorisations définies dans l'interface utilisateur de Team Foundation Server et dans la ligne de commande

La plupart des autorisations que vous pouvez souhaiter définir pour Team Foundation Server sont contrôlées dans l'interface utilisateur de Team Foundation Server. Vous pouvez définir ces autorisations pour un serveur (autorisations de niveau serveur) ou un projet (autorisations de niveau projet). Vous pouvez également définir des autorisations au niveau de la zone pour afficher et interagir avec les éléments de travail pour un projet. Pour plus d'informations sur les autorisations définies par défaut pour les utilisateurs et les autorisations définies pour MSF for Agile Software Development ou les groupes MSF CMMI Process Improvement, consultez Groupes, autorisations et rôles par défaut de Team Foundation Server. Pour plus d'informations sur le mode de définition des autorisations pour les utilisateurs et les groupes, consultez Gestion des utilisateurs et groupes et Gestion des autorisations. Pour plus d'informations sur la gestion des éléments de travail, consultez Gestion d'éléments de travail Team Foundation.

Autorisations de niveau serveur

Les autorisations de niveau serveur ne sont pas spécifiques à un projet unique, mais sont définies au niveau du serveur. Vous pouvez uniquement définir ces autorisations pour les utilisateurs et les groupes de niveau serveur, tels que le groupe Administrateurs Team Foundation, pour les groupes de niveau projet qui ont été ajoutés au niveau serveur sur votre serveur Team Foundation, et pour les groupes personnalisés que vous avez créés et ajoutés au niveau serveur. Vous pouvez définir ces autorisations dans Team Foundation Server en cliquant avec le bouton droit sur le serveur dans Team Explorer et en cliquant sur Sécurité. Vous pouvez définir ces autorisations en utilisant l'utilitaire en ligne de commande TFSSecurity, à l'exception de celles portant la mention tf:. Vous pouvez définir ces autorisations à l'aide de la commande Autorisations de l'utilitaire en ligne de commande tf pour le contrôle de code source.

Nom de l'autorisation Nom au niveau de la ligne de commande Description

Administrer les modifications réservées

tf: AdminShelvesets

Les utilisateurs qui ont cette autorisation peuvent supprimer des jeux de réservations stockés créés par d'autres utilisateurs.

Administrer l'entrepôt

ADMINISTER_WAREHOUSE

Les utilisateurs qui ont cette autorisation peuvent modifier les paramètres d'entrepôt en utilisant la méthode Web ChangeSetting du service Web WarehouseController.asmx. Par exemple, vous pourriez permettre aux utilisateurs de définir l'intervalle de mise à jour pour calculer les cubes OLAP.

Administrer les espaces de travail

tf: AdminWorkspaces

Les utilisateurs qui ont cette autorisation peuvent créer des espaces de travail pour les autres utilisateurs et supprimer les espaces de travail créés par d'autres utilisateurs.

Créer un espace de travail

tf: CreateWorkspace

Les utilisateurs qui ont cette autorisation peuvent créer un espace de travail de contrôle de code source.

Créer de nouveaux projets

CREATE_PROJECTS

Les utilisateurs qui ont cette autorisation peuvent créer des projets dans Team Foundation Server. Pour créer des projets, ces utilisateurs doivent avoir des autorisations d'administrateur dans Windows SharePoint Server et SQL Reporting Services.

Modifier les informations au niveau du serveur

GENERIC_WRITE

Les utilisateurs qui ont cette autorisation peuvent modifier des groupes et des autorisations de niveau serveur. Ils peuvent créer, supprimer et renommer des groupes d'applications Team Foundation Server de niveau serveur, ajouter ou supprimer un groupe ou un utilisateur Windows pour ce groupe d'applications. Cette autorisation accorde implicitement l'accès en écriture de contrôle de version.

Remarque Remarque

Les groupes de serveurs par défaut, tels que les Administrateurs Team Foundation ne peuvent pas être supprimés.

Modifier les paramètres de la trace

DIAGNOSTIC_TRACE

Les utilisateurs qui ont cette autorisation peuvent modifier les paramètres de la trace pour rassembler des informations de diagnostic plus détaillées à propos des services Web Team Foundation Server. Pour plus d'informations sur le traçage, consultez Paramètres de traçage de Team Foundation Server.

Déclencher des événements

TRIGGER_EVENT

Les utilisateurs qui ont cette autorisation peuvent déclencher des événements d'alertes de projet dans Team Foundation Server. Cette autorisation doit uniquement être assignée aux comptes de service.

Gérer le modèle de processus

MANAGE_TEMPLATE

Les utilisateurs qui ont cette autorisation peuvent télécharger, créer, modifiez et télécharger des modèles de processus dans Team Foundation Server.

Afficher les informations au niveau du serveur

GENERIC_READ

Les utilisateurs qui ont cette autorisation peuvent consulter l'appartenance de groupe de niveau serveur et les autorisations de ces utilisateurs.

Autorisations de niveau projet

Les autorisations de niveau projet sont spécifiques aux utilisateurs et aux groupes d'un projet unique. Vous pouvez définir ces autorisations dans Team Foundation Server en cliquant avec le bouton droit sur le projet dans Team Explorer et en cliquant sur Sécurité. Vous pouvez également définir ces autorisations à l'aide de l'utilitaire en ligne de commande TFSSecurity.

Nom de l'autorisation | Nom au niveau de la ligne de commande | Description
Administrer une build | ADMINISTER_BUILD | Les utilisateurs qui ont cette autorisation peuvent supprimer des builds terminées et arrêter les générations actuelles en cours.
Supprimer ce projet | DELETE | Les utilisateurs qui ont cette autorisation peuvent supprimer des projets de Team Foundation Server.
Modifier la qualité de build | EDIT_BUILD_STATUS | Les utilisateurs qui ont cette autorisation peuvent ajouter des informations relatives à la qualité de build dans l'interface utilisateur de Team Foundation Build. Ces informations sont stockées dans le magasin de la base de données de Team Foundation Build.
Modifier les informations au niveau du projet | GENERIC_WRITE | Les utilisateurs qui ont cette autorisation peuvent modifier des groupes et des autorisations de niveau projet. Ils peuvent également créer, supprimer et renommer des groupes de niveau projet dans le projet, ajouter ou supprimer des utilisateurs Windows et des groupes au projet et ajouter ou supprimer des utilisateurs Team Foundation Server ou des groupes à partir du projet. Ils peuvent également modifier les autorisations de projet pour ces utilisateurs et groupes et ajouter ou supprimer des requêtes de suivi des éléments de travail de niveau de projet.
Publier les résultats des tests | PUBLISH_TEST_RESULTS | Les utilisateurs qui ont cette autorisation peuvent ajouter et supprimer des résultats de tests sur le portail de projet d'équipe et ajouter ou supprimer des séries de tests.
Commencer une build | START_BUILD | Les utilisateurs qui ont cette autorisation peuvent démarrer une génération dans l'interface utilisateur de Team Foundation Build ou à partir de la ligne de commande.
Afficher les informations au niveau du projet | GENERIC_READ | Les utilisateurs qui ont cette autorisation peuvent consulter l'appartenance de groupe de niveau projet et les autorisations de ces utilisateurs de projet.
Écrire dans le magasin opérationnel de la build | UPDATE_BUILD | Cette autorisation doit être accordée au compte sous lequel le service de build s'exécute afin de mettre à jour le magasin de la base de données Team Foundation Build. Cette autorisation ne doit être assignée qu'à des comptes de service et non à des utilisateurs individuels.

Autorisations au niveau de la zone de suivi des éléments de travail

Les autorisations au niveau de la zone sont spécifiques aux utilisateurs et aux groupes d'un projet unique. Vous pouvez définir ces autorisations en cliquant avec le bouton droit sur le projet dans Team Explorer, en cliquant sur Zones et itérations et sur l'onglet Zone, puis en cliquant sur Sécurité. Vous pouvez également définir ces autorisations à l'aide de l'utilitaire en ligne de commande TFSSecurity.

Nom de l'autorisation | Nom au niveau de la ligne de commande | Description
Créer et classer les nœuds enfants | CREATE_CHILDREN | Les utilisateurs qui ont cette autorisation peuvent créer des nœuds de zone et trier de nouveau les nœuds de la zone enfant.
Supprimer ce nœud | DELETE | Les utilisateurs qui ont cette autorisation peuvent supprimer des nœuds de zone. Les nœuds enfants situés sous le nœud parent supprimé sont également supprimés.
Modifier ce nœud | GENERIC_WRITE | Les utilisateurs qui ont cette autorisation peuvent renommer des nœuds de zone.
Modifier les éléments de travail dans ce nœud | WORK_ITEM_WRITE | Les utilisateurs qui ont cette autorisation peuvent modifier des éléments de travail dans ce nœud de zone.
Afficher ce nœud | GENERIC_READ | Les utilisateurs qui ont cette autorisation peuvent consulter les paramètres de sécurité de ce nœud.
Afficher les éléments de travail dans ce nœud | WORK_ITEM_READ | Les utilisateurs qui ont cette autorisation peuvent afficher les éléments de travail dans ce nœud de zone, mais pas les modifier ou les changer.

Autorisations du contrôle de code source

Les autorisations du contrôle de code source sont spécifiques aux fichiers et aux dossiers de code source. Vous pouvez définir ces autorisations en cliquant avec le bouton droit sur le dossier ou le fichier dans l'Explorateur du contrôle de code source, en cliquant sur Autorisations et sur l'onglet Sécurité, puis en sélectionnant l'utilisateur ou le groupe pour lequel vous souhaitez changer les autorisations et modifier les autorisations répertoriées dans Autorisations. Vous pouvez définir ces autorisations à l'aide de l'utilitaire en ligne de commande tf pour le contrôle de code source.

Nom de l'autorisation | Nom au niveau de la ligne de commande | Description
Lire | tf: Read | Les utilisateurs qui ont cette autorisation peuvent lire le contenu d'un fichier ou d'un dossier. Si un utilisateur dispose d'autorisations Read sur un dossier, il peut consulter le contenu du dossier et les propriétés des fichiers qu'il contient, même si l'utilisateur ne dispose pas des autorisations permettant d'ouvrir ces fichiers.
Extraire | tf: PendChange | Les utilisateurs qui ont cette autorisation peuvent extraire et apporter une modification en attente aux éléments d'un dossier. Les exemples de modifications en attente incluent l'ajout, l'attribution d'un nouveau nom, la suppression, la restauration, la création de branches et la fusion d'un fichier.
Archiver | tf: Checkin | Les utilisateurs qui ont cette autorisation peuvent archiver des éléments et modifier tout commentaire sur un ensemble de modifications validées. Les modifications en attente sont validées lors de l'archivage.
Étiqueter | tf: Label | Les utilisateurs qui ont cette autorisation peuvent étiqueter des éléments.
Verrouiller | tf: Lock | Les utilisateurs qui ont cette autorisation peuvent verrouiller et déverrouiller des dossiers ou des fichiers.
Modifier les modifications des autres utilisateurs | tf: ReviseOther | Les utilisateurs qui ont cette autorisation peuvent modifier les commentaires des fichiers archivés, même si un autre utilisateur a archivé le fichier.
Déverrouiller les modifications des autres utilisateurs | tf: UnlockOther | Les utilisateurs qui ont cette autorisation peuvent déverrouiller les fichiers verrouillés par d'autres utilisateurs.
Annuler les modifications des autres utilisateurs | tf: UndoOther | Les utilisateurs qui ont cette autorisation peuvent annuler une modification en attente faite par un autre utilisateur.
Administrer les étiquettes | tf: LabelOther | Les utilisateurs qui ont cette autorisation peuvent modifier ou supprimer des étiquettes créées par un autre utilisateur.
Manipuler les paramètres de sécurité | tf: AdminProjRights | Les utilisateurs qui ont cette autorisation peuvent définir des autorisations sur ces fichiers et dossiers.
Archiver les modifications des autres utilisateurs | tf: CheckinOther | Les utilisateurs qui ont cette autorisation peuvent archiver les modifications qui ont été apportées par d'autres utilisateurs. Les modifications en attente seront validées lors de l'archivage.

Voir aussi

Concepts

Groupes, autorisations et rôles par défaut de Team Foundation Server
Gestion d'éléments de travail Team Foundation

Autres ressources

Commandes de l'utilitaire en ligne de commande TFSSecurity
Référence de la ligne de commande du contrôle de code source Team Foundation
Gestion des utilisateurs et groupes
Gestion des autorisations


Groupes, autorisations et rôles par défaut de Team Foundation Server

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Groupes, autorisations et rôles par défaut de Team Foundation Server
Voir aussi
Image de liste déroulante

Lorsque vous créez un projet dans Team Foundation Server, les nouveaux groupes de niveau projet sont créés pour ce projet, par défaut, et se voient assigner des autorisations pour accéder aux ressources appropriées à ce groupe. Pour personnaliser des projets afin qu'ils soient mieux adaptés aux besoins de votre entreprise, vous devez connaître les autorisations qui doivent être assignées à tels utilisateurs et groupes par défaut et les autorisations que vous pouvez ajouter à tous les utilisateurs ou groupes que vous pouvez ajouter. En outre, si vous souhaitez faire correspondre vos utilisateurs aux rôles décrits pour MSF for Agile Software Development ou MSF for CMMI Process Improvement, vous devez assimiler comment aligner ces rôles aux groupes par défaut déjà assignés au projet. Vous pouvez également créer des groupes qui s'associent directement à chacun de ces rôles et assigner à ces groupes les autorisations appropriées au rôle.

Groupes et autorisations par défaut

Chaque fois que vous créez un projet dans Team Foundation Server, les groupes sont créés au niveau du projet. Par défaut, chacun de ces groupes dispose de certaines autorisations qui leur sont assignées. Vous pouvez ajouter des autorisations à ces groupes par défaut en plus de tous les groupes ou utilisateurs que vous souhaitez ajouter au niveau du serveur ou du projet.

Groupes et autorisations de niveau serveur

Par défaut, les groupes suivants existent au niveau du serveur lorsque vous installez Team Foundation Server :

  • SERVER\Team Foundation Administrators Les membres de ce groupe peuvent exécuter toutes les opérations pour Team Foundation Server. Ce groupe doit être limité au plus petit nombre d'utilisateurs ayant besoin du contrôle administratif total sur Team Foundation Server.

  • SERVER\Team Foundation Valid Users Les membres de ce groupe ont accès à Team Foundation Server. Ce groupe contient automatiquement tous les utilisateurs et les groupes qui ont été ajoutés n'importe où dans Team Foundation Server. Vous ne pouvez pas modifier l'appartenance de ce groupe via l'interface utilisateur.

  • SERVER\Service Accounts Les membres de ce groupe disposent d'autorisations de niveau service de Team Foundation Server. Par défaut, ce groupe contient le compte de service fourni pendant l'installation. Si vous souhaitez ajouter de nouveaux comptes à ce groupe, vous devez les ajouter à l'aide de l'outil de ligne de commande TFSSecurity. Ce groupe doit contenir uniquement des comptes de service et pas des comptes d'utilisateur ou des groupes (à moins que le groupe ne contienne que des comptes de service).

Par défaut, les autorisations suivantes sont définies pour ces groupes. Pour une description complète de chaque autorisation figurant dans la liste suivante, consultez Autorisations de Team Foundation Server.

Nom de l'autorisation | Par défaut, attribuez à : | Envisagez d'ajouter à :
Accéder au système de contrôle de code source | Tous les utilisateurs d'un projet (par défaut, non modifiable) | Tous les utilisateurs ou groupes ajoutés manuellement.
Administrer les modifications réservées | Team Foundation Administrators, Service Accounts | Utilisateurs ou groupes ajoutés manuellement et qui devront ou doivent supprimer des jeux de réservations créés par d'autres utilisateurs.
Administrer l'entrepôt | Team Foundation Administrators, Service Accounts | Utilisateurs ou groupes ajoutés manuellement qui devront ou doivent modifier les paramètres d'entrepôt via la méthode Web ChangeSetting du service Web WarehouseController.asmx.
Administrer les espaces de travail | Team Foundation Administrators, Service Accounts | Utilisateurs ou groupes ajoutés manuellement qui devront ou doivent créer des espaces de travail pour les autres utilisateurs et supprimer des espaces de travail créés par d'autres utilisateurs.
Créer un espace de travail | Team Foundation Administrators, Team Foundation Valid Users | Aucun.
Créer de nouveaux projets | Team Foundation Administrators | Administrateurs de projet qui créeront des projets régulièrement. Afin de parvenir à créer des projets, les utilisateurs doivent disposer d'autorisations d'administrateur dans Windows SharePoint Server et d'autorisations de gestionnaire de contenu dans SQL Reporting Services.
Modifier les informations au niveau du serveur | Team Foundation Administrators | Aucun.
Modifier les paramètres de la trace | Team Foundation Administrators | Autres administrateurs du serveur qui devront ou doivent modifier les paramètres de la trace pour rassembler des informations de diagnostic plus détaillées sur les services Web de Team Foundation Server.
Déclencher des événements | Team Foundation Administrators, Service Accounts | Aucun. L'ajout de cette autorisation à d'autres utilisateurs peut provoquer des attaques par déni de service.
Gérer le modèle de processus | Team Foundation Administrators | Administrateurs de projet et tous les utilisateurs ou groupes ajoutés manuellement, par exemple, des spécialistes de processus, qui devront ou doivent créer, modifier, télécharger et transférer des modèles de processus vers Team Foundation Server.
Afficher les informations au niveau du serveur | Team Foundation Administrators, Team Foundation Valid Users | Aucun.

Groupes et autorisations au niveau du projet

Par défaut, les groupes suivants existent au niveau du projet :

  • Project Name\Project Administrators Les membres de ce groupe peuvent administrer tous les aspects du projet d'équipe, bien qu'ils ne puissent pas créer de projets.

  • Project Name\Contributors Les membres de ce groupe peuvent collaborer au projet de plusieurs façons, par exemple, en ajoutant, en modifiant ou en supprimant du code, en créant et en modifiant des éléments de travail, etc.

  • Project Name\Readers Les membres de ce groupe peuvent consulter le projet, mais pas le modifier.

  • Project Name\Build Services Les membres de ce groupe disposent d'autorisations du service de build pour le projet. Ce groupe doit contenir uniquement des comptes de service de build et pas des comptes d'utilisateur ou des groupes (à moins que le groupe ne contienne que des comptes de service de build).

Outre ces comptes de niveau projet, deux des comptes de niveau serveur apparaissent également par défaut dans chaque projet Team Foundation Server :

  • SERVER\Team Foundation Administrators

  • SERVER\Team Foundation Valid Users

Par défaut, les autorisations suivantes sont définies pour ces groupes. Pour une description complète de chaque autorisation figurant dans la liste suivante, consultez Autorisations de Team Foundation Server.

Nom de l'autorisation | Par défaut, attribuez à : | Envisagez d'ajouter à :
Administrer une build | Project Administrators, Team Foundation Administrators | Utilisateurs ou groupes ajoutés manuellement qui devront ou doivent supprimer des builds terminées et terminer les builds actuelles en cours.
Supprimer ce projet | Project Administrators, Team Foundation Administrators | Aucun.
Modifier la qualité de build | Project Administrators, Team Foundation Administrators | Utilisateurs ou groupes ajoutés manuellement qui devront ou doivent ajouter des informations sur la qualité de build via l'interface utilisateur de Team Foundation Build.
Modifier les informations au niveau du projet | Project Administrators, Team Foundation Administrators | Aucun.
Publier les résultats des tests | Project Administrators, Team Foundation Administrators | Utilisateurs ou groupes ajoutés manuellement qui devront ou doivent ajouter et supprimer des résultats de tests sur le portail du projet d'équipe et ajouter ou supprimer des séries de tests.
Commencer une build | Project Administrators, Contributors, Team Foundation Administrators | Utilisateurs ou groupes ajoutés manuellement qui devront ou doivent commencer une build via l'interface utilisateur de Team Foundation Build ou à partir de la ligne de commande.
Afficher les informations au niveau du projet | Project Administrators, Contributors, Readers, Team Foundation Administrators, Team Foundation Valid Users | Tous les utilisateurs ou groupes ajoutés manuellement.
Écrire dans le magasin opérationnel de la build | Build Services, Team Foundation Administrators | Cette autorisation ne doit être assignée qu'à des comptes de service et non à des utilisateurs individuels.

Groupes et autorisations au niveau de la zone

Par défaut, les groupes suivants existent au niveau de la zone :

  • Project Name\Project Administrators

  • Project Name\Contributors

  • Project Name\Readers

  • Project Name\Build Services

  • SERVER\Team Foundation Administrators

  • SERVER\Team Foundation Valid Users

Par défaut, les autorisations suivantes sont définies pour ces groupes. Pour une description complète de chaque autorisation figurant dans la liste suivante, consultez Autorisations de Team Foundation Server.

Nom de l'autorisation | Par défaut, attribuez à : | Envisagez d'ajouter à :
Créer et classer les nœuds enfants | Project Administrators, Team Foundation Administrators | Aucun.
Supprimer ce nœud | Project Administrators, Team Foundation Administrators | Utilisateurs ou groupes ajoutés manuellement qui devront ou doivent supprimer des nœuds de zone.
Modifier ce nœud | Project Administrators, Team Foundation Administrators | Utilisateurs ou groupes ajoutés manuellement qui devront ou doivent renommer des nœuds de zone.
Modifier les éléments de travail dans ce nœud | Project Administrators, Contributors, Build Services, Team Foundation Administrators | Utilisateurs ou groupes ajoutés manuellement qui devront ou doivent modifier des éléments de travail dans ce nœud de zone.
Afficher ce nœud | Project Administrators, Contributors, Readers, Build Services, Team Foundation Administrators, Team Foundation Valid Users | Aucun.
Afficher les éléments de travail dans ce nœud | Project Administrators, Contributors, Readers, Build Services, Team Foundation Administrators | Utilisateurs ou groupes ajoutés manuellement qui devront ou doivent afficher, mais pas modifier ou changer les éléments de travail de ce nœud de zone.

Groupes et autorisations de contrôle de code source

Par défaut, les groupes suivants existent au niveau du contrôle de code source :

  • Project Name\Project Administrators

  • Project Name\Contributors

  • Project Name\Readers

  • Project Name\Build Services

  • SERVER\Team Foundation Administrators

  • SERVER\Service Accounts

Par défaut, les autorisations suivantes sont définies pour ces groupes. Pour une description complète de chaque autorisation figurant dans la liste suivante, consultez Autorisations de Team Foundation Server.

Nom de l'autorisation | Par défaut, attribuez à : | Envisagez d'ajouter à :
Lire | Project Administrators, Contributors, Readers, Build Services, Team Foundation Administrators, Service Accounts | Majorité des utilisateurs ou groupes ajoutés manuellement; ceux qui devront ou doivent lire le contenu d'un fichier ou d'un dossier.
Extraire | Project Administrators, Contributors, Build Services, Team Foundation Administrators, Service Accounts | Utilisateurs ou groupes ajoutés manuellement qui devront ou doivent extraire ou apporter une modification en attente aux éléments d'un dossier.
Archiver | Project Administrators, Contributors, Build Services, Team Foundation Administrators, Service Accounts | Utilisateurs ou groupes ajoutés manuellement qui devront ou doivent archiver des éléments ou modifier tout commentaire sur un ensemble de modifications validées.
Étiqueter | Project Administrators, Contributors, Build Services, Team Foundation Administrators, Service Accounts | Utilisateurs ou groupes ajoutés manuellement qui devront ou doivent étiqueter des éléments.
Verrouiller | Project Administrators, Contributors, Build Services, Team Foundation Administrators, Service Accounts | Utilisateurs ou groupes ajoutés manuellement qui devront ou doivent verrouiller ou déverrouiller des dossiers ou des fichiers.
Réviser les modifications des autres utilisateurs | Project Administrators, Team Foundation Administrators, Service Accounts | Utilisateurs ou groupes ajoutés manuellement responsables de la supervision ou de la surveillance du projet et qui devront ou doivent modifier les commentaires sur des fichiers archivés, même si un autre utilisateur a archivé ces fichiers.
Déverrouiller les modifications des autres utilisateurs | Project Administrators, Team Foundation Administrators, Service Accounts | Utilisateurs ou groupes ajoutés manuellement qui devront ou doivent déverrouiller des fichiers verrouillés par d'autres utilisateurs.
Annuler les modifications des autres utilisateurs | Project Administrators, Team Foundation Administrators, Service Accounts | Utilisateurs ou groupes ajoutés manuellement qui devront ou doivent annuler une modification en attente effectuée par un autre utilisateur.
Administrer les étiquettes | Project Administrators, Team Foundation Administrators, Service Accounts | Utilisateurs ou groupes ajoutés manuellement qui devront ou doivent modifier ou supprimer des étiquettes créées par un autre utilisateur.
Manipuler les paramètres de sécurité | Project Administrators, Team Foundation Administrators, Service Accounts | Aucun.
Archiver les modifications des autres utilisateurs | Project Administrators, Team Foundation Administrators, Service Accounts | Aucun.

Autorisations associées aux rôles MSF for Agile Software Development

Si vous avez créé votre projet d'équipe à l'aide du modèle de processus MSF for Agile Software Development, vous pouvez assigner vos utilisateurs aux groupes qui correspondent aux rôles de MSF for Agile Software Development. Vous pouvez le faire de deux façons. Vous pouvez assigner vos utilisateurs au groupe par défaut qui offre le plus d'autorisations requises pour chaque rôle. Vous pouvez également créer des groupes pour chaque rôle, assigner les autorisations appropriées à ce groupe, puis ajouter les utilisateurs qui appartiennent à ce rôle.

Assignation d'utilisateurs à des groupes par défaut en fonction de leurs rôles MSF for Agile Software Development

Vous pouvez assigner des utilisateurs aux groupes par défaut selon leurs rôles MSF for Agile Software Development. Bien que ces groupes ne correspondent pas directement à chaque rôle, il est relativement simple d'ajouter des utilisateurs à ces groupes et il n'est pas nécessaire de créer des groupes et d'ajouter des autorisations pour ces groupes au niveau du serveur, du projet, de la zone et du contrôle de code source. L'inconvénient de cette approche est que vous perdez un peu de la granularité fine de l'autorisation et du contrôle que vous pouvez avoir en ajoutant des groupes en fonction de chaque rôle spécifique.

Le tableau suivant fournit des cas dans lesquels le groupe par défaut est le plus conforme à chacun des rôles MSF for Agile Software Development. Pour plus d'informations sur MSF for Agile Software Development et ses rôles, consultez le site Web de MSF for Agile Software Development à l'adresse http://go.microsoft.com/fwlink/?linkid=55200&clcid=0x409

Rôle Agile | Ajouter au groupe par défaut
Architecte | Contributor
Analyste métier | Contributor
Développeur | Contributor
Chef de projet | Project Administrator
Responsable de la livraison | Project Administrator
Testeur | Contributor

Création de groupes qui correspondent aux rôles MSF for Agile Software Development et assignation d'autorisations

Vous pouvez créer des groupes personnalisés en fonction de chaque rôle MSF for Agile Software Development et assigner des utilisateurs à ces groupes. Un des avantages de la création de ces groupes au lieu d'utiliser les groupes par défaut est que vous avez plus de contrôle sur les rôles et les autorisations. L'inconvénient de cette approche est que vous devez créer des groupes et ajouter des autorisations pour les groupes au niveau du serveur, du projet, de la zone et du contrôle de code source.

Remarque Remarque

Si vous créez des groupes personnalisés correspondant aux rôles, vous devez définir des autorisations appropriées pour chaque nouveau groupe dans Windows SharePoint Services, Reporting Services et soit dans Active Directory, soit dans Utilisateurs et groupes locaux sur les ordinateurs Team Foundation Server. Cela s'ajoute à la définition des autorisations Team Foundation Server.

Le tableau suivant fournit des exemples dans lesquels les autorisations sont appropriées à un rôle MSF for Agile Software Development. Pour une description complète de chaque autorisation, consultez Autorisations de Team Foundation Server.

Rôle Agile | Serveur | Projet | Zone | Contrôle de code source
Architecte |  | Commencer une build Afficher les informations au niveau du projet | Modifier les éléments de travail dans ce nœud Afficher ce nœud Afficher les éléments de travail dans ce nœud | Lire Extraire Archiver Étiqueter Verrouiller
Analyste métier |  | Afficher les informations au niveau du projet | Afficher ce nœud Afficher les éléments de travail dans ce nœud | Aucun
Développeur |  | Afficher les informations au niveau du projet Commencer une build | Modifier les éléments de travail dans ce nœud Afficher ce nœud Afficher les éléments de travail dans ce nœud | Lire Extraire Archiver Étiqueter Verrouiller
Chef de projet | Créer de nouveaux projets Gérer le modèle de processus | Afficher les informations au niveau du projet Administrer une build Supprimer ce projet Modifier les informations au niveau du projet Commencer une build | Créer et classer les nœuds enfants Supprimer ce nœud Modifier ce nœud Modifier les éléments de travail dans ce nœud Afficher ce nœud Afficher les éléments de travail dans ce nœud | Lire Extraire Archiver Étiqueter Verrouiller Réviser les modifications des autres utilisateurs Déverrouiller les modifications des autres utilisateurs Annuler les modifications des autres utilisateurs Administrer les étiquettes Manipuler les paramètres de sécurité Archiver les modifications des autres utilisateurs
Responsable de la livraison |  | Afficher les informations au niveau du projet Modifier les informations au niveau du projet | Modifier les éléments de travail dans ce nœud Afficher ce nœud Afficher les éléments de travail dans ce nœud | Aucun
Testeur |  | Afficher les informations au niveau du projet Modifier la qualité de build Publier les résultats des tests | Modifier les éléments de travail dans ce nœud Afficher ce nœud Afficher les éléments de travail dans ce nœud | Lire Extraire Archiver Étiqueter Verrouiller

Autorisations associées aux rôles MSF for CMMI Process Improvement

Si vous avez créé votre projet d'équipe à l'aide du processus MSF for CMMI Process Improvement, vous pouvez assigner vos utilisateurs aux groupes qui correspondent aux rôles de MSF for CMMI Process Improvement. Vous pouvez le faire de deux façons. Vous pouvez assigner vos utilisateurs au groupe par défaut qui offre le plus d'autorisations requises pour chaque rôle. Vous pouvez également créer des groupes pour chaque rôle, assigner les autorisations appropriées à ce groupe, puis ajouter les utilisateurs qui appartiennent à ce rôle.

Pour plus d'informations sur MSF for CMMI Process Improvement et ses rôles, consultez le site Web de MSF for CMMI Process Improvement http://go.microsoft.com/fwlink/?linkid=55203&clcid=0x409

Assignation d'utilisateurs à des groupes par défaut en fonction de leurs rôles MSF for CMMI Process Improvement

Vous pouvez assigner des utilisateurs aux groupes par défaut selon leur rôle MSF for CMMI Process Improvement. Bien que ces groupes ne correspondent pas directement à chaque rôle, il est relativement simple d'ajouter des utilisateurs à ces groupes et il n'est pas nécessaire de créer des groupes et d'ajouter des autorisations pour ces groupes au niveau du serveur, du projet, de la zone et du contrôle de code source. L'inconvénient de cette approche est que vous perdez un peu de la granularité fine de l'autorisation et du contrôle que vous pouvez avoir en ajoutant des groupes en fonction de chaque rôle spécifique.

Le tableau suivant fournit des cas dans lesquels le groupe par défaut est le plus conforme à chacun des rôles MSF for CMMI Process Improvement.

Rôle CMMI | Ajouter au groupe par défaut
Auditeur | Contributor
Ingénieur de conception | Project Administrator
Analyste métier | Contributor
Développeur | Contributor
Responsable du développement | Project Administrator
Architecte d'infrastructure | Contributor
Responsable de la gestion intégrée | Contributor
Développeur sénior | Project Administrator
Chef de produit | Contributor
Chef de projet | Project Administrator
Responsable de la livraison | Project Administrator
Architecte de solution | Contributor
Commanditaire | Reader
Expert | Reader
Gestionnaire de tests | Project Administrator
Testeur | Contributor
Architecte de la documentation utilisateur | Contributor
Spécialiste de l'information | Contributor

Création de groupes qui correspondent aux rôles MSF for CMMI Process Improvement et assignation d'autorisations

Vous pouvez créer des groupes personnalisés en fonction de chaque rôle MSF for CMMI Process Improvement et assigner des utilisateurs à ces groupes. Ces groupes offrent beaucoup plus de granularité et de contrôle que les groupes par défaut. L'inconvénient de cette approche est que vous devez créer des groupes et ajouter des autorisations pour les groupes au niveau du serveur, du projet, de la zone et du contrôle de code source. Étant donné que MSF for CMMI Process Improvement propose de nombreux rôles, vous devez étudier avec soin le niveau de vérification, de granularité et de contrôle dont vous avez besoin pour votre projet avant d'investir du temps dans la création de groupes pour chaque rôle.

Remarque Remarque

Si vous créez des groupes personnalisés correspondant aux rôles, vous devez définir des autorisations appropriées pour chaque nouveau groupe dans Windows SharePoint Services, SQL Reporting Services et soit dans Active Directory, soit dans Utilisateurs et groupes locaux sur les ordinateurs Team Foundation Server. Cela s'ajoute à la définition des autorisations Team Foundation Server.

Le tableau suivant fournit des exemples dans lesquels les autorisations sont appropriées à un rôle MSF for CMMI Process Improvement. Pour une description complète de chaque autorisation, consultez Autorisations de Team Foundation Server.

Rôle CMMI | Serveur | Projet | Zone | Contrôle de code source
Auditeur |  | Afficher les informations au niveau du projet | Afficher ce nœud Afficher les éléments de travail dans ce nœud Modifier les éléments de travail dans ce nœud | Aucun
Ingénieur de conception |  | Afficher les informations au niveau du projet | Afficher ce nœud Afficher les éléments de travail dans ce nœud Modifier les éléments de travail dans ce nœud | Lire Extraire Archiver Étiqueter Verrouiller
Analyste métier |  | Afficher les informations au niveau du projet | Afficher ce nœud Afficher les éléments de travail dans ce nœud Modifier les éléments de travail dans ce nœud | Aucun
Développeur |  | Afficher les informations au niveau du projet | Afficher ce nœud Afficher les éléments de travail dans ce nœud Modifier les éléments de travail dans ce nœud | Lire Extraire Archiver Étiqueter Verrouiller
Responsable du développement |  | Afficher les informations au niveau du projet | Afficher ce nœud Afficher les éléments de travail dans ce nœud Modifier les éléments de travail dans ce nœud | Lire Extraire Archiver Étiqueter Verrouiller
Architecte d'infrastructure |  | Afficher les informations au niveau du projet | Afficher ce nœud Afficher les éléments de travail dans ce nœud Modifier les éléments de travail dans ce nœud | Lire Extraire Archiver Étiqueter Verrouiller
Responsable de la gestion intégrée |  | Afficher les informations au niveau du projet | Afficher ce nœud Afficher les éléments de travail dans ce nœud Modifier les éléments de travail dans ce nœud | Aucun.
Développeur sénior |  | Afficher les informations au niveau du projet | Afficher ce nœud Afficher les éléments de travail dans ce nœud Modifier les éléments de travail dans ce nœud | Lire Extraire Archiver Étiqueter Verrouiller
Chef de produit |  | Afficher les informations au niveau du projet | Afficher ce nœud Afficher les éléments de travail dans ce nœud Modifier les éléments de travail dans ce nœud | Lire Extraire Archiver Étiqueter Verrouiller
Chef de projet | Créer de nouveaux projets Gérer le modèle de processus | Afficher les informations au niveau du projet | Afficher ce nœud Afficher les éléments de travail dans ce nœud Modifier les éléments de travail dans ce nœud | Lire Extraire Archiver Étiqueter Verrouiller
Responsable de la livraison |  | Afficher les informations au niveau du projet | Afficher ce nœud Afficher les éléments de travail dans ce nœud Modifier les éléments de travail dans ce nœud | Lire
Architecte de solution |  | Afficher les informations au niveau du projet Commencer une build | Afficher ce nœud Afficher les éléments de travail dans ce nœud Modifier les éléments de travail dans ce nœud | Lire Extraire Archiver Étiqueter Verrouiller
Commanditaire |  | Afficher les informations au niveau du projet | Afficher ce nœud Afficher les éléments de travail dans ce nœud | Aucun
Expert |  | Afficher les informations au niveau du projet | Afficher ce nœud Afficher les éléments de travail dans ce nœud | Aucun
Gestionnaire de tests |  | Afficher les informations au niveau du projet | Afficher ce nœud Afficher les éléments de travail dans ce nœud Modifier les éléments de travail dans ce nœud | Lire Extraire Archiver Étiqueter Verrouiller
Testeur |  | Afficher les informations au niveau du projet | Afficher ce nœud Afficher les éléments de travail dans ce nœud Modifier les éléments de travail dans ce nœud | Lire Extraire Archiver Étiqueter Verrouiller
Architecte de la documentation utilisateur |  | Afficher les informations au niveau du projet | Afficher ce nœud Afficher les éléments de travail dans ce nœud Modifier les éléments de travail dans ce nœud | Lire
Spécialiste de l'information |  | Afficher les informations au niveau du projet | Afficher ce nœud Afficher les éléments de travail dans ce nœud Modifier les éléments de travail dans ce nœud | Lire Extraire Archiver Étiqueter Verrouiller

Voir aussi

Tâches

Comment : créer un groupe de niveau serveur
Comment : créer un groupe de projets d'équipe
Comment : modifier des autorisations pour un groupe ou un utilisateur
Comment : afficher les autorisations

Concepts

Ajout et suppression d'utilisateurs dans des groupes
Autorisations de Team Foundation Server
Autorisations de collaborateur de Team Foundation Server

Autres ressources

Gestion des groupes
Gestion des utilisateurs
Autorisations d'administrateur de Team Foundation Server
Autorisations des coordinateurs de projet Team Foundation Server
Affichage et modification des autorisations
Commandes de l'utilitaire en ligne de commande TFSSecurity


Autorisations d'administrateur de Team Foundation Server

Autorisations d'administrateur de Team Foundation Server
DropDown image

Pour permettre aux utilisateurs d'effectuer des actions dans différents rôles Team Foundation, ils doivent posséder les autorisations appropriées pour Team Foundation Server, Reporting Services et Windows SharePoint Services. Dans cette rubrique, vous apprendrez quelles autorisations sont requises pour un Administrateur Team Foundation Server et où rechercher les informations relatives à la définition appropriée de ces autorisations.

Les membres du groupe Administrateurs Team Foundation Server ont l'ensemble de privilèges le plus élevé de tous les utilisateurs de Team Foundation Server. Les administrateurs gèrent un serveur Team Foundation Server ainsi que les autorisations et la sécurité pour les autres rôles. Pour la plupart des organisations utilisant Team Foundation Server, cette même personne est chargée de créer des projets, de les gérer et de personnaliser le guide de processus. Un administrateur Team Foundation Server doit être un membre des groupes suivants :

  • Administrateurs ou administrateurs de domaine sur les serveurs des couches Application et Données.

  • Administrateurs Team Foundation Server.

  • Administrateurs Windows SharePoint Services.

  • Gestionnaire de contenu SQL Server Reporting Services.

  • Administrateur système SQL Server Reporting Services.

  • Les rubriques suivantes décrivent comment définir ces autorisations.

Dans cette section

Comment : définir des autorisations d'administrateur pour Team Foundation Server

Explique comment définir des autorisations d'administrateur Team Foundation Server.

Comment : définir les autorisations d'administrateur pour Windows SharePoint Services

Explique comment définir des autorisations d'administrateur Windows SharePoint Services.

Comment : définir les autorisations d'administrateur pour Reporting Services

Décrit comment définir des autorisations d'administrateur système ou de gestionnaire de contenu SQL Server Reporting Services.

Voir aussi

Concepts

Autorisations de collaborateur de Team Foundation Server

Autres ressources

Gestion des autorisations
Autorisations des coordinateurs de projet Team Foundation Server


Comment : définir des autorisations d'administrateur pour Team Foundation Server

Comment : définir des autorisations d'administrateur pour Team Foundation Server
Voir aussi

Lors de la configuration d'un utilisateur avec le rôle Administrateur des serveurs Team Foundation, vous devez définir des autorisations dans les groupes Team Foundation Server, les groupes Windows SharePoint Services et les groupes Reporting Services. Vous devez également définir des autorisations sur les groupes d'ordinateurs des couches Application et Données Team Foundation, le cas échéant. Dans cette rubrique, vous apprendrez comment définir des autorisations sur les serveurs Team Foundation pour un administrateur Team Foundation Server.

Remarque Remarque

Vous devez être administrateur Team Foundation Server pour effectuer cette procédure.

Pour ajouter un membre au groupe Administrateurs Team Foundation

  1. Dans Visual Studio, ouvrez Team Foundationet connectez-vous au serveur Team Foundation Server pour lequel vous définissez des autorisations.

  2. Cliquez avec le bouton droit sur le serveur Team Foundation Server, pointez sur Paramètres Team Foundation Server, puis cliquez sur Appartenance au groupe.

  3. Sélectionnez Serveur\Administrateurs Team Foundation, puis sur Propriétés.

  4. Dans Ajouter des utilisateurs et des groupes, sélectionnez Utilisateur ou groupe Windows, puis cliquez sur Ajouter.

  5. Ajoutez le nom de connexion Windows pour la personne à laquelle vous souhaitez accorder des autorisations et cliquez sur OK.

En plus de cette procédure, vous devez également accorder des autorisations d'administrateur sur Reporting Services et Windows SharePoint Services pour ajouter une personne au rôle Administrateur Team Foundation Server. Pour plus d'informations sur ces procédures, consultez Comment : définir les autorisations d'administrateur pour Reporting Services et Comment : définir les autorisations d'administrateur pour Windows SharePoint Services.

Sécurité

Vous ne devez jamais accorder plus d'autorisations que nécessaire à un utilisateur individuel et vous ne devez accorder aucune autorisation à un membre non fiable. Cela risque de compromettre l'intégrité de vos serveur et réseau.

Voir aussi

Tâches

Comment : définir les autorisations d'administrateur pour Reporting Services
Comment : définir les autorisations d'administrateur pour Windows SharePoint Services

Concepts

Serveurs de couche Application Team Foundation
Serveurs de couche Données Team Foundation

Autres ressources

Autorisations d'administrateur de Team Foundation Server


Comment : définir les autorisations d'administrateur pour Windows SharePoint Services

Comment : définir les autorisations d'administrateur pour Windows SharePoint Services
Voir aussi

Pour ajouter une personne en tant qu'Administrateur Team Foundation Server, vous devez définir des autorisations dans les groupes Team Foundation Server, les groupes Windows SharePoint Services et les groupes Reporting Services. Vous devez également définir des autorisations sur les groupes d'ordinateurs des couches Application et Données Team Foundation, le cas échéant. Dans cette rubrique, vous apprendrez à définir des autorisations dans Windows SharePoint Services pour un administrateur de site de Windows SharePoint Services.

Remarque Remarque

Vous devez être administrateur de Windows SharePoint Services pour terminer cette procédure.

Pour ajouter un membre au groupe Administration de SharePoint

  1. Sur la couche Application Team Foundation, cliquez sur Démarrer, pointez sur Outils d'administration, puis cliquez sur Administration centrale de SharePoint.

  2. Dans Administration centrale, cliquez sur Définir le groupe d'administration SharePoint.

  3. Dans Définir le groupe d'administration SharePoint, tapez le nom du compte de groupe et le domaine, le cas échéant.

    Remarque Remarque

    Vous pouvez ajouter un seul groupe ou utilisateur de domaine au groupe Administration de SharePoint. Vous ne pouvez pas ajouter de groupe local. Toutefois, les membres du groupe Administrateurs local sur le serveur peuvent également effectuer des tâches d'administration pour les produits et les technologies Windows SharePoint Services.

  4. Cliquez sur OK.

Pour ajouter un membre au groupe Administrateurs Windows SharePoint Services Site au site de niveau supérieur

  1. Ouvrez Internet Explorer.

  2. Entrez le nom de serveur du serveur de couche Application dans la barre d'adresses d'Internet Explorer pour ouvrir le site Windows SharePoint Service de niveau supérieur.

  3. Cliquez sur Paramètres du site, cliquez sur Aller à l'administration du site, puis cliquez sur Gérer les utilisateurs.

  4. Cliquez sur Ajouter des utilisateurs.

  5. Dans Étape 1 : Sélectionner les utilisateurs, ajoutez l'alias de la personne à laquelle vous souhaitez accorder des autorisations d'administration à l'échelle du site.

  6. Dans Étape 2 : Sélectionner les groupes de sites, sélectionnez Administrateur, puis cliquez sur Suivant.

  7. Dans Étape 3 : Confirmer les utilisateurs, ajoutez l'adresse de messagerie de l'utilisateur.

  8. Dans Étape 4 : Envoyer un message, choisissez s'il faut envoyer automatiquement un courrier électronique à l'utilisateur.

  9. Cliquez sur Terminer.

Non seulement vous devez terminer cette procédure, mais également accorder des autorisations sur Team Foundation Server et Reporting Services afin d'ajouter une personne pour le rôle Administrateur Team Foundation Server. Pour plus d'informations sur ces procédures, consultez Comment : définir les autorisations d'administrateur pour Reporting Services et Comment : définir des autorisations d'administrateur pour Team Foundation Server.

Sécurité

Vous ne devez jamais accorder plus d'autorisations que nécessaire à un utilisateur individuel et vous ne devez accorder aucune autorisation à un membre non fiable. Sinon, vous risquez de compromettre l'intégrité du serveur et du réseau.

Voir aussi

Tâches

Comment : définir des autorisations d'administrateur pour Team Foundation Server
Comment : définir les autorisations d'administrateur pour Reporting Services

Concepts

Team Foundation Server Application Tier
Team Foundation Server Data Tier

Autres ressources

Autorisations d'administrateur de Team Foundation Server


Comment : définir les autorisations d'administrateur pour Reporting Services

Comment : définir les autorisations d'administrateur pour Reporting Services
Voir aussi

Pour ajouter une personne en tant qu'Administrateur Team Foundation Server, vous devez définir des autorisations dans les groupes Team Foundation Server, les groupes Windows SharePoint Services et les groupes Reporting Services. Vous devez également définir des autorisations sur les groupes d'ordinateurs des couches Application et Données Team Foundation, le cas échéant. Dans cette rubrique, vous apprendrez comment définir des autorisations dans Reporting Services pour un administrateur de site Reporting Services.

Remarque Remarque

Vous devez disposer des autorisations en tant qu'administrateur de site Reporting Services pour effectuer cette procédure.

Pour ajouter un membre aux rôles Gestionnaire de contenu Reporting Services et Administrateur système

  1. Ouvrez Internet Explorer.

  2. Tapez ce qui suit dans la barre d'adresses :

    http:// data-tier /Reports/Pages/Folder.aspx

    où data-tier est le nom du serveur de rapports de couche Données Team Foundation. Vous pouvez trouver le nom du serveur de rapports en ouvrant Team Explorer, en développant le nœud Rapports et en affichant les propriétés d'un rapport.

  3. Cliquez sur l'onglet Propriétés, puis cliquez sur Nouvelle attribution de rôle.

  4. Dans Nom d'utilisateur ou de groupe, ajoutez le nom de connexion Windows de la personne à qui vous souhaitez accorder des autorisations Gestionnaire de contenu.

  5. Dans Rôle, sélectionnez Gestionnaire de contenu, puis cliquez sur OK.

  6. Cliquez sur Paramètres du site, puis sur Configurer la sécurité au niveau du site.

  7. Cliquez sur Nouvelle attribution de rôle.

  8. Dans Nom d'utilisateur ou de groupe, ajoutez le nom de connexion Windows de la personne à qui vous souhaitez accorder des autorisations Administrateur système.

  9. Dans Rôle, sélectionnez Administrateur système, puis cliquez sur OK.

Non seulement vous devez terminer cette procédure, mais également accorder des autorisations d'administrateur sur Team Foundation Server et Windows SharePoint Services afin d'ajouter une personne pour le rôle Administrateur Team Foundation Server. Pour plus d'informations sur ces procédures, consultez Comment : définir des autorisations d'administrateur pour Team Foundation Server et Comment : définir les autorisations d'administrateur pour Windows SharePoint Services.

Sécurité

Vous ne devez jamais accorder plus d'autorisations que nécessaire à un utilisateur et vous ne devez accorder aucune autorisation à un membre non fiable. Cela risque de compromettre l'intégrité de votre serveur et de votre réseau.

Voir aussi

Tâches

Comment : définir des autorisations d'administrateur pour Team Foundation Server
Comment : définir les autorisations d'administrateur pour Windows SharePoint Services

Concepts

Team Foundation Server Application Tier
Team Foundation Server Data Tier

Autres ressources

Autorisations d'administrateur de Team Foundation Server


Autorisations des coordinateurs de projet Team Foundation Server

Autorisations des coordinateurs de projet Team Foundation Server
Voir aussi
DropDown image

Pour permettre aux utilisateurs d'effectuer des actions dans différents rôles Team Foundation, ils doivent posséder les autorisations appropriées pour Team Foundation Server, Reporting Services et Windows SharePoint Server. Dans cette rubrique, vous apprendrez quelles autorisations sont requises pour un coordinateur de projet Team Foundation Server et où rechercher les informations relatives à la définition appropriée de ces autorisations.

Un coordinateur de projet Team Foundation Server est généralement responsable d'un projet d'équipe, peut créer et gérer une base de données des éléments de travail de projet d'équipe et un portail de projet d'équipe et administre des autorisations et des droits de sécurité pour le projet d'équipe. Seuls les membres du groupe Administrateurs Team Foundation peuvent créer un projet d'équipe. Dans la plupart des cas, l'Administrateur Team Foundation devra ajouter un utilisateur ou un groupe au projet pour agir en tant que coordinateur du projet d'équipe. Un coordinateur de projet d'équipe doit appartenir aux groupes suivants :

  • Administrateurs de projet Team Foundation Server.

  • Administrateurs Windows SharePoint Services.

  • Gestionnaire de contenu SQL Server Reporting Services.

Dans cette section

Comment : définir des autorisations de coordinateur de projet pour Team Foundation Server

Explique comment définir des autorisations de coordinateur de projet Team Foundation Server.

Comment : définir les autorisations des coordinateurs de projet pour Windows SharePoint Services

Décrit comment définir des autorisations de coordinateur de projet Windows SharePoint Services.

Comment : définir des autorisations de coordinateur de projet pour Reporting Services

Décrit comment définir des autorisations de gestionnaire de contenu SQL Server Reporting Services.

Voir aussi

Concepts

Autorisations de collaborateur de Team Foundation Server
Autorisations de Team Foundation Server
Groupes, autorisations et rôles par défaut de Team Foundation Server

Autres ressources

Gestion des autorisations
Autorisations d'administrateur de Team Foundation Server


Comment : définir des autorisations de coordinateur de projet pour Team Foundation Server

Comment : définir des autorisations de coordinateur de projet pour Team Foundation Server
Voir aussi

Pour ajouter une personne en tant que Chef de projet d'un projet d'équipe, vous devez définir des autorisations dans les groupes Team Foundation Server, les groupes Windows SharePoint Services et les groupes Reporting Services. Dans cette rubrique, vous apprendrez comment définir des autorisations dans Team Foundation Server pour un gestionnaire de contenu de niveau projet pour un projet d'équipe.

Remarque Remarque

Vous devez être administrateur Team Foundation Server pour effectuer cette procédure.

Pour ajouter un membre au groupe Project Administrators

  1. Dans Visual Studio, ouvrez Team Explorer, puis établissez une connexion à Team Foundation Server.

  2. Cliquez avec le bouton droit sur le nœud de projet d'équipe, pointez sur Paramètres du projet d'équipe, puis cliquez sur Appartenance au groupe.

  3. Sélectionnez [Project_Name]\Project Administrators, où Project_Name représente le nom du projet auquel vous souhaitez ajouter un administrateur, puis cliquez sur Propriétés.

  4. Dans Ajouter des utilisateurs et des groupes, sélectionnez Utilisateur ou groupe Windows, puis cliquez sur Ajouter.

  5. Ajoutez le nom de connexion Windows pour la personne ou le groupe auquel vous souhaitez accorder des autorisations, puis cliquez sur OK.

Outre cette procédure, vous devez également accorder des autorisations de coordinateur de projet sur Reporting Services et Windows SharePoint Services pour ajouter une personne au rôle Coordinateur de projet d'équipe. Pour plus d'informations sur ces procédures, consultez Comment : définir des autorisations de coordinateur de projet pour Reporting Services et Comment : définir les autorisations des coordinateurs de projet pour Windows SharePoint Services.

Sécurité

Vous ne devez jamais accorder plus d'autorisations que nécessaire à un utilisateur individuel et vous ne devez accorder aucune autorisation à un membre non fiable. Sinon, vous risquez de compromettre l'intégrité du serveur et du réseau.

Voir aussi

Tâches

Comment : définir des autorisations de coordinateur de projet pour Reporting Services
Comment : définir les autorisations des coordinateurs de projet pour Windows SharePoint Services

Autres ressources

Autorisations des coordinateurs de projet Team Foundation Server


Comment : définir les autorisations des coordinateurs de projet pour Windows SharePoint Services

Comment : définir les autorisations des coordinateurs de projet pour Windows SharePoint Services
Voir aussi

Pour ajouter une personne en tant que Coordinateur d'un projet d'équipe, vous devez définir les autorisations dans les groupes Team Foundation Server, les groupes Windows SharePoint Services et les groupes Reporting Services. Dans cette rubrique, vous apprendrez comment définir les autorisations dans Windows SharePoint Services pour un gestionnaire de contenu de niveau projet d'un projet d'équipe.

Remarque Remarque

Vous devez être administrateur de site Windows SharePoint Services pour exécuter cette procédure.

Pour ajouter un membre au groupe Administrateur de Windows SharePoint Services du site de projet

  1. Dans Visual Studio, ouvrez Team Explorer, puis établissez une connexion à Team Foundation Server.

  2. Cliquez avec le bouton droit sur le nœud du projet d'équipe, puis cliquez sur Afficher le portail du projet.

  3. Cliquez sur Paramètres du site, cliquez sur Aller à l'administration du site, puis cliquez sur Gérer les utilisateurs.

  4. Cliquez sur Ajouter des utilisateurs.

  5. Dans Étape 1 : Sélectionner les utilisateurs, ajoutez le nom de connexion Windows de la personne à laquelle vous souhaitez accorder des autorisations d'administration à l'échelle du site.

  6. Dans Étape 2 : Sélectionner les groupes de sites, sélectionnez Administrateur, puis cliquez sur Suivant.

  7. Dans Étape 3 : Confirmer les utilisateurs, ajoutez l'adresse de messagerie de l'utilisateur.

  8. Dans Étape 4 : Envoyer un message, sélectionnez s'il faut envoyer automatiquement un message électronique à l'utilisateur, puis cliquez sur Terminer.

Une fois cette procédure terminée, vous devez également accorder des autorisations de coordinateur de projet sur Reporting Services et Windows SharePoint Services afin d'ajouter une personne au rôle Coordinateur de projet d'équipe. Pour plus d'informations sur ces procédures, consultez Comment : définir des autorisations de coordinateur de projet pour Reporting Services et Comment : définir les autorisations des coordinateurs de projet pour Windows SharePoint Services.

Sécurité

Vous ne devez jamais accorder plus d'autorisations que nécessaire à un utilisateur et vous ne devez accorder aucune autorisation à un membre non fiable. Vous risquez de compromettre l'intégrité du serveur et du réseau.

Voir aussi

Tâches

Comment : définir des autorisations de coordinateur de projet pour Team Foundation Server
Comment : définir des autorisations de coordinateur de projet pour Reporting Services

Autres ressources

Autorisations des coordinateurs de projet Team Foundation Server


Comment : définir des autorisations de coordinateur de projet pour Reporting Services

Comment : définir des autorisations de coordinateur de projet pour Reporting Services
Voir aussi

Pour ajouter une personne en tant que Coordinateur d'un projet d'équipe, vous devez définir des autorisations dans les groupes Team Foundation Server, les groupes Windows SharePoint Services et les groupes Reporting Services. Dans cette rubrique, vous apprendrez comment définir des autorisations dans Reporting Services pour un gestionnaire de contenu de niveau projet pour un projet d'équipe.

Remarque Remarque

Vous devez être administrateur de site ou un gestionnaire de contenu Reporting Services pour effectuer cette procédure.

Pour ajouter un membre au rôle de Gestionnaire de contenu Reporting Services

  1. Ouvrez Internet Explorer.

  2. Tapez ce qui suit dans la barre d'adresses :

    http:// data-tier /Reports/Pages/Folders.aspx

    où data-tier est le nom du serveur de rapports de couche Données Team Foundation. Vous pouvez trouver le nom du serveur de rapports en ouvrant Team Explorer, en développant le nœud Rapports et en affichant les propriétés d'un rapport.

  3. Cliquez sur l'onglet Propriétés, puis cliquez sur Nouvelle attribution de rôle.

  4. Dans Nom d'utilisateur ou de groupe, ajoutez le nom de connexion de la personne que vous souhaitez ajouter à ce groupe.

  5. Dans Rôle, sélectionnez Gestionnaire de contenu, puis cliquez sur OK.

Outre l'exécution de cette procédure, vous devez également accorder des autorisations de coordinateur de projet dans Team Foundation Server et Windows SharePoint Services pour ajouter une personne dans le rôle Coordinateur de projets d'équipe. Pour plus d'informations sur ces procédures, consultez Comment : définir des autorisations de coordinateur de projet pour Team Foundation Server et Comment : définir les autorisations des coordinateurs de projet pour Windows SharePoint Services.

Sécurité

Vous ne devez jamais accorder plus d'autorisations que nécessaire à un utilisateur individuel et vous ne devez accorder aucune autorisation à un membre non fiable. Sinon, vous risquez de compromettre l'intégrité du serveur et du réseau.

Voir aussi

Tâches

Comment : définir des autorisations de coordinateur de projet pour Team Foundation Server
Comment : définir les autorisations des coordinateurs de projet pour Windows SharePoint Services

Autres ressources

Autorisations des coordinateurs de projet Team Foundation Server


Autorisations de collaborateur de Team Foundation Server

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Autorisations de collaborateur de Team Foundation Server
Voir aussi
Image de liste déroulante

Pour permettre aux utilisateurs d'effectuer des actions dans différents rôles Team Foundation, ils doivent posséder les autorisations appropriées pour Team Foundation Server, Reporting Services et Windows SharePoint Server. Dans cette rubrique, vous apprendrez quelles autorisations sont requises pour un collaborateur de projet Team Foundation Server et où rechercher les informations relatives à la définition appropriée de ces autorisations.

Collaborateur de projet Team Foundation

Un collaborateur de projet Team Foundation participe généralement à un projet, mais ne possède pas de responsabilités d'administration du projet. Un collaborateur de projet Team Foundation est capable de lire et d'écrire des éléments de travail, d'accéder au portail de projet d'équipe et d'apporter un guide de processus pour un projet d'équipe. L'utilisateur qui crée un projet d'équipe est automatiquement ajouté comme un collaborateur de projet. Si vous souhaitez accorder l'accès à d'autres utilisateurs, vous devez les ajouter comme collaborateurs de projet. Un collaborateur de projet d'équipe doit appartenir aux groupes suivants :

  • Collaborateur de projet Team Foundation.

  • Collaborateur Windows SharePoint Services.

  • Navigateur SQL Server Reporting Services.

Les rubriques suivantes décrivent comment définir ces autorisations :

Comment : définir les autorisations de collaborateur pour Reporting Services

Décrit comment définir des autorisations de collaborateur SQL Server Reporting Services.

Comment : définir les autorisations des collaborateurs (Contributors) pour Team Foundation Server

Explique comment définir des autorisations de collaborateur Team Foundation Server.

Comment : définir les autorisations de collaborateur pour Windows SharePoint Services

Explique comment définir des autorisations de collaborateur Windows SharePoint Services.

Voir aussi

Concepts

Autorisations de Team Foundation Server
Groupes, autorisations et rôles par défaut de Team Foundation Server

Autres ressources

Gestion des autorisations
Autorisations des coordinateurs de projet Team Foundation Server
Autorisations d'administrateur de Team Foundation Server


Comment : définir les autorisations des collaborateurs (Contributors) pour Team Foundation Server

Comment : définir les autorisations des collaborateurs (Contributors) pour Team Foundation Server
Voir aussi

Pour ajouter une personne en tant que Collaborateur d'un projet d'équipe, vous devez définir des autorisations dans les groupes Team Foundation Server, les groupes Windows SharePoint Services et les groupes Reporting Services. Dans cette rubrique, vous apprendrez comment définir des autorisations sur Team Foundation Server pour un Collaborateur de projet d'équipe.

Remarque Remarque

Vous devez être administrateur Team Foundation ou administrateur de projet pour exécuter cette procédure.

Pour ajouter un membre au groupe Contributor

  1. Dans Visual Studio, ouvrez Team Explorer, puis établissez une connexion à Team Foundation Server.

  2. Cliquez avec le bouton droit sur le nœud de projet d'équipe, pointez sur Paramètres du projet d'équipe, puis cliquez sur Appartenance au groupe.

  3. Sélectionnez Project_Name\Contributor, où Project_Name représente le nom du projet auquel vous essayez d'ajouter un collaborateur, puis cliquez sur Propriétés.

  4. Dans Ajouter des utilisateurs et des groupes, sélectionnez Utilisateur ou groupe Windows, puis cliquez sur Ajouter.

  5. Ajoutez le nom de connexion Windows de la personne que vous souhaitez ajouter au groupe Contributors.

  6. Cliquez sur OK.

Outre cette procédure, vous devez également accorder des autorisations de collaborateur sur Reporting Services et Windows SharePoint Services pour ajouter une personne au rôle Coordinateur de projet d'équipe. Pour plus d'informations sur ces procédures, consultez Comment : définir les autorisations de collaborateur pour Reporting Services et Comment : définir les autorisations de collaborateur pour Windows SharePoint Services.

Sécurité

Vous ne devez jamais accorder plus d'autorisations que nécessaire à un utilisateur individuel et vous ne devez accorder aucune autorisation à un membre non fiable. Vous risquez de compromettre l'intégrité du serveur et du réseau.

Voir aussi

Tâches

Comment : définir les autorisations de collaborateur pour Reporting Services
Comment : définir les autorisations de collaborateur pour Windows SharePoint Services

Concepts

Autorisations de collaborateur de Team Foundation Server


Comment : définir les autorisations de collaborateur pour Windows SharePoint Services

Comment : définir les autorisations de collaborateur pour Windows SharePoint Services
Voir aussi

Pour ajouter une personne en tant que Collaborateur d'un projet d'équipe, vous devez définir des autorisations dans les groupes Team Foundation Server, les groupes Windows SharePoint Services et les groupes Reporting Services. Dans cette rubrique, vous apprendrez comment définir des autorisations dans Windows SharePoint Services pour un Collaborateur de projet d'équipe.

Remarque Remarque

Vous devez être administrateur de site Windows SharePoint Services ou administrateur au niveau du projet pour exécuter cette procédure.

Pour ajouter un membre au groupe Collaborateur de Windows SharePoint Services

  1. Démarrez Visual Studio et dans Team Explorer, établissez une connexion à Team Foundation Server.

  2. Cliquez avec le bouton droit sur le nœud du projet d'équipe, puis cliquez sur Afficher le portail du projet.

  3. Cliquez sur Paramètres du site, puis cliquez sur Gérer les utilisateurs.

  4. Cliquez sur Ajouter des utilisateurs.

  5. Dans Étape 1 : Sélectionner les utilisateurs, ajoutez le nom de connexion Windows de la personne à laquelle vous souhaitez accorder des autorisations d'administration à l'échelle du site.

  6. Dans Étape 2 : Sélectionner les groupes de sites, sélectionnez Collaborateur, puis cliquez sur Suivant.

  7. Dans Étape 3 : Confirmer les utilisateurs, ajoutez l'adresse de messagerie de l'utilisateur.

  8. Dans Étape 4 : Envoyer un message, choisissez s'il faut envoyer automatiquement un courrier électronique à l'utilisateur.

  9. Cliquez sur Terminer.

En plus d'exécuter cette procédure, vous devez accorder des autorisations de collaborateur sur Team Foundation Server et Reporting Services pour ajouter une personne dans le rôle Collaborateur du projet d'équipe. Pour plus d'informations sur ces procédures, consultez Comment : définir les autorisations des collaborateurs (Contributors) pour Team Foundation Server et Comment : définir les autorisations de collaborateur pour Reporting Services.

Sécurité

Vous ne devez jamais accorder plus d'autorisations que nécessaire à un utilisateur individuel et vous ne devez accorder aucune autorisation à un membre non fiable. Cela risque de compromettre l'intégrité de vos serveur et réseau.

Voir aussi

Tâches

Comment : définir les autorisations de collaborateur pour Reporting Services
Comment : définir les autorisations des collaborateurs (Contributors) pour Team Foundation Server

Concepts

Autorisations de collaborateur de Team Foundation Server


Comment : définir les autorisations de collaborateur pour Reporting Services

Comment : définir les autorisations de collaborateur pour Reporting Services
Voir aussi

Pour ajouter une personne en tant que Collaborateur d'un projet d'équipe, vous devez définir des autorisations dans les groupes Team Foundation Server, les groupes Windows SharePoint Services et les groupes Reporting Services. Dans cette rubrique, vous apprenez comment définir des autorisations dans Reporting Services pour un Collaborateur de projet d'équipe.

Remarque Remarque

Vous devez être administrateur de site Reporting Services, gestionnaire de contenu ou gestionnaire de contenu de projet pour exécuter cette procédure.

Pour ajouter un membre au groupe Navigateur de Reporting Services

  1. Ouvrez Internet Explorer.

  2. Tapez ce qui suit dans la barre d'adresses d'Internet Explorer :

    http:// data-tier /Reports/Pages/Folder.aspx

    où data-tier représente le nom du serveur de rapports de couche Données Team Foundation. Vous pouvez trouver le nom du serveur de rapports en ouvrant Team Explorer, en développant le nœud Rapports et en affichant les propriétés d'un rapport.

  3. Cliquez sur l'onglet Propriétés, puis cliquez sur Nouvelle attribution de rôle.

  4. Dans Nom d'utilisateur ou de groupe, ajoutez le nom de connexion de la personne que vous souhaitez ajouter à ce groupe.

  5. Dans Rôle, sélectionnez Navigateur, puis cliquez sur OK.

Outre l'exécution de cette procédure, vous devez également accorder des autorisations de collaborateur dans Team Foundation Server et Windows SharePoint Services pour ajouter une personne dans le rôle Collaborateur du projet d'équipe. Pour plus d'informations sur ces procédures, consultez Comment : définir les autorisations des collaborateurs (Contributors) pour Team Foundation Server et Comment : définir les autorisations de collaborateur pour Windows SharePoint Services.

Sécurité

Vous ne devez jamais accorder plus d'autorisations que nécessaire à un utilisateur individuel et vous ne devez accorder aucune autorisation à un membre non fiable. Sinon, vous risquez de compromettre l'intégrité du serveur et du réseau.

Voir aussi

Tâches

Comment : définir les autorisations des collaborateurs (Contributors) pour Team Foundation Server
Comment : définir les autorisations de collaborateur pour Windows SharePoint Services

Concepts

Autorisations de collaborateur de Team Foundation Server


Autorisations du contrôle de code source Team Foundation

Autorisations du contrôle de code source Team Foundation
DropDown image

Cette section présente des rubriques expliquant les droits de sécurité et les autorisations pour le contrôle de code source, les builds et audits à utiliser avec la commande tf.exe. Pour plus d'informations sur la sécurisation de Team Foundation Server, consultez Sécurisation de Team Foundation Server.

Dans cette section

Droits et autorisations relatifs à la sécurité du contrôle de code source

Décrit les droits de sécurité et les autorisations pour le contrôle de code source.

Droits et autorisations relatifs à la sécurité Team Build

Décrit les droits de sécurité et les autorisations pour Team Foundation Build.

Audit et autorisations de l'utilisateur

Décrit les audits et les autorisations utilisateur pour Team Foundation.

Voir aussi

Concepts

Autorisations de Team Foundation Server

Autres ressources

Administration de Team Foundation Server


Droits et autorisations relatifs à la sécurité du contrôle de code source

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Droits et autorisations relatifs à la sécurité du contrôle de code source
Voir aussi
Image de liste déroulante

Team Foundation Server inclut des droits de sécurité et des autorisations applicables à l'environnement Team Foundation qui inclut le contrôle de code source. Pour plus d'informations sur les autorisations de Team Foundation Server, consultez Audit et autorisations de l'utilisateur. Les droits et autorisations de Team Foundation Server suivants s'appliquent au système de contrôle de code source.

Autorisations de fichier et de dossier

  • Read

    Lire le contenu d'un fichier ou d'un dossier.

  • PendChange

    Extraire, ajouter, supprimer, effectuer un branchement, fusionner, restaurer.

  • Checkin

    Archiver les modifications.

  • Label

    Appliquez une étiquette aux éléments.

  • Lock

    Verrouiller un élément pour empêcher qu'il ne soit mis à jour par d'autres utilisateurs.

  • ReviseOther

    Modifier le contenu du commentaire sur l'ensemble de modifications et des notes d'archivage d'un autre utilisateur.

  • UnlockOther

    Supprimer le verrouillage d'un autre utilisateur.

  • UndoOther

    Annuler la modification en attente d'un autre utilisateur.

  • LabelOther

    Modifier l'étiquette d'un autre utilisateur.

  • AdminProjectRights

    Configurer les autorisations.

  • CheckinOther

    Archiver sous un autre utilisateur (nécessaire pour les utilitaires de conversion).

Autorisations globales

  • CreateWorkspace

    Créer un espace de travail.

  • AdminWorkspaces

    Modifier l'espace de travail d'un autre utilisateur.

  • AdminShelvesets

    Supprimer les modifications réservées d'un autre utilisateur.

  • AdminConnections

    Interrompre une opération de contrôle de code source en cours.

  • AdminConfiguration

    Configurer des notes d'archivage, des stratégies, des types de fichier, etc.

Voir aussi

Concepts

Contrôle de code source Team Foundation


Droits et autorisations relatifs à la sécurité Team Build

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Droits et autorisations relatifs à la sécurité Team Build
Voir aussi
Image de liste déroulante

Team Foundation Server inclut des droits de sécurité et des autorisations applicables à l'environnement Team Foundation qui inclut Team Foundation Build. Pour plus d'informations sur les autorisations de Team Foundation Server, consultez Audit et autorisations de l'utilisateur. Les droits et autorisations de Team Foundation Server suivants s'appliquent à Team Build.

Attention Attention

Si un utilisateur a besoin d'accéder à l'ordinateur de build à des fins d'examen, il est recommandé que vous ajoutiez l'utilisateur à l'ordinateur de build et que vous accordiez à l'utilisateur des autorisations sur le répertoire de build. Il ne vous est pas recommandé d'accorder à l'utilisateur des autorisations du compte de service de build, car cela lui donnerait le contrôle sur l'ensemble du processus de génération.

  • Administrer une build

    Seuls les comptes avec le droit Administrer une build sont autorisés à effectuer les actions suivantes :

    • Créer des types de build.

      L'Assistant de type de build est activé. Pour plus d'informations, consultez Comment : créer un type de build.

      Remarque Remarque

      Pour créer un type de build, le compte doit également disposer des autorisations d'archivage sur le dossier TeamBuildTypes dans le contrôle de code source. Pour plus d'informations, consultez Droits et autorisations relatifs à la sécurité du contrôle de code source.

    • Modifier les types de build existants.

    • Supprimer des builds.

      Le compte de service de couche Application et le compte de service Team Build doivent disposer des autorisations en lecture/écriture sur le site cible pour pouvoir supprimer une build.

    • Arrêter les générations.

  • Modifier la qualité de la build

    Seuls les comptes avec l'autorisation de modification de la qualité de la build sont autorisés à modifier l'état de la qualité de build dans les rapports. Pour plus d'informations, consultez Comment : définir la qualité de build.

  • Afficher les informations au niveau du projet

    Les comptes avec l'autorisation Afficher les informations au niveau du projet peuvent :

    • Consulter les rapports de build. Pour plus d'informations, consultez Comment : afficher un rapport de build.

    • S'abonner aux notifications par courrier électronique. Pour plus d'informations, consultez Comment : recevoir des notifications de build par courrier électronique.

  • Commencer une build

    Les comptes avec le droit Commencer une build peuvent :

    • Commencer des builds

      La commande Générer {Team Project Name} du menu principal Générer et du menu contextuel de Team Project est activée. Pour plus d'informations, consultez Exécution de builds dans Team Foundation Build.

    Attention Attention

    Les fichiers binaires et les fichiers journaux copiés dans le répertoire de dépôt peuvent être incertains. Vous pouvez étendre le type de build avec une tâche MSBuild personnalisée qui copie de façon sécurisée ces fichiers vers le répertoire cible. Pour plus d'informations sur l'extension d'un type de build, consultez Procédure pas à pas : extension de Team Foundation Build.

  • Écrire dans le magasin opérationnel de la build

    Seuls les comptes avec le droit Écrire dans le magasin opérationnel de la build peuvent écrire dans le magasin opérationnel.

Voir aussi

Concepts

Vue d'ensemble de Team Foundation Build


Audit et autorisations de l'utilisateur

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Audit et autorisations de l'utilisateur
Voir aussi
Image de liste déroulante

Le service d'autorisations Team Foundation permet aux administrateurs et aux propriétaires de fichiers, dossiers et autres objets Team Foundation de gérer les autorisations utilisateur pour les éléments sous leur contrôle à un niveau atomique.

Cette rubrique aborde uniquement les autorisations requises pour le contrôle de version. Pour plus d'informations sur les autorisations Team Foundation Server, consultez Autorisations de Team Foundation Server.

Autorisations

Si vous êtes le propriétaire ou disposez du contrôle administratif sur un fichier, tel que $/projects/314.cs, vous pouvez modifier les autorisations par défaut pour autoriser ou refuser la capacité d'exécuter des commandes sur le fichier à des utilisateurs spécifiques et à des groupes entiers.

Autorisation | Description
Read | Permet aux utilisateurs de lire le contenu d'un fichier ou d'un dossier. Si un utilisateur dispose d'autorisations en lecture sur un dossier, un utilisateur peut consulter le contenu du dossier et les propriétés des fichiers qu'il contient, même si l'utilisateur ne dispose pas des autorisations permettant d'ouvrir ces fichiers.
PendChange | Permet aux utilisateurs d'apporter une modification en attente aux éléments d'un dossier. Les exemples de modifications en attente incluent l'ajout, l'attribution d'un nouveau nom, la suppression, la restauration, la création de branches et la fusion d'un fichier.
Checkin | Permet aux utilisateurs d'archiver des éléments et de modifier tout commentaire sur un ensemble de modifications validées. Les modifications en attente seront validées lors de l'archivage.
Label | Permet aux utilisateurs d'étiqueter des éléments.
Verrouiller | Permet aux utilisateurs de verrouiller et déverrouiller des dossiers ou des fichiers.
ReviseOther | Permet aux utilisateurs de modifier les commentaires sur des fichiers archivés, même si un autre utilisateur a archivé le fichier.
UnlockOther | Permet aux utilisateurs de déverrouiller des fichiers verrouillés par d'autres utilisateurs.
UndoOther | Permet aux utilisateurs d'annuler une modification en attente faite par un autre utilisateur.
LabelOther | Permet aux utilisateurs de modifier ou de supprimer des étiquettes créées par un autre utilisateur.
AdminProjectRights | Permet aux utilisateurs de définir des valeurs de liste de vérification d'accès pour des fichiers et des dossiers.
CheckinOther | Permet aux utilisateurs d'archiver des modifications qui ont été apportées par d'autres utilisateurs. Les modifications en attente seront validées lors de l'archivage.

Autorisations globales

Autorisation globale | Description
CreateWorkspace | Permet à l'utilisateur de créer des espaces de travail.
AdminWorkspaces | Permet à l'utilisateur de créer, modifier et supprimer tout espace de travail.
AdminShelvesets | Permet à l'utilisateur de créer, modifier et supprimer tout jeu de réservations.
AdminConnections | Permet à l'utilisateur de déconnecter d'autres utilisateurs du serveur et d'arrêter l'exécution de commandes.
AdminConfiguration | Permet à l'utilisateur de configurer des espaces de travail.

Voir aussi

Référence

Permission, commande

Concepts

Autorisations de Team Foundation Server


Affichage et modification des autorisations

Affichage et modification des autorisations
DropDown image

Vous pouvez modifier les autorisations associées à un groupe de sécurité pour contrôler les droits d'accès dont les utilisateurs du groupe disposent dans votre projet d'équipe.

Dans cette section

Comment : afficher les autorisations

Décrit comment consulter les autorisations d'un utilisateur ou d'un groupe dans votre projet ou sur l'ensemble de votre serveur Team Foundation Server.

Comment : modifier des autorisations pour un groupe ou un utilisateur

Décrit comment modifier les autorisations d'un utilisateur ou d'un groupe sur un projet ou sur l'ensemble de votre serveur Team Foundation Server.

Voir aussi

Autres ressources

Gestion des utilisateurs et groupes


Comment : afficher les autorisations

Comment : afficher les autorisations

Lors de l'administration de Team Foundation Server, vous souhaiterez afficher et modifier les autorisations accordées aux utilisateurs ou aux groupes. Dans cette rubrique, vous apprendrez comment consulter des autorisations dans Team Foundation pour des individus et des groupes.

Pour consulter des autorisations au niveau du serveur

  1. Dans l'Explorateur d'équipes, cliquez avec le bouton droit sur le serveur pour lequel vous souhaitez consulter les autorisations, choisissez Paramètres Team Foundation Server, puis sélectionnez Sécurité.

  2. Dans le volet Utilisateurs et Groupes, sélectionnez l'utilisateur ou le groupe pour lequel vous souhaitez consulter les autorisations.

    Les autorisations seront affichées dans le volet Autorisation.

Pour consulter des autorisations au niveau du projet

  1. Dans l'Explorateur d'équipes, cliquez avec le bouton droit sur le projet pour lequel vous souhaitez consulter les autorisations, choisissez Paramètres du projet d'équipe, puis sélectionnez Sécurité.

  2. Dans le volet Utilisateurs et Groupes, sélectionnez l'utilisateur ou le groupe pour lequel vous souhaitez consulter les autorisations.

    Les autorisations seront affichées dans le volet Autorisation.

Voir aussi

Tâches

Comment : modifier des autorisations pour un groupe ou un utilisateur

Autres ressources

Affichage et modification des autorisations
Gestion des autorisations


Comment : modifier des autorisations pour un groupe ou un utilisateur

Comment : modifier des autorisations pour un groupe ou un utilisateur
Voir aussi

Vous pouvez modifier explicitement les autorisations d'un utilisateur ou d'un groupe sur un projet ou sur l'ensemble de votre serveur Team Foundation Server. Pour modifier les autorisations d'un groupe, vous devez disposer d'un accès en lecture/écriture sur le groupe.

Pour modifier les autorisations d'un groupe ou d'un utilisateur

  1. Dans Team Explorer, sélectionnez le projet d'équipe dans lequel se trouve le groupe ou pour modifier les autorisations d'un groupe de niveau serveur, sélectionnez le serveur Team Foundation Server dans lequel se trouve le groupe.

  2. Dans le menu Équipe, pointez sur Paramètres du projet d'équipe, puis cliquez sur Sécurité, ou pour modifier les autorisations d'un groupe de niveau serveur, pointez sur Paramètres Team Foundation Server, puis cliquez sur Sécurité.

  3. Dans Utilisateurs et groupes, sélectionnez le groupe ou l'utilisateur pour lequel vous souhaitez modifier les autorisations.

  4. Sous Autorisations pour group or user name, sélectionnez l'autorisation que vous souhaitez modifier, sélectionnez la colonne Autoriser pour accorder cette autorisation ou sélectionnez la colonne Refuser pour refuser l'autorisation.

    Remarque Remarque

    Pour appliquer les autorisations d'un groupe parent, désactivez les cases à cocher Autoriser et Refuser.

  5. Cliquez sur Fermer.

Voir aussi

Tâches

Comment : ajouter des utilisateurs à un groupe de niveau serveur

Autres ressources

Gestion des utilisateurs et groupes


Gestion des services et comptes de service Team Foundation Server

Gestion des services et comptes de service Team Foundation Server
Voir aussi
DropDown image

Team Foundation Server inclut plusieurs services et comptes de service qui s'exécutent sur le serveur de couche Données, sur le serveur de couche Application ou sur les deux à la fois. Cette section décrit comment gérer ces comptes.

Dans cette section

Planificateur de tâches de Team Foundation Server

Décrit comment le service du Planificateur de tâches de Team Foundation Server fournit un mécanisme de planification général pour les services Web de Team Foundation.

Comment : afficher les services Team Foundation Server

Décrit comment consulter les services Team Foundation Server et les pools d'applications de service Web que Team Foundation Server installe.

Comment : assigner un nouveau compte à un service Team Foundation Server

Décrit comment modifier le compte de service que Team Foundation Server utilise.

Réinitialisation des mots de passe et des comptes de service

Répertorie les services et comptes de service que Team Foundation Server installe sur les serveurs de couche Données et de couche Application.

Référence

Commandes de l'utilitaire en ligne de commande TFSAdminUtil

Décrit comment utiliser TFSAdminUtil.exe pour mettre à jour Team Foundation Server afin d'utiliser des nouvelles informations d'identification pour les comptes de service de Team Foundation Server.

Voir aussi

Autres ressources

Gestion de Team Foundation Server


Planificateur de tâches de Team Foundation Server

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Planificateur de tâches de Team Foundation Server
Voir aussi
Image de liste déroulante

Le planificateur de tâches de Visual Studio Team Foundation Server est un service Windows qui s'exécute sur les serveurs de couche Application de Team Foundation Server. Le service du planificateur de tâches de Team Foundation Server fournit un mécanisme de planification général pour les services Web de Team Foundation.

Service du planificateur de tâches de Team Foundation Server

Certains services de Team Foundation ont des tâches répétitives. Par exemple, les administrateurs pourraient souhaiter planifier des builds pour la nuit. Pour ce faire, les services de build doivent être capables d'installer un événement planifié automatiquement dans la base de données d'inscription. Le service du planificateur de tâches de Team Foundation Server, également connu sous le nom de TFSServerScheduler, fournit un service Windows unique pour planifier des tâches répétitives sur les serveurs de Team Foundation. Le service s'exécute via la base de données d'inscription, identifie tous les services Web de Team Foundation Server qui ont planifié des événements et planifie ces tâches.

Instances

Une seule instance du service du planificateur de tâches de Team Foundation Server doit s'exécuter sur un serveur de couche Application de Team Foundation Server. Le service s'exécute sous le nom abrégé de TFSServerScheduler, et par défaut s'exécute sous le compte de service que vous avez spécifié quand vous avez installé Team Foundation Server. Pour consulter l'état du service du planificateur de tâches de Team Foundation Server sur un serveur de couche Application, cliquez sur Démarrer, sur Services d'administration, sur Services, puis accédez à TFSServerScheduler.

Hypothèses et limitations

Le service du planificateur de tâches de Team Foundation Server s'exécute en continu sur les serveurs de couche Application de Team Foundation Server. Les administrateurs ne doivent pas avoir besoin d'arrêter manuellement ou de démarrer ce service. Le service du planificateur de tâches de Team Foundation Server doit redémarrer automatiquement lorsqu'un serveur est redémarré.

Les administrateurs ne configureront pas directement le planificateur de tâches de Team Foundation Server. Les tâches qui doivent être planifiées sont configurées directement sur des composants individuels de Team Foundation, tels que Team Foundation Build. Lorsqu'un événement est ajouté ou supprimé, le service du planificateur de tâches de Team Foundation Server reconfigure automatiquement les tâches planifiées dans la base de données d'inscription.

Le planificateur de tâches de Team Foundation Server n'est pas conçu pour être un mécanisme de planification universel. Il n'est pas conçu pour fournir une granularité de planification supérieure au jour de la semaine, à l'heure du jour et à la minute du jour. La plupart des administrateurs n'auront pas besoin de planifier des tâches au-delà de ce niveau de granularité.

Voir aussi

Concepts

Comment : réinitialiser manuellement le mot de passe des services de couche Application

Autres ressources

Team Foundation Server Registry Settings, Services, and Application Folders


Comment : afficher les services Team Foundation Server

Comment : afficher les services Team Foundation Server

Team Foundation Server comprend plusieurs services qui sont exécutés sur la couche Application. Vos véritables services varieront selon les fonctions de Team Foundation que vous avez installées sur votre serveur de couche Application.

Cette rubrique décrit comment consulter les services Team Foundation Server et les pools d'applications de service Web que Team Foundation Server installe.

Pour consulter les services sur l'ordinateur de couche Application

  1. Sur l'ordinateur de couche Application Team Foundation Server, cliquez sur Démarrer, sur Outils d'administration, puis sur Gestion de l'ordinateur.

  2. Dans le volet de navigation, développez Services et applications, puis ouvrez Services.

  3. Cliquez sur l'en-tête de colonne Ouvrir une session en tant que pour trier les services en fonction du compte sous lequel ils sont exécutés.

    Par défaut, les services Team Foundation Server (service d'analyse de couverture du code, TFSServerScheduler, service Team Build et service du minuteur SharePoint), connus sous le nom de TFSService, sont exécutés sous le compte de service Team Foundation Server que vous avez spécifié lorsque vous avez installé Team Foundation Server.

    Remarque Remarque

    Le service Team Build est installé uniquement lorsque l'ordinateur de build est installé.

Pour consulter des pools d'applications de service Web sur l'ordinateur de couche Application

  1. Sur l'ordinateur de couche Application Team Foundation Server, cliquez sur Démarrer, sur Outils d'administration, puis sur Gestion de l'ordinateur.

  2. Dans le volet de navigation, développez Services et applications, ouvrez Services IIS (Internet Information Services), puis ouvrez Pools d'applications.

  3. Pour chaque pool d'applications, cliquez avec le bouton droit sur le pool d'applications, puis cliquez sur Propriétés.

  4. Cliquez sur l'onglet Identité.

    Par défaut, les pools d'applications de Team Foundation Server (TFS AppPool, TFS Proxy AppPool, TFTFWSS et TFWSSAdm), connus sous le nom de TFSService, sont exécutés sous le compte de service Team Foundation Server que vous avez spécifié lorsque vous avez installé Team Foundation Server.

    Remarque Remarque

    Le pool d'applications TFS Proxy AppPool est installé uniquement lorsque le proxy de contrôle de code source Team Foundation est installé

Voir aussi

Tâches

Comment : assigner un nouveau compte à un service Team Foundation Server

Autres ressources

Gestion des services et comptes de service Team Foundation Server
Réinitialisation des mots de passe et des comptes de service


Comment : assigner un nouveau compte à un service Team Foundation Server

Comment : assigner un nouveau compte à un service Team Foundation Server
Voir aussi

Vous pouvez remplacer le compte de service Team Foundation Server que vous avez spécifié lorsque vous avez installé Team Foundation Server (connu sous le nom de compte TFSService) avec un autre compte, tel que domain\TFSSVC. Pour apporter cette modification, utilisez l'utilitaire TFSAdminUtil avec l'argument ChangeAccount. Cet outil met à jour des serveurs de Team Foundation en remplaçant les anciennes informations sur le compte de service par les nouvelles.

Vous pouvez également modifier les informations de connexion manuellement pour chaque service et mettre à jour le serveur SQL pour reconnaître le nouveau compte de service Team Foundation Server.

Remarque Remarque

L'utilitaire TFSAdminUtil ne crée pas physiquement de compte ni ne modifie son mot de passe, mais met simplement Team Foundation Server à jour pour utiliser les informations d'identification actuelles. Le compte de service peut être un compte local ou de domaine et TFSAdminUtil peut être écrit pour autoriser des mises à jour automatisées. Pour plus d'informations, consultez ChangeAccount, commande.

Mise à jour des informations sur le compte de service avec TFSAdminUtil

Pour assigner un nouveau compte de service à tous les services de Team Foundation Server à l'aide de TFSAdminUtil

  1. À partir de la ligne de commande, localisez l'utilitaire TFSAdminUtil.

    Par défaut, il se trouve dans <drive>:\Program Files\Microsoft Visual Studio 2005 Team Foundation Server\Tools.

  2. Au niveau de la ligne de commande, tapez TFSAdminUtil ChangeAccount oldAccount oldPassword newAccount newPassword (targetMachineName), puis appuyez sur ENTRÉE.

    Vous devez entrer le nom et le mot de passe d'utilisateur de l'ancien compte de service Team Foundation Server (oldAccount et oldPassword), ainsi que le nom et le mot de passe d'utilisateur du nouveau compte (newAccount et newPassword).

    Le nom de l'ordinateur cible (targetMachineName) est facultatif. L'ordinateur cible doit être un serveur de couche Application. Si vous ne spécifiez pas la cible, l'utilitaire TFSAdminUtil cible l'ordinateur actuel.

L'utilitaire TFSAdminUtil parcourt les comptes de service et modifie uniquement ceux qui s'exécutent sous l'ancien compte.

Mise à jour manuelle des informations sur le compte de service

Au lieu d'utiliser l'utilitaire TFSAdminUtil, vous pouvez modifier manuellement les informations de connexion de chaque service et mettre à jour le serveur SQL pour reconnaître le nouveau compte de service Team Foundation Server. Toutefois, vous devez vous reposer sur l'utilitaire TFSAdminUtil pour mettre à jour les informations dans la plupart des situations.

Pour sélectionner le compte sous lequel services s'exécutent

  1. Sur l'ordinateur de couche Application Team Foundation Server, cliquez sur Démarrer, sur Outils d'administration, puis sur Gestion de l'ordinateur.

  2. Dans le volet de navigation, développez Services et applications, puis ouvrez Services.

  3. Exécutez les étapes suivantes pour chaque service de Team Foundation Server : le service d'analyse de couverture du code, TFSServerScheduler, le service Team Build et le service du minuteur de SharePoint. Vous devrez probablement arrêter le service avant d'exécuter le reste de cette procédure.

    Remarque Remarque

    Le service Team Build est installé uniquement lorsque l'ordinateur de build est installé.

    1. Cliquez avec le bouton droit sur le service, puis cliquez sur Propriétés.

    2. Cliquez sur l'onglet Ouverture de session du service.

    3. Spécifiez le nouveau compte de service Team Foundation Server dans la zone de texte Ce compte.

    4. Entrez le mot de passe du compte dans la zone Mot de passe et dans la zone Confirmer le mot de passe, puis cliquez sur OK.

Pour sélectionner un compte sous lequel s'exécutent les pools d'applications de service Web

  1. Sur l'ordinateur de couche Application Team Foundation Server, cliquez sur Démarrer, sur Outils d'administration, puis sur Gestion de l'ordinateur.

  2. Dans le volet de navigation, développez Services et applications, ouvrez Services IIS (Internet Information Services), puis ouvrez Pools d'applications.

  3. Exécutez les étapes suivantes pour chaque pool d'applications de Team Foundation Server : TFS AppPool, TFS Proxy AppPool, TFTFWSS et TFWSSAdm.

    Remarque Remarque

    Le pool d'applications TFS Proxy AppPool est installé uniquement lorsque le proxy de contrôle de code source est installé

    1. Cliquez avec le bouton droit sur le pool d'applications, puis cliquez sur Propriétés.

    2. Cliquez sur l'onglet Identité.

    3. Spécifiez le nouveau compte de service Team Foundation Server dans la zone de texte Nom d'utilisateur.

    4. Entrez le mot de passe du compte dans la zone Mot de passe et dans la zone Confirmer le mot de passe, puis cliquez sur OK.

Pour ajouter un compte à une base de données

  1. Ouvrez SQL Server Management Studio sur l'ordinateur de couche Données de Team Foundation Server. Vous l'ouvrez en général en cliquant sur Démarrer, sur Tous les programmes, sur Microsoft SQL Server, puis sur SQL Server Management Studio.

  2. Sélectionnez le modèle Type de serveur , Nom du serveur et Authentification propre à votre serveur. Fournissez un Nom d'utilisateur et un Mot de passe valables si votre serveur SQL Server l'exige, puis cliquez sur Se conn..

  3. Développez le nœud Sécurité, puis développez le nœud Connexions pour consulter la liste des utilisateurs et des objets qui peuvent accéder à la base de données.

  4. Cliquez avec le bouton droit sur le compte de service Team Foundation Server précédent, puis sélectionnez Propriétés.

    Le compte précédent servira de modèle pour les nouveaux paramètres de compte de service.

  5. Dans SQL Server Management Studio, cliquez avec le bouton droit sur le nœud Connexions, puis sélectionnez Nouvelle connexion.

  6. Spécifiez le nouveau compte de service Team Foundation Server dans la zone de texte Nom d'accès.

  7. Placez les deux fenêtres Propriétés de la connexion au premier plan. Dans chacun des volets de navigation, sélectionnez Mappage de l'utilisateur.

  8. Configurez les paramètres Mappage de l'utilisateur du nouveau compte pour correspondre aux paramètres de l'ancien compte.

  9. Cliquez sur OK dans chaque fenêtre Propriétés de la connexion.

Pour sélectionner le compte pouvant se connecter à une base de données

  1. Ouvrez SQL Server Management Studio sur l'ordinateur de couche Données de Team Foundation Server. Vous l'ouvrez en général en cliquant sur Démarrer, sur Tous les programmes, sur Microsoft SQL Server, puis sur SQL Server Management Studio.

  2. Sélectionnez le modèle Type de serveur , Nom du serveur et Authentification propre à votre serveur. Fournissez un Nom d'utilisateur et un Mot de passe valables si votre serveur SQL Server l'exige, puis cliquez sur Se conn..

  3. Développez le nœud Bases de données pour afficher la liste des bases de données qui constituent la couche Données de Team Foundation Server.

  4. Exécutez les étapes suivantes pour chaque base de données Team Foundation Server : STS_Config, TfsActivityLogging, TfsBuild, TfsIntegration, TfsVersionControl, TfsWarehouse, TfsWorkItemTracking et TfsWorkItemTrackingAttachments.

    1. Cliquez avec le bouton droit sur boîte de dialogue, puis sélectionnez Propriétés.

    2. Dans le volet de navigation, sélectionnez Autorisations, puis cliquez sur Ajoutez.

    3. Cliquez sur Parcourir, sélectionnez la case à cocher du nouveau compte de service Team Foundation Server, puis cliquez sur OK.

    4. Cliquez sur OK.

    5. Sélectionnez l'ancien compte de service Team Foundation Server de la table Utilisateurs ou rôles, puis cliquez sur Supprimer.

    6. Cliquez sur OK.

Sécurité

Pour utiliser TFSAdminUtil, vous devez être administrateur sur la couche Application locale et administrateur de SQL Server sur la couche Données de Team Foundation Server.

Voir aussi

Tâches

Comment : afficher les services Team Foundation Server

Référence

ChangeAccount, commande

Autres ressources

Gestion des services et comptes de service Team Foundation Server


Réinitialisation des mots de passe et des comptes de service

Réinitialisation des mots de passe et des comptes de service
DropDown image

Team Foundation Server inclut plusieurs services et comptes de service qui s'exécutent sur le serveur de couche Données, sur le serveur de couche Application ou sur les deux à la fois. Vos véritables services varieront selon les fonctions de Team Foundation que vous avez installées sur vos serveurs de couche Application et de couche Données. Par exemple, si vous avez opté pour une installation sur un serveur unique, la couche Données et la couche Application s'exécuteront sur le même serveur.

Si vous devez réinitialiser le mot de passe du compte de service Team Foundation Server, vous devez modifier le mot de passe de plusieurs services sur les serveurs de couche Application de Team Foundation Server à l'aide de l'utilitaire en ligne de commande TFSAdminUtil. Vous pouvez également utiliser l'utilitaire en ligne de commande TFSAdminUtil pour déterminer les services qui doivent s'exécuter sous un compte nommé. Le tableau suivant répertorie les noms du service, le compte de service utilisé et la couche sur laquelle s'exécutent ces services.

Nom du service | Compte de service | Couche
Serveur SQL | Système local | Couche Données
Analysis Server (MSSQLSERVER) | Système local | Couche Données
Report Server (MSSQLSERVER) | Service réseau | Couche Application
Service de couverture du code | TFSService | Couche Application
Service Web Report Server | Système local | Couche Données
Explorateur SQL | Système local | Couche Données
SQL Agent | Système local | Couche Données
Planificateur de serveur TFS | TFSService | Couche Application
SharePoint Services | Service réseau | Couche Application
Services Web Team Foundation Server | TFSService | Couche Application
Service Team Build (si Team Foundation Build est installé) | TFSService | Couche Application

Sur le serveur de couche Données de Team Foundation Server, tous les comptes de service correspondant au SQL s'exécutent comme un système local. Vous ne devez modifier le mot de passe pour aucun de ces comptes.

Sur le serveur de couche Application de Team Foundation Server, vous devez modifier le mot de passe du pool d'applications des services Web de Team Foundation Server, ainsi que le mot de passe des services Planificateur de serveur TFS et Service Team Build, selon vos besoins opérationnels.

Dans cette section

Comment : réinitialiser le mot de passe pour le pool d'applications

Explique les procédures permettant de modifier le mot de passe du pool d'applications sur le serveur de couche Application.

Comment : réinitialiser manuellement le mot de passe des services de couche Application

Fournit un lien vers les dernières instructions en ligne pour réinitialiser le mot de passe manuellement.

Comment : modifier le nom d'un compte de service

Fournit un lien vers les dernières instructions en ligne pour modifier le nom du compte.

Voir aussi

Tâches

Comment : réinitialiser le mot de passe pour le pool d'applications

Concepts

Comment : réinitialiser manuellement le mot de passe des services de couche Application

Autres ressources

Commandes de l'utilitaire en ligne de commande TFSAdminUtil


Comment : réinitialiser le mot de passe pour le pool d'applications

Comment : réinitialiser le mot de passe pour le pool d'applications
Voir aussi

Si vous devez réinitialiser le mot de passe de compte de service pour Team Foundation Server, vous devez modifier le mot de passe pour le pool d'applications sur le serveur de couche Application.

Pour réinitialiser le mot de passe pour le pool d'applications

  1. Sur l'ordinateur de couche Application Team Foundation Server, cliquez sur Démarrer, sur Outils d'administration, puis sur Gestion de l'ordinateur.

  2. Dans le volet de navigation, développez Services et applications, ouvrez services IIS (Internet Information Services), puis ouvrez Pools d'applications.

  3. Cliquez avec le bouton droit sur TFS AppPool, puis cliquez sur Propriétés.

  4. Sélectionnez l'onglet Identité.

  5. Sous Identité du pool d'applications, vérifiez que Configurable est sélectionné et que la zone Nom d'utilisateur indique domain\BISSVC.

  6. Dans les zones Mot de passe et Confirmer le mot de passe, entrez le nouveau mot de passe, puis cliquez sur OK.

Voir aussi

Concepts

Comment : réinitialiser manuellement le mot de passe des services de couche Application

Autres ressources

Réinitialisation des mots de passe et des comptes de service


Comment : réinitialiser manuellement le mot de passe des services de couche Application

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Comment : réinitialiser manuellement le mot de passe des services de couche Application
Voir aussi
Image de liste déroulante

Cette procédure n'est pas disponible sur cette version du Guide de l'administrateur Team Foundation. La version la plus récente est disponible sur le site Web de Microsoft : http://go.microsoft.com/fwlink/?linkid=52459.

Voir aussi

Tâches

Comment : réinitialiser le mot de passe pour le pool d'applications

Autres ressources

Réinitialisation des mots de passe et des comptes de service


Comment : modifier le nom d'un compte de service

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Comment : modifier le nom d'un compte de service
Voir aussi
Image de liste déroulante

Cette procédure n'est pas disponible sur cette version du Guide de l'administrateur Team Foundation. La version la plus récente est disponible sur le site Web de Microsoft : http://go.microsoft.com/fwlink/?linkid=52459.

Voir aussi

Autres ressources

Réinitialisation des mots de passe et des comptes de service
Gestion des services et comptes de service Team Foundation Server


Gestion des données

Gestion des données
DropDown image

Cette rubrique contient des liens vers les rubriques expliquant comment gérer différents aspects de l'entrepôt de données Team Foundation Server.

Dans cette section

Attribution d'une taille limite aux pièces jointes

Décrit comment définir une taille limite sur les pièces jointes.

Synchronisation de la planification avec l'entrepôt de données

Explique comment planifier la synchronisation avec l'entrepôt de données.

Choix des outils de maintenance de Team Foundation Server

Détaille comment nettoyer des données Team Foundation Server.

Sauvegarde et restauration des données de Team Foundation Server

Répertorie des rubriques qui traitent de la sauvegarde et de la restauration de données Team Foundation Server.

Comment : configurer les paramètres d'administration de l'espace de travail

Détaille comment configurer des paramètres d'administration de l'espace de travail.

Comment : supprimer des fichiers orphelins de façon définitive

Explique comment supprimer définitivement des fichiers rendus orphelins.

Voir aussi

Autres ressources

Gestion de Team Foundation Server


Attribution d'une taille limite aux pièces jointes

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Attribution d'une taille limite aux pièces jointes
Voir aussi
Image de liste déroulante

Vous pouvez définir une limite de taille pour les pièces jointes aux éléments de travail dans Team Foundation Server. Selon les besoins de votre organisation et les restrictions de stockage de votre serveur Team Foundation, vous pouvez souhaiter limiter la taille autorisée des pièces jointes d'élément de travail. Vous pouvez également souhaiter augmenter la taille par défaut des pièces jointes.

Limites de taille

Par défaut, la limite de taille des pièces jointes d'élément de travail est de 4 096 kilo-octets. Pour plus d'informations sur la modification de la limite de taille des pièces jointes, consultez Comment : définir la taille maximale des pièces jointes pour les éléments de travail.

Considérez attentivement les implications avant de modifier la limite de taille par défaut des pièces jointes. La modification de la valeur de la limite des pièces jointes changera la limite de taille des pièces jointes de tous les utilisateurs Team Foundation Server. La valeur ne peut pas être modifiée pour un seul utilisateur ou un groupe d'utilisateurs. Le serveur Team Foundation Server possédera-t-il les capacités de stockage appropriées ? Si vous choisissez de restreindre la limite de taille des pièces jointes, quelles seront les implications sur le flux de travail de tout ou partie de vos utilisateurs ? Pour la plupart des organisations, la limite de taille par défaut sera probablement appropriée.

Voir aussi

Autres ressources

Gestion des données


Synchronisation de la planification avec l'entrepôt de données

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Synchronisation de la planification avec l'entrepôt de données
Voir aussi
Image de liste déroulante

Team Foundation Server vous permet de planifier la synchronisation entre les bases de données relationnelles et la base de données OLAP utilisées par le Reporting Services. Cette rubrique traite brièvement de l'organisation de l'entrepôt de données et de la synchronisation pour différentes topologies.

Organisation de l'entrepôt de données

L'entrepôt de données est une base de données relationnelle organisée dans un schéma en étoile avec une base de données OLAP dérivée de cette base de données. La base de données OLAP permet aux outils de création de rapports d'accéder aux informations dérivées sans diminuer les performances de la base de données relationnelle qui stocke réellement les informations en temps réel des clients.

L'entrepôt stocke plusieurs types de faits fournis par chacun des outils Team Foundation comme une table relationnelle principale et un cube dans la base de données OLAP qui sort de cette table. Chaque fait dans une table possède des détails, des dimensions et des mesures.

  • Détails Les détails sont des colonnes qui apparaissent dans la table de faits principale dans la base de données relationnelle et pas dans le cube OLAP. Par exemple, les titres d'élément de travail sont des chaînes de texte plus longues utilisées à l'origine dans les rapports de liste.

  • Dimensions Les dimensions sont les propriétés utilisées pour couper les données dans un rapport. Par exemple, les dimensions d'un fait Élément de travail incluent un Type et un État. Les dimensions apparaissent dans la base de données relationnelle en tant que tables avec des références de clé étrangère aux tables de dimensions de la table de faits principale. Tous les faits possèdent une dimension de projet qui peut être utilisée pour couper les données dans l'entrepôt par projet d'équipe.

  • Mesures Les mesures sont des propriétés qui sont regroupées, comptées, ajoutées, etc., afin de fournir des valeurs quantitatives dans les rapports. Par exemple, le cube CodeChurn fourni par l'outil de contrôle de code source inclut les mesures LinesAdded, LinesRemoved et LinesChanged. Les mesures apparaissent sous la forme de colonnes dans la table de faits principale.

Synchronisation

Les mises à jour se produisent à chaque chargement de données pour les modifications qui sont apportées au modèle de processus. Par défaut, l'entrepôt de données est mis à jour toutes les heures.

Vous pouvez contrôler la fréquence de mises à jour par la base de données OLAP des informations dérivées qu'elle fournit aux outils de création de rapports. La planification dépend des besoins de votre système. Pour plus d'informations, consultez Comment : définir l'intervalle de traitement pour l'entrepôt de données.

Voir aussi

Tâches

Comment : définir l'intervalle de traitement pour l'entrepôt de données

Autres ressources

Gestion des données


Choix des outils de maintenance de Team Foundation Server

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Choix des outils de maintenance de Team Foundation Server
Voir aussi
Image de liste déroulante

Team Foundation Server inclut des outils pour maintenir les données de votre serveur. Par exemple, vous pouvez utiliser tf pour supprimer des anciens jeux de réservations du contrôle de code source. Vous pouvez également utiliser les outils de défragmentation de base de données disponibles dans SQL Server.

Commandes de l'utilitaire en ligne de commande TFSAdminUtil

Décrit l'utilitaire en ligne de commande TFSAdminUtil et fournit des liens vers les rubriques sur ses commandes et leurs paramètres.

TFSDeleteProject, commande

Décrit les options et paramètres de TFSDeleteProject, un utilitaire en ligne de commande utilisé pour supprimer un projet d'équipe de Team System.

TFSFieldMapping

Décrit TFSFieldMapping, un utilitaire en ligne de commande utilisé pour modifier ou personnaliser le fichier XML de mappage de projet après la création d'un projet d'équipe.

witimport

Décrit witimport, un utilitaire en ligne de commande utilisé pour valider et importer un type d'élément de travail d'un fichier XML vers un projet d'équipe sur un serveur Team Foundation Server.

witexport

Décrit witexport, un utilitaire en ligne de commande utilisé pour exporter une définition XML pour un type d'élément de travail de Team Foundation Server.

glimport

Décrit glimport, un utilitaire en ligne de commande utilisé pour valider et importer des listes globales d'un fichier XML vers un projet d'équipe sur un serveur Team Foundation Server.

glexport

Décrit glexport, un utilitaire en ligne de commande utilisé pour exporter une définition XML pour les listes globales de Team Foundation Server.

SetupWarehouse

Décrit SetupWarehouse, un outil en ligne de commande utilisé pour régénérer le traitement analytique en ligne (OLAP) ou la base de données relationnelle.

Référence de la ligne de commande du contrôle de code source Team Foundation

Décrit les commandes disponibles avec l'utilitaire en ligne de commande tf.

Voir aussi

Autres ressources

Utilisation des outils de ligne de commande Team Foundation Server
Documentation en ligne de Microsoft SQL Server : Plans de maintenance
Documentation en ligne de Microsoft SQL Server : DBCC (Transact-SQL)


Sauvegarde et restauration des données de Team Foundation Server

Sauvegarde et restauration des données de Team Foundation Server
DropDown image

Vous devez créer régulièrement des sauvegardes pour les serveurs Team Foundation afin de pouvoir restaurer votre déploiement de Team Foundation Server dans son intégralité en cas de défaillance. La création de sauvegardes est un aspect clé de la protection de votre déploiement de Team Foundation contre les pertes. Lors de la restauration des serveurs et des données de Team Foundation, vous pouvez restaurer les données sur l'ordinateur d'où proviennent ces données ou il est possible que vous deviez restaurer les données sur un autre ordinateur.

Dans cette section

Sauvegarde du serveur Team Foundation Server

Décrit comment sauvegarder Team Foundation Server.

Restauration des sauvegardes de Team Foundation Server

Décrit comment restaurer les données de Team Foundation Server et de Team Foundation Server.

Référence

Planification de la sauvegarde et de la restauration

Planification de la récupération d'urgence

Rubriques connexes

Garantie de la disponibilité et du basculement de Team Foundation Server


Sauvegarde du serveur Team Foundation Server

Sauvegarde du serveur Team Foundation Server
DropDown image

Pour restaurer votre déploiement de Team Foundation dans son intégralité en cas de défaillance, le déploiement de Team Foundation requiert la création de sauvegardes pour chaque emplacement de stockage des données. La création de sauvegardes est un aspect clé de la protection de votre déploiement de Team Foundation contre les pertes.

Lorsque vous déployez Team Foundation, gardez une trace des comptes que vous créez, de tous les noms d'ordinateurs, mots de passe et options d'installation que vous choisissez. Conservez toujours une copie de toutes les sauvegardes de la documentation de récupération, des documents et des journaux de base de données et de transactions dans un emplacement hors du site.

Remarque Important

Effectuez périodiquement une tentative de restauration des données pour vérifier que vos fichiers sont correctement sauvegardés. Une tentative de restauration peut révéler des problèmes matériels qui n'apparaissent pas avec les vérifications logicielles.

Lorsque vous sauvegardez et que vous restaurez une base de données, vous devez sauvegarder les données sur des supports (des bandes et des disques, par exemple). Votre plan de sauvegarde doit inclure des dispositions de gestion des supports, telles que :

  • un plan de suivi et de gestion pour stocker et recycler des jeux de sauvegarde ;

  • un calendrier de remplacement des supports de sauvegarde ;

  • dans un environnement multi-serveur, le choix d'utiliser des sauvegardes centralisées ou distribuées ;

  • un moyen de suivi de la durée de vie des supports ;

  • une procédure permettant de réduire les effets de la perte d'un jeu de sauvegarde ou d'un support de sauvegarde (une bande, par exemple) ;

  • le choix de stocker des jeux de sauvegarde sur place ou en dehors du site, et une analyse de la répercution de ce choix sur le temps de récupération.

Pour se protéger contre un incident, tel qu'un feu ou un tremblement de terre, conservez des doubles de vos sauvegardes de serveurs dans un emplacement différent de l'emplacement des serveurs. Cela permet de se protéger contre la perte de données critiques. La méthode conseillée est de garder trois copies du support de sauvegarde et de conserver au moins une copie en dehors du site dans un environnement correctement contrôlé.

Étant donné que les données Team Foundation sont stockées dans des bases de données SQL Server, vous ne devez pas sauvegarder les ordinateurs sur lesquels les clients Team Foundation sont installés. Si une défaillance de support ou un incident impliquant ces ordinateurs devait se produire, la réinstallation de Team Foundation fournit une alternative plus propre et plus fiable pour restaurer une sauvegarde.

Vous pouvez sauvegarder un serveur à l'aide de SQL Server pour sauvegarder les bases de données relatives à votre déploiement de Team Foundation.

Une sauvegarde complète de la base de données est nécessaire pour pouvoir récupérer votre déploiement. Une sauvegarde complète inclut des portions du journal des transactions afin que la sauvegarde complète puisse être récupérée. Les sauvegardes complètes sont indépendantes ; elles représentent l'intégralité de la base de données au moment de la sauvegarde. Pour plus d'informations, consultez Full Backups.

Sous le modèle de sauvegarde de la base complète, des sauvegardes régulières de vos journaux de transactions sont essentielles pour pouvoir récupérer des données. Avec les sauvegardes des journaux de transactions, vous pouvez récupérer la base de données au moment de la panne ou à un moment spécifique.

Le journal des transactions est un enregistrement série de tous les changements qui se sont produits dans une base de données en plus de la transaction qui a exécuté chaque changement. Le journal des transactions enregistre le démarrage de chaque transaction. Il enregistre les modifications apportées aux données et, si nécessaire, suffisamment d'informations pour annuler les changements apportés pendant chaque transaction. Le journal grandit continuellement au fur et à mesure que les opérations enregistrées se produisent dans la base de données.

Les sauvegardes des journaux de transactions vous permettent de récupérer la base de données à un moment antérieur, par exemple, avant d'entrer des données non désirées, ou au moment d'une défaillance. Outre les sauvegardes de la base, les sauvegardes des journaux de transactions doivent faire partie de votre stratégie de récupération. Pour plus d'informations, consultez Using Transaction Log Backups.

Les sauvegardes des journaux de transactions utilisent généralement moins de ressources que les sauvegardes complètes. Par conséquent, vous pouvez créer des sauvegardes de journaux de transactions plus fréquemment que des sauvegardes complètes, réduisant ainsi le risque de perdre des données. Toutefois, il arrive qu'une sauvegarde des journaux de transactions soit plus grande qu'une sauvegarde complète. Prenons l'exemple d'une base de données ayant un taux de transaction élevé ; un taux de transaction élevé provoque un agrandissement rapide du journal des transactions. Dans ce cas, créez des sauvegardes des journaux de transactions plus fréquemment. Pour plus d'informations, consultez Managing a Full Transaction Log.

Il existe trois types de sauvegardes de journaux de transactions :

  • Une sauvegarde ponctuelle d'un journal de transactions contient uniquement les enregistrements des journaux de transactions pour un intervalle sans les modifications en bloc.

  • Une sauvegarde des journaux en bloc inclut des pages de journaux et des ensembles de données modifiés par les opérations en bloc. La récupération à un moment précis n'est pas possible.

  • Une sauvegarde de fichier journal après défaillance est récupérée à partir d'une base de données peut-être endommagée afin de conserver les enregistrements du journal qui n'ont pas encore été sauvegardés. Une sauvegarde de fichier journal après défaillance est effectuée après une défaillance pour empêcher une perte du travail et peut contenir des données de journal ponctuelles ou en bloc.

Le seul moment pendant lequel une sauvegarde complète doit être synchronisée avec les sauvegardes des journaux de transactions est lorsque vous démarrez une séquence de sauvegardes de journaux des transactions. Chaque séquence de sauvegardes des journaux de transactions doit être précédée par une sauvegarde complète ou une sauvegarde différentielle complète. Dans SQL Server 2005, vous pouvez sauvegarder le journal après la première sauvegarde complète pendant qu'une sauvegarde complète est effectuée. Pour plus d'informations sur la création de sauvegardes de journaux, consultez Creating Transaction Log Backups.

Dans cette section

Comment : sauvegarder un serveur Team Foundation Server

Explique les étapes permettant de créer un plan de maintenance pour sauvegarder les bases de données Team Foundation Server.

Voir aussi

Tâches

Comment : sauvegarder un serveur Team Foundation Server

Concepts

Planification de la sauvegarde et de la restauration

Autres ressources

Sauvegarde et restauration des données de Team Foundation Server
Full Backups
Using Transaction Log Backups
Creating Transaction Log Backups


Comment : sauvegarder un serveur Team Foundation Server

Comment : sauvegarder un serveur Team Foundation Server

Pour sauvegarder un serveur Team Foundation Server, vous devez :

  • Créer un plan de maintenance qui sauvegarde toutes les bases de données Team Foundation.

  • Sauvegarder la clé de chiffrement de Report Server.

La couche Données de Team Foundation Server est distribuée parmi plusieurs bases de données SQL Server et les sites de portail de projet d'équipe individuels. Pour sauvegarder les données Team Foundation Server, utilisez les outils de sauvegarde fournis avec SQL Server 2005 ; notamment, SQL Server Management Studio pour sauvegarder les bases de données. Pour plus d'informations, consultez Getting Started with Backup and Restore.

À l'aide de SQL Server Management Studio, vous pouvez choisir de sauvegarder manuellement les bases de données ou de créer un travail planifié qui effectue les sauvegardes de plusieurs bases de données dans le cadre d'un plan de maintenance qui peut être défini pour être exécuté automatiquement à un moment prédéterminé ou à des intervalles prévus.

Le tableau suivant répertorie les bases de données de Team Foundation Server :

Base de données Description

ReportServer

La base de données Reporting Services contient les rapports et paramètres de rapport de Reporting Services.

ReportServerTempDB

La base de données temporaire Reporting Services est utilisée pour stocker des informations temporaires permettant d'exécuter des rapports spécifiques à Reporting Services.

STS_Config

La base de données de configuration de SharePoint contient les informations d'installation et de configuration pour le site du projet d'équipe SharePoint.

STS_SERVERNAME

La base de données SharePoint comprend le contenu réel dans le site SharePoint de l'équipe.

TfsBuild

La base de données de génération contient des données de génération (Team Foundation Build) et des résultats des tests publiés.

TfsIntegration

Projets, zones, itérations et autres données d'inscription.

TfsVersionControl

Base de données contenant le contrôle de code source Team Foundation.

TFSWarehouse

Base de données Analysis Services.

Remarque Remarque

Le cube de données Analysis Services n'est pas sauvegardé parce que vous pouvez recréer le cube à partir de la base de données TFSWarehouse restaurée.

TfsWorkItemTracking

Base de données de suivi des éléments de travail Team Foundation.

TfsWorkItemTrackingAttachments

Base de données de pièces jointes de suivi des éléments de travail Team Foundation.

Pour créer un plan de maintenance qui sauvegarde toutes les bases de données Team Foundation Server

  1. Tout d'abord, vous devez choisir une stratégie de sauvegarde de votre base de données. Pour plus d'informations, consultez Choosing a Recovery Strategy That Supports Your Applications.

    Cette procédure explique comment planifier des sauvegardes complètes et incrémentielles. Si vous souhaitez exécuter les deux types de sauvegardes, vous devez suivre deux fois les étapes de cette procédure : une fois pour la sauvegarde complète et une autre fois pour la sauvegarde incrémentielle. Pour plus d'informations, consultez Creating Transaction Log Backups.

    Remarque Remarque

    En général, les sauvegardes complètes et incrémentielles sont exécutées à des heures différentes afin d'obtenir une protection des données maximale.

  2. Sur le serveur de couche Données Team Foundation, ouvrez SQL Server Management Studio. Vous l'ouvrez en général en cliquant sur Démarrer, sur Tous les programmes, sur Microsoft SQL Server, puis sur SQL Server Management Studio.

  3. Sélectionnez Moteur de base de données pour le Type de serveur. Sélectionnez le Nom du serveur et le schéma d'Authentification appropriés à votre serveur. Fournissez un Nom d'utilisateur et un Mot de passe valables si votre serveur SQL Server l'exige, puis cliquez sur Se conn..

  4. Développez le nœud Gestion.

  5. Cliquez avec le bouton droit sur Plans de maintenance et sélectionnez Assistant Plan de maintenance.

  6. Cliquez sur Suivant dans la page d'accueil de l'Assistant Plan de maintenance.

  7. Sur la page Sélectionner un serveur cible, indiquez un Nom pour ce plan de maintenance.

    • Pour une sauvegarde complète, vous pouvez utiliser TfsFullDataBackup comme nom.

    • Pour une sauvegarde incrémentielle, vous pouvez utiliser TfsIncrementalDataBackup comme nom.

  8. Sélectionnez le serveur et le schéma d'authentification appropriés à votre SQL Server. Indiquez un Nom d'utilisateur et un Mot de passe si votre serveur SQL Server l'exige, puis cliquez sur Suivant.

  9. Sur la page Sélectionner des tâches de maintenance, sélectionnez la tâche de maintenance.

    • Pour une sauvegarde complète, sélectionnez Sauvegarder la base de données (complète).

    • Pour une sauvegarde incrémentielle, sélectionnez Sauvegarder la base de données (journal des transactions).

  10. Cliquez sur Suivant sur la page Sélectionner des tâches de maintenance.

  11. Cliquez sur Suivant sur la page Sélectionner l'ordre des tâches de maintenance.

  12. Dans la liste déroulante Bases de données sous Sélectionnez-en un ou plusieurs, sélectionnez Toutes les bases de données utilisateur, puis cliquez sur OK.

  13. Sélectionnez les options de destination souhaitées pour votre sauvegarde. Reportez-vous à la documentation en ligne SQL Server 2005 pour les informations détaillées à propos des options de cette boîte de dialogue. (Sélectionnez la boîte de dialogue Assistant Plan de maintenance et appuyez sur F1 pour obtenir l'aide spécifique à la boîte de dialogue.)

    Remarque Remarque

    Assurez-vous que les fichiers de sauvegarde sont stockés sur un autre ordinateur sécurisé.

  14. Cliquez sur Suivant.

  15. Cliquez sur Modifier dans la page Sélectionner les propriétés de plan pour ouvrir la boîte de dialogue Nouvelle planification du travail.

  16. Indiquez un nom pour le travail de sauvegarde.

    • Pour une sauvegarde complète, vous pouvez utiliser ScheduledFullBackup comme nom.

    • Pour une sauvegarde incrémentielle, vous pouvez utiliser ScheduledIncrementalBackup comme nom.

  17. Laissez Périodique pour le Type de planification et conservez la case à cocher Activé sélectionnée.

  18. Définissez les options Fréquence et Fréquence quotidienne souhaitées pour votre plan de sauvegarde.

    Remarque Remarque

    En général, les heures de début pour les sauvegardes complètes et incrémentielles sont différentes.

  19. Laissez la valeur Aucune date de fin pour la Durée.

  20. Cliquez sur OK, puis sur Suivant.

  21. Sélectionnez les options de diffusion des rapports désirées sur la page Sélectionner des options de rapport.

  22. Cliquez sur Next.

  23. Cliquez sur Terminer pour terminer la création du plan de maintenance.

    Le serveur SQL sauvegardera les bases de données spécifiées dans le plan de maintenance selon la fréquence que vous avez spécifiée.

    Remarque Remarque

    Si vous projetez de faire des sauvegardes complètes et incrémentielles, suivez deux fois les étapes de cette procédure : une fois pour la sauvegarde complète et une autre fois pour la sauvegarde incrémentielle.

Pour sauvegarder la clé de chiffrement de Report Server

  1. Sur le serveur de couche Données de Team Foundation, ouvrez l'outil de configuration de SQL Reporting Services.

    Vous l'ouvrez en général en cliquant sur Démarrer, sur Tous les programmes, sur Microsoft SQL Server, sur Outils de configuration, puis sur Configuration de Reporting Services.

  2. Entrez le nom d'ordinateur de couche Données et l'instance de base de données dans la boîte de dialogue Sélection de l'instance d'installation de Report Server.

  3. Dans la barre de navigation gauche, cliquez sur Clés de chiffrement.

  4. Cliquez sur Sauvegarder.

    La boîte de dialogue Informations sur la clé de chiffrement s'ouvre.

  5. Tapez un mot de passe dans la zone Mot de passe.

  6. Cliquez sur le bouton de sélection Fichier de clé.

    La boîte de dialogue Enregistrer sous s'ouvre.

  7. Indiquez le nom du fichier pour stocker la clé de chiffrement de Report Server, puis cliquez sur OK pour fermer la boîte de dialogue Enregistrer sous.

  8. Cliquez sur OK pour fermer la boîte de dialogue Informations sur la clé de chiffrement.

Sécurité

Assurez-vous de stocker vos sauvegardes dans un emplacement sécurisé. Vous ne devez pas stocker vos fichiers de sauvegarde sur le même serveur que celui que vous venez de sauvegarder.

L'autorisation d'effectuer des sauvegardes et de créer des plans de maintenance sur le serveur SQL Server est requise pour effectuer les tâches décrites dans cette rubrique.

Voir aussi

Concepts

Comment : restaurer les données de Team Foundation Server

Autres ressources

Getting Started with Backup and Restore
Choosing a Recovery Strategy That Supports Your Applications
Gestion des données
Gestion des serveurs de couche Données dans Team Foundation Server
Gestion de Team Foundation Server


Restauration des sauvegardes de Team Foundation Server

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Restauration des sauvegardes de Team Foundation Server
Voir aussi
Image de liste déroulante

Les restaurations complètes de Team Foundation Server à partir de sauvegardes ne sont normalement pas requises. Toutefois, vous devez songer à tester fréquemment les restaurations pour garantir l'intégrité de vos sauvegardes.

Dans cette section

Comment : restaurer les données de Team Foundation Server

Décrit comment restaurer des données de Team Foundation Server sur le même serveur Team Foundation Server duquel elles sont originaires.

Comment : restaurer les données de Team Foundation Server vers un autre serveur

Décrit comment restaurer des données de Team Foundation Server vers un emplacement de serveur Team Foundation Server différent.

Voir aussi

Concepts

Planification de la sauvegarde et de la restauration

Autres ressources

Sauvegarde et restauration des données de Team Foundation Server


Comment : restaurer les données de Team Foundation Server

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Comment : restaurer les données de Team Foundation Server
Voir aussi
Image de liste déroulante

Cette rubrique décrit comment restaurer un serveur de couche Données de Team Foundation Server. Vous pouvez également utiliser ce type de restauration pour restaurer un serveur de couche Données actif d'un état altéré au dernier état correct. Cette restauration est utile si les données du serveur s'altèrent et doivent être réinitialisées et que le serveur lui-même fonctionne encore correctement. Si vous devez restaurer les données à un autre serveur de couche Données, consultez Comment : restaurer les données de Team Foundation Server vers un autre serveur.

Remarque Remarque

Les instructions de cette rubrique requièrent un démarrage avec un serveur de couche Données actif depuis lequel la sauvegarde a été effectuée.

Pour restaurer des données de Team Foundation Server, exécutez les procédures suivantes :

  • Préparez les serveurs pour restaurer les données.

  • Restaurez les bases de données Team Foundation.

  • Restaurez la base de données Analysis Server.

  • Restaurez les sites portail de projet d'équipe.

  • Redémarrez les serveurs.

  • Faites en sorte que les clients actualisent leurs données de cache.

La couche Données de Team Foundation Server est distribuée parmi plusieurs bases de données SQL Server et les sites de portail de projet d'équipe individuels. Pour retirer les données de Team Foundation Server, utilisez les outils de restauration fournis avec SQL Server 2005, et spécifiquement SQL Server Management Studio pour restaurer les bases de données. Pour plus d'informations, consultez Getting Started with Backup and Restore et Gestion des services SQL Server.

Le tableau suivant répertorie les bases de données Team Foundation Server :

Base de données Description

ReportServer

La base de données Reporting Services contient les rapports et paramètres de rapport de Reporting Services.

ReportServerTempDB

La base de données temporaire Reporting Services est utilisée pour stocker des informations temporaires permettant d'exécuter des rapports spécifiques à Reporting Services.

STS_Config

La base de données de configuration de Windows SharePoint contient les informations d'installation et de configuration pour le site du projet d'équipe SharePoint.

Remarque Remarque

Ne restaurez pas la base de données STS-Config, utilisez la base de données par défaut installée sur le serveur de couche Données.

STS_SERVERNAME

La base de données SharePoint comprend le contenu réel dans le site SharePoint de l'équipe.

TfsBuild

La base de données de génération contient des données de génération (Team Foundation Build) et des résultats des tests publiés.

TfsIntegration

Projets, zones, itérations et autres données d'inscription.

TfsVersionControl

Base de données contenant le contrôle de code source Team Foundation.

TFSWarehouse

Base de données Analysis Services.

Remarque Remarque

Le cube de données Analysis Services n'est pas sauvegardé parce que vous pouvez recréer le cube à partir de la base de données TFSWarehouse restaurée.

TfsWorkItemTracking

Base de données de suivi des éléments de travail Team Foundation.

TfsWorkItemTrackingAttachments

Base de données de pièces jointes de suivi des éléments de travail Team Foundation.

Procédures

Pour préparer les serveurs à des fins de restauration des données

  1. Sur le serveur de couche Données Team Foundation, ouvrez une invite de commandes.

  2. À l'invite de commandes, tapez :

    iisreset /stop

    Cette commande arrête les services (IIS) sur le serveur de couche Données.

  3. Sur le serveur de couche Application Team Foundation, ouvrez une invite de commandes.

  4. À l'invite de commandes, tapez :

    iisreset /stop

    Cette commande arrête les services IIS sur le serveur de couche Application.

Pour restaurer les bases de données Team Foundation

  1. Sur le serveur de couche Données Team Foundation, ouvrez SQL Server Management Studio. Vous l'ouvrez en général en cliquant sur Démarrer, sur Tous les programmes, sur Microsoft SQL Server, puis sur SQL Server Management Studio.

    Remarque Remarque

    Pour plus d'informations sur la restauration de bases de données, consultez Implementing Restore Scenarios.

  2. Sélectionnez Moteur de base de données pour le Type de serveur. Sélectionnez le modèle de Nom du serveur et de Authentification propre à votre serveur. Fournissez un Nom d'utilisateur et un Mot de passe valables si votre serveur SQL Server l'exige, puis cliquez sur Se conn..

  3. Développez le nœud Bases de données pour afficher la liste des bases de données qui constituent la couche Données de Team Foundation Server.

  4. Restaurez chacune des bases de données suivantes :

    • ReportServer

    • ReportServerTempDB

    • STS_SERVERNAME

    • TfsBuild

    • TfsIntegration

    • TfsVersionControl

    • TfsWarehouse

    • TfsWorkItemTracking

    • TfsWorkItemTrackingAttachments

      Remarque Remarque

      Ne restaurez pas la base de données STS-Config, utilisez la base de données installée sur le serveur de couche Données.

    Suivez les étapes décrites dans la procédure suivante pour restaurer chaque base de données.

Pour restaurer une base de données

  1. Cliquez avec le bouton droit sur la base de données que vous souhaitez restaurer, pointez sur Tâches, sur Restaurer, puis cliquez sur Base de données.

  2. Dans la boîte de dialogue Restaurer la base de données, sélectionnez À partir de l'unité dans la zone Source de restauration, puis cliquez sur le bouton d'ellipses (...).

  3. Dans la boîte de dialogue Spécifier la sauvegarde, remplissez les informations pour spécifier l'emplacement du fichier de sauvegarde.

    La première sauvegarde que vous appliquez doit être une sauvegarde complète, suivie par les sauvegardes du journal des transactions dans l'ordre où ils ont été créés.

  4. Cliquez sur OK pour refermer la boîte de dialogue Spécifier la sauvegarde.

  5. Dans la zone Sélectionnez les jeux de sauvegarde à restaurer, sélectionnez les jeux de sauvegarde à restaurer.

  6. Sélectionnez Options dans le volet de navigation gauche.

  7. Sélectionnez la zone Remplacer la base de données existante.

  8. Assurez-vous que les chemins d'accès spécifiés dans la zone Restaurer les fichiers de la base de données en tant que correspondent à vos chemins d'accès à la base de données actuels. Il est important que vous restauriez la base de données sur un lecteur différent.

  9. Sélectionnez l'état approprié dans la zone État de récupération.

  10. Si vous n'appliquez pas de journaux des transactions supplémentaires, sélectionnez Laisser la base de données opérationnelle.

    Si vous appliquez des journaux des transactions supplémentaires, Laisser la base de données non opérationnelle.

  11. Cliquez sur OK pour fermer la boîte de dialogue Restaurer la base de données et restaurer la base de données.

  12. Si vous appliquez des journaux des transactions supplémentaires, suivez cette procédure pour chaque sauvegarde de journal, dans l'ordre où ils ont été créés, en démarrant à partir du journal fait après la sauvegarde complète. Pour plus d'informations, consultez Applying Transaction Log Backups.

  13. Répétez cette procédure pour chaque base de données répertoriée dans la procédure antérieure.

    Attention Attention

    Toutes les bases de données doivent être restaurées en même temps pour ne pas être altérées.

Pour restaurer la base de données Analysis Server

  1. Sur le serveur de couche Données Team Foundation, ouvrez une invite de commandes.

  2. À partir de l'invite de commandes, naviguez jusqu'au répertoire des fichiers programme, puis tapez :

    cd Microsoft Visual Studio 2005 Team Foundation Server\Tools

  3. À l'invite de commandes, tapez :

    net stop TfsServerScheduler

  4. Cette commande arrête le planificateur.

  5. À l'invite de commandes, tapez :

    setupwarehouse -o -s serverName -d TfsWarehouse -c warehouseschema.xml -ra serviceAccount -a serviceAccount

    Cette commande régénère le cube de données Analysis Services à partir de la base de données TFSWarehouse sous-jacente. Pour plus d'informations, consultez SetupWarehouse.

    Par défaut, le compte de service serviceAccount de Team Foundation Server est domain\BISSVC. Pour plus d'informations, consultez Gestion des services et comptes de service Team Foundation Server.

  6. Ouvrez SQL Server Management Studio. Vous l'ouvrez en général en cliquant sur Démarrer, sur Tous les programmes, sur Microsoft SQL Server, puis sur SQL Server Management Studio.

  7. Sélectionnez Analysis Server pour le Type de serveur. Sélectionnez le modèle de Nom du serveur et de Authenfication propre à votre serveur. Fournissez un Nom d'utilisateur et un Mot de passe valables si votre serveur SQL Server l'exige, puis cliquez sur Se conn..

  8. Développez le nœud Bases de données pour afficher la liste des bases de données qui constituent la couche Données de Team Foundation Server.

  9. Cliquez avec le bouton droit sur la base de données TFSWarehouse, puis cliquez sur Processus.

  10. Cliquez sur OK dans la boîte de dialogue Traiter la base de données.

    Cette fonctionnalité traite l'entrepôt.

  11. À l'invite de commandes, tapez :

    net start TfsServerScheduler

    Cette commande démarre le planificateur.

    Remarque Remarque

    Si vous avez les données supplémentaires sauvegardées qui doivent être restaurées, suivez les étapes appropriées pour restaurer ces données. Par exemple, vous pouvez avoir d'autres bases de données SQL ou sites de Windows SharePoint à restaurer.

Redémarrage des serveurs

Si vous restaurez des données sur un serveur différent, vous devez exécuter des étapes supplémentaires avant de redémarrer le serveur de données. Pour plus d'informations, consultez Comment : restaurer les données de Team Foundation Server vers un autre serveur.

Remarque Remarque

Ne redémarrez pas maintenant les serveurs si vous restaurez des données sur un serveur différent.

Pour redémarrer les serveurs

  1. Sur le serveur de couche Données Team Foundation, ouvrez une invite de commandes.

  2. À l'invite de commandes, tapez :

    iisreset /start

    Cette commande redémarre les services IIS sur le serveur de couche Données.

  3. Sur le serveur de couche Application de Team Foundation, ouvrez une invite de commandes.

  4. À l'invite de commandes, tapez :

    iisreset /start

    Cette commande redémarre les services IIS sur le serveur de couche Application.

Pour que les clients actualisent leurs données de cache

  1. Sur le serveur de couche Application Team Foundation, ouvrez Internet Explorer.

  2. Dans la barre d'adresses, tapez :

    http:// applicationTierServerName :8080/WorkItemTracking/v1.0/ClientService.asmx

    Vous serez ainsi connecté au service Web ClientService.

  3. Sélectionnez la méthode Web StampWorkitemCache.

  4. Cliquez sur Appeler.

    Les clients réinitialisent ainsi leur cache de suivi des éléments de travail la prochaine fois qu'ils se connectent à la couche Application.

Sécurité

Des autorisations pour restaurer des bases de données, arrêter et démarrer des services IIS sont requises pour effectuer les tâches décrites dans cette rubrique. Pour vider le cache client, vous devez être membre du groupe d'administration de TFS.

Voir aussi

Tâches

Comment : sauvegarder un serveur Team Foundation Server

Autres ressources

Getting Started with Backup and Restore
Choosing a Recovery Strategy That Supports Your Applications
Gestion des données
Gestion des serveurs de couche Données dans Team Foundation Server
Gestion de Team Foundation Server


Comment : restaurer les données de Team Foundation Server vers un autre serveur

Comment : restaurer les données de Team Foundation Server vers un autre serveur
Voir aussi

Cette rubrique décrit comment restaurer des données de la couche Données Team Foundation Server sur un autre serveur de couche Données. Vous pouvez également utiliser ce type de restauration pour déplacer les données du serveur d'origine vers un nouveau serveur. Cette fonction est utile lors du déplacement de la couche Données vers un nouveau serveur, notamment lors d'une mise à niveau ou d'une défaillance du serveur d'origine. Si vous devez restaurer les données sur le serveur de couche Données d'origine, consultez Comment : restaurer les données de Team Foundation Server.

Remarque Remarque

Les instructions de cette rubrique requièrent l'utilisation d'un serveur possédant une installation récente de la couche Données Team Foundation Server. Pour plus d'informations, consultez le Guide d'installation Team Foundation. La version la plus récente du Guide d'installation Team Foundation est disponible en ligne à l'adresse http://go.microsoft.com/fwlink/?linkid=40042.

Pour restaurer un serveur Team Foundation Server sur un serveur autre que celui qui a fournit la sauvegarde, vous devez effectuer les opérations suivantes :

  • Restaurer les données.

  • Renommer la couche Données.

  • Restaurer les chaînes de connexion sur le serveur de rapports

  • Redémarrer les serveurs.

  • Demander aux clients d'actualiser leurs données de cache des éléments de travail.

Pour restaurer les données

  • Consultez Comment : restaurer les données de Team Foundation Server.

Pour renommer la couche Données

  1. Sur le serveur de couche Application de Team Foundation, ouvrez une invite de commandes.

    Remarque Remarque

    Cette procédure est nécessaire uniquement si le nom du serveur de couche Données Team Foundation a changé.

  2. À partir de l'invite de commandes, naviguez jusqu'au répertoire des fichiers programme, puis tapez :

    cd Microsoft Visual Studio 2005 Team Foundation Server\Tools

  3. À l'invite de commandes, tapez :

    TfsAdminUtil renamedt newDataTierMachineName

    Remarque Remarque

    Si IIS est actif sur le serveur de couche Application, vous serez invité à arrêter IIS.

    L'utilitaire TfsAdminUtil met à jour sur l'ordinateur de couche Données les chaînes de connexion et les autres références présentes sur la couche Application. Pour plus d'informations, consultez Commandes de l'utilitaire en ligne de commande TFSAdminUtil.

Pour restaurer les chaînes de connexion sur le serveur de rapports

  1. Sur le serveur de couche Application Team Foundation, ouvrez Internet Explorer.

  2. Dans la barre d'adresses, tapez http://applicationTierServerName/reports.

  3. Sur le site du rapport de serveurs, cliquez sur TfsOlapReportDS.

    1. Vérifiez que les informations de connexion contenues dans la zone de texte Chaîne de connexion sont correctes :

      Data source= newDataTierServerName ;initial catalog=TfsWarehouse

    2. Sélectionnez Informations d'identification stockées de manière sécurisée sur le serveur de rapports.

    3. Entrez le domaine\compte et le mot de passe pour le serveur de rapports du service TFSREPORTS (comme décrit dans le Guide d'installation).

    4. Sélectionnez Utiliser comme informations d'identification Windows lors de la connexion à la source de données.

  4. Procédez de même pour TfsReportDS.

    1. Vérifiez que les informations de connexion contenues dans la zone de texte Chaîne de connexion sont correctes :

      Data source= newDataTierServerName ;initial catalog=TfsWarehouse

    2. Sélectionnez Informations d'identification stockées de manière sécurisée sur le serveur de rapports.

    3. Entrez domaine\compte et le mot de passe pour le service TFSREPORTS du serveur de rapports (comme décrit dans le Guide d'installation).

    4. Sélectionnez Utiliser comme informations d'identification Windows lors de la connexion à la source de données.

Pour redémarrer les serveurs

  1. Sur le serveur de couche Données Team Foundation, ouvrez une invite de commandes.

  2. À l'invite de commandes, tapez :

    iisreset /start

    Cette commande redémarre les services IIS sur le serveur de couche Données.

  3. Sur le serveur de couche Application Team Foundation, ouvrez une invite de commandes.

  4. À l'invite de commandes, tapez :

    iisreset /start

    Cette commande redémarre les services IIS sur le serveur de couche Application.

Pour demander aux clients d'actualiser leurs données de cache des éléments de travail

  1. Sur le serveur de couche Application Team Foundation, ouvrez Internet Explorer.

  2. Dans la barre d'adresses, tapez :

    http:// applicationTierServerName :8080/WorkItemTracking/v1.0/ClientService.asmx

    Vous serez ainsi connecté au service Web ClientService.

  3. Sélectionnez la méthode Web StampWorkitemCache.

  4. Cliquez sur Appeler.

    Les clients réinitialisent ainsi automatiquement leur cache de suivi des éléments de travail la prochaine fois qu'ils se connectent à la couche Application.

Sécurité

L'autorisation d'effectuer des sauvegardes et de créer des plans de maintenance sur le serveur SQL est requise pour effectuer les tâches décrites dans cette rubrique. Pour vider le cache client, vous devez être membre du groupe d'administration de TFS.

Voir aussi

Tâches

Comment : sauvegarder un serveur Team Foundation Server

Autres ressources

Gestion des données
Gestion des serveurs de couche Données dans Team Foundation Server
Gestion de Team Foundation Server


Comment : configurer les paramètres d'administration de l'espace de travail

Comment : configurer les paramètres d'administration de l'espace de travail
Voir aussi

Un espace de travail représente la copie côté client des fichiers et dossiers présents sur le serveur de contrôle de code source. Lorsque les utilisateurs ajoutent, modifient, suppriment, déplacent, renomment ou gèrent un élément sous contrôle de code source, ces modifications persistent ou sont marquées en tant que modifications en attente dans l'espace de travail. Pour des raisons administratives, les administrateurs Team Foundation Server peuvent devoir créer ou supprimer des espaces de travail pour d'autres utilisateurs, annuler une modification en attente dans l'espace de travail d'un autre utilisateur ou annuler un verrouillage dans l'espace de travail d'un autre utilisateur. Vous pouvez utiliser des commandes du contrôle de code source de Team Foundation pour effectuer ces tâches.

Pour créer un espace de travail pour un utilisateur

  1. Cliquez sur Démarrer et sur Tous les programmes, pointez sur Microsoft Visual Studio 2005 et sur Visual Studio Tools, puis cliquez sur Invite de commandes de Visual Studio.

  2. Tapez mkdir path, où path est l'emplacement d'un répertoire dans lequel vous souhaitez que l'utilisateur stocke une copie personnelle des fichiers sur le serveur de contrôle de code source. Pour des raisons administratives, déterminez si vous souhaitez créer ce répertoire sur une ressource partagée.

    Remarque Remarque

    Le chemin d'accès doit inclure le nom du répertoire que vous souhaitez ajouter. Vous devez placer le chemin d'accès entre guillemets si le nom du chemin d'accès contient des espaces. Par exemple, si l'emplacement du répertoire est D:\Mes projets et si le répertoire que vous souhaitez ajouter est nommé Application Windows, vous devez taper mkdir "D:\Mes projets\Application Windows".

  3. Tapez cd path, où path est le nom du répertoire que vous venez de créer.

  4. Tapez tf workspace /new /s:servername, où servername est le nom du serveur Team Foundation Server, puis appuyez sur ENTRÉE.

  5. Dans la boîte de dialogue Créer un espace de travail, renseignez la zone Nom et cliquez sur OK.

Pour supprimer un espace de travail pour un utilisateur

  1. Cliquez sur Démarrer et sur Tous les programmes, pointez sur Microsoft Visual Studio 2005 et sur Visual Studio Tools, puis cliquez sur Invite de commandes de Visual Studio.

  2. Tapez cd path, où path est le nom du répertoire qui contient l'espace de travail que vous souhaitez supprimer.

  3. Tapez tf workspace /delete [/s:servername] workspacename, où servername est le nom du serveur Team Foundation Server et workspacename est le nom de l'espace de travail que vous souhaitez supprimer.

Modification d'espaces de travail existants

Les espaces de travail sont utilisés pour stocker et synchroniser des copies locales d'éléments de contrôle de code source de Team Foundation. Vous pouvez modifier ces espaces de travail en modifiant la propriété de l'espace de travail, en autorisant d'autres utilisateurs à accéder à l'espace de travail et en modifiant d'autres paramètres.

Pour modifier un espace de travail

  1. Cliquez sur Démarrer, sur Tous les programmes et cliquez vers Microsoft Visual Studio 2005.

  2. Dans le menu Fichier, choisissez Contrôle de code source, puis Espaces de travail.

  3. Dans la boîte de dialogue Gérer les espaces de travail, dans la colonne Nom, mettez en surbrillance l'espace de travail que vous souhaitez modifier et cliquez sur Modifier.

  4. Dans la boîte de dialogue Modifier l'espace de travail, vous pouvez effectuer les tâches suivantes si nécessaire :

    1. Modifiez le nom dans la zone de texte Nom.

    2. Spécifiez d'autres valeurs Propriétaire et Nom de l'ordinateur, si nécessaire.

    3. Entrez un commentaire qui décrit les modifications apportées à l'espace de travail dans la zone Commentaire.

    4. Modifiez les dossiers de travail. Pour plus d'informations, consultez Comment : créer un espace de travail.

    5. Cliquez sur OK pour enregistrer les modifications.

    Remarque Conseil

    Une fois l'espace de travail établi, cliquez avec le bouton droit sur l'espace de travail et utilisez la commande Obtenir la dernière version pour remplir votre espace de travail avec la source du serveur.

  5. Dans la boîte de dialogue Gérer les espaces de travail, cliquez sur Fermer.

Annulation de modifications en attente

Vous pouvez annuler les modifications en attente dans l'espace de travail d'un autre utilisateur en utilisant la commande undo.

Pour annuler une modification en attente dans l'espace de travail d'un autre utilisateur

  1. Cliquez sur Démarrer et sur Tous les programmes, pointez sur Microsoft Visual Studio 2005 et sur Visual Studio Tools, puis cliquez sur Invite de commandes de Visual Studio.

  2. Tapez cd path, où path est l'emplacement du répertoire qui contient l'espace de travail de l'utilisateur.

  3. Tapez tf undo FolderOrFilename où FolderOrFilename est le nom du fichier ou du dossier pour lequel vous souhaitez annuler des modifications en attente, puis appuyez sur ENTRÉE.

    Remarque Remarque

    Si vous utilisez la commande undo pour annuler une modification en attente dans l'espace de travail d'un autre utilisateur, vous devez exécuter une opération get dans cet espace de travail pour mettre à jour le disque local. Non seulement get doit être exécuté, mais il peut être nécessaire d'exécuter get /all pour les fichiers qui ont été annulés afin d'obtenir le contenu approprié des fichiers qui ont été modifiés.

Annulation de verrouillages

Si un utilisateur verrouille un fichier pour l'utiliser dans un espace de travail et si vous devez autoriser l'accès au fichier à d'autres utilisateurs, vous pouvez déverrouiller le fichier dans cet espace de travail en utilisant la commande lock.

Pour déverrouiller un dossier ou un fichier dans un espace de travail

  1. Cliquez sur Démarrer et sur Tous les programmes, pointez sur Microsoft Visual Studio 2005 et sur Visual Studio Tools, puis cliquez sur Invite de commandes de Visual Studio.

  2. Tapez cd path, où path est le nom du répertoire qui contient l'espace de travail dans lequel vous souhaitez déverrouiller un fichier.

  3. Tapez tf lock itemspec /lock:none /workspace:workspacename, où itemspec est le nom du fichier ou du dossier que vous souhaitez déverrouiller et workspacename est le nom de l'espace de travail qui contient l'élément que vous souhaitez déverrouiller.

Sécurité

Les autorisations ou droits de sécurité Team Foundation Build s'appliquent à cette rubrique. Pour plus d'informations, consultez Droits et autorisations relatifs à la sécurité Team Build.

Voir aussi

Référence

Workspace, commande
Workspaces, commande
Lock, commande
Undo, commande

Concepts

Utilisation des espaces de travail du contrôle de code source

Autres ressources

Référence de la ligne de commande du contrôle de code source Team Foundation


Comment : supprimer des fichiers orphelins de façon définitive

Comment : supprimer des fichiers orphelins de façon définitive
Voir aussi

Vous pouvez souhaiter de supprimer définitivement des fichiers qui sont rendus orphelins lorsqu'un utilisateur client supprime une pièce jointe d'un élément de travail. Par exemple, un élément de travail peut avoir un fichier attaché qui est endommagé ou présenter un virus.

La suppression du fichier le supprime de l'élément de travail et du projet. Les bases de données contiennent encore les lignes des métadonnées et du contenu. Toutefois, le RemovedDate est remplacé par la date et l'heure actuelles et le fichier est rendu orphelin. En tant qu'administrateur de la base de données, vous pouvez supprimer la pièce jointe définitivement.

Le contenu du fichier est stocké dans la base de données TfsWorkItemTrackingAttachment sous la forme d'une entrée unique pour le fichier. Cette entrée inclut un GUID et le contenu sous forme d'une image.

Les métadonnées du fichier sont stockées dans la table WorkItemFiles de la base de données TfsWorkItemTracking. Les métadonnées incluent le numéro d'ID de l'élément de travail.

Pour supprimer une pièce jointe d'élément de travail orphelin

  1. Dans Team Explorer, ouvrez l'élément de travail et supprimez le fichier de l'onglet Fichier.

    Remarque Remarque

    L'utilisateur client ou un administrateur peut supprimer le fichier et le rendre orphelin dans la base de données.

  2. Connectez-vous au serveur de couche Données en tant qu'utilisateur disposant des autorisations d'administration de base de données.

  3. Cliquez sur Démarrer, sur Tous les programmes, sur Microsoft SQL Server 2005, puis cliquez sur SQL Server Management Studio.

  4. Dans la boîte de dialogue Se connecter au serveur, sélectionnez un serveur, puis cliquez sur Se conn..

    Remarque Remarque

    Si le nom du serveur n'est pas dans la boîte de dialogue, vous pouvez taper directement le nom dans la zone de liste déroulante.

  5. Exécutez une requête dans la base de données TfsWorkItemTracking pour obtenir une liste des pièces jointes de l'élément de travail.

    Par exemple, vous pouvez utiliser cette requête qui retourne des éléments avec pièces jointes comme indiqué par la valeur FldID de 50 et l'ID de l'élément de travail :

    Image Copier le code Copier le code
    USE TfsWorkItemTracking
GO
SELECT * FROM WorkItemFiles WHERE FldID=50 AND ID = 15

  6. Dans la colonne OriginalName dans les résultats de requête, recherchez le nom de fichier et notez le GUID trouvé dans la colonne FilePath.

  7. Dans la base de données TfsWorkItemAttachment, émettez une requête Delete basée sur le GUID.

    Remarque Remarque

    Il est impossible d'annuler l'action d'une requête Delete. Par sécurité, sauvegardez vos données avant d'exécuter une requête Delete.

    Image Copier le code Copier le code
    USE TfsWorkItemAttachment
GO
DELETE FROM Attachments WHERE FileGuid=<<GUID>>

Sécurité

Vous avez besoin d'autorisations d'administration de base de données pour exécuter des commandes DELETE. Un fichier infecté par un virus n'est pas disponible après sa suppression du projet d'équipe.

Voir aussi

Autres ressources

Gestion des données


Gestion des services SQL Server

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Gestion des services SQL Server
Voir aussi
Image de liste déroulante

Team Foundation Server repose sur trois composants de Microsoft SQL Server 2005. Team Foundation Server utilise les composants suivants :

  • bases de données SQL Server pour stocker des informations opérationnelles sur les composants individuels et l'entrepôt de données ;

  • SQL Server Analysis Services pour agréger et synthétiser les données dans l'entrepôt ;

  • SQL Server Reporting Services pour générer et stocker des rapports sur les projets d'équipe.

En tant qu'administrateur Team Foundation, il n'existe pas de tâches ou d'instructions spéciales que vous devez suivre pour gérer des services SQL Server de Team Foundation Server. Assurez-vous que les services SQL Server sont disponibles et fonctionnent correctement conformément à la documentation en ligne de chaque composant.

Pour plus d'informations sur la gestion de bases de données SQL Server, consultez SQL Server Administration How-to Topics.

Pour plus d'informations sur la gestion des SQL Server Analysis Services, consultez Administering Analysis Services.

Pour plus d'informations sur la gestion des SQL Server Reporting Services, consultez Administering Reporting Services.

Voir aussi

Tâches

Dépannage des rapports de Team Foundation

Concepts

Troubleshooting the Data Warehouse
Concepts sur la sécurité de Team Foundation Server

Autres ressources

Sauvegarde et restauration des données de Team Foundation Server
Gestion de Team Foundation Server


Gestion des composants Team Foundation Server

Gestion des composants Team Foundation Server
DropDown image

Cette section contient des rubriques décrivant comment gérer les composants de Team Foundation Server.

Dans cette section

Garantie de la disponibilité et du basculement de Team Foundation Server

Contient des liens vers les rubriques qui décrivent comment garantir la disponibilité de Team Foundation Server.

Gestion des serveurs de couche Données dans Team Foundation Server

Contient des liens vers les rubriques qui expliquent comment gérer des serveurs de couche Données.

Gestion des serveurs de couche Application dans Team Foundation Server

Contient des liens vers les rubriques qui expliquent comment gérer des serveurs de couche Application.

Voir aussi

Autres ressources

Gestion de Team Foundation Server
Planification de Team Foundation Server


Garantie de la disponibilité et du basculement de Team Foundation Server

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Garantie de la disponibilité et du basculement de Team Foundation Server
Voir aussi
Image de liste déroulante

Vous pouvez vous assurer de la disponibilité de Team Foundation Server en appliquant l'une des trois stratégies de base. La stratégie que vous sélectionnez est déterminée par la durée d'arrêt que les utilisateurs peuvent tolérer et la topologie du système.

Stratégies de disponibilité

En général, les topologies sur un serveur et sur deux serveurs peuvent tolérer un temps d'arrêt raisonnable pour la maintenance de système ou pour la restauration en cas d'échec. Les systèmes complexes peuvent fournir un service ininterrompu grâce à des ressources dédiées. Les stratégies suivantes fournissent des degrés variables de disponibilité de Team Foundation Server.

  • Méthodes de sauvegarde standard Pour la couche Données et la couche Application, vous pouvez gérer des sauvegardes de vos bases de données et les utiliser pour récupérer en un temps raisonnable sans avoir besoin d'un ordinateur supplémentaire ou de ressources de maintenance.

  • Système de secours automatique Outre les méthodes de sauvegarde standard, vous pouvez vous installer et gérer un système de secours automatique pour réduire votre temps de restauration. Cette stratégie nécessite du matériel supplémentaire et, par conséquent, la maintenance d'un système supplémentaire afin que le matériel reste mis à jour et prêt.

  • Clustering Pour les systèmes complexes, vous pouvez installer et gérer des serveurs dédiés dans les clusters pour fournir un service ininterrompu à une couche Données. Cette stratégie augmente considérablement le coût en ressources et en maintenance, les configurations requises pour les ordinateurs de basculement étant très précises. Par exemple, le matériel doit correspondre de manière identique et appartenir à la liste du matériel approuvé.

Méthodes de sauvegarde standard

Pour la couche Données Team Foundation, vous pouvez implémenter les mêmes méthodes conseillées, comme vous le feriez pour une base de données SQL Server. Pour la couche Application, vous pouvez implémenter les mêmes méthodes conseillées utilisées pour la sauvegarde et restaurer n'importe quelle collection de site dans Windows SharePoint Services.

Système de secours automatique

Si vous disposez des ressources permettant de gérer un système de secours, vous pouvez installer des ordinateurs supplémentaires pour éliminer le temps d'arrêt requis pour restaurer l'ordinateur principal pour la couche Application. Vous pouvez installer et gérer un deuxième serveur de couche Application. L'ordinateur doit disposer de mises à jour du logiciel correspondant à celles de l'ordinateur principal, ainsi que des comptes d'utilisateurs principaux et des autorisations mises à jour comme dans l'ordinateur principal. La couche Application ne peut pas faire partie d'une batterie de serveurs Web. Lorsque vous devez utiliser le système de secours, exécutez la commande ATActivate de basculement qui bascule la liaison de couche Données du serveur de couche Application principal au serveur de basculement.

Les applications clientes se connectent à la couche Application principale qui se connecte au serveur de couche Données principal en utilisant le nom de serveur. En tant qu'administrateur système, vous devez basculer manuellement sur le serveur miroir en cas de basculement. Le protocole Internet virtuel (VIP) configuré en tant que VIP est la solution de secours automatique. Le secours miroir surveille constamment le principal pour détecter une défaillance matérielle en envoyant un signal de pulsation sur le réseau. Dès que ce signal de pulsation est perdu, cela suppose que le serveur principal est arrêté.

Clustering

Si le système nécessite une disponibilité très élevée et qu'il peut couvrir le coût des ressources supplémentaires, vous pouvez fournir une disponibilité ininterrompue à la couche Données en utilisant le clustering. En utilisant la technologie Windows Server Clustering, vous pouvez créer un cluster de deux ordinateurs. Pour la couche Application, vous pouvez installer et gérer un serveur de secours automatique.

Voir aussi

Concepts

Planification de la sauvegarde et de la restauration
Configuration et activation d'un serveur de couche Application avec basculement
Clustering du serveur de couche Données
Planification de la récupération d'urgence

Autres ressources

Gestion des données
Sauvegarde et restauration des données de Team Foundation Server


Clustering du serveur de couche Données

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Clustering du serveur de couche Données
Voir aussi
Image de liste déroulante

Vous pouvez garantir un service transparent et ininterrompu de Team Foundation Server en installant la couche Données sur un cluster d'ordinateurs dédiés correspondants. En général, cette stratégie de disponibilité est rentable pour les très grandes entreprises disposant de ressources pour installer et maintenir une topologie complexe.

Installation de la couche Données sur un cluster

Pendant que Windows 2003 Server propose plusieurs configurations de cluster, Team Foundation Server prend en charge une configuration du cluster très spécifique. Si vous avez choisi d'investir en ressources pour utiliser des clusters, Team Foundation Server prend en charge un cluster utilisant une configuration de serveurs à quorum unique implémentant un mode de secours automatique servant deux nœuds.

Serveurs de périphérique de quorum unique

Le périphérique de quorum unique permet à deux nœuds d'apparaître aux clients comme un seul serveur. Le quorum représente le périphérique de stockage contrôlé par le nœud principal pour la couche Données et effectue le suivi du nœud fonctionnant comme nœud principal. Un seul nœud peut posséder le quorum à la fois. Lorsque la couche Données échoue au nœud de secours, celui-ci prend possession du quorum et de la couche Données. Lorsque les deux nœuds sont joints à un seul périphérique de stockage, le quorum peut être créé sur le périphérique de stockage.

Vous gérez les clusters via le programme Windows Cluster Management installé avec Windows Server 2003 Enterprise Edition ou Windows Server 2003 Datacenter Edition. SQL Server fournit des ressources à chaque nœud du cluster.

Pour plus d'informations sur les clusters, consultez Virtual Servers.

SQL Server et clusters

L'installation de SQL Server reconnaît des clusters. Team Foundation Server peut servir l'instance par défaut de SQL Server s'exécutant sur l'ordinateur et non à l'aide d'une instance nommée. Vous ne devez modifier les mots de passe sur aucun des comptes de service SQL Server lorsqu'un nœud de cluster avec basculement est arrêté ou hors connexion. Dans le cas contraire, vous devez réinitialiser le mot de passe à l'aide d'Enterprise Manager lorsque tous les nœuds sont à nouveau en ligne.

Si le compte de service pour SQL Server n'est pas administrateur dans un cluster, les partages administratifs ne peuvent être supprimés sur aucun nœud du cluster. Les partages administratifs doivent être disponibles dans un cluster afin que SQL Server fonctionne.

Compte d'utilisateur de cluster

Après la création d'un cluster, un compte de service de cluster devient membre du groupe des utilisateurs authentifiés. Le compte de service de cluster doit au moins disposer des autorisations suivantes.

  • Réinitialisez le mot de passe sur l'ordinateur objet virtuel.

  • Écrivez l'attribut DnsHostName sur l'objet.

  • Écrivez l'attribut ServicePrincipalName sur l'objet.

  • Créez des objets de configuration Message Queuing si la ressource de nom de réseau est dépendante d'une ressource Message Queuing.

Voir aussi

Tâches

Comment : gérer les clusters d'un serveur de couche Données

Référence

Liste de vérification : configuration des clusters

Concepts

Garantie de la disponibilité et du basculement de Team Foundation Server

Autres ressources

Gestion des données


Liste de vérification : configuration des clusters

 Image de liste déroulante Image de pointage sur liste déroulante Image de réduction Image de développement Image Réduire tout Image Développer tout Copier l'image de pointage
Visual Studio Team System
Liste de vérification : configuration des clusters
Voir aussi
Image Réduire tout Image de liste déroulante

Cette liste de vérification n'est pas disponible dans cette version du Guide de l'administrateur Team Foundation. La version la plus récente de cette rubrique est disponible sur le site Web de Microsoft (http://go.microsoft.com/fwlink/?linkid=52459).

Image de développement Voir aussi

Tâches

Comment : gérer les clusters d'un serveur de couche Données

Concepts

Clustering du serveur de couche Données


Configuration et activation d'un serveur de couche Application avec basculement

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Configuration et activation d'un serveur de couche Application avec basculement
Voir aussi
Image de liste déroulante

Vous pouvez installer un ordinateur de basculement pour le serveur de couche Application de Team Foundation après avoir installé les serveurs de couche Données et de couche Application principaux.

Considérations sur l'Installation de l'ordinateur de basculement

La configuration de l'ordinateur de basculement doit correspondre à la configuration de l'ordinateur principal. Les ordinateurs ne doivent pas nécessairement être identiques, mais l'ordinateur de basculement doit correspondre à la configuration système requise pour Team Foundation. Vous pouvez employer les mêmes composants requis et les mêmes étapes d'installation de Team Foundation pour le basculement que ceux que vous avez utilisés pour l'ordinateur principal.

Pour plus d'informations sur l'installation, consultez « Installation de Team Foundation Server (services) » dans le Guide d'installation Team Foundation Server. Vous pouvez télécharger la dernière version du Guide d'installation Team Foundation sur le site http://go.microsoft.com/fwlink/?linkid=40042 ou ouvrir le fichier d'aide TFSInstall.chm à partir du disque dur. Les détails relatifs à l'installation de la couche Application et de la paire active/passive à l'aide d'un nom de serveur virtuel ne sont pas disponibles sur cette version du Guide de l'administrateur Team Foundation. La version la plus récente de cette rubrique est disponible sur le World Wide Web sur le site Web de Microsoft (http://go.microsoft.com/fwlink/?linkid=52459).

Pour vérifier que l'ordinateur est prêt, vous devez mettre à jour périodiquement l'ordinateur de basculement afin qu'il corresponde à l'ordinateur principal. Toutes les mises à jour que vous effectuez sur l'ordinateur principal doivent être reproduites sur l'ordinateur de basculement. Par exemple, toutes les mises à jour du système, les mises à jour de logiciels et les modifications d'autorisation doivent également être effectuées sur le basculement.

Activation du serveur de basculement

Lorsque le serveur principal tombe en panne, vous devez démarrer le serveur de basculement manuellement. Team Foundation inclut la commande ActivateAT de l'utilitaire TFSAdminUtil pour le serveur de couche Application qui exécute les opérations suivantes :

  • Arrête les services Web sur le serveur de couche Application d'origine et démarre les services Web sur le serveur de basculement.

  • Enregistre le nom de l'ordinateur de basculement dans la base de données d'intégration de Team Foundation.

  • Connecte le serveur de couche Application du basculement au serveur de couche Données actif.

  • Vérifie que le serveur de couche Application est connecté au serveur de couche Données correspondant.

Voir aussi

Référence

ActivateAt, commande

Concepts

Garantie de la disponibilité et du basculement de Team Foundation Server
Comment : configurer et activer un serveur de couche Application avec basculement

Autres ressources

Gestion des données


Gestion des serveurs de couche Données dans Team Foundation Server

Gestion des serveurs de couche Données dans Team Foundation Server
Voir aussi
DropDown image

Cette section contient des liens vers les rubriques décrivant comment gérer le serveur de couche Données dans Team Foundation Server.

Dans cette section

Comment : gérer les clusters d'un serveur de couche Données

Décrit comment grouper un serveur de couche Données.

Comment : renommer un serveur de couche Données

Explique comment renommer un serveur de couche Données.

Comment : réparer un serveur de couche Données

Explique comment réparer un serveur de couche Données.

Comment : désinstaller un serveur de couche Données

Décrit comment désinstaller un serveur de couche Données.

Voir aussi

Concepts

Gestion des serveurs de couche Application dans Team Foundation Server

Autres ressources

Gestion des composants Team Foundation Server


Comment : gérer les clusters d'un serveur de couche Données

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Comment : gérer les clusters d'un serveur de couche Données
Voir aussi
Image de liste déroulante

Cette procédure n'est pas disponible dans cette version du Guide de l'administrateur Team Foundation. La version la plus récente de cette rubrique est disponible sur le site Web de Microsoft (http://go.microsoft.com/fwlink/?linkid=52459).

Voir aussi

Tâches

Comment : restaurer les données de Team Foundation Server vers un autre serveur

Référence

Liste de vérification : configuration des clusters

Concepts

Clustering du serveur de couche Données

Autres ressources

Gestion des données


Comment : renommer un serveur de couche Données

Comment : renommer un serveur de couche Données

Si nécessaire, vous pouvez renommer un serveur de couche Données en renommant l'ordinateur qui héberge la couche Données puis en utilisant l'utilitaire en ligne de commande TFSAdminUtil.

Pour renommer un serveur de couche Données

  1. Sur l'ordinateur qui héberge le serveur de couche Données, dans Windows, sélectionnez Démarrer, cliquez avec le bouton droit sur Poste de travail, puis sélectionnez Propriétés.

    La fenêtre Propriétés système s'ouvre.

  2. Dans l'onglet Nom de l'ordinateur, cliquez sur Modifier.

    La fenêtre Modification du nom d'ordinateur s'ouvre.

  3. Dans la zone Nom de l'ordinateur, tapez le nouveau nom de l'ordinateur, puis cliquez sur OK.

  4. Sur l'ordinateur qui héberge le serveur de couche Application, dans le menu Démarrer de Windows, choisissez Tous les programmes, puis Accessoires, puis choisissez Invite de commandes.

    L'invite de commandes s'affiche.

  5. Naviguez jusqu'au dossier Program Files\Microsoft Visual Studio 2005 Team Foundation Server\Tools à l'aide de la ligne de commande. Par exemple :

    cd C:\Program Files\Microsoft Visual Studio 2005 Team Foundation Server\Tools

  6. Exécutez l'outil TFSAdminUtil avec l'option RenameDT pour se connecter à la couche Données, comme illustré ci-dessous :

    TFSAdminUtil RenameDT MyDataTierServer

    Dans cet exemple, MyDataTierServer représente le nom du serveur de couche Données auquel vous souhaitez vous connecter.

Voir aussi

Tâches

Comment : renommer un serveur de couche Application
Comment : connecter un serveur de couche Application au serveur de couche Données

Autres ressources

Gestion des serveurs de couche Données dans Team Foundation Server
Commandes de l'utilitaire en ligne de commande TFSAdminUtil


Comment : réparer un serveur de couche Données

Comment : réparer un serveur de couche Données

Si une installation de votre serveur de couche Données est endommagée, vous devez réparer l'installation. Dans cette rubrique, vous apprendrez comment réparer une installation de serveur de couche Données.

Pour réparer un serveur de couche Données

  1. Sur l'ordinateur qui héberge la couche Données, cliquez sur Démarrer, sélectionnez Panneau de configuration, puis sélectionnez Ajout/Suppression de programmes.

    La fenêtre Ajout/Suppression de programmes s'ouvre.

  2. Sélectionnez Microsoft Visual Studio 2005 Team Foundation Server (bases de données) et cliquez sur Modifier/Supprimer.

    L'Assistant Installation de Visual Studio 2005 Team Foundation Server (bases de données) s'ouvre.

  3. Dans l'Assistant, sélectionnez Réparer ou réinstaller, cliquez sur Suivant et suivez les instructions de l'Assistant.

Voir aussi

Tâches

Comment : désinstaller un serveur de couche Données
Comment : réparer un serveur de couche Application
Comment : désinstaller un serveur de couche Application


Comment : désinstaller un serveur de couche Données

Comment : désinstaller un serveur de couche Données

Vous pouvez désinstaller un serveur de couche Données pour plusieurs raisons. Dans cette rubrique, vous apprendrez comment désinstaller une installation serveur de couche Données.

Pour désinstaller un serveur de couche Données

  1. Sur l'ordinateur qui héberge la couche Données, cliquez sur Démarrer, sélectionnez Panneau de configuration, puis sélectionnez Ajout/Suppression de programmes.

    La fenêtre Ajout/Suppression de programmes s'ouvre.

  2. Sélectionnez Visual Studio 2005 Team Foundation Server (bases de données) et cliquez sur Modifier/Supprimer.

    L'Assistant Installation de Visual Studio 2005 Team Foundation Server (bases de données) s'ouvre.

  3. Dans l'Assistant, sélectionnez Désinstaller, cliquez sur Suivant et suivez les instructions de l'Assistant.

Voir aussi

Tâches

Comment : réparer un serveur de couche Application
Comment : désinstaller un serveur de couche Application
Comment : réparer un serveur de couche Données


Gestion des serveurs de couche Application dans Team Foundation Server

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Gestion des serveurs de couche Application dans Team Foundation Server
Voir aussi
Image de liste déroulante

Cette section contient des liens vers les rubriques décrivant comment gérer le serveur de couche Application dans Team Foundation Server.

Dans cette section

Comment : configurer et activer un serveur de couche Application avec basculement

Décrit comment configurer et activer un serveur de couche Application passif.

Comment : renommer un serveur de couche Application

Explique comment renommer un serveur de couche Application.

Comment : réparer un serveur de couche Application

Explique comment réparer un serveur de couche Application.

Comment : connecter un serveur de couche Application au serveur de couche Données

Explique comment connecter un autre serveur de couche Application à un serveur de couche Données existant.

Comment : désinstaller un serveur de couche Application

Décrit comment désinstaller un serveur de couche Application.

Voir aussi

Autres ressources

Gestion des serveurs de couche Données dans Team Foundation Server
Gestion des composants Team Foundation Server


Comment : configurer et activer un serveur de couche Application avec basculement

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Comment : configurer et activer un serveur de couche Application avec basculement
Voir aussi
Image de liste déroulante

Cette procédure n'est pas disponible sur cette version du Guide de l'administrateur Team Foundation. La version la plus récente est disponible sur le site Web de Microsoft (http://go.microsoft.com/fwlink/?linkid=52459).

Voir aussi

Référence

ActivateAt, commande

Concepts

Garantie de la disponibilité et du basculement de Team Foundation Server

Autres ressources

Gestion des données


Comment : renommer un serveur de couche Application

Comment : renommer un serveur de couche Application

Si nécessaire, vous pouvez renommer un serveur de couche Application en renommant l'ordinateur, puis en exécutant l'utilitaire en ligne de commande TFSAdminUtil.

Pour renommer un serveur de couche Application

  1. Sur l'ordinateur qui héberge le serveur de couche Application, dans Windows, sélectionnez Démarrer, cliquez avec le bouton droit sur Poste de travail, puis sélectionnez Propriétés.

    La fenêtre Propriétés système s'ouvre.

  2. Dans l'onglet Nom de l'ordinateur, cliquez sur Modifier.

    La fenêtre Modification du nom d'ordinateur s'ouvre.

  3. Dans la zone Nom de l'ordinateur, tapez le nouveau nom de l'ordinateur, puis cliquez sur OK.

  4. Dans le menu Démarrer de Windows, choisissez Tous les programmes, choisissez Accessoires, puis choisissez Invite de commandes.

    L'invite de commandes s'affiche.

  5. Naviguez jusqu'au dossier Program Files\Microsoft Visual Studio 2005 Team Foundation Server\Tools à l'aide de la ligne de commande. Par exemple :

    cd C:\Program Files\Microsoft Visual Studio 2005 Team Foundation Server\Tools

  6. Exécutez l'outil TFSAdminUtil avec l'option ActivateAT pour activer la couche Application, comme indiqué ci-dessous :

    TFSAdminUtil ActivateAT

Les utilisateurs clients devront se connecter au serveur de couche Application récemment renommé s'ils utilisaient précédemment le serveur de couche Application sous son ancien nom. Si les utilisateurs clients ont été connectés au serveur de couche Application pendant l'exécution de la procédure de changement de nom, une actualisation de leurs caches Team Foundation Server peut s'avérer nécessaire ainsi que l'exécution de la commande devenv /resetuserdata ou ils devront patienter deux heures avant de reconnecter.

Voir aussi

Tâches

Comment : renommer un serveur de couche Données

Concepts

Gestion des serveurs de couche Application dans Team Foundation Server

Autres ressources

Commandes de l'utilitaire en ligne de commande TFSAdminUtil


Comment : réparer un serveur de couche Application

Comment : réparer un serveur de couche Application

Si une installation de votre serveur de couche Application est endommagée, vous devez réparer l'installation. Dans cette rubrique, vous apprendrez comment réparer une installation serveur de couche Application.

Pour réparer un serveur de couche Application

  1. Sur l'ordinateur qui héberge la couche Application, cliquez sur Démarrer, sélectionnez Panneau de configuration, puis sélectionnez Ajout/Suppression de programmes.

    La fenêtre Ajout/Suppression de programmes s'ouvre.

  2. Sélectionnez Microsoft Visual Studio 2005 Team Foundation Server (services) et cliquez sur Modifier/Supprimer.

    L'Assistant Installation de Visual Studio 2005 Team Foundation Server (services) s'ouvre.

  3. Dans l'Assistant, sélectionnez Réparer ou réinstaller, cliquez sur Suivant et suivez les instructions de l'Assistant.

Voir aussi

Tâches

Comment : désinstaller un serveur de couche Données
Comment : désinstaller un serveur de couche Application
Comment : réparer un serveur de couche Données


Comment : connecter un serveur de couche Application au serveur de couche Données

Comment : connecter un serveur de couche Application au serveur de couche Données
Voir aussi

Vous pouvez connecter un serveur de couche Application à un serveur de couche Données existant à l'aide de l'outil de ligne de commande TFSAdminUtil.exe.

Pour connecter un serveur de couche Application à la couche Données

  1. Sur l'ordinateur de couche Application, dans le menu Windows Démarrer, choisissez Tous les programmes, puis Accessoires, puis choisissez Invite de commandes.

    L'invite de commandes s'affiche.

  2. Naviguez jusqu'au dossier Program Files\Microsoft Visual Studio 2005 Team Foundation Server\Tools à l'aide de la ligne de commande. Par exemple :

    cd C:\Program Files\Microsoft Visual Studio 2005 Team Foundation Server\Tools

  3. Exécutez l'outil TFSAdminUtil.exe avec l'option RenameDT pour se connecter à la couche Données, par exemple :

    TFSAdminUtil.exe RenameDT MyDataTierServer

    Dans cet exemple, MyDataTierServer représente le nom du serveur de couche Données auquel vous souhaitez vous connecter.

Voir aussi

Concepts

Gestion des serveurs de couche Application dans Team Foundation Server

Autres ressources

Commandes de l'utilitaire en ligne de commande TFSAdminUtil


Comment : désinstaller un serveur de couche Application

Comment : désinstaller un serveur de couche Application

Vous pouvez désinstaller un serveur de couche Application pour plusieurs raisons. Dans cette rubrique, vous apprendrez comment désinstaller une installation serveur de couche Application.

Pour désinstaller un serveur de couche Application

  1. Sur l'ordinateur qui héberge la couche Application, cliquez sur Démarrer, sélectionnez Panneau de configuration, puis sélectionnez Ajout/Suppression de programmes.

    La fenêtre Ajout/Suppression de programmes s'ouvre.

  2. Sélectionnez Visual Studio 2005 Team Foundation Server (services) et cliquez sur Modifier/Supprimer.

    L'Assistant Installation de Visual Studio 2005 Team Foundation Server (services) s'ouvre.

  3. Dans l'Assistant, sélectionnez Désinstaller, cliquez sur Suivant et suivez les instructions de l'Assistant.

Voir aussi

Tâches

Comment : désinstaller un serveur de couche Données
Comment : réparer un serveur de couche Application
Comment : réparer un serveur de couche Données


Gestion de Team Foundation Server dans un domaine Active Directory

Gestion de Team Foundation Server dans un domaine Active Directory
Voir aussi
DropDown image

Lorsque Team Foundation Server est déployé dans un domaine Active Directory, Team Foundation Server utilise des identités Windows stockées dans Active Directory.

Dans cette section

Considérations sur les approbations et les forêts pour Team Foundation Server

Décrit les considérations sur le déploiement stable et sécurisé de Team Foundation Server dans un environnement Active Directory.

Configurations de domaine non prises en charge

Fournit des exemples de configurations de domaine non prises en charge.

Voir aussi

Autres ressources

Gestion de Team Foundation Server
Topologies de Team Foundation Server


Considérations sur les approbations et les forêts pour Team Foundation Server

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Considérations sur les approbations et les forêts pour Team Foundation Server
Voir aussi
Image de liste déroulante

Team Foundation Server fournit une base pour la collaboration inter-groupes via des domaines différents ou même via des forêts différentes. Vous pouvez vous assurer de la sécurité et la stabilité du serveur et de votre domaine en suivant quelques indications importantes.

Team Foundation Server est pris en charge dans les modes Active Directory et niveaux fonctionnels suivants :

  • Windows 2000 Active Directory en mode natif

  • Windows Server 2003 Active Directory dans le niveau fonctionnel de Windows 2000 en mode natif

  • Windows Server 2003 Active Directory dans le niveau fonctionnel de Windows Server 2003

Remarque Remarque

Team Foundation Server ne prend pas en charge les modes d'authentification et les niveaux fonctionnels de Windows NT 4.0.

La couche Application et les couches Données de Team Foundation doivent être dans le même domaine, mais les clients se connectant peuvent être dans différents emplacements de domaine.

Par conséquent, Team Foundation prend en charge les configurations de confiance de domaine suivantes :

  • Domaine unique

  • Domaine unique dans lequel la couche Application est également le contrôleur de domaine

  • Confiance bidirectionnelle transitive dans la même forêt par défaut

Toutes les autres configurations de domaine Active Directory ne sont pas prises en charge et ne doivent pas être utilisées. Vous devez vous assurer que le domaine dans lequel vous installez Team Foundation Server prend en charge Team Foundation Server et que les ordinateurs sur lesquels Team Foundation Server est installé sont dans des environnements de domaine appropriés. Si Team Foundation Server prend en charge des tâches via plusieurs forêts, les confiances inter-forêts appropriées doivent être disponibles.

Pour des considérations en matière de sécurité, nous vous recommandons d'installer Team Foundation Server dans un environnement de domaine Windows Server 2003. Afin d'éviter des emprunts d'identité, vous devez interdire les noms dupliqués et sécuriser les noms d'ordinateurs par créateur. Pour plus d'informations, consultez Windows Server 2003 Active Directory à l'adresse http://go.microsoft.com/fwlink/?linkid=47541

Voir aussi

Concepts

Configurations de domaine non prises en charge

Autres ressources

Gestion de Team Foundation Server dans un domaine Active Directory
Topologies de Team Foundation Server


Configurations de domaine non prises en charge

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Configurations de domaine non prises en charge
Voir aussi
Image de liste déroulante

Les configurations de domaine Active Directory suivantes sont des configurations de domaine prises en charge pour Team Foundation Server :

  • Windows 2000 natif

  • Windows Server 2003 natif

Toutes les autres configurations de domaine ne sont pas prises en charge. Quelques exemples spécifiques de configurations de domaine Team Foundation Server non prises en charge sont :

  • Contrôleurs de domaine Windows NT 4.0

  • Niveau de fonctionnalité de Windows 2000 mixte

  • Niveau de fonctionnalité de Windows 2003 version préliminaire

  • Configuration de la couche Application et de la couche Données entre différents domaines ou sous-domaines.

  • Configuration de la couche Application et de la couche Données entre un domaine et un groupe de travail.

Les exemples de topologies de domaine prises en charge se trouvent dans Topologie Team Foundation Server simple, Topologie Team Foundation Server modérée et Topologie Team Foundation Server complexe.

Voir aussi

Autres ressources

Gestion de Team Foundation Server dans un domaine Active Directory
Topologies de Team Foundation Server


Gestion de Team Foundation Server dans un groupe de travail

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Gestion de Team Foundation Server dans un groupe de travail
Voir aussi
Image de liste déroulante

La gestion de Team Foundation Server dans un environnement de groupe de travail est possible, mais peut présenter certaines difficultés. Cette rubrique présente brièvement les avantages et les inconvénients de l'utilisation de Team Foundation Server dans un groupe de travail.

La différence principale dans un environnement de groupe de travail est l'absence d'un Active Directory. Le fait de ne pas disposer d'Active Directory signifie que les services d'administrateur auront moins de surcharge, ce qui peut être problématique pour les groupes de grande taille. Les comptes locaux doivent être créés dans Team Foundation Server pour chaque utilisateur nécessitant un accès à Team Foundation Server et à ses ressources. Donc pour les groupes de travail autres que les groupes de très petite taille, la gestion du compte requise pour les groupes de travail peut devenir prohibitive.

Pour sécuriser votre serveur Team Foundation Server contre les emprunts d'identité dans un groupe de travail, vous devez utiliser le protocole SSL (Secure Socket Layer) et définir le client pour qu'il ne fasse confiance qu'aux serveurs de certificats désignés.

Pour résumer, les environnements Active Directory sont recommandés pour la plupart des déploiements de Team Foundation Server. Si Team Foundation Server doit être déployé dans un groupe de travail, il doit l'être uniquement dans les groupes de travail disposant d'un nombre très limité d'utilisateurs et d'ordinateurs.

Voir aussi

Autres ressources

Gestion de Team Foundation Server dans un domaine Active Directory
Gestion de Team Foundation Server


Gestion des connexions à distance avec Team Foundation Server Proxy

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Gestion des connexions à distance avec Team Foundation Server Proxy
Voir aussi
Image de liste déroulante

Team Foundation Server assure la prise en charge des équipes multisites au niveau de l'utilisation du contrôle de code source dans le proxy de Team Foundation Server. Le proxy gère un cache de fichiers de contrôle de code source téléchargés dans l'emplacement de l'équipe multisite. Confier au proxy le soin de gérer le téléchargement et la mise en cache réduit considérablement la bande passante requise au niveau des connexions étendues. En configurant le client pour utiliser le proxy, la gestion des fichiers est transparente pour l'utilisateur. Tous les échanges de métadonnées et les téléchargements de fichiers continuent à faire directement l'interface avec Team Foundation Server.

Pour plus d'informations, consultez Team Foundation Server Proxy et contrôle de code source Team Foundation.

Pour plus d'informations sur l'installation du proxy, consultez le Guide d'installation Team Foundation. La version la plus récente du Guide d'installation Team Foundation est disponible en ligne à l'adresse http://go.microsoft.com/fwlink/?linkid=40042.

Voir aussi

Tâches

Comment : configurer le contrôle de code source Team Foundation pour utiliser un serveur proxy


Team Foundation Server Proxy et contrôle de code source Team Foundation

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Team Foundation Server Proxy et contrôle de code source Team Foundation
Voir aussi
Image de liste déroulante

Le proxy de contrôle de code source Team Foundation est conçu pour améliorer les performances réseau en mettant en cache des copies de fichiers de contrôle de code source dans un emplacement distant, proche du développeur qui a besoin des fichiers, mais éloigné de l'emplacement de contrôle de code source principal. En stockant des copies dans l'emplacement distant, en général connecté à l'emplacement source via un lien plus lent que votre réseau local, le proxy aide chaque utilisateur à éviter un téléchargement coûteux des fichiers vers leur espace de travail via la connexion plus lente.

À la place, le proxy de contrôle de code source répond généralement aux requêtes du client en retournant les fichiers du cache local via la connexion locale plus rapide. Lorsqu'un fichier ne se trouve pas dans le cache local, le fichier est téléchargé par le proxy dans le cache local à partir de Team Foundation Server, avant que les fichiers soient retournés au client.

Opérations de base

Les opérations du proxy peuvent être affichées via le côté client et via le côté serveur. Comme tout proxy Internet, vous configurez votre client pour utiliser le proxy. Le proxy contrôle ensuite lui-même l'administration des fichiers. En tant qu'utilisateur du client, vous laissez le proxy contrôler le téléchargement des fichiers. Pour plus d'informations, consultez Comment : configurer le contrôle de code source Team Foundation pour utiliser un serveur proxy.

Sur le côté serveur, votre première tâche en tant qu'administrateur est d'installer le proxy. Ensuite, vous configurez le proxy en modifiant le fichier proxy.config. Une fois ces deux tâches accomplies, vous avez uniquement besoin d'effectuer les tâches occasionnelles de maintenance.

Une limite maximale est définie pour la quantité d'espace de stockage que le proxy peut utiliser pour la mise en cache de fichiers. Lorsque cette limite est atteinte, les anciens fichiers du cache sont supprimés pour libérer de l'espace de stockage utilisé pour mettre en cache de nouveaux fichiers demandés. Le nettoyage supprime les fichiers en fonction de la date de leur dernière consultation. Les fichiers qui n'ont pas été consultés depuis longtemps sont supprimés en premier.

Diagramme de déploiement du proxy

Maintenance

Peu de maintenance ou d'administration sont nécessaires au proxy lui-même. Toutefois, vous devez périodiquement surveiller et gérer les performances. Vous devez regarder les compteurs de performance suivants :

  • Taille de la mémoire cache actuelle

  • Total des accès cache avec résultat - compte et pourcentage

  • Requêtes de téléchargement totales

  • Total des fichiers dans le cache

  • Total d'accès au cache sans résultat - compte et pourcentage

Ces compteurs de performance sont enregistrés dans le cadre de l'installation du proxy. Pour plus d'informations, consultez Comment : examiner les performances du proxy. Les compteurs de performance de proxy disposent de plusieurs instances ; cela signifie qu'il existe un jeu de compteurs pour chaque couche Application que vous avez configurée dans le fichier proxy.config.

En collectant ces données, vous disposerez d'informations sur les performances lors du fonctionnement du serveur proxy. Les compteurs de performance, tels que ceux-ci, jouent un rôle important dans la compréhension de l'état et dans l'optimisation de tous les aspects de Team Foundation Server.

Sécurité

Le proxy de contrôle de code source utilise un modèle de ticket pré-authentifié pour déterminer si un utilisateur demandeur est autorisé à consulter le contenu du fichier demandé. Dans ce modèle, le client de l'utilisateur contacte le serveur de contrôle de code source principal et si l'utilisateur est autorisé, le client reçoit un ticket signé numériquement contenant les détails du fichier qui est demandé. Le client présente ensuite le ticket au serveur proxy. Cette utilisation des signatures de clé publique/privée permet au proxy d'être certain que le ticket provient du serveur et que l'utilisateur est par conséquent autorisé à consulter le fichier. Le proxy examine ensuite le cache pour voir s'il peut répondre à la requête, et s'il ne peut pas, demande le fichier du serveur et l'ajoute au cache.

Voir aussi

Tâches

Comment : configurer le contrôle de code source Team Foundation pour utiliser un serveur proxy


Comment : configurer Team Foundation Server Proxy après l'installation

Comment : configurer Team Foundation Server Proxy après l'installation
Voir aussi

Après avoir installé le proxy de Team Foundation Server, configurez-le afin qu'il puisse gérer un cache de fichiers du contrôle de code source dans l'emplacement de l'équipe multisite. Après avoir installé et configuré le proxy, vous devez configurer le client pour utiliser le proxy. Ensuite, la gestion des fichiers est transparente.

Pour plus d'informations sur la configuration du client, consultez Comment : configurer le contrôle de code source Team Foundation pour utiliser un serveur proxy.

Pour configurer le proxy après l'installation

  1. Ouvrez l'Explorateur Windows et naviguez jusqu'au répertoire %ProgramFiles%\Microsoft Visual Studio 2005 Team Foundation Server\Web Services\VersionControlProxy.

  2. Ouvrez le fichier proxy.config avec un éditeur de texte.

  3. Localisez le jeton suivant et faites les substitutions appropriées, enregistrez-le, puis fermez le fichier :

    Paramètre Valeur

    @H_TFSSERVER@

    URL de votre couche Application de Team Foundation Server, par exemple :

    http://ContosoServer01:8080.

    Le port 8080 est le port défini pour la communication entre le proxy et la couche Application.

    Par exemple, après avoir fait les substitutions, l'URI de Team Foundation Server peut être similaire à :

    Image Copier le code Copier le code
    <Server>
<Uri>http://Contososerver01:8080/VersionControl</Uri>
</Server>

  4. Si le proxy doit être configuré pour cacher des fichiers sur plusieurs serveurs Team Foundation, ajoutez la section suivante une fois pour chaque serveur et apportez les substitutions appropriées, tel que précédemment indiqué :

    Image Copier le code Copier le code
    <Server>
<Uri>@H_TFSSERVER@/VersionControl</Uri>
</Server>

Consultez le Guide de l'administrateur Team Foundation Server (http://go.microsoft.com/fwlink/?linkid=52459) pour plus d'informations sur l'installation de proxy.

Voir aussi

Tâches

Comment : examiner les performances du proxy

Concepts

Fichier de configuration de Team Foundation Server Proxy


Comment : examiner les performances du proxy

Comment : examiner les performances du proxy

Si vous utilisez le proxy Team Foundation Server avec le contrôle de code source, vous pouvez souhaiter consulter ses performances. Les compteurs de performance sont installés par défaut et vous pouvez les consulter dans l'application Performance.

Utilisation de Perfmon.exe pour consulter les performances du proxy

  1. Cliquez sur Démarrer, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration, puis double-cliquez sur Performances.

    - ou -

    À l'invite de commandes, tapez perfmon. La Console de performance s'affiche.

  2. Dans le volet Moniteur système, cliquez avec le bouton droit et sélectionnez Ajouter des compteurs dans le menu contextuel.

  3. Si vous n'utilisez pas le serveur sur lequel vous avez installé TFS Proxy, tapez le nom du serveur dans la liste déroulante Choisir les compteurs sur.

  4. Dans la zone Objet de performance, sélectionnez Serveur proxy TFS. Les compteurs de performance associés à cet objet de performance sont répertoriés.

  5. Sélectionnez Tous les compteurs.

  6. Cliquez sur Fermer. Vous pouvez maintenant consulter les compteurs de performance utilisés par le proxy dans la fenêtre Moniteur système.

Pour utiliser le service Web de ProxyStatistics

  1. Les statistiques suivantes sont accessibles en appelant la méthode Web QueryProxyStatistics en naviguant jusqu'à la page Web V1.0\proxystatistics.asmx qui héberge le service Web VersionControl ProxyStatistics.

  2. Ouvrez une connexion bureau à distance au serveur sur lequel le proxy est installé. Vous pouvez appeler uniquement la méthode QueryProxyStatistics de l'ordinateur local sur lequel le proxy a été installé.

  3. Une fois que vous avez établi la connexion, ouvrez Internet Explorer et entrez cette adresse :

    http://localhost:8081/VersionControlProxy/v1.0/proxystatistics.asmx

  4. Sur la page proxystatistics.asmx, cliquez sur le lien QueryProxyStatistics.

  5. Cliquez sur Appeler pour afficher les statistiques suivantes :

    CurrentCacheSize

    NoOfRequests

    OverallCacheHits

    NoOfFilesInCache

    OverallCacheMisses (exécution @ calculée)

    CacheHitsPercentage (exécution @ calculée)

    CacheMissPercentage (exécution @ calculée)

    Le résultat de l'exemple se présente comme suit :

    Image Copier le code Copier le code
    <?xml version="1.0" encoding="utf-8" ?>
<ArrayOfProxyStatisticsInfo xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns="http://schemas.microsoft.com/TeamFoundation/2005/06/VersionControl/Statistics/02">
<ProxyStatisticsInfo CurrentCacheSize="0" NoOfRequests="3706" OverallCacheHits="3617" NoOfFilesInCache="0" OverallCacheMisses="89" CacheHitsPercentage="97.6" CacheMissPercentage="2.4" ServerId="643c23c1-3f47-43d2-b638-3bd0e7ea8bff" ServerUrl="http://contososerver:8080/VersionControl" />
</ArrayOfProxyStatisticsInfo>

Voir aussi

Concepts

Gestion des connexions à distance avec Team Foundation Server Proxy
Team Foundation Server Proxy et contrôle de code source Team Foundation


Gestion des sites Team Foundation Server dans Windows SharePoint Services

Gestion des sites Team Foundation Server dans Windows SharePoint Services
Voir aussi
DropDown image

Microsoft Windows SharePoint Services ajoute des fonctionnalités de publication Web et de collaboration de projet à Team Foundation permettant d'améliorer la communication et d'encourager le partage des idées chez les utilisateurs ayant des tâches assignées dans les projets d'équipe. Le portail de votre projet d'équipe fournit un emplacement central pour stocker des documents, publier des annonces, répertorier des informations de génération et faire un rapport sur l'état de votre projet d'équipe.

Vous pouvez effectuer plusieurs tâches qui affectent la connectivité d'ensemble et les performances d'un serveur exécutant Windows SharePoint Services et configuré pour Team Foundation. Certaines de ces tâches sont exécutées uniquement si nécessaire, par exemple, en spécifiant une connexion à un serveur Team Foundation Server qui exécute Windows SharePoint Services. Les autres tâches, telles que la synchronisation des utilisateurs de Team Foundation avec les utilisateurs de Windows SharePoint Services, devront peut-être être exécutées régulièrement.

En outre, vous pouvez personnaliser Windows SharePoint Services de plusieurs façons afin de mieux répondre aux besoins de votre organisation, notamment en personnalisant les documents, en répertoriant les informations de génération, en éditant des rapports ou en standardisant le guide de processus dans votre organisation.

Dans cette section

Présentation de Windows SharePoint Services

Décrit Windows SharePoint Services et fournit des liens vers d'autres informations.

Connexion à un serveur Windows SharePoint

Décrit les différents sites configurés par Team Foundation Server sur un Windows SharePoint Server ainsi que les sites par défaut dans Windows SharePoint Services.

Rôles de Windows SharePoint Services

Décrit les différents rôles par défaut disponibles dans Windows SharePoint Services.

Gestion des sites Windows SharePoint Services

Décrit différentes tâches d'administration Windows SharePoint Services.

Ressources externes

MSDN Online

Voir aussi

Tâches

Comment : définir les autorisations d'administrateur pour Windows SharePoint Services
Comment : définir les autorisations des coordinateurs de projet pour Windows SharePoint Services
Comment : définir les autorisations de collaborateur pour Windows SharePoint Services

Concepts

Autorisations de Team Foundation Server


Présentation de Windows SharePoint Services

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Présentation de Windows SharePoint Services
Voir aussi
Image de liste déroulante

L'intégration entre Team Foundation Server et Windows SharePoint Services fournit des informations puissantes aux administrateurs, coordinateurs de projet et collaborateurs de projet à propos du partage et des outils d'organisation. Cette intégration inclut un site Web de projet d'équipe où le guide de processus, les documents de projet, les modèles et les rapports peuvent être partagés avec les membres de l'équipe si nécessaire et en fonction du rôle de chaque membre de l'équipe dans le projet.

Documentation de Windows SharePoint Services

Windows SharePoint Services est une solution de partage d'informations et de collaboration complète avec sa propre documentation. Pour plus d'informations sur l'administration Windows SharePoint Services, consultez le Guide de l'administrateur Windows SharePoint Services Pour plus d'informations sur l'intégration de Windows SharePoint Services avec Team Foundation Server, consultez les rubriques suivantes.

Voir aussi

Concepts

Rôles de Windows SharePoint Services

Autres ressources

Gestion des sites Windows SharePoint Services


Connexion à un serveur Windows SharePoint

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Connexion à un serveur Windows SharePoint
Voir aussi
Image de liste déroulante

Team Foundation Server et Windows SharePoint Services sont intégrés sur la couche Application d'un serveur Team Foundation Server logique. La manière de vous connecter à un serveur de portail dépend de votre rôle de serveur et de si vous souhaitez configurer des paramètres administratifs généraux ou un site Web de projet spécifique.

Portails Windows SharePoint Services pour Team Foundation Server

L'intégration de Team Foundation Server avec Windows SharePoint Services inclut à la fois un site administratif pour contrôler les paramètres de base pour tous les sites Team Foundation Server sur le serveur de projet et un site Web de projet d'équipe pour chaque projet sur le serveur Team Foundation Server. Les serveurs de projet incluent un guide de processus, des documents de projet, des modèles et des fonctions de suivi des éléments de travail qui peuvent être partagés avec les membres de l'équipe autant que nécessaire et en fonction du rôle de chaque membre de l'équipe dans le projet.

Site administratif pour un serveur Team Foundation Server

Vous pouvez effectuer plusieurs tâches qui affectent la connectivité générale et les performances d'un serveur qui exécute Windows SharePoint Services à partir du site Web par défaut ou de niveau supérieur, également en tant que site administratif. Les tâches administratives importantes incluent l'ajout d'utilisateurs et de groupes, la définition des autorisations, ainsi que l'activation ou la désactivation des discussions de documents Web ou des alertes. Vous pouvez vous connecter au site administratif en ouvrant un navigateur Web et en tapant le nom de serveur du serveur de couche Application dans la barre d'adresses.

Sites de projet

À chaque fois que vous créez un projet dans Team Foundation Server, un site Web de projet est également créé. Le site de votre projet d'équipe fournit un emplacement central pour stocker des documents, publier des annonces, répertorier des informations de génération et faire un rapport sur l'état de votre projet d'équipe. Vous pouvez accorder aux utilisateurs des autorisations permettant de consulter le site Web de projet, d'y contribuer ou de l'administrer, le cas échéant.

Site d'administration centrale de Windows SharePoint Services

Pour administrer Windows SharePoint Services, vous devez ajouter un groupe d'administration à l'administration centrale. Windows SharePoint Services dispose d'un outil d'administration centrale séparé installé lorsque vous installez Windows SharePoint Services, appelé Administration centrale de SharePoint. Vous pouvez accéder à cet outil sur la couche Application de Team Foundation à partir du menu Démarrer.

Voir aussi

Tâches

Comment : créer, modifier et supprimer des sites Windows SharePoint Services
Comment : accéder à l'administration du site de Windows SharePoint Services

Concepts

Présentation de Windows SharePoint Services
Rôles de Windows SharePoint Services

Autres ressources

Gestion des sites Team Foundation Server dans Windows SharePoint Services


Rôles de Windows SharePoint Services

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Rôles de Windows SharePoint Services
Voir aussi
Image de liste déroulante

Windows SharePoint Services (WSS) inclut des groupes de sites pour vous aider à assigner des droits particuliers aux utilisateurs de Visual Studio Team Foundation Server. Avec les groupes de site, vous n'avez pas à contrôler séparément les autorisations de fichiers et de dossiers ou à vous inquiéter de garder vos groupes locaux synchronisés avec votre liste d'utilisateurs Web. Vous pouvez utiliser des outils d'administration Windows SharePoint Services pour donner des autorisations distinctes aux membres du projet sur chacun des sites Web de votre projet.

De ce fait, la gestion des utilisateurs effectuée par les administrateurs Team Foundation Server peut être déléguée aux coordinateurs de projet, une fois que le coordinateur de projet est devenu l'administrateur du site du projet. Les administrateurs de site contrôlent l'accès au site et, par défaut, possèdent des droits qui leur permettent d'ajouter, de supprimer ou de modifier l'appartenance au groupe du site pour les utilisateurs. À l'intérieur d'une organisation, cela signifie en général que les administrateurs de site peuvent sélectionner des utilisateurs dans la liste des utilisateurs de l'organisation et leur octroyer un accès selon leurs rôles et leurs besoins dans un projet. Par exemple, si le site Web est le portail d'informations et de documents des membres d'une équipe participant à un projet particulier, l'administrateur de site ajoute les membres de cette équipe au groupe de site Collaborateur, afin que les membres de l'équipe puissent ajouter des documents et mettre à jour les listes.

Pour un site Web de niveau supérieur, les membres du groupe de site Administrateur contrôlent plus d'options et de fonctionnalités du serveur SharePoint que les administrateurs d'un site de projet individuel. Les administrateurs d'un site Web de niveau supérieur peuvent exécuter des actions telles que l'activation ou la désactivation des discussions de documents Web ou des alertes, l'affichage de données d'utilisation et de quota et la modification des paramètres d'accès anonyme.

Remarque Remarque

L'administration de site est distincte de l'Administration centrale de Windows SharePoint Services. L'administration de site est accessible via l'outil Administration centrale de SharePoint.

Quatre groupes Windows SharePoint Services sont décrits ci-dessous :

  • Administrateur

  • Concepteur Web

  • Collaborateur

  • Lecteur

Pour plus d'informations sur les groupes Windows SharePoint Services et Windows SharePoint Services, consultez la documentation du produit Windows SharePoint Services.

Remarque Important

Limitez l'appartenance aux groupes Windows SharePoint aux utilisateurs qui nécessitent un niveau spécifique d'accès et d'autorisations accordé par l'appartenance à ce groupe. Ajoutez un utilisateur ou un groupe au groupe Windows SharePoint Services qui possède les autorisations minimales requises permettant à l'utilisateur ou au groupe de remplir son rôle dans un projet d'équipe. Par exemple, si un utilisateur doit seulement consulter le contenu d'un site Web de projet d'équipe, ajoutez l'utilisateur au groupe §§§Lecteur, et pas au groupe Collaborateur.

Administrateur

Pour créer un administrateur de site, ajoutez un compte d'utilisateur existant au groupe Administrateur du site de niveau supérieur dans Windows SharePoint Services.

Remarque Remarque

Le compte d'utilisateur qui a été utilisé pour installer Team Foundation Server est automatiquement ajouté en tant que membre du rôle Administrateur pour le site de niveau supérieur. Pour plus d'informations sur l'administration Windows SharePoint Services, consultez le Guide de l'administrateur Windows SharePoint Services

Concepteur Web

Un membre du rôle Concepteur Web de Windows SharePoint Services peut créer des listes et des bibliothèques de documents et personnaliser des pages du site Web. Pour permettre à un utilisateur de personnaliser un site Web d'un projet Team Foundation, ajoutez un compte d'utilisateur existant au groupe Concepteur Web du site de projet dans Windows SharePoint Services.

Collaborateur

Un membre du rôle Collaborateur de Windows SharePoint Services peut ajouter le contenu aux bibliothèques et listes de documents existants. Pour permettre à un utilisateur d'apporter du contenu au site Web d'un projet Team Foundation, ajoutez un compte d'utilisateur existant au groupe Collaborateur du site de projet dans Windows SharePoint Services.

Lecteur

Un membre du groupe Lecteur de Windows SharePoint Services possède un accès en lecture seule au site Web. Pour permettre à un utilisateur de lire un site Web d'un projet Team Foundation, ajoutez un compte d'utilisateur existant au groupe Lecteur du site de projet dans Windows SharePoint Services.

Voir aussi

Tâches

Comment : accéder à l'administration du site de Windows SharePoint Services
Comment : définir les autorisations d'administrateur pour Windows SharePoint Services
Comment : définir les autorisations des coordinateurs de projet pour Windows SharePoint Services
Comment : définir les autorisations de collaborateur pour Windows SharePoint Services

Autres ressources

Gestion des utilisateurs
Gestion des groupes


Gestion des sites Windows SharePoint Services

Gestion des sites Windows SharePoint Services
DropDown image

Un site Web Windows SharePoint Service par défaut est créé automatiquement lors de l'installation de Team Foundation Server. De plus, chaque fois que vous créez un nouveau projet dans Team Foundation Server, un site Web de projet est créé automatiquement. Vous pouvez toutefois créer des sites Web supplémentaires à utiliser avec Team Foundation Server. Vous pouvez également modifier et supprimer ces sites Web Windows SharePoint Services.

Dans cette section

Comment : accéder à l'administration du site de Windows SharePoint Services

Décrit comment accéder aux fonctions administratives de Windows SharePoint Server.

Comment : créer, modifier et supprimer des sites Windows SharePoint Services

Décrit comment créer, modifier et supprimer des sites sur Windows SharePoint Server.

Voir aussi

Autres ressources

Gestion des sites Team Foundation Server dans Windows SharePoint Services


Comment : accéder à l'administration du site de Windows SharePoint Services

Comment : accéder à l'administration du site de Windows SharePoint Services
Voir aussi

Un site Web Windows SharePoint Service par défaut est configuré automatiquement lors de l'installation de Visual Studio Team Foundation Server. Ce site Web de niveau supérieur vous permet de contrôler toutes les options et les fonctionnalités du serveur Windows SharePoint. Les administrateurs d'un site Web de niveau supérieur peuvent exécuter des actions telles qu'activer ou désactiver des discussions ou des alertes de document Web, consulter des données d'utilisation et de quota ainsi que modifier des paramètres d'accès anonyme ; enfin les administrateurs peuvent également contrôler l'accès du site et ajouter, supprimer ou modifier l'appartenance à des groupes de site.

Remarque Remarque

L'administration de site est distincte d'Administration centrale de Windows SharePoint Services, accessible via l'outil Administration centrale de SharePoint.

Pour accéder à l'administration de site Windows SharePoint Service

  1. Ouvrez Internet Explorer.

  2. Dans la barre d'adresses, tapez le nom du serveur de couche Application pour accéder au site Windows SharePoint Service de niveau supérieur. Pour consulter le nom du serveur de couche Application, ouvrez Visual Studio, et dans Team Explorer, cliquez avec le bouton droit sur le nom de serveur, puis cliquez sur Propriétés.

Pour ajouter un membre au groupe Administration de SharePoint

  1. Sur la couche Application Team Foundation, cliquez sur Démarrer, pointez sur Outils d'administration, puis cliquez sur Administration centrale de SharePoint.

  2. Dans Administration centrale, cliquez sur Définir le groupe d'administration SharePoint.

  3. Dans Définir le groupe d'administration SharePoint, tapez le nom du compte de groupe et le domaine (le cas échéant).

    Remarque Remarque

    Vous pouvez ajouter un seul groupe ou utilisateur de domaine au groupe Administration de SharePoint. Vous ne pouvez pas ajouter de groupe local. Toutefois, les membres du groupe Administrateurs local sur le serveur peuvent également effectuer des tâches d'administration pour les produits et les technologies Windows SharePoint Services.

  4. Cliquez sur OK.

Voir aussi

Tâches

Comment : définir les autorisations d'administrateur pour Windows SharePoint Services
Comment : créer, modifier et supprimer des sites Windows SharePoint Services

Concepts

Présentation de Windows SharePoint Services
Connexion à un serveur Windows SharePoint
Rôles de Windows SharePoint Services


Comment : créer, modifier et supprimer des sites Windows SharePoint Services

Comment : créer, modifier et supprimer des sites Windows SharePoint Services
Voir aussi

Un site Web Windows SharePoint Service par défaut est créé automatiquement lors de l'installation de Visual Studio Team Foundation Server. De plus, chaque fois que vous créez un nouveau projet dans Team Foundation Server, un portail de projet est créé automatiquement. Vous pouvez toutefois créer des sites Web supplémentaires à utiliser avec Team Foundation Server. Vous pouvez également modifier et supprimer ces sites Web Windows SharePoint Services. Pour plus d'informations sur les sites et l'administration de Windows SharePoint Services, consultez le Guide de l'administrateur Windows SharePoint Services

Attention Attention

Vous ne devez pas supprimer un site Web de projet ou un site Web d'administration par défaut à moins que vous ne quittiez le projet et/ou le serveur Team Foundation Server.

Pour créer un site sur le serveur Windows SharePoint Services

  1. Ouvrez Internet Explorer.

  2. Dans la barre d'adresses, tapez le nom du serveur de couche Application pour accéder au site Windows SharePoint Service de niveau supérieur. Pour consulter le nom du serveur de couche Application, ouvrez Visual Studio, et dans Team Explorer, cliquez avec le bouton droit sur le nom de serveur, puis cliquez sur Propriétés.

  3. Cliquez sur Créer.

  4. Dans Créer une page, sous Pages Web, cliquez sur Sites et espaces de travail.

  5. Dans Nouveau Site SharePoint, dans Titre et description, tapez un titre et une description pour le nouveau site.

  6. Dans Adresse du site Web, tapez un nom d'URL. Le nom d'URL sera automatiquement précédé par l'adresse du serveur de couche Application.

  7. Dans Autorisations, sélectionnez les autorisations utilisateur appropriées pour votre nouveau site.

  8. Cliquez sur Créer.

  9. Dans Sélection du modèle, sélectionnez le modèle approprié pour le processus que vous souhaitez suivre. Par exemple, si vous créez un site Web pour un projet qui utilise MSF Agile, sélectionnez TFS pour MSF Agile.

  10. Cliquez sur OK.

Pour supprimer un site sur le serveur Windows SharePoint Services

  1. Ouvrez Internet Explorer.

  2. Dans la barre d'adresses, tapez le nom du site Web que vous souhaitez supprimer. Le nom sera précédé du nom de serveur de couche Application.

  3. Cliquez sur Paramètres du site.

  4. Dans Paramètres du site, dans Administration, cliquez sur Aller à l'administration du site.

  5. Dans Administration de site, dans Gestion et statistiques, cliquez sur Supprimer ce site.

  6. Dans Supprimer le site Web, cliquez sur Supprimer.

Pour modifier un site sur le serveur Windows SharePoint Services

  1. Ouvrez Internet Explorer.

  2. Dans la barre d'adresses, tapez le nom du site Web que vous souhaitez modifier. Le nom sera précédé du nom de serveur de couche Application.

  3. Cliquez sur Paramètres du site.

  4. Modifiez les paramètres du site pour modifier l'apparence du site, ajouter ou supprimer des données, etc. Pour plus d'informations sur les modifications du site Windows SharePoint Services, consultez le Guide de l'administrateur Windows SharePoint Services

Voir aussi

Tâches

Comment : accéder à l'administration du site de Windows SharePoint Services

Concepts

Présentation de Windows SharePoint Services
Rôles de Windows SharePoint Services


Gestion des paramètres de configuration de Team Foundation Server

Gestion des paramètres de configuration de Team Foundation Server
DropDown image

Vous pouvez utiliser les fichiers web.config et les services Web intégrés du composant Team Foundation Server pour configurer les divers aspects de l'environnement Team Foundation Server. Les rubriques répertoriées ci-dessous contiennent des informations qui décrivent comment utiliser les services Web et les fichiers web.config pour configurer l'environnement Team Foundation Server.

Dans cette section

Activation du traçage pour les composants Team Foundation Server

Contient des liens vers les rubriques expliquant comment activer et configurer le traçage pour Team Foundation Server.

Paramètres du fichier Web.Config global dans les composants Team Foundation Server

Décrit les paramètres contenus dans le fichier web.config global.

Paramètres du fichier de génération Web.Config dans les composants Team Foundation Server

Décrit les paramètres contenus dans le fichier web.config de build.

Paramètres du fichier Web.Config de services dans les composants Team Foundation Server

Décrit les paramètres contenus dans le fichier web.config des services.

Paramètres du fichier Web.Config de contrôle de version dans les composants Team Foundation Server

Décrit les paramètres contenus dans le fichier web.config de contrôle de version.

Paramètres du fichier Web.Config de suivi des éléments de travail dans les composants Team Foundation Server

Décrit les paramètres contenus dans le fichier web.config des éléments de travail.

Comment : modifier les paramètres Web.Config des composants Team Foundation Server

Fournit une procédure générique pour modifier les paramètres web.config dans Team Foundation Server.

Comment : définir la taille maximale des pièces jointes pour les éléments de travail

Décrit comment définir la taille de pièce jointe maximale pour les éléments de travail.

Comment : définir l'intervalle de traitement pour l'entrepôt de données

Explique comment définir l'intervalle de traitement pour l'entrepôt de données.


Activation du traçage pour les composants Team Foundation Server

Activation du traçage pour les composants Team Foundation Server
Voir aussi
DropDown image

Le traçage vous permet d'enregistrer des informations en temps réel à propos de l'exécution et des performances d'application et peut être utilisé pour aider à diagnostiquer des problèmes qui se produisent sur le serveur. Bien qu'elle soit utile pour diagnostiquer des problèmes, l'activation du traçage doit uniquement être utilisée comme dépannage car elle peut avoir un effet négatif sur les performances du serveur. Cette section contient des liens qui décrivent comment activer et configurer le traçage pour Team Foundation Server.

Dans cette section

Paramètres de traçage de Team Foundation Server

Décrit les paramètres disponibles pour le traçage dans Team Foundation Server.

Comment : utiliser les services Web pour activer et configurer le traçage pour les composants Team Foundation Server

Explique comment utiliser les services Web intégrés pour activer et configurer le traçage dans Team Foundation Server.

Comment : modifier le répertoire de sortie de trace des composants Team Foundation Server

Décrit comment modifier le répertoire de sortie pour les journaux des traces.

Voir aussi

Autres ressources

Traçage et instrumentation d'applications


Paramètres de traçage de Team Foundation Server

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Paramètres de traçage de Team Foundation Server
Voir aussi
Image de liste déroulante

Vous pouvez utiliser des commutateurs de trace intégrés pour obtenir des informations d'exécution sur les performances et l'exécution de votre application. Cette rubrique décrit les paramètres de traçage spécifiques à Team Foundation Server. Pour des informations générales sur le traçage, consultez Traçage et instrumentation d'applications.

Commutateurs de trace Team Foundation

Les commutateurs de trace suivants sont disponibles dans Team Foundation Server. Pour plus d'informations sur l'activation de tous ces commutateurs, consultez Comment : utiliser les services Web pour activer et configurer le traçage pour les composants Team Foundation Server. Pour activer des commutateurs, vous devez modifier le fichier web.config de Team Foundation Server de la manière décrite dans Comment : modifier les paramètres Web.Config des composants Team Foundation Server.

Paramètre | Description
API | Effectue le traçage de l'utilisation des méthodes Web, des appels de service Web à service Web (du point de vue de l'appelant) et des méthodes publiques.
Authentification | Effectue le traçage de l'interaction d'authentification.
Autorisation | Effectue le traçage des composants liés à l'autorisation, tels que le gestionnaire de sécurité de contrôle de version.
Base de données | Effectue le traçage de l'interaction de bases de données de votre composant.
EqtTraceLevel | Effectue le traçage des composants des outils Team Foundation Build, Team Edition for Developers et Team Edition for Testers.
traceLevel | Effectue le traçage des composants de suivi des éléments de travail.
eSwitch | Effectue le traçage des services d'intégration et des composants d'entrepôt de données.
Général | Effectue le traçage des cas qui ne correspondent pas aux catégories ci-dessus ; il s'agit d'une catégorie passe-partout.

Paramètres de commutateur de trace

Chaque commutateur peut avoir la valeur de l'un des cinq paramètres qui déterminent la quantité d'informations qui est enregistrée. Pour plus d'informations, consultez Commutateurs de traçage.

Commutateur de trace | Informations de traçage enregistrées
0 | Aucun
1 | Erreurs
2 | Avertissements
3 | Information
4 | Verbose

Voir aussi

Tâches

Comment : modifier les paramètres Web.Config des composants Team Foundation Server
Comment : utiliser les services Web pour activer et configurer le traçage pour les composants Team Foundation Server
Comment : modifier le répertoire de sortie de trace des composants Team Foundation Server

Concepts

Commutateurs de traçage

Autres ressources

Traçage et instrumentation d'applications
Activation du traçage pour les composants Team Foundation Server


Comment : utiliser les services Web pour activer et configurer le traçage pour les composants Team Foundation Server

Comment : utiliser les services Web pour activer et configurer le traçage pour les composants Team Foundation Server
Voir aussi

Vous pouvez utiliser des services Web intégrés pour activer le traçage des applications Team Foundation Server. Cela vous permet de rassembler des informations d'état sur un processus sans recycler le pool d'applications. Vous pouvez démarrer la collecte d'informations après qu'un problème a été détecté. Cette rubrique décrit comment activer le traçage pour les applications Team Foundation Server individuelles. Pour des informations générales sur le traçage, consultez Traçage et instrumentation d'applications.

Vous pouvez utiliser uniquement le service Web pour activer ou désactiver tous les commutateurs de traçage intégrés. Pour activer ou désactiver les commutateurs de traçage individuels, vous devez modifier manuellement le fichier web.config de Team Foundation Server comme indiqué dans Comment : modifier les paramètres Web.Config des composants Team Foundation Server.

Remarque Remarque

Lorsque le traçage est activé à l'aide de cette méthode, les paramètres de traçage ne sont pas rendus persistants lorsque le pool d'applications est répété. Pour les modifications persistantes apportées à l'état du traçage, vous devez modifier le fichier web.config comme indiqué dans Comment : modifier les paramètres Web.Config des composants Team Foundation Server.

Pour activer le traçage pour les applications Team Foundation Server

  • Dans Internet Explorer, recherchez l'URL suivante :

    Image Copier le code Copier le code
    http://<tfsserver>:<port>/<WebService>/tftrace.aspx?[traceWriter=<true|false>][&][All=<traceLevel>]

    Dans cette syntaxe, <tfsserver> représente le nom du serveur Team Foundation Server. <Port> représente le port, généralement 8080. <WebService> représente le nom de l'application Team Foundation Server pour laquelle vous souhaitez activer le traçage. Les arguments traceWriter et All sont facultatifs. Pour obtenir des exemples et des valeurs valides pour les arguments <WebService> et <traceLevel>, consultez ce qui suit.

    Les valeurs valides pour <WebService> sont Build, services, VersionControl, Warehouse et WorkItemTracking. Les valeurs valides pour l'argument All sont None, Errors, Warnings, Information et Verbose.

    Cet exemple affecte Verbose à tous les commutateurs de traçage VersionControl et n'affecte pas la valeur traceWriter :

    Image Copier le code Copier le code
    http://<tfsserver>:8080/VersionControl/tftrace.aspx?All=Verbose

    Cet exemple affecte Error à tous les commutateurs de traçage Warehouse et affecte true à la valeur traceWriter :

    Image Copier le code Copier le code
    http://<tfsserver>:8080/Warehouse/tftrace.aspx?traceWriter=true&All=Error

Voir aussi

Tâches

Comment : modifier le répertoire de sortie de trace des composants Team Foundation Server
Comment : modifier les paramètres Web.Config des composants Team Foundation Server

Autres ressources

Activation du traçage pour les composants Team Foundation Server


Comment : modifier le répertoire de sortie de trace des composants Team Foundation Server

Comment : modifier le répertoire de sortie de trace des composants Team Foundation Server
Voir aussi

Vous pouvez modifier le répertoire de sortie des fichiers de trace du composant Team Foundation Server en modifiant le fichier web.config pour ce composant.

Pour modifier le répertoire de sortie de trace d'un composant Team Foundation Server

  1. Dans Windows, dans le menu Démarrer, choisissez Panneau de configuration, Outils d'administration, puis Gestionnaire des services Internet (IIS).

    Le Gestionnaire des services IIS s'ouvre.

  2. Dans le panneau gauche, développez le nom du serveur, Sites Web, puis Team Foundation Server.

  3. Sélectionnez l'élément Team Foundation Server que vous souhaitez modifier. Par exemple, si vous souhaitez configurer les paramètres d'entrepôt, sélectionnez Entrepôt. Pour les paramètres de niveau serveur, sélectionnez Team Foundation Server.

  4. Dans le panneau droit, double-cliquez sur web.config.

    La fenêtre Propriétés de web.config s'ouvre.

  5. Sélectionnez l'onglet ASP.NET, puis cliquez sur Modifier la configuration.

    La fenêtre Paramètres de configuration ASP.NET s'ouvre.

  6. Dans la zone Paramètres de l'application, sélectionnez la ligne du traceDirectoryName que vous souhaitez modifier et cliquez sur Modifier.

    La boîte de dialogue Modifier/ajouter des paramètres d'application s'ouvre.

  7. Dans la zone Valeur, entrez le nouveau répertoire de sortie de trace et cliquez sur OK.

Voir aussi

Tâches

Comment : utiliser les services Web pour activer et configurer le traçage pour les composants Team Foundation Server

Concepts

Paramètres de traçage de Team Foundation Server

Autres ressources

Activation du traçage pour les composants Team Foundation Server


Paramètres du fichier Web.Config global dans les composants Team Foundation Server

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Paramètres du fichier Web.Config global dans les composants Team Foundation Server
Voir aussi
Image de liste déroulante

Cette rubrique décrit les paramètres configurables dans le fichier web.config global de Team Foundation Server. Pour obtenir une procédure générale qui explique comment accéder à ces paramètres et les modifier, consultez Comment : modifier les paramètres Web.Config des composants Team Foundation Server.

Paramètres du fichier web.config global

Paramètre Description

sqlTimeout

Ce paramètre est une valeur numérique qui représente le délai d'attente en secondes pour toutes les commandes SQL.

CommandLogging

Ce paramètre est une chaîne qui est utilisée pour spécifier le comportement d'enregistrement dans le journal des méthodes de service Web. Les valeurs valides sont les suivantes :

None Les méthodes Web ne sont jamais enregistrées dans le journal.

OnError Les méthodes Web qui rencontrent des erreurs sont enregistrées dans le journal.

ReadWrite Les méthodes Web qui modifient des bases de données sont enregistrées dans le journal.

Normal Comme ReadWrite, avec les méthodes Web qui ne modifient pas de bases de données en plus.

LightWeight Comme ReadWrite, avec les méthodes Web qui disposent de l'accès aux bases de données minimal en plus.

All Toutes les méthodes Web sont enregistrées dans le journal ; en outre, les détails de la requête de méthode de service Web sont toujours inclus lorsqu'ils sont disponibles.

La valeur par défaut est None.

TfsNameUrl

Ce paramètre est l'URL pour le serveur de couche Application. Il est utilisé par tous les services Web Team Foundation Server pour rechercher les autres services Web qui sont exécutés sur l'ordinateur à l'aide du service Web Services\registration.asmx.

Attention Attention

Ce paramètre ne doit pas être modifié.

TFS Name

Ce paramètre est une chaîne qui représente le nom de l'ordinateur de couche Application.

Ce paramètre ne doit pas être modifié.

TfsUrlPublic

Ce paramètre représente l'URL Internet utilisée pour construire l'URL complète pour la récupération d'artefact, telle que les éléments de travail, et apparaît dans les notifications par courrier électronique des alertes de projet.

traceWriter

Ce paramètre est une valeur Boolean qui détermine si le traçage est activé ou désactivé. Affectez true à cette valeur pour récupérer les informations de traçage dans un fichier. Les commutateurs de trace dans la section system.diagnostics du fichier web.config déterminent les types et la quantité des informations récupérées. Pour plus d'informations, consultez Activation du traçage pour les composants Team Foundation Server.

Remarque Remarque

L'activation du traçage crée des demandes d'exécution supplémentaires et augmentera l'utilisation des E/S et du processeur sur la couche Application.

traceDirectoryName

Ce paramètre est une valeur string qui représente l'emplacement du dossier pour les fichiers de trace.

Voir aussi

Tâches

Comment : modifier les paramètres Web.Config des composants Team Foundation Server

Autres ressources

Activation du traçage pour les composants Team Foundation Server
Gestion des paramètres de configuration de Team Foundation Server


Paramètres du fichier de génération Web.Config dans les composants Team Foundation Server

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Paramètres du fichier de génération Web.Config dans les composants Team Foundation Server
Voir aussi
Image de liste déroulante

Cette rubrique décrit les paramètres configurables dans le fichier web.config de build. Pour obtenir une procédure générale qui explique comment accéder à ces paramètres et les modifier, consultez Comment : modifier les paramètres Web.Config des composants Team Foundation Server.

Paramètres du Web.Config de suivi de la génération

Paramètre | Description
port | Ce paramètre est une valeur numérique qui représente le numéro de port utilisé par l'ordinateur de build. Il doit être synchronisé avec le port dans Teambuildservice.exe.config sur l'ordinateur de build.

Voir aussi

Tâches

Comment : modifier les paramètres Web.Config des composants Team Foundation Server

Concepts

Paramètres du fichier Web.Config global dans les composants Team Foundation Server

Autres ressources

Gestion des paramètres de configuration de Team Foundation Server


Paramètres du fichier Web.Config de services dans les composants Team Foundation Server

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Paramètres du fichier Web.Config de services dans les composants Team Foundation Server
Voir aussi
Image de liste déroulante

Cette rubrique décrit les paramètres configurables dans le fichier web.config de services. Pour obtenir une procédure générale qui explique comment accéder à ces paramètres et les modifier, consultez Comment : modifier les paramètres Web.Config des composants Team Foundation Server.

Paramètres du fichier web.config de services

Paramètre | Description
ConnectionString | Ce paramètre de type string représente la chaîne de connexion utilisée par la couche Application pour se connecter à la couche Données.
eventingEnabled | Ce paramètre est une valeur Boolean qui active ou désactive le système d'événements (alertes) du serveur Team Foundation Server.
emailNotificationFromAddress | Ce paramètre de type string représente l'adresse d'origine dans les notifications par courrier électronique de Team Foundation Server pour les archivages, les éléments de travail qui vous sont assignés, etc. La validité de cette adresse est également vérifiée et en fonction de votre configuration serveur, l'adresse peut devoir correspondre à un compte de messagerie valide sur le serveur de messagerie. Si elle n'existe pas ou n'est pas valide, l'adresse utilisée sera TeamSystem@microsoft.com.
smtpServer | Ce paramètre de type string représente le nom du serveur de messagerie.

Voir aussi

Tâches

Comment : modifier les paramètres Web.Config des composants Team Foundation Server

Concepts

Paramètres du fichier Web.Config global dans les composants Team Foundation Server

Autres ressources

Gestion des paramètres de configuration de Team Foundation Server


Paramètres du fichier Web.Config de contrôle de version dans les composants Team Foundation Server

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Paramètres du fichier Web.Config de contrôle de version dans les composants Team Foundation Server
Voir aussi
Image de liste déroulante

Cette rubrique décrit les paramètres configurables dans le fichier web.config de contrôle de version. Pour obtenir une procédure générale qui explique comment accéder à ces paramètres et les modifier, consultez Comment : modifier les paramètres Web.Config des composants Team Foundation Server.

Paramètres du Web.Config de contrôle de version

Paramètre | Description
fileCacheRoot | Ce paramètre est une chaîne qui décrit le chemin d'accès au répertoire qui sert de racine du cache pour le fichier de serveur de contrôle de version.
CacheLimitPercent | Ce paramètre est une valeur numérique qui représente le pourcentage d'espace disque qui peut être utilisé pour le cache.
CacheLimit | Ce paramètre est une valeur numérique qui représente la taille limite du cache, en mégaoctets.
CacheDeletionPercent | Ce paramètre est une valeur numérique qui représente le pourcentage du cache qui sera vidé lorsque la limite du cache est atteinte.
LastWriteTimeUpdateWindow | Ce paramètre indique l'intervalle de temps en heures pour la mise à jour de l'attribut LastWriteTime d'un fichier dans le cache. Ce paramètre empêche la mise à jour de LastWriteTime à chaque requête d'accès au cache et effectue uniquement une mise à jour après l'expiration de la durée spécifiée dans LastWriteTimeUpdateWindow. La valeur par défaut de ce paramètre est de 8 heures et peut varier de 1 à 24 heures.
StatisticsPersistTime | Cet élément indique la fréquence en heures à laquelle les statistiques doivent être écrites sur le disque. La valeur par défaut est de 1 heure et les valeurs peuvent aller de 1 à 24 heures.

Voir aussi

Tâches

Comment : modifier les paramètres Web.Config des composants Team Foundation Server

Concepts

Paramètres du fichier Web.Config global dans les composants Team Foundation Server

Autres ressources

Gestion des paramètres de configuration de Team Foundation Server


Paramètres du fichier Web.Config de suivi des éléments de travail dans les composants Team Foundation Server

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Paramètres du fichier Web.Config de suivi des éléments de travail dans les composants Team Foundation Server
Voir aussi
Image de liste déroulante

Cette rubrique décrit les paramètres configurables dans le fichier Web.Config de suivi des éléments de travail. Pour obtenir une procédure générale qui explique comment accéder à ces paramètres et les modifier, consultez Comment : modifier les paramètres Web.Config des composants Team Foundation Server.

Paramètres du fichier Web.Config de suivi des éléments de travail

Paramètre | Description
WorkItemChangedEvent | Ce paramètre représente une valeur Boolean. Si la valeur est true, l'événement modifié de l'élément de travail est déclenché. Cet événement est utilisé par la fonctionnalité de notification par courrier électronique. Il s'agit d'un sous-ensemble d'événement de Team Foundation Server contrôlé par le paramètre global eventingEnabled. Si eventingEnabled a la valeur false, les événements ne seront pas déclenchés indépendamment de la valeur de ce paramètre. Pour plus d'informations, consultez Paramètres du fichier Web.Config global dans les composants Team Foundation Server.

Voir aussi

Tâches

Comment : modifier les paramètres Web.Config des composants Team Foundation Server

Concepts

Paramètres du fichier Web.Config global dans les composants Team Foundation Server

Autres ressources

Gestion des paramètres de configuration de Team Foundation Server


Comment : modifier les paramètres Web.Config des composants Team Foundation Server

Comment : modifier les paramètres Web.Config des composants Team Foundation Server
Voir aussi

Les informations de configuration pour Team Foundation Server sont contenues dans divers fichiers web.config. Cette rubrique décrit une procédure générale pour modifier ces paramètres de configuration.

Pour modifier un paramètre web.config

  1. Dans Windows, dans le menu Démarrer, choisissez Panneau de configuration, Outils d'administration, puis Gestionnaire des services Internet (IIS).

    Le Gestionnaire des services IIS s'ouvre.

  2. Dans le panneau gauche, développez le nom du serveur, Sites Web, puis Team Foundation Server.

  3. Sélectionnez l'élément Team Foundation Server que vous souhaitez modifier. Par exemple, si vous souhaitez configurer les paramètres d'entrepôt, sélectionnez Entrepôt. Pour les paramètres globaux, sélectionnez Team Foundation Server.

  4. Cliquez avec le bouton droit sur l'élément sélectionné et choisissez Propriétés.

    La fenêtre Propriétés s'ouvre.

  5. Sélectionnez l'onglet ASP.NET, puis cliquez sur Modifier la configuration.

    La fenêtre Paramètres de configuration ASP.NET s'ouvre.

  6. Dans la boîte de dialogue Paramètres de l'application, choisissez la clé que vous souhaitez modifier et cliquer sur Modifier.

    La boîte de dialogue Modifier/ajouter des paramètres d'application s'ouvre.

  7. Dans la zone Valeur, tapez la nouvelle valeur et cliquez sur OK.

    Vous devez redémarrer l'application pour que les modifications apportées au fichier web.config prennent effet.

Voir aussi

Concepts

Paramètres du fichier Web.Config global dans les composants Team Foundation Server
Paramètres du fichier de génération Web.Config dans les composants Team Foundation Server
Paramètres du fichier Web.Config de services dans les composants Team Foundation Server
Paramètres du fichier Web.Config de suivi des éléments de travail dans les composants Team Foundation Server

Autres ressources

Gestion des paramètres de configuration de Team Foundation Server


Comment : définir la taille maximale des pièces jointes pour les éléments de travail

Comment : définir la taille maximale des pièces jointes pour les éléments de travail
Voir aussi

Vous pouvez utiliser les services Web intégrés pour définir la taille maximale des pièces jointes pour les éléments de travail.

Pour définir la taille maximale des pièces jointes pour les éléments de travail

  1. Dans Internet Explorer, recherchez l'URL suivante :

    Image Copier le code Copier le code
    http://<tfsserver>:8080/WorkItemTracking/v1.0/ConfigurationSettingsService.asmx?op=SetMaxAttachmentSize

    où <tfsserver> représente le nom du serveur Team Foundation Server.

  2. Dans la zone MaxSize, entrez la taille maximale des pièces jointes en octets, puis cliquez sur Appeler. La taille maximale des pièces jointes est de 2 gigaoctets.

Voir aussi

Concepts

Attribution d'une taille limite aux pièces jointes

Autres ressources

Gestion des paramètres de configuration de Team Foundation Server


Comment : définir l'intervalle de traitement pour l'entrepôt de données

Comment : définir l'intervalle de traitement pour l'entrepôt de données
Voir aussi

Vous pouvez utiliser les services Web d'entrepôt de données intégrés pour modifier l'intervalle de traitement de l'entrepôt de données.

Pour définir l'intervalle de traitement pour l'entrepôt de données

  1. Dans Internet Explorer, reportez-vous à l'URL suivante :

    Image Copier le code Copier le code
    http://<tfsserver>:8080/Warehouse/v1.0/warehousecontroller.asmx?op=ChangeSetting

    où <tfsserver> représente le nom de Team Foundation Server. Une page contenant deux zones intitulées settingID et newValue s'ouvre.

  2. Dans la zone intitulée settingID, tapez RunIntervalSeconds.

  3. Dans la zone intitulée newValue, tapez le nouvel intervalle en secondes.

  4. Cliquez sur Appeler pour modifier le paramètre.

Voir aussi

Concepts

Synchronisation de la planification avec l'entrepôt de données

Autres ressources

Gestion des paramètres de configuration de Team Foundation Server


Fichier de configuration de Team Foundation Server Proxy

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Fichier de configuration de Team Foundation Server Proxy
Voir aussi
Image de liste déroulante

Team Foundation Server Proxy possède un fichier de configuration XML distinct qui maintient des informations requises pour la configuration du proxy. Cette rubrique décrit les nœuds trouvés dans ce fichier et leur effet sur la configuration de Team Foundation Server Proxy.

Nœuds de configuration de Team Foundation Server Proxy

Les nœuds XML suivants sont recherchés dans le fichier de configuration de Team Foundation Server Proxy localisé au niveau de %ProgramFiles%\Microsoft Visual Studio 2005 Team Foundation Server\Web Services\VersionControlProxy\proxy.config

Nœud Explication

<ProxyConfiguration>

Il s'agit de l'élément racine du fichier de configuration du proxy. Par exemple :

<ProxyConfiguration

xmlns:xsd="http://www.w3.org/2001/XMLSchema"

xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

<!-- Additional nodes omitted for clarity -->

</ProxyConfiguration>

<Servers>

Ce nœud représente une collection de nœuds du <Server> qui correspondent à la couche Application depuis laquelle le proxy sert des fichiers. Chaque nœud de <Server> contient un nœud de <Uri> qui spécifie l'URI du répertoire virtuel VersionControl de la couche Application. Par exemple :

Image Copier le code Copier le code
<Servers>
   <Server>
      <Uri>http://tfserver:8080/VersionControl</Uri>
   </Server>
</Servers>

<CacheRoot>

Ce nœud contient le répertoire racine du cache du fichier. Ce répertoire contient un dossier unique pour chaque couche Application pour laquelle le proxy est configuré. Par exemple :

Image Copier le code Copier le code
<CacheRoot>C:\Program Files\Microsoft Visual Studio 2005 Team Foundation Server\Web Services\VersionControlProxy\Data</CacheRoot>

<CacheLimitPolicy>

Ce nœud spécifie à quel point le proxy exécutera la routine de nettoyage pour supprimer des fichiers périmés. Il peut être configuré de l'une de ces deux manières : vous pouvez utiliser un nœud de <PercentageBasedPolicy> qui exécute la routine de nettoyage lorsqu'un certain pourcentage d'espace disque disponible est rempli, ou vous pouvez utiliser un nœud de <FixedSizeBasedPolicy> pour spécifier une taille fixe pour le cache (en mégaoctets). Lorsque la taille spécifiée est atteinte, la routine de nettoyage est exécutée. Par exemple :

<CacheLimitPolicy>

<!-- Cache limit expressed as percentage of disk space -->

<PercentageBasedPolicy>75</PercentageBasedPolicy> </CacheLimitPolicy>

<CacheLimitPolicy>

<!-- Cache limit expressed as MB -->

<FixedSizeBasedPolicy>500</FixedSizeBasedPolicy>

</CacheLimitPolicy>

<StatisticsPersistTime>

Ce nœud indique la fréquence (en heures) avec laquelle les statistiques doivent être écrites sur le disque. Par exemple :

<StatisticsPersistTime>1</StatisticsPersistTime>

<ReaderChunkSize>

Ce nœud définit la taille de segment du lecteur. Par exemple :

<ReaderChunkSize>1048576</ReaderChunkSize>

<WriterChunkSize>

Ce nœud définit la taille de segment du writer. Par exemple :

<WriterChunkSize>1048576</WriterChunkSize>

Modification des paramètres de configuration du proxy

Pour modifier la configuration du proxy, vous devez ouvrir le fichier proxy.config dans un texte ou un éditeur XML et modifier les valeurs que vous avez spécifiées. Après avoir enregistré les fichiers, vous devez recycler le pool d'applications pour que les modifications soient effectives.

Voir aussi

Concepts

Team Foundation Server Proxy et contrôle de code source Team Foundation

Autres ressources

Gestion des paramètres de configuration de Team Foundation Server


Contrôle de Team Foundation Server

Contrôle de Team Foundation Server
DropDown image

Pour prendre en charge vos utilisateurs, il est important de maintenir et de contrôler vos serveurs de Team Foundation. Cette section présente des stratégies communes pour administrer Team Foundation Server, y compris le type d'activité à contrôler, les éléments à considérer pour déterminer s'il faut supprimer des données de votre serveur Team Foundation Server, et le moment et la méthode opportuns pour mettre votre système à niveau.

Dans cette section

Analyse des journaux des événements

Décrit les codes et messages du journal des événements produits par Team Foundation Server.

Analyse des performances

Fournit des détails sur les compteurs de performance intégrés de Team Foundation Server.

Comment : afficher les compteurs de performance de Team Foundation Server

Présente la méthode pour accéder aux compteurs de performance et consulter les données auxquelles ils donnent accès.

Rubriques connexes

Gestion des utilisateurs et groupes

Autorisations du contrôle de code source Team Foundation

Voir aussi

Concepts

Planification de la récupération d'urgence


Analyse des journaux des événements

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Analyse des journaux des événements
Voir aussi
Image de liste déroulante

Vous pouvez surveiller les événements et les erreurs Team Foundation Server à l'aide de journaux des événements. Team Foundation Server consigne divers événements d'information, d'avertissement et d'erreur dans le journal des événements de l'application. Ces événements peuvent être affichés avec l'Observateur d'événements.

Événements de Team Foundation Server

Le tableau suivant décrit les événements de Team Foundation Server :

Type d'événement | Nom du code d'événement | ID de l'événement
Erreur | AuthenticationException | 3001
Erreur | AuthorizationException | 3002
Erreur | ResourceAccessException | 3003
Erreur | InvalidIdentityException | 3004
Erreur | IdentityNotFoundException | 3005
Erreur | DatabaseFullException | 3006
Erreur | DatabaseConfigurationException | 3007
Erreur | DatabaseConnectionException | 3008
Erreur | UnexpectedDatabaseResultException | 3009
Erreur | SubscriberNotImplemented | 3011
Erreur | PluginLoadException | 3012
Erreur | UnableToContactService | 3013
Erreur | ServerFatalInitError | 3014
Erreur | UnhandledException | 3015
Erreur | WatsonReportException | 3016
Erreur | InstanceMismatchError | 3019
Erreur | SchemaVersionMismatchError | 3020
Erreur | ATStampMismatchError | 3021
Erreur | MalformedRegistrationData | 3022
Erreur | InvalidDownloadKey | 3023
Erreur | FileTransferException | 3024
Erreur | DeltaComputationException | 3025
Erreur | EventNotificationException | 3026
Erreur | UnableToReportException | 3027
Erreur | RegistrationDataNotAvailable | 3028
Erreur | AuthenticationTypeNotSupported | 3029
Avertissement | InvalidDownloadKeyLength | 6001
Avertissement | FileCacheRootNotConfigured | 6002
Avertissement | UnhandledExceptionOccurred | 6003
Avertissement | WatsonReportSuppressed | 6004
Avertissement | InstalledUICultureNotFound | 6005
Avertissement | PerformanceCounterInitialization | 6006
Avertissement | InvalidUri | 6007
Avertissement | InvalidIdentity | 6008
Information | ApplicationStarted | 9001
Information | ApplicationStopped | 9002
Information | ApplicationInitialization | 9003
Information | SystemStateChanged | 9004
Information | ProcessTerminatedByUserAction | 9005

Vous pouvez consulter les journaux d'événements en cliquant sur Démarrer, puis choisissez Outils d'administration, Observateur d'événements. Les événements Team Foundation Server sont consignés dans le journal des événements de l'application et les informations supplémentaires relatives à chaque événement peuvent être affichées en double-cliquant sur les événements individuels.

Voir aussi

Autres ressources

Contrôle de Team Foundation Server


Analyse des performances

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Analyse des performances
Voir aussi
Image de liste déroulante

Team Foundation Server fournit des compteurs de performance qui vous permettent de surveiller les performances et l'activité du serveur. Le tableau suivant décrit les analyseurs de performance Team Foundation disponibles.

Compteurs des services TFS

Nom du compteur | Description
Événements actuels en cours | Le nombre des événements Team Foundation Server qui correspondent aux abonnements.
Notifications actuellement en file d'attente | Le nombre des notifications prêtes à envoyer.
Événements/s actuels | La vitesse de traitement du système d'événements Team Foundation Server.
Requêtes de lien/s actuelles | Le taux des requêtes sur les liens entre les artefacts dans Team Foundation Server.
Requêtes d'inscription/s actuelles | La vitesse à laquelle le service d'inscription Team Foundation Server est interrogé.

Compteurs du serveur proxy TFS

Nom du compteur | Description
Taille de la mémoire cache actuelle (octets) | La taille de la mémoire cache actuelle.
Requêtes de téléchargement totales | Le nombre total des requêtes de téléchargement qui viennent au fichier.
Total d'accès au cache | Le nombre total de requêtes de téléchargement provenant du cache de fichier.
Total des fichiers dans le cache | Le nombre total des fichiers disponibles dans le cache.

Compteurs du contrôle de version TFS

Nom du compteur | Description
Téléchargements de fichier en cours | Le nombre de fichiers qui sont actuellement téléchargés vers le service de contrôle de version TFS.
Téléchargements de fichiers/s en cours | La vitesse de téléchargement des fichiers vers le service de contrôle de version TFS.
Requêtes du serveur en cours | Le nombre de requêtes actuellement actives traitées par le service de contrôle de version TFS.
Téléchargements de fichiers en cours | Le nombre de fichiers qui sont actuellement téléchargés depuis le service de contrôle de version TFS.
Téléchargements de fichiers/s en cours | La vitesse de téléchargement des fichiers depuis le service de contrôle de version TFS.
Requêtes/s en cours | La vitesse de traitement des requêtes par le service de contrôle de version TFS.
Temps de réponse moyen | La durée, en moyenne, que le service de contrôle de version TFS a pris pour traiter une requête unique.

Compteurs de suivi des éléments de travail TFS

Nom du compteur | Description
Demandes de requête actives | Le nombre de requêtes en cours d'exécution.
Requêtes de pagination actives | Nombre de requêtes de pagination en cours d'exécution.
Requêtes GetWorkItem actives | Nombre de requêtes d'éléments de travail en cours d'exécution.
Requêtes de mise à jour actives | Le nombre de mises à jour en cours d'exécution.
Requêtes GetMetadata actives | Le nombre de mises à jour du cache en cours d'exécution.
Requêtes GetStoredQuery actives | Le nombre de demandes de requête stockées en cours d'exécution.
Requêtes GetStoredQueries actives | Le nombre de demandes de requête stockées en cours d'exécution.

Pour plus d'informations sur la consultation des données fournies par ces compteurs de performance, consultez Comment : afficher les compteurs de performance de Team Foundation Server.

Voir aussi

Tâches

Comment : afficher les compteurs de performance de Team Foundation Server

Autres ressources

Contrôle de Team Foundation Server


Comment : afficher les compteurs de performance de Team Foundation Server

Comment : afficher les compteurs de performance de Team Foundation Server
Voir aussi

Team Foundation Server fournit des compteurs de performance qui vous permettent de consulter des données en temps réel relatives aux performances de Team Foundation Server. Cette rubrique explique comment accéder à ces compteurs et consulter les données auxquelles ils permettent d'accéder. Pour plus d'informations sur les compteurs de performance disponibles, consultez Analyse des performances.

Pour consulter les compteurs de performance de Team Foundation Server

  1. Sous Windows, cliquez sur Démarrer, cliquez sur Outils d'administration, puis cliquez sur Performances pour ouvrir la fenêtre Performances.

  2. Dans le volet droit de la fenêtre Performances, cliquez sur + pour ouvrir la fenêtre Ajouter des compteurs .

  3. Dans la zone déroulante Objet de performance, sélectionnez l'ensemble de compteurs de performance Team Foundation Server approprié. Par exemple, vous pouvez choisir Services TFS, Serveur proxy TFS, Contrôle de version TFS ou Suivi des éléments de travail TFS.

  4. Dans la zone de liste gauche, sélectionnez le compteur approprié. Dans la zone de liste droite, sélectionnez l'instance appropriée, puis cliquez sur Ajouter.

    Le compteur de performance est ajouté au Moniteur système.

Voir aussi

Concepts

Analyse des performances

Autres ressources

Contrôle de Team Foundation Server


Sécurisation de Team Foundation Server

Sécurisation de Team Foundation Server
DropDown image

La sécurité Team Foundation est intégrée avec l'authentification Windows et basée sur les utilisateurs et les groupes. L'authentification Windows est utilisée pour authentifier des comptes pour les connexions entre les clients Team Foundation et Team Foundation Server. De plus, l'autorisation Team Foundation Server est basée sur les utilisateurs, les groupes et les autorisations Team Foundation Server. Vous pouvez garantir la sécurité de votre déploiement Team Foundation Server en assignant correctement des autorisations à des utilisateurs et des groupes. Vous pouvez également garantir la sécurité de votre déploiement Team Foundation Server en maîtrisant l'architecture sous-jacente de Team Foundation Server et en sécurisant les ports réseau et le trafic entre vos clients Team Foundation et vos serveurs Team Foundation.

Dans cette section

Concepts sur la sécurité de Team Foundation Server

Décrit les concepts de base de la sécurité de Team Foundation Server.

Architecture de sécurité de Team Foundation Server

Décrit l'architecture de Team Foundation Server et explique comment sécuriser Team Foundation Server.

Sécurité de Team Foundation Server pour les utilisateurs et les groupes

Décrit les rôles et la sécurité Team Foundation Server par défaut.

Synchronisation des comptes Administrateur

Décrit les stratégies de synchronisation des comptes d'administrateur dans Team Foundation Server, SQL Reporting Services et Windows SharePoint Services.

Voir aussi

Autres ressources

Team Foundation Server Deployment


Concepts sur la sécurité de Team Foundation Server

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Concepts sur la sécurité de Team Foundation Server
Voir aussi
Image de liste déroulante

Pour sécuriser Team Foundation Server, vous devez connaître le mode de fonctionnement et de communication de Team Foundation Server avec d'autres composants Team Foundation. Un administrateur Team Foundation Server doit être habitué aux authentifications, protocoles réseau et trafic Windows et à la structure du réseau d'entreprise sur lequel Team Foundation Server est installé, ainsi que comprendre les groupes Team Foundation Server et les autorisations.

Présentation de la Sécurité Team Foundation Server

Les concepts de sécurité de Team Foundation Server peuvent être divisés en trois catégories générales : topologie, authentification et autorisation. La topologie inclut l'emplacement et la méthode de déploiement des serveurs de Team Foundation, le trafic réseau qui passe entre Team Foundation Server et les clients de Team Foundation ainsi que les services qui doivent s'exécuter sur Team Foundation Server. L'authentification inclut la détermination de la validité des utilisateurs, groupes et services de Team Foundation Server. L'autorisation détermine si les utilisateurs, groupes et services de Team Foundation Server valides disposent des autorisations appropriées pour exécuter des actions. De plus, vous devez être informé des dépendances de Team Foundation Server vis-à-vis d'autres composants et services pour optimiser la sécurité de Team Foundation Server dans votre réseau.

Lorsque vous abordez le thème de la sécurité de Team Foundation Server, il est important de comprendre la différence entre authentification et autorisation. Authentification correspond à la vérification des informations d'identification lors d'une tentative de connexion depuis un client, un serveur ou un processus. Autorisation correspond à la vérification que la tentative de connexion est autorisée. L'autorisation s'effectue toujours après authentification réussie. Si une connexion n'est pas authentifiée, elle échoue avant l'exécution d'un contrôle d'autorisation. Si l'authentification d'une connexion réussit, une action spécifique peut encore être rejetée parce que l'utilisateur ou le groupe n'avait pas l'autorisation d'exécuter cette action.

Topologies, ports et services de Team Foundation Server

Le premier élément de déploiement et de sécurité de Team Foundation Server consiste à savoir si les composants de votre déploiement de Team Foundation peuvent se connecter mutuellement pour communiquer. Dans l'idéal, vous souhaitez activer des connexions entre clients de Team Foundation et Team Foundation Server et limiter ou empêcher d'autres tentatives de connexion.

Team Foundation Server dépend de certains ports et services pour fonctionner. Ces ports peuvent être sécurisés et surveillés pour satisfaire les besoins en sécurité de l'entreprise. En fonction de votre déploiement de Team Foundation, vous devez autoriser le trafic réseau de Team Foundation Server de passer entre les clients Team Foundation, la couche Application Team Foundation et les serveurs de couche Données, les serveurs de builds de Team Foundation Build et les clients distants de Team Foundation à l'aide du proxy du contrôle de code source. Par défaut, Team Foundation Server est configuré pour utiliser HTTP pour ses services Web, mais vous pouvez éventuellement choisir de configurer et d'utiliser HTTPS et SSL (SSL) pour une meilleure sécurité. Pour obtenir une liste complète des ports et services Team Foundation Server et savoir comment ils sont utilisés dans l'architecture de Team Foundation Server, consultez Architecture de sécurité de Team Foundation Server. Pour plus d'informations sur Team Foundation Server et HTTPS, consultez Procédure pas à pas : configuration de Team Foundation Server avec SSL (Secure Socket Layer).

Vous pouvez déployer Team Foundation Server dans un domaine Active Directory ou un groupe de travail. Active Directory fournit des fonctionnalités de sécurité plus intégrées que les groupes de travail qui vous permettent de sécuriser votre déploiement de Team Foundation Server. Par exemple, vous pouvez configurer Active Directory pour rejeter des noms d'ordinateurs en double pour empêcher tout utilisateur malveillant d'usurper le nom d'ordinateur avec un serveur Team Foundation Server non autorisé. Pour atténuer ce même type de menace dans un groupe de travail, vous devriez configurer des certificats d'ordinateur. Pour plus d'informations sur Team Foundation Server dans un domaine Active Directory, consultez Gestion de Team Foundation Server dans un domaine Active Directory. Pour plus d'informations sur Team Foundation Server dans un groupe de travail, consultez Gestion de Team Foundation Server dans un groupe de travail.

Il existe certaines contraintes de topologie sur les déploiements de Team Foundation Server indépendamment du fait que vous déployez Team Foundation Server dans un groupe de travail ou un domaine. Par exemple, les serveurs de couche Application et les serveurs de couche Données doivent se trouver sur le même segment réseau sans pare-feux entre eux pour garantir leur fonctionnement. Pour plus d'informations sur les topologies de Team Foundation Server, consultez Topologies de Team Foundation Server.

Authentification

La sécurité de Team Foundation Server est intégrée à l'authentification intégrée Windows (également connue sous le nom de stimulation/réponse Windows NT) et les fonctionnalités de sécurité de Windows Server 2003. L'authentification intégrée Windows est utilisée pour authentifier des comptes pour les connexions entre clients de Team Foundation et Team Foundation Server, pour les services Web sur la couche Application de Team Foundation Server et les serveurs de couche Données, et pour les connexions entre les serveurs de couche Application de Team Foundation et les serveurs de couche Données eux-mêmes. Selon votre réseau, ces utilisateurs et groupes peuvent être spécifiques à un serveur ou un ordinateur unique, ou aux membres d'un domaine Active Directory.

Vous ne devez pas configurer de connexions de base de données SQL entre Team Foundation Server et Windows SharePoint Services pour utiliser l'Authentification SQL Server. L'Authentification SQL Server est moins sécurisée, car lorsque vous vous connectez à la base de données, le nom d'utilisateur et le mot de passe pour le compte d'administrateur de base de données est envoyé à partir du serveur au serveur sous un format non chiffré. L'authentification intégrée Windows n'envoie pas le nom d'utilisateur et mot de passe, mais résume ces informations via le pool d'applications IIS, ce qui est par conséquent plus sécurisé.

Autorisation de Team Foundation Server

L'autorisation de Team Foundation Server est basée sur les utilisateurs et les groupes et les autorisations sont assignées à ces utilisateurs et ces groupes. Votre déploiement spécifique peut requérir une configuration des utilisateurs, des groupes et des autorisations sur plusieurs ordinateurs et dans plusieurs applications. Par exemple, si vous souhaitez inclure des rapports et des portails de projet dans le cadre de votre déploiement, vous devez configurer des autorisations pour les utilisateurs et les groupes dans SQL Reporting Services, Windows SharePoint Services et Team Foundation Server. Sur Team Foundation Server, les autorisations peuvent être définies pour chaque projet, sur tout le serveur et pour chaque classification des groupes au niveau du serveur. Pour plus d'informations sur la configuration d'autorisations, consultez Gestion des autorisations. Pour plus d'informations sur les utilisateurs et les groupes de Team Foundation Server, consultez Gestion des utilisateurs et groupes.

Non seulement vous pouvez configurer des autorisations dans Team Foundation Server, mais vous pouvez également avoir besoin d'une autorisation dans le contrôle du code source et dans les éléments de travail. Ces autorisations sont gérées séparément. Pour plus d'informations sur les autorisations dans le contrôle du code source, consultez Droits et autorisations relatifs à la sécurité du contrôle de code source et Contrôle de code source Team Foundation. Pour plus d'informations sur la personnalisation d'élément de travail, consultez Gestion d'éléments de travail Team Foundation.

Dépendances de Team Foundation Server

Outre ses propres services, Team Foundation Server nécessite certains services d'application Windows et autre sur sa couche Application et les serveurs de couche Données. Le tableau suivant indique en détail les services requis sur les serveurs de couche Application.

Nom du service | Description
Service Application Experience Lookup | Ce service fait partie d'une infrastructure qui offre un moyen d'appliquer des corrections aux applications pour qu'elles s'exécutent sur les versions récentes des systèmes d'exploitation Windows ou des Service Packs. Ce service doit s'exécuter pour que l'application résolve le problème.
Coordinateur de transactions distribuées | Ce service coordonne des transactions qui mettent à jour plusieurs ressources protégées par transaction, telles que les bases de données, les files d'attente de messages et les systèmes de fichiers. Ces ressources protégées par transaction peuvent se trouver sur un seul ordinateur ou être distribuées dans plusieurs ordinateurs du réseau.
Client DNS | Ce service est utilisé pour résoudre des noms de domaines DNS.
Journal des événements | Ce service enregistre des événements sur le système d'exploitation en écrivant sur un, deux ou trois journaux par défaut que vous pouvez lire dans Observateur d'événements : sécurité, application et journaux système.
Service IIS Admin | Ce service gère la métabase IIS.
Ouverture de session réseau | Ce service vérifie les requêtes d'ouverture de session et contrôle la réplication au niveau du domaine de la base de données des comptes d'utilisateurs.
Connexions réseau | Ce service (également connu sous le nom de service Netman) gère toutes les connexions réseau créées et configurées dans les connexions réseau du Panneau de configuration et est chargé d'afficher l'état de réseau dans la zone de notification sur le bureau.
NLA (Network Location Awareness) | Ce service collecte et stocke des informations sur la configuration du réseau, telles que les modifications apportées aux noms et aux emplacements des adresses IP et des noms de domaines.
Appel de procédure distante (RPC) | Ce service représente un mécanisme de communication interprocessus (IPC) sécurisé qui active les échanges de données et les appels de fonctionnalités qui résident dans un processus différent. Ce processus différent peut se trouver sur le même ordinateur, sur le réseau local (LAN) ou sur Internet. Le service Appel de procédure distante sert de mappeur de point final de RPC (EPM) et de Gestionnaire de contrôle des services (SCM).
Gestionnaire des comptes de sécurité (SAM) | Ce service maintient des informations de compte d'utilisateur, y compris les groupes auxquels un utilisateur appartient.
Service du minuteur Microsoft SharePoint | Ce service gère les travaux planifiés dans Windows SharePoint Services.
Windows Management Instrumentation | Ce service démarre et arrête le gestionnaire d'objets CIM (Common Information Model).
Horloge Windows | Ce service (également connu sous le nom de W32Time) synchronise la date et l'heure sur tous les ordinateurs qui s'exécutent sur un réseau Windows Server 2003.
Service de publication World Wide Web | Ce service représente un gestionnaire de configuration en mode utilisateur et de processus qui gère les composants IIS qui traitent des requêtes HTTP et exécutent des applications Web et vérifie périodiquement des applications Web pour déterminer si elles se sont arrêtées de façon inattendue.

Le tableau suivant indique en détail les services requis sur les serveurs de couche Données.

Nom du service | Description
SQL Analysis Server (MSSQLSERVER) | Ce service crée et gère les cubes OLAP et les modèles d'exploration de données.
Service Application Experience Lookup | Ce service fait partie d'une infrastructure qui offre un moyen d'appliquer des corrections aux applications pour qu'elles s'exécutent sur les versions récentes des systèmes d'exploitation Windows ou des Service Packs. Ce service doit s'exécuter pour que l'application résolve le problème.
Coordinateur de transactions distribuées | Ce service coordonne des transactions qui mettent à jour plusieurs ressources protégées par transaction, telles que les bases de données, les files d'attente de messages et les systèmes de fichiers. Ces ressources protégées par transaction peuvent se trouver sur un seul ordinateur ou être distribuées dans plusieurs ordinateurs du réseau.
Client DNS | Ce service est utilisé pour résoudre des noms de domaines DNS.
Journal des événements | Ce service enregistre des événements sur le système d'exploitation en écrivant sur un, deux ou trois journaux par défaut que vous pouvez lire dans Observateur d'événements : sécurité, application et journaux système.
Ouverture de session réseau | Ce service vérifie les requêtes d'ouverture de session et contrôle la réplication au niveau du domaine de la base de données des comptes d'utilisateurs.
Connexions réseau | Ce service (également connu sous le nom de service Netman) gère toutes les connexions réseau créées et configurées dans les connexions réseau du Panneau de configuration et est chargé d'afficher l'état de réseau dans la zone de notification sur le bureau.
NLA (Network Location Awareness) | Ce service collecte et stocke des informations sur la configuration du réseau, telles que les modifications apportées aux noms et aux emplacements des adresses IP et des noms de domaines.
Appel de procédure distante (RPC) | Ce service représente un mécanisme de communication interprocessus (IPC) sécurisé qui active les échanges de données et les appels de fonctionnalités qui résident dans un processus différent. Ce processus différent peut se trouver sur le même ordinateur, sur le réseau local (LAN) ou sur Internet. Le service Appel de procédure distante sert de mappeur de point final de RPC (EPM) et de Gestionnaire de contrôle des services (SCM).
Report Server (MSSSQLSERVER) | Ce service gère le protocole SOAP (Simple Object Access Protocol) et les requêtes d'URL, traite des rapports, fournit un instantané et établit un rapport de la gestion de cache et prend en charge et applique des stratégies de sécurité et une autorisation.
Gestionnaire des comptes de sécurité (SAM) | Ce service maintient des informations de compte d'utilisateur, y compris les groupes auxquels un utilisateur appartient.
Service du minuteur Microsoft SharePoint | Ce service gère les travaux planifiés dans Windows SharePoint Services.
Windows Management Instrumentation | Ce service démarre et arrête le gestionnaire d'objets CIM (Common Information Model).
Horloge Windows | Ce service (également connu sous le nom de W32Time) synchronise la date et l'heure sur tous les ordinateurs qui s'exécutent sur un réseau Windows Server 2003.

Pour plus d'informations sur les services et leur interaction avec l'architecture de Team Foundation Server, consultez Architecture de sécurité de Team Foundation Server.

Voir aussi

Tâches

Procédure pas à pas : configuration de Team Foundation Server avec SSL (Secure Socket Layer)

Concepts

Architecture de sécurité de Team Foundation Server
Gestion de Team Foundation Server dans un groupe de travail
Droits et autorisations relatifs à la sécurité du contrôle de code source
Contrôle de code source Team Foundation
Gestion d'éléments de travail Team Foundation

Autres ressources

Gestion de Team Foundation Server dans un domaine Active Directory
Gestion des autorisations
Gestion des utilisateurs et groupes


Architecture de sécurité de Team Foundation Server

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Architecture de sécurité de Team Foundation Server
Voir aussi
Image de liste déroulante

Pour analyser et prévoir la sécurité de Team Foundation Server, vous devez prendre en compte la couche Application de Team Foundation, la couche Données de Team Foundation, la couche cliente de Team Foundation et les interactions entre elles. Vous devrez savoir quels services Web, bases de données et modèles objet sont utilisés. Vous devrez également savoir quels ports réseau et protocoles sont utilisés par défaut et lesquels peuvent être personnalisés.

Outre ses propres services, Team Foundation Server dépend d'autres services pour fonctionner. Pour plus d'informations sur les dépendances de Team Foundation Server, consultez Concepts sur la sécurité de Team Foundation Server.

Modèle objet

Team Foundation Server inclut un modèle objet qui active la communication entre la couche cliente de Team Foundation et la couche Application de Team Foundation. Ce modèle objet permet également aux intégrateurs de logiciel et à des tiers de personnaliser et d'étendre les fonctionnalités de Team Foundation Server.

Modèle objet de Team Foundation Server

Le modèle objet de Team Foundation Server représente un jeu d'API managées qui incluent les interfaces suivantes.

  • Services communs de TF

    • Service d'inscription

    • Service de sécurité

    • Service de liaison

    • Service d'événement

    • Service de classification

  • Modèle objet de contrôle de version

  • Modèle objet Suivi des éléments de travail

Le modèle objet de Team Foundation Server se trouve publiquement dans la documentation d'extensibilité de Team Foundation Server dans le Kit de développement Visual Studio (SDK).

Services Web et bases de données

Team Foundation Server inclut un jeu de services Web et de bases de données. Ces services et bases de données sont installés et configurés séparément sur la couche Application, Données et sur la couche cliente de Team Foundation. Les illustrations suivantes illustrent brièvement des services Web, des applications et des bases de données sur Team Foundation Server et sur les ordinateurs clients.

Diagramme Architecture serveur Diagramme d'architecture client

Couche Application

La couche Application de Team Foundation contient les services Web ASP.NET suivants qui correspondent aux proxies ou modèles objets respectifs sur la couche cliente. Ces services Web ne sont généralement pas prévus pour la programmation d'intégrateurs tiers, à l'exception du service Web de MSBuild présenté dans la documentation de l'extensibilité de Team Foundation Server dans le Kit de développement Visual Studio (SDK).

  • Services communs de Team Foundation

    • Service Web d'inscription

    • Service Web de Sécurité

    • Service Web de liaison

    • Service Web d'événement

    • Service Web de classification

  • Service Web de contrôle de version

  • Service Web de suivi des éléments de travail

  • Service Web de Team Build

Couche Données

La couche Données de Team Foundation se compose des magasins opérationnels suivants dans SQL Server 2005. Elle inclut des données, procédures stockées et autre logique associée.

  • Suivi des éléments de travail

  • Contrôle de version

  • Services communs de Team Foundation

  • Team Build

  • Entrepôt de création de rapports

Couche cliente

La couche cliente utilise les mêmes services Web répertoriés dans la couche Application pour communiquer avec la couche Application de Team Foundation via le modèle objet de Team Foundation Server. Outre le modèle objet de Team Foundation Server, la couche cliente de Team Foundation se compose de composants de Visual Studio Industry Partners (VSIP), d'une intégration Microsoft Office, d'interfaces de ligne de commande et d'une infrastructure de stratégie d'archivage pour l'intégration avec Team Foundation Server et l'intégration personnalisée. Pour plus d'informations sur l'extension et la personnalisation de la couche cliente, consultez la documentation sur l'extensibilité dans le Kit de développement Visual Studio (SDK).

Ports réseau et protocoles

Par défaut, Team Foundation Server est configuré pour utiliser des ports réseau spécifiques et des protocoles réseaux. Le diagramme suivant illustre le trafic réseau de Team Foundation Server dans un déploiement d'exemple.

Diagramme Ports et communications

Paramètres réseau par défaut

Par défaut, la communication entre la couche Application de Team Foundation, la couche Données de Team Foundation, les serveurs de builds et du proxy de Team Foundation Server utilisent les protocoles et les ports dans la liste suivante.

Service et couche | Protocole | Port
Couche Application - Services Web | HTTP | 8080
Couche Application - Administration de Windows SharePoint Services | HTTP | Ce port est généré de manière aléatoire pendant l'installation de Windows SharePoint Services.
Couche Application - Windows SharePoint Services et SQL Reporting Services | HTTP | 80
Serveur de builds - Accès distant depuis le serveur de couche Application de Team Foundation | .NET Remoting | 9191
Couche Données | MS-SQL TCP | 1443
Couche Données | MS-SQL UDP | 1444
Team Foundation Server Proxy | HTTP | 8080
Couche cliente - Reporting Services | HTTP | 80
Couche cliente - Services Web | HTTP | 8080

Paramètres réseau personnalisables

Vous pouvez choisir de modifier Team Foundation Server pour utiliser HTTPS et SSL (Secure Socket Layer) au lieu de HTTP pour services Web et Microsoft SQL Reporting Services. Dans ce cas, la communication entre la couche Application, la couche Données et la couche cliente changera tel que décrit dans le tableau suivant.

Service et couche | Protocole | Port
Couche Application - Services Web avec SSL | HTTPS | Configuré par l'administrateur
Couche Application - Administration de Windows SharePoint Services | HTTPS | Configuré par l'administrateur
Couche Application - Windows SharePoint Services et SQL Reporting Services | HTTPS | 443
Couche cliente - Reporting Services | HTTPS | 443
Couche cliente - Services Web | HTTPS | Configuré par l'administrateur

Pour plus d'informations sur la configuration de Team Foundation Server pour utiliser HTTPS et SSL, consultez Procédure pas à pas : configuration de Team Foundation Server avec SSL (Secure Socket Layer).

Voir aussi

Tâches

Procédure pas à pas : configuration de Team Foundation Server avec SSL (Secure Socket Layer)

Concepts

Concepts sur la sécurité de Team Foundation Server
Autorisations de Team Foundation Server

Autres ressources

Topologies de Team Foundation Server


Sécurité de Team Foundation Server pour les utilisateurs et les groupes

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Sécurité de Team Foundation Server pour les utilisateurs et les groupes
Voir aussi
Image de liste déroulante

La sécurité de Team Foundation est basée sur les utilisateurs et les groupes. Vous pouvez aider à garantir la sécurité de votre déploiement de Team Foundation Server en assignant correctement des autorisations aux utilisateurs et aux groupes et en vous assurant que vous ajoutez des utilisateurs aux groupes uniquement s'ils nécessitent réellement les autorisations associées à ce groupe. Ces autorisations permettent aux utilisateurs d'accéder uniquement aux données et aux fonctionnalités dont ils ont besoin pour leurs travaux en fonction de leurs rôles et responsabilités dans votre équipe et vous aident à protéger des données auxquelles l'accès doit être limité. Les groupes par défaut qui sont créés lorsque vous installez Team Foundation Server sont conçus pour répondre aux exigences de sécurité de la plupart des organisations. Si votre organisation a des besoins de sécurité spécifiques ou spécialisés, il est possible que vous deviez modifier des groupes de sécurité existants ou en créer de nouveaux.

En général, vous devez éviter d'ajouter directement des utilisateurs à Team Foundation Server. La gestion des autorisations d'un grand nombre d'utilisateurs individuels prend du temps et peut entraîner des problèmes de gestion et de sécurité. Songez à créer des groupes spécifiques pour les rôles communs dans votre entreprise et vos projets et à ajouter autant d'utilisateurs que nécessaire à ces groupes.

Rôles par défaut et sécurité

Bien que les noms de groupes pré-installés varient selon le modèle de processus que vous avez choisi d'implémenter, les utilisateurs de Team Foundation Server peuvent être classés généralement dans trois groupes par défaut. Vous devez déterminer les utilisateurs qui doivent appartenir à un groupe précis, en fonction du role que chaque utilisateur aura dans un projet. Les rôles et les autorisations requises associées sont décrites dans la liste suivante :

  • Administrateur Team Foundation Peut installer et gérer un serveur Team Foundation Server, en plus de fournir des autorisations et la sécurité à d'autres rôles. Les membres de ce groupe sont les seuls qui peuvent créer de nouveaux projets sur un serveur Team Foundation Server. Peut également personnaliser le guide de processus. C'est le groupe le plus privilégié et doit être limité au plus petit nombre d'utilisateurs possible.

  • Administrateur du projet d'équipe Également appelé chef de projet ou coordinateur de projet, ce rôle permet de gérer une base de données des éléments de travail de projet d'équipe et le portail du projet. Peut administrer des autorisations et la sécurité du projet d'équipe. C'est le deuxième groupe le plus privilégié et doit être limité au plus petit nombre d'utilisateurs possible.

  • Collaborateur du projet d'équipe Peut accéder, lire et écrire des éléments de travail, consulter le site Web du projet d'équipe et le guide de processus d'un projet d'équipe. C'est le groupe auquel la plupart des utilisateurs appartiendront.

Le tableau suivant récapitule les autorisations qui sont requises pour chaque exemple de rôle.

Le rôle doit être membre de : | Rôle d'administrateur Team Foundation Server | Rôle d'administrateur du projet d'équipe | Rôle de collaborateur du projet d'équipe
Groupes d'ordinateurs des couches Application et Données | Administrateurs Windows | N/A | N/A
Groupes Team Foundation Server par défaut | Administrateurs Team Foundation | Administrateurs de projet | Collaborateurs
Groupes Windows SharePoint Services | Administrateur de site | Administrateur de niveau site du projet | Collaborateurs de niveau site au projet
Groupes Reporting Services | Gestionnaire de contenu Administrateur de site | Gestionnaire de contenu de niveau site du projet | Navigateur de niveau site du projet

Voir aussi

Concepts

Autorisations de collaborateur de Team Foundation Server
Autorisations de Team Foundation Server
Droits et autorisations relatifs à la sécurité du contrôle de code source

Autres ressources

Autorisations d'administrateur de Team Foundation Server
Autorisations des coordinateurs de projet Team Foundation Server
Gestion des utilisateurs
Gestion des groupes
Administration de Team Foundation Build


Synchronisation des comptes Administrateur

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Synchronisation des comptes Administrateur
Voir aussi
Image de liste déroulante

Dans tout déploiement de Team Foundation Server, vous devez configurer des comptes et des autorisations dans trois emplacements séparés : dans Windows SharePoint Services, dans Microsoft SQL Reporting Services et dans l'interface utilisateur de Team Foundation Server. En fonction de votre déploiement de Team Foundation Server, vous devrez peut-être configurer des comptes d'administrateur sur d'autres ordinateurs, notamment sur des serveurs de builds, sur des serveurs Web, sur des plates-formes de test, ainsi que sur des serveurs de couche Données et de couche Application de Team Foundation. Le suivi de l'ensemble de ces comptes et mots de passe d'administrateur peut être problématique. Vous pouvez légèrement atténuer la charge d'administration de maintenance de ces comptes en synchronisant les utilisateurs et groupes qui ont besoin de ces autorisations sur les ordinateurs séparés.

Détermination d'une stratégie de synchronisation

Votre stratégie de synchronisation pour Team Foundation Server dépend principalement de deux facteurs : du niveau de confiance que vous souhaitez étendre aux utilisateurs dans votre déploiement de Team Foundation Server et si Team Foundation Server est déployé dans un domaine Active Directory ou dans un groupe de travail. Un nombre important d'administrateurs pour les serveurs et le logiciel peut réduire le fardeau administratif et simplifier la configuration, mais cela augmente énormément les problèmes de sécurité. Pour des raisons de sécurité, vous devez limiter au maximum le nombre de comptes d'utilisateurs ayant des autorisations administratives.

Synchronisation des comptes d'administrateur dans un domaine Active Directory

Si vous avez déployé Team Foundation Server dans un domaine Active Directory, vous pouvez créer un groupe Active Directory pour les comptes d'utilisateurs qui ont besoin d'autorisations administratives pour Team Foundation Server pour les serveurs et le logiciel. Par exemple, vous pouvez créer un groupe appelé TFSAdmins et ajoutez ce compte au groupe Administrateurs dans Windows SharePoint Services et dans SQL Reporting Services, au groupe Administrateurs Team Foundation dans Team Foundation Server et aux serveurs Team Foundation eux-mêmes. Vous pouvez ensuite ajouter les utilisateurs qui ont besoin d'autorisations administratives à ce groupe et vous n'avez plus besoin de vous inquiéter à propos de la gestion de plusieurs comptes d'administrateur différents. Le cas échéant, vous pouvez simplement ajouter ou supprimer des utilisateurs de ce groupe et ajouter ce groupe d'administration aux autres serveurs, tels que les serveurs de builds.

Synchronisation des comptes d'administrateur dans un groupe de travail

Si vous avez déployé Team Foundation Server dans un groupe de travail, vous ne pouvez pas créer un compte de groupe unique pour tous les comptes d'utilisateurs qui ont besoin d'autorisations d'administrateur. Vous devez ajouter séparément chaque compte d'utilisateur à chaque groupe Administrateurs et à chaque ordinateur. Dans ce cas, vous pouvez envisager de créer une liste principale contenant les comptes d'utilisateurs ayant besoin d'autorisations administratives pour des ordinateurs et logiciel spécifiques. De cette manière, vous disposez d'un enregistrement auquel vous reporter lorsque vous devez ajouter, supprimer ou ajuster des autorisations administratives.

Voir aussi

Concepts

Autorisations de Team Foundation Server

Autres ressources

Topologies de Team Foundation Server
Gestion des utilisateurs et groupes
Gestion des autorisations
Gestion des services et comptes de service Team Foundation Server


Utilisation des outils de ligne de commande Team Foundation Server

Utilisation des outils de ligne de commande Team Foundation Server
Voir aussi
DropDown image

Team Foundation Server inclut des outils et des stratégies d'administration pour vous aider à gérer votre matériel, serveurs et groupes Team Foundation Server.

Dans cette section

Commandes de l'utilitaire en ligne de commande TFSAdminUtil

Décrit l'utilitaire en ligne de commande TFSAdminUtil et fournit des liens vers les rubriques sur ses commandes et leurs paramètres.

Commandes de l'utilitaire en ligne de commande TFSSecurity

Décrit les options et les paramètres de TFSSecurity, un utilitaire en ligne de commande qui permet aux administrateurs Team Foundation Server d'examiner et de gérer des objets, des groupes d'applications, des utilisateurs et des autorisations pour Visual Studio Team System.

TFSDeleteProject, commande

Décrit les options et paramètres de TFSDeleteProject, un utilitaire en ligne de commande utilisé pour supprimer un projet d'équipe de Team System.

TFSReg, commande

Décrit TFSReg, un utilitaire en ligne de commande utilisé pour modifier, mettre à jour ou supprimer toutes les entrées dans le fichier de configuration des connexions dans Team Foundation Server.

TFSFieldMapping

Décrit TFSFieldMapping, un utilitaire en ligne de commande utilisé pour changer ou personnaliser le fichier XML de mappage de projet après avoir créé un projet d'équipe.

witimport

Décrit witimport, un utilitaire en ligne de commande utilisé pour valider et importer un type d'élément de travail d'un fichier XML vers un projet d'équipe sur un serveur Team Foundation Server.

witexport

Décrit witexport, un utilitaire en ligne de commande utilisé pour exporter une définition XML pour un type d'élément de travail d'un serveur Team Foundation Server.

witfields

Décrit witfields, un utilitaire en ligne de commande utilisé pour administrer des champs de type d'élément de travail sur un serveur Team Foundation Server.

glimport

Décrit glimport, un utilitaire en ligne de commande utilisé pour valider et importer des listes globales d'un fichier XML vers un projet d'équipe sur un serveur Team Foundation Server.

glexport

Décrit glexport, un utilitaire en ligne de commande utilisé pour exporter une définition XML pour les listes globales d'un serveur Team Foundation Server.

SetupWarehouse

Décrit SetupWarehouse, un outil en ligne de commande utilisé pour régénérer le traitement analytique en ligne (OLAP) ou la base de données relationnelle.

Commandes de Team Foundation Build

Décrit le but des commandes Team Foundation Build et fournit des exemples d'utilisation.

Rubriques connexes

Gestion des utilisateurs et groupes

Choix des outils de maintenance de Team Foundation Server

Voir aussi

Autres ressources

Référence de la ligne de commande du contrôle de code source Team Foundation


Commandes de l'utilitaire en ligne de commande TFSAdminUtil

Commandes de l'utilitaire en ligne de commande TFSAdminUtil
DropDown image

Utilisez TFSAdminUtil pour automatiser les tâches de modification des comptes de service ou des mots de passe de compte de Team Foundation Server sur les couches Application et Données qui sont utilisées en interne par Team Foundation Server pour exécuter différentes tâches et services. TFSAdminUtil ne crée pas de compte et ne modifie pas son mot de passe physiquement, il met simplement à jour Team Foundation Server pour utiliser des informations d'identification existantes. Le compte de service peut être un compte local ou de domaine et TFSAdminUtil peut être écrit pour autoriser des mises à jour automatisées.

L'utilitaire en ligne de commande TFSAdminUtil est situé dans <drive>:\Program Files\Microsoft Visual Studio 2005 Team Foundation Server\Tools.

L'utilitaire en ligne de commande TFSAdminUtil dépend de nombreux composants Team Foundation Server disponibles et complètement opérationnels. Ces composants sont les suivants :

  • Microsoft SQL Server 2005

  • Microsoft SQL Server Reporting Services

  • Contrôleur de domaine Active Directory

  • IIS 6.0

  • .NET Framework 2.0

  • Team Foundation Build

Les options globales suivantes sont disponibles pour presque toutes les commandes TFSAdminUtil. Les exceptions sont indiquées.

Option | Description
/? | Affiche la syntaxe de commande et les options de TFSAdminUtil.
/NoPrompt | Utilisé en relation avec les commandes ActivateAT. Cette option spécifie que l'administrateur n'est pas invité avant de valider les modifications. /NoPrompt n'est pas pris en charge pour la commande Sid.

Dans cette section

ChangeAccount, commande

ChangePassword, commande

Sid, commande

RenameDT, commande

Optimize, commande

ActivateAt, commande

Status, commande (TFSAdminUtil)


ChangeAccount, commande

 Image de liste droulante Image de pointage sur liste droulante Image de rduction Image de dveloppement Image Rduire tout Image Dvelopper tout Copier l'image de pointage
Visual Studio Team System
ChangeAccount, commande
Voir aussi
Image Rduire tout Image de liste droulante

Utilisez la commande ChangeAccount pour modifier le compte et le mot de passe pour tous les comptes de service.

TFSAdminUtil ChangeAccount oldacct oldpwd newacct newpwd [target]

Paramètres

Argument | Description
oldacct | Spécifie l'ancien nom du compte.
oldpwd | Spécifie l'ancien mot de passe.
newacct | Spécifie le nouveau nom du compte.
newpwd | Spécifie le nouveau mot de passe du compte.
target | Spécifie l'ordinateur de destination. Si la target est omise, l'ordinateur local est utilisé. L'ordinateur de destination doit être un serveur de couche Application.

Image de dveloppement Notes

La commande ChangeAccount est utilisée par un administrateur qui souhaite remplacer le compte de service, par exemple, MyLocation\bissvc, par un autre compte de service pré-créé tel que MyLocation\tfssvc. L'administrateur exécute cet outil pour mettre à jour tous les serveurs Team Foundation qui contiennent le nouveau compte de service. Remarquez que les comptes Utilisateur peuvent être utilisés si le compte a les autorisations correctes.

L'utilitaire essaie d'abord de mettre à jour la couche Données. Il assigne le nouveau compte au même groupe de rôles que l'ancien compte, en s'assurant que les autorisations sont maintenues et qu'aucun temps mort de SQL Server ne se produit. Cela signifie que l'ancien compte d'utilisateur doit être supprimé manuellement de la couche Données après une modification réussie des comptes.

Ensuite, l'utilitaire met à jour la couche Application en modifiant les identités de pool d'applications. Les pools d'applications doivent être redémarrés individuellement, bien qu'IIS ne doive pas être redémarré. La dernière étape de la couche Application consiste à mettre à jour le Planificateur de tâches de Team Foundation Server, également appelé service TFSServerScheduler. Celui-ci doit également être redémarré pour que les modifications prennent effet. Pour plus d'informations, consultez Planificateur de tâches de Team Foundation Server.

Image de dveloppement Exemples

L'exemple suivant affiche que la syntaxe utilisée pour mettre à jour les comptes de service. L'utilitaire échange toutes les instances de l'ancien compte, MyOldAcct, avec un nouveau compte, MyNewAcct et un nouveau mot de passe, newPass. L'utilitaire parcourt les comptes de service et modifie uniquement ceux qui s'exécutent sous l'ancien compte. Étant donné que le paramètre cible n'est pas fourni, l'ordinateur sur lequel l'outil est exécuté est considéré comme le serveur de couche Application cible.

Image Copier le code Copier le code
TFSAdminUtil.exe ChangeAccount MyOldAcct oldPass MyNewAcct newPass

Image de dveloppement Sécurité

Pour utiliser la commande ChangeAccount de l'utilitaire en ligne de commande TFSAdminUtil, vous devez être administrateur sur la couche Application locale et un administrateur de SQL Server sur la couche Données de Team Foundation Server.

Image de développement Voir aussi

Autres ressources

Utilisation des outils de ligne de commande Team Foundation Server
Administration de Team Foundation Server
Gestion des services et comptes de service Team Foundation Server


ChangePassword, commande

 Image de liste droulante Image de pointage sur liste droulante Image de rduction Image de dveloppement Image Rduire tout Image Dvelopper tout Copier l'image de pointage
Visual Studio Team System
ChangePassword, commande
Voir aussi
Image Rduire tout Image de liste droulante

Use Utilisez ChangePassword pour modifier le mot de passe de tous les comptes de service.

TFSAdminUtil ChangePassword oldacct oldpwd newpwd [target]

Paramètres

Argument | Description
oldacct | Spécifie l'ancien nom du compte.
oldpwd | Spécifie l'ancien mot de passe.
newpwd | Spécifie le nouveau mot de passe du compte.
target | Spécifie l'ordinateur cible. Si la target est omise, l'ordinateur local est utilisé. L'ordinateur cible doit être un serveur de couche Application.

Image de dveloppement Notes

La commande ChangePassword est utilisée par un administrateur qui souhaite modifier le mot de passe du compte de service (par exemple, domaine\nomserveur). L'administrateur modifie le mot de passe sur le compte de domaine puis exécute cet outil pour mettre à jour tous les serveurs Team Foundation avec le nouveau mot de passe.

L'utilitaire met à jour la couche Application en modifiant les mots de passe de pool d'applications. Les pools d'applications doivent être redémarrés individuellement, mais les services IIS (Internet Information Services) ne doivent pas être redémarrés. La dernière étape de la couche Application consiste à mettre à jour le Planificateur de tâches de Team Foundation Server, également appelé service TFSServerScheduler. Pour plus d'informations, consultez Planificateur de tâches de Team Foundation Server.

Remarque Remarque

SQL Server 2005 synchronise ses mots de passe de comptes de service à l'aide d'Active Directory ; par conséquent, l'utilitaire n'a pas besoin de modifier tous les mots de passe SQL Server.

Image de dveloppement Exemples

L'exemple suivant illustre la syntaxe utilisée pour modifier les mots de passe de comptes de service. L'utilitaire échange toutes les instances de l'ancien compte, MyOldAcct, pour disposer d'un nouveau mot de passe de compte, newPass, sur l'ordinateur cible de couche Application, MyAppTier. L'utilitaire parcourt les comptes de service et modifie uniquement ceux qui s'exécutent sous l'ancien compte.

Image Copier le code Copier le code
TFSAdminUtil.exe ChangePassword MyOldAcct oldPass newPass MyAppTier

Image de dveloppement Sécurité

Pour utiliser la commande ChangePassword de l'utilitaire en ligne de commande TFSAdminUtil, vous devez être administrateur sur la couche Application locale et un administrateur de SQL Server sur la couche Données de Team Foundation Server.

Image de développement Voir aussi

Concepts

Serveurs de couche Application Team Foundation
Gestion des serveurs de couche Application dans Team Foundation Server
Serveurs de couche Données Team Foundation

Autres ressources

Commandes de l'utilitaire en ligne de commande TFSAdminUtil
Utilisation des outils de ligne de commande Team Foundation Server
Administration de Team Foundation Server
Gestion des services et comptes de service Team Foundation Server


Sid, commande

 Image de liste droulante Image de pointage sur liste droulante Image de rduction Image de dveloppement Image Rduire tout Image Dvelopper tout Copier l'image de pointage
Visual Studio Team System
Sid, commande
Voir aussi
Image Rduire tout Image de liste droulante

Utilisez la commande Sid pour mettre à jour ou répertorier tout ou partie des identificateurs de sécurité inscrits (SID).

Sid [/noprompt] (/C[hange] | /L[ist]) (/A[ll] | account)

Paramètres

Argument | Description
account | Utilisé avec les options /L[ist] ou /C[hange] pour ordonner à la commande de répertorier ou de mettre à jour les SID pour le compte spécifié par account. Ne peut pas être utilisé avec l'option /A[ll].
Option | Description
/C[hange] | Synchronise le SID dans la base de données Team Foundation Server avec le SID de Windows. S'ils sont différents, met à jour les SID Team Foundation Server pour tous les account d'utilisateur (/All) ou pour un account d'utilisateur spécifique. Cette option fonctionne uniquement dans les environnements de groupe de travail.
/L[ist] | Répertorie les SID pour tous les account d'utilisateur (/All) ou pour un account d'utilisateur spécifique.
/A[ll] | Utilisé en relation avec les options /C[hange] et /L[ist] pour spécifier que tous les SID doivent être mis à jour ou qu'ils doivent être répertoriés. Ne peut pas être utilisé avec le paramètre account.

Image de dveloppement Notes

Team Foundation Server utilise les SID pour authentifier et identifier les utilisateurs dans un environnement de groupe de travail. Le contrôle de code source Team Foundation stocke les informations des utilisateurs dans la table d'identités dans laquelle le SID de l'utilisateur est inscrit en tant que authenticationKey.

La commande TFSAdminUtil Sid est utilisée par un administrateur pour mettre à jour des comptes d'utilisateurs afin de répondre au changement de nom des utilisateurs ou à la réinstallation de Team Foundation sur un autre ordinateur. Par exemple, si l'administrateur souhaite déplacer l'installation de Team Foundation vers un nouvel ordinateur dans son environnement de groupe de travail, il doit suivre ces étapes :

  1. Restaurer les sauvegardes de données et créer la couche Application.

  2. Répertorier tous les comptes à l'aide de la commande TFSAdminUtil SID /List /All.

  3. Créer tous les comptes d'utilisateurs à l'aide de la liste générée à l'étape 2.

  4. Exécuter la commande TFSAdminUtil SID /Change /All pour mettre à jour les SID des comptes d'utilisateurs dans le serveur Team Foundation Server.

    Cela permet de conserver toutes leurs autorisations et propriétés précédentes des comptes d'utilisateurs.

Image de dveloppement Exemples

La commande suivante ordonne à la commande Sid de l'utilitaire TFSAdminUtil de répertorier tous les identificateurs de sécurité inscrits.

Image Copier le code Copier le code
TFSAdminUtil.exe Sid /NoPrompt /List /All

Image de dveloppement Sécurité

Pour utiliser la commande Sid de l'utilitaire en ligne de commande TFSAdminUtil, vous devez être administrateur sur la couche Application locale et un administrateur de SQL Server sur la couche Données de Team Foundation Server.

Image de développement Voir aussi

Autres ressources

Utilisation des outils de ligne de commande Team Foundation Server
Administration de Team Foundation Server
Gestion des services et comptes de service Team Foundation Server
Administration de Team Foundation Server
Gestion des services et comptes de service Team Foundation Server


RenameDT, commande

 Image de liste droulante Image de pointage sur liste droulante Image de rduction Image de dveloppement Image Rduire tout Image Dvelopper tout Copier l'image de pointage
Visual Studio Team System
RenameDT, commande
Voir aussi Exemple
Image Rduire tout Image de liste droulante

Utilisez RenameDT pour modifier le nom de serveur de couche Données de Team Foundation Server.

TFSAdminUtil RenameDT servername

Paramètres

Argument Description

servername

Spécifie l'ordinateur cible. L'ordinateur peut être identifié selon les types suivants :

  • Adresse IP

    L'adresse IP doit être sous le format: aaa.bbb.ccc.ddd.

  • Nom de l'ordinateur

    Aucun espace ou caractère spécial, tel que ";: <> *, seuls les caractères (A-Z | 0-9 | -) sont autorisés, ne peut pas se composer entièrement de nombres, 15 caractères maximum pour des caractères ASCII normaux et 7 caractères maximum pour des caractères de plus grand codage.

  • Adresse de domaine

    Par exemple : Myserver.location.mycompanyt.com.

Image de dveloppement Notes

La couche Application de Team Foundation Server doit savoir le nom ou l'adresse exact du serveur de couche Données pour l'atteindre. Le nom et l'adresse de couche Données sont stockés dans les nombreux emplacements dans Team Foundation Server, à la fois dans la couche Application et les bases de données de couche Données. Lorsqu'il faut basculer vers une nouvelle couche Données, l'administrateur doit vérifier que Team Foundation Server pointe vers les nouveaux nom et adresse de la couche Données.

La commande RenameDT de l'utilitaire en ligne de commande TFSAdminUtil automatise le processus d'attribution d'un nouveau nom à la couche Données en mettant à jour Team Foundation Server pour pointer vers un nouveau nom ou une nouvelle adresse. La commande RenameDT peut également permettre d'automatiser ou de planifier le processus d'attribution d'un nouveau nom à la couche Données.

La commande RenameDT peut être exécutée uniquement sur la couche Application, car elle recherche le fichier web.config sur l'ordinateur sur lequel elle est exécutée. Elle ne possède pas de fonction d'accès distant et ne prend aucun autre paramètre pour spécifier l'ordinateur de couche Application cible.

Image de dveloppement Scénarios d'exemple d'usage

La commande RenameDT peut être utilisée par l'administrateur dans différents scénarios. Les scénarios d'exemple sont répertoriés dans la liste suivante :

  • L'administrateur doit exécuter une maintenance de routine sur la couche Données et doit prendre la couche Données hors connexion en la remplaçant par une autre couche Données temporaire pour éviter d'être indisponible.

  • L'administrateur exécute la commande RenameDT de l'utilitaire en ligne de commande TFSAdminUtil afin que se connecte maintenant à la nouvelle couche Données temporaire. Lorsque la maintenance est terminée, l'administrateur exécute encore l'utilitaire pour basculer vers une couche Données antérieure.

  • La couche Données a échoué et n'est pas fonctionnelle.

  • L'administrateur exécute la commande RenameDT pour pointer Team Foundation Server vers un nouveau serveur de sauvegarde.

  • La couche Données est mise à niveau à un nouveau serveur.

  • L'administrateur exécute la commande RenameDT pour pointer Team Foundation Server vers le nouveau serveur de couche Données.

  • De nouvelles stratégies d'opérations déclarent des normes d'affectation de nom à l'ordinateur spécifique que la couche Données doit respecter.

  • L'administrateur utilise la commande RenameDT pour attribuer à la couche Données un nom plus approprié.

  • L'organisation ou l'entreprise s'est développée et doit effectuer une migration d'une solution à un serveur vers une solution à deux serveurs.

  • Une fois que la nouvelle couche Données indépendante est paramétrée, l'administrateur exécute la commande RenameDT pour pointer Team Foundation Server vers le nouveau serveur.

Image de dveloppement Exemple

L'exemple suivant renomme toutes les instances de la couche Données Team Foundation Server en NewName.
Image Copier le code Copier le code
TFSAdminUtil RenameDT NewName

Image de dveloppement Sécurité

Pour utiliser la commande RenameDT de l'utilitaire en ligne de commande TFSAdminUtil, vous devez être administrateur sur la couche Application locale et un administrateur de SQL Server sur la couche Données de Team Foundation Server.

Image de développement Voir aussi

Concepts

Serveurs de couche Application Team Foundation
Serveurs de couche Données Team Foundation

Autres ressources

Commandes de l'utilitaire en ligne de commande TFSAdminUtil
Utilisation des outils de ligne de commande Team Foundation Server
Administration de Team Foundation Server
Gestion des services et comptes de service Team Foundation Server
Gestion des serveurs de couche Données dans Team Foundation Server


Optimize, commande

 Image de liste droulante Image de pointage sur liste droulante Image de rduction Image de dveloppement Image Rduire tout Image Dvelopper tout Copier l'image de pointage
Visual Studio Team System
Optimize, commande
Voir aussi Exemple
Image Rduire tout Image de liste droulante

Utilisez optimize pour optimiser la base de données Team Foundation en exécutant un nettoyage et une défragmentation de disque.

TFSAdminUtil Optimize

Image de dveloppement Notes

La commande optimize de l'utilitaire en ligne de commande TFSAdmin optimise la couche Données de Team Foundation Server en nettoyant les bases de données et en exécutant une défragmentation des index de base de données. En général, cette optimisation est exécutée par la base de données ou par un administrateur Team Foundation Server dans le cadre du plan de maintenance de la base de données pour Team Foundation Server. Cet utilitaire peut également être écrit pour automatiser et planifier le processus pour l'optimisation normale.

L'utilitaire peut uniquement être exécuté sur la couche Application parce qu'il recherche les services Web sur l'ordinateur sur lequel il est exécuté. Il ne possède pas de fonctions d'accès distant et ne prend aucun autre paramètre pour spécifier le serveur cible de couche Application.

Image de dveloppement Nettoyage de bases de données

Après une période d'utilisation intensive, les bases de données Team Foundation Server peuvent contenir des enregistrements archivés ou d'historique inutiles pouvant être supprimés afin de réduire la taille de base de données et d'augmenter les performances. Chaque base de données implémente sa propre procédure stockée pour exécuter cette optimisation. La commande optimize recherche cette procédure stockée pour chaque base de données et l'exécute si elle la trouve. L'utilitaire parcourt alors les bases de données jusqu'à ce que toutes les bases de données aient été nettoyées. Si une routine de nettoyage de base de données échoue, l'utilitaire affiche un message d'avertissement et passe au nettoyage de la base de données suivante.

Image de dveloppement Défragmentation de bases de données

Lors de la création d'un index de base de données ou de l'ajout de nouveaux enregistrements, la base de données n'est pas ou peu fragmentée. Toutefois, après des activités importantes, l'ordre physique des enregistrements indexés devient progressivement plus erratique, affectant les performances du disque et l'efficacité du gestionnaire de lecture anticipée de SQL Server.

La défragmentation implique la réorganisation de l'ordre physique des enregistrements pour qu'il corresponde à l'ordre logique, diminuant ainsi le temps nécessaire au serveur pour analyser la base de données.

La commande optimize de l'utilitaire en ligne de commande TFSAdmin détermine s'il faut effectuer une réorganisation ou une régénération en fonction de la fragmentation des index de base de données et de la pagination d'index. La défragmentation est exécutée sur les index très fragmentés, alors que la régénération des index est exécutée sur les index dont le compte de pages est inférieur et qui sont moins fragmentés. Si SQL Server retourne des erreurs, un avertissement est émis au niveau de la ligne de commande.

Image de dveloppement Exemple

L'exemple suivant affiche la syntaxe de la commande optimize de l'utilitaire en ligne de commande TFSAdminUtil. Le processus d'optimisation tient en permanence au courant l'utilisateur de sa progression.
Image Copier le code Copier le code
TFSAdminUtil optimize

Image de dveloppement Sécurité

Pour utiliser la commande Optimize de l'utilitaire en ligne de commande TFSAdminUtil, vous devez être administrateur sur la couche Application locale et un administrateur de SQL Server sur la couche Données de Team Foundation Server.

Image de développement Voir aussi

Concepts

Serveurs de couche Application Team Foundation
Serveurs de couche Données Team Foundation

Autres ressources

Commandes de l'utilitaire en ligne de commande TFSAdminUtil
Utilisation des outils de ligne de commande Team Foundation Server
Administration de Team Foundation Server
Gestion des services et comptes de service Team Foundation Server
Gestion des serveurs de couche Données dans Team Foundation Server


ActivateAt, commande

 Image de liste droulante Image de pointage sur liste droulante Image de rduction Image de dveloppement Image Rduire tout Image Dvelopper tout Copier l'image de pointage
Visual Studio Team System
ActivateAt, commande
Voir aussi Exemple
Image Rduire tout Image de liste droulante

Utilisez ActivateAT pour activer l'ordinateur local en tant que serveur de couche Application.

TFSAdminUtil ActivateAT

Image de dveloppement Notes

Il est nécessaire d'empêcher plusieurs couches Application de se connecter à la même couche Données. La commande ActivateAT de l'utilitaire en ligne de commande TFSAdminUtil est utilisée pour activer la couche Application appropriée et la lier au serveur de couche Données.

Image de dveloppement Scénarios d'exemple d'usage

La commande ActivateAT peut être utilisée par l'administrateur dans différents scénarios. Les scénarios d'exemple sont répertoriés dans la liste suivante :

  • Maintenance ou correction de la couche Application :

    L'administrateur configure une nouvelle couche Application et doit l'activer plutôt que la couche Application actuelle. La couche Application (ancienne) actuelle est arrêtée. L'administrateur exécute l'utilitaire en ligne de commande TFSAdminUtil activateAT pour lier la nouvelle couche Application au serveur de couche Données.

  • Échec de la couche Application active :

    Comme la couche Application est la seule raison de l'échec du système, l'administrateur pourrait souhaiter introduire un serveur de couche Application de secours. La couche Application active est connectée au réseau et pointe vers le serveur de couche Données correct. La couche Données doit soutenir la couche Application active et ne doit pas exécuter de transaction avec le serveur de couche Application de secours. La commande ActivateAT est utilisée pour basculer entre les deux serveurs de couche Application si nécessaire.

    Si le serveur de couche Application actif échoue, l'administrateur doit basculer vers le serveur de couche Application de secours. En premier lieu, l'administrateur arrête ou réinitialise les services IIS (Internet Information Services) sur le serveur de couche Application qui a subi l'échec. L'administrateur exécute ensuite l'utilitaire en ligne de commande TFSAdminUtil ActivateAT pour lier la couche Application de secours au serveur de couche Données.

Image de dveloppement Exemple

L'exemple suivant active l'ordinateur local en tant que couche Activation.
Image Copier le code Copier le code
TFSAdminUtil.exe activateAT

Image de dveloppement Sécurité

Pour utiliser la commande ActivateAT de l'utilitaire en ligne de commande TFSAdminUtil, vous devez être administrateur sur la couche Application locale et un administrateur de SQL Server sur la couche Données de Team Foundation Server.

Image de développement Voir aussi

Concepts

Serveurs de couche Application Team Foundation
Serveurs de couche Données Team Foundation

Autres ressources

Commandes de l'utilitaire en ligne de commande TFSAdminUtil
Utilisation des outils de ligne de commande Team Foundation Server
Administration de Team Foundation Server
Gestion des services et comptes de service Team Foundation Server
Gestion des serveurs de couche Données dans Team Foundation Server


Status, commande (TFSAdminUtil)

 Image de liste droulante Image de pointage sur liste droulante Image de rduction Image de dveloppement Image Rduire tout Image Dvelopper tout Copier l'image de pointage
Visual Studio Team System
Status, commande (TFSAdminUtil)
Voir aussi
Image Rduire tout Image de liste droulante

Utilisez Status pour afficher les informations d'état d'un compte de service spécifié sur Team Foundation Server.

TFSAdminUtil Status account [machinename]

Paramètres

Argument | Description
account | Nom du compte. Doit être au format domaine\utilisateur, par exemple mylocation\tfssvc.
machinename | Nom de l'ordinateur. Si le machinename est omis, le compte local est utilisé.

Image de dveloppement Notes

La commande Status de l'utilitaire en ligne de commande TFSAdminUtil fournit des informations sur l'utilisation du compte fourni par Team Foundation Server.

Image de dveloppement Exemples

L'exemple suivant affiche la sortie status pour les ressources qui sont exécutées sous le compte de service "myLocation\tfssvc".

Image Copier le code Copier le code
TfsAdminUtil.exe status myLocation\tfssvc

Résultat de l'exemple :

Image Copier le code Copier le code
LoginName            SID
-------------------------------------------------------------------
MYLOCATION\TFSSVC    S-1-5-21-2127521184-1604012920-1887927527-2435684

DBName                            UserName          UserOrAlias
---------------------------------------------------------------
STS_Config                       db_owner           MemberOf
STS_Config                       MYLOCATION\TFSSVC  User
STS_VSE2017_1                    db_owner           MemberOf
STS_VSE2017_1                    dbo                User
TfsActivityLogging               MYLOCATION\TFSSVC  User
TfsActivityLogging               TFSEXECROLE        MemberOf
TfsBuild                         MYLOCATION\TFSSVC  User
TfsBuild                         TFSEXECROLE        MemberOf
TfsIntegration                   MYLOCATION\TFSSVC  User
TfsIntegration                   TFSEXECROLE        MemberOf
TfsVersionControl                MYLOCATION\TFSSVC  User
TfsVersionControl                TFSEXECROLE        MemberOf
TFSWarehouse                     MYLOCATION\TFSSVC  User
TFSWarehouse                     TFSEXECROLE        MemberOf
TfsWorkItemTracking              MYLOCATION\TFSSVC  User
TfsWorkItemTracking              TFSEXECROLE        MemberOf
TfsWorkItemTrackingAttachments   MYLOCATION\TFSSVC  User
TfsWorkItemTrackingAttachments   TFSEXECROLE        MemberOf

Account status on application tier (IIS application pools): VSE2017.
3 app pool(s) are running under given account: myLocation\tfssvc.

Name           Status
----------------------
TFS AppPool    Running
TFWSSc86e      Running
WSSc86eAdm     Running

Account status on application tier (NT Services): VSE2017.
3 NT service(s) are runing under given account: myLocation \tfssvc.

Name                  DisplayName                       Status
---------------------------------------------------------------
SPTimer               SharePoint Timer Service          Running
coveran               Code Coverage Analysis Service    Stopped
TFSServerScheduler    TFSServerScheduler                Running

Image de développement Voir aussi

Autres ressources

Commandes de l'utilitaire en ligne de commande TFSAdminUtil


Commandes de l'utilitaire en ligne de commande TFSSecurity

Commandes de l'utilitaire en ligne de commande TFSSecurity
DropDown image

Utilisez TFSSecurity pour créer, modifier et supprimer les groupes et utilisateurs de Team Foundation Server ainsi que les autorisations des utilisateurs et des groupes.

L'utilitaire en ligne de commande TFSSecurity est situé dans <drive>:\Program Files\Microsoft Visual Studio 2005 Team Foundation Server\Tools.

Les options suivantes sont prises en charge pour toutes les commandes TFSSecurity.

option | Description
/server:name | Sélectionne explicitement un domaine Team Foundation Server, où name est le nom du domaine.
/? | Affiche la syntaxe de commande et les options de TFSSecurity.

Dans cette section

Spécificateurs d'identité et de sortie TFSSecurity

/i, commande

/im, commande

/imx, commande

/g, commande

/gcg, commande

/gc, commande

/gun, commande

/gud, commande

/gd, commande

/g+, commande

/g-, commande

/m, commande

/a+, commande

/a-, commande

/acl, commande


Spécificateurs d'identité et de sortie TFSSecurity

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Spécificateurs d'identité et de sortie TFSSecurity
Voir aussi
Image de liste déroulante

L'entrée et la sortie de l'utilitaire en ligne de commande TFSSecurity suivent un format standard. L'identité et les spécificateurs de sortie valides sont décrits dans les tableaux suivants.

Spécificateurs d'identité

Une identité peut être référencée à l'aide de l'une des notations suivantes.

Spécificateur d'identité Description Exemple

sid: sid.

Référence l'identité avec le SID spécifié.

sid:S-1-5-21-2127521184-1604012920-1887927527-588340

n:[domaine\]nom

Référence l'identité avec le nom spécifié. Pour Windows, nom est le nom de connexion. Si domaine est omis et le catalogue global (GC) est disponible, l'opération de recherche sera exécutée par GC. Si domaine est omis et GC est non disponible, le contexte de domaine par défaut est utilisé. Pour les groupes d'applications, nom est le nom complet du groupe, et domaine est l'URI ou le GUID du projet conteneur. Si domaine est omis, la portée globale est utilisée.

Pour référencer l'identité de l'utilisateur "John Peoples" dans le domaine "Datum1" de la société fictive "A. Datum Corporation":

n:DATUM1\jpeoples

S'il y a un seul domaine ou que vous êtes connecté au domaine Datum1, l'exemple suivant peut également fonctionner :

n:jpeoples

Pour référencer des groupes d'applications :

n:"Full-time Employees"

n:00a10d23-7d45-4439-981b-d3b3e0b0b1ee\Vendors

n:dn

Référence l'identité avec le nom unique spécifié. Le nom unique peut avoir un préfixe LDAP://.

dn:CN=John Peoples,CN=Users,DC=Datum1,DC=com

dn:LDAP://CN=Developers,OU=Groups,DC=Datum1,DC=com

dm:[portée]

Référence le groupe d'applications Administrative pour la portée. Le paramètre optionnel portée est un URI ou un GUID de projet. Si la portée est omise, la portée globale est utilisée, mais la virgule est requise.

dm:TFSAdmins

srv:

Référence le groupe d'applications Service.

NA

chaîne

Référence une chaîne non qualifiée. Si chaîne commence par S-1-, il est identifié comme un SID. Si chaîne commence par CN= ou LDAP://, il est identifié comme un nom unique. Sinon, chaîne est identifié comme un nom.

"Testeurs d'équipe"

Marqueurs de types

Marqueurs de types d'identités

Les marqueurs de types d'identités suivants sont utilisés dans les messages de sortie.

Marqueur de type d'identité | Description
U | Utilisateur Windows.
G | Groupe Windows.
A | Groupe d'applications Team Foundation Server.
a [ A ] | Groupe d'applications Administrative.
s [ A ] | Groupe d'applications Service.
X | Identité non valide.
? | Identité inconnue.

Marqueurs d'entrée de contrôle d'accès

Les marqueurs d'entrée de contrôle d'accès suivants sont utilisés pour les messages de sortie.

Marqueur d'entrée de contrôle d'accès | Description
+ | Entrée de contrôle d'accès ALLOW.
- | Entrée de contrôle d'accès DENY.
* [ ] | Entrée de contrôle d'accès héritée.

Voir aussi

Autres ressources

Commandes de l'utilitaire en ligne de commande TFSSecurity
Gestion des groupes
Groupes par défaut
Groupes de niveau serveur
Groupes de projets d'équipe


/i, commande

 Image de liste droulante Image de pointage sur liste droulante Image de rduction Image de dveloppement Image Rduire tout Image Dvelopper tout Copier l'image de pointage
Visual Studio Team System
/i, commande
Voir aussi
Image Rduire tout Image de liste droulante

Utilisez /i pour afficher les informations d'identité d'un groupe spécifié sur Team Foundation Server.

TFSSecurity /i identity

Paramètres

Argument | Description
identity | Spécifie l'identité de l'utilisateur ou du groupe d'application. Pour plus d'informations sur les spécificateurs d'identité, consultez Spécificateurs d'identité et de sortie TFSSecurity.

Image de dveloppement Notes

La commande /i de l'utilitaire en ligne de commande TFSSecurity affiche des informations sur chaque groupe de la couche Application du serveur Team Foundation Server. Elle n'affiche pas d'informations d'appartenance.

Image de dveloppement Exemples

L'exemple suivant affiche des informations sur l'identité pour le groupe "Team Foundation Administrators".

Image Copier le code Copier le code
>tfssecurity /i "Team Foundation Administrators"

Résultat de l'exemple :

Image Copier le code Copier le code
Resolving identity "Team Foundation Administrators"...

SID: S-1-9-XXXXXXXXXX-XXXXXXXXXX-XXXXXXXXXX-XXXXXXXXXX-0-0-0-0-1

DN:

Identity type: Team Foundation Server application group
   Group type: AdministrativeApplicationGroup
Project scope: Server scope
 Display name: Team Foundation Administrators
  Description: Members of this application group can perform all privileged operations on the server.

Image de dveloppement Sécurité

Pour utiliser la commande /i de l'utilitaire en ligne de commande TFSSecurity, vous devez être administrateur Team Foundation Server sur la couche Application locale. Exécutez cette commande sur l'ordinateur de couche Application locale.

Image de développement Voir aussi

Tâches

Comment : créer un groupe de niveau serveur

Autres ressources

Commandes de l'utilitaire en ligne de commande TFSSecurity
Groupes de projets d'équipe


/im, commande

 Image de liste droulante Image de pointage sur liste droulante Image de rduction Image de dveloppement Image Rduire tout Image Dvelopper tout Copier l'image de pointage
Visual Studio Team System
/im, commande
Voir aussi
Image Rduire tout Image de liste droulante

Utilisez la commande /im pour afficher des informations sur l'identité de l'appartenance directes pour un groupe spécifié.

TFSSecurity /im identity

Paramètres

Argument | Description
identity | Spécifie l'identité de l'utilisateur ou du groupe. Pour plus d'informations sur les spécificateurs d'identité, consultez Spécificateurs d'identité et de sortie TFSSecurity.

Image de dveloppement Notes

TfsSecurity /im affiche les membres directs du groupe spécifié uniquement. Cela inclut d'autres groupes qui sont membres du groupe spécifié. Toutefois, les membres réels des groupes de membres ne sont pas répertoriés.

Image de dveloppement Exemples

L'exemple suivant affiche des informations sur l'identité de l'appartenance directes pour le groupe "Team Foundation Administrators".

Image Copier le code Copier le code
>tfssecurity /im "Team Foundation Administrators"

Résultat de l'exemple :

Image Copier le code Copier le code
Resolving identity "Team Foundation Administrators"...

SID: S-1-9-XXXXXXXXXX-XXXXXXXXXX-XXXXXXXXXX-XXXXXXXXXX-0-0-0-0-1

DN:

Identity type: Team Foundation Server application group
Group type: AdministrativeApplicationGroup
Project scope: Server scope
Display name: Team Foundation Administrators
Description: Members of this application group can perform all privileged operations on the server.

4 member(s):
  [G] MyLocation\Cwin (Coho Winery)
  [U] MyLocation\ajesper (Aaberg, Jesper)
  [G] BUILTIN\Administrators
s [A] [SERVER]\Service Accounts

Member of 1 group(s):
e [A] [SERVER]\Team Foundation Valid Users

Image de dveloppement Sécurité

Pour utiliser la commande /im de l'utilitaire en ligne de commande TFSSecurity, vous devez être administrateur Team Foundation Server sur la couche Application locale. Exécutez cette commande sur l'ordinateur de couche Application locale.

Image de développement Voir aussi

Tâches

Comment : créer un groupe de niveau serveur

Autres ressources

Commandes de l'utilitaire en ligne de commande TFSSecurity
Groupes de projets d'équipe


/imx, commande

 Image de liste droulante Image de pointage sur liste droulante Image de rduction Image de dveloppement Image Rduire tout Image Dvelopper tout Copier l'image de pointage
Visual Studio Team System
/imx, commande
Voir aussi
Image Rduire tout Image de liste droulante

Utilisez /imx pour afficher des informations sur l'identité de l'appartenance développées pour un groupe spécifié.

TFSSecurity /imx identity

Paramètres

Argument | Description
identity | Spécifie l'identité de l'utilisateur ou du groupe. Pour plus d'informations sur les spécificateurs d'identité, consultez Spécificateurs d'identité et de sortie TFSSecurity.

Image de dveloppement Notes

TfsSecurity /im affiche les membres directs du groupe spécifié uniquement. Les autres groupes de membres du groupe spécifié ainsi que les membres réels des groupes de membres sont répertoriés.

Image de dveloppement Exemples

L'exemple suivant affiche des informations sur l'identité de l'appartenance approfondies pour le "groupe Team Foundation Administrators".

Image Copier le code Copier le code
>tfssecurity /imx "Team Foundation Administrators"

Résultat de l'exemple :

Image Copier le code Copier le code
SID: S-1-9-XXXXXXXXXX-XXXXXXXXXX-XXXXXXXXXX-XXXXXXXXXX-0-0-0-0-1

DN:

Identity type: Team Foundation Server application group
   Group type: AdministrativeApplicationGroup
Project scope: Server scope
 Display name: Team Foundation Administrators
  Description: Members of this application group can perform all privileged operations on the server.

10 member(s):
  [U] MYLOCATION\Cwinbld (Coho Winery Build-Test Account)
  [U] MYLOCATION\tommyh (Tommy Hartono)
  [U] MYLOCATION\henriea (Henriette Andersen)
  [U] MYLOCATION\bissvca (BIS Service Account)
  [U] MYLOCATION\stanisp (Stanislav Pesotsky)
  [G] MYLOCATION\InfoSec Secure Environment
  [U] MYLOCATION\tiannaj (TiAnna Jones)
  [G] MYLOCATION\cwin (Coho Winery)
  [G] BUILTIN\Administrators
s [A] [SERVER]\Service Accounts

Member of 1 group(s):
e [A] [SERVER]\Team Foundation Valid Users

Done.

Pour plus d'informations sur les spécificateurs de sortie, tels que [G] et [U], consultez Spécificateurs d'identité et de sortie TFSSecurity.

Image de développement Voir aussi

Tâches

Comment : créer un groupe de niveau serveur

Autres ressources

Commandes de l'utilitaire en ligne de commande TFSSecurity
Groupes de projets d'équipe


/g, commande

 Image de liste droulante Image de pointage sur liste droulante Image de rduction Image de dveloppement Image Rduire tout Image Dvelopper tout Copier l'image de pointage
Visual Studio Team System
/g, commande
Voir aussi Exemple
Image Rduire tout Image de liste droulante

Utilisez /g pour répertorier les groupes dans une portée de projet.

TFSSecurity /g [scope]

Paramètres

Argument | Description
scope | Facultatif. URI ou GUID de projet. Si le nom du projet est ignoré, les groupes globaux sont affichés.

Image de dveloppement Exemple

L'exemple suivant affiche tous les groupes globaux.
Image Copier le code Copier le code
>TFSSecurity /g

Image de dveloppement Sécurité

Pour utiliser la commande /g de l'utilitaire en ligne de commande TFSSecurity, vous devez être administrateur Team Foundation Server sur la couche Application locale. Exécutez cette commande sur l'ordinateur de couche Application locale.

Image de développement Voir aussi

Tâches

Comment : créer un groupe de niveau serveur

Autres ressources

Commandes de l'utilitaire en ligne de commande TFSSecurity
Groupes de projets d'équipe


/gcg, commande

 Image de liste droulante Image de pointage sur liste droulante Image de rduction Image de dveloppement Image Rduire tout Image Dvelopper tout Copier l'image de pointage
Visual Studio Team System
/gcg, commande
Voir aussi Exemple
Image Rduire tout Image de liste droulante

Utilisez /gcg pour créer un groupe global.

TFSSecurity /gcg groupName [groupDescription]

Paramètres

Argument | Description
groupName | Spécifie le nom de groupe global.
groupDescription | Facultatif. Description de groupe.

Image de dveloppement Notes

Les groupes globaux sont des groupes qui sont créés directement sur Team Foundation Server. Ils s'opposent aux groupes de projets d'équipe qui sont associés à un projet spécifique. Les groupes globaux peuvent se voir assigner des autorisations afin d'effectuer des tâches sur le serveur Team Foundation Server lui-même, telles que la création de projets ou l'administration d'utilisateurs.

Image de dveloppement Exemple

L'exemple suivant crée un groupe global appelé "cwintst" avec la description "Coho Winery Testers".
Image Copier le code Copier le code
>TFSSecurity /gcg cwintst “Coho Winery Testers”

Image de dveloppement Sécurité

Pour utiliser la commande /gcg de l'utilitaire en ligne de commande TFSSecurity, vous devez être administrateur Team Foundation Server sur la couche Application locale. Exécutez cette commande sur l'ordinateur de couche Application locale.

Image de développement Voir aussi

Tâches

Comment : créer un groupe de niveau serveur

Autres ressources

Commandes de l'utilitaire en ligne de commande TFSSecurity
Groupes de projets d'équipe
Groupes par défaut


/gc, commande

 Image de liste droulante Image de pointage sur liste droulante Image de rduction Image de dveloppement Image Rduire tout Image Dvelopper tout Copier l'image de pointage
Visual Studio Team System
/gc, commande
Voir aussi Exemple
Image Rduire tout Image de liste droulante

Utilisez /gc pour créer un groupe spécifique au projet.

TFSSecurity /gc scope groupName [groupDescription]

Paramètres

Argument | Description
scope | Spécifie le GUID ou URI de projet du projet d'équipe. Pour obtenir l'URI, exécutez http://localhost:8080/services/v1.0/CommonStructureService.asmx/ListAllProjects sur Team Foundation Server.
groupName | Spécifie le nom du groupe du projet.
groupDescription | Facultatif. Description du groupe de projets.

Image de dveloppement Notes

Un groupe avec une portée de projet est essentiellement un groupe de sécurité pour votre projet d'équipe. Les groupes de projets peuvent être utilisés pour accorder des autorisations en lecture, en écriture et des autorisations administratives pour satisfaire les exigences de sécurité de votre organisation.

Image de dveloppement Exemple

L'exemple suivant crée un groupe spécifique au projet spécifié par l'URI : "vstfs:///Classification/TeamProject/088e66e2-714a-476d-8f04-db899712f92a". Le groupe est nommé "Test Group" et présente la description "This group is for testing".
Image Copier le code Copier le code
TFSSecurity /gc "vstfs:///Classification/TeamProject/088e66e2-714a-476d-8f04-db899712f92a" "Test Group" "This group is for testing"

Image de dveloppement Sécurité

Pour utiliser la commande /gc de l'utilitaire en ligne de commande TFSSecurity, vous devez être administrateur Team Foundation Server sur la couche Application locale. Exécutez cette commande sur l'ordinateur de couche Application locale.

Image de développement Voir aussi

Tâches

Comment : créer un groupe de niveau serveur
Comment : créer un groupe de projets d'équipe

Autres ressources

Commandes de l'utilitaire en ligne de commande TFSSecurity
Groupes de projets d'équipe
Groupes par défaut


/gun, commande

 Image de liste droulante Image de pointage sur liste droulante Image de rduction Image de dveloppement Image Rduire tout Image Dvelopper tout Copier l'image de pointage
Visual Studio Team System
/gun, commande
Voir aussi Exemple
Image Rduire tout Image de liste droulante

Utilisez la commande /gun pour renommer un groupe.

TFSSecurity /gun groupIdentity groupName

Paramètres

Argument | Description
groupIdentity | Spécifie l'identité du groupe. Pour plus d'informations sur les spécificateurs d'identité valides, consultez Spécificateurs d'identité et de sortie TFSSecurity.
groupName | Spécifie le nouveau nom du groupe.

Image de dveloppement Exemple

L'exemple suivant renomme le groupe "Coho Winery Education" en "Coho Winery Product Support".
Image Copier le code Copier le code
>tfssecurity /gun "Coho Winery Education" "Coho Winery Product Support"

Image de dveloppement Sécurité

Pour utiliser la commande /gun de l'utilitaire en ligne de commande TFSSecurity, vous devez être administrateur Team Foundation Server sur la couche Application locale. Exécutez cette commande sur l'ordinateur de couche Application locale.

Image de développement Voir aussi

Tâches

Comment : renommer un groupe de projets d'équipe
Comment : renommer un groupe de niveau serveur

Concepts

Spécificateurs d'identité et de sortie TFSSecurity

Autres ressources

Commandes de l'utilitaire en ligne de commande TFSSecurity


/gud, commande

 Image de liste droulante Image de pointage sur liste droulante Image de rduction Image de dveloppement Image Rduire tout Image Dvelopper tout Copier l'image de pointage
Visual Studio Team System
/gud, commande
Voir aussi Exemple
Image Rduire tout Image de liste droulante

Utilisez /gud pour modifier la description d'un groupe.

TFSSecurity /gud groupIdentity groupDescription

Paramètres

Argument | Description
groupIdentity | Spécifie l'identité du groupe. Pour plus d'informations sur les spécificateurs d'identité valides, consultez Spécificateurs d'identité et de sortie TFSSecurity.
groupDescription | Spécifie la nouvelle description du groupe.

Image de dveloppement Exemple

L'exemple suivant associe la description « Support produit pour le service informatique de l'établissement vinicole » au groupe « Support produit de Coho Winery ».
Image Copier le code Copier le code
>TFSSecurity /gud "Coho Winery Product Support" "Product support fort he winery IT department"

Image de dveloppement Sécurité

Pour utiliser la commande /gud de l'utilitaire en ligne de commande TFSSecurity, vous devez être administrateur Team Foundation Server sur la couche Application locale. Exécutez cette commande sur l'ordinateur de couche Application locale.

Image de développement Voir aussi

Autres ressources

Commandes de l'utilitaire en ligne de commande TFSSecurity
Gestion des groupes
Groupes par défaut
Groupes de niveau serveur
Groupes de projets d'équipe


/gd, commande

 Image de liste droulante Image de pointage sur liste droulante Image de rduction Image de dveloppement Image Rduire tout Image Dvelopper tout Copier l'image de pointage
Visual Studio Team System
/gd, commande
Voir aussi Exemple
Image Rduire tout Image de liste droulante

Utilisez la commande /gd pour supprimer un groupe.

TFSSecurity /gd groupIdentity

Paramètres

Argument | Description
groupIdentity | Spécifie l'identité du groupe. Pour plus d'informations sur les spécificateurs d'identité valides, consultez Commandes de l'utilitaire en ligne de commande TFSSecurity.

Image de dveloppement Notes

Vous pouvez également supprimer des groupes sur Team Explorer. Pour plus d'informations, consultez Comment : supprimer un groupe de niveau serveur et Comment : supprimer un groupe de projets d'équipe.

Image de dveloppement Exemple

L'exemple suivant supprime un groupe identifié par "S-1-5-21-2127521184-1604012920-1887927527-588340", l'identificateur de sécurité (SID).
Image Copier le code Copier le code
>TFSSecurity /gd S-1-5-21-2127521184-1604012920-1887927527-588340

Image de dveloppement Sécurité

Pour utiliser la commande /gd de l'utilitaire en ligne de commande TFSSecurity, vous devez être administrateur Team Foundation Server sur la couche Application locale. Exécutez cette commande sur l'ordinateur de couche Application locale.

Image de développement Voir aussi

Tâches

Comment : créer un groupe de niveau serveur

Autres ressources

Commandes de l'utilitaire en ligne de commande TFSSecurity
Groupes de projets d'équipe
Groupes par défaut


/g+, commande

 Image de liste droulante Image de pointage sur liste droulante Image de rduction Image de dveloppement Image Rduire tout Image Dvelopper tout Copier l'image de pointage
Visual Studio Team System
/g+, commande
Voir aussi Exemple
Image Rduire tout Image de liste droulante

Utilisez la commande /g+ pour ajouter un utilisateur ou un autre groupe à un groupe existant.

TFSSecurity /g+ groupIdentity memberIdentity

Paramètres

Argument | Description
groupIdentity | Spécifie l'identité du groupe. Pour plus d'informations sur les spécificateurs d'identité valides, consultez Spécificateurs d'identité et de sortie TFSSecurity.
memberIdentity | Spécifie l'identité du membre. Pour plus d'informations sur les spécificateurs d'identité valides, consultez Spécificateurs d'identité et de sortie TFSSecurity.

Image de dveloppement Notes

Vous pouvez également ajouter des utilisateurs et des groupes à un groupe existant à l'aide de Team Explorer. Pour plus d'informations, consultez Comment : ajouter des utilisateurs à un groupe de niveau serveur.

Image de dveloppement Exemple

L'exemple suivant ajoute l'utilisateur "ajesper" au groupe global "Team Foundation Administrators".
Image Copier le code Copier le code
>TFSSecurity /g+ "Team Foundation Administrators" n:ajesper

Image de dveloppement Sécurité

Pour utiliser la commande /g+ de l'utilitaire en ligne de commande TFSSecurity, vous devez être administrateur Team Foundation Server sur la couche Application locale. Exécutez cette commande sur l'ordinateur de couche Application locale.

Image de développement Voir aussi

Tâches

Comment : créer un groupe de niveau serveur

Autres ressources

Commandes de l'utilitaire en ligne de commande TFSSecurity
Groupes de projets d'équipe
Groupes par défaut


/g-, commande

 Image de liste droulante Image de pointage sur liste droulante Image de rduction Image de dveloppement Image Rduire tout Image Dvelopper tout Copier l'image de pointage
Visual Studio Team System
/g-, commande
Voir aussi Exemple
Image Rduire tout Image de liste droulante

Utilisez la commande /g- pour supprimer un utilisateur ou un groupe d'utilisateurs d'un groupe existant.

TFSSecurity /g1 groupIdentity memberIdentity

Paramètres

Argument | Description
groupIdentity | Spécifie l'identité du groupe. Pour plus d'informations sur les spécificateurs d'identité valides, consultez Spécificateurs d'identité et de sortie TFSSecurity.
memberIdentity | Spécifie l'identité du membre. Pour plus d'informations sur les spécificateurs d'identité valides, consultez Spécificateurs d'identité et de sortie TFSSecurity.

Image de dveloppement Notes

Vous pouvez également ajouter des utilisateurs et des groupes à un groupe existant à l'aide de Team Explorer. Pour plus d'informations, consultez Comment : supprimer des utilisateurs d'un groupe de projets d'équipe, Comment : supprimer des utilisateurs d'un groupe par défaut ou Comment : supprimer des utilisateurs d'un groupe de niveau serveur.

Image de dveloppement Exemple

L'exemple suivant supprime l'utilisateur "ajesper" du groupe global "Team Foundation Administrators".
Image Copier le code Copier le code
>TFSSecurity /g- "Team Foundation Administrators" n:ajesper

Image de dveloppement Sécurité

Pour utiliser la commande /g- de l'utilitaire en ligne de commande TFSSecurity, vous devez être administrateur Team Foundation Server sur la couche Application locale. Exécutez cette commande sur l'ordinateur de couche Application locale.

Image de développement Voir aussi

Tâches

Comment : créer un groupe de niveau serveur

Autres ressources

Commandes de l'utilitaire en ligne de commande TFSSecurity
Groupes de projets d'équipe
Groupes par défaut


/m, commande

 Image de liste droulante Image de pointage sur liste droulante Image de rduction Image de dveloppement Image Rduire tout Image Dvelopper tout Copier l'image de pointage
Visual Studio Team System
/m, commande
Voir aussi Exemple
Image Rduire tout Image de liste droulante

Utilisez /m pour vérifier l'appartenance au groupe d'un groupe ou d'un utilisateur spécifié.

TFSSecurity /m groupIdentity [memberIdentity]

Paramètres

Argument | Description
groupIdentity | Spécifie l'identité du groupe. Pour plus d'informations sur les spécificateurs d'identité valides, consultez Spécificateurs d'identité et de sortie TFSSecurity.
memberIdentity | Spécifie l'identité du membre. Pour plus d'informations sur les spécificateurs d'identité valides, consultez Spécificateurs d'identité et de sortie TFSSecurity. Si memberIdentity est omis, le contexte actuel est utilisé.

Image de dveloppement Notes

La commande /m de l'utilitaire en ligne de commande TFSSecurity vérifie les appartenances directes et étendues.

Image de dveloppement Exemple

L'exemple suivant permet de vérifier si l'utilisateur "ajesper" appartient au groupe global "Team Foundation Administrators".
Image Copier le code Copier le code
>TFSSecurity /m "Team Foundation Administrators" n:ajesper

Image de dveloppement Sécurité

Pour utiliser la commande /m de l'utilitaire en ligne de commande TFSSecurity, vous devez être administrateur Team Foundation Server sur la couche Application locale. Exécutez cette commande sur l'ordinateur de couche Application locale.

Image de développement Voir aussi

Tâches

Comment : créer un groupe de niveau serveur

Autres ressources

Commandes de l'utilitaire en ligne de commande TFSSecurity
Groupes de projets d'équipe
Groupes par défaut


/a+, commande

 Image de liste droulante Image de pointage sur liste droulante Image de rduction Image de dveloppement Image Rduire tout Image Dvelopper tout Copier l'image de pointage
Visual Studio Team System
/a+, commande
Voir aussi
Image Rduire tout Image de liste droulante

Utilisez /a+ pour ajouter une entrée de contrôle d'accès.

TFSSecurity /a+ objectID actionID identity (ALLOW | DENY)

Paramètres

Argument Description

objectID

URI de l'objet de contrôle d'accès.

actionID

Nom de l'autorisation pour laquelle l'accès est accordé ou refusé. Pour obtenir la liste des ID valides, consultez Autorisations de Team Foundation Server et Groupes, autorisations et rôles par défaut de Team Foundation Server.

identity

Spécifie l'identité de l'utilisateur ou du groupe. Pour plus d'informations sur les spécificateurs d'identité, consultez Spécificateurs d'identité et de sortie TFSSecurity.

  • ALLOW

    Le groupe ou l'utilisateur est autorisé à effectuer l'opération spécifiée par l'actionID.

  • DENY

    Le groupe ou l'utilisateur n'est pas autorisé à effectuer l'opération spécifiée par l'actionID.

Image de dveloppement Notes

Les entrées de contrôle d'accès sont des mécanismes de sécurité qui déterminent les opérations qu'un utilisateur, un groupe, un service ou un ordinateur est autorisé à effectuer sur un ordinateur ou un serveur.

Image de dveloppement Sécurité

Pour utiliser la commande /a+ de l'utilitaire en ligne de commande TFSSecurity, vous devez être administrateur Team Foundation Server sur la couche Application locale. Exécutez cette commande sur l'ordinateur de couche Application locale.

Image de développement Voir aussi

Tâches

Comment : créer un groupe de niveau serveur

Autres ressources

Commandes de l'utilitaire en ligne de commande TFSSecurity
Groupes de projets d'équipe
Groupes par défaut


/a-, commande

 Image de liste droulante Image de pointage sur liste droulante Image de rduction Image de dveloppement Image Rduire tout Image Dvelopper tout Copier l'image de pointage
Visual Studio Team System
/a-, commande
Voir aussi
Image Rduire tout Image de liste droulante

Utilisez /a- pour supprimer une entrée de contrôle d'accès.

TFSSecurity /a- objectID actionID identity (ALLOW | DENY)

Paramètres

Argument Description

objectID

URI de l'objet de contrôle d'accès.

actionID

Nom de l'autorisation. Pour obtenir la liste des ID valides, consultez Autorisations de Team Foundation Server et Groupes, autorisations et rôles par défaut de Team Foundation Server.

identity

Spécifie l'identité de l'utilisateur ou du groupe. Pour plus d'informations sur les spécificateurs d'identité, consultez Spécificateurs d'identité et de sortie TFSSecurity.

  • ALLOW

    Le groupe ou l'utilisateur est autorisé à effectuer l'opération spécifiée par l'actionID.

  • DENY

    Le groupe ou l'utilisateur n'est pas autorisé à effectuer l'opération spécifiée par l'actionID.

Image de dveloppement Notes

Les entrées de contrôle d'accès sont des mécanismes de sécurité qui déterminent les opérations qu'un utilisateur, un groupe, un service ou un ordinateur est autorisé à effectuer sur un ordinateur ou un serveur.

Image de dveloppement Sécurité

Pour utiliser la commande /a- de l'utilitaire en ligne de commande TFSSecurity, vous devez être administrateur Team Foundation Server sur la couche Application locale. Exécutez cette commande sur l'ordinateur de couche Application locale.

Image de développement Voir aussi

Tâches

Comment : créer un groupe de niveau serveur

Autres ressources

Commandes de l'utilitaire en ligne de commande TFSSecurity
Groupes de projets d'équipe
Groupes par défaut


/acl, commande

 Image de liste droulante Image de pointage sur liste droulante Image de rduction Image de dveloppement Image Rduire tout Image Dvelopper tout Copier l'image de pointage
Visual Studio Team System
/acl, commande
Voir aussi
Image Rduire tout Image de liste droulante

Utilisez /acl pour afficher la liste de vérification d'accès efficaces pour un objet particulier.

TFSSecurity /acl objectID

Paramètres

Argument | Description
objectID | URI de l'objet de contrôle d'accès.

Image de dveloppement Notes

Les entrées de contrôle d'accès sont des mécanismes de sécurité qui déterminent les opérations qu'un utilisateur, un groupe, un service ou un ordinateur est autorisé à effectuer sur un ordinateur ou un serveur.

Image de dveloppement Sécurité

Pour utiliser la commande /acl de l'utilitaire en ligne de commande TFSSecurity, vous devez être administrateur Team Foundation Server sur la couche Application locale. Exécutez cette commande sur l'ordinateur de couche Application locale.

Image de développement Voir aussi

Tâches

Comment : créer un groupe de niveau serveur

Autres ressources

Commandes de l'utilitaire en ligne de commande TFSSecurity
Groupes de projets d'équipe
Groupes par défaut


TFSDeleteProject, commande

 Image de liste droulante Image de pointage sur liste droulante Image de rduction Image de dveloppement Image Rduire tout Image Dvelopper tout Copier l'image de pointage
Visual Studio Team System
TFSDeleteProject, commande
Voir aussi Exemple
Image Rduire tout Image de liste droulante

Utilisez TFSDeleteProject pour supprimer un projet d'équipe Team System lorsque le projet n'est plus nécessaire sur le serveur Team Foundation Server.

Attention Attention

La suppression d'un projet d'équipe ne peut pas être annulée. Toutes les données de projet d'équipe sur le serveur Team Foundation Server, le serveur Windows SharePoint Services, le serveur de contrôle de code source Team Foundation et le serveur SQL Reporting Services seront supprimées. Les données de projet d'équipe stockées dans l'entrepôt de données ne seront pas supprimées.

L'utilitaire en ligne de commande TFSDeleteProject est situé dans <lecteur>\Program Files\Visual Studio8\Common7\IDE.

TFSDeleteproject [/q] [/TeamFoundationServer:servername] [/force] project name

Paramètres

Argument | Description
project name | Nom du projet. Utilisez des guillemets si le nom comporte des espaces.
servername | Nom du serveur. Utilisez des guillemets si le nom comporte des espaces.
Option | Description
/q | Utilisez le mode silencieux. Ne demandez pas à l'utilisateur de confirmer.
/server: servername | Nom du serveur Team Foundation Server sur lequel le projet d'équipe est situé. Ce nom est requis dans les environnements multiserveurs.
/force | Le programme doit poursuivre même si certaines parties ne peuvent pas être supprimées.

Image de dveloppement Notes

Vous devez être connectés à Team Foundation Server avant d'utiliser TFSDeleteProject.

Image de dveloppement Exemple

La commande suivante supprime le projet d'équipe StoreFront du serveur Team Foundation AdventureWorks1 et de Team Explorer.
Image Copier le code Copier le code
c:\Program Files\Microsoft Visual Studio 8\VC> TFSDeleteProject /AdventureWorks1 StoreFront

Image de dveloppement Sécurité

Pour supprimer un projet d'équipe, vous devez être administrateur global ou TFS du serveur Team Foundation Server, ou administrateur du projet d'équipe que vous supprimez.

Image de développement Voir aussi

Tâches

Comment : ajouter ou supprimer un projet d'équipe

Autres ressources

Gestion des autorisations


TFSReg, commande

 Image de liste droulante Image de pointage sur liste droulante Image de rduction Image de dveloppement Image Rduire tout Image Dvelopper tout Copier l'image de pointage
Visual Studio Team System
TFSReg, commande
Voir aussi
Image Rduire tout Image de liste droulante

Utilisez l'utilitaire TFSReg pour modifier, mettre à jour ou supprimer toutes les entrées dans le fichier de configuration de connexions dans Team Foundation Server.

L'utilitaire en ligne de commande TFSReg est situé dans <drive>:\Program Files\Microsoft Visual Studio 2005 Team Foundation Server\Tools.

TFSReg [/D] ConfigFile TFSIntegrationDBServer TFSIntegrationDBName

Paramètres

Argument | Description
ConfigFile | Nom du fichier de configuration de connexions.
TFSIntegrationDBServer | Nom de la base de données de la couche Données.
TFSIntegrationDBName | Nom de la base de données d'intégration.
Option | Description
/D | Cette option est utilisée pour supprimer toutes les entrées dans le fichier de configuration de connexions.

Image de dveloppement Notes

Pendant l'installation, les données d'inscription doivent être incluses dans la base de données d'intégration Team Foundation Server. Pour ce faire, utilisez l'utilitaire en ligne de commande TFSReg pour prendre comme entrée un fichier XML et le fichier de configuration de connexions représentant les données d'inscription.

Les entrées d'inscription peuvent être ajoutées séparément ou toutes à la fois. TFSReg prend en charge les opérations de mise à jour et de suppression. Le comportement par défaut est la mise à jour des entrées d'inscription. L'option /D supprime les entrées dans le fichier de configuration.

Vous pouvez également utiliser le fichier de configuration de connexions pour configurer une extension vers le serveur Team Foundation Server. Par exemple, vous pourriez ajouter des informations pour augmenter les fonctions du Gestionnaire des impératifs Team Project.

Pour obtenir le fichier de configuration de connexions, vous devez appeler les services Web d'inscription et passer la valeur null à la méthode GetRegistrationEntries, comme représenté dans l'exemple de code suivant.

C# Image Copier le code Copier le code
using Microsoft.TeamFoundation.CoreServices.Services;
using Microsoft.TeamFoundation.CoreServices.Proxy;

{
    CoreServicesProxyServices bisServices =
 newCpreServicesProxyServices();
    string domain = "DomainCallerIsInterestedIn";
    IRegistration regProxy =
    (IRegistration) bisServices.GetProxy(domain,
 typeof(IRegistration));
    RegistrationEntry[] regEntries =
 regProxy.GetRegistrationEntries(null);
}

Voici un exemple de fichier de configuration de connexions.

Image Copier le code Copier le code
<?xml version="1.0" encoding="utf-8" ?>
<RegistrationEntries>
  <RegistrationEntry>
    <Type>vstfs</Type>
    <ChangeType>NoChange</ChangeType>
    <ServiceInterfaces>
      <ServiceInterface>
        <Name>CommonStructure</Name>
        <Url>/Services/v1.0/CommonStructureService.asmx</Url>
    </ServiceInterface>
    <ServiceInterface>
      <Name>Eventing</Name>
      <Url>/Services/v1.0/EventService.asmx</Url>
    </ServiceInterface>
    <ServiceInterface>
      <Name>GroupSecurity</Name>
      <Url>/Services/v1.0/GroupSecurityService.asmx</Url>
    </ServiceInterface>
    <ServiceInterface>
      <Name>Authorization</Name>
      <Url>/Services/v1.0/AuthorizationService.asmx</Url>
    </ServiceInterface>
    <ServiceInterface>
      <Name>ProcessTemplate</Name>
      <Url>/Services/v1.0/ProcessTemplate.asmx</Url>
    </ServiceInterface>
    <ServiceInterface>
      <Name>RegistrationService</Name>
      <Url>/Services/v1.0/Registration.asmx</Url>
    </ServiceInterface>
    <ServiceInterface>
      <Name>ServerStatus</Name>
      <Url>/Services/v1.0/ServerStatus.asmx</Url>
    </ServiceInterface>
    <ServiceInterface>
      <Name>IProjectMaintenance</Name>
      <Url>/Services/v1.0/ProjectMaintenance.asmx</Url>
    </ServiceInterface>
    <ServiceInterface>
      <Name>ITeamSystemTask</Name>
      <Url>/Warehouse/v1.0/WarehouseController.asmx</Url>
    </ServiceInterface>
    <ServiceInterface>
      <Name>Warehouse</Name>
      <Url>/Warehouse/v1.0/WarehouseController.asmx</Url>
    </ServiceInterface>
  </ServiceInterfaces>
  <RegistrationExtendedAttributes>
    <RegistrationExtendedAttribute>
      <Name>ArtifactUriRoot</Name>
      <Value />
    </RegistrationExtendedAttribute>
    <RegistrationExtendedAttribute>
      <Name>ATMachineName</Name>
      <Value>ATMACHINE</Value>
    </RegistrationExtendedAttribute>
  </RegistrationExtendedAttributes>
  <Databases>
    <Database>
      <Name>BIS DB</Name>
      <DatabaseName>IntegrationDB</DatabaseName>
      <SQLServerName>DTMachineName</SQLServerName>
      <ConnectionString />
    </Database>
    <Database>
      <Name>BISDW DB</Name>
      <DatabaseName>ReportingDB</DatabaseName>
      <SQLServerName>DTMachineName</SQLServerName>
      <ConnectionString />
    </Database>
  </Databases>
  <EventTypes>
    <EventType>
      <Name>BranchMovedEvent</Name>
      <Schema />
    </EventType>
    <EventType>
      <Name>NodeCreatedEvent</Name>
      <Schema />
    </EventType>
    <EventType>
      <Name>NodePropertiesChangedEvent</Name>
      <Schema />
    </EventType>
    <EventType>
      <Name>NodeRenamedEvent</Name>
      <Schema />
    </EventType>
    <EventType>
      <Name>NodesDeletedEvent</Name>
      <Schema />
    </EventType>
    <EventType>
      <Name>ProjectCreatedEvent</Name>
      <Schema />
    </EventType>
    <EventType>
      <Name>ProjectDeletedEvent</Name>
      <Schema />
    </EventType>
  </EventTypes>
</RegistrationEntry>
<RegistrationEntry>
  <Type>Reports</Type>
  <ChangeType>NoChange</ChangeType>
  <ServiceInterfaces>
    <ServiceInterface>
      <Name>ReportsService</Name>
      <Url>http://DTMachineName/ReportServer/ReportService.asmx</Url>
    </ServiceInterface>
    <ServiceInterface>
      <Name>BaseReportsUrl</Name>
      <Url>http://DTMachineName/Reports</Url>
    </ServiceInterface>
    <ServiceInterface>
      <Name>DataSourceServer</Name>
      <Url>/RosettaService/ReportService.asmx</Url>
    </ServiceInterface>
    <ArtifactTypes>
      <ArtifactType>
         <Name>Report</Name>
        <OutboundLinkTypes>
          <OutboundLinkType>
            <Name />
            <TargetArtifactTypeToolName />
            <TargetArtifactTypeName />
          </OutboundLinkType>
        </OutboundLinkTypes>
      </ArtifactType>
    </ArtifactTypes>
  </ServiceInterfaces>
</RegistrationEntry>
<RegistrationEntry>
  <Type>Wss</Type>
  <ChangeType>NoChange</ChangeType>
  <ServiceInterfaces>
    <ServiceInterface>
      <Name>WssAdminService</Name>
      <Url>http://ATMACHINE:4554/_vti_adm/admin.asmx</Url>
    </ServiceInterface>
    <ServiceInterface>
      <Name>BaseServerUrl</Name>
      <Url>http://ATMACHINE</Url>
    </ServiceInterface>
    <ServiceInterface>
      <Name>BaseSiteUrl</Name>
      <Url>http://ATMACHINE/sites</Url>
    </ServiceInterface>
    <ServiceInterface>
      <Name>BaseSiteUnc</Name>
      <Url>\\ATMACHINE\sites</Url>
    </ServiceInterface>
  </ServiceInterfaces>
  <ArtifactTypes>
    <ArtifactType>
      <Name>ProjectDoc</Name>
      <OutboundLinkTypes>
        <OutboundLinkType>
          <Name />
          <TargetArtifactTypeToolName />
          <TargetArtifactTypeName />
        </OutboundLinkType>
      </OutboundLinkTypes>
    </ArtifactType>
  </ArtifactTypes>
 </RegistrationEntry>
</RegistrationEntries>

Image de dveloppement Exemples

L'exemple suivant supprime "MyConfigFile".

Image Copier le code Copier le code
TFSReg [/D] MyConfigFile MyDataTier IntegrationDB

Image de dveloppement Sécurité

Pour utiliser l'utilitaire en ligne de commande TFSReg, vous devez être administrateur global pour le serveur Team Foundation Server, ou administrateur de projet pour le projet d'équipe.

Image de développement Voir aussi

Autres ressources

Utilisation des outils de ligne de commande Team Foundation Server


TFSFieldMapping

 Image de liste droulante Image de pointage sur liste droulante Image de rduction Image de dveloppement Image Rduire tout Image Dvelopper tout Copier l'image de pointage
Visual Studio Team System
TFSFieldMapping
Voir aussi Exemple
Image Rduire tout Image de liste droulante

Utilisez l'utilitaire TFSFieldMapping pour modifier ou personnaliser le fichier XML de mappage de projet après la création d'un projet d'équipe. Par exemple, vous pouvez créer des types d'éléments de travail ou modifier les types existants pour disposer de nouveaux attributs.

L'utilitaire en ligne de commande TFSFieldMapping est situé dans <lecteur>\Program Files\Visual Studio8\Common7\IDE.

TFSFieldMapping upload | download serverurl projectname filepath

Paramètres

Argument | Description
serverurl | URL du serveur.
projectname | Nom du projet d'équipe.
Filepath | Nom et chemin d'accès du fichier de mappage.
Commande | Description
Upload | download | Téléchargez ou transférez le fichier de mappage de champ.

Image de dveloppement Notes

Les étapes à suivre pour personnaliser le fichier de mappage de champ sont les suivantes :

  1. Téléchargez le fichier de mappage de champ en utilisant l'utilitaire en ligne de commande TFSFieldMapping.

  2. Modifiez le fichier de mappage de champ en modifiant les champs existants ou en ajoutant des champs personnalisés et des attributs. Pour plus d'informations, consultez Comment : modifier la façon dont les champs sont mappés à Microsoft Project

  3. Transférez le fichier de mappage de champ en utilisant l'utilitaire en ligne de commande TFSFieldMapping.

Image de dveloppement Exemple

La commande suivante indique à l'utilitaire TFSFieldMapping de télécharger le fichier de mappage, MappingFile.xml.
Image Copier le code Copier le code
TFSFieldMapping download http://TeamFoundationServer AdventureWorks C:\MappingFile.xml

Dans le code précédent :

  • http://TeamFoundationServer est l'URL du serveur.

  • AdventureWorks est le nom du projet d'équipe.

  • C:\MappingFile.xml est le nom et l'emplacement du fichier de mappage de champ.

Image de dveloppement Sécurité

Pour utiliser l'utilitaire TFSFieldMapping, vous devez être administrateur global ou TFS pour le serveur Team Foundation Server, ou administrateur de projet pour le projet d'équipe.

Image de développement Voir aussi

Tâches

Comment : modifier la façon dont les champs sont mappés à Microsoft Project

Référence

Mappages de champs dans Microsoft Project

Autres ressources

Gestion des autorisations
Utilisation des outils de ligne de commande Team Foundation Server


witimport

 Image de liste droulante Image de pointage sur liste droulante Image de rduction Image de dveloppement Image Rduire tout Image Dvelopper tout Copier l'image de pointage
Visual Studio Team System
witimport
Voir aussi
Image Rduire tout Image de liste droulante

Utilisez la commande witimport pour valider et importer un type d'élément de travail d'un fichier XML vers un projet d'équipe sur un serveur Team Foundation Server. Si vous essayez d'importer un type d'élément de travail qui déjà existe dans le projet d'équipe spécifié, une invite d'avertissement demande si vous souhaitez remplacer le type d'élément de travail existant.

Vous pouvez valider un type d'élément de travail sans l'importer en utilisant l'option /v.

L'utilitaire en ligne de commande witimport est situé dans <lecteur>\Program Files\Visual Studio8\Common7\IDE.

witimport /f filename /t tfs /p teamproject [/v] [/e encodingname]

Paramètres

Paramètre | Description
/f filename | Fichier de définition XML qui contient le type d'élément de travail à importer.
/t tfs | Nom d'ordinateur du serveur Team Foundation Server vers lequel le type d'élément de travail sera importé ou URL d'un serveur Team Foundation Server complètement spécifiée.
/p teamproject | Projet d'équipe vers lequel le type d'élément de travail sera importé. Ce projet d'équipe doit exister sur le serveur Team Foundation Server spécifié par tfs.
/e Encodingname | Nom d'un codage .NET Framework 2.0. Le codage spécifié sera utilisé pour importer le type d'élément de travail XML. Si cet argument n'est pas spécifié, witimport utilise par défaut le codage UTF-8.
/? | Affiche l'aide contextuelle de witimport.
Option | Description
/v | Validez le fichier XML sans importer.

Image de dveloppement Exemples

Dans cet exemple, la commande lit le fichier myworkitem.xml, valide le type d'élément de travail qu'il contient et importe l'élément de travail validé vers le projet d'équipe AdventureWorks sur le serveur AdventureWorksServer de Team Foundation. Cet exemple importe le type d'élément de travail en utilisant le codage UTF-8 par défaut.

Image Copier le code Copier le code
witimport /f myworkitem.xml /t AdventureWorksServer /p AdventureWorks

L'exemple suivant affiche une commande qui utilise une URL au lieu d'un nom de serveur Team Foundation Server. Cet exemple importe le type d'élément de travail en utilisant le codage UTF-8 par défaut.

Image Copier le code Copier le code
witimport /f myworkitem.xml /t http://TFS:8080/bis/registration.asmx /p AdventureWorks

L'exemple suivant valide et importe l'élément de travail en utilisant le codage Unicode (utf-7).

Image Copier le code Copier le code
witimport /f myworkitem.xml /t AdventureWorksServer /p AdventureWorks /e utf-7

L'exemple suivant valide le type d'élément de travail dans le fichier myworkitem.xml sans l'importer. Cet exemple valide le type d'élément de travail en utilisant le codage UTF-8 par défaut.

Image Copier le code Copier le code
witimport /f myworkitem.xml /t AdventureWorksServer /p AdventureWorks /v

Image de développement Voir aussi

Référence

witexport


witexport

 Image de liste droulante Image de pointage sur liste droulante Image de rduction Image de dveloppement Image Rduire tout Image Dvelopper tout Copier l'image de pointage
Visual Studio Team System
witexport
Voir aussi
Image Rduire tout Image de liste droulante

Utilisez la commande witexport pour exporter une définition XML pour un type d'élément de travail à partir d'un serveur Team Foundation Server. Vous pouvez également utiliser cette commande pour imprimer une définition XML à afficher.

L'utilitaire en ligne de commande witexport est situé dans <lecteur>\Program Files\Visual Studio8\Common7\IDE.

witexport [/f filename] /t tfs /p teamproject /n witname [/exportgloballists] [/e encodingname]

Paramètres

Paramètre | Description
/f filename | Le fichier de destination XML dans lequel le type d'élément de travail sera exporté. Si vous omettez ce paramètre, le type d'élément de travail est exporté à l'affichage.
/t tfs | Le nom d'ordinateur du serveur Team Foundation Server à partir duquel le type d'élément de travail sera exporté, ou une URL complètement spécifiée pour le serveur Team Foundation Server.
/p teamproject | Le projet d'équipe à partir duquel le type d'élément de travail sera exporté. Ce projet d'équipe doit exister sur le serveur Team Foundation Server spécifié par tfs.
/n witname | Le nom du type d'élément de travail à exporter. Ce type doit exister dans le projet d'équipe teamproject sur tfs de Team Foundation Server.
/e Encodingname | Nom d'un codage .NET Framework 2.0. Le codage spécifié sera utilisé pour exporter le type d'élément de travail XML. Si cet argument n'est pas spécifié, witimport utilise par défaut le codage UTF-8.
/? | Affiche l'aide contextuelle de witexport.
Option | Description
/exportgloballists | Exporte les définitions des listes globales référencées par le type d'élément de travail.

Image de dveloppement Exemples

La commande de cet exemple exporte le type élément de travail myworkitem à partir du projet d'équipe AdventureWorks sur le AdventureWorksServer de Team Foundation vers le fichier myworkitems.xml. Cet exemple exporte le type d'élément de travail en utilisant le codage UTF-8 par défaut.

Image Copier le code Copier le code
witexport /f myworkitems.xml /t AdventureWorksServer /p AdventureWorks /n myworkitem

L'exemple suivant montre comment utiliser une URL à la place d'un nom de serveur Team Foundation Server. Cet exemple exporte le type d'élément de travail en utilisant le codage UTF-8 par défaut.

Image Copier le code Copier le code
witexport /f myworkitems.xml /t http://TFS:8080/bis/registration.asmx /p AdventureWorks /n myworkitem

L'exemple suivant exporte l'élément de travail en utilisant le codage Unicode (utf-7).

Image Copier le code Copier le code
witexport /f myworkitems.xml /t AdventureWorksServer /p AdventureWorks /n myworkitem /exportgloballists

L'exemple suivant exporte le type d'élément de travail et les listes globales référencées. Cet exemple exporte le type d'élément de travail en utilisant le codage UTF-8 par défaut.

Image Copier le code Copier le code
witexport /f myworkitems.xml /t http://TFS:8080/bis/registration.asmx /p AdventureWorks /n myworkitem

L'exemple suivant affiche le type d'élément de travail au lieu de l'exporter vers un fichier. Cet exemple exporte le type d'élément de travail en utilisant le codage UTF-8 par défaut.

Image Copier le code Copier le code
witexport /t http://TFS:8080/bis/registration.asmx /p AdventureWorks /n myworkitem

Image de développement Voir aussi

Référence

witimport


witfields

 Image de liste droulante Image de pointage sur liste droulante Image de rduction Image de dveloppement Image Rduire tout Image Dvelopper tout Copier l'image de pointage
Visual Studio Team System
witfields
Voir aussi
Image Rduire tout Image de liste droulante

Utilisez la commande witfields pour administrer les champs des types d'éléments de travail de Team Foundation Server.

Remarque Remarque

Il est possible que les administrateurs du projet d'équipe ne soient pas en mesure d'administrer tous les champs de Team Foundation Server.

L'utilitaire en ligne de commande witfields est situé dans <lecteur>\Program Files\Visual Studio8\Common7\IDE.

witfields view /s:tfs [refname | /unused]
witfields rename /s:tfs refname newname
witfields report /s:tfs refname {dimension | detail | measure | disable}[:sum | :count | :distinctcount | :avg | :min | :max]
witfields delete /s:tfs refname
witfields rebuildcache /s:tfs
witfields help

Paramètres

Paramètre | Description
/s: tfs | Nom de l'ordinateur du serveur Team Foundation Server sur lequel afficher ou modifier les champs ou URL complètement spécifiée d'un serveur Team Foundation Server.
refname | Nom de la référence du champ sur lequel exécuter la commande.
/unused | Affiche tous les champs qui ne sont pas utilisés par les types d'un élément de travail sur le serveur Team Foundation Server.
newname | Nouveau nom convivial du champ.
dimension | Type de reportabilité utilisé pour les champs de type Integer, String ou DateTime. Aucun attribut facultatif ne doit être spécifié.
detail | Type de reportabilité utilisé pour les champs de type Integer, Double, String ou DateTime. Aucun attribut facultatif ne doit être spécifié.
measure | Type de reportabilité utilisé pour les champs de type Integer et Double. L'agrégation par défaut est la somme.
disable | Non pris en charge dans cette version.
sum | Non pris en charge dans cette version.
count | Non pris en charge dans cette version.
distinctcount | Non pris en charge dans cette version.
avg | Non pris en charge dans cette version.
min | Non pris en charge dans cette version.
max | Non pris en charge dans cette version.
help | Affiche l'aide contextuelle des witfields.
/? | Affiche l'aide contextuelle des witfields.

Image de dveloppement Exemples

Dans cet exemple, la commande affiche des informations relatives à tous les champs du serveur AdventureWorksServer de Team Foundation Server.

Image Copier le code Copier le code
witfields view /s:AdventureWorksServer

L'exemple suivant décrit une commande qui affiche les informations relatives au champ pour le champ AdventureWorks.Field spécifié.

Image Copier le code Copier le code
witfields view /s:AdventureWorksServer AdventureWorks.Field

L'exemple suivant illustre tous les champs qui ne sont pas utilisés sur le serveur Adventure Works de Team Foundation Server.

Image Copier le code Copier le code
witfields view /s:AdventureWorksServer /unused

Cet exemple remplace le nom convivial du champ référencé AdventureWorks.Field par NewFieldName.

Image Copier le code Copier le code
witfields rename /s:AdventureWorksServer AdventureWorks.Field NewFieldName

La commande suivante indique comment attribuer le type de reportabilité dimension au champ de type DateTime AdventureWorks.Field.

Image Copier le code Copier le code
witfields report /s:AdventureWorksServer AdventureWorks.Field dimension

Les données de ce champ rentrent dans l'entrepôt et le cube afin qu'elles puissent être utilisées pour filtrer des rapports.

La commande suivante indique comment attribuer le type de reportabilité detail au champ de type Integer AdventureWorks.Field. Les données de ce champ vont dans l'entrepôt, mais pas dans le cube.

Image Copier le code Copier le code
witfields report /s:AdventureWorksServer AdventureWorks.Field detail

La commande suivante attribue le type de reportabilité measure au champ de type Double AdventureWorks.Field. Toutes les mesures sont agrégées par somme.

Image Copier le code Copier le code
witfields report /s:AdventureWorksServer AdventureWorks.Field measure

La commande suivante supprime le champ AdventureWorks.Field du serveur AdventureWorksServer de Team Foundation Server.

Image Copier le code Copier le code
witfields delete /s:AdventureWorksServer AdventureWorks.Field

La commande suivante rend non valide le cache des métadonnées pour tous les clients sur le serveur AdventureWorksServer de Team Foundation Server. Les caches des clients seront mis à jour lors de la prochaine connexion au serveur.

Image Copier le code Copier le code
witfields rebuildcache /s:AdventureWorksServer

Les commandes suivantes affichent l'aide contextuelle de l'utilitaire en ligne de commande witfields.

Image Copier le code Copier le code
witfields help
witfields /?

Image de développement Voir aussi

Référence

glexport
witimport
witexport

Autres ressources

Définition des champs des types d'éléments de travail


glimport

 Image de liste droulante Image de pointage sur liste droulante Image de rduction Image de dveloppement Image Rduire tout Image Dvelopper tout Copier l'image de pointage
Visual Studio Team System
glimport
Voir aussi
Image Rduire tout Image de liste droulante

Utilisez la commande glimport pour valider et importer des listes globales d'un fichier XML vers un projet d'équipe sur Team Foundation Server. Si vous essayez d'importer une liste globale qui existe déjà dans le projet d'équipe spécifié, une invite d'avertissement vous demande si vous souhaitez remplacer la liste globale existante. Si aucune liste globale n'existe déjà, une nouvelle liste sera créée.

L'utilitaire en ligne de commande glimport est situé dans <lecteur>\Program Files\Visual Studio8\Common7\IDE.

glimport /f filename /t tfs [/e encodingname]

Paramètres

Paramètre | Description
/f filename | Le fichier de définition XML des listes globales de travail à importer.
/t tfs | Le nom d'ordinateur du serveur Team Foundation Server à partir duquel les listes globales seront importées ou une URL complètement spécifiée pour un serveur Team Foundation Server.
/e encodingname | Nom d'un codage .NET Framework 2.0. Le codage spécifié sera utilisé pour importer les listes globales XML. Si cet argument n'est pas spécifié, glimport utilise par défaut le codage UTF-8.
/? | Affiche l'aide contextuelle de la commande glimport.

Image de dveloppement Exemples

La commande de cet exemple permet de lire le fichier mygloballists.xml, de valider les listes globales qu'il contient et d'importer les listes globales validées vers le serveur AdventureWorksServer de Team Foundation Server. Cet exemple importe les listes globales à l'aide du codage UTF-8 par défaut.

Image Copier le code Copier le code
glimport /f mygloballists.xml /t AdventureWorksServer

L'exemple suivant affiche une commande qui utilise une URL au lieu d'un nom de serveur Team Foundation Server. Cet exemple importe les listes globales à l'aide du codage UTF-8 par défaut et suppose que la configuration du port par défaut est 8080.

Image Copier le code Copier le code
glimport /f mygloballists.xml /t http://TFS:8080

L'exemple suivant valide et importe les listes globales à l'aide du codage Unicode (utf-7).

Image Copier le code Copier le code
glimport /f mygloballists.xml /t AdventureWorksServer /e utf-7

Image de développement Voir aussi

Référence

glexport
witimport
witexport
witfields


glexport

 Image de liste droulante Image de pointage sur liste droulante Image de rduction Image de dveloppement Image Rduire tout Image Dvelopper tout Copier l'image de pointage
Visual Studio Team System
glexport
Voir aussi
Image Rduire tout Image de liste droulante

Utilisez la commande glexport pour exporter une définition XML pour les listes globales d'un serveur Team Foundation Server. Vous pouvez également utiliser cette commande pour imprimer une définition XML à afficher.

L'utilitaire en ligne de commande glexport est situé dans <lecteur>\Program Files\Visual Studio8\Common7\IDE.

glexport [/f filename] /t tfs [/e encodingname]

Paramètres

Paramètre | Description
/f filename | Le fichier de destination XML vers lequel toutes les listes globales sur Team Foundation Server seront exportées. Si vous omettez ce paramètre, le XML est exporté à l'affichage.
/t tfs | Le nom d'ordinateur du serveur Team Foundation Server à partir duquel les listes globales seront importées ou une URL complètement spécifiée pour le serveur Team Foundation Server.
/e encodingname | Nom d'un codage .NET Framework 2.0. Le codage spécifié sera utilisé pour exporter les listes globales XML. Si cet argument n'est pas spécifié, glexport utilise par défaut le codage UTF-8.
/? | Affiche l'aide contextuelle de la commande glexport.

Image de dveloppement Exemples

La commande dans cet exemple exporte les listes globales mygloballists du serveur AdventureWorksServer de Team Foundation Server vers le fichier mygloballists.xml. Cet exemple exporte les listes globales à l'aide du codage UTF-8 par défaut.

Image Copier le code Copier le code
glexport /f mygloballists.xml /t AdventureWorksServer

L'exemple suivant montre comment utiliser une URL à la place d'un nom de serveur Team Foundation Server. Cet exemple exporte les listes globales à l'aide du codage UTF-8 par défaut et suppose que la configuration du port par défaut est 8080.

Image Copier le code Copier le code
glexport /f mygloballists.xml /t http://TFS:8080

L'exemple suivant exporte les listes globales en utilisant le codage Unicode (utf-7).

Image Copier le code Copier le code
glexport /f mygloballists.xml /t AdventureWorksServer /e utf-7

L'exemple suivant affiche les listes globales au lieu de les exporter vers un fichier. Cet exemple exporte les listes globales à l'aide du codage UTF-8 par défaut et suppose que la configuration du port par défaut est 8080.

Image Copier le code Copier le code
glexport /t http://TFS:8080

Image de développement Voir aussi

Référence

glimport
witimport
witexport
witfields


SetupWarehouse

 Image de liste droulante Image de pointage sur liste droulante Image de rduction Image de dveloppement Image Rduire tout Image Dvelopper tout Copier l'image de pointage
Visual Studio Team System
SetupWarehouse
Voir aussi Exemple
Image Rduire tout Image de liste droulante

Utilisez SetupWarehouse pour régénérer le traitement analytique en ligne (OLAP) ou les bases de données relationnelles.

L'utilitaire en ligne de commande SetupWarehouse est situé dans <drive>:\Program Files\Microsoft Visual Studio 2005 Team Foundation Server\Tools.

SetupWarehouse [-v] [-o] -s ServerName -d Database -c ConfigFile -a AccountName -ra DataReaderAccountName [-l LogFile] [-mturl MidTierUrl] [-edt TeamBuildDbName]

Paramètres

Option / Argument | Description
-v | Facultatif. Cette option fournit la sortie des commentaires. Si l'option -l est spécifiée, la sortie est écrite dans le fichier journal.
-o | Facultatif. Lorsque cette option est utilisée, seule la base de données OLAP est créée.
-s ServerName | Requis. Nom du serveur.
-d Database | Requis. Le nom de la base de données d'entrepôt.
-c ConfigFile | Requis. Le fichier XML de configuration.
-a AccountName | Requis. Le nom du compte d'accès.
-ra DataReaderAccountName | Requis. Le nom du compte de lecteur.
-l LogFile | Facultatif. Fichier journal pour la sortie.
-mturl MidTierUrl | Facultatif. L'URL du domaine Team Foundation Server, par exemple, http://machine1:8080.
-edt TeamBuildDbName | Facultatif. Le nom de la base de données Team Foundation Build.

Image de dveloppement Notes

L'entrepôt Team Foundation Server dispose d'une base de données relationnelle et d'une base de données OLAP. Setupwarehouse, l'outil d'installation de l'entrepôt du serveur Team Foundation permet de régénérer la base de données OLAP ou de régénérer les deux bases de données. Cet outil est utile pour les scénarios de sauvegarde/restauration, par exemple, la récupération d'urgence, le déplacement de serveurs, etc. Pour plus d'informations, consultez Comment : restaurer les données de Team Foundation Server.

Image de dveloppement Exemple

L'exécution de la commande suivante régénère le cube de données Analysis Services à partir de la base de données TFSWarehouse sous-jacente.
Image Copier le code Copier le code
      > setupwarehouse -o -s ServerName -d TfsWarehouse -c warehouseschema.xml -ra TFSReportAccount -a TFSServiceAccount

Image de développement Voir aussi

Référence

Syntaxe de ligne de commande

Autres ressources

Gestion des données
Utilisation des outils de ligne de commande Team Foundation Server


Administration du contrôle de code source Team Foundation

Administration du contrôle de code source Team Foundation
DropDown image

Les rubriques contenues dans cette section décrivent comment accomplir des tâches administratives de contrôle de code source communes à l'aide de Team Foundation.

Dans cette section

Configuration des paramètres de contrôle de code source

Contient des informations d'administration sur la configuration du contrôle de code source dans Visual Studio, l'association de type de fichier, la configuration de stratégie d'archivage et les paramètres d'extraction.

Comment : contrôler l'accès au contrôle de code source Team Foundation

Explique les étapes requises pour ajouter des utilisateurs et des groupes au contrôle de code source Team Foundation.

Comment : supprimer l'accès aux fichiers du contrôle de code source

Décrit comment supprimer l'accès à un fichier sous contrôle de code source.

Référence

Référence de la ligne de commande du contrôle de code source Team Foundation

Rubriques connexes

Procédures pas à pas relatives au contrôle de code source Team Foundation

Répertorie les procédures pas à pas qui explorent l'utilisation du contrôle de code source, la personnalisation d'un archivage du contrôle de code source et l'utilisation du contrôle de code source à partir de la ligne de commande.

Utilisation du contrôle de code source Team Foundation

Répertorie des rubriques applicables aux utilisateurs du contrôle de code source Team Foundation.

Procédures pas à pas relatives à l'administration de Team Foundation Server

Indique comment installer et administrer votre serveur Team Foundation Server.

Voir aussi

Autres ressources

Documentation Team Foundation


Configuration des paramètres de contrôle de code source

Configuration des paramètres de contrôle de code source
DropDown image

Le contrôle de code source Team Foundation peut être personnalisé par les administrateurs pour satisfaire les besoins spécifiques d'une équipe. Les options configurables décrites dans cette section sont les suivantes :

Client :

  • Personnalisation des types de fichier associés au contrôle de code source Team Foundation.

Serveur :

  • Personnalisation des notes d'archivage et des stratégies d'archivage.

  • Personnalisation des paramètres d'extraction.

Dans cette section

Comment : configurer Visual Studio avec le contrôle de code source Team Foundation

Décrit les étapes permettant de configurer le contrôle de code source Team Foundation dans Visual Studio.

Types de fichiers

Décrit comment ajouter, modifier et supprimer des extensions de type de fichier associées aux archivages de contrôle de code source Team Foundation.

Référence

Référence de la ligne de commande du contrôle de code source Team Foundation

Voir aussi

Tâches

Procédure pas à pas : personnalisation des stratégies et notes d'archivage

Autres ressources

Administration du contrôle de code source Team Foundation
Utilisation du contrôle de code source Team Foundation


Comment : configurer Visual Studio avec le contrôle de code source Team Foundation

Comment : configurer Visual Studio avec le contrôle de code source Team Foundation
Voir aussi

Pour pouvoir utiliser le contrôle de code source Team Foundation, vous devez configurer Visual Studio. La procédure suivante illustre la configuration de Visual Studio pour utiliser le contrôle de code source Team Foundation.

Pour configurer Visual Studio afin d'utiliser le contrôle de code source Team Foundation

  1. Dans le menu Outils, cliquez sur Options.

  2. Dans la boîte de dialogue Options, recherchez Contrôle de code source, développez-le, puis cliquez sur Sélection du plug-in.

  3. Dans la zone de liste Plug-in de contrôle de code source actif, cliquez sur Visual Studio Team Foundation Server.

  4. Dans le nœud Contrôle de code source, cliquez sur Environnement.

  5. Dans les paramètres de l'environnement du contrôle de code source, cliquez sur l'une des options suivantes :

    • Team Foundation Utilise par défaut les paramètres de Visual Team Foundation.

    • Développeur indépendant Utilise les paramètres appropriés pour un développeur indépendant qui ne fait pas partie d'une équipe.

    • Personnalisé Utilise des paramètres personnalisés.

    Selon l'option que vous sélectionnez, les options suivantes sont disponibles :

    • Tout obtenir lors de l'ouverture d'une solution ou d'un projet

    • Tout archiver lors de la fermeture d'une solution ou d'un projet

    • Afficher la commande d'extraction en mode silencieux dans les menus

    • Conserver les éléments en extraction lors de l'archivage

  6. Sous la section Éléments archivés, dans la zone de liste Enregistrement, sélectionnez l'action que vous souhaitez effectuer lors de l'enregistrement des fichiers et des dossiers :

    • Extraire automatiquement (par défaut)

    • Demander l'extraction

    • Enregistrer sous

  7. Dans la zone de liste Modification, cliquez sur l'action que vous souhaitez effectuer :

    • Demander l'extraction

    • Demander des extractions exclusives

    • Extraire automatiquement (par défaut)

    • Ne rien faire

  8. Le cas échéant, sélectionnez l'option Permettre la modification des éléments archivés.

    Remarque Remarque

    Dans le nœud Contrôle de code source, l'option Visual Studio Team Foundation permet de configurer des types de fichier avec des outils de comparaison et de fusion. Ces instructions sont expliquées dans Comment : associer un type de fichier à un outil de fusion et Comment : associer un type de fichier à un outil de comparaison.

  9. Cliquez sur OK.

Sécurité

Aucune autorisation n'est requise pour effectuer cette tâche.

Voir aussi

Concepts

Introduction à Team Foundation pour les utilisateurs Visual SourceSafe

Autres ressources

Administration du contrôle de code source Team Foundation


Types de fichiers

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Types de fichiers
Voir aussi
Image de liste déroulante

Les définitions de types de fichiers vous permettent de personnaliser le traitement des fichiers à extensions spécifiques par le contrôle de code source Team Foundation . En définissant un type de fichier, vous pouvez empêcher les fichiers présentant certaines extensions d'être fusionnés et ainsi, empêcher plusieurs utilisateurs de les extraire en parallèle.

Remarque Remarque

Par défaut, la fusion et l'extraction multiple de fichiers sont activées.

Remarque Remarque

L'extraction multiple peut être désactivée au niveau du projet d'équipe.

Propriétés de types de fichiers

La définition d'un type de fichier de Team Foundation est composée de trois propriétés. La plus importante de ces propriétés, Extension de fichier, est l'identificateur unique d'un type de fichier.

Propriété | Exemple
Nom | Fichier Visual Basic
Extension de fichier | .vb
Activer la fusion de fichier et l'extraction multiple | Oui

En tant qu'administrateur Team Foundation, vous pouvez spécifier que les fichiers de certains types, tels que les fichiers Microsoft Excel binaires (*.xls) pour lesquels aucun outil de fusion n'existe, ne peuvent pas être fusionnés si des conflits sont détectés et peuvent être extraits par seulement un utilisateur à la fois. Vous pouvez contrôler cela en sélectionnant Activer la fusion de fichier et l'extraction multiple dans la boîte de dialogue Modifier le type de fichier. Pour plus d'informations, consultez Comment : modifier une association de types de fichiers au contrôle de code source Team Foundation. Si un type de fichier n'existe pas pour une extension donnée, les fichiers portant cette extension peuvent être fusionnés.

Codages de fichiers

En plus de ces propriétés de types de fichiers de base, Team Foundation assure également le suivi du codage de fichier pour chaque fichier sur le serveur du contrôle de code source. Vous pouvez substituer le codage par défaut d'un fichier de la fenêtre Propriétés du contrôle de code source ouverte à partir de l'Explorateur du contrôle de code source ou à l'aide de l'interface de ligne de commande. Pour plus d'informations, consultez Comment : configurer le codage du fichier du contrôle de code source et Checkout, commande.

Dans cette section

Comment : ajouter une association de types de fichiers avec le contrôle de code source Team Foundation

Décrit les étapes à suivre pour associer des extensions de types de fichiers aux archivages de contrôle de code source Team Foundation.

Comment : modifier une association de types de fichiers au contrôle de code source Team Foundation

Décrit les étapes à suivre pour modifier les extensions de types de fichiers associées aux archivages de contrôle de code source Team Foundation.

Comment : supprimer un type de fichier associé au contrôle de code source Team Foundation

Explique les procédures à suivre pour supprimer une association d'extension de type de fichier aux archivages de contrôle de code source Team Foundation.

Voir aussi

Concepts

Comparaison de fichiers

Autres ressources

Résolution de conflits (contrôle de code source Team Foundation)


Comment : ajouter une association de types de fichiers avec le contrôle de code source Team Foundation

Comment : ajouter une association de types de fichiers avec le contrôle de code source Team Foundation
Voir aussi

Les définitions de type de fichier vous permettent de personnaliser le traitement des fichiers aux extensions spécifiques par le système de contrôle de code source. En définissant un type de fichier, vous contrôlez si les mots clés internes des fichiers présentant une extension donnée peuvent être développés lors d'un archivage et si plusieurs utilisateurs sont capables de modifier un fichier spécifique en parallèle. La procédure suivante montre comment ajouter une association d'extensions de types de fichiers dans le contrôle de code source.

Pour ajouter une association de types de fichiers au contrôle de code source

  1. Dans le menu Équipe, sélectionnez Paramètres Team Foundation Server, puis Types de fichiers du contrôle de code source. La boîte de dialogue Types de fichiers s'affiche avec les extensions de fichier actuellement associées au contrôle de code source.

  2. Cliquez sur Ajouter.

  3. Dans la zone de texte Nom de la boîte de dialogue Ajouter un type de fichier, tapez une description pour le nouveau type de fichier, par exemple Documents Word pour ajouter une association de fichiers document Microsoft Word au contrôle de code source.

  4. Dans la zone de texte Extension de fichier, tapez l'extension du type de fichier, par exemple, doc pour les fichiers document Microsoft Word.

  5. Activez éventuellement la case à cocher Activer l'extraction multiple (sélectionnée par défaut).

  6. Cliquez sur OK pour revenir à la boîte de dialogue Types de fichiers qui affiche à présent la nouvelle entrée.

    Remarque Conseil

    Vous pouvez spécifier plusieurs extensions de types de fichiers à associer à un seul nom, par exemple, vous pourriez ajouter dot au nom Document Word entré précédemment dans cette procédure.

Sécurité

Vous devez disposer de l'autorisation AdminConfiguration pour effectuer cette tâche. Pour plus d'informations, consultez Droits et autorisations relatifs à la sécurité du contrôle de code source.

Voir aussi

Tâches

Comment : configurer les paramètres d'extraction

Concepts

Types de fichiers

Autres ressources

Configuration des paramètres de contrôle de code source


Comment : modifier une association de types de fichiers au contrôle de code source Team Foundation

Comment : modifier une association de types de fichiers au contrôle de code source Team Foundation
Voir aussi

Les définitions de types de fichiers vous permettent de personnaliser le mode de traitement des fichiers possédant des extensions spécifiques dans le système de contrôle de code source Team Foundation. En définissant un type de fichier, vous contrôlez si les mots clés internes des fichiers possédant une extension particulière peuvent être développés pendant un archivage et si plusieurs utilisateurs peuvent modifier un fichier spécifique en parallèle. La procédure suivante montre comment modifier une association d'extension de type de fichier dans le contrôle de code source.

Pour modifier une association de type de fichier dans le contrôle de code source

  1. Dans le menu Équipe, cliquez sur Paramètres Team Foundation Server, puis sur Types de fichiers du contrôle de code source…. La boîte de dialogue Types de fichiers s'affiche avec les extensions de fichier actuellement associées au contrôle de code source.

  2. Cliquez sur Modifier....

  3. Dans la zone de texte Nom de la boîte de dialogue Modifier le type de fichier, tapez une description pour le nouveau type de fichier; par exemple Documents Word pour ajouter l'association de fichier document Microsoft Word au contrôle de code source.

  4. Dans la zone de texte Extension de fichier, tapez l'extension du type de fichier; par exemple, doc pour les fichiers document Microsoft Word.

  5. Activez éventuellement la case à cocher Activer l'extraction multiple (sélectionnée par défaut).

  6. Cliquez sur OK pour revenir à la boîte de dialogue Types de fichiers qui affiche à présent la nouvelle entrée.

    Remarque Conseil

    Vous pouvez spécifier plusieurs associations d'extensions de types de fichiers avec un seul nom ; par exemple, vous pourriez ajouter dot au nom Document Word entré précédemment.

Sécurité

Vous devez disposer de l'autorisation AdminConfiguration pour effectuer cette tâche. Pour plus d'informations, consultez Droits et autorisations relatifs à la sécurité du contrôle de code source.

Voir aussi

Tâches

Comment : configurer les paramètres d'extraction

Concepts

Types de fichiers

Autres ressources

Configuration des paramètres de contrôle de code source


Comment : supprimer un type de fichier associé au contrôle de code source Team Foundation

Comment : supprimer un type de fichier associé au contrôle de code source Team Foundation
Voir aussi

Les définitions de type de fichier vous permettent de personnaliser la gestion des fichiers à extensions spécifiques appliquée par le système de contrôle de code source. En définissant un type de fichier, vous contrôlez si les mots clés internes des fichiers possédant une extension particulière peuvent être développés pendant un archivage et si plusieurs utilisateurs peuvent modifier un fichier spécifique en parallèle. Pour plus d'informations sur l'ajout d'associations de types de fichiers au contrôle de code source, consultez Comment : ajouter une association de types de fichiers avec le contrôle de code source Team Foundation. La procédure suivante montre comment supprimer une extension de type de fichier associée au contrôle de code source.

Pour supprimer un type de fichier associé au contrôle de code source

  1. Dans le menu Équipe, cliquez sur Paramètres Team Foundation Server, puis sur Types de fichiers du contrôle de code source.

    La boîte de dialogue Types de fichiers s'affiche. Elle affiche une liste des extensions de nom de fichier qui sont actuellement associées au contrôle de code source.

  2. Mettez en surbrillance l'extension du type de fichier que vous souhaitez supprimer, puis cliquez sur Supprimer.

    L'entrée est supprimée et n'apparaît plus dans la boîte de dialogue Types de fichiers.

  3. Cliquez sur OK.

Sécurité

Vous devez disposer de l'autorisation AdminConfiguration pour effectuer cette tâche. Pour plus d'informations, consultez Droits et autorisations relatifs à la sécurité du contrôle de code source.

Voir aussi

Concepts

Types de fichiers

Autres ressources

Configuration des paramètres de contrôle de code source


Comment : contrôler l'accès au contrôle de code source Team Foundation

Comment : contrôler l'accès au contrôle de code source Team Foundation
Voir aussi

Le contrôle de code source Team Foundation prend en charge des autorisations accordant le contrôle d'accès aux groupes Windows, aux utilisateurs Windows et aux groupes Team Foundation. Les autorisations peuvent être héritées du dossier qui les contient ou vous pouvez déclarer les autorisations explicitement.

Les paramètres d'autorisation correspondant au formulaire sont Autoriser ou Refuser. Refuser substitue toujours Autoriser, même si Refuser est hérité et Autoriser est défini explicitement.

Pour définir des autorisations pour les utilisateurs ou les groupes

  1. Dans le menu Affichage de Visual Studio, pointez sur Autres fenêtres, puis cliquez sur Explorateur du contrôle de code source.

  2. Cliquez avec le bouton droit sur le dossier ou le fichier auquel vous souhaitez définir des autorisations, puis cliquez sur Propriétés.

  3. Dans la boîte de dialogue Propriétés, cliquez sur l'onglet Sécurité.

  4. Dans la zone Ajouter des utilisateurs et des groupes, sélectionnez Groupe Team Foundation Server pour définir des autorisations à un groupe de Team Foundation Server. Sinon, sélectionnez Utilisateur ou groupe Windows.

  5. Cliquez sur Ajouter.

    1. Si vous avez sélectionné Groupe Team Foundation Server, la boîte de dialogue Ajouter un groupe s'ouvre. Sélectionnez un groupe et cliquez sur OK. Le groupe auquel vous souhaitez définir des autorisations apparaît dans la zone Utilisateurs et groupes de la boîte de dialogue Propriétés.

    2. Si vous avez sélectionné Utilisateur ou groupe Windows, la boîte de dialogue Sélectionner les utilisateurs ou les groupes s'ouvre. Entrez l'utilisateur ou le groupe auquel vous souhaitez définir des autorisations, puis cliquez sur OK. L'utilisateur ou le groupe apparaît dans la zone Utilisateurs et groupes de la boîte de dialogue Propriétés.

      Remarque Remarque

      Pour consulter une Info-bulle sur les contrôles présentés dans la boîte de dialogue Sélectionner les utilisateurs ou les groupes, cliquez sur l'icône de l'aide située sur la barre de titre, faites-la glisser sur le contrôle, puis cliquez sur le contrôle.

  6. Dans la zone Utilisateurs et groupes de la boîte de dialogue Propriétés, sélectionnez l'utilisateur ou le groupe auquel vous souhaitez définir des autorisations.

  7. Dans la zone Autorisation, sélectionnez Autoriser ou Refuser pour chaque autorisation.

    Remarque Remarque

    Si vous activez la case à cocher Hériter des paramètres de sécurité, les paramètres de sécurité du dossier qui les contient sont sélectionnés automatiquement. Vous pouvez substituer ces paramètres hérités en activant ou désactivant la case Refuser.

  8. Cliquez sur OK pour fermer la boîte de dialogue Propriétés.

Sécurité

Vous devez disposer de l'autorisation AdminProjectRights pour effectuer cette tâche. Pour plus d'informations, consultez Droits et autorisations relatifs à la sécurité du contrôle de code source.

Voir aussi

Autres ressources

Administration du contrôle de code source Team Foundation


Comment : supprimer l'accès aux fichiers du contrôle de code source

Comment : supprimer l'accès aux fichiers du contrôle de code source
Voir aussi

En tant qu'administrateur Team Foundation, il est possible que vous deviez supprimer l'accès à un fichier qui est sous contrôle de code source. Par exemple, quelqu'un peut archiver un fichier infecté par un virus.

La procédure suivante fournit des informations sur la suppression du fichier en utilisant l'interface utilisateur ou l'utilitaire en ligne de commande tf. L'accès est supprimé par remplacement de la mauvaise version par une version propre et par ajout de la version propre à la base de données. En définissant les autorisations en lecture/écriture, vous pouvez empêcher le fichier d'apparaître dans l'Explorateur du contrôle de code source.

Remarque Remarque

Bien que le fichier n'apparaisse plus dans la base de données, ne supprimez pas directement la ligne de ce fichier dans la base de données ou vous pourriez obtenir des résultats inattendus.

Pour supprimer l'accès à un fichier sous contrôle de code source

  1. Dans le menu Affichage de Visual Studio, pointez sur Autres fenêtres, puis cliquez sur Explorateur du contrôle de code source.

  2. Recherchez puis extrayez le fichier à supprimer.

  3. Dans la boîte de dialogue Extraire, vérifiez que le fichier correspondant est sélectionné, puis cliquez sur Extraire dans les options Sélectionnez le type de verrouillage.

  4. Créez un fichier et enregistrez-le au même emplacement et aux mêmes nom et extension que le fichier dont vous souhaitez remplacer la dernière version.

  5. Archivez le fichier.

    Remarque Remarque

    Vous pouvez vous assurer que tout utilisateur client qui possède une copie locale du fichier sur son ordinateur supprime toutes les références au fichier dans l'Explorateur de solutions de Visual Studio et supprime manuellement toutes les copies de ce fichier sur son ordinateur client.

  6. Ouvrez la fenêtre Propriétés du fichier, cliquez sur l'onglet Sécurité et désactivez la case à cocher Hériter des paramètres de sécurité.

  7. Cliquez sur Refuser pour chaque utilisateur et chaque groupe excepté le groupe Administrateurs.

  8. Cliquez sur OK et le fichier est supprimé de l'Explorateur du contrôle de code source.

Pour supprimer l'accès au fichier à partir de la ligne de commande

  1. Ouvrez la ligne de commande et utilisez la commande CheckOut de l'utilitaire tf pour obtenir une version activée en écriture du fichier à supprimer. Par exemple :

    tf checkout myfile.cs

  2. Créez un fichier et écrasez le fichier à supprimer.

  3. Utilisez la commande CheckIn pour écraser la version du fichier dans la base de données.

    Par exemple, vous pouvez souhaiter ajouter un commentaire qui indique que vous avez remplacé le fichier et que les autorisations sont refusées.

    tf checkin /comment:"Overwrote bad file and denied permissions."

  4. Utilisez la commande permission avec l'option /deny pour modifier les autorisations relatives à ce fichier pour un utilisateur ou un groupe.

    Par exemple, vous pouvez utiliser la commande suivante pour refuser aux groupes des autorisations en lecture du fichier sur le domaine ADATUM.

    tf permission /inherit:no myfile.cs

    tf permission /deny:read myfile.cs /group:ADATAUM\Group1, ADATAUM\Group2 myfile.cs

Sécurité

Vous devez disposer des autorisations d'administrateur pour exécuter ces procédures.

Voir aussi

Tâches

Comment : contrôler l'accès au contrôle de code source Team Foundation


Administration de Team Foundation Build

Administration de Team Foundation Build
DropDown image

Les administrateurs Team Foundation Build créent des types de build permettant de générer une solution ou un jeu de solutions dans un environnement distribué. En outre, les types de build peuvent fournir des rapports, permettre la réalisation de tests et fournir d'autres paramètres personnalisés comme indiqué dans Gestion des builds avec Team Foundation Build.

D'autre part, les administrateurs peuvent installer des ordinateurs de build.

Pour une vue d'ensemble de l'architecture de Team Foundation Server, consultez Vue d'ensemble de Team Foundation Build.

Dans cette section

Paramétrage d'un ordinateur de build

Cette section spécifie les composants requis et la procédure d'installation nécessaire pour un ordinateur de build désigné dans un type de build.

Utilisation de types de build dans Team Build

Répertorie les rubriques qui décrivent comment créer, modifier et supprimer des types de build dans Team Foundation Build.

Extension de Team Foundation Build

Explique comment personnaliser Team Foundation Build à l'aide de //:tâches de génération personnalisées.

Référence

Guide de référence Team Foundation Build

Rubriques connexes

Procédures pas à pas relatives à Team Foundation Build

Répertorie les procédures pas à pas qui explorent la création de types de build d'équipe, l'exécution de types de build et l'affichage de rapports de type de build.

Gestion des builds avec Team Foundation Build

Contient des rubriques destinées aux utilisateurs de Team Foundation Build, notamment sur l'exécution des types de build, à l'aide de l'Explorateur Team Build et des rapports de build.

Procédures pas à pas relatives à l'administration de Team Foundation Server

Indique comment installer et administrer votre serveur Team Foundation Server.

Ressources externes

MSDN Online

Voir aussi

Concepts

Droits et autorisations relatifs à la sécurité Team Build

Autres ressources

Documentation Team Foundation


Paramétrage d'un ordinateur de build

Paramétrage d'un ordinateur de build
DropDown image

Les types de build disponibles dans Team Foundation Build sont configurés pour désigner un ordinateur de build spécifique. L'ordinateur de build doit être configuré de façon appropriée pour être utilisé comme ordinateur de build. Cette section présente les composants requis et l'installation des ordinateurs de build.

Dans cette section

Comment : configurer un ordinateur de build

Décrit les étapes à effectuer pour configurer un ordinateur de build destiné à être utilisé en association avec un type de build.

Comment : désinstaller Team Build à partir d'un ordinateur de build

Explique comment supprimer Team Foundation Build d'un ordinateur de build à l'aide de l'applet Ajouter/Supprimer du Panneau de configuration.

Référence

Guide de référence Team Foundation Build

Rubriques connexes

Procédures pas à pas relatives à Team Foundation Build

Répertorie les procédures pas à pas qui explorent la création de types de build d'équipe, l'exécution de types de build et l'affichage de rapports de type de build.

Voir aussi

Autres ressources

Utilisation de types de build dans Team Build


Comment : configurer un ordinateur de build

Comment : configurer un ordinateur de build

À l'aide de Team Foundation Build, un ordinateur désigné peut être utilisé pour exécuter des générations. Vous devrez installer le service Team Build sur l'ordinateur désigné qui est une installation distincte de la couche Application ou Données de Team System ou du client Visual Studio. Vous pouvez désigner un ordinateur séparé ou l'ordinateur de build peut être installé côte à côte sur l'ordinateur client.

La procédure d'installation installe le Kit de développement.NET SDK et les composants Team Foundation Build appropriés. L'un des composants importants installé est le service Team Build. Ce service requiert des autorisations spéciales. Les procédures suivantes décrivent les étapes à suivre pour installer Team Foundation Build sur un ordinateur de build désigné.

Pour installer un ordinateur de build

  1. Sur l'ordinateur sur lequel vous souhaitez installer le service Team Build, exécutez setup.exe pour lancer l'installation d'ordinateur de build et suivez les instructions fournies.

    Remarque Remarque

    Le fichier setup.exe et les fichiers associés sont situés sur le CD d'installation de Team Foundation Server sous \tb.

  2. L'Assistant Installation invite à saisir les informations d'identification de connexion et un compte de domaine ou un compte de groupe de travail valide.

    Remarque Remarque

    Pour générer un projet d'équipe, le compte fourni ci-dessus doit être ajouté au groupe Build Services du projet. Pour plus d'informations, consultez Comment : établir des autorisations pour un ordinateur Team Build.

  3. Après l'installation, cliquez sur OK.

Sécurité

L'autorisation Écrire dans le magasin opérationnel de la build s'applique à cette rubrique. Pour plus d'informations, consultez Droits et autorisations relatifs à la sécurité Team Build

Voir aussi

Tâches

Comment : désinstaller Team Build à partir d'un ordinateur de build


Comment : désinstaller Team Build à partir d'un ordinateur de build

Comment : désinstaller Team Build à partir d'un ordinateur de build
Voir aussi

Les procédures suivantes décrivent les étapes permettant de désinstaller Team Foundation Build d'un ordinateur de build.

Pour désinstaller Team Foundation Build d'un ordinateur de build

  1. Sur l'ordinateur de build, ouvrez le Panneau de configuration et ouvrez Ajout/Suppression de programmes.

  2. Dans la liste de programmes installés, recherchez l'entrée Visual Studio Team Foundation - Team Build, puis cliquez sur Supprimer.

    Il s'agit d'une suppression complète, par conséquent aucun fichier, ni aucune entrée du Registre ne subsiste.

Voir aussi

Autres ressources

Paramétrage d'un ordinateur de build


Utilisation de types de build dans Team Build

Utilisation de types de build dans Team Build
DropDown image

Cette section contient des rubriques qui décrivent la création et la modification des types de build dans Team Foundation Build.

Team Foundation Build utilise des types de build permettant de gérer les conditions sous lesquelles une solution unique ou un jeu de solutions sera généré. Les types de build sont créés et modifiés à l'aide de l'Assistant Création d'un nouveau type de build d'équipe qui inclut les options de configuration suivantes :

  • Espace de travail de build

    Utilisez ce paramètre pour définir les solutions à générer dans le type de build. Pour chaque espace de travail, le propriétaire qui l'a créé est indiqué. Plus précisément, un espace de travail définit la partie de l'arborescence source qui sera générée. Les sources visibles à partir d'un espace de travail spécifique seront en particulier générées sur l'ordinateur de build.

  • Ordinateur de build

    Utilisez ce paramètre pour spécifier l'ordinateur sur lequel la génération est exécutée.

  • Emplacement cible de build

    Utilisez ce paramètre pour spécifier un partage réseau sur lequel la sortie de la génération peut être déplacée. La sortie de chaque génération sera déplacée dans un répertoire séparé sous ce partage.

  • Configuration

    Utilisez ce paramètre pour spécifier la configuration et la plate-forme ; par exemple, debug, x86 ou retail x86.

  • Étapes de génération

    Utilisez ce paramètre pour spécifier des étapes supplémentaires, telles que l'analyse du code, exécutées lors du processus de génération.

Dans cette section

Comment : créer un type de build

Décrit les étapes utilisées pour créer et configurer un nouveau type de build pour Team Foundation Build.

Comment : configurer les tests en fonction des types de build

Explique comment modifier des types de build et des projets pour tirer parti des capacités de test dans Team Foundation Build.

Test des sites et des services Web dans un environnement de travail en équipe

Fournit des informations supplémentaires sur l'utilisation des tests dans Team Foundation Build.

Comment : établir des autorisations pour un ordinateur Team Build

Décrit comment établir des autorisations pour que l'ordinateur Team Build exécute des builds.

Comment : modifier un type de build

Explique comment modifier le fichier xml sous-jacent d'un type de build, notamment quelques paramètres personnalisés.

Comment : mettre à jour les types de build dans des projets d'équipe avec branches

Explique comment modifier des types de build dans une branche récemment établie afin de les générer correctement.

Comment : supprimer un type de build

Décrit comment supprimer un type de build qui n'est plus nécessaire.

Référence

Guide de référence Team Foundation Build

Rubriques connexes

Exécution de builds dans Team Foundation Build

Répertorie les rubriques qui décrivent comment exécuter des builds dans Team Foundation Build, notamment les builds standard, locales et planifiées.

Fonctionnement de l'Explorateur Team Build

Explique les fonctionnalités de l'Explorateur Team Build et répertorie les rubriques qui décrivent comment afficher, interpréter et modifier l'état de type de build et les rapports de type de build générés par un type de build dans Team Foundation Build.

Procédures pas à pas relatives à Team Foundation Build

Répertorie les procédures pas à pas qui explorent la création de types de build d'équipe, l'exécution de types de build et l'affichage de rapports de type de build.

Administration de Team Foundation Build

Répertorie les rubriques relatives aux administrateurs de Team Foundation Build.

Voir aussi

Tâches

Procédure pas à pas : création d'un type de build dans Team Foundation Build


Comment : créer un type de build

Comment : créer un type de build

Team Foundation Build utilise des types de build pour configurer les conditions sous lesquelles une solution unique ou un ensemble de solutions dans un projet d'équipe sera généré. Pour effectuer une génération, vous devrez créer un type de build ou utiliser un type de build existant.

  • Lorsque vous créez des types de build à l'aide de l'Assistant Création d'un nouveau type de build d'équipe, vous pouvez définir plusieurs options. Ces options incluent le mode de numérotation des builds, les étapes de génération, le nettoyage du répertoire de build et la synchronisation des sources. Team Foundation ne possède aucune interface utilisateur pour modifier ces options après leur définition. Pour ajouter vos propres étapes de génération ou modifier le type de build, vous pouvez modifier le fichier .xml en utilisant un éditeur XML. Pour plus d'informations, consultez Comment : modifier un type de build. Vous pouvez substituer les options par défaut en modifiant le fichier de type de build qui est écrit au format MSBuild.

  • Les étapes de génération des types de build peuvent être personnalisées en modifiant le fichier Microsoft.TeamBuild.targets.

  • Les types de build sont supprimés en supprimant directement les fichiers du contrôle de code source. Pour plus d'informations, consultez Comment : supprimer un type de build.

Les types de build sont créés en utilisant l'Assistant Création d'un nouveau type de build d'équipe, comme décrit dans la procédure suivante.

Pour créer un type de build, procédez comme suit :

  1. Dans l'Explorateur d'équipes, sélectionnez le projet pour lequel vous souhaitez créer un type de build.

  2. Dans le menu Générer, sélectionnez Nouveau type de build d'équipe.

    L'Assistant Création d'un nouveau type de build d'équipe apparaît.

  3. Dans l'Assistant Création d'un nouveau type de build d'équipe, spécifiez le nom à associer au type de build dans la zone de texte Quel nom souhaitez-vous donner à ce type de build d'équipe ?.

    Une validation est effectuée afin de vérifier que le nom entré existe déjà pour un type de build établi. Si le nom existe, vous êtes invité à entrer un nom unique. Le nom du type de build doit être un nom de fichier Windows valide et ne peut pas contenir le symbole $.

    Ajoutez une description appropriée dans la zone de texte Description, puis cliquez sur Suivant pour continuer.

    L'étape Sélectionnez et classez les solutions à générer apparaît.

    Remarque Conseil

    Le bouton Suivant est uniquement activé lorsque tous les champs obligatoires sont correctement renseignés.

  4. Dans la zone de liste déroulante Depuis quel espace de travail souhaitez-vous sélectionner les solutions à générer, sélectionnez l'espace de travail qui contient les solutions à inclure dans le type de build. L'option affiche le nom de l'espace de travail et l'utilisateur qui l'a créé.

  5. Dans la liste Sélectionnez et classez les solutions, sélectionnez la ou les solutions que vous souhaitez ajouter au type de build. Utilisez l'option Sélectionner tout pour sélectionner une solution, plusieurs solutions ou toutes les solutions.

  6. Utilisez les touches de direction situées à droite de la liste pour sélectionner les solutions et modifier leur emplacement dans l'ordre de la génération. Les solutions sont générées de façon ordonnée, en commençant en haut de la liste.

    Attention Attention

    Tenez compte des dépendances d'une solution vis-à-vis d'une autre lorsque vous déterminez l'ordre de la génération des solutions. Par exemple, si Solution2 a une dépendance vis-à-vis de Solution1, définissez la génération de Solution1 avant celle de Solution2. Lorsque les solutions sélectionnées et l'ordre de génération spécifié répondent à vos besoins, cliquez sur Suivant. L'étape Sélectionnez les configurations à générer apparaît.

    Remarque Remarque

    Si un branchement est effectué, les types de build du nouveau branchement doivent être modifiés pour spécifier les chemins d'accès corrects. Pour plus d'informations, consultez Comment : mettre à jour les types de build dans des projets d'équipe avec branches et Branchement et fusion du contrôle de code source Team Foundation.

  7. In the grid under Which configurations would you like to build, select the desired configuration and platforms to include in the build. La configuration de génération indique la configuration et la plate-forme souhaitée, par exemple, Retail et Any UC.

    Remarque Remarque

    Si un projet utilise un paramètre de configuration différent dans le Gestionnaire de configuration de celui qui est spécifié dans l'Assistant Création d'un nouveau type de build d'équipe, le projet sera ignoré.

    Remarque Remarque

    Si vous créez un type de build pour les projets Web, sélectionnez Plates-formes mixtes.

  8. Lorsque les sélections de configuration de génération répondent à vos besoins, cliquez sur Suivant.

    L'étape Sélectionnez l'emplacement de build apparaît.

  9. Dans la zone de texte Sur quel ordinateur souhaitez-vous générer les solutions sélectionnées ?, tapez le nom de l'ordinateur, par exemple MachineA_Lab1.

  10. Dans la zone de texte Répertoire de build sur l'ordinateur sélectionné, tapez le répertoire où vous souhaitez que la génération se produise. Il s'agit d'un répertoire local sur l'ordinateur de build. Par exemple, D:\AdventureWorks\TourPackeServices\.

    Attention Attention

    Lors de la sélection du répertoire de build, assurez-vous que l'espace est suffisant pour la build. Si l'espace est insuffisant, les générations échoueront.

    Remarque Remarque

    Le répertoire de build ne peut pas être un répertoire mappé.

  11. Dans la zone de texte Emplacement cible, tapez l'emplacement UNC (\\serveur\partage) ou utilisez Parcourir pour rechercher un emplacement cible. L'emplacement cible est le lieu de stockage des binaires et des fichiers journaux créés à la fin de la génération.

    • Par défaut, le répertoire cible n'est pas créé automatiquement comme un répertoire de partage et, par conséquent, il ne permet pas de publier des builds et des résultats de tests. Vous devez établir un partage manuellement. Afin d'éviter que des utilisateurs non autorisés suppriment des emplacements cibles de build, il est déconseillé d'établir des autorisations de suppression sur le partage.

    • Chaque build générée sera située dans un répertoire séparé. Vous devrez vérifier que le compte avec lequel l'ordinateur de build est configuré dispose d'un accès en écriture à cet emplacement UNC. L'autorisation d'écriture est également requise pour le compte sous lequel la couche Application est configurée.

    Attention Attention

    Les binaires et les fichiers journaux créés copiés dans le répertoire cible ne peuvent pas être sécurisés. Vous pouvez étendre le type de build avec une tâche MSBuild personnalisée qui copie de façon sécurisée ces fichiers vers le répertoire cible. Pour plus d'informations sur l'extension d'un type de build, consultez Procédure pas à pas : extension de Team Foundation Build.

  12. Lorsque les paramètres d'emplacement de build répondent à vos besoins, cliquez sur Suivant.

    L'étape Sélectionnez les options de build apparaît.

  13. Indiquez les options de build que vous souhaitez sélectionner en activant les cases à cocher Série de tests (par exemple, exécution de tests de vérification (BVT) de la génération, etc.) et Exécuter l'analyse du code le cas échéant. Si la case à cocher Série de tests (exécution de tests de vérification (BVT) de la génération, etc.) est activée, utilisez les options déroulantes pour spécifier les options Fichier de métadonnées de test et Liste de tests à exécuter, si approprié. Pour plus d'informations, consultez Utilisation des listes de test et Écriture de code de qualité..

  14. Lorsque les étapes de génération répondent à vos besoins, cliquez sur Suivant.

    L'étape Vérifiez les types de build sélectionnés apparaît.

  15. Si le type de build répond à vos besoins, cliquez sur Terminer. Le nouveau type de build crée les fichiers sous-jacents. Les fichiers suivants sont créés :

    • TeamBuild.proj

    • WokspaceMapping.xml

    Ces fichiers sont archivés dans le contrôle de code source Team Foundation sous le dossier qui porte le même nom que le « type de build ». Par exemple, si vous créez un type de build nommé "myBuildType", dans le contrôle de code source Team Foundation, les fichiers sont stockés dans $/[Nom Projet d'équipe/TeamBuildType/myBuildType.

    Remarque Remarque

    Si vous souhaitez continuer à modifier le type de build, vous devrez modifier le fichier teambuild.proj.

    Une fois les étapes de l'Assistant terminées, vous devez vous assurer que les autorisations appropriées ont été définies pour le type de build que vous venez de créer. Pour plus d'informations, consultez Comment : établir des autorisations pour un ordinateur Team Build.

Sécurité

La première création de type de build peut être exécutée uniquement par un administrateur de projet. Les créations de type de build suivantes requièrent que Team Foundation Server administre des autorisations de génération et d'archivage. Vous devez disposer du droit de sécurité permettant de générer une génération de Team Foundation Server pour exécuter une génération. Les droits ou autorisations relatifs à la sécurité Team Foundation Server s'appliquent à cette rubrique. Pour plus d'informations, consultez Droits et autorisations relatifs à la sécurité Team Build.

Voir aussi

Tâches

Procédure pas à pas : création d'un type de build dans Team Foundation Build
Comment : établir des autorisations pour un ordinateur Team Build
Comment : configurer un ordinateur de build
Procédure pas à pas : extension de Team Foundation Build

Concepts

Vue d'ensemble de Team Foundation Build

Autres ressources

Utilisation de types de build dans Team Build


Comment : configurer les tests en fonction des types de build

Comment : configurer les tests en fonction des types de build
Voir aussi

Cette rubrique explique comment modifier des types de build et des projets pour pouvoir utiliser les fonctions de tests de Team Foundation Build. Les types de tests suivants sont abordés dans cette rubrique :

  • Tests unitaires ASP.NET

  • Tests unitaires de service Web

  • Tests Web

  • Tests de charge

  • Tests ordonnés

  • Tests génériques

Configuration requise pour la génération de projets Web

Pour générer un projet Web à l'aide de Team Foundation Build, le projet doit être configuré pour accepter les mises à jour.

Pour configurer le projet Web afin qu'il accepte les mises à jour

  1. Dans l'Explorateur de solutions, sélectionnez le projet Web.

  2. Dans le menu Affichage, cliquez sur Pages de propriétés.

  3. Dans le volet de gauche, cliquez sur Options MSBuild.

  4. Sélectionnez Autoriser ce site précompilé à être mis à jour.

Remarque Remarque

Cette option est déjà activée par défaut.

Tests unitaires ASP.NET

Les projets ASP.NET peuvent être testés des façons suivantes :

  • Sur un serveur Web local ou distant, par exemple IIS.

  • Sur un serveur de développement ASP.NET. Pour plus d'informations, consultez Serveurs Web dans Visual Web Developer.

Pour tester des projets ASP.NET dans IIS

  1. Créez un projet ASP.NET. Pour plus d'informations, consultez Comment : créer des sites Web locaux IIS.

  2. Ouvrez le fichier .sln dans un éditeur de texte, tel que le Bloc-notes.

    Remarque Remarque

    Par défaut, le fichier .sln d'un projet ASP.NET se trouve dans Mes documents\Visual Studio 2005\projects\WebSiteName.

  3. Définissez les valeurs Debug.AspNetCompiler.PhysicalPath et Release.AspNetCompiler.PhysicalPath comme étant égales à "..\SolutionName\WebProjectName".

  4. Créez un test unitaire pour le projet. Pour plus d'informations, consultez Tests unitaires ASP.NET.

  5. Archivez le projet Web et le projet de test.

  6. Créez un type de build, puis sélectionnez le test à exécuter pendant la génération. Pour plus d'informations, consultez Comment : créer un type de build.

    Remarque Remarque

    À l'étape Sélectionnez les configurations à générer de l'Assistant Création d'un nouveau type de build d'équipe, vous devez taper Plate-forme mixte dans la zone Plate-forme pour le projet Web et le test Web pour que la génération réussisse.

  7. Publiez manuellement le site Web sur l'ordinateur de génération.

  8. Exécutez le type de build.

Pour tester des projets ASP.NET sur un serveur de développement ASP.NET

  1. Créez un projet ASP.NET.

  2. Ouvrez le fichier .sln dans un éditeur de texte, tel que le Bloc-notes.

    Remarque Remarque

    Par défaut, le fichier .sln d'un projet ASP.NET se trouve dans Mes documents\Visual Studio 2005\projects\WebSiteName.

  3. Définissez les valeurs Debug.AspNetCompiler.PhysicalPath et Release.AspNetCompiler.PhysicalPath comme étant égales à "..\SolutionName\WebProjectName".

  4. Créez un test unitaire pour le projet. Pour plus d'informations, consultez Tests unitaires ASP.NET.

  5. Remplacez le chemin d'accès de l'attribut AspNetDevelopmentServerHost dans la méthode de test par %PathToWebRoot%. Pour plus d'informations, consultez Test des sites et des services Web dans un environnement de travail en équipe.

  6. Archivez le projet Web et le projet de test.

  7. Créez un type de build, puis sélectionnez le test à exécuter pendant la génération. Pour plus d'informations, consultez Comment : créer un type de build.

    Remarque Remarque

    À l'étape Sélectionnez les configurations à générer de l'Assistant Création d'un nouveau type de build d'équipe, vous devez taper Plate-forme mixte dans la zone Plate-forme pour le projet Web et le test Web pour que la génération réussisse.

  8. Exécutez le type de build.

Tests unitaires de service Web

Les services Web peuvent être testés des façons suivantes :

  • Sur un serveur Web local ou distant, par exemple IIS.

  • Sur un serveur de développement ASP.NET. Pour plus d'informations, consultez Serveurs Web dans Visual Web Developer.

Pour tester des services Web dans IIS

  1. Créez un projet de service Web. Pour plus d'informations, consultez Procédure pas à pas : création d'un service Web XML en utilisant Visual Basic ou Visual C#.

  2. Ouvrez le fichier .sln dans un éditeur de texte, tel que le Bloc-notes.

    Remarque Remarque

    Par défaut, le fichier .sln d'un projet ASP.NET se trouve dans Mes documents\Visual Studio 2005\projects\WebSiteName.

  3. Définissez les valeurs Debug.AspNetCompiler.PhysicalPath et Release.AspNetCompiler.PhysicalPath comme étant égales à "..\SolutionName\WebProjectName".

  4. Créez un test unitaire pour le projet. Pour plus d'informations, consultez Tests unitaires ASP.NET.

  5. Ajoutez le code suivant à la méthode de test, où WebServiceObject est l'objet de service Web et Location est l'emplacement du service Web.

    Image Copier le code Copier le code
    WebServiceObject.URL = "Location";

  6. Archivez le projet Web et le projet de test.

  7. Créez un type de build, puis sélectionnez le test à exécuter pendant la génération. Pour plus d'informations, consultez Comment : créer un type de build.

    Remarque Remarque

    À l'étape Sélectionnez les configurations à générer de l'Assistant Création d'un nouveau type de build d'équipe, vous devez taper Plate-forme mixte dans la zone Plate-forme pour le projet Web et le test Web pour que la génération réussisse.

  8. Exécutez le type de build.

Pour tester des services Web sur un serveur de développement ASP.NET

  1. Créez un projet de service Web. Pour plus d'informations, consultez Procédure pas à pas : création d'un service Web XML en utilisant Visual Basic ou Visual C#.

  2. Ouvrez le fichier .sln dans un éditeur de texte, tel que le Bloc-notes.

    Remarque Remarque

    Par défaut, le fichier .sln d'un projet ASP.NET se trouve dans Mes documents\Visual Studio 2005\projects\WebSiteName.

  3. Définissez les valeurs Debug.AspNetCompiler.PhysicalPath et Release.AspNetCompiler.PhysicalPath comme étant égales à "..\SolutionName\WebProjectName".

  4. Créez un test unitaire pour le projet. Pour plus d'informations, consultez Comment : générer un test unitaire.

  5. Incluez l'espace de noms Microsoft.VisualStudio.QualityTools.UnitTesting.Web dans la classe de test.

  6. Ajoutez l'attribut AspNetDevelopmentServerAttribute au test unitaire. Pour plus d'informations, consultez Test des services Web.

  7. Ajoutez un appel à la méthode TryUrlRedirection. Pour plus d'informations, consultez la section « Utilisation de la méthode TryUrlRedirection » dans Test des services Web.

  8. Archivez le service Web et le projet de test.

  9. Créez un type de build, puis sélectionnez le test à exécuter pendant la génération. Pour plus d'informations, consultez Comment : créer un type de build.

    Remarque Remarque

    À l'étape Sélectionnez les configurations à générer de l'Assistant Création d'un nouveau type de build d'équipe, vous devez taper Plate-forme mixte dans la zone Plate-forme pour le projet Web et le test Web pour que la génération réussisse.

  10. Publiez manuellement le site Web sur l'ordinateur de génération.

  11. Exécutez le type de build.

Tests Web

Pour effectuer des tests Web avec Team Foundation Build, le service Team Build doit être exécuté sous le compte Administrateur sur l'ordinateur de build. Pour plus d'informations sur l'installation de Team Foundation Build, consultez Comment : configurer un ordinateur de build.

Les tests Web peuvent être effectués des façons suivantes :

  • Sur un serveur Web local ou distant, par exemple IIS.

  • Sur un serveur de développement ASP.NET. Pour plus d'informations, consultez Serveurs Web dans Visual Web Developer.

Pour plus d'informations sur les tests Web, consultez Utilisation des tests Web.

Pour effectuer des tests Web sur IIS

  1. Créez un projet Web.

  2. Ouvrez le fichier .sln dans un éditeur de texte, tel que le Bloc-notes.

    Remarque Remarque

    Par défaut, le fichier .sln d'un projet ASP.NET se trouve dans Mes documents\Visual Studio 2005\projects\WebSiteName.

  3. Créez un test Web.

  4. Archivez le projet Web et le projet de test.

  5. Créez un type de build, puis sélectionnez le test à exécuter pendant la génération. Pour plus d'informations, consultez Comment : créer un type de build.

    Remarque Remarque

    À l'étape Sélectionnez les configurations à générer de l'Assistant Création d'un nouveau type de build d'équipe, vous devez taper Plate-forme mixte dans la zone Plate-forme pour le projet Web et le test Web pour que la génération réussisse.

  6. Publiez manuellement le site Web sur l'ordinateur de génération.

  7. Exécutez le type de build.

Pour effectuer des tests Web sur un serveur de développement ASP.NET

  1. Créez un projet Web.

  2. Ouvrez le fichier .sln dans un éditeur de texte, tel que le Bloc-notes.

    Remarque Remarque

    Par défaut, le fichier .sln d'un projet ASP.NET se trouve dans Mes documents\Visual Studio 2005\projects\WebSiteName.

  3. Définissez les valeurs Debug.AspNetCompiler.PhysicalPath et Release.AspNetCompiler.PhysicalPath comme étant égales à "..\SolutionName\WebProjectName".

  4. Créez un test Web. Pour plus d'informations, consultez Création d'un test Web.

  5. Dans l'Explorateur de solutions, cliquez avec le bouton droit sur le fichier .webtest, puis cliquez sur Ouvrir.

  6. Cliquez sur le bouton Paramétrer les serveurs Web.

  7. Sélectionnez le Serveur Web à paramétrer, puis cliquez sur Modifier.

  8. Sélectionnez Utiliser un serveur de développement ASP.NET.

  9. Dans la zone Chemin d'accès au site Web, tapez % PathToWebRoot%\WebSiteProjectName.

  10. Dans la zone Racine de l'application Web, entrez la racine de l'application Web.

  11. Cliquez sur OK, puis à nouveau sur OK.

  12. Archivez le service Web et le projet de test.

  13. Créez un type de build, puis sélectionnez le test à exécuter pendant la génération. Pour plus d'informations, consultez Comment : créer un type de build.

    Remarque Remarque

    À l'étape Sélectionnez les configurations à générer de l'Assistant Création d'un nouveau type de build d'équipe, vous devez taper Plate-forme mixte dans la zone Plate-forme pour le projet Web et le test Web pour que la génération réussisse.

  14. Exécutez le type de build.

Test de charge

Pour plus d'informations sur les tests de charge, consultez Utilisation des tests de charge.

Pour configurer un test de charge pour une utilisation avec Team Foundation Build

  1. Création d'un test de charge Pour plus d'informations, consultez Création d'un test de charge.

  2. Assurez-vous que SQL Server Express est installé sur l'ordinateur de build et que le service Team Build dispose d'une autorisation en écriture sur SQL Server Express.

  3. Créez un type de build, puis sélectionnez le test à exécuter pendant la génération. Pour plus d'informations, consultez Comment : créer un type de build.

  4. Exécutez le type de build.

    Remarque Remarque

    Pour consulter les résultats des tests pour le test de charge, il est possible que vous deviez modifier des paramètres de configuration si le référentiel des tests de charge était dans une configuration SQL Server Express. Le cas échéant, activez Connexions distantes pour SQL Server Express sur l'ordinateur de build.

Test ordonné

Pour plus d'informations sur les tests ordonnés, consultez Utilisation des tests ordonnés.

Pour configurer un test ordonné pour une utilisation avec Team Foundation Build

  1. Créez un test ordonné. Pour plus d'informations, consultez Comment : créer un test ordonné.

  2. Créez un type de build, puis sélectionnez le test à exécuter pendant la génération. Pour plus d'informations, consultez Comment : créer un type de build.

  3. Exécutez le type de build.

Test générique

Pour plus d'informations sur les tests génériques, consultez Utilisation des tests génériques.

Pour configurer un test générique pour une utilisation avec Team Foundation Build

  1. Créez un test générique. Pour plus d'informations, consultez Comment : créer un test générique.

  2. Créez un type de build, puis sélectionnez le test à exécuter pendant la génération. Pour plus d'informations, consultez Comment : créer un type de build.

  3. Exécutez le type de build.

Voir aussi

Concepts

Test des sites et des services Web dans un environnement de travail en équipe

Autres ressources

Utilisation de types de build dans Team Build
Types de test


Comment : établir des autorisations pour un ordinateur Team Build

Comment : établir des autorisations pour un ordinateur Team Build
Voir aussi

Team Foundation Build utilise des types de build pour configurer les conditions sous lesquelles une solution unique ou un ensemble de solutions dans un projet d'équipe sera généré. Pour exécuter une génération, vous devrez créer un nouveau type de build ou utiliser un type de build existant créé précédemment. Pour plus d'informations sur la création d'un type de build, consultez Comment : créer un type de build.

En outre, vous devez vous assurer que les autorisations de sécurité appropriées ont été établies sur l'ordinateur de build que le type de build est configuré pour utiliser, et que les autorisations appropriées sont accordées aux utilisateurs qui exécuteront la génération comme cela est décrit dans la procédure suivante.

Pour établir des autorisations de génération

  1. Contactez l'administrateur système de l'ordinateur de build que vous avez sélectionné et déterminez le nom du compte sous lequel le service Team Build est exécuté.

  2. Dans le menu Équipe, sélectionnez Paramètres du projet d'équipe, puis Appartenance au groupe.

    La boîte de dialogue Groupes de projets s'affiche.

    Cliquez sur Propriétés dans la boîte de dialogue Groupes de projets.

    La boîte de dialogue Propriétés du groupe Team Foundation Server apparaît.

  3. Cliquez sur l'onglet Membres. Si le nom du compte de l'étape 1 est présent dans la liste des membres, l'ordinateur de build sélectionné peut générer ce type de build. Sinon, suivez ces étapes :

    1. Dans la section Ajouter des utilisateurs et des groupes, sélectionnez Utilisateur ou groupe Windows, puis cliquez sur Ajouter.

      La boîte de dialogue Sélectionner les utilisateurs ou les groupes s'affiche.

    2. Dans la boîte de dialogue Sélectionner les utilisateurs ou les groupes, tapez le nom du compte qui est associé au service Team Build sur l'ordinateur de build utilisé pour ce type de build.

    Remarque Remarque

    Si ce type de build est généré sur plusieurs ordinateurs de build, tous les comptes de service Team Build doivent être ajoutés comme membres de ce groupe Build Services du projet.

  4. Vous devez configurer les utilisateurs qui peuvent exécuter des types de build. Pour ce faire, accordez l'autorisation permettant de commencer/reprendre une génération. Pour plus d'informations, consultez Audit et autorisations de l'utilisateur et Droits et autorisations relatifs à la sécurité Team Build.

Sécurité

Les utilisateurs doivent disposer des droits de sécurité et autorisations permettant de commencer/reprendre une génération de Team Foundation Server pour exécuter une génération. Les droits de sécurité de Team Foundation Server s'appliquent à cette rubrique. Pour plus d'informations, consultez Droits et autorisations relatifs à la sécurité Team Build.

Voir aussi

Tâches

Procédure pas à pas : exécution d'un type de build dans Team Foundation Build
Comment : configurer un ordinateur de build
Comment : créer un type de build

Référence

Start, commande (Team Foundation Build)


Comment : modifier un type de build

Comment : modifier un type de build

Avant de modifier un type de build, vous devez d'abord créer une build à l'aide de l'Assistant Création d'un nouveau type de build d'équipe. Pour plus d'informations, consultez Comment : créer un type de build. Après avoir créé un type de build, le type de build inclura un fichier TeamBuild.proj associé qui est créé et vérifié dans le contrôle de code source Team Foundation sous ${Projet de portfolio}\Team Build Configurations\{Nom du type de build}\TeamBuild.proj. Pour modifier le type de build, le fichier TeamBuild.proj doit être modifié. La procédure suivante montre comment modifier un fichier de type de build TeamBuild.proj.

Pour modifier un fichier de type de build TeamBuild.proj

  1. Pour modifier un type de build existant, le fichier TeamBuild.proj correspondant doit être extrait. Pour plus d'informations, consultez Obtention d'une copie locale des fichiers à partir du serveur du contrôle de code source.

  2. Cliquez avec le bouton droit sur le fichier de type de build et sélectionnez Modifier le type de définition.

  3. Dans le fichier TeamBuild.proj, recherchez la section Description. Modifiez éventuellement la description en modifiant la valeur dans l'élément Description, par exemple :

    Image Copier le code Copier le code
    <Description>This is my new description</Description>

  4. Recherchez l'élément SolutionToBuild. Pour chaque solution que vous souhaitez inclure dans le type de build, un nouvel élément SolutionToBuild doit être créé à l'intérieur de l'élément ItemGroup. Cela spécifie le nom de solution à l'aide de l'attribut Include, par exemple :

    Image Copier le code Copier le code
    <ItemGroup>
    <SolutionToBuild Include="$(SolutionRoot)\path\MySolution.sln" />
    <SolutionToBuild Include="$(SolutionRoot)\Scribble\scribble.sln" />
    <SolutionToBuild Include="$(SolutionRoot)\HelloWorld\HelloWorld.sln" />
    <SolutionToBuild Include="$(SolutionRoot)\TestProject1\TestProject1.sln" />
</ItemGroup>

  5. Recherchez l'élément Order de SolutionsToBuild. L'ordre des solutions est modifié en modifiant l'ordre des solutions spécifié dans l'élément ItemGroup comme décrit à l'étape précédente. Si vous devez déplacer la solution HelloWorld au-dessus de la solution Scribble comme indiqué à l'étape précédente, effectuez les modifications suivantes :

    Image Copier le code Copier le code
    <ItemGroup>
    <SolutionToBuild Include="$(SolutionRoot)\TestProject1\TestProject1.sln" />
    <SolutionToBuild Include="$(SolutionRoot)\HelloWorld\HelloWorld.sln" />
    <SolutionToBuild Include="$(SolutionRoot)\Scribble\scribble.sln" />
</ItemGroup>

  6. Recherchez l'élément ConfigurationToBuild. Pour ajouter une nouvelle combinaison de configurations pour Debug et Retail et des plates-formes telles que x86 et Itanium, ajoutez les éléments à la cible Compile comme indiqué ci-dessous. Dans cet exemple, l'utilisateur possède une nouvelle combinaison de Debug et x86.

    Image Copier le code Copier le code
    <ConfigurationToBuild Include="Release|x86">
    <FlavorToBuild>Debug</FlavorToBuild>
    <PlatformToBuild>x86</PlatformToBuild>
</ConfigurationToBuild>
    Remarque Remarque

    Hormis cette entrée pour la nouvelle configuration, 'Debug' dans l'exemple précédent doit être dans l'élément AvailableConfigurations de TeamBuild.proj s'il n'existe pas déjà.

  7. Recherchez l'élément BuildMachine. L'ordinateur de build peut être modifié en modifiant l'élément BuildMachine, par exemple :

    Image Copier le code Copier le code
    <BuildMachine>machine1</BuildMachine>

  8. Recherchez l'élément BuildDirectoryPath. Le répertoire de build est modifié en modifiant l'élément BuildDirectoryPath, par exemple :

    Image Copier le code Copier le code
    <BuildDirectoryPath>c:/builddir</BuildDirectoryPath>

  9. Recherchez l'élément DropLocation. L'emplacement cible est modifié en modifiant l'élément DropLocation, par exemple :

    Image Copier le code Copier le code
    <DropLocation>\\machine2\drops</DropLocation>

  10. Recherchez l'élément Test activé. Pour modifier l'option d'activation du test dans le processus de génération, modifiez la valeur de l'élément TestingFlag qui peut posséder une valeur True ou False, par exemple :

    Image Copier le code Copier le code
    <TestingFlag>true</TestingFlag>

    Le nom de fichier de métadonnées associé au test peut être modifié en modifiant le commutateur testmetadatafilename dans l'élément TestingArgs, par exemple :

    Image Copier le code Copier le code
    <TestingArgs>/testmetadatafilename:sdfsdf /testlist:sdfsdf</TestingArgs>

    Le nom du nom de fichier de métadonnées peut être modifié en modifiant le commutateur testlist dans l'élément TestingArgs, par exemple :

    Image Copier le code Copier le code
    <TestingArgs>/testmetadatafilename:sdfsdf /testlist:sdfsdf</TestingArgs>

  11. Si vous souhaitez effectuer des tests sélectifs, vous pouvez les spécifier avec un attribut Condition. Par exemple si vous souhaitez effectuer le test pour une configuration "Debug|Any CPU" uniquement, modifiez l'élément MetaDataFile correspondant et ajoutez la condition suivante :

    Image Copier le code Copier le code
    <MetaDataFile
   Condition = ” ’$(Platform)’ = = ’Any CPU’ and ‘$(Flavor)’ = = ’Debug’ ”
   Include = "$(SolutionRoot)\HelloWorld\HelloWorld.vsmdi">
   <TestList>BVT1</TestList>
</MetaDataFile>

    Pour plus d'informations sur les fichiers de métadonnées de test, consultez Réutilisation des tests.

  12. Recherchez l'élément Analyse du code activée. Pour modifier l'option d'activation de l'analyse du code dans le processus de génération, modifiez la valeur de l'élément RunCodeAnalysis à l'aide d'une valeur True ou False, par exemple :

    Image Copier le code Copier le code
    <RunCodeAnalysis>true</RunCodeAnalysis>

  13. Enregistrez le fichier TeamBuild.proj. Les modifications apportées au fichier affecteront le type de build suivant.

    Remarque Remarque

    Les modifications apportées à l'élément TeamProject n'affecteront pas la build.

Sécurité

Team Foundation Server doit vous administrer un droit relatif à la sécurité de build pour que vous puissiez extraire un fichier de type de build. Les droits ou autorisations relatifs à la sécurité Team Foundation Server s'appliquent à cette rubrique. Pour plus d'informations, consultez Droits et autorisations relatifs à la sécurité Team Build.

Voir aussi

Concepts

Référence du schéma de fichier de projet MSBuild
Vue d'ensemble de MSBuild

Autres ressources

Utilisation de types de build dans Team Build
Extension de Team Foundation Build


Comment : mettre à jour les types de build dans des projets d'équipe avec branches

Comment : mettre à jour les types de build dans des projets d'équipe avec branches
Voir aussi

Le branchement avec le contrôle de code source Team Foundation permet de copier tous les dossiers et les fichiers, y compris le dossier Team Build Types, d'une branche antérieure vers une branche de destination. Pour plus d'informations, consultez Branchement et fusion du contrôle de code source Team Foundation. Deux scénarios de branchement affectant les types de build d'équipe de différentes façons sont à considérer :

  • Branche partielle Lorsque seule une ou quelques solutions du dossier de projet d'équipe qui contient plusieurs solutions possèdent des branches.

  • Branche complète Lorsque toutes les solutions du dossier de projet d'équipe possèdent des branches.

Grâce à une branche partielle, les types de build qui figurent dans le dossier Team Build Types seront encore valides pour leur configuration d'origine. En d'autres termes, ils s'exécuteront sur la branche d'origine. Dans le cadre du scénario de la branche partielle, il est recommandé de créer, lorsque cela est nécessaire, des types de build qui pointent vers les solutions à la fois dans la branche d'origine et la nouvelle branche. Pour plus d'informations, consultez Comment : créer un type de build. Bien que vous puissiez modifier les fichiers TeamBuild.proj existants dans la nouvelle branche pour pointer vers les chemins d'accès appropriés, en créant de nouveaux types de build, vous conservez les types de build d'origine qui peuvent encore être utilisés sur la configuration avec branches antérieure.

Comme avec une branche partielle, lorsqu'une branche complète est créée dans un projet d'équipe, une copie du dossier Team Build Types d'origine est effectuée dans l'Explorateur d'équipes. Les types de build qui figurent dans le dossier de la nouvelle branche ne fonctionneront pas automatiquement sur la nouvelle branche, comme c'est le cas avec une branche partielle, ils s'exécuteront sur les chemins d'accès de la branche d'origine. Dans ce cas, il est recommandé de modifier les chemins d'accès aux solutions dans les fichiers TeamBuild.proj afin qu'ils pointent vers le dossier approprié, comme indiqué dans la procédure suivante.

Procédure

Pour remplacer les chemins d'accès d'un fichier TeamBuild.proj par les chemins d'accès de type de build mis à jour en raison d'une opération de branche complète

  1. Pour modifier un type de build existant afin de mettre à jour le chemin d'accès à la solution, le fichier TeamBuild.proj correspondant doit être extrait. Pour plus d'informations, consultez Obtention d'une copie locale des fichiers à partir du serveur du contrôle de code source et Comment : modifier un type de build.

  2. Cliquez avec le bouton droit sur le fichier de type de build et sélectionnez Modifier le type de définition.

  3. Dans le fichier TeamBuild.proj, recherchez la balise <ItemGroup>. Dans la balise <ItemGroup>, mettez à jour le chemin d'accès dans chaque balise SolutionsToBuild, comme illustré dans l'exemple suivant.

    Fichier d'origine copié à partir du dossier de projet d'équipe Alpha :

    Image Copier le code Copier le code
    <ItemGroup>
    <SolutionToBuild Include="$(SolutionRoot)\Alpha\path\Solution1.sln" />
    <SolutionToBuild Include="$(SolutionRoot)\Alpha\path\Solution2.sln" />
</ItemGroup>

    Modifications permettant de refléter le nouveau Beta1 avec branches :

    Image Copier le code Copier le code
    <ItemGroup>
    <SolutionToBuild Include="$(SolutionRoot)\Beta\path\Solution1.sln" />
    <SolutionToBuild Include="$(SolutionRoot)\Beta\path\Solution2.sln" />
</ItemGroup>

  4. Enregistrez le fichier TeamBuild.proj. Les modifications apportées aux chemins d'accès mis à jour dans le fichier affecteront le type de build en avançant.

Sécurité

Team Foundation Server doit vous administrer un droit relatif à la sécurité de build pour que vous puissiez extraire un fichier de type de build. Les droits ou autorisations relatifs à la sécurité Team Foundation Server s'appliquent à cette rubrique. Pour plus d'informations, consultez Droits et autorisations relatifs à la sécurité Team Build.

Voir aussi

Autres ressources

Exécution de builds dans Team Foundation Build


Comment : supprimer un type de build

Comment : supprimer un type de build

Team Foundation Build utilise des types de build pour gérer les conditions sous lesquelles une solution unique ou un jeu de solutions est généré dans un espace de travail de projet d'équipe. Les configurations de build sont supprimées à l'aide de Team Explorer comme décrit dans la procédure suivante.

Pour supprimer un type de build

  1. Dans Team Explorer, sous le nœud de projet d'équipe approprié, double-cliquez sur le dossier de contrôle de version pour ouvrir l'Explorateur du contrôle de code source. Recherchez le type de build que vous souhaitez supprimer dans l'arborescence ${Projet d'équipe}\Team Build Types\{Nom du type de build}\TeamBuild.proj. Le type de build est représenté par le fichier TeamBuild.proj, mais vous devez également supprimer le dossier.

  2. Le dossier du type de build désiré étant sélectionné, choisissez Supprimer dans le menu contextuel. Vous devrez également archiver les modifications qui ont été apportées au répertoire.

  3. L'entrée de type de build est supprimée et l'action supprime tous les fichiers XML sous-jacents.

Sécurité

Le compte de service de couche Application et le compte de service Team Build doivent disposer des autorisations en lecture/écriture sur le site cible pour pouvoir supprimer une build. De même, vous devez disposer du droit de sécurité Administrer une build de Team Foundation Server pour pouvoir supprimer un type de build. Pour plus d'informations, consultez Droits et autorisations relatifs à la sécurité Team Build.

Voir aussi

Tâches

Procédure pas à pas : création d'un type de build dans Team Foundation Build

Concepts

Vue d'ensemble de Team Foundation Build


Extension de Team Foundation Build

Extension de Team Foundation Build
DropDown image

Team Foundation Build est un système extensible pour les services d'automatisation de la génération qui active les builds publiques de bout en bout qui s'intègrent avec d'autres outils Visual Studio Team System. Team Foundation Build fournit une méthode simple basée sur un Assistant pour créer des types de build. Vous pouvez spécifier l'ordinateur de build à utiliser, les solutions à générer, l'emplacement cible, les tests à exécuter, etc à l'aide de l'Assistant. Le résultat d'un type de build créé à l'aide de l'Assistant est un jeu de scripts de build MSBuild utilisés par Team Foundation Build avec le moteur MSBuild pour exécuter les builds.

Team Foundation Build est conçu pour être extensible. L'Assistant Création d'un nouveau type de build d'équipe est conçu pour créer des scripts de build adaptés aux scénarios de génération communs ; toutefois, certains scénarios de génération peuvent requérir la personnalisation des scripts générés par l'Assistant. Team Foundation Build inclut des tâches courantes pour prendre en charge des actions telles que l'exécution de tests et l'obtention de sources à partir du contrôle de code source, mais votre processus de génération peut requérir l'exécution d'autres tâches dans le cadre du processus de génération. Par exemple :

  • Un administrateur de génération peut souhaiter déployer ses assemblys de sortie vers un emplacement spécifié à la fin de la compilation, mais avant le début des tests.

  • Une société peut requérir un système de numérotation de build spécifique et substituer l'un des systèmes de numérotation par défaut inclus dans Team Foundation Build.

  • Un développeur peut souhaiter signer ses assemblys de sortie à la fin de son processus de génération.

Cette section décrit la personnalisation des processus de génération en écrivant des tâches personnalisées.

Dans cette section

Présentation des fichiers de configuration de Team Foundation Build

Procédure pas à pas : extension de Team Foundation Build

Rubriques connexes

MSBuild

Référence MSBuild

Voir aussi

Autres ressources

Administration de Team Foundation Build


Présentation des fichiers de configuration de Team Foundation Build

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Présentation des fichiers de configuration de Team Foundation Build
Voir aussi
Image de liste déroulante

Team Foundation Build est basé sur le moteur MSBuild. L'intégralité du processus Team Foundation Build est contrôlée par un jeu des fichiers XML qui adhèrent au schéma de fichier projet MSBuild. Les éléments suivants de ces fichiers XML sont importants pour le processus de génération :

  • Élément Target. L'élément Target définit le mode de génération du projet. Les éléments Target contiennent un jeu des tâches que MSBuild exécute séquentiellement. Pour plus d'informations sur les cibles, consultez Cibles de MSBuild.

  • Élément Task. L'élément Task spécifie le code qui s'exécutera pendant le processus de génération. Pour plus d'informations sur les tâches, consultez Tâches MSBuild.

    MSBuild est fourni avec une collection de tâches courantes qui peuvent être utilisées pour personnaliser le processus de génération. Pour plus d'informations, consultez Référence des tâches MSBuild.

  • Élément UsingTask. L'élément UsingTask spécifie l'assembly qui contient les tâches utilisées dans le processus de génération.

Les fichiers de script MSBuild peuvent importer d'autres fichiers de script. Par exemple, vous pouvez définir une configuration commune dans un fichier puis l'inclure dans d'autres configurations. Pour plus d'informations, consultez Comment : utiliser la même cible dans plusieurs fichiers projet.

Deux fichiers contrôlent le processus Team Foundation Build :

  • Microsoft.TeamFoundation.Build.targets

    Ce fichier définit le jeu de tâches et de cibles par défaut fourni avec Team Foundation Build (cibles telles que Clean, DropBuild, et Compile). Chaque cible contient les tâches à appeler pour cette cible particulière. Certaines cibles de ce fichier dépendent d'autres cibles pour former une chaîne de cibles à exécuter dans un ordre particulier. Par exemple, la cible Compile dépend de la cible BeforeCompile si bien que toutes les tâches définies dans la cible BeforeCompile sont exécutées avant la cible Compile. Toutes les cibles définies dans ce fichier ne sont pas nécessairement exécutées dans chaque build. Par exemple, les générations de bureau n'exécutent pas la cible Clean.

    Microsoft.TeamFoundation.Build.targets est fourni avec Visual Studio Team System et se trouve dans le répertoire MSBuildExtensionsPath\Microsoft\VisualStudio\v8.0\TeamBuild\. Une seule copie de ce fichier est disponible par ordinateur et elle est partagée par toutes les builds qui s'exécutent sur cet ordinateur. Les clients ne sont pas invités à modifier le fichier.

  • TfsBuild.proj

    Il s'agit du fichier de configuration principal pour Team Foundation Build et il existe un fichier pour chaque type de build. Les paramètres de configuration que vous fournissez dans l'Assistant Création d'un nouveau type de build d'équipe sont stockés dans ce fichier. Ils incluent l'ordinateur de build, le répertoire utilisé pour la génération, l'emplacement cible et les solutions à générer. Ce fichier est créé par l'Assistant Création d'un nouveau type de build d'équipe lorsqu'un utilisateur définit un nouveau type de build. Ce fichier importe Microsoft.TeamFoundation.Build.targets et est transmis à MSBuild. Toute modification apportée à ce fichier affecte les builds de ce type de build. Ce fichier est stocké dans le contrôle de code source sous le dossier $\MyProject\TeamBuildTypes\BuildType où MyProject est le nom du projet d'équipe et BuildType est le nom du type de build.

Ordre cible

Le fichier Microsoft.TeamFoundation.Build.targets définit les cibles communes pour Team Foundation Build et l'ordre dans lequel ces cibles sont appelées pendant le processus de génération. L'ordre d'exécution des cibles est répertorié ci-dessous. Les cibles en gras sont définies pour l'extensibilité et vous devez insérer vos tâches dans l'une d'entre elles selon vos besoins. Il n'est pas recommandé de modifier les autres cibles.

  1. BeforeEndToEndIteration

  2. BuildNumberOverrideTarget

  3. InitializeEndToEndIteration

  4. BeforeClean

  5. CoreClean

  6. AfterClean

  7. Clean

  8. InitializeBuild

  9. BeforeGet

  10. InitializeWorkspace

  11. CoreGet

  12. AfterGet

  13. PreBuild

  14. BeforeCompile

  15. CoreCompile

  16. AfterCompile

  17. Compile

  18. GetChangeSetsAndUpdateWorkItems

  19. PostBuild

  20. BeforeTest

  21. CoreTest

  22. AfterTest

  23. Test

  24. PackageBinaries

  25. TeamBuild

  26. BeforeDropBuild

  27. CoreDropBuild

  28. CopyLogFiles

  29. AfterDropBuild

  30. DropBuild

  31. AfterEndToEndIteration

  32. EndToEndIteration

Voir aussi

Tâches

Procédure pas à pas : extension de Team Foundation Build

Autres ressources

Extension de Team Foundation Build
Concepts MSBuild


Procédure pas à pas : extension de Team Foundation Build

 Image de liste déroulante Image de pointage sur liste déroulante Image de réduction Image de développement Image Réduire tout Image Développer tout Copier l'image de pointage
Visual Studio Team System
Procédure pas à pas : extension de Team Foundation Build
Voir aussi
Image Réduire tout Image de liste déroulante

Vous pouvez étendre Team Foundation Build en créant vos propres tâches personnalisées et en les exécutant pendant une génération. Cette rubrique explique les étapes nécessaires pour étendre un type de build à l'aide d'une tâche personnalisée.

Image de développement Création d'un type de build

Utilisez l'Assistant Création d'un nouveau type de build d'équipe pour créer un type de build. Cela permet de créer le fichier TfsBuild.proj et de l'archiver dans le contrôle de code source. Vous pouvez modifier ce fichier pour personnaliser le type de build. Pour plus d'informations sur la création des types de build, consultez Comment : créer un type de build.

Image de développement Création de tâches personnalisées

Les tâches fournissent le code exécuté pendant le processus de génération et sont contenues dans les éléments Target des fichiers projet MSBuild. MSBuild est le moteur derrière Team Foundation Build et les tâches personnalisées doivent être dans un format compréhensible par MSBuild. Chaque tâche doit être implémentée comme une classe .NET qui implémente l'interface ITask, qui est définie dans l'assembly Microsoft.Build.Framework.dll.

Vous pouvez suivre deux approches pour implémenter une tâche :

  • Implémentez l'interface ITask directement.

  • Dérivez votre classe de la classe d'assistance, Task, qui est définie dans l'assembly Microsoft.Build.Utilities.dll. Task implémente ITask et fournit des implémentations par défaut de certains membres ITask.

Dans les deux cas, vous devez ajouter à votre classe une méthode nommée Execute, qui est la méthode appelée lorsque la tâche s'exécute. Cette méthode ne prend pas de paramètres et retourne une valeur Boolean : true si la tâche a réussi ou false si elle a échoué. L'exemple suivant montre une tâche que n'exécute aucune action et retourne true.

C# Image Copier le code Copier le code
using System;
using Microsoft.Build.Framework;
using Microsoft.Build.Utilities;

namespace MyTasks
{
    public class SimpleTask : Task
    {
        public override bool Execute()
        {
            return true;
        }
    }
}

Les tâches peuvent également accepter des paramètres, déclencher des événements et enregistrer la sortie dans un journal. Pour plus d'informations, consultez Tâches MSBuild et Vue d'ensemble de MSBuild.

Image de développement Extraction de TfsBuild.proj

Après avoir écrit votre tâche, vous devez l'inscrire et l'appeler dans l'une des cibles afin que votre code de tâche s'exécute au point désiré dans le processus de génération. Vous trouverez le fichier TfsBuild.proj dans le dossier $/MyTeamProject/TeamBuildTypes/MyBuildName dans votre contrôle de code source Visual Studio Team System, où MyTeamProject est le nom de votre projet d'équipe et le nœud racine de toutes les sources de votre projet d'équipe et où MyBuildName est le nom que vous avez donné à votre type de build lorsque vous l'avez créé à l'aide de l'Assistant Création d'un nouveau type de build d'équipe. Chaque type de build est stocké dans un dossier du dossier TeamBuildTypes sous le nœud racine du projet d'équipe.

Remarque Remarque

Ne modifiez pas le fichier Microsoft.TeamFoundation.Build.targets parce que les personnalisations s'appliqueront à toutes les générations sur cet ordinateur.

Pour plus d'informations sur l'extraction de fichiers, consultez Utilisation du contrôle de code source Team Foundation.

Image de développement Inscription de votre tâche

Après avoir créé votre tâche, vous devez l'inscrire en spécifiant votre tâche dans un élément UsingTask du fichier TfsBuild.proj. L'élément UsingTask mappe la tâche à l'assembly qui contient l'implémentation de la tâche. Pour plus d'informations, consultez UsingTask, élément (MSBuild).

Pour inscrire une tâche personnalisée

  1. Ouvrez le fichier TfsBuild.proj.

  2. Ajoutez un élément UsingTask au fichier et spécifiez les détails de votre tâche. Par exemple :

    Image Copier le code Copier le code
    <UsingTask
    TaskName="MyTasks.SimpleTask"
    AssemblyName="MyAssembly.Build.Tasks"/>

    - ou -

    Image Copier le code Copier le code
    <UsingTask
    TaskName="MyTasks.SimpleTask"
    AssemblyFile="MyAssembly.Build.Tasks.dll"/>

    - ou -

    Image Copier le code Copier le code
    <UsingTask
    TaskName="MyTasks.SimpleTask"
    AssemblyFile="c:\somediskpath\MyAssembly.Build.Tasks.dll"/>

  3. Enregistrez le fichier.

Image de développement Exécution de la tâche personnalisée

Maintenant que vous avez créé et inscrit votre tâche, vous devez spécifier le point dans le processus de génération au niveau duquel vous souhaitez exécuter votre tâche.

Pour exécuter une tâche

  1. Choisissez où vous souhaitez exécuter votre tâche personnalisée dans le processus de génération. Pour plus d'informations sur l'extension du processus de génération, consultez Présentation des fichiers de configuration de Team Foundation Build.

  2. Ouvrez TfsBuild.proj et ajoutez l'élément Target que vous avez choisi ci-dessus.

  3. Ajoutez l'élément de tâche pour exécuter votre tâche à l'intérieur de l'élément Target. Par exemple, le XML suivant dans TfsBuild.proj exécute la tâche SimpleTask dans la cible BeforeGet qui s'exécute immédiatement avant la cible Get.

    Image Copier le code Copier le code
    <Target Name="BeforeGet">
    <SimpleTask />
</Target>

  4. Enregistrez le fichier.

Image de développement Archivage de fichiers

Vous devez archiver le fichier TfsBuild.proj pour que les modifications prennent effet. Team Foundation Build copie ce fichier du contrôle de code source vers l'ordinateur de build. Ainsi, les modifications apportées à votre copie locale n'affecteront pas la génération. Pour plus d'informations sur l'archivage de fichiers dans le contrôle de code source, consultez Comment : archiver les modifications en attente.

Si vous avez besoin de Team Foundation Build pour copier la DLL de tâche vers l'ordinateur de build, vous devez ajouter la DLL de tâche au contrôle de code source sous le nœud de projet d'équipe.

Image de développement Exemple de tâche

Cet exemple permet de créer une tâche personnalisée qui étend le type de build MyBuildType en enregistrant la taille des fichiers produits par la génération. L'exemple se divise en deux parties :

  • Le code de la tâche.

  • Le fichier TfsBuild.proj.

Les informations enregistrées de cette tâche peuvent être consultées dans le fichier journal de génération, Buildlog.log qui se trouve dans le dossier cible de build. Le journal de génération contient des informations semblables aux éléments suivants :

La taille totale est de 9216 octets dans le répertoire d:\BuildDir\MyTeamProj\MyBuildType\sources\..\Binaries\Release

Image de développement Code de tâche C#

L'exemple suivant contient le code qui calcule la taille binaire totale en ajoutant la taille des fichiers dans le dossier des binaires.

Remarque Remarque

Tous les binaires générés lors d'une génération se trouvent dans le dossier Binaries du répertoire de build sur l'ordinateur de build.

Pour que cette tâche soit incluse dans une génération, la DLL compilée doit être archivée dans le contrôle de code source sous le dossier du projet d'équipe. Cela garantit que le fichier sera copié vers l'ordinateur de build lors d'une génération.

Le code suivant calcule la taille des binaires présents dans le dossier Binaires du répertoire de build. La propriété de racine de la solution est passée à cette tâche par le script Team Foundation Build.

C# Image Copier le code Copier le code
using System;
using System.Collections.Generic;
using System.Text;
using Microsoft.Build.Framework;
using Microsoft.Build.Utilities;
using System.Diagnostics;
using System.IO;

namespace BuildTask
{
    public class BinSize : Task
    {
        private string sourceDir;

        [Required]
        public string SourceDir
        {
            get { return sourceDir; }
            set { sourceDir = value; }
        }
        public override bool Execute()
        {
            string szDir = sourceDir + "\\..\\Binaries";
            ProcessDirectory(szDir);
            return true;
        }
        private void ProcessDirectory(string targetDirectory)
        {
            // Process the list of files found in the directory.
            string[] fileEntries = Directory.GetFiles(targetDirectory, "*.*");
            if (fileEntries.Length > 0)
            {
                dwSize = 0;
                szCurrDir = targetDirectory;
                foreach (string fileName in fileEntries)
                    ProcessFile(fileName);
                ////////////////////////////////////////////////////////////////////////
                // This log message would just print out a line in the build log file.
                // You need to add code to do what you need to do with this data. e.g.
                // publishing it into the warehouse for reporting.
                ///////////////////////////////////////////////////////////////////////
                Log.LogMessage("The total size of is {0} bytes in {1} dir",
                    dwSize, targetDirectory);
            }
            // Recurse into subdirectories of this directory.
            string[] subdirectoryEntries = Directory.GetDirectories(targetDirectory);
            foreach (string subdirectory in subdirectoryEntries)
                ProcessDirectory(subdirectory);
        }
        private void ProcessFile(string path)
        {
            FileInfo fi = new FileInfo(path);
            dwSize = dwSize + fi.Length;
        }
        private long dwSize;
        private string szCurrDir;
    }
}

Image de développement Fichier TfsBuild.proj

Une fois que la tâche est compilée et archivée dans le contrôle de code source, elle doit être appelée depuis le fichier TfsBuild.proj. Dans cet exemple, la tâche doit être appelée après que les fichiers ont été compilés et que tous les binaires ont été copiés dans le répertoire Binaries. Par conséquent, la tâche doit être exécutée dans la cible BeforeDropBuild. Pour plus d'informations sur les cibles extensibles dans TfsBuild.proj, consultez Présentation des fichiers de configuration de Team Foundation Build.

L'exemple suivant contient le code dans le fichier TfsBuild.proj modifié. L'exemple XML est presque entièrement généré par l'Assistant Création d'un nouveau type de build d'équipe à l'exception de l'élément UsingTask et de l'élément Target situés à la fin du fichier.

Image Copier le code Copier le code
<?xml version="1.0" encoding="utf-8"?>
<Project DefaultTargets="DesktopBuild" xmlns="http://schemas.microsoft.com/developer/msbuild/2003">
  <!-- TO EDIT BUILD TYPE DEFINITION

  To edit the build type, you will need to edit this file which was generated
  by the Create New Build Type wizard.  This file is under source control and
  needs to be checked out before making any changes.

  The file is available at -
      $/{TeamProjectName}/TeamBuildTypes/{BuildTypeName}
  where you will need to replace TeamProjectName and BuildTypeName with your
  Team Project and Build Type name that you created

  Checkout the file
    1. Open Source Control Explorer by selecting View -> Other Windows -> Source Control Explorer
    2. Ensure that your current workspace has a mapping for the $/{TeamProjectName}/TeamBuildTypes folder and
       that you have done a "Get Latest Version" on that folder
    3. Browse through the folders to {TeamProjectName}->TeamBuildTypes->{BuildTypeName} folder
    4. From the list of files available in this folder, right click on TfsBuild.Proj. Select 'Check Out For Edit...'

  Make the required changes to the file and save

  Checkin the file
    1. Right click on the TfsBuild.Proj file selected in Step 3 above and select 'Checkin Pending Changes'
    2. Use the pending checkin dialog to save your changes to the source control

  Once the file is checked in with the modifications, all future builds using
  this build type will use the modified settings
  -->
  <!-- Do not edit this -->
  <Import Project="$(MSBuildExtensionsPath)\Microsoft\VisualStudio\v8.0\TeamBuild\Microsoft.TeamFoundation.Build.targets" />
  <ProjectExtensions>
    <!--  DESCRIPTION
     The description is associated with a build type. Edit the value for making changes.
    -->
    <Description>
    </Description>
    <!--  BUILD MACHINE
     Name of the machine which will be used to build the solutions selected.
    -->
    <BuildMachine>MyBuildMachine</BuildMachine>
  </ProjectExtensions>
  <PropertyGroup>
    <!--  TEAM PROJECT
     The team project which will be built using this build type.
    -->
    <TeamProject>MyTeamProject</TeamProject>
    <!--  BUILD DIRECTORY
     The directory on the build machine that will be used to build the
     selected solutions. The directory must be a local path on the build
     machine (for example, c:\build).
    -->
    <BuildDirectoryPath>d:\build</BuildDirectoryPath>
    <!--  DROP LOCATION
      The location to drop (copy) the built binaries and the log files after
     the build is complete. This location must be a valid UNC path of the
     form \\Server\Share. The build machine service account and application
     tier account must have read write permission on this share.
    -->
    <DropLocation>\\MyDropServer\drops</DropLocation>
    <!--  TESTING
     Set this flag to enable/disable running tests as a post build step.
    -->
    <RunTest>true</RunTest>
    <!--  WorkItemFieldValues
      Add or edit key value pairs to set values for fields in the work item created
      during the build process. Please make sure the field names are valid
      for the work item type being used.
    -->
    <WorkItemFieldValues>Priority=1;Severity=1</WorkItemFieldValues>
    <!--  CODE ANALYSIS
       To change CodeAnalysis behavior, edit this value. Valid values for this
       can be Default, Always, or Never.

     Default - To perform code analysis according to individual project settings.
     Always - To always perform code analysis irrespective of project settings.
     Never - To never perform code analysis irrespective of project settings.
     -->
    <RunCodeAnalysis>Default</RunCodeAnalysis>
    <!--  UPDATE ASSOCIATED WORK ITEMS
     Set this flag to enable/disable updating associated work items on a successful build
    -->
    <UpdateAssociatedWorkItems>true</UpdateAssociatedWorkItems>
  </PropertyGroup>
  <ItemGroup>
    <!--  SOLUTIONS
     The path of the solutions to build. To add or delete solutions, edit this
     value. For example, to add a solution MySolution.sln, add following line -
         <SolutionToBuild Include="$(SolutionRoot)\path\MySolution.sln" />

     To change the order in which the solutions are built, modify the order in
     which the solutions appear below.
    -->
    <SolutionToBuild Include="$(SolutionRoot)\ConsoleApplication7\ConsoleApplication7.sln" />
  </ItemGroup>
  <ItemGroup>
    <!--  CONFIGURATIONS
     The list of configurations to build. To add or delete configurations, edit
     this value. For example, to add a new configuration, add the following lines -
         <ConfigurationToBuild Include="Debug|x86">
             <FlavorToBuild>Debug</FlavorToBuild>
             <PlatformToBuild>x86</PlatformToBuild>
         </ConfigurationToBuild>

     The Include attribute value should be unique for each ConfigurationToBuild node.
    -->
    <ConfigurationToBuild Include="Release|Any CPU">
      <FlavorToBuild>Release</FlavorToBuild>
      <PlatformToBuild>Any CPU</PlatformToBuild>
    </ConfigurationToBuild>
    <ConfigurationToBuild Include="Debug|Any CPU">
      <FlavorToBuild>Debug</FlavorToBuild>
      <PlatformToBuild>Any CPU</PlatformToBuild>
    </ConfigurationToBuild>
    <ConfigurationToBuild Include="Debug|x86">
      <FlavorToBuild>Debug</FlavorToBuild>
      <PlatformToBuild>x86</PlatformToBuild>
    </ConfigurationToBuild>
    <ConfigurationToBuild Include="Release|x86">
      <FlavorToBuild>Release</FlavorToBuild>
      <PlatformToBuild>x86</PlatformToBuild>
    </ConfigurationToBuild>
  </ItemGroup>
  <ItemGroup>
    <!--  TEST ARGUMENTS
     If the RunTest is set to true then the following test arguments will be
     used to run tests.

     To add or delete new testlist or to choose a metadata file (.vsmdi) file, edit this value.
     For example, to run BVT1 and BVT2 type tests mentioned in the Helloworld.vsmdi file, add the following -

     <MetaDataFile Include="$(SolutionRoot)\HelloWorld\HelloWorld.vsmdi">
         <TestList>BVT1;BVT2</TestList>
     </MetaDataFile>

     Where BVT1 and BVT2 are valid test types defined in the HelloWorld.vsmdi file.
     MetaDataFile - Full path to test metadata file.
     TestList - The test list in the selected metadata file to run.

     Please note that you must specify the .vsmdi file relative to $(SolutionRoot)
    -->
    <MetaDataFile Include="$(SolutionRoot)\ConsoleApplication7\ConsoleApplication7.vsmdi">
      <TestList>P1 Tests;P2 Tests</TestList>
    </MetaDataFile>
  </ItemGroup>
  <ItemGroup>
    <!--  ADDITIONAL REFERENCE PATH
     The list of additional reference paths to use while resolving references.
     For example,
         <AdditionalReferencePath Include="C:\MyFolder\" />
         <AdditionalReferencePath Include="C:\MyFolder2\" />
    -->
  </ItemGroup>

  <UsingTask TaskName="BuildTask.BinSize" AssemblyFile="$(SolutionRoot)\\tools\\BuildTask.dll" />

  <Target Name="BeforeDropBuild">
    <BinSize SourceDir="$(SolutionRoot)" />
  </Target>

</Project>

Image de développement Voir aussi

Tâches

Comment : écrire une tâche

Concepts

MSBuild

Autres ressources

Extension de Team Foundation Build


Risque potentiel de perte de données en raison de problèmes de fuseau horaire avec la base de données Visual SourceSafe en cours de migration.

Risque potentiel de perte de données en raison de problèmes de fuseau horaire avec la base de données Visual SourceSafe en cours de migration.

Potential data loss due to time zone issues with the Visual SourceSafe Database under migration.

Le convertisseur a détecté des problèmes de fuseau horaire lors de la migration de la base de données Visual SourceSafe. Pour plus d'informations sur les problèmes de fuseau horaire, consultez l'article de Base de connaissances BUG: Using SourceSafe in Multiple Time Zones.

Pendant la migration, le convertisseur essaie de contourner des problèmes pour s'assurer que le nombre maximal de fichiers et de dossiers a migré. Toutefois, le convertisseur n'est peut-être pas capable d'effectuer une migration de toutes les versions. Si vous effectuez une migration d'une base de données Visual SourceSafe qui présente un problème de fuseau horaire, les dates et heures migrées peuvent être inexactes. En outre, le convertisseur peut ne pas être capable d'effectuer une migration des fichiers qui présentent ce problème.


Le partage n'est pas pris en charge dans le contrôle de code source Team Foundation.

Le partage n'est pas pris en charge dans le contrôle de code source Team Foundation.

Sharing is not supported in Team Foundation Source Code Control

Le contrôle de code source Team Foundation ne prend pas en charge le partage. Par conséquent, le convertisseur ne peut pas migrer les liens de partage entre les fichiers partagés. Il se peut que vous ayez à réorganiser les fichiers qui sont des fichiers partagés entre des projets. Pendant la migration, les fichiers partagés sont migrés en créant une version dans le dossier de destination à l'aide du même contenu que la version du fichier lorsque vous avez commencé le partage. À partir de là, les modifications apportées au fichier partagé sont répliquées vers les deux emplacements.

Le partage est une condition préalable au branchement. Par conséquent, le convertisseur ne peut pas associer une branche Visual SourceSafe à une branche de contrôle de code source Team Foundation. La migration d'un fichier partagé vous fournit un réplica du fichier dans le dossier de destination. La migration des événements de branche signifie que les modifications apportées à un fichier partagé ne sont plus répliquées vers les deux emplacements. Par conséquent, les modifications apportées à une branche sont migrées vers la copie respective dans Team Foundation.


TFSAdminhxs {2DDA7CF9-E8CF-4df1-98E8-521EDE1C5FC7}

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
TFSAdminhxs {2DDA7CF9-E8CF-4df1-98E8-521EDE1C5FC7}
Image de liste déroulante

TFSAdminhxs {2DDA7CF9-E8CF-4df1-98E8-521EDE1C5FC7}

{2DDA7CF9-E8CF-4df1-98E8-521EDE1C5FC7}

{2DDA7CF9-E8CF-4df1-98E8-521EDE1C5FC7}

Graphique Rubrique Recherche en texte intégral et débogage d'index


Perte de données due au déplacement d'un dossier source qui n'est pas en cours de migration vers un dossier de destination en cours de migration

Perte de données due au déplacement d'un dossier source qui n'est pas en cours de migration vers un dossier de destination en cours de migration

Data loss due to folder move from source folder not under migration to destination folder under migration

Ce type de perte de données se produit lorsqu'il y a un événement de déplacement de dossier entre un dossier (source) qui n'est pas en cours de migration vers un autre dossier (destination) en cours de migration dans Visual SourceSafe. Après la migration, le dossier déplacé apparaît dans le dossier de destination comme s'il avait été ajouté lors de son déplacement effectif. L'historique du dossier déplacé et les éléments qu'il contenait avant l'événement de déplacement ne sont pas migrés dans le contrôle de code source Team Foundation. Pour empêcher une telle perte d'historique, migrez ensemble les dossiers source et de destination du dossier Visual SourceSafe déplacé.


Versions ou historique des fichiers et dossiers VSS non extraits par le convertisseur

Versions ou historique des fichiers et dossiers VSS non extraits par le convertisseur

Versions or history of VSS Files and Folders not retrieved by Converter.

Le convertisseur ne peut pas migrer le fichier à cause d'erreurs dans la base de données Visual SourceSafe.


Liste des fichiers extraits.

Liste des fichiers extraits.

List of files currently checked out.

Lorsque les fichiers sont migrés, leur état d'extraction n'est pas conservé. Cet avertissement fournit une liste des fichiers qui ont été extraits pendant la migration ou l'analyse. Vous devez archiver ces fichiers avant la migration.


Noms d'étiquettes qui seront modifiés en raison de la migration

Noms d'étiquettes qui seront modifiés en raison de la migration

Label names that will change as a result of migration.

Cet avertissement répertorie les noms d'étiquettes qui ont ou qui seront modifiés pendant la migration parce qu'ils contiennent des caractères qui ne sont pas pris en charge dans Team Foundation Server.


Liste des fichiers dont la propriété Visual SourceSafe de 'conservation de la dernière version uniquement' est activée.

Liste des fichiers dont la propriété Visual SourceSafe de 'conservation de la dernière version uniquement' est activée.

List of files with the Visual SourceSafe property ‘keep latest version only’ enabled.

Lorsque cette option est définie dans la base de données Visual SourceSafe, les versions antérieures de ces fichiers ne peuvent pas être récupérées. Puisque le contrôle de code source Team Foundation ne possède pas de fonctionnalité semblable, pendant la migration, le convertisseur crée un fichier vide pour chaque version de fichier.


Perte de données due au déplacement d'un dossier source qui est en cours de migration vers un dossier de destination qui n'est pas en cours de migration

Perte de données due au déplacement d'un dossier source qui est en cours de migration vers un dossier de destination qui n'est pas en cours de migration

Data loss due to folder move from source folder under migration to destination folder not under migration

Ce type de perte de données se produit lorsqu'il y a un événement de déplacement de dossier entre un dossier (source) en cours de migration vers un autre dossier (destination) qui n'est pas en cours de migration dans Visual SourceSafe. Après la migration, le dossier déplacé apparaît dans le dossier de destination comme s'il avait été ajouté lors de son déplacement effectif. L'historique du dossier déplacé et les éléments qu'il contenait avant l'événement de déplacement ne sont pas migrés dans le contrôle de code source Team Foundation. Pour empêcher une telle perte d'historique, migrez ensemble les dossiers source et de destination du dossier Visual SourceSafe déplacé.


Impossible d'afficher le rapport de migration

Impossible d'afficher le rapport de migration

Cannot View Migration Report

Si vous ne pouvez pas consulter le rapport de migration, vous avez probablement déplacé le fichier XML, mais vous n'avez pas déplacé le fichier XSLT que le rapport de migration requiert pour s'afficher correctement. Ouvrez le rapport de migration à partir de l'emplacement d'origine ou copiez le dossier _MigrationReport_Files qui contient le fichier XSLT et d'autres fichiers connexes au même emplacement.