Managing Content with Microsoft® SharePoint™ Portal Server 2001

Microsoft SharePoint Portal Server 2001

Welcome to Managing Content

This online documentation is designed to provide you with information about planning your SharePoint Portal Server deployment.

SharePoint Portal Server provides integrated workflow, document sharing, and search features to help you organize, share, and find important information located throughout your organization.

SharePoint Portal Server can help you:

  • Organize information using workspace folders, approval workflows for publishing documents, document profiling and categorization.

  • Share information in the workspace and on the dashboard site.

  • Find information using the search features on the dashboard site included with SharePoint Portal Server.

© 2001 Microsoft Corporation. All rights reserved.


Before You Begin

Microsoft® SharePoint™ Portal Server combines document management with a rich, customizable dashboard site to enable users to locate, write, review, and manage content in their organization.


About This Guide

Managing Content with Microsoft® SharePoint™ Portal Server 2001 introduces you to the features, concepts, and terminology of SharePoint Portal Server. This guide provides you with information that you can use to plan your deployment.

This guide is designed for everyone from general users to teams of knowledge strategists or corporate librarians. Users do not need to be system administrators, but they should have a working knowledge of Microsoft Office. Often, a concept in one chapter depends on content in an earlier chapter. Therefore, it is recommended that you read the entire guide before you install SharePoint Portal Server.

For planning information that has become available since this guide was printed, see the Microsoft Web site at www.microsoft.com.


Documentation Roadmap

Users can view Help documentation from the User’s Help page in the workspace or from the Tours and User’s Help quick link on the default home page of the dashboard site. There is an additional link to Help documentation from the Getting Started page in the Management folder, which is accessible to the users who administer the workspace. A link to Getting Started is also on the default home page of the dashboard site.

Documentation Provided with SharePoint Portal Server

Managing Content. An overview of the product along with information about planning and configuring the workspace and the dashboard site.

Planning and Installation. Basic information about installation, product use, and features.

Administrator’s Help. Online documentation providing information about SharePoint Portal Server Administration in Microsoft Management Console (MMC). Additional information is provided about maintenance, performance, and troubleshooting.

Dashboard Site Help. Online documentation providing information about configuring and managing the dashboard site and searching for and using documents.

User’s Help. Online documentation providing procedures for configuring and using the workspace. Describes how to use Web folders to access SharePoint Portal Server.

SharePoint Portal Server Tours. An introduction to SharePoint Portal Server, highlighting key document management and search features.

Readme. Important information that may not be covered in other documentation.

Product Overview for International Customers. An overview of the product for use in countries/regions that do not have a localized version of SharePoint Portal Server.

Resources Available on the World Wide Web

Microsoft Product Support Services. Latest service packs, fixes, white papers, and frequently asked questions (FAQ), plus a searchable knowledge base that contains technical support information and self-help tools. See support.microsoft.com/support.

SharePoint Portal Server Web site on www.microsoft.com. A central source of information about SharePoint Portal Server. See www.microsoft.com/sharepoint.

Training and Certification. Information about training and certification. See www.microsoft.com/trainingandservices.

Course 2095, “Building Knowledge Management Solutions Using Microsoft SharePoint Portal Server,” is a three-day, instructor-led, Microsoft Official Curriculum course. The course provides students with the architectural concepts and the skills necessary to deploy SharePoint Portal Server as a search and document management solution as well as a dashboard site.

To take this course in the United States and Canada, find a training provider on the Web site and register with a Microsoft Certified Technical Education Center (Microsoft CTEC). Outside the United States and Canada, contact your Regional Education Service Center.

MSDN Newsgroups. Web-based forums in which you can share information about developing with Microsoft products, including SharePoint Portal Server. See msdn.microsoft.com/wss.

TechNet. Web-based resource to help you deploy, maintain, and support SharePoint Portal Server. See www.microsoft.com/technet/sharepoint.

Software Development Kit. Information about developing applications for SharePoint Portal Server will be available after product release. It will be part of the Microsoft Developer Network (MSDN®) Platform Software Development Kit available on MSDN.

Digital Dashboard Resource Kit. Technical reference guide with tools. See www.microsoft.com/business/digitaldashboard.

Documentation Available Through Microsoft Press

Resource Kit. Technical reference guide with tools. This documentation will be available after product release. The kit includes:

  • Deployment Guide for migration and integration information

  • Resource Guide for in-depth technical information

See mspress.microsoft.com.


Document Conventions

To help you locate and interpret information easily, this guide uses the following typographic conventions.

Convention | Description
ALL CAPITALS | Acronyms, names of certain commands, and keys on the keyboard.
Bold | Menus and menu commands, command buttons; tab and dialog box titles and options; command-line commands, options, and portions of syntax that must be typed exactly as shown.
Initial Capitals | Names of applications, programs, files, servers, and named windows; directory names and paths.
Italic | Information that you provide, terms that are being introduced, and book titles.
Monospace
 Examples, sample command lines, program code, and program output.

Graphics used to illustrate concepts show views in Microsoft Windows® 2000, Microsoft Internet Explorer, or Office 2000. Users can access SharePoint Portal Server from different operating systems, different browsers, or Office 2000. Depending on your method of access, your view may differ from the graphic display.

Examples and scenarios used to clarify key concepts in this guide refer to a fictional company called Adventure Works. Adventure Works is an outdoor equipment company that specializes in outdoor clothing. Several departments, including Manufacturing, Sales, and Marketing, serve as examples for deploying SharePoint Portal Server.


Microsoft Product Support Services Worldwide

If you are outside the United States and have a question about a Microsoft product, you can get assistance by doing one of the following tasks:

  • Check the information in Help or the product manual.

  • Check the Readme files that come with your product compact discs. These files provide general information that became available shortly before the product was released.

  • See the Microsoft Product Support Services Web site at support.microsoft.com/directory/ww.asp?sd=gn.

If you cannot find a solution, you can receive information about how to obtain product support by contacting the Microsoft subsidiary office in your area.

Contacting a Subsidiary

When you call your local Microsoft subsidiary, be at your computer and have the appropriate product documentation available. Be prepared to provide the following information:

  • Product version

  • Type of hardware, including network hardware, if applicable

  • Operating system

  • Exact wording of any messages that appeared on your screen

  • A description of what happened and what you were doing when the problem occurred

  • A description of how you tried to solve the problem

Important Phone numbers for Microsoft subsidiaries are subject to change. For the most recent listing, see the Product Support Services Web site at support.microsoft.com/directory. If there is no Microsoft subsidiary office in your country/region, contact the establishment from which you obtained your product.

Microsoft Subsidiaries
Argentina
Microsoft de Argentina S.A.
Customer Service:
Phone: (54-11) 4316-4600
Fax: (54-11) 4316-1922
Technical Support:
Phone: (54-11) 4316-4664
Armenia
See Russia
Australia
Microsoft Pty. Ltd.
Phone: (61) 13 20 58
Fax: (61) 2 9023 5021
Technical Support:
Phone: (61) 13 20 58
Austria
Microsoft Ges.m.b.H.
Phone: (43) 1 610 64-0
Fax: (43) 1 610 64-200
Information Services:
Phone: 08000-123 345
Fax: (43) 2236-64595
E-mail: InfoService@microsoft.at
Direct Services:
Phone: (43) 1 795 67028
Fax: (43) 1 795 67029
E-mail: austria@msdirectservices.com
Standard Support:
Installation and handling: (43) 1 50222-2255
Azerbaijan
See Russia
Belgium
Microsoft NV
Phone: +32 2 7043000
Fax: +32 2 7043535
TechNet Subscription: +353 1 703 8738
MSDN Subscription: +32 2 5138684
Microsoft Information Center: +32 2 5133113
Technical Support:
Phone: +32 2 513 32 74 (Dutch speaking)
Phone: +32 2 502 34 32 (English speaking)
Phone: +32 2 513 22 68 (French speaking)
Belorussia
See Russia
Bolivia
See Uruguay
Brazil
Microsoft Informatica Ltda.
Phone: (55) (11) 5514-7100
Fax: (55) (11) 5514-7106/5514-7107
Technical Support:
Phone: (55) (11) 5504-2155
Fax: (55) (11) 5504-2227
Automatic Fax: (55) (11) 5506-8506
Technical Support Bulletin Board Service: (55) (11) 5506-1234
Customer Service:
Phone: (55) (11) 822-5764
Fax: (55) (11) 822-6227
Canada
Microsoft Canada Co.
Head Office Phone: 1 (905) 568-0434
Customer Information Centre: 1 (800) 563-9048
Technical Support:
Desktop Systems including Microsoft Windows® 95: (905) 568-4494
Microsoft Office and Office Components: (905) 568-2294
Other Standard Technical Support: (905) 568-3503
Priority Support Information: (800) 668-7975
Text Telephone (TTY/TDD): (905) 568-9641
Caribbean
Microsoft Caribbean, Inc.
Phone: (809) 273-3600
Fax: (809) 273-3636
Technical Support:
Phone: (408) 953-8086
E-mail: mscasup@microsoft.com
Customer Service:
Phone: (800) 297-5982, for area codes 787 and 809 only
E-mail: msccatus@microsoft.com
Central America
Technical Support:
Phone: (506) 298-2020
Support E-mail: mscasup@microsoft.com
Customer Service:
Phone: (506) 298-2000
E-mail: mscarsup@microsoft.com
Chile
Microsoft Chile S.A.
Phone: 56-2-330-6000
Fax: 56-2-330-6190
Customer Service:
Phone: 56-2-800-330600
Personal Operating System and Applications:
Phone: 56-2-330-6222
Fax: 56-2-341-1439
Colombia
Microsoft Colombia
Phone: (571) 326 4700
Fax: (571) 317 3494
Technical Support:
Línea de Respuesta Microsoft
Phone: (571) 524 0404

Other Cities: 9800 5 10595 y 9800 5 10595
Fax: (091) 524-0405
Croatia
Microsoft Hrvatska d.o.o.
Phone: (+385) (1) 4802 500
Fax: (+385) (1) 4843 688
Product Support:
Phone: (+385) (1) 393539
E-mail: hot-line@microsoft.hr
Customer Service:
Phone: (+385) 0800 300 300
E-mail: info-line@microsoft.hr
Czech Republic
Microsoft s.r.o.
Phone: (+420) (2) 611 97 111
Fax: (+420) (2) 611 97 100
Technical Support:
Phone: (+420) (2) 2150 3222
Denmark
Microsoft Denmark
Phone: (45) 44 89 01 00
Fax: (45) 44 68 55 10
Technical Support:
Phone: (45) 44 89 01 11
Customer Service:
Phone: (45) 44 89 01 90
Dominican Republic
See Central America
Ecuador
Corporation Microsoft del Ecuador S.A.
Phone: (593 2) 460453
Fax: (593 2) 463093
Technical Support:
Phone: (593 2) 258025
Customer Service:
Phone: (593 2) 258025
Egypt
Microsoft Egypt
Phone: 20 2 594 2445
Fax: 20 2 594 2194
Technical Support:
Phone: 20 2 3388724 / 94
Fax: 20 2 3604976
E-mail: mssupport@gbrands.com
England
See United Kingdom
Estonia
Technical Support:
Phone: (+372) 650 49 99
Finland
Microsoft OY
Phone: +358-(0)9-525 501
Fax: +358-(0)9-878 8778
Technical Support:
Phone: +358 (0)9-525-502-500
Customer Service:
Phone: +358 (0)9-525 5026
France
Phone: (33) 825 827 829*
Fax: (33) 01 64-46-06-60
Telex: MSPARIS 604322
Technical Support:
Phone: (33) 825 827 829* access code 1020
Fax: (33) 1 69 28 00 28
Customer Service:
Phone: (33) 0 825 827 829*
*Indigo number
French Polynesia
See France
Georgia
See Russia
Germany
Microsoft GmbH
Phone: ++49 (89) 3176-0
Fax: ++49 (89) 3176-1000
Microsoft Info Service:
Phone: ++49 (1805) 25 11 99*
Fax: ++49 (1805) 25 11 91*
Personal Support (Installation and Handling):
Phone: ++49 (1805) 67 22 55*
*There is a charge for this call
Greece
Microsoft Hellas, S.A.
Phone: (30)(1)61 51 200
Fax: (30)(1)61 06 780
Technical Support:
Phone: (30) (1) 9499100 option 2
Fax: (30) (1) 6109528
Hong Kong SAR
Fax: (852) 2560-2217
Microsoft Information Hotline: (852) 2388-9600
Technical Support:
Personal: (852) 2804-4222
Professional: (852) 2388-9600
Hungary
Microsoft Hungary
Phone: (+36) (1) 437-2800
Fax: (+36) (1) 437-2899
Technical Support:
Phone: (+36) (1) 267-7846 (2MSSUGO)
Customer Service:
Phone: (+36) (1) 267-4636 (2MSINFO)
Iceland
See Denmark
India
Microsoft India
Phone: (91) (80) 559-5733, (91) (11) 629-4600, 629-4601, (91) (22) 285-0193
Fax: (91) (80) 559-7133, (91) (11) 629-2650
Indonesia (SP)
Microsoft Indonesia-Jakarta
Technical Support:
Phone: 62 21 570 42 54
Fax: 62 21 520 81 22
Ireland
See United Kingdom
Technical Support:
Phone: 706 5353
Israel
Microsoft Israel Ltd.
Reception:
Phone: +972-9-952-5353
Fax: +972-9-952-5333
Customer Service & Information Center:
Phone: +972-9-952-5400
Fax: +972-9-952-5411
Technical Free Support for Windows, Office and Microsoft Fun:
Phone: +972-9-952-5400
Fax: +972-9-952-5403
Italy
Microsoft Srl
Phone: (39) (2) 70-398-398
Fax: (39) (2) 7039-2020
Microsoft Rome Office:
Phone: (39) (6) 5095-01
Fax: (39) (6) 5095-0600
Technical Support:
Phone: (39) (2) 70-398-398
Customer Service:
Phone: (39) (2) 70-398-398 (new product information, product literature)
Operatori del Settore IT (Customer Service for IT):
Phone: (39) (2) 70-398-398
Microsoft Consulting Service:
Phone: (39) (2) 70-398-398
Japan
Microsoft Asia Ltd.
Customer Information Center: (81) 3 5354-2300
Product Support (available only in an initial limited period):
Desktop applications, Home products, and Hardware: (81) 3 5354-4500
Internet Explorer and Outlook Express: (81) 3 5354-4543
Windows 95/98 and Other Personal OS: (81) 3 5354-4598
Windows NT Workstation/2000 Professional: (81) 3 5354-4568
Developer Products: (81) 3 5354-4538
Products for Macintosh: (81) 3 5354-4509
Technical Support Services:
Personal/Professional/Premier/Alliance (81) 3 5354-4700
Kazakhstan
See Russia
Kingdom of Saudi Arabia
Microsoft Arabia
Phone: 966 1 218-0808
Fax: 966 1 218-0809
Technical Support:
Phone: 800 124-2255 (toll free)
Fax: 966 1 218-0821
E-mail: saudimss@microsoft.com
Kirgizia
See Russia
Korea
Microsoft CH
Phone: (82) (2) 531-4500
Fax: (82) (2) 531-1724
Customer Satisfaction Center:
Phone: 080-985-2000 (toll free domestic only), (82) (2) 558-8161
Technical Support Center:
Phone: (82) (2) 508-0040
Microsoft FastTips: (82) (2) 3453-7555
Support Sales: (82) (2) 531-4544
Latin America
Microsoft Latin American Headquarters (U.S.A.)
Phone: (305) 489-4800
Fax: (305) 491-1616
Technical Support:
Phone: (214) 714-9100
Customer Service:
Phone: (425) 936-8661
Liechtenstein
See Switzerland
Luxembourg
Microsoft NV
Phone: +32-2-730 39 11
Microsoft Support Network Information Center: +31-800-9977-57
TechNet subscription: +353-1-703 8738
MSDN subscription: +353-1-708-8690
Microsoft Information Center: +32-2-481 52 52
Bulletin board: +32-2-726 85 45
(1200/2400/9600/14400 bd, 8N1, ANSI)
Technical Support:
Phone: +32-2-513 32 74 (Dutch speaking)
Phone: +32-2-502 34 32 (English speaking)
Phone: +32-2-513 22 68 (French speaking)
Malaysia (SP)
Microsoft (Malaysia) Sdn Bhd:
Phone: +6 (03) 757-2266
Fax: +6 (03) 757-2265
Technical Support:
Phone: +6 (03) 793-9595
Fax: +6 (03) 295-2065
Customer Services:
Phone: (Toll-free) 1-800-88-3249
Fax: +6 (03) 758-5011
México
Microsoft México, S.A. de C.V.
267-2110 Atencion a Distribuidores
265-3380 Atencion a Clientes
265-3399 Soporte Sistemas Operativos y Applicaciones de Escritorio
267-2190 Soporte de Servidores y Herramientas de Desarrollo
FastTips: (52)(5) 2612199
Microsoft BBS 628-6200/02 MSMEXICO sin password
Morocco
Microsoft North and West Africa
Phone: 212 2 95 80 80
Fax: 212 2 95 85 85
Customer Service Center:
Phone: 212 2 95 88 88
Fax: 212 2 95 85 85
Email: msnafweb@microsoft.com
Personal Support:
Phone: 212 24 10 41
Fax: 971 4 397 2304
E-mail: msnafweb@microsoft.com
Netherlands
Product Support:
Netherlands (Dutch): (020) 5001005
Netherlands (English): (020) 5001053
Belgium (Dutch): +32 2 513 3274
Belgium (French): +32 2 513 22 68
Belgium (English): +32 2 502 34 32
Luxemburg (French): +32 2 513 2268
Luxemburg (English): +32 2 502 3432
Microsoft Consulting Services Benelux:
Netherlands, Belgium and Luxemburg: +31 (0)20 5001005
Information Services and Subscriptions:
TechNet:
Netherlands: (020) 5001035
Belgium: +32 2 5022176
Luxemburg: +32 2 5022176
Microsoft Developer Network:
Netherlands: (020) 5001037
Belgium: +32 2 5138684
Luxemburg: +32 2 5138684
New Zealand
Microsoft New Zealand Ltd.
Phone: 64 (9) 357-5800
Fax: 64 (9) 358-3726
Technical Support:
Phone: 64 (9) 357-5575
Fax: 64 (9) 357-5577
Northern Ireland
See United Kingdom
Norway
Microsoft Norway AS
Phone: +(47) 22 02 25 00
Fax: +(47) 22 95 06 64
Product Support:
Phone: + (47) 22 02 25 50
Customer Service:
Phone: +(47) 22 02 25 80
Panama
Technical Support:
Phone: (506) 298 2020
E-mail: mscasup@microsoft.com
Customer service:
Phone: (506) 298 2000
E-mail: msccatus@microsoft.com
Papua New Guinea
See Australia
Paraguay
See Uruguay
People’s Republic of China
Microsoft (China) Co. Ltd.
6/F, Beijing Sigma Center
No. 49, Zhichun Road, Haidian District
Beijing, 100080, P.R.C
Phone: 011-86-10-6261 7711
Fax: 011-86-10-6253 6630

Microsoft Asia Regional Engineering Center
19th - 20th Floor, Metro Tower
No. 30 Tian Yao Qiao Road,
Shanghai, 200030, P.R.C.
Phone: 011-86-21-64691188/ 011-86-21-6469 8899
Fax: 011-86-21-6469 1166 / 011-86-21-6469 9900
Peru
Phone: (511) 421-1200
Fax: (511) 421-7307
Technical Support:
Phone: (511) 215-5002, (511) 215-5005
Philippines (SP)
Microsoft Support Services:
Phone: (632) 886-5658
Fax: (632) 886-5657
Toll Free Line: 1-800-1-88-87884 (accessible only from outside Metro Manila)
E-mail: philpss@microsoft.com
Poland
Microsoft Sp. z o.o.
Phone: +(48-22) 661-54-00
Fax: +(48-22) 661-54-34
Information Service: +(48-22) 865-99-33
Technical Support:
Phone: +(48-22) 865-99-66
Portugal
Microsoft Portugal MSFT, Lda.
Phone: (351) 21 4409200
Fax: (351) 21 4412101
Technical Support:
Phone: (351) 21 4409280
Fax: (351) 21 4411655
Puerto Rico
Technical Support:
Phone: (408) 953 8086
E-mail: mscarsup@microsoft.com
Customer service:
Phone: (800) 297 5982, for area codes 787 and 809 only
E-mail: msccatus@microsoft.com
Romania
Microsoft s.r.l.
Phone: (+40) (1) 224 42 21
Fax: (+40) (1) 224 48 16
Technical Support:
Phone: (+40) (1) 203 61 61
E-mail: ro-pss@microsoft.com
Russia
Microsoft Z.A.O.
Microsoft Information Center:
Phone:
Moscow: +7 (095) 916-7171
St. Petersburg: +7 (812) 118-3636
Novosibirsk: +7 (3832) 119-019
Kiev +380 (044) 2305101
Fax:
Moscow: +7 (095) 916-7112
Technical Support:
Phone:
Moscow: +7 (095) 745-5445
St. Petersburg: +7 (812) 118-3636
Novosibirsk: +7 (3832) 119-019
Kiev +380 (044) 2305102
Fax:
Moscow: +7 (095) 916-7112
Scotland
See United Kingdom
Singapore
Microsoft Singapore Pte Ltd
Phone: (65) 337-6088
Fax: (65) 337-6788
Customer services:
Phone: (65) 324-5255
Fax: (65) 324-6181
Product Support Services:
Phone: (65) 378-3600
Slovak Republic
Microsoft Slovakia s.r.o.
Phone: +421-7-5341 9841
Fax: +421-7-5341 9840
Hotline: +421-7-67 296 296
Infoservice: +421-7-67 296 297
Y2K Infoservice: +421-7-67 296 200
Slovenia/Slovenija
Microsoft d.o.o., Ljubljana
Phone: (+386) (0)1 5800 800
Fax: (+386) (0)1 5800 822
Tehnicna podpora: (+386) (0)1 5853 449
South Africa
Microsoft South Africa
All services
Phone: (27) 11 257 0000 or 0860225567 (inside South Africa)
Fax: (27) 11 257 0257
Technical Support:
Fax: (+27)11 257-0424
South East Africa and Indian Ocean Islands
See South Africa
Spain
Microsoft Iberica SRL
Inside Spain
Phone: 902 197 198
Fax: 91 803 8310
Technical Support: 902 197 198
Customer Service: 902 197 198
Fax Back Telephone: 902 197 198
Outside Spain
Phone: (34) 91 353 69 60
Fax: (34) 91 803 8310
Technical Support: (34) 91 353 69 60
Customer Service: (34) 91 353 69 60
Fax Back Telephone: (34) 91 353 69 60
Sweden
Microsoft AB
Phone: +46-(0)8-752 56 00
Fax: +46-(0)8-750 51 58
Customer Service: +46-(0)8-752 56 30
Product Support: +46-(0)8- 752 09 29
Switzerland
Microsoft AG
Phone: 01-839 61 11
Fax: 01-831 08 69
Customer Service:
Phone: 0848-858-868
Microsoft Info-Service:
Fax: 01 311-72-27
Technical Support:
Phone: 0848 80-2255 (German speaking) Installation and Handling
Phone: 022-738 96 88 (French speaking)
Phone: 0848-80-2330 General information about Microsoft Support in Central Europe
Tadzhikistan
See Russia
Taiwan
Phone: (886) (2) 2504-3122
Fax: (886) (2) 2504-3121
Technical Support:
Phone: (886) (2) 2508-9501
Fax: (886) (2) 2508-9575
Thailand
Microsoft (Thailand) Limited
Phone: (662) 266-3300
Fax: (662) 266-3310
Product Support:
Phone: (662) 632-0860 through 632-0863
Fax: (662) 632-0258
Turkey
Microsoft Turkey
Phone: 90 (212) 258 59 98
Fax: (90 (212) 258 59 54
Support Hotline:
Phone: 90 (212) 275 2466
Fax: 90 (212) 272 7755
Turkmenistan
See Russia
United Arab Emirates
Microsoft Gulf and Eastern Mediterranean
Phone: 971 4 397 3888
Fax: 971 4 397 2244
Customer Service Center:
Phone: 971 4 397 5752
Fax: 971 4 397 2304
Email: gemcs@microsoft.com
Personal Support:
Phone: 971 4 397 5443
Fax: 971 4 397 2304
E-mail: mswsgulf@microsoft.com
United Kingdom
Microsoft Limited
Switchboard: (0870) 60 10 100
Fax: (0870) 60 20 100
Technical Support:
Desktop Applications, Home Products, Personal Operating Systems and Hardware: 0870 60 10 100
Developer Products: 0870 50 10 200
Business Systems: 0870 50 10 300
Customers phoning from Ireland should dial 706 5353 for technical support
Uruguay
Technical Support:
Phone: (598) (2) 774934
Fax: (598) (2) 774935
Uzbekistan
See Russia
Venezuela
Microsoft Venezuela
Phone: (582) 276-0500
Fax: (582) 276-0600
Technical Support:
Phone: (582) 993-6755
Wales
See United Kingdom


SharePoint Portal Server Overview

As an organization creates and collects information, employees spend valuable time searching, organizing, and managing that information. Microsoft® SharePoint™ Portal Server 2001 integrates document management and search functions with the tools you use every day. SharePoint Portal Server works with Microsoft Windows® Explorer, Microsoft Office applications and Web browsers to help you create, manage and share content throughout your organization.


Document Management and Publishing

Employees may find large and complex information sources, such as multiple file shares, difficult to organize and use because there is little or no organizational framework in place. The difficulty increases with the addition of information sources such as Web sites, e-mail servers, and databases.

Employees might also have difficulty collaborating with others on documents, controlling access to those documents, and publishing documents in their organization. Important documents can also be lost, overwritten, or hard to find. SharePoint Portal Server offers a number of features to help streamline your document development and avoid these common problems.

To help you manage documents, SharePoint Portal Server offers:

  • Version tracking to record the history of documents

  • Application of descriptive, searchable information to identify a document

  • Document publishing control

  • Automated routing of documents to reviewers

  • Web discussions for online comments by multiple document reviewers

  • Control of document access based on user roles

SharePoint Portal Server helps you collaborate with others, receive feedback from reviewers, identify the document with descriptive information such as keywords, and publish the document to a wide audience.

Version History

SharePoint Portal Server records a document’s history to help you track changes and eliminate the possibility of people overwriting another user’s modifications. To edit a document, you must check it out first. This prevents others from changing it until you check it in. Every time you check in a document, a new version number is assigned to the document and the previous version is archived. When you check out a document, you retrieve the most recent version unless you select an earlier version.

Document Profiles

Document profiles offer a way to add searchable information pertaining to a document. This information can help describe or identify the document more clearly. By default, a profile includes basic properties such as Author and Title. You can easily add custom properties such as Account Number or Project Manager to capture additional information that makes it easier to organize and find documents in your organization.

Document Publishing

Published documents are available for users to search or view on the dashboard site. SharePoint Portal Server supports both private and public versions of a document. You can publish a document automatically each time you save it to the server or you can choose to maintain private document drafts and publish the document when it is complete. You can generate as many drafts as you want before publishing a version of a document.

Approval Routing

Approval routing is an easy way to ensure that a document is adequately reviewed before it is published. When an author chooses to publish a document, it can be routed automatically to one or more people for review before publishing it. Each of these people, called approvers, has the option of approving or rejecting the document. Approvers receive e-mail notification when a document requires review.

Discussions

Using Web discussions, you can conduct online discussions about a document without modifying the document. Instead of using e-mail to discuss a document or trying to capture conversations about a document, authors and reviewers can now communicate with each other through Web discussions. Simultaneous discussions about a document can occur even if one person has the document checked out. Comments are stored as threaded conversations, grouping comments and replies together.

Role-based Security

SharePoint Portal Server uses roles to control access to content. You can assign the coordinator, author, and reader roles to users based on the tasks they perform. Each role identifies a specific set of permissions: coordinators handle management tasks, authors add and update files, and readers have read-only access to published documents. SharePoint Portal Server also offers the option of denying a user access to specific documents.


Indexing and Search Services

In many organizations, valuable documents are stored in many different locations, in a variety of formats. Many server infrastructures do not allow searches across multiple information sources and often only limited text searches. It can also be difficult to determine quickly if the information you seek is included in the search results list. SharePoint Portal Server offers several features that make searches faster and more successful.

To make information easier to find, SharePoint Portal Server offers:

  • A single location to search for information stored in many different places

  • Keyword searches that search the full text of a document and the document’s properties

  • Browsing by topic (categories) to find information

  • Automatic categorization of documents

  • Best Bet classification for documents that are highly relevant to a search

  • Subscriptions to keep you up-to-date on useful information

Whether you are searching for specific information or just want to browse through a group of related documents, SharePoint Portal Server makes finding information easy.

Content Sources

SharePoint Portal Server improves search efficiency by enabling you to search across multiple information sources at the same time. Organizations keep information in a variety of places such as Web sites, file systems, mail servers, and databases. By using a wizard to add a content source, you identify the location of the content you want to make available for searching in order to link that content to your dashboard site. SharePoint Portal Server then indexes information from each content source for quick searches from the dashboard site. With the addition of content sources, the dashboard site is the easiest place to find information, regardless of its location or format.

Full-text Search

The dashboard site provides a full-text search option to search document text and document properties for the keywords you enter. SharePoint Portal Server finds all documents that match your search and returns a list of results. For a more specific search, you can use the advanced search option to add document properties, such as Author, to your search criteria. You can also use a search scope to search only a specific set of documents, such as a folder for press releases or a supplier’s Web site.

Categories

You can organize information in the dashboard site by using categories to group similar documents. This allows users to browse through information by topic. For users who are unfamiliar with where documents are stored, categories help them find what they need. Another advantage is that a document can appear in several different categories. Categories can include documents stored in SharePoint Portal Server and information from additional content sources.

Category Assistant

Categories are an excellent way to organize your information. However, if you have a large number of documents, categorizing them can be a time-consuming task. To simplify the process, SharePoint Portal Server provides an automated categorization tool called the Category Assistant. After you have categorized a few representative documents for each category, the Category Assistant compares those sample documents to the uncategorized documents, and then automatically selects the best category matches.

Best Bets

Best Bets enhance search efficiency and provide guidance to users by directing them to documents considered particularly relevant to their search. A Best Bet is a document selected as the best recommendation for a category or specific keyword. SharePoint Portal Sever displays Best Bets at the top of a search results list.

Subscriptions

Subscriptions notify you about new or updated information on topics that match your interests. You can subscribe to content you find useful: a specific document, all documents in a folder, all documents assigned to a category, or a set of search results. After you subscribe to content, SharePoint Portal Sever notifies you when the content is modified, if a new document matching your criteria is available, or if Web discussion comments about the content are added. You can view your subscription notifications on the dashboard site. You can also choose to receive notifications by e-mail.


The Dashboard Site

SharePoint Portal Server provides a Web site, called the dashboard site, which is created automatically during installation. It offers a centralized access point for finding and managing information. You can use a Web browser to perform document management tasks and searches through the dashboard site. It provides access to information stored inside and outside your organization, allowing users to find and share documents regardless of location or format.

You can customize the home page of the dashboard site to display organizational news and other important information. From the dashboard site, users can perform tasks such as:

  • Search for information

  • Browse through information by categories

  • Subscribe to new or changing information

  • Check documents in and out

  • Review a document’s version history

  • Approve documents for publication

  • Publish documents

The dashboard site uses Microsoft Digital Dashboard technology to organize and display information. A digital dashboard consists of reusable, customizable Web Parts such as Search, Categories, News, and Announcements. You can easily add or remove Web Parts to customize the dashboard site for your organization.


Plan Your Deployment

How can Microsoft® SharePoint™ Portal Server help your organization manage its information? A deployment plan outlines ways to streamline your document management processes and create an effective dashboard site to deliver valuable information to the users in your organization. You can develop a successful deployment plan by understanding what the people in your organization need, how they are most likely to search for information, and what content your organization produces.

This chapter focuses on beginning your deployment by:

  • Learning about the SharePoint Portal Server environment

  • Developing a deployment plan


The SharePoint Portal Server Environment

A SharePoint Portal Server deployment includes preparing the workspace, organizing the dashboard site, and establishing the appropriate security for your organization’s information. Understanding the function of the workspace, the dashboard site, and role-based security will help you create an effective deployment strategy.


Accessing the Workspace

The workspace contains the document library, where documents are stored on the server, along with management tools, the category structure, dashboard site content, and a searchable index of information. A workspace can store any type of file, including spreadsheets, faxes, graphics, audio files, Web pages, presentations, and scripts. A workspace can also contain links to content stored on network file servers, Web sites, Microsoft Exchange servers, Lotus Notes databases, and other SharePoint Portal Server workspaces. An organization can have one workspace or multiple workspaces, depending on its needs. One SharePoint Portal Server computer can host up to 15 workspaces.

You can access a workspace by using:

  • Web browsers. Search for information, browse through the workspace, or perform document management tasks from the dashboard site by using Microsoft Internet Explorer or Netscape Navigator. The address of a workspace is http://ServerName/WorkspaceName.
  • Windows Explorer. Browse through the workspace and perform document management tasks by using a Web Folder shortcut to the workspace under My Network Places.
  • Microsoft Office 2000. Perform document management actions, such as check out and publish, from the File menu in Microsoft Word, Microsoft Excel, and Microsoft PowerPoint®, or go to the workspace by using a Web Folder shortcut.

SharePoint Portal Server integrates document management and search functions with the tools that you use every day.


Introducing the Dashboard Site

When creating a workspace, SharePoint Portal Server also creates an associated Web site. Using a Web browser, a user can perform document management tasks and search for information. This is especially valuable if you have users working on operating systems other than Microsoft Windows® 98, Microsoft Windows NT® 4.0, or Microsoft Windows 2000. Those users do not need to upgrade or change their software to benefit from your SharePoint Portal Server deployment.

The Web site, called the dashboard site, included with SharePoint Portal Server uses Digital Dashboard technology. A digital dashboard consists of Web Parts, which are reusable components that contain Web-based information. Assembling Web Parts in a digital dashboard framework is an easy and flexible way to customize a Web site. The dashboard site included with SharePoint Portal Server packages many key features as Web Parts.

Your dashboard site includes Web Parts that give you access to SharePoint Portal Server search and document management features. In addition, there are four Web Parts for the home page: News, Announcements, Quick Links, and Subscription Summary.

  • The News Web Part displays general items of interest, such as company news, departmental news, or stories from news services. For example, the News Web Part on the home page of a sales and marketing group might display quarterly sales figures or press releases.
  • The Announcements Web Part displays company announcements, departmental events, and so on. For example, the Announcements Web Part in the dashboard site of a sales and marketing group might contain announcements regarding a new employee or a reminder about a department meeting.
  • The Quick Links Web Part displays links to other information of interest, such as company resources. For example, the Quick Links Web Part in the dashboard site of a human resources group might contain links to job openings or benefits information.
  • The Subscription Summary Web Part provides a summary of the current user’s subscription notifications. If you find a document, folder, category, or a set of search results useful, you can subscribe to the content and SharePoint Portal Server notifies you of changes.

You can add value to your dashboard site by adding Web Parts that display business information such as news headlines and stock tickers, collaboration tools such as Microsoft NetMeeting®, or general information such as weather or driving directions. You can also tailor the dashboard to meet the specific needs of your organization by creating custom Web Parts. For example, you could add a Web Part that displays an Excel spreadsheet with your quarterly sales figures. You can also export Web Parts from SharePoint Portal Server to your own Web site. For example, you could use the Search Web Part or Subscription Notifications Web Part in your existing corporate portal.

For more information about customizing the dashboard site, see Dashboard Site Help. You can access Dashboard Site Help from the Help button on any page on the dashboard site. Additional information about digital dashboards is available in the Digital Dashboard Resource Kit (DDRK).


Using Roles to Establish Security

Security is essential, both for document management tasks and for the search function. In document management, it is important to restrict access to sensitive information. In some cases, it is important to restrict the viewing of a document to those who edit or approve it, until it is ready for a larger audience. Security is also important to prevent users from finding documents to which they have no access when they perform searches on the dashboard site.

SharePoint Portal Server roles offer a flexible and secure method to control access to documents. A role is a way to configure permissions for users based on the kinds of tasks they perform. SharePoint Portal Server roles add actions such as check-in, check-out, publish, and approve to traditional file-access permissions, such as Read, Write, and Change. Roles group users who have the same permissions and tasks with specific titles: coordinator, author, and reader.

Each role identifies a specific set of permissions: coordinators handle management tasks, authors add and update files, and readers have read-only access to published documents. Access permissions for the three roles are fixed and cannot be modified. SharePoint Portal Server also offers the option of denying users access to specific documents. Roles are usually specified at the folder level, although you can add coordinators at the workspace level for management tasks.

The roles are:

Coordinator

A coordinator can manage an entire workspace or a specific folder. At the workspace level, coordinators perform administrative tasks such as customizing the dashboard site and managing document profiles, categories, and content sources. The coordinator also creates indexes of updated content when necessary or schedules this to occur automatically.

At the folder level, a coordinator manages folder security by configuring roles. The coordinator can add, edit, or delete documents from the folder and can create subfolders. For enhanced folders, the coordinator selects the appropriate approval process. In addition, the coordinator can undo a document check-out or end the publishing process.

SharePoint Portal Server automatically assigns the person who creates the workspace to the coordinator role at the workspace level and on all folders.

Author

An author can add, edit, delete, or read documents in the folder. In an enhanced folder, authors can also submit a document for publishing. An author can create, rename, and delete folders. Newly created folders inherit the role settings and folder policies from the parent folder. An author cannot change the roles or the approval policy on folders.

Reader

A reader can search for and read documents but cannot add them to the workspace. All folder users have reader permissions by default. In an enhanced folder, readers cannot check out, edit, or delete workspace documents, and cannot view unpublished document drafts.

A user can have different roles for different folders in the same workspace. For example, in one folder a user may be a reader, while in another folder, the same user may be an author. You can assign a role to a user group in addition to an individual. If a user has more than one role in a folder (as an individual and as a member of a group), the least restrictive set of permissions takes precedence.

An additional security setting is Deny Access. Unlike the roles, the Deny Access setting is available only at the document level, not at the folder level. You can deny access to a document for a specific user or group if you do not want that user or group to view the document. Because you deny access to individual documents, you can assign a user to a role for the folder but the user might have no access to a particular document in that folder.

SharePoint Portal Server recognizes security policies in use on your organization’s servers, file shares, and databases during searches. For more information about server security, see “Security Planning” in Planning and Installation. For more information about assigning roles, see “Managing Folder Settings” in User’s Help. If you have the client components installed, you can access User's Help from the Help menu in Windows Explorer when browsing the workspace.


Create Your Deployment Plan

Now that you are familiar with the features and working environment of SharePoint Portal Server, you can start planning your deployment. Begin by assessing your existing content, identifying the needs and habits of your users, and outlining your deployment goals. This information can help you decide how to streamline your document management processes and create an effective dashboard site to deliver valuable information to your organization.

If you are deploying SharePoint Portal Server for a group or organization that you know well, you may already be familiar with the current practices and needs of the organization. Consultations with group members about key goals helps you identify which SharePoint Portal Server features you want to deploy. Coordination with others is especially important if your deployment fits into a larger information management system in your organization. If this is the case, you may want to form a team of key people who understand the goals and requirements of your organization to help you plan an effective deployment.


Examining Your Content

An organization often stores data in many different places, such as file servers, Web sites, and mail servers. Knowing the types of documents that exist in your organization helps you determine the best way to organize your content. If you are uncertain about the location and purpose of the content used by your organization, a content review can help you identify them.

A content review addresses these questions:

  • Who produces content? Who manages it? Content managers can provide information about the people who create the content. They are also the best people to suggest ways to improve the organization of content.

  • Where is content stored? Identify the location of each server used to store content. For example, your group may store discussions about new advertising campaigns in public folders on an Exchange server. Your system administrator can identify the servers used in your organization.

  • What is the purpose of the content? How is it structured? Learn who uses the content and what format is used. For example, you might discover that the product development department stores product specifications as Word documents, and the marketing department uses Lotus Notes to maintain customer profiles.

Knowing where information is stored, and how your organization uses it, helps you clarify your deployment goals.


Assessing User Needs and Habits

If you are uncertain about the needs of your organization, a survey can capture information about the habits and concerns of your users. It can also identify other useful information for planning your deployment.

You can ask users to identify the types of content they find valuable. A user survey could include the following questions:

  • What are the five most useful information sources, content types, or groups of documents for your job? For example, users may list a call-tracking database, spreadsheets listing sales figures, or a folder of design specifications.

  • Are there additional information sources, content types, or groups of documents that would benefit from increased exposure? For example, users may list documents produced in another department or industry publications on the Internet.

  • What information is missing from the current portal? Why is this information important to include? For example, users may list a Web site that offers free tutorials for a software application or a request that the employee handbook be available on the portal.

Responses to these questions help to identify the content that users want to access, even if it is not currently available to them.

You can also ask users how they prefer to find information. Responses to this question help to prioritize your goals for deploying search features. With SharePoint Portal Server, users can locate content in several ways:

  • Users can perform a keyword search, which is the standard way to locate content. Using a specific word or phrase, a keyword search query can produce numerous results. This method appeals to users who want to see all possible content related to a specific query.

  • Users can browse or search through categories, which you add during deployment. Categories group documents by topic and provide an organized view of the information. This method is especially valuable for users who do not know the location of content.

  • Users can navigate through the folder structure to find documents. This method allows users to locate information based on file location. This method may be especially suitable for authors who are familiar with the folder structure in the workspace.

  • When information is visible on the home page, users immediately see it without needing to perform a search. This method works well for content that is relevant to many users.

You can conduct a survey by distributing a questionnaire with detailed questions, whose answers can be analyzed by your planning team. You can also survey your organization by meeting with users to discuss existing practices, work styles and habits, and potential deployment goals. Whether your process is formal or informal, the scope of your deployment and the structure of your organization will determine the approach that you take.


Identifying Your Deployment Goals

Your initial research helps you identify your organization’s information management processes and may uncover some common problems. Analyzing these problems can help you clarify your deployment goals. The following table describes a few typical problems and suggests some of the SharePoint Portal Server features to include in your deployment plan.

Common problem | Deployment goal
It is difficult to track revisions to documents with multiple authors. | Use version control to save changes made to a document and to eliminate the possibility of people overwriting each other’s documents.
Information for the organization is not widely circulated. | Display news, announcements, quick links, and other information on the home page of the dashboard site.
The group lacks control over who accesses content. | Use roles for flexible control over access to content.
There is no process to maintain a private view of a document. | Select a document publication process to ensure that drafts are not visible to readers until the appropriate time.
It is time-consuming to enforce review cycles for documents. | Use an approval process to automatically route documents to designated reviewers.
Information is hard to find on the current portal. | Use categories and Best Bets to organize and highlight relevant content.
Searches are slow because servers are queried one at a time. | Add content sources to create an index of multiple information sources, such as Web servers, file servers, Exchange servers, Lotus Notes databases, and other SharePoint Portal Server workspaces.

From the results of your own research, identify similar problems. This helps you prioritize your deployment goals and configure SharePoint Portal Server to meet the needs of your organization.


Review of Key Concepts and Tasks

You should now have enough information to outline your goals and determine the scope of your efforts. As you learn more about SharePoint Portal Server features in the following chapters, your initial list of goals helps you identify the features to include in your deployment.


Planning Summary

In this chapter, you have learned about the key concepts that define the working environment of SharePoint Portal Server:

  • Purpose of the workspace and methods of accessing it

  • Uses of the dashboard site

  • Value of assigning roles to users as a flexible method of securing content


Planning Tasks

To increase the benefit of SharePoint Portal Server to your organization, create a deployment plan by completing the following tasks:

  1. Review your organization’s content.

  2. Research the needs and habits of your users.
  3. Identify your deployment goals.


Prepare Your Workspace

The document management features of Microsoft® SharePoint™ Portal Server integrate with common tools and applications to help you create, track, and share information. You can perform document management tasks when using Microsoft Word, Microsoft Excel, and Microsoft PowerPoint® applications, or Microsoft Windows® Explorer. In addition, when creating the workspace, SharePoint Portal Server automatically generates a Web site, called the dashboard site, where you can perform document management tasks by using a Web browser.

A workspace is a collection of document folders, management tools, and a searchable index of information. Each workspace initially contains four folders: Documents, Management, Portal Content, and Categories, along with a Web page with links to Help files and configuration wizards. The Documents folder is where documents are stored and managed for the document library in SharePoint Portal Server. Configuring the Documents folder is a large part of preparing the workspace for document management and group collaboration.

This chapter focuses on preparing your workspace for document management by:

  • Designing and configuring the folder structure of the document library

  • Enabling Web Discussions for group collaboration

  • Moving documents into the workspace

If your deployment goals do not include using the document management features, see Chapter 6, “Prepare Your Dashboard Site,” to learn about using the dashboard site to make information easy to find.


Design Your Folder Structure

Examine how your organization creates and uses information before you decide how to store content in the document library. It is important to understand your current document management practices so that you can decide which SharePoint Portal Server features meet the needs of your organization. Careful planning of your folder structure ensures the most benefit from your new workspace.

For example, you might research answers to the following questions:

  • How does the group currently organize their documents?

  • Who has permission to add documents and edit them?

  • Which folders contain documents that may have multiple authors?

  • What should occur before publishing a document?

Talk to the people in your organization. They can help you understand existing processes and identify areas that need improvement. You can then begin to design the folder structure of your document library.


Matching Folder Type with Content

SharePoint Portal Server provides two types of folders for document storage. Enhanced folders support all content management features, including document profiles, public and private views for workspace items, check-in and check-out functions, document version history, and document publishing and approval processes. If you disable enhanced folder settings, you disable check-in, check-out, and versioning for that folder, changing the enhanced folder to a standard folder. SharePoint Portal Server immediately publishes all documents added to standard folders.

SharePoint Portal Server records a history for each file stored in enhanced folders. This helps you track editorial cycles and prevents a user from overwriting another user’s modifications. To edit a document, you must check it out first. This prevents others from changing it until you check it in. Every time you check in or publish a document, a new version number is assigned to the document and the previous version is archived. When you check out a document, you retrieve the most recent version unless you select a previous version. Version history is displayed on the Properties page of the document.

Enhanced folders require users to check out documents for editing and to use the Publish command to make a document visible to readers. Use enhanced folders for documents that require editing, review, or approval before they are made available to users associated with the reader role on the folder. For example, you can store a marketing plan created by a team of people in an enhanced folder. You can see who is working on the file at any time and ensure it receives management approval before it is published.

Note SharePoint Portal Server supports compound, or multi-part, documents only in standard folders. Examples of compound documents are HTML files with relative links, a Microsoft Word document with a linked Microsoft Excel spreadsheet, and a master document created in Microsoft Word.

Comparing Standard and Enhanced Folders

The following table compares the SharePoint Portal Server features supported by each folder type.

Feature | Standard folder | Enhanced folder
Roles | Yes | Yes
Document version history | No | Yes
Check-in/check-out | No | Yes
Private draft versions | No | Yes
Approval routing | No | Yes
Profile metadata | Yes | Yes
Indexed documents | Yes | Yes
Categories | Yes | Yes

Both standard and enhanced folders support SharePoint Portal Server roles. Published documents from both types of folders are included in the index and made available for users to search and read on the dashboard site.

Understanding Folder Inheritance

All folders inherit folder settings from their parent folder unless otherwise specified. The Documents folder in the workspace is enhanced, by default. When you create a new folder in the Documents folder, it inherits this setting. Folder inheritance also occurs when you drag a folder from your computer to the workspace. The folder you drag into the workspace inherits the folder settings of the new parent folder. For example, if the new parent folder is a standard folder, the folder that you drag into the workspace automatically becomes a standard folder. To break the folder setting inheritance, create a new folder in the workspace and enable or disable the folder setting inheritance before moving documents into the new folder.

For information about folder settings, see “Managing Folder Settings” in User’s Help. If you have the client components installed, you can access User’s Help from the Help menu in Windows Explorer when browsing the workspace.


Creating Your Folder Structure

After deciding what type of folder to use for each group of documents, you need to create the folder hierarchy in the workspace. You can duplicate your existing folder structure in the workspace or design a new folder structure.

The quickest method is to duplicate your existing folder structure and make any modifications (combining or dividing folders) necessary to accommodate the desired document management processes. You can drag a folder and its contents into the workspace. The top-level Documents folder is an enhanced folder. Because a folder inherits its settings from the parent folder, any folder you drag into the Documents folder has enhanced folder settings. To break the folder setting inheritance, create a new folder in the workspace, enable or disable the folder setting inheritance as appropriate, and then move the documents into the new workspace folder.

Alternately, you can redesign your structure to take the greatest advantage of SharePoint Portal Server features. This method requires more planning but can yield greater benefits by eliminating redundancy, clarifying processes, and improving document discovery. For an example of a process to redesign a folder structure, see Chapter 5, “Scenario: Workspace Design.”

Three key factors influence how you organize your documents in the workspace:

  • Security and management

  • Document publishing process

  • Document profiles

These factors determine whether you combine folders or separate a folder’s documents into different folders.


Assigning Roles for Security

In document management, it is important to restrict access to sensitive information. In some cases, it is important to restrict the viewing of a document to those who edit or approve it, until it is ready for a larger audience. Each role identifies a specific set of permissions: coordinators handle management tasks, authors add and update files, and readers have read-only access to published documents. Roles offer a flexible and secure way to control user access to workspace documents. You can assign roles to users selected from your existing Microsoft Windows 2000 domain users and groups. SharePoint Portal Server role-based security combines traditional file-access permissions such as Read, Write, and Change, with an extended set of actions such as Check out, Publish, and Approve. You control access to each folder by assigning roles to the appropriate users or groups.

Each user can have multiple roles in the workspace. For example, in one folder, a user may be a reader, while in another folder the same user may be an author. In addition, depending on the level of deployment, one user may perform the duties of both administrator and coordinator. In this situation, the user installs SharePoint Portal Server and creates, customizes, and manages the workspace and dashboard site.

You can distribute management tasks among a number of coordinators. For example, at the workspace level, you can add multiple coordinators to manage the dashboard site, content sources, and index schedules. At the folder level, you can delegate responsibility for managing security and document profiles to the content experts for those folders.

When deciding whether content should be stored in one folder or several, assess security requirements, and evaluate how you can delegate coordinator responsibilities. For example, you may create a folder for each project within a department and assign a project manager as the coordinator on each folder. For more information about roles, see Chapter 3, “Plan Your Deployment.”


Choosing a Publishing Process

Identifying the publication process best suited to your documents helps you decide what folder type to use. Publishing a document creates a public version that is available to readers of a folder. Review the types of documents used in your organization. Which document types can be published immediately? Which document types should remain private until ready for a larger audience of readers?

When you save a document to a standard folder, SharePoint Portal Server publishes it immediately. Therefore, all documents stored in a standard folder are, by default, available for public view. For example, meeting agendas could be stored in standard folders.

In an enhanced folder, unpublished document versions, or drafts, are accessible only to other authors and coordinators for the folder. The Publish action allows you to control when a document changes from a private view to a public view. For example, presentation slides could be stored in an enhanced folder to restrict the audience until they have been reviewed for accuracy.


Adding Approval Routing

Often one or more people must review and approve a document’s content. In this situation, consider adding approval routing to the document publishing process. In approval routing, a document is sent to one or more people, and each person can approve or reject the document. Each step in the approval process is complete when the required people approve or reject the document. An approver receives an e-mail notification when a document requires his review.

You can store published documents in standard or enhanced folders, but only enhanced folders have the option for approval routing. In enhanced folders, you can choose to have a document undergo an approval process before it is made public. Once an author chooses to publish a document, SharePoint Portal Server can automatically route the document to a list of reviewers for approval before successfully publishing it. Each of these people, called approvers, may approve or reject the document. Approval routing provides an easy way to ensure that a document receives adequate review before publication.

Important When you create subfolders, they do not inherit approval process settings from their parent folders. An approval process must be configured for each folder.

SharePoint Portal Server offers two routing options for reviewing a document before publishing it:

  • One after another, called serial approval routing

  • All at once, called parallel approval routing

Both types of approval routing are a series of steps that lead to publication.

Using Serial Approval Routing

A serial approval route (One after another) identifies a list of successive approvers. Each person must approve the document before the next person in the route receives an approval request notification. When the last person on the list approves the document, SharePoint Portal Server publishes the document and makes it available to readers. If any person on the list rejects the document, the approval process ends and the document’s status returns to checked in. A serial route works well in highly structured organizations that use sequential review processes.

Using Parallel Approval Routing

A parallel approval route (All at once) sends e-mail about the document to all approvers at the same time. Parallel routing notifies all approvers simultaneously, instead of the sequential approver notifications used in serial routing. Any approver can approve or reject the document at any time.

Before using a parallel route, you must define the number of approvals required to publish the document. When you establish a parallel approval route for a folder, you can require approval from only one approver or from all of the approvers to publish the document.

For example, a document is sent to three approvers. If only one approval is required, SharePoint Portal Server automatically publishes the document after the first approval. This is especially useful for time-sensitive documents that cannot tolerate delay because a single approver is unavailable. This option suits an informal approval style for a document that does not require everyone on the list to review and approve it.

Requiring unanimous approval is an option that is especially suitable for confidential or highly important documents in which each approver’s vote must be tracked. For example, the members of the board of trustees must review a report detailing a company's five-year financial plan. SharePoint Portal Server sends an e-mail notification about the document to all approvers at the same time. Because this information requires unanimous agreement, SharePoint Portal Server does not publish the document unless all members of the board approve it.

Terminating an Approval Process

A folder coordinator can end an approval process by using either the Bypass Approval action or the Cancel Approval action. These options are useful if a time-sensitive document is under approval and one or more of the approvers are not available to review the document. The Bypass Approval command skips all remaining approvers and publishes the document to the dashboard site. The Cancel Approval command cancels the approval process, which is the equivalent of an approver rejecting the document, and returns the document to an unpublished state in the workspace.

Note Neither of these actions removes the approval routing from the folder; they only override the process for an individual document.

Approving Documents Automatically

If you choose not to configure an approval process for an enhanced folder, SharePoint Portal Server publishes documents automatically upon submission, without review or approval. If you want to take advantage of the version history feature but do not want to apply an approval process, clear the Documents must be approved before publishing check box on the Approval tab of the folder’s Properties page.


Creating Document Profiles and Custom Properties

In many organizations, it is difficult to find documents that contain similar subject matter, especially if the words used in a search query are not in the text of the document. To overcome this problem, you can apply metadata to documents using document profiles. Metadata supplies additional descriptive information for a document, including additional search keywords that may not appear in the text of a document. During a search, SharePoint Portal Server searches a document’s metadata as well as the text of the document.

Metadata matches a property with a value. For example, you can associate a number of values, such as London or Tokyo, with a property called City. A document profile is a collection of properties that provides a consistent way to describe and classify documents. For example, you can create a Marketing Analysis profile to define your market-trend analyses. Document profiles include system-generated metadata such as the file size and modification date. In addition, you can configure document profiles to include custom properties, such as sales region, product, and competitor. A workspace can contain multiple document profiles. After you add a document profile to the workspace, you can assign it to any folder by using the Profiles tab on the Properties page of the specific folder. Every document in the workspace must have a document profile assigned to it.

For example, Eva writes an analysis of a competitor’s product. This product will compete in the market with her organization’s product, the Kodiak coat. Although she does not mention the Kodiak in her document, she decides to include this product name as a keyword property value. After the document is published, Carol uses Kodiak in a search query on the dashboard site. Her search results include Eva’s analysis because the search query found a match in the keyword property value in the document’s metadata.


Planning Document Profiles

Planning for document profiles and properties depends on how you structure the folders in the workspace. You can create document profiles based on how you group documents in your current structure. If you plan to redesign your folder structure, creating custom profiles and properties is a key step in simplifying your folder structure. For an example of the process to redesign a folder structure, see Chapter 5, “Scenario: Workspace Design.”

Before deploying document profiles and properties in your workspace, consider these planning steps:

  1. Decide whether the properties on the Base Document profile are sufficient or you want to create new document profiles with custom properties.

    SharePoint Portal Server supplies a template called the Base Document profile, which you can use to create new document profiles and properties. The Base Document profile consists of the following properties: Title, Author, Keywords, and Description. If you currently have a simple folder structure in which all documents contain similar content, you can apply the Base Document profile to all your documents. However, to aid in successful searching, you can create new document profiles with custom properties to better identify your documents.

  2. Examine your content for descriptive patterns. For each pattern, choose a document profile name.

    Do you see any patterns that suggest how you can group certain documents together with a profile? Look for types of documents found in more than one folder. Plan a profile name for each group of documents. For example, your folders may be separated by competitor name but you see a group of documents that could be described as competitor product analyses. Although the documents are stored in folders for different competitors, you can create a document profile called Competitor Product Analysis and apply it to all of those documents.

  3. For new properties, imagine a word or phrase that people might use to search for these documents.

    When adding new properties, try to anticipate the word or phrase that users may choose in a search query for each document. Talk to the people who create the content and ask which words or phrases they would use to describe it. Choose the properties you need from the words or phrases that people suggest. You can add the specific answers as values for the properties. For example, because you can apply the document profile Competitor Product Analysis to content in folders for two different competitors, you add a new property called Competitor to the document profile. The property values are the names of specific competitors.

  4. Mark essential properties as required. Decide which properties can have multiple values.

    You can make a property required or leave it as an optional field on the document profile. When a property is required, the user must enter a value before checking in a document. Be aware that authors do not consistently enter values for optional properties.

    Note Requiring property values improves discovery of your documents but slows the process of checking documents in. Consider your authors when deciding how many required values to include on your document profiles.

    You can also permit a user to enter multiple values for the same property. For example, in the document profile Competitor Product Analysis, an author could enter the names of two competitors as values for the Competitor property.

  5. For required properties, decide whether values are predetermined or added as needed by authors.

    You can restrict property entries to an established list or allow authors to enter free-text property values. When you add a property to a document profile, you have to decide whether to restrict the property values to an approved list or not.

    Allowing authors to add values as needed is appropriate if your group is small and if users maintain a common vocabulary throughout all content. However, inconsistencies can appear when users enter values in an unrestricted manner. Consider designating one person in your group to review all values entered on document profiles. For example, as part of the editorial process, an editor can evaluate the appropriateness of the property values selected by the author on the document profile.

    Preventing authors from adding new values ensures consistency throughout all document profiles and improves search success. Restricting entries to an established list requires some planning to create a controlled vocabulary for selected properties. However, this task is more manageable if you consult the people who create the content.

For more information about document profiles and properties, see "Managing the Workspace” in User’s Help.


Emphasizing Subjects with Keywords

A keyword is one of the properties available on document profiles. When a search query matches a value in a document’s Keywords property, the document appears toward the top of a search results list, because SharePoint Portal Server weights a match in the Keywords property more heavily than a match in the document body text.

You have two options for allowing authors to add keyword values to a document profile:

  • Authors can add values as needed for the property on the profile form. SharePoint Portal Server enables this method by default.

  • Authors must select values from a predetermined list in the property on the profile form.

Like other document profile properties, SharePoint Portal Server displays the values for the Keywords property as a list of terms an author can select when completing the profile form. If this list is not restricted, an author may either choose a term from the list or enter a new one. Regardless of the method you choose for designating these values, try to keep this list short and manageable so authors can select the correct keyword quickly and accurately.

Adding Keywords as Needed

This method allows authors to add keyword values without restriction. If your group is small, you can create a common vocabulary for authors to use when they complete the Keywords property on the profile form. Distributing a printout of the preferred values with guidelines on how to select the appropriate values for specific document types is one way to clarify the process for your users. This method provides flexibility but a regular review of your keyword list is an essential management practice.

Choosing Keywords from a Restricted List

This method allows you to control the list of pre-approved keyword values available for authors to use. Authors cannot add new values or delete existing ones. This method requires advance planning, but the benefit is consistent use of keywords on all document profiles.

If you decide to use a restricted keyword list but are uncertain how to establish one, consider the following approach:

  1. Allow authors to add values for the Keywords property as needed for a short time. This generates a starter list. Limiting the time allotted to generate this list prevents the list from becoming too large.

  2. Evaluate the list to establish your controlled vocabulary. Take the list to the people who create content and ask them which property values to include in a controlled vocabulary. They may be especially helpful in filtering through variations of a keyword. In addition, you may want to talk to people who might search for the content. Ask them what word or words they would use in their search queries. Do these words match the words in the list that you are refining? After you reduce your list of approved values to a manageable length, you can begin implementing this controlled vocabulary.

  3. Perform a search for any keyword value you want to remove from the list. Check out each document on the search results list and edit the profile to replace the obsolete values with approved values. If the substitute value is new and not yet on the list, it is automatically added to the Keywords property. Check the document back in. At the end of this process, the values listed for the Keywords property may still contain a few obsolete entries, but no documents will have obsolete keywords associated with them.

    Important This step helps you remove inaccurate metadata and avoid check-in delays for documents with obsolete keywords. For example, an author who opens a document with an obsolete keyword would not be able to close it without applying an approved keyword value.

  4. Remove obsolete values from the Keywords value list.

  5. When your value list is complete and accurate, clear the check box labeled Allow users to enter values not in the list.

For information about how to add or remove keywords, see "Managing the Workspace” in User’s Help. If you have the client components installed, you can access User’s Help from the Help menu in Windows Explorer when browsing the workspace.


Enable Web Discussions

Discussions are an excellent way for groups to collaborate on a document. Web Discussions allow users to add remarks about a document without modifying the document itself. Discussions are threaded — replies to a discussion remark appear directly underneath the original remark. In addition, multiple discussions about the same document can occur at the same time. SharePoint Portal Server consolidates comments in a single location, allowing them to be easily reviewed.

Users can access Web discussions from Microsoft Internet Explorer and from the collaboration toolbar in Office 2000. By default, Web discussions for a workspace are enabled. You can prevent users from participating in discussions by disabling Web discussions.

Discussions are stored separately from the document they reference. Even if the document is deleted, the discussions remain in the workspace until you specifically delete them. SharePoint Portal Server maintains only one set of discussions for each document, even though there may be several versions of that document.

You can include discussion items in search results by enabling the search feature for discussions. If you enable the search features for Web discussions, document discussions are included in the index and users with appropriate permissions can search for and view discussions on the dashboard site.

For more information about enabling or disabling Web discussions, enabling or disabling discussion item searches, and managing Web discussions, see "Managing the Workspace” in User’s Help.


Move Documents into the Workspace

After you structure and configure your document library, you can move content into the workspace. Although you can move documents individually, you can also move groups of documents at the same time, or drag folders and their contents into the workspace. If your document library is very large, you can create a script to move your documents into the appropriate document library folders. For information about using scripts to move large numbers of documents, see the SharePoint Portal Server Software Development Kit (SDK).


Moving Multiple Documents

To simultaneously move multiple documents into the workspace, select the documents you want to move, and drag them to the target folder in the workspace. If any documents added to the workspace have names that already exist in the workspace, SharePoint Portal Server prompts you to create new names for the documents you are adding.

You can perform document management tasks on a group of documents as well as individual documents. For example, you can select ten documents, drag them into an enhanced folder, and check them all in at the same time. To do this, drag the folders into the appropriate workspace folder, select the documents, right-click on one of them, and then click Check In. When the profile form appears, you can enter text in the Version Comments field and make any necessary entries to the document profile.

When you check in multiple documents, the profile form appears in bulk edit mode. This means that all of the fields on the form are blank. SharePoint Portal Server applies any information you enter on the profile form to all of the documents you are checking in. If you leave any (or all) fields blank, SharePoint Portal Server does not change those fields on the document profiles of the individual documents.

You can perform other document management tasks, including Publish and Edit Profile, with multiple documents. For more information about managing multiple documents, see “Managing Documents” in User’s Help.


Importing an Existing Folder

You can drag an existing folder from your computer to a document storage folder in the workspace. If you drag a folder from your computer to the workspace, be aware that the folder inherits the settings of the target folder. For example, if the target folder is a standard folder, the folder you drag into the workspace becomes a standard folder also.

Subfolders inherit role assignments but do not inherit approval process settings. You must configure approval settings separately for each new folder. You can use the Properties page of the folder to configure settings such as inheritance of role assignments and approval routing.


Review of Key Concepts and Tasks

This chapter included information about configuring the workspace for document management. As you learn about SharePoint Portal Server features in the following chapters, your preparation can help you gain the most benefit from your new workspace.


Planning Summary

In this chapter, you learned about the key concepts associated with preparing your workspace for document management:

  • Factors that influence folder structure

  • Uses and features of Web discussions

  • Methods of moving content


Tasks to Perform

Based on concepts introduced in this chapter, you should be able to complete the following tasks:

  1. Evaluate document management features and design a workspace folder structure based on:
    • Folder type. Which documents should be stored in enhanced folders and which should be stored in standard folders?

    • Roles. Who creates, manages, and reads the content?

    • Publishing processes. Should documents be published automatically or restricted to a collaborative group until the appropriate time?

    • Approval routing. Do documents need review before publication?

    • Document profiles. Which documents can you group together with similar descriptive properties?
  2. Enable the search feature for Web discussions to allow online remarks about documents.
  3. Move documents into the workspace.


Scenario: Workspace Design

In this scenario, department members create content as a group and manage a large document library. As part of a deployment of Microsoft® SharePoint™ Portal Server, they plan to redesign their folder structure to take maximum advantage of the document management features. This scenario illustrates one group’s process of evaluating and updating their folder structure.


Introduction

Adventure Works is an outdoor equipment company that specializes in outdoor clothing. The manager of the Information Technology (IT) department wants to use SharePoint Portal Server to help his employees share ideas and expertise as the department trains and supports employees, administers the networks, and manages the company’s computer equipment.

Goals

Reorganize the document folder structure to facilitate:

  • Automated publication processes

  • Controlled access to documents

  • Standardized methods of identifying and classifying information

  • Distribution of content management to group managers

Challenge

The group manages an extensive library of documents and adds information regularly. However, its information is stored in a large folder structure that has evolved in inefficient ways. The current structure does not provide an effective method of organizing documents, publishing information, or collaborating on projects.

SharePoint Portal Server Solution

SharePoint Portal Server delivers document access control, versioning capabilities, and approval routing to assist group publication processes. Document profiles make it easy to apply searchable metadata to documents to make them easier to find.

Cast of Characters

  • IT department manager (Garrett)

  • Training supervisor (Jane)

  • Technical support supervisor (Michael)

  • Network administration supervisor (Catherine)

  • Programmer (Matthew)


Create a New Folder Structure

Garrett, who manages the IT group, is deploying SharePoint Portal Server for his department. He knows that the quickest way to move content into the workspace is to drag and drop his existing folder hierarchy into the workspace. However, the current folder structure is difficult to use.

In the past, no one wanted to undertake a reorganization of the folders. Initially, the folder structure seemed a logical division of documents. Although the folder structure made sense at one time, it has evolved under different managers and has become complex and inefficient. Redundancies exist, folder names do not always reflect the nature of the content, and several organizational methods are in effect.

The SharePoint Portal Server deployment is a good opportunity to evaluate document management practices and content organization. Additionally, taking the extra time to reorganize the folder structure allows Garrett to take full advantage of document management features available in SharePoint Portal Server.


Planning the Document Library Structure

Garrett includes the supervisor from each group in the IT department on his deployment team. They discuss the current organization of documents, identify teams that produce content collaboratively, and review processes for publishing documents within the department and the company. They also identify a common problem with lack of control over what documents are added to a folder. Authors sometimes add documents to the wrong folder, making it difficult to find documents again later.

In addition, they discuss the idea that folder organization is often arbitrary. Unfortunately, different authors have different ideas about how to organize their file hierarchies, which leads to inconsistencies within an organization. For example, Jane reports that training materials are organized into folders according to format or media. She would prefer to organize them by subject.

She shows the group a table that represents the folder structure for the training materials to illustrate her point:

Current organization (by format) Suggested organization (by subject)
books
  • databases

  • e-mail & calendars

  • networking

  • word processing

videos

Web-based

labs

 word processing
  • books

  • labs

  • videos

  • Web-based

databases

e-mail & calendars

networking

Folders organize documents for physical storage and enforce management policies such as document publishing processes. Consolidating similar folders is a key goal of redesigning the folder structure. However, the IT department develops a list of three reasons not to combine folders:

Security requirements. Security is a fundamental reason to divide documents into different groups. Are there some documents a user should not see? Do some documents have multiple authors? The IT department must carefully evaluate the security needs for document groups. For example, Catherine and the network administration group manage the configuration and security of the network. Information about the network firewall configuration is restricted to the senior administrators. General information such as instructions to change a logon password is available to a larger group. Even though the same group of people manages both types of information, it is necessary to store the content in separate folders to maintain security.

Management delegation. If different people manage the documents, separate folders may be necessary. A coordinator for a folder controls the approval routing, document publishing processes, and level of access to his content. Distributing the responsibility for these tasks reduces bottlenecks for change requests, such as updating the approval route or giving a new group member access. For example, each group supervisor is designated as coordinator on the folders he manages. This will provide each supervisor a greater degree of control over content access.

Approval processes. Only one approval process can be selected per folder. If folder documents need different approvers, or different publishing processes, separate folders should be used. For example, the technical support group has several people who add new material to the document library. However, depending on the subject, the document goes to one of four different technical reviewers. Only one approval route can be assigned to a folder. Documents are divided by subject and stored in the folder with the appropriate approver.

Reorganizing the folder structure and building document profiles requires planning and human expertise. The members of the deployment group contribute their expert knowledge about the purpose and usage of the content they manage.


Creating Document Profiles

The team members look for descriptive patterns, or groups, while examining the content of each folder. They also look for types of documents found in more than one folder, such as product specifications. For each pattern identified, they suggest a possible document profile name. A document profile is a collection of properties that are useful in describing a particular type of document. For example, Jane proposes a document profile for training tutorials, with properties such as Subject, Skill Level, and System Requirements.

A long list of document groups is created, including client profiles, product specifications, troubleshooting advice, and installation instructions. Adding details to group descriptions further refines the list of document groups. For example, the group of installation instructions is broken down into components such as server installations, printer installations, and modem installations.

In addition to reviewing the content of each folder, the team examines folder names, group templates, and frequently used forms to generate ideas for document profile names. The team finds this audit process time-consuming but productive. The list of document groups develops into a list of document profile names.


Finding Metadata in the Existing Structure

Now that the group has a list of document profiles, each profile needs a set of properties to describe a document. The group converts many folder names to properties for use on document profiles and eliminates the obsolete folders. For example, it combines all installation instructions into a single folder, named Installations. Garrett also adds a property for Hardware to the Installation Instructions document profile to distinguish one type of document from another. For example, when Michael submits a set of instructions to install the new laser printer, he selects Printer as the type of hardware for that property.

For each new document profile, the group works to create a list of properties that identify the associated documents. Garrett uses the Add Document Profile wizard to create the newly defined document profiles. All document profiles are stored in the Management folder in the workspace. Each folder coordinator can select from among the existing document profiles to associate them with the folder.


Reducing the Document Profile List

Garrett’s planning team is very thorough when identifying the different types of documents. However, the identification of twelve different document profiles for troubleshooting advice is excessive. They reevaluate the list of document profiles and consolidate document profiles to eliminate redundancies and reduce the list size. To accomplish this, they make the document profile names less specific and add optional properties. For example, they decide to use one document profile called Troubleshooting Advice. On that document profile, they add properties for Hardware Equipment, Software Applications, Operating Systems, Telephone Systems, and Network Servers. For each of those properties, they add the specific equipment or application names as property values.

It is important to find a balance between the number of document profiles to choose from with the length of the profiles. Too many profiles can confuse the author and be difficult for a coordinator to manage. However, fewer document profiles mean more properties on the profile. To make document check-ins fast and painless for the authors, the team decides to limit required properties to five per document profile.


Adding Properties to Document Profiles

So far, the reorganization has reduced the number of folders and added custom properties to document profiles. Additional properties can be added to capture information that was not previously associated with the documents. These extra properties might address business needs by attaching searchable properties to the documents. For example, Michael asks for a status property for service requests submitted to technical support.


Building the Folder Structure

Garrett creates the new folder structure in the workspace. Adding content is the next step. Because he cannot drag documents from one folder to a matching folder in the workspace, Garrett is concerned about the amount of time needed to manually move documents to the correct folders and fill in the document profiles. He assigns Matthew, a programmer on the team, to write a script to import the documents into the workspace. Matthew carefully reads the software development kit (SDK) for SharePoint Portal Server and creates the requested script. He successfully copies the files from the old folder structure into the appropriate folders in the new document library and updates the document profiles for each file.


Assigning Roles

To simplify the process of securing access to the folders, Garrett adds each group’s supervisor as a coordinator and lets them assign roles to the people in their groups. Delegating this task to several knowledgeable people reduces the burden of security management and shortens the time necessary to accomplish the task.


Adding Approval Routing

Each coordinator then configures an approval process for the appropriate folders by editing the Approval tab on the Properties page of the folder. From there, the coordinator selects a list of approvers and chooses to send mail to all approvers at once (parallel approval) or one approver after another (serial approval) when requesting approval for a document.


Planning Summary

At this point, Garrett’s planning team has:

  • Simplified and reorganized its folder structure.

  • Created document profiles and added custom properties to identify documents.

  • Moved content into the workspace and applied document profiles.

  • Assigned roles to secure content in each folder.

  • Applied approval routing as necessary.

The folder structure for the workspace in is place and the content development processes are configured. The next deployment step is preparing the dashboard site.


Prepare Your Dashboard Site

The document management features in Microsoft® SharePoint™ Portal Server help a group operate more efficiently. The previous chapters described features that define and streamline document creation and publication. Versioning, which uses the document check-in and check-out functions, allows the group to monitor who is working on a document and to store multiple versions of a document. Approval routing enables the group to route a document to one or more reviewers. The document publishing process gives the group control over which document versions are available for readers. In addition, metadata from document profiles helps to identify documents in a search.

This chapter focuses on how to use the dashboard site to make information easier to find by:

  • Customizing the home page of the dashboard site

  • Organizing the content on the dashboard site into categories

For additional information about search capabilities on the dashboard site, see Chapter 8, “Expand Search Capabilities.”


Organize the Home Page

Posting information on the home page is an important step in preparing the dashboard site for your organization. The home page highlights information that is especially important to users.


Adding Content to the Home Page

Using Microsoft Digital Dashboard technology, SharePoint Portal Server organizes information on the home page with Web Parts. The default home page contains four Web Parts: News, Announcements, Quick Links, and Subscription Summary.

You can also add new Web Parts to display additional information of interest to your readers. For example, a dashboard site for a group or department would include information relevant to the group’s work. It might contain a Web Part called Project Status to display project information such as status reports and schedules. In contrast, the dashboard site for a company typically highlights information relevant to all departments of that company. For example, the human resources department learns that searches for information about employee benefits are common. They decide to post information about employee benefits on the home page under a Web Part called Benefits. To keep employees informed about product changes, the marketing department creates a Web Part called Product News with information about a new product line.

If you are a coordinator at the workspace level, you can add new Web parts on the Content management page, in the upper right corner of the dashboard site. You can find more information about working with the home page settings and adding new Web Parts in Dashboard Site Help. You can access Dashboard Site Help from the Help button on any page in the dashboard site. Additional information about digital dashboards is available in the Digital Dashboard Resource Kit (DDRK).


Customizing the Appearance of Your Dashboard Site

You can also customize the appearance of the dashboard site for your organization. You can modify the following elements:

  • Dashboard title

  • Dashboard description

  • Dashboard image and logo

  • Font style, size, and color

  • Web Part layout

Each page in the dashboard site represents a dashboard. A dashboard consists of Web Parts, which are reusable components that contain Web-based information. Assembling Web Parts in a digital dashboard framework is an easy and flexible way to customize the content and appearance of a Web site. Coordinators at the workspace level have access to three management pages on the dashboard site to update the content and appearance. You can change the style settings (colors and fonts on the dashboard) by using the Settings management page. You can view and modify the layout of way Web Parts on a dashboard by using the Layout management page. To add new Web parts, go to the Content management page.

If you are a coordinator at the workspace level, you can find more information about working with the home page settings and instructions on how to modify them in Dashboard Site Help. You can access Dashboard Site Help from the Help button on any page in the dashboard site.


Use Categories to Organize Documents

The success of a search for information usually depends on the volume of content available for searching, the skill of the user who is attempting to find the information, and the user’s access permissions. For example, browsing through 10,000 documents can be overwhelming. If a user does not know exactly what he is searching for or where information is stored, finding a specific document can be time-consuming and frustrating.

You can organize information in the dashboard site by using categories to group similar documents. This allows you to browse through information by topic. For users who are unfamiliar with where documents are stored, categories help them find what they need. Another advantage is that a document may appear in several different categories. Categories accommodate users outside a group without changing the existing folder structure and processes that the group uses. Creating an effective category structure requires planning and some understanding of how others might organize the content.

Categories serve two purposes. First, they provide a centralized structure for information browsing. Categories direct readers to the information they seek through an organized hierarchy of topics. Second, they provide a consistent, controlled set of values that can be added as document metadata. Categories provide a flexible way to both describe and find documents.

Designing Your Category Structure

Every workspace contains a category hierarchy. The top level of the hierarchy is labeled Categories, with subcategories nested under it. To a user browsing the workspace using Microsoft Windows® Explorer, categories operate like folders. Using Windows Explorer, a user can expand the category hierarchy and browse through the associated document links for each category. The dashboard site displays the categories as a Web Part on the home page. Each category is a link to an expanded list that shows subcategories, category Best Bets, and documents assigned to the category.

As with planning for keywords, a user survey facilitates this process. Any user with the appropriate permissions can search for and view a published document. However, the category structure offers a way to direct users to a core group of documents that represent that topic.

After you decide which content to categorize, plan your category structure by considering how users choose to organize the content. For example, do users organize content by department, by project, or by subject matter? If the users organize content by subject matter, what are the top-level categories? What are the subcategories? How many levels of subcategories do you want users to navigate?

When you have decided which categories to use, create the structure in the Categories folder of the workspace. Each top-level category has its own top-level category folder. A subcategory is a subfolder under its corresponding category folder.

You do not need to configure and implement categories, but they can serve as an excellent document management tool for dashboard site users. Categories assist users in finding information.


Categorizing Your Content

After you have established a group of categories, the next step is to assign the appropriate categories to documents. You can manually assign categories on each document or you can assign them automatically by using the Category Assistant.

Manually Categorize Documents

You can manually categorize a document by using the Search and Categories tab on the Properties page of the document. If the document is stored in an enhanced folder, you must check out the document before you can change the document’s category assignments. If you have only a small number of documents to categorize, you can use this method of manual categorization exclusively.

You can associate a document with specific categories by using document profiles. Adding the Categories property to document profiles provides a way to enforce category assignment when authors check in a document. Allowing authors to assign categories on the profile form at check-in also distributes the task of document categorization among multiple authors.

Automatically Categorize Documents

The Category Assistant is a tool to assign categories to documents automatically. If you plan to use categories for a large number of files, the Category Assistant can efficiently assign categories to existing documents and add it automatically to new documents. This reduces the time required to implement categories for your users. Before using it, you must manually apply categories to a selection of documents for the Category Assistant to use as training examples. Documents used as training examples help the Category Assistant learn the definition of a category. The Category Assistant compares training documents assigned to a category with training examples from other categories to identify the most characteristic features (words). Ultimately, the definition of a category is the list of words that best distinguish documents in one category from documents in other categories.

The Category Assistant automatically categorizes new documents by comparing the list of words for each category to the list of words contained in each new document encountered. A single document might, and often will, be automatically categorized into multiple categories.

Consider the following points when you use the Category Assistant:

  • Try to provide as many examples as possible. These examples should encompass as many facets of the category as possible. For a category that includes a type of medical equipment used in hospitals, you could select case studies about hospitals that use the equipment, marketing data that targets participating hospitals, and financial reports that forecast market share in the industry.

  • Consider applying multiple categories to a document. You can assign a document to any category that a user might access. For example, if someone wants to find information about a utility that your group uses, she might look under a category called Internal Tools or a category whose name describes the purpose of the tool, such as Archiving.

Documents may not immediately appear in the assigned categories. Categories are not applied until content is indexed. For this reason, there may be a delay before you see a document appear in the assigned category. The length of the delay depends on the index method you use and the amount of content that is included in the index.

Training the Category Assistant

Training the Category Assistant is the most important step in auto-categorization. The Category Assistant needs training examples for each category. Without good training examples for each category, the accuracy of the Category Assistant is limited. A minimum of 10 documents per category is recommended to successfully train the Category Assistant.

Ideal training documents are:

  • All related to the same category topic. For example, if the category is Product Design, including a document about product specifications would be useful. However, including a training document about product inventory would reduce the Category Assistant’s accuracy.

  • Primarily textual. Word-processing documents are excellent training examples. Documents such as spreadsheets do not offer as much text for the Category Assistant to use for categorization.

  • Relatively long. There must be enough text for the Category Assistant to analyze the documents and identify the keywords that define a category.

Good training examples for each category improve the accuracy of the Category Assistant. The more training examples you provide, the more precise the Category Assistant can be. You can assign the task of training the Category Assistant to one person or several. Two training models are:

Allow authors to categorize documents. If you want to distribute training responsibilities across a group of authors, you can add the Categories property to your document profiles. As authors check in and categorize their documents, they add training examples for the Category Assistant. The benefit of this model is that a greater number of documents are used as training examples. This procedure works best if the authors clearly understand the category structure.

Assign training responsibilities to one individual. If you want to control the Category Assistant training process, you can remove the Categories property from your document profiles. You can then assign categories by editing the Search and Categories tab of the Properties page of a specific document.

Overriding the Category Assistant

If the Category Assistant does not select the appropriate categories for a document, a coordinator can override the Category Assistant by using the following methods:

  • For a single document. The coordinator may enable the Category Assistant for the workspace but occasionally override automatically chosen categories for specific documents. For example, the Category Assistant may place a document about hats in the Coats category. The coordinator can correct the category assignment by editing the document's properties. To do this, clear the Display document in suggested categories check box on the Search and Categories tab on the Properties page and assign the appropriate categories.
  • For all documents. If the Category Assistant is not performing as expected, the coordinator can disable it and neutralize all automatically assigned categories. When the Category Assistant categorizes documents, it updates a hidden property on the base document profile called Autocategories. This property is separate from the Categories attribute, which users update manually. When the Category Assistant is disabled, the Autocategories property is ignored.

It is difficult to return to an automatic categorization system after you override the Category Assistant for more than a few documents. There is no automated way to do this. If you override the Category Assistant, then want to undo that action, you must manually update the Search and Categories tab on the Properties page of the document. Your changes will take effect at the next index update.

For more information about using categories, see "Managing the Workspace” in User’s Help. If you have the client components installed, you can access User’s Help from the Help menu in Windows Explorer when browsing the workspace.


Review of Key Concepts and Tasks

This chapter included information about preparing your dashboard site to make content more accessible to users in your organization. The following chapters focus on how to enhance search capabilities on the dashboard site.


Planning Summary

In this chapter, you learned about the key concepts associated with preparing your dashboard site to connect users to information inside your workspace:

  • Preparation of your home page

  • Use of categories to group documents by topic


Tasks to Perform

Based on concepts introduced in this chapter, you should be able to complete the following tasks:

  1. Add content to the home page of the dashboard site.

  2. Customize the appearance of the dashboard site, if desired.

  3. Add categories to the dashboard site so that users can browse for information.
  4. Choose a manual or automatic categorization method for documents.


Scenario: Group Collaboration

Previous chapters addressed Microsoft® SharePoint™ Portal Server document management features and ways to organize content on the dashboard site to manage your organization’s information. This chapter details a scenario of how an organization might implement SharePoint Portal Server to enhance document management. In this scenario, users create content as a group and use SharePoint Portal Server primarily for its document management features. It is one example of how SharePoint Portal Server can help a group streamline its processes.


Introduction

Adventure Works is an outdoor equipment company that specializes in outdoor clothing. The regional sales manager wants to install SharePoint Portal Server in his department to help his employees share ideas and expertise as they develop marketing strategies, analyze competitors, and generate other useful information.

Goals

  • Automate existing publication processes

  • Ensure reliable document tracking and security

  • Provide easy and consistent communication of group information

Challenges

The group produces a large number of documents and is having difficulty organizing them. Many people work on the same document, so tracking revisions on the latest version of the file is difficult. Sometimes files are accidentally overwritten. The group lacks control over who accesses content. In addition, information relevant to the group as a whole is not communicated effectively.

SharePoint Portal Server Solution

SharePoint Portal Server delivers document access control and versioning capabilities while streamlining group publication processes and providing a ready-to-use Web site.

Cast of Characters

  • Information technology (IT) group administrator (Claus)

  • Sales department administrative assistant (Julia)

  • Regional sales manager (Mark)

  • Regional marketing manager (Lisa)

  • Sales supervisor (Karan)

  • Marketing analyst (Thomas)

  • Salesperson (Eva)


Deploy SharePoint Portal Server

Claus, the company’s IT administrator, installs SharePoint Portal Server. He then creates a workspace and names it SalesNW. A workspace is an organized collection of documents, management folders, dashboard site content, and links to content stored outside the workspace.

Claus assigns Julia to the coordinator role at the workspace level, allowing her to create a folder structure for the document library, specify folder policy, and institute security. Julia has experience with Microsoft Office and is familiar with the department’s current document management processes. As the coordinator, Julia configures the SalesNW workspace for the department’s sales and support personnel.


Preparing the Workspace

Before Julia begins to develop the folder structure for the document library, she needs to answer these key questions:

  • How do the people in her group currently organize their documents?

  • Who has permission to add and edit the documents?

  • Which folders contain documents that may have multiple authors?

  • What additional descriptive information would help users sort and find documents?

  • What processes should occur before a document draft is published?

From the documentation, Julia learns about enhanced folders. Enhanced folders enable users to take advantage of specific document management features such as check-in and check-out and version control. These features are very useful when several people work on the same document. Checking out a document ensures that only one person at a time can edit a document. The versioning feature tracks each version, or draft, of a single document, providing the latest version of the document for check-out.

Julia knows that group members currently store documents in a file share on a server. From her conversations with people in her group, she learns that they are comfortable with the current folder structure and do not want to change it. They help her evaluate each folder and decide that two of their existing folders — Competitors and Products — would immediately benefit from SharePoint Portal Server document management features. Given this information, Julia duplicates the group’s folder structure in the workspace. Next, she modifies the Properties page of the Competitors folders to enable the document management settings. She then does the same on the Products folder. Now that she has a folder structure for her document library, she evaluates the different processes used by the group for document publishing.


Identifying the Publication Process

Julia’s group has a three-step process for publishing their documents: writing, technical review, and publication. To establish this process with SharePoint Portal Server, Julia must address these key questions:

  • Who will create, review, and read the documents?

  • Who should see a document before it is published?

Mark, the sales manager, manages all documents related to Adventure Works’ competitors, such as Clocktower Sporting Goods and Hanson Brothers. Lisa, the marketing manager, manages documents related to Adventure Works apparel, such as the Kodiak and Siberian coats. Julia takes her folder structure layout to Mark and Lisa to discuss these key questions.


Applying Security

SharePoint Portal Server uses three roles to establish security and to control access to workspace content: coordinator, author, and reader. Coordinators can specify folder policy and modify security. Authors can add or modify documents. Readers can search for and read published versions of documents. Mark and Lisa provide Julia with the names of users who should be assigned to the author role for each folder. Julia applies the approved security policy by modifying the Properties page of the folders. To ensure that everyone in her group can read published documents, Julia designates her department’s Microsoft Windows® 2000 user group as a reader on all workspace folders.


Including Web Discussions

Currently, editorial suggestions are e-mailed to the author or the document is edited directly. Mark and Lisa have heard many complaints that these methods make tracking editorial comments difficult. As an alternative, SharePoint Portal Server supports the Microsoft Office 2000 Web Discussions feature. Julia explains to Mark and Lisa the use of Web discussions for collaboration and review. Using Web discussions, users can view the document and simultaneously make online comments without modifying the document. Each discussion is threaded, with replies to a discussion remark appearing directly underneath the original remark. In addition, multiple discussions about the same document can occur at the same time. The managers decide this process sounds like a great solution for their group.


Creating Profiles

To help users find information easily, additional descriptive data can be added to documents stored in the workspace. A document can be assigned a profile, which is an additional set of searchable properties for the document. By default, the document profile template includes the properties of Author, Title, and Description, but additional properties can be added easily. The coordinator can also create custom profiles for special kinds of documents, such as product specifications or marketing plans. All document folders must be associated with at least one document profile.

Julia, Mark, and Lisa evaluate their folders. They decide that documents in both folders fall under one of two document types: competitive analysis and marketing plan. Julia creates a document profiles for each document type. Along with the default properties of Author, Title, and Description, Julia adds properties that are specific to each document profile. For example, the Competitive Analysis profile contains an additional property called Competitors, and the Marketing Plan profile contains a property called Partners.


Adding Approval Routing

In Julia’s group, an author creates a document and then sends it to specific people who decide whether the content is accurate and complete. SharePoint Portal Server offers an optional review process called approval routing. The people who review and approve the documents are approvers. As coordinator, Julia can add approval routing to any enhanced folder and automatically route a document from the author to approvers. When approval routing is in effect, approvers automatically receive an e-mail notification when the document is ready to publish and needs approval.

Mark reviews all documents in the Clocktower Sporting Goods and Hanson Brothers folders. Each of these folders has multiple authors, but Mark and the sales supervisor, Karan, will be the approvers for all documents. Julia adds Mark and Karan as the approvers by modifying the Approval tab on Properties page of the folders.

For the Products folder and its subfolders, Lisa is the approver. However, in the Kodiak folder, only Lisa and one other author create documents. As a result, Lisa feels that no approval routing is required for this subfolder. Because Julia does not add approval routing for this folder, documents are immediately published when they are checked in.

When Julia completes her deployment, she meets with Mark and Lisa to review the folder structure, roles, users, and publishing processes.


Moving Content into the Workspace

Julia is ready to move documents from their file server to the workspace. After checking the SharePoint Portal Server documentation, Julia understands that she can easily drag and drop the content from the file shares into the appropriate workspace folders by using Windows Explorer. She can move each file individually or multiple files at the same time. As each file is checked in to the workspace, it is treated as new content, which means that it has not been published.

Before Julia begins moving content, she needs to address these important questions:

  • How much of the existing content will be published?

  • Will the same document profile apply to all migrated content in a folder?

  • Will Mark want to approve the moved content?

She discusses these questions with Mark to clarify his request. Mark tells her that he wants all the existing Clocktower Sporting Goods and Hanson Brothers folder content moved from the public share to the corresponding workspace folders and published without the current approval routing. The Competitive Analysis profile is appropriate for all the documents.

Before she moves the documents, she temporarily disables the approval routing assigned to the Clocktower Sporting Goods folder. This allows her to publish the documents without requiring Mark to approve each one. She then moves the existing content from the file share to the appropriate workspace folder. When the check-in form appears, she adds a brief sentence about moving the content from the public share, based on Mark’s request, as a version comment. On this same form, she chooses the Competitive Analysis profile, checks the Publish box, and clicks OK. The content is checked in and published. Julia then quickly modifies the Properties page of the folder to enable the approval routing for documents in that folder.


Customizing the Dashboard Site

When Claus created the workspace, SharePoint Portal Server automatically created a dashboard site at the same time. In addition to using Microsoft Office and Windows Explorer to read or manage documents, Julia’s group can also use the dashboard site to access content in the SalesNW workspace. The dashboard site allows everyone in the group to easily find and read content with a Web browser, such as Microsoft Internet Explorer or Netscape Navigator. Now that Julia has prepared the workspace, she is ready to make the dashboard site a more effective tool for her group.

The Web site, called the dashboard site, included with SharePoint Portal Server uses Digital Dashboard technology. A digital dashboard consists of Web Parts, which are reusable components that contain Web-based information. The dashboard site included with SharePoint Portal Server packages many key features as Web Parts. Julia can change the appearance, post content, and add Web Parts to increase the dashboard site’s usefulness for her group.

The home page on the dashboard site features four default Web Parts — Announcements, Quick Links, News, and Subscription Summary — which Julia tailors to her group’s needs. Julia examines them and sees that Announcements and Quick Links offer immediate benefits for her group. For now, she uses the Content management page to remove News from the home page layout. For Quick Links, she adds links to the Clocktower Sporting Goods and the Hanson Brothers Web sites, and a link to the department schedule. As a reminder, she decides to post the next departmental meeting under Announcements. She uses Microsoft Word to create an HTML file announcing the meeting, and adds this to the Announcements Web Part. As a final touch, she uses the Settings management page to add the company name and logo to the dashboard site.


Planning Summary

At this point, Julia has decided:

  • How documents are stored in the document library. Julia creates a workspace folder structure under the Documents folder based on the group’s existing structure and processes. She configures the folders for document management tasks, such as check-in, check-out, versioning, and approval.

  • Who works in each folder and in what capacity. Julia assigns users to author roles for each folder. She also designates all group members as readers. This establishes which group members can create, edit, and read documents.

  • How profiles describe documents. Julia creates document profiles for the documents that she plans to add to the workspace. Document profiles facilitate the search process.

  • How to publish documents. Julia adds approval routing as needed.

  • How to communicate group information. Julia customizes the dashboard site for the group.

The workspace structure and processes are in place, the content is stored in the new document library, and the dashboard site is ready for use. Julia is ready to introduce SharePoint Portal Server to her group.


SharePoint Portal Server in Action

After implementing SharePoint Portal Server, Julia is ready to announce it to her group. She sends an announcement in e-mail to her group that the deployment is complete. Julia includes a general introduction to the product, links to the SharePoint Portal Server Tours, and links to the installation for the client components. She suggests that the group familiarize themselves with new workspace and dashboard site by using the SharePoint Portal Server Tours. She also recommends that after they complete installing the client components, they add a Web folder shortcut to the new workspace, called SalesNW, at http://server1/salesnw/. After this is done, they can access their workspace through My Network Places or Web folders in Windows Explorer and Microsoft Office. They can also access the workspace through the dashboard site by using their Web browser.

Installing the Client Components to Access SharePoint Portal Server

The next morning, Thomas, a marketing analyst at Adventure Works, reads Julia’s e-mail about the new workspace. He clicks the link and installs client components for SharePoint Portal Server on his desktop computer, then adds a Web folder shortcut for the workspace.

Using Document Management Features to Simplify Creating Content

Thomas is ready to create a new marketing proposal for the Kodiak line of coats. He starts Microsoft Word and selects the Marketing Plan template that he has always used to create proposals. Thomas completes the proposal and is ready to save the document to the workspace. Because the Kodiak folder is an enhanced folder, Thomas must check his document in before it becomes visible to readers. In Microsoft Word, Thomas scans the selections on the File menu and chooses Check-in from the available actions. When the typical Save As dialog box appears, he clicks My Network Places and sees the SalesNW workspace. He opens the Kodiak folder, and clicks Save.

A new check-in form appears. Thomas sees a place at the top of the form for comments, so he types a brief sentence about this version of the file. On the same check-in form, he is prompted to select a document profile for the file. From the drop-down list box, he selects Marketing Plan, and fills in the additional properties on the check-in form. After completing the check-in form, Thomas checks the Publish box and clicks OK. Because there is no approval routing for this folder, the document is published immediately and is available for others in the department to read.

Using Subscriptions to Track Content of Interest

Lisa has an update to the information that Thomas used in his case study, but she has not yet forwarded the new information to Thomas. She finds the case study in the Document Library on the dashboard site and uses Web discussions to add comments about the case study. While she is on the dashboard site, she subscribes to the Kodiak Coats folder and requests e-mail notification whenever any folder documents are added or modified. She then notifies Thomas that new information for the case study has been added as a Web discussion comment. Thomas checks out the case study, reviews Lisa’s comment, and updates the document. He then checks in the case study. As requested, Lisa receives an e-mail notification that the updated document has been checked in.

Using the New Dashboard Site

Eva, who is an author for the Hanson Brothers folder, uses the dashboard site instead of Windows Explorer to access her files. She likes accomplishing her document management tasks and finding the information she needs from a central location.

She appreciates the reminder about the department meeting under Announcements and is careful to note it in her calendar. She also browses through Quick Links and reads the latest competitor information.

On the dashboard site, she browses the Document Library to find the draft of her new competitive analysis. She finds it and selects Check-out from the Show Actions option. She makes some revisions, then selects the Publish action.

Approving a Document in SharePoint Portal Server

Because Karan, the editor for the Hanson Brothers folder, is the next person in this folder’s approval routing, she receives an e-mail notification that Eva’s document is waiting for her approval. When Karan receives it, she clicks the e-mail link to open the file. She finds it accurate and complete; so she returns to the e-mail notification and selects Approve, an action that automatically sends e-mail to Mark. Mark receives e-mail about Eva’s document. He follows the same process as Karan and selects Approve in the e-mail. Mark is the last person in the approval routing, so Eva’s document is published for everyone to read.


Expand Search Capabilities

The deployment planning to this point has focused on organizing content in the workspace and configuring the dashboard site. The previous chapters described features that help you manage and search for documents stored in the workspace. You can also make information stored outside the workspace available for search. This feature makes the dashboard site the convenient place to search for information stored in many different places.

This chapter focuses on expanding the amount of information available for searching and improving the results of a search by:

  • Making content outside the workspace available for search

  • Identifying documents that are particularly relevant to a search

  • Influencing the results of a search


Add Content Sources

A content source represents a location outside the workspace where content is stored. A URL for this content is stored in the workspace. This content can be located in a different workspace on the same server, on another server on your network, or on the Internet. Examples of content sources include Web sites, file systems, databases, and other workspaces. Microsoft® SharePoint™ Portal Server creates a searchable index of all content in the workspace and the information available from the content sources that you add. On the dashboard site, users can search for and view information from these content sources.

Note Users cannot check out or edit items from content sources.

Content sources are stored in the Content Sources folder, found in the Management folder of the workspace. To create and manage content sources, you must be designated as a coordinator for the Management folder. You can add a content source at any time by using the Add Content Source Wizard.

You can add the following types of information as content sources:

  • Web site

  • File share

  • Microsoft Exchange 2000 public folders

  • Microsoft Exchange 5.5 public folders

  • Lotus Notes databases

  • SharePoint Portal Server workspaces

When planning to add content sources, determine what content is most useful to your users. To help you determine where content is stored and what information users need to access, a content review and user survey are useful. For more information about content reviews and user surveys, see Chapter 3, “Plan Your Deployment.”

For more information about adding content sources, see the “Managing the Workspace” section in User’s Help. If you have the client components installed, you can access User’s Help from the Help menu in Windows Explorer when browsing the workspace. For more information about adding Microsoft Exchange public folders or Lotus Notes databases as content sources, see the “Advanced Topics” section of Administrator’s Help.


Configuring Content Sources

Each workspace contains an index of content stored in the workspace and content from the content sources that you add. The Content Sources folder contains the Additional Settings tool. Use this tool to configure settings for this index. Using the Additional Settings tool, you can create a schedule to update the index and choose a method for crawling content sources. You can also customize the index settings for a specific content source or apply the same settings to all content sources.

After you create a content source, you can complete the following management tasks related to the index by using the Additional Settings tool located in the Content Sources folder:

  • Schedule updates. Indicate how often SharePoint Portal Server should update the index to include new material in existing content sources and any content sources you have added since the last update.
  • Create search scopes. Provide a way for users to limit what is included in dashboard site searches to improve the speed of searches and yield shorter search results lists.
  • Add rules. Indicate what types of information you want SharePoint Portal Server to include in or exclude from the index.

To customize the settings for an individual content source, edit the Properties page for the content source. For each content source, you can schedule individual updates to the index and establish specific search scopes. For more information about configuring individual content sources, see the “Managing the Workspace” section in User's Help. For more information about the workspace index, see the “Managing Indexes” section in Administrator’s Help.


Scheduling Updates to the Index

You can apply one schedule to update the index for all workspace content sources or customize the schedules to update individual content sources at different times. There are four update methods. Each update method suggests a default schedule to update index content, although you can customize the schedule settings.

The four update methods are:

  • Full update. During a full update, SharePoint Portal Server updates links to all content in the content source. A full update includes refreshing the index for unchanged content, adding new content, modifying changed content, and removing deleted content from the index. This is the most time-consuming and resource-intensive type of update.
  • Incremental update. An incremental update of a content source includes only changed content. SharePoint Portal Server removes deleted content from the index, but does not modify the index for unchanged content. For this reason, performing an incremental update is faster than performing a full update.

    You can perform an incremental update if you know that content has changed but you do not want to create a full update. A periodic (for example, daily) incremental update creates the index without using the time or resources required for a daily full update. By using incremental updates, you can perform full updates less frequently.

  • Adaptive update. An adaptive update is an incremental update that uses a statistical formula to improve performance. An adaptive update records how often content changes, and then crawls only the content that is statistically most likely to have changed. The more frequently you perform an adaptive update, the more efficiently SharePoint Portal Server processes the content. For this reason, an adaptive update is faster than a full or incremental update.

    Important Although an adaptive update is faster than an incremental or full update, some updated content could be missed. For this reason, SharePoint Portal Server always crawls documents that it has not retrieved for two weeks, even if they have not been updated.

  • Notification update. A notification update is the most efficient of all types of updates. SharePoint Portal Server uses this method by default when possible. If a content source supports notification updates, it automatically sends a notification of any changes to the workspace index. This notification triggers an update of the individual content source in the index.

    Note Notifications are available only for SharePoint Portal Server servers and for file shares located on an NTFS file system partition on a computer running Microsoft Windows NT® version 4.0 or Microsoft Window® 2000. Your system administrator can provide you with additional information.

You can customize how often SharePoint Portal Server updates the information for a specific content source or how often it updates the entire index. The default schedule for the Content Sources folder, which contains all content sources, is a daily adaptive update Monday through Thursday at 10:00 P.M. and an incremental update on Friday at 10:00 P.M. This schedule allows information in the index about the content sources to be updated daily based on the frequency with which users access the content and for all changes to content sources to be included in the index on Fridays.


Creating Search Scopes

When you configure a search scope for a content source, dashboard site users can narrow their searches to information from a specific content source. For example, if press releases from a competitor’s Web site are included in the index, you can apply a search scope called Competitor Press to this content source. The scope is displayed as an option next to the keyword search box on the dashboard site. A user can select this search scope and search for a keyword match in the press release content only.

If your index includes many content sources, search scopes can enhance server performance by applying a search query to a specific subset of the content in the index. Search scopes work well when you give them a descriptive, functional name such as Customer Profiles, Finance Department, or Competitor Press.

For more information about configuring search scopes, see the “Managing the Workspace” section in User's Help.


Using Content Source Rules

When adding a content source, you need to determine how much content from each source to include in the index. The amount of content varies depending on the type of information with which you are working. For example, you can restrict Web site content included in the index to a single Web page or an entire site.

You can use rules to specify the content that SharePoint Portal Server includes in the index. You can configure content source rules to avoid specific sites or document types when building the index for a content source. Three types of rules are available to ensure that the content sources that you add are used and updated effectively. The three types of rules are:

  1. Site path rules. You use these to limit the amount of content included in the index. For example, if you include a Web site in the index, you can specify a rule to include only two of the seven pages from that Web site in the index.

    Important For security reasons, if you configure an unlimited number of site hops for a Web site content source it is excluded from the index. To include the content source in the index, you must create a site path rule and specify a number of hops.

  2. Mapping rules. You use these to override how SharePoint Portal Server displays search results or how users access content after you build an index.

  3. File type rules. You use these to specify file types (indicated by file extensions) to include or exclude when crawling an index of all content sources. The file type inclusion and exclusion rules apply only to content that is stored outside the workspace and included in the index through content sources. The file type inclusion and exclusion rules do not apply to content stored in the workspace.

    Note To include documents with proprietary file extensions in your index, you must register the IFilter for that file type. For more information about IFilter registration, see the “Advanced Topics” section in Administrator’s Help.

For more information about using rules with content sources, see the “Managing the Workspace” section in User’s Help.


Applying Categories to Content Sources

SharePoint Portal Server offers two ways to apply categories to content sources. The most efficient method uses the Category Assistant. You can also choose to manually categorize content sources.

Using the Category Assistant

The Category Assistant can automatically evaluate and apply categories to files from content sources in addition to workspace content. When you enable the Category Assistant, you can restrict the categorization to workspace documents only, documents from content sources only, or allow automatic categorization of all documents. The Category Assistant is the most efficient method for applying categories to information stored in content sources.

Before using the Category Assistant to automatically categorize content sources, you must train the Category Assistant by applying categories to content in the workspace. For more information about training the Category Assistant, see Chapter 6, “Prepare Your Dashboard Site.”

Manually Categorizing Content Sources

Alternately, you can manually assign categories to information from content sources. To do this, SharePoint Portal Server includes a special document profile called the Web Link profile. This profile allows you to associate a shortcut with a link to a content source located outside the workspace. In a document folder associated with the Web Link document profile, add a shortcut to the content that you want to categorize and apply the Web Link document profile to it. Edit the document profile to apply the appropriate categories. For more information about how to apply categories to information stored outside the workspace, see the “Managing the Workspace” section in User’s Help.


Identify Best Bets

Best Bets enhance search efficiency and provide guidance to users by directing them to documents considered particularly relevant to their search. A Best Bet is a document selected as the best recommendation for a category or specific keyword. SharePoint Portal Sever displays Best Bets at the top of a search results list.

Keyword Best Bets

A Keyword Best Bet is highly relevant to a keyword. It appears in search results when a user enters that keyword in a query. For example, a coordinator might select the Manufacturing home page as a Best Bet for the keyword “inventory.” If someone then searched for “inventory,” the search results page would display a link to the Manufacturing home page at the top of the search results.

Category Best Bets

A Category Best Bet is a document that is highly relevant to a particular category. For example, the Marketing category for competitor case studies might have a product analysis of Clocktower Sporting Goods as a Category Best Bet. Category Best Bets are prominently displayed in category listings on the dashboard site, just as Keyword Best Bets are prominently displayed in search results.

Identifying Best Bets

You can select a document as a Best Bet for more than one category or keyword. You can also select multiple documents as Best Bets for the same category or keyword. You can select a document as a Best Bet only if you have coordinator privileges for the folder in which the document is stored.

To identify a document as a Best Bet, you update the Search and Categories tab on the Properties page of the document. The Search and Categories tab has two controls: a simple text field for specifying Keyword Best Bets and a Category selection control for selecting Category Best Bets.

Additionally, SharePoint Portal Server will identify documents as Best Bets if a very strong match is found in the search results. For more information about how to designate a Best Bet, see the “Managing the Workspace” section in User’s Help.


Manipulate Search Results

You can use the thesaurus included with SharePoint Portal Server to adjust search results for the benefit of your users. To improve search results, you can edit the thesaurus to expand queries. This means that a user can enter one word in a search query and receive search results for a similar word. For example, the user can search for “IE” and receive matches to “Internet Explorer” in the search results.

Using the Thesaurus to Expand a Search Query

You can edit the thesaurus entries by editing the Extensible Markup Language (XML) file in a text editor. You can make two kinds of thesaurus entries:

  • Replacement set. You can specify a pattern to replace with a substitution set. For example, you want search queries for “W2K” (the pattern) to be replaced by “Windows 2000” (the substitution). If a user searches for “W2K,” SharePoint Portal Server returns only search results containing “Windows 2000.”
  • Expansion set. You can specify a group of substitutions that are synonyms of each other. You can expand search queries that match one substitution to include all other substitutions in the set. For example, you want search queries to treat “writer,” “author,” and “journalist” (the substitutions) as synonyms. If a user searches for “author,” SharePoint Portal Server also returns search results containing “writer” or “journalist.”

For more information about using the thesaurus to expand a search query, see the “Advanced Topics” section in Administrator’s Help and the SharePoint Portal Server Software Development Kit (SDK).

Additional Thesaurus Options

In addition to specifying substitutions and replacement patterns, you can use the thesaurus included with SharePoint Portal Server to further customize search queries. There are two additional options when you edit the thesaurus:

  • Weighting. You can assign a value, or weight, to words in the substitution set. This provides the ability to have certain words make a stronger match to a search query and rank higher in a search results list. You can specify a value between 0 and 1. For example, you can weight the term “IE” as 0.5 and the term “Internet Explorer” as 0.8. Files containing the full term “Internet Explorer” would appear higher in the search results list.
  • Stemming. You can specify stemming in pattern and substitution entries. For example, in English, the stem “buy” matches “bought,” “buying,” and “buys.”

SharePoint Portal Server includes several thesaurus files. For more information about editing the thesaurus, see the “Advanced Topics” section in Administrator’s Help.


Review of Key Concepts and Tasks

This chapter included information about ways to enhance search capabilities on the dashboard site and expand searches to include information outside the workspace.


Planning Summary

In this chapter, you learned about the key concepts associated with expanding your search capabilities:

  • Customization and indexing of content sources

  • Best Bets

  • Enhancing Search Results


Tasks to Perform

Based on concepts introduced in this chapter, you should be able to complete the following tasks:

  1. Add content sources to allow users to access information stored outside the workspace.

  2. Decide a schedule for updating information about content sources to the index.

  3. Identify possible search scopes to enhance searching.

  4. Specify rules to customize content sources.

  5. Associate content sources with categories.

  6. Apply Best Bets to content.
  7. Use the thesaurus to control search results.


Scenario: Sharing Content

In this scenario, a company wants to create a more effective portal to share information with a broad audience and to direct users to the information they require. It is one example of how to use the efficient search capabilities of Microsoft® SharePoint™ Portal Server and the flexibility of the dashboard site to create a central point of access for information.


Introduction

Adventure Works is an outdoor equipment company that specializes in outdoor clothing. Over the past few months, the company has begun using SharePoint Portal Server in various departments to streamline document management practices. Now they want to improve and consolidate search services across the company.

Goals

Configure a dashboard site that:

  • Provides a more flexible searching capability.

  • Delivers faster search results.

  • Offers efficient methods for helping users find the information they need.

Challenge

The Marketing division produces a large amount of content but users cannot find what they need when they need it. Because the company’s existing portal has a very limited search capability and cannot search multiple data stores, it produces slow and unsatisfactory results.

The current portal has two significant problems:

  • Users can perform only very limited text searches. When a user searches for a specific word, that word must be found in the body of the document.

  • No organizational structure guides users toward the information they need.

SharePoint Portal Server Solution

SharePoint Portal Server offers easy access to multiple information sources in an organization so that users can find the information they need efficiently. In addition, the Category Assistant helps coordinators use metadata to categorize content throughout the organization, so that users can browse through content organized by topic.

Cast of Characters

  • Information technology group (IT group)

  • Customer sales and support manager (Robert)

  • Marketing IT administrator (Sean)

  • Marketing vice president

  • Library services clerk (Rachel)
  • Customer support specialist (Hanna)


Create an Effective Dashboard Site

The vice president of marketing recently approached the Information Technology group (IT group) about using SharePoint Portal Server to improve the Marketing portal. Created in-house with very little planning, the existing portal has become disorganized and ineffective.

He has two primary goals for the new dashboard site:

  • All departments must have up-to-date information about the company.

  • Employees should be able to easily search for content through all departments.

At this stage, he does not want the departments to change how they conduct business. However, he does feel that the portal needs significant improvement in its appearance and functionality. Overall, he wants to use the SharePoint Portal Server dashboard site to be a more effective tool to help employees find what they need when they need it.


Preparing the Dashboard Site

Creating a useful dashboard site involves several stages. To begin, the IT group must assess the server requirements, install SharePoint Portal Server, and customize the dashboard site to meet the content needs of the Marketing division.

Assessing Hardware Needs and Installing SharePoint Portal Server

To determine the hardware requirements, The IT group researched the following issues:

  • How much content is searched?

  • How often does content change?

  • How is content distributed? (For example, Internet versus intranet and local sites versus global sites.)

  • How many users search for content?

After establishing the requirements, the IT group determines performance objectives such as how much content to search per second and how many queries to answer. From this information, the IT group determines the hardware needs for the new dashboard site.

Installing SharePoint Portal Server

Sean installs the SharePoint Portal Server from the installation CD, and then creates a workspace devoted to search services, rather than document management. The workspace contains an organized collection of content, management folders, views, and shortcuts. Creating the workspace automatically generates the associated dashboard site.

Customizing the Dashboard Site

After consulting with the IT group, Sean decides to design the dashboard site in two stages. In the first stage, he adds content to the home page and makes departmental content from Web servers, file servers, and databases available for users to search. In the second stage, Sean organizes the new dashboard site with categories to guide users in their searches.

In the first stage, Sean plans to:

  • Assign roles to users to maintain security.

  • Move content from the existing home page to the SharePoint Portal Server dashboard site.

  • Make the departmental content searchable through the dashboard site.

In the second stage, Sean will organize content on the dashboard site by:

  • Creating a category hierarchy and categorize documents.

  • Designating documents as Best Bets.


Assigning Roles to Users

Because Sean must ensure that the dashboard site is secure, he uses roles to control access to content. He first assigns each departmental group a reader role. He assigns coordinator privileges for the workspace to himself and another IT group administrator. He then assigns the author role to the employees responsible for updating news and announcements on the home page of the dashboard site.

SharePoint Portal Server security honors any existing security in the organization. Consequently, in his discussions with the administrators of the various departments, Sean emphasizes the importance of continuing to follow the IT group’s established security policy. This ensures that any documents deemed confidential by the department do not appear in the new dashboard site.


Customizing the Home Page

In addition to the News and Subscription Summary Web Parts included on the default home page, Sean wants to include a stock ticker and the latest sales figures. The stock ticker, built with Microsoft Digital Dashboard technology, is available as a Web Part from the Microsoft Web site. The dashboard site can display the latest sales figures in a Microsoft Excel spreadsheet as a Web Part. He moves content displayed on the old home page to Web Parts on the dashboard site. Sean uses the Content management page for the home page of the dashboard site to add Web Parts and specify the appropriate properties. As a finishing step, he adds the company logo and name to the home page.


Adding Content Sources

Sean compiles a list of content locations from across the company to search through the dashboard site. He uses the Add Content Source Wizard to configure these locations. Using this wizard, he specifies site rules to designate how much content and what types of content to index at that site. SharePoint Portal Server stores the addresses in the Management folder of the workspace.

To improve server performance and save space, SharePoint Portal Server does not physically store the content from these locations. Instead, it compiles an index of searchable content from the departmental locations. After Sean configures the content sources, he creates the index and chooses a schedule to automatically update the index at regular intervals.


Organizing Content on the Dashboard Site

The dashboard site now offers the ability to search for information more efficiently. Sean examines how features such as categories and Best Bets help users across the company find information more easily. Categories are organized groups of related information. Best Bets are documents that are designated by a coordinator as highly relevant to a search subject. Because Sean is not familiar with organizing information in this way, he calls Library Services. Rachel is assigned to help Sean configure the search features with a wide audience in mind.

Jointly, they must:

  • Design a search strategy that uses categories and Best Bets to organize information.

  • Create the category structure.

  • Organize the content by using SharePoint Portal Server.


Creating the Category Structure

The category structure forms the basic framework for searching on the dashboard site. Before designing the new structure, Rachel examines existing methods of content organization used by departments. Her job is easier if she takes into account the work already done. She meets individually with the managers in each department to research how they organize their content. She poses the following questions:

  • What categories does each department already use internally?

  • What content does each department want to see highlighted on the dashboard site?

  • What words do they use to identify that content?

After her series of meetings, Rachel first reviews her category lists to learn which terms are common across all the departments. She then assembles all the new words suggested for the content. Sean can later use this list to identify and designate specific documents as Best Bets, highly relevant, for specific keywords used in a search. Finally, Rachel decides upon the top-level categories to appear on the dashboard site: Competition, Planning and Measuring, Products, Support and Services.

Most of these top-level categories contain additional subcategories. If the user clicks on a top-level category, a list of links to other departmental-level sites appears. Rachel’s new category hierarchy is organized like this:

Competition
  • Competitor Products

  • Competitors
            Support and Services
    • Customer Sales

    • Customer Support
    Planning and Measuring
    • Case Studies

    • Sales Forecasts

    • Design Specifications
             Products
    • Coats

    • Sweaters

    • Gloves

    Adding categories to the dashboard site is a coordinator’s task. Sean uses Rachel’s design to create the category structure. He opens Microsoft Windows® Explorer, goes to the Categories folder in the workspace, and he creates the category structure. To create a category, he opens the Categories folder. From the File menu, he selects New, and then clicks Category. He enters a name for the category and presses Enter. The category appears immediately on the dashboard site.


Categorizing the Content

Now that Sean has created the category structure, he must apply the categories to the content available on the dashboard site. Sean can categorize content in several ways. After reviewing his options, he decides to use the Category Assistant tool to automatically categorize content included in the index. He selects some typical files as examples and manually categorizes them to train the Category Assistant. After he trains the Category Assistant, it automatically assigns categories to any uncategorized documents the next time the index is updated.


Designating Best Bets

SharePoint Portal Server offers two kinds of Best Bets. A Category Best Bet is highly relevant content for the category topic. A Keyword Best Bet is a document particularly relevant to a keyword used in a search query. Based on Rachel’s feedback from the departments, Sean decides to create only Category Best Bets at this point.

For Category Best Bets, Sean asks each department what content it wants to see promoted on the Marketing dashboard site. Using that information, he updates the Properties page for each recommended file to identify it a Best Bet for the appropriate category.


The Dashboard Site in Action

Sean has created a more effective portal to share documents and help users find the information they need. It is now ready to use.

Exploring the Dashboard Site

Robert, a customer sales and support manager, needs the design specification for the Kodiak coat. He launches his browser and goes to the Marketing home page. He has visited this site before, and he notices that it has changed. Under the Announcements Web Part, he reads about the new features on the marketing dashboard site.

Robert is interested in testing the search capability of this new site, so he types Kodiak Design Spec in the search box at the top of the page. The search results list displays category matches and links to content related to Kodiak coats. He notices that results are sorted by Best Match, and the design specification is displayed at the top of the list. He is impressed with the improvements in the redesigned site and recommends it to his staff.

Guiding Users to Information

Robert recently hired Hanna as a customer sales specialist. She needs to learn about the product line as quickly as possible. Acting on Robert’s advice, she launches her browser and goes to the Marketing home page.

On this page, she sees Categories in the navigation bar at the top, and she clicks it. A list of category choices appears. When she clicks Products, Coats appears as a choice under this category. She clicks Coats, and the subcategories for Coats appear above the search results for the category. Under Documents, SharePoint Portal Server displays a list of search results for all other content that is related to coats. Hanna sees a link to the Kodiak Design Specification labeled as a Best Bet for this category.

Because this is the newest product, Hanna decides to read this document first to get an overall understanding of the product. She clicks this link, which opens the document in her browser. After reading this document, she returns to the Coats category page by using the browser’s Back button.

Hanna looks at the long list of files related to the product and wonders if there is another way to organize these results. She notices a Sort by option at the top of the search results list. She clicks Date, and the recently modified items move to the top of the list. She opens and reads several of the files listed. She is now more familiar with the features of each product line.

Next, Hanna decides to read customer feedback about the latest product lines. She remembers the Customer Support category link, so she returns to the Categories page. She clicks Customer Support and sees a link for customer feedback. She clicks Customer Feedback, browses through additional categories, and reads customer comments about several products. By the end of her first day, she feels that she is familiar with the family of products. She now feels more confident about her ability to assist customers.

Subscribing to Updated Information

Because Hanna wants to keep up to date on any new information about the products, she chooses to set up a few valuable subscriptions. By subscribing to a search, she is notified about changes to content included in her search. She decides to set up two subscriptions.

  • She returns to the Products category page and subscribes to it. The dashboard site displays a notification on the Subscription Notifications page when any updates are made to the Products category.

  • Because the Kodiak coat is a new product, she wants to keep up to date with new information about it. Using the Search box at the top of the page, she types Kodiak and clicks Search. After examining the search results, she subscribes to this search as well.

The next day, Hanna receives an e-mail notification that four new customer comments were added under the Products category page and a new advertising campaign for the Kodiak coat is under discussion.


Looking Forward

In the previous chapters, you learned that Microsoft® SharePoint™ Portal Server can be deployed in a department or across an entire organization. It is designed to work seamlessly with familiar applications such as Microsoft Office and Microsoft Internet Explorer, so employees throughout an organization can take advantage of the product immediately. SharePoint Portal Server is the flexible Web-based portal solution that lets you find, share, and publish information easily. Your SharePoint Portal Server deployment can help you use existing content effectively and capture information in new ways that make sense for your business.

SharePoint Portal Server integrates basic document management functions such as check-in, check-out, document profiles, and document publishing with Microsoft Office products used every day. In addition, you can rapidly deploy an out-of-the-box dashboard site and easily use Web-Parts technology to customize a Web-based view of your organization's information. The dashboard site offers a central source for accessing information stored in a wide variety of formats and locations, while maintaining the security of the documents.

Expand Your Deployment

When your initial SharePoint Portal Server deployment provides value for one component of the organization, you will likely discover other uses for SharePoint Portal Server. You can easily add workspaces for different groups or create a corporate dashboard site with links to group dashboard sites. You can scale your use of SharePoint Portal Server from a single dashboard site to a network of organizational and departmental dashboard sites. Whether your deployment goal is building a corporate dashboard site to consolidate your information services or a creating a workspace to help a department manage its documents, you will find SharePoint Portal Server a versatile solution.

Maintain Your Deployment

As you find additional uses for SharePoint Portal Server, it is important to coordinate your deployment efforts with other groups in your company to maintain an efficient system of information management. Maintaining your deployment will ensure its effectiveness over time. After your deployment is in place, evaluate it periodically to ensure that it remains useful. As part of such an evaluation, consider these key factors:

  • Assess the value of your deployment. Does the deployment support your business needs? Can users easily find the information that they need on the dashboard site? Establish the business value of your deployment by measuring improvements in productivity, costs, customer satisfaction, or other measures of business success. This justifies the time and effort that you put into your solution.

  • Balance control with collaboration in managing SharePoint Portal Server. Have you distributed management of the workspace and dashboard site across key planners in your organization? Collaborating with others to manage the workspace and dashboard site can reduce bottlenecks caused by an overload of responsibilities.

  • Incorporate user feedback. Have you asked for regular feedback from your users? Recurring surveys, usability testing, and user interviews help to keep your efforts focused on the needs of your users.
Additional Deployment References

For additional information about SharePoint Portal Server and deployment recommendations, explore these planning references available for your use:

  • The User’s Help page, located in the workspace, provides links to help for all users.

  • The Getting Started page, located in the Management folder of your workspace, centralizes resources for administrators and coordinators.

  • The SharePoint Portal Server Software Development Kit (SDK) provides information about developing applications for SharePoint Portal Server.
  • The Digital Dashboard Resource Kit (DDRK) provides detailed information about customizing the dashboard site.


Accessibility for People with Special Needs

Accessibility for People
with Special Needs

Microsoft is committed to making its products and services easier for everyone to use. This appendix provides information on the following features, products, and services that make Microsoft® Windows®, Microsoft Windows NT®, and Microsoft SharePoint™ Portal Server more accessible for people with disabilities:

  • Features and hints for customizing Windows or Windows NT

  • Microsoft services for people who are deaf or hard-of-hearing

  • Microsoft software documentation online, or on audio cassette, floppy disk, or compact disc (CD)

  • Third-party utilities that enhance accessibility

  • Other products and services for people with disabilities

Note The information in this appendix applies only to users who license Microsoft products in the United States. If you obtained this product outside the United States, your package contains a subsidiary information card listing Microsoft support services telephone numbers and addresses. You can contact your subsidiary to find out whether the type of products and services described in this appendix are available in your area.


Customizing Windows or Windows NT

There are many ways you can customize Windows or Windows NT to make your computer more accessible.

  • Accessibility features have been built into Windows and Windows NT since the introduction of Microsoft Windows 95. These features are useful for individuals who have difficulty typing or using a mouse, have moderately impaired vision, or who are deaf or hard-of-hearing. The features can be installed during setup, or you can add them later from your Windows installation disks.

  • For information about installing and using these features, look up “accessibility” in the Windows Help Index.

  • Some of the accessibility features built into Windows and Windows NT can be added to earlier versions of those products, and to Microsoft MS-DOS®, through Access Pack files. You can download these files or you can order them on disks from Microsoft. (See details in “Accessibility Notes and Utilities to Download” later in this appendix.)

  • You also can use Control Panel and other built-in features to adjust the appearance and behavior of Windows or Windows NT to suit varying vision and motor abilities. These include adjusting colors and sizes, sound volume, and the mouse and keyboard functions.

  • In Microsoft Windows 98 and later, the majority of accessibility settings can be set through the Accessibility Wizard or Control Panel. The Accessibility Wizard presents features sorted by disability, making it easy to customize Windows to each individual's needs. The Accessibility Wizard also enables you to save your settings to a file that can be used on another computer.

  • Dvorak keyboard layouts make the most frequently typed characters on a keyboard more accessible if you have difficulty using the standard QWERTY layout. There are three Dvorak layouts: one if you are a two-handed user, one if you type with your left hand only, and another if you type with your right hand only. You do not need to purchase any special equipment to use these features.

The specific features that are available, and whether they are built-in or obtained separately, depend on which operating system you are using.

For full documentation on the accessibility features available in the operating system you are using, obtain the documents listed below. Accessibility features are also documented in the Microsoft Windows 95 Resource Kit, the Microsoft Windows 98 Resource Kit, the Microsoft Windows NT Resource Kit, and the Windows 2000 Resource Kit.


Accessibility Notes and Utilities to Download

The following documents explain how to customize Windows and Windows NT for users with disabilities. Specific instructions for downloading the files immediately follow this list.

For: | You need:
Customizing Windows for Individuals with Disabilities (describes all of the other documents in this list and includes links to download them) | Microsoft Knowledge Base article Q165486.
Customizing Windows 95 for individuals with disabilities | Cst_W95.exe
Customizing Microsoft Windows NT version 4.0 for individuals with disabilities | Cst_NT4.exe
Customizing Microsoft Windows NT version 3.1 and Microsoft Windows NT version 3.5 for individuals with disabilities (includes Access Pack for Microsoft Windows NT, which provides features for people who have difficulty using a keyboard or mouse, or who are deaf or hard-of-hearing) | Cst_NT3x.exe
Customizing Microsoft Windows 3.1 for individuals with disabilities | Cst_W3x.exe
Customizing Microsoft Windows for Workgroups 3.1 for individuals with disabilities | Cst_WG3x.exe
Customizing Microsoft Windows 3.0 for individuals with disabilities | Cst_W30.exe
Access Pack for Windows 3.0 and Windows 3.1, which provides features for people who have difficulty using a keyboard or mouse, or who are deaf or hard-of-hearing | ACCP.EXE
Dvorak keyboard layouts for people who type with one hand (already included in Windows NT 3.5 and later) | GA0650.EXE


To Download the Files

If you have a modem or another type of network connection, you can download the accessibility files from the following network services:

  • The Microsoft Accessibility and Disabilities Web site on the Internet, www.microsoft.com/enable.

  • Microsoft Product Support Services at http://support.microsoft.com/directory. First choose the link, “Searchable Knowledge Base.” Then choose the appropriate application from the list labeled “My search is about” (or choose “All Products”). Next, select “Specific article ID number” from “I want to search by.” In the “My question is” text box, enter “Q165486” and click Go, or press ENTER.

    The search results include a link to the Knowledge Base article, “Customizing Windows for Individuals with Disabilities,” which includes links to all of the documents listed above.

    For other accessibility articles, choose the appropriate application from the list labeled “My search is about” and type “kbenable” in the text box labeled “My question is.”

  • Microsoft Internet server at ftp.microsoft.com/softlib/mslfiles.


Microsoft Services for People Who Are Deaf or Hard-of-Hearing

If you are deaf or hard-of-hearing, complete access to Microsoft product and customer services is available through a text telephone (TTY/TDD) service.


Customer Service

You can contact the Microsoft Sales Information Center on a text telephone by dialing (800) 892-5234 between 6:30 A.M. and 5:30 P.M. Pacific time, Monday through Friday, excluding holidays.


Technical Assistance

For technical assistance in the United States, you can contact Microsoft Product Support Services on a text telephone at (800) 892-5234 between 6:00 A.M. and 6:00 P.M. Pacific time, Monday through Friday, excluding holidays. In Canada, dial (905) 568-9641 between 8:00 A.M. and 8:00 P.M. eastern time, Monday through Friday, excluding holidays. Microsoft support services are subject to the prices, terms, and conditions in place at the time the service is used.


Microsoft Documentation in Alternative Formats

In addition to the standard forms of documentation, SharePoint Portal Server documentation is available as online Help files in the workspace and on the CD that comes with the package to make them more accessible.

If you have difficulty reading or handling printed documentation, you can obtain many Microsoft publications from Recording for the Blind & Dyslexic, Inc. RFB&D distributes these documents to registered, eligible members of their distribution service, either on audio cassettes or on floppy disks. The RFB&D collection contains more than 80,000 titles, including Microsoft product documentation and books from Microsoft Press®. You can download many of these books from the Microsoft Web site at www.microsoft.com/enable.

For more information, contact Recording for the Blind & Dyslexic at the following address or phone numbers:

Recording for the Blind & Dyslexic, Inc.
20 Roszel Road
Princeton, NJ 08540 		Phone:

Fax:
World Wide Web: 		(800) 803-7201 or
(609) 452-0606
(609) 987-8116
www.rfbd.org


Utilities to Enhance Accessibility

A wide variety of hardware and software products are available to make personal computers easier to use for people with disabilities. Among the different types of products available for the MS-DOS, Windows, and Windows NT operating systems are:

  • Programs that enlarge or alter the color of information on the screen for people with visual impairments.

  • Programs that describe information on the screen in Braille or synthesized speech for people who are blind or have difficulty reading.

  • Hardware and software utilities that modify the behavior of the mouse and keyboard.

  • Programs that enable people to “type” by using a mouse or their voice.

  • Word or phrase prediction software that allow users to type more quickly and with fewer keystrokes.

  • Alternative input devices, such as single switch or puff-and-sip devices, for people who cannot use a mouse or a keyboard.


Getting More Accessibility Information

In addition to the features and resources already described in this appendix, other products, services, and resources for people with disabilities are available from Microsoft and other organizations.

Microsoft provides a catalog of accessibility aids that can be used with the Windows and Windows NT operating systems. You can obtain this catalog from the Microsoft Accessibility Web site at www.microsoft.com/enable.

The Trace R&D Center at the University of Wisconsin-Madison maintains a Web site with a variety of resources for people with disabilities and developers of assistive technology. For information, contact:

Trace R&D Center
University of Wisconsin-Madison
5901 Research Park Boulevard
Madison, WI 53719-1252 		Fax:
World Wide Web: 		(608) 262-8848
http://trace.wisc.edu/


Copyright

Information in this document, including URL and other Internet Web site references, is subject to change without notice. Unless otherwise noted, the example companies, organizations, products, people and events depicted herein are fictitious and no association with any real company, organization, product, person or event is intended or should be inferred. Complying with all applicable copyright laws is the responsibility of the user. Without limiting the rights under copyright, no part of this document may be reproduced, stored in or introduced into a retrieval system, or transmitted in any form or by any means (electronic, mechanical, photocopying, recording, or otherwise), or for any purpose, without the express written permission of Microsoft Corporation.

Microsoft may have patents, patent applications, trademarks, copyrights, or other intellectual property rights covering subject matter in this document. Except as expressly provided in any written license agreement from Microsoft, the furnishing of this document does not give you any license to these patents, trademarks, copyrights, or other intellectual property.

© 2001 Microsoft Corporation. All rights reserved.

Microsoft, MS-DOS, Windows, Windows NT, MSDN, and PowerPoint are either registered trademarks or trademarks of Microsoft Corporation in the United States and/or other countries.

The names of actual companies and products mentioned herein may be the trademarks of their respective owners.

The example companies, organizations, products, domain names, e-mail addresses, logos, people, places, and events depicted herein are fictitious. No association with any real company, organization, product, domain name, email address, logo, person, places, or events is intended or should be inferred.


Glossary

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z


Glossary

A

administrator

A user who sets up, configures and maintains servers, manages server resources, creates and updates indexes, and controls security at the top level of the workspace.

Applications folder

A folder containing a subfolder for each workspace that is automatically added to the index for that workspace. The subfolders can include applications designed for the Microsoft Web Storage System, making these applications searchable by SharePoint Portal Server 2001.

approval

The process of reviewing a document before publishing.

approval route

The path through which a document is approved.

approve

An option during approval to allow a draft document to be published.

See also: publish

approver

A user who has permission to approve or reject documents in a specified folder.

attribute

A behavior, condition, or state described in a property definition. Examples of attributes include a dictionary that is restrictive or unrestrictive for the setting of the value of the property, whether a property is optional or required to have a valid value before being successfully submitted to the Web Storage System, and the valid number and range of values for that property.

See also: property

author

A user who can add, edit, delete, or read all documents in a folder. Authors can also create, rename, and delete folders, but cannot set the security policy on a folder. In an enhanced folder, authors can also submit any document for publishing.

B

Best Bet

A document selected as highly relevant to a specific category or keyword search term on the dashboard site.

C

categories

Groups of related content, organized by subject matter.

Categories folder

A folder that is used by coordinators to organize categories.

Category Assistant

An automated tool used to categorize workspace documents.

check in

Add or return a document to an enhanced folder. Users with appropriate permissions will be able to edit or read the updated document after it is checked in.

See also: check out, enhanced folder

check out

Create a working copy of a document stored in an enhanced folder. Only the user who checks out a document can edit the document.

See also: check in, enhanced folder

check-in form

A form appearing when a user checks in a document. It contains check-in comments, an option to publish a document, and a drop-down menu for selecting a document profile.

comment

A brief text description that provides additional information or context about the document to which it is attached.

content source

The starting point for crawling a file system, database, or Web site in order to include content in an index.

coordinator

A user who can configure user roles on a folder, and can perform all author tasks as well. In an enhanced folder, coordinators can select an approval process, undo the check-out of a document, or end the publishing process by using the Cancel Publishing or Bypass Approval actions.

Coordinators at the workspace node can also manage content sources, document profiles, categories, and subscriptions, and can customize the dashboard site.

crawl

Search content to include it in an index.

D

dashboard

See definition for: digital dashboard

dashboard application

A dashboard plus all the support pieces, customization pages, and custom Web Part forms.

dashboard site

A web site created by using Digital Dashboard technology. The dashboard site contains a number of pages, or dashboards, and includes customization pages and custom Web Part forms. The dashboard site is used to distribute information to workspace users through a Web browser.

See also: dashboard, Web Part

dashboard view

A visual presentation of the information in a Web Part folder in a format suitable for viewing on a Web browser.

demote

To automatically copy the property values found in a SharePoint Portal Server document profile to the properties of a Microsoft Office document. For example, the author name entered in the Author property on the document profile is copied to the Author field on a Word document's properties page.

See also: promote

depth

A measure of how extensive a search is, such as how many links to follow from the content source.

See also: scope

dictionary

A list of possible values for a property. These may be suggested values, or values to which the property is restricted.

digital dashboard

A page on a dashboard site. Each dashboard contains a collection of Web Parts in a modular view that can be presented to users in a Web browser.

See also: dashboard site, Web Part

discussions

A feature for adding threaded remarks about a document.

document

A discrete unit of content and its associated metadata.

See also: file

document library

The storage location for documents in the workspace.

See also: Documents folder

document profile

A set of properties applied to similar documents.

Documents folder

A folder that is used to store documents in the workspace.

draft

An unpublished version of a document stored in the workspace.

See also: publish

E

enhanced folder

A document storage folder that supports document management tasks such as check-in, check-out, versioning, approval, and publishing.

exclusion rules

See definition for: inclusion/exclusion rules

F

file

A single, discrete unit of content. This does not include metadata.

See also: document

G

There are no glossary terms that begin with this letter.

H

There are no glossary terms that begin with this letter.

I

inclusion/exclusion rules

Rules that determine what content should be included or excluded when specific sites are crawled.

index

A resource that is compiled to enable full-text search of documents, document properties, and content stored outside the workspace but made available through content sources.

index workspace

A workspace that manages only content sources.

J

There are no glossary terms that begin with this letter.

K

keywords

A list that represents all possible terms a user might enter in a search form. These terms can be organized into optional hierarchies to help organize them more effectively.

L

There are no glossary terms that begin with this letter.

M

Management folder

A folder that contains the tools for managing document profiles, search resources, and workspace settings.

metadata

The properties and associated values of a document. Metadata can be system-defined, such as file size or date of modification, or user-defined, such as author or title.

Microsoft Management Console

(MMC) A management display framework that hosts administration tools and applications. By using MMC you can create, save, and open collections of tools and applications. Saved collections of tools and applications are called consoles.

N

There are no glossary terms that begin with this letter.

O

There are no glossary terms that begin with this letter.

P

permission

Authorization for a user to perform an action, such as sending e-mail for another user or posting items in a public folder.

Portal Content folder

A folder that contains content for the digital dashboard.

profile

See definition for: document profile

profile form

The form in which properties of a document are displayed, and values specific to the document are selected and stored.

promote

To automatically copy the property values found in a Microsoft Office document to the properties of a SharePoint Portal Server document profile. For example, the author name entered in the Author field of a Word document's properties page is copied to the Author property on the document profile.

See also: demote

property

An element of metadata for a document profile. Each document profile has multiple properties. Properties can be system-defined, such as file size or creation date, or can be user-defined, such as title or keywords.

property weighting

The ability to manipulate the rank of a search result by assigning more importance to particular property values. For example, a file that matches a search term in the title might rank higher than a file that matches the search term only in the text.

See also: rank coercion

publish

To make a document available to readers.

See also: approve, draft

Q

There are no glossary terms that begin with this letter.

R

rank

The relevance of a file to a search query.

rank coercion

The ability to rank a file at the top of search results for a given search query.

See also: property weighting

reader

A user who can search for and read documents but cannot add them to the workspace. By default, all folder users have reader permissions. In an enhanced folder, readers can only view folders and published versions of documents. A reader cannot check out, edit, or delete workspace documents and cannot view draft document versions.

reject

An option during approval to prevent a draft document from being published and return it to authors for additional editing.

roles

Logical sets of permissions, similar to groups, that determine access to documents in the workspace.

S

scope

The range and depth of a search on the dashboard site. For example, when searching for the term “fiscal reports,” you can narrow the scope of your search to a particular category such as Earnings.

See also: depth

search

The functionality of finding information in documents based on keywords found in the text of those documents or related to the properties of the documents. This is commonly referred to as full-text search. You must create full-text indexes to use full-text search.

See also: index

silent installation

An installation that runs unattended and does not require any user input after it has been started.

stemming

A method of mapping a linguistic stem to all matching words. For example, in English, the stem “buy” matches “bought,” “buying,” and “buys.”

subscription

A request for notification that occurs when changes are made to a document, the contents of a folder, a category, or a search results list.

T

There are no glossary terms that begin with this letter.

U

update

The process through which search crawls content and compiles an index of the content. Full updates include all content, incremental updates include only content that has changed, and adaptive updates include only content that is likely to have changed based on an analysis of historical information.

V

version history

The list of versions and associated comments about a particular document.

vocabulary

All of the values associated with documents in a workspace. These may include property values, document profiles, categories, and other keywords.

W

Web Part

A customizable, reusable component used to display specific information on a dashboard. Web Parts are used to associate web-based content (such as XML, HTML, and scripting) with a specific set of properties in an organizational framework.

See also: dashboard site, dashboard, Web Part folder

Web Part folder

A workspace folder, under the Portal Content folder, that is associated with a specific Web Part on the dashboard site. The Web Part folder applies a specific document profile to the documents it contains. For example, the Quick Links folder is associated with the Quick Links Web Part, and applies the Quick Links document profile to all the documents it contains.

See also: dashboard site, dashboard, Web Part

Web Storage System

A storage platform that provides a single repository for managing multiple types of unstructured information in one infrastructure. The Web Storage System combines the features and functionality of the file system, the Web, and a collaboration server (such as Exchange Server) through a single, URL-addressable location for storing, accessing, and managing information, in addition to building and running applications. The Web Storage System is based on the technology that drives Exchange Server Information Store.

word breaking

A search technology used to separate text into individual words for implementing search queries.

workspace

An organized collection of documents, content sources, management folders, categories, document profiles, subscriptions, and discussions. It provides a central location to organize, manage, and publish content.

X

There are no glossary terms that begin with this letter.

Y

There are no glossary terms that begin with this letter.

Z

There are no glossary terms that begin with this letter.