Team Foundation 安装

Visual Studio Team System
Team Foundation 安装
DropDown image

Team Foundation 安装指南是一个综合性指南，其中包括使用单服务器或双服务器以及多客户端拓扑的 Team Foundation 基本安装。此外，您所在的组织可能想要安装 Team Foundation Build 和 Team Foundation Server 代理。使用此安装指南安装和配置 Team Foundation。

概述

Visual Studio 2005 Team Foundation Server 提供了团队协作工具，使组织可以管理和跟踪软件项目的进度和状况。Team Explorer 将在项目站点上发现的项目工作产品集成到 Visual Studio IDE 中，以实现有效的团队访问。Team Foundation 还提供了可扩展的工作项跟踪和企业级的版本控制系统。

开始升级

若要从 Beta 3 Refresh 升级到候选发布，请从 Microsoft 下载中心 (http://go.microsoft.com/fwlink/?LinkID=60341) 下载升级包，并根据 Team Foundation 服务器的升级指示进行操作。若要进行新的安装，请按照本指南中的说明操作。

开始安装

若要在新计算机上成功安装 Team Foundation Server，您应该：

  • 下载此指南的最新版本，可从 Microsoft 下载中心 (http://go.microsoft.com/fwlink/?LinkId=40042) 进行下载。

  • 查看系统必备的安装和管理文档。

    • Windows Server 2003

    • Microsoft SQL Server 2005

    • Windows SharePoint Services

    • 根据组织需要所需的其他软件

  • 安装 Team Foundation Server 之前查看此安装指南中适用的部分。

  • 打印并使用安装 Team Foundation Server 时适用的检查表：

    • 检查表：Team Foundation Server 单服务器部署

    • 检查表：Team Foundation Server 双服务器部署

开始安装 MSDN Library

若要安装 MSDN Library，请在 MSDN 安装媒体的 MSDN 文件夹中找到文件 Setup.chm。MSDN 提供了几个安装选项，如“安装到网络”。这些选项不在本文档的范围之内。

我们会经常更新 Visual Studio Team System 文档。从 Visual Studio Team System 文档目录 (http://go.microsoft.com/fwlink/?LinkId=62213) 可以获取最新版本的 MSDN Library，其中包含对 Team Foundation Server 文档的更改。

本节内容

Team Foundation 逻辑结构

提供组成逻辑结构的 Team Foundation 层的概述。

Team Foundation 物理结构

提供 Team System 产品功能和 Team Foundation 物理结构的概述。

Team Foundation 系统要求

提供对每种部署安装此版本的 Team Foundation Server 时的硬件和软件系统要求。

相关章节

Team Foundation Server 安全安装概述

提供安装 Team Foundation Server 时安全方面的信息，如用户帐户、服务帐户、组和端口设置。

Team Foundation Server 单服务器部署概述

使用本节中的过程在一台服务器上安装和配置应用层组件和数据层组件 Team Foundation Server。

Team Foundation Server 双服务器部署概述

借助本节中的过程，使用两台计算机来安装和配置 Team Foundation Server，一台计算机用于数据层组件，另一台用于应用层组件。

Team Foundation Build 安装概述

使用本节中的过程来安装和配置 Team Foundation Build，esprbuild 提供了生成自动化功能，可帮助您生成和共享 Visual Studio 2005 解决方案。

安装 Team Foundation Server Proxy 概述

使用本节中的过程来安装 Team Foundation Server 代理，该代理缓存以前访问过的源代码管理文件。

团队资源管理器安装概述

使用本节中的过程来安装和配置 Team Explorer，esprtfc 充当客户端组件。

在线资源

Visual Studio Team System 开发人员中心 (http://go.microsoft.com/fwlink/?linkid=37625)。

Visual Studio Team System 主页。

Visual Studio Team System 论坛 (http://go.microsoft.com/fwlink/?linkid=53443)。

与 Visual Studio Team System 用户在线社区一同获取问题的答案并解决问题。

Team Foundation Server 自述文件 (http://go.microsoft.com/fwlink/?linkid=53268)。

包含与产品安装相关的最新问题。

Team Foundation Server 已知问题，位于 (http://go.microsoft.com/fwlink/?linkid=53095)。

包含与产品使用相关的最新问题。

Team Foundation Administrator's Guide（《Team Foundation 管理员指南》）(http://go.microsoft.com/fwlink/?LinkId=52459)。

提供了用于管理用户和组、配置服务器和客户端应用程序以及了解软件开发和 Visual Studio 2005 Team System 组件部署的帮助。

要提出有关“帮助”或本产品其他功能的建议或错误报告，请转到反馈站点。


Team Foundation 逻辑结构
请参见
DropDown image

提供 Team Foundation n 层逻辑结构的概述。

Team Foundation 逻辑结构

Team Foundation 基于多层体系结构，其中包括数据层、应用层和客户端层。

数据层

Team Foundation 数据层包含 Microsoft SQL Server 2005，后者可存储工作项、受版本控制的源文件、测试结果以及其他项目指标。

应用层

Team Foundation 应用层由基于 Web 的、与 Internet 信息服务 (IIS) 集成的前端应用程序组成。这些应用程序包括 SQL Server 2005 Reporting Services、Team Foundation Core Services 和 Windows SharePoint Services。此外，应用层还承载 Team Foundation Windows 服务。

Team Foundation 应用层还包括 Team Foundation Build 和 Team Foundation Server Proxy。Team Foundation Build 提供生成自动化服务。Team Foundation Server Proxy 缓存以前访问过的源代码管理文件，以提高低带宽连接中的源代码管理操作的性能。

客户端层

Team Foundation 客户端层包含 Team Explorer，后者可用作独立应用程序，也可与 Visual Studio 2005（Visual Studio 2005 速成版除外）集成。客户端层还与 Microsoft Office Project 2003 和 Microsoft Office Excel 2003 集成，项目经理可用它们来查看项目信息并将该信息发布到 Team Foundation Server。

请参见

概念

Team Foundation 安装
Team Foundation 物理结构


Team Foundation 物理结构
请参见
DropDown image

提供对 Team Foundation 物理结构的概述，包括每个 Team System 产品所提供的功能。

Team Foundation 物理结构

可以在一台或多台物理计算机上安装 Team Foundation 的逻辑层。

Team Foundation Server

可以使用单服务器或双服务器部署来安装 Team Foundation Server。

单服务器

Team Foundation Server 的单服务器部署会将数据层和应用层放在同一台计算机上。如果选择将客户端层与数据层和应用层安装在同一台计算机上，则只应在安装了服务器组件之后执行此操作。否则，可与其他层并行安装客户端层。有关更多信息，请参见 Team Foundation Server 单服务器部署概述。

双服务器

Team Foundation Server 的双服务器部署会将数据层和应用层放在不同计算机上。可以同时在两台服务器计算机上安装必备组件，但必须在安装 Team Foundation 应用层组件之前安装 Team Foundation 数据层组件。如果选择将客户端层与应用层安装在同一台计算机上，则只应在安装了应用层组件之后执行此操作。否则，可与其他层并行安装客户端层。有关更多信息，请参见 Team Foundation Server 双服务器部署概述。

Team Foundation Build

Team Foundation Server 提供了生成自动化功能，可帮助您使用 Team Foundation Build 来生成和共享 Visual Studio 2005 解决方案。可在安装 Team Foundation 应用层的不同或相同计算机上安装 Team Foundation Build。有关更多信息，请参见 Team Foundation Build 安装概述。

Team Foundation Server Proxy

Team Foundation Server Proxy 通过缓存以前访问的文件来提高 Team Foundation 版本控制性能。可在安装 Team Foundation 应用层的不同或相同计算机上安装 Team Foundation Proxy。有关更多信息，请参见安装 Team Foundation Server Proxy 概述

团队资源管理器

如上所述，客户端层包含 Team Explorer，后者可用作独立应用程序，也可与 Visual Studio 2005（Visual Studio 2005 速成版除外）集成。若要访问 Team Foundation Server，必须先安装 Team Explorer。Team Explorer 既是只具有 Team Foundation 功能的独立应用程序，又是可提供集成 Team Foundation 功能的 Visual Studio 的补充。它提供对工作项跟踪、项目管理和版本控制功能的访问。还可以使用 Team Explorer 来访问 Team Foundation Server 功能，以支持使用 Visual Studio 早期版本进行的开发活动。有关更多信息，请参见团队资源管理器安装概述。

请参见

概念

Team Foundation 安装
Team Foundation 逻辑结构


Team Foundation 系统要求

Team Foundation 系统要求
请参见
DropDown image

提供安装 Team Foundation Server 时对硬件和软件的系统要求。

  • Team Foundation Server（单服务器）

  • Team Foundation Server（双服务器）

  • Active Directory 域要求

  • 网卡设置

  • 64 位操作系统支持

  • 软件

  • Team Explorer

  • Team Foundation Build

  • Team Foundation Server Proxy

Team Foundation Server（单服务器）

下面是针对 Team Foundation Server 建议的系统要求列表。还应验证您的计算机是否满足 Team Foundation Server 必备组件的最低系统要求，如 Microsoft SQL Server 2005 和 Windows SharePoint Services 的要求。

Caution note 警告

Team Foundation Server 不能安装在域控制器上，并且不支持在同一计算机上安装其他服务器，如 Exchange Server 或 Host Integration Server。

单服务器部署，小型团队

用于支持 20 个用户或更少用户的团队级别，并用于产品评估：

组件 | 建议
处理器 | 2.2 GHz Pentium IV 或 Athlon
操作系统 | 带 Service Pack 1 (SP1) 的 Windows Server 2003 企业版 带 Service Pack 1 (SP1) 的 Windows Server 2003 标准版
RAM | 1 GB
硬盘 | 8 GB 可用空间

单服务器部署，中等团队

用于支持 50 个用户或更少用户的团队级别：

组件 | 建议
处理器 | 2.2 GHz Pentium IV 或 Athlon
操作系统 | 带 Service Pack 1 (SP1) 的 Windows Server 2003 企业版 带 Service Pack 1 (SP1) 的 Windows Server 2003 标准版
RAM | 2 GB
硬盘 | 30 GB 可用空间

Team Foundation Server（双服务器）

下面是针对 Team Foundation Server 建议的系统要求列表。还应验证您的计算机是否满足 Team Foundation Server 必备组件的最低系统要求，如 Microsoft SQL Server 2005 和 Windows SharePoint Services 的要求。

Caution note 警告

Team Foundation Server 不能安装在域控制器上，并且不支持在同一计算机上安装其他服务器，如 Exchange Server 或 Host Integration Server。

双服务器部署，部门

用于支持 250 个用户或更少用户的部门级别：

Team Foundation 应用层

组件 | 建议
处理器 | 2.2 GHz Pentium IV 或 Athlon
操作系统 | 带 Service Pack 1 (SP1) 的 Windows Server 2003 企业版 带 Service Pack 1 (SP1) 的 Windows Server 2003 标准版
RAM | 1 GB
硬盘 | 20 GB 可用空间

Team Foundation 数据层

组件 | 建议
处理器 | 双处理器，2.2 GHz Pentium IV 或 Athlon
操作系统 | 带 Service Pack 1 (SP1) 的 Windows Server 2003 企业版 带 Service Pack 1 (SP1) 的 Windows Server 2003 标准版
RAM | 2 GB
硬盘 | 80 GB 可用空间

双服务器部署，公司

用于支持 500 个用户或更少用户的公司级别：

Team Foundation 应用层

组件 | 建议
处理器 | 双处理器，2.2 GHz Pentium IV 或 Athlon
操作系统 | 带 Service Pack 1 (SP1) 的 Windows Server 2003 企业版 带 Service Pack 1 (SP1) 的 Windows Server 2003 标准版
RAM | 2 GB
硬盘 | 40 GB 可用空间

Team Foundation 数据层

组件 | 建议
处理器 | 四处理器，2.2 GHz Pentium IV 或 Athlon
操作系统 | 带 Service Pack 1 (SP1) 的 Windows Server 2003 企业版 带 Service Pack 1 (SP1) 的 Windows Server 2003 标准版
RAM | 4 GB
硬盘 | 150 GB 可用空间

Active Directory 域要求

若要在双服务器部署中安装和配置 Team Foundation Server，必须使用加入到 Active Directory 域中的计算机。对于单服务器部署，可以使用属于工作组成员的计算机，或使用加入到 Active Directory 域中的计算机。使用加入 Active Directory 域的计算机时，Team Foundation Server 需要用不包含 Windows NT Server 4.0 域控制器的 Active Directory 域。使用下表可确定 Team Foundation Server 是否支持您的 Active Directory 域功能级别。

Active Directory 域功能级别 | Supported
Windows 2000 混合模式 -- 支持运行 Windows NT Server 4.0、Windows 2000 和 Windows Server 2003 的域控制器。 | 否
Windows 2000 本机模式 -- 支持运行 Windows 2000 和 Windows Server 2003 的域控制器。 | 是
Windows Server 2003 临时模式 -- 支持运行 Windows NT Server 4.0 和 Windows Server 2003 的域控制器。 | 否
Windows Server 2003 模式 -- 支持运行 Windows Server 2003 的域控制器。 | 是

网卡设置

在各种操作过程中，Team Foundation Server 分别连接到数据层、应用层和客户端层的相应服务和组件。Team Foundation Server 完成大量数据传输（例如，新建团队项目、上载大型文档或将大型文件签入源代码管理）的速度在很大程度上取决于计算机网络的速度。

如果您在进行这样一些操作时感到性能很差，有可能就是因为网络配置问题人为限制了系统吞吐量。网络交换机和计算机网卡的配置（例如，是打开“自动感知模式”还是“自动协商”，是以全双工模式还是以半双工模式传送信息）会影响到网络的速度。

在许多情况下，不依赖自动检测而是将网卡设置为全双工模式并将适配器显式配置为以固定速度（例如 100Mbs）运行，就可以减少完成数据传输所需的时间。请确认每台计算机上的网卡设置正确。有关更多信息，请参见位于 http://support.microsoft.com/?scid=kb;EN-US;Q325487 的“How to troubleshoot network connectivity problems”（如果解决网络连接问题）一文。

64 位操作系统支持

下表表示 Team Foundation 应用程序支持的 64 位操作系统的范围：

Team Foundation 应用程序 | Supported
Team Foundation Server1 | 否
Team Foundation Server (databases)2 | 是
Team Foundation Server (services)2 | 否
Team Foundation Server (proxy) | 否
Team Foundation Server (build) | 否
团队资源管理器 | 否

1 Team Foundation Server 单服务器部署。

2 Team Foundation Server 双服务器部署。

软件

Team Foundation Server 需要下面的软件才能成功安装。若要安装 Team Foundation Server，您必须熟悉并安装下面的软件：

服务器软件 | 用途
Microsoft SQL Server 2005（Standard 或 Enterprise Edition） | 用于 Team Foundation Server 和 Windows SharePoint Services 的数据库后端。
Microsoft SQL Server 2005 修补程序 | 用于更有效地支持报告的 SQL Server Analysis Services 更新。
.NET Framework 2.0 修补程序 KB913363 | 用于更有效地支持大文件处理的 ASP.NET 更新。
带 Service Pack 2 的 Windows SharePoint Services 2.0 | 承载团队项目的门户站点。

Team Foundation Server 包括用于 Team Foundation Server 的 Microsoft SQL Server 2005 Standard Edition 的许可副本。

您可以使用 Team Explorer 和下面的附加软件，但不安装附加软件也可使用 Team Explorer。如果要使用它们，请确保在安装 Team Explorer 前安装它们。

客户端软件 | 用途
Microsoft Office Excel 2003 | 支持工作项跟踪的可选 Team Foundation 集成。
Microsoft Office Project Professional 2003 | 支持工作项跟踪的可选 Team Foundation 集成。

有关配置软件以使用 Team Explorer 的更多信息，请参见如何：安装团队资源管理器的系统必备。

可以将下面的附加软件与 Team Foundation Build 配合使用。要使用 Team Foundation Build 不一定要安装该附加软件；但是，如果要安装该软件，就一定要与 Team Foundation Build 安装在同一台计算机上，以便利用某些功能。

客户端软件 | 用途
Team Edition for Developers | 支持运行静态代码分析。
Team Edition for Testers | 支持在生成过程中运行测试。

团队资源管理器

Team Explorer 系统要求与 Visual Studio 2005 系统要求相同。有关更多信息，请参见 Visual Studio 2005 自述文件。Team Explorer 的建议硬件要求如下：

组件 | 建议
处理器 | 2.0 GHz
操作系统 | Team Explorer 的操作系统要求与 Visual Studio 2005 的操作系统要求相同。有关更多信息，请参见 Visual Studio 2005 自述文件。
RAM | 256 MB
硬盘 | 5 GB 可用空间

Team Foundation Build

Team Foundation Build 的软件要求与 Visual Studio 2005 的系统要求相同，不同的只是支持被限制为带 SP2 的 Windows XP Professional 和带 Service Pack 1 (SP1) 的 Windows Server 2003 标准版或企业版。有关更多信息，请参见 Visual Studio 2005 自述文件。Team Foundation Build 的建议硬件要求如下：

小型团队

用于生成时间少于 30 分钟的项目：

组件 | 建议
处理器 | 1.5 GHz
操作系统 | 带 Service Pack 1 (SP1) 的 Windows Server 2003 企业版 带 Service Pack 1 (SP1) 的 Windows Server 2003 标准版 带 SP2 的 Windows XP Professional
RAM | 512 MB

中等团队

用于生成时间少于 2 小时的项目：

组件 | 建议
处理器 | 2.6 GHz Pentium IV 或 Athlon
操作系统 | 带 Service Pack 1 (SP1) 的 Windows Server 2003 企业版 带 Service Pack 1 (SP1) 的 Windows Server 2003 标准版 带 SP2 的 Windows XP Professional
RAM | 1 GB

大型团队

用于生成时间多于 2 小时的项目：

组件 | 建议
处理器 | 双处理器，2.8 GHz Pentium IV 或 Athlon
操作系统 | 带 Service Pack 1 (SP1) 的 Windows Server 2003 企业版 带 Service Pack 1 (SP1) 的 Windows Server 2003 标准版 带 SP2 的 Windows XP Professional
RAM | 2 GB

Team Foundation Server Proxy

Team Foundation Server Proxy 软件要求包括 Internet 信息服务 (IIS)、.NET Framework 2.0 和修补程序 KB913363。Team Foundation Server Proxy 建议如下硬件要求：

组件 | 建议
处理器 | 单处理器，2.X GHz
操作系统 | 带 Service Pack 1 (SP1) 的 Windows Server 2003 企业版 带 Service Pack 1 (SP1) 的 Windows Server 2003 标准版
RAM | 2 GB

请参见

任务

如何：安装团队资源管理器的系统必备
如何：安装 Team Foundation Server Proxy
演练：安装 Team Foundation Server 单服务器部署
演练：安装 Team Foundation Server 双服务器部署

参考

检查表：Team Foundation Server 单服务器部署
检查表：Team Foundation Server 双服务器部署
检查表：Team Foundation Server 群集部署
检查表：备用应用层配置

概念

Team Foundation 安装
Team Foundation 物理结构


Team Foundation Server 安全安装概述

Team Foundation Server 安全安装概述
请参见
DropDown image

提供安装 Team Foundation Server 时与安全相关的信息。

本节内容

Team Foundation Server 安装所需的用户帐户

描述安装和配置 Team Foundation Server 时需要创建的用户帐户。

Team Foundation Server 安装所需的端口

提供有关需要在干扰防火墙上打开以使 Team Foundation 组件相互通信的端口的信息。

Team Foundation Server 安全组

描述 Team Foundation Server 用来管理安全性的安全组。

如何：向 Team Foundation Administrators 应用程序组添加用户

描述如何向“Team Foundation 管理员”组中添加用户，该组中包含可在服务器上执行所有特权 Team Foundation 操作的用户。

管理 Team Foundation Server 的安全性角色

描述 Team Foundation Server 所需的安全角色，其中包括 Windows SharePoint Services 和 SQL Server Reporting Services。

相关章节

Team Foundation Server 单服务器部署概述

使用本节中的过程在一台服务器上安装和配置 Team Foundation Server。

Team Foundation Server 双服务器部署概述

借助本节中的过程，使用两台计算机来安装和配置 Team Foundation Server，一台计算机用于数据层组件，另一台用于应用层组件。

Team Foundation Build 安装概述

使用本节中的过程来安装和配置 Team Foundation Build，后者提供了生成自动化功能，可帮助您生成和共享 Visual Studio 2005 解决方案。

安装 Team Foundation Server Proxy 概述

使用本节中的过程来安装 Team Foundation Server Proxy，后者缓存以前访问过的源代码管理文件。

团队资源管理器安装概述

使用本节中的过程来安装和配置 Team Explorer。

请参见

概念

Team Foundation 安装


Team Foundation Server 安装所需的用户帐户

Team Foundation Server 安装所需的用户帐户
请参见
DropDown image

描述安装和配置 Team Foundation Server 时需要的用户帐户。

部署注意事项

用户帐户要求取决于部署模型：单服务器或双服务器。在单服务器部署中，可以选择使用 Active Directory 域用户帐户或本地用户帐户。

单服务器部署

若要在加入到 Active Directory 域中的计算机上使用单服务器部署模型来安装和配置 Team Foundation Server，您需要下表中列出的三个 Active Directory 域用户帐户。

若要使用单服务器部署在属于工作组成员的计算机上安装和配置 Team Foundation Server，可以使用本地用户帐户。如果您使用用于运行安装程序和服务的本地用户帐户来安装 Team Foundation Server，则不能将域用户帐户添加到 Team Foundation Server，这些用户帐户无法创建项目。这些用户帐户应是域用户帐户，但也允许是本地用户帐户。

双服务器部署

若要使用双服务器部署模型来安装和配置 Team Foundation Server，这两台计算机都必须加入到 Active Directory 域中，并且您需要下表中列出的三个 Active Directory 域用户帐户。

所需帐户

安装 Team Foundation Server 之前，您必须标识将在安装过程中使用的帐户。本安装向导通过表中列出的占位符名称引用这些帐户。如果要使用不同的用户登录名，或者具有可以使用的现有帐户，请确保在安装期间根据需要将其替换为正确的名称。

示例用户登录名 用途

TFSSETUP

  • 用于运行 Team Foundation Server 安装程序。

  • 此帐户必须是 Team Foundation Server 计算机上的管理员。

  • 此帐户和接下来的两个服务帐户必须是同一个域的成员。例如，您不能有一个域的两个服务帐户，然后使用一个本地帐户运行安装程序。

TFSSERVICE

  • 用作 Team Foundation Server Windows 服务（代码覆盖率分析服务和 TFSSchedulerService）和 SharePoint Timer Service 的服务帐户。

  • 用作 Team Foundation Server 应用程序池 (VSTF AppPool) 和 Windows SharePoint Services 应用程序池（TFWSS 和 WSS_AppPool）的应用程序池标识。

  • 必须对 Team Foundation Server 计算机具有“本地登录”权限。

  • 要获得最佳安全性，此服务帐户：

    • 不应是 Team Foundation Server 计算机上的管理员。

    • 应为域上的 Active Directory 选择“帐户敏感，无法委托”选项。

TFSREPORTS

  • 用作 SQL Server Reporting Services 数据源的服务帐户。

  • 此帐户不应是 Team Foundation Server 计算机上的管理员。

  • 此帐户必须对 Team Foundation Server 计算机具有“本地登录”权限。

TFSPROXY

  • 由不是同一域的成员的计算机上的 Team Foundation Server 代理用作 Team Foundation Server 应用层和数据层组件。

  • 此服务帐户必须是远程计算机上“Administrators”组的成员。

  • 此服务帐户必须是使用代理的 Team Foundation Server 的“Team Foundation Valid Users”组的成员。

有关更多信息，请参见 Team Foundation Server 安装所需的用户帐户。

请参见

任务

如何：安装团队资源管理器的系统必备
如何：安装 Team Foundation Server Proxy
演练：安装 Team Foundation Server 单服务器部署
演练：安装 Team Foundation Server 双服务器部署

参考

检查表：Team Foundation Server 单服务器部署
检查表：Team Foundation Server 双服务器部署
检查表：Team Foundation Server 群集部署
检查表：备用应用层配置

概念

Team Foundation 安装

其他资源

Team Foundation Server 安全安装概述


Team Foundation Server 安装所需的端口

Team Foundation Server 安装所需的端口
请参见
DropDown image

提供了有关需要在干扰防火墙上打开以使 Team Foundation 组件可以相互进行通信的 TCP 端口的信息。

所需的端口

要在 Team Foundation Server、其必备组件和客户端之间启用通信，必须确保这些组件之间的所有防火墙都允许通过多个 TCP 端口进行通信。

Note 注意

Team Foundation Server 和 SQL Server 安装向导将自动为 Windows 防火墙的运行实例添加所需的 TCP 端口例外。如果 Windows 防火墙未运行，或者它被配置为不允许例外，则将不添加例外。

SQL Server 2005 所需的端口

Microsoft SQL Server 2005（Developer、Standard 或 Enterprise 版）使用以下 TCP 端口：

服务或应用程序上下文 | TCP 端口
SQL Server Reporting Service | 80
SQL 服务 | 1433
SQL 浏览器服务 | 1434
SQL 监视 | 1444
SQL Server Analysis Service 重定向程序 | 2382
SQL Server Analysis Service | 2383

Windows SharePoint Services 所需的端口

Windows SharePoint Services 使用以下 TCP 端口：

服务或应用程序上下文 | TCP 端口
Windows SharePoint Services | 80
SharePoint 中心管理 | 17012

Team Foundation Server 所需的端口

Team Foundation Server 使用以下 TCP 端口：

服务或应用程序上下文 | TCP 端口
Team Foundation Server | 8080
Team Foundation Server Proxy | 8081
Team Foundation Build Remoting1 | 9191

Scope

在 Windows 防火墙中，可以指定不对其阻止端口或服务的一组计算机。默认情况下，该范围设置为“任何计算机(包括 Internet 上的计算机)。如果您选择限制不阻止端口或服务的范围，则请确保需要访问该端口或服务的所有计算机都包含在指定范围内。

请参见

任务

如何：安装团队资源管理器的系统必备
如何：安装 Team Foundation Server Proxy
演练：安装 Team Foundation Server 单服务器部署
演练：安装 Team Foundation Server 双服务器部署

参考

检查表：Team Foundation Server 单服务器部署
检查表：Team Foundation Server 双服务器部署
检查表：Team Foundation Server 群集部署
检查表：备用应用层配置

其他资源

Team Foundation Server 安全安装概述


Team Foundation Server 安全组
请参见
DropDown image

描述 Team Foundation Server 用来管理安全性的安全组。

Team Foundation Server 安全组

Team Foundation Server 的安全性由 Team Foundation Server 安全组来管理，这些安全组不同于 Windows 域或本地安全组。

Team Foundation Server 安全组 说明

Team Foundation 管理员

  • 此组包含可在服务器上执行所有特权操作的用户。

  • 默认情况下，安装程序会将用于运行安装程序的帐户（例如 Domain\TFSSETUP）添加到此组中。

Service Accounts

  • 此组包含 Team Foundation Server 服务帐户，如用于 Team Foundation Server Web 服务的应用程序池标识（例如 Domain\TFSSERVICE）。

Team Foundation Valid Users

  • 此组包含对服务器具有访问权限的所有用户和组。

Team Foundation Server 安装程序会将用于运行安装程序的用户帐户（例如 Domain\TFSSETUP）添加到“Team Foundation 管理员”组中。若要将其他用户添加到此组中，必须使用已经是“Team Foundation 管理员”成员的帐户。安装完成后，需要使用运行安装程序时所用的帐户（例如 Domain\TFSSETUP）来登录，以便将初始新成员添加到“Team Foundation 管理员”组中。

Team Foundation Server 安装程序还会将 Team Foundation Server 服务帐户（例如 Domain\TFSSERVICE）添加到“Service Accounts”组中。

请参见

任务

如何：向 Team Foundation Administrators 应用程序组添加用户

概念

Team Foundation 安装

其他资源

Team Foundation Server 安全安装概述


如何：向 Team Foundation Administrators 应用程序组添加用户

如何：向 Team Foundation Administrators 应用程序组添加用户
请参见

Team Foundation Server 的安全性由 Team Foundation Server 安全组管理，后者不同于 Windows 域或本地安全组。Team Foundation Administrators 组包含可在服务器上执行所有特权的 Team Foundation 操作的用户。

Note 注意

用于运行 Team Foundation Server 安装程序的用户帐户（例如 Domain\TFSSETUP）将自动添加到 Team Foundation Administrators 组中。若要向此组中添加其他用户，必须使用已经是此安全组的成员的帐户（例如 Domain\TFSSETUP）。

若要让用户能够创建项目，则必须将他们添加到此组中，并分配给 Windows SharePoint Services 和 SQL Server Reporting Services 中的角色。可以使用 Team Explorer 或 TFSSecurity 命令行实用工具

使用团队资源管理器向 Team Foundation Administrators 安全组中添加用户

  1. 使用已经是 Team Foundation Administrators 安全组成员的用户帐户（例如 Domain\TFSSETUP）的凭据登录到客户端层计算机。

  2. 安装 Team Explorer。有关更多信息，请参见团队资源管理器安装概述。

  3. 启动 Visual Studio 并连接到 Team Foundation Server。有关更多信息，请参见如何：将团队资源管理器连接到 Team Foundation Server。

  4. 在团队资源管理器中，选择要管理的 Team Foundation Server。

  5. 在“团队”菜单上，指向“Team Foundation Server 设置”，然后单击“组成员资格”。

  6. 在“全局组”对话框中，选择要向其中添加用户的组，然后单击“属性”。

  7. 在“Team Foundation Server 组属性”对话框中的“成员”选项卡上，选择“Windows 用户或组”，然后单击“添加”。

  8. 在“选择用户或组”对话框中，按照下面的格式输入要添加的用户的域名和用户名：

    domain\username

    要一次添加多个用户，请用分号 (;) 分隔各项。

  9. 单击“确定”。

使用 Team Foundation Security 命令行实用工具 (TFSSecurity.EXE) 向 Team Foundation Administrators 安全组中添加用户

  1. 使用已经是 Team Foundation Administrators 安全组成员的用户帐户（例如 Domain\TFSSETUP）的凭据登录到应用层计算机。

  2. 在 Windows 资源管理器中，定位到 Team Foundation Server 安装文件夹中的 Tools 目录。

    默认情况下，路径为 <驱动器>:\Program Files\Microsoft Visual Studio 2005 Team Foundation Server\Tools。

  3. 在“开始”菜单上，单击“所有程序”，然后单击“命令提示符”。

  4. 在命令提示符窗口中，使用 TFSSecurity 命令行实用工具的 /g+ 选项向 Team Foundation Administrators 组添加用户。

    必须设置以下标识说明符并指示 Team Foundation Server 服务器。

    • Adm 指定将用户添加到全局管理员组。

    • n 指定要添加的域和用户帐户

    • /server 指示用于应用层的 Team Foundation Server 服务器。

    例如，下列命令将 ADATUM 域中的 Dieter Zilch 的用户帐户添加到已使用应用层连接到本地计算机的 Team Foundation Server。

    TFSSecurity /g+ adm: n: ADATUM\DZilch /server:http://localhost:8080

使用户能够创建团队项目

要创建团队项目，还必须为用户分配 SQL Server Reporting Services 和 Windows Server SharePoint Services 中的角色。下面提供了用于分配角色的位置。有关如何使用页面的更多信息，请参见 Team Foundation Server 管理指南或使用页面上提供的帮助。

为用户分配其他组件中的角色

  1. 在 http://<application-tier>/_layouts/1033/user.aspx 页面上向用户添加 Windows SharePoint Services 管理员角色。

  2. 使用位于 http://<application-tier>/Reports 的 SQL Server Reporting Services 主页向用户添加 SQL Server Reporting Services 内容管理员角色。

安全

要执行此过程，您必须是 Team Foundation Administrators 组的成员，或者具有设置为“允许”的“编辑服务器级别信息”权限。用于安装 Team Foundation Server 的用户帐户会自动添加到此组中，并且可以在安装期间添加用户。有关更多信息，请参见 Team Foundation Server 管理员指南中的“Team Foundation Server 权限”(http://go.microsoft.com/fwlink/?linkid=52459)。

请参见

概念

Team Foundation 安装
Team Foundation Server 安装所需的用户帐户
Team Foundation Server 安全组


管理 Team Foundation Server 的安全性角色

管理 Team Foundation Server 的安全性角色
请参见
DropDown image

描述 Team Foundation Server 所需的安全角色，其中包括 Windows SharePoint Services 和 SQL Server Reporting Services。

安全角色成员资格

向 Team Foundation Server 安全角色中添加用户帐户时，还必须将该用户添加到 Window SharePoint Services 和 SQL Server Reporting Services 中的相应安全角色中。

若要在 Team Foundation Server 中创建新的团队项目，您必须是“Team Foundation 管理员”组的成员、Windows SharePoint Services“管理员”角色的成员，并且还必须是 SQL Server Reporting Services“内容管理员”角色的成员。下表指示 Team Foundation Server 中全局安全组的每种产品中的正确的安全角色成员资格。

Team Foundation Server 安全组 | Windows SharePoint Services 角色 | SQL Server Reporting Services 角色
[Server]\Team Foundation 管理员 | Administrator（顶级站点） | Content Manager（系统级别角色）
[Server]\Team Foundation Valid Users | n/a1 | n/a1
[Server]\Service Accounts | n/a2 | n/a2

1 “Team Foundation Valid Users”组包含对服务器具有访问权限的所有用户和组。此组包含属于服务器上存在的团队项目的成员的所有用户和组。不需要管理此组的成员资格。

2 “Service Accounts”组中的帐户不需要具有 Windows SharePoint Services 或 SQL Server Reporting Services 中的安全角色成员资格。

创建一个团队项目后，您为用户分配不同角色，以便根据每个项目来管理用户权限。Windows SharePoint Services 站点不从顶级站点继承安全设置。与之相反，SQL Server Reporting Services 的项级别安全继承系统级别的角色。下表指示 Team Foundation Server 中的项目级别安全组的每种产品中正确的安全角色成员资格。

Team Foundation Server 安全组 | Windows SharePoint Services 角色 | SQL Server Reporting Services 角色
[ProjectName]\Project Administrators1 | 管理员 | Content Manager
[ProjectName]\Contributor1 | 参与者 | 浏览器
[ProjectName]\Reader1 | 读者 | 浏览器

1此名称是从“MSF for Agile Software Development”过程模板派生的。项目级别安全组的实际名称将根据所选的过程模板的不同而有所不同。

管理 Windows SharePoint Services 和 SQL Server Reporting Services 中安全角色成员资格的过程可在每种产品附带的产品文档中找到。

请参见

概念

Team Foundation 安装


Team Foundation 安装演练

Team Foundation 安装演练
DropDown image

您可以使用下面的演练根据您的部署选择在一个主题中查看安装过程。这些演练仅涉及数据库和应用层服务的安装。有关如何安装 Team Foundation 客户端层组件的信息，请参见“相关章节”中的链接。

本节内容

演练：安装 Team Foundation Server 单服务器部署

描述在一台计算机上安装数据层和应用层的过程。

检查表：Team Foundation Server 单服务器部署

提供一个检查表，以便在 Team Foundation Server 单服务器部署期间用作手头参考。

演练：安装 Team Foundation Server 双服务器部署

描述在一台计算机上安装数据层并在另一台计算机上安装应用层的过程。

检查表：Team Foundation Server 双服务器部署

提供一个检查表，以便在 Team Foundation Server 双服务器部署期间用作手头参考。

参考

Team Foundation 系统要求

Team Foundation Server 安装所需的用户帐户

Team Foundation Server 安装所需的端口

相关章节

Team Foundation Build 安装概述

安装 Team Foundation Server Proxy 概述

团队资源管理器安装概述


演练：安装 Team Foundation Server 双服务器部署

演练：安装 Team Foundation Server 双服务器部署
请参见
CollapseAll 图像 DropDown 图像

可以使用此演练在两台计算机上设置 Team Foundation Server 的服务器组件。

Expand 图像 先决条件

为了完成安装，需要下列设备和信息。

  • 检查表：Team Foundation Server 双服务器部署的打印版本。

  • 可满足团队规模大小所需的硬件和软件要求的两台计算机。有关更多信息，请参见 Team Foundation 系统要求。

  • 两个 Team Foundation Server 服务帐户。有关更多信息，请参见 Team Foundation Server 安装所需的用户帐户。

  • 完成安装所用的用户帐户，该帐户是这两台计算机上的“Administrator”安全组的成员。

Expand 图像 过程摘要

安装数据层组件

  1. 使用安装媒体上的应答文件安装 Microsoft SQL Server 2005 Standard 或 Enterprise Edition。

  2. 安装 Microsoft SQL Server 2005 的修补程序，启用并重新启动 SQL Browser 服务。

  3. 安装 Team Foundation Server (databases)。

安装应用层服务

  1. 安装 Internet 信息服务 (IIS) 并启用 ASP.NET。

  2. 安装 SQL Server 2005 Reporting Services

  3. 安装 Microsoft .NET Framework 2.0 的修补程序。

  4. 安装带有 Service Pack2 的 Windows SharePoint Services。

  5. 安装 Team Foundation Server (services)。

Expand 图像 在数据层上安装 Microsoft SQL Server 2005

满足系统必备后，可以安装 Microsoft SQL Server 2005 Standard 或 Enterprise Edition。

以交互方式安装 Microsoft SQL Server 2005

  1. 在数据层计算机上，使用 Team Foundation Server 设置帐户（例如 Domain\TFSSETUP）登录到 Windows。

  2. 插入 Microsoft SQL Server 2005 的 CD。在“SQL Server 2005 启动”页的“安装”下，单击“服务器组件、工具、联机丛书和示例”。

    Note 注意

    Microsoft SQL Server 2005 标准版 CD 与 Team Foundation Server 一起提供。要安装 Microsoft SQL Server 2005 Enterprise，可以使用单独购买的软件中包含的 CD。通过运行位于安装媒体的 Servers 文件夹中的 Splash.hta 文件，可以显示“开始”页。

    此时将启动 Microsoft SQL Server 2005 安装向导。

  3. 在“最终用户许可协议”页上查看许可协议。如果您接受其中的条款和条件，请选择“我接受许可条款和条件”，然后单击“下一步”。

  4. 在“安装必备组件”页上单击“安装”。在成功安装了所需的组件后，单击“下一步”。

    此时将启动“Microsoft SQL Server 安装向导”。

  5. 单击“下一步”以启动“系统配置检查”。

  6. 在“系统配置检查”页上，检查所有要求操作（例如要求的系统重新启动）的状态，并遵循本页上的指导进行操作，直到所有操作都获得“成功”状态。在除“IIS 功能要求”之外的所有操作都获得“成功”状态后，请单击“下一步”开始安装。

    Note 注意

    SQL Server 2005 Reporting Services 不会安装在数据层计算机上。您可以忽略“IIS 功能要求”的“警告”状态，不会有任何问题。安装程序可能要过一会才能启动。

  7. 在“注册信息”页上填写完注册信息，然后单击“下一步”。

  8. 在“要安装的组件”页上，选择下面的组件，然后单击“高级”。

    • SQL Server Database Services

    • Analysis Services

    • Integration Services

    • 工作站组件、联机丛书和开发工具

      Note 注意

      Reporting Services 应安装在应用层上。Team Foundation Server 不需要 Notification Services。

  9. 在“功能选择”页上，展开下面的节点并指定以下选项。

    Note 注意

    除本节所述情形外，不应更改任何其他功能区中的默认选择。

    1. 在“Database Services”下单击“复制”图标，然后选择“整个功能将不可用”。

      Note 注意

      如果要为数据文件指定不同的位置，选择“数据文件”，然后单击“浏览”以指定目录或不同的物理硬盘。默认情况下，SQL Server 2005 将所有文件安装到系统驱动器中。可以通过使用不同的位置来优化系统性能。对“Analysis Services”下的“数据文件”可以执行同样的操作。

    2. 在“客户端组件”下，唯一需要安装的功能是“管理工具”。对于“客户端组件”下的所有其他项，可以选择单击图标并选择“整个功能将不可用”。

    3. 在“文档、示例和示例数据库”下，可以选择单击“联机丛书”的图标并选择“整个功能将不可用”。单击“下一步”。

  10. 在“实例名”页上，选择“默认实例”，然后单击“下一步”。

    Note 要点

    如果指定已命名的实例，Team Foundation Server 安装将失败。

  11. 在“服务帐户”页上，选择“使用内置系统帐户”并从列表中选择“本地系统”。在“安装结束时启动服务”中，选择所有服务：“SQL Server”、“SQL Server Agent”、“Analysis Services”和“SQL Browser”，然后单击“下一步”。

    Note 注意

    此服务帐户用于 Microsoft SQL Server 2005，不应与启动安装前获取的两个服务帐户混淆。

  12. 在“身份验证模式”页上，选择“Windows 身份验证模式”，然后单击“下一步”。

  13. 在“排序规则设置”页上，选择适合您的语言的排序规则，然后单击“下一步”。

    Note 注意

    如果更改了“排序规则指示符和排序顺序”，则必须选择“区分重音”。

    默认选择基于 Windows Server 2003 中的非 Unicode 语言的设置。对于多数语言，默认选择都是 Windows 排序规则，但对于美国英语，SQL Server 2005 安装时使用 SQL Server 排序规则以向后兼容。如果要更改默认的排序规则以支持其他美国英语字符，请考虑“Latin1_General”。

    对于其他语言，请考虑“_90”Windows 排序规则（当可用时），否则使用其他 Windows 排序规则。

    例如，对于日语部署，如果按下面的方式使用 Unicode CJK Extension A 字符或 Unicode 代理项，请使用“Japanese_90”排序规则，而不是默认排序规则。

    • Team Foundation Server 对象名，如“查询”或“项目”。

    • 签入到版本控制系统中的文件或路径。

    • 用于搜索的任何工作项字段。

    为了避免由全角字符或平假名/片假名等效字符带来的问题，请在安装过程中选中启用区分假名和全角字符的复选框。

    Team Foundation Server 不支持如下排序规则：

    • 不区分重音

    • 二元

    • Binary2

    • 区分大小写

    有关排序规则设置的更多信息，请参见 SQL Server 2005 Books Online（《SQL Server 2005 联机丛书》）中的“Collation Settings in Setup”（安装中的排序规则设置）。

  14. 在“错误和使用情况报告设置”页上，可以选择“自动将 SQL Server 2005 的错误报告发送到 Microsoft 或您公司的错误报告服务器”和“自动将 SQL Server 2005 的功能使用情况数据发送到 Microsoft”，然后单击“下一步”。

  15. 在“准备安装”页上，可以查看要安装的组件的列表，然后单击“安装”。

  16. 在“安装进度”页上，可以监视每个组件的安装状态。安装完成后，单击“下一步”。

    Note 注意

    在激活 SQL Server Reporting Services 期间，安装可能看起来像是有几分钟停止响应。

  17. 单击“完成”退出向导。

    Note 注意

    若要在安装 Team Foundation Server 之前验证安装情况，请参见如何：验证 Microsoft SQL Server 2005 的安装。

Expand 图像 安装 Microsoft SQL Server 2005 修补程序

安装 Microsoft SQL Server 2005 后，必须安装修补程序来更新 SQL Server Analysis Services 以便更有效地支持报告。

Note 注意

有关最近的更新，请访问 Microsoft 网站 (http://go.microsoft.com/fwlink/?LinkId=62015)。

安装 Microsoft SQL Server 2005 修补程序

  1. 在数据层计算机上，打开“SQL Server 配置管理器”，右击“SQL Server 浏览器服务”，然后单击“停止”。

  2. 在 Team Foundation Server 安装媒体上，找到 SQLServerKB 文件夹。

  3. 找到与您的操作系统和语言对应的可执行文件 (.exe)，如 AS2005-KBnnnnnn-x86-ENU.exe，然后双击该文件以启动 Hotfix Installer（修补程序安装程序）。

  4. 在 “Hotfix Installer”中接受“End User License Agreement”（最终用户许可协议），完成各页以安装该修补程序，然后单击“Finish”（完成）。

  5. 在“SQL Server 配置管理器”中，右击“SQL Server Browser 服务”，然后单击“属性”。

  6. 在“服务”选项卡上找到“启动模式”，然后选择“自动”。

  7. 在“登录”选项卡上，单击“启动”。

    Note 注意

    如果在“登录”选项卡上未启用“启动”，则单击“服务”选项卡，将“启动模式”设置为“禁用”，然后再次选择“自动”以显式更新“启动模式”。

要在安装 Windows SharePoint Services 之前验证安装，请参见如何：验证 Microsoft SQL Server 2005 的安装。

Expand 图像 安装 Team Foundation Server 数据库

安装 Team Foundation Server 前，请确保已安装并正在运行 Microsoft SQL Server 2005 Standard 或 Enterprise Edition。有关更多信息，请参见检查表：Team Foundation Server 双服务器部署。

安装 Team Foundation Server (databases)

  1. 使用您在核对检查表时确定的 Team Foundation Server 设置帐户（例如 Domain\TFSSETUP）登录到 Windows。

  2. 插入 Team Foundation Server 安装媒体，在出现的自动运行页上单击“安装 Team Foundation Server”，再单击“双服务器安装”，然后单击“仅安装 Team Foundation 数据库层”。

    如果未出现自动运行页，请在安装媒体的根文件夹中找到并运行自动运行文件 (autorun.exe)。

    此时将启动 Visual Studio 2005 Team Foundation Server (databases) 安装向导。

  3. 在“欢迎使用安装程序”页上单击“下一步”。

  4. 在“许可条款”页上查看许可协议。如果您接受其中的条款和条件，请选择“我接受许可协议中的条款”，然后单击“下一步”。

  5. 在“目标文件夹”页上单击“下一步”。

  6. 在“系统状况检查”页上，单击“报告”链接检查是否有任何警告或阻止。

    • 必须先解决阻止问题，然后才能继续安装。单击“取消”并在解决问题之后再次运行安装程序。

    • 应在继续安装之前解除警告，但不应阻止安装程序完成。可以单击“下一步”。

      例如，如果未启用防火墙，则会在列表中出现一个警告。可以继续安装，但是可能必须手动添加启用组件之间的通信所必须使用的端口和例外。

    • 如果没有列出任何内容，则单击“下一步”。

  7. 在“安装准备就绪”页上单击“安装”。

  8. 在“正在安装组件”页上，可以监视 Team Foundation 数据层组件的安装。

    在安装期间，可能会提示您重新启动计算机。单击“立即重新启动”。在重新启动计算机并且您使用同一帐户再次登录后，安装将继续。

  9. 在“成功完成安装”页上单击“完成”。

  10. 在自动运行页上单击“退出”。

查看 Team Foundation Server 数据库

  1. 从“开始”菜单上单击“程序文件”，再单击“Microsoft SQL Server 2005”，然后单击“SQL Server Management Studio”。

  2. 在“连接到服务器”对话框中选择“服务器中的数据库引擎”类型，键入要连接到的服务器的名称，然后单击“连接”。

    Note 注意

    如果 SQL Server 安装在一个群集上，则服务器的名称是该群集的名称而不是该计算机的名称。

  3. 在“对象资源管理器”中，展开“数据库”并验证 Team Foundation Server 数据库是否存在。

Expand 图像 将应用层配置为应用程序服务器

您的应用层计算机可能已配置为应用程序服务器。如果已配置 Internet 信息服务 (IIS) 这个 Windows 组件，请验证是否已启用 ASP.NET，如果没有则启用。否则，请按照此过程安装 IIS 并启用 ASP.NET。

使用“添加/删除程序”实用工具来启用 ASP.NET

  1. 从“控制面板”中打开“添加/删除程序”。

  2. 单击“添加/删除 Windows 组件”。

    此时将启动“Windows 组件向导”。

  3. 在“Windows 组件”页上选择“应用程序服务器”，然后单击“详细信息”。

  4. 如果尚未选中，请选择“ASP.NET”，然后单击“确定”。

    Note 要点

    任何时候都不要选择“FrontPage 2002 Server Extensions”。此服务器将承载 Windows SharePoint Services，后者与 FrontPage 服务器扩展不兼容。

  5. 在“Windows 组件”页上单击“下一步”。

    Note 注意

    可能会提示您插入 Windows Server 2003 安装媒体。

  6. 单击“完成”关闭向导。

  7. 访问 Windows Update (http://windowsupdate.microsoft.com) 并安装“重要更新和 Service Pack”组中的所有项。

Expand 图像 安装 SQL Server Reporting Services

启用 ASP.NET 后，安装与 Team Foundation Server 一同使用的 SQL Server 2005 Reporting Services（使用 Microsoft SQL Server 2005 Standard 或 Enterprise Edition）。

安装 Microsoft SQL Server 2005 Reporting Services

  1. 在应用层计算机上，使用 Team Foundation Server 设置帐户（例如 Domain\TFSSETUP）登录到 Windows。

  2. 插入 Microsoft SQL Server 2005 的 CD。在“SQL Server 2005 启动”页的“安装”下，单击“服务器组件、工具、联机丛书和示例”。

    Note 注意

    Microsoft SQL Server 2005 标准版 CD 与 Team Foundation Server 一起提供。要安装 SQL Server Enterprise，可以使用单独购买的软件中包含的 CD。通过运行位于安装媒体的 Servers 文件夹中的 Splash.hta 文件，可以显示“开始”页。

    此时将启动 Microsoft SQL Server 2005 安装向导。

  3. 在“最终用户许可协议”页上查看许可协议。如果您接受其中的条款和条件，请选择“我接受许可条款和条件”，然后单击“下一步”。

  4. 在“安装必备组件”页上单击“安装”。在成功安装了所需的组件后，单击“下一步”。

    此时将启动“Microsoft SQL Server 安装向导”。

  5. 单击“下一步”以启动“系统配置检查”。

  6. 在“系统配置检查”页上，检查所有要求操作（例如要求的系统重新启动）的状态，并遵循本页上的指导进行操作，直到所有操作都获得“成功”状态。在所有操作都获得“成功”状态后，单击“下一步”开始安装。

    Note 注意

    安装程序过一会才会启动。

  7. 在“注册信息”页上填写完注册信息，然后单击“下一步”。

  8. 在“要安装的组件”页上，选择“Reporting Services”，然后单击“下一步”。

    Note 注意

    如果单击“高级”，请不要移除任何默认选择。

  9. 在“实例名”页上，选择“默认实例”，然后单击“下一步”。

    Note 要点

    如果指定已命名的实例，Team Foundation Server 安装将失败。

  10. 在“服务帐户”页上，选择“使用内置系统帐户”并从列表中选择“网络服务”。在“在安装结束时启动服务”中，选择“Reporting Services”，然后单击“下一步”。

  11. 在“报表服务器安装选项”页上单击“下一步”。

    将默认选择“安装但不配置服务器”。

  12. 在“错误和使用情况报告设置”页上，可以选择“自动将 SQL Server 2005 的错误报告发送到 Microsoft 或您公司的错误报告服务器”和“自动将 SQL Server 2005 的功能使用情况数据发送到 Microsoft”，然后单击“下一步”。

  13. 在“准备安装”页上，可以查看要安装的组件的列表，然后单击“安装”。

  14. 在“安装进度”页上，可以监视每个组件的安装状态。安装完成后，单击“下一步”。

    Note 注意

    在激活 SQL Server Reporting Services 期间，安装可能看起来像是有几分钟停止响应。

  15. 单击“完成”退出向导。

Caution note 警告

不要使用 Reporting Services 配置工具检验服务是否正在运行。Team Foundation Server 安装向导为您配置 Reporting Services，打开该工具可能会阻止安装完成。

Expand 图像 验证 Reporting Services 安装

安装完后，验证服务是否在运行并设置为自动启动。

验证安装

  1. 单击“开始”，单击“管理工具”，然后单击“服务”。

  2. 在“服务管理器”的“名称”列中找到“SQL Server Reporting Services”，并验证“状态”为“已启动”，“启动类型”为“自动”。

    Note 注意

    右击服务，然后单击“属性”并进行更改，可更改状态或启动类型。

  3. 关闭“服务管理器”。

Expand 图像 安装 Microsoft .NET Framework 2.0 修补程序

安装 Microsoft SQL Server 2005 Reporting Services 后，必须安装修复程序来更新 ASP.NET 以便更有效地支持对大文件的处理。

Note 注意

您可能需要访问网站以获得 Team Foundation Server 的最新更新。

安装 Microsoft .NET Framework 2.0 修补程序

  1. 在应用层计算机上，找到 Team Foundation Server 安装媒体上的 KB913393 文件夹。

  2. 找到与您的操作系统 (X86) 对应的可执行文件 (.exe)，然后双击该文件进行安装。

Expand 图像 安装 Windows SharePoint Services

安装修补程序后，必须为 Team Foundation Server 安装带有 Service Pack 2 的 Microsoft Windows SharePoint Services。

Note 要点

Windows SharePoint Services 需要使用 NTFS 文件系统。

以交互方式安装 Windows SharePoint Services

  1. 在应用层计算机上，使用 Team Foundation Server 设置帐户（例如 Domain\TFSSETUP）登录到 Windows。

  2. 下载带 Service Pack 2 的 Microsoft Windows SharePoint Services (http://go.microsoft.com/fwlink/?linkid=55087) 并将该文件保存到本地硬盘中。

  3. 运行下载的自解压缩安装程序文件 (stsv2.exe)。

  4. 在“最终用户许可协议”页上查看许可协议。如果您接受其中的条款和条件，请选择“我接受许可协议中的条款”，然后单击“下一步”。

  5. 在“安装类型”页上选择“服务器场”，然后单击“下一步”。

    Note 要点

    必须使用“服务器场”选项来安装 Windows SharePoint Services。这样会将 Windows SharePoint Services 配置为使用远程 SQL Server。稍后，Team Foundation Server 安装程序会将 Windows SharePoint Services 配置为与 Team Foundation Server 的其余部分使用相同的 SQL Server 实例。

  6. 在“摘要”页上单击“安装”。

    安装完成时，将打开一个 Web 浏览器窗口，并显示“配置管理虚拟服务器”页。确认该页显示后，不要进行任何更改，关闭该浏览器窗口。

    Note 要点

    不要对显示的页进行任何更改。稍后，Team Foundation Server 安装程序会将 Windows SharePoint Services 配置为与 Team Foundation Server 的其余部分使用相同的 SQL Server 实例。

    如果未显示该页，则应使用“Windows SharePoint Services Administrator's Guide”（《Windows SharePoint Services 管理员指南》）(http://go.microsoft.com/fwlink/?LinkId=52668) 来确定原因并排除故障。

  7. 访问 Windows Update (http://windowsupdate.microsoft.com) 并安装“重要更新和 Service Pack”组中的所有项。

  8. 重新启动计算机。

验证已安装 Windows SharePoint Services

  • 打开 Internet Explorer 并键入相应的服务器名称作为地址。

    例如，对于名为 ADATUM 的服务器，应键入 Http://adatum。

    虽然未配置站点，但服务器是活动 Web 服务器并提供“建设中”页面。

Expand 图像 安装 Team Foundation Server (Services)

安装所有相关组件后，可以安装 Team Foundation Server 应用层组件。

Note 注意

如果正在本地化版本的 Windows SharePoint Services 上安装 Team Foundation Server，必须先安装与 Team Foundation Server 语言匹配的 Windows SharePoint Services 语言包。例如，如果计划安装本地化版本的 Windows SharePoint Services 和英文版的 Team Foundation Server，则必须在安装 Team Foundation Server 之前安装 Windows SharePoint Services 英语语言包。

安装 Team Foundation Server (services)

  1. 在应用层计算机上，使用 Team Foundation Server 设置帐户（例如 Domain\TFSSETUP）登录到 Windows。

  2. 插入 CD，在出现的自动运行页上，单击“安装 Team Foundation Server”，单击“双服务器安装”，然后单击“仅安装 Team Foundation 应用层”。

    如果未出现自动运行页，请在安装媒体的根文件夹中找到并运行自动运行文件 (autorun.exe)。

    将启动 Visual Studio Team Foundation Server (services) 安装向导。

  3. 在“欢迎使用安装程序”页上单击“下一步”。

  4. 在“许可条款”页上查看许可协议。如果您接受其中的条款和条件，请选择“我接受许可协议中的条款”，然后单击“下一步”。

    安装向导将进行扫描，查找可能导致安装失败或导致以后的服务器操作过程中出错的条件。

  5. 在“目标文件夹和数据库服务器”页上，键入以下信息：

    • 在“目标文件夹”框中，键入安装路径或接受默认设置。

    • 在“数据库服务器”框中，键入在其上安装 Team Foundation Server (databases) 的计算机的名称。

      Note 注意

      必须使用计算机名，而不是 IP 地址。

  6. 在“系统状况检查”页上，单击“报告”链接检查是否有任何警告或阻止。

    • 必须先解决阻止问题，然后才能继续安装。单击“取消”并在解决问题之后再次运行安装程序。

    • 应在继续安装之前解除警告，但不应阻止安装程序完成。可以单击“下一步”。

    • 如果没有列出任何内容，则单击“下一步”。

  7. 在“服务帐户”页上，键入 Team Foundation Server 服务帐户（例如 Domain\TFSSERVICE）的帐户信息，然后单击“下一步”。

  8. 在“报告登录帐户”页上，键入 Team Foundation Server 报告帐户（例如 Domain\TFSREPORTS）的帐户信息，然后单击“下一步”。

    Note 注意

    此帐户不应与 Team Foundation Server 安装或服务帐户相同。

  9. 在“Team Foundation 警报”页上，键入以下信息：

    1. 在“SMTP 服务器”框中，键入将用于发送 Team Foundation 警报的服务器的名称。

    2. 在“发件人电子邮件地址”框中，键入发送 Team Foundation 警报的电子邮件地址的名称，然后单击“下一步”。

      Note 注意

      如果要在这里启用警报，就必须知道组织的 SMTP 服务器。对于仅 SMTP 访问，Team Foundation Server 不需要特殊的配置设置。SMTP 的安装和配置不在本文档集的范围之内。有关更多信息，请参见有关 Windows Server 2003 的文档。

  10. 在“安装准备就绪”页上单击“安装”。

    在安装期间，可能会提示您重新启动计算机。单击“立即重新启动”，在重新启动计算机并且您再次登录后，安装将继续。

  11. 在“成功完成安装”页上单击“完成”。

  12. 在 Internet Explorer 中，定位到 http://localhost:8080/services/v1.0/Registration.asmx，然后单击“GetRegistrationEntries”。

  13. 在“GetRegistrationEntries”页上单击“调用”。不必输入 ToolID。

    Note 注意

    要使用此 Web 方法，您必须位于应用层计算机上。

  14. 在 XML 中，确认类型 VSTF 如此处所示，然后关闭。

    <?xml version="1.0" encoding="utf-8" ?>

    <Type>vstfs</Type>

Expand 图像 后续步骤

在安装 Team Foundation Server 后，必须使其他用户能够管理和创建团队项目。有关更多信息，请参见如何：向 Team Foundation Administrators 应用程序组添加用户。

在安装并运行 Team Foundation Server 组件后，可以安装以下其他 Team Foundation 组件。

  • 团队资源管理器

  • Team Foundation Build

  • Team Foundation Server Proxy

下面的建议并不是创建团队项目所必需的，但属于管理 Team Foundation Server 的最佳做法。

  • 应使用“Reporting Services 配置工具”备份 Reporting Services 加密密钥。有关更多信息，请参见Team Foundation Server 管理员指南中的“How to: Back up the Reporting Services Encryption Key”（如何：备份 Reporting Services 加密密钥）。

  • 应建立数据库维护计划并安排完全备份和增量备份。

Expand image 请参见

其他资源

Team Foundation Build 安装概述
安装 Team Foundation Server Proxy 概述
团队资源管理器安装概述


演练：安装 Team Foundation Server 单服务器部署

演练：安装 Team Foundation Server 单服务器部署
请参见
CollapseAll 图像 DropDown 图像

可以使用此演练在单台计算机上设置 Team Foundation Server 的服务器组件。

Expand 图像 先决条件

为了完成安装，需要下列设备和信息。

  • 检查表：Team Foundation Server 单服务器部署的打印版本。

  • 一台满足小组规模的硬件和软件要求的计算机。有关更多信息，请参见 Team Foundation 系统要求。

  • 两个 Team Foundation Server 服务帐户。有关更多信息，请参见 Team Foundation Server 安装所需的用户帐户。Microsoft SQL Server 2005 也需要一个服务帐户，但可以使用内置帐户。

  • 完成安装所用的用户帐户，该帐户是这两台计算机上的“Administrator”安全组的成员。

Expand 图像 安装过程摘要

安装数据层组件

  1. 安装 Internet 信息服务 (IIS) 并启用 ASP.NET。

  2. 安装 Microsoft SQL Server 2005 标准版或企业版，安装过程中会用到安装媒体上的应答文件。

  3. 安装 Microsoft SQL Server 2005 的修补程序，启用并重新启动 SQL Browser 服务。

  4. 安装 Microsoft .NET Framework 2.0 的修补程序。

  5. 安装带 Service Pack2 的 Windows SharePoint Services 2.0。

  6. 安装 Team Foundation Server (services)。

Expand 图像 安装 Internet 信息服务 (IIS)

您的应用层计算机可能已配置为应用程序服务器。如果已配置 Internet 信息服务 (IIS) 这个 Windows 组件，请验证是否已启用 ASP.NET，如果没有则启用。否则，请按照此过程安装 IIS 并启用 ASP.NET。

使用“添加/删除程序”实用工具安装 IIS

  1. 从“控制面板”中打开“添加/删除程序”。

  2. 单击“添加/删除 Windows 组件”。

    此时将启动“Windows 组件向导”。

  3. 在“Windows 组件”页上选择“应用程序服务器”，然后单击“详细信息”。

  4. 如果尚未选中，请选择“ASP.NET”，然后单击“确定”。

    Note 要点

    如果您选择“Internet 信息服务(IIS)”并单击“详细信息”，请不要选择“FrontPage 2002 服务器扩展”。此服务器将承载 Windows SharePoint Services，后者与 FrontPage 服务器扩展不兼容。

  5. 在“Windows 组件”页上单击“下一步”。

    Note 注意

    可能会提示您插入 Windows Server 2003 安装媒体。

  6. 单击“完成”关闭向导。

  7. 访问 Windows Update (http://windowsupdate.microsoft.com) 并安装“重要更新和 Service Pack”组中的所有项。

通过此过程，使用安装向导以交互方式或使用应答文件为 Team Foundation Server 安装和配置 Microsoft SQL Server 2005 标准版或企业版。

Expand 图像 安装 Microsoft SQL Server 2005

在满足系统必备条件后，可以安装 Microsoft SQL Server 2005 标准版或企业版。Team Foundation Server 包括 Microsoft SQL Server 2005 标准版的许可副本。

以交互方式安装 Microsoft SQL Server 2005

  1. 使用 Team Foundation Server 安装帐户（例如 Domain\TFSSETUP）登录到 Windows。

  2. 插入 Microsoft SQL Server 2005 的 CD。在“SQL Server 2005 启动”页的“安装”下，单击“服务器组件、工具、联机丛书和示例”。

    Note 注意

    Microsoft SQL Server 2005 标准版 CD 与 Team Foundation Server 一起提供。要安装 SQL Server Enterprise，可以使用单独购买的软件中包含的 CD。通过运行位于安装媒体的 Servers 文件夹中的 Splash.hta 文件，可以显示“开始”页。

    此时将启动 Microsoft SQL Server 2005 安装向导。

  3. 在“最终用户许可协议”页上查看许可协议。如果您接受其中的条款和条件，请选择“我接受许可条款和条件”，然后单击“下一步”。

  4. 在“安装必备组件”页上单击“安装”。在成功安装了所需的组件后，单击“下一步”。

    此时将启动“Microsoft SQL Server 安装向导”。

  5. 单击“下一步”以启动“系统配置检查”。

  6. 在“系统配置检查”页上，检查所有要求操作（例如要求的系统重新启动）的状态，并遵循本页上的指导进行操作，直到所有操作都获得“成功”状态。在所有操作都获得“成功”状态后，单击“下一步”开始安装。

    Note 注意

    安装程序可能要过一会才能启动。

  7. 在“注册信息”页上填写完注册信息，然后单击“下一步”。

  8. 在“要安装的组件”页上，选择下面的组件，然后单击“高级”。

    • SQL Server Database Services

    • Analysis Services

    • Integration Services

    • Reporting Services

    • 工作站组件、联机丛书和开发工具

      Note 注意

      Team Foundation Server 不需要 Notification Services。

  9. 在“功能选择”页上，展开下面的节点并指定以下选项。

    Note 注意

    除本节所述情形外，不应更改任何其他功能区中的默认选择。

    1. 在“Database Services”之下单击“复制”的图标，并选择“整个功能将不可用”。

      Note 注意

      为了优化系统性能，请选择“数据文件”并单击“浏览”，以指定其他物理硬盘上的文件位置。默认情况下，SQL Server 2005 将所有文件安装到系统驱动器中。对“Analysis Services”下的“数据文件”可以执行同样的操作。

    2. 在“客户端组件”下，唯一需要安装的功能是“管理工具”。对于“客户端组件”下的所有其他项，可以选择单击图标并选择“整个功能将不可用”。

    3. 在“文档、示例和示例数据库”下，可以选择单击“联机丛书”的图标并选择“整个功能将不可用”。单击“下一步”。

  10. 在“实例名”页上，选择“默认实例”，然后单击“下一步”。

    Note 要点

    如果指定已命名的实例，Team Foundation Server 安装将失败。

  11. 在“服务帐户”页上，选择“使用内置系统帐户”并从列表中选择“本地系统”。在“安装结束时启动服务”中，选择所有服务：“SQL Server”、“SQL Server Agent”、“Analysis Services”、“Reporting Services”和“SQL Browser”，然后单击“下一步”。

    Note 注意

    该服务帐户用于 Microsoft SQL Server 2005，不应与启动安装前获得的两个服务帐户混淆。

  12. 在“身份验证模式”页上，选择“Windows 身份验证模式”，然后单击“下一步”。

  13. 在“排序规则设置”页上，选择适合您的语言的排序规则，然后单击“下一步”。

    Note 注意

    如果更改了“排序规则指示符和排序顺序”，则必须选择“区分重音”。

    默认选择基于 Windows Server 2003 中的非 Unicode 语言的设置。对于多数语言，默认选择都是 Windows 排序规则，但对于美国英语，SQL Server 2005 安装时使用 SQL Server 排序规则以向后兼容。如果要更改默认的排序规则以支持其他美国英语字符，请考虑“Latin1_General”。

    对于其他语言，请考虑“_90”Windows 排序规则（当可用时），否则使用其他 Windows 排序规则。

    例如，对于日语部署，如果按下面的方式使用 Unicode CJK Extension A 字符或 Unicode 代理项，请使用“Japanese_90”排序规则，而不是默认排序规则。

    • Team Foundation Server 对象名，如“查询”或“项目”。

    • 签入到版本控制系统中的文件或路径。

    • 用于搜索的任何工作项字段。

    为了避免由全角字符或平假名/片假名等效字符带来的问题，请在安装过程中选中启用区分假名和全角字符的复选框。

    Team Foundation Server 不支持如下排序规则：

    • 不区分重音

    • 二元

    • Binary2

    • 区分大小写

    有关排序规则设置的更多信息，请参见 SQL Server 2005 Books Online（《SQL Server 2005 联机丛书》）中的“Collation Settings in Setup”（安装中的排序规则设置）。

  14. 在“报表服务器安装选项”页上，选择“安装默认配置”，然后单击“下一步”。

  15. 在“错误和使用情况报告设置”页上，可以选择“自动将 SQL Server 2005 的错误报告发送到 Microsoft 或您公司的错误报告服务器”和“自动将 SQL Server 2005 的功能使用情况数据发送到 Microsoft”，然后单击“下一步”。

  16. 在“准备安装”页上，可以查看要安装的组件的列表，然后单击“安装”。

  17. 在“安装进度”页上，可以监视每个组件的安装状态。安装完成后，单击“下一步”。

    Note 注意

    在激活 SQL Server Reporting Services 期间，安装可能看起来像是有几分钟停止响应。

  18. 单击“完成”退出向导。

Expand 图像 安装 Microsoft SQL Server 2005 修补程序

安装 Microsoft SQL Server 2005 后，必须安装修补程序来更新 SQL Server Analysis Services 以便更有效地支持报告。

Note 注意

有关最近的更新，请访问 Microsoft 网站 (http://go.microsoft.com/fwlink/?LinkId=62015)。

安装 Microsoft SQL Server 2005 修补程序

  1. 在数据层计算机上，打开“SQL Server 配置管理器”，右击“SQL Server 浏览器服务”，然后单击“停止”。

  2. 在 Team Foundation Server 安装媒体上，找到 SQLServerKB 文件夹。

  3. 找到与您的操作系统和语言对应的可执行文件 (.exe)，如 AS2005-KBnnnnnn-x86-ENU.exe，然后双击该文件以启动 Hotfix Installer（修补程序安装程序）。

  4. 在 “Hotfix Installer”中接受“End User License Agreement”（最终用户许可协议），完成各页以安装该修补程序，然后单击“Finish”（完成）。

  5. 在“SQL Server 配置管理器”中，右击“SQL Server Browser 服务”，然后单击“属性”。

  6. 在“服务”选项卡上找到“启动模式”，然后选择“自动”。

  7. 在“登录”选项卡上，单击“启动”。

    Note 注意

    如果在“登录”选项卡上未启用“启动”，则单击“服务”选项卡，将“启动模式”设置为“禁用”，然后再次选择“自动”以显式更新“启动模式”。

要在安装 Windows SharePoint Services 之前验证安装，请参见如何：验证 Microsoft SQL Server 2005 的安装。

Expand 图像 安装 Microsoft .NET Framework 2.0 修补程序

必须安装用于更新 ASP.NET 的修补程序，以更有效地支持大文件的处理。

Note 注意

您可能需要访问网站以获得 Team Foundation Server 的最新更新。

安装 Microsoft .NET Framework 2.0 修补程序

  1. 在应用层计算机上，找到 Team Foundation Server 安装媒体上的 KB913393 文件夹。

  2. 找到与您的操作系统 (X86) 对应的可执行文件 (.exe)，然后双击该文件进行安装。

Expand 图像 安装 Microsoft Windows SharePoint Services

按照以下步骤，使用安装向导以交互方式或从命令行中以静默方式为 Team Foundation Server 安装带 Service Pack 2 的 Microsoft Windows SharePoint Services。

Note 要点

Windows SharePoint Services 需要使用 NTFS 文件系统。

以交互方式安装 Windows SharePoint Services

  1. 使用 Team Foundation Server 安装帐户（例如 Domain\TFSSETUP）登录到 Windows。

  2. 下载带 Service Pack 2 的 Microsoft Windows SharePoint Services (http://go.microsoft.com/fwlink/?linkid=55087) 并将该文件保存到本地硬盘中。

  3. 运行下载的自解压缩安装程序文件 (stsv2.exe)。

  4. 在“最终用户许可协议”页上查看许可协议。如果您接受其中的条款和条件，请选择“我接受许可协议中的条款”，然后单击“下一步”。

  5. 在“安装类型”页上选择“服务器场”，然后单击“下一步”。

    Note 要点

    必须使用“服务器场”选项来安装 Windows SharePoint Services。这样会将 Windows SharePoint Services 配置为使用远程 SQL Server。以后，Team Foundation Server 安装程序会将 Windows SharePoint Services 配置为与 Team Foundation Server 的其余部分使用相同的 SQL Server 实例。

  6. 在“摘要”页上单击“安装”。

    安装完成时，将打开一个 Web 浏览器窗口，并显示“配置管理虚拟服务器”页。确认该页显示后，不要进行任何更改，关闭该浏览器窗口。

    Note 要点

    不要对显示的页进行任何更改。以后，Team Foundation Server 安装程序会将 Windows SharePoint Services 配置为与 Team Foundation Server 的其余部分使用相同的 SQL Server 实例。

    如果未显示该页，则应使用“Windows SharePoint Services Administrator's Guide”（《Windows SharePoint Services 管理员指南》）(http://go.microsoft.com/fwlink/?LinkId=52668) 来确定原因并排除故障。

  7. 访问 Windows Update (http://windowsupdate.microsoft.com) 并安装“重要更新和 Service Pack”组中的所有项。

  8. 重新启动计算机。

Expand 图像 验证 Windows SharePoint Services 安装

安装 Windows SharePoint Services 后，即使未安装 Team Foundation Server 也能确保 Windows SharePoint Services 正在运行。

验证已安装 Windows SharePoint Services

  • 打开 Internet Explorer 并键入相应的服务器名称作为地址。

    例如，对于名为 ADATUM 的服务器，应键入 Http://adatum。

    虽然未配置站点，但服务器是活动 Web 服务器并提供“建设中”页面。

    Note 注意

    在本地化版本的 Windows SharePoint Services 上安装 Team Foundation Server 之前，必须先安装与 Team Foundation Server 语言匹配的 Windows SharePoint Services 语言包。例如，如果计划安装本地化版本的 Windows SharePoint Services 和英文版的 Team Foundation Server，则必须在安装 Team Foundation Server 之前安装 Windows SharePoint Services 英语语言包。

Expand 图像 安装 Team Foundation Server

在安装所有相关组件后，可以安装 Team Foundation Server。

安装 Team Foundation Server

  1. 使用 Team Foundation Server 安装帐户（例如 Domain\TFSSETUP）登录到 Windows。

  2. 插入 CD，在出现的自动运行页上单击“安装 Team Foundation Server”，然后单击“单服务器安装”。

    如果未出现自动运行页，请在安装媒体的根文件夹中找到并运行自动运行文件 (autorun.exe)。

    此时将启动“Visual Studio Team Foundation Server 安装向导”。

  3. 在“欢迎使用安装程序”页上单击“下一步”。

  4. 在“许可条款”页上查看条款。如果您接受其中的条款和条件，请选择“我接受许可协议中的条款”，然后单击“下一步”。

    安装向导将进行扫描，查找可能导致安装失败或导致以后的服务器操作过程中出错的条件。

  5. 在“目标文件夹”页上，接受默认的目标文件夹并单击“下一步”。

  6. 在“系统状况检查”页上，单击“报告”链接检查是否有任何警告或阻止。

    • 必须先解决阻止问题，然后才能继续安装。单击“取消”并在解决问题之后再次运行安装程序。

    • 应在继续安装之前解除警告，但不应阻止安装程序完成。可以单击“下一步”。

    • 如果没有列出任何内容，则单击“下一步”。

  7. 在“服务登录帐户”页上，在“帐户名”框中键入您为 Team Foundation Server 服务帐户创建的 Windows 域用户帐户（例如 Domain\TFSSERVICE），并在“密码”框中键入密码，然后单击“下一步”。有关更多信息，请参见 Team Foundation Server 安装所需的用户帐户。

  8. 在“报告登录帐户”页上，键入 Team Foundation Server 报告帐户的帐户信息，然后单击“下一步”。

    Note 注意

    此帐户不应与 Team Foundation Server 安装或服务帐户相同。例如，使用 Domain\TFSREPORTS。

  9. 在“指定警报设置”页上，选择“启用 Team Foundation 警报”，然后键入以下信息：

    • 在“SMTP 服务器”框中，键入将用于发送电子邮件通知的服务器的名称。

    • 在“发件人电子邮件地址”框中，键入作为通知来源的电子邮件地址的名称，然后单击“下一步”。

  10. 在“安装准备就绪”页上单击“安装”。

  11. 在“正在安装组件”页上，可以监视 Team Foundation Server 的安装。

    在安装期间，可能会提示您重新启动计算机。单击“立即重新启动”，在重新启动计算机并且您再次登录后，安装将继续。

  12. 在“成功完成安装”页上，验证完成安装后，单击“完成”。

    安装 Team Foundation Server 后，应使用“Reporting Services 配置工具”备份 Reporting Services 加密密钥。这一步骤并不是创建团队项目所必需的，但属于管理 Team Foundation Server 的最佳做法。有关更多信息，请参见“Team Foundation Server Administrator's Guide”（《Team Foundation Server 管理员指南》）(http://go.microsoft.com/fwlink/?LinkID=52459&clcid=0x409) 中的“How to: Back Up the Reporting Services Encryption Key”（如何：备份 Reporting Services 加密密钥）。

  13. 在 Internet Explorer 中，定位到 http://localhost:8080/services/v1.0/Registration.asmx，然后单击“GetRegistrationEntries”。

  14. 在“GetRegistrationEntries”页上单击“调用”。不必输入 ToolID。

    Note 注意

    要使用此 Web 方法，您必须位于应用层计算机上。

  15. 在 XML 中，确认类型 VSTF 存在，然后关闭。例如：

    <?xml version="1.0" encoding="utf-8" ?>

    <Type>vstfs</Type>

Expand 图像 后续步骤

在安装 Team Foundation Server 后，必须使其他用户能够管理和创建团队项目。有关更多信息，请参见如何：向 Team Foundation Administrators 应用程序组添加用户。

在安装并运行 Team Foundation Server 组件后，可以安装以下其他 Team Foundation 组件。

  • 团队资源管理器

  • Team Foundation Build

  • Team Foundation Server Proxy

下面的建议并不是创建团队项目所必需的，但属于管理 Team Foundation Server 的最佳做法。

  • 应使用“Reporting Services 配置工具”备份 Reporting Services 加密密钥。有关更多信息，请参见Team Foundation Server 管理员指南中的“How to: Back up the Reporting Services Encryption Key”（如何：备份 Reporting Services 加密密钥）。

  • 应建立数据库维护计划并安排完全备份和增量备份。

Expand image 请参见

其他资源

Team Foundation Build 安装概述
安装 Team Foundation Server Proxy 概述
团队资源管理器安装概述


Team Foundation Server 单服务器部署概述

Team Foundation Server 单服务器部署概述
请参见
DropDown image

使用本节中的过程在一台服务器上安装和配置 Team Foundation Server。

本节内容

检查表：Team Foundation Server 单服务器部署

提供一个检查表，以便在 Team Foundation Server 单服务器部署期间用作手头参考。

安装 Team Foundation Server

提供在一台服务器上安装和配置 Team Foundation Server 及其必备组件的详细说明。

相关章节

Team Foundation 系统要求

提供安装此版本的 Team Foundation Server 时对硬件和软件的系统要求。

Team Foundation Server 安全安装概述

提供安装 Team Foundation Server 时与安全相关的信息。

Team Foundation Server 双服务器部署概述

借助本节中的过程，使用两台计算机来安装和配置 Team Foundation Server，一台计算机用于数据层组件，另一台用于应用层组件。

Team Foundation Build 安装概述

使用本节中的过程来安装和配置 Team Foundation Build，后者提供了生成自动化功能，可帮助您生成和共享 Visual Studio 2005 解决方案。

团队资源管理器安装概述

使用本节中的过程来安装和配置 Team Explorer。

请参见

概念

Team Foundation 安装


检查表：Team Foundation Server 单服务器部署

检查表：Team Foundation Server 单服务器部署
请参见
CollapseAll 图像 DropDown 图像

此检查表在 Team Foundation Server 单服务器部署过程中可作为一个有用的参考。应打印此检查表并在完成每个步骤时进行标记。

Expand 图像 单服务器部署检查表

此检查表列出了使用单服务器部署安装 Team Foundation Server 的一般步骤以及指向每个步骤详细信息的链接。单服务器部署会将 Team Foundation Server 数据层和应用层放在同一台计算机上。可在安装了 Team Foundation Server 之后使用单独的过程安装 Team Foundation Build 和 Team Explorer。

完成 步骤

下载此指南的最新版本，可从 Microsoft 下载中心 (http://go.microsoft.com/fwlink/?LinkId=40042) 进行下载。

检验硬件和软件要求。有关更多信息，请参见 Team Foundation 系统要求。

标识用于运行安装程序的用户帐户，并将该帐户添加到本地“Administrators”组。通常，这是您的用户帐户。在本指南中，此帐户为 Domain\TFSSETUP。有关更多信息，请参见 Team Foundation Server 安装所需的用户帐户。

获取两个服务帐户，用于 Team Foundation Server 所用服务之间的通信。

  • 一个用于运行 Team Foundation 服务的帐户（例如 Domain\TFSSERVICE）。

  • 一个用于访问 SQL Server Reporting Services 数据源的帐户（例如 Domain\TFSREPORTS）。

有关更多信息，请参见 Team Foundation Server 安装所需的用户帐户。

安装 Internet 信息服务 (IIS) 6.0。启用 ASP.NET 并重新启动计算机。

Caution note 警告

不要安装 FrontPage Server 2002 扩展。

有关更多信息，请参见如何：安装用于 Team Foundation Server 的 Internet 信息服务。

将 Microsoft SQL Server 2005 Standard 或 Enterprise Edition 作为此计算机上的默认 SQL Server (MSSQLSERVER) 实例进行安装。使用“本地系统”作为服务帐户。安装本文结尾处所示述的修补程序。

有关更多信息，请参见如何：安装用于 Team Foundation Server（单服务器部署）的 Microsoft SQL Server 2005。

验证 Microsoft SQL Server 2005 安装，方法是使用主题 如何：验证 Microsoft SQL Server 2005 的安装 或《SQL Server 联机丛书》中的“如何验证 SQL Server 2005 服务的安装成功”(http://msdn2.microsoft.com/zh-cn/library/ms143673.aspx) 中列出的步骤。

Caution note 警告

此时不要运行 Reporting Services 配置工具。

安装 Microsoft .NET Framework 2.0 修补程序 KB913393，该修补程序位于 Team Foundation Server 安装媒体上。

在安装媒体中，找到包含修补程序的文件夹 KB913393，再找到与您的平台 (X86) 对应的可执行文件 (.exe)，然后双击文件进行安装。

安装用于 Team Foundation Server 的带 Service Pack 2 的 Windows SharePoint Services，然后重新启动计算机。

Caution note 警告

此时不要更改 Window SharePoint Services。Team Foundation Server 安装会为您配置 Windows SharePoint Services。

有关更多信息，请参见如何：安装用于 Team Foundation Server（单服务器部署）的 Microsoft Windows SharePoint Services。

验证相应端口是否打开。

如果在使用 Windows 防火墙或者第三方防火墙软件或硬件解决方案，则应确保所需的端口已打开，以允许在组件之间进行通信。有关更多信息，请参见 Team Foundation Server 安装所需的端口。

安装 Team Foundation Server。有关更多信息，请参见如何：安装 Team Foundation Server。

若要向“Team Foundation Administration”组添加用户，请在本地或其他计算机上安装 Team Explorer。有关更多信息，请参见团队资源管理器安装概述。

Expand image 请参见

其他资源

Team Foundation Server 单服务器部署概述
Team Foundation Build 安装概述
安装 Team Foundation Server Proxy 概述


安装 Team Foundation Server

安装 Team Foundation Server
请参见
DropDown image

使用本节中的过程安装和配置 Team Foundation Server 及其必备组件（数据层和应用层组件位于一台计算机上）。

本节内容

如何：安装用于 Team Foundation Server 的 Internet 信息服务

描述如何安装和配置 Internet 信息服务 (IIS) 6.0。

如何：安装用于 Team Foundation Server（单服务器部署）的 Microsoft SQL Server 2005

描述如何为 Team Foundation Server 安装和配置 SQL Server 2005。

如何：安装用于 Team Foundation Server（单服务器部署）的 Microsoft Windows SharePoint Services

描述如何为 Team Foundation Server 安装和配置 Windows SharePoint Services。

如何：安装 Team Foundation Server

描述如何安装和配置 Team Foundation Server 数据层和应用层组件。

请参见

其他资源

Team Foundation Server 单服务器部署概述


如何：安装用于 Team Foundation Server 的 Internet 信息服务

如何：安装用于 Team Foundation Server 的 Internet 信息服务
请参见

使用此过程为 Team Foundation Server 安装和配置 Internet 信息服务 (IIS) 6.0。

使用“配置您的服务器向导”来安装 IIS

  1. 通过执行以下任一操作来启动“配置您的服务器向导”：

    • 默认情况下，“管理您的服务器”会在 Windows 启动时自动启动。从“管理您的服务器”中，单击“添加或删除角色”。

    • 从“控制面板”中打开“管理工具”，然后打开“配置您的服务器向导”。

  2. 在“欢迎使用‘配置您的服务器向导’”页上单击“下一步”。

  3. 在“预备步骤”页上单击“下一步”。

  4. 在“服务器角色”页上单击“应用程序服务器(IIS，ASP.NET)”，然后单击“下一步”。

  5. 在“应用程序服务器选项”页上选择“启用 ASP.NET”，然后单击“下一步”。

    Note 要点

    不要选择“FrontPage 服务器扩展”。此服务器将承载 Windows SharePoint Services，后者与 FrontPage 服务器扩展不兼容。

  6. 在“选择总结”页上单击“下一步”。

    Note 注意

    可能会提示您插入 Windows Server 2003 安装媒体。

  7. 单击“完成”来完成该向导。

  8. 访问 Windows Update (http://windowsupdate.microsoft.com) 并安装“重要更新和 Service Pack”组中的所有项。

使用“添加/删除程序”实用工具安装 IIS

  1. 从“控制面板”中打开“添加/删除程序”。

  2. 单击“添加/删除 Windows 组件”。

    此时将启动“Windows 组件向导”。

  3. 在“Windows 组件”页上选择“应用程序服务器”，然后单击“详细信息”。

  4. 如果尚未选中，请选择“ASP.NET”，然后单击“确定”。

    Note 要点

    如果您选择“Internet 信息服务(IIS)”并单击“详细信息”，请不要选择“FrontPage 2002 服务器扩展”。此服务器将承载 Windows SharePoint Services，后者与 FrontPage 服务器扩展不兼容。

  5. 在“Windows 组件”页上单击“下一步”。

    Note 注意

    可能会提示您插入 Windows Server 2003 安装媒体。

  6. 单击“完成”关闭向导。

  7. 访问 Windows Update (http://windowsupdate.microsoft.com) 并安装“重要更新和 Service Pack”组中的所有项。

安全

若要执行此过程，您必须是计算机上“Administrators”安全组的成员。在本指南中，用于安装的用户帐户为 Domain\TFSSETUP。如果使用相同的帐户安装 Team Foundation Server，安装过程中此帐户会自动添加到“Team Foundation 管理员”安全组中。有关更多信息，请参见 Team Foundation Server 安装所需的用户帐户。

请参见

其他资源

安装 Team Foundation Server


如何：安装用于 Team Foundation Server（单服务器部署）的 Microsoft SQL Server 2005

如何：安装用于 Team Foundation Server（单服务器部署）的 Microsoft SQL Server 2005
请参见

通过此过程，可以使用安装向导以交互方式或使用应答文件为 Team Foundation Server 安装和配置 Microsoft SQL Server 2005 标准版或企业版。Team Foundation Server 包含 Microsoft SQL Server 2005 标准版的许可副本。您还必须安装本主体末尾所述的修补程序。

Note 注意

在安装 Microsoft SQL Server 2005 之前必须安装 Internet 信息服务 (IIS) 6.0。

自动安装 Microsoft SQL Server 2005

还可以使用提供的应答文件从命令行安装 Microsoft SQL Server 2005。此应答文件将使安装过程自动化，来安装和配置用于 Team Foundation Server 的 Microsoft SQL Server 2005。

Caution note 警告

默认情况下，Microsoft SQL Server 根据操作系统的语言设置指定排序规则设置。有关排序规则设置的更多信息，请参见 SQL Server 2005 Books Online（《SQL Server 2005 联机丛书》）中的“Collation Settings in Setup”（安装程序中的排序规则设置）。

使用应答文件安装 Microsoft SQL Server 2005

  1. 使用 Team Foundation Server 安装帐户（例如 Domain\TFSSETUP）登录到 Windows。

  2. 在 Team Foundation Server 安装媒体中，找到预先配置的自动应答文件 (SQL2005ForATDT.ini) 并将其复制到本地硬盘驱动器上的方便位置（例如，C:\）。

  3. 使用以下命令行运行 Microsoft SQL Server 2005 的安装程序：

    C:\> SQLServerSetupDirectory \setup.exe /qb /settings AnswerFileDirectory \SQL2005ForATDT.ini PIDKEY= ProductKey

    其中，SQLServerSetupDirectory 是 Microsoft SQL Server 2005 的 setup.exe 的路径，AnswerFileDirectory 是应答文件的路径，ProductKey 是 Microsoft SQL Server 2005 的产品密钥，其中没有连字符或空格。

    Note 注意

    若要验证安装，请参见如何：验证 Microsoft SQL Server 2005 的安装。

交互安装 Microsoft SQL Server 2005

Team Foundation Server 包括 Microsoft SQL Server 2005 标准版的许可副本。

Note 注意

在安装 Microsoft SQL Server 2005 之前必须安装 Internet 信息服务 (IIS) 6.0。

以交互方式安装 Microsoft SQL Server 2005

  1. 使用 Team Foundation Server 安装帐户（例如 Domain\TFSSETUP）登录到 Windows。

  2. 插入 Microsoft SQL Server 2005 的 CD。在“SQL Server 2005 启动”页的“安装”下，单击“服务器组件、工具、联机丛书和示例”。

    Note 注意

    Microsoft SQL Server 2005 标准版 CD 与 Team Foundation Server 一起提供。要安装 SQL Server Enterprise，可以使用单独购买的软件中包含的 CD。通过运行位于安装媒体的 Servers 文件夹中的 Splash.hta 文件，可以显示“开始”页。

    此时将启动 Microsoft SQL Server 2005 安装向导。

  3. 在“最终用户许可协议”页上查看许可协议。如果您接受其中的条款和条件，请选择“我接受许可条款和条件”，然后单击“下一步”。

  4. 在“安装必备组件”页上单击“安装”。在成功安装了所需的组件后，单击“下一步”。

    此时将启动“Microsoft SQL Server 安装向导”。

  5. 单击“下一步”以启动“系统配置检查”。

  6. 在“系统配置检查”页上，检查所有要求操作（例如要求的系统重新启动）的状态，并遵循本页上的指导进行操作，直到所有操作都获得“成功”状态为止。在所有操作都获得“成功”状态后，单击“下一步”开始安装。

    Note 注意

    安装程序可能要过一会才能启动。

  7. 在“注册信息”页上填写完注册信息，然后单击“下一步”。

  8. 在“要安装的组件”页上，选择下面的组件，然后单击“高级”。

    • SQL Server Database Services

    • Analysis Services

    • Reporting Services

    • Integration Services

    • 工作站组件、联机丛书和开发工具

      Note 注意

      Team Foundation Server 不需要 Notification Services。

  9. 在“功能选择”页上，展开下面的节点并指定以下选项。

    Note 注意

    除以下所述情形外，不应更改任何其他功能区中的默认选择。

    1. 在“Database Services”之下单击“复制”的图标，并选择“整个功能将不可用”。

      Note 提示

      为了优化系统性能，请选择“数据文件”并单击“浏览”，以指定其他物理硬盘驱动器上的文件位置。默认情况下，SQL Server 2005 将所有文件安装到系统驱动器中。对“Analysis Services”下的“数据文件”可以执行同样的操作。

    2. 在“客户端组件”下，唯一需要安装的功能是“管理工具”。对于“客户端组件”下的所有其他项，可以选择单击图标并选择“整个功能将不可用”。

    3. 在“文档、示例和示例数据库”下，可以选择单击“联机丛书”的图标并选择“整个功能将不可用”。单击“下一步”。

  10. 在“实例名”页上，选择“默认实例”，然后单击“下一步”。

    Note 要点

    如果指定已命名的实例，Team Foundation Server 安装将失败。

  11. 在“服务帐户”页上，选择“使用内置系统帐户”并从列表中选择“本地系统”。在“安装结束时启动服务”中，选择所有服务：“SQL Server”、“SQL Server Agent”、“Analysis Services”、“Reporting Services”和“SQL Browser”，然后单击“下一步”。

    Note 注意

    该服务帐户用于 Microsoft SQL Server 2005，不应与启动安装之前获取的两个服务帐户混淆。

  12. 在“身份验证模式”页上，选择“Windows 身份验证模式”，然后单击“下一步”。

  13. 在“排序规则设置”页上，选择适合您的语言的排序规则，然后单击“下一步”。

    Note 注意

    如果更改了“排序规则指示符和排序顺序”，则必须选择“区分重音”。

    默认选择基于 Windows Server 2003 中的非 Unicode 语言的设置。对于多数语言，默认选择都是 Windows 排序规则，但对于美国英语，SQL Server 2005 安装时使用 SQL Server 排序规则以向后兼容。如果要更改默认的排序规则以支持其他美国英语字符，请考虑“Latin1_General”。

    对于其他语言，请考虑“_90”Windows 排序规则（当可用时），否则使用其他 Windows 排序规则。

    例如，对于日语部署，如果按下面的方式使用 Unicode CJK Extension A 字符或 Unicode 代理项，请使用“Japanese_90”排序规则，而不是默认排序规则。

    • Team Foundation Server 对象名，如“查询”或“项目”。

    • 签入到版本控制系统中的文件或路径。

    • 用于搜索的任何工作项字段。

    为了避免由全角字符或平假名/片假名等效字符带来的问题，请在安装过程中选中启用区分假名和全角字符的复选框。

    Team Foundation Server 不支持如下排序规则：

    • 不区分重音

    • 二元

    • Binary2

    • 区分大小写

    有关排序规则设置的更多信息，请参见 SQL Server 2005 Books Online（《SQL Server 2005 联机丛书》）中的“Collation Settings in Setup”（安装中的排序规则设置）。

  14. 在“报表服务器安装选项”页上，选择“安装默认配置”，然后单击“下一步”。

  15. 在“错误和使用情况报告设置”页上，可以选择“自动将 SQL Server 2005 的错误报告发送到 Microsoft 或您公司的错误报告服务器”和“自动将 SQL Server 2005 的功能使用情况数据发送到 Microsoft”，然后单击“下一步”。

  16. 在“准备安装”页上，可以查看要安装的组件的列表，然后单击“安装”。

  17. 在“安装进度”页上，可以监视每个组件的安装状态。安装完成后，单击“下一步”。

    Note 注意

    在激活 SQL Server Reporting Services 期间，安装可能看起来像是挂起几分钟。

  18. 单击“完成”退出向导。

    Note 注意

    若要在安装 Windows SharePoint Services 之前验证安装，请参见如何：验证 Microsoft SQL Server 2005 的安装。

安装 Microsoft SQL Server 2005 修补程序

安装 Microsoft SQL Server 2005 后，必须安装修补程序来更新 SQL Server Analysis Services 以便更有效地支持报告。

Note 注意

有关最近的更新，请访问 Microsoft 网站 (http://go.microsoft.com/fwlink/?LinkId=62015)。

安装 Microsoft SQL Server 2005 修补程序

  1. 在数据层计算机上，打开“SQL Server 配置管理器”，右击“SQL Server 浏览器服务”，然后单击“停止”。

  2. 在 Team Foundation Server 安装媒体上，找到 SQLServerKB 文件夹。

  3. 找到与您的操作系统和语言对应的可执行文件 (.exe)，如 AS2005-KBnnnnnn-x86-ENU.exe，然后双击该文件以启动 Hotfix Installer（修补程序安装程序）。

  4. 在 “Hotfix Installer”中接受“End User License Agreement”（最终用户许可协议），完成各页以安装该修补程序，然后单击“Finish”（完成）。

  5. 在“SQL Server 配置管理器”中，右击“SQL Server Browser 服务”，然后单击“属性”。

  6. 在“服务”选项卡上找到“启动模式”，然后选择“自动”。

  7. 在“登录”选项卡上，单击“启动”。

    Note 注意

    如果在“登录”选项卡上未启用“启动”，则单击“服务”选项卡，将“启动模式”设置为“禁用”，然后再次选择“自动”以显式更新“启动模式”。

要在安装 Windows SharePoint Services 之前验证安装，请参见如何：验证 Microsoft SQL Server 2005 的安装。

安全

若要执行此过程，您必须是计算机上“Administrators”安全组的成员。在本指南中，用于安装的用户帐户为 Domain\TFSSETUP。如果也使用此帐户安装 Team Foundation Server，则安装过程中此帐户会自动添加到“Team Foundation 管理员”安全组中。有关更多信息，请参见 Team Foundation Server 安装所需的用户帐户。

请参见

其他资源

安装 Team Foundation Server


如何：安装用于 Team Foundation Server（单服务器部署）的 Microsoft Windows SharePoint Services

如何：安装用于 Team Foundation Server（单服务器部署）的 Microsoft Windows SharePoint Services
请参见

按照以下步骤，从命令行中以静默方式或使用安装向导以交互方式为 Team Foundation Server 安装带 Service Pack 2 的 Microsoft Windows SharePoint Services。

在本地化版本的 Windows SharePoint Services 上安装 Team Foundation Server 之前，必须先安装与要安装的 Team Foundation Server 语言匹配的 Windows SharePoint Services 语言包。例如，在安装英文版的 Team Foundation Server 之前，必须安装 Windows SharePoint Services 英语语言包。

Note 要点

Windows SharePoint Services 需要使用 NTFS 文件系统。

以静默方式安装 Microsoft Windows SharePoint Services

可以从命令行中以静默方式安装 Windows SharePoint Services。

以静默方式安装 Windows SharePoint Services

  1. 使用 Team Foundation Server 安装帐户（例如 Domain\TFSSETUP）登录到 Windows。

  2. 下载带 Service Pack 2 的 Microsoft Windows SharePoint Services 2.0 (http://go.microsoft.com/fwlink/?linkid=55087) 并将该文件保存到本地硬盘中的方便位置。

  3. 使用以下命令行运行下载的自解压缩安装程序文件 (stsv2.exe)：

    C:\> DownloadDirectory \STSV2.EXE /C:"setupsts.exe /remoteSql=yes /provision=no /q"

    其中，DownloadDirectory 是硬盘中保存下载文件的位置的路径。

    Note 要点

    必须使用 /remoteSql=yes 选项来安装 Windows SharePoint Services。这样会将 Windows SharePoint Services 配置为使用远程 SQL Server。/provision=no 选项将推迟 Windows SharePoint Services 的配置。以后，Team Foundation Server 安装程序会将 Windows SharePoint Services 配置为与 Team Foundation Server 的其余部分使用相同的 SQL Server 实例。

    您将不会收到声明安装完成的消息。而是在继续操作之前留出几分钟时间等待安装完成。

  4. 访问 Windows Update (http://windowsupdate.microsoft.com) 并安装“重要更新和 Service Pack”组中的所有项。

  5. 重新启动计算机。

以交互方式安装 Microsoft Windows SharePoint Services

安装带 Service Pack 2 的 Microsoft Windows SharePoint Services。

以交互方式安装 Windows SharePoint Services

  1. 使用 Team Foundation Server 安装帐户（例如 Domain\TFSSETUP）登录到 Windows。

  2. 下载带 Service Pack 2 的 Microsoft Windows SharePoint Services (http://go.microsoft.com/fwlink/?linkid=55087) 并将该文件保存到本地硬盘中。

  3. 运行下载的自解压缩安装程序文件 (stsv2.exe)。

  4. 在“最终用户许可协议”页上查看许可协议。如果您接受其中的条款和条件，请选择“我接受许可协议中的条款”，然后单击“下一步”。

  5. 在“安装类型”页上选择“服务器场”，然后单击“下一步”。

    Note 要点

    必须使用“服务器场”选项来安装 Windows SharePoint Services。这样会将 Windows SharePoint Services 配置为使用远程 SQL Server。以后，Team Foundation Server 安装程序会将 Windows SharePoint Services 配置为与 Team Foundation Server 的其余部分使用相同的 SQL Server 实例。

  6. 在“摘要”页上单击“安装”。

    安装完成时，将打开一个 Web 浏览器窗口，并显示“配置管理虚拟服务器”页。确认该页显示后，不要进行任何更改，关闭该浏览器窗口。

    Note 要点

    不要对显示的页进行任何更改。以后，Team Foundation Server 安装程序会将 Windows SharePoint Services 配置为与 Team Foundation Server 的其余部分使用相同的 SQL Server 实例。

    如果未显示该页，则应使用“Windows SharePoint Services Administrator's Guide”（《Windows SharePoint Services 管理员指南》）(http://go.microsoft.com/fwlink/?LinkId=52668) 来确定原因并排除故障。

  7. 访问 Windows Update (http://windowsupdate.microsoft.com) 并安装“重要更新和 Service Pack”组中的所有项。

  8. 重新启动计算机。

验证安装

安装 Windows SharePoint Services 后，即使未安装 Team Foundation Server 也能确保 Windows SharePoint Services 正在运行。

验证已安装 Windows SharePoint Services

  • 打开 Internet Explorer 并键入相应的服务器名称作为地址。

    例如，对于名为 ADATUM 的服务器，应键入 Http://adatum。

    虽然未配置站点，但服务器是活动 Web 服务器并提供“建设中”页面。

安全

若要执行此过程，您必须是计算机上“Administrators”安全组的成员。在本指南中，用于安装的用户帐户为 Domain\TFSSETUP。如果也使用此帐户安装 Team Foundation Server，则安装过程中此帐户会自动添加到“Team Foundation 管理员”安全组中。有关更多信息，请参见 Team Foundation Server 安装所需的用户帐户。

请参见

其他资源

安装 Team Foundation Server


如何：安装 Team Foundation Server

如何：安装 Team Foundation Server
请参见

使用此过程安装 Team Foundation Server。

安装 Team Foundation Server 前，请确保已安装并正在运行 Microsoft SQL Server 2005 Standard 或 Enterprise Edition。完成所有数据层系统必备。有关更多信息，请参见检查表：Team Foundation Server 单服务器部署。

安装 Team Foundation Server

  1. 使用 Team Foundation Server 安装帐户（例如 Domain\TFSSETUP）登录到 Windows。

  2. 插入 CD，在出现的自动运行页上单击“安装 Team Foundation Server”，然后单击“单服务器安装”。

    如果未出现自动运行页，请在安装媒体的根文件夹中找到并运行自动运行文件 (autorun.exe)。

    此时将启动“Visual Studio Team Foundation Server 安装向导”。

  3. 在“欢迎使用安装程序”页上单击“下一步”。

  4. 在“许可条款”页上查看条款。如果您接受其中的条款和条件，请选择“我接受许可协议中的条款”，然后单击“下一步”。

    安装向导将进行扫描，查找可能导致安装失败或导致以后的服务器操作过程中出错的条件。

  5. 在“目标文件夹”页上，接受默认的目标文件夹并单击“下一步”。

  6. 在“系统状况检查”页上，单击“报告”链接检查是否有任何警告或阻止。

    • 必须先解决阻止问题，然后才能继续安装。单击“取消”并在解决了问题后再次运行安装程序。

    • 应在继续安装之前解除警告，但不应阻止安装程序完成。可以单击“下一步”。

    • 如果没有列出任何内容，则单击“下一步”。

  7. 在“服务登录帐户”页上，在“帐户名”框中键入您为 Team Foundation Server 服务帐户创建的 Windows 域用户帐户（例如 Domain\TFSSERVICE），并在“密码”框中键入密码，然后单击“下一步”。有关更多信息，请参见 Team Foundation Server 安装所需的用户帐户。

  8. 在“报告登录帐户”页上，键入 Team Foundation Server 报告帐户的帐户信息，然后单击“下一步”。

    Note 注意

    此帐户不应与 Team Foundation Server 安装或服务帐户相同。例如，使用 Domain\TFSREPORTS。

  9. 在“指定警报设置”页上，选择“启用 Team Foundation 警报”，然后键入以下信息：

    • 在“SMTP 服务器”框中，键入将用于发送电子邮件通知的服务器的名称。

    • 在“发件人电子邮件地址”框中，键入作为通知来源的电子邮件地址的名称，然后单击“下一步”。

  10. 在“安装准备就绪”页上单击“安装”。

  11. 在“正在安装组件”页上，可以监视 Team Foundation Server 的安装。

    在安装期间，可能会提示您重新启动计算机。单击“立即重新启动”，在重新启动计算机并且您再次登录后，安装将继续。

  12. 在“成功完成安装”页上，验证完成安装后，单击“完成”。

    安装 Team Foundation Server 后，应使用“Reporting Services 配置工具”备份 Reporting Services 加密密钥。这一步骤并不是创建团队项目所必需的，但属于管理 Team Foundation Server 的最佳做法。有关更多信息，请参见Team Foundation Server Administrator's Guide（《Team Foundation Server 管理员指南》）(http://go.microsoft.com/fwlink/?LinkID=52459&clcid=0x409) 中的“How to: Back Up the Reporting Services Encryption Key”（如何：备份 Reporting Services 加密密钥）。

  13. 在 Internet Explorer 中，定位到 http://localhost:8080/services/v1.0/Registration.asmx，然后单击“GetRegistrationEntries”。

  14. 在“GetRegistrationEntries”页上单击“调用”。不必输入 ToolID。

    Note 注意

    要使用此 Web 方法，您必须位于应用层计算机上。

  15. 在 XML 中，确认类型 VSTF 存在，然后关闭。

    <?xml version="1.0" encoding="utf-8" ?>

    <Type>vstfs</Type>

    Note 注意

    安装 Team Foundation Server 后，您可能希望安装 Team Explorer、Team Foundation Build 或 Team Foundation Server 代理。

安全

若要执行此过程，您必须是计算机上“Administrators”安全组的成员。在本指南中，用于安装的用户帐户为 Domain\TFSSETUP。如果也使用此帐户安装 Team Foundation Server，则安装过程中此帐户会自动添加到“Team Foundation 管理员”安全组中。有关更多信息，请参见 Team Foundation Server 安装所需的用户帐户。

请参见

其他资源

安装 Team Foundation Server
Team Foundation Build 安装概述
安装 Team Foundation Server Proxy 概述


Team Foundation Server 双服务器部署概述

Team Foundation Server 双服务器部署概述
请参见
DropDown image

借助本节中的过程，使用两台计算机来安装和配置 Team Foundation Server，一台计算机用于数据层组件，另一台用于应用层组件。

本节内容

检查表：Team Foundation Server 双服务器部署

提供一个检查表，以便在 Team Foundation Server 双服务器部署期间用作手头参考。

安装 Team Foundation Server (databases)

提供在不同于安装应用层组件的服务器上安装和配置 Team Foundation Server 数据层组件及其必备组件的详细说明。

安装 Team Foundation Server (services)

提供在不同于安装数据层组件的服务器上安装和配置 Team Foundation Server 应用层组件及其必备组件的详细说明。

提供持续的服务器可用性

提供有关如何将计算机添加到 Team Foundation 并将其配置为接管数据层或应用层服务的详细说明。

相关章节

Team Foundation 系统要求

提供安装此版本的 Team Foundation Server 时对硬件和软件的系统要求。

Team Foundation Server 安全安装概述

提供安装 Team Foundation Server 时与安全相关的信息。

Team Foundation Server 单服务器部署概述

使用本节中的过程在一台服务器上安装和配置 Team Foundation Server。

Team Foundation Build 安装概述

使用本节中的过程来安装和配置 Team Foundation Build，后者提供了生成自动化功能，可帮助您生成和共享 Visual Studio 2005 解决方案。

安装 Team Foundation Server Proxy 概述

使用本节中的过程来安装 Team Foundation Server Proxy，后者缓存以前访问过的源代码管理文件。

团队资源管理器安装概述

使用本节中的过程来安装和配置 Team Explorer。

请参见

概念

Team Foundation 安装


检查表：Team Foundation Server 双服务器部署

检查表：Team Foundation Server 双服务器部署
请参见
CollapseAll 图像 DropDown 图像

此检查表在 Team Foundation Server 双服务器部署过程中可作为一个有用的参考。此检查表列出了使用双服务器部署安装 Team Foundation Server 的一般步骤以及指向每个步骤的详细信息的链接。双服务器部署将 Team Foundation 数据层和应用层放在不同计算机上。应打印此检查表并在完成每个步骤时进行标记。

Expand 图像 准备

安装 Team Foundation Server 前，需要准备以下各项。

完成 步骤

下载此指南的最新版本，可从 Microsoft 下载中心 (http://go.microsoft.com/fwlink/?LinkId=40042) 进行下载。

检验硬件和软件要求。有关更多信息，请参见 Team Foundation 系统要求。

确定运行安装程序时要使用的用户帐户。通常，这是您的用户帐户。在本指南中，此帐户为 Domain\TFSSETUP。

获取两个服务帐户，用于 Team Foundation Server 所用服务之间的通信。

  • 一个用于运行 Team Foundation 服务的帐户（例如 Domain\TFSSERVICE）。

  • 一个用于访问 SQL Server Reporting Services 数据源的帐户（例如 Domain\TFSREPORTS）。

有关这些帐户的要求的更多信息，请参见 Team Foundation Server 安装所需的用户帐户。

Expand 图像 Team Foundation Server 安装 (Databases)

完成 | 步骤
 | 在数据层计算机上，将用于运行 Team Foundation Server 安装程序的帐户（例如 Domain\TFSSETUP）添加到本地“Administrators”组中。
 | 在数据层计算机上，将 Microsoft SQL Server 2005 Standard 或 Enterprise Edition 作为此计算机上的默认 SQL Server 实例进行安装。使用“本地系统”作为服务帐户。安装（安装主题末尾所述的）修补程序。 有关更多信息，请参见如何：安装用于 Team Foundation Server（双服务器部署）的 Microsoft SQL Server 2005。
 | 验证 Microsoft SQL Server 2005 安装，方法是使用主题 如何：验证 Microsoft SQL Server 2005 的安装 或《SQL Server 联机丛书》中的“如何验证 SQL Server 2005 服务的安装成功”(http://msdn2.microsoft.com/zh-cn/library/ms143673.aspx) 中列出的步骤。
 | 在数据层计算机上验证相应端口是否打开。 如果正在使用 Windows 防火墙、第三方防火墙软件或硬件解决方案，则应确保所需的端口已打开，以允许组件之间进行通信。有关更多信息，请参见 Team Foundation Server 安装所需的端口。
 | 在数据层计算机上安装 Team Foundation Server (databases)。有关更多信息，请参见如何：安装 Team Foundation Server (databases)。

Expand 图像 Team Foundation Server 安装 (Services)

完成 步骤

在应用层计算机上，将用于运行 Team Foundation Server 安装程序的帐户（例如 Domain\TFSSETUP）添加到本地“Administrators”组中。

在应用层计算机上，安装 Internet 信息服务 (IIS) 6.0。启用 ASP.NET。

Caution note 警告

不要安装 FrontPage Server 2002 扩展。

有关更多信息，请参见如何：安装用于 Team Foundation Server (services) 的 Internet 信息服务。

在应用层计算机上，安装用于 Team Foundation Server 的 SQL Server 2005 Reporting Services（使用 Microsoft SQL Server 2005 Standard 或 Enterprise Edition）。

Caution note 警告

此时不要运行 Reporting Services 配置工具。

在应用层计算机上，安装 Microsoft .NET Framework 2.0 修补程序 KB913393，该修补程序可从 Team Foundation Server 安装媒体中获得。

在安装媒体中，找到文件夹 KB913393，再找到与您的平台 (X86) 对应的可执行文件 (.exe)，然后双击文件进行安装。

在应用层计算机上，安装用于 Team Foundation Server 的带 Service Pack 2 的 Windows SharePoint Services 并重新启动计算机。

Caution note 警告

此时不要配置 Windows SharePoint Services。Team Foundation Server (services) 安装程序将为您配置 Windows SharePoint Services。有关更多信息，请参见如何：安装用于 Team Foundation Server（双服务器部署）的 Microsoft Windows SharePoint Services。

在应用层计算机上安装 Team Foundation Server (services)。有关更多信息，请参见如何：安装 Team Foundation Server (services)。

在应用层计算机上验证相应端口是否打开。

如果正在使用 Windows 防火墙、第三方防火墙软件或硬件解决方案，则应确保所需的端口已打开，以允许组件之间进行通信。有关更多信息，请参见 Team Foundation Server 安装所需的端口。

在本地或在其他计算机上安装 Team Explorer。有关更多信息，请参见团队资源管理器安装概述。

Expand image 请参见

其他资源

Team Foundation Server 双服务器部署概述
Team Foundation Build 安装概述
安装 Team Foundation Server Proxy 概述


安装 Team Foundation Server (databases)

安装 Team Foundation Server (databases)
请参见
DropDown image

使用本节中的过程在不同于安装应用层组件的服务器上安装和配置 Team Foundation Server 数据层组件及其必备组件。

这些必备组件和组件包括：

组件 | 安装顺序
SQL Server 2005 | 最先安装 （Team Foundation Server 数据层组件的必备组件）
Team Foundation Server 数据层组件 | 然后安装

本节内容

如何：安装用于 Team Foundation Server（双服务器部署）的 Microsoft SQL Server 2005

描述如何在数据层上安装 SQL Server 2005。

如何：验证 Microsoft SQL Server 2005 的安装

描述如何验证 SQL Server 2005 在数据层上的安装。

如何：安装 Team Foundation Server (databases)

描述如何安装 Team Foundation Server 数据层组件。

请参见

其他资源

Team Foundation Server 双服务器部署概述
安装 Team Foundation Server (services)


如何：安装用于 Team Foundation Server（双服务器部署）的 Microsoft SQL Server 2005

如何：安装用于 Team Foundation Server（双服务器部署）的 Microsoft SQL Server 2005
请参见

通过此过程，自动使用应答文件或以交互方式使用安装向导安装和配置用于 Team Foundation Server 的 Microsoft SQL Server 2005 Standard 或 Enterprise Edition。Team Foundation Server 包含 Microsoft SQL Server 2005 Standard Edition 的许可副本。您还必须安装本主体末尾所述的修补程序。

自动安装 Microsoft SQL Server 2005

还可以使用提供的应答文件从命令行安装 Microsoft SQL Server 2005。此应答文件将使安装过程自动化，来安装和配置用于 Team Foundation Server 的 Microsoft SQL Server 2005。

Caution note 警告

默认情况下，Microsoft SQL Server 根据操作系统的语言设置指定排序规则设置。有关排序规则设置的更多信息，请参见 SQL Server 2005 Books Online（《SQL Server 2005 联机丛书》）中的“Collation Settings in Setup”（安装程序中的排序规则设置）。

使用应答文件安装 Microsoft SQL Server 2005

  1. 在数据层计算机上，使用 Team Foundation Server 安装帐户（例如 Domain\TFSSETUP）登录。

  2. 在 Team Foundation Server 安装媒体上，找到预先配置的自动应答文件 (SQL2005ForDT.ini) 并将其复制到本地硬盘驱动器上的方便位置（例如，C:\）。

  3. 使用以下命令行运行 Microsoft SQL Server 2005 的安装程序：

    C:\> SQLServerSetupDirectory \setup.exe /qb /settings AnswerFileDirectory \SQL2005ForDT.ini PIDKEY= ProductKey

    其中，SQLServerSetupDirectory 是 Microsoft SQL Server 2005 的 setup.exe 的路径，AnswerFileDirectory 是应答文件的路径，ProductKey 是 Microsoft SQL Server 2005 的产品密钥，其中没有连字符或空格。

    注意：若要验证安装，请参见如何：验证 Microsoft SQL Server 2005 的安装。

安装 Microsoft SQL Server 2005

安装 Microsoft SQL Server 2005 Standard 或 Enterprise Edition。

以交互方式安装 Microsoft SQL Server 2005

  1. 在数据层计算机上，使用 Team Foundation Server 安装帐户（例如 Domain\TFSSETUP）登录到 Windows。

  2. 插入 Microsoft SQL Server 2005 的 CD。在“SQL Server 2005 启动”页的“安装”下，单击“服务器组件、工具、联机丛书和示例”。

    Note 注意

    Microsoft SQL Server 2005 标准版 CD 与 Team Foundation Server 一起提供。要安装 Microsoft SQL Server 2005 Enterprise，可以使用单独购买的软件中包含的 CD。通过运行位于安装媒体的 Servers 文件夹中的 Splash.hta 文件，可以显示“开始”页。

    此时将启动 Microsoft SQL Server 2005 安装向导。

  3. 在“最终用户许可协议”页上查看许可协议。如果您接受其中的条款和条件，请选择“我接受许可条款和条件”，然后单击“下一步”。

  4. 在“安装必备组件”页上单击“安装”。在成功安装了所需的组件后，单击“下一步”。

    此时将启动“Microsoft SQL Server 安装向导”。

  5. 单击“下一步”以启动“系统配置检查”。

  6. 在“系统配置检查”页上，检查所有要求操作（例如要求的系统重新启动）的状态，并遵循本页上的指导进行操作，直到所有操作都获得“成功”状态为止。在除“IIS 功能要求”之外的所有操作都获得“成功”状态后，请单击“下一步”开始安装。

    Note 注意

    SQL Server 2005 Reporting Services 不会安装在数据层计算机上。您可以忽略“IIS 功能要求”的“警告”状态。安装程序可能要等会儿才开始。

  7. 在“注册信息”页上填写完注册信息，然后单击“下一步”。

  8. 在“要安装的组件”页上，选择下面的组件，然后单击“高级”。

    • SQL Server Database Services

    • Analysis Services

    • Integration Services

    • 工作站组件、联机丛书和开发工具

      Note 注意

      Reporting Services 应安装在应用层上。Team Foundation Server 不需要 Notification Services。

  9. 在“功能选择”页上，展开下面的节点并指定以下选项。

    Note 注意

    除以下所述情形外，不应更改任何其他功能区中的默认选择。

    1. 在“Database Services”之下单击“复制”的图标，并选择“整个功能将不可用”。

      Note 提示

      如果要为数据文件指定不同位置，请选择“数据文件”并单击“浏览”，以指定目录或不同的物理硬盘驱动器。默认情况下，SQL Server 2005 将所有文件安装到系统驱动器中。可以通过使用不同的位置来优化系统性能。对“Analysis Services”下的“数据文件”可以执行同样的操作。

    2. 在“客户端组件”下，唯一需要安装的功能是“管理工具”。对于“客户端组件”下的所有其他项，可以选择单击图标并选择“整个功能将不可用”。

    3. 在“文档、示例和示例数据库”下，可以选择单击“联机丛书”的图标并选择“整个功能将不可用”。单击“下一步”。

  10. 在“实例名”页上，选择“默认实例”，然后单击“下一步”。

    Note 要点

    如果指定已命名的实例，Team Foundation Server 安装将失败。

  11. 在“服务帐户”页上，选择“使用内置系统帐户”并从列表中选择“本地系统”。在“安装结束时启动服务”中，选择所有服务：“SQL Server”、“SQL Server Agent”、“Analysis Services”和“SQL Browser”，然后单击“下一步”。

    Note 注意

    此服务帐户用于 Microsoft SQL Server 2005，不应与启动安装前获取的两个服务帐户混淆。

  12. 在“身份验证模式”页上，选择“Windows 身份验证模式”，然后单击“下一步”。

  13. 在“排序规则设置”页上，选择适合您的语言的排序规则，然后单击“下一步”。

    Note 注意

    如果更改了“排序规则指示符和排序顺序”，则必须选择“区分重音”。

    默认选择基于 Windows Server 2003 中的非 Unicode 语言的设置。对于多数语言，默认选择都是 Windows 排序规则，但对于美国英语，SQL Server 2005 安装时使用 SQL Server 排序规则以向后兼容。如果要更改默认的排序规则以支持其他美国英语字符，请考虑“Latin1_General”。

    对于其他语言，请考虑“_90”Windows 排序规则（当可用时），否则使用其他 Windows 排序规则。

    例如，对于日语部署，如果按下面的方式使用 Unicode CJK Extension A 字符或 Unicode 代理项，请使用“Japanese_90”排序规则，而不是默认排序规则。

    • Team Foundation Server 对象名，如“查询”或“项目”。

    • 签入到版本控制系统中的文件或路径。

    • 用于搜索的任何工作项字段。

    为了避免由全角字符或平假名/片假名等效字符带来的问题，请在安装过程中选中启用区分假名和全角字符的复选框。

    Team Foundation Server 不支持如下排序规则：

    • 不区分重音

    • 二元

    • Binary2

    • 区分大小写

    有关排序规则设置的更多信息，请参见《SQL Server 2005 联机丛书》中的“安装程序中的排序规则设置”。

  14. 在“错误和使用情况报告设置”页上，可以选择“自动将 SQL Server 2005 的错误报告发送到 Microsoft 或您公司的错误报告服务器”和“自动将 SQL Server 2005 的功能使用情况数据发送到 Microsoft”，然后单击“下一步”。

  15. 在“准备安装”页上，可以查看要安装的组件的列表，然后单击“安装”。

  16. 在“安装进度”页上，可以监视每个组件的安装状态。安装完成后，单击“下一步”。

    Note 注意

    在激活 SQL Server Reporting Services 期间，安装可能看起来像是挂起几分钟。

  17. 单击“完成”退出向导。

    Note 注意

    要在安装 Team Foundation Server 前验证您的安装，请参见如何：验证 Microsoft SQL Server 2005 的安装。

安装 Microsoft SQL Server 2005 修补程序

安装 Microsoft SQL Server 2005 后，必须安装修补程序来更新 SQL Server Analysis Services 以便更有效地支持报告。

Note 注意

有关最近的更新，请访问 Microsoft 网站 (http://go.microsoft.com/fwlink/?LinkId=62015)。

安装 Microsoft SQL Server 2005 修补程序

  1. 在数据层计算机上，打开“SQL Server 配置管理器”，右击“SQL Server 浏览器服务”，然后单击“停止”。

  2. 在 Team Foundation Server 安装媒体上，找到 SQLServerKB 文件夹。

  3. 找到与您的操作系统和语言对应的可执行文件 (.exe)，如 AS2005-KBnnnnnn-x86-ENU.exe，然后双击该文件以启动 Hotfix Installer（修补程序安装程序）。

  4. 在 “Hotfix Installer”中接受“End User License Agreement”（最终用户许可协议），完成各页以安装该修补程序，然后单击“Finish”（完成）。

  5. 在“SQL Server 配置管理器”中，右击“SQL Server Browser 服务”，然后单击“属性”。

  6. 在“服务”选项卡上找到“启动模式”，然后选择“自动”。

  7. 在“登录”选项卡上，单击“启动”。

    Note 注意

    如果在“登录”选项卡上未启用“启动”，则单击“服务”选项卡，将“启动模式”设置为“禁用”，然后再次选择“自动”以显式更新“启动模式”。

要在安装 Windows SharePoint Services 之前验证安装，请参见如何：验证 Microsoft SQL Server 2005 的安装。

安全

要执行这些过程，您必须是计算机上“Administrators”安全组的成员。在本指南中，用于安装的用户帐户为 Domain\TFSSETUP。如果也使用此帐户安装 Team Foundation Server，则安装过程中此帐户会自动添加到“Team Foundation 管理员”安全组中。有关更多信息，请参见 Team Foundation Server 安装所需的用户帐户。

Microsoft SQL Server 2005 服务要求打开特定端口。有关更多信息，请参见 Team Foundation Server 安装所需的端口。

请参见

其他资源

安装 Team Foundation Server (databases)
Team Foundation Build 安装概述
安装 Team Foundation Server Proxy 概述


如何：验证 Microsoft SQL Server 2005 的安装

如何：验证 Microsoft SQL Server 2005 的安装
请参见

安装 SQL Server 后，您可能需要验证安装是否完成以及是否为 Team Foundation Server 的下一个安装步骤配置了服务器。下面的过程提供了验证以下配置的步骤。

  • 服务正在运行。

  • 连接设置已配置。

  • 防火墙已正确配置。

Caution note 警告

Team Foundation Server 安装向导可在安装过程中为您配置组件。将验证限制为检查正在运行的服务，并根据下面的过程进行设置。如果您尝试在此时配置 Reporting Services，您可能就会无法正确安装和配置 Team Foundation Server。

验证服务是否正在运行

  1. 从“开始”菜单中，依次单击“所有程序”、“Microsoft SQL Server 2005”、“配置工具”和“SQL Server 配置管理器”。

  2. 选择“SQL Server 2005 Services”，验证是否每个服务都有一个指示服务正在运行的绿色箭头。

  3. 选择“SQL Server 2005 网络配置”，单击“MSSQLServer 的协议”，然后验证是否启用了“TCP/IP”。

验证到服务器的连接

  1. 从“开始”菜单中，依次单击“所有程序”、“Microsoft SQL Server 2005”和“SQL Server Management Studio”。

  2. 在“连接到服务器”对话框中，选择“服务器类型”中的“数据库引擎”，键入要连接到的服务器的名称，然后单击“连接”。

    Note 注意

    如果 SQL Server 安装在一个群集上，则服务器的名称是该群集的名称而不是该计算机的名称。

  3. 在对象资源管理器中，验证服务器名称旁边是否出现了绿色箭头。

    Note 注意

    如果无法连接到服务器，请验证防火墙设置，然后重新尝试连接。

安全

若要执行这些过程，您必须是计算机“Administrators”安全组的成员。有关更多信息，请参见 Team Foundation Server 安装所需的用户帐户。

请参见

任务

如何：安装用于 Team Foundation Server（单服务器部署）的 Microsoft SQL Server 2005
如何：安装用于 Team Foundation Server（双服务器部署）的 Microsoft SQL Server 2005

参考

检查表：Team Foundation Server 单服务器部署
检查表：Team Foundation Server 双服务器部署


如何：安装 Team Foundation Server (databases)

如何：安装 Team Foundation Server (databases)
请参见

使用此过程安装 Team Foundation Server 数据层组件。

安装 Team Foundation Server 前，请确保已安装并正在运行 Microsoft SQL Server 2005 标准版或企业版。完成所有数据层系统必备。有关更多信息，请参见检查表：Team Foundation Server 双服务器部署。

安装 Team Foundation Server (databases)

  1. 使用在检查工作表时标识的 Team Foundation Server 安装帐户（例如 Domain\TFSSETUP）登录到 Windows。

  2. 插入 Team Foundation Server 安装媒体，在出现的自动运行页上单击“安装 Team Foundation Server”，再单击“双服务器安装”，然后单击“仅安装 Team Foundation 数据库层”。

    如果未出现自动运行页，请在安装媒体的根文件夹中找到并运行自动运行文件 (autorun.exe)。

    此时将启动 Visual Studio 2005 Team Foundation Server (databases) 安装向导。

  3. 在“欢迎使用安装程序”页上单击“下一步”。

  4. 在“许可条款”页上查看许可协议。如果您接受其中的条款和条件，请选择“我接受许可协议中的条款”，然后单击“下一步”。

  5. 在“目标文件夹”页上单击“下一步”。

  6. 在“系统状况检查”页上，单击“报告”链接检查是否有任何警告或阻止。

    • 必须先解决阻止问题，然后才能继续安装。单击“取消”并在解决了问题后再次运行安装程序。

    • 应在继续安装之前解除警告，但不应阻止安装程序完成。可以单击“下一步”。

      例如，如果未启用防火墙，则会在列表中出现一个警告。可以继续安装，但启用组件间通信所需的端口和例外可能需要手动添加。

    • 如果没有列出任何内容，则单击“下一步”。

  7. 在“安装准备就绪”页上单击“安装”。

  8. 在“正在安装组件”页上，可以监视 Team Foundation 数据层组件的安装。

    在安装期间，可能会提示您重新启动计算机。单击“立即重新启动”。在重新启动计算机并且您使用同一帐户再次登录后，安装将继续。

  9. 在“成功完成安装”页上单击“完成”。

  10. 在自动运行页上单击“退出”。

查看 Team Foundation Server (databases)

  1. 依次单击“开始”、“程序文件”、“Microsoft SQL Server 2005”，然后单击“SQL Server Management Studio”。

  2. 在“连接到服务器”对话框中，选择“服务器中的数据库引擎”类型，键入要连接到的服务器的名称，然后单击“连接”。

    Note 注意

    如果 SQL Server 安装在一个群集上，则服务器的名称是该群集的名称而不是该计算机的名称。

  3. 在“对象资源管理器”中，展开“数据库”并验证 Team Foundation Server 数据库是否存在。

安全

若要执行此过程，您必须是计算机上“Administrators”安全组的成员。在本指南中，用于安装的用户帐户为 Domain\TFSSETUP。如果使用相同的帐户安装 Team Foundation Server，安装过程中此帐户会自动添加到“Team Foundation 管理员”安全组中。有关更多信息，请参见 Team Foundation Server 安装所需的用户帐户。

请参见

其他资源

安装 Team Foundation Server (databases)

要提出有关“帮助”或本产品其他功能的建议或错误报告，请转到反馈站点。


安装 Team Foundation Server (services)

安装 Team Foundation Server (services)
请参见
DropDown image

使用本节中的过程在不同于安装数据层组件的服务器上安装和配置 Team Foundation Server 应用层组件及其必备组件。

这些必备组件和组件包括：

组件 | 安装顺序
Internet 信息服务 (IIS) 6.0 | 最先安装 （Team Foundation Server 应用层组件的必备组件）
SQL Server 2005 Reporting Services | 其次安装 （Team Foundation Server 应用层组件的必备组件）
带 Service Pack 2 的 Windows SharePoint Services | 第三安装 （Team Foundation Server 应用层组件的必备组件）
Team Foundation Server 应用层组件 | 第四安装

有关在两台计算机上安装 Team Foundation Server 的整个过程的概述，请参见演练：安装 Team Foundation Server 双服务器部署。

本节内容

如何：安装用于 Team Foundation Server (services) 的 Internet 信息服务

描述如何在应用层上安装和配置 Internet 信息服务 (IIS) 6.0。

如何：安装用于 Team Foundation Server（双服务器部署）的 Microsoft SQL Server 2005 Reporting Services

描述如何在 Team Foundation Server 双服务器部署中的应用层上安装 SQL Server 2005 Reporting Services。

如何：安装用于 Team Foundation Server（双服务器部署）的 Microsoft Windows SharePoint Services

描述如何在应用层上安装和配置 Windows SharePoint Services。

如何：安装 Team Foundation Server (services)

描述如何安装 Team Foundation Server 应用层组件。

请参见

其他资源

Team Foundation Server 双服务器部署概述
安装 Team Foundation Server (databases)


如何：安装用于 Team Foundation Server (services) 的 Internet 信息服务

如何：安装用于 Team Foundation Server (services) 的 Internet 信息服务
请参见

使用此过程在 Team Foundation Server 应用层上安装 Internet 信息服务 (IIS) 6.0。

将服务器配置为应用程序服务器

  1. 通过执行以下任一操作来启动“配置您的服务器向导”：

    • 默认情况下，“管理您的服务器”会在 Windows 启动时自动启动。从“管理您的服务器”中，单击“添加或删除角色”。

    • 从“控制面板”中打开“管理工具”，然后打开“配置您的服务器向导”。

  2. 在“欢迎使用‘配置您的服务器向导’”页上单击“下一步”。

  3. 在“预备步骤”页上单击“下一步”。

  4. 在“服务器角色”页上，单击“应用程序服务器 (IIS，ASP.NET)”，然后单击“下一步”。

  5. 在“应用程序服务器选项”页上选择“启用 ASP.NET”，然后单击“下一步”。

    Note 要点

    不要选择“FrontPage 服务器扩展”。此服务器将承载 Windows SharePoint Services，后者与 FrontPage 服务器扩展不兼容。

  6. 在“选择总结”页上单击“下一步”。

    Note 注意

    可能会提示您插入 Windows Server 2003 安装媒体。

  7. 单击“完成”来完成该向导。

  8. 访问 Windows Update (http://windowsupdate.microsoft.com) 并安装“重要更新和 Service Pack”组中的所有项。

使用“添加/删除程序”实用工具来启用 ASP.NET

  1. 从“控制面板”中打开“添加/删除程序”。

  2. 单击“添加/删除 Windows 组件”。

    此时将启动“Windows 组件向导”。

  3. 在“Windows 组件”页上选择“应用程序服务器”，然后单击“详细信息”。

  4. 如果尚未选中，请选择“ASP.NET”，然后单击“确定”。

    Note 要点

    任何时候都不要选择“FrontPage 2002 Server Extensions”。此服务器将承载 Windows SharePoint Services，后者与 FrontPage 服务器扩展不兼容。

  5. 在“Windows 组件”页上单击“下一步”。

    Note 注意

    可能会提示您插入 Windows Server 2003 安装媒体。

  6. 单击“完成”关闭向导。

  7. 访问 Windows Update (http://windowsupdate.microsoft.com) 并安装“重要更新和 Service Pack”组中的所有项。

安全

若要执行这些过程，您必须是计算机上的“Administrators”安全组的成员。在本指南中，将用于安装的用户帐户是 Domain\TFSSETUP。如果使用此相同的帐户安装 Team Foundation Server，则在安装期间此帐户会自动添加到“Team Foundation 管理员”安全组中。有关更多信息，请参见 Team Foundation Server 安装所需的用户帐户。

请参见

其他资源

安装 Team Foundation Server (services)


如何：安装用于 Team Foundation Server（双服务器部署）的 Microsoft SQL Server 2005 Reporting Services

如何：安装用于 Team Foundation Server（双服务器部署）的 Microsoft SQL Server 2005 Reporting Services
请参见

使用这些过程为 Microsoft SQL Server 2005 标准版或企业版安装 Microsoft SQL Server 2005 Reporting Services。您可以使用安装向导或使用应答文件以交互方式安装。

Note 注意

安装前，计算机必须安装有启用了 ASP.NET 的 Internet 信息服务。

使用应答文件安装 Microsoft SQL Server 2005 Reporting Services

可以使用提供的应答文件从命令行安装 Microsoft SQL Server 2005 Reporting Services。此应答文件将使安装过程自动化，从而安装和配置用于 Team Foundation Server 的 Microsoft SQL Server 2005 Reporting Services。

使用应答文件安装 Microsoft SQL Server 2005 Reporting Services

  1. 在应用层计算机上，使用 Team Foundation Server 安装帐户（例如 Domain\TFSSETUP）登录到 Windows。

  2. 在 Team Foundation Server 安装媒体上，找到预先配置的自动应答文件 (SQL2005ForAT.ini) 并将其复制到本地硬盘上的方便位置（例如，C:\）。

  3. 使用以下命令行运行 Microsoft SQL Server 2005 的安装程序：

    C:\> SQLServerSetupDirectory \setup.exe /qb /settings AnswerFileDirectory \SQL2005ForAT.ini PIDKEY= ProductKey

    其中，SQLServerSetupDirectory 是 Microsoft SQL Server 2005 的 setup.exe 的路径，AnswerFileDirectory 是应答文件的路径，ProductKey 是 Microsoft SQL Server 2005 的产品密钥，其中没有连字符或空格。

    Note 要点

    Visual Studio Team Foundation Server (services) 安装向导配置 Reporting Services 以使您可以处理数据层。此时使用 Reporting Service 配置工具可能会妨碍向导正确配置服务。

以交互方式安装 Microsoft SQL Server 2005 Reporting Services

使用 Microsoft SQL Server 2005 标准版或企业版安装 SQL Server 2005 Reporting Services。Team Foundation Server 包括 Microsoft SQL Server 2005 标准版的许可副本。

Note 注意

在安装 Microsoft SQL Server 2005 Reporting Services 之前必须先安装 Internet 信息服务 (IIS) 6.0。

以交互方式安装 Microsoft SQL Server 2005 Reporting Services

  1. 在应用层计算机上，使用 Team Foundation Server 安装帐户（例如 Domain\TFSSETUP）登录到 Windows。

  2. 插入 Microsoft SQL Server 2005 的 CD。在“SQL Server 2005 启动”页的“安装”下，单击“服务器组件、工具、联机丛书和示例”。

    Note 注意

    Microsoft SQL Server 2005 标准版 CD 与 Team Foundation Server 一起提供。要安装 SQL Server Enterprise，可以使用单独购买的软件中包含的 CD。通过运行位于安装媒体的 Servers 文件夹中的 Splash.hta 文件，可以显示“开始”页。

    此时将启动 Microsoft SQL Server 2005 安装向导。

  3. 在“最终用户许可协议”页上查看许可协议。如果您接受其中的条款和条件，请选择“我接受许可条款和条件”，然后单击“下一步”。

  4. 在“安装必备组件”页上单击“安装”。在成功安装了所需的组件后，单击“下一步”。

    此时将启动“Microsoft SQL Server 安装向导”。

  5. 单击“下一步”以启动“系统配置检查”。

  6. 在“系统配置检查”页上，检查所有要求操作（例如要求的系统重新启动）的状态，并遵循本页上的指导进行操作，直到所有操作都获得“成功”状态。在所有操作都获得“成功”状态后，单击“下一步”开始安装。

    Note 注意

    安装程序过一会才会启动。

  7. 在“注册信息”页上填写完注册信息，然后单击“下一步”。

  8. 在“要安装的组件”页上，选择“Reporting Services”，然后单击“下一步”。

    Note 注意

    如果单击“高级”，请不要移除任何默认选择。

  9. 在“实例名”页上，选择“默认实例”，然后单击“下一步”。

    Note 要点

    如果指定已命名的实例，Team Foundation Server 安装将失败。

  10. 在“服务帐户”页上，选择“使用内置系统帐户”并从列表中选择“网络服务”。在“在安装结束时启动服务”中，选择“Reporting Services”，然后单击“下一步”。

  11. 在“报表服务器安装选项”页上单击“下一步”。

    将默认选择“安装但不配置服务器”。

  12. 在“错误和使用情况报告设置”页上，可以选择“自动将 SQL Server 2005 的错误报告发送到 Microsoft 或您公司的错误报告服务器”和“自动将 SQL Server 2005 的功能使用情况数据发送到 Microsoft”，然后单击“下一步”。

  13. 在“准备安装”页上，可以查看要安装的组件的列表，然后单击“安装”。

  14. 在“安装进度”页上，可以监视每个组件的安装状态。安装完成后，单击“下一步”。

    Note 注意

    在激活 SQL Server Reporting Services 期间，安装可能看起来像是有几分钟停止响应。

  15. 单击“完成”退出向导。

Caution note 警告

不要使用 Reporting Services 配置工具检验服务是否正在运行。Team Foundation Server 安装向导为您配置 Reporting Services，打开该工具可能会阻止安装完成。

验证 Report Services 安装

安装完后，验证服务是否在运行并设置为自动启动。

验证安装

  1. 单击“开始”，单击“管理工具”，然后单击“服务”。

  2. 在“服务管理器”的“名称”列中找到“SQL Server Reporting Services”，并验证“状态”为“已启动”，“启动类型”为“自动”。

    Note 注意

    右击服务，然后单击“属性”并进行更改，可更改状态或启动类型。

  3. 关闭“服务管理器”。

    验证完服务后，必须安装 Microsoft .NET Framework 修补程序。有关更多信息，请参见检查表：Team Foundation Server 双服务器部署。

安全

要执行这些过程，您必须是计算机上“Administrators”安全组的成员。在本指南中，用于安装的用户帐户为 Domain\TFSSETUP。如果也使用此帐户安装 Team Foundation Server，则安装过程中此帐户会自动添加到“Team Foundation 管理员”安全组中。有关更多信息，请参见 Team Foundation Server 安装所需的用户帐户。Microsoft SQL Server 2005 服务要求打开特定端口。有关更多信息，请参见 Team Foundation Server 安装所需的端口。

请参见

其他资源

安装 Team Foundation Server (databases)


如何：安装用于 Team Foundation Server（双服务器部署）的 Microsoft Windows SharePoint Services

如何：安装用于 Team Foundation Server（双服务器部署）的 Microsoft Windows SharePoint Services
请参见

通过以下过程，使用安装向导以交互方式或从命令行中以静默方式为 Team Foundation Server 安装带 Service Pack 2 的 Microsoft Windows SharePoint Services。

在本地化版本的 Windows SharePoint Services 上安装 Team Foundation Server 之前，必须先安装与 Team Foundation Server 语言匹配的 Windows SharePoint Services 语言包。例如，在安装英文版本的 Team Foundation Server 之前，必须安装英文的 Windows SharePoint Services 语言包。

Note 要点

Windows SharePoint Services 需要使用 NTFS 文件系统。

以静默方式安装 Microsoft Windows SharePoint Services

可以从命令行中以静默方式安装 Windows SharePoint Services。

以静默方式安装 Windows SharePoint Services

  1. 在应用层计算机上，使用 Team Foundation Server 安装帐户（例如 Domain\TFSSETUP）登录到 Windows。

  2. 下载带 Service Pack 2 的 Microsoft Windows SharePoint Services 2.0 (http://go.microsoft.com/fwlink/?linkid=55087) 并将该文件保存到本地硬盘驱动器中的方便位置。

  3. 使用以下命令行运行下载的自解压缩安装程序文件 (stsv2.exe)：

    C:\> DownloadDirectory \STSV2.EXE /C:"setupsts.exe /remoteSql=yes /provision=no /q"

    其中，DownloadDirectory 是硬盘驱动器中保存下载文件的位置的路径。

    Note 要点

    必须使用 /remoteSql=yes 选项来安装 Windows SharePoint Services。这样会将 Windows SharePoint Services 配置为使用远程 SQL Server。/provision=no 选项将推迟 Windows SharePoint Services 的配置。以后，Team Foundation Server 安装程序会将 Windows SharePoint Services 配置为与 Team Foundation Server 的其余部分使用相同的 SQL Server 实例。

    您将不会收到有关安装完成的任何指示。而是在继续操作之前留出几分钟时间等待安装完成。

  4. 访问 Windows Update (http://windowsupdate.microsoft.com) 并安装“重要更新和 Service Pack”组中的所有项。

  5. 重新启动计算机。

以交互方式安装 Microsoft Windows SharePoint Services

安装带 Service Pack 2 的 Microsoft Windows SharePoint Services。

以交互方式安装 Windows SharePoint Services

  1. 在应用层计算机上，使用 Team Foundation Server 安装帐户（例如 Domain\TFSSETUP）登录到 Windows。

  2. 下载带 Service Pack 2 的 Microsoft Windows SharePoint Services (http://go.microsoft.com/fwlink/?linkid=55087) 并将该文件保存到本地硬盘驱动器中。

  3. 运行下载的自解压缩安装程序文件 (stsv2.exe)。

  4. 在“最终用户许可协议”页上查看许可协议。如果您接受其中的条款和条件，请选择“我接受许可协议中的条款”，然后单击“下一步”。

  5. 在“安装类型”页上选择“服务器场”，然后单击“下一步”。

    Note 要点

    必须使用“服务器场”选项来安装 Windows SharePoint Services。这样会将 Windows SharePoint Services 配置为使用远程 SQL Server。以后，Team Foundation Server 安装程序会将 Windows SharePoint Services 配置为与 Team Foundation Server 的其余部分使用相同的 SQL Server 实例。

  6. 在“摘要”页上单击“安装”。

    安装完成时，将打开一个 Web 浏览器窗口，并显示“配置管理虚拟服务器”页。确认该页显示后，不要进行任何更改，关闭该浏览器窗口。

    Note 要点

    不要对显示的页进行任何更改。以后，Team Foundation Server 安装程序会将 Windows SharePoint Services 配置为与 Team Foundation Server 的其余部分使用相同的 SQL Server 实例。

    如果未显示该页，则应使用“Windows SharePoint Services Administrator's Guide”（《Windows SharePoint Services 管理员指南》）(http://go.microsoft.com/fwlink/?LinkId=52668) 来确定原因并排除故障。

  7. 访问 Windows Update (http://windowsupdate.microsoft.com) 并安装“重要更新和 Service Pack”组中的所有项。

  8. 重新启动计算机。

验证安装

安装 Windows SharePoint Server 之后，可以确保即使在尚未安装 Team Foundation Server 的情况下，也可以运行服务。

验证已安装 Windows SharePoint Services

  • 打开 Internet Explorer 并键入相应的服务器名称作为地址。

    例如，对于名为 ADATUM 的服务器，应键入 Http://adatum。

    虽然未配置站点，但服务器是活动 Web 服务器并提供“建设中”页面。

安全

要执行这些过程，您必须是计算机上“Administrators”安全组的成员。在本指南中，用于安装的用户帐户为 Domain\TFSSETUP。如果也使用此帐户安装 Team Foundation Server，则安装过程中此帐户会自动添加到“Team Foundation 管理员”安全组中。有关更多信息，请参见 Team Foundation Server 安装所需的用户帐户。

请参见

参考

检查表：Team Foundation Server 双服务器部署

其他资源

安装 Team Foundation Server (services)


如何：安装 Team Foundation Server (services)

如何：安装 Team Foundation Server (services)
请参见

使用此过程安装 Team Foundation Server 应用层组件。执行此过程前，请完成数据层计算机的安装和应用层系统必备的安装。

有关更多信息，请参见安装 Team Foundation Server (services)。

安装 Team Foundation Server (services)

  1. 在应用层计算机上，使用 Team Foundation Server 安装帐户（例如 Domain\TFSSETUP）登录到 Windows。

  2. 插入 CD，在出现的自动运行页上，单击“安装 Team Foundation Server”，单击“双服务器安装”，然后单击“仅安装 Team Foundation 应用层”。

    如果未出现自动运行页，请在安装媒体的根文件夹中找到并运行自动运行文件 (autorun.exe)。

    此时将启动“Visual Studio Team Foundation Server (services) 安装向导”。

  3. 在“欢迎使用安装程序”页上单击“下一步”。

  4. 在“许可条款”页上查看许可协议。如果您接受其中的条款和条件，请选择“我接受许可协议中的条款”，然后单击“下一步”。

    安装向导将进行扫描，查找可能导致安装失败或导致以后的服务器操作过程中出错的条件。

  5. 在“目标文件夹和数据库服务器”页上，键入以下信息：

    • 在“目标文件夹”框中，键入安装路径或接受默认设置。

    • 在“数据库服务器”框中，键入在其上安装 Team Foundation Server (databases) 的计算机的名称。

      Note 注意

      必须使用计算机名，而不是 IP 地址。

  6. 在“系统状况检查”页上，单击“报告”链接检查是否有任何警告或阻止。

    • 必须先解决阻止问题，然后才能继续安装。单击“取消”并在解决了问题后再次运行安装程序。

    • 应在继续安装之前解除警告，但不应阻止安装程序完成。可以单击“下一步”。

    • 如果没有列出任何内容，则单击“下一步”。

  7. 在“服务帐户”页上，键入 Team Foundation Server 服务帐户（例如 Domain\TFSSERVICE）的帐户信息，然后单击“下一步”。

  8. 在“报告登录帐户”页上，键入 Team Foundation Server 报告帐户（例如 Domain\TFSREPORTS）的帐户信息，然后单击“下一步”。

    Note 注意

    此帐户不应与 Team Foundation Server 安装或服务帐户相同。

  9. 在“Team Foundation 警报”页上，键入以下信息：

    1. 在“SMTP 服务器”框中，键入将用于发送 Team Foundation 警报的服务器的名称。

    2. 在“发件人电子邮件地址”框中，键入发送 Team Foundation 警报的电子邮件地址的名称，然后单击“下一步”。

      Note 注意

      如果要在这里启用警报，就必须知道组织的 SMTP 服务器。对于仅 SMTP 访问，Team Foundation Server 不需要特殊的配置设置。SMTP 的安装和配置不在本文档集的范围之内。有关更多信息，请参见有关 Windows Server 2003 的文档。

  10. 在“安装准备就绪”页上单击“安装”。

    在安装期间，可能会提示您重新启动计算机。单击“立即重新启动”，在重新启动计算机并且您再次登录后，安装将继续。

  11. 在“成功完成安装”页上单击“完成”。

    安装 Team Foundation Server 后，应使用“Reporting Services 配置工具”备份 Reporting Services 加密密钥。这一步骤并不是创建团队项目所必需的，但属于管理 Team Foundation Server 的最佳做法。有关更多信息，请参见Team Foundation Server 管理员指南中的“How to: Back up the Reporting Services Encryption Key”（如何：备份 Reporting Services 加密密钥）。

  12. 在 Internet Explorer 中，定位到 http://localhost:8080/services/v1.0/Registration.asmx，然后单击“GetRegistrationEntries”。

  13. 在 GetRegistrationEntries 页上单击“调用”。不必输入 ToolID。

    Note 注意

    要使用此 Web 方法，您必须位于应用层计算机上。

  14. 在 XML 中，确认类型 VSTF 如此处所示，然后关闭。

    <?xml version="1.0" encoding="utf-8" ?>

    <Type>vstfs</Type>

    Note 注意

    安装 Team Foundation Server 后，您可能希望安装 Team Explorer、团队 Team Foundation Build 或 Team Foundation Server 代理。

安全

若要执行此过程，您必须是计算机上“Administrators”安全组的成员。在本指南中，用于安装的用户帐户为 Domain\TFSSETUP。如果使用相同的帐户安装 Team Foundation Server，安装过程中此帐户会自动添加到“Team Foundation 管理员”安全组中。有关更多信息，请参见 Team Foundation Server 安装所需的用户帐户。

请参见

其他资源

安装 Team Foundation Server (services)
Team Foundation Build 安装概述
安装 Team Foundation Server Proxy 概述


提供持续的服务器可用性

提供持续的服务器可用性
请参见
DropDown image

为了在维护期间或服务器出现故障的情况下为系统客户端提供连续的服务，可将计算机添加到 Team Foundation 系统并将它们配置为接管数据层或应用层服务。

本节内容

检查表：Team Foundation Server 群集部署

提供在群集中安装 Team Foundation 数据库前所需内容的摘要。

如何：准备用于数据层安装的群集

提供在群集中安装 Team Foundation 数据库前必须完成的步骤。

如何：加速群集中的服务器恢复

提供相应的步骤，以使用脚本文件显式重新启动群集中的数据层和应用层之间的服务。

检查表：备用应用层配置

提供设置备用计算机以支持应用层服务时必须完成的步骤的摘要。

如何：将应用层配置为备用

描述为 Team Foundation 应用层设置热备用计算机时必须完成的步骤。

相关章节

Team Foundation Server 双服务器部署概述

借助本节中的过程，使用两台计算机来安装和配置 Team Foundation Server，一台计算机用于数据层组件，另一台用于应用层组件。

在线资源

Team Foundation Administrator's Guide（《Team Foundation 管理员指南》）(http://go.microsoft.com/fwlink/?LinkId=52459)。

请参见

概念

Team Foundation 安装


检查表：Team Foundation Server 群集部署

检查表：Team Foundation Server 群集部署
请参见
CollapseAll 图像 DropDown 图像

若要确保 Team Foundation 的最大可用性，可在群集中安装数据层。在群集中安装 Team Foundation 前使用此检查表作为所需内容的概述。

Expand 图像 Windows 2003 Server 群集和 SQL Server 2005

完成 | 步骤
 | 下载此指南的最新版本，可从 Microsoft 下载中心 (http://go.microsoft.com/fwlink/?LinkId=40042) 进行下载。
 | 安装 Windows Server 2003 Enterprise Edition 或 Windows Server 2003 Datacenter Edition
 | 配置单个仲裁群集，该群集支持为主动/被动模式配置的两个节点。
 | 安装包括分析组件在内的 SQL Server 2005，安装时对群集的虚拟服务器名称和 SQL Server 的虚拟服务器名称分别使用一个静态 IP 地址。
 | 验证 SQL Server 2005 是否正在运行。
 | 验证每个 SQL Server 服务是否设置为自动启动。有关更多信息，请参见如何：准备用于数据层安装的群集。
 | 为本地驱动器上的数据层制作 NetSetup 文件夹的副本。
 | 修改 msiproperty.ini，将键名 VSTF_DB_SERVER 设置为群集的虚拟服务器名称。

Expand 图像 Team Foundation Server 安装 (Databases)

完成 步骤

检验硬件和软件要求。有关更多信息，请参见 Team Foundation 系统要求。

标识用于运行安装程序的用户帐户，并将该帐户添加到本地“Administrators”组。

通常，这是您的用户帐户。在本指南中，此帐户为 Domain\TFSSETUP。有关更多信息，请参见 Team Foundation Server 安装所需的用户帐户。

获取两个服务帐户，用于 Team Foundation Server 所用服务之间的通信。

  • 一个用于运行 Team Foundation 服务的帐户（例如 Domain\TFSSERVICE）。

  • 一个用于访问 SQL Server Reporting Services 数据源的帐户（例如 Domain\TFSREPORTS）。

有关更多信息，请参见 Team Foundation Server 安装所需的用户帐户。

在主动节点上，将用于运行 Team Foundation Server 安装程序的帐户（例如 Domain\TFSSETUP）添加到本地“Administrators”组中。

在主动节点上，将 Microsoft SQL Server 2005 Standard 或 Enterprise Edition 作为此计算机上的默认 SQL Server 实例进行安装。使用“本地系统”作为服务帐户。安装（安装主题末尾所述的）修补程序。

有关更多信息，请参见如何：安装用于 Team Foundation Server（双服务器部署）的 Microsoft SQL Server 2005。

验证 Microsoft SQL Server 2005 安装，方法是使用主题如何：验证 Microsoft SQL Server 2005 的安装或《SQL Server 联机丛书》中的“如何验证 SQL Server 2005 服务的安装成功”(http://msdn2.microsoft.com/zh-cn/library/ms143673.aspx) 中列出的步骤。

在主动节点上，验证相应端口是否打开。

如果正在使用 Windows 防火墙、第三方防火墙软件或硬件解决方案，则应确保所需的端口已打开，以允许组件之间进行通信。有关更多信息，请参见 Team Foundation Server 安装所需的端口。

在主动节点上安装 Team Foundation Server (databases)。有关更多信息，请参见如何：安装 Team Foundation Server (databases)。

Expand 图像 Team Foundation Server 安装 (Services)

必须在群集以外的计算机上安装应用程序服务。只有 Team Foundation 数据库可驻留在群集中。

完成 步骤

验证应用层计算机是否满足硬件和软件要求。有关更多信息，请参见 Team Foundation 系统要求。

将用于运行安装程序的用户帐户添加到本地管理员组。在本指南中，此帐户为 Domain\TFSSETUP。

有关更多信息，请参见 Team Foundation Server 安装所需的用户帐户。

安装 Internet 信息服务 (IIS) 6.0 并启用 ASP.NET。

Caution note 警告

不要安装 FrontPage 服务器扩展。

有关更多信息，请参见如何：安装用于 Team Foundation Server (services) 的 Internet 信息服务。

安装用于 Team Foundation Server 的 SQL Server 2005 Reporting Services（使用 Microsoft SQL Server 2005 Standard 或 Enterprise Edition）。

Caution note 警告

不要配置报告服务器。Team Foundation Server (services) 安装程序将为您完成 services 配置。

安装 Microsoft .NET Framework 2.0 修补程序 KB913393，该修补程序位于 Team Foundation Server 安装媒体上。

在安装媒体上找到文件夹 KB913393，再找到与您的平台对应的可执行文件 (.exe)，然后双击该文件进行安装。

安装用于 Team Foundation Server 的带 Service Pack 2 的 Windows SharePoint Services 并重新启动。

Caution note 警告

不要配置 Windows SharePoint Services。Team Foundation Server (services) 安装程序将为您完成 Windows SharePoint Services 配置。

有关更多信息，请参见如何：安装用于 Team Foundation Server（双服务器部署）的 Microsoft Windows SharePoint Services。

安装 Team Foundation Server (services)。有关更多信息，请参见如何：安装 Team Foundation Server (services)。

验证防火墙相应端口是否打开或者 SQL Server 是否包含在例外情况中。

如果正在使用 Windows 防火墙、第三方防火墙软件或硬件解决方案，则应确保所需的端口已打开，以允许组件之间进行通信。

有关更多信息，请参见 Team Foundation Server 安装所需的端口。

在本地或在其他计算机上安装 Team Explorer。有关更多信息，请参见团队资源管理器安装概述。

Expand image 请参见

任务

如何：准备用于数据层安装的群集


如何：准备用于数据层安装的群集

如何：准备用于数据层安装的群集
请参见

通过在群集中运行数据层可以为客户端提供不间断的服务。运行 Team Foundation Server 安装向导前，必须为 Team Foundation 数据库安装准备群集。

以下过程假定您安装了 SQL Server 2005 并且在群集中运行。有关更多信息，请参见位于 http://msdn2.microsoft.com/zh-cn/library/ms179530.aspx 的“How to: Create a New SQL Server 2005 Failover Cluster (Setup)”（如何：创建新的 SQL Server 2005 故障转移群集（安装））。

若要完成此过程，您需要了解 SQL Server 的虚拟服务器名称和 IP 地址。

为数据层安装准备群集

  1. 以“群集管理员”身份登录到群集中的主动节点。

  2. 依次单击“开始”、“Microsoft SQL Server 2005”、“配置工具”，然后单击“SQL Server 配置管理器”。

  3. 对接下来的每个 SQL Server 服务，打开“属性”对话框，在“服务”选项卡上，将“启动模式”设置为“自动”。

    • SQL Server (MSSQLSERVER)

    • SQL Server Agent (MSSQLSERVER)

    • SQL Analysis Services (MSSQLSERVER)

    • SQL Server Integration Services

    • SQL Server Browser

    • SQL Server FullText Search (MSSQLSERVER)

      Note 注意

      如果缺少以上任意服务，则无法安装 Team Foundation。可以修改 SQL Server 2005 安装，方法是使用“添加/删除程序”添加 SQL Server 2005 缺少的组件。

  4. 将数据层的 NetSetup 文件夹从安装媒体复制到本地驱动器上的目录，例如 c:\temp\。

  5. 在 NetSetup 副本中，找到并在文本编辑器中编辑 msiproperty.ini 文件。

  6. 在该文件中找到键名 VSTF_DB_SERVER，并将“计算机名”更换为 SQL Server 的虚拟服务器名称。

    下面的示例显示原始标记规范和为“VSTFSQLCLUSTER”上的安装修改的标记。

    原始 VSTF_DB_SERVER=[ComputerName]

    修改后的 VSTF_DB_SERVER= VSTFSQLCLUSTER

    Caution note 警告

    仅更换此实例。如果将“计算机名”更换为其他标记的虚拟服务器名称，则将错误地更新应用层服务计算机名称。

  7. 安装 Team Foundation 数据库。有关更多信息，请参见如何：安装 Team Foundation Server (databases)。

安全

若要为数据层安装准备群集，您必须是“Cluster Administrator”（群集管理员）组的成员。

请参见

任务

如何：加速群集中的服务器恢复

参考

检查表：Team Foundation Server 群集部署

概念

提供持续的服务器可用性


如何：加速群集中的服务器恢复

如何：加速群集中的服务器恢复
请参见 示例

作为“Team Foundation 管理员”，您可以使用脚本文件显式重新启动群集中的数据层和应用层之间的服务。虽然 SQL Server 2005 最终会重新启动这些服务，但是您还是可以通过为数据层群集添加资源提供更及时的恢复。若要添加资源，必须提供一个重新启动服务和控制脚本运行时间的脚本文件，并将资源指向该脚本文件。

下面的过程假定您有一个正在群集中运行的数据层服务器，并且有一个正在工作的应用层服务器。

向数据层群集添加资源

  1. 登录到群集的主动节点。

    Note 注意

    被动节点仅接受已建立的到主动节点的连接。如果尝试登录到被动节点，就会出现一个错误消息。

  2. 在文本编辑器中，创建一个实现 Windows Management Instrumentation (WMI) 的脚本文件，以查询应用程序池进程并重置每个进程。

    Note 注意

    在 Visual Studio 中，可以通过使用 VBScript 或 JScript Web 模板并添加本主题所含示例中的脚本来快速创建脚本文件。您必须将应用层服务器名称的占位符替换为适合您的系统的服务器名称。

  3. 将文件保存到合适的驱动器和目录中。

  4. 依次单击“开始”、“程序”、“管理工具”和“群集管理器”。

  5. 右击“资源”节点，单击“新建”，然后单击“资源”。

  6. 在“新建资源”向导中，为资源键入一个名称，然后为“资源类型”单击“通用脚本”。

    例如，您可以提供以下信息。

    • 名称: TFS IIS 重置

    • 说明: 指向重置到应用层的 IIS 连接的 TFS_IIS_RESET.vbs。

    • 资源类型: 通用脚本

    • 组: 群集组

  7. 在“可能的所有者”页上，验证群集中的两台计算机是否在“可能的所有者”列表中。

  8. 在“相关性”页上，为“可用资源”框中的每项资源选择并单击“添加”，以便将资源移动到“相关性”框中。

    通过将所有资源添加为相关资源，可确保新资源成为联机的最后一项资源。

  9. 在“一般脚本参数”页上，键入脚本文件的路径和名称，然后单击“完成”。

    Note 注意

    如果文件路径太长，可在 Windows 资源管理器中找到该文件并查看该文件的属性。在“常规”选项卡上，可以从“位置”中选择并复制路径，然后将该文本粘贴到向导中。必须键入文件名。

  10. 在“群集管理器”中，右击所添加的脚本的资源，然后单击“联机”。

示例

在 Visual Studio 中，可以使用“新建文件”对话框中提供的 VBScript Web 模板创建脚本文件。下面的示例实现了 Cluster API 的例程，以便通过使用 WMI 控制操作系统，Online 函数查询 IIS 应用程序池并启动池中的每个进程。Offline 函数查询 IIS 应用程序池并停止每个进程。Cluster API 的 LooksAlive 和 IsAlive 函数设置资源监视器使用的状态信息。

Note 注意

应确保将代表应用层服务器名称的占位符 TFS AT Name 替换为您系统中的应用层服务器名称。
CopyCode image 复制代码
Sub Open( )
End Sub

Function Close( )
End Function

Function Online( )
strComputer = "TFS AT Name"

Set objWMIService = GetObject _
    ("winmgmts:{authenticationLevel=pktPrivacy}\\" _
        & strComputer & "\root\microsoftiisv2")

Set colItems = objWMIService.ExecQuery _
    ("Select * From IIsApplicationPool")

For Each objItem in colItems
    objItem.Start
Next
End Function

Function Offline( )
strComputer = "TFS AT Name"

Set objWMIService = GetObject _
    ("winmgmts:{authenticationLevel=pktPrivacy}\\" _
        & strComputer & "\root\microsoftiisv2")

Set colItems = objWMIService.ExecQuery _
    ("Select * From IIsApplicationPool")

For Each objItem in colItems
    objItem.Stop
Next
End Function

Function Terminate( )
    Call Offline
End Function

Function LooksAlive ( )
    LooksAlive = True

End Function

Function IsAlive( )
   IsAlive= True
End Function

安全

若要执行此过程，您必须是“Cluster Administrator”（群集管理员）安全组的成员。

请参见

概念

Team Foundation Server 安装所需的用户帐户


检查表：备用应用层配置

检查表：备用应用层配置
请参见
CollapseAll 图像 DropDown 图像

此检查表列出了在备用计算机上配置应用层的常规步骤。此列表假定您设置了以下物理结构。

  • 运行 SQL Server 和 Team Foundation Server 数据库组件的服务器。

  • 安装并运行 Windows SharePoint、SQL Reporting Services 和 Team Foundation Server 服务组件的服务器。

  • 满足应用层软件和硬件要求的服务器。

应打印此检查表并在完成每个步骤时进行标记。

Expand 图像 准备

在安装和配置备用计算机之前，需要准备以下项。

完成 步骤

下载此指南的最新版本，可从 Microsoft 下载中心 (http://go.microsoft.com/fwlink/?LinkId=40042) 进行下载。

确认备用计算机满足应用层的硬件和软件要求。有关更多信息，请参见 Team Foundation 系统要求中的“应用层”一节。

在备用计算机上，添加以下服务帐户。域和主应用层计算机中应该已经存在这些帐户。在备用计算机上使用的服务帐户必须与在主计算机上使用的帐户相同。

  • 用于运行安装程序的用户帐户（例如 Domain\TFSSETUP）。

  • 用于运行 Team Foundation 服务的服务帐户（例如 Domain\TFSSERVICE）。

  • 用于访问 SQL Server Reporting Services 数据源的服务帐户（例如 Domain\TFSREPORTS）。

有关更多信息，请参见 Team Foundation Server 安装所需的用户帐户。

Expand 图像 安装

完成 步骤

在备用计算机上，安装 Internet 信息服务 (IIS) 6.0 并启用 ASP.NET。

Caution note 警告

不要安装 FrontPage 服务器扩展。

有关更多信息，请参见如何：安装用于 Team Foundation Server (services) 的 Internet 信息服务。

在备用计算机上，安装用于 Team Foundation Server 的 SQL Server 2005 Reporting Services（使用 Microsoft SQL Server 2005 标准版或企业版）。

在备用计算机上，安装 Microsoft .NET Framework 2.0 的修补程序 KB913393，相应的安装程序可从 Team Foundation Server 安装媒体中获得。

在安装媒体中，找到文件夹 KB913393，再找到与您的平台 (X86) 对应的可执行文件 (.exe)，然后双击该文件进行安装。

在备用计算机上，安装用于 Team Foundation Server 的带 Service Pack 2 的 Windows SharePoint Services 并重新启动备用计算机。

Caution note 警告

不要配置 Windows SharePoint Services 的任何设置。Team Foundation Server (services) 安装会为您完成这些服务的配置。

有关更多信息，请参见如何：安装用于 Team Foundation Server（双服务器部署）的 Microsoft Windows SharePoint Services。

在备用计算机上安装 Team Foundation Server (services)。有关更多信息，请参见如何：安装 Team Foundation Server (services)。

Note 注意

如果出现有关您所提供的数据层服务器正被使用的警告，请输入 Y 继续。

确认打开了适当的端口。

在数据层计算机上，如果使用的是 Windows 防火墙或第三方防火墙软件或硬件解决方案，则应确保已打开所需的端口以允许组件之间进行通信。有关更多信息，请参见 Team Foundation Server 安装所需的端口。

安装 Team Explorer。有关更多信息，请参见团队资源管理器安装概述。

在备用计算机上更新用户帐户和组以与主计算机匹配。例如，确保主计算机上团队项目创建者的组成员资格和角色在备用计算机上有相应的成员资格和角色。有关更多信息，请参见如何：向 Team Foundation Administrators 应用程序组添加用户。

Expand 图像 配置

完成 步骤

选择一种将 DNS 主机添加到域中的方法。无论哪个应用层处于活动状态，都必须选择一种方法来指定用于绑定到客户端和数据层的单个主机名。

  • 如果 Team Foundation Server 管理员具有域管理权限，则使用 DNS 主机更新。

  • 如果 Team Foundation Server 管理员不具有域管理权限，则使用专用 IP (DIP) 地址。对于此选项，请获取主计算机和备用计算机的静态 IP 地址，并在域中指定 IP 地址与主计算机相同的虚拟服务器名称。

有关指定主机名的更多信息，请参见如何：将应用层配置为备用中“配置网络适配器”一节的说明。

如果应用层服务器运行的是 SQL Server 企业版，则使用“Reporting Services 配置工具”配置 Reporting Services 来扩展部署。

如果应用层服务器运行的是 SQL Server 标准版，则使用“Reporting Services 配置工具”备份 Reporting Services 加密密钥。

将 Team Foundation Server 应用层的服务器名称设置为虚拟服务器名称。这一步骤会将该名称从计算机名称更改为可通过所使用的网络适配器方法指向的任一计算机的名称。

将 Team Explorer 连接到虚拟服务器名称。

Expand image 请参见

任务

如何：将应用层配置为备用

概念

提供持续的服务器可用性

其他资源

Team Foundation Server 双服务器部署概述


如何：将应用层配置为备用

如何：将应用层配置为备用
请参见

在第一次设置 Team Foundation Server 时，可以为应用层设置备用计算机，也可以在以后设置。必须设置虚拟服务器名称，此虚拟服务器名称应可以配置为指向任一应用层计算机，以便计算机之间的切换对于客户端计算机和数据层服务器是透明的。

此过程假定您已完成如检查表：备用应用层配置中所述的各项准备和安装步骤。这些过程提供了有关完成检查列表中提供的配置步骤的详细信息。

  • 配置网络适配器以提供一个虚拟服务器名称。

  • 配置备用的 SQL Server 2005。

  • 配置 Team Foundation Server 以使用该虚拟服务器名称。

  • 将 Team Explorer 连接到该虚拟服务器名称。

配置 DNS 主机

若要提供一个无论在哪个应用层服务器处于活动状态的情况下都能让客户端和数据层用来通信的单个名称，必须指定域上的主机名称。若要将应用层服务从主服务器切换到备用服务器，必须使用该名称激活备用服务器并将其绑定到数据层。

下列过程说明用于指定域上的主机名称的两个选项。两个选项都需要 DNS 管理员特权，这是因为您必须为虚拟应用程序服务器创建 DNS 主机记录。如果您所在的组织未将“域管理”权限提供给 Team Foundation Server 管理员，则必须使用专用的 IP 地址，这样才可以为主机名称更新 IP 地址。

如果组织向 Team Foundation Server 管理员授予了域管理员权限，则建议使用 DNS 主机更新方法。

DNS 主机更新 创建一条 DNS 主机 (A) 记录，其中包含主 Team Foundation Server 应用层服务器的 IP 地址。在任一 Team Foundation Server 应用层服务器上都不需要特殊的网络配置，因为 DNS 可将对虚拟 Team Foundation Server 应用层服务器的请求解析为对主应用层服务器的 IP 地址的请求。在故障转移期间，域管理员必须更新 DNS 主机项以将通信重定向到新的主 Team Foundation Server 应用层服务器。

专用 IP (DIP) 地址 在此配置中，需要三个静态 IP 地址。DNS 主机记录由域管理员创建，用于将虚拟 Team Foundation Server 应用层服务器名称映射到专用 IP 地址之一。在主 Team Foundation Server 应用层服务器上的网络连接对应的 TCP/IP 属性中手动设置静态 IP 地址和未使用的 IP 地址之一。使用剩余的静态 IP 地址配置备用 Team Foundation Server 应用层服务器。在故障转移期间，Team Foundation Server 管理员将更改新的主 Team Foundation Server 应用层服务器上的网络设置，以使其响应对用于虚拟 Team Foundation Server 应用层服务器的静态 IP 地址的请求。

若要实现备用计算机，域服务器必须具有三个服务器的资源记录。

  • 主服务器 主应用层服务器的计算机名称，该服务器使用静态 IP 地址。例如，可以将主服务器命名为 TFS_AT_01。

  • 备用服务器 备用应用层服务器的计算机名称，该服务器使用静态 IP 地址。例如，可以将备用服务器命名为 TFS_AT_02。

  • 虚拟服务器 带有与主计算机的 IP 地址相同的静态 IP 地址的应用层虚拟服务器的名称。例如，可以使用名称 TFS_AT 作为虚拟服务器名称。

    失败后，必须手动更新虚拟服务器名称的 IP 地址以匹配备用计算机。

    下列过程假定已设置好并且正在运行数据层服务器和应用层服务器。

    Note 注意

    获取静态 IP 地址和指定虚拟服务器名称的步骤取决于您的组织管理域的方式，这不在本文档的讨论范围之内。有关更多信息，请向域管理员咨询。

指定域上的主机名称

  1. 在“开始”菜单上单击“运行”，键入 dnsmgmt.msc，然后单击“确定”。

  2. 在 DNS 管理器中，单击“正向循环区域”，右击域名称，然后单击“新建主机 (A)”。

  3. 在“新建主机”对话框中，键入要用于虚拟服务器的名称，例如 TFS_AT。

  4. 检查并记下主计算机和备用计算机的静态 IP 地址。

  5. 选择“创建相关的指针(PTR)记录”，根据选用的方法键入 IP 地址，然后单击“添加主机”。

    • DNS 主机更新 输入主计算机的 IP 地址。

    • 专用 IP (DIP) 地址 输入三个静态 IP 地址中的一个作为应用层虚拟服务器的地址。必须在网络连接中配置 IP 地址。

  6. 验证主计算机和虚拟服务器是否正在使用预期的静态 IP 地址，以及地址是否相同。

在网络连接中配置专用 IP 地址

  1. 在主计算机上，打开命令提示符窗口并键入 ipconfig /all。

    Note 注意

    如果正在使用 DNS 主机更新，则不必完成此过程。

    网络配置设置将出现。

  2. 从“开始”菜单上单击“控制面板”，然后单击“网络连接”。

  3. 定位到域对应的网络连接，右击“Internet 属性(TCP/IP)”，然后单击“属性”。

  4. 单击“使用下面的 IP 地址”，键入主计算机的静态 IP 地址，然后使用命令提示符窗口中显示的信息键入 IP 地址的子网掩码。

  5. 在命令提示符窗口中找到默认网关的名称。

  6. 在“网络连接”对话框中，单击“使用下面的 DNS 服务器地址”，键入作为首选 DNS 服务器列出的第一个 DNS 服务器地址，然后单击“高级”。

  7. 在“高级 TCP/IP 设置”对话框中，选择“DNS”选项卡，单击“添加”，然后指定在网络配置设置中列出的其他 DNS 服务器。

  8. 选择“WINS”选项卡，单击“添加”，然后指定在网络配置设置中列出的主 WINS 服务器和辅助 WINS 服务器。

  9. 选择“IP 设置”选项卡，单击“添加”，然后指定虚拟服务器（如 AT_TFS）的静态 IP 地址。

  10. 在备用计算机上重复前面的步骤。

配置 SQL Server 2005 以作备用

必须根据您的 Microsoft SQL Server 2005 的版本完成下列步骤之一。

  • 如果使用的是 SQL Server Standard Edition，则需要 Reporting Services 加密密钥文件和用于保护内容的密码来启动备用 Team Foundation Server 应用层服务器上的 Reporting Services。

  • 如果使用的是 SQL Server Reporting Services Enterprise Edition，则必须配置扩展部署。在这种情况下，备用 Team Foundation Server 应用层服务器上的 Reporting Services 实例必须连接到扩展部署（请参见“如何：配置 Report Server 扩展部署”http://msdn2.microsoft.com/en-us/library/ms159114.aspx）。

配置 SQL Server 2005 Standard Edition

  1. 在主 Team Foundation Server 应用层计算机上打开命令提示符窗口。

  2. 通过键入 cd %Program Files%\Microsoft SQL Server\90\Tools\binn 定位到 binn 目录。

  3. 运行 rsconfigtool.exe。

  4. 在“Reporting Services 配置”工具中，单击左导航窗格中的“加密密钥”，然后单击“备份”。

  5. 输入一个强密码以帮助保护加密密钥文件的内容。

  6. 如果主服务器失败，则将文件保存到一个可用的位置。

配置 SQL Server Reporting Services Enterprise Edition

  1. 在备用计算机上打开“报表服务器配置工具”。

  2. 单击“确定”以连接到备用服务器上的报表服务器实例

  3. 在左窗格中单击“初始化”，并验证是否已创建第二个报表服务器实例对应的项。“已初始化”复选框应未选中。

  4. 重新连接到主服务器上的报表服务器实例。已为可逆加密操作初始化主报表服务器。因此，将使用主报表服务器为扩展部署初始化备用服务器上的新报表服务器实例。

  5. 在“初始化”页上选择连接到扩展部署的报表服务器实例，然后单击“初始化”。应为属于同一扩展部署的所有报表服务器实例选中“已初始化”复选框，然后单击“应用”。（可能需要单击“刷新”。）

  6. 在 Internet Explorer 中，定位到 http://TFSAT02/reports，然后验证备用服务器是否在扩展部署中。

配置 Team Foundation Server 以使用虚拟服务器名称

配置主计算机以使用虚拟服务器名称

  • 在主计算机上，使用 TfsAdminUtil 命令行实用工具的 ActivateAT 命令激活虚拟服务器名称。

    例如，下列命令将 TFS_AT 激活为应用层服务器，该服务器使用与主服务器相同的 IP 地址。

    TfsAdminUtil ActivateAT TFS_AT

配置备用计算机以使用虚拟服务器名称

  • 在备用计算机上，使用 TfsAdminUtil 命令行实用工具的 ActivateAT 命令激活虚拟服务器名称。例如，下列命令将 TFS_AT 激活为应用层服务器，该服务器使用与主服务器相同的 IP 地址。

    TfsAdminUtil ActivateAT TFS_AT

将团队资源管理器连接到虚拟服务器

将团队资源管理器连接到虚拟服务器

  1. 打开 Team Explorer，单击“工具”，然后单击“连接到 Team Foundation Server”。

  2. 通过如下方法将服务器名称添加到列表中：单击“添加”，指定虚拟服务器名称，然后单击“关闭”。

  3. 在“连接到”对话框中，从列表中选择虚拟服务器名称，然后单击“连接”。

安全

若要将应用层配置为备用，则您必须为“Team Foundation 管理员”安全组的成员和“Cluster Administrator”安全组的成员。

请参见

任务

如何：安装 Team Foundation Server (services)

参考

检查表：备用应用层配置

概念

提供持续的服务器可用性


Team Foundation Build 安装概述

Team Foundation Build 安装概述
请参见
DropDown image

Team Foundation Server 提供了生成自动化功能，可帮助您使用 Team Foundation Build 来生成和共享 Visual Studio 2005 解决方案。可将 Team Foundation Build 与 Team Foundation 应用层安装在相同或不同的计算机上。

本节内容

如何：安装 Team Foundation Build

使用此过程安装 Team Foundation Build。

相关章节

Team Foundation 系统要求

提供安装此版本的 Team Foundation Server 时对硬件和软件的系统要求。

Team Foundation Server 安全安装概述

提供安装 Team Foundation Server 时与安全相关的信息。

Team Foundation Server 单服务器部署概述

使用本节中的过程在一台服务器上安装和配置 Team Foundation Server。

Team Foundation Server 双服务器部署概述

借助本节中的过程，使用两台计算机来安装和配置 Team Foundation Server，一台计算机用于数据层组件，另一台用于应用层组件。

安装 Team Foundation Server Proxy 概述

使用本节中的过程来安装 Team Foundation Server Proxy，后者缓存以前访问过的源代码管理文件。

团队资源管理器安装概述

使用本节中的过程来安装和配置 Team Explorer。

请参见

概念

Team Foundation 安装


如何：安装 Team Foundation Build

如何：安装 Team Foundation Build
请参见

使用此过程安装 Team Foundation Build。

如何安装 Team Foundation Build

  1. 在 Team Foundation Server 安装媒体中，浏览找到 \build 文件夹并运行 setup.exe。

    此时将启动“Visual Studio 2005 Team Foundation Build Server 安装向导”。

  2. 在“欢迎使用安装程序”页上单击“下一步”。

  3. 在“许可条款和产品密钥”页上查看许可协议。如果您接受其中的条款和条件，请选择“我接受许可协议中的条款”，然后单击“下一步”。

  4. 在“目标文件夹”页上，接受默认的目标文件夹并单击“下一步”。

  5. 在“系统运行状况检查”页上，安装程序向导扫描系统中可能导致安装程序失败或以后在服务器操作期间导致问题的条件。完成系统扫描后，安装程序报告系统运行状况检查的状态。如果系统运行状况检查发现任何问题，您可以单击链接来查看有关特定警告和阻止的报告。应在继续安装之前解除警告，但不应阻止安装程序完成。在继续安装之前，必须解决阻止。如果系统运行状况检查未发现任何阻止，则请单击“下一步”。否则，请单击“取消”并在解决了所有阻止问题后再次运行安装程序。

  6. 在“服务帐户”页上，在“帐户名”框中键入您为 Team Foundation Server 服务帐户创建的 Windows 域用户帐户（例如 Domain\TFSSERVICE），并在“密码”框中键入密码，然后单击“下一步”。有关更多信息，请参见 Team Foundation Server 安装所需的用户帐户。

    Note 注意

    对于此版本，必须使用与 Team Foundation Server 服务帐户相同的 Windows 域用户帐户。

  7. 在“安装准备就绪”页上单击“安装”。

    Note 注意

    安装程序将在 Windows 防火墙中为 MSBuild.exe 和 TeamBuildService.exe 创建程序异常，以允许与 Team Foundation Server 通信。

  8. 在“正在安装组件”页上，可以监视 Team Build 的安装。

  9. 在“成功完成安装”页上单击“完成”。

    Note 注意

    如果要生成的项目需要附加项，如组件、程序或动态链接库 (.dll)，则必须将这些项手动添加到生成计算机中。

安全

若要执行此过程，您必须是计算机上“Administrators”安全组的成员。有关更多信息，请参见 Team Foundation Server 安装所需的用户帐户。

请参见

概念

Team Foundation 物理结构
Team Foundation 系统要求

其他资源

Team Foundation Build 安装概述


安装 Team Foundation Server Proxy 概述

安装 Team Foundation Server Proxy 概述
请参见
DropDown image

使用本节中的过程来安装 Team Foundation Server Proxy，后者缓存以前访问过的源代码管理文件。可将 Team Foundation Server Proxy 与 Team Foundation 应用层安装在相同或不同的计算机上。

本节内容

如何：安装用于 Team Foundation Server Proxy 的 Internet 信息服务

描述如何为 Team Foundation Server Proxy 安装 Internet 信息服务 (IIS) 6.0。

如何：安装 Team Foundation Server Proxy

描述如何安装 Team Foundation Server Proxy，该组件可通过缓存以前访问过的文件来改进源代码管理操作。

如何：配置团队资源管理器以使用 Team Foundation Server Proxy

描述如何配置 Team Explorer 以使用 Team Foundation Server Proxy。

相关章节

Team Foundation 系统要求

提供安装此版本的 Team Foundation Server 时对硬件和软件的系统要求。

Team Foundation Server 安全安装概述

提供安装 Team Foundation Server 时与安全相关的信息。

Team Foundation Server 单服务器部署概述

使用本节中的过程在一台服务器上安装和配置 Team Foundation Server。

Team Foundation Server 双服务器部署概述

借助本节中的过程，使用两台计算机来安装和配置 Team Foundation Server，一台计算机用于数据层组件，另一台用于应用层组件。

Team Foundation Build 安装概述

使用本节中的过程来安装和配置 Team Foundation Build，后者提供了生成自动化功能，可帮助您生成和共享 Visual Studio 2005 解决方案。

团队资源管理器安装概述

使用本节中的过程来安装和配置 Team Explorer。

请参见

概念

Team Foundation 安装


如何：安装用于 Team Foundation Server Proxy 的 Internet 信息服务

如何：安装用于 Team Foundation Server Proxy 的 Internet 信息服务
请参见

使用此过程为 Team Foundation Server Proxy 安装 Internet 信息服务 (IIS) 6.0。

可以在“添加或删除程序”中查看以前是否安装了 IIS，并确认是否启用了 ASP.NET。如果没有，请遵循下面的过程安装 IIS 和启用 ASP.NET。

使用“添加/删除程序”实用工具来启用 ASP.NET

  1. 从“控制面板”中打开“添加/删除程序”。

  2. 单击“添加/删除 Windows 组件”。

    此时将启动“Windows 组件向导”。

  3. 在“Windows 组件”页上选择“应用程序服务器”，然后单击“详细信息”。

  4. 如果尚未选中，请选择“ASP.NET”，然后单击“确定”。

  5. 在“Windows 组件”页上单击“下一步”。

    Note 注意

    可能会提示您插入 Windows Server 2003 安装媒体。

  6. 单击“完成”关闭向导。

  7. 访问 Windows Update (http://windowsupdate.microsoft.com) 并安装“重要更新和 Service Pack”组中的所有项。

将服务器配置为应用程序服务器

  1. 通过执行以下任一操作来启动“配置您的服务器向导”：

    • 默认情况下，“管理您的服务器”会在 Windows 启动时自动启动。从“管理您的服务器”中，单击“添加或删除角色”。

    • 从“控制面板”中打开“管理工具”，然后打开“配置您的服务器向导”。

  2. 在“欢迎使用‘配置您的服务器向导’”页上单击“下一步”。

  3. 在“预备步骤”页上单击“下一步”。

  4. 在“服务器角色”页上选择“应用程序服务器(IIS，ASP.NET)”，然后单击“下一步”。

  5. 在“应用程序服务器选项”页上选择“启用 ASP.NET”，然后单击“下一步”。

  6. 在“选择总结”页上单击“下一步”。

    Note 注意

    可能会提示您插入 Windows Server 2003 安装媒体。

  7. 单击“完成”来完成该向导。

  8. 访问 Windows Update (http://windowsupdate.microsoft.com) 并安装“重要更新和 Service Pack”组中的所有项。

安全

若要执行这些过程，您必须是计算机“Administrators”安全组的成员。在本指南中，用于安装的用户帐户为 Domain\TFSSETUP。有关更多信息，请参见 Team Foundation Server 安装所需的用户帐户。

请参见

任务

如何：安装 Team Foundation Server Proxy

其他资源

安装 Team Foundation Server Proxy 概述


如何：安装 Team Foundation Server Proxy

如何：安装 Team Foundation Server Proxy
请参见

描述如何安装 Team Foundation Server 代理。该代理通过缓存以前访问过的文件来改进源代码管理下载操作。通常，您会在分布式团队的远程位置的计算机上安装 Team Foundation Server 代理。

安装 Team Foundation Server Proxy

  1. 安装并完成 Team Foundation Server 代理计算机的必备组件：

    1. 安装带 Service Pack 1 (SP1) 的 Windows Server 2003 企业版或标准版。

    2. 标识用于运行安装程序的用户帐户，并将该帐户添加到本地 Administrators 组。

      通常，这是您的用户帐户。在本指南中，该帐户引用为 Domain\TFSSETUP，因为具体名称取决于您的组织。有关此帐户要求的更多信息，请参见 Team Foundation Server 安装所需的用户帐户。

    3. 如果安装 Team Foundation Server 代理的计算机与 Team Foundation Server 所在的计算机不在同一个域或工作组上，请获取域或工作组服务帐户，并将该帐户添加到代理所服务的所有 Team Foundation Server 应用层服务器上的 Team Foundation Server Valid Users 组中。

    4. 安装 Internet 信息服务 6.0 并启用 ASP.NET。有关更多信息，请参见如何：安装用于 Team Foundation Server Proxy 的 Internet 信息服务。

    5. 如果安装 Team Foundation Server 代理的计算机不是 Team Foundation Server 所在的计算机，请验证是否安装了 Microsoft .NET Framework 2.0。

      若要验证，请依次单击“开始”、“控制面板”、“添加/删除程序”，然后检查“当前安装的程序”列表。

      Note 注意

      若要安装 Microsoft .NET Framework 2.0，请找到安装媒体上的文件夹 proxy\wcu\dotNetFramework 并运行 dotnetFX。

    6. 安装 Microsoft .NET Framework 2.0 修补程序 KB913393，该修补程序位于安装媒体上。

      在安装媒体上找到修补程序（例如 K913393）的文件夹，再找到与您的操作系统对应的可执行文件 (.exe)，然后双击该文件安装修补程序。

    7. 如果 Team Foundation Server 通过代理服务器连接到网络，请验证是否为局域网 (LAN) 设置选择了“对于本地地址不使用代理服务器”。

      若要验证设置，请依次单击“开始”、“控制面板”“Internet 选项”。在“连接”选项卡中，单击“局域网设置”。在“局域网 (LAN) 设置”对话框中，选中“对于本地地址不使用代理服务器”。用于自动检测的两个选项现在应未选中。

      如果不选择此设置，Team Foundation Server 代理安装程序将无法与 Windows SharePoint Services 一起来完成身份验证，并且访问被拒绝。

  2. 在代理服务器上，使用 Team Foundation Server 安装程序帐户（例如，Domain\TFSSETUP）登录到 Windows。在 Team Foundation Server 安装媒体上，找到 \proxy 文件夹并运行 setup。

    Visual Studio 2005 Team Foundation Server Proxy 安装程序向导随即启动。

  3. 在“欢迎使用安装程序”页上单击“下一步”。

  4. 在“许可条款和产品密钥”页上查看许可协议。如果您接受其中的条款和条件，请选择“我接受许可协议中的条款”，然后单击“下一步”。

  5. 在“系统状况检查”页上，单击“报告”链接检查是否有任何警告或阻止。

    • 必须先解决阻止问题，然后才能继续安装。单击“取消”并在解决了问题后再次运行安装程序。

    • 应在继续安装之前解除警告，但不应阻止安装程序完成。可以单击“下一步”。

    • 如果没有列出任何内容，则单击“下一步”。

  6. 在“目标文件夹”页上，接受默认的目标文件夹并单击“下一步”。

  7. 在“缓存文件夹”页上，接受默认的路径和文件夹并单击“下一步”。

    Note 注意

    指定的文件夹应有足够的空间可用于将在此缓存的文件。

  8. 在“服务帐户”页上，在“帐户名”框中键入您为 Team Foundation Server 服务帐户创建的 Windows 域用户帐户（例如 Domain\TFSSERVICE），并在“密码”框中键入密码，然后单击“下一步”。有关更多信息，请参见 Team Foundation Server 安装所需的用户帐户。

  9. 在“安装准备就绪”页上单击“安装”。

  10. 在“正在安装组件”页上，可以监视 Team Foundation Server 代理的安装。

  11. 在“成功完成安装”页上单击“完成”，Internet Explorer 将出现。

  12. 在“配置 Team Foundation 版本控制代理”页上，按照指示配置代理。

    Note 注意

    必须先配置 Team Foundation Server Proxy 才能使用它。如果此页不显示，请在安装媒体上找到并打开 ProxyConfig.htm。

安全

若要执行此过程，您必须是计算机上“Administrators”安全组的成员。在本指南中，用于安装的用户帐户为 Domain\TFSSETUP。有关更多信息，请参见 Team Foundation Server 安装所需的用户帐户。

请参见

其他资源

安装 Team Foundation Server Proxy 概述


如何：配置团队资源管理器以使用 Team Foundation Server Proxy

如何：配置团队资源管理器以使用 Team Foundation Server Proxy
请参见

描述如何配置 Team Explorer 以使用 Team Foundation Server Proxy。

配置团队资源管理器以使用 Team Foundation Server Proxy

  1. 启动 Microsoft Visual Studio 2005。

  2. 在“工具”菜单中单击“选项”。

  3. 展开“源代码管理”，然后单击“Visual Studio Team Foundation”。

  4. 选择“使用代理服务器”。

  5. 在“Team Foundation Server 名称”框中，键入承载 Team Foundation Server Proxy 的计算机的名称。

  6. 在“端口”框中，键入 8081。

  7. 在“协议”中，选择“Http”。

  8. 单击“确定”。

安全

若要执行此过程，您必须是计算机上“Users”安全组的成员。

请参见

其他资源

安装 Team Foundation Server Proxy 概述


团队资源管理器安装概述

团队资源管理器安装概述
请参见
DropDown image

使用本节中的过程来安装和配置 Team Explorer。可将 Team Explorer 与 Team Foundation 应用层安装在相同或不同的计算机上。

本节内容

如何：安装团队资源管理器的系统必备

描述如何安装 Team Explorer 必备组件。

如何：安装团队资源管理器

描述如何安装 Team Explorer。

如何：将团队资源管理器连接到 Team Foundation Server

描述如何从 Team Explorer 连接到 Team Foundation Server。

相关章节

Team Foundation 系统要求

提供安装此版本的 Team Foundation Server 时对硬件和软件的系统要求。

Team Foundation Server 安全安装概述

提供安装 Team Foundation Server 时与安全相关的信息。

Team Foundation Server 单服务器部署概述

使用本节中的过程在一台服务器上安装和配置 Team Foundation Server。

Team Foundation Server 双服务器部署概述

借助本节中的过程，使用两台计算机来安装和配置 Team Foundation Server，一台计算机用于数据层组件，另一台用于应用层组件。

Team Foundation Build 安装概述

使用本节中的过程来安装和配置 Team Foundation Build，后者提供了生成自动化功能，可帮助您生成和共享 Visual Studio 2005 解决方案。

安装 Team Foundation Server Proxy 概述

使用本节中的过程来安装 Team Foundation Server Proxy，后者缓存以前访问过的源代码管理文件。

请参见

概念

Team Foundation 安装


如何：安装团队资源管理器的系统必备

如何：安装团队资源管理器的系统必备
请参见

使用此过程安装 Team Explorer 必备组件。

安装客户端层的必备组件

  1. 安装满足 Visual Studio 2005 自述文件中所指定的 Visual Studio 2005 系统要求的操作系统。

    Note 注意

    如果将 Team Foundation 客户端层与 Team Foundation 应用层安装在同一台计算机上，请在安装客户端层组件之前先完成应用层的安装。

  2. 访问 Windows Update (http://windowsupdate.microsoft.com) 并安装“重要更新和 Service Pack”组中的所有项。

  3. 安装 Microsoft Office Excel 2003。在安装向导的“安装类型”页上，选择“完全安装”。

    Note 注意

    如果选择自定义安装功能，则必须安装 .NET 可编程性支持才能使用 Visual Studio Team System 集成功能。

  4. 安装 Microsoft Office Project Professional 2003。在安装向导的“安装类型”页上，选择“完全安装”。

    Note 注意

    如果选择自定义安装功能，则必须安装 .NET 可编程性支持才能使用 Visual Studio Team System 集成功能。

  5. 访问 Windows Update (http://windowsupdate.microsoft.com) 并安装“重要更新和 Service Pack”组中的所有项。

  6. 访问 Office Update (http://office.microsoft.com/officeupdate) 并安装所有可用的更新。

Internet Explorer 增强的安全配置

如果在 Windows Server 2003 上安装 Team Explorer，则需要应用 Windows 2000 默认的 Internet Explorer 安全设置，以便为客户端启用 Team Foundation 功能。若要在 Windows Server 2003 上应用 Windows 2000 默认的 Internet Explorer 安全设置，必须禁用 Internet Explorer 增强的安全配置。

Note 要点

应用 Windows 2000 默认的 Internet Explorer 安全设置会使服务器更易于受到来自基于 Web 的恶意内容的攻击。

应用 Windows 2000 默认的 Internet Explorer 安全设置

  1. 打开“控制面板”，单击“添加/删除程序”，再单击“添加/删除 Windows 组件”。

  2. 清除“Internet Explorer 增强的安全配置”复选框，然后单击“下一步”。

  3. 单击“完成”。

  4. 重新启动 Internet Explorer 以应用更改。

安全

若要执行这些过程，您必须是计算机“Administrators”安全组的成员。

请参见

其他资源

团队资源管理器安装概述


如何：安装团队资源管理器

如何：安装团队资源管理器
请参见

使用此过程来安装 Team Explorer。

安装团队资源管理器

  1. 完成安装 Team Explorer 所需的必备组件。有关更多信息，请参见如何：安装团队资源管理器的系统必备。

  2. 在 Team Foundation Server 安装向导的自动运行页上，单击“安装团队资源管理器”。

    如果未出现自动运行页，请在安装媒体的 \tfc 文件夹中找到并运行自动运行文件 (autorun.exe)。

    此时将启动“Visual Studio 2005 团队资源管理器安装向导”。

  3. 在“欢迎使用安装程序”页上单击“下一步”。

  4. 在“许可协议和产品密钥”页上查看许可协议。如果您接受其中的条款和条件，请选择“我接受许可协议中的条款”，然后单击“下一步”。

  5. 在“目标文件夹”页上单击“下一步”。

  6. 在“安装准备就绪”页上单击“安装”。

  7. 在“成功完成安装”页上单击“完成”。

Note 要点

?? 如果以前安装了 Visual Studio 2005 的 MSDN Library，您应该运行最新版本的 MSDN Library 安装程序以便确保拥有 Team Foundation 的最新产品文档。有关更多信息，请参见 Team System 文档目录 (http://go.microsoft.com/fwlink/?LinkId=62213)。

安全

若要执行此过程，您必须是计算机上“Administrators”安全组的成员。

请参见

其他资源

团队资源管理器安装概述


如何：将团队资源管理器连接到 Team Foundation Server

如何：将团队资源管理器连接到 Team Foundation Server
请参见

使用此过程从 Team Explorer 中添加并连接到 Team Foundation Server，或从 Team Explorer 中移除 Team Foundation Server。

添加 Team Foundation Server

  1. 启动 Microsoft Visual Studio 2005。

  2. 在“工具”菜单上单击“连接到 Team Foundation Server”。

    此时将出现“连接到 Team Foundation Server”对话框。

  3. 单击“服务器”。

    此时将出现“添加/移除 Team Foundation Server”对话框。

  4. 单击“添加”。

    此时将出现“添加 Team Foundation Server”对话框。

  5. 在“Team Foundation Server 名称”框中，键入承载 Team Foundation Server 应用层的计算机的名称。

  6. 在“端口号”框中，指定用于此连接的端口（用于 HTTP 的默认端口是 8080）并选择相应的协议。

  7. 单击“确定”返回到“添加/移除 Team Foundation Server”对话框。

  8. 单击“关闭”返回到“连接到 Team Foundation Server”对话框。

  9. 如果此 Team Foundation Server 上存在任何团队项目，则请选择要使用的项目。

  10. 单击“确定”。

连接到 Team Foundation Server

  1. 启动 Microsoft Visual Studio 2005。

  2. 在“工具”菜单上单击“连接到 Team Foundation Server”。

    此时将出现“连接到 Team Foundation Server”对话框。

  3. 在“连接到 Team Foundation Server”列表中，选择要使用的 Team Foundation Server。

  4. 如果此 Team Foundation Server 上存在任何团队项目，则请选择要使用的项目。

  5. 单击“确定”。

移除 Team Foundation Server

  1. 启动 Microsoft Visual Studio 2005。

    Note 注意

    如果您目前连接到想要移除的服务器上，则需要通过右击服务器名称并单击“断开连接”断开连接。

  2. 在“工具”菜单上单击“连接到 Team Foundation Server”。

    此时将出现“连接到 Team Foundation Server”对话框。

  3. 单击“服务器”。

    此时将出现“添加/移除 Team Foundation Server”对话框。

  4. 在“Team Foundation Server 列表”中选择要移除的 Team Foundation Server，然后单击“移除”。

  5. 单击“关闭”返回到“Team Foundation Server”对话框，然后单击“确定”。

安全

若要执行这些过程，您必须成为“Readers”安全组的成员，或者必须在设置为“允许”的团队项目中拥有至少一种权限。有关更多信息，请参见《Team Foundation Server 管理员指南》中的“Team Foundation Server 权限”。

请参见

其他资源

团队资源管理器安装概述


修复和卸载 Team Foundation Server 概述

修复和卸载 Team Foundation Server 概述
DropDown image

使用本节中的过程可卸载 Team Foundation Server 和所有相关组件。

本节内容

如何：卸载 Team Foundation Server 单服务器部署

说明从服务器移除 Team Foundation Server 组件的步骤。

如何：卸载 Team Foundation Server 双服务器部署

说明从应用层服务器和数据层服务器移除 Team Foundation Server 组件的步骤。

如何：卸载 Team Foundation Build

说明从服务器移除 Team Foundation Build 组件的步骤。

如何：修复或卸载 Team Foundation Server Proxy

说明从服务器还原或移除 Team Foundation Server 代理的步骤。

如何：修复或卸载团队资源管理器

说明还原或移除 Team Explorer 组件的步骤。

如何：修复 Team Foundation Server

说明如何将 Team Foundation Server 组件还原到其原始状态。

相关章节

Team Foundation 安装


如何：卸载 Team Foundation Server 单服务器部署

如何：卸载 Team Foundation Server 单服务器部署
请参见

如果必须卸载，应当移除 Team Foundation Server 及其相关组件，移除的顺序应与下表所示的组件安装顺序相反：

顺序 | 组件 | 物理位置
1. | Team Foundation Server 代理 | Team Foundation Server 计算机 - 或 - 单独的计算机
2. | Team Foundation Build | Team Foundation Server 计算机 - 或 - 单独的计算机
3. | Team Explorer | Team Foundation Server 计算机 - 或 - 单独的计算机
4. | Team Foundation Server | Team Foundation Server 计算机
5. | Microsoft Windows SharePoint Services | Team Foundation Server 计算机
6. | Microsoft SQL Server 2005 | Team Foundation Server 计算机
7. | Internet 信息服务 | Team Foundation Server 计算机
Note 注意

卸载 Visual Studio Team System 不会删除数据或移除数据库。

卸载 Team Foundation Server 客户端组件

如果在应用层计算机上安装了客户端层组件，则应首先卸载这些组件。

卸载客户端层组件

  1. 卸载 Team Foundation Server 代理。有关更多信息，请参见如何：修复或卸载 Team Foundation Server Proxy。

  2. 卸载 Team Foundation Build。有关更多信息，请参见如何：卸载 Team Foundation Build。

  3. 卸载 Team Explorer。有关更多信息，请参见如何：修复或卸载团队资源管理器。

卸载 Team Foundation Server (services)

必须先卸载 Team Foundation Server，然后再卸载其他相关组件。Team Foundation Server 服务、TFSServer Scheduler 和代码覆盖率分析服务将被移除。用户数据、Windows SharePoint Services 以及应用程序池将保留。

卸载 Team Foundation Server

  1. 单击“开始”，选择“控制面板”，然后单击“添加/删除程序”。

  2. 选择“Microsoft Visual Studio 2005 Team Foundation Server”，然后单击“更改/删除”。

  3. 在“维护模式选项”页上，选择“卸载”，然后单击“下一步”。

  4. 在消息框中单击“是”。

  5. 在“维护 - 卸载”中可以看到组件的移除进度。

  6. 在“维护 - 安装完成”页上单击“完成”。

卸载 Microsoft Windows SharePoint Services

在卸载 Team Foundation Server 之后，如果需要，可以卸载 Windows SharePoint Services。

卸载 Microsoft Windows SharePoint Services

  1. 单击“开始”，选择“控制面板”，然后单击“添加/删除程序”。

  2. 选择“Microsoft Windows SharePoint Services 2.0”，然后单击“删除”。

  3. 在消息框中单击“是”。

    将显示一个对话框，指示正在进行卸载。卸载完成后，该对话框自动关闭。

卸载 Microsoft SQL Server 2005

在卸载 Windows SharePoint Services 之后，如果需要，可以移除 Microsoft SQL Server 2005。

卸载 Microsoft SQL Server 2005

  1. 单击“开始”，选择“控制面板”，然后单击“添加/删除程序”。

  2. 选择“Microsoft SQL Server 2005”，然后单击“删除”。

  3. 在“组件选择”页的“选择实例”之下，选择要移除的服务器。

    Note 注意

    单击“报告”按钮可以查看计算机上安装的 SQL Server 2005 组件和功能的列表。

  4. 在“删除 SQL Server 2005 公共组件”之下，选择要卸载的组件。

  5. 单击“下一步”。

  6. 在“确认”页中，检查要移除的组件和功能的列表，然后单击“完成”。

  7. 在“完成”页中，单击“退出”。

卸载 Internet 信息服务

在卸载 Microsoft SQL Server 2005 之后，如果需要，可以移除 Internet 信息服务。

卸载 Internet 信息服务

  1. 单击“开始”，然后单击“配置您的服务器向导”。

  2. 在“欢迎使用‘配置您的服务器向导’”页上单击“下一步”。

  3. 在“预备步骤”页上单击“下一步”。

  4. 在“服务器角色”页上选择“应用程序服务器(IIS，ASP.NET)”，然后单击“下一步”。

  5. 单击“完成”。

安全

若要执行此过程，您必须是计算机上“Administrators”安全组的成员。有关更多信息，请参见 Team Foundation Server 安装所需的用户帐户。

请参见

参考

检查表：Team Foundation Server 单服务器部署

其他资源

修复和卸载 Team Foundation Server 概述


如何：卸载 Team Foundation Server 双服务器部署

如何：卸载 Team Foundation Server 双服务器部署
请参见

如果必须卸载，则应按照与下表中所示的组件安装顺序相反的顺序移除 Team Foundation Server 及其相关组件：

顺序 | 组件 | 物理位置
1. | Team Foundation Server 代理 | 应用层计算机 - 或 - 单独的计算机
2. | Team Foundation 源代码管理 | 应用层计算机 - 或 - 单独的计算机
3. | Team Explorer | 应用层计算机 - 或 - 单独的计算机
4. | Team Foundation Server (services) | 应用层计算机
5. | Microsoft SQL Server 2005 Reporting Services | 应用层计算机
5. | 用于 Team Foundation Server 的 Microsoft Windows SharePoint Services | 应用层计算机
6. | 用于 Team Foundation Server 的 Internet 信息服务 | 应用层计算机
7. | Team Foundation Server (databases) | 数据层计算机
8. | 用于 Team Foundation Server 的 Microsoft SQL Server 2005 | 数据层计算机
Note 注意

卸载 Team Foundation Server 数据库不会删除数据或移除数据库。

使用下面部分中介绍的步骤成功卸载双服务器上安装的 Team Foundation Server。

卸载 Team Foundation Server 客户端组件

如果在应用层计算机上安装了客户端层组件，则首先应卸载这些组件。

卸载客户端层组件

  1. 卸载 Team Explorer。有关更多信息，请参见如何：修复或卸载团队资源管理器。

  2. 卸载 Team Foundation Server 代理。有关更多信息，请参见如何：修复或卸载 Team Foundation Server Proxy。

  3. 卸载 Team Foundation Build。有关更多信息，请参见如何：卸载 Team Foundation Build。

卸载 Team Foundation Server (services)

必须在卸载用于应用层服务的所有组件之后，才能卸载数据库层计算机上的所有组件。

所提供的向导将会引导您移除与 Team Foundation Server 相关的应用程序池、网站、文件、注册表和防火墙设置。不会移除用户数据。Windows SharePoint Services 仍保留在原来的位置。Team Foundation Server 服务、TFSServer 计划程序和代码覆盖率分析将被移除。

卸载 Team Foundation Server (services)

  1. 在应用层计算机上，单击“开始”，并单击“控制面板”，然后单击“添加或删除程序”。

  2. 选择“Microsoft Visual Studio 2005 Team Foundation Server (services)”，然后单击“更改/删除”。

  3. 在“维护模式选项”页上，选择“卸载”，然后单击“下一步”。

  4. 在消息框中单击“确定”。

  5. 在“维护 - 卸载”页上检查组件移除的进度。

  6. 在“维护 - 安装完成”页上单击“完成”。

卸载 Team Foundation Server (services) 后，可以卸载 Windows SharePoint Services。

卸载用于 Team Foundation Server 的 Microsoft Windows SharePoint Services

  1. 单击“开始”，并单击“控制面板”，然后单击“添加或删除程序”。

  2. 选择“Microsoft Windows SharePoint Services 2.0”，然后单击“删除”。

  3. 在消息框中单击“是”。

    卸载完成时，将自动关闭此对话框。

卸载 Internet 信息服务也会禁用 ASP.NET。

卸载用于 Team Foundation Server 的 Internet 信息服务

  1. 单击“开始”，然后单击“配置您的服务器向导”。

  2. 在“欢迎使用‘配置您的服务器向导’”页上单击“下一步”。

  3. 在“预备步骤”页上单击“下一步”。

  4. 在“服务器角色”页上，选择“应用程序服务器(IIS，ASP.NET)”，然后单击“下一步”。

  5. 在“角色删除确认”页上，单击“删除应用程序服务器角色”，然后单击“下一步”。

  6. 单击“完成”。

卸载 Team Foundation Server (databases)

卸载完应用层计算机上所有与 Team Foundation Server 相关的软件后，可以卸载 Team Foundation Server (databases) 组件。

卸载 Team Foundation Server (databases)

  1. 在“开始”菜单中，选择“控制面板”，然后单击“添加或删除程序”。

  2. 选择“Microsoft Microsoft Visual Studio 2005 Team System (databases)”，然后单击“更改/删除”。

  3. 在“维护模式选项”页上，选择“卸载”，然后单击“下一步”。

  4. 在“维护 - 卸载”页上，监视组件移除的进度。

  5. 在消息框中单击“确定”。

  6. 在“完成”页上，单击“完成”。

卸载 Visual Studio Team System Server 不会删除数据或移除数据库。

卸载用于 Team Foundation Server 的 Microsoft SQL Server 2005

  1. 登录到数据层计算机。

    Caution note 警告

    如果在群集上进行卸载，则需要登录到群集的活动节点。在活动节点上进行卸载后，群集将会故障转移到第二个节点。必须登录到第二个节点以继续在该节点上进行卸载。

  2. 单击“开始”，选择“控制面板”，然后单击“添加或删除程序”。

  3. 选择“Microsoft SQL Server 2005”，然后单击“删除”。

  4. 在“选择组件”页上的“选择实例”下，选择要移除的服务器。

    Note 注意

    单击“报告”按钮以查看计算机上安装的 SQL Server 2005 组件和功能的列表。

  5. 在“删除 SQL Server 2005 公共组件”下，选择要卸载的组件。

  6. 单击“下一步”。

  7. 在“确认”页上，检查要移除的组件和功能的列表，然后单击“完成”。

  8. 在“完成”页上，单击“退出”。

安全

若要执行这些过程，您必须是计算机上的“Administrators”安全组的成员。有关更多信息，请参见 Team Foundation Server 安装所需的用户帐户。

请参见

其他资源

修复和卸载 Team Foundation Server 概述


如何：卸载 Team Foundation Build

如何：卸载 Team Foundation Build
请参见

Team Foundation Build 是 Team Foundation Server 的客户端，因此卸载时只会移除客户端组件。您为支持生成而添加的附加组件、程序或动态链接库 (.dll) 在安装后仍然保留。使用下面的过程卸载 Team Foundation Build。

卸载 Team Foundation Build

  1. 单击“开始”，选择“控制面板”，然后单击“添加或删除程序”。

  2. 选择“Microsoft Visual Studio 2005 Team Foundation Server (build)”，然后单击“更改/删除”。

  3. 在“维护模式选项”页上，选择“卸载”，然后单击“下一步”。

  4. 在“维护 - 卸载”页上，监视组件的移除进度。

  5. 在“维护 - 安装完成”页上单击“完成”。

安全

若要执行此过程，您必须是计算机上“Administrators”安全组的成员。有关更多信息，请参见 Team Foundation Server 安装所需的用户帐户。

请参见

其他资源

修复和卸载 Team Foundation Server 概述
Team Foundation Build 安装概述


如何：修复或卸载 Team Foundation Server Proxy

如何：修复或卸载 Team Foundation Server Proxy
请参见

使用以下过程修复或卸载 Team Foundation Server Proxy。

Note 注意

修复过程要求您重新启动代理计算机。

修复 Team Foundation Server Proxy

  1. 登录代理计算机，单击“开始”，选择“控制面板”，然后单击“添加或删除程序”。

  2. 选择“Microsoft Visual Studio 2005 Team Foundation Server Proxy”，然后单击“更改/删除”。

  3. 在“维护模式选项”页上，选择“修复/重新安装”，然后单击“下一步”。

  4. 在“服务帐户”页上，键入服务帐户的密码。

    Note 注意

    该服务帐户是特定于组织的。本指南使用 Domain/TFSPROXY 作为此帐户的占位符。

  5. 在“维护 - 修复/重新安装”页上检查组件列表，然后在提示时单击“立即重新启动”。

  6. 登录到代理计算机，在“维护 - 安装完成”页上单击“完成”。

    Note 注意

    如果远程登录，则必须作为控制台登录。

卸载 Team Foundation Server Proxy

  1. 单击“开始”，选择“控制面板”，然后单击“添加或删除程序”。

  2. 在“添加或删除程序”对话框中选择“Microsoft Visual Studio 2005 Team Foundation Server (proxy)”，然后单击“更改/删除”。

  3. 在“维护模式选项”页上单击“卸载”。

  4. 在提示时单击“是”。

  5. 在“维护 - 安装完成”页上单击“完成”。

安全

若要执行此过程，您必须是代理计算机上“Administrators”安全组的成员。有关更多信息，请参见 Team Foundation Server 安装所需的用户帐户。

请参见

其他资源

修复和卸载 Team Foundation Server 概述
安装 Team Foundation Server Proxy 概述


如何：修复或卸载团队资源管理器

如何：修复或卸载团队资源管理器
请参见

使用下面的过程将 Team Explorer 还原为其原始状态或卸载 Team Explorer。

修复团队资源管理器

如果在使用 Team Explorer 时遇到意外的结果，则可修复安装。

修复团队资源管理器

  1. 单击“开始”，选择“控制面板”，然后单击“添加/删除程序”。

  2. 选择“Microsoft Visual Studio 2005 团队资源管理器”，然后单击“更改/删除”。

  3. 在“维护模式选项”页上，选择“修复/重新安装”，然后单击“下一步”。

  4. 在“安装准备就绪”页上单击“安装”。

  5. 在“维护 - 修复/重新安装”页上检查安装进度。

  6. 在显示提示时，单击“立即重新启动”，然后等待服务器重新启动。

    Note 注意

    Microsoft .NET Framework 2.0 版是安装其他组件所必需的，因此应重新启动计算机。

  7. 登录计算机并允许安装程序继续执行。

  8. 在“维护 - 修复/重新安装”页上检查安装进度。

  9. 在显示提示时，单击“立即重新启动”，然后等待服务器重新启动。

  10. 登录计算机并允许安装程序继续执行。

  11. 在“维护 - 安装完成”页上单击“完成”。

卸载团队资源管理器

如果计算机上不再需要 Team Explorer，则可将其移除。

卸载团队资源管理器

  1. 单击“开始”，选择“控制面板”，然后单击“添加/删除程序”。

  2. 选择“Microsoft Visual Studio 2005 团队资源管理器”，然后单击“更改/删除”。

  3. 在“维护模式选项”页上，选择“卸载”，然后单击“下一步”。

  4. 在消息框中单击“是”。

  5. 在“维护 - 卸载”页上，检查组件的移除进度。

  6. 在“维护 - 安装完成”页上单击“完成”。

安全

若要执行此过程，您必须是计算机上“Administrators”安全组的成员。有关更多信息，请参见 Team Foundation Server 安装所需的用户帐户。

请参见

其他资源

修复和卸载 Team Foundation Server 概述
团队资源管理器安装概述


如何：修复 Team Foundation Server

如何：修复 Team Foundation Server
请参见

使用下面的过程将 Team Foundation Server 组件还原为其原始状态，并重新安装 Team Foundation Server 需要的组件。

修复 Team Foundation Server (databases)

修复 Team Foundation Server (databases)

  1. 单击“开始”，选择“控制面板”，然后单击“添加或删除程序”。

  2. 选择“Microsoft Visual Studio 2005 Team Foundation Server (databases)”，然后单击“更改/删除”。

  3. 在“维护模式选项”页上，选择“修复/重新安装”，然后单击“下一步”。

  4. 在“服务帐户”页的“帐户名”框中键入为 Team Foundation Server 服务帐户创建的域用户帐户，然后单击“下一步”。

    Note 注意

    该服务帐户是特定于组织的。本指南使用 Domain/TFSSERVICE 作为此帐户的占位符。

  5. 在“安装准备就绪”页上验证信息，然后单击“安装”。

    即会出现“维护 - 修复/重新安装”页。

  6. 在“维护 - 安装完成”页上单击“完成”。

修复 Team Foundation Server (services)

修复 Team Foundation Server (services)

  1. 登录到应用层。

  2. 单击“开始”，选择“控制面板”，然后单击“添加或删除程序”。

  3. 选择“Microsoft Visual Studio 2005 Team Foundation Server (services)”，然后单击“更改/删除”。

  4. 在“维护模式选项”页上，选择“修复/重新安装”，然后单击“下一步”。

  5. 在“服务帐户”页上，键入服务帐户的密码。

    Note 注意

    该服务帐户是特定于组织的。本指南使用 Domain/TFSSERVICE 作为此帐户的占位符。

  6. 在“报告数据源帐户”中，键入 Reporting Services 帐户的密码。

    Note 注意

    该帐户是特定于组织的。本指南使用 Domain/TFSREPORTS 作为此帐户的占位符。

  7. 在“安装准备就绪”页上验证组件和帐户，然后单击“安装”。

  8. 在“维护 - 修复/重新安装”页上，检查安装进度。

  9. 在“维护 - 安装完成”页上单击“完成”。

安全

若要执行此过程，您必须是计算机上“Administrators”安全组的成员。有关更多信息，请参见 Team Foundation Server 安装所需的用户帐户。

请参见

其他资源

修复和卸载 Team Foundation Server 概述


Team Foundation 安装指南的法律声明

Team Foundation 安装指南的法律声明
CollapseAll 图像 DropDown 图像

本节提供了有关 Team Foundation 安装指南的法律声明。

Expand 图像 法律声明

本文档提供的信息仅供参考，Microsoft 对本文档不做任何明示或暗示的担保。本文档中的信息（包括 URL 和其他 Internet 网站引用）如有更改，恕不另行通知。所有使用风险或因使用本文档而导致的结果都由用户自行承担。除非另有声明，否则此处描述的示例公司、组织、产品、域名、电子邮件地址、徽标、人物、地点和事件都是虚构的，无意与任何真实的公司、组织、产品、域名、电子邮件地址、徽标、人物、地点或事件相关联，也不应进行这方面的推断。遵守所有适用的版权法律是用户的责任。未经 Microsoft Corporation 明确的书面许可，不得出于任何目的或以任何形式或任何手段（电子、机械、复印、记录或其他方法）复制本文档的任何部分，或者将其存储或引入检索系统，或者将其进行传播。受版权法保护的权利不受此限制。

对于本文档中的主题，Microsoft 可能具有专利、专利申请、商标、版权或其他知识产权。除非 Microsoft 的任何书面许可协议明确提出，否则，本文档的提供并不表示 Microsoft 已将这些专利、商标、版权或其他知识产权的任何许可权限授予您。

© 2005 Microsoft Corporation。保留所有权利。

Microsoft、Visual Studio、Windows、SharePoint 和 Windows Server 是 Microsoft Corporation 在美国和/或其他国家或地区的注册商标或商标。

所有其他商标的所有权属于其各自所有者。