Planification de Team Foundation Server

Visual Studio Team System
Planification de Team Foundation Server
Voir aussi
DropDown image

Team Foundation Server est le produit serveur principal pour Visual Studio Team System, une famille de produits de gestion de cycle de vie de logiciel qui vise les équipes de développement de logiciel qui génèrent des applications orientées service sur .NET Framework. Vous pouvez utiliser Team Foundation Server pour intégrer des applications clientes de Visual Studio Team System en fournissant des outils d'administration, des informations de projet unifiées et des rapports, ainsi qu'un contrôle de code source intégré.

Ce guide fournit des informations qui sont requises pour les administrateurs et les décideurs d'entreprise avant la planification de Team Foundation Server. Cela inclut des informations sur la configuration matérielle requise, la configuration logicielle, les topologies de déploiement, l'aide sur les processus et l'intégration avec un autre logiciel. Ce guide ne traite pas spécifiquement des détails opérationnels du produit, mais fournit plutôt une infrastructure de planification afin que vous puissiez déterminer ce que vous devrez réaliser pour intégrer Team Foundation Server dans votre infrastructure d'entreprise.

Dans cette section

Planification de Team Foundation Server

Décrit la planification nécessaire pour les premiers déploiements de Team Foundation Server.

Vue d'ensemble du produit Team Foundation Server

Décrit le produit Team Foundation Server qui inclut les configurations matérielle et logicielle requises et son interaction avec d'autres produits.

Planification du client et du serveur

Décrit la planification des composants clients et de serveur de Team Foundation.

Planification de capacité pour le déploiement de Team Foundation

Décrit la planification en termes de besoins actuels, de performance et de croissance.

Planification de la maintenance du serveur

Décrit la planification pour la récupération d'urgence et la maintenance du système.

Voir aussi

Autres ressources

Administration de Team Foundation Server

Image de pied de page
Pour faire une suggestion ou rapporter un bogue éventuel à propos de l'aide ou de toute autre fonctionnalité, accédez au site de commentaires.


Planification de Team Foundation Server

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Planification de Team Foundation Server
Voir aussi
Image de liste déroulante

Le Guide de planification Team Foundation Server fournit de l'aide sur les impératifs opérationnels et administratifs de Team Foundation Server. Il traite de la configuration matérielle requise, de la configuration logicielle requise, des topologies de déploiement, des processus et de l'intégration avec d'autres logiciels. Il n'a pas pour finalité de fournir une aide ou des procédures sur le déploiement, mais d'aider les décideurs d'entreprise et les administrateurs réseau à planifier Team Foundation Server.

But de ce Guide de planification

Ce guide est destiné à vous aider à planifier l'ajout de Team Foundation Server à votre entreprise, que vous utilisez déjà Visual Studio Team System ou non. Après avoir lu ce guide, vous devez être en mesure de créer ce qui suit :

  • Un plan de matériel (y compris les dates de commande du matériel si nécessaire).

  • Un plan de sauvegarde et de restauration.

  • Un plan d'intégration du logiciel.

  • Une liste des tâches pour l'administrateur qui maintiendra les systèmes au sein de votre organisation et créera des projets initiaux.

Terminologie

Les termes suivants sont utilisés dans ce guide de planification :

  • Visual Studio Team System

    Une famille de produits de gestion du cycle de vie de logiciel qui fournit une solution de bout en bout aux équipes de développement de logiciel qui génèrent des applications orientées services à l'aide du .NET Framework.

  • Team Foundation Server

    Le nom de produit donné à l'ensemble de fonctionnalités de contrôle de code source, suivi des éléments de travail, génération (build), portail de projet d'équipe, création de rapports et gestion de projets pour Microsoft Windows Server 2003.

  • serveur de couche Application de Team Foundation

    La désignation logique d'un sous-ensemble de fonctionnalités de Team Foundation Server qui se compose à l'origine de services Web ASP.NET s'exécutant sous IIS (Internet Information Services), mais inclut également le service du planificateur TFS et le service Build Services, qui sont des services Windows. Le regroupement physique de ces fonctionnalités Team Foundation Server sur un ordinateur unique est connu sous le nom de (services) Team Foundation Server.

  • serveur de couche Données de Team Foundation

    La désignation logique d'un sous-ensemble de fonctionnalités de Team Foundation Server, qui comprend toutes les données persistantes dans Team Foundation, y compris toutes les bases de données SQL ainsi que les fichiers et les répertoires utilisés pour stocker des pièces jointes d'éléments de travail. Le regroupement physique de ces fonctionnalités de Team Foundation Server sur un ordinateur unique est connu sous le nom de (bases de données) Team Foundation Server.

  • Client basé sur les rôles

    L'une des applications clientes de Visual Studio Team System ciblée spécifiquement pour un rôle dans le cycle de vie de développement de logiciel. Il existe trois clients basés sur les rôles dans Visual Studio Team System : Visual Studio Team Edition for Architects, Visual Studio Team Edition for Developerset Visual Studio Team Edition for Architects.

  • Team Explorer

    Une application cliente basée sur Visual Studio pour la gestion et l'analyse de projet logiciel. Team Explorer n'est pas considéré comme un client basé sur les rôles à l'instar de Visual Studio Team Edition for Architects ou de Visual Studio Team Edition for Architects.

Voir aussi

Autres ressources

Administration de Team Foundation Server


Vue d'ensemble du produit Team Foundation Server

Vue d'ensemble du produit Team Foundation Server
Voir aussi
DropDown image

Cette section traite des fonctionnalités de Team Foundation Server qui incluent les fonctionnalités serveur, les clients serveur et les topologies pour le déploiement de Team Foundation Server. Vous pouvez y trouver des informations sur les configurations matérielle et logicielle requises pour Team Foundation Server. Vous pouvez également y trouver des informations sur la personnalisation de Team Foundation Server pour la sécurité et pour les besoins de votre entreprise.

Dans cette section

Composants Team Foundation Server

Décrit les serveurs des couches Application et Données de Team Foundation, les serveurs de builds et les plates-formes de test.

Clients Team Foundation Server

Décrit les clients Team Foundation qui s'intègrent avec Team Foundation Server.

Topologies de Team Foundation Server

Décrit les topologies prises en charge et non prises en charge pour les déploiements de Team Foundation Server et fournit des exemples de topologies pour des déploiements simples, modérés et complexes.

Personnalisation de Team Foundation Server pour vos affaires

Décrit le choix et la personnalisation des modèles de processus pour les projets, fournit une vue d'ensemble du processus et indique comment le choix du modèle de processus affecte le fonctionnement de Team Foundation Server.

Configuration requise du serveur Team Foundation Server

Décrit la configuration requise pour les serveurs de Team Foundation et les clients de Team Foundation Server qui incluent l'aspect matériel, logiciel et la configuration réseau. Décrit également la configuration requise pour travailler avec d'autres environnements de développement.

Sécurité de Team Foundation Server pour les utilisateurs et les groupes

Présente des considérations de planification de la sécurité de Team Foundation Server et fournit une vue d'ensemble de la sécurité de Team Foundation.

Rubriques connexes

Planification du client et du serveur

Voir aussi

Autres ressources

Administration de Team Foundation Server


Composants Team Foundation Server

Composants Team Foundation Server
DropDown image

Les serveurs Team Foundation fournissent des fonctions de contrôle de code source, de suivi des éléments de travail, de création de rapports et des fonctions de site Web de projet pour Visual Studio Team System. Ils peuvent également fournir des fonctions de plate-forme de test et de génération. Les serveurs Team Foundation s'intègrent par ailleurs avec Microsoft Project et Microsoft Excel pour étendre les fonctionnalités de création de rapports et de suivi. Un serveur Team Foundation Server logique est composé de deux composants, comme suit :

  • Serveur de couche Application Team Foundation Cette couche logique est composée à l'origine de services Web, et représente la couche Application dans un déploiement d'application Web classique de trois couches. Les services et fonctions dans un déploiement physique qui appartient à cette couche sont connus sous le nom de Team Foundation Server (services).

  • Serveur de couche Données Team Foundation Cette couche logique est composée à l'origine d'un serveur de base de données Microsoft SQL Server 2005 ; elle inclut des bases de données spécifiques à Team Foundation Server et représente la couche Données dans un déploiement d'application Web classique de trois couches. Les services et fonctions dans un déploiement physique qui appartient à cette couche sont connus sous le nom de Team Foundation Server (bases de données).

La couche Application et la couche Base de données peuvent être déployées physiquement ensemble sur un serveur (déploiement sur un serveur), ou séparément sur deux serveurs distincts (déploiement sur deux serveurs). Une licence Team Foundation Server séparée est requise pour chaque serveur Team Foundation ; pour un déploiement sur deux serveurs, vous avez donc besoin de deux licences Team Foundation Server.

Dans cette section

Serveurs de couche Application Team Foundation

Décrit la couche Application Team Foundation et les services qui s'exécutent sur Team Foundation Server.

Serveurs de couche Données Team Foundation

Décrit la couche Données de Team Foundation et les bases de données qui s'exécutent sur Team Foundation Server.

Serveurs Team Foundation Build

Décrit les serveurs de build et la façon dont ils fonctionnent avec Team Foundation Server.

Plate-forme de test Team Test

Décrit les serveurs de test, y compris les contrôleurs de test et les agents de test, ainsi que la manière dont ils fonctionnent avec Team Foundation Server.

Intégration aux fonctionnalités Windows Server

Décrit comment Team Foundation Server s'intègre avec les fonctionnalités de la famille de produits Windows Server.

Intégration à d'autres produits

Décrit comment Team Foundation Server s'intègre avec d'autres produits, tels que Microsoft Excel et Microsoft SQL Server.


Serveurs de couche Application Team Foundation

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Serveurs de couche Application Team Foundation
Voir aussi
Image de liste déroulante

Le niveau serveur de couche Application de Team Foundation se compose essentiellement de services et applications Web. Vous pouvez déployer ce niveau avec la couche Données sur un serveur unique (déploiement sur un serveur), ou vous pouvez déployer ce niveau sur un serveur séparé de la couche Données (déploiement sur deux serveurs). Le niveau serveur de couche Application de Team Foundation doit être installé sur Windows Server 2003 Standard Edition, Windows Server 2003 Enterprise Edition ou Windows Server 2003 Datacenter. Il ne peut pas être installé sur n'importe quelle version 64 bits des systèmes d'exploitation Windows Server 2003.

Services et applications de couche Application

Le serveur de couche Application de Team Foundation héberge les services Web ASP.NET nécessaires pour la communication avec le serveur de couche Données de Team Foundation ainsi qu'avec les ordinateurs de couche cliente de Team Foundation. Les services suivants sont exécutés sur le serveur de couche Application de Team Foundation :

  • Services Web de Team Foundation Server, y compris le contrôle de code source, le suivi des éléments de travail et les services de notification d'événements. Ces services, exécutés collectivement sous un compte de service spécifié par administrateur, sont souvent désignés en tant que compte de service TFSService.

  • Planificateur de serveur TFS, un service Windows qui s'exécute sous le compte de service TFSService.

  • Team Build Services, un service Windows qui s'exécute sous le compte de service de build. Les Build Services peuvent être configurés pour s'exécuter sous un autre compte de service Windows, le cas échéant.

En plus de ses propres services, Team Foundation Server requiert plusieurs autres services pour fonctionner correctement. Pour plus d'informations sur les services requis pour le serveur de couche Application de Team Foundation, consultez Concepts sur la sécurité de Team Foundation Server.

Le serveur de couche Application de Team Foundation héberge également les applications nécessaires pour l'interopérabilité entre lui-même et le serveur de couche Données de Team Foundation et les ordinateurs de couche cliente de Team Foundation. Les applications suivantes sont exécutées sur le serveur de couche Application de Team Foundation :

  • Les outils d'administration de Team Foundation Server, y compris TFSAdminUtil, TFSSecurity et les commandes Team Foundation. Pour plus d'informations sur les différents outils d'administration à partir de la ligne de commande, consultez Utilisation des outils de ligne de commande Team Foundation Server.

  • Internet Information Services (IIS)

  • ASP.NET 2.0

  • Windows SharePoint Services

  • Microsoft SQL Reporting Services

Configuration de la couche Application

La taille et la portée du déploiement de Team Foundation Server affectent le matériel et les logiciels requis pour le serveur qui héberge le niveau serveur de couche Application de Team Foundation. Pour plus d'informations sur la configuration matérielle requise pour le serveur de couche Application de Team Foundation dans le cadre d'un déploiement sur un serveur ou sur deux serveurs, consultez Configuration requise pour le serveur Team Foundation et Configuration requise pour le serveur Team System.

Voir aussi

Concepts

Architecture de sécurité de Team Foundation Server


Serveurs de couche Données Team Foundation

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Serveurs de couche Données Team Foundation
Voir aussi
Image de liste déroulante

Le niveau serveur de couche Données Team Foundation se compose essentiellement de bases de données et de magasins de données Microsoft SQL Server 2005, de bases de données Team Foundation et de procédures stockées Team Foundation. Vous pouvez déployer ce niveau avec la couche Application sur un serveur unique (déploiement sur un serveur), ou vous pouvez déployer ce niveau sur un serveur séparé de la couche Données (déploiement sur deux serveurs). Le niveau serveur de couche Données Team Foundation doit être installé sur Windows Server 2003 Standard Edition, Windows Server 2003 Enterprise Edition, Windows Server 2003 Datacenter ou sur l'un des systèmes d'exploitation 64 bits . Il ne peut pas être installé sur Windows Server 2003 Web Edition.

Applications et services de couche Données

Le serveur de couche Données Team Foundation héberge les bases de données nécessaires pour les opérations de Team Foundation Server. Les services suivants sont exécutés sur le serveur de couche Données de Team Foundation :

  • Les services Microsoft SQL, y compris les services Analysis Server et SQL Browser. Ces services s'exécutent sous le système local. Toutes les bases de données hébergées sur la couche Données de Team Foundation sont des bases de données SQL, qui requièrent ces services SQL pour leur fonctionnement. Les bases de données sont les suivantes :

    • Base de données de suivi des éléments de travail.

    • Base de données contenant le contrôle de code source.

    • Base de données des services communs de Team Foundation.

    • Base de données Team Foundation Build.

    • Base de données d'entrepôt de rapports.

    • Base de données Windows SharePoint Services.

Configuration de la couche Données

La taille et la portée du déploiement de Team Foundation Server affectent le matériel et les logiciels requis pour le serveur qui héberge le niveau serveur de couche Données de Team Foundation. Pour plus d'informations sur la configuration matérielle requise pour le serveur de couche Données de Team Foundation dans le cadre d'un déploiement sur un serveur ou sur deux serveurs, consultez Configuration requise pour le serveur Team Foundation et Configuration requise pour le serveur Team System.

Voir aussi

Concepts

Serveurs de couche Application Team Foundation

Autres ressources

Topologies de Team Foundation Server


Serveurs Team Foundation Build

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Serveurs Team Foundation Build
Voir aussi
Image de liste déroulante

Pour tirer parti des fonctionnalités de Team Foundation Build, vous pouvez désigner un ou plusieurs ordinateurs dans l'environnement de Team Foundation comme serveur de builds. Team Foundation Server ne nécessite pas de serveur de builds, mais peut s'intégrer avec un ou plusieurs serveurs de builds. Un serveur de builds utilise Team Foundation Build et des tâches Team Foundation Build pour télécharger le code source dans un espace de travail local, générer une build, exécuter des suites de tests, enregistrer des éléments de travail dans un journal, mettre à jour des éléments de travail, enregistrer la couverture de test et les métriques de l'évolution du code, et publier un rapport de build sur le portail de projet d'équipe.

Vous pouvez choisir d'installer Team Foundation Build sur un serveur ou un ordinateur client séparé, ou à côté de tout ordinateur client avec Team System installé. Vous pouvez également choisir d'installer Team Foundation Build sur le même serveur que Team Foundation Server, bien que cela ne soit pas recommandé.

Services et applications du serveur de builds

La fonctionnalité de Team Foundation Build contient les fichiers binaires nécessaires pour générer du code sous forme de logiciel exécutable. Les services suivants sont exécutés sur le serveur de builds :

  • Service Team Build, qui s'exécute sous le compte de service que vous spécifiez pendant l'installation. Pour générer un projet d'équipe sur cet ordinateur, vous devez ajouter ce compte au groupe Build Services du projet Team Foundation Server.

  • Les outils de Team Foundation Build, notamment MSBuild.exe. Pour plus d'informations sur le fonctionnement et la gestion du serveur de builds, consultez Administration de Team Foundation Build.

Configuration requise pour le serveur de versions

Le nombre de serveurs de builds dans le déploiement et la portée de vos builds déterminera le matériel et le logiciel dont vous avez besoin pour le(s) serveur(s) de builds. Pour plus d'informations sur la configuration matérielle requise pour les serveurs de builds, consultez Configuration du serveur pour Team Foundation Build.

Voir aussi

Concepts

Team Foundation Server

Autres ressources

Gestion des builds avec Team Foundation Build


Plate-forme de test Team Test

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Plate-forme de test Team Test
Voir aussi
Image de liste déroulante

Visual Studio intègre, outre la mesure de couverture du code, plusieurs types de tests, notamment les tests unitaires, les tests Web, les tests de charge et les tests manuels. Team Edition for Testers permet aux utilisateurs de Visual Studio Team System d'effectuer des tests sur des ordinateurs distants, appelés plate-forme de test. Une plate-forme de test assure l'exécution répartie et automatisée des tests. Une plate-forme de test Team Edition for Testers est composée d'un seul contrôleur de test et d'un ou de plusieurs agents de test. Un contrôleur de test peut coordonner l'exécution de plusieurs séries de tests sur les ordinateurs sur lesquels l'agent de test est installé.

L'utilisation la plus courante d'une plate-forme de test est la mise à l'échelle de la génération de charge. Par exemple, si vous souhaitez exécuter un test de charge qui simule 10 000 utilisateurs, vous pouvez installer un seul contrôleur et cinq ordinateurs agents pour émuler ce scénario. Vous pouvez également exécuter un vaste ensemble de tests fonctionnels sur les ordinateurs agents. Les tests s'exécuteront en parallèle afin que vous puissiez réduire le temps qu'il faut pour exécuter tous les tests.

Services et applications de la plate-forme de test Team Test

Le contrôleur de Team Edition for Testers héberge les fichiers d'exécution de tests nécessaires pour que Team Edition for Testers effectue les tests sur les ordinateurs agents de Team Edition for Testers. Les services et applications suivants exécutés sur le contrôleur de Team Edition for Testers :

  • Visual Studio Team Test Controller Service (QTController.exe) Ce service communique avec les agents de test et s'exécute sous le contexte utilisateur indiqué au moment de l'installation. Le compte d'utilisateur spécifié doit avoir l'autorisation de lire les compteurs de performance sur les ordinateurs agents de test.

Les services et applications suivants s'exécutent sur l'agent de Team Edition for Testers :

  • Visual Studio Team Test Agent Service (QTAgentService.exe) Ce service communique avec le contrôleur de test et démarre les processus d'agent sur l'ordinateur où les tests sont effectués réellement. Le service s'exécute sous le contexte d'utilisateur indiqué au moment de l'installation.

  • Visual Studio Team Test Agent (QTAgent.exe) Tests exécutés dans ce processus. Le processus s'exécute sous le contexte d'utilisateur indiqué au moment de l'installation.

Configuration de la plate-forme de test Team Test

Le nombre de plates-formes de test dans le déploiement et la portée de vos tests affecte le matériel et les logiciels requis par les contrôleurs et les agents de test dans votre environnement. Pour plus d'informations sur la configuration matérielle requise de la plate-forme de test, consultez Configuration de la plate-forme de test Team Test pour Team Foundation Server.

Voir aussi

Tâches

Mise en route avec les outils de test Team System
Comment : administrer la plate-forme de test

Concepts

À propos du contrôleur et des agents
Sécurité du contrôleur et de l'agent
Installation des fonctionnalités de contrôleur et d'agent


Intégration aux fonctionnalités Windows Server

Intégration aux fonctionnalités Windows Server
Voir aussi
DropDown image

Team Foundation Server s'intègre avec beaucoup de fonctionnalités des produits de la famille Windows Server. Vous pouvez intégrer Team Foundation Server avec les fonctions de gestion des utilisateurs et des groupes d'Active Directory ou vous pouvez intégrer Team Foundation Server avec un environnement de groupe de travail. Vous pouvez également intégrer Team Foundation Server avec des serveurs SMTP pour automatiser les alertes par messagerie électronique des événements Team Foundation Server, tels que les modifications d'élément de travail ou les notifications de générations (builds).

Dans cette section

Intégration à Active Directory

Décrit comment Team Foundation Server s'intègre avec les déploiements Active Directory.

Intégration des groupes de travail

Décrit comment Team Foundation Server s'intègre avec les déploiements de groupes de travail.

Intégration à SMTP Server

Décrit comment Team Foundation Server s'intègre avec les serveurs SMTP.

Voir aussi

Autres ressources

Intégration à d'autres produits


Intégration à Active Directory

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Intégration à Active Directory
Voir aussi
Image de liste déroulante

Team Foundation Server peut s'intégrer avec les fonctions de gestion des utilisateurs et des groupes Active Directory pour gérer des utilisateurs et des groupes. Les petites organisations peuvent utiliser des groupes de travail pour gérer des utilisateurs, mais les grandes organisations doivent utiliser Active Directory pour gérer les utilisateurs et groupes qui travaillent sur les projets dans Team Foundation Server.

Active Directory et Team Foundation Server

Active Directory stocke les informations concernant les objets sur le réseau et facilite ainsi la recherche et l'utilisation de ces informations aux administrateurs et aux utilisateurs. Active Directory utilise un magasin de données structuré comme base pour une organisation logique et hiérarchisée des informations d'annuaire. Dans la mesure où les informations relatives aux utilisateurs et aux groupes sont disponibles sur l'ensemble du réseau, vous pouvez ajouter des utilisateurs et des groupes Active Directory configurés précédemment comme utilisateurs ou groupes de niveau de projet à Team Foundation Server, ou comme utilisateurs ou groupes de niveau serveur de Team Foundation.

En plus des avantages qu'offre Active Directory au niveau de la gestion des utilisateurs, le déploiement de Team Foundation Server peut également bénéficier de l'environnement d'annuaire sécurisé fourni par Active Directory. Active Directory utilise l'authentification de connexion intégrée et l'autorisation d'utilisateur, qui sont des fonctionnalités de base de l'autorité de sécurité locale (Local Security Authority, LSA). L'authentification de connexion et l'autorisation d'utilisateur sont disponibles par défaut et fournissent une protection immédiate pour l'accès au réseau et aux ressources réseau, par exemple vos serveurs Team Foundation.

Limitations

Team Foundation Server a des impératifs de domaine Active Directory spécifiques. Pour plus d'informations sur les niveaux fonctionnels Active Directory pris en charge et la configuration du domaine, consultez Configuration du domaine pour Team Foundation Server.

Voir aussi

Concepts

Topologies prises en charge pour Team Foundation Server

Autres ressources

Gestion de Team Foundation Server dans un domaine Active Directory


Intégration des groupes de travail

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Intégration des groupes de travail
Voir aussi
Image de liste déroulante

Team Foundation Server peut s'intégrer avec les fonctions de groupe de travail des systèmes d'exploitation Windows. Les organisations de petite taille peuvent utiliser des groupes de travail pour gérer les utilisateurs et les ordinateurs dans de petits environnements d'égal à égal (peer-to-peer) où il y a peu d'utilisateurs à gérer et un ensemble relativement homogène de systèmes d'exploitation à gérer et à connecter.

Groupes de travail et Team Foundation Server

Les groupes de travail sont un simple regroupement d'ordinateurs, destinés uniquement à aider les utilisateurs à localiser des éléments comme les imprimantes et les dossiers partagés dans ce groupe. Les groupes de travail dans les systèmes d'exploitation Windows n'offrent pas l'authentification et les comptes d'utilisateurs centralisés qu'offrent les domaines Active Directory, et ils ne disposent pas non plus de beaucoup d'outils de sécurité et de ressources. Team Foundation Server peut ajouter des utilisateurs locaux et des groupes qui sont configurés sur des ordinateurs individuels dans un groupe de travail en tant que membres de groupes de niveau serveur et de niveau projet de Team Foundation Server.

Le déploiement de groupes de travail Team Foundation Server est prévu pour les équipes ou les départements de petite taille qui utilisent des groupes de travail à la place des domaines pour réduire leurs coûts administratifs. Un déploiement de groupe de travail peut également être envisagé pour l'évaluation de projets pilotes ou d'ateliers de test afin d'éviter le besoin de configurer Active Directory. Toutefois, en raison des fonctions de gestion d'utilisateurs limitées, les déploiements de groupes de travail de Team Foundation Server ne conviennent pas aux grandes entreprises.

Les ordinateurs clients peuvent faire partie d'un domaine ou de groupes de travail différents de ceux de l'ordinateur Team Foundation Server. Si c'est le cas, les utilisateurs doivent fournir leurs informations d'identification de compte d'utilisateur locales de Team Foundation Server lorsqu'ils se connectent à Team Foundation Server.

Limitations

Team Foundation Server fonctionne avec les groupes de travail uniquement sur les systèmes d'exploitation 32 bits pris en charge. En outre, un déploiement de groupe de travail requiert que les deux couches Application et Données de Team Foundation Server soient déployées sur le même serveur. Le déploiement de Team Foundation Server sur deux serveurs n'est pas pris en charge pour les groupes de travail. En outre, tous les utilisateurs de Team Foundation Server doivent être créés en tant que comptes locaux sur le serveur exécutant Team Foundation Server.

Voir aussi

Concepts

Intégration à Active Directory
Impératifs de groupe de travail pour Team Foundation Server


Intégration à SMTP Server

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Intégration à SMTP Server
Voir aussi
Image de liste déroulante

Vous pouvez configurer Team Foundation Server pour qu'il s'intègre à un serveur SMTP en vue d'envoyer des notifications par courrier électronique aux utilisateurs pour des événements spécifiques, par exemple quand leurs éléments de travail sont modifiés par un autre utilisateur ou lorsqu'une génération (build) est terminée.

Team Foundation Server et SMTP

Pour chaque projet dans Team Foundation Server, vous pouvez configurer des alertes de projet qui enverront des alertes par messagerie électronique aux utilisateurs pour des types d'événements spécifiques, tels que la modification d'éléments de travail. Team Foundation Server peut envoyer ces alertes à l'aide de tout serveur SMTP déjà configuré dans votre infrastructure réseau.

Team Foundation Server inclut également une infrastructure de notification extensible. Team Foundation inclut un ensemble de modèles de messagerie électronique qui prennent en charge certains types d'événements. Vous pouvez utiliser les outils d'extensibilité de Team Foundation pour ajouter de nouveaux types d'événements par messagerie électronique.

Limitations

Si vous pouvez définir des alertes par messagerie électronique pour les événements dans Team Foundation Server en choisissant l'option Alertes de projet dans le menu Équipe, ces alertes ne fonctionneront pas sans la configuration manuelle du serveur SMTP à utiliser. Pour configurer le serveur SMTP, vous devez modifier manuellement le fichier web.config à l'aide d'un éditeur de texte ordinaire.

Voir aussi

Tâches

Comment : envoyer des requêtes d'élément de travail par courrier électronique
Comment : recevoir des notifications de build par courrier électronique


Intégration à d'autres produits

Intégration à d'autres produits
Voir aussi
DropDown image

Par défaut, Team Foundation Server s'intègre avec plusieurs autres produits Microsoft. Pour planifier et gérer Team Foundation Server efficacement, vous devez comprendre comment Team Foundation Server s'intègre avec ces produits. Vous pouvez planifier ensuite comment utiliser cette intégration pour répondre aux besoins de votre entreprise.

Dans cette section

Intégration à Microsoft Project

Décrit l'intégration de Team Foundation Server avec Microsoft Project.

Intégration à Microsoft Excel

Décrit l'intégration de Team Foundation Server avec Microsoft Excel.

Intégration à Windows SharePoint Services

Décrit l'intégration de Team Foundation Server avec Windows SharePoint Services.

Intégration à SQL Server

Décrit l'intégration de Team Foundation Server avec Microsoft SQL Server.

Voir aussi

Autres ressources

Administrateurs Team Foundation


Intégration à Microsoft Project

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Intégration à Microsoft Project
Voir aussi
Image de liste déroulante

Vous pouvez gérer vos projets Team Foundation Server en intégrant les fonctionnalités de suivi des éléments de travail et de structure de projet de Team Foundation Server avec les fonctions de gestion de projet de Microsoft Project.

Intégration de Microsoft Project avec Team Foundation Server

Vous pouvez modifier la structure de projet de votre projet d'équipe Team Foundation Server à partir de Microsoft Project. À mesure que les besoins du projet changent, vous pouvez modifier la structure ou les itérations du projet pour satisfaire les étapes du cycle de vie du produit. Par exemple, vous pouvez définir le nombre de zones que possède un projet d'équipe et la relation hiérarchique entre elles, ou vous pouvez également modifier le nombre d'itérations que connaît un projet d'équipe et changer les étapes et les éléments de travail qui composent chaque itération.

Le diagramme suivant illustre l'interaction entre un ordinateur client Visual Studio Team System qui a Microsoft Project installé et Team Foundation Server.

Image Intégration de document Team Foundation

La communication entre le client et le serveur s'effectue via les services Web et utilise SOAP sur HTTP.

Limitations

La communication entre les ordinateurs clients et les serveurs Team Foundation, qui inclut la communication de Microsoft Project, s'effectue en clair sauf si vous configurez Team Foundation Server pour qu'il utilise HTTPS et SSL.

Sécurité

Pour que les utilisateurs modifient avec succès la structure ou les itérations du projet, le compte d'utilisateur doit avoir les autorisations appropriées qui incluent l'autorisation Edit project-level information. Pour plus d'informations sur les autorisations, consultez Autorisations de Team Foundation Server.

Voir aussi

Concepts

Modification de la structure et des itérations du projet à partir de Microsoft Excel ou Microsoft Project

Autres ressources

Gestion de projets dans Microsoft Excel et Microsoft Project


Intégration à Microsoft Excel

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Intégration à Microsoft Excel
Voir aussi
Image de liste déroulante

Vous pouvez gérer vos projets Team Foundation Server en intégrant les fonctionnalités de suivi des éléments de travail et de structure de projet de Team Foundation Server avec les fonctions d'édition et de traitement des feuilles de calcul de Microsoft Project.

Intégration de Microsoft Excel avec Team Foundation Server

Vous pouvez utiliser Microsoft Excel pour gérer des éléments de travail, y compris pour ajouter rapidement ou modifier des éléments de travail, établir un graphique de progression des éléments de travail ou planifier des éléments de travail. La modification de plusieurs éléments de travail est beaucoup plus facile à accomplir dans une feuille de calcul Microsoft Excel que dans Team Explorer.

Le diagramme suivant illustre l'interaction entre un ordinateur client Visual Studio Team System avec Microsoft Excel installé et Team Foundation Server.

Image Intégration de document Team Foundation

La communication entre le client et le serveur s'effectue via les services Web et utilise SOAP sur HTTP.

Limitations

La communication entre les ordinateurs clients et les serveurs de Team Foundation, qui inclut la communication de Microsoft Excel et les mises à jour de la base de données des éléments de travail, est envoyée sous forme de trafic réseau non chiffré à moins que ne vous configuriez Team Foundation Server pour utiliser HTTPS et SSL à la place.

Sécurité

Pour que les utilisateurs modifient avec succès la structure ou les itérations du projet, le compte d'utilisateur doit avoir les autorisations appropriées, et notamment l'autorisation Edit project-level information. Pour plus d'informations sur les autorisations, consultez Autorisations de Team Foundation Server.

Voir aussi

Concepts

Publication des éléments de travail

Autres ressources

Gestion des éléments de travail dans Microsoft Excel et Microsoft Project


Intégration à Windows SharePoint Services

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Intégration à Windows SharePoint Services
Voir aussi
Image de liste déroulante

L'intégration entre Team Foundation Server et Windows SharePoint Services fournit aux administrateurs, aux coordinateurs de projet et aux collaborateurs de projet de puissants outils de partage d'informations et d'organisation. Cette intégration inclut un portail de projet d'équipe, de l'aide sur les processus, des documents de projet, des modèles et des rapports qui peuvent être partagés avec les membres de l'équipe autant que nécessaire et en fonction du rôle de chaque membre de l'équipe dans le projet.

Windows SharePoint Services et Team Foundation Server

Microsoft Windows SharePoint Services ajoute des fonctionnalités de travail en groupe sur les projets et la publication Web dans Team Foundation Server, qui peuvent améliorer la communication et favoriser le partage d'idées parmi les utilisateurs qui ont des tâches assignées dans les projets d'équipe. Le portail du projet pour votre projet d'équipe fournit un emplacement central pour stocker des documents, publier des annonces, répertorier des informations de génération (build) et créer des rapports sur l'état de votre projet d'équipe.

Vous pouvez effectuer plusieurs tâches qui affectent la connectivité globale et les performances de vos utilisateurs. Quelques-unes de ces tâches sont exécutées uniquement en fonction des besoins, en spécifiant par exemple une connexion à un serveur Team Foundation Server qui exécute Windows SharePoint Services. D'autres tâches, comme la synchronisation des utilisateurs de Team Foundation avec les utilisateurs de Windows SharePoint Services, peuvent nécessiter une exécution régulière.

De plus, vous pouvez personnaliser Windows SharePoint Services de plusieurs façons afin de mieux répondre aux besoins de votre organisation, y compris le fait de personnaliser des documents, de répertorier des informations de génération (build), de créer des rapports ou de standardiser l'aide sur les processus au sein de votre organisation.

Pour plus d'informations, consultez le Guide de l'administrateur Windows SharePoint Services sur le site Web de Microsoft (http://go.microsoft.com/fwlink/?linkid=19480&clcid=0x409).

Voir aussi

Tâches

Comment : définir les autorisations d'administrateur pour Windows SharePoint Services
Comment : définir les autorisations des coordinateurs de projet pour Windows SharePoint Services
Comment : définir les autorisations de collaborateur pour Windows SharePoint Services

Concepts

Connexion à un serveur Windows SharePoint
Rôles de Windows SharePoint Services

Autres ressources

Gestion des sites Windows SharePoint Services


Intégration à SQL Server

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Intégration à SQL Server
Voir aussi
Image de liste déroulante

À bien des égards, SQL Server est intégré à Team Foundation Server. La couche Données de Team Foundation est principalement composée de bases de données SQL Server. De plus, Team Foundation Server incorpore SQL Reporting Services pour la génération et le stockage de rapports.

Team Foundation Server et SQL Server

Team Foundation Server utilise les fonctionnalités de Microsoft SQL Server 2005 des façons suivantes :

  • Les informations sur les composants et les données de projet sont stockées dans les bases de données de SQL Server.

  • Les informations et les données d'entrepôt sont résumées et gérées par SQL Server Analysis Services.

  • Les rapports de projet sont générés et stockés par SQL Server Reporting Services.

La plupart des tâches liées à SQL de l'administrateur de Team Foundation sont traitées automatiquement via Team Foundation Server. La plus importante exception à cette règle concerne la sauvegarde et restauration de Team Foundation Server, qui requiert l'interaction directe avec le logiciel de sauvegarde de SQL Server.

Voir aussi

Tâches

Comment : définir les autorisations d'administrateur pour Reporting Services
Comment : définir des autorisations de coordinateur de projet pour Reporting Services
Comment : définir les autorisations de collaborateur pour Reporting Services

Concepts

Architecture de sécurité de Team Foundation Server
Synchronisation de la planification avec l'entrepôt de données
Concepts sur la sécurité de Team Foundation Server

Autres ressources

Sauvegarde et restauration des données de Team Foundation Server
SQL Server Administration How-to Topics


Clients Team Foundation Server

Clients Team Foundation Server
Voir aussi
DropDown image

Visual Studio Team System possède quatre applications clientes principales : Visual Studio Team Edition for Architects, Visual Studio Team Edition for Developers, Visual Studio Team Edition for Testers et Team Explorer.

Lorsque vous les utilisez avec Team Foundation Server, les clients Visual Studio Team System fournissent des interfaces utilisateur Visual Studio supplémentaires à des fonctions telles que le contrôle de version, le suivi des éléments de travail, les sites Web d'équipe, la création de rapports, le guide de processus, la gestion de génération (build) l'exécution de tests multisites.

Remarque Remarque

Vous pouvez installer plusieurs clients Visual Studio Team System sur un seul ordinateur. Dans ce cas, Visual Studio Team System unit les fonctions des clients qui ont été installés. Par exemple, si vous installez Visual Studio Team Edition for Architects et Visual Studio Team Edition for Testers, vous disposez du fonctionnement de Team Edition for Architects et de Team Edition for Testers lorsque vous exécutez devenv.exe.

Dans cette section

Visual Studio Team System fournit les fonctionnalités clientes suivantes :
Visual Studio Team Architect

Application cliente de Visual Studio Team System axée sur le rôle de l'architecte logiciel. Grâce à Visual Studio Team Edition for Architects, un développeur peut utiliser le suivi des éléments de travail et le contrôle de code source. Ces fonctionnalités correspondent aux impératifs principaux que vous devez prendre en considération dans votre planification de Team Foundation Server. Si vous avez préparé convenablement le serveur pour les impératifs de suivi des éléments de travail et le contrôle de code source de votre équipe, aucune planification serveur supplémentaire n'est nécessaire pour prendre en charge Visual Studio Team Edition for Architects.

Pour plus d'informations, consultez Documentation Team Edition for Architects.
Visual Studio Team Developer

Application cliente de Visual Studio Team System axée sur le rôle du développeur d'entreprise. Grâce à Visual Studio Team Edition for Developers, un développeur peut utiliser le suivi des éléments de travail, la fonction de génération (build) et le contrôle de code source. Ce sont les principales demandes à considérer dans la planification de Team Foundation Server. Si vous avez préparé convenablement le serveur pour les impératifs de suivi des éléments de travail et le contrôle de code source de votre équipe, aucune planification serveur supplémentaire n'est nécessaire pour prendre en charge Visual Studio Team Edition for Developers.

Pour plus d'informations, consultez Documentation Team Edition for Developers.
Visual Studio Team Test

Application cliente de Visual Studio Team System axée sur le rôle de testeur. Grâce à Visual Studio Team Edition for Testers, un testeur utilise les fonctionnalités de suivi des éléments de travail de Team Foundation. Ce sont les principales demandes à considérer dans la planification de Team Foundation Server. Si vous avez préparé convenablement le serveur pour les impératifs de suivi des éléments de travail et le contrôle de code source de votre équipe, aucune planification serveur supplémentaire n'est nécessaire pour prendre en charge Visual Studio Team Edition for Testers.

Pour plus d'informations sur l'application cliente, consultez Documentation Team Edition for Testers.

En outre, un administrateur du serveur peut jouer un rôle dans l'installation et la configuration d'une plate-forme de test. Une plate-forme de test est un groupe d'ordinateurs composé d'un contrôleur et d'agents. Pour plus d'informations, consultez À propos du contrôleur et des agents. Pour plus d'informations sur l'installation et la configuration, consultez installguide.htm sur le disque Team Test Charge Agent Installation.

Les résultats du test de charge sont stockés dans un ensemble de tables dans la base de données SQL. Selon la quantité de données de charge qui sont stockées régulièrement, un administrateur du serveur peut avoir à planifier l'installation et la maintenance du magasin des résultats des tests de charge. Pour plus d'informations, consultez À propos du magasin des résultats des tests de charge.
Team Explorer

Application cliente Visual Studio pour la gestion et l'analyse des projets logiciels. Team Explorer est une application cliente pour les utilisateurs qui n'ont pas besoin de l'installation de clients basés sur les rôles de Visual Studio Team System, tels que Visual Studio Team Edition for Testers, mais qui souhaitent accéder aux fonctions de Team Foundation Server.

Les principaux utilisateurs de Team Explorer sont les chefs de projet et les analystes. Team Explorer vous fournit une vue organisée de vos projets d'équipe. Par exemple, un projet d'équipe créé à l'aide des modèles du processus MSF for Agile Software Development affiche les nœuds suivants :

  • Éléments de travail Ce nœud permet d'ajouter des éléments de travail, ainsi que de créer et d'afficher des requêtes sur la base de données des éléments de travail.

  • Documents Ce nœud permet d'accéder à des documents, tels que des spécifications fonctionnelles et des évaluations de risques, qui sont stockés sur le portail du projet.

  • Rapports Ce nœud fournit l'accès aux rapports qui contiennent des métriques pour le projet d'équipe.

  • Builds d'équipe Ce nœud permet d'accéder aux builds publiques de votre projet d'équipe.

  • Contrôle de code source Ce nœud permet d'accéder à la hiérarchie de gestion du contrôle de code source pour les projets d'équipe.

Les utilisateurs secondaires de Team Explorer sont des développeurs qui n'utilisent pas Visual Studio Team System, par exemple les développeurs qui utilisent Visual Studio 2005 Professional Edition ou Standard Edition. Pour plus d'informations, consultez Utilisation de l'Explorateur d'équipes.

Voir aussi

Autres ressources

Configuration requise du serveur Team Foundation Server


Topologies de Team Foundation Server

Topologies de Team Foundation Server
Voir aussi
DropDown image

Team Foundation Server est à même d'assurer les fonctionnalités suivantes : contrôle de version, suivi des éléments de travail, build d'équipe, site Web de projet d'équipe, création de rapport et fonctions de gestion de projets dans divers paramètres déployés, du relativement simple au très complexe. Cette rubrique fournit des liens vers des rubriques traitant des topologies de serveurs Team Foundation et des exemples qui illustrent divers niveaux de complexité.

Dans cette section

Topologies prises en charge pour Team Foundation Server

Décrit des topologies qui sont prises en charge pour les installations de Team Foundation Server.

Topologies non prises en charge pour Team Foundation Server

Explique les topologies de Team Foundation Server qui ne sont pas prises en charge.

Topologie Team Foundation Server simple

Décrit une topologie relativement simple de Team Foundation Server.

Topologie Team Foundation Server modérée

Montre une topologie modérément complexe de Team Foundation Server .

Topologie Team Foundation Server complexe

Décrit une topologie très complexe de Team Foundation Server .

Voir aussi

Autres ressources

Vue d'ensemble du produit Team Foundation Server


Topologies prises en charge pour Team Foundation Server

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Topologies prises en charge pour Team Foundation Server
Voir aussi
Image de liste déroulante

Team Foundation Server est pris en charge dans diverses topologies d'installation. Cette rubrique décrit brièvement les impératifs courants pour toutes les topologies prises en charge et décrit quelques-unes des configurations topologiques possibles.

Topologies prises en charge

L'impératif principal pour une topologie de Team Foundation Server prise en charge est que la couche Application et la couche Données soient installées dans le même domaine, mais elles peuvent être sur des nœuds de serveur identiques ou distincts. les ordinateurs de Team Foundation Server doivent utiliser Windows 2003 Server SP1 comme système d'exploitation. Les éditions prises en charge sont les suivantes : Standard, Enterprise et Datacenter. La Web Edition n'est pas prise en charge.

Les topologies prises en charge pour Team Foundation Server peuvent être relativement simples, comme une installation de la couche Application et de la couche Données sur un nœud de serveur unique qui prend en charge plusieurs clients dans un domaine unique, ou elles peuvent être assez complexes, en incorporant des éléments tels que les serveurs de builds de Team Foundation, des serveurs de l'Agent de charge de Team Edition for Testers, des serveurs proxy de contrôle de code source et des composants de basculement, et la prise en charge de clients dans plusieurs domaines. Vous pouvez consulter des exemples de topologies Team Foundation Server dans Topologie Team Foundation Server simple, Topologie Team Foundation Server modéréeet Topologie Team Foundation Server complexe.

Voir aussi

Concepts

Topologies non prises en charge pour Team Foundation Server
Topologie Team Foundation Server simple
Topologie Team Foundation Server modérée
Topologie Team Foundation Server complexe

Autres ressources

Topologies de Team Foundation Server


Topologies non prises en charge pour Team Foundation Server
Voir aussi
Image de liste déroulante

Team Foundation Server fournit des fonctionnalités de contrôle de code source, de suivi des éléments de travail, de génération (build), de portail de projet d'équipe, de création de rapports et de gestion de projets. Si Team Foundation Server est hautement configurable et peut être déployé dans différentes topologies de serveur, certaines topologies ne sont pas recommandées et ne sont donc pas prises en charge. Cette rubrique décrit les topologies non prises en charge pour Team Foundation Server.

Topologies non prises en charge pour Team Foundation Server

Les topologies suivantes ne sont pas recommandées et ne sont pas prises en charge. Pour plus d'informations sur les topologies prises en charge, consultez Topologies prises en charge pour Team Foundation Server.

  • Le clustering NLDB pour la couche Application n'est pas pris en charge.

  • La répartition des services Web de la couche Application entre différents ordinateurs n'est pas prise en charge. Tous les services Web de la couche Application doivent être déployés sur le même serveur.

  • Les instances multiples de Team Foundation Server sur un ordinateur physique unique ne sont pas prises en charge.

  • Le stockage des bases de données de Team Foundation Server sur des ordinateurs de bases de données séparés n'est pas pris en charge. Tous les projets doivent résider sur un seul groupe de serveurs Team Foundation et ne peuvent pas être déployés dans plusieurs groupes.

  • L'utilisation d'une infrastructure SharePoint Portal Server existante pour héberger le portail de projet d'équipe n'est pas prise en charge. Il est recommandé de créer un serveur Team Foundation dédié à l'infrastructure de SharePoint Portal Server.

  • Le déploiement du nœud de serveur de couche Application et du nœud de serveur de couche Données d'une seule instance de Team Foundation Server dans des domaines séparés n'est pas pris en charge.

  • Le déploiement de Team Foundation Server sur Windows Server 2003 Web Edition n'est pas pris en charge. Vous devez utiliser Windows Server 2003 ou Windows 2003 R2 Server.

Voir aussi

Concepts

Topologies prises en charge pour Team Foundation Server

Autres ressources

Topologies de Team Foundation Server


Topologie Team Foundation Server complexe

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Topologie Team Foundation Server complexe
Voir aussi
Image de liste déroulante

Cette rubrique décrit une topologie complexe de Team Foundation Server, avec les composants Team Foundation Server installés dans des nœuds serveurs et accessibles par les clients dans plusieurs domaines à des sites physiques géographiquement distants. Un proxy de contrôle de code source est installé en plus des composants de basculement supplémentaires.

Topologie de serveur complexe

Le diagramme suivant illustre une topologie complexe de Team Foundation Server :

Topologie de serveur complexe

Cet exemple de topologie est semblable à celui de la topologie modérée (consultez Topologie Team Foundation Server modérée) dans la mesure où les services Team Foundation Server sont déployés sur un seul nœud de serveur de couche Application alors que les bases de données Team Foundation Server sont installées sur un nœud de serveur de couche Données séparé, avec Team Foundation Build et la plate-forme de test de l'équipe (agents) déployés à des nœuds de serveur supplémentaires. En outre, des composants de basculement ont été ajoutés. Un serveur de secours de couche Application a été ajouté, tout comme une couche Données avec des technologies de mise en miroir ou de clustering SQL.

Dans l'exemple de diagramme, un domaine enfant nommé Europe.Contoso.com représente un domaine enfant géographiquement distant qui utilise une connexion à bande passante limitée. Dans la mesure où l'obtention d'une référence auprès du composant de contrôle de code source de Team Foundation Server peut prendre beaucoup de temps dans ces conditions de bande passante limitée, un serveur proxy de contrôle de code source est installé dans le domaine enfant pour agir en tant que cache de proxy de fichiers sources. Toutes les requêtes du client vont directement à la couche Application, à l'exception des requêtes 'get' du code source qui sont dirigées vers le serveur proxy de contrôle de code source, qui place alors en cache tous les fichiers sources qu'il télécharge.

Dans cet exemple, la topologie s'applique également à la tolérance de panne et comporte des composants de basculement configurés. Un serveur de secours de couche Application fournit les fonctions de basculement manuelles en cas de défaillance du serveur de couche Application principal. Le basculement de couche Données est assuré grâce aux fonctions de basculement de SQL Server 2005 en utilisant le clustering.

Voir aussi

Concepts

Topologie Team Foundation Server simple
Topologie Team Foundation Server complexe

Autres ressources

Topologies de Team Foundation Server
Vue d'ensemble du produit Team Foundation Server


Topologie Team Foundation Server modérée

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Topologie Team Foundation Server modérée
Voir aussi
Image de liste déroulante

Cette rubrique décrit une topologie de Team Foundation Server modérément complexe, avec les composants de Team Foundation Server installés sur des nœuds de serveur séparés et accessibles par des clients dans plusieurs domaines.

Topologie de serveur modérée

Le diagramme suivant illustre une topologie modérément complexe de Team Foundation Server :

Topologie de serveur modérée

Dans cet exemple, les services de Team Foundation Server sont déployés sur un nœud de serveur de couche Application et les bases de données de Team Foundation Server sont installées sur un nœud de serveur de couche Données séparé. Team Foundation Build et la plate-forme de test de l'équipe (agents) sont déployés sur des nœuds de serveur supplémentaires. Dans ce diagramme, le domaine ContosoTest.Contoso.com représente un domaine enfant localisé dans le même bureau que le domaine parent. Le domaine enfant a une relation d'approbation transitive bidirectionnelle avec Contoso.com. Les utilisateurs/clients dans le domaine enfant peuvent accéder au serveur et se faire authentifier automatiquement à l'aide de l'authentification intégrée de Windows. Dans cette configuration, la présence d'un proxy de contrôle de code source n'étant pas nécessaire, celui-ci n'est pas installé.

Les topologies de cette complexité sont des cibles pour les grandes équipes de développement qui comptent entre 50 et 500 utilisateurs.

Voir aussi

Concepts

Topologie Team Foundation Server simple
Topologie Team Foundation Server complexe

Autres ressources

Topologies de Team Foundation Server
Vue d'ensemble du produit Team Foundation Server


Topologie Team Foundation Server simple

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Topologie Team Foundation Server simple
Voir aussi
Image de liste déroulante

Cette rubrique décrit une topologie relativement simple de Team Foundation Server, avec le serveur et clients qui sont tous contenus dans un seul domaine.

Topologie de serveur simple

Le diagramme suivant illustre une topologie simple de Team Foundation Server :

Topologie de serveur simple

Dans cet exemple, tous les composants serveur, sauf le proxy de contrôle de code source, sont déployés sur un nœud de serveur unique et sont accessibles à partir de connexions clientes dans le même domaine. Dans cette configuration, un proxy de contrôle de code source n'est pas requis et n'est pas installé.

Dans cette configuration, le serveur Team Foundation Build et les composants de la plate-forme de test de l'équipe peuvent être installés soit sur le serveur unique Team Foundation Server soit sur un ou plusieurs clients. Cette configuration est adaptée le mieux aux petits ateliers de développement ou aux projets pilotes.

Voir aussi

Concepts

Topologie Team Foundation Server modérée
Topologie Team Foundation Server complexe

Autres ressources

Topologies de Team Foundation Server
Vue d'ensemble du produit Team Foundation Server


Personnalisation de Team Foundation Server pour vos affaires

Personnalisation de Team Foundation Server pour vos affaires
Voir aussi
DropDown image

Au cœur de la personnalisation de Team Foundation Server se trouve le concept d'un processus. Un processus est une méthode établie que votre organisation a développée (vaguement organisée ou très formelle) pour mener à bien un projet. La section suivante décrit comment Team Foundation Server prend en charge les processus. Elle documente également comment sélectionner un processus prédéfini, et comment le modifier pour l'adapter aux besoins spécifiques de votre organisation.

Dans cette section

Vue d'ensemble du processus

Décrit ce qu'est un processus, et comment Team Foundation Server le prend en charge.

Choix d'un modèle de processus

Décrit comment déterminer le modèle de processus à sélectionner pour un projet.

Personnalisation des modèles de processus

Décrit comment modifier un modèle de processus prédéfini pour mieux refléter le processus de votre organisation.

Voir aussi

Concepts

Architecture des modèles de processus
Vue d'ensemble de la personnalisation des modèles de processus

Autres ressources

Sécurisation de Team Foundation Server
Gestion de Team Foundation Server


Vue d'ensemble du processus

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Vue d'ensemble du processus
Voir aussi
Image de liste déroulante

Dans le cadre de la planification du déploiement de Team Foundation Server, vous devez déterminer quels sont les processus que vous voulez utiliser pour chacun de vos projets sur votre serveur Team Foundation. Vous pouvez choisir d'utiliser un modèle de processus différent lorsque vous créez chaque projet, ou vous pouvez choisir d'utiliser le même modèle de processus pour tous vos projets.

Qu'est-ce qu'un processus ?

La plupart des entreprises ont des procédures établies pour faire le travail, cela va des tâches vaguement organisées aux systèmes hautement formalisés. Ces méthodes de travail sont appelées des processus, et l'ensemble des processus est appelé processus. Les processus se développent au fil du temps pour répondre aux besoins des entreprises. Beaucoup de sociétés et d'organisations ont formalisé le processus et le guide de processus pour aider les entreprises à travailler plus efficacement. Si vous avez un processus très peu formel dans votre entreprise actuelle, ou une grande quantité de développement de processus personnalisé, vous pouvez utiliser Team Foundation et Team Foundation Server pour mieux prendre en charge et développer vos propres processus d'entreprise.

Team Foundation et Microsoft Visual Studio 2005 s'intègrent avec Microsoft Solutions Framework (MSF), un ensemble très personnalisable et évolutif de processus de développement de logiciel, de principes et de méthodes éprouvées conçus pour offrir le type d'aide désiré par l'utilisateur quand il en a besoin. Pour plus d'informations sur Microsoft Solutions Framework et le processus, consultez Visual Studio 2005 Team System: Microsoft Solutions Framework (http://go.microsoft.com/fwlink/?LinkId=51459).

Modèles de processus

Lorsque vous créez un nouveau projet dans Team Foundation Server, vous pouvez par défaut choisir entre deux modèles de processus différents, MSF for Agile Software Development et MSF for CMMI Process Improvement. Chacun des modèles est basé sur un processus MSF différent avec une approche philosophique différente au développement de logiciel. Ces modèles façonnent le mode d'installation et de configuration du projet. Chacun de ces modèles de processus vous fournit un jeu différent d'éléments de travail par défaut, de requêtes d'élément de travail, de modèles de produit, de rapports, de groupes de sécurité et d'aide lorsque vous créez un projet à l'aide de ce modèle.

Vous pouvez personnaliser l'un ou l'autre de ces modèles de processus pour mieux répondre aux besoins de votre entreprise. Pour plus d'informations sur la gestion des modèles de processus, consultez Gestionnaire de modèles de processus et Personnalisation des modèles de processus.

Processus et Team Foundation Server Administrator

Bien qu'il puisse paraître comme un choix simple pendant la création de projet, le choix d'un processus à suivre n'est pas aussi facile que de choisir aléatoirement un modèle de processus dans Team Foundation Server. Le choix de processus et le modèle de processus doivent être basés sur le mode de fonctionnement de votre entreprise, les besoins actuels de votre entreprise et la façon dont vous souhaitez voir votre entreprise fonctionner dans le futur. Toutefois, les décisions concernant le choix du processus ne sont habituellement pas laissées à l'administrateur Team Foundation Server. En tant qu'administrateur Team Foundation Server, vous serez plus préoccupé par l'implémentation des choix de processus qui sont faits et souhaiterez comprendre comment le choix de processus affecte le déploiement et le fonctionnement de Team Foundation Server.

Voir aussi

Concepts

Choix d'un modèle de processus

Autres ressources

Gestionnaire de modèles de processus
Personnalisation des modèles de processus


Choix d'un modèle de processus

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Choix d'un modèle de processus
Voir aussi
Image de liste déroulante

Le choix du modèle de processus à utiliser lors de la création d'un nouveau projet dans Team Foundation Server est une action simple qui a de nombreuses conséquences profondes. Chaque modèle de processus dans Team Foundation Server fournit un jeu différent d'éléments de travail par défaut, de requêtes d'éléments de travail, de modèles de produit, de rapports, de groupes de sécurité et d'aide. De plus, chaque processus a une philosophie distincte et différente d'application pratique du développement logiciel qui dicte comment le modèle du processus fonctionne dans Team Foundation Server.

Il existe beaucoup de ressources disponibles sur les processus, le guide de processus et le choix du processus approprié pour les besoins de votre entreprise. Le fait de déterminer le processus correct pour les besoins de votre entreprise peut être une tâche longue et complexe, en particulier si vous ne disposez pas actuellement de processus documentés ou d'une philosophie de processus globale. Toutefois, vous devez choisir un modèle de processus avant de pouvoir créer un projet dans Team Foundation Server. Si cette rubrique ne va pas dans le détail pour déterminer le processus global correspondant aux besoins de votre entreprise, elle peut vous aider à choisir le modèle de processus à utiliser lors de la création de vos premiers projets dans Team Foundation Server.

Choix initial du modèle de processus

Vous pouvez choisir entre deux modèles de processus différents dans Team Foundation Server. Chacun des modèles décrits ci-dessous est basé sur une approche philosophique différente en matière de développement logiciel. Choisissez le modèle de processus qui s'approche le plus des propres méthodes et besoins de votre entreprise. Vous pouvez également choisir d'étudier d'autres alternatives aux modèles de processus par défaut.

MSF for Agile Software Development

Le modèle de processus MSF for Agile Software Development a été créé par un groupe de professionnels du logiciel connus sous le nom d'Agile Alliance, qui pensent que les individus sont plus importants que les processus et que la capacité à s'adapter rapidement au changement est critique pour le succès. MSF for Agile Software Development est optimisé pour les petits projets selon un calendrier de livraison rapide. Vous pouvez, le cas échéant, choisir le modèle MSF for Agile Software Development si votre entreprise :

  • Ne dispose pas d'une grande quantité de processus documentés et ne manifeste pas d'intérêt pour le développement de processus formels.

  • A de petites équipes de développement de logiciel.

  • Peut prendre en charge de nombreuses petites équipes de développement qui travaillent dans plusieurs directions.

  • A des cycles de développement de logiciel courts (mesurés en semaines ou mois).

  • Prend en charge plusieurs versions logicielles dans une année civile.

Pour plus d'informations, consultez Visual Studio Team System: MSF for Agile Software Development (http://go.microsoft.com/fwlink/?LinkId=51460).

MSF for CMMI Process Improvement

Le modèle de processus MSF for CMMI Process Improvement a été créé dans le monde de l'entreprise en grande partie en dehors de toute culture de développement logiciel par des professionnels qui croient que le fait de formaliser et d'améliorer les méthodes conseillées à travers les leçons apprises est critique pour le succès à long terme. Le cas échéant, vous pouvez choisir le modèle MSF for CMMI Process Improvement si votre entreprise :

  • Souhaite évaluer ses méthodes d'entreprise actuelles.

  • A de grandes équipes de développement logiciel.

  • Doit intégrer des groupes ou des organisations traditionnellement séparés.

  • Peut fournir une aide aux processus de qualité.

  • A de plus longs cycles de développement logiciel.

Pour plus d'informations, consultez Visual Studio Team System: MSF for CMMI Process Improvement (http://go.microsoft.com/fwlink/?LinkId=51462).

Autres options

Il existe beaucoup d'autres modèles de processus en dehors de MSF for Agile Software Development et de MSF for CMMI Process Improvement. Votre entreprise utilise peut-être déjà l'un de ces autres modèles de processus. Quelques-uns de ces modèles de processus peuvent fournir un modèle de processus que vous pouvez télécharger vers Team Foundation Server. Si ce n'est pas le cas, vous pouvez modifier les modèles de processus de Team Foundation Server afin de mieux refléter votre modèle de processus actuel. Pour plus d'informations sur la gestion des modèles de processus, consultez Gestionnaire de modèles de processus et Personnalisation des modèles de processus.

Modification du processus et des modèles de processus au fil du temps

Que vous choisissiez MSF for Agile Software Development, MSF for CMMI Process Improvement ou votre propre modèle de processus personnalisé lorsque vous créez un projet initial, vous pouvez constater au fil du temps qu'il existe certaines choses que vous aimeriez faire différemment. Par exemple, vous pouvez découvrir que vous avez besoin d'un type différent d'élément de travail, ou que vous aimez les flux de travail dans MSF for Agile Software Development, mais aimeriez vraiment que quelques-uns des rapports soient disponibles dans MSF for CMMI Process Improvement. Ce type de croissance et d'évolution de processus est prévisible dans toute entreprise. Team Foundation Server prend en charge le changement de ses modèles de processus pour tenir compte de ces types de modifications. Pour plus d'informations sur la personnalisation des modèles de processus pour votre entreprise, consultez Personnalisation des modèles de processus.

Voir aussi

Concepts

Vue d'ensemble du processus

Autres ressources

Personnalisation des modèles de processus


Configuration requise du serveur Team Foundation Server

Configuration requise du serveur Team Foundation Server
Voir aussi
DropDown image

Les rubriques de cette section fournissent une aide de planification pour le déploiement et l'exploitation de Team Foundation Server. Elles incluent une aide sur la configuration matérielle requise, les topologies prises en charge, les modèles d'authentification ainsi que la sauvegarde et la restauration. Pour de l'aide sur des fonctionnalités spécifiques et le fonctionnement, consultez Vue d'ensemble du produit Team Foundation Server.

Dans cette section

Configuration requise pour le serveur Team Foundation

Fournit des liens vers les informations nécessaires lors de la planification de serveurs Visual Studio Team System.

Spécifications du client pour Team Foundation

Fournit des liens vers les informations nécessaires lors de la planification de clients Visual Studio Team System.

Rubriques connexes

Composants Team Foundation Server

Décrit les composants qui constituent les serveurs de Team Foundation.

Clients Team Foundation Server

Décrit les quatre applications clientes principales pour accéder à Team Foundation Server.

Voir aussi

Autres ressources

Vue d'ensemble du produit Team Foundation Server


Configuration requise pour le serveur Team Foundation

Configuration requise pour le serveur Team Foundation
Voir aussi
DropDown image

Cette rubrique fournit des liens vers des informations nécessaires lors de la planification de serveurs pour Visual Studio Team System.

Dans cette section

Configuration du système d'exploitation

Décrit les systèmes d'exploitation serveurs qui sont pris en charge pour l'installation de Team Foundation Server.

Impératifs de domaine et de groupe de travail

Traite des approches d'authentification que Team Foundation Server prend en charge.

Configuration matérielle et considérations sur les performances

Présente les indications de matériel pour plusieurs configurations de déploiement de Team Foundation Server.

Autres configurations logicielles et considérations

Présente les configurations logicielles requises pour plusieurs configurations de déploiement de Team Foundation Server.

Spécification de la langue et considérations

Décrit les combinaisons de systèmes d'exploitation et de langues de Team Foundation Server qui sont prises en charge.

Impératifs de sauvegarde et considérations

Décrit les ressources nécessaires pour sauvegarder un serveur exécutant Team Foundation Server.

Configuration du réseau et considérations

Décrit comment Team Foundation Server interagit avec autre logiciel réseau.

Rubriques connexes

Spécifications du client pour Team Foundation

Voir aussi

Autres ressources

Configuration requise du serveur Team Foundation Server


Configuration du système d'exploitation

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Configuration du système d'exploitation
Voir aussi
Image de liste déroulante

Les systèmes d'exploitation serveurs suivants sont pris en charge pour l'installation de Team Foundation Server :

  • Windows Server 2003, Standard Edition, avec SP1 installé

  • Windows Server 2003 R2, Standard Edition

  • Windows Server 2003, Enterprise Edition, avec SP1 installé

  • Windows Server 2003 R2, Enterprise Edition

  • Windows Server 2003 Datacenter avec SP1 installé

  • Windows Server 2003 R2 Datacenter

De plus, le serveur Team Foundation Build est pris en charge dans WOW64 dans les éditions x64 de Windows Server 2003, et la couche Données de Team Foundation Server est prise en charge en mode natif dans les éditions x64 de Windows Server 2003 et Windows Server 2003 pour les systèmes basés sur Itanium.

Remarque Remarque

Windows Server 2003 Web Edition et Windows Server 2003 R2 Web Edition, ne sont pas pris en charge.

Configuration du système d'exploitation de la plate-forme de test Team Test

Système d'exploitation | Contrôleur | Agent
Windows XP Professionnel avec le Service Pack 2 installé | Oui | Oui
Windows Server 2003 | Oui | Oui
Windows Server 2003 avec le SP1 installé | Oui | Oui
Windows 2000 avec le SP4 installé | Non | Oui

Voir aussi

Autres ressources

Configuration requise pour le serveur Team Foundation


Impératifs de domaine et de groupe de travail

Impératifs de domaine et de groupe de travail
Voir aussi
DropDown image

Cette section traite de l'approche d'authentification que Team Foundation Server prend en charge.

Il existe deux principes sous-jacents critiques pour les modèles d'authentification de Team Foundation Server : authentification et autorisation. L'authentification se rapporte à la manière dont le système d'exploitation détermine la véritable identité d'un utilisateur. Il est critique de déterminer que les utilisateurs sont réellement ce qu'ils prétendent être. L'autorisation désigne la manière dont le système d'exploitation détermine ce que cet utilisateur est autorisé à faire. L'authentification et l'autorisation sont souvent confondues, mais la distinction est importante dans le cadre de cet exposé.

En général, Team Foundation Server utilise l'authentification intégrée de Windows. Cela signifie qu'une fois que les utilisateurs ont ouvert une session dans le système d'exploitation avec leurs noms d'utilisateurs et mots de passe, ils sont considérés étant authentifiés par Team Foundation Server. En d'autres termes, il n'y a aucune étape d'ouverture de session séparée pour se connecter à Team Foundation Server. L'autorisation est, cependant, contrôlée directement par Team Foundation Server à la place du système d'exploitation ; par conséquent, bien que les utilisateurs puissent accéder à un serveur Team Foundation Server sans procédure supplémentaire de connexion, ils doivent obtenir des autorisations explicites avant de pouvoir lire ou écrire des données dans Team Foundation Server.

Les sections suivantes décrivent les divers modèles d'authentification pris en charge par Team Foundation Server.

Dans cette section

Configuration du domaine pour Team Foundation Server

Décrit les impératifs du déploiement de Team Foundation Server à l'aide de groupes de travail.

Impératifs de groupe de travail pour Team Foundation Server

Décrit les impératifs du déploiement de Team Foundation Server à l'aide d'Active Directory.

Voir aussi

Autres ressources

Configuration requise pour le serveur Team Foundation


Configuration du domaine pour Team Foundation Server

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Configuration du domaine pour Team Foundation Server
Voir aussi
Image de liste déroulante

Un déploiement de domaine Active Directory est prévu pour les équipes de grande taille ou les départements pour lesquels la gestion individuelle de grands groupes d'utilisateurs serait prohibitive. Dans une topologie de déploiement de domaine Active Directory, il y a le serveur qui agit comme contrôleur de domaine Active Directory, qui est indépendant de Visual Studio Team System, et le serveur qui exécute Team Foundation Server.

Remarque Important

Team Foundation Server doit être déployé dans un domaine Active Directory en mode natif de Windows 2003. Visual Studio Team System et Team Foundation Server ne sont pas compatibles avec les contrôleurs de domaine Windows NT 4.0.

Configurations de domaine non prises en charge

  • Contrôleurs de domaine de Windows NT 4.0.

  • Contrôleurs de domaine Windows 2000 en mode mixte (valeur par défaut).

  • Combinaison de contrôleurs de domaine Windows 2000 et de contrôleurs de domaine Windows NT 4.0.

  • Contrôleurs de domaine Windows Server 2003 en mode Windows 2000.

Voir aussi

Concepts

Impératifs de groupe de travail pour Team Foundation Server

Autres ressources

Impératifs de domaine et de groupe de travail


Impératifs de groupe de travail pour Team Foundation Server

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Impératifs de groupe de travail pour Team Foundation Server
Voir aussi
Image de liste déroulante

Le déploiement de groupe de travail est prévu pour les équipes ou les départements de petite taille qui utilisent des groupes de travail à la place des domaines pour réduire leurs coûts administratifs. Un déploiement de groupe de travail peut également être envisagé pour les projets pilotes ou les évaluations afin d'éviter d'impliquer une organisation informatique centrale et la nécessité de configurer Active Directory.

Pour un déploiement de groupe de travail, Team Foundation Server doit être déployé sur un ordinateur unique avec un système d'exploitation 32 bits. La configuration à deux ordinateurs n'est pas prise en charge. En outre, tous les utilisateurs de Team Foundation Server doivent être créés en tant que comptes locaux sur le serveur exécutant Team Foundation Server.

Les ordinateurs clients peuvent faire partie de groupes de travail différents de ceux de l'ordinateur de Team Foundation Server. Toutefois, dans ce cas, les clients doivent se connecter et fournir leurs informations d'identification de compte Team Foundation Server.

Voir aussi

Concepts

Configuration du domaine pour Team Foundation Server

Autres ressources

Impératifs de domaine et de groupe de travail


Configuration matérielle et considérations sur les performances

Configuration matérielle et considérations sur les performances
Voir aussi
DropDown image

Les indications présentées ici sont appropriées pour presque tous les déploiements. Elles ont été testées et validées spécifiquement pour les environnements qui comptent moins de 500 utilisateurs sur un seul Team Foundation Server. Le serveur qui exécute Team Foundation Server doit disposer d'une connexion réseau fiable avec une bande passante d'au moins 1 Mbit/s et une latence maximale de 350 ms.

Si votre environnement ne répond pas à ces critères, vous devez étudier avec soin les implications avant de déployer Team Foundation Server. Les considérations doivent inclure un matériel plus important que celui qui est recommandé ici, pour améliorer la fiabilité de votre réseau et la bande passante, et l'utilisation de plusieurs serveurs qui exécutent Team Foundation Server.

Plusieurs hypothèses et considérations ont été faites pour déterminer la configuration matérielle requise.

  • Les nouveaux serveurs achetés en 2004 doivent être utilisables pour Team Foundation Server en 2005.

  • Les utilisateurs doivent mettre à niveau les serveurs achetés avant 2004.

  • Au moins, un ordinateur physique sera consacré aux opérations de Team Foundation Server.

  • Les serveurs huit voies ne répondent pas à l'objectif de « coût raisonnable » pour les équipes de 500 ou moins.

Dans cette section

Configuration du serveur de couche Application pour Team Foundation

Indications de matériel pour les déploiements de couche Application de Team Foundation Server.

Configuration du serveur de couche Données pour Team Foundation

Indications de matériel pour les déploiements de couche Données de Team Foundation Server.

Configuration du serveur pour Team Foundation Build

Indications de matériel pour les déploiements de serveurs types de Team Foundation Build.

Configuration de la plate-forme de test Team Test pour Team Foundation Server

Indications de matériel pour les déploiements de plate-forme de test Team Test de Team Foundation Server.

Voir aussi

Autres ressources

Configuration requise pour le serveur Team Foundation


Configuration du serveur de couche Application pour Team Foundation

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Configuration du serveur de couche Application pour Team Foundation
Voir aussi
Image de liste déroulante

Les indications présentées ici sont appropriées pour presque tout déploiement de la couche Application de Team Foundation Server. Elles sont testées et validées spécifiquement pour les environnements qui comptent moins de 500 utilisateurs sur un seul Team Foundation Server. Le serveur qui exécute Team Foundation Server doit disposer d'une connexion réseau fiable avec une bande passante d'au moins 1 Mbit/s et une latence maximale de 350 ms.

Recommandations de matériel

Configuration | UC | DD | Mémoire | Commentaires
Moins de 20 utilisateurs | processeur unique, 2,2 GHz | 8 Go | 1 Go | Partagé avec la couche Données
20 à 50 utilisateurs | processeur unique, 2,2 GHz | 30 Go | 2 Go | Partagé avec la couche Données
50 à 250 utilisateurs | processeur unique, 2,2 GHz | 20 Go | 1 Go | Séparé de la couche Données
250 à 500 utilisateurs | biprocesseur, 2,2 GHz | 40 Go | 2 Go | Séparé de la couche Données

Voir aussi

Concepts

Configuration du serveur de couche Données pour Team Foundation

Autres ressources

Configuration matérielle et considérations sur les performances


Configuration du serveur de couche Données pour Team Foundation

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Configuration du serveur de couche Données pour Team Foundation
Voir aussi
Image de liste déroulante

Les indications présentées ici sont appropriées pour presque tous les déploiements de la couche Données de Team Foundation Server. Elles ont été testées et validées spécifiquement pour les environnements qui comptent moins de 500 utilisateurs sur un seul Team Foundation Server. Le serveur qui exécute Team Foundation Server doit disposer d'une connexion réseau fiable avec une bande passante d'au moins 1 Mbit/s et une latence maximale de 350 ms.

Recommandations de matériel

Configuration | Processeur | DD | Mémoire | Commentaires
Moins de 20 utilisateurs | processeur unique, 2,2 GHz | 8 Go | 1 Go | En partage avec la couche Application
20 à 50 utilisateurs | processeur unique, 2,2 GHz | 30 Go | 2 Go | En partage avec la couche Application
50 à 250 utilisateurs | biprocesseur, 2,2 GHz | 80 Go | 2 Go | Séparé de la couche Application
250 à 500 utilisateurs | quadriprocesseur, 2,2 GHz | 150 Go | 4 Go | Séparé de la couche Application

Voir aussi

Concepts

Configuration du serveur de couche Application pour Team Foundation

Autres ressources

Configuration matérielle et considérations sur les performances


Configuration du serveur pour Team Foundation Build

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Configuration du serveur pour Team Foundation Build
Voir aussi
Image de liste déroulante

Les performances de génération (build) varieront grandement selon la taille de la base de code source et la complexité du processus de génération (build). Les indications présentées ici sont destinées aux déploiements serveur types de Team Foundation Build.

Recommandations de matériel

Configuration | Processeur | Mémoire | Durée de génération (build)
Moins de 50 utilisateurs | 1,5 GHz (766 MHz minimum) | 512 Mo (256 Mo minimum) | Moins que 0,5 heure
50 à 250 utilisateurs | 2,6 GHz (2 GHz minimum) | 1 Go (512 Mo minimum) | 0,5 hr - 2 hrs
250 à 500 utilisateurs | biprocesseur, 2,2 GHz (2 GHz minimum) | 2 Go (512 Mo minimum) | 2 - 7 hrs

Voir aussi

Autres ressources

Configuration matérielle et considérations sur les performances


Configuration de la plate-forme de test Team Test pour Team Foundation Server

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Configuration de la plate-forme de test Team Test pour Team Foundation Server
Voir aussi
Image de liste déroulante

Les ressources mémoire et processeur limitent la charge que l'Agent de test peut générer dans une plate-forme de test Team Test. Le service de contrôleur lui-même n'effectue pas beaucoup de travail, toutefois, la base de données du contrôleur a besoin de ressources considérables pour gérer les données et les agents impliqués dans le scénario de test de charge.

Pour plus d'informations sur les configurations matérielle et logicielle requises pour la plate-forme de test Team Test, consultez Installation des fonctionnalités de contrôleur et d'agent.

Voir aussi

Autres ressources

Configuration matérielle et considérations sur les performances


Autres configurations logicielles et considérations

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Autres configurations logicielles et considérations
Voir aussi
Image de liste déroulante

Les éléments suivants sont des configurations logicielles requises pour les ordinateurs de Team Foundation Server.

Composant | Version
SQL Server (préalable) | 2005 (Standard, Enterprise ou Datacenter)
Windows SharePoint Services | 2.0 SP1 ou SP2
ASP.NET / IIS (partie de Windows Server 2003) | 6.0
.NET Framework (partie de Team Foundation Server) | 2.0
Remarque Remarque

SQL Server 2005 Standard est inclus avec chaque copie de Team Foundation Server.

Windows SharePoint Services doit être téléchargé et installé suivant les instructions fournies dans le Guide d'installation Team Foundation Server avant l'installation de Team Foundation Server.

Seul le serveur d'applications requiert les services IIS (Internet Information Services) et ASP.NET.

Configuration logicielle requise du serveur de builds

Composant | Version
.NET Framework (MSBuild) | 2.0

Configuration logicielle requise de Team Test

Le contrôleur requiert :

Composant | Version
SQL Express | 2005
.NET Framework | 2.0

L'agent requiert :

Composant | Version
.NET Framework | 2.0

Voir aussi

Autres ressources

Configuration requise pour le serveur Team Foundation


Spécification de la langue et considérations

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Spécification de la langue et considérations
Voir aussi
Image de liste déroulante

Un déploiement logique de Team Foundation Server, que ce soit sur un ou sur deux ordinateurs, peut être configuré pour prendre en charge une seule langue. Si Team Foundation Server est déployé sur deux ordinateurs, les deux ordinateurs requièrent la même configuration pour à la fois la langue de Team Foundation Server et la langue du système d'exploitation.

Un serveur Team Foundation Server en anglais peut être installé sur un système d'exploitation anglais ou japonais. Une version localisée de Team Foundation Server doit être installée sur un système d'exploitation de la même langue ou sur un système d'exploitation anglais. Par exemple, si vous déployez un serveur Team Foundation Server en japonais, il peut être installé uniquement sur une version japonaise ou anglaise du système d'exploitation.

Vous devez installer le module de prise en charge linguistique Windows SharePoint Services qui correspond à la langue de Team Foundation Server. Par exemple, si vous déployez la version anglaise de Team Foundation Server sur un système d'exploitation localisé pour une autre langue, vous devez installer le module de prise en charge linguistique anglais pour Windows SharePoint Services. Si vous déployez un serveur Team Foundation Server en japonais sur un système d'exploitation anglais, vous devez installer le module de prise en charge linguistique pour le japonais de Windows SharePoint Services.

Voir aussi

Autres ressources

Configuration requise pour le serveur Team Foundation


Impératifs de sauvegarde et considérations

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Impératifs de sauvegarde et considérations
Voir aussi
Image de liste déroulante

Cette rubrique présente les sources de données qui doivent être sauvegardées lors de la sauvegarde de Team Foundation Server. Pour effectuer la sauvegarde, vous devez mettre hors ligne le serveur exécutant Team Foundation Server pendant toute la durée de la sauvegarde afin de garantir une sauvegarde cohérente. Il existe huit bases de données relationnelles et une base de données OLAP qui doivent être sauvegardées. L'utilitaire en ligne de commande NTBackup peut être utilisé pour sauvegarder des ordinateurs Team Foundation Server. Vous devez arrêter et redémarrer manuellement les services IIS (Internet Information Services) lors de la sauvegarde et de la restauration de Visual Studio Team System. De plus, les données IIS doivent être le premier élément que vous sauvegardez et le dernier élément que vous restaurez avant de redémarrer IIS et de remettre Team Foundation Server en ligne.

Informations sur l'appartenance aux groupes

Les informations sur l'appartenance aux groupes sont stockées dans des fichiers ADAM (Active Directory Active Management) sur l'ordinateur de couche Application de Team Foundation Server et exigent des procédures de sauvegarde spéciales. Vous devez arrêter en premier IIS avant de démarrer la sauvegarde sur la couche Application. Vous pouvez exécuter ensuite NTBackup pour sauvegarder les données dans le dossier \Program Files\Microsoft ADAM\BISGSS\data.

Données du portail du projet

Les données du portail de projet sont stockées dans une base de données SQL Server 2005 sur l'ordinateur de couche Application de Team Foundation Server et requièrent les procédures Windows SharePoint Services pour faciliter la sauvegarde. Pour plus d'informations sur la façon de sauvegarder les données Windows SharePoint Services, consultez la documentation du produit pour Windows SharePoint Services.

Bases de données relationnelles Team Foundation Server

Les bases de données relationnelles de Team Foundation Server incluent des éléments de travail, le code source, les résultats de génération (build) et les rapports. Elles sont stockées dans SQL Server 2005 sur l'ordinateur de serveur de bases de données et exigent des procédures de sauvegarde SQL Server.

Base de données OLAP et Team Foundation Server

L'entrepôt de données OLAP de Team Foundation Server est géré à l'aide de SQL Server 2005 Analysis Services sur l'ordinateur de couche Données et exige les procédures de sauvegarde SQL Server Analysis Services.

Pièces jointes des éléments de travail

Les pièces jointes des éléments de travail sont stockées dans le système de fichiers sur l'ordinateur de couche Données et requièrent que vous arrêtiez en premier IIS avant de démarrer la sauvegarde.

Voir aussi

Autres ressources

Configuration requise pour le serveur Team Foundation
Sauvegarde et restauration des données de Team Foundation Server


Configuration du réseau et considérations

Configuration du réseau et considérations
Voir aussi
DropDown image

Cette section traite de la façon dont Team Foundation Server interagit avec d'autres logiciels réseau.

Dans cette section

Configuration du pare-feu pour Team Foundation

Décrit la façon dont Team Foundation Server configure le Pare-feu Windows.

Configuration des services Terminal Server pour Team Foundation

Décrit la façon dont Team Foundation Server fonctionne avec Terminal Server.

Voir aussi

Autres ressources

Configuration requise pour le serveur Team Foundation


Configuration du pare-feu pour Team Foundation

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Configuration du pare-feu pour Team Foundation
Voir aussi
Image de liste déroulante

Le programme d'installation de Team Foundation Server configure automatiquement et ouvre les ports TCP utilisés par Team Foundation Server sur le Pare-feu Windows. Toutefois, dans les entreprises et les infrastructures de centres de données, d'autres logiciels et pare-feu matériels sont couramment utilisés. Vous devez configurer physiquement tout pare-feu logiciel et matériel dans votre déploiement de Team Foundation Server pour autoriser le trafic sur les ports que Team Foundation Server utilise afin que les ordinateurs clients et les clients distants puissent se connecter à Team Foundation Server, et Team Foundation Server puisse communiquer avec les clients.

Pour plus d'informations sur les ports réseau et le trafic que vous devez configurer pour Team Foundation Server, consultez Configuration du réseau et considérations.

Voir aussi

Concepts

Examen des considérations sur la sécurité


Configuration des services Terminal Server pour Team Foundation

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Configuration des services Terminal Server pour Team Foundation
Voir aussi
Image de liste déroulante

Les applications clientes basées sur les rôles de Team Foundation Server, comme Team Edition for Architects, Team Edition for Testers, Team Edition for Developers et Team Explorer fonctionnent correctement avec les services Terminal Server.

Voir aussi

Autres ressources

Configuration du réseau et considérations


Spécifications du client pour Team Foundation

Spécifications du client pour Team Foundation
Voir aussi
DropDown image

Cette rubrique fournit des liens vers des informations nécessaires lors de la planification de clients pour Visual Studio Team System.

Dans cette section

Configuration du système d'exploitation (Guide de planification)

Décrit la configuration requise du système d'exploitation pour les clients de Visual Studio Team Foundation Server.

Impératifs de domaine et de groupe de travail (Guide de planification)

Décrit le domaine et les impératifs de groupe de travail pour les clients de Visual Studio Team Foundation Server.

Configuration matérielle et considérations sur les performances (Guide de planification)

Décrit la configuration matérielle requise pour les clients de Visual Studio Team Foundation Server.

Configuration du réseau et considérations (Guide de planification)

Décrit la configuration du système réseau pour les clients de Visual Studio Team Foundation Server.

Spécifications de la langue et considérations (Guide de planification)

Décrit les spécifications relatives à la langue et d'autres considérations pour les clients de Visual Studio Team Foundation Server.

Autres configurations logicielles et considérations (Guide de planification)

Décrit toules les autres configurations logicielles pour les clients de Visual Studio Team Foundation Server.

Rubriques connexes

Configuration requise pour le serveur Team Foundation

Voir aussi

Concepts

Planification de Team Foundation Server


Configuration du système d'exploitation (Guide de planification)

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Configuration du système d'exploitation (Guide de planification)
Voir aussi
Image de liste déroulante

Les systèmes d'exploitation clients suivants sont pris en charge pour Visual Studio Team System :

  • Windows XP Professionnel avec le Service Pack 2 installé

  • Windows Server 2003

  • Windows Server 2003 avec le Service Pack 1 (SP1) installé

Voir aussi

Concepts

Configuration matérielle et considérations sur les performances (Guide de planification)

Autres ressources

Spécifications du client pour Team Foundation
Configuration requise pour le serveur Team Foundation


Impératifs de domaine et de groupe de travail (Guide de planification)

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Impératifs de domaine et de groupe de travail (Guide de planification)
Voir aussi
Image de liste déroulante

Des actions d'utilisateur, telles que l'administration de l'espace de travail et la création de projet, sont déterminées par des autorisations. Lorsque vous créez un projet dans Team Foundation Server, quatre groupes par défaut sont créés pour ce projet, indépendamment du choix de modèle de processus effectué : Project Administrator, Contributor, Reader, et Build Services. Par défaut, chacun de ces groupes par défaut a un jeu d'autorisations défini. D'autres groupes sont créés d'après le choix de processus effectué, mais ne sont pas ajoutés au projet. Vous pouvez ajouter ces groupes selon les besoins de votre entreprise.

Pour plus d'informations, consultez Autorisations de Team Foundation Server.

Pour établir une connexion à Team Foundation Server avec tout client, vous devez être approuvé dans votre domaine ou disposer d'une approbation appropriée entre domaines ou entre forêts. Vous devez également avoir des autorisations sur le serveur de couche Application et le serveur de couche Données. En d'autres termes, vous devez avoir les mêmes autorisations que pour vous connecter via un dispositif Terminal Server.

Voir aussi

Autres ressources

Spécifications du client pour Team Foundation
Configuration requise pour le serveur Team Foundation


Configuration matérielle et considérations sur les performances (Guide de planification)

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Configuration matérielle et considérations sur les performances (Guide de planification)
Voir aussi
Image de liste déroulante

Cette configuration matérielle requise s'applique aux clients basés sur les rôles de Visual Studio Team System, tels que Team Edition for Architects, Team Edition for Developers, Team Edition for Testers et Team Explorer.

Client | Processeur | Mémoire
Visual Studio Team System et Team Explorer au minimum | 2 GHz | 192 Mo

Voir aussi

Concepts

Configuration du système d'exploitation (Guide de planification)

Autres ressources

Spécifications du client pour Team Foundation
Configuration requise pour le serveur Team Foundation


Configuration du réseau et considérations (Guide de planification)

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Configuration du réseau et considérations (Guide de planification)
Voir aussi
Image de liste déroulante

Pour utiliser Team Foundation Server avec un client quelconque, la communication entre les clients et la couche Application d'une part et les services Web sur la couche Application d'autre part s'effectue via SOAP sur HTTP. Cette communication est en clair sauf si l'utilisateur déploie SSL (Secure Sockets Layer) ou IPSec. L'utilisation de SSL affecte les requêtes HTTP(S) dans le tableau suivant :

  • Portail du projet et rapports.

  • Windows SharePoint Administration.

  • Requêtes de services Web provenant des clients.

  • Requêtes de services Web du proxy.

Remarque Remarque

Pour les déploiements qui sont contenus dans le pare-feu du réseau d'entreprise, les requêtes HTTP en clair peuvent être acceptables. Toutefois, pour les environnements plus sécurisés ou pour les déploiements où les services Web communiquent avec les clients sur Internet, nous recommandons fortement que les clients déploient SSL.

Toute la communication entre la couche Application et la couche Données s'effectue via TCP MS-SQL.

Les ports ouverts par défaut requis sur chaque couche sont récapitulés dans le tableau suivant.

Couche | Protocole | Port
ordinateur de build - accès à distance à partir de la couche Application | Accès à distance au réseau | 9191
Proxy de contrôle de version | HTTP | 8080
Couche Application - Windows SharePoint Services, Microsoft SQL Server Reporting Services | HTTP | 80
Couche Application - Windows SharePoint Services Administration | HTTP | Généré aléatoirement pendant l'installation de Windows SharePoint Services
Couche Application - services Web | HTTP | 8080
Couche Application - Windows SharePoint Services, Microsoft SQL Server Reporting Services avec SSL | HTTPS | 443
Couche Application - Windows SharePoint Services Administration | HTTPS | Administrator configuré
Couche Application - services Web qui utilisent SSL | HTTPS | Administrator configuré
Couche Données | TCP MS-SQL | 1443
Couche Données | UDP MS-SQL | 1444

Pour plus d'informations, consultez Authenticating Users.

Voir aussi

Autres ressources

Spécifications du client pour Team Foundation
Configuration requise pour le serveur Team Foundation
Authenticating Users


Spécifications de la langue et considérations (Guide de planification)

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Spécifications de la langue et considérations (Guide de planification)
Voir aussi
Image de liste déroulante

Vous pouvez installer la version anglaise de Visual Studio sur toute version localisée d'un système d'exploitation pris en charge. Vous pouvez installer toute version localisée de Visual Studio sur un système d'exploitation de langue correspondant, ou sur un système d'exploitation anglais. Par exemple, une version japonaise de Visual Studio peut être installée sur une version japonaise de Windows XP ou une version anglaise de Windows XP, mais pas sur une version allemande de Windows XP.

Si une version localisée de Team Foundation Server est installée sur un système d'exploitation anglais, vous aurez besoin d'un pack d'interface utilisateur multilingue (Multi-User Interface pack, MUI), ou au moins de l'installation des polices appropriées pour cette langue.

Visual Studio Team System et Microsoft Office

Lors de l'utilisation combinée de Visual Studio Team System et de Microsoft Office, il y a des contraintes linguistiques supplémentaires à considérer. La langue du système d'exploitation peut être toute langue prise en charge, et la langue de Visual Studio peut être toute langue prise en charge, sauf lorsque Microsoft Office a été installé. Si Microsoft Office est installé, les contraintes suivantes s'appliquent :

Version linguistique d'Office | Visual Studio en anglais | Visual Studio dans une autre langue
Microsoft Office en anglais | Prise en charge | Prise en charge
Microsoft Office dans une autre langue | Prise en charge | Doit être la même langue que Visual Studio

Voir aussi

Concepts

Configuration du système d'exploitation (Guide de planification)

Autres ressources

Spécifications du client pour Team Foundation
Configuration requise pour le serveur Team Foundation


Autres configurations logicielles et considérations (Guide de planification)

Autres configurations logicielles et considérations (Guide de planification)
Voir aussi
DropDown image

Fournit des informations sur les configurations logicielles requises pour quelques-unes des applications clientes utilisées avec Microsoft Visual Studio 2005 Team Foundation Server.

Dans cette section

Configuration de Team Foundation pour Microsoft Project

Décrit toutes les considérations d'administrateur pour utiliser Microsoft Project en tant que client.

Configuration de Team Foundation pour Microsoft Excel

Décrit toutes les considérations d'administrateur pour utiliser Microsoft Excel en tant que client.

Configuration de Team Foundation pour Windows SharePoint Services

Décrit toutes les considérations d'administrateur pour utiliser Windows SharePoint Services.

Configuration de Team Foundation pour Virtual PC

Décrit toutes les considérations d'administrateur pour utiliser Virtual PC avec Team Foundation Server.

Configuration des services Terminal Server de Team Foundation

Décrit toutes les considérations d'administrateur pour utiliser les services Terminal Server avec Team Foundation Server.

Rubriques connexes

Spécifications du client pour Team Foundation

Configuration requise pour le serveur Team Foundation

Planification de Team Foundation Server

Voir aussi

Autres ressources

Administration de Team Foundation Server


Configuration de Team Foundation pour Microsoft Project

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Configuration de Team Foundation pour Microsoft Project
Voir aussi
Image de liste déroulante

Les utilisateurs peuvent également accéder aux fonctions de Team Foundation Server via Microsoft Project en installant Visual Studio Team System ou Team Explorer sur l'ordinateur client. Visual Studio Team System inclut un plug-in pour Microsoft Project qui intègre les fonctions de suivi des éléments de travail de Team Foundation Server.

Voir aussi

Autres ressources

Spécifications du client pour Team Foundation
Autres configurations logicielles et considérations (Guide de planification)


Configuration de Team Foundation pour Microsoft Excel

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Configuration de Team Foundation pour Microsoft Excel
Voir aussi
Image de liste déroulante

Les utilisateurs peuvent également accéder aux fonctions de Team Foundation Server via Microsoft Excel en installant soit Visual Studio Team System soit Team Explorer sur l'ordinateur client. Visual Studio Team System inclut un plug-in pour Microsoft Excel qui intègre les fonctions de suivi des éléments de travail de Team Foundation Server.

Voir aussi

Autres ressources

Spécifications du client pour Team Foundation
Autres configurations logicielles et considérations (Guide de planification)


Configuration de Team Foundation pour Windows SharePoint Services

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Configuration de Team Foundation pour Windows SharePoint Services
Voir aussi
Image de liste déroulante

Visual Studio Team System inclut un site Web de projet d'équipe qui intègre un guide de processus, des documents de projet, des modèles et des fonctions de suivi des éléments de travail. Aucun impératif d'installation supplémentaire n'est exigé pour accéder aux fonctionnalités de Visual Studio Team System en dehors d'Internet Explorer. Les fonctions de Team Foundation Server sont fournies via le Web, y compris l'accès au portail de projet d'équipe basé sur Windows SharePoint Services, aux rapports basés sur le service SQL Analysis et aux fonctions de suivi des éléments de travail.

Voir aussi

Autres ressources

Spécifications du client pour Team Foundation
Autres configurations logicielles et considérations (Guide de planification)


Configuration de Team Foundation pour Virtual PC

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Configuration de Team Foundation pour Virtual PC
Voir aussi
Image de liste déroulante

Les clients basés sur les rôles de Visual Studio Team System et Team Explorer fonctionnent correctement sur un Virtual PC. Cette configuration n'est pas recommandée pour les environnements de production.

Remarque Remarque

Le profilage ne fonctionnera pas sur un Virtual PC en raison de restrictions de pilotes.

Voir aussi

Autres ressources

Spécifications du client pour Team Foundation
Autres configurations logicielles et considérations (Guide de planification)


Configuration des services Terminal Server de Team Foundation

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Configuration des services Terminal Server de Team Foundation
Voir aussi
Image de liste déroulante

Les clients basés sur les rôles de Visual Studio Team System et Team Foundation Server fonctionnent correctement avec Terminal Server.

Voir aussi

Autres ressources

Spécifications du client pour Team Foundation
Autres configurations logicielles et considérations (Guide de planification)


Vue d'ensemble de la sécurité de Team Foundation

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Vue d'ensemble de la sécurité de Team Foundation
Voir aussi
Image de liste déroulante

Pour mieux sécuriser Team Foundation Server, vous devez comprendre comment Team Foundation Server fonctionne et comment il communique avec les autres composants Team Foundation. Un administrateur Team Foundation Server doit être familier avec l'authentification Windows, les protocoles et le trafic réseau ainsi que la structure du réseau d'entreprise sur lequel Team Foundation Server est installé, en plus de bien comprendre les groupes et les autorisations de Team Foundation Server.

Concepts de sécurité et architecture

Les concepts de sécurité Team Foundation Server incluent la sécurité d'utilisateur et de groupe, les autorisations Team Foundation Server et comment ils interagissent, ainsi que la communication entre les composants Team Foundation. Vous devez examiner ces concepts avec soin avant de planifier le déploiement de Team Foundation Server.

  • L'architecture de Team Foundation Server est passée en revue dans le Team Foundation Server Administrator's Guide. Pour plus d'informations sur l'architecture de Team Foundation Server, consultez Architecture de sécurité de Team Foundation Server.

  • La topologie, l'autorisation et l'authentification de Team Foundation Server sont également décrites dans le Team Foundation Server Administrator's Guide. Pour plus d'informations sur ces concepts, consultez Concepts sur la sécurité de Team Foundation Server.

  • La sécurité d'utilisateur et de groupe est un composant important de Team Foundation Server. Pour plus d'informations sur la sécurité des utilisateurs et des groupes, consultez Sécurité de Team Foundation Server pour les utilisateurs et les groupes.

  • La définition et la gestion des autorisations dans Team Foundation Server sont importantes pour la sécurité de serveur et de projet de Team Foundation Server. Pour plus d'informations sur les autorisations de Team Foundation Server, consultez Gestion des autorisations.

Voir aussi

Concepts

Synchronisation des comptes Administrateur


Planification de la sécurité de Team Foundation Server

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Planification de la sécurité de Team Foundation Server
Voir aussi
Image de liste déroulante

Pour planifier la sécurité de Team Foundation Server, vous devez d'abord comprendre les interactions entre la couche Application de Team Foundation, la couche Données de Team Foundation et la couche cliente de Team Foundation. Vous devez savoir quels services Web, bases de données et modèles d'objet sont utilisés. Vous devez également savoir quels ports réseau et protocoles sont utilisés par défaut et lesquels peuvent être personnalisés. Vous pouvez planifier ensuite un déploiement sécurisé de Team Foundation Server, qui répond aux besoins de votre entreprise tout en réduisant le risque de sécurité.

Concepts de planification de la sécurité

Les concepts de sécurité de Team Foundation Server incluent le fait de planifier une topologie sécurisée et de comprendre comment Team Foundation Server authentifie et autorise des utilisateurs et des groupes. Tout cela requiert de comprendre le fonctionnement de l'architecture de Team Foundation Server. Pour plus d'informations sur l'architecture de Team Foundation Server, consultez Architecture de sécurité de Team Foundation Server et Concepts sur la sécurité de Team Foundation Server.

Considérations sur la planification de Team Foundation Server

Vous devez déterminer si la sécurité de l'architecture de Team Foundation Server est suffisante pour les besoins de votre entreprise, et, le cas échéant, si vous souhaitez configurer Team Foundation Server pour plus de sécurité, grâce par exemple à l'utilisation de HTTPS et SSL. Lorsque vous planifiez la sécurité de Team Foundation Server, posez-vous les questions suivantes :

  • Les paramètres des ports réseau par défaut de Team Foundation Server sont-ils suffisamment sécurisés pour les besoins de mon entreprise ? Par défaut, Team Foundation Server utilise un jeu de ports réseau pour la communication entre les couches Données, Application et cliente. Quelques-uns de ces ports sont configurables ; d'autres ne le sont pas. Vous pouvez choisir de configurer certains ports pour mieux répondre aux besoins de votre entreprise. Vous pouvez également choisir de configurer tout ou partie des couches sur le même ordinateur, selon le cas.

  • Est-ce que je dois configurer Team Foundation Server en vue de l'utilisation des certificats ? Team Foundation Server utilise HTTP dans sa configuration par défaut. Si votre entreprise l'exige, vous pouvez configurer manuellement Team Foundation Server pour qu'il utilise HTTPS avec SSL.

  • Est-ce que je dois déployer Team Foundation Server dans un domaine Active Directory ou dans un groupe de travail ? Vous pouvez déployer Team Foundation Server dans un domaine Active Directory ou dans un groupe de travail. Active Directory fournit des fonctionnalités de sécurité plus intégrées que les groupes de travail, que vous pouvez utiliser pour mieux sécuriser votre déploiement de Team Foundation Server.

En plus de ces questions, vous devez déterminer quels utilisateurs et groupes vous souhaitez ajouter au déploiement de Team Foundation Server, et quelles autorisations vous souhaitez accorder à chacun de ces utilisateurs et groupes. Pour plus d'informations sur les utilisateurs, les autorisations et les groupes, consultez Autorisations de Team Foundation Server.

Voir aussi

Autres ressources

Topologies de Team Foundation Server
Personnalisation de Team Foundation Server pour vos affaires


Planification du client et du serveur

Planification du client et du serveur
DropDown image

Pour planifier Visual Studio Team System, vous devez d'abord déterminer les fonctionnalités Visual Studio Team System qui répondent le mieux aux besoins de votre entreprise, et évaluer les configurations matérielle et logicielle requises de ces fonctionnalités.

Dans cette section

Planification de Team Foundation Build

Résume les impératifs et d'autres informations disponibles pour vous aider à installer et à gérer un atelier de génération (build) public à l'aide de Team Foundation.

Planification de Team Edition for Testers

Résume les impératifs et d'autres informations disponibles pour vous aider à installer et à gérer des serveurs de builds qui sont intégrés dans Visual Studio.

Planification du serveur

Récapitule les serveurs disponibles, l'architecture serveur et les impératifs liés à Team Foundation.

Planification du client

Fournit une vue d'ensemble des applications clientes pour Team Foundation.

Planification d'un projet d'équipe

Vous présente une feuille de route pour la planification d'un projet d'équipe.

Planification pour les bureaux distants

Fournit une description du rôle d'un serveur proxy ou d'un serveur de builds pour Team Foundation dans des bureaux distants.

Examen des considérations sur la sécurité

Fournit une vue d'ensemble de la sécurité que vous pouvez considérer pour la couche Données, la couche Application et les autres serveurs.

Référence

Téléchargez la version la plus récente du Guide de planification Team Foundation Server à l'adresse http://go.microsoft.com/fwlink/?linkid=55995.

Rubriques connexes

Sécurisation de Team Foundation Server

Planification de capacité pour le déploiement de Team Foundation

Migration vers Team Foundation


Planification de Team Foundation Build

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Planification de Team Foundation Build
Voir aussi
Image de liste déroulante

Team Foundation Build fournit les fonctionnalités d'un laboratoire de génération (build) public et fait partie de Visual Studio Team Foundation Server. Avec Team Foundation Build, les gestionnaires de génération d'entreprise peuvent synchroniser les sources, compiler l'application, exécuter des tests unitaires associés, effectuer une analyse du code, générer des builds sur un serveur de fichiers et publier des rapports de build.

Pour plus d'informations, consultez Vue d'ensemble de Team Foundation Build.

Configurations matérielle et logicielle requises

Pour tirer parti des fonctionnalités Team Foundation Build, un ou plusieurs ordinateurs dans l'environnement de Visual Studio Team System peuvent être désignés comme serveurs de génération (build). Team Foundation Build a une configuration matérielle et logicielle requise spécifique.

Pour plus d'informations, consultez Configuration de Team Build pour Team System.

Procédure pas à pas

Pour une expérience pratique avec une génération (build), vous pouvez exécuter une procédure pas à pas :

Procédure pas à pas : exécution d'un type de build dans Team Foundation Build

Dans cette procédure pas à pas, vous exécutez le processus de sélection d'un type de génération (build) et le démarrage manuel d'une génération (build).

Voir aussi

Tâches

Procédure pas à pas : exécution d'un type de build dans Team Foundation Build

Concepts

Vue d'ensemble de Team Foundation Build
Configuration de Team Build pour Team System

Autres ressources

Planification du client et du serveur


Planification de Team Edition for Testers

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Planification de Team Edition for Testers
Voir aussi
Image de liste déroulante

Team Edition for Testers vous permet de créer, de gérer, de modifier et d'exécuter des tests, mais aussi d'obtenir et de stocker les résultats des tests. Visual Studio intègre, outre la mesure de couverture du code, plusieurs types de tests, notamment les tests unitaires, les tests Web, les tests de charge et les tests manuels. Pour plus d'informations, consultez Documentation Team Edition for Testers.

Visual Studio Team Edition for Testers peut utiliser un groupe d'ordinateurs pour générer une charge simulée et pour exécuter des tests à distance simultanément sur plusieurs ordinateurs. Ce groupe d'ordinateurs se compose d'un contrôleur unique et d'un ou de plusieurs agents qui sont collectivement appelés « plate-forme de test ». Pour plus d'informations, consultez Utilisation des agents.

Configurations matérielle et logicielle requises

Les configurations matérielle et logicielle requises pour Team Edition for Testers se répartissent en deux parties : les impératifs pour Visual Studio Team Edition for Testers et les impératifs pour votre plate-forme de test.

Les impératifs liés à Visual Studio Team Edition for Testers sont les mêmes que ceux de Visual Studio.

Les impératifs de la plate-forme de test sont présentés ci-dessous :

Systèmes d'exploitation pris en charge

Les systèmes d'exploitation suivants sont pris en charge pour l'agent et le contrôleur :

Contrôleur

Windows Server 2003 (version finale)

Remarque Remarque

Les contrôleurs de charge ne peuvent pas être installés sur les contrôleurs de domaine.

Windows XP Professionnel (SP2)

Agent

Windows Server 2003 (version finale)

Windows XP Professionnel (SP2)

Windows 2000 (SP4)

Configuration matérielle requise

les configurations matérielle et logicielle requises pour Team Edition for Testers sont documentées dans le Guide d'installation Team Edition for Testers et dans la documentation de Team Edition for Testers. Pour plus d'informations sur les configurations matérielle et logicielle requises pour la plate-forme de test Team Test, consultez Installation des fonctionnalités de contrôleur et d'agent.

Par défaut, SQL Express est installé avec le contrôleur et utilisé comme magasin par défaut pour les résultats des tests de charge. Le contrôleur exécute par conséquent une instance de SQL Express.

Vous pouvez en savoir davantage à propos des impératifs dans le Guide d'installation Team Foundation. La version la plus récente du Guide d'installation Team Foundation est disponible en ligne à l'adresse http://go.microsoft.com/fwlink/?linkid=40042.

Pour une expérience pratique avec Team Edition for Testers et une plate-forme de test, consultez Comment : exécuter un test sur une plate-forme de test.

Voir aussi

Tâches

Comment : exécuter un test sur une plate-forme de test

Concepts

Utilisation des agents

Autres ressources

Planification du client et du serveur
Documentation Team Edition for Testers


Planification du serveur

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Planification du serveur
Voir aussi
Image de liste déroulante

Le principal serveur de Team System est un serveur Team Foundation Server. Il fournit des fonctionnalités de contrôle de version, de suivi des éléments de travail, de génération (build), de portail de projet d'équipe, de création de rapports et de gestion de projets. Team Foundation Server inclut également un entrepôt de données où sont stockées les données du suivi des éléments de travail, du contrôle de code source, des générations (builds) et les outils de test. Ces données sont utilisées par Team Foundation pour ses fonctionnalités intégrées de création de rapport. D'autres serveurs de Visual Studio Team System incluent des serveurs de builds et des serveurs de plate-forme de test de Team Edition for Testers. En fonction des besoins de votre entreprise, vous pouvez choisir de déployer certains de ces serveurs, ou de les déployer tous.

Serveurs Team Foundation Server

Visual Studio Team System inclut les serveurs suivants :

Team Foundation Server

Team Foundation Server fournit des fonctionnalités de contrôle de version, de suivi des éléments de travail, de génération (build), de portail de projet d'équipe, de création de rapports et de gestion de projets. Un serveur Team Foundation Server logique se compose de deux composants : un serveur d'applications, qui comprend essentiellement des services Web, et un serveur de base de données, qui comprend essentiellement une base de données SQL Server 2005. Dans les déploiements de Team Foundation Server, ces deux composants sont connus sous le nom de serveur de couche Application et de serveur de couche Données. Le serveur de couche Application et le serveur de couche Données peuvent être déployés sur un serveur (déploiement sur un serveur) ou sur deux serveurs (déploiement sur deux serveurs).

Serveur de builds

Pour tirer parti des fonctionnalités de Team Foundation Build, vous pouvez désigner un ou plusieurs ordinateurs dans l'environnement de Visual Studio Team System comme serveurs de builds. Team Foundation Build fournit les fonctionnalités d'atelier de build public et fait partie de Visual Studio Team Foundation Server. Avec Team Foundation Build, les gestionnaires de génération d'entreprise peuvent synchroniser les sources, générer l'application, exécuter des tests unitaires associés, effectuer une analyse du code, générer des builds sur un serveur de fichiers et publier des rapports de build. Les résultats des builds sont propagés à l'entrepôt de données pour la création de rapports historiques. Team Foundation Build fonctionne avec d'autres outils de Visual Studio Team Foundation Server pendant le processus de génération (build), y compris le contrôle de code source et le suivi des éléments de travail. Pour plus d'informations sur les fonctionnalités de Team Foundation Build et la planification, consultez Planification de Team Foundation Build.

Serveurs de test et plates-formes de test

Team Edition for Testers vous permet de créer, de gérer, de modifier et d'exécuter des tests, mais aussi d'obtenir et de stocker les résultats des tests. Visual Studio intègre, outre la mesure de couverture du code, plusieurs types de tests, notamment les tests unitaires, les tests Web, les tests de charge et les tests manuels. Team Edition for Testers permet aux utilisateurs de Visual Studio Team System d'effectuer des tests sur des ordinateurs distants, appelés plate-forme de test. Une plate-forme de test se compose d'un contrôleur de test et d'un ou plusieurs agents. Le contrôleur de test et l'agent peuvent être installés sur le même ordinateur ou sur deux ordinateurs différents. Un contrôleur de test peut coordonner l'exécution de plusieurs séries de tests sur les ordinateurs sur lesquels l'agent de test est installé.

Dans la mesure où les outils de test sont intégrés avec les autres composantes de Visual Studio Team System, vous pouvez publier les résultats dans une base de données, générer des rapports de tendance et historiques, comparer différents de données, voir le nombre de bogues trouvés à la suite des tests et identifier les bogues qui ne sont pas liés à un test qui pourrait aider à les reproduire.

Intégration du contrôleur de domaine Active Directory

Visual Studio Team System intègre les fonctions d'autorisation et d'authentification de base de Windows Server 2003 et Windows 2000 Server pour valider les utilisateurs. Visual Studio Team System est compatible avec les domaines en modes natif et mixte de Windows 2000, et également avec les domaines de Windows Server 2003 version préliminaire et Windows Server 2003. Les petites organisations peuvent utiliser l'authentification Windows et les groupes de travail pour gérer leurs utilisateurs à la place d'Active Directory, mais les grandes organisations doivent utiliser Active Directory. Visual Studio Team System utilise les contrôleurs de domaine Active Directory existants dans un déploiement à grande échelle. Pour plus d'informations sur Active Directory, consultez Windows Server 2003 Active Directory (http://go.microsoft.com/fwlink/?LinkId=47541).

Intégration du serveur SMTP

Team Foundation Server a une infrastructure de notification extensible. Team Foundation Server peut utiliser également un serveur SMTP existant pour fournir des fonctions de notification par courrier électronique aux utilisateurs finals.

Architecture de serveur

Le diagramme suivant illustre l'architecture de base des serveurs de Team Foundation.

Diagramme Architecture serveur

Configuration de Team Foundation Server

Team Foundation Server a une configuration matérielle et logicielle requise spécifique. En outre, la configuration matérielle requise peut varier selon la façon dont vous projetez de déployer et d'utiliser Visual Studio Team System. Lors de la planification d'un déploiement de Team Foundation Server, il est tout aussi important de comprendre les besoins spécifiques de votre entreprise. Pour plus d'informations sur la configuration matérielle et logicielle du serveur, consultez Configuration requise pour le serveur Team System.

D'autres considérations sur le serveur

Virtual PC

Les serveurs Team Foundation Server fonctionneront correctement sur un Virtual PC ou un serveur virtuel. Cette configuration n'est, cependant, pas recommandée pour les environnements de production. Elle peut être utilisée dans des scénarios d'évaluation ou de démonstration.

Serveurs Terminal Server

Les serveurs Team Foundation Server fonctionneront correctement avec des sessions Terminal Server. Vous pouvez utiliser des services Terminal Server pour gérer Team Foundation Server à distance. Pour plus d'informations sur les services Terminal Server, consultez Windows Server 2003 Terminal Services (http://go.microsoft.com/fwlink/?LinkId=24427).

Serveurs dédiés

Les serveurs de Team Foundation Server doivent être dédiés aux fonctionnalités de Team Foundation Server. Ils ne doivent pas servir à autre chose, par exemple servir de serveurs de messagerie, serveurs de fichiers, serveurs Web ou serveurs de base de données pour d'autres applications.

Dans cette section

Planification du déploiement sur un serveur

Décrit comment planifier un déploiement sur un seul serveur.

Planification du déploiement sur deux serveurs

Décrit comment planifier un déploiement sur deux serveurs.

Voir aussi

Concepts

Configuration requise pour le serveur Team System
Configuration des plates-formes de test pour Team System
Planification de Team Foundation Build
Configuration de Team Build pour Team System


Planification du déploiement sur un serveur

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Planification du déploiement sur un serveur
Voir aussi
Image de liste déroulante

Un serveur Team Foundation Server logique se compose d'un serveur de couche Application (composé essentiellement de services Web) et d'un serveur de couche Données (composé essentiellement de bases de données SQL Server 2005). Dans la configuration à un seul serveur, les services et programmes de la couche Application et de la couche Données sont hébergés sur le même ordinateur. Les déploiements sur un seul serveur sont conçus pour les déploiements impliquant moins de 100 utilisateurs.

Considérations sur les déploiements sur un serveur

Vous devez déterminer si le déploiement sur un seul serveur est le bon choix compte tenu des besoins de votre entreprise. Au moment de planifier Team Foundation Server et de considérer s'il faut le déployer sur un serveur ou deux serveurs, posez-vous les questions suivantes :

  • Combien d'utilisateurs est-ce que j'ai besoin de prendre en charge ? Si vous projetez d'avoir plus de 100 utilisateurs, déterminez si un déploiement sur deux serveurs peut mieux répondre à vos besoins.

  • Combien de projets est-ce que je vais prendre en charge avec Team Foundation Server ? Si vous prenez en charge un grand nombre de projets, déterminez si un déploiement de Team Foundation Server sur deux serveurs est mieux adapté à vos besoins.

  • Est-ce que je dispose d'un serveur que je peux dédier à Team Foundation Server ? Le serveur dans un déploiement de Team Foundation Server sur serveur unique doit être dédié aux fonctionnalités de Team Foundation Server. Le serveur Team Foundation ne doit pas jouer un autre rôle, servir par exemple de serveur de messagerie, de serveur de fichiers ou de serveur de base de données pour d'autres applications.

  • Quand est-ce que le déploiement devra être disponible pour une utilisation en production ? Prévoyez au moins une journée entière pour l'installation et la configuration de Team Foundation Server, et au moins une autre journée pour la configuration du serveur de Team Foundation.

En plus de ces questions, vous devez étudier votre réseau d'ordinateurs lors de la planification d'un déploiement sur un seul serveur. Si vous projetez d'inclure une plate-forme de test ou un serveur de builds dans le déploiement de Visual Studio Team System, le serveur de Team Foundation doit être un membre du même domaine ou groupe de travail que ces serveurs. Si c'est possible, tous les serveurs doivent être sur le même segment réseau.

Avantages des déploiements sur un seul serveur

Les avantages des déploiements sur un seul serveur sont les suivants :

  • Simplicité Vous pouvez gérer tous les aspects du déploiement de Team Foundation Server sur un seul serveur. Vous pouvez configurer tous les droits d'accès et les autorisations des utilisateurs et des groupes sur un seul serveur. Vous avez seulement un serveur à planifier pour la sauvegarde et la maintenance.

  • Disponibilité Dans la mesure où les deux couches Application et Données sont présentes sur un seul serveur, vous n'avez pas à tenir compte des restrictions du réseau ou de la latence du réseau entre les couches Application et Données lors de la planification de votre déploiement.

Inconvénients des déploiements sur un seul serveur

Les inconvénients des déploiements sur un seul serveur sont les suivants :

  • Faible évolutivité Les déploiements sur un seul serveur sont conçus pour un maximum de 100 utilisateurs. Si votre déploiement dépasse ce nombre, vous serez amené à ajouter un autre déploiement de Team Foundation Server. Ne perdez pas de vue que Team Foundation Server peut prendre en charge seulement 500 utilisateurs par serveur, et que les projets interdépendants qui partagent des fichiers de ressources ne peuvent pas être fractionnés entre plusieurs Team Foundation Server.

  • Contrôle d'accès Tous les utilisateurs de Team Foundation Server doivent avoir accès et disposer des autorisations appropriées sur l'unique Team Foundation Server. Il n'existe pas de séparation de services dans le cadre d'un déploiement de Team Foundation Server sur un seul serveur.

  • Pas basculement Dans la mesure où tous vos composants Team Foundation Server se trouvent sur un seul serveur, vous ne pouvez pas rediriger le serveur de couche Application vers un serveur de couche Données différent en cas de maintenance ou de réparations, et vous ne pouvez pas configurer et déployer un serveur supplémentaire qui peut agir comme serveur de couche Application de basculement ou de secours.

Configuration requise pour les déploiements sur un seul serveur

Le tableau suivant indique la configuration matérielle requise recommandée pour le déploiement de Team Foundation Server sur un seul serveur, selon le nombre d'utilisateurs.

Configuration | Couches | Processeur | DD | Mémoire
Un serveur, moins de 20 utilisateurs. | serveur des couches Application et Données | processeur unique, 2,2 GHz | 8 Go | 1 Go
Un serveur ; 20 à 100 utilisateurs. | serveur des couches Application et Données | biprocesseur, 2,2 GHz | 30 Go | 2 Go

Les indications présentées ici sont appropriées pour la plupart des déploiements sur un seul serveur. Elles sont destinées aux environnements qui comptent moins de 100 utilisateurs sur un seul Team Foundation Server. Le serveur qui exécute Team Foundation Server doit disposer d'une connexion réseau fiable avec une bande passante d'au moins 1 Mbit/s et une latence maximale de 350 ms.

Si votre environnement ne répond pas à ces critères, vous devez étudier avec soin les implications avant de déployer Team Foundation Server. Déterminez si un déploiement de Team Foundation Server sur deux serveurs peut mieux répondre aux besoins de votre entreprise.

Voir aussi

Concepts

Planification du déploiement sur deux serveurs
Configuration requise pour le serveur Team System
Spécifications du client pour Team System

Autres ressources

Gestion des utilisateurs et groupes


Planification du déploiement sur deux serveurs

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Planification du déploiement sur deux serveurs
Voir aussi
Image de liste déroulante

Un serveur Team Foundation Server logique se compose d'un serveur de couche Application (composé essentiellement de services Web) et d'un serveur de couche Données (composé essentiellement de bases de données SQL Server 2005). Dans la configuration à deux serveurs, l'un est le serveur de couche Application, et l'autre est le serveur de couche Données. Les déploiements sur deux serveurs sont conçus pour les déploiements qui comptent plus de 100 utilisateurs sur plusieurs projets d'équipe.

Considérations à propos des déploiements sur deux serveurs

Vous devez décider si un déploiement sur deux serveurs est le choix le plus approprié pour vos besoins d'entreprise. Au moment de planifier Team Foundation Server et de considérer s'il faut le déployer sur un serveur ou deux serveurs, posez-vous les questions suivantes :

  • Combien d'utilisateurs est-ce que j'ai besoin de prendre en charge ? Si vous projetez d'avoir moins de 100 utilisateurs, déterminez si un déploiement sur un seul serveur peut mieux répondre à vos besoins. Inversement, si vous devez prendre en charge plus de 500 utilisateurs, considérez si vous pouvez déployer plusieurs Team Foundation Server. Les projets ne peuvent pas être fractionnés sur plusieurs serveurs, mais vous pouvez déployer plusieurs Team Foundation Server sur un réseau. Envisagez de déployer des projets indépendants sur des serveurs Team Foundation séparés afin qu'aucun serveur Team Foundation Server ne compte plus de 500 utilisateurs.

  • Combien de projets est-ce que je vais prendre en charge avec Team Foundation Server ? Si vous prenez en charge un petit nombre de projets, considérez si un déploiement sur un seul serveur est mieux adapté à vos besoins. Si vous prenez en charge un grand nombre de projets et d'utilisateurs, souvenez-vous que Team Foundation Server peut prendre en charge uniquement 500 utilisateurs sur chaque serveur, et que les projets interdépendants qui partagent des fichiers de ressources ne peuvent pas être fractionnés entre plusieurs Team Foundation Server. Envisagez de grouper des projets liés, et de déployer chaque groupe de projets connexes sur des serveurs Team Foundation séparés afin qu'aucun serveur Team Foundation Server ne compte plus de 500 utilisateurs.

  • Est-ce que je dispose de deux serveurs que je peux dédier à Team Foundation Server ? Les serveurs dans un déploiement de Team Foundation Server sur deux serveurs doivent être dédiés aux fonctionnalités de Team Foundation Server. Les serveurs Team Foundation de couche Application et de couche Données ne doivent pas jouer aucun autre rôle, par exemple serveurs de messagerie, serveurs de fichiers ou serveurs de bases de données pour d'autres applications.

  • Quand est-ce que le déploiement devra être disponible pour une utilisation en production ? Planifiez au moins une journée entière pour l'installation et la configuration du logiciel sur chaque Team Foundation Server, et au moins une autre journée pour la configuration des utilisateurs, des groupes, des projets, de la structure de projet et des autorisations sur les deux serveurs de Team Foundation.

En plus de ces questions, vous devez considérer votre réseau d'ordinateurs lors de la planification d'un déploiement sur deux serveurs. Le serveur de couche Application et le serveur de couche Données doivent être membres du même domaine ou groupe de travail, et se trouver sur le même segment réseau sans la présence d'un pare-feu configuré entre eux. Si vous projetez d'inclure une plate-forme de test ou un serveur de builds dans le déploiement de Visual Studio Team System, les serveurs de Team Foundation doivent également être un membre du même domaine ou groupe de travail que ces serveurs. Si c'est possible, tous les serveurs doivent être sur le même segment réseau.

Avantages du déploiement sur deux serveurs

Les avantages des déploiements sur deux serveurs sont les suivants :

  • Extensibilité Les déploiements sur deux serveurs sont conçus pour un grand nombre d'utilisateurs. Le déploiement sur deux serveurs peut être étendu pour prendre en charge plus d'utilisateurs et de projets, à mesure que le déploiement gagne en portée.

  • Séparation de services Dans la mesure où les services de couche Application et les services de couche Données se trouvent sur des serveurs séparés dans un déploiement sur deux serveurs, vous pouvez configurer séparément les droits d'accès et les autorisations pour les utilisateurs et les groupes sur chaque serveur.

  • Sauvegarde séparée et options de basculement pour les services de couche Application et de couche Données Vous pouvez planifier séparément des sauvegardes des serveurs de couche Application et de couche Données. Si vous devez exécuter la maintenance d'un serveur de couche Données ou remplacer celui-ci dans votre déploiement sur deux serveurs, vous pouvez rediriger le serveur de couche Application vers un serveur de couche Données différent de façon transparente pour les utilisateurs. En outre, vous pouvez choisir de configurer et de déployer un serveur supplémentaire qui peut agir en tant que serveur de secours ou serveur de couche Application de basculement.

Inconvénients des déploiements sur deux serveurs

Les inconvénients des déploiements sur deux serveurs sont les suivants :

  • Plus de complexité Vous devez gérer l'accès et la maintenance sur deux serveurs au lieu d'un.

  • Restrictions de réseau Vous devez avoir une connectivité réseau uniforme entre vos serveurs de couche Application et de couche Données.

Configuration requise pour les déploiements sur deux serveurs

Le tableau suivant indique la configuration matérielle requise recommandée pour le déploiement de Team Foundation Server sur deux serveurs, selon le nombre d'utilisateurs.

Configuration | Couches | Processeur | DD | Mémoire
Deux serveurs ; 100 à 250 utilisateurs. | serveur de couche Application | processeur unique, 2,2 GHz | 20 Go | 1 Go
Deux serveurs ; 100 à 250 utilisateurs. | serveur de couche Données | biprocesseur, 2,2 GHz | 80 Go | 2 Go
Deux serveurs ; 250 à 500 utilisateurs. | serveur de couche Application | biprocesseur, 2,2 GHz | 40 Go | 2 Go
Deux serveurs ; 250 à 500 utilisateurs. | serveur de couche Données | quadriprocesseur, 2,2 GHz | 150 Go | 4 Go

Les indications présentées ici sont appropriées pour la plupart des déploiements. Elles sont destinées aux environnements qui comptent moins de 500 utilisateurs sur un seul Team Foundation Server. Le serveur qui exécute Team Foundation Server doit disposer d'une connexion réseau fiable avec une bande passante d'au moins 1 Mbit/s et une latence maximale de 350 ms.

Si votre environnement ne répond pas à ces critères, vous devez étudier avec soin les implications avant de déployer Team Foundation Server. Déterminez s'il faut augmenter la configuration matérielle requise au-delà de ces recommandations, si vous pouvez améliorer la fiabilité du réseau et de la bande passante, ou si l'utilisation de plusieurs serveurs qui exécutent Team Foundation Server peut mieux répondre aux besoins de votre entreprise.

Voir aussi

Concepts

Planification du déploiement sur un serveur
Configuration requise pour le serveur Team System
Spécifications du client pour Team System

Autres ressources

Gestion des utilisateurs et groupes


Planification du client

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Planification du client
Voir aussi
Image de liste déroulante

Visual Studio Team System a quatre applications clientes principales : Visual Studio Team Edition for Architects, Visual Studio Team Edition for Developers, Visual Studio Team Edition for Testerset Visual Studio 2005 Team Suite, qui inclut le client Team Explorer et possède des fonctionnalités de toutes les éditions basées sur les rôles.

En cas d'utilisation avec Team Foundation Server, ces applications clientes fournissent des interfaces utilisateur Visual Studio supplémentaires aux fonctions telles que le contrôle de code source, le suivi des éléments de travail, les sites Web d'équipe, la création de rapports, le guide de processus, la gestion de génération (builds) et l'exécution de tests.

Remarque Remarque

Il est possible d'installer plusieurs éditions clientes de Visual Studio Team System sur un seul ordinateur. Dans ce cas, Visual Studio Team System unira les fonctions des éditions qui ont été installées. Par exemple, si vous installez Visual Studio Team Edition for Architects et Visual Studio Team Edition for Testers, vous disposerez du fonctionnement à la fois de Visual Studio Team Edition for Architects et de Visual Studio Team Edition for Testers lorsque vous exécuterez Visual Studio.

Clients Team Foundation

Visual Studio Team System inclut les éditions clientes suivantes :

  • Team Edition for Software Architects Application de Visual Studio Team System axée sur le rôle de l'architecte logiciel.

  • Team Edition for Software Developers Application de Visual Studio Team System axée sur le rôle du développeur d'entreprise.

  • Team Edition for Software Testers Application de Visual Studio Team System axée le rôle du testeur.

  • Team Explorer Application Visual Studio pour la gestion et l'analyse de projets logiciels. Team Explorer fournit une vue organisée de vos projets d'équipe et inclut l'accès aux fonctionnalités de Team Foundation Server, y compris le contrôle de code source, le suivi des éléments de travail et bénéficie de l'intégration de Microsoft Project et de Microsoft Excel.

Intégration avec Team Foundation

Visual Studio Team System s'intègre avec plusieurs autres produits, notamment :

  • Microsoft Project Visual Studio Team System inclut un plug-in pour Microsoft Project, qui intègre des fonctions de suivi des éléments de travail de Team Foundation Server.

  • Microsoft Excel Visual Studio Team System inclut un plug-in pour Microsoft Excel, qui intègre des fonctions de suivi des éléments de travail de Team Foundation Server.

  • Windows SharePoint Services Visual Studio Team System inclut un portail de projet d'équipe qui intègre un guide de processus, des documents de projet, des modèles et des fonctions de suivi des éléments de travail.

  • Ligne de commande du contrôle de code source Interface de ligne de commande aux fonctions du contrôle de code source de Team Foundation Server.

Architecture de client

Le diagramme suivant illustre l'architecture de base des clients de Visual Studio Team System.

Diagramme d'architecture client

Rôles des clients

Les fonctions de Visual Studio Team System doivent être évaluées à travers les éditions basées sur les rôles comme Visual Studio Team Edition for Architects, mais également à travers d'autres clients tels qu'Internet Explorer, Microsoft Project et Microsoft Excel. Toutes les éditions basées sur les rôles incluent les fonctionnalités fournies par Team Explorer ainsi que des fonctionnalités spécifiques pour leurs rôles individuels. En déterminant les rôles des individus de votre organisation, vous pouvez déterminer les éditions à évaluer, et vous pouvez planifier plus efficacement le déploiement de Visual Studio Team System.

Considérations sur l'installation de Visual Studio Team Explorer

Team Explorer peut être installé et exécuté à côté d'autres environnements de développement intégré (IDE), permettant ainsi l'accès aux fonctionnalités de Team Foundation Server, comme suit :

  • Développeurs utilisant Visual Studio 2005 Professional Edition ou Standard.

    Team Explorer peut être installé sur Visual Studio 2005 Professional, permettant ainsi l'accès aux fonctionnalités de Team Foundation Server. Team Explorer doit être installé sur cette édition et ne peut pas être installé avec Visual Studio 2005 Professional.

  • Développeurs utilisant Visual Studio 2005 Express.

    Team Explorer peut être installé et exécuté à côté de Visual Studio 2005 Express, permettant ainsi l'accès aux fonctionnalités de Team Foundation Server.

  • Les développeurs qui utilisent d'anciennes versions de Visual Studio, par exemple Visual Studio 6.

    Team Explorer peut être installé et exécuté à côté de versions antérieures de Visual Studio (y compris les versions antérieures de Visual Studio .NET), permettant ainsi l'accès aux fonctionnalités de Team Foundation Server.

  • Les développeurs qui utilisent des environnements de développement intégré autres que Visual Studio.

    Team Explorer peut être installé et exécuté à côté d'autres environnements IDE, permettant ainsi l'accès aux fonctionnalités de Team Foundation Server.

Microsoft Project et Microsoft Excel comme clients de Visual Studio Team System

Les utilisateurs peuvent également accéder aux fonctions de Team Foundation Server via Microsoft Project et Microsoft Excel en installant Visual Studio Team System ou Team Explorer sur l'ordinateur client.

Voir aussi

Concepts

Planification du serveur


Planification pour les bureaux distants

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Planification pour les bureaux distants
Voir aussi
Image de liste déroulante

Lors de la planification d'une implémentation de Team Foundation Server, l'équipe de développement principale peut être localisée à un site et des équipes supplémentaires peuvent être situées à des bureaux multisites distants. Dans un tel cas, vous conserveriez l'essentiel des serveurs des couches Données et Application sur le site principal. Toutefois, vous pouvez également envisager une combinaison de serveurs proxy et de build dans les bureaux distants.

Vous mettriez un serveur proxy dans le bureau distant afin de mieux répondre aux besoins des bureaux distants de votre équipe.

Serveur proxy

Vous souhaitez habituellement placer un serveur proxy à chaque emplacement pour optimiser les performances.

Le matériel de serveur proxy peut être modeste parce qu'il s'agit d'un simple cache. L'impératif majeur concernant le serveur est l'espace disque pour mettre en cache tout ce qui est nécessaire pour éviter les téléchargements via le réseau étendu (WAN).

Pour plus d'informations, consultez Team Foundation Server Proxy et contrôle de code source Team Foundation.

Voir aussi

Concepts

Serveur de builds distant
Team Foundation Server Proxy et contrôle de code source Team Foundation

Autres ressources

Planification de capacité pour le déploiement de Team Foundation


Serveur de builds distant

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Serveur de builds distant
Voir aussi
Image de liste déroulante

En général, la plupart des sociétés souhaitent disposer d'un seul serveur de builds pour créer des builds, enregistrer des éléments de travail et créer des éléments de travail. Vous souhaitez éviter la confusion d'avoir différents serveurs de builds qui créent des builds publiques différentes. Toutefois, il est possible d'avoir des serveurs de builds distants et cela peut répondre aux besoins de vos équipes distantes.

Remarque Remarque

La redistribution des builds des bureaux distants à l'emplacement de développement principal n'offre aucun avantage.

Avant de créer un serveur de builds distant, prenez en considération les points suivants :

  • Si les équipes des bureaux distants souhaitent uniquement démarrer des builds et afficher des rapports, vous n'avez sûrement besoin que d'un serveur de builds à votre emplacement de développement principal.

  • Si les équipes distantes utilisent fréquemment ces builds, vous pouvez automatiser le téléchargement des builds à partir d'un emplacement cible de build central. Dans quelques sociétés, la stratégie de développement prévoit que toutes les builds proviennent d'un emplacement central afin que tout le monde dispose de la même version.

  • Les équipes multisites peuvent utiliser une build (génération) de bureau pour créer les fichiers binaires requis et par conséquent n'ont pas besoin du serveur de builds.

Pour plus d'informations, consultez Gestion des builds avec Team Foundation Build.

Voir aussi

Concepts

Team Foundation Server Proxy et contrôle de code source Team Foundation

Autres ressources

Planification de capacité pour le déploiement de Team Foundation


Examen des considérations sur la sécurité

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Examen des considérations sur la sécurité
Voir aussi
Image de liste déroulante

Avant de déployer Visual Studio Team System pour votre équipe ou organisation, vous devez passer en revue les indications de sécurité suivantes. Ces indications permettront à votre configuration de fonctionner de manière régulière et uniforme, tout en contribuant également à la protection de l'intégrité de vos données.

Activation de l'accès aux ports utilisés par les composants Team Foundation Server

Les différents composants de Team Foundation Server utilisent des ports différents pour dialoguer entre eux. Ces ports doivent être débloqués par les pare-feu pour que Team Foundation Server fonctionne correctement.

Le nombre d'ordinateurs que vous devrez examiner dépend de la topologie serveur que vous avez choisie pour votre installation. Pour plus d'informations, consultez Topologies prises en charge pour Team Foundation Server.

Ordinateurs client et couche Application de Team Foundation

La couche cliente se compose des instances de Visual Studio Team System qui communiquent avec Team Foundation Server. C'est là où les développeurs, les testeurs, les architectes et les gestionnaires effectuent leur travail sur les projets et suivent la progression enregistrée. La couche Application de Team Foundation Server répond aux requêtes du client.

Un client doit pouvoir accéder au port 80 sur le serveur de couche Application afin de pouvoir établir des rapports et accéder au portail du projet. Il a également besoin d'accéder au port 8080, qui est le port utilisé par le serveur de couche Application pour les services Web qui maintiennent le projet sur le serveur de couche Données.

Couche Données de Team Foundation

La couche Données de Team Foundation Server contient l'instance de SQL Server qui stocke les données réelles du projet. Cela inclut toutes les métadonnées du projet, tous les fichiers de code source et tous les produits de travail du projet.

La couche Application de Team Foundation Server communique par défaut avec la couche Données de Team Foundation Server via les ports TCP 1443 et UDP 1444 SQL Server.

Pour plus d'informations sur la communication entre les couches de Team Foundation, consultez Architecture de sécurité de Team Foundation Server.

Ordinateurs de build

Un ordinateur de build est un ordinateur dédié à la génération de la version la plus récente d'un projet géré par Team Foundation Server. Pour des raisons de sécurité, les ordinateurs des couches Application et Données ne doivent jamais être utilisés comme ordinateurs de build. Toutefois, un ordinateur client sur la couche cliente peut être utilisé sans risque dans cette fonction.

La couche Application de Team Foundation Server communique avec les ordinateurs de build sur le port 9191, qui est le port assigné à .NET Remoting.

Utilisation de SSL (Secure Sockets Layer) pour la communication

Si vous avez des clients distants qui utilisent Team Foundation Server sur Internet, vous pouvez souhaiter utiliser SSL (Secure Sockets Layer) pour toutes les communications entre le client distant et la couche Application. Dans cette situation, le client communiquera avec la couche Application de Team Foundation Server sur le port 443 SSL. L'administrateur du serveur devra assigner des ports sécurisés supplémentaires pour Windows SharePoint Services (pour le portail du projet) sur la couche Application de Team Foundation Server et les services Web. Pour plus d'informations sur la configuration de Team Foundation Server pour HTTPS, consultez Procédure pas à pas : configuration de Team Foundation Server avec SSL (Secure Socket Layer).

Dans la configuration distante, vous avez également besoin d'un serveur proxy dédié à la mise en cache des résultats des opérations par rapport au contrôle de code source. Le client doit également communiquer en toute sécurité avec ce serveur sur le port 443.

Configuration de l'authentification

Il existe deux types de base de comptes d'utilisateurs dans Team Foundation Server : les utilisateurs et groupes Windows et les utilisateurs et groupes Team Foundation Server. Les utilisateurs et groupes Team Foundation Server peuvent être globaux au serveur ou spécifiques à un projet donné.

Pour plus d'informations sur la configuration de l'authentification pour les divers composants d'une installation de Team Foundation Server, consultez Sécurité de Team Foundation Server pour les utilisateurs et les groupes.

Configuration du serveur pour une utilisation en groupe de travail

Il est possible de configurer Team Foundation Server en vue d'une exécution dans un groupe de travail. Dans ce cas, les utilisateurs peuvent utiliser des comptes d'ordinateurs locaux pour accéder au serveur. Les équipes exécutant leur serveur dans un groupe de travail doivent installer les couches Application et Données sur le même ordinateur.

Pour plus d'informations sur les conséquences sur la sécurité de l'exécution dans un groupe de travail, consultez Configuring Security in a Workgroup.

Sécurisation des transferts de fichiers

Les transferts de fichiers pour toutes les opérations de contrôle de code source s'effectuent via HTTP. Tous les fichiers sont stockés dans SQL Server. On suppose que le client dispose de la protection antivirus adéquate et que tous les fichiers sont analysés pour d'éventuels virus sur le client.

La seule façon de supprimer un fichier contaminé de Team Foundation Server est de supprimer directement toutes les versions infectées de SQL Server. Pour plus d'informations sur la suppression des fichiers infectés, consultez Comment : supprimer des fichiers orphelins de façon définitive.

Sécurité des ordinateurs de build

L'ordinateur de build doit s'exécuter sous un compte d'utilisateur désigné assigné au groupe Build Services, qui a des autorisations dans Team Foundation Server pour gérer des projets de build. Les deux méthodologies de processus MSF for Agile Software Development et MSF for CMMI Process Improvement prédéfinissent un tel groupe et le préconfigurent avec les autorisations appropriées. Pour plus d'informations sur la configuration des ordinateurs de build, consultez Paramétrage d'un ordinateur de build.

Lorsque vous configurez un ordinateur de build, vous spécifiez un emplacement cible pour le produit de build. Le compte d'utilisateur sous lequel la build s'exécute doit avoir les autorisations requises pour des opérations de lecture et d'écriture à partir de cet emplacement cible.

Sécurité des services Web

Tout l'accès aux services Web est sécurisé par le biais d'autorisations de groupes Team Foundation Server et IIS.

Voir aussi

Concepts

Vue d'ensemble de la sécurité de Team Foundation
Architecture de sécurité de Team Foundation Server
Autorisations de Team Foundation Server

Autres ressources

Planification du client et du serveur
Gestion des utilisateurs et groupes


Planification de capacité pour le déploiement de Team Foundation

Planification de capacité pour le déploiement de Team Foundation
DropDown image

La planification de Team Foundation Server vous permettra de choisir la meilleure configuration de composants. Le déploiement de Team Foundation Server variera en fonction des besoins de votre entreprise. Les rubriques de cette section vous guideront à travers plusieurs considérations sur la planification.

Dans cette section

Considérations sur les performances

Identifie les considérations sur la performance du déploiement de Team Foundation, y compris la taille de l'organisation que vous prenez en charge et les types de tâches que les utilisateurs doivent effectuer.

Directives de licences

Fournit une vue d'ensemble des impératifs liés aux licences pour Team Foundation Server.

Planification des besoins actuels

Identifie des considérations supplémentaires pour le déploiement de Team Foundation.

Rubriques connexes

Planification du client et du serveur

Sécurisation de Team Foundation Server

Administration de Team Foundation Server


Considérations sur les performances

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Considérations sur les performances
Voir aussi
Image de liste déroulante

Lorsque vous planifiez le déploiement de Team Foundation, vous devez considérer la performance globale dont vous avez besoin pour vos utilisateurs de Team Foundation. Le fait de bien comprendre la taille et la portée du déploiement vous aidera à prendre les décisions qui concernent la performance.

Optimisation de la performance

Pour optimiser la performance de Team Foundation, vous devez prendre plusieurs facteurs en considération ; par exemple la taille de votre organisation, les tâches quotidiennes, le matériel actuel et la topologie du réseau. Vous devez également considérer combien de gens seront chargés de la maintenance du déploiement de Team Foundation. Chacun de ces facteurs affectera votre planification.

Les éléments à prendre en compte les plus courants sont abordés brièvement ci-dessous et sont des directives générales pour vous aider dans le processus de planification. Vous pouvez avoir des facteurs supplémentaires dont vous souhaitez tenir compte ; par exemple, une prise en charge multilingue. Notez par écrit les considérations sur la performance propres à votre organisation et utilisez cette liste lors de la planification et de l'installation de Team Foundation.

Taille de votre organisation

Pensez au nombre d'utilisateurs que vous envisagez de prendre en charge. Pour moins de 100 utilisateurs, le déploiement de Team Foundation Server sur un seul serveur sera probablement suffisant. Pour plus de 100 utilisateurs ou pour un environnement de forte demande, le déploiement de Team Foundation Server sur deux serveurs offrira de meilleures performances. De la même façon, le nombre d'utilisateurs que vous projetez de prendre en charge affectera la manière dont vous optimisez d'autres ordinateurs dans votre déploiement, comme les serveurs de builds et les plates-formes de test. Pour plus d'informations, consultez Planification et préparation de Team Foundation.

Portée de votre déploiement

Considérez les types de tâches que vos utilisateurs doivent exécuter. Est-ce que vos utilisateurs doivent, par exemple, effectuer des tests organisés de logiciels ? Si c'est le cas, combien d'utilisateurs effectueront des tests ? Quelle est la fréquence d'exécution des tests, et combien de temps s'écoulera entre les itérations ? En posant ces questions et en déterminant les réponses, vous pouvez planifier le déploiement optimal des composants de Team Foundation. Pour plus d'informations, consultez Planification du client et du serveur.

Performance et matériel

Considérez votre serveur actuel et les ordinateurs clients. La performance de Team Foundation est directement liée à la vitesse du processeur, à la mémoire et à l'espace disponible sur le disque dur des ordinateurs sur lesquels chaque composant est installé. Devrez-vous mettre à niveau quelques-uns des ordinateurs de vos utilisateurs ? Devrez-vous acheter des serveurs supplémentaires ? Vous devez répondre à ces questions lors de la planification de la performance optimale. Pour plus d'informations sur la manière de déterminer la configuration matérielle requise, consultez Configuration de Visual Studio 2005 Team System.

Performance et connectivité réseau

Considérez la latence moyenne de votre réseau et comment vos utilisateurs se connecteront à Team Foundation Server. Une latence réseau de plus de 350 millisecondes peut sensiblement diminuer la performance de Team Foundation, ou même donner lieu à une indisponibilité intermittente du serveur. Est-ce que la latence moyenne de votre réseau se situe dans ces limites ? Devrez-vous optimiser vos routeurs et trafic réseau ? Si vous projetez de prendre en charge des utilisateurs distants, vous devez également considérer comment ces utilisateurs se connecteront aux serveurs de Team Foundation. Est-ce que l'accès Web sera suffisant pour ces utilisateurs, ou est-ce que vous devrez envisager d'obliger les utilisateurs à établir une connexion réseau privée virtuelle avec votre réseau avant de se connecter à Team Foundation Server ? Pour plus d'informations sur la connectivité réseau, consultez Configuration de Visual Studio 2005 Team System. Pour plus d'informations sur la prise en charge des utilisateurs distants, consultez Planification pour les bureaux distants.

Performance et maintenance

Considérez les tâches de maintenance quotidiennes et hebdomadaires que vous devrez exécuter. Combien de personnes maintiendront les serveurs de Team Foundation ? Combien de personnes seront disponibles pour aider les utilisateurs ? Comment est-ce que vous gérerez les sauvegardes, et combien de temps prendront-elles ? Quelques-unes de ces considérations peuvent vous amener à opérer des choix différents de ceux que vous pouvez faire si vous considérez seulement le nombre d'utilisateurs ou la portée du déploiement. Par exemple, un déploiement sur deux serveurs qui est optimisé pour une performance serveur rapide prendra plus de temps au niveau de la maintenance qu'un déploiement sur un seul serveur. Cela pourrait mettre une pression inutile sur une petite organisation avec une seule personne responsable de toutes les tâches de maintenance. Pour plus d'informations sur la maintenance, consultez Planification de la maintenance du serveur.

Voir aussi

Concepts

Planification du déploiement sur deux serveurs
Planification du déploiement sur un serveur
Analyse des performances

Autres ressources

Sécurisation de Team Foundation Server
Administration du contrôle de code source Team Foundation


Directives de licences

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Directives de licences
Voir aussi
Image de liste déroulante

Vous devez acheter des licences à la fois de serveur et de client pour pouvoir utiliser Microsoft Visual Studio 2005 Team Foundation Server. Le nombre de licences dont vous avez besoin dépend du nombre d'ordinateurs sur lesquels vous projetez d'effectuer l'installation et du nombre d'utilisateurs que vous envisagez d'autoriser à accéder à Team Foundation Server.

Cette rubrique fournit une vue d'ensemble des licences pour Team Foundation Server. Pour plus d'informations, consultez le livre blanc Team System Licensing White Paper à l'adresse (http://go.microsoft.com/fwlink/?LinkId=55164).

De combien de licences serveur est-ce que j'ai besoin ?

Vous avez besoin d'une licence serveur pour chaque ordinateur sur lequel vous installez des composants Team Foundation Server.

Type du déploiement | Nombre de licences serveur requises
Un serveur | Un seul
Deux serveurs | Deux : un pour l'ordinateur de couche Base de données et un pour l'ordinateur de couche Application.

De combien de licences de client est-ce que j'ai besoin ?

Vous avez besoin d'une licence pour chaque utilisateur ou périphérique qui accède à Team Foundation Server. Différents types de licences de client sont disponibles. Certains produits clients de Team Foundation Server, tels que Microsoft Visual Studio 2005 Team System, incluent déjà une licence d'accès client (Client Access License, CAL) et ne nécessitent par conséquent pas de licences supplémentaires pour l'accès à Team Foundation Server. Les licences doivent être achetées pour les utilisateurs qui n'accèdent pas à Team Foundation Server à l'aide d'un produit client. Pour plus d'informations, consultez le livre blanc Team System Licensing White Paper à l'adresse (http://go.microsoft.com/fwlink/?LinkId=55164).

Le mécanisme des licences est-il différent pour Team Foundation Server Workgroup Edition ?

L'utilisation de Microsoft Visual Studio 2005 Team Foundation Server Workgroup Edition est limitée à cinq utilisateurs. Les licences CAL ne sont pas nécessaires pour utiliser cette édition. Team Foundation Server Workgroup Edition est fourni avec des produits clients de Microsoft Visual Studio 2005 Team System via des abonnements MSDN Premium. Ces produits clients incluent les suivants :

  • Microsoft Visual Studio 2005 Team Suite

  • Microsoft Visual Studio 2005 Team Edition for Software Architects

  • Microsoft Visual Studio 2005 Team Edition for Software Developers

  • Microsoft Visual Studio 2005 Team Edition for Software Testers

Voir aussi

Autres ressources

Planification de capacité pour le déploiement de Team Foundation


Planification des besoins actuels

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Planification des besoins actuels
Voir aussi
Image de liste déroulante

Il y a beaucoup d'aspects à prendre en considération lorsque vous étudiez vos besoins pour un déploiement de Team Foundation. Le fait de bien comprendre la taille et la portée de votre organisation actuelle ainsi que les impératifs et les limitations des types de déploiement de Team Foundation Server vous aidera à prendre les décisions de planification nécessaires.

Considérations lors de l'estimation des besoins actuels

Pour planifier le déploiement de Team Foundation, vous devez tenir compte de plusieurs facteurs, comme la taille de votre organisation, les tâches et les rôles de vos utilisateurs, les caractéristiques actuelles de votre matériel et la configuration de votre réseau. Vous devez également déterminer combien de personnes vous disposez pour prendre en charge le déploiement de Team Foundation et effectuer les tâches de maintenance. Chacun de ces facteurs vous aidera à comprendre vos besoins actuels. Tous les facteurs n'aboutissent pas aux mêmes conclusions, mais une étude attentive de l'ensemble vous guidera pour créer un plan de déploiement qui répond aux besoins actuels de votre organisation.

Les éléments à prendre en compte les plus courants sont abordés brièvement ci-dessous et sont des directives générales pour vous aider dans le processus de planification. Vous pouvez avoir des facteurs supplémentaires dont vous souhaitez tenir compte, par exemple, une prise en charge multilingue. Écrivez les considérations spécifiques à votre organisation. Utilisez qui liste lors de la planification et de l'installation de Team Foundation.

Taille de votre organisation

Pensez au nombre d'utilisateurs que vous envisagez de prendre en charge. Un déploiement de Team Foundation Server sur un seul serveur est conçu pour un maximum de 100 utilisateurs et un nombre modéré de projets. Les déploiements de Team Foundation Server sur deux serveurs sont conçus pour plus de 100 utilisateurs, pour un grand nombre de projets et pour les environnements à forte demande. De la même façon, le nombre d'utilisateurs que vous planifiez de prendre en charge affectera la planification d'autres ordinateurs dans votre déploiement, comme les serveurs de builds et les plates-formes de test. Le fonctionnement des rôles de vos utilisateurs, tels que les développeurs de logiciels ou les architectes de logiciels, vous aidera également à planifier pour Team Foundation des clients appropriés aux besoins de votre organisation. Pour plus d'informations, consultez Planification et préparation de Team Foundation.

Portée de votre déploiement

Examinez les types et le nombre de tâches que vos utilisateurs doivent exécuter. Comme indiqué ci-dessus, le nombre et la complexité des projets que vous projetez de prendre en charge vous aideront à déterminer si vous déployez Team Foundation Server sur un serveur ou sur deux serveurs. De la même façon, bien comprendre les types de tâches que vos utilisateurs doivent accomplir, par exemple la génération ou le test de logiciels, vous aidera à planifier des composants supplémentaires tels que les serveurs de builds et les plates-formes de test. Pour plus d'informations, consultez Planification du client et du serveur.

Considérations sur le matériel

Étudiez votre serveur actuel et vos ordinateurs clients. Les composants Team Foundation ont des besoins spécifiques en termes de vitesse de processeur, de mémoire et d'espace de disque dur disponible. Devrez-vous mettre à niveau quelques-uns des ordinateurs de vos utilisateurs ? Devrez-vous acheter des serveurs supplémentaires ? Pour plus d'informations sur la manière de déterminer la configuration matérielle requise, consultez Configuration de Visual Studio 2005 Team System.

Configuration du réseau

Considérez la latence moyenne de votre réseau et comment vos utilisateurs se connecteront à Team Foundation Server. Une latence réseau de plus de 350 millisecondes peut sensiblement diminuer la performance de Team Foundation, ou même donner lieu à une indisponibilité intermittente du serveur. Est-ce que la latence moyenne de votre réseau se situe dans ces limites ? Devrez-vous mettre à niveau vos routeurs et augmenter la vitesse de votre trafic réseau ? Devrez-vous effectuer des étapes supplémentaires pour garantir la disponibilité de Team Foundation Server ? Pour plus d'informations sur les considérations relatives aux performances, consultez Considérations sur les performances et Analyse des performances.

Déterminez si vous devrez prendre en charge des utilisateurs distants et comment ces utilisateurs se connecteront aux serveurs de Team Foundation. Est-ce que l'accès Web sera suffisant pour ces utilisateurs, ou est-ce que vous devrez envisager d'obliger les utilisateurs à établir une connexion réseau privée virtuelle avec votre réseau avant de se connecter à Team Foundation Server ? Pour plus d'informations sur la prise en charge des utilisateurs distants, consultez Planification pour les bureaux distants.

Impératifs liés à la maintenance

Considérez les tâches de maintenance quotidiennes et hebdomadaires que vous devrez exécuter. Combien de personnes maintiendront les serveurs de Team Foundation ? Combien de personnes seront disponibles pour aider les utilisateurs ? Comment est-ce que vous gérerez les sauvegardes, et combien de temps prendront-elles ? Quelques-unes de ces considérations peuvent vous amener à opérer des choix différents de ceux que vous pouvez faire si vous considérez seulement le nombre d'utilisateurs ou la portée du déploiement. Par exemple, un déploiement sur deux serveurs qui est optimisé pour une performance serveur rapide prendra plus de temps au niveau de la maintenance qu'un déploiement sur un seul serveur. Cela pourrait mettre une pression inutile sur une petite organisation avec une seule personne responsable de toutes les tâches de maintenance. Pour plus d'informations sur la maintenance, consultez Planification de la maintenance du serveur.

Voir aussi

Concepts

Planification du déploiement sur deux serveurs
Planification du déploiement sur un serveur

Autres ressources

Sécurisation de Team Foundation Server
Administration du contrôle de code source Team Foundation


Planification de la maintenance du serveur

Planification de la maintenance du serveur
Voir aussi
DropDown image

La maintenance courante est critique pour les opérations en cours de Team Foundation Server. Vous devez planifier des sauvegardes régulières de votre serveur Team Foundation Server. Vous devez également avoir un plan de récupération d'urgence en place en cas de défaillance matérielle critique.

Dans cette section

Planification de la récupération d'urgence

Décrit des considérations sur la planification et les facteurs pour une atténuation de l'impact d'incidents tels que la défaillance matérielle.

Planification de la sauvegarde et de la restauration

Décrit des considérations sur la planification et les facteurs de sauvegarde et de restauration de Team Foundation Server.

Voir aussi

Concepts

Planification de Team Foundation Server


Planification de la récupération d'urgence

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Planification de la récupération d'urgence
Voir aussi
Image de liste déroulante

La planification anticipée est importante pour la récupération d'urgence efficace d'un déploiement de Team Foundation. Vous devez appréhender la taille et la portée de votre déploiement de Team Foundation, connaître le planning de maintenance et de sauvegardes pour Team Foundation Server et créer un plan de récupération d'urgence. Vous devez également envisager de simuler une situation de récupération d'urgence et exécuter pas à pas votre plan afin de tester l'efficacité de votre stratégie de récupération d'urgence.

Considérations de récupération d'urgence

Pour planifier la récupération d'urgence, vous devez tenir compte de plusieurs facteurs, par exemple qui sera chargé de lancer les procédures de récupération d'urgence, quels serveurs et matériel sont critiques pour le déploiement de Team Foundation, quelle est la fréquence et la portée des sauvegardes et où celles-ci seront stockées, et quel sera l'effet de l'indisponibilité de Team Foundation Server sur votre organisation. Tous les facteurs ne mènent pas aux mêmes conclusions, mais une considération prudente de la totalité vous guidera pour créer un plan de récupération d'urgence qui satisfait aux besoins actuels de votre organisation.

Les éléments à prendre en compte les plus courants sont abordés brièvement dans les sections suivantes et se veulent des directives générales pour vous aider dans le processus de planification. Vous pouvez avoir des facteurs supplémentaires que vous souhaitez considérer ; par exemple le clustering, le stockage des données hors site, ou la mise en mémoire de serveurs. Pensez à tenir compte des fonctionnalités uniques de votre déploiement de Team Foundation lorsque vous créez votre plan de récupération d'urgence.

Responsabilité de la récupération d'urgence

Considérez qui sera responsable de la récupération d'urgence. Est-ce que ce sera une personne seule ou toute une équipe ? Comment est-ce que ces personnes seront contactées ? Est-ce qu'il y a une façon de contacter ces personnes après les heures de travail normales ? Si une personne n'est pas disponible, quelqu'un d'autre peut-il effectuer les tâches à la place de cette personne ? Ces personnes sont-elles familiarisées avec le plan de récupération d'urgence ? Est-ce que tout le monde sait où trouver le plan de récupération d'urgence ? Pour plus d'informations, consultez Planification et préparation de Team Foundation.

Matériel critique

Considérez le matériel qui est requis pour les opérations quotidiennes de Team Foundation Server. Savez-vous quels ordinateurs sont critiques ? Avez-vous une liste de noms de serveurs et de caractéristiques ? Restreignez-vous l'accès physique à ce matériel critique ? Vous devrez gérer et maintenir régulièrement ce matériel critique, opérations qui incluent le contrôle d'accès du serveur et la réalisation de tâches de maintenance courantes sur des composants stratégiques.

Stockage de sauvegarde et récupération

Considérez la fréquence des sauvegardes de Team Foundation Server et où ces sauvegardes sont stockées. Quelle est la fréquence des sauvegardes des serveurs de Team Foundation ? Est-ce qu'il existe des sauvegardes incrémentielles en plus de sauvegardes complètes ? Est-ce que les utilisateurs extraient des fichiers vers leur espace de travail local ? Le fait de bien connaître l'état actuel des données de Team Foundation Server est important pour déterminer le point de restauration et l'effet que cela aura sur les utilisateurs. Pour plus d'informations sur la sauvegarde et la restauration de Team Foundation Server, consultez Sauvegarde du serveur Team Foundation Server et Restauration des sauvegardes de Team Foundation Server

Atténuation de l'impact des incidents

Déterminez s'il peut être rentable pour votre organisation de mettre en miroir ou en cluster vos serveurs Team Foundation et autres ordinateurs stratégiques. Combien est-ce cela coûterait à votre organisation de mettre en miroir les serveurs de Team Foundation ? Comment se situe ce coût par rapport au coût potentiel de productivité si Team Foundation Server n'est pas disponible aux utilisateurs pendant un jour ou plus ? Par exemple, si vous avez un déploiement de Team Foundation Server sur deux serveurs et si vos serveurs de couche Données connaissent une défaillance de contrôleur de disque dur, vous pourriez rediriger votre serveur de couche Application vers un serveur de couche Données en miroir, ce qui minimise l'impact de l'incident sur les utilisateurs. Le coût de maintenance d'un serveur en miroir est-il fiscalement justifiable ? Vous devez fournir le niveau de tolérance de panne le mieux approprié au besoin global de votre organisation. Pour plus d'informations sur la tolérance de panne et la disponibilité des serveurs, consultez Garantie de la disponibilité et du basculement de Team Foundation Server.

Voir aussi

Concepts

Planification du déploiement sur deux serveurs
Planification du déploiement sur un serveur

Autres ressources

Sécurisation de Team Foundation Server
Administration du contrôle de code source Team Foundation
Planification de la maintenance du serveur


Planification de la sauvegarde et de la restauration

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
Planification de la sauvegarde et de la restauration
Voir aussi
Image de liste déroulante

Créer un plan de sauvegarde et de restauration est une partie critique de tout déploiement de Team Foundation. Pour créer ce plan, vous devez comprendre la taille et la portée du déploiement de Team Foundation, désigner une personne ou une équipe pour effectuer les sauvegardes, déterminer une stratégie de stockage de sauvegarde et examiner quel logiciel de sauvegarde peut le mieux répondre aux besoins de votre organisation. Vous devez également envisager de tester l'intégrité de vos sauvegardes en exécutant des restaurations d'essai selon une fréquence régulière.

Considérations pour la sauvegarde et la restauration de vos serveurs

Il y a plusieurs facteurs à prendre en considération lors de la planification des sauvegardes de Team Foundation Server, par exemple quand planifier des sauvegardes, quelles données sauvegarder et comment stocker les sauvegardes. Tous les facteurs n'aboutissent pas aux mêmes conclusions, mais une étude attentive de l'ensemble vous guidera pour créer un plan de sauvegarde qui répond aux besoins actuels de votre organisation.

Les éléments à prendre en compte les plus courants sont abordés brièvement ci-dessous et sont des directives générales pour vous aider dans le processus de planification. Vous pouvez avoir des facteurs supplémentaires que vous souhaitez considérer ; par exemple le clustering, le stockage des données hors site, ou l'utilisation de serveurs miroirs. Pensez à tenir compte des caractéristiques uniques du déploiement de Team Foundation lors de la création de votre plan de sauvegarde et de restauration.

Portée des sauvegardes

Étudiez les serveurs et ordinateurs requis pour les opérations quotidiennes de Team Foundation Server. Vous devez sauvegarder régulièrement les données sur ces ordinateurs critiques, y compris sans que la liste soit limitative, les serveurs de builds, les contrôleurs de test et Team Foundation Server. Dans la mesure où les serveurs de Team Foundation ne sont pas disponibles pendant la sauvegarde, vous devez également planifier ces sauvegardes afin de limiter les perturbations pour vos utilisateurs. Vous pouvez choisir la fréquence aussi bien que le type de ces sauvegardes. Par exemple, vous pouvez choisir d'effectuer des sauvegardes incrémentielles des serveurs des couches Application et Données sur une base quotidienne, et des sauvegardes complètes sur une base hebdomadaire. Vous pouvez également déterminer s'il faut sauvegarder juste les données sur ces ordinateurs ou l'ordinateur tout entier pour une récupération et une restauration plus faciles. Par exemple, la sauvegarde de l'intégralité de Team Foundation Server requiert plus d'espace de stockage et plus de temps, mais lors de la restauration du serveur, vous n'avez pas à réinstaller et à reconfigurer Team Foundation Server. Pour plus d'informations, consultez Sauvegarde du serveur Team Foundation Server et Restauration des sauvegardes de Team Foundation Server.

Responsabilité des sauvegardes

Déterminez qui sera chargé de la sauvegarde de vos ordinateurs critiques. Est-ce que ce sera une personne seule ou toute une équipe ? Si vous sauvegardez les ordinateurs critiques après les heures de travail, vous pouvez opter pour des sauvegardes automatisées. Dans ce cas, toutefois, quelqu'un doit s'assurer que les sauvegardes automatisées se sont déroulées correctement. Si vous devez restaurer soudainement un serveur à partir d'une sauvegarde, est-ce qu'il existe un moyen de contacter ces personnes après les heures de travail normales ? Si une personne n'est pas disponible, quelqu'un d'autre peut-il sauvegarder ou restaurer les données ? Ces personnes sont-elles familiarisées avec le plan de récupération d'urgence ? Est-ce que tout le monde sait où trouver le plan de récupération d'urgence ? Pour plus d'informations, consultez Planification et préparation de Team Foundation.

Stockage de sauvegarde et récupération

Pensez au volume de stockage des données dont vous aurez besoin et où vous stockerez les données sauvegardées. Vous devez choisir le type de support de stockage qui répond le mieux aux besoins de votre organisation. Vous devez projeter de conserver au moins un jeu de sauvegardes dans un emplacement hors site. Pour plus d'informations sur le stockage de sauvegarde, consultez Backing Up and Restoring Data (http://go.microsoft.com/fwlink?linkid=28310).

Logiciel de sauvegarde

Déterminez si vous souhaitez utiliser les fonctionnalités de sauvegarde de votre système d'exploitation, ou si vous voulez investir dans un autre logiciel de sauvegarde. Vous pouvez choisir d'investir dans des systèmes intégrés de sauvegarde matériels et logiciels. Combien est-ce qu'une solution de logiciel de sauvegarde coûterait à votre organisation ? Comment est-ce que ce coût se compare aux avantages du jeu de fonctionnalités ? Votre logiciel de sauvegarde doit fournir le niveau de gestion de sauvegarde le mieux adapté à l'ensemble des besoins de votre organisation.

Test de l'intégrité des sauvegardes

Envisagez de tester l'intégrité de vos sauvegardes sur une base régulière. Vous devez consulter les journaux de sauvegarde pour d'éventuels événements ou erreurs sur une base quotidienne. Si votre logiciel de sauvegarde vous en offre la possibilité, vous devez exécuter des contrôles de l'intégrité des données sauvegardées. Vous devez également planifier la pratique des restaurations, y compris la restauration d'un serveur à partir de sauvegardes incrémentielles et la restauration d'un serveur à partir de sauvegardes complètes. Le test du scénario complet est la seule façon de garantir que vos sauvegardes assurent vraiment la couverture prévue des données.

Voir aussi

Tâches

Comment : sauvegarder un serveur Team Foundation Server

Concepts

Planification du déploiement sur deux serveurs
Planification du déploiement sur un serveur
Planification de la récupération d'urgence
Garantie de la disponibilité et du basculement de Team Foundation Server
Comment : restaurer les données de Team Foundation Server

Autres ressources

Sécurisation de Team Foundation Server
Administration du contrôle de code source Team Foundation
Planification de la maintenance du serveur


tfsplanninghxs {2DDA7CF9-E8CF-4df1-98E8-521EDE1C5FC7}

 Image de liste déroulante Image de pointage sur liste déroulante Copier l'image de pointage
Visual Studio Team System
tfsplanninghxs {2DDA7CF9-E8CF-4df1-98E8-521EDE1C5FC7}
Image de liste déroulante

tfsplanninghxs {2DDA7CF9-E8CF-4df1-98E8-521EDE1C5FC7}

{2DDA7CF9-E8CF-4df1-98E8-521EDE1C5FC7}

{2DDA7CF9-E8CF-4df1-98E8-521EDE1C5FC7}

Graphique Rubrique Recherche en texte intégral et débogage d'index