Amministratori di Team Foundation

 elenco a discesa elenco a discesa attivabile
Visual Studio Team System
Amministratori di Team Foundation
Vedere anche
elenco a discesa

Gli amministratori di Team Foundation Server sono responsabili dell'installazione e della manutenzione di Team Foundation Server, nonché dell'amministrazione delle autorizzazioni e della protezione di altri ruoli. Gli amministratori di Team Foundation Server possono inoltre personalizzare i modelli di processo.

Un amministratore di Team Foundation Server deve essere membro dei seguenti gruppi:

Ruolo a cui deve appartenere | Ruolo di amministratore di Team Foundation Server
Gruppi di computer a livello applicazione e dati | Amministratori di Windows
Gruppi di Team Foundation Server predefiniti | Amministratori di Team Foundation
Gruppi di Windows SharePoint Services | Amministratore del sito
Gruppi di Reporting Services | Responsabile della gestione del contenuto, Amministratore del sito
Nota Nota

La versione più aggiornata della Guida dell'amministratore di Team Foundation è disponibile sul Web sul sito MSDN Online (http://go.microsoft.com/fwlink/?linkid=52459).

In questa sezione

Pianificazione di Team Foundation Server

Vengono fornite le informazioni necessarie agli amministratori e ai responsabili delle decisioni aziendali per pianificare Team Foundation Server, comprese informazioni su requisiti hardware, requisiti software, topologie di distribuzione, linee guida per il processo e integrazione con altro software.

Migrazione a Team Foundation

Vengono elencati argomenti relativi alla migrazione a Team Foundation.

Amministrazione di Team Foundation Server

Vengono elencati argomenti relativi all'amministrazione di Team Foundation.

Amministrazione del controllo del codice sorgente di Team Foundation

Vengono elencati argomenti relativi all'amministrazione del controllo del codice sorgente mediante Team Foundation.

Amministrazione di Team Foundation Build

Vengono elencati argomenti relativi all'amministrazione di Team Foundation Build.

Amministrazione dei tipi di elemento di lavoro

Vengono elencati argomenti relativi all'amministrazione dei tipi di elementi di lavoro.

Personalizzazione dei modelli di processo

Vengono elencati argomenti relativi alla personalizzazione dei modelli di processo.

Vedere anche

Concetti

Protezione di Team Foundation Server per utenti e gruppi

Immagine piè di pagina
Per inviare suggerimenti o segnalare errori relativi alla Guida o a un'altra funzionalità del prodotto, visitare il sito per l'invio di suggerimenti.


Migrazione a Team Foundation

 elenco a discesa elenco a discesa attivabile
Migrazione a Team Foundation
Vedere anche
elenco a discesa

Negli argomenti di questa sezione viene descritta la migrazione a Team Foundation.

In questa sezione

Migrazione a Visual Studio Team System

Vengono forniti cenni preliminari sulla migrazione a Visual Studio Team System.

Processo di migrazione

Vengono descritte le operazioni necessarie per garantire una corretta migrazione a Team Foundation.

Procedure dettagliate relative alla migrazione

Vengono presentate procedure dettagliate sul processo di migrazione a Visual Studio Team System.

Migrazione da Visual SourceSafe

Viene descritta la migrazione da un ambiente di controllo del codice sorgente Visual SourceSafe a Team Foundation.

Migrazione da ClearQuest

Viene descritta la migrazione da un ambiente di gestione degli elementi di lavoro Visual SourceSafe a Team Foundation.

Riferimenti

Comando del convertitore VSS per la migrazione del controllo del codice sorgente

Riferimenti alla riga di comando per la migrazione degli elementi di lavoro

Vedere anche

Altre risorse

Team Foundation - Documentazione


Migrazione a Visual Studio Team System

 elenco a discesa elenco a discesa attivabile
Migrazione a Visual Studio Team System
Vedere anche
elenco a discesa

Visual Studio Team System fornisce convertitori che consentono di convertire le informazioni da sistemi preesistenti a Visual Studio Team System.

  • Da ClearQuest a Gestione degli elementi di lavoro di Team Foundation Converte gli elementi di lavoro e lo schema di ClearQuest da ClearQuest a Gestione elementi di lavoro Team Foundation.

  • Da Visual SourceSafe a Controllo del codice sorgente di Team Foundation Converte i progetti di controllo del codice sorgente da Visual SourceSafe a Controllo del codice sorgente Team Foundation.

  • I collegamenti riportati nelle sezioni seguenti consentono di visualizzare ulteriori informazioni sull'utilizzo dei convertitori per lo spostamento dei dati in Visual Studio Team System. Per ulteriori informazioni sulla migrazione, vedere Processo di migrazione.

Migrazione a Gestione degli elementi di lavoro di Team Foundation

Per la migrazione a Gestione elementi di lavoro Team Foundation sono disponibili le seguenti procedure dettagliate:

  • Procedura dettagliata: migrazione di elementi di lavoro ClearQuest a Team Foundation Vengono illustrati i passaggi per la migrazione da ClearQuest a Gestione elementi di lavoro Team Foundation.

Nei seguenti argomenti viene descritto in dettaglio il processo per la migrazione a Gestione elementi di lavoro Team Foundation:

  • Pianificazione della migrazione degli elementi di lavoro Viene illustrato come pianificare una migrazione da ClearQuest a Team Foundation.

  • Migrazione degli elementi di lavoro Viene illustrato come eseguire una migrazione da ClearQuest a Team Foundation.

  • Operazioni da effettuare una volta eseguita la migrazione degli elementi di lavoro Vengono descritte le attività da svolgere dopo la migrazione per garantire la riuscita della migrazione e risolvere eventuali problemi.

  • Riferimenti alla riga di comando per la migrazione degli elementi di lavoro Vengono elencate tutte le opzioni della riga di comando per il convertitore della migrazione degli elementi di lavoro.

Migrazione a Controllo del codice sorgente di Team Foundation

Per la migrazione a Controllo del codice sorgente Team Foundation sono disponibili le seguenti procedure dettagliate:

  • Procedura dettagliata: preparazione alla migrazione da Visual SourceSafe a Team Foundation Vengono illustrati i passaggi per la preparazione di un database di Visual SourceSafe per la migrazione a Controllo del codice sorgente Team Foundation.

  • Procedura dettagliata: migrazione da Visual SourceSafe a Team Foundation Vengono illustrati i passaggi per la migrazione di un database di Visual SourceSafe a Controllo del codice sorgente Team Foundation.

Nei seguenti argomenti viene descritto in dettaglio il processo per la migrazione a Controllo del codice sorgente Team Foundation:

  • Pianificazione della migrazione del controllo del codice sorgente Viene illustrato come pianificare una migrazione da Visual SourceSafe a Controllo del codice sorgente Team Foundation.

  • Migrazione del controllo del codice sorgente Viene illustrato come eseguire una migrazione da Visual SourceSafe a Controllo del codice sorgente Team Foundation.

  • Operazioni da effettuare una volta eseguita la migrazione del controllo del codice sorgente Vengono descritte le attività da svolgere dopo la migrazione per garantire la riuscita della migrazione e risolvere eventuali problemi.

  • Comando del convertitore VSS per la migrazione del controllo del codice sorgente Vengono elencate tutte le opzioni della riga di comando per il convertitore della migrazione del controllo del codice sorgente.

Vedere anche

Concetti

Controllo del codice sorgente di Team Foundation
Gestione degli elementi di lavoro di Team Foundation

Altre risorse

Guida introduttiva a Team Foundation


Processo di migrazione
Vedere anche
elenco a discesa

La migrazione consiste nello spostamento di elementi di lavoro o di file di codice sorgente in Team Foundation. Team Foundation include convertitori che consentono di eseguire la migrazione dei dati in Team Foundation. Un convertitore esegue la migrazione dei dati da Visual SourceSafe a Controllo del codice sorgente Team Foundation e l'altro esegue la migrazione dei dati da ClearQuest a Gestione elementi di lavoro Team Foundation.

Processo di migrazione

Il processo di migrazione è uguale per tutti i tipi di dati e consiste delle seguenti fasi:

  1. Esecuzione delle operazioni preliminari alla migrazione:

  2. Preparazione dei dati per la migrazione.

  3. Migrazione dei dati.

    Di seguito è illustrato il processo di migrazione:

    Immagine processo di migrazione

Esecuzione delle operazioni preliminari alla migrazione

Per eseguire le operazioni preliminari alla migrazione, attenersi alla procedura descritta di seguito:

  • Selezionare il periodo in cui eseguire la migrazione Pianificare la migrazione per un periodo in cui gli utenti non devono accedere ai dati di cui verrà eseguita la migrazione. È inoltre possibile bloccare i dati in modo che non venga apportata alcuna modifica durante la migrazione.

  • Creare un progetto Team di Team Foundation È necessario creare un progetto Team in cui eseguire la migrazione dei dati. Per ulteriori informazioni, vedere Procedura: creare un progetto Team.

  • Creare la definizione di un tipo di elemento di lavoro Se si esegue la migrazione di elementi di lavoro, è possibile che sia necessario creare un tipo di elemento di lavoro che consenta di eseguire la migrazione di tutti i dati che si desidera conservare dal software di gestione degli elementi di lavoro precedente. Per ulteriori informazioni, vedere Personalizzazione dei tipi di elemento di lavoro su Team Foundation Server.

Preparazione dei dati per la migrazione

Per preparare i dati per la migrazione, attenersi alla procedura descritta di seguito:

  • Eseguire il backup dei dati Attenersi alle istruzioni del software di origine per eseguire il backup dei dati.

  • Analizzare i dati Analizzare la modalità di migrazione dei dati. Entrambi i convertitori dispongono di una funzione di analisi che consente di determinare come viene eseguita la migrazione dei dati e apportare le modifiche appropriate. Durante l'analisi i convertitori creano file che contengono le impostazioni che verranno utilizzate per controllare la migrazione.

  • Apportare eventuali modifiche necessarie per garantire una corretta migrazione Se si rilevano dei problemi durante l'analisi, è possibile modificare i file delle impostazioni o il progetto Team per definire meglio la migrazione dei dati.

Migrazione dei dati

Per eseguire la migrazione dei dati, attenersi alla procedura descritta di seguito:

  • Modificare i file delle impostazioni per controllare la migrazione Durante l'analisi vengono creati diversi file che potrebbe essere necessario modificare. Ad esempio, per la migrazione di elementi di lavoro è necessario modificare il file di mapping utenti, il file di mapping campi e il file di mappa dello schema.

  • Eseguire la migrazione dei dati Utilizzare il convertitore per eseguire la migrazione dei dati. Per ulteriori informazioni, vedere Migrazione da Visual SourceSafe o Migrazione da ClearQuest.

  • Verificare la migrazione Verificare i dati in Team Foundation e assicurarsi che i dati di migrazione siano stati trasferiti correttamente.

Vedere anche

Concetti

Migrazione da Visual SourceSafe
Migrazione da ClearQuest


Migrazione da Visual SourceSafe

 elenco a discesa elenco a discesa attivabile
Migrazione da Visual SourceSafe
Vedere anche
elenco a discesa

Lo strumento convertitore Visual SourceSafe di Team Foundation consente di trasferire file, cartelle, cronologia della versione, etichette e informazioni utente da un database Visual SourceSafe a Controllo del codice sorgente Team Foundation. Prima di spostare file e informazioni cronologiche in Team Foundation, occorre esaminare una copia di backup del database Visual SourceSafe, archiviare il maggior numero di file possibile e determinare quali informazioni non possono essere trasferite da Visual SourceSafe a Team Foundation. Per ulteriori informazioni, vedere le sezioni che seguono:

Introduzione a Team Foundation per gli utenti di Visual SourceSafe

Vengono fornite informazioni introduttive sull'utilizzo di Controllo del codice sorgente Team Foundation da parte degli utenti di Visual SourceSafe.

Limitazioni del convertitore di Visual SourceSafe

Vengono illustrate le limitazioni del convertitore.

Modalità di migrazione degli eventi della cronologia

Viene descritto come viene eseguita la migrazione di determinati eventi cronologici da Visual SourceSafe a Controllo del codice sorgente Team Foundation.

Pianificazione della migrazione del controllo del codice sorgente

Viene illustrato come pianificare una migrazione da Visual SourceSafe a Controllo del codice sorgente Team Foundation.

Migrazione del controllo del codice sorgente

Viene illustrato come eseguire una migrazione da Visual SourceSafe a Controllo del codice sorgente Team Foundation.

Operazioni da effettuare una volta eseguita la migrazione del controllo del codice sorgente

Vengono descritte le attività da svolgere dopo la migrazione per garantire la riuscita della migrazione e risolvere eventuali problemi.

Comando del convertitore VSS per la migrazione del controllo del codice sorgente

Vengono elencate tutte le opzioni della riga di comando per il convertitore della migrazione del controllo del codice sorgente.

Vedere anche

Attività

Procedura dettagliata: preparazione alla migrazione da Visual SourceSafe a Team Foundation
Procedura dettagliata: migrazione da Visual SourceSafe a Team Foundation

Concetti

Processo di migrazione


Limitazioni del convertitore di Visual SourceSafe

 elenco a discesa elenco a discesa attivabile
Limitazioni del convertitore di Visual SourceSafe
Vedere anche
elenco a discesa

Il convertitore di Visual SourceSafe conserva la maggior parte delle informazioni cronologiche contenute nel database di Visual SourceSafe. Nelle seguenti sezioni viene indicato quali informazioni vengono mantenute e quali vengono scartate, nonché dove tali informazioni risultano disponibili in Controllo del codice sorgente Team Foundation al termine della migrazione.

Informazioni conservate

Lo strumento di conversione copia le seguenti informazioni cronologiche per gli elementi di cui si esegue la migrazione da Visual SourceSafe a Controllo del codice sorgente Team Foundation.

  • Aggiunta di file o cartelle Vengono salvati il nome del file o della cartella, la data e l'ora di aggiunta e il nome dell'utente.

  • Eliminazione di file o cartelle Vengono salvati il nome del file o della cartella, la data e l'ora di eliminazione e il nome dell'utente.

  • Annullamento dell'eliminazione di file o cartelle Vengono salvati il nome del file o della cartella, la data e l'ora di annullamento dell'eliminazione e il nome dell'utente.

  • Ridenominazione di file o cartelle Vengono salvati il nome precedente e quello nuovo, la data e l'ora della ridenominazione e il nome dell'utente.

  • Modifica di file Vengono salvati la data e l'ora di archiviazione e il nome dell'utente.

  • Modifica di etichette Vengono salvati il nome dell'etichetta, la data e l'ora di modifica e il nome dell'utente.

  • Spostamento di cartelle Vengono salvati il percorso precedente e quello nuovo, la data e l'ora dello spostamento e il nome dell'utente.

    Nota Nota

    Le informazioni sugli spostamenti di cartelle in un database di Visual SourceSafe vengono conservate in Controllo del codice sorgente Team Foundation solo se viene eseguita contemporaneamente la migrazione delle cartelle di origine e destinazione.

Informazioni non conservate

Lo strumento di conversione non conserva le informazioni cronologiche relative alle seguenti azioni di Visual SourceSafe:

  • Condivisione Poiché la condivisione non è supportata in Controllo del codice sorgente Team Foundation, la migrazione dei file condivisi viene eseguita mediante la copia in una cartella di destinazione della versione del file al momento della condivisione. Da quel momento, le modifiche apportate al file condiviso vengono replicate in entrambe le copie.

  • Diramazione Poiché la condivisione è una precondizione della diramazione, la migrazione di un file condiviso causa la copia del file nella cartella di destinazione. A seguito di un evento di diramazione, la migrazione delle eventuali modifiche apportate a una diramazione viene eseguita nella rispettiva copia in Controllo del codice sorgente Team Foundation.

  • Blocco Poiché in Controllo del codice sorgente Team Foundation il blocco non è supportato, la migrazione dei file bloccati viene eseguita creando due etichette. L'etichetta PINNED_LATEST viene applicata alle versioni bloccate dei file e all'ultima versione dei file sbloccati. L'etichetta PINNED viene applicata solo alle versioni bloccate dei file. Dopo la migrazione, l'etichetta PINNED_LATEST consentirà di recuperare gli stessi file restituiti dal comando Leggi ultima versione di Visual SourceSafe. È tuttavia possibile che l'etichetta PINNED_LATEST restituisca file differenti se si sono verificati eventi diversi dall'archiviazione dopo il blocco di un file, ad esempio ridenominazione o eliminazione del file.

Indicatori data e ora

L'indicatore data e ora associato a un'azione non viene conservato durante la migrazione, ma viene sostituito dall'indicatore data e ora corrispondente al momento della conversione. Tuttavia l'indicatore data e ora originale dell'azione di un utente viene aggiunto alla fine del commento.

Se ad esempio viene eseguita la conversione della seguente azione utente in Visual SourceSafe:

Azione utente | Versione | Indicatore data e ora | Commento
$/ProgettoA/a.c archiviazione | 5 | 3 giugno 2002, 12:30 | Bug corretto nella schermata di benvenuto

Tale azione utente verrà riportata in Controllo del codice sorgente Team Foundation nel seguente modo:

Azione utente | Versione | Indicatore data e ora | Commento
$/ProgettoA/a.c archiviazione | 5 | 2 maggio 2005, 15:30 | {03/06/2002 12:30} Bug corretto nella schermata di benvenuto

Vedere anche

Concetti

Modalità di migrazione degli eventi della cronologia


Modalità di migrazione degli eventi della cronologia

 elenco a discesa elenco a discesa attivabile
Modalità di migrazione degli eventi della cronologia
Vedere anche
elenco a discesa

In questo argomento viene descritto come viene eseguita la migrazione in Team Foundation degli eventi della cronologia registrati da Visual SourceSafe.

Eventi della cronologia

La migrazione degli eventi della cronologia viene eseguita nell'area equivalente di Team Foundation in modo da mantenere la cronologia dei file di origine. La cronologia delle versioni dei file viene creata riproducendo gli eventi che hanno creato la cronologia. Nella seguente tabella viene illustrata in dettaglio la migrazione di ciascun evento della cronologia.

Evento Modalità di migrazione

Aggiunta file o cartella

L'evento di aggiunta file crea la prima versione del file in Team Foundation. L'evento di aggiunta cartella crea la prima versione della cartella in Team Foundation. Se al momento dell'aggiunta la cartella conteneva file o cartelle, tali file e cartelle vengono aggiunte separatamente.

Modifica file

L'evento di modifica file crea una nuova versione del file in Team Foundation.

Applicazione etichetta file

In Team Foundation l'utente applica un'etichetta a una versione di un file o di una cartella. In Visual SourceSafe è possibile assegnare un'etichetta a un file in modo esplicito o implicito. Se in Visual SourceSafe a un file viene assegnata un'etichetta in modo esplicito, viene creata una nuova versione del file e se si richiede la lettura di tale etichetta, si otterrà il contenuto corrispondente alla versione precedente del file. Per eseguire la migrazione di etichette esplicite, il convertitore applica l'etichetta alla versione in Team Foundation corrispondente a quella con tale etichetta in Visual SourceSafe, ma non crea una nuova versione.

Se in Visual SourceSafe si assegna un'etichetta a una cartella, l'etichetta viene applicata in modo implicito a tutti i file e a tutte le cartelle contenute in tale cartella, ma non vengono create nuove versioni. Nel caso di etichette implicite, il convertitore non esegue alcuna operazione in quanto l'etichetta viene assegnata automaticamente alle versioni corrispondenti in Team Foundation durante la migrazione delle etichette esplicite applicate alla cartella.

Applicazione etichetta cartella

Se in Visual SourceSafe si assegna un'etichetta a una cartella, l'etichetta viene applicata in modo implicito a tutti i file e a tutte le cartelle contenute in tale cartella, ma non vengono create nuove versioni. Durante la migrazione di tali cartelle, il convertitore applica l'etichetta alla versione corrispondente della cartella in Team Foundation, assegnando automaticamente l'etichetta alle versioni correnti dei file e delle cartelle contenute nella cartella a cui è stata assegnata l'etichetta.

Ridenominazione, eliminazione o annullamento dell'eliminazione di file o cartelle

Durante la migrazione di un evento di ridenominazione, eliminazione e annullamento di eliminazione di un file o di una cartella, il convertitore riproduce l'evento per creare la nuova versione del file e della cartella in Team Foundation.

Spostamento cartella

L'evento di spostamento cartella crea una nuova versione della cartella in Team Foundation. In Visual SourceSafe il comando di spostamento non modifica il contenuto o la cronologia della cartella, bensì viene registrato nella cronologia della cartella padre nuova e precedente. Quando si sposta una cartella, Visual SourceSafe non è in grado di ricostruire una versione precedente della cartella padre.

Al termine della migrazione sarà invece possibile ricostruire una versione precedente grazie alla modalità di migrazione dell'evento di spostamento della cartella. Ad esempio, se è stata assegnata l'etichetta "ETICHETTA1" alla cartella $/A contenente la sottocartella /B e successivamente la cartella /B è stata spostata in un'altra cartella $/C e quindi in Visual SourceSafe si richiede la lettura di "ETICHETTA1" da $/A, non si otterrà $/A/B. Al termine della migrazione a Team Foundation, invece, si otterrà la cartella spostata ($/A/B) quando si richiede la lettura dell'etichetta.

Durante la migrazione di cartelle spostate possono presentarsi tre scenari con risultati differenti, a seconda dell'oggetto della migrazione:

  • Viene eseguita la migrazione di entrambe le cartelle di origine e di destinazione. Nessuna perdita di dati. Nel caso dell'esempio precedente, viene eseguita la migrazione della cartella di origine $/A e della cartella di destinazione $/C.

  • Viene eseguita la migrazione solo della cartella di destinazione. Al termine della migrazione, la cartella spostata viene visualizzata nella cartella di destinazione come se fosse stata aggiunta al momento dello spostamento. Non viene eseguita la migrazione in Team Foundation della cronologia della cartella spostata e degli elementi in essa contenuti prima dell'evento di spostamento. Nel caso dell'esempio precedente, l'evento di spostamento della sottocartella /B verrà visualizzato in $/C come un evento di aggiunta cartella. Per impedire la perdita dei dati cronologici, è consigliabile eseguire la migrazione contemporanea delle cartelle di origine e di destinazione della cartella spostata. Quando si esegue l'analisi della migrazione, il report risultante contiene una sezione di avviso in cui viene segnalata la possibile perdita di dati.

  • Viene eseguita la migrazione solo della cartella di origine. Durante la migrazione non viene eseguita la migrazione in Team Foundation della cronologia della cartella spostata e degli elementi in essa contenuti. Per impedire la perdita dei dati cronologici, è consigliabile eseguire la migrazione contemporanea delle cartelle di origine e di destinazione della cartella di Visual SourceSafe spostata. Quando si esegue l'analisi della migrazione, il report risultante contiene una sezione di avviso in cui viene segnalata la possibile perdita di dati.

Condivisione file

In Visual SourceSafe è possibile condividere un file tra più cartelle. Le modifiche apportate a un file condiviso vengono replicate nelle cartelle di condivisione. Internamente in Visual SourceSafe vengono creati collegamenti software tra i file condivisi. Tecnicamente, le cartelle non sono condivise in Visual SourceSafe. Infatti, quando si condivide una cartella in Visual SourceSafe, viene creata una copia della cartella e tutti i file in essa contenuti vengono condivisi.

In Team Foundation non è disponibile una funzionalità di condivisione equivalente. La migrazione dei file condivisi viene eseguita creando nella cartella di destinazione una versione del file con lo stesso contenuto della versione del file al momento della condivisione. Le modifiche apportate successivamente al file condiviso vengono replicate dal convertitore in entrambe le posizioni.

Condivisione ed eliminazione file

Un file condiviso e successivamente eliminato viene gestito come un file condiviso, con la differenza che vengono ignorate tutte le azioni posteriori all'eliminazione.

Se l'eliminazione del file condiviso viene successivamente annullata, durante la migrazione il convertitore segnalerà un errore per ogni azione eseguita sul file, ad esempio modifica o ridenominazione. Tuttavia, durante la migrazione dell'azione di annullamento dell'eliminazione, il convertitore esegue una modifica del file e l'annullamento dell'eliminazione in modo che il contenuto del file corrisponda a quello del file in Visual SourceSafe di cui è stata annullata l'eliminazione.

Se il file condiviso eliminato viene successivamente rinominato, durante la migrazione il convertitore segnalerà un errore per l'azione di ridenominazione. Non verrà perciò eseguita la migrazione delle azioni successive alla ridenominazione e per ognuna di esse il convertitore segnalerà un errore.

Diramazione file

La condivisione è una precondizione per la diramazione. Il convertitore non può associare una diramazione di Visual SourceSafe a una diramazione di Controllo del codice sorgente Team Foundation. La migrazione di un file condiviso produce una replica del file nella cartella di destinazione. La migrazione di un evento di diramazione causa l'interruzione della replica in entrambe le posizioni delle modifiche apportate a un file condiviso. Di conseguenza, la migrazione delle modifiche apportate a una diramazione viene eseguita solo nella rispettiva copia in Team Foundation. Il report di migrazione fornisce un elenco delle cartelle contenenti file condivisi o con diramazioni in Visual SourceSafe.

Archiviazione

Quando si archiviano file o cartelle in Visual SourceSafe, è possibile rimuovere completamente la cronologia di un file o di una cartella oppure rimuovere dalla cronologia solo alcune versioni. Se la cronologia è stata rimossa, il convertitore non può eseguire la migrazione delle versioni rimosse e per questo motivo ignora l'evento di archiviazione.

Ripristino

Quando si esegue un ripristino in Visual SourceSafe, si ripristina la cronologia di un file o di una cartella archiviata. Il convertitore esegue la migrazione della cronologia di file e cartelle ripristinata ed ignora l'evento di ripristino.

Blocco e sblocco

Poiché in Controllo del codice sorgente Team Foundation il blocco non è supportato, la migrazione dei file bloccati viene eseguita creando due etichette. L'etichetta PINNED_LATEST viene applicata alle versioni bloccate dei file e all'ultima versione dei file sbloccati. L'etichetta PINNED viene applicata solo alle versioni bloccate dei file. Dopo la migrazione, l'etichetta PINNED_LATEST consentirà di recuperare gli stessi file restituiti dal comando Leggi ultima versione di Visual SourceSafe. È tuttavia possibile che l'etichetta PINNED_LATEST restituisca file differenti se si sono verificati eventi diversi dall'archiviazione dopo il blocco di un file, ad esempio ridenominazione o eliminazione del file.

Vedere anche

Concetti

Modalità di raggruppamento del convertitore degli insiemi di modifiche per fornire prestazioni migliori

Altre risorse

Pianificazione della migrazione del controllo del codice sorgente


Modalità di raggruppamento del convertitore degli insiemi di modifiche per fornire prestazioni migliori

 elenco a discesa elenco a discesa attivabile
Modalità di raggruppamento del convertitore degli insiemi di modifiche per fornire prestazioni migliori
Vedere anche
elenco a discesa

In Controllo del codice sorgente Team Foundation gli insiemi di modifiche vengono utilizzati per raggruppare le informazioni su un'archiviazione. Un insieme di modifiche comprende:

  • Revisioni di cartelle e file di origine, ad esempio aggiunte, ridenominazioni, modifiche, eliminazioni e spostamenti.

  • Elementi di lavoro correlati.

  • Metadati di sistema, ad esempio il proprietario e la data e l'ora di archiviazione.

  • Note e commenti di archiviazione.

In Visual SourceSafe ogni azione in un file o in una cartella crea una nuova versione nella cronologia dei file, delle cartelle o di entrambi. Durante la migrazione le distinte azioni nella cronologia di Visual SourceSafe vengono raggruppate in un unico insieme di modifiche in base ai seguenti criteri:

  1. Azioni consecutive.

  2. Azioni non in conflitto. Ad esempio, due azioni non influenzano lo stesso file o cartella.

  3. Azioni con lo stesso commento di archiviazione.

  4. Azioni completate dallo stesso utente.

Il raggruppamento delle azioni in un unico insieme di modifiche aumenta le prestazioni della migrazione.

Vedere anche

Concetti

Limitazioni del convertitore di Visual SourceSafe
Modalità di migrazione degli eventi della cronologia


Pianificazione della migrazione del controllo del codice sorgente

 elenco a discesa elenco a discesa attivabile
Pianificazione della migrazione del controllo del codice sorgente
Vedere anche
elenco a discesa

In questa sezione sono contenute informazioni relative alla pianificazione della migrazione di progetti di controllo del codice sorgente di Visual SourceSafe a Controllo del codice sorgente Team Foundation. Il processo di migrazione è dispendioso in termini di tempo per la quantità di dati coinvolti. Il convertitore fornisce opzioni di migrazione che possono ridurre al minimo il tempo di migrazione o consentire ai team di continuare a utilizzare il controllo del codice sorgente durante la migrazione. Valutare quale delle seguenti opzioni di migrazione sia la migliore per il proprio team.

  • Migrazione progetto per progetto Utilizzare questa opzione per eseguire la migrazione del codice sorgente di un team o di un progetto alla volta, che in genere corrisponde a una cartella in Visual SourceSafe. In questo modo gli altri team non sono bloccati durante la migrazione. Tuttavia se due team utilizzano codice sorgente con dipendenze, è necessario eseguire la migrazione contemporanea del codice sorgente di entrambi i team, cioè delle cartelle del progetto. Infatti eventuali dipendenze tra le due cartelle potrebbero causare la perdita di dati se viene eseguita la migrazione solo di alcune cartelle. La fase di analisi consente di identificare le dipendenze tra le cartelle.

  • Migrazione incrementale Utilizzare questa opzione per eseguire la migrazione del database di Visual SourceSafe in fasi. In questo modo si consente agli utenti di continuare a utilizzare Visual SourceSafe mentre è in progresso la migrazione. Per ulteriori informazioni, vedere Procedura: eseguire una migrazione incrementale a Team Foundation

  • Utilizzo della funzione di archiviazione di VSS per eseguire la migrazione parziale della cronologia Utilizzare questa opzione se non si desidera eseguire la migrazione della cronologia precedente. In questo modo è possibile rimuovere la cronologia delle versioni del file e della cartella prima di una data specifica. Per ulteriori informazioni, vedere Procedura: eseguire la migrazione di una cronologia parziale mediante gli archivi in Visual SourceSafe.

Nella seconda fase si esegue l'analisi del database di Visual SourceSafe di cui si desidera eseguire la migrazione e quindi si esegue la migrazione effettiva del database da Visual SourceSafe a Controllo del codice sorgente Team Foundation. La fase di analisi genera un report che contiene informazioni sulla perdita potenziale di dati durante la migrazione. Sebbene sia possibile prevenire alcune di queste perdite di dati eseguendo certe operazioni prima della migrazione. altre perdite non possono essere evitate perché alcuni dati di Visual SourceSafe non possono essere associati a Controllo del codice sorgente Team Foundation. Al termine della migrazione viene presentato un report che contiene informazioni sullo stato e su eventuali perdite di dati subite durante la migrazione. A questo punto potrebbe essere necessario eseguire alcune operazioni per accertarsi di potere utilizzare il codice sorgente di cui è stata eseguita la migrazione.

In questa sezione

Procedura: preparare il database Visual SourceSafe per l'esecuzione del convertitore

Viene descritto come preparare Visual SourceSafe per la migrazione.

Procedura: creare un file di impostazioni per l'analisi e la migrazione del controllo del codice sorgente

Viene descritto come creare un file di impostazioni per controllare la migrazione.

Procedura: analizzare il database VSS per la migrazione

Viene descritto come generare un report di analisi prima della migrazione.

Procedura: configurare SQL Express per la migrazione

Viene descritto come configurare SQL Express per la migrazione.

Procedura: preparare Team Foundation per la migrazione

Viene descritto come preparare Controllo del codice sorgente Team Foundation per la migrazione.

Vedere anche

Riferimenti

Comando del convertitore VSS per la migrazione del controllo del codice sorgente

Altre risorse

Migrazione del controllo del codice sorgente
Operazioni da effettuare una volta eseguita la migrazione del controllo del codice sorgente


Procedura: preparare il database Visual SourceSafe per l'esecuzione del convertitore

Procedura: preparare il database Visual SourceSafe per l'esecuzione del convertitore
Vedere anche

Prima di analizzare o eseguire la migrazione di file inclusi nel controllo del codice sorgente da Visual SourceSafe a Visual Studio 2005, è necessario preparare il database di Visual SourceSafe.

Preparazione del database di Visual SourceSafe per l'esecuzione del convertitore

Per preparare il database di Visual SourceSafe per la migrazione, è necessario archiviare tutti i file, correggere eventuali errori di integrità dei dati, eseguire il backup del database e decidere di quali progetti si desidera eseguire la migrazione.

Per preparare gli utenti per la migrazione

  • Richiedere a tutti gli utenti del database di Visual SourceSafe di archiviare i loro file.

Per preparare i progetti per la migrazione

  1. Intallare Visual SourceSafe 2005 sul computer su cui è in esecuzione il convertitore. Visual SourceSafe 2005 non viene installato per impostazione predefinita quando si installa Visual Studio.

  2. Copiare il database di Visual SourceSafe in una cartella locale sul computer su cui è in esecuzione il convertitore. Sebbene sia possibile eseguire la migrazione di un database di Visual SourceSafe in una cartella condivisa su un computer remoto, la migrazione richiede più tempo.

  3. Se il database di Visual SourceSafe è di una versione precedente a Visual SourceSafe 6.0, eseguirne l'aggiornamento a quest'ultima versione mediante l'utilità DDUPD di Visual SourceSafe.

  4. Correggere eventuali errori di integrità dei dati. Utilizzare lo strumento di analisi di Visual SourceSafe per individuare e, se possibile, risolvere eventuali problemi di integrità dei dati nel database.

Protezione

È necessario appartenere al gruppo Administrators di Team Foundation su Team Foundation per potere completare questa procedura. È inoltre necessario essere un amministratore di sistema per SQL Express.

Vedere anche

Attività

Procedura dettagliata: preparazione alla migrazione da Visual SourceSafe a Team Foundation
Procedura dettagliata: migrazione da Visual SourceSafe a Team Foundation


Procedura: creare un file di impostazioni per l'analisi e la migrazione del controllo del codice sorgente

Procedura: creare un file di impostazioni per l'analisi e la migrazione del controllo del codice sorgente
Vedere anche

È possibile creare un file di impostazioni per controllare le modalità di analisi o di migrazione a Team Foundation dei dati del controllo del codice sorgente. La creazione del file di impostazioni consente di analizzare il processo di migrazione in primo luogo per identificare tempestivamente eventuali problemi che potrebbero verificarsi durante la migrazione. Sarà poi possibile modificare tale file di impostazioni per eseguire effettivamente la migrazione.

Prima di creare il file di impostazioni, è necessario completare le seguenti operazioni:

  • Identificare le cartelle in Visual SourceSafe di cui si desidera eseguire la migrazione.

  • Per la migrazione, identificare la destinazione delle cartelle Visual SourceSafe, ossia cartelle vuote o di destinazione in cui il convertitore creerà le cartelle in Controllo del codice sorgente Team Foundation. Se la cartella si trova nella cartella principale ($/) in Controllo del codice sorgente Team Foundation, il convertitore non crea una cartella di destinazione.

  • Per eseguire il mapping utenti di Visual SourceSafe agli utenti di Team Foundation Server, utilizzare il file di mapping utenti generato durante l'analisi. Per ulteriori informazioni, vedere Procedura: modificare il file di mapping utenti per la migrazione del controllo del codice sorgente.

Il formato del file di impostazioni per l'analisi è leggermente diverso da quello utilizzato per la migrazione e presenta le differenze evidenziate nelle seguenti sezioni.

Per creare un file di impostazioni per l'analisi

  1. Creare un file XML mediante un editor di testo, quale Blocco note.

  2. Copiare nel file XML il testo riportato nella sezione Formato del file di impostazioni per l'analisi in File di esempio delle impostazioni del convertitore VSS.

  3. Nella sezione <VSSDatabase> specificare il percorso del database di Visual SourceSafe per cui si desidera eseguire l'analisi.

  4. Facoltativamente è possibile specificare il nome e il percorso del file di mapping utenti nella sezione <UserMap>. Se non viene fornito il nome del file, il convertitore genererà un file denominato UserMap.xml nella cartella corrente.

  5. Nella sezione <ProjectMap> specificare le cartelle di Visual SourceSafe da analizzare.

  6. Nella sezione <Settings>, all'interno della sezione <Output>, è possibile specificare il nome e il percorso del file del report di analisi. Se non viene specificato il nome del file, il convertitore genererà un file denominato VSSAnalysisReport.xml.

  7. Salvare il file di impostazioni come file XML con estensione xml.

Per creare un file di impostazioni per la migrazione

  1. Copiare il file di impostazioni creato per l'analisi e salvarlo con un nuovo nome. Per riferimento, vedere la sezione Formato del file di impostazioni per la migrazione in File di esempio delle impostazioni del convertitore VSS.

  2. Modificare il file di impostazioni per la migrazione come descritto di seguito.

    • Nella sezione <ProjectMap>, per ogni cartella di Visual SourceSafe di cui si esegue la migrazione, aggiungere le cartelle di destinazione in Controllo del codice sorgente Team Foundation. Per aggiungere una sezione Destination, utilizzare il formato riportato di seguito.

      Immagine CopyCode Copia codice
      <Project Source="$/FolderA" Destination="$/TeamProjectA"></Project>

    • Nella sezione <Settings> aggiungere una sezione <TeamFoundationServer> e specificare il nome, la porta e il protocollo per il server Team Foundation Server di destinazione per la migrazione nel seguente formato:

      Immagine CopyCode Copia codice
      <TeamFoundationServer name="TFS_server_name" port="port_number" protocol="http"></TeamFoundationServer>

      Ad esempio:

      Immagine CopyCode Copia codice
      <TeamFoundationServer name="My_TFS_server" port="8080" protocol="http"></TeamFoundationServer>

    • Facoltativamente, nella sezione <Settings>, all'interno della sezione <Output>, è possibile specificare il nome e il percorso del file del report di analisi. Se non viene fornito il nome del file, il convertitore genererà un file denominato VSSMigrationReport.xml.

    Nota Nota

    Per la memorizzazione di alcuni metadati durante la migrazione il convertitore utilizza SQLExpress. Questi metadati in genere occupano una percentuale di dati molto bassa nel corso della migrazione. In the unlikely event that your migration fails because of the 4GB limit of SQLExpress, you can set the converter to use SQLServer instead by adding the following line to the <Source name="VSS"> section of the settings file: <SQL Server="SQL_Server_name"></SQL>. Ad esempio:

  3. Salvare il file di impostazioni come file XML con estensione xml.

Vedere anche

Attività

Procedura dettagliata: preparazione alla migrazione da Visual SourceSafe a Team Foundation
Procedura dettagliata: migrazione da Visual SourceSafe a Team Foundation
Procedura: creare un progetto Team
Procedura: aggiungere un progetto o una soluzione al controllo del codice sorgente

Riferimenti

Comando del convertitore VSS per la migrazione del controllo del codice sorgente

Concetti

File di esempio delle impostazioni del convertitore VSS


File di esempio delle impostazioni del convertitore VSS

 elenco a discesa elenco a discesa attivabile
File di esempio delle impostazioni del convertitore VSS
Vedere anche
elenco a discesa

Il file di impostazioni del convertitore VSS è un file XML che contiene la configurazione per l'analisi o la migrazione. Le sezioni del file di impostazioni vengono descritte più avanti in questo argomento, seguite da un file di impostazioni di esempio per l'analisi e la migrazione che è possibile utilizzare per creare un file di impostazioni personalizzato.

Sezioni del file di impostazioni

Il file XML di impostazioni del convertitore VSS contiene diverse sezioni che specificano le configurazioni che è necessario fornire per analizzare un database di Visual SourceSafe per la migrazione o per eseguire la migrazione a Team Foundation. Queste sezioni vengono descritte in dettaglio in questo argomento.

<ConverterSpecificSetting>

Nel nodo XML <ConverterSpecificSetting> sono contenute informazioni sulle impostazioni relative al database di Visual SourceSafe di cui si desidera eseguire la migrazione. Il convertitore utilizza queste informazioni per la migrazione.

  • Nella sezione <name> del nodo <VSSDatabase> è contenuto il percorso della cartella in cui si trova il file srcsafe.ini.

  • Nella sezione <name> del nodo <UserMap> è contenuto il file di mapping utenti. Per ulteriori informazioni, vedere Procedura: modificare il file di mapping utenti per la migrazione del controllo del codice sorgente.

  • Nel nodo <Project>, sotto il nodo <ProjectMap>, è necessario specificare la cartella di Visual SourceSafe per l'analisi o la migrazione, nonché, per la migrazione, la cartella di Controllo del codice sorgente Team Foundation in cui eseguire la migrazione. È possibile aggiungere più nodi <Project> per analizzare o eseguire la migrazione di più cartelle di Visual SourceSafe.

    Nota Nota

    Il convertitore utilizza SQL Express durante la migrazione. Se la migrazione non riesce a causa del limite di 4 GB di SQL Express, è possibile impostare il convertitore affinché utilizzi SQL Server mediante l'aggiunta della seguente riga alla sezione <Source name="VSS">: <SQL Server="SQL_Server_name"></SQL>

<Settings>

All'interno del nodo <Settings>, in <file> nella sezione <Output>, è possibile specificare il nome e il percorso del file del report di analisi o di migrazione. Se non si specifica un nome di file, il convertitore genera il file VSSAnalysisReport.xml durante l'analisi e VSSMigrationReport.xml durante la migrazione.

Formato del file di impostazioni per l'analisi

Il file di impostazioni contiene le informazioni di cui il convertitore di Visual SourceSafe deve disporre per analizzare il database di Visual SourceSafe di cui si desidera eseguire la migrazione. È possibile copiare il file XML riportato di seguito in questo argomento e modificarlo per creare un file di impostazioni personalizzato.

Immagine CopyCode Copia codice
<?xml version="1.0" encoding="utf-8"?>
<SourceControlConverter>
<ConverterSpecificSetting>
     <Source name="VSS">
          <VSSDatabase name="c:\VSSDatabase"></VSSDatabase>
          <UserMap name="c:\Migrate\Usermap.xml"></UserMap>
     </Source>
     <ProjectMap>
          <Project Source="$/FolderA"></Project>
          <Project Source="$/FolderB"></Project>
     </ProjectMap>
</ConverterSpecificSetting>
<Settings>
     <Output file="Analysis.xml"></Output>
</Settings>
</SourceControlConverter>
Nota Nota

Se manca una delle sezioni sopra riportate, si verifica un errore di convalida XML.

Formato del file di impostazioni per la migrazione

Il file di impostazioni contiene le informazioni di cui il convertitore di Visual SourceSafe deve disporre per eseguire la migrazione del database di Visual SourceSafe a Controllo del codice sorgente Team Foundation. È possibile copiare il file XML riportato di seguito in questo argomento e modificarlo per creare un file di impostazioni personalizzato o utilizzare le procedure riportate in precedenza per modificare il file di impostazioni creato per l'analisi.

Immagine CopyCode Copia codice
<?xml version="1.0" encoding="utf-8"?>
<SourceControlConverter>
<ConverterSpecificSetting>
     <Source name="VSS">
          <VSSDatabase name="c:\VSSDatabase"></VSSDatabase>
          <UserMap name="c:\Migrate\Usermap.xml"></UserMap>
     </Source>
     <ProjectMap>
          <Project Source="$/FolderA" Destination="$/TeamProjectA"></Project>
          <Project Source="$/FolderB" Destination ="$/TeamProjectB/ProjectB"></Project>
     </ProjectMap>
</ConverterSpecificSetting>
<Settings>
     <TeamFoundationServer name="My_TFS_Server" port="8080" protocol="http"></TeamFoundationServer>
     <Output file="Migration.xml"></Output>
</Settings>
</SourceControlConverter>

Vedere anche

Attività

Procedura: creare un file di impostazioni per l'analisi e la migrazione del controllo del codice sorgente


Procedura: analizzare il database VSS per la migrazione

Procedura: analizzare il database VSS per la migrazione

Il processo di migrazione è dispendioso in termini di tempo per la quantità di dati coinvolti. Per ridurre il tempo di migrazione e verificare che gli altri team non siano bloccati durante il processo, eseguire la migrazione del codice sorgente di un team alla volta. Se due team utilizzano codice sorgente con dipendenze, eseguire la migrazione contemporanea del codice sorgente di entrambi i team per evitare possibili perdite di dati. Nella fase di analisi vengono evidenziate le aree in cui esistono delle dipendenze.

Il report di analisi descrive a grandi linee la perdita potenziale di dati. Per evitare in parte la perdita potenziale di dati, si consiglia di effettuare alcune operazioni prima della migrazione. Alcune perdite di dati, tuttavia, non possono essere evitate in quanto non è possibile definire il mapping tra alcuni dati di Visual SourceSafe e di Controllo del codice sorgente Team Foundation.

Nota Nota

Prima di potere analizzare il database di Visual SourceSafe, è necessario creare un file di impostazioni.

Per analizzare un progetto con il convertitore

  1. Al prompt dei comandi digitare quanto segue:

    VSSConverter Analyze settings.xml

  2. Al prompt fornire la password dell'amministratore di Visual SourceSafe.

    Lo strumento del convertitore visualizza lo stato dell'analisi eseguita prima della conversione. Al termine verranno generati un report e un file di mapping utenti nella directory corrente.

Vedere anche

Attività

Procedura: creare un file di impostazioni per l'analisi e la migrazione del controllo del codice sorgente
Procedura: configurare SQL Express per la migrazione


Procedura: configurare SQL Express per la migrazione

Procedura: configurare SQL Express per la migrazione

È necessario installare SQL Express sul computer su cui è in esecuzione il convertitore per la migrazione. Il convertitore VSS legge la cronologia di singoli file e cartelle nel database di Visual SourceSafe e la memorizza in SQL Express. Il convertitore ordina quindi la cronologia e la elabora ulteriormente. Infine legge la cronologia da SQL Express e avvia la migrazione.

Assicurarsi di disporre dei privilegi di amministratore per SQL Express. Se si installa Visual Studio 2005, si dispone automaticamente di tali privilegi.

Nota Nota

È possibile che il convertitore si chiuda durante la fase di preparazione della migrazione di un database di Visual SourceSafe di grandi dimensioni a causa del limite di 4 GB di SQL Express. Per continuare, è necessario configurare il convertitore in modo che utilizzi SQL Server invece di SQL Express oppure provare a eseguire la migrazione di cartelle più piccole o di una cronologia parziale mediante la funzione di archiviazione di Visual SourceSafe. È possibile impostare il convertitore affinché utilizzi SQL Server nel file di impostazioni.

Per eseguire l'analisi della migrazione del controllo del codice sorgente, è necessario essere un amministratore di sistema per SQL Express. Per impostazione predefinita, se si è installato Visual Studio, si dispone già dei privilegi necessari per SQL Express. Se non si è un amministratore di sistema per SQL Express, è necessario richiedere a un amministratore di sistema di essere aggiunti.

Per aggiungere un amministratore di sistema per SQL Express

  1. Installare SQL Express sul computer su cui si eseguirà il convertitore di Visual SourceSafe. SQL Express viene installato per impostazione predefinita insieme a Visual Studio 2005.

  2. Al prompt dei comandi digitare i comandi seguenti:

    Immagine CopyCode Copia codice
                SQLCMD.exe -S localhost\SQLExpress -E
EXEC sp_grantlogin <username> -- add as user
GO
EXEC sp_addsrvrolemember <username>, 'sysadmin'
GO

Protezione

È necessario appartenere al gruppo Administrators di Team Foundation o degli amministratori dello spazio dei nomi su Team Foundation per potere completare questa procedura. È inoltre necessario essere un amministratore di sistema per SQL Express.

Vedere anche

Attività

Procedura: analizzare il database VSS per la migrazione


Procedura: preparare Team Foundation per la migrazione

Procedura: preparare Team Foundation per la migrazione

Prima di iniziare la migrazione, è necessario preparare opportunamente Team Foundation.

Per preparare Team Foundation per la migrazione

  1. Installare Team Explorer sul computer in cui si desidera eseguire il convertitore di VSS. Il convertitore di Visual SourceSafe è incluso nel client di Team Foundation denominato Team Explorer.

  2. Prima di avviare la migrazione, richiedere a un amministratore di Team Foundation di essere aggiunti al gruppo Team Foundation Administrators di Team Foundation. Per ulteriori informazioni, vedere Procedura: aggiungere un utente.

Vedere anche

Attività

Procedura: creare un file di impostazioni per l'analisi e la migrazione del controllo del codice sorgente
Procedura: configurare SQL Express per la migrazione
Procedura: aggiungere un utente


Migrazione del controllo del codice sorgente

 elenco a discesa elenco a discesa attivabile
Migrazione del controllo del codice sorgente
Vedere anche
elenco a discesa

In questa sezione sono contenute informazioni relative alla migrazione di codice sorgente da progetti Visual SourceSafe a Controllo del codice sorgente Team Foundation. Prima di eseguire la migrazione, è necessario identificare le cartelle di destinazione in Team Foundation per ogni cartella Visual SourceSafe. Se tali cartelle sono già presenti, devono essere vuote. Se le cartelle di destinazione non esistono, verranno create durante la conversione. Le informazioni presentate in questo argomento partono dal presupposto che sia già stata consultata la sezione Pianificazione della migrazione del controllo del codice sorgente.

In questa sezione

Procedura: modificare il file di mapping utenti per la migrazione del controllo del codice sorgente

Viene descritto come controllare la modalità di migrazione delle informazioni utente a Controllo del codice sorgente Team Foundation.

Procedura: eseguire una migrazione incrementale a Team Foundation

Viene illustrato come eseguire una migrazione incrementale in caso il processo di migrazione sia stato interrotto o se è necessario eseguire la migrazione di modifiche apportate dopo il completamento della migrazione iniziale.

Procedura: eseguire la migrazione da Visual SourceSafe a Team Foundation

Viene descritto come eseguire la migrazione del codice sorgente da Visual SourceSafe a Controllo del codice sorgente Team Foundation.

Procedura: eseguire la migrazione di una cronologia parziale mediante gli archivi in Visual SourceSafe

Viene descritto come eseguire la migrazione dei dati cronologici dagli archivi di Visual SourceSafe.

Vedere anche

Riferimenti

Comando del convertitore VSS per la migrazione del controllo del codice sorgente

Altre risorse

Pianificazione della migrazione del controllo del codice sorgente
Operazioni da effettuare una volta eseguita la migrazione del controllo del codice sorgente


Procedura: modificare il file di mapping utenti per la migrazione del controllo del codice sorgente

Procedura: modificare il file di mapping utenti per la migrazione del controllo del codice sorgente
Vedere anche

Durante la fase di analisi viene generato un file di mapping utenti costituito da tutti gli utenti di Visual SourceSafe che hanno effettuato operazioni di controllo del codice sorgente nelle cartelle di cui viene eseguita la migrazione. È possibile utilizzare questo file per eseguire il mapping degli utenti di Visual SourceSafe agli utenti di Team Foundation. Se non viene eseguito il mapping utenti, il convertitore utilizza il nome dell'utente di Visual SourceSafe in Controllo del codice sorgente Team Foundation.

Per personalizzare il file di mapping utenti

  1. Nella cartella di esecuzione dell'analisi, al prompt dei comandi, digitare notepad usermap.xml e premere Invio.

    Verrà visualizzato il seguente file XML:

    Immagine CopyCode Copia codice
    <?xml version="1.0" encoding="utf-8"?>
<UserMappings>
<UserMap From="Admin" To=""></UserMap>
<UserMap From="guest" To=""></UserMap>
<UserMap From="Jane" To=""></UserMap>
<UserMap From="Mike" To=""></UserMap>
</UserMappings>

  2. Per ciascun nome utente di Visual SourceSafe di cui si desidera eseguire il mapping, aggiungere un nome utente di Windows NT o di Team Foundation Server valido nel campo A, come illustrato nel seguente esempio:

    Immagine CopyCode Copia codice
    <?xml version="1.0" encoding="utf-8"?>
<UserMappings>
<UserMap From="Admin" To="MYDOMAIN\Jennifer"></UserMap>
<UserMap From="guest" To="TestAlias1"></UserMap>
<UserMap From="Jane" To="Jane"></UserMap>
<UserMap From="Mike" To=""></UserMap>
</UserMappings>
    Nota Suggerimento:

    Assegnare l'account guest di Visual SourceSafe a un account utente di Windows o a un utente di Team Foundation, se possibile, per evitare di perdere la registrazione delle azioni di controllo della versione eseguite per conto dell'utente guest.

  3. Salvare le modifiche e chiudere Blocco note.

Vedere anche

Attività

Procedura: creare un file di impostazioni per l'analisi e la migrazione del controllo del codice sorgente
Procedura: preparare il database Visual SourceSafe per l'esecuzione del convertitore
Procedura: eseguire la migrazione da Visual SourceSafe a Team Foundation
Procedura dettagliata: preparazione alla migrazione da Visual SourceSafe a Team Foundation
Procedura dettagliata: migrazione da Visual SourceSafe a Team Foundation


Procedura: eseguire una migrazione incrementale a Team Foundation

Procedura: eseguire una migrazione incrementale a Team Foundation
Vedere anche

In questo argomento viene descritto come eseguire una migrazione incrementale se si desidera eseguire la migrazione del database di Visual SourceSafe in fasi o se la migrazione è stata interrotta e si desidera riprenderla dal punto di interruzione. In questo modo si consente agli utenti di continuare a utilizzare Visual SourceSafe mentre è in progresso la migrazione. Durante la migrazione incrementale il convertitore esegue solo la migrazione del delta delle modifiche non ancora migrate.

Limitazioni della migrazione incrementale

Si tenga presente che dall'avvio di una migrazione incrementale fino al termine di tutte le fasi del processo vigono le seguenti limitazioni.

  • Non è possibile modificare il mapping esistente tra le cartelle di Visual SourceSafe e le cartelle di Controllo del codice sorgente Team Foundation, né aggiungere o rimuovere mapping.

  • Non è possibile eseguire operazioni di eliminazione, rimozione, archiviazione o ripristino sul database di Visual SourceSafe.

  • Non è possibile utilizzare le cartelle di Controllo del codice sorgente Team Foundation di cui è stata eseguita la migrazione.

Per eseguire la migrazione in fasi

  1. Richiedere agli utenti di non utilizzare il database di Visual SourceSafe.

  2. Copiare il database di Visual SourceSafe su un computer diverso, dedicato all'esecuzione della migrazione.

  3. Avvisare gli utenti di Visual SourceSafe che possono riprendere a utilizzare il database di Visual SourceSafe.

  4. Avviare la migrazione normale sul database di Visual SourceSafe copiato sul computer di migrazione.

  5. Attendere il termine della migrazione.

  6. Al termine della migrazione richiedere agli utenti di mettere di utilizzare il database di Visual SourceSafe. Copiare il database di Visual SourceSafe sul computer di migrazione.

  7. Eseguire una copia di backup del file di report generato dalla migrazione precedente come riferimento futuro.

  8. Riavviare la migrazione sul database di Visual SourceSafe copiato. Il convertitore VSS determinerà automaticamente che si tratta di una migrazione incrementale e inizierà a eseguire la migrazione delle modifiche apportate dopo la prima migrazione.

    1. Fare clic sul pulsante Start, scegliere Tutti i programmi, Microsoft Visual Studio 2005, Strumenti di Visual Studio 2005 e quindi Prompt dei comandi di Visual Studio 2005.

    2. Al prompt dei comandi digitare il seguente comando utilizzando lo stesso file di impostazioni usato durante la migrazione precedente:

      VSSConverter Migrate settings.xml

      Nota Suggerimento:

      Utilizzare l'opzione /? per visualizzare le opzioni della riga di comando disponibili.

    3. Il convertitore rileverà automaticamente che si tratta di una migrazione incrementale e chiederà di confermare se si desidera eseguirla. Digitare Y per confermare che si desidera eseguire una migrazione incrementale.

    4. Lo strumento del convertitore visualizza lo stato della migrazione. Al termine della conversione lo strumento salva un report di post-migrazione nella directory corrente. È possibile utilizzare Microsoft Internet Explorer per visualizzare il file per informazioni dettagliate.

    5. Al prompt fornire la password per l'utente admin di Visual SourceSafe.

  9. Al termine delle fasi incrementali di migrazione del database di Visual SourceSafe è possibile fare passare gli utenti all'origine di cui è stata eseguita la migrazione su Controllo del codice sorgente Team Foundation.

Per riavviare la migrazione dopo un'interruzione

  1. Risolvere il problema che ha causato l'interruzione della migrazione.

  2. Eseguire una copia di backup del file di report generato dalla migrazione precedente come riferimento futuro.

  3. Effettuare l'operazione descritta al passaggio 8 nella procedura precedente, "Per eseguire la migrazione in fasi".

Protezione

È necessario appartenere al gruppo Administrators di Team Foundation in Team Foundation Server per potere completare questa procedura. È inoltre necessario essere un amministratore di sistema per SQL Express.

Vedere anche

Attività

Procedura: creare un file di impostazioni per l'analisi e la migrazione del controllo del codice sorgente
Procedura: preparare il database Visual SourceSafe per l'esecuzione del convertitore
Procedura dettagliata: preparazione alla migrazione da Visual SourceSafe a Team Foundation
Procedura dettagliata: migrazione da Visual SourceSafe a Team Foundation
Procedura: eseguire la migrazione da Visual SourceSafe a Team Foundation


Procedura: eseguire la migrazione da Visual SourceSafe a Team Foundation

Procedura: eseguire la migrazione da Visual SourceSafe a Team Foundation
Vedere anche

Prima di eseguire la migrazione degli utenti da Visual SourceSafe a Controllo del codice sorgente Team Foundation, effettuare le seguente operazioni:

  • Preparare il database per la migrazione. Per ulteriori informazioni, vedere Procedura: preparare il database Visual SourceSafe per l'esecuzione del convertitore.

  • Stabilire una connessione a Team Foundation Server e creare un progetto Team. Per ulteriori informazioni, vedere Procedura dettagliata: connessione a un progetto Team e Procedura: creare un progetto Team.

  • Creare o modificare il file di impostazioni della migrazione. Per ulteriori informazioni, vedere Procedura: creare un file di impostazioni per l'analisi e la migrazione del controllo del codice sorgente

  • Modificare il file di mapping utenti creato durante l'analisi del database. Per ulteriori informazioni, vedere Procedura: modificare il file di mapping utenti per la migrazione del controllo del codice sorgente.

Nota Nota

Ripresa della migrazione. Se la migrazione non riesce per qualche motivo, è possibile riprenderla dal punto in cui è stata interrotta. Eseguire di nuovo il convertitore e al prompt, se si desidera eseguire una migrazione incrementale, selezionare Y per proseguire con la migrazione. Per ulteriori informazioni, vedere Procedura: eseguire una migrazione incrementale a Team Foundation.

Per eseguire il convertitore

  1. Fare clic sul pulsante Start, scegliere Tutti i programmi, Microsoft Visual Studio 2005, Strumenti di Visual Studio 2005 e quindi Prompt dei comandi di Visual Studio 2005.

  2. Al prompt dei comandi digitare quanto segue:

    VSSConverter Migrate settings.xml

    Nota Suggerimento:

    Utilizzare l'opzione /? per visualizzare le opzioni della riga di comando disponibili.

  3. Digitare Y per confermare la migrazione.

    Lo strumento del convertitore visualizza lo stato della migrazione. Al termine della conversione lo strumento salva un report di post-migrazione nella directory corrente. È possibile utilizzare Internet Explorer per visualizzare il file per informazioni dettagliate.

  4. Al prompt fornire la password per l'utente admin di Visual SourceSafe.

Protezione

È necessario essere un membro del gruppo Administrators di Team Foundation su Team Foundation per potere completare questa procedura. È inoltre necessario essere un amministratore di sistema per SQL Express.

Vedere anche

Attività

Procedura: eseguire una migrazione incrementale a Team Foundation
Procedura: creare un file di impostazioni per l'analisi e la migrazione del controllo del codice sorgente
Procedura: preparare il database Visual SourceSafe per l'esecuzione del convertitore
Procedura dettagliata: preparazione alla migrazione da Visual SourceSafe a Team Foundation
Procedura dettagliata: migrazione da Visual SourceSafe a Team Foundation


Procedura: eseguire la migrazione di una cronologia parziale mediante gli archivi in Visual SourceSafe

Procedura: eseguire la migrazione di una cronologia parziale mediante gli archivi in Visual SourceSafe
Vedere anche

Se si esegue la migrazione di origini da Visual SourceSafe a Controllo del codice sorgente Team Foundation e non si desidera eseguire la migrazione di tutta la cronologia memorizzata in Visual SourceSafe, è possibile eseguire la migrazione della cronologia dopo una data specifica mediante la funzione di archiviazione in Visual SourceSafe.

Nota di avviso Attenzione

Poiché questo metodo consente di rimuovere permanentemente la cronologia delle versioni dal database di Visual SourceSafe, è necessario archiviare una copia del database.

Nota Nota

Il file di archivio di Visual SourceSafe presenta un limite di 2 GB. Se viene restituito un errore, archiviare cartelle più piccole separatamente.

Per eseguire la migrazione di una cronologia parziale mediante gli archivi in Visual SourceSafe

  1. Copiare il database di Visual SourceSafe sul computer su cui si desidera eseguire la migrazione.

  2. Utilizzare la funzione di archiviazione in Visual SourceSafe per rimuovere la cronologia delle versioni precedente al timestamp desiderato. Per specificare il timestamp, è possibile utilizzare uno dei seguenti metodi:

    • Etichetta

    • Versione di una cartella

    • Data

    Per ulteriori informazioni sull'archiviazione in Visual SourceSafe, vedere i database di archiviazione di Visual SourceSafe.

  3. Completare la migrazione utilizzando la copia del database di Visual SourceSafe di cui è stata archiviata la cronologia.

Protezione

È necessario essere un amministratore di Visual SourceSafe per potere archiviare il database di Visual SourceSafe.

Vedere anche

Attività

Procedura dettagliata: preparazione alla migrazione da Visual SourceSafe a Team Foundation
Procedura dettagliata: migrazione da Visual SourceSafe a Team Foundation

Altre risorse

Migrazione del controllo del codice sorgente


Operazioni da effettuare una volta eseguita la migrazione del controllo del codice sorgente

 elenco a discesa elenco a discesa attivabile
Operazioni da effettuare una volta eseguita la migrazione del controllo del codice sorgente
Vedere anche
elenco a discesa

Una volta completata la migrazione del controllo del codice sorgente, è necessario verificare la correttezza del codice sorgente presente in Controllo del codice sorgente Team Foundation. Al termine della migrazione, utilizzare un'utilità di confronto file quale WinDiff per verificare che non siano presenti differenze tra le versioni più recenti dei file e delle cartelle in Visual SourceSafe e quelle del codice sorgente di cui è stata eseguita la migrazione in Controllo del codice sorgente Team Foundation. Se vengono rilevate delle differenze tra i file, le cartelle o le relative versioni, è necessario eseguire la migrazione della versione più recente manualmente.

Nota Nota

In Visual SourceSafe sono sempre presente dei file aggiuntivi con l'estensione *.*scc. Si tratta di file temporanei generati da Visual SourceSafe nella cartella locale quando viene utilizzato un comando di recupero dell'ultima versione in Visual SourceSafe e non sono file di origine.

In questa sezione

Procedura: eseguire la migrazione delle associazioni del controllo del codice sorgente da Visual SourceSafe

Viene descritto come eseguire la migrazione delle associazioni del controllo del codice sorgente in Visual Studio da Visual SourceSafe a Controllo del codice sorgente Team Foundation.

Interpretazione del report di migrazione del controllo del codice sorgente

Contiene informazioni sui messaggi che possono essere visualizzati nel report di migrazione.

Risoluzione dei problemi relativi alla migrazione del controllo del codice sorgente

Contiene argomenti utili per la risoluzione di problemi relativi alla migrazione.

Vedere anche

Altre risorse

Guida introduttiva a Team Foundation
Procedure dettagliate relative al controllo del codice sorgente di Team Foundation
Utilizzo del controllo del codice sorgente di Team Foundation


Procedura: eseguire la migrazione delle associazioni del controllo del codice sorgente da Visual SourceSafe

Procedura: eseguire la migrazione delle associazioni del controllo del codice sorgente da Visual SourceSafe
Vedere anche

Dopo avere eseguito la migrazione del progetto incluso nel controllo del codice sorgente da Visual SourceSafe a Team Foundation, è necessario eseguire la migrazione delle associazioni del controllo del codice sorgente a Team Foundation per effettuare le operazioni di controllo del codice sorgente nell'ambiente Visual Studio. Per convertire nel formato Visual Studio 2005 soluzioni e progetti sviluppati in versioni di Visual Studio precedenti a Visual Studio 2005, è possibile utilizzare la procedura descritta di seguito. È anche possibile modificare le relative associazioni del controllo del codice sorgente.

Per convertire e modificare l'associazione del controllo del codice sorgente

  1. In Esplora controllo del codice sorgente fare clic con il pulsante destro del mouse sulla cartella contenente la soluzione e scegliere Leggi ultima versione.

  2. Se la cartella non è mappata nell'area di lavoro in uso, verrà visualizzata la finestra di dialogo Sfoglia per cartelle. Selezionare una cartella appropriata nel computer locale e scegliere OK.

    Nella cartella locale mappata verrà recuperata una copia della cartella e dei file.

  3. Fare clic con il pulsante destro del mouse sulla cartella contenente la soluzione e scegliere Estrai per la modifica.

  4. Nella finestra di dialogo Estrai scegliere Estrai.

  5. Scegliere Apri dal menu File, quindi Progetto/Soluzione.

  6. Nella finestra di dialogo Apri progetto individuare e selezionare il file della soluzione estratto, quindi scegliere Apri.

  7. Nella finestra di dialogo Conversione guidata di Visual Studio scegliere Fine.

    In Team Foundation i file della soluzione (estensione SLN) e del progetto (estensione PROJ) vengono convertiti automaticamente nel formato Visual Studio 2005. La soluzione viene inoltre associata a Team Foundation.

  8. Al termine della conversione scegliere Chiudi.

  9. In Esplora controllo del codice sorgente fare clic con il pulsante destro del mouse sulla cartella contenente la soluzione e scegliere Archivia modifiche in sospeso.

  10. Nella finestra di dialogo Archivia specificare tutte le informazioni necessarie, selezionare tutti i file, quindi fare clic su Archivia.

Vedere anche

Attività

Procedura dettagliata: migrazione da Visual SourceSafe a Team Foundation

Altre risorse

Migrazione del controllo del codice sorgente


Interpretazione del report di migrazione del controllo del codice sorgente

 elenco a discesa elenco a discesa attivabile
Interpretazione del report di migrazione del controllo del codice sorgente
Vedere anche
elenco a discesa

È possibile visualizzare il report di migrazione del controllo del codice sorgente in Internet Explorer. Il report viene generato come file XML e i file di supporto, ad esempio i file XSLT e quelli grafici, vengono utilizzati per eseguire il rendering di questi file per l'utente.

Report di analisi e migrazione

Il report è suddiviso in sezioni, che a loro volta sono suddivise in sottosezioni. Le sezioni Errore critico, Errore e Avvisi vengono visualizzate solo se durante la migrazione sono stati generati errori o avvisi. Ciascuna sezione del report è comprimibile. Per espandere o comprimere una sezione, fare clic sull'icona nell'intestazione della sezione.

La maggior parte delle sezioni e del contenuto è uguale per i report di analisi e di migrazione.

Il report può contenere le sezioni elencate di seguito, ognuna delle quali viene spiegata in dettaglio in questo argomento.

  • Riepilogo Riepiloga i risultati dell'analisi o della migrazione.

    Nota Nota

    Il numero di azioni analizzate può essere diverso dal numero di azioni sottoposte a migrazione in quanto non viene eseguita la migrazione di tutte le azioni analizzate, tra cui archiviazione, ripristino, cancellazione ed eliminazione.

  • Errore critico Se l'analisi o la migrazione viene interrotta a causa di un errore irreversibile, questa sezione viene inclusa nel report e in essa viene descritto l'errore che ha causato la mancata riuscita dell'analisi o della migrazione.

  • Errore Il convertitore non è sempre in grado di eseguire la migrazione o l'analisi dei file e delle cartelle o delle versioni specifiche dei file e delle cartelle perché il database di Visual SourceSafe di cui si esegue la migrazione è danneggiato o è presente un caso che non può essere gestito dal convertitore. In questa sezione sono elencati questo tipo di errori di perdita di dati.

  • Avvisi In questa sezione sono contenute informazioni sulla perdita o sulla modifica di informazioni in seguito alla mancata migrazione dei dati da Visual SourceSafe a Controllo del codice sorgente Team Foundation. Durante l'analisi il convertitore segnala una potenziale perdita di informazioni. È possibile cercare di prevenire la perdita di dati oppure accettare la perdita durante la migrazione.

  • Input dell'utente Nella sezione dell'input dell'utente vengono riportate le opzioni della riga di comando fornite dall'utente al convertitore.

Riepilogo

Nella seguente tabella vengono descritte le voci delle sezione Riepilogo del report:

Voce | Descrizione
Stato | Segnala se la migrazione o l'analisi è riuscita o meno e indica il numero di errori o avvisi. Fare clic sul numero di errore o avviso per visualizzare le sezioni corrispondenti.
Versione del controllo del codice sorgente | Il programma e la versione del controllo del codice sorgente da cui è stata eseguita la migrazione del codice sorgente o per cui è stata eseguita l'analisi della migrazione.
Database VSS | Il percorso del database di Visual SourceSafe.
Team Foundation Server (solo report di migrazione) | Il server Team Foundation Server in cui è stata eseguita la migrazione del codice sorgente.
Azioni sottoposte a migrazione/analizzate | Il numero di azioni per cui è stata eseguita la migrazione o l'analisi.
Ora di inizio | L'ora di inizio della migrazione o dell'analisi.
Ora di fine | L'ora di fine della migrazione o dell'analisi.
Tempo totale | Il tempo totale impiegato per eseguire la migrazione o l'analisi.
Migrazione/Analisi eseguita da | L'alias della persona che ha eseguito la migrazione o l'analisi.
Cartelle sottoposte a migrazione/analizzate | Elenca le cartelle di cui è stata eseguita la migrazione o l'analisi.

Errore critico

Se l'analisi o la migrazione viene interrotta a causa di un errore irreversibile, questa sezione viene inclusa nel report e in essa viene descritto l'errore che ha causato la mancata riuscita dell'analisi o della migrazione.

Errore

Nella sezione degli errori sono contenute informazioni sui problemi che si sono verificati durante la migrazione o l'analisi, ad esempio le versioni dei file e delle cartelle di cui non è stato possibile eseguire la migrazione. Ciascun messaggio descrive brevemente gli errori che si sono verificati durante la migrazione o l'analisi e contiene un collegamento a un documento che include i dettagli dell'errore.

Per ulteriori informazioni sugli errori di migrazione e analisi, vedere Messaggi di report sulla migrazione del controllo del codice sorgente.

Avvisi

Nella sezione Avvisi sono contenute informazioni sui problemi che si sono verificati durante la migrazione o l'analisi, ad esempio la perdita di dati durante la migrazione. Ciascun avviso descrive brevemente la perdita di dati potenziale o effettiva che ha avuto luogo durante la migrazione o l'analisi e contiene un collegamento a un documento che include i dettagli dell'errore.

Per ulteriori informazioni sugli avvisi di migrazione e analisi, vedere Messaggi di report sulla migrazione del controllo del codice sorgente.

Input dell'utente

Nella sezione Input dell'utente vengono riportate le opzioni della riga di comando utilizzate per eseguire la conversione.

Voce | Descrizione
Comando | Indica la voce della riga di comando utilizzata per eseguire la migrazione o l'analisi.
Opzioni dell'utente | Dettagli delle opzioni specificate sulla riga di comando dall'utente.

Vedere anche

Concetti

Messaggi di report sulla migrazione del controllo del codice sorgente


Risoluzione dei problemi relativi alla migrazione del controllo del codice sorgente

 elenco a discesa elenco a discesa attivabile
Risoluzione dei problemi relativi alla migrazione del controllo del codice sorgente
Vedere anche
elenco a discesa

Se si verificano dei problemi durante la migrazione del database del controllo del codice sorgente, leggere gli argomenti contenuti in questa sezione per informazioni su come risolvere i problemi e completare la migrazione.

In questa sezione

Messaggi di report sulla migrazione del controllo del codice sorgente

In questo argomento vengono fornite informazioni sui messaggi che possono essere presenti nei report di migrazione.

Errori di migrazione critici

In questo argomento sono elencate le cause degli errori critici che si verificano durante la migrazione e vengono fornite possibili soluzioni.

Errori di migrazione

In questo argomento sono elencate le cause comuni degli errori non critici e degli avvisi che si verificano durante la migrazione e vengono fornite possibili soluzioni.

Vedere anche

Riferimenti

Comando del convertitore VSS per la migrazione del controllo del codice sorgente


Messaggi di report sulla migrazione del controllo del codice sorgente

 elenco a discesa elenco a discesa attivabile
Messaggi di report sulla migrazione del controllo del codice sorgente
Vedere anche
elenco a discesa

Il report di migrazione del controllo del codice sorgente comprende due sezioni: Errori e Avvisi. La sezione Errore critico viene aggiunta se si verifica un errore irreversibile che interrompe la migrazione o l'analisi. In questo argomento vengono descritti i messaggi visualizzati in queste sezioni.

Nota Nota

Il numero di azioni analizzate può essere diverso dal numero di azioni sottoposte a migrazione in quanto non viene eseguita la migrazione di tutte le azioni analizzate, tra cui archiviazione, ripristino, cancellazione ed eliminazione.

Errore critico

Se l'analisi o la migrazione viene interrotta a causa di un errore irreversibile, questa sezione viene inclusa nel report e in essa viene descritto l'errore che ha causato la mancata riuscita dell'analisi o della migrazione. Per ulteriori informazioni, vedere Errori di migrazione critici.

Errori

La presenza di errori durante l'analisi o la migrazione indica che non è stata eseguita la migrazione di alcuni file o cartelle, ma non implica che il database non sia utilizzabile. È possibile decidere di ignorare i file di cui non è stata eseguita la migrazione e iniziare a utilizzare quelli presenti in Team Foundation.

Vengono generati errori di migrazione di file o cartelle quando non è possibile eseguire la migrazione o analizzare le relative versioni in quanto lo scenario non è gestibile mediante il convertitore di Visual SourceSafe. In questa sezione sono contenute informazioni relative alla mancata migrazione di file e cartelle non segnalata dal convertitore durante l'analisi. Per ogni messaggio di errore viene fornita una breve spiegazione dell'errore verificatosi durante la migrazione o l'analisi.

Per ulteriori informazioni, vedere Errori di migrazione.

Avvisi

In questa sezione sono contenute informazioni sulla perdita o sulla modifica di informazioni in seguito alla mancata migrazione dei dati da Visual SourceSafe a Controllo del codice sorgente Team Foundation per un motivo noto. Durante l'analisi il convertitore avvisa in caso di potenziale perdita di informazioni, eccetto quando questa perdita può essere dovuta al danneggiamento del database di Visual SourceSafe. Spesso, se il database diVisual SourceSafe è danneggiato, non è possibile recuperare la versione tramite Gestione risorse o la riga di comando di Visual SourceSafe. A volte è possibile adottare alcune misure per evitare la perdita di informazioni oppure è possibile accettare la perdita di dati ed eseguire comunque il convertitore.

Ciascun messaggio descrive brevemente gli avvisi che sono stati generati durante la migrazione o l'analisi e contiene un collegamento a un documento che include i dettagli dell'avviso.

Avvisi di perdita di dati

Nel seguente elenco sono riportati gli avvisi di perdita di dati che il convertitore può generare durante la migrazione o l'analisi:

  • Perdita di dati dovuta allo spostamento da una cartella di origine non inclusa nella migrazione a una di destinazione inclusa nella migrazione

  • Perdita di dati dovuta allo spostamento da una cartella di origine inclusa nella migrazione a una di destinazione non inclusa nella migrazione

  • La condivisione non è supportata nel controllo del codice sorgente di Team Foundation

  • Versioni o cronologia di file e cartelle VSS non recuperati dal convertitore.

Altri avvisi

Nella seguente tabella sono elencati gli altri avvisi che il convertitore può generare durante la migrazione o l'analisi:

  • Perdita potenziale dei dati a causa di problemi legati al fuso orario con il database Visual SourceSafe in fase di migrazione.

  • Elenco dei file attualmente estratti.

  • Nomi di etichette che verranno modificati in seguito a una migrazione.

  • File con la funzionalità VSS per mantenere solo la versione più recente

Vedere anche

Concetti

Interpretazione del report di migrazione del controllo del codice sorgente


Errori di migrazione critici

 elenco a discesa elenco a discesa attivabile
Errori di migrazione critici
Vedere anche
elenco a discesa

In caso di interruzione dell'analisi o della migrazione viene restituito un errore critico che ne indica la causa. Il convertitore consente di riavviare la migrazione dal punto in cui è stata interrotta. Per ulteriori informazioni sulla migrazione incrementale, vedere la nota nella parte superiore dell'argomento Procedura: eseguire la migrazione da Visual SourceSafe a Team Foundation.

Di seguito sono riportate le cause più comuni degli errori di migrazione critici.

  • La migrazione è stata annullata La migrazione o l'analisi è stata interrotta in modo forzato mediante la terminazione del processo dell'applicazione. È possibile riavviare la migrazione dal punto di interruzione eseguendo una migrazione incrementale. Per ulteriori informazioni sulla migrazione incrementale, vedere Procedura: eseguire la migrazione da Visual SourceSafe a Team Foundation.

  • La migrazione è stata interrotta a causa di un errore nel database SQL utilizzato dal convertitore Il convertitore di VSS utilizza SQL Express o SQL Server per elaborare i dati durante la migrazione. Questo messaggio indica che la migrazione è stata interrotta a causa di un errore irreversibile verificatosi nel database SQL. Il messaggio di errore inviato al convertitore viene aggiunto alla fine della descrizione dell'errore critico. Risolvere il problema in base alle informazioni contenute nel messaggio di errore e riavviare la migrazione dal punto di interruzione eseguendo una migrazione incrementale. Per ulteriori informazioni sulla migrazione incrementale, vedere Procedura: eseguire la migrazione da Visual SourceSafe a Team Foundation.

  • L'applicazione non è in grado di gestire l'eccezione Il convertitore di VSS non è in grado di gestire un'eccezione irreversibile verificatasi durante l'analisi o la migrazione. Il messaggio di errore inviato al convertitore viene aggiunto alla fine della descrizione dell'errore critico. Tentare di risolvere il problema in base alle informazioni contenute nel messaggio di errore. Una volta risolto il problema, iniziare nuovamente l'analisi oppure, se era in corso una migrazione, riavviarla dal punto di interruzione eseguendo una migrazione incrementale. Per ulteriori informazioni sulla migrazione incrementale, vedere Procedura: eseguire una migrazione incrementale a Team Foundation.

Vedere anche

Concetti

Messaggi di report sulla migrazione del controllo del codice sorgente


Errori di migrazione

 elenco a discesa elenco a discesa attivabile
Errori di migrazione
Vedere anche
elenco a discesa

La visualizzazione di messaggi di errore durante l'analisi o la migrazione indica che non è stata eseguita la migrazione di alcuni file o cartelle, ma non implica che il database non sia utilizzabile. È possibile decidere di ignorare i file di cui non è stata eseguita la migrazione e iniziare a utilizzare quelli presenti in Team Foundation.

Vengono generati errori di migrazione di file o cartelle quando non è possibile eseguire la migrazione o analizzare le relative versioni in quanto lo scenario non è gestibile mediante il convertitore di Visual SourceSafe. In questa sezione sono contenute informazioni relative alla mancata migrazione di file e cartelle non segnalata dal convertitore durante l'analisi. Per ogni messaggio di errore viene fornita una breve spiegazione dell'errore verificatosi durante la migrazione o l'analisi.

Di seguito sono descritti gli errori più comuni e le relative soluzioni.

  • Impossibile eseguire la migrazione Il convertitore ha rilevato uno scenario di cronologia delle versioni non supportato ed è quindi possibile che la migrazione dei file e delle cartelle appartenenti a tale scenario non sia stata eseguita correttamente. Utilizzare un'utilità di confronto file quale WinDiff per identificare eventuali differenze tra le versioni più recenti dei file e delle cartelle in Visual SourceSafe e quelle dei file di cui è stata eseguita la migrazione in Controllo del codice sorgente Team Foundation. Se sono presenti differenze tra i file, le cartelle o le relative versioni, eseguire la migrazione della versione più recente di tali file e cartelle manualmente.

Nota Nota

Per eseguire manualmente la migrazione di un file o una cartella, ottenere la versione più recente da Visual SourceSafe e aggiungerla a Controllo del codice sorgente Team Foundation mediante Esplora controllo del codice sorgente o il client della riga di comando tf.

  • Impossibile eseguire la migrazione di una cartella in modo ricorsivo a causa di un errore di I/O Durante la migrazione non è stato possibile aggiungere una cartella a Team Foundation perché si è verificato un errore di input/output. Questo messaggio di errore viene aggiunto dopo una breve descrizione dell'errore. Al termine della migrazione sarà possibile aggiungere la versione più recente della cartella mediante una lettura dell'ultima versione dei file e delle cartelle da Visual SourceSafe e archiviandole in una sola operazione.

  • Impossibile eseguire la migrazione a causa di un errore di Team Foundation Non è stato possibile eseguire la migrazione di un file o una cartella a causa di problemi noti o sconosciuti con Team Foundation. Il messaggio di errore inviato al convertitore da Team Foundation viene aggiunto dopo una breve descrizione dell'errore. Provare a correggere il problema ottenendo una copia del file o della cartella da Visual SourceSafe e archiviandola manualmente in Team Foundation.

  • Impossibile eseguire la migrazione di un'etichetta a causa di un errore di Team Foundation Non è stato possibile applicare un'etichetta di Controllo del codice sorgente Team Foundation. Il messaggio di errore inviato al convertitore da Team Foundation viene aggiunto dopo una breve descrizione dell'errore.

  • Impossibile eseguire la migrazione in quanto il percorso contiene un numero di caratteri superiore ai 260 consentiti La lunghezza massima del percorso del server supportata da Controllo del codice sorgente Team Foundation è di 260 caratteri. Il convertitore non è in grado di eseguire la migrazione della versione del file o della cartella a causa di questa limitazione.

Vedere anche

Concetti

Errori di migrazione critici
Messaggi di report sulla migrazione del controllo del codice sorgente


Comando del convertitore VSS per la migrazione del controllo del codice sorgente

 elenco a discesa elenco a discesa attivabile
Comando del convertitore VSS per la migrazione del controllo del codice sorgente
Vedere anche
comprimi tutto elenco a discesa

Il comando VSSConverter consente di analizzare ed eseguire la migrazione dei database di Visual SourceSafe a Controllo del codice sorgente Team Foundation.

espandi Sintassi

VSSConverter [/? /h /help ] [analyze | migrate ] settings_file

analyze

Analizza i risultati previsti della migrazione per un database di Visual SourceSafe.

migrate

Esegue la migrazione di un database di Visual SourceSafe.

settings_file

File XML che specifica le impostazioni di analisi o migrazione.

/?, /h, /help

Visualizza la Guida in linea.

espandi Note

Prima di eseguire il convertitore Visual SourceSafe (VSS), seguire la procedura descritta.

  • Creare un file di impostazioni con le seguenti informazioni.

    • Il percorso del database di Visual SourceSafe.

    • Il percorso e il nome di un file di report di output (facoltativo).

    • Il percorso e il nome di un file di mapping utenti (facoltativo).

    Per ulteriori informazioni, vedere Procedura: creare un file di impostazioni per l'analisi e la migrazione del controllo del codice sorgente.

Il nome di file predefinito del report di analisi è VSSAnalysisReport.xml. Il nome di file predefinito del report di migrazione è VSSMigrationReport.xml. Questi file vengono creati nella stessa directory in cui viene eseguito il convertitore.

Se si specifica un file di output che esiste già, il convertitore restituisce il seguente messaggio di errore.

Error: Output file VSSMigration.xml already exist

Se durante l'analisi non viene fornito un file di mapping utenti, il convertitore creerà il file UserMap.xml nella directory corrente.

espandi Limiti

È possibile eseguire solo un'istanza del convertitore VSS su un computer.

espandi Esempi

Questo comando di esempio esegue un'analisi del database di Visual SourceSafe utilizzando la configurazione nel file settings.xml.

Immagine CopyCode Copia codice
VSSConverter analyze settings.xml

Questo comando di esempio esegue la migrazione di un database di Visual SourceSafe utilizzando la configurazione nel file settings.xml.

Immagine CopyCode Copia codice
VSSConverter migrate settings.xml

espandi Vedere anche

Attività

Procedura dettagliata: preparazione alla migrazione da Visual SourceSafe a Team Foundation
Procedura dettagliata: migrazione da Visual SourceSafe a Team Foundation
Procedura: creare un file di impostazioni per l'analisi e la migrazione del controllo del codice sorgente
Procedura: creare un file di impostazioni per l'analisi e la migrazione del controllo del codice sorgente
Procedura: creare un progetto Team
Procedura: aggiungere un progetto o una soluzione al controllo del codice sorgente

piè di pagina


Migrazione da ClearQuest

 elenco a discesa elenco a discesa attivabile
Migrazione da ClearQuest
Vedere anche
elenco a discesa

Di seguito sono elencate le operazioni eseguite dal convertitore della migrazione degli elementi di lavoro:

  • Lettura degli elementi di lavoro da ClearQuest.

  • Scrittura dei dati in Team Foundation utilizzando i servizi Web di gestione degli elementi di lavoro di Visual Studio Team System.

  • Migrazione degli allegati e dei collegamenti.

  • Migrazione delle informazioni duplicate relative agli elementi di lavoro.

Per scrivere i dati in Team Foundation, il convertitore riproduce le azioni eseguite dagli utenti nel sistema di gestione degli elementi di lavoro originale. Ad esempio, se un elemento di lavoro è stato aperto, risolto e quindi chiuso, il convertitore apre tale elemento di lavoro in Team Foundation, lo risolve e infine lo chiude, salvandolo ad ogni azione e mantenendo gli stessi nomi utente e date per le azioni eseguite.

È possibile verificare il mapping dei dati da ClearQuest a Team Foundation, che include la modifica dei valori dei campi e la modalità di mapping utenti. Per specificare le impostazioni del convertitore, modificare i file XML che definiscono le modalità di migrazione dei dati.

Le seguenti sezioni contengono informazioni utili per la migrazione di elementi di lavoro in Team Foundation.

Limitazioni del convertitore di ClearQuest

Vengono descritte le limitazioni del convertitore di ClearQuest, incluso l'elenco degli elementi di cui non viene eseguita la migrazione.

Pianificazione della migrazione degli elementi di lavoro

Viene illustrato come pianificare una migrazione da ClearQuest a Team Foundation.

Migrazione degli elementi di lavoro

Viene illustrato come migrare elementi di lavoro da ClearQuest a Team Foundation.

Operazioni da effettuare una volta eseguita la migrazione degli elementi di lavoro

Vengono descritte le attività da svolgere dopo la migrazione per garantire la riuscita della migrazione e risolvere eventuali problemi.

Riferimenti alla riga di comando per la migrazione degli elementi di lavoro

Vengono elencate tutte le opzioni della riga di comando per il convertitore della migrazione degli elementi di lavoro.

Schema di gestione degli elementi di lavoro

Lo schema di gestione degli elementi di lavoro di Team Foundation definisce un tipo di elemento di lavoro specifico includendo le seguenti informazioni:

  • I campi presenti su un form elemento di lavoro con i relativi nomi e tipi.

  • Le regole associate a un elemento di lavoro. Ad esempio, per un elemento di lavoro può essere richiesto che il campo Data di apertura venga impostato sulla data corrente al momento della creazione dell'elemento di lavoro.

  • L'elenco dei valori validi per un campo.

  • Caratteristiche dei campi quali Facoltativo/Sola lettura/Obbligatorio.

  • Flusso di lavoro, ad esempio gli stati aperto, risolto e chiuso per un bug.

  • Form elemento di lavoro, ossia il form utilizzato per gestire gli elementi di lavoro nell'ambito del progetto.

Vedere anche

Attività

Procedura dettagliata: migrazione di elementi di lavoro ClearQuest a Team Foundation

Concetti

Processo di migrazione


Limitazioni del convertitore di ClearQuest

 elenco a discesa elenco a discesa attivabile
Limitazioni del convertitore di ClearQuest
Vedere anche
elenco a discesa

Prima di iniziare la migrazione, esaminare le limitazioni del convertitore di ClearQuest e come esse possano ripercuotersi sugli utenti dell'organizzazione.

  • Il convertitore di ClearQuest non genera i campi degli elementi di lavoro utilizzati per l'integrazione con altre funzioni di Visual Studio Team System. Se si desidera utilizzare le funzioni di integrazione, è necessario aggiungere questi campi agli elementi di lavoro dopo la migrazione. Per ulteriori informazioni, vedere Aggiunta dei campi di integrazione nei tipi di elemento di lavoro.

  • Il convertitore non conserva il comportamento dei campi basato sullo stato.

  • Per il contenuto dei file XML utilizzati dal convertitore viene effettuata la distinzione tra maiuscole e minuscole. Ad esempio, "MAPPAUTENTE" e "MappaUtente" sono due stringhe diverse.

  • Il convertitore non conserva il comportamento privo di stato di record privi di stato. Quando viene eseguita la migrazione di record privi di stato, ai record verrà associato un unico stato predefinito.

  • Il convertitore esegue la migrazione dell'azione di annullamento della duplicazione in ClearQuest aggiungendo un'azione esplicita di annullamento dell'azione nella matrice di transizione dello stato per ciascuna <azione> di tipo Duplicate. Questa implementazione consente di annullare le transizioni di stato in modo che l'elemento di lavoro ritorni nello stato in cui era prima di essere contrassegnato come duplicato.

  • Il convertitore esegue la migrazione delle regole di posta elettronica, ma non della semantica dei messaggi di posta elettronica. È necessario configurare le regole di notifica di posta elettronica (dette "avvisi") in Team Foundation. Per ulteriori informazioni, vedere Impostazione di avvisi.

Informazioni di cui non viene eseguita la migrazione

Il convertitore non supporta la migrazione di quanto riportato di seguito.

  • Regole di campi basati su script Basic o Perl in ClearQuest.

  • Notifica tramite posta elettronica per modifiche apportate ai valori dei campi.

  • Comportamento dei campi definito sulla transizione di stato. Ad esempio, l'obbligatorietà dei campi o la sola lettura in alcuni stati.

  • Azioni di eliminazione, importazione o modifica nello schema di ClearQuest.

  • Famiglie di tipi di registrazione in ClearQuest.

  • Elementi dell'interfaccia utente tipo casella di controllo. Il convertitore associa questi campi a campi di tipo numero intero. È necessario limitare manualmente i valori a 0 e 1 nello schema.

  • L'opzione obbligatoria per entità a cui viene fatto riferimento.

  • I campi di sistema interni che ClearQuest imposta automaticamente. Questi campi vengono utilizzati da ClearQuest per la gestione interna e contengono dati che sarebbero inutili se ne venisse eseguita la migrazione.

  • Regole che specificano l'insieme di valori consentiti per campi che identificano persone.

  • Il convertitore non segue le entità con riferimenti inversi per la migrazione. Ad esempio, se il difetto di un'entità di ClearQuest fa riferimento al cliente di un'entità, quest'ultimo fa inversamente riferimento al difetto dell'entità. Se la query di migrazione si basa sul cliente entità, non viene eseguita la migrazione del difetto dell'entità a cui viene fatto riferimento.

  • Il convertitore non è in grado di eseguire la migrazione di elementi di lavoro in cui campi di testo contengono caratteri non supportati. I caratteri non supportati in codice esadecimale sono #x0-#x8, #x10, #xB, #xC e #xE-#x1F. Si tratta di caratteri di controllo che non sono visualizzati nei campi di testo durante il normale uso. Quando questi caratteri vengono rilevati dal convertitore, viene restituito un errore di generazione del documento XML. Il convertitore ignora l'elemento di lavoro e passa a quello successivo per la migrazione.

Vedere anche

Concetti

Pianificazione della migrazione degli elementi di lavoro
Aggiunta dei campi di integrazione nei tipi di elemento di lavoro

Altre risorse

Migrazione degli elementi di lavoro
Operazioni da effettuare una volta eseguita la migrazione degli elementi di lavoro


Pianificazione della migrazione degli elementi di lavoro

 elenco a discesa elenco a discesa attivabile
Pianificazione della migrazione degli elementi di lavoro
Vedere anche
elenco a discesa

Prima di eseguire la migrazione degli elementi di lavoro da ClearQuest a Gestione elementi di lavoro Team Foundation, è necessario effettuare quanto segue.

  • Installare il software necessario per l'esecuzione del convertitore.

  • Raccogliere le informazioni necessarie per il completamento della migrazione.

  • Pianificare la migrazione.

  • Preparare Team Foundation per la migrazione.

Questi passaggi vengono descritti in maggiore dettaglio nelle sezioni seguenti.

Installazione del software necessario per l'esecuzione del convertitore

Prima di potere eseguire la migrazione degli elementi di lavoro di ClearQuest a Gestione elementi di lavoro Team Foundation, è necessario che sul computer su cui si intende eseguire il convertitore sia installato il seguente software:

  • Team Explorer Per ulteriori informazioni sull'installazione di Team Explorer, vedere la guida all'installazione di Team Foundation. La versione più aggiornata della guida all'installazione di Team Foundation è disponibile in linea all'indirizzo http://go.microsoft.com/fwlink/?linkid=40042.

  • Client autonomo ClearQuest versione 2003.06.00.

    Nota Nota

    Potrebbero funzionare anche le versioni 2002.05.20 e 2003.05.00, ma non sono state verificate.

Raccolta delle informazioni necessarie per il completamento della migrazione

È necessario raccogliere le seguenti informazioni:

  • La modalità di mapping tra i nomi degli utenti in ClearQuest e i nomi di dominio di Windows utilizzati da Gestione elementi di lavoro Team Foundation, compresi i nomi degli utenti non più in uso.

  • La modalità di mapping tra i campi degli elementi di lavoro in ClearQuest e Gestione elementi di lavoro Team Foundation, comprese informazioni sulle trasformazioni necessarie, ad esempio, tra un campo di tipo stringa in ClearQuest e un campo di tipo numero intero in Gestione elementi di lavoro Team Foundation.

Pianificazione della migrazione

Detrminare un'ora in cui è possibile richiedere agli utenti di non utilizzare ClearQuest. In questo modo le modifiche apportate durante l'esecuzione del convertitore non andranno perse. Di solito i fine settimana sono il momento ideale per pianificare la migrazione, in quanto la migrazione di database di grandi dimensioni può richiedere molto tempo. Una velocità di migrazione tipica per il convertitore è di circa 3.500 elementi di lavoro all'ora. Il tempo necessario per la migrazione dipende da molti fattori, ad esempio la dimensione degli allegati, il numero di riferimenti a entità e la configurazione del computer utilizzato per la conversione.

Preparazione della gestione degli elementi di lavoro di Team Foundation per la migrazione

Per preparare Gestione elementi di lavoro Team Foundation per la migrazione, seguire la procedura descritta.

  • Creare progetti Team per la gestione degli elementi di lavoro di Team Foundation Creare progetti Team e decidere a quali progetti Team devono appartenere i vari elementi di lavoro. Per ulteriori informazioni sulla creazione di progetti Team di Gestione elementi di lavoro Team Foundation, vedere Procedura dettagliata: creazione di un nuovo progetto Team.

  • Aggiungere l'account utente nel cui ambito viene eseguita la conversione agli account di servizio CQConverter richiede autorizzazioni dell'account di servizio per l'esecuzione. Aggiungere l'account utente nel cui ambito verrà eseguito il convertitore al gruppo Service Accounts del server Team Foundation Server mediante TFSSecurity. Per ulteriori informazioni, vedere Comandi dell'utilità della riga di comando TFSSecurity.

  • È inoltre possibile creare o modificare i tipi di elementi di lavoro Il convertitore genera tipi di elementi di lavoro che corrispondono allo schema dei tipi di elementi di lavoro in ClearQuest durante la fase di analisi. Tuttavia questi tipi di elementi di lavoro generati richiedono spesso delle modifiche per aggiungere funzionalità quali le regole. Come minimo è necessario modificare il form degli elementi di lavoro generato per specificare il layout visivo per i campi in quanto la formattazione del form generato è molto limitata. Per ulteriori informazioni, vedere Procedura dettagliata: personalizzazioni di base per un tipo di elemento di lavoro.

In questa sezione

Procedura: modificare il file di mappa dello schema

Viene illustrato come specificare i file da utilizzare nella migrazione degli elementi di lavoro mediante la modifica del file Schemamap.xml.

Procedura: generare il file di configurazione del convertitore

Viene illustrato come creare il file XML che fornisce le informazioni sulle impostazioni per il database di ClearQuest di cui si desidera eseguire la migrazione.

File di mapping campi, mappa di valori e valori predefiniti

Vengono forniti collegamenti ad argomenti che descrivono la modalità di mapping tra i campi in ClearQuest e quelli in Team Foundation.

File di configurazione del convertitore degli elementi di lavoro

Vengono fornite informazioni aggiuntive sul file di configurazione del convertitore.

Vedere anche

Attività

Procedura dettagliata: migrazione di elementi di lavoro ClearQuest a Team Foundation

Riferimenti

Riferimenti alla riga di comando per la migrazione degli elementi di lavoro


Procedura: modificare il file di mappa dello schema

Procedura: modificare il file di mappa dello schema

Il file di mappa dello schema per la migrazione degli elementi di lavoro specifica i file da utilizzare durante la migrazione degli elementi di lavoro, tra cui:

  • Il mapping tra ogni entità di ClearQuest e un file di definizione dei tipi di elemento di lavoro definiti.

  • Il file di mapping campi per eseguire il mapping tra i campi delle entità e i campi degli elementi di lavoro.

  • Il file di mapping utenti per eseguire il mapping tra gli utenti di ClearQuest e gli utenti di Team Foundation.

Il file di mappa dello schema viene generato dal convertitore durante la fase di analisi. Si consiglia di esaminare questo file prima di eseguire la migrazione e apportare le modifiche necessarie, come l'esclusione di un dato tipo di elemento di lavoro dalla migrazione o l'indicazione di un file di mapping utenti diverso.

Per modificare il file schemamap.xml

  1. Aprire il file Schemamap.xml, di cui è riportato un esempio di seguito:

    Immagine CopyCode Copia codice
    <Mappings>
  <SchemaMaps>
    <SchemaMap SourceEntity="Defect" TargetWIT="Defect"
      WITDFile="Defect.xml" FieldMapFile="DefectFieldMap.xml"/>
    <SchemaMap SourceEntity="Customer" TargetWIT="Customer"
      WITDFile="Customer.xml" FieldMapFile="CustomerFieldMap.xml"/>
  </SchemaMaps>
  <UserMap File="UserMap.xml" />
</Mappings>

  2. Modificare le sezioni del file in base alle esigenze.

    • SourceEntity Verificare che questa sezione contenga l'entità ClearQuest corretta.

    • TargetWIT Verificare che questa sezione faccia riferimento al tipo di elemento di lavoro corretto che deve essere creato in Gestione elementi di lavoro Team Foundation.

    • WITDFile Questa sezione specifica il file XML di definizione dei tipi di elemento di lavoro (WITD).

    • FieldMapFile Questa sezione specifica il file XML di mapping campi.

    • UserMap Questa sezione specifica il file XML di mapping utenti.

Vedere anche

Attività

Procedura dettagliata: migrazione di elementi di lavoro ClearQuest a Team Foundation
Procedura: modificare il file di mapping utenti

Altre risorse

Personalizzazione dei tipi di elemento di lavoro su Team Foundation Server
File di mapping campi, mappa di valori e valori predefiniti


Procedura: generare il file di configurazione del convertitore

Procedura: generare il file di configurazione del convertitore
Vedere anche

Il file di configurazione del convertitore è un file XML che contiene le impostazioni per il convertitore di ClearQuest all'interno di sezioni come descritto di seguito:

<ClearQuest>

Nella sezione ClearQuest sono contenute informazioni sul database di ClearQuest di cui verrà eseguita la migrazione.

  • ConnectionName Nome della connessione di ClearQuest.

  • UserDatabase Nome del database di ClearQuest.

  • QueryName Nome di una query salvata in ClearQuest.

  • UserID ID utente di ClearQuest (utilizzare admin).

<VSTS>

Nella sezione VSTS sono contenute informazioni sul server e sul progetto Team di Gestione elementi di lavoro Team Foundation verso cui viene eseguita la migrazione.

  • URI Nome descrittivo del server Team Foundation o URI completo nel formato http://Server:Porta.

    Se si utilizzano nomi descrittivi, assicurarsi di avere aggiunto Team Foundation Server tramite Team Explorer prima di eseguire il convertitore.

  • ProjectName Nome del progetto Team di Gestione elementi di lavoro Team Foundation.

Altre impostazioni di configurazione

Le altre sezioni del file XML consentono di controllare quanto segue:

  • ExitOnError In questa sezione è possibile impostare il valore True o False. Selezionare True per uscire in caso di errore. Se si imposta il valore True, infatti, il convertitore di ClearQuest si arresta se si verifica un errore durante la migrazione di alcuni elementi di lavoro.

    Nota Nota

    Questa impostazione viene applicata solo in caso di errori non irreversibili. In caso di errore irreversibile, ad esempio se non è possibile connettersi a ClearQuest, il convertitore di ClearQuest si arresterà anche se l'impostazione è False.

  • OutputDirectory Specifica la directory di destinazione per i file di cui viene eseguita la migrazione. Se non si specifica una directory di output, il convertitore crea una directory con il nome dell'entità di base per la generazione dei file di output. Se esiste già una directory con tale nome, i file presenti verranno sovrascritti.

Per creare il file di configurazione

  1. Raccogliere le seguenti informazioni:

    • Nome della connessione di ClearQuest

    • Nome del database di ClearQuest

    • ID utente e password dell'amministratore di ClearQuest. Assicurarsi che l'utente disponga delle autorizzazioni necessarie per l'inoltro di segnalazioni in ClearQuest.

    • Nome del server Team Foundation.

    • Nome del progetto Team di Gestione elementi di lavoro Team Foundation in cui si desidera eseguire la migrazione degli elementi di lavoro.

  2. Creare una query in ClearQuest per selezionare gli elementi di lavoro di cui si desidera eseguire la migrazione a Gestione elementi di lavoro Team Foundation e salvarla. Salvare la query con un nome qualsiasi, ad esempio QueryTransizione.

  3. Scegliere una directory per memorizzare i file generati durante la fase di analisi.

  4. Copiare il seguente file di configurazione XML in un editor di testo:

    Immagine CopyCode Copia codice
    <?xml version="1.0" encoding="utf-8"?>
<WorkItemConverter>
  <Source id="ClearQuest">
    <ClearQuest>
      <ConnectionName>CQRep</ConnectionName>
      <UserDatabase>TEST</UserDatabase>
      <QueryName>Public Queries/All Defects</QueryName>
      <UserID>admin</UserID>
    </ClearQuest>
  </Source>
  <VSTS>
    <URI>JoseLugo</URI>
    <ProjectName>JoseLugoProjectX</ProjectName>
  </VSTS>
  <ExitOnError>true</ExitOnError>
  <OutputDirectory>DefectSchema</OutputDirectory>
</WorkItemConverter>

  5. Modificare il file per specificare le impostazioni con le informazioni raccolte nei passaggi precedenti. In <QueryName>, ad esempio, specificare il nome della query come QueryTransizione, incluso il relativo percorso. Per informazioni sul contenuto di ciascuna sezione, vedere la precedente sezione relativa al file di configurazione.

    Nota Nota

    Se nel file non viene immessa alcuna password, verrà richiesta in seguito durante il processo di migrazione.

  6. Salvare il file, ad esempio con il nome ConfigConvertitoreCQ.xml.

Vedere anche

Riferimenti

Work Item Type Definition Schema


File di mapping campi, mappa di valori e valori predefiniti

 elenco a discesa elenco a discesa attivabile
File di mapping campi, mappa di valori e valori predefiniti
Vedere anche
elenco a discesa

Quando si esegue la migrazione di elementi di lavoro da ClearQuest a Team Foundation, il convertitore consente di controllare il mapping tra i campi in ClearQuest e in Team Foundation.

In questa sezione

Negli argomenti trattati in questa sezione viene descritto come modificare i file XML che controllano la modalità di migrazione degli elementi di lavoro.

Procedura: modificare il file di mapping utenti

Viene illustrato come modificare il file di mapping utenti per eseguire la migrazione dagli utenti di ClearQuest agli utenti di Team Foundation.

Procedura: specificare il mapping dei valori di campo

Viene illustrato come modificare il file di mapping campi per eseguire la migrazione dai campi di ClearQuest ai campi degli elementi di lavoro di Team Foundation.

Schema del file di mapping campi

Vengono fornite informazioni utili per la comprensione del codice XML che specifica il mapping tra i campi di ClearQuest e i campi degli elementi di lavoro di Team Foundation.

Schema del file di mapping utenti

Vengono fornite informazioni utili per la comprensione del codice XML che specifica il mapping tra gli utenti di ClearQuest e gli utenti di Team Foundation.

Vedere anche

Attività

Procedura dettagliata: migrazione di elementi di lavoro ClearQuest a Team Foundation


Procedura: modificare il file di mapping utenti

Procedura: modificare il file di mapping utenti

Il convertitore di ClearQuest utilizza il file di mapping utenti per mappare gli ID utente nel database di ClearQuest agli ID utente di Gestione elementi di lavoro Team Foundation equivalenti. Grazie alla conversione dei valori dei campi degli ID utente in valori validi in Gestione elementi di lavoro Team Foundation è possibile mantenere le informazioni cronologiche sugli elementi di lavoro. In Gestione elementi di lavoro Team Foundation vengono utilizzati ID utente di dominio Windows.

Durante la fase di analisi il convertitore di ClearQuest genera una versione predefinita del file di mapping utenti. Accertarsi dell'accuratezza del file prima di procedere alla conversione, in quanto il convertitore verifica dapprima il file e si arresta in caso vengano rilevati problemi.

Per modificare il file di mapping utenti

  1. Aprire il file usermap.xml, di cui è riportato un esempio di seguito:

    Immagine CopyCode Copia codice
    <UserMappings">
  <UserMap From="admin" To="admin" />
  <UserMap From="user" To="user" />
  <UserMap From="QE" To="QE" />
  <UserMap From="lead" To="lead" />
  <UserMap From="engineer" To="engineer" />
</UserMappings>

  2. Verificare i dati di mapping utenti ed eventualmente apportare correzioni, aggiunte ed eliminazioni. Come destinazione del mapping utenti deve essere indicato un utente di Team Foundation Server esistente.

  3. In Gestione elementi di lavoro Team Foundation aggiungere tutti gli utenti specificati nel file di mapping utenti. Per ulteriori informazioni su come aggiungere utenti, vedere Gestione di utenti e gruppi.

Vedere anche

Attività

Procedura dettagliata: migrazione di elementi di lavoro ClearQuest a Team Foundation

Riferimenti

Schema del file di mapping utenti

Altre risorse

Personalizzazione dei tipi di elemento di lavoro su Team Foundation Server
Gestione di utenti e gruppi


Procedura: specificare il mapping dei valori di campo

Procedura: specificare il mapping dei valori di campo

Il convertitore di ClearQuest utilizza i file di mapping campi per eseguire il mapping tra i campi di tutte le entità di ClearQuest e i campi degli elementi di lavoro di Gestione elementi di lavoro Team Foundation equivalenti. Durante l'analisi il convertitore crea un file di mapping campi per ciascuna entità di ClearQuest.

Per modificare il file di mapping campi

  1. Aprire uno dei file di mapping campi, ad esempio DefectFieldMap.xml, di cui è riportato un esempio di seguito:

    Immagine CopyCode Copia codice
    <FieldMap from="Criticality" to="Severity">
  <ValueMaps>
        <ValueMap from="1-Critical" to = "1"/>
        <ValueMap from="2-Major" to = "2"/>
  </ValueMaps>
</FieldMap>

  2. Esaminare le righe di mapping campi (a partire da ValueMap) e verificare che il campo indicato dopo "from" sia associato al campo corretto indicato dopo "to". Per aggiungere mapping campi, inserire ulteriori righe ValueMap. I valori devono essere inclusi nell'elenco dei valori consentiti se tale elenco è stato specificato nel file dello schema, in questo caso defect.xml.

    Nota Nota

    Se si modificano i mapping campi, assicurarsi di apportare le modifiche corrispondenti nei file dei tipi di elemento di lavoro. Ad esempio, se si modifica un nome di campo nel file di mapping campi, accertarsi che il campo sia presente nel file dei tipi di elemento di lavoro.

  3. Aprire gli altri file di mapping campi e modificarli in base alle esigenze.

Vedere anche

Attività

Procedura dettagliata: migrazione di elementi di lavoro ClearQuest a Team Foundation

Riferimenti

Schema del file di mapping campi
Work Item Type Definition Schema

Concetti

Cenni preliminari sugli elementi di lavoro e sui tipi di elemento di lavoro


Schema del file di mapping campi
comprimi tutto elenco a discesa

Il file di mapping campi consente di specificare il mapping dei campi di ClearQuest ai campi degli elementi di lavoro.

espandi Schema del file di mapping campi

Di seguito è riportato un esempio di file di mapping campi:

Immagine CopyCode Copia codice
<FieldMaps>
<FieldMap from="Criticality" to="Severity">
  <ValueMaps defaultValue="3">
        <ValueMap from="1-Critical" to = "1"/>
        <ValueMap from="2-Major" to = "2"/>
  </ValueMaps>
</FieldMap>
</FieldMaps>

Di seguito sono descritti i nodi e gli attributi che è possibile utilizzare in questo file:

  • <FieldMaps> Nodo contenitore di primo livello che contiene tutti i mapping. In ogni file può essere presente un solo nodo di questo tipo.

  • <FieldMap> Nodo figlio di <FieldMaps>. che definisce un mapping campi. Utilizzare più nodi per specificare più mapping. I mapping vengono definiti mediante i seguenti attributi:

    • from Specificare il nome del campo in ClearQuest per cui si desidera definire il mapping.

    • to Specificare il nome descrittivo del campo in Team Foundation a cui si desidera eseguire il mapping del campo in ClearQuest. È necessario specificare il nome descrittivo del campo e non quello di riferimento.

    • exclude Indica se includere o meno il campo nella migrazione. Impostare su False.

  • <ValueMaps> Facoltativo, a meno che non vengano specificati nodi <ValueMap> figlio. Per ciascun nodo <FieldMap> sono supportati un nodo figlio di <FieldMap> e solo un nodo <ValueMaps>. Contiene tutti i mapping dei valori per il campo specificato nel nodo <FieldMap>.

  • <ValueMap> Facoltativo. Nodo figlio di <ValueMaps>. che definisce il mapping di un valore. Creare più nodi per specificare più mapping. Il mapping dei valori viene specificato mediante i seguenti attributi:

    • from Specificare il valore del campo in ClearQuest per cui si desidera creare il mapping.

    • to Specificare il valore del campo in Team Foundation che il convertitore deve utilizzare per sostituire il valore di ClearQuest specificato durante la migrazione dei dati a Team Foundation.

espandi Vedere anche

Attività

Procedura: specificare il mapping dei valori di campo

piè di pagina


Schema del file di mapping utenti
comprimi tutto elenco a discesa

Nel file di mapping utenti è specificato il mapping utenti tra ClearQuest e Team Foundation. ClearQuest utilizza il proprio database degli utenti mentre Team Foundation Server utilizza i nomi utente Windows per gli utenti. Poiché è possibile che i nomi utente in ClearQuest e Windows non corrispondano, il file di mapping utenti consente di definire i mapping appropriati. Non è obbligatorio specificare i mapping utenti. In assenza di mapping, il convertitore inserirà i nomi utente presenti nel database di ClearQuest negli elementi di lavoro di Team Foundation. Questo comportamento è possibile perché il convertitore opera con regole flessibili. Al termine della migrazione, quando si iniziano a modificare gli elementi di lavoro, è quindi possibile che alcuni campi contengano utenti non validi in Team Foundation. Se in base alle regole definite un campo deve contenere utenti validi, è necessario fornire un nome utente valido per il campo prima di potere salvare l'elemento di lavoro.

Al fine di determinare come agire, tenere presente i seguenti scenari:

  • Se i nomi utente di ClearQuest e Windows in Team Foundation corrispondono, non è necessario specificare alcun mapping.

  • Se i nomi utente di ClearQuest e Windows di Team Foundation differiscono, sono disponibili diverse opzioni:

    • Eseguire il mapping utenti di ClearQuest agli utenti di Team Foundation nel file affinché il convertitore esegua il mapping durante la migrazione.

    • Scegliere di non specificare i mapping per la migrazione. Se in base alle regole definite alcuni campi devono contenere utenti validi, è necessario fornire nomi utente validi quando si modificano i corrispondenti elementi di lavoro dopo la migrazione.

    • Scegliere di non specificare alcun mapping ed eliminare le regole che richiedono la presenza di validi in determinati campi. Questa opzione non è consigliata.

    • Scegliere di non specificare alcun mapping, ma aggiungere <ALLOWEXISTINGVALUE/> per indicare che i campi che contengono valori esistenti devono mantenerli anche se contravvengono a delle regole.

L'assenza di mapping utenti può creare confusione in quanto possono essere presenti elementi di lavoro che contengono nomi utente di ClearQuest ed elementi di lavoro nuovi o modificati che riportano nomi utente di TFS. La scelta consigliata è fornire i mapping in tutti i casi in cui a un nome utente di ClearQuest è associato un nome utente di accesso a Windows diverso e tralasciare tutti i nomi utente a cui non corrisponde alcun nome utente di accesso a Windows.

espandi Schema del file di mapping utenti

Di seguito sono descritti i nodi e gli attributi che è possibile utilizzare in questo file:

  • <UserMappings> Nodo di primo livello che contiene tutti i mapping. In ogni file può essere presente un solo nodo di questo tipo.

  • <UserMap> Nodo figlio di <UserMappings> che definisce un mapping utenti. Utilizzare più nodi per specificare più mapping. I mapping vengono definiti mediante i seguenti attributi:

    • From Specificare il nome utente in ClearQuest che si desidera mappare a un nome utente di Team Foundation diverso.

    • To Specificare il nome utente in Team Foundation a cui si desidera mappare il nome di ClearQuest specificato.

espandi Vedere anche

Attività

Procedura: modificare il file di mapping utenti

piè di pagina


File di configurazione del convertitore degli elementi di lavoro

 elenco a discesa elenco a discesa attivabile
File di configurazione del convertitore degli elementi di lavoro
Vedere anche
elenco a discesa

Il file di configurazione degli elementi di lavoro è un file XML che contiene le impostazioni per il convertitore di ClearQuest. Le sezioni di questo file vengono descritte più avanti in questo argomento, seguite da un file di configurazione di esempio che è possibile utilizzare per creare un file di configurazione personalizzato.

Sezioni del file di configurazione

Il file XML di configurazione del convertitore di elementi di lavoro contiene diverse sezioni che specificano come eseguire la migrazione degli elementi di lavoro da ClearQuest a Team Foundation. Queste sezioni vengono descritte in dettaglio più avanti in questo argomento.

<ClearQuest>

Nella sezione ClearQuest sono contenute informazioni sul database di ClearQuest di cui verrà eseguita la migrazione.

  • ConnectionName Nome della connessione di ClearQuest.

  • UserDatabase Nome del database utenti di ClearQuest.

  • QueryName Nome di una query salvata in ClearQuest.

  • UserID ID utente di ClearQuest. È necessario utilizzare l'ID utente "admin" in quanto questo utente deve essere autorizzato a creare tutti i tipi di elemento di lavoro.

<VSTS>

Nella sezione VSTS sono contenute informazioni sul server e sul progetto Team di Gestione elementi di lavoro Team Foundation verso cui viene eseguita la migrazione.

  • URI Nome descrittivo o URI completo del server Team Foundation Server. Ad esempio, "ServerAT" o "http://ServerAT:8080".

  • ProjectName Nome del progetto Team di Gestione elementi di lavoro Team Foundation.

Altre impostazioni di configurazione

Le altre sezioni nel file XML consentono di controllare quanto segue:

  • ExitOnError In questa sezione è possibile impostare il valore true o false. Selezionare True per uscire in caso di errore. In questo caso, infatti, il convertitore di ClearQuest si arresta se si verifica un errore durante la migrazione di alcuni elementi di lavoro.

    Nota Nota

    Questa impostazione viene applicata solo in caso di errori non irreversibili. In caso di errore irreversibile, ad esempio se non è possibile connettersi a ClearQuest, il convertitore di ClearQuest si arresterà anche se l'impostazione è False.

  • OutputDirectory Specifica la directory di destinazione per i file generati. Se non si specifica una directory di output, il convertitore crea una directory con il nome dell'entità di base per la generazione dei file di output. Se esiste già una directory con tale nome, i file presenti verranno sovrascritti.

File di configurazione del convertitore degli elementi di lavoro di esempio

Di seguito è riportato un file di configurazione del convertitore degli elementi di lavoro di esempio che esegue la migrazione del database TEST di ClearQuest sulla connessione CQRep utilizzando la query All Defects nel progetto Team JoseLugoProjectX in Team Foundation. Viene inoltre indicato che il convertitore deve arrestarsi in caso di errore e viene specificata la directory per i file di output creati dal convertitore.

Immagine CopyCode Copia codice
<?xml version="1.0" encoding="utf-8"?>
<WorkItemConverter>
  <Source id="ClearQuest">
    <ClearQuest>
      <ConnectionName>CQRep</ConnectionName>
      <UserDatabase>TEST</UserDatabase>
      <QueryName>Public Queries/All Defects</QueryName>
      <UserID>admin</UserID>
    </ClearQuest>
  </Source>
  <VSTS>
    <URI>JoseLugo</URI>
    <ProjectName>JoseLugoProjectX</ProjectName>
  </VSTS>
  <ExitOnError>true</ExitOnError>
  <OutputDirectory>DefectSchema</OutputDirectory>
</WorkItemConverter>

Vedere anche

Attività

Procedura: generare il file di configurazione del convertitore
Procedura dettagliata: migrazione di elementi di lavoro ClearQuest a Team Foundation

Riferimenti

Work Item Type Definition Schema


Migrazione degli elementi di lavoro

 elenco a discesa elenco a discesa attivabile
Migrazione degli elementi di lavoro
Vedere anche
elenco a discesa

Dopo avere completato la pianificazione della migrazione ed eseguito l'analisi del database di ClearQuest, è possibile eseguire la migrazione degli elementi di lavoro a Gestione elementi di lavoro Team Foundation.

In questa sezione

Analisi di un database ClearQuest

Vengono descritti la fase di analisi e i file generati.

Procedura: eseguire le migrazione di elementi di lavoro

Viene illustrato come migrare elementi di lavoro da ClearQuest a Gestione elementi di lavoro Team Foundation.

Procedura: eseguire la migrazione di elementi di lavoro a un database esistente in Team Foundation

Vengono forniti argomenti che descrivono come eseguire la migrazione di elementi di lavoro in un database esistente.

Vedere anche

Attività

Procedura dettagliata: migrazione di elementi di lavoro ClearQuest a Team Foundation


Analisi di un database ClearQuest

 elenco a discesa elenco a discesa attivabile
Analisi di un database ClearQuest
Vedere anche
elenco a discesa

Nella fase di analisi il convertitore legge lo schema dal database ClearQuest e genera file che rappresentano lo schema nel formato Team Foundation. Il convertitore utilizza la query ClearQuest per determinare il tipo di entità di base ClearQuest. Una query in ClearQuest si basa su un tipo di entità. Il convertitore determina inoltre i tipi di entità associati con il tipo di entità di base. Le entità associate dell'entità di base sono quelle a cui l'entità di base fa riferimento, ossia le entità presenti nel tipo di entità di base come riferimento o elenco di riferimenti. L'elenco di riferimento esclude tuttavia le seguenti entità:

  • I tipi di entità a cui potrebbe venire fatto riferimento come duplicato di.

  • Entità utente La migrazione degli utenti viene eseguita in base alla gestione degli utenti in Team Foundation. Team Foundation non gestisce gli utenti come entità.

  • Entità allegato La migrazione degli allegati viene eseguita in base alla gestione degli allegati principale di Team Foundation. Team Foundation non gestisce gli allegati come entità.

  • Cronologia La migrazione della cronologia viene eseguita in base alla gestione della cronologia principale di Team Foundation. Team Foundation non gestisce la cronologia come entità.

  • Gruppi Il convertitore non esegue la migrazione dei gruppi di ClearQuest. I gruppi vengono gestiti in modo diverso in Team Foundation.

  • Ratl_replicas Questo riferimento alle entità non è utile per la migrazione e non esiste un concetto equivalente in Team Foundation.

Fase di analisi

Al prompt dei comandi di Visual Studio 2005 eseguire il comando seguente:

CQConverter.exe /c:analyze /m:CqConverterConfig.xml

Il convertitore di ClearQuest potrebbe impiegare alcuni minuti per completare l'esecuzione. Al termine della fase di analisi vengono generati diversi file.

File di configurazione del convertitore

I dati per il convertitore devono essere specificati in un file di configurazione. Per ulteriori informazioni, vedere File di configurazione del convertitore degli elementi di lavoro.

File di output

Durante la fase di analisi vengono generati diversi file di output, che vengono salvati nella cartella specificata dall'elemento <DirectoryOutput> nel file di impostazioni della migrazione. Se non è specificata alcuna directory, il convertitore crea una cartella con lo stesso nome del tipo di entità di base di ClearQuest. Se la cartella esiste già, il contenuto della cartella viene sovrascritto con i nuovi file XML generati.

Al termine della fase di analisi vengono creati i seguenti file.

  • File XML di definizione di tipi di elemento di lavoro Questi file rappresentano i tipi di elemento di lavoro nel formato Team Foundation e vengono utilizzati per creare i tipi di elemento di lavoro in Team Foundation. Vengono generati un file per l'entità primaria e un file per ogni entità a cui viene fatto riferimento con i nomi <TipoEntità>.xml. Ad esempio, un tipo di elemento di lavoro dei difetti genera il file Defect.xml.

  • File XML di mapping campi Questi file specificano il mapping campi tra i tipi di record di ClearQuest e i tipi di elemento di lavoro di Team Foundation e qualsiasi trasformazione dei dati da applicare durante la migrazione dei dati. Questi file hanno una relazione uno-a-uno con i file di tipi di elemento di lavoro. Ciascun file di mapping campi specifica il mapping per il tipo di elemento di lavoro corrispondente. A questi file viene assegnato il nome <NomeEntità>FieldMap.xml. Ad esempio, un tipo di elemento di lavoro dei difetti genera il file DefectFieldMap.xml.

  • File XML di mapping utenti Il nome di questo file è UserMap.xml e specifica il mapping tra gli utenti di ClearQuest e gli utenti di Team Foundation. Questo file potrebbe essere necessario perché ClearQuest utilizza un database utenti distinto e i nomi utente di ClearQuest potrebbero non corrispondere agli account utente Windows richiesti da Team Foundation.

  • File di mappa di schema XML Il nome di questo file è SchemaMap.xml e contiene i nomi di tutti i file descritti precedentemente nonché indica mapping aggiuntivi tra i tipi di elemento di lavoro e i file associati.

  • File XML di report di analisi Il nome di questo file è CQAnalysisReport.xml. Insieme al file viene generata la cartella _AnalysisReport_Files contenente immagini e un foglio di stile per la visualizzazione corretta del file in un browser.

  • Il file di log CQConverter.log

    Nota Nota

    Indipendentemente dal numero di campi di un particolare elemento di lavoro selezionato in una query, dal convertitore vengono selezionati tutti i campi presenti in un tipo di elemento di lavoro per l'analisi. I file di output contengono riferimenti a tutti i campi.

File di definizione del tipo di elemento di lavoro

I file di definizione del tipo di elemento di lavoro catturano lo schema di un tipo di elemento di lavoro nel formato Team Foundation. È possibile utilizzare questo file per creare un nuovo tipo di elemento di lavoro in Team Foundation. Un file di definizione del tipo di elemento di lavoro specifica i campi nel tipo di elemento di lavoro, gli stati e le transizioni di stato, le regole e l'interfaccia utente per la visualizzazione dell'elemento di lavoro. Per ulteriori informazioni sui file di definizione del tipo di elemento di lavoro, vedere Amministrazione dei tipi di elemento di lavoro.

Nelle sezioni seguenti viene illustrato come vengono generati questi tipi di elemento di lavoro.

Mapping dei tipi di campo

Il convertitore esegui il mapping tra i tipi di campo in ClearQuest e i tipi di campo appropriati in Team Foundation, come descritto nella seguente tabella.

Tipo di campo di ClearQuest | Tipo di campo di Team Foundation
ATTACHMENT_LIST | Non applicabile. Per questo tipo di campo la migrazione viene eseguita sotto forma di allegato invece che di campo in Team Foundation.
DATE_TIME | DateTime
INT | Integer
MULTILINE_STRING | Testo normale
REFERENCE | Non applicabile. Per questo tipo di campo la migrazione viene eseguita sotto forma di collegamento invece che di campo in Team Foundation.
REFERENCE_LIST | Non applicabile. Per questo tipo di campo la migrazione viene eseguita sotto forma di collegamento invece che di campo in Team Foundation.
SHORT STRING | Stringa
DBID | Non sottoposto a migrazione. Questo tipo di campo è riservato per i campi di sistema in ClearQuest e non è necessario negli elementi di lavoro sottoposti a migrazione.
ID | Stringa. Per questo tipo di campo la migrazione viene eseguita sotto forma di campo vsts sourceid in Team Foundation.
JOURNAL | Non applicabile. Questo tipo di campo è riservato per i campi di sistema in ClearQuest e la sua migrazione viene eseguita sotto forma di cronologia in Team Foundation.
State | Stringa. Questo tipo di campo è riservato per i campi di sistema in ClearQuest e la sua migrazione viene eseguita sotto forma di campo State del sistema in Team Foundation.

Mapping campi

Ogni tipo di elemento di lavoro in ClearQuest utilizza campi di sistema, come esistono campi di sistema nei tipi di elemento di lavoro di Team Foundation. Il convertitore esegui il mapping tra i campi di sistema di ClearQuest e i campi di sistema in Team Foundation come appropriato. Oltre ai campi di sistema, esistono altri campi che sono in genere presenti nei tipi di elemento di lavoro di ClearQuest. Il convertitore esegui il mapping di tali campi ai campi di Team Foundation appropriati.

Nella seguente tabella viene descritto come il convertitore esegue il mapping dei campi di sistema.

Campo di sistema di ClearQuest | Campo di sistema di Team Foundation
ID | vsts sourceid
State | State

Nella seguente tabella viene descritto come il convertitore esegue il mapping dei campi comuni.

Campo di ClearQuest | Campo di sistema di Team Foundation
Headline | Title
Description | Description
Submitter | Created By
Submit_Date | Created Date
Owner | Assigned To
User_name (cronologia) | Changed By
action_timestamp (cronologia) | Changed Date

Gestione del comportamento dei campi

È possibile specificare il comportamento dei campi in ClearQuest. È inoltre possibile specificare un comportamento diverso per i campi in base allo stato dell'elemento di lavoro. Il convertitore presenta delle limitazioni sulla migrazione del comportamento negli elementi di lavoro di ClearQuest. Ad esempio, il convertitore esegue la migrazione del comportamento del campo specificato solo allo stato iniziale, cioè lo stato di un elemento di lavoro appena creato.

Il comportamento definito per altri stati non viene esaminato o generato nella fase di analisi. Tuttavia Team Foundation supporta la definizione di questi comportamenti ed è possibile aggiungerli manualmente nei tipi di elemento di lavoro dopo la fase di analisi. Per ulteriori informazioni sulla personalizzazione del comportamento per i tipi di elemento di lavoro in Team Foundation, vedere Definizione del flusso di lavoro degli elementi di lavoro.

La migrazione del comportamento degli elementi di lavoro viene eseguita come descritto nella seguente tabella.

Comportamento | Descrizione
Obbligatorio | La migrazione di questo comportamento viene eseguita in Team Foundation. Per specificare Obbligatorio in Team Foundation, applicare l'elemento <OBBLIGATORIO> nella definizione del tipo di elemento di lavoro.
Facoltativo | La migrazione di questo comportamento viene eseguita in Team Foundation. Poiché Facoltativo è il comportamento predefinito di un campo in Team Foundation, non sono necessari altri elementi nella definizione del tipo di elemento di lavoro.
Sola lettura | Non è possibile eseguire la migrazione di questo comportamento.
Use_hook | Non è possibile eseguire la migrazione di questo comportamento.

Campi aggiunti dal convertitore nei tipi di elemento di lavoro

Il convertitore genera i seguenti campi in ciascun tipo di elemento di lavoro oltre ai campi presenti nei tipi di elemento di lavoro di ClearQuest.

Campi necessari per il funzionamento del convertitore.

Non rimuovere questi campi dai tipi di elemento di lavoro per non compromettere la migrazione. Se non si desidera visualizzarli, è possibile rimuoverli dall'interfaccia utente (form) dell'elemento di lavoro. Si consiglia di mantenere questi campi in sola lettura soltanto per impedire agli utenti di modificarli. Di seguito sono elencati questi campi:

  • Campo per l'ID ClearQuest di un elemento di lavoro sottoposto a migrazione.

    Immagine CopyCode Copia codice
    <FIELD name="vsts sourceid" refname="Microsoft.TeamFoundation.Converters.vsts_sourceid" type="String"/>

  • Campo per il database ClearQuest da cui proviene un elemento di lavoro sottoposto a migrazione.

    Immagine CopyCode Copia codice
    <FIELD name="vsts sourcedb" refname="Microsoft.TeamFoundation.Converters.vsts_sourcedb" type="String"/>

  • Campo utilizzato per gestire lo stato della migrazione di un dato elemento di lavoro.

    Immagine CopyCode Copia codice
    <FIELD name="Migration Status" refname="Microsoft.TeamFoundation.Converters.Migration_Status" type="String"/>

  • Campi di sistema in Team Foundation. Quando è presente una corrispondenza tra i campi di sistema in Team Foundation e quelli in ClearQuest, viene generato il file XML di mapping appropriato. Per i campi di sistema in Team Foundation per cui non esiste una corrispondenza con i campi di sistema in ClearQuest vengono generati campi aggiuntivi in ciascun tipo di elemento di lavoro. Questi campi vengono identificati con un commento simile al seguente file XML:

    Immagine CopyCode Copia codice
    <!--State is a core field in Team Foundation Work Item Tracking and we recommend that you use this field because it best suits the purpose-->

Gestione dei campi elenco

Per i campi in ClearQuest potrebbe essere definito un insieme di valori validi o suggeriti. Durante la lettura dei campi e dei rispettivi tipi il convertitore determina se il campo è di tipo elenco e in tal caso raccoglie anche i valori di elenco validi o suggeriti. Queste informazioni vengono catturate nei file di definizione del tipo di elemento di lavoro nella sezione del campo corrispondente. Individuare gli elementi <AllowedValues> o <SugggestedValues>.

Gestione di stati e transizioni di stato

Le definizioni del tipo di entità basate sullo stato nello schema ClearQuest supportano:

  • Un insieme di stati.

  • Transizioni tra stati, dette Azioni.

  • Comportamento del campo associato agli stati.

Il convertitore cattura le azioni e gli stati di ClearQuest come stati e transizioni di stato nelle definizioni del tipo di elemento di lavoro di Team Foundation.

Gestione del form dell'elemento di lavoro

Il convertitore non esegue la migrazione delle informazioni del form dal database ClearQuest a Team Foundation, bensì crea un form dell'elemento di lavoro predefinito come parte dello schema generato durante la fase di analisi. Questo form predefinito però non assomiglia a quello originale in ClearQuest. Il form predefinito presenta una formattazione semplice e quasi sempre richiede modifiche per migliorarne l'usabilità. Per informazioni sulla modifica dei form degli elementi di lavoro, vedere Definizione del form elemento di lavoro.

Controlli sul form

È possibile inserire diversi controlli sul form di un elemento di lavoro in ClearQuest oltre a quelli disponibili in Team Foundation. Team Foundation supporta un insieme di controlli predefiniti che è possibile utilizzare. Alcuni dei controlli disponibili in ClearQuest non lo sono in Team Foundation. Sebbene durante la migrazione venga conservata la quantità massima di dati, le diversità nei controlli si ripercuote sulla visualizzazione dei dati nel form in Team Foundation. I seguenti controlli non sono supportati in Team Foundation.

  • Controlli ActiveX

  • Controllo Calendar

  • Controllo casella di controllo

  • Controllo casella combinata

  • Controllo base duplicata

  • Controllo dipendenti duplicati

  • Controllo padre/figlio

  • Controllo immagine

  • Controllo pulsante di comando

  • Controllo casella di riepilogo

  • Controllo visualizzazione elenco

  • Controllo pulsante di opzione

  • Controllo casella di testo statico

Come parte della pianificazione della migrazione è necessario valutare il possibile effetto dell'assenza di questi controlli per gli utenti.

File di mapping campi

II file di mapping campi specifica il mapping dei campi e dei valori.

Mapping campi

I file di mapping campi specificano il mapping tra i campi di ClearQuest e i campi di Team Foundation. Per la maggior parte dei campi in ClearQuest, a eccezione dei campi di sistema e comuni, esiste un'associazione uno-a-uno in Team Foundation. È necessario mantenere i file di mapping campi sincronizzati con le modifiche apportate ai campi nei file di definizione del tipo di elemento di lavoro. Ad esempio, se si rinomina un campo nel file di definizione del tipo di elemento di lavoro, è necessario modificare il file di mapping di conseguenza. Allo stesso modo, se si eliminano dei campi dal file di definizione del tipo di elemento di lavoro, è necessario eliminare gli stessi campi dal file di mapping campi corrispondente.

Mapping dei valori

I file di mapping campi specificano inoltre come i dati dei campi devono essere trasformati durante la migrazione. Per impostazione predefinita, non viene generato alcun mapping dei valori, ma è possibile specificare i mapping dei valori se si desidera trasformare i dati durante la migrazione. Per specificare le trasformazioni, definire i mapping dei valori per indicare, ad esempio, che al valore "Pri1" deve corrispondere "1".

Il file di mapping campi è un file XML. Nell'esempio riportato di seguito viene illustrato come eseguire il mapping di campi e valori:

<?xml version="1.0"?>

<FieldMaps xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">

  <!-- Title is a core field in Team Foundation Work Item Tracking and we recommend that you use this field because it best suits the purpose-->

  <FieldMap from="Headline" to="Title" />

  <FieldMap from="Submitter" to="Submitter">

    <ValueMaps refer="UserMap" />

  </FieldMap>

  <!-- Created Date is a core field in Team Foundation Work Item Tracking and we recommend that you use this field because it best suits the purpose-->

  <FieldMap from="Submit_Date" to="Created Date" />

  <!-- Assigned To is a core field in Team Foundation Work Item Tracking and we recommend that you use this field because it best suits the purpose-->

  <FieldMap from="Owner" to="Assigned To">

    <ValueMaps refer="UserMap" />

  </FieldMap>

</FieldMaps>

Per ulteriori informazioni sul mapping campi, vedere Schema del file di mapping campi.

Mapping ai campi Percorso area e Percorso iterazione

Nella gestione degli elementi di lavoro di Team Foundation gli elementi di lavoro sono organizzati in una gerarchia di aree strutturali e iterazioni. Per ulteriori informazioni, vedere Procedura: modificare la struttura di un progetto Team e Procedura: modificare le iterazioni di un progetto Team.

I percorsi consentono di raggruppare gli elementi di lavoro strutturalmente per rappresentare i componenti, i progetti o le applicazioni utilizzati dal team. Le iterazioni consentono di raggruppare gli elementi di lavoro in base a eventi principali, quali attività cardine e fasi di progetto. I campi di sistema Percorso area e Percorso iterazione definiscono queste informazioni in Team Foundation. Poiché in ClearQuest non è disponibile questo concetto, il convertitore fornisce un valore predefinito per questi campi, in base a cui tutti gli elementi di lavoro vengono inseriti nella radice di Percorso area e Percorso iterazione.

Sebbene ClearQuest non disponga dei campi Percorso area e Percorso iterazione, è possibile che questi concetti vengano utilizzati in altro modo. Ad esempio, è possibile che un campo nei tipi di elemento di lavoro rappresenti il progetto a cui l'elemento di lavoro appartiene. Ciò corrisponde grosso modo al concetto di Percorso area. Allo stesso modo è possibile che un altro campo, ad esempio Correggi entro, indichi la scadenza per la correzione di un elemento di lavoro particolare. Considerare la possibilità di eseguire il mapping di questi campi a Percorso area e Percorso iterazione, in modo che gli elementi di lavoro vengano distribuiti in nodi diversi e non inseriti tutti nel nodo principale. Specificare questi mapping nei file di mapping campi del tipo di elemento di lavoro come spiegato in precedenza.

Nel seguente file XML di esempio viene eseguito il mapping del campo Tree Path di ClearQuest con i possibili valori Area1 e Area2.

<FieldMap from="Tree Path" to="Area Path" exclude="false">

<ValueMaps>

  <ValueMap from="Area1" to="Area1" />

  <ValueMap from="Area2" to="Area2" />

</ValueMaps>

</FieldMap>

Nel seguente file XML di esempio viene eseguito il mapping del campo Fix By di ClearQuest con i possibili valori Alpha e Beta.

<FieldMap from="Fix By" to="Iteration Path" exclude="false">

<ValueMaps>

  <ValueMap from= "Alpha" to="Alpha"/>

  <ValueMap from= "Beta" to="Beta"/>

</ValueMaps>

</FieldMap>

File di mapping utenti

Nel file di mapping utenti è specificato il mapping utenti tra ClearQuest e Team Foundation. Per ulteriori informazioni, vedere Schema del file di mapping utenti.

File di mappa dello schema

Il file di mappa dello schema specifica il tipo di elemento di lavoro di origine, il tipo di elemento di lavoro di destinazione, il file di definizione dell'elemento di lavoro e il file di mapping campi. Per ulteriori informazioni, vedere Procedura: modificare il file di mappa dello schema.

File di report di analisi

Al termine della migrazione viene generato un file di report di analisi con nome CQAnalysisReport.xml nella cartella in cui è stato eseguito CQConverter. Viene inoltre creata la cartella _MigrationReport_Files contenente i file immagine e un foglio di stile per la visualizzazione del report in un browser. Al termine dell'analisi aprire questo file per visualizzare eventuali errori o avvisi rilevati durante la fase di analisi. Il report di analisi contiene le seguenti informazioni:

  • Riepilogo Informazioni riassuntive sull'analisi.

  • Errori Eventuali errori rilevati durante l'analisi. È necessario correggere tutti gli errori elencati.

  • Avvisi Eventuali avvisi rilevati durante l'analisi. Gli avvisi richiedono l'intervento dell'utente, ma non devono essere per forza corretti.

  • Output Questa sezione elenca i file di output generati.

File di log

Il convertitore genera il file di log CQConverter.log che viene utilizzato per il debug e in genere non è necessario esaminarlo. Il file di log viene creato nella cartella in cui è stato eseguito CQConverter. Questo file contiene i messaggi di analisi e può essere utile per il debug di problemi rilevati durante l'esecuzione del convertitore.

Il livello di analisi viene controllato mediante l'impostazione del valore dell'attributo MinLevelForAllSource nel file CQConverter.exe.config, che si trova nella stessa cartella di CQConverter.exe. È possibile impostare un valore compreso tra 1, livello di analisi minimo, e 4, livello di analisi massimo.

Nota Nota

Si tenga presente che le prestazioni del convertitore sono più lente a livelli di analisi superiori e il file di log può diventare molto grande.

File degli errori

Il convertitore genera inoltre un file contenente tutti gli errori rilevati durante l'esecuzione del convertitore. A questo file viene assegnato il nome ConverterErrors.txt e viene generato nella stessa cartella in cui è stato eseguito CQConverter.

Vedere anche

Attività

Procedura: modificare il file di mappa dello schema

Riferimenti

Schema del file di mapping utenti

Concetti

File di configurazione del convertitore degli elementi di lavoro

Altre risorse

Amministrazione dei tipi di elemento di lavoro
Definizione del flusso di lavoro degli elementi di lavoro
Definizione del form elemento di lavoro


Procedura: eseguire le migrazione di elementi di lavoro

Procedura: eseguire le migrazione di elementi di lavoro

Dopo la fase di analisi il convertitore genera definizioni di tipi di elemento di lavoro per ciascun tipo di record di ClearQuest. Ad esempio, il file per il tipo di record di difetto di ClearQuest è Defect.xml. Il convertitore genera un form dell'elemento di lavoro predefinito come parte della generazione dello schema durante l'analisi. Tuttavia questo form predefinito contiene una formattazione semplice ed è probabile che richieda modifiche per migliorarne l'usabilità. Per informazioni sulla modifica del file di definizione del tipo di elemento di lavoro, vedere Personalizzazione dei tipi di elemento di lavoro su Team Foundation Server.

Dopo avere modificato il layout dell'elemento di lavoro, è possibile eseguire la migrazione degli elementi di lavoro da ClearQuest a Gestione elementi di lavoro Team Foundation.

Migrazione degli elementi di lavoro di ClearQuest

Per eseguire la migrazione degli elementi di lavoro

  1. Al prompt dei comandi, eseguire il comando seguente:

    CQConverter.exe /c:migrate /m:CqConverterConfig.xml /s: path \Schemamap.xml

    Dove path è il nome della directory di output specificato nel file CQConverterConfig.xml.

    Nota Nota

    Il convertitore di ClearQuest può richiedere ore per completare l'esecuzione di database di grandi dimensioni.

    Nota Nota

    Per ulteriori informazioni sui comandi del convertitore di ClearQuest, vedere Riferimenti alla riga di comando per la migrazione degli elementi di lavoro.

  2. Al termine della migrazione esaminare il report corrispondente per verificare lo stato della migrazione e l'eventuale presenza di problemi, quali la mancata migrazione di difetti dovuta ad incoerenze nel mapping campi.

    Il file del report di migrazione CQMigrationReport.xml viene creato nella cartella da cui è stato eseguito il convertitore di ClearQuest.

    Nota Nota

    Poiché il convertitore converte tutti gli elementi di lavoro inclusi nella query specificata, nonché tutti gli elementi di lavoro collegati ad essi, il numero effettivo di elementi di lavoro di cui viene eseguita la migrazione può differire dal numero di elementi di lavoro presenti nella query.

  3. Se non si è eseguita la migrazione di tutti gli elementi di lavoro, è possibile eseguire di nuovo la conversione dopo avere risolto i problemi specificati nel report di migrazione.

Per eseguire la migrazione di più elementi di lavoro da ClearQuest a Gestione elementi di lavoro Team Foundation, è possibile eseguire di nuovo il processo di migrazione.

Per eseguire di nuovo la migrazione sullo stesso database di ClearQuest

  1. Risolvere i problemi riportati nel report della migrazione precedente.

  2. Eseguire una query in ClearQuest che restituisca gli elementi di lavoro desiderati. In alternativa eseguire la stessa query solo se è necessario eseguire la migrazione degli elementi di lavoro la cui migrazione non è riuscita la prima volta.

  3. Modificare la sezione <NomeQuery> nel file di configurazione per specificare il nome della nuova query.

  4. Aprire il prompt dei comandi, quindi digitare il comando di migrazione:

    CQConverter.exe /c:migrate /m:CqConverterConfig.xml /s: path \Schemamap.xml

    Il convertitore di ClearQuest può richiedere ore per completare l'esecuzione di database di grandi dimensioni.

    Nota Nota

    Per ulteriori informazioni sui comandi del convertitore di ClearQuest, vedere Riferimenti alla riga di comando per la migrazione degli elementi di lavoro.

  5. Al termine della migrazione esaminare il report di migrazione e verificare lo stato. Il file del report di migrazione CQMigrationReport.xml viene creato nella cartella da cui è stato eseguito il convertitore di ClearQuest.

Protezione

È necessario appartenere al gruppo Services Accounts di Team Foundation e disporre delle autorizzazioni sufficienti in ClearQuest per potere creare elementi di lavoro di tutti i tipi.

Vedere anche

Attività

Procedura dettagliata: migrazione di elementi di lavoro ClearQuest a Team Foundation

Altre risorse

Operazioni da effettuare una volta eseguita la migrazione degli elementi di lavoro


Procedura: eseguire la migrazione di elementi di lavoro a un database esistente in Team Foundation

Procedura: eseguire la migrazione di elementi di lavoro a un database esistente in Team Foundation
Vedere anche

Il convertitore consente di eseguire il mapping campi dal sistema di gestione degli elementi di lavoro di origine a Gestione elementi di lavoro Team Foundation mediante i file di mapping campi e utenti.

Per eseguire la migrazione dei dati in un tipo di elemento di lavoro esistente in Team Foundation

  1. Eseguire il convertitore con il comando di analisi per generare i file di mapping e di mappa dello schema. In questa fase vengono generati tutti i file di definizione dei tipi di elemento di lavoro (WITD), il file di mappa dello schema, i file di mapping campi e il file di mapping utenti.

    CQConverter.exe /c:analyze /m:cqconverterconfig.xml

    Nota Nota

    I file WITD generati catturano lo schema dei tipi di elemento di lavoro dal database ClearQuest. Poiché si esegue la migrazione a tipi di elemento di lavoro esistenti, non si utilizzano i file WITD generati durante la migrazione. Non eliminarli però, perché sono necessari in un secondo momento per completare questa procedura.

  2. Modificare il file di mappa dello schema per specificare i tipi di elemento di lavoro di destinazione per i tipi di elemento di lavoro di cui si desidera eseguire la migrazione.

  3. Se si esegue la migrazione a tipi di elemento di lavoro già presenti in Gestione elementi di lavoro Team Foundation, lasciare l'attributo del file WITDFile invariato. Il convertitore non fornisce il tipo di elemento di lavoro se l'elemento è già presente in Gestione elementi di lavoro Team Foundation.

    Se si esegue la migrazione a tipi di elemento di lavoro che non sono stati creati in Gestione elementi di lavoro Team Foundation, ma sono stati già creati i file WITD, modificare l'attributo del file WITDFile in modo che faccia riferimento a questi file. Accertarsi di specificare il percorso completo dei file. Il convertitore fornirà quindi i tipi di elemento di lavoro specificati nei file WITD durante la fase di migrazione.

  4. Modificare i file di mapping campi per specificare i mapping campi ai tipi di elemento di lavoro di Gestione elementi di lavoro Team Foundation. I file di mapping campi generati contengono i nomi dei campi contenuti negli schemi generati dal convertitore. Poiché per i mapping campi si utilizza un tipo di elemento di lavoro personalizzato, è necessario fornire i mapping ai campi degli elementi di lavoro di Gestione elementi di lavoro Team Foundation. Per la descrizione dei file di mapping campi, vedere File di mapping campi, mappa di valori e valori predefiniti.

    Se non si desidera eseguire la migrazione di alcuni campi, è possibile eliminare senza problemi i rispettivi mapping.

  5. Modificare il file di mapping utenti, se necessario, come descritto in Procedura: modificare il file di mapping utenti.

  6. Eseguire il convertitore con il comando di migrazione per eseguire la migrazione dei dati.

Protezione

È necessario appartenere al gruppo Administrators di Team Foundation in Team Foundation per potere completare questa procedura.

Vedere anche

Attività

Procedura: eseguire le migrazione di elementi di lavoro
Procedura: modificare il file di mapping utenti

Altre risorse

File di mapping campi, mappa di valori e valori predefiniti


Operazioni da effettuare una volta eseguita la migrazione degli elementi di lavoro

 elenco a discesa elenco a discesa attivabile
Operazioni da effettuare una volta eseguita la migrazione degli elementi di lavoro
Vedere anche
elenco a discesa

Una volta eseguita la migrazione di elementi di lavoro, è consigliabile verificare la riuscita dell'operazione prima di iniziare a utilizzarli. Se durante la migrazione si verificano degli errori problemi, è anche possibile cercare di individuare i problemi e quindi ripetere la migrazione o apportare correzioni agli elementi di lavoro di cui è stata eseguita la migrazione.

In questa sezione

Procedura: verificare la corretta migrazione degli elementi di lavoro

Vengono fornite informazioni su come verificare la correttezza della migrazione degli elementi di lavoro da ClearQuest a Gestione elementi di lavoro Team Foundation.

Utilizzo di elementi di lavoro migrati

Vengono riportate informazioni e collegamenti sull'utilizzo degli elementi di lavoro di cui è stata eseguita la migrazione, compresi collegamenti ad argomenti introduttivi sull'utilizzo di Gestione elementi di lavoro Team Foundation.

Vedere anche

Concetti

Esecuzione di query per elementi di lavoro

Altre risorse

Guida introduttiva a Team Foundation
Procedure dettagliate relative alla gestione degli elementi di lavoro di Team Foundation
Aggiunta e modifica di elementi di lavoro


Procedura: verificare la corretta migrazione degli elementi di lavoro

Procedura: verificare la corretta migrazione degli elementi di lavoro
Vedere anche

Al termine della migrazione è possibile esaminare alcuni degli elementi di lavoro sottoposti a migrazione per verificare se la migrazione delle informazioni è stata eseguita correttamente.

Per verificare gli elementi di lavoro sottoposti a migrazione

  1. Aprire un elemento di lavoro migrato in Gestione elementi di lavoro Team Foundation.

  2. Esaminare il numero nel campo dell'ID ClearQuest e confrontare l'elemento di lavoro di Gestione elementi di lavoro Team Foundation con il bug di ClearQuest corrispondente all'ID.

Per trovare l'elemento di lavoro di Team Foundation corrispondente a un elemento di lavoro di ClearQuest specifico

  1. Creare una query elemento di lavoro con la seguente clausola di query:

    And/Or Campo Operatore Valore

    VSTS SourceID

    =

    ClearQuest work item ID

    Il campo VSTS SourceID corrisponde all'etichetta del campo dell'ID di ClearQuest visualizzato nel form dell'elemento di lavoro.

    Per ulteriori informazioni sulla creazione di query di elementi di lavoro, vedere Procedura: aggiungere nuove query elemento di lavoro.

  2. Eseguire la query.

Vedere anche

Attività

Procedura: aggiungere nuove query elemento di lavoro
Procedura dettagliata: migrazione di elementi di lavoro ClearQuest a Team Foundation
Procedura dettagliata: gestione elementi di lavoro


Utilizzo di elementi di lavoro migrati

 elenco a discesa elenco a discesa attivabile
Utilizzo di elementi di lavoro migrati
Vedere anche
elenco a discesa

Una volta eseguita la migrazione di elementi di lavoro, è possibile iniziare a utilizzarli in Gestione elementi di lavoro Team Foundation. Per informazioni introduttive su Team Foundation, vedere Guida introduttiva a Team Foundation e Procedure dettagliate relative alla gestione degli elementi di lavoro di Team Foundation. Per informazioni sull'utilizzo di elementi di lavoro, vedere gli argomenti elencati di seguito.

  • Per trovare elementi di lavoro di cui è stata eseguita la migrazione, vedere Esecuzione di query per elementi di lavoro.

  • È possibile che occorra modificare alcune degli elementi di lavoro di cui è stata eseguita la migrazione. Per ulteriori informazioni sulla modifica di elementi di lavoro, vedere Aggiunta e modifica di elementi di lavoro.

  • Per informazioni su come modificare rapidamente più elementi di lavoro, vedere Procedura: modificare più elementi di lavoro in Microsoft Excel.

Vedere anche

Concetti

Esecuzione di query per elementi di lavoro

Altre risorse

Guida introduttiva a Team Foundation
Procedure dettagliate relative alla gestione degli elementi di lavoro di Team Foundation
Aggiunta e modifica di elementi di lavoro


Riferimenti alla riga di comando per la migrazione degli elementi di lavoro

 elenco a discesa elenco a discesa attivabile
Riferimenti alla riga di comando per la migrazione degli elementi di lavoro
Vedere anche
comprimi tutto elenco a discesa

Il comando CQConverter viene utilizzato per convertire i database di ClearQuest in modo che possano essere utilizzati con la gestione degli elementi di lavoro di Team Foundation.

espandi Sintassi

CQConverter [/?] {/c[ommand]:Analyze|Migrate} < cqconverterconfig.xml > /s[chema]: < schemamap.xml /m[igration settings]: <migration settings>

/c[ommand]: analyze < cqconverterconfig.xml >

Analizza il database di ClearQuest come configurato in cqconverterconfig.xml.

/c[ommand]: migrate < cqconverterconfig.xml >

Esegue la migrazione del database di ClearQuest come configurato in cqconverterconfig.xml.

/s[chema]: < schemamap.xml >

File XML di mappa dello schema di migrazione.

/m[igration settings]: < migration settings >

File XML di impostazioni di migrazione.

/?, /h, /help

Visualizza la Guida in linea.

espandi Esempi

In questo esempio il convertitore esegue un'analisi in base ai parametri di configurazione definiti nel file cqconverterconfig.xml.

Immagine CopyCode Copia codice
        CQConverter /c:analyze /m:
        cqconverterconfig.xml

In questo esempio il convertitore esegue una migrazione in base ai parametri di configurazione definiti nel file cqconverterconfig.xml e il mapping definito nel file schemamap.xml.

Immagine CopyCode Copia codice
        CQConverter /c:migrate /m:
        cqconverterconfig.xml /s:schemamap.xml

espandi Note

I parametri di configurazione di CQConverter sono configurati in un file XML di configurazione. Specificare questo file nella riga di comando mediante l'opzione della riga di comando /m: o /migrationsettings: in forma espansa, ad esempio: /m:cqconverterconfig.xml

Nota Nota

Per la connessione alla gestione degli elementi di lavoro di Team Foundation o a ClearQuest il convertitore richiede l'immissione di una password. Il convertitore si connette quindi a Team Foundation utilizzando le credenziali di accesso.

espandi Vedere anche

Attività

Procedura dettagliata: migrazione di elementi di lavoro ClearQuest a Team Foundation

piè di pagina


Amministrazione di Team Foundation Server

 elenco a discesa elenco a discesa attivabile
Amministrazione di Team Foundation Server
Vedere anche
elenco a discesa

L'amministrazione di Team Foundation richiede la gestione di utenti e gruppi, la configurazione di applicazioni server e client e la comprensione sia dello sviluppo software che della distribuzione dei componenti di Visual Studio Team System.

Nota Nota

La versione più aggiornata della Guida dell'amministratore di Team Foundation è disponibile sul Web sul sito MSDN Online (http://go.microsoft.com/fwlink/?linkid=52459).

Per informazioni sull'installazione di Team Foundation, vedere la guida all'installazione di Team Foundation. La versione più aggiornata della guida all'installazione di Team Foundation è disponibile sul Web sul sito MSDN Online (http://go.microsoft.com/fwlink/?linkid=40042).

In questa sezione

Amministrazione di Team Foundation Server

Vengono introdotti i concetti chiave e vengono forniti collegamenti ad altre informazioni su Team Foundation Server, ad esempio la documentazione relativa alla pianificazione e all'installazione.

Gestione di Team Foundation Server

Vengono fornite informazioni concettuali e linee guida procedurali sulla gestione di Team Foundation Server, tra cui la gestione di utenti, gruppi e autorizzazioni.

Monitoraggio di Team Foundation Server

Vengono fornite informazioni concettuali e linee guida procedurali sul monitoraggio di Team Foundation Server, tra cui le prestazioni.

Protezione di Team Foundation Server

Vengono fornite informazioni introduttive concettuali sull'architettura e sulla protezione di Team Foundation Server, nonché linee guida per la protezione di utenti, gruppi e servizi.

Utilizzo degli strumenti della riga di comando di Team Foundation Server

Vengono descritti tutti gli strumenti della riga di comando per Team Foundation Server e fornite linee guida per l'utilizzo di tali strumenti.

Vedere anche

Altre risorse

Pianificazione di Team Foundation Server
Procedure dettagliate relative all'amministrazione di Team Foundation Server


Amministrazione di Team Foundation Server

 elenco a discesa elenco a discesa attivabile
Amministrazione di Team Foundation Server
Vedere anche
elenco a discesa

L'amministrazione efficiente di Team Foundation Server è fondamentale per il successo dei progetti Team. Le attività amministrative di Team Foundation Server dipendono dalle funzioni di gestione dei progetti richieste dall'organizzazione. Per amministrare Team Foundation Server, è necessario comprendere i concetti di utenti, gruppi, ereditarietà e autorizzazioni di protezione e portali di progetto di Team Foundation Server. In genere gli amministratori di server esperti hanno gia familiarità con gli altri aspetti dell'amministrazione di Team Foundation Server, quali configurazione, monitoraggio e manutenzione quotidiani e preparazione del ripristino di emergenza.

Prima di potere iniziare ad amministrare Team Foundation Server, è necessario pianificare e installare Team Foundation Server.

Nota Nota

È possibile scaricare la versione più aggiornata della guida dell'amministratore di Team Foundation dal sito Web Microsoft (http://go.microsoft.com/fwlink/?linkid=52459).

In questa sezione

Cenni preliminari sulla pianificazione per Team Foundation Server

Vengono introdotti i concetti chiave e viene fornito un collegamento alla documentazione di pianificazione di Team Foundation Server.

Cenni preliminari sull'installazione per Team Foundation Server

Vengono introdotti i concetti chiave e viene fornito un collegamento alla documentazione di installazione di Team Foundation Server.

Pianificazione e preparazione per Team Foundation

Vengono fornite linee guida concettuali per la pianificazione di Team Foundation.

Requisiti di Visual Studio 2005 Team System

Vengono descritti i requisiti hardware e software per Visual Studio Team System.

Riferimento

Pianificazione di Team Foundation Server

Vedere anche

Altre risorse

Procedure dettagliate relative all'amministrazione di Team Foundation Server
Team Foundation - Documentazione


Cenni preliminari sulla pianificazione per Team Foundation Server

 elenco a discesa elenco a discesa attivabile
Cenni preliminari sulla pianificazione per Team Foundation Server
Vedere anche
elenco a discesa

Nella guida alla pianificazione di Team Foundation Server vengono fornite le informazioni necessarie agli amministratori e ai responsabili delle decisioni aziendali per la pianificazione dei requisiti hardware, dei requisiti software, delle topologie di distribuzione, della scelta di un modello di processo e dell'intergrazione con altro software di Team Foundation Server. In questa guida non vengono trattati in modo specifico i dettagli di funzionamento del prodotto, ma viene fornita una struttura di pianificazione che consente di determinare come integrare Team Foundation Server all'interno dell'azienda.

Download dell'ultima versione

La guida alla pianificazione di Team Foundation Server è disponibile nel sistema della guida in linea di Visual Studio 2005. È possibile scaricare la versione più aggiornata della guida alla pianificazione di Team Foundation dall'Area download Microsoft all'indirizzo http://go.microsoft.com/fwlink/?linkid=55995 http://go.microsoft.com/fwlink/?linkid=55995.

Vedere anche

Concetti

Pianificazione e preparazione per Team Foundation


Cenni preliminari sull'installazione per Team Foundation Server

 elenco a discesa elenco a discesa attivabile
Cenni preliminari sull'installazione per Team Foundation Server
Vedere anche
elenco a discesa

Nella guida all'installazione di Team Foundation Server vengono fornite le informazioni necessarie agli amministratori per installare Team Foundation Server, incluse procedure di installazione e configurazione specifiche per ambienti a server singolo o doppio Team Foundation Server.

Download dell'ultima versione

Se si è installato Team Foundation Server, la guida all'installazione di Team Foundation Server è disponibile sul disco rigido (TFSInstall.chm). È possibile scaricare l'ultima versione della guida all'installazione di Team Foundation nell'Area download Microsoft all'indirizzo http://go.microsoft.com/fwlink/?linkid=40042.

Vedere anche

Concetti

Cenni preliminari sulla pianificazione per Team Foundation Server
Pianificazione e preparazione per Team Foundation

Altre risorse

Team Foundation - Documentazione


Pianificazione e preparazione per Team Foundation

 elenco a discesa elenco a discesa attivabile
Pianificazione e preparazione per Team Foundation
Vedere anche
elenco a discesa

La pianificazione di Team Foundation richiede un'attenta considerazione delle esigenze di sviluppo. In base a tali esigenze è possibile selezionare le funzioni di Visual Studio Team System più adatte all'ambiente di sviluppo. Assicurarsi di disporre dell'hardware e del software necessari, quindi preparare l'installazione.

Pianificazione per Team Foundation Server

Il server Visual Studio Team System primario è Team Foundation Server, che fornisce il controllo della versione, la gestione degli elementi di lavoro, Team Foundation Build, il sito Web del progetto Team, la creazione di report e le funzioni di gestione del progetto. Gli altri server Visual Studio Team System includono i server di generazione e di test. In base alle esigenze aziendali è possibile distribuire alcuni o tutti i server. È necessario valutare attentamente le funzioni e i requisiti hardware e software dei server Visual Studio Team System come parte della pianificazione per Visual Studio Team System.

Pianificazione per i client Team Foundation

Visual Studio Team System comprende quattro applicazioni client primarie: Visual Studio Team Edition for Architects, Visual Studio Team Edition for Developers, Visual Studio Team Edition for Testers e Visual Studio 2005 Team Suite, che include le funzionalità di tutte le versioni basate sui ruoli.

Se utilizzati con i server Visual Studio Team System, queste applicazioni client forniscono interfacce utente Visual Studio aggiuntive per funzionalità quali il controllo della versione, la gestione degli elementi di lavoro, i siti Web di Team Foundation, la creazione di report, le linee guida per il processo, la gestione della generazione e l'esecuzione di test.

Diagramma di esempio per client e server Team Foundation

Di seguito è riportato il diagramma di un esempio di distribuzione di client e server Team Foundation.

Client e server Team Foundation

Vedere anche

Concetti

Linee guida per il processo di Team Foundation

Altre risorse

Pianificazione di client e server
Team Foundation - Documentazione


Requisiti di Visual Studio 2005 Team System

 elenco a discesa elenco a discesa attivabile
Requisiti di Visual Studio 2005 Team System
Vedere anche
elenco a discesa

Una distribuzione corretta di Visual Studio Team System include la distribuzione dell'hardware e del software necessari per l'esecuzione di Visual Studio Team System. Nella seguente sezione vengono presentati i requisiti hardware e software dei componenti di Visual Studio Team System.

In questa sezione

Requisiti di Team Build per Team System

Vengono descritti i requisiti hardware e software per Team Foundation Build.

Requisiti di rig di test per Team System

Vengono descritti i requisiti hardware e software per Team Edition for Testers.

Requisiti del server per Team System

Vengono descritti i requisiti hardware e software per Team Foundation Server.

Requisiti client per Team System

Vengono descritti i requisiti hardware e software per i client Team Foundation e Team Explorer.

Riferimenti

Pianificazione di Team Foundation Server

Sezioni correlate

Amministrazione del controllo del codice sorgente di Team Foundation

Amministrazione di Team Foundation Build

Vedere anche

Concetti

Topologie supportate per Team Foundation Server

Altre risorse

Team Foundation - Documentazione


Requisiti di Team Build per Team System

 elenco a discesa elenco a discesa attivabile
Requisiti di Team Build per Team System
Vedere anche
elenco a discesa

Per sfruttare la funzionalità Team Foundation Build, è possibile designare uno o più computer nell'ambiente Visual Studio Team System come server di generazione. Team Foundation Build presenta requisiti hardware e software specifici. Per la pianificazione della distribuzione di server Team Foundation Build è importante comprendere i requisiti determinati dalle esigenze aziendali.

Requisiti hardware e software

Team Foundation Build fornisce la funzionalità di un ambiente di lavoro pubblico per la generazione. Team Foundation Build consente ai gestori delle generazioni in ambito aziendale di sincronizzare le origini, generare l'applicazione, eseguire unit test associati alla generazione, effettuare l'analisi codice, rilasciare generazioni su un file server e pubblicare report di generazione. I dati dei risultati della generazione vengono trasmessi al data warehouse per la creazione di report cronologici. Team Foundation Build collabora con altri strumenti di Visual Studio Team System durante il processo di generazione, tra cui il controllo del codice sorgente e la gestione degli elementi di lavoro. Nelle sezioni precedenti è stata elencata una gamma di requisiti del server consigliati. Nonostante ciò, se si desidera eseguire la distribuzione in più lingue, è necessario pianificarla in base alle lingue che si desidera supportare nella distribuzione.

Requisiti hardware

Nella seguente tabella sono riportati i requisiti hardware consigliati per la distribuzione di Team Foundation Build, a seconda del numero di utenti e di file generati.

Configurazione | Tempo di generazione | CPU | Disco rigido | Memoria
Minima, 1-2 progetti, 5-20 utenti | 30 minuti | Processore singolo, 766 MHz | 8 GB | 256 MB
Piccola, 2-20 progetti, 20-100 utenti | Da 30 minuti a 2 ore | Processore singolo, 1,5 GHz | 30 GB | 512 MB
Media, più di 20 progetti, 100-250 utenti | Da 2 a 5 ore | Processore singolo, 2,6 GHz | 50 GB | 1 GB
Grande, più di 50 progetti, 250-500 utenti | Da 3 a 7 ore | Due processori, 2,8 GHz | 80 GB | 2 GB

Le indicazioni riportate qui vengono fornite a titolo generale per la pianificazione hardware. Le prestazioni di generazione variano notevolmente a seconda della quantità di codice sorgente su un dato server, nonché della complessità del processo di generazione.

Il server su cui è eseguito Team Foundation Build deve disporre di una connessione di rete affidabile con una larghezza di banda minima di 1 Mbps e una latenza massima di 350 ms. Tra il server Team Foundation Build e i server Team Foundation Server non devono essere presenti un firewall. Se le prestazioni di generazione non soddisfano le aspettative, si consiglia di aggiornare la configurazione hardware.

Considerazioni sull'hardware aggiuntivo

Oltre ai requisiti hardware consigliati, prendere in considerazione la possibilità di impiegare hardware aggiuntivo per i server di importanza strategica, ad esempio alimentatori e ventole ridondanti.

Non utilizzare Team Foundation Server come server di generazione. Le generazioni devono essere eseguite su computer distinti. A causa del carico elevato a cui vengono sottoposti i server durante la generazione, l'esecuzione di generazioni su un server Team Foundation potrebbe rendere il server non disponibile e comprometterne le prestazioni.

Requisiti software

Nella seguente tabella sono riportati i requisiti software per i server Team Foundation Build.

Software | Versione
Microsoft Windows Server 2003 con SP1 o Windows XP Professional | Tutte le edizioni e le versioni
.NET Framework | 2.0

Oltre al software necessario, considerare la possibilità di installare software di gestione o di protezione aggiuntivo, ad esempio software di backup o firewall.

Requisiti delle lingue

Per evitare confusione e semplificare il funzionamento, configurare una distribuzione di Team Foundation Build in modo che utilizzi la stessa lingua del sistema operativo del computer di destinazione e di Team Foundation Server. È possibile, tuttavia, installare una versione di Team Foundation Build in un'altra lingua su un server in lingua inglese, a condizione che la lingua corrisponda a quella della distribuzione di Team Foundation Server.

Vedere anche

Concetti

Requisiti del server per Team System
Requisiti di rig di test per Team System
Requisiti client per Team System

Altre risorse

Requisiti di Visual Studio 2005 Team System
Pianificazione di client e server


Requisiti di rig di test per Team System

 elenco a discesa elenco a discesa attivabile
Requisiti di rig di test per Team System
Vedere anche
elenco a discesa

Molti tipi di test, tra cui unit test, test Web, di carico e manuali, oltre alle misurazioni del code coverage, sono integrati in Visual Studio. Team Edition for Testers consente agli utenti di Visual Studio Team System di eseguire test su computer remoti, detti rig. I rig Team Edition for Testers presentano requisiti hardware e software specifici. Per la pianificazione della distribuzione di rig di test è importante comprendere i requisiti determinati dalle esigenze aziendali.

Requisiti hardware e software

Team Edition for Testers consente di creare, gestire, modificare ed eseguire test, nonché di ottenere e memorizzare i risultati dei test. Un rig di test comprende un controller di test e uno o più agenti. Il controller di test e l'agente possono essere installati sullo stesso computer o su due computer diversi. Un controller di test può coordinare l'esecuzione di diversi test eseguiti su computer su cui è installato l'agente di test. Sia il controller di test che i computer dell'agente di test presentano requisiti hardware e software specifici. Inoltre, se si desidera distribuire un rig di test in più lingue, è necessario pianificare il supporto di queste lingue.

Requisiti hardware

Nella seguente tabella sono riportati i requisiti hardware consigliati per la distribuzione di rig di test per Team Edition for Testers.

Configurazione | Componente | CPU | Disco rigido | Memoria
Minima, 1-2 progetti, 5-20 utenti | Agente di test | Processore singolo, 600 MHz | 1 GB | 256 MB
Minima, 1-2 progetti, 5-20 utenti | Controller di test | Processore singolo, 600 MHz | 1 GB | 256 MB
Minima, 1-2 progetti, 5-20 utenti | Entrambi | Processore singolo, 600 MHz | 1 GB | 512 MB
Piccola, 2-20 progetti, 20-100 utenti | Agente di test | Processore singolo, 2,0 GHz | 5 GB | 512 MB
Piccola, 2-20 progetti, 20-100 utenti | Controller di test | Processore singolo, 1,0 GHz | 8 GB | 512 MB
Piccola, 2-20 progetti, 20-100 utenti | Entrambi | Processore singolo, 2,0 GHz | 8 GB | 1 GB
Media, più di 20 progetti, 100-250 utenti | Agente di test | Processore singolo, 2,6 GHz | 5 GB | 2 GB
Media, più di 20 progetti, 100-250 utenti | Controller di test | Processore singolo, 2,0 GHz | 40 GB | 1 GB
Media, più di 20 progetti, 100-250 utenti | Entrambi | Processore singolo, 2,6 GHz | 40 GB | 2 GB
Grande, più di 50 progetti, 250-500 utenti | Agente di test | Due processori, 2,8 GHz | 8 GB | 2 GB
Grande, più di 50 progetti, 250-500 utenti | Controller di test | Processore singolo, 2,6 GHz | 48 GB | 1 GB
Grande, più di 50 progetti, 250-500 utenti | Entrambi | Due processori, 2,8 GHz | 48 GB | 2 GB

Le indicazioni riportate qui vengono fornite a titolo generale per la pianificazione hardware. Le prestazioni del test variano notevolmente a seconda della quantità di dati di test e del numero di agenti di test. Per gli agenti di test la velocità della CPU e la memoria disponibili limitano il carico di test. I controller di test necessitano di risorse maggiori a seconda del numero di agenti di test e della quantità di dati coinvolti nei test.

Il server su cui è eseguito Team Edition for Testers deve disporre di una connessione di rete affidabile con una larghezza di banda minima di 1 Mbps e una latenza massima di 350 ms. Tra gli agenti di test e il controller di test non devono essere presenti firewall. Se le prestazioni del test non soddisfano le aspettative, si consiglia di aggiornare la configurazione hardware.

Considerazioni sull'hardware aggiuntivo

I rig di test generano una quantità notevole di dati sui controller di test, a seconda della durata e della dimensione del test. In genere è necessario pianificare altri 10 GB di spazio di memorizzazione sul disco rigido per ogni 24 ore di dati di test.

Oltre ai requisiti hardware consigliati, prendere in considerazione la possibilità di impiegare hardware aggiuntivo per i server importanti, ad esempio alimentatori e ventole ridondanti.

Requisiti software

Nella seguente tabella sono riportati i requisiti software per gli agenti di test.

Software | Versione
Microsoft Windows Server 2003 con Service Pack 1, Windows XP Professional con Service Pack 2 o Windows 2000 con Service Pack 4 | Tutte le edizioni e le versioni
SQL Express | 2005
.NET Framework | 2.0

Nella seguente tabella sono riportati i requisiti software per i controller di test.

Software | Versione
Microsoft Windows Server 2003 con SP1 | Tutte le edizioni e le versioni
SQL Express | 2005
.NET Framework | 2.0

Oltre ai requisiti software elencati, considerare la possibilità di installare software di gestione o protezione aggiuntivo, ad esempio software di backup o firewall.

Requisiti delle lingue

Per evitare confusione e semplificare il funzionamento, configurare un rig di test in modo che utilizzi la stessa lingua del sistema operativo del computer e quella di Team Foundation Server. Se l'agente di test e il controller di test sono installati su computer diversi, devono essere configurati per utilizzare la stessa lingua. È possibile, tuttavia, installare una versione di Team Edition for Testers in un'altra lingua su un sistema operativo in lingua inglese, a condizione che la lingua corrisponda a quella della distribuzione di Team Foundation Server.

Vedere anche

Concetti

Requisiti del server per Team System
Requisiti di Team Build per Team System
Requisiti client per Team System

Altre risorse

Requisiti di Visual Studio 2005 Team System
Pianificazione di client e server


Requisiti del server per Team System

 elenco a discesa elenco a discesa attivabile
Requisiti del server per Team System
Vedere anche
elenco a discesa

Team Foundation Server presenta requisiti hardware e software specifici. Inoltre i requisiti hardware possono variare a seconda del tipo di distribuzione e utilizzo di Visual Studio Team System. Per la pianificazione della distribuzione di Team Foundation Server è importante comprendere i requisiti determinati dalle esigenze aziendali.

Requisiti hardware e software

Un server Team Foundation Server logico è costituito da due componenti: un server a livello applicazione, costituito principalmente da servizi Web, e un server a livello dati, costituito principalmente da un database SQL Server 2005. La scelta di distribuire i server a livello applicazione e dati su uno o due server influisce sulla pianificazione dei requisiti del server. Più avanti in questo argomento vengono elencati i requisiti del server sia minimi che consigliati. Nonostante quanto detto sopra, se si desidera eseguire la distribuzione in più lingue, è necessario pianificare le lingue che si desidera supportare nella distribuzione.

Requisiti hardware

Nella seguente tabella sono riportati i requisiti hardware consigliati per la distribuzione di Team Foundation Server su un singolo server e i requisiti consigliati per la distribuzione di Team Foundation Server su due server, in base al numero di utenti.

Configurazione | Livelli | CPU | Disco rigido | Memoria
Un server, meno di 20 utenti. | Server a livello applicazione e dati | Processore singolo, 2,2 GHz | 8 GB | 1 GB
Un server, 20-100 utenti. | Server a livello applicazione e dati | Due processori, 2,2 GHz | 30 GB | 2 GB
Due server, 100-250 utenti. | Server a livello applicazione | Processore singolo, 2,2 GHz | 20 GB | 1 GB
Due server, 100-250 utenti. | Server a livello dati | Due processori, 2,2 GHz | 80 GB | 2 GB
Due server, 250-500 utenti. | Server a livello applicazione | Due processori, 2,2 GHz | 40 GB | 2 GB
Due server, 250-500 utenti. | Server a livello dati | Quattro processori, 2,2 GHz | 150 GB | 4 GB

Le linee guida fornite sono adatte per la maggior parte delle distribuzioni. in ambienti con meno di 500 utenti che utilizzano un singolo server Team Foundation Server. Il server su cui è eseguito Team Foundation Server deve disporre di una connessione di rete affidabile con una larghezza di banda minima di 1 Mbps e una latenza massima di 350 ms.

Se l'ambiente non soddisfa questi criteri, si consiglia di valutare attentamente le implicazioni prima di distribuire Team Foundation Server. Considerare, ad esempio, la possibilità di utilizzare hardware con requisiti migliori di quelli consigliati, un'affidabilità di rete e una larghezza di banda superiori e l'uso di più server con Team Foundation Server.

Hardware aggiuntivo

Oltre ai requisiti hardware consigliati, prendere in considerazione la possibilità di impiegare hardware aggiuntivo per i server importanti, ad esempio alimentatori e ventole ridondanti.

Requisiti software

I requisiti software di Team Foundation Server sono riportati nella guida all'installazione di Team Foundation Server. È possibile scaricare la versione più aggiornata della guida all'installazione di Team Foundation dal sito Web Microsoft (http://go.microsoft.com/fwlink/?linkid=40042).

Oltre ai requisiti software elencati nella guida all'installazione, considerare la possibilità di installare software di gestione o protezione aggiuntivo, ad esempio software di backup o firewall.

Requisiti delle lingue

È possibile configurare una distribuzione di Team Foundation Server logica, su uno o due server, per il supporto di una sola lingua. Se Team Foundation Server è distribuito su due server, l'impostazione della lingua di Team Foundation Server e del sistema operativo deve essere uguale su entrambi i server. L'unica eccezione è rappresentata dalle versioni in inglese di Windows Server 2003. È infatti possibile installare una versione di Team Foundation Server in un'altra lingua su un server in lingua inglese.

Ad esempio, è possibile installare Team Foundation Server in inglese su un sistema operativo in inglese o giapponese. Una versione di Team Foundation Server localizzata deve essere installata su un sistema operativo nella stessa lingua o in inglese. Se si distribuisce Team Foundation Server in giapponese, questo può essere installato su una versione giapponese o inglese del sistema operativo.

È inoltre necessario installare il Language Pack di Windows SharePoint Services corrispondente alla lingua di Team Foundation Server. Ad esempio, se si distribuisce la versione inglese di Team Foundation Server su un sistema operativo localizzato in un'altra lingua, è necessario installare il Language Pack inglese per Windows SharePoint Services. Se si distribuisce Team Foundation Server in giapponese su un sistema operativo in inglese, è necessario installare il Language Pack giapponese di Windows SharePoint Services.

Vedere anche

Concetti

Requisiti di Team Build per Team System
Requisiti di rig di test per Team System
Requisiti client per Team System

Altre risorse

Requisiti di Visual Studio 2005 Team System
Pianificazione di client e server


Requisiti client per Team System

 elenco a discesa elenco a discesa attivabile
Requisiti client per Team System
Vedere anche
elenco a discesa

Allo stesso modo di Team Foundation Server, i client Team Foundation presentano requisiti hardware e software specifici. Per la pianificazione della distribuzione di Visual Studio Team System è importante comprendere i requisiti determinati dalle esigenze aziendali. I requisiti hardware possono variare a seconda del tipo di distribuzione e utilizzo di Visual Studio Team System: versioni basate sui ruoli utilizzate, numero di progetti diversi su cui lavorano gli utenti e numero di ruoli differenti coperti dagli utenti nel corso dei progetti.

Requisiti hardware e software

Per determinare i requisiti hardware e software, considerare i seguenti fattori:

  • Quali versioni basate sui ruoli si desidera installare sui computer client.

  • Quale software è già installato sui computer client.

Per un'introduzione alle diverse versione basate sui ruoli di Team Foundation e su Team Explorer, vedere Pianificazione dei client.

Requisiti hardware

I seguenti requisiti hardware sono applicabili ai client Visual Studio Team System basati sui ruoli e a Team Explorer.

Client | CPU | Memoria | Disco rigido
Requisiti minimi | 2,0 GHz | 512 MB | 8 GB
Requisiti consigliati | 2,6 GHz | 1 GB | 20 GB

Se gli amministratori desiderano installare Visual Studio Team Edition for Testers e includere un rig di test dovranno essere soddisfatti ulteriori requisiti hardware. Per ulteriori informazioni su Visual Studio Team Edition for Testers, vedere Requisiti di rig di test per Team System.

Requisiti software

Tutti i client Visual Studio Team System presentano requisiti software specifici.

Requisiti del sistema operativo client

I client Visual Studio Team System supportano i seguenti sistemi operativi client:

  • Windows XP Professional con Service Pack 2 installato.

  • Windows Server 2003.

Prerequisiti software dei client

Oltre al sistema operativo, è necessario installare il seguente software sui computer client prima di installare i client Visual Studio Team System.

Componente | Versione
Internet Explorer | 6.0 con Service Pack 1
Microsoft Office | 11 con Service Pack 1
MDAC | 9.0
.NET Framework | 2.0

Installazione di Team Explorer con altro software dell'ambiente di sviluppo integrato

Team Explorer può essere installato ed eseguito affiancato ad altri ambienti di sviluppo integrato e consente a questi client di accedere alle funzionalità di Team Foundation Server come descritto di seguito:

  • Sviluppatori che utilizzano Visual Studio 2005 Professional o Standard.

    Team Explorer può essere installato dopo Visual Studio 2005 Professional e consente l'accesso alle funzionalità di Team Foundation Server. Team Explorer deve essere installato dopo queste versioni e non può essere installato affiancato a Visual Studio 2005 Professional.

  • Sviluppatori che utilizzano Visual Studio 2005 Express.

    Team Explorer può essere installato ed eseguito affiancato a Visual Studio 2005 Express e consente l'accesso alle funzionalità di Team Foundation Server.

  • Sviluppatori che utilizzano versioni precedenti di Visual Studio, ad esempio Visual Studio 6.

    Team Explorer può essere installato ed eseguito affiancato a versioni precedenti di Visual Studio (comprese le versioni precedenti di Visual Studio .NET) e consente a questi client di accedere alle funzionalità di Team Foundation Server.

  • Sviluppatori che utilizzano ambienti di sviluppo integrato diversi da Visual Studio.

    Team Explorer può essere installato ed eseguito affiancato ad altri ambienti di sviluppo integrato e consente a questi client di accedere alle funzionalità di Team Foundation Server.

Microsoft Project e Microsoft Excel come client Visual Studio Team System

Gli utenti possono inoltre accedere alle funzionalità di Team Foundation Server tramite Microsoft Project e Microsoft Excel mediante l'installazione di un client Visual Studio Team System basato sui ruoli o Team Explorer sul computer client.

Windows SharePoint Services

A parte Internet Explorer, non sono necessari altri requisiti di installazione per accedere alle funzionalità di Visual Studio Team System. Le funzionalità di Team Foundation Server vengono fornite sul Web, compresi l'accesso al portale Web del progetto Team basato su Windows SharePoint Services, ai report basati sui servizi di SQL Analysis e alle funzioni di gestione degli elementi di lavoro.

Considerazioni sulla lingua

È possibile installare la versione inglese di Visual Studio Team System su qualsiasi versione localizzata di un sistema operativo supportato. È possibile installare qualsiasi versione localizzata di Visual Studio Team System su un sistema operativo nella lingua corrispondente o un sistema operativo in inglese. Ad esempio, è possibile installare una versione giapponese di Visual Studio su una versione giapponese di Windows XP o una versione inglese di Windows XP, ma non su una versione tedesca di Windows XP.

Per installare una versione localizzata di Team Foundation Server su un sistema operativo in inglese, è necessario un pacchetto di interfaccia multiutente o almeno un'installazione dei font appropriati per la lingua.

Visual Studio Team System e Microsoft Office

Quando si utilizzano Visual Studio Team System e Microsoft Office insieme, è necessario tenere presente altre limitazioni relative alla lingua. La lingua del sistema operativo può essere qualsiasi lingua supportata, così come la lingua di Visual Studio, eccetto quando è installato Microsoft Office. In tal caso vigono le seguenti limitazioni.

Lingua della versione di Office | Visual Studio in inglese | Visual Studio in altra lingua
Office in inglese | Supportato | Supportato
Office in altra lingua | Supportato | Deve essere nella stessa lingua di Visual Studio

Altre considerazioni

I client Visual Studio Team System basati sui ruoli e Team Explorer possono essere gestiti in modo remoto e virtuale.

PC virtuali

I client Visual Studio Team System basati sui ruoli e Team Explorer funzionano correttamente su un PC virtuale, ma questa configurazione non è consigliata per gli ambienti di produzione.

Nota Nota

La creazione di profili non funziona su un PC virtuale a causa delle limitazioni del driver.

Terminal Server

I client Visual Studio Team System basati sui ruoli e Team Explorer funzionano correttamente con Terminal Server.

Vedere anche

Concetti

Pianificazione dei client
Pianificazione dei server

Altre risorse

Requisiti di Visual Studio 2005 Team System


Gestione di Team Foundation Server

 elenco a discesa elenco a discesa attivabile
Gestione di Team Foundation Server
Vedere anche
elenco a discesa

L'amministratore di Team Foundation Server deve avere dimestichezza con gli strumenti di amministrazione per Windows Server 2003, SQL Server 2005 e Windows SharePoint Services. Nei seguenti argomenti vengono fornite informazioni specifiche per la gestione di Team Foundation Server.

In questa sezione

Gestione di utenti e gruppi

Viene descritto come aggiungere, eliminare e modificare utenti e gruppi in Team Foundation Server.

Gestione delle autorizzazioni

Vengono descritti i gruppi e le autorizzazioni predefiniti e come modificare tali autorizzazioni.

Gestione dei servizi e degli account di servizio di Team Foundation Server

Vengono descritti i servizi e gli account di servizio eseguiti sul livello dati o applicazione di Team Foundation Server.

Gestione di dati

Vengono descritti gli strumenti, le procedure e le linee guida per la gestione dei dati utilizzati e memorizzati in Team Foundation Server.

Gestione dei servizi SQL Server

Vengono forniti collegamenti ad argomenti rilevanti nella documentazione in linea SQL Server 2005 per la gestione dei database, delle analisi e dei servizi di creazione di report utilizzati da Team Foundation.

Gestione dei componenti di Team Foundation Server

Vengono descritte le procedure per eseguire il clustering, il fail-over, il ripristino e la ridenominazione dei server a livello applicazione e dati.

Gestione di Team Foundation Server in un dominio Active Directory

Viene illustrato come eseguire una distribuzione stabile e protetta di Team Foundation Server in un ambiente Active Directory e vengono forniti esempi di configurazioni di dominio non supportate.

Gestione di Team Foundation Server in un gruppo di lavoro

Vengono discussi i vantaggi e gli svantaggi dell'utilizzo di Team Foundation Server in un gruppo di lavoro.

Gestione delle connessioni remote a Team Foundation Server Proxy

Vengono illustrati il funzionamento del proxy Team Foundation Server e le procedure di configurazione.

Gestione dei siti Team Foundation Server in Windows SharePoint Services

Vengono descritte le attività che influenzano la connettività e le prestazioni di un server su cui è in esecuzione Windows SharePoint Services che è anche configurato per Team Foundation.

Gestione delle impostazioni di configurazione di Team Foundation Server

Vengono illustrate le procedure di configurazione dell'ambiente Team Foundation Server mediante l'utilizzo dei servizi Web e dei file web.config.

Vedere anche

Altre risorse

Amministrazione di Team Foundation Server


Gestione di utenti e gruppi

 elenco a discesa elenco a discesa attivabile
Gestione di utenti e gruppi
Vedere anche
elenco a discesa

La protezione di Team Foundation è basata su utenti e gruppi. È possibile gestire gli utenti e i gruppi per implementare un modello di protezione per l'organizzazione che consenta agli utenti di accedere ai dati e alle funzionalità necessari e al contempo proteggere le informazioni riservate.

In questa sezione

Gestione di gruppi

Vengono descritte le procedure per creare, visualizzare, rinominare, eliminare o registrare gruppi in Team Foundation Server.

Gestione di utenti

Vengono descritte le procedure per aggiungere, disattivare, riattivare o rimuovere singoli account utente in Team Foundation Server.

Sezioni correlate

Amministrazione di Team Foundation Server

Vedere anche

Altre risorse

Gestione dei siti Team Foundation Server in Windows SharePoint Services
Utilizzo degli strumenti della riga di comando di Team Foundation Server


Gestione di gruppi

 elenco a discesa elenco a discesa attivabile
Gestione di gruppi
Vedere anche
elenco a discesa

Un gruppo è una raccolta di utenti con gli stessi requisiti di protezione in Team Foundation Server. L'aggiunta di utenti a gruppi consente di ridurre notevolmente il tempo di gestione delle autorizzazioni degli utenti. Gli utenti ereditano automaticamente le autorizzazioni di qualsiasi gruppo a cui appartengono.

Nota Nota

La propagazione di una nuova appartenenza di un singolo account utente a un gruppo potrebbe richiedere alcuni minuti.

In questa sezione

Gruppi predefiniti

Vengono descritti i gruppi dei progetti Team e globali predefiniti creati quando viene installato Team Foundation Server.

Gruppi personalizzati

Vengono descritti i gruppi dei progetti Team e del server che è possibile creare.

Aggiunta e rimozione di utenti dai gruppi

Vengono forniti collegamenti ad argomenti che illustrano come aggiungere o rimuovere utenti a e da gruppi a livello di server, di progetti Team o predefiniti.

Vedere anche

Altre risorse

Gestione di utenti


Gruppi predefiniti

 elenco a discesa elenco a discesa attivabile
Gruppi predefiniti
Vedere anche
elenco a discesa

Quando viene installato Team Foundation Server, vengono creati i seguenti gruppi globali, che è possibile utilizzare per controllare le autorizzazioni per gli utenti di Team Foundation.

Gruppo | Autorizzazioni
Team Foundation Administrators | Possono eseguire tutte le operazioni privilegiate su Team Foundation Server.
Team Foundation Valid Users | Hanno accesso a Team Foundation Server. Non è possibile aggiungere o rimuovere manualmente utenti o gruppi da questo gruppo mediante l'interfaccia utente di Team Foundation Server.
Team Foundation Service Accounts | Contiene gli account di servizio.

Quando si crea un nuovo progetto Team, Team Foundation crea i seguenti gruppi del progetto Team.

Gruppo | Autorizzazioni
Project Administrators | Possono gestire il progetto Team.
Readers | Possono vedere il progetto Team (accesso in lettura).
Contributors | Possono modificare il progetto Team (accesso in lettura e scrittura).
Build Services | Possono generare il progetto.

È possibile utilizzare questi gruppi del progetto Team per controllare le autorizzazioni dei membri del progetto Team.

In questa sezione

Procedura: visualizzare i gruppi predefiniti

Viene descritto come visualizzare le appartenenze e le autorizzazioni dei gruppi.

Procedura: rimuovere gli utenti da un gruppo predefinito

Viene descritto come rimuovere utenti o gruppi dai gruppi predefiniti di Team Foundation Server.

Procedura: modificare le autorizzazioni per un gruppo predefinito

Viene descritto come modificare le autorizzazioni per un gruppo predefinito a livello di server o di progetto.

Procedura: aggiungere utenti a un gruppo predefinito

Viene descritto come aggiungere utenti o un gruppo di Team Foundation Server a un gruppo già associato a un progetto Team.

Vedere anche

Attività

Procedura: modificare le autorizzazioni per un gruppo o un utente


Procedura: visualizzare i gruppi predefiniti

Procedura: visualizzare i gruppi predefiniti

È possibile visualizzare informazioni e appartenenza per qualsiasi gruppo di protezione in Team Foundation Server. Esaminare regolarmente le informazioni e l'appartenenza per i gruppi di protezione incorporati, nonché le informazioni per qualsiasi gruppo creato. Se si desidera creare un gruppo con autorizzazioni per più progetti, vedere Procedura: creare un gruppo a livello di server. Se si desidera creare un gruppo di protezione per il progetto Team, vedere Procedura: creare un gruppo di progetto Team.

Per visualizzare l'appartenenza per i gruppi a livello di server

  1. In Team Explorer selezionare il server Team Foundation Server per cui si desidera visualizzare le informazioni di appartenenza al gruppo.

  2. Scegliere Impostazioni di Team Foundation Server dal menu Team, quindi Appartenenza a gruppo.

  3. Nella finestra di dialogo Gruppi globali selezionare il gruppo di cui si desidera visualizzare l'appartenenza, quindi scegliere Proprietà.

  4. In Utenti o gruppi esaminare l'elenco degli utenti e dei gruppi membri visualizzati nella scheda Membro. Per visualizzare i gruppi di cui il gruppo è membro, selezionare la scheda Membro di.

  5. Al termine, scegliere OK.

Per visualizzare le autorizzazioni per i gruppi a livello di server

  1. In Team Explorer selezionare il server Team Foundation Server per cui si desidera visualizzare le informazioni sulle autorizzazioni del gruppo.

  2. Scegliere Impostazioni di Team Foundation Server dal menu Team, quindi fare clic su Protezione.

  3. In Utenti e gruppi della finestra di dialogo Autorizzazioni selezionare il gruppo per cui si desidera visualizzare le autorizzazioni.

  4. Esaminare l'elenco degli elementi selezionati nell'elenco delle autorizzazioni. Se un elemento è ombreggiato e non può essere selezionato, l'autorizzazione è stata specificata per impostazione predefinita e non può essere modificata.

  5. Al termine, scegliere Chiudi.

Per visualizzare l'appartenenza per i gruppi del progetto Team

  1. In Team Foundation Server selezionare il progetto Team per cui si desidera visualizzare le informazioni di appartenenza al gruppo.

  2. Scegliere Impostazioni progetto Team dal menu Team, quindi Appartenenza a gruppo.

  3. Nella finestra di dialogo Gruppi di progetti selezionare il gruppo di cui si desidera visualizzare l'appartenenza, quindi scegliere Proprietà.

  4. In Utenti o gruppi esaminare l'elenco degli utenti e dei gruppi membri visualizzati nella scheda Membro. Per visualizzare i gruppi di cui il gruppo è membro, selezionare la scheda Membro di.

  5. Al termine, scegliere OK.

Per visualizzare le autorizzazioni per i gruppi del progetto Team

  1. In Team Explorer selezionare il progetto Team per cui si desidera visualizzare le informazioni di appartenenza al gruppo.

  2. Scegliere Impostazioni progetto Team dal menu Team, quindi fare clic su Protezione.

  3. In Utenti e gruppi della finestra di dialogo Autorizzazioni selezionare il gruppo per cui si desidera visualizzare le autorizzazioni.

  4. Esaminare l'elenco degli elementi selezionati nell'elenco delle autorizzazioni. Se un elemento è ombreggiato e non può essere selezionato, l'autorizzazione è stata specificata per impostazione predefinita e non può essere modificata.

  5. Al termine, scegliere Chiudi.

Protezione

È necessario appartenere al gruppo Team Foundation Valid Users per potere visualizzare le autorizzazioni assegnate a un gruppo. I membri di tale gruppo non possono modificare le autorizzazioni, ma possono visualizzarle.

Vedere anche

Concetti

Aggiunta e rimozione di utenti dai gruppi

Altre risorse

Gestione di Team Foundation Server in un dominio Active Directory
Gruppi predefiniti
Visualizzazione e modifica delle autorizzazioni


Procedura: rimuovere gli utenti da un gruppo predefinito

Procedura: rimuovere gli utenti da un gruppo predefinito

Le modifiche di appartenenza a un gruppo del server predefinito apportate a livello del progetto Team si riflettono sull'intero server.

Per alcuni gruppi predefiniti non è possibile modificare le appartenenze. Per ulteriori informazioni, vedere Gruppi predefiniti.

Per rimuovere utenti o gruppi da un gruppo predefinito a livello di progetto

  1. In Team Explorer selezionare il progetto Team a cui appartiene il gruppo.

  2. Scegliere Impostazioni progetto Team dal menu Team, quindi Appartenenza a gruppo.

  3. Nella finestra di dialogo Gruppi di progetti selezionare il gruppo predefinito da cui si desidera rimuovere gli utenti, quindi scegliere Proprietà.

  4. Nella scheda Membri della finestra di dialogo Proprietà gruppo Team Foundation Server selezionare gli utenti o i gruppi da rimuovere.

  5. Scegliere Rimuovi.

  6. Scegliere OK.

Per rimuovere utenti o gruppi da un gruppo predefinito a livello di server

  1. In Team Explorer selezionare il server Team Foundation.

  2. Scegliere Impostazioni di Team Foundation Server dal menu Team, quindi Appartenenza a gruppo.

  3. Nella finestra di dialogo Gruppi globali selezionare il gruppo predefinito da cui si desidera rimuovere gli utenti, quindi scegliere Proprietà.

  4. Nella scheda Membri della finestra di dialogo Proprietà gruppo Team Foundation Server selezionare gli utenti o i gruppi da rimuovere.

  5. Scegliere Rimuovi.

  6. Scegliere OK.

Protezione

Per potere aggiungere o rimuovere utenti da un progetto Team Foundation Server è necessario disporre dei privilegi di amministratore Team Foundation Server o del progetto. Per ulteriori informazioni sulle autorizzazioni necessarie per l'aggiunta e la rimozione di utenti a e da progetti e per una descrizione delle autorizzazioni a livello di server e progetto, vedere Autorizzazioni per Team Foundation Server.

Vedere anche

Attività

Procedura: rimuovere un gruppo a livello di server

Concetti

Concetti sulla protezione di Team Foundation Server
Protezione di Team Foundation Server per utenti e gruppi
Autorizzazioni per Team Foundation Server


Procedura: modificare le autorizzazioni per un gruppo predefinito

Procedura: modificare le autorizzazioni per un gruppo predefinito
Vedere anche

Alcuni gruppi predefiniti sono definiti a livello di server, mentre altri sono definiti a livello del progetto Team. Le autorizzazioni a livello di server sono diverse da quelle a livello del progetto Team. Per un elenco completo delle autorizzazioni a livello di server e di progetto, vedere Autorizzazioni per Team Foundation Server. Per decidere se concedere o negare un'autorizzazione, utilizzare questo elenco e fare riferimento alle seguenti procedure.

Nota Nota

Alcuni gruppi predefiniti derivano da altre appartenenze del gruppo e le loro autorizzazioni non possono essere modificate direttamente. Per ulteriori informazioni, vedere Gruppi predefiniti.

Per modificare le autorizzazioni per un gruppo predefinito a livello di server

  1. In Team Explorer selezionare il server Team Foundation Server per cui si desidera visualizzare le informazioni sulle autorizzazioni del gruppo.

  2. Scegliere Impostazioni di Team Foundation Server dal menu Team, quindi fare clic su Protezione.

  3. In Utenti e gruppi della finestra di dialogo Protezione globale selezionare il gruppo predefinito per cui si desidera visualizzare le autorizzazioni.

  4. Esaminare l'elenco delle autorizzazioni selezionate nella parte inferiore della finestra di dialogo. Se un elemento è ombreggiato e non può essere selezionato, l'autorizzazione è stata specificata per impostazione predefinita e non può essere modificata.

  5. Per le autorizzazioni appropriate nella parte inferiore della finestra di dialogo selezionare o deselezionare Consenti o Nega a seconda delle esigenze. Al termine, fare clic su Chiudi.

Per modificare le autorizzazioni per un gruppo predefinito a livello di progetto

  1. In Team Explorer selezionare il progetto per cui si desidera visualizzare le informazioni sulle autorizzazioni del gruppo.

  2. Scegliere Impostazioni progetto Team dal menu Team, quindi fare clic su Protezione.

  3. In Utenti e gruppi della finestra di dialogo Protezione del progetto selezionare il gruppo predefinito per cui si desidera visualizzare le autorizzazioni.

  4. Esaminare l'elenco delle autorizzazioni selezionate nella parte inferiore della finestra di dialogo. Se un elemento è ombreggiato e non può essere selezionato, l'autorizzazione è stata specificata per impostazione predefinita e non può essere modificata.

  5. Per le autorizzazioni appropriate nella parte inferiore della finestra di dialogo selezionare o deselezionare Consenti o Nega a seconda delle esigenze. Al termine, fare clic su Chiudi.

Protezione

È necessario essere un amministratore di Team Foundation Server per potere modificare i gruppi predefiniti di Team Foundation Server a livello di server. Per ulteriori informazioni sulle autorizzazioni necessarie per l'aggiunta e la rimozione di utenti a e da progetti e per una descrizione delle autorizzazioni a livello di server e progetto, vedere Autorizzazioni per Team Foundation Server.

Vedere anche

Concetti

Concetti sulla protezione di Team Foundation Server
Protezione di Team Foundation Server per utenti e gruppi
Autorizzazioni per Team Foundation Server


Procedura: aggiungere utenti a un gruppo predefinito

Procedura: aggiungere utenti a un gruppo predefinito

Questa procedura descrive come aggiungere un nuovo membro a uno dei gruppi predefiniti da Team Foundation Server. È possibile aggiungere un utente o un gruppo definito in Team Foundation Server oppure un utente o un gruppo definito dalla rete Windows.

Le modifiche di appartenenza a un gruppo del server predefinito apportate a livello del progetto Team si riflettono sull'intero server.

Per aggiungere utenti a un gruppo associato a un progetto Team

  1. In Team Explorer selezionare il progetto Team in cui si trova il gruppo o, per aggiungere un gruppo a livello di server, selezionare il server Team Foundation Server in cui si trova il gruppo.

  2. Scegliere Impostazioni progetto Team dal menu Team, quindi Appartenenza a gruppo.

  3. Nella finestra di dialogo Gruppi di progetti selezionare il gruppo predefinito a cui si desidera aggiungere gli utenti, quindi scegliere Proprietà.

  4. In Aggiungi membro della scheda Membri nella finestra di dialogo Proprietà gruppo Team Foundation Server selezionare Utente o gruppo Windows.

  5. Fare clic su Aggiungi.

  6. In Immettere i nomi di oggetto da selezionare della finestra di dialogo Selezione utenti o gruppi immettere il nome di dominio e l'alias degli utenti che si desidera aggiungere nel seguente formato:

    dominio\aliasutente

    Per aggiungere più utenti contemporaneamente, separare le voci con un punto e virgola (;).

  7. Scegliere OK.

Per aggiungere un gruppo Team Foundation Server a un gruppo associato a un progetto Team

  1. In Team Explorer selezionare il progetto Team in cui si trova il gruppo o, per aggiungere un gruppo a livello di server, selezionare il server Team Foundation Server in cui si trova il gruppo.

  2. Scegliere Impostazioni progetto Team dal menu Team, quindi Appartenenza a gruppo.

  3. Nella finestra di dialogo Gruppi di progetti selezionare il gruppo predefinito a cui si desidera aggiungere un gruppo Team Foundation Server, quindi scegliere Proprietà.

  4. In Aggiungi membro della scheda Membri nella finestra di dialogo Proprietà gruppo Team Foundation Server selezionare Gruppo Team Foundation Server.

  5. Fare clic su Aggiungi.

  6. In Gruppi della finestra di dialogo Seleziona gruppi selezionare il gruppo che si desidera aggiungere, quindi scegliere OK.

Protezione

Per potere aggiungere o rimuovere utenti da un progetto Team Foundation Server è necessario disporre dei privilegi di amministratore Team Foundation Server o del progetto. Per ulteriori informazioni sulle autorizzazioni necessarie per l'aggiunta e la rimozione di utenti a e da progetti e per una descrizione delle autorizzazioni a livello di server e progetto, vedere Autorizzazioni per Team Foundation Server.

Vedere anche

Concetti

Concetti sulla protezione di Team Foundation Server
Protezione di Team Foundation Server per utenti e gruppi
Autorizzazioni per Team Foundation Server

Altre risorse

Gestione di utenti e gruppi


Gruppi personalizzati

 elenco a discesa elenco a discesa attivabile
Gruppi personalizzati
Vedere anche
elenco a discesa

Un gruppo personalizzato è un gruppo creato al di fuori dei gruppi predefiniti che vengono installati con il server o assegnati a un nuovo progetto.

Un gruppo personalizzato può essere un gruppo a livello di server o di progetto Team. I gruppi a livello di server possono disporre di autorizzazioni sia a livello di server che a livello del progetto Team. Le autorizzazioni a livello di server consentono, tra l'altro, di creare nuovi progetti, amministrare modifiche sospese e modificare il modello di processo. I gruppi del progetto Team possono solo disporre di autorizzazioni per eseguire operazioni sul progetto, ad esempio avviare una generazione o pubblicare i risultati dei test.

Per ulteriori informazioni sulle varie autorizzazioni disponibili nei gruppi di Team Foundation Server, vedere Autorizzazioni per Team Foundation Server.

In questa sezione

Gruppi a livello di server

Vengono descritti i gruppi a livello di server e come crearli e mantenerli.

Gruppi di un progetto Team

Vengono descritti i gruppi del progetto Team e come crearli e mantenerli.

Vedere anche

Altre risorse

Gruppi predefiniti


Gruppi a livello di server

 elenco a discesa elenco a discesa attivabile
Gruppi a livello di server
Vedere anche
elenco a discesa

I gruppi a livello di server vengono creati direttamente sul server Team Foundation Server, a differenza dei gruppi di progetto Team che sono associati a un progetto specifico. Ai gruppi a livello di server è possibile assegnare autorizzazioni per l'esecuzione di operazioni sul server Team Foundation quali la creazione di nuovi progetti o l'amministrazione degli utenti. I gruppi possono inoltre essere assegnati a progetti e ad essi possono essere concesse autorizzazioni per progetti specifici, ad esempio per per avviare una generazione o eliminare un progetto.

In questa sezione

Procedura: creare un gruppo a livello di server

Viene descritto come creare un gruppo personalizzato a livello di server.

Procedura: aggiungere utenti a un gruppo del server

Viene descritto come aggiungere utenti a un gruppo personalizzato a livello di server.

Procedura: rimuovere utenti dal gruppo a livello di server

Viene descritto come rimuovere un utente da un gruppo personalizzato a livello di server.

Procedura: rimuovere un gruppo a livello di server

Viene descritto come eliminare un gruppo personalizzato a livello di server.

Procedura: rinominare un gruppo a livello di server

Viene descritto come assegnare un nuovo nome a un gruppo personalizzato a livello di server.

Sezioni correlate

Gruppi predefiniti

Gruppi di un progetto Team

Vedere anche

Concetti

Gruppi predefiniti, autorizzazioni e ruoli di Team Foundation Server


Procedura: creare un gruppo a livello di server

Procedura: creare un gruppo a livello di server

La creazione di un gruppo di protezione a livello di server consente di concedere in modo efficiente un insieme specifico di autorizzazioni a un gruppo di utenti per Team Foundation Server. Se si desidera creare un gruppo di protezione per il progetto Team, vedere Procedura: creare un gruppo di progetto Team. Assicurarsi di concedere solo le autorizzazioni minime necessarie al gruppo e aggiungere solo quegli utenti o quei gruppi che hanno bisogno di appartenere a questo nuovo gruppo globale. Se questo gruppo richiede un livello elevato di autorizzazioni, ma è specifico del progetto, si consiglia di creare un gruppo a livello del progetto Team.

Per creare un gruppo a livello di server

  1. In Team Explorer selezionare il server Team Foundation Server per cui si desidera creare un gruppo a livello di server.

  2. Scegliere Impostazioni di Team Foundation Server dal menu Team, quindi Appartenenza a gruppo.

  3. Nella finestra di dialogo Appartenenza a gruppo globale fare clic su Nuovo.

  4. Nella casella Nome gruppo della finestra di dialogo Crea gruppo Team Foundation Server digitare il nome per il gruppo del progetto Team.

  5. Nella casella Descrizione digitare una descrizione per il gruppo.

  6. Scegliere OK.

Nota Importante

Dopo avere creato un gruppo a livello di server, è necessario aggiungerlo a Team Foundation Server nella finestra di dialogo Protezione, assegnarvi le autorizzazioni appropriate, quindi aggiungervi dei membri. Per impostazione predefinita, un nuovo gruppo viene creato senza alcuna autorizzazione.

Protezione

È necessario appartenere al gruppo Administrators di Team Foundation per potere creare gruppi a livello di server.

Vedere anche

Attività

Procedura: creare un gruppo di progetto Team
Procedura: modificare le autorizzazioni per un utente

Concetti

Aggiunta e rimozione di utenti dai gruppi

Altre risorse

Visualizzazione e modifica delle autorizzazioni


Procedura: aggiungere utenti a un gruppo del server

Procedura: aggiungere utenti a un gruppo del server

È possibile aggiungere utenti ai gruppi del progetto Team o ai gruppi del server esistenti. È inoltre necessario aggiungere membri ai gruppi creati. Per aggiungere utenti ai gruppi, è necessario disporre dell'accesso di lettura/scrittura ai gruppi che si desidera modificare.

Per aggiungere utenti a un gruppo

  1. In Team Explorer selezionare il progetto Team o l'Team Foundation Server in cui si trova il gruppo a cui si desidera aggiungere gli utenti.

  2. Dal menu Team scegliere Impostazioni progetto Team, quindi fare clic su Appartenenza gruppo o, per aggiungere utenti a un gruppo del server, scegliere Impostazioni Team Foundation Server, quindi fare clic su Appartenenza gruppo.

  3. Nella finestra di dialogo Gruppi di progetti selezionare il gruppo a cui si desidera aggiungere gli utenti, quindi scegliere Proprietà.

  4. In Aggiungi membro , nella scheda Membri della finestra di dialogo Proprietà gruppo Team Foundation Server, selezionare Utente o gruppo Windows.

  5. Fare clic su Aggiungi.

  6. In Immettere i nomi di oggetto da selezionare della finestra di dialogo Selezione utenti o gruppi immettere il nome di dominio e l'alias degli utenti che si desidera aggiungere nel seguente formato:

    dominio\aliasutente

    Per aggiungere più utenti contemporaneamente, separare le voci con un punto e virgola (;).

  7. Scegliere OK.

Per aggiungere un gruppo Team Foundation Server a un gruppo

  1. In Team Explorer selezionare il progetto Team in cui si trova il gruppo o, per aggiungere un gruppo del server, selezionare l'Team Foundation Server in cui si trova il gruppo.

  2. Dal menu Team scegliere Impostazioni progetto Team, quindi fare clic su Appartenenza gruppo o, per aggiungere utenti a un gruppo del server, scegliere Impostazioni Team Foundation Server, quindi fare clic su Appartenenza gruppo.

  3. Nella finestra di dialogo Gruppi di progetti selezionare il gruppo a cui si desidera aggiungere un gruppo di Team Foundation Server, quindi scegliere Proprietà.

  4. In Aggiungi membro, nella scheda Membri della finestra di dialogo Proprietà gruppo Team Foundation Server selezionare Gruppo Team Foundation Server.

  5. Fare clic su Aggiungi.

  6. In Gruppi della finestra di dialogo Seleziona gruppi selezionare il gruppo che si desidera aggiungere, quindi fare clic su Chiudi.

Vedere anche

Attività

Procedura: creare un gruppo di progetto Team
Procedura: creare un gruppo a livello di server

Concetti

Autorizzazioni per Team Foundation Server
Gruppi predefiniti, autorizzazioni e ruoli di Team Foundation Server

Altre risorse

Gruppi a livello di server
Gruppi predefiniti


Procedura: rimuovere utenti dal gruppo a livello di server

Procedura: rimuovere utenti dal gruppo a livello di server

Quando un utente o un gruppo non fa più parte del progetto Team o non ha più bisogno di accedere alla risorse del progetto Team, è possibile rimuovere il relativo account utente dal gruppo a livello di server.

Per rimuovere utenti da un gruppo a livello di server

  1. In Team Explorer selezionare il server Team Foundation Server in cui si trova il gruppo.

  2. Scegliere Impostazioni di Team Foundation Server dal menu Team, quindi Appartenenza a gruppo.

  3. Nella finestra di dialogo Gruppi globali selezionare il gruppo da cui si desidera rimuovere gli utenti, quindi scegliere Proprietà.

  4. Nella scheda Membri della finestra di dialogo Proprietà gruppo Team Foundation Server selezionare gli utenti o i gruppi da rimuovere.

  5. Scegliere Rimuovi.

  6. Scegliere OK.

Protezione

È necessario appartenere al gruppo Administrators di Team Foundation per potere rimuovere membri da un gruppo a livello di server.

Vedere anche

Attività

Procedura: rimuovere un gruppo a livello di server


Procedura: rimuovere un gruppo a livello di server

Procedura: rimuovere un gruppo a livello di server

Se un gruppo a livello di server non viene più utilizzato, è possibile eliminarlo. Prima di procedere, assicurarsi che non siano presenti altri utenti o gruppi che dipendono da tale gruppo per le autorizzazioni necessarie. È inoltre possibile aggiungere o rimuovere le autorizzazioni di un gruppo oppure aggiungere o rimuovere membri. Non è possibile rimuovere i gruppi predefiniti a livello di server.

Per rimuovere un gruppo a livello di server

  1. In Team Explorer selezionare il server Team Foundation Server in cui si trova il gruppo.

  2. Scegliere Impostazioni di Team Foundation Server dal menu Team, quindi Appartenenza a gruppo.

  3. Nella finestra di dialogo Gruppi globali selezionare il gruppo che si desidera rimuovere, quindi scegliere Rimuovi.

  4. Nella finestra di dialogo di conferma dell'eliminazione scegliere Sì, quindi fare clic su Chiudi.

Protezione

È necessario appartenere al gruppo Administrators di Team Foundation per potere rimuovere un gruppo a livello di server.

Vedere anche

Attività

Procedura: rimuovere utenti dal gruppo a livello di server

Concetti

Autorizzazioni per Team Foundation Server

Altre risorse

Visualizzazione e modifica delle autorizzazioni


Procedura: rinominare un gruppo a livello di server

Procedura: rinominare un gruppo a livello di server

È possibile rinominare un gruppo per indicarne più chiaramente lo scopo. Per potere rinominare un gruppo, è necessario disporre dell'accesso in lettura/scrittura a tale gruppo. Non è possibile rinominare i gruppi predefiniti a livello di server, ad esempio Team Foundation Administrators.

Per rinominare un gruppo a livello di server

  1. In Team Explorer selezionare il server Team Foundation Server in cui si trova il gruppo.

  2. Scegliere Impostazioni di Team Foundation Server dal menu Team, quindi Appartenenza a gruppo.

  3. Nella finestra di dialogo Gruppi globali selezionare il gruppo che si desidera rinominare, quindi scegliere Proprietà.

    Nota Nota

    Non è possibile rinominare i gruppi predefiniti.

  4. Nella casella Nome gruppo della finestra di dialogo Proprietà gruppo Team Foundation Server immettere il nuovo nome per il gruppo del progetto Team.

  5. Scegliere OK, quindi scegliere Chiudi.

Protezione

È necessario appartenere al gruppo Administrators di Team Foundation per potere rinominare un gruppo a livello di server.

Vedere anche

Attività

Procedura: rimuovere utenti dal gruppo a livello di server

Altre risorse

Visualizzazione e modifica delle autorizzazioni


Gruppi di un progetto Team

 elenco a discesa elenco a discesa attivabile
Gruppi di un progetto Team
Vedere anche
elenco a discesa

Un gruppo di un progetto Team è un gruppo associato a un progetto Team specifico. È possibile creare un numero qualsiasi di gruppi per un progetto e concedere loro le autorizzazioni specifiche per il progetto che si desidera che i membri di tali gruppi possiedano.

Al momento della creazione di un progetto Team vengono definiti alcuni gruppi del progetto. I gruppi predefiniti inclusi in Team Foundation Server vengono aggiunti al progetto in fase iniziale. Inoltre, al progetto vengono aggiunti tutti i gruppi predefiniti a livello di server. Gli eventuali gruppi personalizzati a livello di server devono invece essere aggiunti manualmente. Qualsiasi modifica apportata all'appartenenza ai gruppi a livello di server come parte del progetto Team viene applicata a tutti i progetti ai quali il gruppo è assegnato. Le modifiche alle autorizzazioni, invece, sono specifiche del progetto Team corrente.

Per informazioni su come modificare gruppi predefiniti e a livello di server, vedere Gruppi predefiniti e Gruppi a livello di server.

In questa sezione

Procedura: creare un gruppo di progetto Team

Viene descritto come creare un gruppo personalizzato di un progetto Team e assegnare autorizzazioni ai relativi membri.

Procedura: aggiungere utenti a un gruppo di progetto Team

Viene descritto come aggiungere utenti o gruppi a un gruppo di un progetto Team nuovo o esistente.

Procedura: rimuovere gli utenti da un gruppo di progetto Team

Viene descritto come rimuovere un utente o un gruppo dall'appartenenza a un gruppo Team.

Procedura: rimuovere un gruppo di un progetto Team

Viene descritto come rimuovere un progetto Team quando non viene più utilizzato.

Procedura: rinominare un gruppo di un progetto Team

Viene descritto come assegnare a un progetto Team esistente un nuovo nome per meglio rifletterne la funzione e lo scopo.

Sezioni correlate

Concetti sulla protezione di Team Foundation Server

Vengono forniti i concetti di base sulla protezione di Team Foundation Server.

Protezione di Team Foundation Server per utenti e gruppi

Viene descritto come la protezione di Team Foundation Server viene applicata a utenti e gruppi.

Autorizzazioni per Team Foundation Server

Vengono descritti i tipi di autorizzazione Team Foundation Server, la relativa funzione e la modalità di gestione.

Vedere anche

Altre risorse

Gruppi predefiniti
Gruppi a livello di server
Gruppi personalizzati


Procedura: creare un gruppo di progetto Team

Procedura: creare un gruppo di progetto Team

È possibile creare gruppi di protezione per il progetto Team per soddisfare meglio i requisiti di protezione dell'organizzazione. La creazione di un gruppo di protezione consente di concedere in modo efficiente un insieme specifico di autorizzazioni a un gruppo di utenti del progetto Team. Assicurarsi di concedere solo le autorizzazioni minime necessarie al gruppo e aggiungere solo quegli utenti o quei gruppi che hanno bisogno di appartenere a questo nuovo gruppo del progetto Team. Se è necessario creare un gruppo non specifico per il progetto, si consiglia di creare un gruppo a livello di server. Se è necessario creare un gruppo con autorizzazioni per più progetti, vedere Procedura: creare un gruppo a livello di server.

Per creare un gruppo di un progetto Team

  1. In Team Explorer selezionare il progetto Team per cui si desidera creare un gruppo.

  2. Scegliere Impostazioni progetto Team dal menu Team, quindi Appartenenza a gruppo.

  3. Nella finestra di dialogo Gruppi di progetti fare clic su Nuovo.

  4. Nella casella Nome gruppo della finestra di dialogo Crea gruppo Team Foundation Server digitare il nome per il gruppo del progetto Team.

  5. Nella casella Descrizione digitare una descrizione per il gruppo.

  6. Scegliere OK.

Nota Importante

Dopo avere creato un gruppo del progetto Team, è necessario aggiungere il nuovo gruppo, assegnarvi le autorizzazioni appropriate, quindi aggiungere membri al gruppo. Per impostazione predefinita, il gruppo del progetto Team viene creato senza alcuna autorizzazione.

Protezione

È necessario appartenere al gruppo Project Administrators o Administrators di Team Foundation per potere creare un gruppo a livello di progetto.

Vedere anche

Attività

Procedura: creare un gruppo a livello di server

Concetti

Aggiunta e rimozione di utenti dai gruppi
Autorizzazioni per Team Foundation Server
Gruppi predefiniti, autorizzazioni e ruoli di Team Foundation Server

Altre risorse

Visualizzazione e modifica delle autorizzazioni


Procedura: aggiungere utenti a un gruppo di progetto Team

Procedura: aggiungere utenti a un gruppo di progetto Team

L'aggiunta di utenti a gruppi esistenti di un progetto Team consente di gestire facilmente gli utenti e le autorizzazioni di cui hanno bisogno. L'aggiunta di utenti a un gruppo di protezione consente di concedere in modo efficiente un insieme specifico di autorizzazioni a un gruppo di utenti del progetto Team.

L'aggiunta di utenti al gruppo di un progetto Team consente di concedere agli utenti le autorizzazioni del gruppo solo al livello di quel particolare progetto. Per informazioni su come apportare modifiche globalmente a un gruppo predefinito, vedere Procedura: aggiungere utenti a un gruppo predefinito.

Per aggiungere utenti a un gruppo

  1. In Team Explorer selezionare il progetto Team a cui appartiene il gruppo.

  2. Scegliere Impostazioni progetto Team dal menu Team, quindi Appartenenza a gruppo.

  3. Nella finestra di dialogo Gruppi di progetti selezionare il gruppo del progetto Team a cui si desidera aggiungere gli utenti, quindi scegliere Proprietà.

  4. In Aggiungi membro della scheda Membri nella finestra di dialogo Proprietà gruppo Team Foundation Server selezionare Utente o gruppo Windows.

  5. Fare clic su Aggiungi.

    In Immettere i nomi di oggetto da selezionare della finestra di dialogo Selezione utenti o gruppi digitare il nome dell'utente che si desidera aggiungere nel formato appropriato per la rete.

    Per aggiungere più utenti contemporaneamente, separare le voci con un punto e virgola (;).

  6. Scegliere OK, quindi scegliere Chiudi.

Per aggiungere un gruppo Team Foundation Server a un gruppo

  1. In Team Explorer selezionare il progetto Team in cui si trova il gruppo o, per aggiungere un gruppo a livello di server, selezionare il server Team Foundation Server in cui si trova il gruppo.

  2. Scegliere Impostazioni progetto Team dal menu Team, quindi Appartenenza a gruppo.

  3. Nella finestra di dialogo Gruppi di progetti selezionare il gruppo predefinito a cui si desidera aggiungere un gruppo di Team Foundation Server, quindi scegliere Proprietà.

  4. In Aggiungi membro della scheda Membri nella finestra di dialogo Proprietà gruppo Team Foundation Server selezionare Gruppo Team Foundation Server.

  5. Fare clic su Aggiungi.

  6. In Gruppi della finestra di dialogo Seleziona gruppi selezionare il gruppo che si desidera aggiungere, quindi scegliere OK.

Protezione

Per potere aggiungere o rimuovere utenti da un progetto Team Foundation Server è necessario disporre dei privilegi di amministratore Team Foundation Server o del progetto. Per ulteriori informazioni sulle autorizzazioni necessarie per l'aggiunta e la rimozione di utenti a e da progetti e per una descrizione delle autorizzazioni a livello di server e di progetto, vedere Autorizzazioni per Team Foundation Server.

Vedere anche

Concetti

Concetti sulla protezione di Team Foundation Server
Protezione di Team Foundation Server per utenti e gruppi
Autorizzazioni per Team Foundation Server
Gruppi predefiniti, autorizzazioni e ruoli di Team Foundation Server

Altre risorse

Gestione di utenti e gruppi


Procedura: rimuovere gli utenti da un gruppo di progetto Team

Procedura: rimuovere gli utenti da un gruppo di progetto Team
Vedere anche

Nella procedura seguente viene descritto come rimuovere un utente o un gruppo esistente all'interno di un gruppo di un progetto Team.

Per rimuovere utenti o gruppi da un gruppo di un progetto Team

  1. In Team Explorer selezionare il progetto Team a cui appartiene il gruppo.

  2. Scegliere Impostazioni progetto Team dal menu Team, quindi Appartenenza a gruppo.

  3. Nella finestra di dialogo Gruppi di progetti selezionare il gruppo da cui si desidera rimuovere gli utenti, quindi scegliere Proprietà.

  4. Nella scheda Membri della finestra di dialogo Proprietà gruppo Team Foundation Server selezionare gli utenti o i gruppi da rimuovere.

  5. Scegliere Rimuovi.

  6. Scegliere OK.

Protezione

Per potere aggiungere o rimuovere utenti da un progetto Team Foundation Server è necessario disporre dei privilegi di amministratore Team Foundation Server o del progetto. Per ulteriori informazioni sulle autorizzazioni necessarie per l'aggiunta e la rimozione di utenti a e da progetti e per una descrizione delle autorizzazioni a livello di server e di progetto, vedere Autorizzazioni per Team Foundation Server.

Vedere anche

Concetti

Concetti sulla protezione di Team Foundation Server
Protezione di Team Foundation Server per utenti e gruppi
Autorizzazioni per Team Foundation Server
Gruppi predefiniti, autorizzazioni e ruoli di Team Foundation Server

Altre risorse

Gestione di utenti e gruppi


Procedura: rimuovere un gruppo di un progetto Team

Procedura: rimuovere un gruppo di un progetto Team

Se un gruppo di protezione non viene più utilizzato, è possibile eliminarlo. Prima di procedere, assicurarsi che non siano presenti altri utenti o gruppi che dipendono da tale gruppo per le autorizzazioni necessarie. È inoltre possibile aggiungere o rimuovere le autorizzazioni di un gruppo oppure aggiungere o rimuovere membri.

Per rimuovere un gruppo di un progetto Team

  1. In Team Explorer selezionare il progetto Team a cui appartiene il gruppo.

  2. Scegliere Impostazioni progetto Team dal menu Team, quindi Appartenenza a gruppo.

  3. Nella finestra di dialogo Gruppi di progetti selezionare il gruppo che si desidera rimuovere, quindi scegliere Rimuovi.

  4. Scegliere Sì nella finestra di dialogo di conferma dell'eliminazione.

Protezione

Per potere aggiungere o rimuovere un gruppo da un progetto Team Foundation Server è necessario disporre dei privilegi di amministratore Team Foundation Server o del progetto. Per ulteriori informazioni sulle autorizzazioni necessarie per la rimozione di gruppi da progetti e per una descrizione delle autorizzazioni a livello di server e di progetto, vedere Autorizzazioni per Team Foundation Server.

Vedere anche

Concetti

Concetti sulla protezione di Team Foundation Server
Protezione di Team Foundation Server per utenti e gruppi
Autorizzazioni per Team Foundation Server
Gruppi predefiniti, autorizzazioni e ruoli di Team Foundation Server

Altre risorse

Gestione di utenti e gruppi


Procedura: rinominare un gruppo di un progetto Team

Procedura: rinominare un gruppo di un progetto Team

È possibile rinominare un gruppo per indicarne più chiaramente lo scopo. Per potere rinominare un gruppo, è necessario disporre dell'accesso in lettura/scrittura a tale gruppo.

Per rinominare un gruppo di un progetto Team

  1. In Team Explorer selezionare il progetto Team a cui appartiene il gruppo.

  2. Scegliere Impostazioni progetto Team dal menu Team, quindi Appartenenza a gruppo.

  3. Nella finestra di dialogo Gruppi di progetti selezionare il gruppo che si desidera rinominare, quindi scegliere Proprietà.

  4. Nella casella Nome gruppo della finestra di dialogo Proprietà gruppo Team Foundation Server digitare il nuovo nome per il gruppo del progetto Team.

  5. Scegliere OK.

Protezione

Per potere aggiungere o rimuovere utenti da un progetto Team Foundation Server è necessario disporre dei privilegi di amministratore Team Foundation Server o del progetto. Per ulteriori informazioni sulle autorizzazioni necessarie per l'aggiunta e la rimozione di utenti a e da progetti e per una descrizione delle autorizzazioni a livello di server e di progetto, vedere Autorizzazioni per Team Foundation Server.

Vedere anche

Concetti

Concetti sulla protezione di Team Foundation Server
Protezione di Team Foundation Server per utenti e gruppi
Autorizzazioni per Team Foundation Server
Gruppi predefiniti, autorizzazioni e ruoli di Team Foundation Server

Altre risorse

Gestione di utenti e gruppi


Aggiunta e rimozione di utenti dai gruppi

 elenco a discesa elenco a discesa attivabile
Aggiunta e rimozione di utenti dai gruppi
Vedere anche
elenco a discesa

Quando si utilizzano progetti Team è necessario aggiungere utenti ai gruppi di protezione e mantenerne un elenco in modo da concedere l'accesso agli utenti e al contempo salvaguardare la protezione dei dati.

Nota Nota

La propagazione di una nuova appartenenza di un singolo account utente a un gruppo potrebbe richiedere alcuni minuti.

Vedere anche

Attività

Procedura: creare un gruppo di progetto Team
Procedura: creare un gruppo a livello di server
Procedura: visualizzare i gruppi predefiniti
Procedura: aggiungere utenti a un gruppo predefinito
Procedura: aggiungere utenti a un gruppo del server
Procedura: aggiungere utenti a un gruppo di progetto Team
Procedura: rimuovere gli utenti da un gruppo predefinito
Procedura: rimuovere utenti dal gruppo a livello di server
Procedura: rimuovere gli utenti da un gruppo di progetto Team


Gestione di utenti

 elenco a discesa elenco a discesa attivabile
Gestione di utenti
Vedere anche
elenco a discesa

È possibile aggiungere, modificare e rimuovere utenti direttamente in Team Foundation Server. Per la gestione degli utenti è necessario determinarne i ruoli e le autorizzazioni di cui hanno bisogno per svolgere il proprio ruolo. Diversamente dai gruppi di Team Foundation Server, che hanno autorizzazioni predefinite, quando si aggiungono singoli account utente, è necessario impostare le autorizzazioni esplicitamente. Le gestione di gruppi è meno complicata della gestione di singoli utenti. Si consiglia di aggiungere gli utenti ai gruppi di Team Foundation Server invece che separatamente.

In questa sezione

Utenti di Team Foundation Server

Vengono descritte le situazioni in cui è possibile assegnare le autorizzazioni direttamente a un utente invece che aggiungere l'utente a un gruppo.

Procedura: visualizzare gli utenti esistenti

Vengono illustrate le operazioni necessarie per determinare quali utenti e gruppi sono direttamente associati a un progetto o al server Team Foundation.

Procedura: aggiungere un utente

Viene illustrata la procedura per l'aggiunta di un account utente direttamente a Team Foundation Server.

Procedura: modificare le autorizzazioni per un utente

Viene illustrata la procedura per la modifica delle autorizzazioni assegnate a un account utente.

Procedura: disattivare o riattivare un utente

Viene illustrata la procedura per la sospensione o il ripristino di un account utente.

Procedura: rimuovere un utente

Viene illustrata la procedura per la rimozione completa di un account utente da Team Foundation Server o un progetto Team.

Sezioni correlate

Gestione di gruppi

Gestione di Team Foundation Server in un dominio Active Directory

Authenticating Users

Vedere anche

Concetti

Gruppi di protezione di Team Foundation

Altre risorse

Configuring Team Foundation Server


Utenti di Team Foundation Server

 elenco a discesa elenco a discesa attivabile
Utenti di Team Foundation Server
Vedere anche
elenco a discesa

In genere è consigliabile assegnare singoli utenti a gruppi e quindi assegnare autorizzazioni in base a tali gruppi. Le autorizzazioni di gruppo sono più semplici da gestire rispetto a quelle individuali poiché consentono di consolidare le autorizzazioni in un insieme ottimale di ruoli ben definiti.

In alcune situazioni potrebbe tuttavia essere preferibile assegnare direttamente a un utente autorizzazioni sul server o un progetto, ad esempio se è necessario assegnare a una persona una funzione di backup, come nel caso in cui occorra concedere a un'altra persona l'autorizzazione Pubblica risultati test mentre il responsabile del testing è in ferie. Per ragioni di sicurezza, è consigliabile rimuovere tali autorizzazioni temporanee quando non sono più necessarie.

Vedere anche

Attività

Procedura: visualizzare gli utenti esistenti
Procedura: aggiungere un utente
Procedura: modificare le autorizzazioni per un utente

Concetti

Gruppi predefiniti, autorizzazioni e ruoli di Team Foundation Server
Autorizzazioni per Team Foundation Server


Procedura: visualizzare gli utenti esistenti

Procedura: visualizzare gli utenti esistenti

È possibile visualizzare quali utenti e gruppi sono direttamente associati a un progetto o al server Team Foundation Server.

Per visualizzare tutti gli utenti a livello di progetto

  1. In Team Explorer selezionare il progetto Team in cui si trova il gruppo o, per aggiungere un gruppo a livello di server, selezionare il server Team Foundation Server in cui si trova il gruppo.

  2. Scegliere Impostazioni progetto Team dal menu Team, quindi fare clic su Protezione.

  3. In Utenti e gruppi nella finestra di dialogo Protezione progetto è visualizzato un elenco degli utenti e dei gruppi associati al progetto

  4. Una volta esaminati gli utenti e i gruppi del progetto, fare clic su Chiudi.

Nota Nota

Per esaminare i membri di un gruppo a livello di progetto, scegliere Impostazioni progetto Team dal menu Team, fare clic su Appartenenza a gruppo, fare clic sul gruppo di cui si desidera esaminare l'appartenenza, quindi scegliere Proprietà.

Per visualizzare tutti gli utenti a livello di server

  1. In Team Explorer selezionare il server Team Foundation Server.

  2. Scegliere Impostazioni di Team Foundation Server dal menu Team, quindi fare clic su Protezione.

  3. In Utenti e gruppi nella finestra di dialogo Protezione globale è visualizzato un elenco degli utenti e dei gruppi associati al progetto

  4. Una volta esaminati gli utenti e i gruppi del progetto, fare clic su Chiudi. Nota: per esaminare i membri di un gruppo a livello di server, scegliere Impostazioni di Team Foundation Server dal menu Team, fare clic su Appartenenza a gruppo, fare clic sul gruppo di cui si desidera esaminare l'appartenenza, quindi scegliere Proprietà.

Protezione

Per potere aggiungere o rimuovere utenti da un progetto Team Foundation Server è necessario disporre dei privilegi di amministratore Team Foundation Server o del progetto. Per ulteriori informazioni sulle autorizzazioni necessarie per l'aggiunta e la rimozione di utenti a e da progetti e per una descrizione delle autorizzazioni a livello di server e progetto, vedere Autorizzazioni per Team Foundation Server.

Vedere anche

Concetti

Utenti di Team Foundation Server


Procedura: aggiungere un utente

Procedura: aggiungere un utente

A differenza dell'aggiunta di utenti a gruppi, l'aggiunta di utenti a Team Foundation Server non è un'attività amministrativa comune. Prima di aggiungere un utente, è necessario determinare il ruolo dell'utente e le autorizzazioni richieste per tale ruolo. Se l'utente ricopre un ruolo comune, è consigliabile aggiungerlo prima a un gruppo invece che aggiungerlo direttamente al server. Per ulteriori informazioni su utenti, gruppi e ruoli, vedere Gruppi predefiniti, autorizzazioni e ruoli di Team Foundation Server.

Per aggiungere un utente a Team Foundation Server

  1. In Visual Studio aprire Team Explorer e connettersi al server Team Foundation Server a cui si desidera aggiungere un utente.

  2. Fare clic con il pulsante destro del mouse sul server Team Foundation Server, scegliere Impostazioni di Team Foundation Server, quindi fare clic su Protezione.

  3. Nella casella Aggiungi utenti e gruppi della finestra di dialogo Protezione globale selezionare Utente o gruppo Windows, quindi scegliere Aggiungi.

  4. Controllare che sia il tipo di oggetto sia il percorso siano corretti.

  5. In Immettere i nomi degli oggetti da selezionare digitare l'alias del gruppo o dell'utente che si desidera aggiungere al server Team Foundation Server.

  6. Scegliere OK.

  7. Nella finestra di dialogo Protezione globale verificare che l'utente appena aggiunto sia evidenziato in Utenti e gruppi. In Autorizzazioni selezionare quelle che si desidera concedere o negare all'utente o al gruppo aggiunto. Per impostazione predefinita, a un nuovo utente o gruppo non viene concessa o negata alcuna autorizzazione. Se non si concedono o negano autorizzazioni, l'utente o il gruppo non viene creato e quindi non risulta visibile una volta scelto Chiudi.

  8. Fare clic su Chiudi.

Protezione

È necessario appartenere al gruppo Administrators di Team Foundation per potere aggiungere un utente direttamente a Team Foundation Server. Non aggiungere un utente direttamente a Team Foundation Server a meno che non richieda autorizzazioni diverse da quelle concesse ai gruppi di Team Foundation Server.

Quando si aggiunge un utente o un gruppo, concedergli solo le autorizzazioni strettamente necessarie a svolgere il rispettivo ruolo.

Vedere anche

Attività

Procedura: aggiungere utenti a un gruppo del server

Concetti

Autorizzazioni per Team Foundation Server

Altre risorse

Gestione di utenti
Gestione di gruppi


Procedura: modificare le autorizzazioni per un utente

Procedura: modificare le autorizzazioni per un utente

Con il tempo è possibile che cambiamenti nelle necessità di progetto o amministrazione richiedano la modifica delle autorizzazioni di un utente a livello di progetto o a livello di server Team Foundation Server. Prima di modificare le autorizzazioni, considerare se potrebbe essere più efficiente rimuovere il singolo utente e aggiungerlo invece a un gruppo che dispone già delle autorizzazioni corrette.

Per modificare le autorizzazioni di un utente a livello di server

  1. In Visual Studio aprire Team Explorer e connettersi al server Team Foundation Server a cui appartiene l'utente che si desidera modificare.

  2. Fare clic con il pulsante destro del mouse sul server Team Foundation Server, scegliere Impostazioni di Team Foundation Server, quindi fare clic su Protezione. In alternativa, selezionare il server Team Foundation Server e scegliere Impostazioni di Team Foundation Server dal menu Team, quindi fare clic su Protezione.

  3. In Utenti e gruppi della finestra di dialogo Protezione globale selezionare l'utente del quale si desidera modificare le autorizzazioni.

  4. In Autorizzazioni selezionare o deselezionare le autorizzazioni che si desidera concedere o negare all'utente da modificare. Se si desidera che le autorizzazioni dell'utente dipendano dal gruppo a livello di server o di progetto a cui appartiene, deselezionare sia Consenti che Nega.

  5. Fare clic su Chiudi.

Per modificare le autorizzazioni di un utente a livello di progetto

  1. In Visual Studio aprire Team Explorer e connettersi al server Team Foundation Server a cui appartiene l'utente che si desidera modificare.

  2. Fare clic con il pulsante destro del mouse sul progetto, scegliere Impostazioni progetto Team, quindi fare clic su Protezione. In alternativa, selezionare il progetto, scegliere Impostazioni progetto Team dal menu Team, quindi fare clic su Protezione.

  3. In Utenti e gruppi della finestra di dialogo Protezione progetto selezionare l'utente del quale si desidera modificare le autorizzazioni.

  4. In Autorizzazioni selezionare o deselezionare le autorizzazioni che si desidera concedere o negare all'utente da modificare. Se si desidera che le autorizzazioni dell'utente dipendano dal gruppo a livello di server o di progetto a cui appartiene, deselezionare sia Consenti che Nega.

  5. Fare clic su Chiudi.

Protezione

Quando si modifica un utente o un gruppo, concedergli solo le autorizzazioni strettamente necessarie a svolgere il rispettivo ruolo.

Vedere anche

Attività

Procedura: aggiungere un utente

Concetti

Autorizzazioni per Team Foundation Server
Gruppi predefiniti, autorizzazioni e ruoli di Team Foundation Server

Altre risorse

Gestione di utenti
Gestione di gruppi


Procedura: disattivare o riattivare un utente

Procedura: disattivare o riattivare un utente

È possibile che cambiamenti nelle necessità di progetto o amministrazione richiedano la disattivazione o riattivazione di un account utente di Team Foundation Server. La disattivazione e successiva riattivazione di un account consentono di mantenere le informazioni cronologiche e la continuità per il ruolo di un utente.

Per disattivare un utente in Team Foundation Server

  1. In Visual Studio aprire Team Explorer e connettersi al server Team Foundation Server a cui appartiene l'utente che si desidera disattivare.

  2. Fare clic con il pulsante destro del mouse sul server Team Foundation Server, scegliere Impostazioni di Team Foundation Server, quindi fare clic su Protezione.

  3. In Utenti e gruppi selezionare l'utente o il gruppo che si desidera disattivare.

  4. In Protezione deselezionare tutte le autorizzazioni Consenti per l'utente e impostare tutte le autorizzazioni su Nega.

  5. Fare clic su Chiudi.

Per riattivare un utente in Team Foundation Server

  1. In Visual Studio aprire Team Explorer e connettersi al server Team Foundation Server a cui appartiene l'utente che si desidera riattivare.

  2. Fare clic con il pulsante destro del mouse sul server Team Foundation Server, scegliere Impostazioni di Team Foundation Server, quindi fare clic su Protezione.

  3. In Utenti e gruppi selezionare l'utente o il gruppo che si desidera riattivare.

  4. In Protezione selezionare tutte le autorizzazioni che si desidera concedere o negare all'utente.

  5. Fare clic su Chiudi.

Protezione

È necessario appartenere al gruppo Administrators di Team Foundation per potere disattivare o riattivare un utente in Team Foundation Server. Quando si riattiva un utente o un gruppo, concedergli solo le autorizzazioni strettamente necessarie a svolgere il rispettivo ruolo.

Vedere anche

Attività

Procedura: aggiungere un utente
Procedura: modificare le autorizzazioni per un utente
Procedura: aggiungere utenti a un gruppo del server

Altre risorse

Gestione di utenti
Gestione di gruppi


Procedura: rimuovere un utente

Procedura: rimuovere un utente

È possibile che si desideri rimuovere un utente che era stato aggiunto direttamente a un server o a un progetto una volta che l'attività assegnatagli è stata portata a termine.

Al fine di ridurre il carico amministrativo si consiglia di assegnare gli utenti a gruppi quando possibile. Se un utente deve eseguire attività comuni per la durata del progetto, è consigliabile aggiungerlo a un gruppo esistente o a un nuovo gruppo. Per informazioni dettagliate sulla creazione di nuovi gruppi, vedere Gruppi personalizzati.

Per spostare a un gruppo un utente assegnato direttamente a un server o a un progetto, è necessario dapprima rimuoverlo e quindi aggiungerlo nuovamente al gruppo desiderato.

Per rimuovere un utente da un server Team Foundation Server

  1. In Visual Studio aprire Team Explorer e connettersi al server Team Foundation Server a cui appartiene l'utente che si desidera rimuovere.

  2. Fare clic con il pulsante destro del mouse sul server Team Foundation Server, scegliere Impostazioni di Team Foundation Server, quindi fare clic su Protezione.

  3. Nella finestra di dialogo Protezione globale selezionare l'utente che si desidera rimuovere dall'elenco Utenti e gruppi.

  4. Fare clic sul pulsante Rimuovi.

  5. Scegliere Chiudi nella finestra di dialogo Protezione globale.

Per rimuovere un utente da un progetto

  1. In Visual Studio aprire Team Explorer e connettersi al server Team Foundation Server a cui appartiene l'utente che si desidera rimuovere.

  2. Fare clic con il pulsante destro del mouse sul progetto, scegliere Impostazioni progetto Team, quindi fare clic su Protezione.

  3. Nella finestra di dialogo Protezione progetto selezionare l'utente che si desidera rimuovere dall'elenco Utenti e gruppi.

  4. Fare clic sul pulsante Rimuovi.

  5. Scegliere Chiudi nella finestra di dialogo Protezione progetto.

Protezione

È necessario appartenere al gruppo Administrators di Team Foundation per potere rimuovere un utente a livello di server, mentre è necessario appartenere al gruppo Project Administrators o Administrators di Team Foundation per potere rimuovere un utente a livello di progetto. Se sono state assegnate autorizzazioni direttamente a un utente affinché ricoprisse un ruolo temporaneo, è necessario rimuovere tale utente appena l'attività è stata portata a termine.

Vedere anche

Attività

Procedura: aggiungere utenti a un gruppo predefinito
Procedura: aggiungere utenti a un gruppo del server
Procedura: aggiungere utenti a un gruppo di progetto Team

Concetti

Utenti di Team Foundation Server


Gestione delle autorizzazioni

 elenco a discesa elenco a discesa attivabile
Gestione delle autorizzazioni
Vedere anche
elenco a discesa

In qualità di amministratore si controlla le azioni che gli utenti possono eseguire concedendo loro autorizzazioni specifiche. Per facilitare il lavoro degli amministratori, Team Foundation fornisce delle impostazioni delle autorizzazioni e dei gruppi predefiniti. È però anche possible personalizzare queste impostazioni predefinite o crearne di proprie. Negli argomenti trattati in questa sezione vengono descritte in dettaglio le autorizzazioni.

In questa sezione

Autorizzazioni per Team Foundation Server

Vengono descritte le varie autorizzazioni che possono essere impostate per utenti e gruppi in Team Foundation Server.

Gruppi predefiniti, autorizzazioni e ruoli di Team Foundation Server

Vengono descritti i gruppi e le autorizzazioni create per impostazione predefinita quando viene installato Team Foundation Server o creato un nuovo progetto Team.

Autorizzazioni di amministratore di Team Foundation Server

Vengono descritte le autorizzazioni necessarie per un amministratore di Team Foundation Server e viene indicato come ottenere informazioni sull'impostazione di tali autorizzazioni.

Autorizzazioni di coordinatore del progetto di Team Foundation Server

Vengono descritte le autorizzazioni necessarie per un responsabile di progetto di Team Foundation Server e viene indicato come ottenere informazioni sull'impostazione di tali autorizzazioni.

Autorizzazioni di collaboratore per Team Foundation Server

Vengono descritte le autorizzazioni necessarie per un collaboratore di progetto di Team Foundation Server e viene indicato come ottenere informazioni sull'impostazione di tali autorizzazioni.

Autorizzazioni del controllo del codice sorgente di Team Foundation

Vengono descritti le autorizzazioni e i privilegi di protezione per il controllo del codice sorgente, le generazioni e il controllo da utilizzare con il comando tf.

Visualizzazione e modifica delle autorizzazioni

Vengono descritte le procedure per la visualizzazione o la modifica delle autorizzazioni a livello di server o di progetto per utenti e gruppi.

Sezioni correlate

Gestione di utenti e gruppi

Gestione dei servizi e degli account di servizio di Team Foundation Server

Controllo e autorizzazioni utente

Autorizzazioni e privilegi di protezione del controllo del codice sorgente

Vedere anche

Altre risorse

Protezione di Team Foundation Server


Autorizzazioni per Team Foundation Server

 elenco a discesa elenco a discesa attivabile
Autorizzazioni per Team Foundation Server
Vedere anche
elenco a discesa

L'autorizzazione per le azioni degli utenti, ad esempio l'amministrazione di aree di lavoro e la creazione di progetti, dipende dalle autorizzazioni. Quando si crea un progetto in Team Foundation Server, vengono creati quattro gruppi predefiniti per il progetto indipendentemente dal modello di processo scelto. Per impostazione predefinita, ciascuno di questi gruppi dispone di un insieme di autorizzazioni che determinano ciò che i membri dei gruppi sono autorizzati ad eseguire.

  • Project Administrators

  • Contributors

  • Readers

  • Build Services

Per gestire i gruppi predefiniti e creare gruppi personalizzati, gli amministratori devono capire il significato delle autorizzazioni e le implicazioni sulla protezione dell'impostazione esplicita delle autorizzazioni.

Nota Nota

In questo argomento non vengono illustrate le autorizzazioni per Windows SharePoint Services o SQL Reporting Services, bensì solo le autorizzazioni impostate in Team Foundation Server.

Impostazioni delle autorizzazioni

Esistono due impostazioni delle autorizzazioni esplicite per le autorizzazioni in Team Foundation Server: Deny e Allow. È inoltre disponibile un'autorizzazione implicita che non imposta né l'autorizzazione Consenti né quella Nega. Questa autorizzazione è un'impostazione di negazione implicita a cui si fa riferimento come non impostata.

Deny

Questa impostazione nega all'utente o al gruppo l'autorizzazione ad eseguire le azioni elencate nella descrizione dell'autorizzazione. La negazione è l'impostazione di autorizzazione più potente in Team Foundation Server. Se un utente appartiene a un gruppo Team Foundation Server con un'autorizzazione specifica negata, l'utente non può eseguire la funzione, anche se appartiene a un altro gruppo autorizzato a eseguire la stessa funzione.

Allow

Questa impostazione concede all'utente o al gruppo l'autorizzazione ad eseguire le azioni elencate nella descrizione dell'autorizzazione. Questa è la seconda impostazione di autorizzazione più potente di Team Foundation Server e quella utilizzata più frequentemente, in quanto senza un'autorizzazione esplicitamente concessa, un utente o un gruppo non può eseguire alcuna azione in Team Foundation Server.

Non impostata

Per impostazione predefinita, la maggior parte delle autorizzazioni in Team Foundation Server non è impostata né come Nega né come Consenti. Le autorizzazioni vengono lasciate non impostate, il che significa che implicitamente sia agli utenti che ai gruppi viene negata l'autorizzazione ad eseguire le azioni specificate nella descrizione dell'autorizzazione. Tuttavia, poiché l'autorizzazione non viene esplicitamente impostata, può essere ereditata da altri gruppi a cui appartiene l'utente o il gruppo.

Ereditarietà

Quando l'autorizzazione non è impostata per un utente o un gruppo, l'utente o il gruppo può risentire dell'impostazione esplicita dell'autorizzazione per i gruppi a cui appartengono in quanto le autorizzazioni all'interno di Team Foundation Server vengono ereditate. Se un'autorizzazione è impostata esplicitamente per un gruppo a cui appartiene un utente, ma non è impostata per un altro gruppo a cui tale utente appartiene, quest'ultimo eredita l'impostazione per l'autorizzazione dall'altro gruppo.

Nota Nota

Le autorizzazioni impostate al di fuori di Team Foundation Server, ad esempio Windows SharePoint Services, non vengono ereditate in Team Foundation Server e non vengono trattate in questo argomento.

Alcune impostazioni di autorizzazione hanno la precedenza su altre. In Team Foundation Server l'autorizzazione Deny ha la precedenza su tutte le altre impostazioni di autorizzazione, compresa Allow. Ad esempio, un utente potrebbe appartenere a due gruppi in un progetto. Per un gruppo l'autorizzazione Pubblica risultati test è negata, mentre per l'altro gruppo è consentita. L'impostazione Deny avrà la precedenza e l'utente non è autorizzato a pubblicare i risultati del test.

Autorizzazioni impostate mediante l'interfaccia utente di Team Foundation Server e dalla riga di comando

Molte delle autorizzazioni impostabili per Team Foundation Server sono controllate mediante l'interfaccia utente di Team Foundation Server. È possibile impostare queste autorizzazioni in base al server (autorizzazioni a livello di server) o al progetto (autorizzazioni a livello di progetto). È inoltre possibile impostare le autorizzazioni a livello di area per la visualizzazione e l'interazione con gli elementi di lavoro in base al progetto. Per ulteriori informazioni su quali autorizzazioni sono impostate per quali utenti per impostazione predefinita e per le autorizzazioni da impostare per i gruppi di MSF for Agile Software Development o di MSF for CMMI Process Improvement, vedere Gruppi predefiniti, autorizzazioni e ruoli di Team Foundation Server. Per ulteriori informazioni su come impostare le autorizzazioni per utenti e gruppi, vedere Gestione di utenti e gruppi e Gestione delle autorizzazioni. Per ulteriori informazioni sulla gestione degli elementi di lavoro, vedere Gestione degli elementi di lavoro di Team Foundation.

Autorizzazioni a livello di server

La autorizzazioni a livello di server non sono proprie di un unico progetto, ma vengono impostate in base al server. È possibile impostare queste autorizzazioni solo per gli utenti e i gruppi a livello di server, ad esempio il gruppo Administrators di Team Foundation, per i gruppi a livello di progetto che sono stati aggiunti a livello del server Team Foundation e per i gruppi personalizzati creati e aggiunti a livello di server. Per impostare queste autorizzazioni in Team Foundation Server, fare clic con il pulsante destro sul server in Team Explorer e scegliere Protezione. È possibile impostare queste autorizzazioni mediante l'utilità della riga di comando TFSSecurity, eccetto per le impostazioni contrassegnate con tf:. Per impostare queste autorizzazioni, utilizzare il comando Permissions dell'utilità della riga di comando tf per il controllo del codice sorgente.

Nome autorizzazione Nome nella riga di comando Descrizione

Amministra modifiche sospese

tf: AdminShelvesets

Consente di eliminare insiemi di sospensione creati da altri utenti.

Amministra warehouse

ADMINISTER_WAREHOUSE

Consente di modificare le impostazioni del data warehouse mediante il metodo Web ChangeSetting del servizio Web WarehouseController.asmx. Ad esempio, è possibile consentire agli utenti di impostare l'intervallo di aggiornamento per il calcolo dei cubi OLAP.

Amministra aree di lavoro

tf: AdminWorkspaces

Consente di creare aree di lavoro per altri utenti ed eliminare aree di lavoro create da altri utenti.

Crea area di lavoro

tf: CreateWorkspace

Consente di creare un'area di lavoro per il controllo del codice sorgente.

Crea nuovi progetti

CREATE_PROJECTS

Consente di creare nuovi progetti in Team Foundation Server. A questo scopo gli utenti devono disporre anche delle autorizzazioni di amministratore in Windows SharePoint Server e SQL Reporting Services.

Modifica informazioni a livello di server

GENERIC_WRITE

Consente di modificare autorizzazioni e gruppi a livello di server. Gli utenti possono creare, eliminare e rinominare gruppi di applicazioni Team Foundation Server a livello di server e aggiungere o rimuovere un utente o un gruppo Windows per il gruppo di applicazioni. Inoltre questa autorizzazione concede implicitamente l'accesso in scrittura al controllo della versione.

Nota Nota

I gruppi del server predefiniti, ad esempio Administrators di Team Foundation, non possono essere eliminati.

Modifica impostazioni di analisi

DIAGNOSTIC_TRACE

Consente di modificare le impostazioni di analisi per la raccolta di informazioni di diagnostica più dettagliate sui servizi Web di Team Foundation Server. Per ulteriori informazioni sulla funzione di analisi, vedere Impostazioni di analisi per Team Foundation Server.

Genera eventi

TRIGGER_EVENT

Consente di attivare eventi di avviso di progetto in Team Foundation Server. Questa autorizzazione può essere assegnata solo ad account di servizio.

Gestisci modello di processo

MANAGE_TEMPLATE

Consente di scaricare, creare, modificare e caricare modelli di processo in Team Foundation Server.

Visualizza informazioni a livello di server

GENERIC_READ

Consente di visualizzare l'appartenenza a un gruppo a livello di server e le autorizzazioni degli utenti.

Autorizzazioni a livello di progetto

Le autorizzazioni a livello di progetto sono proprie di utenti e gruppi di un singolo progetto. Per impostare queste autorizzazioni in Team Foundation Server, fare clic con il pulsante destro sul progetto in Team Explorer e scegliere Protezione. È inoltre possibile impostare queste autorizzazioni mediante l'utilità della riga di comando TFSSecurity.

Nome autorizzazione | Nome nella riga di comando | Descrizione
Amministra generazione | ADMINISTER_BUILD | Consente di eliminare generazioni complete e interrompere generazioni in corso.
Elimina questo progetto | DELETE | Consente di eliminare progetti da Team Foundation Server.
Modifica qualità generazione | EDIT_BUILD_STATUS | Consente di aggiungere informazioni sulla qualità della generazione mediante l'interfaccia utente di Team Foundation Build. Queste informazioni vengono memorizzate nell'archivio del database di Team Foundation Build.
Modifica informazioni a livello di progetto | GENERIC_WRITE | Consente di modificare autorizzazioni e gruppi a livello di progetto. Gli utenti possono inoltre creare, eliminare e rinominare gruppi a livello di progetto, aggiungere o rimuovere utenti e gruppi Windows nel progetto, nonché aggiungere o rimuovere utenti o gruppi Team Foundation Server nel progetto. Gli utenti possono altresì modificare le autorizzazioni del progetto per questi utenti e gruppi e aggiungere o rimuovere query di gestione degli elementi di lavoro a livello di progetto.
Pubblica risultati test | PUBLISH_TEST_RESULTS | Consente di aggiungere o rimuovere i risultati dei test sul portale del progetto Team e aggiungere o rimuovere le esecuzioni dei test.
Avvia generazione | START_BUILD | Consente di avviare una generazione mediante l'interfaccia utente di Team Foundation Build o dalla riga di comando.
Visualizza informazioni a livello di progetto | GENERIC_READ | Consente di visualizzare l'appartenenza a un gruppo a livello di progetto e le autorizzazioni degli utenti del progetto.
Scrivi nell'archivio operativo delle generazioni | UPDATE_BUILD | Consente di aggiornare l'archivio del database di Team Foundation Build. Questa autorizzazione deve essere concessa all'account in cui è in esecuzione il servizio di generazione e può essere assegnata solo ad account di servizio e non a singoli utenti.

Autorizzazioni a livello di area di gestione degli elementi di lavoro

Le autorizzazioni a livello di area sono proprie di utenti e gruppi di un singolo progetto. Per impostare queste autorizzazioni, fare clic con il pulsante destro del mouse sul progetto in Team Explorer e scegliere Aree e iterazioni, quindi fare clic su Protezione nella scheda Area. È inoltre possibile impostare queste autorizzazioni mediante l'utilità della riga di comando TFSSecurity.

Nome autorizzazione | Nome nella riga di comando | Descrizione
Crea e ordina nodi figlio | CREATE_CHILDREN | Consente di creare nuovi nodi dell'area e riordinare i nodi figlio dell'area.
Elimina questo nodo | DELETE | Consente di eliminare nodi dell'area. Vengono eliminati anche i nodi figlio del nodo padre eliminato.
Modifica questo nodo | GENERIC_WRITE | Consente di ridenominare i nodi dell'area.
Modifica elementi di lavoro in questo nodo | WORK_ITEM_WRITE | Consente di modificare elementi di lavoro nel nodo dell'area.
Visualizza questo nodo | GENERIC_READ | Consente di visualizzare le impostazioni di protezione per il nodo.
Visualizza elementi di lavoro in questo nodo | WORK_ITEM_READ | Consente di visualizzare, ma non modificare o cambiare, elementi di lavoro nel nodo dell'area.

Autorizzazioni del controllo del codice sorgente

Le autorizzazioni del controllo del codice sorgente sono proprie dei file e delle cartelle del codice sorgente. Per impostare queste autorizzazioni, fare clic con il pulsante destro del mouse sulla cartella o sul file in Esplora controllo del codice sorgente e scegliere Autorizzazioni, quindi nella scheda Protezione selezionare l'utente o il gruppo di cui si desidera modificare le autorizzazioni e modificare le autorizzazioni elencate in Autorizzazioni. Per impostare queste autorizzazioni, utilizzare l'utilità della riga di comando tf per il controllo del codice sorgente.

Nome autorizzazione | Nome nella riga di comando | Descrizione
Leggi | tf: Read | Consente di leggere il contenuto di un file o di una cartella. Se un utente dispone delle autorizzazioni Read per una cartella, può visualizzare il contenuto della cartella e le proprietà dei file in essa presenti, anche se non è autorizzato ad aprire i file.
Estrai | tf: PendChange | Consente di estrarre e apportare una modifica in sospeso agli elementi di una cartella. Tra gli esempi di modifiche in sospeso figurano l'aggiunta, la ridenominazione, l'eliminazione, l'annullamento dell'eliminazione, la diramazione e l'unione di un file.
Archivia | tf: Checkin | Consente di archiviare elementi ed esaminare i commenti dell'insieme di modifiche salvate. Le modifiche in sospeso vengono salvate al momento dell'archiviazione.
Etichetta | tf: Label | Consente di etichettare elementi.
Blocca | tf: Lock | Consente di bloccare e sbloccare cartelle o file.
Esamina modifiche di altri utenti | tf: ReviseOther | Consente di modificare i commenti relativi ai file archiviati, anche se è stato un altro utente ad archiviare il file.
Sblocca modifiche di altri utenti | tf: UnlockOther | Consente di sbloccare file bloccati da altri utenti.
Annulla modifiche di altri utenti | tf: UndoOther | Consente di annullare una modifica in sospeso apportata da un altro utente.
Amministra etichette | tf: LabelOther | Consente di modificare o eliminare etichette create da un altro utente.
Modifica impostazioni di protezione | tf: AdminProjRights | Consente di impostare autorizzazioni per file e cartelle.
Archivia modifiche di altri utenti | tf: CheckinOther | Consente di archiviare modifiche apportate da altri utenti. Le modifiche in sospeso vengono salvate al momento dell'archiviazione.

Vedere anche

Concetti

Gruppi predefiniti, autorizzazioni e ruoli di Team Foundation Server
Gestione degli elementi di lavoro di Team Foundation

Altre risorse

Comandi dell'utilità della riga di comando TFSSecurity
Riferimenti alla riga di comando del controllo del codice sorgente di Team Foundation
Gestione di utenti e gruppi
Gestione delle autorizzazioni


Gruppi predefiniti, autorizzazioni e ruoli di Team Foundation Server

 elenco a discesa elenco a discesa attivabile
Gruppi predefiniti, autorizzazioni e ruoli di Team Foundation Server
Vedere anche
elenco a discesa

Quando si crea un nuovo progetto in Team Foundation Server, per impostazione predefinita vengono creati nuovi gruppi a livello di progetto e a questi vengono assegnate autorizzazioni per l'accesso alle risorse appropriate per il gruppo. Per personalizzare i progetti al fine di soddisfare meglio le esigenze aziendali, è necessario sapere quali autorizzazioni vengono assegnate a quali utenti e gruppi per impostazione predefinita e quali autorizzazioni è possibile assegnare ad eventuali utenti o gruppi aggiunti. Inoltre, se si desidera allineare strettamente gli utenti con i ruoli descritti per MSF for Agile Software Development o MSF for CMMI Process Improvement, è necessario capire come allineare tali ruoli con i gruppi predefiniti già assegnati al progetto. In alternativa, è possibile creare dei gruppi associati direttamente con ciascuno di questi ruoli e assegnare a tali gruppi le autorizzazioni appropriate al ruolo.

Gruppi predefiniti e autorizzazioni

Quando si crea un progetto in Team Foundation Server, vengono creati dei gruppi a livello del progetto. Per impostazione predefinita, a ciascuno di questi gruppi vengono assegnate determinate autorizzazioni. È possibile aggiungere delle autorizzazioni a questi gruppi predefiniti oltre che a eventuali gruppi o utenti che si desidera aggiungere a livello di server o di progetto.

Gruppi a livello di server e autorizzazioni

Per impostazione predefinita, i seguenti gruppi esistono a livello di server quando si installa Team Foundation Server:

  • SERVER\Team Foundation Administrators I membri di questo gruppo possono eseguire tutte le operazioni per Team Foundation Server. A questo gruppo devono appartenere il minor numero possibile di utenti e solo coloro che hanno bisogno di esercitare un controllo amministrativo totale su Team Foundation Server.

  • SERVER\Team Foundation Valid Users I membri di questo gruppo hanno accesso a Team Foundation Server. Questo gruppo contiene automaticamente tutti gli utenti e tutti i gruppi che sono stati aggiunti all'interno di Team Foundation Server. Non è possibile modificare l'appartenenza di questo gruppo mediante l'interfaccia utente.

  • SERVER\Service Accounts I membri di questo gruppo dispongono di autorizzazioni a livello di servizio per Team Foundation Server. Per impostazione predefinita, questo gruppo contiene l'account di servizio fornito durante l'installazione. Se si desidera aggiungere nuovi account a questo gruppo, è necessario inserirli con lo strumento della riga di comando TFSSecurity. Questo gruppo può contenere solo account di servizio e non account utente o gruppi (a meno che il gruppo contenga esclusivamente account di servizio).

Per impostazione predefinita, questi gruppi dispongono delle seguenti autorizzazioni. Per una descrizione completa di ciascuna autorizzazione inclusa nel seguente elenco, vedere Autorizzazioni per Team Foundation Server.

Nome autorizzazione | Per impostazione predefinita impostata per: | Considerare l'assegnazione anche a:
Accedi al sistema del controllo del codice sorgente | Tutti gli utenti in un progetto (per impostazione predefinita, non modificabile) | Utenti o gruppi aggiunti manualmente.
Amministra modifiche sospese | Team Foundation Administrators, Service Accounts | Utenti o gruppi aggiunti manualmente che potrebbero dovere eliminare aree di sospensione create da altri utenti.
Amministra warehouse | Team Foundation Administrators, Service Accounts | Utenti o gruppi aggiunti manualmente che potrebbero dovere modificare le impostazioni del data warehouse tramite il metodo Web ChangeSetting del servizio Web WarehouseController.asmx.
Amministra aree di lavoro | Team Foundation Administrators, Service Accounts | Utenti o gruppi aggiunti manualmente che potrebbero dovere creare aree di lavoro per altri utenti ed eliminare aree di lavoro create da altri utenti.
Crea area di lavoro | Team Foundation Administrators, Team Foundation Valid Users | Nessuno.
Crea nuovi progetti | Team Foundation Administrators | Amministratori di progetto che creeranno regolarmente nuovi progetti. A questo scopo devono disporre anche delle autorizzazioni di amministratore in Windows SharePoint Server e delle autorizzazioni di responsabile della gestione del contenuto in SQL Reporting Services.
Modifica informazioni a livello di server | Team Foundation Administrators | Nessuno.
Modifica impostazioni di analisi | Team Foundation Administrators | Altri amministratori del server che potrebbero dovere modificare le impostazioni di analisi per la raccolta di informazioni di diagnostica più dettagliate sui servizi Web di Team Foundation Server.
Genera eventi | Team Foundation Administrators, Service Accounts | Nessuno. L'assegnazione di questa autorizzazione ad altri utenti può causare attacchi di tipo denial of service.
Gestisci modello di processo | Team Foundation Administrators | Amministratori di progetto e utenti o gruppi aggiunti manualmente, ad esempio specialisti di processo, che potrebbero dovere creare, modificare, scaricare o caricare modelli di processo in Team Foundation Server.
Visualizza informazioni a livello di server | Team Foundation Administrators, Team Foundation Valid Users | Nessuno.

Gruppi a livello di progetto e autorizzazioni

Per impostazione predefinita, a livello di progetto esistono i seguenti gruppi:

  • Project Name\Project Administrators I membri di questo gruppo possono amministrare tutti gli aspetti del progetto Team, anche se non possono creare nuovi progetti.

  • Project Name\Contributors I membri di questo gruppo possono contribuire al progetto in diversi modi. Ad esempio, possono aggiungere, modificare ed eliminare codice, creare e modificare elementi di lavoro e così via.

  • Project Name\Readers I membri di questo gruppo possono visualizzare il progetto, ma non modificarlo.

  • Project Name\Build Services I membri di questo gruppo dispongono delle autorizzazioni del servizio di generazione per il progetto. Questo gruppo può contenere solo account di servizio di generazione e non account utente o gruppi (a meno che il gruppo contenga esclusivamente account di servizio di generazione).

Oltre a questi account a livello di progetto, per impostazione predefinita, in tutti i progetti Team Foundation Server sono visualizzati anche due degli account a livello di server:

  • SERVER\Team Foundation Administrators

  • SERVER\Team Foundation Valid Users

Per impostazione predefinita, questi gruppi dispongono delle seguenti autorizzazioni. Per una descrizione completa di ciascuna autorizzazione inclusa nel seguente elenco, vedere Autorizzazioni per Team Foundation Server.

Nome autorizzazione | Per impostazione predefinita impostata per: | Considerare l'assegnazione anche a:
Amministra generazione | Project Administrators, Team Foundation Administrators | Utenti o gruppi aggiunti manualmente che potrebbero dovere eliminare generazioni completate o interrompere generazioni in corso.
Elimina questo progetto | Project Administrators, Team Foundation Administrators | Nessuno.
Modifica qualità generazione | Project Administrators, Team Foundation Administrators | Utenti o gruppi aggiunti manualmente che potrebbero dovere aggiungere informazioni sulla qualità della generazione mediante l'interfaccia utente di Team Foundation Build.
Modifica informazioni a livello di progetto | Project Administrators, Team Foundation Administrators | Nessuno.
Pubblica risultati test | Project Administrators, Team Foundation Administrators | Utenti o gruppi aggiunti manualmente che potrebbero dovere aggiungere o rimuovere i risultati dei test sul portale del progetto Team e aggiungere o rimuovere le esecuzioni dei test.
Avvia generazione | Project Administrators, Contributors, Team Foundation Administrators | Utenti o gruppi aggiunti manualmente che potrebbero dovere avviare una generazione mediante l'interfaccia utente di Team Foundation Build o dalla riga di comando.
Visualizza informazioni a livello di progetto | Project Administrators, Contributors, Readers, Team Foundation Administrators, Team Foundation Valid Users | Tutti gli utenti o i gruppi aggiunti manualmente.
Scrivi nell'archivio operativo delle generazioni | Build Services, Team Foundation Administrators | Questa autorizzazione può essere assegnata solo ad account di servizio e non a singoli utenti.

Gruppi a livello di area e autorizzazioni

Per impostazione predefinita, a livello di area esistono i seguenti gruppi:

  • Project Name\Project Administrators

  • Project Name\Contributors

  • Project Name\Readers

  • Project Name\Build Services

  • SERVER\Team Foundation Administrators

  • SERVER\Team Foundation Valid Users

Per impostazione predefinita, questi gruppi dispongono delle seguenti autorizzazioni. Per una descrizione completa di ciascuna autorizzazione inclusa nel seguente elenco, vedere Autorizzazioni per Team Foundation Server.

Nome autorizzazione | Per impostazione predefinita impostata per: | Considerare l'assegnazione anche a:
Crea e ordina nodi figlio | Project Administrators, Team Foundation Administrators | Nessuno.
Elimina questo nodo | Project Administrators, Team Foundation Administrators | Utenti o gruppi aggiunti manualmente che potrebbero dovere eliminare nodi dell'area.
Modifica questo nodo | Project Administrators, Team Foundation Administrators | Utenti o gruppi aggiunti manualmente che potrebbero dovere ridenominare nodi dell'area.
Modifica elementi di lavoro in questo nodo | Project Administrators, Contributors, Build Services, Team Foundation Administrators | Utenti o gruppi aggiunti manualmente che potrebbero dovere modificare elementi di lavoro in questo nodo dell'area.
Visualizza questo nodo | Project Administrators, Contributors, Readers, Build Services, Team Foundation Administrators, Team Foundation Valid Users | Nessuno.
Visualizza elementi di lavoro in questo nodo | Project Administrators, Contributors, Readers, Build Services, Team Foundation Administrators | Utenti o gruppi aggiunti manualmente che potrebbero dovere visualizzare, ma non modificare o cambiare, elementi di lavoro in questo nodo dell'area.

Gruppi di controllo del codice sorgente e autorizzazioni

Per impostazione predefinita, a livello di controllo del codice sorgente esistono i seguenti gruppi:

  • Project Name\Project Administrators

  • Project Name\Contributors

  • Project Name\Readers

  • Project Name\Build Services

  • SERVER\Team Foundation Administrators

  • SERVER\Service Accounts

Per impostazione predefinita, questi gruppi dispongono delle seguenti autorizzazioni. Per una descrizione completa di ciascuna autorizzazione inclusa nel seguente elenco, vedere Autorizzazioni per Team Foundation Server.

Nome autorizzazione | Per impostazione predefinita impostata per: | Considerare l'assegnazione anche a:
Leggi | Project Administrators, Contributors, Readers, Build Services, Team Foundation Administrators, Service Accounts | La maggior parte di utenti o gruppi aggiunti manualmente e chiunque potrebbe dovere leggere il contenuto di un file o di una cartella.
Estrai | Project Administrators, Contributors, Build Services, Team Foundation Administrators, Service Accounts | Utenti o gruppi aggiunti manualmente che potrebbero dovere estrarre o apportare una modifica in sospeso agli elementi in una cartella.
Archivia | Project Administrators, Contributors, Build Services, Team Foundation Administrators, Service Accounts | Utenti o gruppi aggiunti manualmente che potrebbero dovere archiviare elementi o esaminare commenti dell'insieme di modifiche salvati.
Etichetta | Project Administrators, Contributors, Build Services, Team Foundation Administrators, Service Accounts | Utenti o gruppi aggiunti manualmente che potrebbero dovere etichettare elementi.
Blocca | Project Administrators, Contributors, Build Services, Team Foundation Administrators, Service Accounts | Utenti o gruppi aggiunti manualmente che potrebbero dovere bloccare o sbloccare cartelle o file.
Esamina modifiche di altri utenti | Project Administrators, Team Foundation Administrators, Service Accounts | Utenti o gruppi aggiunti manualmente, responsabili della supervisione o del monitoraggio del progetto, che potrebbero dovere modificare commenti dei file archiviati, anche se è stato un altro utente ad archiviare il file.
Sblocca modifiche di altri utenti | Project Administrators, Team Foundation Administrators, Service Accounts | Utenti o gruppi aggiunti manualmente che potrebbero dovere sbloccare file bloccati da altri utenti.
Annulla modifiche di altri utenti | Project Administrators, Team Foundation Administrators, Service Accounts | Utenti o gruppi aggiunti manualmente che potrebbero dovere annullare una modifica in sospeso apportata da un altro utente.
Amministra etichette | Project Administrators, Team Foundation Administrators, Service Accounts | Utenti o gruppi aggiunti manualmente che potrebbero dovere modificare o eliminare etichette create da un altro utente.
Modifica impostazioni di protezione | Project Administrators, Team Foundation Administrators, Service Accounts | Nessuno.
Archivia modifiche di altri utenti | Project Administrators, Team Foundation Administrators, Service Accounts | Nessuno.

Autorizzazioni associate con i ruoli di MSF for Agile Software Development

Se si è creato il progetto Team con il modello di processo di MSF for Agile Software Development, è possibile che si desideri assegnare gli utenti ai gruppi che corrispondono ai ruoli per MSF for Agile Software Development. Questa operazione può essere eseguita in due modi. È possibile assegnare gli utenti al gruppo predefinito che più si allinea alle autorizzazioni necessarie per ciascun ruolo. In alternativa, è possibile creare dei gruppi per ciascun ruolo, assegnare le autorizzazioni appropriate al gruppo, quindi aggiungere gli utenti che svolgono tale ruolo.

Assegnazione di utenti ai gruppi predefiniti in base ai ruoli di MSF for Agile Software Development

È possibile assegnare degli utenti ai gruppi predefiniti in base ai rispettivi ruoli di MSF for Agile Software Development. Sebbene questi gruppi non corrispondano direttamente a ciascun ruolo, è relativamente semplice aggiungere degli utenti a questi gruppi e non è necessario creare nuovi gruppi e aggiungere autorizzazioni per i gruppi ai livelli di server, progetto, area e controllo del codice sorgente. Purtroppo, però, in questo modo si perde parte della granularità dell'autorizzazione e del controllo di cui si può disporre mediante l'aggiunta di gruppi in base a ciascun ruolo.

Nella tabella seguente viene illustrato quale gruppo predefinito si allinea meglio con ciascun ruolo di MSF for Agile Software Development. Per ulteriori informazioni su MSF for Agile Software Development e i relativi ruoli, vedere il sito Web di MSF for Agile Software Development all'indirizzo http://go.microsoft.com/fwlink/?linkid=55200&clcid=0x409.

Ruolo Agile | Aggiungi a gruppo predefinito
Progettista | Collaboratore
Business Analyst | Collaboratore
Sviluppatore | Collaboratore
Responsabile di progetto | Amministratore di progetto
Responsabile del rilascio | Amministratore di progetto
Tester | Collaboratore

Creazione di gruppi che corrispondono ai ruoli di MSF for Agile Software Development e assegnazione delle autorizzazioni

È possibile creare dei gruppi personalizzati in base a ciascun ruolo di MSF for Agile Software Development e assegnare a tali gruppi degli utenti. Se si creano questi gruppi invece di utilizzare i gruppi predefiniti, si esercita un maggiore controllo sui ruoli e sulle autorizzazioni. Tuttavia è necessario creare nuovi gruppi e aggiungere le autorizzazioni per i gruppi ai livelli di server, progetto, area e controllo del codice sorgente.

Nota Nota

Se si creano dei gruppi personalizzati che corrispondono a dei ruoli, è necessario impostare le autorizzazioni appropriate per ciascun gruppo nuovo in Windows SharePoint Services, in Reporting Services e in Active Directory o Utenti e gruppi locali sui computer Team Foundation Server, senza dimenticare le autorizzazioni Team Foundation Server.

Nella tabella seguente viene illustrato quali autorizzazioni sono appropriate per ciascun ruolo di MSF for Agile Software Development. Per una descrizione completa di ciascuna autorizzazione, vedere Autorizzazioni per Team Foundation Server.

Ruolo Agile | Server | Progetto | Area | Controllo del codice sorgente
Progettista |  | Avvia generazione Visualizza informazioni a livello di progetto | Modifica elementi di lavoro in questo nodo Visualizza questo nodo Visualizza elementi di lavoro in questo nodo | Leggi Estrai Archivia Etichetta Blocca
Business Analyst |  | Visualizza informazioni a livello di progetto | Visualizza questo nodo Visualizza elementi di lavoro in questo nodo | Nessuna
Sviluppatore |  | Visualizza informazioni a livello di progetto Avvia generazione | Modifica elementi di lavoro in questo nodo Visualizza questo nodo Visualizza elementi di lavoro in questo nodo | Leggi Estrai Archivia Etichetta Blocca
Responsabile di progetto | Crea nuovi progetti Gestisci modello di processo | Visualizza informazioni a livello di progetto Amministra generazione Elimina questo progetto Modifica informazioni a livello di progetto Avvia generazione | Crea e ordina nodi figlio Elimina questo nodo Modifica questo nodo Modifica elementi di lavoro in questo nodo Visualizza questo nodo Visualizza elementi di lavoro in questo nodo | Leggi Estrai Archivia Etichetta Blocca Esamina modifiche di altri utenti Sblocca modifiche di altri utenti Annulla modifiche di altri utenti Amministra etichette Modifica impostazioni di protezione Archivia modifiche di altri utenti
Responsabile del rilascio |  | Visualizza informazioni a livello di progetto Modifica informazioni a livello di progetto | Modifica elementi di lavoro in questo nodo Visualizza questo nodo Visualizza elementi di lavoro in questo nodo | Nessuna
Tester |  | Visualizza informazioni a livello di progetto Modifica qualità generazione Pubblica risultati test | Modifica elementi di lavoro in questo nodo Visualizza questo nodo Visualizza elementi di lavoro in questo nodo | Leggi Estrai Archivia Etichetta Blocca

Autorizzazioni associate con i ruoli di MSF for CMMI Process Improvement

Se si è creato il progetto Team con il modello di processo di MSF for CMMI Process Improvement, è possibile che si desideri assegnare gli utenti ai gruppi che corrispondono ai ruoli per MSF for CMMI Process Improvement. Questa operazione può essere eseguita in due modi. È possibile assegnare gli utenti al gruppo predefinito che più si allinea alle autorizzazioni necessarie per ciascun ruolo. In alternativa, è possibile creare dei gruppi per ciascun ruolo, assegnare le autorizzazioni appropriate al gruppo, quindi aggiungere gli utenti che svolgono tale ruolo.

Per ulteriori informazioni su MSF for CMMI Process Improvement e i relativi ruoli, vedere il sito Web di MSF for CMMI Process Improvement all'indirizzo http://go.microsoft.com/fwlink/?linkid=55203&clcid=0x409.

Assegnazione di utenti ai gruppi predefiniti in base ai ruoli di MSF for CMMI Process Improvement

È possibile assegnare degli utenti ai gruppi predefiniti in base ai rispettivi ruoli di MSF for CMMI Process Improvement. Sebbene questi gruppi non corrispondano direttamente a ciascun ruolo, è relativamente semplice aggiungere degli utenti a questi gruppi e non è necessario creare nuovi gruppi e aggiungere autorizzazioni per i gruppi ai livelli di server, progetto, area e controllo del codice sorgente. Purtroppo, però, in questo modo si perde parte della granularità dell'autorizzazione e del controllo di cui si può disporre mediante l'aggiunta di gruppi in base a ciascun ruolo.

Nella tabella seguente viene illustrato quale gruppo predefinito si allinea meglio con ciascun ruolo di MSF for CMMI Process Improvement.

Ruolo CMMI | Aggiungi a gruppo predefinito
Controllore | Collaboratore
Ingegnere di generazione | Amministratore di progetto
Business Analyst | Collaboratore
Sviluppatore | Collaboratore
Responsabile di sviluppo | Amministratore di progetto
Progettista infrastrutture | Collaboratore
Responsabile IPM | Collaboratore
Sviluppatore responsabile | Amministratore di progetto
Responsabile di prodotto | Collaboratore
Responsabile di progetto | Amministratore di progetto
Responsabile del rilascio | Amministratore di progetto
Progettista soluzione | Collaboratore
Sponsor | Lettore
Esperto in materia | Lettore
Gestione test | Amministratore di progetto
Tester | Collaboratore
Progettista formazione utente | Collaboratore
Specialista esperienza utente | Collaboratore

Creazione di gruppi che corrispondono ai ruoli di MSF for CMMI Process Improvement e assegnazione delle autorizzazioni

È possibile creare dei gruppi personalizzati in base a ciascun ruolo di MSF for CMMI Process Improvement e assegnare a tali gruppi degli utenti. Questi gruppi offrono una granularità e un controllo maggiori rispetto ai gruppi predefiniti. Tuttavia è necessario creare nuovi gruppi e aggiungere le autorizzazioni per i gruppi ai livelli di server, progetto, area e controllo del codice sorgente. Poiché per MSF for CMMI Process Improvement sono definiti molti ruoli, considerare attentamente il livello di controllo e la granularità necessari per il progetto prima di iniziare a creare gruppi per ciascun ruolo.

Nota Nota

Se si creano dei gruppi personalizzati che corrispondono a dei ruoli, è necessario impostare le autorizzazioni appropriate per ciascun gruppo nuovo in Windows SharePoint Services, in SQL Reporting Services e in Active Directory o Utenti e gruppi locali sui computer Team Foundation Server, senza dimenticare le autorizzazioni Team Foundation Server.

Nella tabella seguente viene illustrato quali autorizzazioni sono appropriate per ciascun ruolo di MSF for CMMI Process Improvement. Per una descrizione completa di ciascuna autorizzazione, vedere Autorizzazioni per Team Foundation Server.

Ruolo CMMI | Server | Progetto | Area | Controllo del codice sorgente
Controllore |  | Visualizza informazioni a livello di progetto | Visualizza questo nodo Visualizza elementi di lavoro in questo nodo Modifica elementi di lavoro in questo nodo | Nessuna
Ingegnere di generazione |  | Visualizza informazioni a livello di progetto | Visualizza questo nodo Visualizza elementi di lavoro in questo nodo Modifica elementi di lavoro in questo nodo | Leggi Estrai Archivia Etichetta Blocca
Business Analyst |  | Visualizza informazioni a livello di progetto | Visualizza questo nodo Visualizza elementi di lavoro in questo nodo Modifica elementi di lavoro in questo nodo | Nessuna
Sviluppatore |  | Visualizza informazioni a livello di progetto | Visualizza questo nodo Visualizza elementi di lavoro in questo nodo Modifica elementi di lavoro in questo nodo | Leggi Estrai Archivia Etichetta Blocca
Responsabile di sviluppo |  | Visualizza informazioni a livello di progetto | Visualizza questo nodo Visualizza elementi di lavoro in questo nodo Modifica elementi di lavoro in questo nodo | Leggi Estrai Archivia Etichetta Blocca
Progettista infrastrutture |  | Visualizza informazioni a livello di progetto | Visualizza questo nodo Visualizza elementi di lavoro in questo nodo Modifica elementi di lavoro in questo nodo | Leggi Estrai Archivia Etichetta Blocca
Responsabile IPM |  | Visualizza informazioni a livello di progetto | Visualizza questo nodo Visualizza elementi di lavoro in questo nodo Modifica elementi di lavoro in questo nodo | Nessuna
Sviluppatore responsabile |  | Visualizza informazioni a livello di progetto | Visualizza questo nodo Visualizza elementi di lavoro in questo nodo Modifica elementi di lavoro in questo nodo | Leggi Estrai Archivia Etichetta Blocca
Responsabile di prodotto |  | Visualizza informazioni a livello di progetto | Visualizza questo nodo Visualizza elementi di lavoro in questo nodo Modifica elementi di lavoro in questo nodo | Leggi Estrai Archivia Etichetta Blocca
Responsabile di progetto | Crea nuovi progetti Gestisci modello di processo | Visualizza informazioni a livello di progetto | Visualizza questo nodo Visualizza elementi di lavoro in questo nodo Modifica elementi di lavoro in questo nodo | Leggi Estrai Archivia Etichetta Blocca
Responsabile del rilascio |  | Visualizza informazioni a livello di progetto | Visualizza questo nodo Visualizza elementi di lavoro in questo nodo Modifica elementi di lavoro in questo nodo | Leggi
Progettista soluzione |  | Visualizza informazioni a livello di progetto Avvia generazione | Visualizza questo nodo Visualizza elementi di lavoro in questo nodo Modifica elementi di lavoro in questo nodo | Leggi Estrai Archivia Etichetta Blocca
Sponsor |  | Visualizza informazioni a livello di progetto | Visualizza questo nodo Visualizza elementi di lavoro in questo nodo | Nessuna
Esperto in materia |  | Visualizza informazioni a livello di progetto | Visualizza questo nodo Visualizza elementi di lavoro in questo nodo | Nessuna
Gestione test |  | Visualizza informazioni a livello di progetto | Visualizza questo nodo Visualizza elementi di lavoro in questo nodo Modifica elementi di lavoro in questo nodo | Leggi Estrai Archivia Etichetta Blocca
Tester |  | Visualizza informazioni a livello di progetto | Visualizza questo nodo Visualizza elementi di lavoro in questo nodo Modifica elementi di lavoro in questo nodo | Leggi Estrai Archivia Etichetta Blocca
Progettista formazione utente |  | Visualizza informazioni a livello di progetto | Visualizza questo nodo Visualizza elementi di lavoro in questo nodo Modifica elementi di lavoro in questo nodo | Leggi
Specialista esperienza utente |  | Visualizza informazioni a livello di progetto | Visualizza questo nodo Visualizza elementi di lavoro in questo nodo Modifica elementi di lavoro in questo nodo | Leggi Estrai Archivia Etichetta Blocca

Vedere anche

Attività

Procedura: creare un gruppo a livello di server
Procedura: creare un gruppo di progetto Team
Procedura: modificare le autorizzazioni per un gruppo o un utente
Procedura: visualizzare le autorizzazioni

Concetti

Aggiunta e rimozione di utenti dai gruppi
Autorizzazioni per Team Foundation Server
Autorizzazioni di collaboratore per Team Foundation Server

Altre risorse

Gestione di gruppi
Gestione di utenti
Autorizzazioni di amministratore di Team Foundation Server
Autorizzazioni di coordinatore del progetto di Team Foundation Server
Visualizzazione e modifica delle autorizzazioni
Comandi dell'utilità della riga di comando TFSSecurity


Autorizzazioni di amministratore di Team Foundation Server

 elenco a discesa elenco a discesa attivabile
Autorizzazioni di amministratore di Team Foundation Server
Vedere anche
elenco a discesa

Per potere ricoprire ruoli diversi nell'ambito di Team Foundation gli utenti devono disporre delle autorizzazioni necessarie per Team Foundation Server, Reporting Services e Windows SharePoint Services. In questa sezione vengono elencate le autorizzazioni necessarie per un amministratore di Team Foundation Server e viene indicato come ottenere ulteriori informazioni sull'impostazione di tali autorizzazioni.

Tra tutti gli utenti di Team Foundation Server, i membri del gruppo Administrators di Team Foundation Server dispongono del maggior numero di privilegi. Gli amministratori sono preposti alla gestione di Team Foundation Server, nonché all'amministrazione delle autorizzazioni e della protezione per tutti gli altri ruoli. Per la maggior parte delle organizzazioni che utilizzano Team Foundation Server, la stessa persona sarà responsabile della creazione e della gestione dei progetti e della personalizzazione delle linee guida per il processo. Un amministratore di Team Foundation Server deve essere membro dei seguenti gruppi:

  • Administrators o Domain Administrators sia per il server a livello applicazione che per il server a livello dati.

  • Administrators di Team Foundation Server.

  • Administrators di Windows SharePoint Services.

  • Gestione contenuto di SQL Server Reporting Services.

  • Amministratore sistema di SQL Server Reporting Services.

  • Negli argomenti seguenti viene illustrato come impostare queste autorizzazioni.

In questa sezione

Procedura: impostare le autorizzazioni di amministratore per Team Foundation Server

Viene descritto come impostare le autorizzazioni di amministratore per Team Foundation Server.

Procedura: impostare le autorizzazioni di amministratore per Windows SharePoint Services

Viene descritto come impostare le autorizzazioni di amministratore per Windows SharePoint Services.

Procedura: impostare le autorizzazioni di amministratore per Reporting Services

Viene descritto come impostare le autorizzazioni Gestione contenuto e Amministratore sistema per SQL Server Reporting Services.

Vedere anche

Concetti

Autorizzazioni di collaboratore per Team Foundation Server

Altre risorse

Gestione delle autorizzazioni
Autorizzazioni di coordinatore del progetto di Team Foundation Server


Procedura: impostare le autorizzazioni di amministratore per Team Foundation Server

Procedura: impostare le autorizzazioni di amministratore per Team Foundation Server
Vedere anche

Per configurare un utente nel ruolo di amministratore di Team Foundation Server, è necessario impostare la autorizzazioni nei gruppi di Team Foundation Server, Windows SharePoint Services e Reporting Services. È inoltre necessario impostare le autorizzazioni per i gruppi dei computer Team Foundation a livello dati e applicazione in base alle esigenze. In questo argomento viene descritto come impostare le autorizzazioni sui server Team Foundation per un amministratore di Team Foundation Server.

Nota Nota

È necessario essere un amministratore di Team Foundation Server per completare questa procedura.

Per aggiungere un membro al gruppo Administrators di Team Foundation

  1. In Visual Studio aprire Team Foundation e connettersi al server Team Foundation Server per cui si desidera impostare le autorizzazioni.

  2. Fare clic con il pulsante destro del mouse sul server Team Foundation Server, scegliere Impostazioni di Team Foundation Server, quindi fare clic su Appartenenza a gruppo.

  3. Selezionare Server\Administrators di Team Foundation, quindi fare clic su Proprietà.

  4. In Aggiungi utenti e gruppi selezionare Utente o gruppo Windows, quindi scegliere Aggiungi.

  5. Aggiungere il nome di accesso Windows della persona alla quale si desidera concedere le autorizzazioni, quindi scegliere OK.

Oltre a completare questa procedura, è necessario concedere le autorizzazioni di amministratore per Reporting Services e Windows SharePoint Services per aggiungere una persona al ruolo di amministratore di Team Foundation Server. Per ulteriori informazioni su queste procedure, vedere Procedura: impostare le autorizzazioni di amministratore per Reporting Services e Procedura: impostare le autorizzazioni di amministratore per Windows SharePoint Services.

Protezione

Non concedere mai troppe autorizzazioni a un singolo utente, né autorizzazioni a un membro non affidabile per non rischiare di compromettere l'integrità del server e della rete.

Vedere anche

Attività

Procedura: impostare le autorizzazioni di amministratore per Reporting Services
Procedura: impostare le autorizzazioni di amministratore per Windows SharePoint Services

Concetti

Server a livello applicazione di Team Foundation
Server a livello dati di Team Foundation

Altre risorse

Autorizzazioni di amministratore di Team Foundation Server


Procedura: impostare le autorizzazioni di amministratore per Windows SharePoint Services

Procedura: impostare le autorizzazioni di amministratore per Windows SharePoint Services
Vedere anche

Per aggiungere una persona nel ruolo di amministratore di Team Foundation Server, è necessario impostare le autorizzazioni nei gruppi di Team Foundation Server, Windows SharePoint Services e Reporting Services. È inoltre necessario impostare le autorizzazioni per i gruppi dei computer Team Foundation a livello dati e applicazione in base alle esigenze. In questo argomento viene descritto come impostare le autorizzazioni in Windows SharePoint Services per un amministratore del sito di Windows SharePoint Services.

Nota Nota

È necessario essere un amministratore di Windows SharePoint Services per potere completare questa procedura.

Per aggiungere un membro al gruppo amministrativo di SharePoint

  1. Nel livello applicazione di Team Foundation, fare clic sul pulante Start, scegliere Strumenti di amministrazione, quindi selezionare Amministrazione centrale SharePoint.

  2. In Amministrazione centrale fare clic su Imposta gruppo amministrativo di SharePoint.

  3. In Imposta gruppo amministrativo di SharePoint digitare il nome dell'account e il dominio, se applicabile, per il gruppo.

    Nota Nota

    Al gruppo amministrativo di SharePoint è possibile aggiungere solo un utente o gruppo di dominio, ma non un gruppo locale. Tuttavia i membri del gruppo Administrators locale sul server possono anche eseguire attività amministrative per prodotti e tecnologie Windows SharePoint Services.

  4. Scegliere OK.

Per aggiungere un membro al gruppo amministrativo del sito di Windows SharePoint Services per il sito principale

  1. Aprire Internet Explorer.

  2. Immettere il nome del server a livello applicazione nella barra dell'indirizzo di Internet Explorer per aprire il sito principale di Windows SharePoint Services.

  3. Fare clic su Impostazioni sito, Vai all'amministrazione del sito e quindi Gestione utenti.

  4. Fare clic su Aggiungi utenti.

  5. Nel Passaggio 1: scelta degli utenti aggiungere l'alias per la persona alla quale si desidera concedere le autorizzazioni di amministrazione per l'intero sito.

  6. Nel Passaggio 2: scelta dei gruppi del sito selezionare Amministratore, quindi scegliere Avanti.

  7. Nel Passaggio 3: conferma degli utenti aggiungere l'indirizzo di posta elettronica dell'utente.

  8. Nel Passaggio 4: invio di posta elettronica scegliere se inviare automaticamente all'utente un messaggio di posta elettronica.

  9. Scegliere Fine.

Oltre a completare questa procedura, è necessario concedere le autorizzazioni per Team Foundation Server e Reporting Services per aggiungere una persona al ruolo di amministratore di Team Foundation Server. Per ulteriori informazioni su queste procedure, vedere Procedura: impostare le autorizzazioni di amministratore per Reporting Services e Procedura: impostare le autorizzazioni di amministratore per Team Foundation Server.

Protezione

Non concedere mai troppe autorizzazioni a un singolo utente, né autorizzazioni a un membro non affidabile per non rischiare di compromettere l'integrità del server e della rete.

Vedere anche

Attività

Procedura: impostare le autorizzazioni di amministratore per Team Foundation Server
Procedura: impostare le autorizzazioni di amministratore per Reporting Services

Concetti

Team Foundation Server Application Tier
Team Foundation Server Data Tier

Altre risorse

Autorizzazioni di amministratore di Team Foundation Server


Procedura: impostare le autorizzazioni di amministratore per Reporting Services

Procedura: impostare le autorizzazioni di amministratore per Reporting Services
Vedere anche

Per aggiungere una persona nel ruolo di amministratore di Team Foundation Server, è necessario impostare le autorizzazioni nei gruppi di Team Foundation Server, Windows SharePoint Services e Reporting Services. È inoltre necessario impostare le autorizzazioni per i gruppi dei computer Team Foundation a livello dati e applicazione in base alle esigenze. In questo argomento viene descritto come impostare le autorizzazioni in Reporting Services per un amministratore del sito di Reporting Services.

Nota Nota

Per completare questa procedura è necessario disporre delle autorizzazioni di amministratore di sito di Reporting Services.

Per aggiungere un membro ai ruoli di amministratore di sistema e responsabile della gestione del contenuto di Reporting Services

  1. Aprire Internet Explorer.

  2. Nella barra dell'indirizzo digitare quanto segue:

    http:// data-tier /Reports/Pages/Folder.aspx

    dove data-tier è il nome del server Team Foundation di report a livello dati. Per determinare il nome del server di report, aprire Team Explorer, espandere il nodo Report e visualizzare le proprietà di un report.

  3. Fare clic sulla scheda Proprietà, quindi fare clic su Nuova assegnazione ruolo.

  4. In Nome gruppo o utente aggiungere il nome di accesso Windows per la persona alla quale si desidera concedere le autorizzazioni di Gestione contenuto.

  5. In Ruolo selezionare Gestione contenuto, quindi scegliere OK.

  6. Fare clic su Impostazioni sito e quindi su Configura protezione a livello di sito.

  7. Fare clic su Nuova assegnazione ruolo.

  8. In Nome gruppo o utente aggiungere il nome di accesso Windows per la persona alla quale si desidera concedere le autorizzazioni di Amministratore sistema.

  9. In Ruolo selezionare Amministratore di sistema, quindi scegliere OK.

Oltre a completare questa procedura, è necessario concedere le autorizzazioni di amministratore per Team Foundation Server e Windows SharePoint Services per aggiungere una persona al ruolo di amministratore di Team Foundation Server. Per ulteriori informazioni su queste procedure, vedere Procedura: impostare le autorizzazioni di amministratore per Team Foundation Server e Procedura: impostare le autorizzazioni di amministratore per Windows SharePoint Services.

Protezione

Non concedere mai troppe autorizzazioni a un singolo utente, né autorizzazioni a un membro non affidabile per non rischiare di compromettere l'integrità del server e della rete.

Vedere anche

Attività

Procedura: impostare le autorizzazioni di amministratore per Team Foundation Server
Procedura: impostare le autorizzazioni di amministratore per Windows SharePoint Services

Concetti

Team Foundation Server Application Tier
Team Foundation Server Data Tier

Altre risorse

Autorizzazioni di amministratore di Team Foundation Server


Autorizzazioni di coordinatore del progetto di Team Foundation Server

 elenco a discesa elenco a discesa attivabile
Autorizzazioni di coordinatore del progetto di Team Foundation Server
Vedere anche
elenco a discesa

Per potere ricoprire ruoli diversi nell'ambito di Team Foundation gli utenti devono disporre delle autorizzazioni necessarie per Team Foundation Server, Reporting Services e Windows SharePoint Services. In questa sezione vengono elencate le autorizzazioni necessarie per un coordinatore del progetto di Team Foundation Server e viene indicato come ottenere ulteriori informazioni sull'impostazione di tali autorizzazioni.

Il coordinatore di un progetto Team Foundation Server è in genere responsabile di un progetto Team e può creare e gestire un database degli elementi di lavoro e un portale di un progetto Team, nonché gestire le autorizzazioni e la protezione per il progetto Team. La creazione di un nuovo progetto Team è consentita solo ai membri del gruppo Administrators di Team Foundation. Nella maggior parte dei casi, per poter assumere il ruolo di coordinatore di un progetto Team, l'amministratore di Team Foundation deve aggiungere un utente o un gruppo al progetto. Un coordinatore di un progetto Team deve essere membro dei seguenti gruppi:

  • Project Administrators di Team Foundation Server.

  • Administrators di Windows SharePoint Services.

  • Gestione contenuto di SQL Server Reporting Services.

In questa sezione

Procedura: impostare le autorizzazioni di coordinatore del progetto per Team Foundation Server

Viene descritto come impostare le autorizzazioni di coordinatore di progetto per Team Foundation Server.

Procedura: impostare le autorizzazioni di coordinatore del progetto per Windows SharePoint Services

Viene descritto come impostare le autorizzazioni di coordinatore di progetto per Windows SharePoint Services.

Procedura: impostare le autorizzazioni di coordinatore del progetto per Reporting Services

Viene descritto come impostare le autorizzazioni Gestione contenuto per SQL Server Reporting Services.

Vedere anche

Concetti

Autorizzazioni di collaboratore per Team Foundation Server
Autorizzazioni per Team Foundation Server
Gruppi predefiniti, autorizzazioni e ruoli di Team Foundation Server

Altre risorse

Gestione delle autorizzazioni
Autorizzazioni di amministratore di Team Foundation Server


Procedura: impostare le autorizzazioni di coordinatore del progetto per Team Foundation Server

Procedura: impostare le autorizzazioni di coordinatore del progetto per Team Foundation Server
Vedere anche

Per aggiungere una persona nel ruolo di collaboratore per un progetto Team, è necessario impostare la autorizzazioni nei gruppi di Team Foundation Server, Windows SharePoint Services e Reporting Services. In questo argomento viene descritto come impostare le autorizzazioni in Team Foundation Server per un responsabile del contenuto a livello di progetto Team.

Nota Nota

È necessario essere un amministratore di Team Foundation Server per completare questa procedura.

Per aggiungere un membro al gruppo Project Administrators

  1. In Visual Studio aprire Team Explorer e connettersi a Team Foundation Server.

  2. Fare clic con il pulsante destro del mouse sul nodo del progetto Team, scegliere Impostazioni progetto Team, quindi Appartenenza a gruppo.

  3. Selezionare [Project_Name]\Project Administrators, dove Project_Name rappresenta il nome del progetto a cui si desidera aggiungere un amministratore, quindi fare clic su Proprietà.

  4. In Aggiungi utenti e gruppi selezionare Utente o gruppo Windows, quindi scegliere Aggiungi.

  5. Aggiungere il nome di accesso Windows della persona o del gruppo a cui si desidera concedere le autorizzazioni, quindi scegliere OK.

Oltre a completare questa procedura, è necessario concedere le autorizzazioni di coordinatore di progetto per Reporting Services e Windows SharePoint Services per aggiungere una persona al ruolo di coordinatore del progetto Team. Per ulteriori informazioni su queste procedure, vedere Procedura: impostare le autorizzazioni di coordinatore del progetto per Reporting Services e Procedura: impostare le autorizzazioni di coordinatore del progetto per Windows SharePoint Services.

Protezione

Non concedere mai troppe autorizzazioni a un singolo utente, né autorizzazioni a un membro non affidabile per non rischiare di compromettere l'integrità del server e della rete.

Vedere anche

Attività

Procedura: impostare le autorizzazioni di coordinatore del progetto per Reporting Services
Procedura: impostare le autorizzazioni di coordinatore del progetto per Windows SharePoint Services

Altre risorse

Autorizzazioni di coordinatore del progetto di Team Foundation Server


Procedura: impostare le autorizzazioni di coordinatore del progetto per Windows SharePoint Services

Procedura: impostare le autorizzazioni di coordinatore del progetto per Windows SharePoint Services
Vedere anche

Per aggiungere una persona nel ruolo di collaboratore per un progetto Team, è necessario impostare la autorizzazioni nei gruppi di Team Foundation Server, Windows SharePoint Services e Reporting Services. In questo argomento viene descritto come impostare le autorizzazioni di responsabile del contenuto di un progetto Team per Windows SharePoint Services.

Nota Nota

È necessario essere un amministratore del sito di Windows SharePoint Services per potere completare questa procedura.

Per aggiungere un membro al gruppo amministrativo di Windows SharePoint Services per il sito del progetto

  1. In Visual Studio aprire Team Explorer e connettersi a Team Foundation Server.

  2. Fare clic con il pulsante destro del mouse sul nodo del progetto Team e scegliere Mostra portale progetto.

  3. Fare clic su Impostazioni sito, Vai all'amministrazione del sito e quindi Gestione utenti.

  4. Fare clic su Aggiungi utenti.

  5. Nel Passaggio 1: scelta degli utenti aggiungere il nome di accesso Windows per la persona alla quale si desidera concedere le autorizzazioni di amministrazione per l'intero sito.

  6. Nel Passaggio 2: scelta dei gruppi del sito selezionare Amministratore, quindi scegliere Avanti.

  7. Nel Passaggio 3: conferma degli utenti aggiungere l'indirizzo di posta elettronica dell'utente.

  8. Nel Passaggio 4: invio di posta elettronica scegliere se inviare automaticamente all'utente un messaggio di posta elettronica, quindi fare clic su Fine.

Al termine della procedura, è necessario concedere le autorizzazioni di coordinatore di progetto per Reporting Services e Windows SharePoint Services per aggiungere una persona al ruolo di coordinatore del progetto Team. Per ulteriori informazioni su queste procedure, vedere Procedura: impostare le autorizzazioni di coordinatore del progetto per Reporting Services e Procedura: impostare le autorizzazioni di coordinatore del progetto per Windows SharePoint Services.

Protezione

Non concedere mai troppe autorizzazioni a un singolo utente, né autorizzazioni a un membro non affidabile per non rischiare di compromettere l'integrità del server e della rete.

Vedere anche

Attività

Procedura: impostare le autorizzazioni di coordinatore del progetto per Team Foundation Server
Procedura: impostare le autorizzazioni di coordinatore del progetto per Reporting Services

Altre risorse

Autorizzazioni di coordinatore del progetto di Team Foundation Server


Procedura: impostare le autorizzazioni di coordinatore del progetto per Reporting Services

Procedura: impostare le autorizzazioni di coordinatore del progetto per Reporting Services
Vedere anche

Per aggiungere una persona nel ruolo di coordinatore del progetto Team, è necessario impostare la autorizzazioni nei gruppi di Team Foundation Server, Windows SharePoint Services e Reporting Services. In questo argomento viene descritto come impostare le autorizzazioni di responsabile della gestione del contenuto di un progetto Team per Reporting Services.

Nota Nota

È necessario essere un amministratore di sito o un responsabile della gestione del contenuto di Reporting Services per potere completare questa procedura.

Per aggiungere un membro al ruolo di responsabile della gestione del contenuto di Reporting Services

  1. Aprire Internet Explorer.

  2. Nella barra dell'indirizzo digitare quanto segue:

    http:// data-tier /Reports/Pages/Folders.aspx

    dove data-tier è il nome del server Team Foundation di report a livello dati. Per determinare il nome del server di report, aprire Team Explorer, espandere il nodo Report e visualizzare le proprietà di un report.

  3. Fare clic sulla scheda Proprietà, quindi fare clic su Nuova assegnazione ruolo.

  4. In Nome gruppo o utente aggiungere il nome di accesso Windows per la persona che si desidera aggiungere a questo gruppo.

  5. In Ruolo selezionare Gestione contenuto, quindi scegliere OK.

Oltre a completare questa procedura, è necessario concedere le autorizzazioni di coordinatore del progetto per Team Foundation Server e Windows SharePoint Services per aggiungere una persona al ruolo di coordinatore del progetto Team. Per ulteriori informazioni su queste procedure, vedere Procedura: impostare le autorizzazioni di coordinatore del progetto per Team Foundation Server e Procedura: impostare le autorizzazioni di coordinatore del progetto per Windows SharePoint Services.

Protezione

Non concedere mai troppe autorizzazioni a un singolo utente, né autorizzazioni a un membro non affidabile per non rischiare di compromettere l'integrità del server e della rete.

Vedere anche

Attività

Procedura: impostare le autorizzazioni di coordinatore del progetto per Team Foundation Server
Procedura: impostare le autorizzazioni di coordinatore del progetto per Windows SharePoint Services

Altre risorse

Autorizzazioni di coordinatore del progetto di Team Foundation Server


Autorizzazioni di collaboratore per Team Foundation Server

 elenco a discesa elenco a discesa attivabile
Autorizzazioni di collaboratore per Team Foundation Server
Vedere anche
elenco a discesa

Per potere ricoprire ruoli diversi nell'ambito di Team Foundation gli utenti devono disporre delle autorizzazioni necessarie per Team Foundation Server, Reporting Services e Windows SharePoint Services. In questa sezione vengono elencate le autorizzazioni necessarie per un collaboratore del progetto di Team Foundation Server e viene indicato come ottenere ulteriori informazioni sull'impostazione di tali autorizzazioni.

Collaboratore di progetto di Team Foundation

In genere un collaboratore di progetto di Team Foundation partecipa a un progetto ma non ha alcuna responsabilità di amministrazione. Un collaboratore di progetto di Team Foundation è in grado di leggere e scrivere gli elementi di lavoro, accedere al portale del progetto Team ed elaborare le linee guida per il processo di un progetto Team. L'utente che crea un nuovo progetto Team viene automaticamente aggiunto in qualità di collaboratore di progetto. Se si desidera concedere l'accesso ad altri utenti, è necessario aggiungerli come collaboratori di progetto. Un collaboratore di un progetto Team deve essere un membro dei seguenti gruppi:

  • Contributors del progetto Team Foundation

  • Collaboratore di Windows SharePoint Services

  • Esplorazione di SQL Server Reporting Services

Negli argomenti seguenti viene illustrato come impostare queste autorizzazioni.

Procedura: impostare le autorizzazioni di collaboratore per Reporting Services

Viene descritto come impostare le autorizzazioni di collaboratore per SQL Server Reporting Services.

Procedura: impostare le autorizzazioni di collaboratore per Team Foundation Server

Viene illustrato come impostare le autorizzazioni di collaboratore per Team Foundation Server.

Procedura: impostare le autorizzazioni dei collaboratori per Windows SharePoint Services

Viene descritto come impostare le autorizzazioni di collaboratore per Windows SharePoint Services.

Vedere anche

Concetti

Autorizzazioni per Team Foundation Server
Gruppi predefiniti, autorizzazioni e ruoli di Team Foundation Server

Altre risorse

Gestione delle autorizzazioni
Autorizzazioni di coordinatore del progetto di Team Foundation Server
Autorizzazioni di amministratore di Team Foundation Server


Procedura: impostare le autorizzazioni di collaboratore per Team Foundation Server

Procedura: impostare le autorizzazioni di collaboratore per Team Foundation Server
Vedere anche

Per aggiungere una persona nel ruolo di collaboratore di progetto Team, è necessario impostare le autorizzazioni nei gruppi di Team Foundation Server, Windows SharePoint Services e Reporting Services. In questo argomento viene descritto come impostare le autorizzazioni di collaboratore di progetto Team per Team Foundation Server.

Nota Nota

Per completare questa procedura è necessario essere un amministratore di Team Foundation o di progetto.

Per aggiungere un membro al gruppo Contributors

  1. In Visual Studio aprire Team Explorer e connettersi a Team Foundation Server.

  2. Fare clic con il pulsante destro del mouse sul nodo del progetto Team, scegliere Impostazioni progetto Team, quindi Appartenenza a gruppo.

  3. Selezionare Project_Name\Contributors, dove Project_Name rappresenta il nome del progetto a cui si desidera aggiungere un collaboratore, quindi fare clic su Proprietà.

  4. In Aggiungi utenti e gruppi selezionare Utente o gruppo Windows, quindi scegliere Aggiungi.

  5. Aggiungere il nome di accesso Windows della persona che si desidera aggiungere al gruppo Contributors.

  6. Scegliere OK.

Oltre a completare questa procedura, è necessario concedere le autorizzazioni di collaboratore per Reporting Services e Windows SharePoint Services per aggiungere una persona al ruolo di collaboratore di progetto Team. Per ulteriori informazioni su queste procedure, vedere Procedura: impostare le autorizzazioni di collaboratore per Reporting Services e Procedura: impostare le autorizzazioni dei collaboratori per Windows SharePoint Services.

Protezione

Non concedere mai troppe autorizzazioni a un singolo utente, né autorizzazioni a un membro non affidabile per non rischiare di compromettere l'integrità del server e della rete.

Vedere anche

Attività

Procedura: impostare le autorizzazioni di collaboratore per Reporting Services
Procedura: impostare le autorizzazioni dei collaboratori per Windows SharePoint Services

Concetti

Autorizzazioni di collaboratore per Team Foundation Server


Procedura: impostare le autorizzazioni dei collaboratori per Windows SharePoint Services

Procedura: impostare le autorizzazioni dei collaboratori per Windows SharePoint Services
Vedere anche

Per aggiungere una persona nel ruolo di collaboratore di progetto Team, è necessario impostare le autorizzazioni nei gruppi di Team Foundation Server, Windows SharePoint Services e Reporting Services. In questo argomento viene descritto come impostare le autorizzazioni di collaboratore di progetto Team per Windows SharePoint Services.

Nota Nota

È necessario essere un amministratore del sito Windows SharePoint Services o un amministratore a livello di progetto per potere completare questa procedura.

Per aggiungere un membro al gruppo dei collaboratori di Windows SharePoint Services

  1. Avviare Visual Studio e in Team Explorer connettersi a Team Foundation Server.

  2. Fare clic con il pulsante destro del mouse sul nodo del progetto Team e scegliere Mostra portale progetto.

  3. Fare clic su Impostazioni sito e quindi Gestione utenti.

  4. Fare clic su Aggiungi utenti.

  5. Nel Passaggio 1: scelta degli utenti aggiungere il nome di accesso Windows per la persona alla quale si desidera concedere le autorizzazioni di amministrazione per l'intero sito.

  6. Nel Passaggio 2: scelta dei gruppi del sito selezionare Collaboratore, quindi scegliere Avanti.

  7. Nel Passaggio 3: conferma degli utenti aggiungere l'indirizzo di posta elettronica dell'utente.

  8. Nel Passaggio 4: invio di posta elettronica scegliere se inviare automaticamente all'utente un messaggio di posta elettronica.

  9. Scegliere Fine.

Oltre a completare questa procedura, è necessario concedere al collaboratore le autorizzazioni per Team Foundation Server e Reporting Services per aggiungere una persona al ruolo di collaboratore di un progetto Team. Per ulteriori informazioni su queste procedure, vedere Procedura: impostare le autorizzazioni di collaboratore per Team Foundation Server e Procedura: impostare le autorizzazioni di collaboratore per Reporting Services.

Protezione

Non concedere mai troppe autorizzazioni a un singolo utente, né autorizzazioni a un membro non affidabile per non rischiare di compromettere l'integrità del server e della rete.

Vedere anche

Attività

Procedura: impostare le autorizzazioni di collaboratore per Reporting Services
Procedura: impostare le autorizzazioni di collaboratore per Team Foundation Server

Concetti

Autorizzazioni di collaboratore per Team Foundation Server


Procedura: impostare le autorizzazioni di collaboratore per Reporting Services

Procedura: impostare le autorizzazioni di collaboratore per Reporting Services
Vedere anche

Per aggiungere una persona nel ruolo di collaboratore di progetto Team, è necessario impostare le autorizzazioni nei gruppi di Team Foundation Server, Windows SharePoint Services e Reporting Services. In questo argomento viene descritto come impostare le autorizzazioni di collaboratore di progetto Team per Reporting Services.

Nota Nota

È necessario essere un amministratore di sito, un responsabile del contenuto o un responsabile del contenuto del progetto di Reporting Services per potere completare questa procedura.

Per aggiungere un membro al gruppo di esplorazione di Reporting Services

  1. Aprire Internet Explorer.

  2. Digitare quanto segue nella barra dell'indirizzo di Internet Explorer:

    http:// data-tier /Reports/Pages/Folder.aspx

    dove data-tier è il nome del server Team Foundation di report a livello dati. Per determinare il nome del server di report, aprire Team Explorer, espandere il nodo Report e visualizzare le proprietà di un report.

  3. Fare clic sulla scheda Proprietà, quindi fare clic su Nuova assegnazione ruolo.

  4. In Nome gruppo o utente aggiungere il nome di accesso per la persona che si desidera aggiungere a questo gruppo.

  5. In Ruolo selezionare Esplorazione, quindi scegliere OK.

Oltre a completare questa procedura, è necessario concedere le autorizzazioni di collaboratore per Team Foundation Server e Windows SharePoint Services per aggiungere una persona al ruolo di collaboratore del progetto Team. Per ulteriori informazioni su queste procedure, vedere Procedura: impostare le autorizzazioni di collaboratore per Team Foundation Server e Procedura: impostare le autorizzazioni dei collaboratori per Windows SharePoint Services.

Protezione

Non concedere mai troppe autorizzazioni a un singolo utente, né autorizzazioni a un membro non affidabile per non rischiare di compromettere l'integrità del server e della rete.

Vedere anche

Attività

Procedura: impostare le autorizzazioni di collaboratore per Team Foundation Server
Procedura: impostare le autorizzazioni dei collaboratori per Windows SharePoint Services

Concetti

Autorizzazioni di collaboratore per Team Foundation Server


Autorizzazioni del controllo del codice sorgente di Team Foundation

 elenco a discesa elenco a discesa attivabile
Autorizzazioni del controllo del codice sorgente di Team Foundation
Vedere anche
elenco a discesa

Questa sezione contiene argomenti in cui vengono descritti le autorizzazioni e i privilegi di protezione per il controllo del codice sorgente, le generazioni e il controllo da utilizzare con il comando tf.exe. Per ulteriori informazioni sulla protezione di Team Foundation Server, vedere Protezione di Team Foundation Server.

In questa sezione

Autorizzazioni e privilegi di protezione del controllo del codice sorgente

Vengono descritti le autorizzazioni e i privilegi di protezione per il controllo del codice sorgente.

Autorizzazioni e privilegi di protezione di Team Build

Vengono descritti le autorizzazioni e i privilegi di protezione per Team Foundation Build.

Controllo e autorizzazioni utente

Vengono descritti i privilegi utente e di controllo per Team Foundation.

Vedere anche

Concetti

Autorizzazioni per Team Foundation Server

Altre risorse

Amministrazione di Team Foundation Server


Autorizzazioni e privilegi di protezione del controllo del codice sorgente

 elenco a discesa elenco a discesa attivabile
Autorizzazioni e privilegi di protezione del controllo del codice sorgente
Vedere anche
elenco a discesa

In Team Foundation Server sono inclusi autorizzazioni e privilegi di protezione applicabili all'ambiente Team Foundation che contiene il controllo del codice sorgente. Per informazioni sulle autorizzazioni di Team Foundation Server, vedere Controllo e autorizzazioni utente. Le autorizzazioni e i privilegi di Team Foundation Server riportati di seguito sono applicabili al controllo del codice sorgente.

Autorizzazioni su file e cartelle

  • Read

    Lettura del contenuto di un file o di una cartella.

  • PendChange

    Estrazione, aggiunta, eliminazione, diramazione, unione e annullamento eliminazione.

  • Checkin

    Archiviazione delle modifiche.

  • Label

    Applicazione di un'etichetta ad elementi.

  • Lock

    Blocco di un elemento in modo che non possa essere aggiornato da un altro utente.

  • ReviseOther

    Modifica del contenuto delle note di archiviazione e dei commenti di un insieme di modifiche di un altro utente.

  • UnlockOther

    Rimozione di un blocco impostato da un altro utente.

  • UndoOther

    Annullamento di una modifica in sospeso di un altro utente.

  • LabelOther

    Modifica di un'etichetta di un altro utente.

  • AdminProjectRights

    Configurazione delle autorizzazioni.

  • CheckinOther

    Archiviazione come altro utente (necessario per l'utilità di conversione).

Autorizzazioni globali

  • CreateWorkspace

    Creazione di un'area di lavoro.

  • AdminWorkspaces

    Modica dell'area di lavoro di un altro utente.

  • AdminShelvesets

    Eliminazione di modifiche sospese di un altro utente.

  • AdminConnections

    Arresto di un'operazione del controllo del codice sorgente in corso.

  • AdminConfiguration

    Configurazione di note, criteri e tipi file di archiviazione e così via.

Vedere anche

Concetti

Controllo del codice sorgente di Team Foundation


Autorizzazioni e privilegi di protezione di Team Build

 elenco a discesa elenco a discesa attivabile
Autorizzazioni e privilegi di protezione di Team Build
Vedere anche
elenco a discesa

In Team Foundation Server sono inclusi autorizzazioni e privilegi di protezione applicabili all'ambiente Team Foundation che contiene Team Foundation Build. Per informazioni sulle autorizzazioni di Team Foundation Server, vedere Controllo e autorizzazioni utente. Le autorizzazioni e i privilegi di Team Foundation Server riportati di seguito sono applicabili a Team Build.

Nota di avviso Attenzione

Si consiglia di aggiungere gli utenti che devono potere accedere al computer di generazione a scopo di analisi agli utenti del computer di generazione e concedere loro autorizzazioni utente sulla directory di generazione. Non è invece consigliabile concedere loro autorizzazioni sull'account del servizio di generazione, in quanto ciò permette di controllare l'intero processo di generazione.

  • Amministra generazione

    Le seguenti operazioni possono essere eseguite solo da account che dispongono del privilegio Amministra generazione:

    • Creazione di nuovi tipi di generazione.

      Creazione guidata nuovo tipo di generazione è attivata. Per ulteriori informazioni, vedere Procedura: creare un nuovo tipo di generazione.

      Nota Nota

      Per potere creare un nuovo tipo di generazione, l'account deve inoltre disporre di autorizzazioni di archiviazione sulla cartella TipiDiGenerazioneTeamFoundation nel controllo del codice sorgente. Per ulteriori informazioni, vedere Autorizzazioni e privilegi di protezione del controllo del codice sorgente.

    • Modifica di tipi di generazione esistenti.

    • Eliminazione di tipi di generazioni.

      Gli account dei servizi livello applicazione e Team Build devono disporre delle autorizzazioni di lettura/scrittura sul sito di destinazione per potere eliminare un tipo di generazione.

    • Interruzione dell'esecuzione di generazioni.

  • Modifica qualità di generazione

    Lo stato della qualità di generazione nei report può essere modificato solo da account che dispongono dell'autorizzazione Modifica qualità di generazione. Per ulteriori informazioni, vedere Procedura: impostare la qualità di generazione.

  • Visualizza informazioni a livello di progetto

    Gli account che dispongono dell'autorizzazione Visualizza informazioni a livello di progetto possono eseguire le seguenti operazioni:

    • Visualizzazione di report di generazione. Per ulteriori informazioni, vedere Procedura: visualizzare un report di generazione.

    • Sottoscrizione a messaggi di posta elettronica di notifica. Per ulteriori informazioni, vedere Procedura: ricevere una notifica di generazione mediante posta elettronica.

  • Avvia generazione

    Gli account che dispongono del privilegio Avvia generazione possono eseguire le seguenti operazioni:

    • Avvio di generazioni

      Il comando Genera {nome del progetto Team} è attivato nel menu principale Genera e nel menu di scelta rapida Progetto Team. Per ulteriori informazioni, vedere Esecuzione delle generazioni in Team Foundation Build.

    Nota di avviso Attenzione

    La copia dei file di log e binari generati nella directory finale potrebbe non essere sicura. È però possibile estendere il tipo di generazione con un'attività MSBuild personalizzata che copia i file in maniera protetta nella directory finale. Per ulteriori informazioni sull'estensione di un tipo di generazione, vedere Procedura dettagliata: estensione di Team Foundation Build.

  • Scrivi nell'archivio operativo delle generazioni

    Solo gli account che dispongono del privilegio Scrivi nell'archivio operativo delle generazioni possono scrivere nell'archivio operativo.

Vedere anche

Concetti

Cenni preliminari su Team Foundation Build


Controllo e autorizzazioni utente

 elenco a discesa elenco a discesa attivabile
Controllo e autorizzazioni utente
Vedere anche
elenco a discesa

Il servizio di autorizzazione di Team Foundation consente agli amministratori e ai proprietari di file, cartelle e altri oggetti di Team Foundation di gestire le autorizzazioni utente per gli elementi da loro controllati a livello atomico.

In questo argomento vengono trattate solo le autorizzazioni necessarie per il controllo della versione. Per ulteriori informazioni sulle autorizzazioni di Team Foundation Server, vedere Autorizzazioni per Team Foundation Server.

Autorizzazioni

Il proprietario o coloro che dispongono di controllo amministrativo su un file, ad esempio $/projects/314.cs, possono modificare le autorizzazioni predefinite per consentire o negare a utenti specifici o interi gruppi la possibilità di eseguire comandi sul file.

Autorizzazione | Descrizione
Read | Consente agli utenti di leggere il contenuto di un file o di una cartella. Se un utente dispone delle autorizzazioni di lettura per una cartella, può visualizzare il contenuto della cartella e le proprietà dei file in essa presenti, anche se non è autorizzato ad aprire i file.
PendChange | Consente agli utenti di apportare una modifica in sospeso agli elementi di una cartella. Tra gli esempi di modifiche in sospeso figurano l'aggiunta, la ridenominazione, l'eliminazione, l'annullamento dell'eliminazione, la diramazione e l'unione di un file.
Checkin | Consente agli utenti di archiviare elementi ed esaminare i commenti dell'insieme di modifiche salvate. Le modifiche in sospeso vengono salvate al momento dell'archiviazione.
Label | Consente agli utenti di etichettare elementi.
Lock | Consente agli utenti di bloccare e sbloccare cartelle o file.
ReviseOther | Consente agli utenti di modificare i commenti relativi ai file archiviati, anche se è stato un altro utente ad archiviare il file.
UnlockOther | Consente agli utenti di sbloccare file bloccati da altri utenti.
UndoOther | Consente agli utenti di annullare una modifica in sospeso apportata da un altro utente.
LabelOther | Consente agli utenti di modificare o eliminare etichette create da un altro utente.
AdminProjectRights | Consente agli utenti di impostare i valori dell'elenco di controllo di accesso (ACL, Access Control List) per file e cartelle.
CheckinOther | Consente agli utenti di archiviare modifiche apportate da altri utenti. Le modifiche in sospeso vengono salvate al momento dell'archiviazione.

Autorizzazioni globali

Autorizzazione globale | Descrizione
CreateWorkspace | Consente all'utente di creare aree di lavoro.
AdminWorkspaces | Consente all'utente di creare, modificare ed eliminare qualsiasi area di lavoro.
AdminShelvesets | Consente all'utente di creare, modificare ed eliminare qualsiasi insieme di sospensione.
AdminConnections | Consente all'utente di disconettere altri utenti dal server e terminare l'esecuzione di comandi.
AdminConfiguration | Consente all'utente di configurare aree di lavoro.

Vedere anche

Riferimenti

Comando Permission

Concetti

Autorizzazioni per Team Foundation Server


Visualizzazione e modifica delle autorizzazioni

 elenco a discesa elenco a discesa attivabile
Visualizzazione e modifica delle autorizzazioni
Vedere anche
elenco a discesa

È possibile modificare le autorizzazioni associate a qualsiasi gruppo di protezione per controllare i dritti di accesso di cui dispongono gli utenti del gruppo nel progetto Team.

In questa sezione

Procedura: visualizzare le autorizzazioni

Viene descritto come visualizzare le autorizzazioni per un utente o un gruppo nel progetto o per l'intero server Team Foundation Server.

Procedura: modificare le autorizzazioni per un gruppo o un utente

Viene descritto come modificare le autorizzazioni per un utente o un gruppo in un progetto o per l'intero server Team Foundation Server.

Vedere anche

Altre risorse

Gestione di utenti e gruppi


Procedura: visualizzare le autorizzazioni

Procedura: visualizzare le autorizzazioni

È possibile che le attività di amministrazione di Team Foundation Server richiedano di visualizzare e modificare autorizzazioni concesse a singoli utenti o gruppi. In questo argomento viene descritto come visualizzare le autorizzazioni in Team Foundation per individui e gruppi.

Per visualizzare autorizzazioni a livello di server

  1. In Team Explorer fare clic con il pulsante destro del mouse sul server di cui si desidera visualizzare le autorizzazioni, scegliere Impostazioni di Team Foundation Server, quindi fare clic su Protezione.

  2. Nel riquadro Utenti e gruppi selezionare l'utente o il gruppo di cui si desidera visualizzare le autorizzazioni.

    Le autorizzazioni verranno visualizzate nel riquadro Autorizzazione.

Per visualizzare autorizzazioni a livello di progetto

  1. In Team Explorer fare clic con il pulsante destro del mouse sul progetto di cui si desidera visualizzare le autorizzazioni, scegliere Impostazioni progetto Team, quindi fare clic su Protezione.

  2. Nel riquadro Utenti e gruppi selezionare l'utente o il gruppo di cui si desidera visualizzare le autorizzazioni.

    Le autorizzazioni verranno visualizzate nel riquadro Autorizzazione.

Vedere anche

Attività

Procedura: modificare le autorizzazioni per un gruppo o un utente

Altre risorse

Visualizzazione e modifica delle autorizzazioni
Gestione delle autorizzazioni


Procedura: modificare le autorizzazioni per un gruppo o un utente

Procedura: modificare le autorizzazioni per un gruppo o un utente
Vedere anche

È possibile modificare esplicitamente le autorizzazioni per un utente o un gruppo in un progetto o per l'intero server Team Foundation Server. Per potere modificare le autorizzazioni di un gruppo, è necessario disporre dell'accesso in lettura/scrittura a tale gruppo.

Per modificare le autorizzazioni per un gruppo o un utente

  1. In Team Explorer selezionare il progetto Team in cui si trova il gruppo o, per modificare le autorizzazioni per un gruppo a livello di server, selezionare il server Team Foundation Server in cui si trova il gruppo.

  2. Dal menu Team scegliere Impostazioni progetto Team, quindi fare clic su Protezione o, per modificare le autorizzazioni per un gruppo a livello di server, scegliere Impostazioni di Team Foundation Server, quindi fare clic su Protezione.

  3. In Utenti e gruppi selezionare il gruppo o l'utente di cui si desidera modificare le autorizzazioni.

  4. In Autorizzazioni per group or user name selezionare l'autorizzazione che si desidera modificare, selezionare la colonna Consenti per concedere l'autorizzazione o la colonna Nega per negarla.

    Nota Nota

    Affinché vengano applicate le autorizzazioni di un gruppo padre, deselezionare entrambe le caselle di controllo Consenti e Nega.

  5. Fare clic su Chiudi.

Vedere anche

Attività

Procedura: aggiungere utenti a un gruppo del server

Altre risorse

Gestione di utenti e gruppi


Gestione dei servizi e degli account di servizio di Team Foundation Server

 elenco a discesa elenco a discesa attivabile
Gestione dei servizi e degli account di servizio di Team Foundation Server
Vedere anche
elenco a discesa

Team Foundation Server include numerosi servizi e account di servizio eseguiti sul server a livello dati, sul server a livello applicazione o su entrambi. In questa sezione viene descritto come gestire tali account.

In questa sezione

Utilità di pianificazione di Team Foundation Server

Viene descritto come il servizio Utilità di pianificazione di Team Foundation Server fornisce un meccanismo di pianificazione generale per i servizi Web di Team Foundation.

Procedura: visualizzare i servizi di Team Foundation Server

Viene descritto come visualizzare i servizi di Team Foundation Server e i pool di applicazioni del servizio Web installati da Team Foundation Server.

Procedura: assegnare un nuovo account a un servizio di Team Foundation Server

Viene descritto come cambiare l'account di servizio utilizzato da Team Foundation Server.

Reimpostazione di account di servizio e password

Elenca i servizi e gli account di servizio che Team Foundation Server installa sui server a livello dati e applicazione.

Riferimenti

Comandi della riga di comando TFSAdminUtil

Viene descritto come utilizzare TFSAdminUtil.exe per aggiornare Team Foundation Server in modo che utilizzi nuove credenziali per gli account di servizio di Team Foundation Server.

Vedere anche

Altre risorse

Gestione di Team Foundation Server


Utilità di pianificazione di Team Foundation Server

 elenco a discesa elenco a discesa attivabile
Utilità di pianificazione di Team Foundation Server
Vedere anche
elenco a discesa

L'Utilità di pianificazione di Visual Studio Team Foundation Server è un servizio Windows che viene eseguito sui server a livello applicazione di Team Foundation Server. Il servizio Utilità di pianificazione di Team Foundation Server fornisce un meccanismo di pianificazione generale per i servizi Web di Team Foundation.

Servizio Utilità di pianificazione di Team Foundation Server

Alcuni servizi di Team Foundation comportano l'esecuzione di attività ripetitive. Ad esempio, è possibile che gli amministratori desiderino pianificare l'esecuzione di generazioni ogni notte. A questo scopo per i servizi di generazione deve essere possibile impostare un evento pianificato automaticamente nel database di registrazione. Il servizio Utilità di pianificazione di Team Foundation Server, noto anche come TFSServerScheduler, fornisce un unico servizio Windows per la pianificazione di attività ripetitive sui server Team Foundation. Questo servizio scorre il database di registrazione, identifica tutti i servizi Web di Team Foundation Server a cui sono associati eventi pianificati e pianifica le attività.

Istanze

Deve essere presente una sola istanza del servizio Utilità di pianificazione di Team Foundation Server in esecuzione su qualsiasi server di Team Foundation Server a livello applicazione. Il servizio viene eseguito con il nome abbreviato TFSServerScheduler e, per impostazione predefinita, viene eseguito mediante l'account di servizio specificato al momento dell'installazione di Team Foundation Server. Per visualizzare lo stato del servizio Utilità di pianificazione di Team Foundation Server su un server a livello applicazione fare clic sul pulsante Start, selezionare Servizi di amministrazione, fare clic su Servizi, quindi selezionare TFSServerScheduler.

Presupposti e limitazioni

Il servizio Utilità di pianificazione di Team Foundation Server è in esecuzione continua sui server Team Foundation Server a livello applicazione. Gli amministratori non hanno bisogno di interrompere o avviare il servizio manualmente. Il servizio Utilità di pianificazione di Team Foundation Server viene riavviato automaticamente al riavvio del server.

Gli amministratori non configureranno direttamente l'Utilità di pianificazione di Team Foundation Server. Le attività che è necessario pianificare vengono configurate direttamente nei singoli componenti di Team Foundation, ad esempio Team Foundation Build. Quando viene aggiunto o eliminato un evento, il servizio Utilità di pianificazione di Team Foundation Server riconfigura automaticamente le attività pianificate nel database di registrazione.

L'Utilità di pianificazione di Team Foundation Server non è stata progettata come meccanismo di pianificazione generico o per fornire una granularità di pianificazione oltre al giorno della settimana, all'ora del giorno e al minuto del giorno. La maggior parte degli amministratori non ha bisogno di pianificare attività oltre questo livello di granularità.

Vedere anche

Concetti

Procedura: reimpostare manualmente la password per i servizi del livello applicazione

Altre risorse

Team Foundation Server Registry Settings, Services, and Application Folders


Procedura: visualizzare i servizi di Team Foundation Server

Procedura: visualizzare i servizi di Team Foundation Server

Team Foundation Server include numerosi servizi che vengono eseguiti sul livello applicazione. I servizi effettivi variano in base alle funzionalità di Team Foundation installate sul server a livello applicazione.

In questo argomento viene descritto come visualizzare i servizi di Team Foundation Server e i pool di applicazioni del servizio Web installati da Team Foundation Server.

Per visualizzare i servizi sul computer a livello applicazione

  1. Sul computer Team Foundation Server a livello applicazione fare clic sul pulsante Start, scegliere Strumenti di amministrazione, quindi selezionare Gestione computer.

  2. Nel riquadro di spostamento espandere Servizi e applicazioni, quindi aprire Servizi.

  3. Fare clic sull'intestazione della colonna Connessione per ordinare i servizi in base all'account nel cui ambito vengono eseguiti.

    Per impostazione predefinita, i servizi di Team Foundation Server, Code Coverage di Analysis Service, TFSServerScheduler, Team Build e Timer di SharePoint vengono eseguiti nell'ambito dell'account di servizio di Team Foundation Server specificato al momento dell'installazione di Team Foundation Server, ossia TFSService.

    Nota Nota

    Il servizio Team Build viene installato solo quando viene installato il computer di generazione.

Per visualizzare i pool di applicazioni del servizio Web sul computer a livello applicazione

  1. Sul computer Team Foundation Server a livello applicazione fare clic sul pulsante Start, scegliere Strumenti di amministrazione, quindi selezionare Gestione computer.

  2. Nel riquadro di spostamento espandere Servizi e applicazioni, aprire Internet Information Services, quindi selezionare Pool di applicazioni.

  3. Per ciascun pool di applicazioni farvi clic sopra con il pulsante destro del mouse, quindi scegliere Proprietà.

  4. Fare clic sulla scheda Identità.

    Per impostazione predefinita, i pool di applicazioni di Team Foundation Server, TFS AppPool, TFS Proxy AppPool, TFTFWSS e TFWSSAdm vengono eseguiti nell'ambito dell'account di servizio di Team Foundation Server specificato al momento dell'installazione di Team Foundation Server, ossia TFSService.

    Nota Nota

    Il pool di applicazioni TFS Proxy AppPool viene installato solo quando viene installato il proxy Controllo del codice sorgente Team Foundation.

Vedere anche

Attività

Procedura: assegnare un nuovo account a un servizio di Team Foundation Server

Altre risorse

Gestione dei servizi e degli account di servizio di Team Foundation Server
Reimpostazione di account di servizio e password


Procedura: assegnare un nuovo account a un servizio di Team Foundation Server

Procedura: assegnare un nuovo account a un servizio di Team Foundation Server
Vedere anche

È possibile sostituire l'account di servizio Team Foundation Server specificato al momento dell'installazione di Team Foundation Server (anche definito account TFSService) con un account diverso, ad esempio domain\TFSSVC. Per apportare questa modifica, utilizzare l'utilità TFSAdminUtil con l'argomento ChangeAccount. Questo strumento consente di aggiornare i server Team Foundation sostituendo le informazioni sull'account di servizio precedente con nuove informazioni.

In alternativa è possibile modificare manualmente le informazioni di accesso per ciascun servizio e aggiornare il server SQL in modo che riconosca il nuovo account di servizio Team Foundation Server.

Nota Nota

L'utilità TFSAdminUtil non crea fisicamente un account o ne modifica la password, ma semplicemente aggiorna Team Foundation Server affinché utilizzi le credenziali correnti. L'account di servizio può essere un account locale o di dominio. È inoltre possibile includere il comando TFSAdminUtil in script per consentire aggiornamenti automatici. Per ulteriori informazioni, vedere Comando ChangeAccount.

Aggiornamento delle informazioni sull'account di servizio mediante TFSAdminUtil

Per assegnare un nuovo account di servizio a tutti i servizi di Team Foundation Server mediante TFSAdminUtil

  1. Dalla riga di comando individuare l'utilità TFSAdminUtil.

    Per impostazione predefinita, l'utilità è contenuta in <drive>:\Programmi\Microsoft Visual Studio 2005 Team Foundation Server\Tools.

  2. Nella riga di comando digitare TFSAdminUtil ChangeAccount oldAccount oldPassword newAccount newPassword [targetMachineName] e premere INVIO.

    È necessario immettere il nome utente e la password per l'account di servizio Team Foundation Server precedente (oldAccount e oldPassword), nonché il nome utente e la password per il nuovo account (newAccount e newPassword).

    Il nome del computer di destinazione (targetMachineName) è facoltativo. Il computer di destinazione deve essere un server a livello applicazione. Se non si specifica la destinazione, l'utilità TFSAdminUtil utilizza il computer corrente.

L'utilità TFSAdminUtil scorre i servizi e modifica solo quelli che vengono eseguiti utilizzando l'account precedente.

Aggiornamento manuale delle informazioni sull'account di servizio

Invece di utilizzare l'utilità TFSAdminUtil, è possibile modificare manualmente le informazioni di accesso per ciascun servizio e aggiornare il server SQL in modo che riconosca il nuovo account di servizio Team Foundation Server. Tuttavia, nella maggior parte delle situazioni si consiglia di aggiornare le informazioni mediante l'utilità TFSAdminUtil.

Per selezionare l'account per l'esecuzione dei servizi

  1. Sul computer Team Foundation Server a livello applicazione fare clic sul pulsante Start, scegliere Strumenti di amministrazione, quindi selezionare Gestione computer.

  2. Nel riquadro di spostamento espandere Servizi e applicazioni, quindi aprire Servizi.

  3. Eseguire le seguenti operazioni per ciascun servizio di Team Foundation Server: Servizio analisi code coverage, TFSServerScheduler, Servizio Team Build e Servizio Timer di SharePoint. È possibile che sia necessario arrestare il servizio per potere completare questa procedura.

    Nota Nota

    Il servizio Team Build viene installato solo se si è installato il computer di generazione.

    1. Fare clic con il pulsante destro del mouse sul servizio, quindi scegliere Proprietà.

    2. Fare clic sulla scheda Accedi per il servizio.

    3. Specificare il nuovo account di servizio di Team Foundation Server nella casella di testo Account specifico.

    4. Digitare la password per l'account nelle caselle Password e Conferma password, quindi scegliere OK.

Per selezionare un account di esecuzione per i pool di applicazioni del servizio Web

  1. Sul computer Team Foundation Server a livello applicazione fare clic sul pulsante Start, scegliere Strumenti di amministrazione, quindi selezionare Gestione computer.

  2. Nel riquadro di spostamento espandere Servizi e applicazioni, aprire Internet Information Services, quindi selezionare Pool di applicazioni.

  3. Eseguire le seguenti operazioni per ciascun pool di applicazioni di Team Foundation Server: TFS AppPool, TFS Proxy AppPool, TFTFWSS e TFWSSAdm.

    Nota Nota

    Il pool di applicazioni TFS Proxy AppPool viene installato solo quando si è installato il proxy del controllo del codice sorgente.

    1. Fare clic con il pulsante destro del mouse sul pool delle applicazioni, quindi scegliere Proprietà.

    2. Fare clic sulla scheda Identità.

    3. Specificare il nuovo account di servizio di Team Foundation Server nella casella di testo Nome utente.

    4. Digitare la password per l'account nelle caselle Password e Conferma password, quindi scegliere OK.

Per aggiungere un nuovo account a un database

  1. Aprire SQL Server Management Studio sul computer Team Foundation Server a livello dati. A questo scopo fare clic sul pulsante Start, scegliere Tutti i programmi, Microsoft SQL Server, quindi SQL Server Management Studio.

  2. Selezionare lo schema Tipo server, Nome server e Autenticazione appropriato per il server. Fornire un nome utente e una password validi, se richiesti da SQL Server, quindi fare clic su Connetti.

  3. Espandere il nodo Protezione, quindi il nodo Account di accesso per visualizzare l'elenco degli utenti e degli oggetti che possono accedere al database.

  4. Fare clic con il pulsante destro del mouse sull'account di servizio di Team Foundation Server precedente, quindi scegliere Proprietà.

    L'account precedente verrà utilizzato come modello per le impostazioni del nuovo account di servizio.

  5. In SQL Server Management Studio fare clic con il pulsante destro del mouse sul nodo Account di accesso, quindi scegliere Nuovo account di accesso.

  6. Specificare il nuovo account di servizio di Team Foundation Server nella casella di testo Nome di accesso.

  7. Visualizzare entrambe le finestre Proprietà account di accesso in primo piano. Nel riquadro di spostamento di ciascuna finestra selezionare Mapping utenti.

  8. Configurare le impostazioni Mapping utenti per il nuovo account in modo che corrispondano a quelle dell'account precedente.

  9. Scegliere OK in ciascuna delle finestre Proprietà account di accesso.

Per selezionare gli account che possono connettersi a un database

  1. Aprire SQL Server Management Studio sul computer Team Foundation Server a livello dati. A questo scopo fare clic sul pulsante Start, scegliere Tutti i programmi, Microsoft SQL Server, quindi SQL Server Management Studio.

  2. Selezionare lo schema Tipo server, Nome server e Autenticazione appropriato per il server. Fornire un nome utente e una password validi, se richiesti da SQL Server, quindi fare clic su Connetti.

  3. Espandere il nodo Database per visualizzare l'elenco dei database che costituiscono il livello dati di Team Foundation Server.

  4. Eseguire le seguenti operazioni per ciascun database di Team Foundation Server: STS_Config, TfsActivityLogging, TfsBuild, TfsIntegration, TfsVersionControl, TfsWarehouse, TfsWorkItemTracking e TfsWorkItemTrackingAttachments.

    1. Fare clic con il pulsante destro del mouse sul database, quindi scegliere Proprietà.

    2. Nel riquadro di spostamento selezionare Autorizzazioni, quindi fare clic su Aggiungi.

    3. Fare clic su Sfoglia, selezionare la casella di controllo per il nuovo account di servizio di Team Foundation Server, quindi scegliere OK.

    4. Scegliere OK.

    5. Selezionare l'account di servizio di Team Foundation Server precedente nella tabella Utenti o ruoli, quindi fare clic su Rimuovi.

    6. Scegliere OK.

Protezione

Per potere utilizzare TFSAdminUtil è necessario disporre di privilegi di amministratore nel livello applicazione locale e di amministratore di SQL Server nel livello dati di Team Foundation Server.

Vedere anche

Attività

Procedura: visualizzare i servizi di Team Foundation Server

Riferimenti

Comando ChangeAccount

Altre risorse

Gestione dei servizi e degli account di servizio di Team Foundation Server


Reimpostazione di account di servizio e password

 elenco a discesa elenco a discesa attivabile
Reimpostazione di account di servizio e password
Vedere anche
elenco a discesa

Team Foundation Server include numerosi servizi e account di servizio eseguiti sul server a livello dati, sul server a livello applicazione o su entrambi. I servizi effettivi variano in base alle funzionalità di Team Foundation installate sui server a livello dati e applicazione. Se, ad esempio, si utilizza una configurazione con un solo server, i servizi a livello dati e applicazione verranno eseguiti sullo stesso server.

Se è necessario reimpostare la password dell'account di servizio per Team Foundation Server, modificare la password per diversi servizi dei server Team Foundation Server a livello applicazione utilizzando l'utilità della riga di comando TFSAdminUtil. È inoltre possibile utilizzare l'utilità della riga di comando TFSAdminUtil per determinare i servizi in esecuzione per un account specifico. Nella seguente tabella sono elencati i nomi dei servizi, l'account utilizzato e il relativo livello di esecuzione.

Nome del servizio | Account del servizio | Livello
SQL Server | Sistema locale | Livello dati
Analysis Server (MSSQLSERVER) | Sistema locale | Livello dati
Report Server (MSSQLSERVER) | Servizio di rete | Livello applicazione
Servizio Code Coverage | TFSService | Livello applicazione
Servizio Report Web | Sistema locale | Livello dati
Servizio browser SQL | Sistema locale | Livello dati
Agente SQL | Sistema locale | Livello dati
Utilità di pianificazione server TFS | TFSService | Livello applicazione
SharePoint Services | Servizio di rete | Livello applicazione
Team Foundation Server Web Services | TFSService | Livello applicazione
Servizio Team Build (se Team Foundation Build è installato) | TFSService | Livello applicazione

Sul server a livello dati Team Foundation Server tutti gli account di servizio relativi a SQL vengono eseguiti come sistema locale. Non modificare la password per nessuno di questi account.

Sul server a livello applicazione Team Foundation Server è necessario modificare la password per il pool di applicazioni Team Foundation Server Web Services e per i servizi Utilità di pianificazione server TFS e Team Build in base alle esigenze operative.

In questa sezione

Procedura: reimpostare la password per il pool di applicazioni

Vengono illustrate le procedure per modificare la password per il pool di applicazioni sul server a livello applicazione.

Procedura: reimpostare manualmente la password per i servizi del livello applicazione

Viene fornito un collegamento alle istruzioni in linea più aggiornate per la reimpostazione manuale della password.

Procedura: modificare il nome di un account di servizio

Viene fornito un collegamento alle istruzioni in linea più aggiornate per la modifica del nome dell'account.

Vedere anche

Attività

Procedura: reimpostare la password per il pool di applicazioni

Concetti

Procedura: reimpostare manualmente la password per i servizi del livello applicazione

Altre risorse

Comandi della riga di comando TFSAdminUtil


Procedura: reimpostare la password per il pool di applicazioni

Procedura: reimpostare la password per il pool di applicazioni
Vedere anche

Se è necessario reimpostare la password dell'account di servizio per Team Foundation Server, modificare la password per il pool di applicazioni sul server a livello applicazione.

Per reimpostare la password per il pool di applicazioni

  1. Sul computer Team Foundation Server a livello applicazione fare clic sul pulsante Start, scegliere Strumenti di amministrazione, quindi selezionare Gestione computer.

  2. Nel riquadro di spostamento espandere Servizi e applicazioni, aprire Internet Information Services, quindi selezionare Pool di applicazioni.

  3. Fare clic con il pulsante destro del mouse su TFS AppPool e scegliere Proprietà.

  4. Selezionare la scheda Identità.

  5. Verificare che in Identità pool di applicazioni sia selezionato Configurabile e che nella casella Nome utente sia visualizzato domain\BISSVC.

  6. Nelle caselle Nuova password e Conferma password digitare la nuova password, quindi fare clic su OK.

Vedere anche

Concetti

Procedura: reimpostare manualmente la password per i servizi del livello applicazione

Altre risorse

Reimpostazione di account di servizio e password


Procedura: reimpostare manualmente la password per i servizi del livello applicazione

 elenco a discesa elenco a discesa attivabile
Procedura: reimpostare manualmente la password per i servizi del livello applicazione
Vedere anche
elenco a discesa

Questa procedura non è disponibile in questa versione della Guida dell'amministratore di Team Foundation. La versione più aggiornata di questo argomento è disponibile in linea sul sito Web Microsoft: http://go.microsoft.com/fwlink/?linkid=52459.

Vedere anche

Attività

Procedura: reimpostare la password per il pool di applicazioni

Altre risorse

Reimpostazione di account di servizio e password


Procedura: modificare il nome di un account di servizio

 elenco a discesa elenco a discesa attivabile
Procedura: modificare il nome di un account di servizio
Vedere anche
elenco a discesa

Questa procedura non è disponibile in questa versione della Guida dell'amministratore di Team Foundation. La versione più aggiornata di questo argomento è disponibile in linea sul sito Web Microsoft: http://go.microsoft.com/fwlink/?linkid=52459.

Vedere anche

Altre risorse

Reimpostazione di account di servizio e password
Gestione dei servizi e degli account di servizio di Team Foundation Server


Gestione di dati

 elenco a discesa elenco a discesa attivabile
Gestione di dati
Vedere anche
elenco a discesa

In questa sezione sono riportati collegamenti ad argomenti in cui viene illustrato come gestire diversi aspetti del data warehouse di Team Foundation Server.

In questa sezione

Impostazione di un limite per le dimensioni degli allegati

Viene descritto come impostare un limite di dimensione per gli allegati.

Pianificazione della sincronizzazione con il data warehouse

Viene descritto come pianificare la sincronizzazione con il data warehouse.

Scelta degli strumenti di manutenzione di Team Foundation Server

Viene spiegato in dettaglio come cancellare dati di Team Foundation Server.

Backup e ripristino dei dati di Team Foundation Server

Consente di accedere ad argomenti che illustrano come eseguire il backup e il ripristino di dati di Team Foundation Server.

Procedura: configurare le impostazioni di amministrazione dell'area di lavoro

Viene spiegato in dettaglio come configurare le impostazioni di amministrazione dell'area di lavoro.

Procedura: eliminare permanentemente i file orfani

Viene descritto come eliminare in modo permanente i file orfani.

Vedere anche

Altre risorse

Gestione di Team Foundation Server


Impostazione di un limite per le dimensioni degli allegati

 elenco a discesa elenco a discesa attivabile
Impostazione di un limite per le dimensioni degli allegati
Vedere anche
elenco a discesa

È possibile impostare un limite per le dimensioni degli allegati degli elementi di lavoro in Team Foundation Server. In base alle esigenze dell'organizzazione e alle limitazioni di archiviazione del server Team Foundation, potrebbe essere necessario limitare le dimensioni consentite per gli allegati degli elementi di lavoro. In alternativa, è possibile incrementare le dimensioni predefinite per gli allegati.

Limiti di dimensione

Per impostazione predefinita, il limite per le dimensioni dei file allegati agli elementi di lavoro è 4.096 kilobyte. Per ulteriori informazioni sulla modifica del limite per le dimensioni degli allegati, vedere Procedura: impostare la dimensione massima degli allegati per gli elementi di lavoro.

Prima di modificare il limite predefinito per le dimensioni degli allegati valutare con attenzione le implicazioni. La modifica del valore limite per gli allegati comporta la modifica del limite per le dimensioni degli allegati per tutti gli utenti di Team Foundation Server. Non è infatti possibile modificare il valore per un singolo utente o gruppo di utenti. Occorre innanzitutto valutare se il server Team Foundation Server dispone di spazio di archiviazione adeguato. Se si decide di ridurre il limite per le dimensioni degli allegati, considerare l'impatto sul flusso di lavoro degli utenti. Notare che per la maggior parte delle organizzazioni il limite predefinito è probabilmente adeguato.

Vedere anche

Altre risorse

Gestione di dati


Pianificazione della sincronizzazione con il data warehouse

 elenco a discesa elenco a discesa attivabile
Pianificazione della sincronizzazione con il data warehouse
Vedere anche
elenco a discesa

In Team Foundation Server è possibile pianificare la sincronizzazione tra i database relazionali e il database OLAP utilizzato da Reporting Services. In questa sezione vengono brevemente descritte l'organizzazione del data warehouse e la sincronizzazione per diverse topologie.

Organizzazione del data warehouse

Il data warehouse include un database relazionale organizzato in uno schema a stella da cui viene derivato un database OLAP che consente agli strumenti per la generazione di report di accedere alle informazioni derivate senza influire sulle prestazioni del database relazionale in cui sono archiviate le informazioni provenienti in tempo reale dai client.

Nel data warehouse vengono archiviati diversi tipi di informazioni provenienti dai vari strumenti di Team Foundation sotto forma di una tabella relazionale principale e un cubo nel database OLAP i cui dati vengono derivati dal contenuto della tabella. A ciascun fatto in una tabella sono associati dettagli, dimensioni e misure.

  • Dettagli I dettagli sono colonne presenti nella tabella dei fatti principale nel database relazionale ma non nel cubo OLAP. Ad esempio, i titoli degli elementi di lavoro sono in genere lunghe stringhe di testo utilizzate principalmente all'interno di elenchi nei report.

  • Dimensioni Le dimensioni sono proprietà utilizzate per sezionare i dati in un report. Ad esempio, le dimensioni di un elemento di lavoro possono includere tipo e stato. Le dimensioni sono presenti nel database relazionale come tabelle con riferimenti alle tabelle delle dimensioni medianti chiavi esterne associate alla tabella dei fatti principale. Tutti i fatti dispongono di una dimensione di progetto che può essere utilizzata per sezionare i dati nel data warehouse in base al progetto Team.

  • Misure Le misure sono proprietà aggregate, ossia conteggiate, sommate e così via, che forniscono valori quantitativi nei report. Ad esempio, il cubo di varianza del codice CodeChurn fornito dallo strumento di controllo del codice sorgente include le misure LinesAdded, LinesRemoved e LinesChanged per le righe aggiunte, rimosse e modificate. Le misure sono presenti come colonne nella tabella dei fatti principale.

Sincronizzazione

Le modifiche apportate al modello del processo generano aggiornamenti ad ogni caricamento dei dati. Per impostazione predefinita, il data warehouse viene aggiornato ogni ora.

È possibile specificare la frequenza di aggiornamento delle informazioni derivate fornite dal database OLAP agli strumenti per la generazione di report. La pianificazione dipende dalle esigenze del sistema. Per ulteriori informazioni, vedere Procedura: impostare l'intervallo di elaborazione per il data warehouse.

Vedere anche

Attività

Procedura: impostare l'intervallo di elaborazione per il data warehouse

Altre risorse

Gestione di dati


Scelta degli strumenti di manutenzione di Team Foundation Server

 elenco a discesa elenco a discesa attivabile
Scelta degli strumenti di manutenzione di Team Foundation Server
Vedere anche
elenco a discesa

Team Foundation Server include alcuni strumenti per la manutenzione dei dati del server. Ad esempio, è possibile utilizzare tf per rimuovere aree di sospensione del controllo del codice sorgente obsolete. È inoltre possibile utilizzare gli strumenti di deframmentazione del database disponibili come parte di SQL Server.

Comandi della riga di comando TFSAdminUtil

Viene descritta l'utilità della riga di comando TFSAdminUtil e forniti collegamenti ad argomenti relativi ai relativi comandi e parametri disponibili.

Comando TFSDeleteProject

Vengono descritti le opzioni e i parametri di TFSDeleteProject, un'utilità della riga di comando che consente di eliminare un progetto Team da Team System.

TFSFieldMapping

Viene descritta TFSFieldMapping, un'utilità della riga di comando che consente di modificare o personalizzare il file XML di mapping del progetto una volta creato il progetto Team.

witimport

Viene descritta witimport, un'utilità della riga di comando che consente di convalidare e importare un tipo di elemento di lavoro da un file XML in un progetto Team in un server Team Foundation Server.

witexport

Viene descritta witexport, un'utilità della riga di comando che consente di esportare una definizione XML per un tipo di elemento di lavoro da Team Foundation Server.

glimport

Viene descritta glimport, un'utilità della riga di comando che consente di convalidare e importare elenchi globali da un file XML in un progetto Team nell'ambito di Team Foundation Server.

glexport

Viene descritta glexport, un'utilità della riga di comando che consente di esportare una definizione XML per elenchi globali da Team Foundation Server.

SetupWarehouse

Viene descritta SetupWarehouse, un'utilità della riga di comando che consente di rigenerare l'elaborazione analitica in linea (OLAP) o il database relazionale.

Riferimenti alla riga di comando del controllo del codice sorgente di Team Foundation

Vengono descritti i comandi disponibili nell'utilità della riga di comando tf.

Vedere anche

Altre risorse

Utilizzo degli strumenti della riga di comando di Team Foundation Server
Documentazione in linea di Microsoft SQL Server: piani di manutenzione
Documentazione in linea di Microsoft SQL Server: DBCC (Transact-SQL)


Backup e ripristino dei dati di Team Foundation Server

 elenco a discesa elenco a discesa attivabile
Backup e ripristino dei dati di Team Foundation Server
elenco a discesa

Si consiglia di creare regolarmente dei backup per i server Team Foundation in modo da potere ripristinare interamente la distribuzione di Team Foundation Server in caso di problemi. La creazione di backup è un aspetto fondamentale per la protezione della distribuzione di Team Foundation contro la perdita di dati. Il ripristino di server e dati Team Foundation può essere eseguito sullo stesso computer su cui sono presenti i dati o su un computer diverso.

In questa sezione

Backup di Team Foundation Server

Viene descritto come eseguire il backup di Team Foundation Server.

Ripristino di Team Foundation Server dai backup

Viene descritto come ripristinare un server Team Foundation Server e dati di Team Foundation Server.

Riferimenti

Pianificazione di backup e ripristino

Pianificazione del ripristino di emergenza

Sezioni correlate

Verifica della disponibilità e del failover di Team Foundation Server


Backup di Team Foundation Server

 elenco a discesa elenco a discesa attivabile
Backup di Team Foundation Server
Vedere anche
elenco a discesa

Affinché sia possibile ripristinare interamente la distribuzione di Team Foundation in caso di errore, è necessario creare backup per ogni percorso di memorizzazione dei dati. La creazione di backup è un aspetto fondamentale per la protezione della distribuzione di Team Foundation contro la perdita di dati.

Quando si distribuisce Team Foundation, tenere traccia degli account creati, dei nomi dei computer, delle password e delle opzioni di configurazione scelte. Tenere sempre una copia del materiale, dei documenti e dei database di recupero e dei backup del registro delle transazioni in una posizione esterna.

Nota Importante

Eseguire periodicamente tentativi di ripristino di dati per verificare che il backup dei file sia stato eseguito correttamente. Tali prove consentono di individuare eventuali problemi hardware non rilevati dalle verifiche software.

Quando si eseguono backup e ripristino di un database, è necessario eseguire il backup dei dati su un supporto, ad esempio nastri o dischi. Il piano di backup deve includere indicazioni sulla gestione dei supporti, ad esempio:

  • Un piano per tenere traccia e gestire la memorizzazione e il riciclo degli insiemi di backup.

  • Una pianificazione per la sovrascrittura dei supporti di backup.

  • In un ambiente multiserver, la scelta tra backup centralizzato e distribuito.

  • Un metodo per tenere traccia della durata utile dei supporti.

  • Una procedura per ridurre al minimo le conseguenze di perdite di un insieme o di supporti di backup, ad esempio un nastro.

  • La scelta tra memorizzazione degli insiemi di backup internamente o esternamente e un'analisi dell'impatto sui tempi di ripristino.

Come misura di sicurezza in caso di calamità, quale un incendio o un terremoto, mantenere duplicati dei backup dei server in ubicazioni diverse da quelle dei server per evitare il rischio di perdita di dati critici. Come procedura ottimale, è consigliabile tenere tre copie dei supporti di backup di cui almeno una fuori sede in un ambiente sottoposto a controlli adeguati.

Poiché i dati di Team Foundation sono memorizzati in database SQL Server, non è necessario eseguire il backup dei computer in cui sono installati i client di Team Foundation. Infatti, in caso di errore o guasto dei supporti relativi a tali computer, la reinstallazione di Team Foundation costituisce un'alternativa più pulita e affidabile del ripristino da backup.

È possibile eseguire il backup di un server utilizzando SQL Server per il backup dei database correlati alla distribuzione di Team Foundation.

Per il ripristino della distribuzione è necessario eseguire il backup completo dei database. Il backup completo include parte del registro delle transazioni, in modo da consentire il ripristino del backup completo. I backup completi sono indipendenti in quanto rappresentano l'intero database al momento del backup. Per ulteriori informazioni, vedere Full Backups.

In base al modello di backup completo del database, è fondamentale eseguire un regolare backup dei registri delle transazioni ai fini del ripristino dei dati. Infatti il backup dei registri delle transazioni consente di recuperare lo stato del database al momento dell'errore o in un altro momento specifico.

Il registro delle transazioni contiene una registrazione consecutiva di tutte le modifiche apportate al database, oltre alle transazioni che hanno eseguito tali modifiche. Il registro delle transazioni tiene traccia dell'inizio di ciascuna transazione, delle modifiche apportate ai dati e, se necessario, informazioni sufficienti per annullare le modifiche apportate nel corso di ciascuna transazione. La dimensione del registro cresce continuamente per ogni operazione registrata eseguita sul database.

I backup del registro delle transazioni consentono il ripristino dello stato del database in un momento precedente specifico, ad esempio precedente all'immissione di dati indesiderati o al verificarsi di un errore. La strategia di recupero deve includere il backup del registro delle transazioni oltre al backup dei database. Per ulteriori informazioni, vedere Using Transaction Log Backups.

Poiché in genere i backup del registro delle transazioni richiedono meno risorse rispetto al backup completo, è possibile creare backup del registro delle transazioni con più frequenza dei backup completi, riducendo in tal modo il rischio di perdita di dati. È però possibile che in alcuni casi la dimensione del backup del registro delle transazioni sia maggiore di quella di un backup completo. Un database con un'elevata frequenza di transazioni, ad esempio, comporta il rapido aumento della dimensione del registro delle transazioni. In questi casi è consigliabile creare backup del registro delle transazioni con più frequenza. Per ulteriori informazioni, vedere Managing a Full Transaction Log.

Esistono tre tipi di backup del registro delle transazioni:

  • Il backup puro del registro contiene solo i record del registro delle transazioni per un intervallo, senza modifiche di massa.

  • Il backup del registro di massa include le pagine del registro e dei dati modificati da operazioni di massa. In questo caso non è possibile eseguire il ripristino in corrispondenza di un momento preciso.

  • Il backup della parte finale del log viene eseguito per un database possibilmente danneggiato per ottenere i record del registro delle transazioni di cui non è stato ancora eseguito il backup. Questo tipo di backup viene eseguito dopo un errore per impedire la perdita di lavoro e può contenere dati del log puro o di massa.

L'avvio di una sequenza di backup del registro delle transazioni è l'unica occasione in cui è necessario sincronizzare un backup completo con i backup del registro delle transazioni. Ogni sequenza di backup del registro delle transazioni deve essere preceduta da un backup completo o completo differenziale. In SQL Server 2005 è possibile eseguire il backup del registro dopo il primo backup completo, anche durante l'esecuzione del backup completo. Per ulteriori informazioni sulla creazione di backup del registro, vedere Creating Transaction Log Backups.

In questa sezione

Procedura: eseguire il backup di un Team Foundation Server

Vengono illustrati i passaggi necessari per creare un piano di manutenzione per il backup dei database di Team Foundation Server.

Vedere anche

Attività

Procedura: eseguire il backup di un Team Foundation Server

Concetti

Pianificazione di backup e ripristino

Altre risorse

Backup e ripristino dei dati di Team Foundation Server
Full Backups
Using Transaction Log Backups
Creating Transaction Log Backups


Procedura: eseguire il backup di un Team Foundation Server

Procedura: eseguire il backup di un Team Foundation Server

Per eseguire il backup di un server Team Foundation Server, è necessario effettuare le seguenti operazioni:

  • Creare un piano di manutenzione per il backup di tutti i database di Team Foundation.

  • Eseguire il backup della chiave di crittografia del server di report.

Il livello dati di Team Foundation Server viene distribuito tra diversi database SQL Server e i singoli siti del portale del progetto Team. Per eseguire il backup dei dati di Team Foundation Server, utilizzare gli strumenti di backup forniti con SQL Server 2005. In particolare utilizzare SQL Server Management Studio per eseguire il backup dei database. Per ulteriori informazioni, vedere Getting Started with Backup and Restore.

SQL Server Management Studio consente di eseguire manualmente il backup di singoli database o di creare un processo pianificato per l'esecuzione dei backup di qualsiasi numero di database come parte di un piano di manutenzione che può essere configurato in modo che venga eseguito automaticamente a un'ora predeterminata o a intervalli pianificati.

Nella tabella seguente sono elencati i database di Team Foundation Server.

Database Descrizione

ReportServer

Questo database di Reporting Services contiene i report e le relative impostazioni per Reporting Services.

ReportServerTempDB

Il database temporaneo di Reporting Services consente di memorizzare temporaneamente le informazioni utilizzate per eseguire report specifici per Reporting Services.

STS_Config

Il database di configurazione di SharePoint contiene le informazioni di impostazione e configurazione per il sito SharePoint del progetto Team.

STS_SERVERNAME

Il database del contenuto di SharePoint contiene il contenuto effettivo del sito SharePoint del progetto Team.

TfsBuild

Il database di generazione contiene i dati di generazione (Team Foundation Build) e i risultati dei test pubblicati.

TfsIntegration

Progetti, aree, iterazioni e altri dati di registrazione.

TfsVersionControl

Il database di Controllo del codice sorgente Team Foundation.

TFSWarehouse

Il database di Analysis Services.

Nota Nota

Non viene eseguito alcun backup del cubo dei dati di Analysis Services perché è possibile ricrearlo dal database TFSWarehouse ripristinato.

TfsWorkItemTracking

Il database di Gestione elementi di lavoro Team Foundation.

TfsWorkItemTrackingAttachments

Il database degli allegati di Gestione elementi di lavoro Team Foundation.

Per creare un piano di manutenzione per il backup di tutti i database di Team Foundation Server

  1. Innanzitutto definire una strategia per il backup del database. Per ulteriori informazioni, vedere Choosing a Recovery Strategy That Supports Your Applications.

    In questa procedura viene illustrato come pianificare backup completi e incrementali. Se si desidera eseguire entrambi i tipi di backup, è necessario seguire la procedura due volte: una prima volta per il backup completo e una seconda volta per il backup incrementale. Per ulteriori informazioni, vedere Creating Transaction Log Backups.

    Nota Nota

    In genere i backup completi e incrementali vengono eseguiti in pianificazioni diverse per garantire una maggiore protezione dei dati.

  2. Sul server Team Foundation a livello dati aprire SQL Server Management Studio. A questo scopo fare clic sul pulsante Start, scegliere Tutti i programmi, Microsoft SQL Server e quindi SQL Server Management Studio.

  3. Selezionare Modulo di gestione di database in Tipo server. Selezionare lo schema Nome server e Autenticazione appropriato per il server. Fornire un nome utente e una password validi, se richiesti da SQL Server, quindi fare clic su Connetti.

  4. Espandere il nodo Gestione.

  5. Fare clic con il pulsante destro del mouse su Piani di manutenzione, quindi scegliere Creazione guidata piano di manutenzione.

  6. Scegliere Avanti nella schermata iniziale della Creazione guidata piano di manutenzione.

  7. Nella pagina Selezione server di destinazione immettere un nome per il piano di manutenzione.

    • Per un backup completo è possibile utilizzare BackupDatiCompletoTFS come nome.

    • Per un backup incrementale è possibile utilizzare BackupDatiIncrementaleTFS come nome.

  8. Selezionare lo schema Server e Autenticazione appropriato per SQL Server. Fornire un nome utente e una password, se richiesti da SQL Server, quindi fare clic su Avanti.

  9. Nella pagina Selezione attività di manutenzione selezionare l'attività di manutenzione.

    • Per un backup completo selezionare Backup database (completo).

    • Per un backup incrementale selezionare Backup database (log delle transazioni).

  10. Scegliere Avanti nella pagina Selezione attività di manutenzione.

  11. Scegliere Avanti nella pagina Selezione ordine attività di manutenzione.

  12. Nella casella di riepilogo a discesa Database, in Selezionare uno o più elementi, selezionare Tutti i database utente, quindi scegliere OK.

  13. Selezionare le opzioni di destinazione desiderate per il backup. Per informazioni dettagliate sulle opzioni contenute in questa finestra di dialogo, fare riferimento alla documentazione in linea di SQL Server 2005. Selezionare la finestra di dialogo Creazione guidata piano di manutenzione, quindi premere F1 per visualizzare le informazioni della guida in linea rilevanti.

    Nota Nota

    Accertarsi che i file di backup vengano archiviati su un computer sicuro diverso.

  14. Scegliere Avanti.

  15. Fare clic su Cambia nella pagina Selezione proprietà piano per aprire la finestra di dialogo Nuova pianificazione processo.

  16. Fornire un nome per il processo di backup.

    • Per un backup completo è possibile utilizzare BackupCompletoPianificato come nome.

    • Per un backup incrementale è possibile utilizzare BackupIncrementalePianificato come nome.

  17. Lasciare l'opzione Tipo pianificazione impostata su Periodica e la casella di controllo Attivata selezionata.

  18. Impostare le opzioni di Frequenza e Frequenza giornaliera per il piano di backup.

    Nota Nota

    In genere le ore di inizio per i backup completo e incrementale sono sfalsate.

  19. Lasciare l'opzione Durata impostata su Nessuna data di fine.

  20. Scegliere OK, quindi Avanti.

  21. Selezionare le opzioni di distribuzione dei report desiderate nella pagina Selezione opzioni report.

  22. Scegliere Avanti.

  23. Fare clic su Fine per completare la creazione del piano di manutenzione.

    SQL Server eseguirà il backup dei database specificati nel piano di manutenzione in base alla frequenza specificata.

    Nota Nota

    Se si desidera eseguire entrambi i tipi di backup, seguire la procedura due volte: una prima volta per il backup completo e una seconda volta per il backup incrementale.

Per eseguire il backup della chiave di crittografia del server di report

  1. Sul server Team Foundation a livello dati aprire lo strumento Configurazione di Reporting Services SQL.

    A questo scopo fare clic sul pulsante Start, scegliere Tutti i programmi, Microsoft SQL Server, Strumenti di configurazione e quindi Configurazione di Reporting Services.

  2. Immettere il nome del computer a livello dati e l'istanza del database nella finestra di dialogo Selezione dell'istanza di installazione del server report.

  3. Nella barra di spostamento a sinistra fare clic su Chiavi di crittografia.

  4. Fare clic su Backup.

    Verrà visualizzata la finestra di dialogo Informazioni chiave di crittografia.

  5. Digitare una password nella casella Password.

  6. Fare clic sul pulsante con i puntini di sospensione File di chiave.

    Verrà visualizzata la finestra di dialogo Salva con nome.

  7. Fornire il nome del file per la memorizzazione della chiave di crittografia di server di report, quindi scegliere OK per chiudere la finestra di dialogo Salva con nome.

  8. Scegliere OK per chiudere la finestra di dialogo Informazioni chiave di crittografia.

Protezione

Accertarsi che i backup vengano archiviati in un percorso sicuro. Non archiviare i file di backup sullo stesso server di cui è stato appena eseguito il backup.

Per eseguire le attività descritte in questo argomento è necessario disporre delle autorizzazioni che consentono di eseguire backup e creare piani di manutenzione su SQL Server.

Vedere anche

Concetti

Procedura: ripristinare i dati di Team Foundation Server

Altre risorse

Getting Started with Backup and Restore
Choosing a Recovery Strategy That Supports Your Applications
Gestione di dati
Gestione dei server a livello dati di Team Foundation Server
Gestione di Team Foundation Server


Ripristino di Team Foundation Server dai backup

 elenco a discesa elenco a discesa attivabile
Ripristino di Team Foundation Server dai backup
Vedere anche
elenco a discesa

Sebbene in genere non occorra eseguire ripristini completi di Team Foundation Server dai backup, si consiglia di eseguire spesso ripristini di prova per garantire l'integrità dei backup.

In questa sezione

Procedura: ripristinare i dati di Team Foundation Server

Viene descritto come ripristinare i dati di Team Foundation Server sullo stesso server Team Foundation Server da cui provengono.

Procedura: ripristinare i dati di Team Foundation Server su un server diverso

Viene descritto come ripristinare i dati di Team Foundation Server su un server Team Foundation Server diverso.

Vedere anche

Concetti

Pianificazione di backup e ripristino

Altre risorse

Backup e ripristino dei dati di Team Foundation Server


Procedura: ripristinare i dati di Team Foundation Server

 elenco a discesa elenco a discesa attivabile
Procedura: ripristinare i dati di Team Foundation Server
Vedere anche
elenco a discesa

In questo argomento viene descritto come ripristinare un server Team Foundation Server a livello dati. È possibile utilizzare questo tipo di ripristino anche per ripristinare l'ultimo stato funzionante di un server a livello dati danneggiato. Ciò risulta utile nel caso in cui i dati sul server siano stati danneggiati e debbano essere ripristinati, ma il server funziona correttamente. Se è necessario ripristinare i dati su un altro server a livello dati, vedere Procedura: ripristinare i dati di Team Foundation Server su un server diverso.

Nota Nota

Le istruzioni contenute in questo argomento richiedono un server a livello dati funzionante di cui è stato eseguito il backup.

Per ripristinare i dati di Team Foundation Server, effettuare le seguenti operazioni:

  • Preparare i server per il ripristino dei dati.

  • Ripristinare i database di Team Foundation.

  • Ripristinare il database di Analysis Server.

  • Ripristinare i siti del portale del progetto Team.

  • Riavviare i server.

  • Richiedere l'aggiornamento dei dati della cache sui client.

Il livello dati di Team Foundation Server viene distribuito tra diversi database SQL Server e i singoli siti del portale del progetto Team. Per recuperare i dati di Team Foundation Server, utilizzare gli strumenti di ripristino forniti con SQL Server 2005. In particolare utilizzare SQL Server Management Studio per ripristinare i database. Per ulteriori informazioni, vedere Getting Started with Backup and Restore e Gestione dei servizi SQL Server.

Nella tabella seguente sono elencati i database di Team Foundation Server.

Database Descrizione

ReportServer

Questo database di Reporting Services contiene i report e le relative impostazioni per Reporting Services.

ReportServerTempDB

Il database temporaneo di Reporting Services consente di memorizzare temporaneamente le informazioni utilizzate per eseguire report specifici per Reporting Services.

STS_Config

Il database di configurazione di Windows SharePoint contiene le informazioni di impostazione e configurazione per il sito SharePoint del progetto Team.

Nota Nota

Non ripristinare il database STS-Config, bensì utilizzare quello predefinito installato sul server a livello dati.

STS_SERVERNAME

Il database del contenuto di SharePoint contiene il contenuto effettivo del sito SharePoint del progetto Team.

TfsBuild

Il database di generazione contiene i dati di generazione (Team Foundation Build) e i risultati dei test pubblicati.

TfsIntegration

Progetti, aree, iterazioni e altri dati di registrazione.

TfsVersionControl

Il database di Controllo del codice sorgente Team Foundation.

TFSWarehouse

Il database di Analysis Services.

Nota Nota

Non viene eseguito alcun backup del cubo dei dati di Analysis Services perché è possibile ricrearlo dal database TFSWarehouse ripristinato.

TfsWorkItemTracking

Il database di Gestione elementi di lavoro Team Foundation.

TfsWorkItemTrackingAttachments

Il database degli allegati di Gestione elementi di lavoro Team Foundation.

Procedure

Per preparare i server per il ripristino dei dati

  1. Sul server Team Foundation a livello dati aprire un prompt dei comandi.

  2. Al prompt dei comandi digitare:

    iisreset /stop

    Sul server a livello dati verrà interrotta l'esecuzione di Internet Information Services (IIS).

  3. Sul server Team Foundation a livello applicazione aprire un prompt dei comandi.

  4. Al prompt dei comandi digitare:

    iisreset /stop

    IIS verrà riavviato sul server a livello applicazione.

Per ripristinare i database di Team Foundation

  1. Sul server Team Foundation a livello dati aprire SQL Server Management Studio. A questo scopo fare clic sul pulsante Start, scegliere Tutti i programmi, Microsoft SQL Server e quindi SQL Server Management Studio.

    Nota Nota

    Per ulteriori informazioni sul ripristino dei database, vedere Implementing Restore Scenarios.

  2. Selezionare Modulo di gestione di database in Tipo server. Selezionare lo schema Nome server e Autenticazione appropriato per il server. Fornire un nome utente e una password validi, se richiesti da SQL Server, quindi fare clic su Connetti.

  3. Espandere il nodo Database per visualizzare l'elenco dei database che costituiscono il livello dati di Team Foundation Server.

  4. Ripristinare ciascuno dei database seguenti:

    • ReportServer

    • ReportServerTempDB

    • STS_SERVERNAME

    • TfsBuild

    • TfsIntegration

    • TfsVersionControl

    • TfsWarehouse

    • TfsWorkItemTracking

    • TfsWorkItemTrackingAttachments

      Nota Nota

      Non ripristinare il database STS-Config, bensì utilizzare quello installato sul server a livello dati.

    Per ripristinare ciascun database, effettuare le operazioni descritte nella procedura seguente.

Per ripristinare un database

  1. Fare clic con il pulsante destro del mouse sul database che si desidera ripristinare, scegliere Attività, Ripristina, quindi fare clic su Database.

  2. Nella finestra di dialogo Ripristina database selezionare Periferica di origine nell'area Origine per il ripristino, quindi fare clic sul pulsante con i puntini di sospensione (…).

  3. Nella finestra di dialogo Seleziona backup immettere le informazioni per specificare il percorso del file di backup.

    Il primo backup che si applica deve essere un backup completo, seguito dai backup del registro delle transazioni nell'ordine di creazione.

  4. Scegliere OK per chiudere la finestra di dialogo Seleziona backup.

  5. Nell'area Selezionare i set di backup da ripristinare selezionare gli insiemi di backup da ripristinare.

  6. Nel riquadro di spostamento a sinistra selezionare Opzioni.

  7. Selezionare la casella di controllo Sovrascrivi il database esistente.

  8. Verificare che i percorsi specificati nell'area Ripristina file di database come corrispondano ai percorsi dei database correnti. Ciò è importante se si ripristina il database su un'unità diversa.

  9. Selezionare lo stato appropriato nell'area Stato di recupero.

  10. Se non si applicano altri registri delle transazioni, selezionare Lascia il database pronto per l'utilizzo.

    Se si applicano altri registri delle transazioni, selezionare Lascia il database non operativo.

  11. Scegliere OK per chiudere la finestra di dialogo Ripristina database e ripristinare il database.

  12. Se si applicano altri registri delle transazioni, seguire questa procedura per ciascun backup del registro, nell'ordine in cui sono stati creati, a partire da quello effettuato dopo il backup completo. Per ulteriori informazioni, vedere Applying Transaction Log Backups.

  13. Ripetere questa procedura per ciascun database elencato precedentemente.

    Nota di avviso Attenzione

    Tutti i database devono essere ripristinati nello stesso momento altrimenti risulteranno danneggiati.

Per ripristinare il database di Analysis Server

  1. Sul server Team Foundation a livello dati aprire un prompt dei comandi.

  2. Al prompt dei comandi spostarsi nella directory del programma, quindi digitare:

    cd Microsoft Visual Studio 2005 Team Foundation Server\Tools

  3. Al prompt dei comandi digitare:

    net stop TfsServerScheduler

  4. L'utilità di pianificazione verrà interrotta.

  5. Al prompt dei comandi digitare:

    setupwarehouse -o -s serverName -d TfsWarehouse -c warehouseschema.xml -ra serviceAccount -a serviceAccount

    Il cubo dei dati di Analysis Services basato sul database TfsWarehouse sottostante verrà rigenerato. Per ulteriori informazioni, vedere SetupWarehouse.

    Per impostazione predefinita, l'account di servizio di Team Foundation Server serviceAccount è domain\BISSVC. Per ulteriori informazioni, vedere Gestione dei servizi e degli account di servizio di Team Foundation Server.

  6. Aprire SQL Server Management Studio. A questo scopo fare clic sul pulsante Start, scegliere Tutti i programmi, Microsoft SQL Server e quindi SQL Server Management Studio.

  7. Selezionare Analysis Server in Tipo server. Selezionare lo schema Nome server e Autenticazione appropriato per il server. Fornire un nome utente e una password validi, se richiesti da SQL Server, quindi fare clic su Connetti.

  8. Espandere il nodo Database per visualizzare l'elenco dei database che costituiscono il livello dati di Team Foundation Server.

  9. Fare clic con il pulsante destro del mouse sul database TFSWarehouse, quindi scegliere Elabora.

  10. Scegliere OK nella finestra di dialogo Elaborazione database.

    Il data warehouse verrà elaborato.

  11. Al prompt dei comandi digitare:

    net start TfsServerScheduler

    L'utilità di pianificazione verrà avviata.

    Nota Nota

    Se è stato eseguito il backup di dati aggiuntivi che devono essere ripristinati, effettuare le operazioni appropriate per ripristinare tali dati. Ad esempio, è possibile che sia necessario ripristinare altri database SQL o siti di Windows SharePoint.

Riavvio dei server

Se si ripristinano i dati su un server diverso, è necessario eseguire altre operazioni prima di riavviare il server a livello dati. Per ulteriori informazioni, vedere Procedura: ripristinare i dati di Team Foundation Server su un server diverso.

Nota Nota

Non riavviare i server subito se si desidera ripristinare i dati su un server diverso.

Per riavviare i server

  1. Sul server Team Foundation a livello dati aprire un prompt dei comandi.

  2. Al prompt dei comandi digitare:

    iisreset /start

    IIS verrà riavviato sul server a livello dati.

  3. Sul server Team Foundation a livello applicazione aprire un prompt dei comandi.

  4. Al prompt dei comandi digitare:

    iisreset /start

    IIS verrà riavviato sul server a livello applicazione.

Per richiedere l'aggiornamento dei dati della cache sui client

  1. Sul server Team Foundation a livello applicazione aprire Internet Explorer.

  2. Nella barra dell'indirizzo digitare:

    http:// applicationTierServerName :8080/WorkItemTracking/v1.0/ClientService.asmx

    Verrà stabilita la connessione al servizio Web ClientService.

  3. Selezionare il metodo Web StampWorkitemCache.

  4. Fare clic su Richiama.

    I client inizializzeranno di nuovo la cache di gestione degli elementi di lavoro alla successiva connessione al livello applicazione.

Protezione

Per eseguire le attività descritte in questo argomento è necessario disporre delle autorizzazioni che consentono di ripristinare i database e interrompere e avviare IIS. Per potere svuotare la cache del client è necessario essere un membro del gruppo TFS Admin.

Vedere anche

Attività

Procedura: eseguire il backup di un Team Foundation Server

Altre risorse

Getting Started with Backup and Restore
Choosing a Recovery Strategy That Supports Your Applications
Gestione di dati
Gestione dei server a livello dati di Team Foundation Server
Gestione di Team Foundation Server


Procedura: ripristinare i dati di Team Foundation Server su un server diverso

Procedura: ripristinare i dati di Team Foundation Server su un server diverso
Vedere anche

In questo argomento viene descritto come ripristinare i dati di Team Foundation Server a livello dati su un altro server a livello dati. Questo tipo di ripristino consente inoltre di spostare i dati dal server originale su uno nuovo. Ciò risulta utile quando si sposta il livello dati su un nuovo server, ad esempio se si esegue un aggiornamento o in caso di errore del server originale. Se è necessario ripristinare i dati sul server a livello dati originale, vedere Procedura: ripristinare i dati di Team Foundation Server.

Nota Nota

Le istruzioni contenute in questo argomento richiedono che sul server sia presente una nuova installazione del livello dati di Team Foundation Server. Per ulteriori informazioni, vedere la guida all'installazione di Team Foundation. La versione più aggiornata della guida all'installazione di Team Foundation è disponibile in linea all'indirizzo http://go.microsoft.com/fwlink/?linkid=40042.

Per ripristinare un server Team Foundation Server su un server diverso da quello di backup, seguire la procedura descritta.

  • Ripristinare i dati.

  • Rinominare il livello dati.

  • Ripristinare le stringhe di connessione sul server di report.

  • Riavviare i server.

  • Richiedere l'aggiornamento dei dati della cache degli elementi di lavoro sui client.

Per ripristinare i dati

  • Per informazioni, vedere Procedura: ripristinare i dati di Team Foundation Server.

Per rinominare il livello dati

  1. Sul server Team Foundation a livello applicazione aprire un prompt dei comandi.

    Nota Nota

    Questa procedura è necessaria solo se il nome del server Team Foundation a livello dati è cambiato.

  2. Al prompt dei comandi spostarsi nella directory del programma, quindi digitare:

    cd Microsoft Visual Studio 2005 Team Foundation Server\Tools

  3. Al prompt dei comandi digitare:

    TfsAdminUtil renamedt NuovoNomeComputerLivelloDati

    Nota Nota

    Se IIS è attivo sul server a livello applicazione, viene richiesto di arrestarlo.

    L'utilità TfsAdminUtil consente di aggiornare le stringhe di connessione e altri riferimenti al computer a livello dati presenti sul livello applicazione. Per ulteriori informazioni, vedere Comandi della riga di comando TFSAdminUtil.

Per ripristinare le stringhe di connessione sul server di report

  1. Sul server Team Foundation a livello applicazione aprire Internet Explorer.

  2. Nella barra dell'indirizzo digitare http://applicationTierServerName/reports.

  3. Sul sito del server di report fare clic su TfsOlapReportDS.

    1. Assicurarsi che nella casella di testo Stringa di connessione siano visualizzate le informazioni di connessione corrette:

      Data source= NuovoNomeServerLivelloApplicazione ;initial catalog=TfsWarehouse

    2. Selezionare Credenziali archiviate nel server di report.

    3. Immettere dominio\account e password per il server di report del servizio TFSREPORTS, come descritto nella guida all'installazione.

    4. Selezionare Utilizza come credenziali di Windows per la connessione all'origine dati.

  4. Attenersi alla stessa procedura per TfsReportDS.

    1. Assicurarsi che nella casella di testo Stringa di connessione siano visualizzate le informazioni di connessione corrette:

      Data source= NuovoNomeServerLivelloApplicazione ;initial catalog=TfsWarehouse

    2. Selezionare Credenziali archiviate nel server di report.

    3. Immettere dominio\account e password per il server di report del servizio TFSREPORTS, come descritto nella guida all'installazione.

    4. Selezionare Utilizza come credenziali di Windows per la connessione all'origine dati.

Per riavviare i server

  1. Sul server Team Foundation a livello dati aprire un prompt dei comandi.

  2. Al prompt dei comandi digitare:

    iisreset /start

    IIS verrà riavviato sul server a livello dati.

  3. Sul server Team Foundation a livello applicazione aprire un prompt dei comandi.

  4. Al prompt dei comandi digitare:

    iisreset /start

    IIS verrà riavviato sul server a livello applicazione.

Per richiedere l'aggiornamento dei dati della cache degli elementi di lavoro sui client

  1. Sul server Team Foundation a livello applicazione aprire Internet Explorer.

  2. Nella barra dell'indirizzo digitare:

    http:// NomeServerLivelloApplicazione :8080/WorkItemTracking/v1.0/ClientService.asmx

    Verrà stabilita la connessione al servizio Web ClientService.

  3. Selezionare il metodo Web StampWorkitemCache.

  4. Fare clic su Richiama.

    I client inizializzeranno di nuovo automaticamente la cache di gestione degli elementi di lavoro alla successiva connessione al livello applicazione.

Protezione

Per eseguire le attività descritte in questo argomento è necessario disporre delle autorizzazioni che consentono di eseguire backup e creare piani di manutenzione su SQL Server. Per potere svuotare la cache del client è necessario essere un membro del gruppo TFS Admin.

Vedere anche

Attività

Procedura: eseguire il backup di un Team Foundation Server

Altre risorse

Gestione di dati
Gestione dei server a livello dati di Team Foundation Server
Gestione di Team Foundation Server


Procedura: configurare le impostazioni di amministrazione dell'area di lavoro

Procedura: configurare le impostazioni di amministrazione dell'area di lavoro
Vedere anche

Un'area di lavoro è la copia sul lato client dei file e delle cartelle presenti sul server del controllo del codice sorgente. Quando gli utenti aggiungono, modificano, eliminano, spostano, rinominano o manipolano in altro modo un elemento con controllo del codice sorgente, le modifiche vengono mantenute, o contrassegnate come modifiche in sospeso, nell'area di lavoro. Per motivi amministrativi, gli amministratori di Team Foundation Server potrebbero avere bisogno di creare o eliminare aree di lavoro per altri utenti oppure di annullare una modifica in sospeso o un blocco nell'area di lavoro di un altro utente. Per eseguire queste operazioni, è possibile utilizzare i comandi del controllo del codice sorgente di Team Foundation.

Per creare un'area di lavoro per un utente

  1. Fare clic sul pulsante Start, scegliere Tutti i programmi, Microsoft Visual Studio 2005, Strumenti di Visual Studio, quindi Prompt dei comandi di Visual Studio.

  2. Digitare mkdir path, dove path è il percorso della directory in cui si desidera l'utente memorizzi una copia personale dei file presenti sul server del controllo del codice sorgente. A scopi amministrativi potrebbe essere conveniente creare questa directory su una risorsa condivisa.

    Nota Nota

    Il percorso deve includere il nome della directory che si desidera aggiungere. Se il nome del percorso contiene degli spazi, racchiuderlo tra virgolette. Ad esempio, se il percorso della directory è D:\Progetti personali e la directory che si desidera aggiungere si chiama Applicazione Windows, digitare mkdir "D:\Progetti personali\Applicazione Windows".

  3. Digitare cd path, dove path è il nome della directory appena creata.

  4. Digitare tf workspace /new /s:servername, dove servername è il nome del server Team Foundation Server, quindi premere INVIO.

  5. Nella finestra di dialogo Crea area di lavoro immettere un nome nella casella Nome, quindi scegliere OK.

Per eliminare un'area di lavoro per un utente

  1. Fare clic sul pulsante Start, scegliere Tutti i programmi, Microsoft Visual Studio 2005, Strumenti di Visual Studio, quindi Prompt dei comandi di Visual Studio.

  2. Digitare cd path, dove path è il nome della directory che contiene l'area di lavoro che si desidera eliminare.

  3. Digitare tf workspace /delete [/s:servername] workspacename, dove servername è il nome del server Team Foundation Server e workspacename è il nome dell'area di lavoro che si desidera eliminare.

Modifica di aree di lavoro esistenti

Le aree di lavoro consentono di memorizzare e sincronizzare le copie locali degli elementi del controllo del codice di sorgente di Team Foundation. È possibile modificare queste aree di lavoro per cambiarne la proprietà, consentire ad altri utenti di accedervi e modificare altre impostazioni.

Per modificare un'area di lavoro

  1. Fare clic sul pulsante Start, selezionare Tutti i programmi, quindi scegliere Microsoft Visual Studio 2005.

  2. Scegliere Controllo del codice dal menu File, quindi Aree di lavoro.

  3. Nella colonna Nome della finestra di dialogo Gestisci aree di lavoro evidenziare l'area di lavoro che si desidera modificare, quindi fare clic su Modifica.

  4. Nella finestra di dialogo Modifica area di lavoro è possibile eseguire le seguenti operazioni a seconda delle necessità.

    1. Modificare il nome nella casella di testo Nome.

    2. Fornire, se necessario, dei valori alternativi per Proprietario e Nome computer.

    3. Immettere la descrizione delle modifiche apportate all'area di lavoro nella casella Commento.

    4. Modificare le cartelle di lavoro. Per ulteriori informazioni, vedere Procedura: creare un'area di lavoro.

    5. Scegliere OK per salvare le modifiche dell'area di lavoro.

    Nota Suggerimento:

    Dopo avere definito l'area di lavoro, fare clic con il pulsante destro del mouse sull'area di lavoro e utilizzare il comando Leggi ultima versione per inserire nell'area di lavoro il codice sorgente proveniente dal server

  5. Fare clic su Chiudi nella finestra di dialogo Gestisci aree di lavoro.

Annullamento delle modifiche in sospeso

Per annullare le modifiche in sospeso nell'area di lavoro di un altro utente, utilizzare il comando undo.

Per annullare una modifica in sospeso nell'area di lavoro di un altro utente

  1. Fare clic sul pulsante Start, scegliere Tutti i programmi, Microsoft Visual Studio 2005, Strumenti di Visual Studio, quindi Prompt dei comandi di Visual Studio.

  2. Digitare cd path, dove path è il percorso della directory che contiene l'area di lavoro dell'utente.

  3. Digitare tf undo FolderOrFilename, dove FolderOrFilename è il nome del file o della cartella per cui si desidera annullare le modifiche in sospeso, quindi premere INVIO.

    Nota Nota

    Se si utilizza il comando undo per annullare una modifica in sospeso nell'area di lavoro di un altro utente, è necessario eseguire un'operazione get nell'area di lavoro per aggiornare il disco locale. Non solo è necessario eseguire get, ma potrebbe essere necessario eseguire get /all per i file che sono stati annullati per ottenere il contenuto corretto dei file che sono stati modificati.

Annullamento di blocchi

Se un utente blocca un file per utilizzarlo in un'area di lavoro ed è necessario consentire l'accesso ad altri utenti, è possibile sbloccare il file nell'area di lavoro mediante il comando lock.

Per sbloccare una cartella o un file in un'area di lavoro

  1. Fare clic sul pulsante Start, scegliere Tutti i programmi, Microsoft Visual Studio 2005, Strumenti di Visual Studio, quindi Prompt dei comandi di Visual Studio.

  2. Digitare cd path, dove path è il nome della directory che contiene l'area di lavoro in cui si desidera sbloccare un file.

  3. Digitare tf lock itemspec /lock:none /workspace:workspacename, dove itemspec è il nome del file o della cartella che si desidera sbloccare e workspacename è il nome dell'area di lavoro che contiene l'elemento che si desidera sbloccare.

Protezione

In questo contesto vengono applicati i privilegi o le autorizzazioni di protezione di Team Foundation Build. Per ulteriori informazioni, vedere Autorizzazioni e privilegi di protezione di Team Build.

Vedere anche

Riferimenti

Comando Workspace
Comando Workspaces
Comando Lock
Comando Undo

Concetti

Utilizzo delle aree di lavoro per il controllo del codice sorgente

Altre risorse

Riferimenti alla riga di comando del controllo del codice sorgente di Team Foundation


Procedura: eliminare permanentemente i file orfani

Procedura: eliminare permanentemente i file orfani

È possibile che sia necessario eliminare permanentemente i file che rimangono orfani quando un utente client elimina un allegato da un elemento di lavoro, ad esempio nel caso in cui il file allegato a un elemento di lavoro è danneggiato o infetto da virus.

Quando si elimina, il file viene rimosso dall'elemento di lavoro e dal progetto, ma nei database rimangono le righe per i metadati e il contenuto. RemovedDate viene però impostato sulla data e ora corrente e il file risulta orfano. In qualità di amministratore è possibile eliminare l'allegato in modo permanente.

Il contenuto del file viene memorizzato nel database TfsWorkItemTrackingAttachment come singola voce per il file. Questa voce include un GUID e il contenuto sotto forma di immagine.

I metadati per il file vengono memorizzati nella tabella WorkItemFiles del database TfsWorkItemTracking. Tra i metadati figurano il numero ID dell'elemento di lavoro.

Per eliminare un file allegato orfano di un elemento di lavoro

  1. In Team Explorer aprire l'elemento di lavoro ed eliminare il file dalla scheda File.

    Nota Nota

    L'utente client o l'amministratore possono eliminare il file e renderlo orfano nel database.

  2. Accedere al server a livello dati come utente con autorizzazioni di amministrazione del database.

  3. Fare clic sul pulsante Start, scegliere Tutti i programmi, Microsoft SQL Server 2005 e quindi SQL Server Management Studio.

  4. Nella finestra di dialogo Connetti al server selezionare il server, quindi fare clic su Connetti.

    Nota Nota

    Se il nome del server non è presente nella finestra di dialogo, è possibile digitarlo direttamente nella casella combinata.

  5. Eseguire una query nel database TfsWorkItemTracking per ottenere l'elenco degli allegati per l'elemento di lavoro.

    Ad esempio, è possibile utilizzare la seguente query che restituisce tutti gli elementi con allegati in base al valore FldID 50 e all'ID dell'elemento di lavoro:

    Immagine CopyCode Copia codice
    USE TfsWorkItemTracking
GO
SELECT * FROM WorkItemFiles WHERE FldID=50 AND ID = 15

  6. Nella colonna OriginalName dei risultati della query individuare il nome del file e annotare il GUID presente nella colonna FilePath.

  7. Nel database TfsWorkItemAttachment eseguire una query Delete basata sul GUID.

    Nota Nota

    Una volta eseguita, la query di eliminazione non potrà essere annullata. È dunque opportuno eseguire una copia di backup dei dati prima di eseguire la query di eliminazione.

    Immagine CopyCode Copia codice
    USE TfsWorkItemAttachment
GO
DELETE FROM Attachments WHERE FileGuid=<<GUID>>

Protezione

È necessario disporre delle autorizzazioni di amministrazione del database per potere eseguire comandi di eliminazione. Dopo che un file infetto da virus è stato rimosso dal progetto Team, non è più disponibile.

Vedere anche

Altre risorse

Gestione di dati


Gestione dei servizi SQL Server

 elenco a discesa elenco a discesa attivabile
Gestione dei servizi SQL Server
Vedere anche
elenco a discesa

Team Foundation Server si basa su tre componenti di Microsoft SQL Server 2005. Team Foundation Server utilizza:

  • Database SQL Server per memorizzare le informazioni operative relative ai singoli componenti e al data warehouse.

  • SQL Server Analysis Services per aggregare e riepilogare i dati nel data warehouse.

  • SQL Server Reporting Services per generare e memorizzare report sui progetti Team.

Gli amministratori di Team Foundation non devono svolgere compiti o operazioni speciali per la gestione dei servizi SQL Server per Team Foundation Server. Assicurarsi che i servizi SQL Server siano disponibili e funzionino correttamente in base a quanto descritto nella documentazione in linea di ciascun componente.

Per ulteriori informazioni sulla gestione dei database SQL Server, vedere SQL Server Administration How-to Topics.

Per ulteriori informazioni sulla gestione di SQL Server Analysis Services, vedere Administering Analysis Services.

Per ulteriori informazioni sulla gestione di SQL Server Reporting Services, vedere Administering Reporting Services.

Vedere anche

Attività

Risoluzione dei problemi relativi alla generazione di report di Team Foundation

Concetti

Troubleshooting the Data Warehouse
Concetti sulla protezione di Team Foundation Server

Altre risorse

Backup e ripristino dei dati di Team Foundation Server
Gestione di Team Foundation Server


Gestione dei componenti di Team Foundation Server

 elenco a discesa elenco a discesa attivabile
Gestione dei componenti di Team Foundation Server
Vedere anche
elenco a discesa

In questa sezione sono forniti argomenti che descrivono come gestire i componenti di Team Foundation Server.

In questa sezione

Verifica della disponibilità e del failover di Team Foundation Server

Vengono forniti collegamenti ad argomenti che descrivono come garantire la disponibilità di Team Foundation Server.

Gestione dei server a livello dati di Team Foundation Server

Vengono forniti collegamenti ad argomenti che illustrano come gestire server a livello dati.

Gestione dei server a livello applicazione di Team Foundation Server

Vengono forniti collegamenti ad argomenti che illustrano come gestire server a livello applicazione.

Vedere anche

Altre risorse

Gestione di Team Foundation Server
Pianificazione di Team Foundation Server


Verifica della disponibilità e del failover di Team Foundation Server

 elenco a discesa elenco a discesa attivabile
Verifica della disponibilità e del failover di Team Foundation Server
Vedere anche
elenco a discesa

È possibile garantire a disponibilità di Team Foundation Server applicando una delle tre strategie di base. La strategia scelta dipende dal tempo di inattività considerato tollerabile per gli utenti e dalla topologia del sistema.

Strategie di disponibilità

In genere, le topologie a server singolo o doppio sono in grado di tollerare tempi di inattività ragionevoli per la manutenzione o il ripristino del sistema in caso di errore. I sistemi complessi possono invece fornire un servizio ininterrotto tramite risorse dedicate. Le strategie illustrate di seguito forniscono diversi livelli di disponibilità per Team Foundation Server.

  • Pratiche di backup standard A livello dati e applicazione è possibile mantenere backup dei database e utilizzarli per eseguire il ripristino in tempi ragionevoli senza ricorrere a computer o risorse di manutenzione aggiuntive.

  • Sistema in standby a caldo Oltre alle pratiche di backup standard, è possibile impostare e mantenere un sistema in standby a caldo per ridurre i tempi di ripristino. Questa strategia richiede hardware aggiuntivo e, pertanto, ulteriore manutenzione del sistema per garantire che l'hardware sia aggiornato e pronto all'uso.

  • Clustering Per i sistemi complessi è possibile impostare e mantenere server dedicati in cluster per garantire un servizio ininterrotto a livello dati. Questa strategia comporta un aumento notevole dei costi in termini di risorse e manutenzione a causa dei rigidi requisiti dei computer failover. L'hardware, ad esempio, deve corrispondere esattamente e appartenere all'elenco approvato.

Pratiche di backup standard

Per il livello dati di Team Foundation è possibile implementare le stesse procedure ottimali applicate per qualsiasi database SQL Server. Per il livello applicazione è possibile implementare le stesse procedure ottimali applicate per il backup e il ripristino di qualsiasi insieme di siti in Windows SharePoint Services.

Sistema in standby a caldo

Se si dispone delle risorse per gestire un sistema in standby, è possibile configurare computer aggiuntivi per eliminare i tempi di inattività necessari per il ripristino del computer primario per il livello applicazione. È possibile impostare e mantenere un secondo server a livello applicazione. Il computer deve disporre degli stesso aggiornamenti software del computer primario e di autorizzazioni e account utente aggiornati come nel computer primario. Il livello applicazione non può essere parte di una Web farm. Quando è necessario utilizzare il sistema in standby, eseguire il comando ATActivate di failover che consente di cambiare l'associazione del livello dati dal server a livello applicazione primario al server failover.

Le applicazioni client si connettono al livello applicazione primario che si connette a sua volta al server a livello dati primario utilizzando il nome del server. In qualità di amministratore di sistema, è necessario passare manualmente al server mirror in caso di failover. Come soluzione di standby a caldo viene impostato il protocollo VIP (Virtual Internet protocol). Il server mirror in standby esegue il monitoraggio continuo del server primario per rilevare eventuali errori hardware inviando un segnale heartbeat in rete. La perdita di tale segnale indica che il server primario non è disponibile.

Clustering

Se il sistema richiede una disponibilità molto elevata e si è in grado di assorbire i costi di risorse aggiuntive, è possibile fornire disponibilità ininterrotta a livello dati utilizzando il clustering. La tecnologia del Servizio cluster di Windows consente di creare un cluster di due computer. Per il livello applicazione è possibile impostare e mantenere un server in standby a caldo.

Vedere anche

Concetti

Pianificazione di backup e ripristino
Impostazione e attivazione di un server failover a livello applicazione
Clustering del server a livello dati
Pianificazione del ripristino di emergenza

Altre risorse

Gestione di dati
Backup e ripristino dei dati di Team Foundation Server


Clustering del server a livello dati

 elenco a discesa elenco a discesa attivabile
Clustering del server a livello dati
Vedere anche
elenco a discesa

Per garantire la continuità del servizio da parte di Team Foundation Server, installare il livello dati su un cluster di computer corrispondenti dedicati. In genere questa strategia di disponibilità è efficace in termini di costi per le organizzazioni di grandi dimensioni che dispongono delle risorse per impostare e mantenere una topologia complessa.

Installazione del livello dati su un cluster

Sebbene Windows 2003 Server offra un'ampia gamma di configurazioni cluster, Team Foundation Server ne supporta una molto specifica. Se si decide di investire risorse nell'utilizzo di cluster, tenere presente che Team Foundation Server supporta un cluster che utilizza una configurazione di server di periferica a singolo quorum che implementa la modalità hot standby e serve due nodi.

Server di periferica a singolo quorum

La periferica a singolo quorum consente ai client di vedere due nodi come un unico server. Il quorum è la periferica di memorizzazione controllata dal nodo primario per il livello dati e gestisce il nodo che funge da nodo primario. Solo un nodo alla volta può possedere il quorum. Quando il livello dati esegue il failover sul nodo di standby, quest'ultimo assume la proprietà del quorum e del livello dati. Quando i due nodi sono associati a un'unica periferica di memorizzazione, il quorum può essere creato sulla periferica di memorizzazione.

I cluster vengono gestiti mediante il programma Windows Cluster Management installato con Windows Server 2003 Enterprise Edition o Windows Server 2003 Datacenter Edition. SQL Server fornisce le risorse per ciascun nodo del cluster.

Per informazioni complete sui cluster, vedere Virtual Servers.

SQL Server e cluster

La configurazione di SQL Server riconosce i cluster. Team Foundation Server può servire l'istanza predefinita di SQL Server in esecuzione sul computer e che non utilizza un'istanza con un nome. Non modificare le password per gli account di servizio di SQL Server quando un nodo di cluster failover è bloccato o non in linea. Se occorresse eseguire questa operazione, sarà necessario reimpostare la password con Enterprise Manager quando tutti i nodi sono di nuovo in linea.

Se l'account di servizio per SQL Server non è un amministratore in un cluster, le condivisioni amministrative non possono essere eliminate sui nodi del cluster. Le condivisioni amministrative devono essere disponibili in un cluster per garantire il funzionamento di SQL Server.

Account utente del cluster

Dopo la creazione di un cluster, un account di servizio cluster diventa membro del gruppo degli utenti autenticati. L'account di servizio cluster deve disporre almeno delle autorizzazioni seguenti.

  • Reimpostazione della password sull'oggetto computer virtuale.

  • Scrittura dell'attributo DnsHostName nell'oggetto.

  • Scrittura dell'attributo ServicePrincipalName nell'oggetto.

  • Creazione di oggetti di configurazione Accodamento messaggi se la risorsa del nome della rete dipende da una risorsa Accodamento messaggi.

Vedere anche

Riferimenti

Elenco di controllo: configurazione del cluster

Concetti

Procedura: eseguire il clustering di un server a livello dati
Verifica della disponibilità e del failover di Team Foundation Server

Altre risorse

Gestione di dati


Elenco di controllo: configurazione del cluster

 elenco a discesa elenco a discesa attivabile
Elenco di controllo: configurazione del cluster
Vedere anche
comprimi tutto elenco a discesa

Questo elenco di controllo non è disponibile in questa versione della Guida dell'amministratore di Team Foundation. La versione più aggiornata di questo argomento è disponibile in linea sul sito Web Microsoft: http://go.microsoft.com/fwlink/?linkid=52459.

espandi Vedere anche

Concetti

Clustering del server a livello dati
Procedura: eseguire il clustering di un server a livello dati

piè di pagina


Impostazione e attivazione di un server failover a livello applicazione

 elenco a discesa elenco a discesa attivabile
Impostazione e attivazione di un server failover a livello applicazione
Vedere anche
elenco a discesa

È possibile impostare un computer failover per il server a livello applicazione di Team Foundation dopo avere impostato i server primari a livello dati e applicazione.

Considerazioni sulla configurazione del computer failover

La configurazione del computer failover deve corrispondere a quella del computer primario. I computer non devono essere identici, ma il computer failover deve soddisfare i requisiti di sistema per Team Foundation. Per il computer failover è possibile soddisfare gli stessi prerequisiti ed eseguire le stesse operazioni di installazione di Team Foundation del computer primario.

Per ulteriori informazioni sull'installazione, vedere la sezione relativa all'installazione di Team Foundation Server (servizi) nella guida all'installazione di Team Foundation Server. È possibile scaricare la versione più aggiornata della guida all'installazione di Team Foundation all'indirizzo http://go.microsoft.com/fwlink/?linkid=40042 o aprire il file della guida TFSInstall.chm sul disco rigido. In questa versione della guida dell'amministratore di Team Foundation non sono disponibili informazioni sull'installazione del livello applicazione su una coppia attiva/passiva utilizzando il nome di un server virtuale. La versione più aggiornata di questo argomento è disponibile sul sito Web Microsoft (http://go.microsoft.com/fwlink/?linkid=52459).

Per assicurarsi che il computer sia pronto, è necessario aggiornare il computer failover periodicamente in modo che corrisponda a quello primario. Gli eventuali aggiornamenti eseguiti sul computer primario devono essere ripetuti su quello failover. Ad esempio, tutti gli aggiornamenti di sistema, gli aggiornamenti software e le modifiche delle autorizzazioni devono essere eseguiti anche sul computer failover.

Attivazione del server failover

Se sul server primario si verifica un errore, è necessario avviare manualmente il server failover. Team Foundation include il comando ActivateAT dell'utilità TFSAdminUtil per il server a livello applicazione che esegue le operazioni descritte di seguito.

  • Arresta i servizi Web sul server a livello applicazione originale e avvia i servizi Web sul server failover.

  • Registra il nome del computer failover nel database di integrazione di Team Foundation.

  • Connette il server failover a livello di applicazione al server a livello dati attivo.

  • Verifica che al server a livello dati corretto sia connesso il server a livello applicazione appropriato.

Vedere anche

Riferimenti

Comando ActivateAt

Concetti

Verifica della disponibilità e del failover di Team Foundation Server
Procedura: impostare e attivare un server failover a livello applicazione

Altre risorse

Gestione di dati


Gestione dei server a livello dati di Team Foundation Server

 elenco a discesa elenco a discesa attivabile
Gestione dei server a livello dati di Team Foundation Server
Vedere anche
elenco a discesa

In questa sezione sono riportati collegamenti ad argomenti in cui viene illustrato come gestire il server a livello dati in Team Foundation Server.

In questa sezione

Procedura: eseguire il clustering di un server a livello dati

Viene illustrato come eseguire il clustering di un server a livello dati.

Procedura: rinominare un server a livello dati

Viene illustrato come rinominare un server a livello dati.

Procedura: ripristinare un server a livello dati

Viene spiegato in dettaglio come ripristinare un server a livello dati.

Procedura: disinstallare un server a livello dati

Viene descritto come disinstallare un server a livello dati.

Vedere anche

Concetti

Gestione dei server a livello applicazione di Team Foundation Server

Altre risorse

Gestione dei componenti di Team Foundation Server


Procedura: eseguire il clustering di un server a livello dati

 elenco a discesa elenco a discesa attivabile
Procedura: eseguire il clustering di un server a livello dati
Vedere anche
elenco a discesa

Questa procedura non è disponibile in questa versione della Guida dell'amministratore di Team Foundation. La versione più aggiornata di questo argomento è disponibile in linea sul sito Web Microsoft (http://go.microsoft.com/fwlink/?linkid=52459).

Vedere anche

Attività

Procedura: ripristinare i dati di Team Foundation Server su un server diverso

Riferimenti

Elenco di controllo: configurazione del cluster

Concetti

Clustering del server a livello dati

Altre risorse

Gestione di dati


Procedura: rinominare un server a livello dati

Procedura: rinominare un server a livello dati

Se necessario, è possibile assegnare un nuovo nome a un server a livello dati ridenominando il computer che ospita il livello dati e quindi utilizzando l'utilità della riga di comando TFSAdminUtil.

Per rinominare un server a livello dati

  1. Sul computer in cui risiede il livello dati, in Windows, fare clic sul pulsante Start, fare clic con il pulsante destro del mouse su Risorse del computer, quindi scegliere Proprietà.

    Verrà visualizzata la finestra Proprietà del sistema.

  2. Nella scheda Nome computer fare clic su Cambia.

    Verrà visualizzata la finestra Cambiamenti nome computer.

  3. Nella casella Nome computer digitare il nuovo nome del computer, quindi scegliere OK.

  4. Sul computer in cui risiede il livello applicazione, fare clic sul pulsante Start di Windows, selezionare Tutti i programmi, Accessori, quindi Prompt dei comandi.

    Verrà visualizzato il prompt dei comandi.

  5. Nella riga di comando digitare Programmi\Microsoft Visual Studio 2005 Team Foundation Server\Tools. Ad esempio:

    cd C:\Program Files\Microsoft Visual Studio 2005 Team Foundation Server\Tools

  6. Eseguire lo strumento TFSAdminUtil con l'opzione RenameDT per connettersi al livello dati come descritto di seguito:

    TFSAdminUtil RenameDT MyDataTierServer

    In questo esempio MyDataTierServer rappresenta il nome del server a livello dati a cui si desidera connettersi.

Vedere anche

Attività

Procedura: rinominare un server a livello applicazione
Procedura: eseguire la connessione di un server a livello applicazione differente al livello dati

Altre risorse

Gestione dei server a livello dati di Team Foundation Server
Comandi della riga di comando TFSAdminUtil


Procedura: ripristinare un server a livello dati

Procedura: ripristinare un server a livello dati

Nel caso in cui sia necessario ripristinare l'installazione di un server a livello dati danneggiata, attenersi alla procedura descritta di seguito.

Per ripristinare un server a livello dati

  1. Sul computer in cui risiede il livello dati fare clic sul pulsante Start, selezionare Pannello di controllo, quindi scegliere Installazione applicazioni.

    Verrà visualizzata la finestra Installazione applicazioni.

  2. Selezionare Microsoft Visual Studio 2005 Team Foundation Server (database) e fare clic su Cambia/Rimuovi.

    Verrà avviata Installazione guidata di Visual Studio 2005 Team Foundation Server (database).

  3. Nella finestra visualizzata selezionare Ripristina/Reinstalla, scegliere Avanti e attenersi alle istruzioni dell'installazione guidata.

Vedere anche

Attività

Procedura: disinstallare un server a livello dati
Procedura: ripristinare un server a livello applicazione
Procedura: disinstallare un server a livello applicazione


Procedura: disinstallare un server a livello dati

Procedura: disinstallare un server a livello dati

Se è necessario disinstallare un server a livello dati per diversi motivi, attenersi alla procedura descritta di seguito.

Per disinstallare un server a livello dati

  1. Sul computer in cui risiede il livello dati fare clic sul pulsante Start, selezionare Pannello di controllo, quindi scegliere Installazione applicazioni.

    Verrà visualizzata la finestra Installazione applicazioni.

  2. Selezionare Microsoft Visual Studio 2005 Team Foundation Server (database), quindi fare clic su Cambia/Rimuovi.

    Verrà avviata Installazione guidata di Visual Studio 2005 Team Foundation Server (database).

  3. Nella finestra visualizzata selezionare Disinstalla, scegliere Avanti e attenersi alle istruzioni dell'installazione guidata.

Vedere anche

Attività

Procedura: ripristinare un server a livello applicazione
Procedura: disinstallare un server a livello applicazione
Procedura: ripristinare un server a livello dati


Gestione dei server a livello applicazione di Team Foundation Server

 elenco a discesa elenco a discesa attivabile
Gestione dei server a livello applicazione di Team Foundation Server
Vedere anche
elenco a discesa

In questa sezione sono riportati collegamenti ad argomenti in cui viene illustrato come gestire il server a livello applicazione in Team Foundation Server.

In questa sezione

Procedura: impostare e attivare un server failover a livello applicazione

Viene illustrato come configurare e attivare un server a livello applicazione passivo.

Procedura: rinominare un server a livello applicazione

Viene illustrato come rinominare un server a livello applicazione.

Procedura: ripristinare un server a livello applicazione

Viene illustrato come ripristinare un server a livello applicazione.

Procedura: eseguire la connessione di un server a livello applicazione differente al livello dati

Viene descritto come connettere un server a livello applicazione diverso a un server a livello dati esistente.

Procedura: disinstallare un server a livello applicazione

Viene descritto come disinstallare un server a livello applicazione.

Vedere anche

Altre risorse

Gestione dei server a livello dati di Team Foundation Server
Gestione dei componenti di Team Foundation Server


Procedura: impostare e attivare un server failover a livello applicazione

 elenco a discesa elenco a discesa attivabile
Procedura: impostare e attivare un server failover a livello applicazione
Vedere anche
elenco a discesa

Questa procedura non è disponibile in questa versione della Guida dell'amministratore di Team Foundation. La versione più aggiornata di questo argomento è disponibile in linea sul sito Web Microsoft (http://go.microsoft.com/fwlink/?linkid=52459).

Vedere anche

Riferimenti

Comando ActivateAt

Concetti

Verifica della disponibilità e del failover di Team Foundation Server

Altre risorse

Gestione di dati


Procedura: rinominare un server a livello applicazione

Procedura: rinominare un server a livello applicazione

Se necessario, è possibile assegnare un nuovo nome a un server a livello applicazione ridenominando il computer e quindi utilizzando l'utilità della riga di comando TFSAdminUtil.

Per rinominare un server a livello applicazione

  1. Sul computer in cui risiede il livello applicazione, in Windows, fare clic sul pulsante Start, fare clic con il pulsante destro del mouse su Risorse del computer, quindi scegliere Proprietà.

    Verrà visualizzata la finestra Proprietà del sistema.

  2. Nella scheda Nome computer fare clic su Cambia.

    Verrà visualizzata la finestra Cambiamenti nome computer.

  3. Nella casella Nome computer digitare il nuovo nome del computer, quindi scegliere OK.

  4. Fare clic sul pulsante Start di Windows, selezionare Tutti i programmi, Accessori, quindi Prompt dei comandi.

    Verrà visualizzato il prompt dei comandi.

  5. Nella riga di comando digitare Programmi\Microsoft Visual Studio 2005 Team Foundation Server\Tools. Ad esempio:

    cd C:\Program Files\Microsoft Visual Studio 2005 Team Foundation Server\Tools

  6. Eseguire lo strumento TFSAdminUtil con l'opzione ActivateAT per attivare il livello applicazione come descritto di seguito:

    TFSAdminUtil ActivateAT

Gli utenti client dovranno connettersi al server a livello applicazione appena rinominato se prima lo utilizzavano con il nome precedente. Per gli utenti client connessi al server a livello applicazione durante la ridenominazione potrebbero essere necessario aggiornare le cache di Team Foundation Server ed eseguire il comando devenv /resetuserdata o attendere due ore prima di riprovare a connettersi.

Vedere anche

Attività

Procedura: rinominare un server a livello dati

Concetti

Gestione dei server a livello applicazione di Team Foundation Server

Altre risorse

Comandi della riga di comando TFSAdminUtil


Procedura: ripristinare un server a livello applicazione

Procedura: ripristinare un server a livello applicazione

Nel caso in cui sia necessario ripristinare l'installazione di un server a livello applicazione danneggiata, attenersi alla procedura descritta di seguito.

Per ripristinare un server a livello applicazione

  1. Sul computer in cui risiede il livello applicazione fare clic sul pulsante Start, selezionare Pannello di controllo, quindi scegliere Installazione applicazioni.

    Verrà visualizzata la finestra Installazione applicazioni.

  2. Selezionare Microsoft Visual Studio 2005 Team Foundation Server (servizi) e fare clic su Cambia/Rimuovi.

    Verrà avviata Installazione guidata di Visual Studio 2005 Team Foundation Server (servizi).

  3. Nella finestra visualizzata selezionare Ripristina/Reinstalla, scegliere Avanti e attenersi alle istruzioni dell'installazione guidata.

Vedere anche

Attività

Procedura: disinstallare un server a livello dati
Procedura: disinstallare un server a livello applicazione
Procedura: ripristinare un server a livello dati


Procedura: eseguire la connessione di un server a livello applicazione differente al livello dati

Procedura: eseguire la connessione di un server a livello applicazione differente al livello dati
Vedere anche

È possibile eseguire la connessione di un server a livello applicazione a un server a livello dati esistente utilizzando lo strumento della riga di comando TFSAdminUtil.exe.

Per eseguire la connessione di un server a livello applicazione al livello dati

  1. Sul computer a livello applicazione fare clic sul pulsante Start di Windows, selezionare Tutti i programmi, Accessori, quindi Prompt dei comandi.

    Verrà visualizzato il prompt dei comandi.

  2. Nella riga di comando digitare Programmi\Microsoft Visual Studio 2005 Team Foundation Server\Tools. Ad esempio:

    cd C:\Program Files\Microsoft Visual Studio 2005 Team Foundation Server\Tools

  3. Eseguire lo strumento TFSAdminUtil.exe con l'opzione RenameDT per connettersi al livello dati, ad esempio:

    TFSAdminUtil.exe RenameDT MyDataTierServer

    In questo esempio MyDataTierServer rappresenta il nome del server a livello dati a cui si desidera connettersi.

Vedere anche

Concetti

Gestione dei server a livello applicazione di Team Foundation Server

Altre risorse

Comandi della riga di comando TFSAdminUtil


Procedura: disinstallare un server a livello applicazione

Procedura: disinstallare un server a livello applicazione

Se è necessario disinstallare un server a livello applicazione per diversi motivi, attenersi alla procedura descritta di seguito.

Per disinstallare un server a livello applicazione

  1. Sul computer in cui risiede il livello applicazione fare clic sul pulsante Start, selezionare Pannello di controllo, quindi scegliere Installazione applicazioni.

    Verrà visualizzata la finestra Installazione applicazioni.

  2. Selezionare Microsoft Visual Studio 2005 Team Foundation Server (servizi), quindi fare clic su Cambia/Rimuovi.

    Verrà avviata Installazione guidata di Visual Studio 2005 Team Foundation Server (servizi).

  3. Nella finestra visualizzata selezionare Disinstalla, scegliere Avanti e attenersi alle istruzioni dell'installazione guidata.

Vedere anche

Attività

Procedura: disinstallare un server a livello dati
Procedura: ripristinare un server a livello applicazione
Procedura: ripristinare un server a livello dati


Gestione di Team Foundation Server in un dominio Active Directory

 elenco a discesa elenco a discesa attivabile
Gestione di Team Foundation Server in un dominio Active Directory
Vedere anche
elenco a discesa

Quando Team Foundation Server viene distribuito in un dominio Active Directory, Team Foundation Server utilizza le identità di Windows memorizzate in Active Directory.

In questa sezione

Considerazioni su trust e insiemi di strutture per Team Foundation Server

Vengono presentate delle considerazioni per eseguire una distribuizione stabile e protetta di Team Foundation Server in un ambiente Active Directory.

Configurazioni di dominio non supportate

Vengono forniti esempi di configurazioni di dominio non supportate.

Vedere anche

Altre risorse

Gestione di Team Foundation Server
Topologie di Team Foundation Server


Considerazioni su trust e insiemi di strutture per Team Foundation Server

 elenco a discesa elenco a discesa attivabile
Considerazioni su trust e insiemi di strutture per Team Foundation Server
Vedere anche
elenco a discesa

Team Foundation Server fornisce una base per la collaborazione tra gruppi tra domini diversi o anche tra insiemi di strutture differenti. Al fine di garantire la protezione e la stabilità del server e del dominio, è necessario attenersi ad alcune linee guida importanti.

Team Foundation Server è supportato nelle modalità di Active Directory e livelli funzionali seguenti:

  • Active Directory di Windows 2000 in modalità nativa

  • Active Directory di Windows Server 2003 al livello funzionale di Windows 2000 nativo

  • Active Directory di Windows Server 2003 al livello funzionale di Windows Server 2003

Nota Nota

Team Foundation Server non supporta le modalità di autenticazione e i livelli funzionali di Windows NT 4.0.

I livelli dati e applicazione di Team Foundation devono essere nello stesso dominio, mentre i client che si connettono possono appartenere a percorsi di dominio diversi.

Team Foundation pertanto supporta le seguenti configurazioni di trust di dominio:

  • Dominio unico

  • Dominio unico in cui il livello applicazione è anche il controller di dominio

  • Trust bidirezionale transitivo predefinito nello stesso insieme di strutture

Tutte le altre configurazioni di dominio di Active Directory non sono supportate e non devono quindi essere utilizzate. Assicurarsi che il dominio in cui si installa Team Foundation Server supporti Team Foundation Server e che i singoli computer su cui è installato Team Foundation Server siano in ambienti di dominio appropriati. Se Team Foundation Server supporta la collaborazione tra più insiemi di strutture, devono essere disponibili trust appropriati tra gli insiemi di strutture.

Per motivi di sicurezza, si consiglia di installare Team Foundation Server in un ambiente di dominio Windows Server 2003. Per evitare attacchi di rappresentazione utente, non consentire l'uso di nomi duplicati e proteggere i nomi dei computer mediante autore. Per ulteriori informazioni, vedere la documentazione relativa ad Active Directory di Windows Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?linkid=47541.

Vedere anche

Concetti

Configurazioni di dominio non supportate

Altre risorse

Gestione di Team Foundation Server in un dominio Active Directory
Topologie di Team Foundation Server


Configurazioni di dominio non supportate

 elenco a discesa elenco a discesa attivabile
Configurazioni di dominio non supportate
Vedere anche
elenco a discesa

Le configurazioni di dominio Active Directory seguenti sono supportate da Team Foundation Server:

  • Windows 2000 nativo

  • Windows Server 2003 nativo

Tutte le altre configurazioni di dominio non sono supportate. Di seguito sono riportati alcuni esempi specifici di configurazioni di dominio di Team Foundation Server non supportate:

  • Controller di dominio Windows NT 4.0

  • Livello funzionale di Windows 2000 misto

  • Livello funzionale di Windows 2003 interim

  • Configurazione del livello applicazione e dati tra domini o sottodomini diversi.

  • Configurazione del livello applicazione e dati tra un dominio e un gruppo di lavoro.

Alcuni esempi di topologie di dominio supportate sono disponibili in Topologia semplice di Team Foundation Server, Topologia moderata di Team Foundation Server e Topologia complessa di Team Foundation Server.

Vedere anche

Altre risorse

Gestione di Team Foundation Server in un dominio Active Directory
Topologie di Team Foundation Server


Gestione di Team Foundation Server in un gruppo di lavoro

 elenco a discesa elenco a discesa attivabile
Gestione di Team Foundation Server in un gruppo di lavoro
Vedere anche
elenco a discesa

La gestione di Team Foundation Server in un ambiente di gruppo di lavoro è possibile, ma può presentare qualche problema. In questo argomento vengono brevemente elencati i pro e i contro dell'utilizzo di Team Foundation Server in un gruppo di lavoro.

La differenza principale in un ambiente di gruppo di lavoro è l'assenza di Active Directory. Se, da un lato, l'assenza di Active Directory comporta un carico minore per l'amministratore, dall'altro può rappresentare un problema per i gruppi di grandi dimensioni. Gli account locali devono essere creati in Team Foundation Server per ciascun utente che richiede l'accesso a Team Foundation Server e alle relative risorse. Ciò significa che, a eccezione dei gruppi di lavoro molto piccoli, la gestione degli account richiesta per i gruppi di lavoro può diventare estremamente complessa.

Per proteggere Team Foundation Server da attacchi di rappresentazione utente in un gruppo di lavoro, utilizzare Secure Socket Layer (SSL) e impostare il client in modo che consideri affidabili solo i server con certificati designati.

In altre parole, gli ambienti Active Directory sono consigliati per la maggior parte delle distribuzioni di Team Foundation Server. Se è necessario distribuire Team Foundation Server in un gruppo di lavoro, distribuirlo solo in gruppi di lavoro con un numero molto basso di utenti e computer.

Vedere anche

Altre risorse

Gestione di Team Foundation Server in un dominio Active Directory
Gestione di Team Foundation Server


Gestione delle connessioni remote a Team Foundation Server Proxy

 elenco a discesa elenco a discesa attivabile
Gestione delle connessioni remote a Team Foundation Server Proxy
Vedere anche
elenco a discesa

Team Foundation Server fornisce ai team distribuiti il supporto per utilizzare il controllo del codice sorgente tramite il proxy di Team Foundation Server, che gestisce una cache dei file di controllo del codice sorgente scaricati nel percorso del team distribuito. La gestione del download e della memorizzazione nella cache dei file del codice sorgente da parte del proxy consente di ridurre in modo significativo la larghezza di banda necessaria per le connessioni di rete WAN. Se si configura il client per l'utilizzo del proxy, la gestione dei file è trasparente all'utente. Lo scambio di metadati e il caricamento di file continuano a interfacciarsi direttamente con Team Foundation Server.

Per ulteriori informazioni, vedere Team Foundation Server Proxy e controllo del codice sorgente.

Per ulteriori informazioni sull'installazione del proxy, vedere la guida all'installazione di Team Foundation. La versione più aggiornata della guida all'installazione di Team Foundation è disponibile in linea all'indirizzo http://go.microsoft.com/fwlink/?linkid=40042.

Vedere anche

Attività

Procedura: configurare il controllo del codice sorgente di Team Foundation per l'utilizzo del server proxy


Team Foundation Server Proxy e controllo del codice sorgente

 elenco a discesa elenco a discesa attivabile
Team Foundation Server Proxy e controllo del codice sorgente
Vedere anche
elenco a discesa

Il proxy Controllo del codice sorgente Team Foundation è stato progettato per migliorare le prestazioni di rete mediante la memorizzazione nella cache di copie dei file di controllo del codice sorgente in un percorso remoto, locale per lo sviluppatore che ha bisogno dei file, ma lontano dal percorso del controllo del codice sorgente principale. Se si memorizzano le copie nel percorso remoto, solitamente collegato al percorso del codice sorgente tramite una connessione più lenta rispetto alla LAN, il proxy consente a ciascun utente di evitare di scaricare file nella propria area di lavoro tramite la connessione più lenta e costosa.

Invece il proxy del controllo del codice sorgente in genere risponde alle richieste del client mediante la restituzione dei file dalla cache locale sulla connessione locale più veloce. Se un file non si trova nella cache locale, il proxy lo scarica in quest'ultima da Team Foundation Server, prima di restituire i file al client.

Funzionamento di base

Le operazioni del proxy possono essere viste sul lato client e sul lato server. Come nel caso di qualsiasi proxy Internet, è necessario configurare il client in modo che usi il proxy affinché quest'ultimo controlli l'amministrazione dei file. In qualità di utente del client è necessario consentire al proxy di controllare i file in corso di download. Per ulteriori informazioni, vedere Procedura: configurare il controllo del codice sorgente di Team Foundation per l'utilizzo del server proxy.

Sul lato server l'amministratore deve innanzitutto configurare il proxy. A questo scopo deve modificare il file proxy.config. Dopo avere eseguito queste due operazioni, l'amministratore deve solo occuparsi della manutenzione occasionale.

Esiste un limite massimo per la quantità di spazio di memorizzazione che il proxy può utilizzare per memorizzare i file nella cache. Quando viene raggiunto questo limite, i file vecchi nella cache vengono eliminati in modo che lo spazio così liberato possa essere utilizzato per la memorizzazione nella cache dei file appena richiesti. La pulizia rimuove i file in base all'ultimo accesso. I file che non sono stati richiesti per il periodo di tempo più lungo vengono eliminati per primi.

Diagramma di pubblicazione tramite proxy

Manutenzione

Il proxy richiede pochissima amministrazione o manutenzione. Tuttavia è necessario monitorare e gestire periodicamente le prestazioni. Si consiglia di osservare i seguenti contatori delle prestazioni.

  • Dimensione cache corrente

  • Totale riscontri nella cache (conteggio e percentuale)

  • Totale richieste di download

  • Totale file in cache

  • Totale mancati riscontri nella cache (conteggio e percentuale)

Questi contatori delle prestazioni vengono registrati durante l'installazione del proxy. Per ulteriori informazioni, vedere Procedura: esaminare le prestazioni del proxy. I contatori delle prestazioni del proxy presentano più istanze, cioè esiste un insieme di contatori per ciascun livello applicazione configurato nel file proxy.config.

Mediante la raccolta di questi dati è possibile determinare le prestazioni quando il server proxy è in esecuzione. Questo tipo di contatori delle prestazioni svolge un ruolo importante nella comprensione dello stato e nell'ottimizzazione di tutti gli aspetti di Team Foundation Server.

Protezione

Il proxy del controllo del codice sorgente utilizza uno schema di ticket preautenticato per determinare se un utente richiedente è autorizzato a visualizzare il contenuto del file richiesto. In questo schema il client dell'utente contatta il server di controllo del codice sorgente master e se l'utente è autorizzato, al client viene fornito un ticket firmato digitalmente contenente i dettagli del file richiesto. Il client quindi presenta il ticket al server proxy. L'utilizzo di firme di chiavi pubbliche/private consente al proxy di verificare se il ticket proviene dal server e se l'utente è pertanto autorizzato a visualizzare il file. Il proxy controlla quindi nella cache per determinare se può soddisfare la richiesta e, in caso negativo, richiede il file dal server e lo aggiunge alla cache.

Vedere anche

Attività

Procedura: configurare il controllo del codice sorgente di Team Foundation per l'utilizzo del server proxy


Procedura: configurare Team Foundation Server Proxy dopo l'installazione

Procedura: configurare Team Foundation Server Proxy dopo l'installazione
Vedere anche

Dopo avere installato il proxy di Team Foundation Server, è necessario configurarlo in modo che possa gestire una cache dei file di controllo del codice sorgente nel percorso del team distribuito. Dopo avere installato e configurato il proxy, è necessario configurare il client per l'uso del proxy. In questo modo la gestione dei file risulta trasparente.

Per ulteriori informazioni sulla configurazione del client, vedere Procedura: configurare il controllo del codice sorgente di Team Foundation per l'utilizzo del server proxy.

Per configurare il proxy dopo l'installazione

  1. Aprire Esplora risorse e accedere a %ProgramFiles%\Microsoft Visual Studio 2005 Team Foundation Server\Web Services\VersionControlProxy.

  2. Aprire il file proxy.config con un editor di testo.

  3. Individuare il seguente token, apportare le sostituzioni appropriate, salvare il file e quindi chiuderlo:

    Parametro Valore

    @H_TFSSERVER@

    L'URL per il livello applicazione di Team Foundation Server, ad esempio:

    http://ContosoServer01:8080.

    La porta 8080 è la porta definita per la comunicazione tra il proxy e il livello applicazione.

    Ad esempio, dopo avere effettuato le sostituzioni, l'URI di Team Foundation Server potrebbe diventare il seguente:

    Immagine CopyCode Copia codice
    <Server>
<Uri>http://Contososerver01:8080/VersionControl</Uri>
</Server>

  4. Se è necessario configurare il proxy in modo che memorizzi nella cache i file da più server Team Foundation, aggiungere la seguente sezione una volta per ogni server e includere le sostituzioni appropriate come descritto in precedenza:

    Immagine CopyCode Copia codice
    <Server>
<Uri>@H_TFSSERVER@/VersionControl</Uri>
</Server>

Per ulteriori informazioni sull'installazione del proxy, vedere la guida dell'amministratore di Team Foundation Server (http://go.microsoft.com/fwlink/?linkid=52459).

Vedere anche

Attività

Procedura: esaminare le prestazioni del proxy

Concetti

File di configurazione di Team Foundation Server Proxy


Procedura: esaminare le prestazioni del proxy

Procedura: esaminare le prestazioni del proxy

Se si utilizza il proxy di Team Foundation Server con il controllo del codice sorgente, è possibile visualizzarne le prestazioni. I contatori delle prestazioni vengono installati per impostazione predefinita ed è possibile visualizzarli nell'applicazione Prestazioni.

Utilizzo di Perfmon.exe per visualizzare le prestazioni del proxy

  1. Fare clic sul pulsante Start, selezionare Pannello di controllo, fare doppio clic su Strumenti di amministrazione, quindi fare doppio clic su Prestazioni.

    -oppure-

    Al prompt dei comandi digitare perfmon. Verrà visualizzata la console Prestazioni.

  2. Nel riquadro Monitor di sistema fare clic con il pulsante destro del mouse e scegliere Aggiungi contatori dal menu di scelta rapida.

  3. Se non si utilizza il server su cui è installato il proxy TFS, digitare il nome del server nella casella di riepilogo Seleziona contatori dal computer.

  4. Selezionare Server proxy TFS nella casella Oggetto prestazioni. Verranno elencati i contatori delle prestazioni associati a questo oggetto prestazioni.

  5. Selezionare Tutti i contatori.

  6. Fare clic su Chiudi. È ora possibile visualizzare i contatori delle prestazioni utilizzati dal proxy nella finestra Monitor di sistema.

Per utilizzare il servizio Web ProxyStatistics

  1. Per accedere alle statistiche riportate di seguito, richiamare il metodo Web QueryProxyStatistics accedendo alla pagina Web V1.0\proxystatistics.asmx che ospita il servizio Web VersionControl ProxyStatistics.

  2. Aprire una connessione del desktop remoto al server su cui è installato il proxy. È possibile richiamare il metodo QueryProxyStatistics solo dal computer locale su cui è stato installato il proxy.

  3. Dopo avere stabilito la connessione, aprire Internet Explorer e accedere al seguente indirizzo:

    http://localhost:8081/VersionControlProxy/v1.0/proxystatistics.asmx

  4. Nella pagina proxystatistics.asmx fare clic sul collegamento QueryProxyStatistics.

  5. Fare clic su Richiama per visualizzare le seguenti statistiche:

    CurrentCacheSize

    NoOfRequests

    OverallCacheHits

    NoOfFilesInCache

    OverallCacheMisses (calcolato in fase di runtime)

    CacheHitsPercentage (calcolato in fase di runtime)

    CacheMissPercentage (calcolato in fase di runtime)

    Di seguito è riportato un output di esempio:

    Immagine CopyCode Copia codice
    <?xml version="1.0" encoding="utf-8" ?>
<ArrayOfProxyStatisticsInfo xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns="http://schemas.microsoft.com/TeamFoundation/2005/06/VersionControl/Statistics/02">
<ProxyStatisticsInfo CurrentCacheSize="0" NoOfRequests="3706" OverallCacheHits="3617" NoOfFilesInCache="0" OverallCacheMisses="89" CacheHitsPercentage="97.6" CacheMissPercentage="2.4" ServerId="643c23c1-3f47-43d2-b638-3bd0e7ea8bff" ServerUrl="http://contososerver:8080/VersionControl" />
</ArrayOfProxyStatisticsInfo>

Vedere anche

Concetti

Gestione delle connessioni remote a Team Foundation Server Proxy
Team Foundation Server Proxy e controllo del codice sorgente


Gestione dei siti Team Foundation Server in Windows SharePoint Services

 elenco a discesa elenco a discesa attivabile
Gestione dei siti Team Foundation Server in Windows SharePoint Services
Vedere anche
elenco a discesa

Microsoft Windows SharePoint Services consente di aggiungere a Team Foundation funzioni di pubblicazione sul Web e collaborazione ai progetti, che possono migliorare la comunicazione e aumentare la condivisione di idee tra gli utenti ai quali sono assegnate attività nei progetti Team. Il portale del progetto Team fornisce una posizione centrale per l'archiviazione di documenti, la pubblicazione di annunci e la presentazione di informazioni sulla generazione e report sullo stato del progetto Team.

È possibile svolgere numerose attività che influenzano la connettività e le prestazioni globali di un server su cui è in esecuzione Windows SharePoint Services configurato per Team Foundation. Alcune di queste attività vengono eseguite solo in base alle necessità, ad esempio per specificare una connessione a Team Foundation Server su cui è in esecuzione Windows SharePoint Services. Altre, come la sincronizzazione degli utenti di Team Foundation con utenti in Windows SharePoint Services, devono essere eseguite regolarmente.

Inoltre è possibile personalizzare Windows SharePoint Services in diversi modi per soddisfare meglio le esigenze dell'organizzazione. Ad esempio, è possibile personalizzare i documenti, elencare le informazioni sulla generazione, creare report o standardizzare le linee guida a livello di organizzazione.

In questa sezione

Informazioni su Windows SharePoint Services

Viene descritto Windows SharePoint Services e vengono forniti collegamenti ad altre informazioni.

Connessione a un server Windows SharePoint

Vengono descritti i vari siti configurati da Team Foundation Server su Windows SharePoint Server, nonché i siti predefiniti all'interno di Windows SharePoint Services.

Ruoli di Windows SharePoint Services

Vengono descritti i vari ruoli predefiniti disponibili in Windows SharePoint Services.

Gestione dei siti Windows SharePoint Services

Vengono descritte le varie attività amministrative di Windows SharePoint Services.

Risorse esterne

MSDN Online

Vedere anche

Attività

Procedura: impostare le autorizzazioni di amministratore per Windows SharePoint Services
Procedura: impostare le autorizzazioni di coordinatore del progetto per Windows SharePoint Services
Procedura: impostare le autorizzazioni dei collaboratori per Windows SharePoint Services

Concetti

Autorizzazioni per Team Foundation Server


Informazioni su Windows SharePoint Services

 elenco a discesa elenco a discesa attivabile
Informazioni su Windows SharePoint Services
Vedere anche
elenco a discesa

L'integrazione tra Team Foundation Server e Windows SharePoint Services fornisce ad amministratori, responsabili di progetto e collaboratori importanti informazioni sugli strumenti di condivisione e organizzativi. L'integrazione include un sito Web del progetto Team che consente di condividere linee guida per il processo, documenti di progetto, modelli e report con i membri del team in base alle necessità e al ruolo di ciascun membro all'interno del progetto.

Documentazione di Windows SharePoint Services

Windows SharePoint Services è una soluzione completa per la collaborazione e la condivisione di informazioni, dotata della propria documentazione. Per ulteriori informazioni sull'amministrazione di Windows SharePoint Services, consultare la guida Windows SharePoint Services Administrator's Guide (informazioni in lingua inglese). Per ulteriori informazioni sull'integrazione di Windows SharePoint Services con Team Foundation Server, vedere i seguenti argomenti.

Vedere anche

Concetti

Ruoli di Windows SharePoint Services

Altre risorse

Gestione dei siti Windows SharePoint Services


Connessione a un server Windows SharePoint

 elenco a discesa elenco a discesa attivabile
Connessione a un server Windows SharePoint
Vedere anche
elenco a discesa

Team Foundation Server e Windows SharePoint Services sono integrati nel livello applicazione di un Team Foundation Server logico. La modalità di connessione a un server di portale dipende dal ruolo del server e se si desidera configurare impostazioni di amministrazione generali o un sito Web per un progetto specifico.

Portali Windows SharePoint Services per Team Foundation Server

L'integrazione di Team Foundation Server con Windows SharePoint Services include sia un sito amministrativo, che consente di controllare le impostazioni di base per tutti i siti Team Foundation Server sul server del progetto, sia un sito Web per ogni progetto Team all'interno di Team Foundation Server. I server di progetto contengono linee guida per il processo, documenti di progetto, modelli e funzionalità di gestione degli elementi di lavoro che possono essere condivisi dai membri del team in base alle necessità e al ruolo di ciascun membro all'interno del progetto.

Sito amministrativo per un Team Foundation Server

È possibile svolgere svariate attività che influenzano la connettività e le prestazioni globali di un server che esegue Windows SharePoint Services dal sito Web predefinito o di livello principale, detto anche sito amministrativo. Le attività di amministrazione più importanti includono l'aggiunta di utenti e gruppi e l'impostazione di autorizzazioni, nonché l'attivazione o la disattivazione di avvisi o discussioni di documenti Web. È possibile connettersi al sito amministrativo da un browser Web digitando il nome del server a livello applicazione nella barra dell'indirizzo.

Siti dei progetti

Quando si crea un progetto in Team Foundation Server, viene creato anche un sito Web del progetto. Il sito del progetto Team fornisce una posizione centrale per l'archiviazione di documenti, la pubblicazione di annunci e la presentazione di informazioni sulla generazione e report sullo stato del progetto Team. È possibile concedere agli utenti le autorizzazioni necessarie per accedere al contenuto del sito Web del progetto, aggiungere informazioni al sito Web del progetto o amministrare il sito Web del progetto, in base alle esigenze.

Sito di amministrazione centrale per Windows SharePoint Services

Per amministrare Windows SharePoint Services, è necessario aggiungere un gruppo amministrativo mediante lo strumento Amministrazione centrale SharePoint installato insieme a Windows SharePoint Services, accessibile dal livello applicazione di Team Foundation mediante il menu di avvio.

Vedere anche

Attività

Procedura: creare, modificare ed eliminare i siti di Windows SharePoint Services
Procedura: accedere all'amministrazione del sito di Windows SharePoint Services

Concetti

Informazioni su Windows SharePoint Services
Ruoli di Windows SharePoint Services

Altre risorse

Gestione dei siti Team Foundation Server in Windows SharePoint Services


Ruoli di Windows SharePoint Services

 elenco a discesa elenco a discesa attivabile
Ruoli di Windows SharePoint Services
Vedere anche
elenco a discesa

Windows SharePoint Services (WSS) include gruppi del sito che cosentono di assegnare privilegi particolari agli utenti di Visual Studio Team Foundation Server. Se si utilizzano i gruppi del sito, non è necessario controllare le autorizzazioni di file e cartelle separatamente o mantenere i gruppi locali sincronizzati con l'elenco di utenti Web. È possibile utilizzare gli strumenti di amministrazione di Windows SharePoint Services per concedere ai membri del progetto autorizzazioni distinte su ciascuno dei siti Web del progetto.

Infatti la gestione degli utenti può essere delegata dagli amministratori di Team Foundation Server ai responsabili di progetto, una volta che il responsabile di progetto è diventato amministratore di sito del progetto. Gli amministratori del sito controllano l'accesso al sito e, per impostazione predefinita, possono aggiungere, eliminare o modificare l'appartenenza degli utenti ai gruppi del sito. All'interno di un'organizzazione significa che in genere gli amministratori del sito possono concedere agli utenti dell'organizzazione selezionati l'accesso in base ai ruoli e alle esigenze nell'ambito del progetto. Ad esempio, se il sito Web è il portale di documenti e informazioni per i membri di un particolare team del progetto, l'amministratore del sito aggiunge i membri del team al gruppo dei collaboratori del sito in modo che possano inserire documenti e aggiornare elenchi.

I membri del gruppo degli amministratori di un sito Web di livello principale controllano più opzioni e funzioni del server SharePoint rispetto agli amministratori di un singolo sito del progetto. Gli amministratori di un sito Web di livello principale possono eseguire operazioni quali attivazione e disattivazione di avvisi o discussioni di documenti Web, visualizzazione dei dati relativi alle quote e all'utilizzo e modifica delle impostazioni di accesso anonimo.

Nota Nota

L'amministrazione dei siti è distinta dall'amministrazione centrale di Windows SharePoint Services, che è accessibile mediante lo strumento Amministrazione centrale SharePoint.

Di seguito sono descritti quattro gruppi di Windows SharePoint Services.

  • Amministratore

  • Designer Web

  • Collaboratore

  • Lettore

Per ulteriori informazioni sui gruppi di Windows SharePoint Services e Windows SharePoint Services, vedere la documentazione relativa a Windows SharePoint Services.

Nota Importante

Limitare l'appartenenza ai gruppi di Windows SharePoint solo agli utenti che hanno bisogno del livello specifico di accesso e delle autorizzazioni concesse in base all'appartenenza al gruppo. Aggiungere un utente o un gruppo al gruppo di Windows SharePoint Services con le autorizzazioni minime necessarie per svolgere il ruolo all'interno di un progetto Team. Ad esempio, se un utente ha solo bisogno di visualizzare il contenuto di un sito Web del progetto Team, aggiungerlo al gruppo dei lettori e non a quello dei collaboratori.

Amministratore

Per creare un amministratore del sito, aggiungere un account utente esistente al gruppo Administrators del sito di livello principale in Windows SharePoint Services.

Nota Nota

L'account utente utilizzato per installare Team Foundation Server viene automaticamente aggiunto come membro del gruppo Administrators per il sito di livello principale. Per ulteriori informazioni sull'amministrazione di Windows SharePoint Services, consultare la guida Windows SharePoint Services Administrator's Guide (informazioni in lingua inglese).

Designer Web

Un membro del gruppo Designer Web di Windows SharePoint Services può creare elenchi e librerie di documenti e personalizzare pagine sul sito Web. Per consentire a un utente di personalizzare un sito Web di un progetto Team Foundation, aggiungere un account utente esistente al gruppo Designer Web del sito del progetto in Windows SharePoint Services.

Collaboratore

Un membro del gruppo Collaboratore di Windows SharePoint Services può aggiungere contenuto a librerie di documenti ed elenchi esistenti. Per consentire a un utente di aggiungere contenuto a un sito Web di un progetto Team Foundation, aggiungere un account utente esistente al gruppo Collaboratore del sito del progetto in Windows SharePoint Services.

Lettore

Un membro del gruppo Lettore di Windows SharePoint Services ha accesso al sito Web in sola lettura. Per consentire a un utente di leggere un sito Web di un progetto Team Foundation, aggiungere un account utente esistente al gruppo Lettore del sito del progetto in Windows SharePoint Services.

Vedere anche

Attività

Procedura: accedere all'amministrazione del sito di Windows SharePoint Services
Procedura: impostare le autorizzazioni di amministratore per Windows SharePoint Services
Procedura: impostare le autorizzazioni di coordinatore del progetto per Windows SharePoint Services
Procedura: impostare le autorizzazioni dei collaboratori per Windows SharePoint Services

Altre risorse

Gestione di utenti
Gestione di gruppi


Gestione dei siti Windows SharePoint Services

 elenco a discesa elenco a discesa attivabile
Gestione dei siti Windows SharePoint Services
Vedere anche
elenco a discesa

Quando si installa Team Foundation Server viene automaticamente creato un sito Web di Windows SharePoint Services predefinito. Inoltre, ogni volta che si crea un nuovo progetto in Team Foundation Server, viene automaticamente creato un sito Web per il progetto. È tuttavia possibile creare ulteriori siti Web da utilizzare con Team Foundation Server e modificare o eliminare questi siti Web di Windows SharePoint Services.

In questa sezione

Procedura: accedere all'amministrazione del sito di Windows SharePoint Services

Viene descritto come accedere alle funzioni amministrative di Windows SharePoint Server.

Procedura: creare, modificare ed eliminare i siti di Windows SharePoint Services

Viene descritto come creare, modificare ed eliminare siti su Windows SharePoint Server.

Vedere anche

Altre risorse

Gestione dei siti Team Foundation Server in Windows SharePoint Services


Procedura: accedere all'amministrazione del sito di Windows SharePoint Services

Procedura: accedere all'amministrazione del sito di Windows SharePoint Services
Vedere anche

Quando si installa Visual Studio Team Foundation Server viene automaticamente effettuato il provisioning di un sito Web di Windows SharePoint Services predefinito di livello principale da cui è possibile controllare tutte le opzioni e le funzionalità del server Windows SharePoint. Gli amministratori di un sito Web di livello principale possono eseguire operazioni quali attivazione e disattivazione di avvisi o discussioni di documenti Web, visualizzazione dei dati relativi alle quote e all'utilizzo e modifica delle impostazioni di accesso anonimo, nonché controllare l'accesso al sito e aggiungere, eliminare o modificare le appartenenze ai gruppi del sito.

Nota Nota

L'amministrazione del sito è distinta dall'amministrazione centrale di Windows SharePoint Services, a cui è possibile accedere mediante lo strumento Amministrazione centrale SharePoint.

Per accedere all'amministrazione del sito di Windows SharePoint Services

  1. Aprire Internet Explorer.

  2. Nella barra degli indirizzi digitare il nome del server a livello applicazione per accedere al sito di livello principale di Windows SharePoint Services. Per visualizzare il nome del server a livello applicazione, aprire Visual Studio e in Team Explorer fare clic con il pulsante destro del mouse sul nome del server e scegliere Proprietà.

Per aggiungere un membro al gruppo amministrativo di SharePoint

  1. Nel livello applicazione di Team Foundation, fare clic sul pulante Start, scegliere Strumenti di amministrazione, quindi selezionare Amministrazione centrale SharePoint.

  2. In Amministrazione centrale fare clic su Imposta gruppo amministrativo di SharePoint.

  3. In Imposta gruppo amministrativo di SharePoint digitare il nome dell'account e il dominio, se applicabile, per il gruppo.

    Nota Nota

    Al gruppo amministrativo di SharePoint è possibile aggiungere solo un utente o gruppo di dominio, ma non un gruppo locale. Tuttavia i membri del gruppo Administrators locale sul server possono anche eseguire attività amministrative per prodotti e tecnologie Windows SharePoint Services.

  4. Scegliere OK.

Vedere anche

Attività

Procedura: impostare le autorizzazioni di amministratore per Windows SharePoint Services
Procedura: creare, modificare ed eliminare i siti di Windows SharePoint Services

Concetti

Informazioni su Windows SharePoint Services
Connessione a un server Windows SharePoint
Ruoli di Windows SharePoint Services


Procedura: creare, modificare ed eliminare i siti di Windows SharePoint Services

Procedura: creare, modificare ed eliminare i siti di Windows SharePoint Services
Vedere anche

Quando si installa Visual Studio Team Foundation Server viene automaticamente creato un sito Web di Windows SharePoint Services predefinito. Inoltre, ogni volta che si crea un nuovo progetto in Team Foundation Server, viene automaticamente creato un portale per il progetto. È tuttavia possibile creare ulteriori siti Web da utilizzare con Team Foundation Server e modificare o eliminare questi siti Web di Windows SharePoint Services. Per ulteriori informazioni sui siti e sull'amministrazione di Windows SharePoint Services, vedere la guida Windows SharePoint Services Administrator's Guide (informazioni in lingua inglese).

Nota di avviso Attenzione

Non eliminare un sito Web di progetto o di amministrazione predefinito a meno che non si ritiri il progetto e/o il server Team Foundation Server.

Per creare un nuovo sito sul server Windows SharePoint Services

  1. Aprire Internet Explorer.

  2. Nella barra degli indirizzi digitare il nome del server a livello applicazione per accedere al sito di livello principale di Windows SharePoint Services. Per visualizzare il nome del server a livello applicazione, aprire Visual Studio e in Team Explorer fare clic con il pulsante destro del mouse sul nome del server e scegliere Proprietà.

  3. Fare clic su Crea.

  4. In Pagine Web all'interno di Pagina di creazione fare clic su Siti e aree di lavoro.

  5. In Titolo e descrizione all'interno di Nuovo sito di SharePoint immettere un titolo e una descrizione per il nuovo sito.

  6. In Indirizzo sito Web digitare il nome dell'URL. Il nome dell'URL verrà automaticamente preceduto dall'indirizzo del server a livello applicazione.

  7. In Autorizzazioni selezionare le autorizzazioni utente appropriate per il nuovo sito.

  8. Fare clic su Crea.

  9. In Selezione modello selezionare il modello adatto al processo che si desidera seguire. Ad esempio, se si desidera creare un nuovo sito Web per un progetto che utilizza MSF Agile, selezionare TFS per MSF Agile.

  10. Scegliere OK.

Per eliminare un sito sul server Windows SharePoint Services

  1. Aprire Internet Explorer.

  2. Nella barra dell'indirizzo digitare il nome del sito Web che si desidera eliminare. Il nome verrà preceduto dal nome del server a livello applicazione.

  3. Fare clic su Impostazioni sito.

  4. In Amministrazione all'interno di Impostazioni sito fare clic su Vai all'amministrazione del sito.

  5. In Gestione e statistiche all'interno di Amministrazione sito fare clic su Elimina il sito.

  6. In Elimina sito Web fare clic su Elimina.

Per modificare un sito sul server Windows SharePoint Services

  1. Aprire Internet Explorer.

  2. Nella barra dell'indirizzo digitare il nome del sito Web che si desidera modificare. Il nome verrà preceduto dal nome del server a livello applicazione.

  3. Fare clic su Impostazioni sito.

  4. Modificare le impostazioni del sito per cambiare l'aspetto del sito, aggiungere o rimuovere dati e così via. Per ulteriori informazioni sulla modifica di un sito di Windows SharePoint Services, vedere la guida Windows SharePoint Services Administrator's Guide (informazioni in lingua inglese).

Vedere anche

Attività

Procedura: accedere all'amministrazione del sito di Windows SharePoint Services

Concetti

Informazioni su Windows SharePoint Services
Ruoli di Windows SharePoint Services


Gestione delle impostazioni di configurazione di Team Foundation Server

 elenco a discesa elenco a discesa attivabile
Gestione delle impostazioni di configurazione di Team Foundation Server
elenco a discesa

È possibile utilizzare i servizi Web incorporati e i file web.config del componente Team Foundation Server per configurare vari aspetti dell'ambiente Team Foundation Server. Negli argomenti elencati di seguito vengono fornite informazioni sull'utilizzo dei servizi Web e dei file web.config per configurare l'ambiente Team Foundation Server.

In questa sezione

Attivazione dell'analisi per i componenti di Team Foundation Server

Vengono forniti collegamenti ad argomenti che illustrano l'attivazione e la configurazione dell'analisi per Team Foundation Server.

Impostazioni globali del file web.config nei componenti di Team Foundation Server

Vengono descritte le impostazioni contenute nel file web.config globale.

Impostazioni del file web.config per la generazione nei componenti di Team Foundation Server

Vengono descritte le impostazioni contenute nel file web.config per la generazione.

Impostazioni del file Web.Config di Services nei componenti di Team Foundation Server

Vengono descritte le impostazioni contenute nel file web.config per i servizi.

Impostazioni del file web.config per il controllo della versione nei componenti di Team Foundation Server

Vengono descritte le impostazioni contenute nel file web.config per il controllo della versione.

Impostazioni del file Web.Config di Gestione elementi di lavoro nei componenti di Team Foundation Server

Vengono descritte le impostazioni contenute nel file web.config per gli elementi di lavoro.

Procedura: modificare le impostazioni di Web.Config per i componenti di Team Foundation Server

Viene illustrata una procedura generica per la modifica delle impostazioni nel file web.config in Team Foundation Server.

Procedura: impostare la dimensione massima degli allegati per gli elementi di lavoro

Viene descritto come impostare la dimensione massima degli allegati per gli elementi di lavoro.

Procedura: impostare l'intervallo di elaborazione per il data warehouse

Viene descritto come impostare l'intervallo di elaborazione per il data warehouse.


Attivazione dell'analisi per i componenti di Team Foundation Server

 elenco a discesa elenco a discesa attivabile
Attivazione dell'analisi per i componenti di Team Foundation Server
Vedere anche
elenco a discesa

L'analisi consente di registrare informazioni in tempo reale sulle prestazioni e sull'esecuzione di applicazioni e può essere utilizzata per diagnosticare problemi sul server. Sebbene l'analisi risulti utile per diagnosticare problemi, deve essere attivata solo per risolvere eventuali problemi in quanto può influire negativamente sulle prestazioni del server. In questa sezione vengono forniti dei collegamenti ad argomenti che descrivono come attivare e configurare l'analisi per Team Foundation Server.

In questa sezione

Impostazioni di analisi per Team Foundation Server

Vengono descritte le impostazioni disponibili per l'analisi in Team Foundation Server.

Procedura: utilizzare i servizi Web per attivare e configurare l'analisi dei componenti di Team Foundation Server

Viene illustrato come utilizzare i servizi Web incorporati per attivare e configurare l'analisi in Team Foundation Server.

Procedura: modificare la directory di output di analisi per i componenti di Team Foundation Server

Viene descritto come modificare la directory di output per i log di analisi.

Vedere anche

Altre risorse

Analisi e strumentazione di applicazioni


Impostazioni di analisi per Team Foundation Server

 elenco a discesa elenco a discesa attivabile
Impostazioni di analisi per Team Foundation Server
Vedere anche
elenco a discesa

È possibile utilizzare le opzioni di analisi integrate per raccogliere, in fase di esecuzione, informazioni sulle prestazioni e sull'esecuzione dell'applicazione. In questo argomento vengono descritte le impostazioni di analisi specifiche di Team Foundation Server. Per informazioni generali sull'analisi, vedere Analisi e strumentazione di applicazioni.

Opzioni di analisi di Team Foundation

In Team Foundation Server sono disponibili le seguenti opzioni di analisi. Per informazioni sull'attivazione di queste opzioni, vedere Procedura: utilizzare i servizi Web per attivare e configurare l'analisi dei componenti di Team Foundation Server. Per attivare le singole opzioni, è necessario modificare il file web.config di Team Foundation Server come descritto in Procedura: modificare le impostazioni di Web.Config per i componenti di Team Foundation Server.

Impostazione | Descrizione
API | Analizza l'utilizzo del metodo Web, le chiamate tra i servizi Web (dalla prospettiva del chiamante) e i metodi pubblici.
Autenticazione | Analizza l'interazione di autenticazione.
Autorizzazione | Analizza i componenti relativi all'autorizzazione, ad esempio il gestore di protezione del controllo della versione.
Database | Analizza l'interazione del database del componente.
EqtTraceLevel | Analizza i componenti degli strumenti Team Foundation Build, Team Edition for Developers e Team Edition for Testers.
traceLevel | Analizza i componenti di gestione degli elementi di lavoro.
eSwitch | Analizza i servizi di integrazione e i componenti del data warehouse.
Generale | Analizza i casi di carattere diverso che non rientrano nelle suddette categorie.

Impostazioni delle opzioni di analisi

Per ciascuna opzione è possibile impostare una tra cinque impostazioni per specificare la quantità di informazioni registrate. Per ulteriori informazioni, vedere Opzioni di analisi.

Opzione di analisi | Informazioni di analisi registrate
0 | Nessuna
1 | Errori
2 | Avvisi
3 | Informazioni
4 | Dettagli

Vedere anche

Attività

Procedura: modificare le impostazioni di Web.Config per i componenti di Team Foundation Server
Procedura: utilizzare i servizi Web per attivare e configurare l'analisi dei componenti di Team Foundation Server
Procedura: modificare la directory di output di analisi per i componenti di Team Foundation Server

Concetti

Opzioni di analisi

Altre risorse

Analisi e strumentazione di applicazioni
Attivazione dell'analisi per i componenti di Team Foundation Server


Procedura: utilizzare i servizi Web per attivare e configurare l'analisi dei componenti di Team Foundation Server

Procedura: utilizzare i servizi Web per attivare e configurare l'analisi dei componenti di Team Foundation Server
Vedere anche

È possibile utilizzare i servizi Web incorporati per attivare l'analisi delle applicazioni di Team Foundation Server, al fine di raccogliere informazioni sullo stato relative a un processo senza ricorrere al riciclaggio del pool di applicazioni. È possibile avviare la raccolta di informazioni dopo il rilevamento di un problema. In questo argomento viene descritto come attivare l'analisi per singole applicazioni di Team Foundation Server. Per informazioni generali sull'analisi, vedere Analisi e strumentazione di applicazioni.

È possibile utilizzare il servizio Web solo per attivare o disattivare tutte le opzioni di analisi incorporate. Per attivare o disattivare singole opzioni di analisi, è necessario modificare manualmente il file web.config di Team Foundation Server come descritto in Procedura: modificare le impostazioni di Web.Config per i componenti di Team Foundation Server.

Nota Nota

Quando l'analisi viene attivata utilizzando questo metodo, le relative impostazioni non vengono mantenute dopo il ciclo del pool di applicazioni. Affinché le modifiche allo stato di analisi siano permanenti, è necessario modificare il file web.config come descritto in Procedura: modificare le impostazioni di Web.Config per i componenti di Team Foundation Server.

Per attivare l'analisi per le applicazioni di Team Foundation Server

  • In Internet Explorer individuare il seguente URL:

    Immagine CopyCode Copia codice
    http://<tfsserver>:<port>/<WebService>/tftrace.aspx?[traceWriter=<true|false>][&][All=<traceLevel>]

    In questa sintassi <tfsserver> rappresenta il nome del server Team Foundation Server, <Port> rappresenta la porta, in genere 8080, e <WebService> rappresenta il nome dell'applicazione di Team Foundation Server per la quale si desidera attivare l'analisi. Gli argomenti traceWriter e All sono facoltativi. Di seguito sono riportati esempi e valori validi per gli argomenti <WebService> e <traceLevel>.

    I valori validi per <WebService> includono Build, services, VersionControl, Warehouse e WorkItemTracking. I valori validi l'argomento All includono None, Errors, Warnings, Information e Verbose.

    In questo esempio vengono impostate tutte le opzioni di analisi di VersionControl su Verbose e non viene impostato alcun valore per traceWriter:

    Immagine CopyCode Copia codice
    http://<tfsserver>:8080/VersionControl/tftrace.aspx?All=Verbose

    In questo esempio vengono impostate tutte le opzioni di analisi di Warehouse su Error e per traceWriter viene impostato il valore true:

    Immagine CopyCode Copia codice
    http://<tfsserver>:8080/Warehouse/tftrace.aspx?traceWriter=true&All=Error

Vedere anche

Attività

Procedura: modificare la directory di output di analisi per i componenti di Team Foundation Server
Procedura: modificare le impostazioni di Web.Config per i componenti di Team Foundation Server

Altre risorse

Attivazione dell'analisi per i componenti di Team Foundation Server


Procedura: modificare la directory di output di analisi per i componenti di Team Foundation Server

Procedura: modificare la directory di output di analisi per i componenti di Team Foundation Server
Vedere anche

È possibile cambiare la directory di output per i file di analisi dei componenti di Team Foundation Server modificando il file web.config per il componente.

Per modificare la directory di output di analisi per un componente di Team Foundation Server

  1. Fare clic sul pulsante Start di Windows, selezionare Pannello di controllo, Strumenti di amministrazione, quindi Gestione Internet Information Services (IIS).

    Verrà visualizzata la finestra Gestione Internet Information Services.

  2. Nel riquadro sinistro espandere il nome del server, Siti Web, quindi Team Foundation Server.

  3. Selezionare la voce di Team Foundation Server che si desidera modificare. Ad esempio, se si desidera configurare le impostazioni del data warehouse, selezionare Warehouse. Per le impostazioni a livello di server selezionare Team Foundation Server.

  4. Nel riquadro destro fare doppio clic su web.config.

    Verrà visualizzata la finestra delle proprietà di web.config.

  5. Selezionare la scheda ASP.NET, quindi fare clic su Modifica configurazione.

    Verrà visualizzata la finestra Impostazioni di configurazione ASP.NET.

  6. Nella finestra di dialogo Impostazioni applicazione selezionare la riga traceDirectoryName che si desidera modificare, quindi fare clic su Modifica.

    Verrà visualizzata la finestra di dialogo Modifica/Aggiungi impostazioni applicazione.

  7. Nella casella Valore digitare la nuova directory per l'output di analisi, quindi scegliere OK.

Vedere anche

Attività

Procedura: utilizzare i servizi Web per attivare e configurare l'analisi dei componenti di Team Foundation Server

Concetti

Impostazioni di analisi per Team Foundation Server

Altre risorse

Attivazione dell'analisi per i componenti di Team Foundation Server


Impostazioni globali del file web.config nei componenti di Team Foundation Server

 elenco a discesa elenco a discesa attivabile
Impostazioni globali del file web.config nei componenti di Team Foundation Server
Vedere anche
elenco a discesa

In questo argomento vengono descritte le impostazioni globali che è possibile configurare nel file web.config di Team Foundation Server. Per una procedura generale che descrive come accedere e modificare queste impostazioni, vedere Procedura: modificare le impostazioni di Web.Config per i componenti di Team Foundation Server.

Impostazioni del file web.config globali

Impostazione Descrizione

sqlTimeout

Valore numerico che indica l'intervallo di timeout in secondi per tutti i comandi SQL.

CommandLogging

Stringa che specifica il comportamento di registrazione dei metodi dei servizi Web. È possibile impostare i seguenti valori:

None: i metodi Web non vengono mai registrati.

OnError: vengono registrati solo i metodi Web che presentano degli errori.

ReadWrite: vengono registrati solo i metodi Web che apportano modifiche ai database.

Normal: vengono registrati sia i metodi Web che apportano modifiche ai database, come per ReadWrite, che quelli che non alterano i database.

LightWeight: vengono registrati sia i metodi Web che apportano modifiche ai database, come per ReadWrite, che quelli con un minimo accesso ai database.

All: vengono registrati tutti i metodi Web e, quando disponibili, vengono anche incluse informazioni sulle richieste dei metodi dei servizi Web.

Il valore predefinito è None.

TfsNameUrl

URL per il server a livello applicazione utilizzato da tutti i servizi Web Team Foundation Server per individuare gli altri servizi Web in esecuzione sul computer mediante il servizio registration.asmx.

Nota di avviso Attenzione

Questa impostazione non deve essere modificata.

TFS Name

Stringa che rappresenta il nome del computer a livello applicazione.

Questa impostazione non deve essere modificata.

TfsUrlPublic

URL Internet utilizzato per formare l'indirizzo URL completo per il recupero degli elementi, ad esempio elementi di lavoro, e visualizzato nei messaggi di avviso di posta elettronica di notifica del progetto.

traceWriter

Valore booleano che determina se l'analisi è attivata. Impostare il valore su true per acquisire le informazioni di analisi in un file. Le opzioni di analisi nella sezione system.diagnostics del file web.config determinano il tipo e la quantità di informazioni raccolte. Per ulteriori informazioni, vedere Attivazione dell'analisi per i componenti di Team Foundation Server.

Nota Nota

L'attivazione dell'analisi causa un aumento delle richieste in fase di esecuzione e dell'utilizzo del processore e dell'I/O a livello applicazione.

traceDirectoryName

Valore di tipo string che rappresenta il percorso della cartella contenente i file di analisi.

Vedere anche

Attività

Procedura: modificare le impostazioni di Web.Config per i componenti di Team Foundation Server

Altre risorse

Attivazione dell'analisi per i componenti di Team Foundation Server
Gestione delle impostazioni di configurazione di Team Foundation Server


Impostazioni del file web.config per la generazione nei componenti di Team Foundation Server

 elenco a discesa elenco a discesa attivabile
Impostazioni del file web.config per la generazione nei componenti di Team Foundation Server
Vedere anche
elenco a discesa

In questo argomento vengono descritte le impostazioni che è possibile configurare nel file web.config per la generazione. Per una procedura generale che descrive come accedere e modificare queste impostazioni, vedere Procedura: modificare le impostazioni di Web.Config per i componenti di Team Foundation Server.

Impostazioni del file web.config per la gestione della generazione

Impostazione | Descrizione
port | Valore numerico che rappresenta il numero della porta utilizzata dal computer di generazione. Deve essere sincronizzato con la porta di Teambuildservice.exe.config sul computer di generazione.

Vedere anche

Attività

Procedura: modificare le impostazioni di Web.Config per i componenti di Team Foundation Server

Concetti

Impostazioni globali del file web.config nei componenti di Team Foundation Server

Altre risorse

Gestione delle impostazioni di configurazione di Team Foundation Server


Impostazioni del file Web.Config di Services nei componenti di Team Foundation Server

 elenco a discesa elenco a discesa attivabile
Impostazioni del file Web.Config di Services nei componenti di Team Foundation Server
Vedere anche
elenco a discesa

In questo argomento vengono descritte le impostazioni che è possibile configurare nel file web.config per i servizi. Per una procedura generale che descrive come accedere e modificare queste impostazioni, vedere Procedura: modificare le impostazioni di Web.Config per i componenti di Team Foundation Server.

Impostazioni del file web.config per i servizi

Impostazione | Descrizione
ConnectionString | Questa impostazione è una valore di tipo string che rappresenta la stringa utilizzata dal livello applicazione per la connessione al livello dati.
eventingEnabled | Questa impostazione è un valore booleano che attiva o disattiva il sistema di gestione degli eventi di Team Foundation Server (avvisi).
emailNotificationFromAddress | Questa impostazione di tipo string rappresenta l'indirizzo del mittente per i messaggi di posta elettronica di notifica di Team Foundation Server relativi ad archiviazioni, assegnazioni di elementi di lavoro assegnati e così via. Questo indirizzo viene inoltre convalidato e, a seconda della configurazione del server, potrebbe dovere corrispondere a un account di posta elettronica valido sul server di posta. Se non esiste o non è valido, viene utilizzato l'indirizzo TeamSystem@microsoft.com.
smtpServer | Questa impostazione di tipo string rappresenta il nome del server di posta.

Vedere anche

Attività

Procedura: modificare le impostazioni di Web.Config per i componenti di Team Foundation Server

Concetti

Impostazioni globali del file web.config nei componenti di Team Foundation Server

Altre risorse

Gestione delle impostazioni di configurazione di Team Foundation Server


Impostazioni del file web.config per il controllo della versione nei componenti di Team Foundation Server

 elenco a discesa elenco a discesa attivabile
Impostazioni del file web.config per il controllo della versione nei componenti di Team Foundation Server
Vedere anche
elenco a discesa

In questo argomento vengono descritte le impostazioni che è possibile configurare nel file web.config per il controllo della versione. Per una procedura generale che descrive come accedere e modificare queste impostazioni, vedere Procedura: modificare le impostazioni di Web.Config per i componenti di Team Foundation Server.

Impostazioni del file web.config per il controllo della versione

Impostazione | Descrizione
fileCacheRoot | Stringa che contiene il percorso della directory principale utilizzata come cache per i file del server di controllo della versione.
CacheLimitPercent | Valore numerico che indica la percentuale di spazio su disco utilizzabile per la cache.
CacheLimit | Valore numerico che indica la dimensione massima della cache in megabyte.
CacheDeletionPercent | Valore numerico che indica la percentuale di cache che viene svuotata quando viene raggiunta la dimensione massima.
LastWriteTimeUpdateWindow | Intervallo di tempo in ore per l'aggiornamento dell'attributo LastWriteTime di un file nella cache. Questa impostazione consente di impedire che l'attributo LastWriteTime venga aggiornato ad ogni richiesta di accesso alla cache in quanto l'aggiornamento viene eseguito solo dopo che è trascorso il tempo specificato in LastWriteTimeUpdateWindow. Il valore predefinito per questa impostazione è 8 ore, ma può essere impostato qualsiasi valore compreso tra 1 e 24 ore.
StatisticsPersistTime | Frequenza in ore per la scrittura su disco delle statistiche. Il valore predefinito per questa impostazione è 1 ora, ma può essere impostato qualsiasi valore compreso tra 1 e 24 ore.

Vedere anche

Attività

Procedura: modificare le impostazioni di Web.Config per i componenti di Team Foundation Server

Concetti

Impostazioni globali del file web.config nei componenti di Team Foundation Server

Altre risorse

Gestione delle impostazioni di configurazione di Team Foundation Server


Impostazioni del file Web.Config di Gestione elementi di lavoro nei componenti di Team Foundation Server

 elenco a discesa elenco a discesa attivabile
Impostazioni del file Web.Config di Gestione elementi di lavoro nei componenti di Team Foundation Server
Vedere anche
elenco a discesa

In questo argomento vengono descritte le impostazioni che è possibile configurare nel file web.config per la gestione degli elementi di lavoro. Per una procedura generale che descrive come accedere e modificare queste impostazioni, vedere Procedura: modificare le impostazioni di Web.Config per i componenti di Team Foundation Server.

Impostazioni del file web.config per la gestione degli elementi di lavoro

Impostazione | Descrizione
WorkItemChangedEvent | Questa impostazione rappresenta un valore booleano. Quando il valore è true, viene generato l'evento di elemento di lavoro modificato, utilizzato dalla funzione di notifica tramite posta elettronica. Si tratta di un sottoinsieme della gestione degli eventi di Team Foundation Server, controllata dall'impostazione globale eventingEnabled. Se eventingEnabled è impostato su false, gli eventi non vengono generati indipendentemente dal valore dell'impostazione. Per ulteriori informazioni, vedere Impostazioni globali del file web.config nei componenti di Team Foundation Server.

Vedere anche

Attività

Procedura: modificare le impostazioni di Web.Config per i componenti di Team Foundation Server

Concetti

Impostazioni globali del file web.config nei componenti di Team Foundation Server

Altre risorse

Gestione delle impostazioni di configurazione di Team Foundation Server


Procedura: modificare le impostazioni di Web.Config per i componenti di Team Foundation Server

Procedura: modificare le impostazioni di Web.Config per i componenti di Team Foundation Server
Vedere anche

Le informazioni sulla configurazione per Team Foundation Server sono contenute in vari file web.config. In questo argomento viene descritta una procedura generale per la modifica delle impostazioni di configurazione.

Per modificare un'impostazione di web.config

  1. Fare clic sul pulsante Start di Windows, selezionare Pannello di controllo, Strumenti di amministrazione, quindi Gestione Internet Information Services (IIS).

    Verrà visualizzata la finestra Gestione Internet Information Services.

  2. Nel riquadro sinistro espandere il nome del server, Siti Web, quindi Team Foundation Server.

  3. Selezionare la voce di Team Foundation Server che si desidera modificare. Ad esempio, se si desidera configurare le impostazioni del data warehouse, selezionare Warehouse. Per le impostazioni globali selezionare Team Foundation Server.

  4. Fare clic con il pulsante destro del mouse sulla voce selezionata e scegliere Proprietà.

    Verrà visualizzata la finestra Proprietà.

  5. Selezionare la scheda ASP.NET, quindi fare clic su Modifica configurazione.

    Verrà visualizzata la finestra Impostazioni di configurazione ASP.NET.

  6. Nella finestra di dialogo Impostazioni applicazione selezionare la chiave che si desidera modificare, quindi fare clic su Modifica.

    Verrà visualizzata la finestra di dialogo Modifica/Aggiungi impostazioni applicazione.

  7. Nella casella Valore digitare il nuovo valore, quindi scegliere OK.

    È necessario chiudere e aprire l'applicazione affinché le modifiche apportate al file web.config diventino effettive.

Vedere anche

Concetti

Impostazioni globali del file web.config nei componenti di Team Foundation Server
Impostazioni del file web.config per la generazione nei componenti di Team Foundation Server
Impostazioni del file Web.Config di Services nei componenti di Team Foundation Server
Impostazioni del file Web.Config di Gestione elementi di lavoro nei componenti di Team Foundation Server

Altre risorse

Gestione delle impostazioni di configurazione di Team Foundation Server


Procedura: impostare la dimensione massima degli allegati per gli elementi di lavoro

Procedura: impostare la dimensione massima degli allegati per gli elementi di lavoro
Vedere anche

È possibile utilizzare i servizi Web incorporati per impostare la dimensione massima degli allegati per gli elementi di lavoro.

Per impostare la dimensione massima degli allegati per gli elementi di lavoro

  1. In Internet Explorer individuare il seguente URL:

    Immagine CopyCode Copia codice
    http://<tfsserver>:8080/WorkItemTracking/v1.0/ConfigurationSettingsService.asmx?op=SetMaxAttachmentSize

    dove <tfsserver> rappresenta il nome del server Team Foundation Server.

  2. Nella casella MaxSize immettere la dimensione massima degli allegati in byte, quindi fare clic su Richiama. La dimensione massima degli allegati consentita è 2 GB.

Vedere anche

Concetti

Impostazione di un limite per le dimensioni degli allegati

Altre risorse

Gestione delle impostazioni di configurazione di Team Foundation Server


Procedura: impostare l'intervallo di elaborazione per il data warehouse

Procedura: impostare l'intervallo di elaborazione per il data warehouse
Vedere anche

È possibile utilizzare i servizi Web incorporati nel data warehouse per modificare l'intervallo di elaborazione del data warehouse.

Per impostare l'intervallo di elaborazione per il data warehouse

  1. In Internet Explorer passare al seguente URL:

    Immagine CopyCode Copia codice
    http://<tfsserver>:8080/Warehouse/v1.0/warehousecontroller.asmx?op=ChangeSetting

    dove <tfsserver> rappresenta il nome del server Team Foundation Server. Viene visualizzata una pagina contenente due caselle con etichette settingID e newValue.

  2. Nella casella settingID digitare RunIntervalSeconds.

  3. Nella casella newValue digitare il nuovo intervallo di tempo in secondi.

  4. Fare clic su Richiama per modificare l'impostazione.

Vedere anche

Concetti

Pianificazione della sincronizzazione con il data warehouse

Altre risorse

Gestione delle impostazioni di configurazione di Team Foundation Server


File di configurazione di Team Foundation Server Proxy

 elenco a discesa elenco a discesa attivabile
File di configurazione di Team Foundation Server Proxy
Vedere anche
elenco a discesa

In Team Foundation Server Proxy è disponibile un file di configurazione XML distinto contenente le informazioni richieste per la configurazione del proxy. In questo argomento vengono descritti i nodi presenti in questo file e il loro effetto sulla configurazione di Team Foundation Server Proxy.

Nodi di configurazione di Team Foundation Server Proxy

Di seguito vengono descritti i nodi XML presenti nel file di configurazione di Team Foundation Server Proxy, disponibile in %ProgramFiles%\Microsoft Visual Studio 2005 Team Foundation Server\Web Services\VersionControlProxy\proxy.config.

Nodo Descrizione

<ProxyConfiguration>

Elemento principale del file di configurazione del proxy. Ad esempio:

<ProxyConfiguration

xmlns:xsd="http://www.w3.org/2001/XMLSchema"

xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

<!-- Additional nodes omitted for clarity -->

</ProxyConfiguration>

<Servers>

Questo nodo rappresenta una raccolta di nodi <Server> che corrispondono al livello applicazione da cui il proxy fornisce i file. Ciascun nodo <Server> contiene un nodo <Uri> che specifica l'URI della directory virtuale VersionControl del livello applicazione. Ad esempio:

Immagine CopyCode Copia codice
<Servers>
   <Server>
      <Uri>http://tfserver:8080/VersionControl</Uri>
   </Server>
</Servers>

<CacheRoot>

Questo nodo contiene la directory principale della cache dei file. Questa directory contiene una cartella per ciascun livello applicazione per cui il proxy è configurato. Ad esempio:

Immagine CopyCode Copia codice
<CacheRoot>C:\Program Files\Microsoft Visual Studio 2005 Team Foundation Server\Web Services\VersionControlProxy\Data</CacheRoot>

<CacheLimitPolicy>

Questo nodo specifica a che punto il proxy esegue la routine di pulizia per rimuovere i file non aggiornati. Questo nodo può essere configurato in due modi: è possibile utilizzare un nodo <PercentageBasedPolicy> che esegue la routine di pulizia quando viene riempita una certa percentuale di spazio disponibile sul disco oppure è possibile utilizzare un nodo <FixedSizeBasedPolicy> per specificare una dimensione fissa per la cache (in megabyte). Quando viene raggiunta la dimensione specificata, viene eseguita la routine di pulizia. Ad esempio:

<CacheLimitPolicy>

<!-- Cache limit expressed as percentage of disk space -->

<PercentageBasedPolicy>75</PercentageBasedPolicy> </CacheLimitPolicy>

<CacheLimitPolicy>

<!-- Cache limit expressed as MB -->

<FixedSizeBasedPolicy>500</FixedSizeBasedPolicy>

</CacheLimitPolicy>

<StatisticsPersistTime>

Questo nodo indica la frequenza (in ore) per la scrittura su disco delle statistiche. Ad esempio:

<StatisticsPersistTime>1</StatisticsPersistTime>

<ReaderChunkSize>

Questo nodo imposta la dimensione del blocco di lettura. Ad esempio:

<ReaderChunkSize>1048576</ReaderChunkSize>

<WriterChunkSize>

Questo nodo imposta la dimensione del blocco di scrittura. Ad esempio:

<WriterChunkSize>1048576</WriterChunkSize>

Modifica delle impostazioni di configurazione del proxy

Per modificare la configurazione del proxy, è necessario aprire il file proxy.config in un editor di testo o XML e modificare i valori specificati manualmente. Una volta salvato il file, è necessario riciclare il pool di applicazioni affinché le modifiche diventino effettive.

Vedere anche

Concetti

Team Foundation Server Proxy e controllo del codice sorgente

Altre risorse

Gestione delle impostazioni di configurazione di Team Foundation Server


Monitoraggio di Team Foundation Server

 elenco a discesa elenco a discesa attivabile
Monitoraggio di Team Foundation Server
Vedere anche
elenco a discesa

Per supportare gli utenti, è importante gestire e monitorare i server Team Foundation. In questa sezione vengono illustrate le strategie comuni per l'amministrazione di Team Foundation Server, compresi il tipo di attività da monitorare, i fattori da considerare per determinare se rimuovere i dati da Team Foundation Server e quando e come prendere in considerazione l'aggiornamento del sistema.

In questa sezione

Monitoraggio dei log eventi

Vengono descritti i messaggi e i codici del log eventi generati da Team Foundation Server.

Monitoraggio delle prestazioni

Vengono descritti in dettaglio i contatori delle prestazioni incorporati per Team Foundation Server.

Procedura: visualizzare i contatori delle prestazioni di Team Foundation Server

Viene descritto come accedere ai contatori delle prestazioni e visualizzare i relativi dati disponibili.

Sezioni correlate

Gestione di utenti e gruppi

Autorizzazioni del controllo del codice sorgente di Team Foundation

Vedere anche

Concetti

Pianificazione del ripristino di emergenza


Monitoraggio dei log eventi

 elenco a discesa elenco a discesa attivabile
Monitoraggio dei log eventi
Vedere anche
elenco a discesa

È possibile monitorare gli eventi e gli errori di Team Foundation Server tramite i log eventi. Nel log eventi dell'applicazione di Team Foundation Server vengono registrati diversi eventi informativi, di avviso e di errore che possono essere visualizzati nel Visualizzatore eventi.

Eventi di Team Foundation Server

Nella seguente tabella vengono descritti gli eventi di Team Foundation Server.

Tipo evento | Nome codice evento | ID evento
Errore | AuthenticationException | 3001
Errore | AuthorizationException | 3002
Errore | ResourceAccessException | 3003
Errore | InvalidIdentityException | 3004
Errore | IdentityNotFoundException | 3005
Errore | DatabaseFullException | 3006
Errore | DatabaseConfigurationException | 3007
Errore | DatabaseConnectionException | 3008
Errore | UnexpectedDatabaseResultException | 3009
Errore | SubscriberNotImplemented | 3011
Errore | PluginLoadException | 3012
Errore | UnableToContactService | 3013
Errore | ServerFatalInitError | 3014
Errore | UnhandledException | 3015
Errore | WatsonReportException | 3016
Errore | InstanceMismatchError | 3019
Errore | SchemaVersionMismatchError | 3020
Errore | ATStampMismatchError | 3021
Errore | MalformedRegistrationData | 3022
Errore | InvalidDownloadKey | 3023
Errore | FileTransferException | 3024
Errore | DeltaComputationException | 3025
Errore | EventNotificationException | 3026
Errore | UnableToReportException | 3027
Errore | RegistrationDataNotAvailable | 3028
Errore | AuthenticationTypeNotSupported | 3029
Avviso | InvalidDownloadKeyLength | 6001
Avviso | FileCacheRootNotConfigured | 6002
Avviso | UnhandledExceptionOccurred | 6003
Avviso | WatsonReportSuppressed | 6004
Avviso | InstalledUICultureNotFound | 6005
Avviso | PerformanceCounterInitialization | 6006
Avviso | InvalidUri | 6007
Avviso | InvalidIdentity | 6008
Informativo | ApplicationStarted | 9001
Informativo | ApplicationStopped | 9002
Informativo | ApplicationInitialization | 9003
Informativo | SystemStateChanged | 9004
Informativo | ProcessTerminatedByUserAction | 9005

Per visualizzare i log eventi, fare clic sul pulsante Start, scegliere Strumenti di amministrazione, quindi selezionare Visualizzatore eventi. Fare doppio clic su un evento di Team Foundation Server scritto nel log eventi dell'applicazione per visualizzarne i dettagli.

Vedere anche

Altre risorse

Monitoraggio di Team Foundation Server


Monitoraggio delle prestazioni

 elenco a discesa elenco a discesa attivabile
Monitoraggio delle prestazioni
Vedere anche
elenco a discesa

Team Foundation Server fornisce contatori delle prestazioni che consentono di monitorare le prestazioni e l'attività del server. Nella seguente tabella vengono descritti i servizi di monitoraggio delle prestazioni disponibili in Team Foundation.

Contatori di Servizi TFS

Nome contatore | Descrizione
Eventi correnti in corso | Il numero di eventi di Team Foundation Server corrispondenti a sottoscrizioni.
Notifiche correnti in coda | Il numero di notifiche pronte per essere inviate.
Eventi correnti al secondo | La frequenza di elaborazione del sistema di eventi di Team Foundation Server.
Query di collegamento correnti al secondo | La frequenza di query di collegamento tra gli elementi in Team Foundation Server.
Query di registrazione correnti al secondo | La frequenza di query al servizio di registrazione di Team Foundation Server.

Contatori del server proxy TFS

Nome contatore | Descrizione
Dimensione cache corrente (byte) | La dimensione della cache corrente.
Totale richieste di download | Il numero totale di richieste di download del file.
Totale richieste soddisfatte dalla cache | Il numero totale di richieste di download soddisfatte dalla cache dei file.
Totale file in cache | Il numero totale di file disponibili nella cache.

Contatori di Controllo della versione TFS

Nome contatore | Descrizione
Caricamenti di file correnti | Il numero di file correntemente caricati nel servizio Controllo della versione TFS.
Caricamenti di file correnti al secondo | La frequenza con cui i file vengono caricati nel servizio Controllo della versione TFS.
Richieste al server correnti | Il numero di richieste correntemente attive in corso di elaborazione dal servizio Controllo della versione TFS.
Download di file correnti | Il numero di file correntemente scaricati dal servizio Controllo della versione TFS.
Download di file correnti al secondo | La frequenza con cui i file vengono scaricati dal servizio Controllo della versione TFS.
Richieste correnti al secondo | La frequenza con cui le richieste vengono elaborate dal servizio Controllo della versione TFS.
Tempo medio di risposta | Il tempo medio che il servizio Controllo della versione TFS impiega per elaborare una singola richiesta.

Contatori della gestione di elementi di lavoro TFS

Nome contatore | Descrizione
Richieste di query attive | Il numero di query correntemente in esecuzione.
Richieste di paging attive | Il numero di richieste di paging correntemente in esecuzione.
Richieste GetWorkItem attive | Il numero di richieste di elementi di lavoro correntemente in esecuzione.
Richieste di aggiornamento attive | Il numero di aggiornamenti correntemente in esecuzione.
Richieste GetMetadata attive | Il numero di aggiornamenti della cache correntemente in esecuzione.
Richieste GetStoredQuery attive | Il numero di richieste di query memorizzate correntemente in esecuzione.
Richieste GetStoredQueries attive | Il numero di richieste di query memorizzate correntemente in esecuzione.

Per informazioni sulla visualizzazione dei dati forniti dai contatori delle prestazioni, vedere Procedura: visualizzare i contatori delle prestazioni di Team Foundation Server.

Vedere anche

Attività

Procedura: visualizzare i contatori delle prestazioni di Team Foundation Server

Altre risorse

Monitoraggio di Team Foundation Server


Procedura: visualizzare i contatori delle prestazioni di Team Foundation Server

Procedura: visualizzare i contatori delle prestazioni di Team Foundation Server
Vedere anche

Team Foundation Server fornisce contatori delle prestazioni che consentono di visualizzare dati relativi alle prestazioni di Team Foundation Server in tempo reale. In questo argomento viene descritto come accedere a questi contatori e visualizzare i relativi dati disponibili. Per ulteriori informazioni sui contatori delle prestazioni disponibili, vedere Monitoraggio delle prestazioni.

Per visualizzare i contatori delle prestazioni di Team Foundation Server

  1. In Windows fare clic sul pulsante Start, scegliere Strumenti di amministrazione, quindi Prestazioni per aprire la finestra Prestazioni.

  2. Nel riquadro di destra della finestra Prestazioni fare clic su + per aprire la finestra Aggiungi contatori.

  3. Nella casella di riepilogo a discesa Oggetto prestazione selezionare l'insieme appropriato di contatori delle prestazioni di Team Foundation Server. È possibile, ad esempio, scegliere Servizi TFS, Server proxy TFS, Controllo della versione TFS o Gestione elementi di lavoro TFS.

  4. Nella casella di riepilogo di sinistra selezionare il contatore appropriato. Nella casella di riepilogo di destra selezionare l'istanza appropriata, quindi scegliere Aggiungi.

    Il contatore delle prestazioni verrà aggiunto a Monitor di sistema.

Vedere anche

Concetti

Monitoraggio delle prestazioni

Altre risorse

Monitoraggio di Team Foundation Server


Protezione di Team Foundation Server

 elenco a discesa elenco a discesa attivabile
Protezione di Team Foundation Server
Vedere anche
elenco a discesa

La protezione di Team Foundation è integrata con l'autenticazione di Windows ed è basata su utenti e gruppi. L'autenticazione di Windows viene utilizzata per autenticare gli account per le connessioni tra i client di Team Foundation e Team Foundation Server. L'autorizzazione di Team Foundation Server, inoltre, è basata su utenti, gruppi e autorizzazioni di Team Foundation Server. È possibile contribuire a garantire la protezione della distribuzione di Team Foundation Server assegnando correttamente le autorizzazioni a utenti e gruppi. Per garantire la protezione della distribuzione di Team Foundation Server è anche necessario conoscere l'architettura sottostante di Team Foundation Server e proteggere le porte e il traffico di rete tra i client e i server di Team Foundation.

In questa sezione

Concetti sulla protezione di Team Foundation Server

Vengono forniti i concetti di base sulla protezione di Team Foundation Server.

Architettura della protezione di Team Foundation Server

Viene descritta l'architettura di Team Foundation Server e viene illustrato come proteggere Team Foundation Server.

Protezione di Team Foundation Server per utenti e gruppi

Vengono illustrati i ruoli predefiniti e la protezione di Team Foundation Server.

Sincronizzazione degli account di amministratore

Vengono descritte le strategie di sincronizzazione degli account amministrativi di Team Foundation Server, SQL Reporting Services e Windows SharePoint Services.

Vedere anche

Altre risorse

Team Foundation Server Deployment


Concetti sulla protezione di Team Foundation Server

 elenco a discesa elenco a discesa attivabile
Concetti sulla protezione di Team Foundation Server
Vedere anche
elenco a discesa

Per garantire la protezione di Team Foundation Server, è necessario comprendere il funzionamento di Team Foundation Server e le modalità di comunicazione con altri componenti di Team Foundation. Un amministratore di Team Foundation Server deve avere familiarità con l'autenticazione di Windows, i protocolli e il traffico di rete e la struttura della rete aziendale in cui è installato Team Foundation Server, nonché con i gruppi e le autorizzazioni di Team Foundation Server.

Informazioni sulla protezione di Team Foundation Server

I concetti di protezione di Team Foundation Server possono essere suddivisi in tre categorie generali: topologia, autenticazione e autorizzazione. La topologia comprende i concetti relativi alla posizione e alla modalità di distribuzione dei server Team Foundation, al traffico di rete tra i client Team Foundation Server e Team Foundation e ai servizi che vengono eseguiti su Team Foundation Server. L'autenticazione riguarda la determinazione della validità di utenti, gruppi e servizi di Team Foundation Server e se tali utenti, gruppi e servizi dispongono delle autorizzazioni appropriate per l'esecuzione di azioni. Allo scopo di ottimizzare la protezione di Team Foundation Server all'interno della rete è inoltre necessario essere consapevoli delle dipendenze di Team Foundation Server da altri componenti e servizi.

Nel quadro di protezione di Team Foundation Server è fondamentale comprendere la differenza tra autenticazione e autorizzazione. Per autenticazione si intende la verifica delle credenziali di un tentativo di connessione da parte di un client, server o processo. Per autorizzazione si intende la verifica che il tentativo di connessione sia un'azione consentita. L'autorizzazione si verifica sempre dopo la riuscita dell'autenticazione. Se una connessione non viene autenticata, viene negata prima della verifica dell'autorizzazione. Se l'autenticazione di una connessione riesce, è ancora possibile negare l'esecuzione di una determinata azione se l'utente o il gruppo non dispone dell'autorizzazione necessaria.

Topologie, porte e servizi di Team Foundation Server

Per la protezione e distribuzione di Team Foundation è innanzitutto necessario determinare se i componenti possono connettersi tra di loro al fine di comunicare. In teoria, è desiderabile consentire le connessioni tra i client Team Foundation e il server Team Foundation Server e limitare o impedire altri tentativi di connessione.

Il funzionamento di Team Foundation Server dipende da determinate porte e servizi. Tali porte possono però essere protette e monitorate in base alle esigenze di sicurezza aziendali. A seconda del tipo di distribuzione di Team Foundation, è necessario consentire al traffico di rete di Team Foundation Server di passare tra i client Team Foundation, i server Team Foundation a livello applicazione e dati, i server di generazione Team Foundation Build e i client Team Foundation remoti mediante un proxy di controllo del codice sorgente. Per impostazione predefinita, Team Foundation Server è configurato in modo che venga utilizzato il protocollo HTTP per i servizi Web, ma è possibile scegliere di configurare e utilizzare i protocolli HTTPS e SSL (Secure Socket Layer) per una protezione maggiore. Per un elenco completo delle porte e dei servizi di Team Foundation Server e informazioni sul loro utilizzo nell'architettura Team Foundation Server, vedere Architettura della protezione di Team Foundation Server. Per informazioni su Team Foundation Server e HTTPS, vedere Procedura dettagliata: impostazione di Team Foundation Server con Secure Socket Layer (SSL).

È possibile distribuire Team Foundation Server in un dominio Active Directory o in un gruppo di lavoro. Rispetto ai gruppi di lavoro, Active Directory offre più funzionalità di protezione incorporate, che è possibile utilizzare per proteggere la distribuzione di Team Foundation Server. È possibile, ad esempio, configurare Active Directory in modo che non siano consentiti nomi di computer duplicati, al fine di impedire lo spoofing del nome del computer da parte di utenti malintenzionati che utilizzano un server Team Foundation Server non autorizzato. Per proteggersi dallo stesso tipo di minaccia in un gruppo di lavoro, è necessario configurare certificati per il computer. Per ulteriori informazioni su Team Foundation Server in un dominio Active Directory, vedere Gestione di Team Foundation Server in un dominio Active Directory. Per ulteriori informazioni su Team Foundation Server in un gruppo di lavoro, vedere Gestione di Team Foundation Server in un gruppo di lavoro.

Indipendentemente dal fatto che avvenga nell'ambito di un gruppo di lavoro o di un dominio, la distribuzione di Team Foundation Server presenta alcune limitazioni di topologia. Ad esempio, per garantire un corretto funzionamento, i server a livello applicazione e dati devono appartenere allo stesso segmento di rete e non deve essere presente alcun firewall tra di essi. Per ulteriori informazioni sulle topologie supportate da Team Foundation Server, vedere Topologie di Team Foundation Server.

Autenticazione

Per la protezione di Team Foundation Server vengono utilizzate l'autenticazione integrata di Windows, nota anche come Windows NT Challenge Response, e le funzionalità di protezione di Windows Server 2003. L'autenticazione integrata di Windows viene utilizzata per autenticare gli account per le connessioni tra client Team Foundation e server Team Foundation Server, per i servizi Web su server Team Foundation Server a livello applicazione e dati e per le connessioni interne tra i server Team Foundation a livello applicazione o quelli a livello dati. A seconda della rete gli utenti e i gruppi possono essere specifici di un singolo server o computer oppure membri di un dominio Active Directory.

È consigliabile non configurare connessioni di database SQL tra Team Foundation Server e Windows SharePoint Services al fine di utilizzare l'autenticazione di SQL Server, in quanto questa autenticazione è meno sicura, perché al momento della connessione al database il nome utente e la password dell'account dell'amministrazione del database vengono inviati da server a server in formato non crittografato. Se invece si utilizza l'autenticazione integrata di Windows, non vengono inviati il nome utente e la password, bensì queste informazioni vengono astratte attraverso il pool di applicazioni IIS, risultando pertanto un metodo più sicuro.

Autorizzazione di Team Foundation Server

L'autorizzazione di Team Foundation Server è basata su utenti e gruppi ai quali vengono assegnate autorizzazioni. La distribuzione specifica potrebbe richiedere la configurazione di utenti, gruppi e autorizzazioni su più computer e all'interno di più applicazioni. Se, ad esempio, si desidera includere nella distribuzione report e portali di progetto, è necessario configurare autorizzazioni per utenti e gruppi in SQL Reporting Services, Windows SharePoint Services e Team Foundation Server. In Team Foundation Server le autorizzazioni possono essere impostate a livello di singolo progetto o server oppure classificate per gruppi su server. Per ulteriori informazioni sulla configurazione di autorizzazioni, vedere Gestione delle autorizzazioni. Per ulteriori informazioni su utenti e gruppi di Team Foundation Server, vedere Gestione di utenti e gruppi.

Oltre a configurare le autorizzazioni per Team Foundation Server, potrebbero essere necessario definire autorizzazioni per il controllo del codice sorgente e gli elementi di lavoro. Queste autorizzazioni vengono gestite separatamente. Per ulteriori informazioni sulle autorizzazioni di controllo del codice sorgente, vedere Autorizzazioni e privilegi di protezione del controllo del codice sorgente e Controllo del codice sorgente di Team Foundation. Per ulteriori informazioni sulla personalizzazione degli elementi di lavoro, vedere Gestione degli elementi di lavoro di Team Foundation.

Dipendenze di Team Foundation Server

Oltre ai propri servizi, Team Foundation Server richiede alcuni servizi applicativi di Windows e altri produttori sui server a livello applicazione e dati. Nella seguente tabella sono riportati in dettaglio i servizi richiesti sui server a livello applicazione.

Nome del servizio | Descrizione
Verifica compatibilità applicazioni | Questo servizio è parte di un'infrastruttura per l'applicazione di correzioni che consentono di eseguire le applicazioni con i più recenti sistemi operativi e service pack di Windows. Per garantire una corretta applicazione delle correzioni, questo servizio deve essere in esecuzione.
Distributed Transaction Coordinator | Questo servizio coordina le transazioni di aggiornamento di due o più risorse protette mediante transazioni, quali database, code di messaggi e file system, che possono trovarsi su un singolo computer o essere distribuite tra più computer in rete.
Client DNS | Questo servizio viene utilizzato per risolvere i nomi di dominio DNS.
Log eventi | Questo servizio registra gli eventi del sistema operativo scrivendoli in uno dei tre log predefiniti accessibili mediante Visualizzatore eventi (Security, Application e System).
Servizio di amministrazione IIS | Questo servizio gestisce la metabase di IIS.
Accesso rete | Questo servizio verifica le richieste di accesso e controlla la replica a livello di dominio del database degli account utente.
Connessioni di rete | Questo servizio, noto anche come Netman, gestisce tutte le connessioni di rete create e configurate in Connessioni di rete nel Pannello di controllo ed è responsabile per la visualizzazione dello stato della rete nell'area di notifica del desktop.
NLA (Network Location Awareness) | Questo servizio raccoglie e archivia le informazioni di configurazione di rete, quali le modifiche a nomi e percorsi degli indirizzi IP e ai nomi di dominio.
RPC (Remote Procedure Call, chiamata di procedura remota) | Questo servizio è un meccanismo protetto di comunicazione tra processi (IPC) che consente lo scambio di dati e la chiamata di funzionalità che risiedono in processi diversi. Il processo diverso può trovarsi sullo stesso computer, sulla rete locale (LAN) o in Internet. Il servizio RPC svolge il ruolo di utilità di mapping degli endpoint RPC (EPM) e di gestore di controllo del servizio (SCM, Service Control Manager).
Gestione account di protezione (SAM) | Questo servizio gestisce le informazioni degli account utente, compresi i gruppi di appartenenza.
Servizio Timer di Microsoft SharePoint | Questo servizio gestisce attività pianificate in Windows SharePoint Services.
Strumentazione gestione Windows | Questo servizio avvia e arresta Common Information Model Object Manager (CIMOM).
Ora di Windows | Questo servizio, noto anche come W32Time, sincronizza data e ora in tutti i computer in esecuzione in una rete Windows Server 2003.
Pubblicazione sul Web | Questo servizio è un gestore di configurazione e processo in modalità utente che gestisce i componenti di IIS che elaborano le richieste HTTP ed eseguono le applicazioni Web e periodicamente controlla le applicazioni Web per determinare eventuali arresti imprevisti.

Nella seguente tabella sono riportati in dettaglio i servizi richiesti sui server a livello dati.

Nome del servizio | Descrizione
SQL Analysis Server (MSSQLSERVER) | Questo servizio crea e gestisce cubi OLAP e modelli di data mining.
Verifica compatibilità applicazioni | Questo servizio è parte di un'infrastruttura per l'applicazione di correzioni che consentono di eseguire le applicazioni con i più recenti sistemi operativi e service pack di Windows. Per garantire una corretta applicazione delle correzioni, questo servizio deve essere in esecuzione.
Distributed Transaction Coordinator | Questo servizio coordina le transazioni di aggiornamento di due o più risorse protette mediante transazioni, quali database, code di messaggi e file system, che possono trovarsi su un singolo computer o essere distribuite tra più computer in rete.
Client DNS | Questo servizio viene utilizzato per risolvere i nomi di dominio DNS.
Log eventi | Questo servizio registra gli eventi del sistema operativo scrivendoli in uno dei tre log predefiniti accessibili mediante Visualizzatore eventi (Security, Application e System).
Accesso rete | Questo servizio verifica le richieste di accesso e controlla la replica a livello di dominio del database degli account utente.
Connessioni di rete | Questo servizio, noto anche come Netman, gestisce tutte le connessioni di rete create e configurate in Connessioni di rete nel Pannello di controllo ed è responsabile per la visualizzazione dello stato della rete nell'area di notifica del desktop.
NLA (Network Location Awareness) | Questo servizio raccoglie e archivia le informazioni di configurazione di rete, quali le modifiche a nomi e percorsi degli indirizzi IP e ai nomi di dominio.
RPC (Remote Procedure Call, chiamata di procedura remota) | Questo servizio è un meccanismo protetto di comunicazione tra processi (IPC) che consente lo scambio di dati e la chiamata di funzionalità che risiedono in processi diversi. Il processo diverso può trovarsi sullo stesso computer, sulla rete locale (LAN) o in Internet. Il servizio RPC svolge il ruolo di utilità di mapping degli endpoint RPC (EPM) e di gestore di controllo del servizio (SCM, Service Control Manager).
Report Server (MSSSQLSERVER) | Questo servizio gestisce le richieste SOAP (Simple Object Access Protocol) e URL, elabora report, fornisce la gestione di snapshot e della cache dei report e supporta e impone i criteri di protezione e l'autorizzazione.
Gestione account di protezione (SAM) | Questo servizio gestisce le informazioni degli account utente, compresi i gruppi di appartenenza.
Servizio Timer di Microsoft SharePoint | Questo servizio gestisce attività pianificate in Windows SharePoint Services.
Strumentazione gestione Windows | Questo servizio avvia e arresta Common Information Model Object Manager (CIMOM).
Ora di Windows | Questo servizio, noto anche come W32Time, sincronizza data e ora in tutti i computer in esecuzione in una rete Windows Server 2003.

Per ulteriori informazioni sui servizi e su come interagiscono con l'architettura di Team Foundation Server, vedere Architettura della protezione di Team Foundation Server.

Vedere anche

Attività

Procedura dettagliata: impostazione di Team Foundation Server con Secure Socket Layer (SSL)

Concetti

Architettura della protezione di Team Foundation Server
Gestione di Team Foundation Server in un gruppo di lavoro
Autorizzazioni e privilegi di protezione del controllo del codice sorgente
Controllo del codice sorgente di Team Foundation
Gestione degli elementi di lavoro di Team Foundation

Altre risorse

Gestione di Team Foundation Server in un dominio Active Directory
Gestione delle autorizzazioni
Gestione di utenti e gruppi


Architettura della protezione di Team Foundation Server

 elenco a discesa elenco a discesa attivabile
Architettura della protezione di Team Foundation Server
Vedere anche
elenco a discesa

A scopo di analisi e pianificazione della protezione di Team Foundation Server, è necessario tenere in considerazione i livelli applicazione, dati e clienti di Team Foundation e le interazioni reciproche. A tal fine è necessario conoscere i servizi Web, database e modelli a oggetti impiegati, nonché sapere quali porte e protocolli di rete vengono utilizzati per impostazione predefinita e quali sono personalizzabili.

Oltre che dai propri servizi, il funzionamento di Team Foundation Server dipende anche da altri servizi. Per ulteriori informazioni sulle dipendenze di Team Foundation Server, vedere Concetti sulla protezione di Team Foundation Server.

Modello a oggetti

Team Foundation Server include un modello a oggetti che consente la comunicazione tra i livelli client e applicazione di Team Foundation. Questo modello a oggetti permette inoltre a integratori di software e a terze parti di personalizzare ed estendere la funzionalità di Team Foundation Server.

Modello a oggetti di Team Foundation Server

Il modello a oggetti di Team Foundation Server è costituito da un gruppo di API gestite che includono le seguenti interfacce:

  • Servizi comuni TF

    • Servizio di registrazione

    • Servizio di protezione

    • Servizio di collegamento

    • Servizio di gestione eventi

    • Servizio di classificazione

  • Modello a oggetti del controllo della versione

  • Modello a oggetti della gestione elementi di lavoro

Una descrizione del modello a oggetti di Team Foundation Server è disponibile al pubblico nella documentazione relativa all'extensibility di Team Foundation Server in Visual Studio SDK.

Servizi Web e database

Team Foundation Server include un gruppo di servizi Web e database, che vengono installati e configurati separatamente sui livelli applicazione, dati e client di Team Foundation. Nelle seguenti figure sono brevemente illustrati i servizi Web, le applicazioni e i database presenti su Team Foundation Server e computer client.

Diagramma architettura server Diagramma architettura client

Livello applicazione

Il livello applicazione di Team Foundation contiene i seguenti servizi Web ASP.NET che corrispondono ai rispettivi proxy o modelli a oggetti sul livello client. Ad eccezione del servizio Web MSBuild, descritto nella documentazione relativa all'extensibility di Team Foundation Server in Visual Studio SDK, questi servizi Web in genere non sono progettati per essere programmati da integratori di terze parti.

  • Servizi comuni di Team Foundation

    • Servizio Web di registrazione

    • Servizio Web di protezione

    • Servizio Web di collegamento

    • Servizio Web di gestione eventi

    • Servizio Web di classificazione

  • Servizio Web del controllo della versione

  • Servizio Web della gestione elementi di lavoro

  • Servizio Web Team Build

Livello dati

Il livello dati di Team Foundation consiste dei seguenti archivi operativi all'interno di SQL Server 2005, che includono dati, stored procedure e altra logica associata.

  • Gestione elementi di lavoro

  • Controllo della versione

  • Servizi comuni di Team Foundation

  • Team Build

  • Data warehouse per creazione di report

Livello client

Il livello client utilizza gli stessi servizi Web elencati nel livello applicazione per comunicare con il livello applicazione di Team Foundation, tramite il modello a oggetti di Team Foundation Server. Oltre al modello a oggetti di Team Foundation Server, il livello client di Team Foundation include anche componenti di Visual Studio Industry Partners (VSIP), integrazione con Microsoft Office, interfacce della riga di comando e uno schema di criteri di archiviazione per l'integrazione con Team Foundation Server e l'integrazione personalizzata. Per ulteriori informazioni su come estendere e personalizzare il livello client, vedere la documentazione relativa all'extensibility in Visual Studio SDK.

Porte e protocolli di rete

Per impostazione predefinita, per Team Foundation Server è configurato l'uso di porte e protocolli di rete specifici. Nel seguente diagramma è illustrato il traffico di rete di Team Foundation Server in una distribuzione di esempio.

Diagramma di porte e comunicazioni

Impostazioni di rete predefinite

Per impostazione predefinita, per la comunicazione tra il livello applicazione di Team Foundation, il livello dati di Team Foundation, i server di generazione e il proxy Team Foundation Server vengono utilizzati i protocolli e le porte elencati.

Servizio e livello | Protocollo | Porta
Livello applicazione – Servizi Web | HTTP | 8080
Livello applicazione – Amministrazione di Windows SharePoint Services | HTTP | Questa porta viene generata in modo casuale durante l'installazione di Windows SharePoint Services.
Livello applicazione – Windows SharePoint Services e SQL Reporting Services | HTTP | 80
Server di generazione – Accesso remoto dal server Team Foundation a livello applicazione | .NET Remoting | 9191
Livello dati | TCP MS-SQL | 1443
Livello dati | UDP MS-SQL | 1444
Proxy Team Foundation Server | HTTP | 8080
Livello dati – Reporting Services | HTTP | 80
Livello client – Servizi Web | HTTP | 8080

Impostazioni di rete personalizzabili

È possibile scegliere di modificare Team Foundation Server in modo che utilizzi HTTPS e Secure Socket Layer (SSL) invece di HTTP per i servizi Web e Microsoft SQL Reporting Services. In questo caso la comunicazione tra i livelli applicazione, dati e client cambia come descritto nella tabella seguente.

Servizio e livello | Protocollo | Porta
Livello applicazione – Servizi Web con SSL | HTTPS | Configurato dall'amministratore
Livello applicazione – Amministrazione di Windows SharePoint Services | HTTPS | Configurato dall'amministratore
Livello applicazione – Windows SharePoint Services e SQL Reporting Services | HTTPS | 443
Livello dati – Reporting Services | HTTPS | 443
Livello client – Servizi Web | HTTPS | Configurato dall'amministratore

Per ulteriori informazioni sulla configurazione dell'uso di HTTPS e SSL per Team Foundation Server, vedere Procedura dettagliata: impostazione di Team Foundation Server con Secure Socket Layer (SSL).

Vedere anche

Attività

Procedura dettagliata: impostazione di Team Foundation Server con Secure Socket Layer (SSL)

Concetti

Concetti sulla protezione di Team Foundation Server
Autorizzazioni per Team Foundation Server

Altre risorse

Topologie di Team Foundation Server


Protezione di Team Foundation Server per utenti e gruppi

 elenco a discesa elenco a discesa attivabile
Protezione di Team Foundation Server per utenti e gruppi
Vedere anche
elenco a discesa

La protezione di Team Foundation è basata su utenti e gruppi. Per garantire la protezione della distribuzione di Team Foundation Server, assegnare correttamente le autorizzazioni a utenti e gruppi e assicurarsi di aggiungere ai gruppi solo gli utenti che hanno davvero bisogno delle autorizzazioni associate al gruppo. Queste autorizzazioni consentono agli utenti di accedere solo ai dati e alle funzioni di cui hanno bisogno per svolgere il lavoro in base ai ruoli e alle responsabilità nell'ambito del team e permettono di proteggere i dati per cui è necessario limitare l'accesso. I gruppi predefiniti creati quando si installa Team Foundation Server sono progettati per soddisfare le esigenze di protezione della maggior parte delle organizzazioni. Se l'organizzazione ha esigenze di protezione specifiche o specializzate, potrebbe essere necessario modificare i gruppi di protezione esistenti o crearne di nuovi.

In genere è necessario evitare di aggiungere utenti direttamente a Team Foundation Server. La gestione delle autorizzazioni per un grande numero di singoli utenti è dispendiosa in termini di tempo e può causare problemi di gestione e sicurezza. Considerare la possibilità di creare gruppi specifici per ruoli comuni nell'ambito dell'azienda e dei progetti e di aggiungere gli utenti a tali gruppi in base alle esigenze.

Ruoli predefiniti e protezione

Sebbene i nomi dei gruppi preinstallati varino a seconda del modello di processo implementato, gli utenti di Team Foundation Server generalmente possono essere classificati in tre gruppi predefiniti. È necessario determinare quali utenti appartengono a quale gruppo, a seconda del ruolo svolto da ciascun utente nell'ambito del progetto. I ruoli e le autorizzazioni necessarie vengono descritti di seguito.

  • Amministratore di Team Foundation Può installare e gestire un server Team Foundation Server oltre che amministra le autorizzazioni e la protezione per altri ruoli. I membri di questo gruppo sono gli unici che possono creare nuovi progetti in Team Foundation Server. Gli amministratori possono inoltre personalizzare le linee guida per il processo. Poiché è il gruppo con il maggior numero di privilegi, deve essere limitato al minore numero di utenti possibile.

  • Amministratore di progetto Team Detto anche responsabile di progetto, può gestire il database degli elementi di lavoro di un progetto Team e il portale del progetto, nonché amministrare le autorizzazioni e la protezione per il progetto Team. Poiché è il secondo gruppo con il maggior numero di privilegi, deve essere limitato al minore numero di utenti possibile.

  • Collaboratore di progetto Team Può accedere a, leggere e scrivere elementi di lavoro, accedere al sito Web del progetto Team e visualizzare le linee guida per il processo di un progetto Team. Si tratta dal gruppo a cui appartiene la maggior parte degli utenti.

Nella seguente tabella sono riassunte le autorizzazioni necessarie per ciascun ruolo di esempio.

Il ruolo deve essere un membro di: | Ruolo di amministratore di Team Foundation Server | Ruolo di amministratore di progetto Team | Ruolo di collaboratore di progetto Team
Gruppi di computer a livello applicazione e dati | Amministratori di Windows | n/d | n/d
Gruppi di Team Foundation Server predefiniti | Amministratori di Team Foundation | Amministratori di progetto | Collaboratori
Gruppi di Windows SharePoint Services | Amministratore del sito | Amministratore a livello di sito del progetto | Collaboratori a livello di sito del progetto
Gruppi di Reporting Services | Responsabile della gestione del contenuto, Amministratore del sito | Responsabile della gestione del contenuto a livello di sito del progetto | Esplorazione a livello di sito del progetto

Vedere anche

Concetti

Autorizzazioni di collaboratore per Team Foundation Server
Autorizzazioni per Team Foundation Server
Autorizzazioni e privilegi di protezione del controllo del codice sorgente

Altre risorse

Autorizzazioni di amministratore di Team Foundation Server
Autorizzazioni di coordinatore del progetto di Team Foundation Server
Gestione di utenti
Gestione di gruppi
Amministrazione di Team Foundation Build


Sincronizzazione degli account di amministratore

 elenco a discesa elenco a discesa attivabile
Sincronizzazione degli account di amministratore
Vedere anche
elenco a discesa

In qualsiasi distribuzione di Team Foundation Server è necessario configurare gli account e le autorizzazioni in tre punti separati: in Windows SharePoint Services, in Microsoft SQL Reporting Services e nell'interfaccia utente di Team Foundation Server. A seconda della distribuzione di Team Foundation Server, è possibile che sia necessario configurare account amministrativi su altri computer, tra cui server di generazione, server Web e i rig di test, nonché server Team Foundation a livello dati e applicazione. La gestione di tutti gli account di amministratore e delle relative password può risultare complessa. È possibile facilitare il compito mediante la sincronizzazione degli utenti e dei gruppi che richiedono le stesse autorizzazioni per diversi computer.

Determinazione di una strategia di sincronizzazione

La strategia di sincronizzazione per Team Foundation Server dipende principalmente da due fattori: dal livello di attendibilità che si desidera estendere agli utenti nell'ambito della distribuzione di Team Foundation Server e dall'ambito in cui avviene la distribuzione di Team Foundation Server, che può essere un dominio Active Directory o un gruppo di lavoro. L'utilizzo di numerosi amministratori a livello di server e software può ridurre al minimo il carico amministrativo e facilitare la configurazione, ma aumenta notevolmente i rischi di sicurezza. Per questo motivo si consiglia di limitare al massimo il numero di account utente con autorizzazioni amministrative.

Sincronizzazione degli account di amministratore in un dominio Active Directory

Se si è distribuito Team Foundation Server in un dominio Active Directory, è possibile creare un gruppo Active Directory per gli account utente che richiedono autorizzazioni amministrative per Team Foundation Server a livello di server e software. Ad esempio è possibile creare un gruppo, detto TFSAdmins, e aggiungere l'account al gruppo di amministratori in Windows SharePoint Services e SQL Reporting Services, al gruppo Administrators di Team Foundation in Team Foundation Server e agli stessi server Team Foundation. È quindi possibile aggiungere gli utenti che richiedono le autorizzazioni amministrative al gruppo desiderato senza preoccuparsi di gestire numerosi account di amministratore diversi. È sufficiente aggiungere o rimuovere gli utenti dal gruppo in base alle esigenze e aggiungere un gruppo amministrativo ad altri server, ad esempio i server di generazione, sempre a seconda delle necessità.

Sincronizzazione degli account di amministratore in un gruppo di lavoro

Se si è distribuito Team Foundation Server in un gruppo di lavoro, non è possibile creare un unico account di gruppo per tutti gli account utente che richiedono le autorizzazioni di amministratore. È necessario aggiungere ciascun account utente a ciascun gruppo di amministratori e computer separatamente. In questo caso si consiglia di creare un elenco in cui si riportano quali account utente richiedono le autorizzazioni amministrative su quali computer e nell'ambito di quale software. In questo modo si dispone di un record a cui fare riferimento quando è necessario aggiungere, rimuovere o modificare le autorizzazioni amministrative.

Vedere anche

Concetti

Autorizzazioni per Team Foundation Server

Altre risorse

Topologie di Team Foundation Server
Gestione di utenti e gruppi
Gestione delle autorizzazioni
Gestione dei servizi e degli account di servizio di Team Foundation Server


Utilizzo degli strumenti della riga di comando di Team Foundation Server

 elenco a discesa elenco a discesa attivabile
Utilizzo degli strumenti della riga di comando di Team Foundation Server
Vedere anche
elenco a discesa

Team Foundation Server include strategie e strumenti di amministrazione utili per gestire i componenti hardware, i server e i gruppi di Team Foundation Server.

In questa sezione

Comandi della riga di comando TFSAdminUtil

Viene descritta l'utilità della riga di comando TFSAdminUtil e forniti collegamenti ad argomenti relativi ai relativi comandi e parametri disponibili.

Comandi dell'utilità della riga di comando TFSSecurity

Vengono descritti le opzioni e i parametri di TFSSecurity, un'utilità della riga di comando che consente agli amministratori di Team Foundation Server di esaminare e gestire oggetti, gruppi di applicazioni, utenti e autorizzazioni per Visual Studio Team System.

Comando TFSDeleteProject

Vengono descritti le opzioni e i parametri di TFSDeleteProject, un'utilità della riga di comando che consente di eliminare un progetto Team da Team System.

Comando TFSReg

Viene descritta TFSReg, un'utilità della riga di comando che consente di modificare, aggiornare o eliminare tutte le voci nel file di configurazione delle connessioni in Team Foundation Server.

TFSFieldMapping

Viene descritta TFSFieldMapping, un'utilità della riga di comando che consente di modificare o personalizzare il file XML di mapping del progetto una volta creato il progetto Team.

witimport

Viene descritta witimport, un'utilità della riga di comando che consente di convalidare e importare un tipo di elemento di lavoro da un file XML in un progetto Team in un server Team Foundation Server.

witexport

Viene descritta witexport, un'utilità della riga di comando che consente di esportare una definizione XML per un tipo di elemento di lavoro da Team Foundation Server.

witfields

Viene descritta witfields, un'utilità della riga di comando che consente di amministrare i campi di un tipo di elemento di lavoro nell'ambito di Team Foundation Server.

glimport

Viene descritta glimport, un'utilità della riga di comando che consente di convalidare e importare elenchi globali da un file XML in un progetto Team nell'ambito di Team Foundation Server.

glexport

Viene descritta glexport, un'utilità della riga di comando che consente di esportare una definizione XML per elenchi globali da Team Foundation Server.

SetupWarehouse

Viene descritta SetupWarehouse, un'utilità della riga di comando che consente di rigenerare l'elaborazione analitica in linea (OLAP) o il database relazionale.

Comandi di Team Foundation Build

Vengono descritte le finalità dei comandi di Team Foundation Build e illustrati degli esempi di utilizzo.

Sezioni correlate

Gestione di utenti e gruppi

Scelta degli strumenti di manutenzione di Team Foundation Server

Vedere anche

Altre risorse

Riferimenti alla riga di comando del controllo del codice sorgente di Team Foundation


Comandi della riga di comando TFSAdminUtil

 elenco a discesa elenco a discesa attivabile
Comandi della riga di comando TFSAdminUtil
elenco a discesa

Utilizzare TFSAdminUtil per automatizzare la modifica di account di servizio o di password degli account di Team Foundation Server ai livelli applicazione e dati, che vengono utilizzati internamente da Team Foundation Server per eseguire varie attività e servizi. TFSAdminUtil non crea fisicamente un account o ne modifica la password, ma semplicemente aggiorna Team Foundation Server in modo che utilizzi le credenziali esistenti. L'account di servizio può essere un account locale o di dominio ed è possibile includere il comando TFSAdminUtil in script per consentire aggiornamenti automatici.

L'utilità della riga di comando TFSAdminUtil è disponibile in <drive>:\Programmi\Microsoft Visual Studio 2005 Team Foundation Server\Tools.

L'utilità della riga di comando TFSAdminUtil dipende dalla disponibilità e dal funzionamento di molti componenti di Team Foundation Server, tra cui:

  • Microsoft SQL Server 2005

  • Microsoft SQL Server Reporting Services

  • Controller di dominio Active Directory

  • IIS 6.0

  • .NET Framework 2.0

  • Team Foundation Build

Le seguenti opzioni globali sono disponibili per quasi tutti i comandi dell'utilità TFSAdminUtil, con le eccezioni riportate di seguito.

Opzione | Descrizione
/? | Visualizza la sintassi e le opzioni dei comandi per TFSAdminUtil.
/NoPrompt | Utilizzato insieme ai comandi ActivateAT. Questa opzione specifica che all'amministratore non viene richiesto di applicare le modifiche. /NoPrompt non è supportato per Comando Sid.

In questa sezione

Comando ChangeAccount

Comando ChangePassword

Comando Sid

Comando RenameDT

Comando Optimize

Comando ActivateAt

Comando Status (TFSAdminUtil)


Comando ChangeAccount

 elenco a discesa elenco a discesa attivabile
Comando ChangeAccount
Vedere anche
comprimi tutto elenco a discesa

Utilizzare il comando ChangeAccount per modificare l'account e la password per tutti gli account di servizio.

TFSAdminUtil ChangeAccount oldacct oldpwd newacct newpwd [target]

Parametri

Argomento | Descrizione
oldacct | Specifica il nome precedente dell'account.
oldpwd | Specifica la password precedente.
newacct | Specifica il nuovo nome dell'account.
newpwd | Specifica la nuova password dell'account.
target | Specifica il computer di destinazione. Se si omette il parametro target, viene utilizzato il computer locale. Il computer di destinazione deve essere un server a livello applicazione.

espandi Note

Il comando ChangeAccount viene utilizzato da un amministratore che desidera sostituire l'account di servizio, ad esempio MyLocation\bissvc, con un altro account di servizio precreato, quale MyLocation\tfssvc. L'amministratore esegue questo strumento per aggiornare tutti i server Team Foundation che dispongono del nuovo account di servizio. Si tenga presente che è possibile utilizzare gli account utente a condizione che dispongano delle autorizzazioni corrette.

L'utilità prova prima ad aggiornare il livello dati. Assegna il nuovo account allo stesso gruppo di ruoli dell'account precedente e fa in modo che le autorizzazioni vengano mantenute e che non si verifichi alcun tempo di inattività per SQL Server. Ciò significa che l'account utente precedente deve essere rimosso manualmente dal livello dati una volta cambiato l'account.

Quindi l'utilità aggiorna il livello applicazione modificando le identità del pool di applicazioni. I pool di applicazioni devono essere riavviati singolarmente, anche se non è necessario riavviare IIS. L'ultima operazione da eseguire sul livello applicazione consiste nell'aggiornamento dell'Utilità di pianificazione di Team Foundation Server, nota anche come servizio TFSServerScheduler. Per rendere effettive le modifiche è necessario riavviare anche questo servizio. Per ulteriori informazioni, vedere Utilità di pianificazione di Team Foundation Server.

espandi Esempi

Nell'esempio riportato di seguito viene illustrata la sintassi utilizzata per aggiornare gli account di servizio. L'utilità scambia tutte le istanze dell'account precedente, MyOldAcct, con un nuovo account, MyNewAcct, e una nuova password, newPass. L'utilità scorre i servizi e modifica solo quelli che vengono eseguiti utilizzando l'account precedente. Poiché non viene fornito il parametro di destinazione, come server a livello applicazione di destinazione viene utilizzato il computer su cui è eseguito lo strumento.

Immagine CopyCode Copia codice
TFSAdminUtil.exe ChangeAccount MyOldAcct oldPass MyNewAcct newPass

espandi Protezione

Per potere utilizzare il comando ChangeAccount dell'utilità della riga di comando TFSAdminUtil è necessario disporre di privilegi di amministratore nel livello applicazione locale e di amministratore di SQL Server nel livello dati di Team Foundation Server.

espandi Vedere anche

Altre risorse

Utilizzo degli strumenti della riga di comando di Team Foundation Server
Amministrazione di Team Foundation Server
Gestione dei servizi e degli account di servizio di Team Foundation Server

piè di pagina


Comando ChangePassword

 elenco a discesa elenco a discesa attivabile
Comando ChangePassword
Vedere anche
comprimi tutto elenco a discesa

Utilizzare il comando ChangePassword per modificare la password per tutti gli account di servizio.

TFSAdminUtil ChangePassword oldacct oldpwd newpwd [target]

Parametri

Argomento | Descrizione
oldacct | Specifica il nome precedente dell'account.
oldpwd | Specifica la password precedente.
newpwd | Specifica la nuova password dell'account.
target | Specifica il computer di destinazione. Se si omette il parametro target, viene utilizzato il computer locale. Il computer di destinazione deve essere un server a livello applicazione.

espandi Note

Il comando ChangePassword viene utilizzato da un amministratore che desidera modificare la password dell'account di servizio, ad esempio dominio\nomeserver. L'amministratore modifica la password dell'account di dominio, quindi esegue il comando per aggiornare tutti i server Team Foundation in base alla nuova password.

L'utilità aggiorna il livello applicazione modificando le password del pool di applicazioni. I pool di applicazioni devono essere riavviati singolarmente, mentre Internet Information Services (IIS) non richiede il riavvio. L'ultima operazione da eseguire sul livello applicazione consiste nell'aggiornamento dell'Utilità di pianificazione di Team Foundation Server, nota anche come servizio TFSServerScheduler. Per ulteriori informazioni, vedere Utilità di pianificazione di Team Foundation Server.

Nota Nota

Poiché SQL Server 2005 sincronizza le proprie password dell'account di servizio con Active Directory, all'utilità non è richiesto di modificare alcuna password di SQL Server.

espandi Esempi

Nell'esempio riportato di seguito viene illustrata la sintassi utilizzata per modificare le password dell'account di servizio. L'utilità scambia tutte le istanze dell'account precedente, MyOldAcct, per associare una nuova password dell'account, newPass, sul computer di destinazione a livello applicazione, MyAppTier. L'utilità scorre gli account di servizio e modifica solo quelli che vengono eseguiti utilizzando l'account precedente.

Immagine CopyCode Copia codice
TFSAdminUtil.exe ChangePassword MyOldAcct oldPass newPass MyAppTier

espandi Protezione

Per potere utilizzare il comando ChangePassword dell'utilità della riga di comando TFSAdminUtil è necessario disporre di privilegi di amministratore nel livello applicazione locale e di amministratore di SQL Server nel livello dati di Team Foundation Server.

espandi Vedere anche

Concetti

Server a livello applicazione di Team Foundation
Gestione dei server a livello applicazione di Team Foundation Server
Server a livello dati di Team Foundation

Altre risorse

Comandi della riga di comando TFSAdminUtil
Utilizzo degli strumenti della riga di comando di Team Foundation Server
Amministrazione di Team Foundation Server
Gestione dei servizi e degli account di servizio di Team Foundation Server

piè di pagina


Comando Sid

 elenco a discesa elenco a discesa attivabile
Comando Sid
Vedere anche
comprimi tutto elenco a discesa

Utilizzare Sid per aggiornare o elencare tutti gli identificatori di protezione registrati o quelli specificati.

Sid [/noprompt] (/C[hange] | /L[ist]) (/A[ll] | account)

Parametri

Argomento | Descrizione
account | Utilizzato con le opzioni /L[ist] o /C[hange] consente di elencare o aggiornare i SID per l'account specificato da account. Non può essere utilizzato insieme all'opzione /A[ll].
Opzione | Descrizione
/C[hange] | Sincronizza il SID nel database di Team Foundation Server con il SID di Windows. Se sono diversi, aggiorna i SID di Team Foundation Server per tutti gli account (/All) o quello di un utente specifico. Questa opzione funziona solo in ambienti di gruppi di lavoro.
/L[ist] | Elenca i SID per tutti gli account (/All) o quello di un utente specifico.
/A[ll] | Utilizzato insieme alle opzioni /C[hange] e /L[ist] consente di specificare che tutti i SID devono essere aggiornati o elencati. Non può essere utilizzato insieme al parametro account.

espandi Note

Team Foundation Server utilizza i SID per autenticare e identificare gli utenti nell'ambiente del gruppo di lavoro. Controllo del codice sorgente Team Foundation memorizza le informazioni degli utenti nella tabella di identità dove il SID dell'utente è registrato come authenticationKey.

Il comando TFSAdminUtil Sid viene utilizzato da un amministratore per aggiornare gli account utente per rispondere all'assegnazione di un nuovo nome agli utenti o alla reinstallazione di Team Foundation su un computer diverso. Ad esempio, se l'amministratore desidera spostare Team Foundation su un nuovo computer nell'ambito del suo gruppo di lavoro, deve seguire la procedura descritta.

  1. Ripristinare i backup dei dati e creare il livello applicazione.

  2. Utilizzare il comando TFSAdminUtil SID /List /All per elencare tutti gli account.

  3. Utilizzare l'elenco generato al punto 2 per creare tutti gli account utente.

  4. Eseguire il comando TFSAdminUtil SID /Change /All per aggiornare i SID degli account utente in Team Foundation Server.

    In questo modo gli account utente conservano tutte le autorizzazioni e le proprietà precedenti.

espandi Esempi

In questo esempio di utilizzo del comando Sid dell'utilità TFSAdminUtil vengono elencati tutti gli identificatori di protezione registrati.

Immagine CopyCode Copia codice
TFSAdminUtil.exe Sid /NoPrompt /List /All

espandi Protezione

Per potere utilizzare il comando Sid dell'utilità della riga di comando TFSAdminUtil è necessario disporre di privilegi di amministratore nel livello applicazione locale e di amministratore di SQL Server nel livello dati di Team Foundation Server.

espandi Vedere anche

Altre risorse

Utilizzo degli strumenti della riga di comando di Team Foundation Server
Amministrazione di Team Foundation Server
Gestione dei servizi e degli account di servizio di Team Foundation Server
Amministrazione di Team Foundation Server
Gestione dei servizi e degli account di servizio di Team Foundation Server

piè di pagina


Comando RenameDT

 elenco a discesa elenco a discesa attivabile
Comando RenameDT
Vedere anche Esempio
comprimi tutto elenco a discesa

Utilizzare RenameDT per modificare il nome del server Team Foundation Server a livello dati.

TFSAdminUtil RenameDT servername

Parametri

Argomento Descrizione

servername

Specifica il computer di destinazione mediante i seguenti attributi:

  • Indirizzo IP

    L'indirizzo IP deve essere nel formato: aaa.bbb.ccc.ddd.

  • Nome computer

    Non è possibile utilizzare spazi o caratteri speciali, ad esempio ";:<>*. Sono consentiti solo i caratteri [A-Z | 0-9 | -]. Il nome non può essere composto solo da numeri e può contenere al massimo 15 caratteri ASCII o 7 caratteri per codifiche di caratteri a due byte.

  • Indirizzo dominio

    Ad esempio Myserver.location.mycompanyt.com.

espandi Note

Il livello applicazione di Team Foundation Server deve conoscere il nome o l'indirizzo esatto del server a livello dati per poterlo raggiungere. Il nome e l'indirizzo del livello dati vengono memorizzati in diversi percorsi sul server Team Foundation Server, nei database sia del livello dati che del livello applicazione. Quando è necessario passare a un nuovo livello dati, l'amministratore deve verificare che Team Foundation Server faccia riferimento al nome o all'indirizzo del nuovo livello dati.

Il comando RenameDT dell'utilità della riga di comando TFSAdminUtil automatizza il processo di ridenominazione del livello dati aggiornando Team Foundation Server in modo che faccia riferimento a un nuovo nome o indirizzo. È inoltre possibile eseguire il comando RenameDT da script per automatizzare o pianificare il processo di ridenominazione del livello dati.

Il comando RenameDT può essere eseguito solo a livello applicazione perché il file web.config viene cercato sul computer su cui tale comando è eseguito e non sono disponibili funzionalità di accesso remoto o la possibilità di specificare il computer a livello applicazione di destinazione.

espandi Scenari di utilizzo di esempio

Il comando RenameDT può essere utilizzato dall'amministratore in vari scenari, tra cui quelli elencati di seguito:

  • L'amministratore deve mettere il livello dati non in linea per eseguire la manutenzione ordinaria e sostituirlo quindi con un altro livello dati temporaneo per evitare tempo di inattività.

  • L'amministratore esegue il comando RenameDT dell'utilità della riga di comando TFSAdminUtil in modo che Team Foundation Server si connetta al nuovo livello dati temporaneo. Al termine della manutenzione l'amministratore esegue di nuovo l'utilità per ripristinare il livello dati precedente.

  • Il livello dati non funziona correttamente.

  • L'amministratore esegue il comando RenameDT affinché Team Foundation Server faccia riferimento a un nuovo server di backup.

  • Il livello dati viene aggiornato con un nuovo server.

  • L'amministratore esegue il comando RenameDT affinché Team Foundation Server faccia riferimento al nuovo server a livello dati.

  • Sono stati definiti nuovi criteri operativi per gli standard di denominazione dei computer appartenenti al livello dati.

  • L'amministratore utilizza il comando RenameDT per assegnare un nuovo nome più appropriato al livello dati.

  • L'organizzazione o l'azienda si è espansa e deve eseguire la migrazione da una soluzione a server singolo a una a server doppio.

  • Dopo avere impostato il nuovo livello dati indipendente, l'amministratore esegue il comando RenameDT affinché Team Foundation Server faccia riferimento al nuovo server.

espandi Esempio

Nell'esempio seguente tutte le istanze del nome del livello dati in Team Foundation Server vengono sostituite con NewName.
Immagine CopyCode Copia codice
TFSAdminUtil RenameDT NewName

espandi Protezione

Per potere utilizzare il comando RenameDT dell'utilità della riga di comando TFSAdminUtil è necessario disporre di privilegi di amministratore nel livello applicazione locale e di amministratore di SQL Server nel livello dati di Team Foundation Server.

espandi Vedere anche

Concetti

Server a livello applicazione di Team Foundation
Server a livello dati di Team Foundation

Altre risorse

Comandi della riga di comando TFSAdminUtil
Utilizzo degli strumenti della riga di comando di Team Foundation Server
Amministrazione di Team Foundation Server
Gestione dei servizi e degli account di servizio di Team Foundation Server
Gestione dei server a livello dati di Team Foundation Server

piè di pagina


Comando Optimize

 elenco a discesa elenco a discesa attivabile
Comando Optimize
Vedere anche Esempio
comprimi tutto elenco a discesa

Utilizzare il comando optimize al fine di ottimizzare il database Team Foundation eseguendo la pulitura e la deframmentazione del disco.

TFSAdminUtil Optimize

espandi Note

L'esecuzione del comando optimize dell'utilità della riga di comando TFSAdmin consente di ottimizzare il livello dati di Team Foundation Server mediante la pulitura dei singoli database e la deframmentazione degli indici dei database. L'ottimizzazione viene in genere eseguita dall'amministratore del database o di Team Foundation Server nell'ambito del piano di manutenzione dei database per Team Foundation Server. Poiché questa utilità può essere eseguita anche tramite script, è possibile automatizzare e pianificare il processo di ottimizzazione ordinaria.

L'utilità deve essere eseguita a livello applicazione in quanto i servizi Web vengono cercati nel computer su cui l'utilità viene eseguita e non sono disponibili funzionalità di accesso remoto o la possibilità di specificare il server a livello applicazione di destinazione.

espandi Pulitura dei database

Dopo un periodo di uso estensivo, i database Team Foundation Server potrebbero contenere record cronologici o archiviati non più utili, che possono quindi essere rimossi allo scopo di ridurre la dimensione dei database e migliorare le prestazioni. All'interno di ogni database è disponibile l'implementazione di una stored procedure per l'ottimizzazione che può essere individuata ed eseguita utilizzando il comando optimize. L'utilità scorre quindi in ciclo tutti i database finché non sono stati tutti puliti. Se la pulitura di un database non viene completata correttamente, viene visualizzato un messaggio di avviso e l'utilità passa alla pulitura del database successivo.

espandi Deframmentazione dei database

Quando viene creato un indice di database e aggiunti alcuni record, il database non presenta un livello di frammentazione significativo. Tuttavia, a seguito di un elevato numero di operazioni, l'ordine fisico dei record indicizzati viene gradualmente modificato e diventa più irregolare, con conseguenze sulle prestazioni del disco e sull'efficacia del gestore read-ahead di SQL Server.

La deframmentazione include la riorganizzazione fisica dei record in un ordine logico in modo da ridurre il tempo richiesto dal server per scorrere il database.

Il comando optimize dell'utilità della riga di comando TFSAdmin determina se eseguire la riorganizzazione o la rigenerazione in base al livello di frammentazione e paginazione degli indici del database. In presenza di un elevato livello di frammentazione degli indici viene eseguita la riorganizzazione, mentre la rigenerazione viene eseguita per livelli di frammentazione e numeri di pagine inferiori. Se SQL Server restituisce un errore, viene riportato un avviso nella riga di comando.

espandi Esempio

Nel seguente esempio viene illustrata la sintassi del comando optimize dell'utilità della riga di comando TFSAdminUtil. Durante l'esecuzione l'utente viene mantenuto costantemente informato sull'avanzamento del processo di ottimizzazione.
Immagine CopyCode Copia codice
TFSAdminUtil optimize

espandi Protezione

Per potere utilizzare il comando Optimize dell'utilità della riga di comando TFSAdminUtil è necessario disporre di privilegi di amministratore nel livello applicazione locale e di amministratore di SQL Server nel livello dati di Team Foundation Server.

espandi Vedere anche

Concetti

Server a livello applicazione di Team Foundation
Server a livello dati di Team Foundation

Altre risorse

Comandi della riga di comando TFSAdminUtil
Utilizzo degli strumenti della riga di comando di Team Foundation Server
Amministrazione di Team Foundation Server
Gestione dei servizi e degli account di servizio di Team Foundation Server
Gestione dei server a livello dati di Team Foundation Server

piè di pagina


Comando ActivateAt

 elenco a discesa elenco a discesa attivabile
Comando ActivateAt
Vedere anche Esempio
comprimi tutto elenco a discesa

Utilizzare il comando ActivateAT per attivare il computer locale come server a livello applicazione.

TFSAdminUtil ActivateAT

espandi Note

È necessario impedire che diversi livelli applicazione si connettano allo stesso livello dati. Il comando ActivateAT dell'utilità della riga di comando TFSAdminUtil consente di attivare il livello applicazione appropriato e associarlo al server a livello dati.

espandi Scenari di utilizzo di esempio

Il comando ActivateAT può essere utilizzato dall'amministratore in vari scenari, tra cui quelli elencati di seguito:

  • Manutenzione o correzione del livello applicazione:

    L'amministratore configura un nuovo livello applicazione e deve attivarlo al posto di quello corrente. Il livello applicazione corrente (quello esistente) viene arrestato. L'amministratore esegue l'utilità della riga di comando TFSAdminUtil activateAT per associare il nuovo livello applicazione al server a livello dati.

  • Errore del livello applicazione attivo:

    Poiché il livello applicazione rappresenta un singolo punto di esposizione agli errori nel sistema, l'amministratore potrebbe decidere di aggiungere un server a livello applicazione di standby. Il livello applicazione attivo è connesso alla rete e fa riferimento al server a livello dati corretto. Il livello dati deve sostenere il livello applicazione attivo e non deve eseguire transazioni con il server a livello applicazione di standby. Il comando ActivateAT consente di passare da un server a livello applicazione all'altro in base alle necessità.

    Se il server a livello applicazione attivo restituisce un errore, l'amministratore deve passare al server a livello applicazione di standby. Innanzitutto l'amministratore arresta o reimposta Internet Information Services (IIS) sul server a livello applicazione che ha presentato l'errore, quindi esegue l'utilità della riga di comando TFSAdminUtil ActivateAT per associare il livello applicazione di standby al server a livello dati.

espandi Esempio

Il comando di esempio seguente attiva il computer locale come livello applicazione.
Immagine CopyCode Copia codice
TFSAdminUtil.exe activateAT

espandi Protezione

Per potere utilizzare il comando ActivateAT dell'utilità della riga di comando TFSAdminUtil è necessario disporre di privilegi di amministratore nel livello applicazione locale e di amministratore di SQL Server nel livello dati di Team Foundation Server.

espandi Vedere anche

Concetti

Server a livello applicazione di Team Foundation
Server a livello dati di Team Foundation

Altre risorse

Comandi della riga di comando TFSAdminUtil
Utilizzo degli strumenti della riga di comando di Team Foundation Server
Amministrazione di Team Foundation Server
Gestione dei servizi e degli account di servizio di Team Foundation Server
Gestione dei server a livello dati di Team Foundation Server

piè di pagina


Comando Status (TFSAdminUtil)

 elenco a discesa elenco a discesa attivabile
Comando Status (TFSAdminUtil)
Vedere anche
comprimi tutto elenco a discesa

Utilizzare il comando Status per visualizzare le informazioni sullo stato per un account di servizio specificato in Team Foundation Server.

TFSAdminUtil Status account [machinename]

Parametri

Argomento | Descrizione
account | Nome dell'account. Deve essere nel formato dominio\utente, ad esempio mylocation\tfssvc.
machinename | Nome del computer. Se si omette il parametro machinename, viene utilizzato l'account locale.

espandi Note

Il comando Status dell'utilità della riga di comando TFSAdminUtil consente di visualizzare informazioni relative all'utilizzo dell'account specificato da parte di Team Foundation Server.

espandi Esempi

Nel seguente esempio viene illustrato l'output di stato per le risorse in esecuzione con account di servizio "myLocation\tfssvc".

Immagine CopyCode Copia codice
TfsAdminUtil.exe status myLocation\tfssvc

Esempio di output:

Immagine CopyCode Copia codice
LoginName            SID
-------------------------------------------------------------------
MYLOCATION\TFSSVC    S-1-5-21-2127521184-1604012920-1887927527-2435684

DBName                            UserName          UserOrAlias
---------------------------------------------------------------
STS_Config                       db_owner           MemberOf
STS_Config                       MYLOCATION\TFSSVC  User
STS_VSE2017_1                    db_owner           MemberOf
STS_VSE2017_1                    dbo                User
TfsActivityLogging               MYLOCATION\TFSSVC  User
TfsActivityLogging               TFSEXECROLE        MemberOf
TfsBuild                         MYLOCATION\TFSSVC  User
TfsBuild                         TFSEXECROLE        MemberOf
TfsIntegration                   MYLOCATION\TFSSVC  User
TfsIntegration                   TFSEXECROLE        MemberOf
TfsVersionControl                MYLOCATION\TFSSVC  User
TfsVersionControl                TFSEXECROLE        MemberOf
TFSWarehouse                     MYLOCATION\TFSSVC  User
TFSWarehouse                     TFSEXECROLE        MemberOf
TfsWorkItemTracking              MYLOCATION\TFSSVC  User
TfsWorkItemTracking              TFSEXECROLE        MemberOf
TfsWorkItemTrackingAttachments   MYLOCATION\TFSSVC  User
TfsWorkItemTrackingAttachments   TFSEXECROLE        MemberOf

Account status on application tier (IIS application pools): VSE2017.
3 app pool(s) are running under given account: myLocation\tfssvc.

Name           Status
----------------------
TFS AppPool    Running
TFWSSc86e      Running
WSSc86eAdm     Running

Account status on application tier (NT Services): VSE2017.
3 NT service(s) are runing under given account: myLocation \tfssvc.

Name                  DisplayName                       Status
---------------------------------------------------------------
SPTimer               SharePoint Timer Service          Running
coveran               Code Coverage Analysis Service    Stopped
TFSServerScheduler    TFSServerScheduler                Running

espandi Vedere anche

Altre risorse

Comandi della riga di comando TFSAdminUtil

piè di pagina


Comandi dell'utilità della riga di comando TFSSecurity

 elenco a discesa elenco a discesa attivabile
Comandi dell'utilità della riga di comando TFSSecurity
elenco a discesa

Utilizzare TFSSecurity per creare, modificare ed eliminare gruppi e utenti di Team Foundation Server, nonché autorizzazioni per utenti e gruppi.

L'utilità della riga di comando TFSSecurity è disponibile in <drive>:\Programmi\Microsoft Visual Studio 2005 Team Foundation Server\Tools.

Le seguenti opzioni sono supportate per tutti i comandi di TFSSecurity.

opzione | Descrizione
/server:nome | Seleziona in modo esplicito un dominio di Team Foundation Server, dove nome è il nome del dominio.
/? | Visualizza la sintassi e le opzioni dei comandi per TFSSecurity.

In questa sezione

Identificatori di output e identità per TFSSecurity

Comando /i

Comando /im

Comando /imx

Comando /g

Comando /gcg

Comando /gc

Comando /gun

Comando /gud

Comando /gd

Comando /g+

Comando /g-

Comando /m

Comando /a+

Comando /a-

Comando /acl


Identificatori di output e identità per TFSSecurity

 elenco a discesa elenco a discesa attivabile
Identificatori di output e identità per TFSSecurity
Vedere anche
elenco a discesa

L'input e l'output dell'utilità della riga di comando TFSSecurity rispettano un formato standard. Nelle seguenti tabelle sono descritti gli identificatori di output e identità validi.

Identificatori di identità

Per fare riferimento a un'identità, utilizzare una delle annotazioni seguenti.

Identificatore di identità Descrizione Esempio

sid: sid.

Fa riferimento all'identità con il SID specificato.

sid:S-1-5-21-2127521184-1604012920-1887927527-588340

n:[dominio\]nome

Fa riferimento all'identità con il nome specificato. In Windows nome indica il nome di accesso. Se il parametro dominio viene omesso ed è disponibile il catalogo globale, la ricerca viene eseguita all'interno del catalogo globale. Se il parametro dominio viene omesso e non è disponibile il catalogo globale, viene utilizzato il contesto di dominio predefinito. Per i gruppi di applicazioni nome indica il nome di visualizzazione del gruppo, mentre dominio è l'URI o il GUID del progetto a cui il gruppo appartiene. Se il parametro dominio viene omesso, viene utilizzato l'ambito globale.

Per fare riferimento all'identità dell'utente "John Peoples" nel dominio "Datum1" presso la società fittizia "A. Datum Corporation":

n:DATUM1\jpeoples

Se esiste solo un dominio o è stato eseguito l'accesso al dominio Datum1, è possibile utilizzare anche il seguente comando:

n:jpeoples

Per fare riferimento ai gruppi di applicazioni:

n:"Full-time Employees"

n:00a10d23-7d45-4439-981b-d3b3e0b0b1ee\Vendors

n:dn

Fa riferimento all'identità con il nome distinto specificato. Il nome distinto può essere preceduto dal prefisso LDAP://.

dn:CN=John Peoples,CN=Users,DC=Datum1,DC=com

dn:LDAP://CN=Developers,OU=Groups,DC=Datum1,DC=com

dm:[ambito]

Fa riferimento al gruppo di applicazioni amministrative per l'ambito. Il parametro facoltativo ambito è l'URI o il GUID del progetto. Se il parametro ambito viene omesso, viene utilizzato l'ambito globale. È comunque necessario includere i due punti.

dm:TFSAdmins

srv:

Fa riferimento al gruppo di applicazioni di servizio.

NA

stringa

Fa riferimento a una stringa non qualificata. Se la stringa inizia con S-1-, viene interpretata come un SID. Se la stringa inizia con CN= o LDAP://, viene interpretata come un nome distinto. Altrimenti la stringa viene interpretata come un nome.

"Tester Team"

Indicatori di tipi

Indicatori di tipi di identità

Nei messaggi di output vengono utilizzati i seguenti indicatori di tipi di identità.

Indicatore di tipi di identità | Descrizione
U | Utente Windows.
G | Gruppo Windows.
A | Gruppo di applicazioni Team Foundation Server.
a [ A ] | Gruppo di applicazioni amministrative.
s [ A ] | Gruppo di applicazioni di servizio.
X | Identità non valida.
? | Identità sconosciuta.

Indicatori di voci di controllo di accesso

Nei messaggi di output vengono utilizzati i seguenti indicatori di voci di controllo di accesso.

Indicatore di voci di controllo di accesso | Descrizione
+ | Voce di controllo di accesso CONSENTI.
- | Voce di controllo di accesso NEGA.
* [ ] | Voce di controllo di accesso ereditata.

Vedere anche

Altre risorse

Comandi dell'utilità della riga di comando TFSSecurity
Gestione di gruppi
Gruppi predefiniti
Gruppi a livello di server
Gruppi di un progetto Team


Comando /i

 elenco a discesa elenco a discesa attivabile
Comando /i
Vedere anche
comprimi tutto elenco a discesa

Utilizzare il comando /i per visualizzare le informazioni di identità per un gruppo specificato in Team Foundation Server.

TFSSecurity /i identity

Parametri

Argomento | Descrizione
identity | Specifica l'identità dell'utente o del gruppo di applicazioni. Per ulteriori informazioni sugli identificatori di identità, vedere Identificatori di output e identità per TFSSecurity.

espandi Note

Il comando /i dell'utilità della riga di comando TFSSecurity consente di visualizzare informazioni relative a ciascun gruppo nel livello applicazione di Team Foundation Server. Non vengono però visualizzate informazioni sull'appartenenza.

espandi Esempi

Il comando di esempio seguente visualizza le informazioni di identità per il gruppo Team Foundation Administrators.

Immagine CopyCode Copia codice
>tfssecurity /i "Team Foundation Administrators"

Esempio di output:

Immagine CopyCode Copia codice
Resolving identity "Team Foundation Administrators"...

SID: S-1-9-XXXXXXXXXX-XXXXXXXXXX-XXXXXXXXXX-XXXXXXXXXX-0-0-0-0-1

DN:

Identity type: Team Foundation Server application group
   Group type: AdministrativeApplicationGroup
Project scope: Server scope
 Display name: Team Foundation Administrators
  Description: Members of this application group can perform all privileged operations on the server.

espandi Protezione

Per potere utilizzare il comando /i dell'utilità della riga di comando TFSSecurity è necessario essere un amministratore di Team Foundation Server nel livello applicazione locale. Eseguire questo comando sul computer a livello applicazione locale.

espandi Vedere anche

Attività

Procedura: creare un gruppo a livello di server

Altre risorse

Comandi dell'utilità della riga di comando TFSSecurity
Gruppi di un progetto Team

piè di pagina


Comando /im

 elenco a discesa elenco a discesa attivabile
Comando /im
Vedere anche
comprimi tutto elenco a discesa

Utilizzare il comando /im per visualizzare le informazioni di identità di appartenenza diretta per un gruppo specificato.

TFSSecurity /im identity

Parametri

Argomento | Descrizione
identity | Specifica l'identità dell'utente o del gruppo. Per ulteriori informazioni sugli identificatori di identità, vedere Identificatori di output e identità per TFSSecurity.

espandi Note

TfsSecurity /im visualizza solo i membri diretti del gruppo specificato, inclusi altri gruppi membri di tale gruppo. Tuttavia i membri effettivi di tali gruppi non sono elencati.

espandi Esempi

Il comando di esempio seguente visualizza le informazioni di identità di appartenenza diretta per il gruppo Team Foundation Administrators.

Immagine CopyCode Copia codice
>tfssecurity /im "Team Foundation Administrators"

Esempio di output:

Immagine CopyCode Copia codice
Resolving identity "Team Foundation Administrators"...

SID: S-1-9-XXXXXXXXXX-XXXXXXXXXX-XXXXXXXXXX-XXXXXXXXXX-0-0-0-0-1

DN:

Identity type: Team Foundation Server application group
Group type: AdministrativeApplicationGroup
Project scope: Server scope
Display name: Team Foundation Administrators
Description: Members of this application group can perform all privileged operations on the server.

4 member(s):
  [G] MyLocation\Cwin (Coho Winery)
  [U] MyLocation\ajesper (Aaberg, Jesper)
  [G] BUILTIN\Administrators
s [A] [SERVER]\Service Accounts

Member of 1 group(s):
e [A] [SERVER]\Team Foundation Valid Users

espandi Protezione

Per potere utilizzare il comando /im dell'utilità della riga di comando TFSSecurity è necessario essere un amministratore di Team Foundation Server nel livello applicazione locale. Eseguire questo comando sul computer a livello applicazione locale.

espandi Vedere anche

Attività

Procedura: creare un gruppo a livello di server

Altre risorse

Comandi dell'utilità della riga di comando TFSSecurity
Gruppi di un progetto Team

piè di pagina


Comando /imx

 elenco a discesa elenco a discesa attivabile
Comando /imx
Vedere anche
comprimi tutto elenco a discesa

Utilizzare il comando /imx per visualizzare le informazioni di identità di appartenenza estesa per un gruppo specificato.

TFSSecurity /imx identity

Parametri

Argomento | Descrizione
identity | Specifica l'identità dell'utente o del gruppo. Per ulteriori informazioni sugli identificatori di identità, vedere Identificatori di output e identità per TFSSecurity.

espandi Note

TfsSecurity /im visualizza solo i membri diretti del gruppo specificato, inclusi altri gruppi membri del gruppo specificato e i membri effettivi di tali gruppi.

espandi Esempi

Il comando di esempio seguente visualizza le informazioni di identità di appartenenza estesa per il gruppo Team Foundation Administrators.

Immagine CopyCode Copia codice
>tfssecurity /imx "Team Foundation Administrators"

Esempio di output:

Immagine CopyCode Copia codice
SID: S-1-9-XXXXXXXXXX-XXXXXXXXXX-XXXXXXXXXX-XXXXXXXXXX-0-0-0-0-1

DN:

Identity type: Team Foundation Server application group
   Group type: AdministrativeApplicationGroup
Project scope: Server scope
 Display name: Team Foundation Administrators
  Description: Members of this application group can perform all privileged operations on the server.

10 member(s):
  [U] MYLOCATION\Cwinbld (Coho Winery Build-Test Account)
  [U] MYLOCATION\tommyh (Tommy Hartono)
  [U] MYLOCATION\henriea (Henriette Andersen)
  [U] MYLOCATION\bissvca (BIS Service Account)
  [U] MYLOCATION\stanisp (Stanislav Pesotsky)
  [G] MYLOCATION\InfoSec Secure Environment
  [U] MYLOCATION\tiannaj (TiAnna Jones)
  [G] MYLOCATION\cwin (Coho Winery)
  [G] BUILTIN\Administrators
s [A] [SERVER]\Service Accounts

Member of 1 group(s):
e [A] [SERVER]\Team Foundation Valid Users

Done.

Per ulteriori informazioni sugli identificatori di output, quali [G] e [U], vedere Identificatori di output e identità per TFSSecurity.

espandi Vedere anche

Attività

Procedura: creare un gruppo a livello di server

Altre risorse

Comandi dell'utilità della riga di comando TFSSecurity
Gruppi di un progetto Team

piè di pagina


Comando /g

 elenco a discesa elenco a discesa attivabile
Comando /g
Vedere anche Esempio
comprimi tutto elenco a discesa

Utilizzare il comando /g per elencare i gruppi in un ambito di progetto.

TFSSecurity /g [scope]

Parametri

Argomento | Descrizione
scope | Facoltativo. URI o GUID del progetto. Se il nome del progetto viene omesso, verranno visualizzati i gruppi globali.

espandi Esempio

Il comando di esempio seguente visualizza tutti i gruppi globali.
Immagine CopyCode Copia codice
>TFSSecurity /g

espandi Protezione

Per potere utilizzare il comando /g dell'utilità della riga di comando TFSSecurity è necessario essere un amministratore di Team Foundation Server nel livello applicazione locale. Eseguire questo comando sul computer a livello applicazione locale.

espandi Vedere anche

Attività

Procedura: creare un gruppo a livello di server

Altre risorse

Comandi dell'utilità della riga di comando TFSSecurity
Gruppi di un progetto Team

piè di pagina


Comando /gcg

 elenco a discesa elenco a discesa attivabile
Comando /gcg
Vedere anche Esempio
comprimi tutto elenco a discesa

Utilizzare il comando /gcg per creare un gruppo globale.

TFSSecurity /gcg groupName [groupDescription]

Parametri

Argomento | Descrizione
groupName | Specifica il nome del gruppo globale.
groupDescription | Facoltativo. Descrizione del gruppo.

espandi Note

I gruppi globali sono gruppi creati direttamente in Team Foundation Server, a differenza dei gruppi di progetto Team, che sono associati a un progetto specifico. Ai gruppi globali è possibile assegnare autorizzazioni per l'esecuzione di operazioni in Team Foundation Server quali la creazione di nuovi progetti o l'amministrazione degli utenti.

espandi Esempio

Nel seguente esempio viene creato il gruppo globale cwintst con descrizione Coho Winery Tester.
Immagine CopyCode Copia codice
>TFSSecurity /gcg cwintst “Coho Winery Testers”

espandi Protezione

Per potere utilizzare il comando /gcg dell'utilità della riga di comando TFSSecurity è necessario essere un amministratore di Team Foundation Server nel livello applicazione locale. Eseguire questo comando sul computer a livello applicazione locale.

espandi Vedere anche

Attività

Procedura: creare un gruppo a livello di server

Altre risorse

Comandi dell'utilità della riga di comando TFSSecurity
Gruppi di un progetto Team
Gruppi predefiniti

piè di pagina


Comando /gc

 elenco a discesa elenco a discesa attivabile
Comando /gc
Vedere anche Esempio
comprimi tutto elenco a discesa

Utilizzare il comando /gc per creare un gruppo specifico di un progetto.

TFSSecurity /gc scope groupName [groupDescription]

Parametri

Argomento | Descrizione
scope | Specifica il GUID del progetto o l'URI del progetto Team. Per ottenere l'URI, eseguire http://localhost:8080/services/v1.0/CommonStructureService.asmx/ListAllProjects su Team Foundation Server.
groupName | Specifica il nome del gruppo del progetto.
groupDescription | Facoltativo. Descrizione del gruppo del progetto.

espandi Note

Un gruppo con un ambito di progetto è fondamentalmente un gruppo di protezione per il progetto Team. I gruppi del progetto possono essere utilizzati per concedere autorizzazioni di lettura, scrittura e amministrative per soddisfare i requisiti di protezione dell'organizzazione.

espandi Esempio

Nell'esempio riportato di seguito viene creato un gruppo per il progetto specificato dall'URI:" vstfs:///Classification/TeamProject/088e66e2-714a-476d-8f04-db899712f92a". Il nome del gruppo è "Test Group" e la descrizione è "This group is for testing".
Immagine CopyCode Copia codice
TFSSecurity /gc "vstfs:///Classification/TeamProject/088e66e2-714a-476d-8f04-db899712f92a" "Test Group" "This group is for testing"

espandi Protezione

Per potere utilizzare il comando /gc dell'utilità della riga di comando TFSSecurity è necessario essere un amministratore di Team Foundation Server nel livello applicazione locale. Eseguire questo comando sul computer a livello applicazione locale.

espandi Vedere anche

Attività

Procedura: creare un gruppo a livello di server
Procedura: creare un gruppo di progetto Team

Altre risorse

Comandi dell'utilità della riga di comando TFSSecurity
Gruppi di un progetto Team
Gruppi predefiniti

piè di pagina


Comando /gun

 elenco a discesa elenco a discesa attivabile
Comando /gun
Vedere anche Esempio
comprimi tutto elenco a discesa

Utilizzare il comando /gun per rinominare un gruppo.

TFSSecurity /gun groupIdentity groupName

Parametri

Argomento | Descrizione
groupIdentity | Specifica l'identità del gruppo. Per ulteriori informazioni sugli identificatori di identità validi, vedere Identificatori di output e identità per TFSSecurity.
groupName | Specifica il nuovo nome del gruppo.

espandi Esempio

Il comando di esempio seguente assegna al gruppo "Coho Winery Education" il nuovo nome "Coho Winery Product Support".
Immagine CopyCode Copia codice
>tfssecurity /gun "Coho Winery Education" "Coho Winery Product Support"

espandi Protezione

Per potere utilizzare il comando /gun dell'utilità della riga di comando TFSSecurity è necessario essere un amministratore di Team Foundation Server nel livello applicazione locale. Eseguire questo comando sul computer a livello applicazione locale.

espandi Vedere anche

Attività

Procedura: rinominare un gruppo di un progetto Team
Procedura: rinominare un gruppo a livello di server

Concetti

Identificatori di output e identità per TFSSecurity

Altre risorse

Comandi dell'utilità della riga di comando TFSSecurity

piè di pagina


Comando /gud

 elenco a discesa elenco a discesa attivabile
Comando /gud
Vedere anche Esempio
comprimi tutto elenco a discesa

Utilizzare il comando /gud per modificare la descrizione di un gruppo.

TFSSecurity /gud groupIdentity groupDescription

Parametri

Argomento | Descrizione
groupIdentity | Specifica l'identità del gruppo. Per ulteriori informazioni sugli identificatori di identità validi, vedere Identificatori di output e identità per TFSSecurity.
groupDescription | Specifica la nuova descrizione per il gruppo.

espandi Esempio

Nell'esempio seguente viene associata la descrizione "Product support for the winery IT department" al gruppo "Coho Winery Product Support".
Immagine CopyCode Copia codice
>TFSSecurity /gud "Coho Winery Product Support" "Product support fort he winery IT department"

espandi Protezione

Per potere utilizzare il comando /gud dell'utilità della riga di comando TFSSecurity è necessario essere un amministratore di Team Foundation Server nel livello applicazione locale. Eseguire questo comando sul computer a livello applicazione locale.

espandi Vedere anche

Altre risorse

Comandi dell'utilità della riga di comando TFSSecurity
Gestione di gruppi
Gruppi predefiniti
Gruppi a livello di server
Gruppi di un progetto Team

piè di pagina


Comando /gd

 elenco a discesa elenco a discesa attivabile
Comando /gd
Vedere anche Esempio
comprimi tutto elenco a discesa

Utilizzare il comando /gd per eliminare un gruppo.

TFSSecurity /gd groupIdentity

Parametri

Argomento | Descrizione
groupIdentity | Specifica l'identità del gruppo. Per ulteriori informazioni sugli identificatori di identità validi, vedere Comandi dell'utilità della riga di comando TFSSecurity.

espandi Note

È anche possibile rimuovere gruppi in Team Explorer. Per ulteriori informazioni, vedere Procedura: rimuovere un gruppo a livello di server e Procedura: rimuovere un gruppo di un progetto Team.

espandi Esempio

Il seguente comando di esempio elimina il gruppo corrispondente all'identificatore di protezione (SID) S-1-5-21-2127521184-1604012920-1887927527-588340.
Immagine CopyCode Copia codice
>TFSSecurity /gd S-1-5-21-2127521184-1604012920-1887927527-588340

espandi Protezione

Per potere utilizzare il comando /gd dell'utilità della riga di comando TFSSecurity è necessario essere un amministratore di Team Foundation Server nel livello applicazione locale. Eseguire questo comando sul computer a livello applicazione locale.

espandi Vedere anche

Attività

Procedura: creare un gruppo a livello di server

Altre risorse

Comandi dell'utilità della riga di comando TFSSecurity
Gruppi di un progetto Team
Gruppi predefiniti

piè di pagina


Comando /g+

 elenco a discesa elenco a discesa attivabile
Comando /g+
Vedere anche Esempio
comprimi tutto elenco a discesa

Utilizzare il comando /g+ per aggiungere un utente o un altro gruppo a un gruppo esistente.

TFSSecurity /g+ groupIdentity memberIdentity

Parametri

Argomento | Descrizione
groupIdentity | Specifica l'identità del gruppo. Per ulteriori informazioni sugli identificatori di identità validi, vedere Identificatori di output e identità per TFSSecurity.
memberIdentity | Specifica l'identità del membro. Per ulteriori informazioni sugli identificatori di identità validi, vedere Identificatori di output e identità per TFSSecurity.

espandi Note

È inoltre possibile aggiungere utenti e gruppi a un gruppo esistente mediante Team Explorer. Per ulteriori informazioni, vedere Procedura: aggiungere utenti a un gruppo del server.

espandi Esempio

Il comando di esempio seguente aggiunge l'utente "ajesper" al gruppo globale Team Foundation Administrators.
Immagine CopyCode Copia codice
>TFSSecurity /g+ "Team Foundation Administrators" n:ajesper

espandi Protezione

Per potere utilizzare il comando /g+ dell'utilità della riga di comando TFSSecurity è necessario essere un amministratore di Team Foundation Server nel livello applicazione locale. Eseguire questo comando sul computer a livello applicazione locale.

espandi Vedere anche

Attività

Procedura: creare un gruppo a livello di server

Altre risorse

Comandi dell'utilità della riga di comando TFSSecurity
Gruppi di un progetto Team
Gruppi predefiniti

piè di pagina


Comando /g-

 elenco a discesa elenco a discesa attivabile
Comando /g-
Vedere anche Esempio
comprimi tutto elenco a discesa

Utilizzare il comando /g- per rimuovere un utente o un gruppo di utenti da un gruppo esistente.

TFSSecurity /g1 groupIdentity memberIdentity

Parametri

Argomento | Descrizione
groupIdentity | Specifica l'identità del gruppo. Per ulteriori informazioni sugli identificatori di identità validi, vedere Identificatori di output e identità per TFSSecurity.
memberIdentity | Specifica l'identità del membro. Per ulteriori informazioni sugli identificatori di identità validi, vedere Identificatori di output e identità per TFSSecurity.

espandi Note

È inoltre possibile aggiungere utenti e gruppi a un gruppo esistente mediante Team Explorer. Per ulteriori informazioni, vedere Procedura: rimuovere gli utenti da un gruppo di progetto Team, Procedura: rimuovere gli utenti da un gruppo predefinito o Procedura: rimuovere utenti dal gruppo a livello di server.

espandi Esempio

Il comando di esempio seguente rimuove l'utente "ajesper" dal gruppo globale Team Foundation Administrators.
Immagine CopyCode Copia codice
>TFSSecurity /g- "Team Foundation Administrators" n:ajesper

espandi Protezione

Per potere utilizzare il comando /g- dell'utilità della riga di comando TFSSecurity è necessario essere un amministratore di Team Foundation Server nel livello applicazione locale. Eseguire questo comando sul computer a livello applicazione locale.

espandi Vedere anche

Attività

Procedura: creare un gruppo a livello di server

Altre risorse

Comandi dell'utilità della riga di comando TFSSecurity
Gruppi di un progetto Team
Gruppi predefiniti

piè di pagina


Comando /m

 elenco a discesa elenco a discesa attivabile
Comando /m
Vedere anche Esempio
comprimi tutto elenco a discesa

Utilizzare il comando /m per verificare l'appartenenza ai gruppi per un gruppo o un utente specificato.

TFSSecurity /m groupIdentity [memberIdentity]

Parametri

Argomento | Descrizione
groupIdentity | Specifica l'identità del gruppo. Per ulteriori informazioni sugli identificatori di identità validi, vedere Identificatori di output e identità per TFSSecurity.
memberIdentity | Specifica l'identità del membro. Per ulteriori informazioni sugli identificatori di identità validi, vedere Identificatori di output e identità per TFSSecurity. Se si omette l'argomento memberIdentity, verrà utilizzato il contesto corrente.

espandi Note

Il comando /m dell'utilità della riga di comando TFSSecurity verifica sia l'appartenenza diretta che quella estesa.

espandi Esempio

Il comando di esempio seguente verifica se l'utente "ajesper" appartiene al gruppo globale Team Foundation Administrators.
Immagine CopyCode Copia codice
>TFSSecurity /m "Team Foundation Administrators" n:ajesper

espandi Protezione

Per potere utilizzare il comando /m dell'utilità della riga di comando TFSSecurity è necessario essere un amministratore di Team Foundation Server nel livello applicazione locale. Eseguire questo comando sul computer a livello applicazione locale.

espandi Vedere anche

Attività

Procedura: creare un gruppo a livello di server

Altre risorse

Comandi dell'utilità della riga di comando TFSSecurity
Gruppi di un progetto Team
Gruppi predefiniti

piè di pagina


Comando /a+

 elenco a discesa elenco a discesa attivabile
Comando /a+
Vedere anche
comprimi tutto elenco a discesa

Utilizzare il comando /a+ per aggiungere una voce di controllo di accesso.

TFSSecurity /a+ objectID actionID identity (ALLOW | DENY)

Parametri

Argomento Descrizione

objectID

URI dell'oggetto di controllo di accesso.

actionID

Nome dell'autorizzazione per cui è concesso o negato l'accesso. Per un elenco di ID validi, vedere Autorizzazioni per Team Foundation Server e Gruppi predefiniti, autorizzazioni e ruoli di Team Foundation Server.

identity

Specifica l'identità dell'utente o del gruppo. Per ulteriori informazioni sugli identificatori di identità, vedere Identificatori di output e identità per TFSSecurity.

  • ALLOW

    Al gruppo o all'utente viene concesso l'accesso all'operazione specificata in actionID.

  • DENY

    Al gruppo o all'utente viene negato l'accesso all'operazione specificata in actionID.

espandi Note

Le voci di controllo di accesso sono meccanismi di protezione che determinano le operazioni che un utente, un gruppo, un servizio o un computer è autorizzato a eseguire su un computer o un server.

espandi Protezione

Per potere utilizzare il comando /a+ dell'utilità della riga di comando TFSSecurity è necessario essere un amministratore di Team Foundation Server nel livello applicazione locale. Eseguire questo comando sul computer a livello applicazione locale.

espandi Vedere anche

Attività

Procedura: creare un gruppo a livello di server

Altre risorse

Comandi dell'utilità della riga di comando TFSSecurity
Gruppi di un progetto Team
Gruppi predefiniti

piè di pagina


Comando /a-

 elenco a discesa elenco a discesa attivabile
Comando /a-
Vedere anche
comprimi tutto elenco a discesa

Utilizzare il comando /a- per rimuovere una voce di controllo di accesso.

TFSSecurity /a- objectID actionID identity (ALLOW | DENY)

Parametri

Argomento Descrizione

objectID

URI dell'oggetto di controllo di accesso.

actionID

Nome dell'autorizzazione. Per un elenco di ID validi, vedere Autorizzazioni per Team Foundation Server e Gruppi predefiniti, autorizzazioni e ruoli di Team Foundation Server.

identity

Specifica l'identità dell'utente o del gruppo. Per ulteriori informazioni sugli identificatori di identità, vedere Identificatori di output e identità per TFSSecurity.

  • ALLOW

    Al gruppo o all'utente viene concesso l'accesso all'operazione specificata in actionID.

  • DENY

    Al gruppo o all'utente viene negato l'accesso all'operazione specificata in actionID.

espandi Note

Le voci di controllo di accesso sono meccanismi di protezione che determinano le operazioni che un utente, un gruppo, un servizio o un computer è autorizzato a eseguire su un computer o un server.

espandi Protezione

Per potere utilizzare il comando /a- dell'utilità della riga di comando TFSSecurity è necessario essere un amministratore di Team Foundation Server nel livello applicazione locale. Eseguire questo comando sul computer a livello applicazione locale.

espandi Vedere anche

Attività

Procedura: creare un gruppo a livello di server

Altre risorse

Comandi dell'utilità della riga di comando TFSSecurity
Gruppi di un progetto Team
Gruppi predefiniti

piè di pagina


Comando /acl

 elenco a discesa elenco a discesa attivabile
Comando /acl
Vedere anche
comprimi tutto elenco a discesa

Utilizzare il comando /acl per visualizzare l'elenco di controllo di accesso effettivo per un determinato oggetto.

TFSSecurity /acl objectID

Parametri

Argomento | Descrizione
objectID | URI dell'oggetto di controllo di accesso.

espandi Note

Le voci di controllo di accesso sono meccanismi di protezione che determinano le operazioni che un utente, un gruppo, un servizio o un computer è autorizzato a eseguire su un computer o un server.

espandi Protezione

Per potere utilizzare il comando /acl dell'utilità della riga di comando TFSSecurity è necessario essere un amministratore di Team Foundation Server nel livello applicazione locale. Eseguire questo comando sul computer a livello applicazione locale.

espandi Vedere anche

Attività

Procedura: creare un gruppo a livello di server

Altre risorse

Comandi dell'utilità della riga di comando TFSSecurity
Gruppi di un progetto Team
Gruppi predefiniti

piè di pagina


Comando TFSDeleteProject

 elenco a discesa elenco a discesa attivabile
Comando TFSDeleteProject
Vedere anche Esempio
comprimi tutto elenco a discesa

Utilizzare TFSDeleteProject per eliminare un progetto Team da Team System quando non è più necessario sul server Team Foundation Server.

Nota di avviso Attenzione

L'eliminazione di un progetto Team non può essere annullata. Tutti i dati del progetto Team sui server Team Foundation Server, Windows SharePoint Services, Controllo del codice sorgente Team Foundation e SQL Reporting Services verranno eliminati. I dati del progetto Team nel data warehouse non verranno invece eliminati.

L'utilità della riga di comando TFSDeleteProject si trova in <unità >\Programmi\Visual Studio8\Common7\IDE.

TFSDeleteproject [/q] [/TeamFoundationServer:servername] [/force] project name

Parametri

Argomento | Descrizione
project name | Il nome del progetto. Utilizzare le virgolette se il nome contiene degli spazi.
servername | Il nome del server. Utilizzare le virgolette se il nome contiene degli spazi.
Opzione | Descrizione
/q | Utilizzare la modalità non interattiva. Non richiedere la conferma all'utente.
/server: servername | Il nome de server Team Foundation Server in cui si trova il progetto Team. Questo parametro è obbligatorio in ambienti multiserver.
/force | Il programma dovrebbe continuare anche se alcune parti non possono essere eliminate.

espandi Note

È necessario essere connessi a Team Foundation Server prima di utilizzare TFSDeleteProject.

espandi Esempio

Il seguente comando elimina il progetto Team StoreFront dal server Team Foundation AdventureWorks1 e da Team Explorer.
Immagine CopyCode Copia codice
c:\Program Files\Microsoft Visual Studio 8\VC> TFSDeleteProject /AdventureWorks1 StoreFront

espandi Protezione

Per potere eliminare un progetto Team, è necessario essere un amministratore globale\TFS di Team Foundation Server o un amministratore del progetto Team che si sta eliminando.

espandi Vedere anche

Attività

Procedura: aggiungere o rimuovere un progetto Team

Altre risorse

Gestione delle autorizzazioni

piè di pagina


Comando TFSReg

 elenco a discesa elenco a discesa attivabile
Comando TFSReg
Vedere anche
comprimi tutto elenco a discesa

Utilizzare l'utilità TFSReg per modificare, aggiornare o eliminare tutte le voci nel file di configurazione delle connessioni in Team Foundation Server.

L'utilità della riga di comando TFSReg è disponibile in <drive>:\Programmi\Microsoft Visual Studio 2005 Team Foundation Server\Tools.

TFSReg [/D] ConfigFile TFSIntegrationDBServer TFSIntegrationDBName

Parametri

Argomento | Descrizione
ConfigFile | Nome del file di configurazione delle connessioni.
TFSIntegrationDBServer | Nome del database a livello dati.
TFSIntegrationDBName | Nome del database di integrazione.
Opzione | Descrizione
/D | Questa opzione viene utilizzata per eliminare tutte le voci nel file di configurazione delle connessioni.

espandi Note

Durante l'installazione i dati di registrazione devono essere inclusi nel database di integrazione di Team Foundation Server. A tal fine, utilizzare l'utilità della riga di comando TFSReg per accettare come input un file XML e il file di configurazione delle connessioni che rappresenta i dati di registrazione.

Le voci di registrazione possono essere aggiunte separatamente o insieme. TFSReg supporta sia operazioni di eliminazione che di aggiornamento. Il comportamento predefinito è l'aggiornamento delle voci di registrazione. L'opzione /D consente di eliminare voci dal file di configurazione.

È anche possibile utilizzare il file di configurazione delle connessioni per configurare un'estensione di Team Foundation Server. Ad esempio, è possibile aggiungere informazioni per aumentare le funzionalità del responsabile dei requisiti del progetto Team.

Per ottenere il file di configurazione delle connessioni, è necessario chiamare i servizi Web di registrazione e passare il valore null al metodo GetRegistrationEntries, come illustrato nell'esempio di codice riportato di seguito.

C# Immagine CopyCode Copia codice
using Microsoft.TeamFoundation.CoreServices.Services;
using Microsoft.TeamFoundation.CoreServices.Proxy;

{
    CoreServicesProxyServices bisServices =
 newCpreServicesProxyServices();
    string domain = "DomainCallerIsInterestedIn";
    IRegistration regProxy =
    (IRegistration) bisServices.GetProxy(domain,
 typeof(IRegistration));
    RegistrationEntry[] regEntries =
 regProxy.GetRegistrationEntries(null);
}

Di seguito è riportato un esempio di file di configurazione delle connessioni.

Immagine CopyCode Copia codice
<?xml version="1.0" encoding="utf-8" ?>
<RegistrationEntries>
  <RegistrationEntry>
    <Type>vstfs</Type>
    <ChangeType>NoChange</ChangeType>
    <ServiceInterfaces>
      <ServiceInterface>
        <Name>CommonStructure</Name>
        <Url>/Services/v1.0/CommonStructureService.asmx</Url>
    </ServiceInterface>
    <ServiceInterface>
      <Name>Eventing</Name>
      <Url>/Services/v1.0/EventService.asmx</Url>
    </ServiceInterface>
    <ServiceInterface>
      <Name>GroupSecurity</Name>
      <Url>/Services/v1.0/GroupSecurityService.asmx</Url>
    </ServiceInterface>
    <ServiceInterface>
      <Name>Authorization</Name>
      <Url>/Services/v1.0/AuthorizationService.asmx</Url>
    </ServiceInterface>
    <ServiceInterface>
      <Name>ProcessTemplate</Name>
      <Url>/Services/v1.0/ProcessTemplate.asmx</Url>
    </ServiceInterface>
    <ServiceInterface>
      <Name>RegistrationService</Name>
      <Url>/Services/v1.0/Registration.asmx</Url>
    </ServiceInterface>
    <ServiceInterface>
      <Name>ServerStatus</Name>
      <Url>/Services/v1.0/ServerStatus.asmx</Url>
    </ServiceInterface>
    <ServiceInterface>
      <Name>IProjectMaintenance</Name>
      <Url>/Services/v1.0/ProjectMaintenance.asmx</Url>
    </ServiceInterface>
    <ServiceInterface>
      <Name>ITeamSystemTask</Name>
      <Url>/Warehouse/v1.0/WarehouseController.asmx</Url>
    </ServiceInterface>
    <ServiceInterface>
      <Name>Warehouse</Name>
      <Url>/Warehouse/v1.0/WarehouseController.asmx</Url>
    </ServiceInterface>
  </ServiceInterfaces>
  <RegistrationExtendedAttributes>
    <RegistrationExtendedAttribute>
      <Name>ArtifactUriRoot</Name>
      <Value />
    </RegistrationExtendedAttribute>
    <RegistrationExtendedAttribute>
      <Name>ATMachineName</Name>
      <Value>ATMACHINE</Value>
    </RegistrationExtendedAttribute>
  </RegistrationExtendedAttributes>
  <Databases>
    <Database>
      <Name>BIS DB</Name>
      <DatabaseName>IntegrationDB</DatabaseName>
      <SQLServerName>DTMachineName</SQLServerName>
      <ConnectionString />
    </Database>
    <Database>
      <Name>BISDW DB</Name>
      <DatabaseName>ReportingDB</DatabaseName>
      <SQLServerName>DTMachineName</SQLServerName>
      <ConnectionString />
    </Database>
  </Databases>
  <EventTypes>
    <EventType>
      <Name>BranchMovedEvent</Name>
      <Schema />
    </EventType>
    <EventType>
      <Name>NodeCreatedEvent</Name>
      <Schema />
    </EventType>
    <EventType>
      <Name>NodePropertiesChangedEvent</Name>
      <Schema />
    </EventType>
    <EventType>
      <Name>NodeRenamedEvent</Name>
      <Schema />
    </EventType>
    <EventType>
      <Name>NodesDeletedEvent</Name>
      <Schema />
    </EventType>
    <EventType>
      <Name>ProjectCreatedEvent</Name>
      <Schema />
    </EventType>
    <EventType>
      <Name>ProjectDeletedEvent</Name>
      <Schema />
    </EventType>
  </EventTypes>
</RegistrationEntry>
<RegistrationEntry>
  <Type>Reports</Type>
  <ChangeType>NoChange</ChangeType>
  <ServiceInterfaces>
    <ServiceInterface>
      <Name>ReportsService</Name>
      <Url>http://DTMachineName/ReportServer/ReportService.asmx</Url>
    </ServiceInterface>
    <ServiceInterface>
      <Name>BaseReportsUrl</Name>
      <Url>http://DTMachineName/Reports</Url>
    </ServiceInterface>
    <ServiceInterface>
      <Name>DataSourceServer</Name>
      <Url>/RosettaService/ReportService.asmx</Url>
    </ServiceInterface>
    <ArtifactTypes>
      <ArtifactType>
         <Name>Report</Name>
        <OutboundLinkTypes>
          <OutboundLinkType>
            <Name />
            <TargetArtifactTypeToolName />
            <TargetArtifactTypeName />
          </OutboundLinkType>
        </OutboundLinkTypes>
      </ArtifactType>
    </ArtifactTypes>
  </ServiceInterfaces>
</RegistrationEntry>
<RegistrationEntry>
  <Type>Wss</Type>
  <ChangeType>NoChange</ChangeType>
  <ServiceInterfaces>
    <ServiceInterface>
      <Name>WssAdminService</Name>
      <Url>http://ATMACHINE:4554/_vti_adm/admin.asmx</Url>
    </ServiceInterface>
    <ServiceInterface>
      <Name>BaseServerUrl</Name>
      <Url>http://ATMACHINE</Url>
    </ServiceInterface>
    <ServiceInterface>
      <Name>BaseSiteUrl</Name>
      <Url>http://ATMACHINE/sites</Url>
    </ServiceInterface>
    <ServiceInterface>
      <Name>BaseSiteUnc</Name>
      <Url>\\ATMACHINE\sites</Url>
    </ServiceInterface>
  </ServiceInterfaces>
  <ArtifactTypes>
    <ArtifactType>
      <Name>ProjectDoc</Name>
      <OutboundLinkTypes>
        <OutboundLinkType>
          <Name />
          <TargetArtifactTypeToolName />
          <TargetArtifactTypeName />
        </OutboundLinkType>
      </OutboundLinkTypes>
    </ArtifactType>
  </ArtifactTypes>
 </RegistrationEntry>
</RegistrationEntries>

espandi Esempi

Il seguente codice di esempio elimina il file MyConfigFile.

Immagine CopyCode Copia codice
TFSReg [/D] MyConfigFile MyDataTier IntegrationDB

espandi Protezione

Per potere utilizzare l'utilità della riga di comando TFSReg, è necessario essere un amministratore globale di Team Foundation Server o un amministratore del progetto Team.

espandi Vedere anche

Altre risorse

Utilizzo degli strumenti della riga di comando di Team Foundation Server

piè di pagina


TFSFieldMapping

 elenco a discesa elenco a discesa attivabile
TFSFieldMapping
Vedere anche Esempio
comprimi tutto elenco a discesa

Utilizzare l'utilità TFSFieldMapping per modificare o personalizzare il file XML di mapping del progetto una volta creato il progetto Team. È ad esempio possibile creare nuovi tipi di elemento di lavoro o modificarne di esistenti assegnando nuovi attributi.

L'utilità della riga di comando TFSFieldMapping si trova in <unità >\Programmi\Visual Studio8\Common7\IDE.

TFSFieldMapping upload | download serverurl projectname filepath

Parametri

Argomento | Descrizione
serverurl | URL del server.
projectname | Nome del progetto Team.
Filepath | Nome e percorso del file di mapping.
Comando | Descrizione
Upload | download | Download o caricamento del file di mapping campi.

espandi Note

Di seguito sono riportate le operazioni necessarie per personalizzare il file di mapping campi:

  1. Scaricare il file di mapping campi utilizzando l'utilità della riga di comando TFSFieldMapping.

  2. Modificare il file di mapping campi cambiando i campi esistenti o aggiungendo campi e attributi personalizzati. Per ulteriori informazioni, vedere Procedura: modificare la modalità di mapping dei campi in Microsoft Project

  3. Caricare il file di mapping campi utilizzando l'utilità della riga di comando TFSFieldMapping.

espandi Esempio

Il seguente comando indica all'utilità TFSFieldMapping di scaricare il file di mapping MappingFile.xml.
Immagine CopyCode Copia codice
TFSFieldMapping download http://TeamFoundationServer AdventureWorks C:\MappingFile.xml

Nel comando sopra riportato:

  • http://TeamFoundationServer è l'URL del server.

  • AdventureWorks è il nome del progetto Team.

  • C:\MappingFile.xml è il nome e il percorso del file di mapping campi.

espandi Protezione

Per potere utilizzare l'utilità TFSFieldMapping, è necessario essere un amministratore globale\TFS di Team Foundation Server o un amministratore del progetto Team.

espandi Vedere anche

Attività

Procedura: modificare la modalità di mapping dei campi in Microsoft Project

Riferimenti

Mapping campi in Microsoft Project

Altre risorse

Gestione delle autorizzazioni
Utilizzo degli strumenti della riga di comando di Team Foundation Server

piè di pagina


witimport

 elenco a discesa elenco a discesa attivabile
witimport
Vedere anche
comprimi tutto elenco a discesa

Utilizzare il comando witimport per convalidare e importare un tipo di elemento di lavoro da un file XML in un progetto Team in un server Team Foundation Server. Se si tenta di importare un tipo di elemento di lavoro già esistente nel progetto Team specificato, viene visualizzato un messaggio di avviso in cui viene richiesto se si desidera sovrascrivere il tipo di elemento di lavoro esistente.

È possibile convalidare un tipo di elemento di lavoro senza importarlo utilizzando l'opzione /v.

L'utilità della riga di comando witimport si trova in <unità >\Programmi\Visual Studio8\Common7\IDE.

witimport /f filename /t tfs /p teamproject [/v] [/e encodingname]

Parametri

Parametro | Descrizione
/f filename | Il file di definizione XML contenente il tipo di elemento di lavoro da importare.
/t tfs | Il nome computer del server Team Foundation Server in cui verrà importato il tipo di elemento di lavoro o un URL completo per un server Team Foundation Server.
/p teamproject | Il progetto Team in cui il tipo di elemento di lavoro verrà importato. Il progetto Team deve essere presente sul server Team Foundation Server specificato dal parametro tfs.
/e Encodingname | Il nome di una codifica .NET Framework 2.0 che verrà utilizzata per importare il file XML contenente la definizione del tipo di elemento di lavoro. Se questo argomento non viene specificato, per impostazione predefinita, il comando witimport utilizza la codifica UTF-8.
/? | Visualizza la guida sensibile al contesto di witimport.
Opzione | Descrizione
/v | Convalida il file XML senza eseguire l'importazione.

espandi Esempi

Questo comando di esempio legge il file myworkitem.xml, convalida il tipo di elemento di lavoro in esso contenuto e importa l'elemento di lavoro convalidato nel progetto Team AdventureWorks sul server Team Foundation AdventureWorksServer. Nell'esempio l'importazione del tipo di elemento di lavoro viene eseguita utilizzando la codifica predefinita UTF-8.

Immagine CopyCode Copia codice
witimport /f myworkitem.xml /t AdventureWorksServer /p AdventureWorks

Nel seguente esempio viene illustrato un comando che utilizza un URL invece di un nome di server Team Foundation Server. Nell'esempio l'importazione del tipo di elemento di lavoro viene eseguita utilizzando la codifica predefinita UTF-8.

Immagine CopyCode Copia codice
witimport /f myworkitem.xml /t http://TFS:8080/bis/registration.asmx /p AdventureWorks

Il seguente comando di esempio esegue la convalida e l'importazione dell'elemento di lavoro utilizzando la codifica Unicode UTF-7.

Immagine CopyCode Copia codice
witimport /f myworkitem.xml /t AdventureWorksServer /p AdventureWorks /e utf-7

Nel seguente esempio la convalida del tipo di elemento di lavoro nel file myworkitem.xml viene eseguita senza importare il file. Nell'esempio la convalida del tipo di elemento di lavoro viene eseguita utilizzando la codifica predefinita UTF-8.

Immagine CopyCode Copia codice
witimport /f myworkitem.xml /t AdventureWorksServer /p AdventureWorks /v

espandi Vedere anche

Riferimenti

witexport

piè di pagina


witexport

 elenco a discesa elenco a discesa attivabile
witexport
Vedere anche
comprimi tutto elenco a discesa

Utilizzare il comando witexport per esportare una definizione XML per un tipo di elemento di lavoro da un server Team Foundation Server. È inoltre possibile utilizzare questo comando per visualizzare una definizione XML a schermo.

L'utilità della riga di comando witexport si trova in <unità >\Programmi\Visual Studio8\Common7\IDE.

witexport [/f filename] /t tfs /p teamproject /n witname [/exportgloballists] [/e encodingname]

Parametri

Parametro | Descrizione
/f filename | Il file di destinazione XML in cui verrà esportato il tipo di elemento di lavoro. Se questo parametro viene omesso, il tipo di elemento di lavoro viene esportato a schermo.
/t tfs | Il nome del computer del server Team Foundation Server da cui verrà esportato il tipo di elemento di lavoro o un URL completo per il server Team Foundation Server.
/p teamproject | Il progetto Team da cui verrà esportato il tipo di elemento di lavoro. Il progetto Team deve essere presente sul server Team Foundation Server specificato dal parametro tfs.
/n witname | Il nome del tipo di elemento di lavoro da esportare. Questo tipo deve essere presente nel progetto Team teamproject sul server Team Foundation Server tfs.
/e Encodingname | Il nome di una codifica .NET Framework 2.0 che verrà utilizzata per esportare il file XML contenente la definizione del tipo di elemento di lavoro. Se questo argomento non viene specificato, per impostazione predefinita, il comando witimport utilizza la codifica UTF-8.
/? | Visualizza la guida sensibile al contesto di witexport.
Opzione | Descrizione
/exportgloballists | Esporta le definizioni degli elenchi globali a cui fa riferimento il tipo di elemento di lavoro.

espandi Esempi

Questo comando di esempio esporta il tipo di elemento di lavoro myworkitem dal progetto Team AdventureWorks sul server Team Foundation AdventureWorksServer nel file myworkitems.xml. Nell'esempio l'esportazione del tipo di elemento di lavoro viene eseguita utilizzando la codifica predefinita UTF-8.

Immagine CopyCode Copia codice
witexport /f myworkitems.xml /t AdventureWorksServer /p AdventureWorks /n myworkitem

Nel seguente esempio viene illustrato un comando che utilizza un URL invece di un nome di server Team Foundation Server. Nell'esempio l'esportazione del tipo di elemento di lavoro viene eseguita utilizzando la codifica predefinita UTF-8.

Immagine CopyCode Copia codice
witexport /f myworkitems.xml /t http://TFS:8080/bis/registration.asmx /p AdventureWorks /n myworkitem

Il seguente comando di esempio esegue l'esportazione del tipo di elemento di lavoro utilizzando la codifica Unicode UTF-7.

Immagine CopyCode Copia codice
witexport /f myworkitems.xml /t AdventureWorksServer /p AdventureWorks /n myworkitem /exportgloballists

Il seguente comando di esempio esegue l'esportazione del tipo di elemento di lavoro e degli elenchi globali di riferimento. Nell'esempio l'esportazione del tipo di elemento di lavoro viene eseguita utilizzando la codifica predefinita UTF-8.

Immagine CopyCode Copia codice
witexport /f myworkitems.xml /t http://TFS:8080/bis/registration.asmx /p AdventureWorks /n myworkitem

Il seguente comando di esempio esegue l'esportazione del tipo di elemento di lavoro a schermo invece che in un file. Nell'esempio l'esportazione del tipo di elemento di lavoro viene eseguita utilizzando la codifica predefinita UTF-8.

Immagine CopyCode Copia codice
witexport /t http://TFS:8080/bis/registration.asmx /p AdventureWorks /n myworkitem

espandi Vedere anche

Riferimenti

witimport

piè di pagina


witfields

 elenco a discesa elenco a discesa attivabile
witfields
Vedere anche
comprimi tutto elenco a discesa

Utilizzare il comando witfields per amministrare i campi dei tipi di elemento di lavoro per Team Foundation Server.

Nota Nota

Gli amministratori del progetto Team potrebbero non essere in grado di amministrare tutti i campi per Team Foundation Server.

L'utilità della riga di comando witfields si trova in <unità >\Programmi\Visual Studio8\Common7\IDE.

witfields view /s:tfs [refname | /unused]
witfields rename /s:tfs refname newname
witfields report /s:tfs refname {dimension | detail | measure | disable}[:sum | :count | :distinctcount | :avg | :min | :max]
witfields delete /s:tfs refname
witfields rebuildcache /s:tfs
witfields help

Parametri

Parametro | Descrizione
/s: tfs | Il nome del computer del server Team Foundation Server per visualizzare o modificare i campi o un URL completo per un server Team Foundation Server.
refname | Il nome di riferimento del campo su cui eseguire il comando.
/unused | Visualizza tutti i campi che non vengono utilizzati dai tipi di elemento di lavoro sul server Team Foundation Server.
newname | Il nuovo nome descrittivo del campo.
dimension | Tipo di segnalabilità utilizzato per i campi di tipo numero intero, stringa o data e ora. Non deve essere specificato alcun attributo facoltativo.
detail | Tipo di segnalabilità utilizzato per i campi di tipo numero intero, numero doppio, stringa o data e ora. Non deve essere specificato alcun attributo facoltativo.
measure | Tipo di segnalabilità utilizzato per i campi di tipo numero intero o numero doppio. L'aggregazione predefinita è la somma.
disable | Non supportato in questa versione.
sum | Non supportato in questa versione.
count | Non supportato in questa versione.
distinctcount | Non supportato in questa versione.
avg | Non supportato in questa versione.
min | Non supportato in questa versione.
max | Non supportato in questa versione.
help | Visualizza la guida sensibile al contesto di witfields.
/? | Visualizza la guida sensibile al contesto di witfields.

espandi Esempi

Questo comando di esempio visualizza le informazioni per tutti i campi sul server Team Foundation Server AdventureWorksServer.

Immagine CopyCode Copia codice
witfields view /s:AdventureWorksServer

Il seguente comando di esempio visualizza le informazioni per il campo AdventureWorks.Field specificato.

Immagine CopyCode Copia codice
witfields view /s:AdventureWorksServer AdventureWorks.Field

Il seguente comando di esempio visualizza tutti i campi che non vengono utilizzati nel server Team Foundation Server Adventure Works.

Immagine CopyCode Copia codice
witfields view /s:AdventureWorksServer /unused

Il seguente comando di esempio sostituisce il nome descrittivo del campo di riferimento AdventureWorks.Field con NewFieldName.

Immagine CopyCode Copia codice
witfields rename /s:AdventureWorksServer AdventureWorks.Field NewFieldName

Il seguente comando imposta il tipo di segnalabilità del campo AdventureWorks.Field di tipo data e ora su dimensione.

Immagine CopyCode Copia codice
witfields report /s:AdventureWorksServer AdventureWorks.Field dimension

I dati di questo campo vengono immessi nel data warehouse e nel cubo in modo da potere essere utilizzati per filtrare i report.

Il seguente comando imposta il tipo di segnalabilità del campo AdventureWorks.Field di tipo numero intero su dettagli. I dati di questo campo vengono immessi nel data warehouse, ma non nel cubo.

Immagine CopyCode Copia codice
witfields report /s:AdventureWorksServer AdventureWorks.Field detail

Il seguente comando imposta il tipo di segnalabilità del campo AdventureWorks.Field di tipo intero doppio su misura. Tutte le misure vengono aggregate come somma.

Immagine CopyCode Copia codice
witfields report /s:AdventureWorksServer AdventureWorks.Field measure

Il seguente comando elimina il campo AdventureWorks.Field dal server Team Foundation Server AdventureWorksServer.

Immagine CopyCode Copia codice
witfields delete /s:AdventureWorksServer AdventureWorks.Field

Il seguente comando invalida la cache dei metadati per tutti i client sul server Team Foundation Server AdventureWorksServer. Le cache dei client verranno aggiornate alla successiva connessione al server.

Immagine CopyCode Copia codice
witfields rebuildcache /s:AdventureWorksServer

Il seguente comando visualizza la guida sensibile al contesto relativa all'utilità della riga di comando witfields.

Immagine CopyCode Copia codice
witfields help
witfields /?

espandi Vedere anche

Riferimenti

glexport
witimport
witexport

Altre risorse

Definizione dei campi dei tipi di elemento di lavoro

piè di pagina


glimport

 elenco a discesa elenco a discesa attivabile
glimport
Vedere anche
comprimi tutto elenco a discesa

Utilizzare il comando glimport per convalidare e importare gli elenchi globali da un file XML in un progetto Team di Team Foundation Server. Se si tenta di importare un elenco globale già esistente nel progetto Team specificato, viene visualizzato un avviso in cui viene richiesto se si desidera sovrascrivere l'elenco globale esistente. Se non è già presente un elenco globale, ne verrà creato uno nuovo.

L'utilità della riga di comando glimport si trova in <unità >\Programmi\Visual Studio8\Common7\IDE.

glimport /f filename /t tfs [/e encodingname]

Parametri

Parametro | Descrizione
/f filename | Il file di definizione XML degli elenchi globali di lavoro da importare.
/t tfs | Il nome del computer del server Team Foundation Server da cui verranno importati gli elenchi globali o un URL completo per un server Team Foundation Server.
/e encodingname | Il nome di una codifica .NET Framework 2.0 che verrà utilizzata per importare il file XML contenente gli elenchi globali. Se questo argomento non viene specificato, per impostazione predefinita, il comando glimport utilizza la codifica UTF-8.
/? | Visualizza la guida sensibile al contesto di glimport.

espandi Esempi

Questo comando di esempio legge il file mygloballists.xml, convalida gli elenchi globali in esso contenuti e importa gli elenchi globali convalidati sul server Team Foundation Server AdventureWorksServer. Nell'esempio l'importazione degli elenchi globali viene eseguita utilizzando la codifica predefinita UTF-8.

Immagine CopyCode Copia codice
glimport /f mygloballists.xml /t AdventureWorksServer

Nel seguente esempio viene illustrato un comando che utilizza un URL invece di un nome di server Team Foundation Server. Nell'esempio l'importazione degli elenchi globali viene eseguita utilizzando la codifica predefinita UTF-8 e la configurazione della porta 8080 predefinita.

Immagine CopyCode Copia codice
glimport /f mygloballists.xml /t http://TFS:8080

Il seguente comando di esempio esegue la convalida e l'importazione degli elenchi globali utilizzando la codifica Unicode UTF-7.

Immagine CopyCode Copia codice
glimport /f mygloballists.xml /t AdventureWorksServer /e utf-7

espandi Vedere anche

Riferimenti

glexport
witimport
witexport
witfields

piè di pagina


glexport

 elenco a discesa elenco a discesa attivabile
glexport
Vedere anche
comprimi tutto elenco a discesa

Utilizzare il comando glexport per esportare una definizione XML per elenchi globali da un server Team Foundation Server. È inoltre possibile utilizzare questo comando per visualizzare una definizione XML a schermo.

L'utilità della riga di comando glexport si trova in <unità >\Programmi\Visual Studio8\Common7\IDE.

glexport [/f filename] /t tfs [/e encodingname]

Parametri

Parametro | Descrizione
/f filename | Il file di destinazione XML in cui verranno esportati tutti gli elenchi globali in Team Foundation Server. Se questo parametro viene omesso, il file XML viene esportato a schermo.
/t tfs | Il nome del computer del server Team Foundation Server da cui verranno importati gli elenchi globali o un URL completo per un server Team Foundation Server.
/e encodingname | Il nome di una codifica .NET Framework 2.0 che verrà utilizzata per esportare il file XML contenente gli elenchi globali. Se questo argomento non viene specificato, per impostazione predefinita, il comando glexport utilizza la codifica UTF-8.
/? | Visualizza la guida sensibile al contesto di glexport.

espandi Esempi

Questo comando di esempio esporta gli elenchi globali mygloballists dal server Team Foundation Server AdventureWorksServer nel file mygloballists.xml. Nell'esempio l'esportazione degli elenchi globali viene eseguita utilizzando la codifica predefinita UTF-8.

Immagine CopyCode Copia codice
glexport /f mygloballists.xml /t AdventureWorksServer

Nel seguente esempio viene illustrato un comando che utilizza un URL invece di un nome di server Team Foundation Server. Nell'esempio l'esportazione degli elenchi globali viene eseguita utilizzando la codifica predefinita UTF-8 e la configurazione della porta 8080 predefinita.

Immagine CopyCode Copia codice
glexport /f mygloballists.xml /t http://TFS:8080

Il seguente comando di esempio esegue l'esportazione degli elenchi globali utilizzando la codifica Unicode UTF-7.

Immagine CopyCode Copia codice
glexport /f mygloballists.xml /t AdventureWorksServer /e utf-7

Il seguente comando di esempio esegue l'esportazione degli elenchi globali a schermo invece che in un file. Nell'esempio l'esportazione degli elenchi globali viene eseguita utilizzando la codifica predefinita UTF-8 e la configurazione della porta 8080 predefinita.

Immagine CopyCode Copia codice
glexport /t http://TFS:8080

espandi Vedere anche

Riferimenti

glimport
witimport
witexport
witfields

piè di pagina


SetupWarehouse

 elenco a discesa elenco a discesa attivabile
SetupWarehouse
Vedere anche Esempio
comprimi tutto elenco a discesa

Utilizzare il comando SetupWarehouse per rigenerare l'elaborazione analitica in linea (OLAP) o i database relazionali.

L'utilità della riga di comando SetupWarehouse è disponibile in <drive>:\Programmi\Microsoft Visual Studio 2005 Team Foundation Server\Tools.

SetupWarehouse [-v] [-o] -s ServerName -d Database -c ConfigFile -a AccountName -ra DataReaderAccountName [-l LogFile] [-mturl MidTierUrl] [-edt TeamBuildDbName]

Parametri

Opzione/Argomento | Descrizione
-v | Facoltativo. Questa opzione fornisce un output dettagliato. Se è specificata l'opzione -l, l'output viene scritto nel file di log.
-o | Facoltativo. Se si utilizza questa opzione, viene creato solo il database OLAP.
-s ServerName | Obbligatorio. Il nome del server.
-d Database | Obbligatorio. Il nome del database del data warehouse.
-c ConfigFile | Obbligatorio. Il fle XML di configurazione.
-a AccountName | Obbligatorio. Il nome dell'account di accesso.
-ra DataReaderAccountName | Obbligatorio. Il nome dell'account di lettura.
-l LogFile | Facoltativo. Il file di log per l'output.
-mturl MidTierUrl | Facoltativo. L'URL del dominio Team Foundation Server, ad esempio http://computer1:8080.
-edt TeamBuildDbName | Facoltativo. Il nome del database di Team Foundation Build.

espandi Note

Il data warehouse di Team Foundation Server comprende un database relazionale e un database OLAP. Setupwarehouse, lo strumento di configurazione del data warehouse del server Team Foundation, può essere utilizzato per rigenerare il database OLAP o entrambi i database. Ciò è utile negli scenari di backup/ripristino, ad esempio il ripristino di emergenza, lo spostamento di server, ecc. Per ulteriori informazioni, vedere Procedura: ripristinare i dati di Team Foundation Server.

espandi Esempio

Mediante il seguente comando è possibile rigenerare il cubo dei dati di Analysis Services dal database TFSWarehouse sottostante.
Immagine CopyCode Copia codice
      > setupwarehouse -o -s ServerName -d TfsWarehouse -c warehouseschema.xml -ra TFSReportAccount -a TFSServiceAccount

espandi Vedere anche

Riferimenti

Sintassi della riga di comando

Altre risorse

Gestione di dati
Utilizzo degli strumenti della riga di comando di Team Foundation Server

piè di pagina


Amministrazione del controllo del codice sorgente di Team Foundation

 elenco a discesa elenco a discesa attivabile
Amministrazione del controllo del codice sorgente di Team Foundation
Vedere anche
elenco a discesa

Negli argomenti di questa sezione viene descritto come completare attività comuni di amministrazione del controllo del codice sorgente mediante Team Foundation.

In questa sezione

Configurazione delle impostazioni del controllo del codice sorgente

Contiene informazioni amministrative sulla configurazione del controllo del codice sorgente in Visual Studio, sull'associazione dei tipi di file, sulla configurazione dei criteri di archiviazione e sulle impostazioni di estrazione.

Procedura: controllare l'accesso al controllo del codice sorgente di Team Foundation

Vengono illustrati i passaggi necessari per aggiungere utenti e gruppi a Controllo del codice sorgente Team Foundation.

Procedura: rimuovere l'accesso ai file del controllo del codice sorgente

Viene descritto come rimuovere l'accesso a un file sotto il controllo del codice sorgente.

Riferimenti

Riferimenti alla riga di comando del controllo del codice sorgente di Team Foundation

Sezioni correlate

Procedure dettagliate relative al controllo del codice sorgente di Team Foundation

Viene fornito un elenco di procedure dettagliate relative all'utilizzo del controllo del codice sorgente, alla personalizzazione dell'archiviazione del controllo del codice sorgente e all'utilizzo del controllo del codice sorgente dalla riga di comando.

Utilizzo del controllo del codice sorgente di Team Foundation

Viene fornito un elenco di argomenti di interesse per gli utenti di Controllo del codice sorgente Team Foundation.

Procedure dettagliate relative all'amministrazione di Team Foundation Server

Viene illustrato come impostare e amministrare Team Foundation Server.

Vedere anche

Altre risorse

Team Foundation - Documentazione


Configurazione delle impostazioni del controllo del codice sorgente

 elenco a discesa elenco a discesa attivabile
Configurazione delle impostazioni del controllo del codice sorgente
Vedere anche
elenco a discesa

Gli amministratori possono personalizzare Controllo del codice sorgente Team Foundation in base alle esigenze specifiche del team. Le opzioni configurabili trattate in questa sezione includono:

Client:

  • Personalizzazione dei tipi di file associati a Controllo del codice sorgente Team Foundation.

Server:

  • Personalizzazione delle note e dei criteri di archiviazione.

  • Personalizzazione delle impostazioni di estrazione.

In questa sezione

Procedura: configurare Visual Studio con il controllo del codice sorgente di Team Foundation

Viene descritta la procedura per la configurazione di Controllo del codice sorgente Team Foundation in Visual Studio.

Tipi di file

Viene illustrato come aggiungere, modificare e rimuovere estensioni di tipi di file associate alle archiviazioni di Controllo del codice sorgente Team Foundation.

Riferimenti

Riferimenti alla riga di comando del controllo del codice sorgente di Team Foundation

Vedere anche

Attività

Procedura dettagliata: personalizzazione dei criteri e delle note di archiviazione

Altre risorse

Amministrazione del controllo del codice sorgente di Team Foundation
Utilizzo del controllo del codice sorgente di Team Foundation


Procedura: configurare Visual Studio con il controllo del codice sorgente di Team Foundation

Procedura: configurare Visual Studio con il controllo del codice sorgente di Team Foundation
Vedere anche

Prima di utilizzare Controllo del codice sorgente Team Foundation, è necessario configurare Visual Studio per l'utilizzo di Controllo del codice sorgente Team Foundation, come descritto di seguito.

Per configurare Visual Studio per l'uso del controllo del codice sorgente di Team Foundation

  1. Scegliere Opzioni dal menu Strumenti.

  2. Nella finestra di dialogo Opzioni individuare Controllo del codice sorgente, espanderlo, quindi scegliere Selezione plug-in.

  3. Nella casella di riepilogo Plug-in del controllo del codice sorgente corrente fare clic su Visual Studio Team Foundation Server.

  4. Nel nodo Controllo del codice sorgente fare clic su Ambiente.

  5. In Impostazioni di ambiente controllo del codice sorgente fare clic su una delle seguenti opzioni:

    • Team Foundation Per impostazione predefinita vengono utilizzate le impostazioni di Visual Team Foundation.

    • Sviluppatore indipendente Vengono utilizzate le impostazioni adeguate a uno sviluppatore indipendente che non appartiene a un team.

    • Personalizza Vengono utilizzate impostazioni personalizzate.

    A seconda dell'opzione selezionata sono disponibili le seguenti opzioni:

    • Leggi i file all'apertura della soluzione o del progetto

    • Archivia i file alla chiusura della soluzione o del progetto

    • Visualizza comando di estrazione automatica nei menu

    • Mantieni gli elementi estratti durante l'archiviazione

  6. Nella casella di riepilogo Salvataggio della sezione Elementi archiviati selezionare l'azione che si desidera venga eseguita in corrispondenza del salvataggio di file e cartelle:

    • Estrai automaticamente (impostazione predefinita)

    • Richiedi estrazione

    • Salva con nome

  7. Nella casella di riepilogo Modifica fare clic sull'azione desiderata:

    • Richiedi estrazione

    • Richiedi estrazioni in modo esclusivo

    • Estrai automaticamente (impostazione predefinita)

    • Non eseguire operazioni

  8. È anche possibile selezionare l'opzione Consenti modifica degli elementi archiviati.

    Nota Nota

    Nel nodo Controllo del codice sorgente l'opzione Visual Studio Team Foundation consente di configurare i tipi di file con gli strumenti di confronto e unione. Per ulteriori informazioni, vedere Procedura: associare un tipo di file a uno strumento di unione e Procedura: associare un tipo di file con uno strumento di rilevamento delle differenze.

  9. Scegliere OK.

Protezione

Per completare questa procedura non è necessaria alcuna autorizzazione.

Vedere anche

Concetti

Introduzione a Team Foundation per gli utenti di Visual SourceSafe

Altre risorse

Amministrazione del controllo del codice sorgente di Team Foundation


Tipi di file

 elenco a discesa elenco a discesa attivabile
Tipi di file
Vedere anche
elenco a discesa

Le definizioni dei tipi di file consentono di personalizzare il modo in cui Controllo del codice sorgente Team Foundation elabora i file con determinate estensioni. La definizione di un tipo di file consente di disattivare i file con determinate estensioni per evitarne l'unione e quindi l'estrazione contemporanea da parte di più utenti.

Nota Nota

Per impostazione predefinita, le unioni e le estrazioni multiple di file sono disattivate.

Nota Nota

Le estrazioni multiple possono essere disattivate al livello del progetto Team.

Proprietà dei tipi di file

Una definizione di tipo di file di Team Foundation comprende tre proprietà. La proprietà più importante è Estensione, cioè l'identificatore univoco di un tipo di file.

Proprietà | Esempio
Nome | File di Visual Basic
Estensione | .vb
Consenti unione file e estrazioni multiple | Sì

In qualità di amministratore di Team Foundation, è possibile specificare che alcuni tipi di file, ad esempio i file di Microsoft Excel (XLS) binari per cui non esiste uno strumento di unione, non possono essere uniti quando vengono rilevati dei conflitti e possono essere estratti solo da un utente alla volta. A tal fine selezionare Consenti unione file e estrazioni multiple nella finestra di dialogo Modifica tipo di file. Per ulteriori informazioni, vedere Procedura: modificare l'associazione del tipo di file al controllo del codice sorgente di Team Foundation. Se per una data estensione non esiste un tipo di file, i file con tale estensione possono essere uniti.

Codifiche dei file

Oltre a queste proprietà dei tipi di file di base, Team Foundation gestisce anche la codifica per ciascun file nel server del controllo del codice sorgente. È possibile ignorare la codifica predefinita per un file nella finestra Proprietà del controllo del codice sorgente aperta in Esplora controllo del codice sorgente o mediante l'interfaccia della riga di comando. Per ulteriori informazioni, vedere Procedura: configurare il tipo di codifica del controllo del codice sorgente e Comando Checkout.

In questa sezione

Procedura: aggiungere l'associazione del tipo di file al controllo del codice sorgente di Team Foundation

Viene descritta la procedura per l'associazione di estensioni dei tipi di file alle archiviazioni del controllo del codice sorgente di Team Foundation.

Procedura: modificare l'associazione del tipo di file al controllo del codice sorgente di Team Foundation

Viene descritta la procedura per la modifica di estensioni dei tipi di file associate alle archiviazioni di Controllo del codice sorgente Team Foundation.

Procedura: rimuovere un tipo di file associato al controllo del codice sorgente di Team Foundation

Vengono descritte le procedure per la rimozione di un'associazione di un'estensione di tipo di file dalle archiviazioni di Controllo del codice sorgente Team Foundation.

Vedere anche

Concetti

Confronto tra file

Altre risorse

Risoluzione dei conflitti (controllo del codice sorgente di Team Foundation)


Procedura: aggiungere l'associazione del tipo di file al controllo del codice sorgente di Team Foundation

Procedura: aggiungere l'associazione del tipo di file al controllo del codice sorgente di Team Foundation
Vedere anche

Le definizioni dei tipi di file consentono di personalizzare il modo in cui il sistema di controllo del codice sorgente elabora i file con determinate estensioni. Mediante la definizione di un tipo di file è possibile controllare se le parole chiave interne dei file con un'estensione particolare possono essere espanse durante l'archiviazione e se più utenti possono modificare un file specifico contemporaneamente. Nella seguente procedura viene illustrato come aggiungere l'associazione dell'estensione di un tipo di file del controllo del codice sorgente.

Per aggiungere un'associazione di un tipo di file al controllo del codice sorgente

  1. Dal menu Team scegliere Impostazioni di Team Foundation Server, quindi selezionare Tipi di file controllo del codice sorgente. Nella finestra di dialogo Tipi di file sono visualizzate le estensioni di file correntemente associate al controllo del codice sorgente.

  2. Fare clic su Aggiungi.

  3. Nella casella di testo Nome della finestra di dialogo Aggiungi tipo di file digitare una descrizione per il nuovo tipo di file, ad esempio Documenti Word per aggiungere l'associazione dei file Microsoft Word al controllo del codice sorgente.

  4. Nella casella di testo Estensione file digitare l'estensione del tipo di file, ad esempio doc per i file Microsoft Word.

  5. È inoltre possibile selezionare la casella di controllo Consenti estrazioni multiple (selezionata per impostazione predefinita).

  6. Scegliere OK per tornare alla finestra di dialogo Tipi di file in cui sarà presente la nuova voce.

    Nota Suggerimento:

    È possibile specificare più estensioni di tipi di file da associare a un unico nome. Ad esempio è possibile aggiungere dot al nome Documenti Word immesso in questa procedura.

Protezione

È necessario disporre dell'autorizzazione AdminConfiguration per completare questa attività. Per ulteriori informazioni, vedere Autorizzazioni e privilegi di protezione del controllo del codice sorgente.

Vedere anche

Attività

Procedura: configurare le impostazioni di estrazione

Concetti

Tipi di file

Altre risorse

Configurazione delle impostazioni del controllo del codice sorgente


Procedura: modificare l'associazione del tipo di file al controllo del codice sorgente di Team Foundation

Procedura: modificare l'associazione del tipo di file al controllo del codice sorgente di Team Foundation
Vedere anche

Le definizioni dei tipi di file consentono di personalizzare il modo in cui il sistema Controllo del codice sorgente Team Foundation elabora i file con determinate estensioni. Mediante la definizione di un tipo di file è possibile controllare se le parole chiave interne dei file con un'estensione particolare possono essere espanse durante l'archiviazione e se più utenti possono modificare un file specifico contemporaneamente. Nella seguente procedura viene illustrato come modificare l'associazione dell'estensione di un tipo di file del controllo del codice sorgente.

Per modificare l'associazione di un tipo di file del controllo del codice sorgente

  1. Dal menu Team scegliere Impostazioni di Team Foundation Server, quindi selezionare Tipi di file controllo del codice sorgente. Nella finestra di dialogo Tipi di file sono visualizzate le estensioni di file correntemente associate al controllo del codice sorgente.

  2. Fare clic su Modifica.

  3. Nella casella di testo Nome della finestra di dialogo Modifica tipo di file digitare una descrizione per il nuovo tipo di file, ad esempio Documenti Word per aggiungere l'associazione dei file Microsoft Word al controllo del codice sorgente.

  4. Nella casella di testo Estensione file digitare l'estensione del tipo di file, ad esempio doc per i file Microsoft Word.

  5. È inoltre possibile selezionare la casella di controllo Consenti estrazioni multiple (selezionata per impostazione predefinita).

  6. Scegliere OK per tornare alla finestra di dialogo Tipi di file in cui sarà presente la nuova voce.

    Nota Suggerimento:

    È possibile specificare più associazioni di estensioni di tipi di file con un unico nome. Ad esempio è possibile aggiungere dot al nome Documenti Word immesso in precedenza.

Protezione

È necessario disporre dell'autorizzazione AdminConfiguration per completare questa attività. Per ulteriori informazioni, vedere Autorizzazioni e privilegi di protezione del controllo del codice sorgente.

Vedere anche

Attività

Procedura: configurare le impostazioni di estrazione

Concetti

Tipi di file

Altre risorse

Configurazione delle impostazioni del controllo del codice sorgente


Procedura: rimuovere un tipo di file associato al controllo del codice sorgente di Team Foundation

Procedura: rimuovere un tipo di file associato al controllo del codice sorgente di Team Foundation
Vedere anche

Le definizioni dei tipi di file consentono di personalizzare il modo in cui il sistema del controllo del codice sorgente gestisce i file con determinate estensioni. Mediante la definizione di un tipo di file è possibile controllare se le parole chiave interne dei file con un'estensione particolare possono essere espanse durante l'archiviazione e se più utenti possono modificare un file specifico contemporaneamente. Per informazioni sull'aggiunta di associazioni di tipi di file al controllo del codice sorgente, vedere Procedura: aggiungere l'associazione del tipo di file al controllo del codice sorgente di Team Foundation. Nella seguente procedura viene illustrato come rimuovere l'estensione di un tipo di file associata al controllo del codice sorgente.

Per rimuovere un tipo di file associato al controllo del codice sorgente

  1. Dal menu Team scegliere Impostazioni di Team Foundation Server, quindi selezionare Tipi di file controllo del codice sorgente.

    Verrà visualizzata la finestra di dialogo Tipi di file contenente un elenco delle estensioni dei nomi di file correntemente associate al controllo del codice sorgente.

  2. Evidenziare l'estensione del tipo di file da rimuovere, quindi fare clic su Rimuovi.

    La voce viene eliminata e non apparirà più nella finestra di dialogo Tipi di file.

  3. Scegliere OK.

Protezione

È necessario disporre dell'autorizzazione AdminConfiguration per completare questa attività. Per ulteriori informazioni, vedere Autorizzazioni e privilegi di protezione del controllo del codice sorgente.

Vedere anche

Concetti

Tipi di file

Altre risorse

Configurazione delle impostazioni del controllo del codice sorgente


Procedura: controllare l'accesso al controllo del codice sorgente di Team Foundation

Procedura: controllare l'accesso al controllo del codice sorgente di Team Foundation
Vedere anche

Controllo del codice sorgente Team Foundation supporta la concessione di autorizzazioni di controllo di accesso a gruppi Windows, utenti Windows e gruppi Team Foundation. Le autorizzazioni possono essere ereditate dalla cartella contenente o dichiarate esplicitamente.

Le impostazioni delle autorizzazioni vengono specificate mediante le azioni Concedi o Nega. La negazione sovrascrive sempre la concessione, anche nel caso in cui l'azione Nega venga ereditata e l'azione Concedi venga definita esplicitamente.

Per impostare autorizzazioni per utenti e gruppi

  1. Scegliere Altre finestre dal menu Visualizza di Visual Studio, quindi fare clic su Esplora controllo del codice sorgente.

  2. Fare clic con il pulsante destro del mouse sulla cartella o sul file per cui si desidera impostare le autorizzazioni e scegliere Proprietà.

  3. Nella finestra di dialogo Proprietà fare clic sulla scheda Protezione.

  4. Nell'area Aggiungi utenti e gruppi selezionare Gruppo Team Foundation Server per impostare le autorizzazioni per un gruppo Team Foundation Server, altrimenti selezionare Utente o gruppo Windows.

  5. Scegliere Aggiungi.

    1. Se è stato selezionato Gruppo Team Foundation Server, viene visualizzata la finestra di dialogo Aggiungi gruppo. Selezionare un gruppo e scegliere OK. Il gruppo per cui si desidera impostare le autorizzazioni viene visualizzato nella casella Utenti e gruppi della finestra di dialogo Proprietà.

    2. Se è stato selezionato Utente o gruppo Windows, viene visualizzata la finestra di dialogo Selezione utenti o gruppi. Immettere l'utente o il gruppo per cui si desidera impostare le autorizzazioni e scegliere OK. L'utente o il gruppo viene visualizzato nella casella Utenti e gruppi della finestra di dialogo Proprietà.

      Nota Nota

      Per visualizzare un suggerimento contenente informazioni sui controlli presenti nella finestra di dialogo Selezione utenti o gruppi, fare clic sull'icona ? nella barra del titolo, posizionare il cursore sul controllo e fare clic su di esso.

  6. Nella casella Utenti e gruppi della finestra di dialogo Proprietà selezionare l'utente o il gruppo per cui si desidera impostare le autorizzazioni.

  7. Nella casella Autorizzazione selezionare Consenti o Nega per ciascuna autorizzazione.

    Nota Nota

    Se è stata selezionata la casella di controllo Eredita impostazioni di protezione, vengono automaticamente selezionate le impostazioni di protezione della cartella contenente, che possono essere sovrascritte selezionando o deselezionando la casella di controllo Nega.

  8. Scegliere OK per chiudere la finestra di dialogo Proprietà.

Protezione

È necessario disporre dell'autorizzazione AdminProjectRights per completare questa attività. Per ulteriori informazioni, vedere Autorizzazioni e privilegi di protezione del controllo del codice sorgente.

Vedere anche

Altre risorse

Amministrazione del controllo del codice sorgente di Team Foundation


Procedura: rimuovere l'accesso ai file del controllo del codice sorgente

Procedura: rimuovere l'accesso ai file del controllo del codice sorgente
Vedere anche

In qualità di amministratore di Team Foundation, è possibile che sia necessario rimuovere l'accesso a un file che si trova sotto il controllo del codice sorgente. Ad esempio, qualcuno potrebbe archiviare un file infetto da un virus.

Nella seguente procedura vengono forniti i dettagli per la rimozione del file mediante l'interfaccia utente o l'utilità della riga di comando tf. Per rimuovere l'accesso, è necessario sovrascrivere la versione non valida con una valida e aggiungere la versione valida al database. L'impostazione delle autorizzazioni di lettura/scrittura consente di impedire al file di venire visualizzato in Esplora controllo del codice sorgente.

Nota Nota

Sebbene il file rimanga nel database come eliminato, non rimuovere la riga del file direttamente dal database per evitare risultati imprevisti.

Per rimuovere l'accesso a un file sotto il controllo del codice sorgente

  1. Scegliere Altre finestre dal menu Visualizza di Visual Studio, quindi fare clic su Esplora controllo del codice sorgente.

  2. Individuare ed estrarre il file che si desidera rimuovere.

  3. Nella finestra di dialogo Estrai verificare che sia selezionato il file corretto, quindi fare clic su Estrai tra le opzioni Selezionare il tipo di blocco.

  4. Creare un nuovo file e salvarlo nello stesso percorso e con lo stesso nome ed estensione del file di cui si desidera sovrascrivere l'ultima versione.

  5. Archiviare il file.

    Nota Nota

    Assicurarsi che gli utenti client che dispongono di una copia locale del file sul computer rimuovano qualsiasi riferimento al file in Esplora soluzioni di Visual Studio e rimuovano manualmente qualsiasi copia del file dal computer client.

  6. Nella finestra Proprietà del file selezionare la scheda Protezione, quindi deselezionare la casella Eredita impostazioni di protezione.

  7. Fare clic su Nega per ciascun utente e gruppo eccetto Administrators.

  8. Scegliere OK per rimuovere il file da Esplora controllo del codice sorgente.

Per rimuovere l'accesso al file dalla riga di comando

  1. Aprire la riga di comando e utilizzare il comando CheckOut dell'utilità tf per ottenere una versione abilitata alla scrittura del file che si desidera rimuovere. Ad esempio:

    tf checkout myfile.cs

  2. Creare un nuovo file e sovrascrivere il file che si desidera rimuovere.

  3. Utilizzare il comando CheckIn per sostituire la versione del file nel database.

    Ad esempio, è possibile aggiungere un commento per spiegare che si è sovrascritto il file e che le autorizzazioni sono negate.

    tf checkin /comment:"Overwrote bad file and denied permissions."

  4. Utilizzare il comando permission insieme all'opzione /deny per modificare le autorizzazioni relative al file per un utente o un gruppo.

    Ad esempio, è possibile utilizzare il seguente comando per negare le autorizzazioni di lettura del file ai gruppi del dominio ADATUM.

    tf permission /inherit:no myfile.cs

    tf permission /deny:read myfile.cs /group:ADATAUM\Group1, ADATAUM\Group2 myfile.cs

Protezione

È necessario disporre delle autorizzazioni di amministratore per completare queste procedure.

Vedere anche

Attività

Procedura: controllare l'accesso al controllo del codice sorgente di Team Foundation


Amministrazione di Team Foundation Build

 elenco a discesa elenco a discesa attivabile
Amministrazione di Team Foundation Build
Vedere anche
elenco a discesa

Gli amministratori di Team Foundation Build creano i tipi di generazione per creare una soluzione o un insieme di soluzioni in un ambiente distribuito. Inoltre i tipi di generazione consentono la generazione di report, l'esecuzione di test e l'utilizzo di altre impostazioni personalizzate descritte in Gestione delle generazioni con Team Foundation Build.

Gli amministratori possono anche configurare i computer di generazione.

Per informazioni generali sull'architettura di Team Foundation Server, vedere Cenni preliminari su Team Foundation Build.

In questa sezione

Impostazione di un computer di generazione

In questa sezione vengono descritti i prerequisiti e il processo di installazione necessari per un computer di generazione designato in un tipo di generazione.

Utilizzo dei tipi di generazione in Team Build

Contiene argomenti che descrivono le procedure di creazione, modifica ed eliminazione di tipi di generazione in Team Foundation Build.

Estensione di Team Foundation Build

Viene illustrato come personalizzare Team Foundation Build mediante attività di generazione personalizzate.

Riferimenti

Riferimenti a Team Foundation Build

Sezioni correlate

Procedure dettagliate relative a Team Foundation Build

Vengono fornite procedure dettagliate relative alla creazione di tipi di generazione, all'esecuzione di tipi di generazione e alla visualizzazione di report sui tipi di generazione.

Gestione delle generazioni con Team Foundation Build

Contiene gli argomenti destinati agli utenti di Team Foundation Build, comprese le procedure di esecuzione dei tipi di generazione, di utilizzo di Team Build Browser e di creazione dei report di generazione.

Procedure dettagliate relative all'amministrazione di Team Foundation Server

Viene illustrato come impostare e amministrare Team Foundation Server.

Risorse esterne

MSDN Online

Vedere anche

Concetti

Autorizzazioni e privilegi di protezione di Team Build

Altre risorse

Team Foundation - Documentazione


Impostazione di un computer di generazione

 elenco a discesa elenco a discesa attivabile
Impostazione di un computer di generazione
Vedere anche
elenco a discesa

Per designare un computer di generazione specifico è necessario impostare tipi di generazione in Team Foundation Build. Per potere utilizzare un computer come computer di generazione, occorre impostarlo in modo appropriato. In questa sezione vengono descritti l'installazione e i prerequisiti per i computer di generazione.

In questa sezione

Procedura: impostare un computer di generazione

Vengono descritti i passaggi necessari per impostare un computer di generazione da utilizzare in associazione a un tipo di generazione.

Procedura: disinstallare Team Build da un computer di generazione

Viene illustrato come rimuovere Team Foundation Build da un computer di generazione utilizzando l'applet di aggiunta/rimozione programmi del Pannello di controllo.

Riferimenti

Riferimenti a Team Foundation Build

Sezioni correlate

Procedure dettagliate relative a Team Foundation Build

Vengono fornite procedure dettagliate relative alla creazione di tipi di generazione, all'esecuzione di tipi di generazione e alla visualizzazione di report sui tipi di generazione.

Vedere anche

Altre risorse

Utilizzo dei tipi di generazione in Team Build


Procedura: impostare un computer di generazione

Procedura: impostare un computer di generazione

Con Team Foundation Build è possibile utilizzare un computer designato per eseguire le generazioni. A questo scopo è necessario installare il servizio Team Build sul computer designato come installazione distinta dal livello applicazione, dati o client Visual Studio di Team System. È possibile designare un computer distinto o installare il computer di generazione sul computer client.

Durante il processo di installazione vengono installati l'SDK .NET e i componenti di Team Foundation Build appropriati. Uno dei componenti più importanti installati è il servizio Team Build. Questo servizio richiede autorizzazioni speciali. Le seguenti procedure illustrano i passaggi da seguire per installare Team Foundation Build su un computer di generazione designato.

Per impostare un computer di generazione

  1. Sul computer per cui si desidera installare il servizio Team Build eseguire setup.exe per avviare l'installazione del computer di generazione, quindi attenersi alle istruzioni visualizzate.

    Nota Nota

    Il file setup.exe e i file associati si trovano sul CD di installazione di Team Foundation Server, nella cartella \tb.

  2. Quando durante l'installazione guidata vengono richieste le credenziali di accesso, immettere un account di dominio o di gruppo di lavoro valido.

    Nota Nota

    Per generare un progetto Team, aggiungere l'account fornito sopra al gruppo Build Services del progetto. Per ulteriori informazioni, vedere Procedura: definire le autorizzazioni relative al computer per la generazione Team.

  3. Al termine dell'installazione scegliere OK.

Protezione

In questo contesto è applicabile l'autorizzazione Scrivi nell'archivio operativo delle generazioni. Per ulteriori informazioni, vedere Autorizzazioni e privilegi di protezione di Team Build.

Vedere anche

Attività

Procedura: disinstallare Team Build da un computer di generazione


Procedura: disinstallare Team Build da un computer di generazione

Procedura: disinstallare Team Build da un computer di generazione
Vedere anche

Le seguenti procedure illustrano i passaggi da seguire per disinstallare Team Foundation Build da un computer di generazione.

Per disinstallare Team Foundation Build da un computer di generazione

  1. Sul computer di generazione aprire il Pannello di controllo e selezionare Installazione applicazioni.

  2. Individuare la voce Visual Studio Team Foundation - Team Build nell'elenco dei programmi installati e fare clic su Rimuovi.

    In questo modo verranno eliminati completamente tutti i file e le voci di registro.

Vedere anche

Altre risorse

Impostazione di un computer di generazione


Utilizzo dei tipi di generazione in Team Build

 elenco a discesa elenco a discesa attivabile
Utilizzo dei tipi di generazione in Team Build
Vedere anche
elenco a discesa

Negli argomenti di questa sezione vengono descritte le procedure di creazione e modifica dei tipi di generazione in Team Foundation Build.

In Team Foundation Build vengono utilizzati i tipi di generazione per gestire le condizioni in base a cui viene generata una soluzione o un insieme di soluzioni. Per creare e modificare tipi di generazione, utilizzare la Creazione guidata nuovo tipo di generazione Team Foundation, che include le seguenti opzioni di configurazione:

  • Area di lavoro di generazione

    Utilizzare questa impostazione per definire le soluzioni da generare all'interno del tipo di generazione. Per ciascuna area di lavoro esiste un proprietario determinato che l'ha creata. In modo specifico, un'area di lavoro definisce la parte della struttura del codice sorgente che verrà generata In particolare, il codice sorgente visibile da una determinata area di lavoro verrà generato sul computer di generazione.

  • Computer di generazione

    Utilizzare questa impostazione per specificare il computer su cui viene eseguita la generazione.

  • Destinazione finale generazione

    Utilizzare questa impostazione per specificare una condivisione di rete come destinazione dell'output della generazione. L'output di ciascuna generazione verrà rilasciato in una directory distinta della condivisione.

  • Configurazione

    Utilizzare questa impostazione per specificare la configurazione e la piattaforma, ad esempio debug, x86 o x86 finale.

  • Istruzioni di generazione

    Utilizzare questa impostazione per specificare istruzioni aggiuntive, ad esempio l'analisi del codice, da eseguire nel processo di generazione.

In questa sezione

Procedura: creare un nuovo tipo di generazione

Viene descritta la procedura per la creazione e la configurazione di un nuovo tipo di generazione per Team Foundation Build.

Procedura: configurare i test con i tipi di generazione

Viene descritto come modificare i tipi di generazione e i progetti per sfruttare le funzionalità di test di Team Foundation Build.

Test di siti Web e di servizi Web in un ambiente di team

Vengono fornite informazioni aggiuntive sull'utilizzo dei test in Team Foundation Build.

Procedura: definire le autorizzazioni relative al computer per la generazione Team

Viene descritto come definire le autorizzazioni per il computer di generazione Team Foundation per l'esecuzione delle generazioni.

Procedura: modificare un tipo di generazione

Viene descritto come modificare un file XML sottostante un tipo di generazione, comprese alcune impostazioni personalizzate.

Procedura: aggiornare i tipi di generazione sui progetti Team diramati

Viene descritto come modificare i tipi di generazione in una diramazione appena definita in modo che vengano generati correttamente.

Procedura: eliminare un tipo di generazione

Viene descritto come eliminare un tipo di generazione non più utilizzato.

Riferimenti

Riferimenti a Team Foundation Build

Sezioni correlate

Esecuzione delle generazioni in Team Foundation Build

Contiene argomenti in cui viene descritto come eseguire generazioni in Team Foundation Build, comprese generazioni standard, locali e pianificate.

Informazioni sul browser di Team Build

Viene descritta la funzionalità di Team Build Browser e vengono presentati argomenti che illustrano come visualizzare, interpretare e modificare lo stato dei tipi di generazione e i report creati da un tipo di generazione in Team Foundation Build.

Procedure dettagliate relative a Team Foundation Build

Vengono fornite procedure dettagliate relative alla creazione di tipi di generazione, all'esecuzione di tipi di generazione e alla visualizzazione di report sui tipi di generazione.

Amministrazione di Team Foundation Build

Vengono elencati argomenti destinati agli amministratori di Team Foundation Build.

Vedere anche

Attività

Procedura dettagliata: creazione di un tipo di generazione in Team Foundation Build


Procedura: creare un nuovo tipo di generazione

Procedura: creare un nuovo tipo di generazione

Team Foundation Build utilizza i tipi di generazione per configurare le condizioni in base a cui viene generata una soluzione o un insieme di soluzioni in un progetto Team. Per eseguire una generazione, è necessario creare un nuovo tipo di generazione o utilizzarne uno esistente.

  • Quando si creano tipi di generazione mediante Creazione guidata nuovo tipo di generazione Team Foundation, è possibile impostare diverse opzioni, tra cui la numerazione delle generazioni, le operazioni di generazione, la pulizia della directory di generazione e la sincronizzazione delle origini. In Team Foundation non è disponibile alcuna interfaccia utente per modificare queste opzioni dopo che sono state definite. Per aggiungere operazioni di generazione personalizzate o modificare il tipo di generazione, è possibile modificare il file XML mediante un editor XML. Per ulteriori informazioni, vedere Procedura: modificare un tipo di generazione. Per sovrascrivere le opzioni predefinite, modificare il file del tipo di generazione nel formato MSBuild.

  • Per personalizzare le operazioni di generazione, modificare il file Microsoft.TeamBuild.targets.

  • Per rimuovere tipi di generazione, eliminare i file direttamente dal controllo del codice sorgente. Per ulteriori informazioni, vedere Procedura: eliminare un tipo di generazione.

Per creare tipi di generazione, utilizzare Creazione guidata nuovo tipo di generazione Team Foundation, come descritto nella procedura seguente.

Per creare un nuovo tipo di generazione

  1. In Team Explorer selezionare il progetto per cui si desidera creare un nuovo tipo di generazione.

  2. Scegliere Nuovo tipo di generazione Team Foundation dal menu Genera.

    Verrà visualizzata Creazione guidata nuovo tipo di generazione Team Foundation.

  3. In Creazione guidata nuovo tipo di generazione Team Foundation specificare il nome da associare con il tipo di generazione nella casella di testo Specificare il nome da assegnare al tipo di generazione Team Foundation.

    Verrà verificato se il nome immesso esiste già per un tipo di generazione definito. Se il nome esiste, viene richiesto di immettere un nome univoco. Il nome del tipo di generazione deve essere un nome di file Windows valido e non può contenere il carattere $.

    Aggiungere una descrizione appropriata nella casella di testo Descrizione e scegliere Avanti per continuare.

    Verrà visualizzata la finestra Selezionare e ordinare soluzioni da generare.

    Nota Suggerimento:

    Il pulsante Avanti è abilitato solo quando tutti i campi obbligatori sono stati compilati correttamente.

  4. Nella casella di riepilogo a discesa Specificare l'area di lavoro da cui selezionare le soluzioni da generare selezionare l'area di lavoro che contiene le soluzioni che si desidera includere nel tipo di generazione. Vengono indicati il nome dell'area di lavoro e l'utente che l'ha creata.

  5. Nell'elenco Seleziona e ordina le soluzioni selezionare una o più soluzioni da aggiungere al tipo di generazione. Utilizzando l'opzione Seleziona tutto, è possibile selezionare una soluzione, più soluzioni o tutte le soluzioni.

  6. Utilizzare i tasti di direzione a destra dell'elenco per selezionare le soluzioni e modificarne la posizione nell'ordine di generazione. Le soluzioni vengono create in ordine, a partire dall'inizio dell'elenco.

    Nota di avviso Attenzione

    Prestare attenzione alle dipendenze tra le soluzioni quando si specifica l'ordine di generazione. Ad esempio, se Soluzione 2 ha una dipendenza su Soluzione 1, impostare Soluzione 1 in modo che venga generata prima di Soluzione 2. Dopo avere selezionato le soluzioni desiderate e avere specificato l'ordine di generazione, scegliere Avanti. Verrà visualizzata la finestra Selezionare configurazioni da generare.

    Nota Nota

    Se viene eseguita un'operazione di diramazione, è necessario modificare i tipi di generazione nella nuova diramazione per specificare i percorsi corretti. Per ulteriori informazioni, vedere Procedura: aggiornare i tipi di generazione sui progetti Team diramati e Diramazioni e unione del controllo del codice sorgente di Team Foundation.

  7. Nella griglia sotto Specificare le configurazioni da generare selezionare la configurazione e le piattaforme desiderate da includere nella generazione. La configurazione di generazione indica la configurazione e la piattaforma desiderate, ad esempio Finale e Qualsiasi CPU.

    Nota Nota

    Se in Gestione configurazione un progetto utilizza un'impostazione di configurazione diversa da quella specificata in Creazione guidata nuovo tipo di generazione Team Foundation, il progetto viene ignorato.

    Nota Nota

    Se si crea un tipo di generazione per progetti Web, selezionare Piattaforme miste.

  8. Una volta effettuate le selezioni desiderate per la configurazione di generazione, scegliere Avanti.

    Verrà visualizzata la finestra Selezionare posizione di generazione.

  9. Nella casella di testo Specificare il computer in cui generare le soluzioni selezionate digitare il nome del computer, ad esempio MachineA_Lab1.

  10. Nella casella di testo Directory di generazione nel computer selezionato digitare la directory in cui si desidera eseguire la generazione. Si tratta di una directory locale sul computer di generazione, ad esempio, D:\AdventureWorks\TourPackeServices\.

    Nota di avviso Attenzione

    Quando si seleziona una directory di generazione, accertarsi che sia disponibile spazio sufficiente per l'operazione, altrimenti la generazione non riuscirà.

    Nota Nota

    La directory di generazione non può essere una directory mappata.

  11. Nella casella di testo Destinazione finale digitare il percorso UNC (\\server\condivisione) o utilizzare Sfoglia per selezionare una destinazione finale, ossia il percorso in cui vengono aggiunti i file di log e binari al termine della generazione.

    • Per impostazione predefinita, la directory finale non viene creata automaticamente come condivisione e pertanto non può essere utilizzata per pubblicare generazioni e risultati di test. È necessario definire manualmente una condivisione. Per impedire ad utenti non autorizzati di eliminare le destinazioni di generazione, si consiglia di non definire autorizzazioni di eliminazione sulla condivisione.

    • Ogni generazione generata viene rilasciata in una directory distinta. Assicurarsi che l'account configurato per il computer di generazione disponga dell'accesso di scrittura al percorso UNC. L'autorizzazione di scrittura è inoltre necessaria per l'account utilizzato dal livello applicazione.

    Nota di avviso Attenzione

    La copia dei file di log e binari generati nella directory finale potrebbe non essere sicura. È però possibile estendere il tipo di generazione con un'attività MSBuild personalizzata che copia i file in maniera protetta nella directory finale. Per ulteriori informazioni sull'estensione di un tipo di generazione, vedere Procedura dettagliata: estensione di Team Foundation Build.

  12. Una volta effettuate le impostazioni desiderate per il percorso di generazione, scegliere Avanti.

    Verrà visualizzata la finestra Selezionare opzioni di generazione.

  13. Indicare le opzioni di generazione che si desidera attivare selezionando le caselle di controllo Esegui test (ad esempio, BVT e così via) ed Esegui analisi del codice in base alle necessità. Se si seleziona la casella di controllo Esegui test (ad esempio, BVT e così via), utilizzare la casella di riepilogo a discesa per specificare File di metadati di test e Elenco di test da eseguire in base alle esigenze. Per ulteriori informazioni, vedere Utilizzo di elenchi di test e Scrittura di codice di qualità.

  14. Dopo avere eseguito le operazioni di generazione desiderate, scegliere Avanti.

    Verrà visualizzata la finestra Controllare selezioni Tipo di generazione.

  15. Se si è soddisfatti del tipo di generazione, fare clic su Fine. Il nuovo tipo di generazione creerà i file sottostanti seguenti:

    • TeamBuild.proj

    • WokspaceMapping.xml

    Questi file vengono archiviati in Controllo del codice sorgente Team Foundation nella cartella con lo stesso nome del tipo di generazione. Ad esempio, se si crea il tipo di generazione TipoGenerazionePersonale, nel controllo del codice sorgente di Team Foundation i file vengono memorizzati in $/[Nome progetto Team]/TeamBuildType/TipoGenerazionePersonale.

    Nota Nota

    Se si desidera modificare ulteriormente il tipo di generazione, è necessario modificare il file teambuild.proj.

    Al termine della procedura guidata è necessario assicurarsi che siano state impostate le autorizzazioni appropriate per il tipo di generazione appena creato. Per ulteriori informazioni, vedere Procedura: definire le autorizzazioni relative al computer per la generazione Team.

Protezione

La prima creazione di un tipo di generazione può essere eseguita solo da un amministratore di progetto. Le creazioni di tipi di generazione successive richiedono le autorizzazioni di archiviazione e amministrazione delle generazioni di Team Foundation Server. È necessario disporre del privilegio di protezione di Team Foundation Server che consente di avviare e riprendere una generazione per potere eseguire una generazione. In questo contesto vengono applicati i privilegi o le autorizzazioni di protezione di Team Foundation Server. Per ulteriori informazioni, vedere Autorizzazioni e privilegi di protezione di Team Build.

Vedere anche

Attività

Procedura dettagliata: creazione di un tipo di generazione in Team Foundation Build
Procedura: definire le autorizzazioni relative al computer per la generazione Team
Procedura: impostare un computer di generazione
Procedura dettagliata: estensione di Team Foundation Build

Concetti

Cenni preliminari su Team Foundation Build

Altre risorse

Utilizzo dei tipi di generazione in Team Build


Procedura: configurare i test con i tipi di generazione

Procedura: configurare i test con i tipi di generazione

In questo argomento viene descritto come modificare i progetti e i tipi di generazione per utilizzare le funzionalità di test di Team Foundation Build. In questo argomento vengono trattati i seguenti tipi di test:

  • Unit test di ASP.NET

  • Unit test dei servizi Web

  • Test Web

  • Test di carico

  • Test ordinati

  • Test generici

Requisiti per la generazione di progetti Web

Per essere generato utilizzando Team Foundation Build, un progetto Web deve essere configurato come aggiornabile.

Per configurare un progetto Web come aggiornabile

  1. In Esplora soluzioni selezionare il progetto Web.

  2. Scegliere Pagine delle proprietà dal menu Visualizza.

  3. Nel riquadro di sinistra fare clic su Opzioni MSBuild.

  4. Selezionare Consenti aggiornamento del sito precompilato.

Nota Nota

Questa opzione è selezionata per impostazione predefinita.

Unit test ASP.NET

È possibile eseguire il test di progetti ASP.NET nei seguenti modi:

  • Su server Web locale o remoto, ad esempio IIS.

  • Su un server di sviluppo ASP.NET. Per ulteriori informazioni, vedere Server Web in Visual Web Developer.

Per eseguire il test di progetti ASP.NET in IIS

  1. Creare un progetto ASP.NET. Per ulteriori informazioni, vedere Procedura: creare siti Web IIS locali.

  2. Aprire il file SLN in un editor di testo quale Blocco note.

    Nota Nota

    Per impostazione predefinita, il file SLN di un progetto ASP.NET si trova in Documenti\Visual Studio 2005\Projects\WebSiteName.

  3. Impostare i valori Debug.AspNetCompiler.PhysicalPath e Release.AspNetCompiler.PhysicalPath su "..\SolutionName\WebProjectName".

  4. Creare uno unit test per il progetto. Per ulteriori informazioni, vedere Unit test di ASP.NET.

  5. Archiviare il progetto Web e il progetto di test.

  6. Creare un nuovo tipo di generazione e selezionare il test da eseguire durante la generazione. Per ulteriori informazioni, vedere Procedura: creare un nuovo tipo di generazione.

    Nota Nota

    Nel passaggio Selezionare configurazioni da generare della Creazione guidata nuovo tipo di generazione Team Foundation, digitare Piattaforme miste nella casella Piattaforma relativa al progetto Web affinché il test venga generato correttamente.

  7. Pubblicare manualmente il sito Web sul computer di generazione.

  8. Eseguire il tipo di generazione.

Per eseguire il test di progetti ASP.NET su un server di sviluppo ASP.NET

  1. Creare un progetto ASP.NET.

  2. Aprire il file SLN in un editor di testo quale Blocco note.

    Nota Nota

    Per impostazione predefinita, il file SLN di un progetto ASP.NET si trova in Documenti\Visual Studio 2005\Projects\WebSiteName.

  3. Impostare i valori Debug.AspNetCompiler.PhysicalPath e Release.AspNetCompiler.PhysicalPath su "..\SolutionName\WebProjectName".

  4. Creare uno unit test per il progetto. Per ulteriori informazioni, vedere Unit test di ASP.NET.

  5. Impostare il percorso dell'attributo AspNetDevelopmentServerHost nel metodo di test su %PathToWebRoot%. Per ulteriori informazioni, vedere Test di siti Web e di servizi Web in un ambiente di team.

  6. Archiviare il progetto Web e il progetto di test.

  7. Creare un nuovo tipo di generazione e selezionare il test da eseguire durante la generazione. Per ulteriori informazioni, vedere Procedura: creare un nuovo tipo di generazione.

    Nota Nota

    Nel passaggio Selezionare configurazioni da generare della Creazione guidata nuovo tipo di generazione Team Foundation, digitare Piattaforme miste nella casella Piattaforma relativa al progetto Web affinché il test venga generato correttamente.

  8. Eseguire il tipo di generazione.

Unit test dei servizi Web

È possibile eseguire il test dei servizi Web nei seguenti modi:

  • Su server Web locale o remoto, ad esempio IIS.

  • Su un server di sviluppo ASP.NET. Per ulteriori informazioni, vedere Server Web in Visual Web Developer.

Per eseguire il test dei servizi Web in IIS

  1. Creare un progetto di servizio Web. Per ulteriori informazioni, vedere Procedura dettagliata: creazione di un servizio Web XML mediante Visual Basic o Visual C#.

  2. Aprire il file SLN in un editor di testo quale Blocco note.

    Nota Nota

    Per impostazione predefinita, il file SLN di un progetto ASP.NET si trova in Documenti\Visual Studio 2005\Projects\WebSiteName.

  3. Impostare i valori Debug.AspNetCompiler.PhysicalPath e Release.AspNetCompiler.PhysicalPath su "..\SolutionName\WebProjectName".

  4. Creare uno unit test per il progetto. Per ulteriori informazioni, vedere Unit test di ASP.NET.

  5. Aggiungere al metodo di test il codice riportato di seguito, dove WebServiceObject è l'oggetto servizio Web e Location è il percorso del servizio Web.

    Immagine CopyCode Copia codice
    WebServiceObject.URL = "Location";

  6. Archiviare il progetto Web e il progetto di test.

  7. Creare un nuovo tipo di generazione e selezionare il test da eseguire durante la generazione. Per ulteriori informazioni, vedere Procedura: creare un nuovo tipo di generazione.

    Nota Nota

    Nel passaggio Selezionare configurazioni da generare della Creazione guidata nuovo tipo di generazione Team Foundation, digitare Piattaforme miste nella casella Piattaforma relativa al progetto Web affinché il test venga generato correttamente.

  8. Eseguire il tipo di generazione.

Per eseguire il test di servizi Web su un server di sviluppo ASP.NET

  1. Creare un progetto di servizio Web. Per ulteriori informazioni, vedere Procedura dettagliata: creazione di un servizio Web XML mediante Visual Basic o Visual C#.

  2. Aprire il file SLN in un editor di testo quale Blocco note.

    Nota Nota

    Per impostazione predefinita, il file SLN di un progetto ASP.NET si trova in Documenti\Visual Studio 2005\Projects\WebSiteName.

  3. Impostare i valori Debug.AspNetCompiler.PhysicalPath e Release.AspNetCompiler.PhysicalPath su "..\SolutionName\WebProjectName".

  4. Creare uno unit test per il progetto. Per ulteriori informazioni, vedere Procedura: generare unit test.

  5. Includere lo spazio dei nomi Microsoft.VisualStudio.QualityTools.UnitTesting.Web nella classe di test.

  6. Aggiungere l'attributo AspNetDevelopmentServerAttribute allo unit test. Per ulteriori informazioni, vedere Test di servizi Web.

  7. Aggiungere una chiamata al metodo TryUrlRedirection. Per ulteriori informazioni, vedere la sezione "Utilizzo del metodo TryUrlRedirection" in Test di servizi Web.

  8. Archiviare il servizio Web e il progetto di test.

  9. Creare un nuovo tipo di generazione e selezionare il test da eseguire durante la generazione. Per ulteriori informazioni, vedere Procedura: creare un nuovo tipo di generazione.

    Nota Nota

    Nel passaggio Selezionare configurazioni da generare della Creazione guidata nuovo tipo di generazione Team Foundation, digitare Piattaforme miste nella casella Piattaforma relativa al progetto Web affinché il test venga generato correttamente.

  10. Pubblicare manualmente il sito Web nel computer di generazione.

  11. Eseguire il tipo di generazione.

Test Web

L'esecuzione di test Web con Team Foundation Build richiede che il servizio Team Build sia in esecuzione con l'account dell'amministratore sul computer di generazione. Per ulteriori informazioni sulle modalità di installazione di Team Foundation Build, vedere Procedura: impostare un computer di generazione.

È possibile eseguire i test Web nei seguenti modi:

  • Su server Web locale o remoto, ad esempio IIS.

  • Su un server di sviluppo ASP.NET. Per ulteriori informazioni, vedere Server Web in Visual Web Developer.

Per ulteriori informazioni sui test Web, vedere Utilizzo di test Web.

Per eseguire test Web su IIS

  1. Creare un progetto Web.

  2. Aprire il file SLN in un editor di testo quale Blocco note.

    Nota Nota

    Per impostazione predefinita, il file SLN di un progetto ASP.NET si trova in Documenti\Visual Studio 2005\Projects\WebSiteName.

  3. Creare un nuovo test Web.

  4. Archiviare il progetto Web e il progetto di test.

  5. Creare un nuovo tipo di generazione e selezionare il test da eseguire durante la generazione. Per ulteriori informazioni, vedere Procedura: creare un nuovo tipo di generazione.

    Nota Nota

    Nel passaggio Selezionare configurazioni da generare della Creazione guidata nuovo tipo di generazione Team Foundation, digitare Piattaforme miste nella casella Piattaforma relativa al progetto Web affinché il test venga generato correttamente.

  6. Pubblicare manualmente il sito Web nel computer di generazione.

  7. Eseguire il tipo di generazione.

Per eseguire test Web su un server di sviluppo ASP.NET

  1. Creare un progetto Web.

  2. Aprire il file SLN in un editor di testo quale Blocco note.

    Nota Nota

    Per impostazione predefinita, il file SLN di un progetto ASP.NET si trova in Documenti\Visual Studio 2005\Projects\WebSiteName.

  3. Impostare i valori Debug.AspNetCompiler.PhysicalPath e Release.AspNetCompiler.PhysicalPath su "..\SolutionName\WebProjectName".

  4. Creare un test Web. Per ulteriori informazioni, vedere Creazione di un test Web.

  5. In Esplora soluzioni fare clic con il pulsante destro del mouse sul file WEBTEST e scegliere Apri.

  6. Selezionare il pulsante Imposta parametri per server Web.

  7. Selezionare il server Web per il quale si desidera impostare i parametri, quindi fare clic su Cambia.

  8. Selezionare Utilizza server di sviluppo ASP.NET.

  9. Nella casella Percorso del sito Web digitare %PathToWebRoot%\WebSiteProjectName.

  10. Nella casella Radice dell'applicazione Web immettere la directory principale dell'applicazione Web.

  11. Scegliere OK, quindi di nuovo OK.

  12. Archiviare il servizio Web e il progetto di test.

  13. Creare un nuovo tipo di generazione e selezionare il test da eseguire durante la generazione. Per ulteriori informazioni, vedere Procedura: creare un nuovo tipo di generazione.

    Nota Nota

    Nel passaggio Selezionare configurazioni da generare della Creazione guidata nuovo tipo di generazione Team Foundation, digitare Piattaforme miste nella casella Piattaforma relativa al progetto Web affinché il test venga generato correttamente.

  14. Eseguire il tipo di generazione.

Test di carico

Per ulteriori informazioni sui test di carico, vedere Utilizzo di test di carico.

Per configurare un test di carico da utilizzare con Team Foundation Build

  1. Creare un test di carico. Per ulteriori informazioni, vedere Creazione di un test di carico.

  2. Assicurarsi che nel computer di generazione sia installato SQL Server Express e che il servizio Team Build disponga dell'autorizzazione di scrittura per SQL Server Express.

  3. Creare un nuovo tipo di generazione e selezionare il test da eseguire durante la generazione. Per ulteriori informazioni, vedere Procedura: creare un nuovo tipo di generazione.

  4. Eseguire il tipo di generazione.

    Nota Nota

    Per visualizzare i risultati del test di carico potrebbe essere necessario modificare alcune impostazioni di configurazione se il repository del test di carico si trovava in un'installazione di SQL Server Express. In questo caso, attivare le connessioni remote per SQL Server Express nel computer di generazione.

Test ordinati

Per ulteriori informazioni sui test ordinati, vedere Utilizzo di test ordinati.

Per configurare un test ordinato da utilizzare con Team Foundation Build

  1. Creare un test ordinato. Per ulteriori informazioni, vedere Procedura: creare un test ordinato.

  2. Creare un nuovo tipo di generazione e selezionare il test da eseguire durante la generazione. Per ulteriori informazioni, vedere Procedura: creare un nuovo tipo di generazione.

  3. Eseguire il tipo di generazione.

Test generico

Per ulteriori informazioni sui test generici, vedere Utilizzo di test generici.

Per configurare un test generico da utilizzare con Team Foundation Build

  1. Creare un test generico. Per ulteriori informazioni, vedere Procedura: creare un test generico.

  2. Creare un nuovo tipo di generazione e selezionare il test da eseguire durante la generazione. Per ulteriori informazioni, vedere Procedura: creare un nuovo tipo di generazione.

  3. Eseguire il tipo di generazione.

Vedere anche

Concetti

Test di siti Web e di servizi Web in un ambiente di team

Altre risorse

Utilizzo dei tipi di generazione in Team Build
Tipi di test


Procedura: definire le autorizzazioni relative al computer per la generazione Team

Procedura: definire le autorizzazioni relative al computer per la generazione Team
Vedere anche

In Team Foundation Build vengono utilizzati i tipi di generazione per configurare le condizioni in base a cui sarà generata una soluzione o un insieme di soluzioni in un progetto Team. Per eseguire una generazione, è necessario creare un nuovo tipo di generazione o utilizzarne uno esistente creato precedentemente. Per ulteriori informazioni sulla creazione di un nuovo tipo di generazione, vedere Procedura: creare un nuovo tipo di generazione.

È inoltre necessario verificare che sul computer di generazione utilizzato per il tipo di generazione siano state definite le autorizzazioni di protezione corrette e che agli utenti che eseguiranno la generazione vengano concesse le autorizzazioni appropriate, come descritto nella procedura seguente.

Per definire le autorizzazioni di generazione

  1. Contattare l'amministratore di sistema per il computer di generazione selezionato e determinare il nome dell'account utilizzato per l'esecuzione del servizio Team Build.

  2. Scegliere Impostazioni progetto Team dal menu Team, quindi Appartenenza a gruppo.

    Verrà visualizzata la finestra di dialogo Gruppi di progetti.

    Verrà visualizzata la finestra di dialogo Proprietà gruppo Team Foundation Server.

  3. Fare clic sulla scheda Membri. Se il nome account del passaggio 1 è presente nell'elenco dei membri, il computer di generazione selezionato può essere utilizzato per questo tipo di generazione. In caso contrario, attenersi ai passaggi riportati di seguito:

    1. In Aggiungi membro selezionare Utente o gruppo Windows, quindi scegliere Aggiungi.

      Verrà visualizzata la finestra di dialogo Selezione utenti o gruppi.

    2. Nella finestra di dialogo Selezione utenti o gruppi digitare il nome dell'account associato al servizio Team Build sul computer di generazione utilizzato per questo tipo di generazione.

    Nota Nota

    Se per questo tipo di generazione vengono utilizzati più computer di generazione, è necessario aggiungere tutti gli account del servizio Team Build come membri del gruppo Build Services del progetto.

  4. È necessario configurare gli utenti che si desidera possano eseguire i tipi di generazione concedendo l'autorizzazione che consente di avviare e riprendere una generazione. Per ulteriori informazioni, vedere Controllo e autorizzazioni utente e Autorizzazioni e privilegi di protezione di Team Build.

Protezione

Perché possano eseguire una generazione, è necessario che gli utenti dispongano del privilegio di protezione di Team Foundation Server che consente di avviare e riprendere una generazione. In questo contesto vengono applicati i privilegi di protezione di Team Foundation Server. Per ulteriori informazioni, vedere Autorizzazioni e privilegi di protezione di Team Build.

Vedere anche

Attività

Procedura dettagliata: esecuzione di un tipo di generazione in Team Foundation Build
Procedura: impostare un computer di generazione
Procedura: creare un nuovo tipo di generazione

Riferimenti

Comando Start (Team Foundation Build)


Procedura: modificare un tipo di generazione

Procedura: modificare un tipo di generazione

Prima di modificare un tipo di generazione, è necessario creare una generazione in Creazione guidata nuovo tipo di generazione Team Foundation. Per ulteriori informazioni, vedere Procedura: creare un nuovo tipo di generazione. Dopo essere stato creato, un tipo di generazione include un file TeamBuild.proj associato che viene creato e archiviato in Controllo del codice sorgente Team Foundation, in ${Progetto portfolio}\Team Build Configurations\{Nome tipo generazione}\TeamBuild.proj. Per modificare il tipo di generazione, è necessario modificare il file TeamBuild.proj. Nella seguente procedura viene illustrato come modificare un file TeamBuild.proj del tipo di generazione.

Per modificare un file TeamBuild.proj del tipo di generazione

  1. Per modificare un tipo di generazione esistente, è necessario estrarre il file TeamBuild.proj corrispondente. Per ulteriori informazioni, vedere Copia locale dei file dal server del controllo del codice sorgente.

  2. Fare clic con il pulsante destro del mouse sul file del tipo di generazione e scegliere Modifica definizione di tipo.

  3. Nel file TeamBuild.proj individuare la sezione Description. Se si desidera, modificare la descrizione cambiando il valore nell'elemento Description, ad esempio:

    Immagine CopyCode Copia codice
    <Description>This is my new description</Description>

  4. Individuare l'elemento SolutionToBuild. Per ogni soluzione che si desidera includere nel tipo di generazione, è necessario creare un nuovo elemento SolutionToBuild all'interno dell'elemento ItemGroup, specificando il nome della soluzione con l'attributo Includi, ad esempio:

    Immagine CopyCode Copia codice
    <ItemGroup>
    <SolutionToBuild Include="$(SolutionRoot)\path\MySolution.sln" />
    <SolutionToBuild Include="$(SolutionRoot)\Scribble\scribble.sln" />
    <SolutionToBuild Include="$(SolutionRoot)\HelloWorld\HelloWorld.sln" />
    <SolutionToBuild Include="$(SolutionRoot)\TestProject1\TestProject1.sln" />
</ItemGroup>

  5. Individuare l'elemento Order of Solutions to Build. Per cambiare l'ordine delle soluzioni, modificare l'ordine specificato nell'elemento ItemGroup, come descritto nel passaggio precedente. Se è necessario spostare la soluzione HelloWorld sopra la soluzione Scribble, come illustrato nel passaggio precedente, apportare le seguenti modifiche:

    Immagine CopyCode Copia codice
    <ItemGroup>
    <SolutionToBuild Include="$(SolutionRoot)\TestProject1\TestProject1.sln" />
    <SolutionToBuild Include="$(SolutionRoot)\HelloWorld\HelloWorld.sln" />
    <SolutionToBuild Include="$(SolutionRoot)\Scribble\scribble.sln" />
</ItemGroup>

  6. Individuare l'elemento ConfigurationsToBuild. Per aggiungere una nuova combinazione di configurazioni di debug e finale e per piattaforme quali x86 e Itanium, aggiungere gli elementi nella destinazione Compile, come illustrato di seguito. In questo esempio l'utente dispone di una nuova combinazione di Debug e per la piattaforma x86.

    Immagine CopyCode Copia codice
    <ConfigurationToBuild Include="Release|x86">
    <FlavorToBuild>Debug</FlavorToBuild>
    <PlatformToBuild>x86</PlatformToBuild>
</ConfigurationToBuild>
    Nota Nota

    A parte questa voce per la nuova configurazione, nell'esempio riportato sopra 'Debug' deve trovarsi nell'elemento AvailableConfigurations in TeamBuild.proj se non esiste già.

  7. Individuare l'elemento BuildMachine. Per cambiare il computer di generazione, modificare l'elemento BuildMachine, ad esempio:

    Immagine CopyCode Copia codice
    <BuildMachine>machine1</BuildMachine>

  8. Individuare l'elemento BuildDirectoryPath. Per cambiare la directory di generazione, modificare l'elemento BuildDirectoryPath, ad esempio:

    Immagine CopyCode Copia codice
    <BuildDirectoryPath>c:/builddir</BuildDirectoryPath>

  9. Individuare l'elemento Drop Location. Per cambiare la destinazione finale, modificare l'elemento DropLocation, ad esempio:

    Immagine CopyCode Copia codice
    <DropLocation>\\machine2\drops</DropLocation>

  10. Individuare l'elemento Testing Enabled. Per modificare l'opzione di attivazione dei test nel processo di generazione, impostare un valore true o false per l'elemento TestingFlag, ad esempio:

    Immagine CopyCode Copia codice
    <TestingFlag>true</TestingFlag>

    Per cambiare il nome del file di metadati associato al test, modificare l'opzione testmetadatafilename nell'elemento TestingArgs, ad esempio:

    Immagine CopyCode Copia codice
    <TestingArgs>/testmetadatafilename:sdfsdf /testlist:sdfsdf</TestingArgs>

    Per cambiare il nome del file di metadati, modificare l'opzione testlist nell'elemento TestingArgs, ad esempio:

    Immagine CopyCode Copia codice
    <TestingArgs>/testmetadatafilename:sdfsdf /testlist:sdfsdf</TestingArgs>

  11. Se si desidera eseguire dei test selettivi, è possibile specificarli con un attributo Condition. Ad esempio, se si desidera eseguire il test solo per la configurazione "Debug|Any CPU", modificare l'elemento MetaDataFile corrispondente e aggiungere la condizione seguente:

    Immagine CopyCode Copia codice
    <MetaDataFile
   Condition = ” ’$(Platform)’ = = ’Any CPU’ and ‘$(Flavor)’ = = ’Debug’ ”
   Include = "$(SolutionRoot)\HelloWorld\HelloWorld.vsmdi">
   <TestList>BVT1</TestList>
</MetaDataFile>

    Per ulteriori informazioni sui file di metadati dei test, vedere Riutilizzo di test.

  12. Individuare l'elemento Analisi codice attivata. Per modificare l'opzione di attivazione dell'analisi codice nel processo di generazione, impostare un valore true o false per l'elemento RunCodeAnalysis, ad esempio:

    Immagine CopyCode Copia codice
    <RunCodeAnalysis>true</RunCodeAnalysis>

  13. Salvare il file TeamBuild.proj. Le modifiche apportate al file si ripercuoteranno sull'avanzamento del tipo di generazione.

    Nota Nota

    Le modifiche apportate all'elemento TeamProject non si ripercuoteranno sulla generazione.

Protezione

È necessario disporre del privilegio di protezione di Team Foundation Server che consente di amministrare una generazione per potere estrarre il file di un tipo di generazione. In questo contesto vengono applicati i privilegi o le autorizzazioni di protezione di Team Foundation Server. Per ulteriori informazioni, vedere Autorizzazioni e privilegi di protezione di Team Build.

Vedere anche

Concetti

Riferimenti dello schema del file di progetto MSBuild
Cenni preliminari su MSBuild

Altre risorse

Utilizzo dei tipi di generazione in Team Build
Estensione di Team Foundation Build


Procedura: aggiornare i tipi di generazione sui progetti Team diramati

Procedura: aggiornare i tipi di generazione sui progetti Team diramati
Vedere anche

In Controllo del codice sorgente Team Foundation la diramazione comporta la copia di tutte le cartelle e di tutti i file, compresa la cartella Tipi di generazione Team Foundation, da una diramazione precedente a una diramazione di destinazione. Per ulteriori informazioni, vedere Diramazioni e unione del controllo del codice sorgente di Team Foundation. È necessario considerare due scenari di diramazione che interessano i tipi di generazione Team Foundation in modi diversi.

  • Diramazione parziale Diramazione di solo una o alcune delle soluzioni contenute in una cartella del progetto Team.

  • Diramazione completa Diramazione di un'intera cartella del progetto Team.

Nel caso di una diramazione parziale, i tipi di generazione contenuti nella cartella Tipi di generazione Team Foundation rimarranno validi per la configurazione originale, ossia verranno eseguiti in base alla diramazione originale. Nel caso di una diramazione parziale si consiglia di creare nuovi tipi di generazione, dove necessario, che facciano riferimento alle soluzioni presenti sia nella diramazione originale che in quella nuova. Per ulteriori informazioni, vedere Procedura: creare un nuovo tipo di generazione. Sebbene sia possibile modificare i file TeamBuild.proj esistenti nella nuova diramazione in modo che facciano riferimento ai percorsi appropriati, mediante la creazione di nuovi tipi di generazione si conservano i tipi di generazione originali che è possibile continuare a utilizzare nella configurazione precedente, esistente prima della diramazione.

Come nel caso di una diramazione parziale, quando si crea una diramazione completa all'interno di un progetto Team, in Team Explorer viene creata una copia della cartella Tipi di generazione Team Foundation originale. I tipi di generazione contenuti nella cartella della nuova diramazione non funzionano automaticamente nella nuova diramazione, come nel caso di una diramazione parziale, ma vengono eseguiti facendo riferimento ai percorsi della diramazione originale. In questo caso si consiglia di modificare i percorsi delle soluzioni nei file TeamBuild.proj in modo che facciano riferimento alla cartella corretta, come descritto nella procedura seguente.

Procedura

Per modificare un file TeamBuild.proj per aggiornare i percorsi dei tipi di generazione a seguito di un'operazione di diramazione completa

  1. Per modificare un tipo di generazione esistente al fine di aggiornare il percorso della soluzione, è necessario estrarre il file TeamBuild.proj corrispondente. Per ulteriori informazioni, vedere Copia locale dei file dal server del controllo del codice sorgente e Procedura: modificare un tipo di generazione.

  2. Fare clic con il pulsante destro del mouse sul file del tipo di generazione e scegliere Modifica definizione di tipo.

  3. Nel file TeamBuild.proj individuare il tag <ItemGroup>. All'interno del tag <ItemGroup>, aggiornare il percorso specificato in ciascun tag SolutionsToBuild come illustrato nell'esempio seguente.

    File originale copiato dalla cartella del progetto Team Alpha:

    Immagine CopyCode Copia codice
    <ItemGroup>
    <SolutionToBuild Include="$(SolutionRoot)\Alpha\path\Solution1.sln" />
    <SolutionToBuild Include="$(SolutionRoot)\Alpha\path\Solution2.sln" />
</ItemGroup>

    Modifiche che riflettono il nuovo progetto Beta1 diramato:

    Immagine CopyCode Copia codice
    <ItemGroup>
    <SolutionToBuild Include="$(SolutionRoot)\Beta\path\Solution1.sln" />
    <SolutionToBuild Include="$(SolutionRoot)\Beta\path\Solution2.sln" />
</ItemGroup>

  4. Salvare il file TeamBuild.proj. Le modifiche dei percorsi aggiornati nel file si rifletteranno sull'avanzamento del tipo di generazione.

Protezione

Per estrarre il file di un tipo di generazione è necessario disporre del privilegio di protezione di Team Foundation Server che consente di amministrare una generazione. Nella procedura qui indicata vengono applicati i privilegi o le autorizzazioni di protezione di Team Foundation Server. Per ulteriori informazioni, vedere Autorizzazioni e privilegi di protezione di Team Build.

Vedere anche

Altre risorse

Esecuzione delle generazioni in Team Foundation Build


Procedura: eliminare un tipo di generazione

Procedura: eliminare un tipo di generazione

Team Foundation Build utilizza i tipi di generazione per gestire le condizioni in base a cui viene generata una soluzione o un insieme di soluzioni nell'area di lavoro di un progetto Team. Le configurazioni di generazione vengono eliminate utilizzando Team Explorer come descritto nella procedura riportata di seguito.

Per eliminare un tipo di generazione

  1. In Team Explorer, nel nodo del progetto Team interessato, fare doppio clic sulla cartella Controllo della versione per aprire Esplora controllo del codice sorgente. Individuare il tipo di generazione che si desidera eliminare nella struttura ${Progetto Team}\Tipi di generazione Team Foundation\{Nome tipo di generazione}\TeamBuild.proj. Il tipo di generazione è rappresentato dal file TeamBuild.proj, ma è necessario eliminare anche la cartella.

  2. Selezionare la cartella del tipo di generazione e scegliere Elimina dal menu di scelta rapida. È inoltre necessario archiviare le modifiche apportate alla directory.

  3. La voce del tipo di generazione viene eliminata e vengono rimossi tutti i file XML sottostanti.

Protezione

Gli account dei servizi livello applicazione e Team Build devono disporre delle autorizzazioni di lettura/scrittura sul sito di destinazione per potere eliminare un tipo di generazione. È inoltre necessario disporre del privilegio di protezione di Team Foundation Server che consente di amministrare una generazione per potere eliminare un tipo di generazione. Per ulteriori informazioni, vedere Autorizzazioni e privilegi di protezione di Team Build.

Vedere anche

Attività

Procedura dettagliata: creazione di un tipo di generazione in Team Foundation Build

Concetti

Cenni preliminari su Team Foundation Build


Estensione di Team Foundation Build

 elenco a discesa elenco a discesa attivabile
Estensione di Team Foundation Build
Vedere anche
elenco a discesa

Team Foundation Build è un sistema estendibile per l'automazione della generazione che supporta generazioni pubbliche end-to-end ed è integrabile con altri strumenti Visual Studio Team System. Team Foundation Build fornisce un semplice metodo guidato per la creazione di tipi di generazione. Nella procedura guidata è possibile specificare il computer di generazione da utilizzare, le soluzioni da generare, la destinazione finale, i test da eseguire e così via. Il risultato di un tipo di generazione creato mediante la procedura guidata è un insieme di script di generazione MSBuild che Team Foundation Build utilizza con il motore di MSBuild per eseguire le generazioni.

Team Foundation Build è stato progettato per essere estendibile. Creazione guidata nuovo tipo di generazione Team Foundation consente di creare script di generazione per gli scenari più diffusi. Tuttavia alcuni scenari di generazione potrebbero richiedere la personalizzazione degli script generati dalla procedura guidata. Sebbene Team Foundation Build includa alcune attività comuni per il supporto di azioni quali l'esecuzione di test e l'ottenimento del codice sorgente dal controllo del codice sorgente, la generazione potrebbe richiedere l'esecuzione di altre attività come parte del processo, tra cui le seguenti:

  • Un amministratore della generazione potrebbe volere distribuire gli assembly di output in una determinata destinazione al termine della compilazione ma prima del testing.

  • Una società potrebbe richiedere uno specifico sistema di numerazione delle generazioni e sostituire uno dei sistemi di numerazione predefiniti inclusi in Team Foundation Build.

  • Uno sviluppatore potrebbe volere firmare gli assembly di output al termine del processo di generazione.

In questa sezione viene illustrato come personalizzare i processi di generazione mediante la scrittura di attività personalizzate.

In questa sezione

Informazioni sui file di configurazione di Team Foundation Build

Procedura dettagliata: estensione di Team Foundation Build

Sezioni correlate

MSBuild

Riferimenti a MSBuild

Vedere anche

Altre risorse

Amministrazione di Team Foundation Build


Informazioni sui file di configurazione di Team Foundation Build

 elenco a discesa elenco a discesa attivabile
Informazioni sui file di configurazione di Team Foundation Build
Vedere anche
elenco a discesa

Team Foundation Build si basa sul motore di MSBuild. L'intero processo di Team Foundation Build è controllato da un insieme di file XML che aderiscono allo schema del file di progetto MSBuild. Gli elementi di questi file XML indicati di seguito sono importanti per il processo di generazione.

  • Elemento Target L'elemento Target definisce la modalità di generazione del progetto. Gli elementi Target contengono un insieme di attività che MSBuild esegue in sequenza. Per ulteriori informazioni sugli elementi Target, vedere Destinazioni di MSBuild.

  • Elemento Task. L'elemento Task specifica il codice che verrà eseguito durante il processo di generazione. Per ulteriori informazioni sulle attività, vedere Attività di MSBuild.

    MSBuild viene fornito con una raccolta di attività comuni che è possibile utilizzare per personalizzare il processo di generazione. Per ulteriori informazioni, vedere Riferimenti delle attività MSBuild.

  • Elemento UsingTask. L'elemento UsingTask specifica l'assembly che contiene le attività utilizzate nel processo di generazione.

Tramite i file di script di MSBuild è possibile importare altri file di script. Ad esempio, è possibile definire una configurazione comune in un file e quindi includerla in altre configurazioni. Per ulteriori informazioni, vedere Procedura: utilizzare la stessa destinazione in più file di progetto.

Due file controllano il processo di Team Foundation Build:

  • Microsoft.TeamFoundation.Build.targets

    Questo file definisce l'insieme di attività e di Target predefiniti che vengono forniti con Team Foundation Build. Tra gli elementi Target figurano Clean, DropBuild e Compile. Ogni Target contiene le attività da chiamare per lo specifico elemento Target. Alcuni Target contenuti in questo file dipendono da altri elementi Target per formare una catena di Target da eseguire in un ordine particolare. Ad esempio, il Target Compile dipende dal Target BeforeCompile così che le attività definite in quest'ultimo vengono eseguite prima di Compile. Non tutti i Target definiti in questo file vengono necessariamente eseguiti in ogni generazione. Ad esempio, per le generazioni su desktop non viene eseguito il Target Clean.

    Microsoft.TeamFoundation.Build.targets viene fornito con Visual Studio Team System e si trova nella directory MSBuildExtensionsPath\Microsoft\VisualStudio\v8.0\TeamBuild\. Su un computer esiste una sola copia di questo file, condivisa da tutte le generazioni in esecuzione su tale macchina. I clienti non devono modificare il file.

  • TfsBuild.proj

    Si tratta del file di configurazione principale per Team Foundation Build ed esiste un file per ciascun tipo di generazione. I parametri di configurazione forniti in Creazione guidata nuovo tipo di generazione Team Foundation vengono memorizzati in questo file, inclusi il computer di generazione, la directory di generazione, la destinazione finale e le soluzioni da generare. Questo file viene creato dalla Creazione guidata nuovo tipo di generazione Team Foundation quando un utente definisce un nuovo tipo di generazione. Questo file importa Microsoft.TeamFoundation.Build.targets e viene passato a MSBuild. Eventuali modifiche apportate a questo file si ripercuotono sulle build di questo tipo di generazione. Questo file è memorizzato nel controllo del codice sorgente nella cartella $\MyProject\TipiDiGenerazioneTeamFoundation\BuildType dove MyProject è il nome del progetto Team e BuildType è il nome del tipo di generazione.

Ordine dei target

Il file Microsoft.TeamFoundation.Build.targets definisce i Target comuni per Team Foundation Build e l'ordine in cui questi vengono chiamati durante il processo di generazione. Di seguito è riportato l'ordine di esecuzione dei Target. I Target in grassetto sono definiti per l'extensibility. È necessario inserire le attività in uno di questi a seconda delle esigenze. Non si consiglia di modificare altri Target.

  1. BeforeEndToEndIteration

  2. BuildNumberOverrideTarget

  3. InitializeEndToEndIteration

  4. BeforeClean

  5. CoreClean

  6. AfterClean

  7. Clean

  8. InitializeBuild

  9. BeforeGet

  10. InitializeWorkspace

  11. CoreGet

  12. AfterGet

  13. PreBuild

  14. BeforeCompile

  15. CoreCompile

  16. AfterCompile

  17. Compile

  18. GetChangeSetsAndUpdateWorkItems

  19. PostBuild

  20. BeforeTest

  21. CoreTest

  22. AfterTest

  23. Test

  24. PackageBinaries

  25. TeamBuild

  26. BeforeDropBuild

  27. CoreDropBuild

  28. CopyLogFiles

  29. AfterDropBuild

  30. DropBuild

  31. AfterEndToEndIteration

  32. EndToEndIteration

Vedere anche

Attività

Procedura dettagliata: estensione di Team Foundation Build

Altre risorse

Estensione di Team Foundation Build
Concetti relativi a MSBuild


Procedura dettagliata: estensione di Team Foundation Build

 elenco a discesa elenco a discesa attivabile
Procedura dettagliata: estensione di Team Foundation Build
Vedere anche
comprimi tutto elenco a discesa

È possibile estendere Team Foundation Build creando attività personalizzate ed eseguendole durante una generazione. In questo argomento vengono illustrate le operazioni necessarie per estendere un tipo di generazione con un'attività personalizzata.

espandi Creazione di un tipo di generazione

Per creare un nuovo tipo di generazione, utilizzare Creazione guidata nuovo tipo di generazione Team Foundation. Verrà creato il file TfsBuild.proj, che verrà archiviato nel controllo del codice sorgente. Modificare questo file per personalizzare il tipo di generazione. Per ulteriori informazioni sulla creazione di tipi di generazione, vedere Procedura: creare un nuovo tipo di generazione.

espandi Creazione di attività personalizzate

Le attività forniscono il codice che viene eseguito durante il processo di generazione e sono contenute negli elementi Target dei file di progetto MSBuild. MSBuild è il motore sottostante Team Foundation Build e le attività personalizzate devono essere in un formato comprensibile da MSBuild. Ogni attività deve essere implementata come classe .NET che implementa l'interfaccia ITask, definita nell'assembly Microsoft.Build.Framework.dll.

Per implementare un'attività, è possibile utilizzare due approcci diversi:

  • Implementare direttamente l'interfaccia ITask.

  • Derivare la classe dalla classe di supporto, Task, definita nell'assembly Microsoft.Build.Utilities.dll. Task implementa ITask e fornisce implementazioni predefinite di alcuni membri di ITask.

In entrambi i casi è necessario aggiungere alla classe un metodo denominato Execute, ossia il metodo che viene richiamato quando viene eseguita l'attività. Questo metodo non richiede parametri e restituisce un valore Boolean: true se l'attività riesce o false in caso contrario. L'esempio seguente mostra un'attività che non esegue alcuna azione e restituisce true.

C# Immagine CopyCode Copia codice
using System;
using Microsoft.Build.Framework;
using Microsoft.Build.Utilities;

namespace MyTasks
{
    public class SimpleTask : Task
    {
        public override bool Execute()
        {
            return true;
        }
    }
}

Le attività possono inoltre accettare parametri, generare eventi e registrare output. Per ulteriori informazioni, vedere Attività di MSBuild e Cenni preliminari su MSBuild.

espandi Estrazione di TfsBuild.proj

Una volta definita l'attività, è necessario registrarla e includerla in uno degli elementi target affinché il relativo codice venga eseguito al momento desiderato nel processo di generazione. Il file TfsBuild.proj si trova nella cartella $/MyTeamProject/TipiDiGenerazioneTeamFoundation/MyBuildName nel controllo del codice sorgente di Visual Studio Team System, dove MyTeamProject è il nome del progetto Team ed è il nodo principale di tutto il codice sorgente del progetto Team e MyBuildName è il nome assegnato al tipo di generazione al momento della creazione in Creazione guidata nuovo tipo di generazione Team Foundation. Ciascun tipo di generazione viene memorizzato in una sottocartella di TipiDiGenerazioneTeamFoundation all'interno del nodo principale del progetto Team.

Nota Nota

Non modificare il file Microsoft.TeamFoundation.Build.targets in quanto le personalizzazioni vengono applicate a tutte le generazioni sul computer.

Per ulteriori informazioni sull'estrazione dei file, vedere Utilizzo del controllo del codice sorgente di Team Foundation.

espandi Registrazione dell'attività

Dopo avere creato l'attività, è necessario registrarla includendola in un elemento UsingTask del file TfsBuild.proj. L'elemento UsingTask associa l'attività all'assembly che ne contiene l'implementazione. Per ulteriori informazioni, vedere Elemento UsingTask (MSBuild).

Per registrare un'attività personalizzata

  1. Aprire il file TfsBuild.proj.

  2. Aggiungere un elemento UsingTask al file e specificare i dettagli dell'attività. Ad esempio:

    Immagine CopyCode Copia codice
    <UsingTask
    TaskName="MyTasks.SimpleTask"
    AssemblyName="MyAssembly.Build.Tasks"/>

    -oppure-

    Immagine CopyCode Copia codice
    <UsingTask
    TaskName="MyTasks.SimpleTask"
    AssemblyFile="MyAssembly.Build.Tasks.dll"/>

    -oppure-

    Immagine CopyCode Copia codice
    <UsingTask
    TaskName="MyTasks.SimpleTask"
    AssemblyFile="c:\somediskpath\MyAssembly.Build.Tasks.dll"/>

  3. Salvare il file.

espandi Esecuzione dell'attività personalizzata

Una volta creata e registrata l'attività, è necessario specificare in quale punto del processo di generazione si desidera eseguirla.

Per eseguire un'attività

  1. Determinare in quale punto del processo di generazione si desidera eseguire l'attività personalizzata. Per ulteriori informazioni su dove è possibile estendere il processo di generazione, vedere Informazioni sui file di configurazione di Team Foundation Build.

  2. Aprire TfsBuild.proj e aggiungere l'elemento Target scelto in precedenza.

  3. Aggiungere l'elemento per eseguire l'attività all'interno dell'elemento Target. Ad esempio, il seguente codice XML in TfsBuild.proj esegue l'attività SimpleTask nel target BeforeGet, che viene eseguito subito prima del target Get.

    Immagine CopyCode Copia codice
    <Target Name="BeforeGet">
    <SimpleTask />
</Target>

  4. Salvare il file.

espandi Archiviazione dei file

È necessario archiviare il file TfsBuild.proj affinché le modifiche abbiano effetto. Team Foundation Build copia il file dal controllo del codice sorgente sul computer di generazione in modo che le modifiche eventualmente apportate alla copia locale non incidano sulla generazione. Per ulteriori informazioni sull'archiviazione dei file nel controllo del codice sorgente, vedere Procedura: archiviare le modifiche in sospeso.

Affinché Team Foundation Build copi la DLL dell'attività sul computer di generazione, è necessario aggiungere la DLL nel controllo del codice sorgente nel nodo del progetto Team.

espandi Attività di esempio

In questo esempio viene creata un'attività personalizzata che estende il tipo di generazione MyBuildType mediante la registrazione della dimensione dei file prodotti dalla generazione. Questo esempio contiene due parti:

  • Il codice dell'attività.

  • Il file TfsBuild.proj.

È possibile visualizzare le informazioni registrate da questa attività nel file di log di generazione, Buildlog.log, situato nella cartella di destinazione della generazione. Il log di generazione contiene informazioni simili a quelle riportate di seguito:

La dimensione totale è 9.216 byte in d:\BuildDir\MyTeamProj\MyBuildType\sources\..\Binaries\Release dir

espandi Codice C# dell'attività

Il seguente esempio contiene il codice che calcola la dimensione binaria totale sommando le dimensioni dei file nella cartella dei file binari.

Nota Nota

Tutti i file binari generati durante una generazione sono situati nella cartella Binaries nella cartella della directory di generazione sul computer di generazione.

Per includere questa attività in una generazione, è necessario archiviare la DLL compilata nel controllo del codice sorgente nella cartella del progetto Team. In questo modo il file verrà copiato sul computer di generazione durante una generazione.

Il codice riportato di seguito calcola la dimensione dei file binari presenti nella cartella Binaries della directory di generazione. La proprietà della directory principale della soluzione viene passata all'attività mediante lo script di Team Foundation Build.

C# Immagine CopyCode Copia codice
using System;
using System.Collections.Generic;
using System.Text;
using Microsoft.Build.Framework;
using Microsoft.Build.Utilities;
using System.Diagnostics;
using System.IO;

namespace BuildTask
{
    public class BinSize : Task
    {
        private string sourceDir;

        [Required]
        public string SourceDir
        {
            get { return sourceDir; }
            set { sourceDir = value; }
        }
        public override bool Execute()
        {
            string szDir = sourceDir + "\\..\\Binaries";
            ProcessDirectory(szDir);
            return true;
        }
        private void ProcessDirectory(string targetDirectory)
        {
            // Process the list of files found in the directory.
            string[] fileEntries = Directory.GetFiles(targetDirectory, "*.*");
            if (fileEntries.Length > 0)
            {
                dwSize = 0;
                szCurrDir = targetDirectory;
                foreach (string fileName in fileEntries)
                    ProcessFile(fileName);
                ////////////////////////////////////////////////////////////////////////
                // This log message would just print out a line in the build log file.
                // You need to add code to do what you need to do with this data. e.g.
                // publishing it into the warehouse for reporting.
                ///////////////////////////////////////////////////////////////////////
                Log.LogMessage("The total size of is {0} bytes in {1} dir",
                    dwSize, targetDirectory);
            }
            // Recurse into subdirectories of this directory.
            string[] subdirectoryEntries = Directory.GetDirectories(targetDirectory);
            foreach (string subdirectory in subdirectoryEntries)
                ProcessDirectory(subdirectory);
        }
        private void ProcessFile(string path)
        {
            FileInfo fi = new FileInfo(path);
            dwSize = dwSize + fi.Length;
        }
        private long dwSize;
        private string szCurrDir;
    }
}

espandi File TfsBuild.proj

Una volta compilata e archiviata l'attività nel controllo del codice sorgente, deve essere chiamata dal file TfsBuild.proj. Poiché in questo esempio l'attività deve essere chiamata dopo che i file sono stati compilati e tutti i file binari sono stati copiati nella rispettiva directory, eseguire l'attività nel target BeforeDropBuild. Per ulteriori informazioni sui target estendibili in TfsBuild.proj, vedere Informazioni sui file di configurazione di Team Foundation Build.

L'esempio riportato di seguito contiene il codice nel file TfsBuild.proj modificato. Il codice XML dell'esempio viene generato quasi interamente da Creazione guidata nuovo tipo di generazione Team Foundation, a eccezione degli elementi UsingTask e Target situati alla fine del file.

Immagine CopyCode Copia codice
<?xml version="1.0" encoding="utf-8"?>
<Project DefaultTargets="DesktopBuild" xmlns="http://schemas.microsoft.com/developer/msbuild/2003">
  <!-- TO EDIT BUILD TYPE DEFINITION

  To edit the build type, you will need to edit this file which was generated
  by the Create New Build Type wizard.  This file is under source control and
  needs to be checked out before making any changes.

  The file is available at -
      $/{TeamProjectName}/TeamBuildTypes/{BuildTypeName}
  where you will need to replace TeamProjectName and BuildTypeName with your
  Team Project and Build Type name that you created

  Checkout the file
    1. Open Source Control Explorer by selecting View -> Other Windows -> Source Control Explorer
    2. Ensure that your current workspace has a mapping for the $/{TeamProjectName}/TeamBuildTypes folder and
       that you have done a "Get Latest Version" on that folder
    3. Browse through the folders to {TeamProjectName}->TeamBuildTypes->{BuildTypeName} folder
    4. From the list of files available in this folder, right click on TfsBuild.Proj. Select 'Check Out For Edit...'

  Make the required changes to the file and save

  Checkin the file
    1. Right click on the TfsBuild.Proj file selected in Step 3 above and select 'Checkin Pending Changes'
    2. Use the pending checkin dialog to save your changes to the source control

  Once the file is checked in with the modifications, all future builds using
  this build type will use the modified settings
  -->
  <!-- Do not edit this -->
  <Import Project="$(MSBuildExtensionsPath)\Microsoft\VisualStudio\v8.0\TeamBuild\Microsoft.TeamFoundation.Build.targets" />
  <ProjectExtensions>
    <!--  DESCRIPTION
     The description is associated with a build type. Edit the value for making changes.
    -->
    <Description>
    </Description>
    <!--  BUILD MACHINE
     Name of the machine which will be used to build the solutions selected.
    -->
    <BuildMachine>MyBuildMachine</BuildMachine>
  </ProjectExtensions>
  <PropertyGroup>
    <!--  TEAM PROJECT
     The team project which will be built using this build type.
    -->
    <TeamProject>MyTeamProject</TeamProject>
    <!--  BUILD DIRECTORY
     The directory on the build machine that will be used to build the
     selected solutions. The directory must be a local path on the build
     machine (for example, c:\build).
    -->
    <BuildDirectoryPath>d:\build</BuildDirectoryPath>
    <!--  DROP LOCATION
      The location to drop (copy) the built binaries and the log files after
     the build is complete. This location must be a valid UNC path of the
     form \\Server\Share. The build machine service account and application
     tier account must have read write permission on this share.
    -->
    <DropLocation>\\MyDropServer\drops</DropLocation>
    <!--  TESTING
     Set this flag to enable/disable running tests as a post build step.
    -->
    <RunTest>true</RunTest>
    <!--  WorkItemFieldValues
      Add or edit key value pairs to set values for fields in the work item created
      during the build process. Please make sure the field names are valid
      for the work item type being used.
    -->
    <WorkItemFieldValues>Priority=1;Severity=1</WorkItemFieldValues>
    <!--  CODE ANALYSIS
       To change CodeAnalysis behavior, edit this value. Valid values for this
       can be Default, Always, or Never.

     Default - To perform code analysis according to individual project settings.
     Always - To always perform code analysis irrespective of project settings.
     Never - To never perform code analysis irrespective of project settings.
     -->
    <RunCodeAnalysis>Default</RunCodeAnalysis>
    <!--  UPDATE ASSOCIATED WORK ITEMS
     Set this flag to enable/disable updating associated work items on a successful build
    -->
    <UpdateAssociatedWorkItems>true</UpdateAssociatedWorkItems>
  </PropertyGroup>
  <ItemGroup>
    <!--  SOLUTIONS
     The path of the solutions to build. To add or delete solutions, edit this
     value. For example, to add a solution MySolution.sln, add following line -
         <SolutionToBuild Include="$(SolutionRoot)\path\MySolution.sln" />

     To change the order in which the solutions are built, modify the order in
     which the solutions appear below.
    -->
    <SolutionToBuild Include="$(SolutionRoot)\ConsoleApplication7\ConsoleApplication7.sln" />
  </ItemGroup>
  <ItemGroup>
    <!--  CONFIGURATIONS
     The list of configurations to build. To add or delete configurations, edit
     this value. For example, to add a new configuration, add the following lines -
         <ConfigurationToBuild Include="Debug|x86">
             <FlavorToBuild>Debug</FlavorToBuild>
             <PlatformToBuild>x86</PlatformToBuild>
         </ConfigurationToBuild>

     The Include attribute value should be unique for each ConfigurationToBuild node.
    -->
    <ConfigurationToBuild Include="Release|Any CPU">
      <FlavorToBuild>Release</FlavorToBuild>
      <PlatformToBuild>Any CPU</PlatformToBuild>
    </ConfigurationToBuild>
    <ConfigurationToBuild Include="Debug|Any CPU">
      <FlavorToBuild>Debug</FlavorToBuild>
      <PlatformToBuild>Any CPU</PlatformToBuild>
    </ConfigurationToBuild>
    <ConfigurationToBuild Include="Debug|x86">
      <FlavorToBuild>Debug</FlavorToBuild>
      <PlatformToBuild>x86</PlatformToBuild>
    </ConfigurationToBuild>
    <ConfigurationToBuild Include="Release|x86">
      <FlavorToBuild>Release</FlavorToBuild>
      <PlatformToBuild>x86</PlatformToBuild>
    </ConfigurationToBuild>
  </ItemGroup>
  <ItemGroup>
    <!--  TEST ARGUMENTS
     If the RunTest is set to true then the following test arguments will be
     used to run tests.

     To add or delete new testlist or to choose a metadata file (.vsmdi) file, edit this value.
     For example, to run BVT1 and BVT2 type tests mentioned in the Helloworld.vsmdi file, add the following -

     <MetaDataFile Include="$(SolutionRoot)\HelloWorld\HelloWorld.vsmdi">
         <TestList>BVT1;BVT2</TestList>
     </MetaDataFile>

     Where BVT1 and BVT2 are valid test types defined in the HelloWorld.vsmdi file.
     MetaDataFile - Full path to test metadata file.
     TestList - The test list in the selected metadata file to run.

     Please note that you must specify the .vsmdi file relative to $(SolutionRoot)
    -->
    <MetaDataFile Include="$(SolutionRoot)\ConsoleApplication7\ConsoleApplication7.vsmdi">
      <TestList>P1 Tests;P2 Tests</TestList>
    </MetaDataFile>
  </ItemGroup>
  <ItemGroup>
    <!--  ADDITIONAL REFERENCE PATH
     The list of additional reference paths to use while resolving references.
     For example,
         <AdditionalReferencePath Include="C:\MyFolder\" />
         <AdditionalReferencePath Include="C:\MyFolder2\" />
    -->
  </ItemGroup>

  <UsingTask TaskName="BuildTask.BinSize" AssemblyFile="$(SolutionRoot)\\tools\\BuildTask.dll" />

  <Target Name="BeforeDropBuild">
    <BinSize SourceDir="$(SolutionRoot)" />
  </Target>

</Project>

espandi Vedere anche

Attività

Procedura: scrivere un'attività

Concetti

MSBuild

Altre risorse

Estensione di Team Foundation Build

piè di pagina


Perdita potenziale dei dati a causa di problemi legati al fuso orario con il database Visual SourceSafe in fase di migrazione.

Perdita potenziale dei dati a causa di problemi legati al fuso orario con il database Visual SourceSafe in fase di migrazione.

Potential data loss due to time zone issues with the Visual SourceSafe Database under migration.

Il convertitore ha rilevato problemi legati al fuso orario con il database di Visual SourceSafe in fase di migrazione. Per ulteriori informazioni sui problemi relativi al fuso orario, vedere l'articolo della Knowledge Base BUG: Using SourceSafe in Multiple Time Zones (informazioni in lingua inglese).

Durante la migrazione il convertitore cerca di risolvere i problemi per garantire la migrazione del massimo numero di file e cartelle. Tuttavia il convertitore potrebbe non essere in grado di eseguire la migrazione di tutte le versioni. Se si esegue la migrazione di un database di Visual SourceSafe che presenta un problema legato al fuso orario, le date e le ore di cui viene eseguita la migrazione potrebbero essere inaccurate. Inoltre il convertitore potrebbe non essere in grado di eseguire la migrazione dei file che presentano questo problema.


La condivisione non è supportata nel controllo del codice sorgente di Team Foundation

La condivisione non è supportata nel controllo del codice sorgente di Team Foundation

Sharing is not supported in Team Foundation Source Code Control

Poiché Controllo del codice sorgente Team Foundation non supporta la condivisione, il convertitore non può eseguire la migrazione di collegamenti di condivisione tra file condivisi. È possibile che sia necessario riorganizzare i file condivisi tra i progetti. La migrazione dei file condivisi viene eseguita creando nella cartella di destinazione una versione del file con lo stesso contenuto della versione del file al momento della condivisione. Da quel momento, le modifiche apportate al file condiviso vengono replicate in entrambi i percorsi.

La condivisione è una precondizione per la diramazione. Pertanto il convertitore non può associare ‏‏‏una diramazione di Visual SourceSafe a una diramazione di Controllo del codice sorgente Team Foundation. La migrazione di un file condiviso produce una replica del file nella cartella di destinazione. La migrazione di un evento di diramazione causa l'interruzione della replica in entrambi i percorsi delle modifiche apportate a un file condiviso. Di conseguenza, la migrazione delle modifiche apportate a una diramazione viene eseguita solo nella rispettiva copia in Team Foundation.


TFSAdminhxs {2DDA7CF9-E8CF-4df1-98E8-521EDE1C5FC7}

 elenco a discesa elenco a discesa attivabile
TFSAdminhxs {2DDA7CF9-E8CF-4df1-98E8-521EDE1C5FC7}
elenco a discesa

TFSAdminhxs {2DDA7CF9-E8CF-4df1-98E8-521EDE1C5FC7}

{2DDA7CF9-E8CF-4df1-98E8-521EDE1C5FC7}

{2DDA7CF9-E8CF-4df1-98E8-521EDE1C5FC7}

Rappresentazione grafica degli argomenti relativi al debug dell'indice e alla ricerca full-text


Perdita di dati dovuta allo spostamento da una cartella di origine non inclusa nella migrazione a una di destinazione inclusa nella migrazione

Perdita di dati dovuta allo spostamento da una cartella di origine non inclusa nella migrazione a una di destinazione inclusa nella migrazione

Data loss due to folder move from source folder not under migration to destination folder under migration

Questo tipo di perdita di dati si verifica in presenza di un evento di spostamento di cartelle tra una cartella di origine inclusa nella migrazione e una cartella di destinazione non inclusa nella migrazione in Visual SourceSafe. Al termine della migrazione, la cartella spostata viene visualizzata nella cartella di destinazione come se fosse stata aggiunta al momento dello spostamento. Non viene eseguita la migrazione nel controllo del codice sorgente di Team Foundation della cronologia della cartella spostata e degli elementi in essa contenuti prima dell'evento di spostamento. Per impedire la perdita di dati cronologici, è consigliabile eseguire la migrazione contemporanea delle cartelle di origine e di destinazione della cartella di Visual SourceSafe spostata.


Versioni o cronologia di file e cartelle VSS non recuperati dal convertitore.

Versioni o cronologia di file e cartelle VSS non recuperati dal convertitore.

Versions or history of VSS Files and Folders not retrieved by Converter.

Il convertitore non è in grado di eseguire la migrazione del file a causa di errori nel database di Visual SourceSafe.


Elenco dei file attualmente estratti.

Elenco dei file attualmente estratti.

List of files currently checked out.

Quando viene eseguita la migrazione dei file, lo stato di archiviazione non viene conservato. In questo avviso sono elencati i file che sono stati estratti al termine della migrazione o dell'analisi. Si consiglia di archiviare questi file prima di eseguirne la migrazione.


Nomi di etichette che verranno modificati in seguito a una migrazione.

Nomi di etichette che verranno modificati in seguito a una migrazione.

Label names that will change as a result of migration.

In questo avviso vengono elencati i nomi delle etichette che verranno o sono stati modificati durante la migrazione in quanto contengono caratteri non supportati in Team Foundation Server.


File con la funzionalità VSS per mantenere solo la versione più recente

File con la funzionalità VSS per mantenere solo la versione più recente

List of files with the Visual SourceSafe property ‘keep latest version only’ enabled.

Se nel database di Visual SourceSafe è impostata questa opzione, non è possibile recuperare versioni dei file precedenti a quella più recente. Poiché Controllo del codice sorgente Team Foundation non dispone di una funzionalità simile, durante la migrazione il convertitore crea un file vuoto per ogni versione del file.


Perdita di dati dovuta allo spostamento da una cartella di origine inclusa nella migrazione a una di destinazione non inclusa nella migrazione

Perdita di dati dovuta allo spostamento da una cartella di origine inclusa nella migrazione a una di destinazione non inclusa nella migrazione

Data loss due to folder move from source folder under migration to destination folder not under migration

Questo tipo di perdita di dati si verifica in presenza di un evento di spostamento di cartelle tra una cartella di origine inclusa nella migrazione e una cartella di destinazione non inclusa nella migrazione in Visual SourceSafe. Al termine della migrazione, la cartella spostata viene visualizzata nella cartella di destinazione come se fosse stata aggiunta al momento dello spostamento. Non viene eseguita la migrazione nel controllo del codice sorgente di Team Foundation della cronologia della cartella spostata e degli elementi in essa contenuti prima dell'evento di spostamento. Per impedire la perdita di dati cronologici, è consigliabile eseguire la migrazione contemporanea delle cartelle di origine e di destinazione della cartella di Visual SourceSafe spostata.


Impossibile visualizzare il report di migrazione

Impossibile visualizzare il report di migrazione

Cannot View Migration Report

Se non si è in grado di visualizzare il report di migrazione, è possibile che sia stato spostato il file XML, ma non il file XSLT richiesto per la corretta visualizzazione del report di migrazione. Aprire il report di migrazione dal percorso originale oppure copiare la cartella _MigrationReport_Files contenente il file XSLT e altri file correlati nello stesso percorso.