backupfile

Contains one row for each data or log file that is backed up. This table is stored in the msdb database.

Column name | Data type | Description
backup_set_id | int NOT NULL REFERENCES backupset(backup_ set_id) | Unique identification number of the file containing the backup set.
first_family_number | tinyint NULL | Family number of the first media containing this backup file.
first_media_number | smallint NULL | Media number of the first media containing this backup file.
filegroup_name | nvarchar(128) NULL | Name of the filegroup containing the database (data or log) file backed up.
page_size | int NULL | Size of the page, in bytes.
file_number | numeric(10,0) NOT NULL | Unique file identification number (FILE_ID).
backed_up_page_count | numeric(10,0) NULL | Number of pages backed up.
file_type | char(1) NULL | File backed up. Can be either D for data or L for log.
source_file_block_size | numeric(10,0) NULL | Device that the original data or log file resided on when it was backed up.
file_size | numeric(20,0) NULL | Length of the file that is backed up, in bytes.
logical_name | nvarchar(128) NULL | Logical name of the file that is backed up.
physical_drive | varchar(260) NULL | Physical drive or partition name.
physical_name | varchar(260) NULL | Remainder of the physical (operating system) file name.

See Also

backupset


backupmediafamily

Contains one row for each media family. This table is stored in the msdb database.

Column name | Data type | Description
media_set_id | int NOT NULL REFERENCES backupmediaset (media_set_id) | Unique identification number that identifies the media set of which this family is a member.
family_sequence_ number | tinyint NOT NULL | Position of this media family in the media set.
media_family_id | uniqueidentifier NULL | Unique identification number that identifies the media family.
media_count | int NULL | Number of media in the media family.
logical_device_name | nvarchar(128) NULL | Name of the backup device in sysdevices. logical_device_name is NULL if this is a temporary backup device (as opposed to a permanent backup device that exists in sysdevices).
physical_device_name | nvarchar(260) NULL | Physical name of the backup device.
device_type | tinyint NULL | Type of backup device: Disk 2 = Temporary. 102 = Permanent. Tape 5 = Temporary. 105 = Permanent. Pipe 6 = Temporary. 106 = Permanent. All permanent device names and device numbers can be found in sysdevices.
physical_block_size | int NULL | Physical block size used to write the media family.

See Also

backupmediaset


backupmediaset

Contains one row for each backup media set. This table is stored in the msdb database.

Column name | Data type | Description
media_set_id | int IDENTITY PRIMARY KEY | Unique media set identification number.
media_uuid | uniqueidentifier NULL | Number of media in the media set. If only one media family in the backup set, then this column is NULL (media_family_count is 1).
media_family_count | tinyint NULL | Number of media families in the media set.
name | nvarchar(128) NULL | Name of the media set
description | nvarchar(255) NULL | Textual description of the media set
software_name | nvarchar(128) NULL | Name of the backup software that wrote the media label.
software_vendor_id | int NULL | Identification number of the software vendor that wrote the backup media label. The Microsoft® SQL Server™ value for this column is hexadecimal 0x1200.
MTF_major_version | tinyint NULL | Major version number of Microsoft Tape Format used to generate this media set.

See Also

backupset

backupmediafamily


backupset

Contains a row for each backup set. This table is stored in the msdb database.

Column name | Data type | Description
backup_set_id | int NOT NULL IDENTITY PRIMARY KEY | Unique backup set identification number that identifies the backup set.
backup_set_uuid | uniqueidentifier NOT NULL | Unique backup set identification number that identifies the backup set on the media.
media_set_id | int NOT NULL REFERENCES backupmediaset (media_set_id) | Unique media set identification number that identifies the media set containing the backup set.
first_family_number | tinyint NULL | Family number of the media where the backup set starts.
first_media_number | smallint NULL | Media number of the media where the backup set starts.
last_family_number | tinyint NULL | Family number of the media where the backup set ends.
last_media_number | smallint NULL | Media number of the media where the backup set ends.
catalog_family_ number | tinyint NULL | Family number of the media containing the start of the backup set directory.
catalog_media_number | smallint NULL | Media number of the media containing the start of the backup set directory.
position | int NULL | Backup set position used in the restore operation to locate the appropriate backup set and files.
expiration_date | datetime NULL | Date and time the backup set expires.
software_vendor_id | int NULL | Identification number of the software vendor writing the backup media header.
name | nvarchar(128) NULL | Name of the backup set.
description | nvarchar(255) NULL | Description of the backup set.
user_name | nvarchar(128) NULL | Name of the user performing the backup operation.
software_major_version | tinyint NULL | Microsoft® SQL Server™ major version number.
software_minor_ version | tinyint NULL | SQL Server minor version number.
software_build_version | smallint NULL | SQL Server build number.
time_zone | smallint NULL | Difference between local time (where the backup operation is taking place) and Universal Coordinated Time (UCT) in 15-minute intervals. Values can be -48 through +48, inclusive. A value of 127 indicates unknown. For example, -20 is Eastern Standard Time (EST) or 5 hours after UCT.
mtf_minor_version | tinyint NULL | Microsoft Tape Format minor version number.
first_lsn | numeric(25,0) NULL | Log sequence number of the first or oldest log record in the backup set.
last_lsn | numeric(25,0) NULL | Log sequence number of the last or newest log record in the backup set.
checkpoint_lsn | numeric(25,0) NULL | Log sequence number of the log record where recovery must start.
database_backup_lsn | numeric(25,0) NULL | Log sequence number of the most recent full database backup.
database_creation_date | datetime NULL | Date and time the database was originally created.
backup_start_date | datetime NULL | Date and time the backup operation started.
backup_finish_date | datetime NULL | Date and time the backup operation finished.
type | char(1) NULL | Backup type. Can be: D = Database. I = Database Differential. L = Log. F = File or Filegroup.
sort_order | smallint NULL | Sort order of the server performing the backup operation.
code_page | smallint NULL | Code page of the server performing the backup operation.
compatibility_level | tinyint NULL | Compatibility level setting for the database. Can be: 60 = SQL Server version 6.0. 65 = SQL Server 6.5. 70 = SQL Server 7.0.
database_version | int NULL | Database version number.
backup_size | numeric(20,0) NULL | Size of the backup set, in bytes.
database_name | nvarchar(128) NULL | Name of the database involved in the backup operation.
server_name | nvarchar(128) NULL | Name of the server running the SQL Server backup operation.
machine_name | nvarchar(128) NULL | Name of the computer running SQL Server.
flags | int NULL | Flag bits: 1 = Backup contains minimally logged data. 2 = WITH SNAPSHOT was used. 4 = Database was read-only at time of backup. 8 = Database was in single-user mode at time of backup.
unicode_locale | int NULL | Unicode locale.
unicode_compare_style | int NULL | Unicode compare style.
collation_name | nvarchar(128) NULL | Collation name.

See Also

restorehistory

backupfile

backupmediaset


logmarkhistory

Contains one row for each marked transaction that has been committed. This table is stored in the msdb database.

Column name | Data type | Description
database_name | nvarchar(128) NOT NULL | Local database where marked transaction occurred.
mark_name | nvarchar(128) NOT NULL | User-provided name for marked transaction.
description | nvarchar(255) NULL | User-provided description of the marked transaction.
user_name | nvarchar(128) NULL | Database user name that performed marked transaction.
lsn | numeric(25,0) NOT NULL | Log sequence number of transaction record where mark occurred.
mark_time | datetime NOT NULL | Commit time of marked transaction (local time).


log_shipping_databases

This table is stored in the msdb database.

Column name | Data type | Description
database_name | sysname | Name of the database being log shipped.
maintenance_plan _id | uniqueidentifier | Maintenance plan ID.


log_shipping_monitor

This table is stored in the msdb database.

Column name | Data type | Description
monitor_server_name | sysname | Name of the log shipping monitor server.
logon_type | int | Authentication method: 1 = Windows authentication. 2 = SQL Server authentication.
logon_data | varbinary(256) | Login name and password.


log_shipping_plan_databases

This table is stored in the msdb database.

Column name | Data type | Description
plan_id | uniqueidentifier | The plan ID for the maintenance plan that exists on the Secondary.
source_database | sysname | Primary database of a log shipping pair.
destination_database | sysname | Secondary database of a log shipping pair.
load_delay | int | Delay (in seconds) before restoring a transaction log after it is transferred to the secondary server.
load_all | bit | 1 = Load all copied transaction logs.
last_file_copied | nvarchar(500) | File name of last transaction log copied.
date_last_copied | datetime | Date that last transaction log was copied.
last_file_loaded | nvarchar(500) | File name of last transaction log loaded.
date_last_loaded | datetime | Date that last transaction log was loaded.
copy_enabled | bit | Allow copying of transaction logs. 0 = Disable copying. 1 = Enable copying.
load_enabled | bit | Allow loading of transaction logs. 0 = Disable loading. 1 = Enable loading.
recover_db | bit | Roll back all uncompleted transactions after restore. 0 = FALSE 1 = TRUE
terminate_users | bit | 1 = Terminate database users.


log_shipping_plan_history

This table is stored in the msdb database.

Column name | Data type | Description
sequence_id | int | The sequence in which rows were inserted.
plan_id | uniqueidentifier | Log shipping plan ID.
source_database | sysname | Name of primary database in log shipping pair.
destination_ database | sysname | Name of secondary database in log shipping pair.
activity | bit | The action performed. 0 = Copy. 1 = Load.
succeeded | bit | Roll back all uncompleted transactions after restore. 0 = FALSE 1 = TRUE
num_files | int | Number of transaction logs shipped to secondary server.
last_file | nvarchar(256) | Name of the last file on which this action was performed.
end_time | datetime | Time and date when which action completed.
duration | int | Amount of time (in seconds) taken to complete the action.
error_number | int | Last error number encountered by the action.
message | nvarchar(500) | Last error message encountered by the action.


log_shipping_plans

This table is stored in the msdb database.

Column name | Data type | Description
plan_id | uniqueidentifier | Log shipping plan ID.
plan_name | sysname | Log shipping plan name.
description | nvarchar(500) | User provided description of log shipping plan.
source_server | sysname | Primary server of log shipping pair.
source_dir | nvarchar(500) | Transaction log source directory on primary server.
destination_dir | nvarchar(500) | Transaction log destination directory on secondary server.
copy_job_id | uniqueidentifier | Copy job ID.
load_job_id | uniqueidentifier | Load job ID.
history_retention _period | int | Length of time to retain history rows for this plan.
file_retention_ period | int | Length of time to retain copied transaction log files.
maintenance_plan _id | uniqueidentifier | Maintenance plan ID.
backup_job_id | uniqueidentifier | Backup job ID.
share_name | nvarchar(500) | Share name.


log_shipping_primaries

This table is stored in the msdb database.

Column name | Data type | Description
primary_id | int (IDENTITY) | Artificial unique key.
primary_server_ name | sysname | Name of primary server in log shipping pair.
primary_database name | sysname | Name of primary database in log shipping pair.
maintenance_plan _id | uniqueidentifier | Maintenance plan ID.
backup_threshold | Int | Number of minutes without a backup occurring, before raising an error.
threshold_alert | int | Error to raise if transaction log backups stop occurring.
threshold_alert_ enabled | bit | Status of threshold alert. 1 = Enabled. 0 = Disabled.
last_backup_ filename | nvarchar(500) | File name of the most recent transaction log backup.
last_updated | datetime | Date (on the monitor server) that the primary last updated the last_backup_filename column.
planned_outage_ start_time | int | Start time of the window during which threshold alerts will not be raised (in HHMMSS format).
planned_outage_ end_time | int | End time of the window during which threshold alerts will not be raised (in HHMMSS format).
planned_outage_ weekday_mask | int | 1 = Sunday 2 = Monday 4 = Tuesday 8 = Wednesday 16 = Thursday 32 = Friday 64 = Saturday
source_directory | nvarchar(500) | Source directory.

See Also

log_shipping_secondaries


log_shipping_secondaries

This table is stored in the msdb database.

Column name | Data type | Description
primary_id | int | Foreign key to log_shipping_primaries.
secondary_server_name | sysname | Name of secondary server in log shipping pair.
secondary_ database_name | sysname | Name of secondary database in log shipping pair.
last_copied_ filename | nvarchar(500) | File name of last transaction log copied to secondary server.
last_loaded_ filename | nvarchar(500) | File name of last transaction log loaded by secondary server.
last_copied_last_ updated | datetime | Modification time of last transaction log file copied to secondary server.
last_loaded_last_ updated | datetime | Modification time of last transaction log file loaded by secondary server.
secondary_plan_ id | uniqueidentifier | Plan ID of the log shipping plan on the secondary server.
copy_enabled | bit | Allow copying of transaction logs. 0 = Disable copying. 1 = Enable copying.
load_enabled | bit | Allow loading of transaction logs. 0 = Disable loading. 1 = Enable loading.
out_of_sync_ threshold | int | Latency between last_loaded_filename and last_backup_file, after which the threshold alert will be raised.
threshold_alert | int | Error to be raised if the out_of_sync_threshold is exceeded.
threshold_alert_ enabled | bit | Status of threshold alert. 1 = Enabled. 0 = Disabled.
planned_outage_ start_time | int | Start time of the window during which threshold alerts will not be raised (in HHMMSS format).
planned_outage_ end_time | int | End time of the window during which threshold alerts will not be raised (in HHMMSS format).
planned_outage_ weekday_mask | int | 1 = Sunday 2 = Monday 4 = Tuesday 8 = Wednesday 16 = Thursday 32 = Friday 64 = Saturday
allow_role_ change | bit | 1 = Role change allowed.

See Also

log_shipping_primaries


sysalerts

Contains one row for each alert. An alert is a message sent in response to an event. An alert can forward messages beyond the Microsoft® SQL Server™ environment, and an alert can be an e-mail or pager message. An alert also can generate a task.

Column name | Data type | Description
id | int | Alert ID.
name | sysname | Alert name.
event_source | nvarchar(100) | Source of the event: SQL Server.
event_category_id | int | Reserved for future use.
event_id | int | Reserved for future use.
message_id | int | User-defined message ID or reference to sysmessages message that triggers this alert.
severity | int | Severity that triggers this alert.
enabled | tinyint | Status of the alert: 0 = Disabled. 1 = Enabled.
delay_between_ responses | int | Wait period, in seconds, between notifications for this alert.
last_occurrence_date | int | Last occurrence (date) of the alert.
last_occurrence_time | int | Last occurrence (time of day) of the alert.
last_response_date | int | Last notification (date) of the alert.
last_response_time | int | Last notification (time of day) of the alert.
notification_message | nvarchar(512) | Additional information sent with the alert.
include_event_ description | tinyint | Bitmask representing whether the event description is sent by either or both: 1 = E-mail. 2 = Pager.
database_name | sysname | Database in which this alert must occur to trigger this alert.
event_description_keyword | nvarchar(100) | Pattern the error must match in order for the alert to trigger.
occurrence_count | int | Number of occurrences for this alert.
count_reset_date | int | Day (date) count will be reset to 0.
count_reset_time | int | Time of day count will be reset to 0.
job_id | uniqueidentifier | ID of the task executed when this alert occurs.
has_notification | int | Number of operators who receive e-mail notification when alert occurs.
flags | int | Reserved.
performance_condition | nvarchar(512) | Reserved.
category_id | int | Reserved.

See Also

sysmessages

sysreplicationalerts

sysnotifications

syscategories


sysaltfiles

Under special circumstances, contains rows corresponding to the files in a database. This table is stored in the master database.

Column name | Data type | Description
fileid | smallint | File identification number which is unique for each database.
groupid | smallint | Filegroup identification number.
size | int | File size, in 8-KB pages.
maxsize | int | Maximum file size (in 8-KB pages). A value of 0 indicates no growth, and a value of -1 indicates that the file should grow until the disk is full.
growth | int | Growth size of the database. A value of 0 indicates no growth. Can be either the number of pages or the percentage of file size, depending on the value of status. If status is 0x100000, then growth is the percentage of file size; otherwise, it is the number of pages.
status | int | For internal use only.
perf | int | Reserved.
dbid | smallint | Database identification number of the database to which this file belongs.
name | nchar(128) | Logical name of the file.
filename | nchar(260) | Name of the physical device, including the full path of the file.


sysarticles

Contains a row for each article defined in the local database. This table is stored in the published database.

Column name | Data type | Description
artid | int | Identity column that provides a unique ID number for the article.
columns | varbinary(32) | Columns in the tables that are being published.
creation_script | nvarchar(255) | Schema script for the article.
del_cmd | nvarchar(255) | Command to execute upon DELETE; otherwise, construct from the log.
description | nvarchar(255) | Descriptive entry for the article.
dest_table | sysname | Name of the destination table.
filter | int | Stored procedure ID, used for horizontal partitioning.
filter_clause | ntext | WHERE clause of the article, used for horizontal filtering.
ins_cmd | nvarchar(255) | Command to execute upon INSERT; otherwise, construct from the log.
name | sysname | Name associated with the article, unique within the publication.
objid | int | Published table object ID.
pubid | int | ID of the publication to which the article belongs.
pre_creation_cmd | tinyint | Pre creation command for DROP TABLE, DELETE TABLE, or TRUNCATE: 0 = None . 1 = DROP. 2 = DELETE. 3 = TRUNCATE.
status | tinyint | Bitmask of the article options. status is tinyint, and can be one of these values: 0 = No additional properties. 8 = Include the column name in INSERT statements. 16 (default) = Use parameterized statements. 24 = Both include the column name in INSERT statements and use parameterized statements.
sync_objid | int | ID of the table or view that represents the article definition.
type | tinyint | Type of article: 1 = Log-based article. 3 = Log-based article with manual filter. 5 = Log-based article with manual view. 7 = Log-based article with manual filter and manual view.
upd_cmd | nvarchar(255) | Command to execute upon UPDATE; otherwise, construct from the log.
schema_option | binary(8) | Indicates what is to be scripted out.
dest_owner | sysname | Owner of the table at the destination database.

See Also

syssubscriptions

syspublications

sysarticleupdates


sysarticleupdates

Contains one row for each article that supports immediate-updating subscriptions. This table is stored in the replicated database.

Column name | Data type | Description
artid | int | Identity column providing a unique ID number for the article.
pubid | int | ID of the publication to which the article belongs.
sync_ins_proc | int | ID of the stored procedure handling Insert Sync Transactions.
sync_upd_proc | int | ID of the stored procedure handling Update Sync Transactions.
sync_del_proc | int | ID of the stored procedure handling Delete Sync Transactions.
autogen | bit | Indicates that stored procedures are automatically generated: 0 = False, not automatic. 1 = True, automatic.
sync_upd_trig | int | ID of the automatic versioning trigger on the article table.
conflict_tableid | int | ID for the conflict table.
ins_conflict_proc | int | ID of the procedure used to write the conflict to the conflict_table.
identity_support | bit | Specifies whether disables automatic identity range handling is enabled when queued updating is used. 0 means that there is no identity range support.

See Also

sysarticles

syspublications


syscacheobjects

Contains information about how the cache is used. syscacheobjects belongs to the master database. The following table shows cache lookup keys.

Column name | Data type | Description
bucketid | int | Bucket ID. Value indicates a range from 0 through (directory size - 1). Directory size is the size of the hash table.
cacheobjtype | nvarchar(34) | Type of object in the cache: Compiled Plan Executable Plan Parse Tree Cursor Parse Tree Extended Stored Procedure
objtype | nvarchar(16) | Type of object: Stored Procedure Prepared statement Ad hoc query (Transact-SQL submitted as language events from isql or osql, as opposed to remote procedure calls) ReplProc (replication procedure) Trigger View Default User table System table Check Rule
objid | int | One of the main keys used for looking up an object in the cache. This is the object ID stored in sysobjects for database objects (procedures, views, triggers, and so on). For cache objects such as ad hoc or prepared SQL, objid is an internally generated value.
dbid | smallint | Database ID in which the cache object was compiled.
uid | smallint | Indicates the creator of the plan for ad hoc query plans and prepared plans. -2 indicates the batch submitted does not depend on implicit name resolution and can be shared among different users. This is the preferred method. Any other value represents the user ID of the user submitting the query in the database.
refcounts | int | Number of other cache objects referencing this cache object. A count of 1 is the base.
usecounts | int | Number of times this cache object has been used since inception.
pagesused | int | Number of memory pages consumed by the cache object.
setopts | int | SET option settings that affect a compiled plan. These are part of the cache key. Changes to values in this column indicate users have modified SET options. These options include: ANSI_PADDING FORCEPLAN CONCAT_NULL_YIELDS_NULL ANSI_WARNINGS ANSI_NULLS QUOTED_IDENTIFIER ANSI_NULL_DFLT_ON ANSI_NULL_DFLT_OFF
langid | smallint | Language ID. ID of the language of the connection that created the cache object.
dateformat | smallint | Date format of the connection that created the cache object.
status | int | Indicates whether the cache object is a cursor plan. Currently, only the least significant bit is used.
sqlbytes | int | Length of name or batch submitted. Can be used to distinguish two names or submitted batches if the first 128 characters are the same.
sql | nvarchar(256) | Procedure name or first 128 characters of the batch submitted.

See Also

sysdatabases

sysusers

syslanguages


syscategories

Contains the categories used by SQL Server Enterprise Manager to organize jobs, alerts, and operators. This table is stored in the msdb database.

Column name | Data type | Description
category_id | int | ID of the category
category_class | int | Type of item in the category: 1 = Job 2 = Alert 3 = Operator
category_type | tinyint | Type of category: 1 = Local 2 = Multiserver 3 = None
name | sysname | Name of the category

See Also

sysalerts

sysoperators

sysjobs


syscharsets

Contains one row for each character set and sort order defined for use by Microsoft® SQL Server™. One of the sort orders is marked in sysconfigures as the default sort order, which is the only one actually in use.

Column name | Data type | Description
type | smallint | Type of entity this row represents. 1001 is a character set; 2001 is a sort order.
id | tinyint | Unique ID for the character set or sort order. Note sort orders and character sets cannot share the same ID number. The ID range of 1 through 240 is reserved for SQL Server use.
csid | tinyint | If the row represents a character set, this field is unused. If the row represents a sort order, this field is the ID of the character set that the sort order is built on. It is assumed a character set row with this ID exists in this table.
status | smallint | Internal system status information bits.
name | sysname | Unique name for the character set or sort order. This field must contain only the letters A-Z or a-z, numbers 0 - 9, and underscores(_). It must begin with a letter.
description | nvarchar(255) | Optional description of the features of the character set or sort order.
binarydefinition | varbinary(255) | For internal use only.
definition | image | Internal definition of the character set or sort order. The structure of the data in this field depends on the type.


syscolumns

Contains one row for every column in every table and view, and a row for each parameter in a stored procedure. This table is in each database.

Column name | Data type | Description
name | sysname | Name of the column or procedure parameter.
id | int | Object ID of the table to which this column belongs, or the ID of the stored procedure with which this parameter is associated.
xtype | tinyint | Physical storage type from systypes.
typestat | tinyint | For internal use only.
xusertype | smallint | ID of extended user-defined data type.
length | smallint | Maximum physical storage length from systypes.
xprec | tinyint | For internal use only.
xscale | tinyint | For internal use only.
colid | smallint | Column or parameter ID.
xoffset | smallint | For internal use only.
bitpos | tinyint | For internal use only.
reserved | tinyint | For internal use only.
colstat | smallint | For internal use only.
cdefault | int | ID of the default for this column.
domain | int | ID of the rule or CHECK constraint for this column.
number | smallint | Subprocedure number when the procedure is grouped (0 for nonprocedure entries).
colorder | smallint | For internal use only.
autoval | varbinary(255) | For internal use only.
offset | smallint | Offset into the row in which this column appears; if negative, variable-length row.
status | tinyint | Bitmap used to describe a property of the column or the parameter: 0x08 = Column allows null values. 0x10 = ANSI padding was in effect when varchar or varbinary columns were added. Trailing blanks are preserved for varchar and trailing zeros are preserved for varbinary columns. 0x40 = Parameter is an OUTPUT parameter. 0x80 = Column is an identity column.
type | tinyint | Physical storage type from systypes.
usertype | smallint | ID of user-defined data type from systypes.
printfmt | varchar(255) | For internal use only.
prec | smallint | Level of precision for this column.
scale | int | Scale for this column.
iscomputed | int | Flag indicating whether the column is computed: 0 = Noncomputed. 1 = Computed.
isoutparam | int | Indicates whether the procedure parameter is an output parameter: 1 = True. 0 = False.
isnullable | int | Indicates whether the column allows null values: 1 = True. 0 = False.

See Also

systypes

syscomments

sysdepends

sysconstraints

sysforeignkeys

sysobjects

sysreferences


syscomments

Contains entries for each view, rule, default, trigger, CHECK constraint, DEFAULT constraint, and stored procedure. The text column contains the original SQL definition statements, which are limited to a maximum size of 4 MB. This table is stored in each database.

Important None of the entries in syscomments should be deleted. If an entry in syscomments is manually removed or modified, the corresponding stored procedure will not function properly. To hide or encrypt stored procedure definitions, use CREATE PROCEDURE with the ENCRYPTION keyword.

Column name | Data type | Description
id | int | Object ID to which this text applies.
number | smallint | Number within procedure grouping, if grouped. 0 for entries that are not procedures.
colid | smallint | Row sequence number for object definitions longer than 4,000 characters.
status | smallint | For internal use only.
ctext | varbinary(8000) | Actual text of the SQL definition statement.
texttype | smallint | 0 = User-supplied comment. 1 = System-supplied comment. 4 = Encrypted comment.
language | smallint | For internal use only.
encrypted | bit | Indicates whether the procedure is encrypted. 0 = Not encrypted. 1 = Encrypted.
compressed | bit | Indicates whether or not the procedure is compressed. 0 = Not compressed 1 = Compressed
text | nvarchar(4000) | Actual text of the SQL definition statement.

See Also

syscolumns

sysobjects


sysconfigures

Contains one row for each configuration option set by a user. sysconfigures contains the configuration options defined before the most recent Microsoft® SQL Server™ startup, plus any dynamic configuration options set since then. This table is only in the master database.

Column name | Data type | Description
value | int | User-modifiable value for the variable (being used by SQL Server only if RECONFIGURE has been executed).
config | smallint | Configuration variable number.
comment | nvarchar(255) | Explanation of the configuration option.
status | smallint | Bitmap indicating the status for the option. Possible values include: 0 = Static (The setting takes effect when the server is restarted.). 1 = Dynamic (The variable takes effect when the RECONFIGURE statement is executed.). 2 = Advanced (The variable is displayed only when the show advanced option is set.). 3 = Dynamic and advanced.

See Also

syscurconfigs


sysconstraints

Contains mappings of constraints to the objects that own the constraints. This system catalog is stored in each database.

Column name | Data type | Description
constid | int | Constraint number.
id | int | ID of the table that owns the constraint.
colid | smallint | ID of the column on which the constraint is defined, 0 if a table constraint.
spare1 | tinyint | Reserved.
status | int | Bitmap indicating the status. Possible values include: 1 = PRIMARY KEY constraint. 2 = UNIQUE KEY constraint. 3 = FOREIGN KEY constraint. 4 = CHECK constraint. 5 = DEFAULT constraint. 16 = Column-level constraint. 32 = Table-level constraint.
actions | int | Reserved.
error | int | Reserved.

See Also

syscolumns

sysobjects


syscurconfigs

Contains an entry for each of the current configuration options. In addition, this table contains four entries that describe the configuration structure. syscurconfigs is built dynamically when queried by a user. For more information, see sysconfigures.

Column name | Data type | Description
value | int | User-modifiable value for the variable (being used by Microsoft® SQL Server™ only if RECONFIGURE has been executed).
config | smallint | Configuration variable number.
comment | nvarchar(255) | Explanation of the configuration option.
status | smallint | Bitmap indicating the status for the option. Possible values include: 0 = Static (The setting takes effect when the server is restarted.). 1 = Dynamic (The variable takes effect when the RECONFIGURE statement is executed.). 2 = Advanced (The variable is displayed only when the show advanced option is set.). 3 = Dynamic and advanced.

See Also

sysconfigures


sysdatabases

Contains one row for each database on Microsoft® SQL Server™. When SQL Server is initially installed, sysdatabases contains entries for the master, model, msdb, mssqlweb, and tempdb databases. This table is stored only in the master database.

Column name | Data type | Description
name | sysname | Name of the database.
dbid | smallint | Database ID.
sid | varbinary(85) | System ID of the database creator.
mode | smallint | Used internally for locking a database while it is being created.
status | int | Status bits, some of which can be set by the user with sp_dboption (read only, dbo use only, single user, and so on): 1 = autoclose; set with sp_dboption. 4 = select into/bulkcopy; set with sp_dboption. 8 = trunc. log on chkpt; set with sp_dboption. 16 = torn page detection, set with sp_dboption. 32 = loading. 64 = pre recovery. 128 = recovering. 256 = not recovered. 512 = offline; set with sp_dboption. 1024 = read only; set with sp_dboption. 2048 = dbo use only; set with sp_dboption. 4096 = single user; set with sp_dboption. 32768 = emergency mode. 4194304 = autoshrink. 1073741824 = cleanly shutdown. Multiple bits can be on at the same time.
status2 | int | 16384 = ANSI null default; set with sp_dboption. 65536 = concat null yields null , set with sp_dboption. 131072 = recursive triggers, set with sp_dboption. 1048576 = default to local cursor, set with sp_dboption. 8388608 = quoted identifier, set with sp_dboption. 33554432 = cursor close on commit, set with sp_dboption. 67108864 = ANSI nulls, set with sp_dboption. 268435456 = ANSI warnings, set with sp_dboption. 536870912 = full text enabled, set with sp_fulltext_database.
crdate | datetime | Creation date.
reserved | datetime | Reserved for future use.
category | int | Contains a bitmap of information used for replication: 1 = Published. 2 = Subscribed. 4 = Merge Published. 8 = Merge Subscribed.
cmptlevel | tinyint | Compatibility level for the database.
filename | nvarchar(260) | Operating-system path and name for the database's primary file.
version | smallint | Internal version number of the SQL Server code with which the database was created. For internal use only by SQL Server tools and in upgrade processing.

See Also

syscacheobjects

syslockinfo

sysprocesses


sysdbmaintplan_databases

Contains one row for each database that has an associated maintenance plan. This table is stored in the msdb database.

Column name | Data type | Description
plan_id | uniqueidentifier | Maintenance plan ID.
database_name | sysname | Name of the database associated with the maintenance plan.

See Also

sysdbmaintplans


sysdbmaintplan_history

Contains one row for each maintenance plan action performed. This table is stored in the msdb database.

Column name | Data type | Description
sequence_id | int | Sequence of history performed by maintenance plans.
plan_id | uniqueidentifier | Maintenance plan ID.
plan_name | sysname | Maintenance plan name.
database_name | sysname | Name of the database associated with the maintenance plan.
server_name | sysname | System name.
activity | nvarchar(128) | Activity performed by the maintenance plan (for example, Backup transaction log, and so on.).
succeeded | bit | 0 = Success 1 = Failure
end_time | datetime | Time at which action completed.
duration | int | Length of time required to complete maintenance plan action.
start_time | datetime | Time at which action began.
error_number | int | Error number reported on failure.
message | nvarchar(512) | Message generated by sqlmaint.

See Also

sysdbmaintplans


sysdbmaintplan_jobs

Contains one row for each maintenance plan job. This table is stored in the msdb database.

Column name | Data type | Description
plan_id | uniqueidentifier | Maintenance plan ID.
job_id | uniqueidentifier | ID of a job associated with the maintenance plan.

See Also

sysjobs

sysdbmaintplans


sysdbmaintplans

Contains one row for each database maintenance plan. This table is stored in the msdb database.

Column name | Data type | Description
plan_id | uniqueidentifier | Maintenance plan ID.
plan_name | sysname | Maintenance plan name.
date_created | datetime | Date the maintenance plan was created.
owner | sysname | Owner of the maintenance plan.
max_history_rows | int | Maximum number of rows allotted for recording the history of the maintenance plan in the system table.
remote_history_server | sysname | Name of the remote server to which the history report could be written.
max_remote_history_rows | int | Maximum number of rows allotted in the system table on a remote server to which the history report could be written.
user_defined_1 | int | Default is NULL.
user_defined_2 | nvarchar(100) | Default is NULL.
user_defined_3 | datetime | Default is NULL.
user_defined_4 | uniqueidentifier | Default is NULL.
log_shipping | bit | Log shipping status: 0 = Disabled 1 = Enabled

See Also

sysdbmaintplan_jobs

sysdbmaintplan_history

sysdbmaintplan_databases


sysdepends

Contains dependency information between objects (views, procedures, and triggers), and the objects (tables, views, and procedures) contained in their definition. This table is stored in each database.

Column name | Data type | Description
id | int | Object ID.
depid | int | Dependent object ID.
number | smallint | Procedure number.
depnumber | smallint | Dependent procedure number.
status | smallint | Internal status information.
depdbid | smallint | Reserved.
depsiteid | smallint | Reserved.
selall | bit | On, if the object is used in a SELECT * statement.
resultobj | bit | On, if the object is being updated.
readobj | bit | On, if the object is being read.

See Also

syscolumns

sysobjects


sysdevices

Contains one row for each disk backup file, tape backup file, and database file. This table is stored only in the master database.

Important This system table provides backward compatibility information. In earlier versions of Microsoft® SQL Server™, this table contained a list of all database files. For SQL Server version 7.0, a list of database files is stored in the sysfiles system table of each database.

Column name | Data type | Description
name | sysname | Logical name of the backup file or database file.
size | int | Size of the file in 2 kilobyte (KB) pages.
low | int | Maintained for backward compatibility only.
high | int | Maintained for backward compatibility only.
status | smallint | Bitmap indicating the type of device: 1 = Default disk 2 = Physical disk 4 = Logical disk 8 = Skip header 16 = Backup file 32 = Serial writes 4096 = Read-only
cntrltype | smallint | Controller type: 0 = Non-CD-ROM database file 2 = Disk backup file 3 - 4 = Diskette backup file 5 = Tape backup file 6 = Named-pipe file
phyname | nvarchar(260) | Name of the physical file.


sysdownloadlist

Holds the queue of download instructions for all target servers.

Column name | Data type | Description
instance_id | int | Identity column that provides the natural insertion sequence of rows.
source_server | nvarchar(30) | Name of the source server.
operation_code | tinyint | Operation code for the job: 1 = INS (INSERT) 2 = UPD (UPDATE) 3 = DEL (DELETE) 4 = START 5 = STOP
object_type | tinyint | Object type code. For Microsoft® SQL Server™ version 7.0, this value can be 1, which corresponds to JOB.
object_id1 | uniqueidentifier | Object identification number.
target_server | nvarchar(30) | Name of the target server.
error_message | nvarchar(1024) | Error message if the target server encounters an error when processing the particular row.
date_posted | datetime | Date and time the job was posted to the target server.
date_downloaded | datetime | Date and time job was last downloaded.
status | tinyint | Status of the job: 0 = Not yet downloaded 1 = Successfully downloaded
deleted_object_name | sysname | Name of deleted object.

  1. The object_id column can be a value of -1, which corresponds to a value of ALL if the operation_code column is a value of DELETE.

See Also

systargetservers


sysfiles

Contains one row for each file in a database. This system table is a virtual table; it cannot be updated or modified directly.

Column name | Data type | Description
fileid | smallint | File identification number unique for each database.
groupid | smallint | Filegroup identification number.
size | int | Size of the file (in 8-KB pages).
maxsize | int | Maximum file size (in 8-KB pages). A value of 0 indicates no growth, and a value of -1 indicates that the file should grow until the disk is full.
growth | int | Growth size of the database. A value of 0 indicates no growth. Can be either the number of pages or the percentage of file size, depending on value of status. If status contains 0x100000, then growth is the percentage of file size; otherwise, it is the number of pages.
status | int | Status bits for the growth value in either megabytes (MB) or kilobytes (K). 0x1 = Default device. 0x2 = Disk file. 0x40 = Log device. 0x80 = File has been written to since last backup. 0x4000 = Device created implicitly by the CREATE DATABASE statement. 0x8000 = Device created during database creation. 0x100000 = Growth is in percentage, not pages.
perf | int | Reserved.
name | nchar(128) | Logical name of the file.
filename | nchar(260) | Name of the physical device, including the full path of the file.

See Also

sysfilegroups


sysfilegroups

Contains one row for each filegroup in a database. This table is stored in each database. There is at least one entry in this table that is for the primary filegroup.

Column name | Data type | Description
groupid | smallint | Group identification number unique for each database.
allocpolicy | smallint | Reserved.
status | int | 0x8 = READ ONLY 0x10 = DEFAULT
groupname | sysname | Name of the filegroup.

See Also

sysindexes

sysfiles


sysforeignkeys

Contains information regarding the FOREIGN KEY constraints that are in table definitions. This table is stored in each database.

Column name | Data type | Description
constid | int | ID of the FOREIGN KEY constraint.
fkeyid | int | Object ID of the table with the FOREIGN KEY constraint.
rkeyid | int | Object ID of the table referenced in the FOREIGN KEY constraint.
fkey | smallint | ID of the referencing column.
rkey | smallint | ID of the referenced column.
keyno | smallint | Position of the column in the reference column list.

See Also

syscolumns

sysobjects


sysfulltextcatalogs

Lists the set of full-text catalogs.

Column name | Data type | Description
ftcatid | smallint | Identifier of the full-text catalog.
name | sysname | Full-text catalog name given by the user.
status | smallint | Reserved; internal use only.
path | nvarchar(260) | Root path given by the user. A value of NULL means a path was not given and the default (installation) path was used.

See Also

sysobjects


sysindexes

Contains one row for each index and table in the database. This table is stored in each database.

Column name | Data type | Description
id | int | ID of table (for indid = 0 or 255). Otherwise, ID of table to which the index belongs.
status | int | Internal system-status information.
first | binary(6) | Pointer to the first or root page.
indid | smallint | ID of index: 1 = Clustered index >1 = Nonclustered 255 = Entry for tables that have text or image data
root | binary(6) | For indid >= 1 and < 255, root is the pointer to the root page. For indid = 0 or indid = 255, root is the pointer to the last page.
minlen | smallint | Minimum size of a row.
keycnt | smallint | Number of keys.
groupid | smallint | Filegroup ID on which the object was created.
dpages | int | For indid = 0 or indid = 1, dpages is the count of data pages used. For indid=255, it is set to 0. Otherwise, it is the count of index pages used.
reserved | int | For indid = 0 or indid = 1, reserved is the count of pages allocated for all indexes and table data. For indid = 255, reserved is a count of the pages allocated for text or image data. Otherwise, it is the count of pages allocated for the index.
used | int | For indid = 0 or indid = 1, used is the count of the total pages used for all index and table data. For indid = 255, used is a count of the pages used for text or image data. Otherwise, it is the count of pages used for the index.
rowcnt | bigint | Data-level rowcount based on indid = 0 and indid = 1. For indid = 255, rowcnt is set to 0.
rowmodctr | int | Counts the total number of inserted, deleted, or updated rows since the last time statistics were updated for the table.
xmaxlen | smallint | Maximum size of a row.
maxirow | smallint | Maximum size of a nonleaf index row.
OrigFillFactor | tinyint | Original fillfactor value used when the index was created. This value is not maintained; however, it can be helpful if you need to re-create an index and do not remember what fillfactor was used.
reserved1 | tinyint | Reserved.
reserved2 | int | Reserved.
FirstIAM | binary(6) | Reserved.
impid | smallint | Reserved. Index implementation flag.
lockflags | smallint | Used to constrain the considered lock granularities for an index. For example, a lookup table that is essentially read-only could be set up to do only table level locking to minimize locking cost.
pgmodctr | int | Reserved.
keys | varbinary(816) | List of the column IDs of the columns that make up the index key.
name | sysname | Name of table (for indid = 0 or 255). Otherwise, name of index.
statblob | image | Statistics BLOB.
maxlen | int | Reserved.
rows | int | Data-level rowcount based on indid = 0 and indid = 1, and the value is repeated for indid >1. For indid = 255, rows is set to 0. Provided for backward compatibility.

See Also

sysindexkeys

sysreferences

sysobjects

sysfilegroups

syslockinfo


sysindexkeys

Contains information for the keys or columns in an index. This table is stored in each database.

Column name | Data type | Description
id | int | ID of the table
indid | smallint | ID of the index
colid | smallint | ID of the column
keyno | smallint | Position of the column in the index

See Also

sysindexes


sysjobhistory

Contains information about the execution of scheduled jobs by SQL Server Agent. This table is stored in the msdb database.

Column name | Data type | Description
instance_id | int | Unique identifier for the row.
job_id | uniqueidentifier | Job ID.
step_id | int | ID of the step in the job.
step_name | sysname | Name of the step.
sql_message_id | int | ID of any Microsoft® SQL Server™ error message returned if the job failed.
sql_severity | int | Severity of any SQL Server error.
message | nvarchar(1024) | Text, if any, of a SQL Server error.
run_status | int | Status of the job execution: 0 = Failed 1 = Succeeded 2 = Retry 3 = Canceled 4 = In progress
run_date | int | Date the job or step started execution. For an In Progress history, this is the date/time the history was written.
run_time | int | Time the job or step completed.
run_duration | int | Elapsed time in the execution of the job or step in HHMMSS format.
operator_id_emailed | int | ID of the operator notified when the job completed.
operator_id_netsent | int | ID of the operator notified by a message when the job completed.
operator_id_paged | int | ID of the operator notified by pager when the job completed.
retries_attempted | int | Number of retry attempts for the job or step.
server | nvarchar(30) | Name of the server where the job was executed.

See Also

sysjobs


sysjobschedules

Contains schedule information for jobs to be executed by SQL Server Agent. This table is stored in the msdb database.

Column name | Data type | Description
schedule_id | int | ID of the schedule.
job_id | uniqueidentifier | ID of the job.
name | sysname | Name of the schedule.
enabled | int | Enabled status of the schedule.
freq_type int Frequency of the schedule execution:

1 = Once
4 = Daily
8 = Weekly
16 = Monthly
32 = Monthly relative
64 = When SQL Server
Agent starts
freq_interval int Value indicating on which days the schedule runs.

If freq_type is 4 (daily), the value is every freq_interval days.

If freq_type is 8 (weekly), the value is a bitmask indicating the days in which weekly schedules are run. The freq_interval values are:

1 = Sunday
2 = Monday
4 = Tuesday
8 = Wednesday
16 = Thursday
32 = Friday
64 = Saturday

If freq_type is 16 (monthly), the value is freq_interval day of the month.

If freq_type is 32 (monthly relative), freq_interval can be one of these values:

1 = Sunday
2 = Monday
3 = Tuesday
4 = Wednesday
5 = Thursday
6 = Friday
7 = Saturday
8 = Day
9 = Weekday
10 = Weekend day
freq_subday_type int Units for the freq_subday_interval:

1 = At the specified time
2 = Seconds
4 = Minutes
8 = Hours
freq_subday_interval | int | Number of freq_subday_type periods to occur between each scheduled execution of the job.
freq_relative_
interval 		int Scheduled job's occurrence of the freq_interval in each month when freq_type is 32 (monthly relative):
1 = First
2 = Second
4 = Third
8 = Fourth
16 = Last
freq_recurrence_
factor 		int Number of weeks or months between the scheduled execution of the job.
active_start_date | int | Date to begin executing the job.
active_end_date | int | Date to stop executing the job.
active_start_time | int | Time to start executing the job.
active_end_time | int | Time to stop executing the job.
next_run_date | int | Date that the job will next execute.
next_run_time | int | Time that the job will next execute.
date_created | datetime | Date the scheduled job entry was created.

See Also

sysjobs


sysjobs

Stores the information for each scheduled job to be executed by SQL Server Agent. This table is stored in the msdb database.

Column name | Data type | Description
job_id | uniqueidentifier | Unique ID of the job.
originating_server | nvarchar(30) | Name of the server from which the job came.
name | sysname | Name of the job.
enabled | tinyint | Indicates whether the job is enabled to be executed.
description | nvarchar(512) | Description for the job.
start_step_id | int | ID of the step in the job where execution should begin.
category_id | int | ID of the job category.
owner_sid | varbinary(85) | System identification number (SID) of the job owner.
notify_level_ eventlog | int | Bitmask indicating under what circumstances a notification event should be logged to the Microsoft® Windows NT® application log: 0 = Never 1 = When the job succeeds 2 = When the job fails 3 = Whenever the job completes (regardless of the job outcome)
notify_level_email | int | Bitmask indicating under what circumstances a notification e-mail should be sent when a job completes: 0 = Never 1 = When the job succeeds 2 = When the job fails 3 = Whenever the job completes (regardless of the job outcome)
notify_level_netsend | int | Bitmask indicating under what circumstances a network message should be sent when a job completes: 0 = Never 1 = When the job succeeds 2 = When the job fails 3 = Whenever the job completes (regardless of the job outcome)
notify_level_page | int | Bitmask indicating under what circumstances a page should be sent when a job completes: 0 = Never 1 = When the job succeeds 2 = When the job fails 3 = Whenever the job completes (regardless of the job outcome)
notify_email_ operator_id | int | E-mail name of the operator to notify.
notify_netsend_ operator_id | int | ID of the computer or user used when sending network messages.
notify_page_ operator_id | int | ID of the computer or user used when sending a page.
delete_level | int | Bitmask indicating under what circumstances the job should be deleted when a job completes: 0 = Never 1 = When the job succeeds 2 = When the job fails 3 = Whenever the job completes (regardless of the job outcome)
date_created | datetime | Date the job was created.
date_modified | datetime | Date the job was last modified.
version_number | int | Version of the job.

See Also

systaskids

sysjobsteps

syscategories

sysdbmaintplan_jobs

sysjobschedules

sysjobhistory

sysjobservers


sysjobservers

Stores the association or relationship of a particular job with one or more target servers.

Column name | Data type | Description
job_id | uniqueidentifier | Job identification number.
server_id | int | Server identification number.
last_run_outcome | tinyint | Outcome for the job's last run: 0 = Succeed 1 = Fail 2 = Cancel
last_outcome_ message | nvarchar(1024) | Associated message, if any, with the last_run_outcome column.
last_run_date | int | Date the job was last run.
last_run_time | int | Time the job was last run.
last_run_duration | int | Duration of the job's run, in seconds.

See Also

sysjobs

systargetservers


sysjobsteps

Contains the information for each step in a job to be executed by SQL Server Agent. This table is stored in the msdb database.

Column name | Data type | Description
job_id | uniqueidentifier | ID of the job.
step_id | int | ID of the step in the job.
step_name | sysname | Name of the job step.
subsystem | nvarchar(40) | Name of the subsystem used by SQL Server Agent to execute the job step.
command | nvarchar(3200) | Command to be executed by subsystem.
flags | int | Reserved.
additional_ parameters | ntext | Reserved.
cmdexec_success_ code | int | Error-level value returned by CmdExec subsystem steps to indicate success.
on_success_action | tinyint | Action to be performed when a step is executed successfully.
on_success_step_id | int | ID of the next step to execute when a step is executed successfully.
on_fail_action | tinyint | Action to be performed when a step is not executed successfully.
on_fail_step_id | int | ID of the next step to execute when a step is not executed successfully.
server | sysname | Reserved.
database_name | sysname | Name of the database in which command is executed if subsystem is TSQL.
database_user_name | sysname | Name of the database user whose account will be used when executing the step.
retry_attempts | int | Number of retry attempts made if the step fails.
retry_interval | int | Amount of time to wait between retry attempts.
os_run_priority | int | Reserved.
output_file_name | nvarchar(200) | Name of the file in which the step's output is saved when subsystem is TSQL or CmdExec.
last_run_outcome | int | Outcome of the previous execution of the job step.
last_run_duration | int | Amount of time incurred in the previous execution of the job.
last_run_retries | int | Number of retry attempts in the last execution of the job step.
last_run_date | int | Date of the job step's previous execution.
last_run_time | int | Time of the job step's previous execution.

See Also

sysjobs


syslanguages

Contains one row for each language present in Microsoft® SQL Server™. Although U.S. English is not in syslanguages, it is always available to SQL Server. This table is stored only in the master database.

Column name | Data type | Description
langid | smallint | Unique language ID.
dateformat | nchar(3) | Date order (for example, DMY).
datefirst | tinyint | First day of the week: 1 for Monday, 2 for Tuesday, and so on through 7 for Sunday.
upgrade | int | Reserved for system use.
name | sysname | Official language name (for example, français).
alias | sysname | Alternate language name (for example, French).
months | nvarchar(372) | Comma-separated list of full-length month names in order from January through December, with each name containing as many as 20 characters.
shortmonths | varchar(132) | Comma-separated list of short-month names in order from January through December, with each name containing as many as 9 characters.
days | nvarchar(217) | Comma-separated list of day names in order from Monday through Sunday, with each name containing as many as 30 characters.
lcid | int | Microsoft Windows NT® locale ID for the language.
mslangid | smallint | SQL Server message group ID.

Thirty-three SQL Server provided languages are installed. Here is a list of the languages.

Name in English | NT LCID | SQL Server Message Group ID
English | 1033 | 1033
German | 1031 | 1031
French | 1036 | 1036
Japanese | 1041 | 1041
Danish | 1030 | 1030
Spanish | 3082 | 3082
Italian | 1040 | 1040
Dutch | 1043 | 1043
Norwegian | 2068 | 2068
Portuguese | 2070 | 2070
Finnish | 1035 | 1035
Swedish | 1053 | 1053
Czech | 1029 | 1029
Hungarian | 1038 | 1038
Polish | 1045 | 1045
Romanian | 1048 | 1048
Croatian | 1050 | 1050
Slovak | 1051 | 1051
Slovene | 1060 | 1060
Greek | 1032 | 1032
Bulgarian | 1026 | 1026
Russian | 1049 | 1049
Turkish | 1055 | 1055
British English | 2057 | 1033
Estonian | 1061 | 1061
Latvian | 1062 | 1062
Lithuanian | 1063 | 1063
Brazilian | 1046 | 1046
Traditional Chinese | 1028 | 1028
Korean | 1042 | 1042
Simplified Chinese | 2052 | 2052
Arabic | 1025 | 1025
Thai | 1054 | 1054

See Also

sysmessages

syscacheobjects


syslockinfo

Contains information on all granted, converting, and waiting lock requests. This table is a denormalized tabular view of internal data structures of the lock manager, and is stored only in the master database.

Column name | Data type | Description
rsc_text | nchar(32) | Textual description of a lock resource. Contains a portion of the resource name.
rsc_bin | binary(16) | Binary lock resource. Contains the actual lock resource that is contained in the lock manager. This column is included for tools that are aware of the lock resource format for generating their own formatted lock resource, and for performing self joins on syslockinfo.
rsc_valblk | binary(16) | Lock value block. Some resource types may include additional data in the lock resource that is not hashed by the lock manager to determine ownership of a particular lock resource. For example, page locks are not owned by a particular object ID. For lock escalation and other purposes, however, the object ID of a page lock may be placed in the lock value block.
rsc_dbid | smallint | Database ID associated with the resource.
rsc_indid | smallint | Index ID associated with the resource, if appropriate.
rsc_objid | int | Object ID associated with the resource, if appropriate.
rsc_type tinyint Resource type. Can be:

1 = NULL Resource (not used).
2 = Database.
3 = File.
4 = Index.
5 = Table.
6 = Page.
7 = Key.
8 = Extent.
9 = RID (Row ID).
10 = Application.
rsc_flag | tinyint | Internal resource flags.
req_mode tinyint Lock request mode. This column is the lock mode of the requester and represents either the granted mode, or the convert or waiting mode. Can be:

0 = NULL. No access is granted to the resource. Serves as a placeholder.
1 = Sch-S (Schema stability). Ensures that a schema element, such as a table or index, is not dropped while any session holds a schema stability lock on the schema element.
2 = Sch-M (Schema modification). Must be held by any session that wants to change the schema of the specified resource. Ensures that no other sessions are referencing the indicated object.
3 = S (Shared). The holding session is granted shared access to the resource.
4 = U (Update). Indicates an update lock acquired on resources that may eventually be updated. It is used to prevent a common form of deadlock that occurs when multiple sessions lock resources for potential update at a later time.
5= X (Exclusive). The holding session is granted exclusive access to the resource.
6 = IS (Intent Shared). Indicates the intention to place S locks on some subordinate resource in the lock hierarchy.
7= IU (Intent Update). Indicates the intention to place U locks on some subordinate resource in the lock hierarchy.
8= IX (Intent Exclusive). Indicates the intention to place X locks on some subordinate resource in the lock hierarchy.
9 = SIU (Shared Intent Update). Indicates shared access to a resource with the intent of acquiring update locks on subordinate resources in the lock hierarchy.
10 = SIX (Shared Intent Exclusive). Indicates shared access to a resource with the intent of acquiring exclusive locks on subordinate resources in the lock hierarchy.
11 = UIX (Update Intent Exclusive). Indicates an update lock hold on a resource with the intent of acquiring exclusive locks on subordinate resources in the lock hierarchy.
12 = BU. Used by bulk operations.
13 = RangeS_S (Shared Key-Range and Shared Resource lock). Indicates serializable range scan.
14 = RangeS_U (Shared Key-Range and Update Resource lock). Indicates serializable update scan.
15 = RangeI_N (Insert Key-Range and Null Resource lock). Used to test ranges before inserting a new key into an index.
16 = RangeI_S. Key-Range Conversion lock, created by an overlap of RangeI_N and S locks.
17 = RangeI_U. Key-Range Conversion lock, created by an overlap of RangeI_N and U locks.
18 = RangeI_X. Key-Range Conversion lock, created by an overlap of RangeI_N and X locks.
19 = RangeX_S. Key-Range Conversion lock, created by an overlap of RangeI_N and RangeS_S. locks.
20 = RangeX_U. Key-Range Conversion lock, created by an overlap of RangeI_N and RangeS_U locks.
21 = RangeX_X (Exclusive Key-Range and Exclusive Resource lock). This is a conversion lock used when updating a key in a range.
req_status tinyint Status of the lock request. Can be:

1 = Granted.
2 = Converting.
3 = Waiting.
req_refcnt | smallint | Lock reference count. Each time a transaction asks for a lock on a particular resource, a reference count is incremented. The lock cannot be released until the reference count equals 0.
req_cryrefcnt | smallint | Reserved for future used. Always set to 0.
req_lifetime | int | Lock lifetime bitmap. During certain query processing strategies, locks must be maintained on resources until the query processor has completed a particular phase of the query. The lock lifetime bitmap is used by the query processor and transaction manager to denote groups of locks that can be released when a certain phase of a query is completed. Certain bits in the bitmap are used to denote locks that are held until the end of a transaction, even if their reference count equals 0.
req_spid | int | Internal Microsoft® SQL Server™ process ID of the session requesting the lock.
req_ecid | int | Execution context ID (ECID). Used to denote which thread in a parallel operation owns a particular lock.
req_ownertype smallint Type of object associated with the lock. Can be one of the following:

1 = Transaction.
2 = Cursor.
3 = Session.
4 = ExSession.

Note that 3 and 4 represent a special version of session locks, tracking database and filegroup locks respectively.
req_transactionID | bigint | Unique transaction ID used in syslockinfo and in profiler event
req_transactionUOW | uniqueidentifier | Identifies the Unit of Work ID (UOW) of the DTC transaction. For non MS DTC transactions, UOW is set to 0.

See Also

sysdatabases

sysobjects

sysprocesses

sysindexes


syslogins

Contains one row for each login account.

Column name | Data type | Description
sid | varbinary(85) | Security identifier.
status | smallint | For internal use only.
createdate | datetime | Date the login was added.
updatedate | datetime | Date the login was updated.
accdate | datetime | For internal use only.
totcpu | int | For internal use only.
totio | int | For internal use only.
spacelimit | int | For internal use only.
timelimit | int | For internal use only.
resultlimit | int | For internal use only.
name | varchar(30) | Login ID of the user.
dbname | nvarchar(128) | Name of the user's default database when connection is established.
password | nvarchar(128) | Encrypted password of the user (may be NULL).
language | nvarchar(128) | User's default language.
denylogin | int | 1, if login is a Microsoft® Windows NT® user or group and has been denied access.
hasaccess | int | 1, if login has been granted access to the server.
isntname | int | 1 if login is a Windows NT user or group; 0 if the login is a Microsoft SQL Server™ login.
isntgroup | int | 1, if login is a Windows NT group.
isntuser | int | 1, if login is a Windows NT user.
sysadmin | int | 1, if login is a member of the sysadmin server role.
securityadmin | int | 1, if login is a member of the securityadmin server role.
serveradmin | int | 1, if login is a member of the serveradmin fixed server role.
setupadmin | int | 1, if login is a member of the setupadmin fixed server role.
processadmin | int | 1, if login is a member of the processadmin fixed server role.
diskadmin | int | 1, if login is a member of the diskadmin fixed server role.
dbcreator | int | 1, if login is a member of the dbcreator fixed server role.
loginname | nvarchar(128) | Actual name of the login, which may be different from the login name used by SQL Server.

See Also

sysremotelogins

sysoledbusers

sysusers


sysmembers

Contains a row for each member of a database role. This table is stored in each database.

Column name | Data type | Description
memberuid | smallint | User ID for the role member.
groupuid | smallint | User ID for the role.

See Also

sysusers


sysmergearticles

Contains one row for each merge article defined in the local database. This table is stored in the publication database.

Column name | Data type | Description
name | sysname | Name of the article.
type | tinyint | Article type.
objid | int | Object identifier.
sync_objid | int | Object ID of the view representing the synchronized data set.
view_type | tinyint | Type of view: 0 = Not a view; use all of base object. 1 = Permanent view. 2 = Temporary view.
artid | uniqueidentifier | Identity column used to provide a unique identification number for the given article. artid is derived from sysobjects.srcid.
description | nvarchar(255) | Brief description of the article.
pre_creation_ command | nvarchar(10) | Default action to take when the article is created in the subscription database: None = If the table already exists at the Subscriber, no action is taken. Delete = Issues a delete based on the WHERE clause in the subset filter. Drop (default) = Drops the table before re-creating it. Truncate = Same as delete, but deletes pages instead of rows. However, does not take a WHERE clause.
pubid | uniqueidentifier | ID of the publication to which the current article belongs.
nickname | int | Nickname mapping for article identification.
column_tracking | int | Indicates whether column tracking is implemented for the article.
status | tinyint | Bitmap used to indicate the status of the article.
conflict_table | sysname | Name of the local table that contains the conflicting records for the current article. This table is supplied for information only, and its contents may be modified or deleted by custom conflict resolution routines or directly by the administrator.
creation_script | nvarchar(255) | Creation script for this article.
conflict_script | nvarchar(255) | Conflict script for this article.
article_resolver | nvarchar(255) | Custom row-level conflict resolver for this article.
ins_conflict_proc | sysname | Procedure used to write conflict to conflict_table.
insert_proc | sysname | Procedure used by the default conflict resolver to insert rows during synchronization.
update_proc | sysname | Procedure used by the default conflict resolver to update rows during synchronization.
select_proc | sysname | Name of an automatically generated stored procedure that the Merge Agent uses to accomplish locking, and finding columns and rows for an article.
schema_option | binary(8) | Indicates what is to be scripted out.
destination_ object | sysname | Name of the table created at the Subscriber.
destination_owner | sysname | Name of the owner of the destination object.
resolver_clsid | nvarchar(1000) | ID of the custom conflict resolver.
subset_ filterclause | nvarchar(2000) | Filter clause for this article.
missing_col_ count | int | Number of missing columns.
missing_cols | varbinary(128) | Bitmap of missing columns.
excluded_cols | varbinary(128) | Bitmap of the columns excluded from the article when it is sent to the Subscriber.
excluded_col_count | int | Number of columns excluded.
columns | varbinary(128) | Reserved for future use.
resolver_info | sysname | Storage for additional information required by custom conflict resolvers.
view_sel_proc | nvarchar(290) | The name of a stored procedure that the Merge Agent uses for doing the initial population of an article in a dynamically filtered publication, and for enumerating changed rows in any filtered publication.
gen_cur | int | Generate number for local changes to the base table of an article.
vertical_partition | int | Specifies whether column filtering is enabled on a table article. 0 indicates there is no vertical filtering and publishes all columns.
identity_support | int | Specifies whether automatic identity range handling is enabled when queued updating is used. 0 means that there is no identity range support.
before_image_objid | int | Tracking table object ID. The tracking table contains certain key column values when a publication is created with @keep_partition_changes = true.
before_view_objid | int | Object ID of a view table. The view is on a table that tracks whether a row belonged at a particular Subscriber before it was deleted or updated. Applies only when a publication is created with @keep_partition_changes = true.
verify_resolver_signature | int | Specifies whether a digital signature is verified before using a resolver in merge replication: 0 = Signature will not be verified. 1 = Signature will be verified to see whether it is from a trusted source.
allow_interactive_resolver | bit | Specifies whether the use of the Interactive Resolver on an article is enabled. 1 specifies that the Interactive Resolver will be used on the article.
fast_multicol_updateproc | bit | Specifies whether the Merge Agent has been enabled to apply changes to multiple columns in the same row in one UPDATE statement. 0 = Issues a separate UPDATE for each column changed. 1 = Issued on UPDATE statement which causes updates to occur to multiple columns in one statement.
check_permissions | int | Bitmap of the table-level permissions that will be verified when the Merge Agent applies changes to the Publisher. check_permissions can have one of these values: 0x00 = Permissions will not be checked. 0x10 = Checks permissions at the Publisher before INSERTs made at a Subscriber can be uploaded. 0x20 = Checks permissions at the Publisher before UPDATEs made at a Subscriber can be uploaded. 0x40 = Checks permissions at the Publisher before DELETEs made at a Subscriber can be uploaded.

See Also

sysmergesubsetfilters

sysmergeschemachange

sysmergepublications


sysmergepublications

Contains one row for each merge publication defined in the database. This table is stored in the publication and subscription databases.

Column name | Data type | Description
publisher | sysname | Name of the default server.
publisher_db | sysname | Name of the default Publisher database.
name | sysname | Name of the publication.
description | nvarchar(255) | Brief description of the publication.
retention | int | Retention period, expressed in days, for the entire publication set.
publication_type | tinyint | Indicates the publication is filtered: 0 = Not filtered. 1 = Filtered.
pubid | uniqueidentifier | Unique identification number for this publication; generated when the publication is added.
designmasterid | uniqueidentifier | Reserved for future use.
parentid | uniqueidentifier | Indicates the parent publication from which the current peer or subset publication was created (used for hierarchical publishing topologies).
sync_mode | tinyint | Synchronization mode of this publication: 0 = Native. 1 = Character.
allow_push | int | Indicates whether the publication allows push subscriptions.
allow_pull | int | Indicates whether the publication allows pull subscriptions.
allow_anonymous | int | Indicates whether the publication allows anonymous subscriptions.
centralized_ conflicts | int | Indicates whether the conflict records are stored at the Publisher: 0 = Conflict records are stored at both the Publisher and at the Subscriber that caused the conflict. 1 = All conflict records are stored at the Publisher.
status | tinyint | Reserved for future use.
snapshot_ready | tinyint | Indicates the snapshot of the publication is ready: 0 = Snapshot is ready for use. 1 = Snapshot is not ready for use.
enabled_for_ internet | bit | Indicates whether the synchronization files for the publication are exposed to the Internet, through FTP and other services.
dynamic_filters | bit | Indicates whether the publication is filtered on a dynamic property.
snapshot_in_defaultfolder | bit | Specifies whether snapshot files are stored in the default folder: 0 = Snapshot files are in default folder. 1 = Snapshot files are stored in the location specified by alt_snapshot_folder.
alt_snapshot_folder | nvarchar(255) | Location of the alternate folder for the snapshot.
pre_snapshot_script | nvarchar(255) | Pointer to an .sql file that the Merge Agent will run before any of the replication object scripts when applying the snapshot at the Subscriber.
post_snapshot_script | nvarchar(255) | Pointer to an .sql file that the Merge Agent will run after all the other replication object scripts and data have been applied during an initial synchronization.
compress_snapshot | bit | Specifies whether the snapshot written to the alt_snapshot_folder location is compressed into the Microsoft® CAB format. 0 specifies that the file is not compressed.
ftp_address | sysname | Network address of the FTP service for the Distributor. Specifies where publication snapshot files are located for the Merge Agent to pick up, if FTP is enabled.
ftp_port | int | Port number of the FTP service for the Distributor.
ftp_subdirectory | nvarchar(255) | Subdirectory of where the snapshot files will be available for the Merge Agent to pick up.
ftp_login | sysname | Username used to connect to the FTP service.
ftp_password | nvarchar(524) | User password used to connect to the FTP service.
conflict_retention | int | Specifies the retention period, in days, for which conflicts are retained. A default of 14 days is assigned before the conflict row is purged from the conflict table.
keep_before_values | int | Specifies whether synchronization optimization is occurring for this publication: 0 = Synchronization is not optimized, and the partitions sent to all Subscribers will be verified when data changes in a partition. 1 = Synchronization is optimized, and only Subscribers having rows in the changed partition are affected.
allow_subscription_copy | bit | Specifies whether the ability to copy the subscription database has been enabled. 0 means copying is not allowed.
allow_synctoalternate | bit | Specifies whether an alternate synchronization partner is allowed to synchronize with this Publisher. 0 means that a synchronization partner is not allowed.
validate_subscriber_info | nvarchar(500) | List the functions that are being used to retrieve Subscriber information and validate the dynamic filtering criteria on the Subscriber.
ad_guidname | sysname | Specifies whether the publication is published in the Microsoft® Active Directory™. A valid GUID specifies that the publication is published in the Microsoft Active Directory, and the GUID is the corresponding Active Directory publication object objectGUID. If NULL, the publication is not published in Microsoft Active Directory.
backward_comp_level | int | Database compatibility level (60, 65, 70, and 80).
max_concurrent_merge | int | Maximum number of concurrent merge processes. A value of 0 for this property means that there is no limit to the number of concurrent merge processes running at any given time. This property sets a limit as to the number of concurrent merge processes that can be run against a merge publication at one time. If there are more snapshot processes scheduled at the same time than the value allows to run, then the excess jobs will be put into a queue and wait until a currently-running merge process finishes.
max_concurrent_dynamic_snapshots | int | Maximum number of concurrent dynamic snapshot sessions that can be running against the merge publication. If 0, there is no limit to the maximum number of concurrent dynamic snapshot sessions that can run simultaneously against the publication at any given time. This property sets a limit as to the number of concurrent snapshot processes that can be run against a merge publication at one time. If there are more snapshot processes scheduled at the same time than the value allows to run, then the excess jobs will be put into a queue and wait until a currently-running merge process finishes.

See Also

sysmergeschemachange

sysmergesubscriptions

sysmergeschemaarticles

MSmerge_genhistory

MSdynamicsnapshotjobs

MSmerge_delete_conflicts

sysmergearticles


sysmergeschemaarticles

Tracks schema-only articles for merge replication. This table is stored in the publication and subscription databases.

Column name | Data type | Description
name | sysname | Name of the schema-only article in the merge publication
type | tinyint | Value indicating the type of schema-only article: 0x20 = Stored procedure schema-only article. 0x40 = View schema-only article or indexed view schema-only article.
objid | int | Object identifier of the article base object. Can be the object identifier of a procedure, view, indexed, view, or UDF.
artid | uniqueidentifier | Article ID.
description | nvarchar(255) | Description of the article.
pre_creation_command | tinyint | Specifies what the system is to do if the table exists at the subscriber when applying the snapshot. None = If the table already exists at the Subscriber, no action is taken. Delete = Issues a delete based on the WHERE clause in the subset filter. Drop (default) = Drops the table before re-creating it. Truncate = Same as delete, but deletes pages instead of rows. Does not take a WHERE clause.
pubid | uniqueidentifier | Unique identifier of the publication.
status | tinyint | Bitmap used to indicate the status of the article.
creation_script | nvarchar(255) | Path and name of an optional article schema pre-creation script used to create target table.
schema_option | binary(8) | Indicates what is to be scripted out. This is a bitmask of the schema generation option for the given article. It specifies the automatic creation of the stored procedure in the destination database for all CALL/MCALL/XCALL.
destination_object | sysname | Name of the destination object in the subscription database. This value applies only to schema-only articles, such as stored procedures, views, and UDFs.
destination_owner | sysname | Owner of the object in the subscription database, if not dbo.

See Also

sysmergepublications


sysmergeschemachange

Contains information about the published articles generated by the Snapshot Agent. This table is stored in the publication and subscription databases.

Column name | Data type | Description
pubid | uniqueidentifier | ID of the publication
artid | uniqueidentifier | ID of the article
schemaversion | int | Number of the last schema change
schemaguid | uniqueidentifier | Unique ID of the last schema
schematype | int | Type of schema: 1 = Schema 2 = System schema 3 = Trigger script
schematext | nvarchar(255) | Name of the script file, or a command which includes a file name

See Also

sysmergepublications

sysmergearticles


sysmergesubscriptions

Contains one row for each known Subscriber and is a local table at the Publisher. This table is stored in the publication and subscription databases.

Column name | Data type | Description
subid | uniqueidentifier | Unique identification number for Subscription.
partnerid | uniqueidentifier | ID of the partner to which it subscribes.
datasource_type | int | Type of data source: 0 = Microsoft SQL Server. 2 = Jet OLE DB.
datasource_path | nvarchar(255) | If a Jet datasource, path to the .mdb file.
srvid | int | Contains the sysservers.srvguid and, with db_name, allows for the subscription to be identified in the local server.
db_name | sysname | Name of the subscribing database.
pubid | uniqueidentifier | ID of the publication from which the current subscription was created.
status | tinyint | Status of the subscription: 0 = Inactive. 1 = Active. 2 = Deleted.
subscriber_type | int | Type of Subscriber: 1 = Global. 2 = Local. 3 = Anonymous.
subscription_type | int | Type of subscription: 0 = Push. 1 = Pull. 2 = Anonymous.
priority | real | Specifies the subscription priority and allows the implementation of priority-based conflict resolution. 0.00 for all local or anonymous subscriptions.
sync_type | tinyint | Type of synchronization: 1 = Automatic. 2 = No synchronization.
description | nvarchar(255) | Brief description of the subscription.
login_name | sysname | Name of the user who created the subscription.
last_validated | datetime | Time of the last successful validation of Subscriber data.
subscriber_server | sysname | ID of the server. Used to map the srvid field to the server-specific value when migrating a copy of the subscription database to a different server.
use_interactive_resolver | bit | Specifies whether the interactive resolver is used during reconciliation. If 0, the interactive resolver is not used.
publication | sysname | Name of the publication.
distributor | sysname | Name of the computer hosting the Distribution Agent.
validation_level | int | Type of validation to perform on the subscription. The validation level specified can be one of these values: 0 = No validation. 1 = Rowcount-only validation. 2 = Rowcount and checksum validation. 3 = Rowcount and binary checksum validation.
resync_gen | int | Generation number that will be used for resynchronization of the subscription. A value of –1 indicates that the subscription is not marked for resynchronization.
attempted_validate | datetime | Last datetime that validation was attempted on the subscription.
last_sync_date | datetime | datetime of the synchronization.
last_sync_status | int | Subscription status: 0 = All jobs are waiting to start. 1 = One or more jobs are starting. 2 = All jobs have executed successfully. 3 = At least one job is executing. 4 = All jobs are scheduled and idle. 5 = At least one job is attempting to execute after a previous failure. 6 = At least one job has failed to execute successfully.
last_sync_summary | sysname | Description of last synchronization results.

See Also

MSmerge_replinfo

sysmergepublications

MSmerge_altsyncpartners


sysmergesubsetfilters

Contains join filter information for partitioned articles. This table is stored in the publication and subscription databases.

Column name | Data type | Description
filtername | sysname | Name of the filter used to create the article.
join_filterid | int | ID of the object representing the join filter.
pubid | uniqueidentifier | ID of the publication.
artid | uniqueidentifier | ID of the article.
art_nickname | int | Nickname of the article.
join_articlename | sysname | Name of the table to join to determine whether the row belongs.
join_nickname | int | Nickname of the table to join to determine whether the row belongs.
join_unique_key | int | Indicates a join on a unique key of join_tablename: 0 = Not a unique key. 1 = A unique key.
expand_proc | sysname | Name of the stored procedure used by the Merge Agent to identify the rows that need to be sent or removed from a Subscriber.
join_filterclause | nvarchar(1000) | Filter clause used for the join.

See Also

sysmergearticles


sysmessages

Contains one row for each system error or warning that can be returned by Microsoft® SQL Server™. SQL Server displays the error description on the user's screen.

Column name | Data type | Description
error | int | Unique error number.
severity | smallint | Severity level of the error.
dlevel | smallint | For internal use only.
description | nvarchar(255) | Explanation of the error with placeholders for parameters.
mslangid | smallint | System message group ID.

See Also

syslanguages

sysalerts


sysnotifications

Contains one row for each notification.

Column name | Data type | Description
alert_id | int | ID of the alert.
operator_id | int | Operator ID to whom this notification should be sent.
notification_method | tinyint | Method of notification: 1 = E-mail 2 = Pager 4 = netsend 7 = All

See Also

sysalerts


sysobjects

Contains one row for each object (constraint, default, log, rule, stored procedure, and so on) created within a database. In tempdb only, this table includes a row for each temporary object.

Column name | Data type | Description
name | sysname | Object name.
Id | int | Object identification number.
xtype | char(2) | Object type. Can be one of these object types: C = CHECK constraint D = Default or DEFAULT constraint F = FOREIGN KEY constraint L = Log FN = Scalar function IF = Inlined table-function P = Stored procedure PK = PRIMARY KEY constraint (type is K) RF = Replication filter stored procedure S = System table TF = Table function TR = Trigger U = User table UQ = UNIQUE constraint (type is K) V = View X = Extended stored procedure
uid | smallint | User ID of owner object.
info | smallint | Reserved. For internal use only.
status | int | Reserved. For internal use only.
base_schema_ ver | int | Reserved. For internal use only.
replinfo | int | Reserved. For use by replication.
parent_obj | int | Object identification number of parent object (for example, the table ID if a trigger or constraint).
crdate | datetime | Date the object was created.
ftcatid | smallint | Identifier of the full-text catalog for all user tables registered for full-text indexing, and 0 for all user tables not registered.
schema_ver | int | Version number that is incremented every time the schema for a table changes.
stats_schema_ ver | int | Reserved. For internal use only.
type | char(2) | Object type. Can be one of these values: C = CHECK constraint D = Default or DEFAULT constraint F = FOREIGN KEY constraint FN = Scalar function IF = Inlined table-function K = PRIMARY KEY or UNIQUE constraint L = Log P = Stored procedure R = Rule RF = Replication filter stored procedure S = System table TF = Table function TR = Trigger U = User table V = View X = Extended stored procedure
userstat | smallint | Reserved.
sysstat | smallint | Internal status information.
indexdel | smallint | Reserved.
refdate | datetime | Reserved for future use.
version | int | Reserved for future use.
deltrig | int | Reserved.
instrig | int | Reserved.
updtrig | int | Reserved.
seltrig | int | Reserved.
category | int | Used for publication, constraints, and identity.
cache | smallint | Reserved.

See Also

syslockinfo

sysindexes

sysreferences

syscolumns

sysforeignkeys

sysconstraints

syscomments

sysdepends

sysprotects

sysfulltextcatalogs

syspermissions

sysusers


sysoledbusers

Contains one row for each user and password mapping for the specified linked server. This table is stored in the master database.

Column name | Data type | Description
rmtsrvid | smallint | SID (security identification number) of the server.
rmtloginame | nvarchar(128) | Name of the remote login that loginsid maps to for linked rmtservid.
rmtpassword | nvarchar(128) | Encrypted password for the specified remote login in linked rmtsrvid.
loginsid | varbinary(85) | SID of the local login to be mapped.
status | smallint | If this value is 1, the mapping should use the user's own credentials.
changedate | datetime | Date mapping information was last changed.

See Also

syslogins

sysservers


sysopentapes

Contains one row for each currently open tape device. This view is stored in the master database.

Column name | Data type | Description
openTape | nvarchar(64) NOT NULL | Physical file name of open tape device. For more information about opening and releasing tape devices, see BACKUP and RESTORE.


sysoperators

Contains one row for each operator.

Column name | Data type | Description
id | int | ID of the operator.
name | sysname | Name of the operator.
enabled | tinyint | Status of alert notifications (Boolean). If 1, this operator can receive notifications when an alert occurs.
email_address | nvarchar(100) | E-mail address for this operator.
last_email_date | int | Date this operator last received an e-mail alert notification.
last_email_time | int | Time of day this operator last received an e-mail alert notification.
pager_address | nvarchar(100) | Pager address for this operator.
last_pager_date | int | Date this operator last received a pager alert notification.
last_pager_time | int | Time of day this operator last received a pager alert notification.
weekday_pager_ start_time | int | Time of day on a weekday (Monday through Friday) after which this operator is available to receive a pager alert notification.
weekday_pager_ end_time | int | Time of day on a weekday (Monday through Friday) after which this operator is not available to receive a pager alert notification.
saturday_pager_ start_time | int | Time of day on Saturday after which this operator is available to receive a pager alert notification.
saturday_pager_ end_time | int | Time of day on Saturday after which this operator is not available to receive a pager alert notification.
sunday_pager_ start_time | int | Time of day on Sunday after which this operator is available to receive a pager alert notification.
sunday_pager_ end_time | int | Time of day on Sunday after which this operator is not available to receive a pager alert notification.
pager_days | tinyint | Bitmask representing the days of the week during which this operator is available to receive a pager alert notification.
netsend_address | nvarchar(100) | Reserved.
last_netsend_ date | int | Date that the most recent network message was last sent to the specified operator ID.
last_netsend_ time | int | Time that the most recent network message was last sent to the specified operator ID.
category_id | int | Reserved.

See Also

syscategories


sysperfinfo

Contains a Microsoft® SQL Server™ representation of the internal performance counters that can be displayed through the Windows NT Performance Monitor.

Note The Windows NT Performance Monitor is available only when using Microsoft Windows NT® 4.0 as the operating system.

Performance condition alerts are only available for the first 99 databases. Any databases created after the first 99 databases will not be included in the sysperfinfo system table, and using the sp_add_alert procedure will return an error.

Column name | Data type | Description
object_name | nchar(128) | Performance object name, such as SQL Server: Lock Manager or SQL Server: Buffer Manager.
counter_name | nchar(128) | Name of the performance counter within the object, such as Page Requests or Locks Requested.
instance_name | nchar(128) | Named instance of the counter. For example, there are counters maintained for each type of lock, such as Table, Page, Key, and so on. The instance name distinguishes between similar counters.
cntr_value | int | Actual counter value. In most cases, this will be a level or monotonically increasing counter that counts occurrences of the instance event.
cntr_type | int | Type of counter as defined by the Windows NT 4.0 performance architecture.


syspermissions

Contains information about permissions granted and denied to users, groups, and roles in the database. This table is stored in each database.

Column name | Data type | Description
id | int | ID of the object for object permissions; 0 for statement permissions.
grantee | smallint | ID of the user, group, or role affected by the permission.
grantor | smallint | ID of the user, group, or role that granted or revoked the permission.
actadd | smallint | For internal use only.
actmod | smallint | For internal use only.
seladd | varbinary(4000) | For internal use only.
selmod | varbinary(4000) | For internal use only.
updadd | varbinary(4000) | For internal use only.
updmod | varbinary(4000) | For internal use only.
refadd | varbinary(4000) | For internal use only.
refmod | varbinary(4000) | For internal use only.

See Also

sysusers

sysobjects


sysprocesses

The sysprocesses table holds information about processes running on Microsoft® SQL Server™. These processes can be client processes or system processes. sysprocesses is stored only in the master database.

Column name | Data type | Description
spid | smallint | SQL Server process ID.
kpid | smallint | Microsoft Windows NT 4.0® thread ID.
blocked | smallint | Process ID (spid) of a blocking process.
waittype | binary(2) | Reserved.
waittime | int | Current wait time in milliseconds. Is 0 when the process is not waiting.
lastwaittype | nchar(32) | A string indicating the name of the last or current wait type.
waitresource | nchar(32) | Textual representation of a lock resource.
dbid | smallint | ID of the database currently being used by the process.
uid | smallint | ID of the user who executed the command.
cpu | int | Cumulative CPU time for the process. The entry is updated for all processes, regardless of whether the SET STATISTICS TIME ON option is ON or OFF.
physical_io | int | Cumulative disk reads and writes for the process.
memusage | int | Number of pages in the procedure cache that are currently allocated to this process. A negative number indicates that the process is freeing memory allocated by another process.
login_time | datetime | Time at which a client process logged into the server. For system processes, the time at which SQL Server startup occurred is stored.
last_batch | datetime | Last time a client process executed a remote stored procedure call or an EXECUTE statement. For system processes, the time at which SQL Server startup occurred is stored.
ecid | smallint | Execution context ID used to uniquely identify the subthreads operating on behalf of a single process.
open_tran | smallint | Number of open transactions for the process.
status | nchar(30) | Process ID status (for example, running, sleeping, and so on).
sid | binary(85) | Globally unique identifier (GUID) for the user.
hostname | nchar(128) | Name of the workstation.
program_name | nchar(128) | Name of the application program.
hostprocess | nchar(8) | Workstation process ID number.
cmd | nchar(16) | Command currently being executed.
nt_domain | nchar(128) | Windows NT 4.0 domain for the client (if using Windows Authentication) or a trusted connection.
nt_username | nchar(128) | Windows NT 4.0 user name for the process (if using Windows Authentication) or a trusted connection.
net_address | nchar(12) | Assigned unique identifier for the network interface card on each user's workstation. When the user logs in, this identifier is inserted in the net_address column.
net_library | nchar(12) | Column in which the client's network library is stored. Every client process comes in on a network connection. Network connections have a network library associated with them that allows them to make the connection.
loginame | nchar(128) | Login name.

See Also

sysdatabases

syslockinfo

sysusers


sysprotects

Contains information about permissions that have been applied to security accounts with the GRANT and DENY statements. This table is stored in each database.

Column name | Data type | Description
id | int | ID of object to which these permissions apply.
uid | smallint | ID of user or group to which these permissions apply.
action | tinyint | Can have one of these permissions: 26 = REFERENCES 178 = CREATE FUNCTION 193 = SELECT 195 = INSERT 196 = DELETE 197 = UPDATE 198 = CREATE TABLE 203 = CREATE DATABASE 207 = CREATE VIEW 222 = CREATE PROCEDURE 224 = EXECUTE 228 = BACKUP DATABASE 233 = CREATE DEFAULT 235 = BACKUP LOG 236 = CREATE RULE
protecttype | tinyint | Can have these values: 204 = GRANT_W_GRANT 205 = GRANT 206 = REVOKE
columns | varbinary(4000) | Bitmap of columns to which these SELECT or UPDATE permissions apply. Bit 0 indicates all columns; bit 1 means permissions apply to that column and NULL means no information.
grantor | smallint | User ID of the user who issued the GRANT or REVOKE permissions.

See Also

sysusers

sysobjects


syspublications

Contains one row for each publication defined in the database. This table is stored in the publication database.

Column name | Data type | Description
description | nvarchar(255) | Descriptive entry for the publication.
name | sysname | Unique name associated with the publication.
pubid | int | Identity column providing a unique ID for the publication.
repl_freq | tinyint | Replication frequency: 0 = Transaction based. 1 = Scheduled table refresh.
status | tinyint | Status: 0 = Inactive. 1 = Active.
sync_method | tinyint | Synchronization method: 0 = Native bulk copy program (bcp utility). 1 = Character bulk copy. 3 = Concurrent, which means that native bulk copy (bcp utility) is used but tables are not locked during the snapshot. 4 = Concurrent_c, which means that character bulk copy is used but tables are not locked during the snapshot.
snapshot_jobid | binary(16) | Scheduled task ID.
independent_ agent | bit | Specifies whether there is a stand-alone Distribution Agent for this publication. 0 = The publication uses a shared Distribution Agent, and each Publisher database/Subscriber database pair has a single, shared Agent. 1 = There is a stand-alone Distribution Agent for this publication.
immediate_sync | bit | Indicates whether the synchronization files are created or re-created each time the Snapshot Agent runs.
enabled_for_ internet | bit | Indicates whether the synchronization files for the publication are exposed to the Internet through FTP and other services.
allow_push | bit | Indicates whether push subscriptions are allowed on the publication.
allow_pull | bit | Indicates whether pull subscriptions are allowed on the publication.
allow_anonymous | bit | Indicates whether anonymous subscriptions are allowed on the publication.
immediate_sync_ ready | bit | Indicates whether the snapshot has been generated by the Snapshot Agent and is ready for use by new subscriptions. It is only meaningful for immediate updating publications. 0 indicates that there is no snapshot ready.
allow_sync_tran | bit | Specifies whether immediate-updating subscriptions are allowed on the publication. 0 means that immediate-updating subscriptions are not allowed.
autogen_sync_ procs | bit | Specifies whether the synchronizing stored procedure for immediate-updating subscriptions is generated at the Publisher. 1 means that it is generated at the Publisher.
retention | int | Amount of change, in hours, to save for the given publication.
allowed_queued_tran | bit | Specifies whether disables queuing of changes at the Subscriber until they can be applied at the Publisher has been enabled. If 0, changes at the Subscriber are not queued.
snapshot_in_defaultfolder | bit | Specifies whether snapshot files are stored in the default folder. If 0, snapshot files have been stored in the alternate location specified by alternate_snapshot_folder. If 1, snapshot files can be found in the default folder.
alt_snapshot_folder | nvarchar(255) | Specifies the location of the alternate folder for the snapshot.
pre_snapshot_script | nvarchar(255) | Specifies a pointer to an .sql file location. The Distribution Agent will run the pre-snapshot script before running any of the replicated object scripts when applying a snapshot at a Subscriber.
post_snapshot_script | nvarchar(255) | Specifies a pointer to an .sql file location. The Distribution Agent will run the post-snapshot script after all the other replicated object scripts and data have been applied during an initial synchronization.
compress_snapshot | bit | Specifies that the snapshot that is written to the @alt_snapshot_folder location is to be compressed into the Microsoft® CAB format. 0 specifies that the snapshot will not be compressed.
ftp_address | sysname | The network address of the FTP service for the Distributor. Specifies where publication snapshot files are located for the Distribution Agent or Merge Agent of a subscriber to pick up.
ftp_port | int | The port number of the FTP service for the Distributor. Specifies where the publication snapshot files are located for the Distribution Agent or Merge Agent of a subscriber to pick up.
ftp_subdirectory | nvarchar(255) | Specifies where the snapshot files will be available for the Distribution Agent or Merge Agent of subscriber to pick up if the publication supports propagating snapshots using FTP.
ftp_login | sysname | The username used to connect to the FTP service.
ftp_password | nvarchar(524) | The user password used to connect to the FTP service.
allow_dts | bit | Specifies that the publication allows data transformations. 0 specifies that DTS transformations are not allowed.
allow_subscription_copy | bit | Specifies whether the ability to copy the subscription databases that subscribe to this publication has been enabled. 0 means that copying is not allowed.
centralized_conflicts | bit | Specifies whether conflict records are stored on the Publisher: 0 = Conflict records are stored at both the publisher and at the subscriber that caused the conflict. 1 = Conflict records are stored at the Publisher.
conflict_retention | int | Specifies the conflict retention period, in days.
conflict_policy | int | Specifies the conflict resolution policy followed when the queued updating subscriber option is used. Can be one of these values: 1 = Publisher wins the conflict. 2 = Subscriber wins the conflict. 3 = Subscription is reinitialized.
queue_type | int | Specifies which type of queue is used. Can be one of these values: msmq = Use Microsoft Message Queuing to store transactions. sql = Use SQL Server to store transactions. NULL = defaults to sql, which specifies to use SQL Server to store transactions.
ad_guidname | sysname | Specifies whether the publication is published in the Microsoft Active Directory™. A valid globally unique identifier (GUID) specifies that the publication is published in the Microsoft Active Directory, and the GUID is the corresponding Active Directory publication object objectGUID. If NULL, the publication is not published in Microsoft Active Directory.
backward_comp_level | int | Database compatibility level (60, 65, 70, and 80).

See Also

sysarticles

sysschemaarticles

sysarticleupdates


sysreferences

Contains mappings of FOREIGN KEY constraint definitions to the referenced columns. This table is stored in each database.

Column name | Data type | Description
constid | int | ID of the FOREIGN KEY constraint
fkeyid | int | ID of the referencing table
rkeyid | int | ID of the referenced table
rkeyindid | smallint | Index ID of the unique index on the referenced table covering the referenced key-columns
keycnt | smallint | Number of columns in the key
forkeys | varbinary(32) | For internal use only
refkeys | varbinary(32) | For internal use only
fkeydbid | smallint | Reserved
rkeydbid | smallint | Reserved
fkey1 | smallint | Column ID of the referencing column
fkey2 | smallint | Column ID of the referencing column
fkey3 | smallint | Column ID of the referencing column
fkey4 | smallint | Column ID of the referencing column
fkey5 | smallint | Column ID of the referencing column
fkey6 | smallint | Column ID of the referencing column
fkey7 | smallint | Column ID of the referencing column
fkey8 | smallint | Column ID of the referencing column
fkey9 | smallint | Column ID of the referencing column
fkey10 | smallint | Column ID of the referencing column
fkey11 | smallint | Column ID of the referencing column
fkey12 | smallint | Column ID of the referencing column
fkey13 | smallint | Column ID of the referencing column
fkey14 | smallint | Column ID of the referencing column
fkey15 | smallint | Column ID of the referencing column
fkey16 | smallint | Column ID of the referencing column
rkey1 | smallint | Column ID of the referenced column
rkey2 | smallint | Column ID of the referenced column
rkey3 | smallint | Column ID of the referenced column
rkey4 | smallint | Column ID of the referenced column
rkey5 | smallint | Column ID of the referenced column
rkey6 | smallint | Column ID of the referenced column
rkey7 | smallint | Column ID of the referenced column
rkey8 | smallint | Column ID of the referenced column
rkey9 | smallint | Column ID of the referenced column
rkey10 | smallint | Column ID of the referenced column
rkey11 | smallint | Column ID of the referenced column
rkey12 | smallint | Column ID of the referenced column
rkey13 | smallint | Column ID of the referenced column
rkey14 | smallint | Column ID of the referenced column
rkey15 | smallint | Column ID of the referenced column
rkey16 | smallint | Column ID of the referenced column

See Also

sysindexes

syscolumns

sysobjects


sysremotelogins

Contains one row for each remote user allowed to call remote stored procedures on Microsoft® SQL Server™.

Column name | Data type | Description
remoteserverid | smallint | Remote server identification.
remoteusername | nvarchar(128) | User's login name on a remote server.
status | smallint | Bitmap of options.
sid | varbinary(85) | Microsoft Windows NT® user security ID.
changedate | datetime | Date and time the remote user was added.

See Also

syslogins

sysservers


sysreplicationalerts

Contains information about the conditions causing a replication alert to fire. This table is stored in the msdb database.

Column name | Data type | Description
alert_id | int | ID of the alert.
status | int | User-defined value: 0 = Unserviced 1 = Serviced
agent_type | int | Type of agent: 1 = Snapshot Agent 2 = Log Reader Agent 3 = Distribution Agent 4 = Merge Agent
agent_id | int | Agent ID from the tables MSsnapshot_agents, MSlogreader_agents, MSdistribution_agents, or MSmerge_agents.
error_id | int | ID of the error stored in MSrepl_errors.
alert_error_code | int | Message ID of the alert raised when logging this record.
time | datetime | Time the record was inserted.
publisher | sysname | Name of the Publisher associated with the agent that fired this alert.
publisher_db | sysname | Publisher database associated with the agent that fired this alert.
publication | sysname | Publication associated with the agent that fired this alert.
publication_type | int | Type of publication: 0 = Snapshot 1 = Transactional 2 = Merge
subscriber | sysname | Name of the Subscriber associated with the agent that fired this alert.
subscriber_db | sysname | Name of the Subscriber database associated with the agent that fired this alert.
article | sysname | Name of the article associated with the agent that fired this alert.
destination_ object | sysname | Name of the subscription table associated with the alert.
source_object | sysname | Name of the published table associated with the alert.
alert_error_text | ntext | Text of the alert.

See Also

sysalerts


sysschemaarticles

Tracks schema-only articles for transactional and snapshot publications. This table is stored in the publication database.

Column name | Data type | Description
artid | int | Article ID.
creation_script | nvarchar(255) | Path and name of an article schema script used to create the target table.
description | nvarchar(255) | Descriptive entry for the article.
dest_object | sysname | Name of the object in the subscription database if the article is a schema-only article, such as stored procedure, view, or UDF.
name | sysname | Name of the schema-only article in a publication.
objid | int | Object identifier of the article base object. Can be the object identifier of a procedure, view, indexed, view, or UDF.
pubid | int | ID for the publication.
pre_creation_cmd tinyint Specifies what the system should do if it detects an existing object of the same name at the Subscriber when applying the snapshot for this article:

0 = Nothing.
1 = Delete destination table.
2 = Drop destination table.
3 = Truncate destination table.

status | int | Bitmap used to indicate the status of the article.
type tinyint Value indicating the type of schema-only article:

0x20 = Stored procedure schema-only article.
0x40 = View schema-only article or. indexed view schema-only article.
schema_option binary(8) Bitmask of the schema generation option for the given article. It specifies the automatic creation of the stored procedure in the destination database for all CALL/MCALL/XCALL. It can be one of these values:

0x00 = Disables scripting by the Snapshot Agent and uses creation_script.
0x01 = Generates the object creation (CREATE TABLE, CREATE PROCEDURE, and so on). This value is the default for stored procedure articles.
0x02 = Generates custom stored procedures for the article, if defined.
0x10 = Generates a corresponding clustered index.
0x20 = Converts user-defined data types to base data types.
0x40= Generates corresponding nonclustered index(es).
0x80= Includes declared referential integrity on the primary keys.
0x73 = Generates the CREATE TABLE statement, creates clustered and nonclustered indexes, converts user-defined data types to base data types, and generates custom stored procedure scripts to be applied at the Subscriber. This value is the default for all articles except stored procedure articles.
0x100= Replicates user triggers on a table article, if defined.
0x200= Replicates foreign key constraints. If the referenced table is not part of a publication, all foreign key constraints on a published table will not be replicated.
0x400= Replicates check constraints.
0x800= Replicates defaults.
0x1000= Replicates column-level collation.
0x2000= Replicates extended properties associated with the published article source object.
0x4000= Replicates unique keys if defined on a table article.
0x8000= Replicates primary key and unique keys on a table article as constraints using ALTER TABLE statements.
dest_owner | sysname | Owner of the table at the destination database.

See Also

syspublications


sysservers

Contains one row for each server that Microsoft® SQL Server™ can access as an OLE DB data source.

Column name | Data type | Description
srvid | smallint | ID (for local use only) of the remote server.
srvstatus | smallint | For internal use only.
srvname | sysname | Name of the server.
srvproduct | nvarchar(128) | Product name for the remote server.
providername | nvarchar(128) | OLE DB provider name for access to this server.
datasource | nvarchar(4000) | OLE DB data source value.
location | nvarchar(4000) | OLE DB location value.
providerstring | nvarchar(4000) | OLE DB provider string value.
schemadate | datetime | Date this row was last updated.
topologyx | int | Used by the SQL Server Enterprise Manager server topology diagram.
topologyy | int | Used by the SQL Server Enterprise Manager server topology diagram.
catalog | sysname | Catalog that is used when making a connection to an OLE DB provider.
connecttimeout | int | Timeout setting for server-connection.
querytimeout | int | Timeout setting for queries against server.
srvnetname | char(30) | Reserved (currently the same as the srvname).
isremote | bit | 1 if server is a remote server, else 0 if server is a linked server.
rpc | bit | 1/0 for sp_serveroption rpc set to true/false.
pub | bit | 1/0 for sp_serveroption pub set to true/false.
sub | bit | 1/0 for sp_serveroption sub set to true/false.
dist | bit | 1/0 for sp_serveroption dist set to true/false.
dpub | bit | 1/0 for sp_serveroption dpub set to true/false.
rpcout | bit | 1/0 for sp_serveroption rpc out set to true/false.
dataaccess | bit | 1/0 for sp_serveroption data access set to true/false.
collationcompatible | bit | 1/0 for sp_serveroption collation compatible set to true/false.
system | bit | 1/0 for sp_serveroption system set to true/false.
useremotecollation | bit | 1/0 for sp_serveroption use remote collation set to true/false.
lazyschemavalidation | bit | 1/0 for sp_serveroption lazy schema validation set to true/false.
collation | sysname | Server collation as set by sp_serveroption collation name.

See Also

sysremotelogins

sysoledbusers


syssubscriptions

Contains one row for each subscription in the database. This table is stored in the publication database.

Column name | Data type | Description
artid | int | Unique ID of an article
srvid | smallint | Server ID of the Subscriber
dest_db | sysname | Name of the destination database
status | tinyint | Status: 0 = Inactive 1 = Subscribed 2 = Active
sync_type | tinyint | Type of synchronization: 1 = Automatic 2 = None
login_name | sysname | Login name used when adding the subscription
subscription_type | int | Type of subscription: 0 = Push 1 = Pull
distribution_jobid | binary(16) | Job ID of the Distribution Agent
timestamp | timestamp | Timestamp
update_mode | tinyint | Update mode: 0 = Read only 1 = Immediate-updating
loopback_detection | bit | Whether the Distribution Agent sends transactions originated at the Subscriber back to the Subscriber: True = Does not send back False = Sends back
queued_reinit | bit | Specifies whether the article is marked for initialization or reinitialization. A value of 1 specifies that the subscribed article is marked for initialization or re-initialization.

See Also

sysarticles


systargetservergroupmembers

Records which target servers are currently enlisted in this multiserver group.

Column name | Data type | Description
servergroup_id | int | Server group ID
server_id | int | Server ID

See Also

systargetservergroups


systargetservergroups

Records which target server groups are currently enlisted in this multiserver environment.

Column name | Data type | Description
servergroup_id | int | Server group ID
name | sysname | Server group name

See Also

systargetservergroupmembers

systargetservers


systargetservers

Records which target servers are currently enlisted in this multiserver operation domain.

Column name | Data type | Description
server_id | int | Server ID.
server_name | nvarchar(30) | Server name.
location | nvarchar(200) | Location of the specified target server.
time_zone_ adjustment | int | Time adjustment interval, in hours, from Greenwich mean time (GMT).
enlist_date | datetime | Date and time that the specified target server was enlisted.
last_poll_date | datetime | Date and time that the specified target server last polled the multiserver's sysdownloadlist system table for jobs to run.
status | int | Status of the target server: 1 = Normal 2 = Re-sync Pending 4 = Suspected Offline
local_time_at_ last_poll | datetime | Date and time the target server was last polled for job operations.
enlisted_by_nt_ user | nvarchar(100) | Username of the person executing sp_msx_enlist on the target server.
poll_internal | int | Number of seconds to elapse before the target server polls the master server for new download instructions.

See Also

systargetservergroups

sysdownloadlist

sysjobservers


systaskids

Contains a mapping of tasks created in earlier versions of Microsoft® SQL Server™ to SQL Server Enterprise Manager jobs in the current version. This table is stored in the msdb database.

Column name | Data type | Description
task_id | int | ID of the task
job_id | uniqueidentifier | ID of the job to which the task is mapped

See Also

sysjobs


systypes

Contains one row for each system-supplied and each user-defined data type. This table is stored in each database.

These are the system-supplied data types and their ID numbers.

Column name | Data type | Description
name | sysname | Data type name.
xtype | tinyint | Physical storage type.
status | tinyint | For internal use only.
xusertype | smallint | Extended user type.
length | smallint | Physical length of data type.
xprec | tinyint | Internal precision, as used by server. (Not to be used in queries.)
xscale | tinyint | Internal scale, as used by server. (Not to be used in queries.)
tdefault | int | ID of stored procedure that contains integrity checks for this data type.
domain | int | ID of stored procedure that contains integrity checks for this data type.
uid | smallint | User ID of data type creator.
reserved | smallint | For internal use only.
usertype | smallint | User type ID.
variable | bit | Variable-length data type is 1; otherwise, 0.
allownulls | bit | Indicates the default nullability for this data type. If nullability is specified with CREATE or ALTER TABLE, then that value overrides the default nullability for this data type.
type | tinyint | Physical storage data type.
printfmt | varchar(255) | Reserved.
prec | smallint | Level of precision for this data type.
scale | tinyint | Scale for this data type (based on precision).

See Also

syscolumns


sysusers

Contains one row for each Microsoft® Windows user, Windows group, Microsoft SQL Server™ user, or SQL Server role in the database.

Column name | Data type | Description
uid | smallint | User ID, unique in this database. 1 is the database owner.
status | smallint | For internal use only.
name | sysname | Username or group name, unique in this database.
sid | varbinary(85) | Security identifier for this entry.
roles | varbinary(2048) | For internal use only.
createdate | datetime | Date the account was added.
updatedate | datetime | Date the account was last changed.
altuid | smallint | For internal use only.
password | varbinary(256) | For internal use only.
gid | smallint | Group ID to which this user belongs. If uid = gid, this entry defines a group.
environ | varchar(255) | Reserved.
hasdbaccess | int | 1, if the account has database access.
islogin | int | 1, if the account is a Windows group, Windows user, or SQL Server user with a login account.
isntname | int | 1, if the account is a Windows group or Windows user.
isntgroup | int | 1, if the account is a Windows group.
isntuser | int | 1, if the account is a Windows user.
issqluser | int | 1, if the account is a SQL Server user.
isaliased | int | 1, if the account is aliased to another user.
issqlrole | int | 1, if the account is a SQL Server role.
isapprole | int | 1, if the account is an application role.

See Also

syslogins

syscacheobjects

sysprocesses

sysobjects

syspermissions

sysprotects

sysmembers


MSagent_parameters

The MSagent_parameters table contains parameters associated with an agent profile. The parameter names are the same as those supported by the agent. This table is stored in the msdb database.

Column name | Data type | Description
profile_id | int | Profile ID from the MSagent_profiles table.
parameter_name | sysname | Name of the parameter.
value | nvarchar(255) | Value of the parameter.

See Also

MSagent_profiles


MSagent_profiles

The MSagent_profiles table contains one row for each defined replication agent profile. This table is stored in the msdb database.

Column name | Data type | Description
profile_id | int | Profile ID.
profile_name | sysname | Unique profile name for agent type.
agent_type | int | Type of agent: 1 = Snapshot Agent 2 = Log Reader Agent 3 = Distribution Agent 4 = Merge Agent 9 = Queue Reader Agent
type | int | Type of profile: 0 = System 1 = Custom
description | nvarchar(3000) | Description of the profile.
def_profile | bit | Specifies whether this profile is the default for this agent type.

See Also

MSagent_parameters


MSarticles

The MSarticles table contains one row for each article being replicated by a Publisher. This table is stored in the distribution database.

Column name | Data type | Description
publisher_id | smallint | ID of the Publisher.
publisher_db | sysname | Name of the Publisher database.
publication_id | int | ID of the publication.
article | sysname | Name of the article.
article_id | int | ID of the article.
destination_object | sysname | Name of the table created at the Subscriber.
source_owner | sysname | Name of the owner of the source table at the Publisher.
source_object | sysname | Name of the source object from which to add the article.
description | nvarchar(255) | Description of the article.

See Also

MSpublications


MSdistpublishers

The MSdistpublishers table contains one row for each remote Publisher supported by the local Distributor. This table is stored in the msdb database.

Column name | Data type | Description
name | sysname | Name of the Publisher Distributor.
distribution_db | sysname | Name of the distribution database.
working_directory | nvarchar(255) | Name of the working directory used to store data and schema files for the publication.
security_mode | int | Security mode implemented at the Distributor: 0 = SQL Server Authentication. 1 = Windows Authentication.
login | sysname | Login ID for SQL Server Authentication.
password | nvarchar(524) | Password for SQL Server Authentication.
active | bit | Indicates whether the local Distributor is in use by the remote Publisher.
trusted | bit | Whether the remote Publisher uses the same password as the local Distributor: 0 = A password is needed at the remote Publisher to connect to the Distributor. 1 = No password is needed.
third_party | bit | Whether the Publisher is an installation of Microsoft® SQL Server™: 0 = SQL Server installation. 1 = Heterogeneous data source.

See Also

MSdistributiondbs


MSdistribution_agents

The MSdistribution_agents table contains one row for each Distribution Agent running at the local Distributor. This table is stored in the distribution database.

Column name | Data type | Description
id | int | ID of the Distribution Agent.
name | nvarchar(100) | Name of the Distribution Agent.
publisher_database_id | int | ID of the Publisher database.
publisher_id | smallint | ID of the Publisher.
publisher_db | sysname | Name of the Publisher database.
publication | sysname | Name of the publication.
subscriber_id | smallint | ID of the Subscriber, used by well-known agents only. For anonymous agents, this column is reserved.
subscriber_db | sysname | Name of the subscription database.
subscription_type | int | Type of subscription: 0 = Push 1 = Pull 2 = Anonymous
local_job | bit | Indicates whether there is a SQL Server Agent job on the local Distributor.
job_id | binary(16) | Job identification number.
subscription_guid | binary(16) | ID of the subscriptions of this agent.
profile_id | int | Configuration ID from the MSagent_profiles table.
anonymous_subid | uniqueidentifier | ID of an anonymous agent.
subscriber_name | sysname | Name of the Subscriber, used by anonymous agents only.
virtual_agent_id | int | For internal use only.
anonymous_agent_id | int | For internal use only.
creation_date | datetime | Datetime when the Distribution or Merge Agent was created.
queue_id | sysname | Identifier to locate the queue for queued updating subscriptions. For non-queued subscriptions, the value is NULL. For Microsoft Message Queuing-based publications, the value is a GUID that uniquely identifies the queue to be used for the subscription. For SQL Server-based queue publications, the column contains the value SQL.
queue_status | int | For internal use only.
offload_enabled | bit | Indicates whether the agent can be activated remotely. 0 specifies the agent cannot be activated remotely. 1 specifies the agent will be activated remotely, and on the remote computer specified in the offload_server property.
offload_server | sysname | Network name of server to be used for remote agent activation.
dts_package_name | sysname | Name of the DTS package. For example, to specify a package of DTSPub_Package, the parameter would be @dts_package_name = N'DTSPub_Package'.
dts_package_password | nvarchar(524) | Password on the package, if there is one. If NULL, means a password is not on the package.
dts_package_location | int | Package location. The location of the package can be distributor or subscriber.
sid | varbinary(85) | Security identification number (SID) for the Distribution Agent or Merge Agent during its first execution.

See Also

MSdistribution_history

MSpublications


MSdistribution_history

The MSdistribution_history table contains history rows for the Distribution Agents associated with the local Distributor. This table is stored in the distribution database.

Column name | Data type | Description
agent_id | int | ID of the Distribution Agent.
runstatus | int | Running status: 1 = Start 2 = Succeed 3 = In progress 4 = Idle 5 = Retry 6 = Fail
start_time | datetime | Time to begin execution of the job.
time | datetime | Time the message is logged.
duration | int | Duration, in seconds, of the message session.
comments | nvarchar(255) | Message text.
xact_seqno | varbinary(16) | Last processed transaction sequence number.
current_delivery_rate | float | Average number of commands delivered per second since the last history entry.
current_delivery_latency | int | Latency between the command entering the distribution database and being applied to the Subscriber since the last history entry.
delivered_transactions | int | Total number of transactions delivered in the session.
delivered_commands | int | Total number of commands delivered in the session.
average_commands | int | Average number of commands delivered in the session.
delivery_rate | float | Average delivered commands per second.
delivery_latency | int | Latency between the command entering the distribution database and being applied to the Subscriber.
total_delivered_commands | int | Total number of commands delivered since the subscription was created.
error_id | int | ID of the error in the MSrepl_error system table.
updateable_row | bit | Set if the history row can be overwritten.
timestamp | timestamp | Timestamp column of this table.

See Also

MSdistribution_agents

MSrepl_errors


MSdistributiondbs

The MSdistributiondbs table contains one row for each distribution database defined on the local Distributor. This table is stored in the msdb database.

Column name | Data type | Description
name | sysname | Name of the distribution database.
min_distretention | int | Minimum retention period, in hours, before transactions are deleted.
max_distretention | int | Maximum retention period, in hours, before transactions are deleted.
history_retention | int | Number of hours to retain history.

See Also

MSdistpublishers


MSdistributor

The MSdistributor table contains the Distributor properties. This table is stored in the msdb database.

Column name | Data type | Description
property | sysname | Name of the property
value | nvarchar(3000) | Value of the property


MSdynamicsnapshotjobs

The MSdynamicsnapshotjobs table tracks the dynamic filter information applied to a dynamic snapshot. This table is stored in the publication and subscription databases.

Column name | Data type | Description
id | int | ID for the dynamic snapshot job.
name | sysname | Name of the dynamic snapshot job.
pubid | uniqueidentifier | Unique identification number for this publication.
job_id | uniqueidentifier | ID of the SQL Server Agent job at the Distributor.
dynamic_filter_login | sysname | Value used for evaluating the SUSER_SNAME() function in dynamic filters defined for the publication.
dynamic_filter_hostname | sysname | Value used for evaluating the HOSTNAME() function in dynamic filters defined for the publication.
dynamic_snapshot_location | nvarchar(255) | Path to the folder where the snapshot files will be read from if a dynamic snapshot is to be used.

See Also

sysmergepublications


MSdynamicsnapshotviews

The MSdynamicsnapshotviews table tracks all the temporary dynamic snapshot views created by the snapshot agent, and is used by the system for cleaning up views in the case of an abnormal shutdown of SQL Server Agent or the Snapshot Agent. This table is stored in the publication and subscription databases.

Column name | Data type | Description
dynamic_snapshot_view_name | sysname | Name of the temporary dynamic snapshot view.


MSlogreader_agents

The MSlogreader_agents table contains one row for each Log Reader Agent running at the local Distributor. This table is stored in the distribution database.

Column name | Data type | Description
id | int | ID of the Log Reader Agent.
name | nvarchar(100) | Name of the Log Reader Agent.
publisher_id | smallint | ID of the Publisher.
publisher_db | sysname | Name of the Publisher database.
publication | sysname | Name of the publication.
local_job | bit | Indicates whether there is a SQL Server Agent job on the local Distributor.
job_id | binary(16) | Job identification number.
profile_id | int | Configuration ID from the MSagent_profiles table.

See Also

MSlogreader_history

MSpublications


MSlogreader_history

The MSlogreader_history table contains history rows for the Log Reader Agents associated with the local Distributor. This table is stored in the distribution database.

Column name | Data type | Description
agent_id | int | ID of the Log Reader Agent.
runstatus | int | Running status: 1 = Start 2 = Succeed 3 = In progress 4 = Idle 5 = Retry 6 = Fail
start_time | datetime | Time to begin execution of the job.
time | datetime | Time the message is logged.
duration | int | Duration, in seconds, of the message session.
comments | nvarchar(255) | Message text.
xact_seqno | varbinary(16) | Last processed transaction sequence number.
delivery_time | int | Time first transaction is delivered.
delivered_transactions | int | Total number of transactions delivered in the session.
delivered_commands | int | Total number of commands delivered in the session.
average_commands | int | Average number of commands delivered in the session.
delivery_rate | float | Average delivered commands per second.
delivery_latency | int | Latency between the command entering the published database and being entered into the distribution database.
error_id | int | ID of the error in the MSrepl_error system table.
timestamp | timestamp | Timestamp column of this table.

See Also

MSrepl_errors

MSlogreader_agents


MSmerge_agents

The MSmerge_agents table contains one row for each Merge Agent running at the Subscriber. This table is stored in the distribution database.

Column name | Data type | Description
id | int | ID of the Merge Agent.
name | nvarchar(100) | Name of the Merge Agent.
publisher_id | smallint | ID of the Publisher.
publisher_db | sysname | Name of the Publisher database.
publication | sysname | Name of the publication.
subscriber_id | smallint | ID of the Subscriber.
subscriber_db | sysname | Name of the subscription database.
local_job | bit | Indicates whether there is a SQL Server Agent job on the local Distributor.
job_id | binary(16) | Job identification number.
profile_id | int | Configuration ID from the MSagent_profiles table.
anonymous_subid | uniqueidentifier | ID of an anonymous agent.
subscriber_name | sysname | Name of the Subscriber.
creation_date | datetime | Date and time the Distribution or Merge Agent was created.
offload_enabled | bit | Specifies that the agent can be activated remotely. 0 specifies the agent cannot be activated remotely. 1 specifies the agent will be activated remotely, and on the remote computer specified in the offload_server property.
offload_server | sysname | Specifies the network name of server to be used for remote agent activation.
sid | varbinary(85) | The security identification number (SID) for the Distribution Agent or Merge Agent during its first execution.

See Also

MSmerge_history

MSpublications


MSmerge_altsyncpartners

The MSmerge_altsyncpartners table tracks the association of who the current synchronization partners are for a Publisher. This table is stored in the publication and subscription databases.

Column name | Data type | Description
subid | uniqueidentifier | Identifier for the original Publisher.
alternate_subid | uniqueidentifier | Identifier for the Subscriber who is the alternate synchronization partner.
description | nvarchar(255) | Description of the alternate synchronization partner.

See Also

sysmergesubscriptions


MSmerge_contents

The MSmerge_contents table contains one row for each row modified in the current database since it was published. This table is used by the merge process to determine the rows that have changed. This table is stored in the publication and subscription databases.

Column name | Data type | Description
tablenick | int | Nickname of the published table.
rowguid | uniqueidentifier | Row identifier for the given row.
generation | int | Generation of the row identified by the tablenick and rowguid.
partchangegen | int | The generation associated with the last data change that could have changed whether the row belongs in a filtered publication.
joinchangegen | int | The generation associated with the last data change to this row that would have changed whether related rows belong in a filtered publication.
lineage | varbinary(249) | Subscriber nickname, version number pairs that are used to maintain a history of changes to this row.
colvl | varbinary(2048) | Column version information.


MSmerge_delete_conflicts

The MSmerge_delete_conflicts table contains information for rows that were deleted because either they conflicted with an update and lost the conflict or the delete was undone to achieve data convergence. This table is stored in the database used for conflict logging, usually the publication database but can be the subscription database if there is decentralized conflict logging.

Column name | Data type | Description
tablenick | int | Nickname of the table.
rowguid | uniqueidentifier | Row identifier for the deleted row.
origin_datasource | varchar(255) | Subscription for which the delete of the row was undone or the delete lost the conflict.
conflict_type | int | Type of conflict: 1 = UpdateConflict: Conflict is detected at the row level. 2 = ColumnUpdateConflict: Conflict detected at the column level. 3 = UpdateDeleteWinsConflict: Delete wins the conflict. 4 = UpdateWinsDeleteConflict: The deleted rowguid that loses the conflict is recorded in this table. 5 = UploadInsertFailed: Insert from Subscriber could not be applied at the Publisher. 6 = DownloadInsertFailed: Insert from Publisher could not be applied at the Subscriber. 7 = UploadDeleteFailed: Delete at Subscriber could not be uploaded to the Publisher. 8 = DownloadDeleteFailed: Delete at Publisher could not be downloaded to the Subscriber.. 9 = UploadUpdateFailed: Update at Subscriber could not be applied at the Publisher 10 = DownloadUpdateFailed: Update at Publisher could not be applied to the Subscriber.
reason_code | int | Error code. May be context-sensitive-based on conflict_type.
reason_text | nvarchar(720) | Description of the error code.
pubid | uniqueidentifier | Publication identifier.
create_time | datetime | The datetime value when the current conflict row was logged.

See Also

sysmergepublications


MSmerge_errorlineage

The MSmerge_errorlineage table contains rows that have been deleted at the Subscriber, but whose delete is not propagated to the Publisher. This table is stored in the publication and subscription databases.

Column name | Data type | Description
tablenick | int | Integer value assigned to the table that is published for merge replication. Corresponds to the nickname field in the sysmergearticles table.
rowguid | uniqueidentifier | Row identifier.
lineage | varbinary(255) | Stores a history list of which Subscribers and Publishers have made updates to a row. Used to detect and resolve conflict situations.


MSmerge_genhistory

The MSmerge_genhistory table contains one row for each generation that a Subscriber knows about (within the retention period). It is used to avoid sending common generations during exchanges and to resynchronize Subscribers that are restored from backups. This table is stored in the publication and subscription databases.

Column name | Data type | Description
guidsrc | uniqueidentifier | Global identifier of the changes identified by generation at the Subscriber.
guidlocal | uniqueidentifier | Local identifier of the changes identified by generation at the Subscriber.
pubid | uniqueidentifier | Publication identifier.
generation | int | Generation value.
art_nick | int | Nickname for the article.
nicknames | varbinary(1000) | A list of nicknames of other Subscribers that are known to already have this generation. Used to avoid sending a generation to a Subscriber that has already seen those changes. Nicknames in the nicknames list are maintained in sorted order to make searches more efficient. If there are more nicknames than can fit in this field, they will not benefit from this optimization.
coldate | datetime | Date when current generation is added to the table.

See Also

sysmergepublications


MSmerge_history

The MSmerge_history table contains history rows for previous updates to Subscriber. This table is stored in the distribution database.

Column name | Data type | Description
agent_id | int | ID of the agent.
runstatus | int | Running status: 1 = Start 2 = Succeed 3 = In progress 4 = Idle 5 = Retry 6 = Fail
start_time | datetime | Time execution of the job began.
time | datetime | Time of this history entry.
duration | int | Cumulative duration, in seconds, of this session.
comments | nvarchar(255) | Message text.
delivery_time | int | Number of seconds it took to apply a batch of changes.
delivery_rate | float | Average delivered commands per second.
publisher_insertcount | int | Number of inserts at the Publisher.
publisher_updatecount | int | Number of updates at the Publisher.
publisher_deletecount | int | Number of deletes at the Publisher.
publisher_conflictcount | int | Number of conflicts at the Publisher.
subscriber_insertcount | int | Number of inserts at the Subscriber.
subscriber_updatecount | int | Number of updates at the Subscriber.
subscriber_deletecount | int | Number of deletes at the Subscriber.
subscriber_conflictcount | int | Number of conflicts at the Subscriber.
error_id | int | ID of an error in the MSrepl_error system table.
timestamp | timestamp | Timestamp column of this table.
updateable_row | bit | Set if the history row can be overwritten.

See Also

MSrepl_errors

MSmerge_agents


MSmerge_replinfo

The MSmerge_replinfo table contains one row for each subscription. This table tracks internal information about the sent and received generation. This table is stored in the publication and subscription databases.

Column name | Data type | Description
repid | uniqueidentifier | Unique ID for the replica.
replnickname | int | Compressed nickname for the replica.
recgen | int | Number of the last generation received.
recguid | uniqueidentifier | Unique ID of the last generation received.
sentgen | int | Number of the last generation sent.
sentguid | uniqueidentifier | Unique ID of the last generation sent.
schemaversion | int | Number of the last schema received.
schemaguid | uniqueidentifier | Unique ID of the last schema received.
merge_jobid | binary(16) | Merge job ID for this subscription.
snapshot_jobid | binary(16) | Snapshot job ID servicing this publication.

See Also

sysmergesubscriptions


MSmerge_subscriptions

The MSmerge_subscriptions table contains one row for each subscription serviced by the Merge Agent at the Subscriber. This table is stored in the distribution database.

Column name | Data type | Description
publisher_id | smallint | ID of the Publisher.
publisher_db | sysname | Name of the Publisher database.
publication_id | int | ID of the publication.
subscriber_id | smallint | ID of the Subscriber.
subscriber_db | sysname | Name of the subscription database.
subscription_type | int | Type of subscription: 0 = Push 1 = Pull 2 = Anonymous
sync_type | tinyint | Type of synchronization: 1 = Automatic 2 = No sync
status | tinyint | Status of the subscription.
subscription_time | datetime | Time the subscription was added.

See Also

MSpublications


MSmerge_tombstone

The MSmerge_tombstone table contains information on deleted rows and allows deletes to be propagated to other Subscribers. This table is stored in the publication and subscription databases.

Column name | Data type | Description
rowguid | uniqueidentifier | Row identifier.
tablenick | int | Nickname of the table.
type | tinyint | Type of delete: 1 = User delete 5 = Row no longer belongs to the filtered partition 6 = System delete
lineage | varbinary(249) | Indicates the version of the record that was deleted, and which updates were known when it was deleted. Allows rules for consistent resolution of a conflict when one Subscriber updates a row while it is being deleted at another Subscriber.
generation | int | Is assigned when a row is deleted. If a Subscriber requests generation N, only tombstones with generation >= N are sent.
reason | nvarchar(255) | Text field containing the reason that tombstone was created.


MSpub_identity_range

The MSpub_identity_range table provides identity range management support. This table is stored in the publication and subscription database.

Column name | Data type | Description
objid | int | ID of the table that has the identity column being managed by replication.
range | bigint | Controls the range size of the consecutive identity values that would be assigned at the subscription in an adjustment.
pub_range | bigint | Controls the range size of the consecutive identity values that would be assigned at the publication in an adjustment.
current_pub_range | bigint | Current range being used by the publication. It can be different than pub_range if viewed after being changed by sp_changearticle and before the next range adjustment.
threshold | int | Percentage value that controls when the Distribution Agent assigns a new identity range. When the percentage of values specified in threshold is used, the Distribution Agent creates a new identity range.
last_seed | bigint | Lower bound of the current range.


MSpublication_access

The MSpublication_access table contains a row for each Microsoft® SQL Server™ login that has access to the specific publication or Publisher. This table is stored in the distribution database.

Column name | Data type | Description
publication_id | int | ID of the publication
login | sysname | Microsoft Windows accounts that exist at both Publisher and Distributor side

See Also

MSpublications


MSpublications

The MSpublications table contains one row for each publication that is replicated by a Publisher. This table is stored in the distribution database.

Column name | Data type | Description
publisher_id | smallint | ID of the Publisher.
publisher_db | sysname | Name of the Publisher database.
publication | sysname | Name of the publication.
publication_id | int | ID of the publication.
publication_type int Type of publication:

0 = Transactional
1 = Snapshot
2 = Merge
thirdparty_flag bit Indicates whether a publication is a Microsoft® SQL Server™ database:

0 = SQL Server
1 = Data source other than SQL Server
independent_agent | bit | Indicates whether there is a stand-alone Distribution Agent for this publication.
immediate_sync | bit | Indicates whether synchronization files are created or re-created each time the Snapshot Agent runs.
allow_push | bit | Indicates whether push subscriptions can be created for the given publication.
allow_pull | bit | Indicates whether pull subscriptions can be created for the given publication.
allow_anonymous | bit | Indicates whether anonymous subscriptions can be created for the given publication.
description | nvarchar(255) | Description of the publication.
vendor_name | nvarchar(100) | Name of the vendor if Publisher is not a SQL Server database.
retention | int | Retention period of the publication, in hours.
sync_method int Synchronization method:

0 = native (produces native-mode bulk copy output of all tables)
1 = character (produces a character-mode bulk copy output of all tables)
3 = concurrent (produces native-mode bulk copy output of all tables but does not lock the table during the snapshot)
4 = concurrent_c (produces a character-mode bulk copy output of all tables but does not lock the table during the snapshot)

The values concurrent and concurrent_c are available for transactional replication and merge replication, but not for snapshot replication.
allow_subscription_copy | bit | Enables or disables the ability to copy the subscription databases that subscribe to this publication. 0 means that copying is disabled, and 1 means it is enabled.
thirdparty_options int Specifies whether the display of a publication in the Replication folder in SQL Server Enterprise Manager is suppressed:

0 = display a heterogeneous publication in the Replication folder in SQL Server Enterprise Manager

1 = suppress the display a heterogeneous publication in the Replication folder in SQL Server Enterprise Manager
allow_queued_tran bit Specifies whether publication allows queued updating:

0 = publication is non-queued
1 = publication is queued

See Also

MSsnapshot_agents

MSdistribution_agents

MSarticles

MSpublisher_databases

MSpublication_access

MSsync_states

MSsubscriptions

MSmerge_subscriptions

MSmerge_agents

MSlogreader_agents


MSpublisher_databases

The MSpublisher_databases table contains one row for each Publisher/Publisher database pair serviced by the local Distributor. This table is stored in the distribution database.

Column name | Data type | Description
publisher_id | smallint | ID of the Publisher.
publisher_db | sysname | Name of the Publisher database.
id | int | ID of the row.

See Also

MSrepl_identity_range

MSrepl_backup_lsns

MSrepl_commands

MSrepl_transactions

MSpublications

MSrepl_originators


MSqreader_agents

The MSqreader_agents table contains one row for each Queue Reader Agent running at the local Distributor. This table is stored in the distribution database.

Column name | Data type | Description
id | int | ID of the Queue Reader Agent.
name | nvarchar(100) | Name of the Queue Reader Agent.
job_id | binary(16) | Unique job ID number from sysjobs table.
profile_id | int | Profile ID from the MSagent_profiles table.

See Also

MSqreader_history


MSqreader_history

The MSqreader_history table contains history rows for the Queue Reader Agents associated with the local Distributor. This table is stored in the distribution database.

Column name | Data type | Description
agent_id | int | ID of the Queue Reader Agent.
publication_id | int | ID of the publication.
runstatus | int | Running state of the agent: 1 = Start 2 = Succeed 3 = In progress 4 = Idle 5 = Retry 6 = Fail
start_time | datetime | Date and time at which agent session started.
time | datetime | Date and time of last logged message.
duration | int | Elapsed time of the logged session activity, in seconds.
comments | nvarchar(255) | Descriptive text.
transaction_id | nvarchar(40) | Transaction ID stored with the message, if applicable.
transaction_status | int | Status of the transaction.
transactions_processed | int | Cumulative number of transactions processed in the session.
commands_processed | int | Cumulative number of commands processed in the session.
delivery_rate | float(8) | Average number of commands delivered per second.
transaction_rate | float(8) | Rate of transactions processed.
subscriber | sysname | Name of the Subscriber.
subscriberdb | sysname | Name of the subscription database.
error_id | int | If not zero, the number represents a Microsoft SQL Server error message.
timestamp | timestamp | Timestamp column for the table.

See Also

MSrepl_errors

MSqreader_agents


MSrepl_backup_lsns

The MSrepl_backup_lsns table contains transaction log sequence numbers (lsn) for supprting the 'sync with backup' option of the Distribution database. This table is stored in the distribution database.

Column name | Data type | Description
publisher_database_id | int | ID of the Publisher database.
valid_xact_id | varbinary(16) | ID of the transaction to be sent to the Publisher to mark the log truncation point. Used only if the Distribution database is in 'sync with backup' mode. Contains the ID of the latest replicated transaction in the Distribution database that has been backed up. It will be sent to the Publisher to mark the log truncation point by the Log Reader.
valid_xact_seqno | varbinary(16) | Sequence number of the transaction to be sent to the Publisher to mark the log truncation point. Used only if the Distribution database is in 'sync with backup' mode. It is the log sequence number of the latest replication transaction in the Distribution database that has been backed up. It will be sent to the Publisher to mark the log truncation point by the Log Reader.
next_xact_id | varbinary(16) | Temporary log sequence number used by backup operations.
nextx_xact_seqno | varbinary(16) | Temporary log sequence number used by backup operations.

See Also

MSpublisher_databases


MSrepl_commands

The MSrepl_commands table contains rows of replicated commands. This table is stored in the distribution database.

Column name | Data type | Description
publisher_database_id | int | ID of the Publisher database.
xact_seqno | varbinary(16) | Transaction sequence number.
type | int | Command type.
article_id | int | ID of the article.
originator_id | int | ID of the originator.
command_id | int | ID of the command.
partial_command | bit | Indicates whether this is a partial command.
command | varbinary(1024) | Command value.

See Also

MSpublisher_databases

MSrepl_transactions

MSrepl_originators


MSrepl_errors

The MSrepl_errors table contains rows with extended Distribution Agent and Merge Agent failure information. This table is stored in the distribution database.

Column name | Data type | Description
id | int | ID of the error.
time | datetime | Time the error occurred.
error_type_id | int | Reserved for future use.
source_type_id | int | Error source type ID.
source_name | nvarchar(100) | Name of the error source.
error_code | sysname | Error code.
error_text | ntext | Error message.
xact_seqno | varbinary(16) | Starting tranaction log sequence number of the failed execution batch. Used only by the Distribution Agents, this is the transaction log sequence number of the first transaction in the failed execution batch.
command_id | int | Command ID of the failed execution batch. Used only by the Distribution Agents, this is the command ID of the first command in the failed execution batch.

See Also

MSdistribution_history

MSsnapshot_history

MSlogreader_history

MSmerge_history

MSqreader_history


MSrepl_identity_range

The MSrepl_identity_range table provides identity range management support. This table is stored in the publication, distribution and subscription databases

Column name | Data type | Description
publisher | sysname | Name of the Publisher.
publisher_db | sysname | Name of the publication database.
tablename | sysname | Name of the table.
identity_support | int | Specifies if automatic identity range handling is enabled. 0 specifies that automatic identity range handling is not enabled.
next_seed | bigint | If automatic identity range is enabled, indicates the starting point of the next range.
pub_range | bigint | Publisher identity range size.
range | bigint | The size of the consecutive identity values that would be assigned to subscribers in an adjustment.
max_identity | bigint | Maximum boundary of the identity range.
threshold | int | Identity range threshold percentage.
current_max | bigint | Current max that can be assigned but not necessarily be assigned.

See Also

MSpublisher_databases


MSrepl_originators

The MSrepl_originators table contains one row for each updatable Subscriber from which the transaction originated. This table is stored in the distribution database.

Column name | Data type | Description
id | int | ID of the updating Subscriber.
publisher_database_id | int | ID of the Publisher database.
srvname | sysname | Name of the updating server.
dbname | sysname | Name of the updating database.

See Also

MSpublisher_databases

MSrepl_commands


MSrepl_transactions

The MSrepl_transactions table contains one row for each replicated transaction. This table is stored in the distribution database.

Column name | Data type | Description
publisher_database_id | int | ID of the Publisher database.
xact_id | varbinary(16) | ID of the transaction.
xact_seqno | varbinary(16) | Sequence number of the transaction.
entry_time | datetime | Time the transaction entered the distribution database.

See Also

MSpublisher_databases

MSrepl_commands


MSrepl_version

The MSrepl_version table contains one row with the current version of replication installed. This table is stored in the distribution database.

Column name | Data type | Description
major_version | int | Major version number of the distribution database.
minor_version | int | Minor version number of the distribution database.
revision | int | Revision number.
db_existed | bit | Indicates whether the distribution database exists before sp_adddistributiondb is called.


MSreplication_objects

The MSreplication_objects table contains one row for each object that is associated with replication in the Subscriber database. This table is stored in the subscription database.

Column name | Data type | Description
publisher | sysname | Name of the Publisher.
publisher_db | sysname | Name of the Publisher database.
publication | sysname | Name of the publication.
object_name | sysname | Name of the object.
object_type | char(2) | Object type: u = Table t = Trigger

See Also

MSreplication_subscriptions


MSreplication_options

The MSreplication_options table stores the type of replication that is installed. This table is stored in the master database.

Column name | Data type | Description
optname | sysname | Type of replication. Values are transactional and merge.
value | bit | Internal status information.
major_version | int | Reserved for future use.
minor_version | int | Reserved for future use.
revision | int | Reserved for future use.
install_failures | int | Reserved for future use.


MSreplication_queue

The MSreplication_queue table is used by the replication process to store the queued commands issued by all the queued updating subscriptions that are using SQL-based queued. . This table is stored in the subscription database.

Column name | Data type | Description
publisher | sysname | Name of the Publisher.
publisher_db | sysname | Name of the publication database.
publication | sysname | Name of the publication.
tranid | sysname | Transaction ID under which the queued command was executed.
data | varbinary(8000) | Packed bytestream that stored information about the queued command.
datalen | int | Length of data, in bytes.
commandtype | int | Type of command being queued: 1 = user command in transaction 2 = subscription synchronization command.
insertdate | datetime | Date of insertion.
orderkey | bigint | Identity column that increases monotonically.
cmdstate | bit | Command state: 0 = complete 1 = partial


MSreplication_subscriptions

The MSreplication_subscriptions table contains one row of replication information for each Distribution Agent servicing the local Subscriber database. This table is stored in the subscription database.

Column name | Data type | Description
publisher | sysname | Name of the Publisher.
publisher_db | sysname | Name of the Publisher database.
publication | sysname | Name of the publication.
independent_agent | bit | Indicates whether there is a stand-alone Distribution Agent for this publication.
subscription_type | int | Type of subscription: 0 = Push 1 = Pull 2 = Anonymous
distribution_agent | sysname | Name of the Distribution Agent.
time | smalldatetime | Time of the last update by Distribution Agent.
description | nvarchar(255) | Description of the subscription.
transaction_timestamp | varbinary(16) | Synctran.
update_mode | tinyint | Type of update.
agent_id | binary(16) | ID of the agent.
subscription_guid | binary(16) | Global identifier for the version of the subscription on the publication.
subid | binary(16) | Global identifier for an anonymous subscription.
immediate_sync | bit | Indicates whether synchronization files are created or re-created each time the Snapshot Agent runs.

See Also

MSsubscription_properties

MSreplication_objects

MSsubscription_agents


MSsnapshot_agents

The MSsnapshot_agents table contains one row for each Snapshot Agent associated with the local Distributor. This table is stored in the distribution database.

Column name | Data type | Description
id | int | ID of the Snapshot Agent.
name | nvarchar(100) | Name of the Snapshot Agent.
publisher_id | smallint | ID of the Publisher.
publisher_db | sysname | Name of the Publisher database.
publication | sysname | Name of the publication.
publication_type | int | Type of publication: 0 = Transactional 1 = Snapshot 2 = Merge
local_job | bit | Indicates whether there is a SQL Server Agent job on the local Distributor.
job_id | binary(16) | Job identification number.
profile_id | int | Configuration ID from the MSagent_profiles table.

See Also

MSsnapshot_history

MSpublications


MSsnapshot_history

The MSsnapshot_history table contains history rows for the Snapshot Agents associated with the local Distributor. This table is stored in the distribution database.

Column name | Data type | Description
agent_id | int | ID of the Snapshot Agent.
runstatus | int | Running status: 1 = Start 2 = Succeed 3 = In progress 4 = Idle 5 = Retry 6 = Fail
start_time | datetime | Time to begin execution of the job.
time | datetime | Time the message is logged.
duration | int | Duration, in seconds, of the message session.
comments | nvarchar(255) | Message text.
delivered_transactions | int | Total number of transactions delivered in the session.
delivered_commands | int | Number of delivered commands per second.
delivery_rate | float | Average delivered commands per second.
error_id | int | ID of the error in the MSrepl_error system table.
timestamp | timestamp | Timestamp column of this table.

See Also

MSrepl_errors

MSsnapshot_agents


MSsubscriber_info

The MSsubscriber_info table contains one row for each Publisher/Subscriber pair that is being pushed subscriptions from the local Distributor. This table is stored in the distribution database.

Column name | Data type | Description
publisher | sysname | Name of the Publisher.
subscriber | sysname | Name of the Subscriber.
type | tinyint | Subscriber type: 0 = Microsoft® SQL Server™ Subscriber 1 = ODBC data source
login | sysname | Login for SQL Server Authentication. Stored in encrypted format if Subscriber is added with SQL Server Authentication mode.
password | nvarchar(524) | Password for SQL Server Authentication. Stored in encrypted format if Subscriber is added with SQL Server Authentication mode.
description | nvarchar(255) | Description of the Subscriber.
security_mode | int | Implemented security mode: 0 = SQL Server Authentication 1 = Windows Authentication

See Also

MSsubscriber_schedule


MSsubscriber_schedule

The MSsubscriber_schedule table contains default merge and transactional synchronization schedules for each Publisher/Subscriber pair. This table is stored in the distribution database.

Column name | Data type | Description
publisher | sysname | Name of the Publisher.
subscriber | sysname | Name of the Subscriber.
agent_type | smallint | Type of agent: 0 = Distribution Agent 1 = Merge Agent
frequency_type | int | Frequency with which to schedule the Distribution Agent: 1 = One time 2 = On demand 4 = Daily 8 = Weekly 16 = Monthly 32 = Monthly relative 64 = Autostart (default) 124 = Recurring
frequency_interval | int | Value to apply to the frequency set by frequency_type.
frequency_relative_interval | int | Date of the Distribution Agent: 1 = First (default) 2 = Second 4 = Third 8 = Fourth 16 = Last
frequency_recurrence_factor | int | Recurrence factor used by frequency_type.
frequency_subday | int | How often to reschedule during the defined period: 1 = Once 2 = Second 4 = Minute (default) 8 = Hour
frequency_subday_interval | int | Interval for frequency_subday.
active_start_time_of_day | int | Time of day when the Distribution Agent will first be scheduled, formatted as HHMMSS.
active_end_time_of_day | int | Time of day when the Distribution Agent will stop being scheduled, formatted as HHMMSS.
active_start_date | int | Date when the Distribution Agent will first be scheduled, formatted as YYYYMMDD.
active_end_date | int | Date when the Distribution Agent will stop being scheduled, formatted as YYYYMMDD.

See Also

MSsubscriber_info


MSsubscription_agents

The MSsubscription_agents table is used by Distribution Agent and triggers of updateable subscriptions to track subscription properties. This table is stored in the subscription database.

Column name | Data type | Description
id | int | ID of the row.
publisher | sysname | Name of the Publisher.
publisher_db | sysname | Name of the publication database.
publication | sysname | Name of the publication.
subscription_type | int | Subscription type: 0 = push 1 = pull 2 = pull anonymous
queue_id | sysname | ID of the Microsoft Message Queue at the Publisher. queue_id is set to SQL for SQL-based queued updating.
update_mode | tinyint | Type of updating: 0 = read only 1 = immediate update 2 = queued update using MSMQ queue 3 = immediate update with queued update as failover using MSMQ queue 4 = queued update using SQL Server queue 5 = immediate update with queued update failover, using SQL Server queue
failover_mode | bit | If a failover type of updating was select, the type of failover chosen: 0 = immediate update is being used. Failover is not enabled. 1 = queued update is being used. Failover is enabled. The queue being used for failover is specified in the update_mode value.
spid | int | System process ID for the connection used by the Distribution Agent that is currently running or has just run.
login_time | datetime | Date and time of the Distribution Agent connection that is currently running or has just run.
allow_subscription_copy | bit | Specifies whether or not the ability to copy the subscription database is allowed.
attach_state | int | For internal use only.
attach_version | binary(16) | Unique identifier representing the version of an attached subscription.
last_sync_status | int | Last run status of the Distribution Agent that is currently running or has just run. Status can be: 1 = Started 2 = Succeeded 3 = In progress 4 = Idle 5 = Retry 6 = Fail
last_sync_summary | sysname | Last message of the Distribution Agent that is currently running or has just run. Status can be: Started Succeeded In progress Idle Retry Fail
last_sync_time | datetime | datetime when the last_sync_summary and last_sync_status columns were updated. Pull or anonymous distribution agents running as SqlServer Agent Service jobs will not update these columns. The history information will instead be logged to the job history table in that case.

See Also

MSreplication_subscriptions

MSsubscription_articles


MSsubscription_articles

The MSsubscription_articles table contains information regarding the articles in a queued subscription. This table is populated only for the replication types of queued updating and immediate updating with queued updating as a failover.

Column name | Data type | Description
agent_id | int | ID of the agent that services this article
artid | int | Article ID from the sysarticles table.
article | sysname | Name of the article from the sysarticles table.
dest_table | sysname | Name of the destination table from the sysarticles table.
owner | sysname | Owner of the subscription.
cft_table | sysname | Name of the conflict table for this article, for queued updating replication type.
columns | binary(32) | Bitmap of the replicated columns of the publication table from the sysarticles table.

See Also

MSsubscription_agents


MSsubscription_properties

The MSsubscription_properties table contains rows for the parameter information for pull Distribution Agents. This table is stored in the subscription database.

Column name | Data type | Description
publisher | sysname | Name of the Publisher.
publisher_db | sysname | Name of the Publisher database.
publication | sysname | Name of the publication.
publication_type | int | Type of publication: 0 = Transactional 2 = Merge
publisher_login | sysname | Login ID used at the Publisher for SQL Server Authentication.
publisher_password | sysname | Password (encrypted) used at the Publisher for SQL Server Authentication.
publisher_security_mode | int | Security mode implemented at the Publisher: 0 = SQL Server Authentication 1 = Windows Authentication 2 = The synchronization triggers use a static sysservers entry to do RPC, and publisher must be defined in the sysservers table as a remote server or linked server.
distributor | sysname | Name of the Distributor.
distributor_login | sysname | Login ID used at the Distributor for SQL Server Authentication.
distributor_password | sysname | Password (encrypted) used at the Distributor for SQL Server Authentication.
distributor_security_mode | int | Security mode implemented at the Distributor: 0 = SQL Server Authentication 1 = Windows Authentication
ftp_address | sysname | Network address of the FTP service for the Distributor.
ftp_port | int | Port number of the FTP service for the Distributor.
ftp_login | sysname | Username used to connect to the FTP service.
ftp_password | sysname | User password used to connect to the FTP service.
alt_snapshot_folder | nvarchar(255) | Specifies the location of the alternate folder for the snapshot.
working_directory | nvarchar(255) | Name of the working directory used to store data and schema files.
use_ftp | bit | Specifies the use of FTP instead of the regular protocol to retrieve snapshots. If 1, FTP is used.
dts_package_name | sysname | Specifies the name of the DTS package.
dts_package_password | nvarchar(524) | Specifies the password on the package, if there is one. A value of NULL means that the package has no password.
dts_package_location | int | Location where the DTS package is stored.
enabled_for_syncmgr | bit | Specifies whether the subscription can be synchronized through the Microsoft Synchronization Manager. If 0, subscription is not registered with Synchronization Manager. If 1, subscription is registered with Synchronization Manager and can be synchronized without starting SQL Server Enterprise Manager.
offload_agent | bit | Specifies if the agent can be activated remotely. If 0, the agent cannot be activated remotely.
offload_server | sysname | Specifies the network name of the server used for remote activation.
dynamic_snapshot_location | nvarchar(255) | Specifies the path to the folder where the snapshot files are saved.

See Also

MSreplication_subscriptions


MSsubscriptions

The MSsubscriptions table contains one row for each subscription serviced by the local Distributor. This table is stored in the distribution database.

Column name | Data type | Description
publisher_database_id | int | ID of the Publisher database.
publisher_id | smallint | ID of the Publisher.
publisher_db | sysname | Name of the Publisher database.
publication_id | int | ID of the publication.
article_id | int | ID of the article.
subscriber_id | smallint | ID of the Subscriber.
subscriber_db | sysname | Name of the subscription database.
subscription_type | int | Type of subscription: 0 = Push 1 = Pull 2 = Anonymous
sync_type | tinyint | Type of synchronization: 1 = Automatic 2 = No sync
status | tinyint | Status of the subscription: 0 = Inactive 1 = Subscribed 2 = Active
subscription_seqno | varbinary(16) | Snapshot transaction sequence number.
snapshot_seqno_flag | bit | 1 = subscription_seqno is the snapshot sequence number.
independent_agent | bit | Indicates whether there is a stand-alone Distribution Agent for this publication.
subscription_time | datetime | --
loopback_detection | bit | Whether the Distribution Agent sends transactions originated at the Subscriber back to the Subscriber: 1 = Does not send back. 0 = Sends back.
agent_id | int | ID of the agent.
update_mode | tinyint | Type of update.
publisher_seqno | varbinary(16) | Sequence number of the transaction at the Publisher for this subscription.
ss_cplt_seqno | varbinary(16) | Sequence number used to signify the completion of the concurrent snapshot processing.

See Also

MSpublications


MSsub_identity_range

The MSsub_identity_range table provides identity range management support for subscriptions. This table is stored in the subscription databases.

Column name | Data type | Description
objid | int | ID of the table that has the identity column being managed by replication.
range | bigint | Controls the range size of the consecutive identity values that would be assigned at the Subscriber in an adjustment.
last_seed | bigint | Lower bound of the current range.
threshold | int | Percentage value that controls when the Distribution Agent assigns a new identity range. When the percentage of values specified in threshold is used, the Distribution Agent creates a new identity range.


MSsync_states

The MSsync_states table tracks which publication is still in concurrent snapshot mode. This table is stored in the distribution database.

Column name | Data type | Description
publisher_id | smallint | ID of the publisher.
publisher_db | sysname | Name of the publication database.
publication_id | int | ID of the publication.

See Also

MSpublications


restorefile

The restorefile table contains one row for each restored file, including files restored indirectly by filegroup name. This table is stored in the msdb database.

Column name | Data type | Description
restore_history_id | int NOT NULL REFERENCES restorehistory(restore_history_id) | Unique identification number identifying the corresponding restore operation.
file_number | numeric(10,0) NULL | File identification number of the restored file. This number must be unique within each database.
destination_phys_drive | varchar(260) NULL | Drive or partition to which the file was restored.
destination_phys_name | varchar(260) NULL | Name of the file, without the drive or partition information, where the file was restored.

See Also

restorehistory


restorefilegroup

The restorefilegroup table contains one row for each restored filegroup. This table is stored in the msdb database.

Column name | Data type | Description
restore_history_id | int NOT NULL REFERENCES restorehistory(restore_history_id) | Unique identification number identifying the corresponding restore operation
filegroup_name | nvarchar(128) NULL | Name of the filegroup being restored

See Also

restorehistory


restorehistory

The restorehistory table contains one row for each restore operation. This table is stored in the msdb database.

Column name | Data type | Description
restore_history_id | int NOT NULL IDENTITY PRIMARY KEY | Unique identification number identifying each restore operation.
restore_date | datetime NULL | Date and time of the restore operation.
destination_database_name | nvarchar(128) NULL | Name of the destination database for the restore operation.
user_name | nvarchar(128) NULL | Name of the user who performed the restore operation.
backup_set_id | int NOT NULL REFERENCES backupset(backup_set_id) | Unique identification number identifying the backup set being restored.
restore_type | char(1) NULL | Type of restore operation: D = Database F = File G = Filegroup L = Log V = Verifyonly
replace | bit NULL | Indicates whether the restore operation specified the REPLACE option: 1 = Specified 0 = Not specified
recovery | bit NULL | Indicates whether the restore operation specified the RECOVERY or NORECOVERY option: 1 = RECOVERY 0 = NORECOVERY
restart | bit NULL | Indicates whether the restore operation specified the RESTART option: 1 = Specified 0 = Not specified
stop_at | datetime NULL | Point in time to which the database was recovered.
device_count | tinyint NULL | Number of devices involved in the restore operation. This number can be less than the number of media families for the backup.
stop_at_mark_name | nvarchar(128) NULL | Indicates recovery to the transaction containing the named mark.
stop_before | bit NULL | Indicates whether the transaction containing the named mark was included in the recovery: 0 = Recovery halted before marked transaction. 1 = Recovery included marked transaction.

See Also

restorefile

restorefilegroup

backupset


Microsoft SQL Server 2000 Copyright and Disclaimer

This document, including sample applications herein, is provided for informational purposes only and Microsoft makes no warranties, either express or implied, in this document. Information in this document, including samples, URL and other Internet Web site references, is subject to change without notice. The entire risk of the use or the results of the use of this document remains with the user.

The primary purpose of a sample is to illustrate a concept, or a reasonable use of a particular statement or clause. Most samples do not include all of the code that would normally be found in a full production system, as a lot of the usual data validation and error handling is removed to focus the sample on a particular concept or statement. Technical support is not available for these samples or for the provided source code.

Unless otherwise noted, the example companies, organizations, products, people, and events depicted herein are fictitious and no association with any real company, organization, product, person, or event is intended or should be inferred. Complying with all applicable copyright laws is the responsibility of the user. Without limiting the rights under copyright, no part of this document may be reproduced, stored in or introduced into a retrieval system, or transmitted in any form or by any means (electronic, mechanical, photocopying, recording, or otherwise), or for any purpose, without the express written permission of Microsoft Corporation.

Microsoft may have patents, patent applications, trademarks, copyrights, or other intellectual property rights covering subject matter in this document. Except as expressly provided in any written license agreement from Microsoft, the furnishing of this document does not give you any license to these patents, trademarks, copyrights, or other intellectual property.

©1996-2000 Microsoft Corporation. All rights reserved.

Active Directory, ActiveX, BackOffice, CodeView, Developer Studio, FoxPro, JScript, Microsoft, Microsoft Press, Microsoft SQL Server, MSDN, MS-DOS, Outlook, PivotChart, PivotTable, PowerPoint, Visual Basic, Visual C++, Visual Studio, Win32, Windows 2000, Windows, and Windows NT are either registered trademarks or trademarks of Microsoft Corporation in the United States and/or other countries.

The names of actual companies and products mentioned herein may be the trademarks of their respective owners.

Version: 8.00.000