Erste Schritte mit Microsoft BizTalkServer2000

BizTalk Server-Banner

Erste Schritte mit Microsoft BizTalk Server 2000

Microsoft BizTalk Server 2000 gehört zur Produktfamilie Microsoft .NET Enterprise Server und vereinigt in einem Produkt die Integration von Unternehmensanwendungen und die Integration von B2B-Anwendungen (Business-to-Business). Mithilfe von BizTalk Server 2000 können Entwickler, IT-Fachleute und Unternehmensexperten dynamische Geschäftsprozesse ausarbeiten, die sich unter Verwendung des Internets über verschiedene Anwendungen, Plattformen und Unternehmen erstrecken.

Neben der Entwicklung von BizTalk Server 2000 hat Microsoft zusammen mit Partnerunternehmen die Entwicklung von Technologien vorangetrieben, die für auf dem Internet basierende Geschäftslösungen erforderlich sind. Dazu gehört BizTalk Framework 2.0, ein plattformunabhängiges XML-Framework (Extensible Markup Language) für die Anwendungsintegration und den elektronischen Handel. BizTalk Framework 2.0 stellt keinen Standard dar, basiert jedoch auf eingeführten Standards, wie z. B. SOAP (Simple Object Access Protocol). SOAP ist auch eine Schlüsseltechnologie in den anderen Komponenten der .NET-Produktlinie, wie z. B. Microsoft Visual Studio 7.0. BizTalk Framework 2.0 stellt für BizTalk Server 2000 die Grundlage für eine übergreifende und zuverlässige Nachrichtenübermittlung zur Verfügung.

Weitere Informationen zu BizTalk Framework 2.0 sowie Informationen zu BizTalk Server 2000-Produktressourcen, wie z. B. Communitydiensten, eine große Schemabibliothek und Whitepaper finden Sie in der Microsoft BizTalk Server 2000-Website (http://www.microsoft.com/biztalk).

Dieser Abschnitt stellt die Funktionen und Dienste sowie das Anwendungs- und Verwaltungsmodell von BizTalk Server 2000 vor. Darüber hinaus finden Sie Informationen zum Verwenden der Onlinehilfe und der Microsoft-Eingabehilfen. Ein BizTalk Server 2000-Glossar steht ebenfalls zur Verfügung. Folgende Themen werden in diesem Abschnitt behandelt:

  • Microsoft BizTalk Server 2000-Hilfe - Einführung

  • BizTalk Server-Glossar

  • Verwenden der Hilfe

  • Eingabehilfen für körperlich Behinderte

  • Microsoft Product Support Services

Copyright © 1999–2000 Microsoft Corporation.
Alle Rechte vorbehalten.


MicrosoftBizTalkServer2000-Hilfe - Einführung

BizTalk Server-Kopfzeile

Microsoft BizTalk Server 2000-Hilfe - Einführung

Microsoft BizTalk Server 2000 stellt eine leistungsstarke webbasierte Entwicklungs- und Ausführungsumgebung bereit, die flexibel verbundene, langlebige Geschäftsprozesse sowohl innerhalb von Unternehmen und als auch zwischen Unternehmen integriert. BizTalk Server kann Transaktionen verarbeiten, die über einen Zeitraum von Wochen oder Monaten und nicht nur von Minuten oder Sekunden ausgeführt werden.

Die BizTalk Server 2000-Features enthalten die Möglichkeit zum Entwickeln und Erstellen von XLANG-Ablaufplänen, zum Integrieren vorhandener Anwendungen, zum Definieren von Dokumentspezifikationen und Spezifikationstransformationen und zum Überwachen und Protokollieren von Aktivität zur Laufzeit.

Der Server stellt einen Standardgateway für das Senden und Empfangen von Dokumenten innerhalb des Internets bereit sowie eine Reihe von Diensten zum Gewährleisten der Datenintegrität, der Übermittlung, der Sicherheit und der Unterstützung für das BizTalk Framework und anderer wichtiger Dokumentformate.

Folgende Themen werden in diesem Abschnitt behandelt:

  • BizTalk Server-Features

  • BizTalk-Dienste

  • BizTalk Server-Anwendungsmodell

  • BizTalk Server-Verwaltungsmodell

  • BizTalk Server-Glossar
mailto:btsdfde@microsoft.com


BizTalkServer-Features

BizTalk Server-Kopfzeile

BizTalk Server-Features

Die folgende Tabelle stellt die BizTalk Server-Features und deren Aufgaben bereit.

Feature Funktion
Verwaltung
  • Serververwaltung

  • Programmgesteuerte Administration
  • Erstellen und Verwalten von Servern und Servergruppen

  • Konfigurieren globaler Servergruppeneigenschaften, wie z. B. den Speicherort der Datenbank für gemeinsam genutzte Warteschlangen und der Überwachungsdatenbank

  • Konfigurieren von Servereinstellungen

  • Konfigurieren und Verwalten von Empfangsfunktionen

  • Anzeigen und Verwalten von Dokumentwarteschlangen

  • Programmgesteuertes Zugreifen auf den System-Manager der XLANG-Ablaufplanung (XLANG Scheduler), XLANG-Gruppen-Manager, XLANG-Ablaufplaninstanzen und XLANG-Ports
Dokumentüberwachung
  • Überwachen von Dokumenten
  • Überwachen des Status von Dokumenten, die von Microsoft BizTalk Server 2000 verarbeitet werden

  • Suchen, Anzeigen und Speichern vollständiger Kopien von Austauschvorgängen und Dokumenten, die von BizTalk Server 2000 verarbeitet werden

  • Erstellen von Abfragen zum Extrahieren wesentlicher Informationen aus der Überwachungsdatenbank in einem überschaubaren Format

  • Extrahieren, Speichern und Analysieren wichtiger benutzerdefinierter Daten in Dokumenten
Orchestrierungsentwurf
  • Entwerfen von BizTalk-Orchestrierungen
  • Erstellen von Zeichnungen zur Abbildung von Geschäftsprozessen und deren programmgesteuerte Implementierung innerhalb einer integrierten Entwurfsumgebung

  • Kompilieren von XLANG-Ablaufplanzeichnungen in XLANG-Ablaufpläne

  • Definieren des Nachrichtendatenflusses innerhalb von Geschäftsprozessen
Messaging
  • Verwenden des BizTalk-Messaging-Managers

  • Zugreifen auf das BizTalk-Messaging-Konfigurationsobjektmodell
  • Lokale oder Remoteverwaltung des Datenaustauschs mithilfe des BizTalk-Messaging-Managers

  • Programmgesteuertes Verwalten des Datenaustauschs mithilfe des BizTalk-Messaging-Konfigurationsobjektmodells

  • Erstellen und Verwalten von Kanälen, Messagingports, Dokumentdefinitionen, Umschlägen, Organisationen und Verteilerlisten
XML-Tools
  • Erstellen von Spezifikationen

  • Zuordnen von Daten
  • Erstellen und Verwalten von Spezifikationen

  • Erstellen von Datensätzen und Feldern und Festlegen der entsprechenden Eigenschaften

  • Zuordnen von Datensätzen und Feldern in einer Quellspezifikation zu Datensätzen und Feldern in einer Zielspezifikation

  • Verwenden von Funktoiden zum Implementieren leistungsstarker Datentransformationsfunktionen


BizTalk-Dienste

Microsoft BizTalk Server 2000 bietet umfassende Messaging- und Orchestrierungsdienste, mit deren Hilfe Sie Geschäfts- und Datenaustauschprozesse automatisieren können.

BizTalk-Messagingdienste

Die BizTalk-Messagingdienste kommen bei folgenden Aufgaben zum Einsatz: Empfangen eingehender Dokumente, Analysieren der Dokumente zum Ermitteln ihres spezifischen Formats, Extrahieren der Schlüsselbezeichner und Identifizieren bestimmter Verarbeitungsregeln, Übermitteln von Dokumenten an die vorgesehenen Ziele und Überwachen von Dokumenten. Ferner sind Dienste vorhanden für die Datenzuordnung, die Erstellung und Korrelation von Empfangsbestätigungen und für den Schutz von Datenintegrität und -sicherheit.

Empfangsfunktionen

BizTalk Server 2000 stellt Empfangsfunktionen bereit, durch die der Server die Dokumente überwachen kann, die an die angegebenen Zielorte gesendet werden. BizTalk Server 2000 unterstützt die folgenden Empfangsfunktionen, die mithilfe der BizTalk Server-Verwaltung konfiguriert werden:

  • Datei

  • Message Queuing

BizTalk Server 2000 unterstützt ferner die folgenden Protokolle, die mithilfe von ASP-Seiten oder eines Microsoft Exchange-Skripts konfiguriert werden:

  • HTTP (ASP-Seite)

  • HTTPS (ASP-Seite)

  • SMTP (Microsoft Exchange-Skript)

Transportdienste

BizTalk Server 2000 stellt Transportdienste bereit, mit denen Dokumente an ihr Ziel übertragen werden. BizTalk Server 2000 unterstützt die folgenden Transportdienste:

  • HTTP

  • HTTPS

  • SMTP

  • Datei

  • Message Queuing

  • Anwendungsintegrationskomponenten

  • Loopback

Datenparser

BizTalk Server 2000 unterstützt Datenparser für eine Vielzahl von Dokumentstandards, wie z. B. ANSI X12, UN/EDIFACT und gültige, wohlgeformte Extensible Markup Language (XML). BizTalk Server 2000 unterstützt auch BizTalk Framework 2.0. Weitere Informationen zu BizTalk Framework 2.0 finden Sie in der Microsoft BizTalk Server 2000-Website (www.microsoft.com/biztalk/). Für Flatfiles ist ebenfalls eine Parserunterstützung vorhanden. Sie können auch eigene benutzerdefinierte Parserkomponenten registrieren und verwenden.

Datenüberprüfung

BizTalk Server 2000 stellt eine Datenüberprüfung bereit, bei der jede Instanz eines Dokuments mit einer Spezifikation abgeglichen wird. Wenn das Dokument nicht den Regeln der Spezifikation entspricht, wird es zur weiteren Überprüfung in einer Angehalten-Warteschlange abgelegt.

Zuverlässige Dokumentübermittlung

BizTalk Server 2000 stellt eine zuverlässige Dokumentübermittlung mithilfe konfigurierbarer Eigenschaften der BizTalk-Messagingdienste bereit. Zu den Eigenschaften zählen das Festlegen der Dienstfenster für das Senden von Dokumenten, das Senden und Empfangen von Empfangsbestätigungen, das Festlegen der Anzahl der Neuversuche und das Festlegen des Zeitraums zwischen Neuversuchen. BizTalk Server 2000 unterstützt die Verwendung BizTalk Framework-kompatibler Umschläge, die zuverlässige Messagingfunktionen ermöglichen. Weitere Informationen zu BizTalk Framework 2.0 finden Sie in der Microsoft BizTalk Server 2000-Website (www.microsoft.com/biztalk/). BizTalk Server 2000 legt ferner Dokumente in Warteschlangen an einem zentralen Speicherort ab. Bei einem Serverausfall können mithilfe von Rollovermechanismen neue Server aktiviert werden, welche die Steuerung über die Dokumente übernehmen und diese verarbeiten.

Sicherheit

BizTalk Server 2000 unterstützt Verschlüsselung und digitale Signaturen. Die Verschlüsselung öffentlicher Schlüssel wird für alle Dokumente unterstützt, die mithilfe der BizTalk Server-Transportdienste übermittelt werden. BizTalk Server unterstützt außerdem die Entschlüsselung und Signaturüberprüfung für empfangene Dokumente.

BizTalk-Orchestrierungsdienste

Die BizTalk-Orchestrierungsdienste ermöglichen die Integration lang dauernder Geschäftsprozesse mit den Anwendungen, die diese Geschäftsprozesse ausführen. Für die Integration verantwortlich ist eine ausführbare Geschäftsprozessdatei, die XLANG-Ablaufplan genannt wird. Weitere Dienste ermöglichen die Steuerung der Ausführung von XLANG-Ablaufplaninstanzen.

Eine Schlüsselfunktion der BizTalk-Orchestrierungsdienste ist die Fähigkeit, komplexe Transaktionen zu verarbeiten, die nicht nur Minuten oder Stunden, sondern Wochen oder Monate dauern. Eine weitere wichtige Funktion ist die Möglichkeit der Implementierung paralleler Aktionen innerhalb eines einzelnen XLANG-Ablaufplanes.

XLANG-Ablaufpläne

Ein XLANG-Ablaufplan ist ein Geschäftsprozess, der implementiert wird, indem jeder Schritt in dem Prozess mit einer Technologiekomponente oder einem Dienst verbunden wird, die/der diesen Schritt ausführt. Ein XLANG-Ablaufplan wird anschließend von einem Dienst ausgeführt, der XLANG-Ablaufplanungsmodul genannt wird. Dieses Modul steuert die Instanziierung, Ausführung, Pausierung und Aktivierung eines XLANG-Ablaufplanes oder mehrerer Instanzen eines oder mehrerer Ablaufpläne.

Implementierungstechnologien

Zu den von den BizTalk-Orchestrierungsdiensten unterstützten Implementierungstechnologien zählen die BizTalk-Messagingdienste, COM-Komponenten, Message Queuing-Dienste und Windows-Skriptkomponenten.

Die Sprache XLANG

XLANG ist eine Sprache, welche die logische Abfolge von Geschäftsprozessen sowie die Implementierung von Geschäftsprozessen mithilfe von verschiedenen Technologiekomponenten und Diensten beschreibt. Die Sprache XLANG wird in XML (Extensible Markup Language) ausgedrückt.


BizTalk Server-Anwendungsmodell

Microsoft BizTalk Server 2000 stellt Tools und Dienste bereit, mit denen Sie ausführbare Anwendungen zum Steuern von Geschäftsprozessen und zum Austausch von Daten zwischen Handelspartnern und Anwendungen innerhalb eines Unternehmens erstellen können. Eine Liste der von BizTalk Server 2000 bereitgestellten Dienste finden Sie unter BizTalk-Dienste.

Das Integrieren der BizTalk-Orchestrierungsdienste und der BizTalk-Messagingdienste ermöglicht den Austausch von Dokumenten und Nachrichten zwischen Ihren Handelspartnern und internen Anwendungen mithilfe mehrerer Transportdienste. Das BizTalk Server-Anwendungsmodell übernimmt außerdem Folgendes:

  • Steuerung komplexer, langlebiger Transaktionen und Geschäftsprozesse.

  • Zuverlässige Übermittlung von Dokumenten und Nachrichten.

  • Datenüberprüfung durch Abgleichen jeder Dokumentinstanz mit einer Spezifikation.

  • Datenzuordnung mithilfe von Zuordnungen zum Transformieren der Dokumentstruktur und des Dokumentformats.

  • Datensicherheit und –integrität mithilfe von Verschlüsselung und digitaler Signaturzertifikate.

  • Generierung von Empfangsbestätigungen und Korrelationsunterstützung.

Weitere Informationen zum Konfigurieren von BizTalk Server 2000 für das Senden und Empfangen von Empfangsbestätigungen finden Sie unter Grundlegendes zu Empfangsbestätigungen.

Detaillierte Informationen zum Integrieren der BizTalk-Orchestrierungsdienste und der BizTalk-Messagingdienste finden Sie unter Integrieren der BizTalk-Dienste.


BizTalkServer-Verwaltungsmodell

BizTalk Server-Kopfzeile

BizTalk Server-Verwaltungsmodell

Die folgende Tabelle stellt die vier Hauptverwaltungsbereiche von Microsoft BizTalk Server 2000 sowie die jeweiligen Verwaltungsfunktionen in den einzelnen Bereichen vor.

Verwaltungsbereich Verwaltungsfunktionen
Serververwaltung
  • Konfigurieren und Verwalten von Servergruppen und Servern

  • Konfigurieren und Verwalten von Empfangsfunktionen

  • Verwalten von Warteschlangen
Anwendungsverwaltung
  • Konfigurieren und Verwalten von COM+-Anwendungen, die als Host für XLANG-Ablaufpläne dienen

  • Konfigurieren und Verwalten der Standardanwendung XLANG-Ablaufplanung (XLANG Scheduler)
Programmgesteuerte Verwaltung
  • Konfigurieren von XLANG-System-Managern, XLANG-Gruppen-Managern, XLANG-Ablaufplaninstanzen und XLANG-Ports
Datenbankverwaltung
  • Konfigurieren, Verwaltung und Pflegen der folgenden Datenbanken:
    • BizTalk-Messaging-Verwaltung

    • Persistenzdatenbank für die Orchestrierung

    • Überwachung

    • Datenbank für gemeinsam genutzte Warteschlangen

Serververwaltung

Die Serververwaltung in BizTalk Server 2000 umfasst Aufgaben wie das Verwalten und Konfigurieren von Servergruppen, das Hinzufügen, Löschen und Konfigurieren von Servern, das Hinzufügen und Konfigurieren von Empfangsfunktionen, das Verwalten der gemeinsam genutzten Warteschlangen von Servergruppen usw. Die folgende Tabelle stellt die allgemeinen Serververwaltungsaufgaben samt einer Beschreibung vor und gibt Quellen für weitere Informationen an.

Verwaltungsaufgabe Beschreibung Informationsquellen
Konfigurieren von Servern und Servergruppen
  • Konfigurieren der Verbindungen zwischen der Überwachungsdatenbank und der Datenbank für gemeinsam genutzte Warteschlangen

  • Konfigurieren der Transportdienste und Parserreihenfolge

  • Konfigurieren von Servereinstellungen
  • Hinzufügen, Löschen und Konfigurieren einer Servergruppe

  • Hinzufügen, Löschen und Konfigurieren von Servern in einer Gruppe
Verwalten von Warteschlangen
  • Löschen und erneutes Senden von Austauschvorgängen und Dokumenten

  • Anzeigen von Daten und Fehlermeldungen
  • Verwalten von Warteschlangen
Verwalten von Empfangsfunktionen
  • Konfigurieren von Empfangsfunktionen
  • Verwalten von Empfangsfunktionen für eine Servergruppe
Problembehandlung
  • Behandeln von Server- und Dokumentverarbeitungsproblemen
  • Verwalten der Ereignisanzeige

  • Problembehandlung - BizTalk Server-Verwaltung

Anwendungsverwaltung

Die Anwendungsverwaltung umfasst das Konfigurieren und Verwalten der COM+-Anwendungen, die als Host für XLANG-Ablaufpläne dienen, der Standardanwendung XLANG-Ablaufplanung (XLANG Scheduler) und der Persistenzdatenbank für die Orchestrierung, die bei der Installation von BizTalk Server 2000 installiert wird. Die folgende Tabelle stellt die allgemeinen Anwendungsverwaltungsaufgaben samt einer Beschreibung vor und gibt Quellen für weitere Informationen an.

Verwaltungsaufgabe Beschreibung Informationsquellen
Verwalten der Standardanwendung XLANG-Ablaufplanung (XLANG Scheduler)
  • Ändern der Konfigurationseinstellungen der Anwendung XLANG-Ablaufplanung (XLANG Scheduler)
  • Verwalten der Standardanwendung XLANG-Ablaufplanung (XLANG Scheduler) und -Datenbank
Verwalten von COM+-Anwendungen
  • Erstellen von COM+-Anwendungen, die bestimmte XLANG-Ablaufpläne ausführen
  • Verwalten von weiteren COM+-Hostanwendungen für XLANG-Ablaufpläne

Programmgesteuerte Verwaltung

Die Verwaltung von Servern und Anwendungen kann programmgesteuert erfolgen. Die folgende Tabelle stellt die allgemeinen programmgesteuerten Verwaltungsaufgaben samt einer Beschreibung vor und gibt Quellen für weitere Informationen an.

Verwaltungsaufgabe Beschreibung Informationsquellen
Verwalten von Warteschlangen
  • Anzeigen von Austausch- und Dokumentdaten

  • Bearbeiten der BizTalk-Messaging-Verwaltungsdatenbank

  • Lesen von Informationen in der Datenbank für gemeinsam genutzte Warteschlangen
  • Weitere Informationen zum Verwenden der Windows-Verwaltungsinstrumentation (WMI) und zur WMI-Anwendungsprogrammierung finden Sie in der MSDN Online Library-Website (msdn.microsoft.com/library/default.asp). Suchen Sie in der Website nach "WMI Application Programming".

  • WMI - Übersicht

  • Accessing the Suspended queue
Konfigurieren und Verwalten von System-Mangern für die XLANG-Ablaufplanung (XLANG Scheduler), XLANG-Gruppen-Managern, XLANG-Ablaufplaninstanzen und XLANG-Ports
  • Starten und Beenden des System-Managers für die XLANG-Ablaufplanung (XLANG Scheduler) und von Gruppen-Managern sowie Abrufen dazugehöriger Informationen

  • Beenden, Unterbrechen, Wiederaufnehmen der Ablaufpläne, die einer Gruppe zugeordnet sind, sowie das Abrufen dazugehöriger Informationen.
  • Administering XLANG Schedules

Datenbankverwaltung

Neben Aufgaben, die zur normalen Datenbankpflege und -administration gehören, wie z. B. Komprimieren von Datendateien und Sichern der Datenbank- und Transaktionsdateiprotokolle, müssen Sie weitere Datenbankaufgaben ausführen, wie z. B. Aufrechterhalten der Verbindungen zwischen BizTalk Server und Microsoft SQL Server, Hinzufügen, Löschen und Wiederherstellen von Datenbanken, Konfigurieren neuer Datenbanken usw. Die folgende Tabelle stellt die allgemeinen Datenbankverwaltungsaufgaben samt einer Beschreibung vor und gibt Quellen für weitere Informationen an.

Verwaltungsaufgabe Beschreibung Informationsquellen
Verwalten von Datenbanken
  • Konfigurieren und/oder Bearbeiten der BizTalk-Messaging-Verwaltungsdatenbank

  • Erstellen und Konfigurieren neuer Persistenzdatenbanken

  • Wiederherstellen und/oder manuelles Entfernen der Überwachungsdatenbank und der Datenbank für gemeinsam genutzte Warteschlangen
  • Konfigurieren der BizTalk-Messaging-Verwaltungsdatenbank

  • Ändern der BizTalk-Messaging-Verwaltungsdatenbank für einen Server

  • Ändern der Einstellungen der Persistenzdatenbank für die Orchestrierung

  • Verwalten von Datenbanken für eine Servergruppe
Überwachen des eingehenden Datenbankverkehrs
  • Konfigurieren von Servereinstellungen
  • Grundlegendes zu Servereigenschaften

  • Optimieren der Servereigenschaften


BizTalk Server-Glossar

A

Abbruch (abort)

Eine laufende Transaktion wird abgebrochen, und ein alternativer Geschäftsprozess wird ausgeführt.

Aktion (action)

Eine Nachricht wird gesendet oder empfangen. Sende- oder Empfangsaktionen können synchron oder asynchron sein, abhängig von den in einem XLANG-Ablaufplan implementierten Anwendungsdiensten.

Aktivieren (rehydrate)

Ruft alle Statusinformationen für eine XLANG-Ablaufplaninstanz aus einer SQL Server-Datenbank ab, nachdem das XLANG-Ablaufplanmodul eine Nachricht erhalten hat.

Siehe auch: XLANG-Ablaufplanungsmodul (XLANG Scheduler Engine)

Angehalten-Warteschlange (Suspended queue)

Eine Tabelle innerhalb der Datenbank für gemeinsam genutzte Warteschlangen in Microsoft SQL Server. Die Angehalten-Warteschlange ist mit einer Servergruppe verbunden. Die Warteschlange enthält Arbeitselemente, bei denen während der Verarbeitung Fehler aufgetreten sind. Die Dokumente werden in der Warteschlange gespeichert, bis sie korrigiert, erneut verarbeitet oder gelöscht werden.

Siehe auch: Wiederholungswarteschlange (Retry queue), Geplant-Warteschlange (Scheduled queue), Datenbank für gemeinsam genutzte Warteschlangen (Shared Queue database), Verarbeitungswarteschlange (Work queue)

ANSI X12 (ANSI X12)

EDI-Standard, der vom Accredited Standards Committee X12 festgelegt wurde. Diese Institution ist vom American National Standards Institute anerkannt.

Asynchrone Kommunikation (asynchronous communication)

Eine einzelne Nachricht, die im Kontext einer einzelnen Kommunikationsaktion gesendet oder empfangen wird.

Siehe auch: Synchrone Kommunikation (synchronous communication)

Austausch (interchange)

Eine oder mehrere Dokumentinstanzen, die eine einzelne Übertragung bilden und zwischen Anwendungen innerhalb einer Organisation oder zwischen Handelspartnern ausgetauscht werden.

Äußere Transaktion (outer transaction)

Eine Transaktion, deren Prozessfluss eine oder mehrere andere Transaktionen enthält.

Siehe auch: Innere Transaktion (inner transaction), Langlebige Transaktion (long-running transaction), Geschachtelte Transaktion (nested transaction), Transaktion (transaction)

Auswahlkriterien (selection criteria)

Ein Name/Wert-Paar, das in einer Dokumentdefinition festgelegt wurde. Name/Wert-Paare werden verwendet, um eine Dokumentdefinition für eingehende EDI-Austauschvorgänge auf der Basis von Werten in der Funktionsgruppenkopfzeile eindeutig zu identifizieren und um Werte in der Funktionsgruppenkopfzeile für ausgehende EDI-Austauschvorgänge einzufügen.

Siehe auch: Dokumentdefinition (document definition), EDI (Electronic Data Interchange) (electronic data interchange (EDI))

B

Bindung (binding)

Ein Prozess, bei dem die zur Implementierung eines Ports zu verwendende Technologie festgelegt wird.

Siehe auch: Port (port)

BizTalk-Dokumentüberwachung (BizTalk Document Tracking)

Eine webbasierte Benutzeroberfläche, die für den Zugriff auf Überwachungsinformationen zu BizTalk-Messagingdiensten verwendet wird. Darüber hinaus kann der XLANG-Ablaufplanzustand für BizTalk-Orchestrierungsdienste überwacht werden.

BizTalk-Editor (BizTalk Editor)

Ein Tool, mit dem Sie Spezifikation erstellen, bearbeiten und verwalten können. Mit dem BizTalk-Editor können Sie eine Spezifikation auf der Basis einer Spezifikationsvorlage, eines vorhandenen Schemas, bestimmter Typen von Dokumentinstanzen oder einer leeren Spezifikation erstellen.

BizTalk Framework (BizTalk Framework)

Ein plattformunabhängiges E-Commerce-Framework, das auf XML-Schemas (Extensible Markup Language) und Industriestandards basiert. Auf dieser Grundlage ist eine branchenübergreifende Integration zwischen Geschäftssystemen möglich, unabhängig von der Plattform, dem Betriebssystem oder der zugrunde liegenden Technologie. Das Framework besteht aus drei Komponenten: Schema, Produkten und Diensten. Weitere Informationen zum BizTalk Framework finden Sie in der BizTalk-Website (www.microsoft/biztalk/).

BizTalk-Mapper (BizTalk Mapper)

Mit diesem Tool können Sie Zuordnungen erstellen, die die Entsprechungen zwischen den Datensätzen und Feldern in einer Spezifikation und den Datensätzen und Feldern in einer anderen Spezifikation definieren. Eine Zuordnung enthält ein XSL-Stylesheet (Extensible Stylesheet Language), mit dem BizTalk Server die in der Zuordnung beschriebene Transformation durchführt.

BizTalk-Messagingdienste (BizTalk Messaging Services)

Folgende Dienste stehen zur Verfügung: Senden, Empfangen, Analysieren, Überwachen von Dokumenten; Empfangsbestätigungsgenerierung und -korrelation; Datenzuordnung, -integrität und -sicherheit.

Siehe auch: BizTalk-Messaging-Manager (BizTalk Messaging Manager)

BizTalk-Messaging-Manager (BizTalk Messaging Manager)

Eine grafische Benutzeroberfläche, mit der BizTalk-Messagingdienste für den Austausch von Dokumenten zwischen Handelspartnern und Anwendungen der eigenen Organisation konfiguriert werden können.

Siehe auch: BizTalk-Messagingdienste (BizTalk Messaging Services)

BizTalk-Messaging-Verwaltungsdatenbank (BizTalk Messaging Management database)

Eine Microsoft SQL Server-Datenbank, die Informationen zu sämtlichen Serverkonfigurationen enthält, z. B. Gruppen- und Servereinstellungen, Empfangsfunktionen und alle Messaging-Konfigurationsinformationen für Objekte, die mithilfe des BizTalk-Messaging-Managers oder durch Zugriff auf die BizTalk-Messaging-Konfigurationsobjektmodelle erstellt wurden.

BizTalk-Orchestrierungsdienste (BizTalk Orchestration Services)

Zu diesen Diensten gehören das Entwerfen, Kompilieren und Ausführen von XLANG-Ablaufplänen. Außerdem besteht die Möglichkeit, benutzerdefinierte COM+-Anwendungen für das Hosting dezidierter XLANG-Ablaufplaninstanzen zu erstellen sowie die Persistenz von XLANG-Ablaufplänen zu gewährleisten.

BizTalk-Orchestrierungs-Designer (BizTalk Orchestration Designer)

Mit diesem Designtool können Sie Zeichnungen erstellen, die langlebige, ausführbare Geschäftsprozesse mit flexiblen Verbindungen darstellen. Die XLANG-Ablaufplanzeichnung wird in einen XLANG-Ablaufplan kompiliert, der zur Ausführung automatischer Geschäftsprozesse verwendet wird.

BizTalk Server 2000 (BizTalk Server 2000)

Ein neues Microsoft-Produkt für die Automatisierung von Geschäftsprozessen und die Anwendungsintegrierung in und zwischen Organisationen. BizTalk Server 2000 stellt eine leistungsstarke webbasierte Entwicklungs- und Ausführungsumgebung bereit, die langlebige Geschäftsprozesse mit flexiblen Verbindungen innerhalb von und zwischen Unternehmen integriert.

BizTalk Server 2000 umfasst folgende Funktionen: die Komposition neuer und vorhandener XLANG-Ablaufpläne; die Integration zwischen vorhandenen Anwendungen; die Definition von Dokumentspezifikationen und Spezifikationstransformationen; die Überwachung und Protokollierung von Laufzeitaktivität.

Der Server stellt einen Standardgateway für das Senden und Empfangen von Dokumenten über das Internet bereit. Außerdem bietet er eine Reihe von Diensten zur Gewährleistung von Datenintegrität, -übermittlung und -sicherheit sowie Unterstützung für das BizTalk Framework und andere wichtige Dokumentformate.

BizTalk Server-Verwaltung (BizTalk Server Administration)

Eine MMC-Schnittstelle (Microsoft Management Console) für die Verwaltung der BizTalk Server 2000-Servergruppe und ihrer Eigenschaften, die Überwachung von Empfangsfunktionen und die Überwachung von Arbeitselementen in den von der Servergruppe verwendeten Microsoft SQL Server-Warteschlangen.

C

Codeliste (code list)

Eine Liste von Codewerten, die als Abkürzungen für eine Vielzahl von Textinformationen verwendet werden. Beispielsweise steht der Wert ST in der Codeliste für Ship To und wird zur Angabe einer Adresse verwendet.

Commit (commit)

Implementiert alle Änderungen, die von einer anstehenden Transaktion angefordert wurden. Diese Aktion wird durchgeführt, wenn alle Aktionen innerhalb einer Transaktion erfolgreich abgeschlossen wurden.

D

Datenbank für gemeinsam genutzte Warteschlangen (Shared Queue database)

Eine Microsoft SQL Server-Datenbank, die von allen Servern in einer Servergruppe gemeinsam genutzt wird. In der Datenbank für gemeinsam genutzte Warteschlangen sind sämtliche Prüfpunktinformationen gespeichert, die sich auf von BizTalk Server verarbeitete Dokumente beziehen. Im Fall eines Serverfehlers können andere Computer, die dieselbe Datenbank für gemeinsam genutzte Warteschlangen verwenden, weiterhin Nachrichten aus der Verarbeitungswarteschlange abrufen bzw. an diese senden. Auf diese Weise werden Redundanz und Prozesslastenausgleich gewährleistet. Die Datenbank für gemeinsam genutzte Warteschlangen wird in der BizTalk Server-Verwaltung grafisch als verschiedene Warteschlangen dargestellt.

Siehe auch: Wiederholungswarteschlange (Retry queue), Geplant-Warteschlange (Scheduled queue), Angehalten-Warteschlange (Suspended queue), Verarbeitungswarteschlange (Work queue)

Datenkonvertierung (data translation)

Ein Prozess, bei dem Daten von einem Format in ein anderes konvertiert werden. Datenkonvertierungen werden zur Laufzeit von BizTalk Server durchgeführt. Die in der Zuordnung definierten Regeln werden verwendet, um Daten mit dem Format der Quellspezifikation in das Format der Zielspezifikation zu konvertieren und um gegebenenfalls erforderliche Operationen oder Berechnungen an den Daten durchzuführen.

Siehe auch: Kompilieren (compile), Datenzuordnung (data mapping), XML (Extensible Markup Language) (Extensible Markup Language (XML)), Zuordnung (map)

Datenzuordnung (data mapping)

Im BizTalk-Mapper kann eine Entsprechung zwischen den Datensätzen und Feldern einer Quellspezifikation und Datensätzen und Feldern einer Zielspezifikation hergestellt werden.

Siehe auch: Kompilieren (compile), Datenkonvertierung (data translation)

Dokument mit automatischem Routing (self-routing document)

Ein Dokument, das alle erforderlichen Routinginformationen, z. B. Quell- und Zielorganisationskennzeichen sowie eine Dokumentdefinition, in den Routingtags oder innerhalb des Dokuments enthält.

Dokument ohne automatisches Routing (non-self-routing document)

Ein Dokument, dem eine oder mehrere der folgenden Routinginformationen fehlen: Quellorganisationskennzeichen, Zielorganisationskennzeichen, Dokumentdefinition.

Dokumentdefinition (document definition)

Eine Reihe von Eigenschaften, die ein bestimmtes Dokument repräsentiert. Dokumentdefinitionseigenschaften enthalten einen Verweis auf eine Dokumentspezifikation und können außerdem globale Überwachungsfelder und Auswahlkriterien enthalten.

Siehe auch: Globale Überwachungsfelder (global tracking fields), Auswahlkriterien (selection criteria)

Dokumentinstanz (document instance)

Eine Darstellung der tatsächlichen Daten, die an BizTalk Server gesendet wird. Der Unterschied zwischen einer Dokumentinstanz und einer Spezifikation besteht darin, dass die Spezifikation die Struktur der Daten definiert, während eine Dokumentinstanz die konkreten Daten innerhalb einer Struktur darstellt.

Siehe auch: Globale Überwachungsfelder (global tracking fields), Pass-Through-Versendung (pass-through submission)

Dokumentstandard (document standard)

Die Struktur, die eine Transaktionsmenge definiert, z. B. ein X12 850-Standard. Anhand eines Dokumentstandards kann ein Implementierungsbericht erstellt werden.

Dokumenttyp (document type)

Bezeichnung des Dokumenttyps, auf dem eine Spezifikation basiert. Wenn eine Spezifikation beispielsweise auf dem X12-Standard 850Schema.xml basiert und diese Spezifikation im BizTalk-Editor geöffnet wird, wird 850 im Feld Dokumenttyp auf der Registerkarte Verweis für den Stammknoten angezeigt.

Dokumenttypdefinition (DTD) (document type definition (DTD))

Eine Standarddefinition, die angibt, welche Elemente und Attribute in anderen Elementen und Attributen enthalten sind, und die Beschränkungen bezüglich deren Reihenfolge, Häufigkeit und Inhalt festlegt.

Dynamische Warteschlange (dynamic queue)

Eine Warteschlange mit einer unbekannten Adresse. Ports, für die Message Queuing implementiert wurde, können eine dynamische Warteschlange verwenden, wenn der Standort der Warteschlange nicht bekannt ist. Die Adresse für diese Warteschlage muss durch eine Nachricht bereitgestellt werden, die die Warteschlangenadresse zur Laufzeit an den Portverweis weiterleitet.

Siehe auch: Statische Warteschlange (static queue), Instanzbezogene Warteschlange (per-instance queue)

Dynamischer Port (dynamic port)

Ein Port, der spezielle Standortinformationen für einen XLANG-Ablaufplan zur Laufzeit anfordert. Der Standort für einen dynamischen Port wird durch eine Nachricht bereitgestellt, die Standortinformationen zur Laufzeit an den Portverweis weiterleitet.

Siehe auch: Port (port), Statischer Port (static port)

E

EDI (Electronic Data Interchange) (electronic data interchange (EDI))

Eine Reihe von Standards, über die die Übertragung von Dokumenten, z. B. Aufträge oder Rechnungen, zwischen Computern gesteuert wird.

Siehe auch: Auswahlkriterien (selection criteria)

Eigene Organisation (home organization)

Ein Objekt, das Ihr Unternehmen im BizTalk-Messaging-Manager darstellt. Die eigene Organisation wird bei der Installation von BizTalk Server 2000 erstellt. Nur die eigene Organisation kann über Anwendungen verfügen.

Siehe auch: Zielanwendung (destination application), Verteilerliste (distribution list), Organisation (organization), Quellanwendung (source application), Handelspartner (trading partner)

Empfangsfunktionen (receive functions)

Funktionen, mit denen jeder BizTalk-Server Verzeichnisse überwachen und zu verarbeitende Dokumente an BizTalk Server versenden kann. BizTalk Server 2000 unterstützt Datei und Message Queuing-Empfangsfunktionen.

Empfangskanal (receipt channel)

Ein Kanal, der Informationen enthält, die zur Verarbeitung einer Empfangsbestätigung erforderlich sind, welche an den Absender eines Dokuments zurückgegeben wird.

Siehe auch: Kanal (channel)

Entscheidung (decision)

Ein Prozess, bei dem eine oder mehrere Regeln nacheinander ausgewertet werden. Im BizTalk-Orchestrierungs-Designer wird eine Entscheidung durch die Entscheidung-Form dargestellt. Regeln sind VBScript-Ausdrücke (Microsoft Visual Basic Scripting Edition), die von Entscheidung- und While-Formen verwendet werden.

Erneutes Senden (resubmit)

Ein Verfahren, bei dem Austauschvorgänge oder Dokumente aus der Angehalten-Warteschlange an BizTalk Server gesendet werden. Das Dokument wird ab dem Einzelpunkt-Versagen verarbeitet.

F

Flatfile mit Feldern fester Breite (positional flat file)

Eine Datei, die Felder derselben Länge und Datensätze mit einem gemeinsamen Datensatz-Abschlusszeichen enthält.

Flatfile mit Trennzeichen (delimited flat file)

Eine Datei, die einen oder mehrere Datensätze enthält, welche als eine Gruppe von Feldern mit Trennzeichen dazwischen dargestellt werden. Die Datensätze selbst werden ebenfalls durch Trennzeichen voneinander abgegrenzt.

Flussdiagrammformen (Flowchart shapes)

Formen, die die Verteilungslogik in einer XLANG-Ablaufplanzeichnung darstellen. Diese Kategorie von Formen enthält die folgenden Formen: Abbruch, Aktion, Beginn, Entscheidung, Ende, Verzweigung, Verknüpfung, Transaktion und While.

Siehe auch: Kommunikationsformen (Communication shapes), Implementierungsformen (Implementation shapes), Flussdiagrammschablone (Flowchart stencil), XLANG-Ablaufplanzeichnung (XLANG schedule drawing)

Flussdiagrammschablone (Flowchart stencil)

Eine Zeichnungsschablone, die vom BizTalk-Orchestrierungs-Designer bereitgestellt wird. Die Flussdiagrammschablone enthält alle Formen, die für den Entwurf des Prozessflusses eines Geschäftsprozesses, der unter Verwendung eines XLANG-Ablaufplans durchgeführt werden kann, zur Verfügung stehen.

Siehe auch: Flussdiagrammformen (Flowchart shapes), Implementierungsschablone (Implementation stencil)

Funktoid (functoid)

Integrierte, wiederverwendbare Funktion, die komplexe Strukturbearbeitungsoperationen zwischen Quellspezifikationselementen, Zielspezifikationselementen und anderen Funktoiden ermöglicht.

Siehe auch: Verknüpfung (link)

Funktoidpalette (Functoid Palette)

Eine Toolbox, die sämtliche Funktoide enthält, die zur Herstellung von Beziehungen zwischen Quellspezifikationselementen und Zielspezifikationselementen verwendet werden können.

G

Geplant-Warteschlange (Scheduled queue)

Eine Tabelle innerhalb der Datenbank für gemeinsam genutzte Warteschlangen in Microsoft SQL Server. Die Geplant-Warteschlange ist einer Servergruppe mit Austauschvorgängen zugeordnet, die von BizTalk Server zwar empfangen, aber noch nicht verarbeitet wurden.

Siehe auch: Wiederholungswarteschlange (Retry queue), Datenbank für gemeinsam genutzte Warteschlangen (Shared Queue database), Angehalten-Warteschlange (Suspended queue), Verarbeitungswarteschlange (Work queue)

Geschachtelte Transaktion (nested transaction)

Eine oder mehrere Transaktionen, die im Prozessfluss einer umfangreicheren Transaktion enthalten sind.

Siehe auch: Innere Transaktion (inner transaction), Langlebige Transaktion (long-running transaction), Transaktion (transaction), Äußere Transaktion (outer transaction)

Globale Überwachungsfelder (global tracking fields)

In einer Dokumentdefinition festgelegte Dokumentspezifikationsfelder, die für jede Instanz eines tatsächlich von den BizTalk-Messagingdiensten verarbeiteten Dokuments in einer Überwachungsdatenbank protokolliert werden.

Siehe auch: Dokumentinstanz (document instance), Dokumentdefinition (document definition)

H

Handelspartner (trading partner)

Eine externe Organisation, mit der die eigene Organisation elektronische Daten austauscht. Der Austausch von Dokumenten unter Handelspartnern wird durch die von Ihnen erstellten Messagingports, Verteilerlisten, Kanäle und XLANG-Ablaufpläne geregelt.

Siehe auch: Kanal (channel), Quellorganisation (source organization), Verteilerliste (distribution list), Eigene Organisation (home organization), Organisation (organization)

I

Implementierungsformen (Implementation shapes)

Diese Formen repräsentieren die Technologien, die vom XLANG-Ablaufplanungsmodul unterstützt werden. Diese Kategorie von Formen enthält BizTalk-Messaging, COM-Komponenten, Message Queuing und Skriptkomponenten.

Siehe auch: Kommunikationsformen (Communication shapes), Flussdiagrammformen (Flowchart shapes), Implementierungsschablone (Implementation stencil)

Implementierungsschablone (Implementation stencil)

Eine Zeichnungsschablone, die vom BizTalk-Orchestrierungs-Designer bereitgestellt wird. Die Implementierungsschablone enthält alle Formen, die zur Bindung eines Ports an eine Implementierungstechnologie verwendet werden können.

Siehe auch: Flussdiagrammschablone (Flowchart stencil), Implementierungsformen (Implementation shapes)

Implementierungstechnologien (implementation technologies)

Technologien, die zur Implementierung eines Ports in einem XLANG-Ablaufplan verwendet werden. Die vom XLANG-Ablaufplanungsmodul unterstützten Technologien sind COM-Komponenten, Windows-Skriptkomponenten, Message Queuing-Dienste und BizTalk-Messagingdienste.

Inaktiver Status (quiescent state)

Dieser Status bezeichnet einen Prozess, der inaktiv oder ruhend ist bzw. sich im Standbymodus befindet.

Industriestandard (industry standard)

Ein definierter Standard, der zum Austausch von Informationen verwendet wird. Standards sind erweiterbar und folgen festgelegten Regeln oder einer bestimmten Syntax.

Innere Transaktion (inner transaction)

Eine Transaktion, die im Prozessfluss einer anderen Transaktion enthalten ist.

Siehe auch: Langlebige Transaktion (long-running transaction), Geschachtelte Transaktion (nested transaction), Transaktion (transaction), Äußere Transaktion (outer transaction)

Instanzbezogene Warteschlange (per-instance queue)

Eine Warteschlange, die zur Verwendung mit jeder neuen Instanz eines XLANG-Ablaufplanes erstellt wird.

Siehe auch: Dynamische Warteschlange (dynamic queue), Statische Warteschlange (static queue)

K

Kanal (channel)

Eigenschaften, die Quellen von Dokumenten bezeichnen und bestimmte Verarbeitungsschritte definieren, welche von den BizTalk-Messagingdiensten durchgeführt werden, bevor ein Dokument an das vom Messagingport bestimmte Ziel oder die mit dem Kanal verbundene Verteilerliste übermittelt wird.

Siehe auch: Offener Kanal (open channel), Offener Messagingport (open messaging port), Empfangskanal (receipt channel), Quellanwendung (source application), Handelspartner (trading partner), Pass-Through-Versendung (pass-through submission), Quellorganisation (source organization)

Kanalfilterung (channel filtering)

Vergleicht den Wert von Feldern in einer Dokumentinstanz mit Feldern in Ausdrücken, die innerhalb eines Kanals festgelegt wurden. Durch diesen Vergleich wird die Auswahl des Kanals bzw. der Kanäle gefiltert, die der Server bei der Verarbeitung eines Dokuments aufruft.

Knotenpfad (node path)

Ein Ausdruck, der verwendet wird, um Informationen zu XML-Elementen und -Attributen abzurufen, Daten auszuwählen, die bestimmten Kriterien entsprechen, und Vergleiche für die abgerufenen Daten durchzuführen. Wird auch als Xpath bezeichnet.

Siehe auch: XPath (XPath)

Kommunikationsformen (Communication shapes)

Formen, die den exakten Inhalt einer Nachricht sowie den Typ des Anwendungsdienstes, der in der XLANG-Ablaufplanzeichnung implementiert wurde, identifizieren. Diese Kategorie von Formen enthält Konstanten, Nachrichten, Ports und Portverweise.

Siehe auch: Flussdiagrammformen (Flowchart shapes), Implementierungsformen (Implementation shapes), XLANG-Ablaufplanzeichnung (XLANG schedule drawing)

Kompensierung (compensation)

Ein Prozess, bei dem eine Entschädigung für eine abgeschlossene Transaktion erfolgt. Kann beispielsweise ein Auftrag, für den die Zahlung bereits eingegangen ist, nicht erfüllt werden, wird dem Käufer der Zahlungsbetrag erstattet.

Kompilieren (compile)

Im BizTalk-Mapper wird eine XSLT-Version (Extensible Stylesheet Language Transformation) einer Zuordnung erstellt, die von BizTalk Server verwendet werden kann. Die Zuordnung wird im WebDAV-Repository gespeichert und von BizTalk Server eingesetzt, um ein Dokumentformat in ein anderes zu konvertieren.

Siehe auch: Datenzuordnung (data mapping), Datenkonvertierung (data translation), XML (Extensible Markup Language) (Extensible Markup Language (XML)), Zuordnung (map)

Kurzlebige Transaktion (short-lived transaction)

Eine Gruppe von Aktionen, die als einzelne logische Arbeitseinheit ausgeführt wird.

Siehe auch: Langlebige Transaktion (long-running transaction), Transaktion (transaction)

L

Langlebige Transaktion (long-running transaction)

Aktionen, die über einen unbegrenzten Zeitraum Nachrichten senden und empfangen. Üblicherweise enthalten langlebige Transaktionen mehrere geschachtelte, kurzlebige Transaktionen.

Siehe auch: Kurzlebige Transaktion (short-lived transaction), Innere Transaktion (inner transaction), Geschachtelte Transaktion (nested transaction), Äußere Transaktion (outer transaction), Transaktion (transaction)

LOB-Anwendung (Line-of-Business) (line-of-business (LOB) application)

Die Hauptgeschäftsanwendung einer Organisation. BizTalk Server 2000 unterstützt zahlreiche Kommunikationsprotokolle, über die LOB-Anwendungen zuverlässig Informationen senden und empfangen können.

Loopback (Loopback)

Ein bestimmter Typ von Transportdienst, mit dem aktuelle Statusdaten an die Anwendung zurückgegeben werden können, von der die Daten ausgegeben wurden. Loopback verwendet den SubmitSync-Methodenaufruf, um die Statusdaten in der ursprünglichen Anwendung wiederherzustellen.

Siehe auch: Transportdienste (transport services)

M

Messagingport (messaging port)

Eine Reihe von Eigenschaften, die bestimmt, wie Dokumente codiert, gesichert und zu einer bestimmten Zielorganisation oder -anwendung transportiert werden.

Siehe auch: Verteilerliste (distribution list)

Moniker (moniker)

Ein Name, der für ein Objekt steht. Dieser kann den vollständigen Pfad oder die Adresse enthalten, die den Standort des Objekts bezeichnet.

Siehe auch: Port (port)

N

Nachricht (message)

1. Ein Datenpaket, das von einem XLANG-Ablaufplan gesendet oder empfangen wird.

2. Im BizTalk-Orchestrierungs-Designer eine Form auf der Datenseite, die den Nachrichten in einem XLANG-Ablaufplan entspricht. Nachrichtenformen bestehen aus Feldern mit eindeutigen Namen, von denen jedes ein einzelnes Datenelement eines bestimmten Datentyps enthält.

O

Offener Kanal (open channel)

Ein Kanal, der für jede beliebige Quellorganisation explizit als offen deklariert wurde. Die Quelldaten für einen offenen Kanal werden entweder in einem Dokument oder in einem mit dem Dokument gesendeten Parameter an die BizTalk-Messagingdienste übergeben.

Siehe auch: Kanal (channel), Offenheitsgrad (openness), Quellorganisation (source organization)

Offener Messagingport (open messaging port)

Ein Messagingport, der für jede beliebige Zielorganisation explizit als offen deklariert wurde. Die Zieldaten für einen offenen Messagingport werden entweder in einem Dokument oder in einem mit dem Dokument gesendeten Parameter an die BizTalk-Messagingdienste übergeben.

Siehe auch: Kanal (channel), Offenheitsgrad (openness), Quellorganisation (source organization)

Offenheitsgrad (openness)

Ein Mangel an expliziten Informationen zu einer Quelle in einem Kanal bzw. einem Ziel in einem Messagingport. Kanäle enthalten Informationen, die die Quelle identifizieren. Messagingports dagegen enthalten Informationen, die das Ziel identifizieren. Handelt es sich bei einem Kanal um eine offene Quelle, werden die Quellinformationen in dem Kanal nicht explizit deklariert, sondern auf andere Weise bereitgestellt. Normalerweise sind diese Informationen in der gesendeten Dokumentinstanz enthalten, oder sie werden in einem Submit-Methodenaufruf als Parameter festgelegt. Ebenso werden die Zielinformationen in einem Messagingport nicht explizit deklariert, wenn es sich bei dem Messagingport um ein offenes Ziel handelt. Stattdessen werden sie über die Dokumentinstanz oder die Parameter in einem Submit-Methodenaufruf bereitgestellt.

Siehe auch: Zielorganisation (destination organization), Offener Kanal (open channel), Offener Messagingport (open messaging port), Quellorganisation (source organization)

Organisation (organization)

Ein Handelspartner oder ein Geschäftszweig innerhalb eines Handelspartners bzw. Ihr Unternehmen, wenn es sich um die eigene Organisation handelt.

Siehe auch: Quellorganisation (source organization), Zielorganisation (destination organization), Eigene Organisation (home organization), Organisationskennzeichen (organization identifier), Handelspartner (trading partner)

Organisationskennzeichen (organization identifier)

Eine Reihe von Eigenschaften, die eine Organisation eindeutig definiert. Eine Organisation kann über mehrere Organisationskennzeichen verfügen. Organisationskennzeichen bestehen aus folgenden Eigenschaften: einem Namen, einem Qualifizierer und einem Wert.

Siehe auch: Organisation (organization)

P

Parallelität (concurrency)

Zwei oder mehr Aktionen, die parallel ausgeführt werden.

Parser (parser)

Eine Komponente von BizTalk Server, die nicht auf XML basierende Dateien (beispielsweise X12-, EDIFACT- und Flatfiledateien) in XML-Dateien konvertiert.

Pass-Through-Versendung (pass-through submission)

Eine Versendung, bei der die Verarbeitungsstufen Analyse, Decodierung, Entschlüsselung, Transformation und Signaturüberprüfung umgangen werden. Die Dokumentinstanz wird direkt an den Kanal weitergeleitet, der in den Versendeparametern angegeben ist. Dieser Versendungstyp kann bei der Übertragung binärer Dateien ohne Datenbeschädigung oder für den Servertransport sowie globale Überwachungsfunktionen verwendet werden.

Siehe auch: Kanal (channel), Dokumentinstanz (document instance)

Pausieren (dehydrate)

Speichert alle Statusinformationen für eine XLANG-Ablaufplaninstanz in einer SQL Server-Datenbank, während das XLANG-Ablaufplanungsmodul auf eine Nachricht wartet, bevor die nächste Aktion im Geschäftsprozess ausgeführt wird.

Siehe auch: XLANG-Ablaufplanungsmodul (XLANG Scheduler Engine)

Pausierter Ablaufplan (dehydrated schedule)

Ein Ablaufplan, der auf eine Nachricht wartet, bevor er die nächste Aktion in der Sequenz ausführt, und der zwischenzeitlich in einer Datenbank gespeichert wird. Sämtliche Statusinformationen zu dem Ablaufplan werden in der Datenbank gespeichert, bis dieser die Nachricht erhält. Pausierte Ablaufpläne reduzieren die Belastung für den Host des Ablaufplanes.

Persistenzdatenbank (persistence database)

Eine Datenbank, in der der XLANG-Ablaufplanzustand gespeichert wird, wenn der XLANG-Ablaufplan pausiert. Eine Standard-Persistenzdatenbank für die Orchestrierung wird während der Installation von BizTalk Server 2000 erstellt.

Pipelinekomponente (pipeline component)

Eine Komponente, die die Integration von Anwendungen mit BizTalk Server 2000 ermöglicht. Entwickler können die IPipelineComponent-Schnittstelle, die IPipelineComponentAdmin-Schnittstelle oder die IBTSAppIntegration-Schnittstelle verwenden, um diese Komponenten zu entwickeln.

Port (port)

Ein benannter Standort, der eine bestimmte Implementierung verwendet. Im BizTalk-Orchestrierungs-Designer ist ein Port durch den Standort, an den Nachrichten gesendet bzw. von dem Nachrichten empfangen werden, sowie die Technologie, die zur Implementierung der Kommunikationsaktion verwendet wird, definiert. Der Standort ist durch den Namen des Ports eindeutig identifiziert.

Siehe auch: Dynamischer Port (dynamic port), Moniker (moniker), Portstandort (port location), Portverweis (port reference), Portimplementierung (port implementation), Portname (port name), Bindung (binding), Statischer Port (static port)

Portgruppe (port group)

Eine Gruppe von Messagingports, über die dasselbe Dokument an verschiedene Organisationen oder Anwendungen von Handelspartnern gesendet werden kann. Im BizTalk-Messaging-Manager wird diese als Verteilerliste bezeichnet.

Portimplementierung (port implementation)

Eine bestimmte Technologie, die ein Port verwendet, um eine Kommunikationsaktion zu implementieren.

Siehe auch: Port (port), Portstandort (port location), Portverweis (port reference), Portname (port name)

Portname (port name)

Eine eindeutige Identifikation für einen Port. Diese Identifikation wird zum Korrelieren des Portstandorts mit einem bestimmten Port verwendet.

Siehe auch: Port (port), Portimplementierung (port implementation), Portstandort (port location), Portverweis (port reference)

Portstandort (port location)

Der mit einem bestimmten Port verbundene Standort. Der Standort hängt u. a. von der verwendeten Portimplementierung ab. Jede Implementierung bietet einen anderen Standorttyp für den Port.

Siehe auch: Port (port), Portimplementierung (port implementation), Portname (port name), Portverweis (port reference)

Portverweis (port reference)

Eine eindeutige Nachricht, die den Portstandort für jeden Port in einem XLANG-Ablaufplan enthält. Die Portverweisform befindet sich auf der Datenseite. Der Datenfluss in oder aus dieser Nachricht enthält den Portstandort für einen Port.

Siehe auch: Portstandort (port location), Port (port), Portimplementierung (port implementation), Portname (port name)

Prüfpunkt (checkpoint)

Ein Speicherort in der Datenbank für gemeinsam genutzte Warteschlangen, an dem der aktuelle Status eines Arbeitselements gespeichert ist. Im Fall eines Serverfehlers können Dokumente, die sich in der Warteschlange des betreffenden Servers befinden, basierend auf den vom Prüfpunkt bereitgestellten Informationen aus der Datenbank für gemeinsam genutzte Warteschlangen abgerufen und an andere Server innerhalb der Servergruppe verteilt werden.

Q

Quellanwendung (source application)

Eine Anwendung der eigenen Organisation, die in einem Kanal als Quelle der Dokumente festgelegt wurde.

Siehe auch: Kanal (channel), Eigene Organisation (home organization)

Quellorganisation (source organization)

Die Organisation eines Handelspartners, die in einem Kanal als Quelle der Dokumente festgelegt wurde.

Siehe auch: Kanal (channel), Zielorganisation (destination organization), Offener Kanal (open channel), Offener Messagingport (open messaging port), Organisation (organization), Handelspartner (trading partner), Offenheitsgrad (openness)

Quellspezifikation (source specification)

Die Spezifikation in einer Zuordnung, die das eingehende Dokument repräsentiert. Der BizTalk-Mapper ordnet eine Quellspezifikation einer Zielspezifikation zu.

R

Reliable Messaging (reliable messaging)

Eine Funktion des BizTalk Framework 2.0-Protokolls, die die garantierte, einmalige Zustellung von Dokumenten in heterogenen Umgebungen über das Internet unterstützt.

S

Schema (schema)

Die Definition der Struktur einer XML-Datei. Ein Schema enthält Eigenschaftsinformationen, die sich auf die Datensätze und Felder innerhalb der Struktur beziehen.

Serialisierungskomponente (serializer)

Eine Komponente von BizTalk Server, die XML-Dateien in nicht auf XML basierende Dateien (beispielsweise X12, EDIFACT und Flatfiles) konvertiert.

Servergruppe (server group)

Eine Gruppe individueller Server, die zentral verwaltet, konfiguriert und überwacht wird.

Siehe auch: Zielspezifikation (destination specification)

Spezifikation (specification)

Ein BizTalk Server-spezifisches XML-Schema. Spezifikationen werden im BizTalk-Editor erstellt und können auf Industriestandards (z. B. EDIFACT, X12 und XML) oder Flatfiles (mit Trennzeichen, mit Feldern fester Breite oder sowohl mit Trennzeichen als auch mit Feldern fester Breite) basieren. Der BizTalk-Mapper verwendet Spezifikationen, die als Quellspezifikationen und Zielspezifikationen geöffnet werden, um Zuordnungen zu erstellen.

Statische Warteschlange (static queue)

Eine Warteschlange mit einer bekannten Adresse. Ports, für die Message Queuing implementiert wurde, können eine statische Warteschlange verwenden, wenn der Standort der Warteschlange bekannt und unveränderlich ist.

Siehe auch: Dynamische Warteschlange (dynamic queue), Instanzbezogene Warteschlange (per-instance queue)

Statischer Port (static port)

Ein Port, der alle notwendigen Informationen für einen XLANG-Ablaufplan zur Entwurfszeit anfordert. Der Designer, der den XLANG-Ablaufplan erstellt, muss den Standort, an den Nachrichten gesendet und von dem Nachrichten empfangen werden, sowie die zur Implementierung der Kommunikationsaktion verwendete Technologie angeben.

Siehe auch: Dynamischer Port (dynamic port), Port (port)

Status (state)

Der Zustand verschiedener Computerelemente zu einem bestimmten Zeitpunkt.

Siehe auch: XLANG-Ablaufplanzustand (XLANG schedule state)

Synchrone Kommunikation (synchronous communication)

Nachrichten, die in Paaren gesendet oder empfangen werden und die im Kontext einer einzelnen Kommunikationsaktion auftreten.

Siehe auch: Asynchrone Kommunikation (asynchronous communication)

T

Transaktion (transaction)

Eine diskrete Aktivität innerhalb eines Computersystems, z. B. die Eingabe eines Kundenauftrags oder die Aktualisierung eines Lagerteils. Transaktionen sind im Allgemeinen mit der Datenbankverwaltung, der Auftragserfassung und anderen Onlinesystemen verbunden. Im BizTalk-Orchestrierungs-Designer werden Transaktionen als Aktionen dargestellt, die innerhalb einer Transaktion-Form gruppiert sind.

Siehe auch: Innere Transaktion (inner transaction), Langlebige Transaktion (long-running transaction), Geschachtelte Transaktion (nested transaction), Äußere Transaktion (outer transaction), Kurzlebige Transaktion (short-lived transaction)

Transaktionsmenge (transaction set)

Segmente in einem EDI-Schema, die eine bestimmte Reihenfolge aufweisen und eine spezielle Bedeutung für eine bestimmte Geschäftstransaktion haben.

Transportdienste (transport services)

Eine Reihe von Diensten, z. B. Netzwerkprotokolle und Anwendungsintegrationskomponenten. BizTalk Server 2000 unterstützt eine Basismenge von Transportdiensten. Auf diese Weise ist der Server in der Lage, Dokumente an Organisationen oder Anwendungen zu senden, unabhängig davon, ob die Anwendungen mithilfe einer COM-Schnittstelle direkt mit dem Server kommunizieren können. BizTalk Server 2000 unterstützt Datei-, HTTP-, HTTPS- und SMTP-Netzwerkprotokolle sowie Message Queuing. Transportdienste werden auch als Transportkomponenten bezeichnet.

Siehe auch: Wiederholungswarteschlange (Retry queue), Loopback (Loopback)

U

Überwachungsdatenbank (Tracking database)

Eine Microsoft SQL Server-Datenbank, die mit einer Servergruppe verbunden ist, welche die Überwachung der vom Server verarbeiteten Dokumente entweder einzeln oder in Batches ermöglicht. Außerdem kann der XLANG-Ablaufplanzustand überwacht werden.

Umschlag (envelope)

1. Eine Reihe von Eigenschaften, die einen Umschlag definiert. Umschlageigenschaften enthalten ein Umschlagsformat und können außerdem einen Verweis auf eine Umschlagspezifikation umfassen.

2. Kopf- und Fußzeileninformationen, oder nur Kopfzeileninformationen, die zu transportierende Dokumentdaten enthalten oder ihnen vorangestellt sind.

Umschlagsformat (envelope format)

Dokumentformate, die ein Umschlag enthalten kann, beispielsweise XML oder X12.

UN/EDIFACT (UN/EDIFACT)

Der internationale EDI-Standard, der von den Vereinten Nationen entwickelt wurde. Dieser Standard ist in Europa sowie in Japan und anderen asiatischen Ländern und Regionen verbreitet. Das Akronym steht für United Nations/Electronic Data Interchange For Administration, Commerce, and Transport.

V

Verarbeitungswarteschlange (Work queue)

Eine Tabelle innerhalb der Datenbank für gemeinsam genutzte Warteschlangen in Microsoft SQL Server. Die Verarbeitungswarteschlange ist mit einer Servergruppe verbunden. Sie enthält Austauschvorgänge, die derzeit von BizTalk Server 2000 verarbeitet werden.

Siehe auch: Wiederholungswarteschlange (Retry queue), Geplant-Warteschlange (Scheduled queue), Datenbank für gemeinsam genutzte Warteschlangen (Shared Queue database), Angehalten-Warteschlange (Suspended queue)

Verknüpfung (link)

Eine einfache BizTalk-Mapper-Operation zum Kopieren eines Wertes (oder eines Namens) von einem Feld in der Quellspezifikation in ein Feld in der Zielspezifikation oder in ein Funktoid.

Siehe auch: Funktoid (functoid)

Version (version)

In BizTalk Server 2000 handelt es sich dabei entweder um eine bestimmte Versionsnummer für eine Spezifikation oder die Versionsnummer des Industriestandards, anhand dessen die Spezifikation erstellt wurde.

Verteilerliste (distribution list)

Eine Gruppe von Messagingports, über die dasselbe Dokument an verschiedene Organisationen von Handelspartnern oder Anwendungen der eigenen Organisation gesendet werden kann. Im BizTalk-Messaging-Konfigurationsobjektmodell wird diese als Portgruppe bezeichnet.

Siehe auch: Eigene Organisation (home organization), Messagingport (messaging port), Handelspartner (trading partner)

Verteilungslogik (routing logic)

Eine Reihe von Regeln, die die Reihenfolge der Ausführung in einem XLANG-Ablaufplan ermittelt. Die Verteilungslogik wird von der Entscheidung-Form im BizTalk-Anwendungsdesigner implementiert.

W

WebDAV (Web Distributed Authoring and Versioning) (Web Distributed Authoring and Versioning (WebDAV))

Eine Erweiterung des Standards HTTP 1.1, die ein hierarchisches Dateispeichermedium, z. B. ein Dateisystem, über eine HTTP-Verbindung offen legt. WebDAV sperrt Dokumente, damit Benutzer nicht aus Versehen die Änderungen anderer Benutzer überschreiben. Es ermöglicht Benutzern die gemeinsame Bearbeitung serverbasierter Dokumente, unabhängig vom Dokumenterstellungstool, der Plattform oder des Webservertyps, auf dem die Dateien gespeichert sind.

Wiederholungswarteschlange (Retry queue)

Eine Tabelle innerhalb der Datenbank für gemeinsam genutzte Warteschlangen in Microsoft SQL Server. Die Wiederholungswarteschlange ist einer Servergruppe mit Arbeitsobjekten zugeordnet, die im Anschluss an den ersten Übertragungsversuch übertragen werden sollen.

Siehe auch: Datenbank für gemeinsam genutzte Warteschlangen (Shared Queue database), Transportdienste (transport services), Geplant-Warteschlange (Scheduled queue), Angehalten-Warteschlange (Suspended queue), Verarbeitungswarteschlange (Work queue)

Wohlgeformtes XML (well-formed XML)

Dieser Standard besagt, dass ein XML-Dokument, welches über einen einzelnen Stamm sowie über Elemente verfügt, entweder vollständig verschachtelt werden muss oder gar nicht verschachtelt werden kann.

Wörterbuch (dictionary)

Eigenschaften, die jedem von BizTalk Server verarbeiteten Arbeitsobjekt zugewiesen sind. Diese Eigenschaften sind im BizTalk-Editor offen gelegt, damit Benutzer BizTalk Server anweisen können, in Dokumentinstanzen Werte für Eigenschaften zu finden, die zur Suche nach einem Messagingport verwendet werden können.

X

XDR (XML-Data Reduced) (XML-Data Reduced (XDR))

Ein XML-Schema, das von Microsoft vorgeschlagen und 1998 dem World Wide Web Consortium (W3C) vorgelegt wurde. Wie XML-Data ist XDR eine Syntax für XML-Schemas (Extensible Markup Language), die die Eigenschaften eines XML-Dokuments festlegt. XDR ist eine Teilmenge von XML-Data.

Siehe auch: XML (Extensible Markup Language) (Extensible Markup Language (XML))

XLANG-Ablaufplan (XLANG schedule)

Bestimmte Geschäftsprozesse, die in der XLANG-Sprache dargestellt werden. Ein XLANG-Ablaufplan wird mit der Dateierweiterung SKX gespeichert.

Siehe auch: XLANG-Ablaufplanzeichnung (XLANG schedule drawing), XLANG-Ablaufplaninstanz (XLANG schedule instance), XLANG-Ablaufplanungsmodul (XLANG Scheduler Engine)

XLANG-Ablaufplaninstanz (XLANG schedule instance)

Eine Abbildung eines Ablaufplanes. Ein XLANG-Ablaufplan stellt nur den Geschäftsprozess und die Implementierungsdienste dar. Das XLANG-Ablaufplanungsmodul kann eine einzige oder mehrere Instanzen eines XLANG-Ablaufplanes ausführen. Verschiedene Instanzen eines XLANG-Ablaufplanes enthalten unterschiedliche Nachrichten, aber alle Instanzen folgen denselben Geschäftsprozessregeln.

Siehe auch: XLANG-Ablaufplan (XLANG schedule), XLANG-Ablaufplanungsmodul (XLANG Scheduler Engine)

XLANG-Ablaufplanung (XLANG Scheduler)

Die Standard-COM+-Anwendung, die bei der Installation von BizTalk Server 2000 installiert wird. Diese Anwendung dient als Host für ausgeführte Instanzen von XLANG-Ablaufplänen.

XLANG-Ablaufplanungsmodul (XLANG Scheduler Engine)

Ein Dienst, der XLANG-Ablaufplaninstanzen ausführt und die Ausführung, Pausierung und Aktivierung eines XLANG-Ablaufplanes steuert.

Siehe auch: Pausieren (dehydrate), Aktivieren (rehydrate), XLANG-Ablaufplanzeichnung (XLANG schedule drawing), XLANG-Ablaufplaninstanz (XLANG schedule instance), XLANG-Ablaufplan (XLANG schedule)

XLANG-Ablaufplanzeichnung (XLANG schedule drawing)

Eine Zeichnung, die einen Geschäftsprozess darstellt. Ist eine Zeichnung abgeschlossen, kann diese im BizTalk-Orchestrierungs-Designer kompiliert und als ein XLANG-Ablaufplan ausgeführt werden. Eine XLANG-Ablaufplanzeichnung wird mit der Dateierweiterung SKV gespeichert.

Siehe auch: Kommunikationsformen (Communication shapes), Flussdiagrammformen (Flowchart shapes), XLANG-Ablaufplan (XLANG schedule), XLANG-Ablaufplanungsmodul (XLANG Scheduler Engine)

XLANG-Ablaufplanzustand (XLANG schedule state)

Die in einer XLANG-Ablaufplaninstanz enthaltenen Informationen. Zu diesen Informationen gehören Nachrichten, die von dieser Instanz gesendet oder empfangen wurden, von dieser Instanz verwendete COM-Objekte sowie der Fortschritt dieser Instanz im Hinblick auf den Abschluss des Geschäftsprozesses.

Siehe auch: Status (state)

XLANG-Identität (XLANG identity)

Ein global eindeutiger Bezeichner, der zur Unterscheidung von Versionsinstanzen einer XLANG-Ablaufplanzeichnung verwendet wird. Diese Eigenschaft ist schreibgeschützt und kann nicht geändert werden. Bei Aktualisierung der XLANG-Ablaufplanzeichnung wird diese Identität ebenfalls aktualisiert. Die XLANG-Identität kann verwendet werden, um einen XLANG-Ablaufplan mit der Version einer XLANG-Ablaufplanzeichnung zu korrelieren, anhand derer der Ablaufplan kompiliert wurde.

XLANG-Sprache (XLANG language)

Eine Sprache, die die logische Sequenzierung von Geschäftsprozessen sowie die Implementierung dieser Geschäftsprozesse mithilfe verschiedener Anwendungsdienste beschreibt. Die XLANG-Sprache wird in XML dargestellt.

XML (Extensible Markup Language) (Extensible Markup Language (XML))

Eine vom World Wide Web Consortium (W3C) entwickelte Spezifikation, die Designern die Erstellung von benutzerdefinierten Tags ermöglicht, die über die Fähigkeiten von Standard-HTML hinausgehen. Während HTML ausschließlich vordefinierte Tags verwendet, um Elemente einer Seite zu beschreiben, kann der Entwickler einer Seite in XML Tags definieren. Tags für jedes beliebige Datenelement, z. B. ein Produkt oder ein Fälligkeitsdatum, können für spezielle Anwendungen verwendet werden. Auf diese Weise können Webseiten als Datenbankeinträge fungieren.

Siehe auch: Kompilieren (compile), Zuordnung (map), Datenkonvertierung (data translation), XDR (XML-Data Reduced) (XML-Data Reduced (XDR)), XPath (XPath)

XSL (Extensible Stylesheet Language) (Extensible Stylesheet Language (XSL))

Ein Stylesheetformat für XML-Dokumente (Extensible Markup Language). XSL wird verwendet, um die Anzeige von XML zu definieren, ebenso wie CSS (Cascading Style Sheets) verwendet wird, um die Anzeige von HTML (Hypertext Markup Language) zu definieren. BizTalk Server verwendet XSL als Konvertierungssprache zwischen zwei Spezifikationen.

XPath (XPath)

Eine umfassende Sprache, die die Navigation durch die Hierarchie eines XML-Dokuments ermöglicht. Mit XPath-Ausdrücken können Sie Informationen zu XML-Elementen und -Attributen abrufen, Daten auswählen, die bestimmten Kriterien entsprechen, und Vergleiche für die abgerufenen Daten durchführen. Wird auch als Knotenpfad bezeichnet.

Siehe auch: XML (Extensible Markup Language) (Extensible Markup Language (XML)), Knotenpfad (node path)

Z

Zielanwendung (destination application)

Ein Anwendung der eigenen Organisation, die in einem Messagingport als Ziel für Dokumente festgelegt wurde.

Siehe auch: Eigene Organisation (home organization)

Zielorganisation (destination organization)

Die Organisation eines Handelspartners, die in einem Messagingport als Ziel für Dokumente festgelegt wurde.

Siehe auch: Offenheitsgrad (openness), Quellorganisation (source organization), Organisation (organization)

Zielspezifikation (destination specification)

Die Spezifikation in einer Zuordnung, die das ausgehende Dokument repräsentiert. Der BizTalk-Mapper ordnet eine Quellspezifikation einer Zielspezifikation zu.

Siehe auch: Quellspezifikation (source specification)

Zuordnen (mapping)

Der Prozess, der die Transformation der Daten einer Struktur in eine andere Struktur beschreibt.

Zuordnung (map)

Eine XML-Datei, die die Entsprechungen zwischen den Datensätzen und Feldern in einer Spezifikation und den Datensätzen und Feldern in einer anderen Spezifikation definiert. Eine Zuordnung enthält ein XSL-Stylesheet (Extensible Stylesheet Language), mit dem BizTalk Server die in der Zuordnung beschriebene Transformation durchführt. Zuordnungen werden im BizTalk-Mapper erstellt.

Siehe auch: Kompilieren (compile), XML (Extensible Markup Language) (Extensible Markup Language (XML)), Datenkonvertierung (data translation)


Verwenden der Hilfe

Dieser Abschnitt enthält Informationen zum Microsoft BizTalk Server 2000-Hilfesystem. Die folgenden Themen werden behandelt:

  • Hilfe - Übersicht

  • Suchen eines Hilfethemas

  • Kennzeichnen eines Hilfethemas mit einem Lesezeichen

  • Kopieren eines Hilfethemas

  • Drucken eines Hilfethemas

  • Ändern der Schriftgröße

  • Verwenden von Sprachfiltern

  • Hilfeanzeige - Tastenkombinationen


Hilfe - Übersicht

Die Informationen im Microsoft BizTalk Server 2000-Hilfesystem werden unter Verwendung von HTML formatiert und angezeigt. Die Hilfeanzeige bietet ein integriertes Inhaltsverzeichnis, einen Index und eine Funktion zur Volltextsuche, die Ihnen das leichte Auffinden von Informationen ermöglichen. Über die Buchsymbole können Sie untergeordnete Bücher und Hilfethemen anzeigen. Klicken Sie auf das Erweiterungssymbol (+) neben einem Buchtitel, um das Inhaltsverzeichnis zu erweitern und die Themen in einem Buch anzuzeigen. Wenn Sie auf das Reduktionssymbol klicken (-), werden die Themen ausgeblendet. Die Hilfeanzeige bietet außerdem die Möglichkeit, neben dem eigentlichen Hilfethema gleichzeitig auch das Inhaltsverzeichnis, den Index oder Suchergebnisse anzuzeigen.

Zusätzlich finden Sie in der Hilfeanzeige die Registerkarte Favoriten, auf der Sie Hilfethemen mit einem Lesezeichen versehen können. So können Sie häufig verwendete Themen schnell und einfach anzeigen.

Sie können das Inhaltsverzeichnis verwenden, um in der Dokumentation zu suchen und weitere Informationen zu BizTalk Server 2000 zu erhalten. Wenn Sie im Inhaltsverzeichnis auf ein Thema klicken, werden die Informationen im Inhaltsbereich im Hilfefenster angezeigt

Das Inhaltsverzeichnis ist nach Büchern entsprechend den Hauptfeatures und –funktionen von BizTalk Server 2000 geordnet. In jedem Buch finden Sie Kapitel mit den folgenden Informationen:

  • Verfahrensweise

  • Grundbegriffe

  • Problembehandlung

  • Ressourcen

Beginnen Sie mit den Kapiteln zu Verfahrensweisen, um Informationen zu Verfahrensweisen und aufgabenbasierten Informationen zu erhalten. Beginnen Sie mit den Kapiteln "Grundbegriffe" und "Ressourcen", um weitere allgemeine Informationen zu BizTalk Server 2000, den Features und anderen Informationen zu erhalten.

Sie können ein Sprachenfilterungstool zum Anzeigen von Informationen zu Microsoft Visual Basic, Visual C++ oder beidem verwenden, um Programmierungsinformationen in der "BizTalk Server 2000 Interface Reference" zu erhalten.

Verwandte Themen

Kennzeichnen eines Hilfethemas mit einem Lesezeichen

Kopieren eines Hilfethemas

Ändern der Schriftgröße

Suchen eines Hilfethemas

Hilfeanzeige - Tastenkombinationen

Drucken eines Hilfethemas

Verwenden von Sprachfiltern


Suchen eines Hilfethemas

In der Hilfeanzeige sind die folgenden Optionen zum Suchen und Durchsuchen verfügbar:

  • Registerkarte "Inhalt"
    1. Klicken Sie auf die Registerkarte Inhalt, um das Inhaltsverzeichnis zu durchsuchen. Doppelklicken Sie auf die Buchsymbole, um ein Thema oder weitere Bücher einzublenden.

    2. Klicken Sie auf einen Eintrag im Inhaltsverzeichnis, um das entsprechende Thema anzuzeigen.
  • Registerkarte "Index"
    1. Klicken Sie auf die Registerkarte Index, um eine Liste der Indexeinträge anzuzeigen. Geben Sie dort ein Wort ein, oder führen Sie einen Bildlauf in der Liste durch. Themen werden oftmals unter mehreren Einträgen indiziert.

    2. Doppelklicken Sie auf einen Indexeintrag, um das entsprechende Thema anzuzeigen.
  • Registerkarte "Suchen"
    1. Klicken Sie auf die Registerkarte Suchen, geben Sie das gesuchte Wort oder den Ausdruck ein, und klicken Sie dann auf Themen auflisten, um jedes Vorkommen eines Wortes oder Ausdrucks zu suchen.

      Verbinden Sie mehrere Wörter oder Ausdrücke durch AND, OR, NEAR oder NOT, um die Suche zu optimieren.

    2. Doppelklicken Sie auf einen Suchergebniseintrag, um das entsprechende Thema anzuzeigen.
  • Registerkarte "Favoriten"
    1. Verwenden Sie die Registerkarten Inhalt, Index oder Suchen zum Suchen und Anzeigen eines Hilfethemas, und versehen Sie das Thema dann mit einem Lesezeichen.

    2. Klicken Sie auf die Registerkarte Favoriten und dann auf Hinzufügen, um das Hilfethema zur Liste Themen hinzuzufügen.

    3. Doppelklicken Sie auf ein Lesezeichen in der Liste Themen, um das Thema direkt anzuzeigen.

Verwandtes Thema

Hilfeanzeige - Tastenkombinationen


Kennzeichnen eines Hilfethemas mit einem Lesezeichen

  1. Suchen Sie mithilfe der Registerkarten Inhalt, Index oder Suchen das Thema, das Sie mit einem Lesezeichen kennzeichnen möchten, und zeigen Sie es an.

  2. Klicken Sie auf die Registerkarte Favoriten und dann auf Hinzufügen.

Das Thema wird zur Liste Themen der Hilfeanzeige hinzugefügt. Später können Sie zu dieser Liste wieder zurückkehren und auf das Lesezeichen doppelklicken, um das Thema direkt anzuzeigen.

Anmerkungen

  • Sie können eine Liste bevorzugter oder häufig verwendeter Hilfethemen erstellen.

  • Klicken Sie auf das Lesezeichen und dann auf Entfernen, um ein Lesezeichen aus der Liste Themen zu entfernen.

Verwandte Themen

Suchen eines Hilfethemas

Hilfeanzeige - Tastenkombinationen


Kopieren eines Hilfethemas

  1. Klicken Sie im Themenfenster in der Hilfeanzeige mit der rechten Maustaste in das Thema, das Sie kopieren möchten, und klicken Sie dann auf Alles auswählen.

  2. Klicken Sie erneut mit der rechten Maustaste in das Thema, und klicken Sie dann auf Kopieren.

    Dadurch wird das Thema in die Zwischenablage kopiert.

  3. Öffnen Sie das Dokument, in das Sie das Thema kopieren möchten.

  4. Klicken Sie in dem Dokument an die Stelle, an der die Informationen angezeigt werden sollen.

  5. Klicken Sie im Menü Bearbeiten auf Einfügen.

Anmerkungen

  • Wenn Sie nur einen Teil eines Themas kopieren möchten, markieren Sie den zu kopierenden Teil, klicken Sie mit der rechten Maustaste auf den markierten Text und dann auf Kopieren.

  • Die Nummern der Schritte werden nicht in die Zwischenablage kopiert.

Verwandte Themen

Suchen eines Hilfethemas

Drucken eines Hilfethemas


Drucken eines Hilfethemas

  • Klicken Sie mit der rechten Maustaste auf das zu druckende Thema, und klicken Sie dann auf Drucken.

Wichtig

  • Wählen Sie ein Thema auf der Registerkarte Inhalt aus, um ein einzelnes Thema zu drucken. Klicken Sie auf der Hilfesymbolleiste auf Drucken und dann auf Ausgewähltes Thema drucken. Die empfohlene Seitenausrichtung ist Querformat; andernfalls werden Codebeispiele oder große Illustrationen und wichtige Textstellen möglicherweise nicht vollständig gedruckt.

  • Wählen Sie auf der Registerkarte Inhalt ein Buch aus, um alle Themen innerhalb eines Buches zu drucken, . Klicken Sie auf der Hilfesymbolleiste auf Drucken und dann auf Ausgewähltes Thema und alle Unterthemen drucken. Die empfohlene Seitenausrichtung ist Querformat; andernfalls werden Codebeispiele oder große Illustrationen und wichtige Textstellen möglicherweise nicht vollständig gedruckt.

Verwandte Themen

Suchen eines Hilfethemas

Hilfeanzeige - Tastenkombinationen


Ändern der Schriftgröße

Sie können die Schriftgröße des Textes vergrößern, um die Anzeige zu erleichtern. Sie können die Schriftgröße auch verkleinern, um eine Darstellung des Layouts einer Seite anzuzeigen.

  • Klicken Sie auf der Symbolleiste auf die Schaltfläche Schriftart ( Schaltfläche "Schriftart"), um die Schrift zu vergrößern oder zu verkleinern.


Verwenden von Sprachfiltern

Die BizTalk Server 2000-Hilfe implementiert ein Sprachfilterungstool, um nur die für Ihre Programmierumgebung relevanten Informationen bereitzustellen. In der Titelleiste von Themen in der "BizTalk Server 2000 Interface Reference" befindet sich eine Filterschaltfläche ( Sprachfilterungstool) die ein Sprachenmenü bereitstellt. Über dieses Menü können Sie Dokumentation anzeigen, die für Visual C++ oder Visual Basic angepasst ist. Wenn Sie Alle anzeigen wählen, werden Informationen für beide Sprachen angezeigt. Unabhängig von der Sprachauswahl werden immer Informationen angezeigt (beispielsweise allgemeine Konzepte), die für beide Sprachen relevant sind.

  • Klicken Sie in der Titelleiste auf die Filterschaltfläche ( Sprachfilterungstool), um die Optionen zum Filtern nach Sprachen anzuzeigen. Klicken Sie dann auf eine der folgenden Optionen:
    • C++

    • Visual Basic

    • Alle anzeigen

Anmerkung

  • Wenn Sie eine Option zum Filtern nach Sprachen auswählen, bleibt diese Option für alle angezeigten Seiten so lange bestehen, bis sie wieder geändert wird.


Hilfeanzeige - Tastenkombinationen

Mit Tastenkombinationen können Sie Aufgaben in der BizTalk Server 2000-Hilfeanzeige ausführen. Die folgende Tabelle ist eine kurze Referenz zu den in der Hilfeanzeige verfügbaren Tastenkombinationen.

Anmerkung

  • Sie können mithilfe der Zehnertastatur den Mauszeiger mit der Tastaturmaus bewegen, um Funktionen zu verwenden, die in dieser Liste nicht enthalten sind. Weitere Informationen zur Tastaturmaus finden Sie in der Windows 2000 Server-Hilfe unter "Bewegen des Mauszeigers mithilfe der Tastatur". In der Windows 2000 Professional-Hilfe finden Sie diese Informationen unter "Bewegen des Mauszeigers mithilfe der Tastaturmaus".

Tastenkombinationen in der Hilfeanzeige

Tastenkombination | Zweck
ALT+LEER | Systemmenüs anzeigen.
UMSCHALT+F10 Kontextmenü der Hilfeanzeige anzeigen.

Anmerkung

  • Verwenden Sie diese Tastenkombination, wenn sich der Fokus im Themenbereich befindet.
ALT+TAB | Zwischen der Hilfeanzeige und anderen geöffneten Fenstern umschalten.
ALT+O | Menü Optionen anzeigen.
ALT+O und dann T drücken | Ausblenden oder Einblenden des Navigationsfenster.
STRG+TAB | Zur nächsten Registerkarte im Navigationsfenster wechseln.
STRG+UMSCHALT+TAB | Zur vorherigen Registerkarte im Navigationsfenster wechseln.
NACH-OBEN-TASTE | Zu dem Thema wechseln, das oberhalb des aktuellen Themas im Inhaltsverzeichnis, im Index oder in der Liste der Suchergebnisse angezeigt wird.
NACH-UNTEN-TASTE | Zu dem Thema wechseln, das unterhalb des aktuellen Themas im Inhaltsverzeichnis, im Index oder in der Liste der Suchergebnisse angezeigt wird.
BILD-NACH-OBEN | Zur vorherigen Seite im Inhaltsverzeichnis, im Index oder in der Liste der Suchergebnisse wechseln.
BILD-NACH-UNTEN | Zur nächsten Seite im Inhaltsverzeichnis, im Index oder in der Liste der Suchergebnisse wechseln.
F6 | Zwischen dem Navigations- und dem Themenfenster umschalten.
ALT+O und dann K | Anzeige des im Themenfenster angezeigten Themas aktualisieren.
NACH-OBEN- oder NACH-UNTEN-TASTE | Bildlauf in einem Thema.
STRG+POS1 | Zum Anfang eines Themas wechseln.
STRG+ENDE | Zum Ende eines Themas wechseln.
STRG+A | Gesamten Text im Themenbereich markieren.
ALT+O und dann D drücken | Ein Thema drucken.
ALT+O und dann Z | Zum vorher angezeigten Thema zurückgehen.
ALT+O und dann V | Zum nächsten (zuvor angezeigten) Thema gehen.
TAB Zwischen verwandten Themen bewegen.

Anmerkung

  • Verwenden Sie diese Tastenkombination, wenn sich der Fokus im Themenbereich befindet.
ALT+F4 | Hilfeanzeige schließen.

Tastenkombinationen auf der Registerkarte "Inhalt"

Tastenkombination | Zweck
ALT+I | Registerkarte Inhalt anzeigen.
NACH-RECHTS-TASTE | Ein Buch öffnen.
NACH-LINKS-TASTE | Ein Buch schließen.
RÜCKTASTE | Zum zuvor geöffneten Buch zurückkehren.
NACH-OBEN- oder NACH-UNTEN-TASTE | Ein Thema auswählen.
EINGABETASTE | Ausgewähltes Thema anzeigen.

Tastenkombinationen auf der Registerkarte "Index"

Tastenkombination | Zweck
ALT+N | Registerkarte Index anzeigen.
NACH-OBEN- oder NACH-UNTEN-TASTE | Ein Schlüsselwort in der Liste auswählen.
ALT+Z oder EINGABETASTE | Zugeordnetes Thema anzeigen.

Tastenkombinationen auf der Registerkarte "Suchen"

Tastenkombination | Zweck
ALT+S | Registerkarte Suchen anzeigen.
ALT+L | Suche starten.
ALT+Z oder EINGABETASTE | Ausgewähltes Thema anzeigen.

Tastenkombinationen auf der Registerkarte "Favoriten"

Tastenkombination | Zweck
ALT+F | Registerkarte Favoriten anzeigen.
ALT+H | Hilfethema zur Liste Themen hinzufügen.
ALT+T Themas in der Liste Themen auswählen.

Anmerkung

  • Verwenden Sie diese Tastenkombination, wenn sich der Fokus im Themenbereich befindet und Sie zur Liste Themen wechseln möchten.
ALT+E | Thema aus der Liste Themen entfernen.
ALT+Z | Thema in der Liste Themen anzeigen.

Verwandtes Thema

Hilfe - Übersicht


Eingabehilfen für körperlich Behinderte

Microsoft hat es sich zur Aufgabe gemacht, die Verwendung seiner Produkte noch einfacher zu gestalten. Informationen zu Features, durch die Microsoft BizTalk Server 2000 besser zugänglich wird, finden Sie unter den folgenden Themen:

  • Hilfeanzeige - Tastenkombinationen

  • BizTalk Server-Verwaltung - Tastenkombinationen

  • BizTalk-Dokumentüberwachung - Tastenkombinationen

  • BizTalk-Orchestrierungs-Designer - Tastenkombinationen

  • BizTalk-Messaging-Manager - Tastenkombinationen

  • BizTalk-Editor - Tastenkombinationen

  • BizTalk-Mapper - Tastenkombinationen

Anmerkung

  • Weitere Informationen zu den Optionen für Eingabehilfen finden Sie in der Windows 2000 Server-Hilfe, im Buch Erste Schritte für Windows 2000 Server unter "Eingabehilfen für körperlich Behinderte". In der Windows 2000 Professional-Hilfe finden Sie Informationen im Kapitel "Eingabehilfen für besondere Anforderungen".


Microsoft Product Support Services

Wenn Sie eine Frage haben

Wenn Sie Fragen zu Ihrem Microsoft-Produkt haben, empfiehlt es sich, im Handbuch und in der Online-Hilfe nachzusehen. Weitere technische Hilfestellungen sowie Informationen erhalten Sie auch im Internet auf unseren Online Supportseiten. Wenn Sie telefonische Unterstützung benötigen, wenden Sie sich bitte an den Technischen Support von Microsoft (Microsoft Product Support Services).

Wenn Sie anrufen, sollten Sie sich an Ihrem Computer befinden und die Produktdokumentation griffbereit vor sich haben. Bitte geben Sie bei telefonischen Anfragen Folgendes an:

  • Die Produktbezeichnung und die Versionsnummer des von Ihnen verwendeten Microsoft-Produkts.

  • Die von Ihnen benutzte Hardware (ggf. einschließlich der Netzwerkhardware).

  • Das von Ihnen eingesetzte Betriebssystem.

  • Den genauen Wortlaut von eventuell am Bildschirm angezeigten Meldungen.

  • Eine Beschreibung des Problems und der aktuellen Arbeitsschritte, bevor das Problem auftrat.

  • Eine Beschreibung Ihres Vorgehens beim Versuch, das Problem selbst zu lösen.

Microsoft Product Support Services

Microsoft unterstützt Sie mit einer breiten Palette von Dienstleistungen: Im Internet finden Sie nicht nur den kostenfreien Online Support, sondern auch Informationen zu unserem umfangreichen deutschsprachigen Supportangebot:

www.microsoft.com/germany/support

Kostenloser Online Support

Im Zentrum der Microsoft Product Support Services steht der kostenlose Online Support. Hier erhalten alle Anwender schnell und einfach Informationen und Hilfe zur Selbsthilfe für den optimalen Einsatz der Microsoft-Software. Der Online Support ist rund um die Uhr kostenlos im Internet verfügbar und bietet Ihnen folgende Services:

  • Knowledge Base – Kein Problem ist zu schwer, kein Begriff zu schwierig – in der deutschsprachigen Knowledge Base finden Sie Tausende von Artikeln unserer Supportteams. Der schnellste Weg zur Problemlösung rund um die Uhr: Einfach ein Stichwort eingeben und das Produkt auswählen.

  • Frequently Asked Questions – Sie haben Fragen – wir die Antworten. In den "Frequently Asked Questions" (FAQs) finden Sie eine Sammlung der Probleme, die am häufigsten an unser Supportteam herangetragen werden. Gerade, wenn Sie die exakte Ursache Ihres Problems nicht kennen, eignen sich die FAQs als erste Anlaufstelle.

  • Troubleshooter – Der Troubleshooter ist Ihr Supportassistent, der Ihr Problem durch Fragen mit verschiedenen Antwortmöglichkeiten eingrenzt und so die Lösung vereinfacht.

  • Downloads – Damit Sie immer auf dem neuesten Stand der Entwicklung sind, bietet unser Downloadbereich aktuelle Updates, Produktergänzungen und Service Packs. Auch kostenlose Software und Betaversionen halten wir dort für Sie bereit.

  • Newsgroups – Zu vielen Microsoft-Produkten gibt es eigene Newsgroups, in denen sich unsere deutschsprachigen Kundinnen und Kunden gegenseitig helfen. Mit einem speziellen Programm fördern wir ein hohes fachliches Niveau und eine freundliche Atmosphäre in unseren Newsgroups. Probieren Sie es aus: Schildern Sie dort Ihr Problem, wenn Sie einmal nicht weiterkommen.

  • Kostenlose Supportanfragen via Internet - Im Fall der Fälle können Sie den Microsoft Supportspezialisten für die meisten Produkte zwei kostenlose technische Anfragen stellen. Das geht ganz bequem per Mausklick. Sie können Ihre Anfrage im Internet abschicken, dort den Status Ihrer Anfrage verfolgen und Ihre Antwort abrufen. Sie benötigen lediglich Ihre Produkt-Seriennummer (PID) und ein kostenloses Microsoft Passport-Konto.

Sämtliche deutschsprachigen, webbasierten Dienstleistungen sind unter der folgenden Adresse verfügbar:

www.microsoft.com/germany/support

Hier finden Sie auch die professionellen Service-Desks für Entwickler, Microsoft-Handelspartner und IT-Spezialisten.

Kostenfreie technische Anfragen

Kundinnen und Kunden, die die Desktop-Betriebssysteme Windows 98 oder Windows ME, Desktop-Anwendungen wie Office 2000 oder Consumer Produkte wie Encarta, Money oder Spiele im Fachhandel erwerben, haben auch die Möglichkeit, zwei kostenlose Anfragen an unser Supportteam zu stellen – telefonisch oder via Internet. Egal, ob Sie Fragen zur Installation oder zur Bedienung haben – hier wird Ihnen freundlich und schnell geholfen. Sie tragen nur die Telefonkosten (z.B. in Deutschland DM 0,24/EURO 0,12 pro Minute).

Kostenlose technische Anfragen an Microsoft werden nicht für Software angeboten, die Sie als DSP-Lizenz erworben haben oder die bereits auf einem neuen PC vorinstalliert war (sogenannte OEM-Lizenzen), und für Lizenzen, die im Rahmen von Lizenzierungsprogrammen für Unternehmen erworben wurden (z. B. OPEN, SELECT). In diesem Fall wenden Sie sich für kostenlose Unterstützung bitte an Ihren Händler oder den Hersteller des PCs.
Die Adressen finden Sie in der Dokumentation zu Ihrem PC und für die gängigsten Hersteller auch online unter:

www.microsoft.com/germany/support

Sie erreichen uns von Montag bis Freitag zwischen 8:00 Uhr und 18:00 Uhr

und Samstags zwischen 9:00 Uhr und 17:00 Uhr (nur kostenfreie Anfragen) unter folgenden Rufnummern:

Wenn Sie von Deutschland aus anrufen: 01805/67 22 55*

Wenn Sie von Österreich aus anrufen: 01-502-22 22 55

Wenn Sie von der Schweiz aus anrufen: 0848/80-22 55

Zeiten und Verfügbarkeit des Supports unterliegen den aktuellen Bedingungen der Microsoft-Niederlassung in Ihrer Nähe und können – mit einer angemessenen Übergangszeit – von Zeit zu Zeit geändert werden.

Kostenpflichtige technische Anfragen

Unabhängig davon, ob Sie Ihre beiden kostenlosen Anfragen bereits genutzt haben oder Lizenzen ohne Anspruch auf kostenlose Unterstützung (etwa DSP- oder OEM-Lizenzen, OPEN, SELECT) einsetzen – wir lassen Sie nicht allein. Unser Supportteam beantwortet Ihre Fragen in diesen Fällen gerne gegen Gebühr.

Wenden Sie sich für weitere Informationen bitte an die Vertragsberatung:

Wenn Sie von Deutschland aus anrufen: 01805/67 23 30*

Wenn Sie von Österreich aus anrufen: 01-502-22 23 30

Wenn Sie von der Schweiz aus anrufen: 0848/80-23 30

Aktuelle Informationen zu den Microsoft Product Support Services finden Sie auch im Internet:

www.microsoft.com/germany/support

*DM 0,24/Min. EURO 0,12/Min.

Weitere nützliche Microsoft Services

Das Microsoft TechNet -Abonnement: Fachwissen auf Abruf:

Wenn technische Schwierigkeiten auftreten, bleibt oft keine Zeit lange nach Lösungen zu suchen. Hilfe bietet hierbei das Microsoft TechNet-Abonnement: Sie erhalten jeden Monat eine CD-ROM mit dem aktuellen Fachwissen unserer IT-Spezialisten. So bekommen Sie einen Großteil technischer Probleme selbst in den Griff.

www.microsoft.com/germany/technet/cd

Wissen aus erster Hand – Microsoft Press

Der Microsoft Press Verlag bietet umfangreiche Buchreihen zu den wichtigsten Produkten von Microsoft an. Diese helfen Ihnen, Ihr Microsoft-Produkt schnell kennenzulernen und erfolgreich einzusetzen.

www.microsoft.com/germany/mspress

Allgemeine Informationen –Infoservice

Bei Fragen zur allgemeinen Produktverfügbarkeit, zu Preisen, Updatemöglichkeiten und dem Lieferumfang eines Produkts wenden Sie sich bitte an:

Für Deutschland:

Microsoft Direkt
Telefon: 01805/25 11 99
Fax: 01805/25 11 91

Für Österreich:

Microsoft InfoService
Postfach 262
1101 Wien
Telefon: 0 8000 123-345
Fax: (02236) 64595
Email: infoservice@microsoft.at
Montag – Freitag 9:00 – 17:00 Uhr

Für die Schweiz:

Microsoft Info-Service
Postfach
8021 Zürich

Telefon: 0848 – 830835

Fax: 0848 – 830836

Microsoft Niederlassungen

Deutschland:

Konrad-Zuse-Str.1
85713 Unterschleißheim
Telefon: 089 / 3176-0
Fax: 089 / 3176-1000

Österreich:

Microsoft Ges.m.b.H
Ada-Christen-Gasse 4
A-1100 Wien
Telefon: 01 - 610 64 - 0
Fax: 01 - 610 64 - 200

Schweiz:

Microsoft AG
Alte Winterthurerstr. 14a
CH-8304 Wallisellen / Zürich
Telefon: 01 / 839 61 11
Fax: 01 / 831 08 69


BizTalkServer2000-Lernprogramm

BizTalk Server-Kopfzeile

BizTalk Server 2000-Lernprogramm

Automatisierte Beschaffung auf Business-to-Business-Ebene

In diesem Lernprogramm wird erläutert, wie Microsoft BizTalk Server 2000 für die Einrichtung und Ausführung eines automatisierten Beschaffungsprozesses auf Business-to-Business-Ebene konfiguriert wird.

Darüber hinaus erfahren Sie, wie BizTalk Server-Komponenten und -Dienste zusammenarbeiten, um flexibel verbundene zeitintensive Geschäftsprozesse sowohl firmenintern als auch firmenübergreifend zu integrieren.

Anmerkung

Das BizTalk Server 2000-Lernprogramm wird auch im Microsoft Word-Format bereitgestellt. Zum Drucken des Lernprogramms müssen Sie diese Version verwenden. Wenn Sie Word nicht installiert haben, können Sie die Datei mit Microsoft WordPad oder Microsoft Word 97 Viewer und Microsoft Word 2000 Viewer anzeigen. Klicken Sie auf Durchsuchen ([...]), und wechseln Sie in das Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\Components\POtoInvoice\Lab auf dem BizTalk Server-Installationslaufwerk.

Anforderungen

BizTalk Server 2000 und alle seine Abhängigkeiten müssen installiert werden, damit das Lernprogramm erfolgreich durchgeführt werden kann. Eine vollständige Liste der Hardware- und Softwareanforderungen für BizTalk Server 2000 finden Sie unter Installieren von BizTalk Server 2000.

Szenario

Dieses Szenario bietet eine umfassende Übersicht über die wichtigsten Elemente von BizTalk Server 2000. ProElectron, Inc. (die Käuferfirma) verwendet BizTalk Server 2000, um einen automatisierten Beschaffungsprozess auf Business-to-Business-Ebene mit Bits, Bytes, & Chips, Inc. (der Verkäuferfirma) zu implementieren.

ProElectron verwendet einen XLANG-Ablaufplan, um den Nachrichtenfluss durch das System zu steuern. Wenn der Umfang einer Auftragsanfrage nicht größer ist als $1000, wird ein Auftrag generiert und an Bits, Bytes, & Chips gesendet. Anderenfalls wird der Prozess beendet.

Das Käufersystem verwendet die BizTalk-Messagingdienste, die den Auftrag empfangen, weiterleiten, in das Format von Bits, Bytes, & Chips übertragen und dann die Daten extrahieren.

Beide Systeme verwenden auch eine Reihe von Hilfskomponenten, die mit BizTalk Server 2000 zusammenarbeiten, um wichtige Datenverarbeitungsaufgaben durchzuführen.

Die folgende Abbildung ist ein Interaktionsdiagramm für das automatisierte Beschaffungssystem auf Business-to-Business-Ebene, das von ProElectron und Bits, Bytes, & Chips implementiert wurde. Die Pfeile zeigen den Datenfluss zwischen Rollen und Entitäten an.

Internet
Bestell-
anwendung
Rechnung
Zahlung
Bits, Bytes,
& Chips, Inc
Auftrag
Auftragsanfrage-
genehmigung
Genehmigung
ProElectron, Inc
Anschaffungsanfrage
Benutzer
Auftrags-
prüfer
Finanzen
Lieferant

Wichtig

  • Für dieses Szenario sind sowohl das Käufer- als auch das Verkäufersystem auf einer einzigen Installation von BizTalk Server 2000 konfiguriert.

Die folgende Abbildung zeigt die Bewegung der Dokumente durch die Käufer- und Verkäufersysteme. Sie stellt auch die Interaktion zwischen dem XLANG-Ablaufplan, den BizTalk-Messagingdiensten und den Hilfskomponenten dar. Diese Abbildung ist eine hilfreiche Referenz, die Sie ausdrucken können, damit sie Ihnen während der Bearbeitung der Unterrichtseinheiten in diesem Lernprogramm zur Verfügung steht.

Send
Payment
Receive Invoice
Entscheidung
PO Request
>$1000
Ende
Receive
PO Request
XLANG-Ablaufplan
Dateiempfangsfunktion
Käuferdateiverzeichnis
WSC-Komponente
ASP-Datei
Nachrichten-
warteschlange
Ja (Ablehnung)
Nein
(Genehmigung)
Skriptkomponente
Messagingport
Messagingport
Channel for Invoice
Channel for PO
Kanal
Port to ProElectron
via HTTP
Port to Bits, Bytes,
& Chips via AIC
Port to Bits, Bytes, & Chips via Local File
POtoINVAIC
SubmitProElectronPO
Port to Bits, Bytes,
& Chips via HTTP
Channel for
Invoice to Payment
Channel for
POReq to PO
Kanal
BizTalk-Messaging
Message Queuing
Aktion
Port
Daten
Daten
ExecuteTutorial
PORequest Receive Function at ProElectron
DropInvoicetoMSMQ
ReceiveInvoice
PORequestApproval
ReceivePOReq
Message Queuing
Nachrichten-
warteschlange
Anwendung
PO Req
PO Req
Start
Käufersystem
BizTalk-Messagingdienste
Stopp
AIC
PO to Invoice
Verkäuferdatei-
verzeichnis
Zahlung
Verkäufer
Käufer
Zahlung
Rechnung
Anmerkung: Pfeile kennzeichnen den Datenfluss.
Rechnung
Rechnung
Zuordnung
Zuordnung
PO
PO
PO
PO
ASP-Datei
Verkäufersystem
BizTalk-Orchestrierung

Inhalt

Unterrichtseinheit 1: Gestalten von Geschäftsprozessen

In dieser Unterrichtseinheit lernen Sie Folgendes:

  • Erstellen einer XLANG-Ablaufplanzeichnung, mit der die Beschaffungsprozesse für ProElectron gestaltet werden, mithilfe des BizTalk-Orchestrierungs-Designers. Weitere Informationen finden Sie unter Entwerfen von BizTalk-Orchestrierungen.

  • Kompilieren der XLANG-Ablaufplanzeichnung in einen XLANG-Ablaufplan. Weitere Informationen finden Sie unter Kompilieren einer XLANG-Ablaufplanzeichnung in einen XLANG-Ablaufplan.

  • Ausführen des XLANG-Ablaufplanes, um zu sehen, wie eine Nachricht durch das Käufersystem bewegt wird.

Unterrichtseinheit 2: Erstellen von Spezifikationen und Zuordnungen

In dieser Unterrichtseinheit lernen Sie Folgendes:

  • Erstellen von Dokumentspezifikationen mithilfe des BizTalk-Editors. Weitere Informationen finden Sie unter Erstellen und Überprüfen von Spezifikationen.

  • Erstellen von Zuordnungen mithilfe des BizTalk-Mappers. Weitere Informationen finden Sie unter Erstellen neuer Zuordnungen.

Unterrichtseinheit 3: Konfigurieren der BizTalk-Messagingdienste

In dieser Unterrichtseinheit lernen Sie Folgendes:

  • Konfigurieren der BizTalk-Messagingdienste für Bits, Bytes, & Chips mithilfe des BizTalk-Messaging-Managers. Weitere Informationen finden Sie unter Verwenden des BizTalk-Messaging-Managers.

  • Erstellen einer Dateiempfangsfunktion für Bits, Bytes, & Chips mithilfe der BizTalk Server-Verwaltung. Weitere Informationen finden Sie unter Hinzufügen einer Dateiempfangsfunktion.

Unterrichtseinheit 4: Fertigstellen des XLANG-Ablaufplanes

In dieser Unterrichtseinheit lernen Sie Folgendes:

  • Implementieren eines Ports in die XLANG-Ablaufplanzeichnung, mit der Sie in Unterrichtseinheit 2 begonnen haben, mithilfe der BizTalk-Messagingimplementierung. Informationen zu den Unterschieden zwischen Ports und Messagingports finden Sie unter Grundlegendes zu Portimplementierungen und Grundlegendes zu Messagingports.

  • Beenden der XLANG-Ablaufplanzeichnung und Kompilieren der Zeichnung in einen XLANG-Ablaufplan.

  • Ausführen des Ablaufplanes, um sämtliche Nachrichtenbewegungen zwischen dem Käufer- und dem Verkäufersystem zu verstehen.

Verknüpfungen

Verknüpfungen können durch das Verwenden eines vorhandenen XLANG-Ablaufplanes, einer Dokumentspezifikation, einer Zuordnung oder eines Konfigurationsskripts Zeit und Arbeit sparen. Durch das Verwenden von Verknüpfungen gelangen Sie zu den nachfolgenden Abschnitten des Lernprogramms.

Für die Verwendung von Verknüpfungen müssen folgende Komponenten auf Laufwerk C: installiert sein.

Weiter mit Vorläufige Installation.


Vorläufige Installation

Bevor Sie mit dem Lernprogramm beginnen, müssen Sie Folgendes erstellen:

  • Einen Ordner mit vier Unterordnern.

  • Zwei lokale Websiteordner mit ASP-Dateien.

  • Zwei Nachrichtenwarteschlangen für das Käufersystem.

Weiter mit Erstellen von Ordnern.


Erstellen von Ordnern

In diesem Verfahren erstellen Sie einen Ordner, der vier Unterordner enthält. Zwei der Unterordner werden als Speicherorte für die in und aus Käufer- und Verkäufersystemen verschobenen Nachrichten verwendet und die anderen beiden Unterordner als Inhaltsordner für die Käufer- und Verkäuferwebsites.

So erstellen Sie die Ordner:

  1. Gehen Sie in Windows Explorer zum Stammverzeichnis des Laufwerkes C:.

    Vorsicht

    • Folgende Ordner müssen auf Laufwerk C: erstellt werden.
  2. Erstellen Sie einen neuen Ordner im Stammverzeichnis von Laufwerk C:; benennen Sie den Ordner TutorialFiles.

  3. Klicken Sie auf den neuen Ordner mit dem Namen TutorialFiles, und erstellen Sie vier Unterordner mit den folgenden Namen:
    • Buyer

    • Seller

    • SubmitPO

    • InvoiceToQueue

Weiter mit Kopieren von Dateien.


Kopieren von Dateien

In diesem Verfahren kopieren Sie die Dateien, die Sie für die Bearbeitung des Lernprogramms benötigen.

  1. Wechseln Sie auf dem BizTalk Server-Installationslaufwerk in das Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\DocSpecsandMaps, und kopieren Sie POReqtoPO.xml.

  2. Fügen Sie die Datei im Verzeichnis \Programme\Microsoft BizTalk Server\BizTalkServerRepository\Maps\Microsoft ein.

  3. Verwenden Sie die folgende Tabelle, um weitere Dateien zu kopieren und in die Unterordner TutorialFiles einzufügen.
    Kopieren aus: Einfügen in:
    \Programme\Microsoft BizTalk Server\Tutorial\Components\SubmitPO\Solution\SubmitProElectronPO.asp | C:\TutorialFiles\SubmitPO
    \Programme\Microsoft BizTalk Server\Tutorial\Components\InvoicetoQueue\Solution\DropInvoicetoMSMQ.asp | C:\TutorialFiles\InvoiceToQueue
    \Programme\Microsoft BizTalk Server\Tutorial\Components\InvoicetoQueue\Solution\Global.asa | C:\TutorialFiles\InvoiceToQueue

Weiter mit Erstellen von lokalen Websiteordnern.


Erstellen von lokalen Websiteordnern

In diesem Verfahren erstellen Sie zwei virtuelle Verzeichnisse. Das erste Verzeichnis simuliert die Käuferwebsite, in der Rechnungen empfangen werden. Das zweite Verzeichnis simuliert die Verkäuferwebsite, in der Aufträge empfangen werden.

  1. Zeigen Sie im Startmenü auf Einstellungen, und klicken Sie dann auf Systemsteuerung.

  2. Doppelklicken Sie auf Verwaltung.

  3. Doppelklicken Sie auf Computerverwaltung.

    Die Konsole der Computerverwaltung wird angezeigt.

  4. In der Konsolenstruktur der Computerverwaltung erweitern Sie Dienste und Anwendungen und Internet-Informationsdienste, und klicken Sie dann auf Standardwebsite.

  5. Im Menü Vorgang zeigen Sie auf Neu, und klicken Sie dann auf Virtuelles Verzeichnis.

    Der Assistent zum Erstellen virtueller Verzeichnisse wird geöffnet.

  6. Klicken Sie auf der Seite Willkommen auf Weiter.

  7. Auf der Seite Alias für Virtuelles Verzeichnis im Feld Alias geben Sie SubmitPO ein, und klicken Sie dann auf Weiter.

  8. Klicken Sie auf der Seite Verzeichnis des Websiteinhalts auf Durchsuchen.

  9. Suchen Sie C:\TutorialFiles\SubmitPO, klicken Sie auf OK und dann auf Weiter.

  10. Klicken Sie auf der Seite Zugriffsberechtigungen auf Weiter.

  11. Klicken Sie auf Fertig stellen, um den Assistent zum Erstellen virtueller Verzeichnisse zu schließen.

  12. Klicken Sie in der Konsolenstruktur der Computerverwaltung auf Standardwebsite.

  13. Um den Ordner zu erstellen, der die Käuferwebsite simuliert, wiederholen Sie die Schritte 5 bis 11 mit den folgenden Änderungen:
    • Bei Schritt 7 geben Sie InvoiceToQueue im Feld Alias ein.

    • Bei Schritt 9 suchen Sie C:\TutorialFiles\InvoiceToQueue.

Die Konsole der Computerverwaltung sollte so ähnlich aussehen wie im Folgenden abgebildet.

Klicken Sie zum Vergrößern oder Verkleinern auf die Abbildung.

  14. Schließen Sie die Konsole der Computerverwaltung.

Weiter mit Erstellen von Nachrichtenwarteschlangen.


Erstellen von Nachrichtenwarteschlangen

In diesem Verfahren erstellen Sie zwei Nachrichtenwarteschlangen, um das Käufersystem für das Versenden und Empfangen von Nachrichten zu aktivieren.

Anmerkung

Für die Durchführung dieses Verfahrens muss Message Queuing installiert sein. Anweisungen zum Installieren von Message Queuing finden Sie unter Installieren der Message Queuing-Dienste.

So erstellen Sie Nachrichtenwarteschlangen:

  1. Zeigen Sie im Startmenü auf Einstellungen, und klicken Sie dann auf Systemsteuerung.

  2. Doppelklicken Sie auf Verwaltung.

  3. Doppelklicken Sie auf Computerverwaltung.

    Die Konsole der Computerverwaltung wird angezeigt.

  4. Erweitern Sie in der Konsolenstruktur der Computerverwaltung Dienste und Anwendungen und Message Queuing, und klicken Sie dann auf Private Warteschlangen.

  5. Zeigen Sie im Menü Vorgang auf Neu, und klicken Sie dann auf Private Warteschlange.

    Das Dialogfeld Warteschlangenname wird angezeigt.

  6. Im Feld Name geben Sie ReceivePOReq ein.

  7. Aktivieren Sie das Kontrollkästchen Auf Transaktionen ausgelegt, und klicken Sie auf OK.

  8. Um die zweite Nachrichtenwarteschlange zu erstellen, wiederholen Sie die Schritte 5 bis 7 mit folgenden Änderungen:
    • Bei Schritt 6 geben Sie ReceiveInvoice im Feld Name ein.

Die Konsole der Computerverwaltung sollte so ähnlich aussehen wie im Folgenden abgebildet.

Klicken Sie zum Vergrößern oder Verkleinern auf die Abbildung.

  9. Schließen Sie die Konsole der Computerverwaltung.

Weiter mit Installieren der Hilfskomponenten.


Installieren der Hilfskomponenten

In diesem Verfahren installieren Sie die folgenden Hilfskomponenten:

  • Eine Windows-Skriptkomponente auf dem Käufersystem, die Sie zum Implementieren eines Ports in einen XLANG-Ablaufplan verwenden und die den Genehmigungs- oder Ablehnungsstatus für eine Auftragsanfrage aus dem XLANG-Ablaufplan annimmt.

  • Eine Anwendungsintegrationskomponente (Application Integration Component, AIC) auf dem Verkäufersystem, die Sie zum Generieren einer Rechnung verwenden, die auf den Daten im Auftragsformular des Käufers basiert.

    Vorsicht

    • Wenn Sie diese Komponenten bereits auf Ihrem Computer installiert haben, müssen Sie sie zuerst wieder deinstallieren. Fahren Sie mit Deinstallieren der Hilfskomponenten fort, um die Komponenten zu deinstallieren.

So installieren Sie die Hilfskomponenten:

  1. Auf dem BizTalk Server-Installationslaufwerk suchen Sie \Programme\Microsoft BizTalk Server\Tutorial\Setup.

  2. Doppelklicken Sie auf Install_POtoInvoice.vbs.

    Eine Feld mit der Meldung, dass die Komponente erfolgreich installiert wurde, wird angezeigt.

  3. Wechseln Sie in das Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\Components\POReqApproval\Solution, und klicken Sie dann auf PORequestApproval.wsc.

  4. Klicken Sie im Menü Datei auf Registrieren.

    Ein Feld mit der Meldung, dass die Komponente erfolgreich registriert wurde, wird angezeigt.

Weiter mit Unterrichtseinheit 1: Gestalten von Geschäftsprozessen.


Deinstallieren der Hilfskomponenten

Vorsicht

Verwenden Sie dieses Verfahren nur, wenn Sie eine vorherige Installation der Komponenten entfernen möchten.

  1. Für die Komponente POtoInvoice wechseln Sie in das Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\Setup auf dem BizTalk Server-Installationslaufwerk.

  2. Doppelklicken Sie auf Remove_POtoInvoice.vbs.

    Ein Feld mit der Meldung, dass die Komponente erfolgreich deinstalliert wurde, wird angezeigt.

  3. Für die Windows-Skriptkomponente wechseln Sie in das Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\Components\POReqApproval\Solution, und klicken Sie dann auf PORequestApproval.wsc.

  4. Klicken Sie im Menü Datei auf Registrierung aufheben.

    Ein Feld mit der Meldung, dass die Registrierung der Komponente erfolgreich aufgehoben wurde, wird angezeigt.

Fahren Sie mit Installieren der Hilfskomponenten fort, um die Komponenten erneut zu installieren.


Unterrichtseinheit1: Gestalten von Geschäftsprozessen

BizTalk Server-Kopfzeile

Unterrichtseinheit 1: Gestalten von Geschäftsprozessen

In dieser Unterrichtseinheit verwenden Sie den BizTalk-Orchestrierungs-Designer für die Erstellung einer XLANG-Ablaufplanzeichnung, die einen automatisierten Beschaffungsprozess beschreibt. Anschließend kompilieren Sie die XLANG-Ablaufplanzeichnung in einen ausführbaren XLANG-Ablaufplan, der den Nachrichtenstrom für das Käufersystem steuert.

Lernziele

  • Erstellen einer XLANG-Ablaufplanzeichnung, die den automatisierten Beschaffungsprozess beschreibt. Weitere Informationen finden Sie unter Erstellen von XLANG-Ablaufplanzeichnungen.

  • Verbinden der Aktionen in einer logischen Reihenfolge, die die Geschäftsprozesse beschreibt. Weitere Informationen finden Sie unter Verbinden von Formen.

  • Implementieren von Geschäftsprozessen durch das Verbinden von Aktionen mit Ports. Weitere Informationen finden Sie unter Einrichten des Kommunikationsflusses zwischen einer Aktion und einem Port.

  • Hinzufügen einer Regel zu Geschäftsprozessen durch das Schreiben eines Skriptausdrucks. Weitere Informationen finden Sie unter Entwerfen von Regeln.

  • Definieren des Datenflusses für Nachrichten. Weitere Informationen finden Sie unter Kommunikationsformen.

  • Speichern der XLANG-Ablaufplanzeichnung und Kompilieren der Zeichnung in einen XLANG-Ablaufplan. Weitere Informationen finden Sie unter Kompilieren von XLANG-Ablaufplänen.

  • Ausführen des XLANG-Ablaufplanes, um die Nachricht in BizTalk Server zu verarbeiten. Weitere Informationen finden Sie unter Ausführen von XLANG-Ablaufplänen.

Weiter mit Erstellen des XLANG-Ablaufplanes für den Käufer.

Verwandtes Thema

Entwerfen von BizTalk-Orchestrierungen


Erstellen des XLANG-Ablaufplanes für den Käufer

In diesem Verfahren gestalten Sie die Geschäftsprozesse für den Käufer und erstellen einen XLANG-Ablaufplan.

Zum Erstellen eines XLANG-Ablaufplanes weiter mit Erstellen der Käuferaktionen.

Verknüpfung

Für die Verwendung eines vorhandenen XLANG-Ablaufplanes direkt weiter mit Ausführen des XLANG-Ablaufplanes.


Erstellen der Käuferaktionen

  1. Zeigen Sie im Startmenü auf Programme und auf Microsoft BizTalk Server 2000, und klicken Sie dann auf BizTalk-Orchestrierungs-Designer.

  2. Ziehen Sie auf der Geschäftsprozessseite die Aktion-Form aus der Flussdiagrammschablone links neben die Trennlinie. Positionieren Sie die Form direkt unterhalb der Beginn-Form.

  3. Klicken Sie mit der rechten Maustaste auf die Aktion-Form, und wählen Sie dann Eigenschaften.

    Das Dialogfeld Aktionseigenschaften wird angezeigt.

  4. Im Feld Name geben Sie Receive PO Request (Auftragsanfrage erhalten) ein, und klicken Sie dann auf OK.

    Vorsicht

    • Damit dieses Szenario richtig ausgeführt wird, müssen alle Namen genauso eingegeben werden, wie in den Anweisungen angegeben. Die Lernprogrammkomponenten verwenden diese Namen.
  5. Auf der Geschäftsprozessseite ziehen Sie die Entscheidung-Form aus der Flussdiagrammschablone links neben die Trennlinie. Positionieren Sie die Form unter der Receive PO Request-Aktion.

  6. Klicken Sie mit der rechten Maustaste auf die Entscheidung-Form, und klicken Sie auf Regel hinzufügen.

    Das Dialogfeld Eigenschaften der Regel wird angezeigt.

  7. Im Feld Regelname geben Sie Denied (Abgelehnt) ein, und klicken Sie dann auf OK.

    Weiter unten in dieser Unterrichtseinheit fügen Sie einen Skriptausdruck hinzu, der die Entscheidungsregel implementiert, nachdem Sie die Entscheidung-Form an die Skriptkomponente gebunden haben, die die Nachrichten- und die Feldnamen bereitstellt.

  8. Wiederholen Sie die Schritte 2 bis 4, um die folgenden drei Aktionen zu erstellen:
    • Positionieren Sie eine zweite Aktion-Form rechts neben der Entscheidung-Form. Nennen Sie diese Aktion Send Denial (Ablehnung senden).

    • Positionieren Sie eine dritte Aktion-Form unter der Entscheidung-Form. Nennen Sie diese Aktion Send Approval (Genehmigung senden).

    • Positionieren Sie eine vierte Aktion-Form unter der Send Approval-Aktion. Nennen Sie diese Aktion Write PO Request to File (Auftragsanfrage in Datei schreiben).
  9. Ziehen Sie auf der Geschäftsprozessseite die Ende-Form aus der Flussdiagrammschablone links neben die Trennlinie. Positionieren Sie die Form unter der Send Denial-Aktion.

    Wenn die Auftragsanfrage nicht genehmigt wird, zeigt der XLANG-Ablaufplan eine Ablehnungsnachricht an und endet.

  10. Ziehen Sie auf der Geschäftsprozessseite die Ende-Form aus der Flussdiagrammschablone links neben die Trennlinie. Positionieren Sie die Form unter der Write PO Request to File-Aktion.

    Wenn die Auftragsanfrage genehmigt wird, schreibt der XLANG-Ablaufplan die Auftragsanfrage in ein Dateiverzeichnis, zeigt eine Genehmigungsnachricht an und endet dann.

Weiter mit Verbinden der Käuferaktionen in einer Reihenfolge.


Verbinden der Käuferaktionen in einer Reihenfolge

  1. Klicken Sie auf die Beginn-Form, um die Kontrollhandles zu markieren.

    Ziehen Sie den unteren Kontrollhandle zum oberen Verbindungspunkt der Receive PO Request-Aktion.

    Die Receive PO Request-Aktion stellt den Anfang des Geschäftsprozesses dar. Wenn eine Auftragsanfrage empfangen wird, wird der XLANG-Ablaufplan ausgeführt.

    Anmerkungen

    • Ein grünes Feld auf einer markierten Form zeigt ein Kontrollhandle an. Sie können Kontrollhandles ziehen, um eine Verbindung mit einer Aktion herzustellen.

    • Ein blaues X auf einer Form zeigt einen Verbindungspunkt an.

    • Verbindungspunkte an der Seite einer Aktion-Form werden nur für die Verbindung mit Ports verwendet, nicht für die Verbindung mit anderen Aktion-Formen.
  2. Wiederholen Sie Schritt 1, um eine Verbindung für die folgende Aktion herzustellen:
    • Verbinden Sie die Receive PO Request-Aktion mit der Entscheidung-Form.
  3. Markieren Sie die Denied-Regel in der Entscheidung-Form, und ziehen Sie dann das rechte Kontrollhandle der Denied-Regel zum oberen Verbindungspunkt der Send Denial-Aktion.

  4. Markieren Sie die Else-Regel in der Entscheidung-Form, und ziehen Sie das linke Kontrollhandle der Else-Regel zum oberen Verbindungspunkt der Send Approval-Aktion.

    Anmerkung

    • Sie können die Regeln in der Entscheidung-Form sowohl vom rechten als auch vom linken Kontrollhandle mit den Aktionen Send Approval und Send Denial verbinden.
  5. Verbinden Sie die Send Approval-Aktion mit der Write PO Request to File-Aktion.

  6. Verbinden Sie die Write PO Request to File-Aktion mit der Ende-Form, die sich darunter befindet.

  7. Verbinden Sie die Send Denial-Aktion mit der Ende-Form, die sich darunter befindet.

  8. Klicken Sie im Menü Datei auf Speichern unter.

    Das Dialogfeld XLANG-Ablaufplanzeichnung speichern unter wird angezeigt.

  9. Wechseln Sie in das Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\Schedule\Lab auf dem BizTalk Server-Installationslaufwerk.

  10. Im Feld Dateiname geben Sie Buyer1 (Käufer1) ein, und klicken Sie dann auf Speichern.

Die XLANG-Ablaufplanzeichnung, die Sie erstellt und gespeichert haben, sollte so wie in der folgenden Darstellung aussehen.

Klicken Sie zum Vergrößern oder Verkleinern auf die Abbildung.

Weiter mit Implementieren eines Ports mithilfe von Message Queuing für den Empfang einer Auftragsanfrage.


Implementieren eines Ports mithilfe von Message Queuing für den Empfang einer Auftragsanfrage

Der Dienst wird für die Überwachung einer Nachrichtenwarteschlange für Auftragsanfragen konfiguriert. Dann wird der XLANG-Ablaufplan gestartet. Informationen zum Verwenden von Ports und Messagingports in diesem Lernprogramm finden Sie unter Integrieren der BizTalk-Dienste.

So implementieren Sie den Port:

  1. Auf der Geschäftsprozessseite ziehen Sie die Message Queuing-Form aus der Implementierungsschablone rechts neben die Trennlinie. Positionieren Sie die Message Queuing-Form so, dass sie sich horizontal auf einer Linie mit der Receive PO Request-Aktion befindet.

    Der Bindungs-Assistent für Message Queuing wird geöffnet.

  2. Überprüfen Sie, ob auf der Seite Willkommen beim Bindungs-Assistenten für Message Queuing die Option Neuen Port erstellen ausgewählt ist.

  3. Im Feld Neuen Port erstellen geben Sie ReceivePORequest (Auftragsanfrage erhalten) ein, und klicken Sie dann auf Weiter.

  4. Überprüfen Sie auf der Seite Informationen über statische oder dynamische Warteschlangen, ob Statische Warteschlange ausgewählt ist, und klicken Sie dann auf Weiter.

  5. Auf der Seite Warteschlangeninformationen klicken Sie auf Bekannte Warteschlange für alle Instanzen verwenden.

  6. Im Feld Geben Sie den Namen der Warteschlange ein geben Sie .\private$\ReceivePOReq ein, und klicken Sie dann auf Weiter.

  7. Auf der Seite Erweiterte Porteigenschaften klicken Sie auf Fertig stellen.

    Auf der Geschäftsprozessseite werden der ReceivePORequest-Port (Auftragsanfrage erhalten) und die zugeordnete Message Queuing-Implementierung angezeigt.

Weiter mit Erstellen des Kommunikationsflusses für die Receive PO Request-Aktion.


Erstellen des Kommunikationsflusses für die Receive PO Request-Aktion

  1. Markieren Sie die Receive PO Request-Aktion, und ziehen Sie den Kontrollhandle rechts neben der Receive PO Request-Aktion zum linken Verbindungspunkt des ReceivePORequest-Ports.

    Der Assistent für XML-Kommunikation wird geöffnet.

  2. Auf der Seite Willkommen beim Assistenten für XML-Kommunikation klicken Sie auf Empfangen, und klicken Sie dann auf Weiter.

  3. Überprüfen Sie auf der Seite Nachrichteninformationen, ob Neue Nachricht erstellen ausgewählt ist.

  4. Im Feld Nachrichtenname geben Sie POReq ein, und klicken Sie dann auf Weiter.

  5. Überprüfen Sie auf der Seite Informationen über die XML-Konvertierung, ob die Option Nachrichten in der Warteschlange als XML-Nachrichten empfangen ausgewählt ist, und klicken Sie dann auf Weiter.

  6. Auf der Seite Informationen über den Nachrichtentyp im Feld Nachrichtentyp geben Sie POReq ein, und klicken Sie dann auf Weiter.

  7. Auf der Seite Informationen über die Nachrichtenspezifikation klicken Sie auf Durchsuchen.

    Das Dialogfeld Nach Spezifikation durchsuchen wird angezeigt.

  8. Wechseln Sie in das Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\DocSpecsandMaps auf dem BizTalk Server-Installationslaufwerk.

  9. Klicken Sie auf PoReq.xml und dann auf Öffnen.

  10. Klicken Sie auf Hinzufügen.

    Das Dialogfeld Feldauswahl wird angezeigt.

  11. Im Bereich Auswahlknoten erweitern Sie Total, und klicken Sie dann auf POTtl und anschließend auf OK.

    Im Bereich Nachrichtenfelder sollte POTtl in der Liste der Nachrichtenfelder angezeigt werden.

  12. Klicken Sie auf Fertig stellen.

Nach dem Implementieren des Ports und dem Erstellen des Kommunikationsflusses sollte die XLANG-Ablaufplanzeichnung so wie in der folgenden Darstellung aussehen.

Klicken Sie zum Vergrößern oder Verkleinern auf die Abbildung.

Weiter mit Implementieren eines Ports mithilfe einer Skriptkomponente.


Implementieren eines Ports mithilfe einer Skriptkomponente

Der XLANG-Ablaufplan leitet den Wert im Feld Total in der Auftragsanfrage an die Entscheidung-Form weiter. Der Skriptausdruck in der Entscheidungsregel verzweigt den Ablaufplanpfad und sendet die entsprechende Nachricht an die Portimplementierung, die eine Windows-Skriptkomponente verwendet, basierend auf der Gesamtzahl der Auftragsanfragen.

So implementieren Sie den Port:

  1. Auf der Implementierungsschablone ziehen Sie die Skriptkomponente-Form rechts neben die Trennlinie, die die beiden Seiten der Zeichnung voneinander trennt. Positionieren Sie die Form so, dass Sie horizontal auf einer Linie mit der Entscheidung-Form liegt.

    Der Bindungsassistent für Skriptkomponenten wird geöffnet.

  2. Auf der Seite Willkommen beim Bindungs-Assistenten für Skriptkomponenten im Feld Neuen Port erstellen geben Sie ApprovalComponent (Genehmigungskomponente) ein, und klicken Sie dann auf Weiter.

  3. Überprüfen Sie auf der Seite Statische oder dynamische Kommunikation, ob Statisch ausgewählt ist, und klicken Sie dann auf Weiter.

  4. Auf der Seite Skriptdatei angeben klicken Sie auf Durchsuchen.

  5. Wechseln Sie in das Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\Components\POReqApproval\Solution auf dem BizTalk Server-Installationslaufwerk.

  6. Klicken Sie auf PORequestApproval.wsc, klicken Sie auf Öffnen und dann auf Weiter.

  7. Überprüfen Sie auf der Seite Informationen über Komponenteninstanziierung, ob Mit Programm-ID "BTSTutorial.PORequestApproval" ausgewählt ist, und klicken Sie dann auf Weiter.

  8. Auf der Seite Methodeninformationen klicken Sie auf Alle auswählen, und klicken Sie dann auf Weiter.

  9. Auf der Seite Erweiterte Porteigenschaften klicken Sie auf Fertig stellen.

Weiter mit Definieren von Nachrichteneigenschaften für die Skriptkomponente.


Definieren von Nachrichteneigenschaften für die Skriptkomponente

  1. Markieren Sie die Send Denial-Aktion, und ziehen Sie das rechte Kontrollhandle zum ApprovalComponent-Skriptkomponentenport von Windows.

    Der Methodenkommunikations-Assistent wird geöffnet.

  2. Überprüfen Sie auf der Seite Willkommen beim Methodenkommunikations-Assistenten, ob Synchronen Methodenaufruf initiieren ausgewählt ist, und klicken Sie dann auf Weiter.

  3. Überprüfen Sie auf der Seite Nachrichteninformationen, ob Neue Nachricht erstellen ausgewählt ist, und klicken Sie dann auf Weiter.

  4. Klicken Sie auf der Seite Informationen über die Nachrichtenspezifikation in der Liste Methoden auf SendDenial, und klicken Sie dann auf Fertig stellen.

  5. Markieren Sie die Send Approval-Aktion, und ziehen Sie den Kontrollhandle rechts neben der Send Approval-Aktion zum ApprovalComponent-Port.

    Der Methodenkommunikations-Assistent wird geöffnet.

  6. Überprüfen Sie auf der Seite Willkommen beim Methodenkommunikations-Assistenten, ob Synchronen Methodenaufruf initiieren ausgewählt ist, und klicken Sie dann auf Weiter.

  7. Überprüfen Sie auf der Seite Nachrichteninformationen, ob Neue Nachricht erstellen ausgewählt ist, und klicken Sie dann auf Weiter.

  8. Klicken Sie auf der Seite Informationen über die Nachrichtenspezifikation in der Liste Methoden auf SendApproval, und klicken Sie dann auf Fertig stellen.

  9. Markieren Sie die Write PO Request to File-Aktion, und ziehen Sie den Kontrollhandle rechts neben der Write PO Request to File-Aktion zum ApprovalComponent-Port.

    Der Methodenkommunikations-Assistent wird geöffnet.

  10. Überprüfen Sie auf der Seite Willkommen beim Methodenkommunikations-Assistenten, ob Synchronen Methodenaufruf initiieren ausgewählt ist, und klicken Sie dann auf Weiter.

  11. Überprüfen Sie auf der Seite Nachrichteninformationen, ob Neue Nachricht erstellen ausgewählt ist, und klicken Sie dann auf Weiter.

  12. Überprüfen Sie auf der Seite Informationen über die Nachrichtenspezifikation in der Liste Methoden, ob WriteToFile ausgewählt ist, und klicken Sie dann auf Fertig stellen.

Weiter mit Schreiben des Skriptausdrucks für die Entscheidungsregel.


Schreiben des Skriptausdrucks für die Entscheidungsregel

Die Ablehnungsentscheidungsregel enthält Eigenschaften, die das Verhalten der Form definieren. Der Skriptausdruck verweist auf Daten, die in Nachrichten enthalten sind, und wird zu TRUE oder FALSE ausgewertet. Der Skriptausdruck definiert auch die logischen und Variablennamen, die von der Entscheidung-Form verwendet werden.

Wenn der Umfang der Auftragsanfrage $1000 überschreitet, geschieht Folgendes:

  • Die Entscheidung-Form sendet eine Nachricht an den Port.

  • Ein Nachrichtenfeld informiert den Benutzer über die Ablehnung.

  • Der XLANG-Ablaufplan endet.

Wenn der Gesamtumfang der Auftragsanfrage $1000 oder weniger beträgt, geschieht Folgendes:

  • Die Entscheidung-Form sendet eine Genehmigungsnachricht an die Skriptkomponente.

  • Die Skriptkomponente zeigt ein Meldungsfeld an, dass den Benutzer über die Genehmigung informiert.

  • Die Skriptkomponente schreibt die Auftragsanfragenachricht in ein lokales Dateiverzeichnis.

  • Der XLANG-Ablaufplan endet.

So schreiben Sie den Skriptausdruck:

  1. Klicken Sie unten auf der Seite auf die Registerkarte Daten.

    Die Seite Daten wird angezeigt.

  2. Zeigen Sie die POReq-Nachricht an, um den Feldnamen zu finden.

    Für das Schreiben des Skriptausdrucks sind sowohl der Nachrichtenname als auch der Feldname erforderlich. In diesem Fall lautet der Nachrichtenname POReq und der Feldname POTtl.

  3. Klicken Sie unten auf der Seite auf die Registerkarte Geschäftsprozess.

    Die Geschäftsprozessseite wird angezeigt.

  4. Klicken Sie mit der rechten Maustaste auf Entscheidung-Form, und klicken Sie dann auf Eigenschaften.

    Das Dialogfeld Entscheidungseigenschaften wird angezeigt.

  5. Überprüfen Sie, ob Denied ausgewählt ist, und klicken Sie dann auf Bearbeiten.

    Das Dialogfeld Eigenschaften der Regel wird angezeigt.

  6. Im Feld Skriptausdruck geben Sie POReq.POTtl > 1000 ein.

    Diese Eingabe gibt an, dass die Auftragsanfrage abgelehnt wird, wenn der Betrag im Feld Total der Anfrage größer als $1000 ist.

  7. Klicken Sie auf OK, um das Dialogfeld Eigenschaften der Regel zu schließen, und klicken Sie dann erneut auf OK, um das Dialogfeld Entscheidungseigenschaften zu schließen.

Die XLANG-Ablaufplanzeichnung sollte so wie in der folgenden Darstellung aussehen.

Klicken Sie zum Vergrößern oder Verkleinern auf die Abbildung.

Weiter mit Definieren des Datenflusses.


Definieren des Datenflusses

Erstellen Sie Verbindungen zwischen den Feldern in den Nachrichtenformen auf der Datenseite, um den Datenfluss innerhalb des Geschäftsprozesses zu definieren.

So definieren Sie den Datenfluss:

  1. Klicken Sie unten auf der Seite auf die Registerkarte Daten.

    Die Seite Daten wird angezeigt.

  2. Klicken Sie in der POReq-Nachricht auf das Feld Document, und ziehen Sie das Kontrollhandle auf der rechten Seite zu einem Verbindungspunkt auf dem Feld Document in der SendDenial_in-Nachricht.

  3. Wiederholen Sie Schritt 2, indem Sie auf das Feld Document klicken und dann den markierten Kontrollhandle rechts vom POReq-Feld zu einem Verbindungspunkt auf den folgenden Feldern ziehen:
    • Das Feld Document im Dialogfeld SendApproval_in.

    • Das Feld Document im Dialogfeld WriteToFile_in.

Anmerkung

  • Klicken Sie auf das Feld Document in der POReq-Nachricht, bevor Sie versuchen, das Kontrollhandle auf die anderen Felder zu ziehen.

Die fertige Datenseite sollte so wie in der folgenden Darstellung aussehen.

Klicken Sie zum Vergrößern oder Verkleinern auf die Abbildung.

Weiter mit Speichern der XLANG-Ablaufplanzeichnung.


Speichern der XLANG-Ablaufplanzeichnung

  • Klicken Sie im Menü Datei auf Buyer1.skv speichern.

Weiter mit Kompilieren des XLANG-Ablaufplanes.


Kompilieren des XLANG-Ablaufplanes

  1. Klicken Sie im Menü Datei auf XLANG Buyer1.skx erstellen.

    Das Dialogfeld XLANG-Ablaufplan speichern unter wird angezeigt.

  2. Stellen Sie sicher, dass der XLANG-Ablaufplan im Ordner \Programme\Microsoft BizTalk Server\Tutorial\Schedule\Lab auf dem BizTalk Server-Installationslaufwerk gespeichert wird, und klicken Sie dann auf Speichern.

  3. Klicken Sie im Menü Datei auf Beenden, um den BizTalk-Orchestrierungs-Designer zu schließen.

Weiter mit Ausführen des XLANG-Ablaufplanes.


Ausführen des XLANG-Ablaufplanes

In diesem Verfahren führen Sie den XLANG-Ablaufplan zweimal aus, um die Genehmigung und die Ablehnung der Auftragsanfrage anzuzeigen.

So führen Sie den XLANG-Ablaufplan aus:

  1. Wechseln Sie in das Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\Schedule\Solution auf dem BizTalk Server-Installationslaufwerk.

  2. Doppelklicken Sie auf ExecuteTutorial.exe. Diese Anwendung wird verwendet, um den XLANG-Ablaufplan mithilfe eines Monikers zu aktivieren.

    Die Anwendung ExecuteTutorial wird geöffnet.

  3. Klicken Sie auf Browse for Schedule.

Verknüpfung

Wenn Sie den vorhandenen XLANG-Ablaufplan verwenden, wechseln Sie in das Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\Schedule\Solution, und fahren Sie mit Schritt 5 in diesem Verfahren fort.

  4. Wenn Sie den XLANG-Ablaufplan Buyer1 erstellt haben, wechseln Sie in das Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\Schedule\Lab auf dem BizTalk Server-Installationslaufwerk.

  5. Klicken Sie auf die XLANG-Ablaufplandatei Buyer1.skx und dann auf Öffnen.

  6. Klicken Sie auf Browse for Data File, und wechseln Sie dann in das Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\Schedule\SampleData auf dem BizTalk Server-Installationslaufwerk.

  7. Klicken Sie auf POReqAccept.xml und dann auf Öffnen.

  8. Klicken Sie auf Start XLANG Schedule.

    Da der Gesamtumfang der Auftragsanfrage unter $1000 liegt, wird sie genehmigt. Ein Feld mit der Meldung, dass die Anwendung Daten an das XLANG-Ablaufplanmodul weitergeleitet hat, wird angezeigt. An dieser Stelle wird die Anwendung beendet. Ein zweites Meldungsfeld informiert Sie darüber, dass die Auftragsanfrage genehmigt wurde. Klicken Sie auf OK, um die Dialogfelder zu schließen.

  9. Klicken Sie auf End (Ende), um die Anwendung ExecuteTutorial zu schließen.

    Wichtig

    • Wenn Sie beim Ausführen der Anwendung einen Automatisierungsfehler feststellen, überprüfen Sie, ob Sie die private Warteschlange richtig konfiguriert haben und der Name richtig ist.
  10. Wechseln Sie in das Verzeichnis C:\TutorialFiles\Buyer.

    Der Dateiname ist POReqXXXXX.xml, wobei XXXXX einen eindeutigen Zahlensatz darstellt. Doppelklicken Sie auf die Datei, um Sie in Microsoft Internet Explorer zu öffnen. Dies ist eine Kopie der Auftragsanfragedatei, die die Anwendung an die Nachrichtenwarteschlange weitergeleitet hat. Nach dem Anzeigen der Datei löschen Sie sie.

  11. Wiederholen Sie die Schritte 1 bis 5, um die Anwendung ExecuteTutorial erneut auszuführen.

  12. Klicken Sie auf Browse for Data File, und wechseln Sie in das Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\Schedule\SampleData auf dem BizTalk Server-Installationslaufwerk.

  13. Klicken Sie auf POReqDeny.xml und dann auf Öffnen.

  14. Klicken Sie auf Start XLANG Schedule.

    Weil der Gesamtumfang $1000 überschreitet, wird die Auftragsanfrage abgelehnt. Ein Feld mit der Meldung, dass die Anwendung beendet wurde, wird angezeigt. Eine zweites Meldungsfeld informiert Sie darüber, dass die Dokumentenablehnung empfangen wurde. Klicken Sie auf OK, um die Dialogfelder zu schließen.

  15. Klicken Sie auf End (Ende), um die Anwendung ExecuteTutorial zu schließen.

Das folgende Diagramm stellt den Datenfluss beim Ausführen des XLANG-Ablaufplanes dar.

Send
Payment
Receive Invoice
Entscheidung
PO Request
>$1000
Ende
Receive
PO Request
XLANG-Ablaufplan
Dateiempfangsfunktion
Käuferdateiverzeichnis
WSC-Komponente
ASP-Datei
Nachrichten-
warteschlange
Ja (Ablehnung)
Nein
(Genehmigung)
Skriptkomponente
Messagingport
Messagingport
Channel for Invoice
Channel for PO
Kanal
Port to ProElectron
via HTTP
Port to Bits, Bytes,
& Chips via AIC
Port to Bits, Bytes, & Chips via Local File
POtoINVAIC
SubmitProElectronPO
Port to Bits, Bytes,
& Chips via HTTP
Channel for
Invoice to Payment
Channel for
POReq to PO
Kanal
BizTalk Messaging
Message Queuing
Aktion
Port
Daten
Daten
ExecuteTutorial
PORequest Receive Function at ProElectron
DropInvoicetoMSMQ
ReceiveInvoice
PORequestApproval
ReceivePOReq
Message Queuing
Nachrichten-
warteschlange
Anwendung
PO Req
PO Req
Start
Käufersystem
BizTalk-Messagingdienste
Stopp
AIC
PO to Invoice
Verkäuferdatei-
verzeichnis
Zahlung
Verkäufer
Käufer
Zahlung
Rechnung
Anmerkung: Pfeile kennzeichnen den Datenfluss.
Rechnung
Rechnung
Zuordnung
Zuordnung
PO
PO
PO
PO
ASP-Datei
Verkäufersystem
BizTalk-Orchestrierung

Weiter mit Zusammenfassung von Unterrichtseinheit 1.


Zusammenfassung von Unterrichtseinheit1

BizTalk Server-Kopfzeile

Zusammenfassung von Unterrichtseinheit 1

In dieser Unterrichtseinheit haben Sie Folgendes durchgeführt:

  • Die XLANG-Ablaufplanzeichnung erstellt, die den automatisierten Beschaffungsprozess beschreibt. Weitere Informationen finden Sie unter Erstellen von XLANG-Ablaufplanzeichnungen.

  • Die Aktionen in einer logischen Reihenfolge verbunden, die den Geschäftsprozess beschreibt. Weitere Informationen finden Sie unter Verbinden von Formen.

  • Den Geschäftsprozess durch das Verbinden von Aktionen mit Ports implementiert. Weitere Informationen finden Sie unter Einrichten des Kommunikationsflusses zwischen einer Aktion und einem Port.

  • Eine Regel zum Geschäftsprozess durch Schreiben eines Skriptausdrucks hinzugefügt. Weitere Informationen finden Sie unter Entwerfen von Regeln.

  • Den Datenfluss für Nachrichten definiert. Weitere Informationen finden Sie unter Kommunikationsformen.

  • Die XLANG-Ablaufplanzeichnung gespeichert und in den XLANG-Ablaufplan kompiliert. Weitere Information finden Sie unter Kompilieren von XLANG-Ablaufplänen.

  • Den XLANG-Ablaufplan zweimal ausgeführt, um die Auftragsanfrage in BizTalk Server zu verarbeiten, und beobachtet, wie die Genehmigung und die Ablehnung erteilt wurden. Weitere Informationen finden Sie unter Ausführen von XLANG-Ablaufplänen.

Die markierten Bereiche der folgenden Abbildung zeigen, welche Schritte Sie in dieser Unterrichtseinheit ausgeführt haben.

Send
Payment
Receive Invoice
Entscheidung
PO Req
>$1000
Ende
Receive
PO Req
XLANG-Ablaufplan
Dateiempfangsfunktion
Käuferdateiverzeichnis
WSC-Komponente
ASP-Datei
Nachrichten-
warteschlange
Ja (Ablehnung)
Nein
(Genehmigung)
Skriptkomponente
Messagingport
Messagingport
Channel for Invoice
Channel for PO
Kanal
Port to ProElectron
via HTTP
Port to Bits, Bytes,
& Chips via AIC
Port to Bits, Bytes, & Chips via Local File
POtoINVAIC
SubmitProElectronPO
Port to Bits, Bytes,
& Chips via HTTP
Channel for
Invoice to Payment
Channel for
POReq to PO
Kanal
BizTalk Messaging
Message Queuing
Aktion
Port
Daten
Daten
ExecuteTutorial
PO Request Receive Function at ProElectron
DropInvoicetoMSMQ
ReceiveInvoice
PORequestApproval
ReceivePOReq
Message Queuing
Nachrichten-
warteschlange
Anwendung
PO Req
PO Req
Start
Käufersystem
BizTalk-Messagingdienste
Stopp
AIC
PO to Invoice
Verkäuferdatei-
verzeichnis
Zahlung
Verkäufer
Käufer
Zahlung
Rechnung
Anmerkung: Pfeile kennzeichnen den Datenfluss.
Rechnung
Rechnung
Zuordnung
Zuordnung
PO
PO
PO
PO
ASP-Datei
Verkäufersystem
BizTalk-Orchestrierung

Weiter mit Unterrichtseinheit 2: Erstellen von Spezifikationen und Zuordnungen.

Verwandtes Thema

Entwerfen von BizTalk-Orchestrierungen


Unterrichtseinheit2: Erstellen von Spezifikationen und Zuordnungen

BizTalk Server-Kopfzeile

Unterrichtseinheit 2: Erstellen von Spezifikationen und Zuordnungen

In dieser Unterrichtseinheit verwenden Sie den BizTalk-Editor zum Erstellen von Spezifikationen und den BizTalk-Mapper zum Erstellen von Zuordnungen.

Lernziele

  • Erstellen einer Spezifikation. Weitere Informationen finden Sie unter Erstellen von Spezifikationen.

  • Hinzufügen von neuen Datensätzen und Feldern zu einer Spezifikation. Weitere Informationen finden Sie unter Hinzufügen neuer Felder zu Datensätzen.

  • Erstellen einer Zuordnung. Weitere Informationen finden Sie unter Zuordnen von Daten.

  • Erstellen von Verknüpfungen zwischen Feldern in einer Zuordnung. Weitere Informationen finden Sie unter Erstellen von Verknüpfungen.

  • Verwenden von Funktoiden, um Werte in einer Zuordnung mathematisch zu bearbeiten. Weitere Informationen finden Sie unter Grundlegendes zu Funktoiden.

  • Speichern von Spezifikationen und Zuordnungen im WebDAV-Repository. Weitere Informationen finden Sie unter Speichern von Spezifikationen und Speichern von Zuordnungen.

Weiter mit Verwenden des BizTalk-Editors.

Verwandtes Thema

Erstellen von Spezifikationen und Zuordnen von Daten


Verwenden des BizTalk-Editors

Sie können den BizTalk-Editor verwenden, um Spezifikationen zu erstellen, zu bearbeiten und zu verwalten.

Zum Erstellen der Zahlungsspezifikation mithilfe des BizTalk-Editors weiter mit Erstellen der Zahlungsspezifikation.

Verknüpfung

Zum Verwenden der vorhandenen Zahlungsspezifikation direkt weiter mit Verwenden der vorhandenen Zahlungsspezifikation.


Verwenden der vorhandenen Zahlungsspezifikation

  1. Kopieren Sie PaymentSpec.xml aus dem Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\DocSpecsandMaps auf dem BizTalk Server-Installationslaufwerk.

  2. Fügen Sie die Datei in das Verzeichnis \Programme\Microsoft BizTalk Server\BizTalkServerRepository\DocSpecs\Microsoft ein.

Zum Erstellen der Spezifikation für die Auftragsanfrage mithilfe des BizTalk-Editors weiter mit Erstellen der Auftragsanfragespezifikation.

Verknüpfung

Zum Verwenden der vorhandenen Auftragsanfragespezifikation weiter mit Verwenden der vorhandenen Auftragsanfragespezifikation.


Erstellen der Zahlungsspezifikation

  1. Zeigen Sie im Startmenü auf Programme und dann auf Microsoft BizTalk Server 2000, und klicken Sie anschließend auf BizTalk-Editor.

  2. Klicken Sie im Menü Datei auf Neu.

    Das Dialogfeld Neue Dokumentspezifikation wird angezeigt.

  3. Klicken Sie auf das Symbol Leere Spezifikation, und klicken Sie dann auf OK.

  4. Im Stammknoten klicken Sie auf LeereSpezifikation.

  5. Doppelklicken Sie auf der Registerkarte Deklaration auf das Feld Wert in der Zeile Name, geben Sie Payment (Zahlung)ein, und drücken Sie dann die EINGABETASTE.

  6. Doppelklicken Sie auf das Feld Wert in der Modell-Zeile, klicken Sie auf Offen, und drücken Sie dann die EINGABETASTE.

Weiter mit Hinzufügen von neuen Datensätzen zum Zahlungsstammknoten der Zahlungsspezifikation.


Hinzufügen von neuen Datensätzen zum Zahlungsstammknoten der Zahlungsspezifikation

  1. Klicken Sie mit der rechten Maustaste auf den Stammknoten Payment, und klicken Sie dann auf Neuer Datensatz.

  2. Benennen Sie diesen Datensatz PaymentHeader (Zahlungskopfzeile), und drücken Sie dann die EINGABETASTE.

  3. Wiederholen Sie die Schritte 1 und 2, um vier zusätzliche Datensätze unter dem Stammknoten Payment zu erstellen und zu benennen. Diese Datensätze sind untergeordnete Datensätze des Stammknotens Payment. Benennen Sie diese Datensätze wie folgt:
    • Seller (Verkäufer)

    • Buyer (Käufer)

    • Item (Posten)

    • PaymentSummary (ZahlungZusammenfassung)

Weiter mit Hinzufügen neuer Datensätze zu vorhandenen Datensätzen in der Zahlungsspezifikation.


Hinzufügen neuer Datensätze zu vorhandenen Datensätzen in der Zahlungsspezifikation

  1. Klicken Sie mit der rechten Maustaste auf den Seller-Datensatz, und klicken sie dann auf Neuer Datensatz.

  2. Benennen Sie den Datensatz Address (Adresse), und drücken Sie dann die EINGABETASTE.

  3. Wiederholen Sie die Schritte 1 und 2, um untergeordnete Datensätze für die in der folgenden Tabelle aufgelisteten übergeordneten Datensätze zu erstellen.
    Übergeordneter Datensatz | Namen der untergeordneten Datensätze
    Seller | ContactInfo (Kontaktinfo)
    Buyer | Address
    Buyer | ContactInfo

Weiter mit Hinzufügen neuer Felder zu vorhandenen Datensätzen in der Zahlungspezifikation.


Hinzufügen neuer Felder zu vorhandenen Datensätzen in der Zahlungspezifikation

  1. Klicken Sie mit der rechten Maustaste auf den PaymentHeader-Datensatz, und klicken Sie dann auf Neues Feld.

  2. Benennen Sie das Feld PONumber (Auftragsnummer), und drücken Sie die EINGABETASTE.

  3. Doppelklicken Sie auf der Registerkarte Deklaration auf das Feld Wert in der Datentyp-Zeile, klicken Sie auf String, und drücken Sie dann die EINGABETASTE.

  4. Doppelklicken Sie auf der Registerkarte Deklaration auf das Feld Wert in der Minimallänge-Zeile, geben Sie 1 ein, und drücken Sie dann die EINGABETASTE.

  5. Doppelklicken Sie auf der Registerkarte Deklaration auf das Feld Wert in der Maximallänge-Zeile, geben Sie 22 ein, und drücken Sie dann die EINGABETASTE.

  6. Wiederholen Sie die Schritte 1 bis 5, um für die in der folgenden Tabelle aufgeführten Datensätze oder untergeordneten Datensätze Felder zu erstellen. Jeder Datensatz enthält mehrere Felder.

    Sie müssen diese Felder nicht für den Käufer erstellen, weil für den Käufer und den Verkäufer parallele Datensatznamen vorhanden sind. Alle Datensätze mit dem gleichen Namen enthalten dieselben Datensatz- und Feldinformationen. Wenn Sie neue Felder zu den Datensätzen Seller/Address oder Seller/ContactInfo hinzufügen, werden die Datensätze Buyer/Address oder Buyer/ContactInfo automatisch mit denselben Feldern aktualisiert.

    Übergeordneter Datensatz | Feldname | Datentyp | Minimallänge | Maximallänge
    PaymentHeader | Date (Datum) | Date | Nicht anwendbar | Nicht anwendbar
    Seller/Address | Name | String | 1 | 60
    Address1 (Adresse1) | String | 1 | 55
    Address2 (Adresse2) | String | 1 | 55
    City (Ort) | String | 2 | 30
    State (Bundesland-Kanton) | String | 2 | 2
    Zip (PLZ) | String | 3 | 15
    Country (Land-Region) | String | 2 | 3
    Seller/ContactInfo | Name | String | 1 | 60
    Number (Nummer) | String | 1 | 60
    Item | Quantity (Menge) | Real(r4) | Nicht anwendbar | Nicht anwendbar
    Price (Preis) | Real(r4) | Nicht anwendbar | Nicht anwendbar
    Description (Beschreibung) | String | 1 | 80
    ExtendedPrice (Erweiteter Preis) | Real(r4) | Nicht anwendbar | Nicht anwendbar
    PaymentSummary | Total (Gesamt) | Real(r4) | Nicht anwendbar | Nicht anwendbar

Weiter mit Speichern der Zahlungsspezifikation in WebDAV.


Speichern der Zahlungsspezifikation in WebDAV

  1. Klicken Sie im Menü Datei auf In WebDAV speichern.

    Das Dialogfeld In WebDAV speichern wird angezeigt.

  2. Doppelklicken Sie auf den Ordner Microsoft.

  3. Im Feld Dateiname geben Sie PaymentSpec (Zahlungsspezifikation) ein, und klicken Sie dann auf Speichern.

  4. Klicken Sie im Menü Extras auf Instanz überprüfen.

    Das Dialogfeld Dokumentinstanz überprüfen wird angezeigt.

  5. Wechseln Sie in das Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\Schedule\Solution auf dem BizTalk Server-Installationslaufwerk.

  6. Klicken Sie auf payment_valid.xml, und klicken Sie dann auf Öffnen.

    Warnungen oder Fehler werden gegebenenfalls auf der Registerkarte Warnungen angezeigt.

Die Zahlungsspezifikation sollte so wie in der folgenden Darstellung aussehen.

Klicken Sie zum Vergrößern oder Verkleinern auf die Abbildung.

Zum Erstellen der Auftragsanfragespezifikation mithilfe des BizTalk-Editors fahren Sie mit Erstellen der Auftragsanfragespezifikation fort.

Verknüpfung

Zum Verwenden der vorhandenen Auftragsanfragespezifikation fahren Sie mit Verwenden der vorhandenen Auftragsanfragespezifikation fort.


Verwenden der vorhandenen Auftragsanfragespezifikation

  1. Kopieren Sie POReq.xml aus dem Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\DocSpecsandMaps auf dem BizTalk Server-Installationslaufwerk.

  2. Fügen Sie die Datei in das Verzeichnis \Programme\Microsoft BizTalk Server\BizTalkServerRepository\DocSpecs\Microsoft ein.

Weiter mit Verwenden des BizTalk-Mappers.


Erstellen der Auftragsanfragespezifikation

In diesem Verfahren erstellen Sie den Stammknoten der Auftragsanfragespezifikation.

So erstellen Sie den Stammknoten:

  1. Klicken Sie im Menü Datei auf Neu.

    Das Dialogfeld Neue Dokumentspezifikation wird angezeigt.

  2. Klicken Sie auf das Symbol Leere Spezifikation, und klicken Sie dann auf OK.

  3. Im Stammknoten klicken Sie auf LeereSpezifikation.

  4. Doppelklicken Sie auf der Registerkarte Deklaration auf das Feld Wert in der Name-Zeile, geben Sie POReq ein, und drücken Sie die EINGABETASTE.

  5. Doppelklicken Sie auf das Feld Wert in der Modell-Zeile, klicken Sie auf Offen, und drücken Sie dann die EINGABETASTE.

Weiter mit Hinzufügen neuer Datensätze zum Stammknoten in der Auftragsanfragespezifikation.


Hinzufügen neuer Datensätze zum Stammknoten in der Auftragsanfragespezifikation

  1. Klicken Sie mit der rechten Maustaste auf den Stammknoten POReq, und klicken Sie dann auf Neuer Datensatz.

  2. Benennen Sie diesen Datensatz Header (Kopfzeile), und drücken Sie dann die EINGABETASTE.

  3. Wiederholen Sie die Schritte 1 und 2, um fünf zusätzliche Datensätze unter dem Stammknoten POReq zu erstellen und zu benennen. Diese Datensätze sind untergeordnete Datensätze des Stammknotens POReq. Benennen Sie diese Datensätze wie folgt:
    • EmployeeInfo (Personalinfo)

    • BillTo (RechnungAn)

    • ShipTo (LiefernAn)

    • Item

    • Total

Weiter mit Hinzufügen von neuen Datensätzen zu vorhandenen Datensätze in der Auftragsanfragespezifikation.


Hinzufügen von neuen Datensätzen zu vorhandenen Datensätze in der Auftragsanfragespezifikation

  1. Klicken Sie mit der rechten Maustaste auf den BillTo-Datensatz, und klicken Sie dann auf Neuer Datensatz.

  2. Benennen Sie den Datensatz Address, und drücken Sie dann die EINGABETASTE.

  3. Wiederholen Sie die Schritte 1 und 2, um für den übergeordneten Datensatz ShipTo einen untergeordneten Datensatz Address zu erstellen und zu benennen.

Weiter mit Hinzufügen von neuen Feldern zu vorhandenen Datensätzen in der Auftragsanfragespezifikation.


Hinzufügen von neuen Feldern zu vorhandenen Datensätzen in der Auftragsanfragespezifikation

  1. Klicken Sie mit der rechten Maustaste auf den Header-Datensatz, und klicken Sie dann auf Neues Feld.

  2. Benennen Sie dieses Feld Date, und drücken Sie dann die EINGABETASTE.

  3. Doppelklicken Sie auf der Registerkarte Deklaration auf das Feld Wert in der Datentyp-Zeile, klicken Sie auf Date, und drücken Sie dann die EINGABETASTE.

  4. Klicken Sie mit der rechten Maustaste auf den EmployeeInfo-Datensatz, und klicken Sie dann auf Neues Feld.

  5. Benennen Sie dieses Feld EmpID, und drücken Sie dann die EINGABETASTE.

  6. Doppelklicken Sie auf der Registerkarte Deklaration auf das Feld Wert in der Datentyp-Zeile, klicken Sie auf String, und drücken Sie dann die EINGABETASTE.

  7. Doppelklicken Sie auf der Registerkarte Deklaration auf das Feld Wert in der Minimallänge-Zeile, geben Sie 1 ein, und drücken Sie dann die EINGABETASTE.

  8. Doppelklicken Sie auf der Registerkarte Deklaration auf das Feld Wert in der Maximallänge-Zeile, geben Sie 60 ein, und drücken Sie dann die EINGABETASTE.

  9. Wiederholen Sie die Schritte 4 bis 8, um für die in der folgenden Tabelle aufgeführten Datensätze oder untergeordneten Datensätze Felder zu erstellen. Jeder Datensatz enthält mehrere Felder.

    Sie müssen diese Felder nicht für ShipTo erstellen, weil für BillTo und ShipTo parallele Datensatznamen vorhanden sind. Alle Datensätze mit dem gleichen Namen enthalten dieselben Datensatz- und Feldinformationen. Wenn Sie dem BillTo/Address-Datensatz neue Felder hinzufügen, wird der ShipTo/Address-Datensatz automatisch mit denselben Feldern aktualisiert.

    Übergeordneter Datensatz | Feldname | Datentyp | Minimallänge | Maximallänge
    EmployeeInfo | LastName (Nachname) | String | 1 | 30
    FirstName (Vorname) | String | 1 | 30
    BillTo/Address | Name | String | 1 | 60
    Address1 | String | 1 | 55
    Address2 | String | 1 | 55
    City | String | 2 | 30
    State | String | 2 | 2
    Zip | String | 3 | 15
    Country | String | 2 | 3
    Item | Quantity | Real(r4) | Nicht anwendbar | Nicht anwendbar
    Price | Real(r4) | Nicht anwendbar | Nicht anwendbar
    Description | String | 1 | 80
    UnitofMeasure (Maßeinheit) | String | 2 | 2
    ExtendedPrice | Real(r4) | Nicht anwendbar | Nicht anwendbar
    Total | LineItemTtl | Real(r4) | Nicht anwendbar | Nicht anwendbar
    QtyTtl | Real(r4) | Nicht anwendbar | Nicht anwendbar
    POTtl | Real(r4) | Nicht anwendbar | Nicht anwendbar

Weiter mit Speichern der Auftragsanfragespezifikation.


Speichern der Auftragsanfragespezifikation

  1. Klicken Sie im Menü Datei auf In WebDAV speichern.

    Das Dialogfeld In WebDAV speichern wird angezeigt.

  2. Überprüfen Sie, ob der Ordner Microsoft geöffnet ist.

  3. Im Feld Dateiname geben Sie POReq ein, und klicken Sie dann auf Speichern.

  4. Klicken Sie im Menü Extras auf Instanz überprüfen.

    Das Dialogfeld Dokumentinstanz überprüfen wird angezeigt.

  5. Wechseln Sie in das Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\Schedule\SampleData auf dem BizTalk Server-Installationslaufwerk.

  6. Klicken Sie auf POReqAccept.xml und dann auf Öffnen.

    Warnungen oder Fehler werden gegebenenfalls auf der Registerkarte Warnungen angezeigt.

Die Auftragsanfragespezifikation sollte so wie in der folgenden Darstellung aussehen.

Klicken Sie zum Vergrößern oder Verkleinern auf die Abbildung.

  7. Klicken Sie im Menü Datei auf Beenden, um die Konsole des BizTalk-Editors zu schließen.

Weiter mit Verwenden des BizTalk-Mappers.


Verwenden des BizTalk-Mappers

In diesem Verfahren erstellen Sie mithilfe des BizTalk-Mappers eine Zuordnung. Diese Zuordnung transformiert die Daten aus einer Nachricht, die mit der Spezifikation von CommonInvoice (Standardrechnung) übereinstimmt, in Daten einer Nachricht, die mit der Spezifikation von PaymentSpec übereinstimmt.

BizTalk-Messagingdienste verwenden eine Zuordnung innerhalb eines Kanals, um anzugeben, wie die Daten eines Dokuments von einem Format in ein anderes Format transformiert werden.

Zum Erstellen der Zuordnung mithilfe des BizTalk-Mappers fahren Sie mit Erstellen der InvoiceToPayment-Zuordnung fort.

Verknüpfung

Zum Verwenden der vorhandenen Zuordnung fahren Sie direkt mit Verwenden der vorhandenen InvoiceToPayment-Zuordnung fort.


Verwenden der vorhandenen InvoiceToPayment-Zuordnung

  1. Kopieren Sie InvoiceToPayment.xml aus dem Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\DocSpecsandMaps auf dem BizTalk Server-Installationslaufwerk.

  2. Fügen Sie die Datei in das Verzeichnis \Programme\Microsoft BizTalk Server\BizTalkServerRepository\Maps\Microsoft ein.

Weiter mit Unterrichtseinheit 3: Konfigurieren der BizTalk-Messagingdienste.


Erstellen der InvoiceToPayment-Zuordnung

  1. Zeigen Sie im Startmenü auf Programme und dann auf Microsoft BizTalk Server 2000, und klicken Sie dann auf BizTalk-Mapper.

  2. Klicken Sie im Menü Datei auf Neu.

    Das Dialogfeld Quellspezifikationstyp auswählen wird angezeigt.

  3. Klicken Sie auf das Symbol WebDAV-Dateien und dann auf OK.

    Das Dialogfeld Quellspezifikation abrufen wird angezeigt.

  4. Doppelklicken Sie auf den Ordner Microsoft.

  5. Klicken Sie auf CommonInvoice.xml und dann auf Öffnen.

    Das Dialogfeld Zielspezifikationstyp auswählen wird angezeigt.

  6. Klicken Sie auf das Symbol WebDAV-Dateien und dann auf OK.

  7. Klicken Sie auf PaymentSpec.xml und dann auf Öffnen.

Weiter mit Erstellen von Verknüpfungen zwischen Feldern.


Erstellen von Verknüpfungen zwischen Feldern

In dem folgenden Verfahren verknüpfen Sie Felder aus der Quellspezifikation mit Feldern in der Zielspezifikation.

So erstellen Sie Verknüpfungen zwischen Feldern:

  1. Erweitern Sie in der Quellspezifikationsstruktur den InvoiceHeader-Datensatz (Rechnungskopfzeile), um die zugeordneten Felder anzuzeigen.

    Weitere Informationen finden Sie unter Erweitern von Strukturelementen.

  2. Erweitern Sie in der Zielspezifikationsstruktur den PaymentHeader-Datensatz, um die zugeordneten Felder anzuzeigen.

  3. Ziehen Sie das Feld InvoiceHeader/Date aus der Quellspezifikationsstruktur zum Feld PaymentHeader/Date in der Zielspezifikationsstruktur. Wiederholen Sie die Schritte 1 bis 3, um Verknüpfungen zwischen den in den folgenden Tabellen aufgeführten Feldern zu erstellen.
    Quelldatensatz/Feld | Zieldatensatz/Feld
    InvoiceHeader/Number | PaymentHeader/PONumber

    Seller/Address/Name | Seller/Address/Name
    Seller/Address/Address1 | Seller/Address/Address1
    Seller/Address/Address2 | Seller/Address/Address2
    Seller/Address/City | Seller/Address/City
    Seller/Address/State | Seller/Address/State
    Seller/Address/PostalCode | Seller/Address/Zip
    Seller/Address/Country | Seller/Address/Country

    Seller/ContactInfo/ContactName | Seller/ContactInfo/Name
    Seller/ContactInfo/ContactNumber | Seller/ContactInfo/Nummer

    Buyer/Address/Name | Buyer/Address/Name
    Buyer/Address/Address1 | Buyer/Address/Adresse1
    Buyer/Address/Address2 | Buyer/Address/Adresse2
    Buyer/Address/City | Buyer/Address/City
    Buyer/Address/State | Buyer/Address/City
    Buyer/Address/PostalCode | Buyer/Address/Zip
    Buyer/Address/Country | Buyer/Address/Country

    Buyer/ContactInfo/ContactName | Buyer/ContactInfo/Name
    Buyer/ContactInfo/ContactNumber | Buyer/ConactInfo/Number

    Item/ItemHeader/Quantity | Item/Quantity
    Item/ItemHeader/Price | Item/Price
    Item/ItemDescription/Description | Item/Description

    InvoiceSummary/InvoiceTotal/Amount PaymentSummary/Total

Weiter mit Verwenden von Funktoiden zum Erstellen von Verknüpfungen.


Verwenden von Funktoiden zum Erstellen von Verknüpfungen

In diesem Verfahren verwenden Sie ein Funktoid, um das Mengenfeld mit dem Preisfeld in der Quellspezifikation zu multiplizieren und diesen Wert in das Feld ExtendedPrice in der Zielspezifikation einzufügen.

So verwenden Sie Funktoide zum Erstellen von Verknüpfungen:

  1. Klicken Sie im Menü Ansicht auf Funktoidpalette.

    Die Funktoidpalette wird angezeigt.

  2. Klicken Sie auf die Registerkarte Mathematisch, ziehen Sie das Funktoid Multiplikation Funktoid "Multiplikation" auf das Zuordnungsraster, und schließen Sie dann die Funktoidpalette.

  3. Ziehen Sie in der Quellspezifikationsstruktur das Feld Item/ItemHeader/Quantity zum Funktoid.

  4. Ziehen Sie in der Quellspezifikationsstruktur das Feld Item/ItemHeader/Price zum Funktoid.

  5. Ziehen Sie das Funktoid Multiplikation zum Feld Item/ExtendedPrice in der Zielspezifikationsstruktur.

Weiter mit Kompilieren der Zuordnung.


Kompilieren der Zuordnung

  1. Klicken Sie im Menü Extras auf Zuordnung kompilieren.

  2. Klicken Sie im unteren Bereich auf die Registerkarte Ausgabe.

    Die Informationen auf der Registerkarte Ausgabe geben an, dass eine XSL-Zuordnung erstellt wurde. Warnungen oder Fehler werden gegebenenfalls auf der Registerkarte Warnungen angezeigt.

Weiter mit Speichern der Zuordnung in WebDAV.


Speichern der Zuordnung in WebDAV

  1. Klicken Sie im Menü Datei auf In WebDAV speichern.

    Das Dialogfeld In WebDAV speichern wird angezeigt.

  2. Doppelklicken Sie auf den Ordner Microsoft.

  3. Im Feld Dateiname geben Sie InvoiceToPayment (RechnungAnZahlung) ein, und klicken Sie dann auf Speichern.

Die von Ihnen erstellte Zuordnung sollte so wie in der folgenden Darstellung aussehen.

Klicken Sie zum Vergrößern oder Verkleinern auf die Abbildung.

  4. Klicken Sie im Menü Datei auf Beenden, um die Konsole des BizTalk-Mappers zu schließen.

Weiter mit Zusammenfassung von Unterrichtseinheit 2.


Zusammenfassung von Unterrichtseinheit2

BizTalk Server-Kopfzeile

Zusammenfassung von Unterrichtseinheit 2

In dieser Unterrichtseinheit haben Sie Folgendes durchgeführt:

  • Eine Spezifikation erstellt. Weitere Informationen finden sie unter Grundlegendes zu Spezifikationen.

  • Neue Datensätze und Felder zu einer Spezifikation hinzugefügt. Weitere Informationen finden Sie unter Hinzufügen neuer Felder zu Datensätzen.

  • Eine Zuordnung erstellt. Weitere Informationen finden Sie unter Zuordnen von Daten.

  • Zwischen Feldern in einer Zuordnung Verknüpfungen erstellt. Weitere Informationen finden Sie unter Erstellen von Verknüpfungen.

  • Funktoide verwendet, um Werte in einer Zuordnung mathematisch zu bearbeiten. Weitere Informationen finden Sie unter Grundlegendes zu Funktoiden.

  • Spezifikationen und Zuordnungen im WebDAV-Repository gespeichert. Weitere Informationen finden Sie unter Speichern von Spezifikationen und Speichern von Zuordnungen.

Der markierte Bereich der folgenden Abbildung zeigt, welche Schritte Sie in dieser Unterrichtseinheit ausgeführt haben.

Send
Payment
Receive Invoice
Entscheidung
PO Req
>$1000
Ende
Receive
PO Req
XLANG-Ablaufplan
Dateiempfangsfunktion
Käuferdateiverzeichnis
WSC-Komponente
ASP-Datei
Nachrichten-
warteschlange
Ja (Ablehnung)
Nein
(Genehmigung)
Skriptkomponente
Messaging Port
Messaging Port
Channel for Invoice
Channel for PO
Kanal
Port to ProElectron
via HTTP
Port to Bits, Bytes,
& Chips via AIC
Port to Bits, Bytes, & Chips via Local File
POtoINVAIC
SubmitProElectronPO
Port to Bits, Bytes,
& Chips via HTTP
Channel for
Invoice to Payment
Channel for
POReq to PO
Kanal
BizTalk Messaging
Message Queuing
Aktion
Port
Daten
Daten
ExecuteTutorial
PO Request Receive Function at ProElectron
DropInvoicetoMSMQ
ReceiveInvoice
PORequestApproval
ReceivePOReq
Message Queuing
Nachrichten-
warteschlange
Anwendung
PO Req
PO Req
Start
Käufersystem
BizTalk-Messagingdienste
Stop
AIC
PO to Invoice
Verkäuferdatei-
verzeichnis
Zahlung
Verkäufer
Käufer
Zahlung
Rechnung
Anmerkung: Pfeile kennzeichnen den Datenfluss.
Rechnung
Rechnung
Zuordnung
Zuordnung
PO
PO
PO
PO
ASP-Datei
Verkäufersystem
BizTalk-Orchestrierung

Weiter mit Unterrichtseinheit 3: Konfigurieren der BizTalk-Messagingdienste.

Verwandtes Thema

Erstellen von Spezifikationen und Zuordnen von Daten


Unterrichtseinheit3: Konfigurieren der BizTalk-Messagingdienste

BizTalk Server-Kopfzeile

Unterrichtseinheit 3: Konfigurieren der BizTalk-Messagingdienste

In dieser Unterrichtseinheit lernen Sie, wie der BizTalk-Messaging-Manager verwendet wird, um Organisationen, Kanäle und Messagingports für Verkäufer- und Käufersysteme zu konfigurieren. Sie lernen darüber hinaus auch die Verwendung der BizTalk Server-Verwaltung für die Konfiguration einer Dateiempfangsfunktion kennen.

Lernziele

  • Erstellen der Dokumentdefinitionen. Weitere Informationen finden Sie unter Erstellen und Verwalten von Dokumentdefinitionen.

  • Erstellen von Organisationen. Weitere Informationen finden Sie unter Erstellen und Verwalten von Organisationen.

  • Erstellen von Messagingports. Weitere Informationen finden Sie unter Erstellen und Verwalten von Messagingports und Integrieren der BizTalk-Dienste.

  • Erstellen von Kanälen. Weitere Informationen finden Sie unter Erstellen und Verwalten von Kanälen.

  • Verwenden einer Zuordnung in einem Kanal, um ein Dokument zu transformieren. Weitere Informationen finden Sie unter Zuordnen von Daten.

  • Erstellen der Empfangsfunktion. Weitere Informationen finden Sie unter Empfangsfunktionen.

Weiter mit Konfigurieren des Käufersystems.

Verwandtes Thema

Verwenden des BizTalk-Messaging-Managers


Konfigurieren des Käufersystems

Der BizTalk-Messaging-Manager wird verwendet, um Organisationen zu erstellen, die Ihre Handelspartner repräsentieren.

Zum Konfigurieren des Käufersystems mithilfe des BizTalk-Messaging-Managers fahren Sie mit Erstellen der Organisationen für das Käufersystem fort.

Verknüpfung

Zum Verwenden eines Skripts für die Konfiguration des Käufersystems fahren Sie direkt mit Konfigurieren des Käufersystems mithilfe eines Konfigurationsskripts fort.


Konfigurieren des Käufersystems mithilfe eines Konfigurationsskripts

Dieses Skript konfiguriert Folgendes:

  • Eine Quellorganisation mit dem Namen ProElectron on Buyer auf dem Käufersystem.

  • Eine Zielorganisation mit dem Namen Bits,Bytes,Chips on Buyer auf dem Käufersystem.

  • Vier Dokumentdefinitionen, die auf Spezifikationen für CommonPO, CommonInvoice, PaymentSpec und POReq verweisen.

  • Einen Messagingport und einen Kanal, die die Bewegungen einer Auftragsanfrage vom Käufersystem zum Verkäufersystem definieren, indem sie einen HTTP-Transportdienst zu einer ASP-Datei auf dem Verkäufersystem verwenden.

  • Ein Messagingport und einen Kanal, die die Bewegungen einer Rechnung definieren, die zum Kunden übermittelt wurde, und sie in ein Zahlungsdokument auf dem Verkäufersystem transformieren.

Vorsicht

  • Wenn Sie den BizTalk-Messaging-Manager und die BizTalk Server-Verwaltung verwendet haben, um das Käufersystem zu konfigurieren, führen Sie das Konfigurationsskript nicht aus.

So führen Sie das Skript aus, das die BizTalk-Messagingdienste für das Käufersystem konfiguriert:

  1. Wechseln Sie in das Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\Setup\MessagingConfigurationScript auf dem BizTalk Server-Installationslaufwerk.

  2. Doppelklicken Sie auf ConfigureBuyer.VBS.

    Ein Meldungsfeld zeigt an, dass der Vorgang erfolgreich durchgeführt wurde.

Weiter mit Konfigurieren des Verkäufersystems.


Erstellen der Organisationen für das Käufersystem

Vorsicht

  • Wenn Sie das Konfigurationsskript verwendet haben, konfigurieren Sie das Käufersystem nicht mithilfe des BizTalk-Messaging-Managers und der BizTalk Server-Verwaltung. Weiter mit Konfigurieren des Verkäufersystems.
  1. Zeigen Sie im Startmenü auf Programme, zeigen Sie auf Microsoft BizTalk Server 2000, und klicken Sie dann auf BizTalk-Messaging-Manager.

  2. Wenn das Dialogfeld BizTalk-Messaging-Manager angezeigt wird, klicken Sie auf Abbrechen.

  3. Zeigen Sie im Menü Datei auf Neu, und klicken Sie auf Organisation.

    Das Dialogfeld Neue Organisation wird angezeigt.

  4. Im Feld Organisationsname geben Sie Bits,Bytes,Chips on Buyer (Bits,Bytes,Chips an Käufer) ein, und klicken Sie dann auf OK.

  5. Wiederholen Sie die Schritte 3 und 4, und benennen Sie die neue Organisation ProElectron on Buyer (ProElectron an Käufer).

Weiter mit Erstellen der Dokumentdefinitionen für die Käufer- und Verkäufersysteme.


Erstellen der Dokumentdefinitionen für die Käufer- und Verkäufersysteme

In diesem Verfahren erstellen Sie vier Dokumentdefinitionen, die sich auf die Dokumentspezifikationen CommonInvoice, CommonPO, PaymentSpec und POReq beziehen. Diese Dokumentdefinitionen werden von Käufer- und Verkäufersystemen gemeinsam genutzt.

So erstellen Sie die Dokumentdefinitionen:

  1. Zeigen Sie im Menü Datei auf Neu, und klicken Sie dann auf Dokumentdefinition.

    Das Dialogfeld Neue Dokumentdefinition wird angezeigt.

  2. Im Feld Dokumentdefinitionsname geben Sie Purchase Order (Auftrag) ein.

  3. Aktivieren Sie das Kontrollkästchen Dokumentspezifikation, und klicken Sie auf die Schaltfläche Durchsuchen.

    Das Dialogfeld Dokumentspezifikation aus dem WebDAV-Repository auswählen wird angezeigt.

  4. Doppelklicken Sie auf den Ordner Microsoft.

  5. Klicken Sie auf CommonPO.xml und dann auf Öffnen.

  6. Klicken Sie auf OK, um das Dialogfeld Neue Dokumentdefinition zu schließen.

  7. Wiederholen Sie die Schritte 1 bis 6, um eine neue Dokumentdefinition mit den folgenden Änderungen zu erstellen:
    • Benennen Sie die neue Dokumentdefinition Invoice (Rechnung).

    • Klicken Sie auf die Spezifikation CommonInvoice.xml aus WebDAV.
  8. Wiederholen Sie die Schritte 1 bis 6, um eine neue Dokumentdefinition mit den folgenden Abweichungen zu erstellen:
    • Benennen Sie die neue Dokumentdefinition Purchase Order Request.

    • Klicken Sie auf die Spezifikation POReq.xml aus WebDAV.
  9. Wiederholen Sie die Schritte 1 bis 6, um eine neue Dokumentdefinition mit den folgenden Abweichungen zu erstellen:
    • Benennen Sie die neue Dokumentdefinition Payment.

    • Klicken Sie auf die Spezifikation PaymentSpec.xml aus WebDAV.

Weiter mit Erstellen eines Messagingports zu Bits, Bytes, & Chips für das Käufersystem.


Erstellen eines Messagingports zu Bits, Bytes, & Chips für das Käufersystem

In diesem Verfahren erstellen Sie einen Messagingport für das Käufersystem. Ein Messagingport definiert das Ziel für ein Dokument.

Die Zielorganisation des Messagingports, den Sie erstellen, ist Bits, Bytes, Chips on Buyer. Dieser Port verwendet den HTTP-Transportdienst, um Dokumente an Bits, Bytes, & Chips zu übermitteln.

So erstellen Sie den Messagingport:

  1. Zeigen Sie im Menü Datei auf Neu, zeigen Sie auf Messagingport, und klicken Sie dann auf Zu einer Organisation.

    Der Messagingport-Assistent wird geöffnet.

  2. Im Feld Name geben Sie Port to Bits,Bytes,Chips via HTTP (Port zu Bits, Bytes, Chips via HTTP) ein und klicken dann auf Weiter.

  3. Auf der Seite Zielorganisation im Bereich Organisation, klicken Sie auf Durchsuchen.

    Das Dialogfeld Organisation auswählen wird angezeigt.

  4. Klicken Sie auf Bits,Bytes,Chips on Buyer und dann auf OK.

  5. Klicken Sie im Bereich Primärer Transport auf Durchsuchen.

    Das Dialogfeld Primärer Transport wird angezeigt.

  6. In der Liste Transporttyp klicken Sie auf HTTP.

  7. Im Feld Adresse nach dem Präfix http:// geben Sie Name Ihres Computers ein, gefolgt von /SubmitPO/SubmitProElectronPO.asp, klicken Sie anschließend auf OK und dann auf Weiter.

    Beispielsweise http://Computer1/SubmitPO/SubmitProElectronPO.asp

    Führen Sie folgende Schritte aus, um den Namen Ihres Computers zu finden:

    1. Zeigen Sie im Startmenü auf Einstellungen, und klicken Sie dann auf Systemsteuerung.

    2. Doppelklicken Sie auf Verwaltung.

    3. Doppelklicken Sie auf Computerverwaltung.

      Die Konsole der Computerverwaltung wird angezeigt.

    4. Klicken Sie im Menü Vorgang auf Eigenschaften.

      Das Dialogfeld Computerverwaltung (Lokal) Eigenschaften wird angezeigt.

    5. Klicken Sie auf die Registerkarte Netzwerkidentifikation.

      Der Name Ihres Computers wird im Feld Computername angezeigt.

  8. Klicken Sie auf der Seite Umschlagsinformationen auf Weiter.

  9. Überprüfen Sie auf der Seite Sicherheitsinformationen, ob das Kontrollkästchen Kanal für diesen Messagingport erstellen aktiviert ist.

  10. Klicken Sie in der Liste Kanaltyp auf Von einer Organisation, und klicken Sie dann auf Fertig stellen.

    Der Kanal-Assistent wird geöffnet.

Weiter mit Erstellen eines Kanals von ProElectron für das Käufersystem.


Erstellen eines Kanals von ProElectron für das Käufersystem

In diesem Verfahren erstellen Sie einen Kanal für den Messagingport.

So erstellen Sie den Kanal:

  1. Auf der Seite Allgemeine Informationen im Feld Name geben Sie Channel for POReq to PO (Kanal für Auftragsanfrage an Auftrag) ein, und klicken Sie dann auf Weiter.

  2. Klicken Sie auf der Seite Quellorganisation auf Durchsuchen.

    Das Dialogfeld Organisation auswählen wird angezeigt.

  3. Klicken Sie auf ProElectron on Buyer, klicken Sie auf OK, und klicken Sie dann auf Weiter.

  4. Auf der Seite Eingehendes Dokument klicken Sie rechts vom Feld Definitionsname des eingehenden Dokuments auf Durchsuchen.

    Das Dialogfeld Dokumentdefinition auswählen wird angezeigt.

  5. Klicken Sie auf Purchase Order Request, klicken Sie auf OK, und klicken Sie dann auf Weiter.

  6. Auf der Seite Ausgehendes Dokument klicken Sie rechts vom Feld Definitionsname des ausgehenden Dokuments auf Durchsuchen.

    Das Dialogfeld Dokumentdefinition auswählen wird angezeigt.

  7. Klicken Sie auf Purchase Order, und klicken Sie dann auf OK.

  8. Überprüfen Sie, ob das Kontrollkästchen Eingehendes Dokument ausgehendem Dokument zuordnen aktiviert ist.

  9. Klicken Sie rechts vom Feld Verweis zuordnen auf Durchsuchen.

    Das Dialogfeld Eine Zuordnung aus dem WebDAV-Repository auswählen wird angezeigt.

  10. Doppelklicken Sie auf den Ordner Microsoft.

  11. Klicken Sie auf POReqtoPO.xml, klicken Sie auf Öffnen und dann auf Weiter.

  12. Klicken Sie auf der Seite Dokumentprotokollierung auf Weiter.

  13. Klicken Sie auf der Seite Erweiterte Konfiguration auf Fertig stellen.

Weiter mit Erstellen eines Messagingports zu Bits, Bytes, & Chips innerhalb eines Käufersystems.


Erstellen eines Messagingports zu Bits, Bytes, & Chips innerhalb eines Käufersystems

In diesem Verfahren versendet der Messagingport mithilfe des Dateitransportdienstes Dokumente innerhalb des Käufersystems. Die Dokumente werden intern an den in der Zieladresse angegebenen Ordner gesendet.

So erstellen Sie den Messagingport:

  1. Zeigen Sie im Menü Datei auf Neu, zeigen Sie auf Messagingport, und klicken Sie dann auf Zu einer Organisation.

    Der Messagingport-Assistent wird geöffnet.

  2. Im Feld Name geben Sie Port to Bits,Bytes,Chips via Local File (Port to Bits,Bytes,Chips über lokale Datei)ein, und klicken Sie dann auf Weiter.

  3. Auf der Seite Zielorganisationsname im Bereich Organisation klicken Sie auf Durchsuchen.

    Das Dialogfeld Organisation auswählen wird angezeigt.

  4. Klicken Sie auf ProElectron on Buyer, und klicken Sie dann auf OK.

  5. Klicken Sie im Bereich Primärer Transport auf Durchsuchen.

    Das Dialogfeld Primärer Transport wird angezeigt.

  6. Klicken Sie in der Liste Transporttyp auf File.

  7. Im Feld Adresse nach dem Präfix file:// geben Sie C:\TutorialFiles\Seller\payment%tracking_id%.xml ein. Beispielsweise file://c:\TutorialFiles\Seller\payment%tracking_id%.xml

    Anmerkung

    • Beim Dateitransportdienst besteht die Standardeinstellung für die Transportkomponente im Anhängen neuer Dateien an eine vorhandene Datei im angegebenen Verzeichnis. Sie müssen das folgende Dateipfadformat verwenden, um eine neue Datei mit einem eindeutigen Namen für jede Dokumentinstanz zu erstellen:
      file://C:\dir\file%tracking_id%.xmlfile://C:\dir\file%tracking_id%.xml
  8. Klicken Sie auf OK, um das Dialogfeld Primärer Transport zu schließen, und klicken Sie dann auf Weiter.

  9. Klicken Sie auf der Seite Umschlagsinformationen auf Weiter.

  10. Überprüfen Sie auf der Seite Sicherheitsinformationen, ob das Kontrollkästchen Kanal für diesen Messagingport erstellen aktiviert ist.

  11. Klicken Sie in der Liste Kanaltyp auf Von einer Organisation, und klicken Sie dann auf Fertig stellen.

    Der Kanal-Assistent wird geöffnet.

Weiter mit Erstellen eines Kanals von Bits, Bytes, & Chips für das Käufersystem.


Erstellen eines Kanals von Bits, Bytes, & Chips für das Käufersystem

Der Kanal, den Sie in diesem Verfahren erstellen, verarbeitet Rechnungen, die von Bits, Bytes, & Chips empfangen werden, und verwendet eine Zuordnung, um eine Rechnung in eine Zahlung zu transformieren.

So erstellen Sie den Kanal:

  1. Auf der Seite Allgemeine Informationen im Feld Name geben Sie Channel for Invoice To Payment (Kanal für Auftrag an Zahlung) ein, und klicken Sie dann auf Weiter.

  2. Auf der Seite Quellorganisation im Bereich Organisation klicken Sie auf Durchsuchen.

    Das Dialogfeld Organisation auswählen wird angezeigt.

  3. Klicken Sie auf Bits,Bytes,Chips on Buyer, klicken Sie auf OK, und klicken Sie dann auf Weiter.

  4. Auf der Seite Eingehendes Dokument klicken Sie rechts vom Feld Definitionsname des eingehenden Dokuments auf Durchsuchen.

    Das Dialogfeld Dokumentdefinition auswählen wird angezeigt.

  5. Klicken Sie auf Invoice, klicken Sie auf OK und dann auf Weiter.

  6. Auf der Seite Ausgehendes Dokument klicken Sie rechts vom Feld Definitionsname des ausgehenden Dokuments auf Durchsuchen.

    Das Dialogfeld Dokumentdefinition auswählen wird angezeigt.

  7. Klicken Sie auf Payment und dann auf OK.

  8. Überprüfen Sie, ob das Kontrollkästchen Eingehendes Dokument ausgehendem Dokument zuordnen aktiviert ist.

  9. Klicken Sie rechts vom Feld Verweis zuordnen auf Durchsuchen.

    Das Dialogfeld Eine Zuordnung aus dem WebDAV-Repository auswählen wird angezeigt.

  10. Doppelklicken Sie auf den Ordner Microsoft.

  11. Klicken Sie auf InvoicetoPayment.xml, klicken Sie auf Öffnen und dann auf Weiter.

  12. Klicken Sie auf der Seite Dokumentprotokollierung auf Weiter.

  13. Klicken Sie auf der Seite Erweiterte Konfiguration auf Fertig stellen.

  14. Klicken Sie im Menü Datei auf Beenden, um den BizTalk-Messaging-Manager zu schließen.

Weiter mit Erstellen einer Dateiempfangsfunktion für das Käufersystem.


Erstellen einer Dateiempfangsfunktion für das Käufersystem

In diesem Verfahren erstellen Sie eine Dateiempfangsfunktion, die die Auftragsanfrage des Käufers aus einem lokalen Dateiverzeichnis empfängt und an die BizTalk-Messagingdienste versendet.

Die folgende Abbildung zeigt die Beziehungen zwischen der versendenden Geschäftsanwendung, dem Dateisystem und der Empfangsfunktion.

Geschäftsanwendung
sendet
Dateisystem
BizTalk-Server Dateiempfangsfunktion
BizTalk-
Server
Submit

So erstellen Sie die Dateiempfangsfunktion:

  1. Zeigen Sie im Startmenü auf Programme und dann auf Microsoft BizTalk Server 2000, und klicken Sie anschließend auf BizTalk Server-Verwaltung.

  2. Erweitern Sie Microsoft BizTalk Server 2000 und BizTalk Server-Gruppe, und klicken Sie dann auf Empfangsfunktionen.

  3. Zeigen Sie im Menü Vorgang auf Neu, und klicken Sie dann auf Dateiempfangsfunktion.

    Das Dialogfeld Dateiempfangsfunktion hinzufügen wird angezeigt.

  4. Im Feld Name geben Sie PORequest Receive Function at ProElectron (Auftragsanfrage-Empfangsfunktion von ProElectron) ein.

  5. Klicken Sie im Feld Server, auf dem die Empfangsfunktion ausgeführt werden soll auf den Namen eines Servers in der BizTalk-Servergruppe.

  6. Im Feld Abzurufende Dateitypen geben Sie *.xml ein.

  7. Im Feld Abrufspeicherort geben Sie C:\TutorialFiles\Buyer ein.

  8. Klicken Sie auf die Schaltfläche Erweitert.

    Das Dialogfeld Erweiterte Optionen für Empfangsfunktionen wird angezeigt.

  9. Klicken Sie in der Liste Kanalname auf Channel for POReq to PO, und klicken Sie dann auf OK.

  10. Klicken Sie auf OK, um das Dialogfeld Dateiempfangsfunktion hinzufügen zu schließen.

  11. Schließen Sie die BizTalk Server-Verwaltung.

Weiter mit Konfigurieren des Verkäufersystems.


Konfigurieren des Verkäufersystems

Verwenden Sie den BizTalk-Messaging-Manager, um Organisationen zu erstellen, die Ihre Handelspartner darstellen.

Weiter mit Erstellen der Organisationen für das Verkäufersystem.


Erstellen der Organisationen für das Verkäufersystem

  1. Zeigen Sie im Startmenü auf Programme und dann auf Microsoft BizTalk Server 2000, und klicken Sie anschließend auf BizTalk-Messaging-Manager.

  2. Wenn das Dialogfeld BizTalk-Messaging-Manager angezeigt wird, klicken Sie auf Abbrechen.

  3. Zeigen Sie im Menü Datei auf Neu, und klicken Sie dann auf Organisation.

    Das Dialogfeld Neue Organisation wird angezeigt.

  4. Auf der Registerkarte Allgemein im Feld Organisationsname geben Sie Bits,Bytes,Chips on Seller (Bits,Bytes,Chips an Verkäufer) ein, und klicken Sie dann auf OK.

  5. Wiederholen Sie die Schritte 3 und 4, benennen Sie die neue Organisation ProElectron on Seller (ProElectron an Verkäufer), und klicken Sie dann auf OK.

Weiter mit Erstellen eines Messagingports zu Bits, Bytes, & Chips für das Verkäufersystem.


Erstellen eines Messagingports zu Bits, Bytes, & Chips für das Verkäufersystem

In diesem Verfahren erstellen Sie einen Messagingport, der das Ziel für ein Dokument definiert. Dieser Messagingport versendet Dokumente innerhalb des Verkäufersystems mithilfe einer Anwendungsintegrationskomponente (Application Integration Component, AIC) als Transportdienst.

Eine Anwendungsintegrationskomponente dient normalerweise als Integrationspunkt zwischen BizTalk Server 2000 und einer Back-End-Anwendung. In diesem Szenario funktioniert die Anwendungsintegrationskomponente sowohl als Integrationspunkt als auch als hypothetische Back-End-Anwendung. Der Messagingport leitet den Auftrag an die Anwendungsintegrationskomponente weiter. Die Anwendungsintegrationskomponente transformiert den Auftrag in eine Rechnung und versendet diese an einen Kanal der BizTalk-Messagingdienste auf dem Verkäufersystem.

Der Auftrag könnte mithilfe einer Zuordnung im Kanal auch in eine Rechnung transformiert werden, aber der Einfachheit halber übernimmt die Anwendungsintegrationskomponente in diesem Szenario diese Funktion.

So erstellen Sie den Messagingport:

  1. Zeigen Sie im Menü Datei auf Neu, zeigen Sie auf Messagingport, und klicken Sie dann auf Zu einer Organisation.

    Der Messagingport-Assistent wird geöffnet.

  2. Im Feld Name geben Sie Port to Bits,Bytes,Chips via AIC (Port zu Bits,Bytes,Chips über AIC) ein, und klicken Sie dann auf Weiter.

  3. Auf der Seite Zielorganisationsname im Bereich Organisation klicken Sie auf Durchsuchen.

    Das Dialogfeld Organisation auswählen wird angezeigt.

  4. Klicken Sie auf Bits,Bytes,Chips on Seller und dann auf OK.

  5. Klicken Sie im Bereich Primärer Transport auf Durchsuchen.

    Das Dialogfeld Primärer Transport wird angezeigt.

  6. Überprüfen Sie, ob in der Liste Transporttyp die Option Anwendungsintegrationskomponente ausgewählt ist, und klicken Sie dann auf Durchsuchen.

    Das Dialogfeld Komponente auswählen wird angezeigt.

  7. Klicken Sie auf POToINVAIC ConvertPOToInvoice und dann auf OK.

  8. Klicken Sie auf OK, um das Dialogfeld Primärer Transport zu schließen, und klicken Sie dann auf Weiter.

  9. Klicken Sie auf der Seite Umschlagsinformationen auf Weiter.

  10. Überprüfen Sie auf der Seite Sicherheitsinformationen, ob das Kontrollkästchen Kanal für diesen Messagingport erstellen aktiviert ist.

  11. Klicken Sie in der Liste Kanaltyp auf Von einer Organisation, und klicken Sie dann auf Fertig stellen.

    Der Kanal-Assistent wird geöffnet.

Weiter mit Erstellen eines Kanals von ProElectron für das Verkäufersystem.


Erstellen eines Kanals von ProElectron für das Verkäufersystem

In diesem Verfahren erstellen Sie einen Kanal für den Messagingport.

Der Kanal, den Sie erstellen, hat als Quellorganisation ProElectron on Seller, die den Käufer auf dem Verkäufersystem darstellt. Dieser Kanal verarbeitet Aufträge, die von ProElectron empfangen werden. Da die eingehenden und ausgehenden Dokumentdefinitionen identisch sind, ist kein Zuordnungsverweis für diesen Kanal erforderlich, und es tritt keine Dokumenttransformation auf.

So erstellen Sie den Kanal:

  1. Auf der Seite Allgemeine Informationen im Feld Name geben Sie Channel for PO (Kanal für Auftrag) ein, und klicken Sie dann auf Weiter.

  2. Auf der Seite Quellorganisation im Bereich Organisation klicken Sie auf Durchsuchen.

    Das Dialogfeld Organisation auswählen wird angezeigt.

  3. Klicken Sie auf ProElectron on Seller, klicken Sie auf OK und dann auf Weiter.

  4. Auf der Seite Eingehendes Dokument klicken Sie rechts vom Feld Definitionsname des eingehenden Dokuments auf Durchsuchen.

    Das Dialogfeld Dokumentdefinition auswählen wird angezeigt.

  5. Klicken Sie auf Purchase Order und dann auf OK, und klicken Sie anschließend auf Weiter.

  6. Auf der Seite Ausgehendes Dokument klicken Sie rechts vom Feld Definitionsname des ausgehenden Dokuments auf Durchsuchen.

    Das Dialogfeld Dokumentdefinition auswählen wird angezeigt.

  7. Klicken Sie auf Purchase Order und dann auf OK, und klicken Sie anschließend auf Weiter.

  8. Klicken Sie auf der Seite Dokumentprotokollierung auf Weiter.

  9. Klicken Sie auf der Seite Erweiterte Konfiguration auf Fertig stellen.

Weiter mit Erstellen eines Messagingports zu ProElectron für das Verkäufersystem.


Erstellen eines Messagingports zu ProElectron für das Verkäufersystem

Die Zielorganisation, die Sie für den Messagingport erstellen, hat den Namen ProElectron on Seller und stellt den Käufer auf dem Verkäufersystem dar. Dieser Messagingport versendet Dokumente vom Verkäufersystem an das Käufersystem. Dieser Port verwendet den HTTP-Transportdienst, um Dokumente an die angegebene Käuferadresse zu übermitteln.

Wenn dieser Port verwendet wird, wird eine Rechnungsnachricht an eine ASP-Seite auf dem Käufersystem versendet, die dann die Rechnung an eine Nachrichtenwarteschlange auf dem Käufersystem weiterleitet.

So erstellen Sie den Messagingport:

  1. Zeigen Sie im Menü Datei auf Neu, zeigen Sie auf Messagingport, und klicken Sie dann auf Zu einer Organisation.

    Der Messagingport-Assistent wird geöffnet.

  2. Auf der Seite Allgemeine Informationen im Feld Name geben Sie Port to ProElectron via HTTP (Port zu ProElectron über HTTP) ein, und klicken Sie dann auf Weiter.

  3. Auf der Seite Zielorganisationsname im Bereich Organisation klicken Sie auf Durchsuchen.

    Das Dialogfeld Organisation auswählen wird angezeigt.

  4. Klicken Sie auf ProElectron on Seller, und klicken Sie dann auf OK.

  5. Klicken Sie im Bereich Primärer Transport auf Durchsuchen.

    Das Dialogfeld Primärer Transport wird angezeigt.

  6. In der Liste Transporttyp klicken Sie auf HTTP.

  7. Im Feld Adresse nach dem Präfix http:// geben Sie Name Ihres Computers ein, gefolgt von /InvoiceToQueue/DropInvoicetoMSMQ.asp, klicken Sie auf OK, und klicken Sie dann auf Weiter.

    Beispielsweise http://Computer1/InvoiceToQueue/DropInvoicetoMSMQ.asp

    Führen Sie folgende Schritte aus, um den Namen Ihres Computers zu finden:

    1. Zeigen Sie im Startmenü auf Einstellungen, und klicken Sie dann auf Systemsteuerung.

    2. Doppelklicken Sie auf Verwaltung.

    3. Doppelklicken Sie auf Computerverwaltung.

      Die Konsole der Computerverwaltung wird angezeigt.

    4. Klicken Sie im Menü Vorgang auf Eigenschaften.

      Das Dialogfeld Eigenschaften von Computerverwaltung (Lokal) wird angezeigt.

    5. Klicken Sie auf die Registerkarte Netzwerkidentifikation.

      Der Name Ihres Computers wird im Feld Computername angezeigt.

  8. Klicken Sie auf der Seite Umschlagsinformationen auf Weiter.

  9. Überprüfen Sie auf der Seite Sicherheitsinformationen, ob das Kontrollkästchen Kanal für diesen Messagingport erstellen aktiviert ist.

  10. Klicken Sie in der Liste Kanaltyp auf Von einer Organisation, und klicken Sie dann auf Fertig stellen.

    Der Kanal-Assistent wird geöffnet.

Weiter mit Erstellen eines Kanals von Bits, Bytes, & Chips für das Verkäufersystem.


Erstellen eines Kanals von Bits, Bytes, & Chips für das Verkäufersystem

Der Kanal, den Sie in diesem Verfahren erstellen, hat als seine Quellorganisation Bits,Bytes,Chips on Seller. Dieser Kanal verarbeitet Rechnungen, die gemäß den Regeln des Messagingports, Port to ProElectron via HTTP, an ProElectron auf dem Verkäufersystem versendet werden.

So erstellen Sie den Kanal:

  1. Auf der Seite Allgemeine Informationen im Feld Name geben Sie Channel for Invoice ein, und klicken Sie dann auf Weiter.

  2. Auf der Seite Quellorganisation im Bereich Organisation klicken Sie auf Durchsuchen.

    Das Dialogfeld Organisation auswählen wird angezeigt.

  3. Klicken Sie auf Bits,Bytes,Chips on Seller und dann auf OK, und klicken Sie anschließend auf Weiter.

  4. Auf der Seite Eingehendes Dokument klicken Sie rechts vom Feld Definitionsname des eingehenden Dokuments auf Durchsuchen.

    Das Dialogfeld Dokumentdefinition auswählen wird angezeigt.

  5. Klicken Sie auf Invoice und dann auf OK, und klicken Sie anschließend auf Weiter.

  6. Auf der Seite Ausgehendes Dokument klicken Sie auf Durchsuchen.

    Das Dialogfeld Dokumentdefinition auswählen wird angezeigt.

  7. Klicken Sie auf Invoice und dann auf OK, und klicken Sie anschließend auf Weiter.

  8. Klicken Sie auf der Seite Dokumentprotokollierung auf Weiter.

  9. Klicken Sie auf der Seite Erweiterte Konfiguration auf Fertig stellen.

  10. Klicken Sie im Menü Datei auf Beenden, um den BizTalk-Messaging-Manager zu schließen.

Weiter mit Zusammenfassung von Unterrichtseinheit 3.


Zusammenfassung von Unterrichtseinheit3

BizTalk Server-Kopfzeile

Zusammenfassung von Unterrichtseinheit 3

In dieser Unterrichtseinheit haben Sie Folgendes durchgeführt:

  • Dokumentdefinitionen erstellt. Weitere Informationen finden Sie unter Erstellen und Verwalten von Dokumentdefinitionen.

  • Organisationen erstellt. Weitere Informationen finden Sie unter Erstellen und Verwalten von Organisationen.

  • Messagingports erstellt. Weitere Informationen finden Sie unter Erstellen und Verwalten von Messagingports.

  • Kanäle erstellt. Weitere Informationen finden Sie unter Erstellen und Verwalten von Kanälen.

  • Eine Zuordnung in einem Kanal verwendet, um ein Dokument zu transformieren. Weitere Informationen finden Sie unter Zuordnen von Daten.

  • Eine Dateiempfangsfunktion erstellt. Weitere Informationen finden Sie unter Empfangsfunktionen.

Verwenden Sie die Schaltfläche Jetzt suchen des BizTalk-Messaging-Managers, um die Dokumentdefinitionen, Organisationen, Messagingports, Kanäle und die Zuordnung anzuzeigen, die Sie in dieser Unterrichtseinheit erstellt haben.

Der markierte Bereich der folgenden Abbildung zeigt, welche Schritte Sie in dieser Unterrichtseinheit ausgeführt haben.

Send
Payment
Receive Invoice
Entscheidung
PO Req
>$1000
Ende
Receive
PO Req
XLANG-Ablaufplan
Dateiempfangsfunktion
Käuferdateiverzeichnis
WSC-Komponente
ASP-Datei
Nachrichten-
warteschlange
Ja (Ablehnung)
Nein
(Genehmigung)
Skriptkomponente
Messagingport
Messagingport
Channel for Invoice
Channel for PO
Kanal
Port to ProElectron
via HTTP
Port to Bits, Bytes,
& Chips via AIC
Port to Bits, Bytes, & Chips via Local File
POtoINVAIC
SubmitProElectronPO
Port to Bits, Bytes,
& Chips via HTTP
Channel for
Invoice to Payment
Channel for
POReq to PO
Kanal
BizTalk Messaging
Message Queuing
Aktion
Port
Daten
Daten
ExecuteTutorial
PO Request Receive Function at ProElectron
DropInvoicetoMSMQ
ReceiveInvoice
PORequestApproval
ReceivePOReq
Message Queuing
Nachrichten-
warteschlange
Anwendung
PO Req
PO Req
Start
Käufersystem
BizTalk-Messagingdienste
Stopp
AIC
PO to Invoice
Verkäuferdatei-
verzeichnis
Zahlung
Verkäufer
Käufer
Zahlung
Rechnung
Anmerkung: Pfeile kennzeichnen den Datenfluss.
Rechnung
Rechnung
Zuordnung
Zuordnung
PO
PO
PO
PO
ASP-Datei
BizTalk-Orchestrierung
BizTalk Orchestration

Weiter mit Unterrichtseinheit 4: Fertigstellen des XLANG-Ablaufplanes.

Verwandtes Thema

Verwenden des BizTalk-Messaging-Managers


Unterrichtseinheit4: Fertigstellen des XLANG-Ablaufplanes

BizTalk Server-Kopfzeile

Unterrichtseinheit 4: Fertigstellen des XLANG-Ablaufplanes

In dieser Unterrichtseinheit verwenden Sie den BizTalk-Orchestrierungs-Designer, um einen Port mithilfe der BizTalk-Messagingdienste zu implementieren. Anschließend kompilieren Sie den fertig gestellten XLANG-Ablaufplan und führen ihn aus.

Lernziele

  • Hinzufügen von Rechnungs- und Zahlungsaktionen. Weitere Informationen finden Sie unter Hinzufügen von Formen.

  • Implementieren eines Ports mithilfe der BizTalk-Messagingdienste. Weitere Informationen finden Sie unter Verwenden der BizTalk-Messaging-Form.

  • Kompilieren und Ausführen des fertig gestellten XLANG-Ablaufplanes. Weitere Informationen finden Sie unter Kompilieren von XLANG-Ablaufplänen und Ausführen von XLANG-Ablaufplänen.

Zum Fertigstellen des XLANG-Ablaufplanes fahren Sie mit Hinzufügen von Rechnungs- und Zahlungsaktionen fort.

Verknüpfung

Zum Verwenden des vorhandenen XLANG-Ablaufplanes fahren Sie mit Ausführen des fertig gestellten XLANG-Ablaufplanes fort.

Verwandtes Thema

Entwerfen von BizTalk-Orchestrierungen


Hinzufügen von Rechnungs- und Zahlungsaktionen

In diesem Verfahren fügen Sie eine Aktion hinzu, die die Rechnung vom Käufer empfängt, sowie eine weitere Aktion, die die Zahlungsnachricht an den Verkäufer versendet.

So erstellen Sie Aktionen:

  1. Zeigen Sie im Startmenü auf Programme und dann auf Microsoft BizTalk Server 2000, und klicken Sie anschließend auf BizTalk-Orchestrierungs-Designer.

  2. Klicken Sie im Menü Datei auf Öffnen.

    Das Dialogfeld XLANG-Ablaufplanzeichnung öffnen wird angezeigt.

  3. Wenn Sie die vorhandene Datei Buyer1.skv verwenden, wechseln Sie im Dialogfeld XLANG-Ablaufplanzeichnung öffnen in das Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\Schedule\Solution auf dem BizTalk Server-Installationslaufwerk, klicken Sie auf Buyer1.skv und dann auf Öffnen.

    Wenn Sie die Datei Buyer1.skv in Unterrichtseinheit 1 erstellt haben, wechseln Sie in das Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\Schedule\Lab auf dem BizTalk Server-Installationslaufwerk, klicken Sie auf Buyer1.skv und dann auf Öffnen.

    Anmerkung

    Im BizTalk-Orchestrierungs-Designer befindet sich nun eine leere Zeichnung, die Sie schließen können.

  4. Markieren Sie die Verbindung zwischen den Aktionen Write PO Request to File und Ende, und drücken Sie dann die ENTF-TASTE.

  5. Verschieben Sie die Ende-Aktion nach unten, um Platz für zwei neue Aktionsformen zu schaffen.

  6. Auf der Geschäftsprozessseite ziehen Sie die Aktion-Form aus der Flussdiagrammschablone links neben die Trennlinie. Positionieren Sie die Form direkt unterhalb der Write PO Request to File-Aktion.

  7. Klicken Sie mit der rechten Maustaste auf die Aktion-Form, und wählen Sie dann Eigenschaften.

    Das Dialogfeld Aktionseigenschaften wird angezeigt.

  8. Im Feld Name geben Sie Receive Invoice (Rechnung erhalten) ein, und klicken Sie dann auf OK.

  9. Auf der Geschäftsprozessseite ziehen Sie die Aktion-Form aus der Flussdiagrammschablone links neben die Trennlinie. Positionieren Sie die Form direkt unterhalb der Receive Invoice-Aktion.

  10. Klicken Sie mit der rechten Maustaste auf die Aktion-Form, und wählen Sie dann Eigenschaften.

    Das Dialogfeld Aktionseigenschaften wird angezeigt.

  11. Im Feld Name geben Sie Send Payment (Zahlung senden) ein, und klicken Sie dann auf OK.

  12. Verbinden Sie die Write PO Request to File-Aktion mit der Receive Invoice-Aktion.

  13. Verbinden Sie die Receive Invoice-Aktion mit der Send Payment-Aktion.

  14. Verbinden Sie die Send Payment-Aktion mit der Ende-Form.

Weiter mit Binden des Message Queuing-Dienstes an das Empfangen einer Rechnung.


Binden des Message Queuing-Dienstes an das Empfangen einer Rechnung

Die Receive Invoice-Aktion ist an einen Message Queuing-Dienst gebunden. Wenn eine Rechnung an die Nachrichtenwarteschlange für Rechnungen übergeben wird, die durch den Dienst definiert wird, aktiviert sie die Receive Invoice-Aktion.

So binden Sie den Message Queuing-Dienst:

  1. Auf der Geschäftsprozessseite ziehen Sie die Message Queuing-Form aus der Implementierungsschablone rechts neben die Trennlinie, die die beiden Seiten der Zeichnung voneinander trennt. Positionieren Sie die Message Queuing-Form so, dass sie sich horizontal auf einer Linie mit der Receive Invoice-Aktion befindet.

    Der Bindungs-Assistent für Message Queuing wird geöffnet.

  2. Überprüfen Sie, ob auf der Seite Willkommen beim Bindungs-Assistenten für Message Queuing die Option Neuen Port erstellen ausgewählt ist.

  3. Im Feld Neuen Port erstellen geben Sie ReceiveInvoice ein, und klicken Sie dann auf Weiter.

  4. Überprüfen Sie auf der Seite Informationen über statische oder dynamische Warteschlangen, ob Statische Warteschlange ausgewählt ist, und klicken Sie dann auf Weiter.

  5. Auf der Seite Warteschlangeninformationen klicken Sie auf Bekannte Warteschlange für alle Instanzen verwenden.

  6. Im Feld Geben Sie den Namen der Warteschlange ein geben Sie .\private$\ReceiveInvoice ein, und klicken Sie dann auf Weiter.

  7. Auf der Seite Erweiterte Porteigenschaften klicken Sie auf Fertig stellen.

Weiter mit Definieren von Nachrichteneigenschaften für den Rechnungsempfangsdienst.


Definieren von Nachrichteneigenschaften für den Rechnungsempfangsdienst

  1. Markieren Sie die Receive Invoice-Aktion, und ziehen Sie das Kontrollhandle rechts neben der Receive Invoice-Aktion auf den ReceiveInvoice-Port.

    Der Assistent für XML-Kommunikation wird geöffnet.

  2. Auf der Seite Willkommen beim Assistenten für XML-Kommunikation klicken Sie auf Empfangen und dann auf Weiter.

  3. Überprüfen Sie auf der Seite Nachrichteninformationen, ob Neue Nachricht erstellen ausgewählt ist.

  4. Im Feld Nachrichtenname geben Sie CommonInvoice ein, und klicken Sie dann auf Weiter.

  5. Überprüfen Sie auf der Seite Informationen über die XML-Konvertierung, ob Nachrichten in der Warteschlange als XML-Nachrichten empfangen ausgewählt ist, und klicken Sie dann auf Weiter.

  6. Auf der Seite Informationen über den Nachrichtentyp im Feld Nachrichtentyp geben Sie CommonInvoice ein, und klicken Sie dann auf Weiter.

  7. Klicken Sie auf der Seite Informationen über die Nachrichtenspezifikation auf Fertig stellen.

Weiter mit Binden der BizTalk-Messagingdienste.


Binden der BizTalk-Messagingdienste

In diesem Verfahren binden Sie einen BizTalk-Messagingdienst an die XLANG-Ablaufplanzeichnung und benennen den verwendeten Kanal.

So binden Sie die BizTalk-Messagingdienste:

  1. Auf der Geschäftsprozessseite ziehen Sie die BizTalk Messaging-Form aus der Implementierungsschablone rechts neben die Trennlinie, die die beiden Seiten der Zeichnung voneinander trennt. Positionieren Sie die BizTalk Messaging-Form so, dass sie sich horizontal auf einer Linie mit der Send Payment-Aktion befindet.

    Der BizTalk-Bindungs-Assistent für Messaging wird geöffnet.

  2. Überprüfen Sie auf der Seite Willkommen beim BizTalk-Bindungs-Assistenten für Messaging, ob Neuen Port erstellen ausgewählt ist.

  3. Im Feld Neuen Port erstellen geben Sie SendPayment ein, und klicken Sie dann auf Weiter.

  4. Überprüfen Sie auf der Seite Kommunikationsrichtung, ob Senden ausgewählt ist, und klicken Sie dann auf Weiter.

  5. Überprüfen Sie auf der Seite Informationen über statische oder dynamische Kanäle, ob Statischer Kanal ausgewählt ist.

  6. Im Feld Geben Sie den Namen eines bekannten, vorgegebenen Kanals ein geben Sie Channel for Invoice To Payment ein, und klicken Sie dann auf Fertig stellen.

    Beachten Sie, dass Channel for Invoice To Payment in Unterrichtseinheit 3 erstellt wurde.

Weiter mit Definieren von Nachrichteneigenschaften für die BizTalk-Messagingdienste.


Definieren von Nachrichteneigenschaften für die BizTalk-Messagingdienste

  1. Ziehen Sie das Kontrollhandle rechts neben der Send Payment-Aktion zum SendPayment-Port.

    Der Assistent für XML-Kommunikation wird geöffnet.

  2. Auf der Seite Willkommen beim Assistenten für XML-Kommunikation klicken Sie auf Weiter.

  3. Auf der Seite Nachrichteninformationen klicken Sie auf Verweis zu einer vorhandenen Nachricht hinzufügen, klicken Sie auf CommonInvoice und dann auf Weiter.

  4. Überprüfen Sie auf der Seite Informationen über die XML-Konvertierung, ob Nachrichten im XML-Format an die Warteschlange senden ausgewählt ist, und klicken Sie dann auf Weiter.

  5. Klicken Sie auf der Seite Informationen über den Nachrichtentyp auf Weiter.

  6. Klicken Sie auf der Seite Informationen über die Nachrichtenspezifikation auf Fertig stellen.

Weiter mit Speichern der fertig gestellten XLANG-Ablaufplanzeichnung.


Speichern der fertig gestellten XLANG-Ablaufplanzeichnung

  1. Klicken Sie im Menü Datei auf Speichern unter.

    Das Dialogfeld XLANG-Ablaufplanzeichnung speichern unter wird angezeigt.

  2. Wechseln Sie in das Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\Schedule\Lab.

  3. Im Feld Dateiname geben Sie Buyer2 ein, und klicken Sie dann auf Speichern.

Weiter mit Kompilieren des fertig gestellten XLANG-Ablaufplanes.


Kompilieren des fertig gestellten XLANG-Ablaufplanes

  1. Klicken Sie im Menü Datei auf XLANG Buyer2.skx erstellen.

    Das Dialogfeld XLANG-Ablaufplan speichern unter wird angezeigt.

  2. Wechseln Sie in das Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\Schedule\Lab auf dem BizTalk Server-Installationslaufwerk.

  3. Im Feld Dateiname geben Sie Buyer2 ein, und klicken Sie dann auf Speichern.

Die fertig gestellte XLANG-Ablaufplanzeichnung sollte so wie in der folgenden Darstellung aussehen.

Klicken Sie zum Vergrößern oder Verkleinern auf die Abbildung.

  4. Klicken Sie im Menü Datei auf Beenden.

Weiter mit Ausführen des fertig gestellten XLANG-Ablaufplanes.


Ausführen des fertig gestellten XLANG-Ablaufplanes

Sie haben die Konfiguration einer automatisierten Beschaffungslösung auf Business-to-Business-Ebene abgeschlossen. Sie können nun die Anwendung ausführen, die den XLANG-Ablaufplan aktiviert.

In diesem Verfahren verwenden Sie eine Anwendung, die den XLANG-Ablaufplan aktiviert und eine Auftragsanfrage an die vom Ablaufplan überwachte Nachrichtenwarteschlange übermittelt.

So führen Sie den XLANG-Ablaufplan aus:

  1. Wechseln Sie in das Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\Schedule\Solution auf dem BizTalk Server-Installationslaufwerk.

  2. Doppelklicken Sie auf ExecuteTutorial.exe. Diese Anwendung wird verwendet, um den XLANG-Ablaufplan mithilfe eines Monikers zu aktivieren.

    Die Anwendung ExecuteTutorial wird geöffnet.

  3. Klicken Sie auf Browse for Schedule.

Verknüpfung

Wenn Sie den vorhandenen XLANG-Ablaufplan verwenden, wechseln Sie in das Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\Schedule\Solution, und fahren Sie mit Schritt 5 fort.

  4. Wenn Sie den Buyer-Ablaufplan erstellt haben, wechseln Sie in das Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\Schedule\Lab auf dem BizTalk Server-Installationslaufwerk.

  5. Klicken Sie auf den Buyer2.skx-Ablaufplan und dann auf Öffnen.

  6. Klicken Sie auf Browse for Data File, und wechseln Sie in das Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\Schedule\SampleData auf dem BizTalk Server-Installationslaufwerk.

  7. Klicken Sie auf POReqAccept.xml und dann auf Öffnen.

  8. Klicken Sie auf Start XLANG Schedule.

    Da der Gesamtumfang der Auftragsanfrage unter $1000 liegt, wird sie genehmigt. Ein Feld wird mit der Meldung angezeigt, dass die Anwendung Daten an das XLANG-Ablaufplanungsmodul weitergeleitet hat. An dieser Stelle wird die Anwendung beendet. Ein zweites Meldungsfeld informiert Sie darüber, dass die Auftragsanfrage genehmigt wurde. Klicken Sie auf OK, um die Dialogfelder zu schließen.

  9. Klicken Sie auf End, um die Anwendung ExecuteTutorial zu schließen.

  10. Wechseln Sie in das Verzeichnis C:\TutorialFiles\Seller.

    Dort befindet sich die Zahlungsdatei. Der Dateiname ist PaymentXXXX.xml, wobei XXXX einen eindeutigen Zahlensatz darstellt. Doppelklicken Sie auf die Datei, um Sie in Microsoft Internet Explorer zu öffnen.

Sie haben eine Auftragsanfrage versendet. Die Auftragsanfrage wurde genehmigt und abschließend wurde eine Zahlungsnachricht an das Verkäufersystem gesendet.

Weiter mit Zusammenfassung von Unterrichtseinheit 4.


Zusammenfassung von Unterrichtseinheit4

BizTalk Server-Kopfzeile

Zusammenfassung von Unterrichtseinheit 4

In dieser Unterrichtseinheit haben Sie Folgendes durchgeführt:

  • Rechnungs- und Zahlungsaktionen hinzugefügt. Weitere Informationen finden Sie unter Verbinden von Formen.

  • Einen Messagingport mithilfe der BizTalk-Messagingdienste implementiert. Weitere Informationen zum Implementieren eines Messagingports mithilfe der BizTalk-Messagingdienste finden Sie unter Verwenden der BizTalk-Messaging-Form.

  • Den fertig gestellten XLANG-Ablaufplan kompiliert und ausgeführt. Weitere Informationen finden Sie unter Kompilieren von XLANG-Ablaufplänen und Ausführen von XLANG-Ablaufplänen.

Der markierte Bereich der folgenden Abbildung zeigt, welche Schritte Sie in dieser Unterrichtseinheit ausgeführt haben.

Send
Payment
Receive Invoice
Entscheidung
PO Req
>$1000
Ende
Receive
PO Req
XLANG-Ablaufplan
Dateiempfangsfunktion
Käuferdateiverzeichnis
WSC-Komponente
ASP-Datei
Nachrichten-
warteschlange
Ja (Ablehnung)
Nein
(Genehmigung)
Skriptkomponente
Messagingport
Messagingport
Channel for Invoice
Channel for PO
Kanal
Port to ProElectron
via HTTP
Port to Bits, Bytes,
& Chips via AIC
Port to Bits, Bytes, & Chips via Local File
POtoINVAIC
SubmitProElectronPO
Port to Bits, Bytes,
& Chips via HTTP
Channel for
Invoice to Payment
Channel for
POReq to PO
Kanal
BizTalk Messaging
Message Queuing
Aktion
Port
Daten
Daten
ExecuteTutorial
PO Request Receive Function at ProElectron
DropInvoicetoMSMQ
ReceiveInvoice
PORequestApproval
ReceivePOReq
Message Queuing
Nachrichten-
warteschlange
Anwendung
PO Req
PO Req
Start
Käufersystem
BizTalk-Messagingdienste
Stopp
AIC
PO to Invoice
Verkäuferdatei-
verzeichnis
Zahlung
Verkäufer
Käufer
Zahlung
Rechnung
Anmerkung: Pfeile kennzeichnen den Datenfluss.
Rechnung
Rechnung
Zuordnung
Zuordnung
PO
PO
PO
PO
ASP-Datei
Verkäufersystem
BizTalk-Orchestrierung

Weiter mit Zusammenfassung des Lernprogramms.

Verwandtes Thema

Entwerfen von BizTalk-Orchestrierungen


Zusammenfassung des Lernprogramms

In diesem Lernprogramm haben Sie Microsoft BizTalk Server 2000 für die Einrichtung und Ausführung eines automatisierten Beschaffungsprozesses auf Business-to-Business-Ebene konfiguriert.

Die folgende Abbildung zeigt den Datenfluss durch BizTalk Server beim Ausführen des XLANG-Ablaufplanes Buyer2 am Ende von Unterrichtseinheit 4.

Send
Payment
Receive Invoice
Entscheidung
PO Request
>$1000
Ende
Receive
PO Request
XLANG-Ablaufplan
Dateiempfangsfunktion
Käuferdateiverzeichnis
WSC-Komponente
ASP-Datei
Nachrichten-
warteschlange
Ja (Ablehnung)
Nein
(Genehmigung)
Skriptkomponente
Messagingport
Messagingport
Channel for Invoice
Channel for PO
Kanal
Port to ProElectron
via HTTP
Port to Bits, Bytes,
& Chips via AIC
Port to Bits, Bytes, & Chips via Local File
POtoINVAIC
SubmitProElectronPO
Port to Bits, Bytes,
& Chips via HTTP
Channel for
Invoice to Payment
Channel for
POReq to PO
Kanal
BizTalk-Messaging
Message Queuing
Aktion
Port
Daten
Daten
ExecuteTutorial
PORequest Receive Function at ProElectron
DropInvoicetoMSMQ
ReceiveInvoice
PORequestApproval
ReceivePOReq
Message Queuing
Nachrichten-
warteschlange
Anwendung
PO Req
PO Req
Start
Käufersystem
BizTalk-Messagingdienste
Stopp
AIC
PO to Invoice
Verkäuferdatei-
verzeichnis
Zahlung
Verkäufer
Käufer
Zahlung
Rechnung
Anmerkung: Pfeile kennzeichnen den Datenfluss.
Rechnung
Rechnung
Zuordnung
Zuordnung
PO
PO
PO
PO
ASP-Datei
Verkäufersystem
BizTalk-Orchestrierung

Sie haben erfahren, wie BizTalk Server-Komponenten und -Dienste zusammenarbeiten, um flexibel verbundene zeitintensive Geschäftsprozesse sowohl firmenintern als auch firmenübergreifend zu integrieren.

Darüber hinaus haben Sie Folgendes gelernt:

  • Mithilfe des BizTalk-Orchestrierungs-Designers Geschäftsprozesse zu gestalten, indem Sie eine XLANG-Ablaufplanzeichnung erstellen.

  • Mithilfe des BizTalk-Messaging-Managers Organisationen, Kanäle, Messagingports und Dokumentdefinitionen zu erstellen.

  • Mithilfe des BizTalk-Editors Spezifikationen zu erstellen.

  • Mithilfe des BizTalk-Mappers Zuordnungen zu erstellen.

  • Einen XLANG-Ablaufplan zu kompilieren und auszuführen.

Sie haben das Lernprogramm erfolgreich absolviert. Weitere Informationen zum Erstellen von in diesem Lernprogramm verwendeten Hilfskomponenten finden Sie unter Anhang: Erstellen von Hilfskomponenten.


Anhang: Erstellen von Hilfskomponenten

In diesem Anhang wird die Erstellung von Hilfskomponenten erläutert, die bei der Verarbeitung von Daten mit Microsoft BizTalk Server 2000 zusammenarbeiten. Jede Komponente, ihre Rolle und ihre Beziehungen im Prozess werden detailliert beschrieben.

Im Einzelnen erstellen Sie:

  • Eine Anwendung auf dem Käufersystem, die einen XLANG-Ablaufplan aktiviert und eine Auftragsanfrage an eine Nachrichtenwarteschlange versendet, die an den XLANG-Ablaufplan gebunden ist, der den Nachrichtenstrom durch das Käufersystem steuert.

  • Eine Windows-Skriptkomponente auf dem Käufersystem, die den Genehmigungs- oder Ablehnungsstatus für eine Auftragsanfrage aus dem XLANG-Ablaufplan annimmt. Bei einer Genehmigung zeigt die Windows-Skriptkomponente eine Genehmigungsmeldung an und schreibt die Auftragsanfrage in ein lokales Dateiverzeichnis, in dem die BizTalk-Messagingdienste sie für das Käufersystem empfangen. Bei einer Ablehnung zeigt die Windows-Skriptkomponente eine Ablehnungsmeldung an, und der Ablaufplan endet.

  • Eine Anwendungsintegrationskomponente (Application Integration Component, AIC) auf dem Verkäufersystem, die auf der Basis der Auftragsdaten des Käufers eine Rechnung generiert.

  • Eine ASP-Datei auf dem Käufersystem, die einen Auftrag an BizTalk Server versendet.

  • Eine ASP-Datei auf dem Verkäufersystem, die eine Rechnung an eine Nachrichtenwarteschlange übermittelt.

Weiter mit Erstellen der Anwendung.


Erstellen der Anwendung

In diesem Abschnitt erstellen Sie eine Anwendung, die einen XLANG-Ablaufplan aktiviert und dann eine Auftragsanfrage an eine Warteschlange übermittelt. Sie verwenden diese Anwendung, um die Implementierung des XLANG-Ablaufplanes und die Konfiguration des BizTalk-Messaging-Managers zu testen.

Zum Abschluss dieser Übungseinheit ändern Sie den Code im Beispielprojekt. Sie konzentrieren sich dabei auf den Code, der für das Aktivieren des XLANG-Ablaufplanes und das Übermitteln einer Nachricht an eine Warteschlange zuständig ist. Der Hilfscode wird bereitgestellt.

Jeder Schritt entspricht einem Codesegment. Achten Sie auf Kommentarblöcke wie im folgenden Beispiel:

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'To Do:''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'To Do: Step A
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

Nach diesem Code folgen Zeilen mit Fragezeichen (?), die als Platzhalter überall dort stehen, wo Sie Änderungen vornehmen müssen. Zum Abschluss der Übungseinheit ersetzen Sie die Fragezeichen mit dem richtigen Code. Beispiel:

Private g_MSMTxDisp As ?Private g_MSMTxDisp As ?

sollte wie folgt geändert werden:

Private g_MSMTxDisp As MSMQ.MSMQTransactionDispenserPrivate g_MSMTxDisp As MSMQ.MSMQTransactionDispenser

Anmerkung

  • Diese Codezeilen wurden kommentiert. Entfernen Sie auf jeden Fall die Kommentarzeichen am Anfang der Zeilen, in denen Sie Änderungen vornehmen. Die Schritte im Codefenster sind nicht zwangsläufig in der richtigen Reihenfolge.

Weiter mit Öffnen der Anwendung.


Öffnen der Anwendung

Wechseln Sie in das Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\Schedule\Lab auf dem BizTalk Server-Installationslaufwerk.

Doppelklicken Sie auf ExecuteTutorial.vbp.

Weiter mit Hinzufügen der erforderlichen Verweise zur Anwendung.


Hinzufügen der erforderlichen Verweise zur Anwendung

In diesem Verfahren können eine Reihe von DLLs (Dynamic Link Libraries), die für die Verwendung von Message Queuing, XML und Scripting Runtime erforderlich sind, durch die Anwendung implementiert werden.

  1. Im Menü Projekt klicken Sie auf Verweise.

  2. Wählen Sie Microsoft Message Queue 2.0 Object Library aus.

    Der vollständige Pfad für diese Typbibliothek lautet \WINNT\System32\MQOA.dll.l.

  3. Wählen Sie Microsoft Scripting Runtime aus.

    Der vollständige Pfad für diese DLL lautet \WINNT\System32\Scrun.dll.

  4. Wählen Sie Microsoft XML, v 3.0 aus.

    Der vollständige Pfad für diese DLL lautet \WINNT\System32\msxml3.dll.

  5. Klicken Sie auf OK.

Weiter mit Definieren und Initialisieren der Message Queue-Objekte.


Definieren und Initialisieren der MessageQueue-Objekte

BizTalk Server-Kopfzeile

Definieren und Initialisieren der Message Queue-Objekte

In diesem Verfahren fügen Sie den Code für die Verwendung der ausgewählten Typbibliotheken hinzu. Die nummerierten Schritte in der folgenden Liste entsprechen den nummerierten Schritten im bereitgestellten Code.

  1. Im Projektfenster erweitern Sie Formulare, und klicken Sie dann auf Form1 (ExecuteTutorial.frm).

  2. Klicken Sie im Menü Ansicht auf Code.

  3. Im Abschnitt General Declarations bei Schritt A des Codes erstellen Sie Nachrichtenwarteschlangen-Objekte wie im folgenden Beispiel:
    Private g_MSMTxDisp As MSMQ.MSMQTransactionDispenserPrivate g_MSMTxDisp As MSMQ.MSMQTransactionDispenser
Private g_MSMQQueue As MSMQ.MSMQQueuePrivate g_MSMQQueue As MSMQ.MSMQQueue
Private g_MSMQInfo As MSMQ.MSMQQueueInfoPrivate g_MSMQInfo As MSMQ.MSMQQueueInfo
  4. Im Ereignisabschnitt Form_Load unter Schritt B des Codes initialisieren Sie die Message Queue-Objekte wie im folgenden Beispiel.
    Set g_MSMQInfo = CreateObject("MSMQ.MSMQQueueInfo")Set g_MSMQInfo = CreateObject("MSMQ.MSMQQueueInfo")
Set g_MSMTxDisp = CreateObject("MSMQ.MSMQTransactionDispenser")Set g_MSMTxDisp = CreateObject("MSMQ.MSMQTransactionDispenser")

Weiter mit Hinzufügen von Code für die Platzierung von Daten in eine Warteschlange.


Hinzufügen von Code für die Platzierung von Daten in eine Warteschlange

In diesem Verfahren fügen Sie eine neue Subroutine mit dem Namen ExecuteMSMQ hinzu. Diese Routine wird vom cmdRunSked_Click-Ereignis aufgerufen. Sie fügen den Code hinzu, um diese Subroutine im folgenden Verfahren aufzurufen.

  • Platzieren Sie bei Schritt C den folgenden Code an das Ende des Codefensters im Projekt:
    Public Sub ExecuteMSMQ(ByVal strQueuePath As String, DataToQueue As String)Public Sub ExecuteMSMQ(ByVal strQueuePath As String, DataToQueue As String)
    Dim QueueMsg As New MSMQMessageDim QueueMsg As New MSMQMessage

    Dim strData As StringDim strData As String
    Dim fSend As BooleanDim fSend As Boolean
    Dim txt As TextStreamDim txt As TextStream
    Dim mybyte() As ByteDim mybyte() As Byte

    g_MSMQInfo.FormatName = strQueuePathg_MSMQInfo.FormatName = strQueuePath
    Set g_MSMQQueue = g_MSMQInfo.Open(MQ_SEND_ACCESS, MQ_DENY_NONE)Set g_MSMQQueue = g_MSMQInfo.Open(MQ_SEND_ACCESS, MQ_DENY_NONE)
    mybyte = StrConv(DataToQueue, vbFromUnicode)mybyte = StrConv(DataToQueue, vbFromUnicode)
    QueueMsg.Body = DataToQueueQueueMsg.Body = DataToQueue

    Set MSMQTx = g_MSMTxDisp.BeginTransactionSet MSMQTx = g_MSMTxDisp.BeginTransaction
    QueueMsg.send g_MSMQQueue, MSMQTxQueueMsg.send g_MSMQQueue, MSMQTx
    MSMQTx.CommitMSMQTx.Commit

    Set QueueMsg = NothingSet QueueMsg = Nothing
    Set MSMQTx = NothingSet MSMQTx = Nothing

End SubEnd Sub

Weiter mit Hinzufügen von Code für die Aktivierung des XLANG-Ablaufplanes und für den Aufruf von "ExecuteMSMQ".


Hinzufügen von Code für die Aktivierung des XLANG-Ablaufplanes und für den Aufruf von "ExecuteMSMQ"

In diesem Verfahren werden Sie Code zum cmdRunSked_Click-Ereignis hinzufügen, das den XLANG-Ablaufplan aktiviert und den Code aufruft, der eine Nachricht an eine Warteschlange sendet.

  1. Im cmdRunSked_Click-Ereignisabschnitt bei Schritt D des Codes rufen Sie ExecuteMSMQ auf, wie im folgenden Code gezeigt:
    ExecuteMSMQ "DIRECT=OS:.\private$\ReceivePoReq", objfs.OpenTextFile(txtData.Text, ForReading).ReadAllExecuteMSMQ "DIRECT=OS:.\private$\ReceivePoReq", objfs.OpenTextFile(txtData.Text, ForReading).ReadAll
  2. Im cmdRunSked_Click-Ereignisabschnitt bei Schritt E des Codes rufen Sie GetObject auf, um den XLANG-Ablaufplan durch einen Moniker zu instanziieren, wie im folgenden Code gezeigt:
    Set SendPAQ = GetObject(txtSked.Text)Set SendPAQ = GetObject(txtSked.Text)

Weiter mit Speichern und Kompilieren der Anwendung.


Speichern und Kompilieren der Anwendung

In diesem Verfahren speichern und kompilieren Sie die Anwendung.

  1. Klicken Sie im Menü Datei auf Projekt speichern.

  2. Klicken Sie im Menü Datei auf ExecuteTutorial.exe erstellen.

  3. Wechseln Sie im Dialogfeld Projekt erstellen in den Ordner \Programme\Microsoft BizTalk Server\Tutorial\Schedule\Lab im BizTalk Server-Installationsverzeichnis, und klicken Sie dann auf OK.

Sie können die Anwendung jetzt starten, um den Käuferablaufplan in den Unterrichtseinheiten 1 und 4 auszuführen.

Weiter mit Erstellen der Windows-Skriptkomponente.


Erstellen der Windows-Skriptkomponente

In diesem Abschnitt erstellen Sie eine Windows-Skriptkomponente, die an den XLANG-Ablaufplan gebunden ist. Der Zweck der Windows-Skriptkomponente ist die Anzeige eines Meldungsfeldes mit Genehmigungs- oder Ablehnungsstatus hinsichtlich der Auftragsanfrage sowie gegebenenfalls das Schreiben der Auftragsanfrage in eine lokale Datei, wenn die Auftragsanfrage genehmigt wurde.

Weiter mit Hinzufügen eines Skripts für die Registrierung der Komponente.


Hinzufügen eines Skripts für die Registrierung der Komponente

In diesem Verfahren fügen Sie ein Skript hinzu, mit dem die Komponente in der Datei registriert werden kann.

  1. Zeigen Sie im Startmenü auf Programme und dann auf Zubehör, und klicken Sie anschließend auf Editor.

  2. Fügen Sie das folgende Skript hinzu:
    <?xml version="1.0"?><?xml version="1.0"?>
<component><component>
<?component error="true" debug="true"?><?component error="true" debug="true"?>
<registration<registration
     description="PORequestApproval"description="PORequestApproval"
     progid="BTSTutorial.PORequestApproval"progid="BTSTutorial.PORequestApproval"
     version="1.00"version="1.00"
     classid="{2938621b-40fc-48e2-827c-bed74e21a538}"classid="{2938621b-40fc-48e2-827c-bed74e21a538}"
>
</registration></registration>

    Da Sie dieselbe Klassen-ID verwenden wie die vorkonfigurierte Komponente, wird die alte Komponente in der Registrierung außer Kraft gesetzt.

Weiter mit Hinzufügen eines Skripts für die Implementierung von Methoden.


Hinzufügen eines Skripts für die Implementierung von Methoden

Diese Komponente umfasst drei mögliche Methoden. Die erste Methode sendet einen Genehmigungsstatus in Form eines Meldungsfeldes, das dem Benutzer angezeigt wird. Die zweite Methode sendet einen Ablehnungsstatus, ebenfalls in Form eines Meldungsfeldes, das dem Benutzer angezeigt wird. Die Entscheidung, welche Methode aufgerufen wird, wird von der Entscheidungsregel in der XLANG-Ablaufplanzeichnung bestimmt. Die letzte Methode schreibt den Auftrag in eine lokale Datei, wenn die Auftragsanfrage genehmigt wurde.

  1. Fügen Sie die drei Methodensignaturen am Dateiende hinzu:
    <public><public>
     <method name="SendApproval"><method name="SendApproval">
          <PARAMETER name="Document"/><PARAMETER name="Document"/>
     </method></method>
     <method name="SendDenial"><method name="SendDenial">
          <PARAMETER name="Document"/><PARAMETER name="Document"/>
     </method></method>
     <method name="WriteToFile"><method name="WriteToFile">
          <PARAMETER name="Document"/><PARAMETER name="Document"/>
          <PARAMETER name="FileName"/><PARAMETER name="FileName"/>
     </method></method>
</public></public>
  2. Fügen Sie das Skript hinzu, das die Methoden am Dateiende implementiert:
    <implements type="Behavior" id="Behavior"/><implements type="Behavior" id="Behavior"/>

<script language="VBScript"><script language="VBScript">
<![CDATA[<![CDATA[

function SendApproval(Document)function SendApproval(Document)
     MsgBox "Scheduler Engine Accepted document :"MsgBox "Scheduler Engine Accepted document :" + vbcrlf + + vbcrlf + Document, 0, "Document Approval Received"
end functionend function

function SendDenial(Document)function SendDenial(Document)
     MsgBox "Scheduler Engine Denied document :"MsgBox "Scheduler Engine Denied document :" + vbcrlf + + vbcrlf + Document, 0, "Document Denied"
end functionend function

function WriteToFile(Document, FileName)function WriteToFile(Document, FileName)
     dim objFileSys, strTimeNowdim objFileSys, strTimeNow

     if FileName = "" thenif FileName = "" then
            FileName = "c:\TutorialFiles\Buyer\POReq*.xml"FileName = "c:\TutorialFiles\Buyer\POReq*.xml"
     end ifend if

'Generate a Unique Number used to generate unique files using a mask'Generate a Unique Number used to generate unique files using a mask
   strTimeNow = left(Replace(CStr(FormatDateTime(Now(), 3)),":",""), 6)strTimeNow = left(Replace(CStr(FormatDateTime(Now(), 3)),":",""), 6)

'Create File System Object'Create File System Object
     Set objFileSys = CreateObject("Scripting.FileSystemObject")Set objFileSys = CreateObject("Scripting.FileSystemObject")

'Create the Specified file, write the document data and close'Create the Specified file, write the document data and close
     Set filestream = objFileSys.CreateTextFile(Replace(FileName, "*", strTimeNow), False)Set filestream = objFileSys.CreateTextFile(Replace(FileName, "*", strTimeNow), False)
     filestream.writeline Documentfilestream.writeline Document
      filestream.closefilestream.close
end functionend function

]]>
</script></script>

</component></component>
  3. Klicken Sie im Menü Datei auf Speichern unter.

    Das Dialogfeld Speichern unter wird angezeigt.

  4. Wechseln Sie in das Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\Components\POReqApproval\Lab auf dem BizTalk Server-Installationslaufwerk.

  5. Im Feld Dateiname geben Sie PoRequestApproval.wsc ein.

  6. Klicken Sie im Feld Speichern unter Typ auf Alle Dateien, und klicken Sie dann auf Speichern.

  7. Schließen Sie Editor.

  8. Wechseln Sie in das Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\Components\POReqApproval\Lab auf dem BizTalk Server-Installationslaufwerk.

  9. Klicken Sie mit der rechten Maustaste auf PoRequestApproval.wsc, und klicken Sie dann auf Registrieren.

Diese Komponente kann durch die vorkonfigurierte Windows-Skriptkomponente ersetzt werden, die Sie in Unterrichtseinheit 1 verwendet haben. Um die Komponente verwenden zu können, müssen Sie die vorhandene Bindung der Windows-Skriptkomponente aus dem Ablaufplan entfernen und dann eine neue Bindung der Windows-Skriptkomponente erstellen, die auf Ihre Komponente verweist.

Weiter mit Löschen der Windows-Skriptkomponente.


Löschen der Windows-Skriptkomponente

In diesem Verfahren löschen Sie die Windows-Skriptkomponente aus der XLANG-Ablaufplanzeichnung Buyer2. Sie können die Komponente, die Sie erstellt haben, neu binden.

  1. Zeigen Sie im Startmenü auf Programme und auf Microsoft BizTalk Server 2000, und klicken Sie dann auf BizTalk-Orchestrierungs-Designer.

  2. Öffnen Sie die Datei Buyer2.skv, die sich im Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\Schedule\Lab auf dem BizTalk Server-Installationslaufwerk befindet, um die in Unterrichtseinheit 4 erstellte Zeichnung zu verwenden.

    Öffnen Sie die Datei Buyer2.skv, die sich im Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\Schedule\Solution auf dem BizTalk Server-Installationslaufwerk befindet, um die vorhandene Zeichnung Buyer2 zu verwenden.

  3. Klicken Sie auf die Skriptkomponente-Form, und drücken Sie dann die ENTF-TASTE.

  4. Klicken Sie auf die Registerkarte Daten.

  5. Löschen Sie die Meldungsfelder für SendApproval, SendDenial und WriteToFile.

Sie können nun die Windows-Skriptkomponente im Ablaufplan verwenden. Gehen Sie wie folgt vor:

  6. Implementieren Sie einen Port zu Buyer2.skv mithilfe der Windows-Skriptkomponente. Ein Beispiel für die Vorgehensweise finden Sie unter Implementieren eines Ports mithilfe einer Skriptkomponente. Verwenden Sie aber nicht die Komponente im Beispiel, sondern Ihre eigene Komponente.

  7. Definieren Sie die Methodenkommunikation für die Portimplementierung. Ein Beispiel für die Vorgehensweise finden Sie unter Definieren von Nachrichteneigenschaften für die Skriptkomponente.

  8. Definieren Sie den Datenfluss für den Port. Ein Beispiel für die Vorgehensweise finden Sie unter Definieren des Datenflusses.

  9. Speichern Sie die XLANG-Datei. Ein Beispiel für die Vorgehensweise finden Sie unter Speichern der XLANG-Ablaufplanzeichnung.

  10. Starten Sie die Anwendung ExecuteTutorial, die sich im Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\Schedule\Solution auf dem BizTalk Server-Installationslaufwerk befindet, um Ihre Komponente zu testen.

Weiter mit Erstellen der Anwendungsintegrationskomponente.


Erstellen der Anwendungsintegrationskomponente

In diesem Abschnitt erstellen Sie eine neue Anwendungsintegrationskomponente (Application Integration Component, AIC) mit dem Namen POtoINVAIC, die ein Auftragsdokument mithilfe von MSXML-DOM in ein Rechnungsdokument konvertiert.

Weiter mit Erstellen eines ActiveX-DLL-Projekts für die Anwendungsintegrationskomponente.


Erstellen eines ActiveX-DLL-Projekts für die Anwendungsintegrationskomponente

  1. Starten Sie Microsoft Visual Basic 6.0.

  2. Im Dialogfeld Neues Projekt klicken Sie auf die Registerkarte Neu, klicken Sie dann auf ActiveX-DLL und anschließend auf Öffnen.

    Auf diese Weise erstellen Sie für Ihre Komponente ein neues Projekt mit dem Namen Projekt1.

  3. Klicken Sie im Projektstrukturfenster auf Projekt1, um das Projekt und das Steuerelement sinnvoll umzubenennen. Ändern Sie im Eigenschaftenfenster die (Name)-Eigenschaft zu POtoInvAIC.

  4. Klicken Sie im Projektstrukturfenster auf Class1(Class1). Ändern Sie im Eigenschaftenfenster die (Name)-Eigenschaft zu ConvertPOtoInvoice.

Weiter mit Hinzufügen der erforderlichen Verweise für die Anwendungsintegrationskomponente.


Hinzufügen der erforderlichen Verweise für die Anwendungsintegrationskomponente

In diesem Verfahren kann eine Anzahl von Schnittstellen, die BizTalk Server 2000 benötigt, durch die Komponente implementiert werden.

  1. Klicken Sie im Menü Projekt auf Verweise.

  2. Klicken Sie auf Microsoft BizTalk Server Application Interface Components 1.0 Type Library.

    Der vollständige Pfad für diese Typbibliothek lautet \Program Files\Microsoft BizTalk Server\btscomplib.tlb.

  3. Wählen Sie Microsoft BizTalk Interchange 1.0 Type Library aus.

    Der vollständige Pfad für diese Typbibliothek lautet \Program Files\Microsoft BizTalk Server\cisapi.tlb.

  4. Wählen Sie Microsoft Scripting Runtime aus.

    Der vollständige Pfad für diese DLL lautet \WINNT\System32\Scrun.dll. Verwenden Sie diese Bibliothek, um ein Dateisystemobjekt zu erstellen, und öffnen Sie einen Text, der zum Schreiben eines Auftrags auf die Festplatte verwendet wird.

  5. Wählen Sie Microsoft XML, v 3.0 aus.

    Der vollständige Pfad für diese DLL lautet \WINNT\System32\msxml3.dll.

  6. Klicken Sie auf OK.

Weiter mit Implementieren der erforderlichen Schnittstelle.


Implementieren der erforderlichen Schnittstelle

Damit BizTalk Server eine Komponente als Anwendungsintegrationskomponente erkennen kann, muss eine von zwei Schnittstellen implementiert sein. Im Rahmen dieses Lernprogramms implementieren Sie die IBTSAppIntegration-Schnittstelle.

  1. Im Fenster Projekt klicken Sie auf das ConvertPOtoInvoice-Klassenmodul.

  2. Klicken Sie im Menü Ansicht auf Code.

  3. Fügen Sie die folgende Codezeile oben im Codefenster ein, um sicherzustellen, dass alle Variablen deklariert sind. Dadurch können einfache Fehler minimiert werden.
    Option ExplicitOption Explicit
  4. Implementieren Sie die erforderliche Schnittstelle, indem Sie die folgende Codezeile nach der Option Explicit-Anweisung hinzufügen:
    Implements IBTSAppIntegrationImplements IBTSAppIntegration

Weiter mit Definieren und Initialisieren der Klassenobjekte.


Definieren und Initialisieren der Klassenobjekte

In diesem Verfahren fügen Sie Code hinzu, um das MSXML-Klassenobjekt zum Erstellen von XML-Dateien mithilfe von DOM zu definieren. Sie werden eine Zeichenfolgenvariable erstellen, die auf das Projektstylesheet verweist, das einen Auftrag in eine Rechnung konvertiert.

  1. Platzieren Sie den folgenden Code unter die Implements IBTSAppIntegration-Anweisung:
    'Class Object Defines'Class Object Defines
Private m_DOMCommonPO As MSXML2.DOMDocumentPrivate m_DOMCommonPO As MSXML2.DOMDocument
Private m_DOMStylesheet As MSXML2.DOMDocumentPrivate m_DOMStylesheet As MSXML2.DOMDocument
Private m_objSubmit As BTSInterchangeLib.InterchangePrivate m_objSubmit As BTSInterchangeLib.Interchange

'Embedded Project Stylesheet to Convert CommonPO to CommonInvoice'Embedded Project Stylesheet to Convert CommonPO to CommonInvoice
Private m_strStylesheet As StringPrivate m_strStylesheet As String
  2. Fügen Sie den folgenden Code hinzu, um die XML-DOM-Objekte, die den Auftrag in eine Rechnung konvertieren, sowie das Interchange-Objekt, das das endgültige Rechnungsdokument an BizTalk Server versendet, zu initialisieren:
    Private Sub Class_Initialize()Private Sub Class_Initialize()
'Create DOM/Interchange Objects'Create DOM/Interchange Objects
    Set m_DOMCommonPO = New MSXML2.DOMDocumentSet m_DOMCommonPO = New MSXML2.DOMDocument
    Set m_DOMStylesheet = New MSXML2.DOMDocumentSet m_DOMStylesheet = New MSXML2.DOMDocument
    Set m_objSubmit = New BTSInterchangeLib.InterchangeSet m_objSubmit = New BTSInterchangeLib.Interchange

'Configure DOM Objects to be Synchronous'Configure DOM Objects to be Syncronous
    m_DOMCommonPO.async = Falsem_DOMCommonPO.async = False
    m_DOMStylesheet.async = Falsem_DOMStylesheet.async = False

'Fill Stylesheet Embedded String'Fill Stylesheet Embedded String
    m_strStylesheet = m_strStylesheet + ""m_strStylesheet = m_strStylesheet + ""

End SubEnd Sub

Weiter mit Implementieren der Schnittstellenmethode.


Implementieren der Schnittstellenmethode

Die ProcessMessage-Methode der IBTSAppIntegration-Schnittstelle empfängt ein eingehendes XML-Standardauftragsdokument, das von BizTalk Server übertragen wurde, und übersetzt die Daten, um es in ein XML-Standardrechnungsdokument zu konvertieren. Das Standardrechnungsdokument wird dann zurück an BizTalk Server versendet. Es soll ein Back-End-System simuliert werden, das Aufträge empfängt und dann eine Rechnung für diese Aufträge zurückgibt.

  1. Fügen Sie die Funktionsdefinition und die Variablen für äußere Maße hinzu, wie im folgenden Code angezeigt:
    Private Function IBTSAppIntegration_ProcessMessage( _Private Function IBTSAppIntegration_ProcessMessage( _
                                ByVal bstrDocument As String) As StringByVal bstrDocument As String) As String
    Dim bstrInvoiceDocument As StringDim bstrInvoiceDocument As String
    Dim objScripting As New Scripting.FileSystemObjectDim objScripting As New Scripting.FileSystemObject
'Initialize ProcessMessage to null    'Initialize ProcessMessage to null
    IBTSAppIntegration_ProcessMessage = ""IBTSAppIntegration_ProcessMessage = ""
  2. Fügen Sie den Code hinzu, um die empfangenen Daten in ein DOM-Objekt zu laden, und überprüfen Sie, ob es im richtigen Format ist, indem Sie den folgenden Code im Anschluss an die IBTSAppIntegration_ProcessMessage-Anweisung hinzufügen:
        m_DOMCommonPO.loadXML bstrDocumentm_DOMCommonPO.loadXML bstrDocument

    If m_DOMCommonPO.parseError.errorCode <> 0 Then 'The data was not valid XMLIf m_DOMCommonPO.parseError.errorCode <> 0 Then 'The data was not valid XML
'Raised errors are not caught in the component, and will be sent back to 'BizTalk Server'Raised errors are not caught in the component, and will be sent back to 'BizTalk Server
        Err.Raise m_DOMCommonPO.parseError.errorCode, "AICSample.ConvertPOToInvoice Component", _Err.Raise m_DOMCommonPO.parseError.errorCode, "AICSample.ConvertPOToInvoice Component", _
            "The provided document was not valid XML and could not be processed because:""The provided document was not valid XML and could not be processed because:" + _
            vbCrLf + vbCrLf + m_DOMCommonPO.parseError.reason + vbCrLf + " on line:vbCrLf + vbCrLf + m_DOMCommonPO.parseError.reason + vbCrLf + " on line: " + _
            CStr(m_DOMCommonPO.parseError.Line) + vbCrLf + "at position:CStr(m_DOMCommonPO.parseError.Line) + vbCrLf + "at position: " + _
            CStr(m_DOMCommonPO.parseError.linepos)CStr(m_DOMCommonPO.parseError.linepos)
    End IfEnd If
  3. Fügen Sie den folgenden Code im Anschluss an die End If-Anweisung hinzu, um die im XSL-Code enthaltende Ressourcendatei zu verwenden, die einen Auftrag in eine Rechnung konvertiert:
        If m_strStylesheet = "" ThenIf m_strStylesheet = "" Then
        m_strStylesheet = StrConv(LoadResData(101, "CUSTOM"), vbUnicode)m_strStylesheet = StrConv(LoadResData(101, "CUSTOM"), vbUnicode)

    End IfEnd If
    m_DOMStylesheet.loadXML m_strStylesheetm_DOMStylesheet.loadXML m_strStylesheet
    bstrInvoiceDocument = m_DOMCommonPO.transformNode(m_DOMStylesheet)bstrInvoiceDocument = m_DOMCommonPO.transformNode(m_DOMStylesheet)

    If bstrInvoiceDocument = "" Then ' Mapping Failed Raise an ErrorIf bstrInvoiceDocument = "" Then ' Mapping Failed Raise an Error
        Err.Raise vbObjectError + 100, "AICSample.ConvertPOToInvoice Component", _Err.Raise vbObjectError + 100, "AICSample.ConvertPOToInvoice Component", _
            "The provided CommonPO document could not be translated into a Common Invoice " + _"The provided CommonPO document could not be translated into a Common Invoice " + _
            "as the map produced blank output.""as the map produced blank output."
    End IfEnd If
  4. Fügen Sie den folgenden Code im Anschluss an die End If-Anweisung hinzu, um das Rechnungsdokument an die BizTalk-Messagingdienste zu versenden:
    IBTSAppIntegration_ProcessMessage = m_objSubmit.Submit(BIZTALK_OPENNESS_TYPE_NOTOPEN, bstrInvoiceDocument, , , "Bits,Bytes,Chips on Seller", , "ProElectron on Seller")IBTSAppIntegration_ProcessMessage = m_objSubmit.Submit(BIZTALK_OPENNESS_TYPE_NOTOPEN, bstrInvoiceDocument, , , "Bits,Bytes,Chips on Seller", , "ProElectron on Seller")

End FunctionEnd Function

    Der Submit-Aufruf gibt die Versendungs-ID zurück, die in diesem Fall nicht verwendet wird.

Weiter mit Beenden der Klassenobjekte.


Beenden der Klassenobjekte

Fügen Sie folgenden Code am Ende des Projekts hinzu, um sicherzustellen, dass alle Objekte aus dem Speicher freigegeben werden, wenn die Klasse beendet wird:

Private Sub Class_Terminate()Private Sub Class_Terminate()
    Set m_DOMCommonPO = NothingSet m_DOMCommonPO = Nothing
    Set m_DOMStylesheet = NothingSet m_DOMStylesheet = Nothing
    Set m_objSubmit = NothingSet m_objSubmit = Nothing
End SubEnd Sub

Weiter mit Erstellen der Ressourcendatei.


Erstellen der Ressourcendatei

In diesem Verfahren fügen Sie die Ressourcendatei hinzu, die die XSL zum Transformieren eines Auftrags in eine Rechnung enthält.

  1. Im Menü Add-Ins klicken Sie auf Add-In-Manager.

    Das Dialogfeld Add-In-Manager wird angezeigt.

  2. Klicken Sie auf VB 6 Ressourcen-Editor.

  3. Im Bereich Ladeverhalten klicken Sie auf Laden/Entladen, um den Ressourcen-Editor zu laden, klicken Sie dann auf Beim Start laden und anschließend auf OK.

  4. Klicken Sie im Menü Extras auf Ressourcen-Editor.

  5. Klicken Sie auf das Symbol Benutzerdefinierte Ressource hinzufügen auf der Symbolleiste.

    Das Dialogfeld Benutzerdefinierte Ressource öffnen wird angezeigt.

  6. Wechseln Sie in das Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\Components\POtoInvoice\Lab, klicken Sie auf POtoINVAIC.txt und dann auf Öffnen.

Vorsicht

  • Stellen Sie sicher, dass die ID Ihrer Ressource 101 ist. Standardmäßig hat die erste Ressource eine ID von 101, aber diese Zahl erhöht sich jeweils um eins, wenn Sie die Ressource ändern. Klicken Sie mit der rechten Maustaste auf die Ressourcen-ID, und klicken Sie dann auf Eigenschaften, um die Ressourcen-ID in 101 zu ändern. Im Feld ID geben Sie 101 ein.
  7. Klicken Sie auf das Symbol Speichern.

    Das Dialogfeld Ressourcendatei speichern unter wird angezeigt.

  8. Wechseln Sie in das Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\Components\POtoInvoice\Lab.

  9. Im Feld Dateiname geben Sie POtoInvAICLab.RES ein, und klicken Sie dann auf Speichern.

  10. Schließen Sie den Ressourcen-Editor.

Weiter mit Aufbauen der Komponente und Festlegen der Binärkompatibilität.


Aufbauen der Komponente und Festlegen der Binärkompatibilität

Da Sie eine neue Komponente erstellen, müssen Sie die Komponente zunächst aufbauen und dann die Projekteigenschaften für Binärkompatibilität mit der neu erstellten DLL festlegen. Die Binärkompatibilität stellt sicher, dass Sie nicht jedes Mal beim Kompilieren der DLL einen neuen global eindeutigen Bezeichner (Globally Unique Identifier, GUID) für das Objekt generieren.

  1. Klicken Sie im Menü Datei auf Projekt speichern unter.

    Das Dialogfeld Datei speichern unter wird angezeigt.

  2. Wechseln Sie in das Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\Components\POToInvoice\Lab auf dem BizTalk Server-Installationslaufwerk.

  3. Im Feld Dateiname geben Sie ConvertPOtoInvoice.cls ein, und klicken Sie dann auf Speichern.

    Das Dialogfeld Projekt speichern unter wird angezeigt.

  4. Wechseln Sie in das Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\Components\POToInvoice\Lab auf dem BizTalk Server-Installationslaufwerk.

  5. Im Feld Dateiname geben Sie POToInvAICLab ein, und klicken Sie dann auf Speichern.

  6. Klicken Sie im Menü Datei auf POToInvAICLab.dll erstellen.

    Das Dialogfeld Projekt erstellen wird angezeigt.

  7. Wechseln Sie in das Verzeichnis \Program Files\Microsoft BizTalk Server\Tutorial\Components\POtoInvoice\Lab auf dem BizTalk Server-Installationslaufwerk, und klicken Sie dann auf OK.

  8. Im Menü Projekt klicken Sie auf Eigenschaften von POToInvAICLab.

  9. Klicken Sie auf die Registerkarte Komponente.

  10. Klicken Sie auf Binär-Kompatibilität.

  11. Klicken Sie auf Durchsuchen ([...]), und wechseln Sie in das Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\Components\POtoInvoice\Lab auf dem BizTalk Server-Installationslaufwerk.

  12. Klicken Sie auf POToInvAICLab.dll und dann auf Öffnen.

  13. Klicken Sie auf OK.

Weiter mit Registrieren der Anwendungsintegrationskomponente.


Registrieren der Anwendungsintegrationskomponente

In diesem Verfahren registrieren Sie die Anwendungsintegrationskomponente, damit sie von BizTalk Server erkannt wird. BizTalk Server durchsucht die Liste der registrierten COM-Komponenten und fragt diese Komponenten ab, um zu bestimmen, durch welche Komponente entweder die IBTSAppIntegration-Schnittstelle oder die IPipelineComponent-Schnittstelle implementiert wird. Alle Komponenten, die den Kriterien entsprechen, werden in einer Komponentenliste im BizTalk-Messaging-Manager angezeigt.

  1. Zeigen Sie im Startmenü auf Einstellungen, und klicken Sie dann auf Systemsteuerung.

  2. Doppelklicken Sie auf Verwaltung.

  3. Doppelklicken Sie auf Komponentendienste.

    Die Konsole der Komponentendienste wird angezeigt.

  4. In der Konsolenstruktur erweitern Sie Komponentendienste, Computer, Arbeitsplatz, und klicken Sie dann auf COM+ Anwendungen.

  5. Klicken Sie mit der rechten Maustaste auf COM+ Anwendungen, zeigen Sie auf Neu, und klicken Sie dann auf Anwendung.

    Der COM-Anwendungsinstallations-Assistent wird geöffnet.

  6. Auf der Seite Willkommen beim COM-Anwendungsinstallations-Assistenten klicken Sie auf Weiter.

  7. Auf der Seite Neue Anwendung erstellen oder installieren klicken Sie auf Eine leere Anwendung erstellen.

  8. Im Feld Geben Sie einen Namen für die neue Anwendung ein geben Sie POToInvAICLab ein.

  9. Klicken Sie im Bereich Aktivierungstyp auf Serveranwendung, und klicken Sie dann auf Weiter.

  10. Klicken Sie im Bereich Konto auf Interaktiver Benutzer, der zurzeit angemeldete Benutzer, und klicken Sie dann auf Weiter.

    Anmerkung

    • Der aktuell angemeldete Benutzer muss ein Mitglied der Gruppe BizTalk Server-Administratoren sein und während des Ausführens dieses Szenarios angemeldet bleiben.
  11. Klicken Sie auf Fertig stellen.

  12. In der Konsolenstruktur erweitern Sie COM+ Anwendungen und dann das Paket POToInvAICLab, das Sie neu erstellt haben.

  13. Klicken Sie auf Komponenten.

  14. Wechseln Sie in das Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\Components\POtoInvoice\Lab auf dem BizTalk Server-Installationslaufwerk.

  15. Ziehen Sie POToInvAICLab.dll zum Ordner Komponenten in den Komponentendiensten.

  16. Schließen Sie die Komponentendienste.

Sie können den Port jetzt für die Verwendung der neuen Anwendungsintegrationskomponente neu konfigurieren, indem Sie folgende Schritte ausführen:

  1. Öffnen Sie den BizTalk-Messaging-Manager.

  2. Im Bereich Suchen klicken Sie auf Messagingports und dann auf Jetzt suchen.

  3. In der Liste Messagingportname doppelklicken Sie auf Port to Bits,Bytes,Chips via AIC.

  4. Auf der Seite Allgemeine Informationen klicken Sie auf Weiter.

  5. Auf der Seite Zielorganisation im Bereich Primärer Transport klicken Sie auf Durchsuchen.

    Das Dialogfeld Primärer Transport wird angezeigt.

  6. Klicken Sie auf Durchsuchen.

  7. In der Liste Verfügbare Komponenten klicken Sie auf POToInvAICLab ConvertPOtoInvoice, und klicken Sie dann auf OK.

  8. Klicken Sie auf OK, um das Dialogfeld Primärer Transport zu schließen, und klicken Sie dann auf Fertig stellen.

  9. Testen Sie die Komponente, indem Sie die Anwendung ExecuteTutorial ausführen, die sich unter \Programme\Microsoft BizTalk Server\Tutorial\Schedule\Solution auf dem BizTalk Server-Installationslaufwerk befindet.


BizTalkServer-Verwaltung

BizTalk Server-Kopfzeile

BizTalk Server-Verwaltung

Die BizTalk Server 2000-Verwaltung ist in die folgenden Bereiche unterteilt:

Installieren von BizTalk Server 2000

Dieser Abschnitt stellt Informationen zum Installieren von BizTalk Server 2000 bereit. Die Informationen enthalten Richtlinien für die Hardware- und Softwareanforderungen und Anweisungen für die Installationsvarianten Vollständig, Tools oder Benutzerdefiniert. Weitere Informationen zum Installieren von BizTalk Server 2000 finden Sie unter Installieren von BizTalk Server 2000.

Grundlegendes zur Sicherheit

Dieser Abschnitt behandelt den sicheren Datenaustausch von Unternehmen mit Handelspartnern bei der Verwendung von BizTalk Server 2000. BizTalk Server nutzt die Vorteile der in Microsoft Windows 2000 und Microsoft SQL Server enthaltenen Sicherheitsfeatures. Weitere Informationen zur Sicherheit und BizTalk Server 2000 finden Sie unter Grundlegendes zur Sicherheit.

Verbessern von Leistung und Skalierbarkeit

Dieser Abschnitt stellt Informationen zum Steigern der Leistung von BizTalk Server und zum Erstellen von skalierbaren Lösungen bereit. Die in diesem Abschnitt behandelten Probleme und Richtlinien enthalten das Identifizieren möglicher Engpässe, das Behandeln von Wartezeit und das Verwalten von Datenbanken. Weitere Informationen zum Erstellen von skalierbaren, leistungsfähigen Lösungen finden Sie unter Verbessern von Leistung und Skalierbarkeit.

Verwalten von Servern und Anwendungen

Dieser Abschnitt behandelt das Verwalten von Servern und XLANG-verwandten Anwendungen. Die in diesem Abschnitt behandelten Themen enthalten das zentrale Konfigurieren und Verwalten von Servern in mehreren Gruppen, das Konfigurieren und Verwalten von Empfangsfunktionen, das Verwalten der gemeinsam genutzten Warteschlange und der COM+-Anwendungen, die als Host für die XLANG-Ablaufpläne dienen. Weitere Informationen zum Verwalten von Servern und Anwendungen finden Sie unter Verwalten von Servern und Anwendungen.

Überwachen von Dokumenten

Dieser Abschnitt stellt Informationen zum Überwachen von Austauschvorgängen und Dokumenten bereit, die von BizTalk Server 2000 verarbeitet werden. Die in diesem Abschnitt behandelten Themen enthalten das Erstellen von Abfragen und erweiterten Abfragen, das Sichern von Austausch- und Dokumentdaten und Daten der benutzerdefinierten Suche. Ebenfalls wird Grundlegendes zu den Ergebnissen von Austauschdatensätzen, Dokumentdatensätzen und zu Empfangsbestätigungen behandelt. Weitere Informationen zum Überwachen von Dokumenten finden Sie unter Überwachen von Dokumenten.

Anmerkung

  • Der Dateipfad zum Öffnen der verschiedenen Dienste und Tools von Microsoft Windows 2000, beispielsweise der Komponentendienste und der Verwaltung, ist abhängig davon, ob der verwendete Computer unter Windows 2000 Server oder Windows 2000 Professional ausgeführt wird. Weitere Informationen finden Sie unter Öffnen der Komponentendienste.

    In der Microsoft BizTalk Server 2000-Hilfe wurden die Pfade zu diesen Diensten und Tools auf der Basis einer Installation von Windows 2000 Server dokumentiert. Beim Verwenden von Windows 2000 Professional finden Sie in der Windows 2000 Professional-Hilfe weitere Informationen zum Öffnen des von Ihnen benötigten/gewünschten Dienstes oder Tools.

Verwandtes Thema

BizTalk Server-Verwaltungsmodell


Installieren von BizTalk Server2000

BizTalk Server-Kopfzeile

Installieren von BizTalk Server 2000

Willkommen beim Microsoft® BizTalk™ Server 2000-Installationshandbuch. Dieses Handbuch stellt Informationen zu Hardware- und Softwareanforderungen sowie vollständige Anweisungen für die folgenden Installationsoptionen bereit:

  • Vollständige Installation. Ermöglicht die Ausführung einer vollständigen Installation von BizTalk Server 2000, einschließlich sämtlicher BizTalk-Dienste und -Tools.

  • Tools-Installation. Ermöglicht die Ausführung einer vollständigen Installation der BizTalk Server 2000-Tools, einschließlich des BizTalk-Orchestrierungs-Designers, der BizTalk-Dokumentüberwachung, des BizTalk-Editors und des BizTalk-Mappers. Der Parser von BizTalk Server 2000, die Serialisierungskomponente, die Korrelationskomponente und die Laufzeitbinärdateien werden nicht installiert.

  • Benutzerdefinierte Installation. Ermöglicht die Ausführung einer benutzerdefinierten Installation mit jeder beliebigen Kombination von BizTalk Server 2000-Diensten und -Tools.

Diese Handbuch enthält die folgenden Themen:

  • Hardware- und Softwareanforderungen

  • Installationsanweisungen


Hardware- und Softwareanforderungen

Dieser Abschnitt enthält Informationen zu den minimalen Hardwareanforderungen sowie den Konfigurationsoptionen für die Installation von Microsoft BizTalk Server 2000. Außerdem werden die Installationsanweisungen der für BizTalk Server 2000 erforderlichen Software beschrieben.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Minimale Hardwareanforderungen

  • Empfohlene Konfiguration für optimale Leistung beim Dokumentmessaging

  • Softwareanforderungen

  • Windows 2000-Vorbereitungen

  • Installieren von SQL Server 7.0 oder SQL Server 2000

  • Installieren von Visio 2000 SR-1A


Minimale Hardwareanforderungen

Die folgenden Hardwareanforderungen müssen mindestens erfüllt sein, damit eine Installation von Microsoft BizTalk Server 2000 ausgeführt werden kann:

  • Intel® Pentium 300-Prozessor

  • 128 Megabyte RAM

  • 6-Gigabyte-Festplatte

  • CD-ROM-Laufwerk

  • Netzwerkkarte

  • VGA- oder Super-VGA-Monitor

  • Microsoft Maus oder kompatibles Zeigegerät


Empfohlene Konfiguration für optimale Leistung beim Dokumentmessaging

Die folgenden Richtlinien helfen Ihnen, BizTalk Server 2000 optimal zu konfigurieren:

  • Erstellen Sie eine Konfiguration mit drei Computern. Auf dem ersten Computer installieren Sie BizTalk Server 2000, auf dem zweiten die Überwachungsdatenbank und auf dem dritten die BizTalk-Messaging-Verwaltungsdatenbank sowie die Datenbank für gemeinsam genutzte Warteschlangen.

  • Für eine Konfiguration, in der ein einzelner Server sämtliche Verarbeitungs- und Empfangsfunktionen ausführt, konfigurieren Sie zwei Server mit BizTalk Server 2000, von denen einer die Verarbeitung und der andere den Empfang übernimmt.

  • Installieren Sie die Überwachungsdatenbank auf einem Computer mit mehreren physischen Festplatten. Die optimale Konfiguration umfasst vier SCSI II-Festplatten und einen SCSI II-Controller. Die erste Festplatte speichert die Dokumentüberwachung, die zweite die Microsoft Windows® 2000-Auslagerungsdatei, die dritte das Protokoll für die Überwachung von Transaktionen und die vierte das DTC-Protokoll (Distributed Transaction Coordinator).

  • Erstellen Sie mehrere Instanzen von Empfangsfunktionen, um mehrere Empfangsstandorte für die zu verarbeitenden Dokumente überwachen zu können. Um die Belastung durch Dokumente zwischen verschiedenen Computern auszugleichen, sollten sich die Empfangsfunktionen auf verschiedenen Computern befinden. Jeder Überwachungsstandort muss eindeutig sein und über eine eigene Empfangsfunktion verfügen. Um die Überlastung einer einzelnen Empfangsfunktion zu vermeiden, sollte die Geschäftsanwendung, die Dokumente ausgibt, diese Dokumente gleichmäßig auf alle Überwachungsstandorte verteilen.

Wichtig

  • Weitere Informationen zur Verbesserung der Leistung von BizTalk Server finden Sie unter Verbessern von Leistung und Skalierbarkeit.


Softwareanforderungen

In der folgenden Tabelle wird die Software aufgelistet, die installiert sein muss, damit Microsoft BizTalk Server 2000 ausgeführt werden kann.

Vollständige Installation | Tools-Installation | Benutzerdefinierte Installation
Microsoft Windows 2000 Server, Microsoft Windows 2000 Advanced Server oder Microsoft Windows 2000 Professional mit NTFS-Dateisystem und Service Pack 1 | Microsoft Windows 2000 Server, Microsoft Windows 2000 Advanced Server oder Microsoft Windows 2000 Professional mit NTFS-Dateisystem und Service Pack 1 | Microsoft Windows 2000 Server, Microsoft Windows 2000 Advanced Server oder Microsoft Windows 2000 Professional mit NTFS-Dateisystem und Service Pack 1
Microsoft Internet Explorer 5 oder höher | Microsoft Internet Explorer 5 oder höher | Microsoft Internet Explorer 5 oder höher
Microsoft Visio® 2000 SR-1A oder höher (für die Verwendung des BizTalk-Orchestrierungs-Designers erforderlich) | Microsoft Visio 2000 SR-1A oder höher (für die Verwendung des BizTalk-Orchestrierungs-Designers erforderlich) | Microsoft Visio 2000 SR-1A oder höher (für die Verwendung des BizTalk-Orchestrierungs-Designers erforderlich)
Microsoft SQL Server™ 7.0 und SQL Server Service Pack 2 (SP2) oder SQL Server 2000 | Microsoft SQL Server 7.0 und SQL Server Service Pack 2 (SP2)* oder SQL Server 2000
Anmerkung
  • Der BizTalk-Messaging-Manager wird nur ausgeführt, wenn der WWW-Publishingdienst ausgeführt wird.
 Anmerkung
  • Der BizTalk-Messaging-Manager wird nur ausgeführt, wenn der WWW-Publishingdienst ausgeführt wird.
 Anmerkung
  • Der BizTalk-Messaging-Manager wird nur ausgeführt, wenn der WWW-Publishingdienst ausgeführt wird.

*Microsoft SQL Server ist für eine benutzerdefinierte Installation nur erforderlich, wenn Sie die Hauptdienste von BizTalk installieren. Für eine Tools-Installation ist dieses Programm nicht erforderlich.


Windows 2000-Vorbereitungen

Empfohlene Plattformen für alle Microsoft BizTalk Server 2000-Installationen sind Microsoft Windows 2000 Server, Microsoft Windows 2000 Advanced Server und Microsoft Windows 2000 Professional mit Service Pack 1. Da BizTalk Server 2000 unter Windows 2000 mit Service Pack 1 ausführlich getestet wurde, enthält dieses Installationshandbuch detaillierte Konfigurationsinformationen für Windows 2000 Server, Windows 2000 Advanced Server und Windows 2000 Professional in Verbindung mit BizTalk Server. Nach der Installation von Windows 2000 Server, Advanced Server oder Professional mit Service Pack 1 müssen Sie der Administratorengruppe ein Windows 2000-Benutzerkonto hinzufügen, bevor Sie Software installieren. Weitere Informationen finden Sie unter Hinzufügen eines Benutzerkontos zur Administratorengruppe. Außerdem müssen Sie Message Queuing installieren. Weitere Informationen finden Sie unter Installieren der Message Queuing-Dienste. Enthält Ihre Installation Service Pack 1 nicht, müssen Sie dieses ebenfalls installieren. Weitere Informationen finden Sie unter Installieren von Windows 2000 Service Pack 1.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Installieren von Windows 2000 Server, Advanced Server oder Professional mit Service Pack 1

  • Installieren von Windows 2000 Service Pack 1

  • Installieren der Message Queuing-Dienste

  • Installieren der Internet-Informationsdienste (IIS)

  • Konfigurieren von IIS-Einstellungen für BizTalk Server 2000

  • Einrichten von Benutzerkonten


Installieren von Windows 2000 Server, Advanced Server oder Professional mit Service Pack1

BizTalk Server-Kopfzeile

Installieren von Windows 2000 Server, Advanced Server oder Professional mit Service Pack 1

Ist Windows 2000 Server, Advanced Server oder Professional auf Ihrem Computer installiert, überprüfen Sie, ob es den unter Schritt 2 beschriebenen Anforderungen entspricht.

  1. Legen Sie die CD für Windows 2000 Server, Advanced Server oder Professional mit Service Pack 1 in das entsprechende Laufwerk ein.

    Falls Sie über eine Version von Windows 2000 verfügen, die das Service Pack 1 nicht enthält, installieren Sie zunächst Windows 2000 und dann separat das Service Pack 1.

  2. Führen Sie das Setup-Programm für Windows 2000 Server, Advanced Server oder Professional mit Service Pack 1 aus, und folgen Sie den Anweisungen auf dem Bildschirm.

    Beachten Sie dabei Folgendes:

    • Der Computername darf nur aus alphanumerischen Zeichen bestehen, da Microsoft SQL Server einen eingeschränkten Zeichensatz in Servercomputernamen unterstützt.

    • Formatieren Sie die Partition mit dem Windows-NTFS-Dateisystem.

    • Klicken Sie auf der Seite Windows 2000-Komponenten in der Liste Komponenten auf Message Queuing-Dienste. Falls Sie Windows 2000 Professional installieren, klicken Sie auf Internet-Informationsdienste (IIS) und dann auf Weiter. Klicken Sie auf der Seite Message Queue-Installationstyp auf Weiter.

    • Klicken Sie auf der Seite Netzwerkeinstellungen auf Standardeinstellungen.

Anmerkungen

  • Nach der Installation von Windows 2000 Server, Advanced Server oder Professional mit Service Pack 1, müssen Sie der Administratorengruppe ein Windows 2000-Benutzerkonto hinzufügen, bevor Sie Software installieren. Weitere Informationen finden Sie unter Hinzufügen eines Benutzerkontos zur Administratorengruppe.

  • Wenn Sie Message Queuing-Dienste auf der Seite Windows 2000-Komponenten während des Setups nicht ausgewählt haben, müssen Sie diese jetzt installieren. Weitere Informationen finden Sie unter Installieren der Message Queuing-Dienste.

  • Wenn Sie Internet-Informationsdienste (IIS) auf der Seite Windows 2000-Komponenten während des Setups nicht ausgewählt haben, müssen Sie diese jetzt installieren. Weitere Informationen finden Sie unter Installieren der Internet-Informationsdienste (IIS).

  • Enthält Ihre Installation Service Pack 1 nicht, müssen Sie dieses ebenfalls installieren. Weitere Informationen finden Sie unter Installieren von Windows 2000 Service Pack 1.

  • Die Windows 2000 Server-, Advanced Server- oder Professional-Partition muss in die neueste NTFS-Version konvertiert werden. Das Setup-Programm führt diese Aktualisierung automatisch durch, falls es sich bei dem vorhandenen Dateisystem um eine alte Version von NTFS handelt. Handelt es sich bei der vorhandenen Partition um FAT oder FAT32, haben Sie die Möglichkeit, diese in NTFS zu konvertieren. Wählen Sie NTFS aus, wenn Sie dazu aufgefordert werden.


Installieren von Windows2000 Service Pack1

BizTalk Server-Kopfzeile

Installieren von Windows 2000 Service Pack 1

  1. Legen Sie die Windows 2000 Service Pack 1-CD in das entsprechende Laufwerk ein.

    Über die Microsoft Windows 2000-Website (http://www.microsoft.com/germany/windows2000/) können Sie das Windows 2000 Service Pack 1 auch downloaden oder die CD bestellen.

  2. Führen Sie das Setup-Programm für das Windows 2000 Service Pack 1 aus, und folgen Sie den Anweisungen auf dem Bildschirm.


Installieren der Message Queuing-Dienste

  1. Zeigen Sie im Startmenü auf Einstellungen, und klicken Sie dann auf Systemsteuerung.

  2. Doppelklicken Sie auf Software.

    Das Dialogfeld Software wird angezeigt.

  3. Klicken Sie auf Windows-Komponenten hinzufügen/entfernen.

    Der Assistent für Windows-Komponenten wird geöffnet.

  4. Aktivieren Sie in der Liste Komponenten das Kontrollkästchen Message Queuing-Dienste, und klicken Sie auf Weiter.

  5. Klicken Sie auf der Seite Message Queue-Installationstyp auf Weiter.

  6. Klicken Sie auf Fertig stellen, um den Assistenten zu schließen.

Anmerkung

  • Übernehmen Sie die Standardeinstellungen, wenn Sie die Message Queuing-Dienste installieren.


Installieren der Internet-Informationsdienste (IIS)

  1. Zeigen Sie im Startmenü auf Einstellungen, und klicken Sie dann auf Systemsteuerung.

  2. Doppelklicken Sie auf Software.

    Das Dialogfeld Software wird angezeigt.

  3. Klicken Sie auf Windows-Komponenten hinzufügen/entfernen.

    Der Assistent für Windows-Komponenten wird geöffnet.

  4. Aktivieren Sie in der Liste Komponenten das Kontrollkästchen Internet-Informationsdienste (IIS), und klicken Sie auf Weiter.

  5. Klicken Sie auf Fertig stellen, um den Assistenten zu schließen.


Konfigurieren von IIS-Einstellungen für BizTalk Server2000

BizTalk Server-Kopfzeile

Konfigurieren von IIS-Einstellungen für BizTalk Server 2000

Sie müssen die Option Dokumenterstellung aktivieren der Internet-Informationsdiensten (IIS) ausschalten, um Probleme beim Zugriff auf und Speichern von Spezifikationen im BizTalk Server 2000-Repository zu vermeiden.

  1. Zeigen Sie im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Internetdienste-Manager.

  2. Klicken Sie auf das Erweiterungssymbol (+) für den lokalen IIS-Server.

  3. Klicken Sie mit der rechten Maustaste auf Standardwebsite und dann auf Eigenschaften.

    Das Dialogfeld Eigenschaften von Standardwebsite wird angezeigt.

  4. Klicken Sie auf die Registerkarte Servererweiterungen, und deaktivieren Sie das Kontrollkästchen Dokumenterstellung aktivieren.


Einrichten von Benutzerkonten

Wenn Sie BizTalk Server 2000 lediglich zu Entwicklungszwecken installieren, können Sie ein Standardbenutzerkonto erstellen. Weitere Informationen finden Sie unter Hinzufügen eines Benutzerkontos zur Administratorengruppe. Wenn Sie BizTalk Server 2000 dagegen zu Produktionszwecken installieren, sollten Sie ein Dienstkonto erstellen. Weitere Informationen finden Sie unter Erstellen eines Dienstkontos. Falls Sie kein Dienstkonto erstellen, d. h. ein reguläres Benutzerkonto mit bestimmten Eigenschaften, wird BizTalk Server 2000 automatisch für den interaktiven Benutzer konfiguriert (d. h. den Benutzer, der während des Installationsprozesses angemeldet ist). Wird BizTalk Server 2000 mit einem interaktiven Benutzer eingerichtet, kann es zu einem Fehler kommen, wenn dieser sich vom Server abmeldet.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Hinzufügen eines Benutzerkontos zur Administratorengruppe

  • Erstellen eines Dienstkontos


Hinzufügen eines Benutzerkontos zur Administratorengruppe

  1. Melden Sie sich als Administrator an.

    Zeigen Sie im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Computerverwaltung.

  2. Klicken Sie in der Konsolenstruktur auf das Erweiterungssymbol (+) für Lokale Benutzer und Gruppen.

  3. Klicken Sie auf Gruppen, und doppelklicken Sie dann im Detailbereich auf Administratoren.

    Das Dialogfeld Eigenschaften von Administratoren wird angezeigt.

  4. Klicken Sie auf Hinzufügen.

  5. Klicken Sie im Feld Suchen in auf den Namen Ihres Computers.

  6. Löschen Sie im Feld mit dem Text <<Geben Sie die Namen getrennt durch Semikolons ein oder wählen Sie in der Liste aus>> diesen Text, und geben Sie stattdessen Ihren Domänen- und Benutzernamen im folgenden Format ein:

    Domäne\Benutzername

  7. Klicken Sie auf OK.

  8. Führen Sie gegebenenfalls auf der Seite Netzwerkkennwort eingeben die folgenden Schritte durch:
    • Geben Sie im Feld Verbinden als Ihren Domänen- und Benutzernamen im folgenden Format ein:

      Domäne\Benutzername

    • Geben Sie im Feld Kennwort das Kennwort ein, das mit Ihrem Benutzernamen verknüpft ist, und klicken Sie auf OK.

    • Klicken Sie auf OK, um das Dialogfeld Eigenschaften von Administratoren zu schließen.
  9. Starten Sie den Computer gegebenenfalls neu, und melden Sie sich unter dem Domänenbenutzerkonto an.


Erstellen eines Dienstkontos

  1. Melden Sie sich als Administrator an.

  2. Zeigen Sie im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Computerverwaltung.

    Das Dialogfeld Computerverwaltung wird angezeigt.

  3. Klicken Sie in der Konsolenstruktur auf das Erweiterungssymbol (+) für Systemprogramme, und klicken Sie auf Lokale Benutzer und Gruppen.

  4. Klicken Sie auf Benutzer, klicken Sie mit der rechten Maustaste in den Detailbereich, und klicken Sie dann auf Neuer Benutzer.

    Das Dialogfeld Neuer Benutzer wird angezeigt.

  5. Geben Sie im Feld Neuer Benutzer einen Namen für das Dienstkonto ein, geben Sie im Feld Kennwort ein Kennwort ein, und geben im Feld Kennwort bestätigen dasselbe Kennwort noch einmal ein.

  6. Deaktivieren Sie das Kontrollkästchen Benutzer muss Kennwort bei der nächsten Anmeldung ändern, klicken Sie auf Erstellen und dann auf Schließen.

  7. Schließen Sie das Fenster Computerverwaltung.

  8. Zeigen Sie im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Lokale Sicherheitsrichtlinie.

    Das Dialogfeld Lokale Sicherheitsrichtlinie wird angezeigt.

  9. Klicken Sie in der Konsolenstruktur auf das Erweiterungssymbol (+) für Lokale Richtlinien, und klicken Sie dann auf Zuweisen von Benutzerrechten.

  10. Doppelklicken Sie im Detailbereich auf Einsetzen als Teil des Betriebssystems, klicken Sie auf Hinzufügen, klicken Sie im Listenfeld auf den soeben erstellten Kontonamen, klicken Sie noch einmal auf Hinzufügen, und klicken Sie dann zweimal auf OK.

  11. Wiederholen Sie die Schritte 8 bis 10 für die Richtlinie Als Dienst anmelden.

Wenn BizTalk Server 2000 bereits installiert ist und das interaktive Benutzerkonto verwendet, führen Sie die folgenden Schritte aus, nachdem Sie ein Dienstkonto erstellt haben.

  1. Zeigen Sie im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Dienste.

  2. Doppelklicken Sie im Detailbereich auf BizTalk-Messagingdienst.

    Das Dialogfeld Eigenschaften von BizTalk-Messagingdienst (Lokaler Computer) wird angezeigt.

  3. Klicken Sie auf die Registerkarte Anmelden und dann auf Dieses Konto.

  4. Klicken Sie auf Durchsuchen, suchen Sie nach dem Namen des von Ihnen erstellten Benutzerkontos, und doppelklicken Sie darauf.

  5. Geben Sie im Feld Kennwort dasselbe Kennwort ein, das Sie dem Benutzerkonto zugewiesen haben, geben Sie im Feld Kennwort bestätigen das Kennwort noch einmal ein, und klicken Sie dann auf OK.

  6. Klicken Sie in dem daraufhin angezeigten Meldungsfeld auf OK.

  7. Starten Sie den Computer neu.


Installieren von SQLServer7.0 oder SQLServer2000

BizTalk Server-Kopfzeile

Installieren von SQL Server 7.0 oder SQL Server 2000

Vor der Installation von Microsoft BizTalk Server 2000 müssen Sie Microsoft SQL Server 7.0 mit SQL Server Service Pack 2 (SP2) oder Microsoft SQL Server 2000 installieren. Während der Installation von BizTalk Server 2000 werden in SQL Server vier BizTalk Server 2000-Datenbanken erstellt (die BizTalk-Messaging-Verwaltungsdatenbank, die Datenbank für gemeinsam genutzte Warteschlangen, die Überwachungsdatenbank und die Persistenzdatenbank für die Orchestrierung).

Wichtig

  • Soll BizTalk Server 2000 auf einem Computer unter Microsoft Windows 2000 Professional mit Service Pack 1 installiert werden, müssen Sie SQL Server 7.0 mit SQL Server Service Pack 2 (SP2) oder SQL Server 2000 auf einem anderen Computer installieren. Windows 2000 Professional unterstützt keine SQL Server 7.0- oder SQL Server 2000-Installationen. Beim Installieren der Datenbanken für BizTalk Server 2000 müssen Sie den Namen des Computers angeben, auf dem SQL Server 7.0 bzw. SQL Server 2000 installiert ist.

Stellen Sie vor der Installation von SQL Server sicher, dass das Anmeldekonto Mitglied der Windows 2000-Administratorengruppe auf dem Computer, auf dem SQL Server installiert werden soll, ist. Weitere Informationen zum Hinzufügen des Anmeldekontos zur Administratorengruppe finden Sie unter Hinzufügen eines Benutzerkontos zur Administratorengruppe.

Bei der Installation von SQL Server 2000 müssen Sie eine gemischte Authentifizierung festlegen. Standardmäßig wird der Authentifizierungsmodus während der SQL Server 2000-Installation auf Nur Windows festgelegt. BizTalk Server 2000 verwendet die SQL-Authentifizierung für den Zugriff auf die BizTalk-Messaging-Verwaltungsdatenbank, die Datenbank für gemeinsam genutzte Warteschlangen sowie die Überwachungsdatenbank und kann mit dieser Einstellung nicht arbeiten. Stellen Sie sicher, dass ein gemischter Authentifizierungsmodus festgelegt wurde, bevor Sie BizTalk Server 2000 installieren. Weitere Informationen finden Sie unter Festlegen des SQL-Authentifizierungsmodus für SQL Server 2000.

Wenn SQL Server auf einem Cluster installiert wurde und BizTalk Server 2000 auf einem anderen Computer installiert werden soll, müssen Sie die SQL Server-Clienttools auf dem Computer mit BizTalk Server 2000 installieren. Unter einem Cluster versteht man mehrere Server, die als ein einzelner Server fungieren. Weitere Informationen finden Sie unter Installieren der SQL Server-Clienttools. Nach Abschluss der Installation müssen Sie die SQL Server-Clientkonfiguration verwenden, um die Standard-Netzwerkbibliothek von Named Pipes in TCP/IP zu ändern. Weitere Informationen finden Sie unter Ändern der Standard-Netzwerkbibliothek in TCP/IP.

Bei der Installation von SQL Server 7.0 oder SQL Server 2000 ist es wichtig, die richtigen Sortierungseinstellungen zu verwenden. "Sortierung" verweist auf eine Gruppe von Regeln, die ermittelt, wie Daten sortiert und verglichen werden. Zeichendaten werden mithilfe von Regeln sortiert, die die korrekte Zeichenreihenfolge definieren, wobei angegeben werden kann, dass in Bezug auf Groß-/Kleinschreibung, Akzente, Kanazeichentypen und Zeichenbreite unterschieden werden soll. Um beispielsweise japanische Zeichen zu speichern, wählen Sie eine Sortierreihenfolge aus, bei der die Groß-/Kleinschreibung beachtet wird, um bei der Einrichtung von SQL Server zwischen Hiraganazeichen und Katakanazeichen zu unterscheiden. Weitere Informationen zu Sortierungseinstellungen erhalten Sie, indem Sie im Startmenü auf Programme zeigen, dann auf Microsoft SQL Server zeigen und anschließend auf Onlinedokumentation klicken. Unter den Themen "Verwenden von SQL-Sortierungen" und "Sortierarten für Windows-Sortierung" finden Sie zusätzliche Information.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Installieren von SQL Server 7.0 oder SQL Server 2000

  • Suchen nach SQL Server 7.0 Service Pack 2

  • Installieren von Service Pack 2 für SQL Server 7.0

  • Installieren der SQL Server-Clienttools

  • Ändern der Standard-Netzwerkbibliothek in TCP/IP

  • Festlegen des SQL-Authentifizierungsmodus für SQL Server 2000

  • Überprüfen der Ausführung von SQL Server

  • Vermeiden unnötiger Speicherplatzreservierung

  • Interaktionen zwischen SQL Server und BizTalk Server 2000-Datenbanken


Installieren von SQLServer7.0 oder SQLServer2000

BizTalk Server-Kopfzeile

Installieren von SQL Server 7.0 oder SQL Server 2000

Legen Sie die Microsoft SQL Server-CD in das entsprechende Laufwerk ein.

  1. Führen Sie das Setup-Programm für SQL Server aus, und folgen Sie den Anweisungen auf dem Bildschirm.

    Der Setup-Assistent führt Sie durch die SQL Server-Installation, jedoch müssen Sie folgende Einstellungen vornehmen:

    • Klicken Sie auf der Seite Setup-Typ auf Standard.

    • Verwenden Sie auf der Seite Dienstkonten ein Domänenbenutzerkonto (falls eine Verbindung zu einem Netzwerk besteht).

    • Geben Sie bei der Installation von SQL Server 2000 eine gemischte Authentifizierung an.

Wichtig

  • Bei Installation von SQL Server 7.0 müssen Sie auch das SQL Service Pack 2 (SP2) installieren. Mithilfe von Query Analyzer können Sie feststellen, ob SP2 installiert ist. Weitere Informationen finden Sie unter Suchen nach SQL Server 7.0 Service Pack 2. Weitere Informationen zur Installation von SQL SP2 finden Sie unter Installieren von Service Pack 2 für SQL Server 7.0.


Suchen nach SQLServer7.0 Service Pack2

BizTalk Server-Kopfzeile

Suchen nach SQL Server 7.0 Service Pack 2

  1. Zeigen Sie im Startmenü auf Programme, zeigen Sie auf Microsoft SQL Server 7.0, und klicken Sie dann auf Query Analyzer.

    Das Dialogfeld Verbindung mit SQL Server herstellen wird angezeigt.

  2. Klicken Sie auf OK.

    Wird der Servername in der Liste SQL Server nicht angezeigt, wählen Sie ihn aus der Liste aus, oder geben Sie ihn ein. Klicken Sie anschließend auf OK.

  3. Geben Sie SELECT @@VERSION im Feld Abfrage ein.

  4. Klicken Sie im Menü Abfrage auf Ausführen.

    Die erste Zeile des Abfrageergebnisses enthält die aktuell ausgeführte Version von SQL Server. Ist SP2 installiert, wird 7.00.842 angezeigt.


Installieren von Service Pack2 für SQLServer7.0

BizTalk Server-Kopfzeile

Installieren von Service Pack 2 für SQL Server 7.0

  1. Legen Sie die SQL Service Pack 2-CD in das entsprechende Laufwerk ein.

  2. Führen Sie das Setup-Programm für das SQL Service Pack 2 aus, und folgen Sie den Anweisungen auf dem Bildschirm.


Installieren der SQLServer-Clienttools

BizTalk Server-Kopfzeile

Installieren der SQL Server-Clienttools

  1. Legen Sie die Microsoft SQL Server-CD in das entsprechende Laufwerk ein.

  2. Führen Sie das Setup-Programm für SQL Server aus, und folgen Sie den Anweisungen auf dem Bildschirm.

    Der Setup-Assistent führt Sie durch die SQL Server-Installation, jedoch müssen Sie folgende Einstellungen vornehmen:

    • Klicken Sie auf der Seite Installationsauswahl auf Eine neue Instanz von SQL Server erstellen oder Clienttools installieren.

    • Klicken Sie auf der Seite Installationsdefinition auf Nur Clienttools.


Ändern der Standard-Netzwerkbibliothek in TCP/IP

  1. Zeigen Sie im Startmenü auf Programme, zeigen Sie auf Microsoft SQL Server 7.0 oder Microsoft SQL Server, und klicken Sie dann auf SQL Server-Clientkonfiguration.

    Das Dialogfeld SQL Server-Clientkonfiguration wird angezeigt.

  2. Wenn Sie Microsoft SQL Server 7.0 installiert haben, klicken Sie auf der Registerkarte Allgemein in der Liste Standard-Netzwerkbibliothek auf TCP/IP.

    Oder

    Wenn Sie Microsoft SQL Server 2000 installiert haben, klicken Sie auf der Registerkarte Netzwerkbibliotheken in der Liste Netzwerkbibliothek auf TCP/IP.

  3. Klicken Sie auf OK.


Festlegen des SQL-Authentifizierungsmodus für SQLServer2000

BizTalk Server-Kopfzeile

Festlegen des SQL-Authentifizierungsmodus für SQL Server 2000

  1. Klicken Sie auf Start, zeigen Sie auf Programme, dann auf Microsoft SQL Server, und klicken Sie anschließend auf Enterprise Manager.

  2. Klicken Sie auf das Erweiterungssymbol (+) für Microsoft SQL Servers und für SQL Server-Gruppe.

  3. Klicken Sie mit der rechten Maustaste auf den Namen des Servers, und klicken Sie auf Eigenschaften.

    Das Dialogfeld SQL Server-Eigenschaften (Konfigurieren) - <Servername> wird angezeigt.

  4. Klicken Sie auf die Registerkarte Sicherheit, klicken Sie auf SQL Server und Windows, und klicken Sie dann auf OK.


Überprüfen der Ausführung von SQLServer

BizTalk Server-Kopfzeile

Überprüfen der Ausführung von SQL Server

Vor der Installation von BizTalk Server 2000 müssen Sie überprüfen, ob SQL Server auf dem Server ausgeführt wird. Dies ist notwendig, da BizTalk Server 2000 während der Installation vier SQL-Datenbanken erstellt.

  1. Zeigen Sie im Startmenü auf Programme, zeigen Sie auf Microsoft SQL Server (wenn Sie SQL Server 2000 installiert haben) oder Microsoft SQL Server 7.0 (wenn Sie SQL Server 7.0 installiert haben), und klicken Sie dann auf Dienst-Manager.

    Das Dialogfeld SQL Server-Dienst-Manager wird angezeigt.

  2. Überprüfen Sie in der Liste Server, ob es sich bei dem Namen des Servers um den Namen Ihres Computers handelt.

    Ist dies nicht der Fall, klicken Sie auf den nach unten zeigenden Pfeil, um eine Liste aller verfügbaren Server anzuzeigen, und suchen Sie nach dem entsprechenden Server.

  3. Klicken Sie in der Liste Dienste auf MSSQLServer (für SQL Server 7.0) oder SQL Server (für SQL Server 2000).

  4. Stellen Sie sicher, dass der MSSQLServer- bzw. der SQL Server-Dienst ausgeführt wird.

    Der Dienst wird ausgeführt, wenn im Dialogfeld die Schaltfläche Starten/Weiter nicht verfügbar ist. Außerdem wird unten im Dialogfeld eine Meldung angezeigt, die besagt, dass der Dienst ausgeführt wird. Zum Beispiel: Wird ausgeführt - \\<Servername> - MSSQLServer.

  5. Wird der Dienst nicht ausgeführt, ist die Schaltfläche Starten/Weiter verfügbar. Klicken Sie darauf, um den Dienst zu starten.


Vermeiden unnötiger Speicherplatzreservierung

  1. Klicken Sie auf Start, zeigen Sie auf Programme, dann auf Microsoft SQL Server 7.0 oder Microsoft SQL Server, und klicken Sie dann auf Enterprise Manager.

  2. Klicken Sie auf das Erweiterungssymbol (+) für Microsoft SQL Servers, SQL Server-Gruppe, <Servername> und Datenbanken.

  3. Klicken Sie mit der rechten Maustaste auf die BizTalk-Messaging-Verwaltungsdatenbank, und klicken Sie auf Eigenschaften.

    Das Dialogfeld Eigenschaften der BizTalk-Messaging-Verwaltungsdatenbank wird angezeigt.

  4. Klicken Sie auf die Registerkarte Optionen.

  5. Aktivieren Sie im Bereich Einstellungen die Kontrollkästchen Protokoll bei Prüfpunkt abschneiden und Automatisch verkleinern, und klicken Sie auf OK.

    Anmerkung

    • Wenn Sie Microsoft SQL Server 2000 installiert haben, können Sie nur das Kontrollkästchen Automatisch verkleinern aktivieren.
  6. Wiederholen Sie die Schritte 3 bis 5 für die Überwachungsdatenbank und die Datenbank für gemeinsam genutzte Warteschlangen.

Wichtig

  • Sie können dieses Verfahren nur abschließen, wenn Sie BizTalk Server 2000 installiert haben. Weitere Informationen zur Installation von BizTalk Server 2000 finden Sie unter Installationsanweisungen.

Anmerkung

  • Bei der Installation erhält die BizTalk-Messaging-Verwaltungsdatenbank standardmäßig den Namen InterchangeBTM, die Überwachungsdatenbank den Namen InterchangeDTA und die Datenbank für gemeinsam genutzte Warteschlangen den Namen InterchangeSQ. Möglicherweise haben Sie diesen Datenbankobjekten während der Installation andere Namen gegeben.


Interaktionen zwischen SQLServer und BizTalk Server2000-Datenbanken

BizTalk Server-Kopfzeile

Interaktionen zwischen SQL Server und BizTalk Server 2000-Datenbanken

Verwenden Sie die Optionen Protokoll bei Prüfpunkt abschneiden und Automatisch verkleinern von Microsoft SQL Server, um unnötige Speicherplatzreservierungen zu vermeiden. Andernfalls können die SQL Server-Protokolle sehr viel Speicherplatz belegen.

Verwandtes Thema

Vermeiden unnötiger Speicherplatzreservierung


Installieren von Visio2000 SR-1A

BizTalk Server-Kopfzeile

Installieren von Visio 2000 SR-1A

Da es sich bei dem BizTalk-Orchestrierungs-Designer um eine Benutzeroberfläche handelt, die auf Microsoft Visio 2000 basiert, muss Visio 2000 Service Release 1A auf Ihrem Computer installiert werden, bevor Sie den BizTalk-Orchestrierungs-Designer verwenden können. Der BizTalk-Orchestrierungs-Designer wurde mit Visio 2000 Standard Edition SR-1A getestet und funktioniert aller Voraussicht nach auch mit höheren Versionen von Visio.

Folgendes Thema wird in diesem Abschnitt behandelt:

  • Installieren von Visio 2000 Standard Edition SR-1A


Installieren von Visio2000 Standard Edition SR-1A

BizTalk Server-Kopfzeile

Installieren von Visio 2000 Standard Edition SR-1A

  1. Legen Sie die Visio 2000 Standard Edition SR-1A-CD (oder eine höhere Version von Visio 2000 Standard Edition) in das entsprechende Laufwerk ein.

  2. Führen Sie das Setup-Programm für Visio 2000 Standard Edition SR-1A aus, und folgen Sie den Anweisungen auf dem Bildschirm.

Anmerkung

  • Weitere Informationen finden Sie in der Dokumentation zu Microsoft Visio 2000 Standard Edition SR-1A.


Installationsanweisungen

Sie können bei der Installation von Microsoft BizTalk Server 2000 den Installations-Assistenten (Microsoft BizTalk Server.msi) oder den Microsoft Windows Installer (Msiexec.exe) verwenden. Der Installations-Assistent ist ein schrittweiser Prozess, bei dem Sie Optionen auswählen, die bestimmten Eigenschaftswerten entsprechen. Der Microsoft Windows Installer erlaubt Ihnen das Festlegen von Eigenschaftswerten in der Befehlszeile. Mit dieser Methode können Sie BizTalk Server 2000 ohne Aufsicht (d. h. ohne ständige Interaktion oder Aufforderungen) installieren. Eine unbeaufsichtigte Installation von BizTalk Server 2000 ist ideal für Testszenarien oder bei einer unternehmensweiten Installation. Unabhängig von der durchgeführten Installation sollten Sie sich jedoch die folgenden Informationen notieren, damit Sie später darauf zurückgreifen können:

  • BizTalk Server-Gruppennamen

  • SQL Server-Namen

  • Benutzernamen

  • Kennwörter

  • Den Namen der BizTalk-Messaging-Verwaltungsdatenbank

  • Den Namen der Überwachungsdatenbank

  • Den Namen der Datenbank für gemeinsam genutzte Warteschlangen

  • Den URL für das WebDAV-Repository

Wichtig

  • Für BizTalk Server 2000 ist Microsoft XML Parser, Version 3.0, erforderlich. Bei dieser Version von BizTalk Server 2000 wird Microsoft XML (MSXML) Parser, Version 3.0, automatisch installiert. Falls Sie andere Versionen des MSXML-Parsers installieren, kann dies zu unerwarteten Ergebnissen mit BizTalk Server 2000 führen.

Anmerkung

  • Während der BizTalk Server 2000-Installation ermittelt das Installationsprogramm den verfügbaren Festplattenspeicher auf Ihrem Computer. Für eine vollständige Installation sind ca. 52 Megabyte (MB) erforderlich, wobei die Anforderungen für die BizTalk-Messaging-Verwaltungsdatenbank, die Überwachungsdatenbank, die Datenbank für gemeinsam genutzte Warteschlangen und die Persistenzdatenbank für die Orchestrierung noch nicht berücksichtigt sind. Eine Tools-Installation erfordert ca. 30 MB Festplattenspeicher. Für eine benutzerdefinierte Installation sind (ausschließlich Datenbankanforderungen) zwischen 2 und 52 MB Festplattenspeicher erforderlich, abhängig von den Diensten und Tools, die Sie installieren.

Bevor Sie Setup ausführen, sollten Sie sicherstellen, dass das Anmeldekonto Mitglied der Windows 2000-Administratorengruppe auf dem Computer, auf dem Sie BizTalk Server 2000 installieren, ist. Weitere Informationen zum Hinzufügen von Konten zur Administratorengruppe finden Sie unter Hinzufügen eines Benutzerkontos zur Administratorengruppe.

Anmerkung

  • Wurde BizTalk Server mithilfe eines interaktiven Benutzers installiert, ist ein Start nur möglich, wenn ein Benutzer an BizTalk Server 2000 angemeldet ist. Alle COM+-Pakete werden unter einem interaktiven Benutzerkonto ausgeführt, nicht unter dem lokalen Systemkonto. Der Dienst wird also nur gestartet, wenn ein Benutzer an BizTalk Server 2000 angemeldet ist. Ist kein Benutzer an BizTalk Server 2000 angemeldet, wenn eine Remoteclientanwendung Dokumente an BizTalk Server 2000 sendet, wird der Dienst nicht gestartet. Um eine solche Situation zu vermeiden, haben Sie zwei Möglichkeiten: Sie können ein Dienstkonto erstellen, oder Sie können den Benutzer, der den Dienst startet, den Computer sperren lassen, so dass die Dienste im Hintergrund ausgeführt werden. Weitere Informationen zum Erstellen eines Dienstkontos finden Sie unter Erstellen eines Dienstkontos.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Vollständige Installation

  • Tools-Installation

  • Benutzerdefinierte Installation

  • Unbeaufsichtigte Installation

  • Entfernen von BizTalk Server 2000


Vollständige Installation

Im folgenden Abschnitt wird die Ausführung einer vollständigen Installation von BizTalk Server 2000 beschrieben, einschließlich sämtlicher BizTalk-Dienste, -Tools und -Beispiele.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Ausführen einer vollständigen Installation von BizTalk Server 2000

  • Starten des WWW-Publishingdienstes

  • Remoteinstallation der BizTalk-Dokumentüberwachung


Ausführen einer vollständigen Installation von BizTalk Server2000

BizTalk Server-Kopfzeile

Ausführen einer vollständigen Installation von BizTalk Server 2000

  1. Legen Sie die Microsoft BizTalk Server 2000-Setup-CD in das entsprechende Laufwerk ein.

  2. Führen Sie das Setup-Programm für Microsoft BizTalk Server 2000 aus, und folgen Sie den Anweisungen auf dem Bildschirm.

    Wichtig

    • Der Setup-Assistent führt Sie durch die Installation von BizTalk Server 2000. Dabei müssen Sie jedoch die in den folgenden Schritten beschriebenen Einstellungen vornehmen.

    • Für BizTalk Server 2000 ist Microsoft XML Parser, Version 3.0, erforderlich. Bei dieser Version von BizTalk Server 2000 wird Microsoft XML (MSXML) Parser, Version 3.0, automatisch installiert. Falls Sie andere Versionen des MSXML-Parsers installieren, kann dies zu unerwarteten Ergebnissen mit BizTalk Server 2000 führen.
  3. Lesen Sie auf der Seite Lizenzvertrag den Lizenzvertrag, klicken Sie auf Ich stimme dem Lizenzvertrag zu, und klicken Sie dann auf Weiter.

    Anmerkung

    • Falls Sie dem Lizenzvertrag nicht zustimmen, können Sie die Installation nicht fortsetzen.
  4. Geben Sie auf der Seite Kundeninformationen Ihren Namen in das Feld Benutzername ein, geben Sie den Namen Ihrer Firma in das Feld Organisation ein, klicken Sie entweder auf Jeden Benutzer dieses Computers (alle Benutzer) oder auf Nur für mich, wenn Sie den Zugriff auf BizTalk Server 2000 einschränken wollen, und klicken Sie anschließend auf Weiter.

  5. Klicken Sie auf der Seite Zielordner auf Weiter, um BizTalk Server 2000 in dem auf der Seite angezeigten Ordner zu installieren, oder klicken Sie auf Ändern, um einen anderen Speicherort auszuwählen.

  6. Klicken Sie auf der Seite Setup-Typ auf Vollständig, und klicken Sie dann auf Weiter.

  7. Geben Sie im Feld Gruppenname auf der Seite Administratorzugriff für BizTalk Server konfigurieren den Gruppennamen ein, den Sie verwenden möchten (oder übernehmen Sie den Standardnamen BizTalk Server-Administratoren).

    Anmerkungen

    • Beim Festlegen von Gruppennamen gelten die folgenden Beschränkungen:

    • Der Gruppenname darf nicht mit einem anderen Gruppen- oder Benutzernamen auf diesem Computer übereinstimmen.

    • Der Gruppenname darf keines der folgenden Zeichen enthalten: ` ! @ # $ % ^ & * ( ) + = [ ] { } | \\ ;\" '< > , . ?

    • Der Gruppenname darf nicht nur aus Punkten (.) oder Leerzeichen bestehen.

    • Sie dürfen diese Gruppe nicht umbenennen, ohne nicht auch den Wert AdminGroupName in der Windows-Registrierung unter HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\BizTalk Server\1.0\NTGroups zu ändern. BizTalk Server 2000 benötigt diesen Registrierungsschlüssel, um die Gruppe zu finden.
  8. Geben Sie im Feld Gruppenbeschreibung eine neue Beschreibung für den Gruppennamen ein, oder übernehmen Sie die Standardbeschreibung, und klicken Sie dann auf Weiter.

  9. Klicken Sie auf der Seite Anmeldeeigenschaften des BizTalk Server-Dienstes auf die Standardeinstellung Lokales Systemkonto, oder klicken Sie auf Dieses Konto, um den Zugriff auf BizTalk Server 2000 auf einen bestimmten Benutzer zu beschränken.

    Wenn Sie Dieses Konto auswählen, geben Sie einen neuen Benutzernamen ein, oder übernehmen Sie den Standardnamen im Feld Benutzername, und geben Sie anschließend im Feld Kennwort ein gültiges Kennwort ein.

    Sollen die BizTalk-Dienste nicht unmittelbar nach Abschluss der Installation gestartet werden, deaktivieren Sie das Kontrollkästchen Dienst nach Abschluss der Installation starten. Die BizTalk-Dienste werden nicht automatisch gestartet, aber die Orchestrierungsdienste werden gestartet.

    Anmerkungen

    • Während der BizTalk Server-Installation werden dem auf der Seite Anmeldeeigenschaften des BizTalk Server-Dienstes angegebenen Konto die Berechtigungen Als Dienst anmelden und Einsetzen als Teil des Betriebssystems erteilt.

    • Falls Sie Dieses Konto ausgewählt haben, geben Sie ein Konto an, das sich in der Windows 2000-Administratorengruppe befindet. Damit Sie Zertifikate für die S/MIME-Komponenten mithilfe des BizTalk-Messaging-Managers konfigurieren können, müssen Sie über ein Benutzerkonto in der Windows 2000-Administratorengruppe verfügen, und die BizTalk-Messagingdienste müssen unter einem lokalen Systemkonto oder einem Benutzerkonto in der Windows 2000-Administratorengruppe ausgeführt werden.
  10. Klicken Sie auf Weiter.

  11. Klicken Sie auf der Seite Bereit zum Installieren des Programms auf Installieren.

    Die BizTalk Server 2000-Installation kann mehrere Minuten in Anspruch nehmen.

  12. Wenn die Seite Willkommen beim Einrichtungs-Assistenten für BizTalk Server 2000-Messagingdatenbanken angezeigt wird, klicken Sie auf Weiter.

    Während der Installation der BizTalk Server 2000-Datenbanken werden Sie aufgefordert, Anmeldeinformationen (Server, Datenbank, Benutzername und Kennwort) für die Konfiguration der BizTalk-Messaging-Verwaltungsdatenbank, der Überwachungsdatenbank und der Datenbank für gemeinsam genutzte Warteschlangen anzugeben.

    Vorsicht

    • Ändern Sie den Code, z. B. gespeicherte Prozeduren oder Trigger, in der BizTalk-Messaging-Verwaltungsdatenbank, der Überwachungsdatenbank und der Datenbank für gemeinsam genutzte Warteschlangen nicht. Greifen Sie nicht direkt auf die Datenbank zu. Rufen Sie die gespeicherten Prozeduren nicht direkt auf. Nehmen Sie sämtliche Änderungen an der Datenbank mithilfe von Methoden und Eigenschaften des BizTalk-Messaging-Konfigurationsobjektmodells vor. Durch direkte Änderungen an der Datenbank werden vom BizTalk-Messaging-Konfigurationsobjektmodell erzwungene Einschränkungen umgangen, was Serverfehler verursachen oder die Datenbank beschädigen kann.
  13. Klicken Sie auf der Seite BizTalk-Messaging-Verwaltungsdatenbank konfigurieren entweder auf Neue BizTalk-Messaging-Verwaltungsdatenbank erstellen oder auf Vorhandene Datenbank auswählen, und geben Sie in den folgenden Textfeldern einen Servernamen and Benutzerinformationen ein:
    • Servername

    • Benutzername

    • Kennwort

    • Datenbank

    Sie können eindeutige Server- und Datenbanknamen auswählen, wobei Sie entweder neue Informationen eingeben oder die Standardeinstellungen übernehmen.

    Wichtig

    • Wird BizTalk Server 2000 auf einem Computer unter Microsoft Windows 2000 Professional mit Service Pack 1 installiert, müssen Sie unter Servername den Namen des Computers angeben, auf dem Microsoft SQL Server 7.0 bzw. Microsoft SQL Server 2000 installiert ist.

    • Wenn Sie Neue BizTalk-Messaging-Verwaltungsdatenbank erstellen und dann eine vorhandene Datenbank auswählen, müssen Sie den Inhalt der Datenbank manuell löschen. Weitere Informationen zum Löschen von Datenbankinhalten erhalten Sie, indem Sie im Startmenü auf Programme zeigen, dann auf Microsoft SQL Server zeigen und schließlich auf Onlinedokumentation klicken. Soll eine neue Datenbank denselben Namen erhalten wie eine vorhandene Datenbank auf demselben Server, empfiehlt es sich, den Datenbankinhalt manuell zu löschen. Beim BizTalk Server-Setup wird lediglich überprüft, ob eine von der Datenbank benötigte gespeicherte Prozedur existiert, nicht ob alle erforderlichen Variablen vorhanden sind. Ist eine gespeicherte Prozedur vorhanden, nimmt das Setupprogramm von BizTalk Server keine Änderungen an der Datenbank vor. Ist die gespeicherte Prozedur nicht vorhanden, wird die Datenbank vom Setupprogramm gelöscht. Anschließend werden die Tabellen der BizTalk-Messaging-Verwaltungsdatenbank neu initialisiert. Diese Informationen gelten auch für die Datenbank für gemeinsam genutzte Warteschlangen und die Überwachungsdatenbank.

    • Falls Sie mit mehreren Installationen von BizTalk Server arbeiten und die BizTalk-Messaging-Verwaltungsdatenbank zentral verwalten möchten, wird dringend empfohlen, dass Sie sich über die Interaktion zwischen BizTalk Server-Datenbanken informieren. Weitere Informationen zur Konfiguration der Datenbank finden Sie unter Ändern der BizTalk-Messaging-Verwaltungsdatenbank.
  14. Klicken Sie auf Weiter.

  15. Geben Sie auf der Seite BizTalk Server-Gruppe konfigurieren im Feld Gruppenname den gewünschten Namen für die BizTalk Server-Gruppe ein, oder übernehmen Sie die Standardeinstellung (BizTalk Server-Gruppe), und klicken Sie dann auf Weiter.

    Sie können auch auf Vorhandene BizTalk Server-Gruppe auswählen klicken und einen Namen aus der Liste Gruppenname auswählen.

    Anmerkung

    • Der Gruppenname darf keines der folgenden Zeichen enthalten: ` ! @ # $ % ^ & * ( ) + = [ ] { } | \\ ;\" '< > , . ?
  16. Wiederholen Sie auf der Seite Überwachungsdatenbank konfigurieren das Verfahren in Schritt 13, und klicken Sie auf Weiter.

    Wichtig

    • Falls Sie die Standardeinstellung für Benutzername auf der Seite Überwachungsdatenbank konfigurieren ändern, muss das angegebene Konto über SA-Berechtigungen verfügen. Dieses Konto wird verwendet, um eine SQL Server-Benutzeranmeldung zu erstellen. Nach der Installation von BizTalk Server können Sie den Namen und das Kennwort des Benutzerkontos ändern, um SA-Zugriff auf die Überwachungsdatenbank durch den BizTalk Server-Dienst zu verhindern. Weitere Informationen finden Sie unter Konfigurieren von Verbindungseigenschaften für eine Servergruppe. Sie können auch die SA-Berechtigung für das während der Installation verwendete Konto ändern. Weitere Informationen zum Ändern von Berechtigungen für SQL Server-Konten erhalten Sie, indem Sie im Startmenü auf Programme zeigen, dann auf Microsoft SQL Server zeigen und schließlich auf Onlinedokumentation klicken.
  17. Wiederholen Sie auf der Seite Datenbank für gemeinsam genutzte Warteschlangen konfigurieren das Verfahren in Schritt 13, und klicken Sie auf Weiter.

  18. Überprüfen Sie auf der Seite BizTalk Server-Gruppe überprüfen, ob die Informationen im Feld Eigenschaften der BizTalk Server-Gruppe korrekt sind, und klicken Sie auf Weiter.

  19. Klicken Sie auf der letzten Seite des Einrichtungs-Assistenten für BizTalk Server 2000-Messagingdatenbanken auf Fertig stellen, um die Konfiguration der BizTalk-Messaging-Verwaltungsdatenbank, der Überwachungsdatenbank und der Datenbank für gemeinsam genutzte Warteschlangen abzuschließen.

  20. Klicken Sie auf der Seite Willkommen beim Einrichtungs-Assistenten für Persistenzdatenbanken für BizTalk Server 2000-Orchestrierung auf Weiter, um die Persistenzdatenbank für die Orchestrierung zu installieren.

    Anmerkung

    • Wenn Sie auf Abbrechen klicken, wird BizTalk Server 2000 zwar installiert, die Persistenzdatenbank für die Orchestrierung und der Datenquellenname jedoch nicht. Sie können die Datenbank und den Datenquellennamen später installieren. Weitere Informationen finden Sie unter Erstellen einer neuen Persistenzdatenbank, Konfigurieren der Standardanwendung XLANG-Ablaufplanung (XLANG Scheduler) und Konfigurieren einer COM+-Hostanwendung für XLANG-Ablaufpläne.
  21. Klicken Sie auf der Seite Standard-Persistenzdatenbank für die Orchestrierung konfigurieren entweder auf Neue Standard-Persistenzdatenbank für die Orchestrierung erstellen oder auf Vorhandene Datenbank auswählen. Anschließend können Sie einen Servernamen auswählen und Datenbankinformationen in den entsprechenden Textfeldern eingeben oder die Standardeinstellungen übernehmen.

    Wichtig

    • Wenn Sie Neue Standard-Persistenzdatenbank für die Orchestrierung erstellen und dann eine Datenbank auswählen, die denselben Namen besitzt wie eine vorhandene Datenbank auf demselben Server, wird der Inhalt dieser Datenbank vom BizTalk Server-Setupprogramm gelöscht. Anschließend werden die Tabellen der Persistenzdatenbank für die Orchestrierung vom BizTalk Server-Setupprogramm neu initialisiert.

    • Wird BizTalk Server 2000 auf einem Computer unter Windows 2000 Professional mit Service Pack 1 installiert, müssen Sie unter Servername den Namen des Computers angeben, auf dem SQL Server 7.0 bzw. SQL Server 2000 installiert ist.

    Anmerkungen

    • Die Persistenzdatenbank für die Orchestrierung wird auf der Basis der aktuellen Benutzeridentität erstellt.

    • Um SQL Server von einem Remotestandort aus verwenden zu können, sind entsprechende Berechtigungen für die Persistenzdatenbank für die Orchestrierung erforderlich. Berechtigungen werden dem interaktiven Benutzer gewährt (d. h. dem Benutzer, der während der Installation von BizTalk Server 2000 angemeldet war), es sei denn, Sie haben die Identität des XLANG-Ablaufplanungsmoduls neu konfiguriert. Wenn Sie die Identität des XLANG-Ablaufplanungsmoduls einem Dienstkonto oder einem anderen eindeutigen Benutzerkonto entsprechend konfiguriert haben, müssen Sie die Berechtigungen so festlegen, dass sie mit der neu konfigurierten Identität übereinstimmen.
  22. Klicken Sie auf Fertig stellen.

  23. Klicken Sie auf der letzten Seite des Microsoft BizTalk Server 2000 Setup-Assistenten auf Infodatei anzeigen, um die neuesten Informationen zu BizTalk Server 2000 zu lesen, und klicken Sie dann auf Fertig stellen.

Vorsicht

  • Ändern Sie die angegebene Identitätswechselebene für COM+-Anwendungen nicht. Standardmäßig ist Identität wechseln festgelegt. Durch Ändern der Sicherheitseigenschaft in Anonym, Identifizieren oder Delegieren können Probleme bei der Installation auftreten.

Wichtig

  • Wenn Sie die Leistung der BizTalk-Orchestrierungsdienste verbessern möchten, suchen Sie im Windows Explorer nach Programme\Gemeinsame Dateien\System\ado, und doppelklicken Sie dann auf adofre15.reg. Klicken Sie im Bestätigungsdialogfeld auf Ja, und klicken Sie dann auf OK. Durch dieses Verfahren ändert sich das ADO-Threadingmodell von "Apartment threaded" in "Both", was sich möglicherweise auch auf andere Anwendungen auswirkt, die ADO verwenden. Provider, die nicht threadsicher sind, können nicht verwendet werden.

Anmerkung

  • Der BizTalk-Messaging-Manager wird nur ausgeführt, wenn der WWW-Publishingdienst ebenfalls ausgeführt wird. Weitere Informationen zum WWW-Publishingdienst finden Sie unter Starten des WWW-Publishingdienstes.


Starten des WWW-Publishingdienstes

  1. Zeigen Sie im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Komponentendienste.

  2. Klicken Sie in der Konsolenstruktur auf Dienste (Lokal).

  3. Klicken Sie im Detailbereich mit der rechten Maustaste auf WWW-Publishingdienst, und klicken Sie dann auf Starten.


Remoteinstallation der BizTalk-Dokumentüberwachung

Bei Installation der BizTalk-Dokumentüberwachung von der BizTalk Server 2000-CD aus wird in der Programmgruppe für BizTalk Server 2000 eine Verknüpfung erstellt, über die auf die BizTalk-Dokumentüberwachung-Webanwendung zugegriffen werden kann. Wird die BizTalk-Dokumentüberwachung jedoch über das Internet installiert, müssen Sie manuell eine Verknüpfung oder einen Favoriten erstellen, um auf die Webanwendung zugreifen zu können. Darüber hinaus müssen Sie die Browsereinstellungen manuell so konfigurieren, dass dieser Webanwendung vertraut wird. Andernfalls werden Dialogfelder mit Sicherheitswarnungen angezeigt.

Folgendes Thema wird in diesem Abschnitt behandelt:

  • Konfigurieren der Internet Explorer-Sicherheitseinstellungen


Konfigurieren der Internet Explorer-Sicherheitseinstellungen

  1. Klicken Sie auf Start, zeigen Sie auf Programme, und klicken Sie dann auf Internet Explorer.

  2. Klicken Sie im Menü Extras auf Internetoptionen.

    Das Dialogfeld Internetoptionen wird angezeigt.

  3. Klicken Sie auf der Registerkarte Sicherheit auf Vertrauenswürdige Sites und dann auf die Schaltfläche Sites.

    Das Dialogfeld Vertrauenswürdige Sites wird angezeigt.

  4. Geben Sie im Feld Diese Website zur Zone hinzufügen den Standort des Servers mit der BizTalk-Dokumentüberwachung ein.

    Zeigen Sie im Startmenü auf Programme, zeigen Sie auf Microsoft BizTalk Server 2000, und klicken Sie auf BizTalk-Dokumentüberwachung, um den Standort des Servers mit der BizTalk-Dokumentüberwachung zu ermitteln. Der Standort dieses Servers wird in der Liste Adresse angezeigt.

  5. Deaktivieren Sie das Kontrollkästchen Für die Sites in dieser Zone ist eine Serverüberprüfung (https:) erforderlich.

  6. Klicken Sie auf Hinzufügen und dann zweimal auf OK, um die Dialogfelder zu schließen.


Tools-Installation

Mit einer Microsoft BizTalk Server 2000-Tools-Installation können Sie nur den BizTalk-Orchestrierungs-Designer, die BizTalk-Dokumentüberwachung, den BizTalk-Editor, den BizTalk-Mapper und die BizTalk Server 2000-Hilfe installieren.

Folgendes Thema wird in diesem Abschnitt behandelt:

  • Ausführen einer Tools-Installation von BizTalk Server 2000


Ausführen einer Tools-Installation von BizTalk Server2000

BizTalk Server-Kopfzeile

Ausführen einer Tools-Installation von BizTalk Server 2000

  1. Legen Sie die Microsoft BizTalk Server 2000-Setup-CD in das entsprechende Laufwerk ein, und folgen Sie den Anweisungen auf dem Bildschirm.

    Wichtig

    • Der Setup-Assistent führt Sie durch die Installation von BizTalk Server 2000. Dabei müssen Sie die in den folgenden Schritten beschriebenen Einstellungen vornehmen.
  2. Lesen Sie auf der Seite Lizenzvertrag den Lizenzvertrag, klicken Sie auf Ich stimme dem Lizenzvertrag zu, und klicken Sie dann auf Weiter.

    Anmerkung

    • Falls Sie dem Lizenzvertrag nicht zustimmen, können Sie die Installation nicht fortsetzen.
  3. Geben Sie auf der Seite Kundeninformationen Ihren Namen in das Feld Benutzername ein, geben Sie den Namen Ihrer Firma in das Feld Organisation ein, klicken Sie auf Jeden Benutzer dieses Computers (alle Benutzer) oder auf Nur für mich, wenn Sie den Zugriff auf BizTalk Server 2000 einschränken wollen, und klicken Sie anschließend auf Weiter.

  4. Klicken Sie auf der Seite Zielordner auf Weiter.

  5. Klicken Sie auf der Seite Setup-Typ auf Tools, und klicken Sie dann auf Weiter.

  6. Klicken Sie auf der Seite Bereit zum Installieren des Programms des Microsoft BizTalk Server 2000 Setup-Assistenten auf Installieren.

  7. Klicken Sie auf der letzten Seite des Microsoft BizTalk Server 2000 Setup-Assistenten auf Infodatei anzeigen, um die neuesten Informationen zu dieser Version von BizTalk Server 2000 zu lesen.

  8. Klicken Sie auf Fertig stellen, um den Installationsprozess abzuschließen.

Wichtig

  • Wenn Sie die Leistung der BizTalk-Orchestrierungsdienste verbessern möchten, suchen Sie im Windows Explorer nach Programme\Gemeinsame Dateien\System\ado, und doppelklicken Sie dann auf adofre15.reg. Klicken Sie im Bestätigungsdialogfeld auf Ja, und klicken Sie dann auf OK. Durch dieses Verfahren ändert sich das ADO-Threadingmodell von "Apartment threaded" in "Both", was sich auch auf andere Anwendungen, die ADO verwenden, auswirken kann.

Anmerkung

  • Verwenden Sie den Windows 2000 Export-Assistenten für COM-Anwendungen, um die BizTalk Server 2000-Austauschkomponenten auf einem Remotecomputer zu installieren.
    1. Zeigen Sie im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Komponentendienste.

    2. Erweitern Sie in der Konsolenstruktur Komponentendienste, Computer, Arbeitsplatz und COM+-Anwendungen.

    3. Klicken Sie mit der rechten Maustaste auf BizTalk Server Interchange Application, und klicken Sie dann auf Exportieren.

      Folgen Sie den Anweisungen auf dem Bildschirm, um eine MSI-Datei zu erstellen, die auf einem Clientcomputer ausgeführt werden kann.


Benutzerdefinierte Installation

Bei einer benutzerdefinierten Microsoft BizTalk Server 2000-Installation können Sie alle Features von BizTalk Server 2000 installieren oder nur bestimmte Features.

Anmerkung

  • Bevor Sie die Serverkomponenten von BizTalk Server 2000 installieren können, müssen Sie Microsoft SQL Server installieren. Weitere Informationen finden Sie unter Installieren von SQL Server 7.0 oder SQL Server 2000.

Folgendes Thema wird in diesem Abschnitt behandelt:

  • Ausführen einer benutzerdefinierten Installation von BizTalk Server 2000


Ausführen einer benutzerdefinierten Installation von BizTalk Server2000

BizTalk Server-Kopfzeile

Ausführen einer benutzerdefinierten Installation von BizTalk Server 2000

  1. Legen Sie die Microsoft BizTalk Server 2000-Setup-CD in das entsprechende Laufwerk ein, und folgen Sie den Anweisungen auf dem Bildschirm.

    Wichtig

    • Der Setup-Assistent führt Sie durch die Installation von BizTalk Server 2000. Dabei müssen Sie die in den folgenden Schritten beschriebenen Einstellungen vornehmen.
  2. Lesen Sie auf der Seite Lizenzvertrag den Lizenzvertrag, klicken Sie auf Ich stimme dem Lizenzvertrag zu, und klicken Sie dann auf Weiter.

    Anmerkung

    • Falls Sie dem Lizenzvertrag nicht zustimmen, können Sie die Installation nicht fortsetzen.
  3. Geben Sie auf der Seite Kundeninformationen Ihren Namen in das Feld Benutzername ein, geben Sie den Namen Ihrer Firma in das Feld Organisation ein, klicken Sie auf Jeden Benutzer dieses Computers (alle Benutzer) oder auf Nur für mich, wenn Sie den Zugriff auf BizTalk Server 2000 einschränken wollen, und klicken Sie anschließend auf Weiter.

  4. Klicken Sie auf der Seite Zielordner auf Weiter.

  5. Klicken Sie auf der Seite Setup-Typ auf Benutzerdefiniert, und klicken Sie dann auf Weiter.

  6. Folgen Sie auf der Seite Benutzerdefinierte Installation den Anweisungen auf dem Bildschirm, um die zu installierenden BizTalk Server 2000-Komponenten auszuwählen.

    Um einen anderen Installationstyp auszuführen, klicken Sie auf Zurück. Andernfalls klicken Sie auf Weiter. Abhängig von den ausgewählten Installationskomponenten werden weitere Seiten mit zusätzlichen Informationen angezeigt.

  7. Klicken Sie auf der Seite Bereit zum Installieren des Programms auf Installieren.

    Die benutzerdefinierte Installation von BizTalk Server 2000 kann einige Minuten in Anspruch nehmen.

  8. Klicken Sie auf der letzten Seite des Microsoft BizTalk Server 2000 Setup-Assistenten auf Infodatei anzeigen, um die neuesten Informationen zu dieser Version von Microsoft BizTalk Server 2000 zu lesen.

  9. Klicken Sie auf Fertig stellen, um den Installationsprozess abzuschließen.

Wichtig

  • BizTalk-Messaging-Manager wird nur ausgeführt, wenn der WWW-Publishingdienst ebenfalls ausgeführt wird. So starten Sie den WWW-Publishingdienst
    1. Zeigen Sie im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Komponentendienste.

    2. Klicken Sie in der Konsolenstruktur auf Dienste (Lokal).

    3. Klicken Sie im Detailbereich mit der rechten Maustaste auf WWW-Publishingdienst, und klicken Sie auf Starten.
  • Wenn Sie die Leistung der BizTalk-Orchestrierungsdienste verbessern möchten, suchen Sie im Windows Explorer nach Programme\Gemeinsame Dateien\System\ado, und doppelklicken Sie dann auf adofre15.reg. Klicken Sie im Bestätigungsdialogfeld auf Ja, und klicken Sie dann auf OK. Durch dieses Verfahren ändert sich das ADO-Threadingmodell von "Apartment threaded" in "Both", was sich auch auf andere Anwendungen, die ADO verwenden, auswirken kann.


Unbeaufsichtigte Installation

Der Microsoft Windows Installer erlaubt Ihnen das Festlegen von Eigenschaftswerten in der Befehlszeile. Diese Methode gibt Ihnen die Möglichkeit, Microsoft BizTalk Server 2000 ohne Aufsicht (d. h. ohne ständige Interaktion oder Aufforderungen) zu installieren. Eine unbeaufsichtigte Installation von BizTalk Server 2000 ist ideal für Testszenarien oder bei einer unternehmensweiten Installation.

Folgendes Thema wird in diesem Abschnitt behandelt:

  • Ausführen einer unbeaufsichtigten Installation von BizTalk Server 2000


Ausführen einer unbeaufsichtigten Installation von BizTalk Server2000

BizTalk Server-Kopfzeile

Ausführen einer unbeaufsichtigten Installation von BizTalk Server 2000

  1. Klicken Sie auf Start und dann auf Ausführen.

  2. Geben Sie cmd in das Feld Öffnen ein, und klicken Sie auf OK.

  3. Nehmen Sie die folgende Eingabe vor, um eine unbeaufsichtigte Installation von BizTalk Server 2000 durchzuführen:
    msiexec /I "\\server\folder\Microsoft BizTalk Server.msi"
/qb /Lv*"C:\Temp\install.log" INSTALLLEVEL=200
ALLUSERS=1
PIDKEY="Aus 25 Zeichen bestehender Produktschlüssel (ohne Striche)"
DSNCONFIG="C:\Temp\BizTalkInstall.ini"

Wichtig

  • Fügen Sie den Parameter ALLUSERS=1 hinzu, um die Installation für alle Benutzer abzuschließen. Darüber hinaus wird durch diesen Parameter sichergestellt, dass die Dienste die Registrierungseinstellungen sehen können.

Anmerkungen

  • Der obige Code enthält die folgenden Optionen:
    • /I ist die Befehlszeile für die Installation oder Konfiguration eines Produkts.

    • /qb ist die Befehlszeile für die Darstellung einer einfachen Benutzeroberfläche (nur Statusanzeige).

    • /Lv* erstellt eine Protokolldatei.

    • INSTALLLEVEL=200 installiert den Server. Wenn Sie für INSTALLLEVEL keinen Wert angeben, wird der Standardwert 100 verwendet, welcher der Tools-Installation von BizTalk Server 2000 entspricht.

    • PIDKEY="Aus 25 Zeichen bestehender Produktschlüssel (ohne Striche)" ist der Produktschlüssel, z. B. PIDKEY=AB6CDEFGH7IJK8LMN45LLTT34.

    • DSNCONFIG="C:\Temp\BizTalkInstall.ini" stellt Installationsinformationen für den Setup-Assistenten bereit.

In der Befehlszeile können Sie verschiedene Optionen angeben, um Eigenschaften für eine BizTalk Server 2000-Installation festzulegen. Für Eigenschaften, die nicht festgelegt wurden, werden die Standardwerte verwendet. Spezielle BizTalk Server 2000-Eigenschaften werden in der folgenden Tabelle aufgelistet.

Öffentliche Eigenschaft | Wert | Beschreibung
USERNAME (vorgegebene Installer-Eigenschaft) | <Name> Standard: {LogonUser} | Der Name des Benutzers, der die Installation durchführt. Dialogfeld Kundeninformationen; Bearbeitungsfeld Benutzername.
COMPANYNAME (vorgegebene Installer-Eigenschaft) | <Organisation> Standard: {LogonCompany} | Der Name der Organisation, welcher der Benutzer, der die Installation durchführt, angehört. Dialogfeld Kundeninformationen; Bearbeitungsfeld Organisation.
PIDKEY | <Produkt-ID> Standard: "" | Der CD-Schlüssel im Format ###-####### für das Produkt. Dialogfeld Kundeninformationen; unterteiltes Eingabefeld Seriennummer.
INSTALLLEVEL (vorgegebene Installer-Eigenschaft) | <Installationsebene> Standard: 100 | Die Installationsebene. Für die BizTalk Server 2000-Installation gilt: 100=Client-Setup-Typ und 200=Server-Setup-Typ.
INSTALLDIR (vorgegebene Installer-Eigenschaft) | <Installationspfad> Standard: "{Programme} \Microsoft BizTalk Server" | Der Zielordner für die Installation.
BTS_GROUP_NAME (Nur vollständige Installation) | <Gruppenname> Standard: "BTSAdmin" | Der Name der BizTalk Server 2000 Windows NT-Gruppe. Dialogfeld Administratorzugriff für BizTalk Server konfigurieren; Bearbeitungsfeld Gruppenname.
BTS_GROUP_DESCRIPTION (Nur vollständige Installation) | <Gruppenbeschreibung> Standard: "Members can fully administer Microsoft BizTalk Server" | Die Beschreibung der BizTalk Server 2000 NT-Gruppe. Dialogfeld Administratorzugriff für BizTalk Server konfigurieren; Bearbeitungsfeld Beschreibung.
BTS_USERNAME (Nur vollständige Installation) | <Benutzername> Standard: "" | Der Domänenanmeldename für den BizTalk Server 2000-Dienst. Dialogfeld Anmeldeeigenschaften des BizTalk Server-Dienstes; Bearbeitungsfeld Benutzername.
BTS_PASSWORD (Nur vollständige Installation) | <Kennwort> Standard: "" | Das Anmeldekennwort für den BizTalk Server 2000-Dienst. Dialogfeld Anmeldeeigenschaften des BizTalk Server-Dienstes; Bearbeitungsfeld Kennwort.
BTS_SERVER (Vollständige und Tools-Installation) | <Servername> Standard: "localhost" | Der Name des BizTalk-Servers, der von einem Remotestandort aus verwaltet werden soll. Dialogfeld BizTalk-Messaging-Manager konfigurieren; Bearbeitungsfeld Servername.
BTS_SDK_SERVER (Vollständige und Tools-Installation) | <Servername> Standard: ""localhost"" | Der Name des BizTalk-Servers, der von DCOM verwendet werden soll. Dialogfeld DCOM für das BizTalk Server SDK konfigurieren; Bearbeitungsfeld Servername.
DSNCONFIG (Initialisierungsdatei) | <Pfadname> Standard: "" | Der Pfad für die Initialisierungsdatei, den die Datenbankeinrichtungs-Assistenten BTSsetupDB.exe und XLANGsetupDB.exe verwenden sollen.

Anmerkungen

  • Die DSNCONFIG-Eigenschaft ist für eine unbeaufsichtigte Installation von BizTalk Server 2000 erforderlich. Der in der Befehlszeile angegebene Initialisierungsdateipfad wird an die Datenbankeinrichtungs-Assistenten BTSsetupDB.exe und XLANGsetupDB.exe weitergeleitet. Wählen Sie einen der folgenden Befehlszeilenwerte aus:
    • DSNCONFIG="Vollständiger Pfad zur INI-Datei für BTSsetupDB.exe und XLANGsetupDB.exe"

      Oder

    • BTSSETUPDB.INI="Vollständiger Pfad zur INI-Datei für BTSsetupDB.exe" und XLANGSETUPDB.INI="Vollständiger Pfad zur INI-Datei für XLANGsetupDB.exe"
  • Der Datenbankeinrichtungs-Assistent verarbeitet den Inhalt dieser Initialisierungsdatei unter Verwendung der folgenden Regeln:
    • Alle [Abschnitte] und Schlüssel= sind optional; fehlt ein Schlüssel, wird der Standardwert in der Beispielinitialisierungsdatei verwendet.

    • Ist der Gruppenname in der angegebenen BizTalk-Messaging-Verwaltungsdatenbank vorhanden, werden die Abschnitte [InterchangeDTA] und [InterchangeSQ] ignoriert, da die Werte durch die Gruppe definiert werden.

    • Angegebene Datenbanken werden erstellt, sofern Sie auf dem entsprechenden Server nicht bereits vorhanden sind.
  • Die Installation der BizTalk-Messaging-Verwaltungsdatenbank und die Installation der Persistenzdatenbank für die Orchestrierung laufen unabhängig voneinander ab.

  • Abhängig von den installierten Features werden bei der Installation eine, keine oder beide der folgenden Komponenten konfiguriert:
    • Die BizTalk-Messaging-Verwaltungsdatenbank wird nur konfiguriert, wenn die BizTalk-Messagingdienste sowie die entsprechenden Komponenten installiert wurden.

    • Die Persistenzdatenbank für die Orchestrierung wird nur konfiguriert, wenn der Orchestrierungsdienst installiert ist.
  • In der Befehlszeile werden die folgenden Eigenschaften verwendet:
    • DSNCONFIG – Gibt den Speicherort der INI-Datei an, die von BTSsetupDB.exe und XLANGsetupDB.exe verwendet werden soll.

      Oder

      BTSSETUPDB.INI – Gibt den Speicherort der INI-Datei an, die von BTSsetupDB.exe verwendet werden soll.

    • XLANGSETUPDB.INI – Gibt den Speicherort der INI-Datei an, die von XLANGsetupDB.exe verwendet werden soll.

Beispielinitialisierungsdatei mit sämtlichen [Abschnitten], Schlüsseln= und Standardwerten

Es folgt ein Beispiel für eine INI-Datei, die für eine unbeaufsichtigte Installation von BizTalk Server 2000 benötigt wird. Diese Befehlszeileneigenschaften sind für eine erstmalige Installation von BizTalk Server 2000 mithilfe des Windows Installer erforderlich.

Beispiel für "SetupDB.ini"

;----------------------------------------------------------------------
; SQL Server connection parameters for BizTalk Messaging Management database
; Required section used by BTSsetupDB.exe only.
; Specify new or existing database.
;
[InterchangeBTM]
Server=localhost
Username=sa
Password=
Database=InterchangeBTM

;----------------------------------------------------------------------
; Name for BizTalk Server Group
; Required section used by BTSsetupDB.exe only.
; Specify new or existing server group.
;
[Group]
GroupName=BizTalkGroup

;----------------------------------------------------------------------
; SQL Server connection parameters for BizTalk Tracking database
; Required section used by BTSsetupDB.exe only.
; Optional if existing server group specified.
;
[InterchangeDTA]
Server=localhost
Username=sa
Password=
Database=InterchangeDTA

;----------------------------------------------------------------------

;
[InterchangeSQ]
Server=localhost
Username=sa
Password=
Database=InterchangeSQ

;----------------------------------------------------------------------
; SQL Server connection parameters for Orchestration database
; Required section used by XLANGsetupDB.exe only.
; Specify new or existing Orchestration database.
;
[Orchestration]
Server=localhost
Database=XLANG

In der folgenden Tabelle werden die Eigenschaften und Werte der Beispielinitialisierungsdatei BizTalkDB.ini beschrieben.

Eigenschaft | Wert | Beschreibung
[InterchangeBTM] Server=BIZTALK Melden Sie sich an diesem ersten SQL-Server mit dem Standardbenutzernamen und -kennwort an.
Database=BizTalkBTM

Erstellen Sie diese BizTalk-Messaging-Verwaltungsdatenbank, wenn sie nicht bereits auf dem Server vorhanden ist.
[Group] | GroupName=BizTalkServerGroup | Ist diese Gruppe bereits vorhanden, werden die übrigen Werte ignoriert.
[InterchangeDTA] Server=DTA-SERVER Melden Sie sich an diesem zweiten SQL-Server mit dem Standardbenutzernamen und -kennwort an.
Database=BizTalkDTA

Erstellen Sie diese Überwachungsdatenbank, wenn sie nicht bereits auf dem Server vorhanden ist.
[InterchangeSQ] Server=SQ-SERVER Melden Sie sich an diesem dritten SQL-Server mit dem Standardbenutzernamen und -kennwort an.
Database=BizTalkSQ

Erstellen Sie diese Datenbank für gemeinsam genutzte Warteschlangen, wenn sie nicht bereits auf dem Server vorhanden ist.
[Orchestration] Server=localhost Melden Sie sich an diesem vierten SQL-Server mit dem Standardbenutzernamen und -kennwort an.
Database=Orchestration

Erstellen Sie diese XLANG-Datenbank, wenn sie nicht bereits auf dem Server vorhanden ist.

Befehlszeilenoptionen für Microsoft Windows Installer

Microsoft Windows Installer (Msiexec.exe) ist ein Programm, das Pakete interpretiert und Produkte installiert. Darüber hinaus wird eine Fehlerebene für die Rückgabe festgelegt, die den Microsoft Win32®-Fehlercodes entspricht. In der folgenden Tabelle werden die Befehlszeilenoptionen für dieses Programm beschrieben, die Sie zusätzlich zu den oben aufgeführten Eigenschaften und Werten verwenden können.

Option | Parameter | Bedeutung
/I | Package|ProductCode | Installiert oder konfiguriert ein Produkt.
/f [p|o|e|d|c|a|u|m|s|v] Package|ProductCode Repariert ein Produkt. Bei dieser Option werden sämtliche Eigenschaftswerte in der Befehlszeile ignoriert. Die Standardargumentliste für diese Option ist pecms. Diese Option verwendet dieselbe Argumentliste wie die REINSTALLMODE-Eigenschaft.

p - Erneute Installation nur dann, wenn die Datei fehlt.

o - Erneute Installation, wenn die Datei fehlt oder eine ältere Version der Datei installiert ist.

e - Erneute Installation, wenn die Datei fehlt oder eine gleich alte oder ältere Version der Datei installiert ist.

d - Erneute Installation, wenn die Datei fehlt oder eine andere Version der Datei installiert ist.

c - Erneute Installation, wenn die Datei fehlt oder die gespeicherte Prüfsumme nicht mit dem berechneten Wert übereinstimmt. Reparatur von Dateien nur dann, wenn die Attributspalte der Dateitabelle den Wert msidbFileAttributesChecksum enthält.

a - Erneute Installation aller Dateien.

u - Neuschreibung aller erforderlichen benutzerspezifischen Einträge in der Registrierung.

m - Neuschreibung aller erforderlichen computerspezifischen Einträge in der Registrierung.

s - Überschreibung aller vorhandenen Verknüpfungen.

v - Start von der Quelle aus und erneute Zwischenspeicherung des lokalen Pakets.
/a | Package | Option für administrative Installation. Installiert ein Produkt im Netzwerk.
/x | Package|ProductCode | Deinstalliert ein Produkt.
/j [u|m]Package

Oder

[u|m]Package /t Transform List

Oder

[u|m]Package /g LanguageID

 Kündigt ein Produkt an. Bei dieser Option werden sämtliche Eigenschaftswerte in der Befehlszeile ignoriert.

u - Ankündigung an den aktuellen Benutzer.

m - Ankündigung an alle Benutzer des Computers.

t -Anwendung der Transformation auf das angekündigte Paket.

g - Sprachkennung.
/L [i|w|e|a|r|u|c|m|o|p|v|+|!]Logfile Gibt den Pfad der Protokolldatei an. Mit den folgenden Flags können Sie festlegen, welche Informationen protokolliert werden sollen:

i - Statusmeldungen

w - Mittelschwere Warnungen

e - Alle Fehlermeldungen

a – Start von Aktionen

r - Aktionsspezifische Aufzeichnungen

u - Benutzeranfragen

c - Ursprüngliche Benutzeroberflächenparameter

m - Nicht genügend Arbeitsspeicher oder Abbruchinformation

o - Meldungen bei nicht ausreichendem Datenträgerspeicherplatz

p - Eigenschaften des Terminals

v - Ausführliche Ausgabe

+ - Anhang an vorhandene Datei

! - Aufzeichnung jeder Zeile im Protokoll

"*" - Platzhalter; Protokollierung aller Daten mit Ausnahme der Option v. Soll die Option v verwendet werden, geben Sie "/l*v" ein.
/m filename Generiert eine Systems Management Server-Statusdatei mit der Dateierweiterung MIF. Muss mit der Option für die Installation (-i), die Entfernung (-x), die Admin-Installation (-a) oder die erneute Installation (-f) verwendet werden. Die Datei Ismif32.dll wird als Teil von SMS installiert und muss sich unter diesem Pfad befinden.

Die Felder der Statusdatei mit der Dateierweiterung MIF enthalten die folgenden Informationen:

Manufacturer - Autor

Product - Revisionsnummer

Version - Subjekt

Locale - Vorlage

Serial Number - Nicht festgelegt

Installation - In der Datei Ismif32.dll auf "Datum/Uhrzeit" festgelegt

InstallStatus - "Erfolg" oder "Fehler"

Deskription - Fehlermeldungen in der folgenden Reihenfolge: 1) Vom Installer generierte Fehlermeldungen; 2) Ressource aus Msi.dll, wenn die Installation nicht gestartet werden kann oder der Benutzer den Vorgang abbricht; 3) Datei mit Systemfehlermeldungen; 4) Formatierte Meldung: "Installationsfehler %i", wobei %i für den von Msi.dll zurückgegebenen Fehler steht.
/p PatchPackage Wendet einen Patch an. Um einen Patch auf ein installiertes Admin-Image anzuwenden, kombinieren Sie die folgenden Optionen:

/p <Patchpaket> /a <Paket>
/q n|b|r|f Legt die Ebene der Benutzeroberfläche fest.

q , qn - Keine Benutzeroberfläche.

qb - Standardoberfläche.

qr - Eingeschränkte Oberfläche mit einem modalen Dialogfeld am Ende der Installation.

qf - Vollständige Oberfläche mit einem modalen Dialogfeld am Ende der Installation.

qn+ - Keine Benutzeroberfläche, mit Ausnahme eines modalen Dialogfeldes am Ende der Installation.

qb+ - Standardoberfläche mit einem modalen Dialogfeld am Ende der Installation. Das modale Dialogfeld wird nicht angezeigt, wenn der Benutzer die Installation abbricht.

qb- - Standardoberfläche ohne modale Dialogfelder. /qb+- ist keine unterstützte Benutzeroberflächenebene.
/?

Oder

/h

 Zeigt Copyrightinformationen zum Windows Installer an.
/y module Ruft den systemeigenen API DllRegisterServer auf, um die Module in der Befehlszeile automatisch zu registrieren. Zum Beispiel: msiexec /y MeineDatei.dll.

Diese Option wird lediglich bei Registrierungsinformationen angewandt, die nicht anhand der Registrierungstabellen der MSI-Datei hinzugefügt werden konnten.
/z module Ruft den systemeigenen API DllUnRegisterServer auf, um die Registrierung der Module in der Befehlszeile aufzuheben. Zum Beispiel: msiexec /z MeineDatei.dll.

Diese Option wird lediglich bei Registrierungsinformationen angewandt, die nicht anhand der Registrierungstabellen der MSI-Datei entfernt werden konnten.

Anmerkungen

  • Für die in der obigen Tabelle beschriebenen Optionen gilt Folgendes:
    • Die Optionen /i, /x, /f[p|o|e|d|c|a|u|m|s|v], /j[u|m], /a, /p, /y und /z dürfen nicht zusammen verwendet werden. Die einzige Ausnahme von dieser Regel ist, dass bei Auswahl einer Admin-Installation sowohl /p als auch /a erforderlich sind.

    • Die Optionen /t und /g sollten nur zusammen mit /j verwendet werden.

    • Die Optionen /l und /q können mit /i, /x, /f[p|o|e|d|c|a|u|m|s|v], /j[u|m], /a und /p verwendet werden.

Syntaxregeln für Eigenschaften und Werte

Nur öffentliche Eigenschaften können mithilfe der Befehlszeile geändert werden. Alle Eigenschaftsnamen in der Befehlszeile werden als Großbuchstaben interpretiert, während beim Wert die Groß-/Kleinschreibung beachtet wird. Wenn Sie beispielsweise in einer Befehlszeile MyProperty eingeben, überschreibt der Installer den Wert MYPROPERTY und nicht den Wert MyProperty in der Eigenschaftentabelle. Verwenden Sie die folgende Befehlszeilensyntax, um ein Produkt zu installieren, bei dem für PROPERTY die Einstellung VALUE gilt. Die Eigenschaft kann an jeder beliebigen Stelle in der Befehlszeile eingefügt werden, nur nicht zwischen einer Option und ihrem Argument.

Richtige Syntax:

msiexec /i A:\Example.msi PROPERTY=VALUE

Falsche Syntax:

msiexec /i PROPERTY=VALUE A:\Example.msi

Eigenschaftswerte, die Zeichenfolgen enthalten, müssen in Anführungszeichen eingeschlossen werden. Die Zeichenfolge zwischen den Anführungszeichen kann auch Leerräume enthalten.

msiexec /i A:\Example.msi PROPERTY="Embedded White Space"

Um eine öffentliche Eigenschaft mithilfe der Befehlszeile zu löschen, geben Sie als Wert eine leere Zeichenfolge ein.

msiexec /i A:\Example.msi PROPERTY=""

Enthalten Teile der Zeichenfolge selbst Anführungszeichen, setzen Sie diese in doppelte Anführungszeichen.

msiexec /i A:\Example.msi PROPERTY="Embedded ""Quotes"" White Space"

Es folgt ein Beispiel für eine komplexe Befehlszeile:

msiexec /i testdb.msi INSTALLLEVEL=3 /l* msi.log COMPANYNAME="Acme ""Widgets"" and ""Gizmos."""

Das folgende Beispiel illustriert Ankündigungsoptionen. Bei Optionen muss keine Groß-/Kleinschreibung beachtet werden.

msiexec /JM msisample.msi /T transform.mst /G langid /LIME logfile.txt

Weitere Informationen zu Microsoft Windows Installer finden Sie auf der MSDN™-Download-Website (msdn.microsoft.com/downloads/).


Entfernen von BizTalk Server2000

BizTalk Server-Kopfzeile

Entfernen von BizTalk Server 2000

Verwenden Sie das Software-Dienstprogramm von Microsoft Windows 2000, um Microsoft BizTalk Server 2000 zu entfernen.

Folgendes Thema wird in diesem Abschnitt behandelt:

  • Entfernen von BizTalk Server 2000


Entfernen von BizTalk Server2000

BizTalk Server-Kopfzeile

Entfernen von BizTalk Server 2000

  1. Zeigen Sie im Startmenü auf Einstellungen, und klicken Sie dann auf Systemsteuerung.

  2. Klicken Sie auf Software.

  3. Klicken Sie auf Microsoft BizTalk Server 2000 und dann auf Entfernen.

    Das Dialogfeld Software wird angezeigt.

  4. Folgen Sie den Anweisungen auf dem Bildschirm, und klicken Sie auf Ja, wenn Sie gefragt werden, ob BizTalk Server 2000 entfernt werden soll.


Grundlegendes zur Sicherheit

Microsoft BizTalk Server 2000 ermöglicht Unternehmen einen sicheren Datenaustausch mit Handelspartnern. BizTalk Server nutzt dabei die Sicherheitsfunktionen von Microsoft Windows 2000 und Microsoft SQL Server.

Zu den Windows 2000-Sicherheitsfunktionen gehören die Folgenden:

  • Infrastruktur öffentlicher Schlüssel

  • Microsoft Komponentendienste

  • Microsoft Kryptografie-API

  • Smartcards

  • Kerberos-Protokoll

Die Verwaltung der Zertifikate öffentlicher Schlüssel umfasst das Anfordern von Zertifikaten, das Verarbeiten von Zertifikaten in einer Antwort auf eine Zertifikatsanforderung und den Austausch von Zertifikaten mit Handelspartnern. Diese Zertifikate stehen für die digitale Signatur und Verschlüsselung zur Verfügung. Der Austausch von Zertifikaten bietet eine Methode zum gemeinsamen Sichern von Daten mit Handelspartnern. Wächst ein Unternehmen weiter, kann die Verwaltung von Zertifikaten jedoch zeitaufwendig werden.

Da BizTalk Server die Sicherheitsfunktionen von Windows 2000 nutzt, wie z. B. SSL (Secure Sockets Layer), können Webseiten erstellt und von Handelspartnern verwendet werden, um Daten sicher über das Internet auszutauschen. Die in Internet-Informationsdienste (IIS, Internet Information Services) implementierte SSL-Technologie ist ein Protokoll, das Datensicherheit zwischen einem Webclient und einem Webserver bereitstellen soll. Das Protokoll beginnt mit einem Handshakephase, in der ein Verschlüsselungsalgorithmus ausgehandelt wird, die (öffentlichen und privaten) Schlüssel überprüft werden und der Server beim Client authentifiziert wird. Nach Abschluss des Handshakes und dem Beginn der Anwendungsdatenübertragung werden alle Daten mit den Sitzungsschlüsseln verschlüsselt, die während des Handshakes ausgehandelt wurden. Durch die Unterstützung offener PKI-Standards (Public-Key Infrastructure, Infrastruktur öffentlicher Schlüssel) und sicherer Protokolle, wie z. B. IPSec, L2TP, SSL/TLS und S/MIME, kann ein Netzwerk schnell um Lieferanten und Handelspartner erweitert werden und gleichzeitig vor Datenmissbrauch, Datendiebstahl und unberechtigten Hackerangriffen schützen.

Die Komponentendienste, eines der Windows 2000-Verwaltungprogramme, bieten umfassende Komponentenfunktionen, wie z. B. die automatische Unterstützung von Transaktionen, um einen Datenintegritätsschutz und eine einfache und doch leistungsstarke, auf Rollen basierende Sicherheit bereitzustellen.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Installation und Konfiguration von BizTalk Server 2000

  • Transportdienste

  • Sicherheit für Hostanwendungen für XLANG-Ablaufplaninstanzen

  • Zertifikate - Übersicht

  • Krypto-API

  • CDOs (Collaborative Data Objects)

Verwandtes Thema

Administratorprivilegien


Installation und Konfiguration von BizTalkServer2000

BizTalk Server-Kopfzeile

Installation und Konfiguration von BizTalk Server 2000

Transaktionen zwischen Handelspartnern müssen sicher sein. Microsoft BizTalk Server 2000 gewährleistet die Sicherheit durch das Bereitstellen mehrerer Authentifizierungs- und Verschlüsselungskomponenten, die auf den Sicherheitsdiensten von Microsoft Windows 2000 basieren. Neben den Windows 2000-Sicherheitsfunktionen nutzt BizTalk Server auch die Sicherheitsfunktionen von Microsoft SQL Server. BizTalk Server basiert hauptsächlich auf der SQL Server-Anmeldungssicherheit, um die Sicherheit der Daten in der BizTalk-Messaging-Management-Datenbank zu gewährleisten. Die standardmäßige BizTalk Persistenzdatenbank für Orchestrierung basiert jedoch auf der Windows 2000-Authentifizierung. Beim Erstellen einer COM+-Komponente, die als Host für Ablaufplaninstanzen und deren Persistenzdatenbanken dient, können Sie auswählen, ob Sie die SQL Server- oder Windows 2000-Authentifizierung verwenden möchten. Darüber hinaus verwendet die Verwaltungskonsole die Windows-Verwaltungsschnittstelle, die über die Windows 2000-Sicherheitsfunktionen zur Verfügung stehen.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Anmeldeeigenschaften

  • Lokale Richtlinien

  • Verwenden eines Dienstkontos

  • Senden von Arbeitsobjekten


Anmeldeeigenschaften

Die Anmeldeeigenschaften bilden die erste Sicherheitsebene von BizTalk Server 2000. Diese Eigenschaften steuern, ob sich ein Benutzer bei einem bestimmten Computer anmelden kann. Die Anmeldeeigenschaften erfordern die Angabe eines Benutzernamens und Kennwortes, ehe auf Ressourcen wie eine Dateifreigabe oder Nachrichtenwarteschlange zugegriffen werden kann. Über HTTP oder SMTP empfangene Nachrichten verwenden ebenfalls die Anmeldeeigenschaften, um die Sicherheit zu gewährleisten. Eine ASP-Seite, auf die über HTTP zugegriffen wird, erfordert z. B. die Eingabe eines Benutzernamens und Kennwortes, ehe der Inhalt der Webseite angezeigt werden kann.

BizTalk Server verwendet für Empfangsfunktionen Internet-Informationsdienste (IIS) und ASP-Seiten. ASP-Seiten (eigentlich der Code hinter den Seiten) stellen für BizTalk Server eine Sicherheitsebene zur Verfügung, indem über IIS SSL-Signaturen (Secure Sockets Layer) überprüft werden und die Sicherheit, z. B. durch Zertifikate, weiter maximiert wird. Weitere Informationen zur IIS-Sicherheit finden Sie in der Windows 2000-Hilfe unter "Internet-Informationsdienste".

Verwandtes Thema

Administratorprivilegien


Lokale Richtlinien

Die Funktion Lokale Richtlinien, die zur Konsole Lokale Sicherheitseinstellungen gehört, legt die Sicherheitsoptionen eines Benutzers oder Dienstkontos fest. Lokale Richtlinien basieren auf dem Computer, bei dem ein Benutzer angemeldet ist, sowie auf den Rechten, über die der Benutzer auf dem entsprechenden Computer verfügt. Zur Einstellung lokaler Richtlinien zeigen Sie im Startmenü auf Einstellungen, klicken auf Systemsteuerung, doppelklicken zuerst auf Verwaltung und dann auf Lokale Sicherheitsrichtlinie. Erweitern Sie den Ordner Lokale Richtlinien.

Mithilfe lokaler Richtlinien werden die Berechtigungen und Rechte von BizTalk Server 2000-Benutzern definiert. Lokale Richtlinien kann verwendet werden, um Folgendes zu konfigurieren:

  • Überwachungsrichtlinien. Bestimmt, welche Sicherheitsereignisse im Sicherheitsprotokoll auf dem Computer protokolliert werden (erfolgreiche Versuche, misslungene Versuche oder beides). (Das Sicherheitsprotokoll ist Teil der Ereignisanzeige.)

  • Zuweisen von Benutzerrechten. Bestimmt, welche Benutzer oder Gruppen über Rechte zum Anmelden oder Ausführen von Aufgaben auf dem Computer verfügen.

  • Sicherheitsoptionen. Aktiviert oder deaktiviert die Sicherheitseinstellungen für den Computer. Hierzu zählen z. B. digitale Signaturen von Daten, Namen von Administrator- und Gastkonten, der Zugriff auf Disketten- und CD-ROM-Laufwerke, Treiberinstallation und Anmeldeaufforderungen.

In der Konsole Lokale Sicherheitseinstellungen können weitere Richtlinien konfiguriert werden, um die Integrität der Daten zu erhalten. Beispielsweise kann mithilfe von Kontorichtlinien Folgendes konfiguriert werden:

  • Kennwortrichtlinien. Bestimmt bei lokalen Benutzerkonten die Einstellungen für Kennwörter, wie z. B. das Erzwingen und die Gültigkeitsdauer.

  • Kontosperrungsrichtlinien. Bestimmt bei lokalen Benutzerkonten, wann und für wen ein Konto gesperrt wird.

Wichtig

  • Lokale Richtlinien gelten per Definition nur lokal auf einem Computer. Wenn diese Einstellungen in ein Gruppenrichtlinienobjekt in Active Directory importiert werden, wirken sie sich auf die lokalen Sicherheitseinstellungen aller Computerkonten aus, auf die dieses Gruppenrichtlinienobjekt angewendet wird. Aus diesem Grund muss die Prioritätsreihenfolge für Sicherheitsrichtlinien beachtet werden. Sicherheitsrichtlinien, die Gruppenrichtlinien (Organisationseinheiten) zugeordnet sind, setzen auf der lokalen Ebene definierte Richtlinien außer Kraft. Richtlinien der Domäne setzen lokale definierte Richtlinien ebenfalls außer Kraft. In jedem Fall gelten die Rechte für das Benutzerkonto nicht mehr, wenn diese Privilegien durch vorhandene lokale Richtlinieneinstellungen außer Kraft gesetzt werden. Dies ist von Bedeutung, da sich das Verhalten von Microsoft Windows 2000 und Microsoft Windows NT wesentlich unterscheiden kann. Wenn z. B. Kennwortrichtlinien für die Gruppenrichtlinie Domäne konfiguriert sind (Standardeinstellung), wirken sie sich auf alle Computer in dieser Domäne aus. Dies bedeutet, dass die lokalen Kontodatenbanken (auf einzelnen Arbeitsstationen) in der Domäne über dieselben Kennwortrichtlinien wie die Domäne selbst verfügen.

Anmerkung

  • Legen Sie Lokale Richtlinien nicht für öffentliche Schlüssel fest. Öffentliche Schlüssel stellen einen Sicherheitsschutz für BizTalk Server bereit. Öffentliche Schlüssel sind eine Komponente der Zertifikate, die zum Ver- und Entschlüsseln von Daten verwendet werden. Wenn einem öffentlichen Schlüssel weitere Richtlinien hinzugefügt werden, kann BizTalk Server das zugeordnete Zertifikat nicht verwenden.

Verwandtes Thema

Administratorprivilegien


Verwenden eines Dienstkontos

Ein Dienstkonto ähnelt einem interaktiven Benutzerkonto, da beide einem Benutzer den Zugriff auf Computer- und/oder Netzwerkressourcen ermöglichen. Ein Dienstkonto ist ein reguläres Benutzerkonto mit bestimmten Eigenschaften, durch die es als ein Teil des Betriebssystems fungieren kann. Dagegen bezieht sich ein interaktives Benutzerkonto auf den Benutzer, der während des Installationsvorgangs von BizTalk Server 2000 angemeldet ist.

Wenn die Identität auf Interaktiver Benutzer festgelegt ist, kann die Anwendung nur ausgeführt werden, wenn ein Benutzer angemeldet ist. Wenn daher BizTalk Server mit einem interaktiven Benutzerkonto eingerichtet wurde, bricht das Programm ab, wenn sich der angegebene Benutzer vom Server abmeldet. Das Auswählen einer interaktiven Benutzeridentität birgt Sicherheitsrisiken, da die Anwendung unter der Identität des angemeldeten Benutzers ohne dessen Wissen oder Zustimmung ausgeführt wird. Wenn z. B. die Anwendung auf einem Computer ausgeführt wird, während ein Administrator angemeldet ist, wird die Anwendung unter der Identität des Administrators ausgeführt und nimmt als solche möglicherweise Aufrufe im Auftrag von Clients vor.

Wenn die Identität auf ein Dienstkonto festgelegt ist, kann dieses als Teil des Betriebssystems fungieren und den Benutzern den Zugriff auf Anwendungen auf einem Server erlauben, auch wenn der Benutzer nicht beim Computer angemeldet ist.

Weitere Informationen zu Dienstkonten finden Sie unter Erstellen eines Dienstkontos.

Verwandtes Thema

Erstellen eines Dienstkontos


Senden von Arbeitsobjekten

Das Senden von Arbeitsobjekten durch einen Benutzer an BizTalk Server 2000, kann mit der COM+-Komponente BizTalk Server-Austauschanwendung (BizTalk Server Interchange Application) gesteuert werden. Die COM+-Komponente BizTalk Server-Austauschanwendung (BizTalk Server Interchange Application) verwendet die folgenden Sicherheitskonfigurationseigenschaften:

  • Authentifizierungsebene

  • Identitätswechselebene

  • Zugriffsberechtigungen

  • Startberechtigungen

  • Konfigurationsberechtigungen

Zur COM+-Komponente BizTalk Server-Austauschanwendung (BizTalk Server Interchange Application) muss zuerst eine Rolle hinzugefügt werden, um das Senden von Arbeitsobjekten durch einen Benutzer zu steuern. Anschließend muss diese Rolle den Methoden Submit und SubmitSync zugeordnet werden.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Hinzufügen einer Rolle zur BizTalk Server-Austauschanwendung (BizTalk Server Interchange Application)

  • Verknüpfen einer neuen Rolle mit den Methoden "Submit" und "SubmitSync"

Verwandtes Thema

Administratorprivilegien


Hinzufügen einer Rolle zur BizTalkServer-Austauschanwendung (BizTalkServer Interchange Application)

BizTalk Server-Kopfzeile

Hinzufügen einer Rolle zur BizTalk Server-Austauschanwendung (BizTalk Server Interchange Application)

  1. Zeigen Sie im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Komponentendienste.

    Die Konsole Komponentendienste wird angezeigt.

  2. Erweitern Sie Komponentendienste, Computer, Arbeitsplatz und schließlich COM+-Anwendungen.

  3. Klicken Sie mit der rechten Maustaste auf BizTalk Server Interchange Application, und klicken Sie auf Eigenschaften.

    Das Dialogfeld Eigenschaften von BizTalk Server Interchange Application wird angezeigt.

  4. Klicken Sie auf die Registerkarte Erweitert, deaktivieren Sie unter Berechtigung das Kontrollkästchen Ändern deaktivieren. Klicken Sie auf OK, und klicken Sie anschließend im Meldungsdialogfeld auf Ja.

  5. Wiederholen Sie Schritt 3.

  6. Klicken Sie auf die Registerkarte Sicherheit, und aktivieren Sie unter Autorisierung das Kontrollkästchen Zugriffsüberprüfung für diese Anwendung erzwingen.

  7. Klicken Sie unter Sicherheitsstufe auf Zugriffsüberprüfung auf Prozess- und Komponentenebene durchführen. Die Sicherheitseigenschaft wird in den Objektkontext einbezogen. Der COM+-Sicherheitsaufruf ist verfügbar.

  8. Klicken Sie auf OK.

  9. Klicken Sie im Meldungsdialogfeld auf Ja.

  10. Erweitern Sie BizTalk Server Interchange Application.

  11. Doppelklicken Sie auf den Ordner Rollen, klicken Sie mit der rechten Maustaste auf den Ordner, zeigen Sie auf Neu, und klicken Sie dann auf Rolle.

    Das Dialogfeld Rolle wird angezeigt.

  12. Geben Sie einen Namen für die Rolle ein, und klicken Sie auf OK.

  13. Klicken Sie im Meldungsdialogfeld auf Ja.

  14. Erweitern Sie die zuvor erstellte Rolle, doppelklicken Sie auf den Ordner Benutzer, klicken Sie mit der rechten Maustaste auf Benutzer, zeigen Sie auf Neu, und klicken Sie dann auf Benutzer.

  15. Geben Sie in das Feld Benutzer oder Gruppen auswählen den vollständigen Namen des Benutzers ein, den Sie hinzufügen möchten.

  16. Klicken Sie nach dem Hinzufügen von Benutzerkonten zur Rolle auf OK.

Anmerkung

  • Für alle Benutzerkonten oder Gruppen, die der Rolle zugewiesen wurden, wird im Ordner Benutzer ein Symbol angezeigt. Die neue Rollenmitgliedschaft wird beim Starten der Anwendung aktiviert.

Verwandtes Thema

Herunterfahren der BizTalk Server-Austauschanwendung (BizTalk Server Interchange Application)


Verknüpfen einer neuen Rolle mit den Methoden "Submit" und "SubmitSync"

  1. Zeigen Sie im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Komponentendienste.

    Die Konsole Komponentendienste wird angezeigt.

  2. Erweitern Sie Komponentendienste, Computer, Arbeitsplatz, COM+-Anwendungen, BizTalk Server Interchange Application, Komponenten, BizTalk.Interchange.1, Schnittstellen, IInterchange und Methoden.

  3. Klicken Sie mit der rechten Maustaste auf Submit und dann auf Eigenschaften.

    Das Dialogfeld Eigenschaften von Submit wird angezeigt.

  4. Klicken Sie auf die Registerkarte Sicherheit.

  5. Aktivieren Sie unter Rollen explizit für ausgewählte Elemente festlegen das Kontrollkästchen der Rolle, die Sie zuvor unter Hinzufügen einer Rolle zur BizTalk Server-Austauschanwendung (BizTalk Server Interchange Application) erstellt haben, und klicken Sie auf OK.

  6. Klicken Sie mit der rechten Maustaste auf SubmitSync und dann auf Eigenschaften.

    Das Dialogfeld Eigenschaften von SubmitSync wird angezeigt.

  7. Klicken Sie auf die Registerkarte Sicherheit.

  8. Aktivieren Sie unter Rollen explizit für ausgewählte Elemente festlegen das Kontrollkästchen der Rolle, die Sie zuvor unter Hinzufügen einer Rolle zur BizTalk Server-Austauschanwendung (BizTalk Server Interchange Application) erstellt haben, und klicken Sie auf OK.

Anmerkung

  • Für die BizTalk Server-Austauschanwendung (BizTalk Server Interchange Application) muss zuerst eine neue Rolle erstellt werden, ehe die Methoden Submit und SubmitSync dieser zugeordnet werden können.

Verwandtes Thema

Herunterfahren der BizTalk Server-Austauschanwendung (BizTalk Server Interchange Application)


Transportdienste

Microsoft BizTalk Server 2000 unterstützt eine Kerngruppe von Transportdiensten. Mithilfe dieser Transportdienste kann ein Server Dokumente an Organisationen oder Anwendungen senden. Dabei ist es unerheblich, ob die Anwendungen direkt mit dem Server mithilfe einer COM-Schnittstelle kommunizieren können. BizTalk Server unterstützt die Netzwerkprotokolle HTTP, HTTPS und SMTP sowie Message Queuing.

Folgende Themen werden in diesem Abschnitt behandelt:

  • HTTP und HTTPS

  • SMTP

  • Message Queuing 2.0

  • Datei

Verwandte Themen

Auswählen eines Transporttyps

Festlegen von Transporteigenschaften


HTTP und HTTPS

HTTPS stellt eine zuverlässige Authentifizierung bereit, wenn mit HTTP auf Webinhalte zugegriffen wird. HTTPS wird am häufigsten verwendet, um eine verschlüsselte Verbindung mit einem authentifizierten Webserver herzustellen. Wenn Clients versuchen, eine HTTPS-Verbindung aufzubauen, wozu in der Regel ein mit https:// beginnender URL in den Browser eingegeben wird, handeln Client und Server gemeinsam das zu verwendende Sicherheitsprotokoll aus und tauschen anschließend die Authentifizierungsinformationen aus.

Microsoft Internet Explorer 5 oder höher unterstützt für HTTP-Transaktionen allgemeine sichere Kommunikationsprotokolle. Dazu zählen u. a. die folgenden:

  • Transport Layer Security (TLS, Version 1.0)

  • Secure Sockets Layer (SSL, Version 2 und 3)

  • Private Communications Technology (PCT, Version 1.0).

Diese Protokolle bieten Verschlüsselungsdienste (zum Schutz der Vertraulichkeit ausgetauschter Daten) und Authentifizierungsdienste (für die gegenseitige Identifikation zwischen Clients und Servern). Die SSL-Unterstützung, die über den integrierten Transportdienst HTTPS bereitgestellt wird, fügt zu einem Austausch die Authentifizierungen zwischen Servern und die Verschlüsselung auf der Transportebene hinzu.

Mithilfe von BizTalk Server und HTTPS können Daten innerhalb einer Organisation oder mit einem Handelspartner über HTTP sicher ausgetauscht werden. Im Folgenden werden detaillierte Informationen dazu bereitgestellt, wie BizTalk Server 2000 HTTP und HTTPS zum Senden und Empfangen von Daten verwendet.

Senden

Die Transportdienste HTTP und HTTPS können zum Schützen von Daten verwendet werden, die an eine Anwendung oder einen Handelspartner gesendet werden. Die Sicherheit dieser Transportdienste basiert auf Zertifikaten.

Vor dem Senden von Daten über HTTP sendet ein BizTalk Server-Administrator z. B. eine Kopie eines Clientzertifikats an einen Handelspartner. Der Handelspartner behält eine Kopie des Zertifikats im BizTalk-Speicher. Künftig wird das Zertifikat verwendet, um den Daten sendenden Handelspartner zu authentifizieren. Um ein Zertifikat an einen Handelspartner zu senden oder zu exportieren, muss eine eindeutige Zertifikatsverwaltung erstellt werden.

Empfangen

BizTalk Server verwendet Microsoft Internet-Informationsdienste (IIS, Internet Information Services) und ASP-Seiten, um die Übertragung von Daten über HTTP zu sichern. Beim Verwenden von HTTPS zum Verbinden mit IIS handeln Client und Server ein gemeinsames Protokoll aus, um den Kanal zu sichern. In Fällen, in denen Server und Client mehrere Protokolle gemeinsam haben, schützt IIS den Kanal mit einem unterstützten Protokoll, wie z. B. SSL. Der Prozess zum Schützen von Daten, die von BizTalk Server über HTTP empfangen werden, ist identisch. Die ASP-Seite dient als Gateway für das Senden von Daten an BizTalk Server. Wenn die Daten sicher sind, empfängt BizTalk Server die Daten unter der Voraussetzung, dass der ASP-Code für einen Aufruf die Methoden Submit oder SubmitSync verwendet.

Verwandte Themen

Auswählen eines Transporttyps

Festlegen von Transporteigenschaften


SMTP

SMTP (Simple Mail Transfer Protocol) ist ein Protokoll für das Senden von E-Mail-Nachrichten zwischen Servern, das im Internet weit verbreitet ist. Eine E-Mail-Nachricht kann mit einem E-Mail-Client mithilfe von POP oder IMAP empfangen werden. Darüber hinaus wird SMTP zum Senden von Nachrichten von einem Mailclient zu einem Mailserver verwendet. Bei der Konfiguration einer E-Mail-Anwendung müssen sowohl der POP- oder IMAP-Server als auch der SMTP-Server angegeben werden.

Mithilfe von SMTP können Daten innerhalb einer Organisation oder mit einem Handelspartner sicher ausgetauscht werden. BizTalk Server 2000 verwendet SMTP, um mithilfe der folgenden Methoden Daten zu senden und zu empfangen:

Senden

BizTalk Server implementiert ein Transportprotokoll, um Daten über SMTP zu senden. Die Mindestanforderung von SMTP ist, dass die Daten MIME-codiert sind. Durch diesen Prozess kann BizTalk Server identifizieren, wo eine Datenmenge endet und die nächste beginnt. Die MIME-Codierung bietet jedoch keine Datensicherheit. Die sichere Version von MIME ist S/MIME. Dokumente, die mithilfe integrierter S/MIME-Codierungskomponenten verschlüsselt werden, sichern die Dokumentintegrität, die Authentifizierung des Absenders und die Nutzlastverschlüsselung. BizTalk Server erstellt ein S/MIME-Dokument mit der verschlüsselten Nachricht als Textkörper des Dokuments. Der MIME-codierten Nachricht muss ein Zertifikat zugeordnet werden, um diese Sicherheitsebene hinzuzufügen. Die MIME-Codierung kann angegeben werden, wenn Messagingports im BizTalk-Messaging-Manager erstellt werden. Hier werden auch die Zertifikate angegeben.

Empfangen

Ein Administrator muss ein Empfangskonto für BizTalk Server erstellen, um die Sicherheit auf der Empfängerseite von SMTP unter Verwendung von Microsoft Exchange Server zu implementieren. Nach dem Einrichten des Kontos können Handelspartner ihre öffentlichen Schlüssel an Exchange Server senden, woraufhin die Anwendung den Absender (Handelspartner) authentifiziert. Die öffentlichen Schlüssel werden zum Exchange Server-Zertifikatspeicher hinzugefügt.

Wenn Exchange Server eine Nachricht empfängt, sendet die Submit-Methode die Daten an BizTalk Server. BizTalk Server gleicht das Zertifikat mit dem öffentlichen Schlüssel ab. Bei einer Übereinstimmung entschlüsselt BizTalk Server die Daten und verarbeitet anschließend das Dokument.

Verwandte Themen

Messagingportelemente

Auswählen eines Transporttyps

Auswählen eines Verschlüsselungszertifikats

Festlegen von Transporteigenschaften


Message Queuing2.0

BizTalk Server-Kopfzeile

Message Queuing 2.0

Message Queuing 2.0 unterstützt Datenschutz und Sicherheit durch Folgendes:

  • Zugriffssteuerung

  • Überwachung

  • Verschlüsselung

  • Authentifizierung

Message Queuing nutzt auch das in Microsoft Windows 2000 enthaltene Sicherheitsprotokoll Kerberos V5 und unterstützt darüber hinaus die 128-Bit- und 40-Bit-Verschlüsselung. Message Queuing kann auch verwendet werden, um Anwendungen zu integrieren und um eine PUSH-orientierte Umgebung zwischen Anwendungen zur Übermittlung von Geschäftsereignissen zu implementieren. Außerdem können mithilfe von Message Queuing zuverlässige Anwendungen erstellt werden, die in nicht zuverlässigen, jedoch kostengünstigen Netzwerken eingesetzt werden.

Mithilfe von Message Queuing können Daten innerhalb einer Organisation oder mit einem Handelspartner sicher ausgetauscht werden. BizTalk Server 2000 verwendet Message Queuing, um mithilfe der folgenden Methoden Daten zu senden und zu empfangen:

Senden

Die erste Sicherheitsebene für Message Queuing bilden ein Benutzername und ein Kennwort, die angegeben werden müssen, um Daten in Message Queuing zu speichern oder daraus abzurufen. Außerdem kann Message Queuing Daten speichern, die über ein Zertifikat verfügen. Im BizTalk-Messaging-Manager können die Benutzer ein Zertifikat für Daten angeben, die in einer Nachrichtenwarteschlange gespeichert sind.

Empfangen

Wenn ein Administrator für eine Nachrichtenwarteschlange Anmeldeeigenschaften erstellt, müssen zum Abrufen der Daten ein Benutzername und ein Kennwort angegeben werden. Das Erstellen von Anmeldeeigenschaften stellt eine grundlegende Sicherheitsebene dar. Wenn ein Handelspartner zu den Daten ein Zertifikat hinzugefügt hat, muss eine Kopie seines privaten Schlüssels empfangen werden, um die Daten zu entschlüsseln, bevor BizTalk Server das Paket verarbeiten kann.

Verwandte Themen

Hinzufügen einer Message Queuing-Empfangsfunktion

Konfigurieren von erweiterten Eigenschaften für Datei- oder Message Queuing-Empfangsfunktionen

Konfigurieren einer Message Queuing-Empfangsfunktion: Registerkarte "Allgemein"

Konfigurieren einer Message Queuing-Empfangsfunktion: Registerkarte "Dienste"

Auswählen eines Transporttyps

Festlegen von Transporteigenschaften


Datei

Microsoft Windows 2000 sichert Daten- und Systemschutz durch die Definition einer wahlfreien Dateizugriffssteuerung. Das für BizTalk Server 2000 erforderliche Windows NTFS-Dateisystem kann Benutzer am Beschädigen von wichtigen System- und Anwendungsdateien hindern. NTFS bietet ferner einen zuverlässigen Schutz für die Hilfsdateien in einer Anwendung.

Mithilfe der Dateispeicherung können Daten innerhalb einer Organisation oder mit einem Handelspartner sicher ausgetauscht werden. Die Dateispeicherung kann auch verwendet werden, um Daten auf folgende Weise zu senden und zu empfangen:

Senden

Die erste Sicherheitsebene der Dateispeicherung bilden ein Benutzername und ein Kennwort, die erforderlich sind, um Daten in einem Ordner zu speichern oder daraus abzurufen. Darüber hinaus können in Ordnern Daten gespeichert werden, die über ein zugeordnetes Zertifikat verfügen. Erstellen Sie mit dem BizTalk Messaging Manager ein Zertifikat für die Daten, die in einem Ordner gespeichert werden sollen, um diese weitere Sicherheitsebene zu verwenden.

Empfangen

Wenn einem Ordner Anmeldeeigenschaften zugewiesen wurden, müssen zum Abrufen der Daten ein Benutzername und ein Kennwort angegeben werden. Der Administrator kann für bestimmte Benutzer verschiedene Zugriffsstufen (Lesen, Löschen usw.) für das Dateiverzeichnis bestimmen. Wenn ein Handelspartner zu den Daten ein Zertifikat hinzugefügt hat, muss eine Kopie seines privaten Schlüssels empfangen werden, um die Daten zu entschlüsseln, bevor BizTalk Server das Paket verarbeiten kann. Eingehende Dokumente können auch digital signiert werden, um sicherzustellen, dass der Absender das Senden des Dokuments nicht bestreiten kann.

Verwandte Themen

Hinzufügen einer Dateiempfangsfunktion

Konfigurieren von erweiterten Eigenschaften für Datei- oder Message Queuing-Empfangsfunktionen

Konfigurieren einer Dateiempfangsfunktion: Registerkarte "Allgemein"

Konfigurieren einer Dateiempfangsfunktion: Registerkarte "Dienste"

Auswählen eines Transporttyps

Festlegen von Transporteigenschaften


Sicherheit für Hostanwendungen für XLANG-Ablaufplaninstanzen

Nach dem Installieren der BizTalk-Orchestrierungsdienste können Sie für Folgendes Sicherheitsebenen festlegen:

  • Erstellen neuer XLANG-Ablaufplaninstanzen

  • Interagieren mit vorhandenen XLANG-Ablaufplaninstanzen

  • Verwaltungsfunktionen für XLANG-Ablaufplaninstanzen

  • Anwendungen, die als Host für XLANG-Ablaufplaninstanzen dienen

Anwendungen, die als Host für XLANG-Ablaufplaninstanzen dienen, bauen auf der rollenbasierten Sicherheit auf, einem automatischen Dienst, der von COM+ bereitgestellt wird. Mithilfe der rollenbasierten Sicherheit können die Benutzer Zugriffsteuerungsrichtlinien für COM+-Anwendungen erstellen und erzwingen. Dank eines flexiblen und erweiterbaren Sicherheitskonfigurationsmodells bietet die rollenbasierte Sicherheit beachtliche Vorteile gegenüber dem Erzwingen der gesamten Sicherheit innerhalb von Komponenten. Es gibt zwei Standard-COM+-Anwendungen, die XLANG-Ablaufplanung (XLANG Scheduler) und XLANG-Hilfsprogrammkomponente für Ablaufplanungspersistenz (XLANG Scheduler Persistence Helper), die bei der Installation der BizTalk-Orchestrierungsdienste automatisch erstellt werden. Die COM+-Anwendung XLANG-Ablaufplanung (XLANG Scheduler) hat vier Rollen, mit denen die Sicherheit von Ablaufplaninstanzen ungeachtet der COM+-Anwendung gewährleistet werden kann, in der diese ausgeführt werden. Die vier Rollen heißen folgendermaßen:

  • XLANG-Ablaufplanersteller. Mithilfe dieser Rolle können angegebene Benutzer XLANG-Ablaufplaninstanzen erstellen. Wenn ein Administrator einem Benutzer z. B. das Erstellen einer XLANG-Ablaufplaninstanz ermöglichen möchte, muss er den Benutzer zur Mitgliederliste dieser Rolle hinzufügen. Ein Benutzer, der nicht als Mitglied dieser Rolle aufgeführt ist, und versucht, eine XLANG-Ablaufplaninstanz zu erstellen, erhält eine Fehlermeldung, die besagt, dass der Zugriff verweigert wurde. Darüber hinaus im Ereignisprotokoll ein Eintrag mit entsprechenden Informationen generiert.

  • XLANG-Ablaufplanbenutzer. Mithilfe dieser Rolle können angegebene Benutzer mit XLANG-Ablaufplaninstanzen interagieren. Wenn ein Administrator einem Benutzer z. B. das Interagieren mit einer Ablaufplaninstanz ermöglichen möchte, muss er den Benutzer der Mitgliederliste dieser Rolle hinzufügen. Ein Benutzer, der nicht als Mitglied dieser Rolle aufgeführt ist und versucht, mit einer Ablaufplaninstanz zu interagieren, erhält eine Fehlermeldung, die besagt, dass der Zugriff verweigert wurde. Darüber hinaus wird im Ereignisprotokoll ein Eintrag mit entsprechenden Informationen generiert.

  • XLANG-Ablaufplanungsadministrator. Mit dieser Rolle wird angegeben, wer über Administratorrechte für die folgenden Aufgaben verfügen soll:
    • Ermitteln, ob eine COM+-Anwendung als Host für XLANG-Ablaufplaninstanzen dienen kann.

    • Festlegen des DSN-Typs einer COM+-Anwendung, die als Host für XLANG-Ablaufplaninstanzen dient, und des Statusverwaltungswertes der Persistenzebene, die die COM+-Anwendung unterstützen muss.

    • Herunterfahren aller XLANG-Ablaufplaninstanzen.

    • Anhalten, Fortsetzen oder Beenden einer XLANG-Ablaufplaninstanz.
  • XLANG-Ablaufplanungsanwendung. Diese Rolle wird von der XLANG-Ablaufplanung für die Interaktion mit einer beliebigen vom Benutzer erstellen COM+-Anwendung verwendet. Deshalb muss die Rolle dieselbe Identität beinhalten, die von COM+-Anwendung für die Ausführung verwendet wird.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Empfohlene Vorgehensweisen für das Sichern von COM+-Anwendungen

  • Sichern der Persistenzdatenbank für die Orchestrierung

  • Bestätigen der Absenderidentität

Verwandtes Thema

XLANG-Ablaufpläne


Empfohlene Vorgehensweisen für das Sichern von COM+-Anwendungen

Mithilfe von Rollen kann ein Administrator Autorisierungsrichtlinien für eine Anwendungen erstellen und auswählen (ggf. bis hinunter auf die Methodenebene), welche Benutzer auf welche Ressourcen zugreifen dürfen. Da für alle XLANG-Ablaufpläne COM+Serveranwendungen als Host dienen, kann der Zugriff auf die installierten COM-Objekte eingeschränkt werden, indem für verschiedene Rollen Sicherheitseigenschaften konfiguriert werden.

Wichtig

  • Wenn auf der Komponentenebene Sicherheitseigenschaften hinzugefügt werden, werden einzelne Komponenten, Schnittstellen und Methoden, die auf den Rolleneinstellungen auf diesen Ebenen basieren, ebenfalls eingeschränkt. Weitere Informationen zur COM+-Sicherheit finden Sie in der MSDN Online Library-Website (msdn.microsoft.com/library/default.asp). Suchen Sie in der Website nach der Seite "Security in COM+".

Empfehlungen für das Sichern von COM+-Anwendungen

Die folgenden Empfehlungen gelten hauptsächlich für das Sichern bereitgestellter Anwendungen:

  • Konfigurieren Sie eine COM+-Anwendung nicht mit interaktiver Benutzeridentität. COM+-Anwendungen, welche die interaktive Benutzeridentität verwenden, können nur verwendet werden, wenn sich ein Benutzer bei dem Computer anmeldet, auf dem sich die Anwendung befindet. Ist kein Benutzer angemeldet, kann die COM+-Anwendung nicht ausgeführt werden. Wenn ein Benutzer eine COM+-Anwendung mithilfe der interaktiven Benutzeridentität erstellt, wird es schwieriger, den Zugriff auf die entsprechende Persistenzdatenbank und andere Ressourcen zu konfigurieren. Weitere Informationen zu Dienstkonten finden Sie unter Verwenden eines Dienstkontos.

  • Konfigurieren Sie die Identität der XLANG-Ablaufplanung (XLANG Scheduler) neu. Während der Installation wird die XLANG-Ablaufplanung automatisch als Interaktiver Benutzer konfiguriert. Diese Konfiguration ist für die meisten Entwickler geeignet. In Produktionssystemen müssen Sie die Identitätseigenschaft der XLANG-Ablaufplanung (XLANG Scheduler) ändern, damit die Anwendung unter einem eindeutigen Benutzerkonto ausgeführt wird. Die Identität wird von allen Nachrichten verwendet, die von der XLANG-Ablaufplanung (XLANG Scheduler) gesendet werden.

    Anmerkung

    • Wenn der Client der Microsoft Windows 2000 Terminaldienste zum Initiieren eines XLANG-Ablaufplanes verwendet wird, muss die Identität der COM+-Anwendung, die als Host für das XLANG-Ablaufplanungsmodul dient, auf einen gültigen Windows 2000-Benutzer- oder -Gruppennamen festgelegt werden. Die Identität der COM+-Anwendung wird auf der Registerkarte Identität im Eigenschaftendialogfeld dieser Anwendung festgelegt. Die Identität darf nicht auf interaktiv festgelegt werden, wenn das XLANG-Ablaufplanungsmodul in einer Sitzung verwendet wird, für die die Terminaldienste als Host dienen.
  • Erstellen Sie eine neue COM+-Anwendung mit einer eindeutigen Identität für alle Hostanwendungen für XLANG-Ablaufplaninstanzen. Erstellen Sie für jeden Geschäftsprozess, wie z. B. Einkauf, eine neue COM+-Anwendung mit eindeutigen Sicherheitsanforderungen. Dadurch können für jede Anwendung individuelle Sicherheitsebenen angeben werden. Darüber hinaus wird ein Schutz vor sehr großen Schäden bereitgestellt, der von instabilem Anwendungscode verursacht werden kann. Auch das Überwachen der Operationen einzelner Anwendungen wird erleichtert.

  • Installieren Sie anwendungsspezifische Komponenten in die zugeordneten Geschäftsprozesse. Dadurch werden Daten geschützt und Anwendungen ausgeschlossen, die keinen Zugriff auf diese Komponenten haben. Voraussetzung dafür ist, dass die Serveranwendung entsprechend geschützt ist.

    Anmerkung

    • Jede COM+-Anwendung muss mindestens eine Komponente enthalten. Wenn keine anwendungsspezifische Komponente installiert ist, muss in der Anwendung eine Platzhalterkomponente erstellt und installiert werden. Andernfalls steht die COM+-Anwendung nicht zur Verfügung.
  • Ändern Sie die Standardeinstellungen für die Mitgliederliste der Rollen der XLANG-Ablaufplanung (XLANG Scheduler), um die Sicherheit zu erhöhen. Bei der Installation von BizTalk Server wird die XLANG-Ablaufplanung (XLANG Scheduler) mit den folgenden Rollen und Standardeinstellungen erstellt und konfiguriert:
    • XLANG-Ablaufplanersteller. Standardeinstellung für die Rollenmitgliedschaft: Jeder.

    • XLANG-Ablaufplanbenutzer. Standardeinstellung für die Rollenmitgliedschaft: Jeder.

    • XLANG-Ablaufplanungsadministrator. Standardeinstellung für die Rollenmitgliedsschaft: Administratoren.

    • XLANG-Ablaufplanungsanwendung. Standardeinstellung für die Rollenmitgliedschaft: Jeder.

Verwandte Themen

Ändern der Anwendungsidentität der Standardanwendung XLANG-Ablaufplanung (XLANG Scheduler)

Erstellen einer COM+-Hostanwendung für XLANG-Ablaufpläne

XLANG-Ablaufpläne


Sichern der Persistenzdatenbank für die Orchestrierung

Wenn eine COM+-Anwendung erstellt wird, die als Host für XLANG-Ablaufplaninstanzen dient, muss der COM+-Anwendung eine Persistenzdatenbank zugeordnet werden. Erstellen Sie deshalb zuerst in Microsoft SQL Server eine Persistenzdatenbank. Beim Erstellen einer Datenbank muss ausgewählt werden, ob die SQL Server- oder die Microsoft Windows 2000-Authentifizierung verwendet werden soll. Nach dem Erstellen der Datenbank muss ein Benutzer der COM+-Anwendung Berechtigungen erteilen, die später als Host für XLANG-Ablaufplaninstanzen dienen wird. Stellen Sie sicher, dass die COM+-Anwendung über Berechtigungen zum Erstellen von Tabellen und Prozeduren in der zugeordneten Persistenzdatenbank verfügt. Die Interaktion zwischen den BizTalk-Orchestrierungsdiensten und der standardmäßigen BizTalk Server-Persistenzdatenbank für die Orchestrierung basiert auf dem Sicherheitsmodell von Windows 2000 und nicht auf dem von SQL Server.

Verwandtes Thema

Verwalten der Standardanwendung XLANG-Ablaufplanung (XLANG Scheduler) und -Datenbank


Bestätigen der Absenderidentität

Während des Ablaufplanentwurfs können verschiedene Formen verwendet werden, um die Implementierungstechnologien zu beschreiben, die zum Implementieren eines Ports in einen Geschäftsprozess verwendet werden. Die COM-Komponente-Form stellt eine Technologie dar, mit der ein Port mithilfe eines Methodenaufrufs für jede Nachricht implementiert werden kann, die gesendet oder empfangen wird. Die Skriptkomponente-Form stellt eine Technologie dar, mit der ein Port mithilfe eines Methodenaufrufs für jede Nachricht implementiert werden kann, die gesendet oder empfangen wird. Die Message Queuing-Form stellt eine Technologie dar, mit der ein Port implementiert wird. Die Message Queuing-Transportdienste werden zum Senden und Empfangen von Nachrichten verwendet. Wird eine der drei Technologien hinzugefügt, kann ein Benutzer fordern, dass vor dem Empfang von Nachrichten die Absenderidentität bestätigt werden muss.

Weitere Informationen zu COM-Komponenten, Windows-Skriptkomponenten oder zur Message Queuing-Sicherheit für XLANG-Ablaufpläne finden Sie unter Implementieren eines Ports mithilfe einer COM-Komponente, Implementieren eines Ports mithilfe einer Windows Script-Komponente und Implementieren eines Ports mithilfe von Message Queuing.

Verwandte Themen

Verwenden der COM-Komponente-Form

Verwenden der Message Queuing-Form

Verwenden der Skriptkomponente-Form


Zertifikate - Übersicht

Digitale Zertifikate binden einen kryptografischen Schlüssel an ein oder mehrere Attribute eines Benutzers. Die von Zertifizierungstellen ausgestellten Zertifikate schützen das Internet, indem die Authentizität von Netzwerknachrichten zugesichert wird. Diese Technologie und die dazugehörigen digitalen Signaturen treiben gegenwärtig die Bereitstellung des E-Commerce im Internet voran.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Grundlegendes zu Zertifikaten

  • Von BizTalk Server benötigte Zertifikate

  • Beschränkungen für Zertifikatsnamen


Grundlegendes zu Zertifikaten

Microsoft BizTalk Server 2000 basiert grundlegend auf der von Zertifikaten bereitgestellten Sicherheitsfunktionen. Durch die Verwendung öffentlicher Schlüssel zur Verschlüsselung der Daten und privater Schlüssel zur Datenentschlüsselung kann BizTalk Server vertrauenswürdige Daten senden und gewährleisten, dass die verarbeiteten Daten sicher sind. Die zur Microsoft Management Console gehörenden Richtlinien öffentlicher Schlüssel ermöglichen die Konfiguration von Agents für die Wiederherstellung verschlüsselter Daten für das Verschlüsselnde Dateisystem, domänenweiter Stammzertifizierungsstellen, vertrauter Zertifizierungsstellen usw. Zertifikate enthalten ferner digitale Signaturen, die auf Dokumente angewendet und bei eingehenden Dokumenten mithilfe der systemeigenen Unterstützung von BizTalk Server für digitale Signaturen überprüft werden können.

Zertifikate werden für die Authentifizierung und die Sicherheit des Austauschs von Informationen in ungesicherten Netzwerken verwendet, wie z. B. dem Internet. Zertifikate können für einen Benutzer, einen Computer oder einen Dienst verwaltet werden. Der in Windows 2000 integrierte auf X.509 basierende Zertifikatsserver für öffentliche Schlüssel ermöglicht Organisationen das Ausstellen von Zertifikaten öffentlicher Schlüssel für die Authentifizierung ihrer Benutzer, ohne von den Diensten kommerzieller Zertifizierungsstellen abhängig zu sein.

BizTalk Server unterstützt Zertifikate mithilfe des BizTalk-Messaging-Managers. Zertifikate erleichtern die Ver- und Entschlüsselung von Daten sowie ihre digitale Signatur. Die Verschlüsselung öffentlicher Schlüssel wird für alle Dokumente unterstützt, die mithilfe den BizTalk Server-Transportdiensten übermittelt werden. BizTalk Server unterstützt außerdem die Entschlüsselung und Signaturüberprüfung für empfangene Dokumente.

Computerschlüssel und Benutzerschlüssel: Vergleich

Beim Abrufen von Zertifikaten sollten dem Computer zugeordnete Computerschlüssel verwendet werden und nicht Benutzerschlüssel, die dem aktuell angemeldeten Benutzer zugeordnet sind. Wenn ein aktuell bei einem Server angemeldeter Benutzer ein Zertifikat mit Benutzerschlüsseln abruft, kann nur dieser Benutzer auf das Zertifikat zugreifen, da das Zertifikat UserKey die Anmeldeinformationen des Benutzers enthält. Wenn demnach ein Benutzer auf Zertifikate mit Benutzerschlüsseln in BizTalk Server zugreifen müssen, muss BizTalk Server im Kontext dieses Benutzers ausgeführt werden. Damit alle Benutzer sich bei BizTalk Server anmelden und auf Schlüssel zugreifen können, müssen Zertifikate über Computerschlüssel verfügen.

Damit BizTalk Server auf Zertifikate (Lokaler Computer) zugreifen kann, muss BizTalk Server als Lokales System oder Administrator ausgeführt werden. Wenn Benutzerschlüssel verwendet werden, muss BizTalk Server im Kontext eines Benutzers ausgeführt werden, der auch Administrator sein muss.


Von BizTalkServer benötigte Zertifikate

BizTalk Server-Kopfzeile

Von BizTalk Server benötigte Zertifikate

Ein Zertifikatsserver speichert Zertifikate für einen Benutzer und einen Computer. Benutzer und Computer verfügen über eigene Zertifikatsspeicher. Wenn ein Benutzer ein Zertifikat erstellt, geht Windows 2000 davon aus, dass das Zertifikat für den Benutzer vorgesehen ist. Eine Organisation muss ihre Zertifikate im privaten Speicher ablegen, der in der Konsole Zertifikate unter Zertifikate (Lokaler Computer) zu finden ist. BizTalk Server 2000 muss alle Handelspartnerzertifikate im BizTalk-Speicher ablegen, der sich in der Konsole Zertifikate unter Zertifikate (Lokaler Computer) befindet, um eine ordnungsgemäße Sicherheit zu gewährleisten.

Wenn zur Entwurfszeit Messagingports und Kanäle erstellt werden, muss ein Benutzer über alle Handelspartnerzertifikate verfügen, die dem BizTalk-Speicher in der Konsole Zertifikate unter Zertifikate (Lokaler Computer) und nicht dem Benutzer zugeordnet sind. Beim Angeben der Sicherheit, wie z. B. Verschlüsselung oder Signaturüberprüfung, für Handelspartner mithilfe des BizTalk-Messaging-Managers handelt es sich bei den angezeigten Zertifikaten um die Handelspartnerzertifikate im BizTalk-Speicher. Der BizTalk-Messaging-Manager zeigt die Zertifikate im privaten Speicher unter Zertifikate (Lokaler Computer) der Konsole Zertifikate an, wenn für SSL-Clients die Sicherheit angegeben wird, wie z. B. überprüfte Entschlüsselung und Signatur. Der Speicherort von Zertifikaten ist wichtig. Wenn also ein Benutzer zur Laufzeit versucht, Dokumente mithilfe von BizTalk Server zu verarbeiten, fungiert der Computer als Hintergrunddienst, und gerade dieser Dienst muss auf die Zertifikate zugreifen können.

Es gibt zwei Möglichkeiten, Probleme hinsichtlich des Speicherortes von Zertifikaten zu beheben:

  • Wenn ein Benutzer bereits Zertifikate erstellt hat, wurden diese von Windows 2000 im Benutzerspeicher gespeichert. Die Zertifikate müssen aus dem Benutzerspeicher in den entsprechenden Speicher unter Zertifikate (Lokaler Computer) verschoben werden. Dieser Prozess erfolgt über die Zertifikatsverwaltung.

  • Wenn ein Benutzer ein Dienstkonto erstellt hat, werden alle Zertifikate dem Computer und nicht dem Benutzer zugeordnet.

Zertifikatsverwaltung über Windows 2000

Die Zertifikatsverwaltung in BizTalk Server erfolgt über Microsoft Windows 2000. Eng integriert in das Windows 2000-Sicherheitsmodell sind Internet-Informationsdienste 5.0 (IIS, Internet Information Services), die einen Zertifikatsserver enthalten. Dieser ermöglicht Organisationen das Ausstellen und Verwalten digitaler dem Internetstandard X.509 entsprechender Zertifikate. Neben den Schlüsselverwaltungsdiensten stellt IIS 5.0 auch den Microsoft Zertifikatsserver bereit, der anpassbare Dienste für das Ausstellen und Verwalten digitaler Zertifikate zur Verfügung stellt. Ein Zertifikatsserver verfügt über eine zentrale Rolle bei der Verwaltung von Softwaresicherheitssystemen und ermöglicht sichere Datenübertragungen über das Internet, über Firmennetzwerke und über andere ungesicherte Netzwerke.

Folgendes Thema wird in diesem Abschnitt behandelt:

  • Erstellen einer Zertifikatsverwaltung

Verwandte Themen

Auswählen eines Zertifikats für die ausgehende Signatur

Auswählen eines Zertifikats zum Überprüfen der Entschlüsselung eingehender Dokumente

Auswählen eines Zertifikats zum Überprüfen der Signatur eingehender Dokumente

Auswählen eines Verschlüsselungszertifikats


Erstellen einer Zertifikatsverwaltung

  1. Klicken Sie im Startmenü auf Ausführen, und geben Sie mmc ein.

    Das Dialogfeld Konsole1 wird angezeigt.

  2. Klicken Sie im Menü Konsole auf Snap-In hinzufügen/entfernen.

    Das Dialogfeld Snap-In hinzufügen/entfernen wird angezeigt.

  3. Klicken Sie auf Hinzufügen.

    Das Dialogfeld Eigenständiges Snap-In hinzufügen wird angezeigt.

  4. Klicken Sie auf Zertifikate und dann auf Hinzufügen.

    Das Dialogfeld Zertifikat-Snap-In wird angezeigt.

  5. Klicken Sie Computerkonto, dann auf Weiter und schließlich auf Fertig stellen.

  6. Klicken Sie im Dialogfeld Eigenständiges Snap-In hinzufügen auf Zertifikate und dann auf Hinzufügen.

    Das Dialogfeld Zertifikat-Snap-In wird angezeigt.

  7. Klicken Sie auf Computerkonto, und klicken Sie auf Weiter. Klicken Sie auf Fertig stellen und dann auf Schließen. Klicken Sie dann auf OK, um das Dialogfeld zu schließen.

Verwandtes Thema

Zertifikate - Übersicht


Beschränkungen für Zertifikatsnamen

Microsoft BizTalk Server 2000 lässt keine identischen Zertifikatsnamen zu. Wenn Zertifikate mit gleichen Namen vorhanden sind, kann im BizTalk-Messaging-Manager nur eines der Zertifikate ausgewählt werden. Wenn z. B. eine Organisation zwei Zertifikate mit dem gleichen Namen und Verweis verwendet, kann die Organisation nicht beide Zertifikate verwenden. Wenn die Organisation eines der Zertifikate verwendet, wird das andere aus der Liste der verfügbaren Zertifikate im Dialogfeld Kanal entfernt.


Krypto-API

Microsoft BizTalk Server 2000 verwendet Krypto-API, um die verarbeiteten Daten zu sichern. Auf Grund aktueller Entwicklungen im Bereich der Kryptografie haben sich neue Funktionen ergeben, einschließlich Mechanismen für das Authentifizieren von Benutzern in einem Netzwerk, welch die Integrität übermittelter Informationen sicherstellen und Benutzer daran hindern, das Absenden ihrer übermittelten Nachrichten zu bestreiten.

Alle Anwendungen, Nachrichten, Daten usw., welche die Verschlüsselung bzw. die Microsoft-spezifische Verschlüsselung verwenden, wie z. B. Microsoft Windows 2000 zum Erstellen von Zertifikaten, verwenden Krypto-API. BizTalk Server verwendet Krypto-API für Empfangsfunktionen, die ein Benutzer beim Verwenden einer benutzerdefinierten COM+-Komponente angibt, z. B. einer Präprozessorkomponente. Dadurch kann BizTalk Server eindeutige Verschlüsselungskomponenten verarbeiten.


CDOs (Collaborative Data Objects)

Microsoft BizTalk Server 2000 erfordert die MIME-Codierung für alle gesendeten und empfangenen Daten. Mithilfe der zur Windows 2000-Umgebung gehörenden Collaborative Data Objects (CDOs) können Daten codiert und von BizTalk Server verarbeitet werden. Bevor BizTalk Server z. B. einen Katalog senden kann, der Text und Grafiken enthält, muss der Datentyp der Grafikdaten zuerst von Binary in String geändert werden. CDOs codieren Text und Grafiken in ein Zeichenfolgenformat, das BizTalk Server dann verarbeiten kann.


Verbessern von Leistung und Skalierbarkeit

Wenn Sie mit den verschiedenen Komponenten von BizTalk Server 2000 vertraut sind, können Sie skalierbare Hochleistungslösungen erstellen. Zur Verbesserung der Leistung von BizTalk Server stehen zahlreiche Verfahren zur Verfügung. Hierzu zählen die Ermittlung potenzieller Engpässe, die Beobachtung von Wartezeiten und die Verwaltung von Datenbanken. Inwieweit Sie eine optimale Lösung erzielen können, richtet sich jedoch nach der Komplexität der Systemarchitektur Ihrer Organisation und nach den Budgetanforderungen.

Die Optimierung der BizTalk-Messaging-Verwaltungsdatenbank, der Datenbank für gemeinsam genutzte Warteschlangen, der Überwachungsdatenbank und der Persistenzdatenbank für die Optimierung ist äußerst wichtig, um eine optimale Leistung in Verbindung mit BizTalk Server zu erzielen. Weitere Informationen zur Optimierung der Datenbanken erhalten Sie unter Zentrales Skalieren der Datenbanken und Dezentrales Skalieren der Datenbanken.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Skalieren von BizTalk Server

  • Leistungsoptimierung


Skalieren von BizTalkServer

BizTalk Server-Kopfzeile

Skalieren von BizTalk Server

Zur Optimierung der Leistung wird dringend die Verteilung der Hauptkomponenten auf mehrere Server empfohlen. BizTalk Server 2000 enthält folgende Hauptkomponenten:

  • BizTalk-Dienste. Zu diesen Diensten zählen die BizTalk-Messagingdienste und die BizTalk-Orchestrierungsdienste. Weitere Informationen finden Sie unter BizTalk-Dienste.

  • Datenbanken. Zu den Datenbanken zählen die BizTalk-Messaging-Verwaltungsdatenbank, die Überwachungsdatenbank, die Datenbank für gemeinsam genutzte Warteschlangen und die Persistenzdatenbank für die Orchestrierung.

  • Transportdienste. Zu den Transportdiensten gehören HTTP-, SMTP- und Dateidienste sowie Message Queuing. Jede Komponente weist eindeutige Skalierungsanforderungen auf.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Vertikales Skalieren von BizTalk Server

  • Horizontales Skalieren von BizTalk Server

Verwandte Themen

Verwalten von BizTalk Server-Datenbanken

Verwalten der BizTalk-Messaging-Verwaltungsdatenbank

Persistenz

Festlegen von Transporteigenschaften

Datenbank für gemeinsam genutzte Warteschlangen

Überwachungsdatenbank


Vertikales Skalieren von BizTalkServer

BizTalk Server-Kopfzeile

Vertikales Skalieren von BizTalk Server

Mithilfe mehrerer Prozessoren und eines großen Speichervolumens kann BizTalk Server 2000 vertikal skaliert werden (zentrale Skalierung). Die vertikale Skalierung von BizTalk Server erfordert zwar weniger Server und ermöglicht eine problemlosere Standortverwaltung, diese Art der Skalierung verursacht jedoch höhere Kosten als die horizontale Skalierung und die Verbesserung der Softwarearchitektur. Sobald die maximale Kapazität der vorhandenen Hardware erreicht ist, müssen Sie mit der horizontalen Skalierung des Systems beginnen.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Zentrales Skalieren von BizTalk Server

  • Zentrales Skalieren der Datenbanken

  • Zentrales Skalieren der Transportdienste


Zentrales Skalieren von BizTalkServer

BizTalk Server-Kopfzeile

Zentrales Skalieren von BizTalk Server

Für die vertikale Skalierung von BizTalk Server 2000 wird die Durchführung folgender Schritte empfohlen:

  • Einsatz eines größeren Prozessors (z. B. Pentium III und die entsprechenden Xeon-Ableitungen mit großem L2-Cache).

  • Verwendung von SMP-Servern (Symmetric Multiple Processing) mit maximal 8 CPUs.

  • Verringern von Datei-E/A und Netzwerkengpässen.

  • Ausführen von Microsoft Windows 2000 Server auf SMP-Servern mit maximal 4 Prozessoren.

    Anmerkung

    • Wenn Microsoft Windows 2000 Server auf einer CPU ausgeführt wird, wird die Leistung durch das Hinzufügen von 3 CPUs verbessert. Dabei wird die Verarbeitungsgeschwindigkeit einer CPU jedoch nicht um das Vierfache gesteigert.

Empfohlene Lösungen für die vertikale Skalierung von BizTalk Server

Um eine optimale Leistung in Verbindung mit BizTalk Server zu erzielen, wird der Einsatz der folgenden Komponenten und die Durchführung der genannten Schritte empfohlen:

  • Ein PIII Xeon MHz-Prozessorsystem mit mehreren Prozessoren (die höchstmögliche Taktfrequenz (MHz) für maximale Leistung), das auf 8 CPUs erweitert werden kann.

  • Ein L2-Prozessorcache mit 1 bis 2 MB (verbessert die Analyseleistung).

  • 512 MB RAM (höherer RAM-Speicher, wenn eine Organisation Dokumente mit mehreren MB verarbeitet).

  • Mehrere Netzwerkkarten mit 100 Mbit/s (Megabits pro Sekunde) oder größer, Netzwerkkarten verbunden mit 100 MB/s-Switchports zur Erhöhung des Netzwerk-E/A-Durchsatzes.

  • Bereitstellen mehrerer Datenträger und Controller für Message Queuing und DTC-Datei- und Protokolloperationen (Distributed Transaction Coordinator). Erstellen von DTC-Protokolloperationen auf einem zentralen Remoteserver, um den Datei-E/A-Inhalt auf den lokalen BizTalk Server zu laden.

  • Verwenden von doppelt vernetzten Netzwerkschnittstellenkarten (NICs) in den BizTalk-Servern, um HTTP-Prozesse von den abhängigen SQL Server-Prozessen der Datenbank für gemeinsam genutzte Warteschlangen und der BizTalk-Messaging-Verwaltungsdatenbank zu trennen.

  • Bei diesen Empfehlungen wird davon ausgegangen, dass BizTalk Server auf einem abhängigen Server ausgeführt wird. Wenn die BizTalk-Dienste den Server gemeinsam mit anderen Anwendungsdiensten verwenden, wird der Einsatz zusätzlicher Hardware empfohlen.


Zentrales Skalieren der Datenbanken

Wenn Sie die Datenbanken vertikal skalieren möchten, müssen Sie die Festplattenkonfiguration ermitteln. Hierbei müssen Sie Durchsatz, Failover und Kosten berücksichtigen.

In der folgende Tabelle werden die verfügbaren Optionen aufgeführt und die einzelnen Optionen miteinander verglichen.

RAID-Stufe | Kosten | Effektive Festplattenauslastung (Prozent) | Geschwindigkeit | Fehlertoleranz
0 (Striping) | Niedrig | 100 | Schnell | Niedrig
1 (Spiegeln) | Hoch | 50 | Mittel | Hoch
5 (Striping mit Parität) | Mäßig | Der effektive Speicherplatz ist der gesamte Speicherplatz aller Festplatten im Array minus 1 (für die Parität) | Langsam | Mäßig (Leistung sinkt nur bei fehlerhafter Festplatte)

Zur Erzielung einer optimalen Leistung empfiehlt es sich, einen effizienten RAID-Controller (Redundant Array of Independent Disks) für die Zwischenspeicherung mit einer schnellen CPU und umfangreichem permanenten RAM-Speicher zu installieren. Darüber hinaus können Sie auch mehrere RAID-Stufen miteinander kombinieren, um die gewünschte Leistung zu erreichen. Beispielsweise bietet RAID 0 die beste Leistung, stellt jedoch keine Fehlertoleranz zur Verfügung. RAID 1 stellt die bestmögliche Fehlertoleranz bereit, jedoch nicht die beste Leistung (da Daten nur auf eine Festplatte und nicht gleichzeitig auf mehrere Festplatten geschrieben werden). Um eine optimale Leistung zu erzielen, können Sie RAID 1 und RAID 0 kombinieren, indem Sie einen Satz von Stripesetdatenträgern spiegeln.

Anmerkungen

  • RAID 5 erreicht oder übersteigt weder die Geschwindigkeit noch die Kosten jeder anderen RAID-Stufe. RAID 5 stellt deutliche Vorteile bereit, ist jedoch beim Schreiben von Daten auf Festplatten langsamer als RAID 0 oder RAID 1.

  • Für jede Strategie ist die Anzahl der Festplattencontroller von großer Bedeutung. Die Gesamtleistung lässt sich deutlich verbessern, wenn Sie eine Festplatte pro Controller verwenden. Bei der Konfiguration von Festplatten ist die effektive Verwendung von Festplattenkanälen ebenfalls wichtig. Bei Festplattenkanälen handelt es sich um Festplatten, die den gleichen Controller verwenden. Die Festplatten können als eigenständige Festplatten konfiguriert oder als Teil eines Arrays ausgeführt werden. Wenn ein Server beispielsweise 10 Festplatten enthält, von denen jeweils 5 in 2 Arrays angeordnet sind und jedes Array mit einem eigenen Controller verbunden ist, sind 2 Festplattenkanäle vorhanden.

Idealerweise befinden sich die BizTalk-Messaging-Verwaltungsdatenbank, die Datenbank für gemeinsam genutzte Warteschlangen, die Überwachungsdatenbank und die Persistenzdatenbank für die Orchestrierung auf separaten Festplattenkanälen. Falls die Systemumgebung der Organisation jedoch erfordert, dass sich die Datenbanken auf einzelnen Servern befinden, ist es wichtig, dass Sie mit der Verwendung jeder Datenbank vertraut sind, wenn Sie das Bereitstellungsszenario planen.

  • Die BizTalk-Messaging-Verwaltungsdatenbank enthält sämtliche Konfigurationsinformationen für BizTalk Server, z. B. Organisationen, Servergruppen, Server, Kanäle und Messagingports. Die Informationen werden gelesen und im Speicher von Microsoft SQL Server zwischengespeichert. Diese Datenbank erhält die geringste Aktivität der 4 Datenbanken und kann sich, falls erforderlich, auf dem gleichen Festplattenkanal befinden wie eine der anderen 3 Datenbanken.

  • Die Datenbank für gemeinsam genutzte Warteschlangen verwaltet die Daten für alle Warteschlangen. Jedes Dokument, für das die asynchrone Kommunikation verwendet wird, wird an die Datenbank für gemeinsam genutzte Warteschlangen gesendet und dort gespeichert. Wenn BizTalk Server bereit ist, das Dokument zu verarbeiten, wird es aus der Datenbank für gemeinsam genutzte Warteschlangen entfernt und verarbeitet. Da die Datenbank sämtliche Transaktionen verwaltet, werden häufig Daten in die Datenbank für gemeinsam genutzte Warteschlangen geschrieben und aus der Datenbank gelesen.

  • Die Überwachungsdatenbank überwacht Dokumente, die den Server durchlaufen, entweder einzeln oder als Batch. In dieser Datenbank werden sowohl die Daten als auch die Protokollinformationen gespeichert. Daher werden häufig Daten in die Überwachungsdatenbank geschrieben, jedoch nur selten Daten aus dieser Datenbank gelesen.

  • Die Persistenzdatenbank für die Orchestrierung speichert die Struktur der XLANG-Ablaufpläne, den Fortschritt der aktivierten XLANG-Ablaufplaninstanzen und die Nachrichten, die gesendet oder empfangen werden, wenn eine XLANG-Ablaufplaninstanz eine Transaktion beginnt oder beendet, das System heruntergefahren wird oder wenn die XLANG-Ablaufplaninstanz pausiert.

Optimierungsempfehlungen für die vertikale Skalierung der Datenbanken

Berücksichtigen Sie Folgendes, um eine optimale Leistung der BizTalk Server-Datenbanken zu erzielen:

  • Ein PIII Xeon MHz-Prozessorsystem mit mehreren Prozessoren (die höchstmögliche Taktfrequenz (MHz) für maximale Leistung), das auf 8 CPUs erweitert werden kann.

  • 512 MB RAM (höherer RAM-Speicher, wenn eine Organisation Dokumente mit mehreren MB verarbeitet).

  • Optimieren der zugrunde liegenden Microsoft SQL Server-Datenbanken und -Protokolle basierend auf den Standardmethoden für Datenbanken. Weitere Informationen zu SQL Server erhalten Sie, wenn Sie im Startmenü zunächst auf Programme und dann auf Microsoft SQL Server zeigen und anschließend auf Onlinedokumentation klicken.

  • Wenn Sie zu Beginn planen, nur wenige Transaktionen durchzuführen, können Sie die Datenbanken auf dem gleichen Festplatten-E/A-Kanal installieren. Wenn weitere Transaktionen verarbeitet werden, fügen Sie Festplatten und/oder Controller auf einem Server hinzu, und verschieben Sie die Datenbanken auf die neuen Festplatten-E/A-Kanäle. Darüber hinaus kann eine einzelne Datenbank auf einen neuen Server verschoben werden. Weitere Informationen zum horizontalen Skalieren der Datenbanken erhalten Sie unter Dezentrales Skalieren der Datenbanken.

So optimieren Sie die BizTalk-Messaging-Verwaltungsdatenbank

  • Installieren Sie die Datenbank auf dem gleichen Festplatten-E/A-Kanal wie die Datenbank für gemeinsam genutzte Warteschlangen oder die Überwachungsdatenbank. Der Inhalt der BizTalk-Messaging-Verwaltungsdatenbank wird im Microsoft SQL Server-Speicher gelesen und zwischengespeichert.

  • Wenn eine Organisation sehr umfangreiche Datenmengen verarbeitet, sollten Sie erwägen, die Datenbank auf einem eigenen Festplatten-E/A-Kanal zu platzieren, damit die Leistung der Datenbank für gemeinsam genutzte Warteschlangen oder der Überwachungsdatenbank nicht beeinträchtigt wird.

So optimieren Sie die Datenbank für gemeinsam genutzte Warteschlangen

  • Falls die CPU-Auslastung 80 Prozent übersteigt, fügen Sie weitere CPUs hinzu.

  • Sofern die durchschnittliche Warteschlangenlänge des Datenträgers mehr als 1 beträgt, oder wenn die Datenträger-E/A-Auslastung 100 Prozent übersteigt, sollten Sie weitere physische Datenträger hinzufügen.

  • Installieren Sie die Datenbank auf einem eigenen Festplatten-E/A-Kanal.

  • Erwerben Sie Datenträger mit der schnellsten Zugriffszeit und Controller mit dem höchsten Durchsatz.

  • Erwägen Sie den Einsatz von RAID 0, und führen Sie eine Spiegelung durch, um Fehlertoleranz zu erhalten.

So optimieren Sie die Überwachungsdatenbank

  • Fügen Sie weitere physische Datenträger hinzu, und erhöhen Sie den Festplattenspeicher der Datenbank für gemeinsam genutzte Warteschlangen.

  • Schätzen Sie die durchschnittliche Dokumentgröße für eine einzelne Transaktion. Multiplizieren Sie die Dokumentgröße mit der Anzahl der Anmeldungen des Dokuments an der Überwachungsdatenbank. Dieser geschätzte Wert gibt an, wie viel Dokumentspeicherplatz je Dokument in der Überwachungsdatenbank erforderlich ist. Multiplizieren Sie den Wert des Dokumentspeicherplatzes mit dem erforderlichen Durchsatz, um zu ermitteln, wie viel Speicher benötigt wird, bevor die Überwachungsdatenbank voll ist. Stellen Sie sicher, dass die Überwachungsdatenbank über ausreichend Speicher verfügt, um ein durchschnittlich großes Dokument zu protokollieren.

  • Installieren Sie die Datenbank auf einem eigenen Festplatten-E/A-Kanal, da umfangreiche Datenmengen in diese Datenbank geschrieben werden. Ein separater Festplatten-E/A-Kanal ist besonders wichtig in Umgebungen, in denen sehr viele Transaktionen durchgeführt werden.

    Anmerkung

    • Für die Überwachung von Austauschvorgängen und Dokumenten existiert eine Größenbeschränkung. Wird diese überschritten, wirkt sich dies deutlich auf die Leistung von BizTalk Server aus. Weitere Informationen zur Größenbeschränkung erhalten Sie unter Austausch- und Dokumentgrößenbeschränkung.

So optimieren Sie die Persistenzdatenbank für die Orchestrierung

  • Da häufig Daten in diese Datenbank geschrieben und aus ihr gelesen werden, sollte die Datenbank über einen eigenen Festplatten-E/A-Kanal verfügen. Erwerben Sie möglichst Datenträger mit der schnellsten Zugriffszeit und Controller mit dem höchsten Durchsatz. Erwägen Sie den Einsatz von RAID 0, und führen Sie eine Spiegelung durch, um Fehlertoleranz zu erhalten.

  • Wenn die CPU-Auslastung 80 Prozent übersteigt, fügen Sie weitere CPUs hinzu.

  • Sofern die durchschnittliche Warteschlangenlänge des Datenträgers mehr als 1 beträgt, oder wenn die Datenträger-E/A-Auslastung über 100 Prozent beträgt, sollten Sie weitere physische Datenträger hinzufügen.

Verwandtes Thema

Skalieren von BizTalk Server


Zentrales Skalieren der Transportdienste

BizTalk Server 2000 unterstützt 4 Transportdienste. Jeder der Transportdienste kann vertikal skaliert werden.

  • HTTP

  • Datei

  • SMTP

  • Message Queuing

Folgende Themen werden in diesem Abschnitt behandelt:

  • HTTP/HTTPS (Zentrales Skalieren)

  • Datei (Zentrales Skalieren)

  • SMTP (Zentrales Skalieren)

  • Message Queuing (Zentrales Skalieren)


HTTP/HTTPS (Zentrales Skalieren)

Empfangen

Die HTTP/HTTPS-Empfangsfunktion sendet Dokumente an BizTalk Server 2000 durch Aufruf des Interchange-Objekts von BizTalk Server. BizTalk Server besitzt keine eindeutige HTTP/HTTPS-Empfangsfunktion. Die HTTP-Empfangsfunktion ruft ein lokales Objekt auf. Daher ist keine Netzwerkwartezeit vorhanden, die sich auf die Leistung auswirken kann. Da sich jedoch die HTTP-Empfangsfunktion und BizTalk Server auf dem gleichen Server befinden, muss die HTTP-Empfangsfunktion 2 Funktionen durchführen: Datentransport und Datenverarbeitung.

In Umgebungen mit hohem Volumen wird die Leistung der HTTP-Empfangsfunktion und der BizTalk-Dienste beeinträchtigt, wenn beide auf dem gleichen Server ausgeführt werden. Wird darüber hinaus SSL (Secure Sockets Layer, wird auch als HTTPS bezeichnet) für den Empfang von Dokumenten verwendet, wird die Leistung aufgrund der Entschlüsselungsverarbeitung weiter reduziert. Je nach Sicherheitsanforderungen einer Organisation müssen gegebenenfalls Daten unter Verwendung von HTTPS verschlüsselt werden. Diese zusätzliche Sicherheitsstufe kann sich ebenfalls auf die Leistung von BizTalk Server auswirken.

Senden

BizTalk Server ist ein systemeigener HTTP/HTTPS-Client. Wenn ein Kanal so konfiguriert ist, dass HTTP/HTTPS als ausgehender Transportdienst verwendet wird, verwendet BizTalk Server HTTP/HTTPS zum Senden von Daten an den HTTP/HTTPS-Server eines Handelspartners. Der ausgehende HTTP/HTTPS-Transportdienst kann nicht von dem Server, auf dem sich die BizTalk-Messagingdienste befinden, auf einen anderen Server verschoben werden. Falls ein Server für die Teilnahme an der Arbeitsobjektverwaltung konfiguriert ist und ein Objekt verarbeitet, das einen HTTP/HTTPS-Transportdienst verwendet, sendet der gleiche Server das Dokument. Weitere Informationen zur Arbeitsobjektverwaltung erhalten Sie unter Zentrales Skalieren von BizTalk Server.

BizTalk Server wird als HTTP-Client ausgeführt. Dies wirkt sich auf die Dokumentserialisierungsleistung des Servers aus. Wenn der Port HTTPS verwendet, wird die Leistung des HTTP-Transportdienstes hierdurch stark beeinflusst. SSL-Beschleunigerkarten können bei der Ausführung als HTTPS-Client nicht verwendet werden, da diese Karten lediglich die HTTPS-Serverleistung verbessern.

Empfohlene Optimierung für HTTP/HTTPS

So optimieren Sie die Leistung der HTTP/HTTPS-Dienste und verbessern damit die Leistung von BizTalk Server

  • Konfigurieren Sie den eingehenden HTTP/HTTPS-Empfangsdienst auf einem anderen Server als BizTalk Server. Wenn der eingehende HTTP/HTTPS-Empfangsdienst nicht auf einem anderen Server als BizTalk Server konfiguriert werden kann, verwenden Sie eine schnellere CPU, oder fügen Sie CPUs hinzu.

  • Erhöhen Sie die Taktfrequenz (MHz) der für BizTalk Server benötigten CPU (um dem zusätzlichen Bedarf für das Senden von Dokumenten gerecht zu werden), und fügen Sie weitere CPUs hinzu, bis die gewünschte Leistungsstufe erreicht ist.

  • Wenden Sie optimale Methoden an, wenn Sie ASP-Seiten mit dem HTTP/HTTPS-Empfangs- oder Sendedienst verwenden. Weitere Informationen zur Optimierung von ASP-Seiten und der Internet-Informationsdienste erhalten Sie, wenn Sie die Hilfe zu Internet-Informationsdienste (Internet Information Services) aufrufen (localhost/iisHelp) und auf Active Server Pages-Handbuch klicken.


Datei (Zentrales Skalieren)

Empfangen

Wenngleich beim Verwenden einer Dateiempfangsfunktion für "Business-to-Business"-Transaktionen eine hohe Leistung erzielt wird, bietet eine Dateiempfangsfunktion nicht ausreichend Sicherheit für internetbasierte Transaktionen und wird daher nicht häufig verwendet. Bei Transaktionen zwischen Anwendungen innerhalb eines Unternehmens kann eine Dateiempfangsfunktion jedoch optimale Leistung bereitstellen, ohne die Sicherheit zu gefährden. Darüber hinaus ist es sicher, eine Dateiempfangsfunktion mit externen Handelspartnern zu verwenden, vorausgesetzt, sie wird mit einer weiteren Empfangsfunktion (z. B. SMTP oder HTTP) kombiniert. Die SMTP- oder HTTP-Empfangsfunktion kann ein Dokument von einem Handelspartner akzeptieren (mit HTTPS oder S/MIME, um die Sicherheit zu gewährleisten) und die Datei in ein internes Dateisystemverzeichnis übernehmen. Anschließend kann BizTalk Server das Dokument mit einer Dateiempfangsfunktion empfangen. Durch diese Kombination von Transportdiensten wird zwar nicht die Leistung erhöht, aber die Flexibilität und Sicherheit verbessert.

Anmerkung

  • Beim Verwenden von S/MIME wird die Leistung von BizTalk Server deutlich verringert.

Senden

Die im Zusammenhang mit der Dateiempfangsfunktion erläuterten Sicherheits- und Leistungsaspekte gelten auch für das Senden von Dokumenten mit einem Dateitransportdienst.

Empfohlene Optimierung für die Dateiempfangsfunktion und den Dateitransportdienst

So optimieren Sie die Leistung der Dateiempfangsfunktion und des Dateitransportdienstes und verbessern damit die Leistung von BizTalk Server

  • Verwenden Sie ein lokales Dateiverzeichnis anstelle eines Remotedateiverzeichnisses, um die Netzwerkwartezeit zu reduzieren.

  • Verwenden Sie Festplattenarrays, um einen hohen Durchsatz zu erzielen. Weitere Informationen zur Geschwindigkeit von Festplattenarrays und zu redundanzbedingten Kompromissen erhalten Sie unter Zentrales Skalieren der Datenbanken.


SMTP (Zentrales Skalieren)

Empfangen

Die SMTP-Empfangsfunktion ähnelt der HTTP-Empfangsfunktion für eingehende Transaktionen dahingehend, dass keine systemeigene SMTP-Empfangsfunktion in BizTalk Server integriert ist. Eine SMTP-Empfangsfunktion kann ein Dokument über einen ereignisbasierten Mechanismus empfangen und das Dokument an BizTalk Server senden. Wenn eine SMTP-Empfangsfunktion vorhanden ist, akzeptiert BizTalk Server das MIME/SMIME-codierte Dokument und bereitet es für die Verarbeitung vor.

Senden

Hier gelten die gleichen Sicherheits- und Leistungsaspekte, die in den Abschnitten über eingehendes S/MIME und ausgehendes HTTP/HTTPS aufgeführt sind. Wenn ein Kanal SMTP als Transportdienst in einem Messagingport oder Port verwendet, verarbeitet der verarbeitende Server das Dokument und sendet es an die empfangende Anwendung.

Anmerkung

  • Die Leistung von BizTalk Server wird stark herabgesetzt, wenn ein digitales Zertifikat benötigt wird, um das ausgehende Dokument mit S/MIME zu codieren.

Empfohlene Optimierung für SMTP

So optimieren Sie die Leistung des SMTP-Dienstes und verbessern damit die Leistung von BizTalk Server

  • Die erzielte Leistung hängt zum großen Teil von dem für den Dokumentempfang verwendeten SMTP-Dienst ab. Eine Organisation kann einen SMTP-Server besitzen, der diese Funktion ausführt. Wenn jedoch kein SMTP-Server verfügbar ist und Microsoft Exchange Server oder ein Messagingsystem eines Drittanbieters verwendet wird, ist für den Server gegebenenfalls umfangreiche neue Hardware erforderlich, um eine adäquate Leistungsstufe für BizTalk Server bereitzustellen. Der SMTP-Server muss in der Lage sein, einen ereignisbasierten Mechanismus aufzurufen, der Dokumente an BizTalk Server senden kann.

  • Wenn BizTalk Server in einer Organisation auf einem SMTP-Server ausgeführt wird, wird die CPU-Leistung hierdurch beeinträchtigt. Um die Leistungsbeeinträchtigung zu minimieren, verwenden Sie eine schnellere CPU.

  • Wird in einer Organisation S/MIME verwendet, wird die Leistung von BizTalk Server erheblich verringert. Um die allgemeine Leistungsbeeinträchtigung von BizTalk Server aufgrund der Verwendung von S/MIME zu reduzieren, verwenden Sie schnellere CPUs.


Message Queuing (Zentrales Skalieren)

Empfangen

Message Queuing verwendet zum Senden und Empfangen von Nachrichten umfangreiche Datenträger-E/A. Message Queuing ist transaktionsorientiert, dies wird zur Verbesserung der Fehlertoleranz unbedingt empfohlen. Die Transaktionsorientierung bezieht sich jedoch nur auf einen lokalen Server. Wenn Message Queuing zur Verbesserung der Fehlertoleranz verwendet wird, muss eine adäquate Anzahl von Festplatten auf jedem BizTalk-Server installiert werden, um die erhöhte Datenträger-E/A zu verarbeiten.

Senden

Beim Senden von Dokumenten mithilfe von Message Queuing treten die gleichen Sicherheits- und Leistungsprobleme auf wie beim Empfangen von Dokumenten mit Message Queuing.

Empfohlene Optimierung für Message Queuing

So optimieren Sie die Leistung von Message Queuing und verbessern damit die Leistung von BizTalk Server

  • Verwenden Sie Transaktionswarteschlangen (in BizTalk Server müssen lokale Warteschlangen anstelle von Remotewarteschlangen verwendet werden, damit Nachrichten in Transaktionswarteschlangen empfangen werden können) und einen schnellen Festplatten-E/A-Kanal. Anders als bei einer öffentlichen Nachrichtenwarteschlange muss eine lokale Warteschlange Microsoft Active Directory nicht abfragen. Daher wird eine bessere Leistung erzielt, wenn Daten aus lokalen Nachrichtenwarteschlangen gelesen und in diese geschrieben werden. Mit nicht-transaktionsorientierten lokalen Warteschlangen kann eine bessere Leistung erreicht werden. Diese Warteschlangen stellen jedoch nicht die gleiche Zuverlässigkeit wie transaktionsorientierte Warteschlangen bereit. Außerdem wird zusätzlicher Speicher benötigt.

    Anmerkung

    • Weitere Informationen zur Festlegung der Hardwareanforderungen für Message Queuing erhalten Sie in der Windows 2000 Server-Hilfe unter "Auswählen der Message Queuing-Serverhardware".
  • Die maximale Größe für Message Queuing-Nachrichten beträgt 4 MB. Für Dokumente, die größer sind als 4 MB, kann der Message Queuing-Transportdienst nicht verwendet werden. Die Persistenzdatenbank für die Orchestrierung verfügt über eine Größenbeschränkung für Dokumente ab 2 MB.

  • Message Queuing ist datenbankintensiv, wenn Journaleinträge verwendet werden. Stellen Sie bei der Einrichtung der Message Queuing-Transportdienste sicher, dass die Standardregeln für die Optimierung von Datenbanken angewendet werden.

  • Um einen maximalen Durchsatz zu erzielen, trennen Sie Daten und Protokolle, und verwenden Sie mehrere Festplatten und Controller.


Horizontales Skalieren von BizTalkServer

BizTalk Server-Kopfzeile

Horizontales Skalieren von BizTalk Server

Bei einer erfolgreichen BizTalk Server 2000-Implementierung wird sowohl eine vertikale als auch eine horizontale (dezentrale) Strategie verwendet. Bei der vertikalen Skalierung wird die Anzahl der erforderlichen Server möglichst gering gehalten. Die horizontale Skalierung stellt folgende Vorteile bereit:

  • Höhere Leistung. Die Leistung übertrifft die kosteneffektiv auf einem einzelnen Server erzielbare Leistung.

  • Fehlertoleranz des Servers.

  • Trennung und Optimierung der verschiedenen Komponenten. Die Leistung der BizTalk-Dienste, der Datenbanken und der Transportdienste kann gesteigert werden.

Durch die horizontale Skalierung der Hardware werden die Kosten minimiert. Bei wachsender Komplexität der Standortverwaltung muss in der Organisation jedoch mit einer vertikalen Skalierung begonnen werden.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Horizontales Skalieren der BizTalk-Messagingdienste

  • Dezentrales Skalieren der Datenbanken

  • Dezentrales Skalieren der Transportdienste

Verwandtes Thema

Skalieren von BizTalk Server


Horizontales Skalieren der BizTalk-Messagingdienste

BizTalk-Messagingdienste können mithilfe von Servergruppen horizontal skaliert werden. Bei Servergruppen handelt es sich um Sammlungen einzelner Server, die zentral verwaltet, konfiguriert und überwacht werden. Weitere Informationen zum Hinzufügen und Konfigurieren von Servergruppen erhalten Sie unter Gruppen und Server.

Server, die Mitglieder der gleichen Servergruppe sind, verwenden gemeinsam folgende Komponenten:

  • Eine Datenbank für gemeinsam genutzte Warteschlangen, die die Aktivität im BizTalk Server-Statusmodul überwacht.

  • Eine Überwachungsdatenbank, die die Dokumentaktivität protokolliert und Berichte generiert.

  • Eine BizTalk-Messaging-Verwaltungsdatenbank, in der Konfigurationsinformationen gespeichert sind.

  • Empfangsfunktionen.

  • Alle Komponenten, die der Server zur Laufzeit benötigt, wie z. B. Transportkomponenten und Anwendungsintegrationskomponenten sowie Datenkonvertierung, Datenverschlüsselung und Signierung.

Eine BizTalk-Servergruppe stellt keinen Mechanismus zum Lastenausgleich für den Empfang eingehender Dokumente oder zur Vereinfachung der Dokumentversendung mithilfe von DCOM (Distributed Component Object Model) zur Verfügung. Sie ermöglicht jedoch die Verarbeitung auf mehreren Servern. Sobald ein Dokument an die Datenbank für gemeinsam genutzte Warteschlangen gesendet wurde, kann jeder Server der Gruppe das Dokument verarbeiten, serialisieren und versenden. Aufgrund dieser Funktion kann ein Server in einer Gruppe ein Dokument senden, das ein anderer Server verarbeitet.

Eine Organisation kann aus folgenden Gründen mehrere Servergruppen enthalten:

  • Gruppierung ähnlicher Transportdienste (HTTP oder Datei)

  • Verbesserte Sicherheit

  • Kategorien für Handelspartner

Weiterhin können Servergruppen verwendet werden, um doppelte Konfigurationen für die Organisation sowie Kanäle und Messagingports zu vermeiden. Servergruppen verwenden gemeinsame Datenbanken. Die Konfigurationsinformationen für die Organisation sowie für Gruppen, Kanäle und Messagingports werden in der BizTalk-Messaging-Verwaltungsdatenbank gespeichert. Daher können zwei oder mehr BizTalk-Servergruppen die gleiche BizTalk-Messaging-Verwaltungsdatenbank verwenden.

Anmerkung

  • Wenn mindestens zwei BizTalk-Servergruppen die gleiche BizTalk-Messaging-Verwaltungsdatenbank verwenden, muss jede Gruppe eine eigene Datenbank für gemeinsam genutzte Warteschlangen, Überwachungsdatenbank und Persistenzdatenbank für die Orchestrierung besitzen, auf die alle Mitglieder der Gruppe zugreifen können.

Empfohlene Lösungen für die horizontale Skalierung von BizTalk Server

So optimieren Sie die BizTalk Server-Leistung

Trennen von Transportdiensten und Empfangsfunktionen

Durch die Aufteilung von Transportdiensten und Empfangsfunktionen auf BizTalk-Servergruppen lässt sich eine höhere Leistung erzielen. Die erreichte Leistung richtet sich nach der Anzahl der verarbeiteten Dokumente und der Komplexität der Datenkonvertierung. BizTalk Server stellt separate Threadpools für den Empfang und die Verarbeitung von Daten bereit. Durch das Trennen von Transportdiensten und Empfangsfunktionen werden Kontextumschaltungen reduziert, da der Server nicht mehr zwischen Sende- und Empfangsoperationen wechseln muss.

Sämtliche Server verarbeiten standardmäßig Arbeitsobjekte. Hierbei wird ein Arbeitsobjekt aus der Datenbank für gemeinsam genutzte Warteschlangen entnommen, verarbeitet und mithilfe des Transportdienstes, für den der Kanal konfiguriert ist, versendet (Verarbeitung ausgehender Arbeitsobjekte). Durch diesen Prozess wird die Gesamtleistung der CPU herabgesetzt, da Kontextumschaltungen stattfinden müssen. Sofern zwei oder mehr Server verwendet werden, kann die Leistungsreduzierung vermieden werden, indem mindestens ein Server als Empfangsdienst eingesetzt wird. Um einen Server als Empfangsdienst zu konfigurieren, deaktivieren Sie in der BizTalk Server-Verwaltung die Funktion An Arbeitsobjektverwaltung teilnehmen und erstellen eine neue Empfangsfunktion für den Server. Weitere Informationen zum Deaktivieren der Funktion An Arbeitsobjektverwaltung teilnehmen erhalten Sie unter Konfigurieren eines Servers in einer Gruppe. Weitere Informationen zum Einrichten einer Dateiempfangsfunktion erhalten Sie unter Hinzufügen einer Dateiempfangsfunktion. Weitere Informationen zum Einrichten einer Message Queuing-Empfangsfunktion erhalten Sie unter Hinzufügen einer Message Queuing-Empfangsfunktion.

Anmerkung

  • Beim Message Queuing können nur durchgeführte Lesevorgänge aus lokalen Warteschlangen verarbeitet werden. Daher kann nur ein einzelner Server aus dieser Warteschlange lesen.

BizTalk Server empfängt Dokumente, wenn eine der folgenden Bedingungen zutrifft:

  • Eine Empfangsfunktion wurde auf dem gleichen Server wie BizTalk Server konfiguriert.

  • Ein SMTP- oder HTTP-Prozess wurde konfiguriert, um die Submit-Methode auf dem Server aufzurufen, auf dem BizTalk Server installiert wurde.

Priorität von Parsern

Durch die Bevorzugung von Parsern kann die Leistung von BizTalk Server optimiert werden. BizTalk Server stellt 4 Datenparser bereit:

  • XML

  • EDIFACT

  • X12

  • Flatfile

Wenn BizTalk Server ein Dokument empfängt, wird versucht, das Dokument nach der Reihenfolge der vorhergehenden Liste zu analysieren. Die Leistung von BizTalk Server lässt sich verbessern, indem Sie die am häufigsten verwendeten Parser an die Spitze der Liste verschieben. Weitere Informationen zum Konfigurieren der Parserreihenfolge erhalten Sie unter Konfigurieren der Parserreihenfolge für eine Servergruppe.

Da es sich bei der Parserreihenfolge um eine Servergruppeneinstellung handelt, empfiehlt es sich, eine separate Gruppe für jeden verarbeiteten Datentyp (XML, EDIFACT, X12 Flatfile) zu erstellen. Legen Sie anschließend die entsprechenden Parserprioritäten für jede Gruppe fest.

Folgendes Thema wird in diesem Abschnitt behandelt:

  • Komponentenlastenausgleich


Komponentenlastenausgleich

Beim Komponentenlastenausgleich (CLB, Component Load Balancing) handelt es sich um ein Feature von Microsoft Application Center 2000. CLB kann nur verwendet werden, wenn Application Center 2000 auf dem gleichen Server wie Microsoft BizTalk Server 2000 installiert ist. CLB ermöglicht Organisationen den Lastenausgleich der BizTalk.Interchange.1-Komponente im COM+-Dienste-Manager. Bei CLB handelt es sich um einen Lastenausgleichsmechanismus für COM-Komponenten. In einer BizTalk Server-Umgebung bietet CLB einem HTTP-Transportdienst die Möglichkeit, mit der Submit-Methode einen Cluster von BizTalk-Servern anstelle eines einzelnen Servers aufrufen. Für die sendende Anwendung wird die Verwendung der Submit-Methode zum Aufrufen des Clusters weiterhin als Versendung an einen Knoten angezeigt. Bei einem Cluster handelt es sich um eine Sammlung von Servern, die als ein einziger Server agieren. Wenn beispielsweise ein Cluster von HTTP-Servern verwendet wird, kann eine einzige Versendung jeden der 3 Server erreichen. Ohne CLB müssen die HTTP-Transportdienste so konfiguriert werden, dass die Versendung an einen der 3 Server erfolgt. Wenn im zweiten Szenario der Server ausfällt, an den der HTTP-Dienst entsprechend seiner Konfiguration sendet, muss der HTTP-Transportdienst neu konfiguriert werden, um an einen anderen Server in der BizTalk-Servergruppe zu senden.

Wichtig

  • Führen Sie keine Replikation der Standardanwendung XLANG-Ablaufplanung (XLANG Scheduler) oder beliebiger COM+-Anwendungen durch, die als Host für XLANG-Ablaufpläne dienen. Wird CLB verwendet, müssen diese COM+-Anwendungen auf jedem Server installiert werden. An XLANG-Ablaufpläne gebundene COM-Komponenten können repliziert werden.


Dezentrales Skalieren der Datenbanken

Wenn Sie die Datenbanken horizontal skalieren möchten, müssen Sie jede Datenbank auf einem eigenen Server installieren. In Umgebungen mit einer großen Anzahl von Transaktionen können durch die Installation einer Datenbank auf einem eindeutigen Server die CPU, Datenträger-E/A und Speicherressourcen des Servers der entsprechenden Datenbank zugeordnet werden.

Empfohlene Optimierung für die horizontale Skalierung der Datenbanken

So optimieren Sie die Datenbankleistung von BizTalk Server

  • Installieren Sie jede Datenbank auf einem separaten Server mit 933 MHz oder einer größeren CPU. Installieren Sie keine der Datenbanken auf dem gleichen Server wie BizTalk Server 2000.

  • Installieren Sie eine beliebige COM+-Anwendung, die als Host für XLANG-Ablaufpläne dient, auf einem eigenen Server mit 933 MHz oder einer größeren CPU.

  • Mehrere Netzwerkkarten mit 100 Mbit/s (Megabits pro Sekunde) oder größer, Netzwerkkarten verbunden mit 100 MB/s-Switchports zur Erhöhung des Netzwerk-E/A-Durchsatzes.

  • Verwenden Sie für eine Organisation, die nur wenige Dokumente verarbeitet, eine problemlos aktualisierbare Datenbank. Wenn die Verarbeitungsanforderungen wachsen, verschieben Sie die Datenbank für gemeinsam genutzte Warteschlangen, die Überwachungsdatenbank und die Persistenzdatenbank für die Orchestrierung auf eigene Server. Das Verschieben der BizTalk-Messaging-Verwaltungsdatenbank ist jedoch komplizierter. Es wird dringend empfohlen, dass die Server, auf dem die BizTalk-Messaging-Verwaltungsdatenbank gespeichert wird, ausreichend Festplattenspeicher und Arbeitsspeicher enthält, damit die Konfiguration bei steigenden Anforderungen an die Dokumentverarbeitung zwischengespeichert werden kann.

  • Installieren Sie für die Überwachungsdatenbank schnelle Netzwerkhardware, um die großen Mengen unkomprimierter Daten zu kompensieren, die zwischen BizTalk Server und der Datenbank ausgetauscht werden.

    Anmerkung

    • Für die Überwachung von Austauschvorgängen und Dokumenten existiert eine Größenbeschränkung. Wird diese überschritten, wirkt sich dies deutlich auf die Leistung von BizTalk Server aus. Weitere Informationen zur Größenbeschränkung erhalten Sie unter Austausch- und Dokumentgrößenbeschränkung.

Verwandtes Thema

Skalieren von BizTalk Server


Dezentrales Skalieren der Transportdienste

BizTalk Server unterstützt 4 Transportdienste. Jeder der Transportdienste kann horizontal skaliert werden.

  • HTTP

  • Datei

  • SMTP

  • Message Queuing

Folgende Themen werden in diesem Abschnitt behandelt:

  • HTTP/HTTPS (Dezentrales Skalieren)

  • Datei (Dezentrales Skalieren)

  • SMTP (Dezentrales Skalieren)

  • Message Queuing (Dezentrales Skalieren)


HTTP/HTTPS (Dezentrales Skalieren)

Empfangen

Die HTTP/HTTPS-Empfangsfunktion kann mithilfe eines Webclusters horizontal skaliert werden. Beispielsweise kann ein Handelspartner ein Dokument an eine Adresse senden, wobei die Versendung jedoch an einen beliebigen Server im Cluster weitergeleitet werden kann. Webcluster sind eine Funktion des in Microsoft Windows 2000 Advanced Server enthaltenen Netzwerklastenausgleichsdienstes (Network Load-Balancing, NLB). Weitere Informationen zum Konfigurieren des Netzwerklastenausgleichsdienstes erhalten Sie in der Windows 2000 Advanced Server-Hilfe. Wenn Sie die Leistung von BizTalk Server verbessern möchten, können Sie einen Webcluster so konfigurieren, dass empfangene Dokumente in einem Dateiverzeichnis oder einer Nachrichtenwarteschlange gespeichert werden. Sie können ihn jedoch auch so konfigurieren, dass Dokumente mit einem der beiden folgenden Verfahren direkt an BizTalk Server gesendet werden:

  • Jeder Server wird statisch für das Senden von Dokumenten an BizTalk Server konfiguriert.

  • Jeder Server wird so konfiguriert, dass Dokumente an einen Webcluster aus BizTalk-Servern (Server, die Mitglieder der gleichen Gruppe sind) mithilfe der CLB-Funktion von Microsoft Application Center 2000 gesendet werden.

    Wichtig

    • Führen Sie keine Replikation der Standardanwendung XLANG-Ablaufplanung (XLANG Scheduler) oder beliebiger COM+-Anwendungen durch, die als Host für XLANG-Ablaufpläne dienen. Wird CLB verwendet, müssen diese COM+-Anwendungen auf jedem Server installiert werden. An XLANG-Ablaufpläne gebundene COM-Komponenten können repliziert werden.

Senden

Die horizontale Skalierung des sendenden HTTP/HTTPS-Transportdienstes ist eine integrierte Funktion im Zusammenhang mit der Verwendung mehrerer Server in einer Gruppe, die für die Teilnahme an der Arbeitsobjektverwaltung konfiguriert sind. Die HTTP/HTTPS-Sendefunktion kann nicht von dem Dokumente verarbeitenden BizTalk-Server getrennt werden, da die Sendefunktion auf jedem Server in der Gruppe verwendet wird, der für die Teilnahme an der Arbeitsobjektverarbeitung konfiguriert ist.

Empfohlene Optimierung für HTTP/HTTPS

So optimieren Sie den HTTP/HTTPS-Transportdienst und verbessern damit die Leistung von BizTalk Server

  • Trennen Sie den empfangenden HTTP/HTTPS-Transportdienst von den übrigen BizTalk-Diensten, und weisen Sie ihn einem separaten Server zu (in Transaktionsumgebungen mit hohem Volumen). Legen Sie darüber hinaus fest, dass der HTTP/HTTPS-Server Dokumente an eine Dateiempfangsfunktion oder Message Queuing-Empfangsfunktion sendet, oder rufen Sie die Submit-Methode auf dem Interchange-Objekt von BizTalk Server mithilfe von DCOM auf. Wenn Sie den HTTP/HTTPS-Transportdienst als abhängigen Dienst einrichten oder festlegen, dass der HTTP/HTTPS-Server Dokumente an eine Empfangsfunktion sendet, führt dies zum Auftreten von Netzwerkwartezeit. Wenn Sie den HTTP/HTTPS-Transportserver und den BizTalk-Server getrennt voneinander konfigurieren, haben Sie jedoch die Möglichkeit, ihre eindeutige Architektur anzupassen und zu optimieren. Durch die Trennung dieser Server können Sie darüber hinaus eine optimale Leistung auf dem BizTalk-Server bereitstellen, da sich die Kosten, die beim Verwenden von SSL zur Ver-/Entschlüsselung anfallen, nicht auswirken.

  • Erstellen Sie einen Cluster mit Lastenausgleich aus HTTP/HTTPS-Transportservern. Hierdurch wird die Leistung des empfangenden HTTP/HTTPS-Transportdienstes weiter verbessert, da horizontale Skalierungsredundanz bereitgestellt wird. Weitere Informationen zum Erstellen eines Webclusters mithilfe des Dienstes für den Lastenausgleich im Netzwerk erhalten Sie in der Windows 2000 Advanced Server-Hilfe.

  • Geben Sie an, wie viele Dokumente von Servern in einer Gruppe verarbeitet werden müssen, die für die Teilnahme an der Arbeitsobjektverwaltung konfiguriert ist. Ermitteln Sie dann die Anzahl der Kanäle, die Messagingports verwenden, die den sendenden HTTP/HTTPS-Transportdienst benötigen. Verbinden Sie die Kanäle, die den sendenden HTTP/HTTPS-Transportdienst verwenden, zu einer einzigen Gruppe. Hierdurch erhalten alle Server in der für die Teilnahme an der Arbeitsobjektverwaltung konfigurierten Gruppe die Möglichkeit, Dokumente zu serialisieren, die von einem beliebigen Transportdienst verwendet werden.

  • Wenden Sie optimale Methoden an, wenn Sie ASP-Seiten mit dem HTTP/HTTPS-Empfangs- oder Sendedienst verwenden. Weitere Informationen zur Optimierung von ASP-Seiten und der Internet-Informationsdienste erhalten Sie, wenn Sie die Hilfe zu Internet-Informationsdienste (Internet Information Services ) aufrufen (localhost/iisHelp). Klicken Sie dann auf Active Server Pages-Handbuch.

  • Verwenden Sie Message Queuing oder einen Dateitransportdienst auf einem lokalen System mit einer Empfangsfunktion, anstatt die Submit-Methode aufzurufen, um Dokumente in BizTalk Server abzurufen.


Datei (Dezentrales Skalieren)

Empfangen

Die Dateiempfangsfunktion kann sich auf dem Server befinden oder von den Servern getrennt werden. Wenngleich die Festlegung der Dateiempfangsfunktion auf einem separaten Server zu einer Minimierung der Leistungsbeeinträchtigung der Datenträger-E/A führen kann, wirkt sich die Netzwerkwartezeit negativ auf die Leistung aus, wenn versucht wird, die Datei abzurufen.

Senden

Eine horizontale Skalierung wird erzielt, wenn mehrere Server in der Gruppe Dokumente verarbeiten und anschließend an den Dateitransportdienst senden. Die Leistung richtet sich danach, ob der BizTalk-Server als Empfangsfunktion verwendet wird oder nicht oder ob der BizTalk-Server als separater Server für die Empfangsfunktion konfiguriert ist oder nicht.

Empfohlene Optimierung für eine Dateiempfangsfunktion oder einen Dateitransportdienst

So optimieren Sie eine Dateiempfangsfunktion oder einen Dateitransportdienst und verbessern die Leistung von BizTalk Server

  • Speichern Sie die Dateiempfangsfunktion auf einem anderen Server als BizTalk Server. Bei dieser Lösung wird jedoch die Leistungsbeeinträchtigung aufgrund der Netzwerkwartezeit nicht berücksichtigt, die bei dem Versuch auftritt, die Datei abzurufen. Wenn Sie die Dateiempfangsfunktion auf einem anderen Server als BizTalk Server speichern, führt das ebenfalls zu einer Reduzierung des Datenträger-E/A-Einflusses auf die Leistung von BizTalk Server. Weiterhin verhindert die Trennung der Server, dass unbekannte Anwendungen Dateien auf dem BizTalk-Server ablegen oder Anforderungen durchführen, die die Serverressourcen maximieren und zu niedriger Leistung führen können.

  • Konfigurieren Sie eine Empfangsfunktion, die auf jedem Server in der Gruppe ausgeführt wird und die gleiche Dateiempfangsfunktion abruft, um sicherzustellen, dass alle Server in der Gruppe Dokumente zur Verarbeitung abrufen. Dateiempfangsdienste sind standardmäßig so konfiguriert, dass sie auf einem Server innerhalb einer Gruppe ausgeführt werden. Wenn eine Gruppe also 5 Server enthält und Sie eine Dateiempfangsfunktion für die Ausführung auf einem Server in der Gruppe konfigurieren, ruft nur dieser eine Server Dateien zur Verarbeitung ab, wenn unter \\receiveserver\receivelocation eine Dateiempfangsfunktion abgerufen wird. Hierdurch wird die Anzahl der dokumentverarbeitenden Server auf einen Server für die gesamte Gruppe begrenzt. Die verbleibenden 4 Server können keine Dateien von der zu analysierenden Empfangsfunktion abrufen.

  • Konfigurieren Sie eine Dateiempfangsfunktion auf einem anderen Server als BizTalk Server. Hierdurch wird verhindert, dass unbekannte Anwendungen Dateien von dem BizTalk-Server abrufen. Da es sich beim Senden und Empfangen von Dateien um unterschiedliche Prozesse handelt, versenden alle Server der Gruppe, die für die Teilnahme an der Arbeitsobjektverwaltung konfiguriert sind, Dateien. Die horizontale Skalierbarkeit basiert nur auf der Anzahl der Server in der Gruppe, die für die Teilnahme an der Arbeitsobjektverwaltung konfiguriert sind.


SMTP (Dezentrales Skalieren)

Empfangen

SMTP kann zwar Dokumente von BizTalk Server empfangen, jedoch keine Dokumente an BizTalk Server senden. Damit ein Dokument an BizTalk Server gesendet werden kann, muss SMTP in der Lage sein, einen ereignisbasierten Mechanismus aufzurufen, um die empfangene Nachricht abzurufen und an eine Dateifreigabe oder eine Nachrichtenwarteschlange zu senden oder das Dokument mithilfe des Interchange-Objekts von BizTalk Server zu versenden. Die SMTP-Server, die diese ereignisbasierten Mechanismen bereitstellen können (Microsoft Exchange Server oder ein Messagingserver eines Drittanbieters) verwenden normalerweise umfangreiche Hardwareressourcen. Daher wird die Fähigkeit zur Verarbeitung von Dokumenten eines Server durch das Hinzufügen dieser Funktion reduziert.

Senden

Lightweight SMTP-Transportdienste ohne ereignisbasierten Mechanismus können zum Versenden von Dokumenten mit SMTP verwendet werden. Der SMTP-Transportserver, der das Dokument sendet, agiert einfach als Relay-Agent. Der ausgehende SMTP-Server ist auf Gruppenebene konfiguriert, nicht auf Serverebene. Wenn der SMTP-Transportdienst auf einem Server einer Gruppe existiert, verwendet daher der Server, der den SMTP-Transportdienst enthält, diesen zum Versenden ausgehender Dokumente. Alle übrigen Server in der Gruppe verwenden den gleichen Server für ausgehende SMTP-Daten.

Empfohlene Optimierung für SMTP

So optimieren Sie den SMTP-Dienst und verbessern damit die Leistung von BizTalk Server

  • Konfigurieren Sie den SMTP-Transportdienst so, dass er auf einem anderen Server als die BizTalk-Dienste ausgeführt wird (Sende- und Empfangsfunktion). In den meisten Fällen verfügt eine Organisation über einen SMTP-Server im Netzwerk, der für Sende- und Empfangsfunktionen verwendet werden kann.


Message Queuing (Dezentrales Skalieren)

Empfangen

Sie müssen festlegen, ob die Message Queuing-Empfangsfunktion auf dem gleichen Server wie BizTalk Server oder auf einem anderen Server installiert werden soll. Wenn Sie eine Transaktionswarteschlange verwenden, muss sich die Message Queuing-Empfangsfunktion auf dem gleichen Server befinden. Andernfalls kann die Message Queuing-Empfangsfunktion auch auf einem anderen Server enthalten sein. Weiterhin müssen Sie entscheiden, welche Leistungsnachteile Sie in Kauf nehmen möchten: Leistungsbeeinträchtigungen durch Datenträger-E/A auf dem lokalen BizTalk-Server oder Netzwerkwartezeit bei der Kommunikation zwischen mehreren Servern. Im zweiten Fall ist weiterhin ein Bedarf nach Datenträger-E/A vorhanden, jedoch auf dem Remoteserver, nicht auf dem lokalen Server. Weitere Informationen zur Festlegung der Hardwareanforderungen für den Message Queuing-Dienst erhalten Sie in der Windows 2000 Server-Hilfe unter "Auswählen der Message Queuing-Serverhardware".

Senden

Beim Senden von Dokumenten mithilfe von Message Queuing treten die gleichen Sicherheits- und Leistungsprobleme auf wie beim Empfangen von Dokumenten mit Message Queuing.

Empfohlene Optimierung für Message Queuing

So optimieren Sie die Leistung für Message Queuing und verbessern damit die Leistung von BizTalk Server

  • Message Queuing ist datenbankintensiv, wenn Journaleinträge verwendet werden. Stellen Sie bei der Einrichtung der Message Queuing-Transportdienste sicher, dass die Standardregeln für die Optimierung von Datenbanken angewendet werden. Trennen Sie beispielsweise Daten und Protokolle, und verwenden Sie mehrere Festplatten und Controller, um einen maximalen Durchsatz zu erzielen.


Leistungsoptimierung

Wenn Sie den Transaktionsanforderungen gerecht werden und die Leistung verbessern möchten, müssen Sie BizTalk Server 2000 optimieren. Neben BizTalk Server können zur Verbesserung der Leistung auch Microsoft Windows 2000 und Datenbankinteraktionen optimiert werden. Nachdem Sie das System konfiguriert haben, sollten Sie es testen und anschließend die Ergebnisse auswerten, um festzustellen, ob die Anfangskonfiguration den Transaktionsanforderungen gerecht wird. Möglicherweise müssen Sie die Architektur neu konfigurieren, um eine optimale Leistung zu erzielen. Nach jeder Neukonfiguration sollten Sie die Architektur wiederum testen und die Ergebnisse auswerten. Sobald die gewünschten Ergebnisse erzielt wurden, sollten Sie einen Wartungsplan einrichten, da sich die Serverleistung im Laufe der Zeit ändert und sich die Menge und Art der Transaktionen, die in der Organisation bearbeitet werden, ebenfalls ändern kann.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Allgemeine Leistungsempfehlungen

  • Architekturentwurf, Überprüfung und Tests

  • Bereitstellen der Leistung


Allgemeine Leistungsempfehlungen

Dieser Abschnitt stellt allgemeine Empfehlungen zur Optimierung von Systemeinstellungen bereit. Weiterhin wird die Optimierung von BizTalk Server 2000-Einstellungen behandelt, mit denen sich die Leistung verbessern lässt. Beispiel:

  • Optimieren Sie Microsoft Windows 2000-Einstellungen. Führen Sie keine unnötigen Dienste oder Protokolle aus, um die Leistung von Microsoft Windows 2000 zu verbessern. Zahlreiche, zur Optimierung von Windows 2000 verwendete Verfahren können auch zur Optimierung von BizTalk Server verwendet werden. Weitere Informationen zur Optimierung von Microsoft Windows 2000-Einstellungen erhalten Sie in der Windows 2000-Hilfe unter "Empfehlungen".

  • Stellen Sie schnelle zuverlässige Netzwerkverbindungen zwischen Transportdiensten, BizTalk-Diensten (Orchestrierungsdienste und BizTalk-Messagingdienste) und den Datenbanken (100 Mbit/s oder schnelleres Ethernet) zur Verfügung. Um den Netzwerkdurchsatz zu optimieren, verwenden Sie mehrere Adapter auf jedem Server mit einem eindeutigen Switchport für jeden Server, wobei eingehende und ausgehende Transaktionen zwischen den Netzwerkschnittstellenkarten (NICs) aufgeteilt werden. Bei Verwendung in Verbindung mit Microsoft Windows 2000 NLB oder der CLB-Komponente von Microsoft Application Center 2000 (IInterchange oder IPipelineComponent) wird die Leistung deutlich gesteigert.

    Wichtig

    • Führen Sie keine Replikation der Standardanwendung XLANG-Ablaufplanung (XLANG Scheduler) oder beliebiger COM+-Anwendungen durch, die als Host für XLANG-Ablaufpläne dienen. Wenn CLB verwendet wird, müssen die COM+-Anwendungen auf jedem Server installiert sein. An XLANG-Ablaufpläne gebundene COM-Komponenten können repliziert werden.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Optimieren der BizTalk-Orchestrierungsdienste

  • Optimieren der BizTalk-Messagingdienste

Verwandtes Thema

Skalieren von BizTalk Server


Optimieren der BizTalk-Orchestrierungsdienste

Mithilfe der BizTalk-Orchestrierungsdienste können XLANG-Ablaufpläne und der Inhalt dieser Ablaufpläne optimiert werden. Wenn Sie verstehen, wie Ablaufpläne den Speicher verwenden und wie die Struktur eines Geschäftsprozessablaufs die Leistung beeinflusst, können Sie Ablaufpläne entwerfen, die die Leistung der BizTalk-Orchestrierungsdienste verbessern. Zu den durch die BizTalk-Orchestrierungsdienste unterstützten Implementierungstechnologien zählen die BizTalk-Messagingdienste, COM-Komponenten, Message Queuing-Dienste und Windows-Skriptkomponenten. Durch Optimierung dieser Komponenten und Dienste lässt sich die Leistung der BizTalk-Orchestrierungsdienste weiter verbessern.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Optimieren von XLANG-Ablaufplänen

  • Optimieren des Inhalts von XLANG-Ablaufplänen


Optimieren von XLANG-Ablaufplänen

Ein XLANG-Ablaufplan kann eine große Anzahl interner Geschäftsprozesse enthalten. Bei den Geschäftsprozessen kann es sich um kurzlebige Transaktionen oder langlebige Transaktionen handeln. BizTalk Server steuert zwar nicht den Inhalt dieser Prozesse, verwaltet jedoch den Informationsfluss durch die Prozesse innerhalb eines XLANG-Ablaufplanes. Unabhängig davon, ob er kurzlebige oder langlebige Transaktionen enthält, sollten Sie beim Entwurf eines XLANG-Ablaufplanes Folgendes berücksichtigen:

  • Eine XLANG-Ablaufplaninstanz wird immer dann im Speicher ausgeführt, wenn sie aufgerufen wird.

  • Mehrere XLANG-Ablaufpläne können auf dem gleichen Server ausgeführt werden.

  • Mehrere unterschiedliche XLANG-Ablaufpläne können parallel mit mehreren XLANG-Ablaufplaninstanzen ausgeführt werden.

Die Persistenzdatenbank für die Orchestrierung stellt ein als Pausierung bezeichnetes Verfahren bereit, mit dem der durch die Ausführung von XLANG-Ablaufplänen verwendete Speicher gesteuert wird. Eine Pausierung tritt ein, wenn eine XLANG-Ablaufplaninstanz auf eine Nachricht wartet und keine andere Aktivität innerhalb des XLANG-Ablaufplanes stattfindet. An diesem Punkt pausiert das XLANG-Ablaufplanungsmodul die XLANG-Ablaufplaninstanz, um die Leistung zu maximieren. Bei der Pausierung einer XLANG-Ablaufplaninstanz bleiben alle instanzspezifischen Zustände für eine Datenbank bestehen und die Instanz wird aus dem Speicher entfernt. Nur ein geringer Anteil der XLANG-Ablaufplaninstanz verbleibt im Speicher innerhalb des XLANG-Ablaufplanungsmoduls. Wenn eine Nachricht an einem Port für die XLANG-Ablaufplaninstanz ankommt, wird die Instanz aktiviert. Bei der Aktivierung einer XLANG-Ablaufplaninstanz wird die Instanz aus der Datenbank im Speicher wiederhergestellt.

Eine XLANG-Ablaufplaninstanz pausiert so lange, bis sie entweder wieder aktiviert oder explizit durch einen Administrator beendet wird. Auf diese Weise kann ein Geschäftsprozess zuverlässig für einen langen Zeitraum ausgeführt werden. Weitere Informationen zu Pausierungs- und Aktivierungseinstellungen erhalten Sie unter Pausierung und Aktivierung. Die Pausierung und Aktivierung spart zwar Speicherplatz, beeinträchtigt jedoch die Leistung. Da die Pausierung und Aktivierung erfordern, dass Daten in die Persistenzdatenbank für die Orchestrierung geschrieben und aus der Datenbank gelesen werden, tritt Netzwerkwartezeit auf.

Wichtig

  • Um die Leistung der BizTalk-Orchestrierungsdienste deutlich zu steigern, navigieren Sie im Windows-Explorer zum Verzeichnis Programme\Gemeinsame Dateien\System\ado und doppelklicken dann auf adofre15.reg. Klicken Sie in dem Bestätigungsdialogfeld auf Ja und anschließend auf OK. Mit diesem Verfahren wird das ADO-Threadingmodell von "Apartment threaded" in "Both" geändert. Dies kann sich auch auf andere Anwendungen auswirken, die ADO verwenden.


Optimieren des Inhalts von XLANG-Ablaufplänen

Ein XLANG-Ablaufplan beschreibt den Geschäftsprozess und die Bindung des Prozesses an Implementierungstechnologien. Die Leistung eines XLANG-Ablaufplanes spiegelt häufig die Leistungsstufe der darin enthaltenen Aktionen wider. Bei der Optimierung des Inhalts eines XLANG-Ablaufplanes ist eine Reihe relevanter Themen zu beachten. Einige dieser Aspekte beziehen sich speziell auf einen XLANG-Ablaufplan während andere auch für die Erstellung einer beliebigen verteilten Anwendung gelten:

  • Zurücksetzen des Pausierungswertes, um Speicher für XLANG-Ablaufpläne zu sparen. Die Standardwartezeit beträgt 0 Sekunden. Diese Zeit können Sie jedoch ändern. Bei einer Zeit von 180 Sekunden oder darunter wird der XLANG-Ablaufplan nie pausiert. Jede Zeit über 180 Sekunden führt zu einer sofortigen Pausierung des XLANG-Ablaufplanes. Weitere Informationen zu Wartezeiten und der Pausierung von XLANG-Ablaufplänen erhalten Sie unter Pausierung und Aktivierung und Synchrone und asynchrone Kommunikation.

  • Verwenden persistenter Komponenten. Persistente Komponenten, wie z. B. IPersistStream oder IPersistStreamInit bieten dem XLANG-Ablaufplanungsmodul die Möglichkeit, XLANG-Ablaufpläne flexibel zu pausieren.

  • Ausführen der COM-Objekte auf dem gleichen Server wie die Persistenzdatenbank für die Orchestrierung. Hierdurch wird sichergestellt, dass sich die Netzwerkwartezeit nicht auf den XLANG-Ablaufplan auswirkt.

  • In-Process-Ausführung von COM+-Paketen, um eine optimale Leistung zu erzielen. Wenngleich sich die In-Process-Ausführung eines COM+-Pakets negativ auf die Stabilität der COM+-Anwendung auswirken kann (beispielsweise kann die gesamte Anwendung ausfallen, wenn eine Komponente innerhalb der Anwendung ausfällt), ist sie jedoch bedeutend schneller als die Out-Of-Process-Ausführung der Anwendung. Um diese potenzielle Instabilität zu vermeiden, sollten Sie die Komponenten der Anwendung unbedingt eingehend auf Stabilität hin prüfen, bevor die Anwendung in einer Produktionsumgebung bereitgestellt wird.

  • Zusammenfassen von Arbeitsobjekten in einer einzelnen Transaktion. Wenn der Zustand einer XLANG-Ablaufplaninstanz am Anfang und Ende einer Transaktion beibehalten wird, wirkt sich dies deutlich auf die Computerressourcen aus. Die Zusammenfassung von Arbeitsobjekten in einer einzelnen Transaktion reduziert die Leistungsbeeinträchtigung jedoch erheblich. Darüber hinaus kann ein XLANG-Ablaufplan nicht während einer MSDTC-Transaktion (Microsoft Distributed Transaction Coordinator) pausiert werden. MSDTC-Transaktionen sind schnell, setzen jedoch die Leistung herab. Gruppieren Sie mehrere Aktionen in einer einzelnen MSDTC-Transaktion, vorausgesetzt, die Aktionen können schnell durchgeführt werden.

  • Langlebige Transaktionen sollten asynchron durchgeführt werden und XLANG-Ablaufpläne sollten so entworfen werden, dass sie COM-Aufrufe schnell ausführen. Ergebnisse asynchroner Arbeit können über Nachrichtenwarteschlangen oder COM-Aufrufe an die XLANG-Ablaufplaninstanz zurückgesendet werden. Bei Verwendung von COM kann der Name eines Ports für "Antworten" in Form eines Monikers übergeben werden, der auch bei einem Neustart des Computers gültig ist.

Verwandtes Thema

Monikersyntax


Optimieren der BizTalk-Messagingdienste

So optimieren Sie die BizTalk-Messagingdienste

  • Senden Sie Dokumente an eine Servergruppe. BizTalk-Servergruppen dienen zur Verteilung von Arbeit auf mehrere Server. Um Daten an BizTalk Server zu senden, verwenden Sie die folgenden Verfahren:
    • Konfigurieren einer Empfangsfunktion (z. B. Message Queuing oder Datei).

    • Aufrufen der Submit-Methode des Interchange-Objekts von BizTalk Server.

    Mit den Empfangsfunktionen lässt sich eine bessere Leistung erzielen als bei Verwendung der Submit-Methode zum Aufrufen des Interchange-Objekts, da die Empfangsfunktionen innerhalb der BizTalk-Dienste ausgeführt werden und den internen Status von Objekten zwischenspeichern können. Die Submit-Methode hingegen wird außerhalb des Prozesses (Out-Of-Process) ausgeführt und muss ihren internen Status für jeden Aufruf neu erstellen.

    Beim Aufruf des Interchange-Objekts für die Versendung anstelle des Verwendens der Empfangsfunktion werden mehr Ressourcen verwendet, da das Interchange-Objekt außerhalb des BizTalk Server-Prozesses erstellt werden muss. Bei Verwendung des Interchange-Objekts stehen jedoch zwei Verfahren für das Senden von Daten an die Server in einer Gruppe zur Verfügung:

    • Statische Konfiguration von Anteilen der gesamten Versendungen auf bestimmten Servern innerhalb der Gruppe. Dieses Verfahren stellt jedoch nur geringe Fehlertoleranz bereit, wenn der Server, auf dem sich ein Transportdienst befindet, statisch einem ausgefallenen BizTalk-Server zugeordnet ist.

    • Verwendung der Microsoft Application Center 2000-Funktion CLB (Component Load-Balancing) zur Verbesserung der Leistung. BizTalk-Servergruppen stellen keinen Lastenausgleich für die Versendung von Dokumenten bereit. Neben dem Lastenausgleich stellt CLB Fehlertoleranz zur Verfügung. Weitere Informationen zu CLB erhalten Sie unter Komponentenlastenausgleich.

    Wichtig

    • Führen Sie keine Replikation der Standardanwendung XLANG-Ablaufplanung (XLANG Scheduler) oder beliebiger COM+-Anwendungen durch, die als Host für XLANG-Ablaufpläne dienen. Wird CLB verwendet, müssen diese COM+-Anwendungen auf jedem Server installiert werden. An XLANG-Ablaufpläne gebundene COM-Komponenten können repliziert werden.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Erstellen und Optimieren von Spezifikationen

  • Erstellen und Optimieren von Zuordnungen

  • Optimieren von BizTalk Server-Gruppeneigenschaften

  • Optimieren der Servereigenschaften

  • Optimieren der Registrierungseinstellungen

  • Optimieren der Verschlüsselung

  • Optimieren der Kommunikation

  • Konfigurieren von Firewalls


Erstellen und Optimieren von Spezifikationen

Wenn die Standardeinstellungen für die globale Überwachung verwendet werden, kann BizTalk Server 2000 ein 20 MB großes XML-Dokument im Unicode-Format unterstützen. Bei anderen Dateitypen, z B. ANSI-Flatfile, unterstützt BizTalk Server die Dateigröße von 20 MB nicht, da eine Datei in einem anderen Format als XML in eine XML-Datei konvertiert werden muss. Im Konvertierungsprozess werden zu den Daten XML-Tags hinzugefügt, wodurch sich die Größe des Dokuments erhöht, das BizTalk Server verarbeiten muss. Andere Dateitypen müssen kleiner als 20 MB sein, damit eine optimale Leistung von BizTalk Server gewährleistet werden kann. Der für die Verarbeitung eines in das XML-Format konvertierten Dokuments benötigte Speicher hängt von der Originalstruktur des Dokuments ab. Wenn globale Überwachungseinstellungen aktiviert sind, können XML-Dokumente im Unicode-Format verarbeitet werden, die größer als 20 MB sind, ohne dass die BizTalk Server-Leistung hiervon stark beeinträchtigt wird.

Anmerkung

  • Wird die Größenbeschränkung für die Überwachung von Austauschvorgängen überschritten, wirkt sich dies negativ auf die Leistung von BizTalk Server aus. Weitere Informationen zur Größenbeschränkung erhalten Sie unter Austausch- und Dokumentgrößenbeschränkung. Die Leistung wird ebenfalls durch die Dokumentprotokollierung beeinträchtigt. Weitere Informationen zur Dokumentprotokollierung erhalten Sie unter Festlegen von Eigenschaften für die Dokumentprotokollierung.

Beim Entwurf von Spezifikationen können Sie Gültigkeitsregeln innerhalb einer Spezifikation konfigurieren. Beispielsweise können Sie festlegen, dass ein Feld einen bestimmten Datentyp enthalten kann (z. B. eine Zeichenfolge), oder komplexere Regeln erstellen (beispielsweise das Überprüfen eines Feldes anhand einer Liste mit 80 Werten). Im zweiten Fall müssen die Daten mit 80 Werten verglichen werden. Wenn sie keinem dieser Werte entsprechen, schlägt die Gültigkeitsüberprüfung der Spezifikation fehl. Die Spezifikationsüberprüfung ist in BizTalk Server standardmäßig aktiviert. Sie beeinträchtigt zwar die Leistung, stellt jedoch die Gültigkeit der gesendeten und empfangenen Daten sicher. Die Überprüfung kann deaktiviert werden. Dies steigert die Leistung und wirkt sich nicht nachteilig auf die Gültigkeit der Daten aus, da BizTalk Server über mehrere andere Mechanismen zur Überprüfung der Daten verfügt. Wenn beispielsweise eine Zuordnung bestimmte Datentypen und Werte erfordert und die Spezifikationsüberprüfung deaktiviert ist, durchlaufen die Daten zwar erfolgreich die Analysephase, wenn während der Serialisierungsphase die Zuordnung angewendet wird, treten jedoch Fehler auf. Falls andere Mechanismen (z. B. Zuordnungen anhand gültiger Daten) verfügbar sind, kann die Spezifikationsüberprüfung deaktiviert werden, um die durch den Überprüfungsprozess hervorgerufenen potenziellen Leistungseinbußen zu verhindern. Alternativ empfiehlt sich die Wahl dieses Verfahrens auch, wenn Sie über gemeinsame Datenstandards mit Geschäftspartnern verfügen und die Transaktionen überprüft haben. Als weiterer Grund für dieses Verfahren ist zu nennen, dass Sie auf diese Weise die vollständige Kontrolle über die Art und Weise besitzen, wie die Daten gesendet werden (z. B. Transaktionen zwischen Anwendungen).

Die Überprüfung kann mit der folgenden Registrierungseinstellung deaktiviert werden:

  • NoValidation. Wenn die Spezifikationsüberprüfung nicht erforderlich ist (Dokumente werden nicht anhand einer Spezifikation für Einstellungen wie z. B. Minimal-/Maximalwerte, Datentypen und/oder erforderliche Werte überprüft), legen Sie für diese Einstellung einen Wert ungleich 0 fest. Die Daten werden dann nicht überprüft. Auf diese Weise lässt sich zwar die Leistung verbessern, möglicherweise werden jedoch ungültige Daten versendet. Die Änderung der Spezifikationsüberprüfung auf einen Wert ungleich 0 kann die richtige Option für Server sein, die Dokumente empfangen, über deren Struktur die Organisation die Kontrolle besitzt.

Die Registrierungseinstellung muss auf jedem einzelnen Server geändert werden. Bei aktivierter Spezifikationsüberprüfung wird jedes auf dem Server verarbeitete Dokument anhand seiner Spezifikation überprüft. Dieses Verfahren wird durch die Verwendung der Spezifikationsüberprüfung verlangsamt.

Empfohlene Lösungen für die Optimierung von Dokumentgröße und Spezifikationen

So optimieren Sie die Leistung von BizTalk Server

  • Nehmen Sie nicht mehr Felder und/oder Attribute in Spezifikationen auf als erforderlich. Bei umfangreichen Feldern und Attributen sind auch die Speicheranforderungen für BizTalk Server erhöht. Eine größere Spezifikation erfordert einen proportionalen Zuwachs im Speicher. Beispiel: Die im Lieferumfang von BizTalk Server enthaltenen EDI-Spezifikationen sind mit den EDI-Standards kompatibel. Normalerweise benötigen die meisten Organisationen, die EDI-Spezifikationen verwenden, nur ungefähr 10 Prozent der gesamten Spezifikation. Wenn eine Organisation und ihre Handelspartner also nur 10 Prozent der vollständigen Spezifikation verwenden, können die nicht benötigten Datensätze und Felder gelöscht werden, und die modifizierte Spezifikation kann für Transaktionen verwendet werden.

  • Wenn die Spezifikationsüberprüfung aktiviert ist, legen Sie keine Gültigkeitsregeln in Spezifikationen für Felder fest, die gültige Daten enthalten. Enthält beispielsweise ein Feld eine Zahl, wird jedoch nur als Zeichenfolge verarbeitet (z B. eine Telefonnummer), legen Sie das Feld nicht als numerisch fest. In diesem Fall ist es nicht notwendig, einen Datentyp festzulegen, da String der Standarddatentyp ist. Das Feld für den Datentyp kann daher leer bleiben. Bei der Festlegung akzeptabler Werte für ein Feld dauert die Überprüfung länger als bei einer einfachen Datentypüberprüfung.


Erstellen und Optimieren von Zuordnungen

Als Bestandteil einer Transaktion verringert die Konvertierung von Daten unter Umständen die Leistung von BizTalk Server 2000. Die Zuordnung von Spezifikationen kann CPU-intensiv sein, wodurch gegebenenfalls die Fähigkeit von BizTalk Server zur Verarbeitung der Gesamttransaktion reduziert wird. Wie stark BizTalk Server betroffen ist, richtet sich vor allem nach der Komplexität der für die Konvertierung verwendeten Zuordnung. Wird beispielsweise das Feld productID in der Quellspezifikation dem Feld itemID in der Zielspezifikation zugeordnet, wirkt sich dies nicht so stark aus wie eine komplexe mathematische Operation, die an den Daten durchgeführt wird, die konvertiert werden.

Empfohlene Lösungen für den Entwurf von Zuordnungen

  • Verwenden Sie Funktoide nur dann, wenn es notwendig ist. Funktoide verwenden Skripts, was dazu führt, dass BizTalk Server ein Skriptmodul lädt. Im Gegensatz zu systemeigenen XML-Transformationen kann dies die Leistung herabsetzen.

  • Verwenden Sie das Funktoid Datenbanksuche nur dann, wenn es notwendig ist. BizTalk Server muss eine Datenbankverbindung einrichten, Datenabfragen durchführen, ein Recordset auffüllen und die Verbindung immer dann schließen, wenn das Funktoid verwendet wird. Dies kann die Leistung von BizTalk Server beeinträchtigen.

  • Vermeiden Sie, COM-Objekte innerhalb von Funktoidskripts aufzurufen, und verwenden Sie keine benutzerdefinierten Funktoide. Beide Verfahren veranlassen BizTalk Server, eine Instanz eines COM-Objekts zu instanziieren. Hierdurch wird die Leistung der Gesamtoperation negativ beeinflusst. Darüber hinaus wird die Leistung instanziierender COM-Objekte beeinflusst, je nachdem, wie die folgenden Fragen beantwortet werden:
    • Handelt es sich um ein In-Process-Objekt oder ein Out-Of-Process-Objekt?

    • Handelt es sich um ein lokales Objekt oder ein Remoteobjekt?

    • Wie fachgerecht wurde das Objekt erstellt?

    • Ist das Objekt transaktionsorientiert?
  • Analysieren Sie jede Zuordnung, um zu ermitteln, wie sich eine optimale Leistung erzielen lässt. Beispielsweise können zwei unterschiedliche Techniken verwendet werden, um 2 Quellfelder miteinander zu verketten und den Ergebniswert in 2 verschiedene Zielfelder einzufügen. Bei der ersten Verkettungstechnik wird ein Funktoid vom Typ Verkettung verwendet, dessen Ausgabe zwei Stellen zugeordnet wird. Bei der zweiten Verkettungstechnik werden 2 Funktoide verwendet, von denen jedes eine einzelne Ausgabeverknüpfung mit einem Zielspezifikationsfeld aufweist. Die erste Technik ist etwas effizienter, da das Skript, das als Bestandteil des Funktoids ausgeführt wird, nur einmal aufgerufen wird. Mithilfe von Tests können Sie ermitteln, welche Techniken die beste Leistung liefern.


Optimieren von BizTalkServer-Gruppeneigenschaften

BizTalk Server-Kopfzeile

Optimieren von BizTalk Server-Gruppeneigenschaften

In der BizTalk Server-Verwaltung können Sie folgende Eigenschaften im Dialogfeld Eigenschaften der BizTalk Server-Gruppe festlegen:

  • Aktualisierungsintervall für Messaging-Verwaltungsobjektcache (Sek.). Für dieses Feld kann ein Maximalwert von 300 Sekunden festgelegt werden. BizTalk Server 2000 führt eine Zwischenspeicherung der Konfigurationen (z. B. Kanäle, Messagingports, Umschläge und Dokumentdefinitionen) im Arbeitsspeicher durch, um zu vermeiden, dass die Datenbank jedes Mal aufgerufen werden muss. Sofern die Objekte nicht regelmäßig geändert werden, legen Sie den Wert auf 300 fest, damit Daten weniger häufig in die Datenbank geschrieben und aus der Datenbank gelesen werden müssen. Da BizTalk Server die Verwaltungsobjekte alle 5 Minuten aktualisiert, muss der Dienst neu gestartet werden, damit die Änderungen sofort wirksam werden.

  • Deaktivieren der Dokumentüberwachung. Auf der Registerkarte Überwachen kann die Dokumentüberwachung aktiviert oder deaktiviert werden. Wird keine Überwachung durchgeführt, deaktivieren Sie dieses Feld, um die Anzahl der Schreib-/Lesevorgänge in der Datenbank für eine einzelne Transaktion zu minimieren. Wenn das Feld aktiviert ist, stellt BizTalk Server eine Verbindung zu der Datenbank her und protokolliert die Daten. Deaktivieren Sie das Feld nur, wenn keine Überwachung notwendig ist. Es wird jedoch dringend empfohlen, die Dokumentüberwachung nicht zu deaktivieren. Weitere Informationen zur Festlegung von Überwachungseigenschaften erhalten Sie unter Konfigurieren von Überwachungseigenschaften für eine Servergruppe.

    Anmerkung

    • Für die Überwachung von Austauschvorgängen existiert eine Größenbeschränkung. Wird diese überschritten, führt das zu Leistungseinbußen bei BizTalk Server. Weitere Informationen zur Größenbeschränkung erhalten Sie unter Austausch- und Dokumentgrößenbeschränkung. Die Leistung wird ebenfalls durch die Dokumentprotokollierung beeinträchtigt. Weitere Informationen zur Dokumentprotokollierung erhalten Sie unter Festlegen von Eigenschaften für die Dokumentprotokollierung.
  • Aufrufreihenfolge für Server anordnen. Für BizTalk Server-Parser kann eine Prioritätsreihenfolge festgelegt werden, wenn eine Gruppe hauptsächlich einen bestimmten Dokumenttyp empfängt. BizTalk Server verfügt über 4 Parser für die Datenanalyse: XML, EDIFACT, X12 und Flatfile. Wenn BizTalk Server ein Dokument empfängt, wird versucht, das Dokument mit diesen Parsern in der Reihenfolge, in der sie aufgeführt sind, zu analysieren. Falls eine Organisation in erster Linie einen bestimmten Dokumenttyp erhält, sollte die Reihenfolge der Parser so geändert werden, dass der erste Parser dem Typ der hauptsächlich empfangenen Dokumente entspricht.

Verwandtes Thema

Horizontales Skalieren der BizTalk-Messagingdienste


Optimieren der Servereigenschaften

In der BizTalk Server-Verwaltung können Sie folgende Eigenschaften im Dialogfeld Eigenschaften von <Server> festlegen:

  • Erstellen mehrerer Instanzen von Empfangsfunktionen. Durch diese Eigenschaft erhält BizTalk Server die Möglichkeit, mehrere Empfangsfunktionen für Dokumente abzurufen, die verarbeitet werden. Um die Dokumentbelastung auf verschiedene Computer zu verteilen, speichern Sie die Empfangsfunktionen auf separaten Computern. Jeder Abrufspeicherort muss eindeutig sein und eine separate Empfangsfunktion enthalten. Um die Überlastung einer einzelnen Empfangsfunktion zu verhindern, muss die Geschäftsanwendung, die Dokumente sendet, die Dokumente gleichmäßig auf die abrufenden Speicherorte aufteilen.

  • Maximale Anzahl von Empfangsfunktionsthreads. Sie können festlegen, wie viele Arbeitsthreads einer Empfangsfunktion pro Prozessor für eine Empfangsfunktion vorhanden sein sollen. Wenn Sie einen zu niedrigen Wert angeben, kann dies zu einer Verlangsamung von BizTalk Server führen, da die Anwendung E/A-Komplettierungsports verwendet. Die Festlegung eines zu hohen Wertes hat normalerweise keine ernstlichen Auswirkungen, führt jedoch unter Umständen zu Leistungseinbußen. Sie können diese Zahl ändern, um den optimalen Wert zu ermitteln. Der empfohlene Wert für Maximale Anzahl von Empfangsfunktionsthreads beträgt 4.

  • Maximale Anzahl von Arbeitsthreads pro Prozessor. Sie können die Anzahl der Arbeitsthreads pro Prozessor für die verarbeitende Seite festlegen. Durch entsprechende Anpassung der Arbeitsthreads kann die Leistung verbessert werden. Klicken Sie in der BizTalk Server-Verwaltung mit der rechten Maustaste auf einen Server in der Konsolenstruktur, und klicken Sie dann auf Eigenschaften. Ändern Sie den Standardwert im Feld Maximale Anzahl von Arbeitsthreads pro Prozessor. Der Standardwert lautet 4. Der empfohlene Wert liegt zwischen 10 und 16, je nach Bereitstellung.


Optimieren der Registrierungseinstellungen

Sie können die Registrierungseinstellungen optimieren, um die Leistung von BizTalk Server zu verbessern. Alle Schlüssel sollten als DWORD-Werte zu HKLM\System\Current Control Set\Services\BTSSVC hinzugefügt werden. Um die Leistung zu verbessern, führen Sie die folgenden Anpassungen für Registrierungseinstellungen durch:

  • NoValidation. Verwenden Sie diesen Registrierungsschlüssel, um die Spezifikationsüberprüfung zu deaktivieren. Wenn die Spezifikationsüberprüfung nicht erforderlich ist (Dokumente werden beispielsweise nicht anhand einer Spezifikation für Minimal-/Maximalwerte, Datentypen oder erforderliche Werte überprüft), legen Sie für diese Einstellung einen Wert ungleich 0 fest. Die Daten werden dann nicht überprüft. Hierdurch wird zwar möglicherweise die Leistung gesteigert, es kann jedoch auch dazu führen, dass ungültige Daten gesendet werden. Diese Einstellung eignet sich für Server, die Dokumente empfangen, deren Struktur durch die Organisation kontrolliert wird.

  • ParserRefreshInterval. Standardmäßig ist hierfür der Wert 60.000 (60 Sekunden) festgelegt. Dieser Wert gibt an, wie häufig BizTalk Server die Datenbank überprüfen soll, um festzustellen, ob ein neuer Parser hinzugefügt wurde (dies ist die einzige Eigenschaft auf Gruppenebene, die während der Ausführung des Servers aktualisiert wird). Wenn keine neuen Parser hinzugefügt werden, legen Sie diesen Wert auf 0 fest. BizTalk Server führt dann keine Überprüfung der Datenbank durch. Mit diesem Wert wird außerdem überprüft, ob zu den Gruppeneinstellungen der Überwachungsdatenbank neue Parser hinzugefügt oder ob die Einstellungen geändert wurden.

  • CacheSize. Verwenden Sie diesen Registrierungsschlüssel, um festzulegen, wie weit der BizTalk Server-Verwaltungsobjektcache anwachsen darf. Der Standardwert beträgt 20. Sobald im BizTalk Server-Objektcache mehr als 20 Kanäle, Messagingports, Umschläge oder Dokumentdefinitionen enthalten sind, muss BizTalk Server einige Objekte aus dem Speicher löschen. Wenn ein Server ein umfangreiches Speichervolumen besitzt, kann hier ein höherer Wert (über 20) festgelegt werden. BizTalk Server bewahrt dann eine größere Anzahl von Objekten im Speicher auf. Dies wirkt sich nicht auf das Aktualisierungsintervall aus. BizTalk Server löscht die zwischengespeicherten Objekte und lädt sie neu, wenn sie abgelaufen sind.

  • BatchSize. Verwenden Sie diesen Wert nur zusammen mit der Message Queuing-Empfangsfunktion. Als Standardwert für BatchSize ist 20 festgelegt. Um die Leistung zu verbessern, liest BizTalk Server bis zu 20 Objekte gleichzeitig aus der Warteschlange und sendet alle 20 Objekte innerhalb einer einzelnen Transaktion. Durch eine Reduzierung der Schreibzugriffe auf die Datenbank kann die Leistung erheblich gesteigert werden. Falls ein Deadlock auftritt und BizTalk Server die Transaktion beendet, müssen die Objekte erneut gesendet werden. BizTalk Server verliert die Dokumente nicht. Werte über 20 wurden bisher nicht getestet. Legen Sie diesen Wert nicht auf 0 fest.

Folgendes Thema wird in diesem Abschnitt behandelt:

  • Verbessern der Verarbeitungsleistung


Verbessern der Verarbeitungsleistung

  1. Klicken Sie auf Start, dann auf Ausführen, geben Sie regedit ein, und klicken Sie dann auf OK.

  2. Klicken Sie im Dialogfeld Registrierungs-Editor auf das Pluszeichen (+), um den Knoten HKEY_LOCAL_MACHINE zu erweitern, erweitern Sie dann SYSTEM, CurrentControlSet und Services, und klicken Sie dann auf BTSSvc.

  3. Klicken Sie mit der rechten Maustaste auf den Detailfensterbereich, zeigen Sie auf Neu, und klicken Sie dann auf DWORD-Wert.

  4. Geben Sie NoValidation ein, und drücken Sie zwei Mal die EINGABETASTE.

    Das Dialogfeld DWORD-Wert bearbeiten wird angezeigt.

  5. Geben Sie im Feld Daten des Wertes einen Wert ein, der ungleich 0 ist (z. B. 1), und klicken Sie dann auf OK. Der Standardwert ist 0 (Überprüfung).

  6. Klicken Sie mit der rechten Maustaste auf den Detailfensterbereich, zeigen Sie auf Neu, und klicken Sie dann auf DWORD-Wert.

  7. Geben Sie ParserRefreshInterval ein, und drücken Sie dann die EINGABETASTE.

  8. Klicken Sie mit der rechten Maustaste auf den Detailfensterbereich, zeigen Sie auf Neu, und klicken Sie dann auf DWORD-Wert.

  9. Geben Sie CacheSize ein, und drücken Sie zwei Mal die EINGABETASTE.

    Das Dialogfeld DWORD-Wert bearbeiten wird angezeigt.

  10. Geben Sie im Feld Daten des Wertes die Anzahl der Kanäle, Messagingports, Umschläge und Dokumentdefinitionen ein, die im Speicher vorhanden sind oder vorhanden sein sollten.

  11. Klicken Sie mit der rechten Maustaste auf den Detailfensterbereich, zeigen Sie auf Neu, und klicken Sie dann auf DWORD-Wert.

  12. Geben Sie BatchSize ein, und drücken Sie dann zwei Mal die EINGABETASTE.

    Das Dialogfeld DWORD-Wert bearbeiten wird angezeigt.

  13. Geben Sie im Feld Daten des Wertes einen Wert für die Anzahl der Objekte ein, die als ein Batch verarbeitet werden sollen.


Optimieren der Verschlüsselung

Wird die Verschlüsselung oder ein anderer Sicherheitsmechanismus verwendet, kann dies die Leistung von BizTalk Server beeinträchtigen. Beim Verwenden der Verschlüsselung wird Folgendes empfohlen:

  • Erhöhen der CPU-Taktfrequenz (MHz). Durch eine Erhöhung der Prozessoranzahl kann die Leistung gesteigert werden.

  • Erhöhen der Serverzahl.

  • Verwenden einer schnelleren CPU.

  • Trennen von BizTalk Server-Funktionen. Beispielsweise können Sende- und Empfangsfunktionen auf separaten Servern platziert werden. Der HTTPS-Transportdienst kann sich ebenfalls auf einem separaten Server befinden.

  • Verwenden eines virtuellen privaten Netzwerks (VPN), wenn ein Dateidienst oder Message Queuing verwendet wird. Wenn ein VPN verfügbar ist, ist eine sichere Datenübertragung gewährleistet. Es ist nicht erforderlich, BizTalk Server-Transaktionen zu sichern, wenn alle mit Handelspartnern durchgeführten Datenübertragungen über ein VPN gesichert werden.

  • Erwerben von Beschleunigerkarten für Verschlüsselungshardware. Beschleunigerkarten stellen bestimmte Prozessoren bereit, die die negativen Auswirkungen beheben können, die Ver- und Entschlüsselung auf die Leistung der CPU eines Servers haben. Der Erwerb von Beschleunigerkarten ist weniger kostenintensiv als das Hinzufügen mehrerer CPUs.


Optimieren der Kommunikation

BizTalk Server stellt Integrationsmechanismen für die synchrone Kommunikation und die asynchrone Kommunikation bereit. BizTalk Server 2000 kann Dokumente über die COM-Integration oder über Serverempfangsfunktionen (Datei oder Message Queuing) akzeptieren.

Wenn ein Dokument an BizTalk Server gesendet wird, wird es normalerweise in die Datenbank für gemeinsam genutzte Warteschlangen übernommen. BizTalk Server ruft die Datenbank ab und verarbeitet dann das Dokument. Bei diesem Prozess handelt es sich um einen asynchronen Kommunikationsmechanismus. Er verwendet die Microsoft SQL Server-Datenbank als Warteschlange für die Erstellung eines Prüfpunkts für Dokumente, die auf die Verarbeitung warten. Diese zusätzliche Abstraktionsschicht ermöglicht dem Transportdienst das Senden von Dokumenten an BizTalk Server unabhängig von dem für die Dokumentübermittlung verwendeten Transportmechanismus.

Ein synchroner Kommunikationsaustausch umgeht alle Warteschlangen und verarbeitet alle vom Messagingport benötigten Komponenten auf dem aufrufenden Thread. Sofern verfügbar, wird für synchrone Kommunikationsprotokolle ein optionales Antwortdokument zurückgegeben. Dieses Verfahren kann nur für eine einzelne Kanalübereinstimmung und für einen einzelnen Messagingport (keine Verteilerlisten) durchgeführt werden. Wenn aufgrund der festgelegten Parameter Übereinstimmungen für mehrere Kanäle vorhanden sind, gibt eine synchrone Kommunikationsversendung eine Fehlermeldung zurück, die angibt, dass für eine synchrone Kommunikationsversendung mehrere Kanalübereinstimmungen nicht zulässig sind. Dieses Verfahren kann nur für einzelne Dokumentaustauschvorgänge verwendet werden. Wenn die Versendung mehrere Dokumente enthält, wird bei synchronen Versendungen eine Fehlermeldung ausgegeben, die darüber informiert, dass mehrere Dokumentversendungen nicht erlaubt sind. Das Verfahren unterstützt keine Gruppen. Die synchrone Kommunikation ist nicht skalierbar. Sie verwendet einen einzelnen Thread zur Verarbeitung einer Transaktion, und ein Lastenausgleich mit anderen BizTalk-Servern in der Gruppe ist nicht möglich, da der gesamte Prozess auf dem Server ausgeführt werden muss, der die Dokumente versendet.

Der synchrone Kommunikationsmechanismus sendet Dokumente direkt an BizTalk Server zur unmittelbaren Verarbeitung. BizTalk Server sperrt die Rückgabe an den Aufrufer der IInterchange::SubmitSync-Schnittstelle, bis die Verarbeitung abgeschlossen ist, wodurch ein Antwortdokument an den Aufrufer gesendet wird. Dieser Mechanismus steht nur für die COM-basierte Integrationsmethode zur Verfügung.

Empfohlene Lösungen für die Optimierung synchroner und asnychroner Kommunikation

So optimieren Sie die Leistung von BizTalk Server

  • Zur Erzielung optimaler Leistung und Skalierbarkeit wird dringend der Einsatz der asynchronen Kommunikation empfohlen. Die asynchrone Kommunikation ist in hohem Maße skalierbar und stellt hohen Durchsatz bereit. Synchrone Kommunikationsaufrufe stellen beinahe unmittelbare Antworten an den aufrufenden Prozess bei einer großen Anzahl von Transaktionen zur Verfügung, da jeder SubmitSync-Aufruf unter einem separaten Thread ausgeführt wird. Wenn jedoch zahlreiche gleichzeitige Aufrufe vorhanden sind, führt dies zur Ausführung einer großen Anzahl von Threads auf einem einzelnen Server, wodurch die Gesamtleistung von BizTalk Server absinkt. Microsoft Windows 2000 führt Kontextumschaltungen zwischen allen Threads durch, was zu einer Verringerung der Gesamtleistung von BizTalk Server führt. Darüber hinaus führen die folgenden Kriterien dazu, dass zwar eine synchrone jedoch keine asynchrone Kommunikationsversendung fehlschlägt:
    • Die Transaktionskriterien stimmen mit mehreren Kanälen überein.

    • Der Austausch enthält mehrere Dokumente.
  • Dokumente mit automatischem Routing können die Leistung von BizTalk Server beeinträchtigen.


Konfigurieren von Firewalls

Firewalls bieten Unterstützung bei der Sicherung interner Netzwerke, führen jedoch zu Wartezeit und können unter Umständen zu Einzelpunktversagen führen. Selbst wenn ein Mechanismus für den Lastenausgleich verwendet wird, um das Einzelpunkt-Versagen zu vermeiden, kann ein Firewall die Netzwerkleistung reduzieren.

Bei der Konfiguration einer BizTalk Server 2000-Umgebung mit einem Firewall werden zwei Hauptkonfigurationen empfohlen:

  • Konfiguration 1. Installieren Sie Server in einem internen Firmennetzwerk. Fügen Sie einige dieser Server, über die die Kommunikation mit Handelspartnern abgewickelt wird, zu einer firmeninternen DMZ (Demilitarized Zone) hinzu. Eine Firma, die eigene Internetdienste verwalten möchte, ohne den unautorisierten Zugang zu ihrem privaten Netzwerk zu ermöglichen, verwendet eine DMZ. Die DMZ stellt die Begrenzung zwischen dem Internet und der Abwehreinrichtung eines internen Netzwerks dar. Üblicherweise handelt es sich dabei um eine Kombination aus Firewalls und Bastionshosts, d. h. Gateways zwischen internen und externen Netzwerken. Die Server in der DMZ sollten lokale Transportdienste verwenden, wie z. B. HTTP, Message Queuing oder SMTP. In dieser Umgebung durchlaufen alle eingehenden und/oder ausgehenden Transaktionen einen Firewall. Die Server in der DMZ senden Dokumente über einen weiteren Firewall an Microsoft SQL Server. Diese Konfiguration ermöglicht Servern, wie z. B. BizTalk Server und HTTP in der DMZ, über einen internen Firewall mit Microsoft SQL Server zu kommunizieren.

  • Konfiguration 2. Installieren Sie die Server in einem Firmennetzwerk. Handelspartner, die Dokumente über das Internet austauschen, senden ihre Daten mithilfe von SMTP/HTTP-Servern in der DMZ (erster Schutzfirewall). Diese Server senden die Daten dann über einen zweiten Firewall an die Server im Firmennetzwerk.

Konfiguration 1 und 2 beeinträchtigen beide die Leistung. Um einen nennenswerten Leistungsabfall zu vermeiden, können Sie den Firewall so einrichten, dass eine bestimmte Anzahl von Transaktionen zwischen einer Organisation und ihren Handelspartnern möglich ist.


Architekturentwurf, Überprüfung und Tests

Zu den Hauptkomponenten von BizTalk Server 2000 zählen die BizTalk-Dienste, die BizTalk Server-Datenbanken und die Transportdienste. Eine mangelhafte Konfiguration einer Komponente kann die Leistung des gesamten Systems beeinträchtigen.

Dieser Abschnitt stellt detaillierte Informationen zum Definieren, Testen und Verbessern der Architektur von BizTalk Server zur Optimierung der Leistung bereit.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Architekturentwurf

  • Test und Analyse der Architektur

Verwandtes Thema

Skalieren von BizTalk Server


Architekturentwurf

Wenn Sie die genaue Anzahl der Dokumente ermitteln möchten, die von BizTalk Server 2000 verarbeitet werden können, müssen Sie zunächst berücksichtigen, ob folgende Komponenten verwendet werden:

  • Spezifikationsüberprüfung

  • Anwendungsintegrationskomponenten

  • Transportdienste

  • Verschlüsselung

  • BizTalk-Orchestrierungsdienste

  • Firewalls

  • Zuordnungen

Weiterhin müssen Sie die Größe der verarbeiteten Dokumente sowie die aktuelle Serverkonfiguration berücksichtigen.

Das Testen der Leistung ist erfolgreich, wenn es mit kontrollierten Prozessen durchgeführt wird. Dabei ist es wichtig, mit wenigen Variablen zu beginnen und dann langsam weitere Variablen hinzuzufügen. Wenn die Leistung abzusinken beginnt, können Sie problemlos den Grund für die sinkende Leistung ermitteln.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Entwickeln von Transaktionskomponenten

  • Festlegen von Transportarten

  • Ausgangsarchitektur

Verwandte Themen

Verwalten von Servern und Anwendungen

BizTalk-Orchestrierungsdienste

Creating Application Integration Components

Erstellen von Spezifikationen

Zuordnen von Daten

Ausführung von XLANG-Ablaufplänen

Verwenden des BizTalk-Orchestrierungs-Designers


Entwickeln von Transaktionskomponenten

Bei der Entwicklung von Transaktionskomponenten müssen Benutzer Transaktionen entwerfen und Transaktionseigenschaften für Geschäftsprozesse festlegen. Weitere Informationen zum Entwerfen von Transaktionen und Festlegen von Transaktionseigenschaften erhalten Sie unter:

  • Entwerfen von Geschäftsprozessen

  • Entwerfen von Transaktionen

  • Transaktionseigenschaften für eine XLANG-Ablaufplanzeichnung

Informationen zu Techniken, die Sie bei der Ermittlung der effizientesten Transaktionskonfiguration unterstützen können, erhalten Sie unter Auswerten der Leistung einer Konfiguration.

Bei der Entwicklung von Transaktionskomponenten müssen Benutzer zunächst ermitteln, welche Transaktionstypen von den Komponenten verarbeitet werden. In einer Business-to-Business-Umgebung oder einer Umgebung, in der Daten zwischen Anwendungen ausgetauscht werden, müssen Sie die Transaktionsanforderungen und -profile bestimmen. Folgendes Szenario ist beispielsweise denkbar: Eine einzelne Transaktion empfängt einen benutzerdefinierten XML-Auftrag und ordnet diesen einem standardmäßigen EDI-Auftrag zu, der später von einer benutzerdefinierten internen Anwendung verarbeitet wird.

Das Szenario erfordert, dass Sie eine Spezifikation für den XML-Auftrag und eine Spezifikation für den EDI-Auftrag erstellen. Verwenden Sie zum Erstellen dieser Spezifikationen den BizTalk-Editor, der XML- und EDI-Vorlagen enthält. Da die Vorlagen alle potenziellen Datensätze und Felder enthalten, können Sie nicht benötigte Datensätze und Felder entfernen und die Vorlagen dann anschließend als finale Spezifikationen speichern. Während der Entwurfszeit wirken sich alle Felder in einer Spezifikation, die überprüft werden müssen, negativ auf die Leistung von BizTalk Server 2000 aus. Weitere Informationen zur Optimierung von Spezifikationen erhalten Sie unter Erstellen und Optimieren von Spezifikationen.

Zusätzlich zum Erstellen einer Spezifikation müssen Sie Daten zuordnen. Da es verschiedene Möglichkeiten zur Konvertierung von Daten in Zuordnungsdateien gibt (mithilfe von XSLT-Konvertierungen, Funktoids oder einem benutzerdefinierten Skript), die alle die Leistung beeinträchtigen, ist es wichtig, die verschiedenen Konvertierungsmethoden zu testen. Durch den Vergleich der verschiedenen Verfahren zur Datenkonvertierung kann gegebenenfalls die Beeinträchtigung der Leistung von BizTalk Server aufgrund von Zuordnungen reduziert werden. Weitere Informationen erhalten Sie unter Erstellen und Optimieren von Zuordnungen.

Verwandte Themen

Entwerfen von Geschäftsprozessen

Entwerfen von Transaktionen

Festlegen von Transportarten

Transaktionseigenschaften für eine XLANG-Ablaufplanzeichnung


Festlegen von Transportarten

Wenn Sie festlegen möchten, wie Daten gesendet und empfangen werden sollen, müssen Sie berücksichtigen, ob folgende Komponenten verwendet werden:

  • Business-to-Business-Transaktionen

  • Transaktionen zwischen Anwendungen

  • Transportdienste (Senden und Empfangen)

  • Verschlüsselung

  • HTTPS oder S/MIME

Überlegen Sie basierend auf der Art der Transaktionen, die verarbeitet werden, ob verschiedene Transportarten benötigt werden. Ermitteln Sie, ob eindeutige Transportarten für Business-to-Business-Transaktionen und für Transaktionen zwischen Anwendungen erforderlich sind, oder ob für beide Transaktionstypen die gleichen Transportarten verwendet werden können.


Ausgangsarchitektur

Bei der erfolgreichen Planung einer Ausgangsarchitektur müssen Sie Folgendes berücksichtigen:

  • Ein Server mit Microsoft SQL Server und BizTalk Server kann verwendet werden, um eine geringe Anzahl von Transaktionen zu verarbeiten.

  • Bei einer mäßig hohen Anzahl von Transaktionen können BizTalk Server und SQL Server auf separaten Computern installiert werden.

  • Ein vorhandener SMTP-Transportdienst kann zum Senden und Empfangen von Daten verwendet werden. Für diesen Transporttyp wird empfohlen, diesen Server auf einem separaten Server zu platzieren.

  • HTTP-, Message Queuing- oder Dateitransportdienste können verwendet werden, um Daten auf Festplattenlaufwerke zurückzuschreiben, die sich auf anderen Servern als dem lokalen BizTalk-Server befinden. Hierdurch kann die Leistung von BizTalk Server verbessert werden.

Eine Ausgangsarchitektur sollte so viele separate Server wie notwendig enthalten. Beispielsweise kann innerhalb einer Firma eine bestimmte Person SMTP-Server und Message Queuing verwalten, während eine andere Person die Sicherheitsrichtlinien verwaltet. Das Ziel einer Ausgangsarchitektur besteht darin, zu ermitteln, wie viele Server erforderlich sind und welche Hardware von diesen Servern benötigt wird, um den voraussichtlichen Arbeitsanfall zu verarbeiten. Nachdem Sie die erforderliche Serveranzahl bestimmt haben, sollten Sie die Ausgangsarchitektur testen.

Verwandtes Thema

Test und Analyse der Architektur


Test und Analyse der Architektur

Bevor Sie die Architektur testen, definieren Sie die Komponenten der Architektur, bestimmen Sie die Transaktionsanforderungen und -profile, ermitteln Sie, welche Transaktionskomponenten entwickelt werden müssen, und legen Sie die erforderlichen Transportarten fest. Starten Sie diesen Prozess, indem Sie einen Basisplan erstellen, der Folgendes enthält:

  • Konfigurieren der BizTalk-Messagingdienste, Organisationen, Dokumentdefinitionen, Kanäle und Messagingports, die zur Verarbeitung von Transaktionen benötigt werden.

  • Konfigurieren der BizTalk-Orchestrierungsdienste.

  • Installieren und/oder Konfigurieren von COM+-Anwendungen, BizTalk Server-Kanälen, Datenbanken oder Nachrichtenwarteschlangen, die für XLANG-Ablaufpläne erforderlich sind.

Nachdem ein Basisplan eingerichtet wurde, verarbeiten Sie Transaktionen mithilfe von BizTalk Server. Dieser Test hilft Ihnen, Faktoren zu ermitteln, die die Leistung beeinträchtigen.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Auswerten der Leistung einer Konfiguration

  • Verbessern der Architektur

Verwandte Themen

Architekturentwurf

Skalieren von BizTalk Server


Auswerten der Leistung einer Konfiguration

Mithilfe des Microsoft Windows 2000-Tools Leistung kann die Leistung der BizTalk-Messagingdienste getestet werden.

Wenn Sie das Tool Leistung verwenden möchten, zeigen Sie im Startmenü auf Programme und dann auf Verwaltung, und klicken Sie dann auf Systemmonitor. Systemmonitor, ein Bestandteil des Tools Leistung, bietet eine grafische Darstellung der Leistungsindikatoren und zeigt an, wie sie sich im Laufe der Zeit ändern. Einige Leistungsindikatoren sollten jedoch abhängig von den überwachten Systemkomponenten überwacht werden. Es stehen zahlreiche Whitepaper zur Verfügung, in denen erläutert wird, wie die Leistung von Windows 2000, IIS, SQL Server und Message Queuing überwacht wird. In den folgenden Tabellen sind einige der zu überwachenden primären Objekte und Leistungsindikatoren aufgeführt. Darüber hinaus enthalten die Tabellen spezifische Informationen im Hinblick auf die zu überwachenden Objekte und Datenquellen, um die Leistung der BizTalk-Messagingdienste zu ermitteln.

Objekt | Leistungsindikator | Überprüfung | Betroffene Komponente
Active Server Pages | Aktuelle Anforderungen | Mit Ausnahme von Spitzenzeiten sollte keine bedeutende Warteschlange vorhanden sein. | HTTP-Transportdienste, die ASP-Seiten verwenden
 | Anforderungen/Sek. | Gibt das Volumen der ASP-Anforderungen an, die HTTP-Transportdienste empfangen (sofern ASP verwendet wird). Wenn Dateien in einer HTTP-Seite bereitgestellt werden, stellt dieser Leistungsindikator keine relevanten Informationen zur Verfügung. | HTTP-Transportdienste, die ASP-Seiten verwenden
 | Anforderung-Wartezeiten | Nahe null. | HTTP-Transportdienste, die ASP-Seiten verwenden
Netzwerkschnittstelle | Empfangene Bytes/s / Bytes gesendet/s | Wenn dieser Wert bei mäßiger Prozessor- und Speicherauslastung fast so hoch ist wie die Verbindungskapazität, wird die Leistung möglicherweise durch die Verbindung beeinträchtigt. | Alle
Prozess, Inetinfo-Instanz | Private Bytes | Überwachen Sie diesen Leistungsindikator, um Speicherverluste aufzudecken, oder um festzustellen, ob der maximal verfügbare RAM-Speicher ausgenutzt wurde. | HTTP-Transportdienst
Arbeitsspeicher | Verfügbare Bytes | Die verfügbaren Bytes sollten dauerhaft nicht weniger als 10 MB ausmachen. Andernfalls veranlasst eine Speicherauslastungsspitze, dass die Auslagerung auf die Festplatte gestartet wird. | Alle
 | Seitenfehler/s, Speicher: Seiteneingabe/s, und Speicher: Seitenlesevorgänge/s | Werden hier niedrige Werte verzeichnet, reagiert der Server schnell auf Anforderungen. Bei hohen Werten muss unter Umständen der RAM-Speicher auf dem Server erhöht werden. | Alle
Physikalischer Datenträger | Lesevorgänge/s / Schreibvorgänge/s | Zusammen sollten die Werte dieser beiden Leistungsindikatoren deutlich unter der Maximalkapazität des Datenträgers liegen. Um diesen Leistungsindikator zu aktivieren, zeigen Sie im Startmenü zunächst auf Programme, dann auf Zubehör, und klicken Sie dann auf Eingabeaufforderung. Geben Sie an der Eingabeaufforderung Folgendes ein: diskperf –y. Starten Sie dann den Computer neu. | SQL Server, Message Queuing und Dateitransportdienste
 | Zeit (%) | Der Wert dieses Leistungsindikators sollte deutlich unter 100 Prozent liegen. Bei einem höheren Wert (er kann bis in den Bereich von 1000 Prozent anwachsen), fügen Sie weitere physikalische Datenträger hinzu oder verschieben Sie eine der Datenbanken auf einen anderen Server. | SQL Server, Message Queuing und Dateitransportdienste
 | Aktuelle Warteschlangenlänge | Bei diesem Leistungsindikator handelt es sich um die Anzahl der anstehenden Anforderungen auf dem Datenträger, wenn die Leistungsdaten gesammelt werden. Der Wert dieses Leistungsindikators sollte im Durchschnitt weniger als 2 betragen, damit die Leistung zufriedenstellend ist. | BizTalk Server SQL Server
SQL Server | Transaktionen/Sekunde | Gibt an, wie hoch die zurzeit von SQL Server ausgeführte Aktivität ist. | SQL Server
BizTalk Server | Verarbeitete Dokumente/Sek. | Gibt an, wie schnell BizTalk Server 2000 Dokumente aus ihrer Verarbeitungswarteschlange abruft und versendet. | BizTalk-Messagingdienste
BizTalk Server | Empfangene Dokumente/Sek. | Gibt an, wie schnell BizTalk Server Dokumente an die Verarbeitungswarteschlange sendet. Dieser Wert gibt nur die Anzahl der Dokumente wieder, die BizTalk Server empfangen hat (hierzu zählen Dokumente, die nicht analysiert werden können), nicht die Anzahl der Dokumente, für die BizTalk Server einen Prüfpunkt in ihrer Verarbeitungswarteschlange erstellt. Die Anzahl der Dokumente, für die in der Verarbeitungswarteschlange ein Prüfpunkt erstellt wird, entsprechen dem Wert des Leistungsindikators Verarbeitete Dokumente/Sek. | BizTalk-Messagingdienste
BizTalk Server | Synchrone Versendungsvorgänge/Sek., Asynchrone Versendungsvorgänge/Sek. | Gibt an, wie schnell Aufrufe der Submit-Methode und/oder der SubmitSync-Methode erfolgen. Da jeder Austausch eine beliebige Anzahl von Dokumenten enthalten kann, ist dieser Leistungsindikator nicht hilfreich bei der Ermittlung der verarbeiteten Dokumente. Bei exklusiver Verwendung von Pass-Through (Verarbeitung von Austauschvorgängen ohne Analyse) müssen Sie diesen Leistungsindikator überwachen, um die eingehende Leistung zu ermitteln. | BizTalk-Messagingdienste
Nachrichtenwarteschlange | Nachrichten in der Warteschlange | Dieser Wert sollte nicht besonders stark ansteigen (über 50 KB), da dies zu einer übermäßigen Speicherauslastung auf dem Microsoft Message QueueServer führt und die Leistung des gesamten Systems hierdurch beeinträchtigt wird. | Message Queuing-Transportdienst
System | Prozessor-Warteschlangenlänge | Dieser Leistungsindikator zeigt die Anzahl der Threads an, die in der gemeinsam von allen Prozessoren des Systems verwendeten Warteschlange auf die Verarbeitung warten. Weist dieser Leistungsindikator einen anhaltenden Wert von zwei oder mehr Threads auf, beeinträchtigt der Prozessor die Leistung des gesamten Systems. | Alle
 | Kontextänderungen/s | Weist dieser Indikator für BizTalk Server einen hohen Wert auf, kann der Grund hierfür darin liegen, dass Sende- und Empfangsfunktionen auf dem gleichen Server ausgeführt werden. Ist dies der Fall, sollten Sie erwägen, die Sende- und Empfangsfunktionen auf verschiedene Server zu verschieben. | Alle
Prozessor | Prozessorzeit (%) | Wenn der Wert dieses Leistungsindikators hoch ist, während die Auslastung von Netzwerkadapterkarte und Datenträger-E/A deutlich unterhalb der Kapazitätsgrenze liegen, hat der Prozessor einen negativen Einfluss auf die Leistung. Überprüfen Sie diesen Leistungsindikator auf einem Computer mit mehreren Prozessoren, um ein eventuelles Ungleichgewicht festzustellen. Während die Spitzenauslastung 100 Prozent betragen kann, sollte die andauernde Auslastung unter diesem Wert liegen. Alle Serverelemente können horizontal skaliert werden. | Alle
Webdienst | GET-Anforderungen/s oder POST-Anforderungen/s | Gibt das Volumen der über die HTTP-Methoden get/post empfangenen Dateien an. | HTTP-Transportdienst

Es wurden keine Leistungsindikatoren speziell für den SMTP-Transportdienst aufgeführt, da für diesen Dienst eine Vielzahl von Produkten zur Verfügung steht. Unabhängig vom verwendeten SMTP-Transportdienst sollten Sie das Volumen der an und von BizTalk Server gesendeten Nachrichten überwachen. Durch die Überwachung der in der Tabelle aufgeführten Leistungsindikatoren können Sie Leistungseinbußen ermitteln. Da alle Komponenten zusammenarbeiten, um zu ermitteln, ob ein System fehlerfrei funktioniert, sollten Sie aufgrund schlechter Leistung einer Komponente keine grundlegenden Änderungen an der Systemkonfiguration vornehmen.

Die durch die Leistungsüberwachung gewonnenen Daten sind auch hilfreich bei der Feststellung von Symptomen, die möglicherweise zum Auftreten von Problemen beitragen. Beispielsweise kann eine hohe Datenträgeraktivität darauf hinweisen, dass SQL Server eine große Datenmenge auf den Datenträger schreibt. Sie kann jedoch auch anzeigen, dass das System häufig Daten auf die Festplatte auslagert. Werden übermäßig häufig Daten auf die Festplatte ausgelagert, ist dies normalerweise ein Anzeichen für zu geringen Arbeitsspeicher. In diesem Fall ist die Datenträgeraktivität ein Indikator für ein Problem, jedoch nicht das Problem selbst.

Verwandtes Thema

Skalieren von BizTalk Server


Verbessern der Architektur

Durch die Ermittlung von Bereichen, die sich negativ auf die Leistung auswirken, können Sie die Systemarchitektur verbessern, um optimale Ergebnisse zu erzielen. Beispielsweise muss möglicherweise die Hardware aktualisiert werden oder es ist unter Umständen erforderlich, verschiedene Komponenten von BizTalk Server auf separate Server zu verschieben. Weiterhin müssen Sie gegebenenfalls die BizTalk Server-Einstellungen anpassen. Weitere Informationen zum Anpassen von Einstellungen erhalten Sie unter Optimieren der Servereigenschaften.

Stellen Sie sicher, dass die Änderungen methodisch durchgeführt werden. Nachdem Sie eine Änderung vorgenommen haben (z. B. das Hinzufügen von CPUs, das Ändern einer Einstellung oder die Aufteilung von Funktionen auf separate Server), dokumentieren Sie die Änderung. Testen Sie dann die neue Konfiguration, um zu ermitteln, ob die Leistung gesteigert wurde. Wenn die neue Konfiguration die Leistung verbessert, können Sie mit der Änderung der Konfiguration fortfahren. Sinkt die Leistung jedoch, sollten Sie den früheren Zustand der Konfiguration wiederherstellen und die Daten analysieren, um zu ermitteln, welche Umstände möglicherweise zum Auftreten des Problems beitragen.

Verwandtes Thema

Auswerten der Leistung einer Konfiguration


Bereitstellen der Leistung

Erstellen Sie einen laufenden Wartungsplan, um die Fehlerfreiheit und zukünftige Leistung von BizTalk Server sicherzustellen. BizTalk Server verarbeitet im Laufe der Zeit wahrscheinlich eine wachsende Anzahl von Dokumenten. Wenngleich die anfängliche BizTalk Server-Architektur zunächst eine zufrieden stellende Leistung erbracht hat, kann sie möglicherweise nicht mehr die gleiche Leistung bereitstellen, wenn die Anzahl der Transaktionen im Laufe der Zeit angewachsen ist, es sei denn, die Systemarchitektur oder die Konfiguration wird geändert. Hardwarefehler oder Situationen, in denen nicht genügend Arbeitsspeicher vorhanden ist, können die Leistung eines Systems ebenfalls beeinträchtigen.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Erstellen eines Wartungsplanes zur Sicherstellung der Leistung

  • Verwenden von Application Center 2000


Erstellen eines Wartungsplanes zur Sicherstellung der Leistung

Ein erfolgreicher Überwachungsplan enthält folgende Komponenten und Aktionen:

  • Ein detaillierter Plan der zu überwachenden Leistungsindikatoren. Es gibt beispielsweise mehrere Leistungsindikatoren von Windows 2000-Systemmonitor, deren Schwellenwerte überwacht werden müssen, sowie verschiedene Interpretationen der Probleme, auf die die Schwellenwerte gegebenenfalls hinweisen. Darüber hinaus können Sie Probleme auf Anwendungsebene überwachen, z. B., ob SQL Server-Abfragen gültige Daten oder Hardwareproblembedingungen zurückgeben sollten.

  • Festlegen von Prozessen zur Lösung von Leistungsproblemen. Beispielsweise kann eine Meldung im Windows 2000-Ereignisprotokoll aufgezeichnet oder die E-Mail-Benachrichtigung aktiviert werden, oder ein benutzerdefiniertes Programm kann eine Reihe von Ereignissen starten.

  • Festlegen der Leistungsschwellenwerte, die eine Benachrichtigung generieren. Beispielsweise kann ein Überwachungstool so konfiguriert werden, dass ein Ereignis in das Windows 2000-Ereignisprotokoll geschrieben wird, wenn die CPU zu 90 Prozent ausgelastet ist. Bleibt die 90 prozentige CPU-Auslastung für mehr als 5 Minuten bestehen, wird eine E-Mail-Nachricht versendet. Wie verschiedene Aktionen für unterschiedliche Problemschweregrade festgelegt werden, richtet sich nach dem verwendeten Überwachungstool.

  • Definieren einer Aktion als Antwort auf in den Windows 2000-Ereignisprotokollen veröffentlichte Ereignisse. Windows 2000, BizTalk Server 2000, SQL Server und systemeigene Microsoft-Transportdienste, wie z. B. Message Queuing und HTTP schreiben Ereignisse in das Windows 2000-Ereignisprotokoll. Das Ereignisprotokoll enthält wichtige Informationen, die möglicherweise auf bevorstehende Probleme auf einem der Server in einem BizTalk Server-System hinweisen. Wenn Sie sich frühzeitig darum kümmern, können Sie einen Systemausfall vermeiden, der die Leistung des gesamten Systems beeinträchtigen würde. In dem Plan sollte auch festgelegt werden, wie häufig Protokolle überwacht und archiviert werden, und wer für die Tasks verantwortlich ist. Mithilfe eines Tools eines Drittanbieters können die Protokolle mehrerer Server zusammengefasst und für eine konsolidierte Analyse in einer Datenbank erfasst werden. Mit diesen Tools können die Protokolle auch von den Servern gelöscht werden.

  • Festlegen der erforderlichen Tools für die Leistungsüberwachung. Das integrierte Tool Windows 2000-Systemmonitor überprüft Leistungsindikatoren und kann Aktionen durchführen, wenn vordefinierte Bedingungen eintreten. Weitere Informationen zur Konfiguration von Warnungen in Systemmonitor erhalten Sie in der Windows 2000-Hilfe unter "Einrichten einer Überwachungskonfiguration". Weiterhin bieten Microsoft Application Center 2000 sowie eine Reihe von Tools von Drittanbietern zusätzliche Funktionen für die Leistungsüberwachung, wie z. B. die Protokollierung einer Datenbank und die Durchführung von Tests auf Anwendungsebene.


Verwenden von Application Center2000

BizTalk Server-Kopfzeile

Verwenden von Application Center 2000

Microsoft Application Center 2000 enthält ein Tool mit der Bezeichnung Health Monitor. Health Monitor bietet weitergehende Funktionen als das Windows 2000-Ereignisprotokoll und Systemmonitor. Dieses Tool ermöglicht Administratoren die Einrichtung von Monitoren. Mit diesen Monitoren werden TCP/IP, Schwellenwerte der Datenquellen von Systemmonitor, Ereignisprotokollfehler und WMI-Ereignisse überprüft. Für diese Monitore können Bedingungen festgelegt werden. Wenn bestimmte Kriterien erfüllt sind (z. B. wenn der Schwellenwert von 90 Prozent in einer CPU erreicht oder überschritten ist), wird eine bestimmte Aktion durchgeführt, wie z. B. das Versetzen eines Servers in den Offlinemodus oder das Versenden einer E-Mail-Nachricht an einen Administrator. Diese Tools können zur proaktiven Überwachung und Wartung von BizTalk Server 2000 verwendet werden.

Wichtig

  • Führen Sie keine Replikation der Standardanwendung XLANG-Ablaufplanung (XLANG Scheduler) oder beliebiger COM+-Anwendungen durch, die als Host für XLANG-Ablaufpläne dienen. Wird der Komponentenlastenausgleich (CLB, Component Load Balancing) verwendet, müssen diese COM+-Anwendungen auf jedem Server installiert werden. An XLANG-Ablaufpläne gebundene COM-Komponenten können repliziert werden.


Verwalten von Servern und Anwendungen

Mit den Verwaltungsfeatures, die mit der Microsoft BizTalk Server 2000-Hilfe bereitgestellt werden, können Sie alle Installationen von BizTalk Server effizient und effektiv verwalten. BizTalk Server 2000 verfügt über 4 Verwaltungsbereiche:

  • Serververwaltung

  • Anwendungsverwaltung

  • Programmgesteuerte Verwaltung

  • Datenbankverwaltung

Dieser Abschnitt behandelt die Serververwaltung und die programmgesteuerte Verwaltung. Weitere Informationen zu Anwendungen und zur Datenbankverwaltung finden Sie unter BizTalk Server-Verwaltungsmodell. Die Serververwaltung enthält das Konfigurieren und Verwalten von Servergruppen, Servern, Empfangsfunktionen und der gemeinsam genutzen Warteschlange für jede Servergruppe. Die Anwendungsverwaltung enthält das Konfigurieren und Verwalten von COM+-Anwendungen, die als Host für XLANG-Ablaufpläne, die Standardanwendung XLANG-Ablaufplanung (XLANG Scheduler) und die Persistenzdatenbank für die Orchestrierung dienen.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Serververwaltung

  • Programmgesteuerte Administration

Verwandtes Thema

BizTalk Server-Verwaltungsmodell


Serververwaltung

Die BizTalk Server-Verwaltung stellt eine zentrale Benutzeroberfläche (UI) bereit, von der aus Sie folgende Aufgaben durchführen können:

  • Hinzufügen und Verwalten von Servern, die mit Microsoft BizTalk Server 2000 in Servergruppen installiert wurden

  • Konfigurieren von Servergruppeneigenschaften, beispielsweise des Speicherortes der Datenbank für gemeinsam genutzte Warteschlangen und der Überwachungsdatenbank

  • Konfigurieren und Verwalten von Empfangsfunktionen

  • Anzeigen und Verwalten von Warteschlangen

Hilfe zu bestimmten Aufgaben finden Sie unter Verfahrensweise.

Allgemeine Hintergrundinformationen finden Sie unter Grundbegriffe.

Anleitungen zum Beheben von Problemen finden Sie unter Problembehandlung - BizTalk Server-Verwaltung.

Verwandtes Thema

BizTalk Server-Verwaltung - Umgebung


Verfahrensweise

Dieser Abschnitt stellt aufgabenspezifische Informationen zum Verwenden der BizTalk Server-Verwaltung bereit. Es wird dringend empfohlen, dass Sie den Abschnitt Grundbegriffe lesen, um alle Features und Funktionen der BizTalk Server-Verwaltung vollständig zu verstehen.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Öffnen der BizTalk Server-Verwaltung

  • Öffnen der Komponentendienste

  • Hinzufügen von Benutzern zur Gruppe "BizTalk Server-Administratoren"

  • Konfigurieren der BizTalk-Messaging-Verwaltungsdatenbank

  • Aktualisieren der Verwaltungskonsole

  • Starten des BizTalk-Messagingdienstes

  • Hinzufügen, Löschen und Konfigurieren einer Servergruppe

  • Hinzufügen, Löschen und Konfigurieren von Servern in einer Gruppe

  • Ausführen von Servern in einer Gruppe

  • Verwalten von Warteschlangen

  • Verwalten von Datenbanken für eine Servergruppe

  • Verwalten von Empfangsfunktionen für eine Servergruppe

  • Verwalten der Ereignisanzeige

  • Verwalten von XLANG-Anwendungen und -Datenbanken


Öffnen der BizTalk Server-Verwaltung

  • Zeigen Sie im Startmenü auf Programme, zeigen Sie auf Microsoft BizTalk Server 2000, und klicken Sie dann auf BizTalk Server-Verwaltung.


Öffnen der Komponentendienste

  • Zeigen Sie im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Komponentendienste.


Hinzufügen von Benutzern zur Gruppe "BizTalk Server-Administratoren"

Um Benutzer zur Gruppe BizTalk Server-Administratoren hinzuzufügen, müssen Sie Mitglied der Gruppe Windows 2000-Administratoren sein. Weitere Informationen zum Hinzufügen von Benutzern zur Gruppe Windows 2000-Administratoren finden Sie unter Hinzufügen eines Benutzerkontos zur Administratorengruppe.

  1. Zeigen Sie im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Computerverwaltung.

  2. Erweitern Sie System, erweitern Sie Lokale Benutzer und Gruppen, und klicken Sie dann auf den Ordner Gruppen.

    Der Inhalt des Ordners wird im Detailbereich angezeigt.

  3. Klicken Sie im Detailbereich auf BizTalk Server-Administratoren.

  4. Zeigen Sie im Menü Vorgang auf Alle Tasks, und klicken Sie dann auf Mitglied hinzufügen.

    Das Dialogfeld Eigenschaften von BizTalk Server-Administratoren wird angezeigt.

  5. Klicken Sie auf Hinzufügen.

  6. Klicken Sie in der Liste Suchen in auf Ihren Domänen- oder Computernamen.

  7. Klicken Sie in der Liste der Benutzer und Computer, die der in Schritt 6 ausgewählten Domäne bzw. dem ausgewählten Computer zugeordnet sind, auf das Benutzerkonto, das hinzugefügt werden soll. Klicken Sie auf Hinzufügen und dann auf OK.

  8. Klicken Sie auf OK, um das Dialogfeld Eigenschaften von BizTalk Server-Administratoren zu schließen.

Anmerkungen

  • Das beschriebene Verfahren basiert auf der Annahme, dass der Gruppenname der BizTalk Server-Verwaltung BizTalk Server-Administratoren lautet.

  • Melden Sie sich gegebenenfalls ab und dann unter Ihrem Benutzerkonto wieder an.

Verwandtes Thema

Administratorprivilegien


Konfigurieren der BizTalk-Messaging-Verwaltungsdatenbank

  1. Klicken Sie in der BizTalk Server-Verwaltung auf Microsoft BizTalk Server 2000.

  2. Klicken Sie im Menü Vorgang auf Eigenschaften.

    Das Dialogfeld Eigenschaften von Microsoft BizTalk Server 2000 wird angezeigt.

  3. Auf der Registerkarte Allgemein können Sie folgende Eigenschaften ändern:
    • Name der SQL-Datenbank. Geben Sie den Namen der BizTalk-Messaging-Verwaltungsdatenbank ein, die alle Servergruppen verwenden sollen.

    • Name des SQL-Servers. Geben Sie den Namen des Servers ein, auf dem die Microsoft SQL Server-Datenbank gespeichert ist, die wiederum die BizTalk Messaging-Verwaltungsdatenbank speichert.

    • Benutzername. Sie können den Benutzernamen für die Anmeldung bei SQL Server ändern, der zum Herstellen der Verbindung zum Server verwendet wird, auf dem die BizTalk-Messaging-Verwaltungsdatenbank gespeichert ist.

    • Kennwort. Sie können das Kennwort für die Anmeldung bei SQL Server ändern, das zum Herstellen der Verbindung zum Server verwendet wird, auf dem die BizTalk-Messaging-Verwaltungsdatenbank gespeichert ist.
  4. Klicken Sie auf OK.

Vorsicht

  • Sie können dieses Verfahren verwenden, wenn Sie die BizTalk-Messaging-Verwaltungsdatenbank für Wartungszwecke in den Offlinemodus versetzen müssen. Jedoch müssen Sie dabei auf eine replizierte Datenbank verweisen, nicht auf eine andere BizTalk-Messaging-Verwaltungsdatenbank, der andere Servergruppen zugeordnet sind. Weitere Informationen zum Ändern der Datenbank finden Sie unter Ändern der BizTalk-Messaging-Verwaltungsdatenbank.

Anmerkungen

  • Wenn Sie entweder die BizTalk-Messaging-Verwaltungsdatenbank ändern oder die Servergruppen auf einen anderen Microsoft SQL-Server verweisen, müssen Sie die folgenden Schritte ausführen:
    1. Beenden Sie alle Server im Knoten Microsoft BizTalk Server 2000. Weitere Informationen zum Beenden von Servern finden Sie unter Beenden eines Servers in einer Gruppe.

    2. Beenden Sie die BizTalk Server-Austauschanwendung (BizTalk Server Interchange Application). Weitere Informationen zum Beenden der BizTalk Server-Austauschanwendung (BizTalk Server Interchange Application) finden Sie unter Herunterfahren der BizTalk Server-Austauschanwendung (BizTalk Server Interchange Application).

    3. Starten Sie alle Server im Knoten Microsoft BizTalk Server 2000 erneut. Weitere Informationen zum erneuten Starten von Servern finden Sie unter Starten eines Servers in einer Gruppe.

    Wenn Sie die BizTalk-Messaging-Verwaltungsdatenbank ändern oder die Servergruppen auf einen anderen Microsoft SQL-Server verweisen, werden alle BizTalk-Server in der zentralen BizTalk-Messaging-Verwaltungsdatenbank mit den neuen Informationen aktualisiert.

  • Falls Sie die BizTalk-Messaging-Verwaltungsdatenbank des vorhandenen Servers ändern und dann den vorhandenen Server auf eine neue Gruppe verweisen, können Probleme beim Senden von Dokumenten an den vorhandenen Server auftreten. Fahren Sie alle Server im Knoten Microsoft BizTalk Server 2000 herunter, beenden Sie die BizTalk Server-Austauschanwendung (BizTalk Server Interchange Application), und starten Sie dann alle Server im Knoten Microsoft BizTalk Server 2000 erneut, um potenzielle Probleme zu vermeiden. Weitere Informationen zum Herunterfahren eines Servers finden Sie unter Beenden eines Servers in einer Gruppe. Weitere Informationen zum Beenden der BizTalk Server-Austauschanwendung (BizTalk Server Interchange Application) finden Sie unter Starten eines Servers in einer Gruppe. Weitere Informationen zum erneuten Starten von Servern finden Sie unter Starten eines Servers in einer Gruppe.

Verwandte Themen

Ändern der BizTalk-Messaging-Verwaltungsdatenbank

Herunterfahren der BizTalk Server-Austauschanwendung (BizTalk Server Interchange Application)

Starten eines Servers in einer Gruppe

Beenden eines Servers in einer Gruppe


Aktualisieren der Verwaltungskonsole

  1. Erweitern Sie in der BizTalk Server-Verwaltung Microsoft BizTalk Server 2000, und erweitern Sie dann die Elemente in der Konsolenstruktur, bis Sie das Element finden, das aktualisiert werden soll. Sie müssen eventuell die Servergruppen, Warteschlangen, Empfangsfunktionen und Server erweitern, um das betreffende Element zu finden.

  2. Klicken Sie auf das Element, das Sie aktualisieren möchten.

  3. Klicken Sie im Menü Vorgang auf Aktualisieren.

Anmerkungen

  • In der BizTalk Server-Verwaltung können Sie den Status folgender Elemente aktualisieren:
    • Knoten Microsoft BizTalk Server 2000

    • Servergruppen

    • Server

    • Warteschlangen

    • Empfangsfunktionen
  • Dieses Verfahren können Sie für jedes Element in der Konsolenstruktur ausführen. Wenn Sie die Verwaltungskonsole auf der Stammebene aktualisieren, werden alle Elemente in der Verwaltungskonsole aktualisiert. Aktualisieren Sie eine Servergruppe, werden nur die Elemente in dieser Gruppe aktualisiert.

  • Es gibt keinen automatischen Aktualisierungszyklus für die Verwaltungskonsole. Führen Sie dieses Verfahren aus, um den aktuellen Status von Servergruppen, Servern, Empfangsfunktionen, die Anzahl der Elemente in einer Warteschlange usw. anzuzeigen.

Verwandte Themen

Gruppen und Server

Empfangsfunktionen

Verwenden von Warteschlangen


Starten des BizTalk-Messagingdienstes

  1. Zeigen Sie im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Komponentendienste.

  2. Stellen Sie sicher, dass Dienste (Lokal) ausgewählt ist.

  3. Klicken Sie im Detailbereich auf BizTalk-Messagingdienst.

  4. Klicken Sie im Menü Vorgang auf Starten.


Hinzufügen, Löschen und Konfigurieren einer Servergruppe

Mithilfe folgender Verfahren können Sie eine Servergruppe hinzufügen, löschen oder konfigurieren:

  • Hinzufügen einer Servergruppe

  • Konfigurieren von allgemeinen Eigenschaften für eine Servergruppe

  • Konfigurieren von Verbindungseigenschaften für eine Servergruppe

  • Konfigurieren von Überwachungseigenschaften für eine Servergruppe

  • Konfigurieren der Parserreihenfolge für eine Servergruppe

  • Löschen einer Servergruppe


Hinzufügen einer Servergruppe

  1. Klicken Sie in der BizTalk Server-Verwaltung auf Microsoft BizTalk Server 2000.

  2. Zeigen Sie im Menü Vorgang auf Neu, und klicken Sie dann auf Gruppe.

    Das Dialogfeld Neue Gruppe wird angezeigt.

  3. Geben Sie im Feld Gruppenname den Namen der neuen Servergruppe ein.

  4. Im Bereich Überwachungsdatenbank:
    • Geben Sie im Feld Name der Überwachungsdatenbank den Namen der Überwachungsdatenbank für diese Servergruppe ein.

    • Geben Sie im Feld Name des SQL-Servers für die Überwachung den Namen des Servers ein, auf dem die Überwachungsdatenbank für diese Servergruppe gespeichert ist.

    • Geben Sie in den Feldern Benutzername und Kennwort den Benutzernamen und das Kennwort für die Anmeldung bei Microsoft SQL Server ein, die zum Herstellen der Verbindung zum Server verwendet werden, auf dem die Überwachungsdatenbank gespeichert ist.

      Benutzername ist ein erforderliches Feld. Kennwort ist ein optionales Feld. Wenn für die Verbindung zum Server kein Kennwort erforderlich ist, lassen Sie das Feld leer.

  5. Im Bereich Datenbank für gemeinsam genutzte Warteschlangen:
    • Geben Sie im Feld Name der Datenbank für gemeinsam genutzte Warteschlangen den Namen der Datenbank für gemeinsam genutzte Warteschlangen für diese Servergruppe ein.

    • Geben Sie im Feld Name des SQL-Servers für gemeinsam genutzte Warteschlangen den Namen des Servers ein, auf dem die Datenbank für gemeinsam genutzte Warteschlangen für diese Servergruppe gespeichert ist.

    • Geben Sie in den Feldern Benutzername und Kennwort den Benutzernamen und das Kennwort für die Anmeldung bei SQL Server ein, die zum Herstellen der Verbindung zum Server verwendet werden, auf dem die Datenbank für gemeinsam genutzte Warteschlangen gespeichert ist.

      Benutzername ist ein erforderliches Feld. Kennwort ist ein optionales Feld. Wenn für die Verbindung zum Server kein Kennwort erforderlich ist, lassen Sie das Feld leer.

  6. Klicken Sie auf OK.

Wichtig

  • Verwenden Sie keines der folgenden Zeichen in dem Namen der Servergruppe: ` ! @ # $ % ^ & * ( ) + = [ ] { } | \\ ;\" '< > , . ?. Weitere Informationen zu ungültigen Zeichen finden Sie unter WMI - Übersicht.

Anmerkung

  • Mit diesem Verfahren wird eine Servergruppe erstellt. Hinweise zum Konfigurieren der Servergruppe mit zusätzlichen Einstellungen finden Sie unter Konfigurieren von allgemeinen Eigenschaften für eine Servergruppe.

Verwandte Themen

Hinzufügen, Löschen und Konfigurieren von Servern in einer Gruppe

Konfigurieren von allgemeinen Eigenschaften für eine Servergruppe

Gruppen und Server

Verwalten der BizTalk-Messaging-Verwaltungsdatenbank

Datenbank für gemeinsam genutzte Warteschlangen

Überwachungsdatenbank

WMI - Übersicht


Konfigurieren von allgemeinen Eigenschaften für eine Servergruppe

  1. Erweitern Sie in der BizTalk Server-Verwaltung Microsoft BizTalk Server 2000, und klicken Sie dann auf die Servergruppe, die Sie konfigurieren möchten.

  2. Klicken Sie im Menü Vorgang auf Eigenschaften.

    Das Dialogfeld Eigenschaften von BizTalk Server-Gruppe wird angezeigt.

  3. Geben Sie im Feld SMTP-Host den Namen des SMTP-Hosts (Simple Mail Transfer Protocol) ein, den diese Servergruppe verwendet.

    Dieses Feld ist optional. Verwenden Sie diese Konfiguration, falls mit BizTalk Server Dokumente mithilfe von SMTP an Geschäftspartner oder an eine interne Anwendung gesendet werden sollen.

  4. Geben Sie im Feld Antwort-URL für Reliable Messaging den URL ein, den diese Servergruppe verwendet, um zuverlässige Messagingübermittlungsbestätigungen mithilfe eines der folgenden unterstützten Protokolle zu empfangen: Datei, Message Queuing, HTTP, HTTP/S oder SMTP.
    Transportprotokoll | Zu verwendendes Präfix
    Datei | file://
    Message Queuing | queue://Direct=OS:<servername>\<warteschlangenname>
    Hyper Text Transport Protocol (http) | http://
    Hyper Text Transport Protocol Secure (https) | https://
    SMTP | mailto:

    Falls Sie Message Queuing angeben, müssen Sie einen Formatnamen verwenden. Außerdem muss vor dem Formatnamen queue:// stehen. Weitere Informationen zu Formatnamen finden Sie unter Verfügbare Empfangsfunktionen.

  5. Klicken Sie in der Liste Aktualisierungsintervall für Messaging-Verwaltungsobjektcache (Sek.) auf die Anzahl der Sekunden zwischen Cacheaktualisierungen für diese Servergruppe.

    In der Standardeinstellung aktualisiert der Server diesen Cache alle 50 Sekunden.

  6. Aktivieren Sie im Bereich Proxyserver das Kontrollkästchen Proxyserver verwenden, falls Sie BizTalk Server für die Verbindung zum Internet über einen Proxyserver konfigurieren möchten.

    Geben Sie die Adresse und den Port des Proxyservers ein, der verwendet werden soll.

  7. Klicken Sie auf OK.

  8. Führen Sie die folgenden Aktionen nur dann aus, wenn Sie im Bereich Proxyserver Änderungen vorgenommen haben.
    • Beenden Sie alle Server in der Gruppe, für die Sie die allgemeinen Eigenschaften konfiguriert haben. Weitere Informationen zum Beenden eines Servers finden Sie unter Beenden eines Servers in einer Gruppe.

    • Starten Sie alle Server in der Gruppe, für die Sie die allgemeinen Eigenschaften konfiguriert haben. Weitere Informationen zum Starten eines Servers finden Sie unter Starten eines Servers in einer Gruppe.

Wichtig

  • Das Feld SMTP-Host ist optional. Sie müssen des Feld jedoch konfigurieren, wenn im BizTalk-Messaging-Manager SMTP als Transportdienst verwendet werden soll. Beispielsweise können Sie im BizTalk-Messaging-Manager SMTP nur dann als primären oder sekundären Transport auswählen, wenn Sie hier den SMTP-Host konfiguriert haben.

Anmerkungen

  • Reliable Messaging in BizTalk Server ist kompatibel mit BizTalk Framework 2.0. Weitere Informationen zu Reliable Messaging und BizTalk Framework 2.0 finden Sie in der Microsoft-Website (microsoft.com/biztalk/). Suchen Sie in der Website nach "BizTalk Framework 2.0".

  • Verwenden Sie beim Konfigurieren des Antwort-URL für Reliable Messaging eine Active Server Page (ASP) oder eine Nachrichtenwarteschlange mit einer Empfangsfunktion zur Überwachung. Falls Sie anfangs keine eigene ASP (Active Server Page) konfigurieren möchten, verwenden Sie die zum Lieferumfang von BizTalk Server gehörende Datei ReceiveStandard.asp. Sie finden diese ASP-Beispielseite unter \Programme\Microsoft BizTalk Server\SDK\Messagingbeispiele\Receive Scripts. Diese Seite dient dazu, Sendungen anzunehmen und an BizTalk Server zu übermitteln. Weitere Informationen zum Implementieren einer sicheren Site finden Sie in der MSDN Online Library-Website (msdn.microsoft.com/library/default.asp). Suchen Sie in der Website nach dem Artikel "Implementing a Secure Site with ASP".

  • Falls Sie im Feld Antwort-URL für Reliable Messaging zum URL localhost hinzufügen, ist die ordnungsgemäße Funktion der Empfangsfunktion nicht gewährleistet. Geben Sie in diesem Feld nicht localhost an.

  • Die Antwort auf eine HTTP-Sendung muss Text sein. Falls die Antwort Binärdaten erfordert, codieren Sie die Binärdaten mithilfe von MIME oder UUEncode.

Verwandte Themen

Verwaltungscache

Verfügbare Empfangsfunktionen

Starten eines Servers in einer Gruppe

Beenden eines Servers in einer Gruppe


Konfigurieren von Verbindungseigenschaften für eine Servergruppe

  1. Erweitern Sie in der BizTalk Server-Verwaltung Microsoft BizTalk Server 2000, und klicken Sie dann auf die Servergruppe, die Sie konfigurieren möchten.

  2. Klicken Sie im Menü Vorgang auf Eigenschaften.

    Das Dialogfeld Eigenschaften von BizTalk Server-Gruppe wird angezeigt.

  3. Klicken Sie auf die Registerkarte Verbindung.

  4. Im Bereich Überwachungsdatenbank:
    • Geben Sie im Feld Name der Überwachungsdatenbank den Namen der Überwachungsdatenbank ein, die diese Servergruppe verwenden soll.

    • Geben Sie im Feld Name des SQL-Servers für die Überwachung den Namen des Microsoft SQL-Servers ein, auf dem die Überwachungsdatenbank gespeichert ist, die diese Servergruppe verwenden soll.

    • Geben Sie in den Feldern Benutzername und Kennwort den Benutzernamen und das Kennwort für die Anmeldung bei Microsoft SQL Server ein, die zum Herstellen der Verbindung zum Server verwendet werden, auf dem die Überwachungsdatenbank gespeichert ist.
  5. Im Bereich Datenbank für gemeinsam genutzte Warteschlangen:
    • Geben Sie im Feld Name der Datenbank für gemeinsam genutzte Warteschlangen den Namen der Datenbank für gemeinsam genutzte Warteschlangen ein, die diese Servergruppe verwenden soll.

    • Geben Sie im Feld Name des SQL-Servers für gemeinsam genutzte Warteschlangen den Namen des Microsoft SQL-Servers ein, auf dem die Datenbank für gemeinsam genutzte Warteschlangen gespeichert ist, die diese Servergruppe verwenden soll.

    • Geben Sie in den Feldern Benutzername und Kennwort den Benutzernamen und das Kennwort für die Anmeldung bei SQL Server ein, die zum Herstellen der Verbindung zum Server verwendet werden, auf dem die Datenbank für gemeinsam genutzte Warteschlangen gespeichert ist.
  6. Klicken Sie auf OK.

Anmerkung

  • Falls Sie Änderungen in den Bereichen Überwachungsdatenbank oder Datenbank für gemeinsam genutzte Warteschlangen vornehmen, müssen Sie die folgenden Schritte ausführen:
    1. Beenden Sie alle Server im Knoten Microsoft BizTalk Server 2000. Weitere Informationen zum Beenden von Servern finden Sie unter Beenden eines Servers in einer Gruppe.

    2. Beenden Sie die BizTalk Server-Austauschanwendung (BizTalk Server Interchange Application). Weitere Informationen zum Beenden der BizTalk Server-Austauschanwendung finden Sie unter Shut down the BizTalk Server Interchange Application.

    3. Starten Sie alle Server im Knoten Microsoft BizTalk Server 2000 erneut. Weitere Informationen zum erneuten Starten von Servern finden Sie unter Starten eines Servers in einer Gruppe.
  • Falls Sie Werte im Bereich Überwachungsdatenbank ändern, müssen Sie die Verbindungszeichenfolge in der Datei Connection.vb entsprechend den neuen Angaben zur Überwachungsdatenbank ändern. Sie finden die Datei Connection.vb im Ordner \Programme\Microsoft BizTalk Server\BizTalkTracking\VBScripts. Die Initial Catalog-Eigenschaft in der Verbindungszeichenfolge enthält den Namen der Überwachungsdatenbank. Geben Sie in dieser Eigenschaft den Namen der aktuellen Überwachungsdatenbank an. Die Verbindungszeichenfolge in der Datei Connection.vb lautet:
    Const g_ConnectionString = "Provider=SQLOLEDB.1;Const g_ConnectionString = "Provider=SQLOLEDB.1;
Persist Security Info=False;User ID=dta_ui_login;
Password=;Initial Catalog=<datenbankname>;
Data Source=<servername>;Connect Timeout=15"

Verwandte Themen

Verfügbare Empfangsfunktionen

Gruppen und Server

Herunterfahren der BizTalk Server-Austauschanwendung (BizTalk Server Interchange Application)

Starten eines Servers in einer Gruppe

Beenden eines Servers in einer Gruppe


Konfigurieren von Überwachungseigenschaften für eine Servergruppe

  1. Erweitern Sie in der BizTalk Server-Verwaltung Microsoft BizTalk Server 2000, und klicken Sie dann auf die Servergruppe, die Sie konfigurieren möchten.

  2. Klicken Sie im Menü Vorgang auf Eigenschaften.

    Das Dialogfeld Eigenschaften von BizTalk Server-Gruppe wird angezeigt.

  3. Klicken Sie auf die Registerkarte Überwachen.

  4. Aktivieren Sie das Kontrollkästchen Dokumentüberwachung aktivieren sowie diejenigen der folgenden Optionen, die Sie verwenden möchten:
    • Aktivieren Sie das Kontrollkästchen Eingehenden Austausch protokollieren, wenn der eingehende Austausch protokolliert werden soll.

    • Aktivieren Sie das Kontrollkästchen Ausgehenden Austausch protokollieren, wenn der ausgehende Austausch protokolliert werden soll.

    • Aktivieren Sie das Kontrollkästchen Ursprüngliche MIME-codierte Nachricht protokollieren, wenn MIME-codierte Nachrichten protokolliert werden sollen.
  5. Klicken Sie auf OK.

Vorsicht

  • Sie können die Überwachung deaktivieren, indem Sie das Kontrollkästchen Dokumentüberwachung aktivieren deaktivieren. Bei deaktivierter Dokumentüberwachung stehen jedoch wichtige Funktionen von BizTalk Server 2000 nicht zur Verfügung. Weitere Informationen zur Überwachung finden Sie unter Grundlegendes zu den Überwachungseinstellungen einer Servergruppe.

Anmerkung

  • Wenn das Kontrollkästchen Dokumentüberwachung aktivieren deaktiviert ist, sind auch die Kontrollkästchen Eingehenden Austausch protokollieren, Ausgehenden Austausch protokollieren und Ursprüngliche MIME-codierte Nachricht protokollieren nicht verfügbar.

Verwandte Themen

Gruppen und Server

Grundlegendes zu den Überwachungseinstellungen einer Servergruppe


Konfigurieren der Parserreihenfolge für eine Servergruppe

  1. Erweitern Sie in der BizTalk Server-Verwaltung Microsoft BizTalk Server 2000, und klicken Sie dann auf die Servergruppe, für die Sie die Parserreihenfolge konfigurieren möchten.

  2. Klicken Sie im Menü Vorgang auf Eigenschaften.

    Das Dialogfeld Eigenschaften von BizTalk Server-Gruppe wird angezeigt.

  3. Klicken Sie auf die Registerkarte Parser.

    Die Parser werden im Feld Aufrufreihenfolge für Server anordnen in folgender Reihenfolge aufgeführt:

    • BizTalk.ParserXML.1

    • BizTalk.ParserEdifact.1

    • BizTalk.ParserX12.1

    • BizTalk.ParserFFile.1

Sie können die Leistung von BizTalk Server verbessern, indem Sie die am häufigsten verwendeten Parser an den Anfang der Liste verschieben.

  4. Klicken Sie im Feld Aufrufreihenfolge für Server anordnen auf den Parser, den Sie verschieben möchten, und klicken Sie dann entweder auf den Pfeil nach oben oder auf den Pfeil nach unten, um den ausgewählten Parser in der Aufrufreihenfolge für den Server nach oben oder nach unten zu verschieben.

  5. Wenn die Parser in der gewünschten Reihenfolge angeordnet sind, klicken Sie auf OK.

Anmerkung

  • Durch Klicken auf die Schaltfläche Aktualisieren werden Parser angezeigt, die in der lokalen Registrierung neu registriert sind. Damit ein neuer Parser im Feld Aufrufreihenfolge für Server anordnen angezeigt wird, müssen Sie bei demjenigen Server auf die Schaltfläche Aktualisieren klicken, auf dem der Parser registriert ist.

Verwandtes Thema

Using the IBizTalkParserComponent Interface


Löschen einer Servergruppe

  1. Erweitern Sie in der BizTalk Server-Verwaltung Microsoft BizTalk Server 2000, und klicken Sie dann auf die Servergruppe, die Sie löschen möchten.

  2. Klicken Sie auf einen Server in der Servergruppe, der gelöscht werden soll.

  3. Klicken Sie im Menü Vorgang auf Beenden.

    Wiederholen Sie die Schritte 2–3 für jeden Server in der Gruppe, bis Sie alle Server in der Gruppe beendet haben.

  4. Klicken Sie auf die Servergruppe.

  5. Klicken Sie im Menü Vorgang auf Löschen.

    Das Dialogfeld Benutzeraktionsbestätigung wird angezeigt.

  6. Klicken Sie auf Ja.

Anmerkungen

  • Servergruppen, die einen oder mehrere aktive Server enthalten, können nicht gelöscht werden. Sie müssen über Windows 2000-Administratorberechtigungen für alle Server der Gruppe verfügen, um die Server zu beenden und die Servergruppe zu löschen.

  • Die Überwachungsdatenbank und die Datenbank für gemeinsam genutzte Warteschlangen, die der jeweiligen Servergruppe zugeordnet sind, verbleiben auch nach dem Löschen der Gruppe in Microsoft SQL Server. Um die Überwachungsdatenbank und die Datenbank für gemeinsam genutzte Warteschlangen zu entfernen, müssen Sie sie manuell löschen. Weitere Informationen zum Löschen dieser Datenbanken finden Sie unter Entfernen der Überwachungsdatenbank und der Datenbanken für gemeinsam genutzte Warteschlangen.

Verwandte Themen

Gruppen und Server

Entfernen der Überwachungsdatenbank und der Datenbanken für gemeinsam genutzte Warteschlangen

Beenden eines Servers in einer Gruppe


Hinzufügen, Löschen und Konfigurieren von Servern in einer Gruppe

Die folgenden Verfahren werden verwendet, um Server in einer Gruppe hinzuzufügen, zu löschen und zu konfigurieren:

  • Hinzufügen eines Servers zu einer Gruppe

  • Löschen eines Servers aus einer Gruppe

  • Konfigurieren eines Servers in einer Gruppe

  • Ändern der BizTalk-Messaging-Verwaltungsdatenbank für einen Server


Hinzufügen eines Servers zu einer Gruppe

  1. Erweitern Sie in der BizTalk Server-Verwaltung Microsoft BizTalk Server 2000, und klicken Sie dann auf die Servergruppe, zu der Sie einen Server hinzufügen möchten.

  2. Zeigen Sie im Menü Vorgang auf Neu, und klicken Sie dann auf Server.

    Das Dialogfeld BizTalk-Server hinzufügen wird angezeigt.

  3. Geben Sie im Feld Name des BizTalk-Servers den Namen eines vorhandenen Servers ein, auf dem sich eine vollständige Installation von BizTalk Server 2000 befindet.

  4. Klicken Sie auf OK.

Anmerkung

  • Klicken Sie mit der rechten Maustaste auf die Gruppe, und klicken Sie dann auf Eigenschaften, um die globalen Eigenschaften für die Servergruppe anzuzeigen, zu der Sie den Server hinzugefügt haben.

Verwandte Themen

Gruppen und Server

Ausführen von Servern in einer Gruppe

Grundlegendes zu Servereigenschaften


Löschen eines Servers aus einer Gruppe

  1. Erweitern Sie in der BizTalk Server-Verwaltung Microsoft BizTalk Server 2000, erweitern Sie die Servergruppe des Servers, den Sie löschen möchten, und klicken Sie dann auf den Server.

  2. Klicken Sie im Menü Vorgang auf Beenden.

    Der Server beendet die Verarbeitung aller aktuellen Austauschvorgänge und Dokumente.

  3. Klicken Sie im Menü Vorgang auf Löschen.

    Das Dialogfeld Benutzeraktionsbestätigung wird angezeigt.

  4. Klicken Sie auf Ja.

Anmerkung

  • Ein Server kann nicht aus einer Servergruppe gelöscht werden, wenn mindestens eine Empfangsfunktion zur Verarbeitung von Dokumenten auf ihn verweist. Sie können die Empfangsfunktion(en) dahin gehend ändern, dass sie auf andere Server verweisen, oder Sie können die Empfangsfunktion(en) löschen, falls sie nicht mehr verwendbar sind.

Verwandte Themen

Freigeben von Austauschvorgängen auf einem Server

Gruppen und Server

Verwalten von Empfangsfunktionen für eine Servergruppe

Ausführen von Servern in einer Gruppe


Konfigurieren eines Servers in einer Gruppe

  1. Erweitern Sie in der BizTalk Server-Verwaltung Microsoft BizTalk Server 2000, erweitern Sie die Servergruppe des Servers, den Sie konfigurieren möchten, und klicken Sie dann auf den Server.

  2. Klicken Sie im Menü Vorgang auf Beenden.

    Serverkonfigurationseinstellungen können nicht geändert werden, während der Server ausgeführt wird.

  3. Klicken Sie im Menü Vorgang auf Eigenschaften.

    Das Dialogfeld Eigenschaften von <Computername> wird angezeigt.

  4. Geben Sie im Feld Maximale Anzahl von Empfangsfunktionsthreads eine Zahl zwischen 1 und 128 ein.

    Der Standardwert ist 4. Weitere Informationen zum Konfigurieren dieser Option finden Sie unter Grundlegendes zu Servereigenschaften.

  5. Falls der Server Objekte in der Arbeitswarteschlange verarbeiten soll, aktivieren Sie das Kontrollkästchen An Arbeitsobjektverwaltung teilnehmen.

    Wenn dieses Kontrollkästchen aktiviert ist, verarbeitet der Server Dokumente in der Arbeitswarteschlange. Deaktivieren Sie dieses Kontrollkästchen, wenn der Server keine Dokumente in der Arbeitswarteschlange verarbeiten soll. Weitere Informationen zum Konfigurieren dieser Option finden Sie unter Grundlegendes zu Servereigenschaften.

  6. Geben Sie im Feld Maximale Anzahl von Arbeitsthreads pro Prozessor eine Zahl zwischen 1 und 128 ein.

    Der Standardwert ist 4. Weitere Informationen zum Konfigurieren dieser Option finden Sie unter Grundlegendes zu Servereigenschaften.

  7. Geben Sie im Feld Zeitraum zwischen Aufrufen der BizTalk Server-Ablaufplanung (ms) eine Zahl zwischen 1 und 4.294.967.295 ein.

    Der Standardwert ist 200. Weitere Informationen zum Konfigurieren dieser Option finden Sie unter Grundlegendes zu Servereigenschaften.

  8. Klicken Sie auf OK.

  9. Klicken Sie mit der rechten Maustaste auf den Server, den Sie konfiguriert haben, und klicken Sie dann auf Starten.

Anmerkung

  • Wenn das Kontrollkästchen An Arbeitsobjektverwaltung teilnehmen deaktiviert ist, sind auch die Kontrollkästchen Maximale Anzahl von Arbeitsthreads pro Prozessor und Zeitraum zwischen Aufrufen der BizTalk Server-Ablaufplanung (ms) nicht verfügbar.

Verwandte Themen

Gruppen und Server

Ausführen von Servern in einer Gruppe

Grundlegendes zu Servereigenschaften


Ändern der BizTalk-Messaging-Verwaltungsdatenbank für einen Server

  1. Erweitern Sie in der BizTalk Server-Verwaltung Microsoft BizTalk Server 2000, erweitern Sie die Servergruppe des Servers, für den Sie die BizTalk-Messaging-Verwaltungsdatenbank ändern möchten, und klicken Sie dann auf den Server.

  2. Klicken Sie im Menü Vorgang auf Beenden.

  3. Klicken Sie im Menü Vorgang auf Löschen.

    Das Dialogfeld Benutzeraktionsbestätigung wird angezeigt.

  4. Klicken Sie auf Ja.

  5. Schließen Sie die BizTalk Server-Verwaltung.

  6. Zeigen Sie im Startmenü auf Programme, zeigen Sie auf Zubehör, und klicken Sie dann auf Windows-Explorer.

  7. Suchen Sie den Ordner \Programme\Microsoft BizTalk Server\Setup.

  8. Klicken Sie auf BTSsetupDB.exe.

  9. Klicken Sie im Menü Datei auf Öffnen.

    Der Microsoft BizTalk Server 2000-Datenbankeinrichtungs-Assistent wird geöffnet.

  10. Klicken Sie auf der Seite Willkommen beim Einrichtungs-Assistenten für BizTalk Server 2000-Datenbanken auf Weiter.

  11. Klicken Sie auf der Seite BizTalk-Messaging-Verwaltungsdatenbank konfigurieren auf Neue BizTalk-Messaging-Verwaltungsdatenbank erstellen.

    Oder

    Klicken Sie auf Vorhandene Datenbank auswählen.

  12. Klicken Sie im Feld Servername auf den Namen des Servers, auf dem die neue BizTalk-Messaging-Verwaltungsdatenbank gespeichert werden soll bzw. auf dem sich die vorhandene Verwaltungsdatenbank befindet.

  13. Falls erforderlich, geben Sie in den Feldern Benutzername und Kennwort einen gültigen Benutzernamen und ein gültiges Kennwort für den Zugriff auf den SQL-Server ein.

  14. Geben Sie im Feld Datenbank den Namen der neuen oder vorhandenen BizTalk-Messaging-Verwaltungsdatenbank ein.

  15. Klicken Sie auf Weiter.

  16. Klicken Sie auf der Seite BizTalk Server-Gruppe konfigurieren auf Neue BizTalk Server-Gruppe erstellen. Geben Sie im Feld Gruppenname den Namen der neuen Gruppe ein, und klicken Sie dann auf Weiter.

    Oder

    Klicken Sie auf Vorhandene BizTalk Server-Gruppe auswählen. Klicken Sie in der Liste Gruppenname auf den Namen der vorhandenen Gruppe, und klicken Sie dann auf Weiter.

    Sie können nur dann eine vorhandene BizTalk Server-Gruppe auswählen, wenn Sie in Schritt 11 eine vorhandene Datenbank ausgewählt haben.

  17. Klicken Sie gegebenenfalls auf Neue Überwachungsdatenbank erstellen, und klicken Sie dann auf Weiter.

    Oder

    Klicken Sie auf Vorhandene Datenbank auswählen. Klicken Sie in der Liste Servername auf einen Server. Falls erforderlich, geben Sie in den Feldern Benutzername und Kennwort einen gültigen Benutzernamen und ein gültiges Kennwort für Microsoft SQL Server ein. Geben Sie im Feld Datenbank den Namen der Datenbank ein. Klicken Sie auf Weiter.

  18. Klicken Sie gegebenenfalls auf Neue Datenbank für gemeinsam genutzte Warteschlangen erstellen, und klicken Sie dann auf Weiter.

    Oder

    Klicken Sie auf Vorhandene Datenbank auswählen. Klicken Sie in der Liste Servername auf einen Server. Falls erforderlich, geben Sie in den Feldern Benutzername und Kennwort einen gültigen Benutzernamen und ein gültiges Kennwort für SQL Server ein. Geben Sie im Feld Datenbank den Namen der Datenbank ein. Klicken Sie auf Weiter.

  19. Überprüfen Sie auf der Seite BizTalk Server-Gruppe überprüfen die eingegebenen Informationen, und klicken Sie dann auf Weiter.

  20. Klicken Sie auf der Seite Der Einrichtungs-Assistent für BizTalk Server 2000-Messagingdatenbanken wird abgeschlossen auf Fertig stellen.

  21. Öffnen Sie die BizTalk Server-Verwaltung.

  22. Erweitern Sie Microsoft BizTalk Server 2000, erweitern Sie die Servergruppe des Servers, für den Sie soeben die BizTalk-Messaging-Verwaltungsdatenbank geändert haben, und klicken Sie dann auf den Server.

  23. Klicken Sie im Menü Vorgang auf Starten.

Wichtig

  • Verwenden Sie dieses Verfahren, um einen Server einer anderen BizTalk-Messaging-Verwaltungsdatenbank zuzuordnen. Weitere Informationen zum Verschieben von Servern zwischen BizTalk-Messaging-Verwaltungsdatenbanken finden Sie unter Verschieben von Servern zwischen BizTalk-Messaging-Verwaltungsdatenbanken. Weitere Informationen zum Ändern der BizTalk-Messaging-Verwaltungsdatenbank für Servergruppen finden Sie unter Ändern der BizTalk-Messaging-Verwaltungsdatenbank.

Verwandte Themen

Ändern der BizTalk-Messaging-Verwaltungsdatenbank

Verwalten von BizTalk Server-Datenbanken

Verschieben von Servern zwischen BizTalk-Messaging-Verwaltungsdatenbanken


Ausführen von Servern in einer Gruppe

Die folgenden Verfahren werden verwendet, um Server innerhalb einer Gruppe auszuführen:

  • Starten eines Servers in einer Gruppe

  • Beenden eines Servers in einer Gruppe

  • Freigeben von Austauschvorgängen auf einem Server


Starten eines Servers in einer Gruppe

  1. Erweitern Sie in der BizTalk Server-Verwaltung Microsoft BizTalk Server 2000, erweitern Sie die Servergruppe des Servers, den Sie starten möchten, und klicken Sie dann auf den Server.

  2. Klicken Sie im Menü Vorgang auf Starten.

Anmerkungen

  • Das Starten eines Servers in einer Servergruppe bewirkt, dass der BizTalk-Messagingdienst auf diesem Server gestartet wird. Wenn der BizTalk-Messagingdienst ausgeführt wird, kann der Server Dokumente, die sich in der Warteschlange für Microsoft SQL Server-Datenbanken befinden, empfangen, übertragen, verarbeiten und überwachen.

  • Die Option Starten steht nur zur Verfügung, wenn der Server beendet wurde. Während der Server ausgeführt wird, ist der Befehl nicht verfügbar.

Verwandte Themen

Hinzufügen, Löschen und Konfigurieren von Servern in einer Gruppe

Verwaltungscache

Gruppen und Server

Beenden eines Servers in einer Gruppe


Beenden eines Servers in einer Gruppe

  1. Erweitern Sie in der BizTalk Server-Verwaltung Microsoft BizTalk Server 2000, erweitern Sie die Servergruppe des Servers, den Sie beenden möchten, und klicken Sie dann auf den Server.

  2. Klicken Sie im Menü Vorgang auf Beenden.

Anmerkungen

  • Das Beenden eines Servers in einer Servergruppe bewirkt, dass der BizTalk-Messagingdienst auf diesem Server beendet wird. Nachdem der BizTalk-Messagingdienst beendet wurde, kann der Server Dokumente, die sich in der Warteschlange für Microsoft SQL Server-Datenbanken befinden, nicht mehr empfangen, übertragen, verarbeiten und überwachen.

  • Informationen zum Weitervertreiben von Austauschvorgängen, die einem von Ihnen beendeten Server zugeordnet sind, finden Sie unter Freigeben von Austauschvorgängen auf einem Server.

Verwandte Themen

Hinzufügen, Löschen und Konfigurieren von Servern in einer Gruppe

Verwaltungscache

Freigeben von Austauschvorgängen auf einem Server

Gruppen und Server


Freigeben von Austauschvorgängen auf einem Server

Dieses Verfahren wird verwendet, um Austauschvorgänge auf einem Server freizugeben, damit die Austauschvorgänge zu anderen Servern in der Gruppe weitervertrieben werden können, wenn der ursprüngliche Server beendet oder in den Offlinemodus versetzt wurde.

  1. Erweitern Sie in der BizTalk Server-Verwaltung Microsoft BizTalk Server 2000, erweitern Sie die Servergruppe des Servers, auf dem Sie Austauschvorgänge freigeben möchten, und klicken Sie dann auf den Server.

  2. Klicken Sie im Menü Vorgang auf Beenden.

  3. Zeigen Sie im Menü Vorgang auf Alle Tasks, und klicken Sie dann auf Austauschvorgänge freigeben.

Verwandte Themen

Hinzufügen, Löschen und Konfigurieren von Servern in einer Gruppe

Gruppen und Server

Beenden eines Servers in einer Gruppe


Verwalten von Warteschlangen

Folgende Verfahren werden in diesem Thema behandelt:

  • Verschieben von Dokumenten in die Angehalten-Warteschlange

  • Anzeigen von Fehlerbeschreibungen

  • Anzeigen von Austauschvorgängen

  • Anzeigen von Dokumenten

  • Erneutes Senden von Dokumenten

  • Löschen von Dokumenten


Verschieben von Dokumenten in die Angehalten-Warteschlange

  1. Erweitern Sie in der BizTalk Server-Verwaltung Microsoft BizTalk Server 2000, erweitern Sie dann die Gruppe mit dem Dokument, das Sie verschieben möchten, und erweitern Sie anschließend Warteschlangen.

  2. Erweitern Sie die Gruppe, die das zu verschiebende Dokument enthält, und klicken Sie dann auf das Dokument.

  3. Zeigen Sie im Menü Vorgang auf Alle Tasks, und klicken Sie dann auf In Angehalten-Warteschlange verschieben.

Verwandte Themen

Angehalten-Warteschlange

Verwenden von Warteschlangen


Anzeigen von Fehlerbeschreibungen

  1. Erweitern Sie in der BizTalk Server-Verwaltung Microsoft BizTalk Server 2000, und erweitern Sie die Gruppe, die das Dokument enthält, das Sie anzeigen möchten. Erweitern Sie Warteschlangen, und klicken Sie dann auf Angehalten-Warteschlange.

  2. Klicken Sie im Detailbereich auf das Dokument, das angezeigt werden soll.

  3. Klicken Sie im Menü Vorgang auf Fehlerbeschreibung anzeigen.

Verwandte Themen

Angehalten-Warteschlange

Verwenden von Warteschlangen

Anzeigen von Dokumenten

Anzeigen von Austauschvorgängen


Anzeigen von Austauschvorgängen

  1. Erweitern Sie in der BizTalk Server-Verwaltung Microsoft BizTalk Server 2000, und erweitern Sie die Gruppe, die den Austausch enthält, den Sie anzeigen möchten. Erweitern Sie Warteschlangen, und klicken Sie dann auf Angehalten-Warteschlange.

  2. Klicken Sie im Detailbereich auf den Austausch, der angezeigt werden soll.

  3. Klicken Sie im Menü Vorgang auf Austausch anzeigen.

    Das Dialogfeld Dokumentinhalt wird angezeigt.

Anmerkungen

  • Wenn Sie einen sehr umfangreichen Austausch anzeigen, werden eventuell Daten abgeschnitten. Im Dialogfeld Dokumentinhalt können bis zu 4 MB Daten angezeigt werden.

  • Falls BizTalk Server den Austausch nicht analysieren konnte, werden im Dialogfeld Dokumentinhalt unter Umständen Binärdaten angezeigt. Weitere Informationen zu Parserfehlern finden Sie unter Analysefehler.

  • Die Menüoption Austausch anzeigen ist bei folgenden Zuständen der Angehalten-Warteschlange verfügbar:
    • Benutzerdefinierte Komponente

    • Analysiert

    • Codierung

    • Signiert

    • Verschlüsselt

    • Überträgt
  • Die Optionen Austausch anzeigen und Dokument anzeigen werden im Menü Vorgang niemals gleichzeitig angezeigt.

Verwandte Themen

Ein Austausch oder Dokument wird in der Angehalten-Warteschlange als Binärdaten angezeigt

Angehalten-Warteschlange

Verwenden von Warteschlangen

Anzeigen von Dokumenten

Anzeigen von Fehlerbeschreibungen


Anzeigen von Dokumenten

  1. Erweitern Sie in der BizTalk Server-Verwaltung Microsoft BizTalk Server 2000, und erweitern Sie die Gruppe, die das Dokument enthält, das Sie anzeigen möchten. Erweitern Sie Warteschlangen, und klicken Sie dann auf Angehalten-Warteschlange.

  2. Klicken Sie im Detailbereich auf das Dokument, das angezeigt werden soll.

  3. Klicken Sie im Menü Vorgang auf Dokument anzeigen.

    Das Dialogfeld Dokumentinhalt wird angezeigt.

Anmerkungen

  • Wenn Sie einen sehr umfangreiches Dokument anzeigen, werden eventuell Daten abgeschnitten. Im Dialogfeld Dokumentinhalt können bis zu 4 MB Daten angezeigt werden.

  • Die Menüoption Dokument anzeigen ist bei folgenden Zuständen der Angehalten-Warteschlange verfügbar:
    • Dokumentüberprüfung

    • Kanalauswahl

    • Zuordnung

    • Korreliert

    • Serialisiert
  • Die Optionen Austausch anzeigen und Dokument anzeigen werden im Menü Vorgang niemals gleichzeitig angezeigt.

Verwandte Themen

Ein Austausch oder Dokument wird in der Angehalten-Warteschlange als Binärdaten angezeigt

Angehalten-Warteschlange

Verwenden von Warteschlangen

Anzeigen von Fehlerbeschreibungen

Anzeigen von Austauschvorgängen


Erneutes Senden von Dokumenten

  1. Erweitern Sie in der BizTalk Server-Verwaltung Microsoft BizTalk Server 2000, und erweitern Sie die Gruppe, die das Dokument enthält, das Sie erneut senden möchten. Erweitern Sie Warteschlangen, und klicken Sie dann auf Angehalten-Warteschlange.

  2. Klicken Sie im Detailbereich auf das Dokument, das erneut gesendet werden soll.

  3. Zeigen Sie im Menü Vorgang auf Alle Tasks, und klicken Sie dann auf Erneut senden.

Anmerkungen

  • Dieses Verfahren zum erneuten Senden von Dokumenten kann auch zum erneuten Übertragen von Dokumenten verwendet werden.

  • Nicht alle Dokumente in der Angehalten-Warteschlange können erneut gesendet werden. In manchen Situationen muss das Dokument gelöscht und nochmals von der ursprünglichen Anwendung oder Organisation aus gesendet werden. Weitere Informationen zu Dokumenten in der Angehalten-Warteschlange finden Sie unter Angehalten-Warteschlange.

Verwandte Themen

Angehalten-Warteschlange

Verwenden von Warteschlangen


Löschen von Dokumenten

  1. Erweitern Sie in der BizTalk Server-Verwaltung Microsoft BizTalk Server 2000, und erweitern Sie die Gruppe, die das Dokument enthält, das Sie löschen möchten. Erweitern Sie Warteschlangen, und klicken Sie dann auf Angehalten-Warteschlange.

  2. Klicken Sie im Detailbereich auf das Dokument, das gelöscht werden soll.

  3. Klicken Sie im Menü Vorgang auf Löschen.

    Das Dialogfeld Benutzeraktionsbestätigung wird angezeigt.

  4. Klicken Sie auf Ja.

Verwandte Themen

Angehalten-Warteschlange

Verwenden von Warteschlangen


Verwalten von Datenbanken für eine Servergruppe

Die folgenden Verfahren werden verwendet, um Datenbanken für Servergruppen zu verwalten:

  • Herunterfahren der BizTalk Server-Austauschanwendung (BizTalk Server Interchange Application)

  • Entfernen der Überwachungsdatenbank und der Datenbanken für gemeinsam genutzte Warteschlangen

  • Manuelles Wiederherstellen der Überwachungsdatenbank

  • Manuelles Wiederherstellen der Datenbank für gemeinsam genutzte Warteschlangen


Herunterfahren der BizTalk Server-Austauschanwendung (BizTalk Server Interchange Application)

BizTalk Server-Kopfzeile

Herunterfahren der BizTalk Server-Austauschanwendung (BizTalk Server Interchange Application

  1. Zeigen Sie im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Komponentendienste.

  2. Erweitern Sie Komponentendienste, erweitern Sie Computer, dann Arbeitsplatz und anschließend COM+-Anwendungen.

  3. Klicken Sie auf BizTalk Interchange Application.

  4. Klicken Sie im Menü Vorgang auf Herunterfahren.

Anmerkung

  • Sie können die BizTalk Server-Austauschanwendung (Interchange Application) auch von einem Remoteserver aus herunterfahren. Erweitern Sie in diesem Fall in Schritt 1 <remotecomputername> anstelle von Arbeitsplatz.

Verwandte Themen

Verwaltungscache

Konfigurieren von Verbindungseigenschaften für eine Servergruppe

Konfigurieren von Überwachungseigenschaften für eine Servergruppe

Gruppen und Server

Öffnen der Komponentendienste

Überwachungsdatenbank


Entfernen der Überwachungsdatenbank und der Datenbanken für gemeinsam genutzte Warteschlangen

  1. Zeigen Sie im Startmenü auf Programme, zeigen Sie auf Microsoft SQL Server, und klicken Sie dann auf Enterprise Manager.

  2. Erweitern Sie Microsoft SQL Server, erweitern Sie SQL Server-Gruppe und dann den jeweiligen Server mit den Datenbanken, die gelöscht werden sollen.

  3. Erweitern Sie den Ordner Datenbanken, und klicken Sie dann auf die Datenbank, die Sie löschen möchten.

  4. Klicken Sie im Menü Vorgang auf Löschen.

    Das Dialogfeld Datenbank löschen wird angezeigt.

  5. Klicken Sie auf Ja.

Anmerkung

  • Der Standardname für die Überwachungsdatenbank lautet InterchangeDTA. Der Standardname für die Datenbank für gemeinsam genutzte Warteschlangen lautet InterchangeSQ.

Verwandte Themen

Gruppen und Server

Datenbank für gemeinsam genutzte Warteschlangen

Beenden eines Servers in einer Gruppe

Überwachungsdatenbank


Manuelles Wiederherstellen der Überwachungsdatenbank

  1. Zeigen Sie im Startmenü auf Programme, zeigen Sie auf Microsoft SQL Server, und klicken Sie dann auf Enterprise Manager.

  2. Erweitern Sie Microsoft SQL Server, erweitern Sie SQL Server-Gruppe und dann den Server, auf dem Sie die Datenbank wiederherstellen möchten.

  3. Klicken Sie auf Datenbanken.

  4. Klicken Sie im Menü Vorgang auf Neue Datenbank.

    Das Dialogfeld Datenbankeigenschaften wird angezeigt.

  5. Geben Sie auf der Registerkarte Allgemein im Feld Name einen Namen für die Überwachungsdatenbank ein, und klicken Sie dann auf OK.

  6. Zeigen Sie im Startmenü auf Programme, zeigen Sie auf Microsoft SQL Server, und klicken Sie dann auf Query Analyzer.

    Das Dialogfeld Verbindung mit SQL Server herstellen wird angezeigt.

  7. Klicken Sie auf OK.

  8. Falls Sie Microsoft SQL Server 7.0 verwenden, klicken Sie im Fenster Abfrage in der Liste DB auf den Namen der neuen Überwachungsdatenbank.

    Oder

    Falls Sie Microsoft SQL Server 2000 verwenden, klicken Sie auf der Registerkarte Objekte auf den Namen der neuen Überwachungsdatenbank.

  9. Klicken Sie auf die Schaltfläche SQL-Skript laden SQL-Skript laden .

  10. Suchen Sie den Ordner \Programme\Microsoft BizTalk Server\Setup.

  11. Klicken Sie auf BTS_Tracking_Schema.sql und dann auf Öffnen.

  12. Klicken Sie auf die Schaltfläche Abfrage ausführen.

  13. Klicken Sie auf die Schaltfläche SQL-Skript laden.

  14. Überprüfen Sie, ob Sie sich im Ordner \Programme\Microsoft BizTalk Server\Setup befinden.

  15. Klicken Sie auf BTS_Reporting.sql und dann auf Öffnen.

  16. Klicken Sie auf die Schaltfläche Abfrage ausführen.

  17. Klicken Sie auf die Schaltfläche SQL-Skript laden.

  18. Überprüfen Sie, ob Sie sich im Ordner \Programme\Microsoft BizTalk Server\Setup befinden.

  19. Klicken Sie auf BTS_Tracking_Logic.sql und dann auf Öffnen.

  20. Klicken Sie auf die Schaltfläche Abfrage ausführen.

  21. Klicken Sie auf die Schaltfläche SQL-Skript laden.

  22. Überprüfen Sie, ob Sie sich im Ordner \Programme\Microsoft BizTalk Server\Setup befinden.

  23. Klicken Sie auf BTS_WorkflowEvents.sql und dann auf Öffnen.

  24. Klicken Sie auf die Schaltfläche Abfrage ausführen.

  25. Klicken Sie auf die Schaltfläche SQL-Skript laden.

  26. Überprüfen Sie, ob Sie sich im Ordner \Programme\Microsoft BizTalk Server\Setup befinden.

  27. Klicken Sie auf BTS_WorkflowSchema.sql und dann auf Öffnen.

  28. Klicken Sie auf die Schaltfläche Abfrage ausführen.

  29. Schließen Sie SQL Query Analyzer und SQL Server Enterprise Manager.

Vorsicht

  • Beim manuellen Wiederherstellen der Überwachungsdatenbank gehen alle Daten verloren. Wenn Sie diese Daten noch benötigen, sichern Sie die Daten vor dem Wiederherstellen der Überwachungsdatenbank.

Anmerkung

  • Verwenden Sie dieses Verfahren, wenn die Überwachungsdatenbank fehlerhaft oder beschädigt ist.

Verwandtes Thema

Manuelles Wiederherstellen der Datenbank für gemeinsam genutzte Warteschlangen


Manuelles Wiederherstellen der Datenbank für gemeinsam genutzte Warteschlangen

  1. Zeigen Sie im Startmenü auf Programme, zeigen Sie auf Microsoft SQL Server, und klicken Sie dann auf Enterprise Manager.

  2. Erweitern Sie Microsoft SQL Server, erweitern Sie SQL Server-Gruppe und dann den Server, auf dem Sie die Datenbank wiederherstellen möchten.

  3. Klicken Sie auf Datenbanken.

  4. Klicken Sie im Menü Vorgang auf Neue Datenbank.

    Das Dialogfeld Datenbankeigenschaften wird angezeigt.

  5. Geben Sie auf der Registerkarte Allgemein im Feld Name einen Namen für die Datenbank für gemeinsam genutzte Warteschlangen ein, und klicken Sie dann auf OK.

  6. Zeigen Sie im Startmenü auf Programme, zeigen Sie auf Microsoft SQL Server, und klicken Sie dann auf Query Analyzer.

    Das Dialogfeld Verbindung mit SQL Server herstellen wird angezeigt.

  7. Klicken Sie auf OK.

  8. Falls Sie Microsoft SQL Server 7.0 verwenden, klicken Sie im Fenster Abfrage in der Liste DB auf den Namen der neuen Datenbank für gemeinsam genutzte Warteschlangen.

    Oder

    Falls Sie Microsoft SQL Server 2000 verwenden, klicken Sie auf der Registerkarte Objekte auf den Namen der neuen Datenbank für gemeinsam genutzte Warteschlangen.

  9. Klicken Sie auf die Schaltfläche SQL-Skript laden SQL-Skript laden .

  10. Suchen Sie den Ordner \Programme\Microsoft BizTalk Server\Setup.

  11. Klicken Sie auf BTS_Core_Schema.sql und dann auf Öffnen.

  12. Klicken Sie auf die Schaltfläche Abfrage ausführen.

  13. Klicken Sie auf die Schaltfläche SQL-Skript laden.

  14. Überprüfen Sie, ob Sie sich im Ordner \Programme\Microsoft BizTalk Server\Setup befinden.

  15. Klicken Sie auf BTS_Core_Logic.sql und dann auf Öffnen.

  16. Klicken Sie auf die Schaltfläche Abfrage ausführen.

  17. Schließen Sie SQL Query Analyzer und SQL Server Enterprise Manager.

Vorsicht

  • Beim manuellen Wiederherstellen der Datenbank für gemeinsam genutzte Warteschlangen gehen alle Daten verloren. Wenn Sie diese Daten noch benötigen, sichern Sie die Daten vor dem Wiederherstellen der Datenbank für gemeinsam genutzte Warteschlangen.

Anmerkung

  • Verwenden Sie dieses Verfahren, wenn die Datenbank für gemeinsam genutzte Warteschlangen fehlerhaft oder beschädigt ist.

Verwandtes Thema

Manuelles Wiederherstellen der Überwachungsdatenbank


Verwalten von Empfangsfunktionen für eine Servergruppe

Die folgenden Verfahren werden verwendet, um Empfangsfunktionen für Servergruppen zu verwalten:

  • Hinzufügen einer Dateiempfangsfunktion

  • Konfigurieren einer Dateiempfangsfunktion: Registerkarte "Allgemein"

  • Konfigurieren einer Dateiempfangsfunktion: Registerkarte "Dienste"

  • Hinzufügen einer Message Queuing-Empfangsfunktion

  • Konfigurieren einer Message Queuing-Empfangsfunktion: Registerkarte "Allgemein"

  • Konfigurieren einer Message Queuing-Empfangsfunktion: Registerkarte "Dienste"

  • Konfigurieren von erweiterten Eigenschaften für Datei- oder Message Queuing-Empfangsfunktionen

  • Löschen einer Empfangsfunktion


Hinzufügen einer Dateiempfangsfunktion

  1. Erweitern Sie in der BizTalk Server-Verwaltung Microsoft BizTalk Server 2000, und erweitern Sie dann die Servergruppe, zu der Sie die Dateiempfangsfunktion hinzufügen möchten.

  2. Klicken Sie auf Empfangsfunktionen.

  3. Zeigen Sie im Menü Vorgang auf Neu, und klicken Sie dann auf Dateiempfangsfunktion.

    Das Dialogfeld Dateiempfangsfunktion hinzufügen wird angezeigt.

  4. Geben Sie im Feld Name den Namen der Empfangsfunktion ein.

  5. Fügen Sie im Feld Kommentar eine kurze Beschreibung hinzu (optional).

  6. Klicken Sie in der Liste Server, auf dem die Empfangsfunktion ausgeführt werden soll auf den Namen eines Servers in der Gruppe.

  7. Geben Sie im Feld Abzurufende Dateitypen die Erweiterungen der Dateien ein, die BizTalk Server empfängt.

    Die Dateierweiterung muss gemäß folgender Syntax eingegeben werden:

    *.ext

    Beispiel: *.xml

  8. Geben Sie im Feld Abrufspeicherort entweder den logischen Pfad oder den UNC-Pfad (Universal Naming Convention) zu dem Verzeichnis ein, den diese Dateiempfangsfunktion als Speicherort für den Dateiempfang verwenden soll.

  9. Klicken Sie in der Liste Präprozessor auf den Namen des benutzerdefinierten Präprozessors.

    Falls Sie keinen benutzerdefinierten Präprozessor verwenden, lassen Sie das Feld leer.

  10. Falls erforderlich, geben Sie in den Feldern Benutzername und Kennwort einen gültigen Benutzernamen und ein gültiges Kennwort für die Verbindung zum Speicherort für den Dateiempfang ein.

    Dies ist nur dann erforderlich, wenn der Empfangsspeicherort geschützt ist und für die Verbindung zum Server ein gültiger Benutzername und ein gültiges Kennwort benötigt wird.

  11. Klicken Sie auf die Schaltfläche Erweitert, um die Empfangsfunktion für Dokumente anzupassen, die kein automatisches Routing unterstützen, oder um Optionen für Offenheitsgrad und Pass-Through anzugeben.

    Weitere Informationen zu erweiterten Optionen finden Sie unter Konfigurieren von erweiterten Eigenschaften für Datei- oder Message Queuing-Empfangsfunktionen.

Anmerkungen

  • Mit diesem Verfahren wird eine Dateiempfangsfunktion mit den Standardeinstellungen erstellt. Hinweise zum Konfigurieren der Dateiempfangsfunktion mit zusätzlichen Einstellungen finden Sie unter Konfigurieren einer Dateiempfangsfunktion: Registerkarte "Allgemein".

  • Wenn mehrere verschiedene Dateitypen abrufbar sein sollen, verwenden Sie eines der üblichen Platzhalterformate.

    Beispiel: *.* oder *.x?l

  • Wenn Sie mehrere Dateiempfangsfunktionen zum Überwachen desselben Verzeichnisses konfigurieren, verwenden Sie Dateierweiterungen mit drei Buchstaben. Falls Sie Dateierweiterungen mit mehr als drei Buchstaben verwenden, stellen Sie sicher, dass die ersten drei Buchstaben eindeutig sind.

    Beispiel: *.xml, *.1xml, *.12xml

  • Dateiempfangsfunktionen können keine schreibgeschützten Dateien verarbeiten.

  • Stellen Sie sicher, dass jede Empfangsfunktion, die Sie erstellen, einen eindeutigen Namen besitzt. Empfangsfunktionen dürfen keine identischen Namen haben.

Verwandte Themen

Verfügbare Empfangsfunktionen

Konfigurieren von erweiterten Eigenschaften für Datei- oder Message Queuing-Empfangsfunktionen

Konfigurieren einer Dateiempfangsfunktion: Registerkarte "Allgemein"

Konfigurieren einer Dateiempfangsfunktion: Registerkarte "Dienste"

Benutzerdefinierte Präprozessoren

Empfangsfunktionen


Konfigurieren einer Dateiempfangsfunktion: Registerkarte "Allgemein"

  1. Erweitern Sie in der BizTalk Server-Verwaltung Microsoft BizTalk Server 2000, erweitern Sie die Servergruppe, für die Sie eine Dateiempfangsfunktion konfigurieren möchten, und erweitern Sie dann Empfangsfunktionen.

  2. Klicken Sie auf die Dateiempfangsfunktion, die Sie konfigurieren möchten.

  3. Klicken Sie im Menü Vorgang auf Eigenschaften.

    Das Dialogfeld Eigenschaften von Name wird angezeigt.

  4. Fügen Sie im Feld Kommentar eine kurze Beschreibung hinzu (optional).

  5. Geben Sie im Bereich Sicherheit in den Feldern Benutzername und Kennwort einen gültigen Benutzernamen und ein gültiges Kennwort für die Verbindung zu dieser Empfangsfunktion ein.

    Dies ist nur dann erforderlich, wenn der Empfangsspeicherort geschützt ist und für die Verbindung zum Server ein gültiger Benutzername und ein gültiges Kennwort benötigt wird.

  6. Wenn Sie die Funktionalität dieser Empfangsfunktion vorübergehend deaktivieren möchten, aktivieren Sie das Kontrollkästchen Empfangsfunktion deaktivieren, und klicken Sie dann auf Ja, um Ihre Auswahl zu bestätigen.

Anmerkung

  • Dateiempfangsfunktionen können keine schreibgeschützten Dateien verarbeiten.

Verwandte Themen

Konfigurieren von erweiterten Eigenschaften für Datei- oder Message Queuing-Empfangsfunktionen

Konfigurieren einer Dateiempfangsfunktion: Registerkarte "Dienste"


Konfigurieren einer Dateiempfangsfunktion: Registerkarte "Dienste"

  1. Erweitern Sie in der BizTalk Server-Verwaltung Microsoft BizTalk Server 2000, erweitern Sie die Servergruppe, für die Sie eine Dateiempfangsfunktion konfigurieren möchten, und erweitern Sie dann Empfangsfunktionen.

  2. Klicken Sie auf die Dateiempfangsfunktion, die Sie konfigurieren möchten.

  3. Klicken Sie im Menü Vorgang auf Eigenschaften.

    Das Dialogfeld Eigenschaften wird angezeigt.

  4. Klicken Sie auf die Registerkarte Dienste.

  5. Klicken Sie in der Liste Server, auf dem die Empfangsfunktion ausgeführt werden soll auf den Namen des Servers.

  6. Geben Sie im Feld Abrufspeicherort entweder den logischen Pfad oder den UNC-Pfad (Universal Naming Convention) zu dem Verzeichnis ein, den diese Dateiempfangsfunktion als Speicherort für den Dateiempfang verwenden soll.

  7. Geben Sie im Feld Abzurufende Dateitypen die Erweiterungen der Dateien ein, die BizTalk Server empfängt.

    Die Dateierweiterung muss gemäß folgender Syntax eingegeben werden:

    *.ext

    Beispiel: *.doc

  8. Klicken Sie in der Liste Präprozessor auf den Namen des benutzerdefinierten Präprozessors.

    Falls Sie keinen benutzerdefinierten Präprozessor verwenden, lassen Sie das Feld leer.

  9. Klicken Sie auf OK.

Anmerkung

  • Wenn Sie mehrere verschiedene Dateitypen empfangen möchten, verwenden Sie eines der üblichen Platzhalterformate.

    Beispiel: *.*

  • Wenn Sie mehrere Dateiempfangsfunktionen zum Überwachen desselben Verzeichnisses konfigurieren, verwenden Sie Dateierweiterungen mit drei Buchstaben. Falls Sie Dateierweiterungen mit mehr als drei Buchstaben verwenden, stellen Sie sicher, dass die ersten drei Buchstaben eindeutig sind.

    Beispiel: *.xml, *.1xml, *.12xml

  • Dateiempfangsfunktionen können keine schreibgeschützten Dateien verarbeiten.

Verwandte Themen

Verfügbare Empfangsfunktionen

Konfigurieren von erweiterten Eigenschaften für Datei- oder Message Queuing-Empfangsfunktionen

Benutzerdefinierte Präprozessoren


Hinzufügen einer Message Queuing-Empfangsfunktion

  1. Erweitern Sie in der BizTalk Server-Verwaltung Microsoft BizTalk Server 2000, und erweitern Sie dann die Servergruppe, zu der Sie die Message Queuing-Empfangsfunktion hinzufügen möchten.

  2. Klicken Sie auf Empfangsfunktionen.

  3. Zeigen Sie im Menü Vorgang auf Neu, und klicken Sie dann auf Message Queuing-Empfangsfunktion.

    Das Dialogfeld Message Queuing-Empfangsfunktion hinzufügen wird angezeigt.

  4. Geben Sie im Feld Name den Namen der Message Queuing-Empfangsfunktion ein.

  5. Fügen Sie im Feld Kommentar eine kurze Beschreibung hinzu (optional).

  6. Klicken Sie in der Liste Server, auf dem die Empfangsfunktion ausgeführt werden soll auf den Namen eines Servers in der Gruppe.

  7. Geben Sie im Feld Abrufspeicherort den Namen des Servers und der Nachrichtenwarteschlange ein, die diese Empfangsfunktion als Empfangsspeicherort verwenden soll.

    Beispiel:

    Direct=OS:<servername>\<warteschlangenname>

    Wählen Sie den verarbeitenden Server aus, auf dem sich die Warteschlange befindet. Transaktionsmessaging wird nur von lokalen Warteschlangen unterstützt.

  8. Klicken Sie in der Liste Präprozessor auf den benutzerdefinierten Präprozessor.

    Falls Sie keinen benutzerdefinierten Präprozessor verwenden, lassen Sie das Feld leer.

  9. Geben Sie in den Feldern Benutzername und Kennwort einen gültigen Benutzernamen und ein gültiges Kennwort für die Verbindung zu Message Queuing ein.

    Dies ist nur dann erforderlich, wenn sich der Empfangsspeicherort nicht auf dem Server befindet, der die Austauschvorgänge und Dokumente verarbeitet.

  10. Klicken Sie auf die Schaltfläche Erweitert, um die Empfangsfunktion für Dokumente anzupassen, die kein automatisches Routing unterstützen, oder um Optionen für Offenheitsgrad und Pass-Through anzugeben.

    Weitere Informationen zu erweiterten Optionen finden Sie unter Konfigurieren von erweiterten Eigenschaften für Datei- oder Message Queuing-Empfangsfunktionen.

Wichtig

  • Geben Sie im Feld Abrufspeicherort vor <servername>\<warteschlangenname> nicht das Präfix queue:// an. Dies ist ein Unterschied zu den allgemeinen Eigenschaften für eine Servergruppe, bei denen Sie das Präfix queue:// verwenden müssen. Weitere Informationen zur Message Queuing-Syntax finden Sie unter Verfügbare Empfangsfunktionen. Weitere Informationen zu den Eigenschaften für eine Servergruppe finden Sie unter Konfigurieren von allgemeinen Eigenschaften für eine Servergruppe.

Anmerkungen

  • Weitere Informationen zu benutzerdefinierten Präprozessoren finden Sie unter Benutzerdefinierte Präprozessoren.

  • Message Queuing-Empfangsfunktionen funktionieren nur dann ordnungsgemäß, wenn der Benutzername und das Kennwort für einen BizTalk-Server angegeben werden, der Leseberechtigung für die Warteschlange besitzt.

  • Um die Zuverlässigkeit sicherzustellen, müssen Transaktionswarteschlangen verwendet werden. Wenn Sie keine Transaktionswarteschlangen verwenden, können Nachrichten verloren gehen. Weitere Informationen zu Transaktionswarteschlangen finden Sie in der MSDN Online Library-Website (msdn.microsoft.com/library/default.asp)). Suchen Sie in der Website nach dem Stichwort "Message Queuing".

  • Stellen Sie sicher, dass jede Empfangsfunktion, die Sie erstellen, einen eindeutigen Namen besitzt. Empfangsfunktionen dürfen keine identischen Namen haben.

Verwandte Themen

Verfügbare Empfangsfunktionen

Konfigurieren von erweiterten Eigenschaften für Datei- oder Message Queuing-Empfangsfunktionen

Konfigurieren einer Message Queuing-Empfangsfunktion: Registerkarte "Allgemein"

Benutzerdefinierte Präprozessoren

Empfangsfunktionen


Konfigurieren einer Message Queuing-Empfangsfunktion: Registerkarte "Allgemein"

  1. Erweitern Sie in der BizTalk Server-Verwaltung Microsoft BizTalk Server 2000, erweitern Sie die Servergruppe, zu der Sie die Message Queuing-Empfangsfunktion hinzufügen möchten, und erweitern Sie dann Empfangsfunktionen.

  2. Klicken Sie auf die Message Queuing-Empfangsfunktion, die Sie konfigurieren möchten.

  3. Klicken Sie im Menü Vorgang auf Eigenschaften.

    Das Dialogfeld Eigenschaften von Name wird angezeigt.

  4. Fügen Sie im Feld Kommentar eine kurze Beschreibung hinzu (optional).

  5. Geben Sie im Bereich Sicherheit in den Feldern Benutzername und Kennwort einen gültigen Benutzernamen und ein gültiges Kennwort für die Verbindung zur Nachrichtenwarteschlange ein.

    Dies ist nur dann erforderlich, wenn sich der Empfangsspeicherort nicht auf dem verarbeitenden Server befindet.

  6. Wenn Sie die Funktionalität dieser Empfangsfunktion vorübergehend deaktivieren möchten, aktivieren Sie das Kontrollkästchen Empfangsfunktion deaktivieren, und klicken Sie dann auf Ja, um Ihre Auswahl zu bestätigen.

Verwandte Themen

Konfigurieren einer Message Queuing-Empfangsfunktion: Registerkarte "Dienste"

Empfangsfunktionen


Konfigurieren einer Message Queuing-Empfangsfunktion: Registerkarte "Dienste"

  1. Erweitern Sie in der BizTalk Server-Verwaltung Microsoft BizTalk Server 2000, erweitern Sie die Servergruppe, zu der Sie die Message Queuing-Empfangsfunktion hinzufügen möchten, und erweitern Sie dann Empfangsfunktionen.

  2. Klicken Sie auf die Message Queuing-Empfangsfunktion, die Sie konfigurieren möchten.

  3. Klicken Sie im Menü Vorgang auf Eigenschaften.

    Das Dialogfeld Eigenschaften von Name wird angezeigt.

  4. Klicken Sie auf die Registerkarte Dienste.

  5. Klicken Sie in der Liste Server, auf dem die Empfangsfunktion ausgeführt werden soll auf den Namen des Servers.

  6. Geben Sie im Feld Abrufspeicherort den Namen des Servers und der Nachrichtenwarteschlange ein, die diese Empfangsfunktion als Empfangsspeicherort verwenden soll.

    Beispiel:

    Direct=OS:<servername>\<warteschlangenname>

  7. Klicken Sie in der Liste Präprozessor auf den benutzerdefinierten Präprozessor.

    Falls Sie keinen benutzerdefinierten Präprozessor verwenden, lassen Sie diese Option leer.

  8. Klicken Sie auf OK.

Wichtig

  • Geben Sie im Feld Abrufspeicherort vor <servername>\<warteschlangenname> nicht das Präfix queue:// an. Dies ist ein Unterschied zu den allgemeinen Eigenschaften für eine Servergruppe, bei denen Sie das Präfix queue:// verwenden müssen. Weitere Informationen zur Message Queuing-Syntax finden Sie unter Verfügbare Empfangsfunktionen. Weitere Informationen zu Servergruppeneigenschaften finden Sie unter Konfigurieren von allgemeinen Eigenschaften für eine Servergruppe.

Anmerkung

  • Weitere Informationen zu benutzerdefinierten Präprozessoren finden Sie unter Benutzerdefinierte Präprozessoren.

Verwandte Themen

Verfügbare Empfangsfunktionen

Konfigurieren von allgemeinen Eigenschaften für eine Servergruppe

Benutzerdefinierte Präprozessoren


Konfigurieren von erweiterten Eigenschaften für Datei- oder Message Queuing-Empfangsfunktionen

  1. Erweitern Sie in der BizTalk Server-Verwaltung Microsoft BizTalk Server 2000, erweitern Sie die Servergruppe, für die Sie eine Empfangsfunktion konfigurieren möchten, erweitern Sie Empfangsfunktionen, und klicken Sie dann auf die Empfangsfunktion, die Sie konfigurieren möchten.

  2. Klicken Sie im Menü Vorgang auf Eigenschaften.

    Das Dialogfeld Eigenschaften von Name wird angezeigt.

  3. Klicken Sie auf die Registerkarte Erweitert.

  4. In der Liste Offenheitsgrad können Sie zwischen folgenden Optionen auswählen:
    • Nicht geöffnet. Klicken Sie auf diese Option, wenn Quelle und Ziel in der Empfangsfunktion oder in der Dokumentinstanz explizit deklariert sind und BizTalk Server das Dokument nicht für diese Information analysieren muss.

    • Offenes Ziel. Klicken Sie auf diese Option, wenn die Zielinformation am Messagingport nicht explizit deklariert ist. Das Ziel wird stattdessen in der Dokumentinstanz oder in einem Versendungsparameter dynamisch bestimmt.

    • Offene Quelle. Klicken Sie auf diese Option, wenn die Quellinformation im Kanal nicht explizit deklariert ist. Die Quelle wird stattdessen in der Dokumentinstanz oder in einem Versendungsparameter dynamisch bestimmt.
  5. Wenn Sie alle Verarbeitungsschritte, wie z. B. Decodierung, Entschlüsselung, Signaturüberprüfung, Analyse usw. umgehen und einen Austausch lediglich transportieren möchten, aktivieren Sie das Kontrollkästchen Mit Pass-Through-Kennzeichen senden.

    Falls Sie das Kontrollkästchen Mit Pass-Through-Kennzeichen senden aktivieren, müssen Sie einen Kanal auswählen.

  6. Klicken Sie in der Liste Umschlagsname auf den Namen einer Umschlagsdefinition.

    Wählen Sie einen Umschlag aus, wenn Sie Flatfiles empfangen möchten. Andernfalls lassen Sie dieses Feld leer.

  7. Klicken Sie in der Liste Kanalname auf den Namen eines Kanals.

  8. Klicken Sie in der Liste Dokumentdefinitionsname auf den Namen einer Dokumentdefinition.

  9. Klicken Sie im Bereich Quelle und Ziel unter Ausgewählte Quelle auf Durchsuchen.

    Das Dialogfeld Quelle auswählen wird angezeigt.

  10. Klicken Sie in der Liste Organisationsqualifizierer auf den Typ des Quellorganisationsqualifizierers.

  11. Klicken Sie in der Liste Organisationskennzeichenwert auf das Organisationskennzeichenwert der Quelle, und klicken Sie dann auf OK.

  12. Klicken Sie im Bereich Quelle und Ziel unter Ausgewähltes Ziel auf Durchsuchen.

    Das Dialogfeld Ziel auswählen wird angezeigt.

  13. Klicken Sie in der Liste Organisationsqualifizierer auf den Typ des Zielorganisationsqualifizierers.

    Wenn Sie Dokumente an eine Verteilerliste senden, müssen Sie in der Liste Organisationsqualifizierer die Option GRUPPE auswählen.

  14. Klicken Sie in der Liste Organisationskennzeichen auf den Organisationskennzeichenwert des Ziels, und klicken Sie dann auf OK.

  15. Klicken Sie auf OK.

Wichtig

  • Bevor Sie die Objekte in der folgenden Liste als erweiterte Eigenschaften einer Empfangsfunktion zuordnen können, müssen Sie sie zunächst erstellen. Diese Objekte werden entweder im BizTalk Messaging-Manager erstellt, oder sie werden programmgesteuert generiert und in der BizTalk-Messaging-Verwaltungsdatenbank gespeichert.
    • Umschläge

    • Kanäle

    • Dokumentdefinitionen

    • Quellqualifizierer

    • Organisationskennzeichenwerte der Quelle

    • Zielqualifizierer

    • Organisationskennzeichenwerte des Ziels

Anmerkungen

  • Wenn Sie in der Liste Offenheitsgrad auf Offene Quelle oder Offenes Ziel klicken, ist das Kontrollkästchen Mit Pass-Through-Kennzeichen senden nicht verfügbar.

  • Wenn Sie Dokumente an eine Verteilerliste senden, müssen Sie im Dialogfeld Ziel auswählen in der Liste Organisationsqualifizierer die Option GRUPPE. auswählen.

  • Alle erweiterten Empfangsfunktionseigenschaften sind optional und können leer gelassen werden. Weitere Informationen zum Senden von Dokumenten finden Sie unter Routing und unter Grundlegendes zu Empfangsfunktionen und Dokumentrouting.

  • Wenn das Kontrollkästchen Mit Pass-Through-Kennzeichen senden aktiviert ist, ist nur die Liste Kanal verfügbar.

  • Bei einer Pass-Through-Versendung werden die Analyse-, Entschlüsselungs- und Decodierungsfunktionen von BizTalk Server 2000 umgangen. Weitere Informationen zum Senden von Dokumenten mit aktiviertem Pass-Through-Kennzeichen finden Sie unter Grundlegendes zu erweiterten Eigenschaften von Empfangsfunktionen. Weitere Informationen zum Senden finden Sie unter Submitting.

Verwandte Themen

Empfangsfunktionen

Routing

Submitting

Grundlegendes zu erweiterten Eigenschaften von Empfangsfunktionen

Grundlegendes zu Empfangsfunktionen und Dokumentrouting


Löschen einer Empfangsfunktion

  1. Erweitern Sie in der BizTalk Server-Verwaltung Microsoft BizTalk Server 2000, erweitern Sie die Servergruppe, in der Sie eine Empfangsfunktion löschen möchten, und erweitern Sie dann Empfangsfunktionen.

  2. Klicken Sie auf die Empfangsfunktion, die gelöscht werden soll.

  3. Klicken Sie im Menü Vorgang auf Löschen.

    Das Dialogfeld Benutzeraktionsbestätigung wird angezeigt.

  4. Klicken Sie auf Ja.

Verwandtes Thema

Empfangsfunktionen


Verwalten der Ereignisanzeige

Sie können die zur BizTalk Server-Verwaltung gehörende Ereignisanzeige als Hilfe zur Problembehandlung bei Server- und Dokumentverarbeitungsproblemen verwenden. Die Ereignisanzeige wird in der Konsolenstruktur der BizTalk Server-Verwaltung angezeigt. Alle anwendungsbezogenen Fehler bei BizTalk Server 2000 sind als BizTalk Server-Fehler gekennzeichnet. Alle auf die XLANG-Ablaufpläne bezogenen Fehler sind als Fehler der XLANG-Ablaufplanung (XLANG Scheduler) gekennzeichnet.

Die folgenden Verfahren werden zum Verwalten der Ereignisanzeige verwendet:

  • Konfigurieren der Ereignisanzeige für BizTalk Server-Fehler

  • Anzeigen von anwendungsbezogenen Fehlern in der Ereignisanzeige


Konfigurieren der Ereignisanzeige für BizTalk Server-Fehler

  1. Erweitern Sie in der BizTalk Server-Verwaltung Ereignisanzeige.

  2. Klicken Sie auf Anwendung.

  3. Klicken Sie im Menü Vorgang auf Eigenschaften.

    Das Dialogfeld Eigenschaften von Anwendung wird angezeigt.

  4. Klicken Sie auf die Registerkarte Filter.

  5. Klicken Sie in der Liste Ereignisquelle auf eine der folgenden Optionen:
    • BizTalk Server. Diese Option filtert nach Ereignisquellen für Fehlernachrichten, die sich auf die BizTalk-Messagingdienste beziehen.

    • XLANG Scheduler. Diese Option filtert nach Ereignisquellen für Fehlernachrichten, die sich auf die BizTalk-Orchestrierungsdienste beziehen.
  6. Klicken Sie auf OK, um das Dialogfeld Anwendungseigenschaften zu schließen.


Anzeigen von anwendungsbezogenen Fehlern in der Ereignisanzeige

  1. Erweitern Sie in der BizTalk Server-Verwaltung Ereignisanzeige.

  2. Klicken Sie auf Anwendung.

    Anwendungsfehlermeldungen werden im Detailbereich aufgeführt.

  3. Klicken Sie im Detailbereich auf eine Nachricht.

  4. Klicken Sie im Menü Vorgang auf Eigenschaften.

Anmerkung

  • Dieses Verfahren geht von der Annahme aus, dass die Ereignisanzeige dahingehend konfiguriert ist, nur BizTalk Server-Fehler und Fehler der XLANG-Ablaufplanung (XLANG Scheduler) anzuzeigen. Weitere Informationen zum Anzeigen von BizTalk Server-Fehlern und Fehler der XLANG-Ablaufplanung(XLANG Scheduler) finden Sie unter Konfigurieren der Ereignisanzeige für BizTalk Server-Fehler.

Verwandtes Thema

Konfigurieren der Ereignisanzeige für BizTalk Server-Fehler


Verwalten von XLANG-Anwendungen und -Datenbanken

Dieser Abschnitt stellt Informationen zum Verwalten von COM+-Anwendungen bereit, die als Host für XLANG-Ablaufpläne dienen. Darüber hinaus gibt er Hinweise zum Verwalten der Standardanwendung XLANG-Ablaufplanung (XLANG Scheduler) und der Standard-Persistenzdatenbank für die Orchestrierung, die bei der Installation von BizTalk Server 2000 erstellt wird.

BizTalk Server 2000 stellt eine COM+-Anwendung mit der Bezeichnung XLANG-Hilfsprogramm für Ablaufplanungsbeständigkeit (Scheduler Persistence Helper) bereit, die von allen COM+-Anwendungen, die als Host für XLANG-Ablaufplaninstanzen dienen, verwendet wird. Nach Abschluss der Installation sollten Sie die Konfiguration des XLANG-Hilfsprogramms für Ablaufplanungsbeständigkeit in keiner Weise mehr ändern.

Folgende Prozeduren werden in diesem Abschnitt behandelt:

  • Verwalten der Standardanwendung XLANG-Ablaufplanung (XLANG Scheduler) und -Datenbank

  • Verwalten von weiteren COM+-Hostanwendungen für XLANG-Ablaufpläne

  • Überwachen von aktiven XLANG-Ablaufplänen

Anmerkungen

  • Zeigen Sie im Startmenü auf Programme, zeigen Sie auf Microsoft SQL Server, und klicken Sie dann auf Onlinedokumentation, um weitere Informationen zu Microsoft SQL Server zu erhalten.

  • Zeigen Sie im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Komponentendienste, um Hilfe zur Verwaltung der Komponentendienste zu erhalten. Klicken Sie in der Konsolenstruktur mit der rechten Maustaste auf Komponentendienste, und klicken Sie dann auf Hilfe.

  • Weitere Informationen zu den Komponentendiensten und COM+ finden Sie in der MSDN Online Library-Website (msdn.microsoft.com/library/default.asp). Suchen Sie im Platform SDK nach "Component Services".

Verwandte Themen

Ausführen von XLANG-Ablaufplänen

Ausführung von XLANG-Ablaufplänen


Verwalten der Standardanwendung XLANG-Ablaufplanung (XLANG Scheduler) und -Datenbank

Die Standardanwendung XLANG-Ablaufplanung (XLANG Scheduler) und die Standard-Persistenzdatenbank für die Orchestrierung werden bei der Installation von BizTalk Server 2000 erstellt. Auf Produktionssystemen oder Systemen mit Microsoft Terminal Server müssen Sie jedoch die Standardeinstellungen für die Anwendung und die Datenbank ändern. Darüber hinaus können Sie neue COM+-Hostanwendungen für XLANG-Ablaufplaninstanzen und neue Persistenzdatenbanken zum Speichern von Statusinformation für XLANG-Ablaufpläne erstellen.

Weitere Informationen zum Erstellen einer neuen COM+-Hostanwendung für XLANG-Ablaufplaninstanzen finden Sie unter Erstellen einer COM+-Hostanwendung für XLANG-Ablaufpläne.

Weitere Informationen zu Sicherheits- und Leistungsaspekten in Bezug auf Änderungen der Standardeinstellungen für die Standardanwendung XLANG-Ablaufplanung (XLANG Scheduler) finden Sie unter Sicherheit für Hostanwendungen für XLANG-Ablaufplaninstanzen.

Folgende Prozeduren werden in diesem Abschnitt behandelt:

  • Konfigurieren der Standardanwendung XLANG-Ablaufplanung (XLANG Scheduler)

  • Ändern der Anwendungsidentität der Standardanwendung XLANG-Ablaufplanung (XLANG Scheduler)

  • Ändern der Einstellungen der Persistenzdatenbank für die Orchestrierung

  • Herunterfahren aller XLANG-Anwendungen

  • Neu starten aller XLANG-Anwendungen

  • Anmerkungen

  • Zeigen Sie im Startmenü auf Programme, zeigen Sie auf Microsoft SQL Server, und klicken Sie dann auf Onlinedokumentation, um weitere Informationen zu Microsoft SQL Server zu erhalten.

  • Zeigen Sie im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Komponentendienste, um Hilfe zur Verwaltung der Komponentendienste zu erhalten. Klicken Sie in der Konsolenstruktur mit der rechten Maustaste auf Komponentendienste, und klicken Sie dann auf Hilfe.

  • Weitere Informationen zu den Komponentendiensten und COM+ finden Sie in der MSDN Online Library-Website (msdn.microsoft.com/library/default.asp). Suchen Sie im Platform SDK nach "Component Services".

Verwandte Themen

Ausführen von XLANG-Ablaufplänen

Ausführung von XLANG-Ablaufplänen


Konfigurieren der Standardanwendung XLANG-Ablaufplanung (XLANG Scheduler)

Die Standardanwendung XLANG-Ablaufplanung (XLANG Scheduler) und die Standard-Persistenzdatenbank für die Orchestrierung werden bei der Installation von BizTalk Server 2000 erstellt. Auf Produktionssystemen oder Systemen mit Microsoft Terminal Server müssen Sie jedoch die Standardeinstellungen für die Anwendung und die Datenbank ändern. Darüber hinaus können Sie neue COM+-Hostanwendungen für XLANG-Ablaufplaninstanzen und neue Persistenzdatenbanken zum Speichern von Statusinformation für XLANG-Ablaufpläne erstellen.

Weitere Informationen zum Erstellen einer neuen COM+-Hostanwendung für XLANG-Ablaufplaninstanzen finden Sie unter Erstellen einer COM+-Hostanwendung für XLANG-Ablaufpläne.

Weitere Informationen zu Sicherheits- und Leistungsaspekten in Bezug auf Änderungen der Standardeinstellungen für die Standardanwendung XLANG-Ablaufplanung (XLANG Scheduler) finden Sie unter Sicherheit für Hostanwendungen für XLANG-Ablaufplaninstanzen.

  1. Zeigen Sie im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Komponentendienste.

  2. Erweitern Sie Komponentendienste in der Konsolenstruktur, erweitern Sie Computer, dann Arbeitsplatz und dann COM+-Anwendungen.

  3. Klicken Sie auf XLANG Scheduler. Klicken Sie im Menü Vorgang auf Eigenschaften.

  4. Es wird dringend empfohlen, dass Sie die Anwendungsidentität der Standardanwendung XLANG-Ablaufplanung (XLANG Scheduler) ändern, insbesondere bei Produktionssystemen oder Systemen mit Microsoft Terminal Server. Weitere Informationen finden Sie unter Ändern der Anwendungsidentität der Standardanwendung XLANG-Ablaufplanung (XLANG Scheduler).

  5. Es wird dringend empfohlen, dass Sie die Standard-Datenbankeinstellungen der Persistenzdatenbank für die Orchestrierung ändern. Weitere Informationen finden Sie unter Ändern der Einstellungen der Persistenzdatenbank für die Orchestrierung.

Anmerkungen

  • Der Datenquellenname (DSN) muss mit dem Namen der COM+-Anwendung übereinstimmen. Wenn beispielsweise die COM+-Anwendung, die als Host für das XLANG-Ablaufplanungsmodul dient, den Namen XLANG-Ablaufplanung (XLANG Scheduler) trägt, muss der DSN ebenfalls XLANG-Ablaufplanung lauten.

  • Zeigen Sie im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Komponentendienste, um Hilfe zur Verwaltung der Komponentendienste zu erhalten. Klicken Sie in der Konsolenstruktur mit der rechten Maustaste auf Komponentendienste, und klicken Sie dann auf Hilfe.

  • Weitere Informationen zu den Komponentendiensten und COM+ finden Sie in der MSDN Online Library-Website (msdn.microsoft.com/library/default.asp). Suchen Sie im Platform SDK nach "Component Services".

Verwandte Themen

Ändern der Anwendungsidentität der Standardanwendung XLANG-Ablaufplanung (XLANG Scheduler)

Ändern der DSN-Einstellungen für eine COM+-Anwendung

Ändern der Einstellungen der Persistenzdatenbank für die Orchestrierung

Erstellen einer neuen Persistenzdatenbank

Erstellen einer Instanziierungsanwendung

Neu starten aller XLANG-Anwendungen

Ausführen von XLANG-Ablaufplänen

Ausführung von XLANG-Ablaufplänen

Herunterfahren aller XLANG-Anwendungen


Ändern der Anwendungsidentität der Standardanwendung XLANG-Ablaufplanung (XLANG Scheduler)

Wir empfehlen Ihnen, das interaktive Standardbenutzerkonto für die Standardanwendung XLANG-Ablaufplanung (XLANG Scheduler) in ein Dienstkonto zu ändern.

Weitere Informationen zu Sicherheits- und Leistungsaspekten in Bezug auf Änderungen der Standardeinstellungen für die Standardanwendung XLANG-Ablaufplanung (XLANG Scheduler) finden Sie unter Sicherheit für Hostanwendungen für XLANG-Ablaufplaninstanzen.

  1. Zeigen Sie im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Komponentendienste.

  2. Erweitern Sie Komponentendienste in der Konsolenstruktur, erweitern Sie Computer, dann Arbeitsplatz und dann COM+-Anwendungen.

  3. Klicken Sie auf XLANG Scheduler. Klicken Sie im Menü Vorgang auf Eigenschaften.

  4. Deaktivieren Sie auf der Registerkarte Erweitert im Bereich Berechtigung das Kontrollkästchen Änderungen nicht zulassen, und klicken Sie dann auf OK.

    Es wird eine Fehlermeldung mit ungefähr folgendem Wortlaut angezeigt: Die Anwendungen wurden durch ein oder mehrere externe Produkte erstellt. Sind Sie sicher, dass die Änderungen, die Sie vornehmen möchten, von diesen Produkten unterstützt werden?

  5. Klicken Sie auf Ja.

    Das Dialogfeld Eigenschaften von XLANG Scheduler wird geschlossen.

  6. Klicken Sie auf XLANG Scheduler. Klicken Sie im Menü Vorgang auf Eigenschaften.

  7. Klicken Sie auf der Registerkarte Identität im Bereich Konto auf Dieser Benutzer.

  8. Geben Sie die Informationen für das Konto ein, das verwendet werden soll.

  9. Klicken Sie auf OK.

    Es wird eine Fehlermeldung mit ungefähr folgendem Wortlaut angezeigt: Die Anwendungen wurden durch ein oder mehrere externe Produkte erstellt. Sind Sie sicher, dass die Änderungen, die Sie vornehmen möchten, von diesen Produkten unterstützt werden?

  10. Klicken Sie auf Ja.

Anmerkungen

  • Zeigen Sie im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Komponentendienste, um Hilfe zur Verwaltung der Komponentendienste zu erhalten. Klicken Sie in der Konsolenstruktur mit der rechten Maustaste auf Komponentendienste, und klicken Sie dann auf Hilfe.

  • Weitere Informationen zu den Komponentendiensten und COM+ finden Sie in der MSDN Online Library-Website (msdn.microsoft.com/library/default.asp). Suchen Sie im Platform SDK nach "Component Services".

Verwandte Themen

Ändern der Einstellungen der Persistenzdatenbank für die Orchestrierung

Konfigurieren der Standardanwendung XLANG-Ablaufplanung (XLANG Scheduler)

Ausführen von XLANG-Ablaufplänen

Ausführung von XLANG-Ablaufplänen

Sicherheit für Hostanwendungen für XLANG-Ablaufplaninstanzen


Ändern der Einstellungen der Persistenzdatenbank für die Orchestrierung

Bei der Installation von BizTalk Server 2000 wird die Persistenzdatenbank für die Orchestrierung eingerichtet und mit Standardeinstellungen konfiguriert. Diese Standardeinstellungen können Sie in eine Konfiguration ändern, die auf das von Ihnen verwendete System abgestimmt ist.

  1. Zeigen Sie im Startmenü auf Programme, zeigen Sie auf Microsoft SQL Server, und klicken Sie dann auf Enterprise Manager.

  2. Erweitern Sie Microsoft SQL Server, erweitern Sie SQL Server-Gruppe, dann den Server, der die Standarddatenbank enthält, und anschließend Datenbanken.

  3. Klicken Sie auf die XLANG-Datenbank. Klicken Sie im Menü Vorgang auf Eigenschaften.

  4. Es werden sechs Registerkarten angezeigt, auf denen Sie verschiedene Datenbankeigenschaften festlegen können:
    • Allgemein

    • Datendateien

    • Transaktionsprotokoll

    • Dateigruppen

    • Optionen

    • Berechtigungen

Weitere Informationen zum Konfigurieren von Datenbanken in Microsoft SQL Server finden Sie in der Microsoft SQL Server-Onlinedokumentation.

Wichtig

  • Dieses Verfahren setzt voraus, das Sie die Standarddatenbank unter dem Namen XLANG eingerichtet haben.

Anmerkungen

  • Die primären Datenbank- und Transaktionsprotokolldateien erhalten bei der Erstellung den Datenbanknamen als Präfix. Beispielsweise XLANGdb_Data.mdf und XLANGdb_Log.ldf. Die primäre Datei enthält die Systemtabellen für die Datenbank.

  • Die maximale Datenbankgröße wird aus dem verfügbaren Plattenspeicher und aus den für die von Ihnen verwendete Version von Microsoft SQL Server festgelegten Lizenzierungslimits ermittelt.

  • Der Objektname der Standard-Orchestrierungsdatenbank ist XLANG. Sie können diesen Namen im Verlauf der Installation ändern.

  • Zeigen Sie im Startmenü auf Programme, zeigen Sie auf Microsoft SQL Server, und klicken Sie dann auf Onlinedokumentation, um weitere Informationen zu SQL Server zu erhalten.

Verwandte Themen

Ändern der Anwendungsidentität der Standardanwendung XLANG-Ablaufplanung (XLANG Scheduler)

Konfigurieren der Standardanwendung XLANG-Ablaufplanung (XLANG Scheduler)

Ausführen von XLANG-Ablaufplänen

Ausführung von XLANG-Ablaufplänen

Sicherheit für Hostanwendungen für XLANG-Ablaufplaninstanzen


Herunterfahren aller XLANG-Anwendungen

  1. Zeigen Sie im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Komponentendienste.

  2. Erweitern Sie Komponentendienste in der Konsolenstruktur, erweitern Sie Computer, dann Arbeitsplatz und dann COM+-Anwendungen.

  3. Klicken Sie auf XLANG Scheduler. Klicken Sie im Menü Vorgang auf Eigenschaften.

  4. Klicken Sie auf der Registerkarte XLANG im Bereich Kontrolliertes Herunterfahren auf Alle XLANG-Anwendungen.

Vorsicht

  • Sie müssen dieses Verfahren anwenden, damit ein kontrolliertes Herunterfahren aller COM+-Anwendungen ausgeführt wird. Dadurch wird der Status aller aktiven XLANG-Ablaufpläne in der Persistenzdatenbank gespeichert. Weitere Informationen finden Sie unter Persistenz.

    Dagegen sollten Sie nicht mit der rechten Maustaste auf eine COM+-Anwendung klicken und auf Herunterfahren klicken. Dadurch können folgende Probleme auftreten:

    • Falls die aktiven XLANG-Ablaufpläne vollständig transaktional sind, werden bei einem unkontrollierten Herunterfahren alle gerade in Ausführung befindlichen Transaktionen abgebrochen.

    • Sind die aktiven XLANG-Ablaufpläne nicht vollständig transaktional, gehen in Verarbeitung befindliche Daten im Ablaufplan verloren.

Wichtig

  • Pausierende XLANG-Ablaufpläne können nicht neu gestartet werden, wenn der Datenquellenname (DSN) nicht verfügbar oder fehlerhaft konfiguriert ist. Weitere Informationen zum Konfigurieren eines DSNs für die Standardanwendung XLANG-Ablaufplanung (XLANG Scheduler) finden Sie unter Konfigurieren der Standardanwendung XLANG-Ablaufplanung (XLANG Scheduler).

Anmerkungen

  • Zeigen Sie im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Komponentendienste, um Hilfe zur Verwaltung der Komponentendienste zu erhalten. Klicken Sie in der Konsolenstruktur mit der rechten Maustaste auf Komponentendienste, und klicken Sie dann auf Hilfe.

  • Weitere Informationen zu den Komponentendiensten und COM+ finden Sie in der MSDN Online Library-Website (msdn.microsoft.com/library/default.asp). Suchen Sie im Platform SDK nach "Component Services".

Verwandte Themen

Konfigurieren der Standardanwendung XLANG-Ablaufplanung (XLANG Scheduler)

Neu starten aller XLANG-Anwendungen

Ausführen von XLANG-Ablaufplänen

Ausführung von XLANG-Ablaufplänen

Herunterfahren einer COM+-Hostanwendung für XLANG-Ablaufpläne


Neu starten aller XLANG-Anwendungen

  1. Zeigen Sie im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Komponentendienste.

  2. Erweitern Sie Komponentendienste in der Konsolenstruktur, erweitern Sie Computer, dann Arbeitsplatz und dann COM+-Anwendungen.

  3. Klicken Sie auf XLANG Scheduler. Klicken Sie im Menü Vorgang auf Eigenschaften.

  4. Klicken Sie auf der Registerkarte XLANG im Bereich Pausierende XLANG-Anwendungen neu starten auf Alle XLANG-Anwendungen.

Wichtig

  • Pausierende XLANG-Ablaufpläne können nicht neu gestartet werden, wenn der Datenquellenname (DSN) nicht verfügbar oder fehlerhaft konfiguriert ist. Weitere Informationen zum Konfigurieren eines DSNs für die Standardanwendung XLANG-Ablaufplanung (XLANG Scheduler) finden Sie unter Konfigurieren der Standardanwendung XLANG-Ablaufplanung (XLANG Scheduler).

  • Wenn Sie pausierende Anwendungen neu starten, startet dieser Vorgang die Aktivierung der pausierenden Ablaufpläne asynchron. Der Aktivierungsvorgang geschieht nicht sofort. Verwenden Sie den XLANG Event Monitor, um zu ermitteln, wann der Aktivierungsvorgang abgeschlossen ist. Weitere Informationen zum Tool XLANG Event Monitor finden Sie in der zur Anwendung gehörenden Datei Info.htm. Der XLANG Event Monitor (XLANGMon.exe) und die Infodatei, die vom Microsoft BizTalk Server 2000 Setup-Assistenten installiert werden, befinden sich im folgenden Installationsverzeichnis: \Programme\Microsoft BizTalk Server\SDK\XLANG-Tools.

Anmerkungen

  • Zeigen Sie im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Komponentendienste, um Hilfe zur Verwaltung der Komponentendienste zu erhalten. Klicken Sie in der Konsolenstruktur mit der rechten Maustaste auf Komponentendienste, und klicken Sie dann auf Hilfe.

  • Weitere Informationen zu den Komponentendiensten und COM+ finden Sie in der MSDN Online Library-Website (msdn.microsoft.com/library/default.asp). Suchen Sie im Platform SDK nach "Component Services".

Verwandte Themen

Konfigurieren der Standardanwendung XLANG-Ablaufplanung (XLANG Scheduler)

Ausführen von XLANG-Ablaufplänen

Ausführung von XLANG-Ablaufplänen

Herunterfahren einer COM+-Hostanwendung für XLANG-Ablaufpläne

Herunterfahren aller XLANG-Anwendungen


Verwalten von weiteren COM+-Hostanwendungen für XLANG-Ablaufpläne

Die meisten COM+-Anwendungen, die als Host für XLANG-Ablaufpläne dienen, müssen erstellt werden, während der XLANG-Ablaufplan entwickelt wird. Dabei sind Sicherheits- und Leistungsanforderungen für die Anwendungen und Ablaufpläne zu berücksichtigen, und es können spezifische COM+-Anwendungen zum Ausführen besonderer Ablaufpläne erstellt werden. Weitere Informationen finden Sie unter Ausführung von XLANG-Ablaufplänen sowie unter Ausführen von XLANG-Ablaufplänen.

Folgende Prozeduren werden in diesem Abschnitt behandelt:

  • Erstellen einer neuen Persistenzdatenbank

  • Ändern der Anwendungsidentität einer COM+-Anwendung

  • Ändern der DSN-Einstellungen für eine COM+-Anwendung

  • Herunterfahren einer COM+-Hostanwendung für XLANG-Ablaufpläne

Anmerkungen

  • Zeigen Sie im Startmenü auf Programme, zeigen Sie auf Microsoft SQL Server, und klicken Sie dann auf Onlinedokumentation, um weitere Informationen zu Microsoft SQL Server zu erhalten.

  • Zeigen Sie im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Komponentendienste, um Hilfe zur Verwaltung der Komponentendienste zu erhalten. Klicken Sie in der Konsolenstruktur mit der rechten Maustaste auf Komponentendienste, und klicken Sie dann auf Hilfe.

  • Weitere Informationen zu den Komponentendiensten und COM+ finden Sie in der MSDN Online Library-Website (msdn.microsoft.com/library/default.asp). Suchen Sie im Platform SDK nach "Component Services".

Verwandte Themen

Ausführen von XLANG-Ablaufplänen

Ausführung von XLANG-Ablaufplänen


Erstellen einer neuen Persistenzdatenbank

  1. Zeigen Sie im Startmenü auf Programme, zeigen Sie auf Microsoft SQL Server, und klicken Sie dann auf Enterprise Manager.

  2. Erweitern Sie Microsoft SQL Server, erweitern Sie SQL Server-Gruppe, dann den Server, für den Sie eine neue Datenbank hinzufügen möchten, und anschließend Datenbanken.

  3. Klicken Sie auf Datenbanken. Klicken Sie im Menü Vorgang auf Neue Datenbank.

  4. Geben Sie auf der Registerkarte Allgemein im Feld Name einen Namen für die neue Datenbank ein, und klicken Sie dann auf OK.

    Diese Aktion erstellt eine neue Datenbank mit den Standardeinstellungen. Sie können die Standardeinstellungen ändern. Weitere Informationen zum Konfigurieren von Datenbanken in Microsoft SQL Server finden Sie in der Microsoft SQL Server-Onlinedokumentation.

Anmerkungen

  • Die primären Datenbank- und Transaktionsprotokolldateien erhalten bei der Erstellung den Datenbanknamen als Präfix. Beispielsweise XLANGdb_Data.mdf und XLANGdb_Log.ldf. Die primäre Datei enthält die Systemtabellen für die Datenbank.

  • Die maximale Datenbankgröße wird aus dem verfügbaren Plattenspeicher und aus den für die von Ihnen verwendete Version von Microsoft SQL Server festgelegten Lizenzierungslimits ermittelt.

  • Zeigen Sie im Startmenü auf Programme, zeigen Sie auf Microsoft SQL Server, und klicken Sie dann auf Onlinedokumentation, um weitere Informationen zu SQL Server zu erhalten.

Verwandte Themen

Konfigurieren der Standardanwendung XLANG-Ablaufplanung (XLANG Scheduler)

Ausführen von XLANG-Ablaufplänen

Ausführung von XLANG-Ablaufplänen

Sicherheit für Hostanwendungen für XLANG-Ablaufplaninstanzen


Ändern der Anwendungsidentität einer COM+-Anwendung

  1. Zeigen Sie im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Komponentendienste.

  2. Erweitern Sie Komponentendienste in der Konsolenstruktur, erweitern Sie Computer, dann Arbeitsplatz und dann COM+-Anwendungen.

  3. Klicken Sie auf die COM+-Anwendung, deren Identität Sie ändern möchten, und klicken Sie dann im Menü Vorgang auf Eigenschaften.

  4. Stellen Sie sicher, dass auf der Registerkarte Erweitert im Bereich Berechtigung das Kontrollkästchen Ändern deaktivieren deaktiviert ist, und klicken Sie dann auf OK.

    Das Dialogfeld Eigenschaften wird geschlossen.

  5. Klicken Sie mit der rechten Maustaste erneut auf die COM+-Anwendung, und klicken Sie dann auf Eigenschaften.

  6. Klicken Sie auf der Registerkarte Identität im Bereich Konto auf Dieser Benutzer.

  7. Geben Sie die Informationen für das Konto ein, das verwendet werden soll.

  8. Klicken Sie auf OK.

    Es wird eine Fehlermeldung mit ungefähr folgendem Wortlaut angezeigt: Die Anwendungen wurden durch ein oder mehrere externe Produkte erstellt. Sind Sie sicher, dass die Änderungen, die Sie vornehmen möchten, von diesen Produkten unterstützt werden?

  9. Klicken Sie auf Ja.

Anmerkungen

  • Weitere Informationen zu Sicherheits- und Leistungsaspekten in Bezug auf die Anwendungsidentitätseinstellungen bei COM+-Anwendungen, die als Host für XLANG-Ablaufpläne dienen, finden Sie unter Sicherheit für Hostanwendungen für XLANG-Ablaufplaninstanzen.

  • Zeigen Sie im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Komponentendienste , um Hilfe zur Verwaltung der Komponentendienste zu erhalten.

  • Weitere Informationen zu den Komponentendiensten und COM+ finden Sie in der MSDN Online Library-Website (msdn.microsoft.com/library/default.asp). Suchen Sie im Platform SDK nach "Component Services".

Verwandte Themen

Ändern der Einstellungen der Persistenzdatenbank für die Orchestrierung

Konfigurieren der Standardanwendung XLANG-Ablaufplanung (XLANG Scheduler)

Ausführen von XLANG-Ablaufplänen

Ausführung von XLANG-Ablaufplänen

Sicherheit für Hostanwendungen für XLANG-Ablaufplaninstanzen


Ändern der DSN-Einstellungen für eine COM+-Anwendung

  1. Zeigen Sie im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Komponentendienste.

  2. Erweitern Sie Komponentendienste in der Konsolenstruktur, erweitern Sie Computer, dann Arbeitsplatz und dann COM+-Anwendungen.

  3. Klicken Sie auf die COM+-Anwendung, deren Datenquellennamen-Einstellungen (DSN-Einstellungen) Sie ändern möchten. Klicken Sie im Menü Vorgang auf Eigenschaften.

  4. Klicken Sie auf der Registerkarte XLANG auf DSN konfigurieren.

    Das Dialogfeld ODBC-Datenquellenadministrator wird angezeigt.

  5. Ändern Sie die Einstellungen entsprechend Ihren Erfordernissen.

Vorsicht

  • Klicken Sie auf keinen Fall nach Änderungen an DSN-Einstellungen auf der Registerkarte XLANG auf Tabellen initialisieren. Durch diese Aktion werden alle Daten gelöscht, die sich bereits in der vorhandenen Datenbank befinden.

Wichtig

  • Der DSN und die COM+-Anwendung müssen denselben Namen tragen. Wenn beispielsweise die COM+-Anwendung den Namen XLANG-Ablaufplanung (XLANG Scheduler) trägt, muss der DSN ebenfalls XLANG-Ablaufplanung lauten.

  • Weitere Informationen zum Konfigurieren eines DSN und zum Verwenden von Datenquellen (ODBC) erhalten Sie, indem Sie im Dialogfeld ODBC-Datenquellenadministrator auf Hilfe klicken.

Anmerkungen

  • Zeigen Sie im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Komponentendienste, um Hilfe zur Verwaltung der Komponentendienste zu erhalten.

  • Weitere Informationen zu den Komponentendiensten und COM+ finden Sie in der MSDN Online Library-Website (msdn.microsoft.com/library/default.asp). Suchen Sie im Platform SDK nach "Component Services".

Verwandte Themen

Ausführen von XLANG-Ablaufplänen

Ausführung von XLANG-Ablaufplänen

Sicherheit für Hostanwendungen für XLANG-Ablaufplaninstanzen


Herunterfahren einer COM+-Hostanwendung für XLANG-Ablaufpläne

  1. Zeigen Sie im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Komponentendienste.

  2. Erweitern Sie Komponentendienste in der Konsolenstruktur, erweitern Sie Computer, dann Arbeitsplatz und dann COM+-Anwendungen.

  3. Klicken Sie auf die COM+-Anwendung, die als Host für XLANG-Ablaufpläne dient, die Sie herunterfahren möchten. Klicken Sie im Menü Vorgang auf Eigenschaften.

  4. Klicken Sie auf der Registerkarte XLANG im Bereich Kontrolliertes Herunterfahren auf Diese XLANG-Anwendung.

Vorsicht

  • Sie müssen dieses Verfahren anwenden, damit ein kontrolliertes Herunterfahren aller COM+-Anwendungen ausgeführt wird. Dadurch wird der Status aller aktiven XLANG-Ablaufpläne in der Persistenzdatenbank gespeichert. Weitere Informationen finden Sie unter Persistenz.

    Dagegen sollten Sie nicht mit der rechten Maustaste auf eine COM+-Anwendung klicken und auf Herunterfahren klicken. Dadurch können folgende Probleme auftreten:

    • Falls die aktiven XLANG-Ablaufpläne vollständig transaktional sind, werden bei einem unkontrollierten Herunterfahren sämtliche "Bei Fehler"- und "Kompensierung"-Fehlerbehandlungsverfahren ausgelöst.

    • Sind die aktiven XLANG-Ablaufpläne nicht vollständig transaktional, gehen in Verarbeitung befindliche Daten im Ablaufplan verloren.

Wichtig

  • Pausierende XLANG-Ablaufpläne können nicht neu gestartet werden, wenn der Datenquellenname (DSN) nicht verfügbar oder fehlerhaft konfiguriert ist. Weitere Informationen zum Konfigurieren eines DSNs für eine COM+-Anwendung, die als Host für XLANG-Ablaufpläne dient, finden Sie unter Konfigurieren einer COM+-Hostanwendung für XLANG-Ablaufpläne.

Anmerkungen

  • Beim Erstellen einer COM+-Hostanwendung für XLANG-Ablaufpläne ist die Option Pausierende XLANG-Anwendungen neu starten nicht verfügbar. Weitere Informationen zum erneuten Starten von pausierenden Anwendungen finden Sie unter Neu starten aller XLANG-Anwendungen.

  • Zeigen Sie im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Komponentendienste, um Hilfe zur Verwaltung der Komponentendienste zu erhalten. Klicken Sie in der Konsolenstruktur mit der rechten Maustaste auf Komponentendienste, und klicken Sie dann auf Hilfe.

  • Weitere Informationen zu den Komponentendiensten und COM+ finden Sie in der MSDN Online Library-Website (msdn.microsoft.com/library/default.asp). Suchen Sie im Platform SDK nach "Component Services".

Verwandte Themen

Konfigurieren einer COM+-Hostanwendung für XLANG-Ablaufpläne

Neu starten aller XLANG-Anwendungen

Ausführen von XLANG-Ablaufplänen

Ausführung von XLANG-Ablaufplänen

Herunterfahren aller XLANG-Anwendungen


Überwachen von aktiven XLANG-Ablaufplänen

Zur Überwachung aktiver XLANG-Ablaufpläne können Sie entweder den XLANG Event Monitor oder die Windows 2000-Ereignisanzeige verwenden.

  • XLANG Event Monitor.Beim Ausführen von XLANG-Ablaufplänen generiert das XLANG-Ablaufplanungsmodul verschiedene Arten von Ereignissen, die den Fortschritt der Ablaufplaninstanzen zeigen. Mithilfe des XLANG Event Monitors können Sie XLANG-Ablaufplanereignisse überwachen und den Fortschritt der Ablaufplaninstanzen anzeigen. Sie können sowohl die Standardanwendung XLANG-Ablaufplanung (XLANG Scheduler) als auch von Ihnen erstellte COM+-Hostanwendungen für XLANG-Ablaufpläne überwachen. Der XLANG Event Monitor kann sämtliche Ereignisse abonnieren, die von den Hostanwendungen auf beliebig vielen lokalen oder verteilten Computern veröffentlicht werden. Darüber hinaus kann der XLANG Event Monitor diese Ereignisse zur späteren Auswertung in einer Datei speichern.

    Weiterführende Informationen zum XLANG Event Monitor finden Sie in der zur Anwendung gehörenden Datei Readme.htm. Der XLANG Event Monitor (XLANGMon.exe) und die Infodatei, die vom Microsoft BizTalk Server 2000 Setup-Assistenten installiert werden, befinden sich im folgenden Installationsverzeichnis: \Programme\Microsoft BizTalk Server\SDK\XLANG-Tools.

  • Windows 2000-Ereignisanzeige. Die Windows 2000-Ereignisanzeige veröffentlicht Ereignismeldungen bezüglich der XLANG-Ablaufpläne. Weitere Informationen zum Anzeigen von Fehlermeldungen mithilfe der Ereignisanzeige finden Sie unter den folgenden Themen:
    • Informationen zum Konfigurieren der Ereignisanzeige zum Filtern nach Fehlermeldungen bezüglich XLANG-Ablaufplänen finden Sie unter Konfigurieren der Ereignisanzeige für BizTalk Server-Fehler.

    • Allgemeine Informationen zur Ereignisanzeige finden Sie in der Windows 2000 Server-Hilfe im Kapitel über die Ereignisanzeige unter "Verwenden der Ereignisanzeige".

Folgendes Thema wird in diesem Abschnitt behandelt:

  • Fehlermeldungen bei XLANG-Ablaufplänen

Verwandtes Thema

Konfigurieren der Ereignisanzeige für BizTalk Server-Fehler


Fehlermeldungen bei XLANG-Ablaufplänen

Die Fehlermeldungen in der folgenden Liste werden zurückgegeben, wenn der Fehler durch einen XLANG-Ablaufplan generiert wird. Die Meldungen können in der Windows 2000-Ereignisanzeige angezeigt werden.

Name der Meldung | Wert | Beschreibung
ID_CAT_UNKNOWN | 0x1 | SVC%0
ID_CAT_NAMESVC | 0x2 | NameSvc%0
ID_CAT_ENGINE | 0x3 | Engine%0
ID_CAT_SYSMGR | 0x4 | SystemMgr%0
ID_CAT_GRPMGR | 0x5 | GroupMgr%0
ID_CAT_WFSVCMGR | 0x6 | WFSvcMgr%0
ID_CAT_OBJECTMODEL | 0x7 | WFObjectModel%0
ID_CAT_BINDING | 0x8 | WFBinding%0
ID_CAT_COM_LAST | 0x9 | <>%0
IDS_I_MTSTOCOM_LAUNCH_FINISHED | 0x1000 | Ein nicht autorisierter Client versuchte, eine neue Instanz eines XLANG-Ablaufplanes zu erstellen. Der Rest der Monikerzeichenfolge und die ID des Clients werden in der folgenden Meldung angezeigt. Die Sicherheits-ID des Clients (SID) ist in Form von Binärdaten eingeschlossen: %1%0
ID_W_NOT_USER | 0x2001 | Ein nicht autorisierter Client versuchte, auf eine vorhandene Instanz eines XLANG-Ablaufplanes zuzugreifen. Der Rest der Monikerzeichenfolge und die ID des Clients werden in der folgenden Meldung angezeigt. Die Sicherheits-ID des Clients (SID) ist in Form von Binärdaten eingeschlossen: %1%0
IDS_E_COMSVCS_INTERNAL_ERROR | 0x3000 | Das XLANG-Ablaufplanungsmodul hat eine Inkonsistenz an seinem internen Zustand festgestellt. Wenden Sie sich an den Microsoft-Produktsupport, und melden Sie den folgenden Fehler: %1%0
IDS_COMSVCS_RESOURCE_ERROR | 0x3001 | Das XLANG-Ablaufplanungsmodul hat das Fehlen einer wichtigen Ressource festgestellt und den Hostprozess des Moduls veranlasst, die Ausführung des Moduls zu beenden: %1%0
IDS_COMSVCS_INTERNAL_ERROR_ASSERT | 0x3002 | Interner COM+-Fehler. Wenden Sie sich an den Microsoft-Produktsupport, und melden Sie diesen Fehler. Assertionsfehler: %1%0
ID_E_USER_EXCEPTION | 0x3003 | Das System hat eine geplante Komponente aufgerufen, aber diese Komponente fiel aus und generierte eine Ausnahme. Dies weist auf ein Problem mit der geplanten Komponente hin. Benachrichtigen Sie den Entwickler dieser Komponente über den Fehler, und stellen Sie die folgenden Informationen bereit: %1%2%0
ID_INITIALIZE_FOR_DTC | 0x3004 | Das XLANG-Ablaufplanungsmodul konnte nicht für Transaktionen initialisiert werden, die für die Unterstützung von Transaktionskomponenten erforderlich sind. Stellen Sie sicher, dass MS DTC ausgeführt wird: %1%0
ID_E_CANT_CREATE_COMPONENT | 0x3005 | Das XLANG-Ablaufplanungsmodul konnte eine Benutzerkomponente nicht erstellen, die für den aktiven XLANG-Ablaufplan erforderlich ist. Detaillierte Informationen werden in der folgenden Nachricht bereitgestellt. %1%0
ID_E_PROGID_NOT_FOUND | 0x3006 | Das XLANG-Ablaufplanungsmodul konnte die Programm-ID der folgenden Nachricht nicht in eine COM-Klassen-ID (CLSID) konvertieren: %1%0
ID_E_CANT_CREATE_INTERCEPTOR | 0x3007 | Das XLANG-Ablaufplanungsmodul konnte kein Interceptorobjekt für die in der folgenden Meldung aufgeführte Schnittstellen-ID erstellen. Mögliche Ursachen hierfür sind 1. die Schnittstelle wurde nicht ordnungsgemäß registriert, 2. es wurde keine Typbibliothek für diese Schnittstelle bereitgestellt, oder 3. die Datei mit den Informationen zu den Schnittstellentypen kann nicht geladen werden. Der Name des diesem Interceptorobjekt zugeordneten Ports lautet: %1%0
ID_E_INTF_NOT_SUPPORTED | 0x3008 | Das XLANG-Ablaufplanungsmodul hat eine Inkonsistenz zwischen der Portimplementierung und den COM-Komponenten entdeckt, auf die jene verweist. Eine in der Portimplementierung aufgeführte Komponente konnte die erwartete Schnittstelle nicht unterstützen. Die Klassen-ID der Komponente und die Schnittstellen-ID (IID), die die Komponente nicht unterstützen konnte, werden in der folgenden Meldung angezeigt. Der dieser Komponente zugeordnete Portname lautet: %1%0
ID_E_UNKNOWN_METHOD | 0x3009 | Das XLANG-Ablaufplanungsmodul empfing einen Aufruf für eine Methode, die in der Portimplementierung für diesen XLANG-Ablaufplan nicht angegeben wurde. Die Schnittstellen-ID (IID) und die Methodennummer werden in der folgenden Meldung angezeigt. Der Name des Ports, bei dem der Aufruf eintraf, lautet: %1%0
ID_E_UNKNOWN_IDISPATCH_METHOD | 0x300A | Das XLANG-Ablaufplanungsmodul empfing durch die IDispatch::Invoke()-Schnittstelle einen Aufruf für eine Methode, die nicht mehr vorhanden ist. Die Verteiler-ID dieser Methode wird in der folgenden Meldung angezeigt. Der Name des Ports, bei dem der Aufruf eintraf, lautet: %1%0
ID_E_NAMED_PARAMS | 0x300B | Das XLANG-Ablaufplanungsmodul empfing über die IDispatch::Invoke()-Schnittstelle einen Methodenaufruf, der benannte Argumente enthält. Erforderlich sind jedoch Positionsargumente. Die Verteiler-ID dieser Methode wird in der folgenden Meldung angezeigt. Der Name des Ports, bei dem der Aufruf eintraf, lautet: %1%0
ID_E_BAD_INVOKE_PARAMS | 0x300C | Das XLANG-Ablaufplanungsmodul empfing über die IDispatch::Invoke()-Schnittstelle einen Methodenaufruf mit einer falschen Anzahl von Argumenten. Die Schnittstellen-ID (IID) und die Verteiler-ID dieser Methode werden in der folgenden Meldung angezeigt. Der Name des Ports, bei dem der Aufruf eintraf, lautet: %1%0
ID_E_BAD_RETURN_POINTER | 0x300D | Das XLANG-Ablaufplanungsmodul empfing über die IDispatch::Invoke()-Schnittstelle einen falschen Ausgabeparameter von einer Methode. Der zurückgegebene Verweis war entweder ungültig (NULL oder ungültiger Zeiger) oder unterstützt die erwartete Schnittstelle nicht. Die erwartete Verteiler-ID wird in der folgenden Meldung angezeigt. Der Name der Nachricht mit dem ungültigen Portverweis lautet: %1%0
ID_E_ACCESS_CHECK_FAILURE | 0x300E | Das XLANG-Ablaufplanungsmodul konnte die Anforderung des Clients zur Monikerauflösung nicht autorisieren. Der Zugriff wird verweigert.%0
ID_E_BAD_INVOKE | 0x300F | Fehler beim Aufrufen der IDispatch::Invoke()-Schnittstelle für eine Methode. Die Verteiler-ID dieser Methode wird in der folgenden Meldung angezeigt. Der Name des Ports, bei dem der Aufruf versucht wurde, lautet: %1%0
ID_E_INVOKED_METHOD | 0x3010 | Die aufgerufene Methode, deren Verteiler-ID in der folgenden Meldung angezeigt wird, meldete einen Fehler. Der Name des Ports, bei dem der Aufruf versucht wurde, lautet: %1%0
ID_E_CANT_GET_TYPEINFO | 0x3011 | Die Komponente, deren Portname und COM-Klassen-ID in der folgenden Meldung angezeigt werden, konnte dem XLANG-Ablaufplanungsmodul die erforderlichen Typinformationen nicht zur Verfügung stellen.%1%0
ID_E_CANT_INVOKE_METHOD | 0x3012 | Das XLANG-Ablaufplanungsmodul war nicht in der Lage, einen Methodenaufruf an das Objekt zu übermitteln, das dem in der folgenden Meldung angezeigten Portnamen zugeordnet ist. Die Namen der aufgerufenen Schnittstelle und der Methode werden ebenfalls angezeigt.%1%0
ID_E_CANT_GET_CLASSINFO | 0x3013 | Die Komponente, deren Portname und COM-Klassen-ID in der folgenden Meldung angezeigt werden, konnte dem XLANG-Ablaufplanungsmodul die erforderlichen Typinformationen zum Schnittstellenaufruf IProvideClassInfo::GetClassInfo nicht zur Verfügung stellen.%1%0
ID_E_SCRIPT_ERROR | 0x3014 | Eine in ein Skript eingebundene Entscheidungsregel einer XLANG-Ablaufplaninstanz konnte nicht ausgeführt werden. Der vom Skriptmodul zurückgegebene Fehler wird in der folgenden Meldung angezeigt. Der Quellcode des Skripts und die Informationen zur Ablaufplaninstanz, in der der Fehler auftrat, werden ebenfalls bereitgestellt.%1%0
ID_E_SCRIPT_ERROR_NOINFO | 0x3015 | Eine in ein Skript eingebundene Entscheidungsregel einer XLANG-Ablaufplaninstanz ist fehlgeschlagen. Detaillierte Informationen zu der Fehlerursache konnten wegen eines internen Fehlers nicht ermittelt werden. Der Fehlercode ist unten angezeigt.%1%0
ID_E_SCRIPT_BADCONV | 0x3016 | Eine in ein Skript eingebundene Entscheidungsregel einer XLANG-Ablaufplaninstanz verwies auf ein Nachrichtenfeld, dessen Typ mit dem VBScriptmodul nicht kompatibel ist. Das XLANG-Ablaufplanungsmodul versuchte vergeblich, das Feld in einen kompatiblen Typ zu konvertieren. Die in der folgenden Meldung angezeigten Informationen enthalten die Skriptregel, die Nachricht und das betreffende Feld sowie den ursprünglichen Feld-Variant-Typ und den Typ, in den das Feld konvertiert werden sollte. Die VARIANT-Datenstruktur des Feldes ist an diesen Protokolleintrag in binärer Form angehängt.%1%0
ID_E_SCRIPT_BADARRAY | 0x3017 | Eine in ein Skript eingebundene Entscheidungsregel einer XLANG-Ablaufplaninstanz verwies auf ein Nachrichtenfeld, dessen Arraytyp mit dem VBScriptmodul nicht kompatibel ist. VBScript unterstützt nur Arrays vom Datentyp Variant. Die in der folgenden Meldung angezeigten Informationen enthalten die Skriptregel, die Nachricht und das betreffende Feld. Die VARIANT-Datenstruktur des Feldes ist an diesen Protokolleintrag in binärer Form angehängt.%1%0
ID_E_SCRIPT_BADEXPR | 0x3018 | Eine in ein Skript eingebundene Entscheidungsregel einer XLANG-Ablaufplaninstanz enthielt einen Ausdruck, der keinen booleschen Wert als Ergebnis zurückgab. Die in der folgenden Meldung angezeigten Informationen enthalten die Skriptregel und den betreffenden Ausdruck. Die vom Ausdruck zurückgegebene VARIANT-Datenstruktur ist an diesen Protokolleintrag in binärer Form angefügt.%1%0
ID_E_SCHEDULE_NOT_RUNNING | 0x3019 | Das XLANG-Ablaufplanungsmodul empfing einen Aufruf für ein Objekt, das einem Port einer nicht aktiven XLANG-Ablaufplaninstanz zugeordnet ist. Der Name des Ports, bei dem der Aufruf eintraf, lautet: %1%0
ID_E_INTERNAL_EXCEPTION | 0x301A | Interne COM+-Ausnahme. Wenden Sie sich an den Microsoft-Produktsupport, und melden Sie diesen Fehler. Geben Sie dabei die unten aufgeführten Informationen an.%1%2%0
ID_E_BAD_DATAFLOW_NOMESSAGE | 0x301B | Problem in der Datenflussspezifikation. Eine im aktiven XLANG-Ablaufplan als Datenquelle angezeigte Nachricht ist nicht verfügbar. Detaillierte Informationen werden in der folgenden Meldung bereitgestellt. %1%0
ID_E_BAD_ARGUMENTVALUE | 0x301C | Eines der als Argument für einen COM-Methodenaufruf verwendeten Felder enthält einen falschen Wertetyp. Die Ursache für diesen Fehler ist möglicherweise ein falscher oder fehlender Datenfluss. Detaillierte Informationen werden in der folgenden Meldung bereitgestellt. %1%0
ID_E_DEEP_VARIANT_NESTING | 0x301D | Eines der als Argument für einen COM-Methodenaufruf verwendeten Felder enthält mehr als eine Schachtelungsebene für den Datentyp Variant. Die SchnittstellenID (IID) und die Verteiler-ID der Methode werden in der folgenden Meldung angezeigt. Der Name des Ports, bei dem der Aufruf eintraf, lautet: %1%0
ID_E_BAD_MAPPORTVALUE | 0x301E | Ein Feld mit einem zugeordneten Port ist ungültig. Detaillierte Informationen werden in der folgenden Meldung bereitgestellt. %1%0
ID_E_BAD_CALLPARAMNUMBER | 0x301F | Einem Aufruf wurde eine falsche Anzahl von Argumenten übergeben. Detaillierte Informationen werden in der folgenden Meldung bereitgestellt. %1%0
ID_E_EXECUTINGCALLEDSCHEDULE | 0x3020 | Der XLANG-Ablaufplan kann nicht auf der obersten Ebene ausgeführt werden, da ihm Kontextargumente übergeben werden müssen. Detaillierte Informationen werden in der folgenden Meldung bereitgestellt. %1%0
ID_E_CANT_GET_SUPPORTERRORINFO | 0x3021 | Die Komponente, deren Portname und COM-Klassen-ID in der folgenden Meldung angezeigt werden, konnte dem XLANG-Ablaufplanungsmodul über ISupportErrorInfo::InterfaceSupportsErrorInfo keine positive Meldung für die Schnittstelle zurückgeben, die es eigentlich unterstützt.%1%0
ID_E_PERSIST_FAILURE | 0x3022 | Der Status der Ablaufplaninstanz konnte nicht in der Datenbank gespeichert werden. Detaillierte Informationen werden in der folgenden Meldung bereitgestellt. %1%0
ID_E_TRANSACTION_COMMIT_FAILURE | 0x3023 | Das System konnte keinen Commit für einen Transaktionskontext ausführen. Detaillierte Informationen werden in der folgenden Meldung bereitgestellt. %1%0
ID_E_TRANSACTION_ABORTED | 0x3024 | Das System brach einen Transaktionskontext ab. Detaillierte Informationen werden in der folgenden Meldung bereitgestellt. %1%0
ID_E_TRANSACTION_ABORT_FAILURE | 0x3025 | Das System konnte einen Transaktionskontext nicht abbrechen. Der Status der Transaktion ist nicht bekannt. Detaillierte Informationen werden in der folgenden Meldung bereitgestellt. %1%0
ID_E_PENDINGREHYDRATIONERROR | 0x3026 | Die Aktivierungsanwendung hat einen Fehler entdeckt und wird deshalb beendet. Dadurch werden einige Aktivierungsanforderungen fehlschlagen. Starten Sie den Dienst für das XLANG-Ablaufplanungsmodul neu. Detaillierte Informationen werden in der folgenden Meldung bereitgestellt. %1%0
ID_E_REHYDRATIONONSTARTUPERROR | 0x3027 | Wegen eines Systemfehlers konnte mindestens ein XLANG-Ablaufplan nicht aktiviert werden. Möglicherweise traten Probleme beim Lesen der Datenbank oder mit den gelesenen Daten auf. Detaillierte Informationen werden in der folgenden Meldung bereitgestellt. %1%0
ID_E_REHYDRATIONERROR | 0x3028 | Fehler beim Aktivieren eines XLANG-Ablaufplanes. Möglicherweise traten Probleme beim Lesen der Datenbank oder mit den gespeicherten Informationen auf. Wahrscheinlich wurde der XLANG-Ablaufplan nicht ordnungsgemäß pausiert. Detaillierte Informationen werden in der folgenden Meldung bereitgestellt. %1%0
ID_E_FOUNDINITIALIZEDTHREAD | 0x3029 | Der Dienst für das XLANG-Ablaufplanungsmodul hat beim Verarbeiten eines XLANG-Ablaufplanes einen kritischen Threadverwaltungsfehler entdeckt. Der Ablaufplan wird möglicherweise fehlschlagen. Wenden Sie sich an den Technischen Support.%1%0
ID_E_CALLONCOMPLETEDSCHEDULE | 0x302A | Der Dienst für das XLANG-Ablaufplanungsmodul empfing einen Aufruf einer bereits abgeschlossenen XLANG-Ablaufplaninstanz. Diese Ablaufplaninstanz wurde bereits aus dem Speicher entfernt. Die Schnittstellen-ID wird in der folgenden Meldung angezeigt.%1%0
IDS_MSG_TIMEBOMB_EXPIRED | 0x302B | Vielen Dank, dass Sie Microsoft BizTalk Server 2000 evaluieren. Der Zeitraum für diese Evaluierungsversion ist abgelaufen. Wenden Sie sich an Microsoft oder einen Softwarehändler, um eine lizenzierte Version von Microsoft BizTalk Server 2000 zu erwerben.%0
ID_E_FIELDPORTPERSISTENCEERROR | 0x302C | Fehler beim persistenten Speichern einer XLANG-Ablaufplaninstanz. Detaillierte Informationen werden in der folgenden Meldung bereitgestellt. %1%0
ID_E_FIELDPORTREHYDRATIONERROR | 0x302D | Fehler beim Wiederherstellen einer bestimmten Subkomponente einer XLANG-Ablaufplaninstanz aus der Datenbank. Detaillierte Informationen werden in der folgenden Meldung bereitgestellt. %1%0
ID_E_SCHEDULEDONE | 0x3030 | Beim Markieren der Aktivitäten der XLANG-Ablaufplaninstanz hat das XLANG-Ablaufplanungsmodul einen Fehler festgestellt. Die Datenbank konnte nicht aktualisiert werden, oder ein anderer Fehler wurde während der letzten Phase festgestellt. Detaillierte Informationen werden in der folgenden Meldung bereitgestellt. %1%0
ID_E_COMPONENT_INCOMPATIBLE_TXN | 0x3031 | Beim Instanziieren einer Komponente hat das XLANG-Ablaufplanungsmodul einen Fehler entdeckt. Entweder war die Komponente zuvor in eine andere Transaktion eingebunden, oder sie war überhaupt nicht in eine Transaktion eingebunden, und die derzeitige Instanziierung erfordert eine Transaktion. Detaillierte Informationen werden in der folgenden Meldung bereitgestellt. %1%0
ID_E_SUSPEND_FAILURE | 0x3032 | Die XLANG-Ablaufplaninstanz konnte nicht angehalten werden. Detaillierte Informationen werden in der folgenden Meldung bereitgestellt. %1%0
ID_E_INITNEW | 0x3033 | Beim Durchführen von IPersistStreamInit::InitNew wurde dem XLANG-Ablaufplanungsmodul ein Fehler zurückgemeldet. Die Klassen-ID der Komponente und der Fehlercode werden in der folgenden Meldung angezeigt. Der dieser Komponente zugeordnete Portname lautet: %1%0
ID_E_POSSIBLEBYOTISSUE | 0x3034 | Die von Ihnen angeforderte Komponente konnte nicht erstellt werden. Möglicherweise wurde die BYOT-Komponente auf diesem Computer innerhalb einer COM+-Anwendung konfiguriert. Diese Einstellung ist mit dem XLANG-Dienst für die Ablaufplanung nicht kompatibel. Der dieser Komponente zugeordnete Portname lautet: %1%0
ID_E_FIELDPROCESSINGERROR | 0x3035 | Der bereitgestellte Feldwert war ungültig. Detaillierte Informationen werden in der folgenden Meldung bereitgestellt. %1%0
ID_E_NO_OBJECT | 0x3036 | Der XLANG-Ablaufplan konnte nicht instanziiert werden. Detaillierte Informationen werden in der folgenden Meldung bereitgestellt. %1%0
ID_E_STARTUP_FAILED | 0x3037 | Fehler beim Starten von mindestens einem der XLANG-Gruppen-Manager. Fehler: %1%0
ID_E_NON_SCRIPT_BADEXPR | 0x3038 | Eine XLANG-Ablaufplaninstanz enthält eine Regel, die Felder anhand unzulässiger Datentypen vergleicht. Detaillierte Informationen werden in der folgenden Meldung bereitgestellt. %1%0
E_BTW_PERSIST_REACHEDEOF | 0x3039 | Das Recordset kann diese Zeile nicht zurückgeben, da das Dateiende erreicht wurde.%1%0
ID_E_BAD_DATAFLOW_EMPTYFIELD | 0x3040 | Problem in der Datenflussspezifikation. Ein als Datenquelle angezeigtes Feld ist leer. Möglicherweise konnte es zuvor nicht persistent gespeichert werden. Detaillierte Informationen werden in der folgenden Meldung bereitgestellt. %1%0
ID_E_CANT_OPEN_DEADLETTER_QUEUE | 0x3041 | Das XLANG-Ablaufplanungsmodul konnte die XLANG-Warteschlange für unzustellbare Nachrichten für die COM+-Hostanwendung nicht erstellen oder öffnen. Der Name der COM+-Anwendung, bei der der Fehler auftrat, lautet: %1%0
ID_E_CANT_XFER_TO_DEADLETTER_QUEUE | 0x3042 | Das XLANG-Ablaufplanungsmodul konnte eine ungültige Nachricht nicht in die XLANG-Warteschlange für unzustellbare Nachrichten für die COM+-Hostanwendung übertragen. Der Name der COM+-Anwendung, bei der der Fehler auftrat, lautet: %1%0
ID_E_CANT_LOADMODULE | 0x3043 | Das XLANG-Ablaufplanungsmodul konnte ein benötigtes Modul nicht laden. Mögliche Ursachen sind Kompilierungsfehler oder semantische Fehler innerhalb des Moduls. Detaillierte Informationen werden in der folgenden Meldung bereitgestellt: %1%0
ID_E_USER_DATA_EXCEPTION | 0x3044 | Ein Wert von einem Client hat eine Ausnahme hervorgerufen. Dies wurde möglicherweise durch eine falsche Speicherzuordnung für die Daten verursacht, durch einen Konflikt beim Zählen von Verweisen oder durch Datenbeschädigung. Die wahrscheinlichste Ursache für das Problem liegt im Clientcode. Detaillierte Informationen werden in der folgenden Meldung bereitgestellt: %1%2%0
E_BTW_INTERNAL_ERROR | 0x4001 | Interner Fehler. %1%0
E_EXPORT_FAILED | 0x4002 | Der XLANG-Ablaufplan konnte nicht verarbeitet werden.%0
E_BTW_UNKNOWN_SHAPE | 0x4003 | Der Compiler kann diese Form nicht interpretieren, da sie unbekannt ist.%0
E_BTW_INCOMPLETE_FLOW | 0x4004 | Unvollständiger Ablauf aufgrund einer fehlenden Verbindung.%0
E_BTW_INCOMPLETE_FLOW_LEFT | 0x4005 | Unvollständiger Ablauf. Die Form muss an der linken Verbindung mit einem Ablauf verbunden sein.%0
E_BTW_INCOMPLETE_FLOW_RIGHT | 0x4006 | Unvollständiger Ablauf. Die Form muss an der rechten Verbindung mit einem Ablauf verbunden sein.%0
E_BTW_INCOMPLETE_FLOW_LATERAL | 0x4007 | Unvollständiger Ablauf. Die Form ist an der Seite mit keinem Objekt verbunden.%0
E_BTW_INCOMPLETE_FLOW_TOP | 0x4008 | Unvollständiger Ablauf. Die Form muss an der oberen Verbindung mit einem Ablauf verbunden sein.%0
E_BTW_INCOMPLETE_FLOW_BOTTOM | 0x4009 | Unvollständiger Ablauf. Die Form muss an der unteren Verbindung mit einem Ablauf verbunden sein.%0
E_BTW_INCOMPLETE_FLOW_ANYLINE | 0x400A | Unvollständiger Ablauf. Es ist keine Verbindung zu einer Form vorhanden.%0
E_BTW_MIRRORLIST_INCONSISTENT | 0x400B | Auf den Fehler- oder Kompensierungsseiten wurden keine Spiegelformen gefunden. Ersetzen Sie die Form durch eine andere Form.%0
E_BTW_BEGIN_INSIDE_TRANSACTION | 0x4010 | Die Beginn-Form darf nicht von einer Transaktion umschlossen sein.%0
E_BTW_END_MULTIPLE_LOOP | 0x4020 | In einer Schleifenverzweigung darf nur eine Ende-Form verwendet werden.%0
E_BTW_END_IN_TRANSACTION | 0x4021 | Eine Ende-Form kann in diesem Kontext nicht verwendet werden.%0
E_BTW_SYNCACTION_NO_PAIR | 0x4030 | Beim Binden an einen COM-Port müssen Aktionen paarweise verwendet werden.%0
E_BTW_INCOMPLETE_FLOW_BINDING | 0x4031 | Für diese Aktion oder diesen Port ist keine Bindung vorhanden.%0
E_BTW_FIELD_TYPE_NOT_SUPPORTED | 0x4040 | Der Typ (Variant-Typ=%1) wird nicht unterstützt.%0
E_BTW_ROLE_NOT_SUPPORTED | 0x4050 | Aufträge (XLANG-Ablaufpläne mit Rollen) können nicht kompiliert werden.%0
E_BTW_EMPTY_TRANSACTION | 0x4060 | Die Transaktion enthält keine gültigen Formen.%0
E_BTW_TRANSACTION_NOT_PERMITTED | 0x4061 | Transaktions-Formen sind unzulässig, wenn der XLANG-Ablaufplan wie eine COM+-Komponente behandelt wird. Entfernen Sie die Transaktion, oder bearbeiten Sie die Eigenschaften der Beginn-Form, um das Transaktionsmodell zu ändern.%0
E_BTW_TRANSACTION_BOUNDARIES_CROSSED | 0x4062 | Ein Ablauf kann außerhalb einer Transaktion nicht mit einer Form innerhalb einer Transaktion verbunden werden, ohne zuerst den Ablauf mit der Transaktion zu verbinden. Um den Ablauf mit der Transaktion zu verbinden, ziehen Sie ihn an den oberen Verbindungspunkt der Transaktion. Anschließend klicken Sie auf die Transaktion, um sie zu markieren. Ziehen Sie einen weiteren Ablauf vom Verbindungspunkt der Transaktion zur ersten Form innerhalb der Transaktion. Um einen Ablauf zu ziehen, der die Transaktion verlässt, müssen Sie zuerst den Ablauf mit dem Verbindungspunkt an der unteren Seite der Transaktion verbinden. Anschließend klicken Sie auf die Transaktion, um sie zu markieren. Ziehen Sie einen weiteren Ablauf vom unteren Verbindungspunkt zur nächsten Form des Geschäftsprozesses.%0
E_BTW_TRANSACTION_TERMINATED_PREMATURELY | 0x4063 | Mindestens ein Pfad innerhalb der Transaktion muss aus der Transaktion heraus führen.%0
E_BTW_NO_RULES_FOR_SWITCH | 0x4070 | Entscheidungs-Formen müssen mindestens eine Regel enthalten.%0
E_BTW_CANNOT_WAIT_ON_ALL_SWITCH_BRANCHES | 0x40A0 | Es kann nicht auf alle Verzweigungen der Entscheidung gewartet werden.%0
E_BTW_NO_BRANCH_FOUND | 0x40A1 | Die Verknüpfung kann die entsprechende Verzweigung oder Entscheidung nicht finden.%0
E_BTW_JOIN_MISMATCH | 0x40A2 | In einer bestimmten Verzweigung oder Entscheidung kann nur eine Verknüpfung verwendet werden.%0
E_BTW_JOIN_SHARED | 0x40A3 | Für Abläufe, die von unterschiedlichen Verzweigungen oder Entscheidungen ausgehen, kann nicht ein und dieselbe Verknüpfung verwendet werden.%0
E_BTW_CANNOT_WAIT_ON_SOME_SWITCH_BRANCHES | 0x40A4 | Nicht alle Pfade führen von der Entscheidung zur Verknüpfung.%0
E_BTW_CANNOT_WAIT_ANY_ON_FORK_BRANCHES | 0x40A5 | "Or" kann nicht abgewartet werden. Die Verzweigungen enthalten Verarbeitungsformen, die möglicherweise nie beendet werden und deshalb zu blockierten Ablaufplänen führen können.%0
E_BTW_DATAFLOW_DISALLOWED_ON_BTM_PORT | 0x40C0 | Dieser Port kann nicht in mehreren Empfangsaktionen gleichzeitig oder innerhalb einer einzelnen Empfangsaktion in einer Schleife verwendet werden.%0
E_BTW_MESSAGE_TECH_NOT_FOUND | 0x4110 | Die Nachricht ist an keinen Port gebunden.%0
E_BTW_MESSAGE_TYPE_MISMATCH | 0x4111 | Die Nachricht wurde im Zusammenhang mit den konfliktverursachenden Typen "%1" und "%2" verwendet.%0
E_BTW_MISSING_TECHNOLOGY | 0x4120 | Die Liste der verfügbaren Methoden für diesen Kommunikationsfluss wurde geändert. Führen Sie den Methodenkommunikations-Assistenten erneut aus, um eine andere Methode auszuwählen, und aktualisieren Sie den Kommunikationsfluss.%0
E_BTW_MISSING_PORT_DATAFLOW | 0x41A0 | Die Einstellungen dieses Ports zeigen an, dass er außerhalb des XLANG-Ablaufplanungsmoduls erstellt wurde. Sie müssen die Quelle des Portverweises durch eine Verbindung vom entsprechenden Nachrichtenfeld bestimmen.%0
E_BTW_CIRCULAR_DATAFLOW | 0x41A1 | Es scheint ein zirkulärer Pfad innerhalb des Datenflusspfades für diesen XLANG-Ablaufplan zu existieren.%0
E_BTW_LOOP_NORULE | 0x41D0 | Eine Regel wurde nicht definiert.%0
E_BTW_LOOP_BODY_EXITS_TRANSACTION | 0x41D1 | Der Text der Schleife kann die einschließende Transaktion nicht verlassen.%0
E_BTW_LOOP_BODY_END_MISSING | 0x41D2 | Das Ende des Nachrichtentextes dieser Schleife kann nicht gefunden werden.%0
E_BTW_ABORT_NOT_IN_TXN | 0x41E0 | Abbruch-Formen müssen mit einer einschließenden Transaktion verknüpft sein.%0
E_BTW_ABORT_CONTEXT_INVALID_SCOPE | 0x41E1 | Abbruch-Formen können nur auf den aktuellen oder übergeordneten Kontext verweisen.%0
E_BTW_END_MULTIPLE_ABORT | 0x41E2 | Mehrere Ende-Formen sind auf der Fehlerseite nicht zulässig.%0
E_BTW_COMPILER_FAILED | 0x5000 | Fehler beim Kompilieren von "%1".%0
E_BTW_PARSE_FAILED | 0x5001 | Fehler beim Analysieren.%0
E_BTW_FIXUP_FAILED | 0x5002 | Fehler bei der Korrektur.%0
E_BTW_VALIDATION_FAILED | 0x5003 | Fehler bei der Überprüfung.%0
E_BTW_NODE_FAILURE | 0x5004 | Bei Knoten "%1" (%2!d!,%3!d!).%0
E_BTW_STACK_TOO_MANY_ITEMS | 0x5005 | Auf dem Stack wurden zu viele Objekte gefunden.%0
E_BTW_STACK_UNEXPECTED_NODE | 0x5006 | Ein unerwarteter Knoten wurde gefunden.%0
E_BTW_XMLQUERY_RETURNED_ZERO_NODES | 0x5007 | Die XML-Abfrage gab keinen Knoten zurück.%0
E_BTW_XMLQUERY_RETURNED_MULTIPLE_NODES | 0x5008 | Die XML-Abfrage gab mehrere Knoten zurück.%1%0
E_BTW_XMLQUERY_MISSING_ATTRIBUTE | 0x5009 | Erforderliches Attribut "%1" hat keinen Wert.%0
E_BTW_LOAD_MODULE_FAILED | 0x500A | Fehler beim Laden von Modul "%1".%0
E_BTW_XML_LOAD_FAILED | 0x500B | Die XML-DOM-Schnittstelle meldete einen Fehler bei "%1!d!, %2!d!".%0
E_BTW_ERROR_LOADING_PACKAGE | 0x500C | 0x%1!X!-Fehler beim Laden von URL: "%2".%0
E_BTW_NAMED_LIST_HAS_DUPLICATE_ENTRIES | 0x500D | Die Liste enthält doppelte Einträge mit dem Namen "%1".%0
E_BTW_REQUIRED_ELEMENT_MISSING | 0x500E | Erforderliches Element "%1" fehlt.%0
E_BTW_ELEMENT_MISSING_VALUE | 0x5100 | Der Elementwert fehlt.%0
E_BTW_REFERENCE_RESOLVE_FAILED | 0x5110 | "%1" mit Ortsangabe "%2" kann nicht aufgelöst werden.%0
E_BTW_CONTEXTREF_INVALID_REFERENCE | 0x5120 | Die Rückgabe bzw. Freigabe bei unabhängigem (nicht einschließendem) Kontext ist nicht zulässig.%0
E_BTW_CONTEXTREF_SELF_REFERENCE | 0x5121 | Die Rückgabe bzw. Freigabe unter Bezugnahme auf einen Kontext innerhalb jenes Kontextes ist nicht zulässig.%0
E_BTW_ASYNC_ACTION_COM_NOT_ALLOWED | 0x5400 | Eine asynchrone Aktion muss auf einen COM-fremden Port verweisen.%0
E_BTW_CONNECTION_PORT_HAS_TECH_BINDING | 0x5490 | Der in einer Verbindung verwendete Port "%1" darf keine Technologiebindung aufweisen.%0
E_BTW_CONNECTION_PORT_REUSED | 0x5491 | Der in einer Verbindung verwendete Port "%1" wurde bereits vorher in einem XLANG-Ablaufplan verwendet.%0
E_BTW_TRANSACTIONS_NESTED | 0x54B0 | Bei geschachtelten Transaktionen muss die äußere Transaktion langlebig sein.%0
E_BTW_TRANSACTIONS_NESTED_RETRY | 0x54B1 | Bei geschachtelten Transaktionen können die äußeren Transaktionen keine Wiederholungsanzahl haben.%0
E_BTW_MESSAGE_HAS_NO_DECL | 0x5520 | Nachricht "%1" hat keine zugeordnete Deklaration.%0
E_BTW_MESSAGE_HAS_UNSATISFIED_DATA_DEPENDENCIES | 0x5521 | Nachricht "%1" enthält unberücksichtigte Datenabhängigkeiten in Bezug auf "%2". Diese Abhängigkeiten werden entweder im Ablauf nicht erstellt oder möglicherweise an einem Port erwartet, für den die Option Keine Instanziierung ausgewählt wurde.%0
E_BTW_PORT_HAS_NO_BINDING | 0x5570 | Port "%1" hat keine zugeordnete Bindung.%0
E_BTW_PORT_HAS_UNSATISFIED_DATA_DEPENDENCIES | 0x5571 | Port "%1" enthält unberücksichtigte Datenabhängigkeiten in Bezug auf Nachrichten "%2". Diese Abhängigkeiten werden entweder im Ablauf nicht erstellt oder möglicherweise an einem Port erwartet, für den die Option Keine Instanziierung ausgewählt wurde.%0
E_BTW_RULE_HAS_NO_BINDING | 0x55B0 | Regel "%1" hat keine zugeordnete Bindung. %0
E_BTW_SCHEDULE_SUSPENDED | 0x55E0 | Der XLANG-Ablaufplan wurde angehalten.%0
E_BTW_SCHEDULE_STOPPED | 0x55E1 | Der XLANG-Ablaufplan wurde beendet.%0
E_BTW_PERSIST_FAILED | 0x55E2 | Der Status der XLANG-Ablaufplaninstanz konnte nicht in der Datenbank gespeichert werden.%0
E_BTW_SUSPEND_FAILED | 0x55E3 | Der XLANG-Ablaufplan konnte nicht angehalten werden.%0
E_XLANG_SHUTTINGDOWN | 0x55E4 | Die XLANG-Anwendung wird beendet.%0
E_BTW_MISSING_MESSAGE_BINDING_ON_PORT | 0x5730 | Die Aktion verwendet Port"%1", dessen Bindung nicht die Bindung für Nachricht "%2" definiert.%0
E_BTW_MISSING_INCOMING_PORTREF | 0x5731 | Die von dieser Empfangsaktion verwendete Nachricht enthält ein Feld (%1), das mit einem Portverweis (%2) verbunden ist, obwohl die Datenflussverbindungen nicht angeben, ob der Portverweis empfangen werden soll.%0
E_BTW_SOURCE_PORT_HAS_NOINVOCATION | 0x5740 | Die Sendeaktion verweist auf Port "%1", für den die Option Keine Instanziierung ausgewählt wurde.%0
E_BTW_MISSING_OUTGOING_PORTREF | 0x5741 | Die von dieser Sendeaktion verwendete Nachricht enthält ein Feld (%1), das mit einem Portverweis (%2) verbunden ist, obwohl die Datenflussverbindungen nicht angeben, ob der Portverweis gesendet werden soll.%0
E_BTW_TASK_LIMIT | 0x5750 | Der Task umfasst "%1!d!" Aktionen. Die aktuelle Begrenzung beträgt "%2!d!".%0
E_BTW_SYNC_DIFFERENT_PORTS | 0x5760 | Synchrones Aktionspaar verweist auf unterschiedliche Ports: "%1" und "%2".%0
E_BTW_SYNC_SAME_MESSAGE | 0x5761 | Synchrones Aktionspaar verweist auf dieselbe Nachricht: "%1".%0
E_BTW_SYNC_ONLY_COM_ALLOWED | 0x5762 | Synchrones Aktionspaar darf nur auf COM-Port verweisen.%0
E_BTW_SYNC_SECOND_MESSAGE_MUST_BE_OUT_FOR_FIRST_MESSAGE | 0x5763 | Bei einem synchronen Aktionspaar muss die Nachricht in der zweiten Aktion die Ausgangsnachricht für die Nachricht in der ersten Aktion sein.%0
E_BTW_INVALID_DELAY_TIME | 0x5770 | Die Verzögerungszeit (%1!d!) ist ungültig. Es ist nicht möglich, für die Verzögerungszeit eine negative Zahl anzugeben.%0
E_BTW_CALL_MESSAGE_SCHEMA_NAME_MISMATCH | 0x5800 | Der Nachrichtenspezifikationsname "%1" für die Nachricht "%2" im aufrufenden XLANG-Ablaufplan stimmt nicht mit dem Spezifikationsnamen "%3" im aufgerufenen XLANG-Ablaufplan überein.%0
E_BTW_CALL_MESSAGE_SCHEMA_REPRESENTATION_MISMATCH | 0x5801 | Die Nachrichtenspezifikationsdarstellung für die Nachricht "%1" im aufrufenden XLANG-Ablaufplan stimmt nicht mit der Spezifikationsdarstellung im aufgerufenen XLANG-Ablaufplan überein.%0
E_BTW_ASSIGNMENT_PORT_HAS_TECH_BINDING | 0x5830 | Der in einem Assignment in einem cut-Formular verwendete Port "%1" kann keine Technologiebindung aufweisen.%0
E_BTW_PARTITION_LIMIT | 0x5850 | Die Partition hat "%1!d!" Prozesse. Die aktuelle Begrenzung beträgt "%2!d!".%0
E_BTW_MESSAGE_USED_IN_PARALLEL | 0x5851 | Parallele Aktionen/Prozesse verwenden dieselbe Nachricht "%1".%0
E_BTW_PORT_USED_IN_PARALLEL | 0x5852 | Parallele Aktionen/Prozesse verwenden denselben Port "%1".%0
E_BTW_INVALID_RETRY_COUNT | 0x5A30 | Die Wiederholungsanzahl "%1!d!" ist ungültig. Die Wiederholungsanzahl kann nicht negativ sein.%0
E_BTW_INVALID_BACKOFF_VALUE | 0x5A31 | Der Backoffwert "%1!d!" ist ungültig. Dieser Wert kann nicht negativ sein.%0
E_BTW_INVALID_TIMEOUT_VALUE | 0x5A32 | Der Timeoutwert "%1!d!" ist ungültig. Dieser Wert kann nicht negativ sein.%0
E_BTW_FIELD_RESERVED_NAME | 0x5A50 | %1 ist als Feldname reserviert.%0
E_BTW_ELEMENT_TYPE_NOT_DEFINED | 0x5A51 | Der Elementtyp "%1" ist nicht definiert.%0
E_BTW_ELEMENT_TYPE_INCOMPLETE | 0x5A70 | Die Elementtypdefinition ist unvollständig. Geben Sie Unterelemente oder dt:type an.%0
E_BTW_MULTIPLE_PORTS | 0x5A90 | Unterschiedliche Ports "%1" und "%2" werden für dasselbe Feld verwendet.%0
E_XLANG_INVALID_COMPARE_TYPE | 0x5A91 | Vergleiche sind für diesen Datentyp unzulässig.%0
E_BTW_FIELD_NOT_MATCHING_SCHEMA_ELEMENT | 0x5A92 | FieldBinding für "%1" hat kein entsprechendes Element im Schema bei Position "%2!d!".%0
E_BTW_FIELD_HAS_AMBIGUOUS_DATAFLOW | 0x5A93 | Ein Nachrichtenfeld kann nicht zugleich einen Datenfluss von einem anderen Nachrichtenfeld und einen Verweis auf einen Port besitzen. Einer der Datenflüsse muss entfernt werden.%0
E_BTW_PORT_TARGET_INVALID | 0x5A94 | Der Typ dieses Feldes ist für die Verwendung als Portverweis ungeeignet. Ports, die an eine COM-Komponente gebunden sind, können als Objektverweise oder Zeichenfolgen übermittelt werden. Ports, die an Nachrichtenwarteschlangen gebunden sind, dürfen nur als Zeichenfolgen übermittelt werden. Interne Ports können nur als Objektverweise übermittelt werden.%0
E_BTW_FIELD_TARGET_INVALID | 0x5A95 | Das Zielfeld "%1" mit dem Variant-Typ "%2" kann keine Daten vom Quellfeld "%3" mit dem Variant-Typ "%4" abrufen.%0
E_BTW_INITIALIZED_MESSAGEFIELD_INVALID_OVERWRITE | 0x5A96 | Die Daten im Feld "%1" einer initialisierten Nachricht "%2" können nicht durch Daten überschrieben werden, die von einer anderen Nachricht oder einem anderen Port der Bindungsspezifikation stammen.%0
E_BTW_DATAFLOW_INCOMPLETE | 0x5AB1 | Eine Quellaktion, welche [IN]-Parameter akzeptiert, muss die entsprechenden Felder über einen Datenfluss auffüllen lassen (über FROM).%0
E_BTW_DATAFLOW_FROM_SYSTEM_FIELD | 0x5AB2 | Der Port kann nicht von einem Systemfeld initialisiert werden.%0
E_BTW_DATAFLOW_FROM_CONSTANT_FIELD | 0x5AB3 | Der Port kann nicht von einem konstanten Nachrichtenfeld initialisiert werden.%0
E_BTW_MISSING_SCRIPT_EXPRESSION | 0x5AC0 | Für die Regel wurde kein Skriptausdruck bereitgestellt.%0
E_BTW_BAD_SCRIPT_EXPRESSION | 0x5AC1 | %1 %2 an Zeichenposition %3!d! in "%4"%0
E_BTW_MAP_INVALID_BINDING | 0x5AE0 | Die Bindung für Nachricht "%1" muss einen Verweis für den zugeordneten Port "%2" enthalten.%0
E_BTW_MESSAGE_BINDING_SCHEMA_MISMATCH | 0x5AE1 | Es besteht ein Missverhältnis zwischen der Bindung und dem Schema für die Nachricht "%1".%0
E_BTW_MESSAGEDECL_INIT_DATA_UNAVAILABLE | 0x5B00 | Initialisierungsdaten für das Feld "%1" konnten nicht erhalten werden.%0
E_BTW_LATENCY_INVALID_VALUE | 0x5B20 | Der Wert für die Wartezeit-Eigenschaft muss eine ganze nicht negative Zahl sein, die kleiner als "%1!d!" (der maximale Wert vom Typ long integer) ist.%0
E_BTW_PORT_LATENCY_ON_INTERNAL | 0x5B21 | Für einen internen Port kann keine Wartezeit angegeben werden.%0
E_BTW_MESSAGE_TECHNOLOGY_MISMATCH | 0x5BB0 | Konflikt zwischen der Port (%1)-Technologie "%2" und der Nachrichten (%3)-Technologie "%4".%0
E_BTW_FIELD_TECHNOLOGY_MISMATCH | 0x5BC0 | Konflikt zwischen der Port (%1)-Technologie "%2" und der Feld (%3)-Technologie "%4".%0
E_BTW_COM_PORT_NOT_CREATABLE | 0x5C10 | Damit ein COM-Port aufgerufen werden kann, muss er eine CLSID, eine Programm-ID oder einen Moniker besitzen.%0
E_BTW_AUTORETURN_COM_PORT_MUST_BE_USED_INSIDE_CONTEXT | 0x5C11 | Der Port "%1", der so konfiguriert ist, dass eine Transaktion abgebrochen wird, wenn eine Methode ein Fehler-HRESULT zurückgibt, kann nur in einer Transaktion verwendet werden.%0
E_BTW_COM_PORT_GENERAL_ACCESS_FAILURE | 0x5C12 | Ein COM-Port kann aufgerufen werden. Weitere Informationen finden Sie in der Windows 2000-Dokumentation.%1%0
E_BTW_COM_PARAMETERS_LIMIT | 0x5C20 | Die Methode hat "%1!d!" Parameter. Die aktuelle Begrenzung beträgt "%2!d!".%0
E_BTW_COM_NO_MATCHING_RETURN | 0x5C21 | Die COM-Methode hat keine entsprechende Rückgabe.%0
E_BTW_COM_NO_MATCHING_METHOD | 0x5C22 | Die COM-Rückgabe hat keine entsprechende Methode.%0
E_BTW_INVALID_SLOT_NUMBER | 0x5C23 | Die Steckplatznummer "%1!d!" ist ungültig. Steckplatznummern können nicht kleiner als SLOT_NONE(-1) sein.%0
E_BTW_INVALID_INVOKE_KIND | 0x5C24 | Der Wert von invokeKind ist ungültig (%1!d!). Zulässige Werte sind 1,2,3,4 und 8.%0
E_BTW_PROXY_DISCONNECTED | 0x5C25 | Die Verbindung zum Proxy wurde bereits getrennt.%0
E_BTW_COM_DISPATCH_SLOT_SPECIFIED | 0x5C26 | Für die Verteilerschnittstelle kann keine Steckplatznummer angegeben werden.%0
E_BTW_COM_SPECIFY_DISPID_OR_SLOT | 0x5C27 | Für DispId oder den Steckplatz müssen gültige Werte angegeben werden.%0
E_BTW_COM_INVALID_BYREF_FOR_RETURN_MESSAGES | 0x5C30 | Byref sollte den Wert "1" haben, da "%1" eine <com:return>-Nachricht darstellt.%0
E_BTW_COM_INVALID_NESTED_VARIANTS | 0x5C31 | Mehr als eine Verschachtelungsebene ist für Variant-Werte unzulässig.%0
E_BTW_COM_FIELD_INDEX_MUST_BE_NON_NEGATIVE | 0x5C32 | Der Index "%1!d!" des Feldes ist nicht gültig. Der Index muss eine nicht negative ganze Zahl sein.%0
E_BTW_COM_FIELD_INDEX_REPEATED | 0x5C33 | Der Index "%1!d!" für das Feld wurde vor einem anderen Feld in der Nachricht verwendet.%0
E_BTW_COM_FIELD_INDEX_NOT_CONTIGUOUS | 0x5C34 | Für Nachrichten des synchronen Aktionspaares "%1" und "%2" ist der Index "%3!d!" für ein Feld nicht gültig. Die Feldindizes für diese Nachrichten müssen einen fortlaufenden Block nicht negativer Zahlen bilden, die mit null beginnen.%0
E_BTW_MSMQ_NO_MQRT_DLL | 0x5D00 | Die Message Queuing-DLL MQRT.DLL kann nicht geladen werden.%0
E_BTW_MSMQ_CREATECHANNEL | 0x5D01 | MQBinder: Fehler bei CreateChannel für: %1.%0
E_BTW_MSMQ_NOT_CONFIGERED_PROPERLY | 0x5D02 | Der Message Queuing-Dienst wurde nicht ordnungsgemäß konfiguriert. Ein Warteschlangenobjekt konnte nicht geöffnet werden: %1.%0
E_BTW_MSMQ_NO_CERTIFICATE_AVAILABLE | 0x5D03 | Der Message Queuing-Dienst kann kein Zertifikat erhalten.%1%0
E_BTW_MSMQ_NO_WELLKNOWN_QUEUE_NAME | 0x5D04 | An eine bekannte Warteschlange kann keine Nachricht gesendet werden, da die Warteschlange innerhalb des XLANG-Ablaufplanes nicht benannt wurde. Geben Sie im XLANG-Ablaufplan einen Namen für die Warteschlange an.%1%0
E_BTW_MSMQ_INVALID_FIELD_TYPE | 0x5D05 | Für das Feld "%2" der Nachricht "%1" wurde ein ungültiger Feldtyp angegeben.%0
E_BTW_MSMQ_PORT_NOT_BOUND | 0x5D06 | Der MSMQ-Port ist nicht gebunden.%1%0
E_BTW_MSMQ_QUEUE_NOT_TRANSACTIONAL | 0x5D10 | Die Warteschlange verfügt nicht über die korrekten Transaktionseigenschaften.%1%0
E_BTW_MSMQ_OPEN_ACCESSDENIED | 0x5D11 | Message Queuing-Fehler: Zugriffsverweigerung beim Öffnen der Warteschlange. Vergleichen Sie den für die Warteschlange im XLANG-Ablaufplan angegebenen Wert für accessRole mit den Rechten, die dem aktuellen Benutzer zugewiesen wurden.%1%0
E_BTW_MSMQ_OPEN_GENERALFAILURE | 0x5D12 | Message Queuing-Fehler beim Versuch, die Warteschlange zu öffnen. Weitere Informationen finden Sie in der Dokumentation zum Message Queuing-Dienst unter Windows 2000. Suchen Sie dort nach dem Fehlercode, und beheben Sie den Fehler entsprechend.%1%0
E_BTW_MSMQ_PORT_NOT_CREATABLE | 0x5D13 | Ein Port, der mithilfe einer Warteschlange implementiert ist, benötigt einen Warteschlangennamen.%0
E_BTW_MSMQ_GENERAL_QUEUE_ACCESS_FAILURE | 0x5D14 | Message Queuing-Fehler beim Zugreifen auf die Warteschlange. Weitere Informationen finden Sie in der Dokumentation zum Message Queuing-Dienst unter Windows 2000. Suchen Sie dort nach dem Fehlercode, und beheben Sie den Fehler entsprechend.%1%0
E_BTW_MSMQ_INVALID_MESSAGE_VT_TYPE | 0x5D20 | Die Message Queuing-Nachricht weist ein unbekanntes Format auf.%1%0
E_BTW_MSMQ_MESSAGE_UNKNOWN_MESSAGETYPE | 0x5D21 | Die Message Queuing-Nachricht hat einen unbekannten Nachrichtentyp. Der Nachrichtentyp konnte der Nachricht nicht entnommen werden.%1%0
E_BTW_MSMQ_MESSAGE_UNAUTHENTICATED | 0x5D22 | Die Message Queuing-Nachricht ist nicht authentifiziert, der Port akzeptiert jedoch nur authentifizierte Nachrichten.%1%0
E_BTW_MSMQ_MESSAGE_INCORRECT_AUTHENTICATE_LEVEL | 0x5D23 | Die Message Queuing-Nachricht ist auf der angeforderten Ebene nicht authentifiziert.%1%0
E_BTW_MSMQ_MESSAGE_INVALID_MESSAGE | 0x5D24 | Die Message Queuing-Nachricht enthält einen ungültigen Nachrichtentext.%1%0
E_BTW_MSMQ_MESSAGE_NOT_SEND | 0x5D25 | Die Message Queuing-Nachricht konnte nicht gesendet werden.%1%0
E_BTW_MSMQ_MESSAGE_SCHEMAVALIDATION_FAILED | 0x5D26 | Die Message Queuing-Nachricht konnte mit dem bereitgestellten Schema nicht erfolgreich überprüft werden. Überprüfen Sie das Schema und den Schemapfad.%1%0
E_BTW_MSMQ_COULD_NOT_CREATE_MQMESSAGE | 0x5D27 | Die Nachrichteninstanz konnte nicht in eine Message Queuing-Nachricht konvertiert werden. %1%0
E_BTW_MSMQ_NO_TRUSTRELATIONSHIP_FOR_USER | 0x5D28 | Das Vertrauensverhältnis konnte für den angegebenen Benutzer nicht eingerichtet werden.%1%0
E_BTW_MSMQ_MESSAGE_EMPY_MESSAGE | 0x5D29 | Die Message Queuing-Nachricht besitzt einen leeren Nachrichtentext.%1%0
E_BTW_MSMQ_MESSAGE_ONLY_ONE_EMPTY_XPATH_ALLOWED | 0x5D2A | Die Message Queuing-Nachricht kann nur ein Feld mit einem leeren Knotenpfad enthalten (XPath).%0
E_BTW_MSMQ_MESSAGE_ONE_EMPTY_XPATH_NEEDED | 0x5D2B | Die Message Queuing-Nachricht muss ein Feld mit einem leeren Knotenpfad (XPath) enthalten.%0
E_BTW_MSMQ_MESSAGE_INVALID_MESSAGEBODY | 0x5D2C | Die Message Queuing-Nachricht enthält einen ungültigen Nachrichtentext.%1%0
E_BTW_MSMQ_MESSAGE_INVALID_MESSAGESTRING | 0x5D2D | Die Message Queuing-Nachricht enthält eine ungültige Zeichenfolge für den Nachrichtentext.%1%0
E_BTW_MSMQ_MESSAGE_UNKNOWN_MESSAGE | 0x5D2E | Die Message Queuing-Nachricht ist ungültig oder unbekannter Art und wurde in die Warteschlange für unzustellbare Nachrichten verschoben.%1%0
E_BTW_MSMQ_MESSAGE_TYPE_CONFLICTING_SCHEMA | 0x5D2F | Die Message Queuing-Nachrichten "%1" und "%2", welche den Typ "%3" besitzen und über Port "%4"gebunden sind, weisen sich widersprechende Spezifikationsdarstellungen auf. Möglicherweise stimmen Name, Typ oder xpath-Abfrage für eines der Felder in den beiden Darstellungen nicht überein.%0
E_BTW_MSMQ_DOCUMENT_FIELD_TYPE_NOT_STRING | 0x5D30 | Ein Feld einer Message Queuing-Nachricht "%1" mit einem leeren Knotenpfad (XPath) muss ein Datentyp String (Zeichenfolge) sein.%0
E_BTW_MSMQ_DOCUMENT_FIELD_CANNOT_CONVERT_TO_STRING | 0x5D31 | Ein Feld einer Message Queuing-Nachricht konnte nicht in eine Zeichenfolge konvertiert werden.%1%0
E_BTW_MSMQ_DOCUMENT_FIELD_CONVERTION_FAILURE | 0x5D32 | Ein Feld einer Message Queuing-Nachricht konnte nicht konvertiert werden.%1%0
E_BTW_CANT_DISPOSE_MESSAGE | 0x6001 | Die XLANG-Ablaufplaninstanz war an eine Warteschlange gebunden, die eine ungültige Nachricht empfing. Das XLANG-Ablaufplanungsmodul konnte diese Nachricht nicht an die Warteschlange für unzustellbare Nachrichten übertragen, so dass die Ablaufplaninstanz beendet wurde.%0

Verwandtes Thema

Konfigurieren der Ereignisanzeige für BizTalk Server-Fehler


Grundbegriffe

Dieser Abschnitt stellt detaillierte Informationen zum Konzept bereit, die wichtig für das Verständnis der BizTalk Server-Verwaltung sind. Er behandelt Verwaltungsaufgaben, wie das Erstellen von Servergruppen, das Definieren von Empfangsfunktionen und das Erstellen von Datenbanken für das Verwalten, Anzeigen und Protokollieren der Dokumentaktivität in Microsoft BizTalk Server 2000.

Folgende Konzepte werden in diesem Abschnitt behandelt:

  • WMI - Übersicht

  • BizTalk Server-Verwaltung - Umgebung

  • Verwaltungscache

  • Verwalten von BizTalk Server-Datenbanken

  • Gruppen und Server

  • Behandeln von Serverfehlern

  • Empfangsfunktionen

  • Verwenden von Warteschlangen

  • Administratorprivilegien


WMI - Übersicht

Windows Management Instrumentation (WMI) ist eine Datenverwaltungsschicht, die einen Bestandteil von Microsoft Windows 2000 bildet. Microsoft BizTalk Server 2000 verwendet die WMI-Schicht, um Verwaltungsfunktionen zu kapseln. Wenn die BizTalk Server-Verwaltung verwendet wird, um Gruppen-, Server- und Warteschlangeneinstellungen zu ändern, werden die neuen Werte über den BizTalk Server WMI-Provider in der BizTalk-Messaging-Verwaltungsdatenbank gespeichert. In BizTalk Server 2000 verwendet dieser WMI-Provider eine Microsoft SQL Server-Datenbank zum Speichern von Verwaltungsobjekten. WMI unterstützt eine einheitliche Skripting-API (Application Programming Interface), die Anwendungen und Skripts den Zugriff auf den WMI-Provider auf einem lokalen Computer oder einem Remotecomputer erlaubt.

Anmerkungen

  • In WMI existieren Einschränkungen hinsichtlich der Syntax und der gültigen Zeichen für WMI-Objektpfade. Der nachfolgenden Liste können Sie die ungültigen Zeichen entnehmen: ` ! @ # $ % ^ & * ( ) + = [ ] { } | \\ ;\" '< > , . ?

    Verwenden Sie keines dieser Zeichen, wenn Sie einen Servergruppennamen erstellen.

  • Alle Zeitstempel werden mithilfe der lokalen Zeit auf dem Microsoft SQL Server-Computer generiert. Jedoch bezieht sich der WMI-Provider auf alle Zeitstempel in UTC-Zeit (Coordinated Universal Time). Die Verwaltungskonsole konvertiert anschließend die Zeitstempel für die Anzeige wieder in die lokale Zeit zurück.

  • Um mithilfe von Programmen auf die WMI-Datenbankschicht zuzugreifen, können Sie die Datei InterchangeProvSchema.mof verwenden, die sich im Ordner \Programme\Microsoft BizTalk Server\Setup befindet. Diese Datei enthält die WMI-Klassen, die den Verwaltungsobjekten entsprechen. Weitere Informationen zum WMI-Anwendungsprogrammierung finden Sie auf der MSDN Online Library-Website (msdn.microsoft.com/library/default.asp). Suchen Sie in der Website nach "WMI Application Programming".


BizTalkServer-Verwaltung - Umgebung

BizTalk Server-Kopfzeile

BizTalk Server-Verwaltung - Umgebung

Folgende Themen werden in diesem Abschnitt behandelt:

  • BizTalk Server-Verwaltung - Benutzeroberfläche

  • BizTalk Server-Verwaltung - Tastenkombinationen


BizTalkServer-Verwaltung - Benutzeroberfläche

BizTalk Server-Kopfzeile

BizTalk Server-Verwaltung - Benutzeroberfläche

Die BizTalk Server-Verwaltung – auch als Verwaltungskonsole bezeichnet – ist ein MMC-Snap-In (Microsoft Management Console), das eine visuelle Darstellung der BizTalk Server-Komponenten bereitstellt, die ein Systemadministrator verwalten kann. Die linke Seite der Verwaltungskonsole wird als Konsolenstruktur bezeichnet und besteht aus Ordnern und Unterordnern, die verschiedene Elemente darstellen, wie z. B. Servergruppen. Die rechte Seite der Verwaltungskonsole wird als Detailbereich bezeichnet und enthält Informationen zu dem Element, das in der Konsolenstruktur ausgewählt ist.

Grafisch wird Microsoft BizTalk Server 2000 als Unterelement des Konsolenstamms auf der linken Seite der Verwaltungskonsole angezeigt. Jede in BizTalk Server konfigurierte Servergruppe wird in einem getrennten Unterordner angezeigt und besteht aus den Warteschlangen und Empfangsfunktionen der jeweiligen Gruppe sowie aus den Namen der Server in der Gruppe. Erweitern Sie ein beliebiges Element in der Konsolenstruktur, um weitere Details über das Element im Detailbereich der Verwaltungskonsole anzuzeigen. Sie können mit der rechten Maustaste auf jedes der Elemente klicken, um es zu konfigurieren oder neue Elemente zu erstellen.

Verwandtes Thema

Öffnen der BizTalk Server-Verwaltung


BizTalkServer-Verwaltung - Tastenkombinationen

BizTalk Server-Kopfzeile

BizTalk Server-Verwaltung - Tastenkombinationen

Sie können in der BizTalk Server-Verwaltung Tastenkombinationen verwenden, um Aufgaben durchzuführen. Die folgende Tabelle ist eine kurze Referenz zu den Tastenkombinationen der Microsoft Management Console.

Anmerkung

  • Um Funktionen zu verwenden, die in dieser Liste nicht enthalten sind, können Sie mithilfe der Zehnertastatur den Mauszeiger mit der Tastaturmaus bewegen. Weitere Informationen zur Tastaturmaus finden Sie in der Windows 2000 Server-Hilfe und der Advanced Server-Hilfe unter "Bewegen des Mauszeigers mit Hilfe der Tastatur". Weitere Informationen zur Tastaturmaus finden Sie in der Windows 2000 Professional-Hilfe unter "Bewegen des Mauszeigers mithilfe der Tastaturmaus".

Tastenkombination | Zweck
F5 | BizTalk Server-Verwaltung aktualisieren. Diese Tastenkombination aktualisiert das aktuelle Element, das in der Konsolenstruktur markiert ist.
ALT+F4 | BizTalk Server-Verwaltung schließen.
ALT+MINUSZEICHEN | Fenstermenüs für das aktive Konsolenfenster anzeigen.
UMSCHALT+F10 | Menü Vorgang für das ausgewählte Element anzeigen.
ALT+O | Menü Vorgang für das ausgewählte Element anzeigen.
ALT+A | Menü Ansicht anzeigen.
F1 | Onlinehilfe für das ausgewählte Element anzeigen.
ALT+EINGABE | Dialogfeld Eigenschaften gegebenenfalls für das ausgewählte Element anzeigen.

Verwandtes Thema

Öffnen der BizTalk Server-Verwaltung


Verwaltungscache

Beim Start von BizTalk Server werden alle Elemente der BizTalk Server-Verwaltung, wie Servergruppen, Servergruppeneigenschaften, Empfangsfunktionen, Verbindungen mit der Datenbank für gemeinsam genutzte Warteschlangen und den Überwachungsdatenbanken usw. im Verwaltungscache gespeichert. Alle Elemente im Zwischenspeicher werden alle 50 Sekunden aktualisiert, mit Ausnahme der Serverdatenbankverbindungen und der Servereigenschaften. Dies bedeutet, dass Änderungen der allgemeinen Eigenschaften einer Servergruppe, wie z. B. des SMTP-Hosts oder des Antwort-URLs für Reliable Messaging, innerhalb von 50 Sekunden übernommen werden. Wenn jedoch Servereigenschaften geändert werden, wie z. B. die Maximale Anzahl von Arbeitsthreads pro Prozessor, muss der Server, auf dem die Konfiguration geändert wurde, beendet und neu gestartet werden, damit die Änderung im Cache gespeichert werden kann. Ebenfalls müssen beim Ändern einer Verbindung mit den BizTalk-Messaging-Verwaltungs- und Überwachungsdatenbanken oder mit der Datenbank für gemeinsam genutzte Warteschlangen die Server in der Gruppe beendet und neu gestartet und die BizTalk Server-Austauschanwendung (BizTalk Server Interchange Application) beendet werden.

Verwandte Themen

Konfigurieren von allgemeinen Eigenschaften für eine Servergruppe

Herunterfahren der BizTalk Server-Austauschanwendung (BizTalk Server Interchange Application)

Starten eines Servers in einer Gruppe

Beenden eines Servers in einer Gruppe


Verwalten von BizTalkServer-Datenbanken

BizTalk Server-Kopfzeile

Verwalten von BizTalk Server-Datenbanken

Die drei den BizTalk-Messagingdiensten zugeordneten Datenbanken sind die folgenden:

  • BizTalk-Messaging-Verwaltungsdatenbank

  • Überwachungsdatenbank

  • Datenbank für gemeinsam genutzte Warteschlangen

Die BizTalk-Messaging-Verwaltungsdatenbank speichert Informationen für alle Serverkonfigurationen, einschließlich der Gruppen- und Servereinstellungen und der Empfangsfunktionen. Die Konfiguration dieser Verwaltungsobjekte erfolgt mithilfe der BizTalk Server-Verwaltung oder mit Programmen. Die BizTalk-Messaging-Verwaltungsdatenbank speichert darüber hinaus alle Informationen der Messagingkonfiguration für Kanäle, Messagingports und andere Messagingobjekte. Zwar werden die Informationen der Messagingkonfiguration in dieser Datenbank gespeichert, doch erfolgt die Konfiguration der Objekte entweder in BizTalk-Messaging-Manager oder mithilfe von Programmen mithilfe des BizTalk-Messaging-Konfigurationsobjektmodells. Weitere Informationen zum Konfigurieren von Kanälen, Messagingports usw. finden Sie unter Verwenden des BizTalk-Messaging-Managers oder Object Model Reference.

Die Überwachungsdatenbank führt ein Protokoll aller Austauschvorgänge, Dokumente und Empfangsbestätigungen, die von BizTalk Server verarbeitet werden. Weitere Informationen zur Überwachungsdatenbank finden Sie unter Überwachungsdatenbank. Informationen zum Konfigurieren der Überwachungseinstellungen finden Sie unter Konfigurieren von Überwachungseigenschaften für eine Servergruppe. Informationen zum Überwachen bestimmter Felder oder Daten von Dokumentinstanzen finden Sie unter Festlegen von Kanaleigenschaften.

Die Datenbank für gemeinsam genutzte Warteschlangen behält Dokumente, während diese verarbeitet werden oder auf die Verarbeitung warten. Dokumente werden später nach der Verarbeitung entfernt. Weitere Informationen zur Datenbank für gemeinsam genutzte Warteschlangen finden Sie unter Datenbank für gemeinsam genutzte Warteschlangen.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Verwalten der BizTalk-Messaging-Verwaltungsdatenbank

  • Verwalten von BizTalk Server-Gruppendatenbanken


Verwalten der BizTalk-Messaging-Verwaltungsdatenbank

In den meisten Unternehmensimplementierungen existiert eine zentrale BizTalk-Messaging-Verwaltungsdatenbank, die zum Konfigurieren mehrerer Servergruppen, Server, Kanäle, Messagingports usw. verwendet wird. Eine Ausnahme von dieser Regel stellen Unternehmen dar, die als Drittanbieter tätig sind. Drittanbieter benötigen möglicherweise für jeden Kunden eine eigene BizTalk-Messaging-Verwaltungsdatenbank, basierend auf den jeweiligen Unternehmensanforderungen der einzelnen Kunden. In allen Fällen wird jedoch dringend die Verwendung einer zentralen BizTalk-Messaging-Verwaltungsdatenbank für alle BizTalk-Servergruppen empfohlen.

Von Zeit zu Zeit kann es erforderlich sein, Server aus der zentralen BizTalk-Messaging-Verwaltungsdatenbank zu entfernen. Beispielsweise benötigt möglicherweise der Server, der die BizTalk-Messaging-Verwaltungsdatenbank ausführt, Wartung. In diesem Fall müssen alle Servergruppen auf eine replizierte BizTalk-Messaging-Verwaltungsdatenbank verweisen, wenn der Betrieb der BizTalk Server-Organisation aufrechterhalten werden soll. Es kann außerdem erforderlich sein, Server zwischen einer oder mehreren BizTalk-Messaging-Verwaltungsdatenbank(en) zu verschieben. Nehmen Sie beispielsweise an, Sie sind ein Drittanbieter mit drei Kunden A, B und C. Das Geschäft mit Kunde A hat nachgelassen, während das Geschäft mit den Kunden B und C zugenommen hat. Sie können die Server, die der BizTalk-Messaging-Verwaltungsdatenbank von Kunde A zugeordnet waren, in die Datenbanken verschieben, die den Kunden B und C zugeordnet sind.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Ändern der BizTalk-Messaging-Verwaltungsdatenbank

  • Entfernen von Servern aus der BizTalk-Messaging-Verwaltungsdatenbank

  • Verschieben von Servern zwischen BizTalk-Messaging-Verwaltungsdatenbanken

  • Verschieben von Remoteservern zwischen BizTalk-Messaging-Verwaltungsdatenbanken


Ändern der BizTalk-Messaging-Verwaltungsdatenbank

Es existieren zwei Verfahren zum Konfigurieren der BizTalk-Messaging-Verwaltungsdatenbank:

  • Verwenden der während der Installation zur Verfügung stehenden Konfigurationsoptionen.

  • Verwenden der BizTalk Server-Verwaltung, um den Server im Microsoft BizTalk Server 2000-Knoten zu ändern.

Wenn Sie alle BizTalk-Server zentral von einem einzelnen Server aus verwalten möchten, konfigurieren Sie alle Server so, dass sie auf eine zentrale BizTalk-Messaging-Verwaltungsdatenbank verweisen. Wenn Sie in dieser Weise vorgehen, verweisen bei jedem Öffnen der BizTalk Server-Verwaltung auf jedem dieser BizTalk-Server die im Knoten Microsoft BizTalk Server 2000 aufgelisteten Server auf die gleiche BizTalk-Messaging-Verwaltungsdatenbank und können zentral verwaltet werden. Wenn eine Auflistung von Servergruppen auf eine zentrale BizTalk-Messaging-Verwaltungsdatenbank verweist, braucht normalerweise nicht zu einer anderen BizTalk-Messaging-Verwaltungsdatenbank gewechselt zu werden. Eine Ausnahme besteht, wenn diese Datenbank aus Wartungsgründen in den Offlinemodus versetzt werden muss. Verwenden Sie in dieser Situation die BizTalk Server-Verwaltung, um alle Servergruppen im Knoten Microsoft BizTalk Server 2000 auf ein Replikat der ursprünglichen zentralen Datenbank verweisen zu lassen. Lassen Sie nicht vorübergehend Servergruppen auf eine andere zentrale BizTalk-Messaging-Verwaltungsdatenbank verweisen, der andere Servergruppen zugeordnet sind. Ansonsten kann es schwierig sein, zur ursprünglichen BizTalk-Messaging-Verwaltungsdatenbankkonfiguration zurückzukehren.

Verwandte Themen

BizTalk Server-Gruppen

Ändern der BizTalk-Messaging-Verwaltungsdatenbank für einen Server

Konfigurieren der BizTalk-Messaging-Verwaltungsdatenbank

Verschieben von Servern zwischen BizTalk-Messaging-Verwaltungsdatenbanken


Entfernen von Servern aus der BizTalk-Messaging-Verwaltungsdatenbank

Wenn alle BizTalk-Server aus der zentralen BizTalk-Messaging-Verwaltungsdatenbank entfernt werden, bleibt der Inhalt der Datenbank erhalten. Wenn Sie hingegen über mehr als eine zentrale BizTalk-Messaging-Verwaltungsdatenbank in Ihrem System verfügen und Sie alle BizTalk-Server aus einer zentralen BizTalk-Messaging-Verwaltungsdatenbank entfernen, bleibt der Inhalt dieser Datenbank erhalten. Sie können der zentralen BizTalk-Messaging-Verwaltungsdatenbank neue BizTalk-Server hinzufügen, indem Sie den Microsoft BizTalk Server 2000-Assistenten für die Datenbankeinrichtung ausführen und auf der Seite BizTalk-Messaging-Verwaltungsdatenbank konfigurieren eine vorhandene Datenbank auswählen. Weitere Informationen zum Hínzufügen oder Ändern der BizTalk-Messaging-Verwaltungsdatenbank für einen Server finden Sie unter Ändern der BizTalk-Messaging-Verwaltungsdatenbank für einen Server.

Verwandtes Thema

Ändern der BizTalk-Messaging-Verwaltungsdatenbank für einen Server


Verschieben von Servern zwischen BizTalk-Messaging-Verwaltungsdatenbanken

Wenn Sie beabsichtigen, einen BizTalk-Server vorübergehend aus einer zentralen BizTalk-Messaging-Verwaltungsdatenbank in eine andere zu verschieben, muss mindestens ein weiterer BizTalk-Server in einer der Servergruppen in der ursprünglichen zentralen Datenbank verbleiben. Dies erlaubt es, den BizTalk-Server auf einfache Weise wieder in die ursprüngliche zentrale Datenbank aufzunehmen. Andernfalls müssen Sie, um der zentralen Datenbank einen neuen BizTalk-Server hinzuzufügen, den Microsoft BizTalk Server-Assistenten für die Datenbankeinrichtung ausführen und auf der Seite BizTalk-Messaging-Verwaltungsdatenbank konfigurieren eine vorhandene Datenbank auswählen. Weitere Informationen zum Hinzufügen oder Ändern der BizTalk-Messaging-Verwaltungsdatenbank für einen Server finden Sie unter Ändern der BizTalk-Messaging-Verwaltungsdatenbank für einen Server.

Verwandte Themen

Ändern der BizTalk-Messaging-Verwaltungsdatenbank für einen Server

Gruppen und Server


Verschieben von Remoteservern zwischen BizTalk-Messaging-Verwaltungsdatenbanken

Wenn Sie versuchen, einen Remoteserver einer BizTalk-Messaging-Verwaltungsdatenbank hinzuzufügen, und sich dieser Server ursprünglich in einer anderen zentralen BizTalk-Messaging-Verwaltungsdatenbank befand, wird im Windows-Ereignisprotokoll der folgende Fehler angezeigt:

Eine neue Instanz der WMI-Klasse MicrosoftBizTalkServer_Server kann nicht im WMI-Provider von BizTalk Server erstellt werden. Der Server <servername> gehört möglicherweise bereits zu einer anderen BizTalk Server-Installation.

Dieser Fehler bedeutet, dass ein Versuch unternommen wurde, einen Remoteserver hinzuzufügen, der sich ursprünglich in einer anderen zentralen Datenbank befand. Wenn dieses Verfahren in der BizTalk Server-Verwaltung durchgeführt wurde, versucht die Verwaltungskonsole zu ermitteln, ob der Remoteserver ebenfalls zu einer Gruppe in der Remote-Zentraldatenbank gehört. Die Verwaltungskonsole fragt den WMI-Provider (Windows Management Instrumentation) des Remoteservers ab, um diese Ermittlung durchzuführen. Wenn der Server zu einer Servergruppe in der anderen Zentraldatenbank gehört, wird eine Fehlermeldung der Verwaltungskonsole angezeigt, die erläutert, dass kein Remoteserver hinzugefügt werden kann, der bereits zu einer Gruppe in einer anderen Zentraldatenbank gehört.

Verwandte Themen

Fehler beim Verschieben eines Remoteservers in eine andere BizTalk-Messaging-Verwaltungsdatenbank

WMI - Übersicht


Verwalten von BizTalkServer-Gruppendatenbanken

BizTalk Server-Kopfzeile

Verwalten von BizTalk Server-Gruppendatenbanken

Jede Servergruppe verwendet zwei Datenbanken, die Datenbank für gemeinsam genutzte Warteschlangen und die Überwachungsdatenbank. Die Datenbank für gemeinsam genutzte Warteschlangen behält alle Dokumente und Austauschvorgänge, die für die Verarbeitung und Übertragung an BizTalk Server 2000 versendet werden. Die Überwachungsdatenbank überwacht und speichert ein- und ausgehende Austauschvorgänge zu Zwecken der Überwachung, Schlichtung und Beilegung von Differenzen.

Um die logische Konfiguration Ihrer Server und Gruppen zu vereinfachen, ist es wichtig, eindeutige Namen für die Datenbanken für gemeinsam genutzte Warteschlangen und die Überwachungsdatenbanken, die jeder der Servergruppen zugeordnet sind, zu erstellen. Wenn Sie beispielsweise über zwei Servergruppen verfügen, eine mit dem Namen Gruppe1, die andere mit dem Namen Gruppe2, benennen Sie die Datenbanken für die erste Gruppe GemeinWart1 und Ueberwach1 und die Datenbanken für die zweite Gruppe GemeinWart2 und Ueberwach2.

Anmerkung

  • Die BizTalk-Messaging-Verwaltungsdatenbank stellt eine von der Datenbank für gemeinsam genutzte Warteschlangen und der Überwachungsdatenbank verschiedene Datenbank dar. Diese Datenbank wird verwendet, um Informationen zum Konfigurieren mehrerer Gruppen und Server sowie Informationen zum Konfigurieren der BizTalk-Messagingdienste zu speichern. Sie verarbeitet keine Dokument- und Austauschübertragungen und überwacht keine Dokument- und Austauschaktivitäten.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Datenbank für gemeinsam genutzte Warteschlangen

  • Überwachungsdatenbank


Datenbank für gemeinsam genutzte Warteschlangen

  • Alle Server in einer Servergruppe verwenden gemeinsam eine Datenbank für gemeinsam genutzte Warteschlangen. Alle Dokumente und Austauschvorgänge, die an die Server einer Gruppe versendet werden, werden in der Datenbank für gemeinsam genutzte Warteschlangen gespeichert, bis sie von BizTalk Server verarbeitet werden.

  • Die Datenbank für gemeinsam genutzte Warteschlangen wird in der BizTalk Server-Verwaltung grafisch als eine Reihe von Warteschlangen dargestellt, die Informationen zum Fortschritt eines Austauschs oder Dokuments in BizTalk Server zur Verfügung stellt. Austauschvorgänge und Dokumente befinden sich während der Verarbeitung durch BizTalk Server in einer der folgenden Warteschlangen.
    • Verarbeitungswarteschlange. Eine Liste von Austauschvorgängen und Dokumenten, die aktuell von BizTalk Server verarbeitet werden.

    • Geplant-Warteschlange. Eine Liste von Austauschvorgängen und Dokumenten, die von BizTalk Server verarbeitet wurden und auf die Übertragung entsprechend dem Dienstfenster warten. Weitere Informationen zum Dienstfenster finden Sie unter der Eigenschaft ServiceWindowInfo.

    • Wiederholungswarteschlange. Eine Liste von Austauschvorgängen und Dokumenten, die erneut gesendet werden, sowie Reliable Messaging-Nachrichten, die auf Empfangsbestätigungen warten.

    • Angehalten-Warteschlange. Eine Liste von Austauschvorgängen und Dokumenten, deren Verarbeitung aus einer Vielzahl von Gründen fehlgeschlagen ist, einschließlich Analysefehler, Serialisierungsfehler oder Übertragungsfehler, oder für die keine gültige Kanalkonfiguration vorhanden ist.

Verwandte Themen

Konfigurieren von Verbindungseigenschaften für eine Servergruppe

Gruppen und Server

ServiceWindowInfo

Verwalten von Warteschlangen

Verwenden von Warteschlangen


Überwachungsdatenbank

Alle Server in einer Servergruppe verwenden gemeinsam eine einzelne Überwachungsdatenbank, die alle die Austausch- und Dokumentaktivität in BizTalk Server betreffenden Informationen speichert. Die Überwachungsdatenbank wird verwendet, um den Status eines Austauschs oder Dokuments bei seiner Verarbeitung auf dem Server zu verfolgen. Wenn Sie beispielsweise überprüfen möchten, ob eine Bestellung an einen Handelspartner gesendet wurde, können Sie die Überwachungsdatenbank abfragen. Diese Datenbank kann außerdem verwendet werden, um zu überprüfen, ob Austauschvorgänge und Dokumente von BizTalk Server erfolgreich gesendet oder empfangen werden, oder um Informationen für Berichte, wie z. B. Übertragungszeiten oder Empfangsbestätigungsreaktionen, zur Verfügung zu stellen.

Definieren von Dokumentüberwachungs- und Protokollierungsparametern für die Überwachungsdatenbank

Sie können in der BizTalk Server-Verwaltung auswählen, ob Austauschvorgänge und Dokumente überwacht werden. Weitere Informationen zum Konfigurieren der Überwachungseinstellungen für eine Servergruppe finden Sie unter Konfigurieren von Überwachungseigenschaften für eine Servergruppe. Wenn Sie die Überwachung aktivieren, stehen die folgenden Optionen zur Verfügung:

  • Eingehenden Austausch protokollieren. Mit dieser Einstellung können Sie angeben, dass alle von einem BizTalk-Server empfangenen Dokumente in der Überwachungsdatenbank gespeichert werden. Gespeicherte eingehende Dokumente stellen einen Aktivitätsdatensatz für die Beilegung von Differenzen zur Verfügung. Diese Option ist standardmäßig aktiviert.

  • Ausgehenden Austausch protokollieren. Mit dieser Einstellung können Sie angeben, dass alle von BizTalk Server gesendeten Dokumente in der Überwachungsdatenbank gespeichert werden. Diese Option ist standardmäßig aktiviert.

  • Ursprüngliche MIME-codierte Nachricht protokollieren. Mit dieser Einstellung können Sie angeben, dass MIME-codierte Dokumente in der Überwachungsdatenbank in ihrem ursprünglichen Nachrichtenformat gespeichert werden, bevor ihre Decodierung erfolgt. Diese Option ist standardmäßig nicht aktiviert.

Verwandte Themen

Konfigurieren von Verbindungseigenschaften für eine Servergruppe

Konfigurieren von Überwachungseigenschaften für eine Servergruppe

Starten eines Servers in einer Gruppe

Beenden eines Servers in einer Gruppe

Verwenden der BizTalk-Dokumentüberwachung


Gruppen und Server

In einer Datenaustauschumgebung, die die Verarbeitung einer großen Anzahl von Dokumenten unterstützt, sind möglicherweise mehrere Server und Datenbanken erforderlich. Unternehmen müssen über eine Möglichkeit verfügen, den Dokumentaustausch zu zentralisieren und zu verwalten.

Microsoft BizTalk Server 2000 zentralisiert den Dokumentaustausch durch das Zusammenfassen von Servern in Gruppen und das Verwalten und Konfigurieren dieser Servergruppen mithilfe der BizTalk Server-Verwaltung.

Folgende Themen werden in diesem Abschnitt behandelt:

  • BizTalk Server-Gruppen

  • Beziehung zwischen Gruppen und Servern

  • Gruppenstatus

  • BizTalk-Server


BizTalkServer-Gruppen

BizTalk Server-Kopfzeile

BizTalk Server-Gruppen

Eine Servergruppe ist das grundlegende Organisationsprinzip in der BizTalk Server-Verwaltung. Servergruppen sind Zusammenstellungen einzelner Server, die zentral verwaltet, konfiguriert und überwacht werden.

Server in einer BizTalk-Servergruppe haben folgende gemeinsamen Eigenschaften:

  • Eine Datenbank für gemeinsam genutzte Warteschlangen, die alle Dokumente bis zu ihrer erfolgreichen Verarbeitung dauerhaft speichert.

  • Eine Überwachungsdatenbank, die zum Protokollieren der Dokument- und Austauschaktivität und zum Ausführen von Berichten verwendet wird.

  • Empfangsfunktionen.

  • Alle Komponenten, die der Server zum Verarbeiten von Dokumenten und Austauschvorgängen benötigt, wie Transportkomponenten, Anwendungsintegrationskomponenten (Application Integration Components, AICs) usw.

Eine zentrale BizTalk-Messaging-Verwaltungsdatenbank verwaltet mehrere Gruppen und Server. Daher teilen sie die gleichen Konfigurationsinformationen. Diese Konfigurationsinformationen geben die Dokumentverarbeitungslogik für die Server an. Geben Sie die gleiche BizTalk-Messaging-Verwaltungsdatenbank für alle Serverinstallationen an, damit Sie jeden Server und jede Gruppe aus der Verwaltungskonsole remote verwalten können. Auch wenn Sie aus Gründen der Skalierbarkeit und der besseren Leistung mehrere Servergruppen einrichten, sollten Sie nur eine zentrale BizTalk-Messaging-Verwaltungsdatenbank verwenden. Andernfalls können diese Server nicht gemeinsam die gleiche BizTalk-Messaging-Verwaltungskonfiguration verwenden.

Verwandte Themen

Hinzufügen, Löschen und Konfigurieren einer Servergruppe

BizTalk-Server

Empfangsfunktionen

Beziehung zwischen Gruppen und Servern

Verwenden von Warteschlangen


Beziehung zwischen Gruppen und Servern

Jede Installation von BizTalk Server 2000 muss über mindestens eine Servergruppe verfügen. Die Beziehung zwischen Gruppen und Servern ist durch die folgenden Punkte definiert:

  • Ein einzelner Server kann nur zu einer Servergruppe gehören.

  • Alle Server in einer Gruppe verwenden die gleichen gemeinsam genutzten Warteschlangen und die gleichen Empfangsfunktionen.

  • Alle Server in einer Gruppe verwenden gemeinsam die gleichen Komponenten, wie Transportkomponenten, Anwendungsintegrationskomponenten (Application Integration Components, AICs) usw. zum Verarbeiten von Austauschvorgängen und Dokumenten.

Die folgende Abbildung zeigt die Beziehung zwischen Servergruppen in BizTalk Server 2000. Server 1-6 wurden mit Microsoft BizTalk Server 2000 installiert. Server A-D wurden mit Microsoft SQL Server installiert und sind ausschließlich der Datenbankverwaltung vorbehalten. Obwohl die Server A-D entweder für die Überwachungsdatenbank oder die Datenbank für gemeinsam genutzte Warteschlangen vorgesehen sind, kann die BizTalk-Messaging-Verwaltungsdatenbank auf einem dieser Server ausgeführt werden, da sie relativ klein und nicht prozessorintensiv ist. Es wird dringend empfohlen, dass die Datenbank für gemeinsam genutzte Warteschlangen und die Überwachungsdatenbank auf zwei getrennten Servern ausgeführt werden, die ausschließlich der Datenbankverwaltung vorbehalten sind, und dass Sie eine einzelne zentrale BizTalk-Messaging-Verwaltungsdatenbank für alle Servergruppen verwenden.

Logische Konfiguration von Gruppen und Servern

Logische Konfiguration von Gruppen und Servern
Gruppe 2
Gruppe 1
Überwachungs-
datenbank
Server C
Überwachungs-
datenbank
Server A
Datenbank für
gem. gen. Warteschlangen
Server D
Datenbank für
gem. gen. Warteschlangen
Server B
BizTalk Server 3
BizTalk Server 2
BizTalk Server 6
BizTalk Server 5
BizTalk Server 4
BizTalk Server 1
BizTalk Messaging- Verwaltungsdatenbank Server A

Verwandtes Thema

Verwalten von BizTalk Server-Datenbanken


Gruppenstatus

Die BizTalk Server-Verwaltung zählt Servergruppen auf und gibt für jede Gruppe an, ob sie Verbindungen mit der Überwachungsdatenbank und/oder der Datenbank für gemeinsam genutzte Warteschlangen herstellen kann. Wenn Sie auf Microsoft BizTalk Server 2000 klicken, wird der Gruppenstatus unter der Statusleiste im Detailbereich angezeigt. Die Gruppenstatuswerte sind:

  • Verbunden. Gibt an, dass die Gruppe mit der Überwachungsdatenbank und der Datenbank für gemeinsam genutzte Warteschlangen verbunden ist.

  • Überwachungsverbindungsfehler. Gibt an, dass die Gruppe nicht mit der Überwachungsdatenbank verbunden ist.

  • Fehler bei Verbindung zu gemeinsam genutzten Warteschlangen. Gibt an, dass die Gruppe nicht mit der Datenbank für gemeinsam genutzten Warteschlangen verbunden ist.

  • Fehler bei Überwachungsverbindung und Verbindung zu gemeinsam genutzten Warteschlangen. Gibt an, dass die Gruppe weder mit der Überwachungsdatenbank noch mit der Datenbank für gemeinsam genutzte Warteschlangen verbunden ist.


BizTalk-Server

Ein Server in einer Servergruppe dient als Host für die entsprechende Funktionalität der BizTalk-Messagingdienste – wie Datenübersetzung, Verschlüsselung, digitale Signatur und Dokumentüberwachung –, um den Dokumentaustausch zwischen anderen externen Servern und Anwendungen zu verwalten, die außerhalb der BizTalk-Servergruppe sind. Jeder Server übergibt eingehende und ausgehende Dokumente an die Datenbank für gemeinsam genutzte Warteschlangen und ruft sie aus dieser ab, wobei er die entsprechenden COM-Methoden (Component Object Model) aufruft, um Dokumente umzuwandeln, zu serialisieren, signieren, ver- oder entschlüsseln und zu transportieren. Für Anwendungen, die nicht die COM-Schnittstellen von BizTalk Server verwenden, verwendet BizTalk Server 2000 Empfangsfunktionen für den Empfang von Daten.

Abhängig von Ihren Geschäftsanforderungen können Sie alle Server in einer Gruppe genau gleich konfigurieren. Auf diese Weise lassen sich Server in einer Gruppe auf einfache Weise hinzufügen und entfernen. Alternativ können Sie einige Server in einer Gruppe ausschließlich für den Empfang von Dokumenten konfigurieren.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Grundlegendes zu Servereigenschaften

  • Serverstatus

Verwandte Themen

BizTalk Server-Gruppen

Beziehung zwischen Gruppen und Servern


Grundlegendes zu Servereigenschaften

Beim Konfigurieren eines Servers in einer Gruppe müssen Sie ein Gleichgewicht zwischen maximalem Durchsatz und Serverleistung finden. Ihre Unternehmensanforderungen, die Serverkapazität und die Netzwerkbandbreite sind einige der Faktoren, die Einfluss darauf haben, wie Sie die Servereigenschaften konfigurieren. Es wird dringend empfohlen, mit verschiedenen Kombinationen in einer Testumgebung, die Ihre Produktionsumgebung simuliert, zu experimentieren, um zu ermitteln, welche Lösung in Ihrer Installation am besten funktioniert.

Maximale Anzahl von Empfangsfunktionsthreads

Die maximale Anzahl von Empfangsfunktionsthreads wird auf Prozessorbasis festgelegt. Der Bereich für diese Option beträgt 1 bis 128. Passen Sie diese Zahl an, um die Leistung der auf dem Server ausgeführten Empfangsfunktionen zu optimieren. In den meisten Fällen bewirkt ein Erhöhen der Zahl der Empfangsfunktionsthreads eine Erhöhung des Durchsatzes der Empfangsfunktionsthreads auf dem Server.

An Arbeitsobjektverwaltung teilnehmen

Wenn das Kontrollkästchen An Arbeitsobjektverwaltung teilnehmen aktiviert ist, verarbeitet der Server Dokumente in der Verarbeitungswarteschlange. Wenn dieses Kontrollkästchen deaktiviert ist, verarbeitet der Server keine Dokumente in der Verarbeitungswarteschlange. Es existieren zwei Situationen, in denen es sinnvoll sein kann, diese Option zu deaktivieren. Die erste Situation besteht im Empfangen von Nachrichten aus einer Nachrichtenwarteschlange. Aktuell unterstützt Message Queuing nur lokale Transaktions-Lesevorgänge. Dies bedeutet, dass sich Ihre Warteschlangen auf einem Server befinden müssen, auf dem Microsoft BizTalk Server 2000 installiert ist, und dass nur ein Server in einer Gruppe für das Lesen aus diesen Warteschlangen konfiguriert werden kann. Um dem Server, auf dem sich die Warteschlange befindet, einen möglichst schnellen Empfang zu ermöglichen, deaktivieren Sie das Kontrollkästchen An Arbeitsobjektverwaltung teilnehmen.

Die zweite Situation, in der ein Deaktivieren dieser Option sinnvoll sein kann, liegt dann vor, wenn Sie die Leistung von BizTalk Server-Clustern maximieren möchten. Beispielsweise kann es sinnvoll sein, einen der Server in der BizTalk Server-Gruppe für die Verarbeitung von Verwaltungsaufgaben zu reservieren.

Maximale Anzahl von Arbeitsthreads pro Prozessor

Die maximale Anzahl von Arbeitsthreads wird auf Prozessorbasis festgelegt. Der Bereich für diese Option beträgt 1 bis 128. Eine niedrige Einstellung kann in Situationen mit hohem Datenverkehr zu einem Engpass führen. Eine hohe Einstellung hat möglicherweise keine nachteiligen Auswirkungen, kann jedoch auch ein Nachlassen der Leistung bewirken.

Maximale Anzahl von Arbeitthreads pro Prozessor und Zeitraum zwischen Aufrufen der BizTalk Server-Ablaufplanung sind zwei Faktoren, die beeinflussen, wie viel Datenverkehr mit den Microsoft SQL Server-Datenbanken herrscht. Sie können den Datenverkehr zu den SQL-Datenbanken beschränken, indem Sie die Zahl für Maximale Anzahl von Arbeitsthreads pro Prozessor niedrig festlegen, für Zeitraum zwischen Aufrufen der BizTalk Server-Ablaufplanung dagegen höher. Analog können Sie den Verkehr zu den Datenbanken erhöhen, indem Sie die Zahl für die maximale Anzahl der Arbeitsthreads erhöhen und die Einstellung für die Zeit zwischen Aufrufen der Ablaufplanung verringern.

Anmerkung

  • Deaktivieren Sie das Kontrollkästchen An Arbeitsobjektverwaltung teilnehmen, wenn Sie auf diesem Server keine Arbeitsobjekte verarbeiten möchten. Legen Sie die Option Maximale Anzahl von Arbeitsthreads pro Prozessor nicht auf Null fest.

Zeitraum zwischen Aufrufen der BizTalk Server-Ablaufplanung (ms)

Der Bereich für Zeitraum zwischen Aufrufen der BizTalk Server-Ablaufplanung beträgt 1 bis 4.294.967.295. Es existiert ein Thread, der verfügbare Elemente in der Verarbeitungswarteschlange abruft. Die Option Zeitraum zwischen Aufrufen der BizTalk Server-Ablaufplanung steuert, wie häufig der Thread die Verarbeitungswarteschlange abfragt. Wenn Sie nicht viele Daten empfangen, wählen Sie hierfür eine hohe Zahl. Wenn Sie viele Daten empfangen, kann es sinnvoll sein, diese Zahl zu verringern.

Verwandtes Thema

Konfigurieren eines Servers in einer Gruppe


Serverstatus

Die BizTalk Server-Verwaltung zählt die Server in einer Servergruppe auf und gibt die Liste der Server zurück. Die BizTalk Server-Verwaltung kann die folgenden Statuswerte für Server unterhalb der Statusleiste im Detailbereich zurückgeben:

  • Wird ausgeführt. Gibt an, dass der Server ausgeführt wird.

  • Zugriff verweigert. Gibt an, dass Sie auf einem Server nicht über Windows 2000-Administratorprivilegien verfügen.

  • Fehler. Gibt an, ob auf einem bei einer Servergruppe registrierten Server BizTalk Server 2000 entfernt wurde.

  • Beendet. Gibt an, ob ein Administrator die Ausführung eines Servers beendet hat.

  • Unbekannt. Gibt an, ob ein bei einer Servergruppe registrierter Server aus einem nicht bekannten Grund nicht verfügbar ist. Wenn dieser Fall eintritt, ist es wahrscheinlich, dass die Serververbindung verloren wurde.

Verwandtes Thema

Administratorprivilegien


Behandeln von Serverfehlern

Sie können die Fehlerbehandlung in BizTalk Server 2000 auf Serverebene mithilfe der Windows 2000-Ereignisanzeige konfigurieren, die in der BizTalk Server-Verwaltung enthalten ist. Die Windows 2000-Ereignisanzeige wird in der Konsolenstruktur der Verwaltungskonsole angezeigt.

Protokollieren von Ereignissen

Die Windows 2000-Ereignisanzeige erstellt ein Protokoll, das Informationen zu Hardware-, Software- und Systemprobleme enthält. In der Verwaltungskonsole kann die Ereignisanzeige so konfiguriert werden, dass Anwendungsfehler und Fehler der XLANG-Ablaufplanung (XLANG Scheduler) angezeigt werden, die für BizTalk Server 2000 spezifisch sind, wodurch die Problembehandlung für BizTalk Server effizient wird. Weitere Informationen zum Anpassen der Ereignisanzeige für Fehler von BizTalk Server und der XLANG-Ablaufplanung (XLANG Scheduler) finden Sie unter Verwalten der Ereignisanzeige.

Weitere Informationen zur Ereignisanzeige in der Windows 2000 Server-Hilfe finden Sie im Kapitel über die Ereignisanzeige unter "Verwenden der Ereignisanzeige".

Anmerkung

  • Alle mit BizTalk Server 2000 zusammenhängenden Anwendungsfehler sind als BizTalk Server-Fehler oder Fehler der XLANG-Ablaufplanung (XLANG Scheduler) definiert.

Verwandtes Thema

Verwalten der Ereignisanzeige


Empfangsfunktionen

Wenn Sie Dokumente von einem Empfangsspeicherort empfangen und sie an BizTalk Server versenden müssen, können Sie Versendeaufrufe mithilfe von Programmen konfigurieren. Weitere Informationen zu Versendeaufrufe finden Sie unter Submitting oder unter der Submit-Methode. Alternativ können Sie Empfangsfunktionen für die Verarbeitung der Daten konfigurieren. Wenn Sie beispielsweise Dokumente von einer Unternehmensorganisation oder –anwendung empfangen müssen, die nicht direkt mithilfe einer COM-Schnittstelle mit BizTalk Server kommunizieren kann, können Sie eine Empfangsfunktion verwenden, um die Austauschdokumente an BizTalk Server zu versenden. Oder wenn Sie aus einer Nachrichtenwarteschlange empfangen müssen, können Sie eine Empfangsfunktion verwenden, um das Dokument an BizTalk Server zu versenden. BizTalk Server 2000 unterstützt zwei Typen von Empfangsfunktionen: Datei und Message Queuing.

Sie können eine allgemeine Empfangsfunktion für BizTalk Server 2000 in der Verwaltungskonsole erstellen, in der Sie den Namen der Empfangsfunktion, die Dokumentdefinition usw. definieren. Weitere Informationen zum Konfigurieren von Empfangsfunktionen finden Sie unter Verwalten von Empfangsfunktionen für eine Servergruppe. Weitere Informationen zum Konfigurieren erweiterter Eigenschaften für Empfangsfunktionen finden Sie unter Grundlegendes zu erweiterten Eigenschaften von Empfangsfunktionen.

Die folgende Abbildung zeigt die Beziehung zwischen der sendenden Unternehmensanwendung, dem Dateisystem und einer allgemeinen BizTalk Server-Empfangsfunktion.

Geschäftsanwendung
sendet
Dateisystem
BizTalk-Server Dateiempfangsfunktion
BizTalk-
Server
Submit

Folgende Themen werden in diesem Abschnitt behandelt:

  • Verfügbare Empfangsfunktionen

  • Benutzerdefinierte Präprozessoren

  • Mehrere Instanzen von Empfangsfunktionstypen

  • Grundlegendes zu Empfangsfunktionen und Dokumentrouting

  • Grundlegendes zu erweiterten Eigenschaften von Empfangsfunktionen


Verfügbare Empfangsfunktionen

Zwei Typen von Empfangsfunktionen stehen in BizTalk Server zur Verfügung: Datei und Message Queuing. Ihre Geschäftspraktiken bestimmen, welchen Typ Empfangsfunktion Sie in welcher Situation verwenden.

Dateiempfangsfunktion

Eine Dateiempfangsfunktion wird aktiviert, wenn in dem Verzeichnis, das die Empfangsfunktion überwacht, Aktivität auftritt. Um eine Dateiempfangsfunktion zu verwenden, müssen Sie in der Lage sein, das Verzeichnis zu ändern. Die Dateiempfangsfunktion entfernt die Dateien aus dem Verzeichnis und versendet sie an BizTalk Server 2000.

Message Queuing-Empfangsfunktion

Eine Message Queuing-Empfangsfunktion wird auf der Basis der Aktivität in einer Nachrichtenwarteschlange aktiviert. Diese Empfangsfunktion extrahiert den Austausch oder das Dokument aus der Warteschlange und versendet ihn/es an BizTalk Server 2000.

When you define the polling location for the message queue, use a format name instead of a path name.Wenn Sie den Abrufspeicherort für die Nachrichtenwarteschlange definieren, verwenden Sie einen Formatnamen anstelle eines Pfadnamens. BizTalk Server ist für die Zusammenarbeit mit nicht angepassten Message Queuing-APIs (Application Programming Interfaces) ausgelegt, und die API-Aufrufe funktionieren nur mit der Formatnameneigenschaft. Verwenden Sie den folgenden Formatnamen, wenn Sie eine Message Queuing-Empfangsfunktion konfigurieren:

  • Direct=OS:<Servername>\<Warteschlangenname>

Anmerkung

  • Weitere Informationen zu Message Queuing und den Formatnamen finden Sie auf der MSDN Online Library-Website (msdn.microsoft.com/library/default.asp), begeben Sie sich hier zur Seite "Platform SDK, Getting Started, Contents of the Platform SDK, Message Queuing Services".


Benutzerdefinierte Präprozessoren

Wenn Sie über Dokumente verfügen, die vor dem Versenden an BizTalk Server verarbeitet werden müssen, können Sie einen benutzerdefinierten Präprozessor erstellen und die Empfangsfunktion für das Aufrufen des Präprozessors konfigurieren. Wenn Sie beispielsweise komprimierte Daten senden und diese entkomprimieren müssen, bevor Sie sie für die Verarbeitung an BizTalk Server versenden, konfigurieren Sie die Empfangsfunktion so, dass sie den benutzerdefinierten Präprozessor aufruft, um die Daten zu entkomprimieren.

Verwandte Themen

Klassenbezeichner wird in der Präprozessorliste angezeigt

IBTSCustomProcess

Preprocessing Documents in a Receive Function


Mehrere Instanzen von Empfangsfunktionstypen

Es können mehrere Instanzen einer Empfangsfunktion existieren. Wenn beispielsweise mehrere Unternehmensanwendungen eine Dateiempfangsfunktion verwenden, um Dokumente und Austauschvorgänge an BizTalk Server 2000 zu versenden, können Sie entweder eine einzelne Instanz oder mehrere Instanzen der Dateiempfangsfunktion konfigurieren.

Anmerkung

  • Stellen Sie sicher, dass jede der erstellten Empfangsfunktionen über einen eindeutigen Namen verfügt. Empfangsfunktionen können keine identischen Namen zugewiesen werden.

Verwandtes Thema

Verwalten von Empfangsfunktionen für eine Servergruppe


Grundlegendes zu Empfangsfunktionen und Dokumentrouting

Ermitteln Sie beim Konfigurieren einer Empfangsfunktion, ob die von der Empfangsfunktion empfangenen Dokumente automatisch oder nicht automatisch geroutet werden. Automatisch geroutete Dokumente enthalten alle erforderlichen Routinginformationen; nicht automatisch gerouteten Dokumenten fehlen einige oder alle Routinginformationen.

Automatisch geroutete Dokumente

Automatisch geroutete Dokumente enthalten sämtliche Routinginformationen – das Quellorganisationskennzeichen, das Zielorganisationskennzeichen und die Dokumentdefinition – in den Routingkennzeichen, die in der Dokumentspezifikation definiert oder hartcodiert im Dokument angegeben sind, wie im Fall von X12 und EDIFACT. Alle Dokumente, für die Sie im BizTalk-Editor eine Spezifikation erstellen können, können als automatisch geroutetes Dokument konfiguriert werden. Verbreitete Typen automatisch gerouteter Dokumente sind XML, X12 und EDIFACT. Sie brauchen keine erweiterten Eigenschaften in der Empfangsfunktion zu konfigurieren, wenn ein Dokument automatisch geroutet wird, es sei denn, sie möchten die im Dokument zur Verfügung gestellten Daten außer Kraft setzen.

Wenn dem Dokument das Quell- oder Zielorganisationskennzeichen oder die Dokumentdefinition fehlen, wird es in der Angehalten-Warteschlange platziert. Darüber hinaus verwendet BizTalk Server beim Fehlen des Quell- oder Zielorganisationskennzeichens den Standardwert von Organisationsname als Organisationskennzeichen und verweist auf den Namen, der in der BizTalk-Messaging-Verwaltungsdatenbank gespeichert ist.

Nicht automatisch geroutete Dokumente

Nicht automatisch gerouteten Dokumenten fehlen einige oder alle der erforderlichen Routinginformationen. Beim Konfigurieren der Empfangsfunktion müssen die folgenden Informationen auf der Registerkarte Erweitert im Dialogfeld Eigenschaften der Empfangsfunktion oder in dem der Empfangsfunktion zu übergebenden Dokument definiert werden:

  • Quellorganisationskennzeichen, Zielorganisationskennzeichen und Dokumentdefinition

Oder

  • Kanal

Wenn Sie ein Dokument versenden, sucht BizTalk Server einen Kanal, um das Dokument zu verarbeiten. Dies kann auf zweierlei Weise geschehen: entweder durch Angabe eines Kanalnamens in der Empfangsfunktion oder durch Angabe von Quell- und Zielorganisationskennzeichen und Dokumentdefinition. Diese drei Eigenschaften unterstützen BizTalk Server beim Suchen des korrekten Kanals. Aus diesem Grund stehen beim Auswählen eines Kanals die Optionen für die Dokumentdefinition und die Informationen zu Quelle und Ziel nicht zur Verfügung, weil der Kanal alle erforderlichen Informationen bereitstellt, um das Dokument zu routen.

Verbreitete Typen nicht automatisch gerouteter Dokumente sind Dokumente, die aus mehreren Quellen stammen (offene Quelle) oder an mehrere Ziele gesendet werden (offenes Ziel).

Konfigurieren einer Empfangsfunktion für das Verwalten von Dokumenten aus mehreren Quellen

Sie können eine einzelne Empfangsfunktion, die nicht automatisch geroutete Dokumente verarbeitet, so konfigurieren, dass sie einen bestimmten Dokumenttyp von verschiedenen Quellen empfängt. Dies ist ein Szenario mit offener Quelle. Der Speicherort der Quellorganisation, die Zielorganisation und die Informationen der Dokumentdefinition müssen sich im Dokument befinden oder in Parametern, die zusammen mit dem Dokument versendet werden. Wenn Sie beispielsweise beabsichtigen, Aufträge von mehreren Kunden zu empfangen, diese aber alle an die gleiche Zielanwendung gesendet werden sollen, legen Sie die Eigenschaften für Dokumentdefinition und Zielorganisationskennzeichen in der Empfangsfunktion fest. Wenn BizTalk Server das Dokument analysiert, sucht das Programm das Kennzeichen der bereitstellenden Organisation, kombiniert diese mit den Parametern in der Empfangsfunktion, sucht den richtigen Kanal und verarbeitet anschließend das Dokument.

Verwandte Themen

Konfigurieren von erweiterten Eigenschaften für Datei- oder Message Queuing-Empfangsfunktionen

Verwalten von Empfangsfunktionen für eine Servergruppe

Festlegen von Eigenschaften für die Quellorganisation


Grundlegendes zu erweiterten Eigenschaften von Empfangsfunktionen

Sie können erweiterte Eigenschaften verwenden, um besondere Typen von Empfangsfunktionen auf der Basis Ihrer Geschäftspraktiken zu konfigurieren.

Beispielsweise können Sie Empfangsfunktionen definieren, um Folgendes zu versenden:

  • Dokumente, bei denen die Eigenschaft Offene Quelle oder Offenes Ziel festgelegt ist.

  • Dokumente, bei denen die Eigenschaft Pass-Through festgelegt ist.

  • Dokumente, die einen Kanalnamen angeben.

  • Andere Typen von nicht automatisch gerouteten Dokumenten.

Definieren der Eigenschaft "Offenheitsgrad" in einem Dokument

Die folgenden Optionen definieren den Offenheitsgrad eines Dokuments:

  • Nicht geöffnet. Gibt an, dass Quelle und Ziel beide explizit in der Empfangsfunktion oder der Dokumentinstanz deklariert sind.

  • Offenes Ziel. Gibt an, dass die Zielinformationen nicht explizit im Messagingport deklariert sind. Das Ziel wird dynamisch in der Dokumentinstanz oder in einem Versendeparameter angegeben. Sie müssen die Eigenschaften für Dokumentdefinition und Quellorganisationskennzeichen in der Empfangsfunktion oder in der Dokumentinstanz konfigurieren, damit BizTalk Server den korrekten Kanal findet.

  • Offene Quelle. Gibt an, dass die Quellinformationen nicht explizit im Kanal deklariert sind. Stattdessen wird die Quelle dynamisch in der Dokumentinstanz angegeben. Sie müssen die Eigenschaften für Dokumentdefinition und Zielorganisationskennzeichen in der Empfangsfunktion oder in der Dokumentinstanz konfigurieren, damit BizTalk Server den korrekten Kanal findet.

Konfigurieren von Empfangsfunktionen mit Pass-Through

Eine mit Pass-Through konfigurierte Empfangsfunktion umgeht die Analyse-, Entschlüsselungs-, Signaturüberprüfungs-, Umwandlungs- und Decodierfunktionen von BizTalk Server. Wählen Sie diese Option, wenn Sie Binärdaten großer Objekte oder andere Austauschvorgänge senden, für die Analyse, Entschlüsselung und Decodierung nicht erforderlich sind. Wenn Sie eine Empfangsfunktion mit der Option Mit Pass-Through-Kennzeichen senden konfigurieren, müssen Sie einen Kanal angeben. Andernfalls kann BizTalk Server das Dokument nicht verarbeiten.

Umschlagsname

Wenn Sie den Empfang eines eingehenden Austauschs in einem Flatfileformat erwarten, geben Sie das Umschlagsformat in der Empfangsfunktion ein. Der Umschlag verweist auf eine Spezifikation, die BizTalk Server anweist, wie der Austausch geöffnet und interpretiert werden soll. Wenn Sie mehrere Flatfiledateien in einem einzelnen Austausch erwarten, müssen die einzelnen Flatfiledateien durch ein Trennzeichen getrennt sein, das als Präfix oder Postfix dient. Infix wird nicht unterstützt. Das Trennzeichen muss im Stammknoten der Umschlagspezifikation und der Dokumentspezifikation festgelegt werden, wenn die Analyseeigenschaften konfiguriert werden. Weitere Informationen zum Festlegen der Analyseeigenschaften für eine Flatfiledatei finden Sie unter Festlegen von Analyseeigenschaften. Suchen Sie nach derTabelle Standard: CUSTOM, Struktur-Eigenschaft: Getrennt.

Kanalname

Jeder Austausch oder jedes Dokument, der/das an BizTalk Server versendet wird, erfordert eine Sammlung von Regeln, die festlegen, wie er/es verarbeitet werden soll. Der Kanal enthält alle Informationen, die der Server benötigt, um den Austausch oder das Dokument zu verarbeiten. Alle Austauschvorgänge und Dokumente, die von BizTalk Server verarbeitet werden, müssen einen Kanal passieren. Ein Kanal wird auf eine von zwei Weisen gefunden. Wenn ein Austausch oder Dokument versendet wird, analysiert BizTalk Server zunächst das Dokument auf das Quell- und Zielkennzeichen und die Dokumentdefinition. Wenn sich diese Informationen nicht in der Dokumentinstanz befinden, untersucht BizTalk Server anschließend die Empfangsfunktion. Sobald Quell- und Zielkennzeichen und Dokumentdefinition entdeckt sind, ermittelt BizTalk Server, welche Kanäle über die gleiche Kombination aus Dokumentdefinition, Quell- und Organisationskennzeichen wie das empfangene Dokument verfügen. Wenn BizTalk Server einen passenden Kanal findet, wird die Dokumentinstanz verarbeitet.

Die zweite Weise, wie ein Kanal gefunden wird, liegt dann vor, wenn er in der Empfangsfunktion angegeben ist. In diesem Fall wird die Kanalsuche umgangen, und das empfangene Dokument wird schneller verarbeitet.

Dokumentdefinition, Quellorganisations- und Zielorganisationskennzeichen

Beim Empfang von nicht automatisch gerouteten Dokumenten können Sie die Dokumentdefinition, das Quellorganisationskennzeichen und/oder das Zielorganisationskennzeichen konfigurieren. Die im empfangenen Dokument enthaltenen Routinginformationen bestimmen, welche dieser Eigenschaften Sie in der Empfangsfunktion definieren. Wenn Sie beispielsweise mehrere Dokumenttypen von der gleichen Quellorganisation empfangen und diese Dokumente immer an das gleiche Ziel senden, können Sie die Quell- und Zielorganisationskennzeichen in der Empfangsfunktion konfigurieren und die Dokumentdefinition dynamisch in der Dokumentinstanz definieren.

Verwandte Themen

Erstellen von Umschlägen

Festlegen von Eigenschaften für die Umschlagsinformationen

Festlegen von Analyseeigenschaften

Grundlegendes zu Kanälen

Grundlegendes zu Dokumentdefinitionen

Grundlegendes zu Umschlägen

Grundlegendes zu Organisationen

Grundlegendes zu Empfangsfunktionen und Dokumentrouting

Verwenden von Umschlägen für die eingehende Verarbeitung


Verwenden von Warteschlangen

Microsoft BizTalk Server 2000 stellt gemeinsame Fähigkeiten für die Warteschlangenverwaltung in der BizTalk Server-Verwaltung bereit. BizTalk Server-Administratoren können Dokumente aus jeder anderen Warteschlange in die Angehalten-Warteschlange verschieben. Aus der Angehalten-Warteschlange können Dokumente gelöscht, erneut versendet oder angezeigt werden, je nach dem Verarbeitungsstatus des Dokuments. BizTalk Server-Administratoren können Fehlermeldungen für Dokumente in der Angehalten-Warteschlange sortieren und anzeigen.

Die folgenden Warteschlangen werden für die Aufnahme von eingehenden und ausgehenden Dokumenten verwendet, die sich in verschiedenen Zuständen des Routings und der Verarbeitung in BizTalk Server befinden:

  • Verarbeitungswarteschlange

  • Geplant-Warteschlange

  • Wiederholungswarteschlange

  • Angehalten-Warteschlange

Anmerkung

  • Austauschvorgänge und Dokumente werden in der BizTalk Server-Verwaltung in der Reihenfolge "First in, First out" angezeigt. Das bedeutet, die ältesten Elemente in einer Warteschlange werden zuerst und die neuesten Elemente zuletzt angezeigt. Darüber hinaus werden bis zu 15.000 Austauschvorgänge und/oder Dokumente zugleich in einer Warteschlange angezeigt. Wenn sich mehr als 15.000 tatsächliche Elemente in einer Warteschlange befinden, müssen Sie aktuelle Elemente in der Warteschlange entfernen oder erneut versenden, so dass neuere Elemente angezeigt werden können. Der Warteschlangenzähler in der Konsolenstruktur – die Zahl in Klammern neben dem Warteschlangennamen – zeigt an, wie viele tatsächliche Elemente sich in der Warteschlange befinden. Dokumente können entfernt oder erneut versendet werden, um sie aus einer Warteschlange zu entfernen.

Verwandtes Thema

Verwalten von Warteschlangen


Verarbeitungswarteschlange

Die Verarbeitungswarteschlange enthält Dokumente, die aktuell von BizTalk Server verarbeitet werden. Transaktionen in der Verarbeitungswarteschlange verbleiben nicht sehr lange in der Warteschlange, weil sie bei Ankunft verarbeitet werden. BizTalk Server-Administratoren können jedes beliebige Dokument in dieser Warteschlange auswählen und es in die Angehalten-Warteschlange verschieben.

Verwandte Themen

Verschieben von Dokumenten in die Angehalten-Warteschlange

Verwenden von Warteschlangen


Geplant-Warteschlange

Die Geplant-Warteschlange enthält Arbeitsobjekte, die von BizTalk Server verarbeitet wurden und auf der Basis des Dienstfensters auf die Übertragung warten. BizTalk Server-Administratoren können jedes beliebige Dokument in dieser Warteschlange auswählen und es in die Abgebrochen-Warteschlange verschieben. Weitere Informationen zum Dienstfenster finden Sie unter dem Objekt BizTalkServiceWindowInfo Interface.

Verwandte Themen

Verschieben von Dokumenten in die Angehalten-Warteschlange

IBizTalkServiceWindowInfo Interface

Verwenden von Warteschlangen


Wiederholungswarteschlange

Die Wiederholungswarteschlange enthält Dokumente, die zur Übermittlung erneut versendet werden und Dokumente, die auf Reliable Messaging-Empfangsbestätigungen warten. Der Unterschied zwischen den beiden Übermittlungsarten ist nicht sichtbar. Standardmäßig werden fehlgeschlagene Übertragungen alle fünf Minuten bis zum Erreichen der maximalen Anzahl von drei erneuten Wiederholungen erneut versucht, bevor sie in die Abgebrochen-Warteschlange verschoben werden. Diese Zahlen können mithilfe von BizTalk-Messaging-Manager oder programmgesteuert geändert werden. Weitere Informationen zum Ändern der Zahl der Wiederholungsversuche finden Sie unter Festlegen von erweiterten Konfigurationseigenschaften oder der Eigenschaft RetryCount und der Eigenschaft RetryInterval.

BizTalk Server-Administratoren können jedes beliebige Dokument in dieser Warteschlange auswählen und es in die Abgebrochen-Warteschlange verschieben.

Verwandte Themen

RetryCount

RetryInterval

Verschieben von Dokumenten in die Angehalten-Warteschlange

Festlegen von erweiterten Konfigurationseigenschaften

Verwenden von Warteschlangen


Angehalten-Warteschlange

Die Angehalten-Warteschlange enthält Arbeitsobjekte, deren Verarbeitung aus einer Vielzahl von Gründen fehlgeschlagen ist, einschließlich Analysefehler, Serialisierungsfehler, Übertragungsfehler oder die Unfähigkeit, eine Kanalkonfiguration zu finden. BizTalk-Administratoren können mit der rechten Maustaste auf jedes beliebige Dokument in dieser Warteschlange klicken, um eine der folgenden Optionen zu wählen:

  • Fehlerbeschreibung anzeigen. Ermöglicht es BizTalk-Administratoren, Fehlerbeschreibungen anzuzeigen, die einen Hinweis darauf geben, warum das Dokument an die Angehalten-Warteschlange gesendet wurde.

  • Austausch anzeigen. Ermöglicht es BizTalk-Administratoren, den Inhalt eines Austauschs anzuzeigen, dessen Verarbeitung aus einer Vielzahl von möglichen Gründen fehlgeschlagen ist, einschließlich Analysefehler oder Übertragungsfehler. Austausch anzeigen steht für die folgenden Statuswerte zur Verfügung:
    • Initiale

    • Benutzerdefinierte Komponente

    • Analysiert

    • Codierung

    • Signiert

    • Verschlüsselt

    • Überträgt
  • Dokument anzeigen. Ermöglicht es BizTalk-Administratoren, den Inhalt eines Dokuments anzuzeigen, dessen Verarbeitung aus einer Vielzahl von möglichen Gründen fehlgeschlagen ist, einschließlich Serialisierungsfehler oder die Unfähigkeit, einen Kanal zu finden. Dokument anzeigen steht für die folgenden Statuswerte zur Verfügung:
    • Dokumentüberprüfung

    • Kanalauswahl

    • Feldüberwachung

    • Zuordnung

    • Korreliert

    • Serialisiert
  • Löschen. Erlaubt BizTalk-Administratoren das vollständige Entfernen eines Eintrags aus der Angehalten-Warteschlange. Diese Aktion kann nicht rückgängig gemacht werden. Nachdem ein Dokument aus der Angehalten-Warteschlange gelöscht wurde, kann es nicht wiederhergestellt werden.

  • Erneut senden. Ermöglicht BizTalk-Administratoren das erneute Versenden von Austauschvorgängen und Dokumenten an BizTalk Server zur Verarbeitung.

Statuswerte der Angehalten-Warteschlange

Austauschvorgänge und Dokumente werden aus einer Vielzahl von Gründen in der Angehalten-Warteschlange platziert. Die folgende Liste erläutert die Statuswerte der Angehalten-Warteschlange, die ihnen zugeordneten Fehlermeldungen und die Aktionen, mit denen Sie reagieren können.

Statuswert der Angehalten-Warteschlange | Fehlermeldung | Fehlerbeschreibung und mögliche Aktion
Kanalauswahl oder Überträgt | Unerwarteter Fehler | Es ist ein unerwarteter interner Serverfehler aufgetreten. Versenden Sie das Dokument erneut.
Kanalauswahl oder Überträgt | Unbekannt | Der Austauschvorgang oder das Dokument wurde von einem inaktiven Server als "in Verarbeitung" gekennzeichnet. Beim Neustart dieses Servers wurde dieses Element automatisch in die Angehalten-Warteschlange verschoben. Auf dem ursprünglichen Server kam es möglicherweise zu einem Fehler. Wenden Sie sich an den Systemadministrator, um weitere Informationen zu erhalten. Wenn das Problem behoben ist, versenden Sie das Dokument oder den Austausch erneut.
Kanalauswahl oder Überträgt | Nicht genügend Arbeitsspeicher | Der Computer, auf dem BizTalk Server ausgeführt wird, verfügte nicht über genügend Arbeitsspeicher. Führen Sie einen Neustart des Servers durch, und versenden Sie alle Austauschvorgänge und Dokumente in der Angehalten-Warteschlange erneut.
Analysiert | Analysefehler | BizTalk Server konnte die Daten nicht analysieren. Zeigen Sie den Inhalt des Austauschs an, um zu ermitteln, warum BizTalk Server diesen nicht analysieren konnte. Versenden Sie den Austausch mithilfe von IInterchange oder einer Empfangsfunktion erneut. Weitere Informationen finden Sie unter Ein Austausch oder Dokument wird in der Angehalten-Warteschlange als Binärdaten angezeigt oder Analysefehler.
Analysiert | Fehlende Daten | Die aus den eingehenden Daten extrahierten Informationen enthielten nicht genügend Informationen, um einen Kanal zu finden. Zeigen Sie den Austausch an, und finden Sie heraus, welche Daten fehlen. Versenden Sie den Austausch mithilfe von IInterchange oder einer Empfangsfunktion erneut. Weitere Informationen finden Sie unter Ein Austausch oder Dokument wird in der Angehalten-Warteschlange als Binärdaten angezeigt oder Analysefehler.
Analysiert | "expiresAt" abgelaufen | Der BizTalk Framework-Zeitstempel "expiresAt" ist abgelaufen. Dieses Dokument ist nicht mehr gültig. Weitere Informationen finden Sie unter Ein Austausch oder Dokument wird in der Angehalten-Warteschlange als Binärdaten angezeigt.
Kanalauswahl | Kein Kanal gefunden | BizTalk Server konnte keine Kanäle finden, die diesem Dokument entsprechen. Erstellen Sie einen Kanal für das Dokument, oder korrigieren Sie das Dokument, und versenden Sie es dann erneut.
Kanalauswahl | Kanal entferntt | Der diesem Dokument zugeordnete Kanal wurde gelöscht, nachdem das Dokument die Arbeitswarteschlange erreicht hatte. Konfigurieren Sie den Kanal erneut, oder konfigurieren Sie das Dokument für einen anderen Kanal, und versenden Sie das Dokument dann erneut. Oder Versenden Sie das Dokument nicht, und löschen Sie es aus der Angehalten-Warteschlange.
Kanalauswahl | Kanal fehlt | Der in der Empfangsfunktion oder im Versendeaufruf angegebene Kanal wurde nicht gefunden. Konfigurieren Sie einen Kanal, oder konfigurieren Sie das Dokument um, und versenden Sie es dann erneut.
Kanalauswahl | Ungültiger Kanal | Der im Versendeaufruf angegebene Kanal ist ein offener Kanal. Offene Kanäle sind für Pass-Through-Versendeaufrufe ungültig. Ändern Sie den Kanal, und versenden Sie das Dokument erneut.
Zuordnung | Zuordnungsfehler | Die Zuordnung, auf die durch den Kanal verwiesen wurde, ist falsch formatiert. Löschen Sie das Dokument aus der Angehalten-Warteschlange, korrigieren Sie die Zuordnung, und versenden Sie das Dokument, als ob es neu wäre.
Serialisiert | Serialisierungsfehler | BizTalk Server konnte das Dokument nicht in das systemeigene Format konvertieren. Versenden Sie das Dokument erneut.
Codierung | Codierungsfehler | BizTalk Server konnte diesen Austausch nicht codieren. Versenden Sie den Austausch erneut.
Signiert | Signierfehler | BizTalk Server konnte diesen Austausch nicht signieren. Möglicherweise ist das Zertifikat abgelaufen. Weitere Informationen finden Sie im Zertifikate-Snap-In der Microsoft Management Console. Weitere Informationen zum Anzeigen der Zertifikate-Snap-Ins in der Windows 2000-Hilfe finden Sie im Kapitel "Verwalten von Zertifikaten" unter "Hinzufügen des Snap-Ins Zertifikate zur MMC-Konsole".
Verschlüsselt | Verschlüsselungsfehler | BizTalk Server konnte diesen Austausch nicht verschlüsseln. Möglicherweise ist das Zertifikat abgelaufen. Weitere Informationen finden Sie im Zertifikate-Snap-In der Microsoft Management Console. Weitere Informationen zum Anzeigen der Zertifikate-Snap-Ins in der Windows 2000-Hilfe finden Sie im Kapitel "Verwalten von Zertifikaten" unter "Hinzufügen des Snap-Ins Zertifikate zur MMC-Konsole".
Überträgt | Übertragungsfehler | BizTalk Server konnte diesen Austausch nicht übermitteln. Überprüfen Sie die Transportadresse im Kanal. Korrigieren Sie das Problem, und versenden Sie den Austausch erneut.
Überträgt | Timeoutfehler | BizTalk Server konnte die Verarbeitung dieses Austauschs nicht vor dem Erreichen des Timeouts abschließen. Dies kann die Ursache haben, dass die Übertragung zuviel Zeit beanspruchte. Wenn Sie einen nicht zuverlässigen Transport verwenden, überprüfen Sie, ob dieser Austausch gesendet wurde, bevor Sie versuchen, ihn erneut zu versenden.
Überträgt | Benutzer verschoben | Ein BizTalk Server-Administrator hat dieses Dokument in die Angehalten-Warteschlange verschoben. Versenden Sie den Austausch erneut.
Überträgt | Zeitstempel abgelaufen | Der BizTalk Framework-Zeitstempel "receiptRequiredBy" ist abgelaufen. Dieses Dokument ist nicht mehr gültig.
Dokumentüberprüfung | Ungültiges Dokument | Die Überprüfung des Dokuments anhand seiner Spezifikation ist fehlgeschlagen. Weitere Informationen finden Sie in der Fehlerbeschreibung im Ereignisprotokoll. Korrigieren Sie das Schema, und versenden Sie das Dokument erneut.
Feldüberwachung | Feldüberwachungsfehler | BizTalk Server konnte die angeforderten Felder innerhalb des Dokuments nicht überwachen. Zeigen Sie das Dokument an, um zu überprüfen, ob die zu überwachenden Felder vorhanden sind, oder ändern Sie die Kanalkonfiguration für die Feldüberwachung. Versenden Sie das Dokument anschließend erneut.
Benutzerdefinierte Komponente | Fehler bei einer benutzerdefinierten Komponente | Fehler bei einer benutzerdefinierten Komponente. Führen Sie eine Problembehandlung bei der benutzerdefinierten Komponente oder dem benutzerdefinierten Präprozessor durch, und versenden Sie den Austausch erneut.
Korreliert | Korrelationsfehler | Fehler beim Korrelieren dieser Empfangsbestätigung.

Anmerkungen

  • Über das Überprüfen der Fehlermeldungen in der Angehalten-Warteschlange hinaus können Sie auch das Ereignisprotokoll überprüfen, um weitere Informationen zu erhalten. Weitere Informationen zum Ereignisprotokoll finden Sie unter Verwalten der Ereignisanzeige.

  • Nicht alle Dokumente in der Angehalten-Warteschlange können erneut versendet werden. In einigen Situationen müssen Sie das Dokument löschen und es erneut aus der ursprünglichen Anwendung oder Organisation heraus versenden.

Verwandte Themen

Ein Austausch oder Dokument wird in der Angehalten-Warteschlange als Binärdaten angezeigt

Verwalten der Ereignisanzeige

Verwalten von Warteschlangen

Analysefehler

Grundlegendes zu Empfangsfunktionen und Dokumentrouting

Grundlegendes zu erweiterten Eigenschaften von Empfangsfunktionen

Verwenden von Warteschlangen


Administratorprivilegien

Um die BizTalk Server-Verwaltung anzuzeigen, müssen Sie Mitglied der BizTalk Server-Administratorgruppe sein. Wenn Sie nicht als BizTalk Server-Administrator angemeldet sind, können Sie keine Elemente im Ordner Microsoft BizTalk Server 2000 anzeigen. Wenn Sie Mitglied der BizTalk Server-Administratorgruppe, nicht jedoch Mitglied der Microsoft Windows 2000-Administratorgruppe sind, können Sie nur die folgenden Aufgaben ausführen:

  • Hinzufügen und Entfernen von Servergruppen

  • Anzeigen und Ändern von Gruppeneigenschaften

  • Verwalten aller Warteschlangen und ihrer Einträge

  • Hinzufügen und Entfernen von Empfangsfunktionen

  • Anzeigen und Ändern von Empfangsfunktionseigenschaften

Darüber hinaus müssen Sie zum Verwalten einer Servergruppe, die drei Server enthält, z. B. Server_1, Server_2 und Server_3, über Windows 2000-Administratorprivilegien auf allen drei Servern verfügen. Wenn die Windows 2000-Administratorprivilegien auf Server_1 geändert wurden und Sie nicht mehr über Administratorprivilegien verfügen, gibt die Verwaltungskonsole eine Liste aller drei der Gruppe angehörenden Server zurück und listet den Status jedes der Server auf. Der Status von Server_1 wird als "Zugriff verweigert" zurückgegeben.

Wenn Sie sowohl Mitglied der BizTalk Server-Administratorgruppe und der Windows 2000-Administratorgruppe sind, können Sie die folgenden zusätzlichen Aufgaben durchführen:

  • Hinzufügen von Servern zu und Entfernen von Servern aus einer Servergruppe

  • Anzeigen und Ändern von Servereigenschaften

  • Anzeigen des Serverstatus

  • Freigeben von Austauschvorgängen auf einem Server

Beim Setup wird der Benutzer, der die BizTalk Server-Installation durchführt, der BizTalk Server-Administratorgruppe hinzugefügt. Sie können der BizTalk Server-Administratorgruppe weitere Benutzer hinzufügen. Weitere Informationen finden Sie unter Hinzufügen von Benutzern zur Gruppe "BizTalk Server-Administratoren".


Problembehandlung - BizTalkServer-Verwaltung

BizTalk Server-Kopfzeile

Problembehandlung - BizTalk Server-Verwaltung

Dieser Abschnitt stellt einen zentralen Ort für Informationen zur Problembehandlung in der BizTalk Server-Verwaltung bereit. Wenn Fehlermeldungen angezeigt werden, versuchen Sie, in diesem Abschnitt eine Lösung zu finden.

Ergänzende Informationen zu Problemen, die nach der Veröffentlichung dieser Dokumentation entdeckt wurden, befinden sich in der Readme-Datei, die sich im Ordner Documentation innerhalb des Microsoft BizTalk Server-Ordners befindet.

Die folgenden Probleme werden behandelt:

  • Fehler beim Abrufen aller Gruppen aus einer Datenbank

  • Austausch- und Dokumentgrößenbeschränkung

  • Transaktionstimeout-Abweichung zwischen den Komponentendiensten und BizTalk Server 2000

  • Der BizTalk-Messagingdienst startet nicht

  • Verringerte Leistung beim Löschen einer großen Menge von Dokumenten aus der Angehalten-Warteschlange

  • Überprüfungsfehler bei Ausgabe

  • Der Server gibt in einem Flatfileaustausch nicht alle Dokumente zurück

  • Klassenbezeichner wird in der Präprozessorliste angezeigt

  • Ein Austausch oder Dokument wird in der Angehalten-Warteschlange als Binärdaten angezeigt

  • BizTalk Server hat die Verarbeitung von Dokumenten unterbrochen

  • Die Empfangsfunktion löscht das Dokument nicht

  • Es kann keine Verbindung mit einem SQL-Server auf einem Clustercomputer hergestellt werden

  • Die Empfangsfunktionen haben die Verarbeitung von Dokumenten abgebrochen

  • Fehler beim Verschieben eines Remoteservers in eine andere BizTalk-Messaging-Verwaltungsdatenbank

  • Analysefehler

Anmerkung

  • Sie können außerdem die Fehlermeldungen in der Angehalten-Warteschlange überprüfen, um weitere Informationen zur Problembehandlung zu erhalten. Weitere Informationen zu der Angehalten-Warteschlange, Fehlermeldungen und möglichen Vorgehensweisen finden Sie unter Angehalten-Warteschlange.

  • Sie können darüber hinaus das Ereignisprotokoll auf detaillierte Informationen, wie z. B. Fehler- und Warnmeldungen, überprüfen. Weitere Informationen zu dem Ereignisprotokoll finden Sie unter Verwalten der Ereignisanzeige.


Fehler beim Abrufen aller Gruppen aus einer Datenbank

Ursache: Die BizTalk-Messaging-Verwaltungsdatenbank ist im Offlinemodus, wenn die folgende Meldung angezeigt wird:

Instanzen von Microsoft BizTalkServer_Group können nicht aufgezählt werden: Die Verbindung zur BizTalk-Messaging-Verwaltungsdatenbank konnte nicht geöffnet werden.

Lösung: Finden Sie heraus, warum der Server im Offlinemodus ist, und versuchen Sie erneut, die Verbindung herzustellen, wenn er wieder im Onlinemodus ist. Beispielsweise können Sie diese Meldung erhalten, wenn der Server, der als Host für die BizTalk-Messaging-Verwaltungsdatenbank dient, zu Wartungszwecken im Offlinemodus betrieben wird.


Austausch- und Dokumentgrößenbeschränkung

Die maximal unterstützte Größe für ein an BizTalk Server gesendetes Dokument beträgt 20 MB. Die maximal unterstützte Größe für einen an BizTalk Server gesendeten Austausch beträgt 20 MB.

Wenn Sie beabsichtigen, Austauschvorgänge im XML-Unicodeformat zu empfangen, die größer als 20 MB sind, ist es ratsam, die globalen Überwachungseinstellungen zu deaktivieren. Wenn Sie beabsichtigen, Austauschvorgänge im ANSI-Flatfileformat zu empfangen, die größer als 7-10 MB sind, ist es ratsam, die globalen Überwachungseinstellungen zu deaktivieren. Weitere Informationen zum Konfigurieren der Überwachungseinstellungen für eine Servergruppe finden Sie unter Konfigurieren von Überwachungseigenschaften für eine Servergruppe.

Analog ist es ratsam, die Einstellungen zur Dokumentprotokollierung im BizTalk-Messaging-Manager zu deaktivieren, wenn Sie beabsichtigen, Dokumentinstanzen im XML-Unicodeformat mit einer Größe von mehr als 20 MB zu empfangen. Ebenso empfiehlt sich das Deaktivieren der Einstellungen zur Dokumentprotokollierung im BizTalk-Messaging-Manager, wenn Sie beabsichtigen, ANSI-Flatfiles zu empfangen, die größer als 7-10 MB sind. Weitere Informationen zum Speichern von Kopien bestimmter Dokumentinstanzen finden Sie unter Festlegen von Eigenschaften für die Dokumentprotokollierung.

Verwandte Themen

Konfigurieren von Überwachungseigenschaften für eine Servergruppe

Festlegen von Eigenschaften für die Dokumentprotokollierung


Transaktionstimeout-Abweichung zwischen den Komponentendiensten und BizTalkServer2000

BizTalk Server-Kopfzeile

Transaktionstimeout-Abweichung zwischen den Komponentendiensten und BizTalk Server 2000

Es existiert eine Abweichung des Dateitimeouts zwischen den Komponentendiensten und BizTalk Server 2000. Beim Senden einer Datei mit BizTalk Server 2000, die den standardmäßigen Transaktionstimeout-Wert von 60 Sekunden überschreitet, verzeichnet BizTalk Server 2000 die Transaktion als gesendet, und der empfangende Server empfängt die Datei ohne Fehler. Die Komponentendienste verzeichnen die Transaktion als abgebrochen. Es kann kein Rollback von Transaktionen durchgeführt werden.


Der BizTalk-Messagingdienst startet nicht

Ursache: Der BizTalk-Messagingdienst startet nicht, wenn BizTalk Server keine Verbindung zum SQL-Server herstellen kann, auf dem die BizTalk-Messaging-Verwaltungsdatenbank gespeichert ist. Alle COM+-Pakete werden unter einem interaktiven Benutzerkonto, nicht unter dem lokalen Systemkonto, ausgeführt. Der Dienst startet nur, wenn ein Benutzer an BizTalk Server angemeldet ist. Wenn z. B. eine Clientanwendung Dokumente remote an BizTalk Server versendet und kein Benutzer an dem Server angemeldet ist, auf dem BizTalk Server 2000 ausgeführt wird, startet der Dienst nicht.

Lösung: Überprüfen Sie die Verbindung von BizTalk Server zur BizTalk-Messaging-Verwaltungsdatenbank. Stellen Sie sicher, dass Microsoft SQL Server ordnungsgemäß ausgeführt wird. Möglicherweise müssen Sie ein Dienstkonto für die Ausführung von BizTalk Server erstellen. Weitere Informationen zum Erstellen eines Dienstkontos finden Sie in der Windows 2000-Hilfe im Kapitel über Dienste unter "So wählen Sie ein Benutzerkonto für die Anmeldung eines Dienstes aus".


Verringerte Leistung beim Löschen einer großen Menge von Dokumenten aus der Angehalten-Warteschlange

Ursache: Möglicherweise bemerken Sie eine geringe Leistung, wenn eine große Menge von Dokumenten aus der Angehalten-Warteschlange gelöscht wird.

Lösung: Wenn Sie alle Dokumente in der Angehalten-Warteschlange löschen müssen, sollten Sie PurgeBizTalkSuspendedQueue.vbs verwenden, ein Microsoft Visual Basic-Beispielskript, das zu diesem Zweck bereitgestellt wird. Nach der Installation von BizTalk Server 2000 finden Sie dieses Skript im Ordner \Programme\Microsoft BizTalk Server\SDK\Messaging Samples\Miscellaneous.

Vorsicht

  • Verwenden Sie dieses Skript nur, wenn Sie den gesamten Inhalt der Angehalten-Warteschlange für die angegebene BizTalk Server-Gruppe permanent löschen möchten.


Überprüfungsfehler bei Ausgabe

Ursache 1: Der Datentyp eines Feldes in der Quellspezifikation stimmt nicht mit dem Datentyp des Feldes überein, mit dem es in der Zielspezifikation verknüpft ist. Dieser Fehler wird in der Ereignisanzeige protokolliert.

Lösung: Korrigieren Sie den Datentyp entweder in der Quell- oder in der Zielspezifikation. Weitere Informationen zu Quell- und Zielspezifikationen finden Sie unter Erstellen und Überprüfen von Spezifikationen.

Ursache 2: Ein Funktoid ist mit einem Feld in der Zielspezifikation verknüpft, und die Eigenschaft des Felddatentyps ist keine Zeichenfolge.

Lösung: Ändern Sie den Felddatentyp in der Zielspezifikation in String. Senden Sie das Dokument für die Verarbeitung an BizTalk Server. Weitere Informationen zu Datentypen finden Sie unter Festlegen von Deklarationseigenschaften.

Ursache 3: In der Zielspezifikation ist einem Feld ein konstanter Wert zugewiesen, der einen anderen Datentyp als den diesem Feld bereits zugewiesenen Datentyp aufweist.

Lösung: Ändern Sie in der Zielspezifikation den diesem Feld zugewiesenen Datentyp. Senden Sie das Dokument für die Verarbeitung an BizTalk Server. Weitere Informationen zu Datentypen finden Sie unter Festlegen von Deklarationseigenschaften.

Ursache 4: In EDIFACT-Daten befinden sich Versionsindikatoren. Die Versionszeichen werden in der logischen Zeichenzahl beim Überprüfen der maximalen physischen Zeichenbeschränkung für ein Feld mit erfasst. Dieser Fehler wird in der Ereignisanzeige protokolliert.

Lösung: Verwenden Sie in EDIFACT-Daten keine Versionsindikatoren. BizTalk Server fügt in ausgehende Daten bei Bedarf automatisch Versionsindikatoren ein.

Verwandte Themen

Erstellen und Überprüfen von Spezifikationen

Festlegen von Deklarationseigenschaften


Der Server gibt in einem Flatfileaustausch nicht alle Dokumente zurück

Ursache: Eines der Dokumente im Austausch entspricht nicht der Dokumentspezifikation. In einem der Dokumente kann z. B. ein erforderliches Feld fehlen.

Lösung: Suchen Sie das Dokument, das nicht der Spezifikation entspricht, korrigieren Sie dieses, und versenden Sie den Austausch erneut. Obwohl für das Dokument, das nicht der Spezifikation entspricht, ein Fehler zurückgegeben wird, kann BizTalk Server nicht alle Dokumente im Austausch verarbeiten. Die Flatfilestruktur ist ein offenes Format und nicht für die Implementierung der Redundanzüberprüfung ausgelegt.


Klassenbezeichner wird in der Präprozessorliste angezeigt

Ursache: Der benutzerdefinierte Präprozessor ist nicht mehr registriert.

Lösung: Überprüfen Sie das Ereignisprotokoll, um zu bestätigen, dass der benutzerdefinierte Präprozessor nicht mehr registriert ist. Registrieren Sie den benutzerdefinierten Präprozessor anschließend erneut, oder wählen Sie in der Liste einen anderen Präprozessor aus.

Verwandte Themen

Konfigurieren einer Dateiempfangsfunktion: Registerkarte "Dienste"

Benutzerdefinierte Präprozessoren

Preprocessing Documents in a Receive Function


Ein Austausch oder Dokument wird in der Angehalten-Warteschlange als Binärdaten angezeigt

Ursache 1: BizTalk Server konnte den Austausch oder das Dokument nicht analysieren.

Lösung: Löschen Sie das Dokument aus der Angehalten-Warteschlange. Stellen Sie sicher, dass der eingehende Austausch oder das eingehende Dokument ein Format aufweist, das BizTalk Server verarbeiten kann (XML, X12, EDIFACT oder FLATFILE). Senden Sie es/ihn erneut von der ursprünglichen Organisation oder Anwendung.

Wenn BizTalk Server ein Dokument nicht analysieren kann, wird es in der Angehalten-Warteschlange als Binärdaten angezeigt, weil BizTalk Server nicht über ausreichende Informationen verfügt, um das Dokument korrekt zu verarbeiten. Weitere Informationen zu Analysefehlern finden Sie unter Analysefehler.

Ursache 2: BizTalk Server konnte den Austausch oder das Dokument analysieren, der Dateninhalt war jedoch ungültig. Der Zeitstempel "expiresAt" ist abgelaufen, und das Dokument ist nicht mehr gültig. Dieser Fehler tritt in BizTalk Framework-Dokumenten auf, die das Feld "expiresAt" verwenden.

Lösung: Löschen Sie das Dokument aus der Angehalten-Warteschlange. Dieses Dokument ist nicht mehr gültig. Finden Sie heraus, warum das Dokument nicht mehr gültig ist.

Ursache 3: BizTalk Server konnte das Dokument nicht analysieren, weil das Schema für das Dokument nicht korrekt ist. Wenn Sie eine Flatfile empfangen und die Codepage für die Dokumentspezifikation auf UTF-8 festgelegt ist, kann BizTalk Server das Dokument nicht analysieren, weil UTF-8 nicht unterstützt wird.

Lösung: Wenn Sie eine Flatfile empfangen, überprüfen Sie, ob die Dokumentspezifikation korrekt ist. Wenn die Codepage für die Dokumentspezifikation auf UTF-8 festgelegt ist, kann BizTalk Server das Dokument nicht verarbeiten. Löschen Sie das Dokument aus der Angehalten-Warteschlange. Weitere Informationen finden Sie unter Festlegen von Verweiseigenschaften.

Verwandte Themen

Analysefehler

Festlegen von Verweiseigenschaften

Angehalten-Warteschlange


BizTalkServer hat die Verarbeitung von Dokumenten unterbrochen

BizTalk Server-Kopfzeile

BizTalk Server hat die Verarbeitung von Dokumenten unterbrochen

Ursache 1: BizTalk Server kann die Verarbeitung von Dokumenten nicht fortsetzen, wenn die Verbindung zu einer der drei Datenbanken – BizTalk-Messaging-Verwaltung, Überwachung oder Gemeinsam genutzte Warteschlangen – verloren wird oder auf die Datenbanken aus anderen Gründen nicht zugegriffen werden kann. Dies kann geschehen, wenn Microsoft SQL Server in Enterprise Manager heruntergefahren oder angehalten wird. Wenn Microsoft BizTalk Server 2000 auf diesen Fehler trifft, werden die BizTalk-Messagingdienste ordnungsgemäß beendet, um den Status der Verarbeitung und die Integrität im Moment des Versagens korrekt zu speichern. Es wird ein Fehler mit vollständiger Beschreibung der Ursache für das Herunterfahren des Dienstes in der Ereignisanzeige aufgezeichnet.

Lösung: Systemadministratoren können diesen Fehler für eine Benachrichtigung über Funkruf oder per Statusmitteilung über E-Mail verwenden, dass BizTalk Server im Offlinemodus ist. Bei einer solchen Benachrichtigung muss der Administrator die BizTalk-Messagingdienste im Dienste-Snap-In der Microsoft Management Console manuell neu starten und anschließend das Ereignisprotokoll erneut überprüfen, um zu ermitteln, ob der Fehler noch vorhanden ist. Wenn dies der Fall ist, muss der Administrator bestätigen, dass die Microsoft SQL Server-Dienste für BizTalk Server verfügbar sind. Weitere Informationen zum Starten der BizTalk-Messagingdienste finden Sie unter Starten des BizTalk-Messagingdienstes.

Ursache 2: Wenn Sie Antivirensoftware auf dem Server verwenden, auf dem BizTalk Server 2000 installiert ist, sind die Standardeinstellungen in einem Messagingport möglicherweise nicht korrekt.

Lösung: Die Standardeinstellung für die Dateitransportkomponente sieht das Anfügen von Dateien vor. Wenn Sie den Dateitransporttyp mit Standardeinstellungen in einem Messagingport auswählen und auf dem Server, auf dem BizTalk Server 2000 installiert ist, Antivirensoftware verwenden und Sie außerdem mehrere Dateien mit exakt demselben Namen gleichzeitig an denselben Dateispeicherort senden, hört BizTalk Server 2000 möglicherweise auf zu reagieren und muss neu gestartet werden. Sie können dieses Problem beheben, indem Sie die Standardeinstellung für die Dateitransportkomponente im Dialogfeld BizTalk SendLocalFile-Eigenschaften von An Datei anhängen in Datei überschreiben ändern. Ferner können Sie das Problem beheben, indem Sie für jede verarbeitete Dokumentinstanz mithilfe des Dateipfadformats im Messagingport eine eindeutige Datei erstellen: file://C:\dir\file%tracking_id%.xml. Weitere Informationen finden Sie unter Angeben einer Transportadresse. Wenn Sie den Server neu starten müssen, finden Sie weitere Informationen unter Starten eines Servers in einer Gruppe.

Verwandtes Thema

Angeben einer Transportadresse

Starten eines Servers in einer Gruppe

Starten des BizTalk-Messagingdienstes


Die Empfangsfunktion löscht das Dokument nicht

Ursache: Möglicherweise ist das Wiederholungsintervall im Rahmen der Verarbeitungskapazität für die Anzahl der generierten Dokumente zu klein gewählt.

Lösung: Verdoppeln Sie das Wiederholungsintervall, und senden Sie die Dokumente erneut an BizTalk Server. Weitere Informationen zum Konfigurieren des Wiederholungsintervalls finden Sie unter Festlegen von erweiterten Konfigurationseigenschaften.

Verwandtes Thema

Festlegen von erweiterten Konfigurationseigenschaften


Es kann keine Verbindung mit einem SQL-Server auf einem Clustercomputer hergestellt werden

Ursache: Wenn Microsoft SQL Server auf einem Cluster installiert wird, kann SQL Server nur Clients unterstützen, die Verbindungen mithilfe TCP/IP herstellen.

Lösung: Installieren Sie die SQL Server-Clienttools, und ändern Sie die Standardnetzwerkbibliothek in TCP/IP. Weitere Informationen zum Installieren der SQL Server-Clienttools finden Sie unter Installieren der SQL Server-Clienttools. Weitere Informationen zum Ändern der Standardnetzwerkbibliothek finden Sie unter Ändern der Standard-Netzwerkbibliothek in TCP/IP.

Verwandte Themen

Ändern der Standard-Netzwerkbibliothek in TCP/IP

Installieren der SQL Server-Clienttools


Die Empfangsfunktionen haben die Verarbeitung von Dokumenten abgebrochen

Ursache: Ein einzelner Remoteserver kann nicht mehr als 50 Empfangsfunktionen zur gleichen Zeit unterstützen.

Lösung: Weitere Informationen zum Unterstützen mehrerer Empfangsfunktionen finden Sie in der Microsoft Product Support Services-Website unter search.support.microsoft.com/kb/c.asp. Suchen Sie in der Knowledge Base nach folgendem Artikel:

  • "Too Many Connections to Remote Share May Cause PRC Failures" (Artikelnummer Q221790).

Weitere Informationen finden Sie in den folgenden Knowledge Base-Artikeln:

  • "Local System Account and Null Sessions in Windows NT" (Artikelnummer Q132679).

  • "Service Running As System Account Fails Accessing Network" (Artikelnummer Q124184).

  • "PRB: Access Denied When Opening a Named Pipe from a Service" (Artikelnummer Q126645).

  • "FindFirstChangeNotification May Not Notify All Processes on File Changes" (Artikelnummer Q188321).


Fehler beim Verschieben eines Remoteservers in eine andere BizTalk-Messaging-Verwaltungsdatenbank

Ursache: Möglicherweise gehört der Server zu einer anderen BizTalk-Messaging-Verwaltungsdatenbank.

Lösung: Wenn Sie versuchen, einen Remoteserver zu einer BizTalk-Messaging-Verwaltungsdatenbank hinzuzufügen, und sich dieser Server ursprünglich in einer anderen zentralen BizTalk-Messaging-Verwaltungsdatenbank befand, wird im Windows-Ereignisprotokoll der folgende Fehler angezeigt:

Eine neue Instanz der WMI-Klasse "MicrosoftBizTalkServer_Server" kann nicht im WMI-Provider von BizTalk Server erstellt werden. Der Server <servername> gehört möglicherweise bereits zu einer anderen BizTalk Server-Installation.

Dieser Fehler bedeutet, dass ein Versuch unternommen wurde, einen Remoteserver hinzuzufügen, der sich ursprünglich in einer anderen zentralen Datenbank befand. Wenn dieses Verfahren in der BizTalk Server-Verwaltung durchgeführt wurde, versucht die Verwaltungskonsole zu ermitteln, ob der Remoteserver ebenfalls zu einer Gruppe in der Remote-Zentraldatenbank gehört. Die Verwaltungskonsole fragt den WMI-Provider (Windows Management Instrumentation) des Remoteservers ab, um diese Ermittlung durchzuführen. Wenn der Server zu einer Gruppe in der anderen Zentraldatenbank gehört, wird eine Fehlermeldung der Verwaltungskonsole angezeigt, die erläutert, dass kein Remoteserver hinzugefügt werden kann, der bereits zu einer Gruppe in einer anderen Zentraldatenbank gehört.

Verwandtes Thema

WMI - Übersicht


Analysefehler

Ursache 1: Wenn Sie Nachrichten im RELIABLE-Format senden, sind die Standardeinstellungen in einem Messagingport möglicherweise nicht korrekt.

Lösung: Die Standardeinstellung für die Dateitransportkomponente sieht das Anfügen von Dateien vor. Wenn Sie den Dateitransporttyp mit Standardeinstellungen wählen und einen Umschlag mit dem RELIABLE-Umschlagformat in einem Messagingport auswählen und dann mehrere Dateien zugleich an denselben Dateispeicherort senden, können unerwartete Ergebnisse beim Analysieren der Datei auftreten. Sie können dieses Problem beheben, indem Sie die Standardeinstellung für die Dateitransportkomponente im Dialogfeld BizTalk SendLocalFile-Eigenschaften von An Datei anhängen in Datei überschreiben ändern. Weitere Informationen zum Ändern der Standardeinstellungen in einem Messagingport finden Sie unter Außerkraftsetzen von Messagingportstandards.

Andere Ursachen: BizTalk Server kann Dokumente aus einer Vielzahl von Gründen nicht analysieren. Einige häufige Ursachen sind:

  • Der Austausch oder das Dokument liegt in einem Format vor, das BizTalk Server nicht interpretieren kann.

  • Das Schema für das Dokument ist nicht korrekt.

  • Ein Flatfileaustausch weist ein falsches oder ungültiges Schema auf.

  • Ein Flatfileaustausch enthält ungültige Zeichen.

  • In einem Flatfileaustausch fehlen Zeichen.

  • In einem Flatfileaustausch fehlen Trennzeichen.

  • Für ein BizTalk Framework 2.0-Dokument ist ein ungültiger Aliasname im Messagingport oder Kanal aufgelistet.

  • In einer benutzerdefinierten XML-Kopfzeile fehlt der Dokumentcontainerknoten.

  • In einem benutzerdefinierten XML-Dokument fehlt ein Attribut.

  • Eine EDI-Dokumentspezifikation stimmt nicht mit dem Umschlag überein.

Lösung: Zeigen Sie die Austausch- oder Dokumentdaten an, um zu ermitteln, warum BizTalk Server den Austausch oder das Dokument nicht analysieren konnte. Sie können folgendermaßen vorgehen, um die Daten des Austauschs oder Dokuments anzuzeigen:

  • Zeigen Sie die ersten 512 Bytes der Austausch- oder Dokumentdaten an. Weitere Informationen zum Anzeigen von Austausch- und Dokumentdaten finden Sie unter Anzeigen von Austauschvorgängen oder Anzeigen von Dokumenten.

  • Zeigen Sie die Austauschdaten im Austauschdatensatz in der BizTalk-Dokumentüberwachung an. Weitere Informationen zum Anzeigen von Austauschvorgängen in der BizTalk-Dokumentüberwachung finden Sie unter Datumsabhängiges Suchen nach Austausch- und Dokumentinformationen, Organisationsabhängiges Suchen nach Austausch- und Dokumentinformationen, Dokumenttypabhängiges Suchen nach Austausch- und Dokumentinformationen oder Suchen nach Austausch- und Dokumentinformationen durch Kombinieren von Abfrageparametern.

  • Verwenden Sie die WMI-Schicht (Windows Management Instrumentation), um die Austauschdaten anzuzeigen. Weitere Informationen zu der WMI-Anwendungsprogrammierung finden Sie in der MSDN Online Library-Website unter msdn.microsoft.com/library/default.asp. Suchen Sie in der Website nach "WMI Application Programming".

Nachdem Sie ermittelt haben, warum BizTalk Server das Dokument nicht analysieren konnte, korrigieren Sie das Problem, und versenden Sie den Austausch oder das Dokument erneut mithilfe von IInterchange oder einer Empfangsfunktion.

Verwandte Themen

Ein Austausch oder Dokument wird in der Angehalten-Warteschlange als Binärdaten angezeigt

Datumsabhängiges Suchen nach Austausch- und Dokumentinformationen

Dokumenttypabhängiges Suchen nach Austausch- und Dokumentinformationen

Organisationsabhängiges Suchen nach Austausch- und Dokumentinformationen

Suchen nach Austausch- und Dokumentinformationen durch Kombinieren von Abfrageparametern

Angehalten-Warteschlange

Anzeigen von Dokumenten

Anzeigen von Austauschvorgängen


Programmgesteuerte Administration

Die Schnittstellen in diesem Abschnitt stellen den Zugriff auf System-Manager der XLANG-Ablaufplanung (XLANG Scheduler), XLANG-Gruppen-Manager, XLANG-Ablaufplaninstanzen und XLANG-Ports bereit.

Der System-Manager der XLANG-Ablaufplanung (XLANG Scheduler) stellt die Monikerauflösung bereit und verwaltet eine Zusammenstellung von Gruppen-Managern. Ein Gruppen-Manager wird in jeder COM+-Anwendung ausgeführt, die als Host eines XLANG-Ablaufplanes vorgesehen ist, und verwaltet eine Zusammenstellung von XLANG-Ablaufplaninstanzen. Eine XLANG-Ablaufplaninstanz stellt einen ausgeführten XLANG-Ablaufplan dar, dessen Informationen abgefragt werden können, wie z. B. Ablaufplanzustand. Bei XLANG-Ablaufplänen mit einem Port, der an eine COM-Komponente gebunden ist, kann ein Proxyobjekt verwendet werden, um einen Verweis auf die Schnittstelle abzurufen, die in der Portbindung angegeben ist.

Anmerkung

  • Auf jedem Computer darf nur ein System-Manager der XLANG-Ablaufplanung (XLANG Scheduler) vorhanden sein.

Die folgende Abbildung veranschaulicht die Beziehung zwischen diesen Schnittstellen und den entsprechenden Monikern.

Relationship diagrams for XLANG interfaces
sked://[host]
System manager
IWFSystemAdmin
sked://[host][!group]
XLANG schedule instance
XLANG schedule instance
XLANG schedule instance
Group manager
Group manager
Group manager
WorkflowInstance
IWFProxy
IWFWorkflowInstance
IWFWorkflowInstance
IWFWorkflowInstance
IWFGroupAdmin
IWFGroupAdmin
IWFGroupAdmin
sked://[host][!group]/file.skx
sked://[host][!group]/file.skx/port
Proxy to COM-bound XLANG port

Weitere Informationen finden Sie unter Administering XLANG Schedules.

Verwandtes Thema

Monikersyntax


Überwachen von Dokumenten

Die BizTalk-Dokumentüberwachung ist eine eigenständige Webanwendung, mit der Sie den Status der von Microsoft BizTalk Server 2000 verarbeiteten Dokumente anzeigen können. Sie können einfache oder erweiterte Abfragen erstellen, um die gewünschten Informationen aus der Überwachungsdatenbank in einem übersichtlichen Format abzurufen. In der BizTalk-Dokumentüberwachung können Sie z. B. erfasste Informationen zu Quelle und Ziel des Dokuments, zum Dokumentnamen und zum Dokumenttyp sowie relevante Daten- und Zeitparameter anzeigen. Ferner können Sie Abfragen erstellen, mit denen standardmäßige und benutzerdefinierte Suchfelder angezeigt werden, damit Sie Geschäftsabläufe untersuchen können. Für jeden Auftrag, der an einen Lieferanten gesendet wird, kann z. B. das Feld Auftragssumme gespeichert werden. Anhand dieser Daten können Sie dann über einen Zeitraum den monetären Gesamtwert von Aufträgen an einen oder mehrere Lieferanten untersuchen und in Berichtform ausgeben.

Darüber hinaus können Sie die BizTalk-Dokumentüberwachung so konfigurieren, dass Austausch- und Dokumentdatensätze einzeln oder in Batches angezeigt werden. Mithilfe der BizTalk-Dokumentüberwachung können Sie auch vollständige Kopien ein- und ausgehender Dokumentinstanzen zur künftigen Bezugnahme anzeigen, untersuchen und speichern.

  • Hilfe zu bestimmten Aufgaben finden Sie unter Verfahrensweise.

  • Allgemeine Hintergrundinformationen finden Sie unter Grundbegriffe.

  • Anleitungen zum Beheben von Problemen finden Sie unter Problembehandlung - BizTalk-Dokumentüberwachung.

Wichtig

  • Da die BizTalk-Dokumentüberwachung als Webanwendung in Microsoft Internet Explorer geöffnet wird, erfolgt ein anderer Zugriff auf die Microsoft BizTalk Server 2000-Hilfe, deren Funktionalität etwas eingeschränkt ist. Die Registerkarten Inhaltsverzeichnis, Index, Suchen und Favoriten stehen nicht zur Verfügung. Sie können auf alle Themen über Verknüpfungen auf der Eröffnungsseite, über die Verknüpfungen Verwandte Themen und über die Schaltfläche Zurück im Browser zugreifen.

    Wenn Sie nach einem bestimmten Hilfethema suchen oder Informationen zu anderen Funktionen und Diensten von BizTalk Server 2000 wünschen, zeigen Sie im Startmenü auf Programme, dann auf Microsoft BizTalk Server 2000, und klicken Sie dann auf BizTalk Server-Dokumentation. Damit die Hilfe im Startmenü zur Verfügung steht, muss BizTalk Server 2000 auf dem Computer installiert sein.

  • Da die BizTalk-Dokumentüberwachung Microsoft ActiveX-Steuerelemente verwendet, kann während einer Auswahl oder Übermittlung von Abfragen ein Dialogfeld zum Download von ActiveX-Steuerelementen angezeigt werden. Klicken Sie in diesem Fall auf Ja, um fortzufahren.

Anmerkung

  • Ein Dialogfeld mit der folgenden Meldung wird bei der Auswahl oder Abfrageauswahl möglicherweise angezeigt:

    Diese Seite greift auf Daten einer anderen Domäne zu. Möchten Sie dies zulassen?

    Damit diese Meldung im Internet Explorer nicht mehr angezeigt wird, können Sie eine sichere Website zu den vertrauenswürdigen Sites auf der Registerkarte Sicherheit im Dialogfeld Internetoptionen hinzufügen.

    Fügen Sie die Webanwendung zur Liste der vertrauenswürdigen Sites im Internet Explorer hinzu, um die Browsereinstellungen manuell so zu konfigurieren, dass dieser Webanwendung vertraut wird. Weitere Informationen zum Hinzufügen der Webanwendung zur Liste der vertrauenswürdigen Sites finden Sie unter Konfigurieren der Internet Explorer-Sicherheitseinstellungen.


Verfahrensweise

Dieser Abschnitt stellt aufgabenspezifische Informationen bereit, die veranschaulichen, wie Sie Suchergebnisse für Austausch- und Dokumentinstanz-Datensätze sowie dazugehörige Daten suchen, anzeigen und speichern können. Es wird dringend empfohlen, dass Sie den Abschnitt Grundbegriffe lesen, um die Suchfunktionen und erwarteten Abfrageergebnisse vollständig zu verstehen.

Die BizTalk-Dokumentüberwachung bieten zwei Suchfunktionsebenen: Abfrage und Erweiterte Abfrage. Sie können Abfragen verwenden, wenn Sie Dokumente anhand standardmäßiger Suchkriterien, wie z. B. Quellorganisation, suchen möchten. Mithilfe erweiterter Abfragen können Sie bestimmte Informationen in Dokumenten suchen, wie z. B. Auftragssumme.

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Erstmaliges Öffnen der BizTalk-Dokumentüberwachung

  • Öffnen der BizTalk-Dokumentüberwachung

  • Hinzufügen von Benutzern zur Gruppe "Benutzer des BizTalk-Serverberichts"

  • Verwenden von Abfragen zum Durchsuchen und Sortieren von Austausch- und Dokumentdaten

  • Erweiterte Abfragen

  • Speichern von Austausch-, Dokument und benutzerdefinierten Suchdaten


Erstmaliges Öffnen der BizTalk-Dokumentüberwachung

Wenn Sie die BizTalk-Dokumentüberwachung zum ersten Mal öffnen und Windows Common Controls und das Steuerelement BizTalk-Dokumentüberwachung nicht auf dem Computer installiert sind, werden Sie zur Installation dieser Komponenten aufgefordert. Wenn diese Komponenten installiert sind, siehe Öffnen der BizTalk-Dokumentüberwachung.

  1. Zeigen Sie im Startmenü auf Programme, dann auf Microsoft BizTalk Server 2000, und klicken Sie auf BizTalk-Dokumentüberwachung.

    Das Dialogfeld Web Page Dialog wird angezeigt und fordert Sie zur Installation der folgenden Komponenten auf:

    • Windows Common Controls

    • BizTalk-Installationssteuerelement für die Dokumentüberwachung
  2. Klicken Sie auf Fortsetzen, um die Windows Common Controls zu installieren.

    Das Dialogfeld Sicherheitswarnung wird angezeigt.

  3. Klicken Sie auf Ja, um das BizTalk-Installationssteuerelement für die Dokumentüberwachung zu installieren.

Anmerkung

  • Ein Dialogfeld mit der folgenden Meldung wird bei der Auswahl oder Abfrageauswahl möglicherweise angezeigt:

    Diese Seite greift auf Daten einer anderen Domäne zu. Möchten Sie dies zulassen?

    Damit diese Meldung im Internet Explorer nicht mehr angezeigt wird, können Sie eine sichere Website zu den vertrauenswürdigen Sites auf der Registerkarte Sicherheit im Dialogfeld Internetoptionen hinzufügen.

    Fügen Sie die Webanwendung zur Liste der vertrauenswürdigen Sites im Internet Explorer hinzu, um die Browsereinstellungen manuell so zu konfigurieren, dass dieser Webanwendung vertraut wird. Weitere Informationen zum Hinzufügen der Webanwendung zur Liste der vertrauenswürdigen Sites finden Sie unter Konfigurieren der Internet Explorer-Sicherheitseinstellungen.

Verwandte Themen

Konfigurieren der Internet Explorer-Sicherheitseinstellungen

Öffnen der BizTalk-Dokumentüberwachung


Öffnen der BizTalk-Dokumentüberwachung

  • Zeigen Sie im Startmenü auf Programme, dann auf Microsoft BizTalk Server 2000, und klicken Sie auf BizTalk-Dokumentüberwachung.

    Oder

    Wenn Sie in Microsoft Internet Explorer einen Favoriten erstellt haben, können Sie die BizTalk-Dokumentüberwachung in Internet Explorer öffnen.

Anmerkung

  • Ein Dialogfeld mit der folgenden Meldung wird bei der Auswahl oder Abfrageauswahl möglicherweise angezeigt:

    Diese Seite greift auf Daten einer anderen Domäne zu. Möchten Sie dies zulassen?

    Damit diese Meldung im Internet Explorer nicht mehr angezeigt wird, können Sie eine sichere Website zu den vertrauenswürdigen Sites auf der Registerkarte Sicherheit im Dialogfeld Internetoptionen hinzufügen.

    Fügen Sie die Webanwendung zur Liste der vertrauenswürdigen Sites im Internet Explorer hinzu, um die Browsereinstellungen manuell so zu konfigurieren, dass dieser Webanwendung vertraut wird. Weitere Informationen zum Hinzufügen der Webanwendung zur Liste der vertrauenswürdigen Sites finden Sie unter Konfigurieren der Internet Explorer-Sicherheitseinstellungen.

Verwandte Themen

Konfigurieren der Internet Explorer-Sicherheitseinstellungen

Erstmaliges Öffnen der BizTalk-Dokumentüberwachung


Hinzufügen von Benutzern zur Gruppe "Benutzer des BizTalk-Serverberichts"

Sie müssen Mitglied der Gruppe Benutzer des BizTalk-Serverberichts sein, um die Benutzeroberfläche der BizTalk-Dokumentüberwachung anzuzeigen und Erweiterte Abfrage-Ausdrücke zu speichern.

  1. Zeigen Sie im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Computerverwaltung.

  2. Erweitern Sie System und Lokale Benutzer und Gruppen, und klicken Sie dann auf den Ordner Gruppen.

  3. Klicken Sie im Detailbereich auf Benutzer des BizTalk-Serverberichts.

  4. Zeigen Sie im Menü Vorgang auf Alle Tasks, und klicken Sie dann auf Mitglied hinzufügen.

    Das Dialogfeld Eigenschaften von Benutzer des BizTalk-Serverberichts wird angezeigt.

  5. Klicken Sie auf Hinzufügen.

  6. Klicken Sie in Suchen in auf den Namen Ihrer Domäne oder den Ihres Computers.

  7. Klicken Sie in der Liste mit den Benutzern und Computern, die der Domäne oder dem Computer zugeordnet sind, die/den Sie in Schritt 6 ausgewählt haben, auf das hinzuzufügende Benutzerkonto, dann auf Hinzufügen und schließlich auf OK.

  8. Klicken Sie auf OK, um das Dialogfeld Eigenschaften von Benutzer des BizTalk-Serverberichts zu schließen.


Verwenden von Abfragen zum Durchsuchen und Sortieren von Austausch- und Dokumentdaten

Mithilfe von Abfragen können Sie Austausch- und Dokumentinstanz-Datensätze sowie dazugehörige Daten unter Verwendung von Standardsuchkriterien wie Dokumenttyp oder Quellorganisation suchen, anzeigen und speichern.

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Datumsabhängiges Suchen nach Austausch- und Dokumentinformationen

  • Organisationsabhängiges Suchen nach Austausch- und Dokumentinformationen

  • Dokumenttypabhängiges Suchen nach Austausch- und Dokumentinformationen

  • Suchen nach Austausch- und Dokumentinformationen durch Kombinieren von Abfrageparametern

  • Löschen von Suchkriterien für Organisationen und Dokumenttypen

  • Anpassen der Seite "Abfrageergebnisse"

  • Anzeigen der Suchparameter für die Seite "Abfrageergebnisse"

Anmerkung

  • Seien Sie bei der Auswahl der Abfrageparameter so spezifisch wie möglich. Dadurch werden die Serverbelastung und die benötigte Zeit zur Rückgabe der Abfrageergebnisse reduziert.

  • Ein Dialogfeld mit der folgenden Meldung wird bei der Auswahl oder Abfrageauswahl möglicherweise angezeigt:

    Diese Seite greift auf Daten einer anderen Domäne zu. Möchten Sie dies zulassen?

    Damit diese Meldung im Internet Explorer nicht mehr angezeigt wird, können Sie eine sichere Website zu den vertrauenswürdigen Sites auf der Registerkarte Sicherheit im Dialogfeld Internetoptionen hinzufügen.

    Fügen Sie die Webanwendung zur Liste der vertrauenswürdigen Sites im Internet Explorer hinzu, um die Browsereinstellungen manuell so zu konfigurieren, dass dieser Webanwendung vertraut wird. Weitere Informationen zum Hinzufügen der Webanwendung zur Liste der vertrauenswürdigen Sites finden Sie unter Konfigurieren der Internet Explorer-Sicherheitseinstellungen.


Datumsabhängiges Suchen nach Austausch- und Dokumentinformationen

  1. Klicken Sie in der BizTalk-Dokumentüberwachung unter Zeitraum in der Liste Datum anzeigen auf Ortszeit oder UTC, um die Zeitzone der angezeigten Datumsangaben festzulegen.

  2. Geben Sie in die Liste Von das Anfangsdatum des zu überwachenden Zeitraums ein, oder klicken Sie auf den Pfeil, um einen Kalender anzuzeigen, in dem Sie ein Datum auswählen können.

    Geben Sie die Anfangszeit in die Liste neben der Liste Von ein, oder klicken Sie auf den NACH OBEN- oder NACH UNTEN-Pfeil, um den Zeitpunkt zu ändern.

  3. Geben Sie in die Liste Bis das Enddatum des zu überwachenden Zeitraums ein, oder klicken Sie auf den Pfeil, um einen Kalender anzuzeigen, in dem Sie ein Datum auswählen können.

    Geben Sie die Anfangszeit in die Liste neben der Liste Bis ein, oder klicken Sie auf den NACH OBEN- oder NACH UNTEN-Pfeil, um den Zeitpunkt zu ändern.

  4. Klicken Sie auf die Schaltfläche Abfrage.

    Die Seite Abfrageergebnisse wird angezeigt.

  5. Suchen Sie den Austauschdatensatz mit den anzuzeigenden Daten, und klicken in der Spalte Daten auf das Symbol Daten, um Austauschdaten anzuzeigen.

    Die Seite Austauschdaten anzeigen wird angezeigt.

  6. Klicken Sie in der Spalte Ablaufplan auf das Symbol Ablaufplan, um den XLANG-Ablaufplanstatus eines Austauschs anzuzeigen.

    Die Seite Zusammenfassung des XLANG-Ablaufplanes anzeigen wird angezeigt.

  7. Klicken Sie auf das Erweiterungssymbol (+) neben dem Austausch, der den anzuzeigenden Dokumentinstanz-Datensatz enthält, um einen Dokumentinstanz-Datensatz anzuzeigen, der einem Austausch zugeordnet ist.

  8. Klicken Sie im Feld Daten auf das Symbol Daten, um die einer Dokumentinstanz zugeordneten Daten anzuzeigen.

    Die Seite Daten der Dokumentinstanz anzeigen wird angezeigt.

  9. Klicken Sie auf Im systemeigenen Format anzeigen oder Im XML-Format anzeigen, um die Daten im systemeigenen oder im XML-Format anzuzeigen.

  10. Klicken Sie im Feld Daten auf das Symbol Empfangsbestätigung, um die zu einer Dokumentinstanz gehörenden Empfangsbestätigungsdaten anzuzeigen.

    Eine neue Seite Abfrageergebnisse wird angezeigt.

  11. Klicken Sie auf das Erweiterungssymbol (+) neben dem Austausch und dann im Feld Daten auf das Symbol Daten.

  12. Suchen Sie das entsprechende Dokument, dessen Daten Sie anzeigen möchten, um für eine Dokumentinstanz die Daten im Feld der benutzerdefinierten Suche anzuzeigen, klicken auf die horizontale Bildlaufleiste, um das Feld Benutzerdefinierte Suche anzuzeigen, und klicken dann auf das Symbol Benutzerdefinierte Suche.

    Die Seite Inhalt des Feldes für benutzerdefinierte Suche anzeigen wird angezeigt.

Anmerkungen

  • Der in der Liste Datum anzeigen gewählte Wert steuert die Suchzeiten und Anzeigeergebnisse. Wenn Sie z. B. in Datum anzeigen die Option UTC wählen und in das Zeitfeld 0800 eingeben, suchen Sie alle Daten, die um oder nach 08:00 Uhr im UTC-Format (Universal Time Coordinated) verarbeitet wurden. Dies entspricht nicht 0800 Ortszeit.

  • Die Standarddatumseinstellung ist sieben Tage vor dem aktuellen Datum.

  • Die Standarddatumsangaben sind die von BizTalk Server generierten Zeitstempel für die Metadaten der Dokumentinstanzen und Austauschvorgänge. Es handelt sich nicht um Datumsangaben für den tatsächlichen Dokumentinhalt. Erstellen Sie einen Erweiterte Abfrage-Ausdruck, um Dokumente nach dem tatsächlichen Dokumentdatum zu suchen. Weitere Informationen zu erweiterten Abfragen finden Sie unter Erstellen von erweiterten Abfragen.

  • Wenn Sie in einer Abfrage nur einen Zeitraum angeben, sucht die BizTalk-Dokumentüberwachung nach allen Quell- und Zielorganisationen sowie nach allen Dokumenttypen. Dieser einzelne Suchparameter wird jedoch nicht empfohlen. Optimale Ergebnisse erhalten Sie, indem Sie stets eine Abfrage mit sehr spezifischen Parametern erstellen, um die Anzahl der Austauschdatensätze zu beschränken, die auf der Seite Abfrageergebnisse angezeigt werden.

  • Der XLANG-Ablaufplanstatus umfasst das letzte entdeckte Ereignis, die verarbeitete Startzeit, die verarbeitete Endzeit usw.

Verwandte Themen

Erstellen von erweiterten Abfragen

Dokumenttypabhängiges Suchen nach Austausch- und Dokumentinformationen

Organisationsabhängiges Suchen nach Austausch- und Dokumentinformationen

Suchen nach Austausch- und Dokumentinformationen durch Kombinieren von Abfrageparametern

Grundlegendes zu Ergebnissen von Dokumentinstanz-Datensätzen

Grundlegendes zu den Ergebnissen von Austauschdatensätzen

Grundlegendes zu Abfragen


Organisationsabhängiges Suchen nach Austausch- und Dokumentinformationen

  1. Klicken Sie in der BizTalk-Dokumentüberwachung in der Liste Quellauswahl auf die Organisation(en), deren Austauschvorgänge und Dokumente Sie anzeigen möchten. Klicken Sie neben der Organisation auf das Erweiterungssymbol (+) und anschließend auf die gewünschte(n) Anwendung(en), um eine Anwendung auszuwählen, die einer Quellorganisation zugeordnet ist. Klicken Sie auf Alles auswählen, um alle Quellorganisationen auszuwählen.

    Oder

    Klicken Sie in der BizTalk-Dokumentüberwachung in der Liste Zielauswahl auf die Organisation(en), deren Austauschvorgänge und Dokumente Sie anzeigen möchten. Klicken Sie neben der Organisation auf das Erweiterungssymbol (+) und anschließend auf die gewünschte(n) Anwendung(en), um eine Anwendung auszuwählen, die einer Zielorganisation zugeordnet ist. Klicken Sie auf Alles auswählen, um alle Zielorganisationen auszuwählen.

    In den Listen Quellauswahl und Zielauswahl können Sie Organisationen und Anwendungen für dieselbe Abfrage auswählen.

  2. Klicken Sie auf die Schaltfläche Abfrage.

    Die Seite Abfrageergebnisse wird angezeigt. Alle Austauschvorgänge, die den Abfragekriterien entsprechen, werden hier aufgeführt.

  3. Suchen Sie den Austauschdatensatz mit den anzuzeigenden Daten, und klicken Sie in der Spalte Daten auf das Symbol Daten, um Austauschdaten anzuzeigen.

    Die Seite Austauschdaten anzeigen wird angezeigt.

  4. Klicken Sie in der Spalte Ablaufplan auf das Symbol Ablaufplan, um den XLANG-Ablaufplanstatus eines Austauschs anzuzeigen.

    Die Seite Zusammenfassung des XLANG-Ablaufplanes anzeigen wird angezeigt.

  5. Klicken Sie auf das Erweiterungssymbol (+) neben dem Austausch, der die anzuzeigenden Dokumentinstanz-Datensätze enthält, um einen Dokumentinstanz-Datensatz anzuzeigen, der mit einem Austausch verknüpft ist.

  6. Klicken Sie im Feld Daten auf das Symbol Daten, um die einer Dokumentinstanz zugeordneten Daten anzuzeigen.

    Die Seite Daten der Dokumentinstanz anzeigen wird angezeigt.

  7. Klicken Sie auf Im systemeigenen Format anzeigen oder Im XML-Format anzeigen, um die Daten im systemeigenen oder im XML-Format anzuzeigen.

  8. Klicken Sie im Feld Daten auf das Symbol Empfangsbestätigung, um die zu einer Dokumentinstanz gehörenden Empfangsbestätigungsdaten anzuzeigen.

    Eine neue Seite Abfrageergebnisse wird angezeigt.

  9. Klicken Sie auf das Erweiterungssymbol (+) neben dem Austausch und dann im Feld Daten auf das Symbol Daten.

  10. Suchen Sie das entsprechende Dokument, dessen Daten Sie anzeigen möchten, um für eine Dokumentinstanz die Daten im Feld der benutzerdefinierten Suche anzuzeigen, klicken auf die horizontale Bildlaufleiste, um das Feld Benutzerdefinierte Suche anzuzeigen, und klicken dann auf das Symbol Benutzerdefinierte Suche.

    Die Seite Inhalt des Feldes für benutzerdefinierte Suche anzeigen wird angezeigt.

Anmerkungen

  • Wenn Sie keine bestimmten Quell- und Zielorganisationen auswählen, gibt die Abfrage Austausch- und Dokumentdatensätze aller Quell- und Zielorganisationen zurück. Die Optionen Alles löschen und Alles auswählen generieren auf der Seite Abfrageergebnisse dieselben Ergebnisse. Optimale Ergebnisse erhalten Sie, indem Sie stets eine Abfrage mit sehr spezifischen Parametern erstellen, um die Anzahl der Austauschdatensätze zu beschränken, die auf der Seite Abfrageergebnisse angezeigt werden.

  • Der XLANG-Ablaufplanstatus umfasst das letzte entdeckte Ereignis, die verarbeitete Startzeit, die verarbeitete Endzeit usw.

Verwandte Themen

Datumsabhängiges Suchen nach Austausch- und Dokumentinformationen

Dokumenttypabhängiges Suchen nach Austausch- und Dokumentinformationen

Suchen nach Austausch- und Dokumentinformationen durch Kombinieren von Abfrageparametern

Grundlegendes zu Ergebnissen von Dokumentinstanz-Datensätzen

Grundlegendes zu den Ergebnissen von Austauschdatensätzen

Grundlegendes zu Abfragen


Dokumenttypabhängiges Suchen nach Austausch- und Dokumentinformationen

  1. Klicken Sie in der BizTalk-Dokumentüberwachung unter Auswahl des Dokumenttyps auf Dokumente anzeigen.

  2. Klicken Sie in der Liste Auswahl des Dokumenttyps auf den Dokumenttyp, den Sie suchen möchten. Klicken Sie auf Alles auswählen, um alle Dokumenttypen auszuwählen.

  3. Klicken Sie auf die Schaltfläche Abfrage.

    Die Seite Abfrageergebnisse wird angezeigt.

  4. Suchen Sie den Austauschdatensatz mit den anzuzeigenden Daten, und klicken in der Spalte Daten auf das Symbol Daten, um Austauschdaten anzuzeigen.

    Die Seite Austauschdaten anzeigen wird angezeigt.

  5. Klicken Sie in der Spalte Ablaufplan auf das Symbol Ablaufplan, um den XLANG-Ablaufplanstatus eines Austauschs anzuzeigen.

    Die Seite Zusammenfassung des XLANG-Ablaufplanes anzeigen wird angezeigt.

  6. Klicken Sie auf das Erweiterungssymbol (+) neben dem Austausch, der die anzuzeigenden Dokumentinstanz-Datensätze enthält, um einen Dokumentinstanz-Datensatz anzuzeigen, der mit einem Austausch verknüpft ist.

  7. Klicken Sie im Feld Daten auf das Symbol Daten, um die einer Dokumentinstanz zugeordneten Daten anzuzeigen.

    Die Seite Daten der Dokumentinstanz anzeigen wird angezeigt.

  8. Klicken Sie auf Im systemeigenen Format anzeigen oder Im XML-Format anzeigen, um die Daten im systemeigenen oder im XML-Format anzuzeigen.

  9. Klicken Sie im Feld Daten auf das Symbol Empfangsbestätigung, um die zu einer Dokumentinstanz gehörenden Empfangsbestätigungsdaten anzuzeigen.

    Eine neue Seite Abfrageergebnisse wird angezeigt.

  10. Klicken Sie auf das Erweiterungssymbol (+) neben dem Austausch und dann im Feld Daten auf das Symbol Daten.

  11. Suchen Sie das entsprechende Dokument, dessen Daten Sie anzeigen möchten, um für eine Dokumentinstanz die Daten im Feld der benutzerdefinierten Suche anzuzeigen, klicken auf die horizontale Bildlaufleiste, um das Feld Benutzerdefinierte Suche anzuzeigen, und klicken dann auf das Symbol Benutzerdefinierte Suche.

    Die Seite Inhalt des Feldes für benutzerdefinierte Suche anzeigen wird angezeigt.

Anmerkungen

  • Wenn Sie zum Einengen der Suche nicht einen oder mehrere Dokumenttypen auswählen, gibt die Abfrage alle Dokumenttypen in der Liste zurück. Optimale Ergebnisse erhalten Sie, indem Sie stets eine Abfrage mit sehr spezifischen Parametern erstellen, um die Anzahl der Austauschdatensätze zu beschränken, die auf der Seite Abfrageergebnisse generiert werden.

  • Der XLANG-Ablaufplanstatus umfasst das letzte entdeckte Ereignis, die verarbeitete Startzeit, die verarbeitete Endzeit usw.

Verwandte Themen

Datumsabhängiges Suchen nach Austausch- und Dokumentinformationen

Organisationsabhängiges Suchen nach Austausch- und Dokumentinformationen

Suchen nach Austausch- und Dokumentinformationen durch Kombinieren von Abfrageparametern

Grundlegendes zu Ergebnissen von Dokumentinstanz-Datensätzen

Grundlegendes zu den Ergebnissen von Austauschdatensätzen

Grundlegendes zu Abfragen


Suchen nach Austausch- und Dokumentinformationen durch Kombinieren von Abfrageparametern

  1. In der BizTalk-Dokumentüberwachung können Sie die folgenden Abfrageparameter in einer einzelnen Abfragesitzung kombinieren, um Austausch- und Dokumentinstanz-Datensätze und dazugehörige Daten zu suchen und anzuzeigen:
    • Quellauswahl. Weitere Informationen zum Erstellen von Abfragen mithilfe des Quellauswahlparameters finden Sie unter Organisationsabhängiges Suchen nach Austausch- und Dokumentinformationen.

    • Zielauswahl. Weitere Informationen zum Erstellen von Abfragen mithilfe des Zielauswahlparameters finden Sie unter Organisationsabhängiges Suchen nach Austausch- und Dokumentinformationen.

    • Dokumenttyp. Weitere Informationen zum Erstellen von Abfragen mithilfe des Dokumenttypparameters finden Sie unter Dokumenttypabhängiges Suchen nach Austausch- und Dokumentinformationen.

    • Datum und Zeit. Weitere Informationen zum Erstellen von Abfragen mithilfe der Datum- und Zeitparameter finden Sie unter Datumsabhängiges Suchen nach Austausch- und Dokumentinformationen.
  2. Klicken Sie auf die Schaltfläche Abfrage.


Löschen von Suchkriterien für Organisationen und Dokumenttypen

  • Klicken Sie in der BizTalk-Dokumentüberwachung unter Quellauswahl, Zielauswahl oder Auswahl des Dokumenttyps auf Alles löschen.

Anmerkung

  • Wenn Sie auf Alles löschen klicken, kehrt die BizTalk-Dokumentüberwachung zur Standardsuche für alle Quell- und Zielorganisationen und alle Dokumenttypen zurück. Optimale Ergebnisse erhalten Sie, indem Sie stets eine Abfrage mit sehr spezifischen Parametern erstellen, um die Anzahl der Austauschdatensätze zu beschränken, die auf der Seite Abfrageergebnisse angezeigt werden.


Anpassen der Seite "Abfrageergebnisse"

  1. Aktivieren Sie in der BizTalk-Dokumentüberwachung unter Sortiersteuerung das Kontrollkästchen Eingehende/ausgehende Austauschvorgänge gruppieren.

    Durch diesen Schritt wird die Seite Abfrageergebnisse so konfiguriert, dass eingehende Austauschvorgänge mit dazugehörigen Austauschvorgängen gruppiert werden. Deaktivieren Sie dieses Kontrollkästchen, wenn eingehende Austauschvorgänge nicht mit dazugehörigen Austauschvorgängen angezeigt werden sollen.

  2. Klicken Sie unter Sortiersteuerung in der Liste Sortierreihenfolge 1 auf die erste Sortierfolgeoption, die Sie verwenden möchten. Wiederholen Sie diesen Schritt für alle Listen mit Sortierreihenfolgen, um die Sortierreihenfolge der Dokumente auf der Seite Abfrageergebnisse zu konfigurieren.

    Jede Sortierreihenfolge-Liste enthält die folgenden Optionen:

    • Quellorganisationsname

    • Quellanwendungsname

    • Zielorganisationsname

    • Zielanwendungsname

    • Dokumenttyp

    • Verarbeitungszeitpunkt


Anzeigen der Suchparameter für die Seite "Abfrageergebnisse"

  1. Legen Sie Parameter für eine Abfrage fest, und klicken Sie dann auf die Schaltfläche Abfrage.

    Die Seite Abfrageergebnisse wird angezeigt.

    Weitere Informationen zum Erstellen von Abfragen bzw. erweiterter Abfragen finden Sie unter:

    • Datumsabhängiges Suchen nach Austausch- und Dokumentinformationen

    • Organisationsabhängiges Suchen nach Austausch- und Dokumentinformationen

    • Dokumenttypabhängiges Suchen nach Austausch- und Dokumentinformationen

    • Erstellen von erweiterten Abfragen
  2. Klicken Sie in der Leiste Suchparameter auf das Symbol Anzeigen.

    Unter Suchparameter werden die folgenden Suchparameter und dazugehörigen Werte aufgeführt:

    • Zeitraum

    • Zeitzone

    • Ausdrucksname

    • Sortierreihenfolge

    • Quellauswahl

    • Zielauswahl

    • Auswahl des Dokumenttyps

Verwandte Themen

Erstellen von erweiterten Abfragen

Datumsabhängiges Suchen nach Austausch- und Dokumentinformationen

Dokumenttypabhängiges Suchen nach Austausch- und Dokumentinformationen

Organisationsabhängiges Suchen nach Austausch- und Dokumentinformationen


Erweiterte Abfragen

Wenn Sie bestimmte Daten suchen müssen, wie z. B. eine Dokumentinstanz mit einer bestimmten Auftragsnummer, können Sie dazu eine erweiterte Abfrage verwenden.

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Erstellen von erweiterten Abfragen

  • Suchen nach vorhandenen erweiterten Abfragen

  • Bearbeiten von vorhandenen erweiterten Abfragen

  • Löschen von vorhandenen erweiterten Abfragen aus einer Abfrage

  • Löschen von vorhandenen erweiterten Abfragen


Erstellen von erweiterten Abfragen

  1. Klicken Sie in der BizTalk-Dokumentüberwachung unter Erweiterte Abfrage auf Neu.

    Die Seite Generator für erweiterte Abfragen wird angezeigt.

  2. Klicken Sie in der Liste Quellauswahl auf eine Option, um die Quellauswahlkriterien anzugeben.

    Dies ist der Name des erfassten Feldes, nach dem Sie suchen.

  3. Klicken Sie in der Liste Operatoren auf einen Operator.

  4. Geben Sie in das Feld Wert einen Wert ein.

  5. Klicken Sie in der Liste AND/OR auf AND oder OR, um diese Bedingung mit einer anderen Bedingung zu kombinieren oder zu vergleichen. Dieser Schritt ist optional.

  6. Klicken Sie auf Fertig.

  7. Wiederholen Sie die Schritte 2 bis 6, bis alle gewünschten Bedingungen hinzugefügt sind.

  8. Führen Sie eines der folgenden Verfahren aus:
    • Klicken Sie auf OK, um die Verwendung dieses Ausdrucks auf die aktuelle Abfragesitzung zu beschränken.

    • Klicken Sie auf Speichern, um den Ausdruck für künftige Abfragesitzungen zu speichern. Geben Sie in das Dialogfeld BizTalk-Dokumentüberwachung den Ausdrucksnamen in das Feld Geben Sie den Ausdrucksnamen ein ein (beschränken Sie den Ausdrucksnamen auf 50 Zeichen), und klicken Sie auf OK.

Anmerkungen

  • Die Zusammenstellung einer oder mehrerer Bedingungen in einer erweiterten Abfrage wird Ausdruck genannt.

  • Wenn der Eingabefokus auf der Liste Quellauswahl ist und Sie auf eine Schaltfläche klicken, müssen Sie gegebenenfalls nochmals auf die Schaltfläche klicken, um sie zu aktivieren.

  • Wenn Sie im BizTalk-Messaging-Manager einen Kanal oder eine Dokumentdefinition für die Überwachung benutzerdefinierter Felder konfiguriert haben, werden diese Felder in der Liste Quellauswahl angezeigt. Wenn der BizTalk-Messaging-Manager nicht für die Überwachung von Feldern konfiguriert wurde, wird in der Liste Quellauswahl nur <Benutzerdefinierte Suche> angezeigt. Weitere Informationen zum Überwachen bestimmter Felder finden Sie unter Festlegen von Eigenschaften für die Dokumentprotokollierung und Auswählen von Spezifikationsfeldern in einem Kanal.

Verwandte Themen

Löschen von vorhandenen erweiterten Abfragen aus einer Abfrage

Löschen von vorhandenen erweiterten Abfragen

Bearbeiten von vorhandenen erweiterten Abfragen

Suchen nach vorhandenen erweiterten Abfragen


Suchen nach vorhandenen erweiterten Abfragen

  1. Klicken Sie in der BizTalk-Dokumentüberwachung unter Erweiterte Abfrage auf Durchsuchen.

    Das Dialogfeld Erweiterte Abfragen wird angezeigt.

  2. Wählen Sie eine vorhandene Abfrage aus, und klicken Sie auf OK.

Anmerkung

  • Wenn der Eingabefokus auf der Liste Quellauswahl ist und Sie auf eine Schaltfläche klicken, müssen Sie gegebenenfalls nochmals auf die Schaltfläche klicken, um sie zu aktivieren.

Verwandte Themen

Erstellen von erweiterten Abfragen

Löschen von vorhandenen erweiterten Abfragen aus einer Abfrage

Löschen von vorhandenen erweiterten Abfragen

Bearbeiten von vorhandenen erweiterten Abfragen


Bearbeiten von vorhandenen erweiterten Abfragen

  1. Klicken Sie in der BizTalk-Dokumentüberwachung unter Erweiterte Abfrage auf Durchsuchen.

    Das Dialogfeld Erweiterte Abfragen wird angezeigt.

  2. Wählen Sie eine vorhandene Abfrage aus, und klicken Sie auf Bearbeiten.

    Das Dialogfeld Generator für erweiterte Abfragen wird angezeigt.

  3. Führen Sie eines oder mehrere der folgenden Verfahren aus:
    • Klicken Sie auf Neu, um eine weitere Bedingung hinzuzufügen. Geben Sie Bedingungen für jedes der vier Felder an, und klicken Sie auf Fertig.

    • Klicken Sie auf eine vorhandene Bedingung, dann auf Bearbeiten, ändern Sie die vier Felder, und klicken Sie auf Fertig.

    • Wählen Sie eine vorhandene Abfrage aus, und klicken Sie auf Entfernen.
  4. Klicken Sie auf Speichern.

    Das Dialogfeld Erweiterte Abfragen wird angezeigt.

  5. Wählen Sie die zuvor bearbeitete Abfrage aus, und klicken Sie auf OK.

Anmerkung

  • Wenn der Eingabefokus auf der Liste Quellauswahl ist und Sie auf eine Schaltfläche klicken, müssen Sie gegebenenfalls nochmals auf die Schaltfläche klicken, um sie zu aktivieren.

Verwandte Themen

Erstellen von erweiterten Abfragen

Löschen von vorhandenen erweiterten Abfragen aus einer Abfrage

Löschen von vorhandenen erweiterten Abfragen

Suchen nach vorhandenen erweiterten Abfragen


Löschen von vorhandenen erweiterten Abfragen aus einer Abfrage

  • Klicken Sie in der BizTalk-Dokumentüberwachung unter Erweiterte Abfrage auf Löschen, um den aktuellen Ausdruck aus dem Feld Ausdrucksname zu entfernen.

Anmerkung

  • Wenn Sie in Internet Explorer auf die Schaltfläche Aktualisieren klicken, wird die erweitere Abfrage nicht aus dem Feld Ausdrucksname gelöscht.

Verwandte Themen

Erstellen von erweiterten Abfragen

Löschen von vorhandenen erweiterten Abfragen

Bearbeiten von vorhandenen erweiterten Abfragen

Suchen nach vorhandenen erweiterten Abfragen


Löschen von vorhandenen erweiterten Abfragen

  1. Klicken Sie in der BizTalk-Dokumentüberwachung unter Erweiterte Abfrage auf Durchsuchen.

    Die Seite Erweiterte Abfragen wird angezeigt.

  2. Wählen Sie eine Abfrage aus, und klicken Sie auf Löschen.

  3. Schließen Sie das Dialogfeld Erweiterte Abfragen, wenn Sie fertig sind.

Anmerkung

  • Wenn der Eingabefokus auf der Liste Quellauswahl ist und Sie auf eine Schaltfläche klicken, müssen Sie gegebenenfalls nochmals auf die Schaltfläche klicken, um sie zu aktivieren.

Verwandte Themen

Erstellen von erweiterten Abfragen

Löschen von vorhandenen erweiterten Abfragen aus einer Abfrage

Bearbeiten von vorhandenen erweiterten Abfragen

Suchen nach vorhandenen erweiterten Abfragen


Speichern von Austausch-, Dokument und benutzerdefinierten Suchdaten

Wenn der BizTalk-Messaging-Manager, das BizTalk-Messaging-Konfigurationsobjektmodell und/oder die BizTalk Server-Verwaltung so konfiguriert sind, dass ein- und ausgehende Austauschvorgänge und die entsprechenden Dokumente gespeichert werden, können Sie Austauschvorgänge, Dokumentdaten und Suchdaten benutzerdefinierter Felder speichern, um diese im Offlinemodus anzuzeigen. Dadurch können Sie Probleme in bestimmten Situationen behandeln oder Ihre Geschäftsabläufe untersuchen.

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Speichern von Austauschdaten

  • Speichern von Dokumentinstanzdaten

  • Speichern von Suchdaten benutzerdefinierter Felder


Speichern von Austauschdaten

  1. Legen Sie Parameter für eine Abfrage fest, und klicken Sie dann auf die Schaltfläche Abfrage.

    Die Seite Abfrageergebnisse wird angezeigt.

    Weitere Informationen zum Erstellen von Abfragen bzw. erweiterter Abfragen finden Sie unter:

    • Datumsabhängiges Suchen nach Austausch- und Dokumentinformationen

    • Organisationsabhängiges Suchen nach Austausch- und Dokumentinformationen

    • Dokumenttypabhängiges Suchen nach Austausch- und Dokumentinformationen

    • Erstellen von erweiterten Abfragen
  2. Klicken Sie im Feld Daten auf das Symbol Daten, um den Austauschdatensatz mit den gewünschten Austauschdaten zu suchen, die Sie speichern möchten.

    Die Seite Austauschdaten anzeigen wird angezeigt.

  3. Klicken Sie auf Speichern unter.

  4. Geben Sie in das Feld Dateiname einen Namen für die Datei ein, und klicken Sie auf Speichern.

Verwandte Themen

Erstellen von erweiterten Abfragen

Speichern von Suchdaten benutzerdefinierter Felder

Speichern von Dokumentinstanzdaten

Datumsabhängiges Suchen nach Austausch- und Dokumentinformationen

Dokumenttypabhängiges Suchen nach Austausch- und Dokumentinformationen

Organisationsabhängiges Suchen nach Austausch- und Dokumentinformationen


Speichern von Dokumentinstanzdaten

  1. Legen Sie Parameter für eine Abfrage fest, und klicken Sie auf die Schaltfläche Abfrage.

    Die Seite Abfrageergebnisse wird angezeigt.

    Weitere Informationen zum Erstellen von Abfragen bzw. erweiterter Abfragen finden Sie unter:

    • Datumsabhängiges Suchen nach Austausch- und Dokumentinformationen

    • Organisationsabhängiges Suchen nach Austausch- und Dokumentinformationen

    • Dokumenttypabhängiges Suchen nach Austausch- und Dokumentinformationen

    • Erstellen von erweiterten Abfragen
  2. Suchen Sie den Austauschdatensatz mit den Dokumentinstanzdaten, die Sie speichern möchten, und klicken Sie links neben dem Austausch auf das Erweiterungssymbol (+).

  3. Klicken Sie im Feld Daten auf das Symbol Daten.

    Die Seite Daten der Dokumentinstanz anzeigen wird angezeigt.

  4. Klicken Sie auf Speichern unter.

  5. Geben Sie in das Feld Dateiname für die Datei einen Namen und eine Erweiterung ein (entweder die XML-Dateierweiterung oder die systemeigene Dateierweiterung des Dokuments), und klicken Sie auf Speichern.

Verwandte Themen

Erstellen von erweiterten Abfragen

Speichern von Suchdaten benutzerdefinierter Felder

Speichern von Austauschdaten

Datumsabhängiges Suchen nach Austausch- und Dokumentinformationen

Dokumenttypabhängiges Suchen nach Austausch- und Dokumentinformationen

Organisationsabhängiges Suchen nach Austausch- und Dokumentinformationen


Speichern von Suchdaten benutzerdefinierter Felder

  1. Legen Sie Parameter für eine Abfrage fest, und klicken Sie dann auf die Schaltfläche Abfrage.

    Die Seite Abfrageergebnisse wird angezeigt.

    Weitere Informationen zum Erstellen von Abfragen bzw. erweiterter Abfragen finden Sie unter:

    • Datumsabhängiges Suchen nach Austausch- und Dokumentinformationen

    • Organisationsabhängiges Suchen nach Austausch- und Dokumentinformationen

    • Dokumenttypabhängiges Suchen nach Austausch- und Dokumentinformationen

    • Erstellen von erweiterten Abfragen
  2. Klicken Sie links neben dem Austauschdatensatz mit dem Dokument, das Sie anzeigen möchten, auf das Erweiterungssymbol (+).

  3. Klicken Sie auf die horizontale Bildlaufleiste, um das Feld Benutzerdefinierte Suche für das Dokument einzublenden, das Sie anzeigen möchten, und klicken Sie auf das Symbol Benutzerdefiniert Suche.

    Die Seite Inhalt des Feldes für benutzerdefinierte Suche anzeigen wird angezeigt.

  4. Klicken Sie auf Speichern unter.

  5. Geben Sie in das Feld Dateiname einen Namen für die Datei ein, und klicken Sie auf Speichern.

Verwandte Themen

Erstellen von erweiterten Abfragen

Speichern von Dokumentinstanzdaten

Speichern von Austauschdaten

Datumsabhängiges Suchen nach Austausch- und Dokumentinformationen

Dokumenttypabhängiges Suchen nach Austausch- und Dokumentinformationen

Organisationsabhängiges Suchen nach Austausch- und Dokumentinformationen


Grundbegriffe

Dieser Abschnitt stellt detaillierte Informationen zum Konzept bereit, die wichtig für das Verständnis des Überwachens von Dokumenten und Aktivitäten sind.

Folgende Themen werden in diesem Abschnitt behandelt:

  • BizTalk-Dokumentüberwachung - Umgebung

  • Verwenden der BizTalk-Dokumentüberwachung

  • Grundlegendes zum Schema der Überwachungsdatenbank

  • Grundlegendes zum Suchen von Austauschvorgängen und dazugehörigen Dokumenten

  • Grundlegendes zu Abfrageergebnissen

  • Grundlegendes zum integrierten XLANG-Ablaufplanstatus eines Austauschs

Anmerkung

  • Ein Dialogfeld mit der folgenden Meldung wird bei der Auswahl oder Abfrageauswahl möglicherweise angezeigt:

    Diese Seite greift auf Daten einer anderen Domäne zu. Möchten Sie dies zulassen?

    Damit diese Meldung im Internet Explorer nicht mehr angezeigt wird, können Sie eine sichere Website zu den vertrauenswürdigen Sites auf der Registerkarte Sicherheit im Dialogfeld Internetoptionen hinzufügen.

    Fügen Sie die Webanwendung zur Liste der vertrauenswürdigen Sites im Internet Explorer hinzu, um die Browsereinstellungen manuell so zu konfigurieren, dass dieser Webanwendung vertraut wird. Weitere Informationen zum Hinzufügen der Webanwendung zur Liste der vertrauenswürdigen Sites finden Sie unter Konfigurieren der Internet Explorer-Sicherheitseinstellungen.


BizTalk-Dokumentüberwachung - Umgebung

Folgende Themen werden in diesem Abschnitt behandelt:

  • BizTalk-Dokumentüberwachung – Benutzeroberfläche

  • BizTalk-Dokumentüberwachung - Tastenkombinationen


BizTalk-Dokumentüberwachung - Benutzeroberfläche

BizTalk Server-Kopfzeile

BizTalk-Dokumentüberwachung – Benutzeroberfläche

Die BizTalk-Dokumentüberwachung ist eine eigenständige Webanwendung, mit der Sie Austauschvorgänge und Dokumente anzeigen können, die für die Überwachung in Microsoft BizTalk Server konfiguriert wurden. Die Hauptseite enthält sechs Bereiche:

  • Zeitraum

  • Quellauswahl

  • Zielauswahl

  • Erweiterte Abfrage

  • Sortiersteuerung

  • Auswahl des Dokumenttyps

Sie können Abfrageparameter unter Zeitraum,, Quellauswahl, Zielauswahl, und Auswahl des Dokumenttyps konfigurieren.

Unten links auf der Seite finden Sie die Bereiche Erweiterte Abfrage und Sortiersteuerung. Unter Erweiterte Abfrage können Sie Parameter konfigurieren, um bestimmte Informationen oder benutzerdefinierte Suchfelder zu suchen. Unter Sortiersteuerung können Sie Optionen konfigurieren, um die Sortierreihenfolge auf der Seite Abfrageergebnisse anzugeben.

Wenn Sie auf der Hauptseite auf die Schaltfläche Abfrage klicken, wird die Seite Abfrageergebnisse angezeigt. Falls Datensätze in der Überwachungsdatenbank den Abfrageparametern entsprechen, werden Austauschdatensätze in einer Liste angezeigt. Die folgende Tabelle beschreibt die Symbole, die auf der Seite Abfrageergebnisse zur Verfügung stehen.

Symbol | Zweck
Datensymbol | Zugreifen auf Austausch- oder Dokumentinstanzdaten. Wenn Sie im Austauschdatensatz auf das Datensymbol klicken, werden die Austauschdaten angezeigt. Wenn Sie im Dokumentinstanz-Datensatz auf das Datensymbol klicken, werden die Dokumentdaten angezeigt.
Erweiterungssymbol | Erweitern des Austauschdatensatzes, um den Dokumentinstanz-Datensatz anzuzeigen.
Ausblendungssymbol | Ausblenden des Austauschdatensatzes, damit der Dokumentinstanz-Datensatz nicht angezeigt wird.
XLANG-Ablaufplansymbol | Anzeigen des zu einem Austausch gehörenden Status eines XLANG-Ablaufplanes.
Empfangsbestätigungssymbol | Anzeigen einer neuen Seite Abfrageergebnisse mit dem Inhalt der Empfangsbestätigung. Weitere Informationen zu Empfangsbestätigungen finden Sie unter Grundlegendes zu den Ergebnissen von Empfangsbestätigungen.
Symbol für benutzerdefinierte Suche | Anzeigen benutzerdefinierter Suchdaten.


BizTalk-Dokumentüberwachung - Tastenkombinationen

Auf verschiedene Aufgaben in der BizTalk-Dokumentüberwachung können Sie über Tastenkombinationen zugreifen. Die folgende Tabelle enthält eine Kurzreferenz zu den Tastenkombinationen, die auf der Hauptseite zur Verfügung stehen.

Anmerkung

  • Sie können mithilfe der Zehnertastatur den Mauszeiger mit der Tastaturmaus bewegen, um Funktionen zu verwenden, die in dieser Liste nicht enthalten sind. Weitere Informationen zur Tastaturmaus finden Sie in der Windows 2000 Server-Hilfe unter "Bewegen des Mauszeigers mithilfe der Tastatur". Weitere Informationen finden Sie in der Windows 2000 Professional-Hilfe unter "Bewegen des Mauszeigers mithilfe der Tastaturmaus".
Tastenkombination | Zweck
ALT+N | Seite Generator für erweiterte Abfragen öffnen.
ALT+D | Seite Erweiterte Abfragen öffnen.
ALT+C | Erweiterte Abfrage aus der aktuellen Abfragesitzung löschen.
ALT+S | Alle Organisationen und Anwendungen in der Liste Quellauswahl auswählen.
ALT+E | Liste Quellauswahl löschen.
ALT+W | Alle Organisationen und Anwendungen in der Liste Zielauswahl auswählen.
ALT+A | Löschen der Liste Zielauswahl.
ALT+T | Alle Dokumenttypen in der Liste Auswahl des Dokumenttyps anzeigen.
ALT+U | Alle Dokumenttypen in der Liste Auswahl des Dokumenttyps auswählen.
ALT+L | Liste Auswahl des Dokumenttyps löschen.
ALT+F | Seite Abfrageergebnisse öffnen.
ALT+I | BizTalk-Dokumentüberwachung schließen.
ALT+H | Onlinehilfe anzeigen.
ALT+Unterstrichener Buchstabe oder unterstrichene Nummer eines Feldnamens | Fokus auf dieses Feld verschieben. ALT+1 verschiebt den Fokus beispielsweise auf Sortierreihenfolge 1.

Die folgende Tabelle beschreibt die Tastenkombinationen, die auf der Seite Abfrageergebnisse zur Verfügung stehen. Drücken Sie auf der Hauptseite ALT+Q, um die Seite Abfrageergebnisse zu öffnen.

Tastenkombination | Zweck
ALT+C | Seite Abfrageergebnisse schließen.
ALT+H | Onlinehilfe anzeigen.
LEERTASTE | Öffnen oder Schließen eines Symbols. Sie müssen die TAB-TASTE verwenden, um den Fokus auf das Symbol zu verschieben, das Sie öffnen oder schließen möchten. Wenn Sie z. B. einen Austauschdatensatz erweitern möchten, drücken Sie die TAB-TASTE, bis sich der Fokus auf dem Erweiterungssymbol des ausgewählten Austauschdatensatzes befindet. Drücken Sie dann die LEERTASTE.

Die folgende Tabelle beschreibt die Tastenkombinationen, die auf der Seite Generator für erweiterte Abfragen zur Verfügung stehen. Drücken Sie auf der Hauptseite ALT+N, um die Seite Generator für erweiterte Abfragen zu öffnen.

Tastenkombination | Zweck
ALT+E | Bedingung zum erweiterten Abfrageausdruck hinzufügen.
ALT+B | Bedingung bearbeiten.
ALT+T | Bedingung aus einem erweiterten Abfrageausdruck entfernen.
ALT+S | Ausdruck speichern.
ALT+O | Verwendung dieses Ausdrucks auf die aktuelle Abfragesitzung beschränken.
ALT+A | Seite Generator für erweiterte Abfragen schließen.
ALT+H | Onlinehilfe anzeigen.
ALT+Unterstrichener Buchstabe in einem Feldnamen | Fokus auf dieses Feld verschieben. ALT+W verschiebt den Fokus z. B. auf das Feld Wert.

Anmerkung

  • Wenn Sie den Eingabefokus in den Bereich Abfrage bewegen und dort mehr als eine Bedingung vorhanden ist, wählen Sie die gewünschte Bedingung mit den NACH-OBEN- und NACH-UNTEN-TASTEN aus.

Die folgende Tabelle beschreibt die Tastenkombinationen, die auf der Seite Erweiterte Abfragen zur Verfügung stehen. Drücken Sie auf der Hauptseite ALT+B, um die Seite Erweiterte Abfragen zu öffnen.

Tastenkombination | Zweck
ALT+E | Vorhandenen Ausdruck bearbeiten.
ALT+N | Seite Generator für erweiterte Abfragen öffnen.
ALT+L | Ausdruck löschen.
ALT+O | Ausdruck zur aktuellen Abfrage hinzufügen.
ALT+A | Seite Erweiterte Abfragen ohne Speichern der Änderungen schließen.
ALT+H | Onlinehilfe anzeigen.


Verwenden der BizTalk-Dokumentüberwachung

Die BizTalk-Dokumentüberwachung dient folgenden Zwecken:

  • Überwachen von Austauschvorgängen und dazugehörigen Dokumenten, die von Microsoft BizTalk Server 2000 verarbeitet werden.

  • Erfüllen rechtlicher und/oder von Normanforderungen an die Aufbewahrung von Kopien aller elektronischen Geschäftstransaktionen.

  • Schnelles und einfaches Beantworten von Kundenfragen. Wenn z. B. ein Kunde fragt: "Wann wurde an Handelspartner A eine Rechnung geschickt?", können Sie das Datum und die Uhrzeit ermitteln und feststellen, ob eine Empfangsbestätigung zurückgesendet wurde.

  • Hilfe bei der Problembehandlung.

  • Hilfe beim Lösen von Konflikten.

Dokumente können entweder in Batches oder als einzelne Transaktionen überwacht werden. Die BizTalk-Dokumentüberwachung speichert automatisch Metadaten, die mit einem Austausch verknüpft sind, wie z. B. Quell- und Zielinformationen, Dokumenttyp sowie Datums- und Zeitparameter. Metadaten werden automatisch gespeichert. Zusätzliche Felder, wie z. B. Auftragsdatum oder Auftragssumme, werden nur erfasst, wenn das BizTalk-Messaging-Konfigurationsobjektmodell oder der BizTalk-Messaging-Manager für die Erfassung dieser Informationen konfiguriert sind. Weitere Informationen zum Konfigurieren ausgewählter zu überwachender Felder finden Sie unter Festlegen von Kanaleigenschaften und Festlegen der Überwachung für Eigenschaften von eingehenden Dokumenten.

Alle Überwachungsinformationen, entweder die Metadaten oder die für die Überwachung konfigurierten Felder, werden in der Überwachungsdatenbank gespeichert, die Sie während der Installation oder bei der Einrichtung einer Servergruppe konfiguriert haben. Über die Benutzeroberfläche der BizTalk-Dokumentüberwachung können Sie auf die Daten zugreifen, die in der Überwachungsdatenbank gespeichert sind, welche einer bestimmten Servergruppe zugeordnet ist. Wenngleich nicht auf alle in der Überwachungsdatenbank gespeicherten Informationen zur Benutzeroberfläche zugegriffen werden kann, stehen die Metadaten und die für die Überwachung konfigurierten Felder unmittelbar zur Verfügung. Wenn Sie z. B. rückverfolgen möchten, wann die Einkaufsanwendung C einen Auftrag an Handelspartner D gesendet hat und wann Handelspartner D auf den Auftrag reagiert hat, stellt Ihnen die BizTalk-Dokumentüberwachung alle gewünschten Informationen zur Verfügung.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Grundlegendes zu den Überwachungseinstellungen einer Servergruppe

  • Grundlegendes zu den Überwachungseinstellungen im BizTalk-Messaging-Manager

Anmerkung

  • Auf der Benutzeroberfläche der BizTalk-Dokumentüberwachung werden keine Reliable Messaging-Bestätigungen angezeigt.

Verwandte Themen

Festlegen von Kanaleigenschaften

Festlegen der Überwachung für Eigenschaften von eingehenden Dokumenten

Überwachungsdatenbank


Grundlegendes zu den Überwachungseinstellungen einer Servergruppe

Die Überwachungseinstellungen einer Servergruppe ermitteln, ob das Überwachen von Austauschvorgängen aktiviert oder deaktiviert ist. Diese globale Überwachungseinstellung wird in der BizTalk Server-Verwaltung konfiguriert. Weitere Informationen zur Konfiguration von Überwachungseinstellungen für eine Servergruppe finden Sie unter Konfigurieren von Überwachungseigenschaften für eine Servergruppe. Wenn die Option Dokumentüberwachung aktivieren aktiviert ist, können Sie BizTalk Server so konfigurieren, dass eingehende und ausgehende Austauschvorgänge sowie ursprünglich MIME-codierte Nachrichten protokolliert werden.

Nach der Installation von Microsoft BizTalk Server 2000 ist die Dokumentüberwachung automatisch aktiviert, sind die Protokollieroptionen für ein- und ausgehende Austauschvorgänge ausgewählt und werden Metadaten für Austauschvorgänge überwacht, wie z. B.:

  • Quellorganisationsinformationen

  • Zielorganisationsinformationen

  • Dokumenttyp

  • Datum und Zeitpunkt der Verarbeitung des Austauschs durch BizTalk Server

  • Dokumentanzahl

  • Fehlerinformationen

  • Kontroll-ID

Zusätzlich zur Überwachung von Austauschvorgängen kann BizTalk Server auch für die Überwachung bestimmter Felder, wie z. B. Auftragssumme oder Rechnungssumme, konfiguriert werden. Weitere Informationen zur Überwachung bestimmter Felder finden Sie unter Grundlegendes zu den Überwachungseinstellungen im BizTalk-Messaging-Manager. Wenn Sie zum Zweck der Nichtabstreitbarkeit oder aus handelsrechtlichen Gründen eine Kopie von Austauschvorgängen im ursprünglichen Format benötigen, verwenden Sie die globalen Überwachungseinstellungen. Falls Sie für interne Zwecke eine Überwachungsliste erstellen möchten oder einen einfachen Zugriff auf Daten auf dokumentorientierter Basis benötigen, können Sie Überwachungseinstellungen im BizTalk-Messaging-Konfigurationsobjektmodell oder im BizTalk-Messaging-Manager konfigurieren. Sie können Überwachungseinstellungen im BizTalk-Messaging-Konfigurationsobjektmodell, im BizTalk-Messaging-Manager oder in der BizTalk Server-Verwaltung konfigurieren. Dadurch kann die Größe der Überwachungsdatenbank rasch zunehmen, da Daten mehrfach gespeichert werden.

Deaktivieren von Einstellungen der BizTalk-Dokumentüberwachung

Wenn Dokumente nicht überwacht werden müssen, können Sie die BizTalk-Dokumentüberwachung deaktivieren. Dadurch verzichten Sie allerdings auf wichtige Funktionen. Bei deaktivierter Dokumentüberwachung ist Folgendes z. B. nicht möglich:

  • Das Überwachen von Austauschvorgängen und dazugehörigen Dokumenten beim Durchlaufen von BizTalk Server 2000.

  • Das Erfüllen rechtlicher Anforderungen Normanforderungen an die Aufbewahrung von Kopien aller elektronischen Geschäftstransaktionen.

  • Das schnelle und einfache Beantworten von Kundenfragen. Wenn z. B. ein Kunde fragt: "Wann wurde an Handelspartner A eine Rechnung geschickt?", können Sie das Datum und die Uhrzeit ermitteln und feststellen, ob eine Empfangsbestätigung zurückgesendet wurde.

  • Hilfe bei der Problembehandlung.

  • Hilfe beim Lösen von Konflikten.

In der BizTalk Server-Verwaltung können Sie die Dokumentüberwachung aktivieren oder deaktivieren sowie die globalen Überwachungseinstellungen ändern. Weitere Informationen zur Konfiguration von Überwachungseinstellungen für eine Servergruppe finden Sie unter Konfigurieren von Überwachungseigenschaften für eine Servergruppe.

Anmerkungen

  • Zeigen Sie im Startmenü auf Programme, auf Microsoft BizTalk Server 2000, und klicken Sie auf BizTalk Server-Verwaltung, um die BizTalk Server-Verwaltung zu öffnen.

  • Für das Überwachung von Austauschvorgängen und Dokumenten existiert eine Größenbeschränkung. Weitere Informationen zur Größenbeschränkung finden Sie unter Austausch- und Dokumentgrößenbeschränkung.

Verwandte Themen

Konfigurieren von Überwachungseigenschaften für eine Servergruppe

Austausch- und Dokumentgrößenbeschränkung

Öffnen der BizTalk Server-Verwaltung

Grundlegendes zu den Überwachungseinstellungen im BizTalk-Messaging-Manager


Grundlegendes zu den Überwachungseinstellungen im BizTalk-Messaging-Manager

Konfigurieren Sie die Überwachungseinstellungen im BizTalk-Messaging-Manager, wenn Folgendes erforderlich ist:

  • Das Speichern vollständiger Kopien ein- und ausgehender Dokumentinstanzen.

  • Das Konfigurieren bestimmter zu erfassender Felder, wie z. B. Auftragssumme oder Auftragsdatum.

Im Gegensatz zur Überwachung der Eigenschaften einer Servergruppe ist das Überwachen bestimmter Felder oder Speichern von Kopien von Dokumentinstanzen nicht automatisch aktiviert. Sie müssen diese Optionen konfigurieren, wenn Sie im BizTalk-Messaging-Manager die entsprechenden Kanäle oder Dokumentdefinitionen konfigurieren.

Weitere Informationen zum Speichern von Kopien ein- und ausgehender Dokumentinstanzen finden Sie unter Festlegen von Eigenschaften für die Dokumentprotokollierung. Weitere Informationen zum Überwachen bestimmter Felder finden Sie unter Auswählen von Spezifikationsfeldern in einem Kanal.

Anmerkungen

  • Zeigen Sie im Startmenü auf Programme, auf Microsoft BizTalk Server 2000, und klicken Sie dann auf BizTalk-Messaging-Manager, um den BizTalk-Messaging-Manager zu öffnen.

  • Für das Überwachen und Speichern von Dokumenten existiert eine Größenbeschränkung. Weitere Informationen zur Größenbeschränkung finden Sie unter Austausch- und Dokumentgrößenbeschränkung.

Verwandte Themen

Austausch- und Dokumentgrößenbeschränkung

Auswählen von Spezifikationsfeldern in einem Kanal

Festlegen von Eigenschaften für die Dokumentprotokollierung

Grundlegendes zu den Überwachungseinstellungen einer Servergruppe


Grundlegendes zum Schema der Überwachungsdatenbank

Alle Server einer Servergruppe verwenden gemeinsam eine Überwachungsdatenbank, in der alle Informationen zur Austausch- und Dokumentaktivität in BizTalk Server gespeichert werden. Die Überwachungsdatenbank dient dem Überwachen des Status eines Austauschs oder Dokuments auf seinem Weg durch den Server. Die drei Haupttabellen in der Überwachungsdatenbank heißen:

  • dta_interchange_details

  • dta_outdoc_details

  • dta_indoc_details

Die unterstützenden Tabellen heißen:

  • dta_group_details

  • dta_interchange_data

  • dta_document_data

  • dta_debug_data

  • dta_routing_details

  • dta_custom_field_names

  • dta_MIME_data

Die folgende Abbildung veranschaulicht das allgemeine Datenbankschema der Überwachungsdatenbank. Zur besseren Übersichtlichkeit sind in der Abbildung nur die Tabellennamen aufgeführt. Die Linien zwischen den Tabellen verdeutlichen, wie die Tabellen über Fremdschlüsselfelder verbunden sind. Diese Schlüsselfelder und ihre Beziehungen zu anderen Tabellen werden ausführlich unter den Themen Struktur der Haupttabellen für Metadaten und Struktur sekundärer Tabellen beschrieben.

Schema der Überwachungsdatenbank

Tracking database schema
dta_group_details
dta_indoc_details
(core table)
dta_document_data
dta_routing_details
dta_custom_field_names
dta_outdoc_details
(core table)
dta_interchange_details
(core table)
dta_interchange_data
dta_debugdoc_data

Folgende Themen werden in diesem Abschnitt behandelt:

  • Haupttabellen für Metadaten

  • Sekundäre Tabellen

  • Struktur der Haupttabellen für Metadaten

  • Struktur sekundärer Tabellen

  • Verknüpfte Tabellen

  • Protokollieren von Austauschvorgängen und Dokumenten

  • Protokollieren von Empfangsbestätigungen

  • Protokollieren von Routinginformationen

  • Überwachen von XLANG-Ablaufplanereignissen in der Überwachungsdatenbank


Haupttabellen für Metadaten

Die Haupttabellen speichern die Metadaten von Austauschvorgängen, die von BizTalk Server verarbeitet werden. Zu den Metadaten zählen Informationen zur Quell- und Zielorganisation, der Dokumenttyp, Datum und Uhrzeit der Verarbeitung des Austauschs, die Dokumentanzahl, Fehlerinformationen, die Kontroll-ID usw.

Die Metadaten sind in der Überwachungsdatenbank in den folgenden drei Haupttabellen enthalten:

  • dta_indoc_details

  • dta_outdoc_details

  • dta_interchange_details

Die folgende Tabelle beschreibt die Funktion jeder Haupttabelle.

Tabellenname | Beschreibung
dta_indoc_details | Enthält einen Datensatz für jedes an BizTalk Server gesendete Dokument.
dta_outdoc_details | Enthält einen Datensatz für jedes von BizTalk Server generierte Dokument. Ein an BizTalk Server gesendetes Dokument kann aus einem oder mehreren generierten Dokumenten resultieren, die aufgrund mehrerer Kanalübereinstimmungen und Portgruppen an verschiedene Ziele übermittelt werden. Die Trennung von ein- und ausgehenden Dokumenten in zwei Tabellen ermöglicht eine physische Darstellung dieser 1:n-Beziehung.
dta_interchange_details | Enthält einen Datensatz für jeden von BizTalk Server verarbeiteten Austausch. Ein Richtungskennzeichen für diese Tabelle unterscheidet Versendungen von Übertragungen.

Verwandtes Thema

Struktur der Haupttabellen für Metadaten


Sekundäre Tabellen

Die sieben sekundären Tabellen, welche die Haupttabellen der Metadaten unterstützen, heißen:

  • dta_document_data

  • dta_debugDoc_data

  • dta_interchange_data

  • dta_routing_details

  • dta_group_details

  • dta_custom_field_names

  • dta_MIME_data

In diesen Tabellen werden unterstützende Informationen gespeichert, wie z. B. Dokumentdaten, Routinginformationen, Informationen zu benutzerdefinierten Suchen usw. Die folgende Tabelle beschreibt die Funktion jeder Tabelle.

Tabellenname | Beschreibung
dta_document_data | Enthält einen Datensatz für jedes an oder von BizTalk Server gesendete Dokument.
dta_debugDoc_data | Enthält für jedes inDoc- oder outDoc-Element, das (für das Messagingkanalobjekt) konfiguriert ist, eine Zeile, in der dessen XML-Zwischenformat aufgezeichnet wird.
dta_interchange_data | Enthält für jeden an oder von BizTalk Server gesendeten Austausch eine Zeile. In dieser Tabelle werden auch Antwortdokumente gespeichert, die an die IInterchange::SubmitSync aufrufende Anwendung zurückgegeben werden.
dta_routing_details | Fungiert als Spiegel der Messagingports, um eine datenbankübergreifende Abhängigkeit der BizTalk-Messaging-Verwaltungsdatenbank zu vermeiden. Insbesondere ist es erforderlich, die Quell- und Zielinformationen hinsichtlich der verarbeiteten Dokumente zu überwachen. Diese Informationen, die aus der BizTalk-Messaging-Verwaltungsdatenbank stammen, werden hier wiederholt, während neue Permutationen auftreten.
dta_group_details | Stellt Erweiterungskomponenten (Parser, Serialisierung und Empfangsbestätigungskorrelation) für Dokumentformate bereit, die verwandte Dokumentgruppen (z. B. X12 oder EDIFACT) innerhalb eines Austauschs verwenden. Diese Tabelle enthält für jede von diesen Komponenten analysierte oder serialisierte Gruppe eine Zeile.
dta_custom_field_names | Enthält für jedes getrennte Paar aus Erfassungsfeld-Knotennamen und Datentyp, das von BizTalk Server entdeckt wird, eine Zeile. Diese Tabelle ist ein Querverweis auf die dta_outdoc_details-Tabelle, die einen Fremdschlüssel für diese Tabelle für ihre Erfassungsfeldnamen verwendet. Die dta_indoc_details-Tabelle ist indirekt durch das Vorhandensein eines Fremdschlüssels mit diesen Feldnamen verbunden, der von der dta_outdoc_details-Tabelle auf seinen übergeordneten Schlüssel in der dta_indoc_details-Tabelle verweist.
dta_MIME_data | Enthält für jeden MIME-codierten Austausch, der an BizTalk Server gesendet wird, eine Zeile. Mithilfe dieser Tabelle können MIME-Daten überwacht werden, die Anlagen enthalten.

Verwandtes Thema

Struktur sekundärer Tabellen


Struktur der Haupttabellen für Metadaten

Die Hauttabellen für Metadaten sind, wie in diesem Abschnitt beschrieben, verknüpft und speichern die Metadaten aller Austauschvorgänge, die von BizTalk Server verarbeitet werden, wenn die Überwachungseinstellungen konfiguriert sind. Weitere Informationen zur Konfiguration von Überwachungseinstellungen für eine Servergruppe finden Sie unter Grundlegendes zu den Überwachungseinstellungen einer Servergruppe.

dta_indoc_details

Diese Tabelle hat eine 1:n-Beziehung mit der folgenden Tabelle:

  • dta_outdoc_details

Diese Tabelle hat eine n:1-Beziehung mit den folgenden Tabellen:

  • dta_group_details

  • dta_interchange_details

  • dta_error_message

  • dta_validity_values

Diese Tabelle hat eine 1:1-Beziehung mit den folgenden Tabellen:

  • dta_debugDoc_data

  • dta_document_data

  • dta_error_message

Die dta_indoc_details-Tabelle enthält pro Dokument, das an BizTalk Server gesendet wird, eine Zeile. Die folgende Tabelle beschreibt die Felder der dta_indoc_details-Tabelle.

Feldname | Beschreibung
nInDocKey | Eindeutiger Datensatzbezeichner des Primärschlüssels.
nDocumentDataKey | Fremdschlüssel von dta_document_data.
nDebugDocDataKey | Fremdschlüssel von dta_debugDoc_data für das XML-Format des empfangenen Dokuments, auch wenn das empfangene Dokument XML-formatiert ist.
nGroupKey | Fremdschlüssel von dta_group_details.
nInterchangeKey | Fremdschlüssel von dta_interchange_details.
uidTrackingGUID | Wert des Hauptüberwachungsschlüssels, der auf einem globaler eindeutigen Bezeichner (GUID) basiert.
dtProcessedTimeStamp | Zeitpunkt der Erstellung des Datensatzes.
nvcSyntax | Code der Dokumentsyntax (XML, X12, EDIFACT, HL7 usw.). Sollte die Syntax aufgrund eines Analysefehlers oder einer Pass-Through-Versendung nicht erkannt werden, hat dieses Feld den Wert UNBEKANNT.
nvcVersion | Version der Syntax.
nvcRelease | Release der Version.
nvcDocType | Dokumenttyp oder Bezeichner der Transaktionsmenge.
nvcControlID | Eindeutige Kontrollnummer für EDI-Dokumente und Funktionsgruppen.
nlsValid | Code, der Überprüfungsergebnisse angibt. Mögliche Werte sind 0 (ungültig), 1 (gültig) und 2 (Pass-Through).
nError | Code, der das Auftreten eines Fehlers meldet. Dies ist der Fremdschlüssel von dta_error_message, der Tabelle mit den Beschreibungen der Fehlermeldungen.

dta_outdoc_details

Diese Tabelle hat eine n:1-Beziehung mit den folgenden Tabellen:

  • dta_indoc_details

  • dta_interchange_details

  • dta_group_details

  • dta_debugDoc_data

  • dta_routing_details

  • dta_error_message

  • dta_ack_status

  • dta_data_level_values

  • dta_validity_values

Diese Tabelle hat eine 1:1-Beziehung mit den folgenden Tabellen:

  • dta_document_data

  • dta_error_message

Diese Tabelle hat eine n:n-Beziehung mit den folgenden Tabellen:

  • dta_custom_field_names

  • dta_ack_status_values

Die dta_outdoc_details-Tabelle enthält pro Dokument, das von BizTalk Server gesendet wird, eine Zeile. Die folgende Tabelle beschreibt die Felder der dta_outdoc_details-Tabelle.

Feldname | Beschreibung
nOutDocKey | Eindeutiger Datensatzbezeichner des Primärschlüssels.
nInDocKey | Fremdschlüssel des übergeordneten dta_indoc_details-Datensatzes.
nDocumentDataKey | Fremdschlüssel der dta_document_data-Tabelle.
nDebugDocDataKey | Fremdschlüssel von dta_debugDoc_data für das XML-Format des ausgehenden Dokuments, auch wenn das ausgehende Dokument XML-formatiert ist. Wird ein ausgehendes Dokument an eine Portgruppe gesendet, wird nur eine Kopie des dta_debugDoc_data-Datensatzes gespeichert, auf den alle sich ergebenden dta_outdoc_details-Datensätze zeigen.
nGroupKey | Fremdschlüssel der dta_group_details-Tabelle.
nInterchangeKey | Fremdschlüssel der dta_interchange_details-Tabelle.
uidTrackingGUID | Wert des Hauptüberwachungsschlüssels, der auf einem globaler eindeutigen Bezeichner (GUID) basiert.
dtProcessedTimeStamp | Zeitpunkt der Erstellung des Datensatzes.
nvcSyntax | Code der Dokumentsyntax (XML, X12, EDIFACT, HL7 usw.). Sollte die Syntax aufgrund eines Analysefehlers oder einer Pass-Through-Versendung nicht erkannt werden, hat dieses Feld den Wert UNBEKANNT.
nvcVersion | Version der Syntax.
nvcRelease | Release der Version.
nvcDocType | Dokumenttyp oder Bezeichner der Transaktionsmenge.
nvcControlID | Eindeutige Kontrollnummer für EDI-Dokumente und Funktionsgruppen.
nlsValid | Code, der Überprüfungsergebnisse angibt. Mögliche Werte sind 0 (ungültig), 1 (gültig) und 2 (Pass-Through).
nError | Code, der das Auftreten eines Fehlers meldet. Dies ist der Fremdschlüssel von dta_error_message, der Tabelle mit den Beschreibungen der Fehlermeldungen.
nAckStatus | Code des Empfangsbestätigungsstatus. Dies ist der Fremdschlüssel von dta_ack_status_values, der Tabelle mit den Beschreibungen der Statuswerte der Empfangsbestätigungen.
nRoutingKey | Fremdschlüssel von dta_routing_details.
nReceiptFlag | Ein Kennzeichen, das angibt, welcher Tabelle eine Empfangsbestätigung zugeordnet ist. Mögliche Werte sind 1 (Austausch), 2 (Gruppe), 4 (eingehendes Dokument), 8 (ausgehendes Dokument). Weitere Informationen zu Empfangsbestätigungen finden Sie unter Protokollieren von Empfangsbestätigungen.
nReceiptKey | Ein eindeutiger Wert zur Identifizierung der Empfangsbestätigung. Weitere Informationen zu Empfangsbestätigungen finden Sie unter Protokollieren von Empfangsbestätigungen.
ntReceiptDueBy | Zeitstempel des Empfangsbestätigung-Endtermins, der entsprechend dem Verarbeitungszeitstempel berechnet wird.
nRealName1 | Fremdschlüssel von dta_custom_field_names.
rlRealValue1 | Erstes Erfassungsfeld für reelle Zahlen. Dieses Feld muss einen reellen 8-Byte-Wert enthalten.
nRealName2 | Fremdschlüssel von dta_custom_field_names.
rlRealValue2 | 2. Erfassungsfeld für reelle Zahlen. Dieses Feld muss einen reellen 8-Byte-Wert enthalten.
nIntName1 | Fremdschlüssel von dta_custom_field_names.
nIntValue1 | Erstes Ganzzahl-Erfassungsfeld.
nIntName2 | Fremdschlüssel von dta_custom_field_names.
nIntValue2 | Zweites Ganzzahl-Erfassungsfeld.
nDateName1 | Fremdschlüssel von dta_custom_field_names.
dtDateValue1 | Erstes Datumserfassungsfeld.
nDateName2 | Fremdschlüssel von dta_custom_field_names.
dtDateValue2 | Zweites Datumserfassungsfeld.
nStrName1 | Fremdschlüssel von dta_custom_field_names.
nvcStrValue1 | Erstes Zeichenfolgen-Erfassungsfeld.
nStrName2 | Fremdschlüssel von dta_custom_field_names.
nvcStrValue2 | Zweites Zeichenfolgen-Erfassungsfeld.
nvcCustomSearch | BLOB für verkettete Zeichenfolgenerfassung als XML.

dta_interchange_details

Diese Tabelle hat eine 1:n-Beziehung mit den folgenden Tabellen:

  • dta_indoc_details

  • dta_outdoc_details

  • dta_group_details

  • dta_interchange_data

Diese Tabelle hat eine n:1-Beziehung mit den folgenden Tabellen:

  • dta_direction_values

  • dta_error_message

  • dta_transport_type_values

Die dta_interchange_details-Tabelle enthält pro Austausch, der von BizTalk Server verarbeitet wird, eine Zeile. Die folgende Tabelle beschreibt die Felder der dta_interchange_details-Tabelle.

Feldname | Beschreibung
nInterchangeKey | Eindeutiger Datensatzbezeichner des Primärschlüssels.
nInterchangeDataKey | Fremdschlüssel von dta_interchange_data.
nResponseDocDataKey | Fremdschlüssel von dta_document_data für das Antwortdokument, das vom Empfänger eines ausgehenden Transports zurückgegeben wird.
uidInterchangeGUID | Globaler eindeutiger Bezeichner (GUID) des Austauschs.
uidSubmissionGUID | Globaler eindeutiger Bezeichner (GUID) der übergeordneten Versendung. Enthält den Korrelationsbezeichner (correlationID), der von den BizTalk-Orchestrierungsdiensten bereitgestellt bzw. diesen bereitgestellt wird. Dieses Feld bleibt leer, wenn der Datensatz zu einem eingehenden Austausch gehört, der nicht von den BizTalk-Orchestrierungsdiensten stammt. Bei eingehenden Austauschvorgängen wird dieses Feld nur aufgefüllt, wenn der Austausch von den BizTalk-Orchestrierungsdiensten stammt. Bei eingehenden Austauschvorgängen wird dieses Feld stets aufgefüllt.
dtProcessedTimeStamp | Zeitpunkt der Erstellung des Datensatzes.
nvcSyntax | Code der Dokumentsyntax (XML, X12, EDIFACT, HL7 usw.). Sollte die Syntax aufgrund eines Analysefehlers oder einer Pass-Through-Versendung nicht erkannt werden, hat dieses Feld den Wert UNBEKANNT.
nvcVersion | Version der Syntax.
nvcControlID | Eindeutige Kontrollnummer für EDI-Austauschvorgänge oder ein Bezeichner für BizTalk Reliable Messages.
nDirection | Kennzeichen, das angibt, ob der Austausch ein- oder ausgehend ist. Mögliche Werte sind 0 (ausgehend) oder 1 (eingehend). Dies ist der Fremdschlüssel von dta_direction_values, der Tabelle mit den Richtungswerten.
dtTimeSent | Zeitstempel einer erfolgreichen Übertragung.
nError | Code, der das Auftreten eines Fehlers meldet. Dies ist der Fremdschlüssel von dta_error_message, der Tabelle mit den Beschreibungen der Fehlermeldungen.
nTestMode | Test- oder Produktionsanzeige. Dieses Feld ist reserviert und wird nicht verwendet.
nvcSrcAliasQualifer | Qualifiziererwert des Absenders, der aus dem versendeten oder übertragenen Austausch extrahiert wird.
nvcSrcAliasId | Bezeichnerwert des Absenders, der aus dem versendeten oder übertragenen Austausch extrahiert wird.
nvcSrcAppName | Bezeichner der Austauschebene für die Quellanwendung, der aus dem versendeten oder übertragenen Austausch extrahiert wird.
nvcDestAliasQualifier | Empfängerqualifizierer, der aus dem versendeten oder übertragenen Austausch extrahiert wird.
nvcDestAliasID | Bezeichnerwert des Empfängers, der aus dem versendeten oder übertragenen Austausch extrahiert wird.
nvcDestAppName | Bezeichner der Austauschebene für die Zielanwendung, der aus dem versendeten oder übertragenen Austausch extrahiert wird.
nAckStatus | Code des Empfangsbestätigungsstatus. Dies ist der Fremdschlüssel von dta_ack_status_values, der Tabelle mit den Beschreibungen der Statuswerte der Empfangsbestätigungen.
nvcSMTPMessageID | SMTP-Transportmeldungsbezeichner (für EDIINT). Dieses Feld ist reserviert und wird nicht verwendet.
nDocumentsAccepted | Die Anzahl der in dem Austausch akzeptierten Dokumente.
nDocumentsRejected | Die Anzahl der in dem Austausch zurückgewiesenen Dokumente.
nTransportType | Anzeigecode des Übertragungsprotokolls. Dies ist ein Fremdschlüssel von dta_transport_type_values.
nvcTransportAddress | Adresse des Transportziels.
ssnvcServerName | Server, der den Austausch verarbeitet hat.
nNumberOfBytes | Größe des Austauschs in Byte. Dieses Feld stellt dar, was im dazugehörigen dta_interchange_data-Datensatz überwacht wird, und kann sich davon unterscheiden, was tatsächlich übertragen wird. Die Größe kann sich durch eine zusätzliche Umschlagverarbeitung und Datenformatkonvertierung während der Übertragung erhöhen.
nNumOfTransmitAttempts | Zähler der Übertragungsversuche.

Verwandtes Thema

Grundlegendes zu den Überwachungseinstellungen einer Servergruppe


Struktur sekundärer Tabellen

In den sekundären Tabellen werden die unterstützenden Daten der Haupttabellen in der Überwachungsdatenbank gespeichert. Dazu zählen z. B. die folgenden Informationen:

  • Suchdaten benutzerdefinierter Felder

  • Routinginformationen

  • Austauschdaten

  • Dokumentdaten

dta_document_data

Diese Tabelle hat eine 1:1-Beziehung mit den folgenden Tabellen:

  • dta_indoc_details

  • dta_outdoc_details

Die dta_document_data-Tabelle ist das zentrale Repository für die Dokumentspeicherung. Die folgende Tabelle beschreibt die Felder der dta_document_data-Tabelle.

Feldname | Beschreibung
nDocumentDataKey | Eindeutiger Datensatzbezeichner des Primärschlüssels.
nCodePage | Die Systemcodeseite (z. B. 1200-Unicode, 65001-UTF-8 usw.) der zeichencodierten gespeicherten Daten. Das Feld hat den Wert -1, wenn BizTalk Server über keine Codeseiteninformationen zu den Daten verfügt. In diesem Fall kann der Wert im Feld nBLOBType gegebenenfalls Informationen zur Interpretation der Daten bereitstellen.
nBLOBType | Kennzeichen, das den Typ der Daten angibt, die im Feld imgDocumentData gespeichert sind. Mögliche Werte sind 0 (Unbekannt) oder 1 (XMLDOM kann geladen werden). XMLDOM kann geladen werden bedeutet, dass die Daten in das MSXML DOMDocument-Objekt geladen und von diesem verarbeitet werden können. Dieses Feld ist ein Fremdschlüssel von dta_blobtype_values.
imgDocumentData | Speicherung eines Dokuments als BLOB (Binary Large Object).
nNumberOfBytes | Die Größe des Dokuments in Byte.
nNumberOfRecords | Die im Dokument enthaltenen Datensätze oder Segmente.

dta_debugDoc_data

Diese Tabelle hat eine 1:1-Beziehung mit der folgenden Tabelle:

  • dta_indoc_details

Diese Tabelle hat eine 1:n-Beziehung mit der folgenden Tabelle:

  • dta_outdoc_details

Die Tabelle ist das zentrale Repository für die Debug-Dokumentspeicherung. Die folgende Tabelle beschreibt die Felder der dta_debugDoc_data-Tabelle.

Feldname | Beschreibung
nDebugDocDataKey | Eindeutiger Datensatzbezeichner des Primärschlüssels.
ntxtDocumentData | Speicherung des Dokuments als BLOB (Binary Large Object). Diese erfolgt stets in Unicode.
nNumberOfBytes | Größe des Dokuments in Byte.
dtProcessedTimeStamp | Zeitpunkt der Erstellung des Datensatzes. Wird vom Auftraglöschbeispiel verwendet, das sich im BizTalk Server-Installationsverzeichnis in \Programme\Microsoft BizTalk Server\SDK\Messaging Samples\SQLServerAgentJobs\DTA_SampleJobs.sql befindet.

dta_interchange_data

Diese Tabelle hat eine n:1-Beziehung mit der folgenden Tabelle:

  • dta_interchange_details

Die dta_interchange_data-Tabelle ist ein zentrales Repository für die Austauschspeicherung und enthält für jeden vom System verarbeiteten Austausch einen Datensatz. Für Austauschvorgänge, die nur an BizTalk Server gesendet werden, gibt das Feld nlsFile an, ob die gespeicherten Daten ursprünglich aus dem Dateisystem stammten. Ist das Kennzeichen festgelegt, enthält das Feld nvcOriginalFileName einen UNC-Pfad (Universal Naming Convention) zum Dateisystemspeicherort, aus dem die Daten stammen. Das Feld imgInterchangeData enthält die gesendeten Daten ungeachtet des Ursprungs.

Feldname | Beschreibung
nInterchangeDataKey | Eindeutiger Datensatzbezeichner des Primärschlüssels.
nCodePage | Die Systemcodeseite (z. B. 1200-Unicode, 65001-UTF-8 usw.) der zeichencodierten gespeicherten Daten. Hat den Wert -1, wenn BizTalk Server über keine Codeseiteninformationen zu den Daten verfügt oder die Daten als Folge einer Pass-Through-Versendung überwacht werden. In diesem Fall kann der Wert im Feld nBLOBType gegebenenfalls Informationen zur Interpretation der Daten bereitstellen.
nlsFile | Kennzeichen, das eine dateibasierte Datenversendung anzeigt. Mögliche Werte sind 0 (nicht dateibasiert) oder 1 (dateibasiert).
nvcOriginalFileName | UNC-Pfad zu der Daten, wenn das Feld nlsFile den Wert 1 hat.
nBLOBType | Kennzeichen, das den Typ der Daten angibt, die im Feld imgDocumentData gespeichert sind. Mögliche Werte sind 0 (Unbekannt) oder 1 (XMLDOM kann geladen werden). XMLDOM kann geladen werden bedeutet, dass die Daten in das MSXML DOMDocument-Objekt geladen und von diesem verarbeitet werden können. Dieses Feld ist ein Fremdschlüssel von dta_blobtype_values.
imgInterchangeData | Speicherung des Austauschs als BLOB (Binary Large Object).

dta_group_details

Diese Tabelle hat eine 1:n-Beziehung mit den folgenden Tabellen:

  • dta_indoc_details

  • dta_outdoc_details

Diese Tabelle hat eine n:1-Beziehung mit den folgenden Tabellen:

  • dta_interchange_details

  • dta_direction_values

Die dta_group_details-Tabelle erstellt pro Gruppe, die von Erweiterungskomponenten des elektronischen Datenaustauschs (EDI) verarbeitet wird, eine Zeile. Die folgende Tabelle beschreibt die Felder der dta_group_details-Tabelle.

Feldname | Beschreibung
nGroupKey | Eindeutiger Datensatzbezeichner des Primärschlüssels.
nInterchangeKey | Fremdschlüssel für dta_interchange_details.
dtProcessedTimeStamp | Zeitpunkt der Erstellung des Datensatzes.
nvcSyntax | Code der Dokumentsyntax (XML, X12, EDIFACT, HL7 usw.). Sollte die Syntax aufgrund eines Analysefehlers oder einer Pass-Through-Versendung nicht erkannt werden, hat dieses Feld den Wert UNBEKANNT.
nvcVersion | Version des Standards.
nvcRelease | Release der Version.
nvcFunctionalGroupID | Code des Typs der Dokumente in der Gruppe.
nvcControlID | Eindeutige Kontrollnummer für EDI-Dokumente und Funktionsgruppen.
nvcSrcAppName | Gruppenebenenbezeichner der Quellanwendung.
nvcDestAppName | Gruppenebenenbezeichner der Zielanwendung.
nAckStatus | Code des Empfangsbestätigungsstatus. Dies ist der Fremdschlüssel von dta_ack_status_values, der Tabelle mit den Beschreibungen der Statuswerte der Empfangsbestätigungen.
nDirection | Kennzeichen, das angibt, ob die Gruppe ein- oder ausgehend ist. Mögliche Werte sind 0 (ausgehend) oder 1 (eingehend). Dies ist ein Fremdschlüssel von dta_direction_values.
nDocumentsAccepted | In der Gruppe akzeptierte Transaktionen.
nDocumentsRejected | In der Gruppe zurückgewiesene Transaktionen.
nNumberOfBytes | Größe des Austauschs in Byte.

dta_routing_details

Diese Tabelle hat eine 1:n-Beziehung mit der folgenden Tabelle:

  • dta_outdoc_details

Die dta_routing_details-Tabelle enthält pro getrennter Quell- und Zielinformationsmenge eine Zeile. Zwei Dokumente können auf der Organisations- und der Anwendungsebene zwei identische Routingfeldwerte aufweisen. In diesem Fall werden diese Dokumente gemäß dem Dokumenttyp oder verschiedener anderer niedriger eingestufter Filter unterschieden. Wenn dies geschieht, enthält die dta_routing_details-Tabelle Zeilen, die mit Ausnahme eines Unterschieds in den entsprechenden übergeordneten Messagingports identisch sind. Diese Verknüpfung mit dem übergeordneten Messagingport wird verwendet, um eine Verbindung zwischen der Benutzeroberflächen-Funktionalität des BizTalk-Messaging-Managers und der Überwachung zu erleichtern. Die folgende Tabelle beschreibt die Felder der dta_routing_details-Tabelle.

Feldname | Beschreibung
nRoutingKey | Eindeutiger Datensatzbezeichner des Primärschlüssels.
nvcSrcOrgName | Name der Quellorganisation entsprechend der Angabe im übergeordneten Kanalobjekt.
nvcSrcAppName | Name der Quellanwendung entsprechend der Angabe im übergeordneten Kanalobjekt.
nvcDestOrgName | Name der Zielorganisation entsprechend der Angabe im übergeordneten Messagingport-Objekt.
nvcDestAppName | Name der Zielanwendung entsprechend der Angabe im übergeordneten Portobjekt.
nvcDistributionName | Name der Verteilerliste.
uidChannelGUID | Eindeutiger Schlüssel des übergeordneten Kanals, der auf einem globalen eindeutigen Bezeichner (GUID) basiert. Wird als Kanalkorrelationsschlüssel für die BizTalk-Messaging-Verwaltungsdatenbank verwendet.
uidPortGUID | Eindeutiger Schlüssel des übergeordneten Ports, der auf einem globalen eindeutigen Bezeichner (GUID) basiert. Wird als Portkorrelationsschlüssel für die BizTalk-Messaging-Verwaltungsdatenbank verwendet.

dta_custom_field_names

Diese Tabelle hat eine n:1-Beziehung mit der folgenden Tabelle:

  • dta_outdoc_details

Die dta_custom_field_names-Tabelle enthält pro getrennt erfasstem Paar aus Knotennamen und Datentyp eine Zeile. Die folgende Tabelle beschreibt die Felder der dta_custom_field_names-Tabelle.

Feldname | Beschreibung
nNameKey | Eindeutiger Datensatzbezeichner des Primärschlüssels.
nvcName | Text des Knotennamens. Beispiel: /CommonPO/Total/@POTotal.
nDataType | In dem benannten Knoten enthaltener Datentyp.

dta_MIME_data

In der dta_MIME_data-Tabelle werden die eingehenden MIME-Daten gespeichert, die von BizTalk Server verarbeitet werden. Mithilfe dieser Tabelle können MIME-Daten überwacht werden, die Anlagen enthalten. Die folgende Tabelle beschreibt die Felder der dta_MIME_data-Tabelle.

Feldname | Beschreibung
nMIMEDataKey | Eindeutiger Datensatzbezeichner des Primärschlüssels.
uidSubmissionGUID | Globaler eindeutiger Bezeichner (GUID) der übergeordneten Versendung.
nCodePage | Systemcodeseite für zeichencodierte gespeicherte Daten im Feld imgMIMEData. Bei MIME-Daten ist der Wert 1252 (ASCII) oder 1200 (Unicode).
imgMIMEData | Speicherung des Dokuments als BLOB (Binary Large Object).


Verknüpfte Tabellen

Die Überwachungsdatenbank enthält 13 Zusatztabellen zur Unterstützung der Haupttabellen und der unterstützenden Tabellen. In diesen Tabellen werden Informationen wie Gruppen- und Austauschkorrelationsschlüssel, Statuswerte von Empfangsbestätigungen, Datenebenenwerte usw. gespeichert. Die folgende Tabelle beschreibt die Tabellen und deren Funktionen.

Tabellenname | Funktion
dta_ack_status_values | Speichert die Statuswerte von Empfangsbestätigungen. Mögliche Werte sind Keine, Ausstehend, Überfällig, Akzeptiert, Mit Fehlern akzeptiert und Abgelehnt.
dta_blobtype_values | Speichert BLOB-Typen. Mögliche Werte sind Unbekannt oder XMLDOM kann geladen werden.
dta_data_level_values | Speichert die in BizTalk Server verwendeten Datenebenenwerte. Mögliche Werte sind Austausch, Gruppe, Eingehendes Dokument und Ausgehendes Dokument.
dta_direction_values | Speichert die Richtung des Austauschs. Mögliche Werte sind Eingehend oder Ausgehend.
dta_error_message | Speichert die in der BizTalk-Dokumentüberwachung verwendeten Fehlermeldungen. Mögliche Werte sind Kein Fehler, Eine benutzerdefinierte Komponente konnte nicht aufgerufen werden, Der Austausch konnte nicht analysiert werden, Der angegebene Kanal ist nicht vorhanden, Der Austausch konnte nicht serialisiert werden, Der Austausch konnte nicht codiert werden, Der Austausch konnte nicht signiert werden, Der Austausch konnte nicht verschlüsselt werden, Fehler beim Übertragungsversuch (erneute Übertragung steht aus), Fehler beim letzten Übertragungsversuch, Das Dokument konnte nicht analysiert werden, Das Dokument konnte nicht überprüft werden, Es konnte kein gültiger Kanal gefunden werden, Das Dokument konnte nicht zugeordnet werden, Es konnte kein gültiger Messagingport gefunden werden und Das Dokument konnte nicht serialisiert werden.
dta_group_correlation_keys | Speichert die Gruppenkorrelationsschlüssel. Die Werte werden dynamisch generiert, um während der Empfangsbestätigungskorrelation mögliche Gruppenkandidaten zu identifizieren.
dta_interchange_correlation_keys | Speichert die Austauschkorrelationsschlüssel. Die Werte sind eindeutig und werden dynamisch generiert, um während der Empfangsbestätigungskorrelation mögliche Gruppenkandidaten zu identifizieren.
dta_transport_type_values | Speichert die Transporttypwerte. Mögliche Werte sind Keine, HTTP, SMTP, DCOM, Anwendungsintegration, Message Queuing, Datei, HTTPS, Offenes Ziel, Loopback und Orchestrierungsaktivierung.
dta_ui_codepage_charset | Speichert die Systemcodeseiten für zeichencodierte Daten.
dta_ui_user_queries | Speichert die erweiterten Abfragen, die von einzelnen Benutzern erstellt und gespeichert werden.
dta_validity_values | Speichert die Überprüfungswerte. Mögliche Wert sind Nicht gültig, Gültig und Pass-Through. Der Wert Pass-Through bedeutet, dass das Dokument nicht analysiert wurde und keiner Überprüfung unterzogen wird. Weitere Informationen zu Pass-Through finden Sie unter Grundlegendes zu erweiterten Eigenschaften von Empfangsfunktionen.
dta_wf_EventData | Enthält für jede Eigenschaft, die in Relation zu einem überwachten COM+-Ereignis protokolliert wird, das von einem XLANG-Ablaufplan ausgelöst wird, einen Datensatz. Gruppen mehrerer Zeilen in dieser Tabelle haben einen gemeinsamen übergeordneten Datensatz in der dta_wf_WorkFlowEvent-Tabelle.
dta_wf_WorkFlowEvent | Enthält für jedes überwachte COM+-Ereignis, das von einem XLANG-Ablaufplan ausgelöst wird, einen Datensatz.


Protokollieren von Austauschvorgängen und Dokumenten

Die verschiedenen Verarbeitungsszenarien, wie z. B. Offene Quelle, Offenes Ziel und Pass-Through, werden in der Überwachungsdatenbank unterschiedlich protokolliert. Die sechs gängigsten Verarbeitungsszenarien sind Nicht geöffnet, Offene Quelle, Offenes Ziel, Loopback, Pass-Through sowie Erwartete Empfangsbestätigung und Empfangsbestätigung generieren (die letzten beiden werden als ein Szenario betrachtet). Die Verarbeitungsszenarien Erwartete Empfangsbestätigung und Empfangsbestätigung generieren werden unter Protokollieren von Empfangsbestätigungen beschrieben. Die verbleibenden Verarbeitungsszenarien werden in der folgenden Tabelle vorgestellt.

Verarbeitungsszenarien | Beschreibung
Nicht geöffnet | Tritt ein, wenn die Quelle und das Ziel explizit in der Empfangsfunktion, der Dokumentinstanz, der Submit-Methode oder der SubmitSync-Methode deklariert sind.
Offene Quelle | Tritt ein, wenn die Quellinformationen nicht explizit im Kanal deklariert sind. Der Kanal muss als offene Quelle markiert sein, und der Submit-Aufruf oder die Empfangsfunktion müssen den Offenheitsgrad der Quelle angeben.
Offenes Ziel | Tritt ein, wenn die Zielinformationen nicht explizit im Messagingport deklariert sind. Das Ziel wird in der Dokumentinstanz, der Submit-Methode oder der SubmitSync-Methode dynamisch angegeben. Der Port muss als offenes Ziel markiert sein, und der Submit-Aufruf oder die Empfangsfunktion muss den Offenheitsgrad des Ziels angeben.
Loopback | Tritt ein, wenn Loopback der in einem Kanal angegebene Transport ist. Loopback gibt das ausgehende Dokument eines Kanals an eine Geschäftsanwendung, Komponente oder einen XLANG-Ablaufplan zurück, die/der das eingehende Dokument mithilfe der SubmitSync-Methode gesendet hat. Dieser Transporttyp ist nur für einen Messagingport verfügbar, der sich mit einer Anwendung verbindet, und steht nur über die SubmitSync-Methode zur Verfügung.
Pass-Through | Tritt ein, wenn Sie in der Empfangsfunktion die Option Mit Pass-Through-Kennzeichen senden auswählen oder in den Methoden Submit oder SubmitSync die Pass-Through-Eigenschaft konfigurieren. BizTalk Server verarbeitet das Dokument nicht. Dies bedeutet, dass das Dokument nicht analysiert, signiert, entschlüsselt, überprüft usw. wird. Das Dokument wird nur von BizTalk Server transportiert.

Die folgende Tabelle veranschaulicht, welche ausgehenden Datensätze in der Überwachungsdatenbank protokolliert werden.

Verarbeitungsszenarien | dta_interchange_details (outgoing) | dta_outdoc_details | Antwortdokument
Nicht geöffnet | X | X | X
Offene Quelle | X | X | X
Offenes Ziel | X | X | X
Loopback | X | X |
Pass-Through | X | X | X

Anmerkungen

  • Antwortdokumente werden nur bei Verwenden der folgenden Transporte generiert: HTTP, HTTPS und AIC. Darüber hinaus muss die Empfängeradresse Rückgabedaten senden.

  • Beim Pass-Through-Szenario ist der Datensatz, der in der dta_outdoc_details-Tabelle protokolliert wird, leer. Das Feld nlsValid hat den Wert 2, um anzugeben, dass dieser Datensatz einem Pass-Through-Dokument zugeordnet ist. Das Feld nSyntax hat den Wert UNBEKANNT. Da BizTalk Server das Dokument nicht verarbeitet, kann BizTalk Server die meisten Felder dieser Tabelle nicht mit relevanten Daten auffüllen.

Die folgende Tabelle veranschaulicht, welche eingehenden Datensätze in der Überwachungsdatenbank protokolliert werden.

Verarbeitungsszenarien | dta_interchange_details (incoming) | dta_indoc_details | Antwortdokument
Nicht geöffnet | X | X | X
Offene Quelle | X | X | X
Offenes Ziel | X | X | X
Loopback | X | X |
Pass-Through | X | X | X

Anmerkungen

  • Antwortdokumente werden nur bei Verwenden der folgenden Transporte generiert: HTTP, HTTPS und AIC. Darüber hinaus muss die Empfängeradresse Rückgabedaten senden.

  • Beim Pass-Through-Szenario ist der Datensatz, der in der dta_indoc_details-Tabelle protokolliert wird, leer. Das Feld nlsValid hat den Wert 2, um anzugeben, dass dieser Datensatz einem Pass-Through-Dokument zugeordnet ist. Das Feld nSyntax hat den Wert UNBEKANNT. Da BizTalk Server das Dokument nicht verarbeitet, kann BizTalk Server die meisten Felder dieser Tabelle nicht mit relevanten Daten auffüllen.

Verwandtes Thema

Protokollieren von Empfangsbestätigungen


Protokollieren von Empfangsbestätigungen

Die folgende Abbildung veranschaulicht den Ablauf von Empfangsbestätigungen in BizTalk Server.

Verarbeiten von Empfangsbestätigungen mithilfe von Kanälen
Generieren und senden von Empfangsbestätigungen
Empfangen und korrelieren von Empfangsbestätigungen
Austausch empfangen und verarbeiten
Zielsystem
Quellsystem
Messagingport zum
Zielsystem
Auftrag
Parser
Messaging-
port zum
Zielsystem
Ausgehende
Dokument-
definition
Empfangsbestätigung
Dokument-
spezifikation
Dokument-
spezifikation
Eingehende
Dokument-
definition
Zuord-
nung
Empfangskanal
Standard-
empfangsbestätigung
Messagingport
zur Anwendung
Kanal vom
Quellsystem
Dokument-
spezifikation
Empfangsbestätigungs-
dokumentdefinition
Kanal für Auftrag
Austausch generieren und senden

In diesem Szenario gilt Folgendes:

  • Quell- und Zielsystem verwenden Microsoft BizTalk Server 2000.

  • Das Quellsystem sendet einen Auftrag an das Zielsystem. Das Quellsystem erwartet eine Empfangsbestätigung für den Auftrag vom Zielsystem.

  • Beide Systeme sind für das Erwarten und Generieren von Empfangsbestätigungen konfiguriert.

Wenn der Auftrag vom Quellsystem verarbeitet und an das Zielsystem gesendet wurde, wird ein Datensatz in der dta_outdoc_details-Tabelle protokolliert. Die folgende Tabelle veranschaulicht, wie die für Empfangsbestätigungen relevanten Felder in diesem Datensatz aussehen können.

Feldname | Beispielwert | Beschreibung
nOutDocKey | 1 | Ein eindeutiger Wert zur Identifizierung des Datensatzes.
nAckStatus | 1 | Gibt an, dass eine Empfangsbestätigung für das Dokument aussteht.
nReceiptFlag |  | Wird zu diesem Zeitpunkt nicht ausgefüllt.
nReceiptKey |  | Wird zu diesem Zeitpunkt nicht ausgefüllt.

Wenn das Zielsystem den Auftrag empfangen und verarbeitet hat, werden in der dta_indoc_details-Tabelle ein Datensatz und in der dta_outdoc_details-Tabelle zwei Datensätze protokolliert. Der Datensatz in der dta_indoc_details-Tabelle enthält Informationen, die für den Auftrag relevant sind. Der Datensatz in der dta_outdoc_details-Tabelle enthält Informationen, die für den Auftrag relevant sind, der zweite Datensatz enthält Informationen, die für den Empfang des Auftrags relevant sind.

Die folgende Tabelle veranschaulicht, wie die für den Auftrag relevanten Felder in dem Datensatz der dta_indoc_details-Tabelle aussehen können.

Feldname | Beispielwert | Beschreibung
nInDocKey | 1 | Ein eindeutiger Wert zur Identifizierung des Datensatzes.
nDocType | Standardauftrag | Identifiziert den Typ des empfangenen Dokuments.

Der erste Datensatz, der in der dta_outdoc_details-Tabelle protokolliert wird, gehört zum von BizTalk Server verarbeiteten Auftrag. Die folgende Tabelle veranschaulicht, wie die für Empfangsbestätigungen relevanten Felder in diesem Datensatz aussehen können.

Feldname | Beispielwert | Beschreibung
nOutDocKey | 10 | Ein eindeutiger Wert zur Identifizierung des Datensatzes.
nInDocKey | 1 | Verknüpft den Datensatz mit dem übergeordneten Datensatz in der dta_indoc_details-Tabelle.

Der zweite Datensatz, der in der dta_outdoc_details-Tabelle protokolliert wird, gehört zur Empfangsbestätigung, die vom Auftrag generiert wird. Die folgende Tabelle veranschaulicht, wie die für Empfangsbestätigungen relevanten Felder in diesem Datensatz aussehen können.

Feldname | Beispielwert | Beschreibung
nOutDocKey | 2 | Ein eindeutiger Wert zur Identifizierung des Datensatzes.
nInDocKey | 1 | Verknüpft den Datensatz mit dem übergeordneten Datensatz in der dta_indoc_details-Tabelle.
nAckStatus | 0 | Die Empfangsbestätigung erwartet selbst keine Empfangsbestätigung.
nReceiptFlag | 4 | Gibt an, dass die Empfangsbestätigung einem Datensatz in der dta_indoc_details-Tabelle zugeordnet ist.
nReceiptKey | 1 | Ein eindeutiger Wert zur Identifizierung des Datensatzes der Empfangsbestätigung.

Wenn das Quellsystem die vom Zielsystem generierte Empfangsbestätigung empfangen hat und ein Datensatz in der dta_indoc_details-Tabelle protokolliert wurde, wird der ursprünglich in der dta_outdoc_details-Tabelle protokollierte Datensatz aktualisiert. Die folgende Tabelle veranschaulicht, wie die für Empfangsbestätigungen relevanten Felder in dem Datensatz der dta_indoc_details-Tabelle aussehen können.

Feldname | Beispielwert | Beschreibung
nInDocKey | 9 | Ein eindeutiger Wert zur Identifizierung des Datensatzes.
nDocType | 997 | Gibt den Typ des empfangenen Dokuments an.

Die folgende Tabelle veranschaulicht, wie die für Empfangsbestätigungen relevanten Felder in dem aktualisierten Datensatz der dta_outdoc_details-Tabelle aussehen können.

Feldname | Beispielwert | Beschreibung
nOutDocKey | 1 | Ein eindeutiger Wert zur Identifizierung des Datensatzes.
nAckStatus | 3 | Gibt an, dass eine Empfangsbestätigung empfangen wurde.
nReceiptFlag | 4 | Gibt an, dass die Empfangsbestätigung einem Datensatz in der dta_indoc_details-Tabelle zugeordnet ist.
nReceiptKey | 9 | Ein eindeutiger Wert zur Identifizierung des Datensatzes der Empfangsbestätigung.

Verwandtes Thema

Protokollieren von Austauschvorgängen und Dokumenten


Protokollieren von Routinginformationen

Die in der Überwachungsdatenbank protokollierten Routinginformationen variieren je nachdem, ob das Dokument ein- oder ausgehend ist und wie BizTalk Server die Daten verarbeitet. Wenn BizTalk Server bei eingehenden Austauschvorgängen ein Dokument empfängt, wird die Dokumentinstanz auf Routinginformationen untersucht. Anschließend überprüft BizTalk Server die Empfangsfunktion oder die in IInterchange::Submit angegebenen Routingparameter. Wenn in der Empfangsfunktion oder IInterchange::Submit Routinginformationen angegeben sind, werden diese Parameter zum Weiterleiten der Dokumentinstanz verwendet. Die in der Dokumentinstanz angegebenen Routinginformationen werden in der Überwachungsdatenbank in der dta_routing_details-Tabelle protokolliert.

Bei ausgehenden Austauschvorgängen stammen die Quell- und Zielinformationen stets vom Kanal und werden in der dta_routing_details-Tabelle protokolliert.

Dies wirkt sich darauf aus, welche Informationen auf der Benutzeroberfläche der BizTalk-Dokumentüberwachung für Aliasnamen angezeigt werden. Es hat keine Auswirkungen darauf, wie an BizTalk Server gesendete und von BizTalk Server übertragene Austauschvorgänge als einzelne Datenflussinstanz in Beziehung stehen.


Überwachen von XLANG-Ablaufplanereignissen in der Überwachungsdatenbank

Aktionsereignisse im Zusammenhang mit Nachrichten, die von einem XLANG-Ablaufplan verarbeitet werden und zwischen den BizTalk-Messagingdiensten und BizTalk-Orchestrierungsdiensten ausgetauscht werden, können in den entsprechenden Tabellen der Überwachungsdatenbank protokolliert werden. Die Aktionsereignisse können mithilfe der BizTalk-Dokumentüberwachung angezeigt werden. Das Überwachen und Anzeigen von Aktionsereignissen in Zusammenhang mit Nachrichten, die von einem XLANG-Ablaufplan verarbeitet werden, ist nach der Installation von BizTalk Server 2000 nicht automatisch aktiviert. Sie müssen die folgenden Schritte durchführen, um diese Funktion zu aktivieren:

  1. Registrieren Sie die DLL-Beispieldatei WorkFlowAudit.dll.

    Diese Beispieldatei finden Sie im Ordner \Programme\Microsoft BizTalk Server\SDK\XLANG Samples\WorkFlowAudit\bin.

  2. Führen Sie die Anwendung WorkFlowAuditClient.exe aus, um WorkFlowAudit.dll zu aktivieren.

    Diese Beispielanwendung finden Sie im Ordner \Programme\Microsoft BizTalk Server\SDK\XLANG Samples\WorkFlowAuditClient.

    Weitere Informationen finden Sie in der Infodatei (Readme.txt) im Ordner \Programme\Microsoft BizTalk Server\SDK\XLANG Samples\WorkFlowAudit\Docs.

  3. Klicken Sie in der Anwendung WorkFlowAuditClient auf die Schaltfläche Start, um das Protokollieren von Aktionsereignissen in Zusammenhang mit einem XLANG-Ablaufplan in der Überwachungsdatenbank zu starten.

Wichtig

  • Datensätze werden nur dann in den Tabellen dta_wf_EventData und dta_wf_WorkFlowEvent protokolliert, wenn die Anwendung WorkFlowAuditClient gestartet wurde. Befolgen Sie zum Starten der Anwendung WorkFlowAuditClient die drei zuvor genannten Schritte. Wird WorkFlowAuditClient angehalten, werden keine Datensätze in den Tabellen dta_wf_EventData und dta_wf_WorkFlowEvent protokolliert.

Nach Durchführung dieser Schritte werden für Nachrichten, die zwischen den BizTalk-Messagingdiensten und BizTalk-Orchestrierungsdiensten ausgetauscht werden, Datensätze in den Tabellen dta_wf_EventData und dta_wf_WorkFlowEvent protokolliert. Der in der dta_wf_EventData-Tabelle im Feld nvcName protokollierte Wert dient als Verknüpfung zwischen den Tabellen dta_wf_EventData und dta_wf_WorkFlowEvent und der dta_interchange_details-Tabelle, einer Haupttabelle in der Überwachungsdatenbank. Weitere Informationen zu den Haupttabellen finden Sie unter Struktur der Haupttabellen für Metadaten.

Von den BizTalk-Orchestrierungsdiensten an die BizTalk-Messagingdienste gesendete Nachrichten

Alle von den BizTalk-Orchestrierungsdiensten an die BizTalk-Messagingdienste mithilfe der BizTalk-Messaging-Portimplementierung im BizTalk-Orchestrierungs-Designer gesendeten Nachrichten werden von einem globalen eindeutigen Bezeichner (GUID) identifiziert, der Korrelationsbezeichner (correlationID) genannt wird. Wird eine Nachricht von den BizTalk-Orchestrierungsdiensten an die BizTalk-Messagingdienste gesendet, wird der Korrelationsbezeichner im Feld uidSubmissionGUID der dta_interchange_details-Tabelle protokolliert. Zusätzlich werden Datensätze in den Tabellen dta_wf_EventData und dta_wf_WorkFlowEvent protokolliert. Dadurch können Sie mithilfe der BizTalk-Dokumentüberwachung die Aktionsereignisse anzeigen, die zu Nachrichten gehören, die von einem XLANG-Ablaufplan verarbeitet wurden.

Von den BizTalk-Messagingdiensten an die BizTalk-Orchestrierungsdienste gesendete Dokumente

Alle an die BizTalk-Messagingdienste gesendeten Dokumente werden von einem globalen eindeutigen Bezeichner identifiziert, der Versendungshandle (SubmissionHandle) genannt wird. Weitere Informationen zum Versendungshandle finden Sie unter Submit Method. Wird das Dokument von den BizTalk-Messagingdiensten an die BizTalk-Orchestrierungsdienste gesendet, wird der Versendungshandle im Feld uidSubmissionGUID der dta_interchange_details-Tabelle aufgezeichnet. Darüber hinaus erfolgen beim Versenden eines Dokuments von den BizTalk-Messagingdiensten an die BizTalk-Orchestrierungsdienste die beiden folgenden Ereignisse:

  • Der Versendungshandle wird in die correlationID-Eigenschaft des Dokuments eingefügt, das an die BizTalk-Orchestrierungsdienste gesendet wird.

  • Datensätze werden in den Tabellen dta_wf_EventData und dta_wf_WorkFlowEvent protokolliert. Da das Dokument von den BizTalk-Messagingdiensten gesendet wurde, wird der Versendunghandle als Korrelationsbezeichner im Feld nvcName der dta_wf_EventData-Tabelle gespeichert.

Anzeigen von Aktionsereignissen

Sie müssen in der BizTalk-Dokumentüberwachung eine Abfrage erstellen und dann auf das Symbol XLANG-Ablaufplan klicken, um die BizTalk-Dokumentüberwachung zum Anzeigen von Aktionsereignissen zu verwenden, die zu Nachrichten gehören, welche von einem XLANG-Ablaufplan verarbeitet wurden. Weitere Informationen zum Erstellen von Abfragen und Anzeigen von XLANG-Ablaufplanereignissen finden Sie unter Verwenden von Abfragen zum Durchsuchen und Sortieren von Austausch- und Dokumentdaten.

Die dta_wf_EventData-Tabelle

Die folgende Tabelle enthält für jede Eigenschaft, die in Relation zu einem überwachten COM+-Ereignis protokolliert wird, das von einem XLANG-Ablaufplan generiert wird, einen Datensatz. Gruppen mehrerer Zeilen in dieser Tabelle haben einen gemeinsamen übergeordneten Datensatz in der dta_wf_WorkFlowEvent-Tabelle.

Feldname | Beschreibung
nEventDataId | Ganzzahliges Schlüsselfeld, das automatisch erhöht wird.
nWorkFlowEventId | Fremdschlüssel des übergeordneten Ereignisdatensatzes in dta_wf_EventData.
nvcName | Korrelationsbezeichner (correlationID).
nvcValue | Beliebiger Wert. Basiert in der Regel auf einem globalen eindeutigen Bezeichner (GUID).

Die dta_wf_WorkFlowEvent-Tabelle

Die folgende Tabelle ist die übergeordnete Tabelle der dta_wf_EventData-Tabelle und enthält für jedes überwachte COM+-Ereignis, das von einem XLANG-Ablaufplan generiert wird, einen Datensatz.

Feldname | Beschreibung
nWorkFlowEventId | Ganzzahliges Schlüsselfeld, das automatisch erhöht wird.
nvcEventId | Typ des Ereignisses.
nvcEventName | Name des Ereignisses.
nProcessId | Prozessbezeichner des auslösenden Ereignisses.
nvcApplicationId | XLANG-Ablaufplanbezeichner.
nvcInstanceId | Bezeichner der bestimmten Instanz des Ablaufplanes.
nEventTime | UTC-Zeit des Ereignisses in Sekunden seit 01.01.1970, 0:00 Uhr.
nEventSubTime | Zum ITime-Argument hinzugefügte Mikrosekunden für eine in Mikrosekunden aufzulösende Zeit.
nEventTick | Wert des hoch auflösenden Leistungsindikators bei Auslösung des Ereignisses.
nvcServerName | Server, auf dem das Ereignis entdeckt wurde.
dtDateEntered | Datum des Ereignisses.

Verwandte Themen

Integrieren der BizTalk-Dienste

Struktur der Haupttabellen für Metadaten

Submit Method

Grundlegendes zum integrierten XLANG-Ablaufplanstatus eines Austauschs


Grundlegendes zum Suchen von Austauschvorgängen und dazugehörigen Dokumenten

Mithilfe der BizTalk-Dokumentüberwachung können Sie unter Verwendung der von Ihnen angegebenen Abfrageparameter alle Austauschvorgänge und Dokumente anzeigen. Sie müssen mit Abfragen und deren Verwendung vertraut sein, um die Suchergebnisse zu optimieren und die Serverbelastung zu minimieren. Wenn Sie z. B. eine Abfrage mit sehr wenigen definierten Parametern erstellen, kann die Abfrage Tausende von Austauschdatensätzen zurückgeben. Dies ist sehr zeitaufwendig und belastet die Verarbeitungsleistung des Servers. Diese Situation wird noch verschlimmert, wenn mehrere Benutzer die Datenbank gleichzeitig abfragen.

BizTalk Server bietet zwei Abfragetypen: Abfragen und erweiterte Abfragen. Abfragen enthalten die gängigsten Kriterien, mit denen Abfrageergebnisse eingeengt werden. Erweiterte Abfragen ermöglichen eine Verfeinerung der Abfrageergebnisse, indem für die Suche nach bestimmten Daten Ausdrücke verwendet werden.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Grundlegendes zu Abfragen

  • Grundlegendes zu erweiterten Abfragen


Grundlegendes zu Abfragen

Die drei Standardabfrageparameter in der BizTalk-Dokumentüberwachung sind Zeitraum und Zeitzone, Quell- und Zielbezeichner und Dokumenttyp. Sie können nach Austausch- und Dokumentdatensätzen suchen, indem Sie in einer Abfrage eines oder mehrere dieser Kriterien angeben. Sie können z. B. alle Dokumenttypen in einem bestimmten Zeitraum suchen. Oder Sie können Austauschvorgänge und Dokumente suchen, die einen bestimmten Dokumenttyp aufweisen, und mit ausgewählten Quell- und Zielorganisationen übereinstimmen.

Zeitraum und Zeitzone

Die in der BizTalk-Dokumentüberwachung angegeben Datums- und Zeitinformationen geben die Uhrzeit an, an der das Dokument von BizTalk Server verarbeitet wurde. Wenn Sie für die Abfrage keinen Zeitraum angeben, umfasst der Standardzeitraum die letzten sieben Werktage. Im Gegensatz zu den Listen Quellauswahl, Zielauswahl oder Auswahl des Dokumenttyps dürfen Sie den Zeitraum nicht leer lassen, um datums- oder uhrzeitabhängig nach Dokumenten zu suchen. In der BizTalk-Dokumentüberwachung müssen Sie stets einen Datums- und Zeitbereich angeben.

Sie können angeben, ob Datum und Uhrzeit gemäß der Ortszeit oder der UTC-Zeit angezeigt werden sollen. In der Regel wird mithilfe der Ortszeit nach Austauschvorgängen und Dokumenten gesucht. Wenn Sie jedoch mit jemandem in einer anderen Zeitzone zusammenarbeiten und gemeinsame Kriterien für das Senden oder Empfangen eines Dokuments definieren müssen, verwenden Sie die UTC-Zeit.

Quell- und Zielorganisation

Sie können basierend auf der Quellorganisation, der Zielorganisation oder beiden nach Austauschvorgängen und Dokumenten suchen. Darüber hinaus können Sie im Rahmen einer Abfrage die Suche nach Dokumenten mit Filtern für eine, mehrere oder alle Organisationen festlegen. Sie können auch nach Austauschvorgängen und Dokumenten suchen, die aus einer Anwendung stammen, die einer Organisation zugeordnet ist. Wenn z. B. Quellorganisation A eine Tabellenkalkulationsanwendung verwendet, die Informationen an eine Datenbankanwendung in Zielorganisation B sendet, können Sie ermitteln, wann die Informationen gesendet und empfangen wurden.

Dokumenttyp

Sie können nach Austauschvorgängen und Dokumenten mit einem bestimmten Dokumenttyp suchen, wie z. B. Auftrag oder Rechnung. In einer Abfrage können Sie Dokumenttypkriterien mit Quell- und Zielbezeichnern kombinieren, um Austauschvorgänge und Dokumente zu suchen, die zwischen Ihnen und Ihren Handelspartnern gesendet und empfangen wurden. Diese Art von Abfrage kann Sie bei der Analyse der Geschäftsbeziehungen zwischen Ihnen und Ihren Handelspartnern unterstützen.

Sortiersteuerung

Es gibt sechs Sortiersteuerelemente, die ermitteln, in welcher Reihenfolge die Spalten auf der Seite Abfrageergebnisse sortiert werden. Die standardmäßige Sortierreihenfolge einer Abfrage ist wie folgt:

  • Quellorganisationsname. Der Name der Quellorganisation des Dokuments.

  • Quellanwendungsname. Der Name der Anwendung, aus der das Dokument stammt.

  • Zielorganisationsname. Der Name der Zielorganisation des Dokuments.

  • Zielanwendungsname. Der Name der Anwendung, an die das Dokument gesendet wird.

  • Dokumenttyp. Der Typ des Dokuments.

  • Verarbeitungszeitpunkt. Der Zeitpunkt, an dem das Dokument von BizTalk Server verarbeitet wurde.

Verwandtes Thema

Grundlegendes zu erweiterten Abfragen


Grundlegendes zu erweiterten Abfragen

Wenn Sie feststellen sollten, dass eine Abfrage zu viele Austausch- und Dokumentdatensätze zurückgibt, können Sie die Suche mithilfe von Abfrageausdrücken einengen. Im Dialogfeld Erweiterte Abfragen können Sie im Generator für erweiterte Abfragen einen neuen Abfrageausdruck erstellen oder eine Liste der Abfrageausdrücke durchsuchen, die Sie zuvor gespeichert haben. Ausdrücke sind SQL-Anweisungen, die durch die Erstellung bedingter Klauseln gebildet werden, welche zur Abfrage hinzugefügt werden. Mithilfe der folgenden Optionen können Sie eine erweiterte Abfrage erstellen:

  • Quellauswahl. Eine Liste der Felder, gemäß denen die Suche erfolgen soll. Wenn Sie im BizTalk-Messaging-Manager einen Kanal oder eine Dokumentdefinition für die Überwachung benutzerdefinierter Felder konfiguriert haben, werden diese Felder in der Liste Quellauswahl angezeigt. Wenn der BizTalk-Messaging-Manager nicht für die Überwachung von Feldern konfiguriert wurde, wird in der Liste Quellauswahl nur <Benutzerdefinierte Suche> angezeigt. Weitere Informationen zum Überwachen bestimmter Felder finden Sie unter Festlegen von Eigenschaften für die Dokumentprotokollierung und Auswählen von Spezifikationsfeldern in einem Kanal.

  • Operatoren. Eine Liste der verfügbaren Operatoren (z. B. >, <, =, enthält und enthält nicht).

  • Wert. Sie können in dieses Feld einen Wert eingeben, um den begrenzenden Wert für die erweiterte Abfrage anzugeben.

  • AND/OR. Eine Liste mit den Gruppierungsoperatoren (AND und OR), mit denen Suchbedingungen kombiniert werden.

  • Abfrage. Eine Liste der erstellten Abfragen.

  • Logische Gruppierung. Eine Beschreibung der kombinierten Suchbedingungen, die Sie mithilfe der Gruppierungsoperatoren AND und OR erstellt haben. Wenn Sie zu einer Abfrage Klauseln hinzufügen, werden Informationen zu Gruppierungsoperatoren im Feld Logische Gruppierung angezeigt. Das Feld Logische Gruppierung kann z. B. Folgendes enthalten:

    1 AND 2 AND (3 OR 4)

    In diesem Beispiel gelten die Bedingungen 1 und 2, und entweder Bedingung 3 oder 4 wird mit den Bedingungen 1 und 2 kombiniert.

Anmerkung

  • Sie können mehrere Abfragen mit demselben Namen erstellen.

Verwandtes Thema

Grundlegendes zu Abfragen


Grundlegendes zu Abfrageergebnissen

Auf der Seite Abfrageergebnisse werden Abfrageergebnisse in zwei Ebenen unterteilt: Austauschdatensätze und Dokumentdatensätze. Die höchste Organisationsebene bilden die Austauschdatensätze. Ein Austauschdatensatz steht für einen Austausch, der an BizTalk Server 2000 gesendet oder von BizTalk Server 2000 übertragen wurde. Austauschdatensätze sind die übergeordneten Datensätze von Dokumentinstanz-Datensätzen und dienen der nachvollziehbaren Strukturierung von Dokumentinstanz-Datensätzen. Weitere Informationen zu den Feldern eines Austauschdatensatzes finden Sie unter Grundlegendes zu den Ergebnissen von Austauschdatensätzen. Auf der Benutzeroberfläche werden Austauschdatensätze als Datenfeldzeilen mit einem Erweiterungssymbol am linken Ende jeder Zeile angezeigt.

Wenn Sie auf das Erweiterungssymbol klicken, werden die Dokumentinstanz-Datensätze angezeigt. Auf der Benutzeroberfläche werden Dokumentinstanz-Datensätze ebenfalls als Datenfeldzeilen angezeigt. In der Regel ist pro Austauschdatensatz ein Dokumentinstanz-Datensatz vorhanden. Wenn jedoch mehrere Dokumenttypen in einem einzelnen Austausch gesendet werden, gibt es für jeden in dem Austausch gesendeten Dokumenttyp einen Dokumentdatensatz. Weitere Informationen zu den Feldern in einem Dokumentinstanz-Datensatz finden Sie unter Grundlegendes zu Ergebnissen von Dokumentinstanz-Datensätzen.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Grundlagen des Überwachungsdatenbank-Schemas

  • Grundlegendes zu den Ergebnissen von Austauschdatensätzen

  • Grundlegendes zu Ergebnissen von Dokumentinstanz-Datensätzen

  • Grundlegendes zu den Ergebnissen von Empfangsbestätigungen

  • Grundlegendes zu den Ergebnissen misslungener Übertragungen


Grundlagen des Überwachungsdatenbank-Schemas

Sie müssen mit den Grundlagen des Schemas der Überwachungsdatenbank vertraut sein, um die auf der Seite Abfrageergebnisse angezeigten Informationen verstehen zu können. Die Überwachungsdatenbank enthält drei Haupttabellen, in denen Metadaten (wie z. B. Kennezeichen von Quell- und Zielorganisation, Datum, Uhrzeit und Dokumenttyp) für alle Austauschvorgänge und Dokumente gespeichert werden, die von BizTalk Server verarbeitet werden. Die Datenbanktabellen heißen:

  • dta_interchange_details

  • dta_indoc_details

  • dta_outdoc_details

dta_interchange_details

In der dta_interchange_details-Tabelle werden alle für Austauschvorgänge relevanten Daten gespeichert. Diese Tabelle ist die übergeordnete Tabelle der Tabellen dta_indoc_details table und dta_outdoc_details. Für jeden von BizTalk Server verarbeiteten Austausch wird in der Tabelle ein Datensatz gespeichert. Die Felder in den Austauschdatensätzen auf der Seite Abfrageergebnisse werden mit Daten dieser Tabelle aufgefüllt. Ein Feld in dieser Tabelle gibt an, ob der Austausch ein- oder ausgehend ist. Wenn Sie z. B. einen Austausch empfangen, wird dieser auf der Seite Abfrageergebnisse als eingehender Austauschdatensatz dargestellt. Wenn Sie dagegen einen Austausch senden, wird dieser auf der Seite Abfrageergebnisse als ausgehender Austauschdatensatz dargestellt Weitere Informationen zur dta_interchange_details-Tabelle finden Sie unter Haupttabellen für Metadaten und Struktur der Haupttabellen für Metadaten.

dta_indoc_details

Die dta_indoc_details-Tabelle speichert alle Daten für jedes Dokument, das an BizTalk Server gesendet wird. Diese Tabelle ist über einen Primärschlüssel mit der dta_interchange_details-Tabelle verknüpft. Die Felder in Dokumentinstanz-Datensätzen, die eingehenden Austauschdatensätzen auf der Seite Abfrageergebnisse zugeordnet sind, werden mit Daten dieser Tabelle aufgefüllt. Wenn Sie z. B. ein Dokument senden und auf der Seite Abfrageergebnisse die Überwachungsinformationen für dieses Dokument anzeigen möchten, müssen Sie zuerst den entsprechenden ausgehenden Austauschdatensatz bestimmen. Wenn Sie anschließend den Datensatz erweitern, wird der Dokumentinstanz-Datensatz angezeigt. Dieser Dokumentinstanz-Datensatz ist der dta_indoc_details-Tabelle zugeordnet und enthält Daten in den Feldern, die Sie für die Überwachung konfiguriert haben. Weitere Informationen zur dta_indoc_details-Tabelle finden Sie unter Haupttabellen für Metadaten und Struktur der Haupttabellen für Metadaten.

dta_outdoc_details

In der dta_outdoc_details-Tabelle werden alle Daten aller Dokument gespeichert, die von BizTalk Server generiert wurden. Die dta_outdoc_details-Tabelle kann für jeden Datensatz in der dta_indoc_details-Tabelle mehrere Datensätze enthalten, da bei einer einzelnen Versendung mehrere Dokumente generiert werden können. Ein an BizTalk Server übermitteltes Dokument kann z. B. an eine 10 Ports umfassende Verteilerliste gesendet werden. In diesem Fall werden in der dta_indoc_details-Tabelle ein und in der dta_outdoc_details-Tabelle 10 Datensätze protokolliert. Demzufolge wird auf der Seite Abfrageergebnisse ein ausgehender Austauschdatensatz mit einem zugeordneten Dokumentinstanz-Datensatz angezeigt. Die Felder im Dokumentinstanz-Datensatz werden mit Daten der dta_outdoc_details-Tabelle aufgefüllt. Weitere Informationen zur dta_outdoc_details-Tabelle finden Sie unter Haupttabellen für Metadaten und Struktur der Haupttabellen für Metadaten.

Verwandte Themen

Protokollieren von Austauschvorgängen und Dokumenten

Haupttabellen für Metadaten

Struktur der Haupttabellen für Metadaten

Grundlegendes zu Ergebnissen von Dokumentinstanz-Datensätzen

Grundlegendes zu den Ergebnissen von Austauschdatensätzen

Grundlegendes zu den Ergebnissen von Empfangsbestätigungen

Grundlegendes zu den Ergebnissen misslungener Übertragungen

Grundlegendes zum Schema der Überwachungsdatenbank


Grundlegendes zu den Ergebnissen von Austauschdatensätzen

Je nach angegebenen Abfrageparametern werden, falls Übereinstimmungen mit den Abfragekriterien gefunden werden, ein oder mehrere Austauschdatensätze angezeigt. Ein Austauschdatensatz repräsentiert einen Austausch, der an BizTalk Server 2000 gesendet oder von BizTalk Server 2000 übertragen wurde.

Ein Austauschdatensatz enthält die in der folgenden Tabelle gezeigten Informationen.

Spaltenüberschrift | Beschreibung
Daten | Eine Verknüpfung zur Anzeige des Austauschdatensatzes im systemeigenen Format.
Ablaufplan Eine Verknüpfung mit den Statusinformationen des XLANG-Ablaufplanes für den einzelnen Austausch, falls verfügbar. Wenn dem Austausch keine Statusinformationen für den XLANG-Ablaufplan zugeordnet sind, wird die folgende Meldung angezeigt:

Für diesen Austausch sind keine XLANG-Ablaufplaninformationen verfügbar.
Richtung | Gibt an, ob der Austausch an BizTalk Server gesendet (eingehend) oder von BizTalk Server übertragen (ausgehend) wird.
Fehler Gibt an, ob mit dem Dokument Fehler verbunden sind. Mögliche Fehlermeldungen sind:
  • Kein Fehler

  • Eine benutzerdefinierte Komponente konnte nicht aufgerufen werden

  • Der Austausch konnte nicht analysiert werden

  • Der angegebene Kanal ist nicht vorhanden

  • Der Austausch konnte nicht serialisiert werden

  • Der Austausch konnte nicht codiert werden

  • Der Austausch konnte nicht signiert werden

  • Der Austausch konnte nicht verschlüsselt werden

  • Fehler beim Übertragungsversuch (erneute Übertragung steht aus)

  • Fehler beim letzten Übertragungsversuch

  • Das Dokument konnte nicht analysiert werden

  • Das Dokument konnte nicht überprüft werden

  • Es konnte kein gültiger Kanal gefunden werden

  • Das Dokument konnte nicht zugeordnet werden

  • Es konnte kein gültiger Messagingport gefunden werden

  • Das Dokument konnte nicht serialisiert werden
Quellorganisation | Gibt den Namen der Quellorganisation an.
Quellanwendung | Gibt die Anwendungen an, aus der das Dokument stammt.
Zielorganisation | Gibt den Namen der Zielorganisation an.
Zielanwendung | Gibt die Zielanwendung für das Dokument an.
Dokumenttyp | Gibt den Typ des Dokuments an. Wenn ein Austausch mehr als einen Dokumenttyp enthält, wird in diesem Feld <MEHRERE> angezeigt.
Dokumentanzahl | Gibt die Anzahl der Dokumente in dem Austausch an.
Kontroll-ID | Gibt eine eindeutige Kontrollnummer für elektronische Datenaustauschvorgänge (EDI) oder einen Bezeichner für BizTalk Reliable Messages an.
Empfangsbestätigungsstatus | Gibt den Empfangsbestätigungsstatus an. Mögliche Werte sind: Keine, Ausstehend, Überfällig, Akzeptiert, Mit Fehlern akzeptiert und Abgelehnt.
Verarbeitungszeitpunkt | Gibt den Zeitpunkt der Verarbeitung des Austauschs an. Die Zeit wird festgelegt, wenn die Dokumentüberwachungs-Datensätze erstellt werden. Nachdem das Feld festgelegt wurde, wird es nicht aktualisiert.
Sendezeitpunkt | Gibt bei einer erfolgreichen Übertragung den Zeitpunkt an, an dem der Austausch gesendet wurde. Ist die Übertragung misslungen, ist der Wert Null. Bei eingehenden Übertragungen enthält das Feld stets den Wert Null.
Quell-ID-Qualifizierer | Gibt den Typ des Qualifizierers der Quellorganisation an. Dies ist der von BizTalk Server intern verwendete Qualifizierer.
Quellbezeichner | Gibt den Organisationskennzeichenwert der Quelle an. Dies ist der in den Daten angegebene Quellbezeichner, der zum Weiterleiten des Dokuments verwendet wird. Unterscheidet sich vom Quell-ID-Qualifizierer. Weitere Informationen zum Routing finden Sie unter Protokollieren von Routinginformationen.
Ziel-ID-Qualifizierer | Gibt den Typ des Qualifizierers der Zielorganisation an.
Zielbezeichner | Gibt den Organisationskennzeichenwert des Ziels an Weitere Informationen zum Routing finden Sie unter Protokollieren von Routinginformationen.

Verwandte Themen

Grundlagen des Überwachungsdatenbank-Schemas

Grundlegendes zu Ergebnissen von Dokumentinstanz-Datensätzen

Grundlegendes zum Suchen von Austauschvorgängen und dazugehörigen Dokumenten


Grundlegendes zu Ergebnissen von Dokumentinstanz-Datensätzen

Dokumentinstanz-Datensätze in einem Austausch werden als Zeilen mit Feldern angezeigt, welche die Dokumentinformationen beschreiben.

Die Ergebnisse eines Dokumentinstanz-Datensatzes enthalten die in der folgenden Tabelle gezeigten Informationen.

Spaltenüberschrift | Beschreibung
Daten | Eine Verknüpfung zum Anzeigen der Daten in der Dokumentinstanz im systemeigenen Format und im XML-Format.
Überwachungs-ID | Ein Überwachungsschlüssel, der auf einem globalen eindeutigen Bezeichner (GUID) basiert.
Dokumenttyp | Gibt den Dokumenttyp an. Wenn ein Austausch mehrere Dokument enthält, gibt dieses Feld den Dokumenttyp an. Dieses Feld enthält stets nur einen Dokumenttyp. Weitere Dokumenttypen werden als getrennte Dokumentinstanz-Datensätze angezeigt.
Kompatibilität | Gibt an, ob das Dokument gültig ist. Mögliche Werte sind Gültig und Ungültig.
Fehler Gibt an, ob mit dem Dokument Fehler verbunden sind. Mögliche Fehlermeldungen sind:
  • Kein Fehler.

  • Eine benutzerdefinierte Komponente konnte nicht aufgerufen werden.

  • Der angegebene Kanal ist nicht vorhanden.

  • Fehler beim Übertragungsversuch (erneute Übertragung steht aus).

  • Fehler beim letzten Übertragungsversuch.

  • Das Dokument konnte nicht analysiert werden.

  • Das Dokument konnte nicht überprüft werden.

  • Es konnte kein gültiger Kanal gefunden werden.

  • Das Dokument konnte nicht zugeordnet werden.

  • Es konnte kein gültiger Messagingport gefunden werden.

  • Das Dokument konnte nicht serialisiert werden.
Empfangsbestätigung | Bietet eine Verknüpfung mit Informationen zur Empfangsbestätigung.

Die folgenden Felder gelten nur für ausgehende Dokumente.

Empfangsbestätigungsstatus | Gibt den Empfangsbestätigungsstatus an. Mögliche Werte sind: Keine, Ausstehend, Überfällig, Akzeptiert, Mit Fehlern akzeptiert und Abgelehnt.
Real 1, Real 2 | Gibt die Daten an, die im Inhalt des Dokuments als reelle Zahlen erfasst wurden. Es gibt zwei Felder, die reelle Zahlen enthalten können.
Integer 1, Integer 2 | Gibt Daten an, die im Inhalt des Dokuments als ganzzahliger Wert erfasst wurden. Es gibt zwei Felder, die ganze Zahlen enthalten können.
Date 1, Date 2 | Gibt Daten an, die im Inhalt des Dokuments als Datumswert erfasst wurden. Es gibt zwei Felder, die Datumsangaben enthalten können.
String 1, String 2 | Gibt Daten an, die im Inhalt des Dokuments als Zeichenfolgenwert erfasst wurden. Es gibt zwei Felder, die Zeichenfolgen enthalten können.
Benutzerdefinierte Suche | Gibt weitere Daten an, die als ein Zeichenfolgenwert erfasst wurden. Dieses Feld ist auf 2 GB begrenzt.

Anmerkungen

  • Weitere Informationen zu den Informationen, die in ausgehenden Dokumenten überwacht werden sollen, finden Sie unter Auswählen von Spezifikationsfeldern in einer Dokumentdefinition und Auswählen von Spezifikationsfeldern in einem Kanal.

  • Wenn Sie in der Dokumentdefinition Felder (wie z. B. die Felder Integer, Real, String, Date oder benutzerdefinierte Felder) als optional und für die Überwachung konfigurieren und diese Felder nicht in der versendeten Dokumentinstanz vorhanden sind, werden die Felder nicht in den Abfrageergebnissen angezeigt. Die BizTalk-Dokumentüberwachung generiert keine Fehler- oder Warnmeldung, die Sie über das Fehlen von Daten in optionalen Feldern informiert.

  • In einer Dokumentinstanz wird eine 1 als -1 überwacht, wenn die folgenden Bedingungen erfüllt sind:
    • Der Datentyp wurde bei der Deklaration von Eigenschaften eines bestimmten Feldes im BizTalk-Editor auf Boolean festgelegt.

    • Das Feld wurde im BizTalk-Messaging-Konfigurationsobjektmodell bzw. im BizTalk-Messaging-Manager für die Überwachung als Integer ausgewählt.

Verwandte Themen

Auswählen von Spezifikationsfeldern in einem Kanal

Auswählen von Spezifikationsfeldern in einer Dokumentdefinition

Grundlagen des Überwachungsdatenbank-Schemas

Grundlegendes zum Suchen von Austauschvorgängen und dazugehörigen Dokumenten

Grundlegendes zu den Ergebnissen von Austauschdatensätzen


Grundlegendes zu den Ergebnissen von Empfangsbestätigungen

Die folgende Abbildung veranschaulicht den Ablauf von Empfangsbestätigungen in der BizTalk-Dokumentüberwachung. In der Abbildung wird Dokument 1 zuerst von BizTalk Server A verarbeitet und ist für die Erwartung einer Empfangsbestätigung gekennzeichnet (Dokument 1 mit festgelegtem Kennzeichen Erwartete Empfangsbestätigung). Anschließend nimmt BizTalk Server B das Dokument über eine Empfangsfunktion entgegen (Dokument 1 mit festgelegtem Kennzeichen Empfangsbestätigung generieren), verarbeitet das Dokument und generiert eine Empfangsbestätigung [Empfangsbestätigung für Dokument 1 (Ausgehend)]. BizTalk Server A erhält dann die Empfangsbestätigung [Empfangsbestätigung für Dokument 1 (Eingehend)]

Ablauf der Empfangsbestätigungen

Ablauf der Empfangsbestätigung
BizTalk-
Server A
Empfangs-
bestätigung für
Dokument 1
(Eingehend)
Empfangs-
bestätigung für
Dokument 1
(Ausgehend)
Empfangsbest.
generieren
(festg. Kennz.)
Erwartete
Empfangsbest.
(festg. Kennz.)
Dokument 1
Dokument 1
Dokument 1
BizTalk-
Server B
Empfangsfunktion

Wenn Sie die Empfangsbestätigung für Dokument 1 mit festgelegtem Kennzeichen Erwartete Empfangsbestätigung anzeigen, suchen Sie zuerst auf der Seite Abfrageergebnisse den Austauschdatensatz, der Dokument 1 mit festgelegtem Kennzeichen Erwartete Empfangsbestätigung entspricht. Klicken Sie im Empfangsbestätigungsfeld auf das Symbol Empfangsbestätigung. Dadurch wird eine neue Seite Abfrageergebnisse mit dem Austauschdatensatz angezeigt, den BizTalk Server A beim Verarbeiten von Dokument 1 mit festgelegtem Kennzeichen Erwartete Empfangsbestätigung generiert hat. Klicken Sie in der Spalte Daten auf das Symbol Daten. Die angezeigten Daten stellen den tatsächlichen Inhalt der Empfangsbestätigung dar. In der obigen Abbildung entspricht der letzte Schritt Empfangsbestätigung für Dokument 1 (Eingehend).

Wenn Sie die Empfangsbestätigung für Dokument 1 mit festgelegtem Kennzeichen Empfangsbestätigung generieren anzeigen, müssen Sie zuerst auf der Seite Abfrageergebnisse den Austauschdatensatz suchen, der Dokument 1 mit festgelegtem Kennzeichen Empfangsbestätigung generieren entspricht. Klicken Sie im Empfangsbestätigungsfeld auf das Symbol Empfangsbestätigung. Dadurch wird eine neue Seite Abfrageergebnisse mit dem Austauschdatensatz angezeigt, den BizTalk Server B beim Verarbeiten von Dokument 1 mit festgelegtem Kennzeichen Empfangsbestätigung generieren generiert hat. Erweitern Sie den Austauschdatensatz, um die Dokumentinstanzdetails anzuzeigen, und klicken Sie im Feld Daten auf das Symbol Daten. Die angezeigten Daten stellen den tatsächlichen Inhalt der Empfangsbestätigung dar. In der obigen Abbildung entspricht der letzte Schritt Empfangsbestätigung für Dokument 1 (Ausgehend).

Anmerkungen

  • Das Senden und Empfangen von Empfangsbestätigungen funktioniert nur mit Parsern, die Empfangsbestätigungen verarbeiten können. Weitere Informationen zu Empfangsbestätigungen finden Sie unter Grundlegendes zu Empfangsbestätigungen.

  • Auf der Benutzeroberfläche der BizTalk-Dokumentüberwachung werden keine Reliable Messaging-Bestätigungen angezeigt.

Verwandte Themen

Protokollieren von Empfangsbestätigungen

Grundlagen des Überwachungsdatenbank-Schemas


Grundlegendes zu den Ergebnissen misslungener Übertragungen

Misslingt eine Übertragung, wird dieses Ereignis in der Überwachungsdatenbank protokolliert. Es werden jedoch nicht alle Fehler, die in der Überwachungsdatenbank protokolliert werden, auf der Benutzeroberfläche der BizTalk-Dokumentüberwachung angezeigt. Fehler werden nur dann auf der Benutzeroberfläche angezeigt, wenn ein Datensatz in der dta_outdoc_details-Tabelle protokolliert wurde. Weitere Informationen zu den Haupttabellen finden Sie unter Grundlagen des Überwachungsdatenbank-Schemas und Haupttabellen für Metadaten.

Die folgende Tabelle zeigt mögliche Fehlermeldungen und ob Datensätze in den verschiedenen Haupttabellen der Überwachungsdatenbank protokolliert werden.

Fehlermeldung | Protokollierung von Datensätzen in | Kommentar
Kein Fehler | dta_indoc_details dta_interchange_details (incoming) dta_interchange_details (outgoing) dta_outdoc_details | Die entsprechenden Felder werden in den drei Haupttabellen protokolliert.
Eine benutzerdefinierte Komponente konnte nicht aufgerufen werden. |  | Diese Fehlermeldung wird nur dann angezeigt, wenn Sie einer Empfangsfunktion einen benutzerdefinierten Präprozessor zugeordnet haben. In der Überwachungsdatenbank werden keine Datensätze protokolliert.
Der Austausch konnte nicht analysiert werden. | dta_interchange_details (incoming) | Bei einem Analysefehler werden der Austausch und die Daten protokolliert.
Der angegebene Kanal ist nicht vorhanden. | dta_indoc_details dta_interchange_details (incoming) |
Der Austausch konnte nicht serialisiert werden. | dta_indoc_details dta_interchange_details (incoming) dta_interchange_details (outgoing) dta_outdoc_details | In der dta_interchange_details (outgoing)-Tabelle wird ein leerer Datensatz protokolliert. Wenn der Austausch erneut und mit Erfolg gesendet wird, erfolgt eine Aktualisierung des Datensatzes.
Der Austausch konnte nicht codiert werden. | dta_indoc_details dta_interchange_details (incoming) dta_interchange_details (outgoing) dta_outdoc_details |
Der Austausch konnte nicht signiert werden. | dta_indoc_details dta_interchange_details (incoming) dta_interchange_details (outgoing) dta_outdoc_details |
Der Austausch konnte nicht verschlüsselt werden. | dta_indoc_details dta_interchange_details (incoming) dta_interchange_details (outgoing) dta_outdoc_details |
Fehler beim Übertragungsversuch (erneute Übertragung steht aus). | dta_indoc_details dta_interchange_details (incoming) dta_interchange_details (outgoing) dta_outdoc_details |
Fehler beim letzten Übertragungsversuch. | dta_indoc_details dta_interchange_details (incoming) dta_interchange_details (outgoing) dta_outdoc_details |
Das Dokument konnte nicht analysiert werden. | dta_indoc_details dta_interchange_details (incoming) |
Das Dokument konnte nicht überprüft werden. | dta_indoc_details dta_interchange_details (incoming) |
Es konnte kein gültiger Kanal gefunden werden. | dta_indoc_details dta_interchange_details (incoming) |
Das Dokument konnte nicht zugeordnet werden. | dta_indoc_details dta_interchange_details (incoming) dta_interchange_details (outgoing) dta_outdoc_details | Der Datensatz in der dta_outdoc_details-Tabelle zeichnet den Protokollierfehler auf, und in der dta_interchange_details (outgoing)-Tabelle wird ein leerer Datensatz protokolliert.
Es konnte kein gültiger Messagingport gefunden werden. | dta_indoc_details dta_interchange_details (incoming) dta_interchange_details (outgoing) dta_outdoc_details | Der Datensatz in der dta_outdoc_details-Tabelle zeichnet einen NoPort-Fehler auf, und in der dta_interchange_details (outgoing)-Tabelle wird ein leerer Datensatz protokolliert.
Das Dokument konnte nicht serialisiert werden. | dta_indoc_details dta_interchange_details (incoming) dta_interchange_details (outgoing) dta_outdoc_details | Datensätze in den Tabellen dta_indoc_details und dta_outdoc_details enthalten den Serialisierungsfehler.

Verwandte Themen

Konfigurieren von Überwachungseigenschaften für eine Servergruppe

Angehalten-Warteschlange

Grundlagen des Überwachungsdatenbank-Schemas

Grundlegendes zum Schema der Überwachungsdatenbank


Grundlegendes zum integrierten XLANG-Ablaufplanstatus eines Austauschs

Sie können den Status zusammengehörender XLANG-Ablaufpläne in der BizTalk-Dokumentüberwachung überwachen. Aktionen in den Ablaufplänen auf einem Server können überwacht und in den entsprechenden Tabellen in der Überwachungsdatenbank mit einem Bezeichner gespeichert werden, der diese in Beziehung zu bestimmten Nachrichteninstanzen setzt. Das Speicherschema der Überwachungsdatenbank und die Korrelation sind Teil von Microsoft BizTalk Server 2000, doch ist die Ereignisabonnementfunktion nach der Installation von BizTalk Server 2000 nicht implementiert. Dafür steht eine Beispiel für die Ausführung der Überwachungsintegration zur Verfügung. Nach der Installation von BizTalk Server 2000 können Sie den Quellcode für dieses Beispiel im Ordner \Programme\Microsoft BizTalk Server\SDK\XLANG Samples\WorkFlowAudit finden. Darüber hinaus enthält der Unterordner Bin die DDL-Datei (WorkFlowAudit.dll) für dieses Beispiel. Die dazugehörige Dokumentation finden Sie im Unterordner Docs in der Datei Readme.txt. Eine Beispielclientanwendung finden Sie in \Programme\Microsoft BizTalk Server\SDK\XLANG Samples\WorkFlowAuditClient.


Problembehandlung - BizTalk-Dokumentüberwachung

Dieser Abschnitt stellt allgemeine Informationen zur Problembehandlung in der BizTalk-Dokumentüberwachung bereit.

  • Probleme beim Anzeigen der Benutzeroberfläche der BizTalk-Dokumentüberwachung

  • Austauschvorgänge und Dokumente werden nicht gespeichert

  • Die Abfrageergebnisse sind leer

  • In den Abfrageergebnissen werden keine Überwachungsfelder angezeigt

  • Zu viele Suchargumente


Probleme beim Anzeigen der Benutzeroberfläche der BizTalk-Dokumentüberwachung

Ursache: Microsoft Office Web-Komponenten sind nicht installiert.

Lösung: Installieren Sie Microsoft Office Web-Komponenten.

  1. Klicken Sie auf Start, zeigen Sie auf Einstellungen, und klicken Sie dann auf Systemsteuerung.

  2. Doppelklicken Sie auf Software.

    Das Dialogfeld Software wird angezeigt.

  3. Klicken Sie auf Microsoft Office 2000 SR-1 Premium.

  4. Klicken Sie auf Ändern.

  5. Klicken Sie auf Features hinzufügen/entfernen.

  6. Klicken Sie auf das Erweiterungssymbol (+) neben Office Tools.

  7. Klicken Sie auf Office Web-Komponenten und dann auf die für Ihre Installation geeignete Option.

  8. Klicken Sie auf Jetzt aktualisieren.


Austauschvorgänge und Dokumente werden nicht gespeichert

Ursache: In der BizTalk Server-Verwaltung ist die Überwachung deaktiviert.

Lösung: Aktivieren Sie die Überwachung in der BizTalk Server-Verwaltung.

  1. Klicken Sie auf Start, zeigen Sie auf Programme, dann auf Microsoft BizTalk Server 2000, und klicken Sie anschließend auf BizTalk Server-Verwaltung.

  2. Erweitern Sie Microsoft BizTalk Server 2000, und klicken Sie auf die Servergruppe, deren Dokumente nicht gespeichert werden.

  3. Klicken Sie im Menü Aktion auf Eigenschaften.

    Das Dialogfeld Eigenschaften von BizTalk Server-Gruppe wird angezeigt.

  4. Klicken Sie auf die Registerkarte Überwachen.

  5. Aktivieren Sie das Kontrollkästchen Dokumentüberwachung aktivieren.

  6. Wählen Sie eine oder mehrere der folgenden Optionen aus:
    • Eingehenden Austausch protokollieren

    • Ausgehenden Austausch protokollieren

    • Ursprüngliche MIME-codierte Nachricht protokollieren
  7. Klicken Sie auf OK.

Verwandtes Thema

Konfigurieren von Überwachungseigenschaften für eine Servergruppe


Die Abfrageergebnisse sind leer

Ursache 1: Der Datums- und Zeitraum ist falsch.

Lösung: Überprüfen Sie, ob der Datums- und Zeitraum richtig ist. Wenn Sie z. B. ein Dokument in den vergangenen 5 Minuten gesendet haben und der Zeitbereich auf die Suche nach Dokumenten ab den vergangenen 10 Minuten oder mehr festgelegt ist, wird das Dokument nicht in den Abfrageergebnissen angezeigt.

Ursache 2: Die Daten wurden gegebenenfalls aus der Datenbank entfernt.

Lösung: Wenden Sie sich an den Datenbankadministrator.

Verwandtes Thema

Datumsabhängiges Suchen nach Austausch- und Dokumentinformationen


In den Abfrageergebnissen werden keine Überwachungsfelder angezeigt

Ursache: BizTalk Server konnte die Daten nicht konvertieren, oder es liegt ein arithmetischer Überlauffehler vor.

Lösung: Suchen Sie im Ereignisprotokoll die folgende Fehlermeldung:

<<Pfad und Dateiname>>: Das folgende Überwachungsfeld für Versendung <<globaler eindeutiger Bezeichner>> konnte nicht protokolliert werden:

Überwachungsfeld: <<Name des Feldes>>

Spezifikationsfeldname: <<Name des Spezifikationsfeldes>>/DTADataTypeTest/String/@_String

Tatsächlicher Wert: <<Tatsächlicher Wert des Feldes>>

Überprüfen und korrigieren Sie die Überwachungsfeldeinstellungen in der Dokument- oder Kanalkonfiguration.

Verwandte Themen

Auswählen von Spezifikationsfeldern in einem Kanal

Festlegen von Eigenschaften für die Dokumentprotokollierung


Zu viele Suchargumente

Ursache: Sie haben in den Listen Quellauswahl und/oder Zielauswahl zu viele Optionen angegeben.

Lösung: Geben Sie die Abfrage so genau wie möglich an. Senken Sie in den Listen Quellauswahl und/oder Zielauswahl die Anzahl der ausgewählten Optionen, und klicken Sie auf Abfrage.

Verwandtes Thema

Verwenden von Abfragen zum Durchsuchen und Sortieren von Austausch- und Dokumentdaten


BizTalk Server2000-Anwendungsentwicklung

BizTalk Server-Kopfzeile

BizTalk Server 2000-Anwendungsentwicklung

BizTalk Server 2000 stellt Tools und Dienste bereit, mit denen Sie ausführbare Anwendungen zum Steuern von Geschäftsprozessen und zum Austausch von Daten zwischen Handelspartnern und Anwendungen innerhalb eines Unternehmens erstellen können.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Entwerfen von BizTalk-Orchestrierungen

  • Konfigurieren der BizTalk-Messagingdienste

  • Erstellen von Spezifikationen und Zuordnen von Daten

  • Integrieren der BizTalk-Dienste


Entwerfen von BizTalk-Orchestrierungen

Der BizTalk-Orchestrierungs-Designer ist ein auf Microsoft Visio 2000 basierendes Entwurfsprogramm, mit dem Sie Geschäftsprozesszeichnungen erstellen können, die als XLANG-Ablaufpläne kompiliert und ausgeführt werden können. XLANG ist eine auf XML basierende Sprache. Ein XLANG-Ablaufplan beschreibt den Geschäftsprozess und die Anbindung des Prozesses an die Anwendungsdienste.

Mithilfe des BizTalk-Orchestrierungs-Designers können Sie Zeichnungen erstellen, die lang dauernde, lose gekoppelte, ausführbare Geschäftsprozesse abbilden. In diesen Zeichnungen werden in der Regel die im Verlauf des angegebenen Prozesses, z. B. einer Auftragsanforderung, durchgeführten Interaktionen und Verfahren beschrieben. Häufig werden diese Geschäftsprozesse nicht durch Zeitbeschränkungen eingeschränkt. Ferner sind die Schritte innerhalb eines Geschäftsprozesses lose gekoppelt. Die Beschreibung des Geschäftsprozesses erfolgt getrennt von der Implementierungslogik und -abfolge bei der Ausführung des Prozesses.

Hilfe zu bestimmten Aufgaben finden Sie unter Verfahrensweise.

Allgemeine Hintergrundinformationen finden Sie unter Grundbegriffe.


Verfahrensweise

Dieser Abschnitt stellt aufgabenspezifische Informationen zum Erstellen von XLANG-Ablaufplanzeichnungen und zum Kompilieren dieser XLANG-Ablaufplanzeichnungen in ausführbare XLANG-Ablaufpläne mithilfe des BizTalk-Orchestrierungs-Designers bereit. Dieser Abschnitt stellt außerdem Informationen zur Vorgehensweise beim Ausführen eines XLANG-Ablaufplanes bereit. Es wird dringend empfohlen, dass Sie den Abschnitt Grundbegriffe lesen, um alle Features und Fähigkeiten des BizTalk-Orchestrierungs-Designers vollständig zu verstehen.

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Verwenden des BizTalk-Orchestrierungs-Designers

  • Ausführung von XLANG-Ablaufplänen


Verwenden des BizTalk-Orchestrierungs-Designers

Dieser Abschnitt enthält Verfahrensbeschreibungen, die erläutern, wie Sie mithilfe des BizTalk-Orchestrierungs-Designers neue XLANG-Ablaufplanzeichnungen entwerfen und diese in ausführbare XLANG-Ablaufpläne kompilieren.

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Öffnen und Speichern von XLANG-Ablaufplanzeichnungen

  • Anzeigen von Entwurfseiten, Formen und Schablonen

  • Hinzufügen, Löschen und Verbinden von Formen

  • Festlegen von Bedingungseigenschaften

  • Festlegen von Parallelitätseigenschaften

  • Festlegen von Transaktionseigenschaften

  • Festlegen von Fehlerbehandlungseigenschaften

  • Implementieren von Ports

  • Senden oder Empfangen von Nachrichten

  • Festlegen des Datenflusses zwischen Nachrichten


Öffnen und Speichern von XLANG-Ablaufplanzeichnungen

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Erstellen einer neuen XLANG-Ablaufplanzeichnung

  • Öffnen einer vorhandenen XLANG-Ablaufplanzeichnung

  • Speichern einer XLANG-Ablaufplanzeichnung


Erstellen einer neuen XLANG-Ablaufplanzeichnung

  • Klicken Sie im BizTalk-Orchestrierungs-Designer im Menü Datei auf Neu.

Anmerkungen

  • Dieses Verfahren öffnet eine neue XLANG-Ablaufplanzeichnung im Entwurfsfenster. Die Seite Geschäftprozess ist die standardmäßig zuerst angezeigte Entwurfsseite. Die Schablonen Flussdiagramm und Implementierung werden beim Start einer neuen Zeichnung ebenfalls standardmäßig geöffnet.

  • Die Dateinamenerweiterung für eine XLANG-Ablaufplanzeichnung lautet SKV.

Verwandte Themen

Öffnen einer vorhandenen XLANG-Ablaufplanzeichnung

Speichern einer XLANG-Ablaufplanzeichnung


Öffnen einer vorhandenen XLANG-Ablaufplanzeichnung

  1. Klicken Sie im BizTalk-Orchestrierungs-Designer im Menü Datei auf Öffnen.

    Das Dialogfeld XLANG-Ablaufplanzeichnung öffnen wird angezeigt.

  2. Suchen Sie nach der XLANG-Ablaufplanzeichnung, die Sie öffnen möchten, klicken Sie auf die Zeichnung und anschließend auf Öffnen.

Anmerkungen

  • Die Dateinamenerweiterung für eine XLANG-Ablaufplanzeichnung lautet SKV.

  • Die Dateinamenerweiterung für einen XLANG-Ablaufplan lautet SKX. Eine SKX-Datei kann nicht im BizTalk-Orchestrierungs-Designer geöffnet werden. Um eine SKX-Datei zu ändern oder zu aktualisieren, öffnen Sie die Quelldatei (SKV-Datei), nehmen die gewünschten Änderungen daran vor und kompilieren anschließend die SKV-Datei in eine SKX-Datei.

Verwandte Themen

Erstellen einer neuen XLANG-Ablaufplanzeichnung

Speichern einer XLANG-Ablaufplanzeichnung


Speichern einer XLANG-Ablaufplanzeichnung

  • Klicken Sie im BizTalk-Orchestrierungs-Designer im Menü Datei auf Speichern.

Anmerkungen

  • Wenn Sie eine XLANG-Ablaufplanzeichnung speichern, wird die Zeichnung unter dem Standarddateinamen ZeichnungX.skv abgelegt, wobei X eine Zahl darstellt, die an den Namen der Zeichnung angehängt wird. Der Name der Datei kann beim Speichern der Zeichnung geändert werden.

  • Sie können auch im Menü Datei auf Speichern unter klicken. Dieser Befehl öffnet das Dialogfeld XLANG-Ablaufplanzeichnung speichern unter. Folgende Aktionen sind möglich:
    • Umbenennen der Datei.

    • Speichern der Datei unter einem anderen Pfad.
  • Die Dateinamenerweiterung für eine XLANG-Ablaufplanzeichnung lautet SKV.

  • Die Dateinamenerweiterung für einen XLANG-Ablaufplan lautet SKX. Eine SKX-Datei kann nicht im BizTalk-Orchestrierungs-Designer geöffnet werden. Um eine SKX-Datei zu ändern oder zu aktualisieren, öffnen Sie die Quelldatei (SKV-Datei), nehmen die gewünschten Änderungen daran vor und kompilieren anschließend die SKV-Datei in eine SKX-Datei.

Verwandte Themen

Erstellen einer neuen XLANG-Ablaufplanzeichnung

Öffnen einer vorhandenen XLANG-Ablaufplanzeichnung


Anzeigen von Entwurfseiten, Formen und Schablonen

Der BizTalk-Orchestrierungs-Designer stellt mehrere Anzeigeoptionen bereit, mit deren Hilfe Sie die Zeichenfläche maximieren oder spezielle Formen oder Datenrelationen anzeigen können.

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Anzeigen der Entwurfsseiten

  • Anzeigen von Formen

  • Anzeigen von Schablonen

  • Verwenden mehrerer Fenster

  • Verwenden von Anmerkungen

  • Anzeigen einer Seitenvorschau, Drucken oder Größenanpassung von XLANG-Ablaufplanzeichnungen


Anzeigen der Entwurfsseiten

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Anzeigen der Seite "Geschäftprozess"

  • Anzeigen der Seite "Daten"

  • Anzeigen der Geschäftsprozess- und Datenseiten

  • Anzeigen der Seiten "Kompensierung für Transaktion"

  • Anzeigen der Seiten "Bei Fehler von Transaktion"

  • Anzeigen einer Seite

Verwandte Themen

Verwenden mehrerer Fenster

Anzeigen von Formen

Anzeigen von Schablonen


Anzeigen der Seite "Geschäftprozess"

  • Klicken Sie im Menü Ansicht auf Geschäftsprozessseite.

Anmerkung

  • Sie können auch auf die Registerkarte Geschäftsprozess klicken, die sich am unteren Rand der Entwurfsseiten befindet.

Verwandte Themen

Verwenden mehrerer Fenster

Anzeigen einer Seite

Anzeigen der Seiten "Kompensierung für Transaktion"

Anzeigen der Seiten "Bei Fehler von Transaktion"

Anzeigen von Formen

Anzeigen von Schablonen

Anzeigen der Geschäftsprozess- und Datenseiten

Anzeigen der Seite "Daten"


Anzeigen der Seite "Daten"

  • Klicken Sie im Menü Ansicht auf Datenseite.

Anmerkung

  • Sie können auch auf die Registerkarte Daten klicken, die sich am unteren Rand der Entwurfsseiten befindet.

Verwandte Themen

Verwenden mehrerer Fenster

Anzeigen einer Seite

Anzeigen der Seiten "Kompensierung für Transaktion"

Anzeigen der Seiten "Bei Fehler von Transaktion"

Anzeigen von Formen

Anzeigen von Schablonen

Anzeigen der Geschäftsprozess- und Datenseiten

Anzeigen der Seite "Geschäftprozess"


Anzeigen der Geschäftsprozess- und Datenseiten

  • Klicken Sie im Menü Ansicht auf Geschäftsprozess- und Datenseiten.

Anmerkung

  • Diese Anzeigeoption öffnet zwei Fenster für ein und denselben XLANG-Ablaufplan: ein Fenster Geschäftsprozess und ein Fenster Daten. Diese Funktion ähnelt der Funktion, die mithilfe des Befehls Neues Fenster zur Verfügung steht. Weitere Informationen zum Öffnen mehrerer Fenster finden Sie unter Verwenden mehrerer Fenster.

Verwandte Themen

Verwenden mehrerer Fenster

Anzeigen einer Seite

Anzeigen der Seiten "Kompensierung für Transaktion"

Anzeigen der Seiten "Bei Fehler von Transaktion"

Anzeigen von Formen

Anzeigen von Schablonen

Anzeigen der Seite "Geschäftprozess"

Anzeigen der Seite "Daten"


Anzeigen der Seiten "Kompensierung für Transaktion"

  • Klicken Sie am unteren Rand der Entwurfsseiten auf die Registerkarte Kompensierung für Transaktion der Seite, die Sie anzeigen möchten.

Anmerkungen

  • Der Platzhalter Transaktion im Namen der Seite wird ersetzt durch den Namen der Transaktion, mit der der Fehlerbehandlungsprozess verknüpft ist.

  • Informationen zur Vorgehensweise beim Hinzufügen einer Seite Kompensierung für Transaktion zu einer XLANG-Ablaufplanzeichnung finden Sie unter Aktivieren der Kompensierung für-Fehlerbehandlung.

Verwandte Themen

Verwenden mehrerer Fenster

Anzeigen einer Seite

Anzeigen der Seiten "Bei Fehler von Transaktion"

Anzeigen von Formen

Anzeigen von Schablonen

Anzeigen der Geschäftsprozess- und Datenseiten

Anzeigen der Seite "Geschäftprozess"

Anzeigen der Seite "Daten"


Anzeigen der Seiten "Bei Fehler von Transaktion"

  • Klicken Sie am unteren Rand der Entwurfsseiten auf die Registerkarte Bei Fehler von Transaktion der Seite, die Sie anzeigen möchten.

Anmerkung

  • Der Platzhalter Transaktion im Namen der Seite wird ersetzt durch den Namen der Transaktion, mit der der Fehlerbehandlungsprozess verknüpft ist.

  • Informationen zur Vorgehensweise beim Hinzufügen einer Seite Bei Fehler von Transaktion zu einer XLANG-Ablaufplanzeichnung finden Sie unter Aktivieren der Bei Fehler von-Fehlerbehandlung.

Verwandte Themen

Verwenden mehrerer Fenster

Anzeigen einer Seite

Anzeigen der Seiten "Kompensierung für Transaktion"

Anzeigen von Formen

Anzeigen von Schablonen

Anzeigen der Geschäftsprozess- und Datenseiten

Anzeigen der Seite "Geschäftprozess"

Anzeigen der Seite "Daten"


Anzeigen einer Seite

  • Klicken Sie auf die Registerkarte für die Seite, die Sie anzeigen möchten.

Anmerkung

  • Die Registerkarten für die einzelnen Seiten befinden sich am unteren Rand der Entwurfsseiten.

Verwandte Themen

Verwenden mehrerer Fenster

Anzeigen der Seiten "Kompensierung für Transaktion"

Anzeigen der Seiten "Bei Fehler von Transaktion"

Anzeigen von Formen

Anzeigen von Schablonen

Anzeigen der Geschäftsprozess- und Datenseiten

Anzeigen der Seite "Geschäftprozess"

Anzeigen der Seite "Daten"


Anzeigen von Formen

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Anzeigen von Flussdiagrammformen

  • Anzeigen von Flussdiagramm- und Kommunikationsformen

  • Anzeigen von Flussdiagramm-, Kommunikations- und Implementierungsformen

Verwandte Themen

Anzeigen von Schablonen

Anzeigen der Entwurfsseiten


Anzeigen von Flussdiagrammformen

  • Klicken Sie im Menü Ansicht auf Flussdiagrammformen.

Anmerkungen

  • Bei Verwendung dieser Option werden auf der Entwurfsseite nur Flussdiagrammformen und die Verbindungen zwischen ihnen angezeigt. Diese Option blendet alle Ports, Portnachrichten, Portimplementierungen und Verbindungen zwischen Ports und Aktionen oder zwischen Ports und Implementierungen aus.

  • Diese Anzeigeoption kann nicht auf der Datenseite verwendet werden.

Verwandte Themen

Anzeigen von Flussdiagramm- und Kommunikationsformen

Anzeigen von Flussdiagramm-, Kommunikations- und Implementierungsformen

Anzeigen von Schablonen

Anzeigen der Entwurfsseiten


Anzeigen von Flussdiagramm- und Kommunikationsformen

  • Klicken Sie im Menü Ansicht auf Flussdiagramm- und Kommunikationsformen.

Anmerkungen

  • Bei Verwendung dieser Option werden auf der Entwurfsseite nur Flussdiagrammformen und die Verbindungen zwischen ihnen angezeigt. Ports, Portnachrichten und die Verbindungen zwischen Ports und Aktionen werden ebenfalls angezeigt. Diese Option blendet alle Implementierungen und Verbindungen zwischen Ports und Implementierungen aus.

  • Diese Anzeigeoption kann nicht auf der Datenseite verwendet werden.

Verwandte Themen

Anzeigen von Flussdiagramm-, Kommunikations- und Implementierungsformen

Anzeigen von Flussdiagrammformen

Anzeigen von Schablonen

Anzeigen der Entwurfsseiten


Anzeigen von Flussdiagramm-, Kommunikations- und Implementierungsformen

  • Klicken Sie im Menü Ansicht auf Flussdiagramm-, Kommunikations- und Implementierungsformen.

Anmerkungen

  • Alle Formen und die Verbindungen zwischen ihnen werden angezeigt.

  • Diese Anzeigeoption kann nicht auf der Datenseite verwendet werden.

Verwandte Themen

Anzeigen von Flussdiagramm- und Kommunikationsformen

Anzeigen von Flussdiagrammformen

Anzeigen von Schablonen

Anzeigen der Entwurfsseiten


Anzeigen von Schablonen

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Anzeigen der Flussdiagramm-Schablone

  • Anzeigen der Implementierung-Schablone

Verwandte Themen

Anzeigen von Formen

Anzeigen der Entwurfsseiten


Anzeigen der Flussdiagramm-Schablone

  • Zeigen Sie im Menü Ansicht auf Schablonen, und klicken Sie auf Flussdiagramm, um die Flussdiagramm-Schablone ein- oder auszublenden.

Verwandte Themen

Anzeigen von Formen

Anzeigen der Entwurfsseiten

Anzeigen der Implementierung-Schablone


Anzeigen der Implementierung-Schablone

  • Zeigen Sie im Menü Ansicht auf Schablonen, und klicken Sie auf Implementierung, um die Implementierung-Schablone ein- oder auszublenden.

Verwandte Themen

Anzeigen von Formen

Anzeigen der Entwurfsseiten

Anzeigen der Flussdiagramm-Schablone


Verwenden mehrerer Fenster

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Öffnen eines neuen Fensters

  • Anordnen von Fenstern nebeneinander

  • Überlappendes Anordnen von Fenstern

  • Umschalten zwischen Fenstern

Verwandtes Thema

Anzeigen der Entwurfsseiten


Öffnen eines neuen Fensters

  • Klicken Sie im Menü Fenster auf Neues Fenster.

Anmerkung

  • Mehrere Fenster ermöglichen zusätzliche Sichten desselben XLANG-Ablaufplanes. Auf diese Weise können Sie Folgendes durchführen:
    • Verschiedene Seiten desselben XLANG-Ablaufplanes zur selben Zeit anzeigen. Sie können z. B. Sichten für die Geschäftsprozessseite, die Datenseite und eine Seite Kompensierung für Transaktion öffnen.

    • Verschiedene Teile derselben Seite eines XLANG-Ablaufplanes zur selben Zeit anzeigen. Beispielsweise können Sie in der einen Sicht eine Vergrößerung anzeigen, um einen bestimmten Satz von Formen im XLANG-Ablaufplan zu betrachten, während Sie in einer anderen Sicht die Darstellung verkleinern können, um den gesamten Ablaufplan zu betrachten.

Verwandte Themen

Überlappendes Anordnen von Fenstern

Umschalten zwischen Fenstern

Anordnen von Fenstern nebeneinander

Anzeigen der Entwurfsseiten


Anordnen von Fenstern nebeneinander

  • Klicken Sie im Menü Fenster auf Nebeneinander.

Anmerkungen

  • Sie können mehrere Fenster zur selben Zeit zu betrachten, indem Sie die Fenster nebeneinander anordnen.

  • Mehrere Fenster bieten zusätzliche Sichten desselben XLANG-Ablaufplanes. Auf diese Weise können Sie Folgendes durchführen:
    • Verschiedene Seiten desselben XLANG-Ablaufplanes zur selben Zeit anzeigen. Sie können z. B. Sichten für die Geschäftsprozessseite, die Datenseite und eine Seite Kompensierung für Transaktion öffnen.

    • Verschiedene Teile derselben Seite eines XLANG-Ablaufplanes zur selben Zeit anzeigen. Beispielsweise können Sie in der einen Sicht eine Vergrößerung anzeigen, um einen bestimmten Satz von Formen im XLANG-Ablaufplan zu betrachten, während Sie in einer anderen Sicht die Darstellung verkleinern können, um den gesamten Ablaufplan zu betrachten.

Verwandte Themen

Überlappendes Anordnen von Fenstern

Umschalten zwischen Fenstern

Öffnen eines neuen Fensters

Anzeigen der Entwurfsseiten


Überlappendes Anordnen von Fenstern

  • Klicken Sie im Menü Fenster auf Überlappend.

Anmerkungen

  • Sie können eines der Fenster in den Vordergrund des Bildschirmes platzieren, indem Sie die Fenster überlappend anordnen. Sie können dann auf die Titelleisten der anderen Fenster klicken, um diese Fenster in den Vordergrund zu bringen.

  • Mehrere Fenster bieten zusätzliche Sichten desselben XLANG-Ablaufplanes. Auf diese Weise können Sie Folgendes durchführen:
    • Verschiedene Seiten desselben XLANG-Ablaufplanes zur selben Zeit anzeigen. Sie können z. B. Sichten für die Geschäftsprozessseite, die Datenseite und eine Seite Kompensierung für Transaktion öffnen.

    • Verschiedene Teile derselben Seite eines XLANG-Ablaufplanes zur selben Zeit anzeigen. Beispielsweise können Sie in der einen Sicht eine Vergrößerung anzeigen, um einen bestimmten Satz von Formen im XLANG-Ablaufplan zu betrachten, während Sie in einer anderen Sicht die Darstellung verkleinern können, um den gesamten Ablaufplan zu betrachten.

Verwandte Themen

Umschalten zwischen Fenstern

Öffnen eines neuen Fensters

Anordnen von Fenstern nebeneinander

Anzeigen der Entwurfsseiten


Umschalten zwischen Fenstern

  • Klicken Sie im Menü Fenster auf den Namen des Fensters, zu dem Sie umschalten möchten.

Anmerkungen

  • Der Name eines Fensters besteht aus dem Namen des XLANG-Ablaufplanes und dem angehängten Namen einer Entwurfsseite. Beispiel: Ablaufplan1.skv:Geschäftsprozess oder Ablaufplan1.skv:Daten

  • Mehrere Fenster bieten zusätzliche Sichten desselben XLANG-Ablaufplanes. Auf diese Weise können Sie Folgendes durchführen:
    • Verschiedene Seiten desselben XLANG-Ablaufplanes zur selben Zeit anzeigen. Sie können z. B. Sichten für die Geschäftsprozessseite, die Datenseite und eine Seite Kompensierung für Transaktion öffnen.

    • Verschiedene Teile derselben Seite eines XLANG-Ablaufplanes zur selben Zeit anzeigen. Beispielsweise können Sie in der einen Sicht eine Vergrößerung anzeigen, um einen bestimmten Satz von Formen im XLANG-Ablaufplan zu betrachten, während Sie in einer anderen Sicht die Darstellung verkleinern können, um den gesamten Ablaufplan zu betrachten.

Verwandte Themen

Überlappendes Anordnen von Fenstern

Öffnen eines neuen Fensters

Anordnen von Fenstern nebeneinander

Anzeigen der Entwurfsseiten


Verwenden von Anmerkungen

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Hinzufügen von Anmerkungen

  • Bearbeiten von Anmerkungen

  • Formatieren von Text in Anmerkungen

  • Löschen von Anmerkungen


Hinzufügen von Anmerkungen

  1. Klicken Sie im BizTalk-Orchestrierungs-Designer auf der Symbolleiste auf die Schaltfläche Text einfügen/bearbeiten ( Schaltfläche Text einfügen/bearbeiten).

  2. Ziehen Sie den Mauszeiger auf den Bereich, in dem Sie eine Anmerkung erstellen möchten.

  3. Geben Sie die Anmerkung ein.

Anmerkungen

  • Klicken Sie auf der Symbolleiste auf die Schaltfläche Standardzeiger ( Schaltfläche Standardzeiger), um das Texttool auszublenden.

  • Da der BizTalk-Orchestrierungs-Designer eine angepasste Microsoft Visio-Oberfläche verwendet, ist die Schaltfläche Text einfügen/bearbeiten in zwei Varianten verfügbar. Die Funktionalität beider Schaltflächen ist identisch:
    • Die Schaltfläche Text einfügen/bearbeiten ( Schaltfläche Text einfügen/bearbeiten)

    • Die Schaltfläche Textblock drehen ( Schaltfläche Textblock drehen)

Verwandte Themen

Löschen von Anmerkungen

Bearbeiten von Anmerkungen

Formatieren von Text in Anmerkungen


Bearbeiten von Anmerkungen

  1. Klicken Sie im BizTalk-Orchestrierungs-Designer auf der Symbolleiste auf die Schaltfläche Text einfügen/bearbeiten ( Schaltfläche Text einfügen/bearbeiten).

  2. Klicken Sie auf die zu bearbeitende Anmerkung.

  3. Bearbeiten Sie die Anmerkung.

Anmerkungen

  • Klicken Sie auf der Symbolleiste auf die Schaltfläche Standardzeiger ( Schaltfläche Standardzeiger), um das Texttool auszublenden.

  • Da der BizTalk-Orchestrierungs-Designer eine angepasste Microsoft Visio-Oberfläche verwendet, ist die Schaltfläche Text einfügen/bearbeiten in zwei Varianten verfügbar. Die Funktionalität beider Schaltflächen ist identisch:
    • Die Schaltfläche Text einfügen/bearbeiten ( Schaltfläche Text einfügen/bearbeiten)

    • Die Schaltfläche Textblock drehen ( Schaltfläche Textblock drehen)

Verwandte Themen

Hinzufügen von Anmerkungen

Löschen von Anmerkungen

Formatieren von Text in Anmerkungen


Formatieren von Text in Anmerkungen

  1. Markieren Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite eine oder mehrere Anmerkungen, die Sie formatieren möchten.

  2. Klicken Sie im Menü Format auf Zeichen.

    Das Dialogfeld Zeichen wird angezeigt. Das Dialogfeld bietet mehrere Optionen zur Auswahl des Schriftgrades, der Schriftart und der Textgestaltung.

  3. Wählen Sie die Optionen aus, die Sie verwenden möchten, und klicken Sie auf OK.

Anmerkungen

  • Diese Optionen werden für alle Anmerkungen übernommen, die Sie in der XLANG-Ablaufplanzeichnung markiert haben, sowie für alle Anmerkungen, die Sie anschließend neu erstellen.

  • Anmerkungen können nicht formatiert werden, solange das Texttool aktiviert ist.

  • Um eine Anmerkung zu markieren, klicken Sie darauf. Soll mehr als eine Anmerkung markiert werden, klicken Sie bei gedrückter UMSCHALT-TASTE auf die Anmerkungen, die Sie auswählen möchten.

Verwandte Themen

Hinzufügen von Anmerkungen

Löschen von Anmerkungen

Bearbeiten von Anmerkungen


Löschen von Anmerkungen

  • Klicken Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite auf die Anmerkung, die Sie löschen möchten, und drücken Sie anschließend die ENTF-TASTE.

Anmerkung

  • Sie müssen das Texttool deaktivieren, bevor Sie eine Anmerkung in der XLANG-Ablaufplanzeichnung löschen können.

Verwandte Themen

Hinzufügen von Anmerkungen

Formatieren von Text in Anmerkungen


Anzeigen einer Seitenvorschau, Drucken oder Größenanpassung von XLANG-Ablaufplanzeichnungen

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Verwenden der Seitenansicht

  • Drucken einer XLANG-Ablaufplanzeichnung

  • Anpassen der Größe einer XLANG-Ablaufplanzeichnung


Verwenden der Seitenansicht

  • Klicken Sie im Menü Datei auf Seitenansicht.

Anmerkung

  • Wenn Sie die Einstellung der Option Layout von Querformat in Hochformat ändern, wird die folgende Meldung angezeigt:

    "Eines oder mehrere Zeichenblätter sind anders ausgerichtet, als unter Seite einrichten vorgegeben. Klicken Sie OK, um die Zeichnung auf mehrere Seiten verteilt auszudrucken, oder passen Sie die Ausrichtung entsprechend an. Ändern Sie die Seitenausrichtung für den Druck, um eine übereinstimmende Ausrichtung zu erreichen."

    Wenn Sie auf OK klicken und diese Änderung vornehmen, zeigt die Seitenansicht möglicherweise folgendes Verhalten an:

    • Wenn Sie auf Nächste Druckseite klicken, um vorwärts zu blättern, und anschließend auf Vorherige Druckseite klicken, um zur ersten Seite zurückzukehren, werden einige Formen in der Seitenansicht so angezeigt, als ob sie sich nicht auf der Seite befänden. Dieses Anzeigeverhalten ist kein Anlass zur Sorge. Der eigentliche Ausdruck des XLANG-Ablaufplanes erfolgt problemlos auch über mehrere Seiten hinweg.

Verwandte Themen

Drucken einer XLANG-Ablaufplanzeichnung

Anpassen der Größe einer XLANG-Ablaufplanzeichnung


Drucken einer XLANG-Ablaufplanzeichnung

  1. Klicken Sie im Menü Datei auf Drucken.

  2. Wählen Sie im angezeigten Dialogfeld Drucken die gewünschten Optionen aus, und klicken Sie auf OK.

Verwandte Themen

Anpassen der Größe einer XLANG-Ablaufplanzeichnung

Verwenden der Seitenansicht


Anpassen der Größe einer XLANG-Ablaufplanzeichnung

  1. Klicken Sie im BizTalk-Orchestrierungs-Designer im Menü Ansicht auf Ganzes Zeichenblatt.

  2. Drücken Sie STRG und halten Sie die Taste gedrückt, während Sie den Mauszeiger über den Seitenrand positionieren.

    Über dem Seitenrand ändert der Mauszeiger sein Aussehen und nimmt die Form eines Doppelpfeiles an.

  3. Klicken Sie auf den Seitenrand, und ziehen Sie den Seitenrand in geeigneter Weise, um die Größe der Seite anzupassen.

Verwandte Themen

Drucken einer XLANG-Ablaufplanzeichnung

Verwenden der Seitenansicht


Hinzufügen, Löschen und Verbinden von Formen

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Hinzufügen von Formen

  • Benennen von Formen

  • Löschen von Formen

  • Löschen nicht verwendeter Ports und Nachrichten

  • Verbinden von Formen


Hinzufügen von Formen

  • Klicken Sie im BizTalk-Orchestrierungs-Designer auf der Flussdiagramm-Schablone auf eine Form, und ziehen Sie sie auf die Entwurfsseite.

Anmerkungen

  • Sie können Flussdiagrammformen zu Geschäftsprozesseiten, den Seiten Kompensierung für Transaktion und den Seiten Bei Fehler von Transaktion hinzufügen. Auf der Datenseite sind Flussdiagrammformen nicht verfügbar.

  • Informationen zum Hinzufügen von Implementierungsformen zu einer XLANG-Ablaufplanzeichnung finden Sie unter Implementieren von Ports.

  • Sie können der Datenseite keine Formen hinzufügen. Jedes Mal, wenn eine Aktion mit einem Port verknüpft wird, werden automatisch neue Nachrichten auf der Datenseite generiert.

Verwandte Themen

Verbinden von Formen

Löschen von Formen

Löschen nicht verwendeter Ports und Nachrichten

Benennen von Formen

Anzeigen der Flussdiagramm-Schablone


Benennen von Formen

  1. Klicken Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite mit der rechten Maustaste auf eine Form, und klicken Sie anschließend auf Eigenschaften.

  2. Geben Sie im Dialogfeld Form-Eigenschaften in das Feld Name einen Namen ein.

Anmerkungen

  • Die Name-Eigenschaft einer jeden Form besitzt einen Standardwert, der sich aus der Bezeichnung der Form und einer angehängten Zahl zusammensetzt, beispielsweise Aktion 1. Sie können diesen Standardwert durch einen Namen Ihrer Wahl ersetzen.

  • Die folgenden Formen können nicht umbenannt werden: Abbruch, Beginn, Entscheidung, Ende, Verzweigung, Verknüpfung und While.

  • Für folgende Formen ist eine Umbenennung möglich: Aktion, Transaktion, Port, Nachricht und Regel.

  • Formennamen müssen bestimmte Benennungskonventionen erfüllen. Die folgenden Konventionen gelten für Transaktionen, Ports, Nachrichten, Regeln und Felder:
    • Der Name muss ein gültiger XML-Elementname sein. Weitere Informationen zu XML-Elementen finden Sie in der W3C-Website (www.w3.org).

    • Der Name darf nicht mit Unterstrichen (__) beginnen.

    • Der Name darf keinen Doppelpunkt (:) enthalten.

    • Der Name darf maximal 32 Zeichen lang sein.

    • Namen von Konstanten und Nachrichten dürfen nicht mit einem nummerischen Zeichen beginnen.
  • Transaktionsnamen mit Zeichen aus einem Ein-Byte-Zeichensatz dürfen maximal 16 Zeichen lang sein. Transaktionsnamen mit Zeichen aus einem Zwei-Byte-Zeichensatz dürfen maximal 8 Zeichen lang sein.

  • Aktionen sind bis auf die Beschränkung der Namenslänge auf 32 Zeichen von allen Namenskonventionen ausgenommen.

Verwandte Themen

Hinzufügen von Formen

Verbinden von Formen

Löschen von Formen

Löschen nicht verwendeter Ports und Nachrichten


Löschen von Formen

  • Klicken Sie auf die Form, die Sie löschen möchten, und drücken Sie ENTF.

Anmerkungen

  • Sie können eine Verbindung zwischen zwei Formen löschen, indem Sie auf die Verbindung klicken und anschließend ENTF drücken.

  • Wenn Sie eine Form löschen, die Verbindungen mit anderen Formen besitzt, werden auch diese Verbindungen gelöscht.

  • Wenn Sie eine Transaktion löschen, werden alle Formen, die von dieser Transaktion umschlossen sind, ebenfalls gelöscht.

  • Sie können eine BizTalk-Messaging- oder Message Queuing-Implementierung löschen, ohne damit auch die Ports zu löschen, mit denen diese Implementierungen verbunden sind.

  • Beim Löschen einer Implementierung einer COM-Komponente oder einer Windows Script-Komponente werden die Ports, mit der die Implementierung verbunden ist, ebenfalls gelöscht.

  • Sie können eine Nachricht löschen, indem Sie innerhalb eines Ports auf die Nachricht klicken und ENTF drücken. Die zugehörige Nachricht wird auf der Datenseite gelöscht.

    Sie können Nachrichten auch über die Datenseite löschen. Weitere Informationen finden Sie unter Löschen einer Nachricht.

  • Mithilfe des beschriebenen Verfahrens können Sie keine Regeln löschen. Weitere Informationen zum Löschen von Regeln finden Sie unter den folgenden Themen:
    • Entfernen einer Regel aus einer Entscheidung

    • Entfernen der Regel aus einer While-Schleife

    • Löschen nicht verwendeter Regeln

Verwandte Themen

Hinzufügen von Formen

Verbinden von Formen

Löschen einer Nachricht

Entfernen einer Regel aus einer Entscheidung

Entfernen der Regel aus einer While-Schleife

Löschen nicht verwendeter Ports und Nachrichten

Löschen nicht verwendeter Regeln

Benennen von Formen


Löschen nicht verwendeter Ports und Nachrichten

  • Klicken Sie im BizTalk-Orchestrierungs-Designer im Menü Extras auf Nicht verwendete Ports und Nachrichten löschen.

Anmerkung

  • Dieses Verfahren entfernt alle nicht verwendeten Ports und alle in diesen Ports enthaltenen Nachrichten aus der XLANG-Ablaufplanzeichnung. Die entsprechenden Nachrichten auf der Datenseite werden ebenfalls entfernt.

Verwandte Themen

Hinzufügen von Formen

Verbinden von Formen

Löschen von Formen

Benennen von Formen


Verbinden von Formen

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Markieren einer Form

  • Verbinden zweier Formen

  • Verwenden des Verbindungstools

  • Ausrichten von Formen entlang einer vertikalen oder horizontalen Achse

Verwandte Themen

Hinzufügen von Formen

Löschen von Formen

Löschen nicht verwendeter Ports und Nachrichten

Benennen von Formen


Markieren einer Form

  • Klicken Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite auf die zu markierende Form.

    Die markierte Form ist von einem grünen gestrichelten Rand umgeben. Alle für diese Form verfügbaren Kontrollhandles ( Kontrollhandle) sind aktiviert.

Anmerkungen

  • Das Markieren einer Form ermöglicht es, die Kontrollhandles ( Kontrollhandle) dieser Form auf andere Formen zu ziehen.

  • Außerdem ermöglicht das Markieren einer Form das Bearbeiten der verfügbaren Formeigenschaften sowie das Ausschneiden, Kopieren, Einfügen, Löschen oder Duplizieren der Form. Nicht alle der genannten Optionen stehen für jede Form zur Verfügung.

  • Wenn Sie eine Aktion-Form kopieren, die mit einer Port-Form verbunden ist, besitzt die Kopie jener Aktion ebenfalls eine Verbindung mit demselben Port.

Verwandte Themen

Hinzufügen von Formen

Verbinden zweier Formen

Löschen von Formen

Verwenden des Verbindungstools


Verbinden zweier Formen

  1. Um zwei Formen zu verbinden, markieren Sie zunächst die erste Form.

    Die markierte Form ist von einem grünen gestrichelten Rand umgeben. Alle für diese Form verfügbaren Kontrollhandles ( Kontrollhandle) sind aktiviert.

  2. Ziehen Sie das geeignete Kontrollhandle auf den Verbindungspunkt ( Verbindungspunkt) der zweiten Form.

    Wenn um den Verbindungspunkt ein rotes Feld ( Aktiver Verbindungspunkt) angezeigt wird, lassen Sie die Maustaste los, um die neue Verbindung festzulegen.

Anmerkungen

  • Prozessabläufe werden durch Verbinden der oberen und unteren Verbindungspunkte und Kontrollhandles von Formen dargestellt.

  • Kommunikationsflüsse werden durch Verbinden des rechten Kontrollhandles einer Aktion-Form mit dem linken Verbindungspunkt einer Port-Form dargestellt.

  • Sie können auch das Verbindungstool verwenden, um Formen miteinander zu verbinden. Weitere Informationen finden Sie unter Verwenden des Verbindungstools.

Verwandte Themen

Hinzufügen von Formen

Löschen von Formen

Markieren einer Form

Verwenden des Verbindungstools


Verwenden des Verbindungstools

  1. Klicken Sie auf der Symbolleiste auf die Schaltfläche Verbindungstool ( Schaltfläche Verbindungstool)).

  2. Bewegen Sie den Mauszeiger über ein Kontrollhandle ( Kontrollhandle) der Form, von der aus Sie eine Verbindung erstellen möchten.

    Das Kontrollhandle ist von einem roten Feld umgeben, welches anzeigt, dass Sie es ziehen können.

  3. Drücken und halten Sie die linke Maustaste, um das Kontrollhandle von der Form auf einen Verbindungspunkt ( Verbindungspunkt) der Form zu ziehen, zu der die gewünschte Verbindung führen soll.

    Wenn um den Verbindungspunkt der Form ein rotes Feld ( Aktiver Verbindungspunkt) angezeigt wird, lassen Sie die Maustaste los, um die neue Verbindung festzulegen.

Anmerkungen

  • Klicken Sie auf der Symbolleiste auf die Schaltfläche Standardzeiger ( Schaltfläche Standardzeiger), um das Verbindungstool auszublenden.

  • Es ist möglich, zu einer Seite neue Formen hinzuzufügen und andere Operationen auszuführen, während das Verbindungstool aktiviert ist. Allerdings erhalten Sie unter Umständen eine Fehlermeldung. Diese Fehlermeldung ist ungültig und ohne Bedeutung. Diese falsche Fehlermeldung wird in zukünftigen Versionen von Microsoft Visio behoben sein. Wenn Sie die erwähnte Fehlermeldung erhalten, klicken Sie auf OK, und setzen Sie den Vorgang fort. Die Fehlermeldung hat folgenden Wortlaut:

    "Interner Visio-Fehler: #-1

    Aktion 1246: Auf dem Zeichenblatt ablegen

    Versuchen Sie zuerst, die Datei zu schließen und wieder zu öffnen. Versuchen Sie dann, Visio neu zu starten."

Verwandte Themen

Hinzufügen von Formen

Verbinden zweier Formen

Löschen von Formen

Markieren einer Form


Ausrichten von Formen entlang einer vertikalen oder horizontalen Achse

  1. Ziehen Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite den Mauszeiger um die Formen herum, die Sie an einer Achse ausrichten möchten.

  2. Klicken Sie auf der Symbolleiste auf die Schaltfläche Formen ausrichten ( Schaltfläche Formen ausrichten).

  3. Klicken Sie im Dialogfeld Shapes ausrichten in einem der folgenden Bereiche auf die Ausrichtung, die Sie verwenden möchten:
    • Klicken Sie im Bereich Waagerechte Ausrichtung auf eine der folgenden Schaltflächen:

      Schaltfläche Horizontal oberer Rand Horizontal oberer Rand

      Schaltfläche Horizontal Mittellinie Horizontal Mittellinie

      Schaltfläche Horizontal unterer Rand Horizontal unterer Rand

    • Klicken Sie im Bereich Senkrechte Ausrichtung auf eine der folgenden Schaltflächen:

      Schaltfläche Vertikal linke Seite Vertikal linke Seite

      Schaltfläche Vertikale Mittellinie Vertikal Mittellinie

      Schaltfläche Vertikal rechte Seite Vertikal rechte Seite

Anmerkungen

  • Sie müssen Formen auf der Entwurfsseite markieren, um die Schaltfläche Formen ausrichten zu aktivieren.

  • Es wird empfohlen, Formen nur an einer Achse auszurichten. Die gleichzeitige Ausrichtung von Formen an beiden Achsen kann dazu führen, dass die Formen übereinander platziert werden. Drücken Sie STRG+Z, um alle unerwünschten Änderungen rückgängig zu machen.

  • Die Schaltfläche Keine Ausrichtung ( Schaltfläche Keine Ausrichtung) im Dialogfeld Shapes ausrichten deaktiviert eine ausgewählte Ausrichtung.

  • Das Kontrollkästchen Führungslinie erstellen und Shapes ankleben ist nicht verfügbar.

  • Um mehrere Formen zu markieren, klicken Sie bei gedrückter UMSCHALT-TASTE auf die Formen.


Festlegen von Bedingungseigenschaften

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Festlegen von Entscheidungsbedingungen

  • Festlegen von Bedingungen für While-Schleifen

  • Erstellen von Regeln

Verwandtes Thema

Entwerfen von Regeln


Festlegen von Entscheidungsbedingungen

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Hinzufügen einer Regel zu einer Entscheidung

  • Bearbeiten einer Regel einer Entscheidung

  • Entfernen einer Regel aus einer Entscheidung

  • Bestimmen der Auswertungsreihenfolge von Regeln

Verwandte Themen

Erstellen von Regeln

Entwerfen von Regeln


Hinzufügen einer Regel zu einer Entscheidung

  1. Klicken Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite mit der rechten Maustaste auf die Entscheidung-Form, der Sie eine Regel hinzufügen möchten, und klicken Sie anschließend auf Regel hinzufügen.

    Das Dialogfeld Regel hinzufügen wird angezeigt.

  2. Klicken Sie im Dialogfeld Regel hinzufügen auf eine der folgenden Optionen:
    • Neue Regel erstellen

      Klicken Sie auf OK. Das Dialogfeld Eigenschaften der Regel wird angezeigt.

      Informationen zum Erstellen von Regeln finden Sie unter Erstellen von Regeln.

    • Vorhandene Regel hinzufügen

      Klicken Sie in der Liste Verfügbare Regeln auf die Regel, die Sie hinzufügen möchten, und klicken Sie anschließend auf OK.

      Das Dialogfeld Regel hinzufügen wird geschlossen und die Regel der Entscheidung hinzugefügt.

Anmerkungen

  • Wird einer XLANG-Ablaufplanzeichnung erstmalig eine Regel hinzugefügt, bewirkt das Klicken auf Regel hinzufügen das Öffnen des Dialogfeldes Eigenschaften der Regel. Das Dialogfeld Regel hinzufügen wird nur dann angezeigt, wenn Sie bereits eine oder mehrere Regeln erstellt haben, die Sie der Entscheidung hinzufügen können. Weitere Informationen zum Dialogfeld Eigenschaften der Regel finden Sie unter Erstellen von Regeln.

  • Sie können einer Entscheidung eine Regel auch dadurch hinzufügen, dass Sie mit der rechten Maustaste auf eine Entscheidung-Form klicken, dann auf Eigenschaften und anschließend auf den Befehl Hinzufügen klicken.

Verwandte Themen

Erstellen von Regeln

Entfernen einer Regel aus einer Entscheidung

Entwerfen von Regeln

Bestimmen der Auswertungsreihenfolge von Regeln

Bearbeiten einer Regel einer Entscheidung


Bearbeiten einer Regel einer Entscheidung

  1. Klicken Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite mit der rechten Maustaste auf eine Entscheidung-Form, und klicken Sie anschließend auf Eigenschaften.

  2. Klicken Sie im Dialogfeld Entscheidungseigenschaften auf die Regel, die Sie bearbeiten möchten, und klicken Sie anschließend auf Bearbeiten.

  3. Nehmen Sie im Dialogfeld Eigenschaften der Regel die gewünschten Änderungen vor, und klicken Sie auf OK.

    Weitere Informationen zum Dialogfeld Eigenschaften der Regel finden Sie unter Erstellen von Regeln.

  4. Um eine weitere Regel zu bearbeiten, klicken Sie auf diese Regel und anschließend auf Bearbeiten.

    Oder

    Klicken Sie auf OK, um das Dialogfeld Entscheidungseigenschaften zu schließen.

Anmerkungen

  • Im Dialogfeld Entscheidungseigenschaften haben Sie auch die Möglichkeit, eine Regel hinzuzufügen, indem Sie auf Hinzufügen klicken.

  • Sie können eine Regel einer Entscheidung auch dadurch bearbeiten, dass Sie mit der rechten Maustaste auf eine Regel innerhalb einer Entscheidung-Form klicken und dann auf den Befehl Eigenschaften klicken. Eine solche Aktion öffnet das Dialogfeld Eigenschaften der Regel.

Verwandte Themen

Hinzufügen einer Regel zu einer Entscheidung

Erstellen von Regeln

Entfernen einer Regel aus einer Entscheidung

Entwerfen von Regeln

Bestimmen der Auswertungsreihenfolge von Regeln


Entfernen einer Regel aus einer Entscheidung

  1. Klicken Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite mit der rechten Maustaste auf die Entscheidung-Form, aus der Sie eine Regel entfernen möchten, und klicken Sie anschließend auf Eigenschaften.

  2. Klicken Sie auf die Regel, die Sie löschen möchten, und klicken Sie anschließend auf Löschen.

Verwandte Themen

Hinzufügen einer Regel zu einer Entscheidung

Erstellen von Regeln

Entwerfen von Regeln

Bestimmen der Auswertungsreihenfolge von Regeln

Bearbeiten einer Regel einer Entscheidung


Bestimmen der Auswertungsreihenfolge von Regeln

  1. Klicken Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite mit der rechten Maustaste auf eine Entscheidung-Form, und klicken Sie anschließend auf Eigenschaften.

  2. Klicken Sie im Dialogfeld Entscheidungseigenschaften auf die Regel, für die Sie die Auswertungsreihenfolge ändern möchten.

  3. Klicken Sie im Bereich Reihenfolge auf den Pfeil nach oben oder nach unten, um die Regel zu verschieben und ihre Position innerhalb der Listenreihenfolge zu ändern.

Anmerkung

  • Es wird empfohlen, die Regeln in der Reihenfolge ihrer Prioritäten anzuordnen, wobei die Regel mit der höchsten Priorität an erster Stelle kommt. Regeln werden der Reihe nach ausgeführt, bis eine Regel zu TRUE ausgewertet wird. Der Prozessablauf folgt der ersten Regel, für die TRUE ausgewertet wird. Wenn für keine Regel TRUE ausgewertet wird, wird der Else-Ablauf verfolgt.

Verwandte Themen

Hinzufügen einer Regel zu einer Entscheidung

Erstellen von Regeln

Entfernen einer Regel aus einer Entscheidung

Entwerfen von Regeln

Bearbeiten einer Regel einer Entscheidung


Festlegen von Bedingungen für While-Schleifen

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Hinzufügen einer Regel zu einer While-Schleife

  • Bearbeiten der Regel einer While-Schleife

  • Entfernen der Regel aus einer While-Schleife

  • Beibehalten des Status innerhalb einer While-Schleife

Verwandte Themen

Erstellen von Regeln

Entwerfen von Regeln


Hinzufügen einer Regel zu einer While-Schleife

  1. Klicken Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite mit der rechten Maustaste auf die While-Form, der Sie eine Regel hinzufügen möchten, und klicken Sie anschließend auf Regel hinzufügen.

    Das Dialogfeld Regel hinzufügen wird angezeigt.

  2. Klicken Sie im Dialogfeld Regel hinzufügen auf eine der folgenden Optionen:
    • Neue Regel erstellen

      Klicken Sie auf OK. Das Dialogfeld Eigenschaften der Regel wird angezeigt.

      Informationen zum Erstellen von Regeln finden Sie unter Erstellen von Regeln.

    • Vorhandene Regel hinzufügen

      Klicken Sie in der Liste Verfügbare Regeln auf die Regel, die Sie hinzufügen möchten, und klicken Sie anschließend auf OK.

      Das Dialogfeld Regel hinzufügen wird geschlossen, und die Regel wird zur While-Schleife hinzugefügt.

Anmerkungen

  • Wird einer XLANG-Ablaufplanzeichnung erstmalig eine Regel hinzugefügt, bewirkt das Klicken auf Regel hinzufügen das Öffnen des Dialogfeldes Eigenschaften der Regel. Das Dialogfeld Regel hinzufügen wird nur dann angezeigt, wenn Sie bereits eine oder mehrere Regeln erstellt haben, die Sie zur While-Schleife hinzufügen können Weitere Informationen zum Dialogfeld Eigenschaften der Regel finden Sie unter Erstellen von Regeln.

  • Sie können zu einer While-Schleife nur eine einzige Regel hinzufügen.

Verwandte Themen

Erstellen von Regeln

Entfernen der Regel aus einer While-Schleife

Entwerfen von Regeln

Bearbeiten der Regel einer While-Schleife

Beibehalten des Status innerhalb einer While-Schleife


Bearbeiten der Regel einer While-Schleife

  1. Klicken Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite mit der rechten Maustaste auf die Regel einer While-Schleife, und klicken Sie anschließend auf Eigenschaften.

  2. Nehmen Sie im Dialogfeld Eigenschaften der Regel die gewünschten Änderungen vor, und klicken Sie auf OK.

    Weitere Informationen zum Dialogfeld Eigenschaften der Regel finden Sie unter Erstellen von Regeln.

Verwandte Themen

Hinzufügen einer Regel zu einer While-Schleife

Erstellen von Regeln

Entfernen der Regel aus einer While-Schleife

Entwerfen von Regeln

Beibehalten des Status innerhalb einer While-Schleife


Entfernen der Regel aus einer While-Schleife

  • Klicken Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite mit der rechten Maustaste auf die While-Form, deren Regel Sie löschen möchten, und klicken Sie anschließend auf Regel löschen.

Verwandte Themen

Hinzufügen einer Regel zu einer While-Schleife

Erstellen von Regeln

Entwerfen von Regeln

Bearbeiten der Regel einer While-Schleife

Beibehalten des Status innerhalb einer While-Schleife


Beibehalten des Status innerhalb einer While-Schleife

  1. Klicken Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite mit der rechten Maustaste auf eine While-Form, und klicken Sie anschließend auf Eigenschaften.

  2. Klicken Sie im Dialogfeld While-Eigenschaften im Bereich Statuspersistenz auf eine der folgenden Optionen:
    • Ja

      Die Nachrichten, die in den einzelnen Schleifendurchgängen verwendet werden, werden als Status des XLANG-Ablaufplanes gespeichert. Wenn die Schleife Bestandteil einer fehlschlagenden Transaktion ist, wird für jeden vollständigen Schleifendurchgang eine Seite Bei Fehler von Transaktion oder Kompensierung für Transaktion aufgerufen.

    • Nein

      Nur die im letzen Schleifendurchgang verwendeten Nachrichten werden als Status des XLANG-Ablaufplanes gespeichert. Wenn die Schleife Bestandteil einer Transaktion ist, die fehlschlägt, wird nur einmal eine Seite Bei Fehler von Transaktion oder Kompensierung für Transaktion aufgerufen.

Verwandte Themen

Hinzufügen einer Regel zu einer While-Schleife

Erstellen von Regeln

Entfernen der Regel aus einer While-Schleife

Entwerfen von Regeln

Bearbeiten der Regel einer While-Schleife


Erstellen von Regeln

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Erstellen einer neuen Regel

  • Verwenden des Ausdrucks-Assistenten

  • Hinzufügen von Konstanten zu einer Regel

  • Löschen nicht verwendeter Regeln

Verwandte Themen

Entwerfen von Regeln

Festlegen von Entscheidungsbedingungen

Festlegen von Bedingungen für While-Schleifen


Erstellen einer neuen Regel

Sie können Regeln erstellen, um innerhalb eines Geschäftsprozesses Bedingungen auszuwerten. Regeln werden in Entscheidungen und While-Schleifen eines XLANG-Ablaufplanes verwendet. Wenn Sie zu einer Entscheidung- oder While-Form eine Regel hinzufügen, wird das Dialogfeld Eigenschaften der Regel angezeigt.

  1. Geben Sie im Dialogfeld Eigenschaften der Regel in das Feld Regelname einen Namen für die Regel ein.

    Dieses Feld muss belegt sein.

  2. In das Feld Regelbeschreibung können Sie eine detaillierte Beschreibung der Regel eingeben.

    Dieses Feld ist optional.

  3. Platzieren Sie die Eingabemarke in das Feld Skriptausdruck, um den Ausdrucks-Assistenten zu aktivieren.

    Sie können den Skriptausdruck, den Sie verwenden möchten, eingeben, oder ihn mithilfe des Ausdrucks-Assistenten bestimmen. Weitere Informationen zum Verwenden des Ausdrucks-Assistenten und zum Erstellen von Skriptausdrücken finden Sie unter Verwenden des Ausdrucks-Assistenten.

Wichtig

  • Da XML zwischen Groß- und Kleinschreibung unterscheidet, müssen Skriptausdrücke derselben Schreibweise folgen wie Nachrichten und deren Felder.

  • Sie müssen die Eingabemarke in das Feld Skriptausdruck platzieren, um den Ausdrucks-Assistenten zu aktivieren.

Anmerkungen

  • Formennamen müssen bestimmte Benennungskonventionen erfüllen. Die folgenden Konventionen gelten für Transaktionen, Ports, Nachrichten, Regeln und Felder:
    • Der Name muss ein gültiger XML-Elementname sein. Weitere Informationen zu XML-Elementen finden Sie in der W3C-Website (www.w3.org).

    • Der Name darf nicht mit Unterstrichen (__) beginnen.

    • Der Name darf keinen Doppelpunkt (:) enthalten.

    • Der Name darf maximal 32 Zeichen lang sein.
  • Die folgenden Formen können nicht umbenannt werden: Abbruch, Beginn, Entscheidung, Ende, Verzweigung, Verknüpfung und While.

  • Die Länge des längsten Regelnamens bestimmt die Breite der Entscheidung- oder While-Form, in der die Regel verwendet wird.

  • Sie können an beliebigen Stellen im Feld Skriptausdruck weitere Skriptausdrücke hinzufügen, indem Sie die Einfügemarke an die Stelle positionieren, an der Sie den jeweiligen Ausdruck hinzufügen möchten.

  • Skriptausdrücke können erst erstellt werden, wenn die Portimplementierungen und die Nachrichtenkommunikation zwischen Aktionen und Ports eingerichtet sind.

  • Bevor Sie die XLANG-Ablaufplanzeichnung in einen XLANG-Ablaufplan kompilieren können, müssen Sie für alle Regeln des Planes vollständige Skriptausdrücke erstellen.

Verwandte Themen

Hinzufügen von Konstanten zu einer Regel

Entwerfen von Regeln

Festlegen von Entscheidungsbedingungen

Festlegen von Bedingungen für While-Schleifen

Verwenden des Ausdrucks-Assistenten


Verwenden des Ausdrucks-Assistenten

  1. Klicken Sie im Dialogfeld Eigenschaften der Regel im Bereich Ausdrucks-Assistent auf eine Nachricht in der Liste Nachricht.

  2. Klicken Sie im Bereich Ausdrucks-Assistent auf ein Feld in der Liste Feld.

  3. Klicken Sie auf Einfügen.

  4. Vervollständigen Sie den Ausdruck im Feld Skriptausdruck.

    Der Ausdrucks-Assistent fügt nur die ausgewählte Nachricht und das ausgewählte Feld hinzu. Zur Auswertung des Skriptausdrucks müssen Sie die Bedingung für die Regel angeben. Beispielsweise:

    PORequest.Total < 500

    Sie können Ausdrücke auch kombinieren, um komplizierte Bedingungen zu formulieren. Beispielsweise

    PORequest.Total < 500 AND PORequest.Quantity < 20

Wichtig

  • Da XML zwischen Groß- und Kleinschreibung unterscheidet, müssen Skriptausdrücke derselben Schreibweise folgen wie Nachrichten und deren Felder.

  • Sie müssen die Eingabemarke in das Feld Skriptausdruck platzieren, um den Ausdrucks-Assistenten zu aktivieren.

  • Die verfügbaren Felder in der Liste Feld basieren auf der Nachricht, die Sie in der Liste Nachricht auswählen. Es können nur Felder verwendet werden, die in dieser Nachricht enthalten sind.

Anmerkungen

  • Die Liste Nachricht enthält alle Nachrichten und Konstanten, die auf der Datenseite zur Verfügung stehen.

  • Regeln können auch die Systemfelder verwenden, die auf der Datenseite bereitgestellt werden Wird ein Systemfeld in einer Regel verwendet, ist es immer von eckigen Klammern eingeschlossen. Beispielsweise

    Nachricht1.[__Exists__]

    Weitere Informationen zu Systemfeldern finden Sie unter Datenverarbeitung.

  • Innerhalb von Regeln ist es auch möglich, Microsoft Visual Basic-Funktionen wie z. B. Date und Time zu verwenden.

  • Sie können an beliebigen Stellen im Feld Skriptausdruck weitere Skriptausdrücke hinzufügen, indem Sie die Einfügemarke an die Stelle positionieren, an der Sie den Ausdruck hinzufügen möchten.

  • Bevor Sie die XLANG-Ablaufplanzeichnung in einen nobr>XLANG-Ablaufplan kompilieren können, müssen Sie für alle Regeln des Ablaufplanes vollständige Skriptausdrücke erstellen.

Verwandte Themen

Hinzufügen von Konstanten zu einer Regel

Erstellen einer neuen Regel

Entwerfen von Regeln

Festlegen von Entscheidungsbedingungen

Festlegen von Bedingungen für While-Schleifen


Hinzufügen von Konstanten zu einer Regel

Sie können den Skriptausdrücken einer Regel Konstanten hinzufügen. Um Konstanten verwenden zu können, müssen Sie zuerst dafür sorgen, dass solche Konstanten zur Verfügung stehen.

  1. Wenn keine Konstanten verfügbar sind, müssen Sie auf der Datenseite der Liste Constants neue Konstanten hinzufügen.

    Weitere Informationen zum Verwenden von Konstanten und Hinzufügen von Konstanten zur Liste Constants finden Sie unter Verwenden von Konstanten.

  2. Klicken Sie im Dialogfeld Eigenschaften der Regel in der Liste Nachricht auf Constants.

  3. Klicken Sie in der Liste Feld auf diejenige Konstante, die Sie verwenden möchten, und klicken Sie anschließend auf Einfügen.

Anmerkung

  • Alle Konstanten in der Liste Constants auf der Datenseite sind für die Verwendung in einer Regel verfügbar.

Verwandte Themen

Erstellen einer neuen Regel

Entwerfen von Regeln

Festlegen von Entscheidungsbedingungen

Festlegen von Bedingungen für While-Schleifen

Verwenden des Ausdrucks-Assistenten


Löschen nicht verwendeter Regeln

  • Klicken Sie im Menü Extras auf Nicht verwendete Regeln löschen.

Anmerkungen

  • Dieses Verfahren löscht jede Regel, die nicht in einer Entscheidung oder einer While-Schleife der XLANG-Ablaufplanzeichnung verwendet wird.

  • Es werden nur solche Regeln aus der XLANG-Ablaufplanzeichnung entfernt, die aktuell in keiner While- oder Entscheidung-Form Verwendung finden. Alle in While- oder Entscheidung-Formen verwendeten Regeln bleiben erhalten, selbst wenn diese Formen aktuell mit keiner anderen Form verbunden sind.

Verwandte Themen

Hinzufügen von Konstanten zu einer Regel

Erstellen einer neuen Regel

Verwenden des Ausdrucks-Assistenten


Festlegen von Parallelitätseigenschaften

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Erstellen paralleler Abläufe

  • Festlegen der Verknüpfungstyp-Eigenschaft

  • Zusammenführen paralleler Abläufe

  • Beenden eines parallelen Ablaufs

Wichtig

  • Weitere Informationen zu parallelen Prozessen finden Sie unter Entwerfen von Parallelität. Es wird dringend empfohlen, dass Sie die Ausführungen zu diesem Themas lesen.


Erstellen paralleler Abläufe

  1. Klicken Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite auf eine Verzweigung-Form.

  2. Verbinden Sie das untere Kontrollhandle ( Kontrollhandle) der Verzweigung-Form mit dem oberen Verbindungspunkt ( Verbindungspunkt) einer nachfolgenden Form im Ablauf des Geschäftsprozesses.

  3. Wiederholen Sie die Schritte 1 und 2, um weitere parallele Abläufe zu erstellen.

Wichtig

  • Weitere Informationen zu parallelen Prozessen finden Sie unter Entwerfen von Parallelität. Es wird dringend empfohlen, dass Sie die Ausführungen zu diesem Themas lesen.

Anmerkungen

  • Nur ein einziger Ablauf kann vom oberen Verbindungspunkt aus in eine Verzweigung-Form einmünden.

  • Bis zu 64 verschiedene Abläufe können eine Verzweigung-Form verlassen, um parallele Prozesse zu starten.

  • Jedes Mal, wenn Sie einen weiteren Ablauf zeichnen möchten, müssen Sie erneut auf die Verzweigung-Form klicken, um sie zu markieren und deren Kontrollhandle zu aktivieren.

    Oder

    Sie können das Verbindungstool verwenden, wenn Sie mehrere parallele Abläufe erstellen möchten, um das Hinzufügen der Abläufe zu beschleunigen. Weitere Informationen zum Verbindungstool finden Sie unter Verwenden des Verbindungstools.

  • Sie können Flussdiagrammformen zu Geschäftsprozessseiten den Seiten Kompensierung für Transaktion und den Seiten Bei Fehler von Transaktion hinzufügen. Auf der Datenseite sind Flussdiagrammformen nicht verfügbar.

Verwandte Themen

Hinzufügen, Löschen und Verbinden von Formen

Verbinden zweier Formen

Beenden eines parallelen Ablaufs

Zusammenführen paralleler Abläufe

Markieren einer Form

Festlegen der Verknüpfungstyp-Eigenschaft

Verwenden des Verbindungstools


Festlegen der Verknüpfungstyp-Eigenschaft

  1. Klicken Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite mit der rechten Maustaste auf eine Verknüpfung-Form, und klicken Sie anschließend auf Eigenschaften.

  2. Klicken Sie im Dialogfeld Verknüpfungseigenschaften auf eine der folgenden Optionen:
    • AND

    • OR

Wichtig

  • Weitere Informationen zu parallelen Prozessen finden Sie unter Entwerfen von Parallelität. Es wird dringend empfohlen, dass Sie die Ausführungen zu diesem Themas lesen.

Anmerkung

  • Wenn Sie für die Verknüpfung die OR-Option auswählen, kann den einzelnen Abläufen, die in die Verknüpfung-Form einmünden, jeweils nur eine einzige Aktion zugeordnet werden.

Verwandte Themen

Erstellen paralleler Abläufe

Beenden eines parallelen Ablaufs

Zusammenführen paralleler Abläufe


Zusammenführen paralleler Abläufe

  1. Klicken Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite auf eine Form des Geschäftsprozesses, die einen parallelen Prozess ausführt.

  2. Verbinden Sie das untere Kontrollhandle ( Kontrollhandle) dieser Form mit dem oberen Verbindungspunkt ( Verbindungspunkt) der Verknüpfung-Form.

  3. Wiederholen Sie Schritt 1 und 2 für alle parallelen Abläufe, die in dieser bestimmten Verknüpfung zusammengeführt werden.

Wichtig

  • Weitere Informationen zu parallelen Prozessen finden Sie unter Entwerfen von Parallelität. Es wird dringend empfohlen, dass Sie die Ausführungen zu diesem Themas lesen.

Anmerkungen

  • Wenn Sie für die Verknüpfung die OR-Option auswählen, kann den einzelnen Abläufen, die in die Verknüpfung-Form einmünden, jeweils nur eine einzige Aktion zugeordnet werden.

  • Bis zu 64 verschiedene Abläufe können über den oberen Verbindungspunkt in eine Verknüpfung-Form einmünden.

  • Nur ein einziger Ablauf kann über den unteren Verbindungspunkt eine Verknüpfung-Form verlassen.

  • Sie können das Verbindungstool verwenden, wenn Sie mehrere parallele Abläufe zusammenführen möchten, um das Verknüpfen der Abläufe zu beschleunigen. Weitere Informationen zum Verbindungstool finden Sie unter Verwenden des Verbindungstools.

  • Sie können Flussdiagrammformen zu Geschäftsprozessseiten den Seiten Kompensierung für Transaktion und den Seiten Bei Fehler von Transaktion hinzufügen. Auf der Datenseite sind Flussdiagrammformen nicht verfügbar.

Verwandte Themen

Hinzufügen, Löschen und Verbinden von Formen

Verbinden zweier Formen

Erstellen paralleler Abläufe

Beenden eines parallelen Ablaufs

Markieren einer Form

Festlegen der Verknüpfungstyp-Eigenschaft

Verwenden des Verbindungstools


Beenden eines parallelen Ablaufs

  1. Klicken Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite auf eine Form des Geschäftsprozesses, die als ein paralleler Prozess ausgeführt wird.

  2. Verbinden Sie das untere Kontrollhandle ( Kontrollhandle) dieser Form mit dem oberen Verbindungspunkt ( Verbindungspunkt) der Ende-Form.

    Dies beendet den parallelen Prozess. Er vereinigt sich nicht mit anderen Abläufen des XLANG-Ablaufplanes.

Wichtig

  • Weitere Informationen zu parallelen Prozessen finden Sie unter Entwerfen von Parallelität. Es wird dringend empfohlen, dass Sie die Ausführungen zu diesem Themas lesen.

Anmerkung

  • Sie können Flussdiagrammformen zu Geschäftsprozessseiten den Seiten Kompensierung für Transaktion und den Seiten Bei Fehler von Transaktion hinzufügen. Auf der Datenseite sind Flussdiagrammformen nicht verfügbar.

Verwandte Themen

Hinzufügen, Löschen und Verbinden von Formen

Verbinden zweier Formen

Erstellen paralleler Abläufe

Zusammenführen paralleler Abläufe

Markieren einer Form

Festlegen der Verknüpfungstyp-Eigenschaft

Verwenden des Verbindungstools


Festlegen von Transaktionseigenschaften

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Festlegen von Transaktionseigenschaften für einen XLANG-Ablaufplan

  • Festlegen von Eigenschaften für einzelne Transaktionen

  • Beschreiben der Transaktionsunterstützung durch Komponenten und Message Queuing

Verwandtes Thema

Entwerfen von Transaktionen


Festlegen von Transaktionseigenschaften für einen XLANG-Ablaufplan

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Festlegen des Transaktionsmodells

  • Festlegen der Transaktionsaktivierung-Eigenschaft

Verwandtes Thema

Entwerfen von Transaktionen


Festlegen des Transaktionsmodells

  1. Klicken Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite mit der rechten Maustaste auf die Beginn-Form, und klicken Sie anschließend auf Eigenschaften.

    Das Dialogfeld Beginneigenschaften wird angezeigt.

  2. Klicken Sie in der Liste Transaktionsmodell auf eine der folgenden Optionen:
    • Transaktionen in den XLANG-Ablaufplan einschließen

      Diese Option ermöglicht es einem XLANG-Ablaufplan, Transaktionen zu verwenden.

    • XLANG-Ablaufplan als COM+-Komponente behandeln

      Diese Option deaktiviert die Transaktionsunterstützung für einen XLANG-Ablaufplan. Eine COM-Komponente kann dann den XLANG-Ablaufplan im Kontext einer COM+-Transaktion aktivieren.

Anmerkungen

  • Wenn Sie für die Transaktionsmodell-Eigenschaft die Option XLANG-Ablaufplan als COM+-Komponente behandeln auswählen, ist die Liste Transaktionsaktivierung aktiviert.

  • Wenn Sie für die Transaktionsmodell-Eigenschaft die Option XLANG-Ablaufplan als COM+-Komponente behandeln auswählen, sollten Sie der XLANG-Ablaufplanzeichnung keine Transaktionen hinzufügen. Die XLANG-Ablaufplanzeichnung kann in diesem Fall nicht ordnungsgemäß kompiliert werden, und Sie erhalten eine Fehlermeldung.

  • Die XLANG-Identität-Eigenschaft ist eine eindeutige Kennung, die dazu dient, unterschiedliche Versionen einer XLANG-Ablaufplanzeichnung zu unterscheiden. Diese Eigenschaft ist schreibgeschützt und kann nicht geändert werden. Bei jeder Änderung einer XLANG-Ablaufplanzeichnung wird auch diese Identitätseigenschaft aktualisiert.

    Mithilfe der XLANG-Identität-Eigenschaft ist es möglich, Versionsübereinstimmungen zwischen einer XLANG-Ablaufplanzeichnung (SKV-Datei) und dem zugehörigen kompilierten XLANG-Ablaufplan (SKX-Datei) zu ermitteln.

  • Die Beginn-Form ist auf Geschäftsprozessseiten, den Seiten Kompensierung für Transaktion und den Seiten Bei Fehler von Transaktion verfügbar. Auf der Datenseite ist die Beginn-Form nicht verfügbar.

Verwandte Themen

Beschreiben der Transaktionsunterstützung durch Komponenten und Message Queuing

Entwerfen von Transaktionen

Festlegen der Transaktionsaktivierung-Eigenschaft


Festlegen der Transaktionsaktivierung-Eigenschaft

  1. Klicken Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite mit der rechten Maustaste auf die Beginn-Form, und klicken Sie anschließend auf Eigenschaften.

    Das Dialogfeld Beginneigenschaften wird angezeigt.

  2. Klicken Sie in der Liste Transaktionsmodell auf XLANG-Ablaufplan als COM+-Komponente behandeln.

    Bei Aktivierung dieser Option behandeln die Komponentendienste den XLANG-Ablaufplan als eine COM+-Komponente. Diese Option deaktiviert die Transaktionsunterstützung für einen XLANG-Ablaufplan. Eine COM-Komponente kann anschließend den XLANG-Ablaufplan im Kontext einer COM+-Transaktion aktivieren.

  3. Klicken Sie in der Liste Transaktionsaktivierung auf eine der folgenden Optionen:
    • Nicht unterstützt

      Der XLANG-Ablaufplan ignoriert eine gegebenenfalls im COM+-Objektkontext der die Ablaufplaninstanz erzeugenden Komponente präsente Transaktion. Keine der Aktionen des Ablaufplanes wird im Geltungsbereich einer Transaktion ausgeführt.

    • Unterstützt

      Der XLANG-Ablaufplan beteiligt sich an einer COM+-Transaktion, sofern eine solche Transaktion im COM+-Objektkontext der die Ablaufplaninstanz erzeugenden Komponente präsent ist.

    • Erforderlich

      Der XLANG-Ablaufplan muss im Geltungsbereich einer Transaktion ausgeführt werden. Ist eine solche Transaktion im COM+-Objektkontext der die Ablaufplaninstanz erzeugenden Komponente nicht präsent, initiiert das XLANG-Ablaufplanungsmodul automatisch eine neue Transaktion und verwendet sie.

    • Neue Transaktion erforderlich

      Der XLANG-Ablaufplan muss im Geltungsbereich einer neuen Transaktion ausgeführt werden. Das XLANG-Ablaufplanungsmodul initiiert automatisch eine neue Transaktion für den Ablaufplan, die sich von allen Transaktionen unterscheidet, die möglicherweise im COM+-Objektkontext der die Ablaufplaninstanz erzeugenden Komponente präsent gewesen sind.

Anmerkungen

  • Die XLANG-Identität-Eigenschaft ist eine eindeutige Kennung, die dazu dient, unterschiedliche Versionen einer XLANG-Ablaufplanzeichnung zu unterscheiden. Diese Eigenschaft ist schreibgeschützt und kann nicht geändert werden. Bei jeder Änderung einer XLANG-Ablaufplanzeichnung wird auch diese Identitätseigenschaft aktualisiert.

    Mithilfe der XLANG-Identität-Eigenschaft ist es möglich, Versionsübereinstimmungen zwischen einer XLANG-Ablaufplanzeichnung (SKV-Datei) und dem zugehörigen kompilierten XLANG-Ablaufplan (SKX-Datei) zu ermitteln.

  • Die Beginn-Form ist auf Geschäftsprozessseiten, den Seiten Kompensierung für Transaktion und den Seiten Bei Fehler von Transaktion verfügbar. Auf der Datenseite ist die Beginn-Form nicht verfügbar.

Verwandte Themen

Beschreiben der Transaktionsunterstützung durch Komponenten und Message Queuing

Entwerfen von Transaktionen

Festlegen des Transaktionsmodells


Festlegen von Eigenschaften für einzelne Transaktionen

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Gruppieren von Aktionen und Abläufen innerhalb einer Transaktion

  • Entwerfen geschachtelter Transaktionen

  • Erstellen von in Transaktionen eintretenden und von Transaktion verlassenden Abläufen

  • Benennen einer Transaktion

  • Festlegen der Transaktionstyp-Eigenschaft

  • Festlegen der Timeout-Eigenschaft

  • Festlegen der Wiederholungsanzahl-Eigenschaft

  • Festlegen der Backoffzeit-Eigenschaft

  • Festlegen der Isolationsebene-Eigenschaft

Verwandtes Thema

Entwerfen von Transaktionen


Gruppieren von Aktionen und Abläufen innerhalb einer Transaktion

  1. Ziehen Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite eine Transaktion-Form von der Flussdiagramm-Schablone auf die linke der Seite der Trennlinie.

  2. Passen Sie die Größe der Transaktion-Form so an, dass sie alle Formen umfasst, die Sie innerhalb der Transaktion platzieren möchten.

Anmerkungen

  • Jede Form und jeder Ablauf innerhalb der Begrenzungslinie einer Transaktion wird als Teil dieser Transaktion behandelt.

  • Um eine Form zu markieren, die sich innerhalb einer Transaktion befindet, klicken Sie auf die Form.

  • Wenn Sie eine Transaktion löschen, die innerhalb ihrer Begrenzungslinie Formen enthält, werden diese Formen ebenfalls gelöscht.

  • Transaktionstypen werden durch die folgenden Farben gekennzeichnet:
    • Blau. Diese Farbe kennzeichnet befristete Transaktionen.

    • Beige. Diese Farbe kennzeichnet langlebige Transaktionen.

    • Grau. Diese Farbe kennzeichnet kurzlebige Transaktionen (DTC-Stil).
  • Sie können Flussdiagrammformen zu Geschäftsprozessseiten, den Seiten Kompensierung für Transaktion und den Seiten Bei Fehler von Transaktion hinzufügen. Auf der Datenseite sind Flussdiagrammformen nicht verfügbar.

Verwandte Themen

Hinzufügen, Löschen und Verbinden von Formen

Erstellen von in Transaktionen eintretenden und von Transaktion verlassenden Abläufen

Entwerfen von Transaktionen

Entwerfen geschachtelter Transaktionen

Benennen einer Transaktion


Entwerfen geschachtelter Transaktionen

  1. Ziehen Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite eine Transaktion-Form aus der Flussdiagramm-Schablone heraus, und platzieren Sie sie innerhalb der Begrenzungslinien einer aktuellen Transaktion.

  2. Passen Sie die Größe der Transaktion-Form so an, dass sie alle Formen umfasst, die Sie innerhalb der Transaktion platzieren möchten.

Wichtig

  • Wenn Sie eine geschachtelte Transaktion erstellen, sind bestimmte Eigenschaften in der äußeren Transaktion deaktiviert:
    • Der Transaktionstyp Kurzlebig, DTC-Stil ist nicht verfügbar.

    • Alle Optionen im Bereich Transaktionsoptionen sind nicht verfügbar.

    • Die Timeout-Eigenschaft ist zwar noch aktiv, kann aber nicht mehr geändert werden, nachdem Sie eine geschachtelte Transaktion erstellt haben, es sei denn, Sie ändern den Transaktionstyp in Befristete Transaktion.

Anmerkungen

  • Jede Form und jeder Ablauf innerhalb der Begrenzungslinie einer Transaktion wird als Teil dieser Transaktion behandelt.

  • Um eine Form zu markieren, die sich innerhalb einer Transaktion befindet, klicken Sie auf die Form.

  • Wenn Sie eine Transaktion löschen, die innerhalb ihrer Begrenzungslinie Formen enthält, werden diese Formen ebenfalls gelöscht.

  • Transaktionstypen werden durch die folgenden Farben gekennzeichnet:
    • Blau. Diese Farbe kennzeichnet befristete Transaktionen.

    • Beige. Diese Farbe kennzeichnet langlebige Transaktionen.

    • Grau. Diese Farbe kennzeichnet kurzlebige Transaktionen (DTC-Stil).
  • Alle Flussdiagrammformen, die nicht vollständig innerhalb einer inneren Transaktion enthalten sind, werden als Teil der äußeren Transaktion behandelt.

  • Flussdiagrammformen innerhalb einer äußeren Transaktion sind möglicherweise zum Teil nicht sichtbar, wenn sie von einer inneren Transaktion teilweise überdeckt werden und nicht vollständig in dieser inneren Transaktion enthalten sind. Markieren Sie diese Formen, und positionieren Sie sie neu, damit sie einander nicht überlappen.

  • Sie können Flussdiagrammformen zu Geschäftsprozessseiten, den Seiten Kompensierung für Transaktion und den Seiten Bei Fehler von Transaktion hinzufügen. Auf der Datenseite sind Flussdiagrammformen nicht verfügbar.

Verwandte Themen

Hinzufügen, Löschen und Verbinden von Formen

Erstellen von in Transaktionen eintretenden und von Transaktion verlassenden Abläufen

Entwerfen von Transaktionen

Gruppieren von Aktionen und Abläufen innerhalb einer Transaktion

Benennen einer Transaktion


Erstellen von in Transaktionen eintretenden und von Transaktion verlassenden Abläufen

  1. Klicken Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite auf eine Form, die einer Transaktion im Ablauf des Geschäftsprozesses vorausgeht.

  2. Verbinden Sie das untere Kontrollhandle ( Kontrollhandle) dieser Form mit dem oberen Verbindungspunkt ( Verbindungspunkt) der Transaktion-Form.

  3. Klicken Sie auf die Transaktion-Form, um sie zu markieren.

  4. Verbinden Sie das obere Kontrollhandle der Transaktion-Form mit dem oberen Verbindungspunkt der ersten Form innerhalb der Transaktion, die den Beginn des Transaktionsflusses repräsentiert.

  5. Setzen Sie den Ablauf fort, indem Sie von jener Anfangsform zur nächsten Form innerhalb der Transaktion verbinden.

  6. Verbinden Sie alle Abläufe innerhalb der Transaktion, und verbinden Sie alle Aktionen mit den Ports, für die Sie einen Kommunikationsfluss erstellen möchten.

  7. Setzen Sie den Ablauf fort, indem Sie das untere Kontrollhandle der letzten Form innerhalb der Transaktion mit dem unteren Verbindungspunkt der Transaktion-Form verbinden.

  8. Klicken Sie auf die Transaktion-Form, um sie zu markieren.

  9. Verbinden Sie das untere Kontrollhandle der Transaktion-Form mit dem oberen Verbindungspunkt der nächsten Form innerhalb des Geschäftsprozessablaufs außerhalb der Transaktion.

Anmerkungen

  • Um eine Form zu markieren, die sich innerhalb einer Transaktion befindet, klicken Sie auf die Form.

  • Sie können Flussdiagrammformen zu Geschäftsprozessseiten, den Seiten Kompensierung für Transaktion und den Seiten Bei Fehler von Transaktion hinzufügen. Auf der Datenseite sind Flussdiagrammformen nicht verfügbar.

Verwandte Themen

Hinzufügen, Löschen und Verbinden von Formen

Verbinden zweier Formen

Entwerfen von Transaktionen

Entwerfen geschachtelter Transaktionen

Gruppieren von Aktionen und Abläufen innerhalb einer Transaktion

Verwenden des Verbindungstools


Benennen einer Transaktion

  10. Klicken Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite mit der rechten Maustaste auf eine Transaktion-Form, und klicken Sie anschließend auf Eigenschaften.

    Das Dialogfeld Eigenschaften der Transaktionen wird angezeigt.

  11. Geben Sie in das Feld Name einen Namen für die Transaktion ein.

Anmerkungen

  • Formennamen müssen bestimmte Benennungskonventionen erfüllen. Die folgenden Konventionen gelten für Transaktionen, Ports, Nachrichten, Regeln und Felder:
    • Der Name muss ein gültiger XML-Elementname sein. Weitere Informationen zu XML-Elementen finden Sie in der W3C-Website (www.w3.org).

    • Der Name darf nicht mit Unterstrichen (__) beginnen.

    • Der Name darf keinen Doppelpunkt (:) enthalten.

    • Der Name darf maximal 32 Zeichen lang sein.
  • Transaktionsnamen mit Zeichen aus einem Ein-Byte-Zeichensatz dürfen maximal 16 Zeichen lang sein. Transaktionsnamen mit Zeichen aus einem Zwei-Byte-Zeichensatz dürfen maximal 8 Zeichen lang sein.

Verwandte Themen

Entwerfen von Transaktionen

Entwerfen geschachtelter Transaktionen

Gruppieren von Aktionen und Abläufen innerhalb einer Transaktion

Festlegen der Backoffzeit-Eigenschaft

Festlegen der Isolationsebene-Eigenschaft

Festlegen der Wiederholungsanzahl-Eigenschaft

Festlegen der Timeout-Eigenschaft

Festlegen der Transaktionstyp-Eigenschaft


Festlegen der Transaktionstyp-Eigenschaft

  1. Klicken Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite mit der rechten Maustaste auf eine Transaktion-Form, und klicken Sie anschließend auf Eigenschaften.

    Das Dialogfeld Eigenschaften der Transaktionen wird angezeigt.

  2. Klicken Sie im Bereich Typ auf eine der folgenden Optionen:
    • Befristete Transaktion

    • Kurzlebig, DTC-Stil

    • Langlebig

Verwandte Themen

Entwerfen von Transaktionen

Entwerfen geschachtelter Transaktionen

Gruppieren von Aktionen und Abläufen innerhalb einer Transaktion

Benennen einer Transaktion

Festlegen der Backoffzeit-Eigenschaft

Festlegen der Isolationsebene-Eigenschaft

Festlegen der Wiederholungsanzahl-Eigenschaft

Festlegen der Timeout-Eigenschaft


Festlegen der Timeout-Eigenschaft

  1. Klicken Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite mit der rechten Maustaste auf eine Transaktion-Form, und klicken Sie anschließend auf Eigenschaften.

    Das Dialogfeld Eigenschaften der Transaktionen wird angezeigt.

  2. Geben Sie im Bereich Transaktionsoptionen in das Feld Timeout einen Wert für ein Zeitintervall in Sekunden ein.

Verwandte Themen

Entwerfen von Transaktionen

Entwerfen geschachtelter Transaktionen

Gruppieren von Aktionen und Abläufen innerhalb einer Transaktion

Benennen einer Transaktion

Festlegen der Backoffzeit-Eigenschaft

Festlegen der Isolationsebene-Eigenschaft

Festlegen der Wiederholungsanzahl-Eigenschaft

Festlegen der Transaktionstyp-Eigenschaft


Festlegen der Wiederholungsanzahl-Eigenschaft

  1. Klicken Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite mit der rechten Maustaste auf eine Transaktion-Form, und klicken Sie anschließend auf Eigenschaften.

    Das Dialogfeld Eigenschaften der Transaktionen wird angezeigt.

  2. Geben Sie im Bereich Transaktionsoptionen in das Feld Wiederholungsanzahl eine Zahl ein, die festlegt, wie oft eine Transaktion wiederholt werden kann, bevor sie als fehlgeschlagen gilt.

Verwandte Themen

Entwerfen von Transaktionen

Entwerfen geschachtelter Transaktionen

Gruppieren von Aktionen und Abläufen innerhalb einer Transaktion

Benennen einer Transaktion

Festlegen der Backoffzeit-Eigenschaft

Festlegen der Isolationsebene-Eigenschaft

Festlegen der Timeout-Eigenschaft

Festlegen der Transaktionstyp-Eigenschaft


Festlegen der Backoffzeit-Eigenschaft

  1. Klicken Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite mit der rechten Maustaste auf eine Transaktion-Form, und klicken Sie anschließend auf Eigenschaften.

    Das Dialogfeld Eigenschaften der Transaktionen wird angezeigt.

  2. Geben Sie im Bereich Transaktionsoptionen in das Feld Backoffzeit ein Zeitintervall in Sekunden ein.

Anmerkung

  • Die Backoffzeit-Eigenschaft bestimmt das Intervall zwischen den einzelnen Versuchen zur Wiederholung einer Transaktion. Diese Option ist nur für kurzlebige Transaktionen des DTC-Typs verfügbar. Die Backoffzeit wird zusammen mit der Wiederholungsanzahl verwendet, um die Wartezeit bis zum nächsten Wiederholungsversuch der Transaktion zu ermitteln. Der Backoff-Wert wächst exponentiell. Ein Backoff-Wert von 2 resultiert in Intervallen von 2, 4, 8, 16 Sekunden usw. für die Zeit bis zum jeweils nächsten Wiederholungsversuch. Die Berechnungsformel lautet B**W ("B hoch W"), wobei B die Backoffzeit und W die aktuelle Wiederholungsanzahl bezeichnet.

Verwandte Themen

Entwerfen von Transaktionen

Entwerfen geschachtelter Transaktionen

Gruppieren von Aktionen und Abläufen innerhalb einer Transaktion

Benennen einer Transaktion

Festlegen der Isolationsebene-Eigenschaft

Festlegen der Wiederholungsanzahl-Eigenschaft

Festlegen der Timeout-Eigenschaft

Festlegen der Transaktionstyp-Eigenschaft


Festlegen der Isolationsebene-Eigenschaft

  1. Klicken Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite mit der rechten Maustaste auf eine Transaktion-Form, und klicken Sie anschließend auf Eigenschaften.

    Das Dialogfeld Eigenschaften der Transaktionen wird angezeigt.

  2. Klicken Sie im Bereich Transaktionsoptionen in der Liste Isolationsebene auf eine der folgenden Optionen:
    • Serializable

    • Read Uncommitted

    • Read Committed

    • Repeatable Read

Anmerkung

  • Diese Eigenschaft kann nur für Transaktionen des Typs Kurzlebig, DTC-Stil festgelegt werden.

Verwandte Themen

Entwerfen von Transaktionen

Entwerfen geschachtelter Transaktionen

Gruppieren von Aktionen und Abläufen innerhalb einer Transaktion

Benennen einer Transaktion

Festlegen der Backoffzeit-Eigenschaft

Festlegen der Wiederholungsanzahl-Eigenschaft

Festlegen der Timeout-Eigenschaft

Festlegen der Transaktionstyp-Eigenschaft


Beschreiben der Transaktionsunterstützung durch Komponenten und Message Queuing

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Beschreiben der Transaktionsunterstützungsebene durch eine COM-Komponente

  • Beschreiben der Transaktionsunterstützungsebene durch eine Windows Script-Komponente

  • Beschreiben der Transaktionsunterstützung durch eine Nachrichtenwarteschlange

Verwandte Themen

Entwerfen von Transaktionen

Festlegen der Transaktionsaktivierung-Eigenschaft

Festlegen des Transaktionsmodells


Beschreiben der Transaktionsunterstützungsebene durch eine COM-Komponente

Transaktionsunterstützung für COM-Komponenten wird im Bindungs-Assistenten für COM-Komponenten festgelegt.

  1. Öffnen Sie den Bindungs-Assistenten für COM-Komponenten.

    Weitere Informationen zu diesem Assistenten finden Sie unter Implementieren eines Ports mithilfe einer COM-Komponente.

  2. Folgen Sie den Anweisungen im Assistenten, bis Sie zur Seite Erweiterte Porteigenschaften gelangen.

  3. Klicken Sie auf der Seite Erweiterte Porteigenschaften im Bereich Transaktionsunterstützung auf eine der folgenden Optionen:
    • Deaktiviert

      Die Transaktionsunterstützung für die von dieser Portimplementierung verwendete COM+-Komponente wird deaktiviert.

    • Nicht unterstützt

      Die von dieser Portimplementierung verwendete COM+-Komponente unterstützt keine Transaktionen.

    • Unterstützt

      Die von dieser Portimplementierung verwendete COM+-Komponente erbt eine vorhandene Transaktion.

    • Erforderlich

      Die von dieser Portimplementierung verwendete COM+-Komponente kann eine vorhandene Transaktion erben oder eine neue Transaktion initiieren.

    • Neue Transaktion erforderlich

      Die von dieser Portimplementierung verwendete COM+-Komponente muss eine neue Transaktion initiieren.

Verwandte Themen

Hinzufügen eines gebundenen Ports zu einer XLANG-Ablaufplanzeichnung

Entwerfen von Transaktionen

Implementieren eines Ports mithilfe einer COM-Komponente

Ändern der Eigenschaften einer Portimplementierung

Festlegen der Transaktionsaktivierung-Eigenschaft

Festlegen des Transaktionsmodells


Beschreiben der Transaktionsunterstützungsebene durch eine Windows Script-Komponente

Transaktionsunterstützung durch Windows Script-Komponenten wird im Bindungs-Assistenten für Skriptkomponenten festgelegt.

  1. Öffnen Sie den Bindungs-Assistenten für Skriptkomponenten.

    Weitere Informationen zu diesem Assistenten finden Sie unter Implementieren eines Ports mithilfe einer Windows Script-Komponente.

  2. Folgen Sie den Anweisungen im Assistenten, bis Sie zur Seite Erweiterte Porteigenschaften gelangen.

  3. Klicken Sie auf der Seite Erweiterte Porteigenschaften im Bereich Transaktionsunterstützung auf eine der folgenden Optionen:
    • Deaktiviert

      Die Transaktionsunterstützung für die von dieser Portimplementierung verwendete COM+-Komponente wird deaktiviert.

    • Nicht unterstützt

      Die von dieser Portimplementierung verwendete COM+-Komponente unterstützt keine Transaktionen.

    • Unterstützt

      Die von dieser Portimplementierung verwendete COM+-Komponente erbt eine vorhandene Transaktion.

    • Erforderlich

      Die von dieser Portimplementierung verwendete COM+-Komponente kann eine vorhandene Transaktion erben oder eine neue Transaktion initiieren.

    • Neue Transaktion erforderlich

      Die von dieser Portimplementierung verwendete COM+-Komponente muss eine neue Transaktion initiieren.

Verwandte Themen

Hinzufügen eines gebundenen Ports zu einer XLANG-Ablaufplanzeichnung

Entwerfen von Transaktionen

Implementieren eines Ports mithilfe einer Windows Script-Komponente

Ändern der Eigenschaften einer Portimplementierung

Festlegen der Transaktionsaktivierung-Eigenschaft

Festlegen des Transaktionsmodells


Beschreiben der Transaktionsunterstützung durch eine Nachrichtenwarteschlange

Transaktionsunterstützung durch Nachrichtenwarteschlangen wird im Bindungs-Assistenten für Message Queuing festgelegt.

  1. Öffnen Sie den Bindungs-Assistenten für Message Queuing.

    Weitere Informationen zu diesem Assistenten finden Sie unter Implementieren eines Ports mithilfe von Message Queuing.

  2. Folgen Sie den Anweisungen im Assistenten, bis Sie zur Seite Erweiterte Porteigenschaften gelangen.

  3. Aktivieren oder deaktivieren Sie auf der Seite Erweiterte Porteigenschaften im Bereich Transaktionsunterstützung das Kontrollkästchen Für diese Warteschlange sind Transaktionen erforderlich.

Verwandte Themen

Hinzufügen eines gebundenen Ports zu einer XLANG-Ablaufplanzeichnung

Entwerfen von Transaktionen

Implementieren eines Ports mithilfe von Message Queuing

Ändern der Eigenschaften einer Portimplementierung

Festlegen der Transaktionsaktivierung-Eigenschaft

Festlegen des Transaktionsmodells


Festlegen von Fehlerbehandlungseigenschaften

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Abbrechen eines Prozessablaufs

  • Aktivieren der Transaktionsfehlerbehandlung

  • Aktivieren der Fehlerbehandlung durch Komponenten

Verwandtes Thema

Behandeln von Ausnahmen


Abbrechen eines Prozessablaufs

  1. Klicken Sie im BizTalk-Orchestrierungs-Designer auf der Flussdiagramm-Schablone auf die Abbruch-Form, und ziehen Sie sie auf die Entwurfsseite.

  2. Verbinden Sie den Prozessablauf ausgehend von einem logischen Abzweig einer Entscheidung-Form mit dem Verbindungspunkt ( Verbindungspunkt) auf der Abbruch-Form.

Wichtig

  • Abbruch-Formen dienen dem Zweck, einen Geschäftsprozess bei Verfolgung eines bestimmten logischen Abzweigs abzubrechen. Sie werden zusammen mit Entscheidungen verwendet.

    Ob die Abbruch-Form verwendet wird, hängt von den Erfordernissen des gegebenen Geschäftsprozesses ab. Die Regeln einer Entscheidung werden ausgewertet, bis für eine Regel TRUE ausgewertet wird. Wird für eine der Regeln TRUE ausgewertet, geht der Prozessablauf zur nächsten Aktion über. Wenn für keine Regel TRUE ausgewertet wird, haben Sie die Möglichkeit, den Prozessablauf abzubrechen.

    Die folgende Abbildung zeigt ein Beispiel für eine Entscheidungsbedingung, wo der Prozessablauf mit Aktion 3 fortgesetzt wird, falls für die Regel TRUE ausgewertet wird, und andernfalls abgebrochen wird.

    Klicken Sie zum Vergrößern oder Verkleinern auf die Abbildung.

    Die Verwendung einer Abbruch-Form in einer logischen Verzweigung

Verwandte Themen

Aktivieren der Fehlerbehandlung durch Komponenten

Aktivieren der Transaktionsfehlerbehandlung

Behandeln von Ausnahmen

Logische Verzweigungen


Aktivieren der Transaktionsfehlerbehandlung

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Aktivieren der Bei Fehler von-Fehlerbehandlung

  • Aktivieren der Kompensierung für-Fehlerbehandlung

Verwandte Themen

Abbrechen eines Prozessablaufs

Behandeln von Ausnahmen


Aktivieren der Bei Fehler von-Fehlerbehandlung

  1. Klicken Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite mit der rechten Maustaste auf eine Transaktion-Form, und klicken Sie anschließend auf Eigenschaften.

    Das Dialogfeld Eigenschaften der Transaktionen wird angezeigt.

  2. Klicken Sie im Bereich Bei Fehler auf Code hinzufügen.

  3. Aktivieren Sie im Bereich Bei Fehler das Kontrollkästchen Aktiviert.

Anmerkungen

  • Durch das Klicken auf Code hinzufügen wird eine Fehlerseite (eine Seite Bei Fehler von Transaktion) erstellt, die mit dieser Transaktion verknüpft ist. Der Platzhalter Transaktion im Namen der Seite wird ersetzt durch den Namen der Transaktion, mit der der Fehlerbehandlungsprozess verknüpft ist.

  • Die Aktivierung des Kontrollkästchens Aktiviert versetzt den XLANG-Ablaufplan in die Lage, den Bei Fehler von-Code für diese Transaktion auszuführen. Auch wenn dieses Kontrollkästchen nicht aktiviert wird, ist es möglich, den Bei Fehler von-Code zu entwerfen. Dieser wird jedoch bei Ausführung des XLANG-Ablaufplanes nicht aktiviert.

Verwandte Themen

Entwerfen geschachtelter Transaktionen

Gruppieren von Aktionen und Abläufen innerhalb einer Transaktion

Behandeln von Ausnahmen


Aktivieren der Kompensierung für-Fehlerbehandlung

  1. Klicken Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite mit der rechten Maustaste auf eine innere Transaktion-Form einer geschachtelten Transaktionsgruppe, und klicken Sie anschließend auf Eigenschaften.

    Das Dialogfeld Eigenschaften der Transaktionen wird angezeigt.

  2. Klicken Sie im Bereich Kompensierung auf Code hinzufügen.

  3. Aktivieren Sie im Bereich Kompensierung das Kontrollkästchen Aktiviert.

Anmerkungen

  • Durch das Klicken auf Code hinzufügen wird eine Fehlerseite (eine Seite Bei Fehler von Transaktion) oder eine Kompensierungsseite (eine Seite Kompensierung für Transaktion) erstellt, die mit dieser Transaktion verknüpft ist.

  • Durch das Aktivieren des Kontrollkästchens Aktiviert kann der XLANG-Ablaufplan den Bei Fehler von-Code oder den Kompensierung-Code für diese Transaktion ausführen. Auch wenn diese Kontrollkästchen nicht aktiviert werden, ist es möglich, den Bei Fehler von-Code oder Kompensierung-Code zu entwerfen. Dieser wird jedoch bei Ausführung des XLANG-Ablaufplanes nicht aktiviert.

  • Der Platzhalter Transaktion im Namen der Seite wird ersetzt durch den Namen der Transaktion, mit der der Fehlerbehandlungsprozess verknüpft ist.

  • Transaktionstypen werden durch die folgenden Farben gekennzeichnet:
    • Blau. Diese Farbe kennzeichnet befristete Transaktionen.

    • Beige. Diese Farbe kennzeichnet langlebige Transaktionen.

    • Grau. Diese Farbe kennzeichnet kurzlebige Transaktionen (DTC-Stil).

Verwandte Themen

Entwerfen geschachtelter Transaktionen

Gruppieren von Aktionen und Abläufen innerhalb einer Transaktion

Behandeln von Ausnahmen


Aktivieren der Fehlerbehandlung durch Komponenten

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Abbrechen einer Transaktion bei Rückgabe eines Fehlers durch eine COM-Komponente

  • Abbrechen einer Transaktion bei Rückgabe eines Fehlers durch eine Windows Script-Komponente

Verwandte Themen

Abbrechen eines Prozessablaufs

Behandeln von Ausnahmen


Abbrechen einer Transaktion bei Rückgabe eines Fehlers durch eine COM-Komponente

Transaktionsunterstützung durch COM-Komponenten wird im Bindungs-Assistenten für COM-Komponenten festgelegt.

  1. Öffnen Sie den Bindungs-Assistenten für COM-Komponenten.

    Weitere Informationen zu diesem Assistenten finden Sie unter Implementieren eines Ports mithilfe einer COM-Komponente.

  2. Folgen Sie den Anweisungen im Assistenten, bis Sie zur Seite Erweiterte Porteigenschaften gelangen.

  3. Aktivieren Sie auf der Seite Erweiterte Porteigenschaften im Bereich Fehlerbehandlung das Kontrollkästchen Transaktion abbrechen, wenn die Methode ein Fehler-HRESULT zurückgibt.

Wichtig

  • Diese Option bestimmt, ob Transaktionen, an denen die Komponente beteiligt ist, abgebrochen werden sollen, wenn Aufrufe von Methoden der Komponente ein HRESULT-Ergebnis zurückgeben, welches einen Fehler anzeigt.

    Die Option kann nur aktiviert werden, wenn die Kommunikationsaktion, die diesen Port verwendet, innerhalb des Prozessablaufs einer Transaktion stattfindet.

Verwandte Themen

Abbrechen einer Transaktion bei Rückgabe eines Fehlers durch eine Windows Script-Komponente

Hinzufügen eines gebundenen Ports zu einer XLANG-Ablaufplanzeichnung

Behandeln von Ausnahmen

Implementieren eines Ports mithilfe einer COM-Komponente

Ändern der Eigenschaften einer Portimplementierung

Festlegen der Transaktionsaktivierung-Eigenschaft

Festlegen des Transaktionsmodells


Abbrechen einer Transaktion bei Rückgabe eines Fehlers durch eine Windows Script-Komponente

Transaktionsunterstützung durch Windows Script-Komponenten wird im Bindungs-Assistenten für Skriptkomponenten festgelegt.

  1. Öffnen Sie den Bindungs-Assistenten für Skriptkomponenten.

    Weitere Informationen zu diesem Assistenten finden Sie unter Implementieren eines Ports mithilfe einer Windows Script-Komponente.

  2. Folgen Sie den Anweisungen im Assistenten, bis Sie zur Seite Erweiterte Porteigenschaften gelangen.

  3. Aktivieren Sie auf der Seite Erweiterte Porteigenschaften im Bereich Fehlerbehandlung das Kontrollkästchen Transaktion abbrechen, wenn die Methode ein Fehler-HRESULT zurückgibt.

Wichtig

  • Diese Option bestimmt, ob Transaktionen, an denen die Komponente beteiligt ist, abgebrochen werden sollen, wenn Aufrufe von Methoden der Komponente ein HRESULT-Ergebnis zurückgeben, welches einen Fehler anzeigt.

    Die Option kann nur aktiviert werden, wenn die Kommunikationsaktion, die diesen Port verwendet, innerhalb des Prozessablaufs einer Transaktion stattfindet.

Verwandte Themen

Abbrechen einer Transaktion bei Rückgabe eines Fehlers durch eine COM-Komponente

Hinzufügen eines gebundenen Ports zu einer XLANG-Ablaufplanzeichnung

Behandeln von Ausnahmen

Implementieren eines Ports mithilfe einer Windows Script-Komponente

Ändern der Eigenschaften einer Portimplementierung

Festlegen der Transaktionsaktivierung-Eigenschaft

Festlegen des Transaktionsmodells


Implementieren von Ports

Der BizTalk-Orchestrierungs-Designer stellt vier Implementierungsformen zur Verfügung, die unterschiedliche Technologien zur Implementierung einer portgestützten Kommunikation repräsentieren. In der folgenden Tabelle werden diese Formen beschrieben.

Name der Form | Beschreibung
COM-Komponente | Mit der COM-Komponente-Form kann mithilfe eines Methodenaufrufs für jede gesendete oder empfangene Nachricht ein Port implementiert werden. Ziehen Sie die Form zum Öffnen des Bindungs-Assistenten für COM-Nachrichten auf die rechte Seite der Trennlinie.
Skriptkomponente | Mit der Skriptkomponente-Form kann mithilfe eines Methodenaufrufs für jede gesendete oder empfangene Nachricht ein Port implementiert werden. Ziehen Sie die Form zum Öffnen des Bindungs-Assistenten für Skriptkomponenten auf die rechte Seite der Trennlinie.
Message Queuing | Mit der Message Queuing-Form kann ein Port implementiert werden. Message Queuing-Dienste dienen zum Senden oder Empfangen von Nachrichten. Ziehen Sie die Form zum Öffnen des Bindungs-Assistenten für Message Queuing auf die rechte Seite der Trennlinie.
BizTalk-Messaging | Mit der BizTalk-Messaging-Form kann ein Port implementiert werden. BizTalk-Messaging-Dienste dienen zum Senden oder Empfangen von Nachrichten. Für die Portimplementierung kann entweder ein BizTalk Server-Messagingport oder ein Kanal verwendet werden. Ziehen Sie die Form zum Öffnen des BizTalk-Bindungs-Assistenten für Messaging auf die rechte Seite der Trennlinie.

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Hinzufügen eines ungebundenen Ports zu einer XLANG-Ablaufplanzeichnung

  • Hinzufügen eines gebundenen Ports zu einer XLANG-Ablaufplanzeichnung

  • Implementieren eines Ports mithilfe einer COM-Komponente

  • Implementieren eines Ports mithilfe einer Windows Script-Komponente

  • Implementieren eines Ports mithilfe von Message Queuing

  • Implementieren eines Ports mithilfe von BizTalk Messaging

  • Ändern der Eigenschaften einer Portimplementierung

Verwandte Themen

Kommunikationsformen

Flussdiagrammformen

Implementierungsformen

Implementieren von Geschäftsprozessen

Zuordnen einer bestimmten Nachricht zu einem bestimmten Port

Senden oder Empfangen von Nachrichten

Grundlegendes zu Portimplementierungen

Verwenden des Methodenkommunikations-Assistenten

Verwenden des Assistenten für XML-Kommunikation


Hinzufügen eines ungebundenen Ports zu einer XLANG-Ablaufplanzeichnung

  • Klicken Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite mit der rechten Maustaste auf die Trennleiste, und klicken Sie anschließend auf Neuen Port hinzufügen.

Anmerkungen

  • Sie können einen Port zu Geschäftsprozessseiten, den Seiten Kompensierung für Transaktion und den Seiten Bei Fehler von Transaktion hinzufügen. Auf der Datenseite sind Ports nicht verfügbar.

  • Der Datenseite können keine Formen hinzugefügt werden. Für jeden neu erstellten Port wird automatisch ein Portverweis auf der Datenseite generiert.

  • Ein ungebundener Port kann entweder mithilfe von Message Queuing oder von BizTalk Messaging implementiert werden. Wenn Sie der Seite eine der genannten Implementierungen hinzufügen, stellt der Implementierungs-Assistent die Möglichkeit bereit, einen der verfügbaren ungebundenen Ports auszuwählen.

Verwandte Themen

Implementieren eines Ports mithilfe einer COM-Komponente

Implementieren eines Ports mithilfe einer Windows Script-Komponente

Implementieren eines Ports mithilfe von BizTalk Messaging

Implementieren eines Ports mithilfe von Message Queuing

Zuordnen einer bestimmten Nachricht zu einem bestimmten Port

Ändern der Eigenschaften einer Portimplementierung

Senden oder Empfangen von Nachrichten


Hinzufügen eines gebundenen Ports zu einer XLANG-Ablaufplanzeichnung

  • Ziehen Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite eine Implementierungsform von der Implementierung-Schablone auf die rechte Seite der Trennlinie, und folgen Sie den Anweisungen des Assistenten für die gewählte Implementierung.

Anmerkungen

  • Sie können einen Port zu Geschäftsprozessseiten, den Seiten Kompensierung für Transaktion und den Seiten Bei Fehler von Transaktion hinzufügen. Auf der Datenseite sind Ports nicht verfügbar.

  • Der Datenseite können keine Formen hinzugefügt werden. Für jeden neu erstellten Port wird automatisch ein Portverweis auf der Datenseite generiert.

Verwandte Themen

Implementieren eines Ports mithilfe einer COM-Komponente

Implementieren eines Ports mithilfe einer Windows Script-Komponente

Implementieren eines Ports mithilfe von BizTalk Messaging

Implementieren eines Ports mithilfe von Message Queuing

Zuordnen einer bestimmten Nachricht zu einem bestimmten Port

Ändern der Eigenschaften einer Portimplementierung

Senden oder Empfangen von Nachrichten


Implementieren eines Ports mithilfe einer COM-Komponente

  1. Ziehen Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite eine COM-Komponente-Form von der Implementierung-Schablone auf die rechte Seite der Trennlinie.

    Der Bindungs-Assistent für COM-Komponenten wird gestartet.

  2. Geben Sie auf der Seite Willkommen beim Bindungs-Assistenten für COM-Komponenten einen Namen für den neu zu erstellenden Port ein.

    Der BizTalk-Orchestrierungs-Designer setzt für jede neue Portimplementierung einen Standardportnamen ein, dem eine (aktualisierte) Zahl angehängt wird. Sie können diesen Namen ändern.

    Klicken Sie auf Weiter.

  3. Klicken Sie auf der Seite Statische oder dynamische Kommunikation auf eine der folgenden Optionen:
    • Statisch

      Die Komponente wird vom XLANG-Ablaufplanungsmodul instanziiert.

      Bei Auswahl der Option Statisch wird die Komponente automatisch gelöscht, wenn die XLANG-Ablaufplaninstanz endet.

      Klicken Sie auf Weiter. Weiter mit Schritt 4 in diesem Verfahren.

    • Dynamisch

      Bei Auswahl dieser Option wird die Komponente von einer anderen Anwendung instanziiert. Ein Moniker oder ein Zeiger auf die Objektinstanz muss an den XLANG-Ablaufplan in Form eines Feldes in einer Nachricht zurückgesendet werden. Auf der Datenseite muss eine Verbindung zwischen diesem Nachrichtenfeld und dem Portverweis auf denjenigen Port gezogen werden, der diese Implementierung verwendet. Weitere Informationen zum Senden einer Nachricht an einen bestimmten Port finden Sie unter Zuordnen einer bestimmten Nachricht zu einem bestimmten Port.

      Klicken Sie auf Weiter. Weiter mit Schritt 5 in diesem Verfahren.

    • Keine Instanziierung

      Wählen Sie diese Option nur aus, wenn es um das Empfangen von Daten geht. Diese Option zeigt an, dass Daten mithilfe einer Methode an den XLANG-Ablaufplan weitergereicht werden. Allerdings wird durch den Methodenaufruf kein Code der Methode ausgeführt. Weitere Informationen finden Sie unter Datenverarbeitung.

      Klicken Sie auf Weiter. Weiter mit Schritt 5 in diesem Verfahren.

    Weitere Informationen zur statischen und dynamischen Kommunikation finden Sie unter den folgenden Themen:

    • Statische und dynamische Ports

    • Instanzenverwaltung

    • Verwenden der Skriptkomponente-Form
  4. Klicken Sie auf der Seite Klasseninformationen auf eine der folgenden Optionen:
    • Von einer registrierten Komponente

      Ein Strukturansicht-Steuerelement zeigt alle auf Ihrem Computer registrierten Komponenten an. Erweitern Sie die Ansicht für den Ordner der gewünschten Klasse, und klicken Sie auf die Klasse.

      Klicken Sie auf Weiter. Weiter mit Schritt 5 in diesem Verfahren.

    • Von einem Moniker

      Geben Sie den Namen eines Standard-COM-Monikers ein, um den Standort der COM-Komponente zu bestimmen, die Sie instanziieren möchten. Bei Auswahl dieser Option kann die COM-Komponente nicht für Kommunikationsvorgänge verwendet werden, die innerhalb einer Transaktion des XLANG-Ablaufplanes stattfinden.

      Klicken Sie auf Weiter. Weiter mit Schritt 5 in diesem Verfahren.

  5. Klicken Sie auf der Seite Schnittstelleninformationen auf die Schnittstelle, die Sie verwenden möchten.

    Klicken Sie auf Weiter. Weiter mit Schritt 6 in diesem Verfahren.

    Anmerkungen

    • Wenn die COM-Komponente nur eine Schnittstelle besitzt, wird diese Seite übersprungen.

    • Wurde die COM-Komponente mit Microsoft Visual Basic erstellt, gibt es für jede Klasse in der Komponente eine Schnittstelle desselben Namens. Jeder Schnittstellenname beginnt mit einem vorangestellten Unterstrich(_).
  6. Wählen Sie auf der Seite Methodeninformationen die Methoden aus, die Sie verwenden möchten.

    Klicken Sie auf Weiter. Weiter mit Schritt 7 in diesem Verfahren.

    Anmerkungen

    • Wenn die COM-Komponente nur eine Methode besitzt, wird diese Seite übersprungen.

    • Sie müssen mindestens eine Methode auswählen.

    • Es besteht die Möglichkeit, mehrere oder alle Methoden auszuwählen. Mithilfe der Schaltflächen Alle auswählen und Gesamte Auswahl aufheben können Sie alle Methoden auswählen oder diese Auswahl aufheben.
  7. Klicken Sie auf der Seite Erweiterte Porteigenschaften im Bereich Sicherheit auf eine der folgenden Optionen:
    • Nicht erforderlich

      Es wird kein Versuch unternommen, die Identität des Absenders zu bestätigen.

    • Optional

      Das XLANG-Ablaufplanungsmodul fordert Informationen zur Identität des Absenders an. Das XLANG-Ablaufplanungsmodul setzt seine Ausführung unabhängig davon fort, ob die gewünschten Identitätsinformationen vorliegen oder nicht.

    • Erforderlich

      Das XLANG-Ablaufplanungsmodul fordert Informationen zur Identität des Absenders an. Die Identität des Absenders muss bekannt sein und der XLANG-Ablaufplan ignoriert die Nachricht, wenn diese Identitätsinformationen nicht vorliegen.

    Anmerkung

    • Wenn der XLANG-Ablaufplan einen eingehenden Methodenaufruf zurückweist, weil die angeforderte Identifizierung des Absenders nicht vorliegt, wird der E_ACCESSDENIED-Fehlercode an den aufrufenden Prozess zurückgegeben.
  8. Klicken Sie auf der Seite Erweiterte Porteigenschaften im Bereich Transaktionsunterstützung auf eine der folgenden Optionen:
    • Deaktiviert

      Die Transaktionsunterstützung für die von dieser Portimplementierung verwendete COM+-Komponente wird deaktiviert.

    • Nicht unterstützt

      Die von dieser Portimplementierung verwendete COM+-Komponente unterstützt keine Transaktionen.

    • Unterstützt

      Die von dieser Portimplementierung verwendete COM+-Komponente erbt eine vorhandene Transaktion.

    • Erforderlich

      Die von dieser Portimplementierung verwendete COM+-Komponente kann eine vorhandene Transaktion erben oder eine neue Transaktion initiieren.

    • Neue Transaktion erforderlich

      Die von dieser Portimplementierung verwendete COM+-Komponente muss eine neue Transaktion initiieren.

  9. Klicken Sie auf der Seite Erweiterte Porteigenschaften im Bereich Statusverwaltungsunterstützung auf eine der folgenden Optionen:
    • Behält den Status nicht bei

      Die von dieser Portimplementierung verwendete Komponente behält den Status nicht über Methodenaufrufe hinweg bei.

    • Behält den Status bei, unterstützt aber keine Persistenz

      Die von dieser Portimplementierung verwendete Komponente behält den Status während der ganzen Lebensdauer der Komponente bei. Dieser Komponentenstatus kann jedoch nicht dauerhaft gesichert werden.

    • Behält den Status bei und unterstützt Persistenz

      Die von dieser Portimplementierung verwendete Komponente behält den Status bei. Dieser Status kann mithilfe einer der Schnittstellen IPersistStream oder IPersistStreamInit gespeichert werden. Die Verwendung von IPersistStream oder IPersistStreamInit ermöglicht es, den Status der Komponente für spätere Instanziierungen zu speichern, bei denen die Komponente mithilfe des gespeicherten Zustands neu angelegt wird.

  10. Aktivieren oder deaktivieren Sie auf der Seite Erweiterte Porteigenschaften im Bereich Fehlerbehandlung das Kontrollkästchen Transaktion abbrechen, wenn die Methode ein Fehler-HRESULT zurückgibt.

    Wichtig

    • Diese Option bestimmt, ob Transaktionen, an denen die Komponente beteiligt ist, abgebrochen werden sollen, wenn Aufrufe von Methoden der Komponente ein HRESULT-Ergebnis zurückgeben, welches einen Fehler anzeigt.

      Die Option kann nur aktiviert werden, wenn die Kommunikationsaktion, welche diesen Port verwendet, innerhalb des Prozessablaufs einer Transaktion stattfindet.

  11. Klicken Sie auf Fertig stellen.

Anmerkungen

  • Formennamen müssen bestimmte Benennungskonventionen erfüllen. Die folgenden Konventionen gelten für Transaktionen, Ports, Nachrichten, Regeln und Felder:
    • Der Name muss ein gültiger XML-Elementname sein. Weitere Informationen zu XML-Elementen finden Sie in der W3C-Website (www.w3.org).

    • Der Name darf nicht mit Unterstrichen (__) beginnen.

    • Der Name darf keinen Doppelpunkt (:) enthalten.

    • Der Name darf maximal 32 Zeichen lang sein.

    • Namen von Konstanten und Nachrichten dürfen nicht mit einem nummerischen Zeichen beginnen.
  • Sie können Portimplementierungen zu Geschäftsprozessseiten, den Seiten Kompensierung für Transaktion und den Seiten Bei Fehler von Transaktion hinzufügen. Auf der Datenseite sind Portimplementierungen nicht verfügbar.

  • Der Datenseite können keine Formen hinzugefügt werden. Für jeden neu erstellten Port wird automatisch ein Portverweis auf der Datenseite generiert.

  • Ein neu erstellter Port wird immer so eingerichtet, dass er mithilfe einer COM-Komponente implementiert werden kann.

  • Wenn Sie eine vorhandene Portimplementierung bearbeiten, können Sie auf der ersten Seite des Implementierungs-Assistenten mithilfe der Option Aktuellen Port umbenennen den Portnamen ändern.

Verwandte Themen

Implementieren eines Ports mithilfe einer Windows Script-Komponente

Implementieren eines Ports mithilfe von BizTalk Messaging

Implementieren eines Ports mithilfe von Message Queuing

Implementierungsformen

Implementieren von Geschäftsprozessen

Zuordnen einer bestimmten Nachricht zu einem bestimmten Port

Ändern der Eigenschaften einer Portimplementierung

Grundlegendes zu Portimplementierungen

Verwenden der COM-Komponente-Form

Verwenden des Methodenkommunikations-Assistenten


Implementieren eines Ports mithilfe einer Windows Script-Komponente

  1. Ziehen Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite eine Skriptkomponente-Form von der Implementierung-Schablone auf die rechte Seite der Trennlinie.

    Der Bindungs-Assistent für Skriptkomponenten wird gestartet.

  2. Geben Sie auf der Seite Willkommen beim Bindungs-Assistenten für Skriptkomponenten einen Namen für den neu zu erstellenden Port ein.

    Der BizTalk-Orchestrierungs-Designer setzt für jede neue Portimplementierung einen Standardportnamen ein, dem eine (aktualisierte) Zahl angehängt wird. Sie können diesen Namen ändern.

    Klicken Sie auf Weiter. Weiter mit Schritt 3 in diesem Verfahren.

  3. Klicken Sie auf der Seite Statische oder dynamische Kommunikation auf eine der folgenden Optionen:
    • Statisch

      Die Komponente wird vom XLANG-Ablaufplanungsmodul instanziiert.

      Bei Auswahl der Option Statisch wird die Komponente automatisch gelöscht, wenn die XLANG-Ablaufplaninstanz endet.

      Klicken Sie auf Weiter. Weiter mit Schritt 4 in diesem Verfahren.

    • Dynamisch

      Bei Auswahl dieser Option wird die Komponente von einer anderen Anwendung instanziiert. Ein Moniker oder ein Zeiger auf die Objektinstanz muss an den XLANG-Ablaufplan in Form eines Feldes in einer Nachricht zurückgesendet werden. Auf der Datenseite muss eine Verbindung zwischen diesem Nachrichtenfeld und dem Portverweis auf denjenigen Port gezogen werden, der diese Implementierung verwendet. Weitere Informationen zum Senden einer Nachricht an einen bestimmten Port finden Sie unter Zuordnen einer bestimmten Nachricht zu einem bestimmten Port.

      Klicken Sie auf Weiter. Weiter mit Schritt 4 in diesem Verfahren.

    • Keine Instanziierung

      Wählen Sie diese Option nur für das Empfangen von Daten aus. Diese Option zeigt an, dass Daten mithilfe einer Methode an den XLANG-Ablaufplan weitergereicht werden. Allerdings wird durch den Methodenaufruf kein Code der Methode ausgeführt.

      Klicken Sie auf Weiter. Weiter mit Schritt 4 in diesem Verfahren.

    Weitere Informationen zur statischen und dynamischen Kommunikation finden Sie unter den folgenden Themen:

    • Statische und dynamische Ports

    • Instanzenverwaltung

    • Verwenden der Skriptkomponente-Form
  4. Klicken Sie auf der Seite Skriptdatei angeben auf Durchsuchen.

  5. Suchen Sie im Dialogfeld Skriptdatei auswählen nach dem Verzeichnis, in dem sich die gewünschte WSC-Datei befindet, klicken Sie auf diese Datei und anschließend auf Öffnen.

    Klicken Sie auf Weiter, und setzen Sie den Vorgang mit der Auswahl einer der beiden folgenden Möglichkeiten fort:

    • Wenn Sie in Schritt 3 die Option Statisch gewählt haben, fahren Sie mit Schritt 6 in diesem Verfahren fort.

    • Wenn Sie in Schritt 3 eine der Optionen Dynamisch oder Keine Instanziierung gewählt haben, fahren Sie mit Schritt 7 in diesem Verfahren fort.
  6. Klicken Sie auf der Seite Informationen über Komponenteninstanziierung auf eine der folgenden Optionen:
    • Mit dem Moniker der Skriptdatei

      Als Moniker werden automatisch der Pfad und der Dateiname der Skriptdatei bereitgestellt.

      Klicken Sie auf Weiter. Weiter mit Schritt 7 in diesem Verfahren.

    • Mit Programm-ID "Prog ID"

      Die Programm-ID wird automatisch bereitgestellt und aus dem XML-Code in der Windows Script-Komponentendatei extrahiert. Diese Option wird empfohlen, da auf diese Weise der Pfad für die Skriptdatei nicht festgelegt wird.

      Klicken Sie auf Weiter. Weiter mit Schritt 7 in diesem Verfahren.

  7. Wählen Sie auf der Seite Methodeninformationen die Methoden aus, die Sie verwenden möchten.

    Klicken Sie auf Weiter. Weiter mit Schritt 8 in diesem Verfahren.

    Anmerkungen

    • Wenn die Windows Script-Komponente nur eine Methode besitzt, wird diese Seite übersprungen.

    • Sie müssen mindestens eine Methode auswählen.

    • Es besteht die Möglichkeit, mehrere oder alle Methoden auszuwählen. Mithilfe der Schaltflächen Alle auswählen und Gesamte Auswahl aufheben können Sie alle Methoden auswählen oder diese Auswahl aufheben.
  8. Klicken Sie auf der Seite Erweiterte Porteigenschaften im Bereich Sicherheit auf eine der folgenden Optionen:
    • Nicht erforderlich

      Es wird kein Versuch unternommen, die Identität des Absenders zu bestätigen.

    • Optional

      Das XLANG-Ablaufplanungsmodul fordert Informationen zur Identität des Absenders an. Das XLANG-Ablaufplanungsmodul setzt seine Ausführung unabhängig davon fort, ob die gewünschten Identitätsinformationen vorliegen oder nicht.

    • Erforderlich

      Das XLANG-Ablaufplanungsmodul fordert Informationen zur Identität des Absenders an. Die Identität des Absenders muss bekannt sein und der XLANG-Ablaufplan ignoriert die Nachricht, wenn diese Identitätsinformationen nicht vorliegen.

    Anmerkung

    • Wenn der XLANG-Ablaufplan einen eingehenden Methodenaufruf zurückweist, weil die angeforderte Identifizierung des Absenders nicht vorliegt, wird der Fehlercode E_ACCESSDENIED an den aufrufenden Prozess zurückgegeben.
  9. Klicken Sie auf der Seite Erweiterte Porteigenschaften im Bereich Transaktionsunterstützung auf eine der folgenden Optionen:
    • Deaktiviert

      Die Transaktionsunterstützung für die von dieser Portimplementierung verwendete COM+-Komponente wird deaktiviert.

    • Nicht unterstützt

      Die von dieser Portimplementierung verwendete COM+-Komponente unterstützt keine Transaktionen.

    • Unterstützt

      Die von dieser Portimplementierung verwendete COM+-Komponente erbt eine vorhandene Transaktion.

    • Erforderlich

      Die von dieser Portimplementierung verwendete COM+-Komponente kann eine vorhandene Transaktion erben oder eine neue Transaktion initiieren.

    • Neue Transaktion erforderlich

      Die von dieser Portimplementierung verwendete COM+-Komponente muss eine neue Transaktion initiieren.

  10. Aktivieren oder deaktivieren Sie auf der Seite Erweiterte Porteigenschaften im Bereich Fehlerbehandlung das Kontrollkästchen Transaktion abbrechen, wenn die Methode ein Fehler-HRESULT zurückgibt.

    Wichtig

    • Diese Option bestimmt, ob Transaktionen, an denen die Komponente beteiligt ist, abgebrochen werden sollen, wenn Aufrufe von Methoden der Komponente ein HRESULT-Ergebnis zurückgeben, welches einen Fehler anzeigt.

      Die Option kann nur aktiviert werden, wenn die Kommunikationsaktion, welche diesen Port verwendet, innerhalb des Prozessablaufs einer Transaktion stattfindet.

  11. Klicken Sie auf Fertig stellen.

Wichtig

  • Bei Verwendung von Windows Script-Komponenten müssen die folgenden Regeln beachtet werden:
    • Argumente müssen per Deklaration als Referenzen und nicht als Werte übergeben werden.

    • Es werden keine Microsoft VBScript-Prozeduren, sondern nur Funktionen unterstützt.

    • Innerhalb einer einzelnen WSC-Datei können nicht mehrere Komponenten verwendet werden.

Anmerkungen

  • Formennamen müssen bestimmte Benennungskonventionen erfüllen. Die folgenden Konventionen gelten für Transaktionen, Ports, Nachrichten, Regeln und Felder:
    • Der Name muss ein gültiger XML-Elementname sein. Weitere Informationen zu XML-Elementen finden Sie in der W3C-Website (www.w3.org).

    • Der Name darf nicht mit Unterstrichen (__) beginnen.

    • Der Name darf keinen Doppelpunkt (:) enthalten.

    • Der Name darf maximal 32 Zeichen lang sein.

    • Namen von Konstanten und Nachrichten dürfen nicht mit einem nummerischen Zeichen beginnen.
  • Sie können Portimplementierungen zu Geschäftsprozessseiten, den Seiten Kompensierung für Transaktion und den Seiten Bei Fehler von Transaktion hinzufügen. Auf der Datenseite sind Portimplementierungen nicht verfügbar.

  • Der Datenseite können keine Formen hinzugefügt werden. Für jeden neu erstellten Port wird automatisch ein Portverweis auf der Datenseite generiert.

  • Ein neu erstellter Port wird immer so eingerichtet, dass er mithilfe einer Windows Script-Komponente implementiert werden kann.

  • Wenn Sie eine vorhandene Portimplementierung bearbeiten, können Sie auf der ersten Seite des Implementierungs-Assistenten mithilfe der Option Aktuellen Port umbenennen den Portnamen ändern.

  • Dateien mit Windows Script-Komponenten verwenden die Dateinamenerweiterung WSC. Weitere Informationen zu Windows Script-Komponenten finden Sie in der Windows Scripting Technologies-Website (msdn.microsoft.com/scripting/default.htm). Suchen Sie in der Website nach der Seite Windows Script Components.

  • Windows Script-Komponenten, die vom XLANG-Ablaufplanungsmodul ausgeführt wurden, können erst wieder modifiziert werden, nachdem das XLANG-Ablaufplanungsmodul und der Windows Scripting Host beendet wurden.

Verwandte Themen

Implementieren eines Ports mithilfe einer COM-Komponente

Implementieren eines Ports mithilfe von BizTalk Messaging

Implementieren eines Ports mithilfe von Message Queuing

Implementierungsformen

Implementieren von Geschäftsprozessen

Zuordnen einer bestimmten Nachricht zu einem bestimmten Port

Ändern der Eigenschaften einer Portimplementierung

Grundlegendes zu Portimplementierungen

Verwenden der Skriptkomponente-Form

Verwenden des Methodenkommunikations-Assistenten


Implementieren eines Ports mithilfe von Message Queuing

  1. Ziehen Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite die Message Queuing-Form von der Implementierung-Schablone auf die rechte Seite der Trennlinie.

    Der Bindungs-Assistent für Message Queuing wird gestartet.

  2. Klicken Sie auf der Seite Willkommen beim Bindungs-Assistenten für Message Queuing auf eine der folgenden Optionen:
    • Neuen Port erstellen

      Der BizTalk-Orchestrierungs-Designer setzt für jede neue Portimplementierung einen Standardportnamen ein, dem eine (aktualisierte) Zahl angehängt wird. Sie können diesen Namen ändern.

      Klicken Sie auf Weiter. Weiter mit Schritt 3 in diesem Verfahren.

    • Vorhandener ungebundener Port

      Klicken Sie in der Liste Vorhandener ungebundener Port auf den Port, den Sie verwenden möchten.

      In dieser Liste erscheinen nur die Namen ungebundener Ports. Ein ungebundener Port besitzt keine definierte Implementierung.

      Klicken Sie auf Weiter. Weiter mit Schritt 3 in diesem Verfahren.

  3. Klicken Sie auf der Seite Informationen über statische oder dynamische Warteschlangen auf eine der folgenden Optionen:
    • Statische Warteschlange

      Eine statische Warteschlange ist eine bekannte, vordefinierte, vorhandene Warteschlange. Diese Warteschlange muss bereits zur Entwurfszeit bekannt sein.

      Klicken Sie auf Weiter. Weiter mit Schritt 4 in diesem Verfahren.

    • Dynamische Warteschlange

      Bei Auswahl dieser Option müssen Sie auf der Datenseite eine Verknüpfung zwischen einem Nachrichtenfeld und dem Portverweis auf diesen Port erstellen.

      Der Name der Warteschlange muss von einer anderen Nachricht bereitgestellt werden, bevor die Kommunikationsaktion mithilfe dieser Portimplementierung stattfindet. Weitere Informationen zu den Vorgehensweisen zum Übermitteln einer bestimmte Nachricht an einen bestimmten Port finden Sie unter Zuordnen einer bestimmten Nachricht zu einem bestimmten Port.

      Klicken Sie auf Weiter. Weiter mit Schritt 5 in diesem Verfahren.

    Weitere Informationen zu statischen und dynamischen Warteschlangen finden Sie unter Statische und dynamische Ports.

  4. Klicken Sie auf der Seite Warteschlangeninformationen auf eine der folgenden Optionen:
    • Neue Warteschlange für jede Instanz erstellen

      Sie müssen der Warteschlange ein Präfix zuweisen. Beispielsweise: .\Private$\PrivateQueuePrefix oder .\PublicQueuePrefix. Für jede neu erstellte Warteschlange wird an das Präfix eine eindeutige Kennung angehängt.

      Es gibt einen Standardnamen für dieses Warteschlangenpräfix. Sie können diesen Standardnamen ändern.

      Soll jemand in die Lage versetzt werden, über diesen Port zu antworten, muss ihm ein Verweis auf den Port in einer Nachricht übermittelt werden. Wählen Sie zu diesem Zweck die Option Neue Warteschlange für jede Instanz erstellen aus, und geben Sie einen Stammnamen für die Warteschlangen ein. Zur Laufzeit erstellt das XLANG-Ablaufplanungsmodul eine neue Warteschlange mit diesem Stammnamen für jede Instanz. Für jede neu erstellt Warteschlange wird dem Stammnamen eine Instanz-GUID angehängt. Diese Warteschlange wird gelöscht, sobald die Instanz endet.

      Wenn Sie keinen Verweis auf diesen Port versenden wollen, gibt es auch keine Notwendigkeit dafür, zu jeder Instanz eine Warteschlange zu erzeugen. Sie können in diesem Fall eine Warteschlange erzeugen, die für alle Instanzen verwendet wird.

      Klicken Sie auf Weiter. Weiter mit Schritt 5 in diesem Verfahren.

    • Bekannte Warteschlange für alle Instanzen verwenden

      Geben Sie den Namen einer bekannten, vordefinierten und vorhandenen Warteschlange ein. Beispielsweise: ".\private$\queuename"

      Klicken Sie auf Weiter. Weiter mit Schritt 5 in diesem Verfahren.

  5. Klicken Sie auf der Seite Erweiterte Porteigenschaften im Bereich Sicherheit auf eine der folgenden Optionen:
    • Nicht erforderlich

      Es wird kein Versuch unternommen, die Identität des Absenders zu bestätigen. Der XLANG-Ablaufplan empfängt jede Nachricht mit einem leeren Absenderfeld (__Sender__). Dabei spielt es keine Rolle, ob die Nachricht authentifiziert wurde oder nicht.

    • Optional

      Das XLANG-Ablaufplanungsmodul fordert Informationen zur Bestätigung der Identität des Absenders an. Der XLANG-Ablaufplan empfängt eine Nachricht unabhängig davon, ob die Nachricht authentifiziert wurde oder nicht. Wenn die Nachricht authentifiziert wurde, enthält das Feld __Sender__ den Wert der SenderID-Eigenschaft der Message Queuing-Nachricht.

    • Erforderlich

      Das XLANG-Ablaufplanungsmodul fordert Informationen zur Bestätigung der Identität des Absenders an. Die Bestätigung der Absenderidentität ist notwendig. Wenn die Nachricht authentifiziert wurde, empfängt der XLANG-Ablaufplan die Nachricht und das Feld __Sender__ enthält den Wert der SenderID-Eigenschaft der Message Queuing-Nachricht.

      Wird die Nachricht nicht authentifiziert, wird ein Eintrag im Anwendungs-Ereignisprotokoll hinzugefügt, und die Nachricht wird in eine andere Warteschlange verschoben, die neu erstellt und mit dem Namen .\private$\Anwendungsname.DeadLetter versehen wird.

  6. Aktivieren oder deaktivieren Sie auf der Seite Erweiterte Porteigenschaften im Bereich Sicherheit das Kontrollkästchen Zum Steuern der Warteschlange eine Windows-Gruppe oder einen Benutzernamen verwenden.

    Bei Aktivierung des Kontrollkästchens müssen Sie den Namen des Benutzers oder der Gruppe eingeben, für den oder die die Berechtigung gegeben ist, Nachrichten in die Warteschlange zu stellen. Diese Option ist nur bei Verwendung einer statischen Warteschlange verfügbar.

  7. Aktivieren oder deaktivieren Sie auf der Seite Erweiterte Porteigenschaften im Bereich Transaktionsunterstützung das Kontrollkästchen Für diese Warteschlage sind Transaktionen erforderlich.

  8. Klicken Sie auf Fertig stellen.

Anmerkungen

  • Formennamen müssen bestimmte Benennungskonventionen erfüllen. Die folgenden Konventionen gelten für Transaktionen, Ports, Nachrichten, Regeln und Felder:
    • Der Name muss ein gültiger XML-Elementname sein. Weitere Informationen zu XML-Elementen finden Sie in der W3C-Website (www.w3.org).

    • Der Name darf nicht mit Unterstrichen (__) beginnen.

    • Der Name darf keinen Doppelpunkt (:) enthalten.

    • Der Name darf maximal 32 Zeichen lang sein.

    • Namen von Konstanten und Nachrichten dürfen nicht mit einem nummerischen Zeichen beginnen.
  • Sie können Portimplementierungen zu Geschäftsprozessseiten, den Seiten Kompensierung für Transaktion und den Seiten Bei Fehler von Transaktion hinzufügen. Auf der Datenseite sind Portimplementierungen nicht verfügbar.

  • Der Datenseite können keine Formen hinzugefügt werden. Für jeden neu erstellten Port wird automatisch ein Portverweis auf der Datenseite generiert.

  • Wenn Sie eine vorhandene Portimplementierung bearbeiten, können Sie auf der ersten Seite des Implementierungs-Assistenten mithilfe der Option Aktuellen Port umbenennen den Portnamen ändern.

Verwandte Themen

Implementieren eines Ports mithilfe einer COM-Komponente

Implementieren eines Ports mithilfe einer Windows Script-Komponente

Implementieren eines Ports mithilfe von BizTalk Messaging

Implementierungsformen

Implementieren von Geschäftsprozessen

Zuordnen einer bestimmten Nachricht zu einem bestimmten Port

Ändern der Eigenschaften einer Portimplementierung

Grundlegendes zu Portimplementierungen

Verwenden der Message Queuing-Form

Verwenden des Assistenten für XML-Kommunikation


Implementieren eines Ports mithilfe von BizTalk Messaging

  1. Ziehen Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite die BizTalk-Messaging-Form von der Implementierung-Schablone auf die rechte Seite der Trennlinie.

    Der BizTalk-Bindungs-Assistent für Messaging wird gestartet.

  2. Klicken Sie auf der Seite Willkommen beim BizTalk-Bindungs-Assistenten für Messaging auf eine der folgenden Optionen:
    • Neuen Port erstellen

      Der BizTalk-Orchestrierungs-Designer setzt für jede neue Portimplementierung einen Standardportnamen ein, dem eine (aktualisierte) Zahl angehängt wird. Sie können diesen Namen ändern.

      Klicken Sie auf Weiter. Weiter mit Schritt 3 in diesem Verfahren.

    • Vorhandener ungebundener Port

      Klicken Sie in der Liste Vorhandener ungebundener Port auf den Port, den Sie verwenden möchten.

      In dieser Liste erscheinen nur die Namen ungebundener Ports. Ein ungebundener Port besitzt keine definierte Implementierung.

      Klicken Sie auf Weiter. Weiter mit Schritt 3 in diesem Verfahren.

  3. Klicken Sie auf der Seite Kommunikationsrichtung auf eine der folgenden Optionen:
    • Senden

      Klicken Sie auf Weiter. Weiter mit Schritt 4 in diesem Verfahren.

    • Empfangen

      Klicken Sie auf Weiter. Weiter mit Schritt 5 in diesem Verfahren.

    Anmerkung

    • Bei Auswahl der Option Empfangen ist es möglich, Nachrichten zu empfangen. Dies kann mithilfe eines HTTP-URLs als Zieladresse oder mithilfe eines von BizTalk-Messaging-Manager konfigurierten Messagingports geschehen, über den ein XLANG-Ablaufplan instanziiert wird, um an einen bestimmten Port dieses Ablaufplanes Nachrichten senden zu können. Weitere Informationen zum Empfangen von Nachrichten mithilfe eines HTTP-URLs finden Sie unter Integrieren der BizTalk-Dienste. Weitere Informationen zum Konfigurieren eines Messagingports mithilfe von BizTalk-Messaging-Manager finden Sie unter Festlegen von Eigenschaften für die Zielanwendung.
  4. Klicken Sie auf der Seite Informationen über statische oder dynamische Kanäle auf eine der folgenden Optionen:
    • Statischer Kanal

      Geben Sie den Namen eines bekannten, vordefinierten, vorhandenen Kanals ein. Klicken Sie auf Fertig stellen.

    • Dynamischer Kanal

      Bei Auswahl dieser Option müssen Sie den Port so konfigurieren, dass er die Daten bereitstellt, die die BizTalk-Messaging-Dienste zur Laufzeit zur Identifizierung des richtigen Kanals für die Nachrichtenverarbeitung benötigen.

      Zusätzlich müssen Sie auf der Datenseite eine Verknüpfung zwischen einem Nachrichtenfeld einer zuvor empfangenen Nachricht und dem Portverweis auf diesen Port erstellen. Das Nachrichtenfeld muss eine Zieladresse enthalten, die die BizTalk-Messaging-Dienste als Zieladresse für einen offenen Messagingport verwenden können, der mit dem erwähnten Kanal verknüpft ist. Weitere Informationen finden Sie unter Integrating BizTalk Services.

      Um den Kommunikationsfluss zwischen einer Aktion und diesem Port einzurichten, verwenden Sie den Assistenten für XML-Kommunikation. Sie müssen auf der Seite Informationen über den Nachrichtentyp im Feld Nachrichtentyp den Namen der dem Kanal zugeordneten Dokumentdefinition für eingehende Dokumente eingeben. Die BizTalk-Messaging-Dienste verwenden diese Angabe, um den richtigen Kanal zur Verarbeitung der Nachricht zu bestimmen. Weitere Informationen finden Sie unter Identifikation.

      Klicken Sie auf Fertig stellen.

    Wichtig

    • Es muss mindestens einen mithilfe der BizTalk Messaging-Dienste konfigurierten Kanal geben, der die angegebene Dokumentdefinition für eingehende Dokumente verwendet. Wenn eine Aktion mit einem über BizTalk-Messaging gebundenen Port kommuniziert und der für diese Bindung angegebene Kanal nicht existiert, endet die XLANG-Ablaufplaninstanz mit einem Fehler und einem Eintrag im Ereignisprotokoll.

    • Es sollte nur einen mithilfe der BizTalk-Messaging-Dienste konfigurierten Kanal geben, der die angegebene Dokumentdefinition für eingehende Dokumente verwendet und für den XLANG-Ablaufplan als Quelle konfiguriert worden ist. Weitere Informationen finden Sie unter Festlegen von Eigenschaften für die Quellanwendung. Jener Kanal muss außerdem mit einem offenen Messagingport verknüpft sein. Wenn eine Aktion mit einem über BizTalk-Messaging gebundenen Port kommuniziert, und es existieren für diese Bindung mehrere Kanäle, endet die XLANG-Ablaufplaninstanz ebenfalls mit einem Fehler und einem Eintrag im Ereignisprotokoll.
  5. Klicken Sie auf der Seite Informationen über die XLANG-Ablaufplanaktivierung auf eine der folgenden Optionen:
    • Ja

      Dieser Port kann nicht in mehreren Empfangsaktionen gleichzeitig oder innerhalb einer einzelnen Empfangsaktion in einer Schleife verwendet werden.

      Klicken Sie auf Fertig stellen.

    • Nein

      Klicken Sie auf Weiter. Weiter mit Schritt 6 in diesem Verfahren.

  6. Geben Sie auf der Seite Kanalinformationen in das Feld Kanalname den Namen des Kanals ein, den Sie verwenden möchten. Weitere Informationen zu Kanälen finden Sie unter den Themen Grundlegendes zu Kanälen und Suchen nach Kanälen.

  7. Geben Sie auf der Seite Kanalinformationen in das Feld HTTP-URL-Adresse, über die der BizTalk-Messagingdienst Dokumente empfängt den URL ein, über den BizTalk Server die Dokumente für diesen Kanal empfängt.

  8. Klicken Sie auf Fertig stellen.

Wichtig

  • Wird ein Port per Konfigurierung veranlasst, beim Eintreffen einer Nachricht einen neuen XLANG-Ablaufplan zu aktivieren, sind dabei die folgenden Einschränkungen zu beachten:
    • Nur ein Port eines Ablaufplanes kann dazu verwendet werden, den Ablaufplan beim Eintreffen der Nachricht zu aktivieren.

    • Nur eine Aktion kann über diesen Port empfangen.

    • Diese eine Aktion darf sich nicht in einer Schleife befinden.

    • Es ist nicht möglich, eine Datenflussverbindung vom Portverweis auf diesen Port zu einer anderen Nachricht im Ablaufplan zu ziehen.

Anmerkungen

  • Formennamen müssen bestimmte Benennungskonventionen erfüllen. Die folgenden Konventionen gelten für Transaktionen, Ports, Nachrichten, Regeln und Felder:
    • Der Name muss ein gültiger XML-Elementname sein. Weitere Informationen zu XML-Elementen finden Sie in der W3C-Website (www.w3.org).

    • Der Name darf nicht mit Unterstrichen (__) beginnen.

    • Der Name darf keinen Doppelpunkt (:) enthalten.

    • Der Name darf maximal 32 Zeichen lang sein.

    • Namen von Konstanten und Nachrichten dürfen nicht mit einem nummerischen Zeichen beginnen.
  • Sie können Portimplementierungen zu Geschäftsprozessseiten, den Seiten Kompensierung für Transaktion und den Seiten Bei Fehler von Transaktion hinzufügen. Auf der Datenseite sind Portimplementierungen nicht verfügbar.

  • Der Datenseite können keine Formen hinzugefügt werden. Für jeden neu erstellten Port wird automatisch ein Portverweis auf der Datenseite generiert.

  • Wenn Sie eine vorhandene Portimplementierung bearbeiten, können Sie auf der ersten Seite des Implementierungs-Assistenten mithilfe der Option Aktuellen Port umbenennen den Portnamen ändern.

Verwandte Themen

Implementieren eines Ports mithilfe einer COM-Komponente

Implementieren eines Ports mithilfe einer Windows Script-Komponente

Implementieren eines Ports mithilfe von Message Queuing

Implementierungsformen

Implementieren von Geschäftsprozessen

Integrieren der BizTalk-Dienste

Zuordnen einer bestimmten Nachricht zu einem bestimmten Port

Ändern der Eigenschaften einer Portimplementierung

Suchen nach Kanälen

Grundlegendes zu Kanälen

Grundlegendes zu Portimplementierungen

Verwenden der BizTalk-Messaging-Form

Verwenden des Assistenten für XML-Kommunikation


Ändern der Eigenschaften einer Portimplementierung

  1. Klicken Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite mit der rechten Maustaste auf eine Implementierungsform, die Sie ändern möchten.

  2. Klicken Sie auf Eigenschaften.

    Der Assistent für die gewählte Implementierungsform wird gestartet.

  3. Folgen Sie den Anweisungen des Assistenten, und nehmen Sie die gewünschten Änderungen an den Eigenschaften vor.

Anmerkungen

  • Sie können jede Portimplementierung auf den Geschäftsprozessseiten, den Seiten Kompensierung für Transaktion und den Seiten Bei Fehler von Transaktion ändern. Auf der Datenseite sind Portimplementierungen nicht verfügbar.

  • Der Datenseite können keine Formen hinzugefügt werden. Für jeden neu erstellten Port wird automatisch ein Portverweis auf der Datenseite generiert.

  • Sie können auf der ersten Seite des Implementierungs-Assistenten mithilfe der Option Aktuellen Port umbenennen den Portnamen ändern.

Verwandte Themen

Implementieren eines Ports mithilfe einer COM-Komponente

Implementieren eines Ports mithilfe einer Windows Script-Komponente

Implementieren eines Ports mithilfe von BizTalk Messaging

Implementieren eines Ports mithilfe von Message Queuing

Implementierungsformen

Implementieren von Geschäftsprozessen


Senden oder Empfangen von Nachrichten

Der BizTalk-Orchestrierungs-Designer stellt zwei Formen der Kommunikation zur Verfügung, mit deren Hilfe ein XLANG-Ablaufplan das Senden und Empfangen von Nachrichten bewerkstelligen kann:

  • Synchrone Kommunikation. Hierbei werden Methodenaufrufe verwendet, um Nachrichtenpaare synchron zu senden oder zu empfangen.

  • Asynchrone Kommunikation. Hierbei werden XML-Nachrichten verwendet, um einzelne Nachrichten asynchron zu senden oder zu empfangen.

Weitere Informationen finden Sie unter Synchrone und asynchrone Kommunikation.

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Einrichten des Kommunikationsflusses zwischen einer Aktion und einem Port

  • Senden oder Empfangen synchroner Nachrichten

  • Senden oder Empfangen asynchroner Nachrichten

  • Ändern des Kommunikationsflusses zwischen einer Aktion und einem Port

Verwandte Themen

Synchrone und asynchrone Kommunikation

Verwenden des Methodenkommunikations-Assistenten

Verwenden des Assistenten für XML-Kommunikation


Einrichten des Kommunikationsflusses zwischen einer Aktion und einem Port

  1. Klicken Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite auf eine Aktion-Form, um sie zu markieren.

  2. Ziehen Sie das rechte Kontrollhandle ( Kontrollhandle) der Aktion-Form auf den Verbindungspunkt ( Verbindungspunkt) einer Port-Form.

    Ein Kommunikations-Assistent wird gestartet.

  3. Fahren Sie je nach Art des zu erstellenden Kommunikationsflusses mit einem der folgenden Verfahren fort.
    • Wenn Sie einen synchronen Kommunikationsfluss zu einem Port erstellen möchten, der eine COM-Komponenten- oder Skriptkomponenten-Implementierung verwendet, müssen Sie den Methodenkommunikations-Assistent verwenden. Weiter mit Senden oder Empfangen synchroner Nachrichten.

    • Wenn Sie einen asynchronen Kommunikationsfluss zu einem Port erstellen möchten, der eine Message Queuing- oder BizTalk-Messaging-Implementierung verwendet, oder wenn Sie einen asynchronen Kommunikationsfluss zu einem ungebundenen Port erstellen möchten, müssen Sie den Assistent für XML-Kommunikation verwenden. Weiter mit Senden oder Empfangen asynchroner Nachrichten.

Anmerkungen

  • Sie können auch das Verbindungstool verwenden, um Formen miteinander zu verbinden. Weitere Informationen finden Sie unter Verwenden des Verbindungstools.

  • Sie können einen Kommunikationsfluss zwischen einer Aktion und einem Port auf jeder Geschäftsprozessseite, den Seiten Kompensierung für Transaktion und den Seiten Bei Fehler von Transaktion einrichten. Auf der Datenseite sind Aktionen und Ports nicht verfügbar.

  • Der Datenseite können keine Formen hinzugefügt werden. Jedes Mal, wenn eine Aktion mit einem Port verbunden wird, werden automatisch neue Nachrichten auf der Datenseite generiert.


Senden oder Empfangen synchroner Nachrichten

Nachdem Sie im BizTalk-Orchestrierungs-Designer einen Kommunikationsfluss zwischen einer Aktion und einem Port für eine synchrone Kommunikation eingerichtet haben, wird der Methodenkommunikations-Assistent gestartet. Weitere Informationen zum Einrichten eines Kommunikationsflusses finden Sie unter Einrichten des Kommunikationsflusses zwischen einer Aktion und einem Port.

  1. Klicken Sie auf der Seite Willkommen beim Methodenkommunikations-Assistenten auf eine der folgenden Optionen:
    • Synchronen Methodenaufruf initiieren

      Das XLANG-Ablaufplanungsmodul initiiert einen synchronen Methodenaufruf.

      In diesem Fall sendet das XLANG-Ablaufplanungsmodul einen Methodenaufruf an eine Komponente, wartet auf eine Antwort der Komponente und empfängt anschließend eine Antwort.

      Klicken Sie auf Weiter. Weiter mit Schritt 3 in diesem Verfahren.

    • Auf synchronen Methodenaufruf warten

      Das XLANG-Ablaufplanungsmodul wartet auf einen Methodenaufruf, der von einer anderen Anwendung initiiert wird.

      In diesem Fall wartet das XLANG-Ablaufplanungsmodul darauf, dass eine andere Anwendung den Methodenaufruf initiiert. Diese andere Anwendung sendet einen Methodenaufruf an eine Komponente. Das XLANG-Ablaufplanungsmodul wartet auf eine Antwort der Komponente und meldet seinerseits eine Antwort an die Anwendung zurück. Der XLANG-Ablaufplan empfängt sowohl den Methodenaufruf als auch die Antwort der Methode.

      Weiter mit Schritt 2 in diesem Verfahren.

  2. Um die Ausführung eines XLANG-Ablaufplanes zu optimieren, geben Sie auf der Seite Willkommen beim Methodenkommunikations-Assistenten die Zeit in Sekunden ein, die das XLANG-Ablaufplanungsmodul auf das Eintreffen einer Nachricht warten soll.

    Der Standardwert für diese Wartezeit ist 0 Sekunden. Sie können diesen Wert ändern. Jede Zeitangabe von nicht mehr als 180 Sekunden führt dazu, dass der XLANG-Ablaufplan keine Pause macht. Jede Zeitangabe von mehr als 180 Sekunden führt dazu, dass der XLANG-Ablaufplan sofort pausiert. Weitere Informationen zu Wartezeiten und dem Pausieren eines XLANG-Ablaufplanes finden Sie unter den Themen Pausierung und Aktivierung und Verwenden des Methodenkommunikations-Assistenten.

    Klicken Sie auf Weiter. Weiter mit Schritt 3 in diesem Verfahren.

  3. Klicken Sie auf der Seite Nachrichteninformationen auf eine der folgenden Optionen:
    • Neue Nachricht erstellen

      Der Name dieser Nachricht wird automatisch von der Methode bestimmt, die Sie auf der nächsten Seite dieses Assistenten auswählen. Der Datenfluss für eine neue Nachricht muss mit anderen Nachrichten auf der Datenseite verbunden sein.

      Klicken Sie auf Weiter. Weiter mit Schritt 4 in diesem Verfahren.

    • Verweis für ein vorhandenes synchrones Nachrichtenpaar hinzufügen

      Dem Kommunikationsfluss wird ein Verweis auf ein zuvor konfiguriertes Nachrichtenpaar hinzugefügt. Diese Nachrichtenpaare können nur innerhalb desselben Ports wiederverwendet werden. Sie können nicht von einer anderen Portimplementierung verwendet werden

      Klicken Sie auf Fertig stellen.

  4. Klicken Sie auf der Seite Informationen über die Nachrichtenspezifikation in der Liste Methoden auf die Methode, die Sie verwenden möchten. Es kann immer nur eine Methode in der Liste ausgewählt werden.

    Die Auswahl einer Methode definiert die Nachrichten für diesen Kommunikationsfluss. Die Ein- und Ausgabeparameter werden automatisch durch die Parameteranforderungen der von Ihnen ausgewählten Methode bestimmt. Beide Parameterlisten enthalten jeweils den Namen und Datentyp des Parameters.

    Weitere Informationen zum Festlegen der in einem Kommunikationsfluss verwendeten Nachrichten finden Sie unter Synchrone Kommunikation.

  5. Klicken Sie auf Fertig stellen.

Anmerkungen

  • Formennamen müssen bestimmte Benennungskonventionen erfüllen. Die folgenden Konventionen gelten für Transaktionen, Ports, Nachrichten, Regeln und Felder:
    • Der Name muss ein gültiger XML-Elementname sein. Weitere Informationen zu XML-Elementen finden Sie in der W3C-Website (www.w3.org).

    • Der Name darf nicht mit Unterstrichen (__) beginnen.

    • Der Name darf keinen Doppelpunkt (:) enthalten.

    • Der Name darf maximal 32 Zeichen lang sein.

    • Namen von Konstanten und Nachrichten dürfen nicht mit einem nummerischen Zeichen beginnen.
  • Die Eigenschaft zur Festlegung der Wartezeit ist nicht aktiviert, sofern Sie nicht auf die Option Auf synchronen Methodenaufruf warten klicken.

  • Die einzigen Methoden, die für eine synchrone Kommunikation verfügbar sind, sind diejenigen, die für die Portimplementierung ausgewählt wurden. Methoden anderer Portimplementierungen können nicht verwendet werden. Auch XML-Nachrichten von asynchronen Kommunikationsflüssen können nicht verwendet werden. Um andere Methoden zur Verfügung zu haben, müssen Sie den geeigneten Assistenten für die Portimplementierung erneut ausführen und andere Methoden auswählen.

  • Beim Einrichten einer synchronen Kommunikation wird eine Nachricht auf der Datenseite erstellt. Diese Nachricht entspricht den Methoden und Parametern, die in dem Kommunikationsfluss verwendet werden. Die Nachricht enthält alle Eingabe- und Ausgabeparameter der Methode.

    Es ist durchaus möglich, dass eine Methode keine Parameter besitzt. Allerdings sind in der entsprechenden Nachricht immer die erforderlichen Systemfelder enthalten. Weitere Informationen zum Festlegen der bei einer synchronen Kommunikation verwendeten Nachrichten finden Sie unter Synchrone Kommunikation.

Verwandte Themen

Pausierung und Aktivierung

Einrichten des Kommunikationsflusses zwischen einer Aktion und einem Port

Implementieren von Ports

Senden oder Empfangen asynchroner Nachrichten

Synchrone Kommunikation

Verwenden des Methodenkommunikations-Assistenten

Verwenden des Assistenten für XML-Kommunikation


Senden oder Empfangen asynchroner Nachrichten

  1. Klicken Sie auf der Seite Willkommen beim Assistenten für XML-Kommunikation auf eine der folgenden Optionen:
    • Senden

      Eine Nachricht wird asynchron versendet.

      Klicken Sie auf Weiter. Weiter mit Schritt 3 in diesem Verfahren.

    • Empfangen

      Das XLANG-Ablaufplanungsmodul setzt die Ausführung des XLANG-Ablaufplanes erst nach Empfang einer Nachricht fort.

      Weiter mit Schritt 2 in diesem Verfahren.

  2. Um die Ausführung eines XLANG-Ablaufplanes zu optimieren, geben Sie auf der Seite Willkommen beim Assistenten für XML-Kommunikation die Zeit in Sekunden ein, die das XLANG-Ablaufplanungsmodul auf das Eintreffen einer Nachricht warten soll.

    Der Standardwert für diese Wartezeit ist 0 Sekunden. Sie können diesen Wert ändern. Jede Zeitangabe von nicht mehr als 180 Sekunden führt dazu, dass der XLANG-Ablaufplan keine Pause macht. Jede Zeitangabe von mehr als 180 Sekunden führt dazu, dass der XLANG-Ablaufplan sofort pausiert. Weitere Informationen zu Wartezeiten und dem Pausieren eines XLANG-Ablaufplanes finden Sie unter den Themen Pausierung und Aktivierung und Verwenden des Assistenten für XML-Kommunikation.

    Klicken Sie auf Weiter. Weiter mit Schritt 3 in diesem Verfahren.

  3. Klicken Sie auf der Seite Nachrichteninformationen auf eine der folgenden Optionen:
    • Neue Nachricht erstellen

      Geben Sie in das Feld Nachrichtenname den Namen für die neue Nachricht ein. Für die Nachricht wird ein Standardname bereitgestellt, dem eine Zahl angehängt ist. Sie können diesen Namen jedoch ändern.

      Der Datenfluss für eine neue Nachricht muss mit anderen Nachrichten auf der Datenseite verbunden sein.

    • Verweis zu einer vorhandenen Nachricht hinzufügen

      Dem Kommunikationsfluss wird ein Verweis auf eine zuvor konfigurierte Nachricht hinzugefügt.

    Klicken Sie auf Weiter, und führen Sie einen der folgenden Schritte aus:

    • Wenn Sie auf der Seite Willkommen beim Assistenten für XML-Kommunikation die Option Senden ausgewählt haben, fahren Sie mit Schritt 4 in diesem Verfahren fort.

    • Wenn Sie auf der Seite Willkommen beim Assistenten für XML-Kommunikation die Option Empfangen ausgewählt haben, fahren Sie mit Schritt 6 in diesem Verfahren fort.
  4. Klicken Sie auf der Seite Informationen über die XML-Konvertierung auf eine der folgenden Optionen:
    • Nachrichten im XML-Format an die Warteschlange senden

    • Nachrichten als Zeichenfolge an die Warteschlange senden

      Das XLANG-Ablaufplanungsmodul muss in diesem Fall die Informationen des XML-Standardwrappers aus der Zeichenfolge entfernen.

    Der Datenfluss wird im XLANG-Ablaufplanungsmodul mithilfe von XML verarbeitet. Das Modul sendet selbsttätig XML-Nachrichten an Nachrichtenwarteschlangen. Das Modul ist auch in der Lage, eine Nachricht als Zeichenfolge zu senden, aus der es jedoch zuvor die Informationen des XML-Standardwrappers entfernen muss. Der Datenfluss muss eine Nachricht im richtigen Spezifikationsformat für diese Aktion übergeben.

    Wenn Sie sich dafür entscheiden, eine XML-Nachricht als Zeichenfolge zu versenden oder zu empfangen, enthält die für diese Nachricht auf der Datenseite generierte Nachrichten-Form ein Feld namens StringData, und Sie können dieser Nachricht keine anderen Spezifikationsfelder hinzufügen.

    Klicken Sie auf Weiter. Weiter mit Schritt 5 in diesem Verfahren.

  5. Geben Sie auf der Seite Informationen über den Nachrichtentyp in das Feld Nachrichtentyp eine Bezeichnung für die Nachricht ein.

    Der von Ihnen eingegebene Text wird zum Bezeichnen der Nachricht verwendet, sobald sie zur Warteschlange gesendet wird.

    Um fortzufahren, wählen Sie eine der folgenden Möglichkeiten:

    • Wenn Sie auf der Seite Informationen über die XML-Konvertierung die Option Nachrichten im XML-Format an die Warteschlange senden ausgewählt haben, klicken Sie auf Weiter. Weiter mit Schritt 8 in diesem Verfahren.

    • Wenn Sie auf der Seite Informationen über die XML-Konvertierung die Option Nachrichten als Zeichenfolge an die Warteschlange senden ausgewählt haben, klicken Sie auf Fertig stellen.
  6. Klicken Sie auf der Seite Informationen über die XML-Konvertierung auf eine der folgenden Optionen:
    • Nachrichten in der Warteschlange als XML-Nachrichten empfangen

    • Nachrichten in der Warteschlange als Zeichenfolgen empfangen

      Das XLANG-Ablaufplanungsmodul muss in diesem Fall die Zeichenfolge um die Informationen des XML-Standardwrappers ergänzen.

    Der Datenfluss wird im XLANG-Ablaufplanungsmodul mithilfe von XML verarbeitet. Das Modul empfängt selbsttätig XML-Nachrichten von Nachrichtenwarteschlangen. Das Modul ist auch in der Lage, eine Nachricht als Zeichenfolge zu empfangen, die es jedoch zuvor um die Informationen des XML-Standardwrappers ergänzen muss.

    Klicken Sie auf Weiter. Weiter mit Schritt 7 in diesem Verfahren.

  7. Geben Sie auf der Seite Informationen über den Nachrichtentyp in das Feld Nachrichtentyp eine Bezeichnung für die Nachricht ein.

    Der von Ihnen eingegebene Text wird zur Identifizierung der Nachrichten verwendet, welche von der Warteschlange empfangen werden sollen.

    Zuerst versucht das XLANG-Ablaufplanungsmodul, eine Übereinstimmung zwischen den Informationen zum Nachrichtentyp und der Nachrichtenbezeichnung in der Warteschlange zu finden.

    Sofern die Nachricht im XML-Format in der Warteschlange vorliegt, versucht das XLANG-Ablaufplanungsmodul als Nächstes, die Informationen zum Nachrichtentyp mit dem XML-Stammelement der Nachricht in der Warteschlange in Übereinstimmung zu bringen.

    Um fortzufahren, wählen Sie eine der folgenden Möglichkeiten:

    • Wenn Sie auf der Seite Informationen über die XML-Konvertierung die Option Nachrichten in der Warteschlange als XML-Nachrichten empfangen ausgewählt haben, klicken Sie auf Weiter. Weiter mit Schritt 8 in diesem Verfahren.

    • Wenn Sie auf der Seite Informationen über die XML-Konvertierung die Option Nachrichten in der Warteschlange als Zeichenfolgen empfangen ausgewählt haben, klicken Sie auf Fertig stellen.
  8. Klicken Sie auf der Seite Informationen über die Nachrichtenspezifikation auf Durchsuchen.

  9. Suchen Sie im Dialogfeld Nach Spezifikation durchsuchen nach der Spezifikation, die Sie verwenden möchten, klicken Sie auf die Spezifikation und anschließend auf Öffnen.

    Geben Sie auf der Seite Informationen über die Nachrichtenspezifikation in das Feld Nachrichtenspezifikation den Pfad und den Dateinamen der Spezifikation ein, die Sie ausgewählt haben.

    Anmerkungen

    • Wenn Sie nicht nach einer vorhandenen Spezifikation suchen, können Sie auf Erstellen klicken. Dieser Vorgang öffnet den BizTalk-Editor, der es Ihnen ermöglicht, eine Spezifikation auszuwählen und nach Bedarf zu modifizieren, um sie für diese Nachricht verwenden zu können, oder eine neue Spezifikation zu erstellen.

    • Wenn Sie eine Spezifikation per Durchsuchen ausgewählt haben, ändert sich die Beschriftung der Schaltfläche Erstellen in Bearbeiten. Klicken Sie auf Bearbeiten, um die ausgewählte Spezifikation zu modifizieren.
  10. Wenn Sie die Gültigkeit der Nachricht anhand ihrer Spezifikation überprüfen möchten, aktivieren Sie auf der Seite Informationen über die Nachrichtenspezifikation das Kontrollkästchen Nachrichten anhand der Spezifikation überprüfen.

    Anmerkung

    • Dieses Kontrollkästchen ist nur dann verfügbar, wenn Sie eine Spezifikation ausgewählt haben, die für eine Überprüfung verwendet werden kann.
  11. Klicken Sie auf der Seite Informationen über die Nachrichtenspezifikation auf Hinzufügen, wenn Sie der Liste Nachrichtenfelder weitere Felder hinzufügen möchten.

    Wichtig

    • Wenn Sie zusätzliche Felder für diese Nachrichtenspezifikation auswählen möchten, müssen Sie eine Spezifikation verwenden, die mithilfe des BizTalk-Editors erstellt wurde. Sie können jeden Standard und jedes Schema anpassen, indem Sie die entsprechende Datei zuerst in den BizTalk-Editor importieren und sie anschließend als BizTalk-Spezifikation speichern. Weitere Informationen finden Sie unter Erstellen und Überprüfen von Spezifikationen.
  12. Erweitern Sie im Dialogfeld Feldauswahl in der Strukturansicht Auswahlknoten alle erforderlichen Knoten, und klicken Sie anschließend auf das Feld, das Sie hinzufügen möchten. Klicken Sie auf OK.

    Anmerkungen

    • Wenn Sie auf ein Feld in der Strukturansicht Auswahlknoten klicken, wird der Name des Feldes automatisch dem Feld Feldname hinzugefügt.

    • Wenn Sie auf ein Feld in der Strukturansicht Auswahlknoten klicken, wird der Knotenpfad des Feldes automatisch dem Feld Knotenpfad hinzugefügt. Dieser Pfad kann manuell bearbeitet werden. Weitere Informationen finden Sie unter Knotenpfadfelder.

    • Es ist nicht möglich, einen Datensatzknoten auszuwählen, um ihn der Liste Nachrichtenfelder hinzuzufügen. Es können nur Felder ausgewählt werden. Weitere Informationen finden Sie unter Knotenpfadfelder.

    • Um der Liste Nachrichtenfelder mehrere Felder hinzuzufügen, müssen Sie im Dialogfeld Feldauswahl ein Feld auswählen und anschließend auf OK klicken. Klicken Sie auf der Seite Informationen über die Nachrichtenspezifikation auf Hinzufügen, und wiederholen Sie den Vorgang, um ein weiteres Feld hinzuzufügen.
  13. Wenn Sie Felder aus der Liste Nachrichtenfelder auf der Seite Informationen über die Nachrichtenspezifikation entfernen möchten, klicken Sie in der genannten Liste auf ein Feld und anschließend auf Entfernen.

    Anmerkung

    • Erforderliche Felder können nicht gelöscht werden. Solche erforderlichen Felder werden in der Liste Nachrichtenfelder mit einem gelben Hintergrund dargestellt.
  14. Klicken Sie auf Fertig stellen.

Anmerkungen

  • Formennamen müssen bestimmte Benennungskonventionen erfüllen. Die folgenden Konventionen gelten für Transaktionen, Ports, Nachrichten, Regeln und Felder:
    • Der Name muss ein gültiger XML-Elementname sein. Weitere Informationen zu XML-Elementen finden Sie in der W3C-Website (www.w3.org).

    • Der Name darf nicht mit Unterstrichen (__) beginnen.

    • Der Name darf keinen Doppelpunkt (:) enthalten.

    • Der Name darf maximal 32 Zeichen lang sein.

    • Namen von Konstanten und Nachrichten dürfen nicht mit einem nummerischen Zeichen beginnen.
  • Die Eigenschaft zur Festlegung der Wartezeit ist nicht aktiviert, sofern Sie nicht auf die Option Empfangen klicken.

  • Die einzigen Nachrichten, die sich für eine asynchrone Kommunikation eignen, sind XML-Nachrichten. Alle XML-Nachrichten stehen zur Verfügung und können für mehr als einen Port angegeben werden. Synchrone Nachrichtenpaare, die mithilfe des Methodenkommunikations-Assistenten erstellt werden, können nicht verwendet werden.

  • Wenn Sie diesen Kommunikationsfluss mit einem Port verbinden, der mithilfe von BizTalk-Messaging implementiert ist, wird die Richtung der Kommunikation (Senden oder Empfangen) durch die Portimplementierung bestimmt und kann nicht im Assistenten für XML-Kommunikation festgelegt werden. Die Option Senden oder Empfangen auf der ersten Seite des Assistenten wird in diesem Fall automatisch ausgewählt und kann nicht geändert werden. Sie müssen auf Weiter klicken und zur nächsten Seite des Assistenten übergehen, um die Konfigurierung des Kommunikationsflusses abzuschließen.

  • Beim Generieren einer asynchronen Kommunikation wird eine Nachricht auf der Datenseite erstellt. Diese Nachricht entspricht den im Kommunikationsfluss gesendeten oder empfangenen Informationen. In der Nachricht sind die erforderlichen Systemfelder sowie alle zusätzlich von Ihnen gewünschten Spezifikationsfelder enthalten. Weitere Informationen zum Festlegen der bei einer asynchronen Kommunikation verwendeten Nachrichten finden Sie unter Asynchrone Kommunikation.

Verwandte Themen

Asynchrone Kommunikation

Erstellen und Überprüfen von Spezifikationen

Erstellen von Spezifikationen und Zuordnen von Daten

Pausierung und Aktivierung

Einrichten des Kommunikationsflusses zwischen einer Aktion und einem Port

Knotenpfadfelder

Senden oder Empfangen synchroner Nachrichten

Verwenden des Assistenten für XML-Kommunikation


Ändern des Kommunikationsflusses zwischen einer Aktion und einem Port

  1. Klicken Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite mit der rechten Maustaste auf den Kommunikationsfluss zwischen einer Aktion und einem Port, und klicken Sie dann auf Eigenschaften.

    Ein Kommunikations-Assistent wird gestartet.

  2. Folgen Sie den Anweisungen des Assistenten, und nehmen Sie die gewünschten Änderungen an den Eigenschaften vor.

    Fahren Sie je nach Art des zu erstellenden Kommunikationsflusses mit einem der folgenden Verfahren fort.

    • Wenn Sie einen synchronen Kommunikationsfluss zu einem Port erstellen möchten, der eine COM-Komponenten- oder Skriptkomponenten-Implementierung verwendet, müssen Sie den Methodenkommunikations-Assistent verwenden. Weiter mit Senden oder Empfangen synchroner Nachrichten.

    • Wenn Sie einen asynchronen Kommunikationsfluss zu einem Port erstellen möchten, der eine Message Queuing- oder BizTalk-Messaging-Implementierung verwendet, oder wenn Sie einen asynchronen Kommunikationsfluss zu einem ungebundenen Port erstellen möchten, müssen Sie den Assistenten für XML-Kommunikation verwenden. Weiter mit Senden und Empfangen asynchroner Nachrichten.

Anmerkungen

  • Sie können einen Kommunikationsfluss zwischen einer Aktion und einem Port auf jeder Geschäftsprozessseite, den Seiten Kompensierung für Transaktion und den Seiten Bei Fehler von Transaktion einrichten. Auf der Datenseite sind Aktionen und Ports nicht verfügbar.

  • Der Datenseite können keine Formen hinzugefügt werden. Jedes Mal, wenn eine Aktion mit einem Port verbunden wird, werden automatisch neue Nachrichten auf der Datenseite generiert.

Verwandte Themen

Einrichten des Kommunikationsflusses zwischen einer Aktion und einem Port

Senden oder Empfangen asynchroner Nachrichten

Senden oder Empfangen synchroner Nachrichten

Verwenden des Methodenkommunikations-Assistenten

Verwenden des Assistenten für XML-Kommunikation


Festlegen des Datenflusses zwischen Nachrichten

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Auswählen einer Nachricht

  • Auswählen eines Feldes innerhalb einer Nachricht

  • Festlegen des Datenflusses zwischen Nachrichten

  • Löschen einer Nachricht

  • Zuordnen einer bestimmten Nachricht zu einem bestimmten Port

  • Verwenden von Konstanten

Verwandte Themen

Hinzufügen, Löschen und Verbinden von Formen

Datenverarbeitung


Auswählen einer Nachricht

  • Klicken Sie im BizTalk-Orchestrierungs-Designer auf der Datenseite auf das graue Vorspannfeld der Nachricht, die Sie auswählen möchten.

    Die gesamte Nachricht ist nach ihrer Auswahl von einer grünen gestrichelten Randlinie umgeben.

Anmerkungen

  • Sie können die Liste Constants, die Liste Port References oder eine Nachrichten-Form auswählen.

  • Wenn Sie eine ganze Nachricht auswählen, können Sie die Nachricht durch Ziehen auf der Seite neu positionieren. Durch das Neupositionieren der Nachrichten können die Datenflüsse möglicherweise deutlicher hervortreten, die zwischen den Nachrichten festgelegt werden.

Verwandte Themen

Hinzufügen, Löschen und Verbinden von Formen

Datenverarbeitung

Löschen einer Nachricht

Festlegen des Datenflusses zwischen Nachrichten

Zuordnen einer bestimmten Nachricht zu einem bestimmten Port

Auswählen eines Feldes innerhalb einer Nachricht

Verwenden von Konstanten


Auswählen eines Feldes innerhalb einer Nachricht

  • Klicken Sie im BizTalk-Orchestrierungs-Designer auf der Datenseite innerhalb einer Nachricht auf ein Feld, das Sie auswählen möchten.

    Das markierte Feld ist von einem grünen gestrichelten Rand umgeben. Alle für dieses Feld verfügbaren Kontrollhandles ( Kontrollhandle) sind aktiviert.

Verwandte Themen

Hinzufügen, Löschen und Verbinden von Formen

Datenverarbeitung

Löschen einer Nachricht

Festlegen des Datenflusses zwischen Nachrichten

Zuordnen einer bestimmten Nachricht zu einem bestimmten Port

Auswählen einer Nachricht

Verwenden von Konstanten


Festlegen des Datenflusses zwischen Nachrichten

  1. Klicken Sie im BizTalk-Orchestrierungs-Designer auf der Datenseite auf ein Feld innerhalb einer Nachricht, um dessen Kontrollhandles ( Kontrollhandle) zu aktivieren.

  2. Ziehen Sie das Kontrollhandle auf den Verbindungspunkt ( Verbindungspunkt) eines Feldes in einer anderen Nachricht, mit dem Sie eine Verbindung herstellen möchten.

    Wenn um den Verbindungspunkt ein rotes Feld ( Aktiver Verbindungspunkt) angezeigt wird, lassen Sie die Maustaste los, um die neue Verbindung festzulegen.

Anmerkung

  • Wenn Sie mehrere Datenflüsse erstellen möchten, können Sie das Verbindungstool verwenden, um das Hinzufügen der Datenflüsse zu beschleunigen. Weitere Informationen zum Verbindungstool finden Sie unter Verwenden des Verbindungstools.

Verwandte Themen

Hinzufügen, Löschen und Verbinden von Formen

Datenverarbeitung

Löschen einer Nachricht

Zuordnen einer bestimmten Nachricht zu einem bestimmten Port

Auswählen eines Feldes innerhalb einer Nachricht

Auswählen einer Nachricht

Verwenden von Konstanten


Löschen einer Nachricht

  • Klicken Sie im BizTalk-Orchestrierungs-Designer auf der Datenseite auf das graue Vorspannfeld der Nachricht, die Sie löschen möchten, und drücken Sie ENTF.

Anmerkungen

  • Sie können die Liste Port References nicht löschen.

  • Sie können die Liste Constants nicht löschen.

  • Wenn Sie ein einzelnes Feld innerhalb einer Nachricht markieren und ENTF drücken, wird nicht nur das Feld, sondern die gesamte Nachricht gelöscht.

Verwandte Themen

Hinzufügen, Löschen und Verbinden von Formen

Datenverarbeitung

Festlegen des Datenflusses zwischen Nachrichten

Auswählen eines Feldes innerhalb einer Nachricht

Auswählen einer Nachricht


Zuordnen einer bestimmten Nachricht zu einem bestimmten Port

  1. Klicken Sie auf das Feld in der Liste Port References, welches den Namen des Ports enthält, auf den Sie Bezug nehmen möchten.

  2. Ziehen Sie das Kontrollhandle ( Kontrollhandle) von jenem Feld auf den Verbindungspunkt ( Verbindungspunkt) desjenigen Feldes in einer Nachricht, dem Sie den Verweis auf den Port übergeben möchten.

Wichtig

  • Weitere Informationen zum Verknüpfen von Nachrichten und Portverweisen finden Sie unter den folgenden Themen:
    • Instanzenverwaltung

    • Datenverarbeitung

    • Grundlegendes zu Portimplementierungen

Verwandte Themen

Datenverarbeitung

Löschen einer Nachricht

Festlegen des Datenflusses zwischen Nachrichten

Implementieren von Ports

Instanzenverwaltung

Auswählen eines Feldes innerhalb einer Nachricht

Auswählen einer Nachricht

Grundlegendes zu Portimplementierungen

Verwenden von Konstanten


Verwenden von Konstanten

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Hinzufügen von Konstanten

  • Bearbeiten von Konstanten

  • Löschen von Konstanten

Verwandte Themen

Datenverarbeitung

Felddatentypen

Zusammenfassung der Datentypen und Datentypwerte


Hinzufügen von Konstanten

  1. Klicken Sie im BizTalk-Orchestrierungs-Designer auf der Datenseite mit der rechten Maustaste auf die Liste Constants, und klicken Sie anschließend auf Eigenschaften.

    Das Dialogfeld Eigenschaften der Nachricht Constants wird angezeigt.

  2. Klicken Sie auf Hinzufügen.

    Das Dialogfeld Eigenschaften der Konstante wird angezeigt.

  3. Geben Sie in das Feld Name einen Namen für die Konstante ein.

  4. Klicken Sie in der Liste Datentyp auf den Datentyp für die Konstante.

  5. Geben Sie in das Feld Wert den Wert für die Konstante ein.

  6. Klicken Sie auf OK und dann erneut auf OK.

Anmerkungen

  • Für jede Konstante, die Sie neu erstellen, wird automatisch ein Standardname mit einer angehängten Zahl eingetragen. Sie können diesen Namen ändern.

  • Der Bereich Datentypbeschreibung bietet schreibgeschützte Informationen zu dem von Ihnen ausgewählten Datentyp. Diese Informationen können ein Formatbeispiel oder die Angabe eines gültigen Wertebereichs für den Datentyp beinhalten.

Verwandte Themen

Datenverarbeitung

Löschen von Konstanten

Bearbeiten von Konstanten

Felddatentypen

Zusammenfassung der Datentypen und Datentypwerte


Bearbeiten von Konstanten

  1. Klicken Sie im BizTalk-Orchestrierungs-Designer auf der Datenseite, mit der rechten Maustaste auf die Liste Constants, und klicken Sie anschließend auf Eigenschaften.

    Das Dialogfeld Eigenschaften der Nachricht Constants wird angezeigt.

  2. Klicken Sie in der Liste Konstanten auf die Konstante, die Sie bearbeiten möchten.

  3. Klicken Sie auf Bearbeiten.

    Das Dialogfeld Eigenschaften der Konstante wird angezeigt.

  4. Bearbeiten Sie jede Konstanteneigenschaft, die Sie ändern möchten, und klicken Sie auf OK.

Anmerkungen

  • Detaillierte Informationen zu den im Dialogfeld Eigenschaften der Konstante verfügbaren Eigenschaften finden Sie unter Hinzufügen von Konstanten.

  • Für jede Konstante, die Sie neu erstellen, wird automatisch ein Standardname mit einer angehängten Zahl eingetragen. Sie können diesen Namen ändern.

  • Der Bereich Datentypbeschreibung bietet schreibgeschützte Informationen zu dem von Ihnen ausgewählten Datentyp. Diese Informationen können ein Formatbeispiel oder die Angabe eines gültigen Wertebereiches für den Datentyp beinhalten.

Verwandte Themen

Hinzufügen von Konstanten

Datenverarbeitung

Löschen von Konstanten

Felddatentypen

Zusammenfassung der Datentypen und Datentypwerte


Löschen von Konstanten

  1. Klicken Sie im BizTalk-Orchestrierungs-Designer auf der Datenseite, mit der rechten Maustaste auf die Liste Constants, und klicken Sie anschließend auf Eigenschaften.

    Das Dialogfeld Eigenschaften der Nachricht Constants wird angezeigt.

  2. Klicken Sie in der Liste Konstanten auf die Konstante, die Sie löschen möchten.

  3. Klicken Sie auf Löschen.

Verwandte Themen

Hinzufügen von Konstanten

Datenverarbeitung

Bearbeiten von Konstanten

Felddatentypen

Zusammenfassung der Datentypen und Datentypwerte


Ausführung von XLANG-Ablaufplänen

Dieser Abschnitt enthält Verfahren, die das Kompilieren und Debuggen von XLANG-Ablaufplänen erläutern und Ihnen erklären, wie Sie einen XLANG-Ablaufplan aktivieren und ausführen. Um XLANG-Ablaufpläne auszuführen, ist es möglicherweise auch erwünscht, eine COM+-Anwendung zu erstellen, die als Host für bestimmte Ablaufplaninstanzen dienen soll.

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Kompilieren und Debuggen von XLANG-Ablaufplänen

  • Erstellen und Konfigurieren einer Hostanwendung für einen XLANG-Ablaufplan

Verwandte Themen

Erstellen einer Instanziierungsanwendung

Verwalten von XLANG-Anwendungen und -Datenbanken

Ausführen von XLANG-Ablaufplänen

Sicherheit für Hostanwendungen für XLANG-Ablaufplaninstanzen


Kompilieren und Debuggen von XLANG-Ablaufplänen

Wenn Sie einen XLANG-Ablaufplan erstellen, können Sie diesen Ablaufplan auch kompilieren, ausführen, testen und debuggen. Der BizTalk-Orchestrierungs-Designer stellt Features bereit, die Hilfestellung beim Kompilieren, Ausführen, Testen und Debuggen von XLANG-Ablaufplänen bieten.

Im BizTalk-Orchestrierungs-Designer stehen folgende Optionen zur Verfügung:

  • Kompilieren

  • Aktualisieren von Methodensignaturen

  • Beenden von in Ausführung befindlichen Instanzen von XLANG-Ablaufplänen

Außer diesen Optionen gibt es zwei Tools, die Ihnen beim Testen und Debuggen eines XLANG-Ablaufplan behilflich sein können:

  • XLANG Event Monitor. Mit diesem Tool können Sie aktive XLANG-Ablaufplaninstanzen überwachen. Spezifische Informationen zum Verwendung des XLANG Event Monitors finden Sie in der zugehörigen Infodatei Readme.htm. Der XLANG Event Monitor (XLANGMon.exe) und die vom Microsoft BizTalk Server 2000 Setup-Assistent installierte Infodatei befinden sich beide im folgenden Installationsverzeichnis: ..\Programme\Microsoft BizTalk Server\SDK\XLANG Tools.

  • Windows 2000-Ereignisanzeige. Mit der Windows 2000-Ereignisanzeige können Fehler angezeigt werden, die bei der Ausführung eines XLANG-Ablaufplanes aufgetreten sind. Weitere Informationen finden Sie unter den folgenden Themen:
    • Verwalten der Ereignisanzeige

    • Überwachen von aktiven XLANG-Ablaufplänen

    • Weitere Informationen zur Ereignisanzeige finden Sie in der Windows 2000 Server-Hilfe im Kapitel "Ereignisanzeige" unter "Verwenden der Ereignisanzeige".

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Kompilieren einer XLANG-Ablaufplanzeichnung in einen XLANG-Ablaufplan

  • Ausführen eines XLANG-Ablaufplanes

  • Debuggen kompilierter Visual Basic-Komponenten

  • Aktualisieren von Methodensignaturen

  • Herunterfahren aller aktiven XLANG-Ablaufpläne

Verwandte Themen

Erstellen und Konfigurieren einer Hostanwendung für einen XLANG-Ablaufplan

Erstellen einer Instanziierungsanwendung

Verwalten von XLANG-Anwendungen und -Datenbanken

Ausführen von XLANG-Ablaufplänen

Sicherheit für Hostanwendungen für XLANG-Ablaufplaninstanzen


Kompilieren einer XLANG-Ablaufplanzeichnung in einen XLANG-Ablaufplan

  1. Klicken Sie im BizTalk-Orchestrierungs-Designer im Menü Datei auf XLANG ZeichnungX.skx erstellen.

    Das Dialogfeld XLANG-Ablaufplan speichern unter wird angezeigt.

  2. Suchen Sie in der Liste Speichern in nach dem Verzeichnis, in dem Sie den XLANG-Ablaufplan speichern möchten.

  3. In der Liste Dateiname können Sie die Datei umbenennen.

  4. Klicken Sie auf Speichern.

Anmerkungen

  • Beim Kompilieren einer XLANG-Ablaufplanzeichnung in einen XLANG-Ablaufplan können Kompilierungsfehler gemeldet werden. Die Fehlermeldung verweist auf ein mögliches Problem in der Zeichnung und die betroffene Form wird mit einer grünen gestrichelten Randlinie hervorgehoben.

  • Wenn Sie eine XLANG-Ablaufplanzeichnung in einen XLANG-Ablaufplan kompilieren, wird die kompilierte Zeichnung unter dem Standardnamen ZeichnungX.skx gespeichert. Dabei bezeichnet X eine Zahl, die dem Namen des Ablaufplanes angehängt wird. Der Name der Datei kann beim Kompilieren der Zeichnung geändert werden.

  • Die Dateinamenerweiterung für einen XLANG-Ablaufplan lautet SKX. Eine SKX-Datei ist eine XML-Datei, deren Inhalt in der Sprache XLANG formuliert ist. Eine SKX-Datei kann nicht im BizTalk-Orchestrierungs-Designer geöffnet werden. Um eine SKX-Datei zu ändern oder zu aktualisieren, öffnen Sie die Quelldatei (SKV-Datei), nehmen die gewünschten Änderungen daran vor und kompilieren anschließend die SKV-Datei in eine SKX-Datei.

  • Die Dateinamenerweiterung für eine XLANG-Ablaufplanzeichnung lautet SKV.

Verwandte Themen

Erstellen und Konfigurieren einer Hostanwendung für einen XLANG-Ablaufplan

Erstellen einer Instanziierungsanwendung

Debuggen kompilierter Visual Basic-Komponenten

Verwalten von XLANG-Anwendungen und -Datenbanken

Öffnen und Speichern von XLANG-Ablaufplanzeichnungen

Aktualisieren von Methodensignaturen

Ausführen eines XLANG-Ablaufplanes

Ausführen von XLANG-Ablaufplänen

Sicherheit für Hostanwendungen für XLANG-Ablaufplaninstanzen

Herunterfahren aller aktiven XLANG-Ablaufpläne


Ausführen eines XLANG-Ablaufplanes

Um einen XLANG-Ablaufplan auszuführen, müssen Sie den XLANG-Ablaufplan aktivieren.

Hierfür stehen Ihnen im Wesentlichen zwei Verfahren zur Verfügung:

  • Sie konfigurieren die BizTalk-Orchestrierungsdienste und die BizTalk-Messaging-Dienste in geeigneter Weise, um mit ihrer Hilfe XLANG-Ablaufpläne zu aktivieren und auszuführen.

    Weitere Informationen finden Sie unter den folgenden Themen:

    • Integrieren der BizTalk-Dienste

    • Festlegen von Eigenschaften für die Zielanwendung
  • Sie aktivieren den XLANG-Ablaufplan per Programm, indem Sie eine Instanziierungsanwendung wie z. B. eine ASP-Seite erstellen.

    Weitere Informationen finden Sie unter den folgenden Themen:

    • Ausführen von XLANG-Ablaufplänen

    • Erstellen einer Instanziierungsanwendung

    • Monikersyntax

Verwandte Themen

Kompilieren einer XLANG-Ablaufplanzeichnung in einen XLANG-Ablaufplan

Erstellen und Konfigurieren einer Hostanwendung für einen XLANG-Ablaufplan

Erstellen einer Instanziierungsanwendung

Debuggen kompilierter Visual Basic-Komponenten

Verwalten von XLANG-Anwendungen und -Datenbanken

Monikersyntax

Aktualisieren von Methodensignaturen

Ausführen von XLANG-Ablaufplänen

Sicherheit für Hostanwendungen für XLANG-Ablaufplaninstanzen

Herunterfahren aller aktiven XLANG-Ablaufpläne


Debuggen kompilierter Visual Basic-Komponenten

Es können Situationen auftreten, in denen Sie Komponenten, die Sie mit Microsoft Visual Basic erstellt haben, debuggen müssen, nachdem Sie sie kompiliert haben.

  1. Öffnen Sie in Visual Basic 6.0 das Visual Basic-Projekt, das Sie debuggen möchten.

  2. Klicken Sie im Menü Datei auf <IhrProjekt>.dll erstellen.

  3. Klicken Sie im Dialogfeld Projekt erstellen auf Optionen.

  4. Klicken Sie im Dialogfeld Projekteigenschaften auf die Registerkarte Kompilieren, klicken Sie auf Kompilieren zu System-Code und auf Keine Optimierung, und aktivieren Sie anschließend das Kontrollkästchen Debug-Informationen für symbolischen Debugger generieren.

  5. Klicken Sie auf OK und dann erneut auf OK, um das Projekt zu kompilieren.

  6. Öffnen Sie das Visual Basic-DLL-Projekt.

  7. Legen Sie die gewünschten Haltepunkte fest.

  8. Klicken Sie im Menü Ausführen auf Starten.

Wenn der XLANG-Ablaufplan das nächste Mal eine Methode der Visual Basic-Komponente aufruft, unterbricht der Visual Basic-Debugger die Ausführung an dem festgelegten Haltepunkt.

Wichtig

  • Beim Erstellen der Visual Basic-DLL muss das Kontrollkästchen Debug-Informationen für symbolischen Debugger generieren aktiviert sein.

  • Stellen Sie sicher, dass das XLANG-Ablaufplanungsmodul die DLL noch nicht in den Speicher geladen hat. Wenn die DLL bereits geladen ist, müssen Sie das Modul beenden und die Ausführung erneut starten.

Anmerkung

  • Weitere Informationen zum Debuggen von Komponenten oder zu den Komponentendiensten und COM+ finden Sie in der MSDN Online Library-Website (msdn.microsoft.com/library/default.asp). Suchen Sie im Platform SDK nach "Component Services".


Aktualisieren von Methodensignaturen

  • Klicken Sie im BizTalk-Orchestrierungs-Designer im Menü Extras auf Methodensignaturen aktualisieren.

Anmerkungen

  • Verwenden Sie diese Option, wenn Sie zur gleichen Zeit COM+-Komponenten und einen XLANG-Ablaufplan erstellen und einen der Methodenparameter für den Aufruf einer der verfügbaren Methoden ändern. Auf diese Weise aktualisieren Sie die Daten des XLANG-Ablaufplanes über die verfügbaren Methodenparameter.

  • Beim Kompilieren eines XLANG-Ablaufplanes wird der Befehl Methodensignaturen aktualisieren automatisch ausgeführt.

Verwandte Themen

Kompilieren einer XLANG-Ablaufplanzeichnung in einen XLANG-Ablaufplan

Erstellen und Konfigurieren einer Hostanwendung für einen XLANG-Ablaufplan

Erstellen einer Instanziierungsanwendung

Debuggen kompilierter Visual Basic-Komponenten

Verwalten von XLANG-Anwendungen und -Datenbanken

Ausführen eines XLANG-Ablaufplanes

Ausführen von XLANG-Ablaufplänen

Sicherheit für Hostanwendungen für XLANG-Ablaufplaninstanzen

Herunterfahren aller aktiven XLANG-Ablaufpläne


Herunterfahren aller aktiven XLANG-Ablaufpläne

  • Klicken Sie im BizTalk-Orchestrierungs-Designer im Menü Extras auf Alle aktiven XLANG-Ablaufplaninstanzen herunterfahren.

Anmerkung

  • Während der Ausführung einer XLANG-Ablaufplaninstanz ist es nicht möglich, Änderungen an COM-Komponenten vorzunehmen, die von diesem XLANG-Ablaufplan verwendet werden. Diese Option beendet alle aktiven Instanzen des Ablaufplanes und hebt die Zugriffssperre für die Komponentendatei auf, so dass Sie Änderungen vornehmen können.

Verwandte Themen

Kompilieren einer XLANG-Ablaufplanzeichnung in einen XLANG-Ablaufplan

Erstellen und Konfigurieren einer Hostanwendung für einen XLANG-Ablaufplan

Erstellen einer Instanziierungsanwendung

Debuggen kompilierter Visual Basic-Komponenten

Verwalten von XLANG-Anwendungen und -Datenbanken

Aktualisieren von Methodensignaturen

Ausführen eines XLANG-Ablaufplanes

Ausführen von XLANG-Ablaufplänen

Sicherheit für Hostanwendungen für XLANG-Ablaufplaninstanzen


Erstellen und Konfigurieren einer Hostanwendung für einen XLANG-Ablaufplan

Dieser Abschnitt enthält Verfahren, die das Aktivieren und Ausführen eines XLANG-Ablaufplanes erläutern. Obwohl Sie zur Ausführung von XLANG-Ablaufplänen die Standardanwendung XLANG-Ablaufplanung (XLANG Scheduler) verwenden können, ist es häufig nützlich, eine neue COM+-Anwendung zu erstellen, um Ablaufplaninstanzen auszuführen.

Auf Grund von Sicherheitsfragen, Belangen der Weitergabe und Konfigurationsproblemen müssen die meisten COM+-Anwendungen, die als Hosts für XLANG-Ablaufpläne dienen, zur selben Zeit wie der XLANG-Ablaufplan entwickelt werden. Sicherheits- und leistungsbezogene Anforderungen der Anwendungen und der Ablaufpläne müssen gleichzeitig berücksichtigt werden. Sie können eine neue COM+-Anwendung erstellen, die als Host für bestimmte Instanzen aktiver Ablaufpläne dienen soll. Möglicherweise möchten Sie aber auch Anwendungen, die bestimmte Ablaufinstanzen ausführen, von anderen XLANG-Ablaufplänen isolieren, die andere Anwendungen verwenden.

Weitere Informationen zu sicherheits- und leistungsbezogenen Themen im Zusammenhang mit dem Erstellen von XLANG-Ablaufplänen und dem Erstellen einer COM+-Anwendung für das Hosting der Ablaufpläne finden Sie unter Sicherheit für Hostanwendungen für XLANG-Ablaufplaninstanzen.

Informationen zur Handhabung von COM+-Anwendungen nach ihrer Erstellung finden Sie unter Verwalten von XLANG-Anwendungen und -Datenbanken.

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Erstellen einer COM+-Hostanwendung für XLANG-Ablaufpläne

  • Konfigurieren einer COM+-Hostanwendung für XLANG-Ablaufpläne

Wichtig

  • Zeigen Sie im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Komponentendienste, um Hilfe zur Verwaltung der Komponentendienste zu erhalten. Klicken Sie in der Konsolenstruktur mit der rechten Maustaste auf Komponentendienste, und klicken Sie anschließend auf Hilfedatei anzeigen.

  • Weitere Informationen zu den Komponentendiensten und COM+ finden Sie in der MSDN Online Library-Website (msdn.microsoft.com/library/default.asp). Suchen Sie im Platform SDK nach "Component Services".

Verwandte Themen

Erstellen einer Instanziierungsanwendung

Verwalten von XLANG-Anwendungen und -Datenbanken

Ausführen von XLANG-Ablaufplänen

Sicherheit für Hostanwendungen für XLANG-Ablaufplaninstanzen


Erstellen einer COM+-Hostanwendung für XLANG-Ablaufpläne

  1. Zeigen Sie im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, und doppelklicken Sie anschließend auf Verwaltung und dann auf Komponentendienste.

  2. Erweitern Sie Komponentendienste in der Konsolenstruktur, erweitern Sie Computer, dann Arbeitsplatz, und klicken Sie dann auf COM+-Anwendungen, um diesen Eintrag zu markieren.

    Sie müssen COM+-Anwendungen zuerst markieren und anschließend mit der rechten Maustaste darauf klicken. Wird der Eintrag nicht zuerst markiert, ist die Option Neu nicht verfügbar.

  3. Klicken Sie mit der rechten Maustaste auf COM+-Anwendungen, zeigen Sie auf Neu, und klicken Sie anschließend auf Anwendung.

    Der COM-Anwendungsinstallations-Assistent wird gestartet.

  4. Klicken Sie auf der Seite Willkommen beim COM-Anwendungsinstallations-Assistenten auf Weiter.

  5. Klicken Sie auf der Seite Neue Anwendung erstellen oder installieren auf die Option Eine leere Anwendung erstellen.

  6. Geben Sie auf der Seite Leere Anwendung erstellen einen Namen für die Anwendung ein, stellen Sie sicher, dass die Option Serveranwendung aktiviert ist, und klicken Sie anschließend auf Weiter.

  7. Legen Sie auf der Seite Anwendungs-ID festlegen für die Identität der Anwendung das geeignete Konto fest.

    Es wird empfohlen, ein eigenes Dienstekonto für COM+-Anwendungen einzurichten, die als Host für XLANG-Ablaufpläne dienen.

    Weitere Informationen zu sicherheits- und leistungsbezogenen Themen im Zusammenhang mit dem Erstellen einer Anwendungsidentität finden Sie unter Sicherheit für Hostanwendungen für XLANG-Ablaufplaninstanzen.

  8. Klicken Sie auf Weiter und anschließend auf Fertig stellen.

  9. Klicken Sie mit der rechten Maustaste auf die gerade erstellte COM+-Anwendung, und klicken Sie anschließend auf Eigenschaften.

  10. Aktivieren Sie auf der Registerkarte XLANG das Kontrollkästchen Diese Anwendung stellt einen Host für BizTalk-Ablaufplaninstanzen dar.

  11. Um die COM+-Anwendung zu konfigurieren, fahren Sie fort mit Konfigurieren einer COM+-Hostanwendung für XLANG-Ablaufpläne.

Wichtig

  • Zeigen Sie im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Komponentendienste, um Hilfe zur Verwaltung der Komponentendienste zu erhalten. Klicken Sie in der Konsolenstruktur mit der rechten Maustaste auf Komponentendienste, und klicken Sie anschließend auf Hilfedatei anzeigen.

  • Weitere Informationen zu den Komponentendiensten und COM+ finden Sie in der MSDN Online Library-Website (msdn.microsoft.com/library/default.asp). Suchen Sie im Platform SDK nach "Component Services".

Anmerkungen

  • Beim Erstellen einer COM+-Hostanwendung für XLANG-Ablaufpläne ist die Option Pausierende XLANG-Anwendungen neu starten nicht verfügbar. Weitere Informationen zum erneuten Starten pausierender Anwendungen finden Sie unter Neu starten aller XLANG-Anwendungen.

Verwandte Themen

Konfigurieren einer COM+-Hostanwendung für XLANG-Ablaufpläne

Erstellen einer Instanziierungsanwendung

Verwalten von XLANG-Anwendungen und -Datenbanken

Ausführen von XLANG-Ablaufplänen

Sicherheit für Hostanwendungen für XLANG-Ablaufplaninstanzen


Konfigurieren einer COM+-Hostanwendung für XLANG-Ablaufpläne

  1. Zeigen Sie im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, und doppelklicken Sie anschließend auf Verwaltung und dann auf Komponentendienste.

  2. Erweitern Sie Komponentendienste in der Konsolenstruktur, erweitern Sie Computer, dann Arbeitsplatz und dann COM+-Anwendungen.

  3. Klicken Sie mit der rechten Maustaste auf die COM+-Anwendung, die Sie konfigurieren möchten, und klicken Sie anschließend auf Eigenschaften.

  4. Es wird dringend empfohlen, ein eigenes Dienstekonto für die Verwaltung von COM+-Anwendungen einzurichten, die als Host für XLANG-Ablaufpläne dienen. Wenn Sie beim Erstellen der COM+-Anwendung mit dem COM-Anwendungsinstallations-Assistenten die Standardeinstellungen übernommen haben, möchten Sie diese Einstellungen möglicherweise ändern. Weitere Informationen finden Sie unter Senden oder Empfangen synchroner Nachrichten.

  5. Konfigurieren Sie die DSN-Einstellungen für die COM+-Anwendung. Weitere Informationen finden Sie unter Ändern der Anwendungsidentität einer COM+-Anwendung.

  6. Konfigurieren Sie eine Datenbank zur Verwendung durch die COM+-Anwendung. Folgende Aktionen sind möglich:
    • Zeigen Sie auf eine vorhandene Datenbank. Weitere Informationen finden Sie unter Ändern der DSN-Einstellungen für eine COM+-Anwendung.

      Oder

    • Erstellen und konfigurieren Sie eine neue Datenbank. Weitere Informationen finden Sie unter den ThemenErstellen einer neuen Persistenzdatenbank und Ändern der DSN-Einstellungen für eine COM+-Anwendung.

Vorsicht

  • Wenn Sie eine neue Datenbank erstellen und konfigurieren, die von der COM+-Anwendung verwendet werden soll, müssen Sie die Tabellen der Datenbank initialisieren, nachdem Sie die DSN-Einstellungen für die COM+-Anwendung festgelegt haben.

    Um weitere Informationen zum Konfigurieren der DSN-Einstellungen und zum Verwenden von (ODBC-)Datenquellen zu erhalten, klicken Sie im Dialogfeld ODBC-Datenquellen-Administrator auf Hilfe.

    So initialisieren Sie neue Datenbanktabellen für die zu konfigurierende COM+-Hostanwendung:

    1. Klicken Sie mit der rechten Maustaste auf die COM+-Anwendung, und klicken Sie anschließend auf Eigenschaften.

    2. Klicken Sie auf die Registerkarte XLANG.

    3. Klicken Sie auf der Registerkarte XLANG auf Tabellen initialisieren.
  • Klicken Sie nicht auf Tabellen initialisieren, wenn Sie eine COM+-Hostanwendung und einen DSN für eine vorhandene Datenbank konfigurieren. Dieser Vorgang würde alle bereits vorhandenen Daten in der Datenbank löschen.

Anmerkungen

  • Zeigen Sie im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Komponentendienste, um Hilfe zur Verwaltung der Komponentendienste zu erhalten. Klicken Sie in der Konsolenstruktur mit der rechten Maustaste auf Komponentendienste, und klicken Sie anschließend auf Hilfedatei anzeigen.

  • Weitere Informationen zu den Komponentendiensten und COM+ finden Sie in der MSDN Online Library-Website (msdn.microsoft.com/library/default.asp). Suchen Sie im Platform SDK nach "Component Services".

Verwandte Themen

Ändern der Anwendungsidentität einer COM+-Anwendung

Ändern der DSN-Einstellungen für eine COM+-Anwendung

Erstellen einer COM+-Hostanwendung für XLANG-Ablaufpläne

Erstellen einer neuen Persistenzdatenbank

Erstellen einer Instanziierungsanwendung

Verwalten von XLANG-Anwendungen und -Datenbanken

Ausführen von XLANG-Ablaufplänen

Sicherheit für Hostanwendungen für XLANG-Ablaufplaninstanzen


Grundbegriffe

Dieser Abschnitt stellt detaillierte Informationen zum Konzept bereit, die wichtig für das Verständnis des BizTalk-Orchestrierungs-Designers sind. Er enthält detaillierte Informationen zu den folgenden Themen:

  • BizTalk-Orchestrierungsdienste

  • Erstellen von XLANG-Ablaufplanzeichnungen

  • Kompilieren von XLANG-Ablaufplänen

  • Debuggen von XLANG-Ablaufplänen

  • Ausführen von XLANG-Ablaufplänen

  • Verwalten des Sitzungsstatus

  • Aktualisieren von XLANG-Ablaufplänen

Anmerkung

  • Es wird dringend empfohlen, dass Sie den Abschnitt Verfahrensweise lesen, der aufgabenspezifische Informationen zur Verwendung des BizTalk-Orchestrierungs-Designers enthält.


BizTalk-Orchestrierungsdienste

BizTalk-Orchestrierungsdienste erweitern die Funktionen etablierter Informationsaustauschtechnologien. Benutzer können damit detaillierte Darstellungen von Geschäftsprozessen erstellen, die sich programmgesteuert in einer integrierten Entwurfsumgebung implementieren lassen.

Entwurf und Implementierung von Geschäftsprozessen wurden traditionell in zwei getrennten Phasen ausgeführt: die Phase des visuellen Entwurfs und die Codierungsphase. Die Phase des visuellen Entwurfs bestand gewöhnlich aus der Analyse vorhandener Geschäftsprozesse (z. B. der Unternehmensbeschaffung) und der Erstellung eines Workflowdiagramms oder eines Interaktionsdiagramms zur Veranschaulichung des Prozesses. Die Codierungsphase wurde im Allgemeinen getrennt ausgeführt. Bei diesem Beispiel wird ein abstraktes visuelles Modell eines Geschäftsprozesses geschaffen und das Modell dann einer Implementierungsumgebung zugeordnet.

Zu den wichtigen Features der BizTalk-Orchestrierung gehört die Integration dieser ehemals getrennten Phasen in einer vereinheitlichten Entwurfsumgebung. Diese Entwurfsumgebung stellt eine vielseitige Zeichenoberfläche und umfassende Implementierungstools bereit. Die BizTalk-Orchestrierung bietet Ihnen folgende Möglichkeiten:

  • Erstellen von XLANG-Ablaufplanzeichnungen zur Beschreibung von Geschäftsprozessen.

  • Implementieren von Geschäftsprozessen durch die Verbindung bestimmter Aktionen innerhalb einer Zeichnung mit Ports, die Standorte darstellen, von denen Nachrichten gesendet oder empfangen werden. Ports sind benannte Standorte, und Nachrichten sind die Daten, die zwischen Aktionen und Ports gesendet bzw. empfangen werden.

  • Definieren des Datenflusses zwischen Nachrichten innerhalb von Geschäftsprozessen.

  • Kompilieren von XLANG-Ablaufplanzeichnungen in XLANG-Ablaufpläne. XLANG-Ablaufpläne sind ausführbare XML-Darstellungen (Extensible Markup Language) der in den Zeichnungen enthaltenen Informationen.

Neben der Integration von Entwurfs- und Implementierungsfunktionen stellt die BizTalk-Orchestrierung eine wichtige zusätzliche Funktion bereit: die Möglichkeit, robuste, langlebige Geschäftsprozesse mit flexiblen Verbindungen zu erstellen, die unternehmens-, plattform- und anwendungsübergreifend sind. Während eines asynchronen, flexibel verbundenen und langlebigen Geschäftsprozesses besteht die Möglichkeit, dass ein über das Internet bestelltes Produkt aus Teilen hergestellt werden muss, die sich im Lager befinden. Einige dieser Teile sind möglicherweise sogar nicht mehr vorrätig. Die Ausführung des gesamten Geschäftsprozesses kann unter Umständen Wochen oder Monate dauern. Im Gegensatz dazu beinhaltet ein eng verbundener Geschäftsprozess den synchronen Austausch von Nachrichten. Wenn ein Kunde beispielsweise Geld von einem Bankkonto abhebt, folgt die Aushändigung des Geldes unmittelbar auf die Belastung des Kontos.

Die BizTalk-Orchestrierung bietet folgende Möglichkeiten:

  • Erstellen einer visuellen Darstellung langlebiger Geschäftsprozesse.

  • Vereinfachen des Nachrichtenaustauschs durch die Verbindung von Aktionen in Ihrer visuellen Darstellung mit Ports, die durch eine bestimmte Technologie implementiert werden.

  • Kompilieren der abgeschlossenen Zeichnung in eine ausführbare XML-Darstellung der Zeichnung.

  • Zuverlässiges Ausführen von Geschäftsprozessen, die Wochen oder Monate dauern können.

Dieser Abschnitt behandelt folgende Themen:

  • Grundlegendes zu Geschäftsprozessen

  • BizTalk-Orchestrierungs-Designer - Umgebung

  • XLANG-Ablaufpläne

Verwandte Themen

Erstellen von XLANG-Ablaufplanzeichnungen

Grundlegendes zu Geschäftsprozessen


Grundlegendes zu Geschäftsprozessen

Geschäftsprozesse sind für das Unternehmensmanagement ebenso wichtig wie Fließbänder im Herstellungsbereich. Durch das Befolgen genau definierter, formalisierter Prozesse können Unternehmen ihre Produktivität erhöhen und Kosten reduzieren. Ein Geschäftsprozess definiert das Nachrichtenaustauschprotokoll zwischen allen verteilten Teilnehmern. Zum Definieren eines Geschäftsprozesses müssen Sie die logische Reihenfolge von Aktionen sowie den zugehörigen Ablauf von Nachrichten bestimmen. Ein Geschäftsprozess beinhaltet keine Definitionen der verteilten Teilnehmer, die diese Aktionen ausführen.

Die Reihenfolge der Schritte in einem langlebigen Geschäftsprozess ist normalerweise asynchron. Bei jedem Schritt handelt es sich um eine Aktion, die von einem oder mehreren unabhängigen, verteilten Teilnehmern ausgeführt werden kann. Diese Aktionen können zum Senden und Empfangen von Nachrichten unter diesen Teilnehmern führen, wobei es sich um Personen handeln kann, die entsprechende Aufgaben ausführen. Bei einem verteilten Teilnehmer kann es sich um einen automatisierten Prozess handeln, der auf Eingaben reagiert, oder es handelt sich sogar um einen eigenen Geschäftsprozess. Sie müssen in der Lage sein, eine komplexe Vielfalt von Beziehungen und Abhängigkeiten zu visualisieren, um Geschäftsprozesse verstehen zu können. Modellierungstools für Geschäftsprozesse, z. B. Workflowdiagramme und Interaktionsdiagramme, wurden entwickelt, um die Beziehungen visuell zu veranschaulichen.

Dieser Abschnitt behandelt folgende Themen:

  • Workflowdiagramme

  • Interaktionsdiagramme


Workflowdiagramme

Ein Workflow ist eine Entwurfstechnologie für Geschäftsprozesse, die Prozeduren innerhalb von Organisationen automatisiert und verbessert. Diese Technologie ist sehr nützlich für die Skizzierung der auszuführenden Schritte, der Abhängigkeiten, die erzwungen werden müssen, und der Zustimmungen, die während der Ausführung des Projekts eingeholt werden müssen. Sie können eine Workflowanwendung verwenden, um Teilnehmern Aufgaben zuzuweisen, individuelle Verantwortlichkeiten zu definieren und um die Beziehungen zwischen den Teilnehmern zu beschreiben. Sie können eine Workflowanwendung auch dazu verwenden, Zeitlimits für die Ausführung von Projekten und das Erreichen von Meilensteinen festzulegen. Die Workflowtechnologie ist jedoch im Allgemeinen stark zentralisiert. Teilnehmern werden Aufgaben zugewiesen und Termine gesetzt, das Workflowmodul ist jedoch verantwortlich für das Routing abgeschlossener Arbeitsobjekte von einem Teilnehmer zum nächsten sowie für das Erzwingen eines Ablaufplanes. Die BizTalk-Orchestrierung hingegen deckt einen größeren Bereich ab.Die Teilnehmer sind autonom, und die Verantwortung für das Routing eines Arbeitsobjekts von einem Teilnehmer zum anderen wird von den Teilnehmern und nicht von einer zentralisierten Anwendung bestimmt.

Verwandte Themen

Interaktionsdiagramme

Grundlegendes zu Geschäftsprozessen


Interaktionsdiagramme

Ein Interaktionsdiagramm beschreibt den Datenfluss innerhalb eines Geschäftsprozesses sowie die ausgetauschten Nachrichten. Die BizTalk-Orchestrierung erweitert das Konzept des Interaktionsdiagramms durch die Bereitstellung von Definitionen und Kontrolle für Entscheidungen, parallele Aktionen, Transaktionen und unterstützende Aktionen, die nicht in ein Interaktionsdiagramm aufgenommen werden können. Der Entwurf eines Geschäftsprozesses mithilfe der BizTalk-Orchestrierung führt zu einem kompilierten, ausführbaren Geschäftsprozess (einem XLANG-Ablaufplan). Im Gegensatz dazu sind Interaktionsdiagramme statische Darstellungen von Geschäftsprozessen.

Die folgende Abbildung zeigt ein typisches Interaktionsdiagramm für ein automatisiertes Beschaffungssystem.

Internet
Bestell-
anwendung
Rechnung
Zahlung
Bits, Bytes,
& Chips, Inc
Auftrag
Auftragsanfrage-
genehmigung
Genehmigung
ProElectron, Inc
Anschaffungsanfrage
Benutzer
Auftrags-
prüfer
Finanzen
Lieferant

Verwandte Themen

Grundlegendes zu Geschäftsprozessen

Workflowdiagramme


BizTalk-Orchestrierungs-Designer - Umgebung

Mit dem BizTalk-Orchestrierungs-Designer können Sie XLANG-Ablaufplanzeichnungen erstellen. Eine XLANG-Ablaufplanzeichnung ist eine Darstellung eines Geschäftsprozesses. Die Zeichnung wird als SKV-Datei gespeichert. Dabei handelt es sich um eine angepasste Version des Microsoft Visio 2000-Dateiformats. Die XLANG-Ablaufplanzeichnung kann dann in einen XLANG-Ablaufplan kompiliert werden. Dabei handelt es sich um eine XML-strukturierte SKX-Textdatei, die vom XLANG-Ablaufplanungsmodul verstanden wird. Mit dem BizTalk-Orchestrierungs-Designer können Sie XLANG-Ablaufplanzeichnungen erstellen, die Folgendes beinhalten:

  • Die visuelle Beschreibung eines Geschäftsprozesses. Dieser Aspekt einer XLANG-Ablaufplanzeichnung entspricht einem Workflowdiagramm oder einem Interaktionsdiagramm.

  • Eine visuelle Darstellung konfigurierbarer Ports. Dabei handelt es sich um den Implementierungsaspekt einer XLANG-Ablaufplanzeichnung.

  • Die visuelle Darstellung der Verbindungen zwischen Formen. Flussdiagrammformen können verbunden werden, um den Prozessablauf in einem Geschäftsprozess darzustellen, und Aktionen können mit Ports verbunden werden, um den Kommunikationsfluss in einem Geschäftsprozess darzustellen.

  • Die visuelle Darstellung des Flusses zwischen bestimmten Nachrichtenfeldern. Dieser Aspekt einer XLANG-Ablaufplanzeichnung bestimmt die Beziehung zwischen einem Nachrichtenfeld in einer Nachricht und einem weiteren Nachrichtenfeld in einer anderen Nachricht. Durch das Korrelieren dieser Beziehungen können Sie datengesteuertes Routing aktivieren.

Eine XLANG-Ablaufplanzeichnung ist eine Darstellung der Prozeduren, die während eines Geschäftsprozesses ausgeführt werden. Eine XLANG-Ablaufplanzeichnung kann Folgendes definieren:

  • Das Nachrichtenaustauschprotokoll, auf das sich die Handelspartner einigen.

  • Aktionen, die zum Senden oder Empfangen von Nachrichten verwendet werden, in denen die logische Reihenfolge von Aktionen beschrieben wird.

  • Die Implementierung von Ports sowie der Aktionen, mit denen diese verknüpft sind.

  • Der Datenfluss zwischen Nachrichtenfeldern.

Dieser Abschnitt behandelt folgende Themen:

  • Entwurfsseiten

  • Flussdiagrammformen

  • Implementierungsformen

  • Kommunikationsformen

  • BizTalk-Orchestrierungs-Designer - Tastenkombinationen


Entwurfsseiten

Im BizTalk-Orchestrierungs-Designer stehen vier Entwurfsseiten zur Verfügung. Sie können diese Entwurfsseiten verwenden, um verschiedene Aspekte Ihrer XLANG-Ablaufplanzeichnung zu erstellen.

  • Geschäftsprozessseite. Auf dieser Seite können Sie Flussdiagrammformen und Implementierungsformen verwenden, um einen Geschäftsprozess zu definieren. Weitere Informationen zur Verwendung dieser Formen finden Sie unter Flussdiagrammformen.

  • Datenseite. Auf dieser Seite können Sie Kommunikationsformen verwenden, um den Datenfluss zwischen Nachrichtenfeldern zu steuern. Der BizTalk-Orchestrierungs-Designer stellt diese Formen automatisch bereit. Weitere Informationen zur Verwendung dieser Formen finden Sie unter Kommunikationsformen.

  • Seite "Bei Fehler von Transaktion". Auf dieser Seite können Sie Flussdiagrammformen und Implementierungsformen verwenden, um einen alternativen Geschäftsprozess für eine fehlgeschlagene Transaktionzu entwerfen.

  • Seite "Kompensierung für Transaktion". Auf dieser Seite können Sie Flussdiagrammformen und Implementierungsformen verwenden, um einen Prozess für das Rückgängigmachen des Commits für eine geschachtelte Transaktion zu entwerfen. Weitere Informationen zu Transaktionen finden Sie unter Entwerfen von Transaktionen.

Verwandtes Thema

Behandeln von Ausnahmen


Flussdiagrammformen

Der BizTalk-Orchestrierungs-Designer stellt über die Flussdiagrammschablone acht Flussdiagrammformen bereit. Diese Formen werden verwendet, um Ihren Geschäftsprozess zu beschreiben. Mit den acht Formen auf der Flussdiagrammschablone lassen sich die Struktur und die Bedeutung von XLANG-Ablaufplänen beschreiben. XLANG ist eine XML-basierte Sprache zur Beschreibung von Geschäftsprozessinteraktionen.

Die folgende Tabelle enthält eine Liste und Beschreibungen der Flussdiagrammformen.

Formname Beschreibung
Beginn

Die Beginn-Form ist auf der Flussdiagrammschablone nicht verfügbar. Sie kann nicht gelöscht werden, und es können keine zusätzlichen Beginn-Formen erstellt werden. Die Beginn-Form stellt den Start einer XLANG-Ablaufplanzeichnung dar. Die Beginn-Form wird automatisch auf allen Geschäftsprozessseiten, sowie auf den Seiten Kompensierung für Transaktion und Bei Fehler von Transaktion erstellt. Die auf der Geschäftsprozessseite angezeigte Beginn-Form verfügt über konfigurierbare Eigenschaften. Die Beginn-Formen auf den Seiten Kompensierung für Transaktion und Bei Fehler von Transaktion besitzen keine konfigurierbaren Eigenschaften. Sie können keine Beginn-Form in eine Transaktion einschließen. Der Geschäftsprozess muss dem Ablauf von der Beginn-Form zur ersten Flussdiagrammform in der Zeichnung folgen.
Aktion

Die Aktion-Form stellt einen Prozess dar, der eine Nachricht von einem Port empfängt oder an einen Port sendet. Die Sende- oder Empfangsaktion kann synchron oder asynchron sein, abhängig von der Komponente bzw. Implementierung, an die der Port gebunden ist.
Entscheidung

Die Entscheidung-Form stellt einen Prozess dar, der eine oder mehrere Regeln nacheinander auswertet.

Diese Form besitzt einen eingehenden Ablauf und einen oder mehrere ausgehende Abläufe. Jeder ausgehende Ablauf ist einer Regel zugeordnet, die auf den Wert TRUE oder FALSE auswertet. Die erste Regel, für die TRUE ausgewertet wird, bestimmt, welcher ausgehende Ablauf im Geschäftsprozess verfolgt wird. Der Geschäftsprozess folgt der ersten Regel, für die TRUE ausgewertet wird. Wenn für keine Regel TRUE ausgewertet wird, wird der Else-Ablauf verfolgt.

Die Entscheidung-Form muss mindestens eine Regel enthalten. Jede Regel muss einen Skriptausdruck enthalten.
While

Die While-Form enthält eine Regel und stellt einen Prozess dar, der wiederholt werden kann. Wenn für die Regel TRUE ausgewertet wird, wird der Ablauf der Regel bis zum Ende verfolgt und dieser dann wiederholt. Wenn für die Regel FALSE ausgewertet wird, wird der Continue-Ablauf verfolgt. Wenn der Geschäftsprozess dem Ablauf einer Regel in einer While-Form folgt, muss der Ablauf mit einer einzelnen Ende-Form abgeschlossen werden.

Für eine While-Schleife können Sie auch die Beibehaltung eines Status konfigurieren. Klicken Sie mit der rechten Maustaste auf eine While-Form, und klicken Sie dann auf Eigenschaften, um das Dialogfeld While-Eigenschaften anzuzeigen. Im Bereich Statuspersistenz können Sie Ja auswählen, um die Nachrichten, die bei jedem Schleifendurchlauf verwendet werden, als XLANG-Ablaufplanstatus zu speichern. Wenn die While-Schleife Teil einer Transaktion ist, die fehlschlägt, wird für jeden vollständig ausgeführten Schleifendurchlauf die Seite Bei Fehler von Transaktion oder Kompensierung für Transaktion aufgerufen. Wenn Sie Nein auswählen, werden nur Nachrichten, die im letzten Schleifendurchlauf verwendet wurden, als XLANG-Ablaufplanstatus gespeichert. Wenn die While-Schleife Teil einer Transaktion ist, die fehlschlägt, wird die Seite Bei Fehler von Transaktion oder Kompensierung für Transaktion nur einmal aufgerufen.

Wenn ein Geschäftsprozess dem Ablauf zu einer While-Form in einer geschachtelten Transaktion folgt, die fehlschlägt, stehen die Nachrichten und Ports, die auf der Seite Bei Fehler von Transaktion bzw. Kompensierung für Transaktion für die geschachtelte Transaktion erstellt wurden, der Seite Bei Fehler von Transaktion für die äußere Transaktion nicht zur Verfügung. Entwerfen Sie den Fehler- bzw. Kompensierungscode so, dass die gesammelten Nachrichten normal aus der geschachtelten Transaktion führen.
Verzweigung

Die Verzweigung-Form verwendet erstmals Parallelität für einen Geschäftsprozess. Ein Ablauf kann in eine Verzweigung eintreten, und bis zu 64 Abläufe können eine Verzweigung verlassen. Alle Abläufe, die eine Verzweigung verlassen, werden parallel (gleichzeitig) ausgeführt. Alle Geschäftsprozesse, die aus einer einzelnen Verzweigung-Form führen, müssen eine Verbindung zu einer einzelnen Verknüpfung-Form herstellen oder in einer Ende-Form enden.
Verknüpfung

Die Verknüpfung-Form synchronisiert parallele Abläufe in einem Geschäftsprozess. Bis zu 64 Abläufe können in eine Verknüpfung-Form eintreten, und nur ein Ablauf verlässt eine Verknüfung-Form. Mithilfe der logischen Operatoren AND und OR wird festgelegt, wie die Abläufe synchronisiert werden. Sie können die folgenden Verknüpfungseigenschaften festlegen:
  • OR. Der erste eintreffende Ablauf kann fortfahren. Die anderen Abläufe werden weiter ausgeführt.

  • AND. Synchronisiert alle eingehenden Abläufe, bevor der ausgehende Ablauf fortfahren kann.
Transaktion

Die Transaktion-Form stellt eine Auflistung von Aktionen dar, die entweder alle oder gar nicht ausgeführt werden. Es gibt drei Arten von Transaktionen:
  • Kurzlebige Transaktionen

  • Langlebige Transaktionen

  • Befristete, langlebige Transaktionen

Transaktionen werden verwendet, um eine Anwendung zuverlässiger zu machen und die Fehlerbehandlung bei großen Anwendungen zu vereinfachen.

Die Transaktion-Form ist auf einen eingehenden Pfad und einen ausgehenden Pfad beschränkt. Die Transaktion-Form kann keine Ende-Formen enthalten. Langlebige Transaktionen können geschachtelte Transaktionen enthalten; kurzlebige Transaktionen hingegen können keine geschachtelten Transaktionen enthalten. Transaktionswiederholungsversuche sind nur für kurzlebige Transaktionen zulässig. Wenn Sie einen Teil Ihres Geschäftsprozesses in eine kurzlebige Transaktion-Form einschließen, können Sie die Wiederholungsanzahl-Eigenschaft für die Transaktion konfigurieren. Wenn bei der kurzlebigen Transaktion ein Fehler auftritt, wird diese so häufig wiederholt, wie Sie angegeben haben.

Durch die Definition von Transaktionseigenschaften können Sie die Seite Kompensierung für Transaktion (für geschachtelte Transaktionen) oder die Seite Bei Fehler von Transaktion verfügbar machen. Auf beiden Seiten können Sie die für die Transaktion spezifischen Fehlerbehandlungsprozesse modellieren.

Anmerkung

  • Wenn die Ränder einer inneren Transaktion-Form mit den Rändern der äußeren Transaktion-Form überlappen, wird die innere Transaktion nicht geschachtelt. Verhindern Sie, dass die Ränder einer inneren Transaktion sich mit den Rändern einer äußeren Transaktion überlappen.
Ende

Die Ende-Form stellt den Abschluss eines Prozessablaufs dar. Eine Zeichnung kann mehrere Ende-Formen verwenden, wenn die Zeichnung Entscheidung-, While- und Verzweigung-Formen beinhaltet.
Abbruch

Die Abbruch-Form beendet die Ausführung innerhalb einer Transaktionsgruppe. Dadurch werden die Seiten Bei Fehler von Transaktion oder Kompensierung für Transaktion zur Fehlerbehandlung aktiviert oder der Transaktionsversuch wiederholt.

Anmerkungen

  • Bei den Seiten Kompensierung für Transaktion und Bei Fehler von Transaktion wird der Parameter Transaktion durch den Namen ersetzt, den Sie der zugehörigen Transaktion auf der Geschäftsprozessseite gegeben haben.

  • Formennamen müssen bestimmte Benennungskonventionen erfüllen. Folgende Konventionen gelten für Transaktion-Formen, Port-Formen, Nachrichten, Regeln und Felder:
    • Der Name muss ein gültiger XML-Elementname sein. Weitere Informationen zu XML-Elementen finden Sie in der W3C-Website (www.w3c.org).

    • Der Name darf nicht mit Unterstrichen (__) beginnen.

    • Der Name darf keinen Doppelpunkt (:) enthalten.

    • Der Name darf maximal 32 Zeichen lang sein.

    • Konstantennamen und Nachrichtennamen dürfen nicht mit einem nummerischen Zeichen beginnen.
  • Transaktionsnamen in Ein-Byte-Zeichensätzen dürfen maximal 16 Zeichen lang sein. Transaktionsnamen in Doppelbyte-Zeichensätzen dürfen maximal 8 Zeichen lang sein.

  • Aktionen sind von allen Benennungskonventionen außer der Beschränkung auf 32 Zeichen ausgenommen.

  • Folgende Formen können Sie nicht benennen: Abbruch, Beginn, Entscheidung, Ende, Verzweigung, Verknüpfung und While.

Verwandte Themen

Kommunikationsformen

Entwerfen von Transaktionen

Implementierungsformen


Implementierungsformen

Der BizTalk-Orchestrierungs-Designer stellt über die Implementierungsschablone vier Implementierungsformen bereit. Mit diesen Formen werden die Implementierungstechnologien beschrieben, die zur Implementierung eines Ports in einem Geschäftsprozess verwendet werden.

Die folgende Tabelle enthält eine Liste und Beschreibungen der Implementierungsformen.

Formname | Beschreibung
COM-Komponente | Mit der COM-Komponente-Form kann mithilfe eines Methodenaufrufs für jede gesendete oder empfangene Nachricht ein Port implementiert werden. Ziehen Sie die Form zum Öffnen des Bindungs-Assistenten für COM-Komponenten auf die rechte Seite der Trennlinie. Weitere Informationen zur COM-Komponentenimplementierung finden Sie unter Verwenden der COM-Komponente-Form.
Skriptkomponente | Mit der Skriptkomponente-Form kann mithilfe eines Methodenaufrufs für jede gesendete oder empfangene Nachricht ein Port implementiert werden. Ziehen Sie die Form zum Öffnen der Skriptkomponenten auf die rechte Seite der Trennlinie. Weitere Informationen zur Skriptkomponentenimplementierung finden Sie unter Verwenden der Skriptkomponente-Form.
Message Queuing | Mit der Message Queuing-Form kann ein Port implementiert werden. Message Queuing-Dienste dienen zum Senden oder Empfangen von Nachrichten. Ziehen Sie die Form zum Öffnen des Bindungs-Assistenten für Message Queuing auf die rechte Seite der Trennline. Weitere Informationen zur Message Queuing-Implementierung finden Sie unter Verwenden der Message Queuing-Form.
BizTalk-Messaging | Mit der BizTalk-Messaging-Form kann ein Port implementiert werden. BizTalk-Messagingdienste dienen zum Senden oder Empfangen von Nachrichten . Ziehen Sie die Form zum Öffnen des BizTalk-Bindungs-Assistenten für Messaging auf die rechte Seite der Trennlinie. Weitere Informationen zur BizTalk-Messagingimplementierung finden Sie unter Verwenden der BizTalk-Messaging-Form.

Anmerkung

  • Formennamen müssen bestimmte Benennungskonventionen erfüllen. Folgende Konventionen gelten für Transaktionen, Ports, Nachrichten, Regeln und Felder:
    • Der Name muss ein gültiger XML-Elementname sein. Weitere Informationen zu XML-Elementen finden Sie in der W3C-Website (www.w3c.org).

    • Der Name darf nicht mit Unterstrichen (__) beginnen.

    • Der Name darf keinen Doppelpunkt (:) enthalten.

    • Der Name darf maximal 32 Zeichen lang sein.

    • Konstantennamen und Nachrichtennamen dürfen nicht mit einem nummerischen Zeichen beginnen.

Verwandte Themen

Kommunikationsformen

Flussdiagrammformen


Kommunikationsformen

Der BizTalk-Orchestrierungs-Designer stellt mehrere Kommunikationsformen bereit, die die Richtung des Datenflusses in und aus Nachrichten anzeigen. Der BizTalk-Orchestrierungs-Designer stellt die Kommunikationsformen automatisch bereit.

Die Formen Port References, Constants und Nachricht befinden sich auf der Datenseite. Die Datenseite stellt den Datenfluss zwischen Nachrichten dar, die von der XLANG-Ablaufplaninstanz bei der Ausführung der Instanz verwendet werden. Zum Entwerfen des Datenflusses können Sie Verbindungen zwischen den Feldern innerhalb der Formen auf der Datenseite erstellen.

Die folgende Tabelle enthält eine Liste und Beschreibungen der Kommunikationsformen.

Formname | Beschreibung
Port | Ports sind benannte Standorte, an denen Nachrichten gesendet oder empfangen werden. Klicken Sie mit der rechten Maustaste auf die Trennlinie, und klicken Sie dann auf Neuen Port hinzufügen, um einen ungebundenen Port hinzuzufügen. Um einen gebundenen Port hinzuzufügen, ziehen Sie eine Implementierungsform auf die rechte Seite der Trennlinie. Jeder Port enthält Nachrichten, die mit den auf der Datenseite angezeigten Nachrichten übereinstimmen. Eine Nachricht stellt die von einer Aktion gesendeten bzw. empfangenen Daten dar. Die Daten in einer Nachricht werden auf der Datenseite in eine Liste von Feldern aufgeteilt.
Port References | Die Nachricht Port References enthält eine Liste aller Ports, die auf der Geschäftsprozessseite erstellt werden. Sobald ein neuer Port auf der Geschäftsprozessseite hinzugefügt wird, wird ein neuer Verweis zu dieser Liste hinzugefügt. Mit der Nachricht Port References können Sie den Ursprung von Portstandorten angeben. Die Nachricht Port References enthält ein Portfeld für jeden Port im Geschäftsprozess.
Constants | Mit der Nachricht Constants können Sie den XLANG-Ablaufplan mit Daten initialisieren. Um eine Konstante hinzuzufügen, doppelklicken Sie auf die Nachricht Constants, oder doppelklicken Sie auf ein Feld in der Nachricht Constants, um das Dialogfeld Eigenschaften der Nachricht Constants zu öffnen.
Nachricht | Nachrichten enthalten eine Liste von Feldern mit Informationen zu den in der Nachricht gesendeten oder empfangenen Daten.

Anmerkung

  • Formennamen müssen bestimmte Benennungskonventionen erfüllen. Folgende Konventionen gelten für Transaktionen, Ports, Nachrichten, Regeln und Felder:
    • Der Name muss ein gültiger XML-Elementname sein. Weitere Informationen zu XML-Elementen finden Sie in der W3C-Website (www.w3c.org).

    • Der Name darf nicht mit Unterstrichen (__) beginnen.

    • Der Name darf keinen Doppelpunkt (:) enthalten.

    • Der Name darf maximal 32 Zeichen lang sein.

    • Konstantennamen und Nachrichtennamen dürfen nicht mit einem nummerischen Zeichen beginnen.

Jede auf der Datenseite definierte Nachricht verfügt über zusätzliche Systemfelder, die vom XLANG-Ablaufplanungsmodul automatisch für jede Nachricht erstellt und beibehalten werden. Auf diese Felder kann verwiesen werden, um beschreibende Informationen zur Nachricht zu erhalten, und sie können in Skriptausdrücken für Regeln verwendet werden. Die folgende Tabelle enthält eine Zusammenfassung der Systemfelder, die automatisch erstellt werden.

Systemfeld Beschreibung
__Exists__ Mit diesem Feld lässt sich das Vorhandensein einer Nachricht testen. Das Vorhandensein einer Nachricht wird davon bestimmt, ob die Nachricht vom XLANG-Ablaufplanungsmodul empfangen oder gesendet wurde.

Dieses Feld wird nicht innerhalb der Nachrichten auf der Datenseite angezeigt. Es wird nur mit Entscheidung- und While-Formen verwendet.
__Sender__ Dieses Feld enthält gegebenenfalls die Identität des Nachrichtenabsenders.

Dieses Feld wird innerhalb der Nachrichten auf der Datenseite angezeigt.
__Status__ Dieses Feld enthält den Status, der von einem COM-Methodenaufruf an einem Port zurückgegeben wird, der an eine COM-Komponente gebunden ist. Dieses Feld wird innerhalb der Nachrichten auf der Datenseite angezeigt.

Anmerkungen

  • Dieses Systemfeld wird nur mit COM-Komponenten- und Skriptkomponenten-Implementierungen verwendet.

  • Der zurückgegebene Status ist stets ein HRESULT.
Document Dieses Feld enthält eine Zeichenfolge mit dem Nachrichtentext, der gesendet bzw. empfangen wird. Es verweist stets auf eine XML-Nachricht.

Anmerkung

  • Dieses Systemfeld wird nur mit Message Queuing- und BizTalk-Messaging-Implementierungen verwendet.

Wichtig

  • Jede Nachricht, die von einer XLANG-Ablaufplaninstanz gesendet wird, muss über eine definierte Quelle für jedes Datenfeld verfügen. Zur Definition der Quelle eines Datenfeldes muss eine Verbindung aus einem anderen Feld in einer anderen Nachricht auf das Feld zeigen.

Anmerkungen

  • Das Kompilierungsmodul, das zum Erstellen eines XLANG-Ablaufplanes verwendet wird, überprüft, ob alle Nur-Eingabe-Felder einer Nachricht definiert sind. Wenn die Nur-Eingabe-Felder teilweise definiert sind, wird der Ablaufplan nicht kompiliert. Die Argumente für eine Methode können auf Eingabe, Ausgabe oder beides lauten. Das Kompilierungsmodul ignoriert die Definitionsanforderung für Argumente, die als Eingabe und Ausgabe definiert sind. Wenn keine eingehenden Verbindungen für Eingabe-Ausgabe-Felder definiert sind, wird der Ablaufplan kompiliert, auch wenn die Nachricht keine Definition für die Daten enthält.

Verwandte Themen

Datenverarbeitung

Flussdiagrammformen

Implementierungsformen


BizTalk-Orchestrierungs-Designer - Tastenkombinationen

Für die Ausführung von Tasks im BizTalk-Orchestrierungs-Designer können Sie Tastenkombinationen verwenden. Die folgende Tabelle ist eine kurze Referenz zu diesen Tastenkombinationen.

Anmerkung

  • Sie können mithilfe der Zehnertastatur den Mauszeiger mit der Tastaturmaus bewegen, um Funktionen zu verwenden, die in dieser Liste nicht enthalten sind. Weitere Informationen zur Tastaturmaus finden Sie in der Windows 2000 Server-Hilfe und in der Advanced Server-Hilfe unter "Bewegen des Mauszeigers mithilfe der Tastatur". Weitere Informationen zur Tastaturmaus finden Sie in der Windows 2000 Professional-Hilfe unter "Bewegen des Mauszeigers mithilfe der Tastaturmaus".
Tastatur | Zweck
ALT oder F10 | Menüleiste aktivieren.
Alt+F4 | Aktives Element schließen oder Programm beenden.
Alt+F7 | Fenster überlappen.
ALT+LEER | Systemmenü für das aktive Element anzeigen.
ALT+Unterstrichener Buchstabe in einem Menünamen | Entsprechendes Menü anzeigen.
Pfeiltasten | Ausgewählte Form in Pfeilrichtung verschieben.
STRG beim Ziehen eines Elements | Ausgewähltes Element kopieren.
STRG+A | Alles markieren.
STRG+C | Ausgewähltes Element auf der Entwurfsseite kopieren.
STRG+F4 | Aktive Zeichnung schließen.
STRG+I | Fenster in Originalgröße anzeigen.
STRG+N | Neue Zeichnung.
STRG+O | Vorhandene Zeichnung öffnen.
STRG+P | Dialogfeld Drucken öffnen.
STRG+Q | Programm beenden.
STRG+UMSCHALT zusammen mit einer der Pfeiltasten | Bildlauf durchführen.
STRG+UMSCHALT, dann Mausklick links | Vergrößern.
STRG+UMSCHALT, dann Mausklick rechts | Verkleinern.
STRG+UMSCHALT+TAB | Zwischen den Registerkarten eines Dialogfeldes von hinten nach vorn umschalten.
STRG+TAB | Zwischen den Registerkarten eines Dialogfeldes von vorn nach hinten umschalten.
STRG+V | Ausgewähltes Element auf der Entwurfsseite einfügen.
STRG+X | Ausgewähltes Element auf der Entwurfsseite ausschneiden.
STRG+Y | Wiederholen.
STRG+Z | Rückgängig machen.
ENTF | Ausgewähltes Element auf der Entwurfsseite löschen.
ESC | Aktuellen Vorgang abbrechen.
F1 | Onlinehilfe anzeigen.
F11 | Dialogfeld Zeichen anzeigen.
F8 | Ausgewählte Formen ausrichten.
NACH-LINKS-TASTE | Fokus nach links wechseln, wenn der Fokus sich auf einer Registerkarte in einem Dialogfeld befindet.
NACH-RECHTS-TASTE | Fokus nach rechts wechseln, wenn der Fokus sich auf einer Registerkarte in einem Dialogfeld befindet.
UMSCHALTTASTE beim Ziehen eines Elements | Element nur in einer geradlinigen horizontalen oder vertikalen Richtung ziehen.
UMSCHALT+TAB | Fokus gegen den Uhrzeigersinn im unteren Fenster von der Registerkarte zu den Fenstern oder Feldern darunter verschieben.
LEERTASTE | Aktivieren oder Deaktivieren eines Kontrollkästchens.
TAB | Fokus im Uhrzeigersinn im unteren Fenster von der Registerkarte zu den Fenstern oder Feldern darunter verschieben.
Unterstrichener Buchstabe eines Befehlsnamens in einem geöffneten Menü | Entsprechenden Befehl ausführen.


XLANG-Ablaufpläne

Die kompilierte Version einer XLANG-Ablaufplanzeichnung ist ein XLANG-Ablaufplan, und das XLANG-Ablaufplanungsmodul führt diesen Ablaufplan aus. Das XLANG-Ablaufplanungsmodul überwacht und steuert den im XLANG-Ablaufplan beschriebenen Geschäftsprozess auf der Grundlage der für den XLANG-Ablaufplan definierten Aktionen, Regeln und Fehlerbehandlungsprozesse.

Dieser Abschnitt behandelt folgende Themen:

  • XLANG-Übersicht

  • Instanzenverwaltung

  • Persistenz

  • Pausierung und Aktivierung

  • Datenverarbeitung


XLANG-Übersicht

XLANG ist eine XML-basierte Sprache zur Beschreibung von Geschäftsprozessinteraktionen. Der BizTalk-Orchestrierungs-Designer kann XLANG-Ablaufplanzeichnungen in XLM-strukturierte XLANG-Ablaufplandateien kompilieren. Da XLANG XML-basiert ist, müssen XLANG-Ablaufpläne XML-Regeln für wohlgeformte Dokumente sowie einer Spezifikation oder einem Standardschema entsprechen.


Instanzenverwaltung

Sie sollten den Unterschied zwischen einer abstrakten Definition eines Geschäftsprozesses und mehreren aktiven Instanzen eines Geschäftsprozesses kennen, um die Instanzenverwaltung durch das XLANG-Ablaufplanungsmodul zu verstehen. Im BizTalk-Orchestrierungs-Designer können Sie eine Geschäftsprozessdefinition entwerfen und diese als XLANG-Ablaufplanzeichnung (eine SKV-Datei) speichern. Wenn Sie eine XLANG-Ablaufplanzeichnung erstellt haben, kompilieren Sie diese in einen XLANG-Ablaufplan (eine SKX-Datei). Wenn Sie den XLANG-Ablaufplan bereitstellen, werden wahrscheinlich mehrere Instanzen des Ablaufplanes gleichzeitig ausgeführt. Jede XLANG-Ablaufplaninstanz kann eine von der Lebensspanne der anderen Instanzen unabhängige Lebensspanne besitzen. Wenn Sie eine Anwendung zur Unterstützung mehrerer XLANG-Ablaufplaninstanzen entwerfen, sollten Sie Folgendes beachten:

  • Aktivieren neuer Instanzen von XLANG-Ablaufplänen beim Empfang von Nachrichten. Sie können Ihre Anwendung so entwerfen, dass eine neue XLANG-Ablaufplaninstanz durch die GetObject-COM-Funktion aktiviert wird, sobald eine Nachricht empfangen wird. Wenn Sie beispielsweise eine Active Server Page (ASP) verwenden, um eine Nachricht mit einem Auftrag oder einer Kundendienstanfrage zu empfangen, muss die ASP die GetObject-COM-Funktion verwenden, um einen XLANG-Ablaufplan zu aktivieren.

Sie können auch den BizTalk-Bindungs-Assistenten für Messaging verwenden, um eine Portbindung zu erstellen, die als benannter Standort dienen kann, an den Nachrichten gesendet werden. BizTalk Server 2000 stellt einen automatisierten Mechanismus zur Aktivierung einer Instanz eines XLANG-Ablaufplanes bereit, wenn ein an BizTalk-Messaging gebundener Port eine Nachricht empfängt. Auf der Seite Informationen über die XLANG-Ablaufplanaktivierung des BizTalk-Bindungs-Assistenten für Messaging werden Sie aufgefordert zu bestätigen, ob der Kanal in den BizTalk-Messagingdiensten so konfiguriert wurde, dass nach der Aktivierung einer neuen Instanz dieses XLANG-Ablaufplanes eine Nachricht an diesen Port gesendet wird. Zur Ausführung dieses Prozesses müssen Sie den Messagingport-Assistenten im BizTalk-Messaging-Manager ausführen. Geben Sie auf der Seite Zielanwendung des Messagingport-Assitenten den Namen des Ports sowie den Namen und den Standort des XLANG-Ablaufplanes an.

  • Korrelieren des Nachrichtenaustauschs an XLANG-Ablaufplaninstanzen. Jeder Instanz eines XLANG-Ablaufplane wird durch das XLANG-Ablaufplanungsmodul ein global eindeutiger Bezeichner (GUID) zugewiesen. Auf diese Weise kann jeder Port in jeder aktiven Instanz eines XLANG-Ablaufplanes eindeutig adressiert werden. Dadurch wird die direkte Kommunikation an bestimmte Ports in bestimmten XLANG-Ablaufplaninstanzen aktiviert. Durch das Aktivieren der direkten Kommunikation über eindeutig adressierbare Portstandorte wird das Problem der Verwendung eines einzelnen Standortes für die Verteilung von Nachrichten an Instanzen vermieden. Die erste von einer Ablaufplaninstanz gesendete Nachricht geht wahrscheinlich an einen statischen Port (einen benannten Standort). Wenn der XLANG-Ablaufplan aktiviert ist, sendet diese Instanz die Standorte ihrer dynamischen Ports (eindeutige Standorte auf Instanzebene) an Empfänger, die für die Kommunikation zurück an die Ports verantwortlich sind. Dies entspricht E-Mail-Nachrichten, die mit eindeutigen Antwortadressen gesendet werden. Die folgende Liste beschreibt die dynamische Bindungsunterstützung in den einzelnen BizTalk Server-Bindungstechnologien:
    • Wenn Sie auf der Seite Statische oder dynamische Kommunikation des Bindungs-Assistenten für COM-Komponenten oder für Skriptkomponenten die Option Statisch auswählen, erstellt das XLANG-Ablaufplanungsmodul die XLANG-Ablaufplaninstanz der Komponente. Wenn Sie Dynamisch auswählen, muss eine andere Anwendung vor der Instanziierung der Komponente einen Schnittstellenzeiger oder Moniker (als Feld in einer Nachricht) senden.

      Sie können auch die Option Keine Instanziierung auswählen. Weitere Informationen zur Komponenteninstanziierung finden Sie unter Statische und dynamische Ports.

    • Wenn Sie auf der Seite Informationen über statische oder dynamische Warteschlangen des Bindungs-Assistenten für Message Queuing die Option Statische Warteschlange auswählen und auf Weiter klicken, wird die Seite Warteschlangeninformationen aufgerufen. Auf der Seite Warteschlangeninformationen können Sie das Erstellen einer separaten Warteschlange auf Instanzebene für jede XLANG-Ablaufplaninstanz oder auch die Verwendung einer einzelnen Warteschlange für alle aktiven Instanzen festlegen. Sie müssen das Erstellen einer separaten Warteschlange auf Instanzebene für jede XLANG-Ablaufplaninstanz festlegen, um die Korrelation zu aktivieren.

    • Wenn Sie auf der Seite Informationen über statische oder dynamische Warteschlangen des Bindungs-Assistenten für Message Queuing die Option Dynamische Warteschlange auswählen, muss eine andere Anwendung vor dem Senden oder Empfangen von Nachrichten über den Port den Namen der Warteschlange (als Feld in einer Nachricht) senden.

    • Auf der Seite Informationen über statische oder dynamische Kanäle des BizTalk-Bindungs-Assistenten für Messaging können Sie wahlweise einen bestimmten Kanalnamen bereitstellen oder angeben, dass die BizTalk-Messagingdienste den richtigen Kanal zur Laufzeit anhand der Portkonfigurationsinformationen identifizieren. Weitere Informationen zum Nachrichtenaustausch finden Sie unter Integrieren der BizTalk-Dienste.

    Wichtig

    • Sie müssen sicherstellen, dass eine Nachricht mit derselben XLANG-Ablaufplaninstanz korreliert, die an einer früheren Kommunikation mit einem Handelspartner beteiligt war.
  • Skalieren der Anwendung. Alle XLANG-Ablaufplaninstanzen, die nicht im Speicher vorhanden sein müssen, sollten pausiert werden. Eine XLANG-Ablaufplaninstanz muss nicht im Speicher vorhanden sein, wenn eine XLANG-Ablaufplaninstanz auf das Eintreffen einer Nachricht wartet.

Anmerkung

  • Alle Implementierungsformen zeigen einen Schatten an, um darauf hinzuweisen, dass der Standort dynamisch gebunden und zur Laufzeit definiert wird.

Verwandte Themen

Datenverarbeitung

Pausierung und Aktivierung

Verwalten des Sitzungsstatus

Persistenz


Persistenz

Das XLANG-Ablaufplanungsmodul speichert die folgenden Informationen in der Persistenzdatenbank:

  • Die Struktur der XLANG-Ablaufpläne.

  • Den Status aktivierter XLANG-Ablaufplaninstanzen.

  • Nachrichten, die bei der Ausführung einer XLANG-Ablaufplaninstanz gesendet oder empfangen werden.

Durch das persistente Speichern ermöglicht das XLANG-Ablaufplanungsmodul folgende Szenarien:

  • Pausieren und Aktivieren langlebiger Ablaufpläne. Während einer langlebigen Transaktion kann ein Systemfehler auftreten. Sobald das System wieder ausgeführt wird, muss das XLANG-Ablaufplanungsmodul auf die Persistenzdatenbank zurückgreifen, um festzustellen, wo der Ablaufplan fortgesetzt werden muss.

  • Wiederherstellen des Status einer Ablaufplaninstanz bei einem Transaktionsfehler. Während einer Transaktion kann ein Systemfehler auftreten, so dass die Transaktion abgebrochen wird. Sobald das System wieder ausgeführt wird, muss das XLANG-Ablaufplanungsmodul auf die Persistenzdatenbank zurückgreifen, um festzustellen, wo der Ablaufplan fortgesetzt werden muss.

  • Unterstützung für das Debuggen und Überwachen von aktiven Ablaufplänen. Debug- und Überwachungstools können Abfragen an die Persistenzdatenbank richten, um Informationen zum Status der Ablaufplaninstanzen bereitzustellen.

Die Unterstützung für das persistente Speichern des Status eines XLANG-Ablaufplanes vor dem Start und nach Beenden einer Transaktion sorgt für Beständigkeit und gewährleistet, dass alle Commits für Änderungen im System dauerhaft sind. Dadurch ist es auch möglich, eine Transaktion bei einem Fehler zu wiederholen. Der Status einer aktiven Ablaufplaninstanz wird unter den folgenden Bedingungen persistent gespeichert:

  • Zu Beginn einer Transaktion. Wenn der Geschäftsprozess zum Start einer Transaktion führt, muss die Wiederholungsanzahl der Transaktion in der Persistenzdatenbank aktualisiert werden. So kann das XLANG-Ablaufplanungsmodul die Wiederholungsanzahl überwachen, wenn bei einer Transaktion ein Systemfehler auftritt.

  • Am Ende einer Transaktion. Wenn der Geschäftsprozess aus einer Transaktion heraus führt, muss der Ablaufplanstatus aktualisiert werden, um gegebenenfalls ein Rollback zu ermöglichen. Diese Aktualisierung erfolgt im Rahmen der Transaktion, um eine unteilbare Datenbankpersistenz zu gewährleisten.

Verwandte Themen

Pausierung und Aktivierung

Instanzenverwaltung

Verwalten des Sitzungsstatus


Pausierung und Aktivierung

Wenn mehrere Instanzen eines XLANG-Ablaufplanes über einen langen Zeitraum gleichzeitig ausgeführt werden, ist es häufig unpraktisch, wenn alle im Speicher verbleiben können. Das XLANG-Ablaufplanungsmodul stellt eine Pausierungs-/Aktivierungs-Infrastruktur bereit, um dieses Problem zu beheben.

Wenn eine XLANG-Ablaufplaninstanz für einen längeren Zeitraum auf eine Nachricht warten soll und keine andere Aktivität innerhalb des Ablaufplanes erfolgt, kann das XLANG-Ablaufplanungsmodul die XLANG-Ablaufplaninstanz pausieren. Bei der Pausierung einer XLANG-Ablaufplaninstanz wird jeder instanzenspezifische Status in der Persistenzdatenbank persistent gespeichert und die Instanz aus dem Speicher entfernt. Wenn eine Nachricht bei einer Portadresse für die pausierende XLANG-Ablaufplaninstanz eintrifft, wird die Instanz aktiviert. Bei der Aktivierung einer XLANG-Ablaufplaninstanz wird die Instanz aus der Datenbank im Speicher wiederhergestellt.

Eine XLANG-Ablaufplaninstanz bleibt pausiert, bis sie aktiviert oder durch einen Administrator explizit beendet wird. Auf diese Weise kann ein Geschäftsprozess für einen längeren Zeitraum zuverlässig ausgeführt werden.

Das XLANG-Ablaufplanungsmodul kann eine Wartezeiteinstellung verwenden, um die Zeitspanne festzulegen, die eine Aktion inaktiv bleiben kann, bevor die XLANG-Ablaufplaninstanz in der Persistenzdatenbank pausiert wird. Mit dieser Wartezeiteinstellung kann das XLANG-Ablaufplanungsmodul die XLANG-Ablaufplaninstanz in der Persistenzdatenbank pausieren und diese später aktivieren, wenn die Nachricht eintrifft. Es gibt jedoch einige Situationen, in denen die Wartezeiteinstellung nicht zum Pausieren eines Ablaufplanes führt:

  • Die Ablaufplaninstanz befindet sich nicht im Ruhezustand. Dies kann vorkommen, wenn für einen der aktuellen Prozessabläufe in der XLANG-Ablaufplaninstanz Aktionen ausgeführt werden. Alle Prozessabläufe in der Ablaufplaninstanz müssen denselben Status besitzen, bevor das XLANG-Ablaufplanungsmodul die XLANG-Ablaufplaninstanz pausieren kann. Die Wartezeit für alle ausstehenden Aktionen muss einen bestimmten Schwellenwert überschreiten, bevor die Pausierung ausgeführt wird.

  • Es liegen ausstehende Transaktionen im DTC-Stil vor. Das XLANG-Ablaufplanungsmodul nimmt keine Pausierung des Ablaufplanes vor, wenn dieser eine Transaktion im DTC-Stil ausführt, da Transaktionen in diesem Stil normalerweise kurzlebig sind.

  • Die Instanz verfügt über Live-Ports, die nicht persistent gespeichert werden können. Ein Live-Port ist ein Portobjekt oder ein Port, der implementiert wurde und später in der Ablaufinstanz verwendet werden kann. Die Lebensdauer eines Ports ist ein wichtiger Aspekt bei der Ausführung einer Ablaufplaninstanz. Ports sind an Implementierungstechnologien, z. B. COM-Schnittstellen, gebunden. Wenn die Implementierungstechnologie, an die ein Port gebunden ist, nicht persistent gespeichert werden kann, und diese Implementierungstechnologie Statusinformationen beinhaltet, die später wieder verwendet werden, kann die Instanz nicht pausiert und dann wieder aktiviert werden. Wenn es zu einem Fehler in der Persistenzdatenbank kommt und diese später erneut ausgeführt wird, gehen die Statusinformationen verloren, und die Ausführung der Ablaufplaninstanz kann nicht von dem Status aus fortgesetzt werden, in dem die Instanz zuletzt pausiert wurde.

Wenn das XLANG-Ablaufplanungsmodul beendet wird, werden so viele Informationen wie möglich in der Persistenzdatenbank gespeichert, einschließlich aller Informationen, die nicht im Kontext zur Transaktion stehen.

Verwandte Themen

Instanzenverwaltung

Verwalten des Sitzungsstatus

Persistenz

Verwenden des Methodenkommunikations-Assistenten

Verwenden des Assistenten für XML-Kommunikation


Datenverarbeitung

In XLANG sind alle Daten in einer Gruppe eindeutig benannter Nachrichten enthalten. Wenn eine Nachricht von einer Aktion empfangen wird, gelangen neue Daten in eine XLANG-Ablaufplaninstanz.

Jede XLANG-Ablaufplanzeichnung besitzt eine Datenseite. Auf der Datenseite können Sie den Datenfluss in einem XLANG-Ablaufplan beschreiben. Zeichnen Sie einen Pfeil vom Quellnachrichtenfeld zum Zielnachrichtenfeld, um anzuzeigen, dass Daten in einem Nachrichtenfeld in ein anderes Nachrichtenfeld führen.

Außer der Nachricht Constants enthält keines der Nachrichtenfelder in den Nachrichten auf der Datenseite zu Anfang einen Wert. Die Nachricht Constants wird mit den auf der Datenseite angegebenen Werten initialisiert. Sie wird automatisch für jede neue XLANG-Ablaufplaninstanz initialisiert. Weitere Informationen zur Verwendung von Konstanten finden Sie unter Die Nachricht "Constants". Die Werte der anderen angezeigten Nachrichten werden festgelegt, wenn die Nachricht in der XLANG-Ablaufplaninstanz gesendet oder empfangen wird. Eine Nachricht kann von mehreren Aktionen empfangen werden. Sobald eine Nachricht empfangen wird, werden die Werte für diese Nachricht überschrieben. Der Datenfluss in die empfangene Nachricht wird nicht verwendet, um die Werte für eine andere empfangene Nachricht festzulegen, auch wenn die Nachricht an einen anderen Punkt im XLANG-Ablaufplan gesendet wird. Exklusiv gesendete Nachrichten verwenden den Datenfluss, der auf der Datenseite angezeigt wird, um ihre Nachrichtenfelder festzulegen. Ein Ablaufplan wird erst dann kompiliert, wenn alle Felder für alle gesendeten Nachrichten festgelegt wurden.

Wenn ein Feld auf der Datenseite aus einem XPath stammt, der auf einen optionalen Knoten im XML-Schema verweist, verwenden Sie die folgenden Richtlinien:

  • Für empfangene Nachrichten, wenn der optionale Knoten existiert. Wenn diese Nachricht empfangen wird und der optionale Knoten im XML-Dokument existiert, speichert das Feld XPath den Knotenwert.

  • Für empfangene Nachrichten, wenn der optionale Knoten nicht existiert. Wenn diese Nachricht empfangen wird und der optionale Knoten nicht existiert, speichert das Feld XPath einen NULL-Wert. Sie müssen eine Entscheidungsregel mit dem VBScript-Ausdruck IsNull (Message.Field) für dieses Feld verwenden, um festzustellen, ob die empfangene Nachricht den optionalen Knoten enthält. Wenn Sie das Vorhandensein eines Wertes nicht überprüfen und dieses Feld einen Datenfluss in eine andere Nachricht bereitstellt, die gesendet wird, tritt ein Fehler auf, wenn das XLANG-Ablaufplanungsmodul versucht, die zu sendende Nachricht zu erstellen.

  • Für gesendete Nachrichten, wenn der optionale Knoten existiert. Wenn diese Nachricht (mit dem auf einen optionalen XML-Knoten verweisenden XPath-Knoten) gesendet wird, verwendet das XLANG-Ablaufplanungsmodul den Datenfluss, um die Nachricht zu erstellen. Wenn der Knoten im Feld Document der Nachricht vorhanden ist, wird er vom XLANG-Ablaufplanungsmodul mit dem Wert für den XPath überschrieben.

  • Für gesendete Nachrichten, wenn der optionale Knoten nicht existiert. Wenn diese Nachricht (mit dem auf einen optionalen XML-Knoten verweisenden XPath-Knoten) gesendet wird, verwendet das XLANG-Ablaufplanungsmodul den Datenfluss, um die Nachricht zu erstellen. Wenn der Knoten im bereitgestellten Feld Document nicht vorhanden ist, wird der Knoten vom XLANG-Ablaufplanungsmodul nicht erstellt, um überschrieben zu werden. Dies verursacht einen Fehler.

Verwenden Sie für Nachrichten, die von einer Nachrichtenwarteschlange empfangen oder gesendet werden, die folgenden Richtlinien:

  • Für empfangene Nachrichten. Wenn eine Aktion eine nicht auf XML basierende Nachricht von einer Nachrichtenwarteschlange empfangen soll, müssen Sie Nachrichten in der Warteschlange als Zeichenfolgen empfangen auf der Seite Informationen über die XML-Konvertierung des Assistenten für XML-Kommunikation auswählen. In dieser Konfiguration zeigt die Nachrichtenform auf der Datenseite ein neues StringData-Feld an. Dieses StringData-Feld enthält die nicht auf XML basierende Nachricht, die von der Warteschlange empfangen wurde. Das Feld Documents in der Nachricht enthält das StringData-Feld, umgeben von dem Standard-XML-Wrapper des XLANG-Ablaufplanungsmoduls.

  • Für gesendete Nachrichten. Wenn eine Aktion eine nicht auf XML basierende Nachricht an eine Nachrichtenwarteschlange senden soll, müssen Sie Nachrichten als Zeichenfolge an die Warteschlange senden auf der Seite Informationen über die XML-Konvertierung des Assistenten für XML-Kommunikation auswählen. In dieser Konfiguration zeigt die Nachrichtenform auf der Datenseite ein neues StringData-Feld an. Zur Vervollständigung dieser Konfiguration müssen Sie eine neue Konstante (mit dem Standard-XML-Wrapper des XLANG-Ablaufplanungsmoduls) in der Nachricht Constants auf der Datenseite erstellen. Der Name dieser Konstante ist nicht relevant, der Datentyp muss jedoch string und der Wert folgender sein: <?xml version="1.0" ?> <StringData> </StringData>. Wenn Sie diese neue Konstante erstellt haben , müssen Sie eine Datenflussverbindung von der neuen Konstante in der Nachricht Constants an das Feld Document in der Nachrichtenform zeichnen. Außerdem müssen Sie eine Datenflussverbindung von dem Feld mit der nicht auf XML basierenden Zeichenfolge zum neuen StringData-Feld in der Nachrichtenform zeichnen.

Anmerkungen

  • Die Datenflussrichtung ist unabhängig von der Richtung des Nachrichtenflusses. Der Nachrichtenfluss zeigt an, ob eine Nachricht gesendet oder empfangen wurde.

  • Wenn Sie möchten, dass der XLANG-Ablaufplan Daten mithilfe eines Methodenaufrufs empfangen kann, ohne die Komponente zu instanziieren, wählen Sie Keine Instanziierung auf der Seite Statische oder dynamische Kommunikation des Bindungs-Assistenten für COM- oder für Skriptkomponenten. Wenn Sie Keine Instanziierung auswählen, wird die Komponente nicht instanziiert und kein Code für den Methodenaufruf ausgeführt. Stattdessen gibt der XLANG-Ablaufplan diese Informationen als Antwort zurück, wenn er die Methodenanforderungsinformationen abfängt. Der Methodenaufruf wird umgangen.

  • Wenn eine Nachricht nur innerhalb des Nachrichtentextes einer While-Schleife verwendet wird, werden die Nachrichtenwerte nicht bei jedem Schleifendurchlauf initialisiert. Wenn eine Nachricht innerhalb und außerhalb des Nachrichtentextes einer While-Schleife verwendet wird, werden die Nachrichtenwerte bei jedem Schleifendurchlauf beibehalten. Die Nachrichtenwerte können auch beibehalten werden, bevor der Geschäftsprozess zur While-Form führt sowie danach.

  • Wenn eine Nachricht innerhalb der Seiten Kompensierung für Transaktion oder Bei Fehler von Transaktion einer While-Schleife initialisiert wird, sind die Nachrichtenwerte außerhalb der Schleife nicht verfügbar.

  • Wenn ein Feld in einer XML-Nachricht (einschließlich der Nachricht Constants) mit dem char-Datentyp den Datenfluss in ein Methodennachrichtenfeld bereitstellt, wird das Feld für die Methode in den integer-Datentypkonvertiert. Wenn das Methodennachrichtenfeld den string-Datentyp besitzt, enthält die Zeichenfolge den ganzzahligen Wert, nicht das Zeichen. Wenn dieses Problem auftreten sollte und das Quellfeld Teil der Nachricht Constants ist, ändern Sie den Datentyp des Konstantenfeldes auf string. Wenn das Quellfeld Teil einer XML-Nachricht ist, müssen Sie eine Komponente verwenden, um den char-Datentyp in den string-Datentyp umzuwandeln.

Dieser Abschnitt behandelt folgende Themen:

  • Die Datenseite

  • Die Nachricht "Constants"

  • Die Nachricht "Port References"

  • Felddatentypen

  • Systemfelder

  • Knotenpfadfelder


Die Datenseite

Jede XLANG-Ablaufplanzeichnung besitzt eine Datenseite. Auf der Datenseite wird Folgendes angezeigt:

  • Eine Nachrichtenform für jede Nachricht im XLANG-Ablaufplan.

  • Eine Nachricht Constants.

  • Eine Nachricht Port References mit einem Portfeld für jeden Port in der XLANG-Ablaufplanzeichnung.

  • Grafische Verbindungen, die den Datenfluss zwischen den Nachrichtenfeldern zeigen.

Nachrichten bestehen aus eindeutig benannten Feldern, die jeweils ein Datenelement eines bestimmten Datentyps enthalten. Jede Nachricht im XLANG-Ablaufplan wird auf der Datenseite als Tabelle angezeigt. Jede Tabelle zeigt den Namen der Nachricht sowie eine Liste der Feldnamen und der entsprechenden Datentypen an. Systemfelder, die keinen Datenfluss erfordern, werden mit einem gelben Hintergrund angezeigt. Benutzerfelder und Systemfelder, die keinen Datenfluss erfordern, werden mit einem weißen Hintergrund angezeigt.

Verbindungen auf der Datenseite zeigen von der rechten Seite eines Quellnachrichtenfeldes zur linken Seite eines Zielnachrichtenfeldes. Diese Verbindung zeigt an, dass das Quellnachrichtenfeld die Daten für das Zielnachrichtenfeld bereitstellt. Wenn die Zielnachricht erstellt werden muss, kopiert das XLANG-Ablaufplanungsmodul die Daten zur Laufzeit vom Quellnachrichtenfeld in das Zielnachrichtenfeld. Ist die Quellnachricht noch nicht eingetroffen, tritt ein Laufzeitfehler auf.

Anmerkungen

  • Die folgenden Datentypen werden auf der Datenseite nicht unterstützt:
    • BinHex

    • BinBase64

    • I8

    • UI8

Wenn Sie in einem XML-Dokument einen Knoten vom Typ BinHex, BinBase64, I8 oder UI8 haben und Sie festlegen, dass der Knoten mithilfe des XPath zu diesem Knoten in den Bereich des XLANG-Ablaufplanungsmoduls auf der Datenseite gebracht werden soll, wird der Knoten in eine Zeichenfolge konvertiert.

  • Es besteht eine Begrenzung von 100 Zeichen für alle Feldnamen in XLANG-Ablaufplänen.

Verwandte Themen

Die Nachricht "Constants"

Datenverarbeitung

Felddatentypen

Knotenpfadfelder

Die Nachricht "Port References"

Systemfelder


Die Nachricht "Constants"

Sie können die Nachricht Constants verwenden, um eine XLANG-Ablaufplaninstanz mit Daten zu initialisieren. Innerhalb des XLANG-Ablaufplanungsmoduls führt die Nachricht Constants eine eindeutige Funktion aus; sie wird weder gesendet noch empfangen. Sie wird für jede neue XLANG-Ablaufplaninstanz automatisch initialisiert. Doppelklicken Sie auf die Nachricht Constants, um eine Konstante zur Nachricht Constants hinzuzufügen, oder doppelklicken Sie auf ein Feld in der Nachricht Constants, um das Dialogfeld Eigenschaften der Nachricht Constants zu öffnen. Klicken Sie im Dialogfeld Eigenschaften der Nachricht Constants auf Hinzufügen, um das Dialogfeld Eigenschaften der Konstante zu öffnen. Im Dialogfeld Eigenschaften der Konstante können Sie die Konstante benennen, einen Datentyp für die Konstante auswählen und ihr einen Wert zuweisen.

Anmerkung

  • XML verarbeitet keine Windows-Gebietsschemaeinstellungen für Datumsformate. Wenn Sie ein Datum für eine Konstante in einem lokalisierten Format zuweisen möchten, legen Sie für die Konstante den stringDatentyp fest. Wenn diese Konstante Daten für ein Feld mit dem date-Datentyp bereitstellt, übersetzt das XLANG-Ablaufplanungsmodul die Zeichenfolge in ein Datum und verwendet dabei das lokalisierte Format.

Verwandte Themen

Datenverarbeitung Die Datenseite

Felddatentypen

Knotenpfadfelder

Die Nachricht "Port References"

Systemfelder


Die Nachricht "Port References"

Die Nachricht Port References enthält eine Liste aller Ports, die auf der Geschäftsprozessseite erstellt werden. Sobald ein neuer Port auf der Geschäftsprozessseite hinzugefügt wird, wird ein neuer Verweis zu dieser Liste hinzugefügt. Mit der Nachricht Port References können Sie den Ursprung von Portstandorten angeben. Die Nachricht Port References enthält ein Portfeld für jeden Port in der XLANG-Ablaufplanzeichnung.

Es gibt Szenarien, in denen Ports in einem XLANG-Ablaufplan zur Entwurfszeit nicht bekannt sind. Dies kann vorkommen, wenn das Ziel bzw. der Ursprung von Nachrichten vom Inhalt anderer Nachrichten bestimmt wird. Ein Geschäftsprozess kann beispielsweise eine Situation beschreiben, in der eine Aktion auf eine Nachricht mit einer Bestätigung an den Handelspartner reagieren muss, von dem die Nachricht stammt. In diesem Beispiel verfügt die empfangene Nachricht im Allgemeinen über ein Feld für die Antwortadresse, das die Ursprungsadresse der Nachricht enthält. Der XLANG-Ablaufplan muss den Inhalt des Feldes für die Antwortadresse mit der Zieladresse der Bestätigungsnachricht korrelieren können. Sie können die Nachricht Port References und eine Bestätigungsnachricht auf der Datenseite verwenden, um dieses Szenario zu implementieren. Weitere Informationen zum Nachrichtenaustausch finden Sie unter Integrieren der BizTalk-Dienste.

Wichtig

  • Aktionen in unterschiedlichen Abzweigen einer Verzweigung können nicht miteinander kommunizieren. Eine Aktion in einer Verzweigung kann z. B. keine Nachricht an eine Warteschlange senden, wenn eine Aktion in einer anderen Verzweigung auf den Empfang einer Nachricht aus dieser Warteschlange wartet. Wenn der Entwurf Ihrer XLANG-Ablaufplanzeichnung fälschlicherweise die Unterstützung der Kommunikation jeglicher Art zwischen Aktionen in unterschiedlichen Verzweigungen vorsieht, kann es zu einem Fehler der XLANG-Ablaufplaninstanz zur Laufzeit kommen, ohne dass jedoch ein Fehler angezeigt wird.

Verwandte Themen

Die Nachricht "Constants"

Datenverarbeitung

Felddatentypen

Knotenpfadfelder

Systemfelder


Felddatentypen

Der BizTalk-Orchestrierungs-Designer zeigt alle Datentypen mit dem jeweiligen XML-Datentypnamen an. Die folgende Tabelle enthält eine Liste der OLE-Automatisierungs-, Visual Basic- und C-Programm-Äquivalente für die angezeigten XML-Datentypnamen.

XML-UI-Ansicht | OLE-Automatisierung | Visual Basic | C
Einfache Typen |  |  |
boolean | VT_BOOL | Boolean | VARIANT_BOOL
string | VT_BSTR | String | BSTR
cy | VT_CY | Currency | CURRENCY
date | VT_DATE | Date | DATE
dispatch | VT_DISPATCH | Object | IDispatch
error | VT_ERROR |  | SCODE
i1 | VT_I1 |  | signed char
i2 | VT_I2 | Integer | SHORT
i4 | VT_I1 | Long | LONG
int | VT_INT |  | INT
r4 | VT_R4 | Single | FLOAT
r8 | VT_R8 | Double | DOUBLE
ui1 | VT_UI1 | Byte | BYTE
ui2 | VT_UI2 |  | USHORT
ui4 | VT_UI4 |  | ULONG
uint | VT_UINT |  | UINT
unknown | VT_UNKNOWN | Object | IUnknown
variant | VT_VARIANT | Variant | VARIANT

Verwandte Themen

Die Nachricht "Constants"

Datenverarbeitung

Die Datenseite

Knotenpfadfelder

Die Nachricht "Port References"

Systemfelder


Systemfelder

Jede Nachricht kann außerdem Systemfelder enthalten, die automatisch durch das XLANG-Ablaufplanungsmodul erstellt werden.

Systemfeldname | Wann wird das Systemfeld angezeigt? | Beschreibung
__Status__ | Wenn die Nachricht von einem Port empfangen wird, der an eine COM- oder Skriptbindung gebunden ist. | HRESULT des Methodenaufrufs.
__Sender__ | Wenn die Nachricht an einen Port gesendet bzw. von diesem empfangen wird. | Wenn eine Nachricht empfangen wird, ist dies die Absenderkennung, die von Message Queuing oder COM bereitgestellt wird. Wenn diese Nachricht gesendet wird, ist der Wert NULL.
Document | Wenn die Nachricht von einem Port gesendet wird, der an Message Queuing oder BizTalk-Messaging gebunden ist. | Eine Zeichenfolge mit dem Nachrichtentext, der gesendet bzw. empfangen wird.

Verwandte Themen

Die Nachricht "Constants"

Datenverarbeitung

Felddatentypen

Knotenpfadfelder

Die Nachricht "Port References"


Knotenpfadfelder

Wenn ein an Message Queuing oder BizTalk-Messaging gebundener Port ein XML-Dokument empfängt, können Sie bestimmte Dokumentknoten in den Datenbereich des XLANG-Ablaufplanungsmoduls bringen. Wenn keine bestimmten Knoten ausgewählt werden, behandelt das XLANG-Ablaufplanungsmodul das XML-Dokument als verdeckte Zeichenfolge, die im Dokumentensystemfeld enthalten ist.

Sie können Dokumentknoten mithilfe der Seite Nachrichtenspezifikation im Assistenten für XML-Kommunikation in den Datenbereich des XLANG-Ablaufplanungsmoduls bringen. Wenn Sie eine XML-Spezifikation bereitstellen, sind die Schaltflächen Hinzufügen und Entfernen aktiviert.

Verwandte Themen

Die Nachricht "Constants"

Datenverarbeitung

Felddatentypen

Die Nachricht "Port References"

Systemfelder

Verwenden des Assistenten für XML-Kommunikation


Erstellen von XLANG-Ablaufplanzeichnungen

Es gibt fünf Aufgaben, die Sie ausführen müssen, wenn Sie einen XLANG-Ablaufplan entwerfen:

  • Zeichnen Sie eine Darstellung des Geschäftsprozesses, den der XLANG-Ablaufplan ausführen wird. Verwenden Sie Flussdiagrammformen, um den Geschäftsprozessablauf auf der linken Seite der Entwurfsseite zu beschreiben. Ihr primärer Geschäftsprozess wird auf der Geschäftsprozessseite gezeichnet. Alternative Prozesse werden auf den Seiten Kompensierung für Transaktion und Bei Fehler von Transaktion gezeichnet.

  • Definieren Sie Regeln für die Verzweigung von Entscheidungen und Prozessen, die innerhalb des Geschäftsprozesses wiederholt werden. Definieren Sie parallele Prozesse, und entwerfen Sie die in dem Geschäftsprozess erforderlichen Transaktionen und untergeordneten Transaktionen.

  • Erstellen Sie die für den Geschäftsprozess erforderlichen Portimplementierungen. Es stehen vier Implementierungstechnologien zur Verfügung: COM-Komponenten, Windows-Skriptkomponenten, Message Queuing-Dienste und BizTalk-Messagingdienste.

  • Definieren Sie den Datenfluss zwischen Nachrichten. Der gesamte Datenfluss zwischen Nachrichten wird auf der Datenseite gezeichnet.

  • Zeichnen Sie erforderliche Geschäftsprozesse für fehlgeschlagene Transaktionen. Alternative Geschäftsprozesse werden auf den Seiten Kompensierung für Transaktion und Bei Fehler von Transaktion gezeichnet.

Anmerkung

  • Sie können Flussdiagrammformen und nobr>Implementierungsformen zu den Geschäftsprozess-, Kompensierungs- und Fehlerseiten hinzufügen. Diese Formen sind auf der Datenseite nicht verfügbar.

Dieser Abschnitt behandelt folgendeThemen:

  • Entwerfen von Geschäftsprozessen

  • Behandeln von Ausnahmen

  • Implementieren von Geschäftsprozessen


Entwerfen von Geschäftsprozessen

Im BizTalk-Orchestrierungs-Designer befindet sich auf der linken Seite der Geschäftsprozessseite der Bereich, in dem Sie Geschäftsprozesse entwerfen können. Die Geschäftsprozessseite wird durch eine Trennlinie in einen Geschäftsprozess-Entwurfsbereich auf der linken und einen Implementierungsbereich auf der rechten Seite unterteilt.

Dieser Abschnitt behandelt folgende Themen:

  • Entwerfen von Aktionen

  • Entwerfen von Regeln

  • Entwerfen von Parallelität

  • Entwerfen von Transaktionen


Entwerfen von Aktionen

Der Geschäftsprozess muss dem Ablauf von der Beginn-Form zur ersten Flussdiagrammform in Ihrer XLANG-Ablaufplanzeichnung folgen. Gewöhnlich handelt es sich bei der ersten Flussdiagrammform in Ihrer XLANG-Ablaufplanzeichnung um eine Aktion-Form.

Es gibt zwei konfigurierbare Eigenschaften für eine Beginn-Form. Im Dialogfeld Beginneigenschaften können Sie die Transaktionsmodell-Eigenschaft konfigurieren, um festzulegen, ob Transaktion-Formen in einer XLANG-Ablaufplaninstanz unterstützt werden oder ob der XLANG-Ablaufplan aus der COM-Komponente einer Transaktion aktiviert wird. Mit der ersten Option wird die Unterstützung für Transaktion-Formen aktiviert, mit der zweiten Option wird die Unterstützung für Transaktion-Formen deaktiviert.

Sie können im Dialogfeld Beginneigenschaften außerdem die Transaktionsaktivierung-Eigenschaft und die XLANG-Identität-Eigenschaft konfigurieren. Weitere Informationen zur Transaktionsaktivierung finden Sie unter Entwerfen von Transaktionen.

Die XLANG-Identität-Eigenschaft ist schreibgeschützt. Sie enthält einen globalen eindeutigen Bezeichner (GUID), der zur Korrelation einer Version der XLANG-Ablaufplanzeichnung mit dem von dieser generierten XLANG-Ablaufplan verwendet wird. Der GUID wird automatisch erstellt, wenn eine neue Zeichnung erstellt wird. Ein neuer GUID wird erstellt, sobald eine XLANG-Ablaufplanzeichnung geändert wird.

Die einzige konfigurierbare Eigenschaft einer Aktion-Form ist der Name der Aktion. Der Name der Aktion darf maximal 32 Zeichen lang sein. Aktionsnamen haben keine Auswirkung auf das Verhalten eines XLANG-Ablaufplanes.

Verwandte Themen

Entwerfen von Parallelität

Entwerfen von Regeln

Entwerfen von Transaktionen

Flussdiagrammformen


Entwerfen von Regeln

Regeln sind Ausdrücke der Microsoft Visual Basic Scripting Edition (VBScript), die von Entscheidung- und While-Formen verwendet werden. Es gibt folgende Regeln:

  • Spezifische VBScript-Ausdrücke wie Date und Uhrzeit.

  • Ausdrücke, die Daten in einem Nachrichtenfeld auswerten.

  • Ausdrücke, die bestimmen können, ob eine Nachricht vorhanden ist.

Eine Regel enthält die folgenden Eigenschaften, die das Verhalten der Form definieren:

  • Regelname. Eine erforderliche Eigenschaft, die in der XLANG-Ablaufplanzeichnung innerhalb der Form angezeigt wird, die die Regel verwendet. Durch den Namen wird die Regel eindeutig identifiziert. Eine einzelne, eindeutig benannte Regel kann in mehreren Entscheidung- und While-Formen verwendet werden. Die Breite der Entscheidung- oder While-Form, die die Regel verwendet, wird von der Regel mit dem längsten Namen in der Form bestimmt.

  • Regelbeschreibung Eine optionale Eigenschaft. Es handelt sich um eine Beschreibung der Regel.

  • Skriptausdruck. Ein erforderlicher VBScript-Ausdruck, der auf Daten in Nachrichten verweist. Der Ausdruck muss auf TRUE oder FALSE auswerten.

Wenn Sie eine XLANG-Ablaufplanzeichnung entwerfen, erstellen Sie die Regeln und stellen Namen und Regelbeschreibungen bereit. Wenn Sie Implementierungsformen zur Zeichnung hinzufügen, fügen Sie damit Skriptausdrücke hinzu.

Anmerkungen

  • Die Skriptausdruck-Eigenschaft ist nur beim Kompilieren der XLANG-Ablaufplanzeichnung in einen XLANG-Ablaufplan erforderlich.

  • Es gibt ein Nachrichtenfeld mit dem Namen __Exists__, das nicht unter den Nachrichten auf der Datenseite angezeigt wird. Mit diesem Feld lässt sich das Vorhandensein einer Nachricht testen. Das Vorhandensein einer Nachricht wird davon bestimmt, ob die Nachricht vom XLANG-Ablaufplanungsmodul empfangen oder definiert wurde.

Verwandte Themen

Erstellen von Regeln

Entwerfen von Aktionen

Entwerfen von Parallelität

Entwerfen von Transaktionen

Flussdiagrammformen

Festlegen von Entscheidungsbedingungen


Entwerfen von Parallelität

Der BizTalk-Orchestrierungs-Designer unterstützt parallele Aktionen. Mit den Formen Verzweigung und Verknüpfung werden parallele (gleichzeitige) Prozessabläufe in einem XLANG-Ablaufplan implementiert. Mit der Verzweigung-Form können Sie parallele Prozessabläufe erstellen, und mit der Verknüpfung-Form können Sie parallele Prozessabläufe synchronisieren, die nicht durch eine Ende-Form beendet werden.

Verknüpfungseigenschaften

Für die Verknüpfung-Form können Sie zwei Eigenschaften festlegen. Diese Eigenschaften repräsentieren die folgenden logischen Operatoren:

  • AND. Der XLANG-Ablaufplan wartet, bis alle Prozessabläufe die Verknüpfung erreicht haben, bevor er mit der nächsten Aktion im Geschäftsprozess fortfährt.

  • OR. Der XLANG-Ablaufplan wartet, bis der erste Prozessablauf die Verknüpfung erreicht hat, und fährt dann mit der nächsten Aktion im Geschäftsprozess fort.

    Aktionen in anderen Abzweigen der Verzweigung führen ihre Prozesse aus, die OR-Verknüpfung wartet jedoch nicht, bis diese beendet sind. Wenn der Prozessablauf, der eine OR-Verknüpfung verlässt, eine Aktion beinhaltet, die einen Datenfluss von einer Verzweigung erfordert, der in die OR-Verknüpfung eintritt, und diese Aktion zum Zeitpunkt der Ausführung der Aktion, die die Verknüpfung verlässt, noch nicht beendet ist, tritt ein Fehler auf.

Gültige Verzweigungs- und Verknüpfungsprozessabläufe

Beachten Sie beim Entwerfen paralleler Abläufe in einem Geschäftsprozess die folgenden Richtlinien:

  • Alle verzweigten Abläufe müssen entweder mit einer Ende-Form enden oder mit einer Verknüpfung-Form in einen einzelnen Ablauf synchronisiert werden.

  • Aktionen mit verzweigten Abläufen können nicht miteinander kommunizieren. Eine Aktion in einer Verzweigung kann z. B. keine Nachricht an eine Warteschlange senden, wenn eine Aktion in einer anderen Verzweigung auf den Empfang einer Nachricht aus dieser Warteschlange wartet.

    Vorsicht

    • Wenn der Entwurf Ihrer XLANG-Ablaufplanzeichnung fälschlicherweise die Unterstützung der Kommunikation zwischen Aktionen in unterschiedlichen Verzweigungen vorsieht, kann es zu einem Fehler der XLANG-Ablaufplaninstanz zur Laufzeit kommen, ohne dass jedoch eine Fehlermeldung angezeigt wird.
  • Sie können Abläufe aus mehreren Verzweigungen nicht mit einer Verknüpfung synchronisieren. Die Verknüpfung-Form kann lediglich zum Synchronisieren der Abläufe aus einer übereinstimmenden Verzweigung verwendet werden. Zwischen der Verwendung der Verzweigung-Form und der Verknüpfung-Form besteht eine 1:1-Entsprechung.

    Die folgende Abbildung zeigt zwei Verzweigungen, die zum Erstellen paralleler Abläufe verwendet werden, sowie eine einzelne Verknüpfung, mit der diese Abläufe synchronisiert werden sollen. Diese Verbindung ist ungültig. Bei dieser Art von Verbindung erhalten Sie eine Fehlermeldung, wenn Sie den XLANG-Ablaufplan kompilieren.

    Klicken Sie zum Vergrößern oder Verkleinern auf die Abbildung.

    Parallele Abläufe mit einer ungültigen Verknüpfung

    Abbildung 1. Parallele Abläufe mit einer ungültigen Verknüpfung.

    Die beiden folgenden Abbildungen zeigen zwei Beispiele für gültige Verknüpfungen.

    In Abbildung 2 werden zwei Verzweigungen zwei Verknüpfungen zugeordnet. Das zweite Paar aus Verzweigung und Verknüpfung ist im ersten Paar geschachtelt.

    Klicken Sie zum Vergrößern oder Verkleinern auf die Abbildung.

    Parallele Abläufe mit einer gültigen Verknüpfung

    Abbildung 2. Parallele Abläufe mit einer 1:1-Entsprechung zwischen Verzweigung und Verknüpfung und geschachtelten Paaren aus Verzweigung und Verknüpfung.

    In Abbildung 3 werden zwei Verzweigungen zwei Verknüpfungen zugeordnet. Das zweite Paar aus Verzweigung und Verknüpfung ist im ersten Paar geschachtelt. Auch wenn ein paralleler Ablauf innerhalb des zweiten Paares aus Verzweigung und Verknüpfung durch eine Ende-Form endet, muss der andere parallele Ablauf trotzdem mit einer übereinstimmenden Verknüpfung synchronisiert werden, bevor sein Ablauf mit dem parallelen Ablauf aus dem ersten Paar synchronisiert werden kann.

    Klicken Sie zum Vergrößern oder Verkleinern auf die Abbildung.

    Parallele Abläufe mit einer gültigen Verknüpfung

    Abbildung 3. Parallele Abläufe mit einer 1:1-Entsprechung zwischen Verzweigung und Verknüpfung und geschachtelten Paaren aus Verzweigung und Verknüpfung sowie einer Ende-Form zum Beenden eines Ablaufs.

  • Wenn Sie mehrere parallele Abläufe mit einer OR-Verknüpfung synchronisieren, kann jeder Prozessablauf, der in die Verknüpfung eintritt, nur eine Aktion enthalten. Ein Ablauf, der mehr als eine Aktion enthält, ist nicht gültig.

    Die folgende Abbildung zeigt eine OR-Verknüpfung, die mehrere parallele Abläufe synchronisiert. Jeder Ablauf enthält nur eine Aktion.

    Klicken Sie zum Vergrößern oder Verkleinern auf die Abbildung.

    Parallele Abläufe mit einer gültigen Verknüpfung

Verwandte Themen

Entwerfen von Aktionen

Entwerfen von Regeln

Entwerfen von Transaktionen

Flussdiagrammformen

Festlegen von Parallelitätseigenschaften


Entwerfen von Transaktionen

Der BizTalk-Orchestrierungs-Designer bietet ein Transaktionsprogrammierungsmodell einschließlich Fehlerbehandlung und Wiederherstellung fehlgeschlagener Transaktionen. Sie können Transaktion-Formen konfigurieren, um zwei zusätzliche Seitentypen im BizTalk-Orchestrierungs-Designer zu erstellen: die Seite Bei Fehler von Transaktion und die Seite Kompensierung für Transaktion. Mithilfe dieser beiden Seiten können Geschäftsprozesse bei fehlgeschlagenen Transaktionen wiederhergestellt werden. Die Seiten Bei Fehler von Transaktion und Kompensierung für Transaktion können Transaktion-Formen enthalten, die auf zusätzliche Fehler- und Kompensierungsseiten verweisen. Auf den Seiten Bei Fehler von Transaktion und Kompensierung für Transaktion können dieselben Port-Formen und Implementierungsformen verwendet werden, die auf der Geschäftsprozessseite angezeigt werden.

Die von Ihnen mit dem BizTalk-Orchestrierungs-Designer entworfenen kurzlebigen Transaktionen verfügen über die vier ACID-Attribute. ACID ist ein Akronym, das sich aus den folgenden Eigenschaften zusammensetzt:

  • Unteilbarkeit (Atomicity). Eine Transaktion stellt eine atomare (unteilbare) Arbeitseinheit dar. Es werden entweder alle Änderungen der Transaktionsdaten oder keine der Änderungen ausgeführt.

  • Konsistenz (Consistency). Beim Commit muss eine Transaktion die Integrität der Daten innerhalb des Systems bewahren. Wenn eine Transaktion eine Datenänderung in einer Datenbank ausführt, die vor Beginn der Transaktion intern konsistent war, muss die Datenbank auch nach dem Commit der Transaktion intern konsistent sein. Für die Gewährleistung dieser Eigenschaft ist im Allgemeinen der Anwendungsentwickler verantwortlich.

  • Isolation. Änderungen, die von parallelen Transaktionen ausgeführt werden, müssen von allen Änderungen, die von anderen parallelen Transaktionen ausgeführt werden, isoliert sein. Isolierte Transaktionen, die parallel ausgeführt werden, führen Änderungen durch, bei denen die interne Datenbankkonsistenz genauso bewahrt wird wie bei der seriellen Ausführung der Transaktionen.

  • Beständigkeit (Durability). Nach dem Commit einer Transaktion sind alle Änderungen im System dauerhaft. Die Änderungen sind auch bei einem Systemfehler persistent gespeichert.

Im Gegensatz dazu wird bei langlebigen Transaktionen die Isolation geopfert, um Vorgänge bearbeiten zu können, deren Ausführung einen längeren Zeitraum in Anspruch nimmt.

Dieser Abschnitt behandelt folgende Themen:

  • Transaktionseigenschaften für eine XLANG-Ablaufplanzeichnung

  • Transaktionseigenschaften für bestimmte Transaktion-Formen

  • Transaktionseigenschaften für eine Portimplementierung

  • Langlebige Transaktionen

  • Kurzlebige Transaktionen

Verwandte Themen

Entwerfen von Aktionen

Entwerfen von Parallelität

Entwerfen von Regeln

Flussdiagrammformen

Festlegen von Transaktionseigenschaften


Transaktionseigenschaften für eine XLANG-Ablaufplanzeichnung

Klicken Sie mit der rechten Maustaste auf die Beginn-Form auf der Geschäftsprozessseite, und klicken Sie dann auf Eigenschaften, um das Dialogfeld Beginneigenschaften anzuzeigen. Sie können im Dialogfeld Beginneigenschaften folgende Eigenschaften konfigurieren:

  • Transaktionsmodell. Die Standardeinstellung für diese Eigenschaft lautet Transaktionen in den XLANG-Ablaufplan einschließen.
    • Wählen Sie Transaktionen in den XLANG-Ablaufplan einschließen aus, wenn Sie eine Auflistung gruppierter Aktionen in eine Transaktion-Form Ihrer XLANG-Ablaufplanzeichnung einschließen möchten. Durch die Auswahl dieser Option wird die Transaktionsaktivierung-Eigenschaft deaktiviert.

    • Wählen Sie XLANG-Ablaufplan als COM+-Komponente behandeln aus, wenn Sie den XLANG-Ablaufplan durch eine COM+-Komponente innerhalb seines COM+-Transaktionskontextes aktivieren möchten. Wenn Sie diese Option auswählen, können Sie keine Transaktionen in Ihre XLANG-Ablaufplanzeichnung einschließen, und die Verwendung der Verzweigung-Form zur Implementierung der Parallelität sollte eingeschränkt sein. Wenn Sie die Verzweigung-Form verwenden, sollten alle Aktionen mit Aufrufen an COM+-Komponenten auf eine einzelne ausgehende Verzweigung beschränkt sein. Diese Beschränkung gilt nicht, wenn die Aktionen in Ihrer XLANG-Ablaufplanzeichnung Aufrufe an COM-Komponenten enthalten. Außerdem sollten alle Transaktionsänderungen in einer einzelnen ausgehenden Verzweigung ausgeführt werden.

      Durch die Auswahl dieser Option wird die Transaktionsaktivierung-Eigenschaft aktiviert.

  • Transaktionsaktivierung. Die Standardeinstellung für diese Eigenschaft ist Nicht unterstützt.
    • Nicht unterstützt. Diese Auswahl gibt an, dass der XLANG-Ablaufplan keine Transaktionen unterstützt.

    • Unterstützt. Diese Auswahl gibt an, dass der XLANG-Ablaufplan möglicherweise an einer COM+-Transaktion teilnimmt.

    • Erforderlich. Diese Auswahl gibt an, dass der XLANG-Ablaufplan eine COM+-Transaktion erfordert.

    • Neue Transaktion erforderlich. Diese Auswahl gibt an, dass der XLANG-Ablaufplan möglicherweise an einer neuen Transaktion teilnimmt. Ist diese Einstellung aktiviert, initialisiert das XLANG-Ablaufplanungsmodul automatisch eine neue Transaktion, die sich von der Transaktion des aufrufenden Prozesses unterscheidet.
  • XLANG-Identität. Weitere Informationen zur XLANG-Identität-Eigenschaft finden Sie unter Flussdiagrammformen.

Verwandte Themen

Entwerfen von Transaktionen

Langlebige Transaktionen

Kurzlebige Transaktionen

Transaktionseigenschaften für eine Portimplementierung

Transaktionseigenschaften für bestimmte Transaktion-Formen


Transaktionseigenschaften für bestimmte Transaktion-Formen

Klicken Sie mit der rechten Maustaste auf der Geschäftsprozessseite auf eine Transaktion-Form, und klicken Sie dann auf Eigenschaften, um das Dialogfeld Eigenschaften der Transaktionen anzuzeigen. Sie können im Dialogfeld Eigenschaften der Transaktionen folgende Eigenschaften konfigurieren:

  • Typ. Diese Eigenschaft bestimmt den Typ der Transaktion, der für die ausgewählte Transaktion-Form verwendet wird. Die Standardeinstellung für diese Eigenschaft ist Kurzlebig, DTC-Stil.
    • Wählen Sie Kurzlebig, DTC-Stil, wenn Sie möchten, dass die Transaktion eine Auflistung von Aktionen gruppiert, die als einzelne logische Arbeitseinheit mit den vier Eigenschaften einer ACID-Transaktion ausgeführt werden. Weitere Informationen zu ACID-Transaktionen finden Sie unter Entwerfen von Transaktionen. Transaktionen mit der Kurzlebig, DTC-Stil-Eigenschaft sind auf der Entwurfsseite grau schattiert. Diese Option ist verfügbar für geschachtelte Transaktionen und eigenständige Transaktionen. Sie können die Option nicht für eine äußere Transaktion auswählen, die eine geschachtelte Transaktion enthält.

    • Wählen Sie Langlebig aus, wenn die Transaktion eine Auflistung von Aktionen gruppieren soll, die Nachrichten über einen unbegrenzten Zeitraum senden und empfangen. Sie können eine langlebige Transaktion außerdem so konfigurieren, dass sie eine Auflistung geschachtelter Transaktionen gruppiert. Transaktionen sind jedoch auf zwei Verschachtelungsebenen beschränkt. Langlebige Transaktionen sind auf der Entwurfsseite gelb schattiert. Diese Option ist für alle Transaktionen verfügbar.

    • Wählen Sie Befristete Transaktion aus, wenn Sie möchten, dass die langlebige Transaktion abgebrochen wird, wenn sie nicht in einer bestimmten Zeit abgeschlossen werden konnte. Befristete Transaktionen sind auf der Entwurfsseite blau schattiert. Diese Option ist für alle Transaktionen verfügbar.
  • Timeout. Diese Eigenschaft bestimmt die Zeit (in Sekunden), die der Transaktion für ihre Ausführung zur Verfügung steht, bevor sie abgebrochen wird. Diese Option ist für befristete Transaktionen und für kurzlebige Transaktionen im DTC-Stil verfügbar.

  • Wiederholungsanzahl. Diese Eigenschaft bestimmt, wie häufig ein Prozess in einer kurzlebigen Transaktion im DTC-Stil ausgeführt wird, wenn der Prozess in der Transaktion nicht beendet wird. Bei jeder Wiederholung wird der Status der Anwendung an den Anfangspunkt des Prozesses in der Transaktion zurückgesetzt.

  • Backoffzeit. Diese Eigenschaft bestimmt das Intervall zwischen den einzelnen Transaktionswiederholungsversuchen. Die Backoffzeit wird mit dem Wiederholungsanzahlwert verwendet, um zu bestimmen, wie lange bis zur nächsten Transaktionswiederholung gewartet werden soll. Der Backoffwert ist exponentiell. Ein Backoffwert von 2 Sekunden führt zu Intervallen von 2, 4, 8, 16 Sekunden usw. zwischen den einzelnen Wiederholungen. Die Formel lautet B**W (B hoch W), wobei gilt: B=Backoffzeit und W=aktuelle Wiederholungsanzahl. Wenn die Backoffzeit eines bestimmten Wiederholungsversuches für eine Transaktion über 180 Sekunden beträgt, wird die XLANG-Ablaufplaninstanz sofort in der Persistenzdatenbank pausiert.

  • Isolationsebene. Die Isolationsebene bestimmt, in welchem Maß parallel Transaktionen auf Daten in den jeweils anderen Transaktionen zugreifen können. Diese Option ist nur für kurzlebige Transaktionen im DTC-Stil verfügbar. Sie sollten Folgendes auswählen:
    • Serializable, um parallele Transaktionen daran zu hindern, Änderungen an Daten vorzunehmen, bevor die ausgewählte Transaktion beendet ist. Von den vier Isolationsebenen ist diese die restriktivste.

    • Read Uncommitted, um parallele Transaktionen die Möglichkeit zu geben, Änderungen an Daten vorzunehmen, bevor die ausgewählte Transaktion beendet ist. Von den vier Isolationsebenen ist dies die am wenigsten restriktive.

    • Read Committed, um zu verhindern, dass die ausgewählte Transaktion auf Datenänderungen in parallelen Transaktionen zugreifen kann, bevor deren Commit ausgeführt wurde. Diese Option ist die Microsoft SQL Server-Standardeinstellung.

    • Repeatable Read, so dass Lesesperren erforderlich sind, bis die ausgewählte Transaktion beendet ist.
  • Bei Fehler. Klicken Sie auf Code hinzufügen, aktivieren Sie das Kontrollkästchen Aktiviert, und klicken Sie dann auf OK, wenn Sie die Seite Bei Fehler von Transaktion aktivieren möchten. Sie können dann die Seite Bei Fehler von Transaktion verwenden, um einen alternativen Geschäftsprozess für die Behandlung eines Fehlers der ausgewählten Transaktion zu entwerfen. Diese Option ist für alle Transaktionen verfügbar.

  • Kompensierung. Klicken Sie auf Code hinzufügen, aktivieren Sie das Kontrollkästchen Aktiviert, und klicken Sie dann auf OK, wenn Sie die Seite Kompensierung für Transaktion aktivieren möchten. Sie können dann die Seite Kompensierung für Transaktion zum Entwerfen eines alternativen Geschäftsprozesses verwenden, mit dem Sie die in einer geschachtelten Transaktion ausgeführte logische Arbeitseinheit rückgängig machen können, für die ein Commit bereits ausgeführt wurde. Diese Option ist nur für geschachtelte Transaktionen verfügbar.

Anmerkung

  • Das Abbrechen einer geschachtelten Transaktion verursacht nicht automatisch einen Abbruch der äußeren Transaktion. Dadurch können Sie eine äußere Transaktion entwerfen, die bei einem Fehler der geschachtelten Transaktion wiederhergestellt werden kann. Ein Fehler in einer geschachtelten Transaktion kann jedoch zu einem Fehler in einer äußeren Transaktion führen, wenn die Seite Bei Fehler von Transaktion bzw. Kompensierung für Transaktion der geschachtelten Transaktion einen Abbruch der äußeren Transaktion vorsieht.

Verwandte Themen

Entwerfen von Transaktionen

Langlebige Transaktionen

Kurzlebige Transaktionen

Transaktionseigenschaften für eine XLANG-Ablaufplanzeichnung

Transaktionseigenschaften für eine Portimplementierung


Transaktionseigenschaften für eine Portimplementierung

Sie können auf den Seiten Erweiterte Porteigenschaften des Bindungs-Assistenten für COM-Komponenten und des Bindungs-Assistenten für Skriptkomponenten Transaktionseigenschaften für COM-Komponenten und Windows-Skriptkomponenten konfigurieren. Die Seite Erweiterte Porteigenschaften stellt eine Option zum Abbrechen der aktuellen Transaktion bereit, wenn ein Fehler von einer Methode in einer Komponente zurückgegeben wird. Auf der Seite Erweiterte Porteigenschaften können Sie folgende Transaktionseigenschaften konfigurieren:

  • Transaktionsunterstützung. Die Transaktionsunterstützungs-Eigenschaft gibt an, in welchem Maß Ihre Komponente Transaktionen erfordert, unterstützt oder ignoriert.
    • Deaktiviert. Diese Auswahl gibt an, dass die Komponente die COM-Transaktionsverwaltung ignoriert.

    • Nicht unterstützt. Diese Auswahl gibt an, dass die Komponente nicht an einer Transaktion teilnimmt bzw. die Transaktionen anderer Komponenten nicht weitergibt.

    • Unterstützt. Diese Auswahl gibt an, dass für den Fall, dass eine Transaktion eine Aktion enthält, die eine Verbindung mit dem Port hat, an den die Komponente gebunden ist, die Komponente in die Transaktion eingeschlossen wird. Andernfalls hat die Komponente keine Transaktion.

    • Erforderlich. Diese Auswahl gibt an, dass für den Fall, dass eine Transaktion eine Aktion enthält, die eine Verbindung mit dem Port hat, an den die Komponente gebunden ist, die Komponente in die Transaktion eingeschlossen wird. Gibt es keine Transaktion mit einer Aktion, die eine Verbindung mit dem Port hat, an den die Komponente gebunden ist, wird eine neue Transaktion für die Komponente erstellt.

    • Neue Transaktion erforderlich. Diese Auswahl gibt an, dass stets eine neue Transaktion für die Komponente erstellt wird.

Wichtig

  • Der BizTalk-Orchestrierungs-Designer verlässt sich auf das Transaktionsverhalten der Implementierungstechnologien, die in einer XLANG-Ablaufplanzeichnung verwendet werden. Er stellt kein Transaktionsverhalten für einen Geschäftsprozess bereit oder legt dieses fest, wenn die XLANG-Ablaufplanzeichnung eine Transaktion-Form enthält. Wenn eine COM-Komponente, Nachrichtenwarteschlange oder ein Skript keinen Transaktionskontext haben, werden die Datenänderungen durch die XLANG-Ablaufplanzeichnung nicht als Transaktion ausgeführt.

Anmerkungen

  • Wenn Sie die Transaktionsmodell-Eigenschaft so festlegen, dass der XLANG-Ablaufplan als COM-Komponente behandelt wird, verwenden Sie keine Transaktion-Formen in der XLANG-Ablaufplanzeichnung. Wenn Sie Transaktion-Formen verwenden und dann versuchen, die XLANG-Ablaufplanzeichnung in einen XLANG-Ablaufplan zu kompilieren, kann der Kompilierungsprozess nicht ausgeführt werden. Sie müssen vor dem Kompilieren alle Transaktion-Formen aus der XLANG-Ablaufplanzeichnung entfernen.

  • Wenn eine COM-Komponente in mehreren Transaktionen verwendet wird, muss die COM-Komponente entweder keinen Status beibehalten oder den Status beibehalten und Persistenz unterstützen.

  • Wenn mehrere Aktionen mit einem an eine COM- oder Skriptkomponente gebundenen Port kommunizieren und diese Aktionen sich innerhalb mehrerer Transaktionen befinden, die nicht ineinander geschachtelt sind, werden die Komponenteninstanzen zerstört und vor jedem neuen Transaktionskontext wieder instanziiert. Wenn die Komponente den Status beibehält und Persistenz unterstützt, wird der Status durch die erneute Aktivierung wiederhergestellt. Wenn die Komponente den Status beibehält und Persistenz nicht unterstützt, geht der Status verloren. Wenn die Komponente von einer anderen Anwendung instanziiert wurde, kann das XLANG-Ablaufplanungsmodul die Komponente nur dann erneut aktivieren, wenn diese sich persistent speichern lässt. Wenn die Komponente von einer anderen Anwendung instanziiert wurde und sich nicht persistent speichern lässt, kann das XLANG-Ablaufplanungsmodul die Komponente nicht erneut instanziieren, und es kommt zu einem Fehler im XLANG-Ablaufplan.

Verwandte Themen

Entwerfen von Transaktionen

Langlebige Transaktionen

Kurzlebige Transaktionen

Transaktionseigenschaften für eine XLANG-Ablaufplanzeichnung

Transaktionseigenschaften für bestimmte Transaktion-Formen


Langlebige Transaktionen

Langlebige Transaktionen unterstützen keine Isolation, eines der vier ACID-Attribute. Eine Beschreibung dieser Attribute finden Sie unter Entwerfen von Transaktionen. Die Daten in einer langlebigen Transaktion sind nicht gesperrt und können von anderen Prozessen oder Anwendungen geändert werden. Wenn Ihre Daten konsistent sein müssen, sollten Sie ausschließlich ACID-Transaktionen verwenden. Da ACID-Transaktionen in einer Umgebung mit einer langen Wartezeit zu schweren Skalierbarkeitsproblemen führen, werden langlebige Transaktionen von XLANG-Ablaufplanzeichnungen unterstützt. Durch langlebige Transaktionen können Sie darauf verzichten, Datenbanken bei längeren Zeiträumen zu sperren. Bei einer langlebigen Transaktion werden Nachrichten über einen unbegrenzten Zeitraum gesendet und empfangen. Abhängig von den Anforderungen des Geschäftsprozesses, den Ihre XLANG-Ablaufplanzeichnung beschreibt, können Sie einen gesamten Geschäftsprozess (mit Ausnahme der Beginn-Form und einer Ende-Form) in eine langlebige Transaktion einschließen.

Im Allgemeinen enthält eine langlebige Transaktion mehrere geschachtelte kurzlebige Transaktionen. In einem einfachen Wire-Transfer-Szenario kann eine langlebige Transaktion beispielsweise die folgenden Aktionen in einer geschachtelten, kurzlebigen Transaktion enthalten:

  • Geld von einem Bankkonto abheben.

  • Wire-Transfer-Prozess initiieren.

Die folgende Abbildung zeigt Geld senden, eine kurzlebige Transaktion, die in einer langlebigen Transaktion namens Wire Transfer geschachtelt ist. Die geschachtelte Transaktion enthält die beiden Aktionen in dem einfachen Wire-Transfer-Szenario. Sobald die Wire Transfer initiieren-Aktion beendet wurde, verlässt der Geschäftsprozess die geschachtelte Transaktion. Wenn dies geschieht, wird das Commit für die geschachtelte Transaktion ausgeführt; das Geld wurde vom Bankkonto abgehoben und an ein Ziel gesendet. An diesem Punkt folgt der Geschäftsprozess der Warten auf Bestätigung-Aktion in der äußeren Transaktion.

Klicken Sie zum Vergrößern oder Verkleinern auf die Abbildung.

In diesem Szenario wurde die Wire Transfer-Transaktion als befristete Transaktion konfiguriert. Wenn der Absender in dem angegebenen Zeitraum keine Bestätigung des Geldempfangs erhalten hat, wird die äußere Transaktion abgebrochen. Wenn dies geschieht, folgt der Geschäftsprozess dem Ablauf zur Seite Kompensierung für Geld senden für die geschachtelte Transaktion. Da das Commit für die geschachtelte Transaktion bereits ausgeführt wurde, muss der alternative Geschäftsprozess Aktionen beschreiben, die ausgeführt werden können, um den Geldbetrag dem Konto des Absenders gutzuschreiben. Wenn der auf der Seite Kompensierung für Geld senden beschriebene Geschäftsprozess ausgeführt wurde, folgt der Geschäftsprozess dem Ablauf zur Seite Bei Fehler von Wire Transfer für die äußere Transaktion. Diese Seite muss einen Geschäftsprozess enthalten, der die Ausnahmebehandlung für die äußere Transaktion beschreibt. In diesem Fall könnte der Geschäftsprozess darin bestehen, nachfolgend eine E-Mail zu senden, in der die Beteiligten über den Status der Übertragung informiert werden.

Verwandte Themen

Entwerfen von Transaktionen

Flussdiagrammformen

Kurzlebige Transaktionen


Kurzlebige Transaktionen

Eine kurzlebige Transaktion ist eine Sammlung gruppierter Aktionen, die als einzelne logische Arbeitseinheit ausgeführt werden. Diese logische Arbeitseinheit weist die vier Eigenschaften einer ACID-Transaktion auf. Weitere Informationen zu ACID-Transaktionen finden Sie unter Entwerfen von Transaktionen.

Verwandte Themen

Entwerfen von Transaktionen

Flussdiagrammformen

Langlebige Transaktionen


Behandeln von Ausnahmen

Das XLANG-Ablaufplanungsmodul kann Systemfehler auffangen. Mit dem BizTalk-Orchestrierungs-Designer können Sie XLANG-Ablaufpläne entwerfen, die auf XLANG-Ablaufplanfehler zur Laufzeit reagieren. Wenn Sie einen Teil eines Geschäftsprozesses in eine Transaktion-Form einschließen, können Sie einen alternativen Geschäftsprozess entwerfen, der ausgeführt wird, wenn ein Fehler auftritt oder eine Anforderung nicht erfüllt wird.

Dieser Abschnitt behandelt folgende Themen:

  • Systemfehler

  • Anwendungsfehler

Verwandtes Thema

Festlegen von Fehlerbehandlungseigenschaften


Systemfehler

Es gibt drei Schweregrade für Systemfehler, die bei der Ausführung des XLANG-Ablaufplanungsmoduls auftreten können. Die drei Schweregrade sind (in absteigender Reihenfolge):

  • Fehler, die in einem XLANG-Ablaufplan aufgefangen werden können.

  • Fehler, die zum Beenden einer XLANG-Ablaufplaninstanz führen.

  • Fehler, die einen Fehler des XLANG-Ablaufplanungsmoduls verursachen.

Dieser Abschnitt behandelt folgende Themen:

  • Fehler, die in einem XLANG-Ablaufplan aufgefangen werden können

  • Fehler, die zum Beenden einer XLANG-Ablaufplaninstanz führen

  • Fehler, die einen Fehler des XLANG-Ablaufplanungmoduls verursachen


Fehler, die in einem XLANG-Ablaufplan aufgefangen werden können

Das XLANG-Ablaufplanungsmodul kann die folgenden Systemfehler auffangen:

  • COM-Fehler, die ein Fehler-HRESULT verursachen. Zum Beispiel eine Nachricht, die besagt, dass der Zugriff verweigert wurde von COM, die dazu führt, dass bei unzureichender Berechtigung eine Methode in einem XLANG-Ablaufplan aufgerufen wird. Dieses kann für COM- oder Skriptbindungen gelten.

  • Transaktionsabbrüche, die durch eingetragene Dienste verursacht werden, z. B. den Distributed Transaction Coordinator (DTC), der eine Transaktion abbricht, weil die Verbindung zu einer Datenbank verloren gegangen ist. Ein weiteres Beispiel ist der Message Queuing-Dienst, der eine Transaktion abbricht, weil er eine Nachricht nicht in eine Warteschlange einreihen kann.

Zur Behandlung eines Fehler-HRESULT mithilfe einer logischen Verzweigung muss die von einem Methodenaufruf stammende _out-Nachricht in einer Entscheidungsregel getestet werden. Der HRESULT-Wert wird im Feld __Status__ der _out-Nachricht gespeichert.

Zur Behandlung eines Fehler-HRESULT mithilfe von Transaktionsfehlerprozessen muss das Kontrollkästchen Transaktion abbrechen, wenn die Methode ein Fehler-HRESULT zurückgibt auf der letzten Seite der Bindungs-Assistenten für COM-Komponenten oder für Skriptkomponenten aktiviert werden. Dieses Kontrollkästchen kann nur aktiviert werden, wenn sich die Aktion in einer Transaktion befindet.

Wichtig

  • Diese Option legt fest, ob Transaktionen, bei denen die Komponente verwendet wird, abgebrochen werden sollen, wenn Methodenaufrufe an die Komponente ein Fehler-HRESULT zurückgeben. Diese Option kann nur festgelegt werden, wenn die Kommunikationsaktion, die diesen Port verwendet, sich im Prozessablauf einer Transaktion befindet.

Die Behandlung eines Fehlers in den Message Queuing- oder BizTalk-Messaging-Implementierungstechnologien kann nur mit Transaktionsfehlerprozessen ausgeführt werden. Dazu müssen Sie das Kontrollkästchen Für diese Warteschlange sind Transaktionen erforderlich auf der letzten Seite des Bindungs-Assistenten für Message Queuing aktivieren.

Anmerkung

  • Eine von Message Queuing gesendete Aktion, die erfolgreich zurückgegeben wird, zeigt an, dass die Nachricht erfolgreich in der Warteschlange platziert wurde. Es zeigt nicht an, dass die Nachricht übermittelt wurde.

Verwandte Themen

Anwendungsfehler

Fehler, die einen Fehler des XLANG-Ablaufplanungmoduls verursachen

Fehler, die zum Beenden einer XLANG-Ablaufplaninstanz führen

Behandeln von Ausnahmen

Systemfehler


Fehler, die zum Beenden einer XLANG-Ablaufplaninstanz führen

Zu den Systemfehlern, die einen Fehler in einer XLANG-Ablaufplaninstanz verursachen, jedoch nicht in einem XLANG-Ablaufplan aufgefangen werden können, gehören:

  • Eine geplante Methode, die nicht mit der aufgerufenen Komponente synchronisiert ist.

  • Eine geplante Warteschlange, die nicht vorhanden ist.

  • Ein geplanter Kanal, der nicht vorhanden ist.

  • Datenfluss aus einer Nachricht, die noch nicht eingetroffen ist.

Verwandte Themen

Anwendungsfehler

Fehler, die in einem XLANG-Ablaufplan aufgefangen werden können

Fehler, die einen Fehler des XLANG-Ablaufplanungmoduls verursachen

Behandeln von Ausnahmen

Systemfehler


Fehler, die einen Fehler des XLANG-Ablaufplanungmoduls verursachen

Systemfehler, die nicht vom XLANG-Ablaufplanungsmodul aufgefangen werden können, können zu einem Fehler des XLANG-Ablaufplanungsmoduls einschließlich aller XLANG-Ablaufplaninstanzen führen, die in derselben COM+-Anwendung ausgeführt werden. Zu diesen Systemfehlern gehören bestimmte Zugriffsverletzungen durch Komponenten, die im Prozessbereich des XLANG-Ablaufplanungsmodul ausgeführt werden. Das XLANG-Ablaufplanungsmodul versucht, diese Fehler aufzufangen, in vielen Fällen ist dies jedoch nicht möglich.

Verwandte Themen

Anwendungsfehler

Fehler, die in einem XLANG-Ablaufplan aufgefangen werden können

Fehler, die zum Beenden einer XLANG-Ablaufplaninstanz führen

Behandeln von Ausnahmen

Systemfehler


Anwendungsfehler

Es gibt drei Möglichkeiten, Fehler zu behandeln, die XLANG-Ablaufplanfehler verursachen können:

  • Verwenden Sie Logische Verzweigungen.

  • Verwenden Sie Transaktionsabbruchprozesse.

  • Verwenden Sie Timeouts.


Logische Verzweigungen

Entscheidungen und Regeln können auf allen Prozessseiten (der Geschäftsprozessseite, allen Fehlerseiten und allen Kompensierungsseiten) zum Verzweigen eines Prozessablaufes verwendet werden. Die folgende Abbildung zeigt einen einfachen Test der Methodenausführung.

Klicken Sie zum Vergrößern oder Verkleinern auf die Abbildung.

In diesem Beispiel besitzt die Clear_out-Nachricht ein Systemfeld mit dem Namen __Status__. In der Regel HRESULT Success wäre der Skriptausdruck Clear_out.[__Status__] >= 0, wobei ein negatives HRESULT einen Fehler und 0 oder ein positives HRESULT einen Erfolg anzeigt. Durch diese Art der Verwendung von Entscheidungen und Regel können alle Datenfelder in einer Nachricht (innerhalb des VB Script-Ausdrucks einer Regel) auf Ausnahmen, nicht ausschließlich auf HRESULTs, getestet werden.

Verwandte Themen

Behandeln von Ausnahmen

Timeouts

Transaktionsabbruchprozesse


Transaktionsabbruchprozesse

Im BizTalk-Orchestrierungs-Designer können Sie mithilfe von Transaktionen eine Auflistung von Aktionen gruppieren, die als einzelne logische Arbeitseinheit ausgeführt werden und sicherstellen, dass alle Aktionen in der Gruppe vollständig ausgeführt werden oder keine. Durch das Gruppieren von Geschäftsprozessen innerhalb von Transaktionen kann der BizTalk-Orchestrierungs-Designer ein Höchstmaß an Struktur und Zuverlässigkeit bereitstellen.

Der Prozessablauf in einer Transaktion wird normal ausgeführt, bis die Transaktion beendet ist oder ein Abbruchereignis eintritt. Ein Abbruchereignis kann folgenden Ursprung haben:

  • Erreichen der Abbruch-Form innerhalb des Prozessablaufs.

  • Ein HRESULT-Fehler, der angegeben wird, um einen Abbruch in einer Portbindung zu verursachen.

  • Jede Bindungstechnologie kann auf der Systemebene ein Fehlerereignis einleiten, das die Transaktion abbricht. So kann z. B. beim Message Queuing ein Fehler bei der Platzierung einer Nachricht in eine Warteschlange auftreten.

  • Das XLANG-Ablaufplanungsmodul kann einen Fehler entdecken, der zur Folge hat, dass es eine Transaktion in einer angegebenen Instanz abbricht. So kann z. B. ein DTC-Fehler auftreten.

  • Das Pausieren eines Ablaufplanes kann den Abbruch aller Transaktionen in diesem Ablaufplan erforderlich machen.

  • Ein Timeout in den Transaktionseigenschaften.

Wenn eine Transaktion abgebrochen wurde, wird je nach dem in der Wiederholungsanzahl-Eigenschaft festgelegten Wert der Transaktionsgruppe eine Wiederholung der Transaktion von vorn versucht. Wenn nach der angegebenen Anzahl von Wiederholungsversuchen weiterhin ein Fehler auftritt, wird der Geschäftsprozess Bei Fehler von Transaktion aufgerufen. Dieser Bei Fehler von Transaktion-Code stellt einen strukturierten Ort zur Behandlung eines Transaktionsfehlers bereit.

Der Bei Fehler von Transaktion-Code muss keine Arbeit innerhalb der Transaktion rückgängig machen. Wenn die Ports an Transaktionsressourcen gebunden sind, bearbeitet der Distributed Transaction Coordinator das Rollback aller eingetragenen Aktionen innerhalb der Transaktion. Für Nichttransaktionsressourcen wird kein Rollback ausgeführt. Wenn die Transaktion in einer äußeren Transaktion geschachtelt ist und für diese geschachtelte Transaktion bereits ein Commit ausgeführt wurde, folgt der Geschäftsprozess dem Ablauf zum Geschäftsprozess Kompensierung für Transaktion für die geschachtelte Transaktion. Der Geschäftsprozess Kompensierung für Transaktion wird auf der Seite Kompensierung für Transaktion beschrieben. Dieser alternative Geschäftsprozess muss Aktionen enthalten, die ausgeführt werden können, um die Arbeit in der geschachtelten Transaktion rückgängig zu machen.

Wenn der Code Kompensierung für Transaktion oder Bei Fehler von Transaktion ausgeführt wurde, folgt der Geschäftsprozess dem Ablauf aus dem unteren Teil der Transaktion-Form auf der Geschäftsprozessseite. Aktionen innerhalb des Geschäftsprozesses, die nach einer Transaktion eintreten, empfangen keinen expliziten Hinweis, ob die Transaktion ausgeführt oder abgebrochen wurde. Sie können in einem Nachrichtenfeld auf der Seite Bei Fehler von Transaktion oder der Seite Kompensierung für Transaktion ein Kennzeichen festlegen, um einen expliziten Hinweis zu aktivieren.

Verwandte Themen

Behandeln von Ausnahmen

Logische Verzweigungen

Timeouts


Timeouts

Wenn eine Aktion in einer Transaktion eine erwartete Nachricht von einem Handelspartner nicht empfängt, wird der Fehler als Anwendungsfehler behandelt. Verwenden Sie befristete Transaktionen als Test für diesen Fehler.

In einem einfachen Wire-Transfer-Szenario kann eine befristete Transaktion beispielsweise die folgenden Aktionen in einer geschachtelten Transaktion enthalten:

  • Geld von einem Bankkonto abheben.

  • Wire-Transfer-Prozess initiieren.

Die folgende Abbildung zeigt Geld senden, eine kurzlebige Transaktion, die in einer langlebigen Transaktion namens Wire Transfer geschachtelt ist. Die geschachtelte Transaktion enthält die beiden Aktionen in dem einfachen Wire-Transfer-Szenario. Sobald die Wire Transfer initiieren-Aktion beendet wurde, verlässt der Geschäftsprozess die geschachtelte Transaktion. Wenn dies geschieht, wird das Commit für die geschachtelte Transaktion ausgeführt; das Geld wurde vom Bankkonto abgehoben und an ein Ziel gesendet. An diesem Punkt folgt der Geschäftsprozess der Warten auf Bestätigung-Aktion in der äußeren Transaktion.

Klicken Sie zum Vergrößern oder Verkleinern auf die Abbildung.

In diesem Szenario wurde die Wire Transfer-Transaktion als befristete Transaktion konfiguriert. Wenn der Absender in dem angegebenen Zeitraum keine Bestätigung des Geldempfangs erhalten hat, wird die äußere Transaktion abgebrochen. Wenn dies geschieht, folgt der Geschäftsprozess dem Ablauf zur Seite Kompensierung für Geld senden für die geschachtelte Transaktion. Da das Commit für die geschachtelte Transaktion bereits ausgeführt wurde, muss der alternative Geschäftsprozess Aktionen beschreiben, die ausgeführt werden können, um den Geldbetrag dem Konto des Absenders gutzuschreiben. Wenn der auf der Seite Kompensierung für Geld senden beschriebene Geschäftsprozess ausgeführt wurde, folgt der Geschäftsprozess dem Ablauf zur Seite Bei Fehler von Wire Transfer für die äußere Transaktion. Diese Seite muss einen Geschäftsprozess enthalten, der die Ausnahmebehandlung für die äußere Transaktion beschreibt. In diesem Fall könnte der Geschäftsprozess darin bestehen, nachfolgend eine E-Mail zu senden, in der die Beteiligten über den Status der Übertragung informiert werden.

Verwandte Themen

Behandeln von Ausnahmen

Logische Verzweigungen

Transaktionsabbruchprozesse


Implementieren von Geschäftsprozessen

Die Implementierungsschablone enthält vier Formen, die den Technologien entsprechen, mit denen die Portimplementierung in einen Geschäftsprozess ausgeführt werden kann. Da jede Aktion entweder eine Nachricht an einen Port sendet oder eine Nachricht von einem Port erhält, variiert die semantische Bedeutung des Sendens und Empfangens von Nachrichten entsprechend der spezifischen Implementierungstechnologie.

Die Verwendung von Implementierungsformen beinhaltet zwei unterschiedliche Prozesse. Im ersten Prozess wird ein Port an eine Implementierungstechnologie gebunden. Grundsätzlich ist ein Port ein abstrakter Standort, an den eine Nachricht gesendet oder von dem eine Nachricht empfangen wird. Bindung des Ports an eine Implementierung definiert den Typ des Standortes, an den der Port gebunden ist. Im zweiten Prozess wird eine Aktion mit dem Port verbunden. Dieser Prozess definiert das Schema der Nachricht, die an den Port gesendet bzw. von diesem empfangen wird.

Der BizTalk-Orchestrierungs-Designer unterstützt vier Implementierungstechnologien:

  • COM-Komponenten. Diese Technologie ermöglicht die synchrone Kommunikation.

  • Windows-Skriptkomponenten. Diese Technologie ermöglicht die synchrone Kommunikation.

  • Message Queuing-Dienste. Diese Technologie ermöglicht die asynchrone Kommunikation.

  • BizTalk-Messagingdienste. Diese Technologie ermöglicht die asynchrone Kommunikation.

Die Entwurfsseite des BizTalk-Orchestrierungs-Designers wird durch eine Trennlinie in einen Geschäftsprozess-Entwurfsbereich auf der linken und einen Implementierungsbereich auf der rechten Seite getrennt. Ziehen Sie eine der Implementierungsformen zum Öffnen des Bindungs-Assistenten für Ports auf die rechte Seite der Trennlinie. Sie können diese Aufgabe auf der Geschäftsprozessseite, der Seite Bei Fehler von Transaktion und auf der Seite Kompensierung für Transaktion ausführen.

Anmerkung

  • Sie können im BizTalk-Orchestrierungs-Designer keinen Umschlag konfigurieren. Wenn Sie eine Flatfile an die BizTalk-Orchestrierung senden möchten, verwenden Sie deshalb den BizTalk-Editor, um den Inhalt der Flatfile in XML zu übersetzen. Sie können die XML-Datei dann an die BizTalk-Orchestrierung senden.

Dieser Abschnitt behandelt folgende Themen:

  • Grundlegendes zu Portimplementierungen

  • Synchrone und asynchrone Kommunikation


Grundlegendes zu Portimplementierungen

Ein Port ist ein benannter Standort, der eine bestimmte Implementierung verwendet. In einem XLANG-Ablaufplan vereinfachen Ports die synchrone und die asynchrone Kommunikation und werden dazu verwendet, Nachrichten in oder aus dem Ablaufplan zu übertragen.

Im BizTalk-Orchestrierungs-Designer wird ein Port durch den Standort definiert, an den Nachrichten gesendet bzw. von dem Nachrichten empfangen werden, sowie von der Technologie, die zur Implementierung der Kommunikationsaktion verwendet wird. Ports sind auf der linken Seite an Aktionen im Geschäftsprozessablauf des XLANG-Ablaufplanes und auf der rechten Seite an eine Implementierungstechnologie gebunden, die zur Vereinfachung der erforderlichen Aktion verwendet werden kann. Der Standort wird durch den Namen des Ports eindeutig identifiziert.

Der Standort eines Ports hängt teilweise von der zur Implementierung des Ports verwendeten Technologie ab. Die folgende Tabelle zeigt die verfügbaren Portimplementierungen und den Standort, der der jeweiligen Portimplementierung zugeordnet ist.

Portimplementierung | Portstandort
COM-Komponente | Ein Zeiger auf eine aktivierte Instanz eines Objekts.
Windows-Skriptkomponente | Ein Zeiger auf eine aktivierte Instanz eines Objekts.
Message Queuing | Ein Warteschlangenpfadname zu einer Nachrichtenwarteschlange.
BizTalk-Messaging | Ein Kanalname für einen bestimmten BizTalk-Messagingkanal.

Ports können auf zweifache Weise beschrieben werden:

  • Statische Ports. Ein statischer Port erfordert, dass alle Informationen zum Portstandort und zur Portimplementierung für einen XLANG-Ablaufplan zur Entwurfszeit bereitgestellt werden. Der Designer, der den XLANG-Ablaufplan erstellt, muss den Standort kennen, an den Nachrichten gesendet bzw. von dem Nachrichten empfangen werden, und die Technologie, die zur Implementierung der Kommunikationsaktion ausgewählt wurde.

  • Dynamische Ports. Ein dynamischer Port erfordert, dass bestimmte Standortinformationen für einen XLANG-Ablaufplan zur Laufzeit bereitgestellt werden. Die Implementierung für einen dynamischen Port wird zur Entwurfszeit ausgewählt, der Standort des Ports bleibt jedoch bis zur Ausführung des XLANG-Ablaufplanes unbekannt. Der Standort für einen dynamischen Port wird über eine Nachricht bereitgestellt, welche die Standortinformationen an den Verweis für den Port übergibt. Diese Nachricht muss an einem Punkt im Prozessablauf des XLANG-Ablaufplanes eintreffen, bevor die Kommunikation, die diese Portimplementierung verwendet, verwendet werden kann.

    Wenn Sie einen dynamischen Port für eine Kommunikation verwenden möchten, und der XLANG-Ablaufplan hat keine Nachricht mit dem Portverweis erhalten, bevor der Ablaufplan versucht, die Aktion zu beenden, wird ein Fehler generiert.

Sowohl statische als auch dynamische Ports stellen Optionen für die synchrone und die asynchrone Kommunikation bereit, die Portimplementierungen für diese Kommunikationsarten sind jedoch je nach der von Ihnen zur Portimplementierung verwendeten Technologie unterschiedlich.

Jeder Port kann entweder statisch oder dynamisch sein, es können jedoch nicht alle Ports die synchrone und die asynchrone Kommunikation implementieren. Wenn Sie eine synchrone Kommunikationsaktion erstellen möchten, müssen Sie eine Portimplementierung für COM- oder Skriptkomponenten verwenden. Wenn Sie eine asynchrone Kommunikationsaktion erstellen möchten, müssen Sie eine Portimplementierung für Message Queuing oder BizTalk-Messaging verwenden.

Dieser Abschnitt behandelt folgende Themen:

  • Statische und dynamische Ports

  • Verwenden der COM-Komponente-Form

  • Verwenden der Skriptkomponente-Form

  • Verwenden der Message Queuing-Form

  • Verwenden der BizTalk-Messaging-Form

Verwandtes Thema

Synchrone und asynchrone Kommunikation


Statische und dynamische Ports

Statisches und dynamisches Portverhalten variieren, je nachdem, welchen Implementierungstyp Sie verwenden.

Portimplementierungen, die COM- oder Skriptkomponenten verwenden

Für eine Portimplementierung, die COM- oder Skriptkomponenten verwendet, stellen die statischen und dynamischen Eigenschaften dar, wie eine Komponente instanziiert wird:

  • Statisch. Für einen XLANG-Ablaufplan, der einen statischen Port verwendet, instanziiert das XLANG-Ablaufplanungsmodul die Komponente, die für diese Portimplementierung definiert wird.

  • Dynamisch. Bei einem XLANG-Ablaufplan, der einen dynamischen Port verwendet, wird die Komponente nicht vom XLANG-Ablaufplanungsmodul instanziiert. Stattdessen wartet der XLANG-Ablaufplan, bis eine andere Anwendung die Komponente instanziiert. Die Objektinstanz muss als Feld in einer Nachricht an den XLANG-Ablaufplan zurückgesendet werden. Auf der Datenseite muss eine Verbindung zwischen diesem Nachrichtenfeld und dem Portverweis auf den Port gezeichnet werden, der diese Implementierung verwendet. Der XLANG-Ablaufplan fängt sowohl die Methodenanforderung als auch die Methodenantwort von der Komponente ab.

Neben Statisch und Dynamisch gibt es eine dritte Option:

  • Keine Instanziierung. Für einen XLANG-Ablaufplan, der einen Port ohne Instanziierung verwendet, wird die Komponente nicht instanziiert und kein Code für den Methodenaufruf ausgeführt. Stattdessen gibt der XLANG-Ablaufplan diese Informationen als Antwort zurück, wenn er die Methodenanforderungsinformationen abfängt. Der Methodenaufruf wird umgangen.

Portimplementierungen, die Message Queuing verwenden

In einer Portimplementierung, die Message Queuing verwendet, werden die statischen und dynamischen Eigenschaften als statische und dynamische Warteschlangen dargestellt.

  • Statische Warteschlange. Ein statischer Port verwendet als statische Warteschlange eine bekannte, vorgegebene Warteschlange. Sie können diese Warteschlange zur Entwurfszeit zuweisen.

    Wenn Sie eine statische Warteschlange verwenden, können Sie auswählen, ob Sie eine bekannte Warteschlange verwenden möchten, die sich nie ändert, oder Sie können jedes Mal, wenn der XLANG-Ablaufplan ausgeführt wird, eine neue Instanz derselben Warteschlange erstellen. Die Warteschlange auf Instanzebene wird durch eine eindeutige Kennung identifiziert, die an den Namen der Warteschlange angehängt wird.

  • Dynamische Warteschlange. Ein dynamischer Port verwendet eine dynamische Warteschlange, die zur Entwurfszeit unbekannt ist. Die Informationen für eine dynamische Warteschlange müssen zur Laufzeit in einem Nachrichtenfeld bereitgestellt werden. Sie müssen auf der Datenseite eine Verknüpfung zwischen einem Nachrichtenfeld und dem Portverweis auf diesen Port erstellen. Wenn eine Nachricht mit dem Warteschlangennamen eintrifft, kann der XLANG-Ablaufplan die zugewiesene Warteschlange verwenden. Die Nachricht mit dem Warteschlangennamen muss eintreffen, bevor die Kommunikation verwendet werden kann, die diese Portimplementierung verwendet.

Portimplementierungen, die BizTalk-Messaging verwenden

In einer Portimplementierung, die BizTalk-Messaging verwendet, werden die statischen und dynamischen Eigenschaften als statische und dynamische Kanäle dargestellt. Dynamische Kanäle können nur beim Senden von Nachrichten verwendet werden. Dynamische Kanäle können nicht zum Empfangen von Nachrichten verwendet werden.

  • Statischer Kanal. Ein statischer Port verwendet als statischen Kanal einen bekannten, vorgegebenen Kanal. Sie können diesen Kanal zur Entwurfszeit zuweisen.

  • Dynamischer Kanal. Ein dynamischer Port verwendet einen dynamischen Kanal, der zur Entwurfszeit unbekannt ist. Die Informationen für einen dynamischen Kanal müssen zur Laufzeit in einem Nachrichtenfeld bereitgestellt werden. Sie müssen auf der Datenseite eine Verknüpfung zwischen einem Nachrichtenfeld und dem Portverweis auf diesen Port erstellen. Wenn eine Nachricht mit dem Kanalnamen eintrifft, kann der XLANG-Ablaufplan den zugewiesenen Kanal verwenden. Die Nachricht mit dem Kanalnamen muss eintreffen, bevor die Kommunikation verwendet werden kann, die diese Portimplementierung verwendet.

Bei einem Port, der einen dynamischen Kanal verwendet, kann der XLANG-Ablaufplan bestimmen, welcher Kanal zur Laufzeit verwendet werden soll, so dass kein vorgegebener Kanal zur Entwurfszeit definiert werden muss. Diese Eigenschaft definiert, welcher Kanal verwendet wird, wenn der XLANG-Ablaufplan die Nachricht an die BizTalk-Messagingdienste übergibt.

Der dynamische Kanal sollte nicht mit einem offenen Kanal verwechselt werden, der im BizTalk-Messaging-Manager konfiguriert wird. Mit einem offenen Kanal kann die Quellorganisation zur Laufzeit anhand der Informationen im Dokument oder der mit dem Dokument gesendeten Parameter bestimmt werden. Diese Eigenschaft definiert die Quelle der Dokumente. Weitere Informationen zu offenen Kanälen finden Sie unter Grundlegendes zu Kanälen.

Die Nachricht, die an einen Port mit einem dynamischen Kanal übergeben wird, kann entweder einen offenen Kanal angeben oder einen Kanal, der bei der Übergabe der Kanalinformationen an die BizTalk-Messagingdienste nicht offen ist.

Verwandte Themen

Implementieren von Ports

Synchrone und asynchrone Kommunikation

Grundlegendes zu Kanälen

Verwenden der BizTalk-Messaging-Form

Verwenden der COM-Komponente-Form

Verwenden der Message Queuing-Form

Verwenden der Skriptkomponente-Form


Verwenden der COM-Komponente-Form

Mit der COM-Komponente-Form können Sie vorgegebene Komponenten oder Anwendungen für die Ausführung von Aktionen in einem XLANG-Ablaufplan verwenden. Da die COM-Technologie synchron ist, gibt es stets einen bidirektionalen Nachrichtenfluss, wenn eine Aktion ausgeführt wird. Im Gegensatz dazu verläuft der Nachrichtenfluss bei einer asynchronen Technologie in einer Richtung.

Das XLANG-Ablaufplanungsmodul unterstützt das Senden oder Empfangen von Nachrichten mithilfe von Aktion-Formen. Wenn Sie im BizTalk-Orchestrierungs-Designer einen Port an eine COM-Komponente binden, wird der Port an eine Schnittstelle gebunden, die durch eine auf Ihrem System registrierte COM-Komponente implementiert wird.

Eine mit diesem Port verbundene Sendeaktion zeigt den Aufruf eines bestimmten Methodenaufrufs durch das XLANG-Ablaufplanungsmodul. Die Parameter IN und IN/OUT werden an den Port gesendet. Dafür wird eine Nachricht mit einem Schema, das durch die Parameter IN/OUT und OUT des Methodenaufrufs definiert wird, vom Port empfangen. Der Methodenaufruf wird von der an den Port gebundenen Schnittstelle unterstützt.

Eine mit diesem Port verbundene Empfangsaktion wartet darauf, dass eine externe Anwendung einen Methodenaufruf an den Port startet. Die Parameter IN und IN/OUT definieren das Schema der Nachricht, die vom Port empfangen wird, und die Parameter IN/OUT und OUT definieren das Schema der Nachricht, die von diesem Port gesendet wird.

Für jede Aktion, die mit einem Port verbunden und an eine COM-Komponente gebunden ist, werden zwei Nachrichten ausgetauscht. Die Nachrichten identifizieren die an der Schnittstelle aufgerufene Methode. Das Schema der Nachrichten entspricht den Parametern IN und IN/OUT (und den Parametern IN/OUT und OUT) der Methodensignatur. Da der Zugriff auf die Typenbibliothek für die Komponenten möglich ist, kann der BizTalk-Orchestrierungs-Designer das Schema für diese Nachrichten automatisch erstellen, ohne den Benutzer nach dieser Information fragen zu müssen.

Wichtig

  • Gehen Sie sorgfältig vor, wenn Sie bei der Implementierung eines langlebigen Geschäftsprozesses COM-Komponenten verwenden. Wenn Sie Komponenten, die den Status beibehalten, in einem XLANG-Ablaufplan verwenden, sollte es sich um Komponenten handeln, die mithilfe der Schnittstelle IPersistStream oder IPersistStreamInit gespeichert werden können. Dadurch wird gewährleistet, dass der XLANG-Ablaufplan seinen Status zusammen mit dem Status der Komponenten speichern kann. XLANG-Ablaufpläne müssen den Status beibehalten und über einen langen Zeitraum stabil ausführen können. Bei der Verwendung von Komponenten, die den Status nicht beibehalten, wird bei jeder Aktivierung des XLANG-Ablaufplanes eine neue Instanz der Komponente erstellt. Die Verwendung von Komponenten, die den Status nicht beibehalten, sollte jedoch keine Auswirkungen auf das Resultat des Ablaufplanes haben.

Bei der Bindung handelt es sich um den Prozess, mit dem die Technologie zur Implementierung eines Ports festgelegt wird. Der Bindungs-Assistent für COM-Komponenten setzt sich aus den folgenden fünf Seiten zusammen:

Willkommen beim Bindungs-Assistenten für COM-Komponenten

Auf der Seite Willkommen beim Bindungs-Assistenten für COM-Komponenten können Sie einen Port erstellen und benennen, für den Sie eine Implementierung definieren möchten.

Statische oder dynamische Kommunikation

Auf der Seite Statische oder dynamische Kommunikation können Sie definieren, wie die Komponente instanziiert werden soll. Die folgende Tabelle enthält eine Liste und Beschreibungen der Einstellungen für die statische und dynamische Kommunikation.

Statische oder dynamische Kommunikation | Beschreibung
Statisch | Wählen Sie diese Option aus, wenn Sie dem XLANG-Ablaufplanungsmodul alle zur Ausführung der Implementierung erforderlichen Informationen zur Entwurfszeit bereitstellen können.
Dynamisch | Wählen Sie diese Option aus, wenn das XLANG-Ablaufplanungsmodul zur Laufzeit zusätzliche Informationen benötigt, um die Implementierung ausführen zu können.
Keine Instanziierung | Wählen Sie diese Option aus, damit der XLANG-Ablaufplan Daten mithilfe eines Methodenaufrufs empfangen kann, ohne die Komponente zu aktivieren. Wenn Sie die Option Keine Instanziierung auswählen, werden Methodenaufrufe an diese Komponente abgefangen, die Argumente vom XLANG-Ablaufplanungsmodul gespeichert, und der Aufruf geht an den aufrufenden Prozess zurück. Die Komponente wird nie instanziiert.

Klasseninformationen

Auf der Seite Klasseninformationen können Sie eine Klasse aus einer Liste registrierter Komponenten oder von einem Moniker auswählen.

Schnittstelleninformationen

Auf der Seite Schnittstelleninformationen können Sie die Schnittstelle auswählen, die Sie verwenden möchten. Diese Seite wird nur dann angezeigt, wenn die ausgewählte Klasse mehrere Schnittstellen enthält. Visual Basic-Komponenten besitzen stets nur eine Schnittstelle.

Methodeninformationen

Auf der Seite Methodeninformationen können Sie die Methoden auswählen, die Sie verwenden möchten. Diese Seite wird nur dann angezeigt, wenn die ausgewählte Klasse mehrere Methoden enthält.

Erweiterte Porteigenschaften

Auf der Seite Erweiterte Porteigenschaften können Sie die Einstellungen für Sicherheit, Transaktionsunterstützung, Statusverwaltungsunterstützung und Fehlerbehandlung konfigurieren.

Zu den Eigenschaften für die Statusverwaltungsunterstützung der COM-Komponente-Form gehören:

  • Persistentes Speichern des Status eines XLANG-Ablaufplanes vor dem Start einer Transaktion und nach Beenden einer Transaktion. Durch die so gewährleistete Dauerhaftigkeit sind alle Datenänderungen nach dem Commit im System dauerhaft. Dadurch ist es auch möglich, eine Transaktion bei einem Fehler zu wiederholen.

  • Optimieren der Instanzenverwaltung, indem das XLANG-Ablaufplanungsmodul die Möglichkeit erhält, den XLANG-Ablaufplan zu pausieren und nach dem Eintreffen der vom Ablaufplan erwarteten Nachricht wieder zu aktivieren.

Sie können mit der COM-Komponente-Form authentifizierte Benutzerinformationen für die empfangenen Nachrichten anfordern.

Bereich Sicherheit

Die folgende Tabelle enthält eine Liste und Beschreibungen der Einstellungen für die Absenderidentitätsbestätigung.

Absenderidentitätsbestätigung | Beschreibung
Nicht erforderlich | Wählen Sie diese Option aus, wenn Sie möchten, dass der XLANG-Ablaufplan eine Nachricht empfangen kann, ohne die Identität des Absenders zu kennen.
Optional | Wählen Sie diese Option aus, wenn Sie möchten, dass das XLANG-Ablaufplanungsmodul den Absender identifiziert, wenn die Komponente eine Nachricht empfängt (falls die Informationen verfügbar sind).
Erforderlich | Wählen Sie diese Option aus, wenn Sie möchten, dass das XLANG-Ablaufplanungsmodul eine Nachricht nur dann empfangen kann, wenn es den Absender identifizieren kann.

Bereich Transaktionsunterstützung

Die folgende Tabelle enthält eine Liste und Beschreibungen der Einstellungen für die Transaktionsunterstützung.

Transaktionsunterstützung | Beschreibung
Deaktiviert | Für alle Nicht-COM+-Komponenten. Diese Option gibt an, dass die Komponente die COM-Transaktionsverwaltung ignoriert.
Nicht unterstützt | Nur für COM+-Komponenten. Diese Option gibt an, dass die Komponente nicht an einer Transaktion teilnimmt bzw. die Transaktionen anderer Komponenten nicht weitergibt.
Unterstützt | Nur für COM+-Komponenten. Diese Option gibt an, dass für den Fall, dass eine Transaktion einem Port zugeordnet ist, an den die Komponente gebunden ist, die Komponente in die Transaktion eingeschlossen wird. Andernfalls hat die Komponente keine Transaktion.
Erforderlich | Nur für COM+-Komponenten. Diese Option gibt an, dass für den Fall, dass eine Transaktion einem Port zugeordnet ist, an den die Komponente gebunden ist, die Komponente in die Transaktion eingeschlossen wird. Ist dem Port, an den die Komponente gebunden ist, keine Transaktion zugeordnet, wird eine neue Transaktion für die Komponente erstellt.
Neue Transaktion erforderlich | Nur für COM+-Komponenten. Diese Option gibt an, dass stets eine neue Transaktion für die Komponente erstellt wird.

Bereich Statusverwaltungsunterstützung

Die folgende Tabelle enthält eine Liste und Beschreibungen der Einstellungen für die Statusverwaltungsunterstützung.

Statusverwaltungsunterstützung | Beschreibung
Behält den Status nicht bei | Diese Option gibt an, dass das XLANG-Ablaufplanungsmodul die Komponenteninstanz beendet, wenn diese pausiert wird. Wenn Sie diese Einstellung auswählen, erstellt das XLANG-Ablaufplanungsmodul bei Bedarf eine neue Komponenteninstanz, wenn der Ablaufplan aktiviert wird.
Behält den Status bei, unterstützt aber keine Persistenz | Diese Option gibt an, dass das XLANG-Ablaufplanungsmodul die Ausführung der Komponenteninstanz nicht beenden soll. Falls es bei der Pausierung der Anwendung zu einem Systemfehler kommt, geht jeder in dieser Komponente beibehaltene Status verloren.
Behält den Status bei und unterstützt Persistenz | Diese Option gibt an, dass das XLANG-Ablaufplanungsmodul die Komponenteninstanz aus dem Speicher entfernt und sie dann im Speicher wiederherstellt, indem es IPersistStream oder IPersistStreamInit für die Komponente während der Pausierung und dann erneut bei der Aktivierung aufruft.

Bereich Fehlerbehandlung

Aktivieren Sie im Bereich Fehlerbehandlung das Kontrollkästchen Transaktion abbrechen, wenn die Methode ein Fehler-HRESULT zurückgibt, wenn Sie möchten, dass das XLANG-Ablaufplanungsmodul die Transaktion abbricht, wenn von einer Methode in einer Komponente ein Fehler zurückgegeben wird.

Anmerkungen

  • Wenn eine Aktion mit einem an eine COM-Komponente gebundenen Port kommuniziert und die angegebene Methode in der Komponente nicht vorhanden ist, wird die XLANG-Ablaufplaninstanz sofort beendet und es erfolgt ein Eintrag ins Ereignisprotokoll.

  • Der BizTalk-Orchestrierungs-Designer unterstützt keine Bindung an eine COM-Komponentenmethode, die einen von IDispatch abgeleiteten Parameter enthält. Der BizTalk-Orchestrierungs-Designer unterstützt jedoch die Bindung an COM-Komponentenmethoden, die Parameter vom Typ IDispatch enthalten.

  • Wenn eine Anwendung einen Verweis auf eine COM-Komponente in einem XLANG-Ablaufplan mithilfe einer IUnknown-Schnittstelle besitzt, wird dieser Verweis nach der Pausierung und Aktivierung der XLANG-Ablaufplaninstanz ungültig. Alle persistent speicherbaren COM-Komponenten werden ordnungsgemäß in den Status aktiviert, in dem sie sich zum Zeitpunkt der Pausierung befanden, den Schnittstellen werden jedoch neue Adressen zugewiesen. Dieses Verhalten wird erwartet und gilt als normal. Wenn zwei oder mehrere Nachrichtenfelder in einer einzelnen XLANG-Ablaufplaninstanz Zeiger auf dieselbe COM-Komponente enthalten und der Ablaufplan pausiert wird, so enthalten diese Nachrichtenfelder nach der Aktivierung Zeiger auf eine einzelne COM-Komponente. Es handelt sich jedoch nicht um dieselbe COM-Komponente wie vor der Pausierung. Stattdessen wurde eine neue COM-Komponente erstellt, die der vor der Pausierung vorhandenen COM-Komponente entspricht. Wenn die ursprüngliche COM-Komponente persistent speicherbar ist, besitzt die neue COM-Komponente denselben Status wie die ursprüngliche COM-Komponente vor der Pausierung.

  • Die Eindeutigkeit von Komponenten wird über While-Schleifen hinweg nicht beibehalten. Wenn eine Nachricht in einer While-Schleife ein Feld mit einem Zeiger auf eine COM-Komponente enthält und eine andere Nachricht außerhalb der While-Schleife ein Feld mit einem Zeiger auf dieselbe COM-Komponente enthält, haben beide Nachrichtenfelder nach der Pausierung und Aktivierung keine Zeiger mehr auf eine einzelne COM-Komponente. Die beiden Nachrichtenfelder besitzen dann Zeiger auf zwei separate COM-Komponenten, die der ursprünglichen COM-Komponente entsprechen. Wenn die ursprüngliche COM-Komponente persistent speicherbar ist, behalten die beiden neuen COM-Komponenten denselben Status bei wie die ursprüngliche COM-Komponente vor der Pausierung.

Verwandte Themen

Statische und dynamische Ports

Synchrone und asynchrone Kommunikation

Verwenden der BizTalk-Messaging-Form

Verwenden der Message Queuing-Form

Verwenden des Methodenkommunikations-Assistenten

Verwenden der Skriptkomponente-Form


Verwenden der Skriptkomponente-Form

Mit der Skriptkomponente-Form können Sie vorgegebene Windows-Skriptkomponenten für die Ausführung von Aktionen in einem XLANG-Ablaufplan verwenden. Da die Skriptkomponente synchron ist, gibt es stets einen bidirektionalen Nachrichtenfluss, wenn eine Aktion ausgeführt wird. Im Gegensatz dazu verläuft der Nachrichtenfluss bei einer asynchronen Technologie in einer Richtung.

Eine mit dem Port verbundene Sendeaktion zeigt den Aufruf eines bestimmten Methodenaufrufs durch das XLANG-Ablaufplanungsmodul. Die Parameter IN und IN/OUT werden an den Port gesendet. Dafür wird eine Nachricht mit einem Schema, das durch die Parameter IN/OUT und OUT des Methodenaufrufs definiert wird, vom Port empfangen. Der Methodenaufruf wird durch die an den Port gebundene Schnittstelle unterstützt.

Eine mit diesem Port verbundene Empfangsaktion wartet, bis eine externe Anwendung einen Methodenaufruf an den Port startet. Die Parameter IN und IN/OUT definieren das Schema der Nachricht, die vom Port empfangen wird, und die Parameter IN/OUT und OUT definieren das Schema der Nachricht, die von diesem Port gesendet wird.

Für jede Aktion, die mit einem Port verbunden und an eine Skriptkomponente gebunden ist, werden zwei Nachrichten ausgetauscht. Die Nachrichten identifizieren die an der Schnittstelle aufgerufene Methode. Das Schema der Nachrichten entspricht den Parametern IN und IN/OUT (und den Parametern IN/OUT und OUT) der Methodensignatur. Da der Zugriff auf die Typenbibliothek für die Komponenten möglich ist, kann der BizTalk-Orchestrierungs-Designer das Schema für diese Nachrichten automatisch erstellen, ohne den Benutzer nach dieser Information fragen zu müssen.

Das XLANG-Ablaufplanungsmodul setzt den Geschäftsprozess erst nach Rückgabe der Methode fort. Zum Senden einer Nachricht ruft das XLANG-Ablaufplanungsmodul die angegebene Methode einer Windows-Skriptkomponente auf.

Ziehen Sie zum Erstellen einer neuen Skriptkomponentenbindung die Skriptkomponente-Form aus der Implementierungsschablone auf die BizTalk-Orchestrierungsentwurfsseite auf die rechte Seite der Trennlinie. Klicken Sie mit der rechten Maustaste auf die Skriptkomponente-Form, und klicken Sie dann auf Eigenschaften, um eine vorhandene Skriptkomponente zu bearbeiten. Durch beide Aktionen wird der Bindungs-Assistent für Skriptkomponenten gestartet. Bei der Bindung handelt es sich um den Prozess, mit dem die Technologie zur Implementierung eines Ports festgelegt wird. Der Bindungs-Assistent für Skriptkomponenten setzt sich aus den folgenden sechs Seiten zusammen:

Willkommen beim Bindungs-Assistenten für Skriptkomponenten

Auf der Seite Willkommen beim Bindungs-Assistenten für Skriptkomponenten können Sie einen Port erstellen und benennen, für den Sie eine Implementierung definieren möchten.

Statische oder dynamische Kommunikation

Auf der Seite Statische oder dynamische Kommunikation können Sie definieren, wie die Komponente instanziiert werden soll. Die folgende Tabelle enthält eine Liste und Beschreibungen der Einstellungen für die statische und dynamische Kommunikation.

Statische oder dynamische Kommunikation | Beschreibung
Statisch | Wählen Sie diese Option aus, wenn Sie dem XLANG-Ablaufplanungsmodul alle zur Ausführung der Implementierung erforderlichen Informationen zur Entwurfszeit bereitstellen können.
Dynamisch | Wählen Sie diese Option aus, wenn das XLANG-Ablaufplanungsmodul zur Laufzeit zusätzliche Informationen benötigt, um die Implementierung ausführen zu können.
Keine Instanziierung | Wählen Sie diese Option aus, damit der XLANG-Ablaufplan Daten mithilfe eines Methodenaufrufs empfangen kann, ohne die Komponente zu aktivieren. Wenn Sie die Option Keine Instanziierung auswählen, werden Methodenaufrufe an diese Komponente abgefangen, die Argumente vom XLANG-Ablaufplanungsmodul gespeichert, und der Aufruf geht an den Aufrufer zurück. Die Komponente wird nie instanziiert.

Skriptdatei angeben

Auf der Seite Skriptdatei angeben können Sie den Pfad zu der Windows-Skriptkomponentendatei (WSC) eingeben, die Sie verwenden möchten.

Informationen über Komponenteninstanziierung

Auf der Seite Informationen über Komponenteninstanziierung können Sie angeben, ob das XLANG-Ablaufplanungsmodul zur Instanziierung der Skriptkomponente einen Moniker oder eine Programm-ID verwenden soll.

Methodeninformationen

Auf der Seite Methodeninformationen können Sie die Methoden auswählen, die zur ausgewählten Klasse gehören.

Erweiterte Porteigenschaften

Auf der Seite Erweiterte Porteigenschaften können Sie die Einstellungen für Sicherheit, Transaktionsunterstützung und Fehlerbehandlung konfigurieren. Mit der Skriptkomponente-Form können sie authentifizierte Benutzerinformationen für die empfangenen Nachrichten anfordern.

Bereich Sicherheit

Die folgende Tabelle enthält eine Liste und Beschreibungen der Einstellungen für die Absenderidentitätsbestätigung.

Absenderidentitätsbestätigung | Beschreibung
Nicht erforderlich | Wählen Sie diese Option aus, wenn Sie möchten, dass der XLANG-Ablaufplan eine Nachricht empfangen kann, ohne die Identität des Absenders zu kennen.
Optional | Wählen Sie diese Option aus, wenn Sie möchten, dass das XLANG-Ablaufplanungsmodul den Absender identifiziert, wenn die Komponente eine Nachricht empfängt (falls die Informationen verfügbar sind).
Erforderlich | Wählen Sie diese Option aus, wenn Sie möchten, dass das XLANG-Ablaufplanungsmodul eine Nachricht nur dann empfangen kann, wenn es den Absender identifizieren kann.

Bereich Transaktionsunterstützung

Die folgende Tabelle enthält eine Liste und Beschreibungen der Einstellungen für die Transaktionsunterstützung.

Transaktionsunterstützung | Beschreibung
Deaktiviert | Für alle Nicht-COM+-Komponenten. Diese Option gibt an, dass die Komponente die COM-Transaktionsverwaltung ignoriert.
Nicht unterstützt | Diese Option ist nur verfügbar, wenn das Skript als COM+-Komponente installiert ist. Diese Auswahl gibt an, dass die Komponente nicht an einer Transaktion teilnimmt bzw. die Transaktionen anderer Komponenten nicht weitergibt.
Unterstützt | Diese Option ist nur verfügbar, wenn das Skript als COM+-Komponente installiert ist. Diese Option gibt an, dass für den Fall, dass eine Transaktion einem Port zugeordnet ist, an den die Komponente gebunden ist, die Komponente in die Transaktion eingeschlossen wird. Andernfalls hat die Komponente keine Transaktion.
Erforderlich | Diese Option ist nur verfügbar, wenn das Skript als COM+-Komponente installiert ist. Diese Option gibt an, dass für den Fall, dass eine Transaktion einem Port zugeordnet ist, an den die Komponente gebunden ist, die Komponente in die Transaktion eingeschlossen wird. Ist dem Port, an den die Komponente gebunden ist, keine Transaktion zugeordnet, wird eine neue Transaktion für die Komponente erstellt.
Neue Transaktion erforderlich | Diese Option ist nur verfügbar, wenn das Skript als COM+-Komponente installiert ist. Diese Option gibt an, dass stets eine neue Transaktion für die Komponente erstellt wird.

Bereich Fehlerbehandlung

Aktivieren Sie im Fehlerbehandlungsbereich das Kontrollkästchen Transaktion abbrechen, wenn die Methode ein Fehler-HRESULT zurückgibt, wenn Sie möchten, dass das XLANG-Ablaufplanungsmodul die Transaktion abbricht, wenn von einer Methode in einer Komponente ein Fehler zurückgegeben wird. Wenn Sie die Seiten Bei Fehler von Transaktion und Kompensierung für Transaktion verwenden möchten, müssen Sie diese Option für das XLANG-Ablaufplanungsmodul auswählen. Wenn diese Option nicht ausgewählt ist, können keine der auf diesen Seiten definierten Wiederherstellungsprozesse für Fehler ausgeführt werden.

Wichtig

  • Wenn Sie Windows-Skriptkomponenten verwenden, müssen diese folgenden Regeln entsprechen:
    • Argumentdeklarationen müssen durch Verweisübergabe, nicht durch Wertübergabe erfolgen.

    • VBScript-Subroutinen werden nicht unterstützt. Es werden lediglich Funktionen unterstützt.

    • In einer einzelnen WSC-Datei können nicht mehrere Komponenten verwendet werden.

Anmerkungen

  • Wenn eine Aktion mit einem an eine Skriptkomponente gebundenen Port kommuniziert und die angegebene Methode in der Skriptkomponente nicht vorhanden ist, wird die XLANG-Ablaufplaninstanz sofort beendet und es erfolgt ein Eintrag ins Ereignisprotokoll.

  • Vom XLANG-Ablaufplanungsmodul ausgeführte Skriptkomponenten können erst geändert werden, wenn das XLANG-Ablaufplanungsmodul und der Windows Scripting Host beendet wurden.

Verwandte Themen

Statische und dynamische Ports

Synchrone und asynchrone Kommunikation

Verwenden der BizTalk-Messaging-Form

Verwenden der COM-Komponente-Form

Verwenden der Message Queuing-Form

Verwenden des Methodenkommunikations-Assistenten


Verwenden der Message Queuing-Form

Mit der Message Queuing-Form kann ein XLANG-Ablaufplan mit einem anderen XLANG-Ablaufplan (oder mit einer Anwendung) mithilfe einer Warteschlange auf eine flexibel verbundene Weise kommunizieren. Nachrichten werden in einer Warteschlange abgelegt und dann gelesen, um die Kommunikation zwischen XLANG-Ablaufplänen und Anwendungen zu ermöglichen. Ein einzelner XLANG-Ablaufplan kann mehrere Ports verwenden, die an die Message Queuing-Form gebunden sind.

Wenn ein Port an eine Message Queuing-Form gebunden ist, ist er auch an eine Nachrichtenwarteschlange gebunden. Der Port kann an eine benannte Warteschlange oder an eine Warteschlange auf Instanzebene gebunden sein. Wenn ein Port an eine Warteschlange auf Instanzebene gebunden ist, wird für jede Instanz dieses XLANG-Ablaufplanes eine eindeutige Warteschlange erstellt und verwendet. Warteschlangen auf Instanzebene bieten eine einfache Möglichkeit für einen XLANG-Ablaufplan, über eine separate Warteschlange für jede XLANG-Ablaufplaninstanz zu verfügen.

Wenn eine Aktion mit einem an eine Nachrichtenwarteschlange gebundenen Port verbunden ist, werden die folgenden Informationen verwendet, um die Art und Weise festzulegen, in der Nachrichten im Ablaufplan repräsentiert werden:

Die von der Aktion gesendete oder empfangene Nachricht muss definiert werden. Da in einer Warteschlange mehrere Nachrichtentypen gespeichert werden können, hilft der Nachrichtentyp, den Typ der Nachricht zu identifizieren, die von der Aktion empfangen werden soll. Während einer Sendeaktion wird der Nachrichtentyp in der Bezeichnungseigenschaft der Nachricht markiert, wenn diese in die Warteschlange geschrieben wird.

Die Message Queuing-Form stellt den Message Queuing-Dienst zum Senden oder Empfangen von Nachrichten dar. Zum Empfang einer Nachricht benötigt das XLANG-Ablaufplanungsmodul den Namen der verwendeten Warteschlange sowie den Namen des Stammelements des in dieser Nachricht enthaltenen XML-Schemas. Zum Senden einer Nachricht benötigt das XLANG-Ablaufplanungsmodul den Namen der Warteschlange, die zum Übertragen von Nachrichten verwendet wird.

Wenn Sie eine XLANG-Ablaufplaninstanz zur Verwendung von Message Queuing für den Empfang von Nachrichten konfigurieren, können Sie den Verwenden des Assistenten für XML-Kommunikation verwenden, um XML oder Zeichenfolge als Zielformat festzulegen.

Ziehen Sie die Message-Queuing-Form zum Erstellen einer neuen Message Queuing-Bindung aus der Implementierungsschablone auf die BizTalk-Orchestrierungsentwurfsseite rechts neben die Trennlinie. Klicken Sie mit der rechten Maustaste auf die Message Queuing-Form, und klicken Sie dann auf Eigenschaften, um eine vorhandene Message Queuing-Implementierung zu bearbeiten. Durch beide Aktionen wird der Bindungs-Assistent für Message Queuing gestartet. Bei der Bindung handelt es sich um den Prozess, mit dem die Technologie zur Implementierung eines Ports festgelegt wird. Der Bindungs-Assistent für Message Queuing setzt sich aus den folgenden vier Seiten zusammen:

Willkommen beim Bindungs-Assistenten für Message Queuing

Auf der Seite Willkommen beim Bindungs-Assistenten für Message Queuing können Sie einen Port erstellen und benennen, für den Sie eine Implementierung definieren möchten, oder Sie wählen einen vorhandenen, ungebundenen Port aus.

Informationen über statische oder dynamische Warteschlangen

Auf der Seite Informationen über statische oder dynamische Warteschlangen können Sie angeben, ob die Nachrichtenwarteschlange zur Entwurfs- oder zur Laufzeit definiert werden soll. Wählen Sie eine der folgenden Optionen:

  • Wählen Sie Statische Warteschlange aus, wenn Sie Warteschlangeninformationen zur Entwurfszeit bereitstellen können.

  • Wählen Sie Dynamische Warteschlange aus, wenn Sie möchten, dass das XLANG-Ablaufplanungsmodul Informationen zur Bestimmung des Warteschlangennamens zur Laufzeit von einer externen Quelle erhalten soll.

Warteschlangeninformationen

Auf der Seite Warteschlangeninformationen können Sie eine neue Warteschlange erstellen oder eine vorhandene Warteschlange angeben. Wählen Sie eine der folgenden Optionen aus:

  • Wählen Sie Neue Warteschlange für jede Instanz erstellen, wenn das XLANG-Ablaufplanungsmodul eine Warteschlange für jede XLANG-Ablaufplaninstanz erstellen soll.

  • Wählen Sie Bekannte Warteschlange für alle Instanzen verwenden, wenn das XLANG-Ablaufplanungsmodul eine bekannte Warteschlange verwenden soll.

Erweiterte Porteigenschaften

Auf der Seite Erweiterte Porteigenschaften können Sie die Sicherheitseinstellungen konfigurieren und festlegen, ob die Transaktionsunterstützung aktiviert werden soll oder nicht. Sie können mit der Message Queuing-Form authentifizierte Benutzerinformationen für die empfangenen Nachrichten anfordern.

Bereich Sicherheit

Die folgende Tabelle enthält eine Liste und Beschreibungen der Einstellungen für die Absenderidentitätsbestätigung.

Absenderidentitätsbestätigung | Beschreibung
Nicht erforderlich | Wählen Sie diese Option aus, wenn Sie möchten, dass der XLANG-Ablaufplan eine Nachricht empfangen kann, ohne die Identität des Absenders zu kennen.
Optional | Wählen Sie diese Option aus, wenn Sie möchten, dass das XLANG-Ablaufplanungsmodul den Absender identifiziert, wenn die Komponente eine Nachricht empfängt (falls die Informationen verfügbar sind).
Erforderlich | Wählen Sie diese Option aus, wenn Sie möchten, dass das XLANG-Ablaufplanungsmodul eine Nachricht nur dann empfangen kann, wenn es den Absender identifizieren kann.

Sie können auch das Kontrollkästchen Zum Steuern der Warteschlange eine Windows-Gruppe oder einen Benutzernamen verwenden aktivieren bzw. deaktivieren. Wenn Sie das Kontrollkästchen aktivieren, geben Sie den Namen des Benutzers bzw. der Gruppe ein, der bzw. die berechtigt ist, Nachrichten in die Warteschlange zu schreiben. Diese Option steht nur zur Verfügung, wenn Sie eine statische Warteschlange erstellen.

Bereich Transaktionsunterstützung

Aktivieren Sie im Bereich Transaktionsunterstützung das Kontrollkästchen Für diese Warteschlange sind Transaktionen erforderlich, um die Transaktionsunterstützung zu aktivieren.

Anmerkungen

  • Zurzeit ermöglicht das unterstützte Namensformat für Warteschlangen keinen Remotezugriff auf eine Warteschlange auf einem anderen Computer. Verwenden Sie öffentliche anstatt private Warteschlangen, wenn ein XLANG-Ablaufplan mit einer Anwendung auf einem Remotecomputer kommuniziert.

  • Wenn eine Aktion mit einem an Message Queuing gebundenen Port kommuniziert und die angegebene Warteschlange für die Bindung nicht vorhanden ist, wird die XLANG-Ablaufplaninstanz sofort beendet und es erfolgt ein Eintrag ins Ereignisprotokoll.

  • Es ist wichtig, dass das XLANG-Ablaufplanungsmodul in der Lage ist, festzustellen, ob es sich um eine Transaktionswarteschlange handelt oder nicht. Wenn sich eine Warteschlange in einem Transaktionskontext befindet und eine Nachricht an die Warteschlange gesendet wird, muss das XLANG-Ablaufplanungsmodul wissen, ob die Transaktion zur Kommunikation mit der Warteschlange verwendet werden soll. Wenn für die Portbindungskonfiguration das Kontrollkästchen Für diese Warteschlange sind Transaktionen erforderlich aktiviert ist, beendet das XLANG-Ablaufplanungsmodul sofort den XLANG-Ablaufplan, wenn zur Laufzeit festgestellt wird, dass die Warteschlange keinen Transaktionskontext besitzt.

Verwandte Themen

Statische und dynamische Ports

Synchrone und asynchrone Kommunikation

Verwenden der BizTalk-Messaging-Form

Verwenden der COM-Komponente-Form

Verwenden der Skriptkomponente-Form

Verwenden des Assistenten für XML-Kommunikation


Verwenden der BizTalk-Messaging-Form

Die BizTalk-Messaging-Form stellt BizTalk-Messagingdienste dar, mit denen Nachrichten zwischen BizTalk-Orchestrierungsdiensten und BizTalk-Messagingdiensten ausgetauscht werden. Das XLANG-Ablaufplanungsmodul benötigt die von den BizTalk-Messagingdiensten zum Empfangen von Dokumenten verwendete HTTP-URL-Adresse, den Namen des Kanals und den Nachrichtentyp der ausgehenden Dokumentdefinition, um eine Nachricht zu empfangen. Für das Empfangen von Dokumenten zur XLANG-Ablaufplanaktivierung ist lediglich der Nachrichtentyp der Dokumentdefinition erforderlich. Das XLANG-Ablaufplanungsmodul benötigt den Namen des Kanals und den Nachrichtentyp der eingehenden Dokumentdefinition, um eine Nachricht zu senden. Weitere Informationenzum Austausch von Nachrichten zwischen BizTalk-Orchestrierungsdiensten und BizTalk-Messagingdiensten finden Sie unter Integrieren der BizTalk-Dienste.

Wichtig

  • Wenn Sie einen Port konfigurieren, um beim Eintreffen einer Nachricht einen neuen XLANG-Ablaufplan zu aktivieren, müssen Sie folgende Einschränkungen berücksichtigen:
    • Es kann nur ein Port in einem Ablaufplan verwendet werden, um den XLANG-Ablaufplan beim Eintreffen der Nachricht zu aktivieren.

    • Es kann nur eine Aktion über diesen Port empfangen werden.

    • Diese Aktion kann sich nicht in einem Schleifenkörper befinden.

    • Sie können keine Datenflussverbindung vom Portverweis auf diesen Port zu einer anderen Nachricht im Ablaufplan zeichnen.

Ziehen Sie die BizTalk-Messaging-Formzum Erstellen einer neuen Message Queuing-Bindung aus der Implementierungsschablone auf die BizTalk-Orchestrierungsentwurfsseite rechts neben die Trennlinie. Klicken Sie mit der rechten Maustaste auf die BizTalk-Messaging-Form, und klicken Sie dann auf Eigenschaften, um eine vorhandene BizTalk-Messaging-Implementierung zu bearbeiten. Durch beide Aktionen wird der Bindungs-Assistent für BizTalk-Messaging gestartet. Bei der Bindung handelt es sich um den Prozess, mit dem die Technologie zur Implementierung eines Ports festgelegt wird. Der Bindungs-Assistent für BizTalk-Messaging setzt sich aus den folgenden Seiten zusammen:

Willkommen beim BizTalk-Bindungs-Assistenten für Messaging

Auf der Seite Willkommen beim BizTalk-Bindungs-Assistenten für Messaging können Sie einen Port erstellen und benennen, für den Sie eine Implementierung definieren möchten, oder Sie wählen einen vorhandenen, ungebundenen Port.

Kommunikationsrichtung

Auf der Seite Kommunikationsrichtung können Sie angeben, ob der Port für das Senden oder das Empfangen von Nachrichten konfiguriert werden soll.

Informationen über statische oder dynamische Kanäle

Die Seite Informationen über statische oder dynamische Kanäle wird nur angezeigt, wenn Sie auf der Seite Willkommen beim BizTalk-Bindungs-Assistenten für Messaging die Option Senden auswählen. Auf der Seite Informationen über statische oder dynamische Kanäle können Sie angeben, ob das XLANG-Ablaufplanungsmodul einen statischen Kanal verwenden soll, der zur Entwurfszeit definiert wird, oder einen dynamischen Kanal, der zur Laufzeit definiert wird.

Informationen über die XLANG-Ablaufplanaktivierung

Auf der Seite Informationen über die XLANG-Ablaufplanaktivierung können Sie angeben, ob bei dieser Empfangsaktion eine XLANG-Ablaufplaninstanz aktiviert werden soll. Wenn Sie Ja auswählen, wird der BizTalk-Bindungs-Assistent für Messaging beendet. Wenn Sie Nein auswählen, wird die Seite Kanalinformationen angezeigt.

Kanalinformationen

Auf der Seite Kanalinformationen können Sie den Namen des Kanals sowie die vom BizTalk-Messagingdienst zum Empfang von Dokumenten verwendete HTTP-URL-Adresse angeben.

Anmerkungen

  • Wenn eine Aktion mit einem an BizTalk-Messaging gebundenen Port kommuniziert und der angegebene Kanal für die Bindung nicht vorhanden ist, wird die XLANG-Ablaufplaninstanz sofort beendet und es erfolgt ein Eintrag ins Ereignisprotokoll.

  • Das Einschließen separater Sende- und Empfangsbindungen für BizTalk-Messaging in einer Transaktion kann zu einer Deadlocksituation führen, die einen Fehler der Transaktion verursacht.

  • Aktionsereignisse, die Nachrichten zugeordnet sind, die von einem XLANG-Ablaufplan verarbeitet werden und von BizTalk-Messagingdiensten gesendet oder empfangen werden, können in der Überwachungsdatenbank überwacht werden. Weitere Informationen finden Sie unter Überwachen von XLANG-Ablaufplanereignissen in der Überwachungsdatenbank.

Verwandte Themen

Statische und dynamische Ports

Synchrone und asynchrone Kommunikation

Verwenden der COM-Komponente-Form

Verwenden der Message Queuing-Form

Verwenden der Skriptkomponente-Form

Verwenden des Assistenten für XML-Kommunikation


Synchrone und asynchrone Kommunikation

Jede Kommunikation mit einer COM-Komponenten- oder Skriptkomponentenimplementierung ist synchron. Wenn Sie einen Kommunikationsfluss zu einem Port erstellen möchten, der eine COM-Komponenten- oder Skriptkomponentenimplementierung verwendet, müssen Sie den Methodenkommunikations-Assistenten verwenden.

Jede Kommunikation mit einem ungebundenen Port oder einer Message Queuing- oder BizTalk-Messaging-Implementierung ist asynchron. Wenn Sie einen Kommunikationsfluss zu einem Port erstellen möchten, der eine Message Queuing- oder BizTalk-Messaging-Implementierung verwendet, oder wenn Sie einen Kommunikationsfluss zu einem ungebundenen Port erstellen möchten, müssen Sie den Assistenten für XML-Kommunikation verwenden.

In der folgenden Abbildung und dem folgenden Text wird beschrieben, welche Funktionen der XLANG-Ablaufplan für die vier möglichen Kommunikationsaktionen ausführt.

Synchrone und asynchrone Kommunikation - Übersicht

Keine
Wartezeit

Warten

Warten

Warten

2

Asynchrone Sendeaktion

Synchrone Sendeaktion

Asynchrone Empfangsaktion

Synchrone Empfangsaktion

1

3

4

4

3

2

1

Warten

Eine andere
Anwendung

XLANG-
Ablaufplan

COM- oder Skriptkomponente

Message Queuing oder Biztalk-Messaging

  1. Synchrone Empfangsaktion
    1. Der XLANG-Ablaufplan wartet, bis eine andere Anwendung einen Methodenaufruf sendet und eine Komponente instanziiert.

    2. Der Ablaufplan fängt den Methodenaufruf ab.

    3. Der Ablaufplan wartet, bis die Komponente die Methodenantwort zurückgibt.

    4. Der Ablaufplan fängt die Methodenantwort ab.

    5. Der Ablaufplan fährt mit der nächsten Aktion im Geschäftsprozessablauf fort.
  2. Synchrone Sendeaktion
    1. Der XLANG-Ablaufplan initiiert den Methodenaufruf und instanziiert die Komponente.

    2. Der Ablaufplan wartet, bis die Komponente die Methodenantwort zurückgibt.

    3. Der Ablaufplan empfängt die Methodenantwort.

    4. Der Ablaufplan fährt mit der nächsten Aktion im Geschäftsprozessablauf fort.
  3. Asynchrone Empfangsaktion
    1. Der XLANG-Ablaufplan wartet, bis eine andere Anwendung eine Nachricht an eine Nachrichtenwarteschlange oder einen BizTalk-Messagingkanal sendet.

    2. Der XLANG-Ablaufplan empfängt die Nachricht von der Nachrichtenwarteschlange oder vom Kanal.

    3. Der Ablaufplan fährt mit der nächsten Aktion im Geschäftsprozessablauf fort.
  4. Asynchrone Sendeaktion
    1. Der XLANG-Ablaufplan sendet eine Nachricht an eine Nachrichtenwarteschlange oder einen BizTalk-Messagingkanal.

    2. Der Ablaufplan fährt mit der nächsten Aktion im Geschäftsprozessablauf fort.

    3. Eine andere Anwendung empfängt die Nachricht von der Nachrichtenwarteschlange oder vom BizTalk-Messagingkanal.

Anmerkungen

  • Bei der synchronen Empfangsaktion gibt es einen Sonderfall. Wenn Sie Keine Instanziierung im Bindungs-Assistenten für COM- oder für Skriptkomponenten auswählen, wird die Komponente nicht instanziiert und kein Code für den Methodenaufruf ausgeführt. Stattdessen gibt der XLANG-Ablaufplan diese Informationen als Antwort zurück, wenn er die Methodenanforderungsinformationen abfängt. Der Methodenaufruf wird umgangen. Weitere Informationen zu statischen und dynamischen Ports und zum Bindungs-Assistenten für COM- und für Skriptkomponenten finden Sie in folgenden Themen:
    • Static and Dynamic Ports

    • Implement Ports

    • Using the COM Component Shape

    • Using the Script Component Shape
  • Aktionsereignisse, die Nachrichten zugeordnet sind, die von einem XLANG-Ablaufplan verarbeitet und von BizTalk-Messagingdiensten gesendet oder empfangen werden, können in der Überwachungsdatenbank überwacht werden. Weitere Informationen finden Sie unter Überwachen von XLANG-Ablaufplanereignissen in der Überwachungsdatenbank.

Dieser Abschnitt enthält Informationen zu folgenden Themen:

  • Verwenden des Methodenkommunikations-Assistenten

  • Synchrone Kommunikation

  • Verwenden des Assistenten für XML-Kommunikation

  • Asynchrone Kommunikation

Verwandte Themen

Implementieren von Ports

Statische und dynamische Ports

Verwenden der COM-Komponente-Form

Verwenden der Skriptkomponente-Form


Verwenden des Methodenkommunikations-Assistenten

Sie können den Methodenkommunikations-Assistenten auf der Geschäftsprozessseite, der Seite Bei Fehler von Transaktion und auf der Seite Kompensierung für Transaktion verwenden, um den Nachrichtenfluss zwischen einer Aktion-Form und einer COM-Komponente- oder einer Skriptkomponente-Form zu definieren. Wenn eine Nachricht gesendet wird, ruft der XLANG-Ablaufplan die Methode mit der _in-Nachricht auf und wartet dann auf den Empfang der _out-Nachricht von der Komponente. Wenn eine Nachricht empfangen werden soll, wartet der XLANG-Ablaufplan, bis eine andere Anwendung die _in-Nachricht an die Methode sendet (durch den Aufruf einer Methode am Port), und wartet dann, bis die _out-Nachricht der Komponente an die andere Anwendung zurückgesendet wird.

Anmerkungen

  • Hinweis für Visual Basic-Programmierer: ByVal-Parameter erscheinen nur in der _in-Nachricht. Alle anderen Parameter erscheinen in der _in- und der _out-Nachricht.

  • Hinweis für C-Programmierer: in-Parameter erscheinen in der _in-Nachricht, out-Parameter in der _out-Nachricht, und in,out-Parameter erscheinen in beiden Nachrichten.

  • Hinweis für Visual Basic-Programmierer und C-Programmierer: Wenn ein Parameter in der _in- und der _out-Nachricht erscheint, enthält die _in-Nachricht den Inhalt, der in die Methode gesendet wurde, und die _out-Nachricht enthält den Inhalt, der von der Methode zurückgegeben wurde.

Ziehen Sie das rechte Kontrollhandle ( Kontrollhandle) einer Aktion-Form auf den Verbindungspunkt ( Verbindungspunkt) eines an eine COM-Komponente- oder eine Skriptkomponente-Form gebundenen Ports, um den Methodenkommunikations-Assistenten zu starten. Der Methodenkommunikations-Assistent setzt sich aus den folgenden drei Seiten zusammen:

Willkommen beim Methodenkommunikations-Assistenten

Auf der Seite Willkommen beim Methodenkommunikations-Assistenten können Sie angeben, ob das XLANG-Ablaufplanungsmodul eine Methode aufrufen oder auf einen Methodenaufruf warten soll. Wenn Sie angeben, dass das XLANG-Ablaufplanungsmodul auf einen Methodenaufruf warten soll, können Sie einen Wert für die Wartezeit in Sekunden festlegen, die das XLANG-Ablaufplanungsmodul auf das Eintreffen der Nachricht warten soll. Wenn dieser Wert 180 Sekunden oder weniger beträgt, wird die XLANG-Ablaufplaninstanz nie in der Persistenzdatenbank pausiert. Ist der Wert höher als 180 Sekunden, wird die XLANG-Ablaufplaninstanz sofort in der Persistenzdatenbank pausiert. Der Standardwert für die Wartezeit ist NULL und weist darauf hin, dass das Eintreffen der Nachricht sofort erwartet wird.

Wenn eine XLANG-Ablaufplaninstanz aus einem anderen Grund aktiviert wird als aufgrund des Eintreffens einer von einer Aktion erwarteten Nachricht (und die XLANG-Ablaufplaninstanz dann in einen Ruhezustand eintritt), wird der angegebene Wartezeitwert verwendet, um zu bestimmen, ob die XLANG-Ablaufplaninstanz sofort pausiert wird oder nicht. Dies kann beispielsweise dann der Fall sein, wenn eine parallele Verzweigung eine Nachricht empfängt, auf die sie gewartet hat, oder wenn der Neustart eines Computers dazu führt, dass alle XLANG-Ablaufplaninstanzen aktiviert werden. In dieser Situation wird der Wert der Wartezeit von dem Zeitpunkt an ausgewertet, an dem die XLANG-Ablaufplaninstanz in einen Ruhezustand eintritt. Wenn der Zeitraum vom Beginn der ursprünglichen Wartezeit (kombiniert mit dem Wartezeitwert) des XLANG-Ablaufplanungsmoduls bis zu dem Zeitpunkt, an dem das XLANG-Ablaufplanungsmodul nach der Aktivierung in den Ruhezustand eingetreten ist, über 180 Sekunden beträgt, wird die XLANG-Ablaufplaninstanz sofort in der Persistenzdatenbank pausiert. Dieser Punkt kann in der XLANG-Ablaufplaninstanz lange nach dem Beginn der Überwachung des Eintreffens einer Nachricht durch das XLANG-Ablaufplanungsmodul eintreten.

Nachrichteninformationen

Auf der Seite Nachrichteninformationen können Sie angeben, ob eine neue Nachricht oder ein Verweis auf eine vorhandene Nachricht erstellt werden soll. Wenn Sie festlegen, dass ein Verweis auf eine vorhandene Nachricht erstellt werden soll, können Sie aus einer Liste vorher erstellter Nachrichten wählen, die von Methoden gesendet bzw. empfangen wurden und bereits über entsprechende Nachrichtenformen verfügen. Wenn die gewünschte Nachricht in der Liste nicht enthalten ist, geben Sie an, dass eine neue Nachricht erstellt werden soll, und definieren Sie den Datenfluss der neuen Nachricht.

Informationen über die Nachrichtenspezifikation

Auf der Seite Informationen über die Nachrichtenspezifikation können Sie eine Nachrichtenspezifikation für die Nachricht auswählen, die Sie auf der Seite Nachrichteninformationen erstellt bzw. auf die Sie auf dieser Seite verwiesen haben.

Verwandte Themen

Asynchrone Kommunikation

Pausierung und Aktivierung

Persistenz

Synchrone und asynchrone Kommunikation

Synchrone Kommunikation

Verwenden des Assistenten für XML-Kommunikation


Synchrone Kommunikation

Die einzigen Methoden, die für die synchrone Kommunikation verfügbar sind, sind die für die Portimplementierung ausgewählten Methoden. Methoden aus anderen Portimplementierungen sowie XML-Nachrichten aus asynchronen Kommunikationsflüssen können nicht verwendet werden. Führen Sie den Methodenkommunikations-Assistenten erneut aus, um die verfügbaren Methoden zu ändern, und wählen Sie verschiedene Methoden aus.

Die Parameter IN und OUT werden von der ausgewählten Methode automatisch anhand der Parameteranforderungen bestimmt. Beide Parameterlisten enthalten den Namen und den Datentyp des Parameters. Neben den der Methode zugeordneten Parametern enthält eine Nachricht auch bestimmte erforderliche Systemfelder. Eine synchrone Nachricht enthält stets die folgenden Systemfelder:

  • __Sender__

    Bei diesem Systemfeld handelt es sich um einen erforderlichen IN-Parameter für die in einer synchronen Nachricht verwendete Methode.

  • __Status__

    Bei diesem Systemfeld handelt es sich um einen erforderlichen OUT-Parameter für die in einer synchronen Nachricht verwendete Methode.

Synchrone Nachrichten

Wenn Sie eine synchrone Kommunikation erstellen, wird auf der Datenseite eine Nachricht erstellt. Die Nachricht entspricht der Methode und den Parametern, die im Kommunikationsfluss verwendet werden. Die Nachricht enthält alle IN-Parameter und alle OUT-Parameter für die Methode.

Eine Methode kann keine Parameter enthalten, die Nachricht enthält jedoch stets erforderliche Systemfelder. Das Nachrichtenschema ist im folgenden Beispiel dargestellt:

Method name_in
__Sender__   string
   parameter 1   Data type 1
   parameter 2   Data type 2
   parameter n   Data type n
Method name_out
__Status__   string
   Parameter 1   Data type 1
   Parameter 2   Data type 2
   Parameter n   Data type n

Die folgende Abbildung zeigt ein synchrones Nachrichtenpaar, das die Systemfelder __Sender__ und __Status__ sowie IN- und OUT-Parameter für den Methodenaufruf enthält.

Ein synchrones Nachrichtenpaar mit einem Methodenaufruf und den zugeordneten Werten
Methode_out
Datentyp 3
Datentyp 2
Datentyp 1
String
Parameter 2
Parameter 1
Datentyp 2
Datentyp 1
Int
_Status_
Parameter 3
Parameter 2
Parameter 1
_Sender_
Methode_in

Verwandte Themen

Pausierung und Aktivierung

Persistenz

Synchrone und asynchrone Kommunikation

Verwenden des Methodenkommunikations-Assistenten


Verwenden des Assistenten für XML-Kommunikation

Sie können den Assistenten für XML-Kommunikation auf der Geschäftsprozessseite und den Seiten Kompensierung für Transaktion und Bei Fehler von Transaktion verwenden, um den Nachrichtenfluss zwischen einer Aktion-Form und einer Message Queuing-Form, einer BizTalk-Messaging-Form oder einem ungebundenen Port zu definieren. Ziehen Sie das rechte Kontrollhandle ( Kontrollhandle) einer Aktion-Form auf den Verbindungspunkt ( Verbindungspunkt) eines ungebundenen Ports oder eines an eine Message Queuing- oder eine BizTalk-Messaging-Form gebundenen Ports, um den Assistenten für XML-Kommunikation zu starten. Der Assistent für XML-Kommunikation setzt sich aus den folgenden fünf Seiten zusammen:

Willkommen beim Assistenten für XML-Kommunikation

Auf der Seite Willkommen beim Assistenten für XML-Kommunikation können Sie angeben, ob der Port eine Nachricht an eine Aktion senden oder eine Nachricht von einer Aktion empfangen soll. Wenn Sie die Kommunikation zwischen einer Aktion und einem Port erstellen, der mit der BizTalk-Messaging-Form implementiert wurde, ist die Kommunikationsrichtung bereits konfiguriert worden. Dies ist erfolgt, als die Portbindung mit dem BizTalk-Bindungs-Assistenten für Messaging erstellt wurde.

Wenn der Port zum Empfang von Nachrichten konfiguriert wurde, können Sie einen Wert für die Wartezeit in Sekunden festlegen, die das XLANG-Ablaufplanungsmodul auf das Eintreffen der Nachricht warten soll. Wenn dieser Wert 180 Sekunden oder weniger beträgt, wird die XLANG-Ablaufplaninstanz nie in der Persistenzdatenbank pausiert. Ist der Wert höher als 180 Sekunden, wird die XLANG-Ablaufplaninstanz sofort in der Persistenzdatenbank pausiert. Der Standardwert für die Wartezeit ist null Sekunden und weist darauf hin, dass das Eintreffen der Nachricht sofort erwartet wird.

Wenn eine XLANG-Ablaufplaninstanz aus einem anderen Grund aktiviert wird als aufgrund des Eintreffens einer von einer Aktion erwarteten Nachricht (und die XLANG-Ablaufplaninstanz dann in einen Ruhezustand eintritt), wird der angegebene Wartezeitwert verwendet, um zu bestimmen, ob die XLANG-Ablaufplaninstanz sofort pausiert wird oder nicht. Dies kann beispielsweise dann der Fall sein, wenn eine parallele Verzweigung eine Nachricht empfängt, auf die sie gewartet hat, oder wenn der Neustart eines Computers dazu führt, dass alle XLANG-Ablaufplaninstanzen aktiviert werden. In dieser Situation wird der Wert der Wartezeit von dem Zeitpunkt an ausgewertet, an dem die XLANG-Ablaufplaninstanz in einen Ruhezustand eintritt. Wenn der Zeitraum vom Beginn der ursprünglichen Wartezeit (zusammen mit dem Wartezeitwert) des XLANG-Ablaufplanungsmoduls bis zu dem Zeitpunkt, an dem das XLANG-Ablaufplanungsmodul nach der Aktivierung in den Ruhezustand eingetreten ist, über 180 Sekunden beträgt, wird die XLANG-Ablaufplaninstanz sofort in der Persistenzdatenbank pausiert. Dieser Punkt kann in der XLANG-Ablaufplaninstanz lange nach dem Beginn der Überwachung des Eintreffens einer Nachricht durch das XLANG-Ablaufplanungsmodul eintreten.

Nachrichteninformationen

Auf der Seite Nachrichteninformationen können Sie angeben, ob eine neue Nachricht oder ein Verweis auf eine vorhandene Nachricht erstellt werden soll. Wenn Sie angeben, dass eine neue Nachricht erstellt werden soll, definieren Sie den Datenfluss der neuen Nachricht. Weitere Informationen zum Datenfluss finden Sie unter Datenverarbeitung. Mit der Bezeichnungseigenschaft einer Nachricht können Sie die Leistung eines Ablaufplanes wie folgt optimieren:

  • Wenn die Bezeichnungseigenschaft der Nachricht dem XML-Stammelement entspricht, das beim Erstellen einer neuen Nachrichtenform angegeben wird, ruft das XLANG-Ablaufplanungsmodul die Nachricht ab.

  • Wenn die Bezeichnungseigenschaft nicht mit dem für das XML-Stammelement bereitgestellten Wert übereinstimmt, überprüft das XLANG-Ablaufplanungsmodul den Inhalt der Nachricht. Wenn der Wert des XML-Stammelements, das beim Erstellen einer neuen Nachrichtenform angegeben wird, mit dem eigentlichen XML-Stammelement übereinstimmt, ruft das XLANG-Ablaufplanungsmodul die Nachricht ab. Andernfalls lässt das XLANG-Ablaufplanungsmodul die Nachricht in der Warteschlange und überprüft die nächste Nachricht.

Informationen über die XML-Konvertierung

Auf der Seite Informationen über die XML-Konvertierung können Sie angeben, ob Nachrichten als XML-formatierte Daten oder als Textzeichenfolgen an die Warteschlange gesendet bzw. aus dieser empfangen werden sollen. Wenn Sie festlegen, dass Nachrichten als Textzeichenfolgen gesendet werden sollen, wird der Standard-XML-Wrapper des XLANG-Ablaufplanungsmoduls aus den Nachrichten entfernt.

Informationen über den Nachrichtentyp

Auf der Seite Informationen über den Nachrichtentyp können Sie eine Bezeichnung angeben, die das XLANG-Ablaufplanungsmodul zur Identifizierung von Nachrichten des von Ihnen definierten Typs verwenden soll. Der von Ihnen eingegebene Text wird verwendet, um die richtigen Nachrichten zu identifizieren, die von der Nachrichtenwarteschlange empfangen werden sollen. Wenn Sie für zwei verschiedene Nachrichten denselben Nachrichtentyp auswählen, stellen Sie sicher, dass die Feldnamen, Feldtypen und XPath-Abfragen genau übereinstimmen. Das XLANG-Ablaufplanungsmodul meldet einen Fehler, falls eine Inkonsistenz zwischen Nachrichten desselben Nachrichtentyps an demselben Port besteht. Geben Sie in das Feld Nachrichtentyp auf der Seite Informationen über den Nachrichtentyp eine Bezeichnungszuweisung für die Nachricht ein. Das XLANG-Ablaufplanungsmodul führt auf der Grundlage der von Ihnen bereitgestellten Informationen folgende Verfahren aus:

  • Das XLANG-Ablaufplanungsmodul versucht, die Informationen zum Nachrichtentyp mit der Nachrichtenbezeichnung in der Warteschlange abzugleichen. Wenn der Nachrichtentyp nicht übereinstimmt, wird die Nachricht ignoriert, und das XLANG-Ablaufplanungsmodul hält weiterhin Ausschau nach neuen eingehenden Nachrichten, die übereinstimmen könnten. Auf diese Weise können mehrere Aktionen mehrere Nachrichtentypen aus einer einzelnen Nachrichtenwarteschlange empfangen.

  • Falls die Nachricht in der Warteschlange das XML-Format besitzt, versucht das XLANG-Ablaufplanungsmodul, die Informationen zum Nachrichtentyp mit dem XML-Stammelement der Nachricht in der Warteschlange abzugleichen.

Informationen über die Nachrichtenspezifikation

Auf der Seite Informationen über die Nachrichtenspezifikation können Sie den Pfad zu der gewünschten Nachrichtenspezifikationsdatei (XML-Datei) eingeben oder diese suchen. Wenn es sich bei der ausgewählten Nachrichtenspezifikation um eine Spezifikation handelt, die mit dem BizTalk-Editor erstellt wurde, können Sie Felder zum Datenbereich des XLANG-Ablaufplanes hinzufügen. Sie können Nachrichten anhand der Spezifikation überprüfen, indem Sie das Kontrollkästchen Nachrichten anhand der Spezifikation überprüfen aktivieren. Wenn Sie auf der Seite Informationen über die Nachrichtenspezifikation auf Durchsuchen klicken, wird das Dialogfeld Nach Spezifikation durchsuchen angezeigt. Mithilfe des Dialogfeldes Nach Spezifikation durchsuchen können Sie nach der gewünschten Spezifikation suchen.

Wenn Sie keine Spezifikation ausgewählt haben, klicken Sie auf der Seite Informationen über die Nachrichtenspezifikation auf Erstellen, um den BizTalk-Editor zu öffnen. Wenn Sie bereits eine Spezifikation ausgewählt haben, klicken Sie auf der Seite Informationen über die Nachrichtenspezifikation auf Bearbeiten, um den BizTalk-Editor mit der ausgewählten Spezifikation zu öffnen.

Wenn Sie auf der Seite Informationen über die Nachrichtenspezifikation auf Hinzufügen klicken, wird das Dialogfeld Feldauswahl angezeigt. Sie können im Dialogfeld Feldauswahl in der Struktur Auswahlknoten alle Knoten nach Wunsch erweitern und dann auf das Feld klicken, das Sie hinzufügen möchten. Im Dialogfeld Feldauswahl können Sie den Namen und den Knotenpfad für Felder bearbeiten, die Sie zur Nachrichtenform des ausgewählten Ports hinzufügen möchten. Die Datentypfelder werden angezeigt, können jedoch nicht bearbeitet werden.

Anmerkungen

  • Die Überprüfung ist nur beim Empfang einer Nachricht verfügbar. Beim Senden einer Nachricht wird das Überprüfungskontrollkästchen ignoriert.

  • Wenn Sie in der Struktur Auswahlknoten auf ein Feld klicken, wird der Feldname automatisch zum Feld Feldname hinzugefügt.

  • Wenn Sie in der Struktur Auswahlknoten auf ein Feld klicken, wird der Knotenpfad automatisch zum Feld Knotenpfad hinzugefügt.

  • Die manuelle Bearbeitung eines Knotenpfades ist sehr nützlich, wenn Sie bestimmte Daten aus einem Feld extrahieren möchten. Wenn das Feld beispielsweise ein Array enthält, müssen Sie nicht das gesamte Array abrufen, sondern können ein einzelnes Element aus dem Array abrufen. Es wird jedoch davon abgeraten, den Knotenpfad für die Nachrichtenspezifikation manuell zu bearbeiten.

  • Sie können keinen Knoten auswählen, um ihn zur Liste Nachrichtenfelder hinzuzufügen. Sie können lediglich Felder auswählen. Auf ein Feld kann auch als Endknoten verwiesen werden. Sie können z. B. die Knoten Verkäufer und Adresse nicht auswählen, weil diese Endknoten enthalten. Die Felder Name und Adresse können ausgewählt werden, weil es sich dabei um Felder handelt, die keine zusätzlichen Knoten enthalten.

  • Beim Warten auf den Empfang einer Nachricht aus einer Nachrichtenwarteschlange können einige Probleme (z. B. ungültige XML-Nachrichten oder eine unzureichende Authentifizierung) dazu führen, dass eine Warteschlange für unzustellbare Nachrichten dynamisch erstellt wird. Die Warteschlange für unzustellbare Nachrichten ist spezifisch für eine COM+-Anwendung. Die Warteschlange für unzustellbare Nachrichten erhält den Namen .\private$\Anwendungsname.DeadLetter. Wenn beispielsweise eine Nachricht mit ungültiger XML in der Warteschlange eintrifft und Sie auf der Seite Informationen über die XML-Konvertierung des Assistenten für XML-Kommunikation festgelegt haben, dass das XLANG-Ablaufplanungsmodul auf XML-Nachrichten aus der Warteschlange wartet, werden alle ungültigen XML-Nachrichten nach .\private$\XLANG Scheduler.DeadLetter verschoben.

  • Wenn zwei verschiedene XLANG-Ablaufpläne unterschiedliche Nachrichten aus derselben Nachrichtenwarteschlange empfangen, kann es vorkommen, dass eine Nachricht von der falschen XLANG-Ablaufplaninstanz verarbeitet wird. Verwenden Sie eine Nachrichtenwarteschlange für jeden Nachrichtentyp, der von einer XLANG-Ablaufplaninstanz empfangen wird, um dieses Problem zu vermeiden.

Verwandte Themen

Asynchrone Kommunikation

Synchrone und asynchrone Kommunikation

Synchrone Kommunikation

Verwenden des Methodenkommunikations-Assistenten


Asynchrone Kommunikation

Eine asynchrone Nachricht wird in einer Nachrichtenwarteschlange oder einem BizTalk-Messaging-Kanal platziert, und der XLANG-Ablaufplan setzt den Vorgang fort. Der Ablaufplan wartet nicht auf eine Antwort.

Die einzigen Nachrichten, die für eine asynchrone Kommunikation zur Verfügung stehen, sind XML-Nachrichten. Alle XML-Nachrichten sind verfügbar und können für mehr als einen Port festgelegt werden. Es ist nicht möglich, die synchronen Nachrichtenpaare, die mithilfe des Methodenkommunikations-Assistenten erstellt wurden, zu verwenden.

Asynchrone Nachrichten

Wenn Sie eine asynchrone Kommunikation erstellen, wird auf der Datenseite eine Nachricht erstellt. Die Nachricht entspricht den im Kommunikationsfluss gesendeten bzw. empfangenen Informationen. Die Nachricht enthält erforderliche Systemfelder sowie die von Ihnen gewünschten zusätzlichen Spezifikationsfelder.

Das Nachrichtenschema wird im folgenden Beispiel dargestellt:

Message name
__Sender__   string
Document   string
   Field 1   Data type 1
   Field 2   Data type 2
   Field n   Data type n

Die folgende Abbildung zeigt eine Nachricht mit dem Namen Nachricht_1. Die Systemfelder __Sender__ und Document werden automatisch bereitgestellt und sind in allen asynchronen Nachrichten vorhanden. Diese Nachricht enthält außerdem zwei vom Benutzer ausgewählte Spezifikationsfelder.

Eine Nachricht mit zwei Systemfeldern und zwei vom Benutzer ausgewählten Feldern
Feld 2
Feld 1
Dokument
Datentyp 1
string
Datentyp 2
string
_Sender_
Nachricht_1

Sie können Spezifikationsfelder mithilfe des Dialogfeldes Feldauswahl im Assistenten für XML-Kommunikation hinzufügen. Klicken Sie im Dialogfeld Feldauswahl auf die Struktur Auswahlknoten, um ein Spezifikationsfeld auszuwählen. Wenn Sie auf einen Knoten klicken, wird der Knotenpfad zum Feld Knotenpfad hinzugefügt. Sie müssen einen Endknoten auswählen. Ein Endknoten ist ein Knoten ohne untergeordnete Elemente. In der folgenden Abbildung ist der Knoten Name ein Endknoten, der Knoten Address (Adresse) jedoch nicht.

Ein Knotenpfad wird auch als XPath bezeichnet. Sie können den ausgewählten Knotenpfad verwenden oder zusätzliche Kriterien zum Pfad eingeben. Wenn Sie beispielsweise einen Knoten mit einem Array auswählen, müssen Sie nicht das gesamte Array abrufen, sondern können einen spezifischen Index im Array angeben, der abgerufen werden soll.

Anmerkung

  • Wenn eine XML-Nachricht als Zeichenfolge gesendet bzw. empfangen werden soll, enthält die auf der Datenseite für diese Nachricht erstellte Nachrichtenform ein Feld namens StringData, und Sie können keine Spezifikationsfelder zu dieser Nachricht hinzufügen.

Die folgende Abbildung zeigt das Dialogfeld Feldauswahl.

Klicken Sie zum Vergrößern oder Verkleinern auf die Abbildung.

Weitere Informationen zum Auswählen von Spezifikationsfeldern und zum Verwenden von Knotenpfaden finden Sie in den folgenden Themen:

  • Knotenpfadfelder

  • Verwenden des Assistenten für XML-Kommunikation

  • Senden oder Empfangen asynchroner Nachrichten

  • Erstellen von Spezifikationen

Verwandte Themen

Erstellen von Spezifikationen

Pausierung und Aktivierung

Knotenpfadfelder

Persistenz

Senden oder Empfangen asynchroner Nachrichten

Synchrone und asynchrone Kommunikation

Verwenden des Assistenten für XML-Kommunikation


Kompilieren von XLANG-Ablaufplänen

Wenn Sie eine XLANG-Ablaufplanzeichnung erstellt haben, können Sie die Zeichnung in einen ausführbaren XLANG-Ablaufplan kompilieren. Bevor Sie die Zeichnung kompilieren, stellen Sie sicher, dass der Datenfluss zwischen Nachrichten auf der Datenseite definiert wurde. Ein XLANG-Ablaufplan beschreibt den Geschäftsprozess und die Bindung des Prozesses an eine Implementierungstechnologie.

Der BizTalk-Orchestrierungs-Designer soll so viele nützliche Informationen wie möglich bereitstellen, wenn während des Kompilierungsprozesses ein Problem im XLANG-Ablaufplan entdeckt wird. Wenn der BizTalk-Orchestrierungs-Designer einen Fehler entdeckt, markiert er die Form, die den Fehler enthält, zeigt eine Fehlermeldung an und bricht die Kompilierung des XLANG-Ablaufplanes ab.

Während der Kompilierung überprüft der BizTalk-Orchestrierungs-Designer jede Form im Hinblick auf Vollständigkeit und Richtigkeit. Das XLANG-Ablaufplanungsmodul verarbeitet zunächst die Beginn-Form auf der Geschäftsprozessseite und geht dann in absteigender Reihenfolge rekursiv durch die gesamte Zeichnung. Wenn das XLANG-Ablaufplanungsmodul einen Fehler entdeckt, so tritt dieser Fehler im Allgemeinen auf, wenn der Geschäftsprozess dem Ablauf zu einer Form in einer tief geschachtelten Position folgt. Um diesen Fehler zu melden, erstellt das XLANG-Ablaufplanungsmodul eine entsprechende Fehlermeldung. Wenn das XLANG-Ablaufplanungsmodul dann durch den Stapel nach oben zurückkehrt, hat jede Methode die Möglichkeit, ihre eigene Fehlermeldung mit der ursprünglichen Fehlermeldung zu verketten. Wenn keine der Methoden eine Fehlermeldung mit der ursprünglichen Fehlermeldung verkettet, fügt die oberste Kompilierungsmethode die folgende generische Fehlermeldung hinzu: Der XLANG-Ablaufplan konnte nicht verarbeitet werden.

Der kompilierte XLANG-Ablaufplan enthält einen globalen eindeutigen Bezeichner (GUID), der mit der XLANG-Identität-Eigenschaft der Beginn-Form übereinstimmt. Mit dieser Identifizierung kann eine Version der XLANG-Ablaufplanzeichnung mit dem XLANG-Ablaufplan korreliert werden, der diese generiert hat.

Anmerkung

  • Es wird dringend empfohlen, dass Sie den Abschnitt Verfahrensweise lesen, der aufgabenspezifische Informationen zur Verwendung des BizTalk-Orchestrierungs-Designers zum Erstellen von XLANG-Ablaufplanzeichnungen und ihrer Kompilierung in ausführbare XLANG-Ablaufpläne enthält.

Verwandte Themen

Kompilieren und Debuggen von XLANG-Ablaufplänen

Kompilieren einer XLANG-Ablaufplanzeichnung in einen XLANG-Ablaufplan

Debuggen von XLANG-Ablaufplänen


Debuggen von XLANG-Ablaufplänen

Der XLANG Event Monitor ist ein Tool, mit dem Sie aktive XLANG-Ablaufplaninstanzen überwachen können. Spezifische Informationen zur Verwendung des XLANG Event Monitors finden Sie in der zugehörigen Infodatei Readme.htm. Der XLANG Event Monitor (XLANGMon.exe) und die vom Microsoft BizTalk Server 2000 Setup-Assistent installierte Infodatei befinden sich beide im folgenden Installationsverzeichnis: ..\Programme\Microsoft BizTalk Server\SDK\XLANG Tools.

Der XLANG Event Monitor beinhaltet die folgenden Features:

  • Der XLANG Event Monitor zeigt die Ausführung des XLANG-Ablaufplanungsmoduls in Echtzeit an.

  • Nach der ersten Enumeration der aktiven Ablaufpläne werden Ereignisse vom XLANG Event Monitor überwacht. Mithilfe des XLANG Event Monitors können aktive Instanzen angehalten und gestoppt werden.

  • Der XLANG Event Monitor verfügt über eine MDI-ähnliche Benutzeroberfläche (Multiple-Document Interface - MDI), mit der Sie gleichzeitig Ablaufverfolgungen für mehrere Instanzen anzeigen können.

  • Der XLANG Event Monitor kann gleichzeitig ausgewählte Anwendungen auf mehreren Computern überwachen.

  • Der XLANG Event Monitor stellt separate Aufzeichnungs- und Anzeigefilter bereit.

Verwandte Themen

Kompilieren und Debuggen von XLANG-Ablaufplänen

Kompilieren von XLANG-Ablaufplänen

Überwachen von aktiven XLANG-Ablaufplänen

Fehlermeldungen bei XLANG-Ablaufplänen


Ausführen von XLANG-Ablaufplänen

Bei der Installation des BizTalk-Orchestrierungs-Designers werden mehrere COM+-Anwendungen innerhalb der Microsoft Windows 2000 Komponentendienste installiert und konfiguriert, darunter auch der XLANG Scheduler. Diese Anwendung ist Host einer Standardinstanz des XLANG-Ablaufplanungsmoduls. Alle in den Komponentendiensten erstellten COM+-Anwendungen verfügen im Dialogfeld für die Eigenschaften der Anwendung über eine Registerkarte XLANG. Auf der Registerkarte XLANG können Sie die neue COM+-Anwendung als Host für das XLANG-Ablaufplanungsmodul aktivieren. Die spezifische COM+-Anwendung, in der ein neuer XLANG-Ablaufplan ausgeführt werden soll, kann über die zur Aktivierung einer XLANG-Ablaufplaninstanz verwendete Monikersyntax festgelegt werden.

Das XLANG-Ablaufplanungsmodul steuert die Aktivierung, Ausführung, Pausierung und erneute Aktivierung aktiver XLANG-Ablaufplaninstanzen. Sie können eine kleine Anwendung erstellen, die den Moniker eines XLANG-Ablaufplanes an das XLANG-Ablaufplanungsmodul weitergibt, um einen XLANG-Ablaufplan zu aktivieren. Das XLANG-Ablaufplanungsmodul führt die Aktionen innerhalb des XLANG-Ablaufplanes aus, und setzt den Geschäftsprozess fort, bis eine Pausierung des XLANG-Ablaufplanes erforderlich ist. Das Pausieren eines XLANG-Ablaufplanes tritt dann ein, wenn das XLANG-Ablaufplanungsmodul mit einer Wartezeit von über drei Minuten bis zum Empfang einer Nachricht rechnet. Wenn die Nachricht eintrifft, pausiert das XLANG-Ablaufplanungsmodul die XLANG-Ablaufplaninstanz und fährt mit der Ausführung der Aktionen des Geschäftsprozesses fort, bis der Ablaufplan beendet ist oder das XLANG-Ablaufplanungsmodul auf eine weitere Nachricht warten muss. Sie müssen über eine konfigurierte Persistenzdatenbank verfügen, um die Pausierung zu unterstützen. Als Netzwerkbibliothek wird TCP/IP empfohlen.

Gehen Sie wie folgt vor, um Informationen zu den Komponentendiensten von Microsoft Windows 2000 anzuzeigen:

  1. Zeigen Sie im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Komponentendienste.

  2. Erweitern Sie Komponentendienste in der Konsolenstruktur, erweitern Sie Computer, dann Arbeitsplatz und dann COM+-Anwendungen.

Die Registerkarte XLANG im Dialogfeld Eigenschaften von COM+-Anwendung zeigt folgende Optionen an:

  • Diese Anwendung stellt einen Host für BizTalk-Ablaufplaninstanzen dar. Wenn diese Option aktiviert ist, kann die COM+-Anwendung Instanzen von XLANG-Ablaufplänen aktivieren. Verwenden Sie einen Moniker, der den Namen der Anwendung beinhaltet, um die Aktivierung einer Ablaufplaninstanz an eine bestimmte COM+-Anwendung zu leiten. Aktivieren Sie diese Option, wenn die Anwendung als Host für das XLANG-Ablaufplanungsmodul dienen soll.

  • Persistenz. In diesem Bereich können Sie Microsoft SQL Server konfigurieren, um die Pausierung und Aktivierung langlebiger Geschäftsprozesse zu unterstützen:
    • Über DSN erstellen wird der ODBC-Datenquellname (DSN) für die COM+Komponente erstellt, die als Host für das XLANG-Ablaufplanungsmodul dient. Ein Datei-DSN speichert Informationen zu einer Datenbankverbindung in einer Datei. Die Datei besitzt die Erweiterung DSN und wird standardmäßig im Verzeichnis ..\Programme\Gemeinsame Dateien\ODBC\Data Sources gespeichert. Klicken Sie auf die Schaltfläche DSN erstellen, um den Assistent zum Erstellen neuer Datenquellen zu starten.

    • Über DSN konfigurieren wird der ODBC-Datenquellen-Administrator geöffnet, mit dem die Datenquelle für XLANG-Ablaufpläne in dieser COM+-Anwendung verwaltet wird.

    • Über Tabellen initialisieren werden die erforderlichen Tabellen für die Unterstützung der Persistenz in der von Ihnen definierten SQL Server-Datenbank erstellt.

    Wichtig

    • Der im Dialogfeld Eigenschaften von XLANG Scheduler konfigurierte Datenquellenname muss mit dem Namen der COM+-Anwendung übereinstimmen.
  • Kontrolliertes Herunterfahren. In diesem Bereich können Sie eine gültige Methode zum Beenden der COM+-Anwendungen auswählen, die als Host für XLANG-Ablaufplaninstanzen dient:
    • Über die Option Alle XLANG-Anwendungen werden alle COM+-Anwendungen heruntergefahren, die als Host für aktive XLANG-Ablaufplaninstanzen dienen.

    Anmerkung

    • Wenn Sie eine andere Anwendung als die Standardanwendung ausgewählt haben, wird die Option Diese XLANG-Anwendung angezeigt.
  • Pausierende XLANG-Anwendungen neu starten. In diesem Bereich können Sie pausierende XLANG-Anwendungen verwalten:
    • Über die Option Alle XLANG-Anwendungen werden alle COM+-Anwendungen aktiviert, die als Host für aktive XLANG-Ablaufplaninstanzen dienen, und gegebenenfalls weiter ausgeführt.

Wichtig

  • Klicken Sie nicht mit der rechten Maustaste auf die COM+-Anwendung, um aktive Instanzen eines XLANG-Ablaufplanes herunterzufahren. Dadurch bleiben COM-Komponenten im Speicher geladen, anstatt richtig entladen zu werden. Verwenden Sie stattdessen den Bereich Kontrolliertes Herunterfahren auf der Registerkarte XLANG in den Eigenschaften für die XLANG Scheduler COM+-Anwendung.

Anmerkungen

  • Wenn der Client für Microsoft Windows 2000 Terminaldienste zur Initiierung eines XLANG-Ablaufplanes verwendet wird, muss die COM+-Anwendung, die als Host für das XLANG-Ablaufplanungsmodul dient, als Identität einen gültigen Windows 2000-Benutzer- oder Gruppennamen haben. Die Identität der COM+-Anwendung wird auf der Seite Identität des Dialogfeldes für die Eigenschaften der Anwendung festgelegt. Die Identität kann nicht auf interaktiv festgelegt werden, wenn das XLANG-Ablaufplanungsmodul während einer Sitzung verwendet wird, bei der Terminaldienste als Host dienen.

  • Aufgabenspezifische Informationen zur Ausführung eines XLANG-Ablaufplanes finden Sie unter Ausführen eines XLANG-Ablaufplanes

Dieser Abschnitt behandelt folgende Themen:

  • Monikersyntax

  • Erstellen einer Instanziierungsanwendung


Monikersyntax

Moniker werden verwendet, um neue XLANG-Ablaufplaninstanzen zu erstellen oder um auf eine vorhandene XLANG-Ablaufplaninstanz zu verweisen. In beiden Fällen können Sie auf einen bestimmten Port innerhalb der Ablaufplaninstanz verweisen. Moniker bestimmen, welche COM+-Anwendung als Host des XLANG-Ablaufplanungsmoduls dienen soll.

Zum Erstellen einer neuer Instanz eines XLANG-Ablaufplanes muss ein Moniker für den XLANG-Ablaufplan an die COM+-Anwendung übergeben werden. Die COM+-Anwendung leitet den Moniker zur Auflösung sowie zur Aktivierung der XLANG-Ablaufplaninstanz mit einer Instanz des XLANG-Ablaufplanungsmoduls an den XLANG-Namensdienst weiter. Das folgende Codebeispiel zeigt die allgemeine Syntax für Moniker:

sked://[Hostname][!Gruppenmanager][/Dateipfad][/Portname]

Alle Segmente der Monikersyntax sind optional, abhängig davon, welchen Objekttyp Sie instanziieren möchten. Die folgende Tabelle enthält eine Liste und Beschreibungen der Monikersyntaxsegmente.

Monikersyntaxsegment | Beschreibung | Beispiele
Hostname | Der Hostname des Computers mit dem XLANG-Ablaufplanungsmodul. Dieser wird auch als XLANG-System-Manager bezeichnet. Falls dieses Segment ausgelassen wird, wird der "localhost" als Standardwert verwendet. Bei diesem Namen wird nicht zwischen Groß- und Kleinschreibung unterschieden. | sked:// sked://MeinServer
Gruppenmanager | Der Gruppen-Manager des XLANG-Ablaufplanungsmoduls, mit dem XLANG-Ablaufplaninstanzen verwaltet werden. Der Name des Gruppen-Managers stimmt mit dem Namen der COM+-Anwendung überein, die als XLANG-Host bestimmt ist. Falls dieses Segment ausgelassen wird, wird XLANG Scheduler als Standardwert verwendet. Bei diesem Namen wird zwischen Groß- und Kleinschreibung unterschieden, und er darf Leerzeichen enthalten. | sked:/// sked://AndererServer!/ sked://AndererServer!MeineGruppe/
Dateipfad | Der Pfad zu einer XLANG-Ablaufplanungsdatei (SKX-Datei), die aktiviert werden soll. Bei diesem Wert wird nicht zwischen Groß- und Kleinschreibung unterschieden. | sked://host1!MeineGruppe/C:\basic.skx sked:///C:\basic.skx
Portname | Der Namen eines Ports, der an eine COM-Komponente oder eine Windows-Skriptkomponente in einem XLANG-Ablaufplan gebunden ist. Bei diesem Namen wird zwischen Groß- und Kleinschreibung unterschieden. | sked:///C:\basiccom.skx/portA

Mit der Monikersyntax kann auf eine vorhandene XLANG-Ablaufplaninstanz verwiesen, ein XLANG-Ablaufplan gestartet oder ein Kommunikationskanal mit einem bestimmten Port in der neuen XLANG-Ablaufplaninstanz eingerichtet werden.

Moniker, die auf eine XLANG-Ablaufplaninstanz verweisen, werden vom XLANG-Ablaufplanungsmodul erstellt und durch das Erstellen einer Verbindung zwischen der Port References-Form und Nachrichten, die vom XLANG-Ablaufplan gesendet werden, verfügbar gemacht. Die genaue Form des Portverweises hängt von der Implementierungstechnologie ab, an die der Port gebunden ist, sowie vom Datentyp des Zielnachrichtenfeldes. Ports, die an Message Queuing- oder BizTalk-Messagingdienste gebunden sind, können nur mit Feldern vom Datentyp String verbunden werden. Das Zielfeld enthält den Namen des Warteschlangen- oder Messagingendpunktes, der an den Port in der aktuellen XLANG-Ablaufplaninstanz gebunden ist.

An COM-Komponenten gebundene Ports können mit Feldern vom Datentyp String, Object oder Unknown verknüpft werden. Wenn das Zielfeld den Datentyp String besitzt, wird ein Moniker erstellt, der auf einen Port in der aktuellen XLANG-Ablaufplaninstanz verweist. Dieser Moniker ist dauerhaft. Der Moniker kann mithilfe der GetObject-Funktion aufgelöst werden und bleibt nach einem Systemneustart gültig. Wenn das Zielfeld den Datentyp Object oder Unknown hat, wird ein COM-Verweis auf die Portinstanz an die Nachrichtenform übergeben. Wenn diese Art von Verweis an eine externe Komponente übergeben wird, ist sie nach einem Systemneustart nicht gültig.

Der Moniker mit einem Verweis auf eine aktive XLANG-Ablaufplaninstanz kann aus dem XLANG-Ablaufplaninstanzobjekt abgerufen werden, wie im folgenden Microsoft Visual Basic-Code dargestellt:

Dim oSchedule as IWFWorkflowInstance
Set oSchedule = GetObject("sked:///C:\temp\myschedule.skx")
dim sMoniker as string
sMoniker = oSchedule.FullyQualifiedName

Verwandte Themen

Erstellen einer Instanziierungsanwendung

Ausführen von XLANG-Ablaufplänen


Erstellen einer Instanziierungsanwendung

Eine Instanziierungsanwendung übergibt mithilfe der GetObject-COM-Funktion einen Moniker für die abgeschlossene XLANG-Ablaufplandatei an das XLANG-Ablaufplanungsmodul. Der folgende Microsoft Visual Basic-Code zeigt, wie dies geschieht:

Dim objExecute As object
Dim strURL as string

strURL = "sked:///c:\temp\myschedule.skx"

' This enables the XLANG Scheduler Engine to execute the XLANG schedule.
Set objExecute = GetObject(strURL)

Wenn Sie im Moniker keinen Port angegeben haben, können Sie mit der Port-Eigenschaft des Objekts, das durch die GetObject-Funktion zurückgegeben wird, einen Verweis auf einen Port abrufen, der an eine COM-Komponente gebunden ist. Ebenso können Sie mit der FullPortName-Eigenschaft den vollständigen, dauerhaften Namen eines Ports abrufen, der an eine Implementierungstechnologie gebunden ist.

Der folgende Code zeigt, wie ein Proxy für einen COM- oder Skriptport abgerufen wird. Dieses Codebeispiel ist eine Fortsetzung des vorherigen Codebeispiels.

Dim oPort as Object
Set oPort = objExecute.Port("SchedulePortName")
Call oPort.ComponentMethodName(arg1,arg2,...argN)

Anmerkung

  • Wenn der Port an ein COM-Objekt gebunden ist, das keine duale Schnittstelle unterstützt, muss die Variable oPort mit der entsprechenden Klasse deklariert werden.

Verwandte Themen

Monikersyntax

Ausführen von XLANG-Ablaufplänen


Verwalten des Sitzungsstatus

Auf der Seite Erweiterte Porteigenschaften des Bindungs-Assistenten für COM-Komponenten können Sie einen Statusverwaltungswert für die Persistenzebene auswählen, die von der COM-Komponente unterstützt wird. Wählen Sie im Bereich für die Statusverwaltungsunterstützung eine der folgenden Optionen aus:

  • Behält den Status nicht bei. Diese Option gibt an, dass das XLANG-Ablaufplanungsmodul die Komponenteninstanz beendet, wenn diese pausiert wird. Wenn Sie diese Einstellung auswählen, erstellt das XLANG-Ablaufplanungsmodul bei Bedarf eine neue Komponenteninstanz, wenn der Ablaufplan aktiviert wird.

  • Behält den Status bei, unterstützt aber keine Persistenz. Diese Option gibt an, dass das XLANG-Ablaufplanungsmodul die Ausführung der Komponenteninstanz nicht beenden soll. Falls bei der Pausierung der Anwendung ein Systemfehler auftritt, geht jeder in dieser Komponente beibehaltene Status verloren.

  • Behält den Status bei und unterstützt Persistenz. Diese Option gibt an, dass das XLANG-Ablaufplanungsmodul die Komponenteninstanz aus dem Speicher entfernt und sie dann im Speicher wiederherstellt, indem es IPersistStream oder IPersistStreamInit für die Komponente während der Pausierung und dann erneut bei der Aktivierung aufruft.

Verwandtes Thema

Instanzenverwaltung


Aktualisieren von XLANG-Ablaufplänen

Es gibt zwei Möglichkeiten, einen XLANG-Ablaufplan zu aktualisieren. Sie können den ursprünglichen XLANG-Ablaufplan überschreiben oder einen neuen XLANG-Ablaufplan hinzufügen, der parallel mit dem ursprünglichen XLANG-Ablaufplan ausgeführt wird.

Wenn Sie den ursprünglichen XLANG-Ablaufplan überschreiben möchten, erstellen Sie mit dem BizTalk-Orchestrierungs-Designer eine neue XLANG-Ablaufplanzeichnung, und kompilieren Sie dann die XLANG-Ablaufplanzeichnung als XLANG-Ablaufplan mit demselben Namen wie dem des ursprünglichen XLANG-Ablaufplanes. Die XLANG-Ablaufplanzeichnung wird als SKV-Datei gespeichert. Dabei handelt es sich um eine angepasste Version des Microsoft Visio 2000-Dateiformats. Die XLANG-Ablaufplanzeichnung kann dann in einen XLANG-Ablaufplan kompiliert werden. Dabei handelt es sich um eine XML-strukturierte SKX-Textdatei, die vom XLANG-Ablaufplanungsmodul verstanden wird. Kopieren Sie die neue SKX-Datei über die ursprüngliche SKX-Datei, um den ursprünglichen XLANG-Ablaufplan zu aktualisieren.

Wenn Sie einen neuen XLANG-Ablaufplan hinzufügen möchten, der parallel mit dem ursprünglichen XLANG-Ablaufplan ausgeführt werden soll, erstellen Sie mit dem BizTalk-Orchestrierungs-Designer eine neue XLANG-Ablaufplanzeichnung, und kompilieren Sie dann die XLANG-Ablaufplanzeichnung als XLANG-Ablaufplan mit einem neuen Namen. Sie müssen den Aktivierungsmechanismus der XLANG-Ablaufplaninstanz ändern, damit dieser auf die neue und nicht auf die alte SKX-Datei verweist. Auf diese Weise stellen Sie sicher, dass der neue XLANG-Ablaufplan ordnungsgemäß aktiviert wird. Wenn Sie diesen Vorgang ausgeführt haben, werden Instanzen des neuen XLANG-Ablaufplanes von neuen XLANG-Ablaufplananfragen erstellt.

Da alle XLANG-Ablaufpläne und deren Komponenten im Allgemeinen auf der Basis einzelner Instanzen arbeiten, werden XLANG-Ablaufplaninstanzen, die bereits mit der Ausführung des ursprünglichen Ablaufplanes begonnen haben, bis zum Abschluss fortgesetzt. Dies gilt auch für XLANG-Ablaufplaninstanzen, die persistent gespeichert wurden, weil der Quellcode des ursprünglichen Ablaufplanes gespeichert wurde. In diesem Szenario folgt der Ausführungspfad weiter dem ursprünglichen Geschäftsprozess, und neue XLANG-Ablaufplananfragen erstellen Instanzen des neuen XLANG-Ablaufplanes.

Anmerkung

  • Wenn ein XLANG-Ablaufplan ein Objekt mit einer geänderten Schnittstelle verwendet, sollten Sie die XLANG-Ablaufplanzeichnung (die SKV-Datei) in den BizTalk-Orchestrierungs-Designer laden und eine neue SKX-Datei kompilieren. Auf diese Weise werden die Bindungsinformationen in der SKX-Datei aktualisiert und so die Synchronisation mit der Typbibliothek der Komponente aktiviert.


Konfigurieren der BizTalk-Messagingdienste

Microsoft BizTalk Server 2000 stellt für den Austausch von Dokumenten zwischen Handelspartnern und zwischen Anwendungen innerhalb eines Unternehmens zwei Konfigurationsmethoden für die BizTalk-Messagingdienste bereit. Sie können entweder den BizTalk-Messaging-Manager, eine grafische Benutzeroberfläche (User Interface, UI), verwenden oder direkt auf das BizTalk-Messaging-Konfigurationsobjektmodell zugreifen.

Mithilfe des BizTalk-Messaging-Managers oder des BizTalk-Messaging-Konfigurationsobjektmodells können Sie Messagingports und Kanäle zum Verwalten des Datenaustauschs erstellen. Sie können ebenfalls Dokumentdefinitionen, Umschläge und Organisationen erstellen, mit denen entweder Messagingports und Kanäle erstellt werden oder Verteilerlisten, bei denen es sich um Gruppen von Messagingports handelt.

Anmerkung

  • Sie müssen zu einem Benutzerkonto in der Gruppe BizTalk Server-Administratoren gehören, um Objekte entweder mithilfe des BizTalk-Messaging-Managers oder des BizTalk-Konfigurationsobjektmodells zu erstellen oder um Skripts und Anwendungen auszuführen, die auf solche Objekte zugreifen oder sie erstellen. Die Gruppe BizTalk Server-Administratoren wird bei der Installation von BizTalk Server 2000 erstellt. Bei Bedarf können weitere Benutzer zu dieser Gruppe hinzugefügt werden. Weitere Informationen zum Hinzufügen eines Benutzerkontos finden Sie unter Hinzufügen von Benutzern zur Gruppe "BizTalk Server-Administratoren".

Folgende Themen werden in diesem Abschnitt behandelt:

  • Verwenden des BizTalk-Messaging-Managers

  • Zugreifen auf das BizTalk-Messaging-Konfigurationsobjektmodell


Verwenden des BizTalk-Messaging-Managers

Der BizTalk-Messaging-Manager ist eine grafische Benutzeroberfläche (User Interface, UI), mit der Sie den Austausch von Geschäftsdokumenten durch das Konfigurieren der BizTalk-Messagingdienste verwalten können. Die BizTalk-Messagingdienste können auch programmgesteuert konfiguriert werden. Weitere Informationen finden Sie unter Zugreifen auf das BizTalk-Messaging-Konfigurationsobjektmodell.

Vorsicht

  • Verwenden Sie den BizTalk-Messaging-Manager, um die BizTalk-Messagingdienste vor dem Verarbeiten von Dokumenten zu konfigurieren. Das Zugreifen auf und Ändern von Objekten, die möglicherweise während der Dokumentverarbeitung verwendet werden, kann zu unerwarteten Ergebnissen führen.

Dokumente können zwischen Handelspartnern und Anwendungen innerhalb eines Unternehmens ausgetauscht werden. Der BizTalk-Messaging-Manager ist sowohl lokal auf dem Computer verfügbar, auf dem BizTalk Server 2000 installiert ist, als auch als Clientanwendung über ein Netzwerk. Dies ermöglicht Systemadministratoren die Sicherheit und zentrale Steuerung des Servers beizubehalten, während Remotebenutzer auf den BizTalk-Messaging-Manager zugreifen können.

Die Microsoft BizTalk Server 2000-Hilfe stellt Informationen zum Erstellen und Verwalten von Kanälen, Messagingports, Dokumentdefinitionen, Umschlägen und Organisationen und zum Verwenden von Verteilerlisten bereit.

BizTalk-Messaging-Manager-Objekte

Die folgende Abbildung zeigt die Beziehung zwischen Objekten, die mithilfe des BizTalk-Messaging-Managers erstellt werden können.

BizTalk-Messaging-Manager - Übersicht
Anwendung (Eigene Organisation)
Dokument-
definition
(eingehend)
Messagingport
(Ziel)
Kanal
(Quelle)
Kanal
Umschlag
Verteilerliste
Messaging-
ports
Dokument-
definition
(ausgehend)
Organisation (Handelspartner)
Eingehendes
Dokument
Ausgehendes
Dokument

Die folgende Zusammenfassung stellt einen Kurzüberblick über die Objekte bereit, die mithilfe des BizTalk-Messaging-Managers erstellt werden können. Die Beziehung zwischen den Objekten wird ebenfalls erläutert. Detaillierte Informationen zu jedem Objekt finden Sie, wenn Sie auf die Verknüpfung am Ende der Beschreibung klicken, um zum Hilfethema für das entsprechende Objekt zu gelangen.

Kanäle

Kanäle sind die primären Objekte im BizTalk-Messaging-Manager. Der Zweck der anderen Objekte des BizTalk-Messaging-Managers ist entweder das Erstellen von Kanälen oder das Unterstützen von Kanaloperationen. Kanäle identifizieren die Dokumentenquelle, die eine Organisation, eine Anwendung innerhalb Ihres Unternehmens oder ein XLANG-Ablaufplan sein kann. Kanäle können mithilfe von Dokumentdefinitionen ebenfalls eingehende und ausgehende Dokumente identifizieren. Weitere Informationen finden Sie unter Grundlegendes zu Kanälen.

Messagingports

Messagingports identifizieren ein Ziel für die Dokumente, die von einem Kanal verarbeitet werden. Das Ziel kann eine Organisation, eine Anwendung innerhalb Ihres Unternehmens oder ein XLANG-Ablaufplan sein. Ein Messagingport gibt eine Zieladresse an, an die die Dokumente gesendet werden. Weiterhin gibt er an, wie die Dokumente zu dieser Adresse übertragen werden und wie Dokumente gegebenenfalls gesichert und mit einem Umschlag versehen werden. Weiter Informationen finden Sie unter Grundlegendes zu Messagingports.

Organisationen

Organisationen stellen andere Handelspartner dar, mit welchen Dokumente ausgetauscht werden können. Ein bestimmter Organisationstyp, die eigene Organisation, stellt Ihr Unternehmen dar. Sie können Anwendungen für die eigene Organisation erstellen, die den internen Anwendungen in Ihrem Unternehmen entsprechen. Organisationen und Anwendungen dienen als Quelle für einen Kanal oder als Ziel für einen Messagingport. Weitere Informationen finden Sie unter Grundlegendes zu Organisationen.

Dokumentdefinitionen

Eine Dokumentdefinition stellt einen bestimmten Typ eines Dokuments dar, das von BizTalk Server 2000 verarbeitet wird. Eine Dokumentdefinition stellt einen Zeiger auf eine Spezifikation bereit. Spezifikationen definieren die Struktur, den Typ und die Version eines Dokuments. Kanäle legen eine eingehende und eine ausgehende Dokumentdefinition fest, um anzugeben, welche Dokumente der Server verarbeitet. Eine Dokumentdefinition kann für eine beliebige Anzahl von Kanälen verwendet werden. Weitere Informationen finden Sie unter Grundlegendes zu Dokumentdefinitionen.

Umschläge

Umschläge stellen für BizTalk Server 2000 die Informationen bereit, die der Server zum Öffnen eingehender oder Erstellen ausgehender Austauschvorgänge benötigt. Umschläge können innerhalb eines Messagingports ausgewählt werden, um den Server beim Erstellen ausgehender Austauschvorgänge zu steuern. Von einem Messagingport unabhängige Umschläge können von BizTalk Server 2000 zum Öffnen eingehender Austauschvorgänge verwendet werden. Weiter Informationen finden Sie unter Grundlegendes zu Umschlägen.

Verteilerlisten

Verteilerlisten sind Gruppen von Messagingports, mit denen das gleiche Dokument an eine Gruppe verschiedener Handelspartner oder an interne Anwendungen gesendet werden kann. Wie für einen einzelnen Messagingport müssen Sie auch für eine Verteilerliste mindestens einen Kanal erstellen. Weitere Informationen finden Sie unter Grundlegendes zu Verteilerlisten.

Anmerkungen

  • Objekte können entweder mithilfe des BizTalk-Messaging-Managers erstellt werden oder programmgesteuert mithilfe des BizTalk-Messaging-Konfigurationsobjektmodells. Weitere Informationen finden Sie unter Zugreifen auf das BizTalk-Messaging-Konfigurationsobjektmodell.

  • Die mithilfe des BizTalk-Messaging-Managers erstellten Objekte können auch Objekte verwenden, die mit anderen Komponenten von BizTalk Server 2000 erstellt werden. Kanäle verwenden Zuordnungen, die mithilfe des BizTalk-Mappers erstellt werden. Dokumentdefinitionen verwenden Dokumentspezifikationen. Umschläge verwenden Umschlagspezifikationen. Spezifikationen können mithilfe des BizTalk-Editors erstellt werden.

  • Hilfe zu bestimmten Aufgaben finden Sie unter Verfahrensweise.

  • Allgemeine Hintergrundinformationen finden Sie unter Grundbegriffe.


Verfahrensweise

Dieser Abschnitt stellt aufgabenspezifische Informationen zum Verwenden des BizTalk-Messaging-Managers bereit. Es wird dringend empfohlen, dass Sie den Abschnitt Grundbegriffe lesen, um die Beziehung zwischen Objekten vollständig zu verstehen, die mithilfe des BizTalk-Messaging-Managers erstellt werden können.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Erstellen und Verwalten von Kanälen

  • Erstellen und Verwalten von Messagingports

  • Erstellen und Verwalten von Organisationen

  • Erstellen und Verwalten von Dokumentdefinitionen

  • Erstellen und Verwalten von Umschlägen

  • Verwenden von Verteilerlisten


Erstellen und Verwalten von Kanälen

Dieser Abschnitt stellt aufgabenspezifische Informationen zum Erstellen und Verwalten von Kanälen bereit. Es wird dringend empfohlen, das Thema Grundlegendes zu Kanälen im Abschnitt "Grundbegriffe" zu lesen, um Kanäle vollständig zu verstehen.

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Erstellen von Kanälen

  • Suchen nach Kanälen

  • Bearbeiten von Kanälen

  • Löschen von Kanälen

  • Festlegen von Kanaleigenschaften


Erstellen von Kanälen

Sie müssen einen Messagingport oder eine Verteilerliste erstellen, bevor Sie einen Kanal erstellen können. Weitere Informationen finden Sie unter Erstellen von Messagingports oder Erstellen von Verteilerlisten.

  1. Klicken Sie im BizTalk-Messaging-Manager im Bereich Nach anderen Elementen suchen auf Messagingports oder Verteilerlisten, und klicken Sie dann auf Jetzt suchen.

  2. Klicken Sie in der Liste Messagingportname auf den Messagingport, für den Sie einen Kanal erstellen möchten.

    Oder

    Klicken Sie in der Liste Verteilerlistenname auf die Verteilerliste, für die Sie einen Kanal erstellen möchten.

  3. Zeigen Sie im BizTalk-Messaging-Manager im Menü Datei auf Neu, zeigen Sie auf Kanal, und führen Sie dann einen der folgenden Schritte aus:
    • Um einen Kanal von einer Organisation zu erstellen, klicken Sie auf Von einer Organisation.

    • Um einen Kanal von einer Anwendung zu erstellen, klicken Sie auf Von einer Anwendung.

    Der Kanal-Assistent wird geöffnet.

  4. Legen Sie auf der Seite Allgemeine Informationen die Eigenschaften fest, und klicken Sie auf Weiter.

    Weitere Informationen finden Sie unter Festlegen von allgemeinen Kanalinformationseigenschaften.

  5. Führen Sie einen der folgenden Schritte aus:
    • Wenn Sie einen Kanal von einer Organisation erstellen, legen Sie die Eigenschaften auf der Seite Quellorganisation fest, und klicken Sie dann auf Weiter. Weitere Informationen finden Sie unter Festlegen von Eigenschaften für die Quellorganisation.

    • Wenn Sie einen Kanal von einer Anwendung erstellen, legen Sie die Eigenschaften auf der Seite Quellanwendung fest, und klicken Sie dann auf Weiter. Weitere Informationen finden Sie unter Festlegen von Eigenschaften für die Quellanwendung.
  6. Legen Sie auf der Seite Eingehendes Dokument die Eigenschaften fest, und klicken Sie dann auf Weiter.

    Weitere Informationen finden Sie unter Festlegen von Eigenschaften für eingehende Dokumente.

  7. Legen Sie auf der Seite Ausgehendes Dokument die Eigenschaften fest, und klicken Sie dann auf Weiter.

    Weitere Informationen finden Sie unter Festlegen von Eigenschaften für ausgehende Dokumente.

  8. Legen Sie auf der Seite Dokumentprotokollierung die Eigenschaften fest, und klicken Sie dann auf Weiter.

    Weitere Informationen finden Sie unter Festlegen von Eigenschaften für die Dokumentprotokollierung.

  9. Legen Sie auf der Seite Erweiterte Konfiguration die Eigenschaften fest.

    Weitere Informationen finden Sie unter Festlegen von erweiterten Konfigurationseigenschaften.

  10. Nachdem Sie alle Kanaleigenschaften festgelegt haben, klicken Sie auf der Seite Erweiterte Konfiguration auf Fertig stellen, um den Kanal-Assistenten zu schließen.

Anmerkungen

  • Sie können beim Benennen eines Kanals den reservierten Systemnamen Reliable Message Acknowledgement Channel nicht verwenden.

  • Sie können dieses Verfahren verwenden, um entweder einen Standardkanal oder einen Empfangskanal zu erstellen. Die Verfahren in diesem Abschnitt enthalten Anmerkungen, die erläutern, welche Kanaleigenschaften beim Erstellen von Empfangskanälen nicht zur Verfügung stehen.

  • Wenn Sie einen Messagingport und einen Kanal für die Pass-Through-Versendung von Daten erstellen, können Sie nur das Dienstfenster und die Features für Wiederholungsanzahl und Intervall des Kanals sowie die Transportfeatures des ihm zugeordneten Messagingports verwenden. Sie können nicht die Überprüfung von codierung oder Verschlüsselung, Filterung, Dokumentüberwachung oder die Zuordnungsfeatures des Kanals verwenden.

  • Beim Speichern eines Kanals, der auf eine Zuordnung verweist, die sich außerhalb der lokalen Domäne befindet, wird möglicherweise ein Fehler angezeigt. Wenn eine Fehlermeldung angezeigt wird, downloaden und konfigurieren Sie das Dienstprogramm WinHTTP Proxy Configuration. Gehen Sie zum Downloaden des Dienstprogramms zur Microsoft MSDN-Website (msdn.microsoft.com/downloads/default.asp), und suchen Sie die Seite "WinHTTP Proxy Configuration Utility". Diese Seite befindet sich im Kapitel zu XML im Buch Web Development.

Verwandte Themen

Löschen von Kanälen

Bearbeiten von Kanälen

Suchen nach Kanälen

Festlegen von Kanaleigenschaften

Grundlegendes zu Kanälen


Suchen nach Kanälen

  1. Klicken Sie im BizTalk-Messaging-Manager im Bereich Nach anderen Elementen suchen auf Kanäle.

  2. Um nach allen Kanälen zu suchen, löschen Sie alle Suchkriterien, und klicken Sie dann auf Jetzt suchen.

  3. Führen Sie eine oder mehrere der folgenden Aktionen aus:
    • Um nach Kanälen mit einem bestimmten Namen zu suchen, geben Sie im Bereich Nach Kanälen suchen im Feld Kanalname den Namen des gesuchten Kanals ein, und klicken Sie dann auf Jetzt suchen. Sie können einen unvollständigen Namen eingeben, und die Suche gibt alle möglichen Namen zurück, die mit dem unvollständigen Namen übereinstimmen.

    • Um nach Kanälen aus einem bestimmten Quelltyp zu suchen, klicken Sie in der Dropdownliste Quelle auf einen Quelltyp, und klicken Sie dann auf Jetzt suchen.

    • Um nach Kanälen zu suchen, die einem bestimmten Messagingport oder einer bestimmten Verteilerliste zugeordnet sind, geben Sie im Feld Messagingport oder Verteilerliste zugeordnet den Namen des Messagingports oder der Verteilerliste ein, und klicken Sie dann auf Jetzt suchen. Sie können einen unvollständigen Namen eingeben, und die Suche gibt alle möglichen Namen zurück, die mit dem unvollständigen Namen übereinstimmen.

    • Um nach Kanälen zu suchen, die eine bestimmte Dokumentdefinition verwenden, geben Sie im Feld Dokumentdefinition verwenden den Namen einer Dokumentdefinition ein, und klicken Sie auf Jetzt suchen.

    • Sie können einen unvollständigen Namen eingeben, und die Suche gibt alle möglichen Namen zurück, die mit dem unvollständigen Namen übereinstimmen.

Anmerkungen

  • Sie können mehr als ein Suchkriterium festlegen, bevor Sie auf Jetzt suchen klicken.

  • Klicken Sie auf Suche löschen, um die Suchkriterien und Suchergebnisse zu löschen.

  • Sie können ferner nach Kanälen suchen, die einem bestimmten Messagingport oder einer bestimmten Verteilerliste zugeordnet sind, indem Sie mit der rechten Maustaste auf den Messagingport oder die Verteilerliste klicken und anschließend auf Kanäle suchen klicken.

  • Wenn nach einer großen Anzahl von Objekten gesucht werden soll, dauert es möglicherweise mehrere Minuten, bis alle Objekte zurückgegeben werden. Mithilfe von Auswahlkriterien können Sie die bei einer Suche zurückgegebenen Objekte eingrenzen.

  • Die Standardanzahl von Elementen, die bei einer Suche zurückgegeben werden, ist 500. Diese Anzahl können Sie anpassen. Weitere Informationen finden Sie unter Festlegen von Serververbindungsoptionen.

  • In den Suchkriterien können die folgenden Platzhalterzeichen verwendet werden.
    Platzhalter | Beschreibung | Beispiel
    % Eine Zeichenfolge aus null oder mehr Zeichen. Der Eintrag %open% findet alle Namen, die das Wort "open" enthalten.
    _ (Unterstrich) | Beliebiges einzelnes Zeichen. | Der Eintrag _ean findet alle Namen mit vier Buchstaben, die auf "ean" enden (Dean, Sean usw.).
    [ ] Beliebiges einzelnes Zeichen im angegebenen Bereich ([a-f]) oder in der angegebenen Menge ([abcdef]). Der Eintrag [C-P]arsen findet alle Namen, die auf "arsen" enden und mit einem beliebigen einzelnen Zeichen zwischen C und P beginnen, z. B.: Carsen, Larsen usw.
    [^] Beliebiges einzelnes Zeichen, das sich nicht im angegebenen Bereich ([^a-f]) oder in der angegebenen Menge ([^abcdef]) befindet. Der Eintrag de[^s]% findet alle Namen, die mit "de" beginnen und deren dritter Buchstabe nicht "s" ist.

Verwandte Themen

Löschen von Kanälen

Bearbeiten von Kanälen

Festlegen von Kanaleigenschaften

Grundlegendes zu Kanälen


Bearbeiten von Kanälen

  1. Klicken Sie im BizTalk-Messaging-Manager in der Liste Kanalname auf den Kanal, den Sie bearbeiten möchten.

    Weitere Informationen zum Suchen nach Kanälen finden Sie unter Suchen nach Kanälen.

  2. Klicken Sie im Menü Datei auf Bearbeiten.

    Der Kanal-Assistent wird geöffnet.

  3. Bearbeiten Sie auf der Seite Allgemeine Informationen die entsprechenden Eigenschaften.

    Weitere Informationen finden Sie unter Festlegen von allgemeinen Kanalinformationseigenschaften.

    Nachdem Sie die Eigenschaften auf einer beliebigen Seite bearbeitet haben, können Sie auf Fertig stellen klicken, um den Kanal-Assistenten zu schließen, oder auf Weiter, um weitere Kanaleigenschaften zu bearbeiten.

  4. Führen Sie einen der folgenden Schritte aus:
    • Wenn Sie einen Kanal von einer Organisation bearbeiten, bearbeiten Sie die entsprechenden Eigenschaften auf der Seite Quellorganisation. Weitere Informationen finden Sie unter Festlegen von Eigenschaften für die Quellorganisation.

    • Wenn Sie einen Kanal von einer Anwendung bearbeiten, bearbeiten Sie die entsprechenden Eigenschaften auf der Seite Quellanwendung. Weitere Informationen finden Sie unter Festlegen von Eigenschaften für die Quellanwendung.
  5. Bearbeiten Sie auf der Seite Eingehendes Dokument die entsprechenden Eigenschaften.

    Weitere Informationen finden Sie unter Festlegen von Eigenschaften für eingehende Dokumente.

  6. Bearbeiten Sie auf der Seite Ausgehendes Dokument die entsprechenden Eigenschaften.

    Weitere Informationen finden Sie unter Festlegen von Eigenschaften für ausgehende Dokumente.

  7. Bearbeiten Sie auf der Seite Dokumentprotokollierung die entsprechenden Eigenschaften.

    Weitere Informationen finden Sie unter Festlegen von Eigenschaften für die Dokumentprotokollierung.

  8. Bearbeiten Sie auf der Seite Erweiterte Konfiguration die entsprechenden Eigenschaften.

    Weitere Informationen finden Sie unter Festlegen von erweiterten Konfigurationseigenschaften.

Anmerkungen

  • Sie können beim Benennen eines Kanals den reservierten Systemnamen Reliable Message Acknowledgement Channel nicht verwenden.

  • Beim Speichern eines Kanals, der auf eine Zuordnung verweist, die sich außerhalb der lokalen Domäne befindet, wird möglicherweise ein Fehler angezeigt. Wenn eine Fehlermeldung angezeigt wird, downloaden und konfigurieren Sie das Dienstprogramm WinHTTP-Proxy Configuration. Gehen Sie zum Downloaden des Dienstprogramms zur Microsoft MSDN-Website (msdn.microsoft.com/downloads/default.asp), und suchen Sie die Seite "WinHTTP Proxy Configuration Utility". Diese Seite befindet sich im Kapitel zu XML im Buch Web Development.

Verwandte Themen

Erstellen von Kanälen

Löschen von Kanälen

Suchen nach Kanälen

Festlegen von Kanaleigenschaften

Grundlegendes zu Kanälen


Löschen von Kanälen

  1. Klicken Sie im BizTalk-Messaging-Manager in der Liste Kanalname auf den Kanal, den Sie löschen möchten.

    Weitere Informationen zum Suchen nach Kanälen finden Sie unter Suchen nach Kanälen.

  2. Klicken Sie im Menü Datei auf Löschen.

Anmerkung

  • Sie können den Empfangskanal erst löschen, nachdem alle Kanäle, die auf ihn verweisen, gelöscht wurden.

Verwandte Themen

Erstellen von Kanälen

Bearbeiten von Kanälen

Suchen nach Kanälen

Festlegen von Kanaleigenschaften

Grundlegendes zu Kanälen


Festlegen von Kanaleigenschaften

Dieser Abschnitt stellt aufgabenspezifische Informationen zum Konfigurieren der Eigenschaften eines Kanals bereit. Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Festlegen von allgemeinen Kanalinformationseigenschaften

  • Festlegen von Eigenschaften für die Quellorganisation

  • Festlegen von Eigenschaften für die Quellanwendung

  • Festlegen von Eigenschaften für eingehende Dokumente

  • Festlegen von Eigenschaften für ausgehende Dokumente

  • Festlegen von Eigenschaften für die Dokumentprotokollierung

  • Festlegen von erweiterten Konfigurationseigenschaften

  • Auswählen einer Quellorganisation

  • Auswählen eines Empfangskanals

  • Auswählen einer eingehenden Dokumentdefinition

  • Auswählen eines Zertifikats zum Überprüfen der Entschlüsselung eingehender Dokumente

  • Auswählen eines Zertifikats zum Überprüfen der Signatur eingehender Dokumente

  • Auswählen einer ausgehenden Dokumentdefinition

  • Auswählen einer Zuordnung

  • Auswählen eines Zertifikats für die ausgehende Signatur

  • Außerkraftsetzen von Messagingportstandards

  • Außerkraftsetzen von Verteilerlistenstandards

  • Festlegen der Überwachung für Eigenschaften von eingehenden Dokumenten

  • Festlegen von Eigenschaften für die Kanalfilterung


Festlegen von allgemeinen Kanalinformationseigenschaften

  1. Geben Sie auf der Seite Allgemeine Informationen des Kanal-Assistenten im Feld Name den Namen des Kanals ein.

  2. Geben Sie im Feld Kommentare ggf. Kommentare für den Kanal ein.

  3. Wenn Sie einen Empfangskanal erstellen möchten, aktivieren Sie das Kontrollkästchen Dies ist ein Empfangskanal.

Wenn Sie einen neuen Kanal erstellen, klicken Sie auf Weiter. Anweisungen zum Ausführen des folgenden Schrittes finden Sie unter Erstellen von Kanälen.

Wenn Sie einen vorhandenen Kanal bearbeiten, klicken Sie auf Weiter. Anweisungen zum Ausführen des folgenden Schrittes finden Sie unter Bearbeiten von Kanälen. Klicken Sie auf Fertig stellen, wenn Sie die Änderungen abgeschlossen haben.

Anmerkungen

  • Ein Empfangskanal ist ein besonderer Kanaltyp, der zum Senden einer Empfangsbestätigung an den Absender eines von BizTalk Server 2000 empfangenen Dokuments verwendet wird. Weitere Informationen zu Empfangsbestätigungen finden Sie unter Grundlegendes zu Empfangsbestätigungen.

  • Sie können keinen Empfangskanal für einen offenen Messagingport oder eine Verteilerliste erstellen.

Verwandte Themen

Erstellen von Kanälen

Bearbeiten von Kanälen

Festlegen von Kanaleigenschaften


Festlegen von Eigenschaften für die Quellorganisation

  1. Führen Sie auf der Seite Quellorganisation des Kanal-Assistenten einen der folgenden Schritte aus:
    • Klicken Sie auf Offene Quelle, um einen offenen Kanal zu erstellen (die Quelle wird jetzt entweder von Daten im Dokument oder in Parametern, die zusammen mit dem Dokument versendet werden, bereitgestellt), und klicken Sie dann auf Weiter.

      Weitere Informationen zum Versenden von Dokumenten finden Sie unter Submitting.

    • Klicken Sie auf Organisation, um eine Handelspartnerorganisation als Quelle zuzuweisen, und fahren Sie dann mit Schritt 2 fort.
  2. Klicken Sie im Bereich Organisation auf Durchsuchen.

    Das Dialogfeld Organisation auswählen wird angezeigt.

  3. Klicken Sie auf eine Organisation, und klicken Sie dann auf OK.

    Weitere Informationen finden Sie unter Auswählen einer Quellorganisation.

  4. Wenn Sie das standardmäßige Organisationskennzeichen für die Quellorganisation außer Kraft setzen möchten, klicken Sie in der Liste Organisationskennzeichen auf ein anderes Kennzeichen.

  5. Wenn Sie, wie im Messagingport angegeben, eine Empfangsbestätigung vom Ziel benötigen, aktivieren Sie das Kontrollkästchen Erwartete Empfangsbestätigung, und geben Sie im Feld Empfangsbestätigungsintervall in Minuten einen Wert ein, oder klicken Sie auf den Pfeil nach oben oder den Pfeil nach unten, um den Wert zu erhöhen oder zu verringern.

    Der Standardwert in Minuten ist 120. Weitere Informationen zu Empfangsbestätigungen finden Sie unter Grundlegendes zu Empfangsbestätigungen.

  6. Wenn Sie eine Empfangsbestätigung für die Quelle generieren möchten, aktivieren Sie das Kontrollkästchen Empfangsbestätigung generieren, klicken Sie auf Durchsuchen, und wählen Sie dann einen Empfangskanal aus.

    Weitere Informationen finden Sie unter Auswählen eines Empfangskanals.

Wenn Sie einen neuen Kanal erstellen, klicken Sie auf Weiter. Anweisungen zum Fertigstellen des folgenden Schrittes finden Sie unter Erstellen von Kanälen.

Wenn Sie einen vorhandenen Kanal bearbeiten, klicken Sie auf Weiter. Anweisungen zum Fertigstellen des folgenden Schrittes finden Sie unter Bearbeiten von Kanälen. Klicken Sie auf Fertig stellen, wenn Sie die Änderungen abgeschlossen haben.

Anmerkungen

  • Wenn Sie ein Quellorganisationskennzeichen für die Verwendung mit X12-Umschlägen auswählen, sollten Sie nicht das Organisationskennzeichen mit dem Namen Organisation auswählen oder ein anderes Kennzeichen, dessen Qualifizierer mehr als 2 Zeichen oder dessen Wert mehr als 15 Zeichen umfasst.

  • Wenn Sie ein Quellorganisationskennzeichen für die Verwendung mit EDIFACT-Umschlägen auswählen, sollten Sie nicht das Organisationskennzeichen mit dem Namen Organisation auswählen oder ein anderes Kennzeichen, dessen Qualifizierer mehr als 4 Zeichen oder dessen Wert mehr als 35 Zeichen umfasst.

  • Wenn Sie einen Kanal von einer bestimmten Organisation bearbeiten, steht die Option Offene Quelle nicht zur Verfügung, und Sie können die Quellorganisation nicht ändern. Wenn Sie einen offenen Kanal bearbeiten, steht die Option Organisation nicht zur Verfügung.

  • Wenn Sie einen Empfangskanal erstellen oder bearbeiten, stehen die Eigenschaften Erwartete Empfangsbestätigung und Empfangsbestätigung generieren nicht zur Verfügung.

Verwandte Themen

Erstellen von Kanälen

Bearbeiten von Kanälen

Festlegen von Kanaleigenschaften

Grundlegendes zu Empfangsbestätigungen


Festlegen von Eigenschaften für die Quellanwendung

  1. Führen Sie auf der Seite Quellanwendung des Kanal-Assistenten einen der folgenden Schritte aus:
    • Klicken Sie auf XLANG-Ablaufplan, um festzulegen, dass es sich bei der Quelle um einen XLANG-Ablaufplan handelt, und klicken Sie dann auf Weiter.

      Sie sollten diese Option nicht auswählen, wenn Sie einen Kanal für einen offenen Messagingport erstellen. Weitere Informationen zum Integrieren der BizTalk-Messagingdienste und der BizTalk-Orchestrierungsdienste finden Sie unter Integrieren der BizTalk-Dienste.

    • Klicken Sie auf Anwendung, um eine Anwendung der eigenen Organisation als Quelle zuzuweisen, und fahren Sie dann mit Schritt 2 fort.
  2. Klicken Sie in der Liste Name auf eine Anwendung.

  3. Wenn Sie das standardmäßige Organisationskennzeichen für die eigene Organisation außer Kraft setzen möchten, klicken Sie in der Liste Organisationskennzeichen auf ein anderes Kennzeichen.

  4. Wenn Sie eine Empfangsbestätigung vom Ziel erhalten möchten, aktivieren Sie das Kontrollkästchen Erwartete Empfangsbestätigung, und geben Sie im Feld Empfangsbestätigungsintervall in Minuten einen Wert ein, oder klicken Sie auf den Pfeil nach oben oder den Pfeil nach unten, um den Wert zu erhöhen oder zu verringern.

    Der Standardwert in Minuten ist 120. Weitere Informationen zu Empfangsbestätigungen finden Sie unter Grundlegendes zu Empfangsbestätigungen.

  5. Wenn Sie eine Empfangsbestätigung für die Quelle generieren möchten, aktivieren Sie das Kontrollkästchen Empfangsbestätigung generieren, klicken Sie auf Durchsuchen, und wählen Sie dann einen Empfangskanal aus.

    Weitere Informationen finden Sie unter Auswählen eines Empfangskanals.

Wenn Sie einen neuen Kanal erstellen, klicken Sie auf Weiter. Anweisungen zum Fertigstellen des folgenden Schrittes finden Sie unter Erstellen von Kanälen.

Wenn Sie einen vorhandenen Kanal bearbeiten, klicken Sie auf Weiter. Anweisungen zum Fertigstellen des folgenden Schrittes finden Sie unter Bearbeiten von Kanälen. Klicken Sie auf Fertig stellen, wenn Sie die Änderungen abgeschlossen haben.

Anmerkungen

  • Ein XLANG-Ablaufplan kann mithilfe des BizTalk-Orchestrierungs-Designers erstellt werden.

  • Beim Erstellen oder Bearbeiten eines Empfangskanals oder eines Kanals, für den ein XLANG-Ablaufplan als Quelle angegeben ist, stehen die Eigenschaften Erwartete Empfangsbestätigung oder Empfangsbestätigung generieren nicht zur Verfügung.

Verwandte Themen

Erstellen von Kanälen

Bearbeiten von Kanälen

Integrieren der BizTalk-Dienste

Festlegen von Kanaleigenschaften

Grundlegendes zu Empfangsbestätigungen


Festlegen von Eigenschaften für eingehende Dokumente

  1. Klicken Sie auf der Seite Eingehendes Dokument des Kanal-Assistenten rechts neben dem Feld Definitionsname des eingehenden Dokuments auf Durchsuchen.

    Das Dialogfeld Dokumentdefinition auswählen wird angezeigt.

  2. Klicken Sie auf eine Dokumentdefinition, und klicken Sie dann auf OK.

    Weitere Informationen finden Sie unter Auswählen einer eingehenden Dokumentdefinition.

  3. Wenn Sie die Entschlüsselung des eingehenden Dokuments überprüfen möchten, aktivieren Sie das Kontrollkästchen Entschlüsselungszertifikat des eingehenden Dokuments überprüfen. Klicken Sie anschließend rechts neben dem Feld Zertifikat zum Überprüfen der Entschlüsselung auf Durchsuchen.

    Das Dialogfeld Zertifikat zum Überprüfen der Entschlüsselung auswählen wird angezeigt.

  4. Wählen Sie ein Zertifikat aus.

    Weitere Informationen finden Sie unter Auswählen eines Zertifikats zum Überprüfen der Entschlüsselung eingehender Dokumente.

  5. Wenn Sie die digitale Signatur des eingehenden Dokuments überprüfen möchten, aktivieren Sie das Kontrollkästchen Signaturzertifikat des eingehenden Dokuments überprüfen. Klicken Sie anschließend rechts neben dem Feld Zertifikat zum Überprüfen der Signatur auf Durchsuchen.

    Das Dialogfeld Zertifikat zum Überprüfen der Signatur auswählen wird angezeigt.

  6. Wählen Sie ein Signaturzertifikat aus.

    Weitere Informationen finden Sie unter Auswählen eines Zertifikats zum Überprüfen der Signatur eingehender Dokumente.

  7. Wenn Sie Felder im eingehenden Dokument überwachen möchten, aktivieren Sie das Kontrollkästchen Eingehendes Dokument überwachen, und klicken Sie dann auf Überwachen.

    Das Dialogfeld Eingehende Dokumente überwachen wird angezeigt.

  8. Legen Sie die Überwachungseigenschaften fest.

    Weitere Informationen finden Sie unter Festlegen der Überwachung für Eigenschaften von eingehenden Dokumenten.

  9. Wenn Sie einen Kanalfilterausdruck für das eingehende Dokument erstellen möchten, aktivieren Sie das Kontrollkästchen Eingehendes Dokument filtern, und klicken Sie dann auf Filtern.

    Das Dialogfeld Kanalfilterausdrücke wird angezeigt.

  10. Legen Sie die Filtereigenschaften fest.

    Weitere Informationen finden Sie unter Festlegen von Eigenschaften für die Kanalfilterung.

Wenn Sie einen neuen Kanal erstellen, klicken Sie auf Weiter. Anweisungen zum Fertigstellen des folgenden Schrittes finden Sie unter Erstellen von Kanälen.

Wenn Sie einen vorhandenen Kanal bearbeiten, klicken Sie auf Weiter. Anweisungen zum Fertigstellen des folgenden Schrittes finden Sie unter Bearbeiten von Kanälen. Klicken Sie auf Fertig stellen, wenn Sie die Änderungen abgeschlossen haben.

Anmerkungen

  • Beim Erstellen eines Empfangskanals ist sowohl die eingehende als auch die ausgehende Dokumentdefinition standardmäßig auf die BizTalk-Standardempfangsbestätigung festgelegt, und sie kann nicht mithilfe einer Zuordnung umgewandelt werden. Um die ausgehende Empfangsbestätigung in ein anderes Format umzuwandeln, müssen Sie im Empfangskanal eine eingehende Dokumentdefinition erstellen und auswählen, die auf die Standardempfangsbestätigungs-Spezifikation im WebDAV-Repository verweist. Darüber hinaus müssen Sie im Empfangskanal eine ausgehende Dokumentdefinition erstellen und auswählen, die auf eine Spezifikation mit dem gewünschten Format der ausgehenden Empfangsbestätigung verweist, und eine Zuordnung im Empfangskanal angeben, um die Formate umzuwandeln. Weitere Informationen finden Sie unter Grundlegendes zu Empfangsbestätigungen.

  • Beim Erstellen eines Empfangskanals, der die BizTalk-Standardempfangsbestätigung für die eingehende Dokumentdefinition verwendet, stehen die Überwachungs- und Filtereigenschaften nicht zur Verfügung.

  • Wenn Sie einen Kanal für einen offenen Messagingport erstellen und die Zielinformationen im Dokument zur Verfügung gestellt werden, muss die eingehende Dokumentdefinition für diesen Kanal auf eine Spezifikation verweisen, die korrekt konfiguriert ist. Weitere Informationen zum Konfigurieren einer Dokumentspezifikation zum Verarbeiten von Dokumenten für einen offenen Messagingport finden Sie unter Festlegen von Wörterbucheigenschaften.

Verwandte Themen

Erstellen von Kanälen

Bearbeiten von Kanälen

Festlegen von Kanaleigenschaften


Festlegen von Eigenschaften für ausgehende Dokumente

  1. Klicken Sie auf der Seite Ausgehendes Dokument des Kanal-Assistenten rechts neben dem Feld Definitionsname des ausgehenden Dokuments auf Durchsuchen.

    Das Dialogfeld Dokumentdefinition auswählen wird angezeigt.

  2. Klicken Sie auf eine Dokumentdefinition, und klicken Sie dann auf OK.

    Weitere Informationen finden Sie unter Auswählen einer ausgehenden Dokumentdefinition.

  3. Wenn Sie eine Zuordnung angeben möchten, aktivieren Sie das Kontrollkästchen Eingehendes Dokument ausgehendem Dokument zuordnen. Klicken Sie anschließend rechts neben dem Feld Verweis zuordnen auf Durchsuchen.

    Das Dialogfeld Eine Zuordnung aus dem WebDAV-Repository auswählen wird angezeigt.

  4. Wählen Sie eine Zuordnungsspezifikation aus.

    Weitere Informationen finden Sie unter Auswählen einer Zuordnung.

  5. Wenn Sie das ausgehende Dokument digital signieren möchten, aktivieren Sie das Kontrollkästchen Ausgehendes Dokument signieren. Klicken Sie anschließend rechts neben dem Feld Signaturzertifikat auf Durchsuchen.

    Wenn Sie einen Kanal für einen Messagingport erstellen, für den die Eigenschaft Signatur auf der Seite Sicherheitsinformationen auf S/MIME festgelegt ist, ist das Kontrollkästchen Ausgehendes Dokument signieren automatisch aktiviert.

    Das Dialogfeld Signaturzertifikat auswählen wird angezeigt.

  6. Wählen Sie ein Signaturzertifikat aus.

    Weitere Informationen finden Sie unter Auswählen eines Zertifikats für die ausgehende Signatur.

Wenn Sie einen neuen Kanal erstellen, klicken Sie auf Weiter. Anweisungen zum Fertigstellen des folgenden Schrittes finden Sie unter Erstellen von Kanälen.

Wenn Sie einen vorhandenen Kanal bearbeiten, klicken Sie auf Weiter. Anweisungen zum Fertigstellen des folgenden Schrittes finden Sie unter Bearbeiten von Kanälen. Klicken Sie auf Fertig stellen, wenn Sie die Änderungen abgeschlossen haben.

Wichtig

  • Das Format des in einem Messagingport angegebenen Umschlags muss mit dem Format des enthaltenen ausgehenden Dokuments oder der ausgehenden Dokumente übereinstimmen. Das Dokumentformat wird durch die Spezifikation bestimmt, auf die die ausgehende Dokumentdefinition eines zugeordneten Kanals verweist. Wenn Sie z. B. einen Umschlag in einem X12-Format für einen Messagingport wählen, müssen Sie für den Kanal eine ausgehende Dokumentdefinition auswählen, die auf eine X12-Spezifikation verweist.

  • Wenn Sie einen Messagingport als offenen Messagingport deklarieren, sollten Sie keine Kanäle für den Messagingport erstellen, die über eine ausgehende Dokumentdefinition mit einer X12- oder EDIFACT-Spezifikation verfügen. Um einen X12- oder EDIFACT-Umschlag zu erstellen, muss der Server über Organisationskennzeichen für Ziel und Quelle verfügen. Ein offener Messagingport gibt kein Zielorganisationskennzeichen an. Darüber hinaus müssen die Dokumente für einen offenen Messagingport die Zieladresse im Dokument aufweisen, X12- und EDIFACT-Dokumente enthalten diese Information jedoch nicht.

  • Beim ersten Öffnen eines beliebigen WebDAV-Repository-Dialogfeldes wird das WebDAV-Repository auf dem lokalen Server ausgewählt, auch wenn der BizTalk-Messaging-Manager mit einer Datenbank auf einem Remoteserver verbunden ist. Wenn Sie zu einem WebDAV-Repository auf einem Remoteserver wechseln, wird standardmäßig dieser Server verwendet, bis Sie ein neues WebDAV-Repository auswählen. Der Standardserver für alle WebDAV-Repository-Dialogfelder ist der letzte Server, zu dem eine Verbindung hergestellt wurde.

Anmerkungen

  • Beim Erstellen eines Empfangskanals ist sowohl die eingehende als auch die ausgehende Dokumentdefinition standardmäßig auf die BizTalk-Standardempfangsbestätigung festgelegt, und sie kann nicht mithilfe einer Zuordnung umgewandelt werden. Um für eine ausgehende Empfangsbestätigung ein anderes Format zu verwenden, müssen Sie eine eingehende Dokumentdefinition erstellen und auswählen, die auf die Standardempfangsbestätigungs-Spezifikation im WebDAV-Repository verweist. Darüber hinaus müssen Sie eine ausgehende Dokumentdefinition erstellen, die auf eine Spezifikation mit dem gewünschten Format für die ausgehende Empfangsbestätigung verweist, sowie eine Zuordnung, die das Format der Empfangsbestätigung umwandelt. Weitere Informationen zu Empfangsbestätigungen finden Sie unter Grundlegendes zu Empfangsbestätigungen.

  • Eine Zuordnung wird verwendet, um das eingehende Dokumentformat in das ausgehende Dokumentformat umzuwandeln. Wenn der Spezifikationsverweis des eingehenden Dokuments dem des ausgehenden Dokuments entspricht, ist keine Zuordnung erforderlich. Standardmäßig ist das Kontrollkästchen Eingehendes Dokument ausgehendem Dokument zuordnen nicht aktiviert. Zuordnungen können mithilfe des BizTalk-Mappers erstellt werden. Weitere Informationen zu Zuordnungen finden Sie unter Zuordnen von Daten.

Verwandte Themen

Erstellen von Kanälen

Bearbeiten von Kanälen

Festlegen von Kanaleigenschaften

Grundlegendes zu Empfangsbestätigungen


Festlegen von Eigenschaften für die Dokumentprotokollierung

  1. Aktivieren Sie auf der Seite Dokumentprotokollierung des Kanal-Assistenten im Bereich Eingehendes Dokument protokollieren die entsprechenden Kontrollkästchen:
    • Im systemeigenen Format. Speichert eingehende Dokumente für den Kanal im ursprünglichen Format. Dies ist die Standardeinstellung.

    • Im XML-Format. Speichert eingehende Dokumente für den Kanal im XML-Format.
  2. Aktivieren Sie im Bereich Ausgehendes Dokument protokollieren die entsprechenden Kontrollkästchen:
    • Im systemeigenen Format. Speichert ausgehende Dokumente für den Kanal im ursprünglichen Format.

    • Im XML-Format. Speichert ausgehende Dokumente für den Kanal im XML-Format.

Wenn Sie einen neuen Kanal erstellen, klicken Sie auf Weiter. Anweisungen zum Fertigstellen des folgenden Schrittes finden Sie unter Erstellen von Kanälen.

Wenn Sie einen vorhandenen Kanal bearbeiten, klicken Sie auf Weiter. Anweisungen zum Fertigstellen des folgenden Schrittes finden Sie unter Bearbeiten von Kanälen. Klicken Sie auf Fertig stellen, wenn Sie die Änderungen abgeschlossen haben.

Anmerkungen

  • Bei Dokumenten, die Protokollierung verwenden, existiert eine Größenbeschränkung, bei deren Überschreiten die Leistung von BizTalk Server erheblich beeinträchtigt wird. Weitere Informationen zur Größenbeschränkung finden Sie unter Austausch- und Dokumentgrößenbeschränkung.

  • BizTalk Server 2000 übersetzt nicht auf XML basierende eingehende Dokumente aus ihrem ursprünglichen, systemeigenen Format für die Verarbeitung in ein XML-Format und ausgehende Dokumente aus einem XML-Format in das erforderliche systemeigene Format des Zieles.

Verwandte Themen

Erstellen von Kanälen

Bearbeiten von Kanälen

Festlegen von Kanaleigenschaften


Festlegen von erweiterten Konfigurationseigenschaften

  1. Geben Sie auf der Seite Erweiterte Konfiguration des Kanal-Assistenten beim Erstellen eines Kanals für einen Messagingport, der ein X12- oder EDIFACT-Umschlagformat angibt, im Feld Gruppenkontrollnummer einen Wert ungleich Null ein.

  2. Geben Sie im Bereich Wiederholungsoptionen im Feld Anzahl von Wiederholungen die Zahl der Versuche ein, die der Server zum erneuten Senden des Dokuments unternehmen soll, wenn keine Empfangsbestätigung empfangen wurde, und geben Sie im Feld Intervall (Minuten) die Anzahl von Minuten zwischen den Wiederholungsversuchen ein.

    Weitere Informationen zu Empfangsbestätigungen finden Sie unter Grundlegendes zu Empfangsbestätigungen.

  3. Wenn Sie die Transport- oder Umschlagskomponenteneinstellungen für einen Messagingport oder eine Verteilerliste außer Kraft setzen möchten, klicken Sie auf Erweitert.
    • Wenn Sie einen Kanal für einen Messagingport erstellen oder bearbeiten, wird das Dialogfeld Messagingportstandards außer Kraft setzen angezeigt. Weitere Informationen finden Sie unter Außerkraftsetzen von Messagingportstandards.

    • Wenn Sie einen Kanal für eine Verteilerliste erstellen oder bearbeiten, wird das Dialogfeld Verteilerlistenstandards außer Kraft setzen angezeigt. Weitere Informationen finden Sie unter Außerkraftsetzen von Verteilerlistenstandards.

Wenn Sie einen neuen Kanal erstellen, klicken Sie auf Weiter. Anweisungen zum Fertigstellen des folgenden Schrittes finden Sie unter Erstellen von Kanälen.

Wenn Sie einen vorhandenen Kanal bearbeiten, klicken Sie auf Weiter. Anweisungen zum Fertigstellen des folgenden Schrittes finden Sie unter Bearbeiten von Kanälen. Klicken Sie auf Fertig stellen, wenn Sie die Änderungen abgeschlossen haben.

Verwandte Themen

Erstellen von Kanälen

Bearbeiten von Kanälen

Wiederholungswarteschlange

Festlegen von Kanaleigenschaften

Grundlegendes zu Empfangsbestätigungen


Auswählen einer Quellorganisation

  1. Klicken Sie auf der Seite Quellorganisation des Kanal-Assistenten rechts neben dem Feld Name auf Durchsuchen.

    Das Dialogfeld Organisation auswählen wird angezeigt.

  2. Klicken Sie in der Liste Verfügbare Organisationen auf eine Organisation und dann auf OK.

Weitere Informationen zum Festlegen von Quellorganisationseigenschaften finden Sie unter Festlegen von Eigenschaften für die Quellorganisation.

Verwandte Themen

Erstellen von Kanälen

Bearbeiten von Kanälen

Festlegen von Kanaleigenschaften

Festlegen von Eigenschaften für die Quellorganisation


Auswählen eines Empfangskanals

  1. Aktivieren Sie auf der Seite Quellanwendung oder Quellorganisation des Kanal-Assistenten das Kontrollkästchen Empfangsbestätigung generieren, und klicken Sie dann auf Durchsuchen.

    Das Dialogfeld Empfangskanal auswählen wird angezeigt.

  2. Klicken Sie in der Liste Verfügbare Empfangskanäle auf einen Empfangskanal, und klicken Sie dann auf OK.

Weitere Informationen zum Festlegen von Quellorganisationseigenschaften finden Sie unter Festlegen von Eigenschaften für die Quellorganisation.

Weitere Informationen zum Festlegen von Quellanwendungseigenschaften finden Sie unter Festlegen von Eigenschaften für die Quellanwendung.

Anmerkung

  • Die Liste Verfügbare Empfangskanäle zeigt nur Empfangskanäle an, die Messagingports zugeordnet sind, deren Ziel identisch mit der Quelle für den Kanal ist, den Sie erstellen. Wenn BizTalk Server 2000 einen Kanal mit angegebenem Empfangskanal aufruft, gibt der Server der ursprünglichen Quelle des Dokuments mithilfe des angegebenen Empfangskanals eine Empfangsbestätigung zurück. Weitere Informationen zu Empfangsbestätigungen finden Sie unter Grundlegendes zu Empfangsbestätigungen.

Verwandte Themen

Erstellen von Kanälen

Bearbeiten von Kanälen

Festlegen von Kanaleigenschaften

Festlegen von Eigenschaften für die Quellanwendung

Festlegen von Eigenschaften für die Quellorganisation

Grundlegendes zu Empfangsbestätigungen


Auswählen einer eingehenden Dokumentdefinition

  1. Klicken Sie auf der Seite Eingehendes Dokument des Kanal-Assistenten rechts neben dem Feld Definitionsname des eingehenden Dokuments auf Durchsuchen.

    Das Dialogfeld Dokumentdefinition auswählen wird angezeigt.

  2. Klicken Sie in der Liste Verfügbare Dokumentdefinitionen auf eine Dokumentdefinition, und klicken Sie dann auf OK.

Informationen zum Festlegen von weiteren Eigenschaften für eingehende Dokumente finden Sie unter Festlegen von Eigenschaften für eingehende Dokumente.

Anmerkung

  • Beim Erstellen eines Empfangskanals ist sowohl die eingehende als auch die ausgehende Dokumentdefinition standardmäßig auf die BizTalk-Standardempfangsbestätigung festgelegt, und sie kann nicht mithilfe einer Zuordnung umgewandelt werden. Um für eine ausgehende Empfangsbestätigung ein anderes Format zu verwenden, müssen Sie eine eingehende Dokumentdefinition erstellen und auswählen, die auf die Standardempfangsbestätigungs-Spezifikation im WebDAV-Repository verweist. Darüber hinaus müssen Sie eine ausgehende Dokumentdefinition erstellen, die auf eine Spezifikation mit dem gewünschten Format für die ausgehende Empfangsbestätigung verweist, sowie eine Zuordnung, die das Format der Empfangsbestätigung umwandelt. Weitere Informationen zu Empfangsbestätigungen finden Sie unter Grundlegendes zu Empfangsbestätigungen.

Verwandte Themen

Erstellen von Kanälen

Erstellen von Dokumentdefinitionen

Bearbeiten von Kanälen

Festlegen von Kanaleigenschaften

Festlegen von Eigenschaften für eingehende Dokumente

Grundlegendes zu Empfangsbestätigungen


Auswählen eines Zertifikats zum Überprüfen der Entschlüsselung eingehender Dokumente

  1. Aktivieren Sie auf der Seite Eingehendes Dokument des Kanal-Assistenten das Kontrollkästchen Entschlüsselungszertifikat des eingehenden Dokuments überprüfen.

  2. Klicken Sie anschließend rechts neben dem Feld Zertifikat zum Überprüfen der Entschlüsselung auf Durchsuchen.

    Das Dialogfeld Zertifikat zum Überprüfen der Entschlüsselung auswählen wird angezeigt.

  3. Klicken Sie in der Liste Zertifikatsname auf einen Zertifikatsnamen, und klicken Sie dann auf OK.

Weitere Informationen zum Festlegen von Eigenschaften für eingehende Dokumente finden Sie unter Festlegen von Eigenschaften für eingehende Dokumente.

Anmerkungen

  • Alle Zertifikate werden im Informationsspeicher des lokalen Computers gespeichert. Um Zertifikate für die S/MIME-Komponenten mithilfe des BizTalk-Messaging-Managers zu konfigurieren, müssen Sie über ein Benutzerkonto in der Windows 2000-Gruppe Administratoren verfügen, und die BizTalk-Messagingdienste müssen als lokales Systemkonto oder als Benutzerkonto in der Windows 2000-Gruppe Administratoren ausgeführt werden.

  • Dokumente werden beim Empfangen durch BizTalk Server entschlüsselt, so dass der Server die erforderlichen Daten erhält, um den entsprechenden Kanal zu identifizieren. Das Zertifikat, das Sie im Kanal angeben, überprüft, ob die Entschlüsselung korrekt durchgeführt wurde.

  • Alle Zertifikate müssen eindeutige Namen aufweisen. Wenn mehrere Zertifikate den gleichen Namen aufweisen, kann nur eines von ihnen ausgewählt werden. Sobald eines der Zertifikate ausgewählt wird, werden andere Zertifikate mit dem gleichen Namen nicht mehr in der Liste angezeigt.

    Weitere Informationen zu Zertifikaten finden Sie unter Zertifikate - Übersicht.

Verwandte Themen

Erstellen von Kanälen

Bearbeiten von Kanälen

Festlegen von Kanaleigenschaften

Festlegen von Eigenschaften für eingehende Dokumente


Auswählen eines Zertifikats zum Überprüfen der Signatur eingehender Dokumente

  1. Aktivieren Sie auf der Seite Eingehendes Dokument des Kanal-Assistenten das Kontrollkästchen Signaturzertifikat des eingehenden Dokuments überprüfen.

  2. Klicken Sie anschließend rechts neben dem Feld Zertifikat zum Überprüfen der Signatur auf Durchsuchen.

    Das Dialogfeld Zertifikat zum Überprüfen der Signatur auswählen wird angezeigt.

  3. Klicken Sie in der Liste Zertifikatsname auf einen Zertifikatsnamen, und klicken Sie dann auf OK.

Weitere Informationen zum Festlegen von Eigenschaften für eingehende Dokumente finden Sie unter Festlegen von Eigenschaften für eingehende Dokumente.

Anmerkungen

  • Alle Zertifikate werden im Informationsspeicher des lokalen Computers gespeichert. Um Zertifikate für die S/MIME-Komponenten mithilfe des BizTalk-Messaging-Managers zu konfigurieren, müssen Sie über ein Benutzerkonto in der Windows 2000-Gruppe Administratoren verfügen, und die BizTalk-Messagingdienste müssen als lokales Systemkonto oder als Benutzerkonto in der Windows 2000-Gruppe Administratoren ausgeführt werden.

  • Alle Zertifikate müssen eindeutige Namen aufweisen. Wenn mehrere Zertifikate den gleichen Namen aufweisen, kann nur eines von diesen ausgewählt werden. Sobald eines der Zertifikate ausgewählt wird, werden andere Zertifikate mit dem gleichen Namen nicht mehr in der Liste angezeigt.

    Weitere Informationen zu Zertifikaten finden Sie unter Zertifikate - Übersicht.

Verwandte Themen

Erstellen von Kanälen

Bearbeiten von Kanälen

Festlegen von Kanaleigenschaften

Festlegen von Eigenschaften für eingehende Dokumente


Auswählen einer ausgehenden Dokumentdefinition

  1. Klicken Sie auf der Seite Ausgehendes Dokument des Kanal-Assistenten rechts neben dem Feld Definitionsname des ausgehenden Dokuments auf Durchsuchen.

    Das Dialogfeld Dokumentdefinition auswählen wird angezeigt.

  2. Klicken Sie in der Liste Verfügbare Dokumentdefinitionen auf eine Dokumentdefinition, und klicken Sie dann auf OK.

Weitere Informationen zum Festlegen von Eigenschaften für ausgehende Dokumente finden Sie unter Festlegen von Eigenschaften für ausgehende Dokumente.

Anmerkung

  • Beim Erstellen eines Empfangskanals ist sowohl die eingehende als auch die ausgehende Dokumentdefinition standardmäßig auf die BizTalk-Standardempfangsbestätigung festgelegt, und sie kann nicht mithilfe einer Zuordnung umgewandelt werden. Um für eine ausgehende Empfangsbestätigung ein anderes Format zu verwenden, müssen Sie eine eingehende Dokumentdefinition erstellen und auswählen, die auf die Standardempfangsbestätigungs-Spezifikation im WebDAV-Repository verweist. Darüber hinaus müssen Sie eine ausgehende Dokumentdefinition erstellen, die auf eine Spezifikation mit dem gewünschten Format für die ausgehende Empfangsbestätigung verweist, sowie eine Zuordnung, die das Format der Empfangsbestätigung umwandelt. Weitere Informationen zu Empfangsbestätigungen finden Sie unter Grundlegendes zu Empfangsbestätigungen.

Verwandte Themen

Erstellen von Kanälen

Erstellen von Dokumentdefinitionen

Bearbeiten von Kanälen

Festlegen von Kanaleigenschaften

Festlegen von Eigenschaften für ausgehende Dokumente

Grundlegendes zu Empfangsbestätigungen


Auswählen einer Zuordnung

  1. Aktivieren Sie auf der Seite Ausgehendes Dokument des Kanal-Assistenten das Kontrollkästchen Eingehendes Dokument ausgehendem Dokument zuordnen, und klicken Sie dann rechts neben dem Feld Verweis zuordnen auf Durchsuchen.

    Das Dialogfeld Eine Zuordnung aus dem WebDAV-Repository auswählen wird angezeigt.

  2. Führen Sie im Feld Server eine der folgenden Aktionen aus, wenn Sie den Server wechseln möchten:
    • Klicken Sie auf einen Server in der Liste.

    • Geben Sie den Namen eines Servers ein, und drücken Sie die EINGABETASTE.
  3. Doppelklicken Sie auf den Ordner, der die gewünschte Zuordnung enthält, klicken Sie auf die Zuordnung, und klicken Sie dann auf Öffnen.

Weitere Informationen zum Festlegen von Eigenschaften für ausgehende Dokumente finden Sie unter Festlegen von Eigenschaften für ausgehende Dokumente.

Wichtig

  • Beim ersten Öffnen eines beliebigen WebDAV-Repository-Dialogfeldes wird das WebDAV-Repository auf dem lokalen Server ausgewählt, auch wenn der BizTalk-Messaging-Manager mit einer Datenbank auf einem Remoteserver verbunden ist. Wenn Sie zu einem WebDAV-Repository auf einem Remoteserver wechseln, wird standardmäßig dieser Server verwendet, bis Sie ein neues WebDAV-Repository auswählen. Der Standardserver für alle WebDAV-Repository-Dialogfelder ist der letzte Server, zu dem eine Verbindung hergestellt wurde.

Anmerkungen

  • Wenn Sie http://localhost als Server auswählen, wandelt der BizTalk-Messaging-Manager diesen Wert automatisch in den Namen des lokalen Computers um.

  • Beim Speichern eines Kanals, der auf eine Zuordnung verweist, die sich außerhalb der lokalen Domäne befindet, wird möglicherweise ein Fehler angezeigt. Wenn eine Fehlermeldung angezeigt wird, downloaden und konfigurieren Sie das Dienstprogramm WinHTTP Proxy Configuration. Gehen Sie zum Downloaden des Dienstprogramms zur Microsoft MSDN-Website (msdn.microsoft.com/downloads/default.asp), und suchen Sie die Seite "WinHTTP Proxy Configuration Utility". Diese Seite befindet sich im Kapitel zu XML im Buch Web Development.

Verwandte Themen

Erstellen von Kanälen

Bearbeiten von Kanälen

Zuordnen von Daten

Festlegen von Kanaleigenschaften

Festlegen von Eigenschaften für ausgehende Dokumente


Auswählen eines Zertifikats für die ausgehende Signatur

  1. Aktivieren Sie auf der Seite Ausgehendes Dokument des Kanal-Assistenten das Kontrollkästchen Ausgehendes Dokument signieren, und klicken Sie dann rechts neben dem Feld Signaturzertifikat auf Durchsuchen.

    Das Dialogfeld Signaturzertifikat auswählen wird angezeigt.

  2. Klicken Sie in der Liste Zertifikatsname auf einen Zertifikatsnamen, und klicken Sie dann auf OK.

Weitere Informationen zum Festlegen von Eigenschaften für ausgehende Dokumente finden Sie unter Festlegen von Eigenschaften für ausgehende Dokumente.

Anmerkungen

  • Alle Zertifikate werden im Informationsspeicher des lokalen Computers gespeichert. Um Zertifikate für die S/MIME-Komponenten mithilfe des BizTalk-Messaging-Managers zu konfigurieren, müssen Sie über ein Benutzerkonto in der Windows 2000-Gruppe Administratoren verfügen, und die BizTalk-Messagingdienste müssen als lokales Systemkonto oder als Benutzerkonto in der Windows 2000-Gruppe Administratoren ausgeführt werden.

  • Alle Zertifikate müssen eindeutige Namen aufweisen. Wenn mehrere Zertifikate den gleichen Namen aufweisen, kann nur eines von diesen ausgewählt werden. Sobald eines der Zertifikate ausgewählt wird, werden andere Zertifikate mit dem gleichen Namen nicht mehr in der Liste angezeigt.

    Weitere Informationen zu Zertifikaten finden Sie unter Zertifikate - Übersicht.

Verwandte Themen

Erstellen von Kanälen

Bearbeiten von Kanälen

Festlegen von Kanaleigenschaften

Festlegen von Eigenschaften für ausgehende Dokumente


Außerkraftsetzen von Messagingportstandards

  1. Klicken Sie auf der Seite Erweiterte Konfiguration des Kanal-Assistenten auf Erweitert.

    Wenn Sie einen Kanal für einen Messagingport erstellen oder bearbeiten, wird das Dialogfeld Messagingportstandards außer Kraft setzen angezeigt.

  2. Klicken Sie auf der Registerkarte Primärer Transport auf Eigenschaften.

    Das Dialogfeld BizTalk Komponente-Eigenschaften wird angezeigt.

  3. Ändern Sie die Eigenschaften der Transportkomponente, die Sie außer Kraft setzen möchten, und klicken Sie dann auf OK.

  4. Wenn der Messagingport über einen Umschlag verfügt, dessen Einstellungen Sie außer Kraft setzen möchten, klicken Sie auf die Registerkarte Umschlag, und klicken Sie dann auf Eigenschaften.

    Das Dialogfeld BizTalk Komponente-Eigenschaften wird angezeigt.

  5. Ändern Sie die Eigenschaften der Umschlagkomponente, die Sie außer Kraft setzen möchten, und klicken Sie dann auf OK.

Weitere Informationen zum Festlegen von erweiterten Eigenschaften finden Sie unter Festlegen von erweiterten Konfigurationseigenschaften.

Wichtig

  • Das Außerkraftsetzen der Transport- und Umschlageigenschaften für einen Messagingport ist ein erweitertes Feature. Wenn Sie sich mit den Eigenschaften der Transport- und Umschlagkomponenten in diesen Dialogfeldern nicht sehr gut auskennen, sollten Sie diese nicht ändern.

  • Wenn Sie einen Umschlag mit einem benutzerdefinierten Format im Messagingport angegeben haben, müssen Sie die benutzerdefinierte Serialisierungskomponente mithilfe der erweiterten Konfigurationseigenschaften konfigurieren.

Anmerkungen

  • Wenn Sie Eigenschaften von Messagingports in einem Kanal außer Kraft setzen, wirken sich die Änderungen nur auf den betreffenden Kanal aus.

  • Die in einem Messagingport festgelegte Transportadresse kann nicht außer Kraft gesetzt werden.

  • Die Standardeinstellung für die HTTP-Transportkomponente sieht die Verwendung des HTTP-Proxyservers vor. Dies ist die korrekte Einstellung, um Daten zu Websites außerhalb des Firewalls Ihres Unternehmens zu transportieren. Um Daten an Websites zu transportieren, die sich innerhalb des Firewalls Ihres Unternehmens befinden (also im Intranet), verwenden Sie dieses Verfahren, um die Standardeinstellung außer Kraft zu setzen.

  • Für die HTTPS-Transportkomponente sollten Sie nur Zertifikate verwenden, die für die Clientauthentifizierung angegeben sind. Zertifikate, die für alle Zwecke angegeben sind, werden nicht in der Liste angezeigt.

  • Die Standardeinstellung für die Dateitransportkomponente sieht das Anfügen von Dateien vor. Wenn Sie den Dateitransporttyp mit Standardeinstellungen in einem Messagingport auswählen und auf dem Server, auf dem BizTalk Server 2000 installiert ist, Antivirensoftware verwenden und Sie außerdem mehrere Dateien mit exakt gleichem Namen gleichzeitig an denselben Dateispeicherort senden, hört BizTalk Server 2000 möglicherweise auf zu reagieren und muss neu gestartet werden. Sie können dieses Problem beheben, indem Sie die Standardeinstellung für die Datentransportkomponente im Dialogfeld BizTalk SendLocalFile-Eigenschaften von An Datei anhängen zu Datei überschreiben ändern. Ferner können Sie das Problem beheben, indem Sie für jede verarbeitete Dokumentinstanz mithilfe des Dateipfadformats im Messagingport eine eindeutige Datei erstellen: file://C:\dir\file%tracking_id%.xml. Weitere Informationen finden Sie unter Angeben einer Transportadresse.

  • Die Standardeinstellung für die Dateitransportkomponente sieht das Anfügen von Dateien vor. Wenn Sie den Dateitransporttyp mit Standardeinstellungen wählen und einen Umschlag mit dem Umschlagformat RELIABLE in einem Messagingport auswählen und dann mehrere Dateien gleichzeitig an denselben Dateispeicherort senden, können unerwartete Ergebnisse beim Analysieren auftreten. Sie können dieses Problem beheben, indem Sie die Standardeinstellung für die Datentransportkomponente im Dialogfeld BizTalk SendLocalFile-Eigenschaften von An Datei anhängen zu Datei überschreiben ändern.

  • Wenn der im Messagingport angegebene Umschlag ein benutzerdefiniertes Format aufweist und Sie eine benutzerdefinierte Serialisierungskomponente erstellt und registriert haben, können Sie die Eigenschaften der benutzerdefinierten Serialisierungskomponente mithilfe dieses Verfahrens konfigurieren.

  • Der standardmäßige Syntaxbezeichner für einen EDIFACT-Umschlag ist UNOA (Großbuchstaben im lateinischen Alphabet). Wenn die Daten eine andere Syntax erfordern, wählen Sie mithilfe dieses Verfahrens einen anderen Syntaxbezeichner aus.

  • Wenn Sie EDIFACT-Versionsindikatoren verwenden, sollten die Daten keine Versionsindikatorzeichen enthalten. Andernfalls können die Daten die physische Zeichengrößenbeschränkung für Felder überschreiten.

Verwandte Themen

Erstellen von Kanälen

Bearbeiten von Kanälen

Festlegen von erweiterten Konfigurationseigenschaften

Festlegen von Kanaleigenschaften


Außerkraftsetzen von Verteilerlistenstandards

  1. Klicken Sie auf der Seite Erweiterte Konfiguration des Kanal-Assistenten auf Erweitert.

    Wenn Sie einen Kanal für eine Verteilerliste erstellen oder bearbeiten, wird das Dialogfeld Verteilerlistenstandards außer Kraft setzen angezeigt.

  2. Wählen Sie in der Liste Messagingport auswählen einen Messagingport aus, den Sie außer Kraft setzen möchten, und klicken Sie dann auf Außer Kraft setzen.

    Das Dialogfeld Messagingportstandards außer Kraft setzen wird angezeigt.

  3. Setzen Sie die Eigenschaften der Transport- und Umschlagkomponente für den ausgewählten Messagingport außer Kraft.

    Weitere Informationen finden Sie unter Außerkraftsetzen von Messagingportstandards.

  4. Wenn Sie die außer Kraft zu setzenden Messagingports geändert haben, klicken Sie auf Schließen.

Weitere Informationen zum Festlegen von erweiterten Eigenschaften finden Sie unter Festlegen von erweiterten Konfigurationseigenschaften.

Verwandte Themen

Erstellen von Kanälen

Bearbeiten von Kanälen

Außerkraftsetzen von Messagingportstandards

Festlegen von erweiterten Konfigurationseigenschaften

Festlegen von Kanaleigenschaften


Festlegen der Überwachung für Eigenschaften von eingehenden Dokumenten

Das Dialogfeld Eingehende Dokumente überwachen listet die Spezifikationsfelder für das eingehende Dokument sowie alle globalen Überwachungsfelder auf, die in der Dokumentdefinition ausgewählt sind.

Wenn Sie in diesem Dialogfeld Spezifikationsfelder auswählen, setzen diese Felder die globalen Überwachungsfelder außer Kraft, jedoch nur für diesen Kanal. Für jede verarbeitete Dokumentinstanz werden die im Kanal ausgewählten Felder in der Überwachungsdatenbank statt in den globalen Überwachungsfeldern protokolliert.

Dieser Abschnitt beschreibt das Auswählen oder Entfernen von Spezifikationsfeldern des eingehenden Dokuments in einem Kanal.

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Auswählen von Spezifikationsfeldern in einem Kanal

  • Entfernen von Spezifikationsfeldern in einem Kanal

Verwandte Themen

Erstellen von Kanälen

Bearbeiten von Kanälen

Festlegen von Kanaleigenschaften

Festlegen von globalen Überwachungseigenschaften

Festlegen von Eigenschaften für eingehende Dokumente


Auswählen von Spezifikationsfeldern in einem Kanal

  1. Aktivieren Sie auf der Seite Eingehendes Dokument des Kanal-Assistenten das Kontrollkästchen Eingehendes Dokument überwachen, und klicken Sie dann auf Überwachen.

    Das Dialogfeld Eingehende Dokumente überwachen wird angezeigt.

  2. Doppelklicken Sie in der Struktur Spezifikationsfelder auf einen beliebigen Datensatz, um die Anzeige zu erweitern.

  3. Wählen Sie ein Spezifikationsfeld aus, das Sie zur Liste Zu überwachende Felder hinzufügen möchten, und führen Sie dann eins der folgenden Verfahren aus:
    Feld als diesen Typ hinzufügen | Verfahren
    Integer | Klicken Sie auf Integer. Sie können zwei Felder als ganzzahlige Werte hinzufügen.
    Real | Klicken Sie auf Real. Sie können zwei Felder als reelle Zahlen hinzufügen.
    Date | Klicken Sie auf Date. Sie können zwei Felder als Datumswerte hinzufügen.
    Text | Klicken Sie auf Text. Sie können zwei Felder als Text hinzufügen.
    Benutzerdefiniert | Klicken Sie auf Benutzerdefiniert. Sie können unbegrenzte Felder als benutzerdefinierte Datentypen hinzufügen. Die Felder werden in Form einer verketteten XML-Zeichenfolge mit Tags für jedes Feld gespeichert.

Weitere Informationen zum Festlegen von Eigenschaften für eingehende Dokumente finden Sie unter Festlegen von Eigenschaften für eingehende Dokumente.

Wichtig

  • Wenn Sie in diesem Dialogfeld Spezifikationsfelder auswählen, setzen diese Felder die globalen Überwachungsfelder außer Kraft, jedoch nur für diesen Kanal. Für jede verarbeitete Dokumentinstanz werden die im Kanal ausgewählten Felder in der Überwachungsdatenbank statt in den globalen Überwachungsfeldern protokolliert.

Anmerkungen

  • Um ein Spezifikationsfeld auszuwählen, das als Datentyp Integer, Real oder Date überwacht werden soll, muss das Feld den in der Spezifikation zugewiesenen Datentyp aufweisen. Weitere Informationen zum Zuweisen eines Datentyps zu einem Spezifikationsfeld finden Sie unter Festlegen von Deklarationseigenschaften.

  • Spezifikationsfelder, denen in der Spezifikation kein Datentyp zugewiesen ist, können nur als Text-Datentyp oder als benutzerdefinierter Datentyp überwacht werden.

  • Wenn ein Spezifikationsfeld, das Sie überwachen möchten, den Character-Datentyp aufweist, können Sie dieses Feld nur als einen benutzerdefinierten Datentyp überwachen.

  • Es können nur zwei Spezifikationsfelder eines bestimmten Datentyps ausgewählt werden. Es kann eine unbeschränkte Anzahl von Feldern als benutzerdefinierter Datentyp ausgewählt werden.

Verwandte Themen

Erstellen von Kanälen

Bearbeiten von Kanälen

Entfernen von Spezifikationsfeldern in einem Kanal

Festlegen von Kanaleigenschaften

Festlegen von globalen Überwachungseigenschaften

Festlegen der Überwachung für Eigenschaften von eingehenden Dokumenten

Überwachen von Dokumentdatenfeldern


Entfernen von Spezifikationsfeldern in einem Kanal

  1. Aktivieren Sie auf der Seite Eingehendes Dokument des Kanal-Assistenten das Kontrollkästchen Eingehendes Dokument überwachen, und klicken Sie dann auf Überwachen.

    Das Dialogfeld Eingehende Dokumente überwachen wird angezeigt.

  2. Klicken Sie in der Liste Zu überwachende Felder auf das Spezifikationsfeld oder die Spezifikationsfelder, das/die Sie entfernen möchten, und klicken Sie dann auf Entfernen.

Weitere Informationen zum Festlegen von Eigenschaften für eingehende Dokumente finden Sie unter Festlegen von Eigenschaften für eingehende Dokumente.

Anmerkung

  • Wenn Sie ein Feld aus der Liste der zu überwachenden Felder entfernen, wird es nur in diesem Kanal aus der Liste entfernt; es wird jedoch nicht aus der Spezifikation entfernt.

Verwandte Themen

Erstellen von Kanälen

Bearbeiten von Kanälen

Auswählen von Spezifikationsfeldern in einem Kanal

Festlegen von Kanaleigenschaften

Festlegen von globalen Überwachungseigenschaften

Festlegen der Überwachung für Eigenschaften von eingehenden Dokumenten

Überwachen von Dokumentdatenfeldern


Festlegen von Eigenschaften für die Kanalfilterung

Ein Kanalfilterausdruck ist ein XPath-Ausdruck, mit dem bestimmt werden kann, ob ein Kanal auf der Grundlage eines angegebenen Feldes oder angegebener Felder im Dokument aufgerufen wird. Wenn Microsoft BizTalk Server 2000 ein Dokument verarbeitet, wird der Wert des angegebenen Feldes oder der angegebenen Felder im Vergleich mit dem Kanalfilterausdruck ausgewertet. Wenn der Ausdruck sich als wahr (TRUE) erweist, wird der Kanal aufgerufen. Wenn der Ausdruck falsch (FALSE) ist, wird der Kanal nicht aufgerufen.

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Hinzufügen eines Kanalfilterausdrucks

  • Bearbeiten eines Kanalfilterausdrucks

  • Entfernen eines Kanalfilterausdrucks

Verwandtes Thema

Festlegen von Eigenschaften für eingehende Dokumente


Hinzufügen eines Kanalfilterausdrucks

  1. Aktivieren Sie auf der Seite Eingehendes Dokument des Kanal-Assistenten das Kontrollkästchen Eingehendes Dokument filtern, und klicken Sie dann auf Filtern.

    Das Dialogfeld Kanalfilterausdrücke wird angezeigt.

  2. Doppelklicken Sie in der Struktur Feld auswählen auf einen beliebigen Knoten, um die Anzeige zu erweitern.

  3. Klicken Sie auf ein Spezifikationsfeld, dass Sie zum Erstellen eines Filterausdrucks verwenden möchten, und klicken Sie dann auf Hinzufügen.

    Das Dialogfeld Ausdruckseigenschaften wird angezeigt.

  4. Klicken Sie in der Liste Operator auf einen Operator:
    Operator Symbol
    Gleich (Standard) =
    Ungleich !=
    Kleiner als <
    Gleich oder kleiner als <=
    Größer als >
    Gleich oder größer als >=

  5. Geben Sie im Feld Wert einen Wert für den Ausdruck ein, und klicken Sie auf OK.

Weitere Informationen zum Festlegen von Eigenschaften für eingehende Dokumente finden Sie unter Festlegen von Eigenschaften für eingehende Dokumente.

Wichtig

  • Ein Kanalfilterausdruck muss ein gültiger XPath-Ausdruck sein. Die Schaltfläche Hinzufügen kann verwendet werden, um eine Klausel zu erstellen, die ein Spezifikationsfeld enthält, und um diese in einen Ausdruck einzufügen; sie generiert jedoch nicht die korrekte Syntax, die für einen gültigen XPath-Ausdruck erforderlich ist. Weitere Informationen zu XPath-Ausdrücken finden Sie unter Kanalfilter und ebenfalls in der Microsoft-Website unter der Adresse (msdn.microsoft.com/library/default.asp). Suchen Sie in der Website nach dem Schlüsselwort "XPath".

Anmerkungen

  • Sie können einen Ausdruck auch direkt in der Liste Ausdrücke eingeben.

  • Um ein Spezifikationsfeld für einen Kanalfilterausdruck auszuwählen, muss dem Feld in der Spezifikation ein Datentyp zugewiesen sein. Weitere Informationen zum Zuweisen eines Datentyps zu einem Feld finden Sie unter Festlegen von Deklarationseigenschaften.

  • Wenn das Spezifikationsfeld, das Sie zum Erstellen eines Ausdrucks verwenden, einen Boolean-Datentyp aufweist, können Sie die Textzeichenfolgen TRUE oder FALSE nicht im Wert des Ausdrucks verwenden. Stattdessen müssen Sie einen numerischen Wert verwenden , -1 für TRUE und 0 für FALSE.

  • Wenn das Spezifikationsfeld, das Sie zum Erstellen eines Ausdrucks verwenden, einen Date-Datentyp aufweist, müssen Sie den Wert im folgenden Format eingeben, einschließlich der Trennstriche: JJJJ-MM-TT.

Verwandte Themen

Erstellen von Kanälen

Bearbeiten eines Kanalfilterausdrucks

Bearbeiten von Kanälen

Entfernen eines Kanalfilterausdrucks

Festlegen von Eigenschaften für die Kanalfilterung

Festlegen von Kanaleigenschaften


Bearbeiten eines Kanalfilterausdrucks

  1. Aktivieren Sie auf der Seite Eingehendes Dokument des Kanal-Assistenten das Kontrollkästchen Eingehendes Dokument filtern, und klicken Sie dann auf Filtern.

    Das Dialogfeld Kanalfilterausdrücke wird angezeigt.

  2. Bearbeiten Sie den Ausdruck in der Liste Ausdrücke, und klicken Sie auf OK.

Weiter Informationen zum Festlegen von Eigenschaften für eingehende Dokumente finden Sie unter Festlegen von Eigenschaften für eingehende Dokumente.

Wichtig

  • Ein Kanalfilterausdruck muss ein gültiger XPath-Ausdruck sein. Weitere Informationen zu XPath-Ausdrücken finden Sie unter Kanalfilter und ebenfalls in der Microsoft-Website unter der Adresse (msdn.microsoft.com/library/default.asp). Suchen Sie in der Website nach dem Schlüsselwort "XPath".

Verwandte Themen

Hinzufügen eines Kanalfilterausdrucks

Entfernen eines Kanalfilterausdrucks

Festlegen von Eigenschaften für die Kanalfilterung


Entfernen eines Kanalfilterausdrucks

  • Deaktivieren Sie auf der Seite Eingehendes Dokument des Kanal-Assistenten das Kontrollkästchen Eingehendes Dokument filtern.

Weitere Informationen zum Festlegen von Eigenschaften für eingehende Dokumente finden Sie unter Festlegen von Eigenschaften für eingehende Dokumente.

Verwandte Themen

Hinzufügen eines Kanalfilterausdrucks

Erstellen von Kanälen

Bearbeiten eines Kanalfilterausdrucks

Bearbeiten von Kanälen

Festlegen von Eigenschaften für die Kanalfilterung

Festlegen von Kanaleigenschaften


Erstellen und Verwalten von Messagingports

Dieser Abschnitt stellt aufgabenspezifische Informationen zum Erstellen und Verwalten von Messagingports bereit. Es wird dringend empfohlen, Grundlegendes zu Messagingports im Abschnitt "Grundbegriffe" zu lesen, damit Sie über das entsprechende Hintergrundwissen zu den Messagingports verfügen.

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Erstellen von Messagingports

  • Suchen nach Messagingport

  • Bearbeiten von Messagingports

  • Löschen von Messagingports

  • Festlegen von Messagingporteigenschaften


Erstellen von Messagingports

  1. Zeigen Sie im BizTalk-Messaging-Manager im Menü Datei auf Neu, zeigen Sie auf Messagingport, und führen Sie dann einen der folgenden Schritte durch:
    • Klicken Sie auf Zu einer Organisation, um einen Messagingport zur Organisation eines Handelspartners zu erstellen.

    • Klicken Sie auf Zu einer Anwendung, um einen Messagingport zu einer internen Anwendung zu erstellen.

    Der Messagingport-Assistent wird geöffnet.

  2. Legen Sie die Eigenschaften auf der Seite Allgemeine Information fest, und klicken Sie auf Weiter.

    Weitere Informationen finden Sie unter Festlegen von allgemeinen Informationseigenschaften für den Messagingport.

  3. Führen Sie einen der folgenden Schritte aus:
    • Wenn Sie einen Messagingport zu einer bestimmten Organisation erstellen, legen Sie die Eigenschaften auf der Seite Zielorganisation fest, und klicken Sie auf Weiter. Weitere Informationen finden Sie unter Festlegen von Eigenschaften für die Zielorganisation.

    • Wenn Sie einen offenen Messagingport erstellen, klicken Sie auf Offenes Ziel, und klicken Sie auf Weiter.

      Für einen offenen Messagingport müssen die Transport- und die Zielinformationen entweder im Dokument selbst oder in einem Parameter enthalten sein, der zusammen mit dem Dokument versendet wird. Weitere Informationen finden Sie unter Submitting.

    • Wenn Sie einen Messagingport zu einer Anwendung erstellen, legen Sie die Eigenschaften auf der Seite Zielanwendung fest, und klicken Sie auf Weiter. Weitere Informationen finden Sie unter Festlegen von Eigenschaften für die Zielanwendung.
  4. Legen Sie auf der Seite Umschlagsinformationen die Eigenschaften fest, und klicken Sie auf Weiter.

    Weitere Informationen finden Sie unter Festlegen von Eigenschaften für die Umschlagsinformationen.

  5. Legen Sie auf der Seite Sicherheitsinformationen die Eigenschaften fest, und klicken Sie auf Weiter.

    Weitere Informationen finden Sie unter Festlegen von Eigenschaften für die Sicherheitseinstellungen.

  6. Wenn Sie nicht direkt im Kanal-Assistenten mit dem Erstellen eines Kanals fortfahren möchten, deaktivieren Sie das Kontrollkästchen Kanal für diesen Messagingport erstellen. Klicken Sie andernfalls in der Liste Kanaltyp auf einen der folgenden Kanaltypen:
    • Von einer Organisation

    • Von einer Anwendung
  7. Klicken Sie auf der Seite Sicherheitsinformationen auf Fertig stellen, um den Messagingport-Assistenten zu schließen, nachdem Sie alle Eigenschaften des Messagingports festgelegt haben.

Wichtig

  • Wenn Sie einen Messagingport als einen offenen Messagingport festlegen, können Sie für den Messagingport keine Kanäle erstellen, deren Definition für das ausgehende Dokument eine X12- oder EDIFACT- Spezifikation enthalten. Der Server muss über einen Quell- und Ziel-Organisationskennzeichen verfügen, um einen X12- oder EDIFACT-Umschlag zu erstellen. Ein offener Messagingport spezifiziert kein Zielorganisationskennzeichen. Darüber hinaus muss in den Dokumenten für einen offenen Messagingport die Zieladresse innerhalb des Dokuments enthalten sein, jedoch X12- und EDIFACT-Dokumente enthalten diese Informationen nicht.

Anmerkungen

  • Sie können einen Messagingport nicht mit dem reservierten Systemnamen Port für Reliable Messaging-Bestätigung benennen.

  • Wenn Sie einen Messagingport und einen Kanal für eine Pass-Through-Versendung von Daten erstellen, können Sie nur das Dienstfenster, den Wiederholungszähler und die Intervallfeatures des Kanals sowie die Transportfeatures des zugeordneten Messagingports verwenden. Sie können die Verifizierung der Decodierung oder Entschlüsselung, das Filtern, die Dokumentüberwachung oder Zuordnungsfeatures des Kanals nicht verwenden.

Verwandte Themen

Erstellen und Verwalten von Kanälen

Löschen von Messagingports

Bearbeiten von Messagingports

Suchen nach Messagingport

Festlegen von Messagingporteigenschaften

Grundlegendes zu Messagingports


Suchen nach Messagingport

  1. Klicken Sie im BizTalk-Messaging-Manager im Bereich Nach anderen Elementen suchen auf Messagingports.

  2. Führen Sie eine oder mehrere der folgenden Aktionen durch:
  • Löschen Sie alle Suchkriterien, und klicken Sie auf Jetzt suchen, um alle Messagingports zu suchen.
    • Geben Sie in das Feld Messagingportname den Namen des Messagingports ein, den Sie suchen möchten, und klicken Sie auf Jetzt suchen, um einen Messagingport mit einem bestimmten Namen zu suchen. Sie können einen unvollständigen Namen eingeben, und die Suche gibt alle möglichen Namen zurück, die mit dem unvollständigen Namen übereinstimmen.

    • Klicken Sie in der Liste Ziel auf einen Zieltyp, und klicken Sie auf Jetzt suchen, um einen Messagingport zu einem bestimmten Typ von Ziel zu suchen.

Anmerkungen

  • Sie können mehr als ein Suchkriterium festlegen, bevor Sie auf Jetzt suchen klicken.

  • Wenn nach einer großen Anzahl von Objekten gesucht werden soll, dauert es möglicherweise mehrere Minuten, bis alle Objekte zurückgegeben werden. Sie können die Anzahl der in einer Suche zurückgegebenen Elemente verringern, indem Sie Suchkriterien verwenden.

  • Die Standardanzahl von Elementen, die bei einer Suche zurückgegeben werden, ist 500. Diese Anzahl können Sie anpassen. Weitere Informationen finden Sie unter Festlegen von Serververbindungsoptionen.

  • Klicken Sie auf Suche löschen, um die Suchkriterien und Suchergebnisse zu löschen.

  • Sie können die folgenden Platzhalterzeichen für die Suchkriterien verwenden.
    Platzhalter | Beschreibung | Beispiel
    % Eine Zeichenfolge aus null oder mehr Zeichen Der Eintrag %open% findet alle Namen, die das Wort "open" enthalten.
    _ (Unterstrich) | Beliebiges einzelnes Zeichen | Der Eintrag _ean findet alle Namen mit vier Buchstaben, die auf "ean" enden (Dean, Sean usw.).
    [ ] Beliebiges einzelnes Zeichen im angegebenen Bereich ([a-f]) oder in der angegebenen Menge ([abcdef]). Der Eintrag [C-P]arsen findet alle Namen, die auf "arsen" enden und mit einem beliebigen einzelnen Zeichen zwischen C und P beginnen, z. B.: Carsen, Larsen usw.
    [^] Beliebiges einzelnes Zeichen, das sich nicht im angegebenen Bereich ([^a-f]) oder in der angegebenen Menge ([^abcdef]) befindet. Der Eintrag de[^s]% findet alle Namen, die mit "de" beginnen und deren dritter Buchstabe nicht "s" ist.

Verwandte Themen

Löschen von Messagingports

Bearbeiten von Messagingports

Grundlegendes zu Messagingports


Bearbeiten von Messagingports

  1. Klicken Sie im BizTalk-Messaging-Manager in der Liste Messagingportname auf den Messagingport, den Sie bearbeiten möchten.

    Weitere Informationen zum Suchen nach Messagingports finden Sie unter Suchen nach Messagingport.

  2. Klicken Sie im Menü Datei auf Bearbeiten.

    Der Messagingport-Assistent wird geöffnet.

  3. Bearbeiten Sie auf der Seite Allgemeine Informationen die entsprechenden Eigenschaften.

    Weitere Informationen finden Sie unter Festlegen von allgemeinen Informationseigenschaften für den Messagingport.

    Nach dem Bearbeiten der Eigenschaften auf einer beliebigen Seite können Sie auf Fertig stellen klicken, um den Messagingport-Assistenten zu schließen, oder auf Weiter klicken, um weitere Eigenschaften des Messagingports zu bearbeiten.

  4. Führen Sie einen der folgenden Schritte durch:
    • Wenn Sie einen Messagingport zu einer Organisation bearbeiten, bearbeiten Sie die erforderlichen Eigenschaften auf der Seite Zielorganisation, und klicken Sie auf Weiter. Weitere Informationen finden Sie unter Festlegen von Eigenschaften für die Zielorganisation.

    • Wenn Sie einen Messagingport zu einer Anwendung bearbeiten, bearbeiten Sie die entsprechenden Eigenschaften auf der Seite Zielanwendung, und klicken Sie auf Weiter. Weitere Informationen finden Sie unter Festlegen von Eigenschaften für die Zielanwendung.
  5. Bearbeiten Sie auf der Seite Umschlagsinformationen die entsprechenden Eigenschaften, und klicken Sie auf Weiter.

    Weitere Information finden Sie unter Festlegen von Eigenschaften für die Umschlagsinformationen.

  6. Bearbeiten Sie auf der Seite Sicherheitsinformationen die entsprechenden Eigenschaften.

    Weitere Informationen finden Sie unter Festlegen von Eigenschaften für die Sicherheitseinstellungen.

  7. Wenn Sie nicht direkt zum Kanal-Assistenten weitergehen möchten, um einen Kanal zu erstellen, deaktivieren Sie das Kontrollkästchen Kanal für diesen Messagingport erstellen. Andernfalls klicken Sie in der Liste Kanaltyp auf einen der folgenden Kanaltypen:
    • Von einer Organisation

    • Von einer Anwendung
  8. Nachdem Sie alle entsprechenden Eigenschaften des Messagingports bearbeitet haben, können Sie auf einer der Seiten auf Fertig stellen klicken, um den Messagingport-Assistenten zu schließen.

Anmerkung

  • Sie können einen Messagingport nicht mit dem reservierten Systemnamen Port für Reliable Messaging-Bestätigung bezeichnen.

Verwandte Themen

Erstellen und Verwalten von Kanälen

Erstellen von Messagingports

Löschen von Messagingports

Festlegen von Messagingporteigenschaften

Grundlegendes zu Messagingports


Löschen von Messagingports

  1. Klicken Sie im BizTalk-Messaging-Manager in der Liste Messagingportname auf den Messagingport, den Sie löschen möchten.

    Weitere Informationen zum Suchen nach Messagingports finden Sie unter Suchen nach Messagingport.

  2. Klicken Sie im Menü Datei auf Löschen.

Anmerkungen

  • Wenn Sie Kanäle für einen Messagingport erstellt haben, können Sie den Messagingport nicht löschen, bevor nicht die ihm zugeordneten Kanäle gelöscht sind.

  • Sie können die einem Messagingport zugeordneten Kanäle suchen, indem Sie mit der rechten Maustaste auf den Messagingport klicken und dann auf Kanäle suchen klicken.

Verwandte Themen

Erstellen und Verwalten von Kanälen

Erstellen von Messagingports

Bearbeiten von Messagingports

Grundlegendes zu Messagingports


Festlegen von Messagingporteigenschaften

Dieser Abschnitt stellt aufgabenspezifische Informationen zum Konfigurieren der Eigenschaften eines Messagingports bereit. Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Festlegen von allgemeinen Informationseigenschaften für den Messagingport

  • Festlegen von Eigenschaften für die Zielorganisation

  • Festlegen von Eigenschaften für die Zielanwendung

  • Festlegen von Eigenschaften für die Umschlagsinformationen

  • Festlegen von Eigenschaften für die Sicherheitseinstellungen

  • Auswählen einer Zielorganisation

  • Auswählen eines Verschlüsselungszertifikats

  • Festlegen von Transporteigenschaften

  • Festlegen von Umschlagstrennzeichen


Festlegen von allgemeinen Informationseigenschaften für den Messagingport

  1. Geben Sie im Messagingport-Assistenten auf der Seite Allgemeine Informationen in das Feld Name den Namen des Messagingports ein.

  2. Geben Sie in das Feld Kommentare einen Kommentar zu dem Messagingport ein, und klicken Sie auf Weiter.

Wenn Sie einen neuen Messagingport erstellen, klicken Sie auf Weiter. Anweisungen zum Fertigstellen des folgenden Schrittes finden Sie unter Erstellen von Messagingports.

Wenn Sie einen vorhandenen Messagingport bearbeiten, klicken Sie auf Weiter. Anweisungen zum Fertigstellen des folgenden Schrittes finden Sie unter Bearbeiten von Messagingports. Klicken Sie auf Fertig stellen, wenn Sie die Änderungen abgeschlossen haben.

Verwandte Themen

Erstellen von Messagingports

Bearbeiten von Messagingports

Festlegen von Messagingporteigenschaften


Festlegen von Eigenschaften für die Zielorganisation

  1. Führen Sie im Messagingport-Assistenten auf der Seite Zielorganisation einen der folgenden Schritte durch:
    • Klicken Sie auf Offenes Ziel, um einen offenen Messagingport zu erstellen, und klicken Sie auf Weiter.

      Für einen offenen Messagingport müssen die Transport- und die Zielinformationen entweder im Dokument selbst oder in Parametern enthalten sein, die zusammen mit dem Dokument versendet werden. Weitere Informationen finden Sie unter Submitting.

    • Klicken Sie auf Organisation, um die Organisation eines bestimmten Handelspartners als Ziel anzugeben, und fahren Sie dann mit Schritt 2 fort.
  2. Klicken Sie im Bereich Organisation auf Durchsuchen.

    Das Dialogfeld Organisation auswählen wird angezeigt.

  3. Klicken Sie auf eine Organisation, und klicken Sie dann auf OK.

    Weitere Informationen finden Sie unter Auswählen einer Zielorganisation.

  4. Klicken Sie im Bereich Primärer Transport auf Durchsuchen.

    Das Dialogfeld Primärer Transport wird angezeigt.

  5. Legen Sie die Eigenschaften für den primären Transport fest.

    Weitere Informationen finden Sie unter Festlegen von Transporteigenschaften.

  6. Wenn Sie die Zeit begrenzen möchten, in der die Dokumente transportiert werden können, aktivieren Sie im Bereich Primärer Transport das Kontrollkästchen Dienstfenster.

    Klicken Sie in den Feldern Von und Bis auf die Stunde, und geben Sie einen Wert ein, oder klicken Sie auf den Pfeil-nach-oben oder Pfeil-nach-unten, um den Wert zu erhöhen oder zu verringern.

  7. Klicken Sie im Bereich Sekundärer Transport auf Durchsuchen, wenn Sie einen sekundären Transport festlegen möchten.

    Das Dialogfeld Sekundärer Transport wird angezeigt.

  8. Legen Sie die Eigenschaften für den sekundären Transport fest.

    Weitere Informationen finden Sie unter Festlegen von Transporteigenschaften.

Wenn Sie einen neuen Messagingport erstellen, klicken Sie auf Weiter. Anweisungen zum Fertigstellen des folgenden Schrittes finden Sie unter Erstellen von Messagingports.

Wenn Sie einen vorhandenen Messagingport bearbeiten, klicken Sie auf Weiter. Anweisungen zum Fertigstellen des folgenden Schrittes finden Sie unter Bearbeiten von Messagingports. Klicken Sie auf Fertig stellen, wenn Sie die Änderungen abgeschlossen haben.

Wichtig

  • Wenn Sie einen Messagingport als einen offenen Messagingport festlegen, erstellen Sie keine Kanäle für den Messagingport, die eine Definition für ausgehende Dokumente mit einer X12- oder EDIFACT-Spezifikation enthalten. Der Server muss über ein Quell- und ein Zielorganisationskennzeichen verfügen, um einen X12- oder EDIFACT-Umschlag zu erstellen. Ein offener Messagingport gibt kein Zielorganisationskennezeichen an. Darüber hinaus muss in den Dokumenten für einen offenen Messagingport die Zieladresse innerhalb des Dokuments enthalten sein, jedoch X12- und EDIFACT-Dokumente enthalten diese Informationen nicht.

Anmerkung

  • Die Stunden des Dienstfensters werden im UTC-Format angezeigt und entsprechen der Zeit auf dem Server.

Verwandte Themen

Erstellen von Messagingports

Bearbeiten von Messagingports

Festlegen von Messagingporteigenschaften


Festlegen von Eigenschaften für die Zielanwendung

  1. Führen Sie im Messagingport-Assistenten auf der Seite Zielanwendung einen der folgenden Schritte durch:
    • Klicken Sie auf Neuer XLANG-Ablaufplan, um einen Port in einer neuen Instanz eines bestimmten XLANG-Ablaufplanes als Ziel anzugeben. Geben Sie dann im Feld Moniker für Ablaufplan den Moniker des spezifizierten Ablaufplanes ein, oder klicken Sie auf Durchsuchen, um den Pfad festzulegen. Geben Sie dann im Feld Portname den Namen des in diesem Ablaufplan vorgesehenen Ports ein, an den das Dokument zu senden ist.

      Die Syntax für Moniker für den Ablaufplan lautet wie folgt:

      sked://[localhost][!GroupManager][/DateiPfad][/PortName]

      Sie können XLANG-Ablaufpläne nur auf dem lokalen Rechner aktivieren.

      Weitere Informationen zu Monikers finden Sie unter Monikersyntax.

    • Klicken Sie auf Aktiver XLANG-Ablaufplan, um eine aktive XLANG-Ablaufplaninstanz als Ziel festzulegen. Verwenden Sie diese Option nur, um eine Nachricht an einen aktiven XLANG-Ablaufplan zu transportieren, wenn ein Handelspartner die Nachricht mit einem HTTP-Transport an eine speziell konfigurierte ASP (Active Server Page) zurücksendet. Weitere Informationen finden Sie unter Integrieren der BizTalk-Dienste.

    • Klicken Sie auf Anwendung, um eine Anwendung der eigenen Organisation als Ziel festzulegen, klicken Sie dann in der Liste Name auf eine Anwendung.
  2. Wenn Sie eine Anwendung als Ziel ausgewählt haben, führen Sie die Schritte 3 bis 5 durch. Andernfalls klicken Sie auf Weiter.

  3. Klicken Sie im Bereich Primärer Transport auf Durchsuchen.

    Das Dialogfeld Primärer Transport wird angezeigt.

  4. Legen Sie die Eigenschaften des primären Transports fest.

    Weitere Informationen finden Sie unter Festlegen von Transporteigenschaften.

  5. Wenn Sie die Zeit begrenzen möchten, innerhalb derer Dokumente transportiert werden können, aktivieren Sie im Bereich Primärer Transport das Kontrollkästchen Dienstfenster.

    Klicken Sie dann in die Felder Von und Bis, und geben Sie einen Wert ein, oder klicken Sie auf den Pfeil-nach-oben oder den Pfeil-nach-unten, um den Wert zu erhöhen oder zu verringern.

  6. Wenn Sie einen sekundären Transport festlegen möchten, klicken Sie im Bereich Sekundärer Transport auf Durchsuchen.

    Das Dialogfeld Sekundärer Transport wird angezeigt.

  7. Legen Sie die Eigenschaften des sekundären Transports fest.

    Weitere Informationen finden Sie unter Festlegen von Transporteigenschaften.

Wenn Sie einen neuen Messagingport erstellen, klicken Sie auf Weiter. Anweisungen zum Fertigstellen des folgenden Schrittes finden Sie unter Erstellen von Messagingports.

Wenn Sie einen vorhandenen Messagingport bearbeiten, klicken Sie auf Weiter. Anweisungen zum Fertigstellen des folgenden Schrittes finden Sie unter Bearbeiten von Messagingports. Klicken Sie auf Fertig stellen, wenn Sie die Änderungen abgeschlossen haben.

Wichtig

  • Wenn Sie die Option Neuer XLANG-Ablaufplan wählen:
    • Der Port, den Sie angeben, muss mit BizTalk-Messaging im angegebenen Ablaufplan verbunden sein, und diese Bindung muss so konfiguriert sein, dass nach Eingang der Nachricht eine neue Ablaufplaninstanz aktiviert wird.

    • Sie sollten nur einen Port in einem Ablaufplan haben, der so konfiguriert ist, dass er eine neue Ablaufplaninstanz nach Eingang der Nachricht aktiviert, und dies sollte die erste Aktion in dem Ablaufplan sein. Weitere Informationen finden Sie unter Implementieren eines Ports mithilfe von BizTalk Messaging.

Anmerkungen

  • Wenn Sie einen XLANG-Ablaufplan als Ziel für einen Messagingport auswählen, liegt die Höchstgrenze für die Dokumente, die Sie mit diesem Messagingport verarbeiten können, bei 2 MB.

  • Der BizTalk-Orchestrierungs-Designer kann zum Erstellen der XLANG-Ablaufpläne verwendet werden.

  • Die Uhrzeiten des Dienstfensters werden im UTC-Format angezeigt und entsprechen der Zeit auf dem Server.

Verwandte Themen

Erstellen von Messagingports

Bearbeiten von Messagingports

Festlegen von Messagingporteigenschaften


Festlegen von Eigenschaften für die Umschlagsinformationen

  1. Wählen Sie im Messagingport-Assistenten auf der Seite Umschlagsinformationen im Bereich Umschlagsinformationen einen Umschlag aus der Liste aus.

    Wenn Sie einen Umschlag auswählen, der ein X12- oder EDIFACT- Format hat, sind die folgenden Schritte erforderlich. Wenn Sie einen Umschlag mit einem CUSTOM-Format auswählen, sind die folgenden Schritte optional.

    1. Klicken Sie auf Trennzeichen, und legen Sie die Eigenschaften der Trennzeichen fest.

      Weitere Informationen finden Sie unter Festlegen von Umschlagstrennzeichen.

    2. Geben Sie in das Feld Austauschkontrollnummer eine Austauschkontrollnummer ein.
  2. Wenn Sie das Standardorganisationskennzeichen für die Zielorganisation außer Kraft setzen möchten, klicken Sie in der Liste Organisationskennzeichen auf ein anderes Kennzeichen.

Wenn Sie einen neuen Messagingport erstellen, klicken Sie auf Weiter. Anweisungen zum Fertigstellen des folgenden Schrittes finden Sie unter Erstellen von Messagingports.

Wenn Sie einen vorhandenen Messagingport bearbeiten, klicken Sie auf Weiter. Anweisungen zum Fertigstellen des folgenden Schrittes finden Sie unter Bearbeiten von Messagingports. Klicken Sie auf Fertig stellen, wenn Sie die Änderungen abgeschlossen haben.

Wichtig

  • Wenn Sie einen Umschlag mit einem RELIABLE-Format wählen, müssen Sie auch die Adresse Antwort-URL für Reliable Messaging im Dialogfeld Eigenschaften von BizTalk Server-Gruppe konfigurieren. Weitere Informationen finden Sie unter Konfigurieren von allgemeinen Eigenschaften für eine Servergruppe.

  • Das Format eines Umschlags, das Sie in einem Messagingport festlegen, muss mit dem Format des Dokuments oder der Dokumente übereinstimmen, das bzw. die er enthält. Das Dokumentformat wird durch die Spezifikation ermittelt, auf die in der Dokumentdefinition für ausgehende Dokumente eines zugeordneten Kanals verwiesen wird. Wenn Sie beispielsweise einen Umschlag mit einem X12-Format für einen Messagingport wählen, müssen Sie eine Dokumentdefinition für ausgehende Dokumente für den Kanal wählen, die auf eine X12-Spezifikation zeigt.

Anmerkungen

  • Wenn Umschläge verarbeitet werden, die mit BizTalk Framework 2.0 kompatibel sind, sollte BizTalk Server 2000 in Bezug auf das Ablaufdatum als Endpunkt betrachtet werden. Wenn BizTalk Framework 2.0–kompatible Dokumente an BizTalk Server 2000 versendet werden, entweder von einer Anwendung oder von einem Handelspartner, werden die folgenden Felder überschrieben, wenn sie vorhanden sind. Sind die folgenden Felder nicht vorhanden, werden sie erstellt:
    • Im Unterabschnitt mit den Eigenschaften:

      <prop:identity>

      <prop:sentAt>

      <prop:expiresAt>

    • Im Unterabschnitt mit den Empfangsinformationen:

      <sendTo>

      <address>

      <sendReceiptBy>

  • Für einen Messagingport zu einer Anwendung sind die in der Liste Organisationskennzeichen zur Verfügung stehenden Organisationskennzeichen diejenigen der eigenen Organisation.

  • Wenn Sie den Loopback-Transporttyp verwenden, können Sie keinen Umschlag mit dem RELIABLE-Format auswählen.

  • Wenn Sie ein Zielorganisationskennzeichen zur Verwendung mit X12-Umschlägen wählen, sollten Sie nicht das Organisationskennzeichen mit dem Namen Organisation oder ein anderes Kennzeichen wählen, dessen Qualifizierer länger als 2 Zeichen oder dessen Wert länger als 15 Zeichen ist.

  • Wenn Sie ein Zielorganisationskennzeichen zur Verwendung mit EDIFACT-Umschlägen wählen, sollten Sie nicht das Organisationskennzeichen mit dem Namen Organisation oder ein anderes Kennzeichen wählen, dessen Qualifizierer länger als 4 Zeichen oder dessen Wert länger als 35 Zeichen ist.

  • Wenn Sie einen Umschlag im EDIFACT-Format auswählen, ist der Standardsyntaxbezeichner UNOA (Uppercase Latin Alphabet). Wenn Ihre Daten eine andere Syntax erfordern, wählen Sie einen anderen Syntaxbezeichner aus, indem Sie die Standardwerte für den Messagingport mit dem Kanal-Assistenten außer Kraft setzen. Weitere Informationen finden Sie unter Außerkraftsetzen von Messagingportstandards.

Verwandte Themen

Erstellen von Umschlägen

Erstellen von Messagingports

Bearbeiten von Messagingports

Festlegen von Messagingporteigenschaften

Grundlegendes zu Umschlägen


Festlegen von Eigenschaften für die Sicherheitseinstellungen

  1. Klicken Sie im Messagingport-Assistenten auf der Seite Sicherheitsinformationen im Bereich Codierung in der Liste Typ auf eine der folgenden Optionen:
    • (Keine). Keine Codierung angegeben. Dies ist die Standardeinstellung.

    • MIME. Gibt die Codierung an, die MIME (Multipurpose Internet Mail Extensions) verwendet.

    • Benutzerdefiniert. Gibt die Codierung an, die eine benutzerdefinierte Codierungskomponente verwendet.

    Anmerkungen

    • Sie können nur dann eine benutzerdefinierte Codierungskomponente festlegen und den Klassenbezeichner (CLSID) konfigurieren, wenn Sie das BizTalk-Messaging-Konfigurationsobjektmodell verwenden.

    • Wenn Sie einen Umschlag festlegen, der ein RELIABLE-Format verwendet, oder einen Umschlag, der ein CUSTOM XML-Format ohne eine Umschlagspezifikation verwendet, und wenn Ihr Dokument keine Anhänge hat, ist Ihre Ausgabe nicht MIME-codiert, selbst wenn Sie die MIME-Codierung vorgegeben haben.
  2. Klicken Sie im Bereich Verschlüsselung in der Liste Typ auf eine der folgenden Optionen:
    • (Keine). Keine Verschlüsselung angegeben. Dies ist die Standardeinstellung.

    • S/MIME. Gibt die Codierung an, die S/MIME (Secure Multipurpose Internet Mail Extensions) verwendet.

    • Benutzerdefiniert. Gibt die Codierung an, die eine benutzerdefinierte Verschlüsselungskomponente verwendet.

    Anmerkung

    • Sie können nur dann eine benutzerdefinierte Verschlüsselungskomponente festlegen und den Klassenbezeichner (CLSID) konfigurieren, wenn Sie das BizTalk-Messaging-Konfigurationsobjektmodell verwenden.
  3. Wenn Sie die S/MIME-Verschlüsselung auswählen, klicken Sie im Bereich Verschlüsselung auf Durchsuchen.

    Das Dialogfeld Verschlüsselungszertifikat auswählen wird angezeigt.

  4. Wählen Sie ein Verschlüsselungszertifikat aus.

    Weitere Informationen finden Sie unter Auswählen eines Verschlüsselungszertifikats.

  5. Klicken Sie im Bereich Signatur in der Liste Typ auf eine der folgenden Optionen:
    • (Keine). Keine Signatur angegeben. Dies ist die Standardeinstellung.

    • S/MIME. Gibt eine Signatur an, die S/MIME (Secure Multipurpose Internet Mail Extensions) verwendet.

    • Benutzerdefiniert. Gibt die Codierung an, die eine benutzerdefinierte Signaturkomponente verwendet.

    Anmerkung

    • Sie können nur dann eine benutzerdefinierte Signaturkomponente festlegen und den Klassenbezeichner (CLSID) konfigurieren, wenn Sie das BizTalk-Messaging-Konfigurationsobjektmodell verwenden.
  6. Wenn Sie nicht direkt mit dem Erstellen eines Kanals im Kanal-Assistenten fortfahren möchten, deaktivieren Sie das Kontrollkästchen Kanal für diesen Messagingport erstellen. Klicken Sie andernfalls in der Liste Kanaltyp auf einen der folgenden Kanaltypen:
    • Von einer Organisation

    • Von einer Anwendung

Wenn Sie einen neuen Messagingport erstellen, klicken Sie auf Weiter. Anweisungen zum Fertigstellen des folgenden Schrittes finden Sie unter Erstellen von Messagingports.

Wenn Sie einen vorhandenen Messagingport bearbeiten, klicken Sie auf Weiter. Anweisungen zum Fertigstellen des folgenden Schrittes finden Sie unter Bearbeiten von Messagingports. Klicken Sie auf Fertig stellen, wenn Sie die Änderungen abgeschlossen haben.

Verwandte Themen

Erstellen von Kanälen

Erstellen von Messagingports

Bearbeiten von Messagingports

Festlegen von Messagingporteigenschaften


Auswählen einer Zielorganisation

  1. Klicken Sie im Messagingport-Assistenten auf der Seite Zielorganisation auf Organisation, klicken Sie danach auf Durchsuchen.

    Das Dialogfeld Organisation auswählen wird angezeigt.

  2. Klicken Sie in der Liste Verfügbare Organisationen auf eine Organisation, und klicken Sie dann auf OK.

Informationen zum Festlegen von weiteren Eigenschaften für eine Zielorganisation finden Sie unter Festlegen von Eigenschaften für die Zielorganisation.

Verwandte Themen

Erstellen von Messagingports

Festlegen von Eigenschaften für die Zielorganisation

Festlegen von Messagingporteigenschaften


Auswählen eines Verschlüsselungszertifikats

  1. Klicken Sie im Messagingport-Assistenten auf der Seite Sicherheitsinformationen im Bereich Verschlüsselung in der Liste Typ auf S/MIME und auf Durchsuchen:

    Das Dialogfeld Verschlüsselungszertifikat auswählen wird angezeigt.

  2. Klicken Sie in der Liste Zertifikatname auf einen Zertifikatnamen, und klicken Sie auf OK.

Informationen zum Festlegen von weiteren Sicherheitseigenschaften finden Sie unter Festlegen von Eigenschaften für die Sicherheitseinstellungen.

Anmerkungen

  • Alle Zertifikate müssen mit einem eindeutigen Namen bezeichnet werden. Wenn zwei oder mehr Zertifikate denselben Namen haben, kann nur eines der Zertifikate ausgewählt werden. Nachdem eines der Zertifikate ausgewählt wurde, werden andere Zertifikate mit demselben Namen nicht mehr in der Liste angezeigt.

    Weitere Informationen zu Zertifikaten finden Sie unter Zertifikate - Übersicht.

Verwandte Themen

Erstellen von Messagingports

Festlegen von Messagingporteigenschaften

Festlegen von Eigenschaften für die Sicherheitseinstellungen


Festlegen von Transporteigenschaften

Zu den Transporteigenschaften gehört ein Transporttyp. Der Transporttyp gibt an, welchen Transportdienst Microsoft BizTalk Server 2000 verwendet, um Dokumente an das im Messagingport angegebene Ziel zu übertragen. Zu den Transporteigenschaften kann auch eine bestimmte Adresse gehören, an die die Daten gesendet werden. Die Adresseigenschaften richten sich nach dem ausgewählten Transporttyp.

Dieser Abschnitt beschreibt, wie die Eigenschaften für den primären und den sekundären Transport für einen Messagingport festgelegt werden. Die folgenden Verfahren werden behandelt:

  • Auswählen eines Transporttyps

  • Angeben einer Transportadresse

  • Auswählen einer Anwendungsintegrationskomponente


Auswählen eines Transporttyps

  1. Klicken Sie im Messagingport-Assistenten auf der Seite Zielanwendung oder Zielorganisation im Bereich Primärer Transport oder Sekundärer Transport auf Durchsuchen.

    Das Dialogfeld Primärer Transport oder Sekundärer Transport wird angezeigt.

  2. Klicken Sie in der Liste Transporttyp auf einen der folgenden Transporttypen:
    • Anwendungsintegrationskomponente. Gibt einen Transport an, der eine Anwendungsintegrationskomponente verwendet, die bei BizTalk Server 2000 registriert wurde.

    • File Gibt einen Transport an, der die Komponente SendLocalFile verwendet.

    • HTTP. Gibt einen Transport an, der das Hypertext Transfer Protocol verwendet.

    • HTTPS. Gibt einen Transport an, der das Secure Hypertext Transfer Protocol verwendet.

    • Loopback. Gibt einen Transport an, der das ausgehende Dokument eines Kanals an eine Geschäftsanwendung, Komponente oder an einen XLANG-Ablaufplan zurückgibt, die bzw. der das eingehende Dokument mithilfe eines Synchronous Submit-Methodenaufrufs versendet hatte. Dieser Transporttyp steht nur für einen Messagingport zur Verfügung, der Dokumente an eine Anwendung sendet.

    • Message Queuing. Gibt einen Transport an, der den Message Queuing-Dienst verwendet.

    • SMTP. Gibt einen Transport an, der das Simple Mail Transfer Protocol verwendet.
  3. Führen Sie einen der folgenden Schritte durch:
    • Wenn Sie den Transporttyp Anwendungsintegrationskomponente wählen, lesen Sie bitte im Abschnitt Auswählen einer Anwendungsintegrationskomponente weiter.

    • Wenn Sie den Loopback-Transporttyp verwenden, ist keine Transportadresse erforderlich.

    • Wenn Sie einen anderen Transporttyp auswählen, lesen Sie bitte im Abschnitt Angeben einer Transportadresse weiter.

Anmerkungen

  • Wenn Sie den Message Queuing-Transporttyp wählen und keinen Umschlag verwenden, liegt die Höchstgrenze für Dokumente, die Sie mit diesem Messagingport verarbeiten können, bei 2 MB.

  • Wenn Sie den Message Queuing-Transporttyp wählen und einen Umschlag verwenden, liegt die Höchstgrenze für Dokumente, die Sie mit diesem Messagingport verarbeiten können, bei 4 MB.

  • Bevor Sie den Transporttyp SMTP auswählen können, müssen Sie den SMTP-Host in der BizTalk-Verwaltung konfigurieren. Weitere Informationen finden Sie unter Konfigurieren von allgemeinen Eigenschaften für eine Servergruppe.

  • Die Standardeinstellung für die HTTP-Transportkomponente ist die Verwendung des HTTP-Proxyservers. Dies ist die korrekte Einstellung, um Daten an Websites außerhalb des Firewalls Ihres Unternehmens zu transportieren. Setzen Sie die Standardeinstellung im Kanal außer Kraft, um Daten an Websites zu transportieren, die sich innerhalb des Firewalls Ihres Unternehmens (d. h. innerhalb Ihres Intranets) befinden. Weitere Informationen finden Sie unter Außerkraftsetzen von Messagingportstandards.

  • Der Loopback-Transporttyp kann verwendet werden, um einem eingehenden Dokument ein anderes Format, einen anderen Umschlag oder andere Sicherheit zuzuordnen (Codierung, Verschlüsselung, digitale Signatur) und um dann das ausgehende Dokument synchron an den Aufrufer als Antwortdokument zu versenden.

  • Wenn Sie den Loopback-Transporttyp wählen, können Sie keinen Umschlag mit dem RELIABLE-Format verwenden.

Verwandte Themen

Erstellen von Messagingports

Auswählen einer Anwendungsintegrationskomponente

Festlegen von Messagingporteigenschaften

Festlegen von Transporteigenschaften

Angeben einer Transportadresse


Angeben einer Transportadresse

  1. Klicken Sie im Messagingport-Assistenten auf der Seite Zielanwendung oder Zielorganisation im Bereich Primärer Transport oder Sekundärer Transport auf Durchsuchen.

    Das Dialogfeld Primärer Transport oder Sekundärer Transport wird angezeigt.

  2. Klicken Sie in der Liste Transporttyp auf einen anderen Transporttyp als auf Loopback oder Anwendungsintegrationskomponente.

  3. Geben Sie im Feld Adresse eine Adresse für das Ziel ein.

  4. Wenn Sie den Transporttyp SMTP ausgewählt haben, geben Sie in das Feld E-Mail-Antwortadresse eine Adresse ein.

    Der Server verwendet diese Adresse als die Absenderadresse im Header des ausgehenden Dokuments und als das Ziel für die Antwort-E-Mail.

Informationen zum Festlegen von weiteren Eigenschaften für eine Zielorganisation finden Sie unter Festlegen von Eigenschaften für die Zielorganisation.

Wichtig

  • Beim File-Transporttyp soll die Standardeinstellung der Transportkomponente neue Dateien an eine bestehende Datei im angegebenen Verzeichnis anhängen.

  • Wenn Sie den File-Transport zum Senden mehrerer Dateien mit demselben Namen an dasselbe Verzeichnis verwenden und die Dateien verschiedene Dokumentformate haben oder verschiedene Codeseiten verwenden, tritt bei den Daten in der angehängten Datei eine Datenkorruption auf.

  • Wenn Sie eine neue Datei für jede Dokumentinstanz erstellen möchten, müssen Sie das folgende Dateipfadformat verwenden:

    file://C:\dir\file%tracking_id%.xml

Anmerkungen

  • Für alle Transporttypen außer Message Queuing wird automatisch ein Präfix für die Adresse erstellt. Dieses Präfix ist unbedingt erforderlich und darf nicht gelöscht werden.

  • Für den Message Queuing-Transporttyp müssen die folgenden Bedingungen erfüllt sein, damit die Adresse gültig ist:
    • Verwenden Sie nicht das Präfix queue:// in der Adresse.

    • Verwenden Sie einen Formatnamen statt eines Pfades. Gültige Formatnamen sind z. B.:

      DIRECT=Protocol:<ServerName>\<WarteschlangeName>

      PUBLIC=QueueGUID

      PRIVATE=MachineGUID\QueueNumber

      Weitere Informationen zum Message Queuing finden Sie in der Microsoft-Website (msdn.microsoft.com/library). Suchen Sie in der Website nach "Message Queuing".

  • Für den File-Transporttyp müssen die folgenden Bedingungen erfüllt sein, damit die Adresse gültig ist:
    • Der von Ihnen angegebene Pfadname muss existieren. Der Dateipfad wird nicht automatisch erstellt, und Sie erhalten keine Warnung, wenn er nicht existiert.

    • Sie müssen einen Dateinamen mit einer Erweiterung angeben.

      Beispiel für einen gültigen Dateipfad:

      file://C:\dir\file.xml

  • Beim File-Transporttyp können Sie Zeichen und Symbole verwenden, um den Dateinamen dynamisch zu ändern. Der vom Server erstellte Dateiname enthält alle statischen Zeichen, die Sie in das Feld Adresse eingeben, dazu den Wert des Symbols. Wenn Sie z. B. in das Feld Adresse eingeben: file://C:\Bestellungen\Rechnung_%tracking_id%.xml kann es sein, dass der eigentliche Dateiname angezeigt wird als C:\Bestellungen\Rechnung_{12345678-90AB-CDEF-1234-567890ABCDEF}.

    Die folgende Tabelle enthält die Symbole, die Sie zusammen mit dem File-Transporttyp verwenden können.
    Symbol | Beschreibung | Eindeutiger Dateiname
    %datetime% | Datum und Uhrzeit, in Millisekunden, der Dateierstellung. Die Zeit bezieht sich nicht auf die lokale Uhrzeit, sondern auf die Greenwich Mean Time (GMT). | Nein
    %document_name% | Name des von BizTalk Server verarbeiteten Dokuments | Nein
    %server% | Hostname des Servers, der das Dokument verarbeitet hat. | Nein
    %tracking_id% | Global einheitliche Überwachungsnummer. | Ja
    %uid% | Zähler, der die Zeit in Millisekunden hochzählt. Diese Zahl wird zurückgesetzt, wenn der Server neu gestartet wird. | Nein

  • Die Standardeinstellung für die File-Transportkomponente ist das Anhängen der Dateien. Wenn Sie den File-Transporttyp mit seinen Standardeinstellungen in einem Messagingport auswählen und Antivirus-Software auf dem Server verwenden, auf dem BizTalk Server 2000 installiert ist, und Sie mehrere Dateien mit genau demselben Namen an dasselbe Dateiverzeichnis senden, kann es passieren, dass BizTalk Server 2000 nicht mehr reagiert und neu gestartet werden muss. Sie können dieses Problem beheben, indem Sie die Standardeinstellung für die File-Transportkomponente im Dialogfeld BizTalk SendLocalFile-Eigenschaften von An Datei anhängen in Datei überschreiben ändern. Sie können dieses Problem auch beheben, indem Sie für jede verarbeitete Dokumentinstanz eine eindeutige Datei mithilfe des Dateipfadformats im Messagingport erstellen: file://C:\dir\file%tracking_id%.xml. Weitere Informationen zum Außerkraftsetzen der Einstellung An Datei anhängen für die Dateitransportkomponente in den erweiterten Eigenschaften des Kanals finden Sie unter Außerkraftsetzen von Messagingportstandards.

  • Die Standardeinstellung für die File-Transportkomponente ist das Anhängen von Dateien. Wenn Sie den File-Transporttyp mit seinen Standardeinstellungen auswählen und einen Umschlag mit einem RELIABLE-Format in einem Messagingport auswählen und dann mehrere Dateien gleichzeitig an dasselbe Dateiverzeichnis senden, kann es zu unerwarteten Ergebnissen beim Parsen kommen. Sie können dieses Problem eliminieren, indem Sie die Standardeinstellung für die File-Transportkomponente im Dialogfeld BizTalk SendLocalFile-Eigenschaften von An Datei anhängen in Datei überschreiben ändern. Weitere Informationen zum Außerkraftsetzen der Einstellung An Datei anhängen für die Dateitransportkomponente in den erweiterten Eigenschaften des Kanals finden Sie unter Außerkraftsetzen von Messagingportstandards.

Verwandte Themen

Erstellen von Messagingports

Auswählen einer Anwendungsintegrationskomponente

Auswählen eines Transporttyps

Festlegen von Messagingporteigenschaften

Festlegen von Transporteigenschaften


Auswählen einer Anwendungsintegrationskomponente

  1. Klicken Sie im Messagingport-Assistenten auf der Seite Zielanwendung oder Zielorganisation im Bereich Primärer Transport oder Sekundärer Transport auf Durchsuchen.

    Das Dialogfeld Primärer Transport oder Sekundärer Transport wird angezeigt.

  2. Klicken Sie in der Liste Transporttyp auf Anwendungsintegrationskomponente.

  3. Klicken Sie rechts vom Feld Komponentenname auf Durchsuchen.

    Das Dialogfeld Komponente auswählen wird angezeigt.

  4. Klicken Sie in der Liste Verfügbare Komponenten auf eine Komponente, und klicken Sie auf OK.

Informationen zum Festlegen von weiteren Eigenschaften für eine Zielorganisation finden Sie unter Festlegen von Eigenschaften für die Zielorganisation.

Anmerkung

  • Eine Anwendungsintegrationskomponente muss bei BizTalk Server 2000 registriert sein, bevor sie in der Liste Verfügbare Komponenten verfügbar ist. Weitere Information finden Sie unter Registering Application Integration Components.

Verwandte Themen

Erstellen von Messagingports

Auswählen eines Transporttyps

Festlegen von Messagingporteigenschaften

Festlegen von Transporteigenschaften

Angeben einer Transportadresse


Festlegen von Umschlagstrennzeichen

Die Eigenschaften der Trennzeichen geben an, welche Zeichen verwendet werden, um Daten innerhalb eines Umschlags und die Dokumente eines Austauschs zu trennen. Trennzeichen sind nur für Umschläge erforderlich, die die Formate X12 und EDIFACT verwenden. Sie sind optional für Umschläge, die ein CUSTOM-Format verwenden.

Umschlagstrennzeichen werden festgelegt, wenn Sie einen Umschlag innerhalb eines Messagingports auswählen. Die für einen Messagingport festgelegten Trennzeichen gelten nur für diesen Messagingport. Es können unterschiedliche Trennzeichen für denselben Umschlag festgelegt werden, wenn dieser in einem anderen Messagingport verwendet wird. Dieser Abschnitt beschreibt, wie die Eigenschaften der Trennzeichen festgelegt werden. Die folgenden Verfahren werden behandelt:

  • Festlegen von X12-Trennzeichen

  • Festlegen von EDIFACT-Trennzeichen

  • Festlegen von benutzerdefinierten Trennzeichen


Festlegen von X12-Trennzeichen

  1. Wählen Sie im Messagingport-Assistenten auf der Seite Umschlagsinformationen im Bereich Umschlagsinformationen einen Umschlag mit einem X12-Format aus, und klicken Sie auf Trennzeichen.

    Das Dialogfeld X12-Trennzeichen wird angezeigt.

  2. Geben Sie die Trennzeichenwerte entweder in das Feld Zeichen oder Hexadezimal ein, und klicken Sie auf OK.

In der nachstehenden Tabelle sind die X12-Trennzeichen aufgeführt:

Trennzeichen | Beschreibung
Komponenten-Elementtrennzeichen | Gibt das Zeichen an, das verwendet wird, um Datenkomponenten innerhalb eines Verbunddatenfeldes zu trennen. Ein Verbunddatenfeld ist ein Feld, das aus verschiedenen Unterfeldern besteht.
Elementtrennzeichen | Gibt das Zeichen an, das verwendet wird, um Datenfelder innerhalb eines Datensatzes zu trennen.
Segmentabschlusszeichen | Gibt das Zeichen an, das verwendet wird, um das Ende eines Datensatzes anzuzeigen.

Informationen zum Festlegen weiterer Eigenschaften der Zielorganisation finden Sie unter Festlegen von Eigenschaften für die Umschlagsinformationen.

Anmerkung

  • Sie können für jedes Trennzeichen entweder ein Zeichen in das Feld Zeichen eingeben oder zwei Zeichen in das Feld Hexadezimal. Das Feld Hexadezimal kann verwendet werden, um nicht druckbare Zeichen als Trennzeichen einzugeben, z. B. die EINGABETASTE.

Verwandte Themen

Erstellen von Messagingports

Festlegen von benutzerdefinierten Trennzeichen

Festlegen von EDIFACT-Trennzeichen

Festlegen von Umschlagstrennzeichen

Festlegen von Eigenschaften für die Umschlagsinformationen

Festlegen von Messagingporteigenschaften


Festlegen von EDIFACT-Trennzeichen

  1. Wählen Sie im Messagingport-Assistenten auf der Seite Umschlagsinformationen im Bereich Umschlagsinformationen einen Umschlag mit einem EDIFACT-Format aus, und klicken Sie auf Trennzeichen.

    Das Dialogfeld EDIFACT-Trennzeichen wird angezeigt.

  2. Geben Sie die Trennzeichenwerte entweder im Feld Zeichen oder Hexadezimal ein, und klicken Sie auf OK.

In der nachstehenden Tabelle sind die EDIFACT-Trennzeichen aufgeführt:

Trennzeichen | Beschreibung
Komponenten-Elementtrennzeichen | Gibt das Zeichen an, das verwendet wird, um Datenkomponenten innerhalb eines Verbunddatenfeldes zu trennen. Ein Verbunddatenfeld ist ein Feld, das aus mehreren Unterfeldern besteht.
Elementtrennzeichen | Gibt das Zeichen an, das verwendet wird, um Datenfelder innerhalb eines Datensatzes zu trennen.
Versionsindikator | Gibt das Zeichen an, das verwendet wird um anzuzeigen, dass das folgende Zeichen nicht als Trennzeichen auszuwerten ist.
Segmentabschlusszeichen | Gibt das Zeichen an, das verwendet wird, um das Ende eines Datensatzes anzuzeigen.

Anmerkungen

  • Wenn Sie EDIFACT-Versionsindikatoren verwenden, dürfen sich in Ihren Daten keine Versionsindikatorenzeichen befinden. Sollte dies doch der Fall sein, kann dies dazu führen, dass die Daten die Begrenzungen der physikalischen Zeichengröße für Felder überschreiten.

  • Sie können für jedes Trennzeichen entweder ein Zeichen in das Feld Zeichen eingeben oder zwei Zeichen in das Feld Hexadezimal. Das Feld Hexadezimal kann verwendet werden, um nicht druckbare Zeichen als Trennzeichen einzugeben, z. B. die EINGABETASTE.

  • Das EDIFACT-Dezimaltrennzeichen kann nicht verwendet werden.

Informationen zum Festlegen weiterer Eigenschaften der Zielorganisation finden Sie unter Festlegen von Eigenschaften für die Umschlagsinformationen.

Verwandte Themen

Erstellen von Messagingports

Festlegen von benutzerdefinierten Trennzeichen

Festlegen von Umschlagstrennzeichen

Festlegen von Eigenschaften für die Umschlagsinformationen

Festlegen von Messagingporteigenschaften

Festlegen von X12-Trennzeichen


Festlegen von benutzerdefinierten Trennzeichen

  1. Wählen Sie im Messagingport-Assistenten auf der Seite Umschlagsinformationen im Bereich Umschlagsinformationen einen Umschlag mit einem benutzerdefinierten Format aus, und klicken Sie auf Trennzeichen.

    Das Dialogfeld Benutzerdefinierte Trennzeichen wird angezeigt.

  2. Geben Sie die Trennzeichenwerte entweder im Feld Zeichen oder Hexadezimal ein, und klicken Sie auf OK.

In der nachstehenden Tabelle sind die benutzerdefinierten Trennzeichen aufgeführt:

Trennzeichen | Beschreibung
Unterfeld | Gibt das Zeichen an, das verwendet wird, um Datenkomponenten innerhalb eines Multipart-Datenfeldes zu trennen.
Feld | Gibt das Zeichen an, das verwendet wird, um die Datenfelder innerhalb eines Datensatzes zu trennen.
Escapezeichen | Gibt das Zeichen an, das verwendet wird, um anzuzeigen, dass das folgende Zeichen nicht als Trennzeichen auszuwerten ist.
Datensatz | Gibt das Zeichen an, das verwendet wird, um das Ende eines Datensatzes anzuzeigen.

Anmerkung

  • Sie können für jedes Trennzeichen entweder ein Zeichen in das Feld Zeichen eingeben oder zwei Zeichen in das Feld Hexadezimal. Das Feld Hexadezimal kann verwendet werden, um nicht druckbare Zeichen als Trennzeichen einzugeben, z. B. die EINGABETASTE.

Informationen zum Festlegen weiterer Eigenschaften der Zielorganisation finden Sie unter Festlegen von Eigenschaften für die Umschlagsinformationen.

Verwandte Themen

Erstellen von Messagingports

Festlegen von EDIFACT-Trennzeichen

Festlegen von Umschlagstrennzeichen

Festlegen von Eigenschaften für die Umschlagsinformationen

Festlegen von Messagingporteigenschaften

Festlegen von X12-Trennzeichen


Erstellen und Verwalten von Organisationen

Dieser Abschnitt stellt aufgabenspezifische Informationen zum Erstellen und Verwalten von Organisationen bereit. Es wird dringend empfohlen, den Punkt Grundlegendes zu Organisationen im Abschnitt "Grundbegriffe" zu lesen, damit Sie über das entsprechende Hintergrundwissen zu den Organisationen verfügen.

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Konfigurieren der eigenen Organisation

  • Erstellen von Organisationen

  • Suchen nach Organisationen

  • Bearbeiten von Organisationen

  • Löschen von Organisationen

  • Festlegen von Organisationseigenschaften


Konfigurieren der eigenen Organisation

  1. Klicken Sie im BizTalk-Messaging-Manager im Bereich Nach anderen Elementen suchen auf Organisationen.

  2. Aktivieren Sie im Bereich Nach Organisationen suchen das Kontrollkästchen Eigene Organisation, und klicken Sie auf Jetzt suchen.

  3. Doppelklicken Sie in der Liste Organisationsname auf Eigene Organisation (Standard).

    Das Dialogfeld Organisationseigenschaften wird angezeigt.

  4. Legen Sie auf der Registerkarte Allgemein die allgemeinen Eigenschaften der Organisation fest.

    Weitere Informationen finden Sie unter Festlegen von allgemeinen Organisationseigenschaften.

  5. Klicken Sie auf die Registerkarte Bezeichner, und legen Sie die Eigenschaften des Organisationskennzeichens fest.

    Weitere Informationen finden Sie unter Festlegen von Eigenschaften für das Organisationskennzeichens.

  6. Klicken Sie auf die Registerkarte Anwendungen, und legen Sie die Eigenschaften der Anwendung fest.

    Weitere Informationen dazu finden Sie unter Festlegen von Anwendungseigenschaften.

  7. Nachdem Sie alle erforderlichen Eigenschaften der eigenen Organisation festgelegt haben, klicken Sie auf OK, um das Dialogfeld Organisationseigenschaften zu schließen.

Wichtig

  • Ein Organisationskennzeichen mit dem Namen SMTP-"Von"-Adresse der Reliable Messaging-Bestätigung wird automatisch für die eigene Organisation erstellt. Dieser Bezeichner kann nicht entfernt werden. Sie sollten den Namen oder Qualifizierer für diesen Bezeichner nicht ändern, Sie können jedoch den Wert ändern. Der für diesen Bezeichner angegebene Wert wird beim Versenden der Reliable Messaging-Empfangsbestätigungen, die das SMTP-Transportprotokoll verwenden, als Absenderadresse verwendet. Weitere Informationen zu Empfangsbestätigungen beim Reliable Messaging finden Sie unter Verarbeiten von Empfangsbestätigungen mithilfe von Reliable Messaging.

  • Der für das Organisationskennzeichen angegebene Wert (SMTP-"Von"-Adresse der Reliable Messaging-Bestätigung) wird auch als Absenderadresse verwendet, wenn die Adresse, die für einen offenen Messagingport bereitgestellt wird, eine SMTP-Adresse ist. Weitere Informationen finden Sie unter Offenheitsgrad.

Anmerkungen

  • Sie können die eigene Organisation jederzeit in jeden beliebigen Namen umbenennen.

  • Im BizTalk-Messaging-Manager können Sie nur zur eigenen Organisation Anwendungen hinzufügen.

Verwandte Themen

Bearbeiten von Organisationen

Suchen nach Organisationen

Festlegen von Anwendungseigenschaften

Festlegen von Organisationseigenschaften

Grundlegendes zu Organisationen


Erstellen von Organisationen

  1. Zeigen Sie im BizTalk-Messaging-Manager im Menü Datei auf Neu, und klicken Sie auf Organisation.

    Das Dialogfeld Neue Organisation wird angezeigt.

  2. Legen Sie auf der Registerkarte Allgemein die allgemeinen Eigenschaften der Organisation fest.

    Weitere Informationen finden Sie unter Festlegen von allgemeinen Organisationseigenschaften.

  3. Klicken Sie auf die Registerkarte Bezeichner, und legen Sie die Eigenschaften des Bezeichners der Organisation fest.

    Weitere Informationen finden Sie unter Festlegen von Eigenschaften für das Organisationskennzeichens.

  4. Nachdem Sie alle erforderlichen Eigenschaften festgelegt haben, klicken Sie auf OK, um das Dialogfeld Neue Organisation zu schließen.

Verwandte Themen

Konfigurieren der eigenen Organisation

Löschen von Organisationen

Bearbeiten von Organisationen

Suchen nach Organisationen

Festlegen von Organisationseigenschaften

Grundlegendes zu Organisationen


Suchen nach Organisationen

  1. Klicken Sie im BizTalk-Messaging-Manager im Bereich Nach anderen Elementen suchen auf Organisationen.

  2. Führen Sie eine oder mehrere der folgenden Aktionen durch:
    • Löschen Sie alle Suchkriterien, und klicken Sie auf Jetzt suchen, um alle Organisationen zu suchen.

    • Geben Sie im Bereich Nach Organisationen suchen in das Feld Organisationsname den Namen der Organisation ein, die Sie suchen möchten, um nach Organisationen eines bestimmten Namens zu suchen, und klicken Sie auf Jetzt suchen. Sie können einen unvollständigen Namen eingeben, und die Suche gibt alle möglichen Namen zurück, die mit dem unvollständigen Namen übereinstimmen.

    • Aktivieren Sie das Kontrollkästchen Eigene Organisation, und klicken auf Jetzt suchen, um nur nach der eigenen Organisation zu suchen.

Anmerkungen

  • Klicken Sie auf Suche löschen, um die Suchkriterien und Suchergebnisse zu löschen.

  • Wenn nach einer großen Anzahl von Objekten gesucht werden soll, dauert es möglicherweise mehrere Minuten, bis alle Objekte zurückgegeben werden. Mithilfe von Auswahlkriterien können Sie die bei einer Suche zurückgegebenen Objekte eingrenzen.

  • Die Standardanzahl von Elementen, die bei einer Suche zurückgegeben werden, ist 500. Diese Anzahl können Sie anpassen. Weitere Informationen finden Sie unter Festlegen vonServer-Verbindungsoptionen.

  • Sie können die folgenden Platzhalter in den Suchkriterien verwenden.
    Platzhalter | Beschreibung | Beispiel
    % Eine Zeichenfolge aus null oder mehr Zeichen Der Eintrag %open% findet alle Namen, die das Wort "open" enthalten.
    _ (Unterstrich) | Beliebiges einzelnes Zeichen | Der Eintrag _ean findet alle Namen mit vier Buchstaben, die auf "ean" enden (Dean, Sean usw.).
    [ ] Beliebiges einzelnes Zeichen im angegebenen Bereich ([a-f]) oder in der angegebenen Menge ([abcdef]). Der Eintrag [C-P]arsen findet alle Namen, die auf "arsen" enden und mit einem beliebigen einzelnen Zeichen zwischen C und P beginnen, z. B.: Carsen, Larsen usw.
    [^] Beliebiges einzelnes Zeichen, das sich nicht im angegebenen Bereich ([^a-f]) oder in der angegebenen Menge ([^abcdef]) befindet. Der Eintrag de[^s]% findet alle Namen, die mit "de" beginnen und deren dritter Buchstabe nicht "s" ist.

Verwandte Themen

Löschen von Organisationen

Bearbeiten von Organisationen

Grundlegendes zu Organisationen


Bearbeiten von Organisationen

  1. Klicken Sie im BizTalk-Messaging-Manager in der Liste Organisationsname auf die Organisation, die Sie bearbeiten möchten.

    Weitere Informationen zum Suchen nach Organisationen finden Sie unter Suchen nach Organisationen.

  2. Klicken Sie im Menü Datei auf Bearbeiten.

    Das Dialogfeld Organisationseigenschaften wird angezeigt.

  3. Bearbeiten Sie auf der Registerkarte Allgemein die Eigenschaften, die Sie ändern möchten.

    Weitere Informationen finden Sie unter Festlegen von allgemeinen Organisationseigenschaften.

  4. Klicken Sie auf die Registerkarte Bezeichner, und bearbeiten Sie alle Eigenschaften der Organisationskennzeichen, die Sie ändern möchten.

    Weitere Informationen finden Sie unter Festlegen von Eigenschaften für das Organisationskennzeichens.

  5. Wenn Sie die eigene Organisation bearbeiten, klicken Sie auf die Registerkarte Anwendungen, und bearbeiten Sie die Eigenschaften der Anwendung, die Sie ändern möchten.

    Weitere Informationen dazu finden Sie unter Festlegen von Anwendungseigenschaften.

  6. Nachdem Sie alle Eigenschaften bearbeitet haben, die Sie ändern möchten, klicken Sie auf OK, um das Dialogfeld Organisationseigenschaften zu schließen.

Wichtig

  • Ein Organisationskennzeichen mit dem Namen SMTP-"Von"-Adresse der Reliable Messaging-Bestätigung wird automatisch für die eigene Organisation erstellt. Dieser Bezeichner kann nicht entfernt werden. Sie sollten den Namen oder Qualifizierer dieses Bezeichners nicht ändern, Sie können aber den Wert ändern. Der Wert für diesen Bezeichner wird beim Versand von Reliable Messaging-Empfangsbestätigungen, die das SMTP-Transportprotokoll verwenden, als Absenderadresse verwendet. Weitere Informationen zu Empfangsbestätigungen beim Reliable Messaging finden Sie unter Verarbeiten von Empfangsbestätigungen mithilfe von Reliable Messaging.

  • Der für das Organisationskennzeichen angegebene Wert (SMTP-"Von"-Adresse der Reliable Messaging-Bestätigung) wird auch als Absenderadresse verwendet, wenn die Adresse, die für einen offenen Messagingport bereitgestellt wird, eine SMTP-Adresse ist. Weitere Informationen finden Sie unter Offenheitsgrad.

Anmerkung

  • Im BizTalk-Messaging-Manager können Sie Anwendungen nur zur eigenen Organisation hinzufügen.

Verwandte Themen

Erstellen von Organisationen

Löschen von Organisationen

Suchen nach Organisationen

Grundlegendes zu Organisationen


Löschen von Organisationen

  1. Klicken Sie im BizTalk-Messaging-Manager in der Liste Organisationsname auf die Organisation, die Sie löschen möchten.

    Weitere Informationen zum Suchen nach Organisationen finden Sie unter Suchen nach Organisationen.

  2. Klicken Sie im Menü Datei auf Löschen.

Anmerkungen

  • Wenn eine Organisation in einem Messagingport oder in einem Kanal verwendet wird, können Sie diese nicht löschen. Sie müssen zunächst alle Kanäle und Messagingports löschen, die diese Organisation verwenden.

  • Sie können die eigene Organisation nicht löschen.

Verwandte Themen

Erstellen von Organisationen

Bearbeiten von Organisationen

Suchen nach Organisationen

Grundlegendes zu Organisationen


Festlegen von Organisationseigenschaften

Dieser Abschnitt stellt aufgabenspezifische Informationen zum Konfigurieren der Eigenschaften einer Organisation bereit. Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Festlegen von allgemeinen Organisationseigenschaften

  • Festlegen von Eigenschaften für das Organisationskennzeichens

  • Festlegen von Anwendungseigenschaften


Festlegen von allgemeinen Organisationseigenschaften

  1. Zeigen Sie im Menü Datei auf Neu, und klicken Sie auf Organisation, oder doppelklicken Sie in der Liste Organisationsname auf eine Organisation.

    Das Dialogfeld Neue Organisation bzw. Organisationseigenschaften wird angezeigt.

  2. Geben Sie auf der Registerkarte Allgemein in das Feld Organisationsname einen eindeutigen Namen für die Organisation ein.

  3. Geben Sie im Feld Kommentare beliebige Kommentare zur Organisation ein.

Verwandte Themen

Konfigurieren der eigenen Organisation

Erstellen von Organisationen

Bearbeiten von Organisationen

Festlegen von Organisationseigenschaften


Festlegen von Eigenschaften für das Organisationskennzeichens

Organisationskennzeichen werden dazu verwendet, Organisationen eindeutig zu kennzeichnen. Eine Organisation kann mehr als einen Organisationskennzeichen haben, aber jeder Bezeichner muss für diese Organisation eindeutig sein.

Wenn Sie eine neue Organisation erstellen, wird automatisch ein Organisationskennzeichen mit dem Namen Organisation erstellt. Der Qualifizierer für diesen Bezeichner ist Organisationsname, und der Wert ist der Name, den Sie der Organisation geben. Dieser Server verwendet dieses Organisationskennzeichen als den Standardbezeichner, sofern Sie nicht zusätzliche Bezeichner erstellen und einen davon als Standardbezeichner zuweisen.

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Hinzufügen von Organisationskennzeichen

  • Bearbeiten von Organisationskennzeichen

  • Entfernen von Organisationskennzeichen

Verwandte Themen

Konfigurieren der eigenen Organisation

Erstellen von Organisationen

Bearbeiten von Organisationen

Organisationskennzeichen

Festlegen von Organisationseigenschaften


Hinzufügen von Organisationskennzeichen

  1. Zeigen Sie im Menü Datei auf Neu, und klicken Sie auf Organisation, oder doppelklicken Sie in der Liste Organisationsname auf eine Organisation.

    Das Dialogfeld Neue Organisation bzw. Organisationseigenschaften wird angezeigt.

  2. Klicken Sie auf die Registerkarte Bezeichner und auf Hinzufügen.

    Das Dialogfeld Neuer Bezeichner wird angezeigt.

  3. Führen Sie im Bereich Name einen der folgenden Schritte durch:
    • Klicken Sie auf Standard, und klicken Sie auf einen Namen in der Liste.

    • Klicken Sie auf Benutzerdefiniert, und geben Sie in das Feld einen eindeutigen Namen ein. Geben Sie dann in das Feld Qualifizierer einen Qualifizierer für den Bezeichner ein.
  4. Geben Sie in das Feld Wert einen Wert für den Bezeichner ein.

  5. Wenn Sie diesen Bezeichner als den Standardbezeichner für die Organisation festlegen möchten, aktivieren Sie das Kontrollkästchen Als Standard festlegen. Achten Sie andernfalls darauf, dass das Kontrollkästchen deaktiviert ist.

  6. Klicken Sie auf OK, um das Dialogfeld Neuer Bezeichner zu schließen.

Wichtig

  • Ein Organisationskennzeichen mit dem Namen SMTP-"Von"-Adresse der Reliable Messaging-Bestätigung wird automatisch für die eigene Organisation erstellt. Dieser Bezeichner kann nicht entfernt werden. Sie sollten den Namen oder Qualifizierer dieses Bezeichners nicht ändern, Sie können aber den Wert ändern. Der Wert für diesen Bezeichner wird beim Versand von Reliable Messaging-Empfangsbestätigungen, die das SMTP-Transportprotokoll verwenden, als Absenderadresse verwendet. Weitere Informationen finden Sie unter Verarbeiten von Empfangsbestätigungen mithilfe von Reliable Messaging.

  • Der für das Organisationskennzeichen angegebene Wert (SMTP-"Von"-Adresse der Reliable Messaging-Bestätigung) wird auch als Absenderadresse verwendet, wenn die Adresse, die für einen offenen Messagingport bereitgestellt wird, eine SMTP-Adresse ist. Weitere Informationen finden Sie unter Offenheitsgrad.

Anmerkungen

  • Es kann nur ein Bezeichner als der Standardbezeichner für eine Organisation zugewiesen werden. Der Standardbezeichner wird verwendet, um eine Organisation zu bezeichnen, sofern Sie nicht einen anderes Organisationskennezeichen in einem Kanal oder Messagingport angegeben haben.

  • Wenn Sie eine neue Organisation erstellen, wird automatisch ein Organisationskennzeichen mit dem Namen Organisation erstellt. Der Qualifizierer für diesen Bezeichner ist Organisationsame, und der Wert ist der Name der Organisation. Sie können weitere Bezeichner erstellen, aber dieser Bezeichner kann weder geändert noch entfernt werden.

  • Wenn der Server beim Verarbeiten eines eingehenden Dokuments mit einem anderen Format als EDIFACT einen leeren Qualifizierer und einen nicht leeren Wert findet, konvertiert er den leeren Qualifizierer zu Organisationsname.

  • Wenn der Server beim Verarbeiten eines eingehenden Dokuments im EDIFACT-Format einen leeren Qualifizierer und einen nicht leeren Wert findet, konvertiert er den leeren Qualifizierer in einen Bindestrich (-). Wenn Sie ein eingehendes Dokument im EDIFACT-Format verarbeiten möchten, das einen leeren Qualifizierer hat, oder einen ausgehenden Umschlag mit einem leeren Qualifizierer, müssen Sie ein benutzerdefiniertes Organisationskennzeichen erstellen, der einen Bindestrich als Qualifizierer hat. Für ein ausgehendes EDIFACT-Dokument konvertiert der Server den Bindestrich in einen leeren Qualifizierer.

  • Wenn Sie ein Organisationskennzeichen für die Verwendung mit EDIFACT-Umschlägen erstellen, darf der Qualifizierer nicht mehr als 4 Zeichen lang sein, und der Wert darf nicht 35 Zeichen übersteigen.

  • Wenn Sie einen Organisationskennzeichen zur Verwendung mit X12-Umschlägen erstellen, darf der Qualifizierer nicht länger als 2 Zeichen sein, und der Wert darf nicht 15 Zeichen übersteigen.

Verwandte Themen

Konfigurieren der eigenen Organisation

Erstellen von Organisationen

Bearbeiten von Organisationskennzeichen

Bearbeiten von Organisationen

Organisationskennzeichen

Entfernen von Organisationskennzeichen

Festlegen von Eigenschaften für das Organisationskennzeichens


Bearbeiten von Organisationskennzeichen

  1. Zeigen Sie im Menü Datei auf Neu, und klicken Sie auf Organisation, oder doppelklicken Sie in der Liste Organisationsname auf eine Organisation.

    Das Dialogfeld Neue Organisation bzw. Organisationseigenschaften wird angezeigt.

  2. Klicken Sie auf die Registerkarte Bezeichner.

  3. Klicken Sie in der Liste Organisationskennzeichen auf das Organisationkennzeichen, den Sie bearbeiten möchten, und klicken Sie auf Bearbeiten.

    Das Dialogfeld Bezeichnereigenschaften wird angezeigt.

  4. Führen Sie im Bereich Name einen der folgenden Schritte durch:
    • Klicken Sie auf Standard, und klicken Sie auf einen Namen in der Liste.

    • Klicken Sie auf Benutzerdefiniert, und geben Sie in das Feld einen eindeutigen Namen ein. Geben Sie dann in das Feld Qualifizierer einen Qualifizierer für den Bezeichner ein.
  5. Geben Sie in das Feld Wert einen Wert für den Bezeichner ein.

  6. Wenn Sie diesen Bezeichner als den Standardbezeichner für die Organisation festlegen möchten, aktivieren Sie das Kontrollkästchen Als Standard festlegen. Achten Sie andernfalls darauf, dass das Kontrollkästchen deaktiviert ist.

  7. Klicken Sie auf OK, um das Dialogfeld Bezeichnereigenschaften zu schließen.

Wichtig

  • Ein Organisationskennzeichen mit dem Namen SMTP-"Von"-Adresse der Reliable Messaging-Bestätigung wird automatisch für die eigene Organisation erstellt. Sie sollten den Namen oder Qualifizierer dieses Bezeichners nicht ändern, Sie können aber den Wert ändern. Dieser Bezeichner kann nicht entfernt werden. Der Wert für diesen Bezeichner wird beim Versenden von Reliable Messaging-Empfangsbestätigungen, die das SMTP-Transportprotokoll verwenden, als Absenderadresse verwendet. Weitere Informationen finden Sie unter Verarbeiten von Empfangsbestätigungen mithilfe von Reliable Messaging.

  • Der für das Organisationskennzeichen angegebene Wert (SMTP-"Von"-Adresse der Reliable Messaging-Bestätigung) wird auch als Absenderadresse verwendet, wenn die Adresse, die für einen offenen Messagingport bereitgestellt wird, eine SMTP-Adresse ist. Weitere Informationen finden Sie unter Offenheitsgrad.

Anmerkungen

  • Es kann nur ein Bezeichner als der Standardbezeichner für eine Organisation zugewiesen werden. Der Standardbezeichner wird verwendet, um eine Organisation zu bezeichnen, sofern Sie nicht eine anderes Organisationkennzeichen in einem Kanal oder Messagingport angegeben haben.

  • Wenn Sie eine neue Organisation erstellen, wird automatisch ein Organisationskennzeichen mit dem Namen Organisation erstellt. Der Qualifizierer für diesen Bezeichner ist Organisationsname, und der Wert ist der Name der Organisation. Sie können weitere Bezeichner erstellen, aber dieser Bezeichner kann weder geändert noch entfernt werden.

  • Wenn der Server beim Verarbeiten eines eingehenden Dokuments mit einem anderen Format als EDIFACT einen leeren Qualifizierer und einen nicht leeren Wert findet, konvertiert er den leeren Qualifizierer zu Organisationsname.

  • Wenn der Server beim Verarbeiten eines eingehenden Dokuments im EDIFACT-Format einen leeren Qualifizierer und einen nicht leeren Wert findet, konvertiert er den leeren Qualifizierer in einen Bindestrich (-). Wenn Sie ein eingehendes Dokument im EDIFACT-Format verarbeiten möchten, das einen leeren Qualifizierer hat, oder einen ausgehenden Umschlag mit einem leeren Qualifizierer, müssen Sie ein benutzerdefiniertes Organisationskennzeichen erstellen, der einen Bindestrich als Qualifizierer hat. Für ein ausgehendes EDIFACT-Dokument konvertiert der Server den Bindestrich in einen leeren Qualifizierer.

  • Wenn Sie ein Organisationskennzeichen für die Verwendung mit EDIFACT-Umschlägen erstellen, darf der Qualifizierer nicht mehr als 4 Zeichen lang sein, und der Wert darf nicht 35 Zeichen übersteigen.

  • Wenn Sie ein Organisationskennzeichen zur Verwendung mit X12-Umschlägen erstellen, darf der Qualifizierer nicht länger als 2 Zeichen sein, und der Wert darf nicht 15 Zeichen übersteigen.

Verwandte Themen

Hinzufügen von Organisationskennzeichen

Konfigurieren der eigenen Organisation

Erstellen von Organisationen

Bearbeiten von Organisationen

Organisationskennzeichen

Entfernen von Organisationskennzeichen

Festlegen von Eigenschaften für das Organisationskennzeichens


Entfernen von Organisationskennzeichen

  1. Zeigen Sie im Menü Datei auf Neu, und klicken Sie auf Organisation, oder doppelklicken Sie in der Liste Organisationsname auf eine Organisation.

    Das Dialogfeld Neue Organisation bzw. Organisationseigenschaften wird angezeigt.

  2. Klicken Sie auf die Registerkarte Bezeichner.

  3. Klicken Sie in der Liste Organisationskennzeichen auf den Bezeichner, den Sie entfernen möchten, und klicken Sie auf Entfernen.

Anmerkungen

  • Das zugewiesene Standard-Organisationskennzecihen kann nicht entfernt werden, bevor Sie nicht einen anderen Bezeichner als Standardbezeichner festgelegt haben.

  • Das Organisationskennzeichen mit dem Namen Organisation wird automatisch beim Erstellen einer Organisation erstellt. Dieses Organisationskennzeichen kann nicht entfernt werden.

Verwandte Themen

Hinzufügen von Organisationskennzeichen

Konfigurieren der eigenen Organisation

Erstellen von Organisationen

Bearbeiten von Organisationskennzeichen

Bearbeiten von Organisationen

Organisationskennzeichen

Festlegen von Eigenschaften für das Organisationskennzeichens


Festlegen von Anwendungseigenschaften

Im BizTalk-Messaging-Manager können Sie Anwendungen nur zur eigenen Organisation hinzufügen. Die Anwendungen, die Sie erstellen, ermöglichen Ihnen, den Ablauf der Dokumente zwischen BizTalk Server 2000 und internen Anwendungen innerhalb Ihrer Organisation zu ermitteln und zu überwachen. Sie können eine Anwendung der eigenen Organisation als eine Quellanwendung in einem Kanal oder eine Zielanwendung in einem Messagingport bestimmen.

Die eigene Organisation kann über eine beliebige Anzahl von Anwendungen verfügen. Jeder Anwendungsname muss eindeutig sein. Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Hinzufügen von Anwendungen

  • Bearbeiten von Anwendungen

  • Entfernen von Anwendungen

Verwandte Themen

Konfigurieren der eigenen Organisation

Bearbeiten von Organisationen

Festlegen von Organisationseigenschaften


Hinzufügen von Anwendungen

  1. Klicken Sie im BizTalk-Messaging-Manager im Bereich Nach anderen Elementen suchen auf Organisationen.

  2. Aktivieren Sie im Bereich Nach Organisationen suchen das Kontrollkästchen Eigene Organisation, und klicken Sie auf Jetzt suchen.

  3. Doppelklicken Sie in der Liste Organisationsname auf Eigene Organisation (Standard).

    Das Dialogfeld Organisationseigenschaften wird angezeigt.

  4. Klicken Sie auf der Registerkarte Anwendungen auf Hinzufügen.

    Das Dialogfeld Neue Anwendung wird angezeigt.

  5. Geben Sie im Feld Anwendungsname einen eindeutigen Namen für die Anwendung ein, und klicken Sie auf OK.

Anmerkung

  • Im BizTalk-Messaging-Manager können Sie Anwendungen nur für die eigene Organisation hinzufügen, bearbeiten und entfernen.

Verwandte Themen

Konfigurieren der eigenen Organisation

Bearbeiten von Anwendungen

Bearbeiten von Organisationen

Entfernen von Anwendungen

Festlegen von Anwendungseigenschaften


Bearbeiten von Anwendungen

  1. Klicken Sie im BizTalk-Messaging-Manager im Bereich Nach anderen Elementen suchen auf Organisationen.

  2. Aktivieren Sie im Bereich Nach Organisationen suchen das Kontrollkästchen Eigene Organisation, und klicken Sie auf Jetzt suchen.

  3. Doppelklicken Sie in der Liste Organisationsname auf Eigene Organisation (Standard).

    Das Dialogfeld Organisationseigenschaften wird angezeigt.

  4. Klicken Sie auf der Registerkarte Anwendungen in der Liste Anwendungen auf die Anwendung, die Sie bearbeiten möchten, und klicken Sie auf Bearbeiten.

    Das Dialogfeld Anwendungseigenschaften wird angezeigt.

  5. Geben Sie im Feld Anwendungsname einen eindeutigen Namen für die Anwendung ein, und klicken Sie auf OK.

Anmerkung

  • Im BizTalk-Messaging-Manager können Sie Anwendungen nur für die eigene Organisation hinzufügen, bearbeiten und entfernen.

Verwandte Themen

Hinzufügen von Anwendungen

Konfigurieren der eigenen Organisation

Bearbeiten von Organisationen

Entfernen von Anwendungen

Festlegen von Anwendungseigenschaften


Entfernen von Anwendungen

  1. Klicken Sie im BizTalk-Messaging-Manager im Bereich Nach anderen Elementen suchen auf Organisationen.

  2. Aktivieren Sie im Bereich Nach Organisationen suchen das Kontrollkästchen Eigene Organisation, und klicken Sie auf Jetzt suchen.

  3. Doppelklicken Sie in der Liste Organisationsname auf Eigene Organisation (Standard).

    Das Dialogfeld Organisationseigenschaften wird angezeigt.

  4. Klicken Sie auf der Registerkarte Anwendungen in der Liste Anwendungen auf die Anwendung, die Sie entfernen möchten, und klicken Sie auf Entfernen.

Anmerkung

  • Im BizTalk-Messaging-Manager können Sie Anwendungen nur für die eigene Organisation hinzufügen, bearbeiten und entfernen.

Verwandte Themen

Hinzufügen von Anwendungen

Konfigurieren der eigenen Organisation

Bearbeiten von Organisationen

Festlegen von Anwendungseigenschaften


Erstellen und Verwalten von Dokumentdefinitionen

Dieser Abschnitt stellt aufgabenspezifische Informationen zum Erstellen und Verwalten von Dokumentdefinitionen bereit. Es wird dringend empfohlen, dass Sie Grundlegendes zu Dokumentdefinitionen im Abschnitt "Grundbegriffe" lesen, um die Dokumentdefinitionen vollständig zu verstehen.

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Erstellen von Dokumentdefinitionen

  • Suchen nach Dokumentdefinitionen

  • Bearbeiten von Dokumentdefinitionen

  • Löschen von Dokumentdefinitionen

  • Festlegen von Dokumentdefinitionseigenschaften


Erstellen von Dokumentdefinitionen

  1. Zeigen Sie im BizTalk-Messaging-Manager im Menü Datei auf Neu, und klicken Sie dann auf Dokumentdefinition.

    Das Dialogfeld Neue Dokumentdefinition wird angezeigt.

  2. Legen Sie auf der Registerkarte Allgemein die allgemeinen Eigenschaften fest.

    Weitere Informationen finden Sie unter Festlegen von Dokumentdefinitionseigenschaften.

  3. Klicken Sie auf die Registerkarte Globale Überwachung, und legen Sie die Überwachungseigenschaften fest.

    Weitere Informationen finden Sie unter Festlegen von globalen Überwachungseigenschaften.

  4. Klicken Sie auf die Registerkarte Auswahlkriterien, und legen Sie die Eigenschaften für die Auswahlkriterien fest.

    Weitere Informationen finden Sie unter Festlegen von Eigenschaften für Auswahlkriterien.

  5. Wenn Sie alle gewünschten Eigenschaften festgelegt haben, klicken Sie auf OK, um das Dialogfeld Neue Dokumentdefinition zu schließen.

Anmerkungen

  • Sie können eine Dokumentdefinition nicht Kanal für Reliable Messaging-Bestätigung oder BizTalk-Standardempfangsbestätigung nennen, da es sich dabei um reservierte Systemnamen handelt.

  • Sie müssen eine Spezifikation auswählen, um globale Überwachungsfelder für die Dokumentdefinition festlegen zu können.

  • Wenn Sie eine Dokumentdefinition in einem Kanal auswählen, können Sie die globalen Überwachungsfelder außer Kraft setzen, indem Sie unterschiedliche zu überwachende Spezifikationsfelder auswählen. Weitere Informationen finden Sie unter Auswählen von Spezifikationsfeldern in einem Kanal.

  • Wenn Sie eine Dokumentdefinition speichern, die auf eine Spezifikation außerhalb der lokalen Domäne verweist, erhalten Sie möglicherweise eine Fehlermeldung. Wenn eine Fehlermeldung angezeigt wird, downloaden und konfigurieren Sie das Dienstprogramm WinHTTP Proxy Configuration. Gehen Sie zum Downloaden des Dienstprogramms zur Microsoft MSDN-Website (msdn.microsoft.com/downloads/default.asp), und suchen Sie die Seite "WinHTTP Proxy Configuration Utility". Diese Seite befindet sich im Kapitel zu XMLim Buch Web Development.

Verwandte Themen

Löschen von Dokumentdefinitionen

Bearbeiten von Dokumentdefinitionen

Suchen nach Dokumentdefinitionen

Grundlegendes zu Dokumentdefinitionen


Suchen nach Dokumentdefinitionen

  1. Klicken Sie im BizTalk-Messaging-Manager im Bereich Nach anderen Elementen suchen auf Dokumentdefinitionen.

  2. Löschen Sie alle Suchkriterien, und klicken Sie auf Jetzt suchen, um nach allen Dokumentdefinitionen zu suchen.

    Oder

    Geben Sie im Bereich Nach Dokumentdefinitionen suchen in das Feld Name der Dokumentdefinition den Namen der gesuchten Dokumentdefinition ein, und klicken Sie auf Jetzt suchen, um nach einer Dokumentdefinition mit einem bestimmten Namen zu suchen. Sie können einen unvollständigen Namen eingeben, und die Suche gibt alle möglichen Namen zurück, die mit dem unvollständigen Namen übereinstimmen.

Anmerkungen

  • Klicken Sie auf Suche löschen, um die Suchkriterien und Suchergebnisse zu löschen.

  • Wenn nach einer großen Anzahl von Objekten gesucht werden soll, dauert es möglicherweise mehrere Minuten, bis alle Objekte zurückgegeben werden. Mithilfe von Auswahlkriterien können Sie die bei einer Suche zurückgegebenen Objekte eingrenzen.

  • Die Standardanzahl von Elementen, die bei einer Suche zurückgegeben werden, ist 500. Diese Anzahl können Sie anpassen. Weitere Informationen finden Sie unter Festlegen von Serververbindungsoptionen.

  • Sie können die folgenden Platzhalter für die Suchkriterien verwenden:
    Platzhalter | Beschreibung | Beispiel
    % Eine Zeichenfolge aus null oder mehr Zeichen. Der Eintrag '%open%' findet alle Namen, die das Wort 'open' enthalten.
    _ (Unterstrich) | Beliebiges einzelnes Zeichen. | Der Eintrag '_ean' findet alle Namen mit vier Buchstaben, die auf ean enden (Dean, Sean usw.).
    [ ] Beliebiges einzelnes Zeichen im angegebenen Bereich ([a-f]) oder in der angegebenen Menge ([abcdef]). Der Eintrag '[C-P]arsen' findet alle Namen, die auf arsen enden und mit einem beliebigen einzelnen Zeichen zwischen C und P beginnen, z. B.: Carsen, Larsen usw.
    [^] Beliebiges einzelnes Zeichen, das sich nicht im angegebenen Bereich ([^a-f]) oder in der angegebenen Menge ([^abcdef]) befindet. Der Eintrag 'de[^s]%' findet alle Namen, die mit de beginnen und deren dritter Buchstabe nicht s ist.

Verwandte Themen

Löschen von Dokumentdefinitionen

Bearbeiten von Dokumentdefinitionen

Grundlegendes zu Dokumentdefinitionen


Bearbeiten von Dokumentdefinitionen

  1. Klicken Sie im BizTalk-Messaging-Manager in der Liste Dokumentdefinitionsname auf die Dokumentdefinition, die Sie bearbeiten möchten.

    Weitere Informationen zum Suchen nach Dokumentdefinitionen finden Sie unter Suchen nach Dokumentdefinitionen.

  2. Klicken Sie im Menü Datei auf Bearbeiten.

    Das Dialogfeld Dokumentdefinitionseigenschaften wird angezeigt.

  3. Bearbeiten Sie auf der Registerkarte Allgemein die allgemeinen Eigenschaften.

    Weitere Informationen finden Sie unter Festlegen von Dokumentdefinitionseigenschaften.

  4. Klicken Sie auf die Registerkarte Globale Überwachung, und bearbeiten Sie die Überwachungseigenschaften.

    Weitere Informationen finden Sie unter Festlegen von globalen Überwachungseigenschaften.

  5. Klicken Sie auf die Registerkarte Auswahlkriterien, und bearbeiten Sie die Eigenschaften für die Auswahlkriterien.

    Weitere Informationen finden Sie unter Festlegen von Eigenschaften für Auswahlkriterien.

  6. Wenn Sie alle gewünschten Eigenschaften bearbeitet haben, klicken Sie auf OK, um das Dialogfeld Dokumentdefinitionseigenschaften zu schließen.

Anmerkungen

  • Sie können eine Dokumentdefinition nicht Kanal für Reliable Messaging-Bestätigung oder BizTalk-Standardempfangsbestätigung nennen, da es sich dabei um reservierte Systemnamen handelt.

  • Sie müssen eine Spezifikation auswählen, um globale Überwachungsfelder für die Dokumentdefinition festlegen zu können.

  • Wenn Sie eine Dokumentdefinition speichern, die auf eine Spezifikation außerhalb der lokalen Domäne verweist, erhalten Sie möglicherweise eine Fehlermeldung. Wenn eine Fehlermeldung angezeigt wird, downloaden und konfigurieren Sie das Dienstprogramm WinHTTP Proxy Configuration. Gehen Sie zum Downloaden des Dienstprogramms zur Microsoft MSDN-Website (msdn.microsoft.com/downloads/default.asp), und suchen Sie die Seite "WinHTTP Proxy Configuration Utility". Diese Seite befindet sich im Kapitel zu XML im Buch Web Development.

Verwandte Themen

Erstellen von Dokumentdefinitionen

Löschen von Dokumentdefinitionen

Suchen nach Dokumentdefinitionen

Grundlegendes zu Dokumentdefinitionen


Löschen von Dokumentdefinitionen

  1. Klicken Sie im BizTalk-Messaging-Manager in der Liste Dokumentdefinitionsname auf die Dokumentdefinition, die Sie löschen möchten.

    Weitere Informationen zum Suchen nach Dokumentdefinitionen finden Sie unter Suchen nach Dokumentdefinitionen.

  2. Klicken Sie im Menü Datei auf Löschen.

Anmerkung

  • Wenn eine Dokumentdefinition in einem Kanal verwendet wird, können Sie diese nicht löschen. Sie müssen zunächst alle Kanäle löschen, die diese Dokumentdefinition verwenden.

Verwandte Themen

Erstellen von Dokumentdefinitionen

Bearbeiten von Dokumentdefinitionen

Suchen nach Dokumentdefinitionen

Grundlegendes zu Dokumentdefinitionen


Festlegen von Dokumentdefinitionseigenschaften

Dieser Abschnitt stellt aufgabenspezifische Informationen zum Konfigurieren der Eigenschaften einer Dokumentdefinition bereit. Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Festlegen von Dokumentdefinitionseigenschaften

  • Auswählen einer Dokumentspezifikation

  • Festlegen von globalen Überwachungseigenschaften

  • Festlegen von Eigenschaften für Auswahlkriterien


Festlegen von Dokumentdefinitionseigenschaften

  1. Klicken Sie im Dialogfeld Neue Dokumentdefinition oder Dokumentdefinitionseigenschaften auf die Registerkarte Allgemein.

  2. Geben Sie in das Feld Dokumentdefinitionsname einen eindeutigen Namen für die Dokumentdefinition ein.

  3. Aktivieren Sie das Kontrollkästchen Dokumentspezifikation.

  4. Klicken Sie auf Durchsuchen, um eine Dokumentspezifikation auszuwählen.

    Weitere Informationen finden Sie unter Auswählen einer Dokumentspezifikation.

Anmerkungen

  • Die Spezifikation eines Dokuments für eine Dokumentdefinition ist optional. Wenn Sie jedoch keine Spezifikation auswählen, können Sie keine globalen Überwachungsfelder festlegen, und die mit der Dokumentdefinition verarbeiteten Daten:
    • Werden nicht von ihrem nativen Format in XML übersetzt.

    • Werden nicht anhand einer Spezifikation überprüft.

    • Können nicht mithilfe einer Zuordnung in eine andere Struktur oder ein anderes Format übertragen werden.
  • Wenn Sie Daten verarbeiten, die nicht übersetzt, transformiert oder überprüft werden sollen, z. B. eine Binärdatei, sollten Sie keine Dokumentspezifikation auswählen.

Verwandte Themen

Erstellen von Dokumentdefinitionen

Bearbeiten von Dokumentdefinitionen

Festlegen von Dokumentdefinitionseigenschaften

Grundlegendes zu Dokumentdefinitionen


Auswählen einer Dokumentspezifikation

  1. Klicken Sie im Dialogfeld Neue Dokumentdefinition oder Dokumentdefinitionseigenschaften auf die Registerkarte Allgemein.

  2. Aktivieren Sie das Kontrollkästchen Dokumentspezifikation, und klicken Sie auf Durchsuchen.

    Das Dialogfeld Dokumentspezifikation aus dem WebDAV-Repository auswählen wird angezeigt.

  3. Führen Sie einen der folgenden Schritte im Dropdownlistenfeld Server aus, wenn Sie den Server ändern möchten:
    • Klicken Sie auf einen Server in der Liste.

    • Geben Sie den Namen eines Servers ein, und drücken Sie die EINGABETASTE.
  4. Doppelklicken Sie auf den Ordner mit der Spezifikation, die Sie öffnen möchten, und doppelklicken Sie auf die Datei.

Wichtig

  • Wenn Sie zum ersten Mal ein WebDAV-Repository-Dialogfeld öffnen, wird das WebDAV-Repository auf dem lokalen Server ausgewählt, auch wenn der BizTalk-Messaging-Manager mit einer Datenbank auf einem Remoteserver verbunden ist. Wenn Sie ein WebDAV-Repository auf einem Remoteserver suchen, wechselt der Standard zu diesem Server, bis Sie ein neues WebDAV-Repository auswählen. Standardserver für alle WebDAV-Repository-Dialogfelder ist der letzte Server, zu dem eine Verbindung hergestellt wurde.

Anmerkungen

  • Wenn Sie http://localhost als Server auswählen, konvertiert der BizTalk-Messaging-Manager diesen automatisch in den Namen des lokalen Computers.

  • Wenn eine Dokumentdefinition als Dokumentdefinition für eingehende Dokumente in einem Kanal für einen offenen Messagingport verwendet wird, muss die Dokumentdefinition auf eine ordnungsgemäß konfigurierte Spezifikation verweisen, wenn die Zielinformation im Dokument bereitgestellt wird. Weitere Informationen zum Konfigurieren einer Dokumentspezifikation zur Verarbeitung von Dokumenten für einen offenen Messagingport finden Sie unter Festlegen von Wörterbucheigenschaften.

  • Dokumentspezifikationen sind optional; in den meisten Fällen ist es jedoch empfehlenswert, eine auszuwählen. Wenn Sie keine Spezifikation auswählen, geschieht Folgendes:
    • Die verarbeiteten Daten werden auf der eingehenden Seite nicht in XML bzw. auf der ausgehenden Seite nicht aus XML übersetzt.

    • Die Daten werden nicht anhand einer Spezifikation überprüft, um zu gewährleisten, dass sie keine Fehler enthalten.

    • Sie können die Struktur bzw. das Format der Daten nicht mithilfe einer Zuordnung in einem Kanal transformieren.

    • Sie können keine globalen Überwachungsfelder für die Dokumentdefinition angeben.
  • Eine Dokumentspezifikation ist nicht erforderlich, wenn Sie die Dokumentdefinition in einer Pass-Through-Versendung verwenden möchten.

  • Wenn Sie das erste Mal eine Verbindung mit einem WebDAV-Repository auf einem Remoteserver herstellen, kann es zu Verzögerungen kommen.

  • Wenn Sie eine Dokumentdefinition speichern, die auf eine Spezifikation außerhalb der lokalen Domäne verweist, erhalten Sie möglicherweise eine Fehlermeldung. Wenn eine Fehlermeldung angezeigt wird, downloaden und konfigurieren Sie das Dienstprogramm WinHTTP Proxy Configuration. Gehen Sie zum Downloaden des Dienstprogramms zur Microsoft MSDN-Website (msdn.microsoft.com/downloads/default.asp), und suchen Sie die Seite "WinHTTP Proxy Configuration Utility". Diese Seite befindet sich im Kapitel zu XML im Buch Web Development.

Verwandte Themen

Erstellen von Dokumentdefinitionen

Bearbeiten von Dokumentdefinitionen

Festlegen von Dokumentdefinitionseigenschaften

Grundlegendes zu Dokumentdefinitionen


Festlegen von globalen Überwachungseigenschaften

In der Liste Spezifikationsfelder auf der Registerkarte Globale Überwachung wird eine Strukturansicht der Spezifikation angezeigt, die Sie für die Dokumentdefinition ausgewählt haben. Sie können die Liste erweitern, um alle Felder in der Spezifikation anzuzeigen und eine begrenzte Anzahl von Feldern zu bestimmen, die in der Überwachungsdatenbank protokolliert werden sollen.

Wenn die Dokumentdefinition als Dokumentdefinition für eingehende Dokumente für einen Kanal ausgewählt wird, werden diese Felder für alle Instanzen eines Dokuments überwacht, die von diesem Kanal verarbeitet werden. Diese Felder werden als globale Überwachungsfelder bezeichnet. Wenn Sie eine Dokumentdefinition in einem Kanal auswählen, haben Sie die Möglichkeit, die globalen Überwachungsfelder außer Kraft zu setzen, indem Sie für jede Dokumentinstanz, die nur von diesem Kanal verarbeitet wird, unterschiedliche zu überwachende Spezifikationsfelder auswählen.

Dieser Abschnitt beschreibt, wie Sie Spezifikationsfelder für eine Dokumentdefinition auswählen.

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Auswählen von Spezifikationsfeldern in einer Dokumentdefinition

  • Entfernen von Spezifikationsfeldern aus einer Dokumentdefinition

Verwandte Themen

Überwachen von Dokumentdatenfeldern

Grundlegendes zu Dokumentdefinitionen


Auswählen von Spezifikationsfeldern in einer Dokumentdefinition

  1. Klicken Sie im Dialogfeld Neue Dokumentdefinition oder Dokumentdefinitionseigenschaften auf die Registerkarte Globale Überwachung.

  2. Klicken Sie in der Liste Spezifikationsfelder auf das Erweiterungssymbol (+) neben einem Datensatz, oder doppelklicken Sie auf den Datensatz, um die Ansicht zu erweitern.

  3. Wählen Sie ein Spezifikationsfeld aus, das zur Liste Zu überwachende Felder hinzugefügt werden soll, und führen Sie dann eines der folgenden Verfahren aus:
    Felddatentyp | Verfahren
    Integer | Klicken Sie auf Integer. Sie können zwei Felder als ganze Zahl hinzufügen.
    Real | Klicken Sie auf Real. Sie können zwei Felder als reelle Zahl hinzufügen.
    Date | Klicken Sie auf Date. Sie können zwei Felder als Datum hinzufügen.
    Text | Klicken Sie auf Text. Sie können zwei Felder als Text hinzufügen.
    Benutzerdefiniert | Klicken Sie auf Benutzerdefiniert. Sie können beliebig viele Felder als benutzerdefinierten Datentyp hinzufügen. Die Felder werden als verkettete XML-Zeichenfolge mit Tags für jedes Feld gespeichert.

Anmerkungen

  • Diesem Feld muss in der Spezifikation der entsprechende Datentyp zugewiesen werden, um ein Spezifikationsfeld zur Überwachung als Datentyp Integer, Real oder Date auszuwählen. Weitere Informationen zum Zuweisen eines Datentyps zu einem Spezifikationsfeld finden Sie unter Festlegen von Deklarationseigenschaften.

  • Spezifikationsfelder, denen in der Spezifikation kein Datentyp zugewiesen wurde, können nur als Text- oder benutzerdefinierter Datentyp überwacht werden.

  • Wenn ein Spezifikationsfeld, das Sie überwachen möchten, über einen Character-Datentyp verfügt, können Sie dieses Feld nur als benutzerdefinierten Datentyp überwachen.

  • Wenn Sie eine Dokumentdefinition in einem Kanal auswählen, können Sie die globalen Überwachungsfelder außer Kraft setzen, indem Sie unterschiedliche zu überwachende Spezifikationsfelder auswählen. Weitere Informationen finden Sie unter Auswählen von Spezifikationsfeldern in einem Kanal.

Verwandte Themen

Erstellen von Dokumentdefinitionen

Bearbeiten von Dokumentdefinitionen

Entfernen von Spezifikationsfeldern aus einer Dokumentdefinition

Festlegen von Dokumentdefinitionseigenschaften

Festlegen von globalen Überwachungseigenschaften

Überwachen von Dokumentdatenfeldern

Grundlegendes zu Dokumentdefinitionen


Entfernen von Spezifikationsfeldern aus einer Dokumentdefinition

  1. Klicken Sie im Dialogfeld Neue Dokumentdefinition oder Dokumentdefinitionseigenschaften auf die Registerkarte Globale Überwachung.

  2. Wählen Sie aus der Liste Zu überwachende Felder das Spezifikationsfeld bzw. die Spezifikationsfelder aus, das/die Sie entfernen möchten, und klicken Sie auf Entfernen.

Anmerkung

  • Wenn Sie ein Feld aus der Liste der zu überwachenden Felder entfernen, wird es nur aus der Liste in dieser Dokumentdefinition entfernt und nicht aus der Spezifikation.

Verwandte Themen

Erstellen von Dokumentdefinitionen

Bearbeiten von Dokumentdefinitionen

Auswählen von Spezifikationsfeldern in einer Dokumentdefinition

Festlegen von Dokumentdefinitionseigenschaften

Festlegen von globalen Überwachungseigenschaften

Überwachen von Dokumentdatenfeldern

Grundlegendes zu Dokumentdefinitionen


Festlegen von Eigenschaften für Auswahlkriterien

Auswahlkriterien bestehen aus eindeutigen Name/Wert-Paaren, die BizTalk Server 2000 nur zur Verarbeitung von EDI-Dokumenten verwendet. Für eingehende X12- oder EDIFACT-Dokumente verwendet der Server Auswahlkriterien, um eine Dokumentdefinition eindeutig zu identifizieren und auszuwählen, da innerhalb von einzelnen EDI-Dokumenten kein Dokumentdefinitionsname verfügbar ist.

Für ausgehende X12- oder EDIFACT-Dokumente werden Auswahlkriterien zum Erstellen der Informationen für Gruppenkopfzeilen verwendet.

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Hinzufügen von Auswahlkriterien

  • Bearbeiten von Auswahlkriterien

  • Entfernen von Auswahlkriterien

Verwandte Themen

Grundlegendes zu Dokumentdefinitionen

Grundlegendes zu Auswahlkriterien


Hinzufügen von Auswahlkriterien

  1. Klicken Sie im Dialogfeld Neue Dokumentdefinition oder Dokumentdefinitionseigenschaften auf die Registerkarte Auswahlkriterien und dann auf Hinzufügen.

    Das Dialogfeld Neuer Name und Wert wird angezeigt.

  2. Geben Sie in das Feld Name einen Namen für das Auswahlkriterium ein.

  3. Geben Sie in das Feld Wert einen Wert für das Auswahlkriterium ein, und klicken Sie auf OK.

Wichtig

  • Damit BizTalk Server 2000 die Werte der Auswahlkriterien den entsprechenden Kopfzeilenelementen eingehender Austauschvorgänge zuordnen und die Werte in die richtigen Kopfzeilenelemente ausgehender Austauschvorgänge einfügen kann, müssen Sie die Namen der Auswahlkriterien genau wie in den folgenden Tabellen gezeigt eingeben.

    X12-Kopfzeilenelemente
    Name | Anforderung | GS-Element
    functional_identifier | Obligatorisch | GS01
    application_sender_code | Obligatorisch | GS02
    application_receiver_code | Obligatorisch | GS03
    standards_version | Obligatorisch | GS08

    EDIFACT-Kopfzeilenelemente
    Name | Anforderung | UNH-Element | UNG-Element
    functional_identifier | Obligatorisch | S009, 0065 | 0038
    application_sender_code | Optional | Nicht verwendet | S006, 0040
    application_receiver_code | Optional | Nicht verwendet | S007, 0044
    standards_version_type | Obligatorisch | S009, 0052 | S008, 0052
    standards_version_value | Obligatorisch | S009, 0054 | S008, 0054

  • Für ausgehende EDIFACT-Austauschvorgänge wird stets eine Nachrichtenkopfzeile (UNH) erstellt. Wenn Sie application_sender_code und application_receiver_code angeben, wird außerdem eine Gruppenkopfzeile (UNG) erstellt.

  • Die Gruppe von Name/Wert-Paaren für Auswahlkriterien, die Sie für die einzelnen Dokumentdefinitionen verwenden, muss über alle Dokumentdefinitionen gesehen eindeutig sein.

Verwandte Themen

Erstellen von Dokumentdefinitionen

Bearbeiten von Dokumentdefinitionen

Bearbeiten von Auswahlkriterien

Entfernen von Auswahlkriterien

Festlegen von Dokumentdefinitionseigenschaften

Festlegen von Eigenschaften für Auswahlkriterien

Grundlegendes zu Dokumentdefinitionen

Grundlegendes zu Auswahlkriterien


Bearbeiten von Auswahlkriterien

  1. Klicken Sie im Dialogfeld Neue Dokumentdefinition oder Dokumentdefinitionseigenschaften auf die Registerkarte Auswahlkriterien.

  2. Klicken Sie in der Liste Auswahlkriterien auf das Auswahlkriterium, das Sie bearbeiten möchten, und klicken Sie dann auf Bearbeiten.

    Das Dialogfeld Eigenschaften von Namen und Wert wird angezeigt.

  3. Geben Sie in das Feld Name einen Namen für das Auswahlkriterium ein.

  4. Geben Sie in das Feld Wert einen Wert für das Auswahlkriterium ein, und klicken Sie auf OK.

Wichtig

  • Damit BizTalk Server 2000 die Werte der Auswahlkriterien den entsprechenden Kopfzeilenelementen eingehender Austauschvorgänge zuordnen und die Werte in die richtigen Kopfzeilenelemente ausgehender Austauschvorgänge einfügen kann, müssen Sie die Namen der Auswahlkriterien genau wie in den folgenden Tabellen gezeigt eingeben.

    X12-Kopfzeilenelemente
    Name | Anforderung | GS Element
    functional_identifier | Obligatorisch | GS01
    application_sender_code | Obligatorisch | GS02
    application_receiver_code | Obligatorisch | GS03
    standards_version | Obligatorisch | GS08

    EDIFACT-Kopfzeilenelemente
    Name | Anforderung | UNH-Element | UNG-Element
    functional_identifier | Obligatorisch | S009, 0065 | 0038
    application_sender_code | Optional | Nicht verwendet | S006, 0040
    application_receiver_code | Optional | Nicht verwendet | S007, 0044
    standards_version_type | Obligatorisch | S009, 0052 | S008, 0052
    standards_version_value | Obligatorisch | S009, 0054 | S008, 0054

  • Für ausgehende EDIFACT-Austauschvorgänge wird stets eine Nachrichtenkopfzeile (UNH) erstellt. Wenn Sie application_sender_code und application_receiver_code angeben, wird außerdem eine Gruppenkopfzeile (UNG) erstellt.

  • Die Gruppe von Name/Wert-Paaren für Auswahlkriterien, die Sie für die einzelnen Dokumentdefinitionen verwenden, muss über alle Dokumentdefinitionen gesehen eindeutig sein.

Verwandte Themen

Hinzufügen von Auswahlkriterien

Entfernen von Auswahlkriterien

Festlegen von Eigenschaften für Auswahlkriterien

Grundlegendes zu Dokumentdefinitionen

Grundlegendes zu Auswahlkriterien


Entfernen von Auswahlkriterien

  1. Klicken Sie im Dialogfeld Dokumentdefinitionseigenschaften auf die Registerkarte Auswahlkriterien.

  2. Klicken Sie in der Liste Auswahlkriterien auf das Auswahlkriterium, das Sie entfernen möchten, und klicken Sie dann auf Entfernen.

Verwandte Themen

Hinzufügen von Auswahlkriterien

Bearbeiten von Auswahlkriterien

Festlegen von Eigenschaften für Auswahlkriterien

Grundlegendes zu Dokumentdefinitionen

Grundlegendes zu Auswahlkriterien


Erstellen und Verwalten von Umschlägen

Dieser Abschnitt stellt aufgabenspezifische Informationen zum Erstellen und Verwalten von Umschlägen bereit. Es wird dringend empfohlen, dass Sie Grundlegendes zu Umschlägen im Abschnitt "Grundbegriffe" lesen, um das Erstellen und Verwalten von Umschlägen vollständig zu verstehen.

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Erstellen von Umschlägen

  • Suchen nach Umschlägen

  • Bearbeiten von Umschlägen

  • Löschen von Umschlägen

  • Auswählen einer Umschlagspezifikation


Erstellen von Umschlägen

  1. Zeigen Sie im BizTalk-Messaging-Manager im Menü Datei auf Neu, und klicken Sie auf Umschlag.

    Das Dialogfeld Neuer Umschlag wird angezeigt.

  2. Geben Sie im Feld Umschlagsname einen eindeutigen Namen für den Umschlag ein.

  3. Klicken Sie in der Liste Umschlagsformat auf eines der folgenden Umschlagsformate:
    • CUSTOM XML

      Sie müssen einen Umschlag mit einem CUSTOM XML-Format und einem Spezifikationsverweis erstellen, damit Microsoft BizTalk Server 2000 eingehende Austauschvorgänge mit einem CUSTOM XML-Format verarbeiten kann. Beim Senden von CUSTOM XML-Austauschvorgängen ist es nicht erforderlich, den Umschlagsnamen in den Submit-Aufrufsparametern anzugeben. BizTalk Server 2000 kann den entsprechenden Umschlag ohne Namensverweis finden.

    • X12

      Sie müssen keinen Umschlag im X12-Format erstellen, damit BizTalk Server 2000 eingehende Austauschvorgänge mit einem X12-Format verarbeiten kann. Außerdem ist es nicht erforderlich, den Umschlagsnamen in den Submit-Aufrufsparametern anzugeben.

    • EDIFACT

      Sie müssen keinen Umschlag im EDIFACT-Format erstellen, damit BizTalk Server 2000 eingehende Austauschvorgänge mit einem EDIFACT-Format verarbeiten kann. Außerdem ist es nicht erforderlich, den Umschlagsnamen in den Submit-Aufrufsparametern anzugeben.

    • FLATFILE

      Sie müssen einen Umschlag mit einem FLATFILE-Format erstellen, damit BizTalk Server 2000 eingehende Austauschvorgänge mit einem FLATFILE-Format verarbeiten kann. Wenn Sie eingehende Flatfiledokumente senden, müssen Sie den Umschlagsnamen in den Submit-Aufrufparametern angeben. Weitere Informationen finden Sie unter Submitting.

    • CUSTOM

      Damit BizTalk Server 2000 eingehende Austauschvorgänge mit einem CUSTOM-Format verarbeiten kann, einem Format, das von BizTalk Server 2000 nicht direkt unterstützt wird, müssen Sie eine benutzerdefinierte Parserkomponente erstellen. Sie müssen nur dann einen Umschlag erstellen, wenn der benutzerdefinierte Parser diesen benötigt. Weitere Informationen finden Sie unter Using the IBizTalkParserComponent Interface.

      Damit BizTalk Server 2000 ausgehende Austauschvorgänge mit einem CUSTOM-Format verarbeiten kann, müssen Sie einen Umschlag mit einem CUSTOM-Format erstellen und den Umschlag in einem Messagingport auswählen. Außerdem müssen Sie eine benutzerdefinierte Serialisierungskomponente erstellen und registrieren. Weitere Informationen finden Sie unter Using the IBizTalkSerializerComponent Interface. Sie können die benutzerdefinierte Serialisierung im Kanal auf der Seite Erweiterte Konfiguration des Kanal-Assistenten konfigurieren. Weitere Informationen finden Sie unter Festlegen von erweiterten Konfigurationseigenschaften.

    • RELIABLE

      Sie müssen keinen Umschlag mit einem RELIABLE-Format erstellen, damit BizTalk Server 2000 eingehende Austauschvorgänge mit einem RELIABLE-Format verarbeiten kann. Außerdem ist es nicht erforderlich, den Umschlagsnamen in den Submit-Aufrufsparametern anzugeben.

      Das RELIABLE-Format verarbeitet Umschläge, die mit BizTalk Framework 2.0 kompatibel sind. Weitere Informationen zu BizTalk Framework 2.0 finden Sie in der Microsoft BizTalk-Website (www.microsoft.com/biztalk/).

      Wenn Sie das RELIABLE-Format auswählen, müssen Sie auch die Adresse Antwort-URL für Reliable Messaging im Dialogfeld Eigenschaften der BizTalk Server-Gruppe konfigurieren. Weitere Informationen finden Sie unter Konfigurieren von allgemeinen Eigenschaften für eine Servergruppe.

  4. Wenn Sie das CUSTOM XML-, das FLATFILE- oder das CUSTOM-Format auswählen, können Sie eine Spezifikation für den Umschlag auswählen. Weitere Informationen finden Sie unter Auswählen einer Umschlagspezifikation.

Anmerkungen

  • Damit BizTalk Server 2000 ausgehende Austauschvorgänge in einem beliebigen Format verarbeiten kann, müssen Sie einen Umschlag erstellen.

  • Wenn Sie das CUSTOM XML-Format, aber keine Spezifikation auswählen, ist das Standardumschlagsformat RELIABLE.

  • Beim Verarbeiten von Umschlägen, die mit BizTalk Framework 2.0 kompatibel sind, sollte BizTalk Server 2000 hinsichtlich des Ablaufzeitpunktes als Endpunkt angesehen werden. Wenn BizTalk Framework 2.0–kompatible Dokumente an BizTalk Server 2000 versendet werden, entweder von einer Anwendung oder von einem Handelspartner, werden die folgenden Felder überschrieben, wenn sie vorhanden sind. Sind die folgenden Felder nicht vorhanden, werden sie erstellt:
    • Im Unterabschnitt mit den Eigenschaften:

      <prop:identity>

      <prop:sentAt>

      <prop:expiresAt>

    • Im Unterabschnitt mit den Empfangsinformationen:

      <sendTo>

      <address>

      <sendReceiptBy>

  • Wenn Sie das Umschlagsformat ändern und eine Spezifikation ausgewählt haben, müssen Sie möglicherweise eine andere Spezifikation auswählen.

  • Wenn Sie einen Umschlag speichern, der auf eine Spezifikation außerhalb der lokalen Domäne verweist, erhalten Sie möglicherweise eine Fehlermeldung. Wenn eine Fehlermeldung angezeigt wird, downloaden und konfigurieren Sie das Dienstprogramm WinHTTP Proxy Configuration. Gehen Sie zum Downloaden des Dienstprogramms zur Microsoft MSDN-Website (msdn.microsoft.com/downloads/default.asp), und suchen Sie die Seite "WinHTTP Proxy Configuration Utility". Diese Seite befindet sich im Kapitel zu XML im Buch Web Development.

Verwandte Themen

Löschen von Umschlägen

Bearbeiten von Umschlägen

Suchen nach Umschlägen

Grundlegendes zu Umschlägen


Suchen nach Umschlägen

  1. Klicken Sie im BizTalk-Messaging-Manager im Bereich Nach anderen Elementen suchen auf Umschläge.

  2. Führen Sie eine oder mehrere der folgenden Aktionen aus:
    • Löschen Sie alle Suchkriterien, und klicken Sie auf Jetzt suchen, um nach allen Umschlägen zu suchen.

    • Wenn Sie nach einem Umschlag mit einem bestimmten Namen suchen möchten, geben Sie im Bereich Nach Umschlägen suchen in das Feld Umschlagsname den Namen des gesuchten Umschlags ein, und klicken Sie auf Jetzt suchen. Sie können einen unvollständigen Namen eingeben, und die Suche gibt alle möglichen Namen zurück, die mit dem unvollständigen Namen übereinstimmen.

    • Wenn Sie nach Umschlägen mit einem bestimmten Format suchen, klicken Sie in der Liste Format auf ein Format und dann auf Jetzt suchen.

Anmerkungen

  • Bevor Sie auf Jetzt suchen klicken, können Sie mehrere Suchkriterien festlegen.

  • Klicken Sie auf Suche löschen, um die Suchkriterien und Suchergebnisse zu löschen.

  • Wenn Sie nach einer großen Anzahl von Objekten suchen, dauert es möglicherweise mehrere Minuten, bis alle Objekte zurückgegeben werden. Mithilfe von Auswahlkriterien können Sie die Anzahl der bei einer Suche zurückgegebenen Objekte eingrenzen.

  • Die Standardanzahl von Elementen, die bei einer Suche zurückgegeben werden, ist 500. Diese Anzahl können Sie anpassen. Weitere Informationen finden Sie unter Festlegen vonServer-Verbindungsoptionen.

  • Sie können folgende Platzhalter in den Suchkriterien verwenden:
    Platzhalter | Beschreibung | Beispiel
    % Eine Zeichenfolge aus null oder mehr Zeichen. Der Eintrag %open% findet alle Namen, die das Wort "open" enthalten.
    _ (Unterstrich) | Beliebiges einzelnes Zeichen. | Der Eintrag _ean findet alle Namen mit vier Buchstaben, die auf "ean" enden (Dean, Sean usw.).
    [ ] Beliebiges einzelnes Zeichen im angegebenen Bereich ([a-f]) oder in der angegebenen Menge ([abcdef]). Der Eintrag [C-P]arsen findet alle Namen, die auf "arsen" enden und mit einem beliebigen einzelnen Zeichen zwischen C und P beginnen, z. B.: Carsen, Larsen usw.
    [^] Beliebiges einzelnes Zeichen, das sich nicht im angegebenen Bereich ([^a-f]) oder in der angegebenen Menge ([^abcdef]) befindet. Der Eintrag de[^s]% findet alle Namen, die mit de beginnen und deren dritter Buchstabe nicht "s" ist.

Verwandte Themen

Löschen von Umschlägen

Bearbeiten von Umschlägen

Grundlegendes zu Umschlägen


Bearbeiten von Umschlägen

  1. Klicken Sie im BizTalk-Messaging-Manager in der Liste Umschlagsname auf den Umschlag, den Sie bearbeiten möchten.

    Informationen zur Suche nach Umschlägen finden Sie unter Suchen nach Umschlägen.

  2. Klicken Sie im Menü Datei auf Bearbeiten.

    Das Dialogfeld Umschlagseigenschaften wird angezeigt.

  3. Geben Sie in das Feld Umschlagsname einen eindeutigen Namen für den Umschlag ein.

  4. Klicken Sie in der Liste Umschlagsformat auf eines der folgenden Umschlagsformate:
    • CUSTOM XML

      Sie müssen einen Umschlag mit einem CUSTOM XML-Format und einem Spezifikationsverweis erstellen, damit Microsoft BizTalk Server 2000 eingehende Austauschvorgänge mit einem CUSTOM XML-Format verarbeiten kann. Beim Senden von CUSTOM XML-Austauschvorgängen ist es nicht erforderlich, den Umschlagsnamen in den Submit-Aufrufsparametern anzugeben. BizTalk Server 2000 kann den entsprechenden Umschlag ohne Namensverweis finden.

    • X12

      Sie müssen keinen Umschlag im X12-Format erstellen, damit BizTalk Server 2000 eingehende Austauschvorgänge mit einem X12-Format verarbeiten kann. Außerdem ist es nicht erforderlich, den Umschlagsnamen in den Submit-Aufrufsparametern anzugeben.

    • EDIFACT

      Sie müssen keinen Umschlag im EDIFACT-Format erstellen, damit BizTalk Server 2000 eingehende Austauschvorgänge mit einem EDIFACT-Format verarbeiten kann. Außerdem ist es nicht erforderlich, den Umschlagsnamen in den Submit-Aufrufsparametern anzugeben.

    • FLATFILE

      Sie müssen einen Umschlag mit einem FLATFILE-Format erstellen, damit BizTalk Server 2000 eingehende Austauschvorgänge mit einem FLATFILE-Format verarbeiten kann. Wenn Sie eingehende Flatfiledokumente senden, müssen Sie den Umschlagsnamen in den Submit-Aufrufparametern angeben. Weitere Informationen finden Sie unter Submitting.

    • CUSTOM

      Sie müssen möglicherweise einen Umschlag erstellen, damit BizTalk Server 2000 eingehende Austauschvorgänge mit einem CUSTOM-Format, einem Format, das von BizTalk Server 2000 nicht direkt unterstützt wird, verarbeiten kann. Sie müssen jedoch eine benutzerdefinierte Parserkomponente erstellen, um diese Austauschvorgänge zu verarbeiten, die möglicherweise einen Umschlag erfordern. Weitere Informationen finden Sie unter Using the IBizTalkParserComponent Interface.

      Damit BizTalk Server 2000 ausgehende Austauschvorgänge mit einem CUSTOM-Format verarbeiten kann, müssen Sie einen Umschlag mit einem CUSTOM- Format erstellen und den Umschlag in einem Messagingport auswählen. Außerdem müssen Sie eine benutzerdefinierte Serialisierungskomponente erstellen und registrieren. Weitere Informationen finden Sie unter Using the IBizTalkSerializerComponent Interface. Sie können die benutzerdefinierte Serialisierung im Kanal auf der Seite Erweiterte Konfiguration des Kanal-Assistenten konfigurieren. Weitere Informationen finden Sie unter Festlegen von erweiterten Konfigurationseigenschaften.

    • RELIABLE

      Sie müssen keinen Umschlag im RELIABLE-Format erstellen, damit BizTalk Server 2000 eingehende Austauschvorgänge mit einem RELIABLE-Format verarbeiten kann. Außerdem ist es nicht erforderlich, den Umschlagsnamen in den Submit-Aufrufsparametern anzugeben.

      Das zuverlässige Format verarbeitet Umschläge, die mit BizTalk Framework 2.0 kompatibel sind. Weitere Informationen zu BizTalk Framework 2.0 finden Sie in der Microsoft BizTalk-Website (www.microsoft.com/biztalk/).

      Wenn Sie das RELIABLE-Format auswählen, müssen Sie auch die Adresse Antwort-URL für Reliable Messaging im Dialogfeld Eigenschaften der BizTalk Server-Gruppe konfigurieren. Weitere Informationen finden Sie unter Konfigurieren von allgemeinen Eigenschaften für eine Servergruppe.

  5. Wenn Sie das CUSTOM XML-, das FLATFILE- oder das CUSTOM-Format auswählen, können Sie eine Spezifikation für den Umschlag auswählen. Weitere Informationen finden Sie unter Auswählen einer Umschlagspezifikation.

Wichtig

  • Wenn Sie einen Umschlag mit dem RELIABLE-Format erstellen und diesen Umschlag in einem Messagingport auswählen, müssen Sie auch die Adresse Antwort-URL für Reliable Messaging im Dialogfeld Eigenschaften der BizTalk Server-Gruppe konfigurieren. Weitere Informationen finden Sie unter Konfigurieren von allgemeinen Eigenschaften für eine Servergruppe.

Anmerkungen

  • Damit BizTalk Server 2000 ausgehende Austauschvorgänge in einem beliebigen Format verarbeiten kann, müssen Sie einen Umschlag erstellen.

  • Wenn Sie das CUSTOM XML-Format, aber keine Spezifikation auswählen, ist das Standardumschlagsformat RELIABLE.

  • Bei der Verarbeitung von Umschlägen, die mit BizTalk Framework 2.0 kompatibel sind, sollte BizTalk Server 2000 im Hinblick auf die Ablaufzeit als Endpunkt betrachtet werden. Wenn BizTalk Framework 2.0–kompatible Dokumente an BizTalk Server 2000 versendet werden, entweder von einer Anwendung oder von einem Handelspartner, werden die folgenden Felder überschrieben, wenn sie vorhanden sind. Sind die folgenden Felder nicht vorhanden, werden sie erstellt:
    • Im Unterabschnitt mit den Eigenschaften:

      <prop:identity>

      <prop:sentAt>

      <expiresAt>

    • Im Unterabschnitt mit den Empfangsinformationen:

      <sendTo>

      <address>

      <sendReceiptBy>

  • Wenn Sie das Umschlagsformat ändern und eine Spezifikation ausgewählt haben, müssen Sie möglicherweise eine andere Spezifikation auswählen.

  • Wenn Sie einen Umschlag speichern, der auf eine Spezifikation außerhalb der lokalen Domäne verweist, erhalten Sie möglicherweise eine Fehlermeldung. Wenn eine Fehlermeldung angezeigt wird, downloaden und konfigurieren Sie das Dienstprogramm WinHTTP Proxy Configuration. Gehen Sie zum Downloaden des Dienstprogramms zur Microsoft MSDN-Website (msdn.microsoft.com/downloads/default.asp), und suchen Sie die Seite "WinHTTP Proxy Configuration Utility". Diese Seite befindet sich im Kapitel zu XML im Buch Web Development.

Verwandte Themen

Erstellen von Umschlägen

Löschen von Umschlägen

Suchen nach Umschlägen

Grundlegendes zu Umschlägen


Löschen von Umschlägen

  1. Klicken Sie im BizTalk-Messaging-Manager in der Liste Umschlagsname auf den Umschlag, den Sie löschen möchten.

    Weitere Informationen zur Suche nach Umschlägen finden Sie unter Suchen nach Umschlägen.

  2. Klicken Sie im Menü Datei auf Löschen.

Anmerkung

  • Ein Umschlag, der in einem Messagingport verwendet wird, kann nicht gelöscht werden. Sie müssen zunächst alle Messagingports löschen, die den Umschlag verwenden.

Verwandte Themen

Erstellen von Umschlägen

Bearbeiten von Umschlägen

Suchen nach Umschlägen

Grundlegendes zu Umschlägen


Auswählen einer Umschlagspezifikation

  1. Aktivieren Sie im Dialogfeld Neuer Umschlag oder Umschlagseigenschaften das Kontrollkästchen Umschlagspezifikation, und klicken Sie auf Durchsuchen.

    Das Dialogfeld Eine Umschlagspezifikation aus dem WebDAV-Repository auswählen wird angezeigt.

  2. Wenn Sie den Server ändern möchten, führen Sie im Feld Server eine der folgenden Aktionen aus:
    • Klicken Sie auf einen Server in der Liste.

    • Geben Sie den Namen eines Servers ein, und drücken Sie die EINGABETASTE.
  3. Doppelklicken Sie auf den Ordner mit der Spezifikation, die Sie öffnen möchten, klicken Sie auf die Spezifikation, und klicken Sie dann auf Öffnen.

Wichtig

  • Wenn Sie ein Dialogfeld WebDAV-Repository zum ersten Mal öffnen, wird das WebDAV-Repository auf dem lokalen Server ausgewählt. Das ist auch dann der Fall, wenn Ihr BizTalk-Messaging-Manager mit einer Datenbank auf einem Remoteserver verbunden ist. Wenn Sie ein WebDAV-Repository auf einem Remoteserver suchen, wechselt der Standard zu diesem Server, bis Sie ein neues WebDAV-Repository auswählen. Der Standardserver für alle WebDAV-Repository-Dialogfelder ist der Server, zu dem zuletzt eine Verbindung hergestellt wurde.

Anmerkungen

  • Wenn Sie http://localhost als Server auswählen, konvertiert der BizTalk-Messaging-Manager diesen automatisch in den Namen des lokalen Computers.

  • Wenn Sie das CUSTOM XML-Format auswählen, können Sie eine Spezifikation für den Umschlag auswählen. Wenn Sie keine Spezifikation auswählen, ist das mit BizTalk Framework 2.0 kompatible Standardumschlagsformat RELIABLE. Weitere Informationen zu BizTalk Framework 2.0 finden Sie in der Microsoft BizTalk-Website (www.microsoft.com/biztalk/).

  • Wenn Sie das FLATFILE-Format auswählen, können Sie eine Spezifikation für den Umschlag auswählen. Wenn der Umschlag zum Öffnen eingehender Austauschvorgänge verwendet wird, müssen Sie eine Spezifikation auswählen. Wenn der Umschlag zum Erstellen ausgehender Austauschvorgänge verwendet wird, ist keine Spezifikation erforderlich.

  • Wenn Sie ein benutzerdefiniertes Format auswählen, können Sie eine Spezifikation für den Umschlag auswählen. Der von Ihnen erstellte benutzerdefinierte Parser bzw. die von Ihnen erstellte benutzerdefinierte Serialisierung bestimmt, ob eine Spezifikation erforderlich ist.

    Zum Verwenden des benutzerdefinierten Formats sind darüber hinaus folgende Schritte erforderlich:

    • Erstellen Sie eine benutzerdefinierte Parserkomponente zum Öffnen eingehender Austauschvorgänge mit diesem benutzerdefinierten Format. Weitere Informationen finden Sie unter Using the IBizTalkParserComponent Interface.

    • Erstellen und konfigurieren Sie eine benutzerdefinierte Serialisierungskomponente zum Erstellen ausgehender Austauschvorgänge mit diesem benutzerdefinierten Format. Weitere Informationen finden Sie unter Using the IBizTalkSerializerComponent Interface.

    • Konfigurieren Sie die benutzerdefinierte Serialisierungskomponente mithilfe der Eigenschaften zum Außerkraftsetzen von Standards für Messagingports im Kanal-Assistenten. Weitere Informationen finden Sie unter Außerkraftsetzen von Messagingportstandards.
  • Wenn Sie einen Umschlag speichern, der auf eine Spezifikation außerhalb der lokalen Domäne verweist, erhalten Sie möglicherweise eine Fehlermeldung. Wenn eine Fehlermeldung angezeigt wird, downloaden und konfigurieren Sie das Dienstprogramm WinHTTP Proxy Configuration. Gehen Sie zum Downloaden des Dienstprogramms zur Microsoft MSDN-Website (msdn.microsoft.com/downloads/default.asp), und suchen Sie die Seite "WinHTTP Proxy Configuration Utility". Diese Seite befindet sich im Kapitel zu XML im Buch Web Development.

Verwandte Themen

Erstellen von Umschlägen

Bearbeiten von Umschlägen

Suchen nach Umschlägen

Grundlegendes zu Umschlägen


Verwenden von Verteilerlisten

Dieser Abschnitt stellt aufgabenspezifische Informationen zur Verwendung von Verteilerlisten bereit. Es wird dringend empfohlen, dass Sie Grundlegendes zu Verteilerlisten im Abschnitt "Grundbegriffe" lesen, um Verteilerlisten vollständig zu verstehen.

Die folgenden Verfahren werden in diesem Abschnitt behandelt:

  • Erstellen von Verteilerlisten

  • Suchen von Verteilerlisten

  • Bearbeiten von Verteilerlisten

  • Löschen von Verteilerlisten


Erstellen von Verteilerlisten

  1. Zeigen Sie im BizTalk-Messaging-Manager im Menü Datei auf Neu, und klicken Sie auf Verteilerliste.

    Das Dialogfeld Neue Verteilerliste wird angezeigt.

  2. Geben Sie im Feld Verteilerlistenname einen eindeutigen Namen für die Verteilerliste ein.

  3. Wählen Sie in der Liste Verfügbare Messagingports die Messagingports, die Sie verwenden möchten, und klicken Sie auf Hinzufügen.

    Die ausgewählten Messagingports werden der Liste Ausgewählte Messagingports hinzugefügt.

  4. Wählen Sie in der Liste Ausgewählte Messagingports die Messagingports, die Sie nicht verwenden möchten, und klicken Sie auf Entfernen.

  5. Nachdem Sie die erforderlichen Eigenschaften festgelegt haben, klicken Sie auf OK, um das Dialogfeld Neue Verteilerliste zu schließen.

Anmerkungen

  • Wenn Sie einen Messagingport aus einer Verteilerliste entfernen, wird dieser nur aus der Verteilerliste und nicht aus der Datenbank entfernt.

  • Eine Verteilerliste muss mindestens einen Messagingport enthalten.

  • Einer Verteilerliste können keine offenen Messagingports hinzugefügt werden.

  • Eine Verteilerliste benötigt mindestens einen Kanal, um funktionieren zu können. Weitere Informationen zu Kanälen finden Sie unter Erstellen und Verwalten von Kanälen.

Verwandte Themen

Löschen von Verteilerlisten

Bearbeiten von Verteilerlisten

Suchen von Verteilerlisten

Grundlegendes zu Verteilerlisten


Suchen von Verteilerlisten

  1. Klicken Sie im BizTalk-Messaging-Manager im Bereich Nach anderen Elementen suchen auf Verteilerlisten.

  2. Führen Sie eine oder mehrere der folgenden Aktionen aus:
    • Löschen Sie alle Suchkriterien, und klicken Sie auf Jetzt suchen, um alle Verteilerlisten zu suchen.

    • Geben Sie für die Suche nach einer Verteilerliste mit einem bestimmten Namen unter Nach Verteilerlisten suchen im Feld Verteilerlistenname den Namen der Verteilerliste ein, die Sie suchen, und klicken Sie auf Jetzt suchen. Sie können auch einen unvollständigen Namen eingeben. Daraufhin gibt die Suche alle möglichen Namen zurück, die mit dem unvollständigen Namen übereinstimmen.

    • Geben Sie für die Suche nach Verteilerlisten, die einen bestimmten Messagingport enthalten, in der Liste Enthält Messagingport den Namen des Messagingports ein, und klicken Sie auf Jetzt suchen.

Anmerkungen

  • Klicken Sie auf Suche löschen, um die Suchkriterien und Suchergebnisse zu löschen.

  • Wenn nach einer großen Anzahl von Objekten gesucht werden soll, dauert es möglicherweise mehrere Minuten, bis alle Objekte zurückgegeben werden. Mithilfe von Auswahlkriterien können Sie die bei einer Suche zurückgegebenen Objekte eingrenzen.

  • Die Standardanzahl von Objekten, die bei einer Suche zurückgegeben werden, ist 500. Diese Anzahl können Sie anpassen. Weitere Informationen finden Sie unter Festlegen von Serververbindungsoptionen.

  • Sie können in den Suchkriterien die folgenden Platzhalter verwenden:
    Platzhalter | Beschreibung | Beispiel
    % Eine Zeichenfolge mit keinen oder mehreren Zeichen. Die Angabe "%open%" findet alle Namen, die das Wort "open" enthalten.
    _ (Unterstrich) | Beliebiges einzelnes Zeichen | Die Angabe "_ean" findet alle Namen mit vier Buchstaben, die auf "ean" enden (Dean, Sean usw.).
    [ ] Beliebiges einzelnes Zeichen im angegebenen Bereich ([a-f]) oder in der angegebenen Menge ([abcdef]). Die Angabe "[C-P]arsen" findet alle Namen, die auf "arsen" enden und mit einem beliebigen einzelnen Zeichen zwischen C und P beginnen, z. B.: Carsen, Larsen usw.
    [^] Beliebiges einzelnes Zeichen, das sich nicht im angegebenen Bereich ([^a-f]) oder in der angegebenen Menge ([^abcdef]) befindet. Die Angabe "de[^s]%" findet alle Namen, die mit "de" beginnen und deren dritter Buchstabe nicht "s" ist.

Verwandte Themen

Erstellen von Verteilerlisten

Löschen von Verteilerlisten

Bearbeiten von Verteilerlisten

Grundlegendes zu Verteilerlisten


Bearbeiten von Verteilerlisten

  1. Klicken Sie im BizTalk-Messaging-Manager in der Liste Verteilerlistenname auf die zu bearbeitende Verteilerliste.

    Weitere Informationen zum Suchen von Verteilerlisten finden Sie unter Suchen von Verteilerlisten.

  2. Klicken Sie im Menü Datei auf Bearbeiten.

    Das Dialogfeld Verteilerlisteneigenschaften wird angezeigt.

  3. Geben Sie im Feld Verteilerlistenname einen eindeutigen Namen für die Verteilerliste ein.

  4. Wählen Sie in der Liste Verfügbare Messagingports die Messagingports, die Sie verwenden möchten, und klicken Sie auf Hinzufügen, um diese der Liste Ausgewählte Messagingports hinzuzufügen.

  5. Wählen Sie in der Liste Ausgewählte Messagingports die Messagingports, die Sie nicht verwenden möchten, und klicken Sie auf Entfernen.

  6. Nachdem Sie die erforderlichen Eigenschaften festgelegt haben, klicken Sie auf OK, um das Dialogfeld Verteilerlisteneigenschaften zu schließen.

Anmerkungen

  • Wenn Sie einen Messagingport aus einer Verteilerliste entfernen, wird dieser nur aus der Verteilerliste und nicht aus der Datenbank entfernt.

  • Eine Verteilerliste muss mindestens einen Messagingport enthalten.

  • Einer Verteilerliste können keine offenen Messagingports hinzugefügt werden.

Verwandte Themen

Erstellen von Verteilerlisten

Löschen von Verteilerlisten

Suchen von Verteilerlisten

Grundlegendes zu Verteilerlisten


Löschen von Verteilerlisten

  1. Klicken Sie im BizTalk-Messaging-Manager in der Liste Verteilerlistenname auf die zu löschende Verteilerliste.

    Weitere Informationen zum Suchen von Verteilerlisten finden Sie unter Suchen von Verteilerlisten.

  2. Klicken Sie im Menü Datei auf Löschen.

Anmerkungen

  • Sie können eine Verteilerliste erst dann löschen, wenn alle Kanäle gelöscht wurden, die der Verteilerliste zugeordnet sind.

  • Sie können nach Kanälen suchen, die einer Verteilerliste zugeordnet sind, indem Sie mit der rechten Maustaste auf die Verteilerliste klicken und dann auf Kanäle suchen klicken.

Verwandte Themen

Erstellen von Verteilerlisten

Suchen von Verteilerlisten

Grundlegendes zu Verteilerlisten


Grundbegriffe

Dieser Abschnitt stellt detaillierte Informationen zum Konzept bereit, die wichtig für das Verständnis des BizTalk-Messaging-Managers sind. Er stellt Informationen zu den folgenden Themen bereit:

  • BizTalk-Messaging-Manager - Umgebung

  • Grundlegendes zu Kanälen

  • Grundlegendes zu Messagingports

  • Grundlegendes zu Organisationen

  • Grundlegendes zu Dokumentdefinitionen

  • Grundlegendes zu Umschlägen

  • Grundlegendes zu Empfangsbestätigungen

  • Grundlegendes zu Verteilerlisten


BizTalk-Messaging-Manager - Umgebung

Folgende Themen werden in diesem Abschnitt behandelt:

  • Konfigurieren der Optionen für den BizTalk-Messaging-Manager

  • BizTalk-Messaging-Manager - Benutzeroberfläche

  • BizTalk-Messaging-Manager - Tastenkombinationen

  • Sicherheit

Vorsicht

  • Sie sollten den BizTalk-Messaging-Manager verwenden, um die BizTalk-Messagingdienste zu konfigurieren, bevor Sie Dokumente verarbeiten. Das Zugreifen auf und Ändern von Objekten, die möglicherweise verwendet werden, während Microsoft BizTalk Server 2000 Dokumente verarbeitet, kann zu unerwarteten Ergebnissen führen.


Konfigurieren von Optionen für den BizTalk-Messaging-Manager

Dieser Abschnitt erläutert, wie die Optionen für den BizTalk-Messaging-Manager geändert werden. Die Optionen umfassen Folgendes:

  • Konfigurieren neuer Messagingports oder Kanäle.

  • Verwalten bereits konfigurierter Messagingports oder Kanäle.

  • Festlegen des Rückgabewertes von Suchvorgängen.

  • Festlegen der Serververbindung.

  • Festlegen des Servertimeoutwertes.

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Auswählen einer BizTalk-Messaging-Manager-Konfigurationsoption

  • Festlegen vonServer-Verbindungsoptionen

Anmerkung

  • Die Symbolleisten im BizTalk-Messaging-Manager können neu angeordnet werden. Nach einem Neustart der Anwendung werden die Symbolleisten jedoch wieder an ihrer ursprünglichen Position angezeigt.


Auswählen einer Konfigurationsoption des BizTalk-Messaging-Managers

  1. Zeigen Sie im Startmenü auf Programme, dann auf Microsoft BizTalk Server 2000, und klicken Sie anschließend auf BizTalk-Messaging-Manager.

    Das Dialogfeld BizTalk-Messaging-Manager wird angezeigt.

  2. Wählen Sie im Bereich Konfigurationsoptionen eine der folgenden Optionen:
    • Wenn Sie einen neuen Messagingport zu einer Organisation erstellen und konfigurieren möchten, klicken Sie auf Neuen Messagingport zu einer Organisation konfigurieren, und klicken Sie dann auf OK.

      Weitere Informationen zum Erstellen und Konfigurieren eines neuen Messagingports zu einer Organisation finden Sie unter Erstellen von Messagingports.

    • Wenn Sie einen neuen Messagingport zu einer Anwendung erstellen und konfigurieren möchten, klicken Sie auf Neuen Messagingport zu einer Anwendung konfigurieren, und klicken Sie dann auf OK.

      Weitere Informationen zum Erstellen und Konfigurieren eines neuen Messagingports zu einer Anwendung finden Sie unter Erstellen von Messagingports.

    • Wenn Sie vorhandene Messagingports verwalten möchten, klicken Sie auf Bereits konfigurierte Messagingports verwalten, und klicken Sie dann auf OK.

      Weitere Informationen zum Verwalten vorhandener Messagingports finden Sie unter Bearbeiten von Messagingports.

    • Wenn Sie vorhandene Kanäle verwalten möchten, klicken Sie auf Bereits konfigurierte Kanäle verwalten, und klicken Sie dann auf OK.

      Weitere Informationen zum Erstellen und Konfigurieren von vorhandenen Kanälen finden Sie unter Bearbeiten von Kanälen.

Anmerkung

  • Wenn dieses Dialogfeld beim Öffnen des BizTalk-Messaging-Managers nicht angezeigt werden soll, aktivieren Sie das Kontrollkästchen Dieses Dialogfeld nicht mehr anzeigen. Um das Dialogfeld wieder anzuzeigen, klicken Sie im Menü Extras auf Optionen, und aktivieren Sie das Kontrollkästchen Dialogfeld "Start" anzeigen.

Verwandte Themen

Erstellen von Messagingports

Bearbeiten von Kanälen

Bearbeiten von Messagingports


Festlegen von Serververbindungsoptionen

  1. Klicken Sie im BizTalk-Messaging-Manager im Menü Extras auf Optionen.

    Das Dialogfeld Optionen wird angezeigt.

  2. Führen Sie im Feld Maximale Anzahl von zurückzugebenden Elementen bei einer Suche einen der folgenden Schritte aus:
    • Geben Sie einen Wert für die Anzahl der in einer Suche zurückzugebenden Elemente ein.

    • Klicken Sie auf den Pfeil nach oben oder den Pfeil nach unten, um den Wert zu erhöhen oder zu verringern.
  3. Geben Sie im Feld Name des BizTalk-Servers, zu dem eine Verbindung hergestellt wird den Namen eines Servers ein, auf dem BizTalk Server 2000 installiert ist.

  4. Führen Sie im Feld Servertimeout in Sekunden einen der folgenden Schritte aus:
    • Geben Sie einen Wert für die Anzahl von Sekunden bis zum Erreichen des Timeouts für die Serververbindung ein.

    • Klicken Sie auf den Pfeil nach oben oder den Pfeil nach unten, um den Wert zu erhöhen oder zu verringern.
  5. Um beim Starten des BizTalk-Messaging-Managers ein Eröffnungsdialogfeld anzuzeigen oder nicht anzuzeigen, aktivieren oder deaktivieren Sie das Kontrollkästchen Dialogfeld "Start" anzeigen.

  6. Nachdem Sie alle Eigenschaften festgelegt haben, klicken Sie auf OK.

Anmerkungen

  • Der Server, zu dem Sie eine Verbindung herstellen, ermittelt die BizTalk-Messaging-Verwaltungsdatenbank, für die Sie neue Objekte mithilfe des BizTalk-Messaging-Managers suchen, bearbeiten oder erstellen. Die Serververbindung ist standardmäßig die zuletzt hergestellte Verbindung. Der Server, der als Host für das WebDAV-Repository dient, das Sie zum Speichern und Abrufen von Spezifikationen für Dokumente, Zuordnungen und den Umschläge verwenden, wird unabhängig in den Dialogfeldern festgelegt, die zum Auswählen von Spezifikationen verwendet werden. Die WebDAV-Verbindung ist standardmäßig die zuletzt hergestellte Verbindung.

  • Die Standardanzahl von Elementen, die bei einer Suche zurückgegeben werden, ist 500.

  • Die Standardanzahl von Sekunden bis zum Erreichen des Timeouts der Serververbindung ist 20.

  • Der Server, zu dem zurzeit eine Verbindung besteht, wird oben im Suchbereich angezeigt, der sich auf der linken Seite des BizTalk-Messaging-Managers befindet.


BizTalk-Messaging-Manager - Benutzeroberfläche

Die BizTalk-Messaging-Manager-Benutzeroberfläche verfügt über zwei Hauptbereiche.

Der linke Bereich zeigt folgende Informationen an:

  • Den Namen des Servers, mit dem der BizTalk-Messaging-Manager verbunden ist.

  • Eine Liste der Objekte, nach denen gesucht werden kann.

  • Suchkriterien, die zum Einschränken der Suche verwendet werden können.

Es kann nach beliebigen Objekten gesucht werden, die mithilfe des BizTalk-Messaging-Managers erstellt wurden. Sie können den Objekttyp auswählen, nach dem gesucht werden soll, indem Sie im Bereich Nach anderen Elementen suchen auf den entsprechenden Namen klicken. Die Suchkriterien unterscheiden sich je nach dem ausgewählten Objekt.

Der rechte Bereich zeigt folgende Informationen an:

  • Die Detailinformationen zu den in der zuletzt durchgeführten Suche zurückgegebenen Elementen.

Die Detailinformationen zu den Elementen unterscheiden sich je nach dem gesuchten Objekttyp.

Die Elemente im Suchergebnisbereich können durch Klicken auf die Spaltenheader in aufsteigender oder absteigender Reihenfolge sortiert werden. Es kann jeweils nur auf der Basis einer Spalte sortiert werden.

Anmerkungen

  • Wenn Sie nach einer großen Anzahl von Objekten eines bestimmten Typs suchen, kann die Rückgabe aller Elemente mehrere Minuten in Anspruch nehmen. Sie können die Anzahl der in einer Suche zurückgegebenen Elemente verringern, indem Sie Suchkriterien verwenden.

  • Die Standardanzahl von Elementen, die bei einer Suche zurückgegeben werden, ist 500. Diese Anzahl können Sie anpassen. Weitere Informationen finden Sie unter Festlegen von Serververbindungsoptionen.

Verwandte Themen

BizTalk-Messaging-Manager - Tastenkombinationen

Suchen nach Kanälen

Suchen von Verteilerlisten

Suchen nach Dokumentdefinitionen

Suchen nach Umschlägen

Suchen nach Messagingport

Suchen nach Organisationen


BizTalk-Messaging-Manager - Tastenkombinationen

Sie können im BizTalk-Messaging-Manager Tastenkombinationen verwenden, um Aufgaben durchzuführen. Die folgende Tabelle ist eine kurze Referenz zu diesen Tastenkombinationen.

Anmerkung

  • Um Funktionen zu verwenden, die in dieser Liste nicht enthalten sind, können Sie mithilfe der Zehnertastatur den Mauszeiger mit der Tastaturmaus bewegen. Weitere Informationen zur Tastaturmaus finden Sie in der Windows 2000 Server-Hilfe und der Advanced Server-Hilfe unter "Bewegen des Mauszeigers mit Hilfe der Tastatur". Weitere Informationen zur Tastaturmaus finden Sie in der Windows 2000 Professional-Hilfe unter "Bewegen des Mauszeigers mithilfe der Tastaturmaus".
Tastenkombination | Zweck
STRG+A | Alles markieren.
STRG+C | Text kopieren.
STRG+X | Text ausschneiden.
STRG+V | Text einfügen.
STRG+Z | Textaktion rückgängig machen.
STRG+R | Einen neuen Messagingport zu einer Organisation erstellen.
STRG+UMSCHALT+R | Einen neuen Messagingport zu einer Anwendung erstellen.
STRG+L | Einen neuen Kanal von einer Organisation erstellen.
STRG+UMSCHALT+L | Einen neuen Kanal von einer Anwendung erstellen.
STRG+T | Eine neue Verteilerliste erstellen.
STRG+D | Eine neue Dokumentdefinition erstellen.
STRG+G | Eine neue Organisation erstellen.
ENTF | Ausgewähltes Element oder ausgewählten Text löschen.
UMSCHALT+F10 | Kontextmenü für das ausgewählte Element anzeigen.
UMSCHALT zusammen mit einer beliebigen Pfeiltaste | Mehr als ein Element in einem Fenster auswählen oder Text auswählen.
TAB | Durch Drücken von TAB in einem Dialogfeld wird zwischen den Schaltflächen und Feldern im Dialogfeld von oben nach unten gewechselt.
UMSCHALT+TAB | Durch Drücken von UMSCHALT+TAB in einem Dialogfeld wird zwischen den Schaltflächen und Feldern im Dialogfeld von unten nach oben gewechselt.
STRG+TAB | Zwischen den Registerkarten eines Dialogfeldes von vorn nach hinten umschalten.
STRG+UMSCHALT+TAB | Zwischen den Registerkarten eines Dialogfeldes von hinten nach vorn umschalten.
LEERTASTE | Aktivieren oder Deaktivieren eines Kontrollkästchens. Die Leertaste verhält sich darüber hinaus wie ein Mausklick, wenn der Fokus sich auf einer Schaltfläche befindet.
ALT+LEER | Systemmenü für das aktive Fenster anzeigen.
ALT+unterstrichener Buchstabe in einem Menünamen | Entsprechendes Menü anzeigen.
Unterstrichener Buchstabe eines Befehlsnamens in einem geöffneten Menü | Entsprechenden Befehl ausführen.
ALT+ PFEIL NACH UNTEN | Dropdownliste für ein aktives Listenfeld anzeigen.
EINGABETASTE | Befehl für die aktive Option oder Schaltfläche ausführen.
ESC | Aktuellen Vorgang abbrechen.
F1 | Onlinehilfe anzeigen.
ALT+F4 | Aktives Fenster schließen oder aktives Programm beenden.
NACH-LINKS-TASTE | Fokus zur Registerkarte links verschieben.
NACH-RECHTS-TASTE | Fokus zur Registerkarte rechts verschieben.
Beliebige Pfeiltaste | Einen Ordner oder eine Datei im Hauptfenster eines Dialogfeldes markieren, während sich der Fokus auf diesem Fenster befindet. Diese Funktion steht in den Dialogfeldern Dokumentspezifikation aus dem WebDAV-Repository auswählen, Eine Umschlagspezifikation aus dem WebDAV-Repository auswählen und Eine Zuordnung aus dem WebDAV-Repository auswählen zur Verfügung. Weitere Informationen finden Sie unter Auswählen einer Dokumentspezifikation, Auswählen einer Umschlagspezifikation und Auswählen einer Zuordnung.

Verwandtes Thema

BizTalk-Messaging-Manager - Benutzeroberfläche


Sicherheit

Sie müssen über ein Benutzerkonto in der Gruppe BizTalk Server-Administratoren verfügen, um mithilfe des BizTalk-Messaging-Managers auf Objekte zuzugreifen oder diese zu erstellen. Die Gruppe BizTalk Server-Administratoren wird bei der Installation von BizTalk Server 2000 erstellt. Zu der Gruppe können nach Bedarf weitere Benutzer hinzugefügt werden. Weitere Informationen zum Hinzufügen eines Benutzerkontos finden Sie unter Hinzufügen von Benutzern zur Gruppe "BizTalk Server-Administratoren".


Grundlegendes zu Kanälen

Ein Kanal ist eine Gruppe von Eigenschaften, die Sie verwenden können, um die BizTalk-Messagingdienste für das Verarbeiten eines empfangenen Dokuments zu konfigurieren. Kanäle können für einen Messagingport oder eine Verteilerliste erstellt werden. Nachdem ein Kanal ein Dokument verarbeitet hat, wird das Dokument an das im zugeordneten Messagingport angegebene Ziel oder an die in der zugeordneten Verteilerliste angegebenen Messagingports transportiert. Für einen Messagingport oder eine Verteilerliste können Sie einen oder mehrere Kanäle erstellen.

In einem Kanal wird die Quelle der Dokumente angegeben. Dabei kann es sich um eine Quellorganisation oder um eine Quellanwendung handeln. Bevor Sie eine Anwendung als Quelle für einen Kanal zuweisen können, müssen Sie eine Anwendung für die eigene Organisation erstellen, die eine tatsächliche interne Anwendung in Ihrem Unternehmen darstellt. Sie können außerdem einen XLANG-Ablaufplan als Quelle für einen Kanal zuweisen. Ein XLANG-Ablaufplan kann mithilfe des BizTalk-Orchestrierungs-Designers erstellt werden. Weitere Informationen finden Sie unter Entwerfen von BizTalk-Orchestrierungen. Weitere Informationen zum Integrieren von BizTalk-Messagingdiensten und BizTalk-Orchestrierungsdiensten finden Sie unter Integrieren der BizTalk-Dienste.

Darüber hinaus kann eine offene Quelle explizit zum Kanal deklariert werden. Dies bedeutet, dass die Quelle entweder im Dokument oder beim Versenden des Dokuments in einem Parameter angegeben sein muss. Dies wird als offener Kanal bezeichnet. Weitere Informationen finden Sie unter Submitting.

Darüber hinaus kann eine eingehende Dokumentdefinition angegeben werden, die ein eingehendes Dokument von einer internen Anwendung oder der Organisation eines Handelspartners darstellt. Ferner wird eine ausgehende Dokumentdefinition angegeben, die ein Dokument darstellt, das an das angegebene Ziel übermittelt werden soll. Weitere Informationen zur Dokumentdefinitionen finden Sie unter Grundlegendes zu Dokumentdefinitionen.

Wenn das Format oder die Struktur eines ausgehenden Dokuments vom Format oder der Struktur des eingehenden Dokuments abweicht, müssen Sie eine Zuordnung für den Kanal angeben. Eine Zuordnung wandelt das Format oder die Struktur des ursprünglichen eingehenden Dokuments in das ausgehende Dokumentformat oder die ausgehende Dokumentstruktur um, die von der Zielorganisation oder –anwendung benötigt wird. Wenn beispielsweise Ihre Buchhaltungsanwendung Aufträge in einem FLATFILE-Format mit Trennzeichen generiert, Ihr Handelspartner aber erwartet, dass Aufträge im X12-Format vorliegen, können Sie eine Zuordnung verwenden, um das Dokumentformat umzuwandeln. Weitere Informationen zu Zuordnungen finden Sie unter Zuordnen von Daten.

Für einen Messagingport oder eine Verteilerliste können mehrere Kanäle erstellt werden, von denen jeder eine andere Konfiguration aufweist. Nehmen Sie z. B. an, dass Sie über zwei interne Buchhaltungsanwendungen verfügen, die Aufträge in verschiedenen Formaten generieren, und dass Sie mit einem Handelspartner zusammenarbeiten, der Aufträge von Ihnen in einem dritten Format zu erhalten wünscht. Sie können einen einzelnen Messagingport zum Handelspartner erstellen. Anschließend können Sie für diesen Messagingport einen Kanal von jeder der Anwendungen erstellen. Die ausgehende Dokumentdefinition wäre für beide Kanäle die gleiche, und sie würde mit dem Format Ihres Handelspartners übereinstimmen. Jedoch würde jeder der Kanäle über eine andere Zuordnung verfügen, um die von den Anwendungen eingehenden Dokumentformate umzuwandeln. Da Sie verschiedene Kanäle erstellen können, die mit einem einzelnen Messagingport verbunden sind, können Sie alle Aufträge im gleichen Format senden.

Darüber hinaus können Sie innerhalb eines Kanals weitere Eigenschaften festlegen, um die folgenden Aktionen auszuführen:

  • Zuweisen von Spezifikationsfeldern, um die eingehende Dokumentdefinition zu überwachen. Alle zugewiesenen Felder werden in einer Überwachungsdatenbank für jede verarbeitete Dokumentinstanz protokolliert, die diesen bestimmten Kanal verwendet, anstelle der globalen Überwachungsfelder, die in der Dokumentdefinition zugewiesen sind. Weitere Informationen zu globalen Überwachungsfeldern finden Sie unter Überwachen von Dokumentdatenfeldern.

  • Erstellen eines Kanalfilterausdrucks, der bestimmt, ob BizTalk Server 2000 den Kanal auf der Basis des Wertes eines Feldes oder mehrerer Felder im verarbeiteten Dokument aufruft.

  • Konfigurieren von Empfangsbestätigungen. Sie können vom Ziel eine Empfangsbestätigung für ein gesendetes Dokument anfordern, und Sie können eine Empfangsbestätigung für die Quelle eines empfangenen Dokuments generieren. Weitere Informationen zum Verarbeiten von Empfangsbestätigungen finden Sie unter Grundlegendes zu Empfangsbestätigungen.

  • Konfigurieren von Sicherheitseigenschaften. Sie können angeben, dass der Server Verschlüsselung und Signatur bei einem eingehenden Dokument überprüft oder ein ausgehendes Dokument digital signiert.

  • Festlegen von Protokollierungsoptionen für Dokumente. Sowohl eingehende als auch ausgehende Dokumente können in ihren ursprünglichen Formaten, im temporären XML-Format oder in beiden Formaten gespeichert werden.

  • Konfigurieren erweiterter Eigenschaften. Sie können für Dokumente in EDI-Formaten eine Gruppenkontrollnummer angeben, Zahl und Zeitintervall festlegen, die der Server zum erneuten Senden von Dokumenten verwendet, und die Transportkomponente und Umschlageigenschaften für den Messagingport oder die Verteilerliste außer Kraft setzen.

Darüber hinaus können Sie mithilfe des BizTalk-Messaging-Managers Empfangskanäle erstellen. Ein Empfangskanal ist ein besonderer Kanaltyp, der zum Senden einer Empfangsbestätigung an den Absender eines von den BizTalk-Messagingdiensten empfangenen Dokuments verwendet wird. Beim Erstellen eines Kanals zur Verarbeitung eines eingehenden Dokuments, für das eine Empfangsbestätigung angefordert ist, können Sie den Empfangskanal angeben, den der Server zum Verarbeiten der Empfangsbestätigung verwenden soll. Aus diesem Grund sollten Sie einen Messagingport und einen diesem zugeordneten Empfangskanal erstellen, bevor Sie einen Messagingport und einen Kanal zur Verarbeitung eines Dokuments erstellen, für das eine Empfangsbestätigung angefordert ist. Weitere Informationen zum Verarbeiten von Empfangsbestätigungen finden Sie unter Grundlegendes zu Empfangsbestätigungen.

Wenn BizTalk Server 2000 ein Dokument empfängt, sucht das Programm den entsprechenden Kanal, der den Server anweist, wie das Dokument verarbeitet werden soll. Anschließend sucht der Server den Messagingport oder die Verteilerliste, der/die dem Kanal zugeordnet ist. Der Messagingport führt den Server durch die Abfolge von Schritten, die erforderlich sind, um das Dokument an das angegebene Ziel zu transportieren. Wenn der Kanal einer Verteilerliste zugeordnet ist, verwendet der Server die Eigenschaften jedes einzelnen Messagingports in der Verteilerliste, um das Dokument an die angegebenen Ziele zu transportieren.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Kanalelemente

  • Gültige Kombinationen aus Kanal und Messagingport


Kanalelemente

Kanäle bestehen aus den folgenden Elementen:

Quellorganisation oder -anwendung

Beim Erstellen eines Kanals weisen Sie entweder eine Anwendung oder eine Organisation als Quelle für Dokumente zu. Eine Quellanwendung stellt immer eine Geschäftsanwendung Ihrer eigenen Organisation dar. Dabei kann es sich um eine Buchhaltungsanwendung, ein Auftragserfassungssystem oder eine LOB-Anwendung (Line-of-Business Application, Geschäftsbereichsanwendung) handeln. Darüber hinaus können Sie einen XLANG-Ablaufplan als Quelle für Dokumente zuweisen. Ein XLANG-Ablaufplan kann mithilfe des BizTalk-Orchestrierungs-Designers erstellt werden. Eine Quellorganisation stellt immer einen externen Handelspartner dar.

Ein Kanal wird immer für einen Messagingport oder eine Verteilerliste erstellt. Das Ziel für die Dokumente, die Sie von der Quelle eines Kanals empfangen, ist im Messagingport oder in den in der Verteilerliste aufgeführten Messagingports zugewiesen, für den/die der Kanal erstellt wird.

Eingehende und ausgehende Dokumentdefinitionen

Dokumentdefinitionen in einem Kanal stellen die eingehenden und ausgehenden Dokumente dar, die von BizTalk Server 2000 verarbeitet werden. Eine Dokumentdefinition stellt einen Zeiger auf eine Spezifikation bereit, die das Dokument definiert. Die Spezifikation definiert Merkmale wie die Dokumentstruktur, den Dokumenttyp und die Version. Weitere Informationen finden Sie unter Grundlegendes zu Dokumentdefinitionen.

Wenn BizTalk Server 2000 ein Dokument empfängt, sucht das Programm den entsprechenden Kanal, um es zu verarbeiten. Der Server verwendet die Spezifikation der eingehenden Dokumentdefinition, um das eingehende Dokument in ein temporäres XML-Format zu übersetzen. Bei Bedarf ordnet der Server Format und Struktur des eingehenden Dokuments dem Format und der Struktur des ausgehenden Dokuments zu. Anschließend verwendet der Server die Spezifikation des ausgehenden Dokuments, um das ausgehende Dokument in das Format und die Struktur zu übersetzen, die von der Zielanwendung oder –organisation erkannt und verwendet werden können.

Zuordnung

Format oder Struktur eines eingehenden Dokuments können von dem Format oder der Struktur abweichen, die für das ausgehende Dokument erforderlich sind. In diesem Fall kann eine Zuordnung verwendet werden, um das Format des eingehenden Dokuments in das Format des ausgehenden Dokuments umzuwandeln.

Wenn Sie z. B. über eine Buchhaltungsanwendung verfügen, die Rechnungen in einem FLATFILE-Format mit Kommas als Trennzeichen generiert, Ihr Handelspartner Rechnungen jedoch im X12-Format benötigt, können Sie eine Zuordnung im Kanal verwenden, um das Format umzuwandeln.

Eine Zuordnung kann darüber hinaus Inhalt und Struktur eines Dokuments umwandeln, das im gleichen Format vorliegt. Weitere Informationen finden Sie unter Zuordnen von Daten.

Überwachungs- und Filterungseigenschaften

Sie können für die eingehende Dokumentdefinition eines Kanals Spezifikationsfelder zuweisen, die in einer Überwachungsdatenbank protokolliert werden sollen. Die Spezifikationsfelder, die Sie in einem Kanal zuweisen, werden für jede mithilfe dieses Kanals verarbeitete Instanz eines Dokuments in einer Überwachungsdatenbank protokolliert. Diese Felder werden anstelle der globalen Überwachungsfelder protokolliert, die in der eingehenden Dokumentdefinition zugewiesen werden. Alle für die ausgehende Dokumentdefinition zugewiesenen globalen Überwachungsfelder werden ignoriert. Weitere Informationen finden Sie unter Überwachen von Dokumentdatenfeldern.

Ein Kanalfilterausdruck stellt eine weitere Möglichkeit bereit, zu ermitteln, welche Kanäle aufgerufen werden, wenn BizTalk Server 2000 ein Dokument empfängt. Für einen Kanalfilterausdruck erfolgt diese Ermittlung auf der Basis des Wertes eines angegebenen Feldes oder angegebener Felder in der Dokumentinstanz.

Wenn der Server ein Dokument verarbeitet, wird der Wert jedes der angegebenen Felder anhand des Wertes für den Kanalfilterausdruck ausgewertet. Wenn der Ausdruck sich als wahr (TRUE) erweist, wird der Kanal aufgerufen. Wenn der Ausdruck falsch (FALSE) ist, wird der Kanal nicht aufgerufen. Wenn beispielsweise der Kanalfilterausdruck erstellt wird, um nach einer Auftragssumme größer als 1.000 zu suchen, und das Summenfeld des Auftrags im Dokument den Wert 1.500 aufweist, wird der Kanal aufgerufen.

Eigenschaften der Dokumentprotokollierung

BizTalk Server 2000 übersetzt nicht auf XML-basierende eingehende Dokumente aus ihrem ursprünglichen systemeigenen Format für die Verarbeitung in ein temporäres Unicode-XML-Format. BizTalk Server 2000 übersetzt ausgehende Dokumente aus einem temporären Unicode-XML-Format in das für das angegebene Ziel erforderliche Format. Sie können auswählen, ob die Daten jedes eingehenden oder ausgehenden Dokuments entweder in einem von beiden oder in beiden Formaten gespeichert werden sollen.

Verwandte Themen

Erstellen und Verwalten von Kanälen

Grundlegendes zu Kanälen

Gültige Kombinationen aus Kanal und Messagingport


Gültige Kombinationen aus Kanal und Messagingport

Es können nur bestimmte Kombinationen aus Kanal (Quelle) und Messagingport (Ziel) erstellt werden, die für die Verwendung mit Microsoft BizTalk Server 2000 gültig sind.

Die folgenden gültigen Geschäftsszenarien zeigen auf, wie Messagingports mit den richtigen Ziel und Kanäle mit den richtigen Quellzuweisungen konfiguriert werden, um Daten korrekt weiterzuleiten.

Szenario 1: Handelspartner zu einer internen Anwendung

In diesem Szenario erstellen Sie einen Messagingport mit einer Anwendung der eigenen Organisation als Ziel. Anschließend erstellen Sie für diesen Messagingport einen Kanal mit dem Handelspartner als Quelle.

Szenario 2: Interne Anwendung zu Handelspartner

In diesem Szenario erstellen Sie einen Messagingport mit der Organisation eines Handelspartners als Ziel. Anschließend erstellen Sie einen Kanal für diesen Messagingport mit einer Anwendung der eigenen Organisation als Quelle.

Szenario 3: Interne Anwendung zu interner Anwendung

In diesem Szenario erstellen Sie einen Messagingport mit einer Anwendung der eigenen Organisation als Ziel. Anschließend erstellen Sie einen Kanal für diesen Messagingport mit einer anderen Anwendung der eigenen Organisation als Quelle.

Szenario 4: Interne Anwendung zu Verteilerliste

In diesem Szenario erstellen Sie eine Verteilerliste, die eine Gruppe von vorhandenen Messagingports zu Organisationen oder Anwendungen umfasst. Anschließend erstellen Sie einen Kanal für diese Verteilerliste mit einer Anwendung der eigenen Organisation als Quelle.

Szenario 5: Interne Anwendung zu offenem Ziel

In diesem Szenario erstellen Sie einen Messagingport, den Sie als einen offenen Messagingport angeben. Anschließend erstellen Sie einen Kanal für diesen Messagingport mit einer Anwendung der eigenen Organisation als Quelle.

Szenario 6: Offene Quelle zu interner Anwendung

In diesem Szenario erstellen Sie einen Messagingport mit einer Anwendung der eigenen Organisation als Ziel. Anschließend erstellen Sie einen Kanal für diesen Messagingport, den Sie als einen offenen Kanal angeben.

Anmerkung

  • Ein Kanal, der als offener Kanal angegeben ist, kann nicht für einen Messagingport erstellt werden, der als offener Messagingport angegeben ist.

Szenario 7: Handelspartner über Zwischenstation zu Handelspartner

In diesem Szenario sendet ein Handelspartner Dokumente über den Computer mit BizTalk Server 2000 an einen anderen Handelspartner, wobei Ihr Unternehmen als Zwischenstation dient. Sie erstellen einen Messagingport mit der Organisation des einen Handelspartners als Ziel. Anschließend erstellen Sie einen Kanal für diesen Messagingport mit einem anderen Handelspartner als Quelle.

Verwandte Themen

Kanalelemente

Grundlegendes zu Kanälen


Grundlegendes zu Messagingports

Ein Messagingport ist eine Gruppe von Eigenschaften, die Sie verwenden können, um die BizTalk-Messagingdienste für das Transportieren von Dokumenten an ein angegebenes Ziel mithilfe eines angegebenen Transportdienstes zu konfigurieren. Die Dokumente, die ein Messagingport transportiert, stammen aus der Quelle, die Sie in einem zugeordneten Kanal angeben. Es können mehrere Kanäle für einen Messagingport erstellt werden, um Dokumente aus vielen Quellen an das gleiche Ziel zu senden.

Ein Messagingport kann so konfiguriert werden, dass er Dokumente an eine zugewiesene Zielorganisation, einen XLANG-Ablaufplan oder eine Zielanwendung sendet.

Für einen Messagingport zu einer Organisation können Sie entweder einen bestimmten Handelspartner als Ziel zuweisen oder ein offenes Ziel deklarieren; dies wird als offener Messagingport bezeichnet. Ein offener Messagingport kann nur verwendet werden, um Dokumente an Organisationen von Handelspartnern zu transportieren. Die Informationen zur Zielorganisation für einen offenen Messagingport müssen entweder im Dokument oder in einem Parameter beim Versenden des Dokuments an BizTalk Server 2000 angegeben werden. Weitere Informationen zum Versenden von Dokumenten finden Sie unter Submitting. Weitere Informationen zu offenen Messagingports finden Sie unter Offenheitsgrad.

Wenn es sich bei der für einen offenen Messagingport angegebenen Adresse um eine SMTP-Adresse handelt, muss der Server über eine Absenderadresse für die eigene Organisation verfügen. Um diese Adresse abzurufen, verwendet der Server den Wert, der für ein besonderes Organisationskennzeichen der eigenen Organisation angegeben ist und als SMTP-"Von"-Adresse der Reliable Messaging-Bestätigung bezeichnet wird. Weitere Informationen zum Konfigurieren dieses Organisationskennzeichens finden Sie unter Konfigurieren der eigenen Organisation.

Für einen Messagingport zu einer Anwendung können Sie entweder einen XLANG-Ablaufplan oder eine Anwendung der eigenen Organisation als Ziel zuweisen. Weitere Informationen zur eigenen Organisation finden Sie unter Grundlegendes zu Organisationen.

Ein Messagingport zu einem XLANG-Ablaufplan kann so konfiguriert werden, dass er eine neue Instanz eines angegebenen XLANG-Ablaufplanes aktiviert und das Dokument anschließend an einen angegebenen Messagingport dieses Ablaufplanes übermittelt. In diesem Fall muss der angegebene Ablaufplan einen Messagingport enthalten, der an BizTalk-Messaging gebunden ist. Bei der Angabe des Ablaufplanes wird auch der Messagingport benannt. Ferner können Sie einen Messagingport so konfigurieren, dass ein Dokument an eine aktuell ausgeführte Instanz eines XLANG-Ablaufplanes übermittelt wird. In diesem Fall muss das Dokument den Namen einer Warteschlange enthalten, an die das Dokument übermittelt werden soll und die vom Zielablaufplan überwacht wird. Weitere Informationen zum Integrieren der BizTalk-Messagingdienste und der BizTalk-Orchestrierungsdienste finden Sie unter Integrieren der BizTalk-Dienste.

Die Messagingporteigenschaften werden außerdem verwendet, um eine bestimmte Adresse zuzuweisen, an die Dokumente übermittelt werden, den Transporttyp festzulegen, um Dokumente an dieses Ziel zu transportieren. Außerdem wird angegeben, wie Dokumente vor dem Transport gesichert und mit welchem Umschlag sie codiert werden.

Wenn BizTalk Server 2000 ein Dokument empfängt, sucht das Programm den entsprechenden Kanal, um es zu verarbeiten. Nach dem Verarbeiten des Dokuments verweist der Kanal den Server an den ihm zugeordneten Messagingport oder die ihm zugeordnete Verteilerliste, der/die den Server durch die Abfolge der erforderlichen Schritte führt, um das Dokument mit einem Umschlag zu codieren, es zu sichern und an das angegebene Ziel zu transportieren.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Messagingportelemente

  • Offene Messagingports


Messagingportelemente

Messagingports bestehen aus den folgenden Elementen:

Ziel

Das Ziel eines Messagingports kann die Organisation eines Handelspartners, ein XLANG-Ablaufplan oder eine Anwendung der eigenen Organisation sein.

Ein Messagingport zu einer Organisation kann explizit die Zielorganisation zuweisen oder alternativ als offener Messagingport deklariert sein. Bei offenen Messagingports wird die Zielorganisation zu dem Zeitpunkt ermittelt, an dem der Messagingport ein Dokument verarbeitet. Die Informationen zur Zielorganisation müssen entweder im Dokument angegeben sein oder beim Versenden des Dokuments in Parametern. Weitere Informationen finden Sie unter Submitting.

Ein Messagingport zu einem XLANG-Ablaufplan kann auf zwei Weisen konfiguriert werden. Sie können einen Messagingport so konfigurieren, dass eine neue Instanz eines XLANG-Ablaufplanes aktiviert wird, indem Sie den Pfad zu einem XLANG-Ablaufplan angeben. Wenn der Messagingport ein Dokument verarbeitet, aktiviert er diesen Ablaufplan und übermittelt das Dokument anschließend an einen Messagingport in diesem Ablaufplan, den Sie außerdem in den Eigenschaften des Messagingports angeben. Alternativ können Sie den Messagingport so konfigurieren, dass Dokumente an einen aktiven XLANG-Ablaufplan übermittelt werden. Diese Option kann nur verwendet werden, wenn Sie einem Handelspartner eine Nachricht senden und der Handelspartner eine Nachricht mithilfe eines HTTP-Transports an eine besonders konfigurierte ASP-Seite zurücksendet. Weitere Informationen finden Sie unter Integrieren der BizTalk-Dienste. Ein XLANG-Ablaufplan kann mithilfe des BizTalk-Orchestrierungs-Designers erstellt werden. Weitere Informationen finden Sie unter Entwerfen von BizTalk-Orchestrierungen.

Ein Messagingport kann außerdem Dokumente an eine Zielanwendung der eigenen Organisation transportieren. Bevor Sie eine Anwendung als Ziel eines Messagingports zuweisen können, müssen Sie zur eigenen Organisation die Anwendung hinzufügen. Weitere Informationen finden Sie unter Hinzufügen von Anwendungen.

Transporteigenschaften

Die Transporteigenschaften, die für einen Messagingport angegeben werden, bestimmen den Transportdienst, der verwendet wird, um Dokumente an die Zielorganisation oder die Zielanwendung zu übermitteln, sowie die genaue Adresse, an die Dokumente gesendet werden.

Die Transporteigenschaften, die Sie für einen Messagingport festlegen, werden auf alle diesem Messagingport zugeordneten Kanäle angewendet. Nachdem BizTalk Server 2000 zum Verarbeiten eines Dokuments einen Kanal aufruft, bezieht sich der Server auf die Eigenschaften des Messagingports, der dem Kanal zugeordnet ist. Der Server sendet die Dokumente an die im Messagingport angegebene Adresse und verwendet dazu den im Messagingport angegebenen Transporttyp.

Darüber hinaus können Sie ein Dienstfenster angeben, das einen bestimmten Zeitraum zuweist, innerhalb dessen Dokumente transportiert werden können.

Umschlaginformationen

Umschläge sind Kopf- und gelegentlich Fußzeilen, die den transportierten Dokumenten voranstehen oder diese einkapseln. Die Umschlagskopfzeile enthält Informationen zu den im Umschlag enthaltenen Dokumenten sowie Informationen darüber, wie diese Dokumente weitergeleitet werden sollen. Eine Umschlagkopfzeile enthält das Quellorganisationskennzeichen, das Zielorganisationskennzeichen und Informationen zum Typ der enthaltenen Dokumente.

BizTalk Server 2000 kann Austauschvorgänge empfangen und verarbeiten, die mehrere Dokumente und Gruppen von Dokumenten enthalten. Beim Transportieren von Dokumenten, die einen Umschlag verwenden, verwendet BizTalk Server 2000 für jedes Dokument einen eigenen Austauschvorgang.

Umschläge sind optional. Wenn Sie sich jedoch für die Verwendung eines Umschlags entscheiden, muss das Format des in einem Messagingport angegebenen Umschlags mit dem Format des enthaltenen Dokuments oder der enthaltenen Dokumente übereinstimmen. Das Dokumentformat wird durch die Spezifikation bestimmt, auf die die ausgehende Dokumentdefinition eines zugeordneten Kanals verweist. Wenn Sie z. B. einen Umschlag mit einem X12-Format für einen Messagingport auswählen, müssen Sie für den Kanal eine ausgehende Dokumentdefinition auswählen, die auf eine X12-Spezifikation verweist. Wenn Sie umgekehrt eine ausgehende Dokumentdefinition in einem Kanal auswählen, muss der Messagingport, dem der Kanal zugeordnet ist, über einen Umschlag im entsprechenden Format verfügen. Wenn Sie z. B. eine ausgehende Dokumentdefinition auswählen, die über eine Spezifikation mit einem X12-Format verfügt, sollten Sie im Messagingport einen X12-Umschlag angeben.

Sicherheitseigenschaften

Die Sicherheitseigenschaften, die Sie einem Messagingport zuweisen, werden auf alle diesem Messagingport zugeordneten Kanäle angewendet. Wenn Sie z. B. S/MIME-Verschlüsselung (Secure Multipurpose Internet Mail Extensions) für einen Messagingport zuweisen, werden alle Dokumente, die von diesem Messagingport zugeordneten Kanälen verarbeitet werden, mit dem angegebenen Verschlüsselungsverfahren verschlüsselt.

Wenn Sie über Dokumente verfügen, die mithilfe eines anderen Verschlüsselungsverfahrens gesichert werden müssen oder keine Verschlüsselung benötigen, müssen Sie einen getrennten Messagingport mit den entsprechenden Sicherheitseigenschaften für diese Dokumente erstellen.

BizTalk Server 2000 unterstützt MIME-Codierung (Multipurpose Internet Mail Extensions).

Der MIME-Nachrichtenformatstandard gibt an, wie Nachrichten formatiert werden müssen, damit Clientprogramme komplexe Textkörper decodieren und anzeigen können, die RTF, mehrere Zeichensätze und binäre Anlagenen enthalten, beispielsweise Grafiken, Klänge, Kalkulationstabellen usw.. MIME ist eine umfassendere und flexiblere Technologie als UUEncode und stellt allgemeine und flexible Mechanismen für das Aufnehmen von Inhalten in Nachrichten bereit. Mit MIME-Formatierung können Sie Folgendes durchführen:

  • Angeben alternativer Mechanismen der Inhaltscodierung für jeden Teil des Textkörpers.

  • Zusammenfassen von Gruppen aus mehreren Inhaltsteilen innerhalb einer Nachricht.

  • Verwenden anderer Zeichensätze als den US-ASCII-Zeichensatz in Textkörperteilen und Nachrichten-Kopfzeilenfeldern.

  • Angeben der beabsichtigten Anordnung eines Inhaltsteils (z. B. im Textfluss oder als Anlage).

BizTalk Server 2000 unterstützt die auf Zertifikaten basierende S/MIME-Verschlüsselung mit öffentlichen Schlüsseln.

Verschlüsselung kann auf Geschäftsdaten angewendet werden, die Sie Ihren Handelspartnern übermitteln. Mithilfe eines Verschlüsselungszertifikats zum Sichern der Daten können Sie sicherstellen, dass nur der beabsichtigte Empfänger auf die Informationen zugreifen kann.

Um Geschäftsdaten zu verschlüsseln, muss die Quellorganisation über ein Exemplar des öffentlichen Schlüssels für das Verschlüsselungszertifikat der Zielorganisation verfügen. Die Quellorganisation verwendet diesen öffentlichen Schlüssel, um die Geschäftsdaten zu verschlüsseln, und leitet anschließend die verschlüsselten Daten an die Zielorganisation weiter. Die Zielorganisation kann dann den privaten Schlüssel ihres Verschlüsselungszertifikats verwenden, um die Geschäftsdaten zu entschlüsseln.

Für einen offenen Messagingport sind die Verschlüsselung betreffenden Sicherheitseigenschaften deaktiviert, weil die Zielorganisation unbekannt ist.

BizTalk Server 2000 unterstützt die auf Zertifikaten basierende digitale Signatur mit öffentlichen Schlüsseln nach S/MIME-Standard. Weitere Informationen zu Zertifikaten finden Sie unter Grundlegendes zu Zertifikaten.

Digitale Signaturen können verwendet werden, um die Authentizität der Datenquelle sicherzustellen, um sicherzustellen, dass die Daten nicht geändert wurden, und um zu verhindern, dass die Datenquelle die Nachricht zurückweist.

Ein Signaturzertifikat wird verwendet, um digitale Signaturen zu erstellen, die die Echtheit von Daten bezeugen. Das Signieren von Daten ändert diese nicht, sondern generiert eine digitale Signaturzeichenfolge, die entweder mit den Daten gebündelt oder separat übertragen wird.

Um ein Dokument digital zu signieren, werden die Daten verarbeitet, um einen Nachrichten-Hash zu erstellen. Anschließend wird der private Schlüssel der Quellorganisation verwendet, um den Nachrichten-Hash zu verschlüsseln und die digitale Signatur zu bilden. Die Daten werden zusammen mit der digitalen Signatur an den Empfänger übertragen.

Der Empfänger muss über ein Exemplar des öffentlichen Schlüssels des Signaturzertifikats des Absenders verfügen, um eine digitale Signatur zu überprüfen. Der Empfänger entschlüsselt die digitale Signatur, indem er den öffentlichen Schlüssel verwendet, um einen Hash zu bilden, und berechnet anschließend unabhängig einen Nachrichten-Hash. Die Ergebnisse der beiden Hashs werden verglichen; wenn sie identisch sind, wurden die Informationen nicht manipuliert.

Anmerkung

  • Weitere Informationen zu Zertifikaten finden Sie unter Zertifikate - Übersicht.

Verwandte Themen

Erstellen und Verwalten von Messagingports

Offene Messagingports

Grundlegendes zu Messagingports


Offene Messagingports

Ein offener Messagingport ist ein Messagingport zu einer Organisation, für den nicht explizit eine bestimmte Zielorganisation deklariert wurde. Ein offener Messagingport kann keine Anwendung als Ziel haben.

Bei einem offenen Messagingport müssen die Ziel- und Transportinformationen entweder im Dokument oder beim Versenden des Dokuments an Microsoft BizTalk Server 2000 in Parametern bereitgestellt werden. Wenn Versendungsparameter verwendet werden, haben diese Vorrang vor den im Dokument enthaltenen Ziel- und Transportinformationen. Weitere Informationen zum Versenden von Dokumenten finden Sie unter Submitting.

Wenn Sie einen Kanal für einen offenen Messagingport erstellen und die Zielinformationen im Dokument bereitgestellt werden, muss die eingehende Dokumentdefinition für diesen Kanal auf eine Spezifikation verweisen, die korrekt konfiguriert ist. Weitere Informationen zum Konfigurieren einer Dokumentspezifikation zum Verarbeiten von Dokumenten für einen offenen Messagingport finden Sie unter Festlegen von Wörterbucheigenschaften.

Für einen offenen Messagingport sind die Verschlüsselung betreffenden Sicherheitseigenschaften deaktiviert, weil die Zielorganisation unbekannt ist. Zum Festlegen der Verschlüsselungseigenschaften muss ein Zertifikat einer bestimmten, bekannten Zielorganisation angegeben werden. Ein Verschlüsselungszertifikat wird verwendet, um Dokumente zu verschlüsseln, die an die bestimmte Zielorganisation transportiert werden.

Sie können einen offenen Messagingport verwenden, um standardisierte Dokumente an viele verschiedene Organisationen von aktuellen oder zukünftigen Handelspartnern zu senden, ohne für jedes Ziel einen Messagingport zu erstellen. Alle Dokumente haben die gleichen Umschlag-, Sicherheits- und Transporteigenschaften gemein, die im Messagingport eingerichtet sind.

Ein offener Messagingport unterscheidet sich in den folgenden Punkten von einer Verteilerliste:

  • Bei einem offenen Messagingport hat jedes Dokument von einem Kanal zur Folge, dass nur ein Dokument and nur ein Ziel übermittelt wird. Bei einer Verteilerliste kann jedes Dokument von einem Kanal die Übermittlung des Dokuments an mehrere Ziele zur Folge haben.

  • Bei einem offenen Messagingport müssen die Eigenschaften des Messagingports nicht geändert werden, um Informationen an die Organisation eines anderen Handelspartners zu senden. Bei einer Verteilerliste müssen Sie einen Messagingport hinzufügen, um Informationen an die Organisation eines anderen Handelspartners zu senden.

Wichtig

  • Wenn Sie einen Messagingport als offenen Messagingport deklarieren, sollten Sie keine Kanäle für den Messagingport erstellen, die über eine ausgehende Dokumentdefinition mit einer X12- oder EDIFACT-Spezifikation verfügen. Um einen X12- oder EDIFACT-Umschlag zu generieren, muss der Server über Organisationskennzeichen für Ziel und Quelle verfügen. Ein offener Messagingport gibt kein Zielorganisationskennzeichen an. Darüber hinaus müssen die Dokumente für einen offenen Messagingport die Zieladresse im Dokument aufweisen, X12- und EDIFACT-Dokumente enthalten diese Information jedoch nicht.

Verwandte Themen

Erstellen und Verwalten von Messagingports

Messagingportelemente

Grundlegendes zu Messagingports


Grundlegendes zu Organisationen

Die Organisationen, die Sie mithilfe des BizTalk-Messaging-Managers erstellen, stellen die Handelspartner dar, mit denen Sie Dokumente austauschen. Ein besonderer Organisationstyp, der als eigene Organisation bezeichnet wird, stellt Ihr Unternehmen dar.

Eigene Organisation

Der BizTalk-Messaging-Manager erstellt die eigene Organisation automatisch. Sie können die eigene Organisation beim Konfigurieren umbenennen, um sie leichter als Ihr Unternehmen kenntlich zu machen. Es gibt nur eine eigene Organisation, und sie kann nicht gelöscht werden.

Die eigene Organisation kann nicht als Quelle oder Ziel für Dokumente in einem Messagingport oder einem Kanal zugewiesen werden. Nur Anwendungen der eigenen Organisation können als Quelle oder Ziel für Dokumente innerhalb Ihres Unternehmens zugewiesen werden. Beispielsweise können Sie einen Messagingport erstellen, der die Organisation eines Handelspartners als Ziel für von Ihrem Unternehmen gesendete Dokumente zuweist. Anschließend, beim Erstellen eines Kanals für diesen Messagingport, weisen Sie nicht Ihre eigene Organisation als Quelle zu, sondern vielmehr eine bestimmte interne Anwendung in Ihrem Unternehmen, aus der die Dokumente stammen. Sie können außerdem eine Anwendung der eigenen Organisation als Quelle für Dokumente in einem Kanal zuweisen und eine andere Anwendung als Ziel in einem Messagingport.

Anwendungen der eigenen Organisation

Die zur eigenen Organisation hinzugefügten Anwendungen erlauben Ihnen, den Dokumentenfluss zwischen Microsoft BizTalk Server 2000 und den tatsächlichen internen Anwendungen in Ihrem Unternehmen zu identifizieren und überwachen. Das einfache Erstellen und Zuweisen einer Anwendung als Quelle oder Ziel im BizTalk-Messaging-Manager steuert oder aktiviert den Ablauf von Dokumenten zu oder von einer tatsächlichen internen Anwendung jedoch nicht. Um eine interne Anwendung in BizTalk Server 2000 zu integrieren und den Dokumentenfluss zu oder von der Anwendung zu steuern, müssen Sie den Server weiter konfigurieren.

Es existieren mehrere Möglichkeiten, Dokumente von einer Ursprungsanwendung zu BizTalk Server 2000 zu transportieren. Die erforderliche Konfiguration, um eine Anwendung für den Transport von Dokumenten an den Server zu integrieren, erfolgt vollständig außerhalb des BizTalk-Messaging-Managers. Weitere Informationen finden Sie unter Submitting.

Das Übermitteln von Dokumenten von BizTalk Server 2000 zu einer internen Anwendung kann Konfigurationen sowohl innerhalb als auch außerhalb des BizTalk-Messaging-Managers erfordern. Der in einem Messagingport angegebenen Transporttyp und die angebene Adresse können einen bestimmten Speicherort bestimmen, an den Dokumente übermittelt werden. Eine Anwendung oder eine separate Komponente muss dann konfiguriert werden, um an diesem Speicherort empfangene Dokumente für die Zielanwendung abzurufen. Alternativ können Sie in den Transporteigenschaften eines Messagingports eine Anwendungsintegrationskomponente angeben, die Dokumente direkt an eine Anwendung übermitteln kann. Weitere Informationen finden Sie unter Grundlegendes zu Messagingports.

Organisationen von Handelspartnern

Alle anderen Organisationen, die Sie mit dem BizTalk-Messaging-Manager erstellen, stellen externe Handelspartner oder Unternehmenseinheiten eines Handelspartners dar. Es kann eine beliebige Anzahl von Organisationen erstellt werden. Sie können die Organisation eines Handelspartners entweder als Quelle von Dokumenten in einem Kanal oder als Ziel für Dokumente in einem Messagingport zuweisen.

Ferner können Sie einen Handelspartner als Quelle von Dokumenten in einem Kanal und einen anderen als Ziel der Dokumente in einem Messagingport zuweisen. In diesem Fall dient Ihr Unternehmen als unabhängige Zwischenstation zwischen den beiden Handelspartnern.

Wie auch bei Anwendungen aktiviert das einfache Erstellen einer Organisation und das anschließende Zuweisen als Quelle oder Ziel im BizTalk-Messaging-Manager nicht den Dokumentenfluss zu oder von dieser Organisation. Sie müssen den Server weiter konfigurieren, um den Dokumentenfluss zwischen Ihren Partnerorganisationen und BizTalk Server 2000 zu steuern und zu lenken.

Es existiert eine Reihe von Möglichkeiten für einen externen Handelspartner als Quellorganisation, Dokumente zu Ihrem BizTalk Server 2000 zu transportieren. Die für diesen Zweck erforderliche Konfiguration ähnelt der Weise, in der Anwendungen für das Transportieren von Dokumenten zum Server integriert werden, und wird ebenfalls vollständig außerhalb des BizTalk-Messaging-Managers vorgenommen. Weitere Informationen finden Sie unter Submitting.

Das Übermitteln von Dokumenten von Ihrem BizTalk Server 2000 an einen externen Handelspartner als Zielorganisation kann Konfigurationen sowohl innerhalb als auch außerhalb des BizTalk-Messaging-Managers erfordern. Transporttyp und Adresse, die in einem Messagingport angegeben werden, ermitteln einen bestimmten Speicherort, an den Dokumente übermittelt werden. Die Zielorganisation, die über Zugriff auf diesen Speicherort verfügen muss, kann anschließend ihren eigenen BizTalk Server, eine ihrer internen Anwendungen oder eine separate Komponente für die Verarbeitung der an diesem Speicherort empfangenen Dokumente konfigurieren. Weitere Informationen zum Konfigurieren von Messagingports finden Sie unter Grundlegendes zu Messagingports.

Folgendes Thema wird in diesem Abschnitt behandelt:

  • Organisationskennzeichen


Organisationskennzeichen

Microsoft BizTalk Server 2000 und andere Handelspartner verwenden Organisationskennzeichen, um Organisationen eindeutig zu identifizieren. Eine Organisation kann über mehrere Organisationskennzeichen verfügen; jedoch muss jedes dieser Kennzeichen für die Organisation eindeutig sein. Beispielsweise können eine Telefonnummer, ein URL oder eine DUNS-Nummer eine Organisation eindeutig identifizieren, aber es können nicht zwei Organisationen die gleiche Telefonnummer als Organisationskennzeichen verwenden.

Ein Organisationskennzeichen besteht aus drei getrennten Elementen: einem Namen, einem Qualifizierer und einem Wert. Beispielsweise kann ein Unternehmen eine Telefonnummer verwenden, um sich eindeutig zu identifizieren. In diesem Beispiel ist der Name des Kennzeichens Telefonnummer, der Qualifizierer, der das Kennzeichen als Telefonnummer identifiziert, ist die Zahl 12, und der Wert der tatsächlichen Telefonnummer ist (801-555-1079). Der Name jedes Organisationskennzeichens besitzt einen eindeutigen Qualifizierer, der anstelle des Namens verwendet wird, um den Typ des Kennzeichens anzugeben. Beispielsweise ist der Standardqualifizierer für ein Telefonnummerkennzeichen 12. Wenn BizTalk Server 2000 Dokumente verarbeitet, werden nur der Qualifizierer und der Wert verwendet, um Organisationen zu identifizieren.

Jede Organisation muss mindestens über ein Kennzeichen verfügen. Wenn Sie eine Organisation erstellen, erstellt der BizTalk-Messaging-Manager ein Kennzeichen mit dem Namen Organisation. Der Qualifizierer für dieses Kennzeichen ist Organisationsname, und der Wert ist der Name, den Sie der Organisation geben. Dieses Kennzeichen wird auch als Standardkennzeichen festgelegt, dies bedeutet, es wird verwendet, wenn kein anderes Kennzeichen angegeben wird. Sie können weitere Kennzeichen erstellen und jedes beliebige Kennzeichen als Standardkennzeichen zuweisen. Das Kennzeichen Organisationsname oder das zugewiesene Standardkennzeichen können nicht gelöscht werden. Das Standardkennzeichen wird verwendet, um eine Organisation zu identifizieren, sofern Sie es nicht durch Auswählen eines anderen Kennzeichens in einem Messagingport oder Kanal außer Kraft setzen.

Wenn BizTalk Server 2000 ein Dokument verarbeitet und transportiert, nimmt das Programm die Organisationskennzeichen der Zielorganisation und der Quellorganisation in die Umschlagkopfzeile auf. Wenn BizTalk Server 2000 Dokumente empfängt, durchsucht das Programm die Daten nach den Kennzeichen der Quellorganisation und der Zielorganisation. Anschließend verwendet der Server die Kennzeichen und den Namen der Dokumentdefinition, um zu ermitteln, welche Kanäle für die Verarbeitung der Dokumente verwendet werden sollen.

Austauschvorgänge mit einem EDI-Format weisen Einschränkungen bei Organisationskennzeichen auf. Wenn Sie ein Organisationskennzeichen für X12-Umschläge verwenden, sollten Sie nicht das Organisationskennzeichen mit dem Namen Organisation verwenden oder ein anderes Kennzeichen, dessen Qualifizierer mehr als 2 Zeichen oder dessen Wert mehr als 15 Zeichen umfasst. Wenn Sie ein Organisationskennzeichen für EDIFACT-Umschläge verwenden, sollten Sie nicht das Organisationskennzeichen mit dem Namen Organisation verwenden oder ein anderes Kennzeichen, dessen Qualifizierer mehr als 4 Zeichen oder dessen Wert mehr als 35 Zeichen umfasst.

Verwandte Themen

Erstellen und Verwalten von Organisationen

Grundlegendes zu Organisationen


Grundlegendes zu Dokumentdefinitionen

Eine Dokumentdefinition stellt einen bestimmten Typ Dokument dar, der von Microsoft BizTalk Server 2000 verarbeitet wird. Eine Dokumentdefinition stellt den Typ des eingehenden oder ausgehenden Dokuments in einem Kanal dar und stellt einen Zeiger auf eine Dokumentspezifikation bereit. Die Dokumentdefinition definiert Struktur, Typ und Version des Dokuments. Die gleiche Dokumentspezifikation kann in einer beliebigen Anzahl von Dokumentdefinitionen verwendet werden, und die gleiche Dokumentdefinition kann in einer beliebigen Anzahl von Kanälen verwendet werden.

Wenn Format und Struktur des eingehenden und ausgehenden Dokuments in einem Kanal identisch sind, können Sie für beide die gleiche Spezifikation verwenden. Andernfalls müssen Sie eine Zuordnung angeben, die der Server verwendet, um das Format oder die Struktur des eingehenden Dokuments in das Format oder die Struktur des ausgehenden Dokuments umzuwandeln.

Wenn BizTalk Server 2000 ein Dokument empfängt, identifiziert das Programm den entsprechenden Kanal oder die entsprechenden Kanäle mit passenden eingehenden Dokumentdefinitionen. Die eingehende Dokumentdefinition für jeden Kanal verweist auf eine Spezifikation. Der Server verwendet die Spezifikation, um ein nicht auf XML-basierendes eingehendes Dokument aus seinem Ursprungsformat in ein temporäres XML-Format zu übersetzen und die Struktur des Dokuments auf ihre Gültigkeit zu prüfen. Die ausgehende Dokumentdefinition für einen Kanal verweist ebenfalls auf eine Spezifikation. Der Server verwendet die ausgehende Dokumentdefinition, um die Datenstruktur des ausgehenden Dokuments zu prüfen. Bei Bedarf kann der Server die Spezifikation darüber hinaus verwenden, um das ausgehende Dokument aus einem XML-Format in ein Format zu übersetzen, das die Zielorganisation oder Zielanwendung erkennen und verwenden kann. Das Ziel wird in dem Messagingport zugewiesen, dem der Kanal zugeordnet ist.

Eine Dokumentspezifikation für eine Dokumentdefinition ist optional; jedoch sollten Sie in den meisten Fällen eine auswählen. Wenn Sie keine Spezifikation auswählen, gelten folgende Einschränkungen:

  • Die verarbeiteten Daten werden nicht auf der eingehenden Seite in XML oder auf der ausgehenden Seite aus XML übersetzt.

  • Die Daten werden nicht anhand einer Spezifikation auf Gültigkeit geprüft, um sicherzustellen, dass sie keine Fehler enthalten.

  • Struktur oder Format der Daten können nicht mithilfe einer Zuordnung in einem Kanal umgewandelt werden.

  • Es können keine globalen Überwachungsfelder oder Auswahlkriterien angegeben werden.

Eine Dokumentspezifikation ist nicht erforderlich, wenn Sie die Dokumentdefinition in einer Pass-Through-Versendung für Daten, die nicht im Unicode-XML-Format vorliegen, verwenden möchten. Ein Beispiel ist das Senden von Binärdaten mithilfe von BizTalk Server 2000 an ein Ziel, ohne dass die Daten in irgendeiner Weise geändert werden. In diesem Fall sollte weder für die eingehende noch für die ausgehende Dokumentspezifikation eine Dokumentdefinition des Kanals ausgewählt werden, der für die Pass-Through-Versendung verwendet wird.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Überwachen von Dokumentdatenfeldern

  • Grundlegendes zu Auswahlkriterien

Verwandte Themen

Erstellen und Verwalten von Dokumentdefinitionen

Erstellen von Spezifikationen

Zuordnen von Spezifikationen

Grundlegendes zu Kanälen


Überwachen von Dokumentdatenfeldern

In einer Dokumentspezifikation können in der Spezifikation enthaltene Felder zugewiesen werden, die in einer Überwachungsdatenbank protokolliert werden sollen. Die in einer Dokumentdefinition zugewiesenen Felder werden für alle Dokumentinstanzen überwacht, die von Kanälen verarbeitet werden, die die betreffende Dokumentdefinition als ihre eingehende Dokumentdefinition verwenden. Da diese Felder für alle Kanäle überwacht werden, werden sie als globale Überwachungsfelder bezeichnet.

Beim Auswählen einer eingehenden Dokumentdefinition für einen Kanal können Spezifikationsfelder für die Überwachung aus dem Kanal heraus zugewiesen werden. Die in einem Kanal zugewiesenen Spezifikationsfelder werden anstelle der globalen Überwachungsfelder für Dokumente überwacht, die von diesem bestimmten Kanal verarbeitet werden.

Die in einer Dokumentdefinition oder in einem Kanal für die Überwachung zugewiesenen Felder werden nur für die eingehende Dokumentdefinition des Kanals in einer Überwachungsdatenbank protokolliert. Felder, die in der ausgehenden Dokumentdefinition des Kanals für die Überwachung zugewiesen sind, werden nicht überwacht.

Mithilfe der Überwachungsdaten aus den verarbeiteten Dokumenten können Informationen zum Betrieb analysiert werden. Beispielsweise kann das Summenfeld des Rechnungsbetrags für alle Rechnungen überwacht werden, die Sie an Ihre Handelspartner senden. Mithilfe dieser Informationen können Sie den Gesamtbetrag der innerhalb eines bestimmten Zeitraums an alle Handelspartner gesendeten Rechnungen oder den Gesamtbetrag der Rechnungen für jeden einzelnen Handelspartner ermitteln.

Verwandte Themen

Erstellen und Verwalten von Dokumentdefinitionen

Verwenden der BizTalk-Dokumentüberwachung


Grundlegendes zu Auswahlkriterien

Auswahlkriterien sind eine eindeutige Gruppe von Name/Wert-Paaren, die Microsoft BizTalk Server 2000 ausschließlich für die Verarbeitung von EDI-Dokumenten verwendet. Für eingehende X12- oder EDIFACT-Dokumente verwendet der Server Auswahlkriterien, um eine Dokumentdefinition eindeutig zu identifizieren und auszuwählen, weil innerhalb einzelner EDI-Dokumente kein Dokumentdefinitionsname zur Verfügung steht.

Für ausgehende X12- oder EDIFACT-Dokumente werden Auswahlkriterien verwendet, um die funktionalen Informationen der Gruppenkopfzeile im Umschlag zu erstellen.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Verwenden von Auswahlkriterien für eingehende Dokumente

  • Verwenden von Auswahlkriterien für ausgehende Dokumente


Verwenden von Auswahlkriterien für eingehende Dokumente

Für die Verarbeitung von eingehenden Dokumenten muss BizTalk Server 2000 über den Namen einer eingehenden Dokumentdefinition verfügen. Normalerweise erhält der Server den Namen der eingehenden Dokumentdefinition entweder aus einem Feld im eingehenden Dokument oder aus einem Parameter, der zusammen mit dem Dokument versendet wird. Weitere Informationen finden Sie unter Submitting.

Bei eingehenden X12- und EDIFACT-Austauschvorgängen können die Dokumente in der funktionalen Gruppe oder den Austauschkopfzeilen enthalten sein. BizTalk Server 2000 verarbeitet die in diesen Gruppen und Austauschvorgängen enthaltenen Dokumente einzeln. Da die dokumentbezogenen Informationen für jedes Dokument in der funktionalen Gruppe oder Austauschkopfzeile enthalten sind, kann der Server keinen Dokumentdefinitionsnamen aus den einzelnen Dokumenten abrufen. Ferner kann, da ein Austausch mehrere Gruppen mit verschiedenen Dokumenttypen enthalten kann, kein einzelner Dokumentdefinitionsname zum Identifizieren einer Dokumentdefinition als Versendungsparameter für den Server zur Verfügung gestellt werden.

In solchen Fällen kann BizTalk Server 2000 dokumentbezogene Daten aus der Kopfzeile der funktionalen Gruppe (der GS-Kopfzeile eines X12-Austauschs und der UNG-Kopfzeile eines EDIFACT-Austauschs) oder der Austauschkopfzeile in einem EDIFACT-Austausch ohne funktionale Gruppen extrahieren. Durch Vergleichen der Werte dieser Daten mit den Werten von Auswahlkriterien, die in einer Dokumentspezifikation angegeben sind, kann der Server die entsprechende Dokumentdefinition eindeutig identifizieren.

Damit BizTalk Server 2000 die Werte der Auswahlkriterien mit den entsprechenden Kopfzeilenelementen eines eingehenden Austauschs vergleichen kann, müssen die Namen der Auswahlkriterien exakt wie in der folgenden Tabelle eingegeben werden.

X12-Kopfzeilenelemente

Name | Anforderung | GS-Element
functional_identifier | Obligatorisch | GS01
application_sender_code | Obligatorisch | GS02
application_receiver_code | Obligatorisch | GS03
standards_version | Obligatorisch | GS08

EDIFACT-Kopfzeilenelemente

Name | Anforderung | UNH-Element | UNG-Element
functional_identifier | Obligatorisch | S009, 0065 | 0038
application_sender_code | Optional | Nicht verwendet | S006, 0040
application_receiver_code | Optional | Nicht verwendet | S007, 0044
standards_version_type | Obligatorisch | S009, 0052 | S008, 0052
standards_version_value | Obligatorisch | S009, 0054 | S008, 0054

Verwandte Themen

Erstellen und Verwalten von Dokumentdefinitionen

Grundlegendes zu Auswahlkriterien

Verwenden von Auswahlkriterien für ausgehende Dokumente


Verwenden von Auswahlkriterien für ausgehende Dokumente

Bei der Verarbeitung eines ausgehenden X12- oder EDIFACT-Dokuments platziert BizTalk Server 2000 jedes Dokument in einem gültigen Umschlag des entsprechenden Formats. Um den Umschlag zu erstellen, fügt der Server die Wertdaten der Auswahlkriterien in den entsprechenden Feldern der Gruppen- und Nachrichtenkopfzeilen ein. Zum Erstellen der Kopfzeilen verwendet der Server die Werte der in der ausgehenden Dokumentdefinition für den Kanal enthaltenen Auswahlkriterien.

Nehmen Sie z. B. an, Sie erstellen eine Dokumentdefinition, die als eins ihrer Auswahlkriterien das Name/Wert-Paar functional_identifier/BESTELLUNGEN aufweist. Wenn Sie diese anschließend als ausgehende Dokumentdefinition in einem Kanal verwenden, wird der Wert des Feldes in der Gruppenkopfzeile, das dem Auswahlkriterium mit dem Namen functional_identifier entspricht, in der Umschlagkopfzeile auf BESTELLUNGEN festgelegt.

Damit BizTalk Server 2000 Werte von Auswahlkriterien in die entsprechenden Kopfzeilenelemente einfügen kann, müssen Sie die Namen der Auswahlkriterien exakt so eingeben, wie sie in den folgenden Tabellen aufgeführt sind.

X12-Kopfzeilenelemente

Name | Anforderung | GS-Element
functional_identifier | Obligatorisch | GS01
application_sender_code | Obligatorisch | GS02
application_receiver_code | Obligatorisch | GS03
standards_version | Obligatorisch | GS08

EDIFACT-Kopfzeilenelemente

Name | Anforderung | UNH-Element | UNG-Element
functional_identifier | Obligatorisch | S009, 0065 | 0038
application_sender_code | Optional | Nicht verwendet | S006, 0040
application_receiver_code | Optional | Nicht verwendet | S007, 0044
standards_version_type | Obligatorisch | S009, 0052 | S008, 0052
standards_version_value | Obligatorisch | S009, 0054 | S008, 0054

Verwandte Themen

Erstellen und Verwalten von Dokumentdefinitionen

Grundlegendes zu Auswahlkriterien

Verwenden von Auswahlkriterien für eingehende Dokumente


Grundlegendes zu Umschlägen

Ein Umschlag kapselt elektronische Geschäftsdaten für den Transport. Standardmäßig besteht ein Umschlag aus Kopf- und Fußzeileninformationen oder nur aus Kopfzeileninformationen. Die Umschlageigenschaften, die Sie eingeben, stellen Microsoft BizTalk Server 2000 die Informationen zur Verfügung, die der Server benötigt, um entweder eingehende Austauschvorgänge zu öffnen oder ausgehende Austauschvorgänge zu erstellen. Beim Erstellen eines Umschlags geben Sie ein Umschlagsformat an; für bestimmte Formattypen können Sie außerdem eine Umschlagspezifikation auswählen.

Die von BizTalk Server 2000 unterstützten Umschlagsformate sind CUSTOM XML, ANSI X12, UN/EDIFACT, FLATFILE (mit Trennzeichen oder mit Feldern fester Breite), CUSTOM und RELIABLE. Das RELIABLE-Format verarbeitet Umschläge, die mitBizTalk Framework 2.0 kompatibel sind. Weitere Informationen zu BizTalk Framework 2.0 finden Sie in der Microsoft BizTalk-Website (www.microsoft.com/biztalk/). Wenn Sie ein CUSTOM-Umschlagsformat angeben, müssen Sie eine benutzerdefinierte Parserkomponente erstellen und registrieren, um eingehende Umschläge zu verarbeiten oder eine benutzerdefinierte Serialisierungskomponente, um ausgehende Umschläge zu verarbeiten. Weitere Informationen finden Sie unter Using the IBizTalkParserComponent Interface und Using the IBizTalkSerializerComponent Interface.

Um BizTalk Server 2000 die Verarbeitung von eingehenden Austauschvorgängen mit den Formaten CUSTOM XML oder FLATFILE zu ermöglichen, müssen Sie Umschläge in einem passenden Format erstellen. Sie müssen eine benutzerdefinierte Parserkomponente erstellen und registrieren, um BizTalk Server 2000 die Verarbeitung von eingehenden Austauschvorgängen in einem benutzerdefinierten Format zu ermöglichen. BizTalk Server 2000 kann eingehende Austauschvorgänge in den Formaten ANSI X12, UN/EDIFACT oder RELIABLE verarbeiten, ohne dazu einen mithilfe des BizTalk-Messaging-Managers erstellten Umschlag zu verwenden.

Zum Verarbeiten von ausgehenden Dokumenten in beliebigen Formaten müssen Sie einen Umschlag erstellen und ihn in einem Messagingport auswählen, um einen Austausch mit dem erforderlichen Umschlagsformat und den erforderlichen Kopfzeileninformationen zu erstellen. BizTalk Server 2000 platziert nur ein Dokument in jeden ausgehenden Austausch.

Wenn Sie einen Umschlag mit einem X12- oder EDIFACT-Format in einem Messagingport auswählen, müssen Sie außerdem Trennzeichen und eine Austauschkontrollnummer angeben. Diese EDI-Eigenschaften wirken sich nur auf die Umschläge aus, die für die Verwendung mit diesem Messagingport ausgewählt sind. Wenn Sie einen Umschlag mit einem CUSTOM-Format auswählen, sind Trennzeichen und Austauschkontrollnummer optional und hängen von den Anforderungen der benutzerdefinierten Parser- oder Serialisierungskomponenten ab. Wenn Sie einen Kanal für einen Messagingport erstellen, der einen Umschlag mit den Formaten X12, EDIFACT oder CUSTOM verwendet, können Sie eine funktionale Gruppenkontrollnummer angeben, die sich nur auf Dokumente angewendet wird, die von dieser Kombination aus Kanal und Messagingport verarbeitet werden.

Das Format des in einem Messagingport ausgewählten Umschlags muss mit dem Format des ausgehenden Dokuments übereinstimmen, das er enthält. Das Format des ausgehenden Dokuments wird durch die Spezifikation bestimmt, auf die die ausgehende Dokumentdefinition eines Kanals verweist. Wenn Sie z. B. einen Umschlag mit einem X12-Format für einen Messagingport auswählen, müssen Sie beim Erstellen eines Kanals für diesen Messagingport eine ausgehende Dokumentdefinition auswählen, die auf eine Spezifikation verweist, die ebenfalls über ein X12-Format verfügt.

Wenn Sie beim Erstellen eines Messagingports keinen Umschlag angeben, werden die Daten ohne Kopfzeile im XML-Format gesendet.

Anmerkung

  • Beim Verarbeiten von Umschlägen, die mit BizTalk Framework 2.0 kompatibel sind, sollte BizTalk Server 2000 hinsichtlich des Ablaufzeitpunktes als Endpunkt angesehen werden. Wenn BizTalk Framework 2.0–kompatible Dokumente an BizTalk Server 2000 versendet werden, entweder von einer Anwendung oder von einem Handelspartner, werden die folgenden Felder überschrieben, wenn sie vorhanden sind. Sind die folgenden Felder nicht vorhanden, werden sie erstellt:
    • Im Unterabschnitt mit den Eigenschaften:

      <prop:identity>

      <prop:sentAt>

      <prop:expiresAt>

    • Im Unterabschnitt mit den Empfangsinformationen:

      <sendTo>

      <address>

      <sendReceiptBy>

Folgende Themen werden in diesem Abschnitt behandelt:

  • Verwenden von Umschlägen für die eingehende Verarbeitung

  • Verwenden von Umschlägen für die ausgehende Verarbeitung

Verwandte Themen

Erstellen und Verwalten von Umschlägen

Grundlegendes zu Messagingports


Verwenden von Umschlägen für die eingehende Verarbeitung

Microsoft BizTalk Server 2000 kann einen eingehenden Austausch in einem X12- oder EDIFACT-Format verarbeiten, ohne dazu einen mithilfe des BizTalk-Messaging-Managers erstellten Umschlag zu verwenden.

Damit BizTalk Server 2000 einen eingehenden Austausch mit einem FLATFILE-Format verarbeiten kann, müssen Sie mithilfe des BizTalk-Messaging-Managers einen Umschlag erstellen. Dieser Umschlag muss auf eine Spezifikation verweisen, die der Server zum Interpretieren und Öffnen des Austauschs verwenden kann. Der Name des Umschlags muss dem Server zur Verfügung gestellt werden, wenn der Austausch für die Verarbeitung versendet wird. Weitere Informationen finden Sie unter Submitting.

Damit BizTalk Server 2000 einen eingehenden Austausch mit einem CUSTOM XML-Format verarbeiten kann, müssen Sie mithilfe des BizTalk-Messaging-Managers einen Umschlag erstellen. Der Server kann jedoch den Umschlag mit dem CUSTOM XML-Format finden, den er für das Interpretieren und Öffnen des Austauschs benötigt, ohne dass ihm der Name des Umschlags beim Versenden zur Verfügung gestellt wird. Sie können dem Server den Namen des Umschlags beim Versenden zur Verfügung stellen, dies ist jedoch nicht erforderlich. Weitere Informationen finden Sie unter Submitting.

Damit BizTalk Server 2000 einen eingehenden Austausch mit einem CUSTOM-Format verarbeiten kann, müssen Sie einen benutzerdefinierten Parser erstellen, um den Austausch zu öffnen. Weitere Informationen finden Sie unter Using the IBizTalkParserComponent Interface.

Die Umschläge, die Sie für die Verarbeitung von eingehenden Austauschvorgängen erstellen, müssen nicht in einem Messagingport ausgewählt werden, der vom Server verwendet werden soll. Nur Umschläge für die Verarbeitung von ausgehenden Austauschvorgängen müssen in einem Messagingport ausgewählt werden.

Verwandte Themen

Erstellen und Verwalten von Umschlägen

Grundlegendes zu Umschlägen

Verwenden von Umschlägen für die ausgehende Verarbeitung


Verwenden von Umschlägen für die ausgehende Verarbeitung

Messagingports regulieren den ausgehenden Datenfluss von Microsoft BizTalk Server 2000 zu einem angegebenen Ziel. Beim Erstellen eines Messagingports können Sie einen Umschlag für die Dokumente auswählen, die von diesem Messagingport verarbeitet werden. Wenn Sie einen Umschlag auswählen, muss das Umschlagsformat mit dem Format der Dokumente übereinstimmen, die er enthält. Das Format der Dokumente wird durch die Spezifikation bestimmt, auf die die ausgehende Dokumentdefinition eines Kanals verweist. Nachdem Sie mithilfe des BizTalk-Messaging-Managers einen Umschlag erstellt haben, können Sie diesen in einer beliebigen Anzahl von Messagingports verwenden.

Wenn BizTalk Server 2000 ein ausgehendes Dokument verarbeitet, verwendet der Server die Eigenschaften des im Messagingport ausgewählten Umschlags, um einen Austausch zu erstellen, indem er das Dokument einkapselt oder mit einem Präfix versieht. Wenn Sie keinen Umschlag für einen Messagingport angeben, werden die Daten ohne Kopf- oder Fußzeile im XML-Format gesendet. Wenn Sie ein CUSTOM XML-Format angeben, jedoch keine Umschlagspezifikation auswählen, werden die Dateien im RELIABLE-Format gesendet . Das RELIABLE-Format verarbeitet Umschläge, die mit BizTalk Framework 2.0 kompatibel sind. Weitere Informationen zu BizTalk Framework 2.0 finden Sie in der Microsoft BizTalk-Website (www.microsoft.com/biztalk/).

Damit BizTalk Server 2000 einen ausgehenden Austausch mit einem CUSTOM-Format verarbeiten kann, müssen Sie für das Erstellen eines Austauschs eine benutzerdefinierte Serialisierungskomponente erstellen. Weitere Informationen finden Sie unter Using the IBizTalkSerializerComponent Interface.

Wenn Sie einen Umschlag mit einem X12- oder EDIFACT-Format auswählen, müssen Sie eine Austauschkontrollnummer und Trennzeichen angeben. Eine Austauschkontrollnummer wird für das Identifizieren und Überwachen von Dokumenten verwendet, die mithilfe des Messagingports verarbeitet werden. Die Austauschkontrollnummer wird bei jeder Verwendung des Umschlags und Messagingports erhöht. Trennzeichen geben die Zeichen an, die zum Trennen der Datensätze und Felder des Umschlags und des im Umschlag enthaltenen Dokuments verwendet werden. Bei Umschlägen mit einem CUSTOM-Format sind Austauschkontrollnummer und Trennzeichen optional.

Wichtig

  • Das Umschlagsformat für einen Messagingport muss mit dem Format des Dokumenttyps der Spezifikation übereinstimmen, auf die die ausgehende Dokumentdefinition für jeden der zugeordneten Kanäle verweist. Wenn Sie z. B. einen Umschlag mit einem X12-Format für einen Messagingport auswählen, müssen Sie für den Kanal eine ausgehende Dokumentdefinition auswählen, die auf eine X12-Spezifikation verweist.

Verwandte Themen

Erstellen und Verwalten von Umschlägen

Grundlegendes zu Umschlägen

Verwenden von Umschlägen für die eingehende Verarbeitung


Grundlegendes zu Empfangsbestätigungen

Beim Austausch von Dokumenten mit einem Handelspartner erwarten Ihre Geschäftsvorgänge möglicherweise, dass Sie Empfangsbestätigungen für gesendete Dokumente erhalten oder Empfangsbestätigungen für Dokumente generieren, die ein Handelspartner an Ihr Unternehmen sendet.

Die BizTalk-Messagingdienste stellen zwei Verfahren für das Verarbeiten von Empfangsbestätigungen für Austauschvorgänge zur Verfügung. Bei Austauschvorgängen, die den X12- oder EDIFACT-Parser oder einen benutzerdefinierten Parser, der Empfangsbestätigungen erfordert, verwenden, können Sie den BizTalk-Messaging-Manager so konfigurieren, dass Kanaleigenschaften für die Verarbeitung von Empfangsbestätigungen verwendet werden. Bei Austauschvorgängen, die den XML-Parser verwenden, besteht die Möglichkeit, Reliable Messaging zu verwenden, das Empfangsbestätigungen automatisch verarbeitet, um die zuverlässige Übermittlung von Daten sicherzustellen.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Verarbeiten von Empfangsbestätigungen mithilfe von Kanälen

  • Verarbeiten von Empfangsbestätigungen mithilfe von Reliable Messaging


Verarbeiten von Empfangsbestätigungen mithilfe von Kanälen

Dieser Abschnitt erläutert, wie Sie die BizTalk-Messagingdienste für die Verwendung von Kanaleigenschaften zum Steuern der Verarbeitung von Empfangsbestätigungen konfigurieren können. Das Zielsystem ist für das Generieren (das Senden) von Empfangsbestätigungen an das Quellsystem konfiguriert. Das Quellsystem ist so konfiguriert, dass es Empfangsbestätigungen vom Zielsystem erwartet (empfängt) und sie mit den ursprünglichen Austauschvorgängen korreliert. Diese Konfiguration wird nur dann angewendet, wenn Sie Austauschvorgänge verarbeiten, die den X12- oder EDIFACT-Parser oder einen benutzerdefinierten Parser verwenden, der Empfangsbestätigungen erfordert. Weitere Informationen zum Erstellen benutzerdefinierter Parser finden Sie unter Using the IBizTalkParserComponent Interface. Wenn Sie Austauschvorgänge verarbeiten, die den XML-Parser verwenden, finden Sie weitere Informationen unter Verarbeiten von Empfangsbestätigungen mithilfe von Reliable Messaging.

Wenn Sie einen benutzerdefinierten Parser verwenden und Empfangsbestätigungen mit den ursprünglichen Austauschvorgängen korrelieren möchten, müssen Sie eine benutzerdefinierte Korrelationskomponente verwenden.

Damit das Quellsystem Empfangsbestätigungen empfängt, muss auch das Zielsystem für das Senden von Empfangsbestätigungen konfiguriert sein. Das Konfigurieren eines Kanals auf dem Quellsystem für das Entgegennehmen von Empfangsbestätigungen ist für den Empfang von Empfangsbestätigungen nicht ausreichend.

Die folgende Abbildung zeigt die Konfiguration sowohl für das Quell- als auch für das Zielsystem beim Verwenden von Kanaleigenschaften für die Verarbeitung von Empfangsbestätigungen.

Verarbeiten von Empfangsbestätigungen mithilfe von Kanälen
Generieren und senden von Empfangsbestätigungen
Empfangen und korrelieren von Empfangsbestätigungen
Austausch empfangen und verarbeiten
Zielsystem
Quellsystem
Messagingport zum
Zielsystem
Auftrag
Parser
Messaging-
port zum
Zielsystem
Ausgehende
Dokument-
definition
Empfangsbestätigung
Dokument-
spezifikation
Dokument-
spezifikation
Eingehende
Dokument-
definition
Zuord-
nung
Empfangskanal
Standard-
empfangsbestätigung
Messagingport
zur Anwendung
Kanal vom
Quellsystem
Dokument-
spezifikation
Empfangsbestätigungs-
dokumentdefinition
Kanal für Auftrag
Austausch generieren und senden

Folgende Themen werden in diesem Abschnitt behandelt:

  • Konfigurieren des Quellsystems für Empfangsbestätigungen an einem Kanal

  • Konfigurieren des Zielsystems für Empfangsbestätigungen an einem Kanal


Konfigurieren des Quellsystems für Empfangsbestätigungen an einem Kanal

Dieses Thema erläutert die Konfiguration der BizTalk-Messagingdienste für das Senden eines Austauschs an einen Handelspartner und für die Verarbeitung einer Empfangsbestätigung mithilfe von Kanaleigenschaften.

Sie müssen einen Kanal und einen Messagingport erstellen, um einen Austausch zu verarbeiten und an das Zielsystem zu senden. Sie brauchen keinen Kanal und Messagingport zu erstellen, um die Empfangsbestätigung zu verarbeiten, die vom Zielsystem zurückgegeben wird. Sie müssen jedoch eine Dokumentdefinition erstellen, die der Server verwendet, um die Gültigkeit der Empfangsbestätigung bei der Rückgabe zu überprüfen.

Um die BizTalk-Messagingdienste für das Senden eines Austauschs an ein Zielsystem und das Verarbeiten einer Empfangsbestätigung mithilfe von Kanaleigenschaften zu konfigurieren, führen Sie die in der folgenden Tabelle aufgeführten Schritte aus. Verweise werden für jedes Verfahren bereitgestellt, und Anmerkungen weisen auf bestimmte Konfigurationsprobleme hin. Andere Einstellungen für Eigenschaften, die für das Abschließen der Konfiguration erforderlich sind, hängen von der einzelnen Geschäftssituation ab und werden hier nicht angegeben.

Schritt Verweise und Anmerkungen
Verwenden des BizTalk-Editors:
  • Erstellen Sie die Spezifikationen für die eingehenden und ausgehenden Dokumentdefinitionen für das ursprüngliche Dokument für den Austausch. Darüber hinaus müssen Sie eine Spezifikation für die Dokumentdefinition erstellen, die der Server verwendet, um die Gültigkeit der Empfangsbestätigung beim Empfang zu überprüfen.
  • Erstellen und Überprüfen von Spezifikationen

    Anmerkungen

    • Für die ausgehende Dokumentdefinition für den Kanal müssen Sie eine Spezifikation erstellen, die das vom Zielsystem erforderte Format verwendet. Beispielsweise X12.

    Wenn die BizTalk-Messagingdienste auf dem Zielsystem den Austausch verarbeiten und der Parser Empfangsbestätigungen erfordert, führt der Parser folgende Aktionen durch:

  • Extrahieren der Kopfzeilenelemente aus dem Austausch.

  • Generieren einer BizTalk-Standardempfangsbestätigung.

  • Einfügen der Elemente in die Standardempfangsbestätigung.

    Für das Quellsystem muss die Spezifikation für die ausgehende Dokumentdefinition des Kanals, der für die Verarbeitung des Austauschs verwendet wird, diese Felder ebenfalls enthalten. Auch die Spezifikation für die Dokumentdefinition zur Gültigkeitsprüfung der Empfangsbestätigung muss diese Felder enthalten. Das Quellsystem verwendet diese Elemente, um die Empfangsbestätigung mit dem ursprünglichen Austausch zu korrelieren.

    Es gibt folgende X12-Kopfzeilenelemente:

    • functional_identifier

    • standards_version

    Die EDIFACT-Kopfzeilenelemente sind:

    • functional_identifier

    • standards_version_type

    • standards_version_value
Verwenden des BizTalk-Messaging-Managers:
  • Erstellen Sie die eingehenden und ausgehenden Dokumentdefinitionen für das Erstellen des Kanals und eine Dokumentdefinition für die Empfangsbestätigung.
  • Erstellen von Dokumentdefinitionen

    Anmerkungen

    • In den Dokumentdefinitionen müssen Sie die zuvor erstellten Spezifikationen auswählen. Weitere Informationen finden Sie unter Auswählen einer Dokumentspezifikation.

    • Sie müssen außerdem eine Dokumentdefinition für die Empfangsbestätigung erstellen.
  • Erstellen Sie einen Messagingport für das Transportieren der Empfangsbestätigung an das Quellsystem.
  • Erstellen von Messagingports

    Anmerkung

    • Sie müssen den Messagingport und seinen zugeordneten Empfangskanal für die Verarbeitung der Empfangsbestätigung zuerst erstellen. Wenn Sie den Kanal für die Verarbeitung des ursprünglichen Austauschs erstellen, müssen Sie den Empfangskanal angeben.
  • Erstellen Sie einen Messagingport für das Transportieren des Austauschs zum Zielsystem.
  • Erstellen von Messagingports
  • Erstellen Sie einen Kanal, um den ursprünglichen Austausch von Ihrem Handelspartner zu verarbeiten.
  • Erstellen von Kanälen

    Anmerkungen

    • Aktivieren Sie auf der Seite Quellanwendung oder Quellorganisation des Kanal-Assistenten das Kontrollkästchen Erwartete Empfangsbestätigung.

    • Legen Sie im Bereich Erwartete Empfangsbestätigung im Feld Empfangsbestätigungsintervall in Minuten den Zeitraum fest, der bis zum Empfang der Empfangsbestätigung gewartet werden soll, bevor der ursprüngliche Austausch erneut gesendet wird. Weitere Informationen finden Sie unter Festlegen von Eigenschaften für die Quellanwendung oder Festlegen von Eigenschaften für die Quellorganisation.
Verwenden der BizTalk-Dokumentüberwachung:
  • Der ursprüngliche Austausch wird in der Überwachungsdatenbank protokolliert, und das Statusfeld der Empfangsbestätigung wird auf Ausstehend festgelegt. Der Status der Empfangsbestätigung in der Überwachungsdatenbank ändert sich nachfolgend, um den Status des Empfangsprozesses wiederzugeben.
  • Grundlegendes zu Ergebnissen von Dokumentinstanz-Datensätzen

  • Grundlegendes zu den Ergebnissen von Empfangsbestätigungen

Versenden von Empfangsbestätigungen auf dem Quellsystem

Empfangsbestätigungen werden an die BizTalk-Messagingdienste in der gleichen Weise versendet wie andere Dokumente. Nachdem eine Empfangsbestätigung versendet wurde, können die X12- und EDIFACT-Parser eine Empfangsbestätigung von anderen Dokumenten unterscheiden und den Server anweisen, die Empfangsbestätigung mit dem ursprünglichen Austausch zu korrelieren.

Wichtig

  • Empfangsbestätigungen müssen an die BizTalk-Messagingdienste ohne die Verwendung von Versendungsparametern versendet werden.


Konfigurieren des Zielsystems für Empfangsbestätigungen an einem Kanal

Dieses Thema erläutert die Konfiguration der BizTalk-Messagingdienste für die Verarbeitung eines Austauschs von einem Handelspartner und für das Generieren einer Empfangsbestätigung mithilfe von Kanaleigenschaften. Zu diesem Zweck müssen Sie einen Kanal und einen Messagingport erstellen, um den ausgehenden Austausch zu verarbeiten und ihn an das Zielsystem zu senden. Sie brauchen keinen Kanal oder Messagingport für die Verarbeitung der Empfangsbestätigung zu erstellen, die das Zielsystem zurückgibt. Ein Parser verarbeitet die Empfangsbestätigung mithilfe lediglich einer Dokumentdefinition.

Um die BizTalk-Messagingdienste für das Verarbeiten eines Austauschs vom Quellsystem und das Senden einer Empfangsbestätigung mithilfe von Kanaleigenschaften zu konfigurieren, führen Sie die in der folgenden Tabelle aufgeführten Schritte aus. Verweise werden für jedes Verfahren bereitgestellt, und Anmerkungen weisen auf bestimmte Konfigurationsprobleme hin. Andere Einstellungen für Eigenschaften, die für das Abschließen der Konfiguration erforderlich sind, hängen von der einzelnen Geschäftssituation ab und werden hier nicht angegeben.

Schritt Verweise und Anmerkungen
Verwenden des BizTalk-Editors:
  • Erstellen Sie die Spezifikationen für die eingehenden und ausgehenden Dokumentdefinitionen, die zum Erstellen des Empfangskanals verwendet werden.
  • Erstellen und Überprüfen von Spezifikationen

    Anmerkungen

    • Für die eingehende Dokumentdefinition des Empfangskanals verwenden Sie die BizTalk-Standardempfangsbestätigungs-Spezifikation. Diese Spezifikation befindet sich im WebDAV-Repository.

    • Für die ausgehende Dokumentdefinition des Empfangskanals müssen Sie eine Spezifikation erstellen, die das von Ihren Geschäftsabläufen erforderte Format verwendet.

    Wenn die BizTalk-Messagingdienste auf dem Zielsystem einen eingehenden Austausch verarbeiten und der Parser Empfangsbestätigungen erfordert, führt der Parser folgende Aktionen durch:

    • Extrahieren von Gruppenkopfzeilen-Elementen.

    • Generieren einer BizTalk-Standardempfangsbestätigung.

    • Einfügen der Kopfzeilenelemente in die Standardempfangsbestätigung.

    Die ausgehende Dokumentspezifikation für den Empfangskanal muss Felder für diese Kopfzeilenelemente enthalten. Das Quellsystem verwendet die Kopfzeilenelemente, um die Empfangsbestätigung mit dem ursprünglichen Austausch zu korrelieren.

    Es gibt folgende X12-Kopfzeilenelemente:

    • functional_identifier

    • standards_version

    Es gibt folgende EDIFACT-Kopfzeilenelemente:

    • functional_identifier

    • standards_version_type

    • standards_version_value
  • Erstellen Sie die Spezifikationen für die eingehenden und ausgehenden Dokumentdefinitionen, die für die Erstellung des Kanals verwendet werden, der den ursprünglichen Austausch vom Quellsystem verarbeitet.
  • Erstellen und Überprüfen von Spezifikationen
Verwenden des BizTalk-Mappers:
  • Erstellen Sie eine Zuordnung für den Empfangskanal.
  • Erstellen neuer Zuordnungen

    Anmerkungen

    • Beim Erstellen des Empfangskanals müssen Sie eine Zuordnung angeben. Die Zuordnung wird verwendet, um die BizTalk-Standardempfangsbestätigung in den richtigen Dokumenttyp für das ausgehende Dokument umzuwandeln.

    • Sie können eine der Zuordnungen im Lieferumfang von BizTalk Server 2000 verwenden, wenn sie dem für Ihren Geschäftsablauf erforderlichen Format entspricht. Sie können diese Zuordnungen aus dem WebDAV-Repository abrufen.

      Oder

    • Sie können eine eigene Zuordnung mithilfe der BizTalk-Standardempfangsbestätigungs-Spezifikation und einer Spezifikation erstellen, die dem für Ihren Geschäftsablauf erforderlichen Dokumenttyp entspricht.
Verwenden des BizTalk-Messaging-Managers:
  • Erstellen Sie die Dokumentdefinitionen für den Empfangskanal und für den Kanal, den Sie zum Verarbeiten des ursprünglichen Austauschs verwenden.
  • Erstellen von Dokumentdefinitionen

    Anmerkungen

    • In den Dokumentdefinitionen müssen Sie die zuvor erstellten Spezifikationen auswählen. Weitere Informationen finden Sie unter Auswählen einer Dokumentspezifikation.

    • Sie müssen außerdem die Dokumentdefinitionen für den Kanal erstellen, der für die Verarbeitung des ursprünglichen Austauschs verwendet wird. Deren Konfiguration unterscheidet sich in Abhängigkeit von Ihrem Geschäftsablauf.
  • Erstellen Sie einen Messagingport für das Transportieren der Empfangsbestätigung an das Quellsystem.
  • Erstellen von Messagingports

    Anmerkung

    • Sie müssen den Messagingport und den ihm zugeordneten Empfangskanal für die Verarbeitung der Empfangsbestätigung erstellen, bevor Sie die entsprechenden Komponenten für die Verarbeitung des ursprünglichen Austauschs erstellen. Wenn Sie den Kanal für die Verarbeitung des ursprünglichen Austauschs erstellen, müssen Sie den Empfangskanal angeben.
  • Erstellen Sie einen Empfangskanal aus einer Anwendung für die Verarbeitung der Empfangsbestätigung.
  • Erstellen von Kanälen

    Anmerkungen

    • Aktivieren Sie auf der Seite Allgemeine Informationen des Kanal-Assistenten das Kontrollkästchen Dies ist ein Empfangskanal.

    • Wählen Sie auf der Seite Quellanwendung des Kanal-Assistenten in der Liste Name eine Anwendung aus.

      Sie können eine Anwendung für die eigene Organisation erstellen, die Sie zum Zuweisen der von den Parsern generierten Empfangsbestätigungen verwenden.

    • Klicken Sie auf der Seite Eingehendes Dokument des Kanal-Assistenten auf Durchsuchen, und suchen Sie die Dokumentdefinition, die Sie zuvor erstellt haben und die die BizTalk-Standardempfangsbestätigungs-Spezifikation verwendet.

    • Klicken Sie auf der Seite Ausgehendes Dokument des Kanal-Assistenten auf Durchsuchen, und suchen Sie nach der Dokumentdefinition, die Sie zuvor erstellt haben und die die Spezifikation für den von Ihrem Geschäftsablauf erforderten Dokumenttyp verwendet.
  • Erstellen Sie einen Messagingport für den Transport der im ursprünglichen Austausch enthaltenen Dokumente an das vorgesehene Ziel.
 Erstellen von Messagingports

Anmerkung

  • Dieser Messagingport benötigt keine besondere Konfiguration zum Verarbeiten von Empfangsbestätigungen.

  • Erstellen Sie einen Kanal, um den ursprünglichen Austausch von Ihrem Handelspartner zu verarbeiten.
  • Erstellen von Kanälen

    Anmerkungen

    • Aktivieren Sie auf der Seite Quellorganisation des Kanal-Assistenten das Kontrollkästchen Empfangsbestätigung generieren.

    • Klicken Sie im Bereich Empfangsbestätigung generieren auf Durchsuchen, und wählen Sie den Empfangskanal aus, den Sie für die Verarbeitung der Empfangsbestätigung erstellt haben. Weitere Informationen finden Sie unter Festlegen von Eigenschaften für die Quellorganisation.

    • Auf der Seite Erweiterte Konfiguration des Kanal-Assistenten können Sie im Bereich Wiederholungsoptionen die Anzahl der Wiederholungsversuche und das Intervall festlegen. Weitere Informationen finden Sie unter Festlegen von erweiterten Konfigurationseigenschaften.
Verwenden der BizTalk-Dokumentüberwachung:
  • Der ursprüngliche Austausch und die Empfangsbestätigung werden in der Überwachungsdatenbank protokolliert.
  • Grundlegendes zu Ergebnissen von Dokumentinstanz-Datensätzen

  • Grundlegendes zu den Ergebnissen von Empfangsbestätigungen


Verarbeiten von Empfangsbestätigungen mithilfe von Reliable Messaging

Dieser Abschnitt erläutert die Konfiguration der BizTalk-Messagingdienste für das Senden und Empfangen von Empfangsbestätigungen mithilfe von Reliable Messaging-Umschlägen, die Austauschvorgänge erstellen, die mit BizTalk Framework 2.0 kompatibel sind. Reliable Messaging erlaubt die automatische Verarbeitung von Empfangsbestätigungen, um die zuverlässige Übermittlung von Daten sicherzustellen. Weitere Informationen zu BizTalk Framework 2.0 finden Sie in der Microsoft BizTalk-Website unter (www.microsoft.com/biztalk/). Wenn Sie Austauschvorgänge senden und empfangen, die den X12-, EDIFACT- oder einen benutzerdefinierten Parser verwenden, finden Sie weitere Informationen unter Verarbeiten von Empfangsbestätigungen mithilfe von Kanälen.

Mithilfe des BizTalk-Messaging-Managers können Sie einen Messagingport für die Verwendung eines RELIABLE-Umschlagsformats für einen ausgehenden Austausch konfigurieren. Umschläge, die das Reliable Messaging-Format verwenden, müssen immer eine Antwort-URL-Adresse in der Kopfzeile enthalten. Die Antwortadresse wird vom Zielsystem verwendet, um eine Empfangsbestätigung an das Absendersystem des Austauschs zu senden.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Konfigurieren des Quellsystems für Reliable Messaging-Empfangsbestätigungen

  • Konfigurieren des Zielsystems für Reliable Messaging-Empfangsbestätigungen


Konfigurieren des Quellsystems für Reliable Messaging-Empfangsbestätigungen

Um die BizTalk-Messagingdienste für das Senden eines Austauschs an ein Zielsystem und für das Verarbeiten einer Empfangsbestätigung mithilfe von Reliable Messaging zu konfigurieren, führen Sie die Schritte in der folgenden Tabelle durch. Verweise werden für jedes Verfahren bereitgestellt, und Anmerkungen weisen auf bestimmte Konfigurationsprobleme hin. Andere Einstellungen für Eigenschaften, die für das Abschließen der Konfiguration erforderlich sind, hängen von der einzelnen Geschäftssituation ab und werden hier nicht angegeben.

Schritt Verweise und Anmerkungen
Verwenden der BizTalk Server-Verwaltung:
  • Konfigurieren Sie die Eigenschaften der Antwortadresse für Reliable Messaging.
  • Konfigurieren von allgemeinen Eigenschaften für eine Servergruppe.

    Anmerkungen

    • Erweitern Sie in der BizTalk Server-Verwaltung Microsoft BizTalk Server 2000, und klicken Sie dann auf die zu konfigurierende Servergruppe.

    • Klicken Sie im Menü Vorgang auf Eigenschaften.

    • Geben Sie im Dialogfeld Eigenschaften von BizTalk Server-Gruppe im Feld Antwort-URL für Reliable Messaging den URL ein, den diese Servergruppe für den Empfang von Reliable Messaging-Empfangsbestätigungen verwendet.

      Wenn Sie einen ausgehenden Austausch erstellen, der einen Reliable Messaging-Umschlag verwendet, setzt der Server automatisch den Antwort-URL für Reliable Messaging in die Kopfzeile des ausgehenden Austauschs ein. Außerdem platziert der Server den ursprünglichen Austausch in der Wiederholungswarteschlange. Der Server verwendet die im Kanal angegebenen Wiederholungsoptionen, um die Anzahl der erneuten Sendeversuche des ursprünglichen Austauschs bis zum Empfang einer Empfangsbestätigung zu ermitteln.
Verwenden des BizTalk-Messaging-Managers:
  • Erstellen Sie einen Umschlag, der das RELIABLE-Umschlagsformat verwendet.
  • Erstellen von Umschlägen

    Anmerkungen

    • Klicken Sie im Dialogfeld Neuer Umschlag in der Liste Umschlagsformat auf RELIABLE.

    • Wenn Sie das CUSTOM XML-Format auswählen und keine Spezifikation auswählen, ist das Standardumschlagsformat RELIABLE.
  • Erstellen Sie einen Messagingport für das Transportieren des ursprünglichen Austauschs zum Zielsystem.
  • Erstellen von Messagingports

    Anmerkung

  • Wählen Sie auf der Seite Umschlagsinformationen des Messagingport-Assistenten im Bereich Umschlagsinformationen den zuvor erstellten Umschlag aus. Weitere Informationen finden Sie unter Festlegen von Eigenschaften für die Umschlagsinformationen.
  • Erstellen Sie einen Kanal für die Verarbeitung des ursprünglichen Austauschs.
  • Erstellen von Kanälen

    Anmerkungen

    • Legen Sie auf der Seite Quellanwendung oder Quellorganisation des Kanal-Assistenten keine Empfangsbestätigungseigenschaften fest.

    • Auf der Seite Erweiterte Konfiguration des Kanal-Assistenten können Sie im Bereich Wiederholungsoptionen die Anzahl der Wiederholungsversuche und das Intervall festlegen. Weitere Informationen finden Sie unter Festlegen von erweiterten Konfigurationseigenschaften.
Verwenden der BizTalk-Dokumentüberwachung:
  • Auf dem Quellsystem wird der ursprüngliche ausgehende Austausch in der Überwachungsdatenbank protokolliert; auf die zurückgegebene Empfangsbestätigung trifft dies jedoch nicht zu.
  • Grundlegendes zu Ergebnissen von Dokumentinstanz-Datensätzen

  • Grundlegendes zu den Ergebnissen von Empfangsbestätigungen


Konfigurieren des Zielsystems für Reliable Messaging-Empfangsbestätigungen

Wenn die BizTalk-Messagingdienste für das Zielsystem einen Austausch im Reliable Messaging-Format empfangen, verwenden sie eine bestimmte Kombination aus Dokumentdefinition, Kanal und Messagingport, um eine Empfangsbestätigung zu verarbeiten und zum Quellsystem zu transportieren. Diese besonderen Systemobjekte werden im BizTalk-Messaging-Manager nicht angezeigt. Außerdem können Sie ähnliche Objekte nicht unter Verwendung der reservierten Systemnamen erstellen.

Der Server verwendet die in der Kopfzeile des ausgehenden Austauschs vorhandene Antwortadresse als Zieladresse für die Empfangsbestätigung.

Sie brauchen die BizTalk-Messagingdienste nicht weiter zu konfigurieren, damit das Zielsystem eine Empfangsbestätigung für einen Austausch zurückgibt, der mit einem Reliable Messaging-Umschlag gesendet wird, es sei denn, das Quellsystem gibt eine SMTP-Adresse als Antwort-URL-Adresse für Reliable Messaging an. Um Empfangsbestätigungen an eine SMTP-Adresse zu senden, muss Ihr Server so konfiguriert sein, dass er eine Absenderadresse in die Kopfzeile der Empfangsbestätigung enthält.

Bei der Installation von BizTalk Server 2000 wird ein Organisationskennzeichen für die eigene Organisation erstellt. Dieses Kennzeichen trägt den Namen SMTP-"Von"-Adresse der Reliable Messaging-Bestätigung und kann nicht entfernt werden. Beim Senden einer Reliable Messaging-Empfangsbestätigung an eine SMTP-Adresse fügt der Server den für dieses Organisationskennzeichen angegebenen Wert als Absenderadresse in die Austauschkopfzeile ein.

Um die BizTalk-Messagingdienste für das Senden einer Empfangsbestätigung an ein Zielsystem unter Verwendung einer SMTP-Antwortadresse für Reliable Messaging zu konfigurieren, führen Sie die Schritte in der folgenden Tabelle aus. Verweise werden für jedes Verfahren bereitgestellt, und Anmerkungen weisen auf bestimmte Konfigurationsprobleme hin. Andere Einstellungen für Eigenschaften, die für das Abschließen der Konfiguration erforderlich sind, hängen von der einzelnen Geschäftssituation ab und werden hier nicht angegeben.

Schritt Verweise und Anmerkungen
Verwenden des BizTalk-Messaging-Managers:
  • Konfigurieren Sie das Organisationskennzeichen für die SMTP-"Von"-Adresse der Reliable Messaging-Bestätigung der eigenen Organisation.
  • Konfigurieren der eigenen Organisation

    Anmerkungen

    • Öffnen Sie die eigene Organisation.

    • Klicken Sie im Dialogfeld Organisationseigenschaften auf die Registerkarte Bezeichner.

    • Klicken Sie in der Liste Organisationskennzeichen auf SMTP-"Von"-Adresse der Reliable Messaging-Bestätigung, und klicken Sie dann auf Bearbeiten.

    • Geben Sie im Dialogfeld Bezeichnereigenschaften im Feld Wert einen Wert für das Kennzeichen ein. Weitere Informationen finden Sie unter Bearbeiten von Organisationskennzeichen.

    Wichtig

    • Ändern Sie nicht den Namen oder Qualifizierer dieses Kennzeichens, sondern nur seinen Wert.
  • Erstellen Sie einen Messagingport für das Transportieren des ursprünglichen Austauschs zum beabsichtigten Ziel.
  • Erstellen von Messagingports

    Anmerkung

    • Dieser Messagingport erfordert keine besondere Konfiguration.
  • Erstellen Sie einen Kanal für die Verarbeitung des ursprünglichen Austauschs.
  • Erstellen von Kanälen

    Anmerkung

    • Dieser Messagingport erfordert keine besondere Konfiguration.
Verwenden der BizTalk-Dokumentüberwachung:
  • Auf dem Zielsystem wird der eingehende Austausch in der Überwachungsdatenbank protokolliert, nicht jedoch die Empfangsbestätigung.
  • Grundlegendes zu Ergebnissen von Dokumentinstanz-Datensätzen

  • Grundlegendes zu den Ergebnissen von Empfangsbestätigungen


Grundlegendes zu Verteilerlisten

Eine Verteilerliste ist eine Gruppe von Messagingports, mit deren Hilfe Sie das gleiche Dokument an mehrere verschiedene Organisationen von Handelspartnern oder interne Anwendung senden können.

Sie können eine Verteilerliste verwenden, um die gleichen Daten an mehrere Handelspartnerorganisationen oder interne Anwendungen Ihrer eigenen Organisation zu senden. Beispielsweise können Sie den gleichen Katalog, die gleiche Preisliste oder den gleichen Newsletter an mehrere Handelspartnerorganisationen senden, indem Sie die Informationen nur einmal an Microsoft BizTalk Server 2000 versenden.

Sie müssen zuerst einen Messagingport zu allen Handelspartnerorganisationen oder internen Anwendungen erstellen, die die Daten erhalten sollen. Fügen Sie anschließend die Messagingports zu einer Verteilerliste hinzufügen. Offene Messagingports können zu einer Verteilerliste nicht hinzugefügt werden. Sie können neue Messagingports zu weiteren Handelspartnerorganisationen oder internen Anwendungen erstellen und diese anschließend zu einer vorhandenen Verteilerliste hinzufügen. Weitere Informationen finden Sie unter Erstellen von Messagingports.

Sie müssen für jede Verteilerliste wenigstens einen Kanal erstellen, sonst kann die Verteilerliste keine Funktion erfüllen. Weitere Informationen finden Sie unter Erstellen von Kanälen.

Wenn BizTalk Server 2000 einen Kanal aufruft, der einer Verteilerliste zugeordnet ist, wird nur der dieser Verteilerliste zugeordnete Kanal für die Verarbeitung der Daten aufgerufen. Keiner der Kanäle, die den einzelnen Messagingports in der Verteilerliste zugeordnet sind, wird aufgerufen. Der Server verwendet der Reihe nach die Eigenschaften jedes Messagingports, um die Daten an die in den Messagingports angegebenen Ziele zu transportieren.

Eine Verteilerliste unterscheidet sich in den folgenden Punkten von einem offenen Messagingport:

  • Bei einer Verteilerliste kann jedes Dokument von einem Kanal die Übermittlung des Dokuments an mehrere Ziele zur Folge haben. Bei einem offenen Messagingport führt jedes Dokument von einem Kanal zur Übermittlung nur eines Dokuments an nur ein Ziel.

  • Bei einer Verteilerliste müssen Sie einen Messagingport hinzufügen, um Informationen an die Organisation eines anderen Handelspartners zu senden. Bei einem offenen Messagingport müssen die Eigenschaften des Messagingports nicht geändert werden, um Informationen an die Organisation eines anderen Handelspartners zu senden.

Verwandtes Thema

Verwenden von Verteilerlisten


Zugreifen auf das BizTalk-Messaging-Konfigurationsobjektmodell

Dieser Abschnitt stellt Informationen zum programmgesteuerten Zugriff auf das BizTalk-Messaging-Konfigurationsobjektmodell bereit. Erklärt werden die Verwaltung von Handelspartnerbeziehungen und die Einrichtung von Messagingports und Kanälen für den Austausch von Daten mithilfe von Microsoft BizTalk Server 2000. Dieser Abschnitt veranschaulicht auch das Erstellen von Dokumentdefinitionen und Umschlägen sowie das Festlegen von Organisationseigenschaften. Weitere Informationen finden Sie in den folgenden Abschnitten:

  • Allgemeine Hintergrundinformationen finden Sie unter Grundbegriffe.

  • Weitere Informationen zu COM-Schnittstellen, Enumerationen und Fehlermeldungen finden Sie in der Object Model Reference.

  • Codebeispiele finden Sie unter BizTalk Messaging Services Code Samples.

Das BizTalk-Messaging-Konfigurationsobjektmodell kann auch über die grafische Benutzeroberfläche des BizTalk-Messaging-Managers konfiguriert werden. Weitere Informationen finden Sie unter Verwenden des BizTalk-Messaging-Managers.


Grundbegriffe

Dieser Abschnitt stellt detaillierte Informationen zum Konzept bereit, die wichtig für das Verständnis des Zugriffs auf das BizTalk-Messaging-Konfigurations-Objektmodell sind. Die folgenden Themen werden behandelt:

  • BizTalk-Messaging-Konfigurationsobjektmodell

  • Kanäle

  • Messagingports

  • Offenheitsgrad

  • Organisationen

  • Dokumentdefinitionen

  • Umschläge

Weitere Informationen zu Codebeispielen, die das BizTalk-Messaging-Konfigurationsobjektmodell verwenden, finden Sie unter BizTalk Messaging Services Code Samples.


BizTalk-Messaging-Konfigurationsobjektmodell

Das BizTalk-Messaging-Konfigurationsobjektmodell erleichtert Anwendungen das Einrichten, Verwalten und Abrufen von Messagingports und Kanälen für Handelspartnerbeziehungen und die Integration zwischen Anwendungen. Mithilfe des BizTalk-Messaging-Konfigurationsobjektmodells können ferner Umschläge und Dokumentdefinitionen erstellt sowie Organisationseigenschaften eingerichtet werden.

Das BizTalk-Messaging-Konfigurationsobjektmodell nutzt eine SQL-Datenbank (Structured Query Language), um Portkonfigurationen und andere relationale Daten zu speichern. Bei der Suche nach Listen mit Objektinstanzen (z. B. Messagingports, Organisationen usw.) werden ADO-Datensätze (ActiveX Data Object) zurückgegeben.

Das BizTalk-Messaging-Konfigurationsobjektmodell umfasst COM-Objekte (Component Object Model), welche die von Microsoft BizTalk Server 2000 benötigten Konfigurationsdaten offen legen, mit deren Hilfe der Austausch strukturierter Dokumente zwischen Anwendungen und Handelspartnern konfiguriert wird. Die COM-Objekte stellen Instanzen von Daten im Arbeitsspeicher dar, die in der Datenbank gespeichert werden können.

Für alle Objekteigenschaften ist, falls nicht anders angegeben, der Lese- und Schreibzugriff aktiviert.

Verwandte Themen

BizTalk-Messaging-Konfigurationsobjekte

Referenzielle Integrität

Sicherheit


BizTalk-Messaging-Konfigurationsobjekte

Die folgende Tabelle enthält die Objekte des BizTalk-Messaging-Konfigurationsobjektmodells.

Objekt | Beschreibung
 | Enthält die Konfiguration der entsprechenden Quellentität und deren Bindung mit einem BizTalkPort-Objekt.
BizTalkConfig | Dient dem Erstellen und Abrufen anderer BizTalk-Objekte, wie z. B. Kanälen, Dokumentspezifikationen und Messagingports.
BizTalkDocument | Bestimmt und beschreibt die Spezifikation eines Dokuments.
BizTalkEnvelope | Bestimmt das Umschlagsformat und/oder Umschlagsschema, das für Dokumente verwendet wird. Umschläge sind für Dokumente mit dem Format X12 oder EDIFACT erforderlich.
BizTalkOrganization | Bestimmt den Ausgangs- oder Zielpunkt für den Austausch elektronischer Daten. Eine Organisation kann einen externen Handelspartner, das eigene Unternehmen oder einen Geschäftsbereich eines Handelspartners oder des eigenen Unternehmens darstellen. Eine Organisation kann eine Quellanwendung in einem Kanal oder eine Zielanwendung in einem Port bestimmen.
BizTalkPort | Definiert die zielbezogenen Attribute einer Dokumentversendung.
BizTalkPortGroup | Konfiguriert eine Portgruppe. Es handelt sich um eine Gruppe vollständiger BizTalkPort-Objekte für das Versenden desselben Dokuments, wie z. B. Katalog, Preisliste oder Newsletter, an eine Gruppe von Handelspartnern.

Vorsicht

  • Greifen Sie nicht direkt auf die Datenbank zu. Rufen Sie die gespeicherten Prozeduren nicht direkt auf. Ändern Sie die Datenbank nur mithilfe der Methoden und Eigenschaften des BizTalk-Messaging-Konfigurationsobjektmodells. Bei direkten Änderungen an der Datenbank werden die zahlreichen Einschränkungen umgangen, die vom BizTalk-Messaging-Konfigurationsobjektmodell erzwungen werden. Dies kann zu Fehlfunktionen des Servers oder zur Beschädigung der Datenbank führen.

  • Der Zugriff auf das BizTalk-Messaging-Konfigurationsobjektmodell darf nur zur Entwurfszeit erfolgen. Der Zugriff auf Objekte, die verwendet werden, während BizTalk Server Dokumente verarbeitet, kann zu unerwarteten Ergebnissen führen.

  • BizTalk Server 2000 behandelt alle Variablen mit dem BSTR-Datentyp als mit NULL beendete Zeichenfolgen. Alle Daten in einem BSTR-Datentyp hinter dem NULL-Zeichen werden ignoriert. Dokumente mit eingebetteten NULL-Zeichen müssen mithilfe des Pass-Through-Modus an BizTalk Server gesendet werden.

Verwandte Themen

Kanäle

Dokumentdefinitionen

Umschläge

Messagingports

Organisationen


Referenzielle Integrität

Bei der Instanziierung von Objekten in BizTalk Server 2000 muss die referenzielle Abhängigkeit beachtet werden. Referenzielle Abhängigkeit bedeutet, dass ein Objekt auf ein anderes Objekt verweist und von diesem abhängig ist. Ein BizTalkChannel-Objekt verweist z. B. auf ein BizTalkPort-Objekt.

Um die referenzielle Integrität zu erhalten, kann eine Objektinstanz nicht gelöscht werden, wenn eine andere Objektinstanz auf diese verweist. Die referenzielle Integrität bleibt erhalten, wenn das Objekt, auf das verwiesen wird, in der Datenbank vorhanden ist.

Entfernen Sie Objekte in der umgekehrten Reihenfolge ihrer Erstellung. Wenn eine Instanz eines Objekts entfernt wird, auf die eine andere Instanz eines Objekts verweist, wird ein Einschränkungsfehler zurückgegeben. Im obigen Beispiel wird ein Einschränkungsfehler zurückgegeben, wenn ein BizTalkPort-Objekt entfernt wird, das von einem BizTalkChannel-Objekt verwendet wird.

Die folgende Auflistung zeigt die bevorzugte Reihenfolge für das Erstellen von Objekten, um die referenzielle Integrität der Objekte zu erhalten:

  1. BizTalkOrganization

  2. BizTalkDocument

  3. BizTalkEnvelope (falls erforderlich)

  4. BizTalkPort
    • Das BizTalkPort-Objekt benötigt das BizTalkOrganization-Objekt.

    • Das BizTalkPort-Objekt verwendet bedingungsabhängig das BizTalkEnvelope-Objekt.
  5. BizTalkChannel
    • Das BizTalkChannel-Objekt benötigt das BizTalkPort-Objekt.

    • Das BizTalkChannel-Objekt benötigt das BizTalkDocument-Objekt.

    • Das BizTalkChannel-Objekt benötigt das BizTalkOrganization-Objekt.

    • Das BizTalkChannel-Objekt verwendet bedingungsabhängig das BizTalkPortGroup-Objekt, wenn der Kanal für Portgruppen erstellt wurde.
  6. BizTalkPortGroup (falls verwendet)
    • Das BizTalkPortGroup-Objekt benötigt das BizTalkPort-Objekt.


Sicherheit

Beim Zugriff auf oder Erstellen von Objekten im BizTalk-Messaging-Konfigurationsobjektmodell muss das Skript oder die Anwendung im Kontext eines Benutzerkontos in der Gruppe BizTalk Server-Administratoren ausgeführt werden. Die Gruppe BizTalk Server-Administratoren wird bei der Installation von BizTalk Server 2000 erstellt. Bei Bedarf können dieser Gruppe weitere Benutzer hinzugefügt werden. Weitere Informationen finden Sie unter Hinzufügen von Benutzern zur Gruppe "BizTalk Server-Administratoren".


Kanäle

Das BizTalkChannel-Objekt enthält die Konfiguration der entsprechenden Quellentität und deren Bindung mit einem BizTalkPort-Objekt. Wenn BizTalk Server 2000 ein Dokument empfängt, führen ein bestimmtes BizTalkChannel-Objekt samt der Eigenschaften, die im zugeordneten BizTalkPort-Objekt konfiguriert sind, oder ein zugeordnetes BizTalkPort-Objekt in einem BizTalkPortGroup-Objekt den Server durch die Schritte, die zum Verarbeiten dieses Dokuments erforderlich sind. Dabei können mehrere Kanäle an dasselbe BizTalkPort-Objekt gebunden sein. So werden mehrere Quellentitäten abgebildet, die Dokumente mit demselben Ziel austauschen.

Das BizTalkChannel-Objekt bestimmt die Zuordnung für die Dokumenttransformation, wenn der Typ des BizTalkDocument-Eingabeobjekts sich vom Typ des BizTalkDocument-Ausgabeobjekts unterscheidet. Es weist ferner auf die Spezifikation, die Felder für die Dokumentüberwachung enthält, und wählt den gewünschten Protokollierungstyp aus.

Verwandte Themen

Kanalfilter

Konfiguration

Dokumentverarbeitung

Dokumentspeicherung

Dokumentüberwachung

Identifikation


Identifikation

BizTalk Server 2000 bestimmt das für die Verarbeitung des Eingabedokuments benötigte BizTalkChannel-Objekt mithilfe einer der folgenden Methoden:

  • Das Kennzeichen, der Qualifizierer und der Wert der Quellorganisation und der Zielorganisation sowie der Name des BizTalkDocument-Objekts sind Parameter der Methoden Submit oder SubmitSync des Interchange-Objekts.

  • Die Kennzeichen, Qualifizierer und Werte der Quell- und Zielorganisation und der Name des BizTalkDocument-Objekts werden in den Kopfzeilenfeldern der Dokumentinstanz angegeben.

  • Der Name des BizTalkChannel-Objekts ist ein Parameter der Methodenaufrufe Submit oder SubmitSync.

Wenn BizTalk Server 2000 ein Dokument empfängt, wird zuerst das BizTalkChannel-Objekt identifiziert, welches das angegebene BizTalkDocument-Objekt unterstützt. Der Server gleicht dann alle BizTalkPort-Objekte ab und bestimmt, ob die Eigenschaften SourceOrganization und DestinationOrganization die BizTalkOrganization Quell- und -Zielobjekte identifizieren, die von den Organisationskennzeichen in dem Dokument oder in den Parametern der Submit-Methode angegeben wurden, als das Dokument gesendet wurde. Dabei werden alle geöffneten Messagingports einbezogen, die entweder der angegebenen Quellorganisation oder der Zielorganisation entsprechen.

Dieser Identifizierungsprozess kann umgangen werden, indem der Name eines BizTalkChannel-Objekts als Parameter der Methoden Submit oder SubmitSync angegeben wird.

Verwandtes Thema

Submitting


Dokumentverarbeitung

Wenn BizTalk Server 2000 ein BizTalkChannel-Objekt identifiziert, verarbeitet der Server das Objekt, das den Server durch die Schritte zum Verarbeiten des Dokuments führt. Bei diesem Vorgang befolgt das BizTalkChannel-Objekt eigene Regeln und die Regeln des zugeordneten BizTalkPort-Objekts.

Ein BizTalkDocument-Eingabeobjekt wird einem BizTalkDocument-Ausgabeobjekt mithilfe eines BizTalkChannel-Objekts zugeordnet. Das BizTalkPort-Objekt muss erstellt sein, ehe ein zugeordnetes BizTalkChannel-Objekt erstellt werden kann.

Wenn BizTalk Server 2000 ein BizTalkChannel-Objekt verarbeitet, fordert der Server alle zugeordneten BizTalkPort-Objekte auf, die vom Server benötigten Dokumentverarbeitungsregeln bereitzustellen. Die von den Eigenschaften des BizTalkChannel-Objekts festgelegten Regeln führen den Server in die ersten Schritte der Dokumentverarbeitung, wie z. B. Bestimmen der zu verwendenden BizTalkDocument-Ein- und -Ausgabeobjekte, der zu verwendenden Zuordnungsdatei und der zu überwachenden Felder. Sobald ein Dokument das endgültige Ausgabeformat erhalten hat, führen die Eigenschaften des BizTalkPort-Objekts den Server in die Schritte zum Vorbereiten und Transportieren des Dokuments gemäß den Regeln, auf die sich die Quell- und die Zielorganisation geeinigt haben.

Wenn ein Dokument gesendet wird, kann der Server mehrere BizTalkPort- und BizTalkChannel-Objekte identifizieren, die mit der Quellorganisation, der Zielorganisation und dem angegebenen BizTalkDocument-Objekt übereinstimmen. Deshalb kann ein Eingabedokument mehrere Ausgabedokumente erzeugen. Jedes Ausgabedokument kann auch an einen anderen Speicherort übertragen werden, indem verschiedene Transporteigenschaften in den übereinstimmenden BizTalkPort-Objekten verwendet werden. Ferner kann jede Ausgabedokumentinstanz eine andere Untermenge von Daten des ursprünglichen Eingabedokuments enthalten, indem unterschiedliche Zuordnungsdateien verwendet werden.


Konfiguration

Ein BizTalkChannel-Objekt besteht aus den internen Dokumentverarbeitungsdaten für die angegebenen BizTalkDocument-Ein- und -Ausgabeobjekte. Für eine vollständige Konfiguration muss ein BizTalkChannel-Objekt über ein vollständiges BizTalkPort-Objekt verfügen, das von dessen Port-Eigenschaft identifiziert wird. BizTalkDocument-Ein- und -Ausgabeobjekte müssen angegeben werden. Nachdem die Eigenschaften InputDocument und OutputDocument ausgewählt wurden, die in diesem BizTalkChannel-Objekt verwendet werden sollen, muss ein BizTalkPort-Objekt oder ein BizTalkPortGroup-Objekt ausgewählt werden.

Der Name eines BizTalkChannel-Objekts muss in der gesamten Datenbank für alle Objekte dieses Typs eindeutig sein.

Die folgenden Eigenschaften sind erforderlich, ehe ein BizTalkChannel-Objekt gespeichert werden kann:

  • InputDocument

  • Port (oder PortGroup)

  • OutputDocument

  • Name

Nachdem ein BizTalkChannel-Objekt erstellt oder gespeichert wurde, können nur die folgenden Eigenschaften geändert werden:

  • Comments

  • ControlNumberValue

  • MapReference

  • Name

  • TrackFields


Kanalfilter

Mithilfe von Kanalfiltern kann ein Filterausdruck erstellt werden, um ein BizTalkChannel-Objekt für die Verarbeitung einer Dokumentinstanz auszuwählen. Der Server verwendet diese Ausdrücke, um das korrekte BizTalkChannel-Objekt auszuwählen. Die Expression-Eigenschaft enthält einen XPath-Ausdruck, der in einen booleschen Wert ausgewertet wird. Wird der Ausdruck mit TRUE ausgewertet, wird der Kanal zum Verarbeiten des Dokuments verwendet. Andernfalls wird der Kanal nicht zum Verarbeiten des Dokuments aufgerufen.

XPath-Ausdrücke dienen dem Abruf des Werts eines bestimmten Elements, Attributs oder einer Zusammenstellung dieser Objekte in einem XML-Dokument. Betrachten Sie das folgende XML-Dokument:

<INVOICE>
    <DATE>12/31/2000</DATE>
    <BILLTO>Vigor Airlines</BILLTO>
    <SUMMARY>
        <ITEM PARTNUMBER="10001" QUANTITY="10"/>
        <ITEM PARTNUMBER="20002" QUANTITY="20"/>
        <TOTAL VALUE="550"/>
    </SUMMARY>
</INVOICE>

Basierend auf diesem Dokument kann der folgende XPath-Ausdruck erstellt werden, um sicherzustellen, dass dieser Kanal nur Rechnungen über $500 verarbeitet:

myChannel.Expression = "/INVOICE/SUMMARY/TOTAL[@VALUE>""500""]"

In diesem Beispiel verarbeitet der Kanal die XML-Dokumentinstanz, da die Summe höher als $500 ist. Weitere Informationen zu XPath-Ausdrücken finden Sie in der Microsoft-Website (msdn.microsoft.com/library/default.asp). Suchen Sie in der Website nach "XPath".

Anmerkung

  • Mit dem BizTalk-Messaging-Manager können Sie XPath-Kanalfilterausdrücke erstellen. Weitere Informationen finden Sie unter Add a channel filtering expression.


Dokumentspeicherung

Mithilfe des BizTalkLoggingInfo-Objekts können Sie bestimmen, wie die Aktivität einer Dokumentinstanz protokolliert werden soll. Standard ist die Protokollierung des Dokuments im systemeigenen Format.

Zur Speicherung von Dokumenten stehen die Optionen in der folgenden Tabelle zur Verfügung:

Eigenschaft | Beschreibung
Alle Eigenschaften leer | Keine Kopie des Dokuments wird gespeichert.
LogNativeInputDocument | Speicherung im systemeigenen Eingabeformat (Standardeinstellung)
LogNativeOutputDocument | Speicherung im systemeigenen Ausgabeformat.
LogXMLInputDocument | Speicherung im XML-Eingabeformat.
LogXMLOutputDocument | Speicherung im XML-Ausgabezwischenformat.
Beliebige Kombinationen dieser Optionen | Speicherung der Optionen wie zuvor beschrieben.

Anmerkung

  • Für Austauschvorgänge und Dokumente, welche die Protokollierung verwenden, existiert eine Größenbeschränkung, die sich bei Überschreiten drastisch auf die Systemleistung von BizTalk Server auswirkt. Weitere Informationen zur Größenbeschränkung finden Sie unter Interchange and document size limit.


Dokumentüberwachung

Ein BizTalkChannel-Objekt zeigt auf die Spezifikation, die Felder für die Überwachung der Instanz des Dokuments enthält. Die vorgesehenen Felder werden für jede Instanz eines Dokuments, das verarbeitet wird, in der Überwachungsdatenbank protokolliert. Wenn Sie einem BizTalkChannel-Objekt ein BizTalkDocument-Eingabeobjekt zuweisen, können Sie Felder bestimmen, die in dem Dokument auf diesem Kanal überwacht werden sollen.

Wenn BizTalk Server 2000 ein BizTalkChannel-Objekt ausführt, wird das BizTalkDocument-Eingabeobjekt zum Verarbeiten eines Eingabedokuments verwendet. Die für die Überwachung vorgesehenen Felder werden erfasst und für jede Instanz dieses Dokuments protokolliert. Alle Felder, die für die Überwachung im BizTalkDocument-Ausgabeobjekt des zugeordneten BizTalkChannel-Objekts vorgesehen sind, werden ignoriert. Verwenden Sie die Methoden des BTSDocTracking-Objekts, um die Informationen abzurufen, die während der Dokumentverarbeitung überwacht werden.

Durch die Protokollierung wichtiger Daten in den verarbeiteten Eingabedokumenten können Sie detaillierte Informationen zu dem Vorgang überwachen und untersuchen. Ein Rechnungssummenfeld kann z. B. für jede Rechnung protokolliert werden, die an Handelspartner gesendet wird. Sie können anschließend den Euro-Gesamtbetrag der Rechnungen bestimmen, die mit der Zeit an alle Handelspartner gesendet werden. Sie können auch den Euro-Gesamtbetrag der Rechnungen ermitteln, die an die einzelnen Handelspartner gesendet werden.

Weitere Informationen finden zur Dokumentüberwachung Sie unter Grundlegendes zum Schema der Überwachungsdatenbank.


Messagingports

Grundsätzlich ist ein Messagingport eine Sammlung von Regeln, die Handelspartnerorganisationen für das gegenseitige Senden von Dokumenten befolgen. Es sind Informationen zum Ziel, zum Transporttyp, zur Sicherheit und zum Umschlag enthalten. Ein Messagingport identifiziert die BizTalkOrganization-Quell- und -Zielobjekte sowie die Quell- und Zielaliasnamen. Ferner identifiziert ein Messagingport Anwendungen, falls vorhanden, die der Organisation zugeordnet sind.

Ein BizTalkPort-Objekt identifiziert eine bestimmte Zielorganisation, es sei denn, es ist als offener Messagingport festgelegt. In diesem Fall wird die Zielorganisation nicht angegeben. Bei offenen Messagingports ist das BizTalkPort-Objekt nur dann gültig, wenn das zugeordnete Dokument oder die Parameter der Methoden Submit oder SubmitSync des Interchange-Objekts die Zieltransport- und Adressinformationen enthalten.

Das BizTalkPort-Objekt gibt ferner die Trennzeicheninformationen und die EDI-Austauschkontrollnummer an. Mithilfe von Trennzeichen werden die Datensätze und Felder des Umschlags und die Dokumente innerhalb des Umschlags getrennt. Mit einer Austauschkontrollnummer werden Dokumente identifiziert und überwacht, die mithilfe des Umschlags gesendet werden. Die Austauschkontrollnummer wird mit jeder Verwendung des Umschlags zur Laufzeit erhöht.

Ein BizTalkPort-Objekt identifiziert auch, falls erforderlich, den Codierungs-, Verschlüsselungs- und Signaturtyp.

Anmerkung

  • Nachdem ein BizTalkPort-Objekt erstellt und gespeichert wurde, können die Zielorganisation und der Offenheitsgrad, die dem Endpunkt zugeordnet wurden, nicht geändert werden.

Verwandte Themen

Offenheitsgrad

Portgruppen


Portgruppen

Das BizTalkPortGroup-Objekt konfiguriert eine Gruppe vollständiger BizTalkPort-Objekte zum Senden desselben Dokuments an eine Gruppe von Handelspartnern. Sie können dieses Objekt beispielsweise verwenden, um ein Dokument mit identischen Daten, wie z. B. Katalog, Preisliste oder Newsletter, an eine Gruppe von Handelspartnern zu senden. Ein Dokument wird an eine Liste mit Partnern gesendet, indem eine Submit-Methode für das Interchange-Objekt aufgerufen wird.

Das BizTalkPortGroup-Objekt muss mindestens ein BizTalkPort-Objekt enthalten. Durch Aufrufen der Methoden AddPort und RemovePort können Sie einem BizTalkPortGroup-Objekt BizTalkPort-Objekte hinzufügen oder aus diesem entfernen.

Ein BizTalkPortGroup-Objekt muss mindestens einem BizTalkChannel-Objekt zugeordnet sein. Ordnen Sie der Portgruppe nach dem Erstellen einen Kanal zu, indem Sie die für das BizTalkChannel-Objekt verfügbare PortGroup-Eigenschaft verwenden. Wenn BizTalk Server 2000 einen zu einer Portgruppe gehörenden Kanal aufruft, wird nur der Kanal aufgerufen, welcher der Portgruppe zum Verarbeiten der Daten zugeordnet ist. Von den Kanälen, die den einzelnen Ports in der Portgruppe zugeordnet sind, wird keiner aufgerufen. Der Server verwendet nacheinander die Eigenschaften jedes Ports, um die Daten zu den in den Ports angegebenen Zielen zu transportieren.

Anmerkungen

  • Einer Portgruppe können keine offenen Messagingports hinzugefügt werden.

  • Der BizTalk-Messaging-Manager behandelt Portgruppen wie Verteilerlisten.

Verwandtes Thema

Submitting


Offenheitsgrad

Die Openness-Eigenschaft des BizTalkEndPoint-Objekts bestimmt, ob der Messagingport oder Kanal offen ist. Ein offenes BizTalkPort-Objekt ist ein Messagingport ohne angegebenes Ziel. Ein offenes BizTalkChannel-Objekt ist ein Kanal ohne angegebene Quelle. Die fehlenden Informationen eines offenen Messagingports oder Kanals müssen vom zugeordneten Dokument oder den Parametern der Methoden Submit oder SubmitSync des Interchange-Objekts bereitgestellt werden.

Wenn ein offener Kanal mithilfe von BIZTALK_OPENNESS_TYPE_EX_SOURCE oder ein offener Messagingport mithilfe von BIZTALK_OPENNESS_TYPE_EX_DESTINATION angegeben wird, können die Eigenschaften Type, Reference und Store nicht für das BizTalkEndPoint-Objekt angegeben werden.

Anmerkung

  • Wird ein offener Messagingport mit dem Transporttyp SMTP verwendet, wird der für das BizTalkOrganization-Kennzeichen SMTP-"Von"-Adresse der Reliable Messaging-Bestätigung angegebene Wert als Absenderadresse verwendet.

Verwandtes Thema

Submitting


Organisationen

BizTalkOrganization-Objekte dienen als Quelle und Ziel für den Austausch elektronischer Daten. Eine Organisation kann einen externen Handelspartner, das eigene Unternehmen oder einen Geschäftsbereich eines Handelspartners oder des eigenen Unternehmens darstellen. Die eigene Organisation kann eine Quellanwendung in einem Kanal oder eine Zielanwendung in einem Messagingport bestimmen.

Anwendungen sind Eigenschaften der eigenen Organisation. Anwendungen können als Quellanwendungen in einem BizTalkChannel-Objekt oder als Zielanwendungen in einem BizTalkPort-Objekt angegeben werden.

Aliasnamen

Ein Alias ist ein Organisationskennzeichen für das BizTalkOrganization-Objekt. Ein BizTalkOrganization-Objekt darf nur einen Standardalias aufweisen, kann jedoch über mehrere Aliasnamen verfügen. Für jedes BizTalkOrganization-Objekt wird automatisch ein Alias generiert. Der Standard- und der automatisch generierte Alias können nicht entfernt werden.

Weitere Informationen finden Sie unter Erstellen und Verwalten von Organisationen.


Dokumentdefinitionen

Das BizTalkDocument-Objekt beschreibt und identifiziert die Dokumentspezifikation, die zum Beschreiben des gesendeten oder empfangenen Dokuments verwendet wird. Die Dokumentspezifikation definiert die Struktur eines Dokuments sowie alle Überprüfungsregeln und Beschreibungen der einzelnen Elemente der Dokumentspezifikation. Das BizTalkDocument-Objekt enthält die Version und den Typ der Spezifikation und optional einen Verweis auf den WebDAV-Speicherort (Web Distributed Authoring and Versioning) der Spezifikation. Weitere Informationen zu Dokumentspezifikationen finden Sie unter Erstellen und Überprüfen von Spezifikationen.

Anmerkungen

  • Die Dokumenteigenschaften Content und Namespace sind erst nach dem Festlegen der Reference-Eigenschaft gültig.

  • Wenn ein neues BizTalkDocument-Objekt erstellt wird, das einen bereits in BizTalk Server registrierten Namespace verwendet, erbt das neue Dokument die Reference-Eigenschaft dieses Namespace. Der Namespace einer neuen zu erstellenden Reference-Eigenschaft muss (bei Unterscheidung von Groß-/Kleinschreibung) eindeutig sein.

Das BizTalkDocument-Objekt enthält auch EDI-Auswahlkriterien (Electronic Data Interchange), gemäß denen BizTalk Server 2000 Informationen aus der funktionalen Gruppenkopfzeile des Dokuments extrahiert, um dieses Objekt zu identifizieren, wenn der Name des BizTalkDocument-Objekts nicht verfügbar ist.

Ein BizTalkDocument-Objekt zeigt auf die Spezifikation, die Felder für die Überwachung der Instanz des Dokuments enthält. Die vorgesehenen Felder werden für jedes verarbeitete Dokument in der Überwachungsdatenbank protokolliert.

Auswahlkriterien

Bei manchen EDI-Eingabeaustauschvorgängen sind Dokumente in funktionalen Gruppenumschlägen enthalten. Wenn BizTalk Server 2000 solche Dokumente verarbeitet, kann der Name des BizTalkDocument-Objekts nicht aus einem Feld in jedem der Dokumente abgerufen werden. Da ferner mehrere Dokumenttypen beteiligt sind, kann ein einzelner Name nicht als Parameter der Submit-Methode des Interchange-Objekts angegeben werden. In diesen Fällen kann der Server dokumentbezogene Daten in der funktionalen Gruppenkopfzeile finden (z. B. in der GS-Kopfzeile eines X12-Austauschs). Durch Vergleichen dieser Daten mit übereinstimmenden Auswahlkriterien, die in der PropertySet-Eigenschaft des BizTalkDocument-Objekts angegeben werden, kann der Server ein BizTalkDocument-Objekt eindeutig identifizieren. Nach der Identifizierung des BizTalkDocument-Objekts kann der Server den Namen abrufen und das entsprechende BizTalkChannel-Objekt anschließend identifizieren und instanziieren.

Mithilfe von Auswahlkriterien kann BizTalk Server 2000 auch die Kopfzeile des auszugebenden EDI-Dokuments erstellen.

Globale Überwachung

Ein BizTalkDocument-Objekt zeigt auf die Spezifikation, in der Felder für die Überwachung ausgewählt werden können. Die vorgesehenen Felder in der Eingabedokumentspezifikation werden für jedes Dokument überwacht, das unter Verwendung dieser Spezifikation verarbeitet wird. Alle Felder, die für die Überwachung in der Ausgabedokumentspezifikation angegeben sind, werden ignoriert. Wenn ein BizTalkChannel-Objekt, das Überwachungsfelder angibt, mit einer Eingabedokumentspezifikation verwendet wird, die für die Überwachung vorgesehene Felder enthält, werden nur die Felder in die Überwachung einbezogen, die vom Kanal angegeben werden.

Durch die Protokollierung wichtiger Daten in den verarbeiteten Eingabedokumenten können Sie detaillierte Informationen zu dem Vorgang überwachen und untersuchen. Ein Rechnungssummenfeld kann z. B. für jede Rechnung protokolliert werden, die an Handelspartner gesendet wird. Sie können anschließend den Euro-Gesamtbetrag der Rechnungen bestimmen, die mit der Zeit an alle Handelspartner gesendet werden. Sie können auch den Euro-Gesamtbetrag der Rechnungen ermitteln, die an die einzelnen Handelspartner gesendet werden.

Verwandte Themen

Dokumentspeicherung

Dokumentüberwachung


Umschläge

Das BizTalkEnvelope-Objekt enthält zwei Informationen:

  • Der Umschlagtyp wird in der Format-Eigenschaft angegeben. Die Dokumenteigenschaft Type muss für die Dokumenttypen Flatfile, Benutzerdefinierte XML, X12, EDIFACT und Zuverlässig der Dokumenteigenschaft Format des Umschlags entsprechen.

  • Die eigentliche Umschlagdatei wird mit der Reference-Eigenschaft angegeben.

Eingabedokumentumschläge

Ein Umschlag ist erforderlich, wenn die Eigenschaft Type des Eingabedokuments Flatfile ist, da der Umschlag Informationen darüber enthält, wie das Dokument in XML analysiert werden kann und welcher Parser zum Verarbeiten des Dokuments verwendet werden soll. Eingabedokumente vom Typ Flatfile ohne Umschlag können nicht verarbeitet werden. Bei allen anderen Eingabedokumenttypen ist ein Umschlag optional.

Ausgabedokumentumschläge

Mithilfe eines Umschlags wird eine Ausgabedokumentinstanz in das systemeigene Format überführt. Der mit einem Ausgabedokument verwendete Umschlag wird im BizTalkPort-Objekt angegeben. Ein Umschlag ist erforderlich, wenn die Type-Eigenschaft des Ausgabedokuments X12 oder EDIFACT ist. Die Reference-Eigenschaft für diese Formattypen wird dagegen ignoriert, da die Angabe, dass die Dokumente das Format X12 oder EDIFACT haben, für die Serialisierung des Dokuments ausreichend sind. Für Ausgabedokumente mit der Type-Eigenschaft Benutzerdefinierte XML wird, falls angegeben, die Reference-Eigenschaft verwendet. Ist die Reference-Eigenschaft nicht angegeben, werden Dokumente vom Typ Benutzerdefinierte XML im transformierten XML-Format an die Verarbeitung übergeben.

Anmerkungen

  • Mehrere BizTalkPort-Objekte können auf einen Umschlag verweisen.

  • Die Umschlageigenschaften Content und Namespace sind erst nach dem Festlegen der Reference-Eigenschaft gültig.

  • Wenn ein neues BizTalkEnvelope-Objekt erstellt wird, das einen bereits in BizTalk Server registrierten Namespace verwendet, erbt das neue Dokument die Reference-Eigenschaft dieses Namespace. Der Namespace einer neuen zu erstellenden Reference-Eigenschaft muss (bei Unterscheidung von Groß-/Kleinschreibung) eindeutig sein.


Erstellen von Spezifikationen und Zuordnen von Daten

Microsoft BizTalk Server 2000 stellt Tools bereit, mit denen Sie die Struktur eines Dokuments definieren und Daten eines Formats einem anderen zuordnen können. Diese Tools basieren auf der Extensible Markup Language (XML) und XML-Standards und stellen die für einen Anwendungsintegrationsserver notwendige Datenkonvertierung bereit.

Mit dem BizTalk-Editor können Sie Spezifikationen erstellen, die auf Industriestandards und allgemeinen Schemas basieren; Sie können aber auch Spezifikationen erstellen, die nur für Ihre Organisation zutreffen.

Mit dem BizTalk-Mapper können Sie eine Zuordnung zwischen Datensätzen und Feldern von zwei verschiedenen Spezifikationen erstellen. Der Server verwendet die Zuordnung zum Verarbeiten und Konvertieren von Daten in Formate, die innerhalb der Organisation oder der Partnerorganisation gemeinsam verwendet werden können.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Erstellen von Spezifikationen

  • Zuordnen von Daten

  • Problembehandlung - BizTalk-Editor und BizTalk-Mapper


Erstellen von Spezifikationen

Der BizTalk-Editor ist ein Tool, mit dem Sie Spezifikationen erstellen, bearbeiten und verwalten können. Der BizTalk-Editor verwendet XML (Extensible Markup Language). Diese Sprache stellt ein allgemeines Vokabular für die Verarbeitung von Überlappungen zwischen syntaktischen, Datenbank- und konzeptuellen Schemata zur Verfügung.

Der BizTalk-Editor erstellt Spezifikationen durch die Interpretation der Eigenschaften von Datensätzen und Felder, die in einer Datei enthalten sind. Spezifikationen bilden die strukturierten Daten ungeachtet des Ursprungsformats als XML ab. Darüber hinaus stellen im BizTalk-Editor erstellte oder geänderte Spezifikationen als allgemeine Datenbeschreibungen bereit, die der BizTalk-Mapper zum Transformieren von Daten verschiedener Formate verwenden kann. Die Spezifikationen ermöglichen eine geschäftsprozessübergreifende Übertragbarkeit von Daten. Eine mit dem BizTalk-Editor erstellte Spezifikation kann auf Folgendem basieren:

  • Wohlgeformte XML

  • Auf XML basierenden Dokumentvorlagen

  • XDR-Schemata (XML-Data Reduced)

  • Dokumenttypdefinitionen (Document Type Definitions, DTDs)

  • Als XML gespeicherte ADO-Datensätze (ActiveX Data Objects)

  • EDI (Electronic Data Interchange) (X12 und EDIFACT).

  • Flatfiles, einschließlich Dateien mit Trennzeichen und Feldern fester Breite (wie beispielsweise SAP IDOCs). Eine Flatfile kann Trennzeichen als auch Felder fester Breite enthalten.

  • Strukturierte Dokumentformate

Im BizTalk-Editor können Sie eine leere Spezifikation ohne Struktur öffnen oder ein vorhandenes Schema oder eine vorhandene Spezifikation importieren. Sie können z. B. eine Dokumenttypdefinition importieren. Dies ist eine strukturierte Datei, in der Elemente und Attribute sowie Einschränkungen hinsichtlich Reihenfolge, Häufigkeit und Inhalt der Elemente und Attribute angegeben sind. Standardspezifikationen wie XML, X12 und EDIFACT können ebenfalls zum Erstellen neuer Spezifikationen verwendet werden.

Wird eine Instanz eines Dokuments importiert, übersetzt der BizTalk-Editor die Struktur des Dokuments und erstellt eine Spezifikation, bei der es sich um eine XML-Darstellung des Dokuments handelt. Sie können beliebige erforderliche Datensätze und Felder in der Spezifikationsstruktur des BizTalk-Editors bearbeiten und die Struktur dann als Spezifikation speichern. Die folgenden Dateitypen können importiert werden:

  • XDR-Schemata

  • Wohlgeformte XML

  • Dokumenttypdefinitionen (DTDs)

Jede Spezifikation beschreibt die Struktur der Datei, wenn ein bestimmter Satz Tags angegeben ist. Der BizTalk-Editor stellt auch verschiedene Vorlagen bereit, die als Ausgangspunkt für das Erstellen allgemeiner Dokumente wie Aufträge, Rechnungen und Versandsanzeigen verwendet werden können.

Wenn BizTalk Server Dokumente verarbeitet, verwendet der Server eine mithilfe von BizTalk-Mapper erstellte Zuordnung, um ein- und ausgehende Daten von einem Spezifikationsformat in ein anderes zu konvertieren.

  • Hilfe zu bestimmten Aufgaben finden Sie unter Verfahrensweise.

  • Allgemeine Hintergrundinformationen finden Sie unter Grundbegriffe.

  • Weitere Ressourcen finden Sie unter Ressourcen.

  • Anleitungen zum Beheben von Problemen finden Sie unter Problembehandlung - BizTalk-Editor und BizTalk-Mapper.


Verfahrensweise

Dieser Abschnitt stellt aufgabenspezifische Informationen zum Erstellen von Spezifikationen bereit. Es wird dringend empfohlen, dass Sie den Abschnitt Grundbegriffe lesen, um die Beziehung zwischen Datensätzen und Feldern vollständig zu verstehen. Zudem erfahren Sie, wie Sie Eigenschaften für einen bestimmten Spezifikationstyp angeben können, den Sie erstellen möchten.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Ändern von Optionen für den BizTalk-Editor

  • Erstellen und Überprüfen von Spezifikationen

  • Öffnen von Spezifikationen

  • Speichern, Exportieren, Konvertieren und Schließen von Spezifikationen

  • Verwalten von Datensätzen und Feldern

  • Festlegen von Eigenschaften für Datensätze und Felder

  • Bearbeiten von Notizen und Syntaxregeln

  • Verwalten von Dokumentinstanzen

  • Verwalten ungültiger Zeichentabellen

  • Verwalten von Ansichten


Ändern von Optionen für den BizTalk-Editor

  1. Klicken Sie im Menü Extras auf Optionen, um Optionen im Dialogfeld Optionen für den BizTalk-Editor anzuzeigen.

  2. Auf der Registerkarte Allgemein können Sie das Kontrollkästchen Neues Feld als Element erstellen aktivieren. Weitere Informationen zu dieser Option finden Sie unter Erstellen eines neuen Feldes als Element.

Verwandtes Thema

Erstellen eines neuen Feldes als Element


Erstellen und Überprüfen von Spezifikationen

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Erstellen einer Spezifikation auf der Basis eines Standards

  • Erstellen einer Spezifikation auf der Basis einer Flatfile

  • Erstellen einer Spezifikation auf der Basis einer leeren Vorlage

  • Erstellen einer Spezifikation auf der Basis einer vorhandenen Spezifikation

  • Erstellen einer Spezifikation auf der Basis einer importierten Datei

  • Überprüfen einer Spezifikation


Erstellen einer Spezifikation auf der Basis eines Standards

  1. Klicken Sie im Menü Datei auf Neu.

  2. Klicken Sie im Dialogfeld Neue Dokumentspezifikation auf XML, X12 oder EDIFACT, und klicken Sie dann auf OK.

    Falls Sie EDIFACT oder X12 auswählen, müssen Sie eine Version angeben. Klicken Sie auf den Ordner für die gewünschte Version, und klicken Sie auf OK.

  3. Klicken Sie auf den Spezifikationstyp und dann auf OK.

  4. Löschen von Datensätzen (falls erforderlich).

  5. Löschen von Feldern (falls erforderlich).

  6. Codes löschen (falls erforderlich).

  7. Speichern neuer Spezifikationen.

Verwandte Themen

Verwalten von Datensätzen und Feldern

Festlegen von Eigenschaften für Datensätze und Felder

Grundlegendes zu Spezifikationen


Erstellen einer Spezifikation auf der Basis einer Flatfile

  1. Klicken Sie im Menü Datei auf Neu.

  2. Klicken Sie im Dialogfeld Neue Dokumentspezifikation auf Leere Spezifikation und dann auf OK.

  3. Markieren Sie den Stammknoten, und klicken Sie dann auf die Registerkarte Verweis.

  4. Doppelklicken Sie auf das Feld Wert in der Zeile Standard.

  5. Klicken Sie in der Liste Standard auf CUSTOM.

  6. Drücken Sie die EINGABETASTE.

  7. Klicken Sie auf Ja, um die Änderung zu bestätigen.

  8. Hinzufügen neuer Datensätze zu einem Stammknoten

  9. Hinzufügen neuer Datensätze zu vorhandenen Datensätzen

  10. Hinzufügen neuer Felder zu einem Stammknoten

  11. Hinzufügen neuer Felder zu Datensätzen

  12. Festlegen von Eigenschaften für Datensätze und Felder

  13. Speichern neuer Spezifikationen.

Anmerkungen

  • Auf der Registerkarte Analysieren müssen Sie für die Struktur-Eigenschaft des Stammknotens Getrennt festlegen, wenn es sich um eine Flatfile mit Trennzeichen und mit Feldern fester Breite handelt. Für weitere Datensatzeigenschaften kann je nach Bedarf Getrennt oder Feste Breite festgelegt werden.

  • Flatfiles, die auf der UTF-8-Codepage basieren, werden vom BizTalk-Editor nicht unterstützt.

Verwandte Themen

Verwalten von Datensätzen und Feldern

Festlegen von Eigenschaften für Datensätze und Felder

Grundlegendes zu Spezifikationen


Erstellen einer Spezifikation auf der Basis einer leeren Vorlage

  1. Klicken Sie im Menü Datei auf Neu.

  2. Klicken Sie im Dialogfeld Neue Dokumentspezifikation auf Leere Spezifikation und dann auf OK.

  3. Hinzufügen neuer Datensätze zu einem Stammknoten

  4. Hinzufügen neuer Datensätze zu vorhandenen Datensätzen

  5. Hinzufügen neuer Felder zu einem Stammknoten

  6. Hinzufügen neuer Felder zu Datensätzen

  7. Festlegen von Eigenschaften für Datensätze und Felder

  8. Speichern neuer Spezifikationen.

Verwandte Themen

Verwalten von Datensätzen und Feldern

Festlegen von Eigenschaften für Datensätze und Felder

Grundlegendes zu Spezifikationen


Erstellen einer Spezifikation auf der Basis einer vorhandenen Spezifikation

  1. Klicken Sie im Menü Datei auf Öffnen.

  2. Suchen Sie im Dialogfeld Dokumentspezifikation öffnen nach einem Ordner, der eine vorhandene Spezifikation enthält.

  3. Klicken Sie auf eine Datei in der Liste und dann auf Öffnen.

  4. Ändern Sie die Spezifikation entsprechend Ihren Anforderungen.

  5. Klicken Sie im Menü Datei auf Speichern unter.

  6. Geben Sie im Feld Dateiname des Dialogfeldes Dokumentspezifikation speichern unter einen Namen für die Spezifikation ein.

  7. Klicken Sie in der Liste Codierung auf UTF-8 oder Unicode, und klicken Sie auf Speichern.

    Klicken Sie in der Liste Codierung auf UTF-8, wenn Sie eine Spezifikation erstellen möchten, die mit ASCII-Zeichen verbunden ist. Klicken Sie in der Liste Codierung auf UTF-8 oder Unicode für Spezifikationen, die mit Doppelbyte-Zeichen verbunden sind.

  8. Verwalten von Datensätzen und Feldern

  9. Speichern neuer Spezifikationen.

Verwandte Themen

Codelistenwerte und Beschreibungen

Verwalten von Datensätzen und Feldern


Erstellen einer Spezifikation auf der Basis einer importierten Datei

  1. Klicken Sie im Menü Extras auf Importieren.

  2. Klicken Sie im Dialogfeld Importmodul auswählen auf Wohlgeformte XML-Instanz, Dokumenttypdefinition oder XDR-Schema, und klicken Sie dann auf OK.

    Falls Sie eine XDR-Datei (XML-Data Reduced) importieren, klicken Sie auf XDR-Schema.

  3. Suchen Sie im Dialogfeld Importmodul importieren nach dem Ordner, der die zu importierende Datei enthält.

  4. Klicken Sie auf die zu importierende Datei und dann auf Öffnen.

    Der BizTalk-Editor erstellt eine Spezifikation, die auf der Struktur der importierten Datei basiert. Sie müssen die Werte sämtlicher Datensatz- und Feldeigenschaften festlegen.

  5. Hinzufügen neuer Datensätze zu einem Stammknoten

  6. Hinzufügen neuer Datensätze zu vorhandenen Datensätzen

  7. Hinzufügen neuer Felder zu einem Stammknoten

  8. Hinzufügen neuer Felder zu Datensätzen

  9. Festlegen von Eigenschaften für Datensätze und Felder

  10. Speichern neuer Spezifikationen.

Wichtig

  • Der Import von Dokumenttypdefinitionen (DTDs), deren Elemente Kommentare enthalten, wird vom BizTalk-Editor nicht unterstützt. Sie müssen die betreffenden Dateien bearbeiten und sämtliche Kommentare in Elementen entfernen, um diese DTDs erfolgreich importieren zu können.

  • Wenn die zu importierende Datei über ein Element mit Inhalt verfügt, das in den Instanzdaten wiederholt wird und keine untergeordneten Elemente aufweist, erstellt der BizTalk-Editor beim Import der Struktur diese nicht als Datensatz, sondern als Feld.

  • Das Dialogfeld Stammelement auswählen wird angezeigt, wenn der BizTalk-Editor nicht ermitteln kann, welches Element den Stammknoten darstellen soll. Wählen Sie das Element aus, bei dem es sich um den Stammknoten handelt, und klicken Sie auf OK.

  • Der BizTalk-Editor kann ein DTD- und/oder XDR-Schema, das einen zyklischen Verweis auf den Stammknoten enthält, nicht importieren. Ein wohlgeformtes XML-Dokument, das einen zyklischen Verweis auf den Stammknoten enthält, kann vom BizTalk-Editor importiert werden, obwohl eine Warnung angezeigt wird, dass zyklische Verweise nicht den Stammknoten eines Dokuments enthalten können. Weitere Informationen finden Sie unter Zyklische Verweise.

  • Beim Importieren einer wohlgeformten XML-Datei, die einen Namespace des Stammknotens enthält, wird dieser Namespace zum Zielnamespace und in der übrigen Spezifikation nicht berücksichtigt. Weitere Informationen zu Zielnamespaces finden Sie unter Festlegen von Verweiseigenschaften.

  • Wenn Sie eine Datei importieren, die ein Element mit gemischtem Inhalt (Textinformationen und Unterelemente) enthält, werden die Textinformationen beim Import ignoriert.

  • Die folgende Tabelle gibt einen Überblick, was beim Import von XDR-Dateien oder DTDs mit bestimmten Datentypen passiert. Die Spalten stehen für die Datentypen.
    "entity" und "entities" | "nmtoken" und "nmtokens" | "notation"
    XDR | Die Datei kann nicht importiert werden. | Die Datei kann importiert werden. Die Datentypen werden entfernt. | Die Datei kann nicht importiert werden.
    DTD | Die Datei kann importiert werden. Die Datentypen werden entfernt. | Die Datei kann importiert werden. Die Datentypen werden entfernt. | Die Datei kann importiert werden. Der Datentyp wird als Enumerationstyp importiert.

Verwandte Themen

Importieren von Dateien

Verwalten von Datensätzen und Feldern

Festlegen von Eigenschaften für Datensätze und Felder


Überprüfen einer Spezifikation

  1. Öffnen Sie eine Spezifikation, oder importieren Sie ein Schema.

    Weitere Informationen finden Sie unter Öffnen von Spezifikationen oder Erstellen einer Spezifikation auf der Basis einer importierten Datei.

  2. Klicken Sie im Menü Extras auf Spezifikation überprüfen.

Auf der Registerkarte Warnungen werden Warnungen angezeigt, die auf Probleme bezüglich der Struktur der Spezifikation hinweisen. Sie können auf eine Warnung doppelklicken, um den Datensatz oder das Feld sowie die zugehörige Eigenschaft in den Fensterbereichen darüber rot anzuzeigen.

Verwandte Themen

Erstellen einer Spezifikation auf der Basis einer importierten Datei

Öffnen von Spezifikationen


Öffnen von Spezifikationen

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Öffnen von vorhandenen Spezifikationen von einem lokalen Laufwerk

  • Öffnen einer vorhandenen Spezifikation aus WebDAV


Öffnen von vorhandenen Spezifikationen von einem lokalen Laufwerk

  1. Klicken Sie im Menü Datei auf Öffnen.

  2. Suchen Sie im Dialogfeld Dokumentspezifikation öffnen nach einem Ordner, der die zu öffnende Spezifikation enthält.

  3. Klicken Sie auf eine Datei in der Liste und dann auf Öffnen.

Verwandtes Thema

Öffnen einer vorhandenen Spezifikation aus WebDAV


Öffnen einer vorhandenen Spezifikation aus WebDAV

  1. Klicken Sie im Menü Datei auf Aus WebDAV abrufen.

  2. Geben Sie im Dialogfeld Aus WebDAV abrufen in der Liste Server den Servernamen ein, und drücken Sie die EINGABETASTE.

    Sie können auch einen Servernamen aus der Liste auswählen.

  3. Suchen Sie nach dem Ordner, der die zu öffnende Spezifikation enthält, klicken Sie auf die Spezifikation, und klicken Sie dann auf Öffnen.

Anmerkung

  • Beim erstmaligen Herstellen einer Verbindung zu einem Remote-WebDAV-Server während einer Sitzung kann es zu Verzögerungen kommen.

Verwandte Themen

Öffnen von vorhandenen Spezifikationen von einem lokalen Laufwerk

Problembehandlung - BizTalk-Editor und BizTalk-Mapper


Speichern, Exportieren, Konvertieren und Schließen von Spezifikationen

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Speichern neuer Spezifikationen

  • Speichern von vorhandenen Spezifikationen

  • Speichern von Spezifikationen

  • Exportieren von XDR-Schemas

  • Konvertieren eines XDR-Schemas in ein XSD-Schema

  • Schließen von Spezifikationen


Speichern neuer Spezifikationen

  1. Klicken Sie im Menü Datei auf Speichern unter.

  2. Geben Sie im Dialogfeld Dokumentspezifikation speichern unter im Feld Dateiname einen Namen für die Datei ein.

  3. Klicken Sie in der Liste Codierung auf UTF-8 oder Unicode, und klicken Sie auf Speichern.

    Klicken Sie in der Liste Codierung auf UTF-8, wenn Sie eine Spezifikation speichern möchten, die mit ASCII-Zeichen verbunden ist. Klicken Sie in der Liste Codierung auf UTF-8 oder Unicode für Spezifikationen, die mit Doppelbyte-Zeichen verbunden sind.


Speichern von vorhandenen Spezifikationen

  • Klicken Sie im Menü Datei auf Speichern.

Anmerkung

  • Das Speichern einer Datei bewirkt, dass der BizTalk-Editor die Datei auf der Festplatte speichert. Um eine Datei in WebDAV zu speichern, müssen Sie über die Berechtigung verfügen, die Datei auf dem Server zu speichern.

Verwandtes Thema

Speichern von Spezifikationen


Speichern von Spezifikationen

  1. Klicken Sie im Menü Datei auf In WebDAV speichern.

  2. Geben Sie im Dialogfeld In WebDAV speichern in der Liste Server den Servernamen ein, und drücken Sie die EINGABETASTE.

    Sie können auch einen Servernamen aus der Liste auswählen.

  3. Suchen Sie nach dem Ordner, in dem Sie die Spezifikation speichern möchten.

  4. Geben Sie im Feld Dateiname den Namen der Datei ein.

  5. Klicken Sie in der Liste Codierung auf UTF-8 oder Unicode, und klicken Sie auf Speichern.

    Klicken Sie in der Liste Codierung auf UTF-8, wenn Sie eine Spezifikation speichern möchten, die mit ASCII-Zeichen verbunden ist. Klicken Sie in der Liste Codierung auf UTF-8 oder Unicode für Spezifikationen, die mit Doppelbyte-Zeichen verbunden sind.

Wichtig

  • Sie können Dateien, deren Namen aus Doppelbyte-Zeichensätzen gebildet werden, nur speichern, wenn das korrekte Gebietsschema festgelegt wurde. Informationen zur Behebung dieses Problems finden Sie unter Im WebDAV-Dialogfeld wird "???.xml" angezeigt.

Anmerkungen

  • Beim erstmaligen Herstellen einer Verbindung zu einem Remote-WebDAV-Server kann es zu Verzögerungen kommen.

  • Das Speichern einer Datei in WebDAV bewirkt, dass der BizTalk-Editor die Datei auf einem Server speichert. Klicken Sie im Menü Datei auf Speichern unter, um eine Datei auf der Festplatte zu speichern.

Verwandte Themen

Speichern von vorhandenen Spezifikationen

Speichern neuer Spezifikationen

Problembehandlung - BizTalk-Editor und BizTalk-Mapper


Exportieren von XDR-Schemas

  1. Klicken Sie im Menü Extras auf XDR-Schema exportieren.

  2. Suchen Sie im Dialogfeld XDR-Schema exportieren als nach dem Verzeichnis, in das Sie die XDR-Datei (XML-Data Reduced) exportieren möchten.

  3. Geben Sie im Feld Dateiname einen Namen für die Datei ein.

  4. Klicken Sie in der Liste Codierung auf UTF-8 oder Unicode, und klicken Sie auf Speichern.

    Klicken Sie in der Liste Codierung auf UTF-8, wenn Sie eine Spezifikation exportieren möchten, die mit ASCII-Zeichen verbunden ist. Klicken Sie in der Liste Codierung auf UTF-8 oder Unicode für Spezifikationen, die mit Doppelbyte-Zeichen verbunden sind.

Anmerkungen

  • Sie können neue und vorhandene Spezifikationen nur exportieren, wenn sie im BizTalk-Editor geöffnet sind.

  • Beim Exportieren einer Spezifikation werden die eindeutigen Spezifikationsinformationen aus der Struktur entfernt, und die übrige Struktur wird als allgemeines Schema gespeichert, das von anderen Anwendungen verwendet werden kann.

Verwandte Themen

Öffnen von Spezifikationen

Konvertieren eines XDR-Schemas in ein XSD-Schema


Konvertieren eines XDR-Schemas in ein XSD-Schema

  1. Erstellen Sie auf dem lokalen Laufwerk einen Ordner namens Convert.

  2. Kopieren Sie den Inhalt von \Programme\Microsoft BizTalk Server\SDK\Messaging Samples\XSDConverter in den Ordner Convert.

  3. Kopieren Sie das zu konvertierende XDR-Schema in den Ordner Convert.

  4. Öffnen Sie eine Eingabeaufforderung.

  5. Wechseln Sie zum Verzeichnis Convert.

  6. Nehmen Sie an der Eingabeaufforderung folgende Eingabe vor:
    wscript convert.js xdrfilename.xml xsdfilename.xsd

Das konvertierte XSD-Schema mit dem Namen xsdfilename.xsd wird im Ordner Convert angezeigt.

Anmerkung

  • Wird kein Dateiname für das XSD-Schema eingegeben, gibt das Skript dem XSD-Schema den Namen des ursprünglichen XDR-Schemas und fügt die Dateierweiterung XSD an. Bei einem XDR-Schema namens xdrfilename.xml würde das konvertierte XSD-Schema beispielsweise xdrfilename.xml.xsd heißen.

Verwandtes Thema

Exportieren von XDR-Schemas


Schließen von Spezifikationen

  • Klicken Sie im Menü Datei auf Schließen.


Verwalten von Datensätzen und Feldern

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Hinzufügen neuer Datensätze zu einem Stammknoten

  • Hinzufügen neuer Felder zu einem Stammknoten

  • Hinzufügen neuer Datensätze zu vorhandenen Datensätzen

  • Hinzufügen neuer Felder zu Datensätzen

  • Einfügen von Datensätzen

  • Einfügen von Feldern

  • Erstellen eines neuen Feldes als Element

  • Ändern von Feldern von Attributen in Elemente

  • Ändern von Feldern von Elementen in Attribute

  • Verschieben von Datensätzen innerhalb einer Spezifikation

  • Verschieben von Feldern innerhalb einer Spezifikation

  • Verschieben von Datensätzen von einer Spezifikation in eine andere

  • Verschieben von Feldern von einer Spezifikation in eine andere

  • Kopieren von Datensätzen innerhalb einer Spezifikation

  • Kopieren von Feldern innerhalb einer Spezifikation

  • Kopieren von Datensätzen von einer Spezifikation in eine andere

  • Kopieren von Feldern von einer Spezifikation in eine andere

  • Umbenennen eines einzelnen Datensatzes

  • Umbenennen eines einzelnen Feldes

  • Umbenennen aller Datensätze mit dem gleichen Namen

  • Löschen von Datensätzen

  • Löschen von Feldern

  • Erstellen von zyklischen Verweisen

  • Erstellen einer neuen Instanz eines vorhandenen Datensatzes

  • Erstellen einer neuen Instanz eines vorhandenen Elementfeldes


Hinzufügen neuer Datensätze zu einem Stammknoten

  1. Klicken Sie auf den Stammknoten.

  2. Klicken Sie im Menü Bearbeiten auf Neuer Datensatz.

    Nach dem letzten Knoten in der Spezifikationsstruktur wird ein untergeordneter Datensatz eingefügt.

  3. Geben Sie einen Namen für den Datensatz ein, und drücken Sie die EINGABETASTE.

Anmerkungen

  • Für eine nicht auf XML basierende Datei, z. B. eine Flatfile, können Sie eine Quelltagbezeichner-Eigenschaft eingeben, um das Tag in der nicht auf XML basierenden Quelldatei zu identifizieren.

  • Gleichgeordnete Datensätze können nicht denselben Namen besitzen.

Verwandtes Thema

Festlegen von Eigenschaften für Datensätze und Felder


Hinzufügen neuer Felder zu einem Stammknoten

  1. Klicken Sie auf den Stammknoten.

  2. Klicken Sie im Menü Bearbeiten auf Neues Feld.

    Nach dem letzten Knoten in der Spezifikationsstruktur wird ein untergeordnetes Feld eingefügt.

  3. Geben Sie einen Namen für das Feld ein, und drücken Sie die EINGABETASTE.

Anmerkung

  • Gleichgeordnete Felder können nur dann denselben Namen haben, wenn die Typ-Eigenschaft eines Feldes auf Attribut festgelegt ist und die Typ-Eigenschaft des anderen Feldes auf Element festgelegt ist.

Verwandte Themen

Ändern von Feldern von Elementen in Attribute

Erstellen eines neuen Feldes als Element

Festlegen von Eigenschaften für Datensätze und Felder


Hinzufügen neuer Datensätze zu vorhandenen Datensätzen

  1. Klicken Sie auf einen Datensatz.

  2. Klicken Sie im Menü Bearbeiten auf Neuer Datensatz.

    Nach dem ausgewählten Datensatz bzw. nach dem letzten untergeordneten Knoten des ausgewählten Datensatzes wird ein untergeordneter Datensatz eingefügt.

  3. Geben Sie einen Namen für den Datensatz ein, und drücken Sie die EINGABETASTE.

Anmerkungen

  • Für eine nicht auf XML basierende Datei, z. B. eine Flatfile, können Sie eine Quelltagbezeichner-Eigenschaft eingeben, um das Tag in der nicht auf XML basierenden Quelldatei zu identifizieren.

  • Gleichgeordnete Datensätze können nicht denselben Namen besitzen.

Verwandtes Thema

Festlegen von Eigenschaften für Datensätze und Felder


Hinzufügen neuer Felder zu Datensätzen

  1. Klicken Sie auf einen Datensatz.

  2. Klicken Sie im Menü Bearbeiten auf Neues Feld.

    Nach dem ausgewählten Datensatz bzw. nach dem letzten untergeordneten Knoten des ausgewählten Datensatzes wird ein untergeordnetes Feld eingefügt.

  3. Geben Sie einen Namen für das Feld ein, und drücken Sie die EINGABETASTE.

Anmerkung

  • Gleichgeordnete Felder können nur dann denselben Namen haben, wenn die Typ-Eigenschaft eines Feldes auf Attribut festgelegt ist und die Typ-Eigenschaft des anderen Feldes auf Element festgelegt ist.

Verwandte Themen

Ändern von Feldern von Elementen in Attribute

Erstellen eines neuen Feldes als Element

Festlegen von Eigenschaften für Datensätze und Felder


Einfügen von Datensätzen

  1. Klicken Sie auf einen Datensatz.

  2. Klicken Sie im Menü Bearbeiten auf Datensatz einfügen.

    Nach dem ausgewählten Datensatz bzw. nach dem letzten untergeordneten Knoten des ausgewählten Datensatzes wird ein gleichgeordneter Datensatz eingefügt.

  3. Geben Sie einen Namen für den Datensatz ein, und drücken Sie die EINGABETASTE.

Anmerkung

  • Gleichgeordnete Datensätze können nicht denselben Namen besitzen.

Verwandtes Thema

Festlegen von Eigenschaften für Datensätze und Felder


Einfügen von Feldern

  1. Klicken Sie auf den Datensatz oder das Feld, nach dem Sie ein Feld einfügen möchten.

  2. Klicken Sie im Menü Bearbeiten auf Feld einfügen.

    Nach dem ausgewählten Datensatz bzw. nach dem letzten untergeordneten Knoten des ausgewählten Datensatzes wird ein gleichgeordnetes Feld eingefügt.

  3. Geben Sie einen Namen für das Feld ein, und drücken Sie die EINGABETASTE.

Anmerkung

  • Gleichgeordnete Felder können nur dann denselben Namen haben, wenn die Typ-Eigenschaft eines Feldes auf Attribut festgelegt ist und die Typ-Eigenschaft des anderen Feldes auf Element festgelegt ist.

Verwandte Themen

Ändern von Feldern von Elementen in Attribute

Erstellen eines neuen Feldes als Element

Festlegen von Eigenschaften für Datensätze und Felder


Erstellen eines neuen Feldes als Element

  1. Klicken Sie im Menü Extras auf Optionen.

  2. Aktivieren Sie im Dialogfeld Optionen für den BizTalk-Editor das Kontrollkästchen Neues Feld als Element erstellen, und klicken Sie auf OK.

Anmerkungen

  • Ist dieses Kontrollkästchen deaktiviert, werden Felder als Attribute erstellt. Wenn Sie das Kontrollkästchen Neues Feld als Element erstellen jedoch aktivieren, werden alle neuen Felder als Elemente erstellt.

  • Gleichgeordnete Felder können nur dann denselben Namen haben, wenn die Typ-Eigenschaft eines Feldes auf Attribut festgelegt ist und die Typ-Eigenschaft des anderen Feldes auf Element festgelegt ist.

Verwandtes Thema

Ändern von Feldern von Elementen in Attribute


Ändern von Feldern von Attributen in Elemente

  1. Klicken Sie auf ein Feld in der Spezifikationsstruktur.

  2. Doppelklicken Sie auf der Registerkarte Deklaration in der Zeile Typ auf das Feld Wert. Die aktuelle Einstellung lautet Attribut.

  3. Klicken Sie in der Liste Typ auf Element, und drücken Sie die EINGABETASTE.

  4. Klicken Sie auf Ja, um die Änderung zu bestätigen.

Anmerkung

  • Gleichgeordnete Felder können nur dann denselben Namen haben, wenn die Typ-Eigenschaft eines Feldes auf Attribut festgelegt ist und die Typ-Eigenschaft des anderen Feldes auf Element festgelegt ist.

Verwandte Themen

Ändern von Feldern von Elementen in Attribute

Erstellen eines neuen Feldes als Element


Ändern von Feldern von Elementen in Attribute

  1. Klicken Sie auf ein Feld in der Spezifikationsstruktur.

  2. Doppelklicken Sie auf der Registerkarte Deklaration in der Zeile Typ auf das Feld Wert. Die aktuelle Einstellung lautet Element.

  3. Klicken Sie in der Liste Typ auf Attribut, und drücken Sie die EINGABETASTE.

  4. Klicken Sie auf Ja, um die Änderung zu bestätigen.

Anmerkung

  • Gleichgeordnete Felder können nur dann denselben Namen haben, wenn die Typ-Eigenschaft eines Feldes auf Attribut festgelegt ist und die Typ-Eigenschaft des anderen Feldes auf Element festgelegt ist.

Verwandtes Thema

Ändern von Feldern von Attributen in Elemente


Verschieben von Datensätzen innerhalb einer Spezifikation

  1. Klicken Sie auf den Stammknoten.

  2. Klicken Sie im Menü Ansicht auf Strukturelemente erweitern.

  3. Klicken Sie auf den Datensatz, den Sie verschieben möchten, und ziehen Sie ihn zu einem anderen Knoten in der Struktur.

    Wenn Sie die Maustaste loslassen, während sich der Mauszeiger in der oberen Hälfte des markierten Knotentextes befindet, wird der Datensatz oberhalb des Knotens als gleichgeordneter Datensatz eingefügt. Befindet sich der Mauszeiger in der unteren Hälfte des markierten Knotentextes, wird der Datensatz unterhalb des Knotens als gleichgeordneter Datensatz eingefügt. Wird der Mauszeiger rechts neben dem markierten Knotentext angezeigt, wird der Datensatz unterhalb des ausgewählten Datensatzes als untergeordneter Datensatz eingefügt.

Verwandte Themen

Kopieren von Datensätzen von einer Spezifikation in eine andere

Kopieren von Datensätzen innerhalb einer Spezifikation

Verschieben von Datensätzen von einer Spezifikation in eine andere


Verschieben von Feldern innerhalb einer Spezifikation

  1. Klicken Sie auf den Stammknoten.

  2. Klicken Sie im Menü Ansicht auf Strukturelemente erweitern.

  3. Klicken Sie auf das Feld, das Sie verschieben möchten, und ziehen Sie es zu einem anderen Knoten in der Struktur.

    Wenn Sie die Maustaste loslassen, während sich der Mauszeiger in der oberen Hälfte des markierten Knotentextes befindet, wird der Datensatz oberhalb des Knotens als gleichgeordneter Datensatz eingefügt. Befindet sich der Mauszeiger in der unteren Hälfte des markierten Knotentextes, wird der Datensatz unterhalb des Knotens als gleichgeordneter Datensatz eingefügt. Wird der Mauszeiger rechts neben dem markierten Knotentext angezeigt, wird das Feld unterhalb des Datensatzes als untergeordnetes Feld eingefügt.

Verwandte Themen

Kopieren von Feldern von einer Spezifikation in eine andere

Kopieren von Feldern innerhalb einer Spezifikation

Verschieben von Feldern von einer Spezifikation in eine andere


Verschieben von Datensätzen von einer Spezifikation in eine andere

  1. Klicken Sie auf den Stammknoten in der Spezifikation, die den Datensatz enthält, den Sie verschieben möchten.

  2. Klicken Sie im Menü Ansicht auf Strukturelemente erweitern.

  3. Klicken Sie auf den Datensatz, den Sie verschieben möchten, und klicken Sie dann im Menü Bearbeiten auf Ausschneiden.

  4. Zeigen Sie im Startmenü auf Programme, zeigen Sie auf Microsoft BizTalk Server 2000, und klicken Sie dann auf BizTalk-Editor.

    Sie müssen eine zweite Instanz des BizTalk-Editors starten, um eine weitere Spezifikation zu öffnen.

  5. Klicken Sie im Menü Datei auf Öffnen.

  6. Suchen Sie im Dialogfeld Dokumentspezifikation öffnen nach dem Ordner, der die Spezifikation enthält, in die Sie den Datensatz verschieben möchten.

  7. Klicken Sie in der Liste auf die Datei, und klicken Sie dann auf Öffnen.

  8. Klicken Sie auf den Stammknoten in der Spezifikation.

  9. Klicken Sie im Menü Ansicht auf Strukturelemente erweitern.

  10. Klicken Sie auf den Stammknoten, den Datensatz oder das Feld, nach dem der Datensatz eingefügt werden soll.

  11. Klicken Sie im Menü Bearbeiten auf Einfügen.

Anmerkung

  • Falls Sie einen Datensatz verschieben, der über denselben Namen verfügt wie ein bereits vorhandener Datensatz, fügt der BizTalk-Editor automatisch am Ende des Datensatznamens eine Zahl hinzu.

Verwandte Themen

Kopieren von Datensätzen von einer Spezifikation in eine andere

Kopieren von Datensätzen innerhalb einer Spezifikation

Verschieben von Datensätzen innerhalb einer Spezifikation


Verschieben von Feldern von einer Spezifikation in eine andere

  1. Klicken Sie auf den Stammknoten der Spezifikation, die das zu verschiebende Feld enthält.

  2. Klicken Sie im Menü Ansicht auf Strukturelemente erweitern.

  3. Klicken Sie auf das Feld, das Sie verschieben möchten, und klicken Sie dann im Menü Bearbeiten auf Ausschneiden.

  4. Zeigen Sie im Startmenü auf Programme, zeigen Sie auf Microsoft BizTalk Server 2000, und klicken Sie dann auf BizTalk-Editor.

    Sie müssen eine zweite Instanz des BizTalk-Editors starten, um eine weitere Spezifikation zu öffnen.

  5. Klicken Sie im Menü Datei auf Öffnen.

  6. Suchen Sie im Dialogfeld Dokumentspezifikation öffnen nach dem Ordner, der die Spezifikation enthält, in die Sie den Datensatz verschieben möchten.

  7. Klicken Sie in der Liste auf die Datei, und klicken Sie dann auf Öffnen.

  8. Klicken Sie auf den Stammknoten der Spezifikation, in die Sie das Feld verschieben möchten.

  9. Klicken Sie im Menü Ansicht auf Strukturelemente erweitern.

  10. Klicken Sie auf den Stammknoten, den Datensatz oder das Feld, nach dem das Feld eingefügt werden soll.

  11. Klicken Sie im Menü Bearbeiten auf Einfügen.

Anmerkung

  • Falls Sie ein Feld verschieben, das über denselben Namen verfügt wie ein bereits vorhandenes Feld, fügt der BizTalk-Editor automatisch am Ende des Feldnamens eine Zahl hinzu.

Verwandte Themen

Kopieren von Feldern von einer Spezifikation in eine andere

Kopieren von Feldern innerhalb einer Spezifikation

Verschieben von Feldern innerhalb einer Spezifikation


Kopieren von Datensätzen innerhalb einer Spezifikation

  1. Klicken Sie auf den Stammknoten.

  2. Klicken Sie im Menü Ansicht auf Strukturelemente erweitern.

  3. Klicken Sie auf den Datensatz, den Sie kopieren möchten, und klicken Sie dann im Menü Bearbeiten auf Kopieren.

  4. Klicken Sie auf den Knoten, nach dem Sie den Datensatz einfügen möchten, und klicken Sie dann im Menü Bearbeiten auf Einfügen.

    Ist der ausgewählte Knoten ein Datensatz, wird ein untergeordneter Datensatz direkt nach dem ausgewählten Knoten eingefügt. Handelt es sich bei dem ausgewählten Knoten dagegen um ein Feld, wird ein gleichgeordneter Datensatz direkt nach dem ausgewählten Knoten eingefügt.

Verwandte Themen

Kopieren von Datensätzen von einer Spezifikation in eine andere

Verschieben von Datensätzen von einer Spezifikation in eine andere

Verschieben von Datensätzen innerhalb einer Spezifikation


Kopieren von Feldern innerhalb einer Spezifikation

  1. Klicken Sie auf den Stammknoten.

  2. Klicken Sie im Menü Ansicht auf Strukturelemente erweitern.

  3. Klicken Sie auf das Feld, das Sie kopieren möchten, und klicken Sie dann im Menü Bearbeiten auf Kopieren.

  4. Klicken Sie auf den Knoten, nach dem Sie das Feld einfügen möchten, und klicken Sie dann im Menü Bearbeiten auf Einfügen.

    Ist der ausgewählte Knoten ein Datensatz, wird ein untergeordnetes Feld direkt nach dem ausgewählten Knoten eingefügt. Handelt es sich bei dem ausgewählten Knoten dagegen um ein Feld, wird ein gleichgeordnetes Feld direkt nach dem ausgewählten Knoten eingefügt.

Verwandte Themen

Kopieren von Feldern von einer Spezifikation in eine andere

Verschieben von Feldern von einer Spezifikation in eine andere

Verschieben von Feldern innerhalb einer Spezifikation


Kopieren von Datensätzen von einer Spezifikation in eine andere

  1. Klicken Sie auf den Stammknoten in der Spezifikation, die den Datensatz enthält, den Sie kopieren möchten.

  2. Klicken Sie im Menü Ansicht auf Strukturelemente erweitern.

  3. Klicken Sie auf den Datensatz, den Sie kopieren möchten, und klicken Sie dann im Menü Bearbeiten auf Kopieren.

  4. Zeigen Sie im Startmenü auf Programme, zeigen Sie auf Microsoft BizTalk Server 2000, und klicken Sie dann auf BizTalk-Editor.

    Sie müssen eine zweite Instanz des BizTalk-Editors starten, um eine weitere Spezifikation zu öffnen.

  5. Klicken Sie im Menü Datei auf Öffnen.

  6. Suchen Sie im Dialogfeld Dokumentspezifikation öffnen nach dem Ordner, der die Spezifikation enthält, in die Sie den Datensatz verschieben möchten.

  7. Klicken Sie in der Liste auf die Datei, und klicken Sie dann auf Öffnen.

  8. Klicken Sie auf den Stammknoten der Spezifikation, in die Sie den Datensatz kopieren möchten.

  9. Klicken Sie im Menü Ansicht auf Strukturelemente erweitern.

  10. Klicken Sie auf den Stammknoten, den Datensatz oder das Feld, nach dem Sie den Datensatz einfügen möchten, und klicken Sie dann im Menü Bearbeiten auf Einfügen.

    Ist der ausgewählte Knoten ein Datensatz, wird ein untergeordneter Datensatz direkt nach dem ausgewählten Knoten eingefügt. Handelt es sich bei dem ausgewählten Knoten dagegen um ein Feld, wird ein gleichgeordneter Datensatz direkt nach dem ausgewählten Knoten eingefügt.

Anmerkung

  • Falls Sie einen Datensatz kopieren, der denselben Namen besitzt wie ein bereits vorhandener Datensatz, fügt der BizTalk-Editor automatisch am Ende des Datensatznamens eine Zahl hinzu.

Verwandte Themen

Kopieren von Datensätzen innerhalb einer Spezifikation

Verschieben von Datensätzen von einer Spezifikation in eine andere

Verschieben von Datensätzen innerhalb einer Spezifikation


Kopieren von Feldern von einer Spezifikation in eine andere

  1. Klicken Sie auf den Stammknoten in der Spezifikation, die das Feld enthält, das Sie kopieren möchten.

  2. Klicken Sie im Menü Ansicht auf Strukturelemente erweitern.

  3. Klicken Sie auf das Feld, das Sie kopieren möchten, und klicken Sie dann im Menü Bearbeiten auf Kopieren.

  4. Zeigen Sie im Startmenü auf Programme, zeigen Sie auf Microsoft BizTalk Server 2000, und klicken Sie dann auf BizTalk-Editor.

    Sie müssen eine zweite Instanz des BizTalk-Editors starten, um eine weitere Spezifikation zu öffnen.

  5. Klicken Sie im Menü Datei auf Öffnen.

  6. Suchen Sie im Dialogfeld Dokumentspezifikation öffnen nach dem Ordner, der die Spezifikation enthält, in die Sie das Feld verschieben möchten.

  7. Klicken Sie in der Liste auf die Datei, und klicken Sie dann auf Öffnen.

  8. Klicken Sie auf den Stammknoten der Spezifikation, in die Sie das Feld kopieren möchten.

  9. Klicken Sie im Menü Ansicht auf Strukturelemente erweitern.

  10. Klicken Sie auf den Stammknoten, den Datensatz oder das Feld, nach dem Sie den Datensatz einfügen möchten, und klicken Sie dann im Menü Bearbeiten auf Einfügen.

    Ist der ausgewählte Knoten ein Datensatz, wird ein untergeordnetes Feld direkt nach dem ausgewählten Knoten eingefügt. Handelt es sich bei dem ausgewählten Knoten dagegen um ein Feld, wird ein gleichgeordnetes Feld direkt nach dem ausgewählten Knoten eingefügt.

Anmerkung

  • Falls Sie ein Feld kopieren, das denselben Namen besitzt wie ein bereits vorhandenes Feld, fügt der BizTalk-Editor automatisch am Ende des Feldnamens eine Zahl hinzu.

Verwandte Themen

Kopieren von Feldern innerhalb einer Spezifikation

Verschieben von Feldern von einer Spezifikation in eine andere

Verschieben von Feldern innerhalb einer Spezifikation


Umbenennen eines einzelnen Datensatzes

  1. Klicken Sie auf den Datensatz, den Sie umbenennen möchten.

  2. Klicken Sie im Menü Bearbeiten auf Umbenennen.

  3. Geben Sie einen neuen Namen für den Datensatz ein, und drücken Sie die EINGABETASTE.

Verwandte Themen

Umbenennen aller Datensätze mit dem gleichen Namen

Umbenennen eines einzelnen Feldes


Umbenennen eines einzelnen Feldes

  1. Klicken Sie auf das Feld, das Sie umbenennen möchten.

  2. Klicken Sie im Menü Bearbeiten auf Umbenennen.

  3. Geben Sie einen neuen Namen für das Feld ein, und drücken Sie die EINGABETASTE.

Anmerkung

  • Felder, bei denen es sich um Elemente handelt, können nicht denselben Namen besitzen wie ein vorhandener Datensatz.

Verwandte Themen

Umbenennen aller Datensätze mit dem gleichen Namen

Umbenennen eines einzelnen Datensatzes


Umbenennen aller Datensätze mit dem gleichen Namen

  1. Klicken Sie auf einen der Datensätze, die Sie umbenennen möchten.

  2. Klicken Sie im Menü Bearbeiten auf Alle "Datensatzname" umbenennen.

  3. Geben Sie einen neuen Namen für die Datensätze ein.

    Alle Datensätze mit diesem Namen werden umbenannt.

Anmerkung

  • Dieser Befehl im Menü Bearbeiten steht nur zur Verfügung, wenn mindestens zwei Datensätze den gleichen Namen besitzen.

Verwandte Themen

Umbenennen eines einzelnen Feldes

Umbenennen eines einzelnen Datensatzes


Löschen von Datensätzen

  1. Klicken Sie auf den Datensatz, den Sie löschen möchten.

  2. Klicken Sie im Menü Bearbeiten auf Löschen.

  3. Klicken Sie im Bestätigungsdialogfeld auf Ja.

Vorsicht

  • Beim Löschen eines Datensatzes werden sämtliche untergeordneten Datensätze und Felder ebenfalls gelöscht.

Verwandtes Thema

Löschen von Feldern


Löschen von Feldern

  1. Klicken Sie auf das Feld, das Sie löschen möchten.

  2. Klicken Sie im Menü Bearbeiten auf Löschen.

  3. Klicken Sie im Bestätigungsdialogfeld auf Ja.

Verwandtes Thema

Löschen von Datensätzen


Erstellen von zyklischen Verweisen

  1. Wählen Sie einen Datensatz aus, unter dem ein zyklischer Verweis erstellt werden soll.

    Dies ist der Basisdatensatz.

  2. Klicken Sie im Menü Bearbeiten auf Neuer Datensatz.

  3. Geben Sie dem neuen Datensatz denselben Namen wie dem Basisdatensatz, und drücken Sie die EINGABETASTE.

    Ein zyklischer Verweis Symbol "zyklischer Verweis" wird erstellt.

  4. Doppelklicken Sie auf der Registerkarte Deklaration in der Zeile Anzahl der Zyklen auf das Feld Wert.

  5. Geben Sie eine Zahl zwischen 1 und 7 ein, und drücken Sie die EINGABETASTE.

Wichtig

  • Für die Minimalvorkommen-Eigenschaft auf der Registerkarte Verweis muss 0 festgelegt werden. Die Einstellung 1 bewirkt eine Endlosschleife.

Anmerkung

  • Zyklische Verweise können nur in XML-Spezifikationen verwendet werden. Stellen Sie sicher, dass es sich um eine XML-basierte Spezifikation handelt.

Verwandtes Thema

Zyklische Verweise


Erstellen einer neuen Instanz eines vorhandenen Datensatzes

  1. Klicken Sie an der Stelle, an der Sie eine neue Instanz eines vorhandenen Datensatzes erstellen möchten, auf einen Knoten.

  2. Klicken Sie im Menü Bearbeiten auf Neuer Datensatz oder Datensatz einfügen.

    Anmerkung

    • Wenn Sie in Schritt 1 ein Feld ausgewählt haben, steht der Befehl Neuer Datensatz im Menü Bearbeiten nicht zur Verfügung.
  3. Geben Sie dem neuen Datensatz denselben Namen wie dem vorhandenen Datensatz, und drücken Sie die EINGABETASTE.

    Damit haben Sie zwei Instanzen desselben Datensatzes erstellt.

Wichtig

  • Eine neue Datensatzinstanz kann nicht über denselben Namen verfügen wie ein gleichgeordneter Datensatz.

  • Wenn Sie einem neuen Datensatz denselben Namen geben wie dem übergeordneten Datensatz, erstellen Sie einen zyklischen Verweis, keine neue Instanz eines vorhandenen Datensatzes. Weitere Informationen finden Sie unter Zyklische Verweise.

Anmerkungen

  • Wenn Sie auf Neuer Datensatz klicken, wird die neue Datensatzinstanz in Abhängigkeit von dem ausgewählten Datensatz erstellt.

  • Wenn Sie dagegen auf Datensatz einfügen klicken, wird die neue Datensatzinstanz dem ausgewählten Datensatz oder Feld gleichgestellt.

  • Die Knotenstruktur unterhalb von Instanzen eines Datensatzes ist identisch; wenn Sie zu einer Datensatzinstanz einen Knoten hinzufügen bzw. einen Knoten daraus entfernen, wird dieser Vorgang für alle anderen Instanzen des Datensatzes ebenfalls durchgeführt. Einige Eigenschaften von Datensatzinstanzen stimmen überein, während andere für jede Instanz einzeln festgelegt werden können. Weitere Informationen zu identischen und nicht identischen Eigenschaften finden Sie unter Eigenschaftsbereich.

  • Sie können einem vorhandenen Datensatz nicht denselben Namen geben wie einem anderen vorhandenen Datensatz.

  • Sie können auch die STRG-TASTE drücken und einen vorhandenen Datensatz rechts neben den Knoten ziehen, unter dem die neue Datensatzinstanz eingefügt werden soll, um eine neue Instanz eines vorhandenen Datensatzes zu erstellen.

Verwandte Themen

Zyklische Verweise

Eigenschaftsbereich


Erstellen einer neuen Instanz eines vorhandenen Elementfeldes

  1. Wählen Sie einen Knoten an der Stelle aus, an der Sie eine neue Instanz eines Elementfeldes erstellen möchten.

    Anmerkung

    • Mehrere Feldinstanzen können nur erstellt werden, wenn es sich um Felder des Typs Element handelt (auf der Registerkarte Deklaration). Bei Feldern des Typs Attribut sind mehrere Feldinstanzen nicht möglich. Wenn Sie zwei oder mehr Attributfelder mit demselben Namen erstellen, bleiben diese Felder unabhängig voneinander.
  2. Klicken Sie im Menü Bearbeiten auf Neues Feld oder Feld einfügen.

    Anmerkung

    • Wenn Sie in Schritt 1 ein Feld ausgewählt haben, steht der Befehl Neues Feld im Menü Bearbeiten nicht zur Verfügung.
  3. Geben Sie dem neuen Feld denselben Namen wie dem vorhandenen Feld, und drücken Sie die EINGABETASTE.

    Damit haben Sie zwei Instanzen desselben Feldes erstellt.

Wichtig

  • Sie können einer neuen Instanz eines Elementfeldes nicht denselben Namen geben wie einer gleichgeordneten Instanz eines Elementfeldes.

Anmerkungen

  • Wenn Sie auf Neues Feld klicken, wird die neue Feldinstanz in Abhängigkeit von dem ausgewählten Datensatz erstellt.

  • Wenn Sie dagegen auf Feld einfügen klicken, wird die neue Feldinstanz dem ausgewählten Datensatz oder Feld gleichgestellt.

  • Einige Eigenschaften von Feldinstanzen stimmen überein, während andere für jede Instanz einzeln festgelegt werden können. Weitere Informationen zu identischen und nicht identischen Eigenschaften finden Sie unter Eigenschaftsbereich.

  • Vorhandene Felder können nur dann denselben Namen haben, wenn die Typ-Eigenschaft eines Feldes auf Attribut und die Typ-Eigenschaft des anderen Feldes auf Element festgelegt ist.

  • Sie können auch die STRG-TASTE drücken und ein vorhandenes Elementfeld rechts neben den Knoten ziehen, unter dem die neue Feldinstanz eingefügt werden soll, um eine neue Instanz eines vorhandenen Elementfeldes zu erstelle,.

Verwandte Themen

Zyklische Verweise

Eigenschaftsbereich


Festlegen von Eigenschaften für Datensätze und Felder

Dieser Abschnitt enthält Informationen zu folgenden Themen:

  • Festlegen von Deklarationseigenschaften

  • Festlegen von Verweiseigenschaften

  • Festlegen von Analyseeigenschaften

  • Deklarieren von Namespaces

  • Hinzufügen von benutzerdefinierten Anmerkungen

  • Bearbeiten von benutzerdefinierten Anmerkungen

  • Löschen von benutzerdefinierten Anmerkungen

  • Festlegen von Wörterbucheigenschaften

  • Hinzufügen einer benutzerdefinierten Wörterbucheigenschaft

  • Umbenennen einer benutzerdefinierten Wörterbucheigenschaft

  • Löschen einer Wörterbucheigenschaft

  • Löschen einer benutzerdefinierten Wörterbucheigenschaft

  • Auswählen von Codes

  • Codes löschen

  • Löschen einer Eigenschaft für ein beliebiges Feld in der Spalte "Wert"

  • Automatisches Berechnen von Feldpositionen


Festlegen von Deklarationseigenschaften

  1. Klicken Sie in der Spezifikationsstruktur auf den Stammknoten, den Datensatz oder das Feld, für den bzw. das Sie eine Eigenschaft festlegen möchten, und klicken Sie dann auf die Registerkarte Deklaration.

  2. Doppelklicken Sie in der Spalte Wert auf das Feld, das mit der Eigenschaft verknüpft ist, die Sie festlegen möchten.

  3. Nehmen Sie in dem Feld eine Eingabe vor, oder klicken Sie auf den nach unten zeigenden Pfeil, um unter den verfügbaren Optionen auszuwählen.

  4. Drücken Sie die EINGABETASTE, um die Änderungen zu bestätigen.

Die Registerkarte Deklaration enthält die Eigenschaften, die in den folgenden Tabellen beschrieben sind. Abhängig von dem ausgewählten Knoten werden die betreffenden Eigenschaften für den Stammknoten, einen Datensatz oder ein Feld festgelegt.

Registerkarte "Deklaration": Stammknoteneigenschaften

Eigenschaft | Wert
Name Der Name des Stammknotens.

Anmerkungen

Wenn Sie den Wert Name auf der Registerkarte Deklaration ändern, wird der Name des Stammknotens in der Spezifikationsstruktur automatisch angepasst. Bei einer neu erstellten Spezifikation bewirkt das Ändern des Wertes Name auf der Registerkarte Deklaration, dass der Wert Spezifikationsname auf der Registerkarte Verweis ebenfalls geändert wird. Da der Spezifikationsname und der Stammknotenname jedoch unterschiedlich sein können, hat eine Änderung des Wertes Spezifikationsname keine Auswirkung auf den Wert Name oder den Namen des Stammknotens in der Spezifikationsstruktur. Nachdem der Wert Spezifikationsname bearbeitet wurde, hat eine Änderung des Wertes Name oder des Stammknotennamens keine Auswirkung auf den Wert Spezifikationsname.
Beschreibung | Die Beschreibung der Spezifikation.
Typ | Der Typ des Datensatzes.
Modell Geschlossen. Gibt an, dass die in der Dokumentinstanz und der Spezifikationsstruktur enthaltenen Daten übereinstimmen.

Offen. Gibt an, dass die Daten in der Dokumentinstanz nicht vollständig mit der Struktur der Spezifikation übereinstimmen.

  • Wird für diese Eigenschaft kein Wert festgelegt, lautet der Standardwert Offen.
Inhalt Nur Element. Gibt an, dass der Stammknoten nur Elemente enthalten kann. Enthält der Stamm einen untergeordneten Datensatz, ist dies die Standardeinstellung.

Leer. Gibt an, dass der Stammknoten keine Unterelemente enthalten kann.

Nur Text. Gibt an, dass der Stammknoten Text, aber keine Unterelemente enthalten kann.

Anmerkung

  • Der BizTalk-Editor unterstützt keine Elemente mit gemischtem Inhalt (Textinformationen und Unterelemente).
Reihenfolge Wählen Sie einen der folgenden Werte aus:
  • Eins. Gibt an, dass nur ein Element angezeigt werden kann.

  • Reihenfolge. Gibt an, dass die Elemente in der angegebenen Reihenfolge angezeigt werden müssen.

  • Viele. Gibt an, dass null oder mehr Elemente in beliebiger Reihenfolge und Kombination angezeigt werden können.

Registerkarte "Deklaration": Datensatzeigenschaften

Eigenschaft | Wert
Name | Der Name des Datensatzes.
Beschreibung | Die Beschreibung des Datensatzes.
Typ | Der Typ des Datensatzes.
Modell Geschlossen. Gibt an, dass die in der Dokumentinstanz und der Spezifikationsstruktur enthaltenen Daten übereinstimmen.

Offen. Gibt an, dass die Daten in der Dokumentinstanz und der Spezifikationsstruktur nicht übereinstimmen.

  • Wird für diese Eigenschaft kein Wert festgelegt, lautet der Standardwert Offen.
Inhalt Nur Element. Gibt an, dass der Datensatz nur Elemente enthalten kann. Dies ist die Standardeinstellung für alle Datensätze, die untergeordnete Datensätze enthalten.

Leer. Gibt an, dass der Datensatz keine Unterelemente enthalten kann.

Nur Text. Gibt an, dass der Datensatz Text, aber keine Unterelemente enthalten kann.

Anmerkung

Der BizTalk-Editor unterstützt keine Elemente mit gemischtem Inhalt (Textinformationen und Unterelemente).
Reihenfolge Wählen Sie einen der folgenden Werte aus:
  • Eins. Gibt an, dass nur ein Element angezeigt werden kann.

  • Reihenfolge. Gibt an, dass die Elemente in der angegebenen Reihenfolge angezeigt werden müssen.

  • Viele. Gibt an, dass null oder mehr Elemente in beliebiger Reihenfolge und Kombination angezeigt werden können.
Anzahl der Zyklen Geben Sie die Anzahl der Zyklen ein, die unter dem Basisdatensatz angezeigt werden sollen. Weitere Informationen finden Sie unter Zyklische Verweise.

Anmerkung

  • Dieses Eigenschaftenfeld steht nur zur Verfügung, wenn Sie einen zyklischen Verweis erstellt haben.

Registerkarte "Deklaration": Feldeigenschaften

Eigenschaft | Wert
Name | Der Name des Feldes.
Beschreibung | Die Beschreibung des Feldes.
Typ Wählen Sie einen der folgenden Werte aus:
  • Element

  • Attribut
Modell Geschlossen. Gibt an, dass die in der Dokumentinstanz und der Spezifikationsstruktur enthaltenen Daten übereinstimmen.

Offen. Gibt an, dass die Daten in der Dokumentinstanz und der Spezifikationsstruktur nicht übereinstimmen.

Anmerkungen

  • Wird für diese Eigenschaft kein Wert festgelegt, lautet der Standardwert Offen.

  • Die Modell-Eigenschaft steht nur für Felder zur Verfügung, deren Wert Typ auf Element festgelegt wurde.
Inhalt Nur Text. Gibt an, dass der Datensatz Text, aber keine Unterelemente enthalten kann.

Anmerkungen

  • Die Inhalt-Eigenschaft steht nur für Felder zur Verfügung, deren Wert Typ auf Element festgelegt wurde.

  • Für die Inhalt-Eigenschaft eines Feldes kann nur der Wert Nur Text festgelegt werden.
Datentyp Ein gültiger Datentyp. Eine Liste und Beschreibungen aller gültigen Datentypen finden Sie unter Zusammenfassung der Datentypen und Datentypwerte.

Wichtig

  • Wurde für die Standard-Eigenschaft auf der Registerkarte Verweis der Wert X12, EDIFACT oder CUSTOM festgelegt, können Sie auf der Registerkarte Analysieren einen Wert für die Benutzerdefinierter Datentyp-Eigenschaft festlegen. Wenn Sie für Benutzerdefinierter Datentyp einen Wert festlegen, wird der Wert im Feld Datentyp automatisch geändert, so dass er mit der Auswahl für Benutzerdefinierter Datentyp übereinstimmt. Falls für Benutzerdefinierter Datentyp bereits ein Wert festgelegt wurde und Sie dann im Feld Datentyp auf der Registerkarte Deklaration einen Wert angeben, wird der im Feld Benutzerdefinierter Datentyp angezeigte Wert gelöscht.

  • Wurde in einer Spezifikation ein Feld erstellt, für dessen Datentyp-Eigenschaft IDREF oder IDREFS festgelegt wurde, muss in dieser Spezifikation ein weiteres Feld mit dem Wert ID für die Datentyp-Eigenschaft erstellt werden.

  • Sie müssen diesem Feld in der Spezifikation einen Datentyp zuweisen, um im BizTalk-Messaging-Manager ein Feld zur Überwachung oder zur Verwendung in einem Kanalfilterausdruck auszuwählen.
Datentypwerte Wenn Sie den Wert Enumeration in der Liste Datentyp auswählen, werden standardmäßig die Datentypwerte a b c im Feld Datentypwerte angezeigt. Sie können die Standardwerte durch benutzerdefinierte Werte, die durch jeweils ein Leerzeichen getrennt sind, ersetzen.

Wenn Sie mit einem X12- oder EDIFACT-Dokument arbeiten, das mit einem bestimmten Feld verknüpfte Codes enthält, werden diese Codes automatisch im Feld Datentypwerte angezeigt, und das Feld Datentyp erhält den Wert Enumeration.
Minimallänge Die minimale Anzahl von Zeichen, die das Feld enthalten kann.

Anmerkung

  • Die Minimallänge-Eigenschaft kann nur für Felder mit den folgenden Datentyp-Werten festgelegt werden: String, Number, Binary (base64) und Binary (hex).
Maximallänge Die maximale Anzahl von Zeichen, die das Feld enthalten kann.

Anmerkung

  • Die Maximallänge-Eigenschaft kann nur für Felder mit den folgenden Datentyp-Werten festgelegt werden: String, Number, Binary (base64) und Binary (hex).
Standardwert Dieser Wert wird verwendet, wenn die eingehende Dokumentinstanz das Feld nicht enthält. Weitere Informationen finden Sie unter Integration von Standardwerten.

Anmerkung

  • Die Standardwert-Eigenschaft wird nur in Spezifikationen angezeigt, bei denen für die Standard-Eigenschaft (auf der Registerkarte Verweis für den Stammknoten) der Wert XML und für die Typ-Eigenschaft (auf der Registerkarte Deklaration für das Feld) der Wert Attribut festgelegt wurde.

Verwandte Themen

Hinzufügen eines Kanalfilterausdrucks

Zyklische Verweise

Integration von Standardwerten

Auswählen von Spezifikationsfeldern in einem Kanal

Auswählen von Spezifikationsfeldern in einer Dokumentdefinition

Zusammenfassung der Datentypen und Datentypwerte


Festlegen von Verweiseigenschaften

  1. Klicken Sie in der Spezifikationsstruktur auf den Stammknoten, den Datensatz oder das Feld, für den bzw. das Sie eine Eigenschaft festlegen möchten, und klicken Sie dann auf die Registerkarte Verweis.

  2. Doppelklicken Sie in der Spalte Wert auf das Feld, das mit der Eigenschaft verknüpft ist, die Sie festlegen möchten.

  3. Nehmen Sie in dem Feld eine Eingabe vor, oder klicken Sie auf den nach unten zeigenden Pfeil, um unter den verfügbaren Optionen auszuwählen.

Die Registerkarte Verweis enthält die Eigenschaften, die in den folgenden Tabellen beschrieben sind. Abhängig von dem ausgewählten Knoten werden die betreffenden Eigenschaften für den Stammknoten, einen Datensatz oder ein Feld festgelegt.

Registerkarte "Verweis": Stammknoteneigenschaften

Eigenschaft | Wert
Spezifikationsname | Der Name der Spezifikation. Dieser Name entspricht dem Wert des <Schema>-Tags in der Spezifikation.
Standard Wählen Sie einen der folgenden Werte aus:
  • XML zum Erstellen einer Spezifikation auf der Basis von XML (Extensible Markup Language).

  • X12 zum Erstellen einer Spezifikation auf der Basis von X12.

  • EDIFACT zum Erstellen einer Spezifikation auf der Basis von EDIFACT.

  • CUSTOM zum Erstellen einer Spezifikation auf der Basis einer Flatfile oder einer benutzerdefinierten Spezifikation, die mit einem benutzerdefinierten Parser analysiert werden soll.
Standardversion | Die Version des Standards, beispielsweise X12, Version 4010, auf der die Spezifikation basiert.
Dokumenttyp | Der Dokumenttyp, beispielsweise 850, auf dem die Spezifikation basiert.
Version | Die Versionsnummer des Dokumentstandards, auf dem die Spezifikation basiert.
Standard-Datensatztrennzeichen Nehmen Sie die Eingabe bzw. Auswahl eines Zeichens vor, das als Trennzeichen für alle Knoten verwendet werden soll, für die Standard-Datensatztrennzeichen als Trennzeichentyp auf der Registerkarte Analysieren festgelegt ist.

Anmerkung

  • Dieses Eigenschaftenfeld wird nur angezeigt, wenn das Standardfeld auf der Registerkarte Verweis (für den Stammknoten) auf CUSTOM festgelegt ist.
Standardfeldtrennzeichen Nehmen Sie die Eingabe bzw. Auswahl eines Zeichens vor, das als Trennzeichen für alle Knoten verwendet werden soll, für die Standardfeldtrennzeichen als Trennzeichentyp auf der Registerkarte Analysieren festgelegt ist.

Anmerkung

  • Dieses Eigenschaftenfeld wird nur angezeigt, wenn das Standardfeld auf der Registerkarte Verweis (für den Stammknoten) auf CUSTOM festgelegt ist.
Standardunterfeldtrennzeichen Nehmen Sie die Eingabe bzw. Auswahl eines Zeichens vor, das als Trennzeichen für alle Knoten verwendet wird, für die Standardunterfeldtrennzeichen als Trennzeichentyp auf der Registerkarte Analysieren festgelegt ist.

Anmerkung

  • Dieses Eigenschaftenfeld wird nur angezeigt, wenn das Standardfeld auf der Registerkarte Verweis (für den Stammknoten) auf CUSTOM festgelegt ist.
Standardescapezeichen Nehmen Sie die Eingabe bzw. Auswahl eines Zeichens vor, das als Escapezeichen für alle Knoten verwendet werden soll, für die Standardescapezeichen als Escapetyp auf der Registerkarte Analysieren festgelegt ist.

Anmerkung

  • Dieses Eigenschaftenfeld wird nur angezeigt, wenn das Standardfeld auf der Registerkarte Verweis (für den Stammknoten) auf CUSTOM festgelegt ist.
Codepage Wählen Sie einen der folgenden Werte:
  • Arabisch (1256)

  • Baltisch (1257)

  • Mitteleuropäisch (1250)

  • Kyrillisch (1251)

  • Griechisch (1253)

  • Hebräisch (1255)

  • Japanisch Shift-JIS (932)

  • Koreanisch (949)

  • Little-Endian-UTF16 (1200)

  • Vereinfachtes Chinesisch (936)

  • Thai (874)

  • Traditionelles Chinesisch (950)

  • Türkisch (1254)

  • Vietnamesisch (1258)

  • Westeuropäisch (1252)

Anmerkung

  • Dieses Eigenschaftenfeld wird nur angezeigt, wenn das Standardfeld auf der Registerkarte Verweis (für den Stammknoten) auf CUSTOM festgelegt ist.

  • UTF7 (65000) und UTF8 (65001) werden von BizTalk Server nicht unterstützt.

  • Wird für Codepage kein Wert festgelegt, lautet der Standardwert Westeuropäisch (1252).
Empfangsbestätigung Wählen Sie eine der folgenden Optionen:
  • Ja. Gibt an, dass die Spezifikation als eingehende Empfangsbestätigung verwendet werden soll. Eine Korrelatorkomponente (X12, EDIFACT oder CUSTOM) stellt eine Verbindung zwischen der Empfangsbestätigung und dem ausgehenden Dokument, das diese bestätigt, her (d. h. dem Dokument, das zuvor an den Absender der Empfangsbestätigung gesendet wurde).

  • Nein. Gibt an, dass die Spezifikation nicht als eingehende Empfangsbestätigung verwendet werden soll.

Anmerkungen

  • Wird für Empfangsbestätigung kein Wert festgelegt, lautet der Standardwert Nein.

  • Für Spezifikationen, die auf der Standardempfangsbestätigung basieren, und für Spezifikationen, denen die Standardempfangsbestätigung zugeordnet ist (beide werden beim Generieren einer ausgehenden Empfangsbestätigung verwendet), sollte die Empfangsbestätigung-Eigenschaft auf Nein festgelegt werden.
Umschlag Wählen Sie eine der folgenden Optionen:
  • Ja. Gibt an, dass es sich bei der Spezifikation um eine Austauschspezifikation handelt.

  • Nein. Gibt an, dass es sich bei der Spezifikation nicht um eine Austauschspezifikation handelt.
Zielnamespace Wenn eine BizTalk Framework-Instanz erstellt und in dieser Instanz ein Namespace festgelegt wurde, muss der in der Instanz verwendete Namespace eingegeben werden.

Anmerkung

  • Wurde für den Zielnamespace einer Instanz der Wert x-schema festgelegt, kann beim Testen der Instanz im BizTalk-Mapper ein Fehler auftreten.

Registerkarte "Verweis": Datensatzeigenschaften

Eigenschaft Wert
Minimalvorkommen Gibt an, wie oft ein Datensatz an seiner Position innerhalb der Knotenhierarchie minimal vorkommen kann. Mögliche Werte sind 0 oder 1.

Anmerkung

  • Wird für diese Eigenschaft kein Wert festgelegt, lautet der Standardwert 1.
Maximalvorkommen Gibt an, wie oft ein Datensatz an seiner Position innerhalb der Knotenhierarchie maximal vorkommen kann. Mögliche Werte sind 1 und *.

Anmerkungen

  • Ein Sternchen (*) zeigt an, dass es sich bei dem Datensatz um einen Schleifendatensatz handelt. Bei Verwendung dieser Spezifikation im BizTalk-Mapper wird der Datensatz als Schleife kompiliert. Wenn Sie 1 eingeben, betrachtet der BizTalk-Mapper diesen Datensatz nicht als Schleifendatensatz.

  • Wird für diese Eigenschaft kein Wert festgelegt, lautet der Standardwert 1.

Registerkarte "Verweis": Feldeigenschaften

Eigenschaft Wert
Erforderlich Wählen Sie eine der folgenden Optionen:
  • Ja. Gibt an, dass dieses Feld vorhanden sein muss.

  • Nein. Gibt an, dass dieses Feld nicht vorhanden sein muss.

  • Wird für diese Eigenschaft kein Wert festgelegt, lautet der Standardwert Nein.
Anfangsposition Eine Zahl, die die Anfangsposition des Feldes im Datensatz angibt.

Anmerkung

  • Dieses Eigenschaftenfeld wird nur angezeigt, wenn der übergeordnete Datensatz auf einer Struktur mit Feldern fester Breite basiert.
Endposition Eine Zahl, die die Endposition des Feldes im Datensatz angibt.

Anmerkung

  • Dieses Eigenschaftenfeld wird nur angezeigt, wenn der übergeordnete Datensatz auf einer Struktur mit Feldern fester Breite basiert.

Verwandtes Thema

Berechnen von Feldpositionen

Grundlegendes zu Empfangsbestätigungen


Festlegen von Analyseeigenschaften

  1. Klicken Sie in der Spezifikationsstruktur auf den Stammknoten, den Datensatz oder das Feld, für den bzw. das Sie eine Eigenschaft festlegen möchten, und klicken Sie dann auf die Registerkarte Analysieren.

  2. Doppelklicken Sie in der Spalte Wert auf das Feld, das mit Eigenschaft verknüpft ist, die Sie festlegen möchten.

  3. Nehmen Sie in dem Feld eine Eingabe vor, oder klicken Sie auf den nach unten zeigenden Pfeil, um unter den verfügbaren Optionen auszuwählen.

Die Registerkarte Analysieren enthält die Eigenschaften, die in den folgenden Tabellen beschrieben sind. Die verfügbaren Eigenschaften hängen von der verwendeten Standard- (X12, EDIFACT oder CUSTOM) und Struktur-Eigenschaft ab. Standardmäßig wird bei einer neuen Spezifikation, die auf einer leeren Spezifikation basiert, die Standard-Eigenschaft XML (Extensible Markup Language) verwendet. Geben Sie für jede Eigenschaft den gewünschten Wert ein. Abhängig von dem ausgewählten Knoten werden die betreffenden Eigenschaften für den Stammknoten, einen Datensatz oder ein Feld festgelegt.

Standard: XML

Registerkarte "Analysieren": Stammknoten-, Datensatz- und Feldeigenschaften.

Diese Eigenschaften werden nicht angezeigt.

Standard: X12 oder EDIFACT

Wichtig

  • Die Werte für Zeichen für Zeilenumbruch, Auffüllzeichen, Escapewert und Trennzeichenwert für einen Datensatz sowie die ihm untergeordneten Felder schließen sich gegenseitig aus.

  • Sie sollten auf jeden Fall sicherstellen, dass das Zeilenumbruchzeichen und das Escapezeichen nicht identisch sind.

Registerkarte "Analysieren": Stammknoten- oder Datensatzeigenschaften

Eigenschaft Wert
Struktur Für den Stammknoten wird automatisch der Standardwert Getrennt verwendet.

Anmerkung

  • Wurde auf der Registerkarte Verweis des Stammknotens einer Spezifikation für die Standard-Eigenschaft der Wert X12 oder EDIFACT festgelegt, können Sie den Wert für die Struktur-Eigenschaft auf der Registerkarte Analysieren des Stammknotens oder eines Datensatzes nicht bearbeiten. Sie müssen den Standard in CUSTOM ändern, um die Struktur-Eigenschaft bearbeiten zu können.
Quelltagbezeichner Der Name des Quelltagbezeichners. Dieser Tagname wird verwendet, um dem Datensatz Daten zuzuordnen.

Anmerkungen

  • Für eine nicht auf XML basierende Datei, z. B. eine Flatfile, können Sie eine Quelltagbezeichner-Eigenschaft eingeben, um jedes beliebige Tag in der Originaldatei zu identifizieren.

  • Bei der Quelltagbezeichner-Eigenschaft muss die Groß-/Kleinschreibung beachtet werden.
Feldreihenfolge Wählen Sie eine der folgenden Optionen aus:
  • Präfix. Ein Präfixtrennzeichen wird vor jeder Komponente und jedem Mitglied einer Komponente in einer Serie angezeigt. * ist beispielsweise das Trennzeichen: *a*a*b*c.

  • Postfix. Ein Postfixtrennzeichen wird nach jeder Komponente und jedem Mitglied einer Komponente in einer Serie angezeigt. * ist beispielsweise das Trennzeichen: a*a*b*c*.

  • Infix. Ein Infixtrennzeichen wird zwischen Komponenten und Mitgliedern von Komponenten in einer Serie angezeigt. * ist beispielsweise das Trennzeichen: a*a*b*c. Dies ist die grundlegende Feldreihenfolge für alle EDI-Dokumente.

Anmerkung

  • Wird für Feldreihenfolge kein Wert festgelegt, lautet der Standardwert Präfix.
Trennzeichentyp Wählen Sie eine der folgenden Optionen aus, um ein Trennzeichen für die untergeordneten Knoten direkt unterhalb des aktuellen Knotens festzulegen:
  • Standard-Datensatztrennzeichen. Gibt an, dass als Trennzeichen der Wert für die Standard-Datensatztrennzeichen-Eigenschaft verwendet werden soll, der in der Dokumentinstanz definiert ist.

  • Standardfeldtrennzeichen. Gibt an, dass als Trennzeichen der Wert für die Standardfeldtrennzeichen-Eigenschaft verwendet werden soll, der in der Dokumentinstanz definiert ist.

  • Standardunterfeldtrennzeichen. Gibt an, dass als Trennzeichen der Wert für die Standardunterfeldtrennzeichen-Eigenschaft verwendet werden soll, der in der Dokumentinstanz definiert ist.
Escapetyp

(Wird auch als Freigabezeichen bezeichnet.)

 Wählen Sie die folgende Option aus, um ein Escapezeichen für die untergeordneten Knoten direkt unterhalb des aktuellen Knotens festzulegen:
  • Standardescapezeichen. Gibt an, dass in der Dokumentinstanz ein Wert für das Escapezeichen definiert wurde.

Ein Escapezeichen ist nützlich, wenn die Felddaten ein Zeichen enthalten, das als Trennzeichen für den übergeordneten Knoten des Feldes verwendet wird. Die Felddaten könnten beispielsweise folgendermaßen lauten:

Braun,Michael,1231,ja

Falls Sie ein Komma als Trennzeichenwert für den Knoten, der das Feld enthält, ausgewählt haben, interpretiert der BizTalk-Editor das Komma nach "Braun" als Trennzeichen, auch wenn es sich dabei um einen Teil der Felddaten handelt. Sie können dieses Problem umgehen, indem Sie direkt vor das Trennzeichen, das Teil der Felddaten sein soll, ein Escapezeichen setzen. Wenn Sie beispielsweise den umgekehrten Schrägstrich als Escapezeichen festlegen, können Sie diesen direkt vor ein Trennzeichen setzen, wie im folgenden Beispiel dargestellt:

Braun\,Michael,1231,ja

Das Komma nach dem umgekehrten Schrägstrich wird vom BizTalk-Editor als Teil der Felddaten und nicht als Trennzeichen interpretiert.

Anmerkung

  • Die Escapetyp-Eigenschaft steht für X12-Spezifikationen nicht zur Verfügung.
Neue Zeile anfügen Wählen Sie eine der folgenden Optionen aus:
  • Ja. Gibt an, dass die Serialisierungskomponente beim Erreichen des Datensatztrennzeichens automatisch eine neue Zeile anfügt (LF,0x0A).

  • Nein. Gibt an, dass die Serialisierungskomponente beim Erreichen des Datensatztrennzeichens im nächsten Datensatz mit derselben Zeile fortfährt.

Anmerkung

  • Wird für Neue Zeile anfügen kein Wert eingegeben, lautet der Standardwert Nein.
Wagenrücklauf überspringen Wählen Sie eine der folgenden Optionen aus:
  • Ja. Teilt dem Parser mit, dass der Wagenrücklauf nach einem Trennzeichen übersprungen werden soll.

  • Nein. Teilt dem Parser mit, dass der Wagenrücklauf nach einem Trennzeichen nicht übersprungen werden soll.

Anmerkung

  • Wird für Wagenrücklauf überspringen kein Wert festgelegt, lautet der Standardwert Ja.
Zeilenvorschub überspringen Wählen Sie eine der folgenden Optionen aus:
  • Ja. Teilt dem Parser mit, dass der Zeilenvorschub nach einem Trennzeichen übersprungen werden soll.

  • Nein. Teilt dem Parser mit, dass der Zeilenvorschub nach einem Trennzeichen nicht übersprungen werden soll.

Anmerkung

  • Wird für Zeilenvorschub überspringen kein Wert festgelegt, lautet der Standardwert Ja.
Datensatzanzahl ignorieren Wählen Sie eine der folgenden Optionen aus:
  • Ja. Teilt dem Parser oder der Serialisierungskomponente mit, dass dieser Datensatz beim Zählen der Datensätze in der Spezifikation nicht berücksichtigt werden soll.

  • Nein. Teilt dem Parser oder der Serialisierungskomponente mit, dass dieser Datensatz beim Zählen der Datensätze in der Spezifikation berücksichtigt werden soll.

Anmerkungen

  • Stimmt die Anzahl der Datensätze in einer an BizTalk Server gesendeten Dokumentinstanz nicht mit der berechneten Anzahl der Datensätze in der Spezifikation überein, tritt ein Analysefehler auf. Weitere Informationen finden Sie unter Analysefehler.

  • Wird für Datensatzanzahl ignorieren kein Wert festgelegt, lautet der Standardwert Ja.

Registerkarte "Analysieren": Feldeigenschaften

Eigenschaft | Wert
Benutzerdefinierter Datentyp Wählen Sie eine der folgenden Optionen aus:
  • String (AN). AN steht für alphanumerische Felder.

  • Binary Hexadecimal (B). B steht für binäre Felder.

  • Date (CY). CY steht für vierstellige Datumsfelder.

  • Number (D0-D4). D0 bis D4 (einschließlich) stehen für Dezimalfelder. Die einstellige Zahl zeigt die Anzahl der Stellen nach dem Dezimaltrennzeichen an.

  • Date (DT). DT steht für Datumsfelder.

  • String (ID). ID steht für Identifikationsfelder.

  • Number (N). N steht für Felder mit ganzen Zahlen.

  • Number (N0-9). N0 bis N9 (einschließlich) stehen für implizite Dezimalfelder (das Dezimaltrennzeichen wird in den Daten nicht angezeigt). Die einstellige Zahl zeigt die Anzahl der Stellen nach dem Dezimaltrennzeichen an.

  • Number (R). R steht für Felder mit reellen Zahlen.

  • Number (R0-R9). R0 bis R9 (einschließlich) stehen für Felder mit reellen Zahlen. Die einstellige Zahl zeigt die Anzahl der Stellen nach dem Dezimaltrennzeichen an.

  • Time (TM). TM steht für Zeitfelder.

Wichtig

  • Wenn Sie für Benutzerdefinierter Datentyp einen Wert angeben, wird der Wert im Feld Datentyp auf der Registerkarte Deklaration automatisch geändert, so dass er mit der Auswahl für Benutzerdefinierter Datentyp übereinstimmt. Wenn Sie beispielsweise Benutzerdefinierter Datentyp auf der Registerkarte Analysieren in Date (CY) ändern, wird unter Datentyp auf der Registerkarte Deklaration automatisch Date angezeigt. Bei Angabe eines Wertes im Feld Datentyp auf der Registerkarte Deklaration wird der Wert im Feld Benutzerdefinierter Datentyp gelöscht.

Anmerkungen

  • Wurde für die Benutzerdefinierter Datentyp-Eigenschaft der Wert Date (DT), Date (CY) oder Time (TM) angegeben, muss für die Benutzerdefiniertes Datum/Zeitformat-Eigenschaft ebenfalls ein Wert festgelegt werden.

  • Alle Werte für benutzerdefinierte Datentypen werden in Spezifikationen, in denen die Standard-Eigenschaft auf X12 festgelegt wurde, unterstützt. Unterstützte Datentypen für Spezifikationen, in denen für die Standard-Eigenschaft EDIFACT festgelegt wurde, sind String (AN) und Number (N).
Benutzerdefiniertes Datum/Zeitformat Wurde für die Benutzerdefinierter Datentyp-Eigenschaft der Wert Date (DT), Date (CY) oder Time (TM) festgelegt, klicken Sie auf eine Option in der Liste.

Anmerkung

  • Dieses Eigenschaftenfeld steht nur zur Verfügung, wenn Date (DT), Date (CY) oder Time (TM) für Benutzerdefinierter Datentyp festgelegt wurde.
Blocksatz Wählen Sie eine der folgenden Optionen aus:
  • Nach links. Richtet Daten in Dateien mit Feldern fester Breite am linken Rand aus, wenn die Daten die maximale Feldlänge unterschreiten. Außerdem werden Daten in Dateien mit Trennzeichen am linken Rand ausgerichtet, wenn die Datenmenge die minimalen Längenanforderungen nicht erfüllt.

  • Nach rechts. Richtet Daten in Dateien mit Feldern fester Breite am rechten Rand aus.

Anmerkung

  • Wird für Blocksatz kein Wert festgelegt, lautet der Standardwert Nach links.
Auffüllzeichen | Geben Sie ein Zeichen ein, um das Feld aufzufüllen. Als Auffüllzeichen können Sie jedes beliebige Zeichen verwenden, einschließlich eines Leerzeichens oder einer Null. Weitere Informationen finden Sie unter Auffüllzeichen.
Zeichen für Zeilenumbruch Geben Sie ein Zeichen ein, um Felddaten einzuschließen. Diese Eigenschaft ist nützlich, wenn die Felddaten ein Zeichen enthalten, das als Trennzeichenwert für den übergeordneten Knoten des Feldes verwendet wird. Die Felddaten könnten beispielsweise folgendermaßen lauten:

Braun,Michael,1231,ja

Falls Sie ein Komma als Trennzeichenwert für den Knoten, der das Feld enthält, ausgewählt haben, interpretiert der BizTalk-Editor das Komma nach "Braun" als Trennzeichen, auch wenn es sich dabei um einen Teil der Felddaten handelt. Sie können dieses Problem umgehen, indem Sie für die Zeichen für Zeilenumbruch-Eigenschaft einen Wert festlegen und dann die Felddaten in das Umbruchzeichen einschließen. Beispielsweise können Sie als Umbruchzeichen für das erste Feld doppelte Anführungszeichen verwenden und anschließend die Felddaten folgendermaßen eingeben:

"Braun,Michael",1231,ja

Das Komma zwischen den doppelten Anführungszeichen wird vom BizTalk-Editor als Teil der Felddaten und nicht als Trennzeichenwert interpretiert.

Anmerkungen

  • Enthalten die Felddaten Zeichen, die auch als Umbruchzeichen verwendet werden, müssen Sie diese Zeichen in ein weiteres Umbruchzeichen einschließen.

    Im folgenden Beispiel wurde das doppelte Anführungszeichen als Umbruchzeichen verwendet:

    "Braun,Michael ""Michi"""

    Nach der Analyse durch den BizTalk-Editor werden die Daten folgendermaßen angezeigt:

    Braun,Michael "Michi"

  • Enthalten die Felddaten in einer eingehenden Dokumentinstanz das Zeilenvorschubzeichen, auf das direkt das Wagenrücklaufzeichen folgt, schließen die entsprechenden Felddaten in der ausgehenden Dokumentinstanz nur das Zeilenvorschubzeichen ein, selbst wenn beide Zeichen von Umbruchzeichen eingeschlossen werden.
Minimallänge mit Auffüllzeichen Die minimale Länge eines Feldes in einer ausgehenden Dokumentinstanz, einschließlich Auffüllzeichen. Weitere Informationen zu Auffüllzeichen finden Sie unter Auffüllzeichen.

Anmerkungen

  • Diese Eigenschaft ist nur verfügbar, wenn das Auffüllzeichen für das Feld festgelegt wurde.

  • Wurde die Minimallänge-Eigenschaft auf der Registerkarte Deklaration für das Feld festgelegt, muss die Minimallänge mit Auffüllzeichen-Eigenschaft größer als oder gleich dem Wert der Minimallänge-Eigenschaft sein. Wurde die Minimallänge-Eigenschaft nicht festgelegt, muss die Minimallänge mit Auffüllzeichen-Eigenschaft größer als oder gleich 1 sein.

Standard: CUSTOM
Struktur-Eigenschaft: Getrennt

Wichtig

  • Die Werte für Zeichen für Zeilenumbruch, Auffüllzeichen, Escapewert und Trennzeichenwert für einen Datensatz sowie die ihm untergeordneten Felder schließen sich gegenseitig aus.

  • Sie sollten auf jeden Fall sicherstellen, dass das Umbruchzeichen und das Escapezeichen nicht identisch sind.

Registerkarte "Analysieren": Stammknoten- oder Datensatzeigenschaften

Eigenschaft | Wert
Struktur Wählen Sie die folgende Option für die Stammknoten-Eigenschaft aus:
  • Getrennt. Gibt an, dass der Stammknoten auf einer Dateistruktur mit Trennzeichen basiert. Individuelle Datensätze können auf Dateistrukturen mit Trennzeichen oder mit Feldern fester Breite basieren.

Wählen Sie eine der folgenden Optionen für Datensatz-Eigenschaften aus:

  • Getrennt. Gibt an, dass der Datensatz auf einer Dateistruktur mit Trennzeichen basiert. Einzelne abhängige Datensätze können auf Dateistrukturen mit Trennzeichen oder mit Feldern fester Breite basieren.

  • Feste Breite. Gibt an, dass der Datensatz auf einer Struktur mit Feldern fester Breite basiert. Datensätze mit Feldern fester Breite können keine untergeordneten Datensätze haben.

Anmerkungen

  • Damit ein Dokument sowohl Trennzeichen als auch Felder fester Breite enthalten kann, muss die Struktur-Eigenschaft des Stammknotens auf Getrennt festgelegt werden. Anschließend kann die Struktur-Eigenschaft für einzelne Datensätze je nach Bedarf auf Feste Breite oder Getrennt festgelegt werden.

  • Beim Wechseln von einer Struktur zu einer anderen wird ein Meldungsfeld angezeigt. Klicken Sie auf Ja, um die neue Struktur zu bestätigen. Unter Umständen werden einige neue Eigenschaften angezeigt, während bestimmte vorhandene Eigenschaften entfernt werden.

  • Wenn Sie mit der rechten Maustaste auf das Feld mit dem Wert für die Struktur-Eigenschaft eines Datensatzes mit Feldern fester Breite und dann auf Eigenschaft löschen klicken, interpretiert der BizTalk-Editor die Struktur des Datensatzes als Datensatz mit Trennzeichen. Unter Umständen werden einige neue Eigenschaften angezeigt, während bestimmte vorhandene Eigenschaften entfernt werden.

  • Wurde für die Standard-Eigenschaft eines Dokuments der Wert CUSTOM festgelegt, ist die Struktur-Eigenschaft für den Stammknoten und alle Datensätze standardmäßig leer. Wenn Sie die Struktur-Eigenschaft leer lassen, lautet der Wert Getrennt.
Quelltagbezeichner Der Name des Quelltagbezeichners. Dieser Tagname wird verwendet, um dem Datensatz Daten zuzuordnen.

Anmerkung

  • Für nicht auf XML basierende Datei, z. B. eine Flatfile, können Sie eine Quelltagbezeichner-Eigenschaft eingeben, um jeden beliebigen Tag in der Originaldatei zu identifizieren.

  • Bei der Quelltagbezeichner-Eigenschaft muss die Groß-/Kleinschreibung beachtet werden.
Feldreihenfolge Wählen Sie eine der folgenden Optionen aus:
  • Präfix. Ein Präfixtrennzeichen wird vor jeder Komponente und jedem Mitglied einer Komponente in einer Serie angezeigt. * ist beispielsweise das Trennzeichen: *a*a*b*c.

  • Postfix. Ein Postfixtrennzeichen wird nach jeder Komponente und jedem Mitglied einer Komponente in einer Serie angezeigt. * ist beispielsweise das Trennzeichen: a*a*b*c*.

  • Infix. Ein Infixtrennzeichen wird zwischen Komponenten und Mitgliedern von Komponenten in einer Serie angezeigt. * ist beispielsweise das Trennzeichen: a*a*b*c. Dies ist die grundlegende Feldreihenfolge für alle EDI-Dokumente (Electronic Data Interchange).

Anmerkung

  • Wird für die Feldreihenfolge kein Wert festgelegt, lautet der Standardwert Präfix.
Trennzeichentyp Wählen Sie eine der folgenden Optionen aus, um ein Trennzeichen für die untergeordneten Knoten direkt unterhalb des aktuellen Knotens festzulegen:
  • Zeichen. Ermöglicht das Festlegen eines Trennzeichenwertes auf der Registerkarte Analysieren. Wenn Sie Zeichen auswählen, müssen Sie einen Trennzeichenwert angeben.

  • Standard-Datensatztrennzeichen. Gibt an, dass als Trennzeichen der Wert für die Standard-Datensatztrennzeichen-Eigenschaft auf der Registerkarte Verweis für den Stammknoten verwendet werden soll.

  • Standardfeldtrennzeichen. Gibt an, dass als Trennzeichen der Wert für die Standardfeldtrennzeichen-Eigenschaft auf der Registerkarte Verweis für den Stammknoten verwendet werden soll.

  • Standardunterfeldtrennzeichen. Gibt an, dass als Trennzeichen der Wert für die Standardunterfeldtrennzeichen-Eigenschaft auf der Registerkarte Verweis für den Stammknoten verwendet werden soll.
Trennzeichenwert | Geben Sie einen Zeichenwert für das Trennzeichen ein, oder wählen Sie einen aus. Sie müssen auf der Registerkarte Analysieren für die Trennzeichentyp-Eigenschaft den Wert Zeichen festlegen, um einen Trennzeichenwert angeben zu können.
Escapetyp

(Wird auch als Freigabezeichen bezeichnet.)

 Wählen Sie eine der folgenden Optionen aus, um ein Escapezeichen für die untergeordneten Knoten direkt unterhalb des aktuellen Knotens festzulegen:
  • Zeichen. Ermöglicht das Festlegen eines Escapewertes auf der Registerkarte Analysieren. Wenn Sie Zeichen auswählen, müssen Sie einen Escapewert angeben.

  • Standardescapezeichen. Gibt an, dass als Escapezeichen der Wert für die Standardescapezeichen-Eigenschaft auf der Registerkarte Verweis für den Stammknoten verwendet werden soll.

Ein Escapezeichen ist nützlich, wenn die Felddaten ein Zeichen enthalten, das als Trennzeichen für den übergeordneten Knoten des Feldes verwendet wird. Die Felddaten könnten beispielsweise folgendermaßen lauten:

Braun,Michael,1231,ja

Falls Sie ein Komma als Trennzeichenwert für den Knoten, der das Feld enthält, ausgewählt haben, interpretiert der BizTalk-Editor das Komma nach "Braun" als Trennzeichen, auch wenn es sich dabei um einen Teil der Felddaten handelt. Sie können dieses Problem umgehen, indem Sie direkt vor das Trennzeichen, das Teil der Felddaten sein soll, ein Escapezeichen setzen. Wenn Sie beispielsweise den umgekehrten Schrägstrich als Escapezeichen festlegen, können Sie diesen direkt vor ein Trennzeichen setzen, wie im folgenden Beispiel dargestellt:

Braun\,Michael,1231,ja

Das Komma nach dem umgekehrten Schrägstrich wird vom BizTalk-Editor als Teil der Felddaten und nicht als Trennzeichen interpretiert.
Escapewert | Geben Sie einen Zeichenwert für das Escapezeichen ein, oder wählen Sie einen aus. Sie müssen auf der Registerkarte Analysieren für die Escapetyp-Eigenschaft den Wert Zeichen festlegen, um einen Escapezeichenwert angeben zu können.
Neue Zeile anfügen Wählen Sie eine der folgenden Optionen aus:
  • Ja. Gibt an, dass der Parser beim Erreichen des Datensatztrennzeichens in die nächste Zeile wechselt und beim nächsten Datensatz mit dieser Zeile beginnt.

  • Nein. Gibt an, dass der Parser beim Erreichen des Datensatztrennzeichens im nächsten Datensatz mit derselben Zeile fortfährt.

Anmerkung

  • Wird für Neue Zeile anfügen kein Wert eingegeben, lautet der Standardwert Nein.
Wagenrücklauf überspringen Wählen Sie eine der folgenden Optionen aus:
  • Ja. Teilt dem Parser mit, dass der Wagenrücklauf nach einem Trennzeichen übersprungen werden soll.

  • Nein. Teilt dem Parser mit, dass der Wagenrücklauf nach einem Trennzeichen nicht übersprungen werden soll.

Anmerkung

  • Wird für Wagenrücklauf überspringen kein Wert festgelegt, lautet der Standardwert Ja.
Zeilenvorschub überspringen Wählen Sie eine der folgenden Optionen aus:
  • Ja. Teilt dem Parser mit, dass der Zeilenvorschub nach einem Trennzeichen übersprungen werden soll.

  • Nein. Teilt dem Parser mit, dass der Zeilenvorschub nach einem Trennzeichen nicht übersprungen werden soll.

Anmerkung

  • Wird für Zeilenvorschub überspringen kein Wert festgelegt, lautet der Standardwert Ja.
Datensatzanzahl ignorieren Wählen Sie eine der folgenden Optionen aus:
  • Ja. Teilt dem Parser oder der Serialisierungskomponente mit, dass dieser Datensatz beim Zählen der Datensätze in der Spezifikation nicht berücksichtigt werden soll.

  • Nein. Teilt dem Parser oder der Serialisierungskomponente mit, dass dieser Datensatz beim Zählen der Datensätze in der Spezifikation berücksichtigt werden soll.

Anmerkungen

  • Stimmt die Anzahl der Datensätze in einer an BizTalk Server gesendeten Dokumentinstanz nicht mit der berechneten Anzahl der Datensätze in der Spezifikation überein, tritt ein Analysefehler auf. Weitere Informationen finden Sie unter Analysefehler.

  • Wird für Datensatzanzahl ignorieren kein Wert festgelegt, lautet der Standardwert Ja.

Registerkarte "Analysieren": Feldeigenschaften

Eigenschaft | Wert
Benutzerdefinierter Datentyp Wählen Sie eine der folgenden Optionen aus:
  • String (AN). AN steht für alphanumerische Felder.

  • Binary Hexadecimal (B). B steht für binäre Felder.

  • Date (CY). CY steht für vierstellige Datumsfelder.

  • Number (D0-D4). D0 bis D4 (einschließlich) stehen für Dezimalfelder. Die einstellige Zahl zeigt die Anzahl der Stellen nach dem Dezimaltrennzeichen an.

  • Date (DT). DT steht für Datumsfelder.

  • String (ID). ID steht für Identifikationsfelder.

  • Number (N). N steht für Felder mit ganzen Zahlen.

  • Number (N0-9). N0 bis N9 (einschließlich) stehen für implizite Dezimalfelder (das Dezimaltrennzeichen wird in den Daten nicht angezeigt). Die einstellige Zahl zeigt die Anzahl der Stellen nach dem Dezimaltrennzeichen an.

  • Number (R). R steht für Felder mit reellen Zahlen.

  • Number (R0-R9). R0 bis R9 (einschließlich) stehen für Felder mit reellen Zahlen. Die einstellige Zahl zeigt die Anzahl der Stellen nach dem Dezimaltrennzeichen an.

  • Time (TM). TM steht für Zeitfelder.

Wichtig

  • Wenn Sie für Benutzerdefinierter Datentyp einen Wert festlegen, wird der Wert im Feld Datentyp auf der Registerkarte Deklaration automatisch geändert, so dass er mit der Auswahl für Benutzerdefinierter Datentyp übereinstimmt. Wenn Sie beispielsweise Benutzerdefinierter Datentyp auf der Registerkarte Analysieren in Date (CY) ändern, wird unter Datentyp auf der Registerkarte Deklaration automatisch Date angezeigt. Bei Angabe eines Wertes auf der Registerkarte Deklaration im Feld Datentyp wird der Wert im Feld Benutzerdefinierter Datentyp gelöscht.

Anmerkung

  • Wurde für die Benutzerdefinierter Datentyp-Eigenschaft der Wert Date (DT), Date (CY) oder Time (TM) angegeben, muss für die Benutzerdefiniertes Datum/Zeitformat-Eigenschaft ebenfalls ein Wert festgelegt werden.
Benutzerdefiniertes Datum/Zeitformat Wurde für die Benutzerdefinierter Datentyp-Eigenschaft der Wert Date (DT), Date (CY) oder Time (TM) festgelegt, klicken Sie auf eine Option in der Liste.

Anmerkung

  • Dieses Eigenschaftenfeld steht nur zur Verfügung, wenn Date (DT), Date (CY) oder Time (TM) für Benutzerdefinierter Datentyp festgelegt wurde.
Blocksatz Wählen Sie eine der folgenden Optionen aus:
  • Nach links. Richtet Daten in den Datei mit Feldern fester Breite am linken Rand aus, wenn die Daten die maximale Feldlänge unterschreiten. Außerdem werden Daten in Dateien mit Trennzeichen am linken Rand ausgerichtet, wenn die Datenmenge die minimalen Längenanforderungen nicht erfüllt.

  • Nach rechts. Richtet Daten in Dateien mit Feldern fester Breite am rechten Rand aus.

Anmerkungen

  • Wird für Blocksatz kein Wert ausgewählt, erfolgt standardmäßig die Ausrichtung am linken Rand.

  • Wird für Blocksatz kein Wert festgelegt, lautet der Standardwert Nach links.
Auffüllzeichen | Geben Sie ein Zeichen ein, um das Feld aufzufüllen, oder wählen Sie ein Zeichen aus. Als Auffüllzeichen können Sie jedes beliebige Zeichen verwenden, einschließlich eines Leerzeichens oder einer Null. Weitere Informationen finden Sie unter Auffüllzeichen.
Zeichen für Zeilenumbruch Geben Sie ein Zeichen ein, um Felddaten einzuschließen. Diese Eigenschaft ist nützlich, wenn die Felddaten ein Zeichen enthalten, das als Trennzeichenwert für den übergeordneten Knoten des Feldes verwendet wird. Die Felddaten könnten beispielsweise folgendermaßen lauten:

Braun,Michael,1231,ja

Falls Sie ein Komma als Trennzeichenwert für den Knoten, der das Feld enthält, ausgewählt haben, interpretiert der BizTalk-Editor das Komma nach "Braun" als Trennzeichen, auch wenn es sich dabei um einen Teil der Felddaten handelt. Sie können dieses Problem umgehen, indem Sie für die Zeichen für Zeilenumbruch-Eigenschaft einen Wert festlegen und dann die Felddaten in das Umbruchzeichen einschließen. Beispielsweise können Sie als Umbruchzeichen für das erste Feld doppelte Anführungszeichen festlegen und anschließend die Felddaten folgendermaßen eingeben:

"Braun,Michael",1231,ja

Das Komma zwischen den doppelten Anführungszeichen wird vom BizTalk-Editor als Teil der Felddaten und nicht als Trennzeichenwert interpretiert.

Anmerkungen

  • Enthalten die Felddaten Zeichen, die auch als Umbruchzeichen verwendet werden, müssen Sie diese Zeichen in ein weiteres Umbruchzeichen einschließen.

    Im folgenden Beispiel wurde das doppelte Anführungszeichen als Umbruchzeichen verwendet:

    "Braun,Michael ""Michi"""

    Nach der Analyse durch den BizTalk-Editor werden die Daten folgendermaßen angezeigt:

    Braun,Michael "Michi".

  • Enthalten die Felddaten in einer eingehenden Dokumentinstanz das Zeilenvorschubzeichen, auf das direkt das Wagenrücklaufzeichen folgt, schließen die entsprechenden Felddaten in der ausgehenden Dokumentinstanz nur das Zeilenvorschubzeichen ein, selbst wenn beide Zeichen von Umbruchzeichen eingeschlossen werden.
Minimallänge mit Auffüllzeichen Die minimale Länge eines Feldes in einer ausgehenden Dokumentinstanz, einschließlich Auffüllzeichen. Weitere Informationen finden Sie unter Auffüllzeichen.

Anmerkungen

  • Diese Eigenschaft kann für ein Feld nur festgelegt werden, wenn das Auffüllzeichen für dieses Feld festgelegt wurde.

  • Wurde die Minimallänge-Eigenschaft auf der Registerkarte Deklaration für das Feld festgelegt, muss die Eigenschaft Minimallänge mit Auffüllzeichen größer als oder gleich dem Wert der Minimallänge-Eigenschaft sein. Wurde die Minimallänge-Eigenschaft nicht festgelegt, muss die Minimallänge mit Auffüllzeichen-Eigenschaft größer als oder gleich 1 sein.

Standard: CUSTOM
Struktur-Eigenschaft: Feste Breite

Registerkarte "Analysieren": Stammknoten- oder Datensatzeigenschaften

Eigenschaft | Wert
Struktur Wählen Sie die folgende Option für die Stammknoten-Eigenschaft aus:
  • Feste Breite. Gibt an, dass der Stammknoten auf einer Struktur für Dateien mit Feldern fester Breite basiert.

Anmerkungen

  • Ein Dokument mit einem Stammknoten mit Feldern fester Breite kann keine Datensätze haben.

  • Wenn Sie mit der rechten Maustaste auf das Feld mit dem Wert für die Struktur-Eigenschaft eines Stammknotens mit Feldern fester Breite und dann auf Eigenschaft löschen klicken, interpretiert der BizTalk-Editor die Struktur des Stammknotens als Stammknoten mit Trennzeichen. Unter Umständen werden einige neue Eigenschaften angezeigt, während bestimmte vorhandene Eigenschaften entfernt werden.

  • Wurde für die Standard-Eigenschaft eines Dokuments der Wert CUSTOM festgelegt, ist die Struktur-Eigenschaft für den Stammknoten und alle Datensätze standardmäßig leer. Wenn Sie die Struktur-Eigenschaft leer lassen, lautet der Wert Getrennt.
Quelltagbezeichner Der Name des Quelltagbezeichners. Dieser Tagname wird verwendet, um dem Datensatz Daten zuzuordnen.

Anmerkungen

  • Für eine nicht auf XML basierende Datei, z. B. eine Flatfile, können Sie eine Quelltagbezeichner-Eigenschaft eingeben, um jedes beliebige Tag in der Originaldatei zu identifizieren.

  • Bei der Quelltagbezeichner-Eigenschaft muss die Groß-/Kleinschreibung beachtet werden.
Quelltagposition | Eine Zahl, die auf die Anfangsposition des Tags im Datensatz mit Feldern fester Breite verweist.
Neue Zeile anfügen Wählen Sie eine der folgenden Optionen aus:
  • Ja. Gibt an, dass der Parser beim Erreichen des Datensatztrennzeichens in die nächste Zeile wechselt und beim nächsten Datensatz mit dieser Zeile beginnt.

  • Nein. Gibt an, dass der Parser beim Erreichen des Datensatztrennzeichens im nächsten Datensatz mit derselben Zeile fortfährt.

Anmerkung

  • Wird für Neue Zeile anfügen kein Wert eingegeben, lautet der Standardwert Nein.
Wagenrücklauf überspringen Wählen Sie eine der folgenden Optionen aus:
  • Ja. Teilt dem Parser mit, dass der Wagenrücklauf nach einem Trennzeichen übersprungen werden soll.

  • Nein. Teilt dem Parser mit, dass der Wagenrücklauf nach einem Trennzeichen nicht übersprungen werden soll.

Anmerkung

  • Wird für Wagenrücklauf überspringen kein Wert festgelegt, lautet der Standardwert Ja.
Zeilenvorschub überspringen Wählen Sie eine der folgenden Optionen aus:
  • Ja. Teilt dem Parser mit, dass der Zeilenvorschub nach einem Trennzeichen übersprungen werden soll.

  • Nein. Teilt dem Parser mit, dass der Zeilenvorschub nach einem Trennzeichen nicht übersprungen werden soll.

Anmerkung

  • Wird für Zeilenvorschub überspringen kein Wert festgelegt, lautet der Standardwert Ja.
Datensatzanzahl ignorieren Wählen Sie eine der folgenden Optionen aus:
  • Ja. Teilt dem Parser oder der Serialisierungskomponente mit, dass dieser Datensatz beim Zählen der Datensätze in der Spezifikation nicht berücksichtigt werden soll.

  • Nein. Teilt dem Parser oder der Serialisierungskomponente mit, dass dieser Datensatz beim Zählen der Datensätze in der Spezifikation berücksichtigt werden soll.

Anmerkungen

  • Stimmt die Anzahl der Datensätze in einer an BizTalk Server gesendeten Dokumentinstanz nicht mit der berechneten Anzahl der Datensätze in der Spezifikation überein, tritt ein Analysefehler auf. Weitere Informationen finden Sie unter Analysefehler.

  • Wird für Datensatzanzahl ignorieren kein Wert festgelegt, lautet der Standardwert Ja.

Registerkarte "Analysieren": Feldeigenschaften

Eigenschaft | Wert
Benutzerdefinierter Datentyp Wählen Sie eine der folgenden Optionen aus:
  • String (AN). AN steht für alphanumerische Felder.

  • Binary Hexadecimal (B). B steht für binäre Felder.

  • Date (CY). CY steht für vierstellige Datumsfelder.

  • Number (D0-D4). D0 bis D4 (einschließlich) stehen für Dezimalfelder. Die einstellige Zahl zeigt die Anzahl der Stellen nach dem Dezimaltrennzeichen an.

  • Date (DT). DT steht für Datumsfelder.

  • String (ID). ID steht für Identifikationsfelder.

  • Number (N). N steht für Felder mit ganzen Zahlen.

  • Number (N0-9). N0 bis N9 (einschließlich) stehen für implizite Dezimalfelder (das Dezimaltrennzeichen wird in den Daten nicht angezeigt). Die einstellige Zahl zeigt die Anzahl der Stellen nach dem Dezimaltrennzeichen an.

  • Number (R). R steht für Felder mit reellen Zahlen.

  • Number (R0-R9). R0 bis R9 (einschließlich) stehen für Felder mit reellen Zahlen. Die einstellige Zahl zeigt die Anzahl der Stellen nach dem Dezimaltrennzeichen an.

  • Time (TM). TM steht für Zeitfelder.

Wichtig

  • Wenn Sie für Benutzerdefinierter Datentyp einen Wert festlegen, wird der Wert im Feld Datentyp auf der Registerkarte Deklaration automatisch geändert, so dass er mit der Auswahl für Benutzerdefinierter Datentyp übereinstimmt. Wenn Sie beispielsweise Benutzerdefinierter Datentyp auf der Registerkarte Analysieren in Date (CY) ändern, wird unter Datentyp auf der Registerkarte Deklaration automatisch Date angezeigt. Bei Angabe eines Wertes im Feld Datentyp auf der Registerkarte Deklaration wird der Wert im Feld Benutzerdefinierter Datentyp gelöscht.

Anmerkung

  • Wurde für die Benutzerdefinierter Datentyp-Eigenschaft der Wert Date (DT), Date (CY) oder Time (TM) angegeben, muss für die Benutzerdefiniertes Datum/Zeitformat-Eigenschaft ebenfalls ein Wert festgelegt werden.
Benutzerdefiniertes Datum/Zeitformat Wurde für die Benutzerdefinierter Datentyp-Eigenschaft der Wert Date (DT), Date (CY) oder Time (TM) festgelegt, klicken Sie auf eine Option in der Liste.

Anmerkung

  • Dieses Eigenschaftenfeld ist nur aktiv, wenn Date (DT), Date (CY) oder Time (TM) für Benutzerdefinierter Datentyp festgelegt wurde.
Blocksatz Wählen Sie eine der folgenden Optionen aus:
  • Nach links. Richtet Daten in Dateien mit Feldern fester Breite am linken Rand aus, wenn die Daten die maximale Feldlänge unterschreiten. Außerdem werden Daten in Dateien mit Trennzeichen am linken Rand ausgerichtet, wenn die Datenmenge die minimalen Längenanforderungen nicht erfüllt.

  • Nach rechts. Richtet Daten in Dateien mit Feldern fester Breite am rechten Rand aus.

Anmerkung

  • Wird für Blocksatz kein Wert festgelegt, lautet der Standardwert Nach links.
Auffüllzeichen | Geben Sie ein Zeichen ein, das zum Auffüllen des Feldes verwendet werden soll. Als Auffüllzeichen können Sie jedes beliebige Zeichen verwenden, einschließlich eines Leerzeichens oder einer Null. Weitere Informationen finden Sie unter Auffüllzeichen.

Verwandtes Thema

Auffüllzeichen


Deklarieren von Namespaces

  1. Klicken Sie auf einen beliebigen Knoten in der Spezifikationsstruktur.

  2. Klicken Sie auf die Registerkarte Namespace.

  3. Klicken Sie mit der rechten Maustaste auf das erste leere Feld in der Spalte Präfix, und klicken Sie dann auf Hinzufügen.

  4. Geben Sie ein Präfix für den Namespace ein, und drücken Sie die EINGABETASTE.

  5. Doppelklicken Sie rechts daneben auf das Feld in der Spalte Uniform Resource Name.

  6. Geben Sie einen Uniform Resource Name ein, und drücken Sie die EINGABETASTE.

Wichtig

  • Der BizTalk-Editor überprüft den für einen Namespace eingegebenen Uniform Resource Name nicht.

Weitere Informationen zu Namespaces finden Sie unter Namespacedeklarationen.

Verwandte Themen

Hinzufügen von benutzerdefinierten Anmerkungen

Löschen von benutzerdefinierten Anmerkungen

Bearbeiten von benutzerdefinierten Anmerkungen

Namespacedeklarationen


Hinzufügen von benutzerdefinierten Anmerkungen

  1. Klicken Sie in der Spezifikationsstruktur auf den Stammknoten, den Datensatz oder das Feld, für den bzw. das Sie eine benutzerdefinierte Anmerkung hinzufügen möchten.

    Anmerkung

    • Auf der Registerkarte Verweis können Sie keine benutzerdefinierte Anmerkung für den Stammknoten hinzufügen.
  2. Klicken Sie auf die Registerkarte Deklaration oder Verweis, je nachdem, wo Sie die benutzerdefinierte Anmerkung hinzufügen möchten.

  3. Klicken Sie mit der rechten Maustaste auf das erste leere Feld in der Spalte Eigenschaft, und klicken Sie dann auf Hinzufügen.

    Der Bearbeitungsmodus wird im Feld Eigenschaft aktiviert.

  4. Geben Sie ein Präfix/Name-Paar (getrennt durch einen Doppelpunkt) ein, und drücken Sie die EINGABETASTE.

    Oder

    Klicken Sie auf eine der benutzerdefinierten Anmerkungen in der Liste, und drücken Sie die EINGABETASTE.

  5. Doppelklicken Sie rechts daneben auf das leere Feld in der Spalte Wert.

  6. Geben Sie den Wert für die benutzerdefinierte Anmerkung ein, und drücken Sie die EINGABETASTE.

Wichtig

  • Damit die Spezifikation erfolgreich kompiliert werden kann, muss das in Schritt 4 verwendete Namespacepräfix in der Spezifikation deklariert werden. Weitere Informationen finden Sie unter Deklarieren von Namespaces.

Verwandte Themen

Hinzufügen von SQL-Anmerkungen

Deklarieren von Namespaces

Löschen von benutzerdefinierten Anmerkungen

Bearbeiten von benutzerdefinierten Anmerkungen

Namespacedeklarationen


Bearbeiten von benutzerdefinierten Anmerkungen

  1. Klicken Sie in der Spezifikationsstruktur auf den Knoten, der die benutzerdefinierte Anmerkung enthält, die Sie bearbeiten möchten.

  2. Klicken Sie auf die Registerkarte (Deklaration oder Verweis), die auf die benutzerdefinierte Anmerkung verweist, die Sie bearbeiten möchten.

  3. Doppelklicken Sie auf das Feld Eigenschaft der benutzerdefinierten Anmerkung, bearbeiten Sie das Feld, und drücken Sie dann die EINGABETASTE.

  4. Doppelklicken Sie auf das Feld Wert der benutzerdefinierten Anmerkung, bearbeiten Sie das Feld, und drücken Sie die EINGABETASTE.

Verwandte Themen

Hinzufügen von SQL-Anmerkungen

Deklarieren von Namespaces

Namespacedeklarationen


Löschen von benutzerdefinierten Anmerkungen

  1. Klicken Sie in der Spezifikationsstruktur auf den Knoten, der die benutzerdefinierte Anmerkung enthält, die Sie löschen möchten.

  2. Klicken Sie auf die Registerkarte (Deklaration oder Verweis), die auf die benutzerdefinierte Anmerkung verweist, die Sie löschen möchten.

  3. Klicken Sie mit der rechten Maustaste auf die benutzerdefinierte Anmerkung, und klicken Sie dann auf Löschen.

  4. Klicken Sie auf Ja, um die Änderung zu bestätigen.

Verwandte Themen

Hinzufügen von benutzerdefinierten Anmerkungen

Hinzufügen von SQL-Anmerkungen

Deklarieren von Namespaces

Bearbeiten von benutzerdefinierten Anmerkungen

Namespacedeklarationen


Festlegen von Wörterbucheigenschaften

  1. Klicken Sie in der Spezifikationsstruktur auf den Stammknoten, den Datensatz oder das Feld, für den bzw. das Sie eine Eigenschaft festlegen möchten, und klicken Sie dann auf die Registerkarte Wörterbuch.

  2. Aktivieren Sie in der Spalte Eigenschaft das Kontrollkästchen mit dem Wert, den Sie mit dem Feld verknüpfen möchten.

Die Registerkarte Wörterbuch enthält die in den folgenden Tabellen beschriebenen Eigenschaften. Wörterbucheigenschaften können nur für Spezifikationen festgelegt werden, für welche die Standard-Eigenschaft auf der Registerkarte Verweis auf XML oder CUSTOM festgelegt wurde.

Registerkarte "Wörterbuch": Stammknoten- oder Datensatzeigenschaften

Eigenschaft | Knotenpfad
Dokumentcontainerknoten | In einem Umschlagschema verweist der Dokumentknoten auf den Datensatz, der das Dokument enthält.

Anmerkung

  • In einer Flatfilespezifikation (mit dem Wert CUSTOM für die Standard-Eigenschaft auf der Registerkarte Verweis), die mithilfe des Flatfileparsers von BizTalk Server analysiert wurde, hat das Aktivieren oder Deaktivieren des Kontrollkästchens für die Wörterbucheigenschaft Dokumentcontainerknoten keine Auswirkungen. Diese Wörterbucheigenschaft steht zur Verfügung, falls Sie eine benutzerdefinierte Spezifikation und einen benutzerdefinierten Parser erstellen möchten, die die Wörterbucheigenschaft Dokumentcontainerknoten verwenden.

Registerkarte "Wörterbuch": Feldeigenschaften

Eigenschaft | Knotenpfad
Dokumentname | Zeigt den Pfad für das Feld einer Dokumentinstanz an, das den Dokumentnamen enthält.
Quelltyp | Zeigt den Pfad für das Feld einer Dokumentinstanz an, das den Quelltyp enthält.
Quellwert | Zeigt den Pfad für das Feld einer Dokumentinstanz an, das den Quellwert enthält.
Zieltyp | Zeigt den Pfad für das Feld einer Dokumentinstanz an, das den Zieltyp enthält.
Zielwert | Zeigt den Pfad für das Feld einer Dokumentinstanz an, das den Zielwert enthält.

Anmerkungen

  • Beim Analysieren einer Spezifikation verwendet der Parser Informationen auf der Registerkarte Wörterbuch, um einen Kanal zu finden. Sie können einen Kanal mithilfe des BizTalk-Messaging-Managers erstellen. Weitere Informationen zu Kanälen und dem BizTalk-Messaging-Manager finden Sie unter Grundlegendes zu Kanälen.

  • Falls Sie eine Spezifikation verwenden, um Dokumente zu definieren, die an einen offenen Messagingport gesendet werden, müssen Sie auf der Registerkarte Wörterbuch den Zielwert für das Feld auswählen, das die Ziel- und Transportinformationen enthält. Bei Verwendung von Versendungsparametern werden die Zielinformationen in einem Dokument überschrieben. Weitere Informationen zum Versenden von Dokumenten finden Sie unter Submitting.

  • Sie können Wörterbucheigenschaften auch festlegen, indem Sie mit der rechten Maustaste auf ein Feld in der Spalte Eigenschaft und dann auf Routinginformationen festlegen klicken.

Verwandte Themen

Hinzufügen einer benutzerdefinierten Wörterbucheigenschaft

Löschen einer Wörterbucheigenschaft

Löschen einer benutzerdefinierten Wörterbucheigenschaft

Umbenennen einer benutzerdefinierten Wörterbucheigenschaft

Submitting

Grundlegendes zu Messagingports


Hinzufügen einer benutzerdefinierten Wörterbucheigenschaft

  1. Klicken Sie in der Spezifikationsstruktur auf das Feld, für das Sie eine benutzerdefinierte Wörterbucheigenschaft hinzufügen möchten.

  2. Klicken Sie auf die Registerkarte Wörterbuch.

  3. Doppelklicken Sie auf das erste leere Feld in der Spalte Eigenschaft.

  4. Geben Sie einen Namen für die Eigenschaft ein, und drücken Sie die EINGABETASTE.

Anmerkungen

  • Verwenden Sie für jede benutzerdefinierte Eigenschaft, die Sie erstellen, einen eindeutigen Namen.

  • Die Standard-Eigenschaft (für den Stammknoten) darf nicht auf X12 oder EDIFACT festgelegt werden.

Verwandte Themen

Löschen einer Wörterbucheigenschaft

Löschen einer benutzerdefinierten Wörterbucheigenschaft

Umbenennen einer benutzerdefinierten Wörterbucheigenschaft

Festlegen von Wörterbucheigenschaften


Umbenennen einer benutzerdefinierten Wörterbucheigenschaft

  1. Klicken Sie auf die Registerkarte Wörterbuch.

  2. Klicken Sie mit der rechten Maustaste auf die benutzerdefinierte Eigenschaft, die Sie umbenennen möchten, und klicken Sie dann auf Umbenennen.

  3. Geben Sie einen Namen für die Eigenschaft ein, und drücken Sie die EINGABETASTE.

Anmerkung

  • Verwenden Sie für jede benutzerdefinierte Eigenschaft, die Sie erstellen, einen eindeutigen Namen.

Verwandte Themen

Hinzufügen einer benutzerdefinierten Wörterbucheigenschaft

Löschen einer Wörterbucheigenschaft

Löschen einer benutzerdefinierten Wörterbucheigenschaft

Festlegen von Wörterbucheigenschaften


Löschen einer Wörterbucheigenschaft

  1. Klicken Sie in der Spezifikationsstruktur auf den Knoten, für den Sie eine Wörterbucheigenschaft löschen möchten, und klicken Sie auf die Registerkarte Wörterbuch.

  2. Deaktivieren Sie in der Spalte Eigenschaft das Kontrollkästchen für den Wert, dessen Verknüpfung mit dem Feld Sie aufheben möchten.

Anmerkungen

  • Sie können Werte für Wörterbucheigenschaften auch löschen, indem Sie mit der rechten Maustaste auf ein Feld in der Spalte Eigenschaft und dann auf Routinginformationen löschen klicken.

  • Indem Sie eine Wörterbucheigenschaft in einem Knoten löschen, entfernen Sie die Routinginformationen.

Verwandte Themen

Hinzufügen einer benutzerdefinierten Wörterbucheigenschaft

Löschen einer benutzerdefinierten Wörterbucheigenschaft

Umbenennen einer benutzerdefinierten Wörterbucheigenschaft

Festlegen von Deklarationseigenschaften


Löschen einer benutzerdefinierten Wörterbucheigenschaft

  1. Klicken Sie auf die Registerkarte Wörterbuch.

  2. Klicken Sie mit der rechten Maustaste auf die benutzerdefinierte Eigenschaft, die Sie löschen möchten, und klicken Sie dann auf Löschen.

  3. Klicken Sie auf Ja, um die Änderung zu bestätigen.

Verwandte Themen

Hinzufügen einer benutzerdefinierten Wörterbucheigenschaft

Löschen einer Wörterbucheigenschaft

Umbenennen einer benutzerdefinierten Wörterbucheigenschaft

Festlegen von Wörterbucheigenschaften


Auswählen von Codes

  1. Klicken Sie auf ein Feld in einer Spezifikationsstruktur.

  2. Klicken Sie auf die Registerkarte Codeliste.

  3. Aktivieren Sie in der Spalte Wert das Kontrollkästchen neben dem Code, den Sie verwenden möchten.

Anmerkungen

  • Codelisten stehen nur für Spezifikationen zur Verfügung, die auf X12 oder EDIFACT basieren. Allerdings sind nicht alle Felder in einer auf X12 oder EDIFACT basierenden Spezifikation mit Codes verknüpft. Auf der Registerkarte Codeliste wird eine vollständige Liste sämtlicher Codes für ein bestimmtes Feld angezeigt. Codes sind mit einem Feld verknüpft, wenn das Kontrollkästchen im Feld Wert neben dem Code aktiviert ist. Eine Beschreibung des Codes wird im Feld Beschreibung angezeigt.

  • Wenn Sie auf der Registerkarte Codeliste einen Code mit einem Feld verknüpfen, wird diese Verknüpfung auch auf der Registerkarte Deklaration angezeigt. Im Feld Datentyp auf der Registerkarte Deklaration wird standardmäßig Enumeration angezeigt, und das Feld Datentypwerte enthält die Codelistennummern, die Sie auf der Registerkarte Codeliste ausgewählt haben. Wenn Sie den Inhalt des Feldes Datentyp auf der Registerkarte Deklaration löschen, sind auf der Registerkarte Codeliste keine Codes ausgewählt. Weitere Informationen finden Sie unter Löschen einer Eigenschaft für ein beliebiges Feld in der Spalte "Wert".

  • Aktivieren Sie das Kontrollkästchen neben einem Code, drücken Sie die UMSCHALTTASTE, und aktivieren Sie das Kontrollkästchen neben einem zweiten Code, um mehrere Codes auszuwählen. Alle Codes zwischen dem ersten und dem zweiten Code werden ausgewählt.

  • Vereinzelt werden doppelte Codewerte auf der Registerkarte Codeliste angezeigt. Abhängig von dem Dokumenttyp, mit dem der Codewert verknüpft ist, haben diese doppelten Codewerte unterschiedliche Beschreibungen. Beim Überprüfen einer Dokumentinstanz muss immer nur ein Codewert ausgewählt werden. Es ist jedoch möglich, aus Versehen mehrere Codewerte auszuwählen. Die folgende Liste enthält einige Regeln zu doppelten Codelisten:
    • Bei Auswahl des obersten Codewertes in einem Satz doppelter Codewerte wird nur dieser Codewert ausgewählt.

    • Bei Auswahl eines Codewertes, der nicht der oberste Codewert in einem Satz doppelter Codewerte ist, wird dieser Codewert und gleichzeitig automatisch der oberste Codewert ausgewählt.

    • Der oberste Codewert in einem Satz doppelter Codewerte kann nicht gelöscht werden, während andere Codewerte in diesem Satz ausgewählt sind.

Verwandte Themen

Löschen einer Eigenschaft für ein beliebiges Feld in der Spalte "Wert"

Codes löschen

Codelistenwerte und Beschreibungen


Codes löschen

  1. Klicken Sie auf ein Feld in der Spezifikationsstruktur.

  2. Klicken Sie auf die Registerkarte Codeliste.

  3. Deaktivieren Sie in der Spalte Wert das Kontrollkästchen neben dem Code, den Sie löschen möchten.

Anmerkungen

  • Codelisten stehen nur für Spezifikationen zur Verfügung, die auf X12 oder EDIFACT basieren. Allerdings sind nicht alle Felder in einer auf X12 oder EDIFACT basierenden Spezifikation mit Codes verknüpft. Auf der Registerkarte Codeliste wird eine vollständige Liste sämtlicher Codes für ein bestimmtes Feld angezeigt. Codes sind mit einem Feld verknüpft, wenn das Kontrollkästchen im Feld Wert neben dem Code aktiviert ist. Eine Beschreibung des Codes wird im Feld Beschreibung angezeigt.

  • Vereinzelt werden doppelte Codewerte auf der Registerkarte Codeliste angezeigt. Abhängig von dem Dokumenttyp, mit dem der Codewert verknüpft ist, haben diese doppelten Codewerte unterschiedliche Beschreibungen. Bei der Überprüfung einer Dokumentinstanz muss immer nur ein Codewert ausgewählt werden. Es ist jedoch möglich, aus Versehen mehrere Codewerte auszuwählen. Die folgende Liste enthält einige Regeln zu doppelten Codelisten:
    • Bei Auswahl des obersten Codewertes in einem Satz doppelter Codewerte wird nur dieser Codewert ausgewählt.

    • Bei Auswahl eines Codewertes, der nicht der oberste Codewert in einem Satz doppelter Codewerte ist, wird dieser Codewert und gleichzeitig automatisch der oberste Codewert ausgewählt.

    • Der oberste Codewert in einem Satz doppelter Codewerte kann nicht gelöscht werden, während andere Codewerte in diesem Satz ausgewählt sind.

Verwandte Themen

Codelistenwerte und Beschreibungen

Auswählen von Codes


Löschen einer Eigenschaft für ein beliebiges Feld in der Spalte "Wert"

  1. Klicken Sie auf die Registerkarte mit der Eigenschaft, die Sie löschen möchten.

  2. Klicken Sie mit der rechten Maustaste auf das Feld in der Spalte Wert, und klicken Sie auf Eigenschaft löschen.


Automatisches Berechnen von Feldpositionen

  1. Wählen Sie ein Feld in einem Datensatz mit Feldern fester Breite aus.

  2. Doppelklicken Sie auf das Feld Wert in der Zeile Datentyp.

  3. Klicken Sie in der Liste Datentyp auf einen Wert.

    Anmerkung

    • Sie müssen einen der folgenden Datentyp-Werte auswählen, um einen Wert für die Maximallänge-Eigenschaft festlegen zu können (Schritt 4 und 5): String, Number, Binary (base64) oder Binary (hex).
  4. Doppelklicken Sie auf das Feld Wert in der Zeile Maximallänge.

  5. Geben Sie im Feld für die Maximallänge einen Wert ein, und drücken Sie die EINGABETASTE.

  6. Wiederholen Sie die Schritte 1 bis 5 für jedes Feld in dem Datensatz.

  7. Klicken Sie mit der rechten Maustaste auf den Datensatz, und klicken Sie dann auf Feldpositionen berechnen.

    Die folgende Warnung wird angezeigt:

    Durch diese Aktion werden die Eigenschaften Anfangsposition und Endposition für die Felder im ausgewählten Datensatz geändert. Möchten Sie den Vorgang fortsetzen?

  8. Klicken Sie auf Ja.

    Die Anfangs- und Endpositionen der Felder im Datensatz werden berechnet. Weitere Informationen finden Sie unter Berechnen von Feldpositionen.

Verwandtes Thema

Berechnen von Feldpositionen


Bearbeiten von Notizen und Syntaxregeln

Im Dialogfeld Knoteneigenschaften können Sie die folgenden Aufgaben durchführen:

  • Lesen und Bearbeiten von Notizen für Felder und Datensätze.

  • Lesen von Syntaxregeln für Datensätze.

Führen Sie die folgenden Schritte aus, um das Dialogfeld Knoteneigenschaften anzuzeigen:

  1. Klicken Sie in der Spezifikationsstruktur mit der rechten Maustaste auf einen Datensatz oder ein Feld, und klicken Sie auf Eigenschaften.

    Standardmäßig wird die Registerkarte Notizen angezeigt.

  2. Klicken Sie auf die Registerkarte Syntaxregeln, um Syntaxregeln für einen Datensatz anzuzeigen.

Anmerkung

  • Syntaxregeln werden nur auf Datensätze angewendet.

Weitere Informationen zum Verwenden dieses Dialogfeldes finden Sie unter den folgenden Themen:

  • Eingeben von Datensatznotizen

  • Anzeigen von Syntaxregeln

  • Eingeben von Feldnotizen


Eingeben von Datensatznotizen

Weitere Informationen zum Öffnen des Dialogfeldes Knoteneigenschaften finden Sie unter Bearbeiten von Notizen und Syntaxregeln.

Sie können Notizen verwenden, um sämtliche Informationen aufzuzeichnen, die für den entsprechenden Datensatz relevant sind. Dabei kann es sich beispielsweise um den Zweck des Datensatzes oder um den Grund für seine Erstellung handeln.

  • Geben Sie den Text im Dialogfeld Knoteneigenschaften ein, und klicken Sie auf OK, um Notizen zu erstellen.

Anmerkungen

  • Zu dem Stammknoten können keine Notizen hinzugefügt werden.

  • Notizen können nur druckbare Zeichen enthalten.

Verwandte Themen

Eingeben von Feldnotizen

Anzeigen von Syntaxregeln


Anzeigen von Syntaxregeln

Weitere Informationen zum Öffnen des Dialogfeldes Knoteneigenschaften finden Sie unter Bearbeiten von Notizen und Syntaxregeln.

Syntaxregeln enthalten Informationen zur Organisation der Spezifikationsstruktur. Sie werden nur für Spezifikationen festgelegt, die auf dem X12-Standard basieren.

Anmerkung

  • Syntaxregeln werden nur auf Datensätze angewendet.

Verwandte Themen

Eingeben von Feldnotizen

Eingeben von Datensatznotizen


Eingeben von Feldnotizen

Weitere Informationen zum Öffnen des Dialogfeldes Knoteneigenschaften finden Sie unter Bearbeiten von Notizen und Syntaxregeln.

Sie können Notizen verwenden, um sämtliche Informationen aufzuzeichnen, die für das entsprechende Feld relevant sind. Dabei kann es sich beispielsweise um den Zweck des Feldes oder um den Grund für seine Erstellung handeln.

  • Geben Sie den Text im Dialogfeld Knoteneigenschaften ein, und klicken Sie auf OK, um Notizen zu erstellen.

Anmerkung

  • Notizen können nur druckbare Zeichen enthalten.

Verwandte Themen

Eingeben von Datensatznotizen

Anzeigen von Syntaxregeln


Verwalten von Dokumentinstanzen

Im BizTalk-Editor können Sie eine Dokumentinstanz auf der Basis einer Spezifikation erstellen oder anhand einer Spezifikation überprüfen.

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Erstellen einer neuen Dokumentinstanz

  • Überprüfen einer neuen Dokumentinstanz


Erstellen einer neuen Dokumentinstanz

  1. Öffnen Sie die Spezifikation, auf der die Dokumentinstanz basieren soll.

  2. Klicken Sie im Menü Extras auf XML-Instanz erstellen.

  3. Suchen Sie im Dialogfeld Dokumentinstanz erstellen unter nach dem Ordner, in dem Sie eine Dokumentinstanz erstellen möchten.

  4. Geben Sie im Feld Dateiname einen Namen für die Dokumentinstanz ein, und klicken Sie auf Speichern.

    Die neue Dokumentinstanz wird auf der Registerkarte Ausgabe angezeigt.

Anmerkung

  • Das einzige Format, das für die Erstellung einer Dokumentinstanz zur Verfügung steht, ist Unicode.

Verwandtes Thema

Überprüfen einer neuen Dokumentinstanz


Überprüfen einer neuen Dokumentinstanz

  1. Öffnen Sie die Spezifikation, anhand derer Sie die Dokumentinstanz überprüfen möchten.

    Weitere Informationen finden Sie unter Öffnen von Spezifikationen.

  2. Klicken Sie im Menü Extras auf Instanz überprüfen.

  3. Suchen Sie im Dialogfeld Dokumentinstanz überprüfen nach der Dokumentinstanz, die Sie überprüfen möchten, und klicken Sie auf Öffnen.

    Wenn Sie eine Dokumentinstanz anhand einer Spezifikation überprüfen, die auf dem X12- oder dem EDIFACT-Standard basiert, wird das Dialogfeld Dokumenttrennzeichen angezeigt. Führen Sie einen der folgenden Schritte aus:

    • X12-basierte Spezifikationen. Wählen Sie das Trennzeichen für das Dokument aus, das Sie überprüfen möchten, und klicken Sie auf OK.

    • EDIFACT-basierte Spezifikationen. Wählen Sie das Trennzeichen und das Escapezeichen für das Dokument aus, das Sie überprüfen möchten, und klicken Sie auf OK.

Wurde die Überprüfung der Dokumentinstanz anhand der Spezifikation abgeschlossen, wird auf der Registerkarte Warnung die folgende Meldung angezeigt: "Die Überprüfung der Dokumentinstanz war erfolgreich." Konnte die Überprüfung der Dokumentinstanz anhand der Spezifikation nicht durchgeführt werden, wird auf der Registerkarte Warnung eine entsprechende Meldung angezeigt. Außerdem werden Fehlerinformationen aufgelistet, denen Sie entnehmen können, warum die Dokumentinstanz nicht überprüft wurde. Wenn Sie eine nicht auf XML basierende Dokumentinstanz anhand einer nicht auf XML basierenden Spezifikation überprüfen und die Dokumentinstanz überprüft wird, können Sie eine XML (Extensible Markup Language)-Version des Dokuments auf der Registerkarte Ausgabe anzeigen.

Wichtig

  • Es wird dringend empfohlen, vor der Verwendung einer Dokumentinstanz in einer Produktionsumgebung die Instanz anhand der Quellspezifikation zu überprüfen und die auf der Registerkarte Warnungen angezeigten Probleme zu beheben.

Anmerkungen

  • Der BizTalk-Editor kann Dokumentinstanzen mit mehreren Dokumenten nicht überprüfen.

  • Eine Dokumentinstanz, die ein Feld mit einem leeren Attributwert ("") enthält, kann anhand einer Spezifikation erfolgreich überprüft werden, unabhängig von dem Wert, der für die Minimallänge-Eigenschaft dieses Feldes festgelegt wurde. Wenn eine Spezifikation beispielsweise über ein Feld verfügt, für dessen Minimallänge-Eigenschaft der Wert 4 festgelegt wurde, und Sie versuchen, eine Dokumentinstanz, die ein entsprechendes Feld mit einem leeren Attributwert enthält, zu überprüfen, schlägt die Überprüfung nur aufgrund dieser Diskrepanz nicht fehl. Der Grund hierfür ist, dass der MSXML-Parser, der dem Überprüfungsmodul zugrunde liegt, ein Attribut mit einem leeren Wert so behandelt, als wäre es nicht vorhanden. Dieses Problem wird mit der nächsten Version von BizTalk Server behoben.

  • Die Instanzüberprüfung kann für EDI-Instanzen (Electronic Data Interchange) (sowohl X12- als auch EDIFACT-Standards) nicht korrekt durchgeführt werden, es sei denn, Austausch-, Gruppen- und Dokumentumschläge (Header und Nachspann) werden entfernt. Für X12-Dokumente müssen Sie ISA-, GS-, ST-, SE-, GE- und IEA-Segmente entfernen, für EDIFACT-Dokumente UNA- (falls vorhanden), UNB-, UNG-, UNH-, UNT-, UNE- und UNZ-Segmente.

  • Eine wohlgeformte XML-Dokumentinstanz, die Elemente enthält, die als XDR-Datentypen (XML-Data Reduced) eingegeben wurden, können möglicherweise nicht anhand der entsprechenden Spezifikation überprüft werden. Stellen Sie sicher, dass für alle Elemente, die als XDR-Datentypen eingegeben wurden, die Modell-Eigenschaft auf Offen festgelegt wurde, damit eine solche Dokumentinstanz überprüft werden kann. Weitere Informationen zur Modell-Eigenschaft finden Sie unter Festlegen von Deklarationseigenschaften.

  • Nicht auf XML basierende Dokumentinstanzen, die in Unicode gespeichert wurden, können nur korrekt überprüft werden, wenn Sie das Kennzeichen für die Bytereihenfolge am Anfang der Datei entfernen.

  • Beim Überprüfen einer Dokumentinstanz anhand einer Spezifikation, für die die Standard-Eigenschaft auf X12, EDIFACT oder CUSTOM festgelegt wurde, muss die Dokumentinstanz über eine Dokumentstruktur verfügen, die dem Standard der Spezifikation entspricht. Beispielsweise können Sie eine X12-Dokumentinstanz nur anhand einer X12-Spezifikation überprüfen.

  • Eine Dokumentinstanz, die einen x-schema-Schemaverweis enthält, wird immer unter Verwendung dieses Schemaverweises überprüft, unabhängig von dem Schema, das im BizTalk-Editor geladen ist.

  • Eine ungültige Zeichentabelle ist kein Kriterium für die Instanzüberprüfung. Enthält eine Instanz beispielsweise Daten, die zwischen dem im Dialogfeld Ungültiger Zeichenbereich angegebenen Anfangs- und Endbereich liegen, kann die Überprüfung dennoch durchgeführt werden.

Verwandtes Thema

Erstellen einer neuen Dokumentinstanz


Verwalten ungültiger Zeichentabellen

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Hinzufügen ungültiger Zeichenbereiche

  • Bearbeiten ungültiger Zeichenbereiche

  • Löschen ungültiger Zeichenbereiche


Hinzufügen ungültiger Zeichenbereiche

  1. Klicken Sie im Menü Ansicht auf Ungültige Zeichentabelle.

  2. Klicken Sie im Dialogfeld Ungültiger Zeichenbereich auf die Schaltfläche Neuer Zeichenbereich Schaltfläche "Neuer Zeichenbereich".

  3. Wählen Sie im Dialogfeld Ungültigen Zeichenbereich eingeben aus der Liste Ungültiger Anfangsbereich einen Wert aus, und drücken Sie die Tabulatortaste.

  4. Klicken Sie auf einen Wert in der Liste Ungültiger Endbereich, und klicken Sie auf OK.

  5. Wiederholen Sie die Schritte 2 bis 4, um weitere ungültige Zeichenbereiche hinzuzufügen.

Wichtig

  • Ungültige Zeichenbereiche können nur für nicht auf XML basierende Dokumente festgelegt werden.

  • Der korrekte Hexadezimalwert für ein Fragezeichen (?) ist (0x3f). Die Standardeinstellung in der Liste Ungültiger Anfangsbereich und der Liste Ungültiger Endbereich ist ? (0x0). Verwenden Sie dieses Zeichen nicht als Satzzeichen. Um ein Fragezeichen einzugeben, wählen Sie den Wert ? (0x3f) aus der Liste aus.

Anmerkungen

  • Die Werte, die in den Listen Ungültiger Anfangsbereich und Ungültiger Endbereich angezeigt werden, sind Hexadezimalwerte. Wird die Spezifikation mithilfe einer Anwendung, wie z. B. Microsoft Internet Explorer 5 oder höher, als XML (Extensible Markup Language)-Quelldatei angezeigt, erscheinen die Werte als Dezimalwerte. Wenn Sie in den Feldern Ungültiger Anfangsbereich und Ungültiger Endbereich beispielsweise ein Semikolon (;) eingeben, wird der Wert als ; (0x3b) angezeigt. In einem Browser dagegen wird derselbe Wert als 59 angezeigt.

  • Um einen ungültigen Zeichenbereich anzugeben, können Sie auch in der Liste Ungültiger Anfangsbereich auf den Wert klicken, ein numerisches oder alphabetisches Zeichen eingeben und dann die Tabulatortaste drücken, um zur Liste Ungültiger Endbereich zu wechseln.

Verwandte Themen

Löschen ungültiger Zeichenbereiche

Bearbeiten ungültiger Zeichenbereiche


Bearbeiten ungültiger Zeichenbereiche

  1. Klicken Sie im Menü Ansicht auf Ungültige Zeichentabelle.

  2. Wählen Sie im Dialogfeld Ungültiger Zeichenbereich den Zeichenbereich aus, den Sie ändern möchten, und klicken Sie auf die Schaltfläche Zeichenbereich ändern Schaltfläche "Zeichenbereich ändern".

  3. Führen Sie im Dialogfeld Ungültigen Zeichenbereich eingeben einen der folgenden Schritte aus:
    • Wählen Sie einen Wert aus der Liste Ungültiger Anfangsbereich aus.

      Oder

    • Wählen Sie einen Wert aus der Liste Ungültiger Endbereich aus.
  4. Klicken Sie auf OK.

  5. Wiederholen Sie die Schritte 2 bis 4, um weitere ungültige Zeichenbereiche zu ändern.

Wichtig

  • Ungültige Zeichenbereiche können nur für nicht auf XML basierende Dokumente festgelegt werden.

  • Der korrekte Hexadezimalwert für ein Fragezeichen (?) ist (0x3f). Die Standardeinstellung in der Liste Ungültiger Anfangsbereich und der Liste Ungültiger Endbereich ist ? (0x0). Verwenden Sie dieses Zeichen nicht als Satzzeichen. Um ein Fragezeichen einzugeben, wählen Sie den Wert ? (0x3f) in der Liste aus.

Anmerkungen

  • Die Werte, die in den Listen Ungültiger Anfangsbereich und Ungültiger Endbereich angezeigt werden, sind Hexadezimalwerte. Wird die Spezifikation mithilfe einer Anwendung, wie z. B. Microsoft Internet Explorer 5 oder höher, als XML-Quelldatei angezeigt, erscheinen die Werte als Dezimalwerte. Wenn Sie in den Feldern Ungültiger Anfangsbereich und Ungültiger Endbereich beispielsweise ein Semikolon (;) eingeben, wird der Wert als ; (0x3b) angezeigt. In einem Browser dagegen wird derselbe Wert als 59 angezeigt.

  • Um einen Zeichenbereich anzugeben, können Sie auch in der Liste Ungültiger Anfangsbereich auf den Wert klicken, ein numerisches oder alphabetisches Zeichen eingeben und dann die Tabulatortaste drücken, um zur Liste Ungültiger Endbereich zu wechseln.

Verwandte Themen

Hinzufügen ungültiger Zeichenbereiche

Löschen ungültiger Zeichenbereiche


Löschen ungültiger Zeichenbereiche

Wichtig

  • Ungültige Zeichenbereiche können nur für nicht auf XML basierende Dokumente festgelegt werden.
  1. Klicken Sie im Menü Ansicht auf Ungültige Zeichentabelle.

    Klicken Sie im Dialogfeld Ungültiger Zeichenbereich auf den Zeichenbereich, den Sie löschen möchten, und klicken Sie auf die Schaltfläche Zeichenbereich löschen Schaltfläche "Zeichenbereich löschen".

  2. Klicken Sie auf Ja, um die Änderung zu bestätigen.

Verwandte Themen

Hinzufügen ungültiger Zeichenbereiche

Bearbeiten ungültiger Zeichenbereiche


Verwalten von Ansichten

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Erweitern von Strukturelementen

  • Reduzieren von Strukturelementen

  • Anzeigen von Registerkarten

  • Ändern der Textgröße


Erweitern von Strukturelementen

  • Klicken Sie auf den Stammknoten oder Datensatz, den Sie erweitern möchten, und klicken Sie dann im Menü Ansicht auf Strukturelemente erweitern.

Anmerkung

  • Sie müssen auf den Stammknoten klicken, um die gesamte Struktur zu erweitern. Durch Klicken auf einen Datensatz erweitern Sie lediglich die untergeordneten Datensätze und Felder innerhalb des Datensatzes.

Verwandtes Thema

Reduzieren von Strukturelementen


Reduzieren von Strukturelementen

  • Klicken Sie auf den Stammknoten oder Datensatz, den Sie reduzieren möchten, und klicken Sie dann im Menü Ansicht auf Strukturelemente reduzieren.

Anmerkung

  • Sie müssen auf den Stammknoten klicken, um die gesamte Struktur zu reduzieren. Durch Klicken auf einen Datensatz reduzieren Sie lediglich die untergeordneten Datensätze und Felder innerhalb des Datensatzes.

Verwandtes Thema

Erweitern von Strukturelementen


Anzeigen von Registerkarten

  • Klicken Sie im Menü Ansicht auf eine der folgenden Registerkartennamen:
    • Deklaration

    • Verweis

    • Analysieren

    • Namespace

    • Wörterbuch

    • Codeliste


Ändern der Textgröße

  • Zeigen Sie im Menü Ansicht auf Textgröße, und klicken Sie auf die gewünschte Größe.


Grundbegriffe

Dieser Abschnitt stellt detaillierte Informationen zum Konzept bereit, die wichtig für das Verständnis des BizTalk-Editors sind.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Grundlegendes zu Spezifikationen

  • Importieren von Dateien

  • BizTalk-Editor - Umgebung

  • Datensätze, Felder und Eigenschaften

  • Namespaceunterstützung

  • Hinzufügen von SQL-Anmerkungen


Grundlegendes zu Spezifikationen

Spezifikationen sind BizTalk Server-spezifische XML-Schemas (Extensible Markup Language), die im BizTalk-Editor erstellt werden. Sie können Spezifikationen erstellen, die auf Industriestandards (wie beispielsweise XML, EDIFACT oder X12) oder auf industriefremden Standards (wie z. B. Flatfiles mit Trennzeichen, Flatfiles mit Feldern fester Breite, Flatfiles mit Trennzeichen und mit Feldern fester Breite, leeren Spezifikationen oder vorhandenen Dateien) basieren.

Industriestandards

Industriestandards stellen einheitliche Verfahren für den elektronischen Datenaustausch für Unternehmen bereit. Die Verwendung einer gemeinsamen Geschäftssprache ermöglicht Computern die Kommunikation innerhalb einer Organisation oder von einem Unternehmen zu einem anderen. Industriestandards geben das Format und den Dateninhalt von elektronischen Geschäftstransaktionen an. Eine Spezifikation, die auf einem Industriestandard basiert, wird als Teilmenge des Standards angesehen. Sie können von einer Industriestandardspezifikation als Grundlage ausgehen und dann alle Datensätze und Felder löschen, die Sie nicht benötigen, um eine Spezifikation zu erstellen, die Ihren Bedürfnissen entspricht. Darüber hinaus müssen Sie möglicherweise Eigenschaften für die verbleibenden Datensätze und Felder ändern.

Industriefremde Standards

In Spezifikationen, die auf industriefremden Standards basieren, müssen Sie die Struktur des Dokuments im BizTalk-Editor definieren. Sie können den BizTalk-Editor für verschiedene Typen von industriefremden Standards verwenden: Flatfiles mit Feldern fester Breite, Flatfiles mit Trennzeichen oder kombinierte Flatfiles mit Feldern fester Breite und mit Trennzeichen.

Anmerkung

  • Sie müssen auf der Registerkarte Analysieren die Struktur-Eigenschaft des Stammknotens auf Getrennt festlegen, wenn es sich um eine Flatfile mit Trennzeichen und mit Feldern fester Breite handelt. Weitere Datensatzeigenschaften werden entweder auf Getrennt oder auf Feste Breite festgelegt, je nach ihren Attributen.

Leere Spezifikationen

Eine leere Spezifikation enthält nur das Stammknotenelement. Wenn Sie von einer leeren Spezifikation ausgehen, müssen Sie die gesamte Spezifikationsstruktur erstellen. Benennen Sie das Stammelement um, und ändern Sie anschließend die Eigenschaftswerte des Stammelements, die Sie ändern möchten, wie z. B. die Titelinformation für die Spezifikation. Anschließend können Sie Datensätze und Felder und deren Eigenschaften hinzufügen, wie es Ihre Geschäftsabläufe erfordern.

Vorhandene Dateien

Sie können vorhandene Dateien wiederverwenden, um die Investition in die Entwicklung von Dokumenten zu nutzen, die den spezifischen Anforderungen Ihres Unternehmens entsprechen. Sie müssen eine Datei zuerst in den BizTalk-Editor importieren und sie dann als Spezifikation speichern, um eine vorhandene Datei wiederzuverwenden. Anschließend müssen Sie die gespeicherte Spezifikation im BizTalk-Mapper öffnen und sie dem von Ihren Handelspartnern benötigten Format zuordnen.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Spezifikationsstruktur

  • Unterstützen von Standards

  • Unterstützen anderer Dateiformate

  • Ungültige XML-Namenzeichen

  • Ungültige Zeichenbereiche

Verwandte Themen

Erstellen einer Spezifikation auf der Basis einer Flatfile

Erstellen einer Spezifikation auf der Basis einer leeren Vorlage

Erstellen einer Spezifikation auf der Basis einer vorhandenen Spezifikation

Erstellen einer Spezifikation auf der Basis eines Standards

Datensätze, Felder und Eigenschaften


Spezifikationsstruktur

Im BizTalk-Editor erstellte Spezifikationen stellen wohlgeformten XML-Code dar. Spezifikationsstrukturen unterscheiden sich je nach dem Dateityp, den Sie als Basis für die Erstellung Ihrer Spezifikation wählen. Unabhängig vom Typ enthält jede Spezifikation die gleiche grundlegende Struktur. Beispielsweise beginnen alle Spezifikationen mit dem Kennzeichen <?xml version=""?> und fahren mit Kopfzeileninformationen fort, wie dem Namen der Datei und Namensraumdaten. Anschließend wird die verbleibende Struktur auf der Basis der in Ihrer Spezifikation enthaltenen Datensätze und Felder und der diesen Datensätzen und Feldern zugeordneten Attribute aufgebaut. Sie können den zugrunde liegenden Code einer Spezifikation anzeigen, indem Sie diese in Microsoft Internet Explorer 5 oder höher öffnen.

Sie können ein (XDR)-Schema (XML-Data Reduced) aus einer Spezifikation erstellen, indem Sie den im Menü Extras den Befehl XDR-Schema exportieren verwenden. Weitere Informationen finden Sie unter Exportieren von XDR-Schemas.

Sie können aus einem XDR-Schema mithilfe eines Konvertierungsskripts, das bei einer vollständigen Installation von BizTalk Server bereitgestellt wird, ein XSD-Schema erstellen. Weitere Informationen zum Konvertieren eines XDR-Schemas in ein XSD-Schema finden Sie unter Konvertieren eines XDR-Schemas in ein XSD-Schema.

Verwandte Themen

Exportieren von XDR-Schemas

Konvertieren eines XDR-Schemas in ein XSD-Schema


Unterstützen von Standards

EDI-Standards (Electronic Data Interchange), wie z. B. EDIFACT und X12 definieren einen großen Teil der möglichen Segmente und Elemente, die die für Geschäftsdokumente benötigte Dateistruktur bilden. Mithilfe des BizTalk-Editors können Sie mit diesen Strukturen als Basis für Ihre Spezifikation beginnen und anschließend die nicht benötigten Segmente und Elemente entfernen. Die endgültige Struktur ist eine Teilmenge des Standards, auf den Sie sich mit Ihrem Handelspartner/Ihren Handelspartnern oder einer anderen Person innerhalb Ihrer Organisation geeinigt haben.

Wenn Sie in einem EDIFACT- oder X12-Dokument Knoten erstellen oder verschieben, wird dringend empfohlen, dass Sie den Dokumentstandard auf CUSTOM festlegen. Darüber hinaus sollten Sie auch die Trennzeichentyp-Eigenschaft festlegen, um die geänderte Struktur mit dem Rest des Dokuments kompatibel zu gestalten. Beachten Sie, dass alle Trennzeichentyp-Einstellungen verloren werden, wenn Sie den Dokumentstandard von CUSTUM auf EDIFACT oder X12 zurücksetzen. Weitere Informationen zum Festlegen der CUSTOM-Eigenschaft finden Sie unter Festlegen von Verweiseigenschaften. Weitere Informationen zum Festlegen der Trennzeichentyp-Eigenschaft finden Sie unter Festlegen von Analyseeigenschaften.

Der BizTalk-Editor unterstützt außerdem X12-Syntaxregeln; diese stellen relationale Bedingungen dar, die zwischen zwei oder mehr Elementen für einen Datensatz bestehen. Wenn die Spezifikation Syntaxregeln enthält, werden diese während des Laufzeitprozesses des Servers bei der Überprüfung der Spezifikation erzwungen.

Es existieren fünf Arten von Regeln:

  • All

    Wenn TXI08 existiert, müssen alle folgenden Knoten vorhanden sein:

    • TXI03
  • Grouped

    Wenn einer der folgenden Knoten vorhanden ist, müssen alle Knoten vorhanden sein:

    • TXI04

    • TXI05
  • Any

    Mindestens einer der folgenden Knoten muss vorhanden sein:

    • TXI02

    • TXI03

    • TXI06
  • One

    Höchstens einer der folgenden Knoten muss vorhanden sein:

    • TXI02

    • TXI03

    • TXI06
  • Any (conditional)

    Wenn PO413 vorhanden ist, muss mindestens einer der folgenden Knoten vorhanden sein:

    • P0410

    • PO411

    • PO412

Verwandte Themen

Festlegen von Verweiseigenschaften

Zusammenfassungsliste der im Lieferumfang enthaltenen, auf EDI basierenden Dokumente


Unterstützen anderer Dateiformate

Der BizTalk-Editor vereinfacht das Erstellen von Spezifikationen mit Dateistrukturen mit Feldern fester Breite, mit Trennzeichen oder mit kombinierten Dateistrukturen mit Feldern fester Breite und mit Trennzeichen. Die folgenden Abschnitte stellen spezifische Details zu jeder dieser Dateistrukturen bereit.

Flatfiles mit Feldern fester Breite

Eine Flatfile mit Feldern fester Breite besteht aus Feldern, die eine identische feste Länge aufweisen, und Datensätzen, die über ein gemeinsames Datensatz-Abschlusszeichen verfügen. Die Struktur einer eingehenden Datei muss in den Datensätzen und Feldern der Quellspezifikation dargestellt sein, damit der auf Feldern fester Breite basierende Charakter der eingehenden Datei gewahrt bleibt. Daher müssen Sie, bevor Sie die Dokumentstruktur einer Quellspezifikation definieren, ein Schema der erforderlichen Datensätze und Felder ermitteln.

In der nachfolgenden Tabelle wird ein Beispiel für ein festes Format gezeigt.

Name | Adresse | Stadt | Telefon
Xxxxxxxxxx | Aaaaaaaaaa | Ccccccccccccccc | xxx-xxx-xxxx
Yyyyyyyyyy | Bbbbbbbbbb | Ddddddddddddd | xxx-xxx-xxxx

Das Feld Name verfügt über eine festgelegte maximale Länge von 10 Zeichen, die maximale Länge des Feldes Adresse beträgt 10 Zeichen, das Feld Stadt kann maximal 15 Zeichen umfassen, und die maximale Länge des Feldes Telefon beträgt 12 Zeichen. Das Datensatz-Abschlusszeichen ist ein Wagenrücklauf- und/oder ein Zeilenvorschubzeichen.

Sie können den BizTalk-Editor verwenden, um aufeinander folgende Datensätze und Felder zu erstellen. Sie können mehrere Datensatztypen erstellen und übergeordneten Datensätzen verschiedene Trennzeichen zuweisen. Bei Strukturen, die mehrere Datensatztypen enthalten, muss die Spezifikation der Typen und Datensatz-Abschlusszeichen ebenfalls in der Reihenfolge angegeben werden, in der sie im Dokument auftreten. Felder müssen durch Anfangsposition, Länge und Datentyp angegeben werden.

Wichtig

  • Ein Datensatz mit Feldern fester Breite muss immer ein untergeordneter Datensatz eines Datensatzes mit Trennzeichen sein. Das für den übergeordneten Datensatz mit Trennzeichen angegebene Trennzeichen darf in den Daten des untergeordneten Datensatzes mit Feldern fester Breite nicht auftreten. Es gibt keine Möglichkeit, das Trennzeichen des übergeordneten Datensatzes mit Trennzeichen in den Daten des untergeordneten Feldes mit fester Breite durch ein Escapezeichen zu kapseln. Weitere Informationen zu Trennzeichen und Escapezeichen finden Sie unter Festlegen von Analyseeigenschaften.

Anmerkungen

  • Sie müssen auf der Registerkarte Analysieren die Struktur-Eigenschaft des Stammknotens auf Getrennt festlegen, wenn es sich um eine Flatfile mit Trennzeichen und mit Feldern fester Breite handelt. Weitere Datensatzeigenschaften werden entweder auf Getrennt oder auf Feste Breit festgelegt, je nach ihren Attributen.

  • Wenn eine Spezifikation vom Typ mit Feldern fester Breite ist und Sie die Struktur in einen Typ mit Trennzeichen ändern, enthält die kompilierte Spezifikation die ursprüngliche Anfangs- und Endposition, die auf der Registerkarte Verweis angegeben ist. Wenn BizTalk Server eine Spezifikation analysiert, ignoriert der Parser diese Informationen jedoch und verarbeitet die Spezifikation als Datei mit Trennzeichen.

Flatfile mit Trennzeichen

Eine Flatfile mit Trennzeichen enthält einen oder mehrere Datensätze, die durch ein Trennzeichen getrennt sind. Der BizTalk-Editor liest Trennzeichen nicht als Teil der Daten. Wenn das Trennzeichen jedoch innerhalb der Daten auftritt, können die Daten formatiert werden, so dass Daten und Trennzeichen unterschieden werden können. Beispielsweise kann das Feld, in dem ein Trennzeichen auftritt, in Anführungszeichen eingeschlossen sein, um anzuzeigen, dass das Trennzeichen als Teil der Daten und nicht als Trennzeichen behandelt werden soll.

Mithilfe des BizTalk-Editors können Sie bestimmte Felder und die ihnen zugeordneten Trennzeichen auswählen. Darüber hinaus können Sie Datensatz-Abschlusszeichen angeben. Um die Verwendung von Flatfiles mit Trennzeichen zu ermöglichen, unterstützt der BizTalk-Editor die folgenden Features:

  • Strukturen, die aus mehreren Datensatzgruppen bestehen.

  • Mehrere Datensatztypen, die durch Datensatztyp-Kennzeichen definiert sind.

  • Datensatz-Abschlusszeichen.

  • Umbruch- und Escapezeichen, um zwischen Felddaten und Trennzeichenwerten zu unterscheiden.

  • Feldanfangs-, Längen- und Typwerte.

  • Feldinhaltskennzeichen und Beschreibungen.

  • Die Fähigkeit, Flatfiles in Spezifikationen umzuwandeln, die vom BizTalk-Mapper verwendet werden können.

Anmerkung

  • Sie müssen auf der Registerkarte Analysieren die Struktur-Eigenschaft des Stammknotens auf Getrennt festlegen, wenn es sich um eine Flatfile mit Trennzeichen und mit Feldern fester Breite handelt. Weitere Datensatzeigenschaften werden entweder auf Getrennt oder auf Feste Breite festgelegt, je nach ihren Attributen.


Ungültige XML-Namenzeichen

Unicode-Zeichen im Bereich von xF900 bis xFFFE sind in XML-Namen (Extensible Markup Language) nicht gültig. Wenn Sie ein ungültiges Unicode-Zeichen in einem XML-Namen verwenden, wird dieses Zeichen bei der Anzeige in der Spezifikationsstruktur in eine durch Escapezeichen gekapselte numerische Einheit übersetzt. Die durch Escapezeichen gekapselte numerische Einheit wird als _xHHHH_ codiert, wobei HHHH für den vierstelligen hexadezimalen Unicode-Code steht. Beispielsweise enthält der Name Versand an in einer Auftragsspezifikation ein Leerzeichen und wird in der Spezifikationsstruktur als Versand_x0020_an angezeigt. Wenn Sie den Mauszeiger über einen Knoten bewegen, der ein codiertes Unicode-Zeichen enthält, wird eine QuickInfo angezeigt, die den Knotennamen mit nicht codiertem Unicode-Zeichen anzeigt.

Anmerkung

  • Dies tritt ein, wenn Sie eine Spezifikationsstruktur im BizTalk-Editor oder im BizTalk-Mapper anzeigen.


Ungültige Zeichenbereiche

Sie können die Ausgabe eines Zeichens oder eines Zeichenbereichs durch BizTalk Server blockieren. Öffnen Sie zu diesem Zweck im BizTalk-Editor eine Spezifikation, die als Zielspezifikation verwendet werden soll. Öffnen Sie das Dialogfeld Ungültiger Zeichenbereich, und geben Sie die Zeichen oder Zeichenbereiche ein, die nicht von BizTalk Server ausgegeben werden sollen. Immer wenn BizTalk Server versucht, ein im Dialogfeld Ungültiger Zeichenbereich einer Ausgabespezifikation angegebenes Zeichen zu verarbeiten, hält die Verarbeitung an, und es wird eine Fehlermeldung angezeigt.

Anmerkung

  • Zeichenbereiche können nur für nicht auf XML basierende vorliegende Dokumente blockiert werden.

Verwandte Themen

Hinzufügen ungültiger Zeichenbereiche

Löschen ungültiger Zeichenbereiche

Bearbeiten ungültiger Zeichenbereiche

Zuordnen von Daten


Importieren von Dateien

Drei Dateitypen können in den BizTalk-Editor importiert werden: Wohlgeformte XML-Instanzen, Dokumenttypdefinitionen (DTDs) und XDR-Schemas (XML-Data Reduced). Die folgenden Abschnitte enthalten weitere Informationen zum Importieren von Dateien in den BizTalk-Editor.

Anmerkung

  • Wenn der BizTalk-Editor nicht ermitteln kann, welches Element den Stammknoten darstellen soll, wird das Dialogfeld Stammelement auswählen angezeigt. Wählen Sie das Element aus, das den Stammknoten darstellen soll, und klicken Sie dann auf OK.

Nach dem Importieren einer wohlgeformten XML-Instanz, einer DTD oder eines XDR-Schemas erstellt der BizTalk-Editor eine Struktur, die auf der importierten Datei basiert, und zeigt eine Zusammenstellung von Datensätzen und Feldern an. Nach dem Speichern im BizTalk-Editor wird die Datei zu einer Spezifikation. Diese Spezifikation weist die entsprechenden Kopfzeileninformationen auf und folgt einer angegebenen Struktur.

Wichtig

  • Die folgende Tabelle erläutert, welche XDR-Dateien und DTDs importiert werden können, wenn sie bestimmte Datentypen enthalten, und ob der Datentyp importiert werden kann. Die Spalten stellen die Datentypen dar.
    "entity" und "entities" | "nmtoken" und "nmtokens" | "notation"
    XDR | Die Datei kann nicht importiert werden. | Die Datei kann importiert werden, aber die Datentypen werden entfernt. | Die Datei kann nicht importiert werden.
    DTD | Die Datei kann importiert werden, aber die Datentypen werden entfernt. | Die Datei kann importiert werden, aber die Datentypen werden entfernt. | Die Datei kann importiert werden, aber der Datentyp wird als Aufzählungstyp importiert.

  • Wenn die letzte Zeile einer DTD ein Verweis auf eine Entität ist (beispielsweise "%xx"), kann die DTD nicht in den BizTalk-Editor importiert werden. Das Erstellen einer neuen Zeile am Ende der DTD, die ein Zeilenendezeichen enthält, ermöglicht das Importieren der DTD in den BizTalk-Editor.

  • Wenn Sie versuchen, eine Datei zu importieren, die einen externen Verweis auf eine andere Datei enthält, schlägt der Import fehl.

  • Wenn der BizTalk-Editor nach dem Importieren einer wohlgeformten XML-Datei (Extensible Markup Language) Warnungen anzeigt, die sich auf zyklische Verweise beziehen, wird dringend empfohlen, dass Sie die in den Warnungen genannten Punkte beheben und die Spezifikation speichern, bevor Sie fortfahren.

  • Beim Importieren von wohlgeformtem XML oder von DTDs kann der BizTalk-Editor keine Datentyp- oder Feldlängenparameter interpretieren.

Verwandtes Thema

Erstellen einer Spezifikation auf der Basis einer importierten Datei


BizTalk-Editor - Umgebung

Folgende Themen werden in diesem Abschnitt behandelt:

  • BizTalk-Editor - Benutzeroberfläche

  • BizTalk-Editor - Menüs

  • BizTalk-Editor - Symbolleisten-Schaltflächen

  • BizTalk-Editor - Tastenkombinationen


BizTalk-Editor - Benutzeroberfläche

Die BizTalk-Editor-Benutzeroberfläche verfügt über drei Hauptbereiche. Der linke Bereich zeigt die Spezifikationsstruktur an, bei der es sich um eine grafische Darstellung einer Spezifikation handelt. Der oberste Knoten in der Spezifikationsstruktur ist der Stammknoten; er wird durch ein Dokumentsymbol mit horizontalen grünen Linien dargestellt Stammknotensymbol . Datensätze und Felder stehen in der Spezifikationshierarchie unterhalb des Stammknotens. Datensätze verwenden das gleiche Symbol wie der Stammknoten. Felder werden durch ein Dokumentsymbol mit vertikalen blauen Linien dargestellt Feldsymbol . Sie können einen Knoten in der Spezifikationsstruktur erweitern oder reduzieren, indem Sie auf das Plus- oder Minussymbol links neben dem Knoten klicken.

Der rechte Bereich enthält sechs Registerkarten: Deklaration, Verweis, Analysieren, Namespace, Wörterbuch und Codeliste. Verwenden Sie diese Registerkarten, um Eigenschaftswerte, Namespaces, Wörterbucheigenschaften und Codelisten für Knoten in einer Spezifikation festzulegen. Weitere Informationen zu diesen Registerkarten finden Sie unter Festlegen von Eigenschaften für Datensätze und Felder.

Der untere Bereich enthält zwei Registerkarten: Ausgabe und Warnung. Die Registerkarte Ausgabe zeigt eine XML-Dokumentinstanz (Extensible Markup Language) an, die beim Verwenden des Features XML-Instanz erstellen des BizTalk-Editors erstellt wird. Weitere Informationen zum Erstellen einer XML-Dokumentinstanz aus einer Spezifikation finden Sie unter Erstellen einer neuen Dokumentinstanz. Die Registerkarte Warnung zeigt an, ob ein Versuch der Überprüfung einer Dokumentinstanz anhand einer Spezifikation erfolgreich war, und zeigt Warnungen im Zusammenhang mit einem nicht erfolgreichen Versuch der Überprüfung eines Dokuments an. Weitere Informationen finden Sie unter Überprüfen einer neuen Dokumentinstanz.

Verwandte Themen

Erstellen einer neuen Dokumentinstanz

Festlegen von Eigenschaften für Datensätze und Felder

Überprüfen einer neuen Dokumentinstanz


BizTalk-Editor - Menüs

BizTalk-Editor-Menüs gruppieren Befehle unter logischen Gesichtspunkten und machen es auf diese Weise einfach, eine bestimmte Aufgabe durchzuführen. Beispielsweise können Sie die Befehle im Menü Ansicht verwenden, um alle Datensätze und Felder in der Spezifikationsstruktur anzuzeigen oder zu reduzieren.

Die folgenden Menüs stehen im BizTalk-Editor zur Verfügung:

  • Datei. Verwenden Sie dieses Menü, um eine Spezifikation zu erstellen, zu öffnen, zu speichern oder zu schließen.

  • Bearbeiten. Verwenden Sie dieses Menü, um Datensätze oder Felder in einer Spezifikation auszuschneiden, zu kopieren, einzufügen, einzusetzen, umzubenennen oder zu löschen.

  • Ansicht. Verwenden Sie dieses Menü, um Ansichten im rechten Bereich der Benutzeroberfläche auszuwählen, Ansichten im unteren Bereich der Benutzeroberfläche auszuwählen, eine Textgröße für die BizTalk-Editor-Anzeige auszuwählen, das Dialogfeld Ungültige Zeichentabelle anzuzeigen, die Spezifikationsstruktur zu erweitern oder zu reduzieren oder die nächste Warnung auf der Registerkarte Warnung zu markieren.

  • Extras. Verwenden Sie dieses Menü, um eine Spezifikation zu überprüfen, eine Dokumentinstanz anhand einer Spezifikation zu überprüfen, eine XML-Dokumentinstanz (Extensible Markup Language) aus einer Spezifikation zu erstellen, Dateien zu importieren, XDR-Schemas (XML-Data Reduced) zu exportieren oder die BizTalk-Editor-Optionen anzuzeigen.

  • Hilfe. Verwenden Sie dieses Menü, um Informationen zur Verfahrensweise und zum Konzept des BizTalk-Editors zu erhalten.

Verwandtes Thema

BizTalk-Mapper - Menüs


BizTalk-Editor - Symbolleisten-Schaltflächen

Der BizTalk-Editor stellt eine Symbolleiste zur Ergänzung der Menüleiste bereit. Alle Schaltflächen der Symbolleiste zeigen grafische Darstellungen der von ihnen durchgeführten Aufgaben an. Sie werden in der folgenden Reihenfolge von links nach rechts angezeigt:

  • Neu

  • Öffnen

  • Speichern

  • Aus WebDAV abrufen

  • In WebDAV speichern

  • Spezifikationsknoten ausschneiden

  • Spezifikationsknoten kopieren

  • Spezifikationsknoten einfügen

  • Löschen

  • Neuer Datensatz

  • Neues Feld

  • Datensatz einfügen

  • Feld einfügen

  • Reduzieren

  • Erweitern


BizTalk-Editor - Tastenkombinationen

Sie können im BizTalk-Editor Tastenkombinationen verwenden, um Aufgaben durchzuführen. Die folgende Tabelle ist eine kurze Referenz zu diesen Tastenkombinationen.

Anmerkung

  • Sie können mithilfe der Zehnertastatur den Mauszeiger mit der Tastaturmaus bewegen, um Funktionen zu verwenden, die in dieser Liste nicht enthalten sind. Weitere Informationen zur Tastaturmaus finden Sie in der Windows 2000 Server- und Advanced Server-Hilfe unter "Bewegen des Mauszeigers mithilfe der Tastatur". Weitere Informationen zur Tastaturmaus finden Sie in der Windows 2000 Professional-Hilfe unter "Bewegen des Mauszeigers mithilfe der Tastaturmaus".
Tastenkombination | Zweck
STRG+N | Neue Spezifikation öffnen.
STRG+O | Vorhandene Spezifikation öffnen.
STRG+S | Spezifikation speichern.
UMSCHALT+R | Datensatz einfügen.
STRG+R | Einen neuen Datensatz zu einem Datensatz hinzufügen.
UMSCHALT+F | Feld einfügen.
STRG+F | Ein neues Feld zu einem Datensatz hinzufügen.
ENTF | Einen Datensatz oder ein Feld löschen.
F4 | Nächste Warnung markieren.
F5 | Schema überprüfen.
STRG+C | Objekt kopieren.
STRG+X | Objekt ausschneiden.
STRG+V | Objekt einfügen.
F6 | Fokus im Uhrzeigersinn von Bereich zu Bereich verschieben.
UMSCHALT+F6 | Fokus gegen den Uhrzeigersinn von Bereich zu Bereich verschieben.
TAB | Fokus von der Registerkarte im rechten Bereich zum Datenblatt darunter umschalten. Durch Drücken von TAB in einem Dialogfeld wird der Fokus zwischen den Schaltflächen und Feldern im Dialogfeld verschoben.
LEERTASTE | Aktivieren und Deaktivieren eines Kontrollkästchens. Die Leertaste verhält sich darüber hinaus wie ein Mausklick, wenn der Fokus sich auf einer Schaltfläche befindet.
F2 | Bearbeitungsmodus für einen markierten Knoten in der Spezifikationsstruktur aktivieren. Bearbeitungsmodus für eine markierte Zeile im Datenblatt des rechten Bereichs aktivieren.
UMSCHALT+F2 Bearbeitungsmodus für die folgenden Felder aktivieren:
  • Die Eigenschaft-Spalte einer markierten benutzerdefinierten Anmerkungszeile auf der Registerkarte Deklaration oder Verweis.

  • Die Präfix-Spalte einer markierten benutzerdefinierten Anmerkungszeile auf der Registerkarte Namespace.

  • Die Eigenschaft-Spalte einer markierten benutzerdefinierten Wörterbuchzeile auf der Registerkarte Wörterbuch.
ALT+NACH-UNTEN | Liste für ein aktives Listenfeld anzeigen.
UMSCHALT++ | Eine neue benutzerdefinierte Anmerkung hinzufügen, wenn der Fokus sich auf dem Namespace-Datenblatt im rechten Bereich befindet.
EINGABETASTE | Bearbeitung von Knoten und Werten bestätigen.
ESC | Bearbeitung von Knoten und Werten abbrechen.
F1 | Onlinehilfe anzeigen.
ALT+F4 | Programm schließen.
NACH-LINKS-TASTE | Registerkarte links aktivieren.
NACH-RECHTS-TASTE | Registerkarte rechts aktivieren.
Beliebige Pfeiltaste | Einen Ordner oder eine Datei im Hauptfensterbereich eines Dialogfeldes markieren, während sich der Fokus auf diesem Bereich befindet. Diese Funktion steht in den Dialogfeldern Neue Dokumentspezifikation, In WebDAV speichern und Aus WebDAV abrufen zur Verfügung. Weitere Informationen zum Dialogfeld Neue Dokumentspezifikation finden Sie unter Erstellen und Überprüfen von Spezifikationen. Weitere Informationen zu WebDAV finden Sie unter Öffnen einer vorhandenen Spezifikation aus WebDAV.
Anwendungstaste und auf Hinzufügen im Kontextmenü klicken | Eine benutzerdefinierte Eigenschaft in eine Spezifikation einfügen. Diese Funktion steht auf den Registerkarten Deklaration, Verweis, Namespace und Wörterbuch zur Verfügung, während eine Eigenschaft markiert ist.

Verwandtes Thema

BizTalk-Editor - Benutzeroberfläche


Datensätze, Felder und Eigenschaften

Der BizTalk-Editor stellt eine Spezifikation als eine Strukturansicht von Datensätzen und Feldern in einer vorgegebenen Reihenfolge dar. Innerhalb dieser Struktur können mithilfe von Datensätzen und Feldern Übergeordnet/Untergeordnet-Beziehungen erstellt werden. Datensätze können weitere Datensätze oder Felder enthalten, aber Felder können keine weiteren Felder oder Datensätze enthalten. Ein Datensatz ist immer ein Element, aber ein Feld kann entweder ein Element oder ein Attribut sein. Die Spezifikationsstruktur, die Datensätze und Felder als Knoten darstellt, stellt Ihnen eine einfache Möglichkeit bereit, alle Datensätze und Felder in einer Spezifikation anzuzeigen, zu erstellen, zu bearbeiten und zu löschen. Jeder Knoten in der Spezifikationsstruktur weist eine Zusammenstellung von Eigenschaftsdefinitionen auf, die auf sechs Registerkarten im Hauptfenster des BizTalk-Editors dargestellt sind: Deklaration, Verweis, Analysieren, Namespace, Wörterbuch und Codeliste. Die Daten auf diesen Registerkarten sind für den BizTalk-Editor erforderlich, um ein Dokument aus seinem ursprünglichen Format in XML zu übersetzen. Die Informationen definieren die Struktur des Dokuments, ob es sich um ein Dokument mit Feldern fester Breite oder mit Trennzeichen handelt, die Reihenfolge und Länge der Daten sowie deren Format.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Datensätze und ihre Eigenschaften

  • Felder und ihre Eigenschaften

  • Berechnen von Feldpositionen

  • Zeichenlängenbeschränkungen

  • Codelistenwerte und Beschreibungen

  • Auffüllzeichen

  • Eigenschaftsbereich

  • Zyklische Verweise

  • Integration von Standardwerten


Datensätze und ihre Eigenschaften

Je nach dem Typ der Spezifikation, die Sie erstellen, müssen Sie möglicherweise Datensätze hinzufügen und/oder entfernen. Nach dem Hinzufügen von Datensätzen zu einer Spezifikation müssen Eigenschaften angegeben werden. Beim Entfernen eines Datensatzes werden dessen Eigenschaften ebenfalls entfernt, zusammen mit allen untergeordneten Datensätzen und Feldern.

Wenn Ihre Spezifikation auf X12 oder EDIFACT basiert, können Sie nur Datensätze des Typs hinzufügen, der im betreffenden Standard vorhanden ist, jedoch können Sie beliebige Datensätze oder auch alle entfernen. Wenn Sie eine Spezifikation erstellen, die auf einer leeren Spezifikation basiert, müssen Sie Datensätze hinzufügen. In einigen Fällen, z. B. beim Erstellen einer Spezifikation, die auf einer vorhandenen Spezifikation basiert, müssen Sie möglicherweise Datensätze hinzufügen und entfernen.

Beim Hinzufügen oder Einfügen eines Datensatzes können Sie sofort mit der Eingabe zum Umbenennen des Datensatzes beginnen. Sie können den Namen eines vorhandenen Datensatzes und dessen Eigenschaften bearbeiten, indem Sie den Datensatz auswählen und ihn entsprechend bearbeiten.

Wenn Sie in eine Spezifikation einen Datensatz einfügen, dessen Name mit dem Namen eines bereits vorhandenen Datensatzes identisch ist, wird an das Ende des Namens des eingefügten Datensatzes eine Zahl angefügt.

Informationen zum das Erstellen einer neuen Instanz eines vorhandenen Datensatzes finden Sie unter Erstellen einer neuen Instanz eines vorhandenen Datensatzes. Informationen zum Erstellen eines zyklischen Verweises finden Sie unter Erstellen von zyklischen Verweisen.

Verwandte Themen

Erstellen einer neuen Instanz eines vorhandenen Datensatzes

Erstellen von zyklischen Verweisen

Eigenschaftsbereich

Festlegen von Eigenschaften für Datensätze und Felder


Felder und ihre Eigenschaften

Je nach dem Typ der Spezifikation, die Sie erstellen, müssen Sie möglicherweise Datensätze hinzufügen und/oder entfernen. Felder entsprechen EDI-Elementen (Electronic Data Interchange). Nach dem Hinzufügen von Feldern zu einer Spezifikation, einschließlich EDI-Dokumenten, müssen Sie Eigenschaftswerte angeben.

Wenn Ihre Spezifikation auf X12 oder EDIFACT basiert, können Sie nur Felder des Typs hinzufügen, der im betreffenden Standard vorhanden ist, jedoch können Sie beliebige Felder oder auch alle entfernen. Wenn Sie eine Spezifikation erstellen, die auf einer leeren Spezifikation basiert, müssen Sie Felder hinzufügen. Unabhängig vom Dokumenttyp, können die Eigenschaften jedes Feldes geändert werden.

Wenn Sie ein neues Feld zu einer Spezifikation hinzufügen oder es in diese einfügen, ist die Typ-Eigenschaft, die sich auf der Registerkarte Deklaration befindet, standardmäßig auf Attribut festgelegt. Sie können diesen Wert für jedes Feld manuell in Element ändern. Informationen zum das Erstellen von neuen Feldern, bei denen die Typ-Eigenschaft standardmäßig auf Element festgelegt ist, finden Sie unter Erstellen eines neuen Feldes als Element.

Beim Hinzufügen oder Einfügen eines Feldes können Sie sofort mit der Eingabe zum Umbenennen des Feldes beginnen. Sie können den Namen eines vorhandenen Feldes und dessen Eigenschaften bearbeiten, indem Sie das Feld auswählen und es entsprechend bearbeiten.

Wenn Sie in eine Spezifikation ein Elementfeld einfügen, dessen Name mit dem Namen eines bereits vorhandenen Elementfeldes identisch ist, wird an das Ende des Namens des eingefügten Feldes eine Zahl angefügt. Wenn Sie in eine Spezifikation ein Feld mit demselben Namen wie dem eines vorhandenen gleichgeordneten Feldes einfügen (und beide Felder über denselben Typ-Wert verfügen), wird eine Zahl an das Ende des Namens des eingefügten Feldes angefügt. Weitere Informationen zu Typ-Werten finden Sie unter Festlegen von Deklarationseigenschaften. Informationen zum Erstellen einer neuen Instanz eines vorhandenen Elementfeldes finden Sie unter Erstellen einer neuen Instanz eines vorhandenen Elementfeldes.

Verwandte Themen

Erstellen eines neuen Feldes als Element

Erstellen einer neuen Instanz eines vorhandenen Elementfeldes

Eigenschaftsbereich

Festlegen von Deklarationseigenschaften

Festlegen von Eigenschaften für Datensätze und Felder


Berechnen von Feldpositionen

Der BizTalk-Editor kann die Anfangs- und Endpositionen für alle Felder in einem Datensatz mit Feldern fester Breite automatisch berechnen. Legen Sie zuerst auf der Registerkarte Deklaration für jedes Feld im Datensatz mit Feldern fester Breite einen Wert für Datentyp und einen Wert für Maximallänge fest. Klicken Sie anschließend mit der rechten Maustaste auf den Datensatz mit Feldern fester Breite, und klicken Sie dann im Kontextmenü auf Feldpositionen berechnen. Die Anfangs- und Endpositionen für die Felder im betreffenden Datensatz werden automatisch berechnet. Weitere Informationen finden Sie unter Automatisches Berechnen von Feldpositionen.

Die folgende Liste erläutert dieses Feature ausführlicher:

  • Wenn für die Felder in einem Datensatz mit Feldern fester Breite Anfangs- und Endpositionen angegeben sind, werden alle diese Angaben mit Ausnahme der Anfangsposition des ersten Feldes beim Berechnen der Feldpositionen überschrieben.

  • Beim Berechnen von Feldpositionen wird die Anfangsposition des ersten Feldes eines Datensatzes mit Feldern fester Breite auf 1 festgelegt, es sei denn, für das Feld war zuvor ein Wert für Anfangsposition festgelegt worden. Wenn für das erste Feld eines Datensatzes mit Feldern fester Breite bereits ein Wert für Anfangsposition festgelegt wurde, beginnt die Berechnung ausgehend von diesem Wert.

  • Die Feldpositionsberechnung berücksichtigt bei der Berechnung von Feldpositionen den Quelltagbezeichner. Betrachten Sie beispielsweise einen Datensatz mit Feldern fester Breite mit den folgenden Eigenschaften: der Quelltagbezeichner ist TAG; die Quelltagposition ist 10; es existieren vier Felder mit den Werten 2, 5, 8 und 6 für Maximallänge; und für das erste Feld ist kein Wert für Anfangsposition festgelegt. Die Anfangs- und Endpositionen der vier Felder sind: Feld 1 = 1, 2; Feld 2 = 3, 7; nicht verwendet = 8, 9; TAG = 10, 12; Feld 3 = 13, 20; und Feld 4 = 21, 26. Wenn Quelltagposition den Wert 1 gehabt hätte, wären die Anfangs- und Endpositionswerte von TAG 1 und 3, und der Feldzähler hätte bei Position 4 begonnen.

  • Die Feldpositionen eines Datensatzes werden vom ersten Feld im Datensatz der Reihe nach bis zum letzten Feld berechnet. Wenn beim Berechnen von Feldpositionen ein Feld festgestellt wird, für dessen Maximallänge-Eigenschaft kein Wert festgelegt ist, werden Anfangs- und Endposition für dieses Feld und alle nachfolgenden Felder des Datensatzes nicht berechnet.

  • Wenn beim Berechnen von Feldpositionen ein gleichgeordneter Datensatz festgestellt wird, werden die Anfangs- und Endpositionen aller auf den gleichgeordneten Datensatz folgenden Felder nicht berechnet.

  • Die Anfangs- und Endpositionen eines Feldes mit dem Wert 1 für Maximallänge sind gleich.

  • Beim Berechnen von Feldpositionen für einen Datensatz mit Feldern fester Breite werden die Positionen von Feldern, die in abgeleiteten Datensätzen enthalten sind, ebenfalls berechnet. Die Positionen von gleichgeordneten Felder, die vor einem Datensatz auftreten, werden berechnet, Positionen gleichgeordneter Felder, die nach einem Datensatz auftreten, werden hingegen nicht berechnet.

Verwandte Themen

Automatisches Berechnen von Feldpositionen


Zeichenlängenbeschränkungen

Es existieren Beschränkungen für die Anzahl der Zeichen, die Sie in Namen und Eigenschaftswerten verwenden können. Die folgende Tabelle zeigt die Zeichenbeschränkungen im BizTalk-Editor.

Name oder Eigenschaftswert | Maximale Anzahl von Zeichen
Knotenname (der Name eines Stammknotens, eines Datensatzes oder eines Feldes) | 255
Namespacepräfix | 64
Zeichenfolgen-Eigenschaftswert | 1024
LONG-Eigenschaftswert | 11
ULONG-Eigenschaftswert | 10
CHAR-Eigenschaftswert | 1
Eigenschaftswert für EDI-Formate (Electronic Date Interchange) (der Wert einer EDI-spezifischen Formateigenschaft, wie z. B der Eigenschaftswert Benutzerdefiniertes Datum/Zeitformat auf der Registerkarte Analysieren für ein Feld in einer auf EDI basierenden Spezifikation) | 15
Zielnamespace+Spezifikationsname | 255


Codelistenwerte und Beschreibungen

Die auf der Registerkarte Codeliste enthaltenen Informationen geben X12- oder EDIFACT-Codewerte und ihre Beschreibungen an. Die Beschreibungen definieren die Bedeutung jedes Codes. Beispielsweise bedeutet der Codewert ST im Feld Address Qualifier Code vieler Standarddokumentspezifikationen, dass die angegebenen Informationen sich auf eine Versandadresse beziehen. Die Codes in der Liste können weder geändert noch gelöscht werden. Sie können lediglich wählen, ob ein bestimmter Code einem Feld zugeordnet werden soll oder nicht.

Nur Spezifikationen, die auf einem X12- oder EDIFACT-Standard basieren, verfügen über Codelisten. Jedoch sind nicht allen Feldern in einer Spezifikation, die auf X12 oder EDIFACT basiert, Codes zugeordnet. Eine vollständige Liste der für ein bestimmtes Feld verfügbaren Codes wird auf der Registerkarte Codeliste angezeigt, wenn das Feld einen Codelistenverweis enthält. Codes sind für ein Feld gültig, wenn das Kontrollkästchen in der Werte-Spalte neben dem Code aktiviert ist. Eine Beschreibung des Codes wird in der Beschreibung-Spalte angezeigt.

Sie können die einem Feld zugeordneten Codes ein- oder ausschließen, indem Sie die Kontrollkästchen in der Werte-Spalte neben dem auf der Registerkarte Codeliste aufgelisteten Code aktivieren oder deaktivieren. Codes werden nach numerischen oder alphabetischen Werten oder anhand einer Kombination von numerischen und alphabetischen Werten aufgelistet. Der Wert stellt eine bestimmte Beschreibung dar. Sie können jedem beliebigen Feld in der Spezifikationsstruktur einen Codewert zuordnen. Beispielsweise können Sie im Feld BEG02 eines X12 850-Auftrags den Code OS auswählen, der zu dem Feld BEG02 ein Attribut hinzufügt, das anzeigt, dass das Feld besondere Auftragsinformationen enthält.

Codelistenwerte und Beschreibungen für die auf EDI basierenden Spezifikationsvorlagen, die in BizTalk Server zur Verfügung stehen, befinden sich in der Microsoft Access-Datenbankdatei unter dem Pfad \Programme\Microsoft BizTalk Server\XML Tools\Databases\CodeLists\CodeListsX12a.mdb. Wenn Sie in dieser Datenbank neue Tabellen für neue Spezifikationsvorlagen erstellen, ist das Format für den Tabellennamen standard_version. Beispielsweise ist für eine D99A EDIFACT-Spezifikationsvorlage der entsprechende Tabellenname EDIFACT_D99A.

Wichtig

  • Wenn Sie in der CodeListsX12a.mdb-Datenbank eine neue Tabelle erstellen, verwenden Sie keine ungültigen XML-Zeichen (Extensible Markup Language) (Unicode-Zeichen im Bereich F900 bis FFFE) in der Werte-Spalte der Tabelle. Wenn Sie eine Spezifikation speichern, die ein Feld mit einem ausgewählten Codelistenwert enthält, der einem Wert in einer Tabelle mit einem ungültigen XML-Zeichen zugeordnet ist, können Sie die Spezifikation nicht öffnen.

Wenn Sie einen Code einem Feld zuordnen, muss der Wert Typ auf der Registerkarte Deklaration auf Attribut festgelegt sein.

Anmerkung

  • Codelisten stehen nur für Spezifikationen zur Verfügung, die auf X12 oder EDIFACT basieren. Daher kann es geschehen, dass die Codeliste für ein bestimmtes Feld auf der Registerkarte Codeliste nicht mehr zur Verfügung steht, wenn Sie die Struktur einer auf X12 oder EDIFACT basierenden Spezifikation in CUSTOM ändern und diese anschließend wieder in X12 oder EDIFACT zurückändern. Wenn dies der Fall ist, speichern Sie die Spezifikation, und öffnen Sie diese anschließend erneut. Die Codeliste wird wieder auf der Registerkarte Codeliste für das entsprechende Feld angezeigt.

Verwandte Themen

Festlegen von Eigenschaften für Datensätze und Felder


Auffüllzeichen

Der BizTalk-Editor ermöglicht die Verwaltung von Auffüllzeichen in Dokumenten mit Trennzeichen, um sicherzustellen, dass Sie die erwartete Ausgabe erhalten. Da jedes Dokument mit Trennzeichen, das von BizTalk Server verarbeitet wird, in XML (Extensible Markup Language) übersetzt werden muss, bevor die Zuordnung stattfindet, müssen Sie sicherstellen, dass Ihre Dokumentspezifikation BizTalk Server anweist, wie Auffüllzeichen in Dokumentinstanzen mit Trennzeichen zu verarbeiten sind. Beispielsweise tritt in einer Dokumentinstanz mit Trennzeichen möglicherweise ein Feld wie das Folgende auf:

Gruen*****

Der Dateninhalt des Feldes ist Gruen, das Feld ist linksbündig, es existieren fünf Auffüllzeichen rechts neben dem Dateninhalt, und das Auffüllzeichen ist ein Sternchen.

Wenn Sie das Auffüllzeichen für das Feld nicht in der Spezifikation definieren, die dem Feld in der Dokumentinstanz entspricht, interpretiert BizTalk Server die fünf Sternchen als Teil des Dateninhalts des Feldes. Sie müssen überprüfen, ob die Eigenschaften auf der Registerkarte Analysieren für dieses Feld wie in der folgenden Tabelle festgelegt sind, um sicherzustellen, dass BizTalk Server die Auffüllzeichen in diesem Feld korrekt verarbeitet.

Eigenschaft | Wert
Blocksatz | Nach links
Auffüllzeichen | *
Minimallänge mit Auffüllzeichen | Legen Sie diesen Eigenschaftswert fest, wenn die Länge des Feldes in der Ausgabedokumentinstanz größer als oder gleich einer bestimmten Länge sein soll. BizTalk Server fügt Auffüllzeichen in das Feld ein, um die korrekte minimale Feldlänge in der Ausgabedokumentinstanz zu erreichen.

Sie können die Auffüllzeichen-Eigenschaft verwenden, um sicherzustellen, dass Auffüllzeichen in einem Feld aus einer an BizTalk Server versendeten Dokumentinstanz entfernt werden. Der Eigenschaftswert Minimallänge mit Auffüllzeichen stellt sicher, dass BizTalk Server in ein Feld in der Ausgabedokumentinstanz Auffüllzeichen einfügt, wenn dies gewünscht wird. Die Blocksatz-Eigenschaft zeigt an, auf welcher Seite des Felddateninhalts die Auffüllzeichen entfernt (aus der Eingabedokumentinstanz) oder eingefügt (in die Ausgabedokumentinstanz) werden. Schließende Auffüllzeichen werden zu einem Feld mit linksbündiger Ausrichtung hinzugefügt oder aus diesem entfernt, und führende Auffüllzeichen werden zu einem Feld mit rechtsbündiger Ausrichtung hinzugefügt oder aus diesem entfernt. Wenn die Auffüllzeichen-Eigenschaft für ein Feld nicht festgelegt ist, werden diesem Feld keine Auffüllzeichen hinzugefügt oder aus diesem entfernt.


Eigenschaftsbereich

Wenn Sie über zwei oder mehr Instanzen eines Datensatzes in einer Spezifikation verfügen, müssen die Werte bestimmter Eigenschaften für diese Instanzen identisch sein. Anders ausgedrückt ist der Bereich dieser Eigenschaften global. Der Bereich bestimmter Feldeigenschaften kann ebenfalls global sein, jedoch nur, wenn die Typ-Eigenschaft für das Feld auf Element festgelegt ist.

Beispielsweise sind alle Eigenschaften auf den Registerkarten Deklaration und Analysieren für mehrere Instanzen eines Datensatzes oder Feldes identisch. Wenn Sie eine Deklaration- oder Analysieren-Eigenschaft für eine Instanz eines Datensatzes oder Feldes ändern, ändert sich diese Eigenschaft automatisch auch für alle anderen Instanzen des betreffenden Datensatzes oder Feldes. Die Eigenschaften auf den Registerkarten Verweis und Wörterbuch weisen jedoch keinen globalen Bereich auf, daher können die Werte dieser Eigenschaften unabhängig für jede Instanz eines Datensatzes oder Feldes festgelegt werden. Codelisten beziehen sich nur auf Felder, und ihr Bereich ist nicht global.

Anmerkungen

  • Der Bereich eines Feldes kann nur global sein, wenn die Typ-Eigenschaft auf Element festgelegt ist.

  • Der Bereich eines Feldes, dessen Typ-Eigenschaft auf Attribut festgelegt ist, ist immer lokal.

  • Im BizTalk-Editor weisen nur ElementType-Deklarationen einen globalen Bereich auf. Wenn Sie ein Schema in den BizTalk-Editor importieren, das AttributeType-Deklarationen mit globalem Bereich enthält, und dieses Schema dann als Spezifikation speichern, wird der Bereich der AttributeType-Deklarationen automatisch in einen lokalen Bereich innerhalb der entsprechenden ElementType-Deklaration bzw. –Deklarationen umgewandelt.


Zyklische Verweise

Ein zyklischer Verweis in einer Spezifikation tritt auf, wenn ein Datensatz als Ableitung seiner selbst erstellt wird. Ein zyklischer Verweis kann nur auftreten, wenn der Wert der Standard-Eigenschaft auf der Registerkarte Verweis auf XML festgelegt ist. Der BizTalk-Editor stellt einen zyklischen Verweis durch ein Symbol dar Symbol "Zyklischer Verweis"

Die folgende Abbildung zeigt, wie ein zyklischer Verweis im BizTalk-Editor angezeigt wird.

Klicken Sie zum Vergrößern oder Verkleinern auf die Abbildung.

Die Anzahl der Zyklen-Eigenschaft wird auf der Registerkarte Deklaration angezeigt und bezieht sich lediglich auf einen zyklischen Knoten. Der Standardwert ist 1; der Maximalwert ist 7. Die Anzahl der Zyklen zeigt an, wie viele Zyklen unterhalb des Basisdatensatzes zur Verfügung stehen. Beispielsweise existiert in der vorhergehenden Abbildung eine Gesamtzahl von vier Ebenen für Datensatz1: drei aus der Zykluszahl 3 und eine aus dem Basisdatensatz. Wenn Sie diese Spezifikation im BizTalk-Mapper öffnen, werden alle vier Ebenen von Datensatz1 angezeigt. Ein Datensatz2 und Feld1 werden ebenfalls für jeden Datensatz1 angezeigt. Sie können auf jeder Ebene des Zyklus Verknüpfungen mit Knoten herstellen.

Es ist nicht möglich, Wörterbuch-Eigenschaftswerte für Felder festzulegen, die von einem zyklischen Knoten abgeleitet sind. Beispielsweise können Sie in der vorhergehenden Abbildung Wörterbuch-Eigenschaftswerte für Stamm/Datensatz1/Feld1 festlegen, nicht jedoch für die Verweise auf Feld1 im Zyklus unterhalb von Stamm/Datensatz1/Datensatz1.

Zyklische Verweise unterliegen den folgenden Einschränkungen:

  • Knoten in einem Zykluspfad (die Knoten, die zwischen dem ersten und dem letzten Datensatz eines zyklischen Verweises auftreten) können nicht an anderer Stelle in der Spezifikation auftreten.

  • Elemente auf einem Zykluspfad können nicht Quelle oder Ziel von Zieh-und-Ablegevorgängen oder von Ausschneide-und-Einfügevorgängen sein.

  • Zyklen können sich nicht überschneiden.

  • Der Stammdatensatz eines zyklischen Verweises kann nicht der Stammknoten der Spezifikation sein.

Wichtig

  • Die Minimalvorkommen-Eigenschaft auf der Registerkarte Verweis für den zyklischen Verweisknoten muss auf 0 festgelegt sein. Das Festlegen auf 1 bewirkt eine Endlosschleife.

Anmerkung

  • Wenn Sie ein Schema importieren, das einen zyklischen Verweis enthält, überprüft der BizTalk-Editor den zyklischen Verweis nicht automatisch auf Gültigkeit.

Verwandte Themen

Erstellen von zyklischen Verweisen

Eigenschaftsbereich


Integration von Standardwerten

Wenn eine Quellspezifikation ein Feld vom Typ Attribut enthält und eine eingehende Dokumentinstanz, die auf der Quellspezifikation basiert, dieses Feld nicht enthält, kann es sinnvoll sein, dass die Spezifikation einen Standardwert für das Feld zur Verfügung stellt. Um den Standardwert für ein Feld in einer Spezifikation festzulegen, markieren Sie das Feld in der Spezifikationsstruktur, und geben Sie auf der Registerkarte Deklaration einen numerischen Wert im Wertfeld für die Standardwert-Eigenschaft ein. Die Standardwert-Eigenschaft wird nur angezeigt, wenn die Typ-Eigenschaft auf Attribut festgelegt ist. Wenn eine eingehende Dokumentinstanz das Feld nicht enthält, wird der Standardwert für das Feld bereitgestellt. Wenn eine eingehende Dokumentinstanz das Feld enthält, wird der Standardwert ignoriert.


Namespaceunterstützung

Folgende Themen werden in diesem Abschnitt behandelt:

  • Namespacedeklarationen

  • Bewahren von Namespaces in importierten Dateien


Namespacedeklarationen

Namespaces, die in einer Spezifikation deklariert sind, werden auf der Registerkarte Namespace des BizTalk-Editors angezeigt. Die folgende Tabelle zeigt die Präfixe und Namespaces, die standardmäßig auf der Registerkarte Namespace angezeigt werden, wenn Sie eine Spezifikation im BizTalk-Editor öffnen. Diese Präfixe und Namespaces können nicht bearbeitet werden.

Präfix | Namespace
(Standard) | urn:schemas-microsoft-com:xml-data
b | urn:schemas-microsoft-com:BizTalkServer
d | urn:schemas-microsoft-com:datatypes

Anmerkungen

  • Der folgende Namespace wird von BizTalk Server nicht unterstützt:

    SOAP-ENC=http://schemas.xmlsoap.org/soap/encoding/

Sie können benutzerdefinierte Namespaces in einer Spezifikation deklarieren, indem Sie ein Namespacepräfix in der Präfix-Spalte und einen Namespace in der Uniform Resource Name-Spalte der Registerkarte Namespace eingeben. Der BizTalk-Editor überprüft nicht den Uniform Resource Name, den Sie für einen Namespace eingeben.

Darüber hinaus können Sie jedem beliebigen Datensatz und Feld eine benutzerdefinierte Anmerkung hinzufügen. Eine benutzerdefinierte Anmerkung besteht aus einem Präfix/Name-Paar und einem zugeordneten Wert. Die Syntax für ein Präfix/Name-Paar wird im folgenden Beispiel gezeigt:

präfix:name

Geben Sie ein Präfix/Name-Paar in der Eigenschaft-Spalte und einen Wert in der Werte-Spalte auf der Registerkarte Deklaration oder Verweis ein. Auf der Registerkarte Deklaration eingegebene Eigenschaftswerte weisen einen globalen Bereich auf, Eigenschaftswerte auf der Registerkarte Verweis besitzen einen lokalen Bereich. Weitere Informationen zu globalen und lokalen Bereichen finden Sie unter Eigenschaftsbereich. Weitere Informationen zum Hinzufügen benutzerdefinierter Anmerkungen finden Sie unter Hinzufügen von benutzerdefinierten Anmerkungen.

Verwandte Themen

Hinzufügen von benutzerdefinierten Anmerkungen

Deklarieren von Namespaces

Bewahren von Namespaces in importierten Dateien

Eigenschaftsbereich


Bewahren von Namespaces in importierten Dateien

Drei Dateitypen können in den BizTalk-Editor importiert werden: XDR-Schemas (XML-Data Reduced), wohlgeformte XML-Instanzen und Dokumenttypdefinitionen (DTDs). Der BizTalk-Editor behandelt vorhandene Namespaces und Präfix/Name-Paare für jeden Dokumenttyp unterschiedlich.

Importieren eines XDR-Schemas

Beim Importieren von XDR-Schemas werden vorhandene Namespaces in folgender Weise behandelt:

  • Namespacedeklarationen werden als benutzerdefinierte Namespaces beibehalten und unter den standardmäßigen Namespaces auf der Registerkarte Namespace angezeigt.

  • Benutzerdefinierte Namespacepräfixe (mit Ausnahme derjenigen, die den Eigenschaften Name und Typ zugeordnet sind) werden nur beibehalten, wenn der zugeordnete Namespace deklariert ist.

Anmerkung

  • Der BizTalk-Editor kann kein XDR-Schema importieren, das ein Namespacepräfix aufweist, das der Eigenschaft Name oder Typ zugeordnet ist.

Importieren einer wohlgeformten XML-Instanz

Beim Importieren einer wohlgeformten XML-Dokumentinstanz werden Namespacedeklarationen aus dem Dokument entfernt, und das Präfix-Namentrennzeichen wird von einem Doppelpunkt (:) in einen Unterstrich (_) geändert, so dass die ursprüngliche Absicht des Namespacepräfixes nicht verloren wird. Zum Beispiel:

präfix_name

Wichtig

  • Wenn Sie eine wohlgeformte XML-Dokumentinstanz importieren, die ein Namespacepräfix/Name-Paar enthält, die importierte Instanz anschließend als Spezifikation speichern und dann versuchen, die ursprüngliche Dokumentinstanz anhand der neuen Spezifikation zu überprüfen, schlägt die Überprüfung fehl. Löschen Sie in der neuen Spezifikation den Knoten, der das Präfix/Name-Paar enthält, und wählen Sie für den übergeordneten Datensatz des betreffenden Knotens (auf der Registerkarte Deklaration) für die Modell-Eigenschaft den Wert Offen aus. Speichern Sie die Spezifikation. Sie können die Dokumentinstanz anhand dieser Spezifikation überprüfen.

Anmerkung

  • Der BizTalk-Editor kann kein Dokument importieren, das ein Namespacepräfix enthält, wenn der zugeordnete Namespace nicht im Dokument deklariert wurde.

Importieren einer DTD

Beim Importieren einer DTD, die ein Präfix/Name-Paar enthält, wird das Trennzeichen aus einem Doppelpunkt (:) in einen Unterstrich (_) geändert. Dies geschieht, damit hinsichtlich der Platzierung in der Gesamtstruktur die ursprüngliche Absicht des Präfix nicht verloren wird, obwohl die Präfixnotation selbst nicht unterstützt wird. Zum Beispiel:

präfix_name

Verwandtes Thema

Namespacedeklarationen


Hinzufügen von SQL-Anmerkungen

Sie können für jeden beliebigen Knoten in einer Spezifikation eine SQL-Anmerkung angeben. Beim Angeben einer SQL-Anmerkung auf der Registerkarte Deklaration wird eine Anmerkung mit globalem Bereich erstellt. Die Anmerkung wird innerhalb der ElementType- oder AttributeType-Deklaration in der Spezifikation gespeichert. Beim Angeben einer SQL-Anmerkung auf der Registerkarte Verweis wird eine Anmerkung mit lokalem Bereich erstellt. Die Anmerkung wird innerhalb des Element- oder Attribut-Verweises in der Spezifikation gespeichert.

Sie können eine SQL-Anmerkung in der Liste auswählen, die angezeigt wird, wenn Sie auf ein leeres Feld in der Eigenschaft-Spalte auf der Registerkarte Deklaration oder Verweis für einen Knoten in einer Spezifikation doppelklicken. Geben Sie einen Wert für die SQL-Anmerkung im entsprechenden Feld in der Werte-Spalte ein. Für alle SQL-Anmerkungen mit Ausnahme von "sql:relationship" und "sql:xpath-query" stellt der Wert ein gewöhnliches Zeichenfolgendatum dar. Weitere Informationen zum Hinzufügen von SQL-Anmerkungen und anderer benutzerdefinierter Anmerkungen finden Sie unter Hinzufügen von benutzerdefinierten Anmerkungen.

Die folgende Liste zeigt alle im BizTalk-Editor möglichen SQL-Anmerkungen:

  • sql:datatype

  • sql:field

  • sql:id

  • sql:id-prefix

  • sql:is-constant

  • sql:key-fields

  • sql:limit-field

  • sql:limit-value

  • sql:map-field

  • sql:is-mapping-schema

  • sql:overflow-field

  • sql:relation

  • sql:relationship

  • sql:target-namespace

  • sql:url-encode

  • sql:use-cdata

  • sql:xpath-query

Der Wert von "sql:relationship" besteht in einem oder mehreren Name/Wert-Paar(en), und der Name in jedem der Name/Wert-Paare muss einer von vier Namen sein: key, key-relation, foreign-key oder foreign-relation. Der Wert von "sql:xpath-query" besteht aus zwei Teilen: der erste Teil besteht aus einem oder mehreren Name/Wert-Paar(en), das/die ein Attribut oder Attribute umfasst/umfassen, und der zweite Teil ist der Inhalt von "sql:xpath-query" in der Form "content=...". Diese beiden Teile sind durch das Gatterzeichen (#) getrennt.

Die folgende Tabelle zeigt gültige Beispiele der SQL-Anmerkungen "sql:relationship" und "sql:xpath-query".

SQL-Anmerkung | Beispielwerte
sql:relationship | key="KundenID"
sql:relationship | key-relation="Kund"
sql:relationship | foreign-key="KundenID"
sql:relationship | foreign-relation="Auftraege"
sql:xpath-query | mapping-schema="Schema.xml" #content=Mitarbeiter

Anmerkungen

  • Der BizTalk-Editor beschränkt die Auswahl von SQL-Anmerkungen nicht auf nur solche, die im aktuellen Kontext angemessen sind. Beispielsweise stehen "sql:relationship" und "xpath-query" auf der Registerkarte Deklaration zur Verfügung, obwohl ihre Verwendung nur auf der Registerkarte Verweis zulässig ist.

  • Beim Angeben einer SQL-Anmerkung wird automatisch ein Namespace mit einem Präfix sql und einem entsprechenden URN-Wert auf der Registerkarte Namespace deklariert.

  • Wenn Sie einen Knoten mit SQL-Anmerkungen auf der Registerkarte Verweis kopieren oder ausschneiden und diesen Knoten dann an einer anderen Stelle in der Spezifikation einfügen, sind die SQL-Anmerkungen im neuen Knoten nicht vorhanden.

Verwandte Themen

Hinzufügen von benutzerdefinierten Anmerkungen

Namespacedeklarationen

Eigenschaftsbereich


Ressourcen

Dieser Abschnitt enthält Informationen zu folgenden Themen:

  • Zusammenfassung der Datentypen und Datentypwerte

  • Zusammenfassungsliste der im Lieferumfang enthaltenen, auf EDI basierenden Dokumente


Zusammenfassung der Datentypen und Datentypwerte

Die folgende Liste stellt Detailinformationen und Beispiele bereit, die Sie beim Angeben eines Wertes für die Datentyp-Eigenschaft auf der Registerkarte Deklaration unterstützen sollen. Nach dem Auswählen einer der folgenden Optionen aus der Liste Datentyp müssen Sie möglicherweise einen Wert im Feld Datentypwerte eingeben.

Datentyp

Character

Enthält eine Zeichenfolge mit einer Länge von einem Zeichen.

StringString

Enthält beliebigen Text.

NumberNumber

Enthält eine Zahl mit Dezimalstellen und kann über ein Vorzeichen, Nachkommastellen und einen Exponenten verfügen. Es wird die standardmäßige englische Zeichensetzung verwendet; beispielsweise 15, 3.14, -123.456E+10.

Integer (int)Integer (int)

Enthält eine Zahl und kann ein optionales Vorzeichen umfassen. Es sind keine Bruchzahlen oder Exponenten möglich; beispielsweise, 1, 58502, -13.

FloatFloat

Enthält eine Zahl ohne Beschränkung der Stellen; kann möglicherweise ein Vorzeichen, Nachkommastellen oder einen Exponenten aufweisen.

Fixed Point (14.4)Fixed Point (14.4)

Gleich wie Number, kann jedoch nicht mehr als 14 Stellen links vom Dezimalpunkt und nicht mehr als 4 rechts davon enthalten; beispielsweise 12.0044. Dieser Datentyp kann für Währungswerte verwendet werden.

BooleanBoolean

Enthält einen Ausdruck, der entweder zu TRUE (1) oder zu FALSE (0) ausgewertet wird.

DateDate

Enthält ein Datum in einer Teilmenge des ISO 8601-Formats ohne Uhrzeitinformationen; beispielsweise 1988-04-07.

Date TimeDate Time

Enthält ein Datum in einer Teilmenge des ISO 8601-Formats mit optionalen Uhrzeit-, jedoch ohne optionale Zeitzoneninformationen. Sekundenbruchteile sind bis zum Nanosekundenbereich möglich; beispielweise, 1988-04-07T18:39:09.

Date Time.tzDate Time.tz

Enthält ein Datum in einer Teilmenge des ISO 8601-Formats mit optionalen Uhrzeit- und optionalen Zeitzoneninformationen; Sekundenbruchteile sind bis zum Nanosekundenbereich möglich; beispielsweise 1988-04-07T18:39:09-08:00.

TimeTime

Enthält eine Uhrzeit in einer Teilmenge des ISO 8601-Formats ohne Datums- und Zeitzoneninformationen; beispielsweise 08:15:27.

Time.tzTime.tz

Enthält eine Uhrzeit in einer Teilmenge des ISO 8601-Formats ohne Datums-, jedoch mit optionalen Zeitzoneninformationen; beispielsweise 08:15:27-05:00.

Byte (i1) Byte (i1)

Enthält eine Zahl und kann ein optionales Vorzeichen enthalten, wie z. B. ein Minuszeichen (-). Es sind keine Bruchzahlen oder Exponenten möglich; beispielsweise, 1, 127, -128.

Word (i2) Word (i2)

Enthält eine Zahl und kann ein optionales Vorzeichen enthalten, wie z. B. ein Minuszeichen (-). Es sind keine Bruchzahlen oder Exponenten möglich; beispielsweise, 1, 703, -32768.

Integer (i4) Integer (i4)

Enthält eine Zahl und kann ein optionales Vorzeichen enthalten, wie z. B. ein Minuszeichen (-). Es sind keine Bruchzahlen oder Exponenten möglich; beispielsweise 1, 703, -32768, 148343, -1000000000.

Double Integer (i8) Double Integer (i8)

Enthält eine Zahl und kann ein optionales Vorzeichen enthalten, wie z. B. ein Minuszeichen (-). Es sind keine Bruchzahlen oder Exponenten möglich; beispielsweise 1, 703, -32768, 148343, -1000000000.

Unsigned Byte (ui1) Unsigned Byte (ui1)

Enthält eine Zahl. Es sind keine Vorzeichen, Bruchzahlen oder Exponenten möglich; beispielsweise 1, 255.

Unsigned Word (ui2) Unsigned Word (ui2)

Enthält eine Zahl. Es sind keine Vorzeichen, Bruchzahlen oder Exponenten möglich; beispielsweise, 1, 255, 65535.

Unsigned Integer (ui4) Unsigned Integer (ui4)

Enthält eine Zahl. Es sind keine Vorzeichen, Bruchzahlen oder Exponenten möglich; beispielsweise, 1, 703, 3000000000.

Unsigned Double Integer (ui8) Unsigned Double Integer (ui8)

Enthält eine Zahl. Es sind keine Vorzeichen, Bruchzahlen oder Exponenten möglich; beispielsweise, 1, 703, 3000000000.

Real (r4)Real (r4)

Enthält eine Zahl mit einem Mindestwert von 1.17549435E-38F und einem Höchstwert von 3.40282347E+38F; beispielsweise 3.14285718E+2.

Double Real (r8)Double Real (r8)

Enthält eine Zahl mit einem Mindestwert von 2.2250738585072014E308 und einem Höchstwert von 1.7976931348623157E+308; beispielsweise .314159265358979E+1.

Universal Unique Identifier (uuid)Universal Unique Identifier (uuid)

Enthält hexadezimale Stellen, die Bytes darstellen, mit optionalen eingebetteten Trennstrichen, die ignoriert werden können; beispielsweise 333C7BC4-460F-11D0-BC04-0080C7055A83.

Uniform Resource Identifier (uri)Uniform Resource Identifier (uri)

Enthält einen URI (Uniform Resource Identifier).

Binary (base64)Binary (base64)

Enthält eine binäre Codierung von binärem Text in Zeichen; beispielsweise die Konvertierung einer GIF-Grafik (Graphic Interchange Format) in eine Textdarstellung.

Binary (hex)Binary (hex)

Enthält eine binäre hexadezimale Stelle, die Bytes darstellt; beispielsweise 0x0ffaa.

IDID

Gibt das Feld als ID an.

IDREFIDREF

Gibt an, dass das Feld auf das Feld verweist, das den ID-Wert enthält.

IDREFSIDREFS

Gibt an, dass das Feld eine Liste von IDs enthält, durch Leerzeichen getrennt.

EnumerationEnumeration

Weist einer Reihe von Werten eine Ordinalreihenfolge zu; beispielsweise können Montag, Dienstag, Mittwoch als 1 2 3 aufgezählt werden.

Anmerkung

  • Der Fixed Point (14.4)-Datentyp kann für Währungswerte verwendet werden.

Verwandtes Thema

Festlegen von Deklarationseigenschaften


Zusammenfassungsliste der im Lieferumfang enthaltenen, auf EDI basierenden Dokumente

Der BizTalk-Editor unterstützt alle auf EDI basierenden Dokumente. Die folgende Tabelle listet die beim Erstellen einer neuen, auf einem Standard basierenden Spezifikation zur Verfügung stehenden Standardspezifikationen, Versionen und Dokumentstandards für auf EDI basierende Dokumente auf. Weitere Informationen finden Sie unter Erstellen einer Spezifikation auf der Basis eines Standards.

Standard Version Dokumentstandards
X12
  • 2040

  • 3010

  • 3060

  • 4010
  • 810

  • 832

  • 846

  • 850

  • 852 (in allen Versionen mit Ausnahme von 2040 verfügbar)

  • 855

  • 856

  • 861

  • 864

  • 867

  • 940 (nur zusammen mit den Versionen 3060 und 4010 verfügbar)

  • 944 (nur zusammen mit den Versionen 3060 und 4010 verfügbar)

  • 997
EDIFACT
  • D93A

  • D95A

  • D95B

  • D97B

  • D98A

  • D98B
  • APERAK (in allen Versionen mit Ausnahme von D93A verfügbar)

  • CONTRL (nur zusammen mit den Versionen D98A und D98B verfügbar)

  • DESADV

  • INVOIC

  • INVRPT

  • ORDERS

  • ORDRSP

  • PARTIN

  • PAYEXT

  • PRICAT

  • PRODAT (nur zusammen mit den Versionen D97B, D98A und D98B verfügbar)

  • RECADV (nur zusammen mit den Versionen D97B, D98A und D98B verfügbar)

  • SLSRPT
XML
  • N/V
  • Standardvorausversandanzeige

  • Standardlagerhaltungsanzeige

  • Standardrechnung

  • Standardgeschäftspartnerprofil

  • Standardauftrag

  • Standardauftragsbestätigung

  • Standardpreiskatalog

  • Standardversandanzeige

  • Standardversandauftrag

  • Standardempfangsbestätigung

  • Einfacher SOAP-Umschlag

  • BTF1-Umschlag

Verwandtes Thema

Erstellen einer Spezifikation auf der Basis eines Standards


Zuordnen von Daten

Der BizTalk-Mapper ist ein Konvertierungstool, mit dem Sie eine Entsprechung zwischen den Datensätzen und Feldern in zwei verschiedenen Spezifikationsformaten herstellen können. Der BizTalk-Mapper verwendet Verknüpfungen und Funktoide, um diese Konvertierung auszuführen. Funktoide führen Operationen aus, die von einfachen Berechnungen bis zur Erstellung komplexer Skripts reichen. Mithilfe des BizTalk-Mappers können Sie die strukturellen Transformationsbeziehungen zwischen Datenelementen der Quell- und der Zielspezifikation grafisch darstellen. Diese Querverweis- und Datenbearbeitungsfunktionalität erstellt eine Zuordnung, die einen Anweisungssatz bereitstellt, mit dem die Beziehung zweier verschiedener Spezifikationsformate definiert wird. Die Spezifikationsformate werden mithilfe des BizTalk-Editors definiert.

Eine Zuordnung repräsentiert Datentransformationen zwischen einer Quellspezifikation und einer Zielspezifikation. Microsoft BizTalk Server 2000 und die Komponente Extensible Stylesheet Language (XSL) von Microsoft XML Parser, Version 3.0, verwenden die Laufzeitinformationen zur Datentransformationen, die eine Zuordnung zur Verfügung stellt. Wenn Sie eine Zuordnung erstellen, können die Transformationsinformationen auf der BizTalk-Mapper-Registerkarte Ausgabe angezeigt werden.

Der BizTalk-Mapper ermöglicht den offenen Austausch von Spezifikationen im XML-Datenformat (Extensible Markup Language). Der BizTalk-Mapper kann nur die Spezifikationen öffnen, die im BizTalk-Editor gespeichert wurden. Im BizTalk-Mapper können keine allgemeinen nicht auf XML- oder XML basierende Dateien geöffnet werden. Wenn Sie zwei allgemeine XML-Dateien konvertieren möchten, müssen Sie diese zuvor in den BizTalk-Editor importieren und als Spezifikationen speichern.

Der BizTalk-Mapper unterstützt eine Vielzahl von Zuordnungsszenarien, die von einfachen Strukturbeziehungen mit über- und untergeordneten Elementen bis zu detaillierten, komplexen Schleifen aus Datensätzen und Hierarchien reichen. Nach Abschluss des Zuordnungsprozesses verwendet eine Serialisierungskomponente die Spezifikation, um ein Dateiformat zu erstellen, das vom Handelspartner oder einer internen Anwendung erkannt wird. Der BizTalk-Mapper bietet auch eine Kompilierungskomponente für Stylesheets, die aus der visuellen Darstellung der Zuordnung ein XSL-Stylesheet erstellt.

Die folgende Abbildung veranschaulicht das Zuordnen einer Quell- zu einer Zielspezifikation. Die Quelldatei ist ein auf EDI basierendes Dokument und die Zieldatei ein Flatfiledokument. In diesem Beispiel wird die EDI-Dokumentstruktur in ein XML-Zwischenformat konvertiert, dessen Struktur in einer XML-Data Reduced-Spezifikation (XDR) abgebildet wird. Das endgültige Format der Datei ist eine Flatfile. Ein datengesteuerter Parser (der die XDR-Spezifikation verwendet) erstellt eine XML-Version der EDI-Quellspezifikation. Das XSL-Modul transformiert anschließend diese XML-Quelldarstellung in eine XML-Darstellung des Zieldateiformats. Die Zielspezifikation wird schließlich in das systemeigene Format der Zieldatei serialisiert. Diese ist in diesem Beispiel eine Flatfile.

Transformieren eines EDI-Dokumentes in ein Flatfiledokument
XDR-
Spezifikation
XDR-
Spezifikation
XSLT Zuordnung
XSL-Modul
EDI nach Flatfile
Serialisierer
Datenparser
XML-Dokument
EDI-Dokument
XML-Dokument
Flatfiledokument
  • Hilfe zu bestimmten Aufgaben finden Sie unter Verfahrensweise.

  • Allgemeine Hintergrundinformationen finden Sie unter Grundbegriffe.

  • Weitere Ressourcen finden Sie unter Ressources.

  • Anleitungen zum Beheben von Problemen finden Sie unter Problembehandlung - BizTalk-Editor und BizTalk-Mapper.

Verwandtes Thema

BizTalk-Mapper - Benutzeroberfläche


Verfahrensweise

Dieser Abschnitt stellt aufgabenspezifische Informationen zum Zuordnen von Daten von einer Spezifikation zu einer anderen Spezifikationbereit. Es wird dringend empfohlen, dass Sie den Abschnitt Grundbegriffe lesen, um Verknüpfungen und Funktoiden sowie andere Eigenschaften und Funktionalität der Zuordnung vollständig zu verstehen.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Ändern der Optionen für den BizTalk-Mapper

  • Erstellen neuer Zuordnungen

  • Öffnen von Zuordnungen

  • Speichern und Schließen von Zuordnungen

  • Ersetzen von Spezifikationen

  • Verwalten von Funktoiden

  • Verwalten von Verknüpfungen

  • Erstellen und Verwalten von kompilierten Zuordnungen

  • Testen von Zuordnungen

  • Verwalten von Ansichten

  • Anpassen der Benutzeroberfläche


Ändern der Optionen für den BizTalk-Mapper

Im Dialogfeld Optionen für den BizTalk-Mapper können Sie allgemeine Optionen festlegen und Farben für das Zuordnungsraster wählen.

  • Klicken Sie im Menü Extras auf Optionen, um das Dialogfeld Optionen für den BizTalk-Mapper aufzurufen. Standardmäßig wird zuerst die Registerkarte Allgemein angezeigt.

Weitere Informationen zur Verwendung des Dialogfeldes Optionen für den BizTalk-Mapper finden Sie unter den folgenden Verfahren:

  • Optionen für den BizTalk-Mapper: Registerkarte "Allgemein"

  • Optionen für den BizTalk-Mapper: Registerkarte "Farben"


Optionen für den BizTalk-Mapper: Registerkarte "Allgemein"

Weitere Informationen zum Zugriff auf das Dialogfeld Optionen für den BizTalk-Mapper finden Sie unter Ändern der Optionen für den BizTalk-Mapper.

Die Registerkarte Allgemein stellt sechs Optionen bereit, mit deren Hilfe Sie das Verhalten des BizTalk-Mappers benutzerdefiniert festlegen können.

  • Warnungen für einfache Verknüpfungsfehler (als Standardeinstellung ausgewählt). Sie erhalten eine Warnung, wenn Sie versuchen, eine Verknüpfung zwischen Knoten zu erstellen, deren Datentypen nicht zusammenpassen.

  • Compilerverknüpfungen anzeigen (als Standardeinstellung ausgewählt). Compilerverknüpfungen werden nach dem Kompilieren in einer Verknüpfung angezeigt.

  • Compilerverknüpfungen nach Benutzeraktion löschen (als Standardeinstellung deaktiviert). Compilerverknüpfungen werden nicht mehr angezeigt, nachdem im BizTalk-Mapper eine Aktion ausgeführt wurde.

  • Verknüpfungen von Datensatzinhalten zulassen (als Standardeinstellung deaktiviert). Inhaltsverknüpfungen von Datensätzen zu Funktoiden können erstellt werden.

    Anmerkung

    • Bestimmte Funktoide arbeiten mit Ein- und/oder Ausgabe, die keinen Datensatzinhalt verwendet. Die Option Verknüpfungen von Datensatzinhalten zulassen hat in diesem Fall keine Auswirkung. Diese Ein- und Ausgabe besteht aus den logischen Funktoiden (Ausgabe): dem Funktoid Anzahl der Datensätze (Eingabe), dem Funktoid Iteration (Eingabe) und dem Funktoid Schleife (Eingabe und Ausgabe).
  • Mehrere Eingaben in Zielstrukturknoten zulassen (als Standardeinstellung deaktiviert). Zwei oder mehr Verknüpfungen können zu einem Knoten in der Verzeichnisstruktur der Zielspezifikation eingerichtet werden.

  • Vor dem Testen der Zuordnung zum Speichern auffordern (als Standardeinstellung aktiviert) Nachdem Sie im Menü Extras auf Zuordnung testen geklickt haben, zeigt der BizTalk-Mapper ein Dialogfeld an, das Sie fragt, ob Sie die Änderungen an Ihrer Zuordnungsdatei speichern möchten.

Verwandtes Thema

Optionen für den BizTalk-Mapper: Registerkarte "Farben"


Optionen für den BizTalk-Mapper: Registerkarte "Farben"

Weitere Informationen zum Zugriff auf das Dialogfeld Optionen für den BizTalk-Mapper finden Sie unter Ändern der Optionen für den BizTalk-Mapper.

Die Registerkarte Farben stellt Optionen bereit, mit denen Sie die Farben im Zuordnungsraster anpassen können. Weitere Informationen zu diesen Optionen finden Sie unter den folgenden Verfahren:

  • Ändern der Farben des Zuordnungsrasters

  • Ändern der Farbe von Verknüpfungen

  • Ändern der Farbe von ausgewählten Objekten

  • Ändern der Farbe von Compilerwarnungen

  • Wiederherstellen der Standardfarben

Verwandtes Thema

Optionen für den BizTalk-Mapper: Registerkarte "Allgemein"


Erstellen neuer Zuordnungen

  1. Klicken Sie im Menü Datei auf Neu.

    Das Dialogfeld Quellspezifikationstyp auswählen wird angezeigt.

  2. Doppelklicken Sie auf eine der folgenden Optionen:
    • Lokale Dateien, und gehen Sie zu Schritt 3.

    • Vorlagen, und gehen Sie zu Schritt 4.

    • WebDAV-Dateien, und gehen Sie zu Schritt 3.
  3. Gehen Sie zu dem Ordner, der die Quellspezifikation enthält, die Sie öffnen möchten, und gehen Sie zu Schritt 5.

  4. Klicken Sie auf EDIFACT, X12 oder XML, und klicken Sie auf OK.

    Wenn Sie EDIFACT oder X12 auswählen, müssen Sie auch die Version wählen, die Sie verwenden möchten. Klicken Sie auf den Ordner für die Version, die Sie verwenden möchten, klicken Sie auf OK, und gehen Sie dann zu Schritt 5.

  5. Wählen Sie die Quellspezifikation aus, und klicken Sie auf Öffnen bzw. OK.

    Das Dialogfeld Zielspezifikationstyp auswählen wird angezeigt.

  6. Doppelklicken Sie auf eine der folgenden Optionen:
    • Lokale Dateien, und gehen Sie zu Schritt 7.

    • Vorlagen, und gehen Sie zu Schritt 8.

    • WebDAV-Dateien, und gehen Sie zu Schritt 7.
  7. Gehen Sie zu dem Ordner, der die Zielspezifikation enthält, die Sie öffnen möchten, und gehen Sie zu Schritt 9.

  8. Klicken Sie auf EDIFACT, X12 oder XML, und klicken Sie auf OK.

    Wenn Sie EDIFACT oder X12 auswählen, müssen Sie auch die Version wählen, die Sie verwenden möchten. Klicken Sie auf den Ordner für die Version, die Sie verwenden möchten, klicken Sie auf OK, und gehen Sie dann zu Schritt 9.

  9. Wählen Sie die Zielspezifikation aus, und klicken Sie auf Öffnen bzw. OK.

Anmerkung

  • Um eine Zuordnung zu erstellen, müssen Sie sowohl eine Quell- als auch eine Zielspezifikation angeben.

Verwandte Themen

Ersetzen von Zielspezifikationen

Ersetzen von Quellspezifikationen


Öffnen von Zuordnungen

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Öffnen von Zuordnungen von einer lokalen Festplatte

  • Abrufen von Zuordnungen aus WebDAV


Öffnen von Zuordnungen von einer lokalen Festplatte

  1. Klicken Sie im Menü Datei auf Öffnen.

    Das Dialogfeld Zuordnungsquelle öffnen wird angezeigt.

  2. Gehen Sie zu dem Ordner, der die Zuordnung enthält, die Sie öffnen möchten.

  3. Klicken Sie auf eine Zuordnung in der Liste, und klicken Sie auf Öffnen.

Verwandtes Thema

Abrufen von Zuordnungen aus WebDAV


Abrufen von Zuordnungen aus WebDAV

  1. Klicken Sie im Menü Datei auf Aus WebDAV abrufen.

    Das Dialogfeld Aus WebDAV abrufen wird angezeigt.

  2. Klicken Sie in der Liste Server auf einen Servernamen.

  3. Gehen Sie zu dem Ordner, der die Zuordnung enthält, die Sie abrufen möchten, und klicken Sie auf Öffnen.

Anmerkungen

  • Wenn Sie zum ersten Mal eine Verbindung zu einem Remote-WebDAV-Server herstellen, wird sich der Vorgang möglicherweise etwas verzögern.

  • Damit Sie eine Zuordnung in WebDAV abrufen können, müssen Sie über die Berechtigung verfügen, von dem Server Dateien abzurufen.

Verwandte Themen

Öffnen von Zuordnungen von einer lokalen Festplatte

Problembehandlung - BizTalk-Editor und BizTalk-Mapper


Speichern und Schließen von Zuordnungen

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Speichern von neuen Zuordnungen

  • Speichern von vorhandenen Zuordnungen

  • Speichern von kompilierten Zuordnungen

  • Speichern von Zuordnungen

  • Schließen von Zuordnungen


Speichern von neuen Zuordnungen

  1. Klicken Sie im Menü Datei auf Speichern unter.

    Das Dialogfeld Zuordnungsquelle speichern unter wird angezeigt.

  2. Geben Sie im Feld Dateiname einen Namen für die Zuordnung ein.

  3. Klicken Sie in der Liste Codierung auf UTF-8 oder Unicode, und klicken Sie auf Speichern.

    Wenn Sie eine Spezifikation verwenden wollen, die mit ASCII-Zeichen zugewiesen ist, klicken Sie auf UTF-8. Für Spezifikationen, die mit Doppelbyte-Zeichensätzen zugewiesen sind, klicken Sie auf Unicode.

Anmerkungen

  • Wenn Sie eine Zuordnung speichern, kompiliert der BizTalk-Mapper diese automatisch. Sie können die Ergebnisse der kompilierten Zuordnung auf der Registerkarte Ausgabe anzeigen.

  • Wenn Sie eine Zuordnung speichern, speichert der BizTalk-Mapper die Zuordnung auf Ihrer Festplatte. Um eine Zuordnung in WebDAV zu speichern, müssen Sie über die Berechtigung verfügen, Dateien auf dem Server zu speichern.

Verwandtes Thema

Speichern von Zuordnungen


Speichern von vorhandenen Zuordnungen

  • Klicken Sie im Menü Datei auf Speichern.

Anmerkungen

  • Wenn Sie eine Zuordnung speichern, kompiliert der BizTalk-Mapper diese automatisch. Sie können die Ergebnisse der kompilierten Zuordnung auf der Registerkarte Ausgabe anzeigen.

  • Wenn Sie eine Zuordnung speichern, speichert der BizTalk-Mapper die Zuordnung auf Ihrer Festplatte. Um eine Zuordnung in WebDAV zu speichern, müssen Sie über die Berechtigung verfügen, Dateien auf dem Server zu speichern.

Verwandtes Thema

Speichern von Zuordnungen


Speichern von kompilierten Zuordnungen

  1. Klicken Sie im Menü Datei auf Kompilierte Zuordnung speichern unter.

    Das Dialogfeld Kompilierte Zuordnung speichern unter wird angezeigt.

  2. Geben Sie im Feld Dateiname einen Namen für die Datei ein, und klicken Sie auf Speichern.

Verwandtes Thema

Speichern von Zuordnungen


Speichern von Zuordnungen

  1. Klicken Sie im Menü Datei auf In WebDAV speichern.

    Das Dialogfeld In WebDAV speichern wird angezeigt.

  2. Klicken Sie in der Liste Server auf einen Servernamen.

  3. Gehen Sie zu dem Ordner, in dem Sie Ihre Zuordnung speichern möchten, und geben Sie in das Feld Dateiname den Namen der Datei ein.

  4. Klicken Sie in der Liste Codierung auf UTF-8 oder Unicode, und klicken Sie auf Speichern.

    Wenn Sie eine Spezifikation verwenden möchten, die mit ASCII-Zeichen zugewiesen ist, klicken Sie auf UTF-8. Für Spezifikationen, die mit Doppelbyte-Zeichensätzen zugewiesen sind, klicken Sie auf Unicode.

Wichtig

  • Sie können Dateien deren Dateinamen Doppelbyte-Zeichensätze enthalten, nicht speichern, wenn Ihre Ländereinstellung nicht korrekt ist. Weitere Informationen finden Sie unter Im WebDAV-Dialogfeld wird "???.xml" angezeigt.

Anmerkungen

  • Wenn Sie zum ersten Mal eine Verbindung zu einem Remote-WebDAV-Server herstellen, wird sich der Vorgang möglicherweise etwas verzögern.

  • Damit Sie eine Zuordnung in WebDAV speichern können, müssen Sie über die Berechtigung verfügen, auf dem Server Dateien zu speichern.

Verwandtes Thema

Problembehandlung - BizTalk-Editor und BizTalk-Mapper


Schließen von Zuordnungen

  • Klicken Sie im Menü Datei auf Schließen.


Ersetzen von Spezifikationen

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Ersetzen von Quellspezifikationen

  • Ersetzen von Zielspezifikationen


Ersetzen von Quellspezifikationen

  1. Klicken Sie im Menü Bearbeiten auf Quellspezifikation ersetzen.

    Wenn Sie Ihre Zuordnung nicht gespeichert haben, werden Sie aufgefordert, die Änderungen an der Zuordnungsquelle zu speichern.

    Das Dialogfeld Quellspezifikationstyp auswählen wird angezeigt.

  2. Doppelklicken Sie auf eine der folgenden Optionen:
    • Lokale Dateien, und gehen Sie zu Schritt 3.

    • Vorlagen, und gehen Sie zu Schritt 4.

    • WebDAV-Dateien, und gehen Sie zu Schritt 3.
  3. Gehen Sie zu dem Ordner, der die Quellspezifikation enthält, und gehen Sie zu Schritt 5.

  4. Klicken Sie auf EDIFACT, X12 oder XML, und klicken Sie auf OK.

    Wenn Sie EDIFACT oder X12 auswählen, müssen Sie auch die Version wählen, die Sie verwenden möchten. Klicken Sie auf den Ordner für die Version, klicken Sie auf OK, und gehen Sie dann zu Schritt 5.

  5. Wählen Sie die Quellspezifikation aus, und klicken Sie auf Öffnen bzw. OK.

Anmerkungen

  • Die Quelltestwerte bleiben erhalten, wenn Sie eine Quellspezifikation ersetzen, sofern die diesen Werten zugewiesenen Felder in der neuen Spezifikation vorhanden sind. Weitere Informationen zu Quelltestwerten finden Sie unter Testen von Verknüpfungen.

  • Die Registerkarte Warnungen führt alle Warnungen auf, die sich auf die Verknüpfungen beziehen, die infolge des Ersetzens der Quellspezifikation verloren gehen könnten.

  • Sie können auch mit der rechten Maustaste auf einen Datensatz oder ein Feld in der Struktur der Quellspezifikation klicken und dann auf Spezifikation ersetzen klicken.

Verwandte Themen

Ersetzen von Zielspezifikationen

Testen von Verknüpfungen


Ersetzen von Zielspezifikationen

  1. Klicken Sie im Menü Bearbeiten auf Zielspezifikation ersetzen.

    Wenn Sie Ihre Zuordnung nicht gespeichert haben, werden Sie aufgefordert, die Änderungen an der Zuordnungsquelle zu speichern.

    Das Dialogfeld Zielspezifikationstyp auswählen wird angezeigt.

  2. Doppelklicken Sie auf eine der folgenden Optionen:
    • Lokale Dateien, und gehen Sie zu Schritt 3.

    • Vorlagen, und gehen Sie zu Schritt 4.

    • WebDAV-Dateien, und gehen Sie zu Schritt 3.
  3. Gehen Sie zu dem Ordner, der die Zielspezifikation enthält, und gehen Sie zu Schritt 5.

  4. Klicken Sie auf EDIFACT, X12 oder XML, und klicken Sie auf OK.

    Wenn Sie EDIFACT oder X12 auswählen, müssen Sie auch die Version wählen, die Sie verwenden möchten. Klicken Sie auf den Ordner für die Version, klicken Sie auf OK, und gehen Sie dann zu Schritt 5.

  5. Wählen Sie die Zielspezifikation aus, und klicken Sie auf Öffnen bzw. OK.

Anmerkungen

  • Die konstanten Werte für das Ziel bleiben erhalten, wenn Sie eine Zielspezifikation ersetzen, sofern die diesen Werten zugewiesenen Felder in der neuen Spezifikation vorhanden sind. Weitere Informationen zu konstanten Werten für das Ziel finden Sie unter Hinzufügen von konstanten Werten.

  • Die Registerkarte Warnungen führt alle Warnungen auf, die sich auf die Verknüpfungen beziehen, die infolge des Ersetzens der Zielspezifikation verloren gehen könnten.

  • Sie können auch mit der rechten Maustaste auf einen Datensatz oder ein Feld in der Struktur der Zielspezifikation klicken und dann auf Spezifikation ersetzen klicken.

Verwandte Themen

Hinzufügen von konstanten Werten

Ersetzen von Quellspezifikationen


Verwalten von Funktoiden

Folgende Themen werden in diesem Abschnitt behandelt:

  • Arbeiten mit der Funktoidpalette

  • Bearbeiten von Funktoideigenschaften


Arbeiten mit der Funktoidpalette

Die Funktoidpalette enthält die im BizTalk-Mapper verfügbaren Funktoide. Sie können das gewünschte Funktoid in der Funktoidpalette suchen und in das Zuordnungsraster ziehen. Die verschiedenen Typen von Funktoiden sind auf Registerkarten angeordnet. Möglicherweise müssen Sie auf den Pfeil nach rechts oder den Pfeil nach links klicken, um die verborgenen Registerkarten anzuzeigen.

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Hinzufügen von Zeichenfolgenfunktoiden

  • Hinzufügen von mathematischen Funktoiden

  • Hinzufügen von logischen Funktoiden

  • Hinzufügen von Datums-und Uhrzeitfunktoiden

  • Hinzufügen von Konvertierungsfunktoiden

  • Hinzufügen von wissenschaftlichen Funktoiden

  • Hinzufügen von kumulativen Funktoiden

  • Hinzufügen von Datenbankfunktoiden

  • Hinzufügen des Funktoids "Skripterstellung"

  • Hinzufügen des Funktoids "Anzahl der Datensätze"

  • Hinzufügen des Funktoids "Index"

  • Hinzufügen des Funktoids "Iteration"

  • Hinzufügen des Funktoids "Wertezuordnung"

  • Hinzufügen des Funktoids "Wertezuordnung (Flattening)"

  • Hinzufügen des Funktoids "Schleife"

  • Löschen von Funktoiden

Verwandte Themen

BizTalk-Mapper - Funktoidpalette

Grundlegendes zu Funktoiden


Hinzufügen von Zeichenfolgenfunktoiden

  1. Klicken Sie im Menü Ansicht auf Funktoidpalette.

  2. Klicken Sie auf der Funktoidpalette auf die Registerkarte Zeichenfolge.

  3. Ziehen Sie ein Funktoid Zeichenfolge aus der Funktoidpalette in das Zuordnungsraster.

    Detaillierte Informationen zu bestimmten Zeichenfolgenfunktoiden finden Sie unter Zeichenfolgenfunktoide.

  4. Ziehen Sie einen Datensatz oder ein Feld aus der Struktur der Quellspezifikation auf das Funktoid im Zuordnungsraster, und ziehen Sie das Funktoid auf einen Datensatz oder Feld in der Struktur der Zielspezifikation.

Wichtig

  • Um eine Verknüpfung zwischen einem Funktoid und einem Datensatz zu erstellen, müssen Sie die Eigenschaft Verknüpfungen von Datensatzinhalten zulassen aktivieren. Klicken Sie dazu im Menü Extras auf Optionen. Aktivieren Sie im Dialogfeld Optionen für den BizTalk-Mapper auf der Registerkarte Allgemein das Kontrollkästchen Verknüpfungen von Datensatzinhalten zulassen, und klicken Sie auf OK.

Anmerkung

  • Möglicherweise müssen Sie die Spezifikationsstrukturen erweitern, um die Datensätze oder Felder anzuzeigen, die Sie zuordnen möchten. Weitere Informationen finden Sie unter Erweitern von Strukturelementen.

Verwandte Themen

Zulassen von Verknüpfungen für Datensatzinhalte

Erstellen von Verknüpfungen zwischen Feldern und Funktoiden

Erstellen von Verknüpfungen zwischen Datensätzen und Funktoiden

Zeichenfolgenfunktoide

Grundlegendes zu Funktoiden


Hinzufügen von mathematischen Funktoide

  1. Klicken Sie im Menü Ansicht auf Funktoidpalette.

  2. Klicken Sie auf der Funktoidpalette auf die Registerkarte Mathematisch.

  3. Ziehen Sie ein mathematisches Funktoid aus der Funktoidpalette in das Zuordnungsraster.

    Detaillierte Informationen zu bestimmten mathematischen Funktoiden finden Sie unter Hinzufügen von mathematischen Funktoiden.

  4. Ziehen Sie einen Datensatz oder ein Feld aus der Struktur der Quellspezifikation auf das Funktoid im Zuordnungsraster, und ziehen Sie das Funktoid auf einen Datensatz oder Feld in der Struktur der Zielspezifikation.

Wichtig

  • Um eine Verknüpfung zwischen einem Funktoid und einem Datensatz zu erstellen, müssen Sie die Eigenschaft Verknüpfungen von Datensatzinhalten zulassen aktivieren. Klicken Sie dazu im Menü Extras auf Optionen. Aktivieren Sie im Dialogfeld Optionen für den BizTalk-Mapper auf der Registerkarte Allgemein das Kontrollkästchen Verknüpfungen von Datensatzinhalten zulassen, und klicken Sie auf OK.

Anmerkung

  • Möglicherweise müssen Sie die Spezifikationsstrukturen erweitern, um die Datensätze oder Felder anzuzeigen, die Sie zuordnen möchten. Weitere Informationen finden Sie unter Erweitern von Strukturelementen.

Verwandte Themen

Zulassen von Verknüpfungen für Datensatzinhalte

Erstellen von Verknüpfungen zwischen Feldern und Funktoiden

Erstellen von Verknüpfungen zwischen Datensätzen und Funktoiden

Mathematische Funktoide

Grundlegendes zu Funktoiden


Hinzufügen von logischen Funktoiden

  1. Klicken Sie im Menü Ansicht auf Funktoidpalette.

  2. Klicken Sie auf der Funktoidpalette auf die Registerkarte Logisch.

  3. Ziehen Sie ein logisches Funktoid aus der Funktoidpalette in das Zuordnungsraster.

    Detaillierte Informationen zu bestimmten logischen Funktoiden finden Sie unter Logische Funktoide.

  4. Ziehen Sie einen Datensatz oder ein Feld aus der Quellspezifikation-Struktur auf das Funktoid im Zuordnungsraster. Ziehen Sie dann das Funktoid auf einen Datensatz im Verzeichnis Zielspezifikation.

Wichtig

  • Um eine Verknüpfung zwischen einem Funktoid und einem Datensatz zu erstellen, müssen Sie die Eigenschaft Verknüpfungen von Datensatzinhalten zulassen aktivieren. Klicken Sie dazu im Menü Extras auf Optionen. Aktivieren Sie im Dialogfeld Optionen für den BizTalk-Mapper auf der Registerkarte Allgemein das Kontrollkästchen Verknüpfungen von Datensatzinhalten zulassen, und klicken Sie auf OK.

Anmerkungen

  • Logische Funktoide reagieren beim Vergleich von zwei Zeichenfolgen auf die Groß- und Kleinschreibung. Beispielsweise sind "Abc" und "abc" nicht identisch. Ausgenommen von dieser Regel ist der Vergleich von Zeichenketten, die die booleschen Werte TRUE und FALSE enthalten, durch logische Funktoide. Beispielsweise sind "True" und "true" nicht identisch.

  • Möglicherweise müssen Sie die Spezifikationsstrukturen erweitern, um die Datensätze oder Felder anzuzeigen, die Sie zuordnen möchten. Weitere Informationen finden Sie unter Erweitern von Strukturelementen.

Verwandte Themen

Zulassen von Verknüpfungen für Datensatzinhalte

Erstellen von Verknüpfungen zwischen Feldern und Funktoiden

Erstellen von Verknüpfungen zwischen Datensätzen und Funktoiden

Logische Funktoide

Grundlegendes zu Funktoiden


Hinzufügen von Datums- und Uhrzeitfunktoiden

  1. Klicken Sie im Menü Ansicht auf Funktoidpalette.

  2. Klicken Sie auf der Funktoidpalette auf die Registerkarte Datum/Uhrzeit.

  3. Ziehen Sie ein Funktoid Datum und Uhrzeit aus der Funktoidpalette in das Zuordnungsraster.

    Detaillierte Informationen zu bestimmten Datums- und Zeitfunktoiden finden Sie unter Datums- und Zeitfunktoide.

  4. Ziehen Sie einen Datensatz oder ein Feld aus der Struktur der Quellspezifikation auf das Funktoid im Zuordnungsraster, und ziehen Sie das Funktoid auf einen Datensatz oder Feld in der Struktur der Zielspezifikation.

Wichtig

  • Um eine Verknüpfung zwischen einem Funktoid und einem Datensatz zu erstellen, müssen Sie die Eigenschaft Verknüpfungen von Datensatzinhalten zulassen aktivieren. Klicken Sie dazu im Menü Extras auf Optionen. Aktivieren Sie im Dialogfeld Optionen für den BizTalk-Mapper auf der Registerkarte Allgemein das Kontrollkästchen Verknüpfungen von Datensatzinhalten zulassen, und klicken Sie auf OK.

Anmerkungen

  • Die Funktoide Datum, Uhrzeit und Datum und Uhrzeit benötigen nur eine Verknüpfung zu einem Feld oder einem Datensatz in der Struktur der Zielspezifikation.

  • Möglicherweise müssen Sie die Spezifikationsstrukturen erweitern, um die Datensätze oder Felder anzuzeigen, die Sie zuordnen möchten. Weitere Informationen finden Sie unter Erweitern von Strukturelementen.

Verwandte Themen

Zulassen von Verknüpfungen für Datensatzinhalte

Erstellen von Verknüpfungen zwischen Feldern und Funktoiden

Erstellen von Verknüpfungen zwischen Datensätzen und Funktoiden

Datums- und Zeitfunktoide

Grundlegendes zu Funktoiden


Hinzufügen von Konvertierungsfunktoiden

  1. Klicken Sie im Menü Ansicht auf Funktoidpalette.

  2. Klicken Sie auf der Funktoidpalette auf die Registerkarte Konvertierung.

    Möglicherweise müssen Sie auf der Funktoidpalette auf den Pfeil nach rechts klicken, um die Registerkarte anzuzeigen.

  3. Ziehen Sie ein Funktoid Konvertierung aus der Funktoidpalette in das Zuordnungsraster.

    Detaillierte Informationen zu bestimmten Konvertierungsfunktoiden finden Sie unter Konvertierungsfunktoide.

  4. Ziehen Sie einen Datensatz oder ein Feld aus der Struktur der Quellspezifikation auf das Funktoid im Zuordnungsraster, und ziehen Sie das Funktoid auf einen Datensatz oder Feld in der Struktur der Zielspezifikation.

Wichtig

  • Um eine Verknüpfung zwischen einem Funktoid und einem Datensatz zu erstellen, müssen Sie die Eigenschaft Verknüpfungen von Datensatzinhalten zulassen aktivieren. Klicken Sie dazu im Menü Extras auf Optionen. Aktivieren Sie im Dialogfeld Optionen für den BizTalk-Mapper auf der Registerkarte Allgemein das Kontrollkästchen Verknüpfungen von Datensatzinhalten zulassen, und klicken Sie auf OK.

Anmerkung

  • Möglicherweise müssen Sie die Spezifikationsstrukturen erweitern, um die Datensätze oder Felder anzuzeigen, die Sie zuordnen möchten. Weitere Informationen finden Sie unter Erweitern von Strukturelementen.

Verwandte Themen

Zulassen von Verknüpfungen für Datensatzinhalte

Konvertierungsfunktoide

Erstellen von Verknüpfungen zwischen Feldern und Funktoiden

Erstellen von Verknüpfungen zwischen Datensätzen und Funktoiden

Grundlegendes zu Funktoiden


Hinzufügen von wissenschaftlichen Funktoiden

  1. Klicken Sie im Menü Ansicht auf Funktoidpalette.

  2. Klicken Sie auf der Funktoidpalette auf die Registerkarte Wissenschaftlich.

    Möglicherweise müssen Sie auf der Funktoidpalette auf den Pfeil nach rechts klicken, um die Registerkarte anzuzeigen.

  3. Ziehen Sie ein wissenschaftliches Funktoid aus der Funktoidpalette in das Zuordnungsraster.

    Detaillierte Informationen zu bestimmten wissenschaftlichen Funktoiden finden Sie unter Wissenschaftliche Funktoide.

  4. Ziehen Sie einen Datensatz oder ein Feld aus der Struktur der Quellspezifikation auf das Funktoid im Zuordnungsraster, und ziehen Sie das Funktoid auf einen Datensatz oder ein Feld in der Struktur der Zielspezifikation.

Wichtig

  • Um eine Verknüpfung zwischen einem Funktoid und einem Datensatz zu erstellen, müssen Sie die Eigenschaft Verknüpfungen von Datensatzinhalten zulassen aktivieren. Klicken Sie dazu im Menü Extras auf Optionen. Aktivieren Sie im Dialogfeld Optionen für den BizTalk-Mapper auf der Registerkarte Allgemein das Kontrollkästchen Verknüpfungen von Datensatzinhalten zulassen, und klicken Sie auf OK.

Anmerkung

  • Möglicherweise müssen Sie die Spezifikationsstrukturen erweitern, um die Datensätze oder Felder anzuzeigen, die Sie zuordnen möchten. Weitere Informationen finden Sie unter Erweitern von Strukturelementen.

Verwandte Themen

Zulassen von Verknüpfungen für Datensatzinhalte

Erstellen von Verknüpfungen zwischen Feldern und Funktoiden

Erstellen von Verknüpfungen zwischen Datensätzen und Funktoiden

Wissenschaftliche Funktoide

Grundlegendes zu Funktoiden


Hinzufügen von kumulativen Funktoiden

  1. Klicken Sie im Menü Ansicht auf Funktoidpalette.

  2. Klicken Sie auf der Funktoidpalette auf die Registerkarte Kumulativ.

    Möglicherweise müssen Sie auf der Funktoidpalette auf den Pfeil nach rechts klicken, um die Registerkarte anzuzeigen.

  3. Ziehen Sie ein kumulatives Funktoid aus der Funktoidpalette in das Zuordnungsraster.

    Detaillierte Informationen zu bestimmten kumulativen Funktoiden finden Sie unter Kumulative Funktoide.

  4. Ziehen Sie ein Feld (mit einem übergeordneten Schleifendatensatz) aus der Struktur der Quellspezifikation auf das Funktoid im Zuordnungsraster, und ziehen Sie dann das Funktoid auf einen Datensatz oder ein Feld in der Struktur der Quellspezifikation.

    Weitere Informationen zu Schleifendatensätze finden Sie unter Verwenden von kumulativen Funktoiden.

Wichtig

  • Weitere Informationen zum Kontext dieses Verfahrens finden Sie unter Verwenden von kumulativen Funktoiden.

  • Um eine Verknüpfung zwischen einem Funktoid und einem Datensatz zu erstellen, müssen Sie die Eigenschaft Verknüpfungen von Datensatzinhalten zulassen aktivieren. Klicken Sie dazu im Menü Extras auf Optionen. Aktivieren Sie im Dialogfeld Optionen für den BizTalk-Mapper auf der Registerkarte Allgemein das Kontrollkästchen Verknüpfungen von Datensatzinhalten zulassen, und klicken Sie auf OK.

Anmerkung

  • Möglicherweise müssen Sie die Spezifikationsstrukturen erweitern, um die Datensätze oder Felder anzuzeigen, die Sie zuordnen möchten. Weitere Informationen finden Sie unter Erweitern von Strukturelementen.

Verwandte Themen

Zulassen von Verknüpfungen für Datensatzinhalte

Erstellen von Verknüpfungen zwischen Feldern und Funktoiden

Erstellen von Verknüpfungen zwischen Datensätzen und Funktoiden

Kumulative Funktoide

Grundlegendes zu Funktoiden


Hinzufügen von Datenbankfunktoiden

  1. Klicken Sie im Menü Ansicht auf Funktoidpalette.

  2. Klicken Sie auf der Funktoidpalette auf die Registerkarte Datenbank.

    Möglicherweise müssen Sie auf der Funktoidpalette auf den Pfeil nach rechts klicken, um die Registerkarte anzuzeigen.

  3. Ziehen Sie ein Funktoid Datenbank aus der Funktoidpalette in das Zuordnungsraster.

    Detaillierte Informationen zu bestimmten Datenbankfunktoiden finden Sie unter Datenbankfunktoide.

Wichtig

  • Weitere Informationen zur Verwendung der Funktoide Datenbank zum Extrahieren von Informationen aus einer Datenbank finden Sie unter Verwenden von Datenbankfunktoiden.

  • Um eine Verknüpfung zwischen einem Funktoid und einem Datensatz zu erstellen, müssen Sie die Eigenschaft Verknüpfungen von Datensatzinhalten zulassen aktivieren. Klicken Sie dazu im Menü Extras auf Optionen. Aktivieren Sie im Dialogfeld Optionen für den BizTalk-Mapper auf der Registerkarte Allgemein das Kontrollkästchen Verknüpfungen von Datensatzinhalten zulassen, und klicken Sie auf OK.

Anmerkung

  • Möglicherweise müssen Sie die Spezifikationsstrukturen erweitern, um die Datensätze oder Felder anzuzeigen, die Sie zuordnen möchten. Weitere Informationen finden Sie unter Erweitern von Strukturelementen.

Verwandte Themen

Zulassen von Verknüpfungen für Datensatzinhalte

Erstellen von Verknüpfungen zwischen Feldern und Funktoiden

Erstellen von Verknüpfungen zwischen Datensätzen und Funktoiden

Datenbankfunktoide

Grundlegendes zu Funktoiden


Hinzufügen des Funktoids "Skripterstellung"

  1. Klicken Sie im Menü Ansicht auf Funktoidpalette.

  2. Klicken Sie auf der Funktoidpalette auf die Registerkarte Erweitert.

    Möglicherweise müssen Sie auf der Funktoidpalette auf den Pfeil nach rechts klicken, um die Registerkarte anzuzeigen.

  3. Ziehen Sie das Funktoid Skripterstellung Funktoid "Skripterstellung" in das Zuordnungsraster.

    Detaillierte Informationen zu bestimmten Funktoiden vom Typ Skripterstellung finden Sie unter Erweiterte Funktoide.

  4. Doppelklicken Sie auf das Funktoid Skripterstellung.

  5. Klicken Sie im Dialogfeld Funktoideigenschaften auf die Registerkarte Skript, und geben Sie das gewünschte Skript ein. Klicken Sie dann auf OK.

  6. Ziehen Sie einen Datensatz oder ein Feld aus der Struktur der Quellspezifikation auf das Funktoid Skripterstellung im Zuordnungsraster, und ziehen Sie das Funktoid Skripterstellung dann auf einen Datensatz oder ein Feld in der Struktur der Zielspezifikation.

Wichtig

  • Wenn es in einem Funktoid Skripterstellung mehrere Funktionen gibt, ist die erste Funktion die Haupt- oder primäre Funktion. Für diese Funktion müssen Parameter festgelegt sein, falls Verknüpfungen zum Funktoid vorhanden sind.

  • Um eine Verknüpfung zwischen einem Funktoid und einem Datensatz zu erstellen, müssen Sie die Eigenschaft Verknüpfungen von Datensatzinhalten zulassen aktivieren. Klicken Sie dazu im Menü Extras auf Optionen. Aktivieren Sie im Dialogfeld Optionen für den BizTalk-Mapper auf der Registerkarte Allgemein das Kontrollkästchen Verknüpfungen von Datensatzinhalten zulassen, und klicken Sie auf OK.

Anmerkung

  • Möglicherweise müssen Sie die Spezifikationsstrukturen erweitern, um die Datensätze oder Felder anzuzeigen, die Sie zuordnen möchten. Weitere Informationen finden Sie unter Erweitern von Strukturelementen.

Verwandte Themen

Erweiterte Funktoide

Zulassen von Verknüpfungen für Datensatzinhalte

Erstellen von Verknüpfungen zwischen Feldern und Funktoiden

Erstellen von Verknüpfungen zwischen Datensätzen und Funktoiden

Verwalten von Ansichten


Hinzufügen des Funktoids "Anzahl der Datensätze"

  1. Klicken Sie im Menü Ansicht auf Funktoidpalette.

  2. Klicken Sie auf der Funktoidpalette auf die Registerkarte Erweitert.

    Möglicherweise müssen Sie auf der Funktoidpalette auf den Pfeil nach rechts klicken, um die Registerkarte anzuzeigen.

Ziehen Sie das Funktoid Anzahl der Datensätze Funktoid "Anzahl der Datensätze" aus der Funktoidpalette in das Zuordnungsraster.

Detaillierte Informationen zum Funktoid Anzahl der Datensätze finden Sie unter Erweiterte Funktoide.

  3. Ziehen Sie einen Schleifendatensatz aus der Struktur der Quellspezifikation auf das Funktoid Anzahl der Datensätze im Zuordnungsraster, ziehen Sie dann das Funktoid Anzahl der Datensätze auf ein Feld in der Struktur der Zielspezifikation.

    Weitere Informationen zu Schleifendatensätze finden Sie unter Verwenden des Funktoids "Datensatzanzahl".

Wichtig

  • Weitere Informationen zum Kontext dieses Verfahrens finden Sie unter Verwenden des Funktoids "Datensatzanzahl".

  • Um eine Verknüpfung zwischen einem Funktoid und einem Datensatz zu erstellen, müssen Sie die Eigenschaft Verknüpfungen von Datensatzinhalten zulassen aktivieren. Klicken Sie dazu im Menü Extras auf Optionen. Aktivieren Sie im Dialogfeld Optionen für den BizTalk-Mapper auf der Registerkarte Allgemein das Kontrollkästchen Verknüpfungen von Datensatzinhalten zulassen, und klicken Sie auf OK.

Anmerkung

  • Möglicherweise müssen Sie die Spezifikationsstrukturen erweitern, um die Datensätze oder Felder anzuzeigen, die Sie zuordnen möchten. Weitere Informationen finden Sie unter Erweitern von Strukturelementen.

Verwandte Themen

Erweiterte Funktoide

Zulassen von Verknüpfungen für Datensatzinhalte

Erstellen von Verknüpfungen zwischen Feldern und Funktoiden

Erstellen von Verknüpfungen zwischen Datensätzen und Funktoiden

Grundlegendes zu Funktoiden


Hinzufügen des Funktoids "Index"

  1. Klicken Sie im Menü Ansicht auf Funktoidpalette.

  2. Klicken Sie auf der Funktoidpalette auf die Registerkarte Erweitert.

    Möglicherweise müssen Sie auf der Funktoidpalette auf den Pfeil nach rechts klicken, um die Registerkarte anzuzeigen.

  3. Ziehen Sie das Funktoid Index Funktoid "Index" aus der Funktoidpalette in das Zuordnungsraster.

    Detaillierte Informationen zum Funktoid Index finden Sie unter Erweiterte Funktoide.

  4. Ziehen Sie ein Feld (mit einem übergeordneten Schleifendatensatz) aus der Struktur der Quellspezifikation auf das Funktoid Index im Zuordnungsraster, und ziehen Sie dann das Funktoid Index auf ein Feld in der Struktur der Quellspezifikation.

    Weitere Informationen zu Schleifendatensätze finden Sie unter Verwenden des Funktoids "Index".

  5. Doppelklicken Sie auf das Funktoid Index, um seine Eigenschaftenseite aufzurufen.

  6. Klicken Sie auf die Schaltfläche Neuen Parameter einfügen Schaltfläche "Neuen Parameter einfügen", geben Sie den Indexwert ein, und drücken Sie dann die EINGABETASTE.

  7. Wiederholen Sie ggf. Schritt 6.

  8. Klicken Sie auf OK.

Wichtig

  • Weitere Informationen zum Kontext dieses Verfahrens finden Sie unter Verwenden des Funktoids "Index".

  • Um eine Verknüpfung zwischen einem Funktoid und einem Datensatz zu erstellen, müssen Sie die Eigenschaft Verknüpfungen von Datensatzinhalten zulassen aktivieren. Klicken Sie dazu im Menü Extras auf Optionen. Aktivieren Sie im Dialogfeld Optionen für den BizTalk-Mapper auf der Registerkarte Allgemein das Kontrollkästchen Verknüpfungen von Datensatzinhalten zulassen, und klicken Sie auf OK.

Anmerkung

  • Möglicherweise müssen Sie die Spezifikationsstrukturen erweitern, um die Datensätze oder Felder anzuzeigen, die Sie zuordnen möchten. Weitere Informationen finden Sie unter Erweitern von Strukturelementen.

Verwandte Themen

Erweiterte Funktoide

Zulassen von Verknüpfungen für Datensatzinhalte

Erstellen von Verknüpfungen zwischen Feldern und Funktoiden

Erstellen von Verknüpfungen zwischen Datensätzen und Funktoiden

Grundlegendes zu Funktoiden


Hinzufügen des Funktoids "Iteration"

  1. Klicken Sie im Menü Ansicht auf Funktoidpalette.

  2. Klicken Sie auf der Funktoidpalette auf die Registerkarte Erweitert.

    Möglicherweise müssen Sie auf der Funktoidpalette auf den Pfeil nach rechts klicken, um die Registerkarte anzuzeigen.

  3. Ziehen Sie das Funktoid Iteration Funktoid "Iteration" aus der Funktoidpalette in das Zuordnungsraster.

    Detaillierte Informationen zum Funktoid Iteration finden Sie unter Erweiterte Funktoide.

Wichtig

  • Weitere Informationen zur Verwendung des Funktoids Iteration finden Sie unter Verwenden des Funktoids "Iteration".

  • Um eine Verknüpfung zwischen einem Funktoid und einem Datensatz zu erstellen, müssen Sie die Eigenschaft Verknüpfungen von Datensatzinhalten zulassen aktivieren. Klicken Sie dazu im Menü Extras auf Optionen. Aktivieren Sie im Dialogfeld Optionen für den BizTalk-Mapper auf der Registerkarte Allgemein das Kontrollkästchen Verknüpfungen von Datensatzinhalten zulassen, und klicken Sie auf OK.

Anmerkung

  • Möglicherweise müssen Sie die Spezifikationsstrukturen erweitern, um die Datensätze oder Felder anzuzeigen, die Sie zuordnen möchten. Weitere Informationen finden Sie unter Erweitern von Strukturelementen.

Verwandte Themen

Erweiterte Funktoide

Zulassen von Verknüpfungen für Datensatzinhalte

Erstellen von Verknüpfungen zwischen Feldern und Funktoiden

Erstellen von Verknüpfungen zwischen Datensätzen und Funktoiden

Grundlegendes zu Funktoiden


Hinzufügen des Funktoids "Wertezuordnung"

  1. Klicken Sie im Menü Ansicht auf Funktoidpalette.

  2. Klicken Sie auf der Funktoidpalette auf die Registerkarte Erweitert.

    Möglicherweise müssen Sie auf der Funktoidpalette auf den Pfeil nach rechts klicken, um die Registerkarte anzuzeigen.

  3. Ziehen Sie das Funktoid Wertezuordnung Funktoid "Wertezuordnung" aus der Funktoidpalette in das Zuordnungsraster.

    Detaillierte Informationen zum Funktoid Wertezuordnung finden Sie unter Erweiterte Funktoide.

Wichtig

  • Weitere Informationen zur Verwendung des Funktoids Wertezuordnung finden Sie unter Verwenden des Funktoids "Wertezuordnung".

  • Um eine Verknüpfung zwischen einem Funktoid und einem Datensatz zu erstellen, müssen Sie die Eigenschaft Verknüpfungen von Datensatzinhalten zulassen aktivieren. Klicken Sie dazu im Menü Extras auf Optionen. Aktivieren Sie im Dialogfeld Optionen für den BizTalk-Mapper auf der Registerkarte Allgemein das Kontrollkästchen Verknüpfungen von Datensatzinhalten zulassen, und klicken Sie auf OK.

Anmerkung

  • Möglicherweise müssen Sie die Spezifikationsstrukturen erweitern, um die Datensätze oder Felder anzuzeigen, die Sie zuordnen möchten. Weitere Informationen finden Sie unter Erweitern von Strukturelementen.

Verwandte Themen

Hinzufügen des Funktoids "Wertezuordnung (Flattening)"

Erweiterte Funktoide

Zulassen von Verknüpfungen für Datensatzinhalte

Erstellen von Verknüpfungen zwischen Feldern und Funktoiden

Erstellen von Verknüpfungen zwischen Datensätzen und Funktoiden

Grundlegendes zu Funktoiden


Hinzufügen des Funktoids "Wertezuordnung (Flattening)"

  1. Klicken Sie im Menü Ansicht auf Funktoidpalette.

  2. Klicken Sie auf der Funktoidpalette auf die Registerkarte Erweitert.

    Möglicherweise müssen Sie auf der Funktoidpalette auf den Pfeil nach rechts klicken, um die Registerkarte anzuzeigen.

  3. Ziehen Sie das Funktoid Wertezuordnung (Flattening) Funktoid "Wertezuordnung (Flattening)" aus der Funktoidpalette in das Zuordnungsraster.

    Detaillierte Informationen zum Funktoid Wertezuordnung (Flattening) finden Sie unter Erweiterte Funktoide.

Wichtig

  • Weitere Informationen zur Verwendung des Funktoids Wertezuordnung (Flattening) finden Sie unter Verwenden des Funktoids "Wertezuordnung (Flattening)".

  • Um eine Verknüpfung zwischen einem Funktoid und einem Datensatz zu erstellen, müssen Sie die Eigenschaft Verknüpfungen von Datensatzinhalten zulassen aktivieren. Klicken Sie dazu im Menü Extras auf Optionen. Aktivieren Sie im Dialogfeld Optionen für den BizTalk-Mapper auf der Registerkarte Allgemein das Kontrollkästchen Verknüpfungen von Datensatzinhalten zulassen, und klicken Sie auf OK.

Anmerkung

  • Möglicherweise müssen Sie die Spezifikationsstrukturen erweitern, um die Datensätze oder Felder anzuzeigen, die Sie zuordnen möchten. Weitere Informationen finden Sie unter Erweitern von Strukturelementen.

Verwandte Themen

Hinzufügen des Funktoids "Wertezuordnung"

Erweiterte Funktoide

Zulassen von Verknüpfungen für Datensatzinhalte

Erstellen von Verknüpfungen zwischen Feldern und Funktoiden

Erstellen von Verknüpfungen zwischen Datensätzen und Funktoiden

Grundlegendes zu Funktoiden


Hinzufügen des Funktoids "Schleife"

  1. Klicken Sie im Menü Ansicht auf Funktoidpalette.

  2. Klicken Sie auf der Funktoidpalette auf die Registerkarte Erweitert.

    Möglicherweise müssen Sie auf der Funktoidpalette auf den Pfeil nach rechts klicken, um die Registerkarte anzuzeigen.

  3. Ziehen Sie das Funktoid Schleife Funktoid "Schleife" aus der Funktoidpalette in das Zuordnungsraster.

    Detaillierte Informationen zum Funktoid Schleife finden Sie unter Erweiterte Funktoide.

Wichtig

  • Weitere Informationen zur Verwendung des Funktoids Schleife finden Sie unter Verwenden des Funktoids "Schleife".

  • Um eine Verknüpfung zwischen einem Funktoid und einem Datensatz zu erstellen, müssen Sie die Eigenschaft Verknüpfungen von Datensatzinhalten zulassen aktivieren. Klicken Sie dazu im Menü Extras auf Optionen. Aktivieren Sie im Dialogfeld Optionen für den BizTalk-Mapper auf der Registerkarte Allgemein das Kontrollkästchen Verknüpfungen von Datensatzinhalten zulassen, und klicken Sie auf OK.

Anmerkung

  • Möglicherweise müssen Sie die Spezifikationsstrukturen erweitern, um die Datensätze oder Felder anzuzeigen, die Sie zuordnen möchten. Weitere Informationen finden Sie unter Erweitern von Strukturelementen.

Verwandte Themen

Erweiterte Funktoide

Zulassen von Verknüpfungen für Datensatzinhalte

Erstellen von Verknüpfungen zwischen Feldern und Funktoiden

Erstellen von Verknüpfungen zwischen Datensätzen und Funktoiden

Grundlegendes zu Funktoiden


Löschen von Funktoiden

  1. Klicken Sie mit der rechten Maustaste auf das Funktoid, das Sie entfernen möchten, und klicken Sie dann auf Löschen.

  2. Klicken Sie im Bestätigungsdialogfeld auf Ja.


Bearbeiten von Funktoideigenschaften

  • Klicken Sie mit der rechten Maustaste auf ein Funktoid im Zuordnungsraster und dann auf Eigenschaften, um das Dialogfeld Funktoideigenschaften aufzurufen.

Anmerkungen

  • Sie können auf ein Funktoid auch doppelklicken, um seine Eigenschaften zu bearbeiten.

  • Die Registerkarte Allgemein zeigt Informationen zu den Eingabeparametern an. Die Registerkarte Skript zeigt Skriptinformationen an.

Weitere Informationen zur Verwendung dieses Dialogfeldes finden Sie in den folgenden Themen:

  • Eingabeparameter

  • Funktoidskripts


Eingabeparameter

Weitere Informationen zum Zugriff auf das Dialogfeld Funktoideigenschaften finden Sie unter Bearbeiten von Funktoideigenschaften.

Die Eingabeparameter für viele Funktoide können auf der Registerkarte Allgemein des Dialogfeldes Funktoideigenschaften hinzugefügt, gelöscht und nach oben und unten verschoben werden. Weitere Informationen finden Sie unter den folgenden Verfahren:

  • Einfügen von Eingabeparametern

  • Löschen von Eingabeparametern

  • Verschieben von Eingabeparametern

  • Umbenennen von Eingabeparametern

Anmerkung

  • Bei einigen Funktoiden ist die Anzahl der Parameter, die diese haben können, begrenzt. Information dazu, wie viele Parameter ein bestimmtes Funktoid jeweils haben kann, finden Sie jeweils im Dialogfeld Funktoideigenschaften auf der Registerkarte Allgemein im Bereich Eingabeparameter für dieses Funktoid.


Einfügen von Eingabeparametern

  1. Doppelklicken Sie auf ein Funktoid im Zuordnungsraster.

    Das Dialogfeld Funktoideigenschaften wird angezeigt.

  2. Klicken Sie auf der Registerkarte Allgemein auf die Schaltfläche Neuen Parameter einfügen Schaltfläche "Neuen Paramete einfügen. Geben Sie die Informationen für den neuen Parameter ein, und drücken Sie die EINGABETASTE.

    Anmerkung

    • Falls die Schaltfläche Neuen Parameter einfügen in Schritt 2 nicht verfügbar ist, akzeptiert oder benötigt das Funktoid keine Eingabeparameter.
  3. Wiederholen Sie Schritt 2, um ggf. weitere Parameter hinzuzufügen.

  4. Klicken Sie auf OK.

Wichtig

  • Doppelte Fragezeichen werden in einem konstanten Wert für einen Eingabeparameter nicht unterstützt.

Verwandte Themen

Löschen von Eingabeparametern

Verschieben von Eingabeparametern

Umbenennen von Eingabeparametern


Löschen von Eingabeparametern

  1. Doppelklicken Sie auf ein Funktoid im Zuordnungsraster.

  2. Klicken Sie auf der Registerkarte Allgemein im Bereich Eingabeparameter auf den Eingabeparameter, den Sie löschen möchten.

  3. Klicken Sie auf die Schaltfläche Ausgewählten Parameter löschen [image] , und klicken Sie auf OK.

Verwandte Themen

Einfügen von Eingabeparametern

Verschieben von Eingabeparametern

Umbenennen von Eingabeparametern


Verschieben von Eingabeparametern

  1. Doppelklicken Sie auf ein Funktoid im Zuordnungsraster.

  2. Klicken Sie auf der Registerkarte Allgemein im Bereich Eingabeparameter auf den Eingabeparameter, den Sie verschieben möchten.

  3. Klicken Sie auf die Schaltfläche Ausgewählten Parameter nach oben verschieben [image] , um den Parameter nach oben zu verschieben, oder klicken Sie auf die Schaltfläche Ausgewählten Parameter nach unten verschieben Schaltfläche "Ausgewählten Parameter nach unten verschiebe", um den Parameter nach unten zu verschieben, und klicken Sie auf OK.

Verwandte Themen

Löschen von Eingabeparametern

Einfügen von Eingabeparametern


Umbenennen von Eingabeparametern

  1. Doppelklicken Sie auf ein Funktoid im Zuordnungsraster.

  2. Klicken Sie auf der Registerkarte Allgemein im Bereich Eingabeparameter mit der rechten Maustaste auf den Eingabeparameter, den Sie umbenennen möchten, und klicken Sie auf Wert ändern.

  3. Geben Sie einen neuen Parameternamen ein, und klicken Sie auf OK.

Verwandte Themen

Löschen von Eingabeparametern

Einfügen von Eingabeparametern

Verschieben von Eingabeparametern


Funktoidskripts

Weitere Informationen zum Zugriff auf das Dialogfeld Funktoideigenschaften finden Sie unter Bearbeiten von Funktoideigenschaften.

Auf der Registerkarte Skript im Dialogfeld Funktoideigenschaften können Sie Skripts anzeigen oder bearbeiten.

Anmerkung

  • Sie können das Skript für jedes beliebige Funktoid anzeigen, jedoch nur das Skript eines Funktoids vom Typ Skripterstellung bearbeiten.

Verwandtes Thema

Eingabeparameter


Verwalten von Verknüpfungen

Folgende Themen werden in diesem Abschnitt behandelt:

  • Erstellen von Verknüpfungen zwischen Feldern

  • Erstellen von Verknüpfungen zwischen Feldern und Funktoiden

  • Erstellen von Verknüpfungen zwischen Datensätzen und Feldern

  • Erstellen von Verknüpfungen zwischen Datensätzen und Funktoiden

  • Erstellen von Verknüpfungen zwischen Funktoiden

  • Zulassen von Verknüpfungen für Datensatzinhalte

  • Umleiten von Verknüpfungen

  • Löschen von Verknüpfungen


Erstellen von Verknüpfungen zwischen Feldern

  • Ziehen Sie ein Feld aus der Struktur der Quellspezifikation auf ein Feld in der Struktur der Zielspezifikation.

Wichtig

  • Der Datentyp eines Feldes in der Quellspezifikation sollte dem Datentyp eines Feldes entsprechen, mit dem es in der Zielspezifikation verknüpft ist.

Anmerkungen

  • Sie können keine Verknüpfung mit einem Knoten in der Zielspezifikation erstellen, dem ein konstanter Wert für das Ziel zugeordnet ist.

  • Sie können keine Verknüpfung zu einem erforderlichen Feld in der Zielspezifikation erstellen, dem ein Standardwert zugeordnet ist. Weitere Informationen dazu, wie Sie ein Feld zu einem erforderlichen Feld bestimmen, finden Sie unter Festlegen von Verweiseigenschaften. Weitere Informationen zum Festlegen des Standardwertes eines Feldes finden Sie unter Festlegen von Deklarationseigenschaften.

  • Möglicherweise müssen Sie die Spezifikationsstrukturen erweitern, um die Felder anzuzeigen, die Sie zuordnen möchten. Weitere Informationen finden Sie unter Erweitern von Strukturelementen.

Verwandte Themen

Hinzufügen von konstanten Werten

Verwalten von Ansichten

Festlegen von Deklarationseigenschaften

Festlegen von Verweiseigenschaften

Zusammenfassung der Datentypen und Datentypwerte


Erstellen von Verknüpfungen zwischen Feldern und Funktoiden

  • Ziehen Sie ein Feld aus der Struktur der Quellspezifikation oder der Zielspezifikation auf ein Funktoid im Zuordnungsraster.

    Oder

  • Ziehen Sie das Funktoid aus dem Zuordnungsraster auf ein Feld in der Struktur Quellspezifikation oder der Zielspezifikation.

Wichtig

  • Ein Feld mit einer bestimmten Datentypeigenschaft in der Zielspezifikation einer Zuordnung sollte nicht mit einem Funktoid verknüpft werden, das Ausgabe mit einem anderen Datentyp erzeugt.

Anmerkungen

  • Sie müssen zuerst ein Funktoid zum Zuordnungsraster hinzufügen, bevor Sie eine Verknüpfung aus einem Feld zum Funktoid hinzufügen können. Weitere Informationen zum Hinzufügen eines Funktoids zum Zuordnungsraster finden Sie unter Arbeiten mit der Funktoidpalette.

  • Sie können keine Verknüpfung mit einem Knoten (in der Zielspezifikation) erstellen, dem ein konstanter Wert für das Ziel zugeordnet ist.

  • Sie können keine Verknüpfung zu einem erforderlichen Feld (in der Zielspezifikation) erstellen, dem ein Standardwert zugeordnet ist. Weitere Informationen dazu, wie Sie ein Feld als ein erforderliches Feld definieren, finden Sie unter Festlegen von Verweiseigenschaften. Weitere Informationen zum Festlegen des Standardwertes eines Feldes finden Sie unter Festlegen von Deklarationseigenschaften.

Verwandte Themen

Hinzufügen von konstanten Werten

Verwalten von Ansichten

Festlegen von Deklarationseigenschaften

Festlegen von Verweiseigenschaften

Arbeiten mit der Funktoidpalette


Erstellen von Verknüpfungen zwischen Datensätzen und Feldern

  1. Klicken Sie im Menü Extras auf Optionen.

  2. Aktivieren Sie im Dialogfeld Optionen für den BizTalk-Mapper das Kontrollkästchen Verknüpfungen von Datensatzinhalten zulassen, und klicken Sie auf OK.

  3. Ziehen Sie einen Datensatz aus der Struktur der Quellspezifikation auf ein Feld in der Struktur der Zielspezifikation.

    Oder

    Ziehen Sie einen Datensatz aus der Struktur der Zielspezifikation auf ein Feld der Struktur der Quellspezifikation.

Anmerkungen

  • Sie können keine Verknüpfung mit einem Knoten in der Zielspezifikation erstellen, dem ein konstanter Wert für das Ziel zugeordnet ist.

  • Sie können keine Verknüpfung zu einem erforderlichen Feld in der Zielspezifikation erstellen, dem ein Standardwert zugeordnet ist. Weitere Informationen dazu, wie Sie ein Feld als ein erforderliches Feld definieren, finden Sie unter Festlegen von Verweiseigenschaften. Weitere Informationen zum Festlegen des Standardwertes eines Feldes finden Sie unter Festlegen von Deklarationseigenschaften.

  • Möglicherweise müssen Sie die Spezifikationsstrukturen erweitern, um die Datensätze und Felder anzuzeigen, die Sie zuordnen möchten. Weitere Informationen finden Sie unter Erweitern von Strukturelementen.

Verwandte Themen

Hinzufügen von konstanten Werten

Verwalten von Ansichten

Festlegen von Deklarationseigenschaften

Festlegen von Verweiseigenschaften


Erstellen von Verknüpfungen zwischen Datensätzen und Funktoiden

  1. Klicken Sie im Menü Extras auf Optionen.

    Das Dialogfeld Optionen für den BizTalk-Mapper wird angezeigt.

  2. Aktivieren Sie das Kontrollkästchen Verknüpfungen von Datensatzinhalten zulassen, und klicken Sie auf OK.

  3. Ziehen Sie einen Datensatz aus der Struktur der Quellspezifikation oder der Zielspezifikation auf ein Funktoid im Zuordnungsraster.

    Oder

    Ziehen Sie das Funktoid aus dem Zuordnungsraster auf einen Datensatz in der Struktur Quellspezifikation oder der Zielspezifikation.

Anmerkungen

  • Sie müssen zuerst ein Funktoid zum Zuordnungsraster hinzufügen, bevor Sie eine Verknüpfung von einem Datensatz zum Funktoid hinzufügen können.

  • Sie können keine Verknüpfung mit einem Knoten in der Zielspezifikation erstellen, dem ein konstanter Wert für das Ziel zugeordnet ist. Weitere Informationen zu konstanten Werten für das Ziel finden Sie unter BizTalk-Mapper - Benutzeroberfläche.

Verwandtes Thema

Hinzufügen von konstanten Werten

Verwalten von Ansichten


Erstellen von Verknüpfungen zwischen Funktoiden

  • Ziehen Sie ein Funktoid auf ein anderes Funktoid im Zuordnungsraster.

Anmerkung

  • Verknüpfungen werden im Zuordnungsraster von links nach rechts verarbeitet. Sie können keine Verknüpfung von einem Funktoid zu einem anderen Funktoid direkt darunter oder darüber erstellen.

Verwandte Themen

Erstellen von Verknüpfungen zwischen Feldern und Funktoiden

Erstellen von Verknüpfungen zwischen Datensätzen und Funktoiden


Zulassen von Verknüpfungen für Datensatzinhalte

  1. Klicken Sie im Menü Extras auf Optionen.

    Das Dialogfeld Optionen für den BizTalk-Mapper wird angezeigt.

  2. Aktivieren Sie das Kontrollkästchen Verknüpfungen von Datensatzinhalten zulassen, und klicken Sie auf OK.

  3. Ziehen Sie einen Datensatz aus der Struktur der Quellspezifikation auf einen Datensatz in der Struktur der Zielspezifikation.


Umleiten von Verknüpfungen

  1. Klicken Sie im Zuordnungsraster auf eine Verknüpfung, um diese zu markieren.

    Die Endpunkte der Verknüpfungen sind mit kleinen blauen Kästchen markiert.

  2. Ziehen Sie einen der Endpunkte zum Funktoid oder Knoten, zu dem Sie eine Verbindung herstellen möchten.

    Wenn Sie den Endpunkt ziehen, verwandelt sich der Mauszeiger in ein Fadenkreuz. Wenn Sie auf ein Objekt zeigen, zu dem keine Verknüpfung hergestellt werden kann, verwandelt sich der Zeiger in einen diagonal durchgestrichenen Kreis.

Wichtig

  • Wenn zwei oder mehr Quellverknüpfungen mit einem Funktoid verbunden sind und Sie eine oder mehrere dieser Quellverknüpfungen zu unterschiedlichen Knoten in der Quellspezifikation umleiten, bleibt die Reihenfolge der Eingabeparameter des Funktoids möglicherweise nicht erhalten. Doppelklicken Sie auf das Funktoid, um seine Eingabeparameter anzuzeigen, und stellen Sie sicher, dass diese in der korrekten Reihenfolge stehen.


Löschen von Verknüpfungen

  1. Klicken Sie mit der rechten Maustaste auf die Verknüpfung, die Sie löschen möchten, und klicken Sie dann auf Löschen.

  2. Klicken Sie im Bestätigungsdialogfeld auf Ja.


Anzeigen von Rasterverknüpfungen und Funktoiden

Folgende Themen werden in diesem Abschnitt behandelt:

  • Anzeigen von Verknüpfungen und Funktoiden im Zuordnungsraster

  • Anzeigen von Verknüpfungen und Funktoiden mithilfe der Rastervorschau


Anzeigen von Verknüpfungen und Funktoiden im Zuordnungsraster

  1. Bewegen Sie den Cursor im Zuordnungsraster entlang des Randes in die Richtung, in die Sie blättern möchten.

    Der Cursor verwandelt sich von einem Zeiger oder einem senkrechten Balken in einen großen Pfeil.

  2. Klicken Sie mit der linken Maustaste und halten Sie diese gedrückt, um in die Richtung zu blättern, in die der Zeiger zeigt.

Anmerkung

  • Sie können auch blättern, indem Sie in den Hintergrund des Zuordnungsrasters klicken und dann mit den PFEILTASTEN in alle vier Richtungen blättern.

Verwandte Themen

BizTalk-Mapper - Benutzeroberfläche

Anzeigen von Verknüpfungen und Funktoiden mithilfe der Rastervorschau


Anzeigen von Verknüpfungen und Funktoiden mithilfe der Rastervorschau

  1. Klicken Sie im Menü Ansicht auf Rastervorschau.

    Das Fenster Rastervorschau wird geöffnet und stellt dar, wo sich die Funktoide im Zuordnungsraster befinden.

  2. Ziehen Sie die grüne Positionierungsleiste im Dialogfeld Rastervorschau an einen neuen Ort.

    Wenn Sie die grüne Positionierungsleiste verschieben, werden die Verknüpfungen und Funktoide im Zuordnungsraster ebenfalls verschoben.

Anmerkung

Die Rastervorschau ist hilfreich für das Navigieren im Zuordnungsraster, wenn viele Funktoide über das Zuordnungsraster verteilt sind.

Verwandte Themen

BizTalk-Mapper - Benutzeroberfläche

Anzeigen von Verknüpfungen und Funktoiden im Zuordnungsraster


Bearbeiten von Verknüpfungseigenschaften

  • Klicken Sie mit der rechten Maustaste auf eine Verknüpfung im Zuordnungsraster und dann auf Eigenschaften, um das Dialogfeld Verknüpfungseigenschaften aufzurufen.

    Die Registerkarte Allgemein wird als Standardregisterkarte angezeigt.

Weitere Informationen zur Verwendung dieses Dialogfeldes finden Sie in den folgenden Themen:

  • Anzeigen von Verknüpfungseigenschaften: Registerkarte "Allgemein"

  • Anzeigen von Verknüpfungseigenschaften: Registerkarte "Compiler"

Anmerkung

  • Sie können auf eine Verknüpfung auch doppelklicken, um ihre Eigenschaften anzuzeigen.

Verwandte Themen

Kompilieren von Zuordnungen

Verwalten von Verknüpfungen


Anzeigen von Verknüpfungseigenschaften: Registerkarte "Allgemein"

Weitere Informationen zum Zugriff auf das Dialogfeld Verknüpfungseigenschaften finden Sie unter Bearbeiten von Verknüpfungseigenschaften.

Die Registerkarte Allgemein zeigt Informationen zur Quelle und zum Ziel einer Verknüpfung an. Der Bereich Quelle zeigt den Datensatzpfad, den Feldpfad oder den Namen des Funktoids für die Verknüpfungsquelle an, je nachdem, ob die Verknüpfungsquelle ein Datensatz, ein Feld oder ein Funktoid ist. Der Bereich Ziel zeigt den Datensatzpfad, den Feldpfad oder den Funktoidnamen für das Verknüpfungsziel an, je nachdem, ob das Verknüpfungsziel ein Datensatz, ein Feld oder ein Funktoid ist.

Verwandtes Thema

Anzeigen von Verknüpfungseigenschaften: Registerkarte "Compiler"


Anzeigen von Verknüpfungseigenschaften: Registerkarte "Compiler"

Weitere Informationen zum Zugriff auf das Dialogfeld Verknüpfungseigenschaften finden Sie unter Bearbeiten von Verknüpfungseigenschaften.

Die Registerkarte Compiler stellt einen Bereich zum Festlegen der Compilereigenschaften für Quellspezifikationsverknüpfungen und einen Bereich für das Festlegen der Compilereigenschaften für Zielspezifikationsverknüpfungen bereit. Weitere Informationen zum Ändern dieser Einstellungen finden Sie in den folgenden Themen:

  • Auswählen von Compilereigenschaften für Quellspezifikationsverknüpfungen

  • Auswählen von Compilereigenschaften für Zielspezifikationsverknüpfungen

Verwandtes Thema

Anzeigen von Verknüpfungseigenschaften: Registerkarte "Allgemein"


Auswählen von Compilereigenschaften für Quellspezifikationsverknüpfungen

  1. Klicken Sie mit der rechten Maustaste auf eine Verknüpfung im Zuordnungsraster, die mit einem Knoten in der Quellspezifikation verbunden ist, und klicken Sie auf Eigenschaften.

  2. Klicken Sie auf die Registerkarte Compiler, und klicken Sie auf eine der folgenden Optionen im Bereich Quellspezifikationsverknüpfungen:
    • Wert kopieren (Standard). Kopiert den Wert des Knotens in die eingehende Dokumentinstanz.

    • Namen kopieren. Kopiert den Namen des Knotens in die eingehende Dokumentinstanz.
  3. Klicken Sie auf OK.

Verwandtes Thema

Auswählen von Compilereigenschaften für Zielspezifikationsverknüpfungen


Auswählen von Compilereigenschaften für Zielspezifikationsverknüpfungen

  1. Klicken Sie mit der rechten Maustaste auf eine Verknüpfung im Zuordnungsraster, die mit einem Knoten in der Zielspezifikation verbunden ist, und klicken Sie auf Eigenschaften.

  2. Klicken Sie auf die Registerkarte Compiler, und klicken Sie auf eine der folgenden Optionen im Bereich Zielspezifikationsverknüpfungen:
    • Verknüpfungen vereinfachen (Standard). Dieser Modus bedeutet, dass die Quell- und Zielspezifikationen zusammenpassen und dass eine 1:1-Verknüpfung für jeden Datensatz und jedes Feld erstellt wird.

    • Verknüpfungen von oben nach unten zuordnen. Dieser Modus ordnet jeweils eine Ebene einer anderen Ebene zu, wobei von oben nach unten verfahren wird.

    • Verknüpfungen von unten nach oben zuordnen. Dieser Modus ordnet jeweils eine Ebene einer anderen Ebene zu, wobei von unten nach oben verfahren wird.
  3. Klicken Sie auf OK.

Anmerkungen

  • Wenn Sie eine Compilerdirektive des Typs Verknüpfungen vereinfachen, Von oben nach unten zuordnen und Von unten nach oben zuordnen für Verknüpfungen von Feldern in der Quellspezifikation mit Feldern in der Zielspezifikation verwenden, die denselben übergeordneten Datensatz haben, behandelt der BizTalk-Mapper alle diese Verknüpfungen so, als ob sie auf die Compilerdirektive des Typs Verknüpfungen vereinfachen festgelegt wären.

  • Wenn Sie eine oder mehrere Compilerdirektiven des Typs Verknüpfungen vereinfachen und eine Compilerdirektive des Typs Von oben nach unten zuordnen für Verknüpfungen von Feldern in der Quellspezifikation mit Feldern in der Zielspezifikation verwenden, die denselben übergeordneten Datensatz haben, behandelt der BizTalk-Mapper alle diese Verknüpfungen so, als ob sie auf die Compilerdirektive des Typs Von oben nach unten zuordnen festgelegt wären.

  • Wenn Sie eine oder mehrere Compilerdirektiven des Typs Verknüpfungen vereinfachen und eine Compilerdirektive des Typs Von unten nach oben zuordnen für Verknüpfungen von Feldern in der Quellspezifikation mit Feldern in der Zielspezifikation verwenden, die denselben übergeordneten Datensatz haben, behandelt der BizTalk-Mapper alle diese Verknüpfungen so, als ob sie auf die Compilerdirektive des Typs Von unten nach oben zuordnen festgelegt wären.

  • Wenn Sie eine oder mehrere Compilerdirektiven des Typs Von oben nach unten zuordnen und eine oder mehrere Compilerdirektiven des Typs Von unten nach oben zuordnen für Verknüpfungen von Feldern in der Quellspezifikation mit Feldern in der Zielspezifikation verwenden, die denselben übergeordneten Datensatz haben, behandelt der BizTalk-Mapper alle diese Verknüpfungen so, als ob sie auf die Compilerdirektive des Typs Verknüpfungen vereinfachen festgelegt wären.

Verwandte Themen

Zuordnen der Ebenen innerhalb der Knotenhierarchie

Auswählen von Compilereigenschaften für Quellspezifikationsverknüpfungen


Erstellen und Verwalten von kompilierten Zuordnungen

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Kompilieren von Zuordnungen

  • Auflösen von Warnungen und Beheben von Fehlern nach dem Kompilieren einer Zuordnung

  • Hinzufügen von konstanten Werten


Kompilieren von Zuordnungen

  • Klicken Sie im Menü Extras auf Zuordnung kompilieren.

Vorsicht

  • Der BizTalk-Mapper generiert eine Warnung auf der Registerkarte Warnungen, wenn der Compiler auf einen Umstand stößt, der zu fehlerhaften Ergebnissen führt. Eine Zuordnung kann erst dann als für eine produktive Umgebung einsatzbereit betrachtet werden, wenn sie keine Warnungen mehr generiert.

Verwandtes Thema

Auflösen von Warnungen und Beheben von Fehlern nach dem Kompilieren einer Zuordnung


Auflösen von Warnungen und Beheben von Fehlern nach dem Kompilieren einer Zuordnung

  1. Doppelklicken Sie auf der Registerkarte Warnungen auf eine Warnung.

    Die Verknüpfung oder das Funktoid, auf die bzw. das sich die Warnung oder der Fehler bezieht wird im Zuordnungsraster aufgehellt dargestellt.

  2. Ändern Sie ggf. die Verknüpfung oder das Funktoid.

  3. Wiederholen Sie die Schritt 1-2 für jede Warnung.

  4. Klicken Sie im Menü Extras auf Zuordnung kompilieren.

Verwandte Themen

Kompilieren von Zuordnungen


Hinzufügen von konstanten Werten

  1. Wählen Sie einen Datensatz oder ein Feld in der Struktur der Zielspezifikation aus, und klicken Sie auf die Registerkarte Werte.

  2. Geben Sie in das Feld Konstanter Wert für Ziel einen Wert ein, den Sie dem Datensatz oder Feld zuordnen möchten.

Anmerkung

  • Sie können keine Verknüpfung zu einem Datensatz oder Feld erstellen, dem ein konstanter Wert zugeordnet ist.

  • Sie können einem Datensatz nur dann einen konstanten Wert zuordnen, wenn seine Eigenschaft Inhalt auf Nur Text festgelegt wurde. Weitere Informationen zur Eigenschaft Inhalt finden Sie unter Festlegen von Deklarationseigenschaften.

Verwandtes Thema

Festlegen von Deklarationseigenschaften


Testen von Zuordnungen

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Testen von Eigenschaften für verknüpfte Datensätze und Felder testen

  • Testen von Verknüpfungen

  • Testen von Funktoiden


Testen von Eigenschaften für verknüpfte Datensätze und Felder testen

Wichtig

  • Kompilieren Sie eine Zuordnung immer, bevor Sie diese testen, damit Sie Warnungen auflösen und Fehler beheben können. Weitere Informationen finden Sie unter Kompilieren von Zuordnungen.
  1. Klicken Sie auf ein Feld in der Struktur der Quellspezifikation, die mit einer Verknüpfung verbunden ist.

  2. Klicken Sie auf die Registerkarte Werte.

  3. Geben Sie einen Wert in das Feld Quelltestwert ein.

  4. Klicken Sie im Menü Extras auf Zuordnung testen.

    Wichtig

    • Vor Beginn des Tests werden Sie aufgefordert, Ihre Datei zu speichern. Speichern Sie Ihre Datei vor dem Testen als Sicherheitsmaßnahme für den Fall, dass unvorhergesehene Fehler in der Datei auftreten.
  5. Klicken Sie auf Ja, um die Zuordnung zu aktualisieren.

  6. Überprüfen Sie die Ergebnisse auf der Registerkarte Ausgabe.

Anmerkung

  • Falls die Eigenschaft Maximalvorkommen für einen Datensatz ein Sternchen (*) ist, gibt dies an, dass dies eine Schleifendatensatz ist. Die eingehende Dokumentinstanz, die der BizTalk-Mapper generiert, um die Zuordnung zu testen, enthält zwei Vorkommnisse des Datensatzes.

Verwandte Themen

Kompilieren von Zuordnungen

Testen von Zuordnungen


Testen von Verknüpfungen

Wichtig

  • Kompilieren Sie eine Zuordnung immer, bevor Sie diese Testen, damit Sie Warnungen auflösen und Fehler beheben können. Weitere Informationen finden Sie unter Kompilieren von Zuordnungen.
  1. Klicken Sie auf ein Feld in der Struktur der Quellspezifikation, die mit einer Verknüpfung verbunden ist.

  2. Klicken Sie auf die Registerkarte Werte.

  3. Geben Sie einen Wert in das Feld Quelltestwert ein.

  4. Klicken Sie im Menü Extras auf Zuordnung testen.

    Wichtig

    • Vor Beginn des Tests werden Sie aufgefordert, Ihre Datei zu speichern. Speichern Sie Ihre Datei vor dem Testen als Sicherheitsmaßnahme für den Fall, dass unvorhergesehene Fehler in der Datei auftreten.
  5. Klicken Sie auf Ja, um die Zuordnung zu aktualisieren.

  6. Überprüfen Sie die Ergebnisse auf der Registerkarte Ausgabe.

Verwandte Themen

Kompilieren von Zuordnungen

Testen von Zuordnungen


Testen von Funktoiden

Wichtig

  • Kompilieren Sie eine Zuordnung immer, bevor Sie diese Testen, damit Sie Warnungen auflösen und Fehler beheben können. Weitere Informationen finden Sie unter Kompilieren von Zuordnungen.
  1. Klicken Sie im Menü Extras auf Zuordnung testen.

    Wichtig

    • Vor Beginn des Tests werden Sie aufgefordert, Ihre Datei zu speichern. Speichern Sie Ihre Datei vor dem Testen als Sicherheitsmaßnahme für den Fall, dass unvorhergesehene Fehler in der Datei auftreten.
  2. Klicken Sie auf Ja, um die Zuordnung zu aktualisieren.

  3. Überprüfen Sie die Ergebnisse auf der Registerkarte Ausgabe.

Verwandte Themen

Kompilieren von Zuordnungen

Testen von Zuordnungen


Verwalten von Ansichten

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Erweitern von Strukturelementen

  • Reduzieren von Strukturelementen

  • Anzeigen von Datensatz- und Feldeigenschaften

  • Anzeigen von Namespaces

  • Anpassen der Fenstergröße für die Struktur der Quellspezifikation

  • Anpassen der Fenstergröße für die Struktur der Zielspezifikation

  • Ändern der Größe des unteren Fensters


Erweitern von Strukturelementen

  • Klicken Sie auf den Stammknoten oder einen Datensatz in der Spezifikationsstruktur, den Sie erweitern möchten, und klicken Sie im Menü Ansicht auf Strukturelemente erweitern.

    Oder

    Klicken Sie mit der rechten Maustaste auf einen Stammknoten oder einen Datensatz in einer Struktur, und klicken Sie auf Strukturelemente erweitern.

Verwandtes Thema

Reduzieren von Strukturelementen


Reduzieren von Strukturelementen

  • Klicken Sie auf den Stammknoten oder einen Datensatz in der Spezifikationsstruktur, den Sie reduzieren möchten, und klicken Sie im Menü Ansicht auf Strukturelemente reduzieren.

Anmerkung

  • Sie können auch mit der rechten Maustaste auf den Stammknoten oder einen Datensatz in einer Struktur klicken und dann auf Strukturelemente reduzieren klicken.

Verwandtes Thema

Erweitern von Strukturelementen


Anzeigen von Datensatz- und Feldeigenschaften

  • Klicken Sie auf einen Datensatz oder ein Feld entweder in der Struktur der Quellspezifikation oder in der Struktur der Zielspezifikation, und klicken Sie im Menü Ansicht auf Eigenschaften.

    Oder

    Wählen Sie einen Datensatz oder ein Feld in einer der Strukturen aus, und klicken Sie auf die Registerkarte Eigenschaften.

Anmerkung

  • Sie müssen möglicherweise die Bildlaufleiste auf der Registerkarte Eigenschaften ziehen, um eine bestimmte Eigenschaft und den ihr zugeordneten Wert zu sehen.


Anzeigen von Namespaces

Sie können die Namespaces in einer Zuordnung anzeigen, indem Sie die Zuordnung in Microsoft Internet Explorer 5 oder höher anzeigen.

  1. Starten Sie den Internet Explorer, und gehen Sie zu der Zuordnungsdatei, die Sie öffnen möchten.

  2. Blättern Sie zum ersten Tag <schema> (direkt gefolgt vom Tag <srctree>), um die Informationen zum Namespace für die Quellspezifikation zu sehen.

  3. Blättern Sie zum zweiten Tag <schema> (direkt gefolgt vom Tag <sinktree>), um die Informationen zum Namespace für die Zielspezifikation zu sehen.

Verwandtes Thema

Namespaceunterstützung


Anpassen der Fenstergröße für die Struktur der Quellspezifikation

  1. Positionieren Sie den Cursor an den rechten Fensterrand der Struktur der Quellspezifikation, bis sich der Cursor in einen Pfeil mit zwei Spitzen verwandelt.

  2. Ziehen Sie den Rand nach rechts, um die Fenstergröße zu vergrößern, oder nach links, um die Fenstergröße zu verringern.

Anmerkung

  • Doppelklicken Sie auf den Rand, um seine Standardposition wiederherzustellen.

Verwandte Themen

Anpassen der Fenstergröße für die Struktur der Zielspezifikation

Ändern der Größe des unteren Fensters


Anpassen der Fenstergröße für die Struktur der Zielspezifikation

  1. Positionieren Sie den Cursor an den linken Fensterrand der Struktur der Zielspezifikation, bis sich der Cursor in einen Pfeil mit zwei Spitzen verwandelt.

  2. Ziehen Sie den Rand nach links, um die Fenstergröße zu vergrößern, oder nach rechts, um die Fenstergröße zu verringern.

Anmerkung

  • Doppelklicken Sie auf den Rand, um seine Standardposition wiederherzustellen.

Verwandte Themen

Anpassen der Fenstergröße für die Struktur der Quellspezifikation

Ändern der Größe des unteren Fensters


Ändern der Größe des unteren Fensters

  1. Positionieren Sie den Cursor an den oberen Rand des unteren Fensters, bis sich der Cursor in einen Pfeil mit zwei Spitzen verwandelt.

  2. Ziehen Sie das Fenster nach oben, um die Fenstergröße zu vergrößern, oder nach unten, um die Fenstergröße zu verringern.

Anmerkung

  • Doppelklicken Sie auf den Rand, um seine Standardposition wiederherzustellen.

Verwandte Themen

Anpassen der Fenstergröße für die Struktur der Zielspezifikation

Anpassen der Fenstergröße für die Struktur der Quellspezifikation


Anpassen der Benutzeroberfläche

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Ändern der Farben des Zuordnungsrasters

  • Ändern der Farbe von Verknüpfungen

  • Ändern der Farbe von ausgewählten Objekten

  • Ändern der Farbe von Compilerwarnungen

  • Wiederherstellen der Standardfarben

  • Ändern der Textgröße


Ändern der Farben des Zuordnungsrasters

  1. Klicken Sie im Menü Extras auf Optionen.

    Das Dialogfeld Optionen für den BizTalk-Mapper wird angezeigt.

  2. Klicken Sie auf die Registerkarte Farben.

  3. Klicken Sie auf das Kästchen neben Rastervordergrund, das die gestrichelten Linien im Zuordnungsraster darstellt. Wählen Sie aus der Farbpalette eine neue Farbe aus.

    Oder

    Klicken Sie auf das Kästchen neben Rasterhintergrund, das die Hintergrundfarbe des Zuordnungsrasters darstellt. Wählen Sie aus der Farbpalette eine neue Farbe aus.

  4. Klicken Sie auf OK.

Verwandte Themen

Ändern der Farbe von Compilerwarnungen

Ändern der Farbe von Verknüpfungen

Ändern der Farbe von ausgewählten Objekten

Wiederherstellen der Standardfarben


Ändern der Farbe von Verknüpfungen

  1. Klicken Sie im Menü Extras auf Optionen.

    Das Dialogfeld Optionen für den BizTalk-Mapper wird angezeigt.

  2. Klicken Sie auf die Registerkarte Farben.

  3. Klicken Sie auf das Kästchen neben einer der folgenden Optionen:
    • Feste Verknüpfungen. Feste Verknüpfungen sind einfache wertekopierende Verknüpfungen im Zuordnungsraster.

    • Elastische Verknüpfungen. Elastische Verknüpfungen sind einfache wertekopierende Verknüpfungen, die aus der Struktur der Quellspezifikation in die Struktur der Zielspezifikation gezogen werden. Nach dem Erstellen der Verknüpfung ändert sich die Farbe der Verknüpfung in die zuvor festgelegte Farbe für Verknüpfungen.

    • Teilverknüpfungen. Teilverknüpfungen sind Verknüpfungen, die für ein Feld oder einen Datensatz bestehen, dessen übergeordneter Datensatz reduziert ist.

    • Compilerverknüpfungen. Compilerverknüpfungen sind Compilerdirektivenverknüpfungen. Dies sind Verknüpfungen, die automatisch erstellt werden, wenn eine Verknüpfung von einem Feld in der Struktur der Quellspezifikation zu einem Feld in der Struktur der Zielspezifikation erstellt wird und die Hierarchie der beiden Strukturen nicht zusammenpasst.
  4. Wählen Sie aus der Farbpalette eine neue Farbe aus.

  5. Wiederholen Sie Schritt 3, um ggf. weitere Farben zu ändern.

  6. Klicken Sie auf OK.

Verwandte Themen

Ändern der Farben des Zuordnungsrasters

Ändern der Farbe von Compilerwarnungen

Ändern der Farbe von ausgewählten Objekten

Wiederherstellen der Standardfarben


Ändern der Farbe von ausgewählten Objekten

  1. Klicken Sie im Menü Extras auf Optionen.

  2. Klicken Sie im Dialogfeld Optionen für den BizTalk-Mapper auf die Registerkarte Farben.

  3. Klicken Sie in das Kästchen neben Ausgewählte Objekte, und wählen Sie aus der Farbpalette eine neue Farbe aus.

  4. Klicken Sie auf OK.

Verwandte Themen

Ändern der Farben des Zuordnungsrasters

Ändern der Farbe von Compilerwarnungen

Ändern der Farbe von Verknüpfungen

Wiederherstellen der Standardfarben


Ändern der Farbe von Compilerwarnungen

  1. Klicken Sie im Menü Extras auf Optionen.

    Das Dialogfeld Optionen für den BizTalk-Mapper wird angezeigt.

  2. Klicken Sie auf die Registerkarte Farben.

  3. Klicken Sie in das Kästchen neben Compilerwarnungen, und wählen Sie aus der Farbpalette eine neue Farbe aus.

  4. Klicken Sie auf OK.

Verwandte Themen

Ändern der Farben des Zuordnungsrasters

Ändern der Farbe von Verknüpfungen

Ändern der Farbe von ausgewählten Objekten

Wiederherstellen der Standardfarben


Wiederherstellen der Standardfarben

  1. Klicken Sie im Menü Extras auf Optionen.

    Das Dialogfeld Optionen für den BizTalk-Mapper wird angezeigt.

  2. Klicken Sie auf die Registerkarte Farben.

  3. Klicken Sie auf Standardfarben wiederherstellen, und klicken Sie auf OK.

Verwandte Themen

Ändern der Farben des Zuordnungsrasters

Ändern der Farbe von Compilerwarnungen

Ändern der Farbe von Verknüpfungen

Ändern der Farbe von ausgewählten Objekten


Grundbegriffe

Dieser Abschnitt stellt detaillierte Informationen zum Konzept bereit, die wichtig für das Verständnis des BizTalk-Mappers sind.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Zuordnen von Spezifikationen

  • Zuordnen von Szenarien

  • BizTalk-Mapper - Umgebung

  • Erstellen von Verknüpfungen

  • Zuordnen der Ebenen innerhalb der Knotenhierarchie

  • Anzeigen von Datensatz-, Feld-, Verknüpfungs- und Funktoideigenschaften

  • Grundlegendes zu Funktoiden

  • Kompilieren von Zuordnungen

  • Testen von Zuordnungen


Zuordnen von Spezifikationen

Eine Zuordnung identifiziert die Art und Weise, in der Daten des einen Formats in einem anderen Format dargestellt werden. Eine Zuordnung erfordert zwei Spezifikationen. Die eine Spezifikation dient als Quelle und die andere als Ziel. Die Zuordnung von Daten definiert einen Prozess der Datenübersetzung, bei dem die Entsprechungen zwischen den Datensätzen und Feldern der Quellspezifikation und den Datensätzen und Feldern der Zielspezifikation festgelegt werden.

Es gibt zwei Arten von Zuordnungen: Die erste Art der Zuordnung ist eine spezifische Zuordnung und dient dem Zweck, den individuellen Erfordernissen eines bestimmten Handelspartners gerecht zu werden. Die zweite Art der Zuordnung ist eine allgemeine Zuordnung und dient dem Zweck, die Erfordernisse mehrerer Handelspartner abzudecken. Sollen die speziellen Datensätze und Felder eines bestimmten Handelspartners in einer Zuordnung erfasst werden, erstellen Sie eine Zuordnung, die sich nur auf diesen Handelspartner bezieht. Bei allgemeinen Zuordnungen erfassen und gruppieren Sie die Anforderungen mehrerer Handelspartner innerhalb einer einzigen Zuordnung. Da mehrere Organisationen miteinander vernetzt sein können und Sie dieselbe Zuordnung für die Dokumente mehrerer Handelspartner verwenden können, hilft Ihnen dieses Feature, wertvolle Ressourcen und Zeit zu sparen.

Der BizTalk-Mapper zeigt eine grafische Darstellung einer Zuordnung an, die sowohl einfache Übersetzungen, bei denen Werte kopiert werden und die als Verknüpfungen bezeichnet werden, als auch Elemente für die komplexe strukturelle Bearbeitung enthalten kann, die als Funktoide bezeichnet werden. Durch Kombinieren dieser Elemente können Sie auf einfache Weise eine Zuordnung zwischen den Daten einer Quellspezifikation und den Daten einer Zielspezifikation festlegen.


Zuordnen von Szenarien

Folgende Themen werden in diesem Abschnitt behandelt:

  • Schleifenpfade

  • Reihenfolge von Datensätzen und Feldern


Schleifenpfade

Ein Datensatz einer Spezifikation ist ein Schleifendatensatz, wenn die Maximalvorkommen-Eigenschaft auf der Registerkarte Verweis für jenen Datensatz auf * festgelegt ist. Weitere Informationen zur Maximalvorkommen-Eigenschaft finden Sie unter Festlegen von Verweiseigenschaften.

Ein Schleifenpfad tritt in einer Zuordnung auf, wenn ein Feld innerhalb eines Schleifendatensatzes der Quellspezifikation mit einem Feld innerhalb eines Schleifendatensatzes der Zielspezifikation verknüpft ist. Die folgende Abbildung zeigt zwei Schleifenpfade: einer führt von Stamm\Datensatz1\Feld1 (Root\Record1\Field1) nach Stamm\DatensatzA\Feld1 (Root\RecordA\Field1) und der andere von Stamm\Datensatz2\Feld2 (Root\Record2\Field2) nach \Stamm\DatensatzB\Feld3 (\Root\RecordB\Field3).

Klicken Sie zum Vergrößern oder Verkleinern auf die Abbildung.

Zuordnung mit Schleifenpfad

Der Registerkarte Eigenschaften ist zu entnehmen, dass es sich bei Datensatz1 (Record1) und DatensatzA (RecordA) um Schleifendatensätze handelt. Auch Datensatz2 (Record2) und DatensatzB (RecordB) sind Schleifendatensätze .

Der folgende Code zeigt ein Beispiel für ein Eingabedokument:

<Root>
<Record1 Field1=Red>
<Record1 Field1=Green>
<Record1 Field1=Blue>
<Record2 Field2=50>
<Record2 Field2=100>
</Root>

Unter Verwendung der zuvor gezeigten Zuordnung würde dieses Eingabedokument in das folgende Ausgabedokument umgewandelt werden:

<Root>
<RecordA Field1=Red>
<RecordA Field1=Green>
<RecordA Field1=Blue>
<RecordB Field3=50>
<RecordB Field3=100>
</Root>

Eine Zuordnung weist einen Mehrfachschleifenpfad auf, wenn Felder aus zwei oder mehr Schleifendatensätzen der Quellspezifikation mit Feldern eines einzelnen Schleifendatensatzes der Zielspezifikation verknüpft sind.

Die folgende Abbildung zeigt ein Beispiel für einen Mehrfachschleifenpfad.

Klicken Sie zum Vergrößern oder Verkleinern auf die Abbildung.

Zuordnung mit Mehrfach-Schleifenpfad

Mehrfachschleifenpfade werden vom BizTalk-Mapper nicht unterstützt. Wenn Sie versuchen, eine Zuordnung zu kompilieren, die einen Mehrfachschleifenpfad enthält, zeigt die Registerkarte Warnungen an, dass der Zielknoten mehrere Quellschleifenpfade besitzt.

Verwandte Themen

Festlegen von Verweiseigenschaften


Reihenfolge von Datensätzen und Feldern

Eine implizite Reihenfolge der Datensätze und Felder in der Ausgabe wird von XSL (Extensible Stylesheet Language) nicht gewährleistet Der Grund dafür ist, dass der BizTalk-Mapper zum Generieren der XSL-Spezifikation die Struktur der Zielspezifikation durchläuft und anschließend die Verknüpfungen über das Zuordnungsraster zurückverfolgt, um Werte aus der Quellspezifikationsstruktur zu extrahieren. Wenn Sie beispielsweise eine Ausgabedatei erzeugen möchten, die zuerst alle Datensätze mit Rechnungsadressen (RechnungAn) und anschließend alle Datensätze mit Lieferadressen (LiefernAn) enthält, müssen Sie sicherstellen, dass in der Zielspezifikation der RechnungAn-Adressdatensatz vor dem LiefernAn-Adressdatensatz aufgeführt ist.

Die folgende Abbildung illustriert diese Struktur.

Klicken Sie zum Vergrößern oder Verkleinern auf die Abbildung.

Das Feld Kontakttyp kennt zwei gültige Codes (RA und LA), die die Adressen entweder als RechnungAn-Adresse oder als LiefernAn-Adresse kennzeichnen. Um die gewünschte Ausgabe zu generieren, werden zum Zuordnungsraster Funktoide des Typs Gleich hinzugefügt und einerseits mit Feldern der Quellspezifikation sowie andererseits mit Datensätzen der Zielspezifikation verknüpft.

Das erste Funktoid überprüft für die Zuordnung die folgende Bedingung:

Hat Kontakttyp den Wert RA?

Wenn diese Bedingung erfüllt ist, wird ein Ausgabedatensatz des Typs RechnungAnAdresse generiert und es werden ihm die erforderlichen Felder zugeordnet. Ist die Bedingung nicht erfüllt, muss der BizTalk-Mapper erneut alle Eingabe-Adressdatensätze durchlaufen.

Wichtig

  • Die Reihenfolge, in der die Datensätze und Felder in einer Ausgabedokumentinstanz erscheinen, hängt von der Reihenfolge der Datensätze und Felder in der entsprechenden Ausgabespezifikation ab.


BizTalk-Mapper - Umgebung

Folgende Themen werden in diesem Abschnitt behandelt:

  • BizTalk-Mapper - Benutzeroberfläche

  • BizTalk-Mapper - Menüs

  • BizTalk-Mapper - Symbolleisten-Schaltflächen

  • BizTalk-Mapper - Funktoidpalette

  • BizTalk-Mapper - Tastenkombinationen


BizTalk-Mapper - Benutzeroberfläche

Die beiden Spezifikationen, die an der Erstellung einer Zuordnung beteiligt sind, werden im Hauptfenster des BizTalk-Mappers als Strukturansichten angezeigt. Die Quellspezifikation befindet sich auf der linken Seite. Von ihr ausgehend werden die Daten per Zuordnung auf die Zielspezifikation abgebildet, die auf der rechten Seite zu sehen ist. Das zwischen den beiden Spezifikationen befindliche Zuordnungsraster illustriert auf grafische Weise die strukturelle Datentransformation zwischen den beiden Spezifikationen. Verknüpfungen und Funktoide werden innerhalb des Zuordnungsrasters angezeigt. Bewegungen innerhalb des Zuordnungsrasters nach oben, unten, rechts oder links lassen sich problemlos durchführen, indem Sie den Mauszeiger über die Ränder des Zuordnungsrasters bewegen.

Sie können das Dialogfeld Rastervorschau verwenden, um innerhalb des Zuordnungsrasters schnell von einer Position zu einer anderen zu wechseln. Durch Ziehen der grünen Positionierungsleiste können Sie sich nach oben, unten, links oder rechts bewegen. Ein Funktoid des Zuordungsrasters wird in der Rastervorschau als ein rotes Feld, das von einem schwarzen Rand umgeben ist, angezeigt. Sind zwei oder mehr Funktoide im Zuordnungsraster enthalten, werden sie grafisch als zwei rote Felder dargestellt, die miteinander verbunden und von einem schwarzen Rand umgeben sind.

Unterhalb der Strukturansichten und des Zuordnungsrasters befindet sich der untere Bereich. Dieser Bereich enthält vier Registerkarten:

  • Eigenschaften Bei Auswahl eines Knotens in der Quellspezifikations- oder Zielspezifikationsstruktur zeigt die Registerkarte Eigenschaften die Eigenschaften und die Werte der Eigenschaften für diesen Knoten an.

  • Werte Auf dieser Registerkarte befinden sich zwei Textfelder, Quelltestwert und Konstanter Wert für Ziel. Sie können ein Feld auswählen und anschließend einen Wert in das Feld Quelltestwert eingeben. Dies ermöglicht es Ihnen, Zuordnungen mit den tatsächlichen Werten zu testen, die Sie den Feldern zugewiesen haben. Im Feld Konstanter Wert für Ziel können Sie einen Wert eingeben, der einem Feld der Zielstruktur zugewiesen werden soll. Es ist nicht möglich, eine Verknüpfung zwischen einem Funktoid oder einem Knoten der Quellspezifikation und einem Feld der Zielspezifikation herzustellen, dem ein konstanter Wert zugewiesen wurde.

  • Ausgabe Diese Registerkarte zeigt ein kompiliertes XSL (Extensible Stylesheet Language)-Stylesheet an, wenn Sie eine Zuordnung kompiliert haben, und sie zeigt die Testausgabe an, wenn Sie eine Zuordnung getestet haben.

  • Warnungen Diese Registerkarte zeigt nach der Kompilierung einer Zuordnung Compilerwarnungen an.

Verwandte Themen

Kompilieren von Zuordnungen

Testen von Zuordnungen

Anzeigen von Verknüpfungen und Funktoiden mithilfe der Rastervorschau


BizTalk-Mapper - Menüs

Die Menüs des BizTalk-Mappers bieten eine logische Zusammenfassung von Befehlen und vereinfachen auf diese Weise die Ausführung einer bestimmten Aufgabe. Sie können beispielsweise die Befehle im Menü Ansicht dazu verwenden, alle Datensätze und Felder der Quellspezifikationstruktur anzuzeigen oder alle Datensätze und Felder der Zielspezifikationsstruktur auszublenden.

Der BizTalk-Mapper verfügt über folgende Menüs:

  • Datei. Verwenden Sie dieses Menü, um eine Zuordnung neu zu erstellen, zu öffnen, zu speichern oder zu schließen.

  • Bearbeiten. Verwenden Sie dieses Menü, um die Quell- oder Zielspezifikation zu ersetzen, oder um ein Objekt innerhalb des Zuordnungsrasters zu löschen.

  • Ansicht. Verwenden Sie dieses Menü, um die Funktoidpalette, die Eigenschaften von Funktoiden und die Rastervorschau anzuzeigen. Außerdem können Sie dieses Menü dazu verwenden, die Textgröße für die Anzeige im BizTalk-Mapper auszuwählen, die Registerkarten im unteren Fensterbereich zu aktivieren, die Strukturansichten der Spezifikationen zu erweitern oder zu reduzieren, oder die nächste Warnmeldung auf der Registerkarte Warnungen hervorzuheben.

  • Extras. Verwenden Sie dieses Menü, um Zuordnungen zu kompilieren und zu testen und um die Optionen für den BizTalk-Mapper anzuzeigen.

  • Hilfe. Verwenden Sie dieses Menü, um praktische Anleitungen und Grundlageninformationen zur Verwendung des BizTalk-Mappers zu erhalten.

Verwandtes Thema

BizTalk-Editor - Menüs


BizTalk-Mapper - Symbolleisten-Schaltflächen

Der BizTalk-Mapper stellt als Ergänzung zur Menüleiste eine Symbolleiste zur Verfügung. Alle Schaltflächen der Symbolleiste zeigen grafische Darstellungen der Aufgaben, die sie ausführen. Sie werden auf der Symbolleiste in folgender Reihenfolge angezeigt (von links nach rechts):

  • Neu

  • Öffnen

  • Speichern

  • Aus WebDAV abrufen

  • Im WebDAV speichern

  • Löschen

  • Reduzieren

  • Erweitern

  • Funktoidpalette anzeigen

  • Zuordnung kompilieren

  • Zuordnung testen


BizTalk-Mapper - Funktoidpalette

Die Funktoidpalette enthält alle Funktoide, die im BizTalk-Mapper zur Verfügung stehen. Ein Funktoid beinhaltet Code, der Daten von einem Datensatz oder Feld der Quellspezifikation oder von einem anderen Funktoid (z. B. dem Funktoid Datum) übernimmt, diese Daten eigenständig verarbeitet und anschließend einen neuen Wert zurückgibt, der in einen Datensatz oder ein Feld der Zielspezifikation übertragen wird. Weitere Informationen zur Funktoidpalette finden Sie unter Grundlegendes zu Funktoiden.

Verwandte Themen

Grundlegendes zu Funktoiden

Arbeiten mit der Funktoidpalette


BizTalk-Mapper - Tastenkombinationen

Der BizTalk-Mapper bietet verschiedene Tastenkombinationen zum Ausführen von Aufgaben . Die folgende Tabelle ist eine kurze Referenz zu diesen Tastenkombinationen.

Anmerkung

  • Um Funktionen zu verwenden, die in dieser Liste nicht enthalten sind, können Sie mithilfe der Zehnertastatur den Mauszeiger mit der Tastaturmaus bewegen. Weitere Informationen zur Tastaturmaus finden Sie in der Windows 2000 Server- und Advanced Server-Hilfe unter "Bewegen des Mauszeigers mithilfe der Tastatur". Weitere Informationen zur Tastaturmaus finden Sie in der Windows 2000 Professional-Hilfe unter "Bewegen des Mauszeigers mithilfe der Tastaturmaus".
Tastenkombination | Zweck
STRG+N | Eine neue Spezifikation öffnen.
STRG+O | Eine vorhandene Zuordnung öffnen.
STRG+S | Eine Zuordnung speichern.
STRG+F5 | Eine Zuordnung testen.
F4 | Die nächste Warnmeldung markieren.
F5 | Eine Zuordnung kompilieren.
ENTF | Ein Objekt im Zuordnungsraster löschen.
F6 | Den Fokus im Uhrzeigersinn zum nächsten Fensterbereich verschieben.
UMSCHALT+F6 | Den Fokus entgegen dem Uhrzeigersinn zum nächsten Fensterbereich verschieben. Durch Drücken von UMSCHALT+F6 nach dem Öffnen der Funktoidpalette wird der Fokus zur Registerkarte Zeichenfolge verschoben; mit der linken oder rechten Pfeiltaste können die anderen Registerkarten angezeigt werden.
TAB | Fokus im Uhrzeigersinn im unteren Fensterbereich von der Registerkarte zu den Fensterbereichen oder Feldern darunter verschieben. Durch Drücken von TAB in einem Dialogfeld wird der Fokus zwischen den Schaltflächen und Feldern im Dialogfeld verschoben.
UMSCHALT+TAB | Fokus entgegen dem Uhrzeigersinn im unteren Fensterbereich von der Registerkarte zu den Fensterbereichen oder Feldern darunter verschieben.
LEERTASTE | Aktivieren oder Deaktivieren eines Kontrollkästchens. Die Leertaste verhält sich darüber hinaus wie ein Mausklick, wenn der Fokus sich auf einer Schaltfläche befindet.
F1 | Onlinehilfe anzeigen.
ALT+F4 | Programm schließen.
NACH-LINKS-TASTE | Registerkarte links aktivieren.
NACH-RECHTS-TASTE | Registerkarte rechts aktivieren.
Eine beliebige Pfeiltaste | Einen Ordner oder eine Datei im Hauptfensterbereich eines Dialogfeldes markieren, während sich der Fokus auf diesem Bereich befindet. Diese Funktion steht in den Dialogfeldern In WebDAV speichern und Aus WebDAV abrufen zur Verfügung. Weitere Informationen finden Sie unter Abrufen von Zuordnungen aus WebDAV.


Erstellen von Verknüpfungen

Verknüpfungen übernehmen die grundlegende Funktion, Daten aus Datensätzen und Feldern der Quellspezifikationsstruktur in Datensätze und Felder der Zielspezifikationsstruktur zu kopieren. Der BizTalk-Mapper unterstützt 1:1- und 1:n-Verknüpfungen. Eine Verknüpfung kann beispielsweise einen einzelnen Datensatz oder ein einzelnes Feld der Quellspezifikationsstruktur mit einem einzelnen Datensatz oder Feld der Zielspezifikationsstruktur verbinden. Es ist mit einer Verknüpfung auch möglich, einen einzelnen Datensatz oder ein einzelnes Feld der Quellspezifikationsstruktur mit mehreren Datensätzen oder Feldern der Zielspezifikationsstruktur zu verbinden. Schließlich können Verknüpfungen auch dazu verwendet werden, mehrere Datensätze oder Felder der Quellspezifikationsstruktur mit einem Funktoid zu verbinden, das mit einem einzelnen Datensatz oder Feld der Zielspezifikationsstruktur verbunden wird. Mehrere Datensätze oder Felder der Quellspezifikationsstruktur können mit einem einzelnen Datensatz oder Feld der Zielspezifikationsstruktur verbunden werden.

Verwandtes Thema

Verwalten von Verknüpfungen


Zuordnen der Ebenen innerhalb der Knotenhierarchie

Der BizTalk-Mapper unterstützt die Verwendung von Compilerdirektiven. Mithilfe dieser Direktiven können Sie festlegen, nach welchem Schema die Ebenen innerhalb der Hierarchie der Quellspezifikationsstruktur den Ebenen innerhalb der Hierarchie der Zielspezifikationsstruktur zuzuordnen sind. Wenn Sie eine Verknüpfung zwischen einem Feld der Quellspezifikationsstruktur und einem Feld der Zielspezifikationsstruktur definieren, fügt der BizTalk-Mapper zur Zuordnung automatisch Compilerverknüpfungen basierend auf den Optionen hinzu, die Sie im Dialogfeld Verknüpfungseigenschaften auf der Registerkarte Compiler im Gruppenfeld Zielspezifikationsverknüpfungen ausgewählt haben. Weitere Informationen dazu finden Sie unter Auswählen von Compilereigenschaften für Zielspezifikationsverknüpfungen. Die folgenden Abbildungen zeigen die möglichen Zuordnungen zwischen den Ebenen der Knotenhierarchie:

  • Verknüpfungen vereinfachen. (Standard). Dieser Modus bedeutet, dass der übergeordnete Datensatz der Verknüpfung eine 1:1-Verknüpfung mit jedem Datensatz der anderen Struktur besitzt. Im ersten gezeigten Fall ist die Quellspezifikation komplexer als die Zielspezifikation. Im zweiten gezeigten Fall ist die Zielspezifikation komplexer.
Wenn die Quellspezifikationsstruktur komplexer als die Zielspezifikationsstruktur ist: Verknüpfungen vereinfachen (Modus)
F2
S5
S4
Stamm2
F1
S3
S2
S1
Stamm1
Benutzerdefinierte Verknüpfung
Compilerverknüpfung

Wenn die Zielspezifikationsstruktur komplexer als die Quellspezifikationsstruktur ist: Verknüpfungen vereinfachen (Modus)
S5
S4
S3
Stamm2
F2
F1
S2
S1
Stamm1
Benutzerdefinierte Verknüpfung
Compilerverknüpfung

  • Verknüpfungen von oben nach unten zuordnen. Dieser Modus ordnet die Ebenen nacheinander von oben nach unten zu. Im ersten gezeigten Fall ist die Quellspezifikation komplexer als die Zielspezifikation. Im zweiten gezeigten Fall ist die Zielspezifikation komplexer.
Wenn die Quellspezifikation komplexer als die Zielspezifikation ist: Verknüpfungen von oben nach unten zuordnen (Modus)
F2
S5
S4
Stamm2
F1
S3
S2
S1
Stamm1
Benutzerdefinierte Verknüpfungen
Compilerverknüpfung

Wenn die Zielspezifikation komplexer als die Quellspezifikation ist: Verknüpfungen von oben nach unten zuordnen (Modus)
S5
S4
S3
Stamm2
F2
F1
S2
S1
Stamm1
Benutzerdefinierte Verknüpfungen
Compilerverknüpfung

  • Verknüpfungen von unten nach oben zuordnen. Dieser Modus ordnet die Ebenen nacheinander von unten nach oben zu. Im ersten gezeigten Fall ist die Quellspezifikation komplexer als die Zielspezifikation. Im zweiten gezeigten Fall ist die Zielspezifikation komplexer.
Wenn die Quellspezifikation komplexer als die Zielspezifikation ist: Verknüpfungen von unten nach oben zuordnen (Modus)
F2
R5
R4
Stamm2
F1
R3
R2
R1
Stamm1
Benutzerdefinierte Verknüpfungen
Compilerverknüpfungen

Wenn die Zielspezifikation komplexer als die Quellspezifikation ist: Verknüpfungen von unten nach oben zuordnen (Modus)
S5
S4
S3
Stamm2
F2
F1
S2
S1
Stamm1
Benutzerdefinierte Verknüpfungen
Compilerverknüpfung

Anmerkungen

  • Wenn Sie für Verknüpfungen von Feldern der Quellspezifikation mit Feldern der Zielspezifikation, die demselben übergeordneten Datensatz angehören, eine Compilerdirektive des Typs Verknüpfungen vereinfachen, eine Compilerdirektive des Typs Verknüpfungen von oben nach unten zuordnen und eine Compilerdirektive des Typs Verknüpfungen von unten nach oben zuordnen verwenden, behandelt der BizTalk-Mapper alle Verknüpfungen so, als ob für sie die Compilerdirektive des Typs Verknüpfungen vereinfachen festgelegt wurde.

  • Wenn Sie für Verknüpfungen von Feldern der Quellspezifikation mit Feldern der Zielspezifikation, die demselben übergeordneten Datensatz angehören, eine oder mehrere Compilerdirektiven des Typs Verknüpfungen vereinfachen und eine Compilerdirektive des Typs Verknüpfungen von oben nach unten zuordnen verwenden, behandelt der BizTalk-Mapper alle Verknüpfungen so, als ob für sie die Compilerdirektive Verknüpfungen von oben nach unten zuordnen festgelegt wurde.

  • Wenn Sie für Verknüpfungen von Feldern der Quellspezifikation mit Feldern der Zielspezifikation, die demselben übergeordneten Datensatz angehören, eine oder mehrere Compilerdirektiven des Typs Verknüpfungen vereinfachen und eine Compilerdirektive des Typs Verknüpfungen von unten nach oben zuordnen verwenden, behandelt der BizTalk-Mapper alle Verknüpfungen so, als ob für sie die Compilerdirektive Verknüpfungen von unten nach oben zuordnen festgelegt wurde.

  • Wenn Sie für Verknüpfungen von Feldern der Quellspezifikation mit Feldern der Zielspezifikation, die demselben übergeordneten Datensatz angehören, eine oder mehrere Compilerdirektiven des Typs Verknüpfungen von oben nach unten zuordnen und eine oder mehrere Compilerdirektiven des Typs Verknüpfungen von unten nach oben zuordnen verwenden, behandelt der BizTalk-Mapper alle Verknüpfungen so, als ob für sie die Compilerdirektive Verknüpfungen vereinfachen festgelegt wurde.

Verwandtes Thema

Kompilieren von Zuordnungen


Anzeigen von Datensatz-, Feld-, Verknüpfungs- und Funktoideigenschaften

Die Quellspezifikation und die Zielspezifikation zeigen alle Datensätze und Felder an, die einer Spezifikation zugeordnet sind. Diese Spezifikationen können Sie mit dem BizTalk-Editor neu erstellen oder in den BizTalk-Editor als wohlgeformtes XML importieren. Die Quellspezifikation wird links vom Zuordnungsraster und die Zielspezifikation rechts vom Zuordnungsraster angezeigt.

Datensatz- und Feldeigenschaften und deren Werte

Die Eigenschaften von Datensätzen und Feldern sowie die Werte dieser Eigenschaften werden auf der Registerkarte Eigenschaften angezeigt, die sich unterhalb des Hauptfensterbereichs befindet. Wenn Sie einen Datensatz oder ein Feld auswählen, werden die Haupteigenschaften und deren Werte aus den Eigenschaftsregisterkarten des BizTalk-Editors angezeigt.

Eigenschaften von Verknüpfungen und Funktoiden

Das Zuordnungsraster des BizTalk-Mappers illustriert auf grafische Weise die Struktur der Datentransformation. Verknüpfungen werden als einzelne Linien angezeigt, die einen Datensatz oder ein Feld der Quellspezifikationsstruktur mit einem Datensatz oder Feld der Zielspezifikationsstruktur verbinden. Verknüpfungen dienen auch dazu, einen Datensatz oder ein Feld mit einem Funktoid zu verbinden. Funktoide werden als Symbole angezeigt. Eigenschaften von Verknüpfungen beinhalten Informationen zu Quell- und Zieldaten sowie zu Compilerdirektiven. Eigenschaften von Funktoiden beinhalten Informationen zu Eingabeparameter und zugehörigen Skripten.

Verwandte Themen

Datensätze, Felder und Eigenschaften

Grundlegendes zu Funktoiden


Grundlegendes zu Funktoiden

Der BizTalk-Mapper unterstützt komplexe strukturbezogene Transformationen von Datensätzen und Feldern der Quellspezifikationsstruktur in Datensätze und Felder der Zielspezifikationsstruktur. Funktoide führen Berechnungen mithilfe vordefinierter Formeln und bestimmter, als Argumente bezeichneter Werte aus. Die Ausführung dieser Berechnungen erfolgt auf der Basis der angegebenen Reihenfolge der Datensätze und Felder. Daten können hinzugefügt, Datums- oder Zeitangaben modifiziert, Daten verkettet oder andere Operationen ausgeführt werden, indem ein Funktoid in der Funktoidpalette ausgewählt, auf den Zuordnungsraster gezogen und mit Elementen der Quellspezifikations- und Zielspezifikationsstruktur verknüpft wird. So bewirkt beispielsweise das Funktoid Addition die Addition von Werten.

Die Funktoidpalette umfasst die folgenden Registerkarten:

  • Zeichenfolge. Diese Funktoide bearbeiten Datenzeichenfolgen mithilfe von Zeichenfolgenfunktionen. Beispielsweise sucht das Funktoid Zeichenfolge suchen nach einer Textzeichenfolge innerhalb einer anderen Textzeichenfolge und gibt als Ergebnis die Position des ersten Zeichens der gefundenen Zeichenfolge zurück.

  • Mathematisch. Diese Funktoide führen Berechnungen mithilfe spezieller Werte aus, die als Argumente bezeichnet werden und in einer bestimmten Reihenfolge oder Kombination in die Berechnungen eingehen. Das Funktoid Addition z. B. addiert die Werte der bezeichneten Felder oder Datensätze.

  • Logisch. Diese Funktoide führen bestimmte logische Tests aus. Wenn ein logisches Funktoid mit einem Datensatz der Zielspezifikation verknüpft ist und den Wert TRUE zurückgibt, wird der entsprechende Datensatz im Ausgabedokument generiert. Wenn ein logisches Funktoid mit einem Datensatz der Zielspezifikation verknüpft ist und den Wert FALSE zurückgibt, wird der entsprechende Datensatz im Ausgabedokument nicht generiert. Die Ausgabe eines logischen Funktoids kann auch als Eingabe für andere Funktoide innerhalb einer Zuordnung verwendet werden.

  • Datum/Uhrzeit. Diese Funktoide bearbeiten datums- und zeitbezogene Daten oder fügen einem Datensatz oder Feld der Zielspezifikation das aktuelle Datum und die aktuelle Zeit oder andere Datums- und Zeitdaten hinzu.

  • Konvertierung. Diese Funktoide ähneln weitgehend entsprechenden Hilfsfunktionen des Software Engineering wie z. B. DEC2HEX, die einen Hexadezimalwert für einen gegebenen Dezimalwert zurückgibt. Sie können auch dazu verwendet werden, ein Zeichen in dessen ASCII-Wert oder einen Wert in das entsprechende ASCII-Zeichen zu konvertieren.

  • Wissenschaftlich. Diese Funktoide konvertieren einen numerischen in einen Wert einer mathematischen Funktion. Beispielsweise verwendet das Funktoid Kosinus als Argument den Wert eines Feldes oder Datensatzes und gibt als Ergebnis den Kosinus dieses Wertes als Winkel in Bogenmaß (Radiant) zurück.

  • Kumulativ. Diese Funktoide geben die Summe, den Mittelwert oder das Minimum bzw. Maximum der Eingabewerte eines Schleifendatensatzes zurück.

  • Datenbank. Diese Funktoide extrahieren Daten aus einer Datenbank.

  • Erweitert. Diese Registerkarte bietet ein Funktoid, das ein benutzerdefiniertes Microsoft Visual Basic-Skript verwenden kann, sowie Funktoide zum Verwalten und Extrahieren von Informationen aus Schleifendatensätzen.

Sie können außerdem eigene, benutzerdefinierte Funktoide erstellen. Ein Beispiel für ein solches benutzerdefiniertes Funktoid finden Sie im Ordner Programme\Microsoft BizTalk Server\SDK\Messaging Samples\SampleFunctoid, sofern auf dem gegebenen Computer eine vollständige Installation von BizTalk Server oder eine benutzerdefinierte Installation durchgeführt wurde, bei der auch Messagingbeispiele installiert wurden.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Verwenden von kaskadierenden Funktoiden

  • Verwenden von kumulativen Funktoiden

  • Verwenden von Datenbankfunktoiden

  • Verwenden des Funktoids "Datensatzanzahl"

  • Verwenden des Funktoids "Index"

  • Verwenden des Funktoids "Iteration"

  • Verwenden des Funktoids "Wertezuordnung"

  • Verwenden des Funktoids "Wertezuordnung (Flattening)"

  • Verwenden des Funktoids "Schleife"


Verwenden von kaskadierenden Funktoiden

Mit kaskadierenden Funktoiden können Sie Zuordnungen erstellen, bei denen Felder oder Datensätze mit mehreren Funktoiden verknüpft werden müssen, um das gewünschte Ergebnis in ein Feld oder einen Datensatz der Zielspezifikation zu übertragen. Kaskadierende Funktoide vereinfachen das Erstellen mehrerer aufeinander folgender Transformationen im Zuordnungsraster. Kaskadieren von Funktoiden bedeutet, dass ein Funktoid mit einem anderen Funktoid verknüpft wird, bevor der Verknüpfungspfad zu einem Datensatz oder Feld der Zielspezifikation führt. So können Sie beispielsweise kaskadierende Funktoide dazu verwenden, aus zwei verketteten Zeichenfolgen eine dritte Zeichenfolge zu generieren, die anschließend in ein Feld der Zielspezifikation eingespeist wird. Die Anzahl der Funktoide, die Sie durch Kaskadieren im Zuordnungsraster kombinieren können, ist unbegrenzt. Allerdings können komplizierte Kaskadierungen die Leistungsfähigkeit des Zuordnungsschemas beeinträchtigen.


Verwenden von kumulativen Funktoiden

Kumulative Funktoide operieren im Kontext der Datensatzebene der Quellspezifikation. In der Regel erscheinen in einer Eingabedatei bestimmte Datensätze mehrmals. Beispielsweise kann ein Auftrag ( PurchaseOrder) mehr als einen Posten (Item) umfassen. Der Abschnitt für den einzelnen Posten (LineItem) kann Angaben zum Produkt (Product), eine Beschreibung (Description), sowie Angaben zum Preis (Price)und zur Menge (Quantity) enthalten. Der folgende Code ist ein Beispiel für ein Auftragsdokument:

<PurchaseOrder>
  <From>Kevin F. Browne</From>
  <To>Bits, Bytes, & Chips</To>
<LineItems>
  <Item>
    <Product>TravelLight 400</Product>
    <Description>laptop computer</Description>
    <Price>2000</Price>
    <Quantity>1</Quantity>
  </Item>
  <Item>
    <Product>TravelTuff Case</Product>
    <Description>laptop computer case</Description>
    <Price>50</Price>
    <Quantity>2</Quantity>
  </Item>
  <Item>
    <Product>ScreenClean</Product>
    <Description>computer monitor cleaner</Description>
    <Price>2</Price>
    <Quantity>100</Quantity>
  </Item>
</LineItems>
</PurchaseOrder>

Die folgende Abbildung zeigt diesen Auftrag, wie er im BizTalk-Editor angezeigt wird.

Klicken Sie zum Vergrößern oder Verkleinern auf die Abbildung.

Beachten Sie, dass die Maximalvorkommen-Eigenschaft auf der Registerkarte Verweis für den Posten-Datensatz (Item) auf den Wert * festgelegt ist. Dies zeigt an, dass der Posten-Datensatz (Item) ein Schleifendatensatz ist und der BizTalk-Mapper diesen Datensatz als eine Schleife kompiliert.

Möglicherweise möchten Sie die Gesamtsumme aller Einzelposten des Auftrags ermitteln und die kumulative Summe per Zuordnung in ein Feld eines Ausgabedokuments übertragen. Zu diesem Zweck müssen Sie zuerst für jeden Posten-Datensatz (Item) des Auftrags den erweiterten Preis berechnen und anschließend die Summen der einzelnen Posten-Datensätze (Item) zusammenzählen, während der Zuordnungsprozess fortschreitend alle Posten-Datensätze (Item) des Auftrags verarbeitet.

Die folgende Abbildung zeigt ein Funktoid Multiplikation und ein Funktoid Kumulative Summe, welche dazu verwendet werden, die Beträge der Item-Datensätze eines eingehenden Auftrags zusammenzuzählen und das Ergebnis in das Feld POTotal ("Auftragsumme") eines TotalsDocument-Dokuments auszugeben.

Klicken Sie zum Vergrößern oder Verkleinern auf die Abbildung.

In diesem Beispiel werden alle Item-Datensätze, die unterhalb des LineItems-Datensatzes ("Einzelposten") eines eingehenden Auftrags existieren, von der kumulativen Operation berücksichtigt. Die Inhalte der Felder für Preis- und Quantitätsangaben (Price und Quantity) werden an ein Funktoid Multiplikation gesendet. Die Ausgabe des Funktoids Multiplikation dient als Eingabe für das Funktoid Kumulative Summe. Die Ausgabe des Funktoids Kumulative Summe ist der akkumulierte Wert aller in dem Eingabe-Auftrag durchsuchten Item-Datensätze. Dieser Wert wird an das Feld POTotal des TotalsDocument-Dokuments übermittelt und ist die Summe aller einzelnen Produkte aus Preis und Menge: (2000x1)+(50x2)+(2x100)=2300.

Anmerkungen

  • Die kumulative Zusammenführung einer bestimmten Eingabe erfolgt auf der Ebene des übergeordneten Datensatzes, aus dem die Eingabeverknüpfung herausführt. Diese Feststellung gilt auch für die Ausgaben eines Funktoids, die als Eingabe für ein kumulatives Funktoid dienen.

  • Kumulative Funktoide ignorieren nichtnumerische Eingaben. So wird z. B. der Eingabewert drei nicht verarbeitet.

Die Funktoide Kumulativer Durchschnitt, Kumulativer Minimalwert und Kumulativer Maximalwert verhalten sich ähnlich wie das Funktoid Kumulative Summe. Das Funktoid Kumulative Zeichenfolge zeigt insofern ein anderes Verhalten als die übrigen kumulativen Funktoide, als es Zeichenfolgen verkettet und keine numerischen Werte zusammenzählt.

Verwandte Themen

Hinzufügen von kumulativen Funktoiden

Kumulative Funktoide


Verwenden von Datenbankfunktoiden

Datenbankfunktoide extrahieren Daten aus einer Datenbank. Um die Funktionsweise von Datenbankfunktoiden zu verstehen, stellen Sie sich ein großes Einzelhandelsunternehmen mit vielen Niederlassungen vor, die sich über einen großes geografisches Gebiet verteilen. Jede Filiale wird durch einen numerischen Code identifiziert und an alle Partner wird eine entsprechende Adressliste verteilt. Die Adressliste könnte beispielsweise die folgende Struktur aufweisen:

Filialenkennung ("StoreID"): 123

Name ("Name"): A. Datum Corporation

Adresse ("Address"): 1234 Main Street

Ort ("City"): Denver, Colorado

PLZ ("PostalCode"): 97402

Telefon ("PhoneNumber"): 801-555-0179

Geschäftsführer ("StoreManager"): Anthony Chor

In nachfolgenden Transaktionen wird in einem Auftrag nur der numerische Code versendet, der die jeweilige Filiale kennzeichnet. Der BizTalk-Mapper verwendet diesen Code, um die Adressinformationen aus einer Datenbank zu extrahieren. Die folgende Abbildung illustriert ein solches Szenario.

Klicken Sie zum Vergrößern oder Verkleinern auf die Abbildung.

Zuordnung: Datenbank (Funktoid)

In dieser Abbildung repräsentiert die Quellspezifikation einen eingehenden Auftrag und die Zielspezifikation eine dazu gehörige Rechnung. Das Funktoid Datenbanksuche Funktoid "Datenbanksuche" sucht in einer Datenbank nach dem passenden Datensatz der entsprechenden Tabelle. Die Ausgabe des Funktoids Datenbanksuche kann nur mit Funktoiden des Typs Wertextrahierer Funktoid "Wertextrahierer" verknüpft werden. Das Funktoid Wertextrahierer entnimmt dem Suchdatensatz den geeigneten Spaltennamen. Das Funktoid Fehlerrückgabe Funktoid "Fehlerrückgabe" gibt eine Zeichenfolge aus, die Fehlerinformationen enthält, sofern zur Laufzeit Fehler (beispielsweise Verbindungsfehler) aufgetreten sind.

Das Funktoid Datenbanksuche erfordert vier Eingabeparameter in folgender Reihenfolge:

  • Suchwert

  • Verbindungszeichenfolge der Datenbank

  • Tabellenname

  • Spaltenname für den Suchwert

Informationen zum Einfügen, Löschen und Verschieben von Eingabeparametern finden Sie unter Eingabeparameter.

In dem vorhergehenden Beispiel wird der erste Eingabeparameter dem Feld StoreID des eingehenden Auftrags entnommen, während die übrigen drei Eingabeparameter Konstanten darstellen, die im Dialogfeld Funktoideigenschaften auf der Registerkarte Allgemein für das Funktoid Datenbanksuche definiert sind. Es ist möglich, von der Quellspezifikationsstruktur ausgehende Verknüpfungen zu erstellen, die Werte für alle vier Eingabeparameter bereitstellen. Weitere Informationen zum Einfügen, Löschen und Verschieben von Eingabeparametern finden Sie unter Eingabeparameter.

Das Funktoid Wertextrahierer erfordert die beiden folgenden Eingabeparameter in der angegebenen Reihenfolge:

  • Eine Verknüpfung zum Funktoid Datenbanksuche

  • Den Spaltennamen

Das Funktoid Fehlerrückgabe erfordert exakt einen Eingabeparameter: eine Verknüpfung zum Funktoid Datenbanksuche

Anmerkungen

  • Einige SQL Server-Datentypen wie z. B. text, ntext und image können nicht als Suchwerte für das Funktoid Datenbanksuche verwendet werden.

  • Wenn mehr als ein Datensatz mit den Eingabeparametern des Funktoids Datenbanksuche übereinstimmt, extrahiert das Funktoid Wertextrahierer nur den ersten Datensatz in der Tabelle.

Verwandte Themen

Datenbankfunktoide

Eingabeparameter


Verwenden des Funktoids "Datensatzanzahl"

Das Funktoid Datensatzanzahl operiert im Kontext der Datensatzebene der Quellspezifikation. In der Regel tauchen in einer Eingabedatei bestimmte Datensätze mehrmals auf. Beispielsweise kann ein Auftrag ("purchase order") mehr als einen Posten ("item") umfassen. Der Abschnitt für den einzelnen Posten kann Angaben zum Produkt, eine Beschreibung, sowie Angaben zum Preis und zur Menge enthalten. Der folgende Code ist ein Beispiel für ein Auftragsdokument:

<PurchaseOrder>
  <From>Kevin F. Browne</From>
  <To>Bits, Bytes, & Chips</To>
<LineItems>
  <Item>
    <Product>TravelLight 400</Product>
    <Description>laptop computer</Description>
    <Price>2000</Price>
    <Quantity>1</Quantity>
  </Item>
  <Item>
    <Product>TravelTuff Case</Product>
    <Description>laptop computer case</Description>
    <Price>50</Price>
    <Quantity>2</Quantity>
  </Item>
  <Item>
    <Product>ScreenClean</Product>
    <Description>computer monitor cleaner</Description>
    <Price>2</Price>
    <Quantity>100</Quantity>
  </Item>
</LineItems>
</PurchaseOrder>

Die folgende Abbildung zeigt diesen Auftrag, wie er im BizTalk-Editor dargestellt wird.

Klicken Sie zum Vergrößern oder Verkleinern auf die Abbildung.

Beachten Sie, dass für die Maximalvorkommen-Eigenschaft auf der Registerkarte Verweis für dem Item-Datensatz auf den Wert * festgelegt ist. Dies zeigt an, dass der Item-Datensatz ein Schleifendatensatz ist und der BizTalk-Mapper diesen Datensatz als eine Schleife kompiliert.

Möglicherweise möchten Sie die Gesamtzahl aller Einzelposten des Auftrags ermitteln und diesen Wert mit einer Zuordnung in ein Feld eines Ausgabedokuments übertragen. Dieses Szenario unterscheidet sich von dem üblichen Zuordnungsszenario, bei dem der Inhalt des Quelldokuments auf das Ausgabedokument abgebildet wird. In diesem Fall generiert das Funktoid Anzahl der Datensätze den Wert, der dem Ausgabedokument zugeordnet wird.

Das Funktoid Datensatzanzahl besitzt einen Eingabe- und einen Ausgabewert. Als Eingabe dient eine Verknüpfung mit einem Schleifendatensatz der Quellspezifikation. Der Datensatz taucht im ursprünglichen Eingabedokument also mehrmals auf. Die Ausgabe des Funktoids Anzahl der Datensätze ist eine Verknüpfung mit einem Feld der Zielspezifikation.

Die folgende Abbildung zeigt ein Funktoid Anzahl der Datensätze, das die Anzahl der Auftragsposten zählt, die in einer eingehenden Auftragsspezifikation enthalten sind, und diesen Wert in das Feld Number_Of_Items des POReport-Ausgabedokuments überträgt.

Klicken Sie zum Vergrößern oder Verkleinern auf die Abbildung.

Zuordnung: Anzahl der Datensätze (Funktoid)

Da in diesem Beispiel der eingehende Auftrag drei Posten umfasst, beträgt im Feld Number_Of_Items der Wert 3.

Verwandtes Thema

Erweiterte Funktoide


Verwenden des Funktoids "Index"

Das Funktoid Index operiert im Kontext der Datensatzebene der Quellspezifikation. In der Regel tauchen in einer Eingabedatei bestimmte Datensätze mehrmals auf. Beispielsweise kann ein Wetterbericht ("Weather Report") für mehr als einen Tag eine Tagesvorhersage ("DailySummary") enthalten. Der Abschnitt für die Tagesvorhersage ("DailySummary") könnte Angaben über die Temperatur, den Luftdruck ("Pressure") und die Windgeschwindigkeit ("WindSpeed") enthalten. Der folgende Code ist ein Beispiel für einen Wetterbericht:

<WeatherReport>
  <DailySummary>
    <Temperature>20</Temperature>
    <Pressure>80</Pressure>
    <WindSpeed>10</WindSpeed>
  </DailySummary>
  <DailySummary>
    <Temperature>23</Temperature>
    <Pressure>78</Pressure>
    <WindSpeed>20</WindSpeed>
  </DailySummary>
  <DailySummary>
    <Temperature>24</Temperature>
    <Pressure>77</Pressure>
    <WindSpeed>16</WindSpeed>
  </DailySummary>
</WeatherReport>

Die folgende Abbildung zeigt diesen Wetterbericht, wie er im BizTalk-Editor angezeigt wird.

Klicken Sie zum Vergrößern oder Verkleinern auf die Abbildung.

Beachten Sie, dass für die Maximalvorkommen-Eigenschaft auf der Registerkarte Verweis für dem DailySummary-Datensatz der Wert * festgelegt ist. Dies zeigt an, dass der DailySummary-Datensatz ein Schleifendatensatz ist und der BizTalk-Mapper diesen Datensatz als eine Schleife kompiliert.

Möglicherweise möchten Sie die Wetterinformationen der ersten beiden DailySummary-Datensätze des Wetterberichts zusammenstellen. Jedes Feld des DailySummary-Datensatzes der eingehenden Quellspezifikation kann im BizTalk-Mapper mit einem Funktoid Index verknüpft werden, und jedes Funktoid Index kann festlegen, aus welchem DailySummary-Datensatz (dem ersten oder dem zweiten) die Informationen herausgezogen werden sollen. Die Funktoide des Typs Index können anschließend mit den geeigneten Feldern einer Zielspezifikation verknüpft werden. Beachten Sie, dass Funktoide des Typs Index nur zwischen Feldern funktionieren, die unterhalb eines einzigen übergeordneten Datensatzes existieren, sowohl innerhalb der Quellspezifikation. als auch innerhalb der Zielspezifikation.

Die folgende Abbildung illustriert Funktoide des Typs Index, die in dieser Weise verwendet werden.

Klicken Sie zum Vergrößern oder Verkleinern auf die Abbildung.

Zuordnung: Index (Funktoid)

Um eine zusammenfassende Vorhersage für den ersten Tag zu erhalten, müssen die drei oberen Funktoide des Typs Index den Indexwert 1 verwenden. Um eine zusammenfassende Vorhersage für den zweiten Tag zu erhalten, müssen die drei unteren Funktoide des Typs Index den Indexwert 2 verwenden.

Indexwerte als Eingabeparameter werden auf der Registerkarte Allgemein des Eigenschaftenblattes eines Funktoids Index festgelegt. Doppelklicken Sie auf ein Funktoid Index, um das zugehörige Eigenschaftenblatt anzuzeigen. Der erste Eingabeparameter identifiziert das Feld der Quellspezifikation, das mit dem Funktoid Index verknüpft wird. Der oder die nachfolgende(n) Eingabeparameter geben den oder die Indexwert(e) an.

Die folgende Abbildung zeigt das Eigenschaftenblatt des obersten Funktoids Index der zuvor abgebildeten Zuordnung an.

Klicken Sie zum Vergrößern oder Verkleinern auf die Abbildung.

Funktoideigenschaften: Index (Dialogfeld)

Anmerkungen

  • Ein Eingabeparameter eines Funktoids Index, dem der Wert einer nichtnumerischen Konstante zugewiesen wurde, wird vom BizTalk-Mapper als der Wert 1 interpretiert. Wenn z. B. in der vorhergehenden Abbildung der zweite Eingabeparameter durch einen Eingabeparameter mit dem Wert eineZeichenfolge ersetzt würde, wäre das Zuordnungsergebnis das gleiche.

  • Obwohl die Eingabe für die Indexreihenfolge in der Regel ein konstanter Wert ist, der auf der Registerkarte Allgemein im Dialogfeld Funktoideigenschaften festgelegt wird, ist es auch möglich, die Eingabe für die Indexreihenfolge mithilfe einer Verknüpfung zu einem Knoten der Quellspezifikation bereitzustellen. Wenn eine solche Verknüpfung aus einem Schleifendatensatz herausführt, der keinen übergeordneten Datensatz des ersten Eingabeparameters darstellt, bezieht sich die Eingabe für die Indexreihenfolge auf das erste Vorkommen des Knotens innerhalb des eingehenden Dokuments.

  • Der Wert der Indexeingabe ist immer relativ zum aktuellen Kontext innerhalb des Quelldokuments zu verstehen.

Enthält eine Eingabedatei mehrere Wetterberichte und umfasst jeder Wetterbericht mehrere tagesbezogene Vorhersagen, ist möglicherweise mehr als ein Indexwert anzugeben. Der folgende Code ist ein Beispiel für eine Eingabedatei mit mehr als einem Wetterbericht:

<WeatherReports>
  <WeatherReport1>
    <DailySummary>
      <Temperature>20</Temperature>
      <Pressure>80</Pressure>
      <WindSpeed>10</WindSpeed>
    </DailySummary>
    <DailySummary>
      <Temperature>23</Temperature>
      <Pressure>78</Pressure>
      <WindSpeed>20</WindSpeed>
    </DailySummary>
  </WeatherReport1>
  <WeatherReport2>
    <DailySummary>
      <Temperature>24</Temperature>
      <Pressure>77</Pressure>
      <WindSpeed>16</WindSpeed>
    </DailySummary>
    <DailySummary>
      <Temperature>22</Temperature>
      <Pressure>79</Pressure>
      <WindSpeed>21</WindSpeed>
    </DailySummary>
  </WeatherReport2>
</WeatherReports>

Ein Funktoid Index mit zwei Indexwerten, von denen der erste auf 1 und der zweite auf 2 festgelegt ist, bezieht seinen Feldwert aus der ersten Tagesvorhersage des zweiten Wetterberichts.

Wichtig

  • Ein Funktoid Index muss so viele Indexwerte besitzen, wie es übergeordnete Knoten zwischen der Feldebene und der ersten Ebene unterhalb des Stammknotens gibt. Beispielsweise sind für die Verarbeitung des Beispieldokuments mit mehreren Wetterberichten zwei Indexwerte erforderlich. Für das erste Beispieldokument, das nur einen Wetterbericht enthält, ist ein Indexwert erforderlich. Wird für ein Funktoid Index nicht die erforderliche Anzahl von Indexwerten bereitgestellt, wird eine Ausgabe auf der Basis des ersten Knotens im Quelldokument generiert, der dem ersten Eingabeparameter des Funktoids Index entspricht.

Verwandtes Thema

Erweiterte Funktoide


Verwenden des Funktoids "Iteration"

Das Funktoid Iteration identifiziert, welche Reihenfolgenummer eines Schleifendatensatzes gerade zu einem gegebenen Zeitpunkt zugeordnet wird. Die folgende Abbildung illustriert diese Art der Verwendung des Funktoids Iteration in Verbindung mit einem Funktoid Gleich.

Klicken Sie zum Vergrößern oder Verkleinern auf die Abbildung.

Zuordnung: Iteration (Funktoid)

Für jeden der beiden Datensätze der Zielspezifikation gibt es jeweils ein Paar von Funktoiden (das Funktoid Iteration Funktoid "Iteration" und das Funktoid Gleich Funktoid "Gleich"). Die folgende Abbildung zeigt das Eigenschaftenblatt des obersten Funktoids Gleich.

Klicken Sie zum Vergrößern oder Verkleinern auf die Abbildung.

Funktoideigenschaften: Gleich (Dialogfeld)

Der folgende Code zeigt ein Beispiel für eine eingehende Dokumentinstanz, die mit der Struktur der Quellspezifikation übereinstimmt:

<Root>
<Record1 Field1="A"/>
<Record1 Field1="B"/>
</Root>

Während die eingehende Dokumentinstanz gemäß der Quellspezifikation verarbeitet wird, gibt das Funktoid Iteration den Wert 1 zurück, wenn der erste Datensatz zugeordnet wird, und den Wert 2, wenn der zweite Datensatz zugeordnet wird. Das Funktoid Gleich gibt den Wert TRUE zurück, wenn seine beiden Eingabeparameter identisch sind. Deshalb liefert das obere Funktoidenpaar den Wert TRUE, wenn der erste Datensatz der eingehenden Dokumentinstanz zugeordnet wird. Der Wert TRUE wird an den Datensatz Record2 der Zielspezifikation übergeben und Record2 wird in das Ausgabedokument geschrieben. Wenn der zweite Eingabeparameter des unteren Funktoids Gleich einen Wert von 2 besitzt, verhält sich das untere Funktoidenpaar in ähnlicher Weise wie das obere Funktoidenpaar. Anders ausgedrückt: als Ergebnis der Zuordnung des zweiten Datensatzes der eingehenden Dokumentinstanz wird Record3 der Zielspezifikation in die Ausgabedokumentinstanz geschrieben. Der folgende Code zeigt die resultierende Ausgabedokumentinstanz:

<Root2>
<Record2 Field2="A"/>
<Record3 Field3="B"/>
</Root2>

Verwandtes Thema

Erweiterte Funktoide


Verwenden des Funktoids "Wertezuordnung"

Das Funktoid Wertezuordnung Funktoid "Wertezuordnung" erfordert zwei Eingabeparameter und gibt den Wert des zweiten Eingabeparameters zurück, falls der erste Parameter den Wert TRUE besitzt. Die folgende Abbildung zeigt eine Zuordnung unter Verwendung des Funktoids Wertezuordnung.

Klicken Sie zum Vergrößern oder Verkleinern auf die Abbildung.

Zuordnung: Wertezuordnung (Funktoid)

Um die Zuordnung zu vervollständigen, müssen Sie für jedes Funktoid die Eingabeparameter festlegen. Die folgende Abbildung zeigt das für jedes der Funktoide Wertezuordnung identische Eigenschaftenblatt.

Klicken Sie zum Vergrößern oder Verkleinern auf die Abbildung.

Funktoideigenschaften: Wertezuordnung (Dialogfeld)

Die folgende Abbildung zeigt das Eigenschaftenblatt für das oberste Funktoid Gleich.

Klicken Sie zum Vergrößern oder Verkleinern auf die Abbildung.

Funktoideigenschaften: Gleich (Dialogfeld)

Das Eigenschaftenblatt des mittleren Funktoids Gleich zeigt Ähnliches, hat aber als zweiten Eingabeparameter einen konstanten Wert Y. Auch das Eigenschaftenblatt des untersten Funktoids Gleich ähnelt dem ersten, weist aber als zweiten Eingabeparameter einen konstanten Wert Z aus.

Eine Quelldokumentinstanz kann beispielsweise das folgende Element enthalten:

<Field Name="X" Value="1"/>

Ein Name-Wert von X veranlasst das obere Funktoid Gleich der Zuordnung, den Wert TRUE zurückzugeben. Durch den vom Funktoid Gleich produzierte Wert TRUE gibt das mit ihm verknüpfte Funktoid Attributwert, den Wert 1 zurückzugeben.

Der folgende Code zeigt ein Beispiel für eine Dokumentinstanz, die der Quellspezifikation der Zuordnung entspricht.

<Root>
  <Record>
    <Field Name="X" Value="1"/>
    <Field Name="Y" Value="2"/>
    <Field Name="Z" Value="3"/>
  </Record>
  <Record>
    <Field Name="X" Value="4"/>
    <Field Name="Y" Value="5"/>
    <Field Name="Z" Value="6"/>
  </Record>
  <Record>
    <Field Name="X" Value="7"/>
    <Field Name="Y" Value="8"/>
    <Field Name="Z" Value="9"/>
  </Record>
</Root>

Unter Verwendung der anfangs gezeigten Zuordnung und dieser Quelldokumentinstanz generiert BizTalk Server die folgende Ausgabedokumentinstanz:

<Root>
<Record X="1"/>
<Record Y="2"/>
<Record Z="3"/>
<Record X="4"/>
<Record Y="5"/>
<Record Z="6"/>
<Record X="7"/>
<Record Y="8"/>
<Record Z="9"/>
</Root>

Wichtig

  • Das Funktoid Wertezuordnung akzeptiert boolesche Eingaben nur in Form der kleingeschriebenen Zeichenfolgen true und false. Wenn z. B. ein Feld einer eingehenden Dokumentinstanz einen Wert von TRUE besitzt und direkt mit dem obersten Eingabeparameter eines Funktoids Wertezuordnung verknüpft ist, wird der Wert des zweiten Eingabeparameters des Funktoids Wertezuordnung nicht an das Ausgabedokument weiterleitet.

Verwandte Themen

Erweiterte Funktoide

Verwenden des Funktoids "Wertezuordnung (Flattening)"


Verwenden des Funktoids "Wertezuordnung (Flattening)"

Ein übliches Szenario für Benutzer von Microsoft Commerce Server besteht darin, einen Commerce Server-Katalog auf ein Schema mit einer "vereinfachten" ("flat") Hierarchie abzubilden. Eine solche Zuordnung wird durch das Funktoid Wertezuordnung (Flattening) ermöglicht. Der folgende Code ist ein Beispiel für einen Commerce Server-Katalog:

<Root>
  <Record>
    <Field Name="X" Value="1"/>
    <Field Name="Y" Value="2"/>
    <Field Name="Z" Value="3"/>
  </Record>
  <Record>
    <Field Name="X" Value="4"/>
    <Field Name="Y" Value="5"/>
    <Field Name="Z" Value="6"/>
  </Record>
  <Record>
    <Field Name="X" Value="7"/>
    <Field Name="Y" Value="8"/>
    <Field Name="Z" Value="9"/>
  </Record>
</Root>

Der folgende Code ist ein Beispiel für ein vereinfachtes Schema:

<Root>
  <Record X="1" Y="2" Z="3"/>
  <Record X="4" Y="5" Z="6"/>
  <Record X="7" Y="8" Z="9"/>
</Root>

In diesem Zuordnungsszenario ist es wichtig, die 1:1-Entsprechung zwischen den drei Datensätzen im Katalog und den drei Datensätze des vereinfachten Schemas beizubehalten. Die folgende Abbildung illustriert eine Zuordnung, die diese Entsprechung beibehält.

Klicken Sie zum Vergrößern oder Verkleinern auf die Abbildung.

Zuordnung: Wertezuordnung (Flattening) (Funktoid)

In dieser Zuordnung stellt die Quellspezifikation die Struktur des eingehenden Katalogs, während die Zielspezifikation die Struktur des ausgehenden vereinfachten Schemas darstellt. Für jeden der drei Datensätze gibt es ein Funktoidenpaar (das Funkoid Gleich Funktoid "Gleich" und das Funktoid Wertezuordnung (Flattening) Funktoid "Wertezuordnung (Flattening)"). Die folgende Abbildung zeigt das für jedes der Funktoide Wertezuordnung (Flattening) identische Eigenschaftenblatt.

Klicken Sie zum Vergrößern oder Verkleinern auf die Abbildung.

Funktoideigenschaften: Wertezuordnung (Flattening) (Dialogfeld)

Die folgende Abbildung zeigt das Eigenschaftenblatt für das oberste Funktoid Gleich.

Klicken Sie zum Vergrößern oder Verkleinern auf die Abbildung.

Funktoideigenschaften: Gleich (Dialogfeld)

Das Eigenschaftenblatt des mittleren Funktoids Gleich zeigt Ähnliches, hat aber als zweiten Eingabeparameter einen den konstanten Wert Y. Auch das Eigenschaftenblatt des untersten Funktoids Gleich ähnelt dem ersten, weist aber als zweiten Eingabeparameter den konstanten Wert Z auf.

Das oberste Funktoidenpaar stellt in seiner Kombination sicher, dass der Wert von X von jedem der drei Datensätze des Katalogs zu jedem der drei Datensätze des vereinfachten Schemas übertragen wird. Das Funktoid Wertezuordnung (Flattening) gibt den Wert des zweiten Parameters seines Eigenschaftenblattes zurück, sofern der erste Parameter auf true festgelegt ist. Deshalb gibt das oberste Funktoid Wertezuordnung (Flattening) den Wert von /Root/Record/Field/@Value nur dann zurück, wenn ihm das Funktoid Gleich, mit dem es verknüpft ist, den Wert true zurückgibt. Das Funktoid Gleich, das mit ihm verknüpft ist, gibt einen Wert true nur für solche Felder des eingehenden Katalogs zurück, die das Namensattribut X haben.

Das Funktoid Gleich des mittleren Funktoidenpaars gibt einen Wert true nur für diejenigen Felder der eingehenden Spezifikation zurück, die das Namensattribut Y besitzen, so dass dieses Funktoidenpaar sicherstellt, dass für jeden der drei Katalogdatensätze der Wert von Y in jeden der drei Datensätze im vereinfachten Schema übernommen wird. Das dritte Funktoidenpaar verarbeitet in ähnlicher Weise den Wert von Z.

Wichtig

  • Das Funktoid Wertezuordnung (Flattening) akzeptiert boolesche Eingaben nur in Form der kleingeschriebenen Konstantenzeichenfolgen true und false. Wenn z. B. ein Feld einer eingehenden Dokumentinstanz einen Wert von TRUE besitzt und direkt mit dem obersten Eingabeparameter eines Funktoids Wertezuordnung (Flattening) verknüpft ist, wird der Wert des zweiten Eingabeparameters des Funktoids Wertezuordnung (Flattening) nicht an das Ausgabedokument weitergereicht.

Anmerkung

  • Wenn ein Datensatz einer eingehenden Dokumentinstanz für einen Katalog mehr als ein Feld mit einem Attribut besitzt, das mit dem zweiten Eingabeparameter eines der Funktoide des Typs Gleich übereinstimmt, wird nur der letzte Datensatz mit dieser Art Übereinstimmung dem Ausgabedokument zugeordnet. Beispielsweise würde in dem vorhergehenden Beispiel eines Commerce Server-Katalogs nur das letzte von drei Feldelementen des ersten Datensatzes zugeordnet werden, wenn alle diese Felder ein Namensattribut mit dem Wert X besitzen.

Informationen zum Zuordnen der Daten zwischen einem vereinfachten Schema und einem Commerce Server-Katalog (also genau in der umgekehrten Richtung der Zuordnung, wie sie in dem hier geschilderten Zuordnungsszenario definiert war) finden Sie unter Verwenden des Funktoids "Schleife"

Verwandte Themen

Erweiterte Funktoide

Verwenden des Funktoids "Schleife"

Verwenden des Funktoids "Wertezuordnung"


Verwenden des Funktoids "Schleife"

Das Funktoid Schleife Funktoid "Schleife" wird dazu verwendet, mehrere Datensätze und/oder Felder der Quellspezifikation in einem einzigen Datensatz der Zielspezifikation zusammenzufassen. Die folgende Abbildung illustriert diese Art der Verwendung des Funktoids Schleife.

Klicken Sie zum Vergrößern oder Verkleinern auf die Abbildung.

Zuordnung: Schleife (Funktoid)

Der BillTo-Datensatz der Quellspezifikation und der Addresses-Datensatz der Zielspezifikation sind beides Schleifendatensätze, wie der Einstellung * der Maximalvorkommen-Eigenschaft in den Abschnitten Quellattribute und Zielattribute auf der Registerkarte Eigenschaften zu entnehmen ist. In diesem Beispiel sind auch die Datensätze ShipTo und Header der Quellspezifikation Schleifendatensätze. Wenn eine eingehende Dokumentinstanz drei BillTo-Datensätze und zwei ShipTo-Datensätze enthält, würde das Funktoid Schleife aus diesen Elementen fünf Addresses-Datensätze im ausgehenden Dokument erstellen.

Der folgende Code zeigt ein Beispiel für eine eingehende Dokumentinstanz.

<Root>
<BillTo Name="Kim Yoshida" Address="345 North 63rd Street"
City="Boston" PostalCode="07458"></BillTo>
<BillTo Name="Michelle Votava" Address="7890 Broadway"
City="Columbus" PostalCode="46290"></BillTo>
<BillTo Name="Tanya Van Dam" Address="1234 Main Street"
City="Denver" PostalCode="97402"></BillTo>
<ShipTo Name="Patricia Esack" Address="456 First Avenue"
City="Miami" PostalCode="81406"></ShipTo>
<ShipTo Name="Peter Kress" Address="567 2nd Avenue"
City="Seattle" PostalCode="98103"></ShipTo>
<Header ID="01"></Header>
<Header ID="02"></Header>
<Header ID="03"></Header>
</Root>

Diese eingehende Dokumentinstanz würde die folgende ausgehende Dokumentinstanz produzieren, wenn sie durch die in der vorhergehenden Abbildung gezeigte Zuordnung verarbeitet wird:

<Root>
<Addresses Name="Kim Yoshida" Address="345 North 63rd Street"
City="Boston" PostalCode="07458" ID="01" />
<Addresses Name="Michelle Votava" Address="7890 Broadway"
City="Columbus" PostalCode="46290" ID="01" />
<Addresses Name="Tanya Van Dam" Address="1234 Main Street"
City="Denver" PostalCode="97402" ID="01" />
<Addresses Name="Patricia Esack" Address="456 First Avenue"
City="Miami" PostalCode="81406" ID="01" />
<Addresses Name="Peter Kress" Address="567 2nd Avenue"
City="Seattle" PostalCode="98103" ID="01" />
</Root>

Beachten Sie, dass in jedem Addresses-Datensatz, der in der ausgehenden Dokumentinstanz generiert wird, das Feld ID den Wert 01 hat. Der Grund hierfür liegt darin, dass der Header-Datensatz nicht mit dem Funktoid Schleife verknüpft ist. Der Wert des ersten ID-Feldes der eingehenden Dokumentinstanz wird an jeden in der ausgehenden Dokumentinstanz erstellten Datensatz weitergegeben.

Wichtig

  • Unter bestimmten Bedingungen verhalten sich einige Funktoide möglicherweise nicht wie erwartet, wenn sie innerhalb einer Zuordnung verwendet werden, die mit einem Funktoid Schleife arbeitet. Ein Funktoid liefert nicht die erwarteten Ergebnisse, wenn folgende Bedingungen erfüllt sind:
    • Das Funktoid besitzt mehr als eine Quellspezifikationsverknüpfung.

    • Zwei oder mehr der Quellspezifikationsverknüpfungen des Funktoids sind mit untergeordneten Feldern der Eingabedatensätze für das Funktoid Schleife verknüpft. Die untergeordneten Felder sind untereinander nicht gleichgeordnet.

    • Das Funktoid besitzt eine Zielspezifikationsverknüpfung, die auf ein untergeordnetes Feld eines Ausgabedatensatzes des Funktoids Schleife führt.

    Wenn Sie ein Funktoid, für das diese Bedingungen erfüllt sind, zur vorhergehenden Zuordnung hinzufügen müssten, würde dieses Funktoid eine Quellspezifikationsverknüpfung mit dem Name-Feld unterhalb des BillTo-Datensatzes, eine andere Quellspezifikationsverknüpfung mit dem Name-Feld unterhalb des ShipTo-Datensatzes und eine Zielspezifikationsverknüpfung mit dem Name-Feld unterhalb des Addresses-Datensatzes besitzen.

Zuordnen eines vereinfachten Schemas zu einem Commerce Server-Katalog

Sie können das Funktoid Schleife dazu verwenden, ein vereinfachtes Schema auf einen Microsoft Commerce Server-Katalog abzubilden. Weitere Informationen zu vereinfachten Schemas und Commerce Server-Katalogen finden Sie unter Verwenden des Funktoids "Wertezuordnung (Flattening)".

Die folgende Abbildung zeigt ein vereinfachtes Schema, das einem Commerce Server-Katalog zugeordnet ist.

Klicken Sie zum Vergrößern oder Verkleinern auf die Abbildung.

Zuordnung von Flatfile und Katalog

Wichtig

  • Damit diese Zuordnung ordnungsgemäß funktioniert, ist Folgendes zu tun:
    • Für jede Verknüpfung mit dem Name-Feld der Zielspezifikation muss in den Eigenschaften für die Quellspezifikationsverknüpfungen die Option Namen kopieren ausgewählt werden. Weitere Informationen dazu finden Sie unter Auswählen von Compilereigenschaften für Quellspezifikationsverknüpfungen.

    • Für jede Verknüpfung mit dem Value-Feld der Zielspezifikation muss in den Eigenschaften für die Quellspezifikationsverknüpfungen die Option Wert kopieren ausgewählt werden. Weitere Informationen dazu finden Sie unter Auswählen von Compilereigenschaften für Quellspezifikationsverknüpfungen.

    • Für die Verknüpfung, die das Funktoid Schleife mit dem Datensatz namens Field in der Zielspezifikation verbindet, muss in den Eigenschaften für die Zielspezifikationsverknüpfungen die Option Verknüpfungen von oben nach unten zuordnen ausgewählt werden. Weitere Informationen dazu finden Sie unter Auswählen von Compilereigenschaften für Zielspezifikationsverknüpfungen.

    • Stellen Sie sicher, dass im Dialogfeld Optionen für den BizTalk-Mapper die Option Mehrere Eingaben in Zielstrukturknoten zulassen aktiviert ist. Weitere Informationen dazu finden Sie unter Optionen für den BizTalk-Mapper: Registerkarte "Allgemein".

Verwandte Themen

Optionen für den BizTalk-Mapper: Registerkarte "Allgemein"

Auswählen von Compilereigenschaften für Zielspezifikationsverknüpfungen

Auswählen von Compilereigenschaften für Quellspezifikationsverknüpfungen

Verwenden des Funktoids "Wertezuordnung (Flattening)"


Kompilieren von Zuordnungen

Beim Kompilieren von Zuordnungen erstellt die Compilerkomponente des BizTalk-Mappers eine visuelle Darstellung der Transformationen der Zuordnung. Diese Komponente generiert auch das zur Laufzeit verwendete XSL (Extensible Stylesheet Language)-Stylesheet. Dieser Prozess erstellt eine Zuordnung. Das Kompilieren einer Zuordnung erzwingt die Anwendung der strukturbezogenen Regeln und Transformationen, die im Zuordnungsraster festgelegt sind. Transformationen, wie beispielsweise Verknüpfungen, werden in derselben Reihenfolge verarbeitet, in der die Datensätze und Felder innerhalb der Instanz der Quellstruktur angezeigt werden. Wenn der BizTalk-Mapper beispielsweise auf ein Quellelement (Datensatz oder Feld) trifft, dem eine Verknüpfung zugeordnet ist, kompiliert der BizTalk-Mapper die Eigenschaften dieser Verknüpfung. Die auszuführende Aktion kann ein einfaches Kopieren von Werten sein, mit dem ein Datensatz oder Feld in der Zielspezifikation aufgefüllt wird. Sie kann aber auch die Berechnung von Werten beinhalten, die auf der Basis der Eigenschaften eines Funktoids aus einem oder mehreren Datensätzen und Feldern der Quelle gewonnen und in eines oder mehrere Datensatz- und Feldelemente des Ziels übertragen werden. Die Ausführung einer jeden Verknüpfung erfolgt unabhängig von der Ausführung anderer Verknüpfungen.

Der BizTalk-Mapper generiert eine Warnmeldung auf der Registerkarte Warnungen, wenn der Compiler auf eine Situation stößt, die zu einer fehlerhaften Ausgabe führt. Wenn z. B. für ein Funktoid, das einen Eingabeparameter erfordert, kein Eingabeparameter bereitsteht, generiert der BizTalk-Mapper bei der Kompilierung der Zuordnung eine entsprechende Warnmeldung auf der Registerkarte Warnungen. Eine Zuordnung darf keine Warnungen generieren, wenn sie in einer Produktionsumgebung eingesetzt werden soll.

Der Kompilierungsprozess speichert alle Informationen zur Quell- und Zielspezifikation einschließlich aller Inhalte und Funktionen von Verknüpfungen und Objekten. Die kompilierte Zuordnung wird von BizTalk Server dazu verwendet, die eigentliche Übersetzung einer Eingabeinstanz in eine Ausgabeinstanz durchzuführen.

Verwandtes Thema

Zuordnen der Ebenen innerhalb der Knotenhierarchie


Testen von Zuordnungen

Sie können während der Erstellung einer Zuordnung mithilfe des BizTalk-Mappers überprüfen, ob die von Ihnen entworfene Zuordnung die richtige Ausgabe liefert. Die Funktion Zuordnung testen generiert automatisch aus der Spezifikation eine Testinstanz des Quelldokuments. Diese Funktion überprüft anhand der Spezifikation Informationen wie z. B. die Anzahl von Vorkommen eines Datensatzes, die Datentypen von Feldern usw. und generiert anschießend die Testinstanz. Sie können auf der Registerkarte Werte im Feld Quelltestwert für jeden Datensatz und jedes Feld eindeutige Werte angeben und anschließend die Ergebnisse auf der Grundlage dieser Daten testen.

Beim Testen einer Zuordnung kompiliert der BizTalk-Mapper diese automatisch. Es empfiehlt sich jedoch, zuerst die Zuordnung zu kompilieren und alle Ursachen für Warnungen und Fehler zu beseitigen, bevor Sie die Zuordnung testen. Bevor der Test beginnt, werden Sie aufgefordert, die Zuordnungsdatei zu speichern. Das Speichern der Datei vor dem Testen ist eine Vorsichtsmaßnahme, die den Zweck hat, die Zuordnungsdaten für den Fall zu sichern, dass beim Testen unbeabsichtigt Probleme in der Zuordnung auftreten.

Nach dem Testen der Zuordnung werden die Ergebnisse des Tests auf der Registerkarte Ausgabe angezeigt. Die Testdaten entsprechen der Zielspezifikation.

Anmerkung

  • Die BizTalk-Mapper-Funktion zum Testen von Zuordnungen beschränkt sich auf das Testen einer Zuordnung anhand einer automatisch generierten Dokumentinstanz. Die Dokumentinstanz für den Test wird vom BizTalk-Mapper generiert und basiert auf der Quellspezifikation . Es ist also nicht möglich, mit dem BizTalk-Mapper eine Zuordnung unter Verwendung einer echten Instanz eines Geschäftsdokuments Ihrer Wahl zu testen. Im Lieferumfang von BizTalk Server ist jedoch ein Beispielskript für das Testen von Zuordnungen enthalten, mit dem Sie eine Zuordnung anhand einer frei gewählten Dokumentinstanz testen können. Weitere Informationen dazu finden Sie in der Datei \Programme\Microsoft BizTalk Server\SDK\Messaging Samples\MapTest\Readme.txt.

Verwandte Themen

Testen von Funktoiden

Testen von Verknüpfungen

Testen von Eigenschaften für verknüpfte Datensätze und Felder testen


Ressourcen

Folgende Themen werden in diesem Abschnitt behandelt:

  • Anpassen der Anzeige

  • Zeichenfolgenfunktoide

  • Mathematische Funktoide

  • Logische Funktoide

  • Datums- und Zeitfunktoide

  • Konvertierungsfunktoide

  • Wissenschaftliche Funktoide

  • Kumulative Funktoide

  • Datenbankfunktoide

  • Erweiterte Funktoide

  • Zuordnungen für die Integration der BizTalk-Dienste


Anpassen der Anzeige

Zum Anpassen des Erscheinungsbildes des BizTalk-Mappers gibt es verschiedene Möglichkeiten. Beispielsweise können Sie die Hintergrundfarben des Zuordnungsrasters ändern, neue Farben für Verknüpfungen und markierte Objekte angeben, die Farbe von Compilerwarnungen und die Größe des dargestellten Textes ändern. Folgende Elemente können angepasst werden:

  • Rastervordergrund. Die gestrichelten Linien des Zuordnungsrasters.

  • Rasterhintergrund. Die Hintergrundfarbe des Zuordnungsrasters.

  • Feste Verknüpfungen. Wertkopieverknüpfungen im Zuordnungsraster.

  • Elastische Verknüpfungen. Wertkopieverknüpfungen, die von der Quellspezifikationsstruktur zur Zielspezifikationsstruktur gezogen werden.

  • Teilverknüpfungen. Verknüpfungen mit einem Feld oder einen Datensatz, dessen übergeordneter Datensatzknoten reduziert ist.

  • Compilerverknüpfungen. Durch Compilerdirektiven festgelegte Verknüpfungen, die automatische generiert werden, wenn eine Verknüpfung zwischen einem Feld der Quellspezifikationsstruktur und einem Feld der Zielspezifikationsstruktur definiert wird.

Diese Features sind im Dialogfeld Optionen für den BizTalk-Mapper verfügbar, das über das Menü Extras geöffnet werden kann. Änderungen der Textgröße können über das Menü Ansicht vorgenommen werden.

Verwandtes Thema

Optionen für den BizTalk-Mapper: Registerkarte "Farben"


Zeichenfolgenfunktoide

Funktoid Parameter
Funktoid "Zeichenfolge suchen" Zeichenfolge suchen

Gibt die Position in einer Zeichenfolge zurück, an der eine andere angegebene Zeichenfolge beginnt.

 Dieses Funktoid muss zwei Eingabeparameter aufweisen. Das erste Feld, das Sie mit dem Funktoid verknüpfen, ist die Zeichenfolge, welche die Position der zweiten Zeichenfolge bestimmt.
Functoid "Zeichenfolge von links" Zeichenfolge von links

Gibt eine angegebene Anzahl von Zeichen eines Textelements zurück, beginnend mit dem äußeren linken Zeichen.

 Dieses Funktoid muss zwei Eingabeparameter aufweisen. Das erste Feld, das Sie mit dem Funktoid verknüpfen, ist die Zeichenfolge, welche die Ausgabezeichenfolge bestimmt. Das zweite Feld, das Sie mit dem Funktoid verknüpfen, bestimmt die Anzahl der Zeichen, die als Ausgabewert zurückgegeben werden. Das Ergebnis der Ausgabe ist eine Zeichenfolge, die eine Untermenge des ersten Feldes ist, das Sie mit dem Funktoid verknüpft haben.
Funktoid "Kleinbuchstaben" Kleinbuchstaben

Konvertiert ein Textelement in Kleinbuchstaben.

 Dieses Funktoid muss einen Eingabeparameter aufweisen.
Functoid "Zeichenfolge von rechts" Zeichenfolge von rechts

Extrahiert eine angegebene Anzahl von Zeichen eines Textelements, beginnend mit dem äußeren rechten Zeichen.

 Dieses Funktoid muss zwei Eingabeparameter aufweisen. Das erste Feld, das Sie mit dem Funktoid verknüpfen, ist die Zeichenfolge, welche die Ausgabezeichenfolge bestimmt. Das zweite Feld, das Sie mit dem Funktoid verknüpfen, bestimmt die Anzahl der Zeichen, die als Ausgabewert zurückgegeben werden. Das Ergebnis der Ausgabe ist eine Zeichenfolge, die eine Untermenge des ersten Feldes ist, das Sie mit dem Funktoid verknüpft haben.
Funktoid "Zeichenfolgenlänge" Zeichenfolgenlänge

Gibt als ganzeZahl die Größe eines Objekts ohne Auffüllzeichen zurück.

 Dieses Funktoid muss einen Eingabeparameter aufweisen. Der Ausgabewert gibt in Zeichen die Größe der im Eingabefeld enthaltenen Daten an.
Funktoid "Zeichenfolge extrahieren" Zeichenfolge extrahieren

Extrahiert eine Zeichenfolge, die durch die Anfangs- und Endposition einer Quellzeichenfolge angegeben wird.

 Dieses Funktoid muss drei Eingabeparameter aufweisen, von denen einer eine Zeichenfolge sein muss.

Die Reihenfolge, in der Sie die Felder mit dem Funktoid verknüpfen, muss die Folgende sein:

  1. Feld Zeichenfolge

  2. Feld Anfangsposition

  3. Feld Endposition
Funktoid "Verketten" Verketten

Verkettet eine Reihe von Eingabezeichenfolgen.

 Dieses Funktoid darf mehrere Eingabeparameter aufweisen.
Funktoid "Zeichenfolge links kürzen" Zeichenfolge links kürzen

Entfernt führende Leerzeichen aus einem Textelement.

 Dieses Funktoid muss einen Eingabeparameter aufweisen.
Funktoid "Zeichenfolge rechts kürzen" Zeichenfolge rechts kürzen

Entfernt nachfolgende Leerzeichen aus einem Textelement.

 Dieses Funktoid muss einen Eingabeparameter aufweisen.
Funktoid "Großbuchstaben" Großbuchstaben

Konvertiert ein Textelement in Großbuchstaben.

 Dieses Funktoid muss einen Eingabeparameter aufweisen.


Mathematische Funktoide

Funktoid | Parameter
Funktoid "Absoluter Wert" Absoluter Wert Gibt den absoluten Wert einer Zahl zurück. | Dieses Funktoid muss einen Eingabeparameter aufweisen. Der Endwert ist ungeachtet des tatsächlichen Eingabewerts stets positiv.
Funktoid "Ganze Zahl" Ganze Zahl Gibt den ganzzahligen Teil einer Zahl zurück. | Dieses Funktoid muss einen Eingabeparameter aufweisen. Dieses Funktoid entfernt das Dezimalkomma sowie alle Stellen rechts des Dezimalkommas aus einer Zahl.
Funktoid "Maximalwert Maximalwert Gibt den maximalen Wert in einer Reihe numerischer Werte zurück. | Dieses Funktoid muss einen oder mehrere Eingabeparameter aufweisen.
Funktoid "Minimalwert Minimalwert Gibt den minimalen Wert in einer Reihe numerischer Werte zurück. | Dieses Funktoid muss einen oder mehrere Eingabeparameter aufweisen.
Funktoid "Modulo" Modulo Gibt den Restwert zurück, nachdem eine Zahl durch eine ganze Zahl geteilt wurde. | Dieses Funktoid muss zwei Eingabeparameter aufweisen. Dieses Funktoid gibt den Rest der Division einer ganze Zahl zurück. Dieses Funktoid ist nützlich für Stückgutberechnungen, wie z. B. Versandmengen.
Funktoid "Runden" Runden Rundet eine Zahl auf eine angegebene Anzahl von Dezimalstellen oder auf eine ganze Zahl, wenn keine Dezimalstellen angegeben werden. | Dieses Funktoid muss zwei Eingabeparameter aufweisen. Die erste mit diesem Funktoid verknüpfte Eingabe stellt den Wert dar. Die zweite mit diesem Funktoid verknüpfte Eingabe stellt die Anzahl der Dezimalstellen dar, auf die der Wert gerundet werden soll. Das Funktoid nimmt Auf- und Abrundungen auf der Basis der standardmäßigen Berechnungsregeln vor.
Funktoid "Quadratwurzel" Quadratwurzel Gibt die Quadratwurzel einer Zahl zurück. | Dieses Funktoid muss einen Eingabeparameter aufweisen.
Funktoid "Addition" Addition Berechnet die Summe einer Reihe von Zahlen. | Dieses Funktoid muss einen oder mehrere Eingabeparameter aufweisen.
Funktoid "Subtraktion" Subtraktion Subtrahiert eine Zahl von einer anderen Zahl. | Dieses Funktoid muss einen oder mehrere Eingabeparameter aufweisen.
Funktoid "Multiplikation" Multiplikation Multipliziert eine Zahl mit einer anderen Zahl. | Dieses Funktoid muss einen oder mehrere Eingabeparameter aufweisen.
Funktoid "Division" Division Dividiert eine Zahl durch eine andere Zahl. | Dieses Funktoid muss zwei Eingabeparameter aufweisen. Sie können dieses Funktoid mit reellen und ganzen Zahlen verwenden.


Logische Funktoide

Funktoid | Parameter
Funktoid "Größer als" Größer als Gibt TRUE zurück, wenn der erste Parameter größer als der zweite Parameter ist. | Dieses Funktoid muss zwei Eingabeparameter aufweisen.
Funktoid "Größer als oder gleich" Größer als oder gleich Gibt TRUE zurück, wenn der erste Parameter größer als oder gleich dem zweiten Parameter ist. | Dieses Funktoid muss zwei Eingabeparameter aufweisen.
Funktoid "Kleiner als" Kleiner als Gibt TRUE zurück, wenn der erste Parameter kleiner als der zweite Parameter ist. | Dieses Funktoid muss zwei Eingabeparameter aufweisen.
Funktoid "Kleiner als oder gleich" Kleiner als oder gleich Gibt TRUE zurück, wenn der erste Parameter kleiner als oder gleich dem zweiten Parameter ist. | Dieses Funktoid muss zwei Eingabeparameter aufweisen.
Funktoid "Gleich" Gleich Gibt TRUE zurück, wenn der erste Parameter gleich dem zweiten Parameter ist. | Dieses Funktoid muss zwei Eingabeparameter aufweisen.
Funktoid "Ungleich" Ungleich Gibt TRUE zurück, wenn der erste Parameter ungleich dem zweiten Parameter ist. | Dieses Funktoid muss zwei Eingabeparameter aufweisen.
Funktoid "Logische Zeichenfolge" Logische Zeichenfolge Gibt TRUE zurück, wenn es sich bei dem Parameter um einen Zeichenfolgenwert handelt. | Dieses Funktoid muss einen Eingabeparameter aufweisen.
Funktoid "Logisches Datum" Logisches Datum Gibt TRUE zurück, wenn es sich bei dem Parameter um einen Datumswert handelt. | Dieses Funktoid muss einen Eingabeparameter aufweisen.
Funktoid "Logischer numerischer Wert" Logischer numerischer Wert Gibt TRUE zurück, wenn es sich bei dem Parameter um einen numerischen Wert handelt. | Dieses Funktoid muss einen Eingabeparameter aufweisen.
Funktoid "Logisches OR" Logisches OR Gibt das logische OR von Parametern zurück. | Dieses Funktoid muss einen oder mehrere Eingabeparameter aufweisen.
Funktoid "Logisches AND" Logisches AND Gibt das logische AND von Parametern zurück. | Dieses Funktoid muss einen oder mehrere Eingabeparameter aufweisen.


Datums- und Zeitfunktoide

Funktoid | Parameter
Funktoid "Tage hinzufügen" Tage hinzufügen Fügt einem Datum eine angegebene Anzahl von Tagen hinzu. | Dieses Funktoid muss zwei Eingabeparameter aufweisen. Die erste Verknüpfung muss als Eingabe Datumsinformationen aufweisen. Die zweite Verknüpfung bestimmt die Anzahl der Tage, die dem Datum hinzugefügt werden soll.
Funktoid "Datum" Datum Gibt das aktuelle Datum zurück. | Für dieses Funktoid sind keine Eingabeparameter erforderlich. Das Ausgabeformat ist JJJJ-MM-TT.
Funktoid "Uhrzeit" Uhrzeit Gibt die aktuelle Uhrzeit zurück. | Für dieses Funktoid sind keine Eingabeparameter erforderlich. Das Ausgabeformat ist HH:MM:SS.
Funktoid "Datum und Uhrzeit" Datum und Uhrzeit Gibt das Datum und die Uhrzeit zurück. | Für dieses Funktoid sind keine Eingabeparameter erforderlich. Das Ausgabeformat ist JJJJ-MM-TTTHH:MM:SS.


Konvertierungsfunktoide

Funktoid | Parameter
Funktoid "ASCII aus Zeichen" ASCII aus Zeichen Gibt einen ASCII-Wert zurück, wenn ein Zeichen angegeben wurde. | Dieses Funktoid muss einen Eingabeparameter aufweisen. Dieses Funktoid konvertiert einen zugrunde liegenden ASC-Wertcode. Beispiel: A=97
Funktoid "Zeichen aus ASCII" Zeichen aus ASCII Gibt ein Zeichen zurück, wenn ein ASCII-Wert angegeben wurde. | Dieses Funktoid muss einen Eingabeparameter aufweisen. Dieses Funktoid konvertiert einen Wert in dessen zugrunde liegenden ASC-Wertcode. Beispiel: 98=B
Funktoid "Hexadezimal" Hexadezimal Gibt einen Hexadezimalwert zurück, wenn eine Dezimalzahl angegeben wurde. | Dieses Funktoid muss einen Eingabeparameter aufweisen. Dieses Funktoid konvertiert einen Dezimal- in einen Hexadezimalwert. Beispiel: 10=A.
Funktoid "Oktal" Oktal Gibt einen Oktalwert zurück, wenn eine Dezimalzahl angegeben wurde. | Dieses Funktoid muss einen Eingabeparameter aufweisen. Dieses Funktoid konvertiert einen Dezimal- in einen Oktalwert. Beispiel: (Oktal 0-7), 8=10 und 10=12


Wissenschaftliche Funktoide

Funktoid | Parameter
Funktoid "Arcustangens" Arcustangens Gibt den Arcustangens einer Zahl zurück. | Dieses Funktoid muss einen Eingabeparameter aufweisen. Der Eingabewert muss in Radiant angegeben werden.
Funktoid "Kosinus" Kosinus Gibt den Kosinus einer Zahl zurück. | Dieses Funktoid muss einen Eingabeparameter aufweisen. Der Eingabewert muss in Radiant angegeben werden.
Funktoid "Sinus" Sinus Gibt den Sinus einer Zahl zurück. | Dieses Funktoid muss einen Eingabeparameter aufweisen. Der Eingabewert muss in Radiant angegeben werden.
Funktoid "Tangens" Tangens Gibt den Tangens einer Zahl zurück. | Dieses Funktoid muss einen Eingabeparameter aufweisen. Der Eingabewert muss in Radiant angegeben werden.
Funktoid "Natürliche Exponentialfunktion" Natürliche Exponentialfunktion Erhebt e in die angegebene Potenz. | Dieses Funktoid muss einen Eingabeparameter aufweisen.
Funktoid "Natürlicher Logarithmus" Natürlicher Logarithmus Gibt den Logarithmus (Basis e) eines Wertes zurück. | Dieses Funktoid muss einen Eingabeparameter aufweisen.
10^X Erhebt 10 in die angegebene Potenz | Dieses Funktoid muss einen Eingabeparameter aufweisen.
Funktoid "Allgemeiner Logarithmus" Allgemeiner Logarithmus Gibt den Logarithmus (Basis 10) eines Wertes zurück. | Dieses Funktoid muss einen Eingabeparameter aufweisen.
X^Y Erhebt einen Wert in die angegebene Potenz. | Dieses Funktoid muss zwei Eingabeparameter aufweisen.
Funktoid "Logarithus mit angegebener Basis" Logarithmus mit angegebener Basis Gibt den Logarithmus der angegebenen Basis eines Wertes zurück. | Dieses Funktoid muss zwei Eingabeparameter aufweisen.


Kumulative Funktoide

Funktoid | Parameter
Funktoid "Kumulative Summe" Kumulative Summe Addiert alle Werte für das verbundene Feld durch Iteration über den übergeordneten Datensatz. | Dieses Funktoid muss einen Eingabeparameter aufweisen.
Funktoid "Kumulativer Durchschnitt" Kumulativer Durchschnitt Berechnet den Durchschnitt aller Werte für das verbundene Feld durch Iteration über den übergeordneten Datensatz. | Dieses Funktoid muss einen Eingabeparameter aufweisen.
Funktoid "Kumulativer Minimalwert" Kumulativer Minimalwert Gibt die minimale Eingabe zurück, die den übergeordneten Datensatz umfasst. | Dieses Funktoid muss einen Eingabeparameter aufweisen.
Funktoid "Kumulativer Maximalwert" Kumulativer Maximalwert Gibt die maximale Eingabe zurück, die den übergeordneten Datensatz umfasst. | Dieses Funktoid muss einen Eingabeparameter aufweisen.
Funktoid "Kumulative Zeichenfolge" Kumulative Zeichenfolge Gibt die verkettete Zeichenfolge von Zeichenfolgenwerten für das verbundene Feld durch Iteration über den übergeordneten Datensatz zurück. | Dieses Funktoid muss einen Eingabeparameter aufweisen.


Datenbankfunktoide

Funktoid | Parameter
Funktoid "Datenbanksuche" Datenbanksuche Sucht einen bestimmten Wert in einer Datenbank, ruft den Datensatz ab, der den Wert enthält, und speichert ihn als ADO-Recordset. | Dieses Funktoid muss exakt vier Eingabeparameter aufweisen.
Funktoid "Wertextrahierer" Wertextrahierer Gibt einen Wert aus einer bestimmten Spalte in einem ADO-Recordset zurück, das zuvor durch das Funktoid Datenbanksuche abgerufen wurde. | Dieses Funktoid muss exakt zwei Eingabeparameter aufweisen.
Funktoid "Fehlerrückgabe" Fehlerrückgabe Gibt, falls vorhanden, die Fehlerzeichenfolge zurück, die beim Verwenden des Funktoids Datenbanksuche durch ODBC zurückgegeben wird. | Dieses Funktoid muss exakt einen Eingabeparameter aufweisen.


Erweiterte Funktoide

Funktoid | Parameter
Funktoid "Skripterstellung" Skripterstellung Benutzerdefiniertes Visual Basic-Skript. | Die Anzahl der Eingabeparameter für dieses Funktoid kann, basierend auf einem benutzerdefinierten Skript, konfiguriert werden.
Funktoid "Anzahl der Datensätze" Anzahl der Datensätze Gibt die Gesamtzahl der Datensätze zurück, die in der Instanz gefunden wurden. | Dieses Funktoid muss einen Eingabeparameter aufweisen.
Funktoid "Index" Index Gibt den Wert eines Datensatzes oder Feldes bei einem angegebenen Index zurück. | Dieses Funktoid muss mindestens zwei Eingabeparameter aufweisen. Die maximale Anzahl der Eingabeparameter wird durch die Anzahl der Ebenen in der Spezifikationshierarchie beschränkt.
Funktoid "Iteration" Iteration Gibt die Iterationsnummer (in einer Schleife) des Quelldatensatzes zurück. | Dieses Funktoid muss einen Eingabeparameter aufweisen.
Funktoid "Wertezuordnung" Wertezuordnung Gibt den Wert des zweiten Parameters zurück, wenn der Wert des ersten Parameters TRUE ist. | Dieses Funktoid muss zwei Eingabeparameter aufweisen.
Funktoid "Wertezuordnung (Flattening)" Wertezuordnung (Flattening) Gibt den Wert des zweiten Parameters zurück, wenn der Wert des ersten Parameters TRUE ist, und vereinfacht die Hierarchie des Quelldokuments. | Dieses Funktoid muss zwei Eingabeparameter aufweisen.
Funktoid "Schleife" Schleife Erstellt mehrere Ausgabedatensätze durch Iteration über jeden Datensatz. | Dieses Funktoid muss mindestens einen Eingabeparameter aufweisen. Die maximale Anzahl der Eingabeparameter ist unbegrenzt.


Zuordnungen für die Integration der BizTalk-Dienste

Wenn Sie die BizTalk-Orchestrierungsdienste und die BizTalk-Messaging-Dienste mithilfe eines anderen Transports als HTTP integrieren, müssen Sie gegebenenfalls eine Zuordnung erstellen, um einen Pfadnamen in einen Formatnamen zu konvertieren. Weitere Informationen finden Sie unter Integrieren der BizTalk-Dienste.

Konvertieren eines Pfadnamens in einen Formatnamen

Der folgende Code ist ein Beispiel eines Pfadnamens einer Nachrichtenwarteschlange:

private$\sourcechannel2{9e0016bf-be1f-48fe-82de-b27077ab5e73}

Sie müssen die folgende Zeichenfolge vor den Pfadnamen setzen, um diesen Pfadnamen in einen Formatnamen zu konvertieren:

queue://Direct=OS:

Dazu können Sie das Funktoid Verketten verwenden.

Die folgende Abbildung veranschaulicht eine Zuordnung, bei der das Funktoid Verketten zum Verknüpfen von zwei oder mehreren Zeichenfolgen verwendet wird. Weitere Informationen zum Funktoid Verketten finden Sie unter Zeichenfolgenfunktoide.

Klicken Sie zum Vergrößern oder Verkleinern auf die Abbildung.

Pfadname zu Formatname

Wenn Sie auf das Funktoid Verketten doppelklicken, werden dessen Eigenschaften angezeigt. Die folgende Abbildung veranschaulicht die Eigenschaften des Funktoids Verketten bei einer Zuordnung, die das Präfix queue://Direct=OS: dem Pfadnamen private$\sourcechannel2{9e0016bf-be1f-48fe-82de-b27077ab5e73} anfügt.

Weitere Informationen finden Sie unter Bearbeiten von Funktoideigenschaften.

Klicken Sie zum Vergrößern oder Verkleinern auf die Abbildung.

Funktoideigenschaften: Verketten (Dialogfeld)


Problembehandlung - BizTalk-Editor und BizTalk-Mapper

Dieser Abschnitt enthält Informationen zu folgenden Themen:

  • Beim Herstellen einer Verbindung zu einem Remote-WebDAV-Server ist ein Kennwort erforderlich

  • Fehler beim Herstellen einer Verbindung zu WebDAV bzw. beim Speichern von Dateien in WebDAV

  • Im WebDAV-Dialogfeld wird "???.xml" angezeigt

  • Im Dialogfeld "Aus WebDAV abrufen" wird der Ordner "BizTalkServerRepositoryMaps" angezeigt

  • Das Dialogfeld "Aus WebDAV abrufen" bzw. "In WebDAV speichern" ist leer

  • Fehler beim Herstellen einer Verbindung zu "http://localhost"

  • Eine an BizTalk Server gesendete Flatfile wurde nicht vollständig analysiert

  • Leerzeichen in einer an BizTalk Server gesendeten Flatfile werden nicht beibehalten

  • Fehler beim Testen der Zuordnung

  • Fehler beim DTD-Import

  • Beim Verwenden des Datums- oder Uhrzeitfeldes schlägt die Instanzüberprüfung fehl


Beim Herstellen einer Verbindung zu einem Remote-WebDAV-Server ist ein Kennwort erforderlich

Ursache: Möglicherweise hat der Benutzer keinen Zugriff auf den Ordner BizTalkServerRepository.

Lösung: Stellen Sie dem Benutzer Zugriff auf den Ordner BizTalkServerRepository bereit. Führen Sie hierzu folgende Schritte durch:

  1. Zeigen Sie im Startmenü auf Programme, dann auf Verwaltung, und klicken Sie anschließend auf Internetdienste-Manager.

  2. Erweitern Sie in der Konsolenstruktur den Namen des Computers.

  3. Erweitern Sie Standardwebsite.

  4. Klicken Sie mit der rechten Maustaste auf BizTalkServerRepository und anschließend auf Eigenschaften.

  5. Klicken Sie auf die Registerkarte Verzeichnissicherheit.

  6. Klicken Sie im Bereich Steuerung des anonymen Zugriffs und der Authentifizierung auf Bearbeiten.

  7. Aktivieren Sie das Kontrollkästchen Anonyme Anmeldung, und klicken Sie zweimal auf OK.


Fehler beim Herstellen einer Verbindung zu WebDAV bzw. beim Speichern von Dateien in WebDAV

Ursache 1: Wenn Sie versuchen, eine Zuordnung oder Spezifikation aus WebDAV abzurufen bzw. in WebDAV zu speichern, wird unter Umständen eine der folgenden Meldungen angezeigt:

Die Datei kann nicht im WebDAV-Repository gespeichert werden. Der Server ist zurzeit möglicherweise nicht verfügbar.

Im aktuellen Bereich wurde kein Schlüssel gefunden, der den beschriebenen Eigenschaften entspricht.

Diese Meldungen werden angezeigt, wenn die Einstellung Anonym für das Benutzerkonto auf dem Webserver nicht über Schreibrechte für das Microsoft Windows 2000-Verzeichnis verfügt, das als Host für das Repository dient.

Lösung: Gewähren Sie dem Benutzer Zugriff auf das Repository. Führen Sie hierzu folgende Schritte durch:

  1. Zeigen Sie im Startmenü auf Programme, dann auf Zubehör, und klicken Sie anschließend auf Windows-Explorer.

  2. Navigieren Sie zu dem Speicherort, an dem Sie Microsoft BizTalk Server 2000 installiert haben.

  3. Erweitern Sie das Verzeichnis Microsoft BizTalk Server, klicken Sie mit der rechten Maustaste auf BizTalkServerRepository, und klicken Sie dann auf Eigenschaften.

  4. Klicken Sie auf die Registerkarte Sicherheitseinstellungen.

  5. Klicken Sie auf Hinzufügen, und geben Sie dann den Domänennamen und den Benutzernamen der Person ein, die Berechtigungen für das Repository erhalten soll. Verwenden Sie dabei das folgende Format: Domänenname\Benutzername.

  6. Klicken Sie zweimal auf OK.

Ursache 2: Wenn Sie versuchen, eine Zuordnung oder Spezifikation aus WebDAV abzurufen bzw. in WebDAV zu speichern, wird unter Umständen die folgende Meldung angezeigt:

Auf http://localhost/BizTalkServerRepository/DocSpecs wurde kein BizTalk Server-Repository gefunden. Geben Sie einen anderen Servernamen ein, um die Verbindung zu WebDAV erneut herzustellen.

Diese Meldung wird angezeigt, wenn FrontPage-Servererweiterungen auf dem Webserver aktiviert sind.

Lösung: Deaktivieren Sie FrontPage-Servererweiterungen. Wird der WWW-Publishingdienst ausgeführt, beenden Sie diesen, und starten Sie ihn neu.

Anmerkung

  • Dieses Problem kann auch auftreten, wenn der WWW-Publishingdienst auf dem Hostcomputer für das WebDAV-Repository nicht ausgeführt wird.

So deaktivieren Sie FrontPage-Servererweiterungen

  1. Zeigen Sie im Startmenü auf Programme, dann auf Verwaltung, und klicken Sie anschließend auf Internetdienste-Manager.

  2. Doppelklicken Sie im Detailbereich auf <Name des Computers>, klicken Sie mit der rechten Maustaste auf Standardwebsite, und klicken Sie dann auf Eigenschaften.

    Das Dialogfeld Eigenschaften von Standardwebsite wird angezeigt.

  3. Deaktivieren Sie auf der Registerkarte Servererweiterungen das Kontrollkästchen Dokumenterstellung aktivieren, und klicken Sie auf OK.

So beenden Sie den WWW-Publishingdienst und starten ihn neu

  1. Zeigen Sie im Startmenü auf Programme, dann auf Verwaltung, und klicken Sie anschließend auf Komponentendienste.

  2. Klicken Sie in der Konsolenstruktur auf Dienste (lokal).

  3. Klicken Sie im Detailbereich mit der rechten Maustaste auf WWW-Publishingdienst, und klicken Sie auf Beenden.

  4. Klicken Sie mit der rechten Maustaste auf WWW-Publishingdienst, und klicken Sie auf Starten.


Im WebDAV-Dialogfeld wird "???.xml" angezeigt

Ursache: Der für Ihren Computer angezeigte Zeichensatz hängt von dem in BizTalk Server angegebenen Gebietsschema ab.

Lösung: Geben Sie für Ihren Computer denselben Zeichensatz an wie für das Gebietsschema in BizTalk Server. Führen Sie hierzu folgende Schritte durch:

  1. Zeigen Sie im Startmenü auf Einstellungen, und klicken Sie dann auf Systemsteuerung.

  2. Doppelklicken Sie auf Ländereinstellungen.

  3. Aktivieren Sie im Bereich Spracheinstellungen für das System auf der Registerkarte Allgemein das Kontrollkästchen für die gewünschte Sprache, und klicken Sie auf Standard festlegen.

    Das Dialogfeld Systemgebietsschema wählen wird angezeigt.

  4. Klicken Sie auf das gewünschte Gebietsschema und dann zweimal auf OK.

    Das Dialogfeld Ländereinstellungen ändern wird angezeigt.

  5. Klicken Sie auf Ja, um die Änderungen zu akzeptieren, und starten Sie den Computer neu.

Anmerkung

  • Nach dem Neustart des Computers wird die ausgewählte Sprache im Dialogfeld Ländereinstellungen folgendermaßen angezeigt: Sprache (Standard).

Verwandte Themen

Speichern von Zuordnungen

Speichern von Spezifikationen


Im Dialogfeld "Aus WebDAV abrufen" wird der Ordner "BizTalkServerRepositoryMaps" angezeigt

Ursache: Im Feld Lokaler Pfad des Dialogfeldes Eigenschaften von BizTalkServerRepository wird am Ende ein umgekehrter Schrägstrich angezeigt.

Lösung: Entfernen Sie den umgekehrten Schrägstrich im Bearbeitungsfeld Lokaler Pfad des Dialogfeldes Eigenschaften von BizTalkServerRepository. Führen Sie hierzu folgende Schritte durch:

  1. Zeigen Sie im Startmenü auf Programme, zeigen Sie auf Verwaltung, und klicken Sie anschließend auf Computerverwaltung.

  2. Erweitern Sie in der Computerverwaltungskonsole Dienste und Anwendungen, dann Internet-Informationsdienste und schließlich Standardwebsite.

  3. Klicken Sie mit der rechten Maustaste auf BizTalkServerRepository und dann auf Eigenschaften.

  4. Entfernen Sie den umgekehrten Schrägstrich im Bearbeitungsfeld Lokaler Pfad des Dialogfeldes Eigenschaften von BizTalkServerRepository, und klicken Sie auf OK.

Mit diesem Verfahren wird der Ordner BizTalkServerRepositoryMaps aus dem Dialogfeld Aus WebDAV abrufen entfernt. Es wird empfohlen, diesen Ordner zu entfernen, da er nicht verwendet werden kann.


Das Dialogfeld "Aus WebDAV abrufen" bzw. "In WebDAV speichern" ist leer

Ursache: Die Funktion zum Durchsuchen von Verzeichnissen im Dialogfeld Eigenschaften von BizTalkServerRepository ist deaktiviert.

Lösung: Aktivieren Sie die Funktion zum Durchsuchen von Verzeichnissen im Dialogfeld Eigenschaften von BizTalkServerRepository. Führen Sie hierzu folgende Schritte durch:

  1. Zeigen Sie im Startmenü auf Programme, dann auf Verwaltung, und klicken Sie anschließend auf Internetdienste-Manager.

  2. Erweitern Sie den Computer, für den Sie eine Problembehandlung durchführen.

  3. Erweitern Sie Standardwebsite.

  4. Klicken Sie mit der rechten Maustaste auf BizTalkServerRepository und anschließend auf Eigenschaften.

  5. Aktivieren Sie auf der Registerkarte Virtuelles Verzeichnis das Kontrollkästchen Verzeichnis durchsuchen.

  6. Stellen Sie sicher, dass Lesen und Schreiben ebenfalls aktiviert sind, und klicken Sie auf OK.


Fehler beim Herstellen einer Verbindung zu "http://localhost"

Ursache: Das Kontrollkästchen Proxyserver verwenden ist aktiviert, das Kontrollkästchen Proxyserver für lokale Adressen umgehen jedoch nicht.

Lösung: Behalten Sie die Einstellung Proxyserver verwenden bei, und schalten Sie Proxyserver für lokale Adressen umgehen ein. Führen Sie hierzu folgende Schritte durch:

  1. Zeigen Sie im Startmenü auf Programme, und klicken Sie dann auf Internet Explorer.

  2. Klicken Sie im Menü Extras auf Internetoptionen.

  3. Klicken Sie auf die Registerkarte Verbindungen und dann auf LAN-Einstellungen.

  4. Aktivieren Sie im Bereich Proxyserver des Dialogfeldes Einstellungen für lokales Netzwerk (LAN) das Kontrollkästchen Proxyserver für lokale Adressen umgehen.

  5. Klicken Sie zweimal auf OK.

Anmerkung

  • Dieser Fehler tritt nicht auf, wenn Sie eine Verbindung zu http://<Name des Computers> herstellen.


Eine an BizTalk Server gesendete Flatfile wurde nicht vollständig analysiert

Ursache: Fehler beim Analysieren können auftreten, wenn für eine an BizTalk Server gesendete Flatfile mit Trennzeichen Folgendes gilt:

  • Für die Feldreihenfolge-Eigenschaft wurde Präfix oder Postfix festgelegt.

  • Der Name des Stammknotens ist eine Zeichenfolge, die in dem Namen eines anderen Knotens in der Datei enthalten ist.

Lösung: Geben Sie dem Stammknoten einen neuen Namen, der nicht im Namen eines anderen Knotens in der Spezifikation enthalten ist.


Leerzeichen in einer an BizTalk Server gesendeten Flatfile werden nicht beibehalten

Ursache: Beim Senden einer Flatfile an BizTalk Server werden Leerzeichen unter Umständen entfernt. Der Grund hierfür ist, dass der zugrunde liegende MSXML-Parser Leerzeichen in einem Feld, für dessen Typ-Eigenschaft (auf der Registerkarte Deklaration) Element festgelegt wurde, standardmäßig nicht beibehält.

Lösung: Sollen die Leerzeichen in einem in einer Flatfile enthaltenem Feld beibehalten werden, legen Sie im BizTalk-Editor auf der Registerkarte Deklaration den Wert Attribut für die Typ-Eigenschaft des Feldes in der Quellspezifikation fest.

Verwandtes Thema

Festlegen von Deklarationseigenschaften


Fehler beim Testen der Zuordnung

Ursache: Wenn Sie eine Zuordnung testen, kompiliert der BizTalk-Mapper die Zuordnung, bevor diese getestet wird. Wird während des Kompiliervorgangs eine Warnung ausgegeben, kann die Zuordnung möglicherweise nicht getestet werden. Folgende Fehlermeldung wird angezeigt:

Fehler bei der XSL-Transformation mithilfe der Testinstanz des Dokuments für die Quellspezifikation.

Lösung: Lösen Sie sämtliche Compilerwarnungen auf, und kompilieren Sie die Zuordnung erneut. Um eine Compilerwarnung aufzulösen, führen Sie folgende Schritte durch:

  1. Doppelklicken Sie auf der Registerkarte Ausgabe auf das Wort Warnung. Auf diese Weise wird die Verknüpfung oder das Funktoid, mit der bzw. dem die Warnung verbunden ist, markiert.

  2. Lösen Sie die Warnung auf.

Um die Zuordnung neu zu kompilieren, gehen Sie folgendermaßen vor:

  • Klicken Sie im Menü Extras auf Zuordnung kompilieren.

Verwandtes Thema

Testen von Zuordnungen


Fehler beim DTD-Import

Ursache: Beim Import einer Dokumenttypdefinition (DTD), die einen externen Verweis auf eine andere Datei enthält, wird unter Umständen die folgende Meldung angezeigt:

DTD enthält ungültiges Zeichen.

Lösung: Entfernen Sie vor dem Import sämtliche externen Verweise in einer DTD.


Beim Verwenden des Datums- oder Uhrzeitfeldes schlägt die Instanzüberprüfung fehl

Ursache: Wenn BizTalk Server eine eingehende Dokumentinstanz verarbeitet, kann die Instanzüberprüfung fehlschlagen, wenn eine Verknüpfung zwischen einem Funktoid oder einem Quellfeld und einem Zielknoten besteht, für dessen Datentyp-Eigenschaft Date, Date Time, Date Time.tz, Time oder Time.tz festgelegt wurde, und wenn die beim Zielknoten eingehenden Daten nicht im ISO 8601-Format vorliegen.

Lösung: Wenn Sie eine Verknüpfung zu einem Feld in einer Zielspezifikation herstellen, für dessen Datentyp-Eigenschaft Date, Date Time, Date Time.tz, Time oder Time.tz festgelegt wurde, sollten Sie sicherstellen, dass die mit diesem Feld verknüpften Daten (unabhängig davon, ob Sie aus einem Funktoid oder einem Knoten in einer eingehenden Dokumentinstanz stammen) im ISO 8601-Format vorliegen. Die folgende Tabelle enthält das korrekte ISO 8601-Format für sämtliche Werte, die für die Datentyp-Eigenschaft festgelegt werden können.

Datentyp-Eigenschaft | ISO 8601-Format
Date | YYYY-MM-DD (1988-04-07)
Date Time | YYYY-MM-DDTHH:MM:SS (1988-04-07T18:39:09)
Date Time.tz | YYYY-MM-DDTHH:MM:SS-TZH:TZM (1988-04-07T18:39:09-08:00)
Time | HH:MM:SS (08:15:27)
Time.tz | HH:MM:SS-TZH:TZM (08:15:27-05:00)


Integrieren der BizTalk-Dienste

Durch das Integrieren der BizTalk-Orchestrierungsdienste und BizTalk-Messagingdienste können Sie den Austausch von Dokumenten und Nachrichten zwischen Ihren Handelspartnern und internen Anwendungen mit mehreren Transportdiensten steuern. Dies ermöglicht auch:

  • Steuerung komplexer, langlebiger Transaktionen und Geschäftsprozesse.

  • Zuverlässige Zustellung von Dokumenten und Nachrichten.

  • Datenvalidierung durch Überprüfen jeder Dokumenteninstanz anhand einer Spezifikation.

  • Datenzuordnung mithilfe von Zuordnungen zum Transformieren der Dokumentstruktur und des Formats.

  • Datensicherheit und Integrität mithilfe von Verschlüsselung und digitalen Signaturzertifikaten.

  • Unterstützung für die Generierung und Korrelation von Empfangsbestätigungen.

Die BizTalk-Orchestrierungsdienste und BizTalk-Messagingdienste können auf verschiedene Weise integriert werden, dieser Abschnitt zeigt jedoch das übliche Szenario.

Bei diesem Szenario konfigurieren Sie eine XLANG-Ablaufplaninstanz im Quellsystem, um eine Nachricht zu initiieren und an ein Zielsystem eines Handelspartners zu senden; dann warten Sie, bis Sie von dem Partner eine Antwortnachricht erhalten und senden die Antwortnachricht an dieselbe XLANG-Ablaufplaninstanz, die die Ausgangsnachricht gesendet hat. Ein Beispiel eines geläufigen Geschäftsprozesses, bei dem Sie diese Konfiguration anwenden können, ist der Versand einer Bestellung und das Abwarten der Bestätigung, bevor der Geschäftsprozess fortgeführt wird.

In den Themen in diesem Abschnitt werden die erforderlichen Konfigurationsschritte für den Austausch von Nachrichten zwischen Ihrem Unternehmen und einem Handelspartner mithilfe eines HTTP-Transports und eines Nicht-HTTP-Transports erläutert.Sie können jedoch eine ähnliche Konfiguration verwenden, um den Austausch von Nachrichten zwischen Anwendungen innerhalb Ihres Unternehmens zu steuern.

Da BizTalk Server 2000 als das Quellsystem dienen kann, das die Ausgangsnachricht sendet, oder als Zielsystem, das die Antwortnachricht sendet, stellt dieser Abschnitt die erforderlichen Konfigurationsschritte für beide Varianten bereit. Dadurch bekommen Sie einen Einblick in die gesamte erforderliche Konfiguration.

Beispiele für XLANG-Ablaufpläne, die diese Konfigurationen widerspiegeln, und andere verwandte Dateien finden Sie im Ordner \Programme\Microsoft BizTalk Server\SDK\XLANG Samples\Integrating BizTalk Services.

Anmerkungen

  • Die Begriffe Messagingport, der in den BizTalk-Messagingdiensten verwendet wird, und Port, der in den BizTalk-Orchestrierungsdiensten verwendet wird, haben eine vollkommen unterschiedliche Bedeutung.
    • Ein Messagingport ist eine Gruppe von Eigenschaften, die die BizTalk-Messagingdienste anweisen, Dokumente mithilfe eines festgelegten Transportdienstes an ein bestimmtes Ziel zu transportieren.

    • Ein Port ist eine benannte Adresse, die eine bestimmte Implementierung verwendet. In einem XLANG-Ablaufplan ermöglichen Ports die synchrone und asynchrone Kommunikation und werden verwendet, um Nachrichten in den und aus dem Ablaufplan zu senden. Aktionsereignisse, die sich auf Nachrichten beziehen und von einem XLANG-Ablaufplan verarbeitet werden, werden von den BizTalk-Messagingdiensten gesendet oder empfangen, die in der Überwachungsdatenbank überwacht werden können. Weitere Informationen finden Sie unter Überwachen von XLANG-Ablaufplanereignissen in der Überwachungsdatenbank.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Verwenden eines HTTP-Transports

  • Verwenden eines Nicht-HTTP-Transports

Verwandte Themen

BizTalk-Dienste

Instanzenverwaltung


Verwenden eines HTTP-Transports

Dieser Abschnitt erläutert, wie die BizTalk-Orchestrierungsdienste und BizTalk-Messagingdienste sowohl für das Quellsystem als auch für das Zielsystem integriert und konfiguriert werden, so dass Folgendes erreicht wird:

  • Das Quellsystem generiert eine Nachricht und sendet sie an das Zielsystem eines Handelspartners mit Hilfe einer bestimmten XLANG-Ablaufplaninstanz.

  • Das Zielsystem sendet eine Antwortnachricht mithilfe eines HTTP-Transports.

  • Das Quellsystem erhält eine Antwortnachricht und leitet diese an dieselbe XLANG-Ablaufplaninstanz weiter, die die Ausgangsnachricht generiert und versendet hat.

Informationen zum Konfigurieren beider Systeme, so dass das Zielsystem einen Nicht-HTTP-Transport zum Versenden der Antworten verwenden kann, finden Sie unter Verwenden eines Nicht-HTTP-Transports.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Konfigurieren des Quellsystems für das Verwenden eines HTTP-Transports

  • Konfigurieren des Zielsystems für das Verwenden eines HTTP-Transports


Konfigurieren des Quellsystems für das Verwenden eines HTTP-Transports

Die Schritte in diesem Thema erläutern, wie das Quellsystem konfiguriert werden muss, damit es eine Nachricht generiert und versendet, die eine HTTP-URL-Antwortadresse enthält. Das Zielsystem des Handelspartners verwendet die in der Ausgangsnachricht enthaltene Antwortadresse, um eine Antwortnachricht an eine ASP-Seite auf der Website des Quellsystems mithilfe eines HTTP-Transports zu senden. Informationen zum Konfigurieren des Quellsystems, so dass das Zielsystem einen Nicht-HTTP-Transport zum Versenden der Antworten verwenden kann, finden Sie unter Konfigurieren des Quellsystems für das Verwenden eines Nicht-HTTP-Transports. Die für einen sicheren HTTPS-Transport erforderlichen Konfigurationsschritte werden weiter unten in diesem Thema behandelt.

Der HTTP-URL, der in dieser Konfiguration als Antwortadresse verwendet wird, wird vom XLANG-Ablaufplan basierend auf den Daten aus den Porteigenschaften generiert. Er besteht aus den folgenden Elementen:

  • Die Adresse einer ASP-Seite auf der Website des Quellsystems, an die eine Antwortnachricht gesendet wird.

  • Eine Abfragezeichenkette, die den Namen des Kanals in den BizTalk-Messagingdiensten für das Quellsystem enthält, der zum Verarbeiten der Antwortnachricht verwendet wird, und ein vollständiger Pfadname einer instanzbezogenen Warteschlange, die die XLANG-Ablaufplaninstanz erstellt und an die die Antwortnachricht gesendet wird.

Nachfolgend ein Beispiel für eine HTTP-URL-Antwortadresse:

http://hostname/receiveresponse.asp?channel=ChannelForReply&qpath=hostname.domain.corp.vigorair-18.com\private$\sendingchannel2{9e0016bf-be1f-48fe-82de-b27077ab5e73}

Die Antwortnachricht, die ASP-Seite im Quellsystem erhält, enthält Skript, das die folgenden Schritte ausführt:

  • Kanalnamen und Informationen zum Warteschlangenpfad aus der Abfragezeichenkette extrahieren.

  • Den Warteschlangenpfad von einem Pfadnamen in einen Formatnamen konvertieren und ein Präfix queue:// einfügen, das von den BizTalk-Messagingdiensten benötigt wird.

  • Versenden einer Antwortnachricht an die BizTalk-Messagingdienste für das Quellsystem, wobei der Kanalname und die Informationen zum Warteschlangenpfad als Versendungssparameter verwendet werden. Weitere Informationen zum Versenden von Dokumenten finden Sie unter Submitting.

Die BizTalk-Messagingdienste für das Quellsystem verwenden den festgelegten Kanal, um Antwortnachrichten zu verarbeiten und verwenden den zugeordneten Messagingport, der den Warteschlangenpfad verwendet, um die Antwortnachricht an dieselbe aktive XLANG-Ablaufplaninstanz zu transportieren, die die Ausgangsnachricht generiert hat.

Damit die Konfiguration dieses Quellsystems korrekt funktioniert, muss auch das Zielsystem des Handelspartners korrekt konfiguriert sein. Weitere Informationen zum Konfigurieren des Zielsystems finden Sie unter Konfigurieren des Zielsystems für das Verwenden eines HTTP-Transports.

Um das Quellsystem so zu konfigurieren, dass ein HTTP-Transport verwendet wird, führen Sie die Schritte in der folgenden Tabelle aus. Verweise werden für jedes Verfahren bereitgestellt, und Anmerkungen weisen auf bestimmte Konfigurationsprobleme hin. Andere Einstellungen für Eigenschaften, die zum Fertigstellen der Konfiguration erforderlich sind, hängen von der einzelnen Geschäftssituation ab und sind hier nicht angegeben.

Schritt Verweise und Anmerkungen
Verwenden des BizTalk-Editors:
  • Erstellen Sie die Spezifikationen, die für die Dokumentdefinitionen für ein- und ausgehende Dokumente des Kanals benötigt werden, der die Ausgangsnachricht verarbeiten wird.
  • Erstellen und Überprüfen von Spezifikationen

    Anmerkungen

    • Sie müssen in jeder dieser Spezifikationen ein Feld für die Antwortadresse hinzufügen. Dieses Feld kann auf jeder Ebene hinzugefügt werden. Jedoch muss die Adresse mit dem Handelspartner abgestimmt werden und den Spezifikationen im Zielsystem Ihres Handelspartners entsprechen. Weitere Informationen finden Sie unter Verwalten von Datensätzen und Feldern.
  • Erstellen Sie die Spezifikationen, die für die Dokumentdefinitionen für ein- und ausgehende Dokumente des Kanals benötigt werden, der die Ausgangsnachricht verarbeiten wird.
  • Erstellen und Überprüfen von Spezifikationen

    Anmerkung

    • Für diese Spezifikationen ist keine besondere Konfiguration erforderlich.
Verwenden des BizTalk-Messaging-Managers:
  • Erstellen Sie eine Organisation, die für den Handelspartner und das Zielsystem steht.
  • Erstellen von Organisationen

    Anmerkung

    • Für diese Organisation ist keine besondere Konfiguration erforderlich.
  • Erstellen Sie die Dokumentdefinitionen, die zum Erstellen des Kanals benötigt werden, mit dem Sie die Ausgangsnachricht verarbeiten.
  • Erstellen von Dokumentdefinitionen

    Anmerkung

    • Wählen Sie in den Dokumentdefinitionen die Spezifikationen aus, die ein Antwortfeld haben. Weitere Informationen finden Sie unter Auswählen einer Dokumentspezifikation.
  • Erstellen Sie die Dokumentdefinitionen, die zum Erstellen des Kanals benötigt werden, mit dem Sie die Antwortnachricht verarbeiten.
  • Erstellen von Dokumentdefinitionen

    Anmerkung

    • Für diese Dokumentdefinitionen ist keine besondere Konfiguration erforderlich.
  • Erstellen Sie einen Messagingport zu einer Organisation, um die Ausgangsnachricht zum Zielsystem zu transportieren.
  • Erstellen von Messagingports

    Anmerkung

    • Dieser Messagingport darf kein offener Messagingport sein.
  • Erstellen Sie einen Messagingport zu einer Anwendung, um die Antwortnachricht an die aktive XLANG-Ablaufplaninstanz zu transportieren, welche die ausgehende Nachricht generiert hat.
  • Erstellen von Messagingports

    Anmerkung

    • Klicken Sie im Messagingport-Assistenten auf der Seite Zielanwendung auf Aktiver XLANG-Ablaufplan. Weitere Informationen finden Sie unter Festlegen von Eigenschaften für die Zielanwendung.
  • Erstellen Sie einen Kanal von einer Organisation, um die Antwortnachricht vom Zielsystem zu verarbeiten.
  • Erstellen von Kanälen

    Anmerkung

    • Notieren Sie sich den Kanalnamen und den Namen der Dokumentdefinition für ausgehende Dokumente, die Sie verwenden. Diese Namen werden zum Konfigurieren der BizTalk-Orchestrierungsdienste verwendet.
Verwenden des BizTalk-Orchestrierungs-Designers:
  • Verwenden Sie eine BizTalk-Messaging-Form, um einen Port zum Senden der Ausgangsnachricht zu implementieren.
  • Implementieren eines Ports mithilfe von BizTalk Messaging

    Anmerkung

    • Klicken Sie im BizTalk-Bindungs-Assistenten für Messaging auf der Seite Informationen über statische oder dynamische Kanäle auf Statischer Kanal, und geben Sie im Feld Geben Sie den Namen eines bekannten, vorgegebenen Kanals ein den Namen des Kanals im BizTalk-Messaging-Manager ein, den Sie zum Verarbeiten der Ausgangsnachricht verwenden.
  • Richten Sie den Kommunikationsfluss zwischen einer Aktion-Form und dem Port ein, der die Ausgangsnachricht sendet.
  • Senden oder Empfangen asynchroner Nachrichten

    Anmerkungen

    • Klicken Sie im Assistenten für XML-Kommunikation auf der Seite Nachrichteninformationen auf Neue Nachricht erstellen, und geben Sie im Feld Nachrichtenname einen Namen für die Nachricht ein.

      Sie können jeden Namen verwenden; jedoch wird durch Verwenden des Namens der Dokumentdefinition für eingehende Dokumente für den Kanal deutlicher, welche Nachricht Sie versenden.

    • Geben Sie auf der Seite Informationen über den Nachrichtentyp im Feld Nachrichtentyp den Namen der Dokumentdefinition für eingehende Dokumente für den Kanal ein, den Sie zur Verarbeitung der Nachricht verwenden.

    • Klicken Sie auf der Seite Informationen über die Nachrichtenspezifikation auf Durchsuchen, und gehen Sie zu der Spezifikation, die Sie für die Definition eingehender Dokumente des Kanals verwenden, mit dem Sie die Ausgangsnachricht verarbeiten.

    • Klicken Sie auf der Seite Informationen über die Nachrichtenspezifikation in den Bereich Nachrichtenfelder, klicken Sie auf Hinzufügen, und fügen Sie das Feld in der Spezifikation hinzu, das angelegt wurde, um die Antwortadresse in der Ausgangsnachricht aufzunehmen.
  • Verwenden Sie eine BizTalk-Messaging-Form, um einen Port zu implementieren, mit dem Sie eine Antwortnachricht empfangen.
  • Implementieren eines Ports mithilfe von BizTalk Messaging

    Anmerkung

    • Klicken Sie im BizTalk-Bindungs-Assistenten für Messaging auf der Seite Informationen über die XLANG-Ablaufplanaktivierung auf Nein.

    • Geben Sie auf der Seite Kanalinformationen im Feld Kanalname den Namen des Kanals im BizTalk-Messaging-Manager ein, mit dem Sie die Antwortnachricht verarbeiten werden.

      Der BizTalk-Orchestrierungs-Designer verwendet den Kanalnamen und einen global eindeutigen Bezeichner (GUID), um eine instanzbezogene Warteschlange zu erstellen und zu benennen, an die die Antwortnachricht gesendet wird.

    • Geben Sie auf der Seite Kanalinformationen in das Feld HTTP-URL-Adresse, über die der BizTalk-Messagingdienst Dokumente empfängt die Adresse der ASP-Seite ein, an die der Handelspartner eine Antwortnachricht senden kann.

      Der BizTalk-Orchestrierungs-Designer verwendet die Adresse und den Kanalnamen, die bzw. den Sie zuvor eingegeben haben, um eine HTTP-URL-Adresse mit einer Abfragezeichenfolge zu erstellen, die den Kanalnamen und den Warteschlangenpfad der instanzbezogenen Warteschlange enthält.
  • Richten Sie den Kommunikationsfluss zwischen einer Aktion-Form und dem Port ein, mit dem Sie eine Antwortnachricht empfangen.
  • Senden oder Empfangen asynchroner Nachrichten

    Anmerkungen

    • Klicken Sie im Assistenten für XML-Kommunikation auf der Seite Nachrichteninformationen auf Neue Nachricht erstellen, und geben Sie im Feld Nachrichtenname einen Namen für die Nachricht ein.

      Sie können jeden Namen verwenden; jedoch wird durch das Verwenden des Namens der Dokumentdefinition für ausgehende Dokumente für den Kanal deutlicher, welche Nachricht Sie empfangen.

    • Geben Sie auf der Seite Informationen über den Nachrichtentyp im Feld Nachrichtentyp den Namen der Dokumentdefinition für ausgehende Dokumente für den Kanal ein, den Sie zum Verarbeiten der Antwortnachricht verwenden.

      Alle Nachrichten, die von den BizTalk-Messagingdiensten an eine XLANG-Ablaufplaninstanz gesendet werden, werden an eine Nachrichtenwarteschlange gesendet. Die Nachrichtenbezeichnung für diese Nachrichten ist der Name der Dokumentdefinition für ausgehende Dokumente des Kanals.
  • Richten Sie den Datenfluss ein, um die Portverweisdaten an das Feld für die Antwortadresse weiterzuleiten.
  • Festlegen des Datenflusses zwischen Nachrichten

    Anmerkungen

    • Klicken Sie auf die Registerkarte Daten.

    • Klicken Sie auf der Datenseite in der Portverweise-Nachricht auf den Portverweis für den Port, der die Antwortnachricht empfangen wird.

    • Ziehen Sie dann das Kontrollhandle auf den Verbindungspunkt des Feldes für die Antwortadresse in der Ausgangsnachricht.

      Dadurch werden die Portverweisdaten in das Feld für die Antwortadresse der ausgehenden Ausgangsnachricht weitergeleitet. Der Portverweis ist eine HTTP-URL-Adresse einer ASP-Seite, die eine Abfragezeichenkette mit einem Kanalnamen und den Warteschlangenpfad der instanzbezogenen Warteschlange für den Port enthält.
Verwenden der ASP-Seite:
  • Sie können die Beispiel-ASP-Seite verwenden, die zusammen mit BizTalk Server 2000 bereitgestellt wird, oder eine ASP-Seite, die dasselbe Skript wie die Beispielseite verwendet.
 Anmerkungen
  • Um die Beispiel-ASP-Seite zu verwenden, gehen Sie zu \Programme\Microsoft BizTalk Server\SDK\Messaging Samples\ReceiveScripts auf dem Installationslaufwerk, um das Beispiel ReceiveResponse.asp zu suchen.

  • Speichern Sie diese Datei dann in dem entsprechenden Verzeichnis für die Website des Quellsystems.

  • Wenn die Beispiel-ASP-Seite eine Antwortnachricht empfängt, extrahiert ihr Skript den Kanalnamen und den Warteschlangenpfad aus der Abfragezeichenfolge in der Adresse des HTTP-Headers. Die ASP-Seite konvertiert außerdem den Warteschlangenpfad von einem Pfadnamen in einen Formatnamen und fügt ein Präfix queue:// hinzu. Die Seite verwendet dann diese Daten als Parameter, um die Antwortnachricht an die BizTalk-Messagingdienste für das Quellsystem zu versenden. Weitere Informationen zum Versenden von Dokumenten finden Sie unter Submitting.

Verwenden eines sicheren HTTPS-Transports

Falls Ihr Geschäftsprozess einen sicheren Transport für den Austausch von Nachrichten mit einem Handelspartner erfordert, müssen Sie einen HTTPS-Transport verwenden.

Die einzige Veränderung, die Sie an der Konfiguration des Quellsystems vornehmen müssen, damit ein HTTPS-Transport verwendet werden kann, besteht in der Modifizierung der URL-Adresse für den Port, an dem Sie die Antwortnachricht empfangen.

Wenn Sie den Port implementieren, der die Antwortnachricht empfängt, muss der URL, den Sie für die Antwortadresse eingeben, statt eines HTTP-Präfixes ein HTTPS-Präfix aufweisen.

Nachfolgend ein Beispiel für eine Antwortadresse, die für HTTPS vorbereitet ist:

https://hostname/receiveresponse.asp?channel=ChannelForReply&qpath=hostname.domain.corp.vigorair-18.com\private$\sendingchannel2{9e0016bf-be1f-48fe-82de-b27077ab5e73}

Für das Zielsystem sind keine weiteren Änderungen an der Konfiguration erforderlich.

Verwandte Themen

Verwenden eines Nicht-HTTP-Transports

Integrieren der BizTalk-Dienste


Konfigurieren des Zielsystems für das Verwenden eines HTTP-Transports

Durch die Schritte in diesem Thema wird erläutert, wie das Zielsystem konfiguriert werden muss, damit es eine Nachricht empfängt, die eine HTTP-URL-Antwortadresse enthält, und an das Quellsystem eine Antwortnachricht mithilfe eines HTTP-Transports sendet. Informationen zum Konfigurieren der Systeme, so dass das Zielsystem einen Nicht-HTTP-Transport für das Versenden der Antwortnachrichten verwendet, finden Sie unter Konfigurieren des Zielsystems für das Verwenden eines Nicht-HTTP-Transports. Die Überlegungen zur Konfiguration für die Verwendung eines sicheren HTTPS-Transports werden weiter unten in diesem Thema behandelt.

Wenn die BizTalk-Messagingdienste für das Zielsystem die Ausgangsnachricht empfangen, sind diese so konfiguriert, dass sie eine neue Instanz eines festgelegten XLANG-Ablaufplanes aktivieren und die Nachricht an einen festgelegten Port in dieser XLANG-Ablaufplaninstanz senden.

Der XLANG-Ablaufplan ist so konfiguriert, dass er die Daten der Antwortadresse, die sich in einem Feld der Ausgangsnachricht befinden, an das Portverweisfeld für den Port weiterleitet, der zum Senden der Antwortnachricht verwendet wird. Der XLANG-Ablaufplan versendet dann mit der dynamischen Kanaloption die Antwortnachricht an die BizTalk-Messagingdienste.

Für die dynamische Kanaloption werden spezifische Portdaten als Versendungsparameter weitergeleitet, wenn die Nachricht an die BizTalk-Messagingdienste versendet wird. Die Portverweisdaten, in diesem Fall die Antwortadresse, werden an den Zielbezeichnerparameter weitergeleitet, und der Nachrichtentyp für den Port wird als Parameter für den Dokumentendefinitionsnamen weitergeleitet. Weitere Informationen zu Versendungsparametern finden Sie unter Submitting. Die Versendungsparameter ermöglichen den BizTalk-Messagingdiensten das Festlegen eines bestimmten Kanals zur Verarbeitung der Antwortnachricht. Weitere Informationen finden Sie unter Identifikation.

Wenn Sie die dynamische Kanaloption verwenden, muss dem Kanal in den BizTalk-Messagingdiensten ein offener Messagingport zugewiesen sein. Der offene Messagingport transportiert die Antwortnachricht zum Quellsystem des Handelspartners, indem die Antwortadresse verwendet wird, die als Zielbezeichnerparameter weitergeleitet wird. Da dies die HTTP-URL einer ASP-Seite im Quellsystem ist, wird der HTTP-Transport verwendet. Weitere Informationen zu offenen Messagingports finden Sie unter Offene Messagingports.

Damit die Konfiguration dieses Zielsystems korrekt funktioniert, muss auch das Quellsystem des Handelspartners korrekt konfiguriert sein. Weitere Informationen zum Konfigurieren des Quellsystems finden Sie in Konfigurieren des Quellsystems für das Verwenden eines HTTP-Transports.

Um das Zielsystem so zu konfigurieren, dass ein HTTP-Transport verwendet wird, führen Sie die Schritte in der folgenden Tabelle aus. Verweise werden für jedes Verfahren bereitgestellt, und Anmerkungen weisen auf bestimmte Konfigurationsprobleme hin. Andere Einstellungen für Eigenschaften, die für das Fertigstellen der Konfiguration erforderlich sind, hängen von der einzelnen Geschäftssituation ab und sind hier nicht angegeben.

Schritt Verweise und Anmerkungen
Verwenden des BizTalk-Editors:
  • Erstellen Sie die Spezifikationen für die Dokumentdefinitionen für ein- und ausgehende Dokumente des Kanals, mit dem Sie die Ausgangsnachricht verarbeiten werden.
  • Erstellen und Überprüfen von Spezifikationen

    Anmerkung

    • Sie müssen in jeder dieser Spezifikationen ein Feld für die Antwortadresse hinzufügen. Dieses Feld kann auf jeder Ebene hinzugefügt werden. Jedoch muss die Adresse mit dem Handelspartner abgestimmt werden und den Spezifikationen im Quellsystem Ihres Handelspartners entsprechen. Weitere Informationen finden Sie unter Verwalten von Datensätzen und Feldern.
  • Erstellen Sie die Spezifikationen, die für die eingehenden und ausgehenden Dokumentdefinitionen des Kanals benötigt werden, der die Antwortnachricht verarbeiten wird.
  • Erstellen und Überprüfen von Spezifikationen

    Anmerkung

    • Für diese Spezifikationen ist keine besondere Konfiguration erforderlich.
Verwenden des BizTalk-Messaging-Managers:
  • Erstellen Sie eine Organisation, die für den Handelspartner mit dem Quellsystem steht.
  • Erstellen von Organisationen

    Anmerkung

    • Für diese Organisation ist keine besondere Konfiguration erforderlich.
  • Erstellen Sie die Dokumentdefinitionen, die für das Erstellen eines Kanals benötigt werden, der die Ausgangsnachricht verarbeitet, und eines Kanals, der die Antwortnachricht verarbeitet.
  • Erstellen von Dokumentdefinitionen

    Anmerkung

    • Wählen Sie in den Dokumentdefinitionen die zuvor erstellten Spezifikationen. Weitere Informationen finden Sie unter Auswählen einer Dokumentspezifikation.
  • Erstellen Sie einen Messagingport zu einer Anwendung, um eine neue XLANG-Ablaufplaninstanz zu aktivieren und um die Ausgangsnachricht an einen Port in der XLANG-Ablaufplaninstanz zu transportieren.
  • Erstellen von Messagingports

    Anmerkungen

    • Klicken Sie im Messagingport-Assistenten auf der Seite Zielanwendung auf Neuer XLANG-Ablaufplan.

    • Geben Sie im Feld Moniker für Ablaufplan den Moniker des spezifizierten Ablaufplanes ein, oder klicken Sie auf Durchsuchen, um den Pfad festzulegen.

    • Geben Sie im Feld Portname den Namen des in diesem Ablaufplan vorgesehenen Ports ein, an den das Dokument gesendet wird.

      Weitere Informationen finden Sie unter Festlegen von Eigenschaften für die Zielanwendung.
  • Erstellen Sie einen Kanal von einer Organisation, um die Ausgangsnachricht vom Handelspartner zu verarbeiten.
  • Erstellen von Kanälen

    Anmerkung

    • Notieren Sie sich den Kanalnamen und den Namen der Dokumentdefinition für ausgehende Dokumente, die Sie verwenden. Diese Namen werden zum Konfigurieren der BizTalk-Orchestrierungsdienste verwendet.
  • Erstellen Sie einen offenen Messagingport zu einer Organisation, um die Antwortnachricht zum Quellsystem zu transportieren.
  • Erstellen von Messagingports

    Anmerkung

    • Klicken Sie im Messagingport-Assistenten auf der Seite Zielorganisation auf Offenes Ziel.

    • Weitere Informationen finden Sie unter Festlegen von Eigenschaften für die Zielanwendung.

      Für einen offenen Messagingport müssen die Zielinformationen im Dokument enthalten sein oder von den Versendungsparametern bereitgestellt werden. Wenn der XLANG-Ablaufplan die Antwortnachricht an die BizTalk-Messagingdienste versendet, gibt er die Daten der Antwortadresse als Zielbezeichner-Verwendungsparameter weiter, die in der Ausgangsnachricht enthalten waren.
  • Erstellen Sie einen Kanal von einer Anwendung, um die Antwortnachricht vom XLANG-Ablaufplan zu verarbeiten.
  • Erstellen von Kanälen

    Anmerkung

    • Klicken Sie im Kanal-Assistenten auf der Seite Quellanwendung auf XLANG-Ablaufplan. Weitere Informationen finden Sie unter Festlegen von Eigenschaften für die Quellanwendung.
Verwenden des BizTalk-Orchestrierungs-Designers:
  • Verwenden Sie eine BizTalk-Messaging-Form, um einen Port für das Empfangen der Ausgangsnachricht zu implementieren.
  • Implementieren eines Ports mithilfe von BizTalk Messaging

    Anmerkungen

    • Klicken Sie im BizTalk-Bindungs-Assistenten für Messaging auf der Seite Kommunikationsrichtung auf Empfangen.

    • Klicken Sie im BizTalk-Bindungs-Assistenten für Messaging auf der Seite Informationen über die XLANG-Ablaufplanaktivierung auf Ja.

      Wichtig

    • Wenn Sie auf Ja klicken, wird der Port so konfiguriert, dass eine neue Ablaufplaninstanz aktiviert wird, wenn eine Nachricht ankommt. Weitere wichtige Informationen zu dieser Option finden Sie in den Themen, auf die in Zusammenhang mit diesem Schritt verwiesen wird.
  • Richten Sie den Kommunikationsfluss zwischen einer Aktion-Form und dem Port ein, der die Ausgangsnachricht empfängt.
  • Senden oder Empfangen asynchroner Nachrichten

    Anmerkung

    • Klicken Sie im Assistenten für XML-Kommunikation auf der Seite Nachrichteninformationen auf Neue Nachricht erstellen, und geben Sie im Feld Nachrichtenname einen Namen für die Nachricht ein.

      Sie können jeden Namen verwenden; jedoch wird durch das Verwenden des Namens der Dokumentdefinition für ausgehende Dokumente für den Kanal deutlicher, welche Nachricht Sie senden.

    • Geben Sie auf der Seite Informationen über den Nachrichtentyp im Feld Nachrichtentyp den Namen der Dokumentdefinition für ausgehende Dokumente für den Kanal ein, den Sie zur Verarbeitung der Antwortnachricht verwenden.

      Alle von BizTalk-Messaging an den XLANG-Ablaufplan weitergeleiteten Nachrichten verwenden eine Nachrichtenwarteschlange. Die Bezeichnung für diese Nachrichten ist der Name der Dokumentdefinition für ausgehende Dokumente des Kanals.
  • Verwenden Sie eine BizTalk-Messaging-Form, um einen Port zum Senden der Antwortnachricht zu implementieren.
  • Implementieren eines Ports mithilfe von BizTalk Messaging

    Anmerkungen

    • Klicken Sie im BizTalk-Bindungs-Assistenten für Messaging auf der Seite Informationen über statische oder dynamische Kanäle auf Dynamischer Kanal.

    • Wenn Sie einen Port erstellen, der einen dynamischen Kanal verwendet, wird der Kanal, den die BizTalk-Messagingdienste zum Verarbeiten der Nachricht verwenden, aufgrund der Portdaten ermittelt, die als Versendungsparameter weitergeleitet wurden. Dies wird weiter unten in dieser Tabelle beschrieben.
  • Richten Sie den Kommunikationsfluss zwischen einer Aktion-Form und dem Port ein, der zum Versenden der Antwortnachricht verwendet wird.
  • Senden oder Empfangen asynchroner Nachrichten

    Anmerkung

    • Klicken Sie im Assistenten für XML-Kommunikation auf der Seite Nachrichteninformationen auf Neue Nachricht erstellen, und geben Sie im Feld Nachrichtenname einen Namen für die Nachricht ein.

      Sie können jeden Namen verwenden; jedoch wird durch das Verwenden des Namens der Dokumentdefinition für eingehende Dokumente für den Kanal deutlicher, welche Nachricht Sie versenden.

    • Auf der Seite Informationen über den Nachrichtentyp im Feld Nachrichtentyp müssen Sie den Namen der Dokumentdefinition für eingehende Dokumente für den Kanal eingeben, den Sie zum Verarbeiten der Nachricht verwenden.

      Die Daten der Dokumentdefinition für eingehende Dokumente werden als Versendungsparameter an die BizTalk-Messagingdienste weitergeleitet. Dies wird weiter unten in der Tabelle beschrieben.
  • Richten Sie den Datenfluss ein, um das Antwortfeld an den Portverweis des Ports weiterzuleiten, der die Antwortnachricht sendet.
  • Festlegen des Datenflusses zwischen Nachrichten

    Anmerkungen

    • Klicken Sie auf die Registerkarte Daten.

    • Klicken Sie in der Ausgangsnachricht auf der Datenseite Daten auf das Feld für die Antwortadresse. Ziehen Sie dann das Kontrollhandle auf den linken Verbindungspunkt des Portverweises in der Nachricht Portverweise für den Port, der zum Senden einer Antwortnachricht verwendet wird.

    Wichtig

    • Sie müssen das Feld für die Antwortadresse mit dem linken Verbindungspunkt des Portverweises verbinden.

    • Ein linker Verbindungspunkt an einem Portverweis ist nur verfügbar, wenn ein Port konfiguriert wird, der einen dynamischen Kanal zum Senden von Nachrichten verwendet.

      Für einen Port, der einen dynamischen Kanal verwendet, müssen die Daten für den Portverweis aus einem Feld in einer zuvor empfangenen Nachricht weitergeleitet werden.

      In diesem Szenario werden die Daten der Antwortadresse aus der Ausgangsnachricht an das Portverweisfeld für den Port weitergeleitet, der zum Versenden der Antwort verwendet wird. Die Antwortadresse ist der HTTP-URL, an den die Antwort gesendet wird.

      Wenn ein Port, der einen dynamischen Kanal verwendet, eine Nachricht an die BizTalk-Messagingdienste weiterleitet, werden die Portverweisdaten als Zielbezeichnerparameter weitergegeben und die Nachrichtentypdaten werden als Dokumentdefinitionsparameter weitergeleitet. Mithilfe der Parameter können die BizTalk-Messagingdienste feststellen, welcher Kanal zum Verarbeiten der Nachricht aufgerufen werden soll. Weitere Informationen finden Sie unter Identifikation und Submitting.

      Wenn ein Port so konfiguriert wird, dass ein dynamischer Kanal verwendet wird, werden die Informationen zum Ziel als Parameter in einer Versendung an ein offenes Ziel weitergeleitet. Deshalb muss ein Kanal, der von einem Port aufgerufen wird, der einen dynamischen Kanal verwendet, einem offenen Messagingport zugewiesen sein.

Verwenden eines sicheren HTTPS-Transports

Da der zum Transport von Antworten verwendete Messagingport ein offener Messagingport ist, ist es nicht möglich, ein Verschlüsselungszertifikat zum Verschlüsseln von Dokumenten zu verwenden.

Wenn für den Geschäftsprozess ein sicherer Transport für den Austausch von Nachrichten mit einem Handelspartner erforderlich ist, muss das Quellsystem einen HTTPS-URL statt eines HTTP-URL in den ursprünglich an Sie gesendeten Nachrichten als Antwortadresse angeben.

Weitere Informationen finden Sie unter Konfigurieren des Quellsystems für das Verwenden eines HTTP-Transports.


Verwenden eines Nicht-HTTP-Transports

Dieser Abschnitt erläutert, wie die BizTalk-Orchestrierungsdienste und die BizTalk-Messagingdienste sowohl für das Quellsystem als auch für das Zielsystem integriert und konfiguriert werden, so dass:

  • Das Quellsystem eine Nachricht generiert und an das Zielsystem eines Handelspartners mithilfe einer bestimmten XLANG-Ablaufplaninstanz sendet.

  • Das Zielsystem die Ausgangsnachricht empfängt, eine XLANG-Ablaufplaninstanz aktiviert, die eine Antwortnachricht generiert, und dann die Antwortnachricht an das Quellsystem mit einem Nicht-HTTP-Transport sendet.

Informationen zum Konfigurieren beider Systeme , so dass das Zielsystem einen HTTP-Transport zum Versenden der Antwortnachrichten verwenden kann, finden Sie unter Verwenden eines HTTP-Transports.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Konfigurieren des Quellsystems für das Verwenden eines Nicht-HTTP-Transports

  • Konfigurieren des Zielsystems für das Verwenden eines Nicht-HTTP-Transports


Konfigurieren des Quellsystems für das Verwenden eines Nicht-HTTP-Transports

Die Schritte in diesem Thema erläutern, wie das Quellsystem konfiguriert werden muss, damit es eine Nachricht generiert und versendet, die den Pfad einer statischen Warteschlange enthält. Das Zielsystem des Handelspartners ist so konfiguriert, dass es den Warteschlangenpfad in einer Nachricht in ein Feld einer Antwortnachricht weiterleitet und diese an das Quellsystem mithilfe eines Nicht-HTTP-Transports sendet. Informationen zum Konfigurieren des Quellsystems, so dass das Zielsystem einen HTTP-Transport zum Versenden der Antwortnachrichten verwendet, finden Sie unter Konfigurieren des Quellsystems für das Verwenden eines HTTP-Transports.

Wenn das Quellsystem die Antwortnachricht empfängt, versendet es die Nachricht an die BizTalk-Messagingdienste. Die BizTalk-Messagingdienste transportieren die Antwortnachricht an die Warteschlange, die im Warteschlangenpfad im Dokumentfeld festgelegt wird. Diese Warteschlange wird von derselben XLANG-Ablaufplaninstanz überwacht, welche auch die Ausgangsnachricht generiert hat, und der Ablaufplan ruft die Nachricht aus der Warteschlange ab.

Damit die Konfiguration dieses Quellsystems korrekt funktioniert, muss auch das Zielsystem des Handelspartners korrekt konfiguriert sein. Weitere Informationen zum Konfigurieren des Zielsystems finden Sie in Konfigurieren des Zielsystems für das Verwenden eines Nicht-HTTP-Transports.

Um das Quellsystem so zu konfigurieren, dass ein Nicht-HTTP-Transport verwendet wird, führen Sie die in der folgenden Tabelle aufgeführten Schritte aus. Verweise werden für jedes Verfahren bereitgestellt, und Anmerkungen weisen auf bestimmte Konfigurationsprobleme hin. Andere Einstellungen für Eigenschaften, die zum Fertigstellen der Konfiguration erforderlich sind, hängen von der einzelnen Geschäftssituation ab und sind hier nicht angegeben.

Schritt Verweise und Anmerkungen
Verwenden des BizTalk-Editors:
  • Erstellen Sie die Spezifikationen für die eingehenden und ausgehenden Dokumentdefinitionen des Kanals, den Sie zum Verarbeiten der Ausgangsnachricht verwenden.
  • Erstellen und Überprüfen von Spezifikationen

    Anmerkung

    • Sie müssen in jeder dieser Spezifikationen ein Feld für den Warteschlangenpfad hinzufügen. Dieses Feld kann auf jeder Ebene hinzugefügt werden. Jedoch muss die Adresse mit dem Handelspartner abgestimmt werden und den Spezifikationen im Zielsystem des Handelspartners entsprechen. Weitere Informationen finden Sie unter Verwalten von Datensätzen und Feldern.
  • Erstellen Sie die Spezifikationen für die Dokumentdefinitionen für ein- und ausgehende Dokumente des Kanals, mit dem Sie die Antwortnachricht verarbeiten werden.
  • Erstellen und Überprüfen von Spezifikationen

    Anmerkungen

    • Sie müssen in der Spezifikation für eingehende Dokumente einen Warteschlangenpfad hinzufügen. Dieses Feld kann auf jeder Ebene hinzugefügt werden. Jedoch muss die Adresse mit dem Handelspartner abgestimmt werden und den Spezifikationen im Zielsystem des Handelspartners entsprechen. Weitere Informationen finden Sie unter Verwalten von Datensätzen und Feldern.

    • Das Feld zur Angabe des Warteschlangenpfades in der Spezifikation für eingehende Dokumente muss als der Zielwert in den Eigenschaften festgelegt sein. Weitere Informationen finden Sie unter Festlegen von Wörterbucheigenschaften.

      Wenn die Antwortnachricht empfangen und an die BizTalk-Messagingdienste im Quellsystem versendet wird, wird der Warteschlangenpfad erkannt und als Zielbezeichnerparameter behandelt. Weitere Informationen finden Sie unter Submitting. Der Messagingport transportiert die Antwortnachricht an die von diesem Warteschlangenpfad angegebene Warteschlange. Der XLANG-Ablaufplan überwacht diese Warteschlange und ruft die Antwort ab.

Verwenden des BizTalk-Mappers:
  • Erstellen Sie eine Zuordnung, die in dem Kanal verwendet wird, der die Ausgangsnachricht verarbeitet.
  • Erstellen neuer Zuordnungen

    Wichtig

    • Die Syntax für den Namen des Warteschlangenpfades, den der XLANG-Ablaufplan generiert, muss von einem Pfadnamen in einen Formatnamen geändert werden, und es muss das Präfix queue:// hinzugefügt werden. Bei dem HTTP-Transport-Szenario übernimmt das Skript in der ASP-Seite diese Änderung. Um diese Änderung für das Nicht-HTTP-Transport-Szenario vorzunehmen, müssen Sie ein Funktoid Verketten in einer Zuordnung verwenden. Weitere Informationen finden Sie unter Zuordnungen für die Integration der BizTalk-Dienste.
Verwenden des BizTalk-Messaging-Managers:
  • Erstellen Sie eine Organisation, die für den Handelspartner mit dem Zielsystem steht.
  • Erstellen von Organisationen

    Anmerkung

    • Für diese Organisation ist keine besondere Konfiguration erforderlich.
  • Erstellen Sie die Dokumentdefinitionen, die für das Erstellen eines Kanals benötigt werden, der die Ausgangsnachricht verarbeitet, und eines Kanals, der die Antwortnachricht verarbeitet.
  • Erstellen von Dokumentdefinitionen

    Anmerkung

    • Wählen Sie in den Dokumentdefinitionen die zuvor erstellten Spezifikationen aus. Weitere Informationen finden Sie unter Auswählen einer Dokumentspezifikation.
  • Erstellen Sie einen Messagingport zu einer Organisation, um die Ausgangsnachricht zum Zielsystem zu transportieren.
  • Erstellen von Messagingports

    Anmerkung

    • Für diesen Messagingport ist keine besondere Konfiguration erforderlich.
  • Erstellen Sie einen Kanal von einer Anwendung, um die Ausgangsnachricht vom XLANG-Ablaufplan zu verarbeiten.
  • Erstellen von Kanälen

    Anmerkungen

    • Klicken Sie im Kanal-Assistenten auf der Seite Quellanwendung auf XLANG-Ablaufplan. Weitere Informationen finden Sie unter Festlegen von Eigenschaften für die Quellanwendung.

    • Aktivieren Sie auf der Seite Ausgehendes Dokument das Kontrollkästchen Eingehendes Dokument ausgehendem Dokument zuordnen, und klicken Sie rechts neben dem Feld Verweis zuordnen auf Durchsuchen. Gehen Sie dann zu der Zuordnung, die Sie zuvor erstellt haben, und klicken Sie auf Öffnen.

    • Notieren Sie sich den Kanalnamen und den Namen der Dokumentendefinition für eingehende Dokumente, die Sie verwenden. Diese Namen werden verwendet, um die BizTalk-Orchestrierungsdienste zu konfigurieren.
  • Erstellen Sie einen offenen Messagingport zu einer Organisation, um die Antwortnachricht zur aktiven XLANG-Ablaufplaninstanz zu transportieren, die die Ausgangsnachricht generiert hat.
  • Erstellen von Messagingports

    Anmerkungen

    • Klicken Sie im Messagingport-Assistenten auf der Seite Zielorganisation auf Offenes Ziel. Weitere Informationen finden Sie unter Festlegen von Eigenschaften für die Zielorganisation.

    • Für dieses Szenario erstellen Sie einen Messagingport zu einer Organisation, selbst wenn Sie die Antwortnachricht an eine Anwendung, nämlich an einen XLANG-Ablaufplan, senden.

      Dadurch können Sie einen offenen Messagingport verwenden, um die Antwortnachricht mithilfe der Warteschlangeninformationen als Versendungsparameter zu versenden. Weitere Informationen finden Sie unter Submitting.

      Der offene Messagingport transportiert die Antwort zur statischen Warteschlange, die in dem Warteschlangenpfad angegeben ist, die der XLANG-Ablaufplan so konfiguriert ist, dass er sie abruft.
  • Erstellen Sie einen Kanal von einer Organisation, um die Antwortnachricht vom Zielsystem zu verarbeiten.
  • Erstellen von Kanälen

    Anmerkungen

    • Die Dokumentdefinition für eingehende Dokumente für diesen Kanal muss die Dokumentdefinition verwenden, die die zuvor erstellte Spezifikation verwendet, in der Sie das Feld zum Angeben des Warteschlangenpfades als den Zielwert in den Wörterbucheigenschaften festgelegt haben.

    • Notieren Sie sich den Kanalnamen und den Namen der Dokumentendefinition für eingehende Dokumente, die Sie verwenden. Diese Namen werden zum Konfigurieren der BizTalk-Orchestrierungsdienste verwendet.
Verwenden des BizTalk-Orchestrierungs-Designers:
  • Verwenden Sie eine BizTalk-Messaging-Form, um einen Port zum Senden der Ausgangsnachricht zu implementieren.
  • Implementieren eines Ports mithilfe von BizTalk Messaging

    Anmerkung

    • Klicken Sie im BizTalk-Bindungs-Assistenten für Messaging auf der Seite Informationen über statische oder dynamische Kanäle auf Statischer Kanal, und geben Sie im Feld Geben Sie den Namen eines bekannten, vorgegebenen Kanals ein den Namen des Kanals im BizTalk-Messaging-Manager ein, den Sie zum Verarbeiten der Ausgangsnachricht verwenden.
  • Richten Sie den Kommunikationsfluss zwischen einer Aktion-Form und dem Port ein, der die Ausgangsnachricht sendet.
  • Senden oder Empfangen asynchroner Nachrichten

    Anmerkungen

    • Klicken Sie im Assistenten für XML-Kommunikation auf der Seite Nachrichteninformationen auf Neue Nachricht erstellen, und geben Sie im Feld Nachrichtenname einen Namen für die Nachricht ein.

      Sie können jeden Namen verwenden; jedoch wird durch die Verwendung des Namens der Dokumentdefinition für eingehende Dokumente für den Kanal deutlicher, welche Nachricht Sie versenden.

    • Geben Sie auf der Seite Informationen über den Nachrichtentyp im Feld Nachrichtentyp den Namen der Dokumentdefinition für eingehende Dokumente für den Kanal ein, den Sie zum Verarbeiten der Nachricht verwenden.

    • Klicken Sie auf der Seite Informationen über die Nachrichtenspezifikation auf Durchsuchen, und gehen Sie zu der Spezifikation, die Sie für die Definition eingehender Dokumente des Kanals für die Ausgangsnachricht verwenden.

    • Klicken Sie auf der Seite Informationen über die Nachrichtenspezifikation in den Bereich Nachrichtenfelder, klicken Sie auf Hinzufügen, und fügen Sie das Feld in der Spezifikation hinzu, das angelegt wurde, um den Warteschlangenpfad aufzunehmen.
  • Verwenden Sie eine BizTalk-Message Queuing-Form, um einen Port zu implementieren, an dem Sie eine Antwortnachricht empfangen.
  • Implementieren eines Ports mithilfe von Message Queuing

    Anmerkungen

    • Bei diesem Szenario verwenden Sie eine Message Queuing-Portbindung, obwohl Sie eine Nachricht von den BizTalk-Messagingdiensten empfangen.

    • Klicken Sie im Bindungs-Assistenten für Message Queuing auf der Seite Informationen über statische oder dynamische Warteschlangen auf Statische Warteschlange.

    • Klicken Sie auf der Seite Warteschlangeninformationen auf Bekannte Warteschlange für alle Instanzen verwenden, und geben Sie in das Feld Geben Sie den Namen der Warteschlange ein den Namen der statischen Warteschlange ein, mit deren Hilfe Sie die Antwortnachrichten verarbeiten.
  • Richten Sie den Kommunikationsfluss zwischen einer Aktion-Form und dem Port ein, an dem Sie eine Antwortnachricht empfangen.
  • Senden oder Empfangen asynchroner Nachrichten

    Anmerkung

    • Klicken Sie im Assistenten für XML-Kommunikation auf der Seite Willkommen beim Assistenten für XML-Kommunikation auf Empfangen.

    • Klicken Sie auf der Seite Nachrichteninformationen auf Neue Nachricht erstellen, und geben Sie im Feld Nachrichtenname einen Namen für die Nachricht ein.

      Sie können jeden Namen verwenden; jedoch wird durch das Verwenden des Namens der Dokumentdefinition für ausgehende Dokumente für den Kanal deutlicher, welche Nachricht Sie empfangen.

    • Geben Sie auf der Seite Informationen über den Nachrichtentyp im Feld Nachrichtentyp den Namen der Dokumentdefinition für ausgehende Dokumente für den Kanal ein, den Sie zum Verarbeiten der Antwortnachricht verwenden.

      Alle von BizTalk-Messaging an den XLANG-Ablaufplan weitergeleiteten Nachrichten verwenden eine Nachrichtenwarteschlange. Die Bezeichnung für diese Nachrichten ist der Name der Dokumentdefinition für ausgehende Dokumente des Kanals.
  • Richten Sie den Datenfluss vom empfangenden Portverweis zum Feld zum Angeben des Warteschlangenpfades ein.
  • Festlegen des Datenflusses zwischen Nachrichten

    Anmerkungen

    • Klicken Sie auf die Registerkarte Daten.

    • Klicken Sie auf der Datenseite in der Nachricht Portverweise auf das Feld für den Port, der die Antwortnachricht empfängt. Ziehen Sie dann das Kontrollhandle zum Verbindungspunkt des Feldes zum Angeben des Warteschlangenpfades in der Ausgangsnachricht.

      Dadurch werden die Verweisreferenzdaten in das Warteschlangenfeld der Ausgangsnachricht eingefügt. Der Portverweis ist der Warteschlangenpfad der statischen Warteschlange für den Port, mit dem Sie eine Antwortnachricht empfangen.


Konfigurieren des Zielsystems für das Verwenden eines Nicht-HTTP-Transports

Die Schritte in diesem Thema erläutern, wie das Zielsystem konfiguriert werden muss, damit es eine Nachricht empfängt, die einen Warteschlangenpfad enthält, und eine Antwortnachricht an denselben Warteschlangenpfad zum Quellsystem mithilfe eines Nicht-HTTP-Transports sendet. Informationen zum Konfigurieren des Zielsystems, so dass das Zielsystem einen HTTP-Transport zum Versenden der Antwortnachrichten verwendet, finden Sie unter Konfigurieren des Zielsystems für das Verwenden eines HTTP-Transports.

Wenn die BizTalk-Messagingdienste für das Zielsystem die Ausgangsnachricht empfangen, sind diese so konfiguriert, dass sie eine neue Instanz eines festgelegten XLANG-Ablaufplanes aktivieren und die Nachricht an einen festgelegten Port in dieser XLANG-Ablaufplaninstanz weiterleiten.

Der XLANG-Ablaufplan ist so konfiguriert, dass er die Daten im Feld des Warteschlangenpfades der Ausgangsnachricht an ein passendes Feld der Antwortnachricht weiterleitet und die Antwortnachricht dann an einen Kanal in den BizTalk-Messagingdiensten versendet.

Die BizTalk-Messagingdienste verwenden den angegebenen Kanal, um die Antwortnachricht zu verarbeiten und sie an einen Messagingport weiterzuleiten. Dieser Messagingport ist so konfiguriert, dass die Antwortnachricht an eine Adresse transportiert wird, die mit dem Handelspartner, der für das Quellsystem zuständig ist, vereinbart wurde. Dieser Messagingport darf kein offener Messagingport sein.

Damit die Konfiguration dieses Zielsystems korrekt funktioniert, muss auch das Quellsystem des Handelspartners korrekt konfiguriert sein. Weitere Informationen zum Konfigurieren des Quellsystems finden Sie unter Konfigurieren des Quellsystems für das Verwenden eines Nicht-HTTP-Transports.

Um das Zielsystem so zu konfigurieren, dass ein Nicht-HTTP-Transport verwendet wird, führen Sie die in der folgenden Tabelle aufgeführten Schritte aus. Verweise werden für jedes Verfahren bereitgestellt, und Anmerkungen weisen auf bestimmte Konfigurationsprobleme hin. Andere Einstellungen für Eigenschaften, die zum Abschließen der Konfiguration erforderlich sind, hängen von der einzelnen Geschäftssituation ab und sind hier nicht angegeben.

Schritt Verweise und Anmerkungen
Verwenden des BizTalk-Editors:
  • Erstellen Sie die Spezifikationen für die Dokumentdefinitionen für ein- und ausgehende Dokumente des Kanals, mit dem Sie die Ausgangsnachricht verarbeiten werden.
  • Erstellen und Überprüfen von Spezifikationen

    Anmerkungen

    • Sie müssen in jeder dieser Spezifikationen ein Feld für den Warteschlangenpfad hinzufügen. Dieses Feld kann auf jeder Ebene hinzugefügt werden. Jedoch muss die Adresse mit dem Handelspartner abgestimmt werden und den Spezifikationen im Quellsystem Ihres Handelspartners entsprechen. Weitere Informationen finden Sie unter Verwalten von Datensätzen und Feldern.
  • Erstellen Sie die Spezifikationen für die Dokumentdefinitionen für ein- und ausgehende Dokumente des Kanals, mit dem Sie die Antwortnachricht verarbeiten werden.
  • Erstellen und Überprüfen von Spezifikationen

    Anmerkungen

    • Sie müssen in jeder dieser Spezifikationen ein Feld für den Warteschlangenpfad hinzufügen. Dieses Feld kann auf jeder Ebene hinzugefügt werden. Jedoch muss die Adresse mit dem Handelspartner abgestimmt werden und den Spezifikationen im Quellsystem Ihres Handelspartners entsprechen. Weitere Informationen finden Sie unter Verwalten von Datensätzen und Feldern.
Verwenden des BizTalk-Messaging-Managers:
  • Erstellen Sie eine Organisation, die für den Handelspartner mit dem Quellsystem steht.
  • Erstellen von Organisationen

    Anmerkung

    • Für diese Organisation ist keine besondere Konfiguration erforderlich.
  • Erstellen Sie die erforderlichen Dokumentdefinitionen für das Einrichten eines Kanals, um die Ausgangsnachricht zu verarbeiten.
  • Erstellen von Dokumentdefinitionen

    Anmerkung

    • Wählen Sie in den Dokumentdefinitionen die zuvor erstellten Spezifikationen aus. Weitere Informationen finden Sie unter Auswählen einer Dokumentspezifikation.
  • Erstellen Sie die erforderlichen Dokumentdefinitionen für das Einrichten eines Kanals, um die Antwortnachricht zu verarbeiten.
  • Erstellen von Dokumentdefinitionen

    Anmerkung

    • Wählen Sie in den Dokumentdefinitionen die zuvor erstellten Spezifikationen aus. Weitere Informationen finden Sie unter Auswählen einer Dokumentspezifikation.
  • Erstellen Sie einen Messagingport zu einer Anwendung, um eine neue XLANG-Ablaufplaninstanz zu aktivieren, und transportieren Sie die Ausgangsnachricht an einen Port in dieser XLANG-Ablaufplaninstanz.
  • Erstellen von Messagingports

    Anmerkungen

    • Klicken Sie im Messagingport-Assistenten auf der Seite Zielanwendung auf Neuer XLANG-Ablaufplan.

    • Geben Sie im Feld Moniker für Ablaufplan den Moniker des angegebenen Ablaufplanes ein, oder klicken Sie auf Durchsuchen, um den Pfad festzulegen.

    • Geben Sie im Feld Portname den Namen des in diesem Ablaufplan vorgesehenen Ports ein, an den das Dokument gesendet wird.

      Weitere Informationen finden Sie unter Festlegen von Eigenschaften für die Zielanwendung.

      Um diesen Schritt abzuschließen, brauchen Sie den Pfad eines XLANG-Ablaufplanes und den Namen des Ports im Ablaufplan, an den die Ausgangsnachricht gesendet wird. Deshalb müssen Sie zunächst den XLANG-Ablaufplan erstellen und seinen Port konfigurieren, wie weiter unten in dieser Tabelle beschrieben.
  • Erstellen Sie einen Kanal von einer Organisation, um die Ausgangsnachricht vom Handelspartner zu verarbeiten.
  • Erstellen von Kanälen

    Anmerkung

    • Notieren Sie sich den Kanalnamen und den Namen der Dokumentendefinition für ausgehende Dokumente, die Sie verwenden. Mit diesen Namen werden die BizTalk-Orchestrierungsdienste konfiguriert.
  • Erstellen Sie einen Messagingport zu einer Organisation, um die Antwortnachricht zum Quellsystem zu transportieren.
  • Erstellen von Messagingports

    Anmerkungen

    • Klicken Sie im Messagingport-Assistenten auf der Seite Zielorganisation auf Organisation. Klicken Sie rechts vom Feld Name auf Durchsuchen.

    • Wählen Sie im Dialogfeld Organisation auswählen die Organisation aus, die Sie zuvor erstellt haben und die für den Handelspartner und das Quellsystem steht. Weitere Informationen finden Sie unter Auswählen einer Zielorganisation.

    • Klicken Sie im Messagingport-Assistenten auf der Seite Zielorganisation im Bereich Primärer Transport auf Durchsuchen.

    • Wählen Sie im Dialogfeld Primärer Transport aus der Liste Transporttyp den Transporttyp aus, und geben Sie im Feld Adresse eine Adresse ein.

      Der Transporttyp und die Adresse müssen mit dem Handelspartner abgestimmt werden und den Spezifikationen im Quellsystem Ihres Handelspartners entsprechen.

    • Sie können keinen offenen Messagingport zum Senden der Antwortnachricht verwenden.
  • Erstellen Sie einen Kanal von einer Anwendung, um die Antwortnachricht vom XLANG-Ablaufplan zu verarbeiten.
  • Erstellen von Kanälen

    Anmerkungen

    • Klicken Sie im Kanal-Assistenten auf der Seite Quellanwendung auf XLANG-Ablaufplan. Weitere Informationen finden Sie unter Festlegen von Eigenschaften für die Quellanwendung.

    • Notieren Sie sich den Kanalnamen und den Namen der Dokumentendefinition für eingehende Dokumente, die Sie verwenden. Diese Namen werden zum Konfigurieren der BizTalk-Orchestrierungsdienste verwendet.
Verwenden des BizTalk-Orchestrierungs-Designers:
  • Verwenden Sie eine BizTalk-Messaging-Form, um einen Port zum Empfangen der Antwortnachricht zu implementieren.
  • Implementieren eines Ports mithilfe von BizTalk Messaging

    Anmerkungen

    • Klicken Sie im BizTalk-Bindungs-Assistenten für Messaging auf der Seite Kommunikationsrichtung auf Empfangen.

    • Klicken Sie im BizTalk-Bindungs-Assistenten für Messaging auf der Seite Informationen über die XLANG-Ablaufplanaktivierung auf Ja.

    Wichtig

    • Wenn Sie auf Ja klicken, wird der Port so konfiguriert, dass eine neue Ablaufplaninstanz aktiviert wird, wenn eine Nachricht ankommt. Weitere wichtige Informationen zu dieser Option finden Sie in den Themen, auf die in Zusammenhang mit diesem Schritt verwiesen wird.

      Notieren Sie sich den Namen, den Sie diesem Port geben und den Speicherort, an dem Sie den kompilierten XLANG-Ablaufplan speichern. Sie brauchen diese Informationen, um einen Messagingport in den BizTalk-Messagingdiensten zu konfigurieren, wie weiter oben in dieser Tabelle beschrieben.
  • Richten Sie den Kommunikationsfluss zwischen einer Aktion-Form und dem Port ein, der die Anfangsnachricht empfängt.
  • Senden oder Empfangen asynchroner Nachrichten

    Anmerkung

    • Klicken Sie im Assistenten für XML-Kommunikation auf der Seite Nachrichteninformationen auf Neue Nachricht erstellen, und geben Sie im Feld Nachrichtenname einen Namen für die Nachricht ein.

      Sie können jeden Namen verwenden; jedoch wird durch das Verwenden des Namens der Dokumentdefinition für ausgehende Dokumente für den Kanal deutlicher, welche Nachricht Sie senden.

    • Geben Sie auf der Seite Informationen über den Nachrichtentyp im Feld Nachrichtentyp den Namen der Dokumentdefinition für ausgehende Dokumente für den Kanal ein, den Sie zur Verarbeitung der Antwortnachricht verwenden.

      Alle von BizTalk-Messaging an den XLANG-Ablaufplan weitergeleiteten Nachrichten verwenden eine Nachrichtenwarteschlange. Die Bezeichnung für diese Nachrichten ist der Name der Dokumentdefinition für ausgehende Dokumente des Kanals.

    • Klicken Sie auf der Seite Informationen über die Nachrichtenspezifikation auf Durchsuchen, und gehen Sie zu der Spezifikation, die Sie für die Definition ausgehender Dokumente des Kanals für die Ausgangsnachricht verwenden.

    • Klicken Sie im Bereich Nachrichtenfelder auf Hinzufügen, und fügen Sie das Feld in der Spezifikation hinzu, das erstellt wurde, um die Adresse des Warteschlangenpfades für die Ausgangsnachricht aufzunehmen.
  • Verwenden Sie eine BizTalk-Messaging-Form, um einen Port zum Senden der Antwortnachricht zu implementieren.
  • Implementieren eines Ports mithilfe von BizTalk Messaging

    Anmerkung

    • Klicken Sie im BizTalk-Bindungs-Assistenten für Messaging auf der Seite Informationen über statische oder dynamische Kanäle auf Statischer Kanal, und geben Sie im Feld Geben Sie den Namen eines bekannten, vorgegebenen Kanals ein den Namen des Kanals im BizTalk-Messaging-Manager ein, den Sie zum Verarbeiten der Antwortnachricht verwenden.

    • Da dieser Port einen statischen Kanal verwendet, erfolgt kein Zielversendungsaufruf an BizTalk-Messaging. Daher kann der angegebene Kanal keinem offenen Messagingport zugewiesen werden.
  • Richten Sie den Kommunikationsfluss zwischen einer Aktion-Form und dem Port ein, der die Antwortnachricht sendet.
  • Senden oder Empfangen asynchroner Nachrichten

    Anmerkungen

    • Klicken Sie im Assistenten für XML-Kommunikation auf der Seite Nachrichteninformationen auf Neue Nachricht erstellen, und geben Sie im Feld Nachrichtenname einen Namen für die Nachricht ein.

      Sie können jeden Namen verwenden; jedoch wird durch das Verwenden des Namens der Dokumentdefinition für eingehende Dokumente für den Kanal deutlicher, welche Nachricht Sie versenden.

    • Geben Sie auf der Seite Informationen über den Nachrichtentyp im Feld Nachrichtentyp den Namen der Dokumentdefinition für eingehende Dokumente für den Kanal ein, den Sie zur Verarbeitung der Nachricht verwenden.

    • Klicken Sie auf der Seite Informationen über die Nachrichtenspezifikation auf Durchsuchen, und gehen Sie zu der Spezifikation, die Sie für die Definition eingehender Dokumente des Kanals verwenden, mit dem Sie die Antwortnachricht verarbeiten.

    • Klicken Sie im Bereich Nachrichtenfelder auf Hinzufügen, und fügen Sie das Feld in der Spezifikation hinzu, das erstellt wurde, um die Adresse des Warteschlangenpfades für die Antwortnachricht aufzunehmen.
  • Richten Sie den Datenfluss vom Feld zur Angabe des Warteschlangenpfades in der Ausgangsnachricht zum Feld zur Angabe des Warteschlangenpfades in der Antwortnachricht ein.
  • Festlegen des Datenflusses zwischen Nachrichten

    Anmerkungen

    • Klicken Sie auf die Registerkarte Daten.

    • Klicken Sie auf der Datenseite im Feld zum Angeben des Warteschlangenpfades in der Ausgangsnachricht. Ziehen Sie dann das Kontrollhandle auf den Verbindungspunkt des Feldes zum Angeben des Warteschlangenpfades in der Antwortnachricht.

      Dadurch werden die Daten zum Warteschlangenpfad von der Ausgangsnachricht an die Antwortnachricht weitergeleitet.


BizTalk Server 2000 Interface Reference

You can programmatically integrate applications with Microsoft BizTalk Server 2000 by using the BizTalk Messaging Configuration object model, or by extending and customizing the functionality of the server to suit your business and information-exchange needs. The interface reference provides all the information necessary for programmers of the Microsoft Visual Basic and Visual C++ programming languages to use or extend BizTalk Server 2000. This section also includes a complete list of interfaces, objects, enumerations, code samples, and possible error messages.

BizTalk Server 2000 supports programmatic application integration by accessing the BizTalk Messaging Configuration object model and submitting documents by calling the methods of the IInterchange interface. BizTalk Server 2000 also supports the use of extensible application integration components (AICs), including a lightweight integration model and support for the pipeline-component model available in Microsoft Site Server, Commerce Edition 3.0.

The interface reference is divided into the following parts:

Using the BizTalk Messaging Configuration Object Model

This section provides information about how to access the BizTalk Messaging Configuration object model, including all the reference pages for the supported interfaces. This information is provided for both Microsoft Visual C++ and Visual Basic developers. For more information, see Using the BizTalk Messaging Configuration Object Model.

Submitting Documents

This section covers submitting documents to BizTalk Server 2000, using the synchronous and asynchronous methods of the IInterchange interface. It shows how to move a document once the trading partner relationships are set up, and how to track documents moving through BizTalk Server 2000. For more information, see Submitting Documents.

Creating Custom Components

This section covers BizTalk Server 2000 support for extensible application integration components (AICs), including a lightweight integration model and support for the pipeline-component model available in Microsoft Site Server, Commerce Edition 3.0.

This allows developers to do the following:

  • Enable business applications to receive business documents, using AICs.

  • Extend the functionality of BizTalk Server 2000 by developing components to perform digital signatures and verification, encryption and decryption, parsing, and transport.

For more information, see Creating Custom Components.

Administering XLANG Schedules

This section provides information about the interfaces that can be used to access a running instance of a specific XLANG schedule, or to perform system-wide administrative tasks in the XLANG Scheduler run-time environment. This information is provided for both Microsoft Visual C++ and Visual Basic developers. For more information, see Administering XLANG Schedules.


Using the BizTalk Messaging Configuration Object Model

This section provides information about how to use the BizTalk Messaging Configuration object model programmatically. For additional information, see the following sections:

  • For general background information, see Concepts.

  • For information about COM interfaces, enumerations, and error messages, see the Object Model Reference.

  • For examples of code, see BizTalk Messaging Services Code Samples.

The BizTalk Messaging Configuration object model can also be configured using the BizTalk Messaging Manager graphical user interface. For more information, see Using BizTalk Messaging Manager.


Object Model Reference

This section provides reference information about interfaces used by Microsoft BizTalk Server 2000 for both Microsoft Visual C++ and Visual Basic programming. Reference information is provided for all interfaces, objects, methods, properties, and enumerations exposed for accessing the BizTalk Messaging Configuration object model. In addition, a complete list of Error Messages is provided.

The following COM interfaces and enumerations are documented in this reference:

  • IBizTalkBase

  • IBizTalkCertificateInfo

  • IBizTalkChannel

  • IBizTalkConfig

  • IBizTalkDocument

  • IBizTalkEndPoint

  • IBizTalkEnvelope

  • IBizTalkLoggingInfo

  • IBizTalkOrganization

  • IBizTalkPort

  • IBizTalkPortGroup

  • IBizTalkServiceWindowInfo

  • IBizTalkTransportInfo

  • IDictionary

  • ISimpleList

  • Object Model Enumerations


IBizTalkBase Interface [C++]

IBizTalkBase Object [Visual Basic]

In C++, the IBizTalkBase interface defines common methods and properties that are inherited by the following objects. In Microsoft Visual Basic, the IBizTalkBase class defines common methods and properties that are implemented by the following objects.

  • BizTalkChannel

  • BizTalkDocument

  • BizTalkEnvelope

  • BizTalkOrganization

  • BizTalkPort

  • BizTalkPortGroup

Note

The methods and properties of this object are always invoked on the objects listed above, rather than by creating an actual BizTalkBase object.

The properties of the BizTalkBase object are shown in the following table.

Property | Type | Description
DateModified | BSTR | Date and time at which the information in the object was created or last modified. This is a read-only property.
Handle | long | Handle to the object. This is a read-only property.
Name | BSTR | Name of the object.

The methods of the BizTalkBase object are shown in the following table.

Method | Description
Clear | Clears the object in memory. All the member variables of the object in memory are initialized to their default values.
Create | Creates a new object in the database.
Load | Loads a specified object in memory.
LoadByName | Loads a specified object by name in memory.
Remove | Removes the object from the database.
Save | Saves the object in the database.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkBase::Clear Method [C++]

IBizTalkBase.Clear Method [Visual Basic]

The Clear method clears the object in memory. All member variables of the object in memory are initialized to their default values.

Syntax

[C++]

HRESULT Clear();

[Visual Basic]

object.Clear()

Parameters

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Applies To

This method is supported by the following objects:

  • BizTalkChannel

  • BizTalkDocument

  • BizTalkEnvelope

  • BizTalkOrganization

  • BizTalkPort

  • BizTalkPortGroup

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkBase::Create Method [C++]

IBizTalkBase.Create Method [Visual Basic]

The Create method creates a new object in the database.

Syntax

[C++]

HRESULT Create(
    long* plBiztalkObjectHandle
);

[Visual Basic]

object.Create()

Parameters

[C++]

plBiztalkObjectHandle

[out, retval] Pointer to a long that contains the handle to the object.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This method returns a Long that contains the handle to the object.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Applies To

This method is supported by the following objects:

  • BizTalkChannel

  • BizTalkDocument

  • BizTalkEnvelope

  • BizTalkOrganization

  • BizTalkPort

  • BizTalkPortGroup

Remarks

The Name property must be set before calling this method. Name must be unique across the database for each object type. Create updates the DateModified property.

When creating any object that refers to an XML document specification or map located outside your local domain, you might receive an error. If an error occurs, download and configure the WinHTTP proxy utility. To download this utility, go to the Microsoft MSDN Web site at msdn.microsoft.com/downloads/default.asp, and browse to the WinHTTP Proxy Configuration Utility page, which is located in the XML chapter of the Web Development book.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkBase::DateModified Property [C++]

IBizTalkBase.DateModified Property [Visual Basic]

The DateModified property contains the date and time at which the information in the object was created or last modified.

Syntax

[C++]

Get method:

HRESULT get_DateModified(
    BSTR* pstrModified
);

[Visual Basic]

object.DateModified

Parameters

[C++]

pstrModified

[out, retval] Pointer to a BSTR that contains the date modified.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a String that contains the date modified.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Applies To

This property is supported by the following objects:

  • BizTalkChannel

  • BizTalkDocument

  • BizTalkEnvelope

  • BizTalkOrganization

  • BizTalkPort

  • BizTalkPortGroup

Remarks

This is a read-only property. The format for the strModified string is yyyy-mm-dd hh:mm:ss. The time is in coordinated universal time (UTC). The server sets this property when the Create or the Save method is called for the object.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkBase::Handle Property [C++]

IBizTalkBase.Handle Property [Visual Basic]

The Handle property contains the handle to the object.

Syntax

[C++]

Get method:

HRESULT get_Handle(
    long* plBiztalkObjectHandle
);

[Visual Basic]

object.Handle

Parameters

[C++]

plBiztalkObjectHandle

[out, retval] Pointer to a long that contains the handle to the object.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a Long that contains the handle to the object.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Applies To

This property is supported by the following objects:

  • BizTalkChannel

  • BizTalkDocument

  • BizTalkEnvelope

  • BizTalkOrganization

  • BizTalkPort

  • BizTalkPortGroup

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkBase::Load Method [C++]

IBizTalkBase.Load Method [Visual Basic]

The Load method loads an object in memory.

Syntax

[C++]

HRESULT Load(
    long lBiztalkObjectHandle
);

[Visual Basic]

object.Load(lBiztalkObjectHandle As Long)

Parameters

[C++]

lBiztalkObjectHandle

[in] Long that contains the handle to the object to load.

[Visual Basic]

lBiztalkObjectHandle

Long that contains the handle to the object to load.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Applies To

This method is supported by the following objects:

  • BizTalkChannel

  • BizTalkDocument

  • BizTalkEnvelope

  • BizTalkOrganization

  • BizTalkPort

  • BizTalkPortGroup

Remarks

Load calls the Clear method internally before loading the object.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkBase::LoadByName Method [C++]

IBizTalkBase.LoadByName Method [Visual Basic]

The LoadByName method loads an object by name in memory.

Syntax

[C++]

HRESULT LoadByName(
    BSTR strName
);

[Visual Basic]

object.LoadByName(strName As String)

Parameters

[C++]

strName

[in] BSTR that contains the name.

[Visual Basic]

strName

String that contains the name.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Applies To

This method is supported by the following objects:

  • BizTalkChannel

  • BizTalkDocument

  • BizTalkEnvelope

  • BizTalkOrganization

  • BizTalkPort

  • BizTalkPortGroup

Remarks

LoadByName calls the Clear method internally before loading the object.

Names have a maximum length of 64 characters.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkBase::Name Property [C++]

IBizTalkBase.Name Property [Visual Basic]

The Name property contains the name of the object.

Syntax

[C++]

Get method:

HRESULT get_Name(
    BSTR* pstrName
);

Put method:

HRESULT put_Name(
    BSTR strName
);

[Visual Basic]

object.Name

Parameters

[C++]

Get method:

pstrName

[out, retval] Pointer to a BSTR that contains the name of the object.

Put method:

strName

[in] BSTR that contains the name of the object.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a String that contains the name.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Applies To

This property is supported by the following objects:

  • BizTalkChannel

  • BizTalkDocument

  • BizTalkEnvelope

  • BizTalkOrganization

  • BizTalkPort

  • BizTalkPortGroup

Remarks

The server requires the Name property. It must be set before calling the Create or the Save method for the object. Name must be unique across a database for each object type and must be at least one character long. Names have a maximum length of 64 characters.

The following table lists names reserved for use by BizTalk Server:

Name | Object type
Reliable Message Acknowledgement Port | IBizTalkPort
Reliable Message Acknowledgement Channel | IBizTalkChannel
BizTalk Canonical Receipt | IBizTalkDocument
Reliable Messaging Acknowledgement | IBizTalkDocument
Reliable Messaging Acknowledgement SMTP From Address | IBizTalkOrganization alias
Home Organization | IBizTalkOrganization

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkBase::Remove Method [C++]

IBizTalkBase.Remove Method [Visual Basic]

The Remove method removes the object from the database.

Syntax

[C++]

HRESULT Remove();

[Visual Basic]

object.Remove()

Parameters

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Applies To

This method is supported by the following objects:

  • BizTalkChannel

  • BizTalkDocument

  • BizTalkEnvelope

  • BizTalkOrganization

  • BizTalkPort

  • BizTalkPortGroup

Remarks

The object cannot be removed if any other object refers to it.

A BizTalkOrganization object cannot be removed if it is the default organization. Before it can be removed, the IsDefault property must be set to False, and another organization must have the IsDefault property set to True.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topic

Referential Integrity


IBizTalkBase::Save Method [C++]

IBizTalkBase.Save Method [Visual Basic]

The Save method saves the object in the database.

Syntax

[C++]

HRESULT Save();

[Visual Basic]

object.Save()

Parameters

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Applies To

This method is supported by the following objects:

  • BizTalkChannel

  • BizTalkDocument

  • BizTalkEnvelope

  • BizTalkOrganization

  • BizTalkPort

  • BizTalkPortGroup

Remarks

The Save method updates the DateModified property.

When saving any object that refers to an XML document specification or map located outside your local domain, you might receive an error. If an error occurs, download and configure the WinHTTP proxy utility. To download this utility, go to the Microsoft MSDN Web site at msdn.microsoft.com/downloads/default.asp, and browse to the WinHTTP Proxy Configuration Utility page, which is located in the XML chapter of the Web Development book.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkCertificateInfo Interface [C++]

BizTalkCertificateInfo Object [Visual Basic]

Use this object to configure a certificate associated with a BizTalkPort or a BizTalkChannel object.

In C++, use the IBizTalkCertificateInfo interface to access the methods of the BizTalkCertificateInfo object.

The properties of the BizTalkCertificateInfo object are shown in the following table.

Property | Type | Description
Name | BSTR | Name of the certificate. This is a read-only property.
Reference | BSTR | Reference to the certificate in the certificate store.
Store | BIZTALK_ STORE_ TYPE | Store type of the certificate.
Usage | BIZTALK_USAGE_ TYPE | Type of use for the certificate. This is a read-only property.

Remarks

This object is automatically created when a BizTalkPort or a BizTalkChannel object is instantiated with the CreatePort or the CreateChannel method of the BizTalkConfig object.

For output documents, access the BizTalkCertificateInfo object by using the EncryptionCertificateInfo property of the BizTalkPort object. For input documents, access the BizTalkCertificateInfo object by using the SignatureCertificateInfo, VerifySignatureCertificateInfo, or DecryptionCertificateInfo property of the BizTalkChannel object. To obtain the set of all existing BizTalkCertificateInfo objects, use the Certificates property of the BizTalkConfig object.

Note

  • All certificates are stored in the local computer store. To configure certificates for the S/MIME components, the script or application accessing the object model must be run in the context of a user account in the BizTalk Server Administrators group.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkCertificateInfo::Name Property [C++]

BizTalkCertificateInfo.Name Property [Visual Basic]

The Name property contains the name of the certificate.

Syntax

[C++]

Get method:

HRESULT get_Name(
    BSTR* pstrName
);

[Visual Basic]

object.Name

Parameters

[C++]

pstrName

[out, retval] Pointer to a BSTR that contains the name.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a String that contains the name.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkCertificateInfo::Reference Property [C++]

BizTalkCertificateInfo.Reference Property [Visual Basic]

The Reference property contains a reference to the certificate in the certificate store.

Syntax

[C++]

Get method:

HRESULT get_Reference(
    BSTR* pstrReference
);

Put method:

HRESULT put_Reference(
    BSTR strReference
);

[Visual Basic]

object.Reference

Parameters

[C++]

Get method:

pstrReference

[out, retval] Pointer to a BSTR that contains the certificate reference.

Put method:

strReference

[in] BSTR that contains the certificate reference.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

Note

  • In addition to the HRESULT values listed on the error messages page, the put method returns CryptoAPI errors. Additional information about CryptoAPI is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.
[Visual Basic]

This property returns a String that contains the certificate reference.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

A reference to a certificate should be obtained by using the Certificates property on the BizTalkConfig object.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkCertificateInfo::Store Property [C++]

BizTalkCertificateInfo.Store Property [Visual Basic]

The Store property contains the store type for the certificate.

Syntax

[C++]

Get method:

HRESULT get_Store(
    BIZTALK_STORE_TYPE* pStoreType
);

Put method:

HRESULT put_Store(
    BIZTALK_STORE_TYPE eStoreType
);

[Visual Basic]

object.Store

Parameters

[C++]

Get method:

pStoreType

[out, retval] Pointer to an enumeration value that contains the certificate store type. Valid values are from the BIZTALK_STORE_TYPE enumeration.

Put method:

eStoreType

[in] Enumeration value that contains the certificate store type. Valid values are from the BIZTALK_STORE_TYPE enumeration.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns an enumeration value. Valid values are from the BIZTALK_STORE_TYPE enumeration.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

The store, which contains the certificate, is determined by the use of the certificate as follows:

Certificate type | Store
Decryption | MY
Encryption | BIZTALK
Signature | MY
Verify signature | BIZTALK

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkCertificateInfo::Usage Property [C++]

BizTalkCertificateInfo.Usage Property [Visual Basic]

The Usage property contains the type of use for the certificate.

Syntax

[C++]

Get method:

HRESULT get_Usage(
    BIZTALK_USAGE_TYPE* pUsageType
);

[Visual Basic]

object.Usage

Parameters

[C++]

pUsageType

[out, retval] Pointer to an enumeration value. Valid values are from the BIZTALK_USAGE_TYPE enumeration.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns an enumeration value. Valid values are from the BIZTALK_USAGE_TYPE enumeration.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkChannel Interface [C++]

BizTalkChannel Object [Visual Basic]

Use the methods and properties of the BizTalkChannel object to configure a channel for processing documents.

In C++, use the IBizTalkChannel interface to access the methods of the BizTalkChannel object.

The properties of the BizTalkChannel object are shown in the following table.

Property | Type | Description
Comments | BSTR | User comments for the object.
ControlNumberValue | BSTR | Value of the group control number.
DateModified | BSTR | Date and time at which the information in the object was created or last modified. This is a read-only property obtained from the BizTalkBase object.
DecryptionCertificateInfo | IDispatch | Information about the certificate that decrypts the input document.
ExpectReceiptTimeout | long | Time, in minutes, in which to expect the receipt for the current document before treating the document as expired.
Expression | BSTR | Complete set of equations that filter the selection of the object.
Handle | long | Identifier of the object. This is a read-only property obtained from the BizTalkBase object.
InputDocument | long | Handle to the input BizTalkDocument object. This is a required property.
IsReceiptChannel | VARIANT_BOOL | Flag that indicates whether the object is a receipt channel.
LoggingInfo | IDispatch | Information about logging.
MapContent | BSTR | Contents of the map that provide instructions on how the input document in the format used by the source organization is to be rendered in the format used by the destination organization, if different. This is a read-only property.
MapReference | BSTR | Full Web Distributed Authoring and Versioning (WebDAV) URL of the map that provides instructions on how the input document in the format used by the source organization is to be rendered in the format used by the destination organization, if different. This is a required property if the InputDocument property is different from the OutputDocument property.
Name | BSTR | Name of the object. This is a required property obtained from the BizTalkBase object.
OutputDocument | long | Handle to the output BizTalkDocument object. This is a required property.
Port | long | Associated BizTalkPort object. Either the Port or the PortGroup property must be specified.
PortGroup | long | Associated BizTalkPortGroup object. Either the Port or the PortGroup property must be specified.
ReceiptChannel | long | Handle to the receipt channel for this object.
RetryCount | long | Number of times to retry submitting a document when there is a failure to connect to the destination.
RetryInterval | long | Interval between attempts to resubmit a document when there is a failure to connect to the destination. This value is specified in minutes.
SignatureCertificateInfo | IDispatch | Information about the certificate that signs the output document.
SourceEndpoint | IDispatch | Information about the source.
TrackFields | IDispatch | Dictionary object that stores additional custom tracking fields used to track interchange data for the BizTalkDocument object for the associated BizTalkChannel object.
VerifySignatureCertificateInfo | IDispatch | Information about the certificate that verifies the signature of the input document.

The methods of the BizTalkChannel object are shown in the following table.

Method | Description
Clear | Clears the object in memory. All member variables of the object in memory are initialized to their default values. This method is obtained from the BizTalkBase object.
Create | Creates a new object in the database. This method is obtained from the BizTalkBase object.
GetConfigComponent | Reads the CLSID of the component associated with the BizTalkPort object.
GetConfigData | Gets the configuration associated with the specified BizTalkPort object.
Load | Loads an object in memory. This method is obtained from the BizTalkBase object.
LoadByName | Loads an object by name in memory. This method is obtained from the BizTalkBase object.
Remove | Removes the object. This method is obtained from the BizTalkBase object.
Save | Saves the object to the database. This method is obtained from the BizTalkBase object.
SetConfigComponent | Sets the CLSID of the component associated with the BizTalkPort object.
SetConfigData | Sets the configuration information for the associated BizTalkPort object.

Remarks

A BizTalkChannel object requires an associated complete BizTalkPort object. One or more BizTalkChannel objects can be associated with a BizTalkPort object. A BizTalkChannel object can be associated with only one input BizTalkDocument object and one output BizTalkDocument object; however, a BizTalkDocument object can be associated with more than one BizTalkChannel object.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Channels

Document Processing


IBizTalkChannel::Comments Property [C++]

BizTalkChannel.Comments Property [Visual Basic]

The Comments property contains the user comments for the object.

Syntax

[C++]

Get method:

HRESULT get_Comments(
    BSTR* pstrComments
);

Put method:

HRESULT put_Comments(
    BSTR strComments
);

[Visual Basic]

object.Comments

Parameters

[C++]

Get method:

pstrComments

[out, retval] Pointer to a BSTR that contains the comments.

Put method:

strComments

[in] BSTR that contains the comments.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a String that contains the comments.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkChannel::ControlNumberValue Property [C++]

BizTalkChannel.ControlNumberValue Property [Visual Basic]

The ControlNumberValue property contains the value of the group control number.

Syntax

[C++]

Get method:

HRESULT get_ControlNumberValue(
    BSTR* pstrControlNumberValue
);

Put method:

HRESULT put_ControlNumberValue(
    BSTR strControlNumberValue
);

[Visual Basic]

object.ControlNumberValue

Parameters

[C++]

Get method:

pstrControlNumberValue

[out, retval] Pointer to a BSTR that contains the control number.

Put method:

strControlNumberValue

[in] BSTR that contains the control number.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This method returns a String that contains the control number.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

The ControlNumberValue property must contain a value between 1 and 999999999.

If the Format property of the BizTalkEnvelope object for the associated BizTalkPort object is set to X12, EDIFACT, or Custom, this property is required.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkChannel::DecryptionCertificateInfo Property [C++]

BizTalkChannel.DecryptionCertificateInfo Property [Visual Basic]

The DecryptionCertificateInfo property contains information about the certificate that decrypts the input document. This information includes the Name, Reference, Store, and Usage properties and is created and stored in memory in the BizTalkCertificateInfo object.

Syntax

[C++]

Get method:

HRESULT get_DecryptionCertificateInfo(
    IDispatch** ppDecryptionCertificateInfoDisp
);

Putref method:

HRESULT putref_DecryptionCertificateInfo(
    IDispatch* pDecryptionCertificateInfoDisp
);

[Visual Basic]

object.DecryptionCertificateInfo

Parameters

[C++]

Get method:

ppDecryptionCertificateInfoDisp

[out, retval] Address of a pointer to an IDispatch interface that contains the certificate information.

Putref method:

pDecryptionCertificateInfoDisp

[in] Pointer to an IDispatch interface that contains the certificate information.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns an Object that contains the certificate information.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkChannel::ExpectReceiptTimeout Property [C++]

BizTalkChannel.ExpectReceiptTimeout Property [Visual Basic]

The ExpectReceiptTimeout property contains the value of the time, in minutes, in which to expect the receipt for the current document before treating the document as expired.

Syntax

[C++]

Get method:

HRESULT get_ExpectReceiptTimeout(
    long* plMinutes
);

Put method:

HRESULT put_ExpectReceiptTimeout(
    long lMinutes
);

[Visual Basic]

object.ExpectReceiptTimeout

Parameters

[C++]

Get method:

plMinutes

[out, retval] Pointer to a long that contains the minutes.

Put method:

lMinutes

[in] Long that contains the minutes.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a Long that contains the minutes.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkChannel::Expression Property [C++]

BizTalkChannel.Expression Property [Visual Basic]

The Expression property contains an expression that filters the selection of the BizTalkChannel object. If the expression evaluates to true, the server selects the channel for processing the document.

Syntax

[C++]

Get method:

HRESULT get_Expression(
    BSTR* pstrExpression
);

Put method:

HRESULT put_Expression(
    BSTR strExpression
);

[Visual Basic]

object.Expression

Parameters

[C++]

Get method:

pstrExpression

[out, retval] Pointer to a BSTR that contains the XPath expression.

Put method:

strExpression

[in] BSTR that contains the XPath expression.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This method returns a String that contains the expression.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

The XPath expression must be based on the input document specification set in the InputDocument property.

Note

  • If the specification field that you are using to create an expression has a Boolean data type, you cannot use the text strings "true" or "false" as the expression value. You must use a numerical value instead: "-1" for true and "0" for false. For example, to filter a channel so it processes only approved purchase orders, your expression might look like this:
    Channel1.Expression = "/PORequest/Total[IsApproved = -1]"

    This sample assumes that the input document specification contains a Total subelement with a Boolean IsApproved field.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topic

Channel Filtering


IBizTalkChannel::GetConfigComponent Method [C++]

BizTalkChannel.GetConfigComponent Method [Visual Basic]

The GetConfigComponent method retrieves the CLSID of the component associated with the BizTalkPort object.

Syntax

[C++]

HRESULT GetConfigComponent(
    BIZTALK_CONFIGDATA_TYPE eConfigType,
    long lPortHandle,
    BSTR* pstrCLSID
);

[Visual Basic]

object.GetConfigComponent( _
    eConfigType As BIZTALK_CONFIGDATA_TYPE, _
    lPortHandle As Long _
)

Parameters

[C++]

eConfigType

[in] Enumeration value. Valid values are from the BIZTALK_CONFIGDATA_TYPE enumeration.

lPortHandle

[in] Long that contains the handle to the BizTalkPort object.

pstrCLSID

[out, retval] Pointer to a BSTR that contains the CLSID of the component.

[Visual Basic]

eConfigType

Enumeration value. Valid values are from the BIZTALK_CONFIGDATA_TYPE enumeration.

lPortHandle

Long that contains the handle.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

Note

In addition to the HRESULT values listed on the error messages page, this method returns OLEDB provider errors. Additional information about OLEDB is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

[Visual Basic]

This method returns a String that contains the CLSID of the component.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

If the eConfigType parameter is set to BIZTALK_CONFIGDATA_TYPE_SIGNATURE and the associated BizTalkPort object has both the EncryptionType and SignatureType properties set to S/MIME, this method returns an empty string ("").

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkChannel::GetConfigData Method [C++]

BizTalkChannel.GetConfigData Method [Visual Basic]

The GetConfigData method gets the configuration associated with the specified BizTalkPort object.

Syntax

[C++]

HRESULT GetConfigData(
    BIZTALK_CONFIGDATA_TYPE eConfigType,
    long lPortHandle,
    VARIANT* pvarType,
    VARIANT* pvarDictionary
);

[Visual Basic]

object.GetConfigData( _
    eConfigType As BIZTALK_CONFIGDATA_TYPE, _
    lPortHandle As Long, _
    pvarType As Variant _
)

Parameters

[C++]

eConfigType

[in] Enumeration value. Valid values are from the BIZTALK_CONFIGDATA_TYPE enumeration.

lPortHandle

[in] Long that identifies the handle to the associated BizTalkPort object.

pvarType

[in, out] Pointer to a VARIANT that contains the transport type.

pvarDictionary

[in, out] Pointer to a VARIANT that contains a pointer to the IDictionary interface of an object that contains the primary transport configuration information.

[Visual Basic]

eConfigType

[in] Enumeration value. Valid values are from the BIZTALK_CONFIGDATA_TYPE enumeration.

lPortHandle

Long that identifies the handle to the associated BizTalkPort object.

pvarType

Variant that contains the transport type.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

Note

In addition to the HRESULT values listed on the error messages page, this method returns OLEDB provider errors. Additional information about OLEDB is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

[Visual Basic]

This method returns a CDictionary object that contains the primary transport configuration information.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

The Dictionary object returned by this method has specific string qualifiers used for EDIFACT and X12. The following tables describe these strings.

EDIFACT

Qualifier string | Description
SerializerEdifact_SenderIntID | Interchange sender internal identification
SerializerEdifact_SenderIntSubID | Interchange sender internal subidentification
SerializerEdifact_RecipientIntID | Interchange recipient internal identification
SerializerEdifact_RecipientIntSubID | Interchange recipient internal subidentification
SerializerEdifact_RecipientRefPwd | Recipient reference/password
SerializerEdifact_RecipientRefPwdQual | Recipient reference/password qualifier
SerializerEdifact_ApplicationRef | Application reference
SerializerEdifact_ProcPriCode | Processing priority code
SerializerEdifact_AckRequest | Acknowledgment request
SerializerEdifact_AgreementID | Interchange agreement identifier
SerializerEdifact_TestInd | Test indicator
SerializerEdifact_UNACtrl | "Send UNA Always" or "Send UNA Only When Required"
SerializerEdifact_SyntaxID | Syntax identifier

X12

Qualifier string | Description
SerializerX12_AuthInfoQual | Authorization information qualifier
SerializerX12_AuthInfo | Authorization information
SerializerX12_SecInfoQual | Security information qualifier
SerializerX12_SecInfo | Security information
SerializerX12_CtrlStdID | Interchange control standards identifier
SerializerX12_CtrlVerNum | Interchange control version number
SerializerX12_AckRequired | Acknowledgment required
SerializerX12_UseInd | Usage indicator

Note

  • For more information about the EDIFACT standard, see the United Nations Economic Commission for Europe Web site (www.unece.org).

  • For more information about the X12 standard, see the Data Interchange Standards Association Web site (www.disa.org).

If you override the transport properties of a BizTalkPort object with this method and then change the transport properties in that BizTalkPort object, you must call this method again.

If the eConfigType parameter is set to BIZTALK_CONFIGDATA_TYPE_SIGNATURE and the associated BizTalkPort object has both the EncryptionType and SignatureType properties set to S/MIME, this method returns an empty Dictionary object.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkChannel::InputDocument Property [C++]

BizTalkChannel.InputDocument Property [Visual Basic]

The InputDocument property contains the handle to the BizTalkDocument object that describes the input document specification.

Syntax

[C++]

Get method:

HRESULT get_InputDocument(
    long* plInDocHandle
);

Put method:

HRESULT put_InputDocument(
    long lInDocHandle
);

[Visual Basic]

object.InputDocument

Parameters

[C++]

Get method:

plInDocHandle

[out, retval] Pointer to a long that contains the handle to the input BizTalkDocument object.

Put method:

lInDocHandle

[in] Long that contains the handle to the input BizTalkDocument object.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a Long that contains the handle to the input BizTalkDocument object.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a required property.

This property cannot be changed after the Create or the Save method is called.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Configuring

Document Definitions

Document Processing


IBizTalkChannel::IsReceiptChannel Property [C++]

BizTalkChannel.IsReceiptChannel Property [Visual Basic]

The IsReceiptChannel property contains a flag that indicates whether the object is a receipt channel.

Syntax

[C++]

Get method:

HRESULT get_IsReceiptChannel(
    VARIANT_BOOL* pbIsReceiptChannel
);

Put method:

HRESULT put_IsReceiptChannel(
    VARIANT_BOOL bIsReceiptChannel
);

[Visual Basic]

object.IsReceiptChannel

Parameters

[C++]

Get method:

pbIsReceiptChannel

[out, retval] Pointer to a VARIANT_BOOL that contains the flag. A value of VARIANT_TRUE indicates that this channel is used as a receipt channel. A value of VARIANT_FALSE indicates that this channel is not used as a receipt channel.

Put method:

bIsReceiptChannel

[in] VARIANT_BOOL that contains the flag. A value of VARIANT_TRUE indicates that this channel is used as a receipt channel. A value of VARIANT_FALSE indicates that this channel is not used as a receipt channel.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a Variant that indicates whether the channel is used as a receipt channel.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topic

ReceiptChannel


IBizTalkChannel::LoggingInfo Property [C++]

BizTalkChannel.LoggingInfo Property [Visual Basic]

The LoggingInfo property contains information about logging the document. This information includes the LogNativeInputDocument, LogNativeOutputDocument, LogXMLInputDocument, and LogXMLOutputDocument properties and is created and stored in memory in the BizTalkLoggingInfo object.

Syntax

[C++]

Get method:

HRESULT get_LoggingInfo(
    IDispatch** ppLoggingInfoDisp
);

Putref method:

HRESULT putref_LoggingInfo(
    IDispatch* pLoggingInfoDisp
);

[Visual Basic]

object.LoggingInfo

Parameters

[C++]

Get method:

ppLoggingInfoDisp

[out, retval] Address of a pointer to an IDispatch interface that contains the logging fields.

Putref method:

pLoggingInfoDisp

[in] Pointer to an IDispatch interface that contains the logging fields.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns an Object that contains the logging fields.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topic

Document Storage


IBizTalkChannel::MapContent Property [C++]

BizTalkChannel.MapContent Property [Visual Basic]

The MapContent property contains the contents of the map that provide instructions on how the input document in the format used by the source organization is to be rendered in the format used by the destination organization, if different.

Syntax

[C++]

Get method:

HRESULT get_MapContent(
    BSTR* pstrMapContent
);

[Visual Basic]

object.MapContent

Parameters

[C++]

pstrMapContent

[in] BSTR that contains the map contents.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a String that contains the map contents.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property. The Create and Save methods copy the text of the map specified by the MapReference property to this string, if empty.

Once you have created or saved a BizTalkChannel object with MapReference set to a map, any changes you make to the content of the referenced map are not automatically updated on the referring BizTalkChannel object. To update the BizTalkChannel object that refers to the revised map, you must save the map, reset the MapReference property of the BizTalkChannel object to its current value, and then call Save on the referring BizTalkChannel object.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkChannel::MapReference Property [C++]

BizTalkChannel.MapReference Property [Visual Basic]

The MapReference property contains the full Web Distributed Authoring and Versioning (WebDAV) URL of the map that provides instructions on how the input document in the format used by the source organization is to be rendered in the format used by the destination organization, if different.

Syntax

[C++]

Get method:

HRESULT get_MapReference(
    BSTR* pstrReference
);

Put method:

HRESULT put_MapReference(
    BSTR strReference
);

[Visual Basic]

object.MapReference

Parameters

[C++]

Get method:

pstrReference

[out, retval] Pointer to a BSTR that contains the map name.

Put method:

strReference

[in] BSTR that contains the map name.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a String that contains the map name.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a required property if the InputDocument property refers to a different document specification than the OutputDocument property.

Once you have created or saved a BizTalkChannel object with MapReference set to a map, any changes you make to the content of the referenced map are not automatically updated on the referring BizTalkChannel object. To update the BizTalkChannel object that refers to the revised map, you must save the map, reset the MapReference property of the BizTalkChannel object to its current value, and then call Save on the referring BizTalkChannel object.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkChannel::OutputDocument Property [C++]

BizTalkChannel.OutputDocument Property [Visual Basic]

The OutputDocument property contains the handle to the BizTalkDocument object that describes the output document specification.

Syntax

[C++]

Get method:

HRESULT get_OutputDocument(
    long* plOutDocHandle
);

Put method:

HRESULT put_OutputDocument(
    long lOutDocHandle
);

[Visual Basic]

object.OutputDocument

Parameters

[C++]

Get method:

plOutDocHandle

[out, retval] Pointer to a long that contains the handle to the output BizTalkDocument object.

Put method:

lOutDocHandle

[in] Long that contains the handle to the output BizTalkDocument object.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a Long that contains the handle to the output BizTalkDocument object.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a required property. This property cannot be changed after the Create or the Save method is called.

If the Openness property of the associated BizTalkEndPoint object is set to BIZTALK_OPENNESS_TYPE_SOURCE, the InputDocument property can identify an input BizTalkDocument object that has an X12 or an EDIFACT specification. If it does, however, OutputDocument must not identify a BizTalkDocument object that has an X12 or an EDIFACT specification.

If the Openness property of the associated BizTalkEndPoint object is set to BIZTALK_OPENNESS_TYPE_DESTINATION, the OutputDocument property for this BizTalkChannel object must not identify an output BizTalkDocument object that has an X12 or an EDIFACT specification.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topic

Document Definitions


IBizTalkChannel::Port Property [C++]

BizTalkChannel.Port Property [Visual Basic]

The Port property contains the handle to the associated BizTalkPort object.

Syntax

[C++]

Get method:

HRESULT get_Port(
    long* plPortHandle
);

Put method:

HRESULT put_Port(
    long lPortHandle
);

[Visual Basic]

object.Port

Parameters

[C++]

Get method:

plPortHandle

[out, retval] Pointer to a long that contains the handle to the BizTalkPort object.

Put method:

lPortHandle

[in] Long that contains the handle to the BizTalkPort object.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a Long that contains the handle to the BizTalkPort object.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

The following constraints are enforced:

  • Either the Port or the PortGroup property must be specified for a channel.

  • This property cannot be changed after the Create or the Save method is called.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topic

Messaging Ports


IBizTalkChannel::PortGroup Property [C++]

BizTalkChannel.PortGroup Property [Visual Basic]

The PortGroup property contains the handle to the associated BizTalkPortGroup object.

Syntax

[C++]

Get method:

HRESULT get_PortGroup(
    long* plPortGroupHandle
);

Put method:

HRESULT put_PortGroup(
    long lPortGroupHandle
);

[Visual Basic]

object.PortGroup

Parameters

[C++]

Get method:

plPortGroupHandle

[out, retval] Pointer to a long that contains the handle to the associated BizTalkPortGroup object.

Put method:

lPortGroupHandle

[in] Long that contains the handle to the associated BizTalkPortGroup object.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a Long that contains the handle to the associated BizTalkPortGroup object.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

The following constraints are enforced:

  • Either the Port property or PortGroup must be specified for a channel.

  • This property cannot be changed after the Create or the Save method is called.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topic

Port Groups


IBizTalkChannel::ReceiptChannel Property [C++]

BizTalkChannel.ReceiptChannel Property [Visual Basic]

The ReceiptChannel property contains the handle to the receipt channel for this object.

Syntax

[C++]

Get method:

HRESULT get_ReceiptChannel(
    long* plReceiptChannelHandle
);

Put method:

HRESULT put_ReceiptChannel(
    long lReceiptChannelHandle
);

[Visual Basic]

object.ReceiptChannel

Parameters

[C++]

Get method:

plReceiptChannelHandle

[out, retval] Pointer to a long that contains the handle.

Put method:

lReceiptChannelHandle

[in] Long that contains the handle.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a Long that contains the handle to the receipt channel.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

A BizTalkChannel object can specify a receipt channel only if it is not a receipt channel itself. The channel specified as the receipt channel must have the IsReceiptChannel property set to TRUE. In addition, the receipt channel must use a messaging port with a DestinationEndpoint that is the same as the SourceEndpoint on the channel using the receipt channel. This allows the receipt channel to send a receipt to the original source of the document.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkChannel::RetryCount Property [C++]

BizTalkChannel.RetryCount Property [Visual Basic]

The RetryCount property specifies the number of times to retry submitting a document when a destination connection failure occurs.

Syntax

[C++]

Get method:

HRESULT get_RetryCount(
    long* plCount
);

Put method:

HRESULT put_RetryCount(
    long lCount
);

[Visual Basic]

object.RetryCount

Parameters

[C++]

Get method:

plCount

[out, retval] Pointer to a long that contains the number of retries.

Put method:

lCount

[in] Long that contains the number of retries.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a Long that contains the number of retries.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

The RetryCount property must contain a value between 0 and 999. The default value is 3 retries.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkChannel::RetryInterval Property [C++]

BizTalkChannel.RetryInterval Property [Visual Basic]

The RetryInterval property specifies the amount of time, in minutes, between retry attempts when a destination connection failure occurs during document submission.

Syntax

[C++]

Get method:

HRESULT get_RetryInterval(
    long* pInterval
);

Put method:

HRESULT put_RetryInterval(
    long lInterval
);

[Visual Basic]

object.RetryInterval

Parameters

[C++]

Get method:

pInterval

[out, retval] Pointer to a long that contains the retry interval, in minutes.

Put method:

lInterval

[in] Long that contains the retry interval, in minutes.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a Long that contains the retry interval, in minutes.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

The RetryInterval property must contain a value between 1 and 63999. The default value is 5 minutes.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkChannel::SetConfigComponent Method [C++]

BizTalkChannel.SetConfigComponent Method [Visual Basic]

The SetConfigComponent method sets the CLSID of the component associated with the BizTalkPort object.

Syntax

[C++]

HRESULT SetConfigComponent(
    BIZTALK_CONFIGDATA_TYPE eConfigType,
    long lPortHandle,
    BSTR strCLSID
);

[Visual Basic]

object.SetConfigComponent( _
    eConfigType As BIZTALK_CONFIGDATA_TYPE, _
    lPortHandle As Long, _
    strCLSID As String _
)

Parameters

[C++]

eConfigType

[in] Enumeration value. Valid values are from the BIZTALK_CONFIGDATA_TYPE enumeration. The BIZTALK_CONFIGDATA_TYPE_PRIMARYTRANSPORT and BIZTALK_CONFIGDATA_TYPE_SECONDARYTRANSPORT enumeration values cannot be used with this method.

lPortHandle

[in] Long that contains the handle.

strCLSID

[in] BSTR that contains the CLSID of the component.

[Visual Basic]

eConfigType

Enumeration value. Valid values are from the BIZTALK_CONFIGDATA_TYPE enumeration. The BIZTALK_CONFIGDATA_TYPE_PRIMARYTRANSPORT and BIZTALK_CONFIGDATA_TYPE_SECONDARYTRANSPORT enumeration values cannot be used with this method.

lPortHandle

Long that contains the handle.

strCLSID

String that contains the CLSID of the component.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkChannel::SetConfigData Method [C++]

BizTalkChannel.SetConfigData Method [Visual Basic]

The SetConfigData method sets the configuration information for the BizTalkPort object.

Syntax

[C++]

HRESULT SetConfigData(

    BIZTALK_CONFIGDATA_TYPE eConfigType,
    long lConfigDataHandle,
    IDispatch* pConfigDataDisp
);

[Visual Basic]

object.SetConfigData( _

    eConfigType As BIZTALK_CONFIGDATA_TYPE, _
    lConfigDataHandle As Long, _
    pConfigDataDisp As Object _
)

Parameters

[C++]

eConfigType

[in] Enumeration value. Valid values are from the BIZTALK_CONFIGDATA_TYPE enumeration.

lConfigDataHandle

[in] Long that identifies the handle to the associated BizTalkPort object.

pConfigDataDisp

[in] Pointer to the IDictionary interface of an object that contains information about the component specified in the eConfigType parameter.

[Visual Basic]

eConfigType

Enumeration value. Valid values are from the BIZTALK_CONFIGDATA_TYPE enumeration.

lConfigDataHandle

Long that identifies the handle to the associated BizTalkPort object.

pConfigDataDisp

CDictionary object that contains information about the component specified in the eConfigType parameter.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

The Dictionary object passed to this method has specific string qualifiers used for EDIFACT and X12. For a description of these qualifiers, see the GetConfigData Method.

When using the BIZTALK_CONFIGDATA_TYPE_PRIMARYTRANSPORT or BIZTALK_CONFIGDATA_TYPE_SECONDARYTRANSPORT enumeration value, the content of the transport dictionary varies according to the transport protocol used. The following tables list the transport dictionary fields for each protocol.

HTTP and HTTPS

Field name | Data type | Required | Description
URL | String | Yes | URL of the document destination.
ContentType | String | No | Value for the Content-Type HTTP/HTTPS property that appears in HTTP headers during transmission. The default value is an empty string ("").
ClientCert | String | No | Reference to the certificate used with SSL connections using HTTPS. The default value is an empty string ("").
ProxyName | String | No | URL of the proxy server used when sending documents outside a firewall.
ProxyPort | Integer | No | Port number used by the proxy server.
UseProxy | Boolean | No | Value that indicates whether the proxy server is used. The default value is True.

Local File

Field name | Data type | Required | Description
Filename | String | Yes | Name and path of the file to be created.
CopyMode | Integer | No | Value that indicates how the file should be written. Use a value of 0 for overwrite mode, a value of 1 for append mode, and a value of 2 to create a new file. The default value is append mode (1).
UserName | String | No | Windows NT username needed to access a file share. The default value is an empty string ("").
Password | String | No | Windows NT username needed to access a file share. The default value is an empty string ("").

Message Queuing

Field name | Data type | Required | Description
QueueName | String | Yes | Name of the Messaging Queue to which the document is sent.
MessageLabel | String | Yes | Value specified in the message label field on the queue.
Priority | Integer | No | Priority of the message placed in the queue. This must be a value between 0 and 7, where a higher value indicates a higher priority. The default value is 3
AuthLevel | Integer | No | Value indicating whether the message needs to be authenticated using a digital signature. Use a value of 0 to bypass authentication. A value of 1 indicates that authentication will be used. The default value is 0.
Delivery | Integer | No | Value indicating how a message is delivered to a queue. Use a value of 1 to indicate that the message should be backed up until it is delivered to the queue. A value of 0 indicates that the message is only resident in memory. The default value is 0.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkChannel::SignatureCertificateInfo Property [C++]

BizTalkChannel.SignatureCertificateInfo Property [Visual Basic]

The SignatureCertificateInfo property contains information about the certificate that signs the output document. This information includes the Name, Reference, Store, and Usage properties and is created and stored in memory in the BizTalkCertificateInfo object.

Syntax

[C++]

Get method:

HRESULT get_SignatureCertificateInfo(
    IDispatch** ppSignatureCertificateInfoDisp
);

Putref method:

HRESULT putref_SignatureCertificateInfo(
    IDispatch* pSignatureCertificateInfoDisp
);

[Visual Basic]

object.SignatureCertificateInfo

Parameters

[C++]

Get method:

ppSignatureCertificateInfoDisp

[out, retval] Address of a pointer to an IDispatch interface that contains the certificate information.

Putref method:

pSignatureCertificateInfoDisp

[in] Pointer to an IDispatch interface that contains the certificate information.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a BizTalkCertificateInfo object that contains the certificate information.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkChannel::SourceEndpoint Property [C++]

BizTalkChannel.SourceEndpoint Property [Visual Basic]

The SourceEndpoint property contains information about the source. This information includes the Alias, Application, and Organization properties and is created and stored in memory in the BizTalkEndPoint object.

Syntax

[C++]

Get method:

HRESULT get_SourceEndpoint(
    IDispatch** ppSrcEndpointDisp
);

Putref method:

HRESULT putref_SourceEndpoint(
     IDispatch* pSrcEndpointDisp
);

[Visual Basic]

object.SourceEndpoint

Parameters

[C++]

Get method:

ppSrcEndpointDisp

[out, retval] Address of a pointer to an IDispatch interface that contains information about the source.

Putref method:

pSrcEndpointDisp

[in] Pointer to an IDispatch interface that contains information about the source.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns an Object that contains information about the source.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkChannel::TrackFields Property [C++]

BizTalkChannel.TrackFields Property [Visual Basic]

The TrackFields property identifies the Dictionary object that points to the specification that contains fields to track interchange data on input documents for this BizTalkChannel object. These tracking fields override the fields set in the TrackFields property on the BizTalkDocument object.

Syntax

[C++]

Get method:

HRESULT get_TrackFields(
    IDispatch** ppTrackFieldsDisp
);

Putref method:

HRESULT putref_TrackFields(
    IDispatch* pTrackFieldsDisp
);

[Visual Basic]

object.TrackFields

Parameters

[C++]

Get method:

ppTrackFieldsDisp

[out, retval] Address of a pointer to the IDictionary interface of an object that contains the custom tracking fields.

Putref method:

pTrackFieldsDisp

[in] Pointer to the IDictionary interface of an object that contains the custom tracking fields.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a CDictionary object that contains the custom tracking fields.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

The fields in the Dictionary object must contain an XPath value that identifies the field to be tracked in a document. By default, the Dictionary object provides eight predefined fields for tracking data in a document. These predefined fields consist of two fields for each of the following data types: integer, real, date, and string. If additional fields are required for tracking, you can use the x_custom_search field in the Dictionary object, and set the value to a SimpleList object. The SimpleList object contains a list of XPaths pointing to the additional tracking fields. XPath values can be added to and deleted from this list using the Add and Delete methods.

The following table shows the field names in the Dictionary object for TrackFields:

Field Name | Field type
i_value1 | Integer value
i_value2 | Integer value
r_value1 | Real value
r_value2 | Real value
d_value1 | Date value
d_value2 | Date value
s_value1 | String value
s_value2 | String value
x_custom_search | A list to return one or more additional data items

For more information about XPath expressions, go to the Microsoft Web site (msdn.microsoft.com/library/default.asp) and search for XPath.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topic

Document Tracking


IBizTalkChannel::VerifySignatureCertificateInfo Property [C++]

BizTalkChannel.VerifySignatureCertificateInfo Property [Visual Basic]

The VerifySignatureCertificateInfo property contains information about the certificate that verifies the signature of the input document. This information includes the Name, Reference, Store, and Usage properties and is created and stored in memory in the BizTalkCertificateInfo object.

Syntax

[C++]

Get method:

HRESULT get_VerifySignatureCertificateInfo(
    IDispatch** ppVerifySignatureCertificateInfoDisp
);

Putref method:

HRESULT putref_VerifySignatureCertificateInfo(
    IDispatch* pVerifySignatureCertificateInfoDisp
);

[Visual Basic]

object.VerifySignatureCertificateInfo

Parameters

[C++]

Get method:

ppVerifySignatureCertificateInfoDisp

[out, retval] Address of a pointer to an IDispatch interface that contains the certificate information.

Put method:

pVerifySignatureCertificateInfoDisp

[in] Pointer to an IDispatch interface that contains the certificate information.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a BizTalkCertificateInfo object that contains the certificate information.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkConfig Interface [C++]

BizTalkConfig Object [Visual Basic]

Use the BizTalkConfig object to create channels, document specifications, envelopes, organizations, ports, and port groups.

In C++, use the IBizTalkConfig interface to access the methods of the BizTalkConfig object.

The properties of the BizTalkConfig object are shown in the following table.

Property | Data type | Description
Certificates | Object | Returns an ADO recordset that contains all specified certificates. This is a read-only property.
Channels | Object | Returns an ADO recordset that contains all BizTalkChannel objects. This is a read-only property.
Documents | Object | Returns an ADO recordset that contains all BizTalkDocument objects. This is a read-only property.
Envelopes | Object | Returns an ADO recordset that contains all BizTalkEnvelope objects.
Organizations | Object | Returns an ADO recordset that contains all BizTalkOrganization objects. This is a read-only property.
PortGroups | Object | Returns an ADO recordset that contains all BizTalkPortGroup objects. This is a read-only property.
Ports | Object | Returns an ADO recordset that contains all BizTalkPort objects. This is a read-only property.

The methods of the BizTalkConfig object are shown in the following table.

Method | Description
CreateChannel | Returns the address of a pointer to a new BizTalkChannel object.
CreateDocument | Returns the address of a pointer to a new BizTalkDocument object.
CreateEnvelope | Returns the address of a pointer to a new BizTalkEnvelope object.
CreateOrganization | Returns the address of a pointer to a new BizTalkOrganization object.
CreatePort | Returns the address of a pointer to a new BizTalkPort object.
CreatePortGroup | Returns the address of a pointer to a new BizTalkPortGroup object.

Remarks

In C++, each object created by using one of the methods of this interface inherits the following common methods from the IBizTalkBase interface. In Microsoft Visual Basic, each object created by using the methods of this class implements the following common properties and methods from the IBizTalkBase class.

  • DateModified

  • Handle

  • Name

  • Clear

  • Create

  • Load

  • LoadByName

  • Remove

  • Save

When BizTalkPort and BizTalkChannel objects are created, BizTalk Server automatically creates some associated subobjects. You can access these subobjects by using properties of the BizTalkPort and BizTalkChannel objects.

The relationship between objects, their subobjects, and the properties used to obtain the subobjects is shown in the following table.

Subobject | Associated object | Property to set
BizTalkEndPoint | BizTalkPort | DestinationEndpoint
BizTalkEndPoint | BizTalkChannel | SourceEndpoint
BizTalkLoggingInfo | BizTalkChannel | LoggingInfo
BizTalkTransportInfo | BizTalkPort | PrimaryTransport, SecondaryTransport
BizTalkServiceWindowInfo | BizTalkPort | ServiceWindowInfo
BizTalkCertificateInfo | BizTalkPort | EncryptionCertificateInfo
BizTalkCertificateInfo | BizTalkChannel | SignatureCertificateInfo, VerifySignatureCertificateInfo, or DecryptionCertificateInfo

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkConfig::Certificates Property [C++]

BizTalkConfig.Certificates Property [Visual Basic]

The Certificates property returns an ADO recordset that contains all specified certificates.

Syntax

[C++]

Get method:

HRESULT get_Certificates(
    BIZTALK_STORE_TYPE StoreType,
    BIZTALK_USAGE_TYPE UsageType,
    BSTR NamePrefix,
    IDispatch** ppCertsDisp
);

[Visual Basic]

object.Certificates( _

    StoreType As BIZTALK_STORE_TYPE, _
    UsageType As BIZTALK_USAGE_TYPE, _
    NamePrefix As String, _

)

Parameters

[C++]

StoreType

[in] Enumeration value. Valid values are from the BIZTALK_STORE_TYPE enumeration.

UsageType

[in] Enumeration value. Valid values are from the BIZTALK_USAGE_TYPE enumeration.

NamePrefix

[in] BSTR that contains a prefix used as the selection criteria for certificate names. Any certificate Name starting with this value is returned in the recordset. This value is case sensitive.

ppCertsDisp

[out, retval] Address of a pointer to an IDispatch interface that contains all specified certificates.

[Visual Basic]

StoreType

Enumeration value. Valid values are from the BIZTALK_STORE_TYPE enumeration.

UsageType

Enumeration value. Valid values are from the BIZTALK_USAGE_TYPE enumeration.

NamePrefix

String that contains a prefix used as the selection criteria for certificate names. Any certificate Name starting with this value is returned in the recordset. This value is case sensitive.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

Note

  • In addition to the HRESULT values listed on the error messages page, this method returns OLEDB provider errors. Additional information about OLEDB is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

This property returns an Object that contains all specified certificates.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property.

Each record in the ADO recordset returned by this property contains information about an existing BizTalkCertificateInfo object in the database. The fields in each record contain the following information, listed in order:

  • Name

  • Reference

  • Store

  • Usage

Additional information about Microsoft ActiveX Data Objects is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkConfig::Channels Property [C++]

BizTalkConfig.Channels Property [Visual Basic]

The Channels property returns an ADO recordset that contains all BizTalkChannel objects.

Syntax

[C++]

Get method:

HRESULT Channels(
    IDispatch** ppChannelsDisp
);

[Visual Basic]

object.Channels

Parameters

[C++]

ppChannelsDisp

[out, retval] Address of a pointer to an IDispatch interface that contains all BizTalkChannel objects.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

Note

  • In addition to the HRESULT values listed on the error messages page, this method returns OLEDB provider errors. Additional information about OLEDB is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.
[Visual Basic]

This property returns an Object that contains all BizTalkChannel objects.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property.

Each record in the ADO recordset returned by this property contains information about an existing BizTalkChannel object in the database. The fields in each record contain the following information, listed in order:

  • Handle

  • Name

  • DateModified

Additional information about Microsoft ActiveX Data Objects is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkConfig::CreateChannel Method [C++]

BizTalkConfig.CreateChannel Method [Visual Basic]

[C++]

The CreateChannel method returns the address of a pointer to a new BizTalkChannel object.

[Visual Basic]

The CreateChannel method returns a new BizTalkChannel object.

Syntax

[C++]

HRESULT CreateChannel(
    IDispatch** ppChannelDisp
);

[Visual Basic]

object.CreateChannel()

Parameters

[C++]

ppChannelDisp

[out, retval] Address of a pointer to an IDispatch interface that contains a new BizTalkChannel object.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This method returns a new BizTalkChannel object.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkConfig::CreateDocument Method [C++]

BizTalkConfig.CreateDocument Method [Visual Basic]

[C++]

The CreateDocument method returns the address of a pointer to a new BizTalkDocument object.

[Visual Basic]

The CreateDocument method returns a new BizTalkDocument object.

Syntax

[C++]

HRESULT CreateDocument(
    IDispatch** ppDocumentDisp
);

[Visual Basic]

object.CreateDocument()

Parameters

[C++]

ppDocumentDisp

[out, retval] Address of a pointer to an IDispatch interface that contains a new BizTalkDocument object.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This method returns a new BizTalkDocument object.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkConfig::CreateEnvelope Method [C++]

BizTalkConfig.CreateEnvelope Method [Visual Basic]

[C++]

The CreateEnvelope method returns the address of a pointer to a new BizTalkEnvelope object.

[Visual Basic]

The CreateEnvelope method returns a new BizTalkEnvelope object.

Syntax

[C++]

HRESULT CreateEnvelope(
    IDispatch** ppEnvelopeDisp
);

[Visual Basic]

object.CreateEnvelope()

Parameters

[C++]

ppEnvelopeDisp

[out, retval] Address of a pointer to an IDispatch interface that contains a new BizTalkEnvelope object.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This method returns a new BizTalkEnvelope object.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkConfig::CreateOrganization Method [C++]

BizTalkConfig.CreateOrganization Method [Visual Basic]

[C++]

The CreateOrganization method returns the address of a pointer to a new BizTalkOrganization object.

[Visual Basic]

The CreateOrganization method returns a new BizTalkOrganization object.

Syntax

[C++]

HRESULT CreateOrganization(
    IDispatch** ppOrganizationDisp
);

[Visual Basic]

object.CreateOrganization()

Parameters

[C++]

ppOrganizationDisp

[out, retval] Address of a pointer to an IDispatch interface that contains a new BizTalkOrganization object.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This method returns a new BizTalkOrganization object.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkConfig::CreatePort Method [C++]

BizTalkConfig.CreatePort Method [Visual Basic]

[C++]

The CreatePort method returns the address of a pointer to a new BizTalkPort object.

[Visual Basic]

The CreatePort method returns a new BizTalkPort object.

Syntax

[C++]

HRESULT CreatePort(
    IDispatch** ppPortDisp
);

[Visual Basic]

object.CreatePort()

Parameters

[C++]

ppPortDisp

[out, retval] Address of a pointer to an IDispatch interface that contains a new BizTalkPort object.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This method returns a new BizTalkPort object.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkConfig::CreatePortGroup Method [C++]

BizTalkConfig.CreatePortGroup Method [Visual Basic]

[C++]

The CreatePortGroup method returns the address of a pointer to a new BizTalkPortGroup object.

[Visual Basic]

The CreatePortGroup method returns a new BizTalkPortGroup object.

Syntax

[C++]

HRESULT CreatePortGroup(
    IDispatch** ppPortGroupDisp
);

[Visual Basic]

object.CreatePortGroup()

Parameters

[C++]

ppPortGroupDisp

[out, retval] Address of a pointer to an IDispatch interface that contains a new BizTalkPortGroup object.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This method returns a new BizTalkPortGroup object.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkConfig::Documents Property [C++]

BizTalkConfig.Documents Property [Visual Basic]

The Documents property returns an ADO recordset that contains all BizTalkDocument objects.

Syntax

[C++]

Get method:

HRESULT Documents(
    IDispatch** ppDocumentsDisp
);

[Visual Basic]

object.Documents

Parameters

[C++]

ppDocumentsDisp

[out, retval] Address of a pointer to an IDispatch interface that contains all BizTalkDocument objects.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

Note

  • In addition to the HRESULT values listed on the error messages page, this method returns OLEDB provider errors. Additional information about OLEDB is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.
[Visual Basic]

This property returns an Object that contains all BizTalkDocument objects.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property.

Each record in the ADO recordset returned by this property contains information about an existing BizTalkDocument object in the database. The fields in each record contain the following information, listed in order:

  • Handle

  • Name

  • DateModified

Additional information about Microsoft ActiveX Data Objects is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkConfig::Envelopes Property [C++]

BizTalkConfig.Envelopes Property [Visual Basic]

The Envelopes property returns an ADO recordset that contains all BizTalkEnvelope objects.

Syntax

[C++]

Get method:

HRESULT Envelopes(
    IDispatch** ppEnvelopesDisp
);

[Visual Basic]

object.Envelopes

Parameters

[C++]

ppEnvelopesDisp

[out, retval] Address of a pointer to an IDispatch interface that contains all BizTalkEnvelope objects.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

Note

  • In addition to the HRESULT values listed on the error messages page, this method returns OLEDB provider errors. Additional information about OLEDB is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.
[Visual Basic]

This property returns an Object that contains all BizTalkEnvelope objects.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property.

Each record in the ADO recordset returned by this property contains information about an existing BizTalkEnvelope object in the database. The fields in each record contain the following information, listed in order:

  • Handle

  • Name

  • DateModified

  • Format

Additional information about Microsoft ActiveX Data Objects is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkConfig::Organizations Property [C++]

BizTalkConfig.Organizations Property [Visual Basic]

The Organizations property returns an ADO recordset that contains all BizTalkOrganization objects.

Syntax

[C++]

Get method:

HRESULT Organizations(
    IDispatch** ppOrganizationsDisp
);

[Visual Basic]

object.Organizations

Parameters

[C++]

ppOrganizationsDisp

[out, retval] Address of a pointer to an IDispatch interface that contains all BizTalkOrganization objects.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

Note

  • In addition to the HRESULT values listed on the error messages page, this method returns OLEDB provider errors. Additional information about OLEDB is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.
[Visual Basic]

This property returns an Object that contains all BizTalkOrganization objects.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property.

Each record in the ADO recordset returned by this property contains information about an existing BizTalkOrganization object in the database. The fields in each record contain the following information, listed in order:

  • Handle

  • Name

  • DateModified

  • IsDefault

Additional information about Microsoft ActiveX Data Objects is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkConfig::PortGroups Property [C++]

BizTalkConfig.PortGroups Property [Visual Basic]

The PortGroups property returns an ADO recordset that contains all BizTalkPortGroup objects.

Syntax

[C++]

HRESULT PortGroups(
    IDispatch** ppPortGroupsDisp
);

[Visual Basic]

object.PortGroups

Parameters

[C++]

ppPortGroupsDisp

[out, retval] Address of a pointer to an IDispatch interface that contains all BizTalkPortGroup objects.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

Note

  • In addition to the HRESULT values listed on the error messages page, this method returns OLEDB provider errors. Additional information about OLEDB is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.
[Visual Basic]

This property returns an Object that contains all BizTalkPortGroup objects.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property.

Each record in the ADO recordset returned by this property contains information about an existing BizTalkPortGroup object in the database. The fields in each record contain the following information, listed in order:

  • Handle

  • Name

  • DateModified

Additional information about Microsoft ActiveX Data Objects is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkConfig::Ports Property [C++]

BizTalkConfig.Ports Property [Visual Basic]

The Ports property returns an ADO recordset that contains all BizTalkPort objects.

Syntax

[C++]

Get method:

HRESULT Ports(
    IDispatch** ppPortsDisp
);

[Visual Basic]

object.Ports

Parameters

[C++]

ppPortsDisp

[out, retval] Address of a pointer to an IDispatch interface that contains all BizTalkPort objects.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

Note

  • In addition to the HRESULT values listed on the error messages page, this method returns OLEDB provider errors. Additional information about OLEDB is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.
[Visual Basic]

This property returns an Object that contains all BizTalkPort objects.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property.

Each record in the ADO recordset returned by this property contains information about an existing BizTalkPort object in the database. The fields in each record contain the following information, listed in order:

  • Handle

  • Name

  • DateModified

Additional information about Microsoft ActiveX Data Objects is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkDocument Interface [C++]

BizTalkDocument Object [Visual Basic]

Use the BizTalkDocument object to identify and describe the document specification of a document.

In C++, use the IBizTalkDocument interface to access the methods of the BizTalkDocument object.

The properties of the BizTalkDocument object are shown in the following table.

Property | Type | Description
Content | BSTR | Content of the document specification described by the object. This is a read-only property.
DateModified | BSTR | Date and time at which the information in the object was created or last modified. This is a read-only property obtained from the BizTalkBase object.
Handle | long | Handle to the object. This is a read-only property obtained from the BizTalkBase object.
Name | BSTR | Name of the object. This is a required property obtained from the BizTalkBase object.
NameSpace | BSTR | String that resolves naming conflicts between elements in a document. This is a read-only property.
PropertySet | IDispatch | Dictionary object that contains the electronic data interchange (EDI) selection criteria (name/value pairs) by which the server extracts information from the functional group header of the EDI document to identify the object when the document is input. It helps the server create the header of the EDI document when it is output. This is a required property if the document is an EDI document.
Reference | BSTR | Full Web Distributed Authoring and Versioning (WebDAV) URL for the document specification referred to by this BizTalkDocument object. This is a required property when the TrackFields property is set.
TrackFields | IDispatch | Dictionary object that stores the custom fields that Tracking uses to track all documents processed by the server, based on this document instance. The Reference property must contain a WebDAV URL when this property is set.
Type | BSTR | Type of document specification. This is a read-only property.
Version | BSTR | Version of the document standard. This is a read-only property.

The methods of the BizTalkDocument object are shown in the following table.

Method | Description
Clear | Clears the object in memory. All member variables of the object in memory are initialized to their default values. This method is obtained from the BizTalkBase object.
Create | Creates a new object in the database. This method is obtained from the BizTalkBase object.
Load | Loads the object in memory. This method is obtained from the BizTalkBase object.
LoadByName | Loads the object by name in memory. This method is obtained from the BizTalkBase object.
LoadByPropertySet | Loads the document object by its PropertySet object.
Remove | Removes the object from the database. This method is obtained from the BizTalkBase object.
Save | Saves the object in the database. This method is obtained from the BizTalkBase object.

Remarks

Each BizTalkDocument object must have at least one associated BizTalkChannel object. More than one BizTalkDocument object can refer to the same document specification.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topic

Document Definitions


IBizTalkDocument::Content Property [C++]

BizTalkDocument.Content Property [Visual Basic]

The Content property contains the content of the document specification described by the object.

Syntax

[C++]

Get method:

HRESULT get_Content(
    BSTR* pstrContent
);

[Visual Basic]

object.Content

Parameters

[C++]

pstrContent

[out, retval] Pointer to a BSTR that contains the content.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a String that contains the content.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property.

The Reference property is checked when the Create or the Save method is called. If this string is not empty when Create is called, Content is set to the contents of the document specification and the NameSpace property is changed to the value found in the document specification.

Once you have created or saved an object with Reference set to a document specification, any changes you make to the Content or NameSpace of the referenced document specification are not automatically updated on the referring object. To update the object that refers to the revised document specification, you must save the document specification, reset the Reference property of the object to its current value, and then call Save on the referring object.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkDocument::LoadByPropertySet Method [C++]

BizTalkDocument.LoadByPropertySet Method [Visual Basic]

The LoadByPropertySet method loads the document object by its PropertySet.

Syntax

[C++]

HRESULT LoadByPropertySet(
    IDispatch** pPropSetDictionaryDisp
);

[Visual Basic]

object.LoadByPropertySet( _

    pPropSetDictionaryDisp As Object _
)

Parameters

[C++]

pPropSetDictionaryDisp

[in] Address of a pointer to an IDispatch interface that contains the PropertySet.

[Visual Basic]

pPropSetDictionaryDisp

Object that contains the PropertySet.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkDocument::NameSpace Property [C++]

BizTalkDocument.NameSpace Property [Visual Basic]

The NameSpace property contains the string that resolves naming conflicts between elements in a document.

Syntax

[C++]

Get method:

HRESULT get_NameSpace(
    BSTR* pstrNameSpace
);

[Visual Basic]

object.NameSpace

Parameters

[C++]

pstrNameSpace

[out, retval] Pointer to a BSTR that contains the namespace.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a String that contains the namespace.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property. The Reference property is checked when the Create or the Save method is called. If this string is not empty when Create is called, Content is set to the contents of the document specification and NameSpace is changed to the value found in the document specification.

Once you have created or saved an object with Reference set to a document specification, any changes you make to the Content or NameSpace of the referenced document specification are not automatically updated on the referring object. To update the object that refers to the revised document specification, you must save the document specification, reset the Reference property of the object to its current value, and then call Save on the referring object.

Note

  • When creating a document, the number of characters in the NameSpace combined with the number of characters in the specification name cannot exceed 255.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkDocument::PropertySet Property [C++]

BizTalkDocument.PropertySet Property [Visual Basic]

The PropertySet property contains a Dictionary object that contains the electronic data interchange (EDI) selection criteria (name/value pairs) by which the server extracts information from the functional group header of the EDI document to identify the object when the document is input. It helps the server create the header of the EDI document when it is output.

Syntax

[C++]

Get method:

HRESULT get_PropertySet(
    IDispatch** ppPropSetDisp
);

Putref method:

HRESULT putref_PropertySet(
    IDispatch* pPropSetDisp
);

[Visual Basic]

object.PropertySet

Parameters

[C++]

Get method:

ppPropSetDisp

[out, retval] Address of a pointer to an IDispatch interface that contains the selection criteria.

Putref method

pPropSetDisp

[in] Pointer to an IDispatch interface that contains the selection criteria.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns an Object that contains the selection criteria.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a required property if the document is an EDI document. The Delimiters property of the associated BizTalkPort object must also be defined.

The following table shows whether names are required in the Dictionary object for PropertySet.

Selection criteria | X12 | EDIFACT
application_sender_code | Yes | Yes
application_receiver_code | Yes | Yes
functional_identifier | Yes | Yes
standards_version | Yes | No
standards_version_type | No | Yes
standards_version_value | No | Yes

Note

  • The name/value pairs contained in the Dictionary object cannot exceed a total of 450 bytes.

PropertySet can be set only if the Reference property is set.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topic

Document Definitions


IBizTalkDocument::Reference Property [C++]

BizTalkDocument.Reference Property [Visual Basic]

The Reference property contains the full Web Distributed Authoring and Versioning (WebDAV) URL for the document specification referred to by the object.

Syntax

[C++]

Get method:

HRESULT get_Reference(
    BSTR* pstrReference
);

Put method:

HRESULT put_Reference(
    BSTR strReference
);

[Visual Basic]

object.Reference

Parameters

[C++]

Get method:

pstrReference

[out, retval] Pointer to a BSTR that contains the reference.

Put method:

strReference

[in] BSTR that contains the reference.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a String that contains the reference.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

Reference is checked when the Create or the Save method is called. If this string is not empty when Create is called, Content is set to the contents of the document specification and the NameSpace property is changed to the value found in the document specification.

Once you have created or saved an object with Reference set to a document specification, any changes you make to the Content or NameSpace of the referenced document specification are not automatically updated on the referring object. To update the object that refers to the revised document specification, you must save the document specification, reset the Reference property of the object to its current value, and then call Save on the referring object.

If Reference is not set, the PropertySet and TrackFields properties must not be set.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkDocument::TrackFields Property [C++]

BizTalkDocument.TrackFields Property [Visual Basic]

The TrackFields property identifies the Dictionary object that stores the custom fields used to track the document. A BizTalkDocument object points to the specification that contains fields to track the document. The designated fields are logged to the Tracking database for each instance of a document that is processed. Tracking fields on the BizTalkDocument object are global. The TrackFields property on the BizTalkChannel object overrides the values specified by this property.

Syntax

[C++]

Get method:

HRESULT get_TrackFields(
    IDispatch** ppTrackFieldsDisp
);

Putref method:

HRESULT putref_TrackFields(
    IDispatch* pTrackFieldsDisp
);

[Visual Basic]

object.TrackFields

Parameters

[C++]

Get method:

ppTrackFieldsDisp

[out, retval] Address of a pointer to the IDictionary interface of the object that contains the custom tracking fields.

Putref method:

pTrackFieldsDisp

[in] Pointer to the IDictionary interface of the object that contains the custom tracking fields.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a CDictionary object that contains the custom tracking fields.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

TrackFields can be set only if the Reference property is set. Tracking fields specified for an output BizTalkDocument object are ignored.

The fields in the Dictionary object must contain an XPath value that identifies the field to be tracked in a document. By default, the Dictionary object provides eight predefined fields for tracking data in a document. These predefined fields consist of two fields for each of the following data types: integer, real, date, and string. If additional fields are required for tracking, you can use the x_custom_search field in the Dictionary object and set the value to a SimpleList object. The SimpleList object contains a list of XPaths pointing to the additional tracking fields. XPath values can be added to and deleted from this list using the Add and Delete methods.

The following table shows the field names in the Dictionary object for TrackFields:

Field Name | Field type
i_value1 | Integer value
i_value2 | Integer value
r_value1 | Real value
r_value2 | Real value
d_value1 | Date value
d_value2 | Date value
s_value1 | String value
s_value2 | String value
x_custom_search | A list to return one or more additional data items

For more information about XPath expressions, go to the Microsoft Web site (msdn.microsoft.com/library/default.asp) and search for XPath.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Document Definitions

Document Tracking


IBizTalkDocument::Type Property [C++]

BizTalkDocument.Type Property [Visual Basic]

The Type property contains the type of document specification.

Syntax

[C++]

HRESULT get_Type(
    BSTR* pstrType
);

[Visual Basic]

object.Type

Parameters

[C++]

pstrType

[out, retval] Pointer to a BSTR that contains the document type.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a String that contains the document type.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property. All document instances must have the same document type as the associated envelope. For example, if the Format property of the BizTalkEnvelope object is set to X12, Type must also be X12.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkDocument::Version Property [C++]

BizTalkDocument.Version Property [Visual Basic]

The Version property contains the version of the document standard.

Syntax

[C++]

HRESULT get_Version(
    BSTR* pstrVersion
);

[Visual Basic]

object.Version

Parameters

[C++]

pstrVersion

[out, retval] Pointer to a BSTR that contains the version.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a String that contains the version.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkEndPoint Interface [C++]

BizTalkEndPoint Object [Visual Basic]

Use the BizTalkEndPoint object to configure source information for a BizTalkChannel object and destination information for a BizTalkPort object.

In C++, use the IBizTalkEndPoint interface to access the methods of the BizTalkEndPoint object.

The properties of the BizTalkEndPoint object are shown in the following table.

Property | Type | Description
Alias | long | Handle to the organization identifier type/value pair for the destination BizTalkOrganization object for the associated BizTalkPort object.
Application | long | Handle to the associated application for the destination BizTalkOrganization object for this BizTalkPort object.
Openness | BIZTALK_OPENNESS_ TYPE_EX | Enumeration value that indicates whether the object is open.
Organization | long | Handle to the destination BizTalkOrganization object for this BizTalkPort object. This is a required property for this object to be complete unless the Openness property is set to BIZTALK_OPENNESS_ TYPE_EX_DESTINATION.

Remarks

The BizTalkEndPoint object is automatically created when a BizTalkPort object or a BizTalkChannel object is instantiated with the CreatePort or the CreateChannel method of the BizTalkConfig object.

For destination endpoints, access the BizTalkEndPoint object by using the DestinationEndpoint property of the BizTalkPort object. For source endpoints, access the BizTalkEndPoint object by using the SourceEndpoint property of the BizTalkChannel object.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkEndPoint::Alias Property [C++]

BizTalkEndPoint.Alias Property [Visual Basic]

The Alias property contains the handle to the alias.

Syntax

[C++]

Get method:

HRESULT get_Alias(
    long* plAliasHandle
);

Put method:

HRESULT put_Alias(
    long lAliasHandle
);

[Visual Basic]

object.Alias

Parameters

[C++]

Get method:

plAliasHandle

[out, retval] Pointer to a long that contains the handle to the alias.

Put method:

lAliasHandle

[in] Long that contains the handle to the alias.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a Long that contains the handle to the alias.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkEndPoint::Application Property [C++]

BizTalkEndPoint.Application Property [Visual Basic]

The Application property contains the handle to the application.

Syntax

[C++]

Get method:

HRESULT get_Application(
    long* plAppHandle
);

Put method:

HRESULT put_Application(
    long lAppHandle
);

[Visual Basic]

object.Application

Parameters

[C++]

Get method:

plAppHandle

[out, retval] Pointer to a long that contains the handle to the application.

Put method:

lAppHandle

[in] Long that contains the handle to the application.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a Long that contains the handle to the application.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkEndPoint::Openness Property [C++]

BizTalkEndPoint.Openness Property [Visual Basic]

The Openness property contains an enumeration value that indicates whether the object has an open destination or source, or neither.

Syntax

[C++]

Get method:

HRESULT get_Openness(
    BIZTALK_OPENNESS_TYPE_EX* pOpennessType
);

Put method:

HRESULT put_Openness(
    BIZTALK_OPENNESS_TYPE_EX OpennessType
);

[Visual Basic]

object.Openness

Parameters

[C++]

Get method:

pOpennessType

[out, retval] Pointer to an enumeration value. Valid values are from the BIZTALK_OPENNESS_TYPE_EX enumeration.

Put Method:

OpennessType

[in] Enumeration value. Valid values are from the BIZTALK_OPENNESS_TYPE_EX enumeration.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns an enumeration value. Valid values are from the BIZTALK_OPENNESS_TYPE_EX enumeration.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

The BizTalkPort object is valid only if the associated document or the parameters on the Submit or the SubmitSync method of the IInterchange interface identify the missing information.

If Openness is set to BIZTALK_OPENNESS_TYPE_EX_SOURCE for a BizTalkEndPoint object associated with a channel, the following constraints apply:

  • The SignatureType property must not be set.

  • The BizTalkPort object cannot be included in a port group.

If Openness is set to BIZTALK_OPENNESS_TYPE_EX_FROMWORKFLOW on a channel, the associated BizTalkOrganization object must be the default organization.

If Openness on the object is set to BIZTALK_OPENNESS_TYPE_EX_DESTINATION for a BizTalkEndPoint object associated with a messaging port, the following constraints apply:

  • The PrimaryTransportType property must be set to BIZTALK_TRANSPORT_TYPE_OPENDESTINATION.

  • The EncryptionType property must not be set.

  • The document or the parameters on Submit or SubmitSync must specify the destination, transport type, and address.

  • The BizTalkPort object cannot be included in a port group.

Note

  • This property cannot be changed on an existing port.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topic

Openness


IBizTalkEndPoint::Organization Property [C++]

BizTalkEndPoint.Organization Property [Visual Basic]

The Organization property contains the handle to the organization.

Syntax

[C++]

Get method:

HRESULT get_Organization(
    long* plOrganizationHandle
);

Put method:

HRESULT put_Organization(
    long lOrganizationHandle
);

[Visual Basic]

object.Organization

Parameters

[C++]

Get method:

plOrganizationHandle

[out, retval] Pointer to a long that contains the handle to the organization.

Put method:

lOrganizationHandle

[in] Long that contains the handle to the organization.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a Long that contains the handle to the organization.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkEnvelope Interface [C++]

BizTalkEnvelope Object [Visual Basic]

Use the BizTalkEnvelope object to configure the envelope format used with documents processed by BizTalk Server. An envelope is the header information for an interchange.

In C++, use the IBizTalkEnvelope interface to access the methods of the BizTalkEnvelope object.

The properties of the BizTalkEnvelope object are shown in the following table.

Property | Type | Description
Content | BSTR | Contents of the selected envelope format specification. This is a read-only property.
DateModified | BSTR | Date and time at which the information in the object was created or last modified. This is a read-only property obtained from the BizTalkBase object.
Format | BSTR | String that identifies the type of envelope.
Handle | long | Handle to the object. This is a read-only property obtained from the BizTalkBase object.
Name | BSTR | Name of the object. This is a required property obtained from the BizTalkBase object.
NameSpace | BSTR | String that resolves naming conflicts between elements in an envelope specification. This is a read-only property.
Reference | BSTR | Full Web Distributed Authoring and Versioning (WebDAV) URL name of the envelope format specification file. This is a required property if the Format property is set to "custom".
Version | BSTR | Version of the envelope format specification. This is a read-only property.

The methods of the BizTalkEnvelope object are shown in the following table.

Method | Description
Clear | Clears the object in memory. All member variables of the object in memory are initialized to their default values. This method is obtained from the BizTalkBase object.
Create | Creates a new object in the database. This method is obtained from the BizTalkBase object.
Load | Loads the object in memory. This method is obtained from the BizTalkBase object.
LoadByName | Loads the object by name in memory. This method is obtained from the BizTalkBase object.
Remove | Removes the object from the database. This method is obtained from the BizTalkBase object.
Save | Saves the object in the database. This method is obtained from the BizTalkBase object.

Remarks

All document instances in an electronic data interchange (EDI) functional group must have the same format. All document instances must have the same document type as the associated envelope. For example, if Format is set to X12, the Type property of the BizTalkDocument objects for the associated BizTalkPort object must also be X12.

If you use an envelope with an EDIFACT format and you want to use a null value for the empty qualifier in the header for the source or the destination, create a custom identifier with a single dash (-) as the qualifier. To do this, use the CreateAlias method on the BizTalkOrganization object. When an empty qualifier is encountered on an input EDIFACT envelope, the server converts the empty qualifier to a dash. For an output EDIFACT envelope, the server converts the dash to an empty qualifier.

The BizTalkEnvelope object is required for input documents if the Type property of the BizTalkDocument object is set to "flatfile" or "custom xml".

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topic

Envelopes


IBizTalkEnvelope::Content Property [C++]

BizTalkEnvelope.Content Property [Visual Basic]

The Content property contains the contents of the selected envelope format specification.

Syntax

[C++]

HRESULT get_Content(
    BSTR* pstrContent
);

[Visual Basic]

object.Content

Parameters

[C++]

pstrContent

[out, retval] Pointer to a BSTR that contains the content.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a String that contains the content.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property.

The Reference property is checked when the Create or the Save method is called. If this string is not empty when Create is called, Content is set to the contents of the envelope specification, and the NameSpace property is changed to the value found in the envelope specification.

Once you have created or saved an object with Reference set to an envelope specification, any changes you make to the Content or NameSpace of the referenced envelope specification are not automatically updated on the referring object. To update the object that refers to the revised envelope specification, you must save the envelope specification, reset the Reference property of the object to its current value, and then call Save on the referring object.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkEnvelope::Format Property [C++]

BizTalkEnvelope.Format Property [Visual Basic]

The Format property contains the string that identifies the type of envelope.

Syntax

[C++]

Get method:

HRESULT get_Format(
    BSTR* pstrFormat
);

Put method:

HRESULT put_Format(
    BSTR Format
);

[Visual Basic]

object.Format

Parameters

[C++]

Get method:

pstrFormat

[out, retval] Pointer to a BSTR that contains the envelope format.

Put method:

Format

[in] BSTR that contains the envelope format. The BSTR must be one of the values listed in the Remarks section below.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a String that contains the envelope format.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

The format value must be one of the following strings:

  • x12

  • edifact

  • custom xml (default)

  • custom

  • flatfile

  • reliable

Note

  • Any string other than the ones listed here will cause an error at run time.

If this property is set to "custom", the Reference property is required. Also, a custom parser component has to be registered with the server for input documents with this property set to "custom". For more information about custom parser components, see Using the IBizTalkParserComponent Interface.

All document instances must have the same document type as the associated envelope. For example, if Format is set to "x12", the Type property of the BizTalkDocument objects must also be "x12".

If Format is set to X12, edifact, or reliable, the Reference property should not be set.

For more information about envelope formats, see Create envelopes.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topic

Envelopes


IBizTalkEnvelope::NameSpace Property [C++]

BizTalkEnvelope.NameSpace Property [Visual Basic]

The NameSpace property contains the string that resolves naming conflicts between elements in an envelope specification.

Syntax

[C++]

Get method:

HRESULT get_NameSpace(
    BSTR* pstrNameSpace
);

[Visual Basic]

object.NameSpace

Parameters

[C++]

pstrNameSpace

[out, retval] Pointer to a BSTR that contains the namespace.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a String that contains the namespace.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property. The Reference property is checked when the Create or the Save method is called. If this string is not empty when Create is called, the Content property is set to the contents of the envelope specification, and NameSpace is changed to the value found in the envelope specification.

Once you have created or saved an object with Reference set to an envelope specification, any changes you make to the Content or NameSpace of the referenced envelope specification are not automatically updated on the referring object. To update the object that refers to the revised envelope specification, you must save the envelope specification, reset the Reference property of the object to its current value, and then call Save on the referring object.

Note

  • When creating an envelope, the number of characters in the NameSpace combined with the number of characters in the specification name cannot exceed 255.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkEnvelope::Reference Property [C++]

BizTalkEnvelope.Reference Property [Visual Basic]

The Reference property contains the full Web Distributed Authoring and Versioning (WebDAV) URL of the envelope format specification file.

Syntax

[C++]

Get method:

HRESULT get_Reference(
    BSTR* pReference
);

Put method:

HRESULT put_Reference(
    BSTR Reference
);

[Visual Basic]

object.Reference

Parameters

[C++]

Get method:

pReference

[out, retval] Pointer to a BSTR that contains the reference.

Put method:

Reference

[in] BSTR that contains the reference.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a String that contains the reference.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a required property if the Format property is set to "custom". Reference is checked when the Create or the Save method is called. If this string is not empty when Create is called, the Content property is set to the contents of the envelope specification, and the NameSpace property is changed to the value found in the envelope specification.

Once you have created or saved an object with Reference set to an envelope specification, any changes you make to the Content or NameSpace of the referenced envelope specification are not automatically updated on the referring object. To update the object that refers to the revised envelope specification, you must save the envelope specification, reset the Reference property of the object to its current value, and then call Save on the referring object.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkEnvelope::Version Property [C++]

BizTalkEnvelope.Version Property [Visual Basic]

The Version property contains the version of the envelope format specification.

Syntax

[C++]

Get method:

HRESULT get_Version(
    BSTR* pstrVersion
);

[Visual Basic]

object.Version

Parameters

[C++]

pstrVersion

[out, retval] Pointer to a BSTR that contains the version.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a String that contains the version.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkLoggingInfo Interface [C++]

BizTalkLoggingInfo Object [Visual Basic]

Use the BizTalkLoggingInfo object to configure the document-logging information for an associated BizTalkChannel object.

In C++, use the IBizTalkLoggingInfo interface to access the methods of the BizTalkLoggingInfo object.

The IBizTalkLoggingInfo interface defines the following properties:

Property | Type | Description
LogNativeInputDocument | VARIANT_BOOL | Flag that indicates whether the input document instance is saved and logged in its native format.
LogNativeOutputDocument | VARIANT_BOOL | Flag that indicates whether the output document instance is saved and logged in its native format.
LogXMLInputDocument | VARIANT_BOOL | Flag that indicates whether the XML input document is saved and logged.
LogXMLOutputDocument | VARIANT_BOOL | Flag that indicates whether the XML output document is saved and logged.

Remarks

The BizTalkLoggingInfo object is automatically created when a BizTalkChannel object is instantiated with the CreateChannel method of the BizTalkConfig object. You can access the BizTalkLoggingInfo object by using the LoggingInfo property of the BizTalkChannel object.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topic

Document Storage


IBizTalkLoggingInfo::LogNativeInputDocument Property [C++]

BizTalkLoggingInfo.LogNativeInputDocument Property [Visual Basic]

The LogNativeInputDocument property contains the flag that indicates whether the input document instance is saved and logged in its native format.

Syntax

[C++]

Get method:

HRESULT get_LogNativeInputDocument(
    VARIANT_BOOL* pbLogNativeInDoc
);

Put method:

HRESULT put_LogNativeInputDocument(
    VARIANT_BOOL bLogNativeInDoc
);

[Visual Basic]

object.LogNativeInputDocument

Parameters

[C++]

Get method:

pbLogNativeInDoc

[out, retval] Pointer to a VARIANT_BOOL type that contains the flag. A value of VARIANT_TRUE indicates that input documents will be saved and logged in their native format. A value of VARIANT_FALSE indicates that input documents will not be saved and logged in their native format.

Put method:

bLogNativeInDoc

[in] VARIANT_BOOL type that contains the flag. A value of VARIANT_TRUE indicates that documents will be saved and logged in their native format. A value of VARIANT_FALSE indicates that documents will not be saved and logged in their native format.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a Variant that contains the flag. A value of True indicates that input documents will be saved and logged in their native format. A value of False indicates that input documents will not be saved and logged in their native format.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topic

Document Storage


IBizTalkLoggingInfo::LogNativeOutputDocument Property [C++]

BizTalkLoggingInfo.LogNativeOutputDocument Property [Visual Basic]

The LogNativeOutputDocument property contains the flag that indicates whether the output document instance is saved and logged in its native format.

Syntax

[C++]

Get method:

HRESULT get_LogNativeOutputDocument(
    VARIANT_BOOL* pbLogNativeOutDoc
);

Put method:

HRESULT put_LogNativeOutputDocument(
    VARIANT_BOOL bLogNativeOutDoc
);

[Visual Basic]

object.LogNativeOutputDocument

Parameters

[C++]

Get method:

pbLogNativeOutDoc

[out, retval] Pointer to a VARIANT_BOOL type that contains the flag. A value of VARIANT_TRUE indicates that output documents will be saved and logged in their native format. A value of VARIANT_FALSE indicates that output documents will not be saved and logged in their native format.

Put method:

bLogNativeOutDoc

[in] VARIANT_BOOL type that contains the flag. A value of VARIANT_TRUE indicates that output documents will be saved and logged in their native format. A value of VARIANT_FALSE indicates that output documents will not be saved and logged in their native format.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a Variant that contains the flag. A value of True indicates that output documents will be saved and logged in their native format. A value of False indicates that output documents will not be saved and logged in their native format.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topic

Document Storage


IBizTalkLoggingInfo::LogXMLInputDocument Property [C++]

BizTalkLoggingInfo.LogXMLInputDocument Property [Visual Basic]

The LogXMLInputDocument property contains the flag that indicates whether the XML input document instance is saved and logged.

Syntax

[C++]

Get method:

HRESULT get_LogXMLInputDocument(
    VARIANT_BOOL* pbLogXMLInDoc
);

Put method:

HRESULT put_LogXMLInputDocument(
    VARIANT_BOOL bLogXMLInDoc
);

[Visual Basic]

object.LogXMLInputDocument

[C++]

Get method:

pbLogXMLInDoc

[out, retval] Pointer to a VARIANT_BOOL type that contains the flag. A value of VARIANT_TRUE indicates that input documents will be saved and logged in XML format. A value of VARIANT_FALSE indicates that input documents will not be saved and logged in XML format.

Put method:

bLogXMLInDoc

[in] VARIANT_BOOL type that contains the flag. A value of VARIANT_TRUE indicates that input documents will be saved and logged in XML format. A value of VARIANT_FALSE indicates that input documents will not be saved and logged in XML format.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a Variant that contains the flag. A value of True indicates that input documents will be saved and logged in XML format. A value of False indicates that input documents will not be saved and logged in XML format.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topic

Document Storage


IBizTalkLoggingInfo::LogXMLOutputDocument Property [C++]

BizTalkLoggingInfo.LogXMLOutputDocument Property [Visual Basic]

The LogXMLOutputDocument property contains a flag that indicates whether the XML output document instance is saved and logged.

Syntax

[C++]

Get method:

HRESULT get_LogXMLOutputDocument(
    VARIANT_BOOL* pbLogXMLOutDoc
);

Put method:

HRESULT put_LogXMLOutputDocument(
    VARIANT_BOOL bLogXMLOutDoc
);

[Visual Basic]

object.LogXMLOutputDocument

[C++]

Get method:

pbLogXMLOutDoc

[out, retval] Pointer to a VARIANT_BOOL type that contains the flag. A value of VARIANT_TRUE indicates that output documents will be saved and logged in XML format. A value of VARIANT_FALSE indicates that output documents will not be saved and logged in XML format.

Put method:

bLogXMLOutDoc

[in] When putting the property, a VARIANT_BOOL type that contains the flag. A value of VARIANT_TRUE indicates that output documents will be saved and logged in XML format. A value of VARIANT_FALSE indicates that output documents will not be saved and logged in XML format.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a Variant that contains the flag. A value of True indicates that output documents will be saved and logged in XML format. A value of False indicates that output documents will not be saved and logged in XML format.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topic

Document Storage


IBizTalkOrganization Interface [C++]

BizTalkOrganization Object [Visual Basic]

Use the BizTalkOrganization object to configure organizations, its organization identifiers (aliases), and the applications within the organization that send and/or receive documents. The application indicates the ultimate source or destination of the document.

In C++, use the IBizTalkOrganization interface to access the methods of the BizTalkOrganization object.

The properties of the BizTalkOrganization object are shown in the following table.

Property | Type | Description
Aliases | IDispatch | ADO recordset of aliases that refer to the object. The alias for an object is the organization identifier type/value pair.
Applications | IDispatch | ADO recordset of applications that refer to the object.
Comments | BSTR | User comments for the object.
DateModified | BSTR | Date and time at which the information in the object was created or last modified. This is a read-only property obtained from the BizTalkBase object.
Handle | long | Identifier for the object. This is a read-only property obtained from the BizTalkBase object.
IsDefault | VARIANT_BOOL | Flag that indicates whether the object is the default organization.
Name | BSTR | Name of the object. This is a required property that is obtained from the BizTalkBase object.

The methods of the BizTalkOrganization object are shown in the following table.

Method | Description
Clear | Clears the object in memory. All member variables of the object in memory are initialized to their default values. This method is obtained from the BizTalkBase object.
Create | Creates a new object in the database. This method is obtained from the BizTalkBase object.
CreateAlias | Creates an alias for the object. The alias is the organization identifier type/value pair.
CreateApplication | Creates a new application.
GetDefaultAlias | Gets the default alias for the object.
Load | Loads an object in memory. This method is obtained from the BizTalkBase object.
LoadAlias | Loads an existing alias for the object in memory.
LoadApplication | Loads an application in memory.
LoadByName | Loads an object by name in memory. This method is obtained from the BizTalkBase object.
Remove | Removes the object from the database. This method is obtained from the BizTalkBase object.
RemoveAlias | Removes an alias.
RemoveApplication | Removes an application.
Save | Saves the object to the database. This method is obtained from the BizTalkBase object.
SaveAlias | Saves this alias.
SaveApplication | Saves this application.

Remarks

A BizTalkOrganization object can have more than one application, but each application name must be unique for that object.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topic

Organizations


IBizTalkOrganization::Aliases Property [C++]

BizTalkOrganization.Aliases Property [Visual Basic]

The Aliases property returns an ADO recordset that contains information about all aliases that refer to the object. The alias for an object is the organization qualifier/value pair.

Syntax

[C++]

Get method:

HRESULT get_Aliases(
    IDispatch** ppAliasesDisp
);

[Visual Basic]

object.Aliases

Parameters

[C++]

ppAliasesDisp

[out, retval] Address of a pointer to an IDispatch interface that contains all aliases that refer to the object.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns an Object that contains all aliases that refer to the object.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

BizTalk Messaging Manager refers to aliases as identifiers.

Each record in the ADO recordset returned by this property contains information about the aliases of an existing BizTalkOrganization object in the database. The fields in each record contain the following information, listed in order:

  • Handle assigned to the alias.

  • Name specified in the CreateAlias method.

  • Boolean specified in the CreateAlias method.

  • Qualifier specified in the CreateAlias method.

  • Value specified in the CreateAlias method.

Additional information about Microsoft ActiveX Data Objects is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topic

Organizations


IBizTalkOrganization::Applications Property [C++]

BizTalkOrganization.Applications Property [Visual Basic]

The Applications property returns an ADO recordset that contains information about all applications that refer to the Organization object.

Syntax

[C++]

Get method:

HRESULT get_Applications(
    IDispatch** ppApplicationsDisp
);

[Visual Basic]

object.Applications

Parameters

[C++]

ppApplicationsDisp

[out, retval] Address of a pointer to an IDispatch interface that contains all applications that refer to the object.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

Note

  • In addition to the HRESULT values listed on the error messages page, this method returns OLEDB provider errors. Additional information about OLEDB is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.
[Visual Basic]

This property returns an Object that contains all applications that refer to the object.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

Each record in the ADO recordset returned by this property contains information about the applications of an existing BizTalkOrganization object in the database. The fields in each record contain the following information, listed in order:

  • Handle assigned to the application.

  • Name specified in the CreateApplication method.

Additional information about Microsoft ActiveX Data Objects is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkOrganization::Comments Property [C++]

BizTalkOrganization.Comments Property [Visual Basic]

The Comments property contains the user comments for the object.

Syntax

[C++]

Get method:

HRESULT get_Comments(
    BSTR* pstrComments
);

Put method:

HRESULT put_Comments(
    BSTR strComments
);

[Visual Basic]

object.Comments

Parameters

[C++]

Get method:

pstrComments

[out, retval] Pointer to a BSTR that contains the comments.

Put method:

strComments

[in] When putting the property, a BSTR that contains the comments.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a String that contains the comments.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkOrganization::CreateAlias Method [C++]

BizTalkOrganization.CreateAlias Method [Visual Basic]

The CreateAlias method creates a new alias for this Organization object. The alias for an object is the organization identifier that contains a name and a qualifier/value pair.

Syntax

[C++]

HRESULT CreateAlias(
    BSTR strName,
    VARIANT_BOOL bDefault,
    BSTR strQualifier,
    BSTR strValue
);

[Visual Basic]

object.CreateAlias( _
    strName As String, _
    bDefault As Boolean, _
    strQualifier As String, _
    strValue As String _
)

Parameters

[C++]

strName

[in] BSTR that contains the name of the alias.

bDefault

[in] VARIANT_BOOL type that contains the flag. This default alias overrides the previous default alias when set to VARIANT_TRUE. A value of VARIANT_FALSE indicates that this alias should not override the previous default alias. If no alias is specified as the default, one is assigned when the Create method is called.

strQualifier

[in] BSTR that contains the qualifier. This parameter cannot be set to "group".

strValue

[in] BSTR that contains the value.

[Visual Basic]

strName

String that contains the name of the alias.

bDefault

Boolean that contains the flag. This default alias overrides the previous default alias when set to True. If no alias is specified as the default, one is assigned when the Create method is called.

strQualifier

String that contains the qualifier. This parameter cannot be set to "group".

strValue

String that contains the value.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

More than one alias can be created for a BizTalkOrganization object. The organization alias must contain a name that is unique for the specified BizTalkOrganization object, and a qualifier/value pair that is unique across all BizTalkOrganization objects. One of these aliases must be specified as the default alias for the object.

The server automatically creates an alias named Organization with a default identifier of OrganizationName and the value set to the organization's name for new organizations. If the organization name is changed, the value is automatically updated with the new name. This alias cannot be removed.

Note

  • When using envelopes with an EDIFACT format and you want to use a null value for the empty qualifier in the header for the source or the destination, create a custom identifier with a single dash (-) as the qualifier.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topic

Organizations


IBizTalkOrganization::CreateApplication Method [C++]

BizTalkOrganization.CreateApplication Method [Visual Basic]

The CreateApplication method creates a new application.

Syntax

[C++]

HRESULT CreateApplication(
    BSTR strName
);

[Visual Basic]

object.CreateApplication( _
    strName As String _

)

Parameters

[C++]

strName

[in] BSTR that contains the name of the application.

[Visual Basic]

strName

String that contains the name of the application.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

If a BizTalkOrganization object is associated with more than one application, each application name must be unique.

Notes

  • BizTalk Messaging Manager refers to the default organization as the home organization.

  • BizTalk Messaging Manager allows applications to be created for the home organization only. The BizTalk Messaging Configuration object model does not enforce this restriction. Therefore, if you create an application for an organization other than the default (home) organization, you cannot modify it using BizTalk Messaging Manager.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topic

Organizations


IBizTalkOrganization::GetDefaultAlias Method [C++]

BizTalkOrganization.GetDefaultAlias Method [Visual Basic]

The GetDefaultAlias method returns the handle to the default alias for the object. The default alias for an object is the default organization identifier type/value pair.

Syntax

[C++]

HRESULT GetDefaultAlias(
    long* plAliasHandle
);

[Visual Basic]

object.GetDefaultAlias()

Parameters

[C++]

plAliasHandle

[out, retval] Pointer to a long that contains the handle.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This method returns a Long that contains the handle.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topic

Organizations


IBizTalkOrganization::IsDefault Property [C++]

BizTalkOrganization.IsDefault Property [Visual Basic]

The IsDefault property contains the flag that indicates whether the object is the default organization.

Syntax

[C++]

Get method:

HRESULT get_IsDefault(
    VARIANT_BOOL* pbIsDefault
);

[Visual Basic]

object.IsDefault

Parameters

[C++]

Get method:

pbIsDefault

[out, retval] Pointer to a VARIANT_BOOL type that indicates whether this organization is the default organization. A value of VARIANT_TRUE indicates that this organization is the default organization. A value of VARIANT_FALSE indicates that this organization is not the default organization.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a Boolean that contains the flag. If True, this organization is the default organization.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property. There must be one and only one default organization at any time.

Note

  • BizTalk Messaging Manager refers to the default organization as the home organization.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkOrganization::LoadAlias Method [C++]

BizTalkOrganization.LoadAlias Method [Visual Basic]

The LoadAlias method loads an associated alias for the object in memory. The alias for an object is the organization qualifier/value pair.

Syntax

[C++]

HRESULT LoadAlias(
    long lAliasHandle,
    VARIANT* pvarName,
    VARIANT* pvarDefault,
    VARIANT* pvarQualifier,
    VARIANT* pvarValue
);

[Visual Basic]

object.LoadAlias( _
    lAliasHandle As Long, _
    pvarName As Variant, _
    pvarDefault As Variant, _
    pvarQualifier As Variant, _
    pvarValue As Variant _
)

Parameters

[C++]

lAliasHandle

[in] Long that contains the handle to the alias.

pvarName

[in, out] Pointer to a VARIANT that contains the name of the organization identifier.

pvarDefault

[in, out] Pointer to a VARIANT that contains the default flag.

pvarQualifier

[in, out] Pointer to a VARIANT that contains the qualifier of the organization identifier.

pvarValue

[in, out] Pointer to a VARIANT that contains the value of the organization identifier.

[Visual Basic]

lAliasHandle

Long that contains the handle to the alias.

pvarName

Variant that contains the name of the organization identifier.

pvarDefault

Variant that contains the default flag.

pvarQualifier

Variant that contains the qualifier of the organization identifier.

pvarValue

Variant that contains the value of the organization identifier.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

The values used with the parameters of this method can be obtained from the Aliases property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topic

Organizations


IBizTalkOrganization::LoadApplication Method [C++]

BizTalkOrganization.LoadApplication Method [Visual Basic]

The LoadApplication method loads an associated application for the object in memory.

Syntax

[C++]

HRESULT LoadApplication(
    long lApplicationHandle,
    VARIANT* pvarName
);

[Visual Basic]

object.LoadApplication( _
    lApplicationHandle As Long, _
    pvarName As Variant _
)

Parameters

[C++]

lApplicationHandle

[in] Long that contains the application handle.

pvarName

[in, out] Pointer to a VARIANT that contains the name of the application.

[Visual Basic]

lApplicationHandle

Long that contains the application handle.

pvarName

Variant that contains the name of the application.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

The values used with the parameters of this method can be obtained from the Applications property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkOrganization::RemoveAlias Method [C++]

BizTalkOrganization.RemoveAlias Method [Visual Basic]

The RemoveAlias method removes an alias. The alias for an object is the organization identifier type/value pair.

Syntax

[C++]

HRESULT RemoveAlias(
    long lAliasHandle
);

[Visual Basic]

object.RemoveAlias( _
    lAliasHandle As Long _
)

Parameters

[C++]

lAliasHandle

[in] Long that contains the handle to the alias.

[Visual Basic]

lAliasHandle

Long that contains the handle to the alias.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This record cannot be removed if any of the following conditions apply:

  • A BizTalkPort or a BizTalkChannel object refers to it.

  • It has been designated the default organization identifier.

  • This alias was autogenerated.

The alias handle can be obtained from the Aliases property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topic

Organizations


IBizTalkOrganization::RemoveApplication Method [C++]

BizTalkOrganization.RemoveApplication Method [Visual Basic]

The RemoveApplication method removes an application from the default organization.

Syntax

[C++]

HRESULT RemoveApplication(
    long lApplicationHandle
);

[Visual Basic]

object.RemoveApplication( _
    lApplicationHandle As Long _
)

Parameters

[C++]

lApplicationHandle

[in] Long that contains the handle.

[Visual Basic]

lApplicationHandle

Long that contains the handle.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This record cannot be removed if a BizTalkPort or a BizTalkChannel object refers to it.

The application handle can be obtained from the Applications property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkOrganization::SaveAlias Method [C++]

BizTalkOrganization.SaveAlias Method [Visual Basic]

The SaveAlias method saves an alias for the object. The alias for an object is the organization identifier type/value pair.

Syntax

[C++]

HRESULT SaveAlias(
    long lAliasHandle,
    BSTR strName,
    VARIANT_BOOL bDefault,
    BSTR strQualifier,
    BSTR strValue
);

[Visual Basic]

object.SaveAlias( _
    lAliasHandle As Long, _
    strName As String, _
    bDefault As Boolean, _
    strQualifier As String, _
    strValue As String _
)

Parameters

[C++]

lAliasHandle

[in] Long that contains the handle to the alias.

strName

[in] BSTR that contains the name of the organization identifier. This parameter cannot be changed if this alias was autogenerated.

bDefault

[in] VARIANT_BOOL type that contains the default flag. A value of VARIANT_TRUE indicates that this is the default alias for the organization. A value of VARIANT_FALSE indicates that this is not the default alias for the organization.

strQualifier

[in] BSTR that contains the qualifier of the organization identifier. This parameter cannot be changed if this alias was autogenerated. This parameter cannot be set to "group".

strValue

[in] BSTR that contains the value of the organization identifier. This parameter cannot be changed if this alias was autogenerated.

[Visual Basic]

lAliasHandle

Long that contains the handle to the alias.

strName

String that contains the name of the organization identifier. This parameter cannot be changed if this alias was autogenerated.

bDefault

Variant that contains the default flag. A value of True indicates that this is the default alias for the organization. A value of False indicates that this is not the default alias for the organization.

strQualifier

String that contains the qualifier of the organization identifier. This parameter cannot be changed if this alias was autogenerated. This parameter cannot be set to "group".

strValue

String that contains the value of the organization identifier. This parameter cannot be changed if this alias was autogenerated.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topic

Organizations


IBizTalkOrganization::SaveApplication Method [C++]

BizTalkOrganization.SaveApplication Method [Visual Basic]

The SaveApplication method saves this application for the default organization object.

Syntax

[C++]

HRESULT SaveApplication(
    long lApplicationHandle,
    BSTR strName
);

[Visual Basic]

object.SaveApplication( _
    lApplicationHandle As Long, _
    strName As String _
)

Parameters

[C++]

lApplicationHandle

[in] Long that contains the handle to the application.

strName

[in] BSTR that contains the name of the application.

[Visual Basic]

lApplicationHandle

Long that contains the handle to the application.

strName

String that contains the name of the application.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkPort Interface [C++]

BizTalkPort Object [Visual Basic]

The BizTalkPort object configures a one-way transfer of a document between organizations and applications. It identifies the source organization and/or application, the destination organization and/or application, the primary transport type, and, if selected, the associated envelope for transmission.

In C++, use the IBizTalkPort interface to access the methods of the BizTalkPort object.

The properties of the BizTalkPort object are shown in the following table.

Property | Type | Description
Channels | IDispatch | ADO recordset that contains information about all BizTalkChannel objects that refer to the object. This is a read-only property.
Comments | BSTR | User comments for the Port object.
ControlNumberValue | BSTR | Value of the interchange control number. This is a required property if the Format property of the associated BizTalkEnvelope object is set to "x12", "edifact", or "custom". This constraint is not enforced for this release, but the server fails if it is not adhered to.
DateModified | BSTR | Date and time at which the information in the object was created or last modified. This is a read-only property obtained from the BizTalkBase object.
Delimiters | IDispatch | Dictionary object that contains all delimiters used in the document specification. This is a required property if the Format property of the associated BizTalkEnvelope object is set to "x12", "edifact", or "custom".
DestinationEndpoint | IDispatch | Information about the destination.
EncodingType | BIZTALK_ENCODING_ TYPE | Enumeration value that indicates the type of document encoding.
EncryptionCertificateInfo | IDispatch | Information about the certificate that encrypts the document.
EncryptionType | BIZTALK_ENCRYPTION_ TYPE | Enumeration value that indicates the type of document encryption.
Envelope | long | Handle to the BizTalkEnvelope object associated with this BizTalkPort object.
Handle | long | Handle to the object. This is a read-only property obtained from the BizTalkBase object.
Name | BSTR | Name of the object. This is a required property obtained from the BizTalkBase object.
PrimaryTransport | IDispatch | Primary transport component information.
SecondaryTransport | IDispatch | Secondary transport component information.
ServiceWindowInfo | IDispatch | Service window information.
SignatureType | BIZTALK_SIGNATURE_ TYPE | Enumeration value that indicates the type of digital signing and verification.

The methods of the BizTalkPort object are shown in the following table.

Method | Description
Clear | Clears the object in memory. All the member variables of the object in memory are initialized to their default values. This method is obtained from the BizTalkBase object.
Create | Creates a new object in the database. This method is obtained from the BizTalkBase object.
Load | Loads the object in memory. This method is obtained from the BizTalkBase object
LoadByName | Loads the object by name in memory. This method is obtained from the BizTalkBase object.
Remove | Removes the object from the database. This method is obtained from the BizTalkBase object.
Save | Saves the object in the database. This method is obtained from the BizTalkBase object.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Document Processing

Messaging Ports


IBizTalkPort::Channels Property [C++]

BizTalkPort.Channels Property [Visual Basic]

The Channels property contains an ADO recordset that contains information about all BizTalkChannel objects that refer to the object.

Syntax

[C++]

Get method:

HRESULT get_Channels(
    IDispatch** ppChannelsDisp
);

[Visual Basic]

object.Channels

Parameters

[C++]

ppChannelsDisp

[out, retval] Address of a pointer to an IDispatch interface that contains the BizTalkChannel objects that refer to the object.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns an Object that contains the BizTalkChannel objects that refer to the object.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property.

Each record in the ADO recordset returned by this property contains information about the BizTalkChannel objects in the database that are associated with this BizTalkPort object. The fields in each record contain the following information, listed in order:

  • Handle

  • Name

  • A unique channel identifier, in GUID format.

Additional information about Microsoft ActiveX Data Objects is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkPort::Comments Property [C++]

BizTalkPort.Comments Property [Visual Basic]

The Comments property contains the user comments for the Port object.

Syntax

[C++]

Get method:

HRESULT get_Comments(
    BSTR* pstrComments
);

Put method:

HRESULT put_Comments(
    BSTR strComments
);

[Visual Basic]

object.Comments

Parameters

[C++]

Get method:

pstrComments

[out, retval] Pointer to a BSTR that contains the comments.

Put method:

strComments

[in] BSTR that contains the comments.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a String that contains the comments.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkPort::ControlNumberValue Property [C++]

BizTalkPort.ControlNumberValue Property [Visual Basic]

The ControlNumberValue property contains the value of the interchange control number.

Syntax

[C++]

HRESULT get_ControlNumberValue(
    BSTR* pstrControlNumberValue
);

Put method:

HRESULT put_ControlNumberValue(
    BSTR strControlNumberValue
);

[Visual Basic]

object.ControlNumberValue

Parameters

[C++]

Get method:

pstrControlNumberValue

[out, retval] Pointer to a BSTR that contains the interchange control number.

Put method:

strControlNumberValue

[in] BSTR that contains the interchange control number.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a String that contains the interchange control number.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

The ControlNumberValue property must contain a value between 1 and 999999999.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkPort::Delimiters Property [C++]

BizTalkPort.Delimiters Property [Visual Basic]

The Delimiters property contains a Dictionary object that contains all delimiters used in the document specification. Delimiters specifies which characters to use to separate data within the envelope and the documents that are sent using this envelope.

Syntax

[C++]

Get method:

HRESULT get_Delimiters(
    IDispatch** ppDelimitersDisp
);

Putref method:

HRESULT putref_Delimiters(
    IDispatch* pDelimitersDisp
);

[Visual Basic]

object.Delimiters

Parameters

[C++]

Get method:

ppDelimitersDisp

[out, retval] Address of a pointer to an IDispatch interface that contains the delimiters.

Putref method:

pDelimitersDisp

[in] Pointer to an IDispatch interface that contains the delimiters.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns an Object that contains the delimiters.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a required property for the object to be complete if the Format property of the associated BizTalkEnvelope object is set to "x12", "edifact", or "custom". The PropertySet property of the associated BizTalkDocument object must also be defined. The following table shows which names are required for the delimiters of the Dictionary object for various formats:

Delimiter | X12 | EDIFACT
Record_delim | Yes | Yes
Field_delim | Yes | Yes
Subfield_delim | Yes | Yes
Escape_char | No | Yes

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkPort::DestinationEndpoint Property [C++]

BizTalkPort.DestinationEndpoint Property [Visual Basic]

The DestinationEndpoint property contains information about the destination. This information includes the Alias, Application, and Organization properties and is created and stored in memory in the BizTalkEndPoint object.

Syntax

[C++]

Get method:

HRESULT get_DestinationEndpoint(
    IDispatch** ppDestEndpointDisp
);

Putref method:

HRESULT putref_DestinationEndpoint(
     IDispatch* pDestEndpointDisp
);

[Visual Basic]

object.DestinationEndpoint

Parameters

[C++]

Get method:

ppDestEndpointDisp

[out, retval] Address of a pointer to an IDispatch interface that contains information about the destination.

Putref method:

pDestEndpointDisp

[in] Pointer to an IDispatch interface that contains information about the destination.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns an Object that contains information about the destination.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

Once a BizTalkPort object has been created, the destination BizTalkOrganization object cannot be changed.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkPort::EncodingType Property [C++]

BizTalkPort.EncodingType Property [Visual Basic]

The EncodingType property contains the enumeration value that indicates the type of document encoding.

Syntax

[C++]

Get method:

HRESULT get_EncodingType(
    BIZTALK_ENCODING_TYPE* pEncodingType
);

Put method:

HRESULT put_EncodingType(
    BIZTALK_ENCODING_TYPE EncodingType
);

[Visual Basic]

object.EncodingType

Parameters

[C++]

Get method:

pEncodingType

[out, retval] Pointer to an enumeration value. Valid values are from the BIZTALK_ENCODING_TYPE enumeration.

Put method:

EncodingType

[in] When putting the property, an enumeration value. Valid values are from the BIZTALK_ENCODING_TYPE enumeration.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns an enumeration value. Valid values are from the BIZTALK_ENCODING_TYPE enumeration.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

The Clear method sets EncodingType to BIZTALK_ENCODING_TYPE_NONE.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkPort::EncryptionCertificateInfo Property [C++]

BizTalkPort.EncryptionCertificateInfo Property [Visual Basic]

The EncryptionCertificateInfo property contains information about the certificate that encrypts the document. This information includes the Name, Reference, Store, and Usage properties and is created and stored in memory in the BizTalkCertificateInfo object.

Syntax

[C++]

Get method:

HRESULT get_EncryptionCertificateInfo(
    IDispatch** ppEncryptionCertificateInfoDisp
);

Putref method:

HRESULT putref_EncryptionCertificateInfo(
    IDispatch* pEncryptionCertificateInfoDisp
);

[Visual Basic]

object.EncryptionCertificateInfo

Parameters

[C++]

Get method:

ppEncryptionCertificateInfoDisp

[out, retval] Address of a pointer to an IDispatch interface that contains the certificate information.

Putref method:

pEncryptionCertificateInfoDisp

[in] Pointer to an IDispatch interface that contains the certificate information.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns an Object that contains the certificate information.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkPort::EncryptionType Property [C++]

BizTalkPort.EncryptionType Property [Visual Basic]

The EncryptionType property contains the enumeration value that indicates the type of document encryption.

Syntax

[C++]

Get method:

HRESULT get_EncryptionType(
    BIZTALK_ENCRYPTION_TYPE* pEncryptionType
);

Put method:

HRESULT put_EncryptionType(
    BIZTALK_ENCRYPTION_TYPE EncryptionType
);

[Visual Basic]

object.EncryptionType

Parameters

[C++]

Get method:

pEncryptionType

[out, retval] Pointer to an enumeration value. Valid values are from the BIZTALK_ENCRYPTION_TYPE enumeration.

Put method:

EncryptionType

[in] Enumeration value. Valid values are from the BIZTALK_ENCRYPTION_TYPE enumeration.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns an enumeration value. Valid values are from the BIZTALK_ENCRYPTION_TYPE enumeration.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

The Clear method sets EncryptionType to BIZTALK_ENCRYPTION_TYPE_NONE.

If the EncryptionType is set to BIZTALK_ENCRYPTION_TYPE_SMIME, then the EncryptionCertificateInfo property must be set.

For open messaging ports, EncryptionType must be set to BIZTALK_ENCRYPTION_TYPE_NONE.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkPort::Envelope Property [C++]

BizTalkPort.Envelope Property [Visual Basic]

The Envelope property contains the handle to the associated BizTalkEnvelope object.

Syntax

[C++]

Get method:

HRESULT get_Envelope(
    long* plEnvelopeHandle
);

Put method:

HRESULT put_Envelope(
    long lEnvelopeHandle
);

[Visual Basic]

object.Envelope

Parameters

[C++]

Get method:

plEnvelopeHandle

[out, retval] Pointer to a long that contains the handle to the object.

Put method:

lEnvelopeHandle

[in] Long that contains the handle to the object.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a Long that contains the handle to the object.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topic

Envelopes


IBizTalkPort::PrimaryTransport Property [C++]

BizTalkPort.PrimaryTransport Property [Visual Basic]

The PrimaryTransport property contains the primary transport component information, including the Address, Parameter, and Type properties of the BizTalkTransportInfo object.

Syntax

[C++]

Get method:

HRESULT get_PrimaryTransport(
    IDispatch** ppTransportInfoDisp
);

Putref method:

HRESULT putref_PrimaryTransport(
    IDispatch* pTransportInfoDisp
);

[Visual Basic]

object.PrimaryTransport

Parameters

[C++]

Get method:

ppTransportInfoDisp

[out, retval] Address of a pointer to an IDispatch interface that contains the primary transport component information.

Putref method:

pTransportInfoDisp

[in] Pointer to an IDispatch interface that contains the primary transport component information.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns an Object that contains the primary transport component information.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a required property for the object.

The following constraints are enforced:

  • If the Openness property of the associated BizTalkEndPoint object is set to BIZTALK_OPENNESS_TYPE_EX_DESTINATION, the Address property cannot be set, and PrimaryTransport must be set to BIZTALK_TRANSPORT_TYPE_OPENDESTINATION. The BizTalkServiceWindowInfo object cannot be used with open destination ports.

  • Once a BizTalkPort object has been created, the Openness property of the associated BizTalkEndPoint object cannot be changed.

  • The Openness property cannot be set to BIZTALK_OPENNESS_TYPE_EX_SOURCE or BIZTALK_OPENNESS_TYPE_EX_FROMWORKFLOW.

  • When using a Type of BIZTALK_TRANSPORT_TYPE_LOOPBACK, the primary and secondary transport Address property cannot be set, and the BizTalkServiceWindowInfo object cannot be used.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkPort::SecondaryTransport Property [C++]

BizTalkPort.SecondaryTransport Property [Visual Basic]

The SecondaryTransport property contains the secondary transport component information, including the Address, Parameter, and Type properties, and is created and stored in memory in the BizTalkTransportInfo object.

Syntax

[C++]

Get method:

HRESULT get_SecondaryTransport(
    IDispatch** ppTransportInfoDisp
);

Putref method:

HRESULT putref_SecondaryTransport(
    IDispatch* pTransportInfoDisp
);

[Visual Basic]

object.SecondaryTransport

Parameters

[C++]

Get method:

ppTransportInfoDisp

[out, retval] Address of a pointer to an IDispatch interface that contains the secondary transport component information.

Putref method:

pTransportInfoDisp

[in] Pointer to an IDispatch interface that contains the secondary transport component information.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This method returns an Object that contains the secondary transport component information.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a required property for the object to be complete.

The following constraints are enforced:

  • If the Openness property of the associated BizTalkEndPoint object is set to BIZTALK_OPENNESS_TYPE_EX_DESTINATION, the Address property cannot be set, and SecondaryTransport must be set to BIZTALK_TRANSPORT_TYPE_OPENDESTINATION.

  • Once a BizTalkPort object has been created, the Openness property of the associated BizTalkEndPoint object cannot be changed.

  • The Openness property cannot be set to BIZTALK_OPENNESS_TYPE_EX_SOURCE or BIZTALK_OPENNESS_TYPE_EX_FROMWORKFLOW.

  • The Type property cannot be set to BIZTALK_TRANSPORT_TYPE_LOOPBACK.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkPort::ServiceWindowInfo Property [C++]

BizTalkPort.ServiceWindowInfo Property [Visual Basic]

The ServiceWindowInfo property contains information about the service window. This information includes the FromTime, IsEnabled, and ToTime properties and is created and stored in memory in the BizTalkServiceWindowInfo object.

Syntax

[C++]

Get method:

HRESULT get_ServiceWindowInfo(
    IDispatch** ppServiceWindowInfoDisp
);

Putref method:

HRESULT putref_ServiceWindowInfo(
    IDispatch* pServiceWindowInfoDisp
);

[Visual Basic]

object.ServiceWindowInfo

Parameters

[C++]

Get method:

ppServiceWindowInfoDisp

[out, retval] Address of a pointer to an IDispatch interface that contains the service window.

Putref method:

pServiceWindowInfoDisp

[in] Pointer to an IDispatch interface that contains the service window.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This method returns an Object that contains information about the service window.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

If this property is used, the BizTalkServiceWindowInfo object must specify a valid time range by using the FromTime and ToTime properties.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkPort::SignatureType Property [C++]

BizTalkPort.SignatureType Property [Visual Basic]

The SignatureType property contains the enumeration value that indicates the type of digital signing and verification.

Syntax

[C++]

Get method:

HRESULT get_SignatureType(
    BIZTALK_SIGNATURE_TYPE* pSignatureType
);

Put method:

HRESULT put_SignatureType(
    BIZTALK_SIGNATURE_TYPE SignatureType
);

[Visual Basic]

object.SignatureType

Parameters

[C++]

Get method:

pSignatureType

[out, retval] Pointer to an enumeration value. Valid values are from the BIZTALK_SIGNATURE_TYPE enumeration.

Put method:

SignatureType

[in] Enumeration value. Valid values are from the BIZTALK_SIGNATURE_TYPE enumeration.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns an enumeration value. Valid values are from the BIZTALK_SIGNATURE_TYPE enumeration.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

The Clear method sets SignatureType to BIZTALK_SIGNATURE_TYPE_NONE.

BizTalkPort objects associated with open channels cannot have a SignatureType.

If the SignatureType on a BizTalkPort object is changed from BIZTALK_SIGNATURE_TYPE_NONE to BIZTALK_SIGNATURE_TYPE_SMIME, all channels associated with this BizTalkPort object must have already been saved with a SignatureCertificateInfo object. Also, if a BizTalkChannel contains a SignatureCertificateInfo object and the SignatureType of the BizTalkPort is set to BIZTALK_SIGNATURE_TYPE_NONE, the signature will be ignored.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkPortGroup Interface [C++]

BizTalkPortGroup Object [Visual Basic]

Use the BizTalkPortGroup object to configure port groups that are used to distribute the same document to many organizations.

In C++, use the IBizTalkPortGroup interface to access the methods of the BizTalkPortGroup object.

The properties of the BizTalkPortGroup object are shown in the following table.

Property | Type | Description
Channels | IDispatch | ADO recordset that contains information about all BizTalkChannel objects that refer to this object.
DateModified | BSTR | Date and time at which the information in the object was created or last modified. This is a read-only property obtained from the BizTalkBase object.
Handle | long | Handle to the object. This is a read-only property obtained from the BizTalkBase object.
Name | BSTR | Name of the object. This is a required property obtained from the BizTalkBase object.
Ports | IDispatch | ADO recordset that contains information about all BizTalkPort objects that refer to this object.

The methods of the BizTalkPortGroup object are shown in the following table.

Method | Description
AddPort | Adds a BizTalkPort object to this port group. There must be at least one BizTalkPort object in the port group.
Clear | Clears the object in memory. All member variables of the object in memory are initialized to their default values. This method is obtained from the BizTalkBase object.
Create | Creates a new object in the database. This method is obtained from the BizTalkBase object.
Load | Loads the object in memory. This method is obtained from the BizTalkBase object.
LoadByName | Loads the object by name in memory. This method is obtained from the BizTalkBase object.
Remove | Removes the BizTalkPortGroup object from the database. This method is obtained from the BizTalkBase object.
RemovePort | Removes a BizTalkPort object from the port group. There must be at least one BizTalkPort object in the port group.
Save | Saves the object in the database. This method is obtained from the BizTalkBase object.

Remarks

There must always be at least one BizTalkPort object and one BizTalkChannel object associated with a BizTalkPortGroup object. The BizTalkChannel object is associated with the BizTalkPortGroup object, not the BizTalkPort object within the group. Each BizTalkPort object within the group has another BizTalkChannel object or objects associated with it, but these are ignored when the port group channel is invoked.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topic

Port Groups


IBizTalkPortGroup::AddPort Method [C++]

BizTalkPortGroup.AddPort Method [Visual Basic]

The AddPort method adds a BizTalkPort object to this port group.

Syntax

[C++]

HRESULT AddPort(
    long lPortHandle
);

[Visual Basic]

object.AddPort( _
    lPortHandle As Long _
)

Parameters

[C++]

lPortHandle

[in] Long that contains the handle to the object.

[Visual Basic]

lPortHandle

Long that contains the handle to the object.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

The following constraints apply to this method:

  • There must be at least one BizTalkPort in this BizTalkPortGroup object.

  • The Openness property of the associated BizTalkEndPoint object to be added must be set to BIZTALK_OPENNESS_TYPE_NOTOPEN.

  • The port group specified by this object cannot contain any duplicate BizTalkPort objects.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkPortGroup::Channels Property [C++]

BizTalkPortGroup.Channels Property [Visual Basic]

The Channels property contains an ADO recordset that contains information about all BizTalkChannel objects that refer to the object.

Syntax

[C++]

Get method:

HRESULT get_Channels(
    IDispatch** ppChannelsDisp
);

[Visual Basic]

object.Channels

Parameters

[C++]

ppChannelsDisp

[out, retval] Address of a pointer to an IDispatch interface that contains an ADO recordset that contains all BizTalkChannel objects that refer to the object.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

Note

  • In addition to the HRESULT values listed on the error messages page, this method returns OLEDB provider errors. Additional information about OLEDB is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.
[Visual Basic]

This property returns an Object that contains all BizTalkChannel objects that refer to the object.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

Each record in the ADO recordset returned by this property contains information about the BizTalkChannel objects in the database that are associated with this BizTalkPortGroup object. The fields in each record contain the following information, listed in order:

  • Handle

  • Name

Additional information about Microsoft ActiveX Data Objects is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkPortGroup::Ports Property [C++]

BizTalkPortGroup.Ports Property [Visual Basic]

The Ports property contains an ADO recordset that contains information about all BizTalkPort objects that refer to the object.

Syntax

[C++]

Get method:

HRESULT Ports(
    IDispatch** ppPortsDisp
);

[Visual Basic]

object.Ports

Parameters

[C++]

ppPortsDisp

[out, retval] Address of a pointer to an IDispatch interface that contains an ADO recordset that contains all BizTalkPort objects that refer to the object.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

Note

  • In addition to the HRESULT values listed on the error messages page, this method returns OLEDB provider errors. Additional information about OLEDB is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.
[Visual Basic]

This property returns an Object that contains all BizTalkPort objects that refer to the object.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

Each record in the ADO recordset returned by this property contains information about the BizTalkPort objects in the database that are associated with this BizTalkPortGroup object. The fields in each record contain the following information, listed in order:

  • Handle

  • Name

Additional information about Microsoft ActiveX Data Objects is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkPortGroup::RemovePort Method [C++]

BizTalkPortGroup.RemovePort Method [Visual Basic]

The RemovePort method removes a BizTalkPort object from this port group.

Syntax

[C++]

HRESULT RemovePort(
    long lPortHandle
);

[Visual Basic]

object.RemovePort( _
    lPortHandle As Long _

)

Parameters

[C++]

lPortHandle

[in] Long that contains the handle to the object to remove.

[Visual Basic]

lPortHandle

Long that contains the handle to the object to remove.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

Note

  • In addition to the HRESULT values listed on the error messages page, this method returns OLEDB provider errors. Additional information about OLEDB is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.
[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

The last BizTalkPort object associated with the object cannot be removed. A BizTalkPort object cannot be removed if a BizTalkChannel object refers to it.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkServiceWindowInfo Interface [C++]

BizTalkServiceWindowInfo Object [Visual Basic]

Use the BizTalkServiceWindowInfo object to configure the service window for an associated BizTalkPort object. The service window indicates a valid time range for transmitting documents.

In C++, use the IBizTalkServiceWindowInfo interface to access the methods of the BizTalkServiceWindowInfo object.

The properties of the BizTalkServiceWindowInfo object are shown in the following table.

Property | Type | Description
FromTime | BSTR | Earliest time that the interchange can be transmitted.
IsEnabled | VARIANT_BOOL | Flag that indicates whether the service window is enabled.
ToTime | BSTR | Latest time that the interchange can be transmitted.

Remarks

The BizTalkServiceWindowInfo object is automatically created when a BizTalkPort object is instantiated with the CreatePort method of the BizTalkConfig object. Access the properties of the BizTalkServiceWindowInfo object by using the ServiceWindowInfo property of the BizTalkPort object.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkServiceWindowInfo::FromTime Property [C++]

BizTalkServiceWindowInfo.FromTime Property [Visual Basic]

The FromTime property indicates the earliest hour of any day that the interchange can be transmitted.

Syntax

[C++]

Get method:

HRESULT get_FromTime(
    BSTR* pstrFromTime
);

Put method:

HRESULT put_FromTime(
    BSTR strFromTime
);

[Visual Basic]

object.FromTime

Parameters

[C++]

Get method:

pstrFromTime

[out, retval] Pointer to a BSTR that contains the earliest time that the interchange can be transmitted.

Put method:

strFromTime

[in] BSTR that contains the earliest time that the interchange can be transmitted.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a String that contains the earliest time that the interchange can be transmitted.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

The FromTime property must contain an integer value between 0 and 23. Fractional values and minutes cannot be specified.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkServiceWindowInfo::IsEnabled Property [C++]

BizTalkServiceWindowInfo.IsEnabled Property [Visual Basic]

The IsEnabled property indicates whether a service window is enabled.

Syntax

[C++]

Get method:

HRESULT get_IsEnabled(
    VARIANT_BOOL* pbIsEnabled
);

Put method:

HRESULT put_IsEnabled(
    VARIANT_BOOL bIsEnabled
);

[Visual Basic]

object.IsEnabled

Parameters

[C++]

Get method:

pbIsEnabled

[out, retval] Pointer to a VARIANT_BOOL type that indicates whether a service window is enabled. A value of VARIANT_TRUE indicates that the service window is enabled. A value of VARIANT_FALSE indicates that the service window is not enabled.

Put method:

bIsEnabled

[in] VARIANT_BOOL type that indicates whether a service window is enabled. A value of VARIANT_TRUE indicates that the service window is enabled. A value of VARIANT_FALSE indicates that the service window is not enabled.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a String that indicates whether a service window is enabled. A value of True indicates that the service window is enabled. A value of False indicates that the service window is not enabled.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkServiceWindowInfo::ToTime Property [C++]

BizTalkServiceWindowInfo.ToTime Property [Visual Basic]

The ToTime property contains the latest hour of any day that the interchange can be transmitted.

Syntax

[C++]

Get method:

HRESULT get_ToTime(
    BSTR* pstrToTime
);

Put method:

HRESULT put_ToTime(
    BSTR strToTime
);

[Visual Basic]

object.ToTime

Parameters

[C++]

Get method:

pstrToTime

[out, retval] Pointer to a BSTR that contains the latest time that the interchange can be transmitted.

Put method:

strToTime

[in] BSTR that contains the latest time that the interchange can be transmitted.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a String that contains the latest time that the interchange can be transmitted.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

The ToTime property must contain an integer value between 0 and 23. Fractional values and minutes cannot be specified.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkTransportInfo Interface [C++]

BizTalkTransportInfo Object [Visual Basic]

Use the BizTalkTransportInfo object to configure the transport service for an associated BizTalkPort object.

In C++, use the IBizTalkTransportInfo interface to access methods of the BizTalkTransportInfo object.

The properties of the BizTalkTransportInfo object are shown in the following table.

Property | Type | Description
Address | BSTR | Destination address of the primary transport component.
Parameter | BSTR | Required return e-mail address for the associated source BizTalkOrganization object if the Type property is BIZTALK_TRANSPORT_ TYPE_SMTP.
Type | BIZTALK_TRANSPORT_ TYPE | Enumeration value that indicates the type of transport component to be used for the primary transport.

Remarks

The BizTalkTransportInfo object is automatically created when a BizTalkPort object is instantiated with the CreatePort method of the BizTalkConfig object. Access the BizTalkTransportInfo object by using the PrimaryTransport or SecondaryTransport property of the BizTalkPort object.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkTransportInfo::Address Property [C++]

BizTalkTransportInfo.Address Property [Visual Basic]

The Address property contains the destination address.

Syntax

[C++]

Get method:

HRESULT get_Address(
    BSTR* pstrTransportAddress
);

Put method:

HRESULT put_Address(
    BSTR strTransportAddress
);

[Visual Basic]

object.Address

Parameters

[C++]

Get method:

pstrTransportAddress

[out, retval] Pointer to a BSTR that contains the address.

Put method:

strTransportAddress

[in] BSTR that contains the address.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a String that contains the address.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

If the Openness property of the associated BizTalkEndPoint object is set to BIZTALK_OPENNESS_TYPE_DESTINATION, Address cannot be set, and the Type property must be set to BIZTALK_TRANSPORT_TYPE_OPENDESTINATION.

Address must have one of the following prefixes, according to the Type property:

Transport type | Prefix | Example Address value
APPINTEGRATION | Not applicable | {11111111-1111-1111-1111-111111111111}
FILE | file:// | file://C:\Test\MyFile.xml
HTTP | http:// | http://www.vigorair-18.com/repository/bts.asp
HTTPS | https:// | https://www.vigorair-18.com/secure/btss.asp
LOOPBACK | Not applicable | Not applicable
MSMQ | Not applicable | DIRECT=OS:.\private$\myqueue
NONE | Not applicable | Not applicable
OPENDESTINATION | Not applicable | Not applicable
ORCHESTRATIONACTIVATION | Not applicable | C:\XLANG\Schedules\mysched.skx
SMTP | mailto: | mailto:patricia@vigorair-18.com

Notes

  • The queue:// prefix must be used with an open messaging port when a Message Queue is specified as the destination address. For open messaging ports, the address is specified either in the document instance or as a parameter when submitting the document. For more information, see Routing.

  • When using the Orchestration Activation Component transport type, the Address property must contain the full path of the XLANG schedule on the local computer. The file:// prefix cannot be used when specifying the path of the XLANG schedule (.skx) file.

  • When using the HTTP or HTTPS transport types, BizTalk Server sends the data using a proxy server by default. This is the correct setting to transport data to computers outside of your company's firewall. However, when sending data within your company's intranet, you can bypass the use of a proxy server. To do this, you must set the UseProxy field to False in the transport dictionary. For more information, see SetConfigData.

When using the file:// transport type, you can include symbols to modify the file name. The file name created by the server contains any static characters you specified in the Address property, along with the actual value of the symbol. For example, if the Address property is set to "file://C:\Orders\Invoice_%tracking_id%.xml", the actual file name would use a format similar to: C:\Orders\Invoice_{12345678-90AB-CDEF-1234-567890ABCDEF}. The following table contains the symbols that can be used with the file:// transport type:

Symbol | Description | Unique file name
%datetime% | Date and time, in milliseconds, of the file creation. The time is based on Greenwich Mean Time (GMT) rather than local time. | No
%document_name% | Name of the document processed by BizTalk Server. | No
%server% | Host name of the server that processed the document. | No
%tracking_id% | Globally unique tracking number. | Yes
%uid% | Counter that increases over time, represented in milliseconds. This number is reset when the server is rebooted. | No

When sending reliable messaging receipts that use the SMTP transport protocol, the value specified in the identifier named Reliable Messaging Acknowledgement SMTP From Address is used as the From address. This identifier is automatically created for the default BizTalkOrganization object. This identifier cannot be removed. You should not modify the name or qualifier for this identifier, but you can modify the value. For more information, see Processing Receipts Using Reliable Messaging.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkTransportInfo::Parameter Property [C++]

BizTalkTransportInfo.Parameter Property [Visual Basic]

The Parameter property contains the required return e-mail address of the associated source BizTalkOrganization object if the Type property is set to BIZTALK_TRANSPORT_TYPE_SMTP.

Syntax

[C++]

Get method:

HRESULT get_Parameter(
    BSTR* pstrPrimaryTransportParameter
);

Put method:

HRESULT put_Parameter(
    BSTR strPrimaryTransportParameter
);

[Visual Basic]

object.Parameter

Parameters

[C++]

Get method:

pstrPrimaryTransportParameter

[out, retval] Pointer to a BSTR that contains the address.

Put method:

strPrimaryTransportParameter

[in] BSTR that contains the address.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a String that contains the address.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkTransportInfo::Type Property [C++]

BizTalkTransportInfo.Type Property [Visual Basic]

The Type property contains the enumeration value that indicates the type of transport component.

Syntax

[C++]

Get method:

HRESULT get_Type(
    BIZTALK_TRANSPORT_TYPE* pTransportType
);

Put method:

HRESULT put_Type(
    BIZTALK_TRANSPORT_TYPE TransportType
);

[Visual Basic]

object.Type

Parameters

[C++]

Get method:

pTransportType

[out, retval] Pointer to an enumeration value. Valid values are from the BIZTALK_TRANSPORT_TYPE enumeration.

Put method:

TransportType

[in] Enumeration value. Valid values are from the BIZTALK_TRANSPORT_TYPE enumeration.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns an enumeration value. Valid values are from the BIZTALK_TRANSPORT_TYPE enumeration.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

The following constraints are enforced:

  • If the Openness property of the associated BizTalkEndPoint object is set to BIZTALK_OPENNESS_TYPE_DESTINATION, the Address property cannot be set, and Type must be set to BIZTALK_TRANSPORT_TYPE_OPENDESTINATION.

When using the Message Queuing transport type (BIZTALK_TRANSPORT_TYPE_MSMQ), the following restrictions apply:

  • When using an envelope, the maximum size of a document submitted to BizTalk Server is 4MB.

  • When an envelope is not used, the maximum size of a document submitted to BizTalk Server is 2MB.

  • When using the BIZTALK_TRANSPORT_TYPE_SMTP, the Parameter property must be set to the reply-to SMTP address.

  • The transport Type of BIZTALK_TRANSPORT_TYPE_ORCHESTRATIONACTIVATION is supported only when the Openness property of the associated BizTalkEndPoint object is set to BIZTALK_OPENNESS_TYPE_TOWORKFLOW.

  • When using the Orchestration activation component type (BIZTALK_TRANSPORT_TYPE_ORCHESTRATIONACTIVATION), the maximum size of a document sent to the port on the XLANG schedule is 2MB.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IDictionary Interface [C++]

CDictionary Object [Visual Basic]

The Dictionary object is a collection object that supports the creation, storage, and retrieval of name/value pairs in memory. This object is used by several methods in the BizTalk Messaging Configuration object model.

In C++, use the IDictionary interface to access the methods of the Dictionary object. In Microsoft Visual Basic, the CDictionary class defines the methods and properties of a Dictionary object.

The properties of the Dictionary object are shown in the following table.

Property | Type | Description
Count | long | Number of entries in the Dictionary object. This is a read-only property.
NewEnum | IUnknown | Returns the IUnknown interface pointer for the Dictionary object. The caller can use this interface pointer to call QueryInterface for the enumerator for this object. This is a read-only property.
Prefix | BSTR | Filter that excludes all entries with a specific prefix when the contents of the Dictionary object are saved.
Value | VARIANT | Value associated with an entry name.

The methods of the Dictionary object are shown in the following table.

Method | Description
GetMultiple | Returns the values of multiple entries from the Dictionary object.
PutMultiple | Adds specified entries to the Dictionary object or changes them.

Remarks

A Dictionary object is designed to be a general-purpose collection. Therefore, it can be used for anything that is supported by its internal structure. Every value in a Dictionary object is a Variant. This means that a Dictionary object can be created that consists of almost any kind of value (including other Dictionary objects).

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include commerce.h
Library: Use Microsoft Commerce 2000 Core Components Type Library (MscsCore.dll)


IDictionary::Count Property [C++]

CDictionary.Count Property [Visual Basic]

The Count property returns the number of elements in the Dictionary object.

Syntax

[C++]

HRESULT get_Count(
    long* Count
);

[Visual Basic]

object.Count

Parameters

[C++]

Count

[out, retval] Long used to return the count.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a Long that contains the count.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This property is read-only.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include commerce.h
Library: Use Microsoft Commerce 2000 Core Components Type Library (MscsCore.dll)


IDictionary::GetMultiple Method [C++]

CDictionary.GetMultiple Method [Visual Basic]

The GetMultiple method returns multiple entries from the Dictionary object.

Syntax

[C++]

HRESULT GetMultiple(
    long cb,
    const LPOLESTR rgolestr[],
    VARIANT rgvar[]
);

[Visual Basic]

object.GetMultiple( _
    cb As Long, _
    rgolestr As String, _
    rgvar As Variant _
)

Parameters

[C++]

cb

[in] Long that specifies the number of values to retrieve.

rgolestr

[in, size_is(cb)] Array of string values that identifies the Dictionary object entries for which the values should be retrieved.

rgvar

[out, size_is(cb)] Array of VARIANTs. When GetMultiple returns, this array contains the values associated with the Dictionary object entries identified by the rgolestr[] array.

[Visual Basic]

cb

Long that specifies the number of values to retrieve.

rgolestr

Array of string values that identifies the CDictionary object entries for which the values should be retrieved.

rgvar

Array of Variants. When GetMultiple returns, this array contains the values associated with the CDictionary object entries identified by the rgolestr array.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

If you call PutMultiple or GetMultiple from Microsoft Visual Basic Scripting Edition (VBScript), these methods fail because they require data types that VBScript does not support.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include commerce.h
Library: Use Microsoft Commerce 2000 Core Components Type Library (MscsCore.dll)


IDictionary::NewEnum Property [C++]

CDictionary.NewEnum Property [Visual Basic]

[C++]

The NewEnum property retrieves an Enumerator object that implements the IEnumVariant interface of the Dictionary object.

[Visual Basic]

This property is not available in Microsoft Visual Basic.

Syntax

[C++]

Get method:

HRESULT get_NewEnum(
    IUnknown** _NewEnum
);

[Visual Basic]

Not applicable

Parameters

[C++]

_NewEnum

[out, retval] Address of a pointer to an IUnknown interface for an object that implements the IEnumVariant of this collection. You can call QueryInterface through the returned pointer to retrieve a pointer to the IEnumVariant for this object. To retrieve the values associated with these elements, you can retrieve the elements in turn, using the Next method of the IEnumVariant interface, and call the Value method on those elements.

[Visual Basic]

Not applicable

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

Not applicable

Error Value [Visual Basic]

[Visual Basic]

Not applicable

Remarks

[C++]

This property is read-only.

[Visual Basic]

Not applicable

Requirements

[C++]

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include commerce.h

[Visual Basic]

Not applicable


IDictionary::Prefix Property [C++]

CDictionary.Prefix Property [Visual Basic]

The Prefix property contains a filter that excludes entries with a specific prefix when the contents of the Dictionary object are saved.

Syntax

[C++]

Get method:

HRESULT get_Prefix(
    BSTR* Prefix
);

Put method:

HRESULT put_Prefix(
    BSTR Prefix
);

[Visual Basic]

object.Prefix

Parameters

[C++]

Get method:

Prefix

[out, retval] Pointer to a BSTR that contains the prefix.

Put method:

Prefix

[in] BSTR that contains the prefix.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a String that contains the prefix.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

Any name/value pair with a name beginning with the specified prefix is not saved to the database. The prefix default is an underscore (_). Therefore, any keywords that begin with an underscore are not saved unless the prefix is changed.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include commerce.h
Library: Use Microsoft Commerce 2000 Core Components Type Library (MscsCore.dll)


IDictionary::PutMultiple Method [C++]

CDictionary.PutMultiple Method [Visual Basic]

The PutMultiple method adds specified entries to the Dictionary object or changes them.

Syntax

[C++]

HRESULT PutMultiple(
    long cb,
    const LPOLESTR rgolestr[],
    const VARIANT rgvar[]
);

[Visual Basic]

object.PutMultiple( _
    cb As Long, _
    rgolestr As String, _
    rgvar As Variant _
)

Parameters

[C++]

cb

[in] Long that identifies the number of elements in the rgolestr and rgvar arrays.

rgolestr

[in, size_is(cb)] Array of strings that contains the names to add to the Dictionary object.

rgvar

[in, size_is(cb)] Array of VARIANTs that contains the values to add to the Dictionary object.

[Visual Basic]

cb

Long that identifies the number of elements in the rgolestr and rgvar arrays.

rgolestr

Array of Strings that contains the names to add to the CDictionary object.

rgvar

Array of Variants that contains the values to add to the CDictionary object.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

A one-to-one mapping exists between the elements of the rgolestr and rgvar arrays. This means that rgolestr[n] is added to the Dictionary object and is initialized to rgvar[n]. If the element specified by rgolestr[n] is already in the Dictionary object, the value associated with the element is overwritten with the value stored in rgvar[n].

[Visual Basic]

If you call PutMultiple or GetMultiple from Microsoft Visual Basic Scripting Edition (VBScript), these methods fail because they require data types that VBScript does not support.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include commerce.h
Library: Use Microsoft Commerce 2000 Core Components Type Library (MscsCore.dll)


IDictionary::Value Property [C++]

CDictionary.Value Property [Visual Basic]

The Value property returns or sets the value associated with an entry name.

Syntax

[C++]

Get method:

HRESULT get_Value(
    BSTR bstrName,
    VARIANT* Value
);

Put method:

HRESULT put_Value(
    BSTR bstrName,
    VARIANT Value
);

[Visual Basic]

object.Value( _
    bstrName As String _
)

Parameters

[C++]

Get method:

bstrName

[in] BSTR that contains the name.

Value

[out, retval] Pointer to a VARIANT used to return the value.

Put method:

bstrName

[in] BSTR that contains the name.

Value

[in] When putting the property, a VARIANT that contains the value.

[Visual Basic]

bstrName

String that contains the name.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property optionally returns a Variant that contains the value.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

The value of a Dictionary object can be read or written to without explicitly using the Value method by treating the named entry as a property of the Dictionary object.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include commerce.h
Library: Use Microsoft Commerce 2000 Core Components Type Library (MscsCore.dll)


ISimpleList Interface [C++]

CSimpleList Object [Visual Basic]

Use the SimpleList object to create an array of variants that supports enumeration.

In C++, use the ISimpleList interface to access methods of the SimpleList object. In Microsoft Visual Basic, the CSimpleList class defines the methods and properties of a SimpleList object.

The properties of the SimpleList object are shown in the following table.

Property | Type | Description
Count | long | Number of elements in the SimpleList object. This is a read-only property.
Item | VARIANT | Container for an element of the SimpleList object.

The methods of the SimpleList object are shown in the following table.

Method | Description
Add | Adds the specified item to the SimpleList object.
Delete | Deletes the specified item from the SimpleList object.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include commerce.h
Library: Use Microsoft Commerce 2000 Core Components Type Library (MscsCore.dll)


ISimpleList::Add Method [C++]

CSimpleList.Add Method [Visual Basic]

The Add method adds the specified item to the SimpleList object.

Syntax

[C++]

HRESULT Add(
    VARIANT* pVar
);

[Visual Basic]

object.Add( _
    pVar As Variant _
)

Parameters

[C++]

pVar

[in] Pointer to the VARIANT to add to the SimpleList object.

[Visual Basic]

pVar

Variant to add to the CSimpleList object.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include commerce.h
Library: Use Microsoft Commerce 2000 Core Components Type Library (MscsCore.dll)


ISimpleList::Count Property [C++]

CSimpleList.Count Property [Visual Basic]

The Count property returns the number of elements in the SimpleList object.

Syntax

[C++]

Get method:

HRESULT get_Count(
    long* Count
);

[Visual Basic]

object.Count

Parameters

[C++]

Count

[out, retval] Pointer to a long used to return the number of items in the SimpleList object.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a Long that contains the number of items in the CSimpleList object.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This property is read-only.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include commerce.h
Library: Use Microsoft Commerce 2000 Core Components Type Library (MscsCore.dll)


ISimpleList::Delete Method [C++]

CSimpleList.Delete Method [Visual Basic]

The Delete method deletes the specified item from the SimpleList object.

Syntax

[C++]

HRESULT Delete(
    long Index
);

[Visual Basic]

object.Delete( _
    Index As Long _
)

Parameters

[C++]

Index

[in] Long that contains the index value of the item to delete.

[Visual Basic]

Index

Long that contains the index value of the item to delete.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include commerce.h
Library: Use Microsoft Commerce 2000 Core Components Type Library (MscsCore.dll)


ISimpleList::Item Property [C++]

CSimpleList.Item Property [Visual Basic]

The Item property is a read/write Variant that contains an element of the SimpleList object. An initialized Variant is stored at a specified array index. If an item is already stored at the specified index, that item is overwritten by the put method.

Syntax

[C++]

Get method:

HRESULT get_Item(
    long Index
    VARIANT* Item
);

Put method:

HRESULT put_Item(
    long Index,
    VARIANT Item
);

Putref method:

HRESULT putref_Item(
    long Index,
    VARIANT Item
);

[Visual Basic]

object.Item( _
    Index As Long _
)

Parameters

[C++]

Get method:

Index

[in] Long that contains the index of the item.

Item

[out, retval] Pointer to a VARIANT used to return the item.

Put and Putref methods:

Index

[in] Long that contains the index of the item.

Item

[in] VARIANT that contains the new item.

[Visual Basic]

Index

Long that contains the index of the item.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a Variant that contains the new item.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

When putting a value, use the putref_Item method if you are setting an object reference; use the put_Item method if you are setting a scalar value.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include commerce.h
Library: Use Microsoft Commerce 2000 Core Components Type Library (MscsCore.dll)


Object Model Enumerations

The following enumerations provide possible values of properties and parameters:

  • BIZTALK_ENCODING_TYPE

  • BIZTALK_ENCRYPTION_TYPE

  • BIZTALK_OPENNESS_TYPE

  • BIZTALK_OPENNESS_TYPE_EX

  • BIZTALK_SIGNATURE_TYPE

  • BIZTALK_STORE_TYPE

  • BIZTALK_TRANSPORT_TYPE

  • BIZTALK_USAGE_TYPE

  • BIZTALK_CONFIGDATA_TYPE


BIZTALK_ENCODING_TYPE

The BIZTALK_ENCODING_TYPE enumeration has one of the following values:

Name | Value | Description
BIZTALK_ENCODING_TYPE_NONE | 1 | Specifies that encoding is not used.
BIZTALK_ENCODING_TYPE_MIME | 2 | Specifies Multipurpose Internet Mail Extensions (MIME) encoding.
BIZTALK_ENCODING_TYPE_CUSTOM | 3 | Specifies custom encoding.


BIZTALK_ENCRYPTION_TYPE

The BIZTALK_ENCRYPTION_TYPE enumeration has one of the following values:

Name | Value | Description
BIZTALK_ENCRYPTION_TYPE_NONE | 1 | Specifies that encryption is not used.
BIZTALK_ENCRYPTION_TYPE_CUSTOM | 2 | Specifies custom encryption.
BIZTALK_ENCRYPTION_TYPE_SMIME | 4 | Specifies Secure Multipurpose Internet Mail Extensions (S/MIME) encryption.


BIZTALK_OPENNESS_TYPE

The BIZTALK_OPENNESS_TYPE enumeration has one of the following values:

Name | Value | Description
BIZTALK_OPENNESS_TYPE_NOTOPEN | 1 | Specifies that this instance of the object is not open.
BIZTALK_OPENNESS_TYPE_SOURCE | 2 | Specifies that the source organization of this instance of the object is open.
BIZTALK_OPENNESS_TYPE_DESTINATION | 4 | Specifies that the destination organization of this instance of the object is open.


BIZTALK_OPENNESS_TYPE_EX

The BIZTALK_OPENNESS_TYPE_EX enumeration has one of the following values:

Name | Value | Description
BIZTALK_OPENNESS_TYPE_EX_NOTOPEN | 1 | Specifies that this instance of the object is not open.
BIZTALK_OPENNESS_TYPE_EX_SOURCE | 2 | Specifies that the source organization of this instance of the object is open.
BIZTALK_OPENNESS_TYPE_EX_DESTINATION | 4 | Specifies that the destination organization of this instance of the object is open.
BIZTALK_OPENNESS_TYPE_EX_FROMWORKFLOW | 8 | Specifies that BizTalk Server is receiving a document from an XLANG schedule instance.
BIZTALK_OPENNESS_TYPE_EX_TOWORKFLOW | 16 | Specifies that BizTalk Server is sending a document to an XLANG schedule instance.


BIZTALK_SIGNATURE_TYPE

The BIZTALK_SIGNATURE_TYPE enumeration has one of the following values:

Name | Value | Description
BIZTALK_SIGNATURE_TYPE_NONE | 1 | Specifies that there is no signature.
BIZTALK_SIGNATURE_TYPE_CUSTOM | 2 | Specifies the custom signature of the document.
BIZTALK_SIGNATURE_TYPE_SMIME | 4 | Specifies the S/MIME signature of the document.


BIZTALK_STORE_TYPE

The BIZTALK_STORE_TYPE enumeration has one of the following values:

Name | Value | Description
BIZTALK_STORE_TYPE_MY | 1 | Specifies that the certificate store is type MY. This store contains certificates authorized only by your organization.
BIZTALK_STORE_TYPE_BIZTALK | 2 | Specifies that the certificate is stored in the dedicated BizTalk Server 2000 store.


BIZTALK_TRANSPORT_TYPE

The BIZTALK_TRANSPORT_TYPE enumeration has one of the following values:

Name | Value | Description
BIZTALK_TRANSPORT_TYPE_NONE | 1 | Specifies that this instance of the object does not select a transport component.
BIZTALK_TRANSPORT_TYPE_HTTP | 4 | Specifies that this instance of the object selects a Hypertext Transport Protocol (HTTP) transport component.
BIZTALK_TRANSPORT_TYPE_SMTP | 8 | Specifies that this instance of the object selects a Simple Mail Transfer Protocol (SMTP) transport component.
BIZTALK_TRANSPORT_TYPE_ APPINTEGRATION | 32 | Specifies that this instance of the object selects an application integration component (AIC) transport component.
BIZTALK_TRANSPORT_TYPE_MSMQ | 128 | Specifies that this instance of the object selects a Microsoft Message Queuing transport component.
BIZTALK_TRANSPORT_TYPE_FILE | 256 | Specifies that this instance of the object selects a file as a transport component.
BIZTALK_TRANSPORT_TYPE_HTTPS | 1024 | Specifies that this instance of the object selects a Secure Hypertext Transfer Protocol (HTTPS) transport component.
BIZTALK_TRANSPORT_TYPE_ OPENDESTINATION | 2048 | Specifies that the messaging port is an open destination.
BIZTALK_TRANSPORT_TYPE_LOOPBACK | 4096 | Specifies that the document submitted to the server with the SubmitSync method will be processed and then returned back as the response document of the method.
BIZTALK_TRANSPORT_TYPE_ORCHESTRATIONACTIVATION | 8192 | Specifies that the Address property contains the path of an XLANG schedule to be executed.


BIZTALK_USAGE_TYPE

The BIZTALK_USAGE_TYPE enumeration has one of the following values:

Name | Value | Description
BIZTALK_USAGE_TYPE_ENCRYPTION | 1 | Specifies that this is an encryption certificate.
BIZTALK_USAGE_TYPE_SIGNATURE | 2 | Specifies that this is a signature certificate.
BIZTALK_USAGE_TYPE_BOTH | 4 | Specifies that this certificate is used for both encryption and signature.


BIZTALK_CONFIGDATA_TYPE

The BIZTALK_CONFIGDATA_TYPE enumeration has one of the following values:

Name | Value | Description
BIZTALK_CONFIGDATA_TYPE_PRIMARYTRANSPORT | 0 | Configures the primary transport on the messaging port.
BIZTALK_CONFIGDATA_TYPE_SECONDARYTRANSPORT | 1 | Configures the secondary transport on the messaging port.
BIZTALK_CONFIGDATA_TYPE_ENCRYPTION | 2 | Configures the encryption certificate on the messaging port.
BIZTALK_CONFIGDATA_TYPE_ENCODING | 3 | Configures the encoding type on the messaging port.
BIZTALK_CONFIGDATA_TYPE_SIGNATURE | 4 | Configures the signature verification on the messaging port.
BIZTALK_CONFIGDATA_TYPE_SERIALIZER | 5 | Configures the serializer on the messaging port.


Error Messages

The properties and methods of the BizTalk Messaging Configuration object model use standard Component Object Model (COM) HRESULT return values to communicate whether the operation was successful or not.

In C++, these values are the actual return values from the methods themselves (including property get_ and put_ methods). The program must explicitly perform error checking by examining these return values, or use some variation of structured error handling.

In Microsoft Visual Basic (VB), and in Visual Basic Scripting Edition (VBS), these values are placed in the Number property of the global Err object. Error handling is either handled automatically, displaying a standard error dialog box, or explicitly by the program, checking the value of the Number property of the global Err object. The On Error Resume Next command disables automatic error handling, thereby enabling explicit error handling.

For additional information about error message values, see the following sections:

  • Standard COM Errors

  • BizTalk Server 2000 Error Messages


Standard COM Errors

The following table shows the most common standard COM errors returned by the properties and methods of the BizTalk Server objects.

Constant | Value (32-bit) | Description
S_OK | 00000000 | The standard return value used to communicate successful completion.
S_FALSE | 00000001 | An alternate success value, typically used to communicate successful, but non-standard completion. The precise meaning depends on the method or property in question.
E_UNEXPECTED | 8000FFFF | Catastrophic failure error.
E_NOTIMPL | 80004001 | Not implemented error.
E_OUTOFMEMORY | 8007000E | Out of memory error.
E_INVALIDARG | 80070057 | One or more arguments are not valid error.
E_NOINTERFACE | 80004002 | Interface not supported error.
E_POINTER | 80004003 | Pointer not valid error.
E_HANDLE | 80070006 | Handle not valid error.
E_ABORT | 80004004 | Operation aborted error.
E_FAIL | 80004005 | Unspecified error.
E_ACCESSDENIED | 80070005 | General access denied error.
MK_E_NOOBJECT | 800401E5 | The object identified by this moniker could not be found.

Additional information may be available using the global Err object. In Visual Basic, the Description property of the Err object may contain a text description of the error.

In C++, call the OLE DB method GetErrorInfo on the IErrorRecords interface to retrieve the most recently set IErrorInfo pointer in the current logical thread. The GetDescription method of the IErrorInfo interface may return a text description of the error. For more information about the GetErrorInfo method, go to the MSDN Online Library Web site (msdn.microsoft.com/library/default.asp) and browse to OLE DB Interfaces in the Platform SDK.


BizTalk Server 2000 Error Messages

The BizTalk Messaging Configuration object model error messages defined by BizTalk Server can be used in your application by including the bts_config_errors.h file located in the BizTalk Server installation directory at \Program Files\Microsoft BizTalk Server\SDK\Include. These error messages, returned during design time by the methods and properties of the object model, contain a BTS_ prefix in the message name. All other errors occur during run time, while BizTalk Server is processing a document.

The following table contains both design time and run time errors.

Message name | Value | Description
CIS_E_OBJECT_NOT_FOUND | 0x0100 | The object was not found.
CIS_E_STATE_NOT_FOUND | 0x0101 | The state engine state was not found in the messaging port definition.
CIS_E_STATE_TRANSITION | 0x0103 | The state table contains a bad engine state transition.
CIS_E_BAD_ENGINE_CONFIG_FILE | 0x0105 | The string that describes the input state configuration is not valid.
CIS_E_CANNOT_ADD_STATE | 0x0106 | BizTalk Server could not add the user-defined state to the system.
CIS_E_NO_COMPONENT_FOUND | 0x0107 | There is no component in the state definition or the ProgID is wrong.
CIS_E_PIPECOMP_ADMIN_REQUIRED | 0x0108 | The required IPipelineComponentAdmin interface was not found on the component.
CIS_E_BAD_COMPONENT_TYPE | 0x0109 | The component type specified for the state engine is not recognized.
CIS_E_BAD_STATE_CONFIG | 0x010A | The state configuration is not valid.
CIS_E_BAD_STATE_TYPE | 0x010B | The specified state type is not recognized.
CIS_E_BAD_COMPONENT_CONFIG | 0x010C | The component configuration is not valid.
CIS_E_INTERNAL_FAILURE | 0x010F | An internal server failure occurred due to an unknown cause.
CIS_E_CREATE_SCHEDULER_FAILED | 0x0111 | The Queue Scheduler for the service could not be created.
CIS_E_AGREEMENT_SELECT_FAILED | 0x0112 | No channels matched the input criteria. Verify that a messaging port and a channel exist, and that they match the following fields: Source qualifier: "%1" Source identifier value: "%2" Source document name: "%3" Destination qualifier: "%4" Destination identifier value: "%5" Also verify that any expressions specified for the channels are compatible with this document.
CIS_E_ERROR | 0x0113 | An error occurred in BizTalk Server.%n %n Details:%n ------------------------------%n %1
CIS_E_SERVICE_INITIALIZATION_FAILURE | 0x0114 | The service failed to start. Verify that this server is enlisted in a BizTalk Server group.
CIS_E_SCHEDULER_FAILED | 0x0115 | The Queue Scheduler failed and has exited.
CIS_E_WORKER_THREAD_FAILED | 0x0116 | A worker thread failed and has exited.
CIS_E_SHARED_QUEUE_DB_EXEC_FAILED | 0x0117 | Execution against the Shared Queue database has failed.
CIS_E_CANT_READ_WORK_ITEM | 0x0119 | A work item in the Shared Queue database cannot be read.
CIS_E_CHECKPOINT_FAILED | 0x011c | Checkpointing the work item failed.
CIS_E_CREATE_DEAD_WORK_ITEM_FAILED | 0x011e | A new work item in the Suspended queue cannot be created.
CIS_E_GET_SNAPSHOT_FAILED | 0x0122 | A snapshot of the Shared Queue database cannot be taken.
CIS_E_FREE_INTERCHANGES_FAILED | 0x0124 | The specified interchanges cannot be freed.
CIS_E_DELETE_INTERCHANGE_FAILED | 0x0125 | The specified interchange cannot be deleted.
CIS_E_RECEIVING_INTERCHANGE_FAILED | 0x0127 | The specified interchange was not received.
CIS_E_GETTING_NEXT_SCHEDULED_WORK_ITEM_FAILED | 0x0128 | The next scheduled work item cannot be obtained for processing.
CIS_E_GET_COUNT_FAILED | 0x0129 | The count on the shared queues cannot be obtained.
CIS_E_TRANSMISSION_FAILED | 0x012a | All retry transmissions failed.
CIS_W_TRANSMISSION_ATTEMPT_FAILED | 0x012b | A transmission attempt failed.
CIS_W_TRANSMISSION_XFER_TO_SECONDARY | 0x012c | The primary transport for messaging port "%1" cannot transmit the data. The server will switch to the secondary transport.
CIS_E_RECEIPT_GENERATION_FAILED | 0x012e | After creating the work item, the attempt to generate a receipt failed.
CIS_E_RECEIPT_GENERATION_FAILED_NO_WORK_ITEM | 0x012f | The attempt to generate a receipt failed before the work item was created.
CIS_E_L1_RECEIPT_CORRELATION_FAILED | 0x0130 | Receipt correlation failed.
CIS_E_AGREEMENT_LACKING_PARAMS | 0x0133 | At least one of the fields necessary to select a channel is missing. Verify that your document and envelopes extract the proper fields for the parser, or specify the necessary fields upon submission. Channel selection fields: Source identifier type: "%1" Source identifier value: "%2" Source document name: "%3" Destination identifier type: "%4" Destination identifier value: "%5"
CIS_E_AGREEMENT_FAILED | 0x0134 | The channel cannot be selected.
CIS_E_ORIGINAL_L1_INTERCHANGE_MISSING | 0x0135 | When trying to correlate an incoming receipt, the original interchange and related document(s) are no longer present.
CIS_E_UNEXPECTED_DB_BEHAVIOR | 0x0136 | An unexpected return occurred. The database may need to be restarted.
CIS_E_AGREEMENT_INVALID_MAP | 0x0137 | The map specified by the reference "%1" is not valid. Verify that the reference points to a valid map created by BizTalk Mapper.
CIS_I_SERVICE_MSG | 0x0138 | 1%
CIS_E_AGREEMENT_MAP_FAILED | 0x0139 | The XML document could not be translated. The map specified by reference "%1" failed. Verify that the map is up to date.
CIS_E_XML_ERROR | 0x013A | The XML document could not be parsed on line: %2, position: %3 for the following reason: "%1"
CIS_E_AGREEMENT_PROCESSING_FAILED | 0x013f | The server could not finish processing the document.
CIS_E_AGREEMENT_PROCESSING_FAILED_W_NAME | 0x0140 | The following channel configuration setting is not valid: "%1"
CIS_E_AGREEMENT_INVALID_QUERY | 0x0141 | The "%2" query for the "%1" document tracking field is not a valid XSL pattern. This pattern must be removed or corrected.
CIS_I_SERVICE_START | 0x0142 | The service has started.
CIS_I_SERVICE_STOP | 0x0143 | The service has stopped.
CIS_E_ERROR_EX | 0x0144 | An error occurred in BizTalk Server.%n %n Details:%n ------------------------------%n %1 %2 %3 %4 %5 %6 %7 %8 %9 %n
CIS_E_ERROR_EX_HEAD | 0x0145 | ======================================== ======================================= Date: %1 Source: BizTalk Server 2000 Time: %2 Category: BizTalk Server 2000 User: %3 Computer: %4 Description: An error occurred in BizTalk Server. Details: -------
CIS_E_ERROR_EX_FOOT | 0x0146 |
CIS_E_INVALID_DATA_FORMAT | 0x0147 | The business document that was passed in is not in a recognized format and could not be parsed or decrypted.
CIS_E_CREATE_ENGINE | 0x0148 | BizTalk Server was unable to create a new instance of the processing engine to process a work item. This might be due to a failure to create a new COM+ transaction.
CIS_E_MISSING_DESTINATION_DOCUMENT_SPEC | 0x0149 | BizTalk Server has detected an incomplete messaging port. The destination specification is missing from the messaging port.
CIS_E_PROCESSING_THREAD_FAILED | 0x014A | The processing thread failed to start. This might be due to a failure to create the state engine.
CIS_E_NOSRCORG | 0x014B | No source organization that corresponds to the ID and Qualifier pair has been specified.
CIS_E_NODESTORG | 0x014C | No destination organization that corresponds to the Identifier and Qualifier pair has been specified.
CIS_E_NODOC | 0x014D | No document that corresponds to the document name has been specified.
CIS_E_NOPIPELINES | 0x014E | No channel that corresponds to the parameters has been specified.
CIS_E_NOT_RESUBMITTABLE | 0x014F | The state of the item in the Suspended queue does not allow resubmission.
CIS_E_PIPESELECT_POLICY_FAILED | 0x0150 | No channels matched the certificates that were found with the incoming data. The following certificates accompanied the submitted data: Signature certificate reference: "%1" Encryption certificate reference: "%2"
CIS_E_SUBMIT_INVALIDDOC | 0x0151 | The submitted document is not valid. See the following messages for more details.
CIS_E_SUBMITSYNC_TOOMANYDOCS | 0x0152 | The SubmitSync method failed because multiple documents where found within the data. Only one document is allowed per synchronous submission. If this is a structured flat-file submission, then the most common cause of failure is extra leading or trailing white space around the data.
CIS_E_SUBMITSYNC_TOOMANYPIPES | 0x0153 | The synchronous submission could not be completed because multiple valid channels matched the incoming document. Only one channel is allowed to match the incoming document.
CIS_E_XMIT_NOTRANSPORTCOMP | 0x0154 | This server could not create a component with the class ID "%1" for transport. Verify that this component is properly registered. The following error was returned:
CIS_E_XMIT_EMPTY_DOCUMENT | 0x0155 | Messaging port "%1" cannot transmit a zero-byte document.
CIS_E_XMIT_FAILED_W_NAME | 0x0156 | The server could not finish processing messaging port "%1".
CIS_E_XMIT_NO_INTERFACE | 0x0157 | The server could not obtain the "%1" interface from the transport component with CLSID "%2".
CIS_E_XMIT_NO_BTS_AIC_INTERFACES | 0x0158 | The server could not obtain either the "%1" or "%2" interfaces from the BizTalk Server application integration component with CLSID "%3".
CIS_E_XMIT_FAILED_W_DETAILS | 0x0159 | The server encountered a transport error while processing the messaging port "%1", which uses a transport component with a ProgID of "%2".
CIS_E_NOHDR_ERROR_EX | 0x015A | %1 %2 %3 %4 %5 %6 %7 %8 %9 %n
CIS_W_COMP_NOACK | 0x015B | The correlation component "%1" could not find a document for which to send a receipt. No action will be taken.
CIS_E_CORRELATIONCOMP_FAILED | 0x015C | The correlation component "%1" returned an unexpected failure. The document will be placed in the Suspended queue.
CIS_E_CORRELATION_FAILED | 0x015D | Receipt correlation processing failed.
CIS_E_XML_VALIDATE_ERROR | 0x015E | The XML document has failed validation for the following reason: %1
CIS_E_CHANNEL_ACCESSDENIED | 0x015F | The submitted document does not have the necessary signature or encryption required by channel "%3". The following certificates accompanied the submitted data: Signature certificate reference: "%1" Encryption certificate reference: "%2"
CIS_I_SERVICE_RESTARTING | 0x0160 | The service is restarting.
BTS_E_CONSTRAINT | 0x1201 | Constraint Error
BTS_E_NOOBJECT | 0x1202 | The object was not found.
BTS_E_INTERNALFAILURE | 0x1203 | An internal failure occurred.
BTS_E_ENVELOPE_CONTROLNUMBER | 0x120C | If the envelope format is set to X12 or EDIFACT, the control number value must be set to a number greater than or equal to 1.
BTS_E_ENVELOPE_DELIMETER | 0x120D | If the envelope format is set to X12, then delimiters are required and must be set.
BTS_E_ENCRYPTION_CUSTOM_NOCLSID | 0x120E | If the encryption type is Custom, then the class identifier (CLSID) must also be specified.
BTS_E_ENCODING_CUSTOM_NOCLSID | 0x120F | If the encoding type is Custom, then the class identifier (CLSID) must also be specified.
BTS_E_SIGNATURE_CUSTOM_NOCLSID | 0x1210 | If the signature type is Custom, then the class identifier (CLSID) must also be specified.
BTS_E_INVALIDCONTROLNUMBER | 0x1212 | The control number value must be set to a number greater than or equal to 1.
BTS_E_ENVELOPE_INUSE | 0x1213 | The format of the envelope cannot be changed because it is used in a messaging port.
BTS_E_CHANNEL_MISSINGMAPSOURCE | 0x1215 | The channel is missing the MapSource node.
BTS_E_INVALID_CERT_USAGE | 0x1216 | The certificate is not valid for the current usage. An encryption certificate cannot be used for signing; nor can a signing certificate be used for encryption. Make sure that the correct certificate is selected.
BTS_E_MISSINGSMTPHOST | 0x1218 | The SMTP host is missing. The SMTP host can be configured in BizTalk Server Administration.
BTS_E_INVALID_ENCRYPT_STORE | 0x1219 | The encryption store type is not valid. The store type must be BIZTALK.
BTS_E_INVALID_SGNTCERT_STORE | 0x121A | The signature store type is not valid. The store type must be MY.
BTS_E_DATATOOLONG | 0x121B | The data length is too long.
BTS_E_INVALID_VERIFY_ENCRYPTCERT_STORE | 0x121C | The encryption verification store type is not valid. The store type must be MY.
BTS_E_INVALID_VERIFY_SGNTCERT_STORE | 0x121D | The signature verification store type is not valid. The store type must be BIZTALK.
BTS_E_ORGANIZATION_UNIQUE_ID | 0x121F | The organization identifier must be a unique identifier.
BTS_E_ORGANIZATION_UNIQUE_NAME | 0x1220 | The organization name must be a unique name.
BTS_E_OBJECT_ALREADY_EXISTS | 0x1221 | The object already exists. You cannot call the Create() method on a BizTalk Messaging Configuration object multiple times without also calling the Clear() or Remove() methods.
BTS_E_ALIAS_UNIQUE_ID | 0x1222 | The identifier must be a unique identifier.
BTS_E_ALIAS_UNIQUE_NAME | 0x1223 | The identifier name for this organization must be a unique name.
BTS_E_ALIAS_UNIQUE_QUALIFIERVALUE | 0x1225 | The identifier must have a unique qualifier-value pair.
BTS_E_ALIAS_FOREIGN_OWNERID | 0x1226 | The organization cannot be removed because it is referred to by an identifier.
BTS_E_XMLSHARE_UNIQUE_ID | 0x1227 | The primary identifier for the XML Share table in the SQL Server database must be a unique identifier.
BTS_E_XMLSHARE_UNIQUE_REFERENCE | 0x1228 | The reference for the XML Share table in the SQL Server database must be a unique reference.
BTS_E_DOCUMENT_UNIQUE_ID | 0x1229 | The document identifier must be a unique identifier.
BTS_E_DOCUMENT_UNIQUE_NAME | 0x122A | The document name must be a unique name.
BTS_E_DOCUMENT_FOREIGN_SHAREID | 0x122C | The XML Share table in the SQL Server database cannot be removed because it is referred to by a document.
BTS_E_ENVELOPE_UNIQUE_ID | 0x122D | The envelope identifier must be a unique identifier.
BTS_E_ENVELOPE_UNIQUE_NAME | 0x122E | The envelope name must be a unique name.
BTS_E_ENVELOPE_FOREIGN_SHAREID | 0x1230 | The XML Share table in the SQL Server database cannot be removed because it is referred to by an envelope.
BTS_E_CONTROLNUMBER_UNIQUE_ID | 0x1231 | The control-number identifier must be a unique identifier.
BTS_E_PORTGROUP_UNIQUE_ID | 0x1232 | The distribution list identifier must be a unique identifier.
BTS_E_PORTGROUP_UNIQUE_NAME | 0x1233 | The distribution list name must be a unique name.
BTS_E_MISSING_VALUE | 0x1235 | The identifier value property must have a value.
BTS_E_MISSING_SRCORGID | 0x1236 | The Channel SourceOrganization property must have a value.
BTS_E_APPLICATION_UNIQUE_ID | 0x1237 | The application identifier must be a unique identifier.
BTS_E_APPLICATION_FOREIGN_OWNERID | 0x1238 | The organization cannot be removed because it is referred to by an application.
BTS_E_APPLICATION_UNIQUE_NAME | 0x1239 | For applications within this organization, the application name must be a unique name.
BTS_E_CHANNEL_UNIQUE_ID | 0x123A | The channel identifier must be a unique identifier.
BTS_E_CHANNEL_UNIQUE_NAME | 0x123B | The channel name must be a unique name.
BTS_E_CHANNEL_FOREIGN_INPDOCID | 0x123D | The inbound document cannot be removed because it is used by a channel.
BTS_E_CHANNEL_FOREIGN_OUTDOCID | 0x123E | The output document cannot be removed because it is used by a channel.
BTS_E_CHANNEL_FOREIGN_PORTGROUPID | 0x123F | The distribution list cannot be removed because it is used by a channel.
BTS_E_CHANNEL_FOREIGN_SRCORGID | 0x1240 | The source organization cannot be removed because it is used by a channel.
BTS_E_ENVELOPE_INVALIDFORMAT | 0x1241 | The only valid envelope-format strings are: Custom, Custom XML, EDIFACT, Flatfile, X12, and Reliable. The previously specified format will remain unchanged.
BTS_E_CHANNEL_FOREIGN_CONTROLNUMID | 0x1242 | The control number cannot be removed because it is used by an channel.
BTS_E_PORT_UNIQUE_ID | 0x1243 | The messaging port identifier must be a unique identifier.
BTS_E_PORT_UNIQUE_NAME | 0x1244 | The messaging port name must be a unique name.
BTS_E_CHANNEL_FOREIGN_SRCAPPID | 0x1247 | The source application cannot be removed because it is used by a channel.
BTS_E_PORT_FOREIGN_DSTORGID | 0x1248 | The destination organization cannot be removed because it is used by a messaging port.
BTS_E_PORT_FOREIGN_DSTALIASID | 0x1249 | The destination identifier cannot be removed because it is used by a messaging port.
BTS_E_PORT_FOREIGN_ENVID | 0x124A | The envelope cannot be removed because it is used by a messaging port.
BTS_E_CHANNEL_FOREIGN_SRCALIASID | 0x124B | The source identifier cannot be removed because it is used by a channel.
BTS_E_PORT_FOREIGN_DSTAPPID | 0x124C | The destination application cannot be removed because it is used by a messaging port.
BTS_E_PORT_FOREIGN_CONTROLNUMID | 0x124D | The control number cannot be removed because it is used by a messaging port.
BTS_E_DOCUMENT_MISSING_REFERENCE | 0x124E | The Reference property must have a value if the TrackingFields or PropertySet properties are specified.
BTS_E_DOCUMENT_REFERENCE_CANT_BE_CHANGED | 0x124F | A document reference cannot be modified if it is referred to by a channel.
BTS_E_PORTGROUP_NOTOPENGRP | 0x1251 | Messaging ports that are set to an open destination or set to an XLANG schedule (BIZTALK_OPENNESS_TYPE_EX_TOWORKFLOW) cannot be used in distribution lists.
BTS_E_PORTGROUP_DUPLICATEPORT | 0x1252 | A duplicate messaging port cannot be added to the distribution list.
BTS_E_OUTPUTCONFIG_UNIQUE_ID | 0x1255 | The output configuration identifier must be a unique identifier.
BTS_E_OUTPUTCONFIG_FOREIGN_PORTID | 0x1256 | The messaging port cannot be removed because it is used by a channel.
BTS_E_OUTPUTCONFIG_FOREIGN_CHANNELID | 0x1257 | The channel cannot be removed because it is used by a messaging port.
BTS_E_PORT_LOOPBACK_RELIABLE | 0x125F | A messaging port with the transport type Loopback cannot be associated with an envelope that uses the Reliable format.
BTS_E_ALIAS_RESERVEDWORD | 0x1262 | Group is a reserved word for qualifiers and cannot be used as the qualifier for an identifier.
BTS_E_DOCUMENT_NEEDMAPREF | 0x1268 | A map reference is required to transform the inbound document to the outbound document if the document specifications are different.
BTS_E_PORT_DESTORGNOTSPECIFIED | 0x126C | This messaging port must have a destination organization specified.
BTS_E_PORT_MISSING_PRITRANSTYPE | 0x126D | You must specify a primary transport type for this messaging port. The primary transport cannot be blank, and it cannot be an open destination.
BTS_E_PORT_MISSING_PRITRANSADDRESS | 0x126E | This messaging port must have a primary transport address specified.
BTS_E_PORT_INVALID_SECTRANSTYPE | 0x126F | The secondary transport type cannot be set to Open, Loopback, or to BizTalk Orchestration Activation.
BTS_E_PORT_MISSING_SECTRANSADDRESS | 0x1270 | The secondary transport address is missing, although the transport type has been defined.
BTS_E_PORT_INVALID_ORG | 0x1271 | The organization specified in this messaging port does not exist.
BTS_E_PORT_INVALID_ALIAS | 0x1272 | The identifier specified for the organization in this messaging port either does not exist or it does not belong to the organization.
BTS_E_PORT_INVALID_APPLICATION | 0x1273 | The application specified for the organization in this messaging port either does not exist or it does not belong to the organization.
BTS_E_PORT_INVALID_ENVELOPE | 0x1274 | The envelope specified in this messaging port does not exist.
BTS_E_PORT_OPEN_DESTORG_SPECIFIED | 0x127C | An open-destination messaging port cannot have a destination organization specified.
BTS_E_PORT_OPEN_DESTAPP_SPECIFIED | 0x127E | An open-destination messaging port cannot have a destination application specified.
BTS_E_PORT_OPEN_PRITRANSTYPEOPEN | 0x127F | An open-destination messaging port must specify a primary transport type as an open destination.
BTS_E_PORT_OPEN_PRITRANSADDRESS | 0x1280 | An open-destination messaging port cannot specify a primary transport address.
BTS_E_PORT_OPEN_PRITRANSPARAMETER | 0x1281 | An open-destination messaging port cannot specify a primary transport parameter.
BTS_E_PORT_OPEN_SECTRANSTYPE | 0x1282 | An open-destination messaging port cannot specify the secondary transport type.
BTS_E_PORT_OPEN_SECTRANSADDRESS | 0x1283 | An open-destination messaging port cannot specify a secondary transport address.
BTS_E_PORT_OPEN_SECTRANSPARAMETER | 0x1284 | An open-destination messaging port cannot specify a secondary transport parameter.
BTS_E_PORT_OPEN_ENCRYPTIONTYPE | 0x1285 | An open-destination messaging port cannot specify an encryption type.
BTS_E_PORT_OPEN_ENCRYPTIONREF | 0x1286 | An open-destination messaging port cannot specify an encryption reference.
BTS_E_PORT_SIGNATTYPEANDREFERENCE | 0x1287 | The signature type is specified; however, the signature reference is missing.
BTS_E_PORT_ENCRYPTIONTYPEANDREFERENCE | 0x1288 | The encryption type is specified; however, the encryption reference is missing.
BTS_E_ALIAS_DEFAULT | 0x128A | One and only one default identifier is required and permitted at all times. The default identifier cannot be missing, nor can it be duplicated.
BTS_E_ALIAS_AUTO | 0x128B | The alias, which uses the name "Organization" and the qualifier "OrganizationName," is a system-created alias. You cannot remove this alias, create another alias that uses the same name and qualifier, or change any fields of this alias.
BTS_E_TRANSPORT_SYNTAXAPPINT | 0x128E | Either the syntax of this address is incorrect for the Application Integration Component transport type property, or the component is not registered, or else the component is not a valid AIC component.
BTS_E_TRANSPORT_SYNTAXFILE | 0x128F | The syntax of this address is incorrect for the File transport type.
BTS_E_TRANSPORT_SYNTAXHTTP | 0x1291 | The syntax of this address is incorrect for the HTTP transport type.
BTS_E_TRANSPORT_SYNTAXHTTPS | 0x1292 | The syntax of this address is incorrect for the HTTPS transport type.
BTS_E_TRANSPORT_SYNTAXSMTP | 0x1293 | The syntax of this address is incorrect for the SMTP transport type.
BTS_E_TRANSPORT_SYNTAXNONE | 0x1294 | You cannot specify a transport address or a parameter when the transport type is set to None, or when the source or destination are Open.
BTS_E_TRANSPORT_LOCALHOST | 0x1295 | The transport address cannot contain the word "localhost". Replace it with the computer name instead.
BTS_E_PORTGROUP_LASTPORT | 0x1296 | The messaging port cannot be removed if it is the last remaining messaging port in a distribution list.
BTS_E_TRANSPORT_MISSING_PRISMTPPARAMETER | 0x1298 | A primary transport parameter is required for the SMTP transport type.
BTS_E_TRANSPORT_MISSING_SECSMTPPARAMETER | 0x1299 | A secondary transport parameter is required for the SMTP transport type.
BTS_E_NAMEREQ | 0x129A | The Name property must always be at least one character long.
BTS_E_INVALIDTIMEFORMAT | 0x129B | The time format is not valid. Enter the time, in hours, in a 24-hour format (from 0 to 23 hours). You can enter only hours, not minutes or seconds.
BTS_E_TIMESTAMP | 0x129C | This object cannot be saved or removed because the timestamp has changed.
BTS_E_PORTGROUP_MISSING_PORT | 0x129D | A distribution list must contain at least one messaging port.
BTS_E_ORGANIZATION_REMOVEDEFAULT | 0x129E | The home organization cannot be removed.
BTS_E_PORT_SERVICEWINDOW_EQUAL | 0x129F | The start time (FromTime) and end time (ToTime) for the service window cannot be equal.
BTS_E_ENVELOPE_REFERENCENOTALLOWED | 0x12A2 | The reference property cannot be set for this envelope format.
BTS_E_ENVELOPE_REFERRED | 0x12A3 | This envelope cannot be removed because it is used in a messaging port or channel.
BTS_E_TRANSPORT_LOOPBACK_SECTYPECONFLICT | 0x12A4 | The secondary transport type cannot be specified for the messaging port if the primary transport type is set to Loopback.
BTS_E_TRANSPORT_LOOPBACK_SECADDRESSCONFLICT | 0x12A5 | The secondary transport address cannot be specified for the messaging port if the transport type is set to Loopback.
BTS_E_PORT_LOOPBACK_SERVICEWINDOW | 0x12A6 | The service window cannot be specified for the messaging port if the transport type is set to Loopback.
BTS_E_PORT_OPEN_DESTALIAS_SPECIFIED | 0x12A7 | An open-destination messaging port cannot have a destination identifier specified.
BTS_E_PORT_OPEN_SERVICEWINDOW | 0x12A8 | The service window cannot be specified for the messaging port if the messaging port is an open-destination messaging port.
BTS_E_PORT_SERVICEWINDOWTIMES | 0x12AA | To use a service window, you must set both the From and To times or else, do not set either time.
BTS_E_TRANSPORT_LOOPBACK_PRIADDRESSCONFLICT | 0x12AC | A primary transport address cannot be specified for the messaging port if the transport type is Loopback.
BTS_E_PORT_ORGCHANGE | 0x12AD | The destination-organization identifier cannot be changed after it is created.
BTS_E_PORT_OPENNESSCHANGE | 0x12AE | The Openness property cannot be changed after it is created.
BTS_E_PORT_SIGNATURE_CHANNEL_CERTREF | 0x12AF | The signature-certification reference for a channel does not match the signature type for the port.
BTS_E_PORT_SIGNATURE_CHANNEL_OPEN | 0x12B0 | A messaging port that contains a signature type cannot be connected to an open-source channel. Also, a messaging port that is already connected to an open-source channel cannot have a signature type assigned to it.
BTS_E_CHANNEL_OPEN_SRCORG | 0x12B1 | An open-source channel cannot specify a source organization.
BTS_E_PORTGROUP_LOOPBACKPORT | 0x12B2 | A messaging port that uses the Loopback transport type cannot be added to a distribution list. Also, the transport type of a messaging port that is already included in a distribution list cannot be changed to Loopback.
BTS_E_CHANNEL_OPEN_SRCALIAS | 0x12B3 | An open-source channel cannot have a source identifier specified.
BTS_E_CHANNEL_OPEN_SRCAPP | 0x12B4 | An open-source channel cannot specify a source application.
BTS_E_CHANNEL_PORTORPORTGROUP | 0x12B5 | Either a messaging port or a distribution list, but not both, must be specified in a channel.
BTS_E_CHANNEL_MISSING_DOCUMENT | 0x12B6 | Both input and output documents are needed in a channel.
BTS_E_CHANNEL_INVALIDTYPE | 0x12B7 | A channel cannot be set to an open destination or set to an XLANG schedule (BIZTALK_OPENNESS_TYPE_EX_TOWORKFLOW).
BTS_E_CHANNEL_MISSING_OUTDOCREFERENCE | 0x12B8 | If the inbound document definition for a channel has a reference to a specification, the outbound document definition must also have a reference to a specification.
BTS_E_CHANNEL_TRACKFIELDSCANTBESET | 0x12B9 | If the inbound document definition for a channel does not have a reference to a specification, the tracking fields cannot be set.
BTS_E_CHANNEL_EXPRESSIONCANTBESET | 0x12BA | If the inbound document definition for a channel does not have a reference to a specification, the channel-filtering expressions cannot be set.
BTS_E_CHANNEL_MAPREFCANTBESET | 0x12BB | If the inbound document definition for a channel does not have a reference to a specification then a reference to a map cannot be set.
BTS_E_CHANNEL_NOTSAME_INPDOC_OUTDOC | 0x12BC | If the inbound document definition for a channel does not have a reference to a specification then the outbound document handle should be the same of inbound document handle.
BTS_E_CHANNEL_OPEN_RECEIPTCONFLICT | 0x12BD | Channels that are set from an open source or set from an XLANG schedule (BIZTALK_OPENNESS_TYPE_EX_FROMWORKFLOW) cannot be receipt channels.
BTS_E_CHANNEL_RECEIPT_RECEIPTTIMEOUT | 0x12BE | The Expect Receipt Timeout property cannot be set on a receipt channel.
BTS_E_CHANNEL_RECEIPT_CANTSETRECEIPTCHANNEL | 0x12BF | An identifier cannot be set on a receipt channel.
BTS_E_CHANNEL_RECEIPT_CONFLICT | 0x12C0 | In a receipt channel, the source specification from the original channel must be used as the destination specification, and the destination specification from the original channel must be used as the source specification.
BTS_E_CHANNEL_SRCORGDEFAULT | 0x12C1 | If the channel is set from an XLANG schedule (BIZTALK_OPENNESS_TYPE_EX_FROMWORKFLOW), the source organization must be the home organization.
BTS_E_CHANNEL_PORT_BOTHOPEN | 0x12C2 | Both the channel and messaging port cannot be set to Open.
BTS_E_CHANNEL_RECEIPT_INVALID | 0x12C3 | The Receipt Channel and Expect Receipt Timeout properties cannot be set for an open-source channel. These properties also cannot be set if the messaging port is set to an open destination, set to an XLANG schedule (BIZTALK_OPENNESS_TYPE_EX_TOWORKFLOW), or if the messaging port uses the Loopback transport type.
BTS_E_CHANNEL_RECEIPTMATCHNOTFOUND | 0x12C4 | The corresponding receipt channel for this channel could not be found.
BTS_E_CHANNEL_RECEIPT_OPENPORT | 0x12C5 | A receipt channel can be connected only to messaging ports that are not open messaging ports.
BTS_E_CHANNEL_RECEIPT_LOOPBACKPORT | 0x12C6 | A receipt channel cannot be connected to a messaging port that uses the Loopback transport type. Also, the transport type of a messaging port that is already connected to a receipt channel cannot be changed to Loopback.
BTS_E_CHANNEL_CANNOTUPDATE | 0x12C8 | After a channel is created, the following properties cannot be changed: source organization, openness designation, messaging port, distribution list, and receipt channel designation.
BTS_E_PORT_INVALIDOPENNESS | 0x12C9 | A messaging port cannot be set to an open source; nor can it be set from an XLANG schedule (BIZTALK_OPENNESS_TYPE_EX_FROMWORKFLOW).
BTS_E_CHANNEL_CONTROLNUMBER_ENVELOPEFORMATMISMATCH | 0x12CA | If the envelope format for the messaging port is X12 or EDIFACT, the control-number value on the channel must be set.
BTS_E_PORT_ENVELOPE_SERIALIZERCLSID | 0x12CB | If the envelope format for the messaging port is set to Custom, a class identifier (CLSID) for the serializer component must be specified.
BTS_E_CHANNEL_AIC_TRANSPORTCLSID | 0x12CD | If the transport type associated with the channel is set to Application Integration Component, a class identifier (CLSID) must be specified for the primary transport.
BTS_E_CHANNEL_RECEIPT_PORTGROUP | 0x12CE | If a channel is connected to a distribution list, a receipt channel cannot be specified.
BTS_E_COMPONENTREQUIRES2AGGREGATEFTM | 0x12CF | To be a valid object in the BizTalk Object Model, this custom component must aggregate the free-threaded marshaler.
BTS_E_CERTREFNOTFOUND | 0x12D1 | Either the certificate reference could not be found in MY or BIZTALK stores or it is not valid.
BTS_E_NODOC | 0x12D2 | The Document Definition has been removed from the database. Avoid deleting objects when documents might exist in the queues which reference these objects.
BTS_E_NOENV | 0x12D3 | The envelope has been removed from the database. Avoid deleting objects when documents might exist in the queues which reference these objects.
BTS_E_NOCHANNEL | 0x12D4 | The channel has been removed from the database. Avoid deleting objects when documents might exist in the queues which reference these objects.
BTS_E_INVALIDREFERENCE | 0x12D5 | Either the WebDAV repository reference does not contain a valid HTTP address or it contains the text "localhost." Please provide either a valid HTTP address or replace the text "localhost" with the actual computer name.
BTS_E_CANNOTCONTAINSUBOBJECTS | 0x12D6 | The property set and delimiter objects cannot contain any subobjects.
BTS_E_INVALIDTRACKFIELDS | 0x12D7 | The "x_custom_search" field in the tracking field dictionary must be a simple list.
BTS_E_CHANNEL_INVALID_ORG | 0x12D8 | The organization specified in this channel does not exist.
BTS_E_CHANNEL_INVALID_ALIAS | 0x12D9 | The identifier specified for the organization in this channel either does not exist or it does not belong to the organization.
BTS_E_CHANNEL_INVALID_APPLICATION | 0x12DA | The application specified for the organization in this channel either does not exist or it does not belong to the organization.
BTS_E_CHANNEL_INVALID_INPDOCID | 0x12DB | The input document specified in this channel does not exist.
BTS_E_CHANNEL_INVALID_OUTDOCID | 0x12DC | The output document specified in this channel does not exist.
BTS_E_CHANNEL_INVALID_PORTGROUP | 0x12DD | The distribution list specified in this channel does not exist.
BTS_E_OBJECT_NOT_XMLSERILIZABLE | 0x12DE | The given dictionary or simplelist object must implement IPersistXML methods.
BTS_E_CHANNEL_INVALID_PORT | 0x12E0 | At least one messaging port that is referenced in this channel either does not exist or it is not associated with this channel.
BTS_E_CHANNEL_RECEIPT_VERSIGN_DECRYPT | 0x12E1 | The Verify Signature or Decrypt Encryption properties cannot be set on a receipt channel.
BTS_E_INVALID_REQUEST_CHANNEL | 0x12E2 | A channel that is connected to a distribution list cannot be used as a request channel.
BTS_E_DESTINATION_NOT_FOUND | 0x12E3 | The destination URL is not specified, and the messaging port is an open destination. Either the destination URL or a destination for the messaging port must be specified.
BTS_E_DESTINATION_CONFLICT | 0x12E4 | Both a destination URL and a destination for the messaging port cannot be specified. Specify only one of these properties.
BTS_E_ASYNC_TRANSPORT | 0x12E5 | The transport type for the request channel is not valid. Only the HTTP, HTTPS, and Application Integration Component transport types are valid for a request channel.
BTS_E_INVALID_RESPONSE_CHANNEL | 0x12E6 | The response channel can be connected only to a messaging port with a transport type set to Loopback.
BTS_E_INVALID_VERSION | 0x12E7 | The database version is incompatible with the installed version of the server. Try running setup again.
BTS_E_INVALID_SCHEMA | 0x12E8 | The document or envelope specification is not valid. Open the specification in BizTalk Editor, and then on the Tools menu, click Validate Specification. Resolve any warnings to ensure that the specification is valid.
BTS_E_CHANNEL_RECEIPTCHANNEL_PORTGROUP | 0x12E9 | A receipt channel cannot be connected to a distribution list.
BTS_E_TRANSPORT_ORCHESTRATION_OPENNESS | 0x12EA | A messaging port that uses the BizTalk Orchestration Activation transport type must have the Openness Type property set to an XLANG schedule (BIZTALK_OPENNESS_TYPE_EX_TOWORKFLOW).
BTS_E_TRANSPORT_ORCHESTRATION_ADDRESSPARAMETER | 0x12EB | Both a primary address and a parameter are required for a messaging port that uses a BizTalk Orchestration Activation transport type.
BTS_E_ORCHESTRATION_INVALIDORG | 0x12EC | A messaging port that uses a BizTalk Orchestration Activation transport type must have the home organization set as the destination organization.
BTS_E_INVALID_FILTEREXPRESSION | 0x12ED | The channel filtering expression is not valid. Make sure that the node-path expression is valid.
BTS_E_MULTIPLEDOCDEFSFORPROPSET | 0x12EE | Multiple document definitions were found for the given property set. Only a single document definition for a given property set is expected.
BTS_E_INVALID_PROPSET | 0x12EF | The PropertySet cannot contain non-string element values.
BTS_E_DBSCHEMA_MISMATCH | 0x1300 | The existing Database Schema is not compatible with the current version of the product. You must delete the existing database.
BTS_E_UNEXPECTED_INSTALL | 0x1301 | The existing Database Schema is newer than the current version that is installed. Setup will rollback the changes.
CIS_E_DOCSCHEMA_ATTRIB_MISSING | 0x1400 | The "%3" attribute is missing in the "%4" element. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_INVALID_ATTRIB_VALUE | 0x1401 | The "%3" attribute value "%4" is not valid. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_EMPTY_ELEMENT | 0x1402 | The "%3" element cannot be empty. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_INVALID_CHILD_ELEMENT | 0x1403 | The "%3" element cannot be a child of the "%4" element. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_MULTIPLE_INFO | 0x1404 | Only one record description or one field description is allowed for each element declaration. One of the descriptions must be removed. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_INVALID_FIELD_DECL | 0x1405 | The root node cannot contain a field. The root node of the document must contain a record. Verify that the root node in your document is declared as a record. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_INVALID_LEN_DECL | 0x1406 | The minimum length value must be no greater than the maximum length value. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_INVALID_POSLEN_DECL | 0x1407 | The value of the start position must be no greater than the value of the end position. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_NO_INFO_YET | 0x1408 | A field description or record description must be specified before references to other elements. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_INVALID_SCHEMATYPE_XML | 0x1409 | Only non-XML document specifications are allowed for this format. The schema_type attribute has the value "xml". Verify that the specification selected is a non-XML specification. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_NO_INFO | 0x140A | No record information or field information was found in the "%3" element. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_INVALID_ATTRIB | 0x140B | The "%3" attribute is not allowed in the "%4" element. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_MISSING_ELEM_DECL | 0x140C | There is no element with the name "%1" in the document specification.
CIS_E_DOCSCHEMA_MISSING_ATTR_DECL | 0x140D | There is no attribute with the name "%1" in the document specification.
CIS_E_DOCSCHEMA_INVALID_POSITIONAL_DECL | 0x140E | The "%1" record cannot be a child of the "%2" positional record. Only fields can be children of positional records.
CIS_E_DOCSCHEMA_INVALID_RECORD_CHILDREN | 0x140F | The children of the "%1" delimited record must either be all records or all fields. Records with no tag identifier cannot have mixed records and fields as children.
CIS_E_DOCSCHEMA_NO_RECORD_CHILDREN | 0x1410 | The "%1" delimited record must have at least one child. Records with no tag identifier must have at least one child, or else the record cannot be found in a non-XML format. Either add a child to the record, give the record a tag identifier, or remove the record from the specification.
CIS_E_DOCSCHEMA_MISSING_RECORD_TAG | 0x1411 | The "%1" delimited record is marked to repeat but it does not have a tag identifier. Only the last record in a document specification is allowed to have this property. If this record appears only once in the document, then mark it as a single occurrence. Otherwise, give the record a tag identifier that tells the server where to look for the next record in the specification.
CIS_E_DOCSCHEMA_NO_ROOT_ELEMENT | 0x1412 | The root-node name "%3" was not found in the specification. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_INVALID_ROOT_ELEMENT | 0x1413 | The "%3" element cannot be the root node of this document. Only <Schema> is allowed. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_INVALID_EMPTY_ATTRIBUTE | 0x1414 | The "%3" attribute in the "%4" element cannot be empty. Either specify a nonempty value or remove the attribute. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_INVALID_REFERENCE | 0x1415 | The "%1" record has an illegal cyclic path through the "%2" record. The only cyclic reference allowed for a record is if the record has a tag identifier that allows the system to terminate the search. Either remove the cyclic reference or add an appropriate tag identifier to the document specification.
CIS_E_DOCSCHEMA_LOADFAILED | 0x1416 | The specification failed to load. See the following messages for details.
CIS_E_DOCSCHEMA_MISSING_NS | 0x1417 | Valid BizTalk Server specifications for non-XML documents must have the namespace declarations of "urn:schemas-microsoft-com:BizTalkServer", "urn:schemas-microsoft-com:datatypes", and "urn:schemas-microsoft-com:xml-data" in the root node of the specification.
CIS_E_DOCSCHEMA_INVALID_SCHEMA_USAGE | 0x1418 | The specification referenced in the "%1" document is not compatible with the "%2" format. Select a specification that is compatible with this format, or if this is a valid specification for the defined format, assign "%2" to the "standard" property on this specification.
CIS_E_DOCSCHEMA_MISSING_POSLEN_DECL | 0x1419 | The "%3" field is missing a start and end position, and is referenced in the "%4" positional record. Specify valid start and end positions for this field. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_DUPLICATE_NAMESPACE | 0x141A | The duplicate namespace declaration "%3" has been found. Please remove the duplicate reference to same namespace. Line: %1, Pos: %2.
CIS_E_PARSER_EOF | 0x1430 | The end of the file was reached prematurely.
CIS_E_PARSER_MISSING_TAG | 0x1431 | The required "%1" record was not found in the inbound document.
CIS_E_PARSER_MISSING_FIELD | 0x1432 | The required field "%1" in the "%2" record was not found in the inbound document.
CIS_E_PARSER_FAILURE | 0x1433 | The parser failed to convert the document due to processing errors. See the following messages for details.
CIS_E_PARSER_INVALIDDATA | 0x1434 | The parser cannot match the current position of the data with the specification. Verify that the version of this specification is consistent with the version of the data and that the root parsing tags match.
CIS_E_PARSER_NO_DATA | 0x1435 | There is no data that can be parsed on the dictionary. Verify that either the "working_data" field or the "file_path" field contains nonempty data.
CIS_E_PARSER_INVALID_ENVNAME | 0x1436 | The envelope name "%1" does not reference a valid envelope for the BizTalk Server parser. Either the envelope name does not exist or there is an envelope specification attached that is not valid.
CIS_E_PARSER_NO_COMPONENTS_FOUND | 0x1439 | No parser component recognizes the data. This might be caused by an interchange specification that is missing or not valid, or it might be caused by data that is not valid. Verify that both the interchange specification (if one is specified) and the data match.
CIS_E_PARSER_COMPONENT_FAILED | 0x1440 | While trying to process document #%4 during submission "%1", the parser component named "%2" failed on the method "%3" with the error code "%5". Possible causes are: the component found unexpected data in the incoming stream; a document specification could not be found given the data; or an internal component failure occurred. If this problem continues, remove this component from the valid list of parser components or contact your system administrator.
CIS_E_PARSER_DOCUMENT_FAILED | 0x1441 | Document #%4 within submission "%1" was returned as a document that was not valid from the parser component named "%2". The most frequent cause is a document specification that is not valid or else the component was unable to determine the necessary routing fields. Verify that the proper specification is defined for this data.
CIS_E_PARSER_INVALID_DATETIME | 0x1442 | The "%1" date or time format does not match the format of the "%2" data extracted from the incoming data.
CIS_E_PARSER_INVALID_COMPONENT | 0x1443 | Within submission "%1", the parser component named "%2" could not be loaded. Verify that this component can be run in a stand-alone executable and that the server has sufficient permissions to start it.
CIS_W_PARSER_SKIPPED_COMPONENT | 0x1444 | The parser was unable to probe the specified component. This component will be skipped.
CIS_E_PARSER_UNUSEABLE_DOCNAME | 0x1445 | The parser cannot use the document "%1" as it has no specification. Please attach a specification to this document or specify a different one.
CIS_E_PARSER_CONTROL_NUMBER_MISMATCH | 0x1446 | The control number of segment "%1" (%2) does not match that of segment "%3" (%4).
CIS_E_PARSER_DOCCOUNT_INCORRECT | 0x1447 | The document or segment count contained in tag "%1" (%2) does not match the number of documents or segments processed (%3).
CIS_E_PARSER_X12_ISA_PARSE_FAILED | 0x1448 | The parser cannot parse the ISA section of the X12 document. This segment is fixed-width; if fields in this segment do not have correct length, the parsing will fail because the delimiters are picked up from the wrong offsets.
CIS_E_PARSER_MIN_LENGTH | 0x1449 | The data contains a field value ("%1") that doesn't meet minimum length requirement for tag "%2" (minimum length is %3).
CIS_E_PARSER_MAX_LENGTH | 0x144A | The data contains a field value ("%1") that doesn't meet maximum length requirement for tag "%2" (maximum length is %3).
CIS_E_PARSER_NO_DATA_CONSUMED | 0x144B | No data was read by the parser. Make sure that the code page is set correctly for the data. If the data is UNICODE, make sure that there is no byte order mark (0xFFFE or 0xFEFF) appears at the beginning of the file.
CIS_E_PARSER_UNSUPPORTED_EDIFACT_SYNTAX | 0x144C | EDIFACT documents with the "UNOX" or the "UNOY" syntax identifier are not supported.
CIS_E_PARSER_DATA_REMAINING | 0x144D | Additional data in the document instance was not parsed. Make sure that the document instance you want to validate contains only one document.
CIS_E_PARSER_MISSING_DELIMITER | 0x144E | While parsing record "%1", the parser cannot find the required delimiter: "%2" (%3).
CIS_E_PARSER_MISSING_LEADING_DELIMITER | 0x144F | While parsing record "%1", the parser cannot find the required leading delimiter: "%2" (%3).
CIS_E_PARSER_MISSING_TRAILING_DELIMITER | 0x1450 | While parsing record "%1", the parser cannot find the required trailing delimiter: "%2" (%3).
CIS_E_VALIDATE_GROUP_RULE | 0x1451 | In record "%1", if any of the following fields exist, then all must exist: %2
CIS_E_VALIDATE_GROUP_ALL | 0x1452 | In record "%1", all of the following fields must exist: %2
CIS_E_VALIDATE_GROUP_ONE | 0x1453 | In record "%1", only one of the following fields can exist: %2
CIS_E_PARSER_INVALID_WRAP_CHAR_FOUND | 0x1454 | While parsing record "%1", the parser found an occurrence of a wrap character, "%2", that is not valid.
CIS_E_VALIDATE_GROUP_ANY | 0x1455 | In record "%1", one or more of the following fields must exist: %2
CIS_E_PARSER_EXTRA_DELIMITER | 0x1456 | While parsing record "%1", the parser found the following extra delimiter: "%2".
BTS_E_DOCUMENT_HAS_INVALID_MANIFEST | 0x1457 | Error parsing the manifest.
CIS_E_ADMIN_CACHE_PARSERS | 0x1504 | The latest modification date from the administration parser table could not be loaded.
CIS_E_ADMIN_INIT_CACHE | 0x1505 | The configuration data in the global cache could not be initialized.
CIS_E_ADMIN_RELOAD_CACHE | 0x1506 | The configuration data from the database could not be reloaded.
CIS_E_ADMIN_PARSER_GETCLSID | 0x1507 | The class identifiers (CLSIDs) of the parser records could not be loaded.
CIS_E_ADMIN_CACHE_OBJECTNOTCREATED | 0x1509 | The administration cache cannot be created.
CIS_E_ADMIN_CACHE_INITIALLOAD | 0x150A | The configuration cache data from the database could not be loaded.
CIS_E_ADMIN_ADD_SERVER_ACCESS_DENIED | 0x150B | Server "%1" cannot be added because access to the "%2" is denied.
CIS_E_ADMIN_ADD_SERVER_NO_SERVICE | 0x150C | Server "%1" cannot be added because BizTalk Server is not installed on the computer.
CIS_E_ADMIN_DELETE_SERVER_NO_ACCESS | 0x150D | The "%1" server cannot be deleted because access to the "%2" service is denied and the service cannot be stopped.
CIS_E_ADMIN_DELETE_GROUP_SERVER_RUNNING | 0x150E | This server group cannot be deleted because the "%1" server is still running.
CIS_E_ADMIN_DELETE_GROUP_SERVER_ACCESS_DENIED | 0x150F | This server group cannot be deleted because access to the "%1" service on "%2" server is denied.
CIS_E_ADMIN_NOGROUP | 0x1512 | The specified administration group does not exist.
CIS_E_ADMIN_NOSERVER | 0x1513 | The specified administration server does not exist.
CIS_E_ADMIN_NORECEIVESERVICE | 0x1514 | The specified administration receive function does not exist in the database.
CIS_E_ADMIN_UNEXPECTED_REMOVE_RECEIVESERVICE | 0x1515 | An unexpected error occurred while trying to remove the "%1" receive function from the database.
CIS_E_ADMIN_UNEXPECTED_REMOVE_GROUP | 0x1516 | An unexpected error occurred while trying to remove the "%1" group from the database.
CIS_E_ADMIN_UNEXPECTED_REMOVE_SERVER | 0x1517 | An unexpected error occurred while trying to remove the "%1" server from the database.
CIS_E_ADMIN_NOTIMESTAMPS | 0x151A | The specified administration timestamps object does not exist in the database.
CIS_E_ADMIN_REFRESH_THREAD_ERROR | 0x151B | The configuration refresh thread encountered an error while loading the configuration data.
CIS_E_ADMIN_REFRESH_THREAD_EXIT | 0x151C | The configuration refresh thread cannot load the configuration data because of a previous error.
CIS_E_ADMIN_RECSVC_GENERAL | 0x151D | The configuration refresh thread cannot set up one or more receive functions. This might be because SQL Server is not started.
CIS_E_ADMIN_CREATE_GROUP | 0x1529 | The server group cannot be created because "%1".
CIS_E_ADMIN_LOAD_GROUP_PROPS | 0x152A | The group properties cannot be loaded because "%1".
CIS_E_ADMIN_SAVE_GROUP_PROPS | 0x152B | The group properties cannot be saved because "%1".
CIS_E_ADMIN_REMOVE_GROUP | 0x152C | The server group cannot be removed from the database because "%1".
CIS_E_ADMIN_GETALLADMINGROUPS | 0x152D | All server groups cannot be retrieved from the database.
CIS_E_ADMIN_GETSERVERS | 0x152E | All servers for the "%1" server group cannot be retrieved from the database because "%2".
CIS_E_ADMIN_GETRECEIVESERVICES | 0x152F | All receive functions for the "%1" group cannot be retrieved from database because "%2".
CIS_E_ADMIN_GETPARSERS_IN_GROUP | 0x1531 | All parsers for the "%1" server group cannot be retrieved from the database because "%2".
CIS_E_ADMIN_GETLOCALSMTPHOST | 0x1538 | The local SMTP host cannot be retrieved because "%1".
CIS_E_ADMIN_CREATE_SERVER | 0x1539 | The server cannot be created because "%1".
CIS_E_ADMIN_LOAD_SERVER_PROPS | 0x153A | The server properties cannot be loaded because "%1".
CIS_E_ADMIN_SAVE_SERVER_PROPS | 0x153B | The server properties cannot be saved because "%1".
CIS_E_ADMIN_REMOVE_SERVER | 0x153C | The server cannot be removed from the database because "%1".
CIS_E_ADMIN_GETALLADMINSERVRES | 0x153D | All servers cannot be retrieved from the database.
CIS_E_ADMIN_GETSERVERBYNAME | 0x153E | The server properties for "%1" cannot be retrieved because "%2".
CIS_E_ADMIN_DECRYPT_PASSWORD | 0x1540 | The "%1" property cannot be retrieved.
CIS_E_ADMIN_EXEC_COMMMAND_ON_PARSER | 0x154F | The SQL command "%1" on the parser database table cannot be executed because "%2".
CIS_E_ADMIN_CREATE_RECEIVESERVICE | 0x155D | The receive function cannot be created because "%1".
CIS_E_ADMIN_LOAD_RECEIVESERVICE_PROPS | 0x155E | The receive function properties cannot be loaded because "%1".
CIS_E_ADMIN_SAVE_RECEIVESERVICE_PROPS | 0x155F | The receive function properties cannot be saved because "%1".
CIS_E_ADMIN_REMOVE_RECEIVESERVICE | 0x1560 | The receive function cannot be removed from the database because "%1".
CIS_E_ADMIN_GETALLRECEIVESERVICES | 0x1561 | All receive functions cannot be retrieved from the database because "%1".
CIS_E_ADMIN_GETALLRECEIVESERVICESINSERVER | 0x1562 | All receive functions cannot be retrieved for the "%1" server because "%2".
CIS_E_ADMIN_LOAD_TIMESTAMPS | 0x1563 | All timestamps cannot be retrieved from the database because "%1".
CIS_E_ADMIN_GETSQCONNECT | 0x1570 | The Shared Queue database connection string cannot be retrieved from the database.
CIS_E_ADMIN_GETCOMPUTERNAME | 0x1571 | The name of the local computer cannot be retrieved. Internally, BizTalk Server is using "localhost" as the computer name.
CIS_E_ADMIN_MIN_CONSTRAINT | 0x1573 | The size of the "%1" property is less than the minimum required length for "%2".
CIS_E_ADMIN_MAX_CONSTRAINT | 0x1574 | The size of the "%1" property is greater than the maximum length allowed for "%2".
CIS_E_ADMIN_GET_MGMTDB_CONNECT_PROPS | 0x1575 | The BizTalk Messaging Management database properties cannot be retrieved.
CIS_E_ADMIN_KEY_EMPTY | 0x1576 | The key to the database table, property "%1", is empty.
CIS_E_ADMIN_COCREATE_IN_CREATE | 0x1577 | An instance of the "%1" object could not be created while creating a new "%2" object.
CIS_E_ADMIN_ADO_OPEN_CONNECTSTRING | 0x1578 | The connection to the BizTalk Messaging Management database could not be opened.
CIS_E_ADMIN_COCREATE_IN_LOAD | 0x1579 | An instance of the "%1" object could not be created while loading the "%2" properties.
CIS_E_ADMIN_COCREATE_IN_SAVE | 0x1580 | An instance of the "%1" object could not be created while saving the "%2" properties.
CIS_E_ADMIN_COCREATE_IN_REMOVE | 0x1581 | An instance of the "%1" object could not be created while trying to remove the "%2" object.
CIS_E_ADMIN_COCREATE_IN_GETALL | 0x1582 | An instance of the "%1" object could not be created while trying to get all instances of "%2".
CIS_E_ADMIN_COCREATE_IN_GETALL_INSERVER | 0x1583 | An instance of the "%1" object could not be created while trying to get all instances of the "%2" object in the "%3" server.
CIS_E_ADMIN_GET_PROP | 0x1584 | The "%1" property cannot be retrieved.
CIS_E_ADMIN_CLOSE_ADO_CONNECTION | 0x1585 | The ADO connection cannot be closed.
CIS_E_ADMIN_CLOSE_ADO_RECORDSET | 0x1586 | The ADO record set cannot be retrieved.
CIS_E_ADMIN_ENCRYPT_PASSWORD | 0x1587 | The "%1" property cannot be processed.
CIS_E_ADMIN_COCREATE_IN_GETALLNAMES | 0x1588 | An instance of the "%1" object could not be created while trying to get the names of all the "%2" object instances.
CIS_E_ADMIN_COCREATE_IN_GETOTHERS_OF_GROUP | 0x1589 | An instance of the "%1" object could not be created while trying to get all instance of the "%2" object in the "%3" group.
CIS_E_ADMIN_COCREATE_IN_GET_SMTPHOST | 0x158A | An instance of the "%1" object could not be created while trying to get "%2" for the local server.
CIS_E_ADMIN_COCREATE_IN_GET_SQ_CONNECTSTRING | 0x158B | An instance of the "%1" object could not be created while trying to get the Shared Queue parameters of "%2" in order to connect to the database.
CIS_E_ADMIN_COCREATE_SERVER_BYNAME | 0x158C | An instance of the "%1" object could not be created while trying to get the properties of the "%2" server instance of the "%3" class.
CIS_E_ADMIN_GETSQCONNECT_IN_OPEN | 0x158D | The Shared Queue database connection string could not be retrieved from the database because "%1".
CIS_E_ADMIN_COCREATE_EXEC_SQL_COMMAND_ON_PARSER | 0x158E | An instance of the "%1" object could not be created while trying to execute a SQL command on the "%2" database table.
CIS_E_ADMIN_COCREATE_PARSER_CLSIDS_IN_GROUP | 0x158F | An instance of the "%1" object could not be created while retrieving the class identifiers (CLSIDs) for the parsers that belong to the "%2" group.
CIS_E_ADMIN_INVALID_ARGUMENT | 0x1590 | An unexpected internal error occurred. An invalid "%1" argument was used when calling the "%2" method.
CIS_E_ADMIN_MAX_ENUM_CONSTRAINT | 0x1591 | The value of the "%1" property is greater than the maximum value allowed for "%2".
CIS_E_ADMIN_MIN_ENUM_CONSTRAINT | 0x1592 | The value of the "%1" property is smaller than the minimum value allowed for "%2".
CIS_E_ADMIN_CREATE_CHANGETYPE_TO_BSTR | 0x1593 | The type of the "%1" property could not be changed to a string.
CIS_E_ADMIN_CREATE_CHANGETYPE_TO_BOOL | 0x1594 | The type of the "%1" property could not be changed to Boolean.
CIS_E_ADMIN_COCREATE_IN_ENUMINSTANCES | 0x1595 | An instance of the "%1" object could not be created while enumerating instances of the "%2" object.
CIS_E_ADMIN_COCREATE_IN_PUTINSTANCE | 0x1596 | An instance of the "%1" object could not be created while setting an instance of the "%2" object.
CIS_E_ADMIN_COCREATE_IN_GETOBJECT | 0x1597 | An instance of the "%1" object could not be created while getting an instance of the "%2" object.
CIS_E_ADMIN_COCREATE_IN_DELETEINSTANCE | 0x1598 | An instance of the "%1" object could not be created while deleting an instance of the "%2" object.
CIS_E_ADMIN_COCREATE_IN_LOADPROPS | 0x1599 | An instance of the "%1" object could not be created while loading properties for an instance of the "%2" object.
CIS_E_ADMIN_COCREATE_IN_LOADPARSERS | 0x159B | An instance of the "%1" object could not be created while loading parsers from a database for an instance the "%2" object.
CIS_E_ADMIN_COCREATE_IN_SETPARSERSFROM_REGISTRY | 0x159C | An instance of the "%1" object could not be created while setting parsers from the registry for an instance of the "%2" object.
CIS_E_ADMIN_COCREATE_IN_SETPARSERSFROM_CLIENT | 0x159D | An instance of the "%1" object could not be created while setting parsers from the client for an instance of the "%2" object.
CIS_E_ADMIN_COCREATE_IN_REFRESHPARSERLIST | 0x159E | An instance of the "%1" object could not be created while refreshing the parser list for an instance of the "%2" object.
CIS_E_ADMIN_COCREATE_IN_MOVETOSUSPENDED_Q | 0x159F | An instance of the "%1" object could not be created while moving an instance of "%2" to the Suspended queue.
CIS_E_ADMIN_COCREATE_IN_RESUBMIT | 0x15A0 | An instance of the "%1" object could not be created while resubmitting an instance of "%2".
CIS_E_ADMIN_COCREATE_IN_VIEWDOC | 0x15A2 | An instance of the "%1" object could not be created while viewing a document instance of "%2".
CIS_E_ADMIN_COCREATE_IN_VIEWERRORDESC | 0x15A3 | An instance of the "%1" object could not be created while viewing the error description of an instance of "%2".
CIS_E_ADMIN_COCREATE_IN_VIEWINTERCHANGE | 0x15A4 | An instance of the "%1" object could not be created while viewing the interchanges of an instance of "%2".
CIS_E_ADMIN_COCREATE_IN_FREEINTERCHANGES | 0x15A5 | An instance of the "%1" object could not be created while freeing the interchanges for an instance of a "%2".
CIS_E_ADMIN_COCREATE_IN_STARTSERVER | 0x15A6 | An instance of the "%1" object could not be created while starting the server for an instance of a "%2".
CIS_E_ADMIN_COCREATE_IN_STOPSERVER | 0x15A7 | An instance of the "%1" object could not be created while stopping the server for an instance of a "%2".
CIS_E_ADMIN_NO_DELETE_SERVER_IN_RECVSERVICE | 0x15A8 | The "%1" server cannot be deleted because it is the processing server for at least one receive function.
CIS_E_ADMIN_UPDATE_GROUP_SERVER_RUNNING | 0x15A9 | The server group properties cannot be changed because the "%1" server is still running.
CIS_E_ADMIN_UPDATE_GROUP_SERVER_ACCESS_DENIED | 0x15AA | The server group properties cannot be changed because access to the "%1" service on "%2" server is denied.
CIS_E_ADMIN_UPDATE_SERVER_SERVER_RUNNING | 0x15AC | The server properties cannot be changed because the "%1" server is still running.
CIS_E_ADMIN_UPDATE_SERVER_SERVER_ACCESS_DENIED | 0x15AD | The server properties cannot be changed because access to the "%1" service on "%2" server is denied.
CIS_E_ADMIN_UPDATE_READ_ONLY_PROP | 0x15AE | The "%1" property cannot be changed. It is a read only property.
CIS_E_ADMIN_DIFFERENT_ROOT | 0x15AF | The "%1" server may already belong to a different BizTalk Server installation.
CIS_E_ADMIN_NOT_RESUBMITABLE | 0x15B0 | This Suspended queue item cannot be submitted again.
CIS_E_ADMIN_DBCONNECT | 0x15B1 | BizTalk Server failed to access the "%1" database on the "%2" server with the database connection information.
CIS_E_ADMIN_PURGE_SUSPENDEDQ | 0x15B2 | An instance of the "%1" object could not be created while deleting documents from "%2".
CIS_E_ADMIN_REQ_PROP_MISSING | 0x15B3 | %1 cannot be NULL.
CIS_E_ADMIN_WMI_ERROR_HANDLING | 0x15B4 | The BizTalk Server WMI provider error-handling method failed. The original error description for the error that called the error-handling method is: "%1".
CIS_W_ADMIN_QUERY_FAILED | 0x15B5 | An attempt to get the Where clause values for a WMI Query failed.
CIS_E_ADMIN_INVALID_ENUM_CONSTRAINT | 0x15B6 | The value "%2" of the "%1" property is not valid.
CIS_E_ADMIN_OPENNESS_CONSTRAINT | 0x15B7 | The value "%2" of the "%1" property is not permitted when the value of the IsPassThrough property is set to TRUE.
CIS_E_ADMIN_RECEIVE_INVALID_SERVER_GROUP | 0x15B8 | the specified server and/or group is not valid
CIS_E_ADMIN_INVALID_INSTANCE_NAME | 0x15B9 | The specified instance name "%1" contains at least one of the following characters that is not valid: [ ` ~ ! @ # $ % ^ & * ( ) + = [ ] { } | \ ; " ' < > , . ? ]
BTS_E_ADMIN_GROUP_UNIQUE_NAME | 0x15BA | A BizTalk Server group with the same name already exists in the BizTalk Messaging Management database.
BTS_E_ADMIN_TIMESTAMPS_DATA_CORRUPTION | 0x15BB | Internal data corruption has been detected in the adm_TimeStamps table of the BizTalk Messaging Management database.
BTS_E_ADMIN_SERVER_UNIQUE_NAME | 0x15BC | A BizTalk Server with the same name already exists in the BizTalk Messaging Management database.
BTS_E_ADMIN_SERVER_FOREIGN_GROUPNAME | 0x15BD | This BizTalk Server does not reference a valid BizTalk Server group in the BizTalk Messaging Management database.
BTS_E_ADMIN_RECSVC_UNIQUE_NAME | 0x15BE | A BizTalk Server receive function with the same name already exists in the BizTalk Messaging Management database.
BTS_E_ADMIN_RECSVC_FOREIGN_GROUPNAME | 0x15BF | This BizTalk Server receive function does not reference a valid BizTalk Server group in the BizTalk Messaging Management database.
BTS_E_ADMIN_PARSER_UNIQUE_ID | 0x15C1 | A BizTalk Server parser with the same CLSID and Group Name already exists in the BizTalk Messaging Management database.
BTS_E_ADMIN_PARSER_FOREIGN_GROUPNAME | 0x15C2 | This BizTalk Server parser does not reference a valid BizTalk Server group in the BizTalk Messaging Management database.
CIS_E_ADMIN_DB_SPROCVERSION | 0x15C3 | The "%1" database on the "%2" server does not contain the necessary database schema.
CIS_E_ADMIN_DB_VERSION | 0x15C4 | The "%1" database on the "%2" server is not compatible with the current version of the product.
CIS_E_DTA_LOG_INTERCHANGE_DETAILS_FAILED | 0x1604 | The details of an interchange could not be logged.
CIS_E_DTA_LOG_DOCUMENT_DETAILS_FAILED | 0x1605 | The details of a document could not be logged.
CIS_E_DTA_LOG_GROUP_DETAILS_FAILED | 0x1606 | The details of a group could not be logged.
CIS_E_DTA_INIT_FAILED | 0x160A | The DTA object could not be initialized.
CIS_E_DTA_FAILED_TO_GET_ADMIN_PROPERTIES | 0x160E | The administration properties could not be obtained.
CIS_E_DTA_DATABASE_CONNECTION | 0x160F | The server could not establish connection to the Tracking database.
CIS_E_DTA_LOG_DOCUMENT_FAILED | 0x1619 | A copy of the document could not be logged.
CIS_E_DTA_LOG_INTERCHANGE_FAILED | 0x1620 | A copy of the interchange could not be logged.
CIS_E_DTA_OBJECT_IS_UNINITIALIZED | 0x1623 | The DTA initialization method must be explicitly invoked before any DTA method can be invoked.
CIS_E_DTA_FAILED_TO_COMMIT | 0x1625 | Changes could not be committed to the database.
CIS_E_DTA_FAILED_TO_LOG_SOURCE_XML | 0x1626 | The intermediate source XML could not be logged.
CIS_E_DTA_FAILED_TO_LOG_DEST_XML | 0x1627 | The intermediate destination XML could not be logged.
CIS_E_DTA_ACK_NO_ROW_FOUND | 0x162B | Acknowledgment correlation failed. The correlation key(s) given did not match any record in the Tracking database.
CIS_E_DTA_ACK_MULTIPLE_ROWS_FOUND | 0x162C | Acknowledgment correlation failed. The correlation key(s) given match more than one record in the Tracking database.
CIS_E_DTA_LOG_MIME_FAILED | 0x162D | The MIME data for submission "%1" could not be logged.
CIS_W_DTA_LOG_TRACKING_FIELD_FAILED | 0x162E | The following tracking field for submission "%1" could not be logged: Tracking field: %2 Specification field name: %3 Actual value: %4 Possible causes are either a conversion error or an arithmetic overflow error. Check the tracking field settings in the document or channel configuration.
CIS_W_DTA_LOG_BINARY_TRACKING_FIELD_FAILED | 0x162F | The following tracking field for submission "%1" could not be logged: Tracking field: %2 Specification field name: %3 The submission could not be logged because the corresponding XML element or attribute is set to binary type, which can only be tracked as custom type tracking field. Correct the tracking field settings in the document or channel configuration.
CIS_E_DTA_INIT_TRANSACTIONAL_SESSION | 0x1631 | The server could not create a transactional session for the Tracking object.
CIS_W_DTA_RECORD_UPDATE_FAILED | 0x1632 | An attempt to update a tracking record has failed. The record was probably deleted prior to the update action.
CIS_E_RESPONSE_DOM_LOAD_FAILED | 0x1701 | The XML-DOM could not be loaded from the response data.
CIS_E_RECEIVE_MSMQ_BYOT_CREATE_FAILED | 0x1702 | A Message Queuing receive function failed to create an IInterchange object using a Bring Your Own Transaction (BYOT) object. This may have been caused by editing the BizTalk Server COM+ application or configuring the BYOT object in its own COM+ application. This BizTalk Message Queuing receive function will be stopped.
CIS_E_RECEIVE_MSMQ_ZERO_BYTE_DOC | 0x1703 | A Message Queuing receive function read a zero byte document. This document has been discarded.
CIS_E_RECEIVE_SERVICE_FAILED | 0x1704 | There was a failure processing the "%1" receive function. Check your receive function configuration in BizTalk Server Administration.
CIS_E_INITWORKITEM | 0x1705 | There was a failure creating the internal work item. Make sure that SQL Server is running.
CIS_E_NOPIPELINE | 0x1706 | A channel with the name "%1" cannot be located.
CIS_E_OPEN_PASSTHROUGH | 0x1707 | The channel and messaging port openness type are not compatible with the submit method call.
CIS_E_DLQ_DETAILS | 0x1708 | Details about the Suspended queue could not be retrieved.
CIS_E_INVALID_OPENDEST | 0x1709 | The destination specified for the following open-destination messaging port was not valid: %1
CIS_E_SQL_MISSINGROWS | 0x170a | Rows were missing from the record returned by SQL OLEDB provider.
CIS_E_BTF_TIME_STAMP_EXPIRED | 0x170b | The BizTalk Framework document "%1" was received with an expired "%2" timestamp. This message will be discarded.
CIS_E_ACCESS_DENIED | 0x170c | The current process did not have administrative privileges and cannot access the Suspended queue.
CIS_E_BTF_ERROR_FINDING_TAG | 0x170d | The parser could either not find the BizTalk Framework tag "%1", or the tag did not have a value. This document will be moved to the Suspended queue.
CIS_E_INVALID_FORMAT | 0x170e | The "%1" envelope format is not recognized by the server. Specify a valid envelope format.
CIS_E_INVALID_MAP | 0x170f | The server could not load the map that is referenced by this channel.
CIS_E_MALFORMED_EXPR | 0x1710 | The expression "%1" is malformed and cannot be interpreted by the server.
CIS_E_DB_SHUTDOWN | 0x1711 | The server is shutting down because of a database failure.
CIS_E_SUBMIT_BLOCKED | 0x1712 | All submit calls have been blocked due to a database failure. After correcting this problem, please go to Component Services and shut down the 'BizTalk Server Interchange Application', before attempting to call any submit method.
CIS_E_CERT_NOT_FOUND | 0x1713 | The required certificate cannot be found in the certificate store.
CIS_E_NODATA | 0x1714 | The Submit method call did not contain a document or a file path.
CIS_E_TOOMUCH_DATA | 0x1715 | The Submit method call contained both a document and a file path.
CIS_E_INVALID_OPENFLAG | 0x1716 | The Submit method call was passed an openness type that is not valid. Refer to the BizTalk Server 2000 Help documentation for the enumeration of these values.
CIS_E_PASSTHROUGH_PARAMS | 0x1717 | The Submit method call contained a channel along with source, destination, or document name information. Do not include source, destination, or document name information when passing the channel as a parameter within a Submit method call.
CIS_E_NOSRCID | 0x1718 | The Submit method call contained a source qualifier but no source identifier.
CIS_E_NODESTID | 0x1719 | The Submit method call contained a destination qualifier but no destination identifier.
MSG_TIMEBOMB_EXPIRED | 0x171A | Thank you for evaluating Microsoft BizTalk Server 2000. The period for this evaluation version has ended. Please contact Microsoft or your software reseller to obtain a licensed version of Microsoft BizTalk Server 2000.
CIS_E_LOOPBACK | 0x171B | An attempt was made to submit a document that uses the Loopback transport type. The Loopback transport type can only be used when calling the SubmitSync method.
CIS_E_DBEXECUTE | 0x171C | The following stored procedure call failed: "%1".
CIS_E_MISSING_SMTPHOST | 0x171D | In order to use the SMTP transport, the SMTP host must be specified. To specify an SMTP host, in BizTalk Server Administration expand Microsoft BizTalk Server 2000, right-click BizTalk Server Group, and then click Properties to open the BizTalk Server Group Properties dialog box. On the General tab, in the SMTP host box, specify the SMTP host that you want to use.
CIS_E_INVALIDHANDLE | 0x171E | This method expected a submission handle or an array of submission handles, but the incoming data was not valid. Verify that the parameters are correct.
CIS_E_DBCONNECT | 0x171F | BizTalk Server failed to initialize a connection to database: "%1" on server: "%2".
CIS_E_PASSTHROUGH_WITH_NOCHANNEL | 0x1720 | A valid channel name must be specified as a submission parameter on a Submit or SubmitSync method call when the pass-through flag is set to true.
CIS_W_DBFAILURE | 0x1721 | The database call failed and returned the following error string: "%1". If possible, we will attempt to retry this call.
CIS_E_GET_BTMPARAMS | 0x1722 | Unable to load connection parameters for BTM database. Please go to the Administration MMC to resolve this problem.
CIS_E_UNABLE_TO_CREATE_CUSTOM_PRE_PROC | 0x1723 | The custom preprocessing component for the receive function "%1" could not be created. This document will be moved to the Suspended queue.
CIS_E_CUSTOM_PRE_PROC_FAILED | 0x1724 | The custom preprocessing component used by the receive function "%1" failed. This document will be moved to the Suspended queue.
CIS_E_CUSTOM_PRE_PROC_NO_BSTR | 0x1725 | The custom preprocessing component used by the File receive function "%1" failed to return a valid BSTR. A valid BSTR is required. This document will be moved to the Suspended queue.
CIS_E_CUSTOM_PRE_PROC_INVALID_DATA | 0x1726 | The custom preprocessing component used by the Message Queue receive function "%1" cannot be called because the message contains data that is not a BSTR or a BYTE array. This document will be moved to the Suspended queue.
CIS_E_CUSTOM_PRE_PROC_INVALID_CP | 0x1727 | The custom preprocessing component used by the Message Queue receive function "%1" failed to return a valid code page. This document will be moved to the Suspended queue.
CIS_E_CUSTOM_PRE_PROC_INVALID_DATA_OUT | 0x1728 | The custom preprocessing component used by the Message Queue receive function "%1" failed to return a valid document, the document must be either a BSTR or a BYTE array. This document will be moved to the Suspended queue.
CIS_E_CUSTOM_FILE_PRE_PROC_FAIL | 0x1729 | The custom preprocessing component used by the file receive function "%1" failed. The document "%2" will be moved to the Suspended queue.
CIS_E_CUSTOM_PRE_PROC_CANT_SET_CTX | 0x172A | The server was unable to set the context on the custom preprocessing component used by the receive function "%1". This document will be moved to the Suspended queue.
CIS_E_FILERCV_FILE_SHARE_DOWN | 0x172B | The file receive function "%1" was unable to connect to the network share "%2". This receive function will try to connect again.
CIS_E_FILERCV_NETWORK_DOWN | 0x172C | The file receive function "%1" is experiencing network problems and was unable to connect to the network share "%2". This receive function will try to connect again.
CIS_E_RECEIVE_FUNCTION_DISABLED | 0x172D | The receive function "%1" has experienced problems, it will be shut down and disabled. Once these problems have been corrected, re-enable this receive function in BizTalk Server Administration.
CIS_E_UNRECOVERABLE | 0x172E | There was a serious error within the BizTalk Server scheduler component. The server is being shut down. Resolve this problem and then restart the server.
CIS_E_RELIABLE_NOACK | 0x172F | The server has not received a receipt for the reliable message.
CIS_E_DLQ_ID | 0x1730 | Suspended Queue ID: "%1"
CIS_E_CANNOT_FIRE_EVENT | 0x1731 | The server cannot send a WMI event for the Suspended queue item "%1". The most likely cause is that the user configured for this submission has insufficient privileges to access WMI.
CIS_E_SERIALIZER_INVALID_DOCUMENT | 0x1800 | The document with the "%1" tracking identifier is invalid XML. The serializer cannot continue.
CIS_E_BTF_INVALID_ADDRESS_TYPE | 0x1801 | The BizTalk Framework document has an "type" specified that is not valid for the "%1" address field. This document will be moved to the Suspended queue.
CIS_E_RELIABLE_MSG_RECEIPT_REQ_BY | 0x1802 | The BizTalk Framework document "%1" will not be transmitted as it has an expired "receiptRequiredBy" timestamp. This message will be discarded.
CIS_E_CUSTOM_ENVELOPE_ERROR | 0x1803 | The custom envelope:"%1" had the property "%2" specified, but the custom envelope generator could not to locate the XML node. This document will be moved to the Suspended queue.
CIS_E_SERIALIZER_INVALID_DATETIME | 0x1804 | The "%1" date or time format is not valid. Correct the format specification.
CIS_E_SERIALIZER_INVALID_DTDATA | 0x1805 | The "%1" date or time field is not a valid ISO8601 format. Make sure that the XML date or time is formatted correctly.
CIS_E_SERIALIZER_INVALID_DELIMITER | 0x1806 | The "%1" delimiter is either missing or has a value specified that is not valid. Update the delimiter value.
CIS_E_SERIALIZER_MISSING_PROPSET | 0x1807 | The "%1" document is missing the entire property set that is required for this serializer to run.
CIS_E_SERIALIZER_MISSING_PROP | 0x1808 | The property set for the "%1" document either is missing or does not contain a valid value for the "%2" property. Add or correct this property.
CIS_E_SERIALIZER_INVALIDARG | 0x1809 | Both source and destination qualifiers and values are required for this serializer to run. Specify qualifiers and values in the messaging port for this transaction.
CIS_E_SERIALIZER_MISMATCH_SPEC | 0x180A | The serialization produced no output. Verify that the document specification matches the outbound XML document.
CIS_E_SERIALIZER_FAILED | 0x180B | The serializer could not finish processing. See the following messages for details.
CIS_E_SERIALIZER_INVALID_SRCQUAL | 0x180C | The "%1" qualifier for the source identifier is too long to be placed in the outbound document header. Update the channel with a shorter qualifier.
CIS_E_SERIALIZER_INVALID_SRCID | 0x180D | The "%1" value for the source identifier is too long to be placed in the output header. Update the channel with a shorter value.
CIS_E_SERIALIZER_INVALID_DESTQUAL | 0x180E | The "%1" qualifier for the destination identifier is too long to be placed in the output header. Update the port with a shorter qualifier.
CIS_E_SERIALIZER_INVALID_DESTID | 0x180F | The "%1" value for the destination identifier is too long to be placed in the output header. Update the port with a shorter identifier.
CIS_E_SERIALIZER_INVALID_POSREC | 0x1810 | The "%1" positional record is defined to contain a record length of zero. This happens when there is no tag, and none of the fields in this record specify start and end positions. Update the fields to have valid start and end positions for this record.
CIS_E_SERIALIZER_NODELIMS | 0x1811 | This serializer component requires delimiters specified in the messaging port. Specify a valid delimiter set for this component.
CIS_E_SERIALIZER_INVALID_CHAR | 0x1812 | The serializer component has encountered a character, "%1", that is not valid. An entry specified in the InvalidCharacterMap tag of the document specification states that characters between "%2" and "%3" are not valid.
CIS_E_SERIALIZER_INVALID_LENGTH | 0x1813 | The length of the "%1" field ("%2") is not valid; it must be between %3 and %4. This document will be rejected.
CIS_E_SERIALIZER_SELECT_SINGLE_NODE_FAILED | 0x1814 | The serializer component cannot find the node using the query "%1". This document will be rejected.
CIS_E_SERIALIZER_RELIABLE_URL_MISSING | 0x1815 | The reply-to URL required for reliable messaging was not set. This document will be rejected.
CIS_E_SERIALIZER_CONTROL_NUMBER | 0x1816 | The serializer component cannot find a control number for %1 %2 in the BizTalk Management database. This document will be rejected.
CIS_E_CUSTOM_ENV_PARSE_TABLE_ERROR | 0x1817 | The serializer component failed to build the custom envelope ID:"%1", this was due to errors in the XML Schema supplied. This document will be moved to the Suspended queue.
CIS_E_SUBSYNC_RELIABLE_MSG | 0x1818 | The BizTalk Framework document that was submitted has "reliability" information specified. This information is not permitted in a synchronous call.
CIS_E_CUSTXML_BODY_NOT_FOUND | 0x1819 | The parser was unable to locate the XML document node by using the query specified in the XML specification: "%1".
CIS_E_BTF_ACK_BAD_MSG_ID | 0x181A | The BizTalk Framework receipt had a <prop:identity> tag that is not valid: "%1". This document will be moved to the Suspended queue.
CIS_E_BTF_MANIFEST_REF_MISSING | 0x181B | The BizTalk Framework document has a <manifest> tag without the mandatory <reference> tag. This document will be moved to the Suspended queue.
CIS_E_CUSTOM_ENV_NO_DOC_NODE | 0x181C | The serializer failed to create the custom envelope because the Document Container Node property was not specified in the XML specification. This document will be moved to the Suspended queue.
CIS_E_BTF_INVALID_XSI_TYPE | 0x181D | The BizTalk Framework document contains an xsi:type attribute "%1" that is not valid. This attribute must not have spaces, and the first character must be alphabetical. This document will be moved to the Suspended queue.
CIS_E_SERIALIZER_INVALID_SYNTAX_IDENTIFIER | 0x181E | The EDIFACT Syntax Identifier "%1" is not valid. Update the channel with a correct identifier.
CIS_E_SERIALIZER_INVALID_UNA_CONTROL | 0x181F | The EDIFACT UNA Control value "%1" is not valid. Update the channel with a correct value.
CIS_E_SERIALIZER_EXPECT_BSTR_VALUE | 0x1820 | The configuration data for the field "%1" must be a string. Update the data for this field.
BTS_E_XMLSERIALIZER_MISSING_DEST | 0x1821 | The BizTalk Framework header could not be generated because no destination identifier was specified.
BTS_E_XMLSERIALIZER_MISSING_SRC | 0x1822 | The BizTalk Framework header could not be generated because no source identifier was specified.
CIS_E_BTF_IDENTITY_MISSING | 0x1904 | The parser could not find the mandatory BizTalk Framework tag "identity". This document will be moved to the Suspended queue.
CIS_E_BTF_EXPIRESAT_MISSING | 0x1905 | The parser could not find the mandatory BizTalk Framework tag "expiresAt". This document will be moved to the Suspended queue.
CIS_E_MSMQ_NOT_INSTALLED | 0x1906 | The Message Queuing receive function could not be started because the Message Queuing service is not installed on the server.
CIS_W_FILE_RECEIVE_RETRY_FAILURE | 0x1907 | There are file(s) in the "%1" directory that cannot be accessed by the file receive function. The receive service will try again to access the file(s) in "%2" seconds.
CIS_E_FTP_RECEIVE_DELETE_FAILURE | 0x1908 | The "%1" FTP receive function could not delete the following file after processing it: FTP server: "%2" Directory path: "%3" File name: "%4"
CIS_E_FILE_RECEIVE_DELETE_FAILURE | 0x1909 | The following file could not be deleted after processing: "%1". Make sure that the file attribute is not set to read-only.
CIS_E_LOGON_USER_FAILURE | 0x190a | Unable to logon with the account %1. Make sure that %2 has been granted "logon locally" privilege on this server and that the BizTalk Server account has "act as part of the operating system" privilege.
CIS_E_MSMQ_RECEIVE_IMPERSONATION_FAILURE | 0x190b | The "%1" Message Queuing receive function could not impersonate the logged on user.
CIS_E_RECEIVE_CANNOT_CREATE_THREAD | 0x190c | A receive-function thread cannot be created due to a system error.
CIS_E_MSMQ_RECEIVE_OPENQ_FAILURE | 0x190d | The following Message Queuing queue cannot be opened: "%1" (Message Queuing error code: 0x%2=%3). Verify the existence and security setting of the queue.
CIS_E_MSMQ_RECEIVE_PEEKQ_FAILURE | 0x190e | The Message Queuing queue could not be read: "%1" (Message Queuing error code: 0x%2=%3).
CIS_E_MSMQ_RECEIVE_RETRIEVEQ_FAILURE | 0x190f | A message could not be retrieved from the following Message Queuing queue: '%1' (Message Queuing error: 0x%2=%3).
CIS_E_FILE_RECEIVE_FINDCHANGE_FAILURE | 0x1910 | The file-change notification cannot be set up on the following directory: "%1". Make sure that the path is correct.
CIS_E_SET_CURRENT_DIR_FAILURE | 0x1911 | The current directory cannot be set to: "%1". Make sure that the path is correct.
CIS_E_FTP_RECEIVE_OPENCONNECT_FAILURE | 0x1912 | The FTP connection to the following server cannot be opened: "%1". Verify that the user "%2" has the correct password and permissions and that the user belongs to the correct domain. Also verify that messaging port number "%3" is correct.
CIS_E_FTP_RECEIVE_GET_FAILURE | 0x1913 | The FTP GET operation could not retrieve the "%1" file from the "%2" server.
CIS_W_RECEIVE_SUBMIT_FAILURE | 0x1914 | A submit request initiated from the "%1" receive function has failed.
CIS_E_READONLY_FILE | 0x1915 | The "%1" receive function picked up the following file: '%2'. This file is marked as read-only and cannot be processed.
CIS_E_BAD_RECSVC | 0x1916 | There was a serious failure in the receive function "%1". This receive service will be shut down, please check the event log for additional error messages.
CIS_E_FILE_RECEIVE_IMPERSONATION_FAILURE | 0x1917 | The "%1" file receive function could not impersonate the logged on user.
CIS_E_MSMQ_RECEIVE_UNEXPECTED_PASSTHROUGH | 0x1918 | The ""%1"" Message Queuing receive function is not configured for a pass-through submission, but it has encountered a document that was submitted previously as a pass-through submission. Change this receive function to accept pass-through submissions or remove the pass-through document from the queue. This receive function will be shut down.
CIS_E_BTSDOCUMENT_INVALIDNAME | 0x1A00 | The document named "%1" does not exist. Correct the document name or add the document to the BizTalk Messaging Management database.
CIS_E_BTSDOCUMENT_INVALIDDOC | 0x1A01 | The server could not load any documents with the given criteria.
CIS_E_BTSDOCUMENT_AMBIGUOUS_NAMESPACE | 0x1A02 | The root node "%1" is ambiguous because documents "%2" and "%3" refer to different specifications with that name. Either change the specifications to remove this ambiguity or use the document name explicitly.
CIS_E_BTSDOCUMENT_AMBIGUOUS_PROPSET | 0x1A03 | The property set is ambiguous because documents "%1" and "%2" refer to the same property set.
CIS_E_BTSDOCUMENT_AMBIGUOUS_PROPSETSHAREID | 0x1A04 | The property set is ambiguous because documents "%1" and "%2" refer to the same property set and have reference "%3".
CIS_E_BTSDOCUMENT_INVALIDPROPERTYSET | 0x1A05 | The following property set was specified: %1.
CIS_E_BTSDOCUMENT_EMPTYPROPERTYSET | 0x1A06 | The property set was empty.
CIS_E_BTSDOCUMENT_LOADFAILED | 0x1A07 | The document "%1" could not be loaded. Possible causes are using a non-envelope specification, or incorrectly configured tracking details.
CIS_E_BTSENVELOPE_LOADFAILED | 0x1A20 | The envelope "%1" could not be loaded. A possible cause is that the specification is not valid. Configure a valid envelope specification.
CIS_E_FAILED_TO_JOIN_TX | 0x1A21 | BizTalk Server failed to join a transaction. Ensure both the DTC and the SQL Server database are running.
MSG_COM_CREATE_FAILED | 0x1B01 | An instance of the %1 class cannot be created: %2.
MSG_CONNECT_WMI_FAILED | 0x1B02 | A connection to Windows Management on "%1" cannot be established: %2.
MSG_COSETPROXY_FAILED | 0x1B03 | The authentication credential cannot be set for the Windows Management connection: %1.
MSG_WMI_ENUMINST_FAILED | 0x1B04 | Instances of the BizTalk Server WMI provider class "%1" cannot be enumerated: %2.
MSG_WMI_GETPROP_FAILED | 0x1B05 | The property value of "%1" cannot be retrieved from the BizTalk Server WMI provider because of an unexpected error: %2.
MSG_WMI_EXECQUERY_FAILED | 0x1B06 | An unexpected error is preventing execution of the BizTalk Server WMI provider query "%1": %2.
MSG_WMI_GETOBJ_FAILED | 0x1B07 | The BizTalk Server WMI provider instance of "%1" cannot be retrieved because of an unexpected error: %2.
MSG_WMI_PUTPROP_FAILED | 0x1B08 | The property value of "%1" cannot be changed because of an unexpected error: %2.
MSG_WMI_PUTINST_FAILED | 0x1B09 | The property values of the BizTalk Server WMI provider instance "%1" cannot be updated because of an unexpected error: %2.
MSG_WMI_DELINST_FAILED | 0x1B0A | The BizTalk Server WMI provider instance "%1" cannot be deleted because of an unexpected error: %2.
MSG_WMI_CREATEINST_FAILED | 0x1B0B | A new instance of the WMI class "%1" cannot be created in the BizTalk Server WMI provider: %2.
MSG_WMI_CREATEGETOBJ_FAILED | 0x1B0C | A new instance of the BizTalk Server WMI provider class "%1" cannot be created because of an unexpected error: %2.
MSG_WMI_EXECMETHOD_GETOBJ_FAILED | 0x1B0D | The method "%1" of the BizTalk Server WMI provider class "%2" cannot be executed because of a failure to retrieve the class: %3.
MSG_WMI_EXECMETHODCLASS_FAILED | 0x1B0E | The method "%1" of the BizTalk Server WMI provider class "%2" cannot be executed because of a failure to retrieve the method information: %3.
MSG_WMI_EXECMETHODSPAWN_FAILED | 0x1B0F | The method "%1" of the BizTalk Server WMI provider class "%2" cannot be executed because of an unexpected error: %3.
MSG_WMI_EXECMETHODPUTPARAM_FAILED | 0x1B10 | The method "%1" of the BizTalk Server WMI provider class "%2" cannot be executed because of a failure to set the parameter value: %3.
MSG_WMI_EXECMETHOD_FAILED | 0x1B11 | The method "%1" of the WMI class "%2" cannot be executed by the BizTalk Server WMI provider: %3.
MSG_GET_HOSTNAME_FAILED | 0x1B12 | The local computer name cannot be obtained because of an unexpected error: %1.
MSG_OUT_OF_MEMORY | 0x1B14 | Insufficient memory.
MSG_FAIL_LOAD_BMP | 0x1B17 | At least one of the bitmaps cannot be loaded in the BizTalk Server Administration console: %1.
MSG_FAIL_SET_BMPSTRIP | 0x1B18 | At least one pair of bitmaps cannot be added to the image list of the BizTalk Server Administration console: %1.
MSG_ERROR_WMI_PATH_EMPTY | 0x1B19 | The requested operation cannot be completed because of a previous WMI failure. The WMI object path is empty in this case.
MSG_ERROR_BTM_GRP_ENUM_FAIL | 0x1B20 | Unknown problems are preventing the WMI provider from enumerating a list of server groups from the BizTalk Messaging Management database: %1.
MSG_ERROR_GRP_DTA_DB_FAIL | 0x1B21 | Unknown problems are preventing the WMI provider from accessing the Tracking database for the "%1" group.
MSG_ERROR_GRP_SQ_DB_FAIL | 0x1B22 | Unknown problems are preventing the WMI provider from accessing the Shared Queue database the "%1" group.
MSG_ERROR_GRP_BOTH_DB_FAIL | 0x1B23 | Unknown problems are preventing the WMI provider from accessing the Tracking and Shared Queue databases for the "%1" group.
MSG_ERROR_DECRYPT_FAIL | 0x1B24 | Password decryption failed: %1.
MSG_WARN_ENUM4ROOTUPD_FAILED | 0x1B27 | Unknown problems are preventing the WMI provider from retrieving following list of servers and their states to prepare for BizTalk Messaging Management database update: %1
MSG_ERROR_CHANGE_ROOTDB | 0x1B28 | The server "%1" cannot be updated with the new BizTalk Messaging Management database information: %2.
MSG_ERROR_CHANGE_ROOTDB_CONNECT | 0x1B29 | We cannot connect to the WMI namespace "%1" to update server "%2" with the new BizTalk Messaging Management database information: %3
MSG_CHANGE_ROOTDB_SUMMARY | 0x1B30 | The BizTalk Messaging Management database change request has been completed. %1%2 %3%4
MSG_CHANGE_ROOTDB_ON_LOCAL | 0x1B3A | Because the server and server group information cannot be retrieved from the original BizTalk Messaging Management database, the BizTalk Messaging Management database information will be updated only on the local computer "%1". The update has been successful.
MSG_ERROR_UNEXPECTED_ENDOFLIST | 0x1B3C | An unexpected end of list (EOL) for the "%1" class enumeration has been reached.
MSG_ERROR_ORG_QUALIFIERS_FROM_DB_FAILED | 0x1B3D | The organization qualifiers cannot be retrieved from the BizTalk Messaging Management database because of an unexpected error. "%1".
MSG_ERROR_ORG_VALUES_FROM_DB_FAILED | 0x1B3E | The organization values cannot be retrieved from the BizTalk Messaging Management database because of an unexpected error. "%1".
MSG_WARN_NOT_RESUBMITABLE | 0x1B3F | In the selected group of multiple items, at least one item cannot be submitted again.
MSG_WARNING_PROP_VALUES_CHANGED | 0x1B40 | %1 "%2" specified for receive function "%3" has been removed from the BizTalk Messaging Management database.
MSG_WARNING_QUALIFIER_CHANGED | 0x1B41 | The qualifier and identifier pair "%1" and "%2" specified for receive function "%3" is not valid in the BizTalk Messaging Management database.
MSG_WARNING_ORGANIZATION_CHANGED | 0x1B42 | Organization "%1" specified for receive function "%2" is not valid in the BizTalk Messaging Management database.
MSG_TIMEBOMB_DAYS_LEFT | 0x1B43 | Thank you for evaluating Microsoft BizTalk Server 2000. The period for this evaluation version has %1 days left. Please contact Microsoft or your software reseller to obtain a licensed version of Microsoft BizTalk Server 2000.
INTERCHANGE_EVENT | 0x3005 | BizTalk Server: %1

Note

  • When an error occurs, the %n variables are replaced with relevant information, such as an object name.


Submitting Documents

This section provides information about how to submit documents to Microsoft BizTalk Server 2000. For additional information, see the following sections:

  • For help with specific tasks, see How To.

  • For general background information, see Concepts.

  • For information about COM interfaces and enumerations, see the Submitting Documents Reference.

  • For examples of code, see BizTalk Messaging Services Code Samples.


How To...

This section provides task-specific information about how to submit documents to Microsoft BizTalk Server 2000. It is highly recommended that you review the Concepts as well. The following topics are covered:

  • Read the Tracking Database

  • Submit a Document from a Remote Client


Read the Tracking Database

The purpose of the tracking interface, IBizTalkTrackData, is to facilitate programmatic access to the tracking information of Microsoft BizTalk Server 2000. This complements the IInterchange interface so that returns from IInterchange calls can be fed to these IBizTalkTrackData methods to access data about the activity of documents submitted to BizTalk Server 2000.

There can be a one-to-one or a one-to-many relationship between input and output documents. In a normal document flow, one document is submitted to the server, is tracked and possibly transformed, and one document results as output from the server. However, the messaging port can be configured so that one document submitted can result in many documents as output to several destinations:

  1. Get the SubmissionHandle return from the Submit method of the IInterchange interface.

  2. Call the GetInterchanges method, using the SubmissionHandle return as the input. This method returns a list of interchanges contained in that submission, including all the data from the Tracking database. Because transport-specific information (delivery times, receipt flags, and so on) appears in the interchange data, you can look here to confirm or check status on delivery, for example.

  3. Call the GetInDocDetails method, using the SubmissionHandle return as the input. This method returns a list of the documents that were included in that submission. You can look here to find information about an input document (for example, was a specific document valid, how many bytes was it, and so on).

  4. Call the GetOutDocDetails method, using the SubmissionHandle return as the input. This method returns a list of the documents that were generated as a result of the submission. You can look here to find information about an output document (for example, looking for PO #123456 out of a submission made earlier today).

Related Topic

Submitting Documents Reference


Submit a Document from a Remote Client

A document can be submitted to Microsoft BizTalk Server 2000 from a remote client running an application that uses the IInterchange interface. To accomplish this, follow these steps:

  1. Using a computer that has Microsoft BizTalk Server 2000 installed, go to the Start menu, point to Programs, point to Administrative Tools, and then click Component Services.

  2. In the Tree pane, click Component Services, expand Computers, expand My Computer, expand COM+ Applications, and then click BizTalk Server Interchange Application.

  3. On the Action menu, click Export.

  4. On the Welcome to the COM Application Export Wizard dialog box, enter the name of an export installation package to be created.

  5. In the Export as area, click the Application proxy option and click Next to finish the wizard.

The COM Application Export Wizard creates a Windows Installer Package file with an .msi extension and its associated Cabinet file with a .cab extension. Copy these files to the remote client and run the Windows Installer Package file. Now the remote client can run applications that use the IInterchange interface.

Notes

  • The remote client must be running Microsoft Windows 2000.

  • The computer used to create the installation package acts as an "interchange server" for the remote client that is submitting documents. Therefore, all documents submitted on the remote client are routed through that server.

  • You can also create a remote client during the BizTalk Server 2000 installation.


Submitting Documents Reference

This section provides reference information about components and interfaces used to submit documents to Microsoft BizTalk Server 2000 for both Microsoft Visual C++ and Visual Basic programming. Reference information is provided for all interfaces, objects, and enumerations exposed for submitting documents to BizTalk Server 2000.

The following COM interfaces and enumerations are documented in this reference:

  • IBizTalkTrackData

  • IBTSCustomProcess

  • IBTSCustomProcessContext

  • IInterchange

  • Interchange Enumerations


IBizTalkTrackData Interface [C++]

BTSDocTracking Object [Visual Basic]

Use this object to facilitate programmatic access to the tracking information of Microsoft BizTalk Server 2000. This object complements the Interchange object so that returns from Interchange methods can be passed to these methods for reading tracking data about the documents submitted to BizTalk Server 2000.

In C++, use the IBizTalkTrackData interface to access the methods of the BizTalkTrackData object.

The methods of the BizTalkTrackData object are shown in the following table.

Method | Description
GetInDocDetails | Returns an ADO recordset that contains a list of the documents that were included in the SubmissionHandle return from the Submit method of the IInterchange interface. This method returns specific information for an input document.
GetInterchanges | Returns an ADO recordset that contains a list of interchanges contained in the SubmissionHandle return from the Submit method of the IInterchange interface, including all the data from the Tracking database. Transport-specific information, such as delivery times and receipt flags, appears in the Tracking database; you can check there to confirm or check status on delivery, for example.
GetOutDocDetails | Returns an ADO recordset that contains a list of the documents that were generated when the Submit method of the IInterchange interface was called. This method returns specific information for an output document, for example, PO #123456 from a Submit call made earlier today.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BTSDocTracking.h
Library: Use Microsoft BizTalk Server Doc Tracking 1.0 Type Library (CISDTA.dll)

Related Topics

Understanding the Tracking Database Schema

Document Definitions

Read the Tracking Database

Document Tracking


IBizTalkTrackData::GetInDocDetails Method [C++]

BTSDocTracking.GetInDocDetails Method [Visual Basic]

The GetInDocDetails method returns an ADO recordset that contains a list of the documents that were included in the SubmissionHandle return from the Submit method of the IInterchange interface. This method returns specific information for an input document.

Syntax

[C++]

HRESULT GetInDocDetails(
    BSTR bstrSubmissionID,
    IDispatch** ppdispResult

);

[Visual Basic]

object.GetInDocDetails( _
    bstrSubmissionID As String _
)

Parameters

[C++]

bstrSubmissionID

[in] BSTR that contains the SubmissionHandle string returned by Submit for this document instance.

ppdispResult

[out, retval] Address of a pointer to an IDispatch interface that contains a list of the documents that were included in the submission.

[Visual Basic]

bstrSubmissionID

String that contains the SubmissionHandle string returned by Submit for this document instance.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This method returns an Object that contains a list of the documents that were included in the submission.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BTSDocTracking.h
Library: Use Microsoft BizTalk Server Doc Tracking 1.0 Type Library (CISDTA.dll)

Related Topic

Understanding the Tracking Database Schema


IBizTalkTrackData::GetInterchanges Method [C++]

BTSDocTracking.GetInterchanges Method [Visual Basic]

The GetInterchanges method returns an ADO recordset that contains a list of interchanges contained in the SubmissionHandle return from the Submit method of the IInterchange interface, including all the data from the Tracking database. Because transport-specific information, such as delivery times and receipt flags, appears in the Tracking database, you can check there to confirm or check status on delivery, for example.

Syntax

[C++]

HRESULT GetInterchanges(
    BSTR bstrSubmissionID,
    IDispatch** ppdispResult
);

[Visual Basic]

object.GetInterchanges( _
    bstrSubmissionID As String, _
)

Parameters

[C++]

bstrSubmissionID

[in] BSTR that contains the SubmissionHandle string returned by Submit for this document instance.

ppdispResult

[out, retval] Address of a pointer to an IDispatch interface that contains a list of interchanges contained in this submission, including all the data from the Tracking database.

[Visual Basic]

bstrSubmissionID

String that contains the SubmissionHandle string returned by Submit for this document instance.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This method optionally returns an Object that contains a list of interchanges contained in this submission, including all the data from the Tracking database.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BTSDocTracking.h
Library: Use Microsoft BizTalk Server Doc Tracking 1.0 Type Library (CISDTA.dll)

Related Topic

Understanding the Tracking Database Schema


IBizTalkTrackData::GetOutDocDetails Method [C++]

BTSDocTracking.GetOutDocDetails Method [Visual Basic]

The GetOutDocDetails method returns an ADO recordset that contains a list of the documents that were generated as a result of the Submit method of the IInterchange interface. This method returns specific information for an output document, for example, PO #123456 from a Submit call made earlier today.

Syntax

[C++]

HRESULT GetOutDocDetails(
    BSTR bstrSubmissionID,
    IDispatch** ppdispResult
);

[Visual Basic]

object.GetOutDocDetails( _
    bstrSubmissionID As String _
)

Parameters

[C++]

bstrSubmissionID

[in] BSTR that contains the SubmissionHandle string returned by Submit for this document instance.

ppdispResult

[out, retval] Address of a pointer to an IDispatch interface that contains a list of the documents that were generated as a result of the submission.

[Visual Basic]

bstrSubmissionID

String that contains the SubmissionHandle string returned by Submit for this document instance.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This method returns an Object that contains a list of the documents that were generated as a result of the submission.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BTSDocTracking.h
Library: Use Microsoft BizTalk Server Doc Tracking 1.0 Type Library (CISDTA.dll)

Related Topic

Understanding the Tracking Database Schema


IBTSCustomProcess Interface [C++]

IBTSCustomProcess Object [Visual Basic]

Implement IBTSCustomProcess to create a custom preprocessor for BizTalk Server receive functions.

The methods of IBTSCustomProcess are shown in the following table.

Method | Description
Execute | Performs the custom processing of the data prior to sending the data to BizTalk Server for processing.
SetContext | Retrieves context information associated with the data being processed.

Remarks

For information about custom preprocessors, see Preprocessing Documents in a Receive Function.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include btsaic.h
Library: Use Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)


IBTSCustomProcess::Execute Method [C++]

IBTSCustomProcess.Execute Method [Visual Basic]

The Execute method performs the custom processing on data obtained from a receive function.

Syntax

[C++]

HRESULT Execute(
    VARIANT vDataIn,
    long nCodePageIn,
    VARIANT_BOOL bIsFilePath,
    VARIANT* nCodePageOut,
    VARIANT* vDataOut
);

[Visual Basic]

object.Execute( _
    vDataIn As Variant, _
    nCodePageIn As Long, _
    bIsFilePath As Boolean, _
    nCodePageOut As Variant, _
    vDataOut As Variant _
)

Parameters

[C++]

vDataIn

[in] VARIANT that contains the input data read by the receive function. For data read from a message queue, the data can be either an array or a BSTR. If the data is read from a file receive function, this parameter contains the file path. For file receive functions, the bIsFilePath parameter is set to VARIANT_TRUE.

nCodePageIn

[in] Long that contains the code page of the input data. The code page indicates the character set and keyboard layout used on a computer.

bIsFilePath

[in] VARIANT_BOOL flag that indicates the type of input data. A value of VARIANT_TRUE indicates that the vDataIn parameter contains a file path. A value of VARIANT_FALSE indicates that the vDataIn parameter contains data from a message queue.

nCodePageOut

[out] Pointer to a VARIANT that contains the code page of the output data. The code page indicates the character set and keyboard layout used on a computer.

vDataOut

[out] Pointer to a VARIANT that contains the output data. For file receive functions, this will be a BSTR. The data in this parameter is sent to BizTalk Server for processing.

[Visual Basic]

vDataIn

VARIANT that contains the input data read by the receive function. If the data is read from a file receive function, this parameter contains the file path. For file receive functions, the bIsFilePath parameter must be set to True.

nCodePageIn

Long that contains the code page of the input data. The code page indicates the character set and keyboard layout used on a computer.

bIsFilePath

VARIANT_BOOL flag that indicates the type of input data. A value of True indicates that the vDataIn parameter contains a file path. A value of False indicates that the vDataIn parameter contains data from a message queue.

nCodePageOut

VARIANT that contains the code page of the output data. The code page indicates the character set and keyboard layout used on a computer.

vDataOut

VARIANT that contains the output data. The data in this parameter is sent to BizTalk Server for processing.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

If BizTalk Server fails to create the custom preprocessor component, or if the Execute method returns an error or invalid data, the document being processed is placed in the Suspended queue.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include btsaic.h
Library: Use Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)


IBTSCustomProcess::SetContext Method [C++]

IBTSCustomProcess.SetContext Method [Visual Basic]

The SetContext method retrieves information associated with a document submitted to BizTalk Server.

Syntax

[C++]

HRESULT SetContext(
    IBTSCustomProcessContext* pCtx
);

[Visual Basic]

object.SetContext( _
    pCtx As IBTSCustomProcessContext _
)

Parameters

[C++]

pCtx

[in] IBTSCustomProcessContext that contains information associated with the document being processed by BizTalk Server.

[Visual Basic]

pCtx

IBTSCustomProcessContext that contains information associated with the document being processed by BizTalk Server.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

For additional information about the custom process context object, see IBTSCustomProcessContext.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include btsaic.h
Library: Use Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)


IBTSCustomProcessContext Interface [C++]

IBTSCustomProcessContext Object [Visual Basic]

Use this object to retrieve information associated with data being processed by using a custom preprocessor component.

In C++, use the IBTSCustomProcessContext interface to access the methods of the BTSCustomProcessContext object.

The properties of the BTSCustomProcessContext object are shown in the following table.

Property | Type | Description
ChannelName | BSTR | Name of the channel.
DestID | BSTR | Value of the destination organization qualifier.
DestQualifier | BSTR | Qualifier type of the destination organization.
DocName | BSTR | Name of the document.
EnvelopeName | BSTR | Name of the envelope used with the document.
Openness | long | Value that indicates if the messaging port is open.
PassThrough | long | Value that indicates whether pass-through submission mode is being used.
SourceID | BSTR | Value of the source organization qualifier.
SourceQualifier | BSTR | Qualifier type of the source organization.

Remarks

This object can be obtained by calling the SetContext method on the IBTSCustomProcess object. For information about custom preprocessors, see Preprocessing Documents in a Receive Function.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include btsaic.h
Library: Use Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)


IBTSCustomProcessContext::ChannelName Property [C++]

IBTSCustomProcessContext.ChannelName Property [Visual Basic]

The ChannelName property returns the name of the channel used for processing the current document.

Syntax

[C++]

Get method:

HRESULT get_ChannelName(
    BSTR* bstrPipelineName
);

[Visual Basic]

object.ChannelName()

Parameters

[C++]

bstrPipelineName

[out, retval] Pointer to a BSTR that contains the name of the channel used for processing the current document.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a String that contains the channel name.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include btsaic.h
Library: Use Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)


IBTSCustomProcessContext::DestID Property [C++]

IBTSCustomProcessContext.DestID Property [Visual Basic]

The DestID property returns the value of the destination organization qualifier.

Syntax

[C++]

Get method:

HRESULT get_DestID(
    BSTR* bstrDestID
);

[Visual Basic]

object.DestID()

Parameters

[C++]

bstrDestID

[out, retval] Pointer to a BSTR that contains the value of the destination organization qualifier.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a String that contains the value of the destination organization qualifier.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include btsaic.h
Library: Use Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)


IBTSCustomProcessContext::DestQualifier Property [C++]

IBTSCustomProcessContext.DestQualifier Property [Visual Basic]

The DestQualifier property returns the destination organization qualifier type.

Syntax

[C++]

Get method:

HRESULT get_DestQualifier(
    BSTR* bstrDestQualifier
);

[Visual Basic]

object.DestQualifier()

Parameters

[C++]

bstrDestQualifier

[out, retval] Pointer to a BSTR that contains the destination organization qualifier type.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

[Visual Basic]

This property returns a String that contains the destination organization qualifier type.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include btsaic.h
Library: Use Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)


IBTSCustomProcessContext::DocName Property [C++]

IBTSCustomProcessContext.DocName Property [Visual Basic]

The DocName property returns the name of the document definition used by the current document.

Syntax

[C++]

Get method:

HRESULT get_DocName(
    BSTR* bstrDocName
);

[Visual Basic]

object.DocName()

Parameters

[C++]

bstrDocName

[out, retval] Pointer to a BSTR that contains the document definition name.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a String that contains the document definition name.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include btsaic.h
Library: Use Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)


IBTSCustomProcessContext::EnvelopeName Property [C++]

IBTSCustomProcessContext.EnvelopeName Property [Visual Basic]

The EnvelopeName property returns the name of the envelope used with the current document.

Syntax

[C++]

Get method:

HRESULT get_EnvelopeName(
    BSTR* bstrEnvelopeName
);

[Visual Basic]

object.EnvelopeName()

Parameters

[C++]

bstrEnvelopeName

[out, retval] Pointer to a BSTR that contains the envelope name.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a String that contains the envelope with the current document.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include btsaic.h
Library: Use Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)


IBTSCustomProcessContext::Openness Property [C++]

IBTSCustomProcessContext.Openness Property [Visual Basic]

The Openness property returns the openness associated with the messaging port.

Syntax

[C++]

Get method:

HRESULT get_Openness(
    long* lOpenness
);

[Visual Basic]

object.Openness()

Parameters

[C++]

lOpenness

[out, retval] Pointer to a long that indicates openness on the messaging port. The long returned in this parameter represents a value in the BIZTALK_OPENNESS_TYPE enumeration.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a Long that indicates openness on the messaging port. The Long returned in this property represents a value in the BIZTALK_OPENNESS_TYPE enumeration.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include btsaic.h
Library: Use Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)


IBTSCustomProcessContext::PassThrough Property [C++]

IBTSCustomProcessContext.PassThrough Property [Visual Basic]

The PassThrough property indicates whether the document uses pass-through submission mode.

Syntax

[C++]

Get method:

HRESULT get_PassThrough(
    long* fPassThrough
);

[Visual Basic]

object.PassThrough()

Parameters

[C++]

fPassThrough

[out, retval] Pointer to a long that indicates whether the document uses pass-through submission mode. A value of 0 indicates that pass-through submission mode is not used. A non-zero value indicates that pass-through submission mode is used with the current document.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a Long that indicates whether the document uses pass-through submission mode. A value of 0 indicates that pass-through submission mode is not used. A non-zero value indicates that pass-through submission mode is used with the current document.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include btsaic.h
Library: Use Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)


IBTSCustomProcessContext::SourceID Property [C++]

IBTSCustomProcessContext.SourceID Property [Visual Basic]

The SourceID property returns the value of the source organization qualifier.

Syntax

[C++]

Get method:

HRESULT get_SourceID(
    BSTR* bstrSourceID
);

[Visual Basic]

object.SourceID()

Parameters

[C++]

bstrSourceID

[out, retval] Pointer to a BSTR that contains the value of the source organization qualifier.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a String that contains the value of the source organization qualifier.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include btsaic.h
Library: Use Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)


IBTSCustomProcessContext::SourceQualifier Property [C++]

IBTSCustomProcessContext.SourceQualifier Property [Visual Basic]

The SourceQualifier property returns the source organization qualifier type.

Syntax

[C++]

Get method:

HRESULT get_SourceQualifier(
    BSTR* bstrSourceQualifier
);

[Visual Basic]

object.SourceQualifier()

Parameters

[C++]

bstrSourceQualifier

[out, retval] Pointer to a BSTR that contains the source organization qualifier type.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a String that contains the source organization qualifier type.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include btsaic.h
Library: Use Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)


IInterchange Interface [C++]

Interchange Object [Visual Basic]

Use this object to exchange documents between applications and BizTalk Server 2000 directly or through a receive function

In C++, use the IInterchange interface to access the methods of the Interchange object.

The methods of the Interchange object are shown in the following table.

Method | Description
CheckSuspendedQueue | Checks the Suspended queue and returns a list of handles to documents or interchanges in the queue that match the request criteria.
DeleteFromSuspendedQueue | Deletes all specified documents from the Suspended queue.
GetSuspendedQueueItemDetails | Returns details of a document in the Suspended queue.
Submit | Submits an interchange to BizTalk Server 2000 for asynchronous processing. This method accepts only a string variable as the document or interchange. This means that applications cannot submit other objects, such as DOM objects, CDictionary objects, ADO objects, or any other data type or object type.
SubmitSync | Submits an interchange to BizTalk Server 2000 for synchronous transmission. This method returns a response if one is provided. This method accepts only a string variable for the document or interchange. This means that applications cannot submit other objects, such as DOM objects, CDictionary objects, ADO objects, or any other data type or object type.

Remarks

Using parameters with Submit and SubmitSync overrides certain fields in the header of a self-routing document.

For information about submitting documents from a remote client, see How To.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include cisapi.h
Library: (cisapi.tlb)

Related Topics

Submitting

Routing

Steps for Submitting a Document by Using COM Interfaces


IInterchange::CheckSuspendedQueue Method [C++]

Interchange.CheckSuspendedQueue Method [Visual Basic]

The CheckSuspendedQueue method checks the Suspended queue and returns a list of documents that match the request criteria.

Syntax

[C++]

HRESULT CheckSuspendedQueue(
    BSTR DocName,
    BSTR SourceName,
    BSTR DestName,
    VARIANT* DocumentHandleList
);

[Visual Basic]

object.CheckSuspendedQueue( _
    DocName As String, _
    SourceName As String, _
    DestName As String _
)

Parameters

[C++]

DocName

[in] BSTR that contains the name of the BizTalkDocument object. This parameter narrows the search for items in the Suspended queue. If this parameter is omitted, this method matches all BizTalkDocument objects. This is an optional parameter.

SourceName

[in] BSTR that contains the name of the source BizTalkOrganization object. This parameter narrows the search criteria for items in the Suspended queue. If this parameter is omitted, this method matches all BizTalkOrganization objects. This is an optional parameter.

DestName

[in] BSTR that contains the name of the destination BizTalkOrganization object. This parameter narrows the search criteria for items in the Suspended queue. If this parameter is omitted, this method matches all BizTalkOrganization objects. This is an optional parameter.

DocumentHandleList

[out] Pointer to a VARIANT that contains a list of handles to all documents in the Suspended queue.

[Visual Basic]

DocName

String that contains the name of the BizTalkDocument object. This parameter narrows the search for items in the Suspended queue. If this parameter is omitted, this method matches all BizTalkDocument objects. This is an optional parameter.

SourceName

String that contains the name of the source BizTalkOrganization object. This parameter narrows the search criteria for items in the Suspended queue. If this parameter is omitted, this method matches all BizTalkOrganization objects. This is an optional parameter.

DestName

String that contains the name of the destination BizTalkOrganization object. This parameter narrows the search criteria for items in the Suspended queue. If this parameter is omitted, this method matches all BizTalkOrganization objects. This is an optional parameter.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This method returns a Variant that contains a list of handles to all documents in the Suspended queue.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

The returned items are not deleted from the queue. To delete items from the Suspended queue, use the DeleteFromSuspendedQueue method.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include cisapi.h
Library: (cisapi.tlb)

Related Topics

Submitting

Steps for Submitting a Document by Using COM Interfaces


IInterchange::DeleteFromSuspendedQueue Method [C++]

Interchange.DeleteFromSuspendedQueue Method [Visual Basic]

The DeleteFromSuspendedQueue method deletes all specified documents from the Suspended queue.

Syntax

[C++]

HRESULT DeleteFromSuspendedQueue(
    VARIANT* DocumentHandleList
);

[Visual Basic]

object.DeleteFromSuspendedQueue( _
    DocumentHandleList As Variant _
)

Parameters

[C++]

DocumentHandleList

[in] Pointer to a VARIANT that contains a full list of handles or a subset for documents to be deleted from the Suspended queue.

[Visual Basic]

DocumentHandleList

Variant that contains a full list of handles or a subset for documents to be deleted from the Suspended queue.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

None.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include cisapi.h
Library: (cisapi.tlb)

Related Topics

Submitting

Steps for Submitting a Document by Using COM Interfaces


IInterchange::GetSuspendedQueueItemDetails Method [C++]

Interchange.GetSuspendedQueueItemDetails Method [Visual Basic]

The GetSuspendedQueueItemDetails method uses the list of handles returned by the CheckSuspendedQueue method to get information about a single entry in the Suspended queue.

Syntax

[C++]
HRESULT GetSuspendedQueueItemDetails(
    BSTR ItemHandle,
    VARIANT* SourceName,
    VARIANT* DestName,
    VARIANT* DocName,
    VARIANT* ReasonCode,
    VARIANT* ItemData
);
[Visual Basic]
object.GetSuspendedQueueItemDetails( _
    ItemHandle As String, _
    SourceName As Variant, _
    DestName As Variant, _
    DocName As Variant, _
    ReasonCode As Variant, _
    ItemData As Variant _
)

Parameters

[C++]

ItemHandle

[in] BSTR that contains the handle to an item in the Suspended queue.

SourceName

[out] Pointer to the VARIANT that contains the name of the source BizTalkOrganization object.

DestName

[out] Pointer to the VARIANT that contains the name of the destination BizTalkOrganization object.

DocName

[out] Pointer to the VARIANT that contains the name of the BizTalkDocument object.

ReasonCode

[out] Pointer to the VARIANT that contains the reason a document or interchange has been placed in the Suspended queue. For more information about this value, see the CISReasonToQueue enumeration.

ItemData

[out] Pointer to the VARIANT that contains the document instance or interchange.

[Visual Basic]

ItemHandle

String that contains the handle to an item in the Suspended queue.

SourceName

Variant that contains the name of the source BizTalkOrganization object. The value of this output parameter is set by calling this method.

DestName

Variant that contains the name of the destination BizTalkOrganization object. The value of this output parameter is set by calling this method.

DocName

Variant that contains the name of the associated BizTalkDocument object. The value of this output parameter is set by calling this method.

ReasonCode

Variant that contains the reason a document or interchange has been placed in the Suspended queue. For more information about this value, see the CISReasonToQueue enumeration. The value of this output parameter is set by calling this method.

ItemData

Variant that contains the document instance or interchange. The value of this output parameter is set by calling this method.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

None.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include cisapi.h
Library: (cisapi.tlb)

Related Topics

Submitting

Steps for Submitting a Document by Using COM Interfaces


IInterchange::Submit Method [C++]

Interchange.Submit Method [Visual Basic]

The Submit method sends a document to BizTalk Server 2000 for asynchronous processing. BizTalk Server 2000 places the document in a queue until the next available server can process it.

Syntax

[C++]

HRESULT Submit(
    BIZTALK_OPENNESS_TYPE lOpenness,
    BSTR Document,
    BSTR DocName,
    BSTR SourceQualifier,
    BSTR SourceID,
    BSTR DestQualifier,
    BSTR DestID,
    BSTR ChannelName,
    BSTR FilePath,
    BSTR EnvelopeName,
    long PassThrough,
    BSTR* SubmissionHandle
);

[Visual Basic]

object.Submit( _
    lOpenness As BIZTALK_OPENNESS_TYPE, _
    Document As String, _
    DocName As String, _
    SourceQualifier As String, _
    SourceID As String, _
    DestQualifier As String, _
    DestID As String, _
    ChannelName As String, _
    FilePath As String, _
    EnvelopeName As String, _
    PassThrough As Long _
)

Parameters

[C++]

lOpenness

[in] Enumeration value that indicates whether associated BizTalkPort objects can be open. Valid values are from the BIZTALK_OPENNESS_TYPE enumeration.

Document

[in] BSTR that contains the document instance submitted. This parameter accepts only a string buffer as the document or interchange. This means that applications cannot submit other objects, such as DOM objects, CDictionary objects, ADO objects, or any other data type or object type. Either the Document parameter or the FilePath parameter must be specified. Do not specify both. This is an optional parameter.

DocName

[in] BSTR that contains the name of the BizTalkDocument object associated with the instance of the document being submitted. If the lOpenness parameter is set to BIZTALK_OPENNESS_TYPE_SOURCE, you can select an input BizTalkDocument object that has an X12 or EDIFACT specification. If you do, however, the output BizTalkDocument must not have an X12 or EDIFACT specification. If lOpenness is set to BIZTALK_OPENNESS_TYPE_DESTINATION, the BizTalkDocument object must not have an X12 or EDIFACT specification. The DocName parameter cannot be used if the PassThrough parameter is set to TRUE. This is an optional parameter.

SourceQualifier

[in] BSTR that contains the qualifier of the source organization. This indicates how the SourceID parameter is to be interpreted. Valid values come from the organization identifier qualifiers that are created when the user creates an alias for an organization. Common qualifiers include the DUNS number, telephone number, and BizTalk. You must specify a SourceID. The default qualifier for all new organizations is Organization Name and refers to the name of the organization in the database. If a BizTalk Framework 2.0–compliant document is submitted and a qualifier is not found during parsing, the qualifier defaults to BizTalk. The SourceQualifier parameter cannot be used if the PassThrough parameter is set to TRUE. This is an optional parameter.

SourceID

[in] BSTR that contains the value of the qualifier of the source organization. For example, if the SourceQualifier parameter is Telephone, this value is the telephone number. If the Openness flag is set to OpenSrc, SourceID is interpreted as the source organization name. The SourceID parameter cannot be used if the PassThrough parameter is set to TRUE. This is an optional parameter.

DestQualifier

[in] BSTR that contains the qualifier of the destination organization. This indicates how the DestID parameter is to be interpreted. Valid values come from the organization identifier qualifiers that are created when the user creates an alias for an organization. Common qualifiers include the DUNS number, telephone number, and BizTalk. You must specify a DestID. The default qualifier for all new organizations is OrganizationName and refers to the name of the organization in the database. If a BizTalk Framework 2.0–compliant document is submitted and a qualifier is not found during parsing, the qualifier defaults to BizTalk. The DestQualifier parameter cannot be used if the PassThrough parameter is set to TRUE. This is an optional parameter.

DestID

[in] BSTR that contains the value of the qualifier of the destination organization. For example, if the DestQualifier parameter is Telephone, this value is the telephone number. If the Openness flag is set to OpenDest, DestID is used as the destination address. Note that the queue:// prefix must be used with an open messaging port when a Message Queue is specified as the destination address. The DestID parameter cannot be used if the PassThrough parameter is set to TRUE. This is an optional parameter.

ChannelName

[in] BSTR that contains the name of the BizTalkChannel object that is executed for this document. This bypasses the normal processing in which the parser tries to determine which messaging port/channel pair to execute, based on routing information in the parameters or in the document. This is an optional parameter unless the PassThrough parameter is set to TRUE.

FilePath

[in] BSTR that specifies a fully qualified path that contains the document to be submitted, rather than submitting the document directly as a string. BizTalk Server 2000 supports URL, UNC, and drive: format only. If the document is submitted as a file that is pointed to by the FilePath parameter, the call returns successfully after BizTalk Server 2000 has successfully copied the file to the Work queue. It is safe to delete the file from the specified path as soon as this method returns successfully. When a document is submitted to the server, using FilePath to specify the data, Submit can take 30 seconds or longer if the location of the file resides on a remote server that is unavailable, if the UNC path is invalid, or if the SQL server is down. Either the Document parameter or the FilePath parameter must be specified. Do not specify both. The FilePath parameter cannot be used if the PassThrough parameter is set to TRUE and a map is specified. This is an optional parameter.

EnvelopeName

[in] BSTR that contains the name of the envelope specification to use to break the interchange into documents. When an envelope name is provided in this parameter, the envelope must have a valid interchange specification. This requirement is enforced for envelopes created for Custom XML format also. When submitting a flat file to BizTalk Server 2000, you must create an envelope for this flat file and specify the name of the envelope in EnvelopeName. This is an optional parameter.

PassThrough

[in] Long that indicates how the server processes the document. When this parameter is set to TRUE, no decryption, decoding, or signature verification is performed on the document. When set to FALSE, the document is decrypted and decoded, and the signature is verified. When using pass-through submission mode (TRUE), the BIZTALK_OPENNESS_TYPE value must be set to BIZTALK_OPENNESS_TYPE_NOTOPEN and the ChannelName parameter must be specified. In addition, the DocName, SourceQualifier, SourceID, DestQualifier, and DestID parameters cannot be specified with pass-through submission mode. Pass-through submission mode should be used to prevent data corruption when exchanging binary files, or when only the server transport and global tracking features are being used.

SubmissionHandle

[out, retval] Pointer to a BSTR that contains a unique identifier for the submitted document or interchange. This handle can be used to query the Tracking database for the status of the interchange or document submitted. If more than one document is submitted (an interchange), a single handle is returned, yet the Tracking database enables the user to get the status of all child documents related to this interchange identifier.

[Visual Basic]

lOpenness

Enumeration value that indicates whether associated BizTalkPort objects can be open. Valid values are from the BIZTALK_OPENNESS_TYPE enumeration.

Document

String that contains the document instance submitted. This parameter accepts only a string buffer as the document or interchange. This means that applications cannot submit other objects, such as DOM objects, CDictionary objects, ADO objects, or any other data type or object type. Either the Document parameter or the FilePath parameter must be specified. Do not specify both. This is an optional parameter.

DocName

String that contains the name of the BizTalkDocument object associated with the instance of the document being submitted. If the lOpenness parameter is set to BIZTALK_OPENNESS_TYPE_SOURCE, you can select an input BizTalkDocument object that has an X12 or EDIFACT specification. If you do, however, the output BizTalkDocument must not have an X12 or EDIFACT specification. If lOpenness is set to BIZTALK_OPENNESS_TYPE_DESTINATION, the BizTalkDocument object must not have an X12 or EDIFACT specification. The DocName parameter cannot be used if the PassThrough parameter is set to True. This is an optional parameter.

SourceQualifier

String that contains the qualifier of the source organization. This indicates how the SourceID parameter is to be interpreted. Valid values come from the organization identifier qualifiers that are created when the user creates an alias for an organization. Common qualifiers include the DUNS number, telephone number, and BizTalk. You must specify a SourceID. The default qualifier for all new organizations is Organization Name and refers to the name of the organization in the database. If a BizTalk Framework 2.0–compliant document is submitted and a qualifier is not found during parsing, the qualifier defaults to BizTalk. The SourceQualifier parameter cannot be used if the PassThrough parameter is set to True. This is an optional parameter.

SourceID

String that contains the value of the qualifier of the source organization. For example, if the SourceQualifier parameter is Telephone, this value is the telephone number. If the Openness flag is set to OpenSrc, SourceID is interpreted as the source organization name. The SourceID parameter cannot be used if the PassThrough parameter is set to True. This is an optional parameter.

DestQualifier

String that contains the qualifier of the destination organization. This indicates how the DestID parameter is to be interpreted. Valid values come from the organization identifier qualifiers that are created when the user creates an alias for an organization. Common qualifiers include the DUNS number, telephone number, and BizTalk. You must specify a DestID. The default qualifier for all new organizations is OrganizationName and refers to the name of the organization in the database. If a BizTalk Framework 2.0–compliant document is submitted and a qualifier is not found during parsing, the qualifier defaults to BizTalk. The DestQualifier parameter cannot be used if the PassThrough parameter is set to True. This is an optional parameter.

DestID

String that contains the value of the qualifier of the destination organization. For example, if the DestQualifier parameter is Telephone, this value is the telephone number. If the Openness flag is set to OpenDest, DestID is used as the destination address. Note that the queue:// prefix must be used with an open messaging port when a Message Queue is specified as the destination address. The DestID parameter cannot be used if the PassThrough parameter is set to True. This is an optional parameter.

ChannelName

String that contains the name of the BizTalkChannel object that is executed for this document. This bypasses the normal processing in which the parser tries to determine which messaging port/channel pair to execute, based on routing information in the parameters or in the document. This is an optional parameter unless the PassThrough parameter is set to True.

FilePath

String that specifies a fully qualified path that contains the document to be submitted, rather than submitting the document directly as a string. BizTalk Server 2000 supports URL, UNC, and drive: format only. If the document is submitted as a file that is pointed to by the FilePath parameter, the call returns successfully after BizTalk Server 2000 has successfully copied the file to the Work queue. It is safe to delete the file from the specified path as soon as this method returns successfully. When a document is submitted to the server, using FilePath to specify the data, Submit can take 30 seconds or longer if the location of the file resides on a remote server that is unavailable, if the UNC path is invalid, or if the SQL server is down. Either the Document parameter or the FilePath parameter must be specified. Do not specify both. The FilePath parameter cannot be used if the PassThrough parameter is set to True and a map is specified. This is an optional parameter.

EnvelopeName

String that contains the name of the envelope specification to use to break the interchange into documents. When an envelope name is provided as an argument, the envelope must have a valid interchange specification. This requirement is enforced for envelopes created for Custom XML format also. When submitting a flat file to BizTalk Server 2000, you must create an envelope for this flat file and specify the name of the envelope in EnvelopeName. This is an optional parameter.

PassThrough

Long that indicates how the server processes the document. When this parameter is True, no decryption, decoding, or signature verification is performed on the document. When set to False, the document is decrypted and decoded, and the signature is verified. When using pass-through submission mode (True), the BIZTALK_OPENNESS_TYPE value must be set to BIZTALK_OPENNESS_TYPE_NOTOPEN and the ChannelName parameter must be specified. In addition, the DocName, SourceQualifier, SourceID, DestQualifier, and DestID parameters cannot be specified with pass-through submission mode. Pass-through submission mode should be used to prevent data corruption when exchanging binary files, or when only the server transport and global tracking features are being used.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This method returns a String that contains a unique identifier for the submitted document or interchange. This handle can be used to query the Tracking database for the status of the interchange or document submitted. If more than one document is submitted (an interchange), a single handle is returned; yet the Tracking database can access the status of all child documents related to this interchange identifier.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include cisapi.h
Library: (cisapi.tlb)

Related Topics

Openness

Routing

Submitting

Steps for Submitting a Document by Using COM Interfaces


IInterchange::SubmitSync Method [C++]

Interchange.SubmitSync Method [Visual Basic]

The SubmitSync method sends an interchange or document to BizTalk Server 2000 for synchronous processing. An optional response document is returned to the caller.

Syntax

[C++]

HRESULT SubmitSync(
    BIZTALK_OPENNESS_TYPE lOpenness,
    BSTR Document,
    BSTR DocName,
    BSTR SourceQualifier,
    BSTR SourceID,
    BSTR DestQualifier,
    BSTR DestID,
    BSTR ChannelName,
    BSTR FilePath,
    BSTR EnvelopeName,
    long PassThrough,
    VARIANT* SubmissionHandle,
    VARIANT* ResponseDocument
);

[Visual Basic]

object.SubmitSync( _
    lOpenness As BIZTALK_OPENNESS_TYPE, _
    Document As String, _
    DocName As String, _
    SourceQualifier As String, _
    SourceID As String, _
    DestQualifier As String, _
    DestID As String, _
    ChannelName As String, _
    FilePath As String, _
    EnvelopeName As String, _
    PassThrough As Long, _
    SubmissionHandle As Variant, _
    ResponseDocument As Variant _
)

Parameters

[C++]

lOpenness

[in] Enumeration value that indicates whether associated BizTalkPort objects can be open. Valid values are from the BIZTALK_OPENNESS_TYPE enumeration.

Document

[in] BSTR that contains the document instance submitted. This parameter accepts only a string buffer as the document or interchange. This means that applications cannot submit other objects, such as DOM objects, CDictionary objects, ADO objects, or any other data type or object type. Either the Document parameter or the FilePath parameter must be specified. Do not specify both. This is an optional parameter.

DocName

[in] BSTR that contains the name of the BizTalkDocument object associated with the instance of the document submitted. If the lOpenness parameter is set to BIZTALK_OPENNESS_TYPE_SOURCE, you can select an input BizTalkDocument object that has an X12 or EDIFACT specification. If you do, however, the output BizTalkDocument must not have an X12 or EDIFACT specification. If lOpenness is set to BIZTALK_OPENNESS_TYPE_DESTINATION, the BizTalkDocument object must not have an X12 or EDIFACT specification. The DocName parameter cannot be used if the PassThrough parameter is set to TRUE. This is an optional parameter.

SourceQualifier

[in] BSTR that contains the qualifier of the source organization. This indicates how the SourceID parameter is to be interpreted. Valid values come from the organization identifier qualifiers that are created when the user creates an alias for an organization. Common qualifiers include the DUNS number, telephone number, and BizTalk. You must specify a SourceID. The default qualifier for all new organizations is Organization Name and refers to the name of the organization in the database. If a BizTalk Framework 2.0–compliant document is submitted and a qualifier is not found during parsing, the qualifier defaults to BizTalk. The SourceQualifier parameter cannot be used if the PassThrough parameter is set to TRUE. This is an optional parameter.

SourceID

[in] BSTR that contains the value of the qualifier of the source organization. For example, if the SourceQualifier parameter is Telephone, this value is the telephone number. If the Openness flag is set to OpenSrc, SourceID is interpreted as the source organization name. The SourceID parameter cannot be used if the PassThrough parameter is set to TRUE. This is an optional parameter.

DestQualifier

[in] BSTR that contains the qualifier of the destination organization. This indicates how the DestID parameter is to be interpreted. Valid values come from the organization identifier qualifiers that are created when the user creates an alias for an organization. Common qualifiers include the DUNS number, telephone number, and BizTalk. You must specify a DestID parameter. The default qualifier for all new organizations is Organization Name and refers to the name of the organization in the database. If a BizTalk Framework 2.0–compliant document is submitted and a qualifier is not found during parsing, the qualifier defaults to BizTalk. The DestQualifier parameter cannot be used if the PassThrough parameter is set to TRUE. This is an optional parameter.

DestID

[in] BSTR that contains the value of the qualifier of the destination organization. For example, if the DestQualifier parameter is Telephone, this value is the telephone number. If the Openness flag is set to OpenDest, DestID is used as the destination address. Note that the queue:// prefix must be used with an open messaging port when a Message Queue is specified as the destination address. The DestID parameter cannot be used if the PassThrough parameter is set to TRUE. This is an optional parameter.

ChannelName

[in] BSTR that contains the name of the BizTalkChannel object that is executed for this document. This bypasses the normal processing in which the parser tries to determine which messaging port/channel pair to execute, based on routing information in the parameters or in the document. This is an optional parameter unless the PassThrough parameter is set to TRUE.

FilePath

[in] BSTR that specifies a fully qualified path that contains the document to be submitted, rather than submitting the document directly as a string. BizTalk Server 2000 supports URL, UNC, and drive: format only. Either the Document parameter or the FilePath parameter must be specified. Do not specify both. The FilePath parameter cannot be used if the PassThrough parameter is set to TRUE and a map is specified. This is an optional parameter.

EnvelopeName

[in] BSTR that contains the name of the envelope specification to use to break the interchange into documents. When an envelope name is provided in this parameter, the envelope must have a valid interchange specification. This requirement is enforced for envelopes created for Custom XML format also. This is an optional parameter.

PassThrough

[in] Long that indicates how the server processes the document. When this parameter is set to TRUE, no decryption, decoding, or signature verification is performed on the document. When set to FALSE, the document is decrypted and decoded, and the signature is verified. When using pass-through submission mode (TRUE), the BIZTALK_OPENNESS_TYPE value must be set to BIZTALK_OPENNESS_TYPE_NOTOPEN and the ChannelName parameter must be specified. In addition, the DocName, SourceQualifier, SourceID, DestQualifier, and DestID parameters cannot be specified with pass-through submission mode. Pass-through submission mode should be used to prevent data corruption when exchanging binary files, or when only the server transport and global tracking features are being used.

SubmissionHandle

[out] Pointer to a BSTR that contains a unique identifier for the submitted document or interchange. This handle can be used to query the Tracking database for the status of the interchange or document submitted. If more than one document is submitted (an interchange), a single handle is returned; yet the Tracking database can access the status of all child documents related to this interchange identifier.

ResponseDocument

[out] Pointer to the VARIANT that contains the optional response document.

[Visual Basic]

lOpenness

Enumeration value that indicates whether associated BizTalkPort objects can be open. Valid values are from the BIZTALK_OPENNESS_TYPE enumeration.

Document

String that contains the document instance submitted. This parameter accepts only a string buffer as the document or interchange. This means that applications cannot submit other objects, such as DOM objects, CDictionary objects, ADO objects, or any other data type or object type. Either the Document parameter or the FilePath parameter must be specified. Do not specify both. This is an optional parameter.

DocName

String that contains the name of the BizTalkDocument object associated with the instance of the document submitted. If the lOpenness parameter is set to BIZTALK_OPENNESS_TYPE_SOURCE, you can select an input BizTalkDocument object that has an X12 or EDIFACT specification. If you do, however, the output BizTalkDocument must not have an X12 or EDIFACT specification. If lOpenness is set to BIZTALK_OPENNESS_TYPE_DESTINATION, the BizTalkDocument object must not have an X12 or EDIFACT specification. The DocName parameter cannot be used if the PassThrough parameter is set to True. This is an optional parameter.

SourceQualifier

String that contains the qualifier of the source organization. This indicates how the SourceID parameter is to be interpreted. Valid values come from the organization identifier qualifiers that are created when the user creates an alias for an organization. Common qualifiers include the DUNS number, telephone number, and BizTalk. You must specify a SourceID. The default qualifier for all new organizations is Organization Name and refers to the name of the organization in the database. If a BizTalk Framework 2.0–compliant document is submitted and a qualifier is not found during parsing, the qualifier defaults to BizTalk. The SourceQualifier parameter cannot be used if the PassThrough parameter is set to True. This is an optional parameter.

SourceID

String that contains the value of the qualifier of the source organization. For example, if the SourceQualifier parameter is Telephone, this value is the telephone number. If the Openness flag is set to OpenSrc, SourceID is interpreted as the source organization name. The SourceID parameter cannot be used if the PassThrough parameter is set to True. This is an optional parameter.

DestQualifier

String that contains the qualifier of the destination organization. This indicates how the DestID parameter is to be interpreted. Valid values come from the organization identifier qualifiers that are created when the user creates an alias for an organization. Common qualifiers include the DUNS number, telephone number, and BizTalk. You must specify a DestID. The default qualifier for all new organizations is Organization Name and refers to the name of the organization in the database. If a BizTalk Framework 2.0–compliant document is submitted and a qualifier is not found during parsing, the qualifier defaults to BizTalk. The DestQualifier parameter cannot be used if the PassThrough parameter is set to True. This is an optional parameter.

DestID

String that contains the value of the qualifier of the destination organization. For example, if the DestQualifier parameter is Telephone, this value is the telephone number. If the Openness flag is set to OpenDest, DestID is used as the destination address. Note that the queue:// prefix must be used with an open messaging port when a Message Queue is specified as the destination address. The DestID parameter cannot be used if the PassThrough parameter is set to True. This is an optional parameter.

ChannelName

String that contains the name of the BizTalkChannel object that is executed for this document. This bypasses the normal processing in which the parser tries to determine which messaging port/channel pair to execute, based on routing information in the parameters or in the document. This is an optional parameter unless the PassThrough parameter is set to True.

FilePath

String that specifies a fully qualified path that contains the document to be submitted, rather than submitting the document directly as a string. BizTalk Server 2000 supports URL, UNC, and drive: format only. Either the Document parameter or the FilePath parameter must be specified. Do not specify both. The FilePath parameter cannot be used if the PassThrough parameter is set to True and a map is specified. This is an optional parameter.

EnvelopeName

String that contains the name of the envelope specification to use to break the interchange into documents. When an envelope name is provided in this parameter, the envelope must have a valid interchange specification. This requirement is enforced for envelopes created for Custom XML format also. This is an optional parameter.

PassThrough

Long that indicates how the server processes the document. When this parameter is True, no decryption, decoding, or signature verification is performed on the document. When set to False, the document is decrypted and decoded, and the signature is verified. When using pass-through submission mode (True), the BIZTALK_OPENNESS_TYPE value must be set to BIZTALK_OPENNESS_TYPE_NOTOPEN and the ChannelName parameter must be specified. In addition, the DocName, SourceQualifier, SourceID, DestQualifier, and DestID parameters cannot be specified with pass-through submission mode. Pass-through submission mode should be used to prevent data corruption when exchanging binary files, or when only the server transport and global tracking features are being used.

SubmissionHandle

Variant that contains a unique identifier for the submitted document or interchange. This handle can be used to query the Tracking database for the status of the interchange or document submitted. If more than one document is submitted (an interchange), a single handle is returned; yet the Tracking database can access the status of all child documents related to this interchange identifier.

ResponseDocument

Variant that contains the optional response document.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

None.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

SubmitSync returns an optional response document when provided. If no response is returned, the call returns successfully, but with no response and with an HRESULT value of S_FALSE. If the destination is another BizTalk Server, an ASP page must be used to return a response.

A synchronous interchange bypasses all queues and executes all the components required by the messaging port on the calling thread. For synchronous protocols (HTTP and AIC), an optional response document is returned to the user, if available. This method is valid only for a single channel match. If the parameters set cause multiple channels to match, synchronous submission returns an error indicating that multiple channel matches are not allowed for synchronous submission. This method can be used only for single document interchanges. If the submission contains multiple documents, synchronous submission returns an error indicating that multiple document submissions are not allowed. This method does not support port groups.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include cisapi.h
Library: (cisapi.tlb)

Related Topics

Openness

Routing

Submitting

Steps for Submitting a Document by Using COM Interfaces


Interchange Enumerations

The following enumeration lists the possible values of properties and parameters:

  • CISReasonToQueue


CISReasonToQueue

The CISReasonToQueue enumerations are defined in the cisapi.h header file, located on the BizTalk Server installation drive in the Program Files\Microsoft BizTalk Server\SDK\Include folder.

The CISReasonToQueue enumeration has one of the following values:

Name | Value | Description
noReason | 0 | Not supported for this release.
rtdlqParserFailure | 1 | Specifies that the instance of the document was placed in the queue because of failure of the parser.
rtdlqParserDocFailure | 2 | Specifies that the instance of the document was placed in the queue because the business document was invalid.
rtdlqDocValidation | 3 | Specifies that the document was placed in the queue because document validation failed.
rtdlqChannelSelectFailure | 4 | Specifies that the instance of the document was placed in the queue because of failure in selecting the correct BizTalkChannel object.
rtdlqInvalidMap | 5 | Specifies that the instance of the document was placed in the queue because the map referred to by the BizTalkChannel object was formatted incorrectly.
rtdlqFieldTrackingFailure | 6 | Specifies that the instance of the document was placed in the queue because the server was unable to track the requested fields within the document.
rtdlqMappingFailure | 7 | Specifies that the instance of the document was placed in the queue because of failure of transformation.
rtdlqSerializerFailure | 8 | Specifies that the instance of the document was placed in the queue because the server could not convert this document to its native format.
rtdlqEncodingFailure | 9 | Specifies that the instance of the document was placed in the queue because the server was unable to encode this interchange.
rtdlqSigningFailure | 10 | Specifies that the instance of the document was placed in the queue because the server was unable to sign this interchange.
rtdlqEncryptionFailure | 11 | Specifies that the instance of the document was placed in the queue because the server was unable to encrypt this interchange.
rtdlqTransmissionFailure | 12 | Specifies that the instance of the document was placed in the queue because the server was unable to deliver this document.
rtdlqUserMove | 13 | Specifies that the administrator moved this instance of the document to the queue.
rtdlqTimeout | 14 | Specifies that the instance of the document was placed in the queue because a time-out occurred.
rtdlqCustomCompFailure | 15 | Specifies that the instance of the document was placed in the queue because of failure of a custom component.
unkReason | 16 | Specifies that this item was marked as "In process" by an inactive server. On restart of this server, this item was automatically moved to the Suspended queue. There was probably a catastrophic failure on the original server. Contact the system administrator for more information.
rtdlqNoChannel | 17 | Specifies that the instance of the document was placed in the queue because the BizTalkChannel object was deleted.
rtdlqMissingChannel | 18 | Specifies that the instance of the document was placed in the queue because the BizTalkChannel object specified by the Submit method of the IInterchange interface was not found.
rtdlqInvalidChannel | 19 | Specifies that the instance of the document was placed in the queue because the BizTalkChannel object specified by the Submit method of the IInterchange interface specifies an open BizTalkPort object. This is not permitted.
rtdlqOutOfMemory | 20 | Specifies that your computer has run out of memory. Rebooting is recommended.
rtdlqBTFRecReqExpired | 21 | Specifies that the document was placed in the queue because the BTF timestamp receiptRequiredBy expired.
rtdlqBTFExpiresAtExpired | 22 | Specifies that the document was placed in the queue because the BTF timestamp expiresAt expired.
rtdlqCorrelationFailure | 23 | Specifies that the document receipt failed.


Concepts

This section provides detailed conceptual information that is important to understand how to submit documents to Microsoft BizTalk Server 2000. The following topics are covered:

  • Submitting

  • Accessing the Suspended queue

  • Routing

  • Preprocessing Documents in a Receive Function

  • Steps for Submitting a Document by Using COM Interfaces


Submitting

All documents must be sent to Microsoft BizTalk Server 2000 by using the Submit or SubmitSync method of the IInterchange interface in order to be processed. If an application is Microsoft Windows–based and is capable of invoking methods on COM objects, it can submit a document directly. The business application calls the Submit or SubmitSync method of the IInterchange interface, passing in the document or the file path of the document as a string supplied as a parameter. This is the simplest approach because no additional configuration is necessary. However, this method requires that the business application be designed to support direct calls to BizTalk Server 2000.

If the application is not capable of invoking methods on COM objects, receive functions can be used to submit documents to BizTalk Server. Receive functions enable applications to post documents or interchanges to specific locations that BizTalk Server 2000 is monitoring. These locations are defined according to the specific receive function. Each receive function uses event-based monitoring to recognize the presence of a document or interchange. Once the data is received by the function, it submits the data to BizTalk Server 2000. For example, a file receive function can be configured to submit a document to BizTalk Server 2000 when the business application can save a document as a file but cannot submit it directly. For more information about adding and configuring receive functions, see Manage Receive Functions for a Server Group.

The receive functions are configured to continuously monitor a specific directory or queue for a file to appear and then be submitted to BizTalk Server 2000. HTTP and SMTP protocols are configured outside BizTalk Server 2000. You must create script pages for these transport services.

Notes

  • There is a size limit for interchanges and documents that use logging, which, if exceeded, greatly affects the performance of BizTalk Server. For more information about the size limit, see Interchange and document size limit.

  • A script or application that uses the IInterchange interface to submit documents to BizTalk Server can be run in any user account.

  • When processing envelopes that are compliant with BizTalk Framework 2.0, BizTalk Server 2000 should be considered the endpoint with regard to the expiration time. When BizTalk Framework 2.0-compliant documents are submitted to BizTalk Server 2000, either from an application or a trading partner, the following fields are overwritten if present, or created if absent:
    • In the properties subsection:

    <prop:identity>

    <prop:sentAt>

    <expiresAt>

    • In the receipt information subsection:

    <sendTo>

    <address>

    <sendReceiptBy>

For examples of code, see BizTalk Messaging Services Code Samples.

Sending documents to BizTalk Server 2000 asynchronously

Applications that submit documents asynchronously to BizTalk Server 2000 call Submit. Receive functions also call Submit. Submit returns after sending the document. No response document is returned, since the protocol does not support it.

Submit accepts only a string buffer or a file path as the document or interchange. BizTalk Server 2000 supports UNC and local file path formats.

Sending documents to BizTalk Server 2000 synchronously

Applications that submit documents synchronously to BizTalk Server 2000 call SubmitSync.

A synchronous interchange bypasses all queues and executes all the components required by the messaging port on the calling thread. For synchronous protocols, an optional response document is returned to the user, if available. This method is valid only for a single channel match. If the parameters set cause multiple channels to match, synchronous submission returns an error indicating that multiple channel matches are not allowed for synchronous submission. This method can be used only for single document interchanges. If the submission contains multiple documents, synchronous submission returns an error indicating that multiple document submissions are not allowed. This method does not support port groups.

SubmitSync accepts only a string buffer or a file path as the document or interchange. BizTalk Server 2000 supports UNC and local file path formats.

Error handling with the Submit and SubmitSync methods

When an error occurs when submitting interchanges or documents to BizTalk Server 2000, an event log entry is created and/or an error is returned to the caller, depending on which method is called and the nature of the failure. Documents submitted can end up in the Suspended queue due to a number of possible conditions. The following table describes what happens when one or more of the documents or interchanges submitted are placed in the Suspended queue due to an error during submission.

Method called | Error returned to caller | Event log entry
Submit | Document failure error | For every document that fails in processing
SubmitSync | Document failure error | None

Related Topics

Routing

Steps for Submitting a Document by Using COM Interfaces

Submitting Documents Reference


Accessing the Suspended queue

The Suspended queue contains work items that have failed processing for a variety of reasons, including parsing errors, serialization errors, failed transmissions, or the inability to find a channel configuration. You can retrieve or delete items from the queue using the interfaces provided.

Note

  • When accessing or deleting items in the Suspended queue, the script or application must be run in the context of a user account in the BizTalk Server Administrators group. The BizTalk Server Administrators group is created when BizTalk Server 2000 is installed. Additional users can be added to this group as necessary.

Retrieving items from the Suspended queue

To retrieve items from the Suspended queue, applications call the CheckSuspendedQueue method of the IInterchange interface.

CheckSuspendedQueue retrieves a list of items in the Suspended queue that meets the search criteria specified by the parameters of the method. This returns a list of handles that can subsequently be used to call the DeleteFromSuspendedQueue or the GetSuspendedQueueItemDetails method of the IInterchange interface.

Getting item details from the Suspended queue

CheckSuspendedQueue returns a list of handles to items in the Suspended queue. To process these items, you must get the item details associated with each item in the Suspended queue by using GetSuspendedQueueItemDetails.

GetSuspendedQueueItemDetails retrieves the details about an item in the Suspended queue. If this method does not return individual details about this item (because the item has been removed between the time CheckSuspendedQueue was called and the call to this method, for example), each parameter that cannot be determined is returned.

Removing items from the Suspended queue

To remove items from the Suspended queue, applications call DeleteFromSuspendedQueue.

DeleteFromSuspendedQueue removes a list of items from the Suspended queue that meets the search criteria specified by the parameters of the method.


Routing

To process a document, Microsoft BizTalk Server 2000 must load the rules that govern how the incoming document instance is to be processed. These rules are known as the channel. A specific BizTalkChannel object is associated with a BizTalkPort object and connects two organizations.

To find the channel to process the received document, the server must have the source organization, the destination organization, and the document definition. The server can obtain this information by one of the following methods:

  • This information can be found in the content of the document itself from the data contained in the routing fields (self-routing documents).

  • This information can be explicitly declared in the parameter list of the Submit method of the IInterchange interface (call-based routing).

  • This information can be explicitly declared in the properties of a custom receive function. For more information about receive functions, see Understanding Receive Functions and Document Routing.

  • You can choose to specify the channel to use when calling Submit. This causes the server to bypass the channel selection process.

Once the server has this information, it searches for the messaging port/channel pair that matches these routing criteria. If more than one channel matches, each of the channels is processed, possibly resulting in multiple output documents.

Call-based routing

In call-based routing, the source organization identifier (SourceID), the destination organization identifier (DestID), and the name of the document definition (DocName) are specified as parameters of Submit. If SourceQualifier and DestQualifier are not specified, they default to OrganizationName and refer to the name of the organization in the database. If a BizTalk Framework 2.0–compliant document is submitted and a qualifier is not found during parsing, the qualifier defaults to BizTalk. If the Openness flag is set to OpenDest, the DestID is used as the destination address. If SourceID, DestID, or DocName is left blank, the missing information must be provided by the routing information contained within the document. If one of these parameters/fields is not in Submit or in the document, the document goes to the Suspended queue.

Note

  • Note that the queue:// prefix must be used with an open messaging port when a Message Queue is specified as the destination address.

Self-routing documents

Self-routing documents have the source organization identifier (SourceID field), the destination organization identifier (DestID field), and the name of the document definition (DocName field) defined in the routing tags defined by the document specification, which are contained within the <SelectionFields> tag. If SourceQualifier and DestQualifier are not specified, they default to OrganizationName and refer to the name of the organization in the database. If a BizTalk Framework 2.0–compliant document is submitted and a qualifier is not found during parsing, the qualifier defaults to BizTalk. The BizTalk Framework specification also defines the routing tags for BizTalk Framework–compliant messages. These tags are defined as the <to> and <from> tags under the <route> tag, which is contained in the <header> tag under the root <biztalk> tag. The first tag under the <body> tag determines the document type. For more information, see the BizTalk Framework 2.0 Independent Document Messaging Specification. For X12 or EDIFACT routing, the locations of the routing fields are hard-coded and are not specified in a document specification.


Preprocessing Documents in a Receive Function

Documents can be submitted to BizTalk Server 2000 for processing by using a receive function. Using this mechanism, other applications can send their output files to a specified directory or message queue. BizTalk Server continually monitors the specified location at regular intervals and processes the files or messages placed in that location. BizTalk Server provides interfaces that allow you to create custom preprocessing components. These components process the file or message picked up by the receive function prior to submitting the data to BizTalk Server for processing.

A custom preprocessor component is required to implement the category identifier (CATID) CATID_BIZTALK_CUSTOM_PROCESS in the registry. This allows the BizTalk Server Administration user interface, or administration console, to recognize the custom preprocessor and display it in the Preprocessor list, where it can be selected.

For additional information, see IBTSCustomProcess and IBTSCustomProcessContext.

Related Topics

BizTalk Server Administration User Interface

Receive Functions


Steps for Submitting a Document by Using COM Interfaces

Use the following steps as a guideline when submitting documents to BizTalk Server with the IInterchange interface,

  1. Determine whether the source organization, destination organization, and document definition name are in the parameters of the Submit or the SubmitSync method of the IInterchange interface or are included in the document; it might be a combination of the two.
    • This information can be explicitly declared in the parameter list of Submit or SubmitSync (call-based routing).

      One or more of these parameters can be left blank and the missing information can be provided by the routing information contained within the document.

    • This information can be found in the content of the document itself from the data in the routing fields (self-routing documents).

    • The user can choose to explicitly call out the specific channel to use when calling Submit. This causes the server to bypass channel selection.

    • This information can be explicitly declared in the properties of a custom receive function.
  2. Decide whether to submit asynchronously or synchronously.
    • Call Submit, passing in the document or the file path of the document as a string supplied as a parameter. BizTalk Server 2000 supports URL, UNC, and drive: format for the file path.

      Submit accepts only a string variable as the document or interchange.

    • Call SubmitSync, passing in the document or the file path of the document as a string supplied as a parameter.
      • A response document is returned to the user, if available.

      • This method is valid only for a single channel match.

      • This method can be used only for single-document interchanges.
  3. Decide whether to call some of the Suspended queue methods. (This is optional and can be implemented in the same application or a different application.)
    • Call the CheckSuspendedQueue method of the IInterchange interface.
      • Retrieve items from the Suspended queue.

      • This returns a list of handles that can subsequently be used to call the DeleteFromSuspendedQueue or the GetSuspendedQueueItemDetails method of the IInterchange interface.
    • Call GetSuspendedQueueItemDetails.

      Retrieve the details about a particular item in the Suspended queue.

    • Call DeleteFromSuspendedQueue.

      Remove items from the Suspended queue.


Creating Custom Components

This section provides information about how to create custom components and extend Microsoft BizTalk Server 2000 to integrate line-of-business applications and add features such as encryption and decryption or digital signature. With this information, you can do the following:

  • Create application integration components (AICs) that enable your applications to receive business documents, using BizTalk Server 2000.

  • Extend the functionality of BizTalk Server 2000 by developing custom components to perform digital signature, encryption and decryption, parsing, serializing, and transport of documents.

For additional information, see the following sections:

  • For help with specific tasks, see How To.

  • For general background information, see Concepts.

  • For information about COM interfaces, see Creating Custom Components Reference.

  • For examples of code, see BizTalk Messaging Services Code Samples.


How To...

This section provides task-specific information about how to create server components. It is highly recommended that you review the Concepts in "Creating Custom Components" as well. The following topics are covered:

  • Creating Pipeline Components

  • Use the SAP R/3 AIC


Creating Pipeline Components

Use the following steps to create a pipeline component:

  1. Create an Active Template Library wizard–generated Inproc server project.

  2. Add a simple COM object.

  3. Go to the Projectname.idl file and remove the dual or custom interface generated by the wizard in step 2.

  4. Verify that the resulting IDL file looks like the code examples that follow. You might choose to implement your own set of interfaces from the ones defined in Pipecomp.idl.
    // SimplePipeComponent.idl : IDL source for SimplePipeComponent.dll
//
import "oaidl.idl";
import "ocidl.idl";
import "pipecomp.idl";

[
    uuid(D26A52F6-63A0-42B1-8C88-3C71C66BB189),
    version(1.0),
    helpstring("SimplePipeComponent 1.0 Type Library")
]
library SIMPLEPIPECOMPONENTLib
{
    importlib("stdole32.tlb");
    importlib("stdole2.tlb");
    [
        uuid(E66CAF06-18D8-4C70-9D39-5ED9756C21AD),
        helpstring("MySimplePipelineComponent Class")
    ]
    coclass MySimplePipelineComponent
    {
        [default] interface IPipelineComponentAdmin;
        interface IPipelineComponent;
        interface IPipelineComponentDescription;
    };
};
  5. One of the implementations of MySimplePipelineComponent [coclass] is defined in the header file as follows:
    // MySimplePipelineComponent.h : Declaration of the
// CMySimplePipelineComponent

#ifndef __MYSIMPLEPIPELINECOMPONENT_H_
#define __MYSIMPLEPIPELINECOMPONENT_H_

#include "resource.h"       // main symbols

/////////////////////////////////////////////////////////////////////////////
// CMySimplePipelineComponent
class ATL_NO_VTABLE CMySimplePipelineComponent :
    public CComObjectRootEx<CComSingleThreadModel>,
    public CComCoClass<CMySimplePipelineComponent, &CLSID_MySimplePipelineComponent>,
    public ISupportErrorInfo,
    public IDispatchImpl<IPipelineComponentAdmin, &IID_IPipelineComponentAdmin, &LIBID_SIMPLEPIPECOMPONENTLib>,
    public IDispatchImpl<IPipelineComponent, &IID_IPipelineComponent, &LIBID_SIMPLEPIPECOMPONENTLib>,
    public IDispatchImpl<IPipelineComponentDescription, &IID_IPipelineComponentDescription, &LIBID_SIMPLEPIPECOMPONENTLib>
{
public:
    CMySimplePipelineComponent()
    {
    }

DECLARE_REGISTRY_RESOURCEID(IDR_MYSIMPLEPIPELINECOMPONENT)

DECLARE_PROTECT_FINAL_CONSTRUCT()

BEGIN_COM_MAP(CMySimplePipelineComponent)
    COM_INTERFACE_ENTRY2(IDispatch,IPipelineComponentAdmin)
    COM_INTERFACE_ENTRY(IPipelineComponentAdmin)
    COM_INTERFACE_ENTRY(IPipelineComponent)
    COM_INTERFACE_ENTRY(IPipelineComponentDescription)
    COM_INTERFACE_ENTRY(ISupportErrorInfo)
END_COM_MAP()

// ISupportsErrorInfo
    STDMETHOD(InterfaceSupportsErrorInfo)(REFIID riid);

public://IPipelineComponentAdmin
    STDMETHODIMP GetConfigData(IDispatch** ppDict );
    STDMETHODIMP SetConfigData(IDispatch* pDict );

public://IPipelineComponent
    STDMETHODIMP Execute(IDispatch*  pdispObject,IDispatch*  pdispContext,LONG lFlags,LONG* plErrorLevel);
    STDMETHODIMP EnableDesign(BOOL fEnable);
public: //IPipelineComponentDescription
    STDMETHODIMP ValuesRead(VARIANT* pvar);
    STDMETHODIMP ValuesWritten(VARIANT* pvar);
    STDMETHODIMP ContextValuesRead(VARIANT* pvar);

};

#endif //__MYSIMPLEPIPELINECOMPONENT_H_

Related Topics

Creating Application Integration Components

IPipelineComponent

IPipelineComponentAdmin


Use the SAP R/3 AIC

To use the Systems, Applications, and Products in Data Processing (SAP) AIC, do the following:

Install the DCOM connector

  1. Download the SAP Remote Function Call SDK (www.sap.com/bapi).
    • Go to the COM section and click the DCOM Component Connector.

    • Follow the instructions from the File Download wizard.
  2. Run the image, and unzip it to add the Rfcsdk subdirectories to the client computer.

  3. Install the DCOM connector.

  4. Follow the installation instructions from the \Rfcsdk\Ccwww subdirectory Install page.

  5. Once the connector is installed, create a destination, entering information for the following:
    • Destination name

    • Application server

    • Server number

    • Client

    • Language

    • User

    • Password

Enter the destination name in BizTalk Messaging Manager

This is the destination name chosen during SAP DCOM connector configuration. For more information, see Select a destination organization.

Create a COM+ server package

  1. Create a COM+ server package.

  2. Mark it as Transactions Not Supported.

  3. Add AICOMP.dll to this package.


Creating Custom Components Reference

This section provides reference information about components and interfaces used by Microsoft BizTalk Server 2000 for both C++ and Visual Basic programming. Reference information is provided for all interfaces exposed for extending BizTalk Server 2000.

The following COM interfaces are documented in this reference for C++ developers:

  • IBizTalkParserComponent

  • IBizTalkSerializerComponent

The following COM interfaces and enumerations are documented in this reference for C++ and Visual Basic developers:

  • IBizTalkAcknowledge

  • IBizTalkCorrelation

  • IBTSAppIntegration

  • IFunctoid

  • IPipelineComponent

  • IPipelineComponentAdmin

  • ISchemaImporter

  • ISchemaImporterError

  • ISchemaImporterErrorProvider

  • Receipt Enumerations

  • Functoid Enumerations


IBizTalkAcknowledge Interface [C++]

IBizTalkAcknowledge Object [Visual Basic]

Use this object to process receipts sent to the server.

In C++, use the IBizTalkAcknowledge interface to access the methods of the BizTalkAcknowledge object.

The methods of the BizTalkAcknowledge object are shown in the following table.

Method | Description
AckDocument | Processes receipts received for documents.
AckGroup | Processes receipts received for document groups.
AckInterchange | Processes receipts received for document interchanges.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BTSDocTracking.h
Library: Use Microsoft BizTalk Server Doc Tracking 1.0 Type Library (CISDTA.dll)

Related Topics

Creating Receipt Correlator Components

How Receipts Are Logged

Understanding Receipts


IBizTalkAcknowledge::AckDocument Method [C++]

IBizTalkAcknowledge.AckDocument Method [Visual Basic]

The AckDocument method processes receipts for documents.

Syntax

[C++]

HRESULT AckDocument(
    BSTR bstrSyntax,
    BSTR bstrTrackingId,
    DTA_ACK_STATUS enumAckStatus
);

[Visual Basic]

object.AckDocument( _
    bstrSyntax As String, _
    bstrTrackingId As String, _
    enumAckStatus As DTA_ACK_STATUS _
)

Parameters

[C++]

bstrSyntax

[in] BSTR that contains the syntax of the outbound document to be acknowledged, for example, X12 or EDIFACT.

bstrTrackingId

[in] BSTR that contains the unique tracking identifier of the document. This value is a globally unique identifier (GUID). This value can be obtained from the Tracking_ID field in the dta_outdoc_details table. For more information, see Supporting the Tracking Database with Parser and Serializer Components.

enumAckStatus

[in] Enumeration value that indicates the receipt status. Valid values are from the DTA_ACK_STATUS enumeration.

[Visual Basic]

bstrSyntax

String that contains the syntax of the outbound document to be acknowledged, for example, X12 or EDIFACT.

bstrTrackingId

String that contains the unique tracking identifier of the document. This value is a globally unique identifier (GUID). This value can be obtained from the Tracking_ID field in the dta_outdoc_details table. For more information, see Supporting the Tracking Database with Parser and Serializer Components.

enumAckStatus

Enumeration value that indicates the receipt status. Valid values are from the DTA_ACK_STATUS enumeration.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This method is called only for receipts on individual documents. If the receipt needs to be mapped, a document definition that points to CanonicalReceipt.xml shipped in WebDAV must be created for the receipt.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BTSDocTracking.h
Library: Use Microsoft BizTalk Server Doc Tracking 1.0 Type Library (CISDTA.dll)


IBizTalkAcknowledge::AckGroup Method [C++]

IBizTalkAcknowledge.AckGroup Method [Visual Basic]

The AckGroup method processes receipts for document groups.

Syntax

[C++]

HRESULT AckGroup(
    BSTR bstrSyntax,
    BSTR bstrVersion,
    BSTR bstrRelease,
    BSTR bstrFunctionalGroupId,
    BSTR bstrControlId,
    BSTR bstrSrcAppName,
    BSTR bstrDestAppName,
    DTA_ACK_STATUS enumAckStatus
);

[Visual Basic]

object.AckGroup( _
    bstrSyntax As String, _
    bstrVersion As String, _
    bstrRelease As String, _
    bstrFunctionalGroupId As String, _
    bstrControlId As String, _
    bstrSrcAppName As String, _
    bstrDestAppName As String, _
    enumAckStatus As DTA_ACK_STATUS _
)

Parameters

[C++]

bstrSyntax

[in] BSTR that contains the syntax of the outbound document to be acknowledged, for example, X12 or EDIFACT. You must use the exact strings for the following syntax types:

  • X12

  • EDIFACT

  • Custom XML

bstrVersion

[in] BSTR that contains the version of the syntax, used primarily for EDI.

bstrRelease

[in] BSTR that contains the release of the version of the syntax, used primarily for EDI.

bstrFunctionalGroupId

[in] BSTR that contains the code for the type of documents in a group, used primarily for EDI.

bstrControlId

[in] BSTR that contains the unique identifier for the control number, used primarily for EDI.

bstrSrcAppName

[in] BSTR that contains the name of the source application.

bstrDestAppName

[in] BSTR that contains the name of the destination application.

enumAckStatus

[in] Enumeration value that indicates the receipt status. Valid values are from the DTA_ACK_STATUS enumeration.

[Visual Basic]

bstrSyntax

String that contains the syntax of the outbound document to be acknowledged, for example, X12 or EDIFACT. You must use the exact strings for the following syntax types:

  • X12

  • EDIFACT

  • Custom XML

bstrVersion

String that contains the version of the syntax, used primarily for EDI.

bstrRelease

String that contains the release of the version of the syntax, used primarily for EDI.

bstrFunctionalGroupId

String that contains the code for the type of documents in a group, used primarily for EDI.

bstrControlId

String that contains the unique identifier for the control number, used primarily for EDI.

bstrSrcAppName

String that contains the name of the source application.

bstrDestAppName

String that contains the name of the destination application.

enumAckStatus

Enumeration value that indicates the receipt status. Valid values are from the DTA_ACK_STATUS enumeration.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This method is called only for receipts on document groups.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BTSDocTracking.h
Library: Use Microsoft BizTalk Server Doc Tracking 1.0 Type Library (CISDTA.dll)


IBizTalkAcknowledge::AckInterchange Method [C++]

IBizTalkAcknowledge.AckInterchange Method [Visual Basic]

The AckInterchange method processes receipts for document interchanges.

Syntax

[C++]

HRESULT AckInterchange(
    BSTR bstrSyntax,
    BSTR bstrInterchangeId,
    BSTR bstrVersion,
    BSTR bstrControlId,
    BSTR bstrSrcAliasQualifier,
    BSTR bstrSrcAliasId,
    BSTR bstrSrcAppName,
    BSTR bstrDestAliasQualifier,
    BSTR bstrDestAliasId,
    BSTR bstrDestAppName,
    DTA_ACK_STATUS enumAckStatus
);

[Visual Basic]

object.AckInterchange( _
    bstrSyntax As String, _
    bstrInterchangeId As String, _
    bstrVersion As String, _
    bstrControlId As String, _
    bstrSrcAliasQualifier As String, _
    bstrSrcAliasId As String, _
    bstrSrcAppName As String, _
    bstrDestAliasQualifier As String, _
    bstrDestAliasId As String, _
    bstrDestAppName As String, _
    enumAckStatus As DTA_ACK_STATUS _
)

Parameters

[C++]

bstrSyntax

[in] BSTR that contains the syntax of the outbound document to be acknowledged, for example, X12 or EDIFACT. You must use the exact strings for the following syntax types:

  • X12

  • EDIFACT

  • Custom XML

bstrInterchangeId

[in] BSTR that contains the unique tracking identifier of the interchange. This value is a globally unique identifier (GUID).

bstrVersion

[in] BSTR that contains the version of the syntax, used primarily for EDI.

bstrControlId

[in] BSTR that contains the unique identifier for the control number, used primarily for EDI.

bstrSrcAliasQualifier

[in] BSTR that contains the qualifier of the source organization. This indicates how the bstrSrcAliasID parameter is to be interpreted. Valid values come from the organization identifier qualifiers that are created when the user creates an alias for an organization. Common qualifiers include the DUNS number, telephone number, and BizTalk. The default qualifier for all new organizations is Organization Name and refers to the name of the organization in the database. If a BizTalk Framework 2.0–compliant document is submitted and a qualifier is not found during parsing, the qualifier defaults to BizTalk.

bstrSrcAliasId

[in] BSTR that contains the value of the qualifier of the source organization. For example, if the bstrSrcAliasQualifier parameter is Telephone, this value is the telephone number.

bstrSrcAppName

[in] BSTR that contains the name of the source application.

bstrDestAliasQualifier

[in] BSTR that contains the qualifier of the source organization. This indicates how the bstrDestAliasID parameter is to be interpreted. Valid values come from the organization identifier qualifiers that are created when the user creates an alias for an organization. Common qualifiers include the DUNS number, telephone number, and BizTalk. The default qualifier for all new organizations is Organization Name and refers to the name of the organization in the database. If a BizTalk Framework 2.0–compliant document is submitted and a qualifier is not found during parsing, the qualifier defaults to BizTalk.

bstrDestAliasId

[in] BSTR that contains the value of the qualifier of the source organization. For example, if the bstrDestAliasQualifier parameter is Telephone, this value is the telephone number.

bstrDestAppName

[in] BSTR that contains the name of the destination application.

enumAckStatus

[in] Enumeration value that indicates the receipt status. Valid values are from the DTA_ACK_STATUS enumeration.

[Visual Basic]

bstrSyntax

String that contains the syntax of the outbound document to be acknowledged, for example, X12 or EDIFACT. You must use the exact strings for the following syntax types:

  • X12

  • EDIFACT

  • Custom XML

bstrInterchangeId

String that contains the unique tracking identifier of the interchange. This value is a globally unique identifier (GUID).

bstrVersion

String that contains the version of the syntax, used primarily for EDI.

bstrControlId

String that contains the unique identifier for the control number, used primarily for EDI.

bstrSrcAliasQualifier

String that contains the qualifier of the source organization. This indicates how the bstrSrcAliasID parameter is to be interpreted. Valid values come from the organization identifier qualifiers that are created when the user creates an alias for an organization. Common qualifiers include the DUNS number, telephone number, and BizTalk. The default qualifier for all new organizations is Organization Name and refers to the name of the organization in the database. If a BizTalk Framework 2.0–compliant document is submitted and a qualifier is not found during parsing, the qualifier defaults to BizTalk.

bstrSrcAliasId

String that contains the value of the qualifier of the source organization. For example, if the bstrSrcAliasQualifier parameter is Telephone, this value is the telephone number.

bstrSrcAppName

String that contains the name of the source application.

bstrDestAliasQualifier

String that contains the qualifier of the source organization. This indicates how the bstrDestAliasID parameter is to be interpreted. Valid values come from the organization identifier qualifiers that are created when the user creates an alias for an organization. Common qualifiers include the DUNS number, telephone number, and BizTalk. The default qualifier for all new organizations is Organization Name and refers to the name of the organization in the database. If a BizTalk Framework 2.0–compliant document is submitted and a qualifier is not found during parsing, the qualifier defaults to BizTalk.

bstrDestAliasId

String that contains the value of the qualifier of the source organization. For example, if the bstrDestAliasQualifier parameter is Telephone, this value is the telephone number.

bstrDestAppName

String that contains the name of the destination application.

enumAckStatus

Enumeration value that indicates the receipt status. Valid values are from the DTA_ACK_STATUS enumeration.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This method is called only for receipts on document interchanges.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BTSDocTracking.h
Library: Use Microsoft BizTalk Server Doc Tracking 1.0 Type Library (CISDTA.dll)


IBizTalkCorrelation Interface

Implement IBizTalkCorrelation to create receipt correlator components.

The method of the BizTalkCorrelation object is shown in the following table.

Method | Description
Correlate | Extracts all relevant information from the document, document group, or interchange.

Note

  • This interface is not available in Microsoft Visual Basic.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BTSParserComps.h

Related Topic

Creating Receipt Correlator Components


IBizTalkCorrelation::Correlate Method

The Correlate method extracts all relevant information from the document, document group, or interchange.

Syntax

[C++]

HRESULT Correlate(
    IUnknown* Acknowledge,
    IDictionary* Dict
);

[Visual Basic]

This method is not available in Microsoft Visual Basic.

Parameters

[C++]

Acknowledge

[in] Pointer to the IBizTalkAcknowledge interface to invoke and set the receipt flag.

Dict

[in] Pointer to an IDictionary interface of an object that contains the receipt information.

[Visual Basic]

Not applicable

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

Not applicable

Requirements

[C++]

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BTSParserComps.h

[Visual Basic]

Not applicable


IFunctoid Interface [C++]

CannedFunctoid Object [Visual Basic]

In C++, implement IFunctoid to create custom mapping functions. IFunctoid defines the generic protocol for calling custom functions used by the mapping tool.

In Microsoft Visual Basic, implement CannedFunctoid to create custom mapping functions. CannedFunctoid defines the generic protocol for calling custom functions used by the mapping tool.

This object must register its class identifier (CLSID) under a well-known category identifier (CATID) of the function objects enumerated by the mapping tool. The CATID is {2560F3BF-DB47-11D2-B3AE-00C04F72D6C1}. Each custom object can support multiple functions and can contain icons and names for each supported function.

Function identifiers from 0 to 1000 are reserved for built-in functions in the BizTalk Mapper. User-defined functions (custom functions) should use function identifiers 1001 and above.

The properties of the CannedFunctoid object are shown in the following table.

Property | Description
FunctionsCount | Returns the number of functions implemented by the functoid.
Version | Returns the version of the functoid.

The methods of the CannedFunctoid object are shown in the following table.

Method | Description
GetFunctionParameter | Retrieves the connection-type bit flags for the specified parameter.
GetFunctionDescripter | Retrieves information about a specific functoid.
GetScriptBuffer | Retrieves the script code used to implement the functoid.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include CannedFunctoid.h
Library: Use Microsoft BizTalk Server Canned Functoids 1.0 Type Library (CannedFunctoid.dll)


IFunctoid::FunctionsCount Property [C++]

CannedFunctoid.FunctionsCount Property [Visual Basic]

The FunctionsCount property returns the number of functions implemented by the functoid.

Syntax

[C++]

HRESULT get_FunctionsCount(
    long* plCount
);

[Visual Basic]

object.FunctionsCount

Parameters

[C++]

plCount

[out, retval] Pointer to a long that contains the number of functions implemented by the functoid.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a Long that contains the number of functions implemented by the functoid.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include CannedFunctoid.h
Library: Use Microsoft BizTalk Server Canned Functoids 1.0 Type Library (CannedFunctoid.dll)


IFunctoid::GetFunctionDescripter Method [C++]

CannedFunctoid.GetFunctionDescripter Method [Visual Basic]

The GetFunctionDescripter method retrieves information about a specific functoid.

Syntax

[C++]

HRESULT GetFunctionDescripter(
    long lIndex,
    FUNC_CATEGORY* pFuncCategory,
    SCRIPT_CATEGORY* pScriptCategory,
    FUNC_TYPE* pFuncType,
    BSTR* pbstrName,
    BSTR* pbstrToolTip,
    long* plBitmapID,
    long* plParmCount,
    FUNCID* pFuncId
);

[Visual Basic]

object.GetFunctionDescripter( _
    lIndex As Long, _
    pFuncCategory As FUNC_CATEGORY, _
    pScriptCategory As SCRIPT_CATEGORY, _
    pFuncType As FUNC_TYPE, _
    pbstrName As String, _
    pbstrToolTip As String, _
    plBitmapID As Long, _
    plParmCount As Long _
)

Parameters

[C++]

lIndex

[in] Long that specifies the index number of the function.

pFuncCategory

[in, out] Pointer to a value that contains the FUNC_CATEGORY bit flags for this function.

pScriptCategory

[in, out] Pointer to a value that contains the SCRIPT_CATEGORY bit flags for this function. This value must be set to SCRIPT_CATEGORY_VBSCRIPT for this release.

pFuncType

[in, out] Pointer to a value that contains the FUNC_TYPE bit flags for this function.

pbstrName

[in, out] Pointer to a BSTR that contains the function name.

pbstrToolTip

[in, out] Pointer to a BSTR that contains the ToolTip that appears when the mouse pointer is paused over the custom functoid icon in the mapping tool.

plBitmapID

[in, out] Pointer to the long bitmap identifier of the bitmap used for the custom functoid icon displayed in the mapping tool.

plParmCount

[in, out] Pointer to a long that contains the number of parameters implemented by the function.

pFuncId

[out, retval] Pointer to a long that contains the function identifier.

[Visual Basic]

lIndex

Long that specifies the index number of the function.

pFuncCategory

Value that contains the FUNC_CATEGORY bit flags for this function.

pScriptCategory

Value that contains the SCRIPT_CATEGORY bit flags for this function. This value must be set to SCRIPT_CATEGORY_VBSCRIPT for this release.

pFuncType

Value that contains the FUNC_TYPE bit flags for this function.

pbstrName

String that contains the function name.

pbstrToolTip

String that contains the ToolTip that appears when the mouse pointer is paused over the custom functoid icon in the mapping tool.

plBitmapID

Long that contains the bitmap identifier of the bitmap used for the custom functoid icon displayed in the mapping tool.

plParmCount

Long that contains the number of parameters implemented by the function.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This method returns a Long that contains the function identifier.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include CannedFunctoid.h
Library: Use Microsoft BizTalk Server Canned Functoids 1.0 Type Library (CannedFunctoid.dll)


IFunctoid::GetFunctionParameter Method [C++]

CannedFunctoid.GetFunctionParameter Method [Visual Basic]

The GetFunctionParameter method retrieves the connection-type bit flags for the specified parameter.

Syntax

[C++]

HRESULT GetFunctionParameter(
    FUNCID funcId,
    long lParameter,
    long* plConnectionType
);

[Visual Basic]

object.GetFunctionParameter( _
    funcId As FUNCID, _
    lParameter As Long _
)

Parameters

[C++]

funcId

[in] Long that contains the function identifier.

lParameter

[in] Long that contains the function parameter number. For output parameters, a value of -1 is used.

plConnectionType

[out, retval] Pointer to a long that contains the CONNECTION_TYPE bit flags for the specified parameter.

[Visual Basic]

funcId

Long that contains the function identifier.

lParameter

Long that contains the function parameter number. For output parameters, a value of -1 is used.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This method returns a Long that contains the CONNECTION_TYPE bit flags for the specified parameter.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include CannedFunctoid.h
Library: Use Microsoft BizTalk Server Canned Functoids 1.0 Type Library (CannedFunctoid.dll)


IFunctoid::GetScriptBuffer Method [C++]

CannedFunctoid.GetScriptBuffer Method [Visual Basic]

The GetScriptBuffer method retrieves the script code used to implement the functoid.

Syntax

[C++]

Get method:

HRESULT GetScriptBuffer(
    FUNCID cFuncId,
    long lInputParameters,
    BSTR* pbstrScriptBuffer
);

[Visual Basic]

object.GetScriptBuffer( _
    cFuncId As FUNCID, _
    lInputParameters As Long _
)

Parameters

[C++]

cFuncId

[in] Long that contains the function identifier.

lInputParameters

[in] Long that indicates the number of connected input parameters for the specified function.

pbstrScriptBuffer

[out, retval] Pointer to a BSTR that contains the script code used to implement the function.

[Visual Basic]

cFuncId

Long that contains the function identifier.

lInputParameters

Long that indicates the number of connected input parameters for the specified function.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This method returns a String that contains the script code used to implement the function.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include CannedFunctoid.h
Library: Use Microsoft BizTalk Server Canned Functoids 1.0 Type Library (CannedFunctoid.dll)


IFunctoid::Version Property [C++]

CannedFunctoid.Version Property [Visual Basic]

The Version property returns the version of the functoid.

Syntax

[C++]

HRESULT get_Version(
    long* pVersion
);

[Visual Basic]

object.Version

Parameters

[C++]

pVersion

[out, retval] Pointer to a long that contains the custom functoid version.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a Long that contains the custom functoid version.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property.

If the custom functoid is modified in any way, the author should update the version number.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include CannedFunctoid.h
Library: Use Microsoft BizTalk Server Canned Functoids 1.0 Type Library (CannedFunctoid.dll)


IBizTalkParserComponent Interface

Use this object to convert a document to XML for later processing and to identify the BizTalkChannel objects necessary to process the documents.

In C++, use the IBizTalkParserComponent interface to access the methods of the BizTalkParserComponent object.

The methods of the BizTalkParserComponent object are shown in the following table.

Method | Description
GetGroupDetails | Gets details of the group for the Tracking database. This method is called only if there are groups in the interchange.
GetGroupSize | Gets the size of the group after all documents in the group are parsed. This method is called only if there are groups in the interchange.
GetInterchangeDetails | Gets information about the organization identifiers of the source and destination BizTalkOrganization objects.
GetNativeDocumentOffsets | Identifies offsets from the beginning of the stream for final details about the group in the Tracking database for final logging.
GetNextDocument | Examines the data in a document and determines when to get the next document if this is not the last document.
GroupsExist | Determines if the interchange contains groups.
ProbeInterchangeFormat | Identifies the format of the interchange.

Remarks

Application integration components must be properly registered so that BizTalk Server 2000 can recognize that they belong to BizTalk Server 2000. Application integration components register themselves with the category ID CATID_BIZTALK_AIC. The CATIDs are defined in the bts_sdk_guids.h file. For more information, see Registering Application Integration Components.

Note

  • This interface is not available in Microsoft Visual Basic.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BTSParserComps.h

Related Topics

Identification

Sequence for Calling Methods of the IBizTalkParserComponent Interface

Using the IBizTalkParserComponent Interface


IBizTalkParserComponent::GetGroupDetails Method

[C++]

The GetGroupDetails method gets details of the group for the Tracking database.

[Visual Basic]

This method is not available in Microsoft Visual Basic.

Syntax

[C++]

HRESULT GetGroupDetails(
    IDictionary* Dict
);

[Visual Basic]

Not applicable

Parameters

[C++]

Dict

[in] Pointer to an IDictionary interface of an object that contains details about the group. All information is returned as string types, no matter how it appears in the data.

[Visual Basic]

Not applicable

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

Not applicable

Remarks

[C++]

This method is called only if groups are detected in the interchange.

[Visual Basic]

Not applicable

Requirements

[C++]

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BTSParserComps.h

[Visual Basic]

Not applicable

Related Topics

Sequence for Calling Methods of the IBizTalkParserComponent Interface

Using the IBizTalkParserComponent Interface


IBizTalkParserComponent::GetGroupSize Method

[C++]

The GetGroupSize method gets the size of the group after all documents in the group are parsed.

[Visual Basic]

This method is not available in Microsoft Visual Basic.

Syntax

[C++]

HRESULT GetGroupSize(
    long* GroupSize,
    BOOL* LastGroup
);

[Visual Basic]

Not applicable

Parameters

[C++]

GroupSize

[out] Pointer to a long that contains the size of the interchange.

LastGroup

[out] Pointer to a Boolean value that indicates whether the group is the last group in the interchange. If this parameter is set to TRUE, the next method called is GetGroupDetails for the next group in the data. If it is set to FALSE, the component is finished. When it is released, it leaves the IStream interface after the last byte it has read.

[Visual Basic]

Not applicable

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

Not applicable

Remarks

[C++]

After all documents in the group are called, the final details about the group are required. Both output parameters are added to the Tracking database for final logging.

This method is called only if there are groups in the interchange.

[Visual Basic]

Not applicable

Requirements

[C++]

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BTSParserComps.h

[Visual Basic]

Not applicable

Related Topics

Sequence for Calling Methods of the IBizTalkParserComponent Interface

Using the IBizTalkParserComponent Interface


IBizTalkParserComponent::GetInterchangeDetails Method

[C++]

The GetInterchangeDetails method gets information about the organization identifiers of the source and destination BizTalkOrganization objects.

[Visual Basic]

This method is not available in Microsoft Visual Basic.

Syntax

[C++]

HRESULT GetInterchangeDetails(
    IDictionary* Dict
);

[Visual Basic]

Not applicable

Parameters

[C++]

Dict

[in] Pointer to an IDictionary interface of an object that contains information about the organization identifiers of the source and destination BizTalkOrganization objects.

[Visual Basic]

Not applicable

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

Not applicable

Remarks

[C++]

The minimum sets of fields are:

Field | Description
src_id_type | Source qualifier
src_id_value | Source ID
dest_id_type | Destination qualifier
dest_id_value | Destination ID

The parameters of the Submit method of the IInterchange interface override any fields set here.

[Visual Basic]

Not applicable

Requirements

[C++]

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BTSParserComps.h

[Visual Basic]

Not applicable

Related Topics

Sequence for Calling Methods of the IBizTalkParserComponent Interface

Using the IBizTalkParserComponent Interface


IBizTalkParserComponent::GetNativeDocumentOffsets Method

[C++]

The GetNativeDocumentOffsets method identifies offsets from the beginning of the stream for final details about the group in the Tracking database for final logging.

[Visual Basic]

This method is not available in Microsoft Visual Basic.

Syntax

[C++]

HRESULT GetNativeDocumentOffsets(
    BOOL SizeFromXMLDoc,
    LARGE_INTEGER* StartOffset,
    long* DocLength
);

[Visual Basic]

Not applicable

Parameters

[C++]

SizeFromXMLDoc

[out] Boolean value that indicates the XML document passed in from the GetNextDocument method was used to determine the size. If this parameter is TRUE, the server fills in the StartOffset and DocLength values for the document just parsed. If this parameter is FALSE, the server ignores the values in StartOffset and DocLength.

StartOffset

[out] Pointer to a LARGE_INTEGER that contains the location of the beginning of the document. This parameter is returned if the SizeFromXMLDoc parameter is set to TRUE.

DocLength

[out] Pointer to a long that contains the length of the document. This parameter is returned if the SizeFromXMLDoc parameter is set to TRUE.

[Visual Basic]

Not applicable

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

Not applicable

Remarks

[C++]

This method is called immediately after GetNextDocument whether or not the document is valid (as long as the parser does not return an error value). These are offsets into the IStream object relative to the beginning of the stream, not the beginning of the interchange.

[Visual Basic]

Not applicable

Requirements

[C++]

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BTSParserComps.h

[Visual Basic]

Not applicable

Related Topics

Sequence for Calling Methods of the IBizTalkParserComponent Interface

Using the IBizTalkParserComponent Interface


IBizTalkParserComponent::GetNextDocument Method

[C++]

The GetNextDocument method examines the data in a document and determines when to get the next document, if this is not the last document.

[Visual Basic]

This method is not available in Microsoft Visual Basic.

Syntax

[C++]

HRESULT GetNextDocument(
    IDictionary* Dict,
    BSTR DocSpecName,
    BOOL* DocIsValid,
    BOOL* LastDocument,
    GeneratedReceiptLevel ReceiptGenerated,
    BOOL* DocIsReceipt,
    BSTR* CorrelationCompProgID
);

[Visual Basic]

Not applicable

Parameters

[C++]

Dict

[in] Pointer to an IDictionary interface of an object into which to set the XML instance created on parsing the current document. The parsed XML document is placed into the working_data field of the dictionary.

DocSpecName

[in] BSTR that contains the name of the BizTalk document specification used to generate the XML from the document's native format.

DocIsValid

[out] Pointer to a Boolean value that indicates whether the document instance is valid. If it is invalid but the parser can recover from it, set this parameter to FALSE. This parameter and the LastDocument parameter are independent. Therefore, if there are no more documents and the last one is invalid, both flags are set. If the document is invalid and the parser cannot continue, it might return an error value. The server then stops at the current position of the IStream pointer. The component places the invalid data (if the parser can recover) in the working_data field for inspection by the system administrator if the document is invalid.

LastDocument

[out] Pointer to a Boolean value that indicates whether this is the last document instance in the group or interchange. When the last document is found, the LastDocument flag is set to TRUE. If there are groups, this flag signals the last document in the group, and the GetGroupSize method is called. If there are no groups, this is the last call to get document data from the parser, and the IStream pointer is set appropriately.

ReceiptGenerated

Enumeration value. Valid values are from the GeneratedReceiptLevel enumeration.

DocIsReceipt

[out] Pointer to Boolean value that identifies whether or not this document is a receipt.

CorrelationCompProgID

[out] Pointer to a BSTR that contains the program ID for the correlation of documents.

[Visual Basic]

Not applicable

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

Not applicable

Requirements

[C++]

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BTSParserComps.h

[Visual Basic]

Not applicable

Related Topics

Sequence for Calling Methods of the IBizTalkParserComponent Interface

Using the IBizTalkParserComponent Interface


IBizTalkParserComponent::GroupsExist Method

[C++]

The GroupsExist method determines whether the interchange contains groups.

[Visual Basic]

This method is not available in Microsoft Visual Basic.

Syntax

[C++]

HRESULT GroupsExist(
    BOOL* GrpsExist
);

[Visual Basic]

Not applicable

Parameters

[C++]

GrpsExist

[out, retval] Pointer to a Boolean value that indicates whether the data format contains groups. If this parameter is set to FALSE, the GetGroupDetails and GetGroupSize methods are never called.

[Visual Basic]

Not applicable

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

Not applicable

Requirements

[C++]

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BTSParserComps.h

[Visual Basic]

Not applicable

Related Topics

Sequence for Calling Methods of the IBizTalkParserComponent Interface

Using the IBizTalkParserComponent Interface


IBizTalkParserComponent::ProbeInterchangeFormat Method

[C++]

The ProbeInterchangeFormat method identifies the format of the interchange.

[Visual Basic]

This method is not available in Microsoft Visual Basic.

Syntax

[C++]

HRESULT ProbeInterchangeFormat(
    IStream* pData,
    BOOL FromFile,
    BSTR EnvName,
    IStream* pReceiptData,
    BSTR* Format
);

[Visual Basic]

Not applicable

Parameters

[C++]

pData

[in] Pointer to the IStream object that contains the data for the document interchange. Additional information about the IStream object is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

FromFile

[in] Boolean value. TRUE indicates that the data came from the file referred to by the FilePath parameter of the Submit or the SubmitSync method of the IInterchange interface. FALSE indicates that the data came from the Document parameter of Submit or SubmitSync as a string. If the data is from a file, no conversion is made. If the data is a string, you can use UNICODE/MBCS techniques to understand it.

EnvName

[in] BSTR that contains the name of the envelope.

pReceiptData

[in] Pointer to the IStream object that contains the receipt document.

Format

[out] Pointer to a BSTR that contains the format. If the server recognizes the format, it must fill in this parameter with a nonempty string and hold on to (add a reference count to) the IStream interface because it is not given back to the component. This IStream object is read-only; it supports only the Read, Stat, and Seek methods. All other methods return E_NOTIMPL. This method should not return a failure if it does not recognize the format. It returns S_FALSE or an empty or NULL Format string. If you do not recognize the format, you do not need to move the IStream pointer back to its original position; the server resets the IStream pointer. Unless your format requires it, do not assume that the pointer is at the beginning. The pointer can be somewhere in the middle during the probing stage.

[Visual Basic]

Not applicable

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

Not applicable

Remarks

[C++]

This is the first method that is called by the server. If ProbeInterchangeFormat returns an error in the middle of the document list, it blocks the server from detecting more document types, even if they could be handled by a custom parser that follows the failed parser, if there are two or more custom parsers on a server. If the first custom parser fails, any document that follows is not parsed, even if the other custom parser could handle it, because the server ends the entire parsing operation at the time of the failure.

[Visual Basic]

Not applicable

Requirements

[C++]

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BTSParserComps.h

[Visual Basic]

Not applicable

Related Topics

Sequence for Calling Methods of the IBizTalkParserComponent Interface

Using the IBizTalkParserComponent Interface


IBizTalkSerializerComponent Interface

Use this object to convert a document from XML to the document's original native format.

In C++, use the IBizTalkSerializerComponent interface to access the methods of the BizTalkSerializerComponent object.

The methods of the BizTalkSerializerComponent object are shown in the following table.

Method | Description
AddDocument | Adds an XML document for storage by the serializer component.
GetDocInfo | Gets details of the document.
GetGroupInfo | Gets details of the group, such as size and offset, for the Tracking database.
GetInterchangeInfo | Gets information about the interchange created.
Init | Outputs the document instance to the serializer component and indicates where it should be sent.

Remarks

Application integration components must be properly registered so that Microsoft BizTalk Server 2000 can recognize that they belong to BizTalk Server 2000. Application integration components register themselves with the category ID CATID_BIZTALK_AIC. The CATIDs are defined in the bts_sdk_guids.h file. For more information, see Registering Application Integration Components.

Note

  • This interface is not available in Microsoft Visual Basic.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BTSSerializerComps.h

Related Topics

Sequence for Calling Methods of the IBizTalkSerializerComponent Interface

Using the IBizTalkSerializerComponent Interface


IBizTalkSerializerComponent::AddDocument Method

[C++]

The AddDocument method adds an XML document for storage by the serializer component.

[Visual Basic]

This method is not available in Microsoft Visual Basic.

Syntax

[C++]

HRESULT AddDocument(
    long DocHandle,
    IDictionary* Transport,
    BSTR TrackID,
    long ChannelID
);

[Visual Basic]

Not applicable

Parameters

[C++]

DocHandle

[in] Long that contains the handle to the document that is stored by the component and later retrieved when calling the GetDocInfo method. This parameter supports out-of-order recreation of the interchange in case the documents need to be reordered (such as in X12).

Transport

[in] Pointer to an IDictionary interface of an object that contains the XML document to be stored. It is on the working_data field. This parameter cannot be set by the component. This is an optional parameter.

TrackID

[in] BSTR that contains the document tracking ID used by the server.

ChannelID

[in] Long that contains the BizTalkChannel object associated with the current document.

[Visual Basic]

Not applicable

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

Not applicable

Remarks

[C++]

This method is called only once per interchange.

[Visual Basic]

Not applicable

Requirements

[C++]

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BTSSerializerComps.h

[Visual Basic]

Not applicable

Related Topics

Sequence for Calling Methods of the IBizTalkSerializerComponent Interface

Using the IBizTalkSerializerComponent Interface


IBizTalkSerializerComponent::GetDocInfo Method

[C++]

The GetDocInfo method gets details of the document.

[Visual Basic]

This method is not available in Microsoft Visual Basic.

Syntax

[C++]

HRESULT GetDocInfo(
    long* DocHandle,
    BOOL* SizeFromXMLDoc,
    LARGE_INTEGER* DocStartOffset,
    long* DocLen
);

[Visual Basic]

Not applicable

Parameters

[C++]

DocHandle

[out] Pointer to a long that contains the document handle. For each ID that is passed back, this address is assigned to the group record that was created when the GetGroupInfo method was called. This parameter also returns properties of the document, for example, size and length, unless the SizeFromXMLDoc parameter is set to TRUE, in which case the other parameters are ignored.

SizeFromXMLDoc

[out] Pointer to a Boolean value that indicates that the document offset and length values are retrieved from the XML document. If this parameter is TRUE, the server fills in the DocStartOffset and DocLen values for the document. If this parameter is FALSE, the server ignores the values in DocStartOffset and DocLen.

DocStartOffset

[out] Pointer to a LARGE_INTEGER that contains the offset to the beginning of the document. This parameter is returned if SizeFromXMLDoc is set to TRUE.

DocLen

[out] Pointer to a long that contains the length of the document. This parameter is returned if SizeFromXMLDoc is set to TRUE.

[Visual Basic]

Not applicable

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

Not applicable

Remarks

[C++]

This method is called once for every document in a group (or interchange, if there are no groups).

[Visual Basic]

Not applicable

Requirements

[C++]

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BTSSerializerComps.h

[Visual Basic]

Not applicable

Related Topics

Sequence for Calling Methods of the IBizTalkSerializerComponent Interface

Using the IBizTalkSerializerComponent Interface


IBizTalkSerializerComponent::GetGroupInfo Method

[C++]

The GetGroupInfo method gets details of the group, such as size and offset, for the Tracking database.

[Visual Basic]

This method is not available in Microsoft Visual Basic.

Syntax

[C++]

HRESULT GetGroupInfo(
    long* NumDocs,
    LARGE_INTEGER* GrpStartOffset,
    long* GrpLen
);

[Visual Basic]

Not applicable

Parameters

[C++]

NumDocs

[out] Pointer to a long that contains the number of documents in the group.

GrpStartOffset

[out] Pointer to a LARGE_INTEGER that contains the offset to the start of the group in the IStream interface.

GrpLen

[out] Pointer to a long that contains the length of the group.

[Visual Basic]

Not applicable

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

Not applicable

Remarks

[C++]

This method is called the number of times returned by the GetInterchangeInfo method. Call the GetDocInfo method for each document in the group.

[Visual Basic]

Not applicable

Requirements

[C++]

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BTSSerializerComps.h

[Visual Basic]

Not applicable

Related Topics

Sequence for Calling Methods of the IBizTalkSerializerComponent Interface

Using the IBizTalkSerializerComponent Interface


IBizTalkSerializerComponent::GetInterchangeInfo Method

[C++]

The GetInterchangeInfo method gets information about the interchange created.

[Visual Basic]

This method is not available in Microsoft Visual Basic.

Syntax

[C++]

HRESULT GetInterchangeInfo(
    BSTR* InterchangeID,
    long* lNumGroups
);

[Visual Basic]

Not applicable

Parameters

[C++]

InterchangeID

[out] Pointer to a BSTR that contains the interchange ID, which is placed in the Tracking database.

lNumGroups

[out] Pointer to a long that contains the number of groups generated in the interchange. This can be either 0 or 1. A document can exist in only one group.

[Visual Basic]

Not applicable

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

Not applicable

Remarks

[C++]

This method is called after all the documents are passed in.

[Visual Basic]

Not applicable

Requirements

[C++]

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BTSSerializerComps.h

[Visual Basic]

Not applicable

Related Topics

Sequence for Calling Methods of the IBizTalkSerializerComponent Interface

Using the IBizTalkSerializerComponent Interface


IBizTalkSerializerComponent::Init Method

[C++]

The Init method outputs the document instance to the serializer component and indicates its destination.

[Visual Basic]

This method is not available in Microsoft Visual Basic.

Syntax

[C++]

HRESULT Init(
    BSTR srcQual,
    BSTR srcID,
    BSTR destQual,
    BSTR destID,
    long EnvID,
    IDictionary* pDelimiters,
    IStream* OutputStream,
    long NumDocs
);

[Visual Basic]

Not applicable

Parameters

[C++]

srcQual

[in] BSTR that contains the source-organization identifier qualifier.

srcID

[in] BSTR that contains the source-organization identifier value.

destQual

[in] BSTR that contains the destination-organization identifier qualifier.

destID

[in] BSTR that contains the destination-organization identifier value.

EnvID

[in] Long that contains the envelope identifier value.

pDelimiters

[in] Pointer to an IDictionary interface of an object that contains the delimiters used in the document.

OutputStream

[in] Pointer to an IStream interface that contains the data of this document. This IStream pointer is write-only. The only methods that are supported are Write and Stat; all other methods return E_NOTIMPL. Additional information about the IStream object is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

NumDocs

[in] Long that contains the number of documents sent as part of this interchange. For this release, this parameter is set to 1.

[Visual Basic]

Not applicable

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

Not applicable

Requirements

[C++]

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BTSSerializerComps.h

[Visual Basic]

Not applicable

Related Topics

Sequence for Calling Methods of the IBizTalkSerializerComponent Interface

Using the IBizTalkSerializerComponent Interface


IBTSAppIntegration Interface [C++]

IBTSAppIntegration Object [Visual Basic]

Use this object to create an entry point for receiving a document.

In C++, use the IBTSAppIntegration interface to access the methods of the BTSAppIntegration object.

The method of the BTSAppIntegration object is shown in the following table.

Method | Description
ProcessMessage | Processes the document.

Remarks

Application integration components must be properly registered so that Microsoft BizTalk Server 2000 can recognize that they belong to BizTalk Server 2000. Application integration components register themselves with the category ID CATID_BIZTALK_AIC. The CATIDs are defined in the bts_sdk_guids.h file. For more information, see Registering Application Integration Components.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include btsaic.h
Library: Use Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)

Related Topic

Using the IBTSAppIntegration Interface


IBTSAppIntegration::ProcessMessage Method [C++]

IBTSAppIntegration.ProcessMessage Method [Visual Basic]

The ProcessMessage method processes a document and returns a response document, if available. This method is called at run time when the server is sending a document to the component.

Syntax

[C++]

HRESULT ProcessMessage(
    BSTR bstrDocument,
    BSTR* pbstrResponseDocument
);

[Visual Basic]

object.ProcessMessage( _
    bstrDocument As String _
)

Parameters

[C++]

bstrDocument

[in] BSTR that contains the document.

pbstrResponseDocument

[retval, out] Pointer to a BSTR that contains the response document.

[Visual Basic]

bstrDocument

String that contains the document.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

String that contains the response document.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

Components can return a response string to pass back a text-based response to an application, using the SubmitSync method of the IInterchange interface to send documents.

Components must raise an error if a problem with processing occurs so that the document can be retransmitted or sent to the Suspended queue. If no error is returned, the server assumes that the component successfully processed the data.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include btsaic.h
Library: Use Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)


IPipelineComponent Interface [C++]

IPipelineComponent Object [Visual Basic]

Use this object to create custom pipeline components that can execute in Microsoft BizTalk Server 2000 to extend its functionality.

In C++, use the IPipelineComponent interface to access the methods of the PipelineComponent object.

The methods of the PipelineComponent object are shown in the following table.

Method | Description
EnableDesign | Configures the component for execution in one of two modes: design mode or execution mode.
Execute | Executes the operation expected of the component, given the transport Dictionary object and other configuration settings.

Remarks

Application integration components must be properly registered so that BizTalk Server 2000 can recognize that they belong to BizTalk Server 2000. Application integration components register themselves with the category ID CATID_BIZTALK_AIC. The CATIDs are defined in the bts_sdk_guids.h file. For more information, see Registering Application Integration Components.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include pipecomp.h
Library: Use Microsoft Commerce 2000 Default Pipeline Components Type Library (pipecomplib.tlb)

Related Topic

Creating Application Integration Components


IPipelineComponent::EnableDesign Method [C++]

IPipelineComponent.EnableDesign Method [Visual Basic]

The EnableDesign method configures the component for execution in one of two modes: design mode or execution mode.

Syntax

[C++]

HRESULT EnableDesign(
    BOOL fEnable
);

[Visual Basic]

object.EnableDesign( _
    fEnable As Boolean _
)

Parameters

[C++]

fEnable

Boolean value that indicates the mode of the component. A value of TRUE specifies that the component runs in design mode. A value of FALSE (default) specifies execution mode.

[Visual Basic]

fEnable

Boolean that indicates the mode of the component. A value of True specifies that the component runs in design mode. A value of False (default) specifies execution mode.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

None.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

The pipeline component runs in execution mode by default.

This method is called when the Override messaging port defaults page is opened in the Channel Wizard's Advanced Configuration page. It is also called when the property page is closed and the fEnable parameter is set to true. Design mode is not enabled unless this method has been called with the fEnable parameter set to True.

Design-only fields are returned only when the fEnable parameter is set to true. Otherwise, the Dictionary object passed to the server contains unnecessary information.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include pipecomp.h
Library: Use Microsoft Commerce 2000 Default Pipeline Components Type Library (pipecomplib.tlb)


IPipelineComponent::Execute Method [C++]

IPipelineComponent.Execute Method [Visual Basic]

The Execute method executes the operation expected of the component, given the transport Dictionary object and other configuration settings. Microsoft BizTalk Server 2000 calls this method, passing in the transport Dictionary object. The component can read these Dictionary object values, perform the necessary functions, and optionally write new values back to the transport Dictionary object for further processing.

Syntax

[C++]

HRESULT Execute(
    IDispatch* pDispOrder,
    IDispatch* pDispContext,
    long lFlags,
    long* plErrorLevel
);

[Visual Basic]

object.Execute( _
    pDispOrder As Object, _
    pDispContext As Object, _
    lFlags As Long _
)

Parameters

[C++]

pDispOrder

[in] Pointer to the transport Dictionary object.

pDispContext

[in] Not supported for this release.

lFlags

[in] Reserved.

PlErrorLevel

[out, retval] Reserved.

[Visual Basic]

pDispOrder

Object that contains the transport CDictionary object.

pDispContext

Not supported for this release.

lFlags

Reserved.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This method returns a Long that contains the error level.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

For a component designed to run in BizTalk Server 2000, the first parameter is a Transport Dictionary object. The Transport Dictionary values can be read by the component for processing. The string values supplied by the server for all application integration components (AICs) are as follows:

  • Src_ID_Type: The type of identifier used for the source organization.

  • Src_ID_Value: The value of the source organization identifier.

  • Dest_ID_Type: The type of identifier used for the destination organization.

  • Dest_ID_Value: The value of the destination organization identifier.

  • Document_Name: The name of the input document definition.

  • Tracking_ID: A key value that is based on the globally unique identifier (GUID) and used for tracking.

For a component that runs in a Commerce Server order-processing pipeline, the first parameter contains the OrderForm object.

This method is called at run time when the server is sending a document to the component. This method is called immediately after the SetConfigData method of the IPipelineComponentAdmin interface. The document is passed in the first parameter as a dictionary within the working_data field of the Dictionary object. Components can add the ResponseField key to the Dictionary object to pass back a text-based response to an application, using the SubmitSync method of the IInterchange interface.

The component must raise an error if a problem with processing occurs so that the server can retry transmission later and, after all retries, send the document to the Suspended queue. If no error is returned, the server assumes that the component successfully processed the data.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include pipecomp.h
Library: Use Microsoft Commerce 2000 Default Pipeline Components Type Library (pipecomplib.tlb)


IPipelineComponentAdmin Interface [C++]

IPipelineComponentAdmin Object [Visual Basic]

Use this object between the component and the component user interface.

In C++, use the IPipelineComponentAdmin interface to access the methods of the PipelineComponentAdmin object.

The methods of the PipelineComponentAdmin object are shown in the following table.

Method | Description
GetConfigData | Returns a Dictionary object that contains the configuration data for the component for the user interface to display these values.
SetConfigData | Sets the configuration settings for a component, using the contents of a Dictionary object.

Remarks

Application integration components must be properly registered so that BizTalk Server 2000 can recognize that they belong to BizTalk Server 2000. Application integration components register themselves with the category ID CATID_BIZTALK_AIC. The CATIDs are defined in the bts_sdk_guids.h file. For more information, see Registering Application Integration Components.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include pipecomp.h
Library: Use Microsoft Commerce 2000 Default Pipeline Components Type Library (pipecomplib.tlb)

Related Topic

Creating Application Integration Components


IPipelineComponentAdmin::GetConfigData Method [C++]

IPipelineComponentAdmin.GetConfigData Method [Visual Basic]

The GetConfigData method returns a Dictionary object that contains the configuration data for the component to be used to display these values. GetConfigData enables the user interface component to read the current value from the component and display it on the property page initially.

Syntax

[C++]

HRESULT GetConfigData(
    IDispatch** ppConfigDictionary
);

[Visual Basic]

object.GetConfigData()

Parameters

[C++]

ppConfigDictionary

[out, retval] Address of a pointer to a Dictionary object from which the user interface can read the configuration data.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This method optionally returns a CDictionary object from which the user interface can read the configuration data.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

When a BizTalkPort object is first saved, this method is called to get the defaults for use in autoconfiguring the application integration component (AIC) from the Dictionary object provided. Components must provide defaults for all mandatory properties, whenever possible.

This method is called when the user selects the property page. It is used to supply property page defaults. It is called again when the property page is closed. The contents of this returned Dictionary object are not used.

Components must always return a valid dictionary pointer from GetConfigData.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include pipecomp.h
Library: Use Microsoft Commerce 2000 Default Pipeline Components Type Library (pipecomplib.tlb)


IPipelineComponentAdmin::SetConfigData Method [C++]

IPipelineComponentAdmin.SetConfigData Method [Visual Basic]

The SetConfigData method sets the configuration for a component, using the contents of a Dictionary object. With this method, the user interface can set or change these values. SetConfigData enables the user interface to write the updated value from the property page to the component.

Syntax

[C++]

HRESULT SetConfigData(
    IDispatch* pConfigDictionary
);

[Visual Basic]

object.SetConfigData( _
    pConfigDictionary As Object _
)

Parameters

[C++]

pConfigDictionary

[in] Pointer to a Dictionary object that contains the configuration information.

[Visual Basic]

pConfigDictionary

CDictionary object that contains the configuration information.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

None.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

The server calls SetConfigData when the property page is saved. It is used to verify the values entered by the user on the property page. The contents of this provided Dictionary object are also stored in the database.

This method is called immediately before the Execute method of the IPipelineComponent interface at run time, when the server is ready to send a document to the component. Data stored during design time from autoconfiguration or from property-page updates is passed to the component to allow for property setup prior to calling Execute.

Components validate the properties provided in SetConfigData and raise an error if any of the properties are invalid or missing.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include pipecomp.h
Library: Use Microsoft Commerce 2000 Default Pipeline Components Type Library (pipecomplib.tlb)


ISchemaImporter Interface [C++]

SchemaImporter Object [Visual Basic]

Use this object to handle the importing of DTDs, XDRs, and well-formed XML documents.

In C++, use the ISchemaImporter interface to access the properties and methods of the SchemaImporter object.

The properties of the SchemaImporter object are shown in the following table.

Property | Description
ImportFormatDescription | Returns descriptive text about a supported import format.
ImportFormatIcon | Returns an icon for a supported import format.
NumberOfSupportedImportFormats | Returns the number of supported data formats from which a schema can be extracted.

The method of the SchemaImporter object is shown in the following table.

Method | Description
ExtractXMLSchema | Extracts a schema from a document.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SchemaImporter.h
Library: Use Microsoft BizTalk Server Import Extension Module 1.0 Type Library (ExtensionMod.dll)


ISchemaImporter::ExtractXMLSchema Method [C++]

SchemaImporter.ExtractXMLSchema Method [Visual Basic]

The ExtractXMLSchema method extracts a schema from a document.

Syntax

[C++]

HRESULT ExtractXMLSchema(
    long lFormatIndex,
    BSTR strDocumentPath,
    IDispatch** ppSchemaDOM
);

[Visual Basic]

object.ExtractXMLSchema( _
    lFormatIndex As Long, _
    bstrDocumentPath As String _
)

Parameters

[C++]

lFormatIndex

[in] Index value that specifies the type of document from which to import the schema. Pass in 0 to import well-formed XML, 1 to import a document type definition (DTD), or 2 to import an XDR schema.

strDocumentPath

[in] Path to the document from which to import the schema.

ppSchemaDOM

[out, retval] Address of a pointer to an IDispatch interface that contains the extracted XML schema.

[Visual Basic]

lFormatIndex

Index value that specifies the type of document from which to import the schema. Pass in 0 to import well-formed XML, 1 to import a document type definition (DTD), or 2 to import an XDR schema.

bstrDocumentPath

Path to the document from which to import the schema.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This method returns an Object that contains information about the extracted XML schema.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SchemaImporter.h
Library: Use Microsoft BizTalk Server Import Extension Module 1.0 Type Library (ExtensionMod.dll)


ISchemaImporter::ImportFormatDescription Property [C++]

SchemaImporter.ImportFormatDescription Property [Visual Basic]

The ImportFormatDescription property returns descriptive text about a supported import format.

Syntax

[C++]
HRESULT get_ImportFormatDescription(
     long lFormatIndex,
     BSTR* ppbstrDescription
);
[Visual Basic]
object.ImportFormatDescription( _
     lFormatIndex As Long _
)

Parameters

[C++]

lFormatIndex

[in] Index value that specifies the type of document from which to import the schema. Pass in 0 to import well-formed XML, 1 to import a document type definition (DTD), or 2 to import an XDR schema.

ppbstrDescription

[out, retval] Pointer to a BSTR that contains a textual description of the input document format.

[Visual Basic]

lFormatIndex

Index value that specifies the type of document from which to import the schema. Pass in 0 to import well-formed XML, 1 to import a document type definition (DTD), or 2 to import an XDR schema.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a String that contains a textual description of the input document format.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SchemaImporter.h
Library: Use Microsoft BizTalk Server Import Extension Module 1.0 Type Library (ExtensionMod.dll)


ISchemaImporter::ImportFormatIcon Property [C++]

ISchemaImporter.ImportFormatIcon Property [Visual Basic]

The ImportFormatIcon property returns an icon for a supported import format.

Syntax

[C++]
HRESULT get_ImportFormatIcon(
     long lFormatIndex,
     long* pIconID
);
[Visual Basic]
object.ImportFormatIcon( _
     lFormatIndex As Long _
)

Parameters

[C++]

lFormatIndex

[in] Index value that specifies the type of document from which to import the schema. Pass in 0 to import well-formed XML, 1 to import a document type definition (DTD), or 2 to import an XDR schema.

pIconID

[out, retval] Pointer to a long that contains the icon identifier for the input format.

[Visual Basic]

lFormatIndex

Index value that specifies the type of document from which to import the schema. Pass in 0 to import well-formed XML, 1 to import a document type definition (DTD), or 2 to import an XDR schema.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a Long that is the icon identifier for the input format.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read only-property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SchemaImporter.h
Library: Use Microsoft BizTalk Server Import Extension Module 1.0 Type Library (ExtensionMod.dll)


ISchemaImporter::NumberOfSupportedImportFormats Property [C++]

SchemaImporter.NumberOfSupportedImportFormats Property [Visual Basic]

The NumberOfSupportedImportFormats property returns the number of supported data formats from which a schema can be extracted.

Syntax

[C++]
HRESULT get_NumberOfSupportedImportFormats(
     long* plNumber
);
[Visual Basic]
object.NumberOfSupportedImportFormats

Parameters

[C++]

plNumber

[out, retval] Pointer to a long that indicates the number of supported import formats.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a Long that contains the number of supported import formats.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SchemaImporter.h
Library: Use Microsoft BizTalk Server Import Extension Module 1.0 Type Library (ExtensionMod.dll)


ISchemaImporterError Interface [C++]

SchemaImporterError Object [Visual Basic]

Use this object to identify and decipher errors or warnings.

In C++, use the ISchemaImporterError interface to access the properties of the SchemaImporterError object.

The properties of the SchemaImporterError object are shown in the following table.

Property | Description
IsWarning | Returns a value that identifies the object as an error or a warning.
NodePath | Returns the path to the node that generated the error or warning.
Text | Returns the error or warning message.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SchemaImporter.h
Library: Use Microsoft BizTalk Server Import Extension Module 1.0 Type Library (ExtensionMod.dll)


ISchemaImporterError::IsWarning Property [C++]

SchemaImporterError.IsWarning Property [Visual Basic]

The IsWarning property returns a value that identifies the object as an error or a warning.

Syntax

[C++]
HRESULT get_IsWarning(
     VARIANT_BOOL* pIsWarning
);
[Visual Basic]
object.IsWarning

Parameters

[C++]

pIsWarning

[out, retval] Set to VARIANT_TRUE if the object is a warning; otherwise, set to VARIANT_FALSE to indicate that the object is an error.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a Boolean value. Set to True if the object is a warning; otherwise, set to False to indicate that the object is an error.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SchemaImporter.h
Library: Use Microsoft BizTalk Server Import Extension Module 1.0 Type Library (ExtensionMod.dll)


ISchemaImporterError::NodePath Property [C++]

SchemaImporterError.NodePath Property [Visual Basic]

The NodePath property returns the path to the node that generated the error or warning.

Syntax

[C++]
HRESULT get_NodePath(
     BSTR* pbstrNodePath
);
[Visual Basic]
object.NodePath

Parameters

[C++]

pbstrNodePath

[out, retval] Pointer to a BSTR that contains the fully qualified name of the node that generated the error or warning.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a String that is the fully qualified name of the node that generated the error or warning.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SchemaImporter.h
Library: Use Microsoft BizTalk Server Import Extension Module 1.0 Type Library (ExtensionMod.dll)


ISchemaImporterError::Text Property [C++]

SchemaImporterError.Text Property [Visual Basic]

The Text property returns the error or warning message.

Syntax

[C++]
HRESULT get_Text(
     BSTR* pbstrText
);
[Visual Basic]
object.Text

Parameters

[C++]

pbstrText

[out, retval] Pointer to a BSTR that contains the text associated with the error or warning.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a String that is the text associated with the error or warning.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SchemaImporter.h
Library: Use Microsoft BizTalk Server Import Extension Module 1.0 Type Library (ExtensionMod.dll)


ISchemaImporterErrorProvider Interface [C++]

SchemaImporterErrorProvider Object [Visual Basic]

Use this object to return errors or warnings.

In C++, use the ISchemaImporterErrorProvider interface to access the properties of the SchemaImporterErrorProvider object.

The properties of the SchemaImporterErrorProvider object are shown in the following table.

Property | Description
Error | Returns the error or warning.
NumberOfErrors | Returns the number of errors or warnings.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SchemaImporter.h
Library: Use Microsoft BizTalk Server Import Extension Module 1.0 Type Library (ExtensionMod.dll)


ISchemaImporterErrorProvider::Error Property [C++]

SchemaImporterErrorProvider.Error Property [Visual Basic]

The Error property returns the error or warning.

Syntax

[C++]
HRESULT get_Error(
     long lIndex,
     ISchemaImporterError** pdswError
);
[Visual Basic]
object.Error( _
     lIndex As Long _
)

Parameters

[C++]

lIndex

[in] Index of the required error or warning.

pdswError

[out, retval] Address of a pointer to an ISchemaImporterError interface that contains the error or warning.

[Visual Basic]

lIndex

Index of the required error or warning.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a SchemaImporterError object that contains the error or warning.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SchemaImporter.h
Library: Use Microsoft BizTalk Server Import Extension Module 1.0 Type Library (ExtensionMod.dll)


ISchemaImporterErrorProvider::NumberOfErrors Property [C++]

SchemaImporterErrorProvider.NumberOfErrors Property [Visual Basic]

The NumberOfErrors property returns the number of errors or warnings.

Syntax

[C++]
HRESULT get_NumberOfErrors(
     long* plNumberOfErrors
);
[Visual Basic]
object.NumberOfErrors

Parameters

[C++]

plNumberOfErrors

[out, retval] Pointer to a long that indicates the number of errors.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a Long that indicates the number of errors.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SchemaImporter.h
Library: Use Microsoft BizTalk Server Import Extension Module 1.0 Type Library (ExtensionMod.dll)


Receipt Enumerations

The following receipt enumeration provides possible values of properties and parameters for the IBizTalkAcknowledge interface:

  • DTA_ACK_STATUS

  • GeneratedReceiptLevel


DTA_ACK_STATUS

The DTA_ACK_STATUS enumeration has one of the following values:

Name | Value | Description
DTA_ACK_NONE | 0 | No receipt is expected.
DTA_ACK_PENDING | 1 | The receipt is expected but has not yet arrived.
DTA_ACK_OVERDUE | 2 | The receipt has timed out.
DTA_ACK_ACCEPTED | 3 | The receipt has arrived with a status of accepted.
DTA_ACK_PARTIALLY_ACCEPTED | 4 | The receipt has arrived with a status of accepted with errors.
DTA_ACK_REJECTED | 5 | The receipt has arrived with a status of rejected.


GeneratedReceiptLevel

The GeneratedReceiptLevel enumeration has one of the following values:

Name | Value | Description
NoReceiptGenerated | 0 | No receipt is created.
DocReceiptGenerated | 1 | A receipt is generated for each document.
GroupReceiptGenerated | 2 | A receipt is generated for each group.
InterchangeReceiptGenerated | 3 | A receipt is generated for each interchange.


Functoid Enumerations

The following functoid enumerations provide possible values of properties and parameters:

  • CONNECTION_TYPE

  • FUNC_CATEGORY

  • FUNC_TYPE

  • SCRIPT_CATEGORY


CONNECTION_TYPE

The CONNECTION_TYPE enumeration defines the following values:

Name | Value | Description
CONNECT_TYPE_NONE | 0 | The connection type is none.
CONNECT_TYPE_FIELD | 1 | The connection type is field.
CONNECT_TYPE_RECORD | 2 | The connection type is record.
CONNECT_TYPE_RECORD_CONTENT | 4 | The connection type is record content.
CONNECT_TYPE_FUNC_STRING | 8 | The connection type function is string.
CONNECT_TYPE_FUNC_MATH | 16 | The connection type function is mathematical.
CONNECT_TYPE_FUNC_DATACONV | 32 | The connection type function is data conversion.
CONNECT_TYPE_FUNC_DATETIME_FMT | 64 | The connection type function is date/time format.
CONNECT_TYPE_FUNC_SCIENTIFIC | 128 | The connection type function is scientific.
CONNECT_TYPE_FUNC_BOOLEAN | 256 | The connection type function is Boolean.
CONNECT_TYPE_FUNC_SCRIPTER | 512 | The connection type function is script.
CONNECT_TYPE_FUNC_COUNT | 1024 | The connection type function is count.
CONNECT_TYPE_FUNC_INDEX | 2048 | The connection type function is index.
CONNECT_TYPE_FUNC_CUMULATIVE | 4096 | The connection type function is cumulative.
CONNECT_TYPE_FUNC_VALUE_MAPPING | 8192 | The connection type function is value mapping.
CONNECT_TYPE_FUNC_LOOPING | 16384 | The connection type function is looping.
CONNECT_TYPE_FUNC_ITERATION | 32768 | The connection type function is iteration.
CONNECT_TYPE_FUNC_DBLOOKUP | 65536 | The connection type function is database lookup.
CONNECT_TYPE_FUNC_DBEXTRACT | 131072 | The connection type function is database extraction.
CONNECT_TYPE_ALL | -1 | The connection type includes all connection types.
CONNECT_TYPE_ALL_EXCEPT_RECORD | -3 | The connection type includes all connection types except records.


FUNC_CATEGORY

The FUNC_CATEGORY enumeration defines the following values:

Name | Value | Description
FUNC_CATEGORY_STRING | 3 | The function category is string.
FUNC_CATEGORY_MATH | 4 | The function category is mathematical.
FUNC_CATEGORY_DATACONV | 5 | The function category is data conversion.
FUNC_CATEGORY_DATETIME_FMT | 6 | The function category is date/time format.
FUNC_CATEGORY_SCIENTIFIC | 7 | The function category is scientific.
FUNC_CATEGORY_BOOLEAN | 8 | The function category is Boolean.
FUNC_CATEGORY_SCRIPTER | 9 | The function category is script.
FUNC_CATEGORY_COUNT | 10 | The function category is count. This value is not supported for this release.
FUNC_CATEGORY_INDEX | 11 | The function category is index.
FUNC_CATEGORY_CUMULATIVE | 12 | The function category is cumulative.
FUNC_CATEGORY_VALUE_MAPPING | 13 | The function category is value mapping. This value is not supported for this release.
FUNC_CATEGORY_LOOPING | 14 | The function category is looping. This value is not supported for this release.
FUNC_CATEGORY_ITERATION | 15 | The function category is iteration. This value is not supported for this release.
FUNC_CATEGORY_DBLOOKUP | 16 | The function category is database lookup.
FUNC_CATEGORY_DBEXTRACT | 17 | The function category is database extraction.
FUNC_CATEGORY_UNKNOWN | 31 | The function category is unknown.


FUNC_TYPE

The FUNC_TYPE enumeration defines the following values:

Name | Value | Description
FUNC_TYPE_STD | 1 | The function type is standard.
FUNC_TYPE_VARIABLEINPUT | 2 | The function type is variable input.
FUNC_TYPE_SCRIPTOR | 3 | The function type is script.


SCRIPT_CATEGORY

The SCRIPT_CATEGORY enumeration defines the following values:

Name | Value | Description
SCRIPT_CATEGORY_VBSCRIPT | 0 | The custom functoid function is written in the Microsoft Visual Basic Scripting Edition (VBScript) language.
SCRIPT_CATEGORY_JSCRIPT | 1 | The custom functoid function is written in the Microsoft JScript language. This value is not supported for this release.
SCRIPT_CATEGORY_XSLSCRIPT | 2 | The custom functoid function is written in the Extensible Stylesheet Language (XSL). This value is not supported for this release.


Concepts

This section provides detailed conceptual information that is important to understanding how to extend Microsoft BizTalk Server 2000. BizTalk Server 2000 can perform data transformation, digital signature, encryption and decryption, parsing, serializing, and transport of documents. In addition, you can create your own application integration components (AICs) to extend the capabilities of BizTalk Server 2000.

The following topics are covered:

  • Creating Application Integration Components

  • Using the IBizTalkParserComponent Interface

  • Using the IBizTalkSerializerComponent Interface

  • Supporting the Tracking Database with Parser and Serializer Components

  • Creating Receipt Correlator Components

For samples of code, see BizTalk Messaging Services Code Samples.


Creating Application Integration Components

When creating an application integration component (AIC), you can implement either the pipeline model using the IPipelineComponent interface or the lightweight model using the IBTSAppIntegration interface.

Application integration components are COM objects that the BizTalk Server state engine calls to deliver data to an application. If a messaging port is configured in BizTalk Server 2000 to include the use of an AIC for application integration, this component is automatically instantiated and passed the requisite data. The component then determines how to handle communicating this data back to the application. This can be done using private API calls, invoking other COM objects, using database writes, and so on.

By default, AICs run in the LocalSystem account. If another security context is required, set it as part of the implementation of the AIC. However, if an AIC is installed as a COM+ application, an administrator can configure security of the AIC by using the Component Services console.

Related Topics

Lightweight Application Integration Components

Pipeline Application Integration Components

Registering Application Integration Components


Pipeline Application Integration Components

One approach for application integration with BizTalk Server 2000 is the creation of a pipeline component. This is the same model used in Microsoft Site Server Commerce Edition 3.0 for application integration with the Commerce Interchange pipeline (CIP) and the Order Processing pipeline (OPP). BizTalk Server 2000 supports this method so that pipeline components written for application integration for CIP and OPP are compatible. This is also a useful technique when the component requires configuration properties.

The primary entry point for a pipeline component is the Execute method of the IPipelineComponent interface. This is the method that BizTalk Server 2000 calls to transfer control and to pass the data to the component. It is in the implementation of this method that the component does its work.

Related Topics

IPipelineComponent

IPipelineComponentAdmin


Lightweight Application Integration Components

BizTalk Server 2000 supports an additional model for application developers who want a lighter-weight model for application integration, one that does not support a design-time user interface or configuration properties. This model requires a single interface that contains a single method as an entry point. The component is implemented, and the document is passed to it through the ProcessMessage method of the IBTSAppIntegration interface.

IBTSAppIntegration is for applications that do not need properties for their component and need only an entry point for receiving a document. This is a simpler approach to application integration than pipeline components. BizTalk Server 2000 queries for this interface first. If it does not find this interface implemented, it queries for the pipeline component interfaces.


Registering Application Integration Components

To use an application integration component (AIC) in BizTalk Server 2000, the component must be registered with the category IDs for all pipeline components and for the specific type of pipeline component, in this case application integration.

Register the AIC as an out-of-process component to provide better isolation. An AIC can be registered as an in process (inproc) component to increase its performance. However, an inproc component that fails to respond during an error condition might cause BizTalk Server to fail. Therefore, an AIC should be thoroughly tested before registering it as an inproc component.

Notes

  • An out-of-process component registered as a COM+ application must be configured to run in an identity other than the interactive user.

  • The application integration component must be registered by a user in the BizTalk Server Administrators group. The BizTalk Server Administrators group is created when BizTalk Server 2000 is installed. Additional users can be added to this group as necessary.

For more information about Component Services and COM+, go to the MSDN Online Library Web site (msdn.microsoft.com/library/default.asp) and browse to Component Services in the Platform SDK.

Assigning affinity

Each application integration component (AIC) must be associated with two category IDs. One category ID marks the component as a BizTalk Server component. A component so marked appears in a list of components in the BizTalk Server administration console. The second category ID indicates the type or purpose of the component. This second association is called affinity. Only those components whose affinity is registered as application integration components appear in lists of such components.

To register affinity for an AIC created with Microsoft Visual C++ using ATL, include the following code in your header file:

#include "bts_sdk_guids.h"
// Implement the Component and AIC Category IDs (CATID)
BEGIN_CATEGORY_MAP(AIC_ClassName)
    IMPLEMENTED_CATEGORY(CATID_BIZTALK_COMPONENT)
    IMPLEMENTED_CATEGORY(CATID_BIZTALK_AIC)
END_CATEGORY_MAP()

To register affinity for an AIC created with Microsoft Visual Basic:

  1. After registering your component using Regsvr32.exe, search the registry for the CLSID of your AIC under the following key:

    HKEY_CLASSES_ROOT\CLSID

  2. Expand the Implemented Categories key of your AIC.

  3. Add two new keys with the following names:

    HKEY_CLASSES_ROOT\CLSID\AIC_CLSID\Implemented Categories\{5C6C30E7-C66D-40e3-889D-08C5C3099E52}

    HKEY_CLASSES_ROOT\CLSID\AIC_CLSID\Implemented Categories\{BD193E1D-D7DC-4b7c-B9D2-92AE0344C836}

These GUIDs can be found in bts_sdk_guids.h in the Program Files\Microsoft BizTalk Server\SDK\Include folder. The first key shown in step 3 above identifies the AIC as a BizTalk Server component (CATID_BIZTALK_COMPONENT). The second key shown in step 3 above identifies the component as an AIC (CATID_BIZTALK_AIC).

Testing affinity

To test affinity, use BizTalk Messaging Manager to create a port that uses the AIC. For more information, see Select an application integration component.


Using the IBizTalkParserComponent Interface

The parser has two responsibilities:

  • Convert the documents to XML for later processing.

  • Get the parameters necessary to select the channel (these are the source qualifier, source identifier, destination qualifier, destination identifier, and document definition name). These returned fields are combined with the parameters of the Submit method of the IInterchange interface to select the channels necessary to process the documents.

This interface gets information from the component for one interchange. If the incoming data stream represents multiple interchanges, the server selects the component at every interchange boundary. This simplifies construction of a component because it deals with only one interchange at a time. There is one component instance per thread. No single object needs to be safe for multiple threads. This interface is supported only in C++.

If the ProbeInterchangeFormat method of the IBizTalkParserComponent interface returns an error in the middle of the document list, it blocks the server from detecting more document types, even if they could be handled by a custom parser that follows the failed parser, if there are two or more custom parsers on a server. If the first custom parser fails, any document that follows is not parsed, even if the other custom parser could handle it, because the server ends the entire parsing operation at the time of the failure.

For additional information, see Sequence for Calling Methods of the IBizTalkParserComponent Interface.

Related Topic

Registering Application Integration Components


Sequence for Calling Methods of the IBizTalkParserComponent Interface

The following tables show a possible sequence for calling the methods, based on the sample interchange.

If you have an interchange with two groups, with two documents in the first group and one in the second, the methods are called in the following sequence:

Method | Return
ProbeInterchangeFormat | Non-empty format string
GetInterchangeDetails | N/A
GroupsExist | True
GetGroupDetails | N/A
GetNextDocument | The LastDoc parameter is set to False.
GetNativeDocumentOffsets | N/A
GetNextDocument | The LastDoc parameter is set to True.
GetNativeDocumentOffsets | N/A
GetGroupSize | The LastGroup parameter is set to False.
GetGroupDetails | N/A
GetNextDocument | The LastDoc parameter is set to True.
GetNativeDocumentOffsets | N/A
GetGroupSize | The LastGroup parameter is set to True.

If you have an interchange with two documents, the methods are called in the following sequence:

Method | Return
ProbeInterchangeFormat | Non-empty format string
GetInterchangeDetails | N/A
GroupsExist | False
GetNextDocument | The LastDoc parameter is set to False.
GetNativeDocumentOffsets | N/A
GetNextDocument | The LastDoc parameter is set to True.
GetNativeDocumentOffsets | N/A


Using the IBizTalkSerializerComponent Interface

The serializer converts the document from XML back to its native format. This interface is intended to work on a single interchange and is designed to get information from the component for one interchange. This simplifies the construction of this component because it has to deal with only one interchange at a time. There is only one instance per thread. No single object needs to be safe for multiple threads. This interface is supported only in C++.

Related Topic

Registering Application Integration Components


Sequence for Calling Methods of the IBizTalkSerializerComponent Interface

The following tables show the possible sequence of calling the methods of the IBizTalkSerializerComponent interface, based on the following sample interchanges.

If you have an interchange with one document, the methods are called in the following sequence:

Method | Return
Init | The numdocs parameter is set to 1.
AddDocument | The docHandle parameter is set to 0.
GetInterchangeInfo | The numGroups parameter is set to 0.
GetDocInfo | The docHandle parameter is set to 0.

If you have an interchange with one group, with one document in the group, the methods are called in the following sequence:

Method | Return
Init | The numdocs parameter is set to 1.
AddDocument | The docHandle parameter is set to 0.
GetInterchangeInfo | The numGroups parameter is set to 1.
GetGroupInfo | The numdocs parameter is set to 1.
GetDocInfo | The docHandle parameter is set to 0.

If you have an interchange with two groups, with two documents in the first group and one in the second, the methods are called in the following sequence (this assumes support of batching):

Method | Return
Init | The numdocs parameter is set to 3.
AddDocument | The handle parameter is set to 0.
AddDocument | The handle parameter is set to 1.
AddDocument | The handle parameter is set to 2.
GetInterchangeInfo | The numGroups parameter is set to 2.
GetGroupInfo | The numdocs parameter is set to 2.
GetDocInfo | The handle parameter is set to 1.
GetDocInfo | The handle parameter is set to 0.
GetGroupInfo | The numdocs parameter is set to 1.
GetDocInfo | The handle parameter is set to 2.

Related Topic

IBizTalkSerializerComponent


Supporting the Tracking Database with Parser and Serializer Components

When creating a custom parser or serializer, you might want your component to support the BizTalk Server Tracking database. To accomplish this, the component must use the IDictionary interface to add key/value pairs into the database.

Interchange table

The following table contains the list of keys that can be used to support the Tracking database from the interchange level with a custom component. The table used in the database is dta_interchange_details.

Dictionary key | Inbound or Outbound | Column logged in Tracking database | Description
Src_ID_Type | Both | *nvcSrcAliasQualifier | This is the qualifier for the source organization. This value can come from a parameter supplied in a Submit call or from a receive function in the BizTalk Server Administration user interface. A parser can overwrite this value to manipulate the routing information used for channel selection.
Src_ID_Value | Both | *nvcSrcAliasId | This contains the value of the qualifier of the source organization. This value can come from a parameter supplied in a Submit call or from a receive function in the BizTalk Server Administration user interface. A parser can overwrite this value to manipulate the routing information used for channel selection.
In_Src_ID_App | Inbound | nvcSrcAppName | This is the interchange level identifier for the source application of an EDI interchange. When the parser sets the value with this dictionary key, the value is logged on the inbound interchange in the Tracking database.
Dest_ID_Type | Both | *nvcDestAliasQualifier | This is the qualifier for the destination organization. This value can come from a parameter supplied in a Submit call or from a receive function in the BizTalk Server Administration user interface. A parser can overwrite this value to manipulate the routing information used for channel selection.
Dest_ID_Value | Both | *nvcDestAliasId | This contains the value of the qualifier of the destination organization. This value can come from a parameter supplied in a Submit call or from a receive function in the BizTalk Server Administration user interface. A parser can overwrite this value to manipulate the routing information used for channel selection.
In_Dest_ID_App | Inbound | nvcDestAppName | This is the interchange level identifier for the destination application of an EDI interchange. When the parser sets the value with this dictionary key, the value is logged on the inbound interchange in the Tracking database.
interchange_id | Inbound | nvcControlID | This is the unique control number used to identify an EDI interchange instance between trading partners. When the parser sets the value with this dictionary key, the value is logged on the inbound interchange in the Tracking database.
interchange_version | Inbound | nvcVersion | This is the version of an EDI interchange. When the parser sets the value with this dictionary key, the value is logged on the inbound interchange in the Tracking database.
Out_Src_ID_App | Outbound | *nvcSrcAppName | This is the interchange level identifier for the source application of an EDI interchange. When the serializer sets the value with this dictionary key, the value is logged on the outbound interchange in the Tracking database.
Out_Dest_ID_App | Outbound | *nvcDestAppName | This is the interchange level identifier for the destination application of an EDI interchange. When the serializer sets the value with this dictionary key, the value is logged on the outbound interchange in the Tracking database.
out_interchange_id | Outbound | *nvcControlID | This is the unique control number used to identify an EDI interchange instance between trading partners. The serializer usually generates this unique value. When the serializer sets the value with this dictionary key, the value is logged on the outbound interchange in the Tracking database.
out_interchange_version | Outbound | *nvcVersion | This is the version of the EDI standard. When the serializer sets the value with this dictionary key, the value is logged on the outbound interchange in the Tracking database.

Note

  • The columns of the dta_interchange_details table marked with an asterisk (*) are used for receipt correlation.

Group table

The following table contains the list of keys that can be used to support the Tracking database from the group level with a custom component. The table used in the database is dta_group_details. This table applies to both inbound and outbound documents.

Dictionary key | Column logged in Tracking database | Description
group_id | *nvcControlID | This is the unique control number of a group instance within an EDI interchange. Both the parser and the serializer can set the value with this key. The value is logged on the inbound and the outbound group, respectively, in the Tracking database. For outbound document processing, the serializer usually generates this value.
functional_identifier | *nvcFunctionalGroupID | This is the code for the type of documents in an EDI group. Both the parser and the serializer can set the value with this key. The value is logged on the inbound and the outbound group, respectively, in the Tracking database. In the serializer, this value can be read from the document’s PropertySet.
application_sender_code | *nvcSrcAppName | This is the group level identifier for the source application in an EDI group. Both the parser and the serializer can set the value with this key. The value is logged on the inbound and the outbound group, respectively, in the Tracking database. In the serializer, this value can be read from the document’s PropertySet.
application_receiver_code | *nvcDestAppName | This is the group level identifier for the destination application in an EDI group. Both the parser and the serializer can set the value with this key. The value is logged on the inbound and the outbound group, respectively, in the Tracking database. In the serializer, this value can be read from the document’s PropertySet.
standards_version | *nvcVersion | This is the version of the EDI standard. Both the parser and the serializer can set the value with this key. The value is logged on the inbound and the outbound group, respectively, in the Tracking database.
standards_release | *nvcRelease | This is the release of the version of the EDI standard. Both the parser and the serializer can set the value with this key. The value is logged on the inbound and the outbound group, respectively, in the Tracking database.

Note

The columns of the dta_group_details table marked with an asterisk (*) are used for receipt correlation.

Inbound document table

The following table contains the list of keys that can be used to support the Tracking database from the document level with a custom component. The table used in the database is dta_indoc_details. This table applies to inbound documents only.

Dictionary key | Column logged in Tracking database | Description
doc_id | nvcControlID | This is the unique control number of an EDI document instance. When the parser sets the value with this dictionary key, the value is logged on the inbound document in the Tracking database.
standards_version | nvcVersion | This is the version of the EDI standard. When the parser sets the value with this dictionary key, the value is logged on the inbound document in the Tracking database.
standards_release | nvcRelease | This is the release of the version of the EDI standard. When the parser sets the value with this dictionary key, the value is logged on the inbound document in the Tracking database.
doc_type | nvcDocType | This is the document type or transaction set identifier. When the parser sets the value with this dictionary key, the value is logged on the inbound document in the Tracking database.

Outbound document table

The following table contains the list of keys that can be used to support the Tracking database from the document level with a custom component. The table used in the database is dta_outdoc_details. This table applies to outbound documents only.

Dictionary key | Column logged in Tracking database | Description
out_doc_doc_id | nvcControlID | This is the unique control number of an EDI document instance. When the serializer sets the value with this dictionary key, the value is logged on the outbound document in the Tracking database.
out_doc_syntax | nvcSyntax | This is the code for document syntax, such as XML, X12, EDIFACT, H7, and so on. When the serializer sets the value with this dictionary key, the value is logged on the outbound document in the Tracking database.
out_doc_standards_version | nvcVersion | This is the version of the EDI standard. When the serializer sets the value with this dictionary key, the value is logged on the outbound document in the Tracking database. In the serializer, this value can be read from the document’s PropertySet.
out_doc_standards_release | nvcRelease | This is the release of the version of the EDI standard. When the serializer sets the value with this dictionary key, the value is logged on the outbound document in the Tracking database. In the serializer, this value can be read from the document’s PropertySet.
out_doc_doc_type | nvcDocType | This is the document type or transaction set identifier. When the serializer sets the value with this dictionary key, the value is logged on the outbound document in the Tracking database.
Tracking_ID | uidTrackingGUID | This is the tracking identifier of the document for which a receipt is generated.

Note

  • The Tracking_ID key is used when calling the AckDocument method.

Interchange and document tables

The following table contains the list of keys that can be used to support the Tracking database from the interchange and document level with a custom component. The table used in the database for interchange data is dta_interchange_data. The table used in the database for document data is dta_document_data.

Dictionary key | Inbound or Outbound | Column logged in Tracking database | Description
in_codepage | Inbound | nCodePage | This is the system code page value with which interchange/document data is encoded. When the parser sets the value with this dictionary key, the value is logged in the data record related to the inbound interchange/document in the Tracking database.
out_codepage | Outbound | nCodePage | This is the system code page value with which interchange/document data is encoded. When the serializer sets the value with this dictionary key, the value is logged in the data record related to the outbound interchange/document in the Tracking database.

Related Topic

Understanding the Tracking Database Schema


Creating Receipt Correlator Components

Receipt correlator components can be implemented to correlate documents, groups of documents, and interchanges with their receipts. To use a receipt correlator, you must implement a custom parser using the IBizTalkParserComponent interface. This is required because the server can obtain only the progID of the receipt correlator to be used by calling the GetNextDocument method on the IBizTalkParserComponent interface.

In addition, with BizTalk Server on the receiver side where the receipt is being generated, the parser component is responsible for putting the acknowledgment status, as well as sufficient information, on the receipt (a Canonical Receipt to begin with, but it can be mapped into other receipt document schemas, such as AK997 in EDI) to allow the correlator component on the sender side to uniquely identify the original outbound interchange, group, or document record. For an XML document, using the GUID is usually sufficient. But for EDI interchanges, since GUID cannot be used (there is no placeholder for any GUID in an EDI interchange), a combination of EDI-specific fields is needed for this unique identifier. For instance, the default X12 correlator component uses a combination of the following fields for this purpose: version, release, functional group ID, control ID, source application name, and destination application name.

Whenever the server receives a receipt as an inbound document, the parser component's responsibility is to detect the inbound document as being a receipt, to extract all relevant information needed for correlation, and to place the receipt onto the transport dictionary. Upon returning from the GetNextDocument method call, the parser should set the DocIsReceipt parameter to TRUE and the CorrelationCompProgID parameter to the progID of the corresponding correlator component.

The server calls the Correlate method on the IBizTalkCorrelation interface, and passes in a pointer to the IBizTalkAcknowledge object and the transport dictionary containing the receipt as the working data. Then the receipt correlator's implementation of the Correlate method extracts all relevant information about the document, document group, or interchange that should have been set by the parser component from the transport dictionary. Using this information, the Correlate method then calls AckDocument, AckGroup, or AckInterchange on the IBizTalkAcknowledge interface and sets the DTA_ACK_STATUS value for that document, group, or interchange.

Note that the server does not immediately call IBizTalkCorrelation. The receipt document and the correlation progID are stored to the database for later correlation. When the document is picked up for processing, the correlation component is created and invoked with the transport dictionary that was given by the parser component and a pointer to IBizTalkAcknowledge.

Related Topic

Understanding Receipts


Administering XLANG Schedules

To administer XLANG schedules, use the following interfaces:

  • IWFSystemAdmin

  • IWFGroupAdmin

To access a running instance of a specific XLANG schedule, use the following interfaces:

  • IWFWorkflowInstance

  • IWFProxy

For more information, see Programmatic Administration.


XLANG Schedule Reference

The following illustration shows the relationship between the XLANG interfaces covered in this section, and the corresponding monikers.

Relationship diagrams for XLANG interfaces
sked://[host]
System manager
IWFSystemAdmin
sked://[host][!group]
XLANG schedule instance
XLANG schedule instance
XLANG schedule instance
Group manager
Group manager
Group manager
WorkflowInstance
IWFProxy
IWFWorkflowInstance
IWFWorkflowInstance
IWFWorkflowInstance
IWFGroupAdmin
IWFGroupAdmin
IWFGroupAdmin
sked://[host][!group]/file.skx
sked://[host][!group]/file.skx/port
Proxy to COM-bound XLANG port

The following XLANG schedule interfaces are available:

Administrator Interfaces:

  • IWFGroupAdmin

  • IWFSystemAdmin

Schedule Instance Interfaces:

  • IWFProxy

  • IWFWorkflowInstance

Related Topics

Programmatic Administration


IWFGroupAdmin Interface [C++]

IWFGroupAdmin Object [Visual Basic]

The IWFGroupAdmin interface allows a client application to control running instances of an XLANG schedule. Use this interface to stop, suspend, resume, and retrieve information about all the schedule instances associated with a group manager.

The IWFGroupAdmin interface defines the following properties:

Property | Type | Description
Count | long | The number of running schedule instances associated with this group manager.
FullyQualifiedName | BSTR | The moniker of this group manager.
InstanceIsResident | VARIANT_BOOL | A value that indicates whether the specified schedule instance is currently resident in memory.
InstanceIsSuspended | VARIANT_BOOL | A value that indicates whether the specified schedule instance is currently in a suspended state.
Name | BSTR | The name of this group manager.
UseFileDSN | VARIANT_BOOL | A value that indicates whether a file Data Source Name (DSN) is used for dehydrating the schedule instances.

The IWFGroupAdmin interface defines the following methods:

Method | Description
ResumeInstance | Resumes the execution of a schedule in a suspended state.
Shutdown | Dehydrates all running schedule instances, and stops the group manager.
Startup | Starts all the dehydrated schedule instances for the current group manager.
SuspendInstance | Pauses execution of the schedule instance.
TerminateInstance | Stops execution of the schedule instance.

Remarks

To obtain a reference to an IWFGroupAdmin object, you can invoke the COM GetObject function using a moniker. The following Microsoft Visual Basic code sample shows how to obtain a reference to the default XLANG Scheduler Group Manager on the local computer.

Dim oGM As IWFGroupAdmin
Set oGM = GetObject("sked://!XLANG Scheduler")

To obtain a reference to other group managers, replace "XLANG Scheduler" with the name of the COM+ application that has been designated as an XLANG Scheduler Engine host or group manager. You can determine whether a COM+ application is a group manager by using the IsWorkflowHost method on the IWFSystemAdmin interface.

You can also obtain a reference to all group managers associated with the XLANG Scheduler System Manager through the collection of IWFGroupAdmin objects contained by the SysMgr object. The following Microsoft Visual Basic code displays the fully qualified name of each group manager.

Dim oSM As SysMgr
Dim oGM As IWFGroupAdmin
Set oSM = GetObject("sked://")
For Each oGM In oSM
    MsgBox ("Group Manager: " + oGM.FullyQualifiedName)
Next

The IWFGroupAdmin object also enumerates a collection of the IWFWorkflowInstance objects that represent currently running schedule instances for this group manager.

You can determine the XLANG Scheduler System Manager associated with any group manager by following these steps:

  1. Retrieve the FullyQualifiedName property of the IWFGroupAdmin object.

  2. Parse the XLANG Scheduler System Manager name out of the moniker string returned.

    This is the portion between the sked:// prefix and the exclamation point (!).

  3. Obtain a reference to the SysMgr object using a moniker created with the XLANG Scheduler System Manager name from step 2.

For additional information about monikers, see Moniker Syntax.

Note

  • When using C++, the COM CoGetObject function is used in place of GetObject.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SkedCore.h
Library: Use XLANG Scheduler Runtime Type Library (SkedCore.dll)


IWFGroupAdmin::Count Property [C++]

IWFGroupAdmin.Count Property [Visual Basic]

The Count property contains the number of running XLANG schedule instances associated with this group manager.

Syntax

[C++]

Get method:

HRESULT get_Count(

    long* lCount
);

[Visual Basic]

object.Count

Parameters

[C++]

Get method:

lCount

[out, retval] Pointer to a long that contains the number of running schedule instances associated with this group manager.

[Visual Basic]

None

Return Values

[C++]

For a list of error messages returned by the XLANG Scheduler Engine, see XLANG Schedule Error Messages or Standard COM Errors.

[Visual Basic]

This property returns a Long that contains the number of running schedule instances associated with this group manager.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the XLANG Schedule Error Messages or Standard COM Errors page.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SkedCore.h
Library: Use XLANG Scheduler Runtime Type Library (SkedCore.dll)


IWFGroupAdmin::FullyQualifiedName Property [C++]

IWFGroupAdmin.FullyQualifiedName Property [Visual Basic]

The FullyQualifiedName property contains the moniker of this group manager.

Syntax

[C++]

Get method:

HRESULT get_FullyQualifiedName(

    BSTR* varFullyQualifiedName
);

[Visual Basic]

object.FullyQualifiedName

Parameters

[C++]

Get method:

varFullyQualifiedName

[out, retval] Pointer to a BSTR that contains the moniker of this group manager.

[Visual Basic]

None

Return Values

[C++]

For a list of error messages returned by the XLANG Scheduler Engine, see XLANG Schedule Error Messages or Standard COM Errors.

[Visual Basic]

This property returns a String that contains the moniker of this group manager.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the XLANG Schedule Error Messages or Standard COM Errors page.

Remarks

This is a read-only property.

Although a group manager can be instantiated through a local moniker, this property always includes the full Domain Name Services (DNS) style system name. For example, suppose the default XLANG Scheduler Group Manager, named XLANG Scheduler, is running on a computer named MyMachine in the domain vigorair-18.com. The FullyQualifiedName property would contain a value of sked://MyMachine.vigorair-18.com!XLANG Scheduler.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SkedCore.h
Library: Use XLANG Scheduler Runtime Type Library (SkedCore.dll)

Related Topic

Moniker Syntax


IWFGroupAdmin::InstanceIsResident Property [C++]

IWFGroupAdmin.InstanceIsResident Property [Visual Basic]

The InstanceIsResident property contains a value that indicates whether the specified XLANG schedule instance is currently resident in memory.

Syntax

[C++]

Get method:

HRESULT get_InstanceIsResident(

    BSTR varInstanceId,
    VARIANT_BOOL* pvarIsResident
);

[Visual Basic]

object.InstanceIsResident( _
    varInstanceId As String _
)

Parameters

[C++]

Get method:

varInstanceId

[in] BSTR that contains the globally unique identifier (GUID) assigned to the schedule instance.

pvarIsResident

[out, retval] Pointer to a VARIANT_BOOL set to VARIANT_TRUE if the specified schedule instance is currently resident in memory. If the specified schedule instance is currently dehydrated, this parameter is set to VARIANT_FALSE.

[Visual Basic]

varInstanceId

String that contains the globally unique identifier (GUID) assigned to the schedule instance.

Return Values

[C++]

For a list of error messages returned by the XLANG Scheduler Engine, see XLANG Schedule Error Messages or Standard COM Errors.

[Visual Basic]

This property returns a Boolean set to True if the specified schedule instance is currently resident in memory. If the specified schedule is currently dehydrated, this property is set to False.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the XLANG Schedule Error Messages or Standard COM Errors page.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SkedCore.h
Library: Use XLANG Scheduler Runtime Type Library (SkedCore.dll)


IWFGroupAdmin::InstanceIsSuspended Property [C++]

IWFGroupAdmin.InstanceIsSuspended Property [Visual Basic]

The InstanceIsSuspended property contains a value that indicates whether the specified XLANG schedule instance is currently in a suspended state.

Syntax

[C++]

Get method:

HRESULT get_InstanceIsSuspended(

    BSTR varInstanceId,
    VARIANT_BOOL* pvarIsSuspended
);

[Visual Basic]

object.InstanceIsSuspended( _
    varInstanceId As String _
)

Parameters

[C++]

Get method:

varInstanceId

[in] BSTR that contains the globally unique identifier (GUID) assigned to the schedule instance.

pvarIsSuspended

[out, retval] Pointer to a VARIANT_BOOL set to VARIANT_TRUE if the specified schedule instance is currently in a suspended state. If the specified schedule instance is not suspended, this parameter is set to VARIANT_FALSE.

[Visual Basic]

varInstanceId

String that contains the globally unique identifier (GUID) assigned to the schedule instance.

Return Values

[C++]

For a list of error messages returned by the XLANG Scheduler Engine, see XLANG Schedule Error Messages or Standard COM Errors.

[Visual Basic]

This property returns a Boolean set to True if the specified schedule instance is currently in a suspended state. If the specified schedule is not suspended, this property is set to False.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the XLANG Schedule Error Messages or Standard COM Errors page.

Remarks

This is a read-only property.

This property should be checked prior to calling the ResumeInstance method.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SkedCore.h
Library: Use XLANG Scheduler Runtime Type Library (SkedCore.dll)


IWFGroupAdmin::Name Property [C++]

IWFGroupAdmin.Name Property [Visual Basic]

The Name property contains the name of this group manager.

Syntax

[C++]

Get method:

HRESULT get_Name(

    BSTR* varName
);

[Visual Basic]

object.Name

Parameters

[C++]

Get method:

varName

[out, retval] Pointer to a BSTR that contains the name of this group manager.

[Visual Basic]

None

Return Values

[C++]

For a list of error messages returned by the XLANG Scheduler Engine, see XLANG Schedule Error Messages or Standard COM Errors.

[Visual Basic]

This property returns a String that contains the name of this group manager.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the XLANG Schedule Error Messages or Standard COM Errors page.

Remarks

This is a read-only property.

This property is the same as the name of the hosting COM+ application.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SkedCore.h
Library: Use XLANG Scheduler Runtime Type Library (SkedCore.dll)


IWFGroupAdmin::ResumeInstance Method [C++]

IWFGroupAdmin.ResumeInstance Method [Visual Basic]

The ResumeInstance method starts the XLANG schedule instance executing from a suspended state.

Syntax

[C++]

HRESULT ResumeInstance(
    BSTR bInstanceId
);

[Visual Basic]

object.ResumeInstance( _
    bInstanceId As String _
)

Parameters

[C++]

bInstanceId

[in] BSTR that contains the globally unique identifier (GUID) assigned to the schedule instance to be resumed.

[Visual Basic]

bInstanceId

String that contains the globally unique identifier (GUID) assigned to the schedule instance to be resumed.

Return Values

[C++]

For a list of error messages returned by the XLANG Scheduler Engine, see XLANG Schedule Error Messages or Standard COM Errors.

[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the XLANG Schedule Error Messages or Standard COM Errors page.

Remarks

The schedule instance can be paused with the SuspendInstance method. Prior to calling the ResumeInstance method, the InstanceIsSuspended property should be checked.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SkedCore.h
Library: Use XLANG Scheduler Runtime Type Library (SkedCore.dll)


IWFGroupAdmin::Shutdown Method [C++]

IWFGroupAdmin.Shutdown Method [Visual Basic]

The Shutdown method stops the group manager and dehydrates all running XLANG schedule instances.

Syntax

[C++]

HRESULT Shutdown();

[Visual Basic]

object.Shutdown()

Parameters

[C++]

None

[Visual Basic]

None

Return Values

[C++]

For a list of error messages returned by the XLANG Scheduler Engine, see XLANG Schedule Error Messages or Standard COM Errors.

[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the XLANG Schedule Error Messages or Standard COM Errors page.

Remarks

Prior to stopping the group manager, all running schedule instances associated with this group manager are dehydrated to the database specified in the Data Source Name (DSN) file, and requests for activation of any new schedule instances are refused until shutdown is completed.

Any component that is bound in an XLANG schedule should not invoke this method to stop the group manager, as this can produce unexpected results.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SkedCore.h
Library: Use XLANG Scheduler Runtime Type Library (SkedCore.dll)


IWFGroupAdmin::Startup Method [C++]

IWFGroupAdmin.Startup Method [Visual Basic]

The Startup method starts all the previously running dehydrated XLANG schedule instances associated with this group manager.

Syntax

[C++]

HRESULT Startup();

[Visual Basic]

object.Startup()

Parameters

[C++]

None

[Visual Basic]

None

Return Values

[C++]

For a list of error messages returned by the XLANG Scheduler Engine, see XLANG Schedule Error Messages or Standard COM Errors.

[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the XLANG Schedule Error Messages or Standard COM Errors page.

Remarks

The XLANG Scheduler System Manager normally calls this method. Users should not call this method directly.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SkedCore.h
Library: Use XLANG Scheduler Runtime Type Library (SkedCore.dll)


IWFGroupAdmin::SuspendInstance Method [C++]

IWFGroupAdmin.SuspendInstance Method [Visual Basic]

The SuspendInstance method pauses the running XLANG schedule instance in its current state.

Syntax

[C++]

HRESULT SuspendInstance(
    BSTR bInstanceId
);

[Visual Basic]

object.SuspendInstance( _
    bInstanceId As String _
)

Parameters

[C++]

bInstanceId

[in] BSTR that contains the globally unique identifier (GUID) assigned to the schedule instance to be suspended.

[Visual Basic]

bInstanceId

String that contains the globally unique identifier (GUID) assigned to the schedule instance to be suspended.

Return Values

[C++]

For a list of error messages returned by the XLANG Scheduler Engine, see XLANG Schedule Error Messages or Standard COM Errors.

[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the XLANG Schedule Error Messages or Standard COM Errors page.

Remarks

The schedule instance can be restarted with the ResumeInstance method.

This method might block if actions with COM-bound ports are waiting for a method to complete, or if a short-lived transaction is currently in progress.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SkedCore.h
Library: Use XLANG Scheduler Runtime Type Library (SkedCore.dll)


IWFGroupAdmin::TerminateInstance Method [C++]

IWFGroupAdmin.TerminateInstance Method [Visual Basic]

The TerminateInstance method stops a running XLANG schedule instance.

Syntax

[C++]

HRESULT TerminateInstance(
    BSTR bInstanceId
);

[Visual Basic]

object.TerminateInstance( _
    bInstanceId As String _
)

Parameters

[C++]

bInstanceId

[in] BSTR that contains the globally unique identifier (GUID) assigned to the schedule instance to be stopped.

[Visual Basic]

bInstanceId

String that contains the globally unique identifier (GUID) assigned to the schedule instance to be stopped.

Return Values

[C++]

For a list of error messages returned by the XLANG Scheduler Engine, see XLANG Schedule Error Messages or Standard COM Errors.

[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the XLANG Schedule Error Messages or Standard COM Errors page.

Remarks

A terminated schedule instance can never be restarted or resumed.

This method might block if actions with COM-bound ports are waiting for a method to complete, or if a short-lived transaction is currently in progress.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SkedCore.h
Library: Use XLANG Scheduler Runtime Type Library (SkedCore.dll)


IWFGroupAdmin::UseFileDSN Property [C++]

IWFGroupAdmin.UseFileDSN Property [Visual Basic]

The UseFileDSN property contains a value that indicates whether a Data Source Name (DSN) file is used for dehydrating the XLANG schedule instances.

Syntax

[C++]

Get method:

HRESULT get_UseFileDSN(

    VARIANT_BOOL* pfUseFileDSN
);

[Visual Basic]

object.UseFileDSN

Parameters

[C++]

Get method:

pfUseFileDSN

[out, retval] Pointer to a VARIANT_BOOL set to VARIANT_TRUE if the group manager uses a DSN file for dehydrating schedule instances. If a DSN file is not used, this parameter is set to VARIANT_FALSE.

[Visual Basic]

None

Return Values

[C++]

For a list of error messages returned by the XLANG Scheduler Engine, see XLANG Schedule Error Messages or Standard COM Errors.

[Visual Basic]

This property returns a Boolean set to True if the group manager uses a DSN file for dehydrating schedule instances. If a DSN file is not used, False is returned.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the XLANG Schedule Error Messages or Standard COM Errors page.

Remarks

This is a read-only property.

The value of this property is set when the group manager process is launched. The DSN setting in the COM+ catalog is changed either on the XLANG tab of the XLANG Scheduler Properties dialog box or by setting the UseFileDSN property on the IWFSystemAdmin interface. If the DSN value is changed while the group manager is running, the value of this property is not dynamically updated. The new value is not reflected until the next time the group manager is launched. Updates to this property require the caller to be in the XLANG Administrator role and are not normally performed by user code.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SkedCore.h
Library: Use XLANG Scheduler Runtime Type Library (SkedCore.dll)


IWFProxy Interface [C++]

IWFProxy Object [Visual Basic]

The IWFProxy interface contains information about ports in an XLANG schedule instance that are bound to a COM component. Use this interface to obtain a schedule instance. If this interface is used on a non-COM port binding, an error is returned.

The IWFProxy interface defines the following properties:

Property | Type | Description
FullyQualifiedName | BSTR | The fully qualified name of a COM-bound port.
WorkflowInstance | IWFWorkflowInstance | The current schedule instance.

Remarks

A reference to this interface can be obtained from:

  • The Port property available on the IWFWorkflowInstance interface.

  • An XLANG schedule moniker that specifies the port name.

The following Microsoft Visual Basic code sample shows how to activate an XLANG schedule on the local computer by using a moniker, and obtain a reference to the named port on that XLANG schedule instance.

Dim oPort As Object
Set oPort = GetObject("sked:///C:\schedules\test.skx/PortA")

At this point, the oPort variable contains a reference to the COM object bound in PortA of the schedule instance.

For additional information about monikers, see Moniker Syntax.

Note

When using C++, the COM CoGetObject function is used in place of GetObject.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SkedCore.h
Library: Use XLANG Scheduler Runtime Type Library (SkedCore.dll)


IWFProxy::FullyQualifiedName Property [C++]

IWFProxy.FullyQualifiedName Property [Visual Basic]

The FullyQualifiedName property contains the moniker of the port instance to which this proxy is bound.

Syntax

[C++]

Get method:

HRESULT get_FullyQualifiedName(

    BSTR* varFullyQualifiedName
);

[Visual Basic]

object.FullyQualifiedName

Parameters

[C++]

Get method:

varFullyQualifiedName

[out, retval] Pointer to a BSTR that contains the moniker of the port.

[Visual Basic]

None

Return Values

[C++]

For a list of error messages returned by the XLANG Scheduler Engine, see XLANG Schedule Error Messages or Standard COM Errors.

[Visual Basic]

This property returns a String that contains the moniker of the port.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the XLANG Schedule Error Messages or Standard COM Errors page.

Remarks

This is a read-only property.

The moniker retrieved with this property can be used with the COM GetObject function to obtain a reference to the XLANG schedule instance. This moniker is valid as long as the schedule instance is running. If the schedule instance is dehydrated and rehydrated for any reason, such as rebooting the system, the moniker remains valid. Once the schedule instance completes, or ends by using the TerminateInstance method, the moniker can no longer be used.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SkedCore.h
Library: Use XLANG Scheduler Runtime Type Library (SkedCore.dll)


IWFProxy::WorkflowInstance Property [C++]

IWFProxy.WorkflowInstance Property [Visual Basic]

The WorkflowInstance property contains a reference to the current XLANG schedule instance.

Syntax

[C++]

Get method:

HRESULT get_WorkflowInstance(

    IWFWorkflowInstance** varScheduleInst
);

[Visual Basic]

object.WorkflowInstance

Parameters

[C++]

Get method:

varScheduleInst

[out, retval] Address of a pointer to an IWFWorkflowInstance interface that contains the current schedule instance.

[Visual Basic]

None

Return Values

[C++]

For a list of error messages returned by the XLANG Scheduler Engine, see XLANG Schedule Error Messages or Standard COM Errors.

[Visual Basic]

This property returns an Object that contains the current schedule instance.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the XLANG Schedule Error Messages or Standard COM Errors page.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SkedCore.h
Library: Use XLANG Scheduler Runtime Type Library (SkedCore.dll)


IWFSystemAdmin Interface [C++]

SysMgr Object [Visual Basic]

The IWFSystemAdmin interface provides a client application with system-wide administrative control over the XLANG Scheduler Engine. Use this interface to start, stop, and retrieve information about the group managers.

The IWFSystemAdmin interface defines the following properties:

Property | Type | Description
Count | long | Contains the number of group managers associated with this XLANG Scheduler System Manager.
FullyQualifiedName | BSTR | Contains the fully qualified DNS-style name of the XLANG Scheduler System Manager.
IsWorkflowHost | VARIANT_BOOL | Checks whether the COM+ server application is an XLANG Scheduler Engine host.
Item | BSTR | Returns a reference to the named schedule group.
UseFileDSN | VARIANT_BOOL | Indicates whether a file Data Source Name (DSN) is used for dehydrating the XLANG schedule instances.

The IWFSystemAdmin interface defines the following methods:

Method | Description
ShutdownAll | Shuts down all group managers.
ShutdownApp | Shuts down a specific group manager.
Startup | Starts all group managers.
TestAdminStatus | Checks a caller for XLANG Scheduler Engine administrator access.

Remarks

To obtain a reference to this object, you can invoke the COM GetObject function using a moniker. The following Microsoft Visual Basic code sample shows how to obtain a reference to the XLANG Scheduler System Manager on the local computer.

Dim oSM As SysMgr
Set oSM = GetObject("sked://")

This object also enumerates a collection of the IWFGroupAdmin objects that represent the group managers associated with this XLANG Scheduler System Manager.

For additional information about monikers, see Moniker Syntax.

Note

  • When using C++, the COM CoGetObject function is used in place of GetObject.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SysMgr.h
Library: Use XLANG Scheduler - System Manager (SKEDSMGR.dll)


IWFSystemAdmin::Count Property [C++]

SysMgr.Count Property [Visual Basic]

The Count property contains the number of running group managers.

Syntax

[C++]

Get method:

HRESULT get_Count(

    long* lCount
);

[Visual Basic]

object.Count

Parameters

[C++]

Get method:

lCount

[out, retval] Pointer to a long that contains the number of running group managers.

[Visual Basic]

None

Return Values

[C++]

For a list of error messages returned by the XLANG Scheduler Engine, see XLANG Schedule Error Messages or Standard COM Errors.

[Visual Basic]

This property returns a Long that contains the number of running group managers.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the XLANG Schedule Error Messages or Standard COM Errors page.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SysMgr.h
Library: Use XLANG Scheduler - System Manager (SKEDSMGR.dll)


IWFSystemAdmin::FullyQualifiedName Property [C++]

SysMgr.FullyQualifiedName Property [Visual Basic]

The FullyQualifiedName property contains the moniker of this XLANG Scheduler System Manager.

Syntax

[C++]

Get method:

HRESULT get_FullyQualifiedName(

    BSTR* varFullyQualifiedName
);

[Visual Basic]

object.FullyQualifiedName

Parameters

[C++]

Get method:

varFullyQualifiedName

[out, retval] Pointer to a BSTR that contains the moniker of this XLANG Scheduler System Manager.

[Visual Basic]

None

Return Values

[C++]

For a list of error messages returned by the XLANG Scheduler Engine, see XLANG Schedule Error Messages or Standard COM Errors.

[Visual Basic]

This property returns a String that contains the moniker of this group manager.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the XLANG Schedule Error Messages or Standard COM Errors page.

Remarks

This is a read-only property.

Although an XLANG Scheduler System Manager can be instantiated through a local moniker, this property always includes the full Domain Name Services (DNS) style system name. For example, suppose the XLANG Scheduler System Manager is running on a computer named MyMachine in the domain vigorair-18.com. The FullyQualifiedName property would contain a value of sked://MyMachine.vigorair-18.com.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SysMgr.h
Library: Use XLANG Scheduler - System Manager (SKEDSMGR.dll)

Related Topic

Moniker Syntax


IWFSystemAdmin::IsWorkflowHost Property [C++]

SysMgr.IsWorkflowHost Property [Visual Basic]

The IsWorkflowHost property controls whether the named COM+ server application is an XLANG Scheduler Engine host.

Syntax

[C++]

Get method:

HRESULT get_IsWorkflowHost(
    BSTR varAppName,
    VARIANT_BOOL* pIsWorkflowHost
);

Put method:

HRESULT put_IsWorkflowHost(
    BSTR varAppName,
    VARIANT_BOOL varIsWorkflowHost
);

[Visual Basic]

object.IsWorkflowHost( _
    varAppName As String _
)

Parameters

[C++]

Get method:

varAppName

[in] BSTR that contains the COM+ server application name.

pIsWorkflowHost

[out, retval] Pointer to a VARIANT_BOOL that indicates whether the COM+ server application is hosting the XLANG Scheduler Engine.

Put method:

varAppName

[in] BSTR that contains the COM+ server application name.

varIsWorkflowHost

[out, retval] VARIANT_BOOL that indicates whether the COM+ server application is hosting the XLANG Scheduler Engine.

[Visual Basic]

varAppName

String that contains the COM+ server application name.

Return Values

[C++]

For a list of error messages returned by the XLANG Scheduler Engine, see XLANG Schedule Error Messages or Standard COM Errors.

[Visual Basic]

This property returns a Boolean that indicates whether the COM+ server application is hosting the XLANG Scheduler Engine.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the XLANG Schedule Error Messages or Standard COM Errors page.

Remarks

This property cannot be set on the XLANG Scheduler Engine application, or on any COM+ application marked as read-only.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SysMgr.h
Library: Use XLANG Scheduler - System Manager (SKEDSMGR.dll)


IWFSystemAdmin::Item Property [C++]

SysMgr.Item Property [Visual Basic]

The Item property returns a reference to one of the running group managers.

Syntax

[C++]

Get method:

HRESULT get_Item(

    BSTR strGrpMgrName,
    IUnknown** ppItem
);

[Visual Basic]

object.Item( _
    strGrpMgrName As String _
)

Parameters

[C++]

Get method:

strGrpMgrName

[in] BSTR that contains the group name corresponding to the hosting COM+ server application name. Group names are case sensitive and can contain spaces.

ppItem

[out, retval] Address of a pointer to an IUnknown interface that refers to a group manager.

[Visual Basic]

strGrpMgrName

[in] String that contains the group name corresponding to the hosting COM+ server application name. Group names are case sensitive and can contain spaces.

Return Values

[C++]

For a list of error messages returned by the XLANG Scheduler Engine, see XLANG Schedule Error Messages or Standard COM Errors.

[Visual Basic]

This property returns a group manager Object.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the XLANG Schedule Error Messages or Standard COM Errors page.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SysMgr.h
Library: Use XLANG Scheduler - System Manager (SKEDSMGR.dll)


IWFSystemAdmin::ShutdownAll Method [C++]

SysMgr.ShutdownAll Method [Visual Basic]

The ShutdownAll method stops the group managers and terminates their associated COM+ applications.

Syntax

[C++]

HRESULT ShutdownAll();

[Visual Basic]

object.ShutdownAll()

Parameters

[C++]

None

[Visual Basic]

None

Return Values

[C++]

For a list of error messages returned by the XLANG Scheduler Engine, see XLANG Schedule Error Messages or Standard COM Errors.

[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the XLANG Schedule Error Messages or Standard COM Errors page.

Remarks

When the ShutdownAll method is called, new schedule activations are disabled and the shutdown notice is propagated to all running group managers. Once this method has completed, all group managers are stopped and the system can be safely rebooted.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SysMgr.h
Library: Use XLANG Scheduler - System Manager (SKEDSMGR.dll)


IWFSystemAdmin::ShutdownApp Method [C++]

SysMgr.ShutdownApp Method [Visual Basic]

The ShutdownApp method stops a specific group manager application and terminates the associated COM+ application.

Syntax

[C++]

HRESULT ShutdownApp(
    BSTR varAppName
);

[Visual Basic]

object.ShutdownApp( _
    varAppName As String _
)

Parameters

[C++]

varAppName

[in] BSTR that contains the COM+ server application name to be stopped.

[Visual Basic]

varAppName

String that contains the COM+ server application name to be stopped.

Return Values

[C++]

For a list of error messages returned by the XLANG Scheduler Engine, see XLANG Schedule Error Messages or Standard COM Errors.

[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the XLANG Schedule Error Messages or Standard COM Errors page.

Remarks

When the ShutdownApp method is called, new schedule activations on the named application are disabled and all running XLANG schedule instances associated with that application are stopped. If this method is called on the default XLANG Scheduler Group Manager, all group managers are shut down. Calling this method on the default XLANG Scheduler Group Manager is equivalent to calling the ShutdownAll method.

Note

  • The COM+ application name of the default XLANG Scheduler Group Manager is XLANG Scheduler.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SysMgr.h
Library: Use XLANG Scheduler - System Manager (SKEDSMGR.dll)


IWFSystemAdmin::StartUp Method [C++]

SysMgr.StartUp Method [Visual Basic]

The StartUp method starts the group managers.

Syntax

[C++]

HRESULT StartUp();

[Visual Basic]

object.StartUp()

Parameters

[C++]

None

[Visual Basic]

None

Return Values

[C++]

For a list of error messages returned by the XLANG Scheduler Engine, see XLANG Schedule Error Messages or Standard COM Errors.

[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the XLANG Schedule Error Messages or Standard COM Errors page.

Remarks

When this method is invoked, rehydration is initiated for all group managers and, subsequently, all XLANG schedules. This method is asynchronous, and it can complete before all group managers and schedules are running.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SysMgr.h
Library: Use XLANG Scheduler - System Manager (SKEDSMGR.dll)


IWFSystemAdmin::TestAdminStatus Method [C++]

SysMgr.TestAdminStatus Method [Visual Basic]

The TestAdminStatus method determines whether a caller on the IWFGroupAdmin interface is an XLANG Scheduler Engine administrator.

Syntax

[C++]

HRESULT TestAdminStatus();

[Visual Basic]

object.TestAdminStatus()

Parameters

[C++]

None

[Visual Basic]

None

Return Values

[C++]

For a list of error messages returned by the XLANG Scheduler Engine, see XLANG Schedule Error Messages or Standard COM Errors.

[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the XLANG Schedule Error Messages or Standard COM Errors page.

Remarks

This method is intended for internal use by the group managers.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SysMgr.h
Library: Use XLANG Scheduler - System Manager (SKEDSMGR.dll)


IWFSystemAdmin::UseFileDSN Property [C++]

SysMgr.UseFileDSN Property [Visual Basic]

The UseFileDSN property contains a value that indicates whether a COM+ server application uses a Data Source Name (DSN) file for dehydrating the XLANG schedule instances.

Syntax

[C++]

Get method:

HRESULT get_UseFileDSN(
    BSTR varAppName,
    VARIANT_BOOL* pfUseFileDSN
);

Put method:

HRESULT put_UseFileDSN(
    BSTR varAppName,
    VARIANT_BOOL* varUseFileDSN
);

[Visual Basic]

object.UseFileDSN( _
    varAppName As String _
)

Parameters

[C++]

Get method:

varAppName

[in] BSTR that contains the COM+ server application name.

pfUseFileDSN

[out, retval] Pointer to a VARIANT_BOOL set to VARIANT_TRUE if the COM+ server application uses a DSN file for dehydrating schedule instances. If a DSN file is not used, this parameter is set to VARIANT_FALSE.

Put method:

varAppName

[in] BSTR that contains the COM+ server application name.

varUseFileDSN

[out, retval] VARIANT_BOOL that indicates whether the COM+ server application uses a DSN file for dehydrating schedule instances. If a DSN file is not used, this parameter is set to VARIANT_FALSE.

[Visual Basic]

varUseFileDSN

Boolean that indicates whether the COM+ server application uses a DSN file for dehydrating schedule instances. If a DSN file is not used, this parameter is set to False.

Return Values

[C++]

For a list of error messages returned by the XLANG Scheduler Engine, see XLANG Schedule Error Messages or Standard COM Errors.

[Visual Basic]

This property returns a Boolean set to True if the COM+ server application uses a DSN file for dehydrating schedule instances. If a DSN file is not used, False is returned.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the XLANG Schedule Error Messages or Standard COM Errors page.

Remarks

If this property is changed while any group manager is running, the value of this property is not dynamically updated in the group managers. Therefore, the UseFileDSN property value exposed by the IWFGroupAdmin interface contains an incorrect value. The updated value is not reflected until the next time the group manager is launched.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SysMgr.h
Library: Use XLANG Scheduler - System Manager (SKEDSMGR.dll)


IWFWorkflowInstance Interface [C++]

IWFWorkflowInstance Object [Visual Basic]

The IWFWorkflowInstance interface allows a client application to navigate the ports of an XLANG schedule instance, check the completion status, and determine whether the schedule instance completed successfully. Use this interface to gather information about a specific, running schedule instance.

The IWFWorkflowInstance interface defines the following properties:

Property | Type | Description
CompletionStatus | long | A value that indicates the success or failure of the schedule instance.
FullPortName | BSTR | The full name of a port in a form usable by the associated technology.
FullyQualifiedName | BSTR | The fully qualified name of this schedule instance.
InstanceId | BSTR | The unique identifier associated with this schedule instance.
IsCompleted | VARIANT_BOOL | A value that indicates whether the schedule instance completed.
ModuleId | BSTR | The unique identifier of the XML module that contains the schedule and binding information.
ModuleName | BSTR | The name of the XML module that contains the schedule and binding information.
ParentInstanceID | BSTR | The unique identifier of the parent schedule instance.
Port | IUnknown | A reference to the named port. This is applicable only to COM-based port bindings.

The IWFWorkflowInstance interface defines the following method:

Method | Description
WaitForCompletion | Blocks until the schedule instance completes.

Remarks

A reference to this interface can be obtained from:

  • The WorkflowInstance property available on the IWFProxy interface.

  • The collection of IWFWorkflowInstance objects returned by the IWFGroupAdmin object.

  • An XLANG schedule moniker.

The following Microsoft Visual Basic code sample shows how to instantiate an XLANG schedule on the local computer and obtain a reference to that schedule instance.

Dim oWFI As IWFWorkflowInstance
Set oWFI = GetObject("sked:///C:\schedules\test.skx")

To obtain a reference to all currently running schedule instances in a group manager, you can access the collection of IWFWorkflowInstance objects contained by the IWFGroupAdmin object. The following Microsoft Visual Basic code displays the fully qualified name of each schedule instance running in the default XLANG Scheduler Group Manager.

Dim oGM As IWFGroupAdmin
Dim oWFI As IWFWorkflowInstance
Set oGM = GetObject("sked://!XLANG Scheduler")
For Each oWFI In oGM
    MsgBox ("XLANG Schedule: " + oWFI.FullyQualifiedName)
Next

When using multiple group managers, you can determine the group manager associated with any schedule instance by following these steps:

  1. Retrieve the FullyQualifiedName property of the IWFWorkflowInstance object.

  2. Parse the group manager name out of the moniker string returned.

    This is the portion that begins with an exclamation point (!) and ends with a slash (/).

  3. Obtain a reference to the IWFGroupAdmin object using a moniker created with the group manager name from step 2.

For additional information about monikers, see Moniker Syntax.

Note

  • When using C++, the COM CoGetObject function is used in place of GetObject.

  • When accessing this object in Microsoft Visual Basic, you must declare your object variable with the appropriate type information rather than using the Object type. For example:
    Dim myInstance As IWFWorkflowInstance

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SkedCore.h
Library: Use XLANG Scheduler Runtime Type Library (SkedCore.dll)


IWFWorkflowInstance::CompletionStatus Property [C++]

IWFWorkflowInstance.CompletionStatus Property [Visual Basic]

The CompletionStatus property indicates the final completion status of the XLANG schedule instance.

Syntax

[C++]

Get method:

HRESULT get_CompletionStatus(
    long* varCompletionStatus
);

[Visual Basic]

object.CompletionStatus

Parameters

[C++]

Get method:

varCompletionStatus

[out, retval] Pointer to a long that contains the completion status of the schedule instance. A value of 0 indicates success.

[Visual Basic]

None

Return Values

[C++]

For a list of error messages returned by the XLANG Scheduler Engine, see XLANG Schedule Error Messages or Standard COM Errors.

Note

  • A return value of S_OK does not indicate that the processes or applications associated with the schedule instance completed successfully. It indicates only that the schedule instance was completely processed by the XLANG Scheduler Engine, without errors.
[Visual Basic]

This property returns a Long that contains the completion status.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the XLANG Schedule Error Messages or Standard COM Errors page.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SkedCore.h
Library: Use XLANG Scheduler Runtime Type Library (SkedCore.dll)


IWFWorkflowInstance::FullPortName Property [C++]

IWFWorkflowInstance.FullPortName Property [Visual Basic]

The FullPortName property contains the full name of the specified port.

Syntax

[C++]

Get method:

HRESULT get_FullPortName(
    BSTR varParam,

    BSTR* varFullPortName
);

[Visual Basic]

object.FullPortName( _
    varParam As String _
)

Parameters

[C++]

Get method:

varParam

[in] BSTR that contains the name of the port to be retrieved.

varFullPortName

[out, retval] Pointer to a BSTR that contains the full port name.

[Visual Basic]

varParam

String that contains the name of the port to be retrieved.

Return Values

[C++]

For a list of error messages returned by the XLANG Scheduler Engine, see XLANG Schedule Error Messages or Standard COM Errors.

[Visual Basic]

This property returns a String that contains the full port name.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the XLANG Schedule Error Messages or Standard COM Errors page.

Remarks

This is a read-only property.

The full port name is returned in a form that is usable by the associated binding technology. For example, a port that is bound to a COM component returns a fully qualified moniker as the name of the port. For a port that is bound to Microsoft Message Queuing, this method returns the full path of the queue.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SkedCore.h
Library: Use XLANG Scheduler Runtime Type Library (SkedCore.dll)


IWFWorkflowInstance::FullyQualifiedName Property [C++]

IWFWorkflowInstance.FullyQualifiedName Property [Visual Basic]

The FullyQualifiedName property contains the moniker of the XLANG schedule instance.

Syntax

[C++]

Get method:

HRESULT get_FullyQualifiedName(

    BSTR* varFullyQualifiedName
);

[Visual Basic]

object.FullyQualifiedName

Parameters

[C++]

Get method:

varFullyQualifiedName

[out, retval] Pointer to a BSTR that contains the moniker of the schedule instance.

[Visual Basic]

None

Return Values

[C++]

For a list of error messages returned by the XLANG Scheduler Engine, see XLANG Schedule Error Messages or Standard COM Errors.

[Visual Basic]

This property returns a String that contains the moniker of the schedule instance.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the XLANG Schedule Error Messages or Standard COM Errors page.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SkedCore.h
Library: Use XLANG Scheduler Runtime Type Library (SkedCore.dll)


IWFWorkflowInstance::InstanceId Property [C++]

IWFWorkflowInstance.InstanceId Property [Visual Basic]

The InstanceId property contains the globally unique identifier (GUID) assigned to the current XLANG schedule instance.

Syntax

[C++]

Get method:

HRESULT get_InstanceId(

    BSTR* varInstanceId
);

[Visual Basic]

object.InstanceId

Parameters

[C++]

Get method:

varInstanceId

[out, retval] Pointer to a BSTR that contains the GUID of the schedule instance.

[Visual Basic]

None

Return Values

[C++]

For a list of error messages returned by the XLANG Scheduler Engine, see XLANG Schedule Error Messages or Standard COM Errors.

[Visual Basic]

This property returns a String that contains the GUID of the schedule instance.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the XLANG Schedule Error Messages or Standard COM Errors page.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SkedCore.h
Library: Use XLANG Scheduler Runtime Type Library (SkedCore.dll)


IWFWorkflowInstance::IsCompleted Property [C++]

IWFWorkflowInstance.IsCompleted Property [Visual Basic]

The IsCompleted property indicates whether the XLANG schedule instance has finished executing.

Syntax

[C++]

Get method:

HRESULT get_IsCompleted(

    VARIANT_BOOL* varIsCompleted
);

[Visual Basic]

object.IsCompleted

Parameters

[C++]

Get method:

varIsCompleted

[out, retval] Pointer to a VARIANT_BOOL that, if VARIANT_TRUE, indicates the schedule instance has finished executing. If VARIANT_FALSE, the schedule instance is still executing.

[Visual Basic]

None

Return Values

[C++]

For a list of error messages returned by the XLANG Scheduler Engine, see XLANG Schedule Error Messages or Standard COM Errors.

[Visual Basic]

This property returns a Boolean that, if True, indicates the schedule instance has finished executing. If False, the schedule instance is still executing.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the XLANG Schedule Error Messages or Standard COM Errors page.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SkedCore.h
Library: Use XLANG Scheduler Runtime Type Library (SkedCore.dll)


IWFWorkflowInstance::ModuleId Property [C++]

IWFWorkflowInstance.ModuleId Property [Visual Basic]

The ModuleId property contains the globally unique identifier (GUID) of the XLANG module associated with the current XLANG schedule instance.

Syntax

[C++]

Get method:

HRESULT get_ModuleId(

    BSTR* varModuleId
);

[Visual Basic]

object.ModuleId

Parameters

[C++]

Get method:

varModuleId

[out, retval] Pointer to a BSTR that contains the GUID of the XLANG module associated with the current schedule instance.

[Visual Basic]

None

Return Values

[C++]

For a list of error messages returned by the XLANG Scheduler Engine, see XLANG Schedule Error Messages or Standard COM Errors.

[Visual Basic]

This property returns a String that contains the GUID of the XLANG module associated with the current schedule instance.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the XLANG Schedule Error Messages or Standard COM Errors page.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SkedCore.h
Library: Use XLANG Scheduler Runtime Type Library (SkedCore.dll)


IWFWorkflowInstance::ModuleName Property [C++]

IWFWorkflowInstance.ModuleName Property [Visual Basic]

The ModuleName property contains the name of the XLANG module associated with the current XLANG schedule instance.

Syntax

[C++]

Get method:

HRESULT get_ModuleName(

    BSTR* varModuleName
);

[Visual Basic]

object.ModuleName

Parameters

[C++]

Get method:

varModuleName

[out, retval] Pointer to a BSTR that contains the name of the XLANG module associated with the current schedule instance.

[Visual Basic]

None

Return Values

[C++]

For a list of error messages returned by the XLANG Scheduler Engine, see XLANG Schedule Error Messages or Standard COM Errors.

[Visual Basic]

This property returns a String that contains the name of the XLANG module associated with the current schedule instance.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the XLANG Schedule Error Messages or Standard COM Errors page.

Remarks

This is a read-only property.

The module name is defined in the XLANG schedule (.skx) file.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SkedCore.h
Library: Use XLANG Scheduler Runtime Type Library (SkedCore.dll)


IWFWorkflowInstance::ParentInstanceID Property [C++]

IWFWorkflowInstance.ParentInstanceID Property [Visual Basic]

The ParentInstanceID property contains the globally unique identifier (GUID) assigned to the parent XLANG schedule instance of the current schedule instance.

Syntax

[C++]

Get method:

HRESULT get_ParentInstanceID(

    BSTR* varParentInstanceID
);

[Visual Basic]

object.ParentInstanceID

Parameters

[C++]

Get method:

varParentInstanceID

[out, retval] Pointer to a BSTR that contains the GUID of the parent schedule instance of the current schedule instance.

[Visual Basic]

None

Return Values

[C++]

For a list of error messages returned by the XLANG Scheduler Engine, see XLANG Schedule Error Messages or Standard COM Errors.

[Visual Basic]

This property returns a String that contains the GUID of the parent schedule instance of the current schedule instance.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the XLANG Schedule Error Messages or Standard COM Errors page.

Remarks

This is a read-only property.

The property returns a NULL value if no parent schedule instance exists.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SkedCore.h
Library: Use XLANG Scheduler Runtime Type Library (SkedCore.dll)


IWFWorkflowInstance::Port Property [C++]

IWFWorkflowInstance.Port Property [Visual Basic]

The Port property contains a reference to a COM-bound port.

Syntax

[C++]

Get method:

HRESULT get_Port(

    BSTR varParam,
    IUnknown** varPort
);

[Visual Basic]

object.Port

Parameters

[C++]

Get method:

varParam

[in] BSTR that contains the name of the port to which to obtain a reference.

varPort

[out, retval] Address of a pointer to an IUnknown interface that contains a reference to a port in the current XLANG schedule instance.

[Visual Basic]

varParam

String that contains the name of the port to which to obtain a reference.

Return Values

[C++]

For a list of error messages returned by the XLANG Scheduler Engine, see XLANG Schedule Error Messages or Standard COM Errors.

[Visual Basic]

This property returns an Object that contains the specified port.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the XLANG Schedule Error Messages or Standard COM Errors page.

Remarks

This is a read-only property.

The MK_E_NOOBJECT error code is returned if the moniker or port name passed in the varParam parameter is incorrect.

When using Microsoft Visual Basic, the variable used for the port reference returned by using this property should be declared as a specific class or as a Variant. You can't obtain the port reference if you declare the variable as an Object since the port actually returns an IUnknown reference.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SkedCore.h
Library: Use XLANG Scheduler Runtime Type Library (SkedCore.dll)


IWFWorkflowInstance::WaitForCompletion Method [C++]

IWFWorkflowInstance.WaitForCompletion Method [Visual Basic]

The WaitForCompletion method waits until the current XLANG schedule instance completes executing.

Syntax

[C++]

HRESULT WaitForCompletion();

[Visual Basic]

object.WaitForCompletion()

Parameters

[C++]

None

[Visual Basic]

None

Return Values

[C++]

For a list of error messages returned by the XLANG Scheduler Engine, see XLANG Schedule Error Messages or Standard COM Errors.

[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the XLANG Schedule Error Messages or Standard COM Errors page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SkedCore.h
Library: Use XLANG Scheduler Runtime Type Library (SkedCore.dll)


BizTalk Messaging Services Code Samples

Sample files are located in the Messaging Samples folder in the Microsoft BizTalk Server installation drive. Browse to \Program Files\Microsoft BizTalk Server\SDK\Messaging Samples on the installation drive to find the sample files. This is only a relative path. Depending on your installation of BizTalk Server 2000, you might have to modify this path.

The following samples are available in the BizTalk Server 2000 SDK:

Sample folder name | Readme file | Description
BTConfigAssistant | Readme.doc | This tool enables the user to see all details of a configuration. It also provides a mechanism to easily import and export configurations.
BTFDevToolkit | ReadMe.txt | This folder contains the BizTalk Framework Developers' Toolkit and XML Components.
BTSAppIntegration\VB (Visual Basic) | Readme.txt | This sample demonstrates an application integration component (AIC) that implements the IBTSAppIntegration interface.
BTSAppIntegration\VC (C++) | Readme.txt | This sample demonstrates an AIC that implements the IBTSAppIntegration interface using ATL.
CustomPreProcessor | Readme.txt | This sample demonstrates a simple implementation of a custom preprocessor to be used with either File or Message Queuing receive functions.
DirectIntegration | Readme.doc | This tool helps users submit documents to BizTalk Messaging Services and check the results of the submission. Tracking and Suspended Queue information is used to determine the results.
DistributionList | DistributionListReadme.txt | This sample configures a BizTalk distribution list (port group) and submits a document to it.
MapTest | Readme.txt | This tools allows users to create a document using an XML document instance, a compiled BizTalk Server map, and an optional schema.
Miscellaneous | No readme files are included with these samples. | Several Microsoft Visual Basic Scripting Edition (VBScript) files are included in this folder that perform various tasks. Descriptions are available in comment blocks at the beginning of these files. To view them, open the .vbs file in an editor.
PipelineComponent\VB (Visual Basic) | Readme.txt | This sample demonstrates an AIC that implements the IPipelineComponent and IPipelineComponentAdmin interfaces in Visual Basic.
PipelineComponent\VC (C++) | Readme.txt | This sample demonstrates an AIC that implements the IPipelineComponent and IPipelineComponentAdmin interfaces, using ATL.
ReceiveScripts | ReceiveReadme.txt | This folder contains example files for receiving data into BizTalk Messaging Services.
Sample1 | Sample1Readme.txt | This sample demonstrates how to configure BizTalk Messaging Services and submit a document to BizTalk Server 2000. Also included in the sample are the creation and use of open destination messaging ports, organization aliases, and custom envelopes.
Sample2 | Sample2Readme.txt | This sample demonstrates how to configure BizTalk Messaging Services to generate "receipts" when sending documents.
Sample3 | Sample3Readme.txt | This sample demonstrates how to configure a distribution list (port group) and send a document to it.
SampleFunctoid | Readme.txt | This sample demonstrates a custom functoid that performs date format conversion.
SampleImporter | Readme.txt | This sample demonstrates a custom import module, which imports a delimited flat file and displays it in BizTalk Editor.
SOC | Readme.txt | This sample demonstrates a synchronous interaction with the XLANG Scheduler Engine.
SQLServerAgentJobs | Readme.txt | This sample demonstrates SQL scripts for monitoring receipts and purging the tracking information.
VBCustPreProcessor | Readme.txt | This sample demonstrates a simple implementation of a custom preprocessor to be used with a File receive function.
XSDConverter | Readme.txt | This sample converts an XDR schema to an XSD schema.

Notes

  • When using C++, you need to add Program Files\Microsoft BizTalk Server\SDK\Include to the include directory list.

  • Some of the samples have a dependency on the Pipecomplib.tlb file. For these samples, you need to add \Program Files\Common Files\Microsoft Shared\Enterprise Servers\Commerce to the include directory list.


.topic 5
Aktivieren Sie dieses Kontrollkästchen, damit die COM+-Anwendung XLANG-Ablaufplaninstanzen ausführen kann.

.topic 8
Aktivieren Sie dieses Kontrollkästchen um zum Verweisen auf die Persistenzdatenbank für diese COM+-Anwendung einen Datei-DSN zu verwenden. Wenn dieses Kontrollkästchen nicht aktiviert wird, wird ein System- oder Benutzer-DSN verwendet. Ein Dateidatenquellenname (DSN, Data Source Name) speichert Informationen über eine Datenbankverbindung in einer Datei. Die Datei hat standardmäßig die Erweiterung DSN und wird im Verzeichnis $\Programme\Gemeinsame Dateien\ODBC\Data Sources gespeichert.

.topic 3
Dieses Feld enthält den DSN-Namen, der für die Kommunikation mit der Persistenzdatenbank für diese COM+-Anwendung verwendet wird. Der DSN-Name muss immer mit dem Namen der COM+-Anwendung übereinstimmen.

.topic 2
Klicken Sie auf diese Schaltfläche, um den ODBC-Datenquellennamen (DSN) für die COM+-Hostanwendung für das XLANG-Ablaufplanungsmodul zu erstellen. Wichtig: Der im Dialogfeld "Eigenschaften von XLANG Scheduler" konfigurierte DSN-Name muss mit dem Namen der COM+-Anwendung übereinstimmen.

.topic 1
Klicken Sie auf diese Schaltfläche, um den ODBC-Datenquellenadministrator zu öffnen und die auf dem Computer definierten Datenquellen zu verwalten.

.topic 4
Klicken Sie auf diese Schaltfläche, um die für die Unterstützung der Persistenz für XLANG-Ablaufplaninstanzen erforderlichen Tabellen in einer SQL Server-Datenbank zu erstellen.

.topic 7
Klicken Sie auf diese Schaltfläche, um alle ausgeführten XLANG-Ablaufplaninstanzen erfolgreich zu beenden. Der Ablaufplanstatus für alle ausgeführten Ablaufpläne wird in der Persistenzdatenbank gespeichert.

.topic 6
Klicken Sie auf diese Schaltfläche, damit alle ausgeführten COM+-Hostanwendungen für XLANG-Ablaufplaninstanzen die Aktivierung der Ablaufplaninstanzen starten und wenn möglich, das Ausführen fortsetzen.


Support Online

Online Support
und Information

* | Microsoft BizTalk Server 2000 Website
* | Microsoft Product Support Services Website
* | Microsoft COM Website
* | Microsoft Message Queuing Website
* | Microsoft SQL Server Website
* | Microsoft Windows Script Technologies Website
* | Microsoft XML Developer Center
* | MSDN Online
* | MSDN Online Library
* | Microsoft Accessibility Website


Copyright

Die in diesen Unterlagen enthaltenen Angaben und Daten, einschließlich URLs und anderen Verweisen auf Internetwebsites, können ohne vorherige Ankündigung geändert werden. Sofern nichts anderes angegeben ist, sind die in den Beispielen verwendeten Firmen, Organisationen, Produkte, Personen und Ereignisse frei erfunden. Jede Ähnlichkeit mit bestehenden Firmen, Organisationen, Produkten, Personen oder Ereignissen ist rein zufällig. Die Benutzer/innen sind verpflichtet, sich an alle anwendbaren Urheberrechtsgesetze zu halten. Unabhängig von der Anwendbarkeit der entsprechenden Urheberrechtsgesetze darf ohne ausdrückliche schriftliche Erlaubnis der Microsoft Corporation kein Teil dieses Dokuments für irgendwelche Zwecke vervielfältigt oder in einem Datenempfangssystem gespeichert oder darin eingelesen werden, unabhängig davon, auf welche Art und Weise oder mit welchen Mitteln (elektronisch, mechanisch, durch Fotokopieren, Aufzeichnen, usw.) dies geschieht.

Microsoft Corporation kann Besitzer von Patenten oder Patentanträgen, Marken, Urheberrechten oder anderen Rechten über geistiges Eigentum sein, die den Inhalt dieses Dokuments betreffen. Die Bereitstellung dieses Dokuments erteilt keinerlei Lizenzrechte an diesen Patenten, Marken, Urheberrechten oder anderem geistigen Eigentum, ausgenommen, dies wurde explizit durch einen schriftlich festgehaltenen Lizenzvertrag mit der Microsoft Corporation vereinbart.

Copyright © 1999-2000 Microsoft Corporation. Alle Rechte vorbehalten.

Microsoft, Active Directory, ActiveX, BizTalk, JScript, MSDN, MS-DOS, Visio, Visual Basic, Visual C++, Visual Studio, Win32, Windows und Windows NT sind entweder eingetragene Marken oder Marken der Microsoft Corporation in den USA und/oder anderen Ländern.

Intel ist eine eingetragene Marke der Intel Corporation.

Weitere in diesem Dokument aufgeführte Produkt- und Firmennamen können geschützte Marken ihrer jeweiligen Inhaber sein.