Mise en route avec Microsoft BizTalk Server 2000

Membre de la famille de produits .NET Enterprise Server, Microsoft BizTalk Server 2000 réunit en un seul produit l'intégration EAI (Enterprise Application Integration) et B2B (Business-to-Business) destinée aux entreprises. BizTalk Server 2000 permet aux développeurs, aux responsables informatiques et aux analystes professionnels de créer facilement des processus dynamiques qui rendent disponibles les applications, les plates-formes et les entreprises sur Internet.

Outre BizTalk Server 2000, Microsoft, en collaboration avec des partenaires industriels, a innové dans d'autres technologies qu'imposaient les solutions professionnelles sur Internet. BizTalk Framework 2.0 en est un exemple. Il s'agit d'une structure XML (Extensible Markup Language) indépendante des plates-formes qui permet l'intégration des applications et le commerce électronique. Si ce n'est pas un standard à part entière, BizTalk Framework 2.0 s'appuie sur des standards existants tels que la technologie SOAP (Simple Object Access Protocol), utilisée essentiellement par d'autres membres de la ligne de produits .NET comme Microsoft Visual Studio 7.0. BizTalk Framework 2.0 fournit la base d'échanges au format Reliable interopérables pour BizTalk Server 2000.

Pour plus d'informations sur BizTalk Framework 2.0 et sur les ressources de BizTalk Server 2000, telles que les services de communauté, la grande bibliothèque de schémas et les livres blancs, accédez aux sites Web de Microsoft à l'adresse (http://www.microsoft.com/biztalk(Site US)) et (http://www.microsoft.com/france/biztalk(Site français)).

Cette section décrit les fonctionnalités, les services, le modèle d'application et le modèle d'administration de BizTalk Server 2000. Vous pouvez également trouver des rubriques sur l'utilisation de l'aide en ligne et sur les options d'accessibilité de Microsoft. Le glossaire de BizTalk Server 2000 y est également présent. Cette section traite des rubriques suivantes :

  • Introduction à Microsoft BizTalk Server 2000

  • Glossaire BizTalk Server

  • Utilisation de l'aide

  • Accessibilité pour les personnes atteintes de handicaps

  • Les Services du Support Technique Microsoft

Copyright © 1999–2000 Microsoft Corporation.
Tous droits réservés.


Introduction à Microsoft BizTalk Server 2000

Microsoft BizTalk Server 2000 offre un environnement d'exécution et de développement puissant basé sur le Web, qui intègre des processus professionnels longs et faiblement couplés au sein d'une entreprise et dans plusieurs d'entre elles. BizTalk Server peut prendre en charge des transactions qui sont exécutées pendant des semaines ou des mois aussi bien que celles qui ne durent que quelques minutes ou quelques heures.

BizTalk Server 2000 permet de concevoir et d'utiliser des planifications XLANG, d'intégrer des applications existantes, de définir des spécifications de documents et de transformer des spécifications, ainsi que de contrôler et consigner l'activité d'exécution.

Le serveur fournit une passerelle standard pour l'envoi et la réception de documents sur Internet, de même qu'une gamme de services assurant l'intégrité, le transfert, la sécurité et la prise en charge des données BizTalk Framework et d'autres formats de documents clés.

Cette section traite des rubriques suivantes :

  • Fonctionnalités de BizTalk Server

  • Services BizTalk

  • Modèle d'application BizTalk Server

  • Modèle d'administration de BizTalk

  • Glossaire BizTalk Server


Fonctionnalités de BizTalk Server

Le tableau suivant contient des informations sur les fonctionnalités de BizTalk Server et leur utilisation.

Caractéristiques Fonction
Administration
  • Administration des serveurs

  • Administration programmée
  • Création et gestion de serveurs et de groupes de serveurs.

  • Configuration des propriétés globales de groupe de serveurs, telles que l'emplacement des bases de données de files d'attente partagées et de suivi.

  • Configuration des paramètres du serveur.

  • Configuration et gestion des fonctions de réception.

  • Affichage et gestion des files d'attente de documents.

  • Accès programmé au gestionnaire du système XLANG Scheduler, aux gestionnaires de groupe, aux instances de planification XLANG et aux ports XLANG.
Suivi des documents
  • Suivi de documents
  • Suivi de la progression du traitement des documents par Microsoft BizTalk Server 2000.

  • Recherche, affichage, visualisation et enregistrement de copies intégrales d'échanges ou de documents traités par BizTalk Server 2000.

  • Création de requêtes pour extraire des informations essentielles de la base de données de suivi dans un format facile à afficher.

  • Extraction, enregistrement et analyse de données utilisateur importantes contenues dans des documents.
Conception de l'orchestration
  • Conception des orchestrations BizTalk
  • Création de schémas décrivant les processus professionnels et implémentation programmée de ces schémas dans un environnement de conception intégré.

  • Compilation de schémas de planification XLANG en planifications XLANG.

  • Définir le flux de données entre les messages au sein des processus professionnels.
Échanges
  • Utilisation du Gestionnaire d'échanges BizTalk

  • Accès au modèle d'objets de configuration d'Échanges BizTalk
  • Gestion de l'échange de données localement ou à distance à l'aide du Gestionnaire d'échanges BizTalk.

  • Gestion de l'échange de données par programme à l'aide du modèle d'objet de configuration d'échanges BizTalk.

  • Création et gestion de canaux, de ports d'échanges, de définitions de document, d'enveloppes, d'organisations et de listes de distribution.
Outils XML
  • Création de spécifications

  • Mappage de données
  • Création et gestion de spécifications.

  • Création d'enregistrements et de champs, et définition de leurs propriétés.

  • Mappage d'enregistrements et de champs à partir d'une spécification source en enregistrements et champs d'une spécification de destination.

  • Utilisation de fonctoids pour implémenter de puissantes fonctionnalités de transformation de données.


Services BizTalk

Microsoft BizTalk Server 2000 fournit un ensemble complet de services d'échanges et d'orchestration permettant d'automatiser vos processus professionnels et d'échange de données.

Services d'échanges BizTalk

Les services d'échanges BizTalk incluent la réception de documents entrants, l'analyse de documents pour déterminer leur format, l'extraction d'identificateurs clé et l'identification de règles de traitement spécifiques, la remise de documents à leurs destinations respectives ainsi que le suivi de documents. Vous y trouverez également les services de mappage des données, la génération et la corrélation d'accusés de réception, ainsi que des services assurant l'intégrité et la sécurité des données.

Fonctions de réception

BizTalk Server 2000 fournit des fonctions de réception permettant au serveur de contrôler les documents envoyés aux emplacements spécifiés. BizTalk Server 2000 prend en charge les fonctions de réception suivantes, configurées à l'aide de BizTalk Server Administration :

  • Fichier

  • Message Queuing

BizTalk Server 2000 prend également en charge les protocoles suivants, configurés à l'aide des pages ASP ou d'un script Microsoft Exchange :

  • HTTP (à l'aide d'une page .asp)

  • HTTPS (à l'aide d'une page .asp)

  • SMTP (à l'aide d'un script Microsoft Exchange)

Services de transport

BizTalk Server 2000 fournit des services de transport permettant de transmettre des documents à leurs destinations. BizTalk Server 2000 prend en charge les services de transport suivants :

  • HTTP

  • HTTPS

  • SMTP

  • Fichier

  • Message Queuing

  • Composants d'intégration d'application

  • Bouclage

Parseurs de données

BizTalk Server 2000 prend en charge des parseurs de données pour une variété de standards de document de l'industrie, tels que ANSI X12, UN/EDIFACT et XML(Extensible Markup Language) valide et bien formé. BizTalk Server 2000 prend également en charge BizTalk Framework 2.0. Pour plus d'informations sur BizTalk Framework 2.0, accédez au site Web de Microsoft BizTalk à l'adresse suivante : (www.microsoft.com/biztalk/). La prise en charge du parseur pour les tables bidirectionnelles est également disponible. Vous pouvez également enregistrer et utiliser vos propres composants de parseur personnalisés.

Validation des données

BizTalk Server 2000 assure la validation des données en vérifiant chaque instance d'un document par rapport à une spécification. Si le document ne respecte pas les règles de la spécification, il est placé dans une file d'attente interrompue pour une analyse ultérieure.

Livraison de document au format Reliable

BizTalk Server 2000 permet une livraison de document au format Reliable grâce à des propriétés de services d'échanges BizTalk configurables. Ces propriétés incluent la définition de fenêtres Service pour l'envoi de documents, l'envoi ou la réception d'accusés de réception, la définition du nombre de tentatives et la définition du délai écoulé entre ces tentatives. BizTalk Server 2000 prend en charge l'utilisation d'enveloppes compatibles BizTalk Framework, qui fournissent des fonctionnalités d'échanges au format Reliable. Pour plus d'informations sur BizTalk Framework 2.0, accédez au site Web de Microsoft BizTalk à l'adresse suivante : (www.microsoft.com/biztalk/). BizTalk Server 2000 centralise également les documents mis en file d'attente. En cas de défaillance d'un serveur, les mécanismes de substitution permettent aux nouveaux serveurs de prendre le contrôle des documents et de les traiter.

Sécurité

BizTalk Server 2000 prend en charge le cryptage et les signatures numériques. La technologie de cryptage de clé publique est prise en charge pour tous les documents transmis à l'aide des services de transport BizTalk Server 2000. Celui-ci prend également en charge le décryptage et la vérification des signatures pour les documents qu'il reçoit.

Services d'Orchestration BizTalk

Les services d'orchestration BizTalk incluent l'intégration de processus professionnels de longue durée dans les applications qui exécutent ces processus. Cette intégration est assurée par un fichier de processus professionnels exécutable appelé planification XLANG. D'autres services assurent le contrôle de l'exécution des instances de planification XLANG.

L'une des principales fonctionnalités des services d'orchestration de BizTalk Server est sa capacité à traiter des transactions complexes exécutées pendant des semaines ou des mois, pas seulement pendant quelques minutes ou quelques heures. Une autre fonctionnalité importante est la possibilité d'implémenter des actions simultanées dans une planification XLANG.

Planifications XLANG

Une planification XLANG est un processus professionnel implémenté par la connexion de chaque étape du processus à un composant ou un service qui exécute l'étape. Une planification XLANG est ensuite exécutée par un service appelé moteur de XLANG Scheduler. Ce moteur contrôle l'instanciation, l'exécution, la mise en attente et la réalimentation d'une planification XLANG, ou de plusieurs instances d'une ou plusieurs planifications.

Technologies d'implémentation

Les technologies d'implémentation prises en charge par les services d'orchestration BizTalk incluent les services d'échanges BizTalk, les composants COM, les services Message Queuing et les composants Windows Script.

Langage XLANG

XLANG est un langage qui décrit le séquencement logique des processus professionnels ainsi que l'implémentation du processus professionnel à l'aide de différents composants ou services. Ce langage est exprimé en XML (Extensible Markup Language).


Modèle d'application BizTalk Server

Microsoft BizTalk Server 2000 propose des outils et des services permettant de créer des applications exécutables pour contrôler les processus professionnels et l'échange des données entre des partenaires commerciaux et les applications de votre entreprise. Vous trouverez la liste des services fournis par BizTalk Server 2000 dans la rubrique Services BizTalk.

L'intégration des services d'orchestration BizTalk et des services d'échanges BizTalk permet de contrôler l'échange de documents et de messages entre vos partenaires commerciaux et vos applications internes grâce à plusieurs services de transport. Les fonctionnalités suivantes sont également fournies :

  • Contrôle des transactions complexes de longue durée et des processus professionnels.

  • Livraison fiable de documents et de messages.

  • Validation des données assurée par le contrôle de chaque instance de document par rapport à une spécification.

  • Mappage des données assuré par des mappages pour transformer la structure et le format des documents.

  • Sécurité et intégrité des données assurées par des certificats de cryptage et de signature numérique.

  • Prise en charge de la génération et de la corrélation d'accusés de réception.

Pour plus d'informations sur la configuration de BizTalk Server 2000 pour l'envoi ou la réception d'accusés de réception, voir Description des accusés de réception.

Pour plus d'informations sur l'intégration des services d'orchestration BizTalk et des services d'échanges BizTalk, voir Intégration des services BizTalk.


Modèle d'administration de BizTalk

Le tableau suivant décrit les quatre principaux domaines d'administration de Microsoft BizTalk Server 2000 et les fonctions administratives appropriées à chaque domaine.

Domaine d'administration Description des fonctions administratives
administration des serveurs ;
  • Configuration et gestion des groupes de serveurs et des serveurs.

  • configurer et gérer les fonctions de réception ;

  • Gestion des files d'attente.
administration des applications ;
  • Configuration et gestion des applications COM+ qui hébergent les planifications XLANG.

  • Configuration et gestion de l'application XLANG Scheduler par défaut.
administration de la programmation ;
  • Configuration des gestionnaires du système XLANG, des gestionnaires de groupe XLANG, des instances de planification XLANG et des ports XLANG.
administration des bases de données.
  • Configuration, gestion et maintenance des bases de données suivantes :
    • Gestion d'échanges BizTalk

    • Persistance d'orchestration

    • Suivi

    • Files d'attente partagées

administration des serveurs ;

Dans BizTalk Server 2000, l'administration des serveurs inclut des tâches telles que la gestion et la configuration des groupes de serveurs, l'ajout, la suppression et la configuration des serveurs, l'ajout et la configuration des fonctions de réception, la gestion de la file partagée pour chaque groupe de serveurs, etc. Le tableau suivant contient les tâches administratives générales des serveurs, leur description et les rubriques contenant des informations supplémentaires.

Tâche administrative Description Pour obtenir des informations supplémentaires
Configuration des serveurs et des groupes de serveur
  • Configuration des connexions pour les bases de données de suivi et de files d'attente partagées.

  • Configuration de l'ordre des services de transport et du parseur.

  • Configuration des paramètres du serveur.
  • Ajout, suppression et configuration d'un groupe de serveurs

  • Ajout, suppression et configuration de serveurs dans un groupe
Gestion des files d'attente
  • Suppression et nouvelle soumission des échanges et des documents.

  • Affichage des données et des messages d'erreur.
  • Gestion des files d'attente
Gestion des fonctions de réception
  • Configuration des fonctions de réception.
  • Gestion des fonctions de réception d'un groupe de serveurs
Dépannage
  • Résolution des problèmes de traitement de serveur et de document.
  • Gestion de l'Observateur d'événements

  • Dépannage d'Administration de BizTalk Server

administration des applications ;

L'administration d'application inclut la configuration et la gestion des applications COM+ qui hébergent des planifications XLANG, l'application XLANG Scheduler par défaut et la base de données de persistance d'orchestration créée lors de l'installation de BizTalk Server 2000. Le tableau suivant contient les tâches administratives générales d'application, leur description et les rubriques contenant des informations supplémentaires.

Tâche administrative Description Pour obtenir des informations supplémentaires
Gestion de l'application XLANG Scheduler par défaut
  • Modification des paramètres par défaut de l'application XLANG Scheduler.
  • Gestion de l'application et de la base de données XLANG Scheduler par défaut
Gestion des applications COM+
  • Création d'applications COM+ pour exécuter des planifications XLANG.
  • Gestion des autres applications COM+ hébergeant des planifications XLANG

administration de la programmation ;

La gestion et l'administration des serveurs et des applications peuvent être effectuées par programme. Le tableau suivant contient les tâches administratives générales de programmation, leur description et les rubriques contenant des informations supplémentaires.

Tâche administrative Description Pour obtenir des informations supplémentaires
Gestion des files d'attente
  • Affichage des données d'échange et de document.

  • Modification de la base de données Gestion d'échanges BizTalk.

  • Lecture de la base de données de files d'attente partagées.
  • Pour plus d'informations sur l'utilisation de WMI (Windows Management Instrumentation) et de la programmation d'applications WMI, accédez au site Web de la bibliothèque MSDN en ligne(msdn.microsoft.com/library/default.asp, puis recherchez « WMI Application Programming ».

  • Vue d'ensemble de WMI

  • Accès à la file d'attente interrompue
Configuration et gestion du gestionnaire du système XLANG Scheduler, des gestionnaires de groupe, des instances de planification XLANG et des ports XLANG
  • Démarrage, arrêt et extraction d'informations sur le gestionnaire du système XLANG Scheduler et les gestionnaires de groupe.

  • Arrêt, interruption, reprise et extraction d'informations sur toutes les planifications associées à un groupe.
  • Administration des planifications XLANG

Gestion de base de données

Outre la maintenance et l'administration régulières des bases de données, telles que la compression des fichiers de données et la sauvegarde de la base de données et des fichiers journaux de transactions, vous devez effectuer d'autres tâches relatives aux bases de données, comme la gestion de la connectivité entre BizTalk Server et Microsoft SQL Server, l'ajout, la suppression et la restauration de bases de données, la configuration de nouvelles bases de données, etc. Le tableau suivant contient les tâches administratives générales de base de données, leur description et les rubriques contenant des informations supplémentaires.

Tâche administrative Description Pour obtenir des informations supplémentaires
Gestion des bases de données
  • Configuration et/ou modification de la base de données Gestion d'échanges BizTalk.

  • Création et configuration de nouvelles bases de données de persistance.

  • Restauration et/ou suppression manuelle des bases de données de suivi et de files d'attente partagées.
  • Configuration de la base de données Gestion d'échanges BizTalk

  • Modification de la base de données Gestion d'échanges BizTalk d'un serveur

  • Modification des paramètres de la base de données de persistance d'orchestration par défaut

  • Gestion des bases de données d'un groupe de serveurs
Surveillance du trafic vers les bases de données
  • Configuration des paramètres du serveur.
  • Description des propriétés d'un serveur

  • Optimisation des propriétés du serveur


BizTalk Server

A

abandonner (abort)

Annuler une transaction en cours et exécuter un autre processus professionnel.

action (action)

Envoyer ou recevoir un message. L’envoi ou la réception d’actions peut être synchrone ou asynchrone, selon les services d’application implémentés dans une planification XLANG.

Administration de BizTalk Server (BizTalk Server Administration)

Interface MMC (Microsoft Management Console) utilisée pour gérer le groupe de serveurs BizTalk Server 2000 et leurs propriétés, contrôler les fonctions de réception et surveiller les opérations dans les files d'attente Microsoft SQL Server utilisées par le groupe de serveurs.

ANSI X12

Normes EDI définies par Accredited Standards Committee X12, dont le travail est approuvé par l’ANSI (American National Standards Institute).

application de destination (destination application)

Application d'organisation d'origine conçue dans un port d'échanges comme destination des documents.

application métier (line-of-business (LOB) application)

Application principale d'une organisation. BizTalk Server 2000 prend en charge de nombreux protocoles de communication qui permettent aux applications métier d'envoyer et de recevoir des informations en toute sécurité.

application source (source application)

Application de l'organisation d'origine conçue dans un canal comme source des documents.

Voir aussi : canal, organisation d'origine

B

base de données de files d’attente partagées (Shared Queue database)

Base de données Microsoft SQL Server partagée par tous les serveurs d'un groupe de serveurs. Cette base de données enregistre toutes les informations relatives aux points de contrôle associées aux documents traités par BizTalk Server. Si un serveur tombe en panne, les autres ordinateurs qui utilisent la base de données de files d’attente partagées peuvent continuer à extraire les messages de la file de travail et à envoyer des messages dans cette file. La redondance ainsi que l'équilibrage de la charge des processus sont ainsi assurés. La base de données de files d’attente partagées est présentée graphiquement dans la console Administration de BizTalk Server sous forme d'une série de files d'attente distinctes.

Voir aussi : file de nouvel essai, file d'attente planifiée, file d'attente interrompue, file de travail

base de données de persistance (persistence database)

Base de données utilisée pour enregistrer l'état des planifications XLANG réalimentées. Une base de données par défaut appelée base de données Persistance d'orchestration est fournie lors de l'installation de BizTalk Server 2000.

base de données Suivi (Tracking database)

Base de données Microsoft SQL Server associée à un groupe de serveurs qui permet d'assurer le suivi des documents traités par le serveur individuellement ou par lots. Vous pouvez également suivre l'état des planifications XLANG.

base de données Gestion d'échanges BizTalk (BizTalk Messaging Management database)

Base de données Microsoft SQL Server qui contient les informations relatives aux configurations de tous les serveurs, notamment les paramètres des groupes et des serveurs, les fonctions de réception et toutes les informations de configuration des échanges pour les objets créés à l’aide du Gestionnaire d’échanges BizTalk ou du modèle d’objet de configuration d’échanges BizTalk.

BizTalk Framework

Structure de commerce électronique indépendante de la plate-forme et basée sur des schémas XML (Extensible Markup Language) et des standards de l’industrie. Elle permet l’intégration sur plusieurs secteurs d’activités et entre des systèmes professionnels, indépendamment de la plate-forme, du système d’exploitation ou de la technologie sous-jacente. Plus particulièrement, elle est constituée des trois éléments suivants : schéma, produits et services. Pour plus d'informations sur BizTalk Framework, rendez vous sur le site Web de BizTalk (www.microsoft.com/france/biztalk).

BizTalk Server 2000

Nouveau produit Microsoft destiné à l'automatisation de processus professionnels et l'intégration d'applications dans les entreprises et entre les entreprises. Microsoft BizTalk Server 2000 offre un environnement d’exécution et de développement puissant basé sur le Web, qui intègre des processus professionnels longs et faiblement couplés au sein d’une entreprise et dans plusieurs d’entre elles.

BizTalk Server 2000 permet de concevoir et d’utiliser des planifications XLANG, l'intégration dans des applications existantes, la définition de spécifications de document et de transformations de spécifications ainsi que ainsi que de contrôler et consigner l’activité d’exécution.

Le serveur fournit une passerelle standard pour l’envoi et la réception de documents sur Internet, de même qu’une gamme de services assurant l’intégrité, le transfert, la sécurité et la prise en charge des données BizTalk Framework et d’autres formats de documents clés.

Boucle (Loopback)

Type de service de transport qui permet le retour de données d'état actuel à l'application d'où proviennent ces données. Le bouclage utilise l'appel de méthode SubmitSync pour restaurer les données d'état dans l'application originale.

Voir aussi : services de transport

C

canal (channel)

Ensemble de propriétés qui désigne la source des documents et définit les étapes de traitement spécifiques exécutées par les services d'échanges BizTalk avant la livraison d'un document à la destination désignée par le port d'échanges ou la liste de distribution à laquelle le canal est associé.

Voir aussi : canal ouvert, port d'échanges ouvert, canal de réception, application source, partenaire commercial, soumission directe, organisation source

canal d'accusés de réception (receipt channel)

Canal contenant les informations requises pour traiter un accusé de réception pouvant être renvoyé à l'émetteur d'un document.

Voir aussi : canal

canal ouvert (open channel)

Canal déclaré explicitement comme étant ouvert pour toute organisation source. Les données source d'un canal ouvert sont transmises aux services d'échanges BizTalk dans le document ou dans un paramètre soumis avec le document.

Voir aussi : canal, openness, organisation source

champs de suivi global (global tracking fields)

Champs de spécification de document, conçus dans une définition de document, qui sont consignés dans une base de données de suivi pour chaque instance d'un document traité par les services d'échanges BizTalk.

Voir aussi : instance de document, définition de document

chemin de nœud (node path)

Expression utilisée pour obtenir des informations sur les éléments et les attributs XML, sélectionner les données correspondant à des critères spécifiques et effectuer des comparaisons des données extraites. Plus communément appelé XPath.

Voir aussi : XPath

communication asynchrone (asynchronous communication)

Message envoyé ou reçu dans le cadre d’une action de communication.

Voir aussi : communication synchrone

communication synchrone (synchronous communication)

Messages envoyés ou reçus par paires, dans le cadre d'une action de communication.

Voir aussi : communication asynchrone

compensation

Processus permettant de réparer une transaction terminée. Par exemple, si le paiement a été effectué pour un ordre ne pouvant pas être honoré, le paiement est renvoyé à l'acheteur.

compiler (compile)

Dans le Mappeur BizTalk, créer une version XSLT (Extensible Stylesheet Language Transformations) d'un mappage pouvant être utilisé par BizTalk Server. Le mappage est enregistré dans le référentiel WebDAV et utilisé par BizTalk Server pour convertir un format de document dans un autre.

Voir aussi : mappage de données, conversion de données, XML (Extensible Markup Language), mappage

composant de pipeline (pipeline component)

Composant créé pour intégrer des applications avec BizTalk Server 2000. Les développeurs peuvent utiliser l'interface IPipelineComponent ou l'interface IPipelineComponentAdmin ou l'interface plus légère IBTSAppIntegration pour développer ces composants.

Concepteur d'orchestration BizTalk (BizTalk Orchestration Designer)

Outil de conception utilisé pour créer des schémas décrivant des processus professionnels exécutables asynchrones de longue durée. Le schéma de planification XLANG est compilé en planification XLANG utilisée pour exécuter le processus professionnel automatisé.

concurrence (concurrency)

Exécution simultanée de deux ou plusieurs actions.

conversion de données (data translation)

Processus qui convertit des données d'un format dans un autre format. Les données sont converties dans BizTalk Server lors de l'exécution. Les règles spécifiées dans un mappage sont utilisées pour convertir des données d'un format de spécification source en un format de spécification de destination, et pour effectuer des opérations ou des calculs concernant les données.

Voir aussi : compiler, mappage de données, XML (Extensible Markup Language), mappage

critères de sélection (selection criteria)

Paire nom-valeur désignée dans une définition de document. Ces paires sont utilisées pour identifier de manière unique une définition de document pour les échanges EDI entrants, en fonction des valeurs définies dans l'en-tête de groupe fonctionnel, et pour insérer des valeurs dans l'en-tête de groupe fonctionnel pour les échanges EDI sortants.

Voir aussi : définition du document, EDI (Electronic Data Interchange)

D

décision (decision)

Processus d'évaluation séquentielle d'une ou plusieurs règles. Dans le Concepteur d'orchestration BizTalk, une décision est représentée par la forme Décision. Les règles sont des expressions Microsoft Visual Basic Scripting Edition (VBScript), utilisées par les formes Décision et Tant que.

définition de document (document definition)

Ensemble de propriétés représentant un document spécifique. Les propriétés de définition de document incluent un pointeur sur une spécification de document et peuvent contenir des champs de suivi global et des critères de sélection.

Voir aussi : champs de suivi global, critères de sélection

dictionnaire (dictionary)

Collection de propriétés associées à chaque opération traitée par BizTalk Server. Ces propriétés sont exportées dans l'Éditeur BizTalk pour que les utilisateurs puissent indiquer à BizTalk Server comment trouver dans les instances de document les valeurs des propriétés utilisées pour localiser un port d'échanges.

document avec auto-routage (self-routing document)

Document contenant toutes les informations de routage requises, telles que les identificateurs d'organisation source et de destination et une définition de document, dans les balises de routage ou dans le document.

document sans auto-routage (non-self-routing document)

Document pour lequel il manque un ou plusieurs des éléments d'information suivants : identificateur d'organisation source, identificateur d'organisation de destination ou définition de document.

DTD (Document Type Definition)

Définition standard spécifiant les éléments et les attributs pouvant exister dans d'autres éléments et attributs et qui spécifie les contraintes relatives à leur classement, fréquence et contenu.

E

échange (interchange)

Collection d'une ou plusieurs instances de document comprenant une seule transmission et échangée entre des applications d'une organisation ou entre des partenaires commerciaux.

échange au format Reliable (reliable messaging)

Fonctionnalité du protocole de BizTalk Framework 2.0 qui prend en charge la livraison unique de documents garantie dans des environnements hétérogènes par le biais d'Internet.

Éditeur BizTalk (BizTalk Editor)

Outil permettant de créer, de modifier et de gérer les spécifications. Cet éditeur permet de créer une spécification basée sur un modèle de spécification, un schéma existant, certains types d’instances de document ou une spécification vide.

état (state)

Condition à un moment donné des nombreux éléments de calcul.

Voir aussi : état de planification XLANG

état de planification XLANG (XLANG schedule state)

Informations contenues dans une instance de planification XLANG. Elles incluent les messages envoyés ou reçus par cette instance, les objets COM utilisés par cette instance et la progression de cette instance vers la fin de l'exécution du processus professionnel.

Voir aussi : état

état de repos (quiescent state)

État représentant une activité de traitement inactive ou au repos, ou un processus en mode attente.

EDI (Electronic Data Interchange)

Ensemble de standards utilisés pour contrôler le transfert des documents, tels que les ordres d'achat et les factures, entre des ordinateurs.

Voir aussi : critères de sélection

emplacement du port (port location)

Emplacement associé à un port spécifique. Il dépend également de l'implémentation de port utilisée. Chaque implémentation fournit un type d'emplacement différent pour le port.

Voir aussi : port, implémentation du port, nom du port, référence du port

ensemble de transactions (transaction set)

Collection de segments d'un schéma EDI ayant un ordre spécifique et une signification particulière pour une transaction professionnelle donnée.

enveloppe (envelope)

1. Ensemble de propriétés définissant une enveloppe. Les propriétés d'enveloppe comportent un format d'enveloppe et peuvent comporter un pointeur vers une spécification d'enveloppe..

2. Informations d'en-tête et de pied de page, ou informations d'en-tête uniquement, qui encapsulent ou précèdent les données du document pour le transport.

F

file d'attente dynamique (dynamic queue)

File d'attente dont l'adresse est inconnue. Les ports qui font appel à une implémentation Message Queuing peuvent utiliser une file d'attente dynamique si l'emplacement de la file d'attente n'est pas connu. Son adresse doit être fournie par le biais d'un message qui la transmet à la référence du port lors de l'exécution.

Voir aussi : file d'attente statique, file d'attente par instance

File d'attente interrompue (Suspended queue)

Table de la base de données de files d’attente partagées de Microsoft SQL Server. La file d'attente interrompue est associée à un groupe de serveurs. Elle contient les opérations pour lesquelles des erreurs ou des défaillances ont été rencontrées lors du traitement. La file d'attente enregistre les documents jusqu'à ce qu'ils soient corrigés et traités de nouveau, ou simplement supprimés.

Voir aussi : file de nouvel essai, file d'attente planifiée, base de données de files d’attente partagées, file de travail

file d'attente par instance (per-instance queue)

File d'attente créée pour être utilisée avec chaque nouvelle instance d'une planification XLANG.

Voir aussi : file d'attente dynamique, file d'attente statique

File d'attente planifiée (Scheduled queue)

Table de la base de données de files d’attente partagées de Microsoft SQL Server. La file d'attente planifiée est associée à un groupe de serveurs qui contient les échanges reçus mais non encore traités par BizTalk Server.

Voir aussi : file de nouvel essai, base de données de files d’attente partagées, file d'attente interrompue, file de travail

file d'attente statique (static queue)

File d'attente dont l'adresse est connue. Les ports qui font appel à une implémentation Message Queuing peuvent utiliser une file d'attente statique lorsque l'emplacement de cette dernière est connu et ne change pas.

Voir aussi : file d'attente dynamique, file d'attente par instance

File de nouvel essai (Retry queue)

Table de la base de données de files d’attente partagées de Microsoft SQL Server. La file de nouvel essai est associée à un groupe de serveurs qui contient des opérations planifiées pour la transmission après la tentative d'une transmission initiale.

Voir aussi : base de données de files d'attente partagées, services de transport, file d'attente planifiée, file d'attente interrompue, file de travail

File de travail (Work queue)

Table de la base de données de files d’attente partagées de Microsoft SQL Server. La file de travail est associée à un groupe de serveurs. Elle contient les échanges traités par BizTalk Server 2000.

Voir aussi : file de nouvel essai, file d'attente planifiée, base de données de files d’attente partagées, file d'attente interrompue

filtrage de canal (channel filtering)

Comparaison de la valeur de champs d'une instance de document aux valeurs contenues dans des expressions désignées dans un canal. Cette comparaison permet de filtrer la sélection de canaux appelés par le serveur pour traiter un document.

flat-file délimité (delimited flat file)

Fichier contenant un ou plusieurs enregistrements représentés sous forme d'un groupe de champs séparés par un délimiteur. Les enregistrements sont également séparés par un délimiteur.

Voir aussi : organisation d'origine

flat-file positionnel (positional flat file)

Fichier contenant des champs de longueur fixe ainsi que des enregistrements disposant d'un terminateur de fin d'enregistrement commun.

fonctions de réception (receive functions)

Fonctionnalité permettant aux serveurs BizTalk de contrôler les répertoires et de soumettre des documents à BizTalk Server en vue d’un traitement. BizTalk Server 2000 prend en charge les fonctions de réception Fichier et Message Queuing.

fonctoid (functoid)

Fonction intégrée réutilisable qui permet d'effectuer des opérations de manipulation structurelle complexes entre des éléments de spécification source, des éléments de spécification de destination et d'autres fonctoids.

Voir aussi : lien

format d'enveloppe (envelope format)

Format des documents pouvant être contenus dans une enveloppe ; par exemple, XML ou X12.

formes Communication (Communication shapes)

Formes utilisées pour identifier le contenu exact d'un message et le type de services d'application implémenté dans un schéma de planification XLANG. Cette catégorie de formes inclut Constantes, Message, Port et Références du port.

Voir aussi : formes Diagramme de flux, formes Implémentation, schéma de planification XLANG

formes Diagramme de flux (Flowchart shapes)

Formes représentant la logique de routage dans un schéma de planification XLANG. Cette catégorie de formes inclut Abandon, Action, Début, Décision, Fin, Branche, Jointure et Tant que.

Voir aussi : formes Communication, formes Implémentation, stencil du diagramme de flux, schéma de planification XLANG

formes Implémentation (Implementation shapes)

Formes représentant les technologies prises en charge par le moteur de XLANG Scheduler. Cette catégorie de formes inclut Échanges BizTalk, Composant COM, Message Queuing et Composant de script.

Voir aussi : formes Communication, formes Diagramme de flux, stencil d'implémentation

G

Gestionnaire d'échanges BizTalk (BizTalk Messaging Manager)

Interface graphique utilisateur permettant de configurer les services d’échanges BizTalk pour échanger des documents entre des partenaires commerciaux et des applications de l’organisation d'origine.

Voir aussi : Services d'échanges BizTalk

groupe de ports (port group)

Groupe de ports d'échanges pouvant être utilisés pour envoyer le même document à différentes organisations de partenaire commercial ou applications. Dans le Gestionnaire d'échanges BizTalk, il s'agit d'une liste de distribution.

groupe de serveurs (server group)

Collection de serveurs dont la gestion, la configuration et la surveillance sont centralisées.

I

identificateur d'organisation (organization identifier)

Ensemble de propriétés qui identifie de manière unique une organisation. Celle-ci peut comporter plusieurs identificateurs constitués des propriétés suivantes : un nom, un qualificateur et une valeur.

Voir aussi : organisation

identité XLANG (XLANG identity)

Identificateur unique global utilisé pour différencier les versions d’un schéma de planification XLANG. Cette propriété est en lecture seule et ne peut pas être modifiée. Chaque fois qu'un schéma de planification XLANG est mis à jour, cette identité est également mise à jour. L'identité XLANG peut être utilisée pour associer une planification XANG à la version d'un schéma de planification XLANG à partir de laquelle la planification a été compilée.

implémentation du port (port implementation)

Technologie utilisée par un port pour implémenter une action de communication.

Voir aussi : port, emplacement du port, référence du port, nom du port

instance de document (document instance)

Représentation des données réelles envoyées à BizTalk Server. Une instance de document diffère d'une spécification dans le sens où celle-ci définit la structure des données, alors qu'une instance de document est une représentation des données contenues dans une structure.

Voir aussi : champs de suivi global, soumission directe

instance de planification XLANG (XLANG schedule instance)

Évocation d'une planification. Une planification XLANG ne représente que le processus professionnel et les services d'implémentation. Une instance ou plusieurs instances, d'une planification XLANG peuvent être exécutées par le moteur de XLANG Scheduler. Différentes instances de la même planification XLANG contiennent différents messages, mais toutes les instances suivent les mêmes règles relatives aux processus professionnels.

Voir aussi : planification XLANG, moteur de XLANG Scheduler

L

Langage XLANG (XLANG language)

Langage décrivant la séquence logique des processus professionnels, ainsi que l'implémentation du processus professionnel à l'aide de différents services d'application. Le langage XLANG est exprimé en XML.

liaison (binding)

Processus qui permet de spécifier la technologie utilisée pour implémenter un port.

Voir aussi : port

lien (link)

Dans le Mappeur Microsoft BizTalk, opération simple de copie d'une valeur (ou de copie d'un nom) d'un champ de la spécification source dans un champ de la spécification de destination, ou un fonctoid.

Voir aussi : fonctoid

liste de codes (code list)

Liste de valeurs de codes utilisées en tant qu'abréviations pour plusieurs informations textuelles. Par exemple, ST correspond à la valeur Ship To de la liste de codes et qualifie le plus souvent une adresse.

liste de distribution (distribution list)

Groupe de ports d'échanges pouvant être utilisés pour envoyer le même document à différentes organisations de partenaires commerciaux ou d'applications d'organisation d'origine. Dans le modèle de configuration d'échanges BizTalk, il s'agit d'un groupe de ports.

Voir aussi : organisation d'origine, port d'échanges, partenaire commercial

logique de routage (routing logic)

Ensemble de règles qui détermine la séquence d'exécution dans une planification XLANG. La logique de routage est implémentée par la forme Décision dans BizTalk Application Designer.

M

mappage (map)

Fichier XML qui définit la correspondance entre les enregistrements et les champs d'une spécification et ceux d'une autre spécification. Un mappage contient une feuille de style XSL (Extensible Stylesheet Language), utilisée par BizTalk Server pour effectuer la transformation décrite dans le mappage. Les mappages sont créés dans le Mappeur BizTalk.

Voir aussi : compiler, XML (Extensible Markup Language), conversion de données

mapping

Processus de spécification de la transformation en une autre structure des données d'une structure.

mappage de données (data mapping)

Dans le Mappeur BizTalk, création d'une correspondance entre les enregistrements et les champs de la spécification source et ceux de la spécification de destination.

Voir aussi : compiler, conversion de données

Mappeur BizTalk (BizTalk Mapper)

Outil de création de mappages qui définissent la correspondance entre les enregistrements et les champs d’une spécification et ceux d’une autre spécification. Un mappage contient une feuille de style XSL (Extensible Stylesheet Language), utilisée par BizTalk Server pour effectuer la transformation décrite dans le mappage.

message

1. Paquet de données envoyé ou reçu par une planification XLANG.

2. Dans le Concepteur d'orchestration BizTalk, forme de la page Données qui correspond aux messages dans une planification XLANG. Les formes Message sont constituées de champs ayant un nom unique, contenant un seul élément de données du type spécifié.

mettre en attente (dehydrate)

Enregistrer toutes les informations d'état d'une instance de planification XLANG dans une base de données SQL Server alors que le moteur de XLANG Scheduler attend de recevoir un message pour exécuter l'action suivante dans le processus professionnel.

Voir aussi : moteur de XLANG Scheduler

moniker

Nom représentant un objet et pouvant inclure le chemin complet ou l'adresse qui identifie l'emplacement de cet objet.

Voir aussi : port

moteur de XLANG Scheduler (XLANG Scheduler Engine)

Service qui exécute les instances de planification XLANG et contrôle l'activation, l'exécution, la mise en attente et la réalimentation d'une planification XLANG.

Voir aussi : réalimenter, schéma de planification XLANG, instance de planification XLANG, planification XLANG

N

nom du port (port name)

Identification unique d'un port. Elle permet d'associer l'emplacement du port à un port.

Voir aussi : port, implémentation du port, emplacement du port, référence du port

O

openness

Absence d'informations explicites sur une source dans un canal ou une destination d’un port d'échanges. Les canaux contiennent des informations qui identifient la source. Les ports d'échanges contiennent des informations qui identifient la destination. Si un canal est désigné comme source ouverte, les informations source ne sont pas explicitement déclarées dans le canal et sont fournies par d'autres moyens. En général, ces informations sont contenues dans l'instance du document envoyé ou sont définies sous forme de paramètres dans un appel à la méthode Submit. De même, si un port d'échanges est désigné comme destination ouverte, les informations relatives à la destination ne sont pas explicitement déclarées dans le port d'échanges et sont placées dans l'instance de document ou dans les paramètres d'un appel à la méthode Submit.

Voir aussi : organisation de destination, canal ouvert, port d'échanges ouvert, organisation source

organisation (organization)

Partenaire commercial ou unité professionnelle d'un partenaire commercial, ou dans le cas de l'organisation d'origine, votre propre entreprise.

Voir aussi : organisation source, organisation de destination, organisation d'origine, identificateur d'organisation, partenaire commercial

organisation de destination (destination organization)

Organisation de partenaire commercial conçue dans un port d'échanges comme destination des documents.

Voir aussi : openness, organisation source, organisation

organisation d'origine (home organization)

Objet représentant votre entreprise dans le Gestionnaire d'échanges BizTalk. Elle est créée lors de l'installation de BizTalk Server 2000. Seule l'organisation d'origine peut contenir des applications.

Voir aussi : application de destination, liste de distribution, organisation, application source, partenaire commercial

organisation source (source organization)

Organisation de partenaire commercial conçue dans un canal comme source des documents.

Voir aussi : canal, organisation de destination, canal ouvert, port d'échanges ouvert, openness, organisation, partenaire commercial

P

palette de fonctoids (functoid palette)

Boîte à outils contenant tous les fonctoids pouvant être utilisés pour créer des relations entre des éléments de spécification source et des éléments de spécification de destination.

parseur (parser)

Composant de BizTalk Server qui convertit des fichiers non-XML (par exemple, X12, EDIFACT et table bidirectionnelle) en fichiers XML.

partenaire commercial (trading partner)

Organisation externe avec laquelle votre organisation d'origine échange des données électroniques. Les ports d'échanges, les listes de distribution, les canaux et les planifications XLANG que vous créez gèrent l'échange de documents entre les partenaires commerciaux.

Voir aussi : canal, organisation source, liste de distribution, organisation d'origine, organisation

planification mise en attente (dehydrated schedule)

Planification enregistrée temporairement dans une base de données dans l'attente de la réception d'un message, avant de passer à l'action suivante de la séquence. Les informations d'état relatives à la planification sont enregistrées dans la base de données jusqu'à la réception du message. La réalimentation des planifications permet de réduire la charge de l'ordinateur qui héberge la planification.

planification XLANG (XLANG schedule)

Processus professionnels spécifiques exprimés en langage XLANG. Une planification XLANG est enregistrée avec l'extension de fichier .skx.

Voir aussi : schéma de planification XLANG, instance de planification XLANG, moteur de XLANG Scheduler

point de contrôle (checkpoint)

Emplacement de stockage dans la base de données Files d'attente partagées qui contient l'état actuel d'une opération. En cas de panne d'un serveur, les documents placés en file d'attente sur ce serveur peuvent être extraits de la base de données de files d'attente partagées et redistribués à d'autres serveurs du groupe de serveurs, en fonction des informations fournies par le point de contrôle.

port

Emplacement désigné pour utiliser une implémentation spécifique. Dans le Concepteur d'orchestration BizTalk, un port est défini par l'emplacement de destination ou source des messages, et la technologie utilisée pour implémenter l'action de communication. L'emplacement est identifié de manière univoque par le nom du port.

Voir aussi : port dynamique, moniker, emplacement du port, référence du port, implémentation du port, nom du port, liaison, port statique

port d'échanges (messaging port)

Ensemble de propriétés qui indiquent comment les documents sont enveloppés, sécurisés et transportés vers une organisation ou une application de destination donnée.

Voir aussi : liste de distribution

port d'échanges ouvert (open messaging port)

Port d'échanges explicitement déclaré comme étant ouvert à toute organisation de destination. Les données de destination d'un port d'échanges ouvert sont transmises aux services d'Échanges BizTalk dans le document ou dans un paramètre soumis avec le document.

Voir aussi : canal, openness, organisation source

port dynamique (dynamic port)

Port requérant la spécification d'informations d'emplacement particulières pour une planification XLANG lors de l'exécution. L'emplacement d'un port dynamique est fourni par un message qui transmet des informations d'emplacement à la référence pour le port lors de l'exécution.

Voir aussi : port, port statique

port statique (static port)

Port requérant que toutes les informations requises soient fournies pour une planification XLANG lors de la conception. Le concepteur qui crée la planification XLANG doit connaître l'emplacement vers lequel les messages sont envoyés ou à partir duquel les messages sont reçus, ainsi que la technologie choisie pour implémenter l'action de communication.

Voir aussi : port dynamique, port

R

réalimenter (rehydrate)

Extraire toutes les informations d'état d'une instance de planification XLANG d'une base de données SQL Server après réception d'un message par le moteur de XLANG Scheduler.

Voir aussi : moteur de XLANG Scheduler

référence du port (port reference)

Message unique contenant l'emplacement de chaque port d'une planification XLANG. La forme Références de port se trouve dans la page Données. Les flux de données entrants et sortants de ce message contiennent l'emplacement du port.

Voir aussi : emplacement du port, port, implémentation du port, nom du port

S

schéma (schema)

Définition de la structure d'un fichier XML. Un schéma contient des informations sur les propriétés étant donné qu'il appartient aux enregistrements et aux champs de la structure.

schéma de planification XLANG (XLANG schedule drawing)

Schéma représentant un processus professionnel. Dans le Concepteur d'orchestration BizTalk, lorsqu'un schéma est terminé, il peut être compilé et exécuté sous forme de planification XLANG. Un schéma de planification XLANG est enregistré avec l'extension de fichier .skv.

Voir aussi : formes Communication, formes Diagramme de flux, planification XLANG, moteur de XLANG Scheduler

sérialiseur (serializer)

Composant de BizTalk Server qui convertit les fichiers XML en fichiers non-XML (par exemple, X12, EDIFACT et flat-file).

Services d'échanges BizTalk (BizTalk Messaging Services)

Services qui incluent l’envoi, la réception, l’analyse et le suivi des documents, la génération et la corrélation d’accusés de réception ainsi que le mappage, l’intégrité et la sécurité des données.

Voir aussi : Gestionnaire d'échanges BizTalk

Services d'orchestration BizTalk (BizTalk Orchestration Services)

Services qui incluent la conception, la compilation et l’exécution de planifications XLANG. D’autres services incluent la possibilité de créer des applications COM+ personnalisées pour héberger des instances de planifications XLANG dédiées, ainsi que la persistance des planifications XLANG.

services de transport (transport services)

Ensemble de services qui inclut des protocoles de réseau et des composants d'intégration d’applications (AIC). BizTalk Server 2000 prend en charge un ensemble clé de services de transport. Le serveur peut ainsi envoyer les documents aux organisations ou aux applications, que les applications soient en mesure ou non de communiquer directement avec le serveur par le biais de l'interface COM. BizTalk Server 2000 prend en charge les protocoles de réseau Fichier, HTTP, HTTPS et SMTP et Message Queuing. Les services de transport sont également appelés composants de transport.

Voir aussi : file de nouvel essai, bouclage

soumettre à nouveau (resubmit)

Procédure qui soumet des échanges ou des documents à BizTalk Server en provenance de la file d'attente interrompue. Le document est traité à partir du point de défaillance.

soumission directe (pass-through submission)

Soumission qui ignore les étapes d'analyse, de décodage, de décryptage et de vérification des signatures. L'instance de document est transmise directement au canal spécifié dans les paramètres de soumission. Ce type de soumission peut être utilisé pour transmettre des fichiers binaires sans altération des données, ou n'utiliser que les fonctions de transport de serveur ou de suivi global.

Voir aussi : canal, instance de document

spécification (specification)

Schéma XML propre à BizTalk Server. Les spécifications sont créées dans l'Éditeur BizTalk et peuvent s’appuyer sur des standards de l’industrie (tels que EDIFACT, X12 et XML) ou sur des fichiers flat-file (délimités, positionnels, ou délimités et positionnels). Le Mappeur BizTalk utilise des spécifications, ouvertes comme des spécifications source et des spécifications de destination, pour créer des mappages.

spécification de destination (destination specification)

Spécification d'un mappage représentant le document sortant. Le Mappeur BizTalk mappe une spécification source en spécification de destination.

Voir aussi : spécification source

spécification source (source specification)

Dans un mappage, spécification représentant un document entrant. Le Mappeur BizTalk mappe une spécification source en spécification de destination.

Voir aussi : spécification de destination

standard de document (document standard)

Structure qui définit un ensemble de transactions, tel qu'un standard X12 850. Un conseil d'implémentation peut être créé à partir d'un standard de document.

standard de l’industrie (industry standard)

Norme utilisée pour l'échange d'informations. Les normes sont extensibles et suivent un ensemble de règles bien définies, ou syntaxe.

stencil d'implémentation (Implementation stencil)

Stencil de schéma fourni par le Concepteur d'orchestration BizTalk. Il fournit toutes les formes pouvant être utilisées pour lier un port à une technologie d'implémentation.

Voir aussi : Stencil de diagramme de flux, formes Implémentation

stencil du diagramme de flux (Flowchart stencil)

Stencil de schéma fourni par le Concepteur d'orchestration BizTalk. Le stencil du diagramme de flux fournit toutes les formes permettant de concevoir le flux d'un processus professionnel pouvant être exécuté par une planification XLANG.

Voir aussi : formes Diagramme de flux, stencil d'implémentation

suivi de documents BizTalk (BizTalk Document Tracking)

Interface utilisateur basée sur le Web qui permet d’accéder aux informations de suivi de tous les services d’échanges BizTalk. Elle permet également d'obtenir l’état des planifications XANG pour les services d’orchestration BizTalk.

T

technologies d'implémentation (implementation technologies)

Technologies utilisées pour implémenter un port dans une planification XLANG. Les technologies prises en charge par le moteur de XLANG Scheduler incluent les composants COM, les composants de scripts Windows, les services Message Queuing et les services d'échanges BizTalk.

transaction

Activité discrète sur un ordinateur, telle que la saisie d'une commande client ou la mise à jour d'un élément d'inventaire. Les transactions sont généralement associées à la gestion de la base de données, à la saisie des commandes et autres systèmes en ligne. Dans le Concepteur d'orchestration BizTalk, les transactions sont représentées sous forme d'une collection d'actions regroupées dans une forme Transaction.

Voir aussi : transaction interne, transaction de longue durée, transaction imbriquée, transaction externe, transaction courte

transaction courte (short-lived transaction)

Collection d'actions groupées qui sont exécutées en tant qu'opération logique unique.

Voir aussi : transaction de longue durée, transaction

transaction de longue durée (long-running transaction)

Collection d'actions qui envoient et reçoivent des messages pendant une période illimitée. En règle générale, les transactions de longue durée contiennent plusieurs transactions courtes imbriquées.

Voir aussi : transaction courte, transaction interne, transaction imbriquée, transaction externe, transaction

transaction externe (outer transaction)

Transaction contenant une ou plusieurs transactions dans son flux de processus.

Voir aussi : transaction interne, transaction de longue durée, transaction imbriquée, transaction

transaction imbriquée (nested transaction)

Une ou plusieurs transactions contenues dans le flux de processus d'une transaction de plus grande taille.

Voir aussi : transaction interne, transaction de longue durée, transaction externe, transaction

transaction interne (inner transaction)

Transaction contenue dans le flux de processus d'une autre transaction.

Voir aussi : transaction interne, transaction de longue durée, transaction externe, transaction

type de document (document type)

Désignation du type de document servant de base à une spécification. Par exemple, si une spécification est basée sur 850Schema.xml du standard X12, lorsque cette spécification est ouverte dans l'Éditeur BizTalk, 850 apparaît dans le champ du type de document dans l'onglet Référence du nœud racine.

U

UN/EDIFACT

Norme EDI internationale développée dans les Nations Unies. Elle est couramment utilisée en Europe, ainsi qu'au Japon et dans d’autres pays et régions d'Asie. Appelé également United Nations/Electronic Data Interchange For Administration, Commerce, and Transport.

V

valider (commit)

Implémenter toutes les modifications demandées par une transaction en attente. Cette action se produit lorsque toutes les actions d'une transaction sont exécutées avec succès.

version

Dans BizTalk Server 2000, numéro de version d'une spécification ou numéro de version de l'industrie à partir de laquelle une spécification est créée.

W

WebDAV (Web Distributed Authoring and Versioning)

Extension de la norme HTTP 1.1 qui permet d'obtenir un support de stockage de fichiers hiérarchique, tel qu'un système de fichiers sur une connexion HTTP. WebDAV verrouille les documents pour éviter que les utilisateurs n’écrasent les modifications apportées par d'autres utilisateurs. Il permet également aux utilisateurs de partager et de traiter des documents basés sur le serveur, quels que soient leurs outils de création de page Web, leurs plates-formes et le type des serveurs Web contenant les fichiers.

X

XDR (XML-Data Reduced)

Dialecte de schéma XML proposé par Microsoft et soumis à W3C (World Wide Web Consortium) en 1998. Comme XML-Data, XDR est une syntaxe pour les schémas XML (Extensible Markup Language) qui définissent les caractéristiques d'un document XML. XDR est un sous-ensemble de XML-Data.

Voir aussi : XML (Extensible Markup Language)

XLANG Scheduler

Application COM+ par défaut installée lors de l'installation de BizTalk Server 2000. Elle sert à héberger les instances des planifications XLANG en cours d'exécution.

XML (Extensible Markup Language)

Spécification développée par W3C (World Wide Web Consortium) qui permet aux concepteurs de créer des balises personnalisées au-delà des fonctionnalités HTML standard. Alors que HTML n'utilise que des balises prédéfinies pour décrire les éléments de la page, XML permet au développeur de la page de définir des balises. Il est possible d'utiliser, pour des applications spécifiques, des balises pour toutes les données virtuelles, telles qu'un produit ou un montant dû. Les pages Web peuvent ainsi fonctionner comme des enregistrements de base de données.

Voir aussi : compiler, mappage, conversion de données, XDR (XML-Data Reduced), XPath

XML bien formé (well-formed XML)

Standard qui indique qu'un document XML ayant une seule racine et des éléments doit s'imbriquer complètement ou pas du tout.

XPath

Langage complet utilisé pour naviguer dans la hiérarchie d'un document XML. Les expressions Xpath peuvent obtenir des informations sur les éléments et les attributs XML, sélectionner des données qui répondent à des critères spécifiques et effectuer des comparaisons des données extraites. Appelé également chemin de nœud.

Voir aussi : XML (Extensible Markup Language), chemin de nœud

XSL (Extensible Stylesheet Language)

Format de feuille de style pour les documents XML (Extensible Markup Language). XSL permet de définir l'affichage XML de la même manière que les feuilles de style en cascade (CSS) sont utilisées pour définir l'affichage HTML (Hypertext Markup Language). BizTalk Server utilise XSL comme langage de conversion entre deux spécifications.


Utilisation de l'aide

Cette section comprend des informations relatives au système d'aide de Microsoft BizTalk Server 2000. Cette section traite des rubriques suivantes :

  • Vue d'ensemble de l'aide

  • Recherche d'une rubrique d'aide

  • Définition d'un signet pour une rubrique d'aide

  • Copie d'une rubrique d'aide

  • Impression d'une rubrique d'aide

  • Modification de la taille de police

  • Utilisation du filtrage sur le langage

  • Touches de raccourci de la Visionneuse de l'aide


Vue d'ensemble de l'aide

Le système d'aide de Microsoft BizTalk Server 2000 est mis et forme et présenté au format HTML. La Visionneuse de l'aide comporte une table des matières intégrée, un index et une fonction de recherche de texte intégral qui permet de trouver facilement les informations. Des icônes représentant des livres s'ouvrent pour laisser apparaître des sous-livres et des rubriques. Pour développer la table des matières et afficher les rubriques d'un livre, cliquez sur le signe plus (+) figurant en regard d'un titre de livre. Pour masquer les rubriques, cliquez sur le signe moins (-). La Visionneuse de l'aide offre en outre l'avantage de vous permettre d'afficher la table des matières, l'index ou les résultats d'une recherche pendant que vous examinez une rubrique d'aide.

La Visionneuse de l'aide contient également l'onglet Favoris, grâce auquel vous pouvez identifier des rubriques à l'aide de signets. Ceci vous permet d'afficher rapidement les rubriques que vous consultez souvent.

Pour en savoir plus sur BizTalk Server 2000, vous pouvez utiliser la table des matières pour parcourir la documentation. Lorsque vous cliquez sur une rubrique dans la table des matières, les informations correspondantes sont affichées dans le volet de contenu de la fenêtre d'aide.

La table des matières est organisée en livres d'après les caractéristiques et fonctions principales de BizTalk Server 2000. Chaque livre comprend des chapitres reprenant les informations suivantes :

  • Comment

  • Concepts

  • Dépannage

  • Ressources

Pour des informations sur les procédures et les tâches, commencez par les chapitres Comment. Pour des informations plus générales sur BizTalk Server 2000, ses fonctionnalités ou autres sujets, consultez d'abord les chapitres Concepts et Ressources.

En ce qui concerne les informations de programmation figurant dans BizTalk Server 2000 Interface Reference, vous pouvez utiliser un outil de filtrage pour afficher les informations spécifiques à Microsoft Visual Basic, à Visual C++ ou à ces deux langages.

Voir aussi

Définition d'un signet pour une rubrique d'aide

Copie d'une rubrique d'aide

Modification de la taille de police

Recherche d'une rubrique d'aide

Touches de raccourci de la Visionneuse de l'aide

Impression d'une rubrique d'aide

Utilisation du filtrage sur le langage


Recherche d'une rubrique d'aide

Dans la Visionneuse de l'aide, vous disposez des options de navigation et de recherche suivantes :

  • Onglet Sommaire
    1. Pour parcourir la table des matières, cliquez sur l'onglet Sommaire. Double-cliquez sur les icônes de livre pour faire apparaître les titres de rubrique et les icônes de sous-livre.

    2. Cliquez sur une entrée de la table des matières pour afficher la rubrique correspondante.
  • Onglet Index
    1. Pour afficher une liste d'entrées d'index, cliquez sur l'onglet Index, puis tapez un mot ou parcourez la liste. Les rubriques sont souvent indexées sous plusieurs entrées.

    2. Double-cliquez sur une entrée de l'index pour afficher la rubrique correspondante.
  • onglet Recherche
    1. Pour rechercher toutes les occurrences d'un mot ou d'une expression, cliquez sur l'onglet Rechercher, tapez le mot ou l'expression que vous souhaitez rechercher, puis cliquez sur Rechercher.

      Pour affiner vos recherches, associez plusieurs mots ou expressions à l'aide des opérateurs AND, OR, NEAR ou NOT.

    2. Double-cliquez sur une entrée des résultats de la recherche pour afficher la rubrique correspondante.
  • Onglet Favoris
    1. Pour définir un signet pour une rubrique, utilisez l'onglet Sommaire, Index ou Rechercher pour rechercher, puis afficher une rubrique.

    2. Cliquez sur l'onglet Favoris puis cliquez sur Ajouter pour enregistrer le titre de la rubrique dans la liste Rubriques.

    3. Double-cliquez sur un signet dans la liste Rubriques pour afficher rapidement la rubrique correspondante.

Voir aussi

Touches de raccourci de la Visionneuse de l'aide


Définition d'un signet pour une rubrique d'aide

  1. Utilisez l'onglet Sommaire, Index ou Rechercher pour rechercher et afficher la rubrique à marquer d'un signet.

  2. Cliquez sur l'onglet Favoris, puis sur Ajouter.

La Visionneuse de l'aide ajoute le titre de la rubrique à la liste Rubriques. Par la suite, vous pourrez retourner à cette liste et double-cliquer sur le signet pour afficher rapidement la rubrique.

Remarques

  • Vous pouvez créer une liste de rubriques d'aide favorites (celles que vous consultez souvent).

  • Pour supprimer un signet de la liste Rubriques, sélectionnez-le, puis cliquez sur Supprimer.

Voir aussi

Recherche d'une rubrique d'aide

Touches de raccourci de la Visionneuse de l'aide


Copie d'une rubrique d'aide

  1. Dans le volet des rubriques de la Visionneuse de l'aide, cliquez avec le bouton droit dans la rubrique que vous souhaitez copier, puis cliquez sur Sélectionner tout.

  2. Dans la rubrique, cliquez de nouveau à l'aide du bouton droit, puis cliquez sur Copier.

    La rubrique est ainsi copiée dans le Presse-papiers.

  3. Ouvrez le document dans lequel vous souhaitez copier la rubrique.

  4. Dans le document, cliquez à l'endroit où vous souhaitez faire figurer les informations.

  5. Dans le menu Edition, cliquez sur Coller.

Remarques

  • Si vous ne voulez copier que partiellement une rubrique, sélectionnez la partie souhaitée, cliquez avec le bouton droit sur votre sélection, puis cliquez sur Copier.

  • Les numéros des étapes ne sont pas copiés dans le Presse-papiers.

Voir aussi

Recherche d'une rubrique d'aide

Impression d'une rubrique d'aide


Impression d'une rubrique d'aide

  • Cliquez avec le bouton droit sur la rubrique que vous voulez imprimer, puis cliquez sur Imprimer.

Important

  • Pour imprimer une seule rubrique, dans l'onglet Sommaire, sélectionnez une rubrique. Dans la barre d'outils Aide, cliquez sur Imprimer, puis sur Imprimer la rubrique sélectionnée. Il est préférable que l'orientation de la page soit en Paysage ; sinon, les exemples de code, les grandes illustrations et le texte significatif risquent de ne pas être intégralement imprimés.

  • Pour imprimer toutes les rubriques d'un livre, dans l'onglet Sommaire, sélectionnez un livre. Dans la barre d'outils de l'Aide, cliquez sur Imprimer, puis cliquez sur Imprimer la rubrique sélectionnée et toutes les sous-rubriques. Il est préférable que l'orientation de la page soit en Paysage ; sinon, les exemples de code, les grandes illustrations et le texte significatif risquent de ne pas être intégralement imprimés.

Voir aussi

Recherche d'une rubrique d'aide

Touches de raccourci de la Visionneuse de l'aide


Modification de la taille de police

Vous pouvez augmenter la taille de police du texte pour améliorer la lisibilité de l'affichage ou la diminuer pour disposer d'une représentation de la structure d'une page.

  • Dans la barre d'outils, cliquez sur le bouton Police ( Font button) pour augmenter ou diminuer la taille du texte.


Utilisation du filtrage sur le langage

Afin de fournir uniquement les informations significatives pour votre environnement de programmation, l'aide de BizTalk Server 2000 implémente un outil de filtrage sur le langage. Dans la barre de titre des rubriques de Création de solutions à l'aide de BizTalk Server 2000 (SDK), vous disposez d'un bouton de filtrage ( Language-filtering tool) permettant l'accès à un menu de langages. Ce menu vous permet d'afficher la documentation adaptée à Visual C++ ou à Visual Basic. Si vous sélectionnez Afficher tout, vous obtenez les informations relatives aux deux langages. Quel que soit le langage choisi, les informations significatives pour chacun d'eux (par exemple, des concepts généraux) sont toujours affichées.

  • Pour afficher les options de filtrage sur le langage, cliquez sur le bouton de filtrage ( Language-filtering tool) dans la barre de titre et sélectionnez l'une des options suivantes :
    • C ++

    • Visual Basic

    • Afficher tout

Remarque

  • Une fois que vous avez sélectionné une option de filtrage sur le langage, cette sélection s'applique à toutes les autres pages affichées tant que vous ne modifiez pas le paramétrage.


Touches de raccourci de la Visionneuse de l'aide

Les touches de raccourci permettent d'effectuer certaines tâches dans la Visionneuse de l'aide de BizTalk Server. Le tableau suivant présente ces touches de raccourci.

Remarque

  • Le clavier numérique permet d'obtenir la fonctionnalité non incluse dans la liste pour déplacer le pointeur de la souris à l'aide des Touches souris. Pour plus d'informations sur les touches souris dans l'Aide de Windows 2000 Server, consultez la rubrique « Utilisation du clavier pour déplacer le pointeur de la souris ». Dans l'Aide de Windows 2000 Professionnel, consultez la rubrique « Pour déplacer le pointeur de la souris en utilisant les touches souris ».

Touches de raccourci de la Visionneuse de l'aide

Appuyez sur | Pour
ALT+ESPACE | Afficher le menu Système.
MAJ+F10 Afficher le menu contextuel de la Visionneuse de l'aide.

Remarque

  • Utilisez ce raccourci lorsque le volet des rubriques est actif.
ALT+TAB | Aller et venir entre la Visionneuse de l'aide et les autres fenêtres ouvertes.
ALT+O | Afficher le menu Options.
ALT+O, puis appuyez sur L | Masquer ou afficher le volet de navigation.
CTRL+TAB | Passer à l'onglet suivant dans le volet de navigation.
CTRL+MAJ+TAB | Passer à l'onglet précédent dans le volet de navigation.
HAUT | Remonter d'une rubrique dans la table des matières, l'index ou la liste des résultats de la recherche.
BAS | Descendre d'une rubrique dans la table des matières, l'index ou la liste des résultats de la recherche.
PAGE PRÉCÉDENTE | Remonter d'une page dans la table des matières, l'index ou la liste des résultats de la recherche.
PAGE SUIVANTE | Descendre d'une page dans la table des matières, l'index ou la liste des résultats de la recherche.
F6 | Activer alternativement le volet de navigation et le volet des rubriques.
ALT+O, puis appuyez sur U | Actualiser la rubrique affichée dans le volet des rubriques.
Flèche HAUT ou Flèche BAS | Faire défiler le texte d'une rubrique.
CTRL+ORIGINE | Atteindre le début d'une rubrique.
CTRL+FIN | Atteindre la fin d'une rubrique.
CTRL+A | Mettre en surbrillance l'intégralité du texte affiché dans le volet des rubriques.
ALT+O, puis appuyez sur I | Imprimer une rubrique.
ALT+O, puis appuyez sur P | Retourner à la rubrique affichée précédemment.
ALT+O, puis appuyez sur S | Passer à la rubrique suivante (parmi les rubriques affichées précédemment).
TAB Se déplacer entre des rubriques apparentées

Remarque

  • Utilisez ce raccourci lorsque le volet des rubriques est actif.
ALT+F4 | Fermer Help Viewer.

Touches de raccourci de l'onglet Sommaire

Appuyez sur | Pour
ALT+S | Afficher l'onglet Sommaire.
DROITE | Ouvrir un livre.
GAUCHE | Fermer un livre.
RET.ARR | Retourner au livre ouvert précédemment.
Flèche HAUT ou Flèche BAS | Sélectionner une rubrique.
ENTRÉE | Afficher la rubrique sélectionnée.

Touches de raccourci de l'onglet Index

Appuyez sur | Pour
ALT+I | Afficher l'onglet Index.
Flèche HAUT ou Flèche BAS | Sélectionner un mot clé dans la liste.
ALT+C ou ENTRÉE | Afficher la rubrique associée.

Touches de raccourci de l'onglet Rechercher

Appuyez sur | Pour
ALT+R | Afficher l'onglet Recherche.
ALT+H | Commencer une recherche.
ALT+C ou ENTRÉE | Afficher la rubrique sélectionnée.

Touches de raccourci de l'onglet Favoris

Appuyez sur | Pour
ALT+V | Afficher l'onglet Favoris.
ALT+A | Ajouter une rubrique à la liste Rubriques
ALT+Q Sélectionner une rubrique dans la liste Rubriques

Remarque

  • Utilisez ce raccourci lorsque le volet des rubriques est actif et que vous souhaitez accéder à la liste Rubriques.
ALT+M | Supprimer une rubrique de la liste Rubriques.
ALT+C | Afficher une rubrique de la liste Rubriques.

Voir aussi

Vue d'ensemble de l'aide


Accessibilité pour les personnes atteintes de handicaps

Microsoft s'engage à rendre ses produits plus faciles d'emploi pour tous. Pour plus informations sur les fonctionnalités améliorant l'accessibilité de Microsoft BizTalk Server 2000, voir :

  • Touches de raccourci de la Visionneuse de l'aide

  • Touches de raccourci de la console Administration de BizTalk Server

  • Touches de raccourci de Suivi de documents BizTalk

  • Touches de raccourci du Concepteur d'Orchestration BizTalk

  • Touches de raccourci du Gestionnaire d'échanges BizTalk

  • Touches de raccourci de l'Éditeur BizTalk

  • Touches de raccourci du Mappeur BizTalk

Remarque

  • Pour plus d'informations sur les options d'accessibilité, dans l'aide de Windows 2000 Server, dans le livre Démarrer Windows 2000, voir Accessibilité pour les personnes atteintes de handicaps. Dans l'aide de Windows 2000 Professionnel, voir le chapitre Accessibilité pour des besoins particuliers.


Les Services du Support Technique Microsoft

Le parcours solution

Si vous avez une question ou si vous rencontrez un problème concernant l’utilisation d’un produit Microsoft, nous vous suggérons de :

  • Consulter les rubriques d'aide en ligne ou la documentation du produit.

  • Consulter les fichiers « lisez-moi » fournis avec le jeu de disques ou disquettes de votre produit. Ces fichiers contiennent des informations générales, mises à jour à la date de commercialisation du produit.

  • Visiter le site web du Support Technique de la filiale Microsoft qui dessert votre pays (voir la rubrique Contacts ci-dessous), qui vous propose un ensemble de guides et d’informations techniques toujours à jour et destiné à vous aider à trouver une réponse aux problématiques les plus courantes.

  • Visiter le site web de la filiale Microsoft qui dessert votre pays (voir la rubrique Contacts ci-dessous) ou nous contacter pour identifier l’offre de services de Support qui répond le mieux à vos besoins

Les ressources du service de Support en ligne

L’équipe Support en ligne vous propose de nombreuses ressources d’auto-formation, des guides d’installation et de dépannage, des téléchargements, de la documentation technique ainsi que des groupes de discussion spécialisés qui simplifient les échanges avec d’autres utilisateurs de produits Microsoft.

Vous pourrez ainsi obtenir rapidement et facilement une réponse à la majeure partie de vos questions 24 heures sur 24, 7 jours sur 7.

Visitez le site web du service de Support en ligne de la filiale Microsoft qui dessert votre pays :

  • pour la France : http://www.microsoft.com/france/support/

  • pour le Canada : http://www.microsoft.com/canada/french/support/

  • pour les autres pays, consultez les adresses web indiquées sous la rubrique Contacts.

Les Services de Support Technique

Le Support Premier

Destiné aux grandes entreprises et aux administrations, le Support Premier offre une expertise technique et des services professionnels sur mesure, afin de garantir la meilleure disponibilité des solutions Microsoft. Cette offre homologuée ISO 9002 s’articule autour de quatre types de prestations : une relation technique suivie et personnalisée avec Microsoft ; une prévoyance accrue pour la gestion de vos solutions ; un accès privilégié au savoir-faire de Microsoft et une réactivité permanente.

Les offres Microsoft Support Premier Agréé

Bâties sur le modèle de l'offre Support Premier de Microsoft, les offres de la famille Support Premier Agréé sont spécifiquement conçues pour répondre aux attentes des entreprises possédant entre 200 et 5000 PC. Conjointement délivrées par Microsoft et ses Centres de Support Agréés, les offres Support Premier Agréé s'appuient sur la diversité des compétences et l'expérience de nos partenaires, procurant ainsi des avantages complémentaires à ceux que Microsoft pourrait fournir en intervenant seule.

Le Support Professionnel Microsoft

Que vous soyez un professionnel de l’informatique, un développeur, un revendeur informatique ou un consultant, l’offre de Support Professionnel vous garantit une assistance technique réactive de haut niveau, à votre disposition 24 heures sur 24 en cas d’incident critique. Accessible en ligne ou par téléphone, cette offre de support met à votre disposition un service d’assistance efficace 24 heures sur 24, 7 jours sur 7 en cas de panne bloquante.

L’Assistance Technique facturée à l’incident

Disponible au Canada uniquement, l’Assistance technique facturée à l’incident est accessible du lundi au vendredi de 8 h à 23 h, et le samedi de 10 h à 18 h HNE à l'exception des jours fériés. Composez le ( 1 800 668-7975 ; le paiement de l'assistance technique pour votre incident est effectué par carte de crédit.

Pour plus de renseignements

Les Services d'Information sont à votre écoute afin de vous fournir de plus amples renseignements sur les offres de support technique proposées par Microsoft et ses partenaires. Vous pouvez nous contacter en France au ( 0 825 827 829 code 4488, et au Canada au ( 1 800 563-9048.

Pour les autres pays, consultez les numéros de téléphone indiqués sous la rubrique Contacts.

* Les services de Support Technique de Microsoft sont offerts selon les conditions tarifaires et contractuelles en vigueur et peuvent faire l'objet de modifications. Ce document n’est pas un document contractuel et a uniquement pour objet de vous informer sur le Support Technique qui vous est proposé par Microsoft. Microsoft se réserve le droit d’adapter ou de modifier à tout moment le contenu de ce programme en fonction des évolutions, adaptations ou modifications qui pourraient s’avérer nécessaires.

** Sont exclus les programmes multi-licences, tels que Microsoft Open License et Microsoft Select License, et les Licences Étudiants.

*** Des frais de communication téléphonique peuvent s’appliquer.

Contacts

La liste des pays et des filiales Microsoft offrant un support après-vente pour les versions françaises est indiquée ci-dessous :

Pays | Numéros de téléphone
Belgique | Microsoft NV Téléphone : (32) 2-730-3911 Fax : (32) 2-735-1609 CompuServe : 02-2150530 (GO MSBEN) Support technique (francophone) : (32) 2-513-2268 http://www.microsoft.com/belgium/support/default.asp?lang=2
Canada | Microsoft Canada Co. Téléphone (support technique) : 1 (905) 568-3503 Centre d'information : 1 (800) 563-9048 Tél. support technique (bilingue) : 1 (905) 568-2294 Téléphone texte (TT/TDD) : 1 (905) 568-9641 http://www.microsoft.com/canada/french/support/
France | Microsoft France Téléphone : 0 825 827 829 (0,98 FTTC/min) suivi de 0 et du code 44 88 # Télex : MSPARIS 604322F Fax : (33) 01 64 46 06 60 (htt://www.microsoft.com/france/support/
Luxembourg | Microsoft NV Téléphone : (32) 2-730-3911 Service clients : (32) 2-7303922 CompuServe : (32) 2-2150530 (GO MSBEN) BBS : (32) 2-7350045 (1200/2400/9600 bauds, 8 bits, pas de parité, 1 bit de stop, émulation terminal ANSI) Support technique (francophone) : (32) 2-513-2268 http://www.microsoft.com/belgium/support/default.asp?lang=2
Polynésie française | Voir France
Suisse | Microsoft SA Support technique (francophone) : (41) (22) 738 96 88 Téléphone : (41) (1) 839 61 11 Fax : (41) (1) 831 08 69 Informations : Tél. : 155 59 00 Fax : 064 - 224294 Microsoft Info-Service, Postfach, 8099 Zürich Prix, mises à jour, etc. : 01/839 61 11 CompuServe : 01/273 10 28 (GO MSEURO Microsoft Europe centrale) http://www.microsoft.com/switzerland/fr/support

S'il n'existe pas de filiale Microsoft dans votre pays, veuillez contacter le revendeur auprès duquel vous avez effectué l'achat de votre produit Microsoft ou consulter le site web suivant : http://www.microsoft.com/worldwide .


Didacticiel de BizTalk Server 2000

Approvisionnement automatisé interentreprises

Ce didacticiel vous apprend à configurer Microsoft BizTalk Server 2000 afin de définir et d'exécuter un processus d'approvisionnement automatisé interentreprises.

Ce didacticiel vous explique également comment les composants et les services de BizTalk Server concourent conjointement à l'intégration de processus professionnels asynchrones de longue durée, à la fois au sein d'une même entreprise ou entre différentes entreprises.

Remarque

Le didacticiel BizTalk Server 2000 est également fourni au format Microsoft Word. Pour imprimer le didacticiel, vous devez utiliser cette version. Si Word n'est pas installé sur votre ordinateur, vous pouvez afficher le fichier à l'aide de Microsoft WordPad ou de l'afficheur Microsoft Word 97/2000. Le fichier Tutorial.doc se trouve dans \Program Files\Microsoft BizTalk Server\Tutorial\POtoInvoice\Lab, sur le lecteur où est installé BizTalk Server.

Conditions

Pour pouvoir suivre correctement ce didacticiel, vous devez installer BizTalk Server 2000 et tous les composants nécessaires y étant liés. Pour une liste complète des configurations matérielle et logicielle requises pour BizTalk Server 2000, voir Installation de BizTalk Server 2000.

Scénario

Ce scénario fournit une vue d'ensemble complète des éléments-clés de BizTalk Server 2000. La société ProElectron, S.A. (organisation de l'acheteur) utilise BizTalk Server 2000 pour implémenter un processus d'approvisionnement automatisé interentreprises avec la société Bits, Bytes, & Chips, S.A. (organisation du vendeur).

ProElectron utilise une planification XLANG pour gérer le flux de messages dans le système. Si une requête d'ordre d'achat est inférieure ou égale à 1000 EUR, un ordre d'achat est généré et envoyé à Bits, Bytes, & Chips. Sinon, le processus s'interrompt.

Le système de l'acheteur utilise les services d'Échanges BizTalk pour recevoir et router l'ordre d'achat, le transformer pour le faire correspondre au format de Bits, Bytes, & Chips, puis extraire les données.

Les deux systèmes utilisent également une série de composants auxiliaires qui sont associés à BizTalk Server 2000 pour la réalisation de tâches-clés en matière de traitement des données.

L'illustration suivante correspond à un schéma d'interaction représentant le système d'approvisionnement automatisé interentreprises implémenté par ProElectron et Bits, Bytes, & Chips. Les flèches identifient le flux de données entre les rôles et les entités.

Internet
Application
commande
Facture
Paiement
Bits, Bytes,
& Chips, Inc
Ordre
d'achat
Accord
requête OA
Approbation OA
ProElectron, Inc
Requête d'achat
Utilisateur
Approbation
OA
Finance
Fournisseur

Important

  • Pour les besoins de ce scénario, les systèmes de l'acheteur et du vendeur sont tous deux configurés sur une installation monoposte de BizTalk Server 2000.

L'illustration suivante montre le déplacement des documents à travers les deux systèmes. Vous pouvez également y observer l'interaction entre la planification XLANG, les services d'échanges BizTalk et les composants auxiliaires. Cette illustration constitue une référence utile qu'il serait judicieux d'imprimer et d'avoir à vos côtés tout au long des modules de ce didacticiel.

Flux de données
Envoyer
Paiement
Recevoir Facture
Décision
Req OA
>$1000
Fin
Recevoir
Req OA
Planification XLANG
Fonction réception fichier
Rép. fichier acheteur
Composant WSC
Fichier ASP
File d'attente de mess.
Oui (Refuser)
Non
(Approuver)
Composant de script
Port d'échanges
Port d'échanges
Canal de la facture
Canal de l'OA
Canal
Port vers ProElectron
via HTTP
Port vers Bits, Bytes,
& Chips via AIC
Port vers Bits, Bytes, & Chips via Local File
POtoINVAIC
SubmitProElectronPO
Port vers Bits, Bytes,
& Chips via HTTP
Canal de la
facture en paiement
Canal de
POReq en OA
Canal
Échanges BizTalk
Message Queuing
Action
Port
Données
Données
ExecuteTutorial
Fonction Recevoir requête OA chez ProElectron
DropInvoicetoMSMQ
ReceiveInvoice
PORequestApproval
ReceivePOReq
Message Queuing
File d'attente de mess.
Application
Req OA
Req OA
Démarrer
Système de l'acheteur
Services d'échanges BizTalk
Arrêter
AIC
OA pour Facture
Rép. fic. vendeur
Paiement
Vendeur
Acheteur
Paiement
Facture
Remarque : les flèches de direction indiquent le flux de données.
Facture
Facture
Mappage
Mappage
OA
OA
OA
OA
Fichier ASP
Système du vendeur
Orchestration BizTalk

Contenu

Module 1 : modélisation des processus professionnels

Ce module vous apprend comment procéder pour :

  • utiliser le Concepteur d'Orchestration BizTalk pour créer un schéma de planification XLANG modélisant les processus d'approvisionnement de ProElectron (pour plus d'informations, voir Conception des orchestrations BizTalk ;

  • compiler le schéma de planification XLANG en une planification XLANG (pour plus d'informations, voir Compilation d'un schéma de planification XLANG dans une planification XLANG) ;

  • exécuter la planification XLANG afin d'observer le déplacement du message au sein du système de l'acheteur.

Module 2 : création de spécifications et de mappages

Ce module vous apprend comment procéder pour :

  • utiliser l'Éditeur BizTalk pour créer des spécifications de documents (pour plus d'informations, voir Création et validation de spécifications) ;

  • utiliser le Mappeur BizTalk pour créer des mappages (pour plus d'informations, voir Création de nouveaux mappages).

Module 3 : configuration des services d'Échanges BizTalk

Ce module vous apprend comment procéder pour :

  • utiliser le Gestionnaire d'échanges BizTalk pour configurer les services d'Échanges BizTalk pour Bits, Bytes, & Chips (pour plus d'informations, voir Utilisation du Gestionnaire d'échanges BizTalk ;

  • utiliser l'Administration de BizTalk Server pour créer une fonction de réception de fichier pour Bits, Bytes, & Chips (pour plus d'informations, voir Ajout d'une fonction de réception de fichier).

Module 4 : clôture de la planification XLANG

Ce module vous apprend comment procéder pour :

  • implémenter un port dans le schéma de planification XLANG commencé au module 2, via une implémentation d'Échanges BizTalk. Pour plus d'informations sur les différences entre les ports et les ports de messagerie, voir Description des implémentations de ports et Description des ports d'échanges.

  • terminer le schéma de planification XLANG et le compiler en une planification XLANG ;

  • exécuter la planification pour percevoir le déplacement complet des messages entre les systèmes de l'acheteur et du vendeur.

Raccourcis

Grâce aux raccourcis, vous pouvez économiser votre temps et votre énergie en utilisant une planification XLANG, une spécification de document, un mappage ou un script de configuration existants. L'utilisation de raccourcis vous permet de passer à des sections ultérieures de ce didacticiel.

Pour utiliser les raccourcis, les composants doivent être installés sur le lecteur C.

Passez à Installation préliminaire.


Installation préliminaire

Avant de commencer le didacticiel, vous devez créer les éléments suivants :

  • un dossier contenant quatre sous-dossiers ;

  • deux dossiers de sites Web locaux contenant des fichiers ASP ;

  • deux files d'attente de messages pour le système de l'acheteur.

Passez à Création des dossiers.


Création des dossiers

Cette procédure consiste à créer un dossier contenant quatre sous-dossiers. Parmi ces sous-dossiers, deux servent d'emplacements pour les messages à mesure que ceux-ci entrent dans les systèmes de l'acheteur et du vendeur et en sortent. Les deux autres constituent des dossiers de contenu pour les sites Web de l'acheteur et du vendeur.

Pour créer les dossiers

  1. Dans l'Explorateur Windows, accédez au répertoire racine de votre lecteur C:\.

    Attention

    • Vous devez créer les dossiers suivants sur votre lecteur C:\.
  2. Créez un nouveau dossier sur la racine de votre lecteur C:\. Appelez ce dossier TutorialFiles.

  3. Cliquez sur le nouveau dossier dénommé TutorialFiles et créez quatre sous-dossiers portant les noms suivants :
    • Buyer

    • Seller

    • SubmitPO

    • InvoiceToQueue

Passez à Copie des fichiers.


Copie des fichiers

Dans cette procédure, vous copiez les fichiers nécessaires pour ce didacticiel.

  1. Sur le lecteur où est installé BizTalk Server, accédez au dossier \Program Files\Microsoft BizTalk Server\Tutorial\DocSpecsandMaps et copiez le fichier POReqtoPO.xml.

  2. Collez le fichier dans le dossier \Program Files\Microsoft BizTalk Server\BizTalkServerRepository\Maps\Microsoft.

  3. Utilisez le tableau suivant pour copier et coller des fichiers supplémentaires dans les sous-dossiers du dossier TutorialFiles.
    Copier à partir de : Coller dans :
    \Program Files\Microsoft BizTalk Server\Tutorial\Components\SubmitPO\Solution\SubmitProElectronPO.asp | C:\TutorialFiles\SubmitPO
    \Program Files\Microsoft BizTalk Server\Tutorial\Components\InvoicetoQueue\Solution\DropInvoicetoMSMQ.asp | C:\ TutorialFiles \InvoiceToQueue
    \Program Files\Microsoft BizTalk Server\Tutorial\Components\InvoicetoQueue\Solution\Global.asa | C:\ TutorialFiles \ InvoiceToQueue

Passez à Création des dossiers de sites Web locaux.


Création des dossiers de sites Web locaux

Cette procédure consiste à créer deux répertoires virtuels. Le premier répertoire simule le site Web de l'acheteur qui reçoit les factures. Le second répertoire simule le site Web du vendeur qui reçoit les ordres d'achat.

  1. Dans le menu Démarrer, pointez sur Paramètres, puis cliquez sur Panneau de configuration.

  2. Double-cliquez sur Outils d'administration.

  3. Double-cliquez sur Gestion de l'ordinateur.

    La console Gestion de l'ordinateur s'affiche.

  4. Dans l'arborescence de la console Gestion de l'ordinateur, développez Services et applications, développez Services Internet (IIS), puis cliquez sur Site Web par défaut.

  5. Dans le menu Action, pointez sur Nouveau, puis cliquez sur Répertoire virtuel.

    L'Assistant Création de répertoire virtuel s'ouvre.

  6. Sur la page Assistant Création de répertoire virtuel, cliquez sur Suivant.

  7. Sur la page Alias du répertoire virtuel, dans la zone Alias, tapez SubmitPO, puis cliquez sur Suivant.

  8. Sur la page Répertoire de contenu du site Web, cliquez sur Parcourir.

  9. Accédez à C:\TutorialFiles\SubmitPO, cliquez sur OK, puis sur Suivant.

  10. Sur la page Autorisations d'accès, cliquez sur Suivant.

  11. Cliquez sur Terminer pour fermer l'Assistant Création de répertoire virtuel.

  12. Dans l'arborescence de la console Gestion de l'ordinateur, cliquez sur Site Web par défaut.

  13. Pour créer le dossier simulant le site Web de l'acheteur, répétez les étapes 5 à 11, avec les variations suivantes :
    • À l'étape 7, dans la zone Alias, tapez InvoiceToQueue.

    • À l'étape 9, accédez à C:\TutorialFiles\InvoiceToQueue.

Votre console Gestion de l'ordinateur doit apparaître comme dans l'illustration suivante.

Cliquez sur l'image pour l'agrandir ou la réduire.

Console Gestion de l'ordinateur

  14. Fermez la console Gestion de l'ordinateur.

Passez à Création des files d'attente de messages.


Création des files d'attente de messages

Cette procédure consiste à créer deux files d'attente de messages afin de permettre au système de l'acheteur d'envoyer et de recevoir des messages.

Remarque

Pour que cette procédure puisse être exécutée, Message Queuing doit être installé. Pour obtenir des instructions sur l'installation de Message Queuing, voir Installation de Message Queuing

Pour créer les files d'attente de messages

  1. Dans le menu Démarrer, pointez sur Paramètres, puis cliquez sur Panneau de configuration.

  2. Double-cliquez sur Outils d'administration.

  3. Double-cliquez sur Gestion de l'ordinateur.

    La console Gestion de l'ordinateur s'affiche.

  4. Dans la console Gestion de l'ordinateur, développez Services et applications, développez Message Queuing, puis cliquez sur Files d'attente privées.

  5. Dans le menu Action, pointez sur Nouveau, puis cliquez sur File d'attente privée.

    La boîte de dialogue Nom de file d'attente s'affiche.

  6. Dans la zone Nom, tapez ReceivePoReq.

  7. Activez la case à cocher Transactionnel, puis cliquez sur OK.

  8. Pour créer la seconde file d'attente de messages, répétez les étapes 5 à 7, avec la variation suivante :
    • À l'étape 6, dans la zone Nom, tapez ReceiveInvoice.

Votre console Gestion de l'ordinateur doit apparaître comme dans l'illustration suivante.

Cliquez sur l'image pour l'agrandir ou la réduire.

Console Gestion de l'ordinateur

  9. Fermez la console Gestion de l'ordinateur.

Passez à Installation des composants auxiliaires.


Installation des composants auxiliaires

Cette procédure consiste en l'installation des composants auxiliaires suivants.

  • Vous installez sur le système de l'acheteur un composant de script Windows (WSC), que vous utilisez pour implémenter un port vers une planification XLANG, et qui accepte le statut d'accord ou de refus pour une requête d'ordre d'achat de la planification XLANG.

  • Vous installez sur le système du vendeur un composant d'intégration de l'application (AIC - Application Integration Component), que vous utilisez pour générer une facture basée sur les données de l'ordre d'achat de l'acheteur.

    Attention

    • Si ces composants ont été précédemment installés sur votre ordinateur, vous devez tout d'abord les désinstaller. Pour désinstaller les composants, accédez à Désinstallation des composants auxiliaires.

Pour installer les composants auxiliaires

  1. Sur le lecteur où est installé BizTalk Server, accédez au dossier \Program Files\Microsoft BizTalk Server\Tutorial\Setup.

  2. Double-cliquez sur Install_POtoInvoice.vbs.

    Un message indiquant que le composant a été installé correctement s'affiche.

  3. Accédez au dossier \Program Files\Microsoft BizTalk Server\Tutorial\Components\POReqApproval\Solution et cliquez sur PORequestApproval.wsc.

  4. Dans le menu Fichier, cliquez sur Inscrire.

    Un message indiquant que le composant a été inscrit correctement s'affiche.

Passez au Module 1 : modélisation des processus professionnels.


Désinstallation des composants auxiliaires

Attention

N'utilisez cette procédure que si vous supprimez une installation précédente des composants.

  1. Pour le composant POtoInvoice, accédez à \Program Files\Microsoft BizTalk Server\Tutorial\Setup sur le lecteur où est installé BizTalk Server.

  2. Double-cliquez sur Remove_POtoInvoice.vbs.

    Un message indiquant que le composant a été correctement désinstallé s'affiche.

  3. Pour le composant de script Windows, accédez au dossier \Program Files\Microsoft BizTalk Server\Tutorial\Components\POReqApproval\Solution et cliquez sur PORequestApproval.wsc.

  4. Dans le menu Fichier, cliquez sur Désinscrire.

    Un message indiquant que l'inscription du composant a été correctement supprimée s'affiche.

Pour réinstaller les composants, accédez à Installation des composants auxiliaires.


Module 1 : modélisation des processus professionnels

Dans ce module, vous utilisez le Concepteur d'Orchestration BizTalk pour créer un schéma de planification XLANG décrivant un processus d'approvisionnement automatisé. Vous compilez ensuite le schéma de planification XLANG en une planification XLANG exécutable gérant le flux de messages pour le système de l'acheteur.

Objectifs

  • Créer un schéma de planification XLANG décrivant le processus d'approvisionnement automatisé. Pour plus d'informations, voir Création de schémas de planification XLANG.

  • Connecter les actions dans une séquence logique décrivant les processus professionnels. Pour plus d'informations, voir Connexion de Formes.

  • Implémenter les processus professionnels en connectant des actions à des ports. Pour plus d'informations, voir Établissement du flux de communication entre une action et un port.

  • Ajouter une règle aux processus professionnels en écrivant une expression de script. Pour plus d'informations, voir Conception de règles.

  • Définir le flux de données pour les messages. Pour plus d'informations, voir Formes Communication.

  • Enregistrer le schéma de planification XLANG et le compiler en une planification XLANG. Pour plus d'informations, voir Compilation des planifications XLANG.

  • Exécuter la planification XLANG pour traiter le message dans BizTalk Server. Pour plus d'informations, voir Exécution des planifications XLANG.

Passez à Création de la planification XLANG pour l'acheteur.

Voir aussi

Conception des orchestrations BizTalk


Création de la planification XLANG pour l'acheteur

Cette procédure consiste à modéliser les processus professionnels pour l'acheteur et à créer une planification XLANG.

Pour créer la planification XLANG, passez à Création des actions de l'acheteur.

Raccourci

Pour utiliser la planification XLANG existante, passez directement à Exécution de la planification XLANG.


Création des actions de l'acheteur

  1. Dans le menu Démarrer, pointez sur Programmes, pointez sur Microsoft BizTalk Server 2000, puis cliquez sur Concepteur d'Orchestration BizTalk.

  2. Sur la page Processus professionnel, faites glisser la forme Action à partir du stencil du diagramme de flux à gauche de la barre de séparation. Positionnez la forme directement sous la forme Début.

  3. Cliquez avec le bouton droit sur la forme Action 1, puis cliquez sur Propriétés.

    La boîte de dialogue Propriétés de l'action s'affiche.

  4. Dans la zone Nom, tapez Receive PO Request (Recevoir la requête d'ordre d'achat), puis cliquez sur OK.

    Attention

    • Pour que ce scénario fonctionne correctement, vous devez respecter exactement la saisie des noms indiquée. Les composants du didacticiel utilisent ces noms.
  5. Sur la page Processus professionnel, faites glisser la forme Décision à partir du stencil du diagramme de flux à gauche de la barre de séparation. Positionnez cette forme sous l'action Receive PO Request (Recevoir la requête d'ordre d'achat).

  6. Cliquez avec le bouton droit sur la forme Décision, puis cliquez sur Ajouter une règle.

    La boîte de dialogue Propriétés de la règle s'affiche.

  7. Dans la zone Nom de règle, tapez Denied (Refusé), puis cliquez sur OK.

    Plus loin dans ce module, vous ajouterez une expression de script implémentant la règle de décision, après avoir lié la forme Décision au composant de script, qui fournit les noms de message et de champ.

  8. Répétez les étapes 2 à 4 pour créer les trois actions suivantes :
    • Positionnez une seconde forme Action à la droite de la forme Décision. Appelez cette action Send Denial (Envoyer le refus).

    • Positionnez une troisième forme Action en-dessous de la forme Décision. Appelez cette action Send Approval (Envoyer l'approbation).

    • Positionnez une quatrième forme Action sous l'action Send Approval (Envoyer l'approbation). Appelez cette action Write PO Request to File (Écrire l'ordre d'achat sur le fichier).
  9. Sur la page Processus professionnels, faites glisser la forme Fin à partir du stencil du diagramme de flux à gauche de la barre de séparation. Positionnez la forme en dessous de l'action Send Denial (Envoyer le refus).

    Si la requête d'ordre d'achat n'est pas accordée, la planification XLANG affiche un message de refus et prend fin.

  10. Sur la page Processus professionnels, faites glisser la forme Fin à partir du stencil du diagramme de flux à gauche de la barre de séparation. Positionnez la forme en dessous de l'action Write PO Request to File (Écrire l'ordre d'achat sur le fichier).

    Si la requête d'ordre d'achat est accordée, la planification XLANG écrit la requête dans un répertoire de fichiers, affiche un message d'accord et prend fin.

Passez à Connexion des actions de l'acheteur dans une séquence.


Connexion des actions de l'acheteur dans une séquence

  1. Cliquez sur la forme Début afin de mettre en évidence les poignées de contrôle.

    Faites glisser la poignée de contrôle inférieure vers le point de connexion supérieur de l'action Receive PO Request (Recevoir la requête d'ordre d'achat).

    L'action Receive PO Request (Recevoir la requête d'ordre d'achat) représente le début du processus professionnel. Lorsqu'une requête d'ordre d'achat est reçue, la planification XLANG démarre.

    Remarques

    • Une poignée de contrôle est matérialisée par un cadre vert lorsqu'une forme est sélectionnée. Vous pouvez faire glisser les poignées de contrôle pour la connexion à une action.

    • Un point de connexion est représenté par un X bleu sur une forme.

    • Les points de connexion situés sur le côté d'une forme Action ne sont utilisés que pour la connexion aux ports. Ils ne servent pas pour la connexion aux autres formes Action.
  2. Répétez l'étape 1 pour créer une connexion aux actions suivantes :
    • Connectez l'action Receive PO Request (Recevoir la requête d'ordre d'achat) à la forme Décision.
  3. Sélectionnez la règle Denied (Refusé) dans la forme Décision et faites glisser la poignée de contrôle de droite de la règle Denied (Refusé) vers le point de connexion supérieur de l'action Send Denial (Envoyer le refus).

  4. Sélectionnez la règle Sinon de la forme Décision et faites glisser la poignée de contrôle de gauche de la règle Sinon vers le point de connexion supérieur de l'action Send Approval (Envoyer l'approbation).

    Remarque

    • Vous pouvez connecter les règles de la forme Décision aux actions Send Approval (Envoyer l'approbation) et Send Denial (Envoyer le refus) à partir de la poignée de contrôle de droite ou de gauche.
  5. Connectez l'action Send Approval (Envoyer l'approbation) à l'action Write PO Request to File (Écrire l'ordre d'achat sur le fichier).

  6. Connectez l'action Write PO Request to File (Écrire l'ordre d'achat sur le fichier) à la forme Fin située en dessous.

  7. Connectez l'action Send Denial (Envoyer le refus) à la forme Fin située en dessous.

  8. Dans le menu Fichier, cliquez sur Enregistrer sous.

    La boîte de dialogue Enregistrer un schéma de planification XLANG sous s'affiche.

  9. Accédez au dossier \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Lab sur le lecteur où est installé BizTalk Server.

  10. Dans la zone Nom de fichier, tapez Buyer1(Acheteur1) et cliquez sur Enregistrer.

Le schéma de planification XLANG que vous avez créé et enregistré doit apparaître comme dans l'illustration suivante.

Cliquez sur l'image pour l'agrandir ou la réduire.

Schéma de planification XLANG

Passez à Implémentation d'un port à l'aide de Message Queuing pour recevoir une requête d'ordre d'achat.


Implémentation d'un port à l'aide de Message Queuing pour recevoir une requête d'ordre d'achat

Le service est configuré pour contrôler une file d'attente de messages d'une requête d'ordre d'achat. Dans ce cas, la planification XLANG commence le traitement. Pour plus d'informations sur l'utilisation des ports et des ports d'échanges, voir Intégration des services BizTalk.

Pour implémenter le port

  1. Sur la page Processus professionnel, faites glisser la forme Message Queuing du stencil Implémentation vers la droite de la barre de séparation. Positionnez la forme Message Queuing de sorte qu'elle soit alignée horizontalement par rapport à l'action Receive PO Request (Recevoir la requête d'ordre d'achat).

    L'Assistant Liaison de Message Queuing s'ouvre.

  2. Sur la première page de l'Assistant Liaison de Message Queuing, vérifiez que Créer un port est sélectionné.

  3. Dans la zone Créer un port, tapez ReceivePORequest (Recevoir la requête d'ordre d'achat) et cliquez sur Suivant.

  4. Sur la page Informations sur la file d'attente statique ou dynamique, vérifiez que File d'attente statique est sélectionné et cliquez sur Suivant.

  5. Sur la page Informations sur la file d'attente, cliquez sur Utiliser une file d'attente connue pour toutes les instances.

  6. Dans la zone Entrez le nom de la file d'attente, tapez .\private$\ReceivePOReq et cliquez sur Suivant.

  7. Sur la page Propriétés avancées du port, cliquez sur Terminer.

    Le port ReceivePORequest et l'implémentation Message Queuing associés apparaissent sur la page Processus professionnel.

Passez à Création du flux de communication pour l'action Recevoir requête OA.


Création du flux de communication pour l'action Recevoir requête OA

  1. Sélectionnez l'action Receive PO Request (Recevoir la requête d'ordre d'achat) et faites glisser la poignée de contrôle située à sa droite vers le point de connexion de gauche du port ReceivePORequest.

    L'Assistant Communication XML s'ouvre.

  2. Sur la page Assistant Communication XML, cliquez sur Recevoir, puis sur Suivant.

  3. Sur la page Informations sur le message, vérifiez que l'option Créer un message est sélectionnée.

  4. Dans la zone Nom du message, tapez POReq et cliquez sur Suivant.

  5. Sur la page Informations sur l'interprétation XML, vérifiez que Recevoir les messages XML de la file d'attente est sélectionné et cliquez sur Suivant.

  6. Sur la page Informations sur les types de message, dans la zone Type du message, tapez POReq et cliquez sur Suivant.

  7. Dans la page Informations sur la spécification du message, cliquez sur Parcourir.

    La boîte de dialogue Rechercher une spécification apparaît.

  8. Accédez au dossier \Program Files\Microsoft BizTalk Server\Tutorial\DocSpecsandMaps sur le lecteur où est installé BizTalk Server.

  9. Cliquez sur PoReq.xml puis sur Ouvrir.

  10. Cliquez sur Ajouter.

    La boîte de dialogue Sélection d'un champ apparaît.

  11. Dans la zone Sélectionner un noeud, développez Total, cliquez sur POTtl, puis sur OK.

    Dans la zone Champs de message, POTtl doit figurer dans la liste des champs de message.

  12. Cliquez sur Terminer.

Après avoir implémenté le port et créé le flux de communication, le schéma de planification XLANG doit apparaître comme dans l'illustration suivante.

Cliquez sur l'image pour l'agrandir ou la réduire.

Schéma de planification XLANG

Passez à Implémentation d'un port à l'aide d'un composant de script.


Implémentation d'un port à l'aide d'un composant de script

La planification XLANG transmet la valeur du champ total de la requête d'ordre d'achat à la forme Décision. L'expression de script de la règle de décision dévie le chemin de la planification et envoie le message approprié à l'implémentation de port qui utilise un composant de script Windows, basé sur le total de la requête d'ordre d'achat.

Pour implémenter le port

  1. Dans le stencil Implémentation, faites glisser la forme Composant de script vers la droite de la barre de séparation qui divise les deux côtés du schéma. Positionnez la forme de sorte qu'elle soit alignée horizontalement par rapport à la forme Décision.

    L'Assistant Liaison des composants de script s'ouvre.

  2. Sur la page Assistant Liaison de composants de script, dans la zone Créer un port, tapez ApprovalComponent (Composant d'approbation) et cliquez sur Suivant.

  3. Sur la page Communication statique ou dynamique, vérifiez que Statique est sélectionné et cliquez sur Suivant.

  4. Sur la page Sélectionnez le fichier de script, cliquez sur Parcourir.

  5. Accédez au dossier \Program Files\Microsoft BizTalk Server\Tutorial\Components\POReqApproval\Solution sur le lecteur où est installé BizTalk Server.

  6. Cliquez sur PORequestApproval.wsc, sur Ouvrir, puis sur Suivant.

  7. Sur la page Informations sur l'instanciation du composant, vérifiez que Utiliser Prog ID "BTSTutorial.PORequestApproval" est sélectionné et cliquez sur Suivant.

  8. Sur la page Informations sur la méthode, cliquez sur Sélectionner Tout puis sur Suivant.

  9. Sur la page Propriétés avancées du port, cliquez sur Terminer.

Passez à Définition des propriétés de message pour le composant de script.


Définition des propriétés de message pour le composant de script

  1. Sélectionnez l'action Send Denial (Envoyer le refus) et faites glisser la poignée de contrôle située à droite vers le port Composant de script Windows ApprovalComponent (Composant d'approbation).

    L'Assistant Communication de méthodes s'ouvre.

  2. Sur la page Assistant Communication de méthodes, vérifiez que l'option Lancer un appel de méthode synchrone est sélectionnée, puis cliquez sur Suivant.

  3. Sur la page Informations sur le message, vérifiez que Créer un message est sélectionné et cliquez sur Suivant.

  4. Sur la page Informations sur la spécification du message, dans la liste Méthodes, cliquez sur Send Denial (Envoyer le refus) et cliquez sur Terminer.

  5. Sélectionnez l'action Send Approval (Envoyer l'approbation) et faites glisser la poignée de contrôle située à droite de l'action Send Approval (Envoyer l'approbation) vers le port ApprovalComponent (Composant d'approbation).

    L'Assistant Communication de méthodes s'ouvre.

  6. Sur la page Assistant Communication de méthodes, vérifiez que l'option Lancer un appel de méthode synchrone est sélectionnée, puis cliquez sur Suivant.

  7. Sur la page Informations sur le message, vérifiez que Créer un message est sélectionné et cliquez sur Suivant.

  8. Sur la page Informations sur la spécification du message, dans la liste Méthodes, cliquez sur Send Denial (Envoyer le refus) et cliquez sur Terminer.

  9. Sélectionnez l'action Write PO Request to File (Écrire l'ordre d'achat sur le fichier) et faites glisser la poignée de contrôle située à droite de l'action Write PO Request to File (Écrire l'ordre d'achat sur le fichier) vers le port ApprovalComponent (Composant d'approbation).

    L'Assistant Communication de méthodes s'ouvre.

  10. Sur la page Assistant Communication de méthodes, vérifiez que l'option Lancer un appel de méthode synchrone est sélectionnée, puis cliquez sur Suivant.

  11. Sur la page Informations sur le message, vérifiez que Créer un message est sélectionné et cliquez sur Suivant.

  12. Sur la page Informations sur la spécification du message, dans la zone Méthodes, vérifiez que WriteToFile est sélectionné et cliquez sur Terminer.

Passez à Écriture d'une expression de script pour la règle de décision.


Écriture d'une expression de script pour la règle de décision

La règle de décision du refus contient des propriétés qui définissent le comportement de la forme. L'expression de script fait référence aux données contenues dans des messages, et prend la valeur TRUE ou FALSE. Elle définit également la logique et les noms de variable utilisés par la forme Décision.

Si le total de la requête d'ordre d'achat est supérieur à 1000 EUR :

  • la forme Décision envoie un message de refus au port ;

  • un message informe l'utilisateur du refus ;

  • la planification XLANG prend fin.

Si le total de la requête d'ordre d'achat est inférieur ou égal à 1000 EUR :

  • la forme Décision envoie un message d'accord au composant de script ;

  • le composant de script affiche un message qui informe l'utilisateur de l'accord ;

  • le composant de script écrit le message de la requête d'ordre d'achat dans un répertoire de fichiers local ;

  • la planification XLANG prend fin.

Pour écrire l'expression de script

  1. Cliquez sur l'onglet Données situé en bas de la page.

    La page Données apparaît.

  2. Affichez le message POReq pour trouver le nom de champ.

    Pour écrire l'expression de script, il faut indiquer le nom du message et le nom du champ. Dans ce cas, le nom du message est POReq et celui du champ est POTtl.

  3. Cliquez sur l'onglet Processus professionnel situé en bas de la page.

    La page Processus professionnel apparaît.

  4. Cliquez avec le bouton droit sur la forme Décision et cliquez sur Propriétés.

    La boîte de dialogue Propriétés de la décision apparaît.

  5. Vérifiez que Denied (Refusé) est sélectionné et cliquez sur Modifier.

    La boîte de dialogue Propriétés de la règle s'affiche.

  6. Dans la zone Expression de script, tapez POReq.POTtl > 1000.

    Cela signifie que si le champ total de la requête d'ordre d'achat est supérieur à 1000 EUR, la requête est refusée.

  7. Cliquez sur OK pour fermer la boîte de dialogue Propriétés de la règle, puis de nouveau sur OK pour fermer la boîte de dialogue Propriétés de la décision.

Le schéma de planification XLANG doit apparaître comme dans l'illustration suivante.

Cliquez sur l'image pour l'agrandir ou la réduire.

Schéma de planification XLANG

Passez à Définition du flux de données.


Définition du flux de données

Pour définir le flux de données dans le processus professionnel, vous créez des connexions entre les champs des formes Message de la page Données.

Pour définir le flux de données

  1. Cliquez sur l'onglet Données situé en bas de la page.

    La page Données apparaît.

  2. Dans le message POReq, cliquez sur le champ Document et faites glisser la poignée de contrôle située à droite vers un point de connexion du champ Document du message SendDenial_in.

  3. Répétez l'étape 2 en cliquant sur le champ Document et en faisant glisser la poignée de contrôle sélectionnée à droite de la zone POReq vers un point de connexion des champs suivants :
    • le champ Document de la zone SendApproval_in.

    • le champ Document de la zone WriteToFile_in.

Remarque

  • Cliquez sur le champ Document du message POReq avant de faire glisser la poignée de contrôle vers les autres champs.

Une fois complétée, la page Données doit apparaître comme dans l'illustration suivante.

Cliquez sur l'image pour l'agrandir ou la réduire.

Page de données

Passez à Enregistrement du schéma de planification XLANG.


Enregistrement du schéma de planification XLANG

  • Dans le menu Fichier, cliquez sur Enregistrer Buyer1.skv.

Passez à Compilation de la planification XLANG.


Compilation de la planification XLANG

  1. Dans le menu Fichier, cliquez sur Créer XLANG Buyer1.skx.

    La boîte de dialogue Enregistrer la planification XLANG vers apparaît.

  2. Vérifiez que la planification XLANG a été enregistrée dans le dossier \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Lab sur le lecteur où est installé BizTalk Server et cliquez sur Enregistrer.

  3. Dans le menu Fichier, cliquez sur Quitter pour fermer le Concepteur d'Orchestration BizTalk.

Passez à Exécution de la planification XLANG.


Exécution de la planification XLANG

Cette procédure consiste à exécuter deux fois la planification XLANG pour afficher l'accord et le refus de requêtes d'ordre d'achat.

Pour exécuter la planification XLANG :

  1. Accédez au dossier \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Solution sur le lecteur où est installé BizTalk Server.

  2. Double-cliquez sur ExecuteTutorial.exe. Cette application permet d'activer la planification XLANG à l'aide d'un moniker.

    L'application ExecuteTutorial s'ouvre.

  3. Cliquez sur Browse for Schedule.

Raccourci

Si vous utilisez la planification XLANG existante, recherchez le dossier \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Solution, puis passez à l'étape 5.

  1. Si vous avez créé la planification XLANG Buyer1(Acheteur1), accédez au dossier \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Lab sur le lecteur où est installé BizTalk Server.

  2. Cliquez sur le fichier XLANG des planifications Buyer1.skx puis sur Ouvrir.

  3. Cliquez sur Browse for Data File et accédez au dossier \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\SampleData sur le lecteur où est installé BizTalk Server.

  4. Cliquez sur POReqAccept.xml, puis cliquez sur Ouvrir.

  5. Cliquez sur Start XLANG Schedule.

    Dans la mesure où le total est inférieur à 1000 dollars, la demande d'ordre d'achat est approuvée. Un message s'affiche pour indiquer que l'application a transmis les données au moteur de XLANG Scheduler. À ce stade, l'application est terminée. Un second message vous informe que la demande d'ordre d'achat a été approuvée. Cliquez sur OK pour fermer les boîtes de dialogue.

  6. Cliquez sur End (Fin) pour fermer l'application ExecuteTutorial.

    Important

    • Si vous rencontrez une erreur d'automatisation lors de l'exécution de l'application, assurez-vous que vous avez correctement configuré la file d'attente privée et que son nom est correct.
  7. Accédez au dossier C:\TutorialFiles\Buyer.

    Le nom de fichier est POReqXXXXX.xml, où XXXXX représente un ensemble unique de nombres. Double-cliquez sur le fichier pour l'ouvrir dans Microsoft Internet Explorer. Il s'agit d'une copie du fichier de la requête d'ordre d'achat que l'application a placé dans la file d'attente de messages. Après avoir affiché ce fichier, supprimez-le.

  8. Répétez les étapes 1 à 5 pour réexécuter l'application ExecuteTutorial.

  9. Cliquez sur Browse for Data File et accédez au dossier \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\SampleData sur le lecteur où est installé BizTalk Server.

  10. Cliquez sur POReqDeny.xml puis sur Ouvrir.

  11. Cliquez sur Start XLANG Schedule.

    Étant donné que son total dépasse 1000 EUR, la requête d'ordre d'achat est refusée. Un message s'affiche pour indiquer que l'application est terminée. Un second message indique que le refus du document a été reçu. Cliquez sur OK pour fermer les boîtes de dialogue.

  12. Cliquez sur End (Fin) pour fermer l'application ExecuteTutorial.

Le schéma ci-dessous illustre le flux de données lors de l'exécution de la planification XLANG.

Flux de données
Envoyer
Paiement
Recevoir Facture
Décision
Req OA
>$1000
Fin
Recevoir
Req OA
Planification XLANG
Fonction réception fichier
Répertoire fichier acheteur
Composant WSC
Fichier ASP
File d'attente de mess.
Oui (Refuser)
Non
(Approuver)
Composant de script
Port d'échanges
Port d'échanges
Canal de la facture
Canal de l'OA
Canal
Port vers ProElectron
via HTTP
Port vers Bits, Bytes,
& Chips via AIC
Port vers Bits, Bytes, & Chips via Local File
POtoINVAIC
SubmitProElectronPO
Port vers Bits, Bytes,
& Chips via HTTP
Canal de la
facture en paiement
Canal de
POReq en OA
Canal
Échanges BizTalk
File d'attente de mess.
Action
Port
Données
Données
ExecuteTutorial
Fonction Recevoir requête OA chez ProElectron
DropInvoicetoMSMQ
ReceiveInvoice
PORequestApproval
ReceivePOReq
File d'attente de mess.
File d'attente de mess.
Application
Req OA
Req OA
Démarrer
Système de l'acheteur
Services d'échanges BizTalk
Arrêter
AIC
OA pour Facture
Répertoire du fichier
du vendeur
Paiement
Vendeur
Acheteur
Paiement
Facture
Remarque : les flèches de direction indiquent le flux de données.
Facture
Facture
Mappage
Mappage
OA
OA
OA
OA
Fichier ASP
Système du vendeur
Orchestration BizTalk

Passez à Module 1 - Résumé.


Résumé du module 1

Dans ce module, vous avez accompli les tâches suivantes :

  • créé le schéma de planification XLANG qui décrivait le processus d'approvisionnement automatisé. Pour plus d'informations, voir Création de schémas de planification XLANG.

  • connecté les actions dans une séquence logique qui décrivait le processus professionnel. Pour plus d'informations, voir Connexion des formes.

  • implémenté le processus professionnel en connectant des actions aux ports. Pour plus d'informations, voir Établissement du flux de communication entre une action et un port.

  • ajouté une règle au processus professionnel en écrivant une expression de script. Pour plus d'informations, voir Conception de règles.

  • défini le flux de données des messages. Pour plus d'informations, voir Formes Communication.

  • enregistré le schéma de planification XLANG et compiler le schéma en planification XLANG. Pour plus d'informations, voir Compilation des planifications XLANG.

  • exécuté la planification XLANG à deux reprises pour traiter la requête d'ordre d'achat par l'intermédiaire de BizTalk Server, en observant l'accord et le refus. Pour plus d'informations, voir Exécution des planifications XLANG.

Les zones mises en surbrillance du schéma ci-après illustrent les procédures que vous avez effectuées dans ce module.

Envoyer
Paiement
Recevoir Facture
Décision
Req OA
>$1000
Fin
Recevoir
Req OA
Planification XLANG
Fonction réception fichier
Répertoire fichier acheteur
Composant WSC
Fichier ASP
File d'attente de mess.
Oui (Refuser)
Non
(Approuver)
Composant de script
Port d'échanges
Port d'échanges
Canal de la facture
Canal de l'OA
Canal
Port vers ProElectron
via HTTP
Port vers Bits, Bytes,
& Chips via AIC
Port vers Bits, Bytes,& & Chips via AIC
POtoINVAIC
SubmitProElectronPO
Port vers Bits, Bytes,
& Chips via AIC
Canal de la
facture en paiement
Canal de
POReq en OA
Canal
Échanges BizTalk
Message Queuing
Action
Port
Données
Données
ExecuteTutorial
Fonction Recevoir requête OA chez ProElectron
DropInvoicetoMSMQ
ReceiveInvoice
PORequestApproval
ReceivePOReq
Message Queuing
File d'attente de mess.
Application
Req OA
Req OA
Démarrer
Système de l'acheteur
Services d'Échanges BizTalk
Arrêter
AIC
OA pour Facture
Répertoire du fichier
du vendeur
Paiement
Vendeur
Acheteur
Paiement
Facture
Remarque : les flèches de direction indiquent le flux de données.
Facture
Facture
Mappage
Mappage
OA
OA
OA
OA
Fichier ASP
Système du vendeur
Orchestration BizTalk

Passez au Module 2 : création de spécifications et de mappages.

Voir aussi

Conception des orchestrations BizTalk


Module 2 : création de spécifications et de mappages

Dans ce module, vous utilisez l'Éditeur BizTalk pour créer des spécifications et Mappeur BizTalk pour créer des mappages.

Objectifs

  • créer une spécification. Pour plus d'informations, voir Création de spécifications ;

  • ajouter de nouveaux enregistrements et champs à une spécification. Pour plus d'informations, voir Ajout de nouveaux champs aux enregistrements ;

  • créer un mappage. Pour plus d'informations, voir Données de mappage ;

  • créer des liens entre les champs d'un mappage. Pour plus d'informations, voir Création de liaisons ;

  • utiliser des fonctoids pour effectuer des manipulations mathématiques de valeurs dans un mappage. Pour plus d'informations, voir Présentation des fonctoids ;

  • enregistrer des spécifications et des mappages dans le référentiel WebDAV. Pour plus d'informations, voir Stockage de spécifications et Stockage de mappages.

Passez à Utilisation de l'Éditeur BizTalk.

Voir aussi

Création de spécifications et mapping de données


Utilisation de l'Éditeur BizTalk

Vous pouvez utiliser l'Éditeur BizTalk pour créer, modifier et gérer des spécifications.

Pour créer la spécification de paiement à l'aide de l'Éditeur BizTalk, passez à Création de la spécification de paiement.

Raccourci

Pour utiliser la spécification de paiement existante, passez directement à Utilisation de la spécification de paiement existante.


Utilisation de la spécification de paiement existante

  1. Copiez le fichier PaymentSpec.xml du dossier \Program Files\Microsoft BizTalk Server\Tutorial\DocSpecsandMaps sur le lecteur où est installé BizTalk Server.

  2. Insérez ce fichier dans le dossier \Program Files\Microsoft BizTalk Server\BizTalkServerRepository\DocSpecs\Microsoft.

Pour créer la spécification de la requête d'ordre d'achat à l'aide de l'Éditeur BizTalk, passez à Création de la spécification de la requête d'ordre d'achat.

Raccourci

Pour utiliser la spécification de la requête d'ordre d'achat existante, passez à Utilisation de la spécification de la requête d'ordre d'achat existante.


Création de la spécification de paiement

  1. Dans le menu Démarrer, pointez sur Programmes, pointez sur Microsoft BizTalk Server 2000, et cliquez sur Éditeur BizTalk.

  2. Dans le menu Fichier, cliquez sur Nouveau.

    La boîte de dialogue Nouvelle spécification de document apparaît.

  3. Cliquez sur l'icône Spécification vide, puis cliquez sur OK.

  4. Dans le noeud racine, cliquez sur Spécification vide.

  5. Dans l'onglet Déclaration, double-cliquez sur le champ Valeur de la ligne Nom, tapez Payment, et appuyez sur ENTRÉE.

  6. Double-cliquez sur le champ Valeur de la ligne Modèle, cliquez sur Ouvrir, et appuyez sur ENTRÉE.

Passez à Ajout de nouveaux enregistrements au noeud racine Payment de la spécification de paiement.


Ajout de nouveaux enregistrements au noeud racine Payment de la spécification de paiement

  1. Cliquez avec le bouton droit sur le noeud racine Payment et cliquez sur Nouvel enregistrement.

  2. Dénommez cet enregistrement PaymentHeader et appuyez sur ENTRÉE.

  3. Suivez les étapes 1 et 2 pour créer et dénommer quatre enregistrements supplémentaires sous le noeud racine Payment. Il s'agit des enfants du noeud racine Payment. Nommez les enregistrements comme suit :
    • Seller

    • Buyer

    • Item

    • PaymentSummary

Passez à Ajout de nouveaux enregistrements aux enregistrements existants de la spécification de paiement.


Ajout de nouveaux enregistrements aux enregistrements existants de la spécification de paiement

  1. Cliquez avec le bouton droit sur l'enregistrement Seller et cliquez sur Nouvel enregistrement.

  2. Dénommez l'enregistrement Address et appuyez sur ENTRÉE.

  3. Suivez les étapes 1 et 2 pour créer les enregistrements enfant des enregistrements parent répertoriés dans le tableau ci-dessous.
    Enregistrement parent | Nom des enregistrements enfant
    Seller | ContactInfo
    Buyer | Address
    Buyer | ContactInfo

Passez à Ajout de nouveaux champs aux enregistrements existants de la spécification de paiement.


Ajout de nouveaux champs aux enregistrements existants de la spécification de paiement

  1. Cliquez avec le bouton droit sur l'enregistrement PaymentHeader et cliquez sur Nouveau.

  2. Dénommez ce champ PONumber et appuyez sur ENTRÉE.

  3. Dans l'onglet Déclaration, double-cliquez sur le champ Valeur de la ligne Type de données et cliquez sur String, et appuyez sur ENTRÉE.

  4. Dans l'onglet Déclaration, double-cliquez sur le champ Valeur dans la ligne Longueur minimale, tapez 1 puis appuyez sur la touche ENTRÉE.

  5. Dans l'onglet Déclaration, double-cliquez sur le champ Valeur de la ligne Longueur maximale, tapez 22, et appuyez sur ENTRÉE.

  6. Suivez les étapes 1 à 5 pour créer des champs pour les enregistrements ou les enregistrements enfants répertoriés dans le tableau suivant. Chaque enregistrement contient plusieurs champs.

    Il n'est pas nécessaire de créer des champs pour l'acheteur car il existe des noms d'enregistrement parallèles pour l'acheteur et le vendeur. Tous les enregistrements possédant le même nom contiennent les mêmes informations de champs et d'enregistrements. Si vous ajoutez des champs à l'enregistrement Seller/Address ou Seller/ContactInfo, l'enregistrement Buyer/Address ou Buyer/ContactInfo est automatiquement mis à jour avec les mêmes champs.

    Enregistrement parent | Nom de champ | Type de données | Longueur minimale | Longueur maximale
    PaymentHeader | Date | Date | Non applicable | Non applicable
    Seller/Address | Name | String | 1 | 60
    Address1 | String | 1 | 55
    Address2 | String | 1 | 55
    City | String | 2 | 30
    State | String | 2 | 2
    Zip | String | 3 | 15
    Country | String | 2 | 3
    Vendeur/ContactInfo | Name | String | 1 | 60
    Number | String | 1 | 60
    Item | Quantity | Real(r4) | Non applicable | Non applicable
    Price | Real(r4) | Non applicable | Non applicable
    Description | String | 1 | 80
    ExtendedPrice | Real(r4) | Non applicable | Non applicable
    PaymentSummary | Total | Real(r4) | Non applicable | Non applicable

Passez à Enregistrement de la spécification de paiement dans le référentiel WebDAV.


Enregistrement de la spécification de paiement dans le référentiel WebDAV

  1. Dans le menu Fichier, cliquez sur Stocker dans WebDAV.

    La boîte de dialogue Stocker dans WebDav s'affiche.

  2. Double-cliquez sur le dossier Microsoft.

  3. Dans la zone Nom de fichier, tapez PaymentSpec et cliquez sur Enregistrer.

  4. Dans le menu Outils, cliquez sur Valider l'instance.

    La boîte de dialogue Valider une instance de document s'affiche.

  5. Recherchez le dossier \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Solution sur le lecteur où est installé BizTalk Server.

  6. Cliquez sur payment_valid.xml puis sur Ouvrir.

    Les avertissements ou les messages d'erreur apparaissent, le cas échéant, dans l'onglet Avertissements.

La spécification de paiement doit apparaître comme dans l'illustration suivante.

Cliquez sur l'image pour l'agrandir ou la réduire.

Pour créer la spécification de la requête d'ordre d'achat à l'aide de l'Éditeur BizTalk, passez à Création de la spécification de la requête d'ordre d'achat.

Raccourci

Pour utiliser la spécification de la requête d'ordre d'achat existante, passez à Utilisation de la spécification de la requête d'ordre d'achat existante.


Utilisation de la spécification de la requête d'ordre d'achat existante

  1. Copiez le fichier POReq.xml du dossier \Program Files\Microsoft BizTalk Server\Tutorial\DocSpecsandMaps sur le lecteur où est installé BizTalk Server.

  2. Insérez ce fichier dans le dossier \Program Files\Microsoft BizTalk Server\BizTalkServerRepository\DocSpecs\Microsoft.

Passez à Utilisation de Mappeur BizTalk.


Création de la spécification de la requête d'ordre d'achat

Cette procédure consiste à créer le noeud racine de la spécification de la requête d'ordre d'achat.

Pour créer le noeud racine

  1. Dans le menu Fichier, cliquez sur Nouveau.

    La boîte de dialogue Nouvelle spécification de document apparaît.

  2. Cliquez sur l'icône Spécification vide, puis cliquez sur OK.

  3. Dans le noeud racine, cliquez sur Spécification vide.

  4. Dans l'onglet Déclaration, double-cliquez sur le champ Valeur de la ligne Nom, tapez POReq et appuyez sur ENTRÉE.

  5. Double-cliquez sur le champ Valeur de la ligne Modèle, cliquez sur Ouvrir, et appuyez sur ENTRÉE.

Passez à Ajout de nouveaux enregistrements au noeud racine de la spécification de la requête d'ordre d'achat.


Ajout de nouveaux enregistrements au noeud racine de la spécification de la requête d'ordre d'achat

  1. Cliquez avec le bouton droit sur le noeud racine POReq et cliquez sur Nouvel enregistrement.

  2. Dénommez cet enregistrement Header et appuyez sur ENTRÉE.

  3. Suivez les étapes 1 et 2 pour créer et dénommer cinq enregistrements supplémentaires sous le noeud racine POReq. Il s'agit des enregistrements enfant du noeud racine POReq. Nommez les enregistrements comme suit :
    • EmployeeInfo

    • BillTo

    • ShipTo

    • Item

    • Total

Passez à Ajout de nouveaux enregistrements aux enregistrements existants de la spécification de la requête d'ordre d'achat.


Ajout de nouveaux enregistrements aux enregistrements existants de la spécification de la requête d'ordre d'achat

  1. Cliquez avec le bouton droit sur l'enregistrement BillTo et cliquez sur Nouvel Enregistrement.

  2. Dénommez l'enregistrement Address et appuyez sur ENTRÉE.

  3. Suivez les étapes 1 et 2 pour créer et dénommer un enregistrement enfant Address de l'enregistrement parent ShipTo.

Passez à Ajout de nouveaux champs aux enregistrements existants de la spécification de la requête d'ordre d'achat.


Ajout de nouveaux champs aux enregistrements existants de la spécification de la requête d'ordre d'achat

  1. Cliquez avec le bouton droit sur l'enregistrement Header et cliquez sur Nouveau Champ.

  2. Dénommez ce champ Date et appuyez sur ENTRÉE.

  3. Dans l'onglet Déclaration, double-cliquez sur le champ Valeur de la ligne Type de données, cliquez sur Date, et appuyez sur ENTRÉE.

  4. Cliquez avec le bouton droit sur l'enregistrement EmployeeInfo et cliquez sur Nouveau Champ.

  5. Dénommez ce champ EmpID et appuyez sur ENTRÉE.

  6. Dans l'onglet Déclaration, double-cliquez sur le champ Valeur de la ligne Type de données, cliquez sur String, et appuyez sur ENTRÉE.

  7. Dans l'onglet Déclaration, double-cliquez sur le champ Valeur dans la ligne Longueur minimale, tapez 1 puis appuyez sur la touche ENTRÉE.

  8. Dans l'onglet Déclaration, double-cliquez sur le champ Valeur de la ligne Longueur maximale, tapez 60, et appuyez sur ENTRÉE.

  9. Suivez les étapes 4 à 8 pour créer des champs pour les enregistrements ou les enregistrements enfants répertoriés dans le tableau suivant. Chaque enregistrement contient plusieurs champs.

    Il n'est pas nécessaire de créer les champs de ShipTo car il existe des noms d'enregistrement parallèles pour BillTo et ShipTo. Tous les enregistrements possédant le même nom contiennent les mêmes informations de champs et d'enregistrements. Si vous ajoutez des champs à l'enregistrement BillTo/Address, l'enregistrement ShipTo/Address est mis à jour automatiquement avec les mêmes champs.

    Enregistrement parent | Nom de champ | Type de données | Longueur minimale | Longueur maximale
    EmployeeInfo | LastName | String | 1 | 30
    FirstName | String | 1 | 30
    BillTo/Address | Name | String | 1 | 60
    Address1 | String | 1 | 55
    Address2 | String | 1 | 55
    City | String | 2 | 30
    State | String | 2 | 2
    Zip | String | 3 | 15
    Country | String | 2 | 3
    Item | Quantity | Real(r4) | Non applicable | Non applicable
    Price | Real(r4) | Non applicable | Non applicable
    Description | String | 1 | 80
    UnitofMeasure | String | 2 | 2
    ExtendedPrice | Real(r4) | Non applicable | Non applicable
    Total | LineItemTtl | Real(r4) | Non applicable | Non applicable
    QtyTtl | Real(r4) | Non applicable | Non applicable
    POTtl | Real(r4) | Non applicable | Non applicable

Passez à Enregistrement de la spécification de la requête d'ordre d'achat.


Enregistrement de la spécification de la requête d'ordre d'achat

  1. Dans le menu Fichier, cliquez sur Stocker dans WebDAV.

    La boîte de dialogue Stocker dans WebDav s'affiche.

  2. Vérifiez que le dossier Microsoft est ouvert.

  3. Dans la zone Nom de fichier, tapez POReq et cliquez sur Enregistrer.

  4. Dans le menu Outils, cliquez sur Valider l'instance.

    La boîte de dialogue Valider une instance de document s'affiche.

  5. Accédez au dossier \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\SampleData sur le lecteur où est installé BizTalk Server.

  6. Cliquez sur POReqAccept.xml puis cliquez sur Ouvrir.

    Les avertissements ou les messages d'erreur apparaissent, le cas échéant, dans l'onglet Avertissements.

La spécification de la requête d'ordre d'achat doit apparaître comme dans l'illustration suivante.

Cliquez sur l'image pour l'agrandir ou la réduire.

  7. Dans le menu Fichier, cliquez sur Quitter pour fermer la console de l'Éditeur BizTalk.

Passez à Utilisation de Mappeur BizTalk.


Utilisation de Mappeur BizTalk

Cette procédure consiste à utiliser le Mappeur BizTalk pour créer un mappage qui transforme les données d'un message conforme à la spécification CommonInvoice en données d'un message conforme à la spécification PaymentSpec.

Les services d'échanges BizTalk utilisent un mappage dans un canal pour indiquer comment les données d'un document présenté sous un format sont transformées en un document présenté sous un autre format.

Pour créer le mappage à l'aide de Mappeur BizTalk, passez à Création du mappage InvoiceToPayment.

Raccourci

Pour utiliser le mappage existant, passez directement à Utilisation du mappage InvoiceToPayment existant.


Utilisation du mappage InvoiceToPayment existant

  1. Copiez le fichier InvoiceToPayment.xml du dossier \Program Files\Microsoft BizTalk Server\Tutorial\DocSpecsandMaps sur le lecteur où est installé BizTalk Server.

  2. Collez le fichier dans le dossier \Program Files\Microsoft BizTalk Server\BizTalkServerRepository\Maps\Microsoft.

Passez au Module 3 : configuration des services d'échanges BizTalk.


Création du mappage InvoiceToPayment

  1. Dans le menu Démarrer, pointez sur Programmes, pointez sur Microsoft BizTalk Server 2000, et cliquez sur Mappeur BizTalk.

  2. Dans le menu Fichier, cliquez sur Nouveau.

    La boîte de dialogue Sélectionner le type de spécification source apparaît.

  3. Cliquez sur l'icône Fichiers WebDAV, puis sur OK.

    La boîte de dialogue Extraire la spécification source apparaît.

  4. Double-cliquez sur le dossier Microsoft.

  5. Cliquez sur CommonInvoice.xml puis sur Ouvrir.

    La boîte de dialogue Sélectionner le type de spécification de destination apparaît.

  6. Cliquez sur l'icône Fichiers WebDAV, puis sur OK.

  7. Cliquez sur PaymentSpec.xml puis sur Ouvrir.

Passez à Création de liens entre les champs.


Création de liaisons entre les champs

La procédure suivante consiste à lier des champs de la spécification source aux champs de la spécification de destination.

Pour créer des liens entre des champs

  1. Dans l'arborescence Spécification source, développez l'enregistrement InvoiceHeader afin d'afficher les fichiers associés.

    Pour plus d'informations, voir Développement des éléments de l'arborescence.

  2. Dans l'arborescence Spécification de destination, développez l'enregistrement PaymentHeader afin d'afficher les champs associés.

  3. Faites glisser le champ InvoiceHeader/Date de l'arborescence Spécification source vers le champ PaymentHeader/Date de l'arborescence Spécification de destination. Suivez les étapes 1 à 3 pour créer des liens entre les champs répertoriés dans les tableaux ci-dessous.
Enregistrement/champ source | Enregistrement/champ de destination
InvoiceHeader/Number | PaymentHeader/PONumber

Seller/Address/Name | Seller/Address/Name
Seller/Address/Address1 | Seller/Address/Address1
Seller/Address/Address2 | Seller/Address/Address2
Seller/Address/City | Seller/Address/City
Seller/Address/State | Seller/Address/State
Seller/Address/PostalCode | Seller/Address/Zip
Seller/Address/Country | Seller/Address/Country

Seller/ContactInfo/ContactName | Seller/ContactInfo/Name
Seller/ContactInfo/ContactNumber | Seller/ContactInfo/Number

Buyer/Address/Name | Buyer/Address/Name
Buyer/Address/Address1 | Buyer/Address/Address1
Buyer/Address/Address2 | Buyer/Address/Address2
Buyer/Address/City | Buyer/Address/City
Buyer/Address/State | Buyer/Address/State
Buyer/Address/PostalCode | Buyer/Address/Zip
Buyer/Address/Country | Buyer/Address/Country

Buyer/ContactInfo/ContactName | Buyer/ContactInfo/Name
Buyer/ContactInfo/ContactNumber | Buyer/ContactInfo/Number

Item/ItemHeader/Quantity | Item/Quantity
Item/ItemHeader/Price | Item/Price
Item/ItemDescription/Description | Item/Description

InvoiceSummary/InvoiceTotal/Amount PaymentSummary/Total

Passez à Création de liens à l'aide des fonctoids.


Création de liens à l'aide des fonctoids

Cette procédure consiste à utiliser un fonctoid pour multiplier le champ Quantity par le champ Price de la spécification source, et à placer cette valeur dans le champ ExtendedPrice de la spécification de destination.

Pour créer des fonctoids à l'aide de liens

  1. Dans le menu Affichage, cliquez sur Palette de fonctoids.

    La Palette de fonctoids apparaît.

  2. Cliquez sur l'onglet Mathématique, faites glisser le fonctoid Multiplication Fonctoid Multiplication sur la grille de mapping et fermez la palette de fonctoids.

  3. Dans l'arborescence Spécification source, faites glisser le champ Item/ItemHeader/Quantity sur le fonctoid.

  4. Dans l'arborescence Spécification source, faites glisser le champ Item/ItemHeader/Price sur le fonctoid.

  5. Faites glisser le fonctoid Multiplication dans le champ Item/ExtendedPrice de l'arborescence Spécification de destination.

Passez à Compilation du mappage.


Compilation du mappage

  1. Dans le menu Outils, cliquez sur Compiler le fichier de mappage.

  2. Dans le volet de sortie, cliquez sur l'onglet Sortie.

    Les informations de l'onglet Sortie indiquent qu'un mappage XSL a été créé. Les avertissements ou les messages d'erreur apparaissent, le cas échéant, dans l'onglet Avertissements.

Passez à Enregistrement du mappage dans le référentiel WebDAV.


Enregistrement du mappage dans le référentiel WebDAV

  1. Dans le menu Fichier, cliquez sur Stocker dans WebDAV.

    La boîte de dialogue Stocker dans WebDav s'affiche.

  2. Double-cliquez sur le dossier Microsoft.

  3. Dans la zone Nom de fichier, tapez InvoiceToPayment et cliquez sur Enregistrer.

Le mappage que vous avez créé doit apparaître comme dans l'illustration suivante.

Cliquez sur l'image pour l'agrandir ou la réduire.

  4. Dans le menu Fichier, cliquez sur Quitter pour fermer la console Mappeur BizTalk.

Passez à Module 2 - Résumé.


Module 2 - Résumé

Dans ce module, vous avez accompli les tâches suivantes :

  • créé une spécification. Pour plus d'informations, voir Définition des spécifications ;

  • ajouté de nouveaux enregistrements et champs à une spécification. Pour plus d'informations, voir Ajout de nouveaux champs aux enregistrements ;

  • créé un mappage. Pour plus d'informations, voir Données de mappage.

  • créé des liens entre des champs d'un mappage. Pour plus d'informations, voir Création de liaisons ;

  • utilisé des fonctoids pour manipuler des valeurs mathématiques dans un mappage. Pour plus d'informations, voir Présentation des fonctoids ;

  • enregistré des spécifications et des mappages dans le référentiel WebDAV. Pour plus d'informations, voir Stockage de spécifications et Stockage de mappages.

Les zones mises en surbrillance du schéma ci-après illustrent les procédures que vous avez effectuées dans ce module.

Envoyer
Paiement
Recevoir Facture
Décision
Req OA
>$1000
Fin
Recevoir
Req OA
Planification XLANG
Fonction réception fichier
Répertoire fichier acheteur
Composant WSC
Fichier ASP
File d'attente de mess.
Oui (Refuser)
Non
(Approuver)
Composant de script
Port d'échanges
Port d'échanges
Canal de la facture
Canal de l'OA
Canal
Port vers ProElectron
via HTTP
Port vers Bits, Bytes,
& Chips via AIC
Port vers Bits, Bytes, & Chips via Local File
POtoINVAIC
SubmitProElectronPO
Port vers Bits, Bytes,
& Chips via HTTP
Canal de la
facture en paiement
Canal de
POReq en OA
Canal
Échanges BizTalk
Message Queuing
Action
Port
Données
Données
ExecuteTutorial
Fonction Recevoir requête OA chez ProElectron
DropInvoicetoMSMQ
ReceiveInvoice
PORequestApproval
ReceivePOReq
Message Queuing
File d'attente de mess.
Application
Req OA
Req OA
Démarrer
Système de l'acheteur
Services d'échanges BizTalk
Arrêter
AIC
OA pour Facture
Répertoire du fichier
du vendeur
Paiement
Vendeur
Acheteur
Paiement
Facture
Remarque : les flèches de direction indiquent le flux de données.
Facture
Facture
Mappage
Mappage
OA
OA
OA
OA
Fichier ASP
Système du vendeur
Orchestration BizTalk

Passez au Module 3 : configuration des services d'Échanges BizTalk.

Voir aussi

Création de spécifications et mapping de données


Module 3 : configuration des services d'Échanges BizTalk

Dans ce module, vous allez apprendre à utiliser le Gestionnaire d'échanges BizTalk pour configurer des organisations, des canaux et des ports d'échanges pour les systèmes du vendeur et de l'acheteur. Vous pouvez allez également apprendre à utiliser BizTalk Server Administration pour configurer une fonction de réception de fichier.

Objectifs

  • créer des définitions de document. Pour plus d'informations, voir Création et gestion de définitions de document ;

  • créer des organisations. Pour plus d'informations, voir Création et gestion d'organisations.

  • créer des ports d'échanges. Pour plus d'informations, voir Création et gestion des ports d'échanges et Intégration des services BizTalk ;

  • créer des canaux. Pour plus d'informations, voir Création et gestion de canaux ;

  • utiliser un mappage d'un canal pour transformer un document. Pour plus d'informations, voir Données de mappage.

  • créer une fonction de réception. Pour plus d'informations, voir Fonctions de réception.

Passez à Configuration du système de l'acheteur.

Voir aussi

Utilisation du Gestionnaire d'échanges BizTalk


Configuration du système de l'acheteur

Vous utilisez le Gestionnaire d'échanges BizTalk pour créer des organisations représentant vos partenaires commerciaux.

Pour configurer le système de l'acheteur à l'aide du Gestionnaire d'échanges BizTalk, passez à Création d'organisations pour le système de l'acheteur.

Raccourci

Pour configurer le système de l'acheteur à l'aide d'un script, passez directement à Configuration du système de l'acheteur à l'aide d'un script de configuration.


Configuration du système de l'acheteur à l'aide d'un script de configuration

Ce script configure les éléments suivants :

  • une organisation source appelée ProElectron on Buyer sur le système de l'acheteur ;

  • une organisation de destination appelée Bits,Bytes,Chips on Buyer sur le système de l'acheteur ;

  • quatre définitions de document faisant référence aux spécifications de CommonPO, CommonInvoice, PaymentSpec et POReq ;

  • un port d'échanges et un canal définissant le déplacement d'une requête d'ordre d'achat du système de l'acheteur vers le système du vendeur à l'aide du service de transport HTTP dans un fichier ASP du système du vendeur ;

  • un port d'échanges et un canal définissant le déplacement d'une facture ayant été envoyée à l'acheteur et la transformant en un document de paiement sur le système du vendeur.

Attention

  • Si vous avez utilisé le Gestionnaire d'échanges BizTalk et BizTalk Server Administration pour configurer le système de l'acheteur, n'exécutez pas le script de configuration.

Pour exécuter le script qui configure les services d'échanges BizTalk pour le système de l'acheteur :

  1. Accédez au dossier \Program Files\Microsoft BizTalk Server\Tutorial\Setup\MessagingConfigurationScript sur le lecteur où est installé BizTalk Server.

  2. Double-cliquez sur ConfigureBuyer.VBS.

    Un message s'affiche pour indiquer que l'opération a réussi.

Passez à Configuration du système du vendeur.


Création d'organisations pour le système de l'acheteur

Attention

  • Si vous avez implémenté le script de configuration, n'utilisez pas le Gestionnaire d'échanges BizTalk et BizTalk Server Administration pour configurer le système de l'acheteur. Passez à Configuration du système du vendeur.
  1. Dans le menu Démarrer, pointez sur Programmes et sur Microsoft BizTalk Server 2000, puis cliquez sur Gestionnaire d'échanges BizTalk.

  2. Si une boîte de dialogue Gestionnaire d'échanges BizTalk apparaît, cliquez sur Annuler.

  3. Dans le menu Fichier, pointez sur Nouveau et cliquez sur Organisation.

    La boîte de dialogue Nouvelle organisation apparaît.

  4. Dans la zone Nom de l'organisation, tapez Bits, Bytes, Chips on Buyer et cliquez sur OK.

  5. Répétez les étapes 3 et 4, en dénommant la nouvelle organisation ProElectron on Buyer.

Passez à Création de définitions de document pour les systèmes de l'acheteur et du vendeur.


Création de définitions de document pour les systèmes de l'acheteur et du vendeur

Cette procédure consiste à créer quatre définitions de document qui font référence aux spécifications de document, CommonInvoice, CommonPO, PaymentSpec et POReq. Ces définitions sont partagées par les systèmes de l'acheteur et du vendeur.

Pour créer des définitions de document

  1. Dans le menu Fichier, pointez sur Nouveau et cliquez sur Définition de document.

    La boîte de dialogue Nouvelle définition de document s'affiche.

  2. Dans la zone Nom de la définition de document, tapez Purchase Order.

  3. Activez la case à cocher Spécification de document et cliquez sur le bouton Parcourir.

    La boîte de dialogue Sélection d'une spécification de document dans le référentiel WebDAV apparaît.

  4. Double-cliquez sur le dossier Microsoft.

  5. Cliquez sur CommonPO.xml puis sur Ouvrir.

  6. Cliquez sur OK pour fermer la boîte de dialogue Nouvelle définition de document.

  7. Répétez les étapes 1 à 6 pour créer une nouvelle définition de document et modifiez simplement les éléments suivants :
    • dénommez la nouvelle définition de document Invoice ;

    • cliquez sur la spécification CommonInvoice.xml de WebDAV.
  8. Répétez les étapes 1 à 6 pour créer une nouvelle définition de document et modifiez simplement les éléments suivants :
    • dénommez la nouvelle définition de document Purchase Order Request ;

    • cliquez sur la spécification POReq.xml de WebDAV.
  9. Répétez les étapes 1 à 6 pour créer une nouvelle définition de document et modifiez simplement les éléments suivants :
    • dénommez la nouvelle définition de document Payment ;

    • cliquez sur la spécification PaymentSpec.xml de WebDAV.

Passez à Création d'un port d'échanges sur Bits, Bytes, & Chips pour le système de l'acheteur.


Création d'un port d'échanges sur Bits, Bytes, & Chips pour le système de l'acheteur

Cette procédure consiste à créer un port d'échanges pour le système de l'acheteur. Le port d'échanges définit la destination d'un document.

Le port d'échanges que vous créez a son organisation de destination "Bits, Bytes, & Chips on Buyer". Il utilise le service de transport HTTP pour l'envoi des documents à Bits, Bytes, & Chips.

Pour créer le port d'échanges :

  1. Dans le menu Fichier, pointez sur Nouveau, pointez sur Port d'échanges, et cliquez sur Vers une organisation.

    L'Assistant Nouveau port d'échanges s'ouvre.

  2. Dans la zone Nom, tapez Port to Bits, Bytes, Chips via HTTP et cliquez sur Suivant.

  3. Sur la page Organisation de destination, dans la zone Organisation, cliquez sur Parcourir.

    La boîte de dialogue Sélectionner une organisation s'affiche.

  4. Cliquez sur Bits, Bytes , Chips on Buyer puis sur OK.

  5. Dans la zone Transport principal, cliquez sur Parcourir.

    La boîte de dialogue Transport principal s'affiche.

  6. Dans la liste Type de transport, cliquez sur HTTP.

  7. Dans la zone Adresse, après le préfixe http://, tapez le nom de votre ordinateur, suivi de /SubmitPO/SubmitProElectronPO.asp, cliquez sur OK, puis sur Suivant.

    Par exemple, http://Ordinateur1/SubmitPO/SubmitProElectronPO.asp.

    Pour trouver le nom de votre ordinateur, procédez comme suit :

    1. Dans le menu Démarrer, pointez sur Paramètres, puis cliquez sur Panneau de configuration.

    2. Double-cliquez sur Outils d'administration.

    3. Double-cliquez sur Gestion de l'ordinateur.

      La console Gestion de l'ordinateur s'affiche.

    4. Dans le menu Action, cliquez sur Propriétés.

      La boîte de dialogue Propriétés de Gestion de l'ordinateur (local) apparaît.

    5. Cliquez sur l'onglet Identification réseau.

      Le nom de votre ordinateur s'affiche dans le champ Nom de l'ordinateur.

  8. Sur la page Informations d'enveloppe, cliquez sur Suivant.

  9. Sur la page Informations de sécurité, vérifiez que la case à cocher Créer un canal pour ce port d'échanges est activée.

  10. Dans la liste Type de canal, cliquez sur À partir d'une organisation, puis sur Terminer.

    L'Assistant Nouveau canal s'ouvre.

Passez à Création d'un canal à partir de ProElectron pour le système de l'acheteur.


Création d'un canal à partir de ProElectron pour le système de l'acheteur

Cette procédure consiste à créer un canal pour le port d'échanges.

Pour créer le canal :

  1. Sur la page Informations générales, dans la zone Nom, tapez Channel for POReq to PO et cliquez sur Suivant.

  2. Sur la page Organisation source, cliquez sur Parcourir.

    La boîte de dialogue Sélectionner une organisation s'affiche.

  3. Cliquez sur ProElectron on Buyer, sur OK, puis sur Suivant.

  4. Sur la page Document entrant, à droite de la zone Nom de la définition du document entrant, cliquez sur Parcourir.

    La boîte de dialogue Sélectionner une définition de document s'affiche.

  5. Cliquez sur Purchase Order Request, sur OK, puis sur Suivant.

  6. Sur la page Document sortant, à droite de la zone Nom de la définition de document sortant, cliquez sur Parcourir.

    La boîte de dialogue Sélectionner une définition de document s'affiche.

  7. Cliquez sur Purchase Order puis sur OK.

  8. Vérifiez que la case à cocher Mapper le document entrant sur le document sortant est activée.

  9. À droite de la zone Référence de mappage, cliquez sur Parcourir.

    La boîte de dialogue Sélection d'un mappage dans le référentiel WebDAV s'affiche.

  10. Double-cliquez sur le dossier Microsoft.

  11. Cliquez sur POReqtoPO.xml, sur Ouvrir, puis sur Suivant.

  12. Sur la page Journalisation du document, cliquez sur Suivant.

  13. Sur la page Configuration avancée, cliquez sur Terminer.

Passez à Création d'un port d'échanges sur Bits, Bytes & Chips dans le système de l'acheteur.


Création d'un port d'échanges sur Bits, Bytes, & Chips dans le système de l'acheteur

Dans cette procédure, le port d'échanges envoie des documents dans le système de l'acheteur à l'aide du service de transport de fichier. Les documents sont envoyés en interne au dossier spécifié dans l'adresse de destination.

Pour créer le port d'échanges :

  1. Dans le menu Fichier, pointez sur Nouveau, pointez sur Port d'échanges, et cliquez sur Vers une organisation.

    L'Assistant Nouveau port d'échanges s'ouvre.

  2. Dans la zone Nom, tapez Port to Bits, Bytes, Chips via Local File et cliquez sur Suivant.

  3. Sur la page Organisation de destination, dans la zone Organisation, cliquez sur Parcourir.

    La boîte de dialogue Sélectionner une organisation s'affiche.

  4. Cliquez sur ProElectron on Buyer puis sur OK.

  5. Dans la zone Transport principal, cliquez sur Parcourir.

    La boîte de dialogue Transport principal s'affiche.

  6. Dans la liste Type de transport, cliquez sur Fichier.

  7. Dans la zone Adresse, après file://, tapez C:\TutorialFiles\Seller\payment%tracking_id%.xml. Par exemple, file://c:\TutorialFiles\Seller\payment%tracking_id%.xml.

    Remarque

    • Pour le service de transport de fichiers, le paramètre par défaut du composant transport consiste à ajouter de nouveaux fichiers à un fichier existant dans le répertoire spécifié. Pour créer un nouveau fichier ayant un nom unique pour chaque instance de document, vous devez utiliser le format de chemin de fichier suivant :
      file://C:\dir\file%tracking_id%.xmlfile://C:\dir\file%tracking_id%.xml
  8. Cliquez sur OK pour fermer la boîte de dialogue Transport principal et cliquez sur Suivant.

  9. Sur la page Informations d'enveloppe, cliquez sur Suivant.

  10. Sur la page Informations de sécurité, vérifiez que la case à cocher Créer un canal pour ce port d'échanges est activée.

  11. Dans la liste Type de canal, cliquez sur À partir d'une organisation, puis sur Terminer.

    L'Assistant Nouveau canal s'ouvre.

Passez à Création d'un canal à partir de Bits, Bytes, & Chips pour le système de l'acheteur.


Création d'un canal à partir de Bits, Bytes, & Chips pour le système de l'acheteur

Le canal que vous créez dans cette procédure traite les factures reçues de Bits, Bytes, & Chips et utilise un mappage pour transformer la facture en paiement.

Pour créer le canal :

  1. Sur la page Informations générales, dans la zone Nom, tapez Channel for Invoice To Payment et cliquez sur Suivant.

  2. Sur la page Organisation source, dans la zone Organisation, cliquez sur Parcourir.

    La boîte de dialogue Sélectionner une organisation s'affiche.

  3. Cliquez sur Bits, Bytes, Chips on Buyer, sur OK, puis sur Suivant.

  4. Sur la page Document entrant, à droite de la zone Nom de la définition du document entrant, cliquez sur Parcourir.

    La boîte de dialogue Sélectionner une définition de document s'affiche.

  5. Cliquez sur Invoice, sur OK, puis sur Suivant.

  6. Sur la page Document sortant, à droite de la zone Nom de la définition de document sortant, cliquez sur Parcourir.

    La boîte de dialogue Sélectionner une définition de document s'affiche.

  7. Cliquez sur Payment puis sur OK.

  8. Vérifiez que la case à cocher Mapper le document entrant sur le document sortant est activée.

  9. À droite de la zone Référence de mappage, cliquez sur Parcourir.

    La boîte de dialogue Sélection d'un mappage dans le référentiel WebDAV s'affiche.

  10. Double-cliquez sur le dossier Microsoft.

  11. Cliquez sur InvoicetoPayment.xml, sur Ouvrir, puis sur Suivant.

  12. Sur la page Journalisation du document, cliquez sur Suivant.

  13. Sur la page Configuration avancée, cliquez sur Terminer.

  14. Dans le menu Fichier, cliquez sur Quitter pour fermer le Gestionnaire d'échanges BizTalk.

Passez à Création d'une fonction de réception de fichiers pour le système de l'acheteur.


Création d'une fonction de réception de fichiers pour le système de l'acheteur

Cette procédure consiste à créer une fonction de réception de fichier qui extrait la requête d'ordre d'achat de l'acheteur d'un répertoire de fichiers local et la soumet aux services d'échanges BizTalk.

La relation entre l'application professionnelle d'envoi, le système de fichiers et la fonction de réception est représentée dans l'illustration suivante.

Fonction de réception
Application professionnelle
d'envoi
Système de fichiers
Fonction de réception de fichiers BizTalk Server
BizTalk
Server
Soumettre

Pour créer la fonction de réception de fichier

  1. Dans le menu Démarrer, pointez sur Programmes et sur Microsoft BizTalk Server 2000, puis cliquez sur Administration de BizTalk Server.

  2. Développez Microsoft BizTalk Server 2000, puis Groupe BizTalk Server, et cliquez sur Fonctions de réception.

  3. Dans le menu Action, pointez sur Nouveau et cliquez sur Fonction de réception de fichier.

    La boîte de dialogue Ajouter une fonction de réception de fichier s'affiche.

  4. Dans la zone Nom, tapez PORequest Receive Function at ProElectron.

  5. Dans la zone Serveur sur lequel sera exécutée la fonction de réception, cliquez sur le nom d'un serveur du groupe de serveurs BizTalk.

  6. Dans la zone Types de fichiers à interroger, tapez *.xml.

  7. Dans la zone Emplacement de l'interrogation, tapez C:\TutorialFiles\Buyer.

  8. Cliquez sur le bouton Avancé.

    La boîte de dialogue Options de fonction de réception avancées apparaît.

  9. Dans la liste Nom du canal, cliquez sur Channel for POReq to PO puis sur OK.

  10. Cliquez sur OK pour fermer la boîte de dialogue Ajouter une fonction de réception de fichier.

  11. Fermez Administration de BizTalk Server.

Passez à Configuration du système du vendeur.


Configuration du système du vendeur

Vous utilisez le Gestionnaire d'échanges BizTalk pour créer des organisations représentant vos partenaires commerciaux.

Passez à Création d'organisations pour le système du vendeur.


Création d'organisation pour le système du vendeur

  1. Dans le menu Démarrer, pointez sur Programmes et sur Microsoft BizTalk Server 2000, puis cliquez sur Gestionnaire d'échanges BizTalk.

  2. Si une boîte de dialogue Gestionnaire d'échanges BizTalk apparaît, cliquez sur Annuler.

  3. Dans le menu Fichier, pointez sur Nouveau et cliquez sur Organisation.

    La boîte de dialogue Nouvelle organisation apparaît.

  4. Dans l'onglet Général, dans la zone Nom de l'organisation, tapez Bits, Bytes, Chips on Seller et cliquez sur OK.

  5. Répétez les étapes 3 et 4, en dénommant la nouvelle organisation ProElectron on Seller et cliquez sur OK.

Passez à Création d'un port d'échanges sur Bits, Bytes, & Chips pour le système du vendeur.


Création d'un port d'échanges sur Bits, Bytes, & Chips pour le système du vendeur

Cette procédure consiste à créer un port d'échanges qui définit la destination d'un document. Ce port envoie des documents en interne dans le système du vendeur en utilisant le composant d'intégration de l'application comme service de transport.

Un composant d'intégration de l'application sert généralement de point d'intégration entre BizTalk Server 2000 et une application principale. Dans ce scénario, ce composant fonctionne à la fois comme point d'intégration et application principale éventuelle. Le port d'échanges transmet l'ordre d'achat au composant d'intégration de l'application. Celui-ci transforme l'ordre d'achat en facture et la soumet à un canal des services d'échanges BizTalk du système du vendeur.

L'ordre d'achat peut également être transformé en facture en utilisant un mappage dans le canal, mais par souci de simplicité, le composant d'intégration de l'application exécute cette fonction dans ce scénario.

Pour créer le port d'échanges :

  1. Dans le menu Fichier, pointez sur Nouveau, pointez sur Port d'échanges, et cliquez sur Vers une organisation.

    L'Assistant Nouveau port d'échanges s'ouvre.

  2. Dans la zone Nom, tapez Port to Bits, Bytes, Chips via AIC et cliquez sur Suivant.

  3. Sur la page Organisation de destination, dans la zone Organisation, cliquez sur Parcourir.

    La boîte de dialogue Sélectionner une organisation s'affiche.

  4. Cliquez sur Bits, Bytes, Chips on Seller puis sur OK.

  5. Dans la zone Transport principal, cliquez sur Parcourir.

    La boîte de dialogue Transport principal s'affiche.

  6. Dans la liste Type de transport, vérifiez que Composant d'intégration aux applications est sélectionné et cliquez sur Parcourir.

    La boîte de dialogue Sélectionner un composant s'affiche.

  7. Cliquez sur POToINVAIC ConvertPOToInvoice puis sur OK.

  8. Cliquez sur OK pour fermer la boîte de dialogue Transport principal et cliquez sur Suivant.

  9. Sur la page Informations d'enveloppe, cliquez sur Suivant.

  10. Sur la page Informations de sécurité, vérifiez que la case à cocher Créer un canal pour ce port d'échanges est activée.

  11. Dans la liste Type de canal, cliquez sur À partir d'une organisation, puis sur Terminer.

    L'Assistant Nouveau canal s'ouvre.

Passez à Création d'un canal à partir de ProElectron pour le système du vendeur.


Création d'un canal à partir de ProElectron pour le système du vendeur

Cette procédure consiste à créer un canal pour le port d'échanges.

Le canal que vous créez a son organisation source "ProElectron on Seller", qui représente l'acheteur sur le système du vendeur. Ce canal traite les ordres d'achat reçus de ProElectron. Étant donné que les définitions de document entrant et sortant sont identiques, aucune référence de mappage n'est requise pour ce canal et aucune transformation de document n'est opérée.

Pour créer le canal :

  1. Sur la page Informations générales, dans la zone Nom, tapez Channel for PO et cliquez sur Suivant.

  2. Sur la page Organisation source, dans la zone Organisation, cliquez sur Parcourir.

    La boîte de dialogue Sélectionner une organisation s'affiche.

  3. Cliquez sur ProElectron on Seller, cliquez sur OK, puis sur Suivant.

  4. Sur la page Document entrant, à droite de la zone Nom de la définition du document entrant, cliquez sur Parcourir.

    La boîte de dialogue Sélectionner une définition de document s'affiche.

  5. Sélectionnez Purchase Order, cliquez sur OK puis sur Suivant.

  6. Sur la page Document sortant, à droite de la zone Nom de la définition de document sortant, cliquez sur Parcourir.

    La boîte de dialogue Sélectionner une définition de document s'affiche.

  7. Sélectionnez Purchase Order, cliquez sur OK puis sur Suivant.

  8. Sur la page Journalisation du document, cliquez sur Suivant.

  9. Sur la page Configuration avancée, cliquez sur Terminer.

Passez à Création d'un port d'échanges sur ProElectron pour le système du vendeur.


Création d'un port d'échanges sur ProElectron pour le système du vendeur

L'organisation de destination que vous créez pour le port d'échanges s'appelle "ProElectron on Seller", qui représente l'acheteur sur le système du vendeur. Ce port d'échanges envoie des documents du système du vendeur au système de l'acheteur. Il utilise le service de transport HTTP pour envoyer les documents à l'adresse de l'acheteur spécifiée.

Lorsque ce port est utilisé, un message de facture est envoyé à une page ASP du système de l'acheteur qui, à son tour, envoie cette facture à une file d'attente de messages du système de l'acheteur.

Pour créer le port d'échanges :

  1. Dans le menu Fichier, pointez sur Nouveau, pointez sur Port d'échanges, et cliquez sur Vers une organisation.

    L'Assistant Nouveau port d'échanges s'ouvre.

  2. Sur la page Informations générales, dans la zone Nom, tapez Port To ProElectron via HTTP et cliquez sur Suivant.

  3. Sur la page Organisation de destination, dans la zone Organisation, cliquez sur Parcourir.

    La boîte de dialogue Sélectionner une organisation apparaît.

  4. Cliquez sur ProElectron on Seller puis sur OK.

  5. Dans la zone Transport principal, cliquez sur Parcourir.

    La boîte de dialogue Transport principal s'affiche.

  6. Dans la liste Type de transport, cliquez sur HTTP.

  7. Dans la zone Adresse, après le préfixe http://, tapez le nom de votre ordinateur, suivi de /InvoiceToQueue/DropInvoicetoMSMQ.asp, cliquez sur OK, puis sur Suivant.

    Par exemple, http://Ordinateur1/InvoiceToQueue/DropInvoicetoMSMQ.asp.

    Pour trouver le nom de votre ordinateur, procédez comme suit :

    1. Dans le menu Démarrer, pointez sur Paramètres, puis cliquez sur Panneau de configuration.

    2. Double-cliquez sur Outils d'administration.

    3. Double-cliquez sur Gestion de l'ordinateur.

      La console Gestion de l'ordinateur s'affiche.

    4. Dans le menu Action, cliquez sur Propriétés.

      La boîte de dialogue Propriétés de Gestion de l'ordinateur (local) apparaît.

    5. Cliquez sur l'onglet Identification réseau.

      Le nom de votre ordinateur s'affiche dans le champ Nom de l'ordinateur.

  8. Sur la page Informations d'enveloppe, cliquez sur Suivant.

  9. Sur la page Informations de sécurité, vérifiez que la case à cocher Créer un canal pour ce port d'échanges est activée.

  10. Dans la liste Type de canal, cliquez sur À partir d'une organisation, puis sur Terminer.

    L'Assistant Nouveau canal s'ouvre.

Passez à Création d'un canal à partir de Bits, Bytes, & Chips pour le système du vendeur.


Création d'un canal à partir de Bits, Bytes, & Chips pour le système du vendeur

Le canal que vous créez dans cette procédure a pour organisation source "Bits,Bytes,Chips on Seller". Ce canal traite les factures envoyées à ProElectron sur le système du vendeur selon les règles du port d'échanges, Port vers ProElectron via HTTP.

Pour créer le canal :

  1. Sur la page Informations générales, dans la zone Nom, tapez Canal for Invoice et cliquez sur Suivant.

  2. Sur la page Organisation source, dans la zone Organisation, cliquez sur Parcourir.

    La boîte de dialogue Sélectionner une organisation s'affiche.

  3. Cliquez sur Bits, Bytes, Chips on Seller, cliquez sur OK, puis sur Suivant.

  4. Sur la page Document entrant, à droite de la zone Nom de la définition du document entrant, cliquez sur Parcourir.

    La boîte de dialogue Sélectionner une définition de document s'affiche.

  5. Cliquez sur Invoice, sur OK, puis sur Suivant.

  6. Sur la page Document sortant, cliquez sur Parcourir.

    La boîte de dialogue Sélection d'une définition de document s'affiche.

  7. Cliquez sur Invoice, sur OK, puis sur Suivant.

  8. Sur la page Journalisation du document, cliquez sur Suivant.

  9. Sur la page Configuration avancée, cliquez sur Terminer.

  10. Dans le menu Fichier, cliquez sur Quitter pour fermer le Gestionnaire d'échanges BizTalk.

Passez à Module 3 - Résumé.


Module 3 - Résumé

Dans ce module, vous avez accompli les tâches suivantes :

  • créé des définitions de document. Pour plus d'informations, voir Création et gestion de définitions de document ;

  • créé des organisations. Pour plus d'informations, voir Création et gestion d'organisations.

  • créé des ports d'échanges. Pour plus d'informations, voir Création et gestion des ports d'échanges ;

  • créé des canaux. Pour plus d'informations, voir Création et gestion de canaux ;

  • utilisé un mappage dans un canal pour transformer un document. Pour plus d'informations, voir Données de mappage.

  • créé une fonction de réception de fichier. Pour plus d'informations, voir Fonctions de réception.

Pour afficher les définitions de document, les organisations, les ports d'échanges, les canaux et le mappage que vous avez créés dans ce module, utilisez le bouton Rechercher du Gestionnaire d'échanges BizTalk.

Les zones mises en surbrillance du schéma ci-après illustrent les procédures que vous avez effectuées dans ce module.

Envoyer
Paiement
Recevoir Facture
Décision
Req OA
>$1000
Fin
Recevoir
Req OA
Planification XLANG
Fonction réception fichier
Répertoire fichier acheteur
Composant WSC
Fichier ASP
File d'attente de mess.
Oui (Refuser)
Non
(Approuver)
Composant de script
Port d'échanges
Port d'échanges
Canal de la facture
Canal de l'OA
Canal
Port vers ProElectron
via HTTP
Port vers Bits, Bytes,
& Chips via AIC
Port vers Bits, Bytes, & Chips via Local File
POtoINVAIC
SubmitProElectronPO
Port vers Bits, Bytes,
& Chips via HTTP
Canal de la
facture en paiement
Canal de
POReq to PO
Canal
Échanges BizTalk
Message Queuing
Action
Port
Données
Données
ExecuteTutorial
Fct. Recevoir requête OA chez ProElectron
DropInvoicetoMSMQ
ReceiveInvoice
PORequestApproval
ReceivePOReq
Message Queuing
File d'attente de mess.
Application
Req OA
Req OA
Démarrer
Système de l'acheteur
Services d'échanges BizTalk
Arrêter
AIC
OA pour Facture
Répertoire du fichier
du vendeur
Paiement
Vendeur
Acheteur
Paiement
Facture
Remarque : les flèches de direction indiquent le flux de données.
Facture
Facture
Mappage
Mappage
OA
OA
OA
OA
Fichier ASP
Système du vendeur
Orchestration BizTalk

Passez au Module 4 : clôture de la planification XLANG.

Voir aussi

Utilisation du Gestionnaire d'échanges BizTalk


Module 4 : clôture de la planification XLANG

Dans ce module, vous utilisez le Concepteur d'Orchestration BizTalk pour implémenter un port à l'aide des services d'échanges BizTalk. Ensuite, vous compilez et exécutez la planification XLANG terminée.

Objectifs

  • ajouter des actions de facture et de paiement. Pour plus d'informations, voir Ajout de formes ;

  • implémenter un port à l'aide des services d'échanges BizTalk. Pour plus d'informations, voir Utilisation de la forme Échanges BizTalk.

  • compiler et exécuter la planification XLANG terminée. Pour plus d'informations, voir Compilation des planifications XLANG et Exécution des planifications XLANG.

Pour terminer la planification XLANG, passez à Ajout d'actions de facture et de paiement.

Raccourci

Pour utiliser la planification XLANG existante, passez directement à Exécution de la planification XLANG terminée.

Voir aussi

Conception des orchestrations BizTalk


Ajout d'actions de facture et de paiement

Cette procédure consiste à ajouter une action qui reçoit une facture de l'acheteur et une autre action qui envoie un message de paiement au vendeur.

Pour créer les actions

  1. Dans le menu Démarrer, pointez sur Programmes, pointez sur Microsoft BizTalk Server 2000, puis cliquez sur Concepteur d'Orchestration BizTalk.

  2. Dans le menu Fichier, cliquez sur Ouvrir.

    La boîte de dialogue Ouvrir un schéma de planification XLANG apparaît.

  3. Si vous utilisez le fichier Buyer1.skv existant, dans la boîte de dialogue Ouvrir un schéma de planification XLANG, accédez au dossier \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Solution sur le lecteur où est installé BizTalk Server, cliquez sur Buyer1.skv, puis sur Ouvrir.

    Si vous avez créé le fichier Buyer1.skv dans le module 1, accédez au dossier \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Lab sur le lecteur où est installé BizTalk Server, cliquez sur Buyer1.skv, puis sur Ouvrir.

    Remarque

    Le Concepteur d'Orchestration BizTalk contient un schéma vierge, que vous pouvez fermer.

  4. Sélectionnez la connexion entre l'action Write PO Request to File (Écrire la requête d'ordre d'achat dans fichier) et l'action Fin et appuyez sur SUPPR.

  5. Déplacez l'action Fin vers le bas pour libérer de la place pour les deux nouvelles formes d'action.

  6. Sur la page Processus professionnel, faites glisser la forme Action du stencil Diagramme de flux vers la gauche de la barre de séparation. Positionnez la forme directement en dessous de l'action Write PO Request to File (Écrire la requête d'ordre d'achat dans fichier).

  7. Cliquez avec le bouton droit sur la forme Action 1, puis cliquez sur Propriétés.

    La boîte de dialogue Propriétés de l'action s'affiche.

  8. Dans la zone Nom, tapez Receive Invoice (Recevoir Facture) et cliquez sur OK.

  9. Sur la page Processus professionnel, faites glisser la forme Action du stencil Diagramme de flux vers la gauche de la barre de séparation. Positionnez la forme directement en dessous de l'action Receive Invoice (Recevoir Facture).

  10. Cliquez avec le bouton droit sur la forme Action 1, puis cliquez sur Propriétés.

    La boîte de dialogue Propriétés de l'action s'affiche.

  11. Dans la zone Nom, tapez Send Payment (Envoyer Paiement) et cliquez sur OK.

  12. Connectez l'action Write PO Request to File (Écrire la requête d'ordre d'achat dans fichier) à l'action Recevoir Facture.

  13. Connectez l'action Receive Invoice (Recevoir Facture) à l'action Send Payment (Envoyer Paiement).

  14. Connectez l'action Send Payment (Envoyer Paiement) à la forme Fin.

Passez à Liaison du service Message Queuing pour recevoir une facture.


Liaison du service Message Queuing pour recevoir une facture

L'action Receive Invoice (Recevoir Facture) est liée à un service de file d'attente de messages. Lorsqu'une facture est placée dans la file d'attente de messages définie par le service, elle active l'action Receive Invoice (Recevoir Facture).

Pour lier le service de file d'attente de messages

  1. Sur la page Processus professionnel, faites glisser la forme Message Queuing du stencil Implémentation vers la droite de la barre de séparation qui divise les deux côtés du schéma. Positionnez la forme Message Queuing de sorte qu'elle soit alignée horizontalement par rapport à l'action Receive Invoice (Recevoir Facture).

    L'Assistant Liaison de Message Queuing s'ouvre.

  2. Sur la première page de l'Assistant Liaison de Message Queuing, vérifiez que Créer un port est sélectionné.

  3. Dans la zone Créer un port, tapez ReceiveInvoice (Recevoir Facture) et cliquez sur Suivant.

  4. Sur la page Informations sur la file d'attente statique ou dynamique, vérifiez que File d'attente statique est sélectionné et cliquez sur Suivant.

  5. Sur la page Informations sur la file d'attente, cliquez sur Utiliser une file d'attente connue pour toutes les instances.

  6. Dans la zone Entrez le nom de la file d'attente, tapez .\private$\ReceiveInvoice (Recevoir Facture) et cliquez sur Suivant.

  7. Sur la page Propriétés avancées du port, cliquez sur Terminer.

Passez à Définition des propriétés de message du service Receive Invoice.


Définition des propriétés de message du service Receive Invoice

  1. Sélectionnez l'action Receive Invoice (Recevoir Facture) et faites glisser la poignée de contrôle située à droite de l'action Receive Invoice (Recevoir Facture) vers le port Receive Invoice (Recevoir Facture).

    L'Assistant Communication XML s'ouvre.

  2. Sur la page Assistant Communication XML, cliquez sur Recevoir, puis sur Suivant.

  3. Sur la page Informations sur le message, vérifiez que Créer un message est sélectionné.

  4. Dans la zone Nom du message, tapez CommonInvoice et cliquez sur Suivant.

  5. Sur la page Informations sur l'interprétation XML, vérifiez que Recevoir les messages XML de la file d'attente est sélectionné et cliquez sur Suivant.

  6. Sur la page Informations sur les types de messages, dans la zone Type de message, tapez CommonInvoice et cliquez sur Suivant.

  7. Sur la page Informations sur la spécification du message, cliquez sur Terminer.

Passez à Liaison des services d'échanges BizTalk.


Liaison des services d'échanges BizTalk

Cette procédure consiste à lier un service d'échanges BizTalk au schéma de planification XLANG et à dénommer le canal utilisé.

Pour lier les services d'échanges BizTalk

  1. Sur la page Processus professionnel, faites glisser la forme Échanges BizTalk Messaging du stencil Implémentation vers la droite de la barre de séparation qui divise les deux côtés du schéma. Positionnez la forme Échanges BizTalk de sorte qu'elle soit alignée horizontalement sur l'action Send Payment (Envoyer Paiement).

    L'Assistant Liaison d'Échanges BizTalk s'ouvre.

  2. Sur la page Assistant Liaison d'Échanges BizTalk, vérifiez que Créer un port est sélectionné.

  3. Dans la zone Créer un port, tapez SendPayment (Envoyer Paiement) et cliquez sur Suivant.

  4. Sur la page Direction de la communication, vérifiez que Envoyer est sélectionné et cliquez sur Suivant.

  5. Sur la page Informations sur le canal statique ou dynamique, vérifiez que Canal statique est sélectionné.

  6. Dans la zone Entrez le nom d'un canal connu pré-existant, tapez Channel for Invoice To Payment (Canal de la facture en paiement) et cliquez sur Terminer.

    Notez que Channel for Invoice To Payment (Canal de la facture en paiement) a été créé dans le module 3.

Passez à Définition des propriétés de message des services d'échanges BizTalk.


Définition des propriétés de message des services d'échanges BizTalk

  1. Faites glisser la poignée de contrôle située à droite de l'action Send Payment (Envoyer Paiement) vers le port Send Payment (Envoyer Paiement).

    L'Assistant Communication XML s'ouvre.

  2. Sur la page Assistant Communication XML, cliquez sur Suivant.

  3. Sur la page Informations sur le message, cliquez sur Ajouter une référence à un message existant, cliquez sur CommonInvoice, puis sur Suivant.

  4. Sur la page Informations sur l'interprétation XML, vérifiez que Envoyer des messages XML à la file d'attente est sélectionné et cliquez sur Suivant.

  5. Sur la page Informations sur les types de messages, cliquez sur Suivant.

  6. Sur la page Informations sur la spécification du message, cliquez sur Terminer.

Passez à Enregistrement du schéma de planification XLANG terminé.


Enregistrement du schéma de planification XLANG terminé

  1. Dans le menu Fichier, cliquez sur Enregistrer sous.

    La boîte de dialogue Enregistrer un schéma de planification XLANG sous s'affiche.

  2. Accédez au dossier \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Lab.

  3. Dans la zone Nom du fichier, tapez Buyer2 et cliquez sur Enregistrer.

Passez à Compilation du schéma de planification XLANG terminé.


Compilation du schéma de planification XLANG terminé

  1. Dans le menu Fichier, cliquez sur Créer XLANG Buyer2.skx.

    La boîte de dialogue Enregistrer la planification XLANG vers apparaît.

  2. Accédez au dossier \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Lab sur le lecteur où est installé BizTalk Server.

  3. Dans la zone Nom du fichier, tapez Buyer2 et cliquez sur Enregistrer.

Le schéma de planification XLANG obtenu doit apparaître comme dans l'illustration suivante.

Cliquez sur l'image pour l'agrandir ou la réduire.

Schéma de planification XLANG

  4. Dans le menu Fichier, cliquez sur Quitter.

Passez à Exécution de la planification XLANG terminée.


Exécution de la planification XLANG terminée

Vous avez terminé la configuration d'une solution d'approvisionnement automatisée interentreprises. Vous pouvez maintenant exécuter l'application qui active la planification XLANG.

Cette procédure consiste à utiliser une application qui active la planification XLANG et à envoyer une requête d'ordre d'achat dans la file d'attente de messages contrôlée par la planification.

Pour exécuter la planification XLANG :

  1. Recherchez le dossier \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Solution sur le lecteur où est installé BizTalk Server.

  2. Double-cliquez sur ExecuteTutorial.exe. Cette application permet d'activer la planification XLANG à l'aide d'un moniker.

    L'application ExecuteTutorial s'ouvre.

  3. Cliquez sur Browse for Schedule.

Raccourci

Si vous utilisez la planification XLANG existante, recherchez le dossier \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Solution, puis passez à l'étape 5.

  1. Si vous avez créé la planification XLANG Buyer2, accédez au dossier \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Lab sur le lecteur où est installé BizTalk Server.

  2. Cliquez sur la planification XLANG Acheteur2.skx puis sur Ouvrir.

  3. Cliquez sur Browse for Data File et accédez au dossier \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\SampleData sur le lecteur où est installé BizTalk Server.

  4. Cliquez sur POReqAccept.xml puis cliquez sur Ouvrir.

  5. Cliquez sur Start XLANG Schedule.

    Dans la mesure où le total est inférieur à 1000 dollars, la demande d'ordre d'achat est approuvée. Un message s'affiche pour indiquer que l'application a transmis les données au moteur XLANG Scheduler. À ce stade, l'application est terminée. Un second message vous informe que la demande d'ordre d'achat a été approuvée. Cliquez sur OK pour fermer les boîtes de dialogue.

  6. Cliquez sur End pour fermer l'application ExecuteTutorial.

  7. Accédez au dossier C:\TutorialFiles\Seller.

    Il contient le fichier de paiement. Il s'appelle PaymentXXXX.xml, où XXXX est un ensemble unique de numéros. Double-cliquez sur le fichier pour l'ouvrir dans Microsoft Internet Explorer.

Vous avez soumis une requête d'ordre d'achat. Elle a été accordée et s'est terminée par l'envoi d'un message de paiement au système du vendeur.

Passez à Module 4 - Résumé.


Module 4 - Résumé

Dans ce module, vous avez accompli les tâches suivantes :

  • ajouter des actions de facture et de paiement. Pour plus d'informations, voir Connexion des formes.

  • implémenter un port d'échanges à l'aide des services d'échanges BizTalk. Pour plus d'informations sur l'implémentation d'un port d'échanges à l'aide des services d'échanges BizTalk, voir Utilisation de la forme Échanges BizTalk.

  • compiler et exécuter la planification XLANG terminée. Pour plus d'informations, voir Compilation des planifications XLANG et Exécution des planifications XLANG.

Les zones mises en surbrillance du schéma ci-après illustrent les procédures que vous avez effectuées dans ce module.

Envoyer
Paiement
Recevoir Facture
Décision
Req OA
>$1000
Fin
Recevoir
Req OA
Planification XLANG
Fonction réception fichier
Répertoire fichier acheteur
Composant WSC
Fichier ASP
File d'attente de mess.
Oui (Refuser)
Non
(Approuver)
Composant de script
Port d'échanges
Port d'échanges
Canal de la facture
Canal de l'OA
Canal
Port vers ProElectron
via HTTP
Port vers Bits, Bytes,
& Chips via AIC
Port vers Bits, Bytes, & Chips via fichier local
POtoINVAIC
SubmitProElectronPO
Port vers Bits, Bytes,
& Chips via HTTP
Canal de la
facture en paiement
Canal de
POReq en OA
Canal
Échanges BizTalk
Message Queuing
Action
Port
Données
Données
ExecuteTutorial
Fonction Recevoir requête OA chez ProElectron
DropInvoicetoMSMQ
ReceiveInvoice
PORequestApproval
ReceivePOReq
File d'attente de mess.
File d'attente de mess.
Application
Req OA
Req OA
Démarrer
Système de l'acheteur
Services d'Échanges BizTalk
Arrêter
AIC
OA pour Facture
Répertoire du fichier
du vendeur
Paiement
Vendeur
Acheteur
Paiement
Facture
Remarque : les flèches de direction indiquent le flux de données.
Facture
Facture
Mappage
Mappage
OA
OA
OA
OA
Fichier ASP
Système du vendeur
Orchestration BizTalk

Passez à Didacticiel - Résumé.

Voir aussi

Conception des orchestrations BizTalk


Didacticiel - Résumé

Dans ce didacticiel, vous avez configuré Microsoft BizTalk Server 2000 pour la définition et l'exécution d'un processus d'approvisionnement automatisé interentreprises.

L'illustration suivante représente le flux de données dans BizTalk Server lors de l'exécution de la planification XLANG Buyer2 à la fin du module 4.

Flux de données
Envoyer
Paiement
Recevoir Facture
Décision
Req OA
>$1000
Fin
Recevoir
Req OA
Planification XLANG
Fonction réception fichier
Rép. fic. acheteur
Composant WSC
Fichier ASP
File d'attente de mess.
Oui (Refuser)
Non
(Approuver)
Composant de script
Port d'échanges
Port d'échanges
Canal de la facture
Canal de l'OA
Canal
Port vers ProElectron
via HTTP
Port vers Bits, Bytes,
& Chips via AIC
Port vers Bits, Bytes, & Chips via Local File
POtoINVAIC
SubmitProElectronPO
Port vers Bits, Bytes,
& Chips via HTTP
Canal de la
facture en paiement
Canal de
POReq en OA
Canal
Échanges BizTalk
Message Queuing
Action
Port
Données
Données
ExecuteTutorial
Fonction Recevoir requête OA chez ProElectron
DropInvoicetoMSMQ
ReceiveInvoice
PORequestApproval
ReceivePOReq
Message Queuing
File d'attente de mess.
Application
Req OA
Req OA
Démarrer
Système de l'acheteur
Services d'échanges BizTalk
Arrêter
AIC
OA pour Facture
Rép. fic. vendeur
Paiement
Vendeur
Acheteur
Paiement
Facture
Remarque : les flèches de direction indiquent le flux de données.
Facture
Facture
Mappage
Mappage
OA
OA
OA
OA
Fichier ASP
Système du vendeur
Orchestration BizTalk

Vous vous êtes familiarisé au fonctionnement des composants et des services BizTalk Server pour l'intégration de processus professionnels asynchrones de longue durée, au sein des entreprises et entre les entreprises.

Vous avez également appris à :

  • utiliser le Concepteur d'Orchestration BizTalk pour modéliser des processus professionnels en créant un schéma de planification XLANG ;.

  • utiliser le Gestionnaire d'échanges BizTalk pour créer des organisations, des canaux, des ports d'échanges et des définitions de document ;

  • utiliser l'Éditeur BizTalk pour créer des spécifications ;

  • utiliser le Mappeur BizTalk pour créer des mappages

  • compiler et exécuter une planification XLANG.

Vous avez suivi le didacticiel avec succès. Pour plus d'informations détaillées sur la création des composants auxiliaires utilisés dans ce didacticiel, passez à l'Annexe : création de composants auxiliaires.


Annexe : création de composants auxiliaires

Dans cette annexe, vous allez apprendre à créer des composants auxiliaires qui fonctionnent avec Microsoft BizTalk Server 2000 pour traiter des données. Chaque composant, son rôle et sa relation dans le processus sont décrits en détails.

Plus particulièrement, vous allez créer :

  • une application sur le système de l'acheteur qui active une planification XLANG et envoie une requête d'ordre d'achat à une file d'attente de messages liée à la planification XLANG qui contrôle le flux des messages dans le système de l'acheteur ;

  • un composant de script Windows du système de l'acheteur qui accepte le statut d'accord ou de refus d'une requête d'ordre d'achat de la planification XLANG. Si la requête est accordée, ce composant affiche un message d'accord et écrit la requête d'ordre d'achat dans un répertoire de fichiers local, d'où les services d'échanges BizTalk du système de l'acheteur l'extrait. Si la requête est refusée, le composant affiche un message de refus et la planification prend fin ;

  • un composant d'intégration de l'application sur le système du vendeur qui génère une facture basée sur les données de l'ordre d'achat de l'acheteur ;

  • un fichier ASP du système de l'acheteur qui soumet un ordre d'achat à BizTalk Server ;

  • un fichier ASP du système du vendeur qui envoie une facture dans une file d'attente de messages.

Passez à Création de l'application.


Création de l'application

Dans cette rubrique, vous allez créer une application qui active une planification XLANG et place une requête d'ordre d'achat dans une file d'attente. Vous utilisez cette application pour tester l'implémentation de la planification XLANG et la configuration du Gestionnaire d'échanges BizTalk.

Pour terminer cet atelier, modifiez le code dans l'exemple de projet. Vous allez prendre en compte le code permettant d'activer la planification XLANG et de placer un message dans une file d'attente. Le code auxiliaire vous est fourni.

Chaque étape correspond à un segment de code. Examinez les blocs de commentaires identiques à l'exemple ci-dessous :

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'To Do:To Do : Step A
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

Ce code est suivi de lignes contenant des points d'interrogation (?) qui identifient des espaces réservés où vous devez effectuer une modification. Remplacez les points d'interrogation par le code approprié pour terminer l'atelier. Exemple :

Private g_MSMTxDisp As ?Private g_MSMTxDisp As ?

doit être remplacé par :

Private g_MSMTxDisp As MSMQ.MSMQTransactionDispenserPrivate g_MSMTxDisp As MSMQ.MSMQTransactionDispenser

Remarque

  • Ces lignes de code contiennent des commentaires. Veillez à supprimer le point d'interrogation au début des lignes que vous voulez modifier. Les étapes ne sont pas nécessairement classées dans la fenêtre de code.

Passez à Ouverture de l'application.


Ouverture de l'application

Accédez au dossier \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Lab sur le lecteur où est installé BizTalk Server.

Double-cliquez sur ExecuteTutorial.vbp.

Passez à Ajout des références requises à l'application.


Ajout des références requises à l'application

Cette procédure consiste à permettre à l'application d'implémenter les DLL requises pour utiliser Message Queuing, XML et Scripting Runtime.

  1. Dans le menu Projet, cliquez sur Références.

  2. Sélectionnez Microsoft Message Queue 2.0 Object Library.

    Le chemin complet de cette bibliothèque de types est \WINNT\System32\msxml2.dll.

  3. Sélectionnez Microsoft Scripting Runtime.

    Le chemin complet de cette DLL est \WINNT\System32\Scrun.dll.

  4. Sélectionnez Microsoft XML, v 3.0.

    Le chemin complet de cette DLL est \WINNT\System32\msxml3.dll.

  5. Cliquez sur OK.

Passez à Définition et initialisation des objets Message Queue.


Définition et initialisation des objets Message Queue

Cette procédure consiste à ajouter le code approprié pour utiliser les bibliothèques de types choisies. Les étapes portant une lettre dans la liste ci-dessous correspondent à celles du code fourni.

  1. Dans la fenêtre Projet, développez Formulaires, puis cliquez sur Formulaire1 (ExecuteTutorial.frm).

  2. Dans le menu Affichage, cliquez sur Code.

  3. Dans la section Général Déclarations de l'étape A du code, créez les objets Message Queue comme indiqué dans l'exemple suivant :
    Private g_MSMTxDisp As MSMQ.MSMQTransactionDispenserPrivate g_MSMTxDisp As MSMQ.MSMQTransactionDispenser
Private g_MSMQQueue As MSMQ.MSMQQueuePrivate g_MSMQQueue As MSMQ.MSMQQueue
Private g_MSMQInfo As MSMQ.MSMQQueueInfoPrivate g_MSMQInfo As MSMQ.MSMQQueueInfo
  4. Dans la section des événements Form_Load de l'étape B du code, initialisez les objets Message Queue comme indiqué dans l'exemple suivant.
    Set g_MSMQInfo = CreateObject("MSMQ.MSMQQueueInfo")Set g_MSMQInfo = CreateObject("MSMQ.MSMQQueueInfo")
Set g_MSMTxDisp = CreateObject("MSMQ.MSMQTransactionDispenser")Set g_MSMTxDisp = CreateObject("MSMQ.MSMQTransactionDispenser")

Passez à Ajout de code pour placer des données dans une file d'attente.


Ajout de code pour placer des données dans une file d'attente

Cette procédure consiste à ajouter un nouveau sous-programme appelé ExecuteMSMQ. Celui-ci est appelé par l'événement cmdRunSked_Click. Vous ajoutez le code pour appeler ce sous-programme dans la procédure suivante.

  • Placez le code suivant à la fin de la fenêtre de code de votre projet à l'étape C :
    Public Sub ExecuteMSMQ(ByVal strQueuePath As String, DataToQueue As String)
    Dim QueueMsg As New MSMQMessage

    Dim strData As String
    Dim fSend As Boolean
    Dim txt As TextStream
    Dim mybyte() As Byte

    g_MSMQInfo.FormatName = strQueuePath
    Set g_MSMQQueue = g_MSMQInfo.Open(MQ_SEND_ACCESS, MQ_DENY_NONE)
    mybyte = StrConv(DataToQueue, vbFromUnicode)
    QueueMsg.Body = DataToQueue

    Set MSMQTx = g_MSMTxDisp.BeginTransaction
    QueueMsg.send g_MSMQQueue, MSMQTx
    MSMQTx.Commit

    Set QueueMsg = NothingSet QueueMsg = Nothing
    Set MSMQTx = NothingSet MSMQTx = Nothing

End SubEnd Sub

Passez à Ajout de code pour activer la planification XLANG et appeler ExecuteMSMQ.


Ajout de code pour activer la planification XLANG et appeler ExecuteMSMQ

Cette procédure consiste à ajouter du code à l'événement cmdRunSked_Click qui active la planification XLANG et appelle le code qui place un message dans une file d'attente.

  1. Dans la section des événements cmdRunSked_Click de l'étape D du code, appelez ExecuteMSMQ, comme indiqué dans le code suivant :
    ExecuteMSMQ "DIRECT=OS:.\private$\ReceivePoReq", objfs.OpenTextFile(txtData.Text, ForReading).ReadAll
  2. Dans la section des événements cmdRunSked_Click de l'étape E du code, appelez GetObject pour instancier la planification XLANG par moniker, comme indiqué dans le code suivant :
    Set SendPAQ = GetObject(txtSked.Text)

Passez à Enregistrement et compilation de l'application.


Enregistrement et compilation de l'application

Cette procédure consiste à enregistrer et à compiler l'application.

  1. Dans le menu Fichier, cliquez sur Enregistrer le Projet.

  2. Dans le menu Fichier, cliquez sur Créer ExecuteTutorial.exe.

  3. Dans la boîte de dialogue Créer le projet, accédez au dossier \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Lab sur le lecteur où est installé BizTalk Server et cliquez sur OK.

Vous pouvez maintenant lancer l'application pour exécuter la planification de l'acheteur des modules 1 et 4.

Passez à Création du composant de script Windows (WSC).


Création du composant de script Windows (WSC)

Dans cette rubrique, vous allez créer un composant de script Windows lié à la planification XLANG. Le rôle de ce composant est d'afficher un message contenant le statut d'accord ou de refus de la requête d'ordre d'achat, et d'écrire éventuellement la requête d'ordre d'achat dans un fichier local si elle est accordée.

Passez à Ajout d'un script pour enregistrer le composant.


Ajout d'un script pour enregistrer le composant

Cette procédure consiste à ajouter un script permettant d'enregistrer le composant dans un fichier.

  1. Dans le menu Démarrer, pointez sur Programmes, puis sur Accessoires, et cliquez sur Bloc-notes.

  2. Ajoutez le script suivant :
    <?xml version="1.0"?><?xml version="1.0" ?>
<component><component>
<?component error="true" debug="true"?>
<registration
     description="PORequestApproval"
     progid="BTSTutorial.PORequestApproval"
     version="1.00"
     classid="{2938621b-40fc-48e2-827c-bed74e21a538}"
>
</registration>

    Étant donné que vous utilisez le même identificateur de classe que le composant prédéfini, l'ancien composant est remplacé dans le registre.

Passez à Ajout d'un script pour implémenter des méthodes.


Ajout d'un script pour implémenter des méthodes

Ce composant fournit trois méthodes. La première méthode envoie à l'utilisateur un statut d'accord sous la forme d'un message. La deuxième envoie à l'utilisateur un statut de refus, également sous la forme d'un message. Le choix de la décision relative à la méthode appelée est dicté par la règle de décision du schéma de planification XLANG. La dernière méthode écrit l'ordre d'achat dans un fichier local si la requête a été accordée.

  1. Ajoutez les trois signatures de méthode à la fin du fichier :
    <public><public>
     <method name="SendApproval"><method name="SendApproval">
          <PARAMETER name="Document"/><PARAMETER name="Document"/>
     </method></méthode>
     <method name="SendDenial"><method name="SendDenial">
          <PARAMETER name="Document"/><PARAMETER name="Document"/>
     </method></méthode>
     <method name="WriteToFile"><method name="WriteToFile">
          <PARAMETER name="Document"/><PARAMETER name="Document"/>
          <PARAMETER name="FileName"/><PARAMETER name="FileName"/>
     </method></method>
</public></public>
  2. Ajoutez le script qui implémente les méthodes jusqu'à la fin du fichier :
    <implements type="Behavior" id="Behavior"/><implements type="Behavior" id="Behavior"/>

<script language="VBScript"><script language="VBScript">
<![CDATA[<![CDATA[

function SendApproval(Document)function SendApproval(Document)
     MsgBox "Scheduler Engine Accepted document :" + vbcrlf + + vbcrlf + Document, 0, "Document Approval Received"
end functionend function

function SendDenial(Document)
     MsgBox "Scheduler Engine Denied document :" + vbcrlf + + vbcrlf + Document, 0, "Document Denied"
end functionend function

function WriteToFile(Document, FileName)
     dim objFileSys, strTimeNow

     if FileName = "" then
            FileName = "c:\TutorialFiles\Buyer\POReq*.xml"FileName = "c:\TutorialFiles\Buyer\POReq*.xml"
     end ifend if

'Generate a Unique Number used to generate unique files using a mask
   strTimeNow = left(Replace(CStr(FormatDateTime(Now(), 3)),":",""), 6)

'Create File System Object
     Set objFileSys = CreateObject("Scripting.FileSystemObject")Set objFileSys = CreateObject("Scripting.FileSystemObject")

'Create the Specified file, write the document data and close
     Set filestream = objFileSys.CreateTextFile(Replace(FileName, "*", strTimeNow), False)
     filestream.writeline Document
      filestream.close
end functionend function

]]>
</script></script>

</component></component>
  3. Dans le menu Fichier, cliquez sur Enregistrer sous.

    La boîte de dialogue Enregistrer sous apparaît.

  4. Accédez au dossier \Program Files\Microsoft BizTalk Server\Tutorial\Components\POReqApproval\Lab sur le lecteur où est installé BizTalk Server.

  5. Dans la zone Nom de fichier, tapez PoRequestApproval.wsc.

  6. Dans la zone Type de fichier, cliquez sur Tous les fichiers puis sur Enregistrer.

  7. Fermez le Bloc-notes.

  8. Accédez au dossier \Program Files\Microsoft BizTalk Server\Tutorial\Components\POReqApproval\Lab sur le lecteur où est installé BizTalk Server.

  9. Cliquez avec le bouton droit sur PoRequestApproval.wsc et cliquez sur Inscrire.

Ce composant peut être remplacé par le composant prédéfini dans le module 1. Pour utiliser ce dernier, vous devez supprimer le composant existant en liant à partir de la planification et créer une nouvelle liaison de composant qui pointe sur votre composant.

Passez à Suppression du composant de script Windows.


Suppression du composant de script Windows

Cette procédure consiste à supprimer le composant de script Windows du schéma de planification XLANG Acheteur2. Vous pouvez lier de nouveau le composant que vous avez créé.

  1. Dans le menu Démarrer, pointez sur Programmes, pointez sur Microsoft BizTalk Server 2000, puis cliquez sur Concepteur d'Orchestration BizTalk.

  2. Pour utiliser le schéma créé dans le module 4, ouvrez le fichier Acheteur2.skv contenu dans le dossier \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Lab sur le lecteur où est installé BizTalk Server.

    Pour utiliser le schéma Acheteur2 prédéfini, ouvrez le fichier Acheteur2.skv contenu dans le dossier \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Solution sur le lecteur où est installé BizTalk Server.

  3. Cliquez sur la forme Composant de script et appuyez sur SUPPR.

  4. Cliquez sur l'onglet Données.

  5. Supprimez les messages SendApproval, SendDenial et WritetoFile.

Vous êtes maintenant prêt à utiliser votre composant de script Windows dans la planification. Procédez comme suit :

  1. Implémentez un port sur Acheteur2.skv à l'aide de votre composant de script Windows. Pour un exemple, voir Implémentation d'un port à l'aide d'un composant de script. Cependant, utilisez votre composant et non celui de la procédure.

  2. Définissez la communication de la méthode de l'implementation du port. Pour un exemple, voir Définition des propriétés de message du composant de script.

  3. Définir le flux de données pour le port. Pour un exemple, voir Définition du flux de données.

  4. Enregistrez le fichier XLANG. Pour un exemple, voir Enregistrement du schéma de planification XLANG.

  5. Pour tester votre composant, exécutez l'application ExecuteTutorial qui se trouve dans le dossier \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Solution sur le lecteur où est installé BizTalk Server.

Passez à Création du composant d'intégration de l'application (AIC).


Création du composant d'intégration de l'application (AIC)

Dans cette rubrique, vous allez créer un nouveau composant d'intégration de l'application appelé POtoINVAIC qui convertit un document d'ordre d'achat en un document de facture à l'aide de MSXML DOM.

Passez à Création d'un projet DLL ActiveX pour le composant d'intégration de l'application.


Création d'un projet DLL ActiveX pour le composant d'intégration de l'application

  1. Démarrez Microsoft Visual Basic 6.0.

  2. Dans la boîte de dialogue Nouveau projet, cliquez sur l'onglet Nouveau, cliquez sur ActiveX DLL, puis sur Ouvrir.

    Un nouveau projet est créé pour votre composant, appelé Projet 1.

  3. Pour attribuer un nom plus significatif au projet et au contrôle, dans la fenêtre de l'arborescence du projet, cliquez sur Projet1. Dans la fenêtre des propriétés, remplacez la propriété (Nom) par POtoInvAIC.

  4. Dans la fenêtre de l'arborescence du projet, cliquez sur Class1(Class1). Dans la fenêtre des propriétés, remplacez la propriété (Nom) par ConvertPOtoInvoice.

Passez à Ajout des références appropriées au composant d'intégration de l'application.


Ajout des références appropriées au composant d'intégration de l'application

Cette procédure consiste à permettre au composant d'implémenter les interfaces requises par BizTalk Server 2000.

  1. Dans le menu Projet, cliquez sur Références.

  2. Cliquez sur Microsoft BizTalk Server Application Interface Components 1.0 Type Library.

    Le chemin complet de cette bibliothèque de types est \Program Files\Microsoft BizTalk Server\btscomplib.tlb.

  3. Sélectionnez Microsoft BizTalk Server Interchange 1.0 Type Library.

    Le chemin complet de cette bibliothèque de types est \Program Files\Microsoft BizTalk Server\cisapi.tlb.

  4. Sélectionnez Microsoft Scripting Runtime.

    Le chemin complet de cette DLL est \WINNT\System32\Scrun.dll. Utilisez cette bibliothèque pour créer un objet système de fichiers et ouvrir un flux de texte utilisé pour écrire un ordre d'achat sur le disque.

  5. Sélectionnez Microsoft XML, v 3.0.

    Le chemin complet de cette DLL est \WINNT\System32\msxml3.dll.

  6. Cliquez sur OK.

Passez à Implémentation de l'interface appropriée.


Implémentation de l'interface appropriée

Pour que BizTalk Server reconnaisse un composant comme composant d'intégration de l'application, il doit implémenter l'une des deux interfaces. Pour les besoins de ce didacticiel, vous allez implémenter l'interface IBTSAppIntegration.

  1. Dans la fenêtre Project, cliquez sur le module de la classe ConvertPOtoInvoice.

  2. Dans le menu Affichage, cliquez sur Code.

  3. Ajoutez la ligne de code suivante en haut de la fenêtre de code pour vous assurer que toutes les variables sont explicitement déclarées afin de minimiser les erreurs simples :
    Option Explicit
  4. Implémentez l'interface requise en ajoutant la ligne de code suivante après l'instruction Option Explicit :
    Implements IBTSAppIntegration

Passez à Définition et initialisation des objets de classe.


Définition et initialisation des objets de classe

Cette procédure consiste à ajouter le code approprié pour définir les objets de classe MSXML permettant de créer les fichiers XML à l'aide de DOM. Vous allez créer une variable de chaîne qui pointe sur la feuille de style du projet qui convertit un ordre d'achat en facture.

  1. Placez le code suivant en dessous de l'instruction Implements IBTSAppIntegration :
    'Class Object Defines
Private m_DOMCommonPO As MSXML2.DOMDocument
Private m_DOMStylesheet As MSXML2.DOMDocument
Private m_objSubmit As BTSInterchangeLib.Interchange

'Embedded Project Stylesheet to Convert CommonPO to CommonInvoice
Private m_strStylesheet As String
  2. Ajoutez le code suivant pour initialiser les objets XML DOM qui vont convertir l'ordre d'achat en facture, ainsi que l'objet Interchange qui soumet le document de facture final à BizTalk Server :
    Private Sub Class_Initialize()
'Create DOM/Interchange Objects
    Set m_DOMCommonPO = New MSXML2.DOMDocument
    Set m_DOMStylesheet = New MSXML2.DOMDocument
    Set m_objSubmit = New BTSInterchangeLib.Interchange

'Configure DOM Objects to be Synchronous
    m_DOMCommonPO.async = False
    m_DOMStylesheet.async = False

'Fill Stylesheet Embedded String
    m_strStylesheet = m_strStylesheet + ""

End SubEnd Sub

Passez à Implémentation de la méthode d'interface.


Implémentation de la méthode d'interface

La méthode ProcessMessage de l'interface IBTSAppIntegration prend en compte un document entrant d'ordre d'achat XML commun en provenance de BizTalk Server et interprète les données pour les convertir en un document de facture XML commun. Le document de facture commun est ensuite renvoyé à BizTalk Server. Le but est de simuler un système principal qui reçoit des ordres d'achat et renvoie éventuellement une facture pour ces ordres d'achat.

  1. Ajoutez les variables de définition de fonction et de dimension, comme dans le code suivant :
    Private Function IBTSAppIntegration_ProcessMessage( _
                                ByVal bstrDocument As String) As String
    Dim bstrInvoiceDocument As String
    Dim objScripting As New Scripting.FileSystemObject
'Initialize ProcessMessage to null
    IBTSAppIntegration_ProcessMessage = ""
  2. Ajoutez le code pour charger les données reçues dans un objet DOM et s'assurer que le format est correct en ajoutant le code suivant en dessous de l'instruction IBTSAppIntegration_ProcessMessage :
        m_DOMCommonPO.loadXML bstrDocument

    If m_DOMCommonPO.parseError.errorCode <> 0 Then 'The data was not valid XML
'Raised errors are not caught in the component, and will be sent back to 'BizTalk Server
        Err.Raise m_DOMCommonPO.parseError.errorCode, "AICSample.ConvertPOToInvoice Component", _
            "The provided document was not valid XML and could not be processed because:" + _
            vbCrLf + vbCrLf + m_DOMCommonPO.parseError.reason + vbCrLf + " on line: " + _
            CStr(m_DOMCommonPO.parseError.Line) + vbCrLf + "at position: " + _
            CStr(m_DOMCommonPO.parseError.linepos)
    End IfEnd If
  3. Ajoutez le code pour utiliser le fichier de ressource contenant le code XSL qui convertit un ordre d'achat en facture en ajoutant le code suivant en dessous de l'instruction End If :
        If m_strStylesheet = "" Then
        m_strStylesheet = StrConv(LoadResData(101, "CUSTOM"), vbUnicode)

    End IfEnd If
    m_DOMStylesheet.loadXML m_strStylesheet
    bstrInvoiceDocument = m_DOMCommonPO.transformNode(m_DOMStylesheet)

    If bstrInvoiceDocument = "" Then ' Mapping Failed Raise an Error
        Err.Raise vbObjectError + 100, "AICSample.ConvertPOToInvoice Component", _
            "The provided CommonPO document could not be translated into a Common Invoice " + _
            "as the map produced blank output."
    End IfEnd If
  4. Ajoutez le code pour soumettre le document de facture aux services d'échanges BizTalk en ajoutant le code suivant en dessous de l'instruction End If :
    IBTSAppIntegration_ProcessMessage = m_objSubmit.Submit(BIZTALK_OPENNESS_TYPE_NOTOPEN, bstrInvoiceDocument, , , "Bits,Bytes,Chips on Seller", , "ProElectron on Seller")

End FunctionEnd Function

    L'appel de soumission renvoie l'identification de soumission, qui dans le cas présent n'est pas utilisée.

Passez à Clôture des objets de classe.


Clôture des objets de classe

Pour s'assurer que tous les objets sont libérés de la mémoire lorsque la classe est terminée, ajoutez ce code à la fin de votre projet :

Private Sub Class_Terminate()
    Set m_DOMCommonPO = Nothing
    Set m_DOMStylesheet = Nothing
    Set m_objSubmit = Nothing
End SubEnd Sub

Passez à Création du fichier de ressources.


Création du fichier de ressource

Cette procédure consiste à ajouter le fichier de ressource contenant le XSL pour la transformation d'un ordre d'achat en facture.

  1. Dans le menu Compléments, cliquez sur Gestionnaire de compléments.

    La boîte de dialogue Gestionnaire de compléments apparaît.

  2. Cliquez sur Éditeur de ressources VB 6.

  3. Dans la zone Comportement, cliquez sur Charger/Décharger pour charger l'Éditeur de ressources, cliquez sur Charger au Démarrage, puis sur OK.

  4. Dans le menu Outils, cliquez sur Éditeur de ressources.

  5. Cliquez sur l'icône Ajouter une ressource personnalisée de la barre d'outils.

    La boîte de dialogue Ouvrir une ressource personnalisée apparaît.

  6. Accédez au dossier \Program Files\Microsoft BizTalk Server\Tutorial\Components\POtoInvoice\Lab, cliquez sur POtoINVAIC.txt, puis sur Ouvrir.

Attention

  • Vérifiez que l'identificateur de votre ressource est 101. Par défaut, la première ressource que vous créez porte l'identificateur 101, mais ce nombre s'incrémente de un si vous modifiez la ressource. Pour attribuer la valeur 101 à l'identificateur de la ressource, cliquez avec le bouton droit sur l'identificateur et cliquez sur Propriétés. Dans la zone ID, tapez 101.
  7. Cliquez sur l'icône Enregistrer.

    La boîte de dialogue Enregistrer le fichier de ressources sous apparaît.

  8. Accédez au dossier \Program Files\Microsoft BizTalk Server\Tutorial\Components\POtoInvoice\Lab.

  9. Dans la zone Nom de fichier, tapez POtoInvAICLab.RES et cliquez sur Enregistrer.

  10. Fermez l'Éditeur de ressource.

Passez à Création du composant et définition de la compatibilité binaire.


Création du composant et définition de la compatibilité binaire

Étant donné que vous créez un nouveau composant, vous devez le construire à ce stade, puis définir les propriétés du projet pour la compatibilité binaire avec la nouvelle DLL créée. La compatibilité binaire permet de s'assurer que chaque fois que vous compilez la DLL, vous ne générez pas un identificateur global unique (GUID) pour l'objet.

  1. Dans le menu Fichier, cliquez sur Enregistrer le projet sous.

    La boîte de dialogue Enregistrer le projet sous apparaît.

  2. Accédez au dossier \Program Files\Microsoft BizTalk Server\Tutorial\Components\POToInvoice\Lab sur le lecteur où est installé BizTalk Server.

  3. Dans la zone Nom de fichier, tapez ConvertPOtoInvoice.cls et cliquez sur Enregistrer.

    La boîte de dialogue Enregistrer le projet sous apparaît.

  4. Accédez au dossier \Program Files\Microsoft BizTalk Server\Tutorial\Components\POToInvoice\Lab sur le lecteur où est installé BizTalk Server.

  5. Dans la zone Nom de fichier, tapez POToInvAICLab et cliquez sur Enregistrer.

  6. Dans le menu Fichier, cliquez sur Créer POToInvAICLab.dll.

    La boîte de dialogue Créer le projet apparaît.

  7. Recherchez le dossier \Program Files\Microsoft BizTalk Server\Tutorial\Components\POToInvoice\Lab dans le répertoire d'installation de BizTalk Server et cliquez sur OK.

  8. Dans le menu Projet, cliquez sur Propriétés de POToInvAICLab.

  9. Cliquez sur l'onglet Composant.

  10. Cliquez sur Compatibilité binaire.

  11. Cliquez sur Parcourir ([...]) et accédez au dossier \Program Files\Microsoft BizTalk Server\Tutorial\POtoInvoice\Lab sur le lecteur où est installé BizTalk Server.

  12. Cliquez sur POToInvAICLab.dll puis sur Ouvrir.

  13. Cliquez sur OK.

Passez à Enregistrement du composant d'intégration de l'application.


Enregistrement du composant d'intégration de l'application

Cette procédure consiste à enregistrer le composant de script Windows pour qu'il soit reconnu par BizTalk Server. Celui-ci examine la liste des composants COM enregistrés, puis les interroge afin de déterminer lequel implémente l'interface IBTSAppIntegration ou IPipelineComponent. Tous les composants qui répondent à ce critère sont affichés dans une liste de composants dans le Gestionnaire d'échanges BizTalk.

  1. Dans le menu Démarrer, pointez sur Paramètres, puis cliquez sur Panneau de configuration.

  2. Double-cliquez sur Outils d'administration.

  3. Double-cliquez sur Services de composants.

    La console des services de composants s'affiche.

  4. Dans l'arborescence de la console, développez Services de composants, Ordinateurs, Poste de travail, et cliquez sur Applications COM+.

  5. Cliquez avec le bouton droit sur Applications COM+, pointez sur Nouveau et cliquez sur Application.

    L'Assistant Installation Application COM s'ouvre.

  6. Dans la page Assistant Installation d'Applications COM, cliquez sur Suivant.

  7. Dans la page Installater ou créer d'une nouvelle application, cliquez sur Créer une application vide.

  8. Dans la zone Entrez un nom pour la nouvelle application, tapez POToInvAICLab.

  9. Dans la zone Type d'activation, cliquez sur Application serveur puis sur Suivant.

  10. Dans la zone Compte, cliquez sur Utilisateur Interactif : l'utilisateur actuellement connecté puis sur Suivant.

    Remarque

    • L'utilisateur qui est connecté doit être membre du groupe d'administrateurs BizTalk Server et doit rester connecté pendant l'exécution de ce scénario.
  11. Cliquez sur Terminer.

  12. Dans l'arborescence de la console, développez Applications COM+ et développez le nouveau module que vous avez créé, appelé POToInvAICLab.

  13. Cliquez sur Composants.

  14. Accédez au dossier \Program Files\Microsoft BizTalk Server\Tutorial\Components\POtoInvoice\Lab sur le lecteur où est installé BizTalk Server.

  15. Faites glisser POToInvAICLab.dll dans le dossier Composants de Services de composants.

  16. Fermez Services de composants.

Vous pouvez maintenant reconfigurer le port pour utiliser le nouveau composant d'intégration de l'application, en procédant comme suit :

  1. Ouvrez le Gestionnaire d'échanges BizTalk.

  2. Dans la zone Rechercher, cliquez sur Ports d'échanges puis sur Rechercher.

  3. Dans la liste Nom du port d'échanges, double-cliquez sur Port to Bits,Bytes,Chips via AIC.

  4. Sur la page Informations générales, cliquez sur Suivant.

  5. Sur la page Organisation de destination, dans la zone Transport principal, cliquez sur Parcourir.

    La boîte de dialogue Transport principal s'affiche.

  6. Cliquez sur Parcourir.

  7. Dans la liste Composants disponibles, cliquez sur POToInvAICLab ConvertPOtoInvoice puis sur OK.

  8. Cliquez sur OK pour fermer la boîte de dialogue Transport principal, et cliquez sur Terminer.

  9. Testez votre composant en exécutant l'application qui se trouve dans le dossier \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Solution sur le lecteur où est installé BizTalk.


Administration de BizTalk Server 2000

L'administration de BizTalk Server 2000 est divisée de la manière suivante :

Installation de BizTalk Server 2000

Cette section fournit des informations sur l'installation de Microsoft BizTalk Server 2000. Elle contient des directives sur la configuration matérielle et logicielle requise, ainsi que des instructions sur l'installation complète, l'installation d'outils et l'installation personnalisée. Pour plus d'informations sur l'installation de Microsoft BizTalk Server 2000, voir Installation de BizTalk Server 2000.

Présentation de la sécurité

Cette section explique comment les entreprises peuvent échanger des données en toute sécurité avec des partenaires commerciaux lorsqu'elles utilisent BizTalk Server 2000. BizTalk Server tire parti des fonctions de sécurité incluses dans Microsoft Windows 2000 et Microsoft SQL Server. Pour plus d'informations sur la sécurité et sur BizTalk Server 2000, voir Présentation de la sécurité.

Amélioration des performances et de l'évolutivité

Cette section fournit des informations sur l'amélioration des performances de BizTalk Server et la création de solutions évolutives. Vous y trouverez des informations sur l'identification des goulots d'étranglement potentiels, la latence d'adressage et la gestion de bases de données. Pour plus d'informations sur la création d'une solution évolutive à hautes performances, voir Amélioration des performances et de l'évolutivité.

Administration des serveurs et des applications

Cette section présente le mode d'administration des serveurs et des applications associées à XLANG. Les rubriques qu'elle contient indiquent notamment comment centraliser la configuration et la gestion de serveurs en plusieurs groupes, configurer et gérer les fonctions de réception, configurer les Files d'attente partagées et gérer les applications COM+ qui hébergent des planifications XLANG. Pour plus d'informations sur l'administration des serveurs et des applications, voir Administration des serveurs et des applications.

Suivi de documents

Cette section fournit des informations sur le suivi d'échanges et de documents traités par BizTalk Server 2000. Les rubriques qu'elle contient indiquent notamment comment créer des requêtes et des requêtes avancées, comment enregistrer un échange, un document et des données de recherche personnalisée, et décrivent l'enregistrement d'échange, l'enregistrement de documents et les résultats de réception. Pour plus d'informations sur le suivi de documents, voir Suivi de documents.

Remarque

  • Le chemin d'accès aux fichiers permettant d'ouvrir divers services et outils Microsoft Windows 2000, tels que les services de composants et les outils d'administration, est différent selon que vous utilisez un ordinateur exécutant Windows 2000 Server ou Windows 2000 Professionnel. Pour plus d'informations, voir Ouverture des services de composants.

    Dans l'aide de Microsoft BizTalk Server 2000, les chemins d'accès à ces services et outils correspondent à une installation de Windows 2000 Server. Si vous utilisez Windows 2000 Professionnel, reportez-vous à l'aide correspondante pour plus d'informations sur l'ouverture du service ou de l'outil qui vous intéresse.

Voir aussi

Modèle d'administration de BizTalk


Installation de BizTalk Server 2000

Bienvenue dans le guide d'installation de Microsoft® BizTalk™ Server 2000. Vous y trouverez des conseils sur la configuration matérielle et logicielle requise, ainsi que des instructions complètes sur les options d'installation suivantes :

  • Installation complète. Permet d'effectuer une installation complète de tous les services et outils de BizTalk Server 2000.

  • Installation des outils. Permet d'effectuer une installation complète des outils de BizTalk Server 2000, à savoir le Concepteur d'orchestration BizTalk, le Suivi de documents BizTalk, l'Éditeur BizTalk et le Mappeur BizTalk. Le parseur, le sérialiseur, la corrélation et les binaires d'exécution de BizTalk Server 2000 ne sont pas installés.

  • Installation personnalisée. Permet d'effectuer une installation personnalisée incluant toute combinaison d'outils et de services de BizTalk Server 2000.

Ce guide contient les rubriques suivantes :

  • Configuration matérielle et logicielle requise

  • Instructions d'installation


Configuration matérielle et logicielle requise

Cette section contient des informations sur la configuration matérielle minimale et les options de configuration requises pour installer Microsoft BizTalk Server 2000. Elle contient également des instructions d'installation des logiciels préalables requis pour BizTalk Server 2000.

Cette section traite des rubriques suivantes :

  • Configuration matérielle minimale requise

  • Configuration recommandée pour optimiser les performances d'échanges de document

  • Configuration logicielle requise

  • Conditions préalables de Windows 2000

  • Installation de SQL Server 7.0 ou de SQL Server 2000

  • Installation de Visio 2000 SR-1A


Configuration matérielle minimale requise

La configuration matérielle minimale d'une installation de base de Microsoft BizTalk Server 2000 comprend les éléments suivants :

  • Un processeur Intel® Pentium 300.

  • 128 méga-octets (Mo) de mémoire RAM.

  • Un disque dur de 6 Go.

  • Un lecteur de CD-ROM.

  • Une carte réseau.

  • Un écran VGA ou Super VGA.

  • Une souris Microsoft ou autre dispositif de pointage compatible.


Configuration recommandée pour optimiser les performances d'échanges de documents

Voici des conseils d'optimisation des performances de BizTalk Server 2000 :

  • Créez une configuration constituée de trois ordinateurs. Dans cette configuration, installez BizTalk Server 2000 sur le premier ordinateur, la base de données Suivi sur le deuxième ordinateur et les bases de données Gestion d'échanges et Files d'attente partagées sur le troisième ordinateur.

  • Pour une configuration dans laquelle un seul serveur exécute toutes les fonctions de traitement et de réception, configurez deux serveurs BizTalk Server 2000, l'un dédié au traitement et l'autre à la réception.

  • Installez la base de données Suivi sur un ordinateur disposant de plusieurs disques durs. La configuration optimale inclut quatre disques durs SCSI II et un contrôleur SCSI II. Le premier disque dur est dédié à l'enregistrement du suivi des documents ; le deuxième est dédié au fichier de page système Microsoft Windows® 2000 ; le troisième est dédié au journal des transactions de suivi et le quatrième au journal DTC (Distributed Transaction Coordinator).

  • Créez plusieurs instances des fonctions de réception pour contrôler plusieurs emplacements de réception des documents à traiter. Pour équilibrer la charge des documents sur plusieurs ordinateurs, placez les fonctions de réception sur des ordinateurs distincts. Chaque emplacement de contrôle doit être unique et comporter une fonction de réception distincte. Pour éviter de surcharger chaque fonction de réception, l'application professionnelle qui envoie les documents doit les répartir équitablement entre tous les emplacements de contrôle.

Important

  • Pour plus d'informations sur l'amélioration des performances de BizTalk Server, voir Amélioration des performances et de l'évolutivité.


Configuration logicielle requise

Le tableau suivant présente les logiciels à installer pour exécuter Microsoft BizTalk Server 2000.

Installation complète | Installation des outils | Installation personnalisée
Microsoft Windows 2000 Server, Microsoft Windows 2000 Advanced Server ou Microsoft Windows 2000 Professionnel avec le système de fichiers NTFS et Service Pack 1 | Microsoft Windows 2000 Server, Microsoft Windows 2000 Advanced Server ou Microsoft Windows 2000 Professionnel avec le système de fichiers NTFS et Service Pack 1 | Microsoft Windows 2000 Server, Microsoft Windows 2000 Advanced Server ou Microsoft Windows 2000 Professionnel avec le système de fichiers NTFS et Service Pack 1
Microsoft Internet Explorer 5 ou ultérieur | Microsoft Internet Explorer 5 ou ultérieur | Microsoft Internet Explorer 5 ou ultérieur
Microsoft Visio® 2000 SR-1A ou version ultérieure (nécessaire pour utiliser le Concepteur d'orchestration BizTalk) | Microsoft Visio 2000 SR-1A ou version ultérieure (nécessaire pour utiliser le Concepteur d'orchestration BizTalk) | Microsoft Visio 2000 SR-1A ou version ultérieure (nécessaire pour utiliser le Concepteur d'orchestration BizTalk)
Microsoft SQL Server™ 7.0 et SQL Server Service Pack 2 (SP2) ou SQL Server 2000 | Microsoft SQL Server 7.0 et SQL Server Service Pack 2 (SP2)* ou SQL Server 2000
Remarque
  • Le Gestionnaire d'échanges BizTalk ne peut fonctionner que si le service de publication World Wide Web est actif.
 Remarque
  • Le Gestionnaire d'échanges BizTalk ne peut fonctionner que si le service de publication World Wide Web est actif.
 Remarque
  • Le Gestionnaire d'échanges BizTalk ne peut fonctionner que si le service de publication World Wide Web est actif.

*Microsoft SQL Server est requis pour une installation personnalisée si vous installez les services principaux de BizTalk. Il n'est pas requis pour l'installation des outils.


Conditions préalables de Windows 2000

Microsoft Windows 2000 Server, Microsoft Windows 2000 Advanced Server et Microsoft Windows 2000 Professionnel avec Service Pack 1 constituent les plates-formes recommandées pour toutes les installations de Microsoft BizTalk Server 2000. Étant donné que BizTalk Server 2000 a fait l'objet de tests approfondis sous Windows 2000 avec Service Pack 1, ce guide d'installation contient des informations détaillées sur la configuration requise de Windows 2000 Server, Windows 2000 Advanced Server et Windows 2000 Professionnel en association avec BizTalk Server. Après avoir installé Windows 2000 Server, Windows 2000 Advanced Server ou Windows 2000 Professionnel avec Service Pack 1, vous devez ajouter un compte utilisateur Windows 2000 au groupe d'administrateurs avant d'installer tout logiciel. Pour plus d'informations, voir Ajout d'un compte utilisateur au groupe d'administrateurs. Vous devez également installer Message Queuing. Pour plus d'informations, voir Installation de Message Queuing. Si votre installation n'inclut pas Service Pack 1, vous devez l'installer. Pour plus d'informations, voir Installation de Windows 2000 Service Pack 1.

Cette section traite des rubriques suivantes :

  • Installation de Windows 2000 Server, Windows 2000 Advanced Server ou Windows 2000 Professionnel avec Service Pack 1

  • Installation de Windows NT 2000 Service Pack 1

  • Installation de Message Queuing

  • Installation des services Internet (IIS)

  • Configuration des paramètres IIS de BizTalk Server 2000

  • Configuration des comptes utilisateur


Installation de Windows 2000 Server, Windows 2000 Advanced Server ou Windows 2000 Professionnel avec Service Pack 1

Si Windows 2000 Server, Windows 2000 Advanced Server ou Windows 2000 Professionnel est installé sur votre ordinateur, veillez à respecter les conditions requises de l'étape 2 ci-dessous.

  1. Insérez le CD-ROM d'installation de Windows 2000 Server, Windows 2000 Advanced Server ou Windows 2000 Professionnel avec Service Pack 1 dans le lecteur approprié.

    Si vous ne disposez pas d'une version de Windows 2000 dotée de Service Pack 1, installez d'abord Windows 2000, puis Service Pack 1 séparément.

  2. Exécutez le programme d'installation de Windows 2000 Server, Windows 2000 Advanced Server ou Windows 2000 Professionnel avec Service Pack 1 et suivez les instructions en ligne.

    Respectez les conditions suivantes :

    • N'utilisez que des caractères alphanumériques dans les noms d'ordinateur car Microsoft SQL Server prend en charge un jeu de caractères limité dans les noms de serveur.

    • Formatez la partition à l'aide de NTFS (Windows NT File System).

    • Sur la page Composants Windows 2000, dans la liste Composants, cliquez sur Services Message Queuing. Si vous installez Windows 2000 Professionnel, cliquez sur Services Internet (IIS) et sur Suivant. Sur la page Type de Message Queuing, cliquez sur Suivant.

    • Sur la page Paramètres de réseau, cliquez sur Paramètres par défaut.

Remarques

  • Après avoir installé Windows 2000 Server, Windows 2000 Advanced Server ou Windows 2000 Professionnel avec Service Pack 1, vous devez ajouter un compte utilisateur Windows 2000 au groupe d'administrateurs avant d'installer tout logiciel. Pour plus d'informations, voir Ajout d'un compte utilisateur au groupe d'administrateurs.

  • Si vous n'avez pas sélectionné Services Message Queuing sur la page Composants Windows 2000 lors de l'installation, vous devez procéder à l'installation. Pour plus d'informations, voir Installation de Message Queuing.

  • Si vous n'avez pas sélectionné Services Internet (IIS) sur la page Composants Windows 2000 lors de l'installation de Windows 2000 Professionnel, vous devez procéder à l'installation. Pour plus d'informations, voir Installation des services Internet (IIS).

  • Si votre installation n'inclut pas Service Pack 1, vous devez l'installer. Pour plus d'informations, voir Installation de Windows 2000 Service Pack 1.

  • La partition Windows 2000 Server, Windows 2000 Advanced Server ou Windows 2000 Professionnel doit être convertie dans la dernière version du système de fichiers NTFS. Le programme d'installation effectue automatiquement cette mise à jour si le système de fichiers existant est l'ancienne version de NTFS. Si la partition existante est FAT ou FAT32, vous avez la possibilité de passer à NTFS. Lorsque vous êtes invité à le faire, choisissez NTFS.


Installation de Windows NT 2000 Service Pack 1

  1. Insérez le CD-ROM d'installation de Windows 2000 Service Pack 1 dans le lecteur approprié.

    Vous pouvez également accéder à la zone des téléchargement du site Web de Microsoft Windows 2000 (www.microsoft.com/france/windows2000/) pour télécharger Windows 2000 Service Pack 1 ou commander le CD-ROM.

  2. Exécutez le programme d'installation de Windows 2000 Service Pack 1 et suivez les instructions en ligne.


Installation de Message Queuing

  1. Dans le menu Démarrer, pointez sur Paramètres, puis cliquez sur Panneau de configuration.

  2. Double-cliquez sur Ajout/Suppression de programmes.

    La boîte de dialogue Ajout/Suppression de programmes apparaît.

  3. Cliquez sur Ajouter/Supprimer des composants Windows.

    L'Assistant Composants de Windows s'ouvre.

  4. Dans la liste Composants, activez la case à cocher Services Message Queuing et cliquez sur Suivant.

  5. Sur la page Type de Message Queuing, cliquez sur Suivant.

  6. Cliquez sur Terminer pour fermer l'Assistant.

Remarque

  • Acceptez les paramètres par défaut lors de l'installation du composant Services Message Queuing.


Installation des services Internet (IIS)

  1. Dans le menu Démarrer, pointez sur Paramètres, puis cliquez sur Panneau de configuration.

  2. Double-cliquez sur Ajout/Suppression de programmes.

    La boîte de dialogue Ajout/Suppression de programmes apparaît.

  3. Cliquez sur Ajouter/Supprimer des composants Windows.

    L'Assistant Composants de Windows s'ouvre.

  4. Dans la liste Composants, activez la case à cocher Services Internet (IIS) et cliquez sur Suivant.

  5. Cliquez sur Terminer pour fermer l'Assistant.


Configuration des paramètres IIS de BizTalk Server 2000

Pour éviter les problèmes d'accès et d'enregistrement des spécifications dans le référentiel BizTalk Server 2000, vous devez désactiver l'option Activer les opérations d'auteur des services Internet (IIS).

  1. Dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration, puis sur Services de composant.

  2. Cliquez sur l'icône de l'identificateur de développement (+) du serveur IIS local.

  3. Cliquez avec le bouton droit sur Site Web par défaut et cliquez sur Propriétés.

    La boîte de dialogue Propriétés de Site Web par défaut apparaît.

  4. Cliquez sur l'onglet Extensions serveur et désactivez la case à cocher Activer les opérations d'auteur.


Configuration des comptes utilisateur

Si vous installez BizTalk Server 2000 à des fins de développement uniquement, vous pouvez créer un compte utilisateur standard. Pour plus d'informations, voir Ajout d'un compte utilisateur au groupe d'administrateurs. Si vous l'installez à des fins de production, vous devez créer un compte de services. Pour plus d'informations, voir Création d'un compte de services. Si vous ne créez pas de compte de services, c'est-à-dire un compte normal ayant des propriétés, BizTalk Server 2000 est configuré automatiquement pour l'utilisateur interactif (celui qui est connecté pendant la procédure d'installation). Si BizTalk Server 2000 est configuré avec un utilisateur interactif, il tombera en panne si l'utilisateur indiqué se déconnecte du serveur.

Cette section traite des rubriques suivantes :

  • Ajout d'un compte utilisateur au groupe d'administrateurs

  • Création d'un compte de services


Ajout d'un compte utilisateur au groupe d'administrateurs

  1. Connectez-vous en tant qu'administrateur.

    Dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration puis sur Gestion de l'ordinateur.

  2. Dans l'arborescence de la console, cliquez sur l'icône de l'identificateur de développement (+) en regard de Utilisateurs et groupes locaux.

  3. Cliquez sur Groupes et, dans le volet des détails, double-cliquez sur Administrateurs.

    La boîte de dialogue Propriétés de Administrateurs s'affiche.

  4. Cliquez sur Ajouter.

  5. Dans la liste Regarder dans, cliquez sur le nom de votre ordinateur.

  6. Dans la zone contenant le texte <<Entrez des noms séparés par des points-virgules ou choisissez à partir de la liste>>, supprimez le texte et tapez votre nom de domaine et d'utilisateur dans le format suivant :

    Nom de domaine\nom d'utilisateur

  7. Cliquez sur OK.

  8. Si nécessaire, sur la page Saisie du mot de passe réseau, complétez les champs suivants :
    • Dans la zone Se connecter en tant que, tapez votre nom de domaine et d'utilisateur dans le format suivant :

      Nom de domaine\nom d'utilisateur

    • Dans la zone Mot de passe, tapez le mot de passe associé à votre nom d'utilisateur et cliquez sur OK.

    • Cliquez sur OK pour fermer la boîte de dialogue Propriétés de Administrateurs.
  9. Si nécessaire, redémarrez l'ordinateur et connectez-vous à l'aide de votre compte utilisateur de domaine.


Création d'un compte de services

  1. Connectez-vous en tant qu'administrateur.

  2. Dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration puis sur Gestion de l'ordinateur.

    La boîte de dialogue Gestion de l'ordinateur s'affiche.

  3. Dans l'arborescence de la console, cliquez sur l'icône de l'identificateur de développement (+) en regard de Outils système et cliquez sur Utilisateurs et groupes locaux.

  4. Cliquez sur Utilisateurs, cliquez avec le bouton droit sur le volet des détails, puis cliquez sur Nouvel utilisateur.

    La boîte de dialogue Nouvel utilisateur apparaît.

  5. Dans la zone Nom d'utilisateur, tapez un nom pour le compte de services. Dans la zone Mot de passe, tapez un mot de passe et tapez le même mot de passe dans la zone Confirmer le mot de passe.

  6. Désactivez la case à cocher L'utilisateur doit changer de mot de passe à la prochaine ouverture de session, cliquez sur Créer, puis sur Fermer.

  7. Fermez la fenêtre Gestion de l'ordinateur.

  8. Dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration, puis sur Stratégie de sécurité locale.

    La boîte de dialogue Paramètres de sécurité locale apparaît.

  9. Dans l'arborescence de la console, cliquez sur l'icône de l'identificateur de développement (+) en regard de Stratégies locales et cliquez sur Attribution des droits utilisateur.

  10. Dans le volet des détails, double-cliquez sur Agir en tant que partie du système d'exploitation, cliquez sur Ajouter, cliquez sur le nom de compte que vous venez de créer dans la zone de liste, cliquez sur Ajouter, puis sur OK à deux reprises.

  11. Répétez les étapes 8 à 10 pour la stratégie Connexion en tant que service.

Si BizTalk Server 2000 est déjà installé et utilise le compte utilisateur interactif, effectuez les étapes suivantes après avoir créé le compte de services.

  1. Dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration et sur Services.

  2. Dans le volet des détails, double-cliquez sur Services d'échanges BizTalk.

    La boîte de dialogue Propriétés de Service d'échanges BizTalk (Ordinateur local) s'affiche.

  3. Cliquez sur l'onglet Connexion, puis sur Ce compte.

  4. Cliquez sur Parcourir, localisez le nom de compte utilisateur que vous avez créé et double-cliquez sur ce nom.

  5. Dans la zone Mot de passe, tapez le mot de passe que vous avez associé au nom de compte utilisateur ; dans la boîte de dialogue de confirmation, tapez de nouveau le mot de passe et cliquez sur OK.

  6. Un message apparaît ; cliquez sur OK.

  7. Redémarrez l'ordinateur.


Installation de SQL Server 7.0 ou de SQL Server 2000

Avant d'installer Microsoft BizTalk Server 2000, vous devez installer Microsoft SQL Server 7.0 et SQL Server Service Pack 2 (SP2) ou Microsoft SQL Server 2000. Lors de l'installation de BizTalk Server 2000, le programme d'installation crée quatre bases de données BizTalk Server 2000 (Gestion d'échanges BizTalk, Files d'attente partagées, Suivi et Persistance d'orchestration) dans SQL Server.

Important

  • Si vous prévoyez d'installer BizTalk Server 2000 sur un ordinateur doté de Microsoft Windows 2000 Professionnel avec Service Pack 1, vous devez installer SQL Server 7.0 et SQL Server Service Pack 2 (SP2) ou SQL Server 2000 sur un autre ordinateur. Windows 2000 Professionnel ne prend pas en charge les installations de SQL Server 7.0 ou SQL Server 2000. Lorsque vous installez les bases de données de BizTalk Server 2000, vous devez indiquer le nom de l'ordinateur sur lequel SQL Server 7.0 ou SQL Server 2000 est installé.

Avant d'installer SQL Server, vérifiez que votre compte d'ouverture de session est un membre du groupe d'administrateurs de Windows 2000 sur lequel vous voulez installer SQL Server. Pour plus d'informations, voir Ajout d'un compte utilisateur au groupe d'administrateurs.

Si vous installez SQL Server 2000, vous devez spécifier une authentification mixte. Par défaut, lorsque vous installez SQL Server 2000, le mode d'authentification est défini pour Windows 2000 uniquement. BizTalk Server 2000 utilise l'authentification SQL pour accéder aux bases de données Gestion d'échanges BizTalk, Files d'attente partagées et Suivi et ne fonctionne pas avec ce paramètre. Avant d'installer BizTalk Server 2000, vérifiez que le mode d'authentification est défini sur Mixte. Pour plus d'informations, voir Définition du mode d'authentification SQL pour SQL Server 2000.

Si vous installez SQL Server sur un cluster et prévoyez d'installer BizTalk Server 2000 sur un autre ordinateur, vous devez installer les outils clients de SQL Server sur l'ordinateur doté de BizTalk Server 2000. Un cluster est un ensemble de serveurs qui agissent comme un seul serveur. Pour plus d'informations, voir Installation des outils clients SQL Server. Lorsque vous avez terminé, vous devez utiliser l'Utilitaire réseau client pour attribuer TCP/IP à la bibliothèque réseau par défaut des canaux nommés. Pour plus d'informations, voir Attribution de TCP/IP à la bibliothèque de réseau par défaut

Lorsque vous installez SQL Server 7.0 ou SQL Server 2000, il est important d'utiliser les paramètres de classement appropriés. Le terme classement fait référence à un ensemble de règles qui déterminent le mode de tri et de comparaison des données. Les données de type caractère sont triées d'après des règles qui définissent la séquence de caractères appropriée à l'aide d'options portant sur le respect de la casse, les accents, les caractères de type Kana ou la largeur des caractères. Par exemple, pour enregistrer des caractères japonais, sélectionnez l'ordre de tri faisant la distinction entre les majuscules et les minuscules pour différencier le japonais-Hiragana du japonais-Katakana lors de l'installation de SQL Server. Pour plus d'informations sur les paramètres de classement, dans le menu Démarrer, pointez sur Programmes et sur Microsoft SQL Server, puis cliquez sur Documentation en ligne. Les rubriques Utilisation du classement SQL et Styles de tri des classements Windows contiennent des informations supplémentaires.

Cette section traite des rubriques suivantes :

  • Installation de SQL Server 7.0 ou 2000

  • Vérification de SQL Server 7.0 Service Pack 2

  • Installation de SQL Service Pack 2 pour SQL Server 7.0

  • Installation des outils clients SQL Server

  • Attribution de TCP/IP à la bibliothèque de réseau par défaut

  • Définition du mode d'authentification SQL pour SQL Server 2000

  • Vérification du bon fonctionnement de SQL Server

  • Éviter l'allocation d'espace disque inutile

  • Interactions entre SQL Server et les bases de données BizTalk Server 2000


Installation de SQL Server 7.0 ou 2000

  1. Insérez le CD-ROM d'installation de Microsoft SQL Server dans le lecteur approprié.

  2. Exécutez le programme d'installation de SQL Server et suivez les instructions en ligne.

    L'Assistant Installation vous guide au cours des étapes nécessaires à l'installation de SQL Server, mais vous devez respecter les conditions suivantes :

    • Sur la page Type d'installation, cliquez sur Par défaut.

    • Sur la page Comptes de services, utilisez un nom d'utilisateur de domaine (en cas de connexion à un réseau).

    • Lors de l'installation de SQL Server 2000, spécifiez le mode d'authentification mixte.

Important

  • Si vous installez SQL Server 7.0, vous devez installer SQL Service Pack 2 (SP2). Vous pouvez vérifier si Service Pack 2 est installé à l'aide de l'Analyseur de requêtes. Pour plus d'informations, voir Vérification de SQL Server 7.0 Service Pack 2. Pour plus d'informations sur l'installation de SQL SP2, voir Installation de SQL Service Pack 2 pour SQL Server 7.0.


Vérification de SQL Server 7.0 Service Pack 2

  1. Dans le menu Démarrer, pointez sur Programmes et sur Microsoft SQL Server 7.0, puis cliquez sur Analyseur de requêtes.

    La boîte de dialogue Connexion à SQL Server s'affiche.

  2. Cliquez sur OK.

    Si le nom de votre serveur n'apparaît pas dans la liste SQL Server, sélectionnez-le ou tapez-le et cliquez sur OK.

  3. Dans la zone de texte Requête, tapez SELECT @@VERSION.

  4. Dans le menu Requête, cliquez sur Exécuter.

    La première ligne du résultat de la requête contient la version de SQL Server en cours d'exécution. Si vous avez installé SP2, vous devez obtenir 7.00.842.


Installation de SQL Service Pack 2 pour SQL Server 7.0

  1. Insérez le CD-ROM d'installation de SQL Service Pack 2 dans le lecteur approprié.

  2. Exécutez le programme d'installation de SQL Service Pack 2 et suivez les instructions en ligne.


Installation des outils clients SQL Server

  1. Insérez le CD-ROM d'installation de Microsoft SQL Server dans le lecteur approprié.

  2. Exécutez le programme d'installation de SQL Server et suivez les instructions en ligne.

    L'Assistant Installation vous guide au cours des étapes nécessaires à l'installation de SQL Server, mais vous devez respecter les conditions suivantes :

    • Sur la page Choix de l'installation, cliquez sur Créer une nouvelle instance de SQL Server ou installer des outils client

    • Sur la page Choix de l'installation, cliquez sur Outils clients uniquement.


Attribution de TCP/IP à la bibliothèque de réseau par défaut

  1. Dans le menu Démarrer, pointez sur Programmes et sur Microsoft SQL Server 7.0 ou Microsoft SQL Server, puis cliquez sur Utilitaire Réseau Client.

    La boîte de dialogue Utilitaire Réseau Client SQL Server apparaît.

  2. Si vous avez installé Microsoft SQL Server 7.0, dans l'onglet Général, dans la liste Bibliothèque réseau par défaut, cliquez sur TCP/IP.

    -ou-

    Si vous avez installé Microsoft SQL Server 2000, dans l'onglet Bibliothèques réseau, dans la liste Bibliothèque réseau, cliquez sur TCP/IP.

  3. Cliquez sur OK.


Définition du mode d'authentification SQL pour SQL Server 2000

  1. Cliquez sur Démarrer, pointez sur Programmes et sur Microsoft SQL Server, puis cliquez sur Enterprise Manager.

  2. Cliquez sur l'icône de l'identificateur de développement (+) en regard de Serveurs Microsoft SQL et Groupe SQL Server.

  3. Cliquez avec le bouton droit sur le nom de votre serveur, puis cliquez sur Propriétés.

    La boîte de dialogue Propriétés de SQL Server apparaît.

  4. Cliquez sur l'onglet Sécurité, sur SQL Server et Windows, puis sur OK.


Vérification du bon fonctionnement de SQL Server

Avant d'installer BizTalk Server 2000, vérifiez que SQL Server fonctionne sur votre serveur. Cette opération est nécessaire car BizTalk Server 2000 doit créer quatre bases de données pendant l'installation.

  1. Dans le menu Démarrer, pointez sur Programmes et sur Microsoft SQL Server (si vous avez installé SQL Server 2000) ou Microsoft SQL Server 7.0 (si vous avez installé SQL Server 7.0), puis cliquez sur Gestionnaire de services.

    La boîte de dialogue Gestionnaire des Services SQL Server apparaît.

  2. Dans la liste Serveur, vérifiez que le nom du serveur est celui de votre ordinateur.

    Si ce n'est pas le cas, cliquez sur la flèche de la liste déroulante pour afficher la liste des serveurs disponibles et faites défiler pour localiser votre serveur.

  3. Dans la liste Services, cliquez sur MSSQLServer (pour SQL Server 7.0) ou sur SQL Server (pour SQL Server 2000).

  4. Vérifiez que le service MSSQLServer ou SQL Server fonctionne.

    Le service fonctionne si le bouton Démarrer/Continuer de la boîte de dialogue n'est pas disponible. De même, en bas de la boîte de dialogue, un message indique que le service fonctionne. Par exemple, \\<nom serveur>—MSSQLServer—Running.

  5. Si le service ne fonctionne pas, le bouton Démarrer/Continuer est disponible. Cliquez dessus pour démarrer le service.


Éviter l'allocation d'espace disque inutile

  1. Cliquez sur Démarrer, pointez sur Programmes, sur Microsoft SQL Server 7.0 ou Microsoft SQL Server, puis cliquez sur Enterprise Manager.

  2. Cliquez sur l'icône de l'identificateur de développement (+) en regard de Serveurs Microsoft SQL, Groupe SQL Server, <nom serveur> et Bases de données.

  3. Cliquez avec le bouton droit sur la base de données Gestion d'échanges BizTalk et cliquez sur Propriétés.

    La boîte de dialogue de propriétés de la base de données Gestion d'échanges BizTalk s'affiche.

  4. Cliquez sur l'onglet Options.

  5. Dans la zone Paramètres, activez les cases à cocher Vider le journal au point de contrôle et Réduction automatique et cliquez sur OK.

Remarque

  • Si Microsoft SQL Server 2000 est installé, vous pouvez activer uniquement la case à cocher Réduction automatique.
  6. Répétez les étapes 3 à 5 pour les bases de données Suivi et Files d'attente partagées.

Important

  • Vous ne pouvez suivre cette procédure que si vous avez installé BizTalk Server 2000. Pour plus d'informations sur l'installation de BizTalk Server 2000, voir Instructions d'installation.

    Remarque

  • Pendant l'installation, l'objet base de données Gestion d'échanges BizTalk prend par défaut le nom InterchangeBTM ; l'objet base de données Suivi prend par défaut le nom InterchangeDTA et l'objet base de données Files d'attente partagées le nom InterchangeSQ. Vous pouvez avoir renommé ces objets bases de données par défaut pendant l'installation.


Interactions entre SQL Server et les bases de données BizTalk Server 2000

Pour éviter l'allocation d'espace disque inutile, utilisez les fonctions Vider le journal au point de contrôle et Réduction automatique de Microsoft SQL Server. Sinon, les connexions à SQL Server peuvent consommer des espaces disque importants.

Voir aussi

Éviter l'allocation d'espace disque inutile


Installation de Visio 2000 SR-1A

Étant donné que le Concepteur d'orchestration de BizTalk est une interface utilisateur basée sur Microsoft Visio 2000, le service Visio 2000 version 1A doit être installé sur votre ordinateur avant toute utilisation du Concepteur d'orchestration BizTalk. Celui-ci a été testé avec Visio 2000 Standard Edition SR-1A, et peut fonctionner avec les versions ultérieures de Visio.

Cette section traite de la rubrique suivante :

  • Installation de Visio 2000 Standard Edition SR-1A


Installation de Visio 2000 Standard Edition SR-1A

  1. Insérez le CD-ROM d'installation de Visio 2000 Standard Edition SR-1A (ou une version ultérieure de Visio 2000 Standard Edition) dans le lecteur approprié.

  2. Exécutez le programme d'installation de Visio 2000 Standard Edition SR-1A et suivez les instructions en ligne.

Remarque

  • Pour plus d'informations, consultez la documentation de Microsoft Visio 2000 Standard Edition SR-1A.


Instructions d'installation

Vous pouvez installer Microsoft BizTalk Server 2000 à l'aide de l'Assistant Installation (Microsoft BizTalk Server.msi) ou de Microsoft Windows Installer (Msiexec.exe). L'Assistant Installation est une procédure pas à pas au cours de laquelle vous sélectionnez des options correspondant à des valeurs de propriété spécifiques. Microsoft Windows Installer vous permet d'indiquer des valeurs de propriétés sur la ligne de commande. Vous pouvez utiliser cette méthode pour installer BizTalk Server 2000 en mode silencieux (sans interaction ou invites de commande permanentes). Une installation en mode silencieux constitue une solution idéale pour les scénarios de test ou dans le cadre d'un déploiement à grande échelle au sein d'une entreprise. Quel que soit le type d'installation choisi, il est recommandé de conserver un enregistrement des informations suivantes pour une utilisation ultérieure :

  • Noms de groupe de serveurs BizTalk Server

  • Noms SQL Server

  • Noms d'utilisateur

  • Mot de passe

  • Nom de la base de données Gestion d'échanges BizTalk

  • Nom de la base de données Suivi

  • Nom de la base de données Files d'attente partagées

  • URL du référentiel WebDAV

Important

  • BizTalk Server 2000 nécessite l'analyseur Microsoft XML version 3.0. Cette version de BizTalk Server 2000 installe automatiquement l'analyseur Microsoft XML (MSXML) version 3.0. Si vous installez d'autres versions de l'analyseur MSXML, BizTalk Server 2000 risque de réagir d'une manière inattendue.

    Remarque

  • Lors de l'installation de BizTalk Server 2000, le programme d'installation détermine l'espace disponible sur le disque dur de votre ordinateur. Une installation complète requiert environ 52 Mo d'espace libre, qui n'incluent pas l'espace requis pour les bases de données Gestion d'échanges BizTalk, Suivi, Files d'attente partagées et Persistance d'orchestration. L'installation des outils requiert environ 30 Mo d'espace libre sur le disque dur. Une installation personnalisée requiert environ 2 à 52 Mo d'espace libre sur le disque dur, qui n'incluent pas l'espace requis pour les bases de données des services et des outils installés.

Avant d'exécuter le programme d'installation, vérifiez que votre compte d'ouverture de session est membre du groupe d'administrateurs Windows 2000 pour l'ordinateur sur lequel vous installez BizTalk Server 2000.Pour plus d'informations sur la liaison à un groupe d'administrateurs, voir Ajout d'un compte utilisateur au groupe d'administrateurs.

Remarque

  • Si BizTalk Server a été installé à l'aide d'un utilisateur interactif, il ne démarrera pas si un utilisateur n'est pas connecté à BizTalk Server 2000. Tous les packages COM+ fonctionnent sous un compte utilisateur interactif et non sous le compte système local. Cela signifie que le service ne démarre que si un utilisateur est connecté à BizTalk Server 2000. Si, par exemple, un utilisateur n'est pas connecté à BizTalk Server 2000 lorsqu'une application cliente envoie des documents à distance à BizTalk Server 2000, le service ne démarre pas. Pour éviter cette situation, créez un compte de services ou faites en sorte que l'utilisateur qui démarre le service verrouille l'ordinateur et laisse les services fonctionner en arrière-plan. Pour plus d'informations sur la création d'un compte de services, voir Création d'un compte de services.

Cette section traite des rubriques suivantes :

  • Installation complète

  • Installation des outils

  • Installation personnalisée

  • Installation en mode silencieux

  • Suppression de BizTalk Server 2000


Installation complète

La section suivante permet d'effectuer une installation complète de BizTalk Server 2000, incluant tous les services, les outils et les exemples de BizTalk.

Cette section traite des rubriques suivantes :

  • Installation complète de BizTalk Server 2000

  • Démarrage du service de publication World Wide Web

  • Installation du suivi de documents BizTalk à distance


Installation complète de BizTalk Server 2000

  1. Insérez le CD-ROM d'installation de Microsoft BizTalk Server 2000 dans le lecteur approprié.

  2. Exécutez le programme d'installation de Microsoft BizTal Serve 2000 et suivez les instructions en ligne.

    Important

    • L'Assistant Installation vous guide au cours des étapes nécessaires à l'installation de BizTalk Server 2000. Vous devez respecter les conditions mentionnées dans les étapes suivantes.

    • BizTalk Server 2000 nécessite l'analyseur Microsoft XML version 3.0. Cette version de BizTalk Server 2000 installe automatiquement l'analyseur Microsoft XML (MSXML) version 3.0. Si vous installez d'autres versions de l'analyseur MSXML, BizTalk Server 2000 risque de réagir d'une manière inattendue.
  3. Sur la page Contrat de licence, lisez les informations proposées, cliquez sur J'accepte ce contrat de licence, puis sur Suivant.

    Remarque

    • Si vous n'acceptez pas le contrat de licence, vous ne pouvez pas poursuivre l'installation.
  4. Sur la page Informations client, tapez votre nom dans la zone Nom d'utilisateur, tapez le nom de votre société dans la zone Organisation, cliquez sur Toute personne utilisant cet ordinateur (tous les utilisateurs) ou sur Pour moi uniquement si vous souhaitez restreindre l'accès à BizTalk Server 2000, puis cliquez sur Suivant.

  5. Sur la page Dossier de destination, cliquez sur Suivant pour installer BizTalk Server 2000 dans le dossier indiqué sur la page ou cliquez sur Modifier pour sélectionner un autre emplacement.

  6. Dans la boîte de dialogue Type d'installation, cliquez sur Complète, puis sur Suivant.

  7. Sur la page Configurer l'accès administratif à BizTalk, dans la zone Nom du groupe, tapez le nom du groupe que vous voulez utiliser (ou acceptez le nom par défaut, Administrateurs BizTalk Server).

    Remarques

    • Pour créer un nom de groupe, respectez les restrictions de désignation de groupe suivantes :

    • Le nom du groupe doit être différent de tout autre nom de groupe ou d'utilisateur de cet ordinateur.

    • Le nom du groupe ne peut pas contenir les caractères suivants : ` ! @ # $ % ^ & * ( ) + = [ ] { } | \\ ;\" '< > , .?

    • Le nom du groupe ne peut pas comprendre uniquement des points ( . ) ou des espaces.

    • Ne renommez pas ce groupe sans modifier également la valeur de "AdminGroupName" dans le Registre de Windows sous HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\BizTalk Server\1.0\NTGroups. BizTalk Server 2000 prend en compte cette clé de Registre pour rechercher le groupe.
  8. Dans la zone Description du groupe, tapez une nouvelle description du nom du groupe ou acceptez la valeur par défaut, puis cliquez sur Suivant.

  9. Sur la page Propriétés de connexion du service Microsoft BizTalk Server, cliquez sur le paramètre par défaut, Compte système local ou cliquez sur Ce compte pour limiter l'accès à BizTalk Server 2000 à un utilisateur donné.

    Si vous sélectionnez Ce compte, tapez un nouveau nom d'utilisateur ou acceptez le nom par défaut dans la zone Nom d'utilisateur, tapez votre mot de passe dans la zone Mot de passe.

    Si vous ne voulez pas que les services BizTalk démarrent automatiquement à la fin de l'installation, désactivez la case à cocher Démarrer le service après la fin de l'installation. Les services BizTalk ne démarrent pas automatiquement, contrairement aux services d'orchestration.

    Remarques

    • L'installation de BizTalk Server accorde les droits Connexion en tant que service et Agir en tant que partie du système d'exploitation au compte spécifié sur la page Propriétés de connexion du service Microsoft BizTalk Server.

    • Si vous sélectionnez Ce compte, spécifiez un compte appartenant au groupe d'administrateurs de Windows 2000. Pour configurer les certificats des composants S/MIME à l'aide du Gestionnaire d'échanges BizTalk, vous devez appartenir à un compte utilisateur du groupe d'administrateurs Windows 2000 ; par ailleurs, les services d'échanges BizTalk doivent fonctionner en tant que compte système local ou en tant que compte utilisateur du groupe d'administrateurs Windows 2000.
  10. Cliquez sur Suivant.

  11. Sur la page Prêt à installer le programme, cliquez sur Installer.

    La procédure d'installation de BizTalk Server 2000 peut prendre plusieurs minutes.

  12. Lorsque la page Assistant Configuration des bases de données d'échanges Microsoft BizTalk Server 2000 apparaît, cliquez sur Suivant.

    Pendant l'installation des bases de données BizTalk Server 2000, vous êtes invité à indiquer des informations de connexion (serveur, base de données, nom d'utilisateur et mot de passe) pour configurer les bases de données Gestion d'échanges BizTalk, Suivi et Files d'attente partagées.

    Attention

    • Ne modifiez pas le code, tel que les procédures stockées ou les déclencheurs, dans les bases de données Gestion d'échanges BizTalk, Suivi et Files d'attente partagées. N'accédez pas directement à la base de données. N'appelez pas directement les procédures stockées. Effectuez toutes les modifications de la base de données via les méthodes et les propriétés du modèle d'objets de configuration d'échanges BizTalk. Si vous apportez directement des modifications à la base de données, de nombreuses contraintes appliquées par le modèle d'objets de configuration d'échanges BizTalk ne sont pas respectées, ce qui entraîne un mauvais fonctionnement du serveur ou une altération de la base de données.
  13. Sur la page Configurer une base de données Gestion d'échanges BizTalk, cliquez sur Créez une nouvelle base de données Gestion d'échanges BizTalk ou Sélectionnez une base de données existante, puis tapez le nom de votre serveur et des informations utilisateur dans les zones de texte suivantes :
    • Nom de serveur

    • Nom d'utilisateur

    • Mot de passe

    • Base de données

    Vous pouvez choisir un nom de serveur et de base de données unique et taper de nouvelles informations ou accepter les valeurs par défaut.

    Important

    • Si vous installez BizTalk Server 2000 sur un ordinateur doté de Microsoft Windows 2000 Professionnel avec Service Pack 1, le Nom du serveur que vous devez spécifier est celui de l'ordinateur sur lequel vous avez installé Microsoft SQL Server 7.0 ou Microsoft SQL Server 2000.

    • Si vous sélectionnez Créer une nouvelle base de données Gestion d'échanges BizTalk et choisissez une base de données existante, vous devez supprimer manuellement le contenu de la base de données. Pour plus d'informations sur la suppression du contenu d'une base de données, dans le menu Démarrer, pointez sur Programmes et sur Microsoft SQL Server, puis cliquez sur Documentation en ligne. Pour créer une base de données ayant le même nom qu'une base de données existante sur le même serveur, il est recommandé de supprimer manuellement le contenu de la base de données. Le programme d'installation de BizTalk Server vérifie uniquement si une procédure stockée requise par la base de données existe, au lieu de vérifier si toutes les variables requises par la base de données existent. Si la procédure stockée existe, le programme d'installation de BizTalk Server ne modifie pas la base de données. Si la procédure stockée n'existe pas, le programme d'installation de BizTalk Server supprime la base de données. Ensuite, il réinitialise les tables de la base de données Gestion d'échanges BizTalk. Les informations mentionnées ci-dessus sont vraies pour les bases de données Files d'attente partagées et Suivi.

    • Si vous avez configuré plusieurs installations de BizTalk Server et souhaitez centraliser la gestion de la base de données Gestion d'échanges BizTalk, nous vous recommandons de revoir les informations sur les interactions des bases de données BizTalk Server. Pour plus d'informations sur la configuration de la base de données, voir Modification de la base de données Gestion d'échanges BizTalk.
  14. Cliquez sur Suivant.

  15. Sur la page Configurer un groupe de serveurs BizTalk Server, tapez le nom que vous voulez utiliser comme groupe BizTalk Server dans la zone Nom du groupe ou acceptez la valeur par défaut (Groupe de serveurs BizTalk), puis cliquez sur Suivant.

    Vous pouvez également cliquer sur Sélectionnez un groupe BizTalk Server et choisir un nom dans la liste Nom du groupe.

    Remarques

    • Le nom du groupe ne peut pas contenir les caractères suivants : ` ! @ # $ % ^ & * ( ) + = [ ] { } | \\ ;\" '< > , .?
  16. Sur la page Configurer une base de données de suivi, répétez la procédure de l'étape 13 et cliquez sur Suivant.

    Important

    • Si vous modifiez le Nom d'utilisateur par défaut sur la page Configurer une base de données de suivi, le compte que vous spécifiez doit avoir les autorisations de niveau SA. Ce compte permet de créer une connexion utilisateur SQL Server. Après l'installation de BizTalk Server, modifiez le nom d'utilisateur et le mot de passe pour supprimer l'accès de niveau SA à la base de données Suivi par le service BizTalk Server. Pour plus d'informations, voir Configuration des propriétés de connexion d'un groupe de serveurs. Vous pouvez également modifier l'autorisation de niveau SA du compte utilisé pendant l'installation. Pour plus d'informations sur la modification des autorisations de compte SQL Server, dans le menu Démarrer, pointez sur Programmes et sur Microsoft SQL Server, puis cliquez sur Documentation en ligne.
  17. Sur la page Configurer une base de données de files d'attente partagées, répétez la procédure de l'étape 13 et cliquez sur Suivant.

  18. Sur la page Vérifiez le groupe BizTalk Server, vérifiez que les informations de la zone Propriétés du groupe de serveurs BizTalk Server sont correctes et cliquez sur Suivant.

  19. Sur la dernière page de l'Assistant Configuration des bases de données d'échanges Microsoft BizTalk Server 2000, cliquez sur Terminer pour terminer la configuration des bases de données Gestion d'échanges BizTalk, Suivi et Files d'attente partagées.

  20. Sur la page Assistant Configuration des bases de données de persistance d'orchestration Microsoft BizTalk Server, cliquez sur Suivant pour installer la base de données Persistance d'orchestration.

    Remarque

    • Si vous cliquez sur Annuler, BizTalk Server 2000 est installé, mais pas la base de données Persistance d'orchestration et le nom DSN (Data Source Name). Vous pouvez installer la base de données et le nom DSN ultérieurement. Pour plus d'informations, voir Création d'une base de données de persistance, Configuration de l'application XLANG Scheduler par défaut et Configuration d'une application COM+ pour héberger des planifications XLANG.
  21. Sur la page Configurez une base de données de persistance d'orchestration par défaut, cliquez sur Créez une nouvelle base de données de persistance d'orchestration par défaut ou Sélectionnez une base de données existante, puis choisissez un nom de serveur et tapez les informations relatives à la base de données dans les zones de texte appropriées ou acceptez les valeurs par défaut.

    Important

    • Si vous sélectionnez Créez une nouvelle base de données de persistance d'orchestration par défaut et choisissez une base de données ayant le même nom, sur le même serveur, comme base de données existante, le programme d'installation de BizTalk Server supprime le contenu de la base de données. Le programme d'installation de BizTalk Server réinitialise ensuite les tables de la base de données Persistance d'orchestration.

    • Si vous installez BizTalk Server 2000 sur un ordinateur doté de Windows 2000 Professionnel avec Service Pack 1, le Nom du serveur que vous spécifiez est celui de l'ordinateur sur lequel vous avez installé SQL Server 7.0 ou SQL Server 2000.

    Remarques

    • La base de données Persistance d'orchestration est créée en fonction de l'identité de connexion de l'utilisateur.

    • Pour utiliser SQL Server à distance, vous devez disposer des autorisations appropriées pour la base de données Persistance d'orchestration. Si vous n'avez pas configuré l'identité du moteur de XLANG Scheduler, les autorisations sont accordées à l'utilisateur interactif (celui qui était connecté pendant l'installation de BizTalk Server 2000). Si vous avez reconfiguré l'identité du moteur XLANG Scheduler en fonction d'un compte de services que vous avez créé ou d'un autre compte utilisateur unique, vous devez définir des autorisations en fonction de l'identité reconfigurée.
  22. Cliquez sur Terminer.

  23. Sur la dernière page de l'Assistant Installation de Microsoft BizTalk Server 2000, cliquez sur Afficher le fichier Lisezmoi afin de lire les dernières informations importantes sur BizTalk Server 2000, puis cliquez sur Terminer.

Attention

  • Ne modifiez pas le niveau d'emprunt d'identité des applications COM+. Le niveau par défaut est Emprunter l'identité. Si vous attribuez la valeur Anonyme, Identifier ou Déléguer à cette propriété de sécurité, vous risquez de rencontrer des problèmes lors de l'installation.

Important

  • Pour améliorer sensiblement les performances des services d'orchestration BizTalk, dans l'Explorateur Windows, accédez à Program Files\ Fichiers communs \System\ado, puis double-cliquez sur adofre15.reg. Dans la boîte de dialogue de confirmation, cliquez sur Oui, puis sur OK. Cette procédure fait passer le modèle de thread ADO de « Threads cloisonnées » à « Les deux » et peut affecter d'autres applications utilisant ADO. Les fournisseurs qui ne sont pas sécurisés contre les threads ne peuvent être utilisés.

    Remarque

  • Le Gestionnaire d'échanges BizTalk ne peut fonctionner que si le service de publication World Wide Web est actif. Pour plus d'informations sur ce service, voir Démarrage du service de publication World Wide Web.


Démarrage du service de publication World Wide Web

  1. Dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration et sur Services de composants.

  2. Dans l'arborescence de la console, cliquez sur Services (Locaux).

  3. Dans le volet des détails, cliquez avec le bouton droit sur Service de publication World Wide Web, puis cliquez sur Démarrer.


Installation du suivi de documents BizTalk à distance

Lorsque le suivi de documents BizTalk est installé à partir du CD-ROM d'installation de BizTalk Server 2000, un raccourci est créé dans le groupe de programmes pour que BizTalk Server 2000 puisse accéder à l'application Web de suivi de documents BizTalk. Cependant, si le suivi de documents BizTalk est installé par l'intermédiaire d'Internet, vous devez créer manuellement un raccourci ou un favori pour accéder à l'application Web. De plus, pour éviter l'affichage de boîtes de dialogue d'avertissement concernant la sécurité, vous devez configurer manuellement les paramètres de votre navigateur afin d'approuver l'application Web.

Cette section traite de la rubrique suivante :

  • Configuration des paramètres de sécurité Internet Explorer


Configuration des paramètres de sécurité Internet Explorer

  1. Cliquez sur Démarrer, pointez sur Programmes, puis cliquez sur Internet Explorer.

  2. Dans le menu Outils, cliquez sur Options Internet.

    La boîte de dialogue Options Internet s'affiche.

  3. Dans l'onglet Sécurité, cliquez sur Sites de confiance, puis sur le bouton Sites.

    La boîte de dialogue Sites de confiance s'affiche.

  4. Dans la zone Zone, tapez l'emplacement du serveur de suivi de documents BizTalk.

    Pour rechercher l'emplacement du serveur de suivi de documents BizTalk, dans le menu Démarrer, pointez sur Programmes, pointez sur Microsoft BizTalk Server 2000, puis cliquez sur Suivi de documents Biztalk. L'emplacement du serveur de suivi de documents BizTalk apparaît dans la liste Adresse.

  5. Désactivez la case à cocher Vérifier le serveur (https:) pour tous les sites dans cette zone.

  6. Cliquez sur Ajouter, puis sur OK à deux reprises pour fermer les boîtes de dialogue.


Installation des outils

L'installation des outils Microsoft BizTalk Server 2000 permet d'installer le Concepteur d'orchestration BizTalk, le Suivi de documents BizTalk, l'Éditeur BizTalk, le Mappeur BizTalk et l'aide de BizTalk Server 2000 uniquement.

Cette section traite de la rubrique suivante :

  • Installation des outils de BizTalk Server 2000


Installation des outils de BizTalk Server 2000

  1. Insérez le CD-ROM d'installation de Microsoft BizTalk Server 2000 dans le lecteur approprié et suivez les instructions à l'écran.

    Important

    • L'Assistant Installation vous guide au cours des étapes nécessaires à l'installation de BizTalk Server 2000. Vous devez respecter les conditions mentionnées dans les étapes suivantes.
  2. Sur la page Contrat de licence, lisez les informations proposées, cliquez sur J'accepte ce contrat de licence, puis cliquez sur Suivant.

    Remarque

    • Si vous n'acceptez pas le contrat de licence, vous ne pouvez pas poursuivre l'installation.
  3. Sur la page Informations client, tapez votre nom dans la zone Nom d'utilisateur, tapez le nom de votre société dans la zone Organisation, cliquez sur Toute personne utilisant cet ordinateur (tous les utilisateurs) ou sur Pour moi uniquement si vous souhaitez restreindre l'accès à BizTalk Server 2000, puis cliquez sur Suivant.

  4. Sur la page Dossier de destination, cliquez sur Suivant.

  5. Dans la boîte de dialogue Type d'installation, cliquez sur Outils, puis sur Suivant.

  6. Sur la page Prêt à installer le programme de l'Assistant Installation de Microsoft BizTalk Server 2000, cliquez sur Installer.

  7. Sur la dernière page de l'Assistant Installation de Microsoft BizTalk Server 2000, cliquez sur Afficher le fichier Lisezmoi pour lire les dernières informations importantes sur cette version de BizTalk Server 2000.

  8. Cliquez sur Terminer pour achever le processus d'installation.

Important

  • Pour améliorer sensiblement les performances des services d'orchestration BizTalk, dans l'Explorateur Windows, accédez à Program Files\ Fichiers communs \System\ado, puis double-cliquez sur adofre15.reg. Dans la boîte de dialogue de confirmation, cliquez sur Oui, puis sur OK. Cette procédure fait passer le modèle de thread ADO de « Threads cloisonnées » à « Les deux » et peut affecter d'autres applications utilisant ADO.

    Remarque

  • Pour installer le composant Échanges BizTalk Server 2000 sur un ordinateur distant, utilisez l'Assistant d'exportation d'application COM de Windows 2000.
    1. Dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration et sur Services de composants.

    2. Dans l'arborescence de la console, développez successivement Services de composant, Ordinateurs, Poste de travail et Applications COM+.

    3. Cliquez avec le bouton droit sur Application Échange BizTalk Server et cliquez sur Exporter.

      Suivez les instructions à l'écran pour créer un fichier .msi pouvant être exécuté sur un ordinateur client.


Installation personnalisée

Une installation personnalisée de Microsoft BizTalk Server 2000 permet d'installer tout ou partie des fonctionnalités de BizTalk Server 2000.

Remarque

  • Pour installer les composants de serveur de BizTalk Server 2000, vous devez d'abord installer Microsoft SQL Server. Pour plus d'informations, voir Installation de SQL Server 7.0 ou 2000.

Cette section traite de la rubrique suivante :

  • Installation personnalisée de BizTalk Server 2000


Installation personnalisée de BizTalk Server 2000

  1. Insérez le CD-ROM d'installation de Microsoft BizTalk Server 2000 dans le lecteur approprié et suivez les instructions à l'écran.

    Important

    • L'Assistant Installation vous guide au cours des étapes nécessaires à l'installation de BizTalk Server 2000. Vous devez respecter les conditions mentionnées dans les étapes suivantes.
  2. Sur la page Contrat de licence, lisez les informations proposées, cliquez sur J'accepte ce contrat de licence, puis cliquez sur Suivant.

    Remarque

    • Si vous n'acceptez pas le contrat de licence, vous ne pouvez pas poursuivre l'installation.
  3. Sur la page Informations client, tapez votre nom dans la zone Nom d'utilisateur, tapez le nom de votre société dans la zone Organisation, cliquez sur Toute personne utilisant cet ordinateur (tous les utilisateurs) ou sur Pour moi uniquement si vous souhaitez restreindre l'accès à BizTalk Server 2000, puis cliquez sur Suivant.

  4. Sur la page Dossier de destination, cliquez sur Suivant.

  5. Dans la boîte de dialogue Type d'installation, cliquez sur Personnalisée, puis sur Suivant.

  6. Sur la page Installation personnalisée, suivez les instructions pour sélectionner les composants BizTalk Server 2000 que vous voulez installer.

    Pour effectuer un autre type d'installation, cliquez sur Précédent. Sinon, cliquez sur Suivant. D'autres pages s'affichent pour que vous puissiez entrer des informations complémentaires, selon les composants d'installation que vous avez sélectionnés.

  7. Sur la page Prêt à installer le programme, cliquez sur Installer.

    La procédure d'installation personnalisée de BizTalk Server 2000 peut prendre quelques minutes.

  8. Sur la dernière page de l'Assistant Installation de Microsoft BizTalk Server 2000, cliquez sur Afficher le fichier Lisezmoi afin de lire les dernières informations importantes sur cette version de Microsoft BizTalk Server 2000.

  9. Cliquez sur Terminer pour achever le processus d'installation.

    Important

  • Le Gestionnaire d'échanges BizTalk ne peut fonctionner que si le service de publication World Wide Web est actif. Pour démarrer ce service, procédez comme suit :
    1. Dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration et sur Services de composants.

    2. Dans l'arborescence de la console, cliquez sur Services (Locaux).

    3. Dans le volet des détails, cliquez avec le bouton droit sur Service de publication World Wide Web, puis cliquez sur Démarrer.
  • Pour améliorer sensiblement les performances des services d'orchestration BizTalk, dans l'Explorateur Windows, accédez à Program Files\ Fichiers communs \System\ado, puis double-cliquez sur adofre15.reg. Dans la boîte de dialogue de confirmation, cliquez sur Oui, puis sur OK. Cette procédure fait passer le modèle de thread ADO de « Threads cloisonnées » à « Les deux » et peut affecter d'autres applications utilisant ADO.


Installation en mode silencieux

Microsoft Windows Installer vous permet d'indiquer des valeurs de propriétés sur la ligne de commande. Grâce à cette méthode, vous pouvez installer Microsoft BizTalk Server 2000 en mode silencieux (sans interaction ni invites constantes). Une installation en mode silencieux constitue une solution idéale pour les scénarios de test ou dans le cadre d'un déploiement à grande échelle au sein d'une entreprise.

Cette section traite de la rubrique suivante :

  • Installation en mode silencieux de BizTalk Server 2000


Installation en mode silencieux de BizTalk Server 2000

  1. Cliquez sur Démarrer, puis sur Exécuter.

  2. Dans la zone Ouvrir, tapez cmd et cliquez sur OK.

  3. Tapez ce qui suit pour installer BizTalk Server 2000 en mode silencieux :
    msiexec /I "\\server\folder\Microsoft BizTalk Server.msi"
/qb /Lv*"C:\Temp\install.log" INSTALLLEVEL=200
ALLUSERS=1
PIDKEY="your 25-character product key (without dashes)"
DSNCONFIG="C:\Temp\BizTalkInstall.ini"

Important

  • Vous devez ajouter le paramètre ALLUSERS=1 pour terminer l'installation pour tous les utilisateurs. Ce paramètre permet de s'assurer que les services peuvent accéder aux paramètres du Registre.

Remarques

  • Dans le code précédent :
    • /I est la ligne de commande pour installer ou configurer un produit.

    • /qb est la ligne de commande pour présenter une interface utilisateur de base (barre de progression uniquement).

    • /Lv* génère un fichier journal.

    • INSTALLLEVEL=200 installe le serveur. Si vous ne spécifiez pas INSTALLLEVEL, la valeur par défaut est 100, ce qui correspond à l'installation des outils de BizTalk Server 2000.

    • PIDKEY="la clé de votre produit sur 25 caractères (sans tiret)" est la clé du produit. Par exemple, PIDKEY=AB6CDEFGH7IJK8LMN45LLTT34.

    • DSNCONFIG="C:\Temp\BizTalkInstall.ini" fournit des informations d'installation à l'Assistant Installation.

Vous pouvez spécifier différentes options sur la ligne de commande pour définir des propriétés d'une installation de BizTalk Server 2000. Les propriétés non spécifiées correspondent aux valeurs par défaut. Les propriétés propres à BizTalk Server 2000 sont présentées dans le tableau ci-dessous.

Propriété publique | Valeur | Description
USERNAME (propriété intégrée de Installer) | <nom> Valeur par défaut : {LogonUser} | Nom de l'utilisateur qui effectue l'installation. Boîte de dialogue Informations client ; zone d'édition Nom d'utilisateur.
COMPANYNAME (propriété intégrée de Installer) | <organisation> Valeur par défaut : {LogonCompany} | Nom de l'organisation pour laquelle l'utilisateur effectue l'installation. Boîte de dialogue Informations client ; zone d'édition Organisation.
PIDKEY | <id-produit> Valeur par défaut : "" | Clé du CD au format (xxxxx-xxxxx-xxxxx-xxxxx) du produit. Boîte de dialogue Informations client ; zone d'édition masquée Numéro de série.
INSTALLLEVEL (propriété intégrée de Installer) | <niveau d'installation> Valeur par défaut : 100 | Niveau d'installation des fonctionnalités. Pour l'installation de BizTalk Server 2000, 100=Client et 200=Type d'installation serveur.
INSTALLDIR (propriété intégrée de Installer) | <chemin d'installation> Valeur par défaut : "{ProgramFiles}\Microsoft BizTalk Server" | Dossier de destination de l'installation.
BTS_GROUP_NAME (Installation complète uniquement) | <Nom du groupe> Valeur par défaut : "BTSAdmin" | Nom du groupe BizTalk Server 2000 Windows NT. Boîte de dialogue ConfigAdminGroup ; zone d'édition Nom du groupe.
BTS_GROUP_DESCRIPTION (Installation complète uniquement) | <Description du groupe> Valeur par défaut : "Les membres peuvent administrer totalement Microsoft BizTalk Server" | Description du groupe BizTalk Server 2000 NT. Boîte de dialogue ConfigAdminGroup ; zone d'édition Description du groupe.
BTS_USERNAME (Installation complète uniquement) | <nomutilisateur> Valeur par défaut : "" | DOMAINE\nom d'ouverture de session du service BizTalk Server 2000. Boîte de dialogue ConfigServiceLogon; zone d'édition Nom d'utilisateur.
BTS_PASSWORD (Installation complète uniquement) | <motdepasse> Valeur par défaut : "" | Mot de passe d'ouverture de session au service BizTalk Server 2000. Boîte de dialogue ConfigServiceLogon; zone d'édition Mot de passe.
BTS_SERVER (Installation complète et installation des outils) | <nomserveur> Valeur par défaut : "localhost" | Nom du serveur BizTalk à administrer à distance. Boîte de dialogue ConfigMgmtDesk ; zone d'édition Nom du serveur.
BTS_SDK_SERVER (Installation complète et installation des outils) | <nomserveur> Valeur par défaut : "localhost" | Nom du serveur BizTalk à utiliser pour DCOM. Boîte de dialogue ConfigSDK ; zone d'édition Nom du serveur.
DSNCONFIG (fichier d'initialisation) | <chemin d'accès> Valeur par défaut : "" | Chemin d'accès au fichier d'initialisation de BTSsetupDB.exe et XLANGsetupDB.exe que l'Assistant Installation va utiliser.

Remarques

  • L'installation en mode silencieux de BizTalk Server 2000 requiert la propriété DSNCONFIG. Le fichier d'initialisation indiqué sur la ligne de commande est transmis aux Assistants Configuration des bases de données BTSsetupDB.exe et XLANGsetupDB.exe. Sélectionnez l'une des valeurs de ligne de commande suivantes :
    • DSNCONFIG="Chemin d'accès complet au fichier .ini pour BTSsetupDB.exe et XLANGsetupDB.exe"

      -ou-

    • BTSSETUPDB.INI="Chemin d'accès complet au fichier .ini pour BTSsetupDB.exe" et XLANGSETUPDB.INI="Chemin d'accès complet au fichier .ini pour XLANGsetupDB.exe"
  • L'Assistant Configuration des bases de données traite le contenu du fichier d'initialisation en respectant les règles suivantes :
    • Toutes les [sections] et clés= sont facultatives ; en l'absence de clé, la valeur par défaut définie dans le fichier d'initialisation est utilisée.

    • Si GroupName existe dans la base de données Gestion d'échanges BizTalk, les sections [InterchangeDTA] et [InterchangeSQ] sont ignorées puisque le groupe définit des valeurs.

    • Les bases de données spécifiées sont créées si elles n'existent pas sur le serveur indiqué.
  • L'installation de la base de données Gestion d'échanges BizTalk et celle de la base de données Persistance d'orchestration sont indépendantes.

  • Selon les fonctionnalités que vous installez, le programme d'installation configure une des bases de données suivantes, aucune ou les deux :
    • Bases de données Gestion d'échanges BizTalk - configurées seulement si les services d'échanges BizTalk et ses composants associés sont installés.

    • Base de données Persistance d'orchestration - configurée seulement si le service d'orchestration est installé.
  • Les propriétés suivantes sont utilisées sur la ligne de commande :
    • DSNCONFIG - spécifie l'emplacement du fichier .ini qui sera utilisé par BTSsetupDB.exe et XLANGsetupDB.exe

      -ou-

      BTSSETUPDB.INI - spécifie l'emplacement du fichier .ini qui sera utilisé par BTSsetupDB.exe

    • XLANGSETUPDB.INI - spécifie l'emplacement du fichier .ini qui sera utilisé par XLANGsetupDB.exe

Exemple de fichier d'initialisation avec toutes les [sections], clés= et valeurs par défaut

Voici un exemple de format d'un fichier .ini requis pour l'installation en mode silencieux de BizTalk Server 2000. Ces propriétés de ligne de commande sont requises pour installer BizTalk Server 2000 à l'aide de Windows Installer.

Exemple de SetupDB.ini

;----------------------------------------------------------------------
; SQL Server connection parameters for BizTalk Messaging Management database
; Required section used by BTSsetupDB.exe only.
; Specify new or existing database.
;
[InterchangeBTM]
Server=localhost
Username=sa
Password=
Database=InterchangeBTM

;----------------------------------------------------------------------
; Name for BizTalk Server Group
; Required section used by BTSsetupDB.exe only.
; Specify new or existing server group.
;
[Group]
GroupName=BizTalkGroup

;----------------------------------------------------------------------
; SQL Server connection parameters for BizTalk Tracking database
; Required section used by BTSsetupDB.exe only.
; Optional if existing server group specified.
;
[InterchangeDTA]
Server=localhost
Username=sa
Password=
Database=InterchangeDTA

;----------------------------------------------------------------------

;
[InterchangeSQ]
Server=localhost
Username=sa
Password=
Database=InterchangeSQ

;----------------------------------------------------------------------
; SQL Server connection parameters for Orchestration database
; Required section used by XLANGsetupDB.exe only.
; Specify new or existing Orchestration database.
;
[Orchestration]
Server=localhost
Database=XLANG

Les propriétés et les valeurs de l'exemple de fichier d'initialisation BizTalkDB.ini sont décrites dans le tableau ci-dessous.

Propriété | Valeur | Description
[InterchangeBTM] Server=BIZTALK Ouvrez une session sur ce premier serveur SQL Server à l'aide du nom d'utilisateur et du mot de passe par défaut.
Database=BizTalkBTM

Créez cette base de données Gestion d'échanges BizTalk si elle n'existe pas sur le serveur.
[Group] | GroupName=BizTalkServerGroup | Les autres valeurs sont ignorées si ce groupe existe déjà.
[InterchangeDTA] Server=DTA-SERVER Ouvrez une session sur ce deuxième serveur SQL Server à l'aide du nom d'utilisateur et du mot de passe par défaut.
Database=BizTalkDTA

Créez cette base de données Suivi si elle n'existe pas sur le serveur.
[InterchangeSQ] Server=SQ-SERVER Ouvrez une session sur ce troisième serveur SQL Server à l'aide du nom d'utilisateur et du mot de passe par défaut.
Database=BizTalkSQ

Créez cette base de données Files d'attente partagées si elle n'existe pas sur le serveur.
[Orchestration] Server=localhost Ouvrez une session sur ce quatrième serveur SQL Server à l'aide du nom d'utilisateur et du mot de passe par défaut.
Database=Orchestration

Créez cette base de données XLANG si elle n'existe pas sur le serveur.

Options de ligne de commande de Microsoft Windows Installer

Microsoft Windows Installer (Msiexec.exe) est le programme qui interprète les packages et installe les produits. Il définit également un niveau d'erreur sur retour correspondant aux codes d'erreur Microsoft Win32®. Le tableau suivant décrit les options de ligne de commande de ce programme que vous pouvez utiliser en plus des propriétés et des valeurs répertoriées ci-dessus.

Option | Paramètres | Description
/I | Package|ProductCode | Installe ou configure un produit.
/f [p|o|e|d|c|a|u|m|s|v] Package|ProductCode Répare un produit. Cette option ignore toute valeur de propriété entrée dans la ligne de commande. La liste d'arguments par défaut de cette option est pecms. Cette option partage la même liste d'arguments que la propriété REINSTALLMODE.

p - Procède à la réinstallation uniquement si le fichier est absent.

o - Procède à la réinstallation uniquement si le fichier est absent ou si une version antérieure est installée.

e - Procède à la réinstallation uniquement si le fichier est absent ou si une version équivalente ou antérieure est installée.

d - Procède à la réinstallation si le fichier est absent ou si une version différente est installée.

c - Procède à la réinstallation si le fichier est absent ou si la somme de contrôle stockée ne correspond pas à la valeur calculée. Répare uniquement les fichiers dont la colonne Attributs de la table Fichier contient msidbFileAttributesChecksumFile.

a - Force la réinstallation de tous les fichiers.

u - Réécrit toutes les entrées de Registre spécifiques à l'utilisateur.

m - Réécrit toutes les entrées de Registre requises spécifiques à l'ordinateur.

s - Remplace tous les raccourcis existants.

v - Exécute à partir de la source et remet en mémoire cache le package local.
/a | Lot | Option d'installation administrative. Installe un produit sur le réseau.
/x | Package|ProductCode | Désinstalle un produit.
/j [u|m]Package

ou

[u|m]Package /t Transform List

ou

[u|m]Package /g LanguageID

 Annonce un produit. Cette option ignore toute valeur de propriété entrée sur la ligne de commande.

u - Annonce à l'utilisateur en cours.

m - Annonce à tous les utilisateurs de l'ordinateur.

t - Applique la transformation au package d'installation annoncé.

g - Identificateur de langue.
/L [i|w|e|a|r|u|c|m|o|p|v|+|!]Logfile Spécifie le chemin d'accès à un fichier journal ; les indicateurs suivants précisent les informations à enregistrer :

i - Messages d'état

w - Avertissements non critiques

e - Tous les messages d'erreur

a - Démarrage des actions

r - Enregistrements spécifiques à certaines actions

u - Requêtes de l'utilisateur

c - Paramètres d'interface utilisateur (UI) initiaux

m - Informations de mémoire insuffisante ou de sortie fatale

o - Messages de disque insuffisant

p - Propriétés du terminal

v - Mode documenté

+ - Ajouter au fichier journal existant

! ! - Forcer l'écriture de chaque ligne dans le fichier journal

"*" - Caractère générique ; enregistrer toutes les informations, à l'exception de l'option v. Pour inclure l'option v, spécifiez "/l*v".
/m filename Génère un fichier .mif d'état SMS (Systems Management Server). Doit être utilisé avec l'option d'installation (-i), de suppression (-x), d'installation administrative (-a) ou de réinstallation (-f). Ismif32.dll est installé dans le cadre de SMS et doit figurer dans le chemin d'accès.

Les champs du fichier .mif d'état sont complétés avec les informations suivantes :

Fabricant - Auteur

Produit - Numéro de révision

Version - Sujet

Local - Modèle

Numéro de série - Non défini

Installation - Définie par Ismif32.dll sur "DateTime"

InstallStatus - "Success" ou "Failed"

Description - Messages d'erreur dans l'ordre suivant : 1) Messages d'erreur générés par Installer ; 2) Ressource de Msi.dll si l'installation n'a pas pu commencer ou si l'utilisateur a quitté ; 3) Fichier de messages d'erreur système ; 4) Message formaté : "Erreur Installer %i", où %i est l'erreur renvoyée par Msi.dll
/p Package correctif Applique un correctif. Pour appliquer un correctif à une image administrative installée, vous devez utiliser les combinaisons d'options suivantes :

/p <PatchPackage> /a <Package>
/q n|b|r|f Définit le niveau d'interface utilisateur.

q , qn - Pas d'interface utilisateur.

qb - Interface utilisateur de base.

qr - Interface utilisateur réduite avec affichage d'une boîte de dialogue modale à la fin de l'installation.

qf - Interface utilisateur intégrale avec affichage d'une boîte de dialogue modale à la fin.

qn+ - Aucune interface utilisateur à l'exception de l'affichage d'une boîte de dialogue modale à la fin.

qb+ - Interface utilisateur de base avec affichage d'une boîte de dialogue modale à la fin. Cette boîte de dialogue ne s'affiche pas si l'utilisateur annule l'installation.

qb- - Interface utilisateur de base sans boîtes de dialogue modales. /qb+- n'est pas un niveau d'interface utilisateur pris en charge.
/?

ou

/h

 Affiche les informations de copyright pour Windows Installer.
/y module y - Appelle le système API DllRegisterServer pour auto-enregistrer les modules passés sur la ligne de commande. Par exemple, msiexec /y my_file.dll.

Cette option est utilisée uniquement pour les informations de Registre qui ne peuvent pas être ajoutées à l'aide des tables de Registre du fichier .msi.
/z module z - Appelle le système API DllUnRegisterServer pour annuler l'enregistrement des modules passés sur la ligne de commande. Par exemple, msiexec /z my_file.dll.

Cette option est utilisée uniquement pour les informations de Registre qui ne peuvent pas être supprimées à l'aide des tables de Registre du fichier .msi.

Remarques

  • Dans le tableau précédent :
    • Les options /i, /x, /f[p|o|e|d|c|a|u|m|s|v], /j[u|m], /a, /p, /y et /z ne doivent pas être utilisées conjointement. Exception à cette règle : la correction d'une installation administrative requiert les options /p et /a.

    • Les options /t et /g ne doivent être utilisées qu'avec /j.

    • Les options /l et /q peuvent être utilisées avec /i, /x, /f[p|o|e|d|c|a|u|m|s|v], /j[u|m], /a et /p.

Règles de syntaxe des propriétés et des valeurs

Seules les propriétés publiques peuvent être modifiées sur la ligne de commande. Tous les noms de propriété de la ligne de commande sont interprétés en majuscules, mais la valeur conserve la distinction entre les majuscules et les minuscules. Si vous tapez MyProperty sur la ligne de commande, le programme Installer remplace la valeur de MYPROPERTY et non celle de MyProperty dans la table des propriétés. Pour installer un produit à l'aide de PROPERTY définie sur VALUE, utilisez la syntaxe suivante sur la ligne de commande. Vous pouvez placer la propriété n'importe où, sauf entre une option et son argument.

Syntaxe correcte :

msiexec /i A:\Example.msi PROPERTY=VALUE

Syntaxe incorrecte :

msiexec /i PROPERTY=VALUE A:\Example.msi

Les valeurs des propriétés qui sont des chaînes littérales doivent être placées entre guillemets. Incluez des espaces dans la chaîne entre ces marques.

msiexec /i A:\Example.msi PROPERTY="Embedded White Space"

Pour supprimer une propriété publique sur la ligne de commande, définissez sa valeur sous forme d'une chaîne vide.

msiexec /i A:\Example.msi PROPERTY=""

Pour les sections de texte définies séparément à l'aide de guillemets littéraux, placez la section dans une seconde paire de guillemets.

msiexec /i A:\Example.msi PROPERTY="Embedded ""Quotes"" White Space"

Voici un exemple de ligne de commande compliquée.

msiexec /i testdb.msi INSTALLLEVEL=3 /l* msi.log COMPANYNAME="Acme ""Widgets"" and ""Gizmos."""

L'exemple suivant illustre les options d'annonce. Les commutateurs ne font pas la distinction entre les majuscules et les minuscules.

msiexec /JM msisample.msi /T transform.mst /G langid /LIME logfile.txt

Pour plus d'informations sur Microsoft Windows Installer, accédez au site Web de téléchargement MSDN™ (msdn.microsoft.com/downloads/).


Suppression de BizTalk Server 2000

Pour supprimer Microsoft BizTalk Server 2000, utilisez l'utilitaire Ajout/Suppression de programme de Microsoft Windows 2000.

Cette section traite de la rubrique suivante :

  • Suppression de BizTalk Server 2000


Suppression de BizTalk Server 2000

  1. Dans le menu Démarrer, pointez sur Paramètres, puis cliquez sur Panneau de configuration.

  2. Cliquez sur Ajout/Suppression de programmes.

  3. Cliquez sur Microsoft BizTalk Server 2000 et cliquez sur Supprimer.

    La boîte de dialogue Ajout/Suppression de programmes apparaît.

  4. Suivez les instructions à l'écran et cliquez sur Oui lorsque vous êtes invité à supprimer BizTalk Server 2000.


Présentation de la sécurité

Microsoft BizTalk Server 2000 permet aux entreprises d'échanger des données en toute sécurité avec leurs partenaires commerciaux. BizTalk Server tire parti des fonctions de sécurité offertes par Microsoft Windows 2000 et Microsoft SQL Server.

Les fonctions de sécurité de Windows 2000 sont les suivantes :

  • Infrastructure de clés publiques

  • Services de composant Microsoft

  • Microsoft Cryptography API

  • Cartes à puce

  • Protocole Kerberos

La gestion des certificats à clé publique inclut les demandes de certificats, le traitement des certificats dans une réponse de requête de certificats, et l'échange de certificats avec des partenaires commerciaux. Ces certificats peuvent utiliser des signatures numériques ainsi qu'un cryptage. L'échange de certificats constitue une méthode de sécurisation des données lors d'échanges avec des partenaires commerciaux. Toutefois, lorsque les échanges augmentent, le processus de gestion des certificats peut prendre beaucoup de temps.

Dans la mesure où BizTalk Server tire parti des fonctions de sécurité de Windows 2000, telles que SSL (Secure Sockets Layer), des pages Web peuvent être créées puis utilisées par les partenaires commerciaux pour échanger des données de manière sécurisée via Internet. Le protocole SSL, implémenté dans les services IIS (Internet Information Services), permet de garantir la confidentialité entre un client Web et un serveur Web. Le protocole débute avec une phase d'authentification qui négocie un algorithme de cryptage, vérifie les clés (publiques et privées) et authentifie le serveur pour le client. Une fois que le protocole d'authentification est terminé et que la transmission des données débute, toutes les données sont cryptées par le biais des clés de session négociées durant le protocole d'authentification. Grâce à la prise en charge des standards de type « open PKI » (infrastructure de clés publiques) et des protocoles sécurisés, tels que IPSec, L2TP, SSL/TLS et S/MIME, un réseau peut être rapidement étendu aux fournisseurs et aux partenaires, tout en garantissant une protection contre les imposteurs, le vol de données et les intrus malveillants.

Les services de composant, l'un des outils d'administration de Windows 2000, offre des fonctionnalités de composant complètes, telles que la prise en charge des transactions automatiques pour la protection de l'intégrité des données ainsi qu'une sécurité simple mais puissante qui repose sur les rôles.

Cette section traite des rubriques suivantes :

  • Installation et configuration de BizTalk Server 2000

  • Services de transport

  • Sécurité des applications hébergeant des instances de planification XLANG

  • Présentation des certificats

  • Crypto API

  • CDO (Collaborative Data Objects)

Voir aussi

Privilèges d'administration


Installation et configuration de BizTalk Server 2000

Les transactions avec les partenaires commerciaux doivent être sécurisées. Microsoft BizTalk Server 2000 répond à ces besoins de sécurité en offrant plusieurs composants d'authentification et de cryptage qui exploitent les services de sécurité de Windows 2000. Outre les fonctions de sécurité de Windows 2000, BizTalk Server tire également parti des fonctions de sécurité de Microsoft SQL Server. Pour garantir la sécurité des données dans la base de données Gestion d'échanges BizTalk, BizTalk Server s'appuie principalement sur la sécurité de l'ouverture de session SQL Server. En revanche, la base de données de persistance d'orchestration par défaut s'appuie sur l'authentification Windows 2000. Lorsque vous créez un composant COM+ qui héberge des instances de planification et sa base de données, vous pouvez opter soit pour l'authentification SQL Server, soit pour l'authentification Windows 2000. De plus, la console d'administration utilise l'interface WMI (Windows Management Interface) disponible dans la sécurité de Windows 2000.

Cette section traite des rubriques suivantes :

  • Propriétés de connexion

  • Stratégies locales

  • Utilisation d'un compte de services

  • Envoi d'opérations


Propriétés de connexion

Les propriétés de connexion constituent le premier niveau de sécurité de BizTalk Server 2000. Ces propriétés déterminent la capacité d'un utilisateur à se connecter à un ordinateur donné. Vous devez fournir un nom d'utilisateur et un mot de passe avant d'accéder aux ressources, telles qu'un partage de fichiers ou une file d'attente de messages. Les messages reçus par le biais de HTTP et SMTP utilisent également des propriétés de connexion pour garantir la sécurité. Par exemple, si vous accédez à une page ASP via HTTP, vous devez entrer un nom d'utilisateur et un mot de passe pour être en mesure d'afficher le contenu de la page Web.

BizTalk Server utilise les services ISS (Internet Information Services) et les pages ASP pour ses fonctions de réception. Les pages ASP, ou plus exactement le code situé derrière ces pages, offrent une sécurité à BizTalk Server grâce à la vérification des signatures depuis SSL (Secure Sockets Layer) et à l'optimisation des options de sécurité supplémentaires, telles que les certificats, par le biais de IIS. Pour plus d'informations sur la sécurité IIS, reportez-vous à Internet Information Services dans l'aide de Windows 2000.

Voir aussi

Privilèges d'administration


Stratégies locales

Les stratégies locales, qui font partie de la console des paramètres de sécurité locaux, déterminent les options de sécurité d'un utilisateur ou d'un compte de services. Les stratégies locales sont fonction de l'ordinateur sur lequel vous avez ouvert une session et des droits dont vous bénéficiez sur cet ordinateur. Pour définir des stratégies locales, dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration et sur Stratégie de sécurité locale, puis développez le dossier Stratégies locales.

Les stratégies locales définissent les autorisations et les droits des utilisateurs de BizTalk Server 2000. Ces stratégies locales peuvent être utilisées pour configurer les éléments suivants :

  • Stratégie d'audit : détermine quels événements de sécurité sont consignés dans le fichier journal de l'ordinateur (les tentatives réussies, les tentatives échouées, ou les deux). (Le journal de sécurité fait partie de l'Observateur d'événements.)

  • Attribution des droits utilisateur : détermine quels utilisateurs ou groupes possèdent des privilèges d'ouverture de session ou d'exécution de tâches sur l'ordinateur.

  • Options de sécurité : active ou désactive les paramètres de sécurité de l'ordinateur, tels que la signature numérique des données, les noms des comptes Administrateur et Invités, l'accès aux lecteurs de disquettes et de CD-ROM, l'installation des pilotes et les invites de commandes.

D'autres stratégies dans la console des paramètres de sécurité locaux peuvent être configurées pour préserver l'intégrité de vos données. Par exemple, les stratégies de comptes peuvent être utilisées pour configurer les éléments suivants :

  • Stratégie de mot de passe : détermine des paramètres des mots de passe, tels que la vérification et les durées de vie, pour les comptes d'utilisateur local.

  • Stratégie de verrouillage du compte : détermine quand et pour qui un compte sera verrouillé hors du système pour les comptes d'utilisateur local.

Important

  • Les stratégies locales sont, par définition, locales sur un ordinateur. Une fois que ces paramètres sont importés dans un objet Stratégie de groupe dans Active Directory, ils affectent les paramètres de sécurité locale de tous les comptes d'ordinateur auxquels cet objet Stratégie de groupe est appliqué. Par conséquent, il est important de noter la priorité des stratégies de sécurité. Les stratégies de sécurité associées à la stratégie de groupe (unités d'organisation) remplacent les stratégies établies au niveau local. Les stratégies du domaine remplacent les stratégies définies localement. Dans les deux cas, les droits de votre compte d'utilisateur peuvent ne plus s'appliquer si un paramètre de stratégie locale est prioritaire par rapport à ces privilèges. Ceci est important car il existe d'importantes différences entre Microsoft Windows 2000 et Microsoft Windows NT. Par exemple, lorsque les stratégies de mot de passe sont configurées pour la stratégie de groupe Domaine (configuration par défaut), elles affectent chaque ordinateur appartenant à ce domaine. Par conséquent, les bases de données de compte local (sur les stations de travail individuelles) dans le domaine ont la même stratégie de mot de passe que le domaine proprement dit.

Remarque

  • Ne définissez pas les stratégies locales pour les clés publiques. Les clés publiques fournissent une protection en termes de sécurité pour BizTalk Server. Elles constituent un composant des certificats qui sont utilisés pour crypter et décrypter les données. Lorsque vous ajoutez des stratégies supplémentaires dans une clé publique, BizTalk Server n'est pas en mesure d'utiliser les certificats associés.

Voir aussi

Privilèges d'administration


Utilisation d'un compte de services

Un compte de services est similaire à un compte d'utilisateur interactif car ils permettent tous les deux à un utilisateur d'accéder à un ordinateur et/ou aux ressources du réseau. Un compte de services est un compte d'utilisateur régulier doté de propriétés spécifiques qui lui permettent d'être considéré comme faisant partie du système d'exploitation. En revanche, un compte d'utilisateur interactif fait référence à l'utilisateur connecté durant la procédure d'installation de BizTalk Server 2000.

Si l'identité correspond à un utilisateur interactif, l'application s'exécute uniquement lorsqu'un utilisateur est connecté. Par conséquent, si BizTalk Server est configuré avec un compte d'utilisateur interactif, il échoue si l'utilisateur spécifié se déconnecte du serveur. Toutefois, le choix d'une identité d'utilisateur interactif implique des risques en termes de sécurité car l'application est exécutée sous l'identité de l'utilisateur connecté, sans qu'il n'en soit averti ou n'y ait consenti. Par exemple, si l'application est exécutée sur un ordinateur alors qu'un administrateur a ouvert une session, l'application est exécutée sous l'identité de l'administrateur qui effectue éventuellement des appels au nom des clients.

Si l'identité correspond à un compte de services, elle peut agir en tant que partie du système d'exploitation et permettre aux utilisateurs d'accéder à des applications sur un serveur même si l'utilisateur n'est pas connecté à l'ordinateur.

Pour plus d'informations sur les comptes de services, voir Création d'un compte de services.

Voir aussi

Création d'un compte de services


Envoi d'opérations

Le composant COM+ de l'application Échange BizTalk Server permet de déterminer la capacité d'un utilisateur à envoyer des opérations à BizTalk Server 2000. Le composant COM+ de l'application Échange BizTalk Server utilise les propriétés de configuration de sécurité suivantes :

  • Niveau d'authentification

  • Niveau d'emprunt d'identité

  • Autorisations d'accès

  • Autorisations d'exécution

  • Autorisations de configuration

Pour déterminer la capacité d'un utilisateur à envoyer des opérations, un rôle doit d'abord être ajouté à l'application Échange BizTalk Server, qui est l'une des applications COM+, et le rôle doit être associé aux méthodes Submit et SubmitSync.

Cette section traite des rubriques suivantes :

  • Ajout d'un rôle à l'application Échange BizTalk Server

  • Association d'un nouveau rôle aux méthodes Submit et SubmitSync

Voir aussi

Privilèges d'administration


Ajout d'un rôle à l'application Échange BizTalk Server

  1. Dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration et sur Services de composants.

    La console des services de composants s'affiche.

  2. Développez Services de composant, Ordinateurs, Poste de travail et Applications COM+.

  3. Cliquez avec le bouton droit sur BizTalk Server Interchange Application, puis cliquez sur Propriétés.

    La boîte de dialogue Propriétés de BizTalk Server Interchange Application s'affiche.

  4. Cliquez sur l'onglet Avancé, désactivez la case à cocher Désactiver les modifications dans la zone Autorisation, cliquez sur OK puis, dans la boîte de dialogue de messages, cliquez sur Oui.

  5. Répétez l'étape 3.

  6. Cliquez sur l'onglet Sécurité, puis activez la case à cocher Appliquer les vérifications d'accès pour cette application dans la zone Autorisation.

  7. Dans la zone Niveau de sécurité, cliquez sur Effectuer les vérifications d'accès au niveau du processus et des composants. La propriété de sécurité sera incluse dans le contexte de l'objet. L'appel de sécurité COM+ est disponible.

  8. Cliquez sur OK.

  9. Dans la boîte de dialogue de confirmation, cliquez sur Oui.

  10. Développez Application Échange BizTalk Server.

  11. Double-cliquez sur le dossier Rôles, cliquez avec le bouton droit sur le dossier, pointez sur Nouveau, puis cliquez sur Rôle.

    La boîte de dialogue Rôle s'affiche.

  12. Entrez le nom du rôle, puis appuyez sur OK.

  13. Dans la boîte de dialogue de confirmation, cliquez sur Oui.

  14. Développez le rôle que vous avez créé, double-cliquez sur le dossier Utilisateurs, cliquez avec le bouton droit sur Utilisateurs, pointez sur Nouveau, puis cliquez sur Utilisateur.

  15. Dans la zone Sélectionnez Utilisateurs ou Groupes, entrez le nom complet de l'utilisateur que vous voulez ajouter.

  16. Lorsque vous avez ajouté les comptes d'utilisateur au rôle, cliquez sur OK.

Remarque

  • Pour chaque compte d'utilisateur ou groupe affecté au rôle, une icône apparaît dans le dossier Utilisateurs. L'appartenance au nouveau rôle est activée lorsque l'application démarre.

Voir aussi

Arrêt de l'application Échange BizTalk Server


Association d'un nouveau rôle aux méthodes Submit et SubmitSync

  1. Dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration et sur Services de composants.

    La console des services de composants s'affiche.

  2. Développez Services de composant, Ordinateurs, Poste de travail, Applications COM+, Application Échange BizTalk Server, Composants, BizTalk.Interchange.1, Interfaces, IInterchange et Méthodes.

  3. Cliquez avec le bouton droit sur Submit, puis cliquez sur Propriétés.

    La boîte de dialogue Propriétés de Submit s'affiche.

  4. Cliquez sur l'onglet Sécurité.

  5. Dans la zone Rôles explicitement définis pour les éléments sélectionnés, activez la case à cocher correspondant au rôle créé dans la procédure Ajout d'un rôle à l'application Échange BizTalk Server et cliquez sur OK.

  6. Cliquez avec le bouton droit sur SubmitSync, puis cliquez sur Propriétés.

    La boîte de dialogue Propriétés de SubmitSync s'affiche.

  7. Cliquez sur l'onglet Sécurité.

  8. Dans la zone Rôles explicitement définis pour les éléments sélectionnés, activez la case à cocher correspondant au rôle créé dans la procédure Ajout d'un rôle à l'application Échange BizTalk Server et cliquez sur OK.

Remarque

  • Vous devez d'abord créer un nouveau rôle pour l'application Échange BizTalk Server avant de pouvoir associer les méthodes Submit et SubmitSync.

Voir aussi

Arrêt de l'application Échange BizTalk Server


Services de transport

Microsoft BizTalk Server 2000 prend en charge un groupe principal de services de transport. Ces services de transport permettent au serveur d'envoyer des documents aux organisations ou aux applications, qu'elles soient ou non en mesure de communiquer directement avec le serveur par le biais d'une interface COM. BizTalk Server gère les protocoles réseau HTTP, HTTPS et SMTP, ainsi que Message Queuing.

Cette section traite des rubriques suivantes :

  • HTTP et HTTPS

  • SMTP

  • Message Queuing 2.0

  • Fichier

Voir aussi

Sélection d'un type de transport

Définition des propriétés de transport


HTTP et HTTPS

Le protocole HTTPS permet d'offrir une authentification forte lorsque vous utilisez HTTP pour accéder à des données sur le Web. HTTPS est utilisé le plus souvent pour assurer une connexion cryptée à un serveur Web qui requiert une authentification. Lorsque des clients tentent d'établir une connexion HTTPS (généralement par le biais d'une URL commençant par https://), le client et le serveur négocient un protocole de sécurité commun, puis échangent les informations d'authentification.

Microsoft Internet Explorer 5 (ou les versions ultérieures) gère les principaux protocoles de communication sécurisés pour les transactions HTTP :

  • TLS version 1.0 (Transport Layer Security)

  • SSL versions 2 et 3 (Secure Sockets Layer)

  • PCT version 1.0 (Private Communications Technology)

Chaque protocole fournit des services de cryptage (pour garantir la confidentialité des données échangées) et des services d'authentification (pour garantir une identification mutuelle entre les clients et les serveurs). La prise en charge de SSL, par le biais du service de transport HTTPS intégré, ajoute une authentification de serveur à serveur et un cryptage de la couche de transport dans un échange.

BizTalk Server et HTTPS permettent d'échanger des données de manière sécurisée au sein d'une organisation ou avec un partenaire commercial par le biais de HTTP. Des informations détaillées sont fournies ci-après concernant l'utilisation de HTTP et de HTTPS pour envoyer et recevoir des données dans BizTalk Server 2000.

Envoyer

Les services de transport HTTP et HTTPS permettent de sécuriser les données envoyées à une application ou à un partenaire commercial. La sécurité de ces services de transport repose sur les certificats.

Par exemple, avant d'envoyer des données sur HTTP, un administrateur BizTalk Server envoie une copie du certificat client à un partenaire commercial. Ce dernier garde une copie du certificat dans le magasin de certificats BizTalk. Par la suite, le certificat est utilisé pour authentifier le partenaire commercial qui envoie des données. Un gestionnaire de certificats unique doit être créé pour envoyer ou exporter un certificat vers un partenaire commercial.

Réception

Pour sécuriser les données sur HTTP, BizTalk Server utilise les services IIS (Microsoft Internet Information Services) et les pages ASP. Lorsque le protocole HTTPS est utilisé pour la connexion à IIS, le client et le navigateur négocient un protocole commun pour sécuriser le canal. Si le serveur et le client ont plusieurs protocoles en commun, IIS sécurise le canal avec un protocole reconnu, tel que SSL. Pour sécuriser les données qui sont reçues par BizTalk Server sur HTTP, la procédure est identique. La page ASP fait office de passerelle pour l'envoi des données à BizTalk Server. Si les données sont sécurisées, BizTalk Server reçoit les données dans la mesure où le code ASP utilise la méthode Submit ou SubmitSync pour effectuer un appel.

Voir aussi

Sélection d'un type de transport

Définition des propriétés de transport


SMTP

Le protocole SMTP (Simple Mail Transfer Protocol) est utilisé pour l'envoi de messages électroniques entre des serveurs. SMTP est un protocole couramment utilisé pour l'envoi de messages sur Internet. Un message électronique peut être récupéré avec un client de messagerie qui utilise un serveur POP ou IMAP. De plus, SMTP permet d'envoyer des messages d'un client de messagerie à un serveur de messagerie. Lors de la configuration d'une application de messagerie, le serveur POP ou IMAP et le serveur SMTP doivent être spécifiés.

SMTP permet d'échanger des données de manière sécurisée avec une organisation ou un partenaire commercial. BizTalk Server 2000 utilise SMTP pour envoyer et recevoir des données à l'aide des méthodes suivantes :

Envoyer

BizTalk Server implémente un protocole de transport pour envoyer des données via SMTP. SMTP requiert au minimum un codage MIME des données. BizTalk Server peut ainsi identifier la fin d'un groupe de données et le début du groupe de données suivant. Cependant, le codage MIME ne garantit pas la sécurité des données. S/MIME est la version sécurisée de la version MIME. L'utilisation des composants de codage S/MIME intégrés permet de garantir l'intégrité des documents, l'authentification de l'expéditeur et le cryptage du transport de données. BizTalk Server crée un document S/MIME dans lequel le message crypté constitue le corps du document. Pour ajouter cette sécurité supplémentaire, un certificat doit être associé au message MIME. Le codage MIME peut être spécifié lorsque les ports d'échanges sont créés dans le Gestionnaire d'échanges BizTalk, lequel permet également de spécifier les certificats.

Réception

Pour implémenter la sécurité au niveau de la réception de SMTP à l'aide de Microsoft Exchange Server, un administrateur doit créer un compte de réception pour BizTalk Server. Une fois que le compte est configuré, les partenaires commerciaux transmettent leurs clés publiques à Exchange Server qui authentifie l'expéditeur (partenaire commercial). La clé publique est ajoutée au magasin de certificats d'Exchange Server.

Lorsque Exchange Server reçoit un message, la méthode Submit envoie les données à BizTalk Server qui compare le certificat à la clé publique ; s'ils correspondent, BizTalk Server décode les données et traite le document.

Voir aussi

Éléments de port d'échanges

Sélection d'un type de transport

Sélection d'un certificat de cryptage

Définition des propriétés de transport


Message Queuing 2.0

Message Queuing 2.0 gère la confidentialité et la sécurité des données grâce aux procédures suivantes :

  • Contrôle d'accès

  • Audit

  • Cryptage

  • Authentification

Message Queuing tire également parti du protocole de sécurité Kerberos V5 de Microsoft Windows 2000. De plus, les cryptages 128 bits et 40 bits sont gérés. Message Queuing facilite l'instauration d'un environnement de diffusion d'événements métiers de type « push » et la création d'applications fiables fonctionnant sur des réseaux non sécurisés mais avantageux en termes de coûts.

Message Queuing permet d'échanger des données de manière sécurisée au sein d'une organisation et avec un partenaire commercial. BizTalk Server 2000 recourt à Message Queuing pour envoyer et recevoir les données à l'aide des méthodes suivantes :

Envoyer

Le nom d'utilisateur et le mot de passe constituent le premier niveau de sécurité de Message Queuing, et ils sont requis pour stocker des données ou récupérer des données de Message Queuing. Message Queuing peut en outre stocker des données auxquelles est associé un certificat. Les utilisateurs peuvent recourir au Gestionnaire d'échanges BizTalk pour spécifier un certificat pour les données stockées sur une file d'attente de messages.

Réception

Si un administrateur crée des propriétés de connexion pour une file d'attente de messages, un nom d'utilisateur et un mot de passe sont nécessaires pour récupérer les données. La création de propriétés de connexion forme une sécurité fondamentale. Si l'un de vos partenaires commerciaux a ajouté un certificat aux données, vous devez recevoir une copie de sa clé privée pour décrypter les données avant que BizTalk Server puisse traiter le package.

Voir aussi

Ajout d'une fonction de réception Message Queuing

Configuration des propriétés avancées des fonctions de réception de fichier et Message Queuing

Configuration d'une fonction de réception Message Queuing : Onglet Général

Configuration d'une fonction de réception Message Queuing : Onglet Services

Sélection d'un type de transport

Définition des propriétés de transport


Fichier

Microsoft Windows 2000 garantit la protection des données et du système en définissant un contrôle d'accès conditionnel aux fichiers. Le système de fichiers NTFS de Windows, requis pour BizTalk Server 2000, peut empêcher les utilisateurs d'endommager les fichiers d'application pour le système de clés. NTFS offre également une sécurité importante pour les fichiers de prise en charge dans une application.

Le stockage de fichiers permet également d'échanger des données de manière sécurisée au sein d'une organisation et avec un partenaire commercial. Il permet également d'envoyer et de recevoir des données :

Envoyer

Le nom d'utilisateur et le mot de passe constituent le premier niveau de sécurité pour le stockage des fichiers. Un nom d'utilisateur et un mot de passe sont requis pour le stockage ou la récupération des données dans un dossier. De plus, les dossiers peuvent stocker des données auxquelles est associé un certificat. Pour utiliser cette sécurité supplémentaire, utilisez le Gestionnaire d'échanges BizTalk afin de créer un certificat pour les données à stocker dans un dossier.

Réception

Si les propriétés de connexion à un dossier ont été appliquées, un nom d'utilisateur et un mot de passe sont nécessaires pour récupérer les données. Un administrateur peut également déterminer les niveaux d'accès (lecture, suppression, etc.) des différents utilisateurs au répertoire de fichiers. Si l'un de vos partenaires commerciaux a ajouté un certificat aux données, vous devez recevoir une copie de sa clé privée pour décrypter les données avant que BizTalk Server puisse traiter le package. Les documents entrants peuvent également disposer d'une signature numérique pour s'assurer que la source ne peut pas nier avoir envoyé le document.

Voir aussi

Ajout d'une fonction de réception de fichier

Configuration des propriétés avancées des fonctions de réception de fichier et Message Queuing

Configuration d'une fonction de réception de fichier : Onglet Général

Configuration d'une fonction de réception de fichier : Onglet Services

Sélection d'un type de transport

Définition des propriétés de transport


Sécurité des applications hébergeant des instances de planification XLANG

Une fois que vous avez installé les services d'Orchestration BizTalk, vous pouvez définir des niveaux de sécurité pour les éléments suivants :

  • Création de nouvelles instances de planification XLANG

  • Interaction avec les instances de planification XLANG existantes

  • Fonctions d'administration liées aux instances de planification XLANG

  • Applications hébergeant des instances de planification XLANG

Les applications qui hébergent des instances de planification XLANG s'appuient sur la sécurité liée aux rôles, laquelle constitue un service automatique fourni par COM+. La sécurité liée aux rôles permet aux utilisateurs de créer et de renforcer une stratégie de contrôle d'accès pour les applications COM+. Grâce à un modèle de configuration souple et modulable, la sécurité liée aux rôles est beaucoup plus avantageuse que la mise en oeuvre de l'intégralité de la sécurité au sein des composants. Il existe deux applications COM+ par défaut, XLANG Scheduler et le programme d'assistance XLANG Scheduler Persistence Helper ; elles sont automatiquement créées lorsque les services d'Orchestration BizTalk sont installés. L'application XLANG Scheduler COM+ comporte quatre rôles qui permettent d'assurer la sécurité des instances de planification, indépendamment de l'application COM+ dans laquelle ils sont exécutés. Ces quatre rôles sont les suivants :

  • Créateur de planification XLANG : ce rôle permet aux utilisateurs spécifiés de créer des instances de planification XLANG. Par exemple, si un administrateur souhaite qu'un utilisateur soit en mesure de créer une instance de planification XLANG, il doit ajouter cet utilisateur à la liste des membres de ce rôle. Si un utilisateur non membre de ce rôle tente de créer une instance de planification XLANG, un message d'erreur l'avertit que l'accès lui est refusé. En outre, une entrée est générée dans le journal d'événements, indiquant que l'accès a été refusé.

  • Utilisateur de planification XLANG : ce rôle permet aux utilisateurs spécifiés d'interagir avec les instances de planification XLANG. Par exemple, si un administrateur souhaite qu'un utilisateur soit en mesure d'interagir avec une instance de planification, il doit ajouter cet utilisateur à la liste de membres de ce rôle. Si un utilisateur non membre de ce rôle tente d'interagir avec une instance de planification, un message d'erreur l'avertit que l'accès lui est refusé. En outre, une entrée est générée dans le journal d'événements, indiquant que l'accès a été refusé.

  • Administrateur de XLANG Scheduler : ce rôle peut être utilisé pour spécifier quels utilisateurs disposent de droits d'administration pour les opérations suivantes :
    • Déterminer si une application COM+ est en mesure d'agir en tant qu'hôte pour les instances de planification XLANG.

    • Définir le type DSN d'une application COM+ hébergeant des instances de planification XLANG et définir la valeur de gestion de l'état correspondant au niveau de persistance que l'application COM+ doit prendre en charge.

    • Fermer toutes les instances de planifications XLANG.

    • Suspendre, reprendre ou mettre fin à une instance de planification XLANG.
  • Application XLANG Scheduler : ce rôle est utilisé par l'application XLANG Scheduler pour interagir avec les applications COM+ créées par un utilisateur. Par conséquent, l'identité du rôle doit être la même que celle utilisée par l'application COM+ pour l'exécution.

Cette section traite des rubriques suivantes :

  • Méthodes optimales pour la sécurisation des applications COM+

  • Sécurisation de la base de données de persistance d'orchestration

  • Confirmation de l'identité de l'expéditeur

Voir aussi

Planifications XLANG


Méthodes optimales pour la sécurisation des applications COM+

Grâce aux rôles, un administrateur peut construire une stratégie en fonction des droits d'administration pour une application, en choisissant (jusqu'au niveau de la méthode, si besoin est) les droits d'accès des différents utilisateurs aux différentes ressources. Dans la mesure où toutes les planifications XLANG sont hébergées dans des applications serveur COM+, il est possible de configurer les propriétés de la sécurité des différents rôles afin de limiter l'accès aux objets COM installés.

Important

  • Si les propriétés de la sécurité sont ajoutées au niveau des composants, les méthodes, les interfaces et les composants individuels basés sur les paramètres des rôles à ces niveaux sont également limités. Pour plus d'informations sur la sécurité COM+, accédez au site Web MSDN Online Library (msdn.microsoft.com/library/default.asp), puis consultez la page traitant de la sécurité dans les applications COM+.

Recommandations pour la sécurité des applications COM+

Les recommandations suivantes s'appliquent principalement à la sécurisation des applications déployées :

  • Ne pas configurer une application COM+ en tant qu'utilisateur interactif : les applications COM+ qui utilisent l'identité d'utilisateur interactif peuvent être utilisées uniquement si un utilisateur est connecté à l'ordinateur sur lequel réside l'application. Si aucun utilisateur n'est connecté, l'application COM+ ne peut pas être exécutée. De plus, si un utilisateur crée une application COM+ avec un utilisateur interactif, il sera plus difficile de configurer l'accès à sa base de données de persistance et aux autres ressources. Pour plus d'informations sur les comptes de services, voir Utilisation d'un compte de services.

  • Reconfigurer l'identité de XLANG Scheduler : lors de l'installation, l'identité de XLANG Scheduler est automatiquement configurée en tant qu'utilisateur interactif. Cette configuration convient à la plupart des développeurs. Sur les systèmes de production, vous devez changer la propriété de l'identité de XLANG Scheduler pour que l'application s'exécute uniquement sous un compte d'utilisateur unique. L'identité est utilisée par tous les messages envoyés par l'application XLANG Scheduler.

    Remarque

    • Lorsque vous utilisez le client pour les services Terminal Server Microsoft Windows 2000 afin d'initier une planification XLANG, l'identité de l'application COM+ hébergeant le moteur de XLANG Scheduler doit correspondre à un nom d'utilisateur ou de groupe Windows 2000 valide. L'identité de l'application COM+ est définie dans la page Identité de la boîte de dialogue des propriétés de cette application. L'identité ne peut être interactive lorsque vous utilisez le moteur de XLANG Scheduler dans une session hébergée par les services Terminal Server.
  • Créer une nouvelle application COM+ avec une identité unique pour chaque application hébergeant des instances de planification XLANG : créez une application COM+ qui comporte une identité unique pour chaque traitement professionnel (tel que l'achat) ainsi que des spécifications de sécurité uniques. Ainsi, le niveau de sécurité peut être spécifié séparément pour chaque application. De plus, les dommages pouvant découler des codes d'application non stables sont minimisés, et il est plus facile d'effectuer un audit des opérations des applications séparément.

  • Installer des composants propres aux applications dans leurs traitements professionnels associés : les données sont protégées et les applications qui n'ont pas accès à ces composants sont exclues, à condition que le serveur d'applications soit protégé correctement.

    Remarque

    • Chaque application COM+ doit contenir au minimum un composant. Si un composant propre à une application n'est pas installé, un composant fictif doit être créé et installé dans l'application, sinon l'application COM+ ne sera pas disponible.
  • Modifier les paramètres par défaut de la liste des membres des rôles de XLANG Scheduler afin d'offrir une sécurité renforcée : lors de l'installation de BizTalk Server, l'application XLANG Scheduler est créée et configurée avec les rôles suivants et les paramètres par défaut correspondants :
    • Créateur de planification XLANG : l'appartenance au rôle correspond par défaut à Tout le monde.

    • Utilisateur de planification XLANG : l'appartenance au rôle correspond par défaut à Tout le monde.

    • Administrateur de XLANG Scheduler : l'appartenance au rôle correspond par défaut à Administrateurs.

    • Application XLANG Scheduler : l'appartenance au rôle correspond par défaut à Tout le monde.

Voir aussi

Modification de l'identité de l'application XLANG Scheduler par défaut

Création d'une application COM+ pour héberger des planifications XLANG

Planifications XLANG


Sécurisation de la base de données de persistance d'orchestration

Lorsqu'une application COM+ hébergeant des instances de planification XLANG est créée, une base de données de persistance doit être associée à l'application COM+. Vous devez donc créer en premier lieu une base de données de persistance dans Microsoft SQL Server. Lors de la création d'une base de données, vous devez opter pour l'authentification SQL Server ou Microsoft Windows 2000 pour la sécurité. Une fois la base de données créée, vous devez attribuer des autorisations pour l'application COM+ qui sera créée ultérieurement pour héberger les instances de planification XLANG. Assurez-vous que l'application COM+ dispose d'autorisations pour créer des tables et des procédures dans la base de données de persistance associée. L'interaction entre les services d'Orchestration BizTalk et la base de données de persistance d'orchestration BizTalk Server par défaut repose sur le modèle de sécurité Windows 2000 plutôt que sur le modèle SQL Server.

Voir aussi

Gestion de l'application et de la base de données XLANG Scheduler par défaut


Confirmation de l'identité de l'expéditeur

Lors de la conception de la planification, différentes formes peuvent être utilisées pour décrire les technologies d'implémentation permettant d'implémenter un port dans un traitement professionnel. La forme Composant COM représente une technologie pouvant être utilisée pour implémenter un port en ayant recours à un appel de méthode pour chaque message envoyé ou reçu. La forme Composant de script représente une technologie pouvant être utilisée pour implémenter un port en ayant recours à un appel de méthode pour chaque message envoyé ou reçu. La forme Message Queuing représente une technologie pouvant être utilisée pour implémenter un port. Les services de transport Message Queuing permettent d'envoyer ou de recevoir des messages. Lorsque vous ajoutez l'une de ces trois technologies, vous pouvez exiger que l'identité de l'expéditeur soit confirmée avant la réception des messages.

Pour plus d'informations sur les composants COM, les composants de script Windows ou la sécurité de Message Queuing pour les planifications XLANG, voir Implémentation d'un port en utilisant un composant COM, Implémentation d'un port en utilisant un composant de script Windows, et Implémentation d'un port à l'aide de Message Queuing.

Voir aussi

Utilisation de la forme Composant COM

Utilisation de la forme Message Queuing

Utilisation de la forme composant de script


Présentation des certificats

Les certificats numériques lient une clé de cryptage à un ou plusieurs attributs d'un utilisateur. Les certificats sont émis par des organismes de certification et ils protègent les échanges sur Internet en assurant l'authenticité des messages sur le réseau. Cette technologie ainsi que les signatures numériques sur lesquelles elle repose sont actuellement un facteur responsable de la croissance du commerce électronique sur Internet.

Cette section traite des rubriques suivantes :

  • Présentation des certificats

  • Certificats requis par BizTalk Server

  • Restrictions des noms de certificat


Présentation des certificats

La sécurité offerte par les certificats est un élément important de Microsoft BizTalk Server 2000. Grâce aux clés publiques qui cryptent les données et aux clés privées qui permettent le décryptage des données, BizTalk Server peut envoyer des données fiables et garantir que les données traitées sont sécurisées. Les stratégies de clés publiques, qui font partie de la console MMC (Microsoft Management Console), permettent aux utilisateurs de configurer des agents de récupération des données cryptées pour EFS (Encrypting File System), des autorités de certification racine au niveau du domaine, des autorités de certification de confiance, etc. Les certificats contiennent également des signatures numériques qui peuvent être appliquées aux documents et vérifiées pour les documents entrants grâce à la prise en charge native des signatures numériques par BizTalk Server.

Les certificats permettent d'authentifier et de sécuriser les données échangées sur des réseaux non sécurisés, comme Internet. Les certificats peuvent être gérés pour un utilisateur, un ordinateur ou un service. Certificate Server X.509 est intégré à Windows 2000 Server et permet aux organisations d'émettre des certificats avec clés publiques pour l'authentification de leurs utilisateurs, sans être tributaire des services des autorités de certification.

Dans BizTalk Server, les certificats sont pris en charge par le biais du Gestionnaire d'échanges BizTalk. Les certificats facilitent le cryptage, le décryptage et la signature numérique des données. La technologie de cryptage avec clé publique est prise en charge pour tous les documents qui sont transmis par le biais des services de transport BizTalk Server. BizTalk Server gère en outre le décryptage et la vérification des signatures des documents reçus.

Comparaison entre MachineKeys et UserKeys

Pour obtenir des certificats, il est préférable d'utiliser MachineKeys, associé à l'ordinateur, plutôt que UserKeys, associé à l'utilisateur actuellement connecté. Si un utilisateur connecté à un serveur obtient un certificat à l'aide de UserKeys, lui seul peut accéder au certificat car le UserKey du certificat contient les informations de connexion le concernant. Par conséquent, si des utilisateurs souhaitent accéder dans BizTalk Server aux certificats à l'aide de UserKeys, BizTalk Server doit être exécuté dans le contexte de cet utilisateur. Pour permettre à tout utilisateur de se connecter à BizTalk Server et d'accéder aux clés, les certificats doivent détenir des MachineKeys.

Pour permettre à BizTalk Server d'accéder aux Certificats (Ordinateur local), BizTalk Server doit s'exécuter comme Système local (LocalSystem) ou Administrateur. De plus, en cas d'utilisation des UserKeys, BizTalk Server doit s'exécuter dans le contexte de cet utilisateur, qui doit également être un administrateur.


Certificats requis par BizTalk Server

Un serveur de certificats stocke les certificats d'un utilisateur ou d'un ordinateur. Chaque utilisateur dispose d'un magasin de certificats, et chaque ordinateur dispose de ses propres magasins de certificats. Si un utilisateur crée un certificat, Windows 2000 suppose que le certificat est pour l'utilisateur. Une organisation doit stocker ses certificats dans le magasin Personnel situé sous Certificats (Ordinateur local) sur la console Certificats. Toutefois, afin de fournir la sécurité adaptée, BizTalk Server 2000 a besoin que tous les certificats des partenaires commerciaux soient stockés dans le magasin BizTalk situé sous Certificats (Ordinateur local) sur la console Certificats.

Durant la conception, lorsque les ports d'échanges et les canaux sont créés, tous les certificats des partenaires commerciaux doivent être associés au magasin BizTalk, situé sous Certificats (Ordinateur local) sur la console Certificats, plutôt qu'à l'utilisateur. Lors de la spécification de la sécurité des partenaires commerciaux (telle que le cryptage ou la vérification de signatures) par le biais du Gestionnaire d'échanges BizTalk, les certificats affichés sont ceux des partenaires commerciaux, qui se trouvent dans le magasin BizTalk. Le Gestionnaire d'échanges BizTalk affiche les certificats qui se trouvent dans le magasin Personnel situé sous Certificats (Ordinateur local) sur la console Certificats lors de la spécification de la sécurité (la vérification du décryptage et de la signature notamment) pour les clients SSL. L'emplacement des certificats est important car lorsqu'un utilisateur tente de traiter des documents par le biais de BizTalk Server à l'exécution, l'ordinateur agit en tant que service d'arrière-plan, et c'est ce service qui doit accéder aux certificats.

Il existe deux méthodes pour résoudre les problèmes liés à l'emplacement de stockage des certificats :

  • Si un utilisateur possède déjà des certificats, Windows 2000 les a stockés dans le magasin de l'utilisateur. Les certificats doivent être déplacés du magasin de l'utilisateur vers le magasin BizTalk sous Certificats (Ordinateur local). Cette procédure est effectuée par le biais du Gestionnaire de certificats.

  • Si un utilisateur a créé un compte de services, tous les certificats sont associés à l'ordinateur et non à l'utilisateur.

Gestion des certificats par le biais de Windows 2000

BizTalk Server offre une gestion des certificats par le biais de Windows 2000. IIS 5.0 est étroitement intégré au modèle de sécurité de Windows 2000 et inclut un serveur de certificats. Ainsi, les organisations peuvent émettre et gérer les certificats numériques X.509 au standard Internet. Outre les services de gestion clés dans IIS 5.0, le serveur de certificats Microsoft dans in IIS 5.0 inclut des services personnalisables d'émission et de gestion de certificats numériques. Un serveur de certificats joue un rôle central dans la gestion des systèmes de sécurité des logiciels pour permettre des communications sécurisées sur Internet, les intranets d'entreprise et d'autres réseaux non sécurisés.

Cette section traite de la rubrique suivante :

  • Création d'un gestionnaire de certificats

Voir aussi

Sélection d'un certificat pour la signature sortante

Sélection d'un certificat pour vérifier le décryptage d'un document entrant

Sélection d'un certificat pour vérifier la signature d'un document entrant

Sélection d'un certificat de cryptage


Création d'un gestionnaire de certificats

  1. Dans le menu Démarrer, cliquez sur Exécuter, puis tapez mmc.

    La boîte de dialogue Console1 apparaît.

  2. Dans le menu Console, cliquez sur Ajouter/Supprimer un composant logiciel enfichable.

    La boîte de dialogue Ajouter/Supprimer un composant logiciel enfichable apparaît.

  3. Cliquez sur Ajouter.

    La boîte de dialogue Ajout d'un composant logiciel enfichable autonome s'affiche.

  4. Cliquez sur Certificats, puis sur Ajouter.

    La boîte de dialogue Composant logiciel enfichable Certificats s'affiche.

  5. Cliquez sur Le compte de l'ordinateur, sur Suivant, puis sur Terminer.

  6. Dans la boîte de dialogue Ajout d'un composant logiciel enfichable autonome, cliquez sur Certificats, puis sur Ajouter.

    La boîte de dialogue Composant logiciel enfichable Certificats s'affiche.

  7. Cliquez sur Le computer de l'ordinateur, Suivant, Terminer, Fermer, puis cliquez sur OK pour fermer les boîtes de dialogue.

Voir aussi

Présentation des certificats


Restrictions des noms de certificat

Microsoft BizTalk Server 2000 n'autorise pas les noms identiques pour les certificats. Si plusieurs certificats portent le même nom, seul l'un d'entre eux peut être sélectionné dans le Gestionnaire d'échanges BizTalk. Par exemple, si une organisation utilise deux certificats qui partagent le même nom et la même référence, l'organisation ne peut pas utiliser les deux certificats. Si elle utilise l'un des certificats, l'autre disparaît de la liste des certificats disponibles dans la boîte de dialogue Canal.


Crypto API

Microsoft BizTalk Server 2000 utilise Crypto API pour sécuriser les données traitées. Les récentes évolutions en matière de cryptographie ont donné lieu à de nouvelles utilisations, notamment des mécanismes pour l'authentification des utilisateurs sur un réseau, ce qui permet de garantir l'intégrité des données transmises et d'empêcher les utilisateurs de nier qu'ils sont à l'origine des messages transmis.

Toutes les applications, toutes les données et tous les messages qui recourent au cryptage et au cryptage Microsoft (comme Microsoft Windows 2000 pour générer des certificats) utilisent Crypto API. BizTalk Server utilise Crypto API pour les fonctions de réception qu'un utilisateur spécifie lorsqu'il utilise un composant COM+ personnalisé, tel que le composant de prétraitement, ce qui permet à BizTalk Server de gérer des composants de cryptage uniques.


CDO (Collaborative Data Objects)

Microsoft BizTalk Server 2000 requiert un codage MIME de toutes ses données, que ce soit au niveau de la réception ou de l'envoi. Grâce aux objets CDO (Collaborative Data Objects), lesquels font partie de l'environnement Windows 2000, les données peuvent être codées et traitées par BizTalk Server. Par exemple, pour que BizTalk Server puisse envoyer un catalogue contenant du texte et des graphiques, les données (graphiques) doivent d'abord passer de l'état binaire à l'état de chaîne. Les objets CDO codent le texte et les graphiques dans un format de chaîne que BizTalk Server est en mesure de traiter.


Amélioration des performances et de l'évolutivité

La compréhension des différents composants de BizTalk Server 2000 vous permettra de créer des solutions évolutives et à haute performance. Il existe plusieurs méthodes pour augmenter les performances de BizTalk Server, comme l'identification des goulots d'étranglement potentiels, la résolution des problèmes de temps de latence et la gestion des bases de données. Toutefois, le degré d'optimisation que vous pouvez atteindre pour votre solution dépend de la complexité de l'architecture du système de votre organisation et des contraintes budgétaires.

L'optimisation de la base de données Gestion d'échanges BizTalk, de la base de données de files d'attente partagées, de la base de données de suivi et de la base de données de persistance d'orchestration est essentielle pour obtenir des performances optimales avec BizTalk Server. Pour plus d'informations sur l'optimisation des bases de données, voir Évolution verticales des bases de données et Évolution horizontale des bases de données.

Cette section traite des rubriques suivantes :

  • Évolution de BizTalk Server

  • Optimisation des performances


Évolution de BizTalk Server

Pour optimiser les performances, il est conseillé de distribuer des composants clés sur plusieurs serveurs. Les composants clés de BizTalk Server 2000 sont les suivants :

  • Services BizTalk. Ces services comprennent les services d'échanges BizTalk et les services d'Orchestration BizTalk. Pour plus d'informations, voir Services BizTalk.

  • Bases de données. Ces bases de données sont les bases de données Gestion d'échanges BizTalk, de suivi, de files d'attente partagées et de persistance d'orchestration.

  • Services de transport. Les services de transport comprennent HTTP, File, SMTP et Message Queuing. Chaque composant a ses propres besoins d'évolution.

Cette section traite des rubriques suivantes :

  • Évolution verticale de BizTalk Server

  • Évolution horizontale de BizTalk Server

Voir aussi

Gestion des bases de données BizTalk Server

Gestion de la base de données Gestion d'échanges BizTalk

Persistance

Définition des propriétés de transport

Base de données de files d'attente partagée

Base de données de suivi


Évolution verticale de BizTalk Server

L'utilisation de plusieurs processeurs et d'une mémoire importante permet de faire évoluer BizTalk Server 2000 verticalement. L'évolution verticale de BizTalk Server nécessite un peu moins de serveurs et simplifie la gestion des sites mais elle entraîne des coûts plus élevés que l'évolution horizontale ou que l'amélioration de l'architecture logicielle. De plus, une fois la capacité du matériel existant maximisée, vous devez commencer à faire évoluer le système horizontalement.

Cette section traite des rubriques suivantes :

  • Évolution verticale de BizTalk Server

  • Évolution verticale des bases de données

  • Évolution verticale des services de transport


Évolution verticale de BizTalk Server

Pour faire évoluer BizTalk Server 2000 verticalement, il est recommandé d'effectuer les opérations suivantes :

  • Augmenter la taille du processeur (utiliser par exemple un Pentium III et les dérivés du processeur Xeon avec des mémoires cache de second niveau).

  • Utiliser des serveurs SMP (Symmetric multiple processing) qui combinent jusqu'à huit unités centrales.

  • Diminuer les E/S de fichiers et les goulots d'étranglement du réseau.

  • Exécuter Microsoft Windows 2000 Server sur des serveurs SMP à quatre voies.

    Remarque

    • Lorsque Microsoft Windows 2000 Server fonctionne sur une unité centrale, l'ajout de trois unités supplémentaires améliore les performances mais la vitesse de traitement de chaque unité n'est pas multipliée par quatre.

Recommandations pour l'évolution verticale de BizTalk Server

Pour obtenir des performances optimales avec BizTalk Server, la configuration suivante est recommandée :

  • Système multiprocesseur Xeon PIII (avec la vitesse la plus élevée en MHz pour des performances maximales), qu'il est possible de faire évoluer à huit UC.

  • Cache de second niveau (L2) de 1 à 2 Mo pour le processeur (pour augmenter les performances d'analyse).

  • 512 Mo de RAM (davantage si une organisation traite des documents de plusieurs méga-octets).

  • Plusieurs cartes réseau de 100 Mbits/s (mégabits par seconde) ou supérieur, connectées à des ports de commutateurs 100 Mbits/s pour augmenter le débit d'E/S du réseau.

  • Fournir plusieurs disques et plusieurs contrôleurs pour les opérations de fichier et de journalisation du Coordinateur de transactions distribuées (DTC, Distributed Transaction Coordinator) et du système Message Queuing. Enregistrer les opérations de journalisation DTC sur un serveur distant central afin de décharger la contention d'E/S de fichiers sur le serveur BizTalk Server local.

  • Utiliser des cartes interface réseau NIC sur les serveurs BizTalk Server pour distinguer les processus HTTP des processus SQL Server dédiés des bases de données de files d'attente partagées et Gestion d'échanges BizTalk.

  • Ces recommandations supposent que BizTalk Server fonctionne sur un serveur dédié. Si les services BizTalk partagent le serveur avec d'autres services d'applications, il est conseillé d'utiliser du matériel supplémentaire.


Évolution verticale des bases de données

Pour faire évoluer les bases de données verticalement, vous devez déterminer la configuration nécessaire pour le disque. La configuration du disque se détermine en fonction du débit, de la reprise après incident et des coûts.

Le tableau suivant identifie les options disponibles et propose une comparaison.

Niveau RAID | Coût | Pourcentage d'utilisation effective du disque | Vitesse | Tolérance de panne
0 (Agrégat par bandes) | Faible | 100 | Rapide | Faible
1 (Fonctionnement en miroir) | Élevée | 50 | Moyen | Élevée
5 (Agrégat par bandes avec parité) | Modéré | L'espace disque effectif est l'espace total de tous les disques de l'ensemble moins 1 (pour la parité) | Faible | Modérée (uniquement car les performances se dégradent lorsqu'un disque est défaillant)

Pour obtenir des performances optimales, il est recommandé d'installer un contrôleur RAID (Redundant Array of Independent Disks) équipé d'une UC rapide et d'une grande quantité de mémoire RAM non volatile. Vous pouvez aussi combiner plusieurs niveaux RAID pour obtenir les performances recherchées. Par exemple, le niveau RAID 0 permet les meilleures performances mais ne fournit pas la tolérance de panne. Le niveau RAID 1 permet la meilleure tolérance de panne mais ne permet pas les meilleures performances (l'écriture des données se fait sur un seul disque et non sur plusieurs disques, simultanément). Pour obtenir des performances optimales, vous pouvez combiner les niveaux RAID 1 et RAID 0 en mettant en miroir un agrégat par bandes avec parité.

Remarques

  • Le niveau RAID 5 n'atteint pas la vitesse et le coût des autres niveaux RAID. Ce niveau apporte des avantages clés mais l'écriture des données sur les disques se fait plus lentement qu'avec le niveau RAID 0 ou RAID 1.

  • Quelle que soit la stratégie adoptée, le nombre de contrôleurs de disques est une donnée critique. Vous pouvez améliorer nettement les performances générales en utilisant un disque par contrôleur. Lors de la configuration des disques, il est important de penser à une utilisation efficace des canaux de disques. Les canaux de disques sont des disques qui partagent le même contrôleur. Il est possible de configurer ces disques comme des disques autonomes ou de les configurer comme des disques faisant partie d'un arrangement de disques. Par exemple, si vous disposez d'un serveur équipé de 10 disques, soit 5 disques dans deux arrangements de disques, et que chaque arrangement de disques est connecté à son propre contrôleur, vous disposez dès lors de 2 canaux de disques.

Idéalement, il est préférable de placer les bases de données Gestion d'échanges BizTalk, de files d'attentes partagées, de suivi et de persistance d'orchestration dans des canaux de disques distincts. Cependant, si l'environnement du système de votre organisation impose l'installation des bases de données sur des serveurs séparés, il est important de comprendre l'utilisation de chacune d'elles lorsque vous planifiez le scénario de déploiement.

  • La base de données Gestion d'échanges BizTalk contient toutes les données de configuration, telles que les données relatives aux groupes de serveurs des organisations, aux serveurs, aux canaux et aux ports d'échanges pour BizTalk Server. Ces données sont lues et mises en cache dans la mémoire Microsoft SQL Server. Cette base de données reçoit les dernières opérations des quatre bases de données et peut être installée, si nécessaire, sur le même canal de disques que l'une des trois autres bases de données.

  • La base de données de files d'attente partagées gère les données pour toutes les files d'attente. Tous les documents qui utilisent un mode de communication asynchrone sont transmis et stockés dans la base de données de files d'attente partagées. Lorsque BizTalk Server est prêt à traiter un document, celui-ci est retiré de la base de données de files d'attente partagées pour être traité. Du fait que cette base gère toutes les transactions, les données sont enregistrées et lues fréquemment à partir de la base de données de files d'attente partagées.

  • La base de données de suivi permet de suivre les documents qui transitent par le serveur, individuellement ou dans des lots. Cette base de données contient les données et les informations de journalisation les concernant. Par conséquent, les données sont souvent enregistrées dans la base de données de suivi mais elles y sont rarement lues.

  • La base de données de persistance d'orchestration par défaut stocke la structure des planifications XLANG, les données relatives à la progression des instances de planification XLANG activées et les messages envoyés ou reçus lorsqu'une instance de planification XLANG débute ou termine une transaction, lorsque le système est arrêté ou lorsque l'instance d'une planification XLANG est réactivée.

Recommandations d'optimisation pour l'évolution verticale des bases de données

Tenez compte des données suivantes pour obtenir des performances optimales avec les bases de données BizTalk Server :

  • Système multiprocesseur Xeon PIII (avec la vitesse la plus élevée en MHz pour des performances maximales), qu'il est possible de faire évoluer à huit UC.

  • 512 Mo de RAM (davantage si une organisation traite des documents de plusieurs méga-octets).

  • Optimisez les bases de données Microsoft SQL Server sous-jacentes et les journaux en vous basant sur les meilleures méthodes adoptées pour les bases de données standard. Pour plus d'informations sur Microsoft SQL Server, dans le menu Démarrer, pointez sur Programmes et sur Microsoft SQL Server, puis cliquez sur Documentation en ligne.

  • Si vous prévoyez tout d'abord d'effectuer uniquement un petit nombre de transactions, vous pouvez installer les bases de données sur le même canal d'E/S de disque. Au fur et à mesure que davantage de transactions sont traitées, ajoutez des disques et/ou des contrôleurs sur un serveur et déplacez les bases de données sur ces nouveaux canaux d'E/S de disque. En outre, il est possible de déplacer une base de données sur un nouveau serveur. Pour plus d'informations sur l'évolution horizontale des bases de données, voir Évolution horizontale des bases de données.

Pour optimiser la base de données Gestion d'échanges BizTalk :

  • Installez la base de données sur le même canal d'E/S de disque en tant que base de données de files d'attente partagées ou de suivi. Le contenu de la base de données Gestion d'échanges BizTalk est lu et mis en cache dans la mémoire Microsoft SQL Server.

  • Si une organisation traite un volume important de données, vous devez envisager d'installer cette base de données sur son propre canal d'E/S de disque de façon à ne pas nuire aux performances des bases de données de files d'attente partagées et de suivi.

Pour optimiser la base de données de files d'attente partagées :

  • Si le taux d'utilisation de l'UC dépasse 80 pour cent, ajoutez des UC supplémentaires.

  • Si la file d'attente du disque est en moyenne supérieure à 1 ou si l'utilisation du disque en E/S est supérieure à 100 pour cent, ajoutez des disques physiques supplémentaires.

  • Installez la base de données sur son canal d'E/S de disque dédié.

  • Achetez des disques avec les temps d'accès les plus rapides et des contrôleurs avec le débit le plus élevé.

  • Envisagez d'utiliser le niveau RAID 0 et de le mettre en miroir pour disposer de la tolérance de panne.

Pour optimiser la base de données de suivi :

  • Ajoutez plus de disques physiques et davantage d'espace disque par rapport à l'existant pour la base de données de files d'attente partagées.

  • Évaluez la taille moyenne des documents pour une seule transaction. Multipliez la taille du document par la fréquence à laquelle le document est consigné dans la base de données de suivi. Le résultat de ce calcul donne une estimation du volume de l'espace de stockage requis par document dans la base de données de suivi. Multipliez la valeur de l'espace de stockage des documents par la valeur du débit requis pour déterminer l'espace qui est nécessaire et ainsi éviter la saturation de la base de données de suivi. Assurez-vous que la base de données de suivi dispose de suffisamment d'espace pour accepter la journalisation d'un document de taille moyenne.

  • Installez cette base de données sur son propre canal d'E/S de disque car un volume important de données y est enregistré. Dans les environnements dans lesquels le volume des transactions est massif, il est particulièrement important de disposer d'un canal d'E/S de disque distinct.

    Remarque

    • Il existe des limites de taille pour le suivi des échanges et des documents, qui, si elles sont dépassées, nuisent grandement aux performances de BizTalk Server. Pour plus d'informations sur cette limite de taille, voir Limite de la taille des documents et des échanges.

Pour optimiser la base de données de persistance d'orchestration :

  • Les données étant enregistrées et lues dans cette base de données de façon fréquente, il est conseillé de disposer d'un canal d'E/S de disque dédié pour cette base de données. Il est si possible préférable d'acheter des disques avec les temps d'accès les plus rapides et des contrôleurs avec le débit le plus élevé. Envisagez d'utiliser le niveau RAID 0 et de le mettre en miroir pour disposer de la tolérance de panne.

  • Si la capacité de l'UC dépasse 80 pour cent, ajoutez des UC supplémentaires.

  • Si la file d'attente du disque est en moyenne supérieure à 1 ou si l'utilisation du disque en E/S est supérieure à 100 pour cent, ajoutez des disques physiques supplémentaires.

Voir aussi

Évolution de BizTalk Server


Évolution verticale des services de transport

BizTalk Server 2000 prend en charge quatre services de transport. Il est possible de faire évoluer verticalement chacun de ces services de transport :

  • HTTP

  • Fichier

  • SMTP

  • Message Queuing

Cette section traite des rubriques suivantes :

  • HTTP/HTTPS (évolution verticale)

  • File (évolution verticale)

  • SMTP (évolution verticale)

  • Message Queuing (évolution verticale)


HTTP/HTTPS (évolution verticale)

Réception

La fonction de réception du service de transport HTTP/HTTPS permet d'envoyer des documents à BizTalk Server 2000 par l'appel de l'objet BizTalk Server Interchange. BizTalk Server ne dispose pas d'une fonction de réception HTTP/HTTPS unique. La fonction de réception HTTP appelle un objet local. Par conséquent, aucune latence de réseau n'existe et n'affecte les performances. Toutefois, comme la fonction de réception HTTP et BizTalk Server résident tous deux sur le même serveur, la fonction de réception HTTP doit assurer deux fonctions : transporter les données et traiter les données.

Dans les environnements dans lesquels le volume est important, l'exécution de la fonction de réception HTTP et des services BizTalk sur le même serveur nuit aux performances des deux. De plus, si SSL (secure sockets layer, également appelé HTTPS) est utilisé pour recevoir les documents, les performances sont davantage dégradées en raison du traitement du décryptage. Les besoins en sécurité d'une organisation rendent parfois nécessaire le cryptage des données avec HTTPS. Ce niveau de sécurité supplémentaire risque d'affecter les performances de BizTalk Server.

Envoi

BizTalk Server est un client HTTP/HTTPS natif. Lorsqu'un canal est configuré pour utiliser HTTP/HTTPS comme service de transport sortant, BizTalk Server utilise le service HTTP/HTTPS pour envoyer les données à un serveur HTTP/HTTPS d'un partenaire commercial. Vous ne pouvez pas déplacer le service de transport sortant HTTP/HTTPS vers un serveur distinct du serveur sur lequel sont installés les services d'échanges BizTalk. Si un serveur est configuré pour participer au traitement d'un élément de travail et qu'il traite un document utilisant un service de transport HTTP/HTTPS, c'est ce même serveur qui envoie le document. Pour plus d'informations sur le traitement des éléments de travail, voir Évolution verticale de BizTalk Server.

BizTalk Server fonctionne comme un client HTTP, ce qui affecte la puissance de sérialisation des documents du serveur. Si le port utilise les services de transport HTTPS, les performances du service de transport HTTP sont grandement atteintes. Il est impossible d'utiliser des cartes accélérateur SSL lorsqu'il fonctionne en tant que client HTTPS car ces cartes ne peuvent améliorer que les performances des serveurs HTTPS.

Optimisation recommandée pour le service HTTP/HTTPS

Pour optimiser les performances du service HTTP/HTTPS et ainsi améliorer les performances du serveur BizTalk Server :

  • Configurez le service de réception entrant HTTP/HTTPS sur un serveur différent du serveur BizTalk Server. Si le service de réception entrant HTTP/HTTPS ne peut pas être installé sur un serveur différent du serveur BizTalk Server, utilisez une UC plus rapide ou ajoutez des UC supplémentaires.

  • Augmentez la vitesse de l'UC qui est requise pour le serveur BizTalk Server (permettant de répondre aux besoins supplémentaires pour l'envoi des documents) et ajoutez des UC supplémentaires jusqu'à atteindre le niveau de performance voulu.

  • Appliquez les méthodes conseillées lorsque vous utilisez des pages ASP avec le service de réception ou d'envoi HTTP/HTTPS. Pour plus d'informations sur l'optimisation des pages ASP et des services IIS (Internet Information Services), consultez le site Web dédié à l'aide de Microsoft Internet Information Services (localhost/iisHelp) et cliquez sur Guide Active Server Pages.


File (évolution verticale)

Réception

Bien que les performances soient élevées lorsqu'une fonction de réception de fichier est utilisée pour les transactions entreprise à entreprise (B to B, business-to-business), cette fonction n'est pas sécurisée pour les transactions basées sur Internet et elle n'est donc pas largement utilisée. Cependant, dans le cadre des transactions d'application à application au sein d'une entreprise, la fonction de réception de fichier peut assurer des performances optimales sans nuire à la sécurité. De plus, il est possible d'utiliser une fonction de réception de fichier avec des partenaires commerciaux externes, à condition de l'associer à une autre fonction de réception telle que SMTP ou HTTP. La fonction de réception SMTP ou HTTP peut accepter un document émis par un partenaire commercial (en utilisant les services HTTPS ou S/MIME) et enregistrer le fichier dans un répertoire de système de fichiers externe. BizTalk Server peut ensuite utiliser une fonction de réception de fichier pour recevoir le document. Cette combinaison de services de transport risque de ne pas augmenter les performances mais permet une plus grande flexibilité et une plus grande sécurité.

Remarque

  • L'utilisation de S/MIME dégrade considérablement les performances de BizTalk Server.

Envoi

Les questions relatives à la sécurité et à la performance abordées pour la fonction de réception de fichier concernent également l'envoi des documents avec un service de transport de fichier.

Optimisation recommandée pour la fonction de réception de fichier et le service de transport de fichier

Pour optimiser les performances de la fonction de réception de fichier et du service de transport de fichier et ainsi améliorer les performances du serveur BizTalk Server :

  • Utilisez un répertoire de fichiers local de préférence à un répertoire de fichiers distant pour réduire les temps de latence du réseau.

  • Utilisez des arrangements de disques pour obtenir des débits élevés. Pour plus d'informations sur les compromis entre la vitesse des arrangements de disques et la redondance, voir Évolution verticale des bases de données.


SMTP (évolution verticale)

Réception

La fonction de réception SMTP est similaire à la fonction de réception HTTP pour les transactions entrantes dans la mesure où il n'existe pas de fonction de réception SMTP native intégrée à BizTalk Server 2000. Une fonction de réception SMTP permet de recevoir des documents via un système basé sur les événements et de les envoyer à BizTalk Server 2000. Si une fonction de réception SMTP existe, BizTalk Server accepte les documents codés au format MIME/SMIME et les prépare en vue de leur traitement.

Envoi

Les questions relatives à la sécurité et aux performances abordées dans les sections traitant des services S/MIME entrants et des services HTTP/HTTPS sortants s'appliquent ici. Si un canal utilise le service SMTP comme service de transport dans un port d'échanges ou un port, le serveur de traitement traite le document et l'envoie à l'application destinataire.

Remarque

  • Les performances de BizTalk Server sont fortement dégradées lorsque des certificats numériques sont nécessaires pour codés les documents sortants au format S/MIME.

Optimisation recommandée pour le service SMTP

Pour optimiser les performances du service SMTP et ainsi améliorer les performances du serveur BizTalk Server :

  • Le niveau de performance atteint dépend grandement du service SMTP utilisé pour la réception des documents. Une organisation peut disposer d'un serveur SMTP qu'elle utilise pour remplir cette fonction. Cependant, si aucun serveur SMTP n'est disponible et que l'organisation choisit d'utiliser Microsoft Exchange Server ou d'utiliser le système d'échanges d'une tierce partie, il est probable qu'il faille installer beaucoup plus de matériel sur le serveur pour maintenir un niveau de performance approprié pour BizTalk Server. Le serveur SMTP doit être capable d'appeler un système basé sur les événements, lequel doit être capable à son tour d'envoyer des documents à BizTalk Server.

  • Si une organisation choisit d'exécuter BizTalk Server sur un serveur SMTP, ce choix va avoir un impact sur les performances de l'UC. Pour minimiser l'impact sur les performances, utilisez une UC plus rapide.

  • Si une organisation utilise S/MIME, les performances de BizTalk Server se trouvent fortement dégradées. Afin de réduire l'impact sur les performances générales de S/MIME sur BizTalk Server, utilisez des UC plus rapides.


Message Queuing (évolution verticale)

Réception

Le service Message Queuing utilise généralement un volume important d'E/S de disque pour recevoir et envoyer des messages. Le service Message Queuing est transactionnel, ce qui est fortement recommandé pour l'amélioration de la tolérance de panne. Cependant, il est transactionnel uniquement sur un serveur local. Si vous utilisez le service Message Queuing pour améliorer la tolérance de panne, vous devez installer des disques en quantité suffisante sur chaque serveur BizTalk Server afin de pouvoir traiter les E/S de disque en plus grand nombre.

Envoi

L'envoi de documents avec Message Queuing est un sujet qui appelle les mêmes questions de sécurité et de performance que la réception de documents avec Message Queuing.

Optimisation recommandée pour Message Queuing

Pour optimiser les performances du service Message Queuing et ainsi améliorer les performances du serveur BizTalk Server :

  • Utilisez des files d'attente transactionnelles (vous devez utiliser des files d'attente locales sur BizTalk Server plutôt que des files d'attente distantes pour permettre la réception sur des files d'attente transactionnelles) ainsi qu'un canal d'E/S de disque rapide. Les files d'attente n'ont pas besoin d'interroger Microsoft Active Directory ; toutefois, les files d'attente de message publiques doivent interroger Active Directory. Par conséquent, la lecture et l'enregistrement des données dans les files d'attente locales entraîne de meilleures performances. Il est possible d'utiliser des files d'attente locales non transactionnelles pour obtenir de meilleures performances. Cependant, les files d'attente locales non transactionnelles n'offrent pas la même fiabilité que les files d'attente transactionnelles. De la mémoire est également requise en quantité supplémentaire.

    Remarque

    • Pour plus d'informations sur la façon de définir les besoins en matériel pour le service Message Queuing, voir « Sélection du matériel du serveur Message Queuing » dans l'aide de Windows 2000 Server.
  • Le volume maximal accepté pour les messages Message Queuing est de 4 Mo. Si les documents dépassent les 4 Mo, il est impossible d'utiliser le service de transport Message Queuing. La limite pour la taille des documents de la base de données de persistance d'orchestration est de 2 Mo.

  • Le service Message Queuing réquisitionne la base de données de façon intensive si la journalisation est utilisée. Assurez-vous que les règles standard pour l'optimisation des bases de données sont appliquées lors de la configuration des services de transport Message Queuing.

  • Pour maximiser le débit, séparez les données et les journaux et utilisez plusieurs disques et plusieurs contrôleurs.


Évolution horizontale de BizTalk Server

Une mise en oeuvre réussie de BizTalk Server 2000 fait appel à la fois à une stratégie verticale et horizontale. Le recours à une évolution verticale permet de minimiser le nombre de serveurs requis. L'évolution horizontale apporte les avantages suivants :

  • Performances accrues. Les performances dépassent les performances coûteuses qui pourraient être obtenues sur un seul serveur.

  • Tolérance de panne sur le serveur.

  • Séparation et optimisation des différents composants. Les performances des services BizTalk, des bases de données et des services de transport peuvent être augmentées.

L'évolution horizontale du matériel permet de réduire les coûts. Cependant, comme la gestion des sites est de plus en plus complexe, vous devez commencer par une évolution verticale pour votre organisation.

Cette section traite des rubriques suivantes :

  • Évolution horizontale des services d'échanges BizTalk

  • Évolution horizontale des bases de données

  • Évolution horizontale des services de transport

Voir aussi

Évolution de BizTalk Server


Évolution horizontale des services d'échanges BizTalk

Il est possible de faire évoluer les services d'échanges BizTalk horizontalement en utilisant des groupes de serveurs. Les groupes de serveurs sont des collections des serveurs individuels faisant l'objet d'une gestion, d'une configuration et d'une surveillance centralisées. Pour plus d'informations sur l'ajout et la configuration des groupes de serveurs, voir Groupes et serveurs.

Les serveurs membres d'un même groupe de serveurs partagent :

  • une base de données de files d'attente partagées qui contrôle l'activité dans le moteur d'état BizTalk Server,

  • une base de données de suivi qui consigne dans des journaux l'activité des documents et crée des rapports,

  • une base de données Gestion d'échanges BizTalk qui stocke les données de configuration,

  • des fonctions de réception,

  • tous les composants nécessaires au serveur au moment de l'exécution, comme les composants de transport et les composants d'intégration des applications ainsi que la conversion des données, le cryptage des données et la signature.

Un groupe de serveurs BizTalk Server ne fournit pas un système d'équilibrage de la charge qui permet la réception des documents entrants ou qui facilite l'envoi des documents en utilisant un modèle d'objet DCOM (Distributed Component Object Model). Il ne permet pas le traitement des tâches de plusieurs serveurs. Une fois le document transmis à une base de données de files d'attente partagées, il peut être traité, sérialisé et envoyé par n'importe quel serveur dans le groupe. Cette fonctionnalité autorise un serveur dans un groupe à envoyer un document qu'un autre serveur traite.

Une organisation peut disposer de plusieurs groupes de serveurs pour les raisons suivantes :

  • Pour grouper les services de transport similaires (HTTP ou File)

  • Pour obtenir une sécurité accrue

  • Pour catégoriser les partenaires commerciaux

Vous pouvez également utiliser des groupes de serveurs pour éviter la duplication des configurations des organisations, des canaux et des ports d'échanges. Les groupes de serveurs partagent des bases de données. Les données de configuration pour les organisations, les groupes, les canaux et les ports d'échanges sont stockées dans la base de données Gestion d'échanges BizTalk. Par conséquent, plusieurs groupes de serveurs BizTalk Server peuvent partager la même base de données Gestion d'échanges BizTalk.

Remarque

  • Si plusieurs groupes de serveurs BizTalk Server partagent la même base de données Gestion d'échanges BizTalk, chaque groupe doit disposer de ses propres bases de données de files d'attente partagées, de suivi et de persistance d'orchestration, qui sont partagées par tous les membres du groupe.

Recommandations pour l'évolution horizontale de BizTalk Server

Pour optimiser les performances de BizTalk Server :

Séparer les services de transport et les fonctions de réception

En séparant les services de transport et les fonctions de réception pour les groupes de serveurs BizTalk Server, vous pouvez obtenir des performances plus élevées. Le niveau de performance atteint dépend du nombre de documents traités et de la complexité de la conversion des données; BizTalk Server fournit des pools de threads distincts pour la réception et le traitement des données. La séparation des services de transport et des fonctions de réception permet de réduire le changement de contextes en éliminant le besoin, pour le serveur, d'alterner entre les opérations d'envoi et de réception.

Tous les serveurs traitent des éléments de travail par défaut, ce qui implique la récupération des travaux dans la base de données de files d'attente partagées, leur traitement et leur envoi au moyen du service de transport que le canal doit utiliser (traiter les travaux sortants). Ce processus dégrade les performances générales de l'UC car un changement de contextes doit être effectué. Si vous utilisez plusieurs serveurs, vous pouvez éviter cette dégradation en configurant au moins un serveur pour qu'il fonctionne comme service de réception. Afin de configurer un serveur de façon à ce qu'il se comporte comme un service de réception, vous pouvez utiliser Administration de BizTalk Server pour désactiver la fonction Participer au traitement de l'élément de travail et créer une nouvelle fonction de réception pour le serveur. Pour plus d'informations sur la désactivation de la fonction Participer au traitement de l'élément de travail, voir Configuration d'un serveur dans un groupe. Pour plus d'informations sur la définition d'une fonction de réception de fichiers, voir Ajout d'une fonction de réception de fichier. Pour plus d'informations sur la définition d'une fonction de réception Message Queuing, voir Ajout d'une fonction de réception Message Queuing.

Remarque

  • Pour le service Message Queuing, seules des lectures transactionnelles peuvent être effectuées à partir de files d'attente locales et il n'est donc possible qu'à un seul serveur de lire à partir de cette file d'attente.

BizTalk Server reçoit des documents si l'une des conditions suivantes existe :

  • Une fonction de réception a été configurée sur le même serveur que le serveur BizTalk Server.

  • Un processus SMTP ou HTTP a été configuré pour appeler une méthode Submit sur le serveur sur lequel BizTalk Server a été installé.

Établir une priorité entre les parseurs

En établissant des priorités entre les parseurs, vous pouvez optimiser les performances de BizTalk Server. BizTalk Server fournit quatre parseurs de données :

  • XML

  • EDIFACT

  • X12

  • Flat-file

Lorsque BizTalk Server reçoit un document, il essaie de l'analyser dans l'ordre de la liste précédente. En déplaçant les parseurs les plus fréquemment utilisés en haut de la liste, vous pouvez améliorer les performances de BizTalk Server. Pour plus d'informations sur la configuration de l'ordre des parseurs, voir Configuration de l'ordre des parseurs d'un groupe de serveurs.

Comme la fonctionnalité de classement des parseurs est un paramétrage des groupes de serveurs, il est conseillé de créer un groupe distinct pour chaque type de données (XML, EDIFACT, X12, Flat-file) traité, puis de définir les jeux de priorités de parseur adéquats pour chaque groupe.

Cette section traite de la rubrique suivante :

  • Équilibrage de charge de composant


Équilibrage de charge de composant

L'équilibrage de charge de composant (CLB, Component Load Balancing) est une fonctionnalité de Microsoft Application Center 2000. Pour utiliser cette fonctionnalité, Application Center 2000 doit être installé sur le même serveur que Microsoft BizTalk Server 2000. La fonctionnalité CLB permet aux organisations d'équilibrer la charge du composant BizTalk.Interchange.1 dans le gestionnaire de services COM+. La fonctionnalité CLB est un système d'équilibrage de charge pour les composants COM. Dans un environnement BizTalk Server, la fonctionnalité CLB permet à un service de transport HTTP d'utiliser la méthode Submit pour appeler un cluster de serveurs BizTalk Server au lieu d'appeler un seul serveur (pour l'application émettrice, l'utilisation de la méthode Submit pour appeler le cluster apparaît toujours comme l'envoi à un noeud). Un cluster est un ensemble de serveurs qui agissent comme un seul serveur. Par exemple, si vous utilisez un cluster de serveurs HTTP, un envoi unique peut être dirigé vers n'importe lequel des trois serveurs. Sans la fonctionnalité CLB, les services de transport HTTP doivent être configurés de façon à faire les envois à l'un des trois serveurs. Dans ce dernier scénario, si le serveur vers lequel un service HTTP envoie des documents tombe en panne, le service de transport HTTP devra être reconfiguré pour la transmission des documents vers un autre serveur dans le groupe de serveurs BizTalk Server.

Important

  • Ne répliquez pas l'application XLANG Scheduler par défaut ou toute application COM+ qui héberge les planifications XLANG. Lorsque l'équilibrage de charge de composant est utilisé, ces applications COM+ doivent être installées sur chaque serveur. Vous pouvez répliquer les composants COM liés à des planifications XLANG.


Évolution horizontale des bases de données

Pour faire évoluer les bases de données horizontalement, installez chaque base de données sur son propre serveur. Dans les environnements avec de grands volumes de transactions, l'installation d'une base de données sur un serveur unique permet l'allocation des ressources d'UC, d'E/S de disque et de mémoire du serveur à la base de données appropriée.

Optimisation recommandée pour l'évolution horizontale des bases de données

Pour optimiser les performances des bases de données de BizTalk Server :

  • Installez chaque base de données sur un serveur distinct équipé d'une UC de 933 MHz ou plus. N'installez pas les bases de données sur le même serveur que BizTalk Server 2000.

  • Installez les applications COM+ qui hébergent les planifications XLANG sur leurs propres serveurs, équipés d'UC de 933 MHz ou plus.

  • Plusieurs cartes réseau de 100 Mbits/s (mégabits par seconde) ou plus, connectées à des ports de commutateurs pour augmenter le débit d'E/S du réseau.

  • Si une organisation traite un petit nombre de documents, utilisez une base de données qu'il est facile de mettre à niveau. Si les besoins en traitement augmentent, déplacez la base de données de files d'attente partagées, la base de données de suivi et la base de données de persistance d'orchestration sur leurs propres serveurs. Toutefois, sachez que le déplacement de la base de données Gestion d'échanges BizTalk est plus difficile. Il est fortement recommandé de veiller à ce que le serveur sur lequel est stockée la base de données Gestion d'échanges BizTalk dispose de suffisamment d'espace disque et de mémoire pour mettre la configuration dans le cache au fur et à mesure que les besoins en traitement des documents augmentent.

  • Pour la base de données de suivi, installez du matériel de réseau rapide pour compenser le volume important des données non compressées échangées entre BizTalk Server et la base de données.

    Remarque

    • Il existe des limites de taille pour le suivi des échanges et des documents, qui, si elles sont dépassées, nuisent grandement aux performances de BizTalk Server. Pour plus d'informations sur cette limite de taille, voir Limite de la taille des documents et des échanges.

Voir aussi

Évolution de BizTalk Server


Évolution horizontale des services de transport

BizTalk Server prend en charge quatre services de transport. Il est possible de faire évoluer horizontalement chacun de ces services de transport :

  • HTTP

  • Fichier

  • SMTP

  • Message Queuing

Cette section traite des rubriques suivantes :

  • HTTP/HTTPS (évolution horizontale)

  • File (évolution horizontale)

  • SMTP (évolution horizontale)

  • Message Queuing (évolution horizontale)


HTTP/HTTPS (évolution horizontale)

Réception

Il est possible de faire évoluer horizontalement la fonction de réception HTTP/HTTPS en utilisant un cluster Web. Par exemple, un partenaire commercial a la possibilité d'envoyer un document à une seule adresse mais l'envoi peut être routé vers n'importe quel serveur du cluster. Les clusters Web représentent l'une des caractéristiques du service d'équilibrage de charge de réseau (NLB, Network Load-Balancing) inclus dans Microsoft Windows 2000 Advanced Server. Pour plus d'informations sur la configuration de la fonctionnalité NLB, voir l'aide de Windows 2000 Advanced Server. Afin d'améliorer les performances de BizTalk Server, vous pouvez configurer un cluster Web pour placer les documents reçus dans un répertoire de fichiers ou dans une file d'attente, ou pour envoyer des documents directement à BizTalk Server grâce à l'une des deux méthodes suivantes :

  • Configuration statique de chaque serveur pour envoyer des documents à BizTalk Server.

  • Configuration de chaque serveur pour l'envoi des documents à un cluster Web de serveurs BizTalk Server (des serveurs membres d'un même groupe) en utilisant la fonctionnalité CLB d'équilibrage de charge de composant de Microsoft Application Center 2000.

    Important

    • Ne répliquez pas l'application XLANG Scheduler par défaut ou toute application COM+ qui héberge les planifications XLANG. Lorsque l'équilibrage de charge de composant est utilisé, ces applications COM+ doivent être installées sur chaque serveur. Vous pouvez répliquer les composants COM liés à des planifications XLANG.

Envoi

L'évolution horizontale du service de transport HTTP/HTTPS pour les envois est une fonctionnalité propre à l'utilisation de plusieurs serveurs dans un groupe configuré pour participer au traitement de l'élément de travail. Il est impossible de séparer la fonctionnalité d'envoi HTTP/HTTPS du serveur BizTalk Server qui traite les documents car la fonctionnalité d'envoi est utilisée sur tous les serveurs du groupe configuré pour participer au traitement des éléments de travail.

Optimisation recommandée pour le service HTTP/HTTPS

Pour optimiser le service de transport HTTP/HTTPS et ainsi améliorer les performances du serveur BizTalk Server :

  • Dédiez le service de transport de réception HTTP/HTTPS à un serveur distinct du serveur des services BizTalk (pour les environnements avec des volumes de transactions importants). De plus, faites en sorte que le serveur HTTP/HTTPS envoie les documents à une fonction de réception de fichiers ou à une fonction de réception Message Queuing, ou qu'il appelle la méthode Submit sur l'objet BizTalk Server Interchange en utilisant DCOM. Le fait de dédier le service de transport HTTP/HTTPS ou de configurer le serveur HTTP/HTTPS pour qu'il envoie des documents à une fonction de réception, crée de la latence sur le réseau. Toutefois, la configuration distincte du serveur de transport HTTP/HTTPS et du serveur BizTalk Server vous permet de concilier leurs architectures uniques et d'optimiser chacun d'eux. De plus, en séparant ces serveurs, vous pouvez maintenir des performances optimales sur le serveur BizTalk Server car celui-ci n'est pas concerné par les coûts induits par l'utilisation de SSL pour le cryptage/décryptage.

  • Créez un cluster de serveurs de transport HTTP/HTTPS dont la charge est équilibrée. Ceci améliorera davantage les performances du service de transport de réception HTTP/HTTPS car cela permet la redondance de l'évolution horizontale. Pour plus d'informations sur l'utilisation du service NLB pour créer un cluster Web, voir l'aide de Windows 2000 Advanced Server.

  • Prévoyez le nombre de documents que les serveurs doivent traiter dans un groupe configuré pour participer au traitement d'un élément de travail. Déterminez ensuite combien de canaux utilisent des ports d'échanges nécessitant un service de transport d'envoi HTTP/HTTPS. Associez les canaux qui utilisent le service de transport d'envoi HTTP/HTTPS dans un groupe unique. Ceci permettra à l'ensemble des serveurs du groupe configuré pour participer au traitement de l'élément de travail de sérialiser les documents qui utilisent un service de transport.

  • Appliquez les méthodes conseillées lorsque vous utilisez des pages ASP avec le service de réception ou d'envoi HTTP/HTTPS. Pour plus d'informations sur l'optimisation des pages ASP et des services IIS (Internet Information Services), consultez le site Web dédié à l'aide de Microsoft Internet Information Services (localhost/iisHelp). Puis, cliquez sur Guide Active Server Pages.

  • Préférez l'utilisation du service de transport File ou Message Queuing sur un système local avec une fonction de réception à l'appel de la méthode Submit pour rechercher des documents sur le serveur BizTalk Server.


File (évolution horizontale)

Réception

La fonction de réception de fichiers peut être séparée des serveurs ou peut résider sur le serveur. Bien que la séparation de la fonction de réception de fichiers et son installation sur un serveur distinct permette de minimiser l'impact sur les performances d'E/S du disque, la latence du réseau aura une influence sur les performances lors de la tentative d'extraction du fichier.

Envoi

L'évolution horizontale s'effectue au moyen de plusieurs serveurs dans le groupe qui traitent des documents puis les envoient au service de transport de fichiers. Les performances dépendent de l'utilisation ou non de BizTalk Server comme fonction de réception ou de la configuration ou non de BizTalk Server comme serveur distinct pour la fonction de réception.

Optimisation recommandée pour la fonction de réception de fichiers ou le service de transport de fichiers

Pour optimiser les performances de la fonction de réception de fichiers et du service de transport de fichiers et ainsi améliorer les performances de BizTalk Server :

  • Stockez la fonction de réception de fichiers sur un serveur distinct du serveur BizTalk Server. Cette solution ne résout cependant pas les problèmes de performances liés à la latence du réseau, qui se présentent lorsque vous tentez d'extraire un fichier. Le stockage de la fonction de réception de fichiers sur un serveur distinct du serveur BizTalk Server permet également de réduire l'impact des E/S de disque sur les performances de BizTalk Server. En outre, cette séparation des serveurs empêche les applications non reconnues de placer des fichiers sur le serveur BizTalk ou de lancer des requêtes, ce qui risque de réquisitionner toutes les ressources du serveur et induire de faibles performances.

  • Configurez l'exécution d'une fonction de réception sur chaque serveur dans le groupe qui recherche la même fonction de réception de fichiers pour ainsi garantir que tous les serveurs du groupe extraient des documents pour leur traitement. Les services de réception de fichiers sont configurés par défaut pour s'exécuter sur un serveur au sein d'un groupe. Par conséquent, si vous disposez de cinq serveurs dans un groupe et que vous configurez l'exécution de la fonction de réception de fichiers sur un seul serveur dans le groupe, lorsque la fonction de réception de fichiers est appelée à l'adresse \\serveur_réception\emplacement_réception, seul un serveur sur cinq extrait les fichiers pour leur traitement. Ceci limite à un le nombre de serveurs capables de traiter des documents pour le groupe entier. Les quatre serveurs restants ne peuvent pas extraire des fichiers à analyser provenant de l'opération de réception.

  • Configurez l'exécution d'une fonction de réception de fichiers sur un serveur distinct du serveur BizTalk Server. Ceci empêche les applications non reconnues d'extraire des fichiers du serveur BizTalk Server. L'envoi et la réception de fichiers étant des processus différents, tous les serveurs du groupe configurés pour participer au traitement de l'élément de travail envoient des fichiers. L'évolutivité horizontale est basée uniquement sur le nombre de serveurs dans le groupe, configuré pour participer au traitement de l'élément de travail.


SMTP (évolution horizontale)

Réception

Le service de transport SMTP est capable de recevoir des documents de BizTalk Server mais ne peut pas lui en envoyer. Pour envoyer un document à BizTalk Server, le service SMTP doit pouvoir invoquer un système basé sur les événements pour rechercher un message reçu et l'envoyer à un partage de fichier ou à une file d'attente d'échanges, ou envoyer le document en utilisant l'objet BizTalk Server Interchange. Les serveurs SMTP, capables de fournir des systèmes basés sur des événements (Microsoft Exchange Server ou des serveurs d'échanges de tierces parties), utilisent généralement un volume important de ressources matérielles. Par conséquent, l'ajout de cette fonctionnalité sur un serveur diminue sa capacité à traiter des documents.

Envoi

Les services de transport Lightweight SMTP qui ne possèdent pas de systèmes basés sur les événements peuvent être utilisés pour envoyer des documents en utilisant le service SMTP. Le serveur de transport SMTP qui envoie les documents fonctionne simplement comme un agent de relais. Le serveur de transport SMTP sortant est configuré au niveau du groupe et non au niveau du serveur. Par conséquent, si le transport SMTP existe sur l'un des serveurs dans un groupe, le serveur contenant le service de transport SMTP l'utilise pour envoyer des documents sortants. Tous les autres serveurs du groupe utilisent le même serveur pour le service de transport SMTP sortant.

Optimisation recommandée pour le service SMTP

Pour optimiser les performances du service SMTP et ainsi améliorer les performances de BizTalk Server :

  • Configurez le service de transport SMTP pour qu'il s'exécute sur un serveur distinct du serveur sur lequel sont installés les services BizTalk (pour les fonctions d'envoi et de réception). Dans la plupart des cas, une organisation dispose d'un serveur SMTP sur son réseau, lequel peut être utilisé pour les fonctions d'envoi et de réception.


Message Queuing (évolution horizontale)

Réception

Vous devez choisir d'installer la fonction de réception Message Queing sur le même serveur que BizTalk Server ou de l'installer sur un serveur différent. Si vous utilisez une file d'attente transactionnelle, la fonction de réception Message Queing doit se trouver sur le même serveur. Cependant, si vous n'utilisez pas une file d'attente transactionnelle, la fonction de réception Message Queing peut se trouver sur un serveur distinct. Vous devez également décider si vous acceptez de subir les impacts sur les performances en ayant les E/S de disques sur le serveur BizTalk Server local ou de subir la latence engendrée sur le réseau pour les communications de plusieurs serveurs. Dans ce dernier exemple, le besoin en E/S de disque existe toujours mais il existe uniquement sur le serveur distant au lieu du serveur local. Pour plus d'informations sur la façon de définir les besoins en matériel pour le service Message Queuing, voir « Sélection du matériel du serveur Message Queuing » dans l'aide de Windows 2000 Server.

Envoi

L'envoi de documents avec Message Queuing est un sujet qui appelle les mêmes questions de sécurité et de performance que la réception de documents avec Message Queuing.

Optimisation recommandée pour Message Queuing

Pour optimiser les performances du service Message Queuing et ainsi améliorer les performances de BizTalk Server :

  • Le service Message Queuing réquisitionne la base de données de façon intensive si la journalisation est utilisée. Assurez-vous que les règles standard pour l'optimisation des bases de données sont appliquées lors de la configuration des services de transport Message Queuing. Par exemple, pour maximiser le débit, séparez les données et les journaux et utilisez plusieurs disques et plusieurs contrôleurs.


Optimisation des performances

Pour répondre aux besoins en transactions et améliorer les performances, vous devez optimiser BizTalk Server 2000. Outre BizTalk Server, vous pouvez également optimiser Microsoft Windows 2000 et les interactions des bases de données. Après avoir configuré votre système, testez-le, puis évaluez-en les résultats pour déterminer si votre configuration d'origine répond aux besoins en transactions. Vous devrez certainement reconfigurer votre architecture afin d'obtenir des performances optimales. Après chaque reconfiguration, procédez à un nouveau test et évaluez les résultats. Une fois les résultats escomptés obtenus, lancez un plan de maintenance car les performances du serveur évoluent dans le temps. De plus, la quantité et le type de transaction traités dans votre organisation peuvent changer.

Cette section traite des rubriques suivantes :

  • Recommandations pour l'optimisation générale des performances

  • Conception, affinage et test de l'architecture

  • Maintenance des performances


Recommandations pour l'optimisation générale des performances

Cette section fournit des recommandations générales pour l'optimisation des paramètres système et comprend des rubriques consacrées à l'optimisation des paramètres BizTalk Server 2000 pour obtenir des performances accrues. Exemple :

  • Optimisation des paramètres Microsoft Windows 2000. Appliquez les méthodes conseillées qui consistent par exemple à ne pas faire fonctionner des services ou des protocoles inutiles pour ainsi améliorer les performances de Microsoft Windows 2000. Pour optimiser BizTalk Server, il est également possible d'utiliser de nombreuses techniques employées pour optimiser Windows 2000. Pour plus d'informations sur l'optimisation des paramètres de Microsoft Windows 2000, voir la rubrique « Méthodes conseillées » dans l'aide de Windows 2000.

  • Maintenez une connectivité réseau rapide et fiable entre les services de transport, les services BizTalk (services d'Orchestration et services d'échanges BizTalk) et les bases de données (Ethernet 100 mégabits par seconde ou supérieur). Pour optimiser le débit du réseau, utilisez plusieurs cartes réseau dans chaque serveur avec un port de commutateur pour chacune d'elle et des transactions entrantes et sortantes réparties entre les cartes NIC (Network Interface Cards). Lorsque le service CLB d'équilibrage de charge de composant (IInterchange ou IpipelineComponent) est utilisé conjointement au service NLB de Microsoft Windows 2000 ou de Microsoft Application Center 2000, les performances augmentent de façon significative.

    Important

    • Ne répliquez pas l'application XLANG Scheduler par défaut ou toute application COM+ qui héberge les planifications XLANG. Lorsque l'équilibrage de charge de composant est utilisé, ces applications COM+ doivent être installées sur chaque serveur. Vous pouvez répliquer les composants COM liés à des planifications XLANG.

Cette section traite des rubriques suivantes :

  • Optimisation des services d'orchestration BizTalk

  • Optimisation des services d'échanges BizTalk

Voir aussi

Évolution de BizTalk Server


Optimisation des services d'orchestration BizTalk

Si vous faites appel aux services d'orchestration BizTalk, vous pouvez optimiser les planifications XLANG et leur contenu. Moyennant une bonne compréhension de la façon dont les planifications utilisent la mémoire et dont la structure d'un processus professionnel affecte les performances, vous pouvez concevoir des planifications qui améliorent les performances des services d'orchestration BizTalk. Les technologies d'implémentation prises en charge par les services d'orchestration BizTalk incluent les services d'échanges BizTalk, les composants COM, les services Message Queuing et les composants Windows Script. En optimisant ces composants et ces services, vous pouvez aller encore plus loin dans l'amélioration des performances des services d'orchestration BizTalk.

Cette section traite des rubriques suivantes :

  • Optimisation des planifications XLANG

  • Optimisation des contenus des planifications XLANG


Optimisation des planifications XLANG

Une planification XLANG peut contenir un nombre important de processus professionnels internes. Les processus professionnels peuvent inclure des transactions de courte durée ou des transactions de longue durée. BizTalk Server ne contrôle pas le contenu de ces processus mais il gère le flux des données à travers ces processus dans une planification XLANG. Lorsque vous créez une planification XLANG et quelle consiste en plusieurs transactions de courte durée ou de longue durée, tenez compte des points suivants :

  • Une instance de planification XLANG s'exécute en mémoire à chaque fois qu'elle est appelée.

  • Plusieurs planification XLANG peuvent fonctionner sur un même serveur.

  • Plusieurs planifications XLANG différentes peuvent fonctionner simultanément, avec plusieurs instances de planifications XLANG.

La base de données de persistance d'orchestration fournit un système appelé système de mise en attente, pour contrôler la mémoire utilisée par les planifications XLANG en fonctionnement. La mise en attente se produit lorsqu'une instance de planification XLANG attend un message et qu'aucune autre activité n'a lieu dans la planification XLANG. À ce stade, le moteur de XLANG Scheduler met en attente l'instance de planification XLANG afin de maximiser les performances. La mise en attente d'une instance de planification XLANG consiste à rendre permanent tous les états spécifiques d'une instance dans une base de données et à supprimer cette instance de la mémoire. Seule une petite portion de l'instance de planification XLANG reste en mémoire dans le moteur XLANG Scheduler. Lorsqu'un message parvient à un port pour l'instance de planification XLANG, l'instance est réalimentée. La réalimentation d'une instance de planification XLANG consiste à restaurer l'instance dans la mémoire, à partir de la base de données.

Une instance de planification XLANG reste en attente jusqu'à ce qu'elle soit réactivée ou qu'un administrateur l'interrompe explicitement. Ce système permet à un processus professionnel de fonctionner de manière fiable pendant une longue période. Pour plus d'informations sur la configuration des paramètres de mise en attente et de réalimentation, voir Mise en attente et réalimentation. Les processus de mise en attente et de réalimentation permettent d'économiser de la mémoire mais ils affectent les performances. Comme ces deux processus nécessitent la lecture et l'enregistrement des données dans la base de données de persistance d'orchestration, le réseau génère une latence.

Important

  • Pour augmenter considérablement les performances des services d'Orchestration BizTalk, dans l'Explorateur Windows, accédez à Program Files\Common Files\System\ado, puis double-cliquez sur adofre15.reg. Dans la boîte de dialogue de confirmation, cliquez sur Oui, puis sur OK. Cette procédure fait passer le modèle de thread ADO de « Threads cloisonnées » à « Les deux » et peut affecter d'autres applications utilisant ADO.


Optimisation des contenus des planifications XLANG

Une planification XLANG décrit un processus professionnel et la liaison de ce processus aux techniques d'implémentation. La performance d'une planification XLANG reflète souvent le niveau de performance des actions qu'elle contient. Il existe un certain nombre de points pertinents qu'il est utile de prendre en considération pour l'optimisation des contenus d'une planification XLANG. Certains sont spécifiques aux planifications XLANG et d'autres concernent la création d'applications distribuées.

  • Rétablissez la valeur de mise en attente pour conserver de la mémoire pour les planifications XLANG. La valeur par défaut du délai d'attente est 0 seconde. Vous pouvez modifier cette valeur. Une valeur inférieure ou égale à 180 secondes fait que la planification XLANG n'est jamais mise en attente. Toute valeur supérieure à 180 secondes entraîne la réalimentation immédiate de la planification XLANG. Pour plus d'informations sur les temps d'attente et la mise en attente des planifications XLANG, voir Mise en attente et réalimentation et Communication synchrone et asynchrone.

  • Utilisez des composants permanents. Les composants permanents comme IPersistStream ou IpersistStreamInit permettent au moteur de XLANG Scheduler de mettre en attente les planifications XLANG de manière flexible.

  • Exécutez les objets COM sur le même serveur que la base de données de persistance d'orchestration. Ceci permet de garantir que la planification XLANG ne génère pas de latence au niveau du réseau.

  • Exécutez des applications COM+ intra-processus pour obtenir des performances optimales. Bien que l'exécution d'une application COM+ dans un processus puisse affecter la stabilité de cette application COM+ (par exemple, si un composant dans l'application présente une défaillance, toute l'application peut être défaillante), il est considérablement plus rapide de l'exécuter ainsi que de l'exécuter en dehors d'un processus. Pour éviter ce problème d'instabilité potentielle, assurez-vous de tester très avant les composants dans l'application pour garantir la stabilité avant de déployer l'application dans un environnement de production.

  • Organisez les travaux dans une transaction unique. Le fait de rendre permanent l'état d'une instance de planification XLANG en début ou en fin de transaction affecte grandement les ressources de l'ordinateur. Cependant, l'organisation des éléments de travail dans une transaction unique réduit considérablement l'impact sur les performances. De plus, une planification XLANG ne peut pas être mise en attente au milieu d'une transaction du Coordinateur de transactions distribuées de Microsoft (MSDTC, Microsoft Distributed Transaction Coordinator). Les transactions MSDTC sont rapides mais elles dégradent les performances. Groupez plusieurs actions dans une transaction MSDTC unique, à condition que les actions puissent être achevées rapidement.

  • Les transactions de longue durée doivent être effectuées de façon asynchrone et les planifications XLANG doivent être conçues de façon à terminer rapidement les appels COM. Le résultat des travaux asynchrones peut être communiqué à l'instance de planification XLANG via des messages en files d'attente ou via des appels COM. Avec les appels COM, le nom d'un port de « réponse » peut être transmis sous la forme d'un moniker qui reste valide même après le redémarrage de l'ordinateur.

Voir aussi

Syntaxe du moniker


Optimisation des services d'échanges BizTalk

Pour optimiser les services d'échanges BizTalk :

  • Envoyez des documents à un groupe de serveurs. Les groupes de serveurs BizTalk sont utilisés pour la distribution des travaux à travers plusieurs serveurs. Pour envoyer des données à BizTalk Server, utilisez les méthodes suivantes :
    • Configuration d'une fonction de réception (comme Message Queuing ou File).

    • Appel de la méthode Submit sur l'objet BizTalk Server Interchange.

    L'utilisation des fonctions de réception apporte de meilleures performances que l'utilisation de la méthode Submit pour appeler l'objet Interchange car les fonctions de réception s'exécutent dans les services BizTalk et peuvent mettre en cache l'état interne des objets, tandis que la méthode Submit s'exécute en extra-processus et doit reconstruire son état interne pour chaque appel.

    Appeler l'objet Interchange pour les envois plutôt qu'utiliser une fonction de réception nécessite plus de ressources car l'objet Interchange doit être créé en dehors du processus BizTalk Server. Cependant, lorsque vous utilisez cet objet, vous disposez de deux méthodes pour envoyer des données aux serveurs d'un groupe :

    • Configuration statique des segments de tous les envois vers des serveurs spécifiques dans le groupe. Toutefois, cette opération ne permet pas de bénéficier d'un niveau élevé de tolérance de panne si le serveur, qui dispose d'un service de transport, est mappé de façon statique à un serveur BizTalk Server qui tombe en panne.

    • Utilisation de la fonctionnalité CLB de Microsoft Application Center 2000 pour améliorer les performances. Les groupes de serveurs BizTalk Server ne fournissent pas la fonctionnalité d'équilibrage de charge pour l'envoi des documents. En plus de l'équilibrage de charge, la fonctionnalité CLB fournit la tolérance de panne. Pour plus d'informations sur la fonctionnalité CLB, voir Équilibrage de charge de composant.

    Important

    • Ne répliquez pas l'application XLANG Scheduler par défaut ou toute application COM+ qui héberge les planifications XLANG. Lorsque l'équilibrage de charge de composant est utilisé, ces applications COM+ doivent être installées sur chaque serveur. Vous pouvez répliquer les composants COM liés à des planifications XLANG.

Cette section traite des rubriques suivantes :

  • Création et optimisation des spécifications

  • Création et optimisation des mapping

  • Optimisation des propriétés du groupe de serveurs BizTalk Server

  • Optimisation des propriétés du serveur

  • Optimisation des paramètres du Registre

  • Optimisation du cryptage

  • Optimisation des communications

  • Configuration de pare-feu


Création et optimisation des spécifications

Lorsque les paramètres par défaut de suivi global sont utilisés, BizTalk Server 2000 peut prendre en charge un document au format XML Unicode de 20 Mo. Pour les autres types de fichiers, comme les fichiers au format ANSI Flat-file, BizTalk Server ne prend pas en charge une taille de 20 Mo car un fichier qui n'est pas au format XML doit être converti en XML. Le processus de conversion consiste à ajouter des balises XML dans les données, ce qui augmente la taille du document que BizTalk Server doit traiter. Afin de maintenir des performances optimales pour BizTalk Server, la taille des autres types de fichiers doit être inférieure à 20 Mo. La quantité de mémoire requise pour le traitement d'un document qui a été converti au format XML dépend de la structure d'origine du document. Lorsque les paramètres de suivi global sont activés, les documents au format XML Unicode dont la taille est supérieure à 20 Mo peuvent être traités sans que les performances du serveur BizTalk Server en soit grandement affectées.

Remarque

  • Le dépassement des limites de taille pour le suivi des échanges modifie les performances du serveur BizTalk Server. Pour plus d'informations sur cette limite de taille, voir Limite de la taille des documents et des échanges. Les performances se trouvent également affectées par le processus de journalisation des documents. Pour plus d'informations sur la journalisation des documents, voir Définition des propriétés de journalisation de document.

Lorsque vous concevez des spécifications, vous pouvez configurer des règles de validation dans une spécification. Il vous est par exemple possible de spécifier qu'un champ contienne un type particulier de données (comme une chaîne) ou de spécifier des règles plus complexes, comme la comparaison de la valeur d'un champ à 80 valeurs pour sa validation. Dans cet exemple, les données doivent être comparées à 80 valeurs et si elles ne correspondent à aucune d'entre elles, la validation de la spécification échoue. La validation de la spécification est activée par défaut dans BizTalk Server ; cela affecte les performances mais garantit la validité des données envoyées ou reçues. Vous pouvez désactiver la validation, ce qui augmente les performances et ne nuit pas forcément de façon irrémédiable à la validité des données car BizTalk Server dispose de plusieurs autres systèmes pour la validation des données. Par exemple, si un mappage nécessite certains types de données et certaines valeurs et que la validation de la spécification est désactivée, les données passent avec succès la phase d'analyse mais non la phase de sérialisation lorsque le mapping est appliqué. Si d'autres systèmes (tels que le mapping reposant sur des données valides) sont disponibles, la validation de la spécification peut être désactivée pour éviter la dégradation potentielle des performances causée par le processus de validation. Vous pouvez aussi choisir de procéder ainsi car vous avez convenu d'appliquer des standards de données avec vos partenaires commerciaux et avez validé ces transactions. Vous pouvez également faire ce choix parce que vous contrôlez entièrement la façon dont les données sont envoyées (par des transactions d'application à application par exemple).

Il est possible d'utiliser le paramètre de Registre suivant pour désactiver la validation :

  • NoValidation. Lorsque la validation de la spécification n'est pas requise (c'est-à-dire lorsque les documents ne sont pas validés par rapport à une spécification pour des paramètres comme les valeurs minimales/maximales, les types de données et/ou les valeurs requises) affectez une valeur différente de zéro à ce paramètre et les données ne seront pas validées. Ceci peut aider à augmenter les performances mais des données non valides risquent d'être envoyées. L'affectation d'une valeur différente de zéro au paramètre de validation de la spécification peut représenter le bon choix pour les serveurs qui reçoivent des documents dont l'organisation contrôle la structure.

La définition des paramètres du Registre s'effectue au niveau de chaque serveur. Lorsque la validation de la spécification est activée, chaque document traité par le serveur est validé par rapport à sa spécification. Le traitement des documents est donc plus lent que dans le cas où aucune validation de spécification n'est utilisée.

Solutions recommandées pour l'optimisation de la taille des documents et des spécifications

Pour optimiser les performances de BizTalk Server :

  • N'incluez pas plus de champs et/ou d'attributs dans les spécifications que nécessaire. Plus le nombre de champs et d'attributs est important et plus les besoins en mémoire augmentent pour BizTalk Server. Une spécification plus importante nécessite une mémoire proportionnellement plus importante. Par exemple, les spécifications EDI incluses dans BizTalk Server sont conformes aux standards EDI. D'une façon générale, la plupart des organisations qui utilisent des spécifications EDI requièrent approximativement dix pour cent de toute la spécification. Par conséquent, lorsqu'une organisation et son partenaire commercial utilisent uniquement dix pour cent de toute une spécification, les enregistrements et les champs inutiles peuvent être supprimés et la spécification modifiée, utilisée pour les transactions.

  • Si la validation de la spécification est activée, n'indiquez pas de règles de validation dans les spécifications pour les champs qui contiennent des données valides. Par exemple, si un champ contient un nombre qui doit être traité uniquement en tant que chaîne (comme un numéro de téléphone), ne spécifiez pas qu'il doit être numérique. Dans ce type de cas, il n'est pas nécessaire de spécifier un type de données car le type de données par défaut est une chaîne. Par conséquent, le champ pour le type de données peut ne pas être complété. La validation de la spécification des valeurs autorisées pour un champ est plus longue que la simple validation d'un type de données.


Création et optimisation des mapping

La conversion des données comme opération faisant partie d'une transaction risque de réduire les performances de BizTalk Server 2000. Le mapping des spécifications peut nécessiter une utilisation intense de l'UC, ce qui risque également de limiter les capacités de BizTalk Server à traiter la transaction dans sa totalité. Le degré d'atteinte des performances de BizTalk Server dépend en grande partie de la complexité du mapping utilisé pour la conversion. Par exemple, le mapping d'un champ appelé IDproduit dans la spécification source à un champ appelé IDarticle dans la spécification de destination ne recourt pas à l'UC de façon aussi intensive qu'une opération mathématique complexe réalisée sur des données en cours de conversion.

Solutions recommandées pour la conception de mapping

  • Utilisez des fonctoids uniquement lorsque cela est nécessaire. Les fonctoids utilisent des scripts, ce qui demande à BizTalk Server de charger un moteur de script. Ceci risque de nuire aux performances contrairement aux transformations du XML natif.

  • Utilisez le fonctoid Recherche dans la base de données uniquement lorsque cela est nécessaire. En effet, BizTalk Server doit établir la connexion à une base de données, rechercher des données, compléter un jeu d'enregistrements et mettre fin à la connexion à chaque fois que ce fonctoid est utilisé. Ceci risque de dégrader les performances de BizTalk Server.

  • Évitez d'appeler des objets COM dans des scripts de fonctoids et d'utiliser des fonctoids personnalisés. Ces deux techniques font que BizTalk Server instancie une instance d'un objet COM. Ceci affecte les performances de toute l'opération. De plus, les performances de l'opération d'instanciation des objets COM sont diminuées par les réponses aux questions suivantes :
    • L'opération est-elle effectuée au sein d'un processus ou en dehors d'un processus ?

    • L'objet est-il local ou distant ?

    • L'objet est-il correctement écrit ?

    • L'opération est-elle transactionnelle ?
  • Analysez chaque mapping pour déterminer la façon d'obtenir des performances optimales. Par exemple, il est possible d'utiliser deux techniques différentes pour concaténer deux champs sources et placer la valeur obtenue dans deux champs de destination différents. La première technique de concaténation consiste à utiliser un seul fonctoid de concaténation et à mapper le résultat à deux emplacements. La seconde technique de concaténation consiste à utiliser deux fonctoids, chacun avec un lien unique du résultat à un champ source de destination. La première technique est légèrement plus efficace en raison du fait que le script, qui s'exécute en tant qu'élément du fonctoid, est appelé une fois seulement. En réalisant un test, vous pouvez déterminer les techniques qui offrent les meilleures performances.


Optimisation des propriétés du groupe de serveurs BizTalk Server

Dans Administration de BizTalk Server, vous pouvez spécifier les propriétés suivantes à partir de la boîte de dialogue Propriétés du groupe de serveurs BizTalk Server :

  • Intervalle d'actualisation de cache d'objet de gestion d'échanges (en secondes). Ce champ peut être défini à 300 secondes au maximum. BizTalk Server 2000 enregistre en mémoire cache les configurations (comme les canaux, les ports d'échanges, les enveloppes et les définitions de document) pour ne pas devoir appeler la base de données à chaque fois. Si ces objets ne sont pas souvent modifiés, définissez cette valeur à 300 afin de réduire le nombre de fois auquel les données sont enregistrées puis lues dans la base de données. Comme BizTalk Server actualise les objets de gestion toutes les cinq minutes, le service doit être relancé pour que les modifications soient appliquées immédiatement.

  • Désactiver le suivi de document. Utilisez l'onglet Suivi pour activer ou désactiver le suivi des documents. Si vous choisissez de ne pas utiliser le suivi, désactivez ce champ pour réduire le nombre de lectures/écritures effectuées dans la base de données pour une seule transaction. Lorsque ce champ est activé, BizTalk Server se connecte à la base de données et consigne les données dans un journal. Ne désactivez pas ce champ, excepté si vous n'avez pas besoin de la fonction de suivi. Il est toutefois vivement recommandé de ne pas désactiver la fonction de suivi des documents. Pour plus d'informations, voir Configuration des propriétés de suivi d'un groupe de serveurs.

    Remarque

    • Il existe une limite de taille pour le suivi des échanges. Lorsque les limites de taille sont dépassées, les performances de BizTalk Server sont diminuées. Pour plus d'informations sur cette limite de taille, voir Limite de la taille des documents et des échanges. Les performances se trouvent également affectées par le processus de journalisation des documents. Pour plus d'informations sur la journalisation des documents, voir Définition des propriétés de journalisation de document.
  • Organiser la séquence d'appels du serveur. Il est possible d'établir des priorités entre les parseurs de BizTalk Server lorsqu'un groupe reçoit principalement un certain type de document. BizTalk Server dispose de quatre parseurs qu'il utilise pour analyser les données : XML, EDIFACT, X12 et Flat-File. Lorsque BizTalk Server reçoit un document, il essaie de l'analyser en utilisant ces trois parseurs dans l'ordre dans lequel ils se présentent. Si une organisation reçoit essentiellement un type de document en particulier, le classement des parseurs doit être modifié de façon à ce que le premier parseur corresponde au type des documents reçus.

Voir aussi

Évolution horizontale des services d'échanges BizTalk


Optimisation des propriétés du serveur

Dans Administration de BizTalk Server, vous pouvez définir les propriétés suivantes à partir de la boîte de dialogue Propriétés <Serveur> :

  • Créez plusieurs instances de fonctions de réception. Ceci permettra à BizTalk Server d'interroger plusieurs fonctions de réception pour les documents traités. Pour équilibrer la charge des documents sur plusieurs ordinateurs, placez les fonctions de réception sur des ordinateurs distincts. Chaque emplacement d'interrogation doit être unique et doit disposer d'une fonction de réception distincte. Pour éviter la surcharge des fonctions de réception, l'application métier qui envoie des documents doit distribuer de façon égale les documents entre tous les emplacements d'interrogation.

  • Nombre maximal de threads de fonction de réception autorisé. Vous pouvez choisir le nombre de threads de travail de fonction de réception par processeur que vous voulez pour une fonction de réception. Une quantité trop faible risque de ralentir BizTalk Server car celui-ci utilise des ports de terminaison d'E/S. Une quantité trop élevée n'entraîne pas d'effets graves mais les performances risquent d'être dégradées. Vous pouvez ajuster ce nombre et rechercher la valeur optimale qui convient à leur définition. La valeur recommandée pour le Nombre maximal de threads de fonction de réception autorisé est 4.

  • Nombre maximal de threads de fonction de réception autorisé. Vous pouvez spécifier le nombre de threads de travail par processeur pour le côté traitement. En ajustant de façon adéquate le nombre de ces threads de travail, vous pouvez améliorer les performances. Dans Administration de BizTalk Server, cliquez avec le bouton droit sur un serveur dans l'arborescence de la console et cliquez sur Propriétés. Modifiez la valeur par défaut dans la zone Nombre maximal de threads de travail autorisé par processeur. La valeur par défaut est 4. La valeur conseillée est comprise entre 10 et 16, selon le déploiement.


Optimisation des paramètres du Registre

Vous pouvez optimiser les paramètres du Registre pour améliorer les performances de BizTalk Server. Toutes les clés doivent être ajoutées en tant que valeurs DWORD dans HKLM\System\Current Control Set\Services\BTSSVC. Pour améliorer les performances, vous pouvez effectuer les ajustements de paramètres de Registre suivants :

  • NoValidation. Utilisez cette clé de Registre pour désactiver la validation de la spécification. Lorsque la validation de la spécification n'est pas requise (c'est-à-dire lorsque les documents ne sont pas validés par rapport à une spécification pour des paramètres comme les valeurs minimales/maximales, les types de données ou les valeurs requises) affectez une valeur différente de zéro et les données ne seront pas validées. Ceci peut améliorer les performances mais des données non valides risquent d'être envoyées. Ce paramétrage est approprié pour des serveurs qui reçoivent des documents dont l'organisation contrôle la structure.

  • ParserRefreshInterval. Par défaut défini à 60 000 (60 secondes). Cette valeur indique la fréquence à laquelle BizTalk Server doit contrôler la base de données pour vérifier l'ajout d'un nouveau parseur (c'est la seule propriété de niveau groupe qui est actualisée lorsque le serveur est en fonctionnement). Si aucun parseur ne doit être ajouté, définissez cette valeur à 0 pour que BizTalk Server ne contrôle pas la base de données. Cette valeur sert également à vérifier si de nouveaux parseurs ont été ajoutés dans les paramètres de groupe de la base de données de suivi ou si les paramètres ont été modifiés.

  • CacheSize. Utilisez cette clé de Registre pour indiquer la taille que le cache de l'objet de gestion de BizTalk Server est autorisé à atteindre. La valeur par défaut est 20. Par conséquent, dès que le cache de l'objet BizTalk Server dépasse 20 canaux, ports d'échanges, enveloppes ou définitions de document, BizTalk Server doit supprimer certains éléments de la mémoire. Si un serveur dispose d'une quantité importante de mémoire, cette valeur peut être supérieure (supérieure à 20) et BizTalk Server peut stocker davantage d'éléments en mémoire. Cela n'affecte pas les intervalles d'actualisation. BizTalk Server supprime les objets mis en cache et les recharge lorsqu'ils ont expiré.

  • BatchSize. Utilisez cette valeur uniquement avec la fonction de réception Message Queue. Par défaut la valeur BatchSize est définie à 20. Afin d'améliorer les performances, BizTalk Server lit simultanément jusqu'à 20 éléments dans la file d'attente et envoie ces 20 éléments dans une seule transaction. La réduction de la fréquence à laquelle les données sont enregistrées dans une base de données améliore considérablement les performances. Lorsqu'une étreinte fatale se produit et que BizTalk met fin à la transaction, il doit soumettre de nouveau les éléments. BizTalk Server ne perd pas les documents. Les valeurs supérieures à 20 n'ont pas été testées. Ne définissez pas cette valeur à 0.

Cette section traite de la rubrique suivante :

  • Amélioration des performances de traitement


Amélioration des performances de traitement

  1. Cliquez sur Démarrer, choisissez Exécuter, tapez regedit puis cliquez sur OK.

  2. Dans la boîte de dialogue Éditeur du Registre, cliquez sur le signe plus (+) correspondant au noeud HKEY_LOCAL_MACHINE ; développez les niveaux SYSTEM, CurrentControlSet et Services, puis cliquez sur BTSSvc.

  3. Cliquez avec le bouton droit dans le volet des informations, pointez sur Nouveau, puis cliquez sur Valeur DWORD.

  4. Tapez NoValidation et appuyez sur ENTRÉE deux fois.

    La boîte de dialogue Édition de la valeur DWORD s'affiche.

  5. Dans la zone Données de la valeur, tapez une valeur différente de 0, 1 par exemple, puis cliquez sur OK. La valeur par défaut est 0 (validation).

  6. Cliquez avec le bouton droit dans le volet des informations, pointez sur Nouveau, puis cliquez sur Valeur DWORD.

  7. Tapez ParserRefreshInterval et appuyez sur ENTRÉE.

  8. Cliquez avec le bouton droit dans le volet des informations, pointez sur Nouveau, puis cliquez sur Valeur DWORD.

  9. Tapez CacheSize et appuyez sur ENTRÉE deux fois.

    La boîte de dialogue Édition de la valeur DWORD s'affiche.

  10. Dans la zone Données de la valeur, tapez le nombre de canaux, de ports d'échanges, d'enveloppes et de définitions de document que vous voulez avoir ou que vous avez en mémoire.

  11. Cliquez avec le bouton droit dans le volet des informations, pointez sur Nouveau, puis cliquez sur Valeur DWORD.

  12. Tapez BatchSize et appuyez sur ENTRÉE deux fois.

    La boîte de dialogue Édition de la valeur DWORD s'affiche.

  13. Dans la zone Données de la valeur, tapez une valeur correspondant au nombre d'éléments à traiter en tant que lot.


Optimisation du cryptage

L'utilisation du cryptage ou d'un autre système de sécurité risque de diminuer les performances de BizTalk Server. Lorsque vous utilisez le cryptage, les recommandations suivantes s'appliquent :

  • Augmentez la vitesse d'horloge de l'UC (MHz). L'augmentation du nombre de processeurs augmente les performances.

  • Augmentez le nombre de serveurs.

  • Utilisez une UC plus rapide.

  • Séparez les fonctionnalités de BizTalk Server. Par exemple, les fonctions de réception et d'envoi peuvent être placées sur des serveurs distincts. Il est également possible de placer le service de transport HTTPS sur un serveur différent.

  • Utilisez un réseau privé virtuel (VPN) si les services de transport File ou Message Queuing sont utilisés. Lorsqu'un réseau VPN est disponible, le transfert des données est sécurisé. Il n'est pas nécessaire de sécuriser les transactions BizTalk Server lorsque tous les transferts de données réalisés avec les partenaires commerciaux sont sécurisés au moyen d'un réseau VPN.

  • Achetez des cartes d'accélérateur matériel pour le cryptage. Les cartes d'accélérateurs fournissent des processeurs dédiés qui sont capables d'éliminer les problèmes de performance dus au cryptage et au décryptage effectués sur l'UC d'un serveur. L'achat de cartes d'accélérateurs est moins onéreux que l'ajout de plusieurs UC.


Optimisation des communications

BizTalk Server fournit des systèmes d'intégration de communications synchrones et de communications asynchrones. BizTalk Server 2000 peut accepter des documents via l'intégration du modèle COM ou via des fonctions de réception du serveur (File ou Message Queuing).

D'une façon générale, lorsqu'un document est envoyé à BizTalk Server, il est placé dans une base de données de files d'attente partagées. BizTalk Server interroge la base de données puis traite le document. Ce processus est un processus de communication asynchrone. Il utilise la base de données Microsoft SQL Server comme une file d'attente pour contrôler les documents en attente de traitement. Cette couche supplémentaire d'abstraction permet au service de transport d'envoyer des documents au serveur BizTalk Server indépendamment du système de transport utilisé pour la livraison des documents.

Un échange de communications synchrones ignore toutes les files d'attente et traite tous les composants requis par le port d'échanges sur la thread qui appelle. Pour les protocoles de communications synchrones, un document de réponse facultatif est renvoyé, s'il est disponible. Cette méthode est valide uniquement pour une correspondance unique de canaux et uniquement pour un port d'échanges (et non pour des listes de distribution). Lorsque les paramètres définis font que plusieurs canaux se correspondent, un envoi effectué par un mode de communication synchrone renvoie une erreur, ce qui indique que les correspondances entre plusieurs canaux ne sont pas autorisées pour un envoi dans le cadre d'une communication synchrone. Cette méthode peut être utilisée uniquement pour les échanges de documents uniques. Si l'envoi contient plusieurs documents, une erreur est renvoyée pour les envois synchrones, ce qui indique que les envois de documents multiples ne sont pas autorisés. Cette méthode ne prend pas en charge les groupes. Les communications synchrones ne peuvent pas évoluer. Les communications synchrones utilisent une thread unique pour traiter une transaction et ne peuvent pas faire l'objet d'un équilibrage de charge avec d'autres serveurs BizTalk Server dans le groupe car tout le processus doit s'exécuter sur le serveur qui envoie les documents.

Le système de communications synchrones envoie des documents directement à BizTalk Server pour un traitement immédiat. BizTalk Server bloque le retour pour l'appelant de l'interface IInterchange::SubmitSync jusqu'à ce que le traitement soit terminé, puis une réponse est envoyée à l'appelant. Ce système est disponible uniquement pour la méthode d'intégration basée sur le modèle COM.

Solutions recommandées pour l'optimisation des communications synchrones et asynchrones

Pour optimiser les performances de BizTalk Server :

  • Il est hautement recommandé d'utiliser des communications asynchrones pour atteindre des performances et une évolutivité optimales. Les communications asynchrones sont hautement évolutives et offrent un niveau de débit élevé. Les appels de communications synchrones permettent l'émission de réponses presque immédiates vers l'appelant dans des environnements à grands volumes de transactions car chaque appel SubmitSync s'exécute sous une thread distincte. Cependant, lorsque plusieurs appels sont lancés en même temps, cela signifie que plusieurs threads s'exécutent sur un même serveur et cela dégrade donc les performances générales de BizTalk Server. Microsoft Windows 2000 permet le changement de contextes entre toutes les threads mais cela entraîne des dégradations de performances au niveau de BizTalk Server. Par ailleurs, les situations suivantes entraînent l'échec d'un envoi par communication synchrone mais non l'échec d'un envoi par communication asynchrone :
    • Les critères de transaction correspondent à plusieurs canaux.

    • Un échange contient plusieurs documents.
  • Les documents avec auto-routage risquent de dégrader les performances de BizTalk Server.


Configuration de pare-feu

Les pare-feu aident à la sécurisation des réseaux internes mais leur présence introduit un problème de latence et risque potentiellement de créer un point faible unique. Même si un système d'équilibrage de la charge est utilisé pour réduire ce risque, la présence d'un pare-feu est susceptible de réduire les performances du réseau.

Lorsque vous configurez un environnement BizTalk Server 2000 avec un pare-feu, sachez que deux configurations principales sont conseillées :

  • Configuration 1. Installez des serveurs sur un réseau interne de l'entreprise et d'autres serveurs, ceux qui communiquent avec les partenaires commerciaux, sur une zone DMZ (demilitarized zone) de l'entreprise. Une entreprise qui souhaite héberger ses propres services Internet sans sacrifier aux accès non autorisés à son réseau privé, utilise une zone DMZ. Une zone DMZ est une frontière entre Internet et les lignes de défense d'un réseau interne. Il s'agit généralement d'une combinaison de pare-feu et de serveurs servant de bastions, qui sont des passerelles entre les réseaux internes et externes. Les serveurs de la zone DMZ doivent utiliser des services de transport locaux comme HTTP, Message Queue ou SMTP. Dans un environnement de ce type, toutes les transactions entrantes et/ou sortantes transitent par un pare-feu. Les serveurs de la zone DMZ envoient les documents à Microsoft SQL Server via un autre pare-feu. Cette configuration permet aux serveurs, comme les serveurs BizTalk Server et HTTP dans la zone DMZ, de communiquer avec un serveur Microsoft SQL Server via un pare-feu interne.

  • Configuration 2. Installez les serveurs sur un réseau d'entreprise. Les partenaires commerciaux qui échangent des documents par Internet transmettent leurs données en utilisant des serveurs SMTP/HTTP dans la zone DMZ (premier pare-feu de protection). Ces serveurs envoient ensuite les données aux serveurs qui résident sur le réseau de l'entreprise via un second pare-feu.

Le choix entre la configuration 1 et la configuration 2 a un impact sur les performances. Pour éviter qu'une dégradation importante des performances ne se produise, vous pouvez construire le pare-feu de façon à assurer un nombre courant de transactions entre une organisation et ses partenaires commerciaux.


Conception, affinage et test de l'architecture

Les composants clés de BizTalk Server 2000 incluent les services BizTalk, les bases de données BizTalk Server et les services de transport. Une configuration insuffisante des composants risque de dégrader les performances de tout le système.

Cette section présente des informations complètes sur la définition, le test et l'affinage de l'architecture de BizTalk Server pour optimiser les performances.

Cette section traite des rubriques suivantes :

  • Conception de l'architecture

  • Test et analyse de l'architecture

Voir aussi

Évolution de BizTalk Server


Conception de l'architecture

Afin de déterminer de façon précise le nombre de documents qui peut être traité par BizTalk Server 2000, vous devez tout d'abord savoir si les fonctionnalités suivantes sont utilisées :

  • Validation des spécifications

  • Composants d'intégration aux applications

  • Services de transport

  • Cryptage

  • Services d'Orchestration BizTalk

  • Pare-feu

  • Mapping

Vous devez également tenir compte de la taille des documents traités ainsi que de la configuration actuelle du serveur.

Le test des performances est considéré réussi lorsqu'il est effectué avec des processus contrôlés. Il est important de commencer avec un petit nombre de variables puis d'en ajouter progressivement. Ainsi, lorsque les performances commencent à se dégrader, vous pouvez facilement en identifier la cause.

Cette section traite des rubriques suivantes :

  • Développement de composants de transaction

  • Identification des services de transport

  • Architecture de départ

Voir aussi

Administration des serveurs et des applications

Services d'Orchestration BizTalk

Création des composants d'intégration de l'application

Création de spécifications

Mappage de données

Exécuter les planifications XLANG

Utilisation du Concepteur d'Orchestration BizTalk


Développement de composants de transaction

Pour développer les composants de transaction, les utilisateurs doivent concevoir des transactions et définir des propriétés de transaction pour les processus professionnels. Pour plus d'informations sur l'activation des transactions, voir Conception de transactions.

  • Conception de processus professionnels

  • Conception de transactions

  • Propriétés des transactions d'un schéma de planification XLANG

Pour plus d'informations sur les techniques permettant de déterminer la meilleure configuration des transactions, voir Évaluation des performances d'une configuration.

Afin de développer des composants de transaction, vous devez d'abord déterminer les types de transactions traités par le composant. Dans un environnement de type application à application et/ou entreprise à entreprise (B to B), vous devez déterminer vos besoins en transactions et les profils de transactions. Par exemple, vous pouvez être confronté à un scénario dans lequel une transaction unique consiste à recevoir un bon de commande au format Custom XML et à le mapper à un bon de commande au format standard EDI, qui sera par la suite traité par une application interne personnalisée.

Ce scénario nécessite la création d'une spécification pour le bon de commande XML et d'une spécification pour le bon de commande EDI. Pour créer ces spécifications, utilisez l'Éditeur BizTalk, qui comporte des modèles XML et EDI. Comme ces modèles contiennent tous les enregistrements et les champs potentiellement utiles vous pouvez supprimer ceux dont vous n'avez pas besoin puis sauvegarder les modèles en tant que spécifications finales. Au cours de la conception, lorsque des champs d'une spécification nécessitent une validation, les performances de BizTalk Server 2000 risquent de s'en trouver affectées. Pour plus d'informations sur l'optimisation des spécifications, voir Création et optimisation des spécifications.

En plus de la création d'une spécification, vous devez mapper des données. Parce qu'il existe un certain nombre de méthodes pour convertir des données dans des fichiers de mappage (comme les conversions XSLT directes, les fonctoids et les scripts personnalisés) et que toutes ont un impact sur les performances, il est important de les tester. Le test d'une méthode de conversion de données pour la comparer à une autre aide à réduire la dégradation des performances de BizTalk Server due au mapping. Pour plus d'informations, voir Création et optimisation des mapping.

Voir aussi

Conception de processus professionnels

Conception de transactions

Identification des services de transport

Propriétés des transactions d'un schéma de planification XLANG


Identification des services de transport

Afin de déterminer comment envoyer et recevoir des données, vous devez savoir si les fonctionnalités suivantes sont utilisées :

  • Transactions B to B

  • Transactions d'application à application

  • Services de transport (envoi et réception)

  • Cryptage

  • HTTPS ou S/MIME

Déterminez si vous avez besoin de services de transport différents en vous basant sur le type de transaction que vous devez traiter. Déterminez si des services de transport uniques sont nécessaires pour les transactions B to B et les transactions d'application à application ou si les mêmes services de transport peuvent être utilisés pour ces deux types de transactions.


Architecture de départ

Afin de planifier correctement une architecture de départ, tenez compte des points suivants :

  • Il est possible d'utiliser un seul serveur avec Microsoft SQL Server et BizTalk Server pour traiter des volumes de transactions qui sont faibles.

  • L'installation de BizTalk Server et de SQL Server sur des machines distinctes peut s'envisager pour des volumes de transactions modérés.

  • Il est possible d'utiliser un service de transport SMTP existant pour envoyer et recevoir des données. Il est recommandé de placer ce serveur sur un serveur distinct pour ce type de transport.

  • Les services de transport HTTP, Message Queuing ou File peuvent être utilisés pour l'écriture des données sur des unités de disque situées sur d'autres serveurs que le serveur local BizTalk Server, ce qui peut aider à améliorer les performances de BizTalk Server.

L'architecture de départ doit contenir autant de serveurs distincts que possible. En effet, dans une entreprise, une personne peut par exemple administrer des serveurs SMTP et Message Queuing, tandis qu'une autre personne gère les stratégies de sécurité. En créant une architecture de départ, l'objectif est de déterminer le nombre de serveurs nécessaires et le matériel requis par ces serveurs pour traiter le volume de travail estimé. Lorsque vous avez déterminé le nombre de serveurs requis, testez l'architecture de départ.

Voir aussi

Test et analyse de l'architecture


Test et analyse de l'architecture

Avant de tester l'architecture, définissez les composants de l'architecture, déterminez les besoins en transactions et les profiles, déterminez quels composants de transaction il est nécessaire de développer et enfin, déterminez les services de transports utiles. Commencez ce processus en créant un plan de référence qui nécessite les actions suivantes :

  • Configurer les services d'échanges BizTalk, les organisations, les définitions de document, les canaux et les ports d'échanges requis pour traiter les transactions.

  • Configurer les services d'Orchestration BizTalk.

  • Installer et/ou configurer des applications COM+, des canaux BizTalk Server, des bases de données ou des files d'attente de message requis pour les planifications XLANG.

Une fois le plan de référence créé, traitez les transactions en utilisant BizTalk Server. Ce test aide à identifier les facteurs qui affectent les performances.

Cette section traite de la rubrique suivante :

  • Évaluation des performances d'une configuration

  • Amélioration de l'architecture

Voir aussi

Conception de l'architecture

Évolution de BizTalk Server


Évaluation des performances d'une configuration

Vous pouvez utiliser l'outil de test des performances de Microsoft Windows 2000 pour tester les performances des services d'échanges BizTalk.

Pour utiliser cet outil de test, dans le menu Démarrer, pointez sur Programmes, pointez sur Outils d'administration, puis cliquez sur Performances. Le Moniteur système, qui fait partie des outils de test des performances, affiche un compteur graphique dont les données changent avec le temps. Plusieurs compteurs doivent être contrôlés selon le composant du système à contrôler. De nombreux Livres blancs traitent de la façon de contrôler les performances de Windows 2000, IIS, SQL Server et de Message Queue ; quant aux tableaux suivants, ils citent uniquement quelques uns des objets et compteurs principaux qui doivent être contrôlés. Ils contiennent en outre des informations spécifiques sur les objets et les compteurs à contrôler pour déterminer les performances des services d'échanges BizTalk.

Objet | Compteur | Commentaire | Composant concerné
ASP (Active Server Pages) | Requêtes en attente | La file d'attente ne doit pas contenir un nombre important d'éléments, excepté aux heures de pointe. | Services de transport HTTP qui utilisent des pages .asp
 | Requêtes/s | Indique le volume de requêtes ASP que les services de transport HTTP reçoivent (lorsqu'ils utilisent des pages ASP). Lorsque les fichiers sont déposés sur une page HTTP, ce compteur ne fournit pas d'informations pertinentes. | Services de transport HTTP qui utilisent des pages .asp
 | Temps d'attente des requêtes | Proche de zéro. | Services de transport HTTP qui utilisent des pages .asp
Segment de réseau | Octets reçus par seconde/Octets envoyés par seconde | Si ce nombre est proche de la capacité de la connexion et que le processeur et la mémoire sont réquisitionnés de façon modérée, la connexion risque d'affecter les performances. | Complète
Processus, instance Inetinfo | Nombre d'octets privés | Surveille cet objet pour détecter les pertes de mémoire ou une taille de mémoire approchant la RAM maximale disponible. | Service de transport HTTP
Mémoire | Nombre d'octets disponibles | La quantité d'octets disponibles ne doit pas se situer constamment au-dessous de 10 Mo. Lorsque cela est le cas, une pointe d'utilisation de la mémoire entraîne la pagination sur le disque. | Complète
 | Défauts de page/s, Mémoire Entrée de pages/s, Mémoire Lectures de pages/s | Lorsque ces données sont faibles, cela signifie que le serveur doit répondre rapidement aux requêtes. Si elles sont élevées, l'augmentation de la RAM sur le serveur risque d'être nécessaire. | Complète
Disque physique | Lecture/disque/s Écriture/disque/s | Lorsqu'elles sont combinées, les données de ces deux compteurs doivent être nettement inférieures à la capacité maximale du périphérique disque. Pour activer ce compteur, dans le menu Démarrer, pointez sur Accessoires, puis cliquez sur Invite de commandes. Sur la ligne de commandes, tapez diskperf –y. Puis, redémarrez l'ordinateur. | SQL Server, services de transport Message Queue et File.
 | % Temps du disque | Ce compteur doit indiquer une valeur nettement inférieure à 100 pour cent. Si la valeur est supérieure (si elle est comprise dans un intervalle allant jusqu'à 1 000 pour cent), ajoutez davantage de disques physiques ou déplacez l'une des bases de données vers un autre serveur. | SQL Server, services de transport Message Queue et File.
 | Longueur de la file d'attente du disque actuelle | Ce compteur indique le nombre de requêtes en attente sur le disque au moment où les données de performances sont collectées. Ce compteur doit en moyenne être inférieur à 2 pour indiquer de bonnes performances. | BizTalk Server SQL Server
SQL Server | Transactions E/S/s | Indique combien d'activités le serveur SQL effectue. | SQL Server
BizTalk Server | Documents traités/s | Indique la vitesse à laquelle BizTalk Server 2000 recherche les documents dans sa file d'attente de travail et à quelle vitesse il les envoie. | Services d'échanges BizTalk
BizTalk Server | Documents reçus/s | Indique la vitesse à laquelle BizTalk Server envoie les documents à la file d'attente de travail. Cette valeur reflète uniquement le nombre de documents que BizTalk Server a reçus (y compris, les documents dont l'analyse a échoué) et non le nombre de documents que BizTalk Server contrôle dans sa file d'attente. Le nombre de documents contrôlés dans la file d'attente de travail est essentiellement égal au nombre de documents indiqués dans le compteur Documents traités/s. | Services d'échanges BizTalk
BizTalk Server | Envois synchrones/s, Envois asynchrones/s | Indique à quelle vitesse sont effectués les appels de la méthode Submit et/ou SubmitSync. Parce que chaque échange peut contenir un nombre illimité de documents, ce compteur n'est pas utile pour déterminer les documents traités. Si vous utilisez exclusivement des échanges directs (échanges traités sans analyse), ce compteur est celui que vous devez contrôler pour déterminer les performances en entrée. | Services d'échanges BizTalk
Message Queue | Messages dans la file d'attente | Cette valeur ne doit pas augmenter de façon importante (elle ne doit pas dépasser les 50 Ko) car la mémoire risque d'être utilisée de façon excessive sur le serveur Message Queue et les performances de tout le système risque d'être dégradées. | Service de transport Message Queue
Système | Longueur de file d'attente du processeur | Ce compteur indique le nombre de threads en attente d'exécution dans la file d'attente partagée par tous les processeurs du système. Si ce compteur indique en permanence une valeur égale à deux threads ou plus, cela signifie que le processeur participe à la dégradation des performances de tout le système. | Complète
 | Changements de contextes/s | Si le nombre indiqué est élevé sur le serveur BizTalk Server, cela est sans doute dû au fait que les fonctions de réception et d'envoi sont exécutées sur le même serveur. Si tel est le cas, envisagez de séparer les fonctions d'envoi et de réception et de les installer sur des serveurs distincts. | Complète
Processeur | % Temps processeur | Si la valeur indiquée par ce compteur est élevée et que la capacité de la carte réseau et des E/S de disque est dépassée, le processeur dégrade les performances. Sur un ordinateur équipé de plusieurs processeurs, examinez ce compteur pour identifier les déséquilibres. Par ailleurs, si cette valeur peut atteindre 100 pour cent lors des périodes de pointe, elle doit être inférieure pour les utilisations prolongées. Tous les éléments du serveur peuvent évoluer horizontalement. | Complète
Service Web | Récupération ou envoi de requêtes/s | Indique le volume de fichiers reçus par les méthodes HTTP de récupération ou d'envoi. | Service de transport HTTP

Aucun compteur spécifique au service de transport SMTP n'est mentionné car il existe un large éventail de produits SMTP disponibles. Quel que soit le service de transport SMTP utilisé, contrôlez le volume des messages envoyés et reçus de BizTalk Server. En contrôlant les compteurs cités dans ce tableau, vous pouvez identifier les dégradations des performances. Parce que la santé d'un système dépend du fonctionnement de l'ensemble des composants, ne modifiez pas de façon radicale la configuration de votre système en vous basant uniquement sur les faibles performances d'un seul composant.

Les données obtenues par le contrôle des performances sont également utiles à l'identification des symptômes qui risquent de poser des problèmes. Par exemple, une activité de disque élevée peut indiquer que SQL Server enregistre une grande quantité de données sur le disque mais cela peut également indiquer que le système effectue souvent des paginations sur le disque. Une pagination excessive sur le disque indique généralement que la mémoire est insuffisante. Dans ce cas, l'activité du disque est un indice signalant un problème mais non un problème.

Voir aussi

Évolution de BizTalk Server


Amélioration de l'architecture

En identifiant les zones qui affectent les performances, vous pouvez parfaire l'architecture du système pour rechercher des résultats optimum. Par exemple, le matériel a peut-être besoin de subir une mise à niveau ou plusieurs composants de BizTalk Server doivent être déplacés vers des serveurs distincts. En outre, il vous faudra peut-être ajuster les paramètres de BizTalk Server. Pour plus d'informations sur l'ajustement des paramètres, voir Optimisation des propriétés du serveur.

Assurez-vous que les modifications sont apportées méthodiquement. Une fois les modifications apportées, comme l'ajout d'UC supplémentaires, la modification d'un paramètre ou la séparation des fonctions et leur installation sur des serveurs distincts, documentez les modifications puis testez la nouvelle configuration pour déterminer si les performances se sont améliorées. Si la nouvelle configuration entraîne une amélioration des performances, vous pouvez poursuivre la modification de la configuration. Cependant, si la nouvelle configuration dégrade les performances, reconfigurez le système pour le restituer dans son état précédent et analysez les données pour déterminer l'origine du problème.

Voir aussi

Évaluation des performances d'une configuration


Maintenance des performances

Afin de maintenir les performances, créez un plan de maintenance courant qui garantisse le maintien d'un système en bon état ainsi que de bonnes performances futures pour BizTalk Server. Il est fort probable qu'avec le temps BizTalk Server traite un nombre croissant de documents. Même si l'architecture de départ de BizTalk Server a suffi à un bon fonctionnement, si le nombre des transactions augmente avec le temps, elle risque de ne plus suffire au maintien du même niveau de performance, à moins que l'architecture ou la configuration du système soit modifiées. Des pannes matérielles ou des mémoires insuffisantes peuvent également affecter les performances d'un système.

Cette section traite des rubriques suivantes :

  • Création d'un plan de maintenance des performances

  • Utilisation de Microsoft Application Center 2000


Création d'un plan de maintenance des performances

Un plan de contrôle réussi inclut :

  • Un plan détaillé des compteurs à contrôler. Il existe par exemple, plusieurs compteurs pour le Moniteur système de Windows 200, plusieurs seuils à contrôler ainsi que plusieurs interprétations possibles des problèmes qui peuvent être signalés par ces seuils. De plus, vous pouvez aussi contrôler les problèmes au niveau application comme vérifier si les requêtes SQL Server doivent renvoyer des données valides ou renvoyer des conditions de problèmes matériels.

  • Identification des processus pour la résolution des problèmes de performance. Il peut s'agir par exemple, de la consignation d'un message dans le journal des événements de Windows 2000, de l'activation d'une notification d'envoi de courrier électronique, ou de l'exécution d'une série d'événements par un programme personnalisé.

  • Définition des seuils de performance qui doivent générer une notification. Il est par exemple possible de configurer un outil de contrôle pour l'écriture d'un événement dans le journal des événements de Windows 2000 lorsque la capacité d'utilisation de l'UC atteint 90 pour cent. Cependant, si la capacité d'utilisation de l'UC stagne à 90 pour cent pendant plus de 5 minutes, il est possible de générer l'envoi d'un message électronique. La définition de différentes actions en réponse à différents niveaux de gravité de problèmes dépend de l'outil de contrôle utilisé.

  • La définition des séries d'actions en réponse aux événements enregistrés dans les journaux de Windows 2000. Windows 2000, BizTalk Server 2000, SQL Server et les services de transport natifs de Microsoft comme Message Queuing et HTTP enregistrent des événements dans le journal des événements de Windows 2000. Ce journal d'événements contient des informations précieuses qui peuvent signaler la survenue de problèmes sur l'un des serveurs du système BizTalk Server. Si vous traitez ces problèmes suffisamment tôt, vous pouvez éviter une défaillance du système qui pourrait dégrader les performances de tout le système. Un plan de maintenance doit inclure la fréquence à laquelle les journaux sont contrôlés et archivés et inclure également la partie responsable des tâches à accomplir. Il est possible d'utiliser un outil d'une tierce partie pour cumuler les journaux de plusieurs serveurs et les enregistrer dans une base de données pour effectuer des analyses consolidées. Ces outils peuvent servir à purger les journaux des serveurs.

  • La détermination des outils requis pour le contrôle des performances. L'outil Moniteur système de Windows 2000 examine les compteurs de performance et est capable de prendre des mesures lorsqu'une condition prédéfinie se présente. Pour plus d'informations sur la configuration d'alertes dans le Moniteur système, voir « Définition d'une configuration de contrôle » dans l'aide de Windows 2000. Par ailleurs, Microsoft Application Center 2000 ainsi qu'un certain nombre d'autres outils de tierces parties, met en oeuvre cette fonctionnalité avec des fonctions supplémentaires comme la journalisation dans une base de données et les tests au niveau application.


Utilisation de Microsoft Application Center 2000

Microsoft Application Center 2000 contient un outil appelé Health Monitor. Health Monitor remplace la fonctionnalité du journal des événements de Windows 2000 et les outils de contrôle du système. Il permet aux administrateurs d'installer des moniteurs. Ces moniteurs incluent notamment le contrôle de TCP/IP, des seuils de compteurs pour le contrôle des performances, des erreurs consignées dans des journaux d'événements et des événements WMI. Il est possible de configurer des conditions pour ces moniteurs de façon à ce que lorsque certains critères sont rencontrés, par exemple lorsqu'une UC atteint ou dépasse un seuil de 90 pour cent, une action est effectuée comme la déconnexion d'un serveur ou l'envoi d'un message par courrier électronique à un administrateur. Ces outils peuvent être utilisés pour contrôler et maintenir de façon proactive les performances de BizTalk Server 2000.

Important

  • Ne répliquez pas l'application XLANG Scheduler par défaut ou toute application COM+ qui héberge les planifications XLANG. Lorsque l'équilibrage de charge de composant est utilisé, ces applications COM+ doivent être installées sur chaque serveur. Vous pouvez répliquer les composants COM liés à des planifications XLANG.


Administration des serveurs et des applications

Les fonctions d'administration fournies avec Microsoft BizTalk Server 2000 vous permettent d'administrer efficacement toutes les installations de BizTalk Server 2000. L'administration porte sur quatre domaines :

  • administration des serveurs ;

  • administration des applications ;

  • administration de la programmation ;

  • administration des bases de données.

Cette section traite de l'administration des serveurs et des applications. Pour plus d'informations sur l'administration des serveurs et des applications, voir Modèle d'administration de BizTalk. L'administration des serveurs inclut la configuration et la gestion des groupes de serveurs, des serveurs, des fonctions de réception et de la file d'attente partagée de chaque groupe de serveurs. L'administration des applications inclut la configuration et la gestion des applications COM+ qui hébergent des planifications XLANG, l'application XLANG Scheduler par défaut et la base de données de persistance d'orchestration par défaut.

Cette section traite des rubriques suivantes :

  • Administration des serveurs

  • Administration programmée

Voir aussi

Modèle d'administration de BizTalk


Administration des serveurs

Administration de BizTalk Server inclut une interface utilisateur (IU) grâce à laquelle vous pouvez :

  • ajouter et gérer des serveurs installés avec Microsoft BizTalk Server 2000 dans des groupes de serveurs ;

  • configurer les propriétés des groupes de serveurs, telles que l'emplacement de la base de données de suivi et de la base de données de files d'attente partagée ;

  • Configuration et gestion des fonctions de réception.

  • afficher et gérer les files d'attente.

Pour obtenir de l'aide sur des tâches spécifiques, voir Comment.

Pour obtenir des informations générales, voir Concepts.

Pour obtenir des instructions sur la résolution de problèmes, voir Dépannage d'Administration de BizTalk Server.

Voir aussi

Environnement de Administration de BizTalk Server


Comment...

Cette section fournit des informations sur les procédures d'utilisation d'Administration de BizTalk Server. Il est vivement conseillé de consulter la section Concepts afin de bien comprendre toutes les fonctionnalités et capacités d'Administration de BizTalk Server.

Cette section traite des rubriques suivantes :

  • Ouverture de Administration de BizTalk Server

  • Ouverture des services de composant

  • Ajout d'utilisateurs au groupe Administrateurs de BizTalk Server

  • Configuration de la base de données Gestion d'échanges BizTalk

  • Actualisation de la console d'administration

  • Démarrage du service d'Échanges BizTalk

  • Ajout, suppression et configuration d'un groupe de serveurs

  • Ajout, suppression et configuration de serveurs dans un groupe

  • Exécution de serveurs dans un groupe

  • Gestion des files d'attente

  • Gestion des bases de données d'un groupe de serveurs

  • Gestion des fonctions de réception d'un groupe de serveurs

  • Gestion de l'Observateur d'événements

  • Gestion des applications et des bases de données XLANG


Ouverture de Admistration de BizTalk Server

  • Dans le menu Démarrer, pointez sur Programmes et sur Microsoft BizTalk Server 2000, puis cliquez sur Administration de BizTalk Server.


Ouverture des services de composant

  • Dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration et sur Services de composants.


Ajout d'utilisateurs au groupe Administrateurs de BizTalk Server

Pour ajouter des utilisateurs au groupe Administrateurs de BizTalk Server, vous devez être un membre du groupe Administrateurs de Windows 2000. Pour plus d'informations sur l'ajout d'utilisateurs au groupe Administrateurs de Windows 2000, voir Ajout d'un compte utilisateur au groupe d'administrateurs.

  1. Dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration puis sur Gestion de l'ordinateur.

  2. Développez successivement Outils système et Utilisateurs et groupes locaux, puis cliquez sur le dossier Groupes.

    Le contenu du dossier apparaît dans le volet de détails.

  3. Dans le volet de détails, cliquez sur Administrateurs de BizTalk Server.

  4. Dans le menu Action, pointez sur Toutes les tâches, puis cliquez sur Ajouter au groupe.

    La boîte de dialogue Propriétés de Administrateurs de BizTalk Server s'affiche.

  5. Cliquez sur Ajouter.

  6. Dans la liste Regarder dans, cliquez sur votre domaine ou sur le nom de votre ordinateur.

  7. Dans la liste contenant les utilisateurs et les ordinateurs associés au domaine ou à l'ordinateur que vous avez sélectionné à l'étape 6, cliquez sur le compte utilisateur à ajouter, cliquez sur Ajouter, puis sur OK.

  8. Cliquez sur OK pour fermer la boîte de dialogue Propriétés de Administrateurs de BizTalk Server.

Remarques

  • Cette procédure implique que le nom du groupe d'Administration de BizTalk Server est Administrateurs de BizTalk Server.

  • Le cas échéant, déconnectez-vous et utilisez votre compte utilisateur pour vous reconnecter.

Voir aussi

Privilèges d'administration


Configuration de la base de données Gestion d'échanges BizTalk

  1. Dans Administration de BizTalk Server, cliquez sur Microsoft BizTalk Server 2000.

  2. Dans le menu Action, cliquez sur Propriétés.

    La boîte de dialogue Propriétés de BizTalk Server 2000 s'affiche.

  3. L'onglet Général vous permet de modifier les propriétés suivantes :
    • Nom de base de données SQL : Entrez le nom de la base de données Gestion d'échanges BizTalk que vous voulez utiliser pour tous les groupes de serveurs.

    • Nom du serveur SQL : Entrez le nom du serveur qui stocke la base de données Microsoft SQL Server sur laquelle la base de données Gestion d'échanges BizTalk est stockée.

    • Nom d'utilisateur : Vous pouvez modifier le nom d'utilisateur SQL Server utilisé pour vous connecter au serveur sur lequel la base de données Gestion d'échanges BizTalk est stockée.

    • Mot de passe : Vous pouvez modifier le mot de passe SQL Server utilisé pour vous connecter au serveur sur lequel la base de données Gestion d'échanges BizTalk est stockée.
  4. Cliquez sur OK.

Attention

  • Utilisez cette procédure si vous devez mettre la base de données Gestion d'échanges BizTalk hors ligne pour des opérations de maintenance. Cependant, vous devez pointer sur une base de données répliquée et non sur une autre base de données Gestion d'échanges BizTalk à laquelle sont associés d'autres groupes de serveurs. Pour plus d'informations sur l'utilisation d'une autre base de données, voir Modification de la base de données Gestion d'échanges BizTalk.

Remarques

  • Lorsque vous utilisez une autre base de données Gestion d'échanges BizTalk ou lorsque vous pointez sur les groupes de serveurs d'un autre serveur Microsoft SQL, vous devez procéder comme suit :
    1. Arrêtez tous les serveurs du noeud Microsoft BizTalk Server 2000. Pour plus d'informations sur l'arrêt des serveurs, voir Arrêt d'un serveur dans un groupe.

    2. Fermez l'application Échange BizTalk Server. Pour plus d'informations sur l'arrêt de l'application Échange BizTalk Server, voir Arrêt de l'application Échange BizTalk Server.

    3. Redémarrez tous les serveurs du noeud Microsoft BizTalk Server 2000. Pour plus d'informations sur le redémarrage des serveurs, voir Démarrage d'un serveur dans un groupe.

    Lorsque vous utilisez une autre base de données Gestion d'échanges BizTalk ou que vous pointez sur les groupes de serveurs d'un autre serveur Microsoft SQL, tous les serveurs BizTalk de la base de données centrale Gestion d'échanges BizTalk sont mis à jour avec les nouvelles informations.

  • Si vous modifiez la base de données Gestion d'échanges BizTalk de votre serveur puis ajoutez votre serveur à un nouveau groupe, des problèmes peuvent survenir lorsque vous soumettez un document à votre serveur. Pour éviter d'éventuels problèmes, arrêtez tous les serveurs dans le noeud Microsoft BizTalk Server 2000, fermez l'application Échange BizTalk Server, puis redémarrez tous les serveurs dans le noeud Microsoft BizTalk Server 2000. Pour plus d'informations sur l'arrêt des serveurs, voir Arrêt d'un serveur dans un groupe. Pour plus d'informations sur la fermeture de l'application Échange BizTalk Server, voir Arrêt de l'application Échange BizTalk Server. Pour plus d'informations sur le redémarrage des serveurs, voir Démarrage d'un serveur dans un groupe.

Voir aussi

Modification de la base de données Gestion d'échanges BizTalk

Arrêt de l'application Échange BizTalk Server

Démarrage d'un serveur dans un groupe

Arrêt d'un serveur dans un groupe


Actualisation de la console d'administration

  1. Dans Administration de BizTalk Server, développez Microsoft BizTalk Server 2000 puis les éléments de l'arborescence de la console jusqu'à ce que vous trouviez l'élément à actualiser. Vous devrez peut-être développer les groupes de serveurs, les files d'attente, les fonctions de réception et les serveurs pour trouver l'élément que vous voulez actualiser.

  2. Cliquez sur l'élément que vous voulez actualiser.

  3. Dans le menu Action, cliquez sur Actualiser.

Remarques

  • Dans Administration de BizTalk Server, vous pouvez actualiser le statut des éléments suivants :
    • Noeud de Microsoft BizTalk Server 2000

    • Groupes de serveurs

    • Serveurs

    • Files d'attente

    • Fonctions de réception
  • Vous pouvez effectuer cette opération d'actualisation pour tous les éléments de l'arborescence de la console. Lorsque vous actualisez la console d'administration au niveau de la racine, tous les éléments de la console d'administration sont actualisés. En revanche, lorsque vous actualisez un groupe de serveurs, seuls les éléments de ce groupe sont actualisés.

  • Il n'existe pas de cycle d'actualisation automatique pour la console d'administration. Effectuez cette procédure pour visualiser l'état actuel des serveurs, des groupes de serveurs, des fonctions de réception, du nombre d'éléments dans une file d'attente, etc.

Voir aussi

Groupes et serveurs

Fonctions de réception

Utilisation des files d'attente


Démarrage du service d'Échanges BizTalk

  1. Dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration et sur Services de composants.

  2. Vérifiez que Services (Local) est sélectionné.

  3. Dans le volet de détails, cliquez sur Service d'Échanges BizTalk.

  4. Dans le menu Action, cliquez sur Démarrer.


Ajout, suppression et configuration d'un groupe de serveurs

Reportez-vous aux procédures suivantes pour ajouter, supprimer et configurer un groupe de serveurs :

  • Ajout d'un groupe de serveurs

  • Configuration des propriétés générales d'un groupe de serveurs

  • Configuration des propriétés de connexion d'un groupe de serveurs

  • Configuration des propriétés de suivi d'un groupe de serveurs

  • Configuration de l'ordre des parseurs d'un groupe de serveurs

  • Suppression d'un groupe de serveurs


Ajout d'un groupe de serveurs

  1. Dans Administration de BizTalk Server, cliquez sur Microsoft BizTalk Server 2000.

  2. Dans le menu Action, pointez sur Nouveau, puis cliquez sur Groupe.

    La boîte de dialogue Nouveau groupe s'affiche.

  3. Dans la zone Nom du groupe, entrez le nom du nouveau groupe de serveurs.

  4. Dans la zone Base de données de suivi :
    • Dans la zone Nom de la base de données de suivi, entrez le nom de la base de données de suivi pour ce groupe de serveurs.

    • Dans la zone Nom du serveur SQL de suivi, entrez le nom du serveur sur lequel est stockée la base de données de suivi correspondant à ce groupe.

    • Dans les zones Nom d'utilisateur et Mot de passe, entrez le nom d'utilisateur et le mot de passe de connexion Microsoft SQL Server utilisés pour la connexion au serveur sur lequel la base de données de suivi est stockée.

      Le champ Nom d'utilisateur doit obligatoirement être renseigné, contrairement au champ facultatif Mot de passe. Ne renseignez pas ce champ si la connexion au serveur ne nécessite pas l'entrée d'un mot de passe.

  5. Dans la zone Base de données de files d'attente partagée :
    • Dans la zone Nom de la base de données de files d'attente partagée, entrez le nom de la base de données de files d'attente partagée correspondant à ce groupe de serveurs.

    • Dans la zone Nom du serveur SQL de files d'attente partagées, entrez le nom du serveur sur lequel est stockée la base de données de files d'attente partagée correspondant à ce groupe de serveurs.

    • Dans les zones Nom d'utilisateur et Mot de passe, entrez le nom d'utilisateur et le mot de passe de connexion SQL Server utilisés pour la connexion au serveur sur lequel la base de données de files d'attente partagée est stockée.

      Le champ Nom d'utilisateur doit obligatoirement être renseigné, contrairement au champ facultatif Mot de passe. Ne renseignez pas ce champ si la connexion au serveur ne nécessite pas l'entrée d'un mot de passe.

  6. Cliquez sur OK.

Important

  • N'utilisez pas les caractères suivants dans le nom du groupe de serveurs : ` ! @ # $ % ^ & * ( ) + = [ ] { } | \\ ;\" '< > , .?. Pour plus d'informations sur les caractères non valides, voir Vue d'ensemble de WMI.

Remarque

  • Cette procédure crée un groupe de serveurs. Pour utiliser des paramètres supplémentaires pour la configuration du groupe de serveurs, voir Configuration des propriétés générales d'un groupe de serveurs.

Voir aussi

Ajout, suppression et configuration de serveurs dans un groupe

Configuration des propriétés générales d'un groupe de serveurs

Groupes et serveurs

Gestion de la base de données Gestion d'échanges BizTalk

Base de données de files d'attente partagée

Base de données de suivi

Vue d'ensemble de WMI


Configuration des propriétés générales d'un groupe de serveurs

  1. Dans Administration de BizTalk Server, développez Microsoft BizTalk Server 2000, puis cliquez sur le groupe de serveurs que vous voulez configurer.

  2. Dans le menu Action, cliquez sur Propriétés.

    La boîte de dialogue Propriétés du groupe de serveurs BizTalk Server s'affiche.

  3. Dans la zone Hôte SMTP, entrez le nom de l'hôte SMTP (Simple Mail Transfer Protocol) que ce groupe de serveurs utilise.

    Ce champ est facultatif. Utilisez cette configuration si vous recourez à BizTalk Server pour envoyer des documents à un partenaire commercial ou à une application interne via SMTP .

  4. Dans la zone URL de réponse d'échange de type Reliable, entrez l'URL que ce groupe de serveurs utilise pour recevoir les accusés de réception d'échanges au format Reliable via l'un des protocoles pris en charge ci-après : File, Message Queuing, HTTP, http(S) ou SMTP.
    Transport | Préfixe
    Fichier | fichier://
    Message Queuing | queue://Direct=OS:<nomduserveur>\<nomdelafiled'attente>
    HTTP (Hyper Text Transport Protocol) | http://
    HTTPS (Hyper Text Transport Protocol Secure) | https://
    SMTP | mailto:

    Si vous spécifiez Message Queuing, vous devez utiliser un nom de format. En outre, "queue://" doit précéder le nom de format. Pour plus d'informations sur les noms de format, voir Fonctions de réception disponibles.

  5. Dans la liste Intervalle d'actualisation de cache d'objet de gestion d'échanges (en secondes), cliquez sur le nombre de secondes écoulées entre les mises à jour de cache pour le groupe de serveurs.

    Par défaut, le serveur met à jour ce cache toutes les 50 secondes.

  6. Dans la zone Serveur proxy, activez la case à cocher Utiliser un serveur proxy si vous voulez configurer la connexion Internet de BizTalk Server via un serveur proxy.

    Entrez l'adresse et le port du serveur proxy que vous voulez utiliser.

  7. Cliquez sur OK.

  8. Suivez les étapes suivantes uniquement si vous avez apporté des modifications dans la zone Serveur proxy.
    • Arrêtez chaque serveur du groupe de serveurs pour lequel vous avez configuré les propriétés générales. Pour plus d'informations sur l'arrêt d'un serveur, voir Arrêt d'un serveur dans un groupe.

    • Démarrez chaque serveur du groupe de serveurs pour lequel vous avez configuré les propriétés générales. Pour plus d'informations sur le démarrage d'un serveur, voir Démarrage d'un serveur dans un groupe.

Important

  • Le champ Hôte SMTP ne doit pas obligatoirement être renseigné. Vous devez toutefois configurer ce champ si vous envisagez d'utiliser SMTP comme service de transport dans le Gestionnaire d'échanges BizTalk. Par exemple, vous ne pouvez pas choisir SMTP comme transport principal ou secondaire dans le Gestionnaire d'échanges BizTalk si vous n'avez pas configuré l'hôte SMTP à ce stade.

Remarques

  • L'échange au format Reliable dans BizTalk Server est compatible avec BizTalk Framework 2.0. Pour plus d'informations sur l'échange au format Reliable et BizTalk Framework 2.0, consultez le site Web Microsoft à l'adresse microsoft.com/biztalk, puis effectuez une recherche sur "BizTalk Framework 2.0".

  • Lorsque vous configurez la zone URL de réponse d'échange de type Reliable, utilisez une page ASP (Active Server Page) ou une file d'attente de messages dotée d'une fonction de réception pour la surveillance. Si vous ne voulez pas configurer votre propre page ASP dès le départ, utilisez le fichier ReceiveStandard.asp inclus dans BizTalk Server. Cet exemple de page ASP se trouve dans \Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\Receive Scripts. Cette page est conçue pour enregistrer des envois et les transmettre à BizTalk Server. Pour plus d'informations sur l'implémentation d'un site sécurisé, consultez le site Web MSDN Online Library à l'adresse www.msdn.microsoft.com/library/default.asp, puis effectuez une recherche sur "Implementing a Secure Site with ASP".

  • Si vous spécifiez que l'URL doit inclure localhost dans la zone URL de réponse d'échange de type Reliable, la fonction de réception ne fonctionnera pas correctement. Par conséquent, ne spécifiez pas localhost dans ce champ.

  • La réponse à un envoi HTTP doit être constituée de texte. Si la réponse nécessite des données binaires, codez ces données binaires avec MIME ou UUEncode.

Voir aussi

Cache d'administration

Fonctions de réception disponibles

Démarrage d'un serveur dans un groupe

Arrêt d'un serveur dans un groupe


Configuration des propriétés de connexion d'un groupe de serveurs

  1. Dans Administration de BizTalk Server, développez Microsoft BizTalk Server 2000, puis cliquez sur le groupe de serveurs que vous voulez configurer.

  2. Dans le menu Action, cliquez sur Propriétés.

    La boîte de dialogue Propriétés du groupe de serveurs BizTalk Server s'affiche.

  3. Cliquez sur l'onglet Connexion.

  4. Dans la zone Base de données de suivi :
    • Dans la zone Nom de la base de données de suivi, entrez le nom de la base de données de suivi que ce groupe de serveurs utilise.

    • Dans la zone Nom du serveur SQL de suivi, entrez le nom du serveur Microsoft SQL qui stocke la base de données de suivi que ce groupe de serveurs utilise.

    • Dans les zones Nom d'utilisateur et Mot de passe, entrez le nom d'utilisateur et le mot de passe de connexion Microsoft SQL Server utilisés pour la connexion au serveur sur lequel la base de données de suivi est stockée.
  5. Dans la zone Base de données de files d'attente partagée :
    • Dans la zone Nom de la base de données de files d'attente partagée, entrez le nom de la base de données de files d'attente partagée que ce groupe de serveurs utilise.

    • Dans la zone Nom du serveur SQL de files d'attente partagées, entrez le nom du serveur Microsoft SQL qui stocke la base de données de files d'attente partagée que ce groupe de serveurs utilise.

    • Dans les zones Nom d'utilisateur et Mot de passe, entrez le nom d'utilisateur et le mot de passe de connexion SQL Server utilisés pour la connexion au serveur sur lequel la base de données de files d'attente partagée est stockée.
  6. Cliquez sur OK.

Remarque

  • Si vous modifiez des informations dans les zones Base de données de suivi ou Base de données de files d'attente partagée, vous devez procéder comme suit :
    1. Arrêtez tous les serveurs du noeud Microsoft BizTalk Server 2000. Pour plus d'informations sur l'arrêt des serveurs, voir Arrêt d'un serveur dans un groupe.

    2. Fermez l'application Échange BizTalk Server. Pour plus d'informations sur l'arrêt de l'application Échange BizTalk Server, voir Arrêt de l'application Échange BizTalk Server.

    3. Redémarrez tous les serveurs du noeud Microsoft BizTalk Server 2000. Pour plus d'informations sur le redémarrage des serveurs, voir Démarrage d'un serveur dans un groupe.
  • Si vous modifiez des valeurs dans la zone Base de données de suivi, vous devez mettre à jour la chaîne de connexion dans le fichier Connection.vb et la remplacer par les nouvelles informations de la base de données de suivi. Le fichier Connection.vb se trouve dans le dossier \Program Files\Microsoft BizTalk Server\Setup. La propriété Catalogue initiale, dans la chaîne de connexion, contient le nom de la base de données de suivi. Mettez à jour cette propriété afin de mettre à jour le nom de la base de données de suivi. La chaîne de connexion dans le fichier Connection.vb est :
    Const g_ConnectionString = "Provider=SQLOLEDB.1;
Persist Security Info=False;User ID=dta_ui_login;
Password=;Initial Catalog=<databasename>;
Data Source=<servername>;Connect Timeout=15"

Voir aussi

Fonctions de réception disponibles

Groupes et serveurs

Arrêt de l'application Échange BizTalk Server

Démarrage d'un serveur dans un groupe

Arrêt d'un serveur dans un groupe


Configuration des propriétés de suivi d'un groupe de serveurs

  1. Dans Administration de BizTalk Server, développez Microsoft BizTalk Server 2000, puis cliquez sur le groupe de serveurs que vous voulez configurer.

  2. Dans le menu Action, cliquez sur Propriétés.

    La boîte de dialogue Propriétés du groupe de serveurs BizTalk Server s'affiche.

  3. Cliquez sur l'onglet Suivi.

  4. Activez la case à cocher Activer le Suivi de documents et sélectionnez, parmi les options suivantes, celles que vous voulez utiliser :
    • Activez la case à cocher Consigner l'échange entrant dans un journal pour consigner les échanges entrants.

    • Activer la case à cocher Consigner l'échange sortant dans un journal pour consigner les échanges sortants.

    • Activez la case à cocher Consigner le message MIME d'origine dans un journal pour consigner les messages MIME.
  5. Cliquez sur OK.

Attention

  • Vous pouvez désactiver la case à cocher Activer le Suivi de documents afin de désactiver le suivi, auquel cas, vous ne serez plus en mesure d'utiliser certaines fonctionnalités importantes de BizTalk Server 2000. Pour plus d'informations sur le suivi, voir Description des paramètres de suivi d'un groupe de serveurs.

Remarque

  • Si vous n'activez pas la case à cocher Activer le Suivi de documents, les cases à cocher Consigner l'échange entrant dans un journal, Consigner l'échange sortant dans un journal et Consigner le message MIME d'origine dans un journal ne sont pas disponibles.

Voir aussi

Groupes et serveurs

Description des paramètres de suivi d'un groupe de serveurs


Configuration de l'ordre des parseurs d'un groupe de serveurs

  1. Dans Administration de BizTalk Server, développez Microsoft BizTalk Server 2000, puis cliquez sur le groupe de serveurs pour lequel vous voulez configurer l'ordre des parseurs.

  2. Dans le menu Action, cliquez sur Propriétés.

    La boîte de dialogue Propriétés du groupe de serveurs BizTalk Server s'affiche.

  3. Cliquez sur l'onglet Parseurs.

    Les parseurs figurent dans la zone de liste Organiser la séquence d'appels du serveur, et ils apparaissent dans l'ordre suivant :

    • BizTalk.ParserXML.1

    • BizTalk.ParserEdifact.1

    • BizTalk.ParserX12.1

    • BizTalk.ParserFFile.1

Pour optimiser les performances de BizTalk Server, vous pouvez déplacer les parseurs les plus fréquemment utilisés vers le sommet de la liste.

  4. Dans la zone Organiser la séquence d'appels du serveur, cliquez sur le parseur que vous voulez déplacer, puis cliquez sur les flèches HAUT ou BAS pour que le parseur sélectionné apparaisse plus haut ou plus bas dans la séquence d'appels du serveur.

  5. Lorsque les parseurs sont organisés dans l'ordre de votre choix, cliquez sur OK.

Remarque

  • Le bouton Actualiser enregistre les nouveaux parseurs stockés dans le registre local. Si vous voulez qu'un nouveau parseur apparaisse dans la zone Organiser la séquence d'appels du serveur, vous devez cliquer sur le bouton Actualiser correspondant au serveur sur lequel le parseur est enregistré.

Voir aussi

Using the IBizTalkParserComponent Interface


Suppression d'un groupe de serveurs

  1. Dans Administration de BizTalk Server, développez Microsoft BizTalk Server 2000, puis développez le groupe de serveurs que vous voulez supprimer.

  2. Cliquez sur un serveur dans le groupe de serveurs que vous voulez supprimer.

  3. Dans le menu Action, cliquez sur Arrêter.

    Répétez les étapes 2 et 3 pour chaque serveur dans le groupe, jusqu'à l'arrêt de tous les serveurs.

  4. Cliquez sur le groupe de serveurs.

  5. Dans le menu Action, cliquez sur Supprimer.

    La boîte de dialogue Confirmation de l'action utilisateur s'affiche.

  6. Cliquez sur Oui.

Remarques

  • Vous ne pouvez pas supprimer un groupe de serveurs qui contient un ou plusieurs serveurs en cours d'exécution. Pour arrêter les serveurs et supprimer le groupe de serveurs, vous devez disposer de droits d'administrateur dans Windows 2000 pour tous les serveurs du groupe.

  • Les bases de données de files d'attente partagée et de suivi qui sont associées au groupe de serveurs sont maintenues dans Microsoft SQL Server, même si vous supprimez le groupe. Pour supprimer les bases de données de files d'attente partagée et de suivi, vous devez effectuer une suppression manuelle. Pour plus d'informations sur la suppression de ces bases de données, voir Suppression des bases de données de suivi et de files d'attente partagées.

Voir aussi

Groupes et serveurs

Suppression des bases de données de suivi et de files d'attente partagées

Arrêt d'un serveur dans un groupe


Ajout, suppression et configuration de serveurs dans un groupe

Les procédures suivantes permettent d'ajouter, de supprimer et de configurer des serveurs dans un groupe :

  • Ajout d'un serveur à un groupe

  • Suppression d'un serveur d'un groupe

  • Configuration d'un serveur dans un groupe

  • Modification de la base de données Gestion d'échanges BizTalk d'un serveur


Ajout d'un serveur à un groupe

  1. Dans Administration de BizTalk Server, développez Microsoft BizTalk Server 2000, puis cliquez sur le groupe de serveurs auquel vous voulez ajouter un serveur.

  2. Dans le menu Action, pointez sur Nouveau, puis cliquez sur Serveur.

    La boîte de dialogue Ajouter un serveur BizTalk s'affiche.

  3. Dans la zone Nom du serveur BizTalk Server, entrez le nom d'un serveur sur lequel vous avez effectué une installation complète de BizTalk Server 2000.

  4. Cliquez sur OK.

Remarque

  • Pour visualiser les propriétés globales du groupe de serveurs auquel vous avez ajouté le serveur, cliquez avec le bouton droit sur le groupe, puis cliquez sur Propriétés.

Voir aussi

Groupes et serveurs

Exécution de serveurs dans un groupe

Description des propriétés d'un serveur


Suppression d'un serveur d'un groupe

  1. Dans Administration de BizTalk Server, développez Microsoft BizTalk Server 2000 et le groupe de serveurs contenant le serveur que vous voulez supprimer, puis cliquez sur le serveur.

  2. Dans le menu Action, cliquez sur Arrêter.

    Le serveur termine le traitement de tous les échanges et documents en cours.

  3. Dans le menu Action, cliquez sur Supprimer.

    La boîte de dialogue Confirmation de l'action utilisateur s'affiche.

  4. Cliquez sur Oui.

Remarque

  • Vous ne pouvez pas supprimer un serveur d'un groupe de serveurs si une ou plusieurs fonctions de réception pointe sur ce serveur pour le traitement de documents. Vous pouvez modifier les fonctions de réception pour faire en sorte qu'elles pointent sur d'autres serveurs. Vous pouvez également supprimer les fonctions de réception si elles ne peuvent plus être utilisées.

Voir aussi

Échanges libres à partir d'un serveur

Groupes et serveurs

Gestion des fonctions de réception d'un groupe de serveurs

Exécution de serveurs dans un groupe


Configuration d'un serveur dans un groupe

  1. Dans Administration de BizTalk Server, développez Microsoft BizTalk Server 2000 et le groupe de serveurs contenant le serveur que vous voulez configurer, puis cliquez sur le serveur.

  2. Dans le menu Action, cliquez sur Arrêter.

    Vous ne pouvez pas modifier les paramètres de configuration du serveur lorsque le serveur est en cours d'exécution.

  3. Dans le menu Action, cliquez sur Propriétés.

    La boîte de dialogue Propriétés de <Computername> s'affiche.

  4. Dans la zone Nombre maximal de threads de fonction de réception autorisé, entrez un nombre compris entre 1 et 128.

    La valeur par défaut est 4. Pour plus d'informations sur la configuration de cette option, voir Description des propriétés d'un serveur.

  5. Si vous voulez que le serveur traite les éléments dans la file de travail, activez la case à cocher Participer au traitement de l'élément de travail.

    Lorsque cette case à cocher est activée, le serveur traite les documents dans la file de travail. Désactivez cette case à cocher si vous ne voulez pas que le serveur traite les documents dans la file de travail. Pour plus d'informations sur la configuration de cette option, voir Description des propriétés d'un serveur.

  6. Dans la zone Nombre maximal de threads de fonction de réception autorisé, entrez un nombre compris entre 1 et 128.

    La valeur par défaut est 4. Pour plus d'informations sur la configuration de cette option, voir Description des propriétés d'un serveur.

  7. Dans la zone Intervalle entre appels de BizTalk Server Scheduler (en millisecondes), entrez un nombre compris entre 1 et 4 294 967 295.

    La valeur par défaut est 200. Pour plus d'informations sur la configuration de cette option, voir Description des propriétés d'un serveur.

  8. Cliquez sur OK.

  9. Cliquez avec le bouton droit sur le serveur que vous avez configuré, puis cliquez sur Démarrer.

Remarque

  • Si la case à cocher Participer au traitement de l'élément de travail est désactivée, les cases à cocher Nombre maximal de threads de travail autorisé par processeur et Intervalle entre appels de BizTalk Server Scheduler (en millisecondes) ne sont pas disponibles.

Voir aussi

Groupes et serveurs

Exécution de serveurs dans un groupe

Description des propriétés d'un serveur


Modification de la base de données Gestion d'échanges BizTalk d'un serveur

  1. Dans Administration de BizTalk Server, développez Microsoft BizTalk Server 2000 et le groupe de serveurs contenant le serveur dont vous voulez modifier la base de données Gestion d'échanges BizTalk, puis cliquez sur le serveur.

  2. Dans le menu Action, cliquez sur Arrêter.

  3. Dans le menu Action, cliquez sur Supprimer.

    La boîte de dialogue Confirmation de l'action utilisateur s'affiche.

  4. Cliquez sur Oui.

  5. Fermez Administration de BizTalk Server.

  6. Dans le menu Démarrer, pointez sur Programmes et sur Accessoires, puis cliquez sur Synchroniser.

  7. Accédez à \Program Files\Microsoft BizTalk Server\Setup.

  8. Cliquez sur le fichier BTSsetupDB.exe.

  9. Dans le menu Fichier, cliquez sur Ouvrir.

    L'Assistant Configuration des bases de données d'échanges Microsoft BizTalk Server 2000 s'ouvre.

  10. Dans la page Assistant Configuration des bases de données Microsoft BizTalk Server 2000, cliquez sur Suivant.

  11. Dans la page Configurer une base de données Gestion d'échanges BizTalk, cliquez sur Créer une nouvelle base de données Gestion d'échanges BizTalk.

    —Ou—

    Cliquez sur Sélectionner une base de données existante.

  12. Dans la zone Nom du serveur, cliquez sur le nom du serveur sur lequel se trouve la nouvelle base de données Gestion d'échanges BizTalk ou la base de données existante Gestion d'échanges BizTalk.

  13. Dans les zones Nom d'utilisateur et Mot de passe, entrez un mot de passe et un nom d'utilisateur valides pour accéder au serveur SQL, le cas échéant.

  14. Dans la zone Base de données, entrez le nom de la nouvelle base de données Gestion d'échanges BizTalk ou de la base de données Gestion d'échanges BizTalk existante.

  15. Cliquez sur Suivant.

  16. Dans la page Configurer un groupe de serveurs BizTalk, cliquez sur Nouveau groupe BizTalk Server. Dans la zone Nom du groupe, entrez le nom du nouveau groupe, puis cliquez sur Suivant.

    —Ou—

    Cliquez sur Sélectionnez un groupe BizTalk Server existant. Dans la liste Nom du groupe, cliquez sur le nom du groupe existant, puis cliquez sur Suivant.

    Vous pouvez uniquement sélectionner un groupe BizTalk Server existant si vous avez sélectionné une base de données existante à l'étape 11.

  17. Si nécessaire, cliquez sur Créer une nouvelle base de données de suivi, puis cliquez sur Suivant.

    —Ou—

    Cliquez sur Sélectionner une base de données existante. Dans la liste Nom du serveur, cliquez sur un serveur. Dans les zones Nom d'utilisateur et Mot de passe, entrez un nom d'utilisateur et un mot de passe Microsoft SQL Server valides, le cas échéant. Dans la zone Base de données, entrez le nom de la base de données. Cliquez sur Suivant.

  18. Si nécessaire, cliquez sur Créer une nouvelle base de données de files d'attente partagée, puis cliquez sur Suivant.

    —Ou—

    Cliquez sur Sélectionner une base de données existante. Dans la liste Nom du serveur, cliquez sur un serveur. Dans les zones Nom d'utilisateur et Mot de passe, entrez un nom d'utilisateur et un mot de passe SQL Server valides, le cas échéant. Dans la zone Base de données, entrez le nom de la base de données. Cliquez sur Suivant.

  19. Dans la page Vérifiez le groupe BizTalk Server, vérifiez les informations que vous avez entrées, puis cliquez sur Suivant.

  20. Dans la page Fin de l'Assistant Installation des bases de données d'échanges Microsoft BizTalk Server 2000, cliquez sur Terminer.

  21. Ouvrez Administration de BizTalk Server.

  22. Développez Microsoft BizTalk Server 2000 et le groupe de serveurs contenant le serveur pour lequel vous venez de modifier la base de données Gestion d'échanges BizTalk, puis cliquez sur le serveur.

  23. Dans le menu Action, cliquez sur Démarrer.

Important

  • Utilisez cette procédure pour associer un serveur à une autre base de données Gestion d'échanges BizTalk. Pour plus d'informations sur le déplacement de serveurs entre les bases de données Gestion d'échanges BizTalk, voir Déplacement de serveurs entre les bases de données Gestion d'échanges BizTalk. Pour plus d'informations sur la modification de la base de données Gestion d'échanges BizTalk des groupes de serveurs, voir Modification de la base de données Gestion d'échanges BizTalk d'un serveur.

Voir aussi

Modification de la base de données Gestion d'échanges BizTalk

Gestion des bases de données BizTalk Server

Déplacement des serveurs entre les bases de données Gestion d'Échanges BizTalk


Exécution de serveurs dans un groupe

Les procédures suivantes permettent d'exécuter des serveurs dans un groupe :

  • Démarrage d'un serveur dans un groupe

  • Arrêt d'un serveur dans un groupe

  • Échanges libres à partir d'un serveur


Démarrage d'un serveur dans un groupe

  1. Dans Administration de BizTalk Server, développez Microsoft BizTalk Server 2000 et le groupe contenant le serveur que vous voulez démarrer, puis cliquez sur le serveur.

  2. Dans le menu Action, cliquez sur Démarrer.

Remarques

  • Lorsque vous démarrez un serveur dans un groupe de serveurs, le service d'Échanges BizTalk démarre sur le serveur. Une fois que le service d'Échanges BizTalk est en cours d'exécution, le serveur peut recevoir, transmettre, traiter et effectuer un suivi des documents mis en file d'attente sur les bases de données Microsoft SQL Server.

  • L'option Démarrer est disponible uniquement si le serveur est arrêté. S'il est en cours d'exécution, la commande n'est pas disponible.

Voir aussi

Ajout, suppression et configuration de serveurs dans un groupe

Cache d'administration

Groupes et serveurs

Arrêt d'un serveur dans un groupe


Arrêt d'un serveur dans un groupe

  1. Dans Administration de BizTalk Server, développez Microsoft BizTalk Server 2000 et le groupe de serveurs contenant le serveur que vous voulez arrêter, puis cliquez sur le serveur.

  2. Dans le menu Action, cliquez sur Arrêter.

Remarques

  • L'arrêt d'un serveur dans un groupe de serveurs implique l'arrêt du service d'Échanges BizTalk sur le serveur. Une fois que le service d'Échanges BizTalk est arrêté, le serveur ne peut recevoir, transmettre, traiter ni effectuer un suivi des documents qui sont mis en file d'attente sur les bases de données Microsoft SQL Server.

  • Si vous voulez redistribuer les échanges associés à un serveur que vous avez arrêté, voir Échanges libres à partir d'un serveur.

Voir aussi

Ajout, suppression et configuration de serveurs dans un groupe

Cache d'administration

Échanges libres à partir d'un serveur

Groupes et serveurs


Échanges libres à partir d'un serveur

Cette procédure est utilisée pour libérer des échanges d'un serveur afin qu'ils puissent être redistribués vers d'autres serveurs dans le groupe si le serveur initial est arrêté ou mis hors ligne.

  1. Dans Administration de BizTalk Server, développez Microsoft BizTalk Server 2000 et le groupe contenant le serveur sur lequel vous voulez libérer des échanges, puis cliquez sur le serveur.

  2. Dans le menu Action, cliquez sur Arrêter.

  3. Dans le menu Action, pointez sur Toutes les tâches, puis cliquez sur Échanges libres.

Voir aussi

Ajout, suppression et configuration de serveurs dans un groupe

Groupes et serveurs

Arrêt d'un serveur dans un groupe


Gestion des files d'attente

Cette section traite des procédures suivantes :

  • Déplacement de documents vers la file d'attente interrompue

  • Affichage des descriptions d'erreur

  • Affichage des échanges

  • Affichage des documents

  • Renvoi de documents

  • Suppression de documents


Déplacement de documents vers la file d'attente interrompue

  1. Dans Administration de BizTalk Server, développez successivement Microsoft BizTalk Server 2000, le groupe contenant le document à déplacer et les Files d'attente.

  2. Développez la file d'attente contenant le document que vous voulez déplacer, puis cliquez sur le document.

  3. Dans le menu Action, pointez sur Toutes les tâches, puis cliquez sur Déplacer vers la file interrompue.

Voir aussi

File d'attente interrompue

Utilisation des files d'attente


Affichage des descriptions d'erreur

  1. Dans Administration de BizTalk Server, développez successivement Microsoft BizTalk Server 2000, le groupe contenant le document à afficher et Files d'attente, puis cliquez sur File d'attente interrompue.

  2. Dans le volet de détails, cliquez sur le document que vous voulez afficher.

  3. Dans le menu Action, cliquez sur Afficher la description de l'erreur.

Voir aussi

File d'attente interrompue

Utilisation des files d'attente

Affichage des documents

Affichage des échanges


Affichage des échanges

  1. Dans Administration de BizTalk Server, développez successivement Microsoft BizTalk Server 2000, le groupe contenant l'échange à afficher et les Files d'attente, puis cliquez sur File d'attente interrompue.

  2. Dans le volet des détails, cliquez sur l'échange que vous voulez afficher.

  3. Dans le menu Action, cliquez sur Afficher l'échange.

    La boîte de dialogue Contenu de document s'affiche.

Remarques

  • Si vous affichez un échange important, les données peuvent être tronquées. Vous pouvez afficher jusqu'à 4 Mo de données dans la boîte de dialogue Contenu de document.

  • Si BizTalk Server n'est pas en mesure d'analyser l'échange, des données binaires peuvent apparaître dans la boîte de dialogue Contenu de document. Pour plus d'informations sur les erreurs d'analyse, voir Erreurs d'analyse.

  • L'option de menu Afficher l'échange est disponible pour les états suivants de file d'attente interrompue :
    • Composant personnalisé

    • Analyse

    • Codage

    • Signature

    • Cryptage

    • Transmission en cours
  • Les options Afficher l'échange et Afficher le document n'apparaissent jamais simultanément dans le menu Action.

Voir aussi

Un échange ou un document apparaît sous forme de données binaires dans la fille d'attente interrompue

File d'attente interrompue

Utilisation des files d'attente

Affichage des documents

Affichage des descriptions d'erreur


Affichage des documents

  1. Dans Administration de BizTalk Server, développez successivement Microsoft BizTalk Server 2000, le groupe contenant le document à afficher et Files d'attente, puis cliquez sur File d'attente interrompue.

  2. Dans le volet de détails, cliquez sur le document que vous voulez afficher.

  3. Dans le menu Action, cliquez sur Afficher le document.

    La boîte de dialogue Contenu de document s'affiche.

Remarques

  • Si vous essayez d'afficher un document volumineux, les données risquent d'être tronquées. Vous pouvez afficher jusqu'à 4 Mo de données dans la boîte de dialogue Contenu de document.

  • L'option de menu Afficher le document est disponible pour les états suivants de file d'attente interrompue :
    • Validation du document

    • Sélection du canal

    • Mappage

    • Corrélation

    • Sérialisation
  • Les options Afficher l'échange et Afficher le document n'apparaissent jamais simultanément dans le menu Action.

Voir aussi

Un échange ou un document apparaît sous forme de données binaires dans la fille d'attente interrompue

File d'attente interrompue

Utilisation des files d'attente

Affichage des descriptions d'erreur

Affichage des échanges


Renvoi de documents

  1. Dans Administration de BizTalk Server, développez successivement Microsoft BizTalk Server 2000, le groupe contenant le document à renvoyer et les Files d'attente, puis cliquez sur File d'attente interrompue.

  2. Dans le volet de détails, cliquez sur le document que vous voulez renvoyer.

  3. Dans le menu Action, pointez sur Toutes les tâches, puis cliquez sur Soumettre à nouveau.

Remarques

  • Cette procédure, destinée à renvoyer des documents, peut également être utilisée pour retransmettre des documents.

  • Tous les documents de la file d'attente interrompue ne peuvent pas être renvoyés. Dans certains cas, vous devez supprimer le document puis le renvoyer depuis l'application ou l'organisation d'origine. Pour plus d'informations sur la base de données Files d'attente partagées, voir Base de données Files d'attente partagées.

Voir aussi

File d'attente interrompue

Utilisation des files d'attente


Suppression de documents

  1. Dans Administration de BizTalk Server, développez successivement Microsoft BizTalk Server 2000, le groupe contenant le document à supprimer et les Files d'attente, puis cliquez sur File d'attente interrompue.

  2. Dans le volet de détails, cliquez sur le document que vous voulez supprimer.

  3. Dans le menu Action, cliquez sur Supprimer.

    La boîte de dialogue Confirmation de l'action utilisateur s'affiche.

  4. Cliquez sur Oui.

Voir aussi

File d'attente interrompue

Utilisation des files d'attente


Gestion des bases de données d'un groupe de serveurs

Les procédures suivantes permettent de gérer des bases de données pour un groupe de serveurs :

  • Arrêt de l'application Échange BizTalk Server

  • Suppression des bases de données de suivi et de files d'attente partagées

  • Restauration manuelle de la base de données de suivi

  • Restauration manuelle de la base de données de files d'attente partagée


Arrêt de l'application Échange BizTalk Server

  1. Dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration puis sur Services de composant.

  2. Développez successivement Services de composant, Ordinateurs, Poste de travail et Applications COM+.

  3. Cliquez sur l'application Échange BizTalk Server

  4. Dans le menu Action, cliquez sur Fermer.

Remarque

  • Vous pouvez fermer l'application Échange BizTalk Server à partir d'un serveur distant. Auquel cas, développez <remotecomputername> au lieu de Poste de travail à l'étape 1.

Voir aussi

Cache d'administration

Configuration des propriétés de connexion d'un groupe de serveurs

Configuration des propriétés de suivi d'un groupe de serveurs

Groupes et serveurs

Ouverture des services de composant

Base de données de suivi


Suppression des bases de données de suivi et de files d'attente partagées

  1. Dans le menu Démarrer, pointez sur Programmes et sur Microsoft SQL Server, puis cliquez sur Enterprise Manager.

  2. Développez Serveurs Microsoft SQL, Groupe SQL Server, ainsi que le serveur contenant les bases de données à supprimer.

  3. Développez le dossier Bases de données, puis cliquez sur la base de données que vous voulez supprimer.

  4. Dans le menu Action, cliquez sur Supprimer.

    La boîte de dialogue Suppression d'une base de données s'affiche.

  5. Cliquez sur Oui.

Remarque

  • Le nom par défaut de la base de données de suivi est "InterchangeDTA". Le nom par défaut de la base de données de files d'attente partagée est "InterchangeDTA".

Voir aussi

Groupes et serveurs

Base de données de files d'attente partagée

Arrêt d'un serveur dans un groupe

Base de données de suivi


Restauration manuelle de la base de données de suivi

  1. Dans le menu Démarrer, pointez sur Programmes et sur Microsoft SQL Server, puis cliquez sur Enterprise Manager.

  2. Développez Serveurs Microsoft SQL, Groupe SQL Server, ainsi que le serveur sur lequel vous voulez restaurer la base de données.

  3. Cliquez sur Bases de données.

  4. Dans le menu Action, cliquez sur Nouvelle base de données.

    La boîte de dialogue Propriétés de la base de données s'affiche.

  5. Dans la zone Nom de l'onglet Général, entrez un nom pour la base de données de suivi, puis cliquez sur OK.

  6. Dans le menu Démarrer, pointez sur Programmes et sur Microsoft SQL Server, puis cliquez sur Analyseur de requêtes.

    La boîte de dialogue Connexion à SQL Server s'affiche.

  7. Cliquez sur OK.

  8. Si vous disposez de Microsoft SQL Server 7.0, sélectionnez la fenêtre Requête, puis dans la liste des bases de données, cliquez sur le nom de la nouvelle base de données de suivi.

    —Ou—

    Si vous disposez de Microsoft SQL Server 2000, cliquez sur l'onglet Objets, puis sélectionnez le nom de la nouvelle base de données de suivi.

  9. Cliquez sur le bouton Charger le script SQL Load SQL Script button.

  10. Accédez à \Program Files\Microsoft BizTalk Server\Setup.

  11. Cliquez sur BTS_Tracking_Schema.sql, puis cliquez sur Ouvrir.

  12. Cliquez sur le bouton Exécuter la requête.

  13. Cliquez sur le bouton Charger un script SQL.

  14. Vérifiez que vous êtes bien dans le dossier \Program Files\Microsoft BizTalk Server\Setup.

  15. Cliquez sur BTS_Reporting.sql, puis sur le bouton Ouvrir.

  16. Cliquez sur le bouton Exécuter la requête.

  17. Cliquez sur le bouton Charger un script SQL.

  18. Vérifiez que vous êtes bien dans le dossier \Program Files\Microsoft BizTalk Server\Setup.

  19. Cliquez sur BTS_Tracking_Logic.sql, puis sur le bouton Ouvrir.

  20. Cliquez sur le bouton Exécuter la requête.

  21. Cliquez sur le bouton Charger un script SQL.

  22. Vérifiez que vous êtes bien dans le dossier \Program Files\Microsoft BizTalk Server\Setup.

  23. Cliquez sur BTS_WorkflowEvents.sql, puis sur le bouton Ouvrir.

  24. Cliquez sur le bouton Exécuter la requête.

  25. Cliquez sur le bouton Charger un script SQL.

  26. Vérifiez que vous êtes bien dans le dossier \Program Files\Microsoft BizTalk Server\Setup.

  27. Cliquez sur BTS_WorkflowSchema.sql, puis sur le bouton Ouvrir.

  28. Cliquez sur le bouton Exécuter la requête.

  29. Fermez l'Analyseur de requêtes SQL ainsi que SQL Server Enterprise Manager.

Attention

  • Lorsque vous restaurez manuellement la base de données de suivi, vous perdez toutes les données. Si vous devez conserver ces données, faites-en une copie de sauvegarde avant de restaurer la base de données de suivi.

Remarque

  • Utilisez cette procédure si la base de données de suivi est corrompue ou endommagée.

Voir aussi

Restauration manuelle de la base de données de files d'attente partagée


Restauration manuelle de la base de données de files d'attente partagée

  1. Dans le menu Démarrer, pointez sur Programmes et sur Microsoft SQL Server, puis cliquez sur Enterprise Manager.

  2. Développez Serveurs Microsoft SQL, Groupe SQL Server, ainsi que le serveur sur lequel vous voulez restaurer la base de données.

  3. Cliquez sur Bases de données.

  4. Dans le menu Action, cliquez sur Nouvelle base de données.

    La boîte de dialogue Propriétés de la base de données s'affiche.

  5. Dans la zone Nom de l'onglet Général, entrez un nom pour la base de données partagée, puis cliquez sur OK.

  6. Dans le menu Démarrer, pointez sur Programmes et sur Microsoft SQL Server, puis cliquez sur Analyseur de requêtes.

    La boîte de dialogue Connexion à SQL Server s'affiche.

  7. Cliquez sur OK.

  8. Si vous disposez de Microsoft SQL Server 7.0, sélectionnez la fenêtre Requête, puis dans la liste des bases de données, cliquez sur le nom de la nouvelle base de données de files d'attente partagée.

    —Ou—

    Si vous disposez de Microsoft SQL Server 2000, cliquez sur l'onglet Objets et sélectionnez le nom de la nouvelle base de données de files d'attente partagée.

  9. Cliquez sur le bouton Charger le script SQL Load SQL Script button.

  10. Accédez à \Program Files\Microsoft BizTalk Server\Setup.

  11. Cliquez sur BTS_Core_Schema.sql, puis sur le bouton Ouvrir.

  12. Cliquez sur le bouton Exécuter la requête.

  13. Cliquez sur le bouton Charger un script SQL.

  14. Vérifiez que vous êtes bien dans le dossier \Program Files\Microsoft BizTalk Server\Setup.

  15. Cliquez sur BTS_Core_Logic.sql, puis sur le bouton Ouvrir.

  16. Cliquez sur le bouton Exécuter la requête.

  17. Fermez l'Analyseur de requêtes SQL ainsi que SQL Server Enterprise Manager.

Attention

  • Lorsque vous restaurez manuellement la base de données de files d'attente partagée, vous perdez toutes les données. Si vous devez conserver ces données, faites-en une copie de sauvegarde avant de restaurer la base de données de files d'attente partagée.

Remarque

  • Utilisez cette procédure si la base de données de files d'attente partagée est corrompue ou endommagée.

Voir aussi

Restauration manuelle de la base de données de suivi


Gestion des fonctions de réception d'un groupe de serveurs

Les procédures suivantes permettent de gérer les fonctions de réception d'un groupe de serveurs :

  • Ajout d'une fonction de réception de fichier

  • Configuration d'une fonction de réception de fichier : Onglet Général

  • Configuration d'une fonction de réception de fichier : Onglet Services

  • Ajout d'une fonction de réception Message Queuing

  • Configuration d'une fonction de réception Message Queuing : Onglet Général

  • Configuration d'une fonction de réception Message Queuing : Onglet Services

  • Configuration des propriétés avancées des fonctions de réception de fichier et Message Queuing

  • Suppression d'une fonction de réception


Ajout d'une fonction de réception de fichier

  1. Dans Administration de BizTalk Server, développez Microsoft BizTalk Server 2000, puis cliquez sur le groupe de serveurs auquel vous voulez ajouter la fonction de réception de fichier.

  2. Cliquez sur Fonctions de réception.

  3. Dans le menu Action, pointez sur Nouveau, puis cliquez sur Fonction de réception de fichier.

    La boîte de dialogue Ajouter une fonction de réception de fichier s'affiche.

  4. Dans la zone Nom, entrez le nom de la fonction de réception de fichier.

  5. Dans la zone Commentaire, ajoutez éventuellement une brève description.

  6. Dans la liste Serveur sur lequel sera exécutée la fonction de réception, cliquez sur le nom d'un serveur du groupe.

  7. Dans la zone Types de fichiers à interroger, tapez l'extension des fichiers reçus par BizTalk Server.

    L'extension des types de fichiers doit respecter la syntaxe suivante :

    *.ext

    Exemple : *.xml

  8. Dans la zone Emplacement de l'interrogation, entrez le chemin logique ou le chemin UNC (Universal Naming Convention) vers le répertoire que cette fonction de réception utilise en tant qu'emplacement de la réception de fichier.

  9. Dans la liste Préprocesseur, cliquez sur le nom du préprocesseur personnalisé.

    Ne renseignez pas ce champ si vous n'utilisez pas de préprocesseur personnalisé.

  10. Dans les zones Nom d'utilisateur et Mot de passe, entrez un nom d'utilisateur et un mot de passe valides pour la connexion à l'emplacement de réception de fichier (facultatif).

    Ces informations sont requises uniquement si l'emplacement de réception est protégé et si la connexion au serveur requiert un nom d'utilisateur et un mot de passe valides.

  11. Pour personnaliser la fonction de réception de documents sans auto-routage ou pour spécifier des options openness ou directes, cliquez sur Avancé.

    Pour plus d'informations sur les options avancées, voir Configuration des propriétés avancées des fonctions de réception de fichier et Message Queuing.

Remarques

  • Cette procédure crée une fonction de réception de fichier avec les paramètres par défaut. Pour utiliser des paramètres supplémentaires pour la configuration de la fonction de réception, voir Configuration d'une fonction de réception de fichier : Onglet Général

  • Si vous voulez interroger plusieurs types de fichiers, utilisez n'importe quel format générique standard.

    Exemple : *.* or *.x?l

  • Si vous configurez une ou plusieurs fonctions de réception de fichier pour surveiller le même répertoire, utilisez des extensions de fichier à trois lettres. Si vous utilisez des extensions de fichier de plus de trois lettres, vérifiez que les trois premières lettres sont uniques.

    Exemple : *.xml, *.1xml, *.12xml

  • Les fonctions de réception de fichier ne traitent pas les fichiers en lecture seule.

  • Vérifiez que le nom de chaque fonction de réception créée est unique. Vous ne pouvez pas attribuer le même nom à plusieurs fonctions de réception.

Voir aussi

Fonctions de réception disponibles

Configuration des propriétés avancées des fonctions de réception de fichier et Message Queuing

Configuration d'une fonction de réception de fichier : Onglet Général

Configuration d'une fonction de réception de fichier : Onglet Services

Préprocesseurs personnalisés

Fonctions de réception


Configuration d'une fonction de réception de fichier : Onglet Général

  1. Dans Administration de BizTalk Server, développez successivement Microsoft BizTalk Server 2000, le groupe de serveurs pour lequel vous voulez configurer une fonction de réception de fichier et Fonctions de réception.

  2. Cliquez sur la fonction de réception que vous voulez configurer.

  3. Dans le menu Action, cliquez sur Propriétés.

    La boîte de dialogue Propriétés s'affiche.

  4. Dans la zone Commentaire, ajoutez éventuellement une brève description.

  5. Dans les champs Nom d'utilisateur et Mot de passe de la zone Sécurité, entrez un nom d'utilisateur et un mot de passe valides pour vous connecter à cette fonction de réception.

    Ces informations sont requises uniquement si l'emplacement de réception est protégé et si la connexion au serveur requiert un nom d'utilisateur et un mot de passe valides.

  6. Si vous voulez arrêter temporairement cette fonction de réception, activez la case à cocher Désactiver la fonction de réception, puis cliquez sur Oui pour confirmer votre choix.

Remarque

  • Les fonctions de réception de fichier ne traitent pas les fichiers en lecture seule.

Voir aussi

Configuration des propriétés avancées des fonctions de réception de fichier et Message Queuing

Configuration d'une fonction de réception de fichier : Onglet Services


Configuration d'une fonction de réception de fichier : Onglet Services

  1. Dans Administration de BizTalk Server, développez successivement Microsoft BizTalk Server 2000, le groupe de serveurs pour lequel vous voulez configurer une fonction de réception de fichier et Fonctions de réception.

  2. Cliquez sur la fonction de réception de fichier que vous voulez configurer.

  3. Dans le menu Action, cliquez sur Propriétés.

    La boîte de dialogue Propriétés s'affiche.

  4. Cliquez sur l'onglet Services.

  5. Dans la liste Serveur sur lequel sera exécutée la fonction de réception, cliquez sur le nom du serveur.

  6. Dans la zone Emplacement de l'interrogation, entrez le chemin logique ou le chemin UNC (Universal Naming Convention) vers le répertoire que cette fonction de réception utilise en tant qu'emplacement de la réception de fichier.

  7. Dans la zone Types de fichiers à interroger, tapez l'extension des fichiers reçus par BizTalk Server.

    L'extension des types de fichiers doit respecter la syntaxe suivante :

    *.ext

    Exemple : *.doc

  8. Dans la liste Préprocesseur, cliquez sur le nom du préprocesseur personnalisé.

    Ne renseignez pas ce champ si vous n'utilisez pas de préprocesseur personnalisé.

  9. Cliquez sur OK.

Remarque

  • Si vous voulez recevoir plusieurs types de fichiers, utilisez n'importe quel format avec les caractères génériques standard.

    Exemple : *.*

  • Si vous configurez une ou plusieurs fonctions de réception de fichier pour surveiller le même répertoire, utilisez des extensions de fichier à trois lettres. Si vous utilisez des extensions de fichier de plus de trois lettres, vérifiez que les trois premières lettres sont uniques.

    Exemple : *.xml, *.1xml, *.12xml

  • Les fonctions de réception de fichier ne traitent pas les fichiers en lecture seule.

Voir aussi

Fonctions de réception disponibles

Configuration des propriétés avancées des fonctions de réception de fichier et Message Queuing

Préprocesseurs personnalisés


Ajout d'une fonction de réception Message Queuing

  1. Dans Administration de BizTalk Server, développez successivement Microsoft BizTalk Server 2000, le groupe de serveurs auquel vous voulez ajouter une fonction de réception Message Queuing et Fonctions de réception.

  2. Cliquez sur Fonctions de réception.

  3. Dans le menu Action, pointez sur Nouveau, puis cliquez sur Fonction de réception Message Queuing.

    La boîte de dialogue Ajouter une fonction de réception Message Queuing s'affiche.

  4. Dans la zone Nom, entrez le nom de la fonction de réception Message Queuing.

  5. Dans la zone Commentaire, ajoutez éventuellement une brève description.

  6. Dans la liste Serveur sur lequel sera exécutée la fonction de réception, cliquez sur le nom d'un serveur du groupe.

  7. Dans la zone Emplacement de l'interrogation, tapez le nom du serveur et de Message Queuing que cette fonction de réception utilise en tant qu'emplacement de réception.

    Exemple :

    Direct=OS:<nom du serveur>\<nom de la file d'attente>

    Sélectionnez le serveur de traitement sur lequel la file d'attente réside. L'échange transactionnel est uniquement pris en charge par les files d'attente locales.

  8. Dans la liste Préprocesseur, cliquez sur le préprocesseur personnalisé.

    Ne renseignez pas ce champ si vous n'utilisez pas de préprocesseur personnalisé.

  9. Dans les zones Nom d'utilisateur et Mot de passe, tapez un nom d'utilisateur et un mot de passe valides pour la connexion à Message Queuing.

    Ces informations sont requises uniquement lorsque l'emplacement de réception ne se trouve pas sur le serveur qui traite les échanges et les documents.

  10. Pour personnaliser la fonction de réception de documents sans auto-routage ou pour spécifier des options openness ou directes, cliquez sur Avancé.

    Pour plus d'informations sur les options avancées, voir Configuration des propriétés avancées des fonctions de réception de fichier et Message Queuing.

Important

  • N'ajoutez pas le préfixe " file d'attente:// " à <nom du serveur>\<nom de la file d'attente> dans la zone Emplacement de l'interrogation. Ces propriétés sont différentes des propriétés générales d'un groupe de serveurs pour lequel vous ajoutez le préfixe "file d'attente://". Pour plus d'informations sur la syntaxe de Message Queuing, voir Fonctions de réception disponibles. Pour plus d'informations sur les propriétés d'un groupe de serveurs, voir Configuration des propriétés générales d'un groupe de serveurs.

Remarques

  • Pour plus d'informations sur le pré-traitement personnalisé, voir Préprocesseurs personnalisés.

  • Pour qu'une fonction de réception Message Queuing fonctionne, le mot de passe et le nom d'utilisateur fournis à BizTalk Server doivent vous accorder des autorisations en lecture sur la file d'attente.

  • Dans un souci de fiabilité, vous devez utiliser des files d'attente transactionnelles. Si vous utilisez des files d'attente non-transactionnelles, les messages risquent d'être perdus. Pour plus d'informations sur les files d'attente transactionnelles, accédez au site Web MSDN Online Library (msdn.microsoft.com/library/default.asp), puis effectuez une recherche sur les mots-clés "Message Queuing".

  • Vérifiez que le nom de chaque fonction de réception créée est unique. Vous ne pouvez pas attribuer le même nom à plusieurs fonctions de réception.

Voir aussi

Fonctions de réception disponibles

Configuration des propriétés avancées des fonctions de réception de fichier et Message Queuing

Configuration d'une fonction de réception Message Queuing : Onglet Général

Préprocesseurs personnalisés

Fonctions de réception


Configuration d'une fonction de réception Message Queuing : Onglet Général

  1. Dans Administration de BizTalk Server, développez successivement Microsoft BizTalk Server 2000, le groupe de serveurs pour lequel vous voulez configurer une fonction de réception Message Queuing et Fonctions de réception.

  2. Cliquez sur la fonction de réception Message Queuing que vous voulez configurer.

  3. Dans le menu Action, cliquez sur Propriétés.

    La boîte de dialogue Propriétés s'affiche.

  4. Dans la zone Commentaire, ajoutez éventuellement une brève description.

  5. Dans les champs Nom d'utilisateur et Mot de passe de la zone Sécurité, entrez un mot de passe et un nom d'utilisateur valides pour vous connecter à la file d'attente de messages.

    Ces informations sont requises uniquement lorsque l'emplacement de réception ne se trouve pas sur le serveur de traitement.

  6. Si vous voulez arrêter temporairement cette fonction de réception, activez la case à cocher Désactiver la fonction de réception, puis cliquez sur Oui pour confirmer votre choix.

Voir aussi

Configuration d'une fonction de réception Message Queuing : Onglet Services

Fonctions de réception


Configuration d'une fonction de réception Message Queuing : Onglet Services

  1. Dans Administration de BizTalk Server, développez successivement Microsoft BizTalk Server 2000, le groupe de serveurs pour lequel vous voulez configurer une fonction de réception Message Queuing et Fonctions de réception.

  2. Cliquez sur la fonction de réception Message Queuing que vous voulez configurer.

  3. Dans le menu Action, cliquez sur Propriétés.

    La boîte de dialogue Propriétés s'affiche.

  4. Cliquez sur l'onglet Services.

  5. Dans la liste Serveur sur lequel sera exécutée la fonction de réception, cliquez sur le nom du serveur.

  6. Dans la zone Emplacement de l'interrogation, tapez le nom du serveur et de Message Queuing que cette fonction de réception utilise en tant qu'emplacement de réception.

    Exemple :

    Direct=OS:<nom du serveur>\<nom de la file d'attente>

  7. Dans la liste Préprocesseur, cliquez sur le préprocesseur personnalisé.

    Ne renseignez pas ce champ si vous n'utilisez aucun préprocesseur personnalisé.

  8. Cliquez sur OK.

Important

  • N'ajoutez pas le préfixe " file d'attente:// " à <nom du serveur>\<nom de la file d'attente> dans la zone Emplacement de l'interrogation. Ces propriétés sont différentes des propriétés générales d'un groupe de serveurs pour lequel vous ajoutez le préfixe "file d'attente://". Pour plus d'informations sur la syntaxe de Message Queuing, voir Fonctions de réception disponibles. Pour plus d'informations sur les propriétés d'un groupe de serveurs, voir Configuration des propriétés générales d'un groupe de serveurs.

Remarque

  • Pour plus d'informations sur le pré-traitement personnalisé, voir Préprocesseurs personnalisés.

Voir aussi

Fonctions de réception disponibles

Configuration des propriétés générales d'un groupe de serveurs

Préprocesseurs personnalisés


Configuration des propriétés avancées des fonctions de réception de fichier et Message Queuing

  1. Dans Administration de BizTalk Server, développez Microsoft BizTalk Server 2000 et le groupe de serveurs pour lequel vous voulez configurer une fonction de réception, puis cliquez sur la fonction de réception.

  2. Dans le menu Action, cliquez sur Propriétés.

    La boîte de dialogue Propriétés s'affiche.

  3. Cliquez sur l'onglet Avancé.

  4. Dans la liste Propriétés Openness, vous pouvez sélectionner :
    • Non ouvert : cliquez sur cette option lorsque la source et la destination sont déclarées explicitement dans la fonction de réception ou dans l'instance de document et lorsque BizTalk Server ne doit pas analyser le document pour vérifier ces informations.

    • Destination ouverte : cliquez sur cette option lorsque les informations de destination ne sont pas déclarées explicitement dans le port d'échanges. La destination est spécifiée dynamiquement dans l'instance de document ou dans un paramètre d'envoi.

    • Source ouverte : cliquez sur cette option lorsque les informations de la source ne sont pas explicitement déclarées dans le canal. La source est spécifiée dynamiquement dans l'instance de document ou dans un paramètre d'envoi.
  5. Si vous voulez ignorer les traitements tels que le décodage, le décryptage, la vérification de la signature et l'analyse, et soumettre uniquement un échange, activez la case à cocher Soumettre avec un indicateur direct.

    Vous devez sélectionner un canal si vous activez la case à cocher Soumettre avec un indicateur direct.

  6. Dans la liste Nom d'enveloppe, cliquez sur le nom d'une définition d'enveloppe.

    Choisissez une enveloppe si vous pensez recevoir des tables bidimensionnelles. Dans le cas contraire, ne renseignez pas ce champ.

  7. Dans la liste Nom du canal, cliquez sur le nom d'un canal.

  8. Dans la liste Nom de la définition de document, cliquez sur le nom d'une définition de document.

  9. Dans la zone Source et destination, cliquez sur Parcourir dans la zone Source sélectionnée.

    La boîte de dialogue Sélectionner la source apparaît.

  10. Dans la liste Qualificateur de l'organisation, cliquez sur le type de qualificateur de l'organisation source.

  11. Dans la liste Valeur de l'identificateur d'organisation, cliquez sur la valeur de l'identificateur de l'organisation source, puis cliquez sur OK.

  12. Dans la zone Source et destination, cliquez sur Parcourir dans la zone Destination sélectionnée.

    La boîte de dialogue Sélectionner la destination s'affiche.

  13. Dans la liste Qualificateur de l'organisation, cliquez sur le type de qualificateur de l'organisation de destination.

    Si vous envoyez des documents à une liste de distribution, dans la liste Qualificateur de l'organisation, vous devez choisir Groupe.

  14. Dans la liste Valeur de l'identificateur d'organisation, cliquez sur la valeur de l'identificateur d'organisation de destination, puis cliquez sur OK.

  15. Cliquez sur OK.

Important

  • Vous devez créer les objets présentés ci-après pour pouvoir les affecter comme propriétés avancées d'une fonction de réception. Ces objets sont créés soit dans le Gestionnaire d'échanges BizTalk, soit en mode programmation, et sont stockés dans la base de données Gestion d'échanges BizTalk.
    • Enveloppes

    • Canaux

    • Définitions de document

    • Qualificateurs source

    • Valeurs de l'identificateur d'organisation source

    • Qualificateurs de destination

    • Valeurs de l'identificateur d'organisation de destination

Remarques

  • Si vous cliquez sur Source ouverte ou Destination ouverte dans la liste Propriété Openness, la case à cocher Soumettre avec un indicateur direct n'est pas disponible.

  • Si vous voulez envoyer un document à une liste de distribution, vous devez sélectionner Groupe dans la liste Qualificateur de l'organisation de la boîte de dialogue Sélectionner la destination.

  • Toutes les propriétés avancées des fonctions de réception sont facultatives ; vous ne devez pas nécessairement les définir. Pour plus d'informations sur l'envoi de documents, voir Routage ou Description des fonctions de réception et du routage de documents.

  • Si la case à cocher Soumettre avec un indicateur direct est activée, seule la liste Canal est disponible.

  • Lorsque vous envoyez directement des documents, les fonctions d'analyse, de décryptage et de décodage de BizTalk Server 2000 ne sont pas utilisées. Pour plus d'informations sur l'envoi de documents avec l'indicateur direct, voir Description des propriétés avancées d'une fonction de réception. Pour plus d'informations sur l'envoi de documents, voir Envoi.

Voir aussi

Fonctions de réception

Routage

Envoi

Description des propriétés avancées d'une fonction de réception

Description des fonctions de réception et du routage de documents


Suppression d'une fonction de réception

  1. Dans Administration de BizTalk Server, développez successivement Microsoft BizTalk Server 2000, le groupe de serveurs dans lequel vous voulez supprimer une fonction de réception et Fonctions de réception.

  2. Cliquez sur le groupe que vous voulez supprimer.

  3. Dans le menu Action, cliquez sur Supprimer.

    La boîte de dialogue Confirmation de l'action utilisateur s'affiche.

  4. Cliquez sur Oui.

Voir aussi

Fonctions de réception


Gestion de l'Observateur d'événements

Vous pouvez utiliser l'Observateur d'événement inclus dans Administration de BizTalk Server pour faciliter la résolution des problèmes liés au serveur et au traitement des documents. L'Observateur d'événements apparaît dans l'arborescence de la console d'administration de BizTalk Server. Toutes les erreurs d'application de BizTalk Server 2000 sont considérées comme des erreurs de BizTalk Server. Toutes les erreurs de planification XLANG sont considérées comme des erreurs de XLANG Scheduler.

Les procédures suivantes sont utilisées pour gérer l'Observateur d'événements :

  • Configuration de l'Observateur d'événements pour les erreurs de BizTalk Server

  • Affichage des erreurs d'application dans l'Observateur d'événements


Configuration de l'Observateur d'événements pour les erreurs de BizTalk Server

  1. Dans BizTalk Server Administration, développez Observateur d'événements.

  2. Cliquez sur Application.

  3. Dans le menu Action, cliquez sur Propriétés.

    La boîte de dialogue Propriétés d'application s'affiche.

  4. Cliquez sur l'onglet Filtre.

  5. Dans la liste Source d'événements, cliquez sur l'une des options suivantes :
    • BizTalk Server : filtre les sources d'événements des messages d'erreur liés aux services d'Échanges BizTalk.

    • XLANG Scheduler : filtre les sources d'événements des messages d'erreur liés aux services d'orchestration BizTalk.
  6. Cliquez sur OK pour fermer la boîte de dialogue Propriétés d'application.


Affichage des erreurs d'application dans l'Observateur d'événements

  1. Dans BizTalk Server Administration, développez Observateur d'événements.

  2. Cliquez sur Application.

    Les messages d'erreur d'application figurent dans le volet de détails.

  3. Cliquez sur un message dans la liste.

  4. Dans le menu Action, cliquez sur Propriétés.

Remarque

  • Cette procédure implique que vous ayez configuré l'Observateur d'événements pour qu'il affiche uniquement les messages d'erreur de BizTalk Server et de XLANG Scheduler. Pour plus d'informations sur l'affichage des erreurs de BizTalk Server et de XLANG Scheduler, voir Configuration de l'Observateur d'événements pour les erreurs de BizTalk Server.

Voir aussi

Configuration de l'Observateur d'événements pour les erreurs de BizTalk Server


Gestion des applications et des bases de données XLANG

Cette section fournit des informations sur la gestion des applications COM+ qui hébergent des planifications XLANG. Elle inclut également des informations sur la gestion de l'application XLANG Scheduler et de la base de données de persistance d'orchestration par défaut, lesquelles sont créées lorsque vous installez BizTalk Server 2000.

BizTalk Server 2000 propose une application COM+ appelée programme d'assistance XLANG Scheduler Persistence Helper, utilisée avec toutes les applications COM+ qui hébergent des instances de planification XLANG. Vous ne pouvez absolument pas modifier la configuration du programme d'assistance XLANG Scheduler Persistence Helper une fois l'installation terminée.

Cette section traite des procédures suivantes :

  • Gestion de l'application et de la base de données XLANG Scheduler par défaut

  • Gestion des autres applications COM+ hébergeant des planifications XLANG

  • Surveillance de l'exécution des planifications XLANG

Remarques

  • Pour plus d'informations sur Microsoft SQL Server, dans le menu Démarrer, pointez sur Programmes et sur Microsoft SQL Server, puis cliquez sur Documentation en ligne.

  • Pour accéder à l'aide de l'administration des services de composant, dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration puis sur Services de composant. Dans l'arborescence de la console, cliquez avec le bouton droit sur Services de composant, puis cliquez sur Aide.

  • Pour plus d'informations sur les services de composants et COM+, accédez au site Web MSDN Online Library (msdn.microsoft.com/library/default.asp), puis parcourez la plate-forme SDK jusqu'aux services de composant.

Voir aussi

Exécution des planifications XLANG

Exécuter les planifications XLANG


Gestion de l'application et de la base de données XLANG Scheduler par défaut

La base de données de persistance d'orchestration et l'application XLANG Scheduler par défaut sont créées durant l'installation de BizTalk Server 2000. Sur les systèmes de production ou les systèmes exécutant Microsoft Terminal Server, vous devez modifier les paramètres par défaut de cette application et de cette base de données. Vous pouvez également créer de nouvelles applications COM+ en vue d'héberger des instances de planification XLANG et de nouvelles bases de données de persistance pour stocker les informations relatives à l'état de la planification XLANG.

Pour plus d'informations sur la création d'une application COM+ en vue d'héberger des instances de planification XLANG, voir Création d'une application COM+ pour héberger des planifications XLANG.

Pour plus d'informations sur la sécurité et les performances liées à la modification des paramètres par défaut de l'application XLANG Scheduler par défaut, voir Sécurité des applications hébergeant des instances de planification XLANG.

Cette section traite des procédures suivantes :

  • Configuration de l'application XLANG Scheduler par défaut

  • Modification de l'identité de l'application XLANG Scheduler par défaut

  • Modification des paramètres de la base de données de persistance d'orchestration par défaut

  • Arrêt de toutes les applications XLANG

  • Redémarrage de toutes les applications XLANG

  • Remarques

  • Pour plus d'informations sur Microsoft SQL Server, dans le menu Démarrer, pointez sur Programmes et sur Microsoft SQL Server, puis cliquez sur Documentation en ligne.

  • Pour accéder à l'aide de l'administration des services de composant, dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration puis sur Services de composant. Dans l'arborescence de la console, cliquez avec le bouton droit sur Services de composant, puis cliquez sur Aide.

  • Pour plus d'informations sur les services de composants et COM+, accédez au site Web MSDN Online Library (msdn.microsoft.com/library/default.asp), puis parcourez la plate-forme SDK jusqu'aux services de composant.

Voir aussi

Exécution des planifications XLANG

Exécuter les planifications XLANG


Configuration de l'application XLANG Scheduler par défaut

La base de données de persistance d'orchestration et l'application XLANG Scheduler par défaut sont créées durant l'installation de BizTalk Server 2000. Sur des systèmes de production ou des systèmes exécutant Microsoft Terminal Server, vous devez modifier les paramètres par défaut de cette application et de cette base de données. Vous pouvez également créer de nouvelles applications COM+ en vue d'héberger des instances de planification XLANG et de nouvelles bases de données de persistance pour stocker les informations relatives à l'état de la planification XLANG.

Pour plus d'informations sur la création d'une application COM+ en vue d'héberger des instances de planification XLANG, voir Création d'une application COM+ pour héberger des planifications XLANG.

Pour plus d'informations sur la sécurité et les performances liées à la modification des paramètres par défaut de l'application XLANG Scheduler par défaut, voir Sécurité des applications hébergeant des instances de planification XLANG.

  1. Dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration et sur Services de composants.

  2. Dans l'arborescence de la console, développez successivement Services de composant, Ordinateurs, Poste de travail et Applications COM+.

  3. Cliquez sur XLANG Scheduler. Dans le menu Action, cliquez sur Propriétés.

  4. Il est vivement conseillé de modifier l'identité de l'application XLANG Scheduler par défaut, plus particulièrement sur les systèmes de production ou les systèmes exécutant Microsoft Terminal Server. Pour plus d'informations, voir Modification de l'identité de l'application XLANG Scheduler par défaut

  5. Il est vivement recommandé de modifier les paramètres par défaut de la base de données de persistance d'orchestration. Pour plus d'informations, voir Modification des paramètres de la base de données de persistance d'orchestration par défaut.

Remarques

  • Le nom de la source de données (DSN) et de l'application COM+ doivent être similaires. Par exemple, si l'application COM+ hébergeant le moteur de XLANG Scheduler porte le nom XLANG Scheduler, le DSN doit également porter le nom XLANG Scheduler.

  • Pour accéder à l'aide de l'administration des services de composant, dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration puis sur Services de composant. Dans l'arborescence de la console, cliquez avec le bouton droit sur Services de composant, puis cliquez sur Aide.

  • Pour plus d'informations sur les services de composants et COM+, accédez au site Web MSDN Online Library (msdn.microsoft.com/library/default.asp), puis parcourez la plate-forme SDK jusqu'aux services de composant.

Voir aussi

Modification de l'identité de l'application XLANG Scheduler par défaut

Modification des paramètres DSN d'une application COM+

Modification des paramètres de la base de données de persistance d'orchestration par défaut

Création d'une base de données de persistance

Création d'une application d'instanciation

Redémarrage de toutes les applications XLANG

Exécution des planifications XLANG

Exécuter les planifications XLANG

Arrêt de toutes les applications XLANG


Modification de l'identité de l'application XLANG Scheduler par défaut

Il est conseillé de remplacer le compte utilisateur interactif par défaut de l'application XLANG Scheduler par défaut par un compte de services.

Pour plus d'informations sur la sécurité et les performances liées à la modification des paramètres par défaut de l'application XLANG Scheduler par défaut, voir Sécurité des applications hébergeant des instances de planification XLANG.

  1. Dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration et sur Services de composants.

  2. Dans l'arborescence de la console, développez successivement Services de composant, Ordinateurs, Poste de travail et Applications COM+.

  3. Cliquez sur XLANG Scheduler. Dans le menu Action, cliquez sur Propriétés.

  4. Dans la zone Autorisation de l'onglet Avancé, désactivez la case à cocher Désactiver les modifications, puis cliquez sur OK.

    Le message suivant s'affiche : Les applications ont été créées par un ou plusieurs produits externes. Êtes-vous sûr que les modifications que vous allez effectuer sont prises en charge par ces produits ?

  5. Cliquez sur Oui.

    La boîte de dialogue Propriétés de XLANG Scheduler apparaît.

  6. Cliquez sur XLANG Scheduler. Dans le menu Action, cliquez sur Propriétés.

  7. Dans la zone Compte de l'onglet Identité, cliquez sur Cet utilisateur.

  8. Entrez les informations du compte que vous voulez utiliser.

  9. Cliquez sur OK.

    Le message suivant s'affiche : Les applications ont été créées par un ou plusieurs produits externes. Êtes-vous sûr que les modifications que vous allez effectuer sont prises en charge par ces produits ?

  10. Cliquez sur Oui.

Remarques

  • Pour accéder à l'aide de l'administration des services de composant, dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration puis sur Services de composant. Dans l'arborescence de la console, cliquez avec le bouton droit sur Services de composant, puis cliquez sur Aide.

  • Pour plus d'informations sur les services de composants et COM+, accédez au site Web MSDN Online Library (msdn.microsoft.com/library/default.asp), puis parcourez la plate-forme SDK jusqu'aux services de composant.

Voir aussi

Modification des paramètres de la base de données de persistance d'orchestration par défaut

Configuration de l'application XLANG Scheduler par défaut

Exécution des planifications XLANG

Exécuter les planifications XLANG

Sécurité des application hébergeant des instances de planification XLANG


Modification des paramètres de la base de données de persistance d'orchestration par défaut

Lorsque vous installez BizTalk Server 2000, la base de données de persistance d'orchestration est configurée avec les paramètres par défaut. Vous pouvez les modifier afin d'utiliser une configuration adaptée au système que vous exécutez.

  1. Dans le menu Démarrer, pointez sur Programmes et sur Microsoft SQL Server, puis cliquez sur Enterprise Manager.

  2. Développez successivement Serveurs Microsoft SQL, Groupe SQL Server, le serveur contenant la base de données par défaut, puis Bases de données.

  3. Cliquez sur XLANG Scheduler. Dans le menu Action, cliquez sur Propriétés.

  4. Vous pouvez définir les différentes propriétés de la base de données par le biais des six onglets suivants :
    • Général

    • Fichiers de données

    • Journal des transactions

    • Groupes de fichiers

    • Options

    • Autorisations

Pour plus d'informations sur la configuration de bases de données dans Microsoft SQL Server, reportez-vous à la documentation en ligne de Microsoft SQL Server.

Important

  • Cette procédure implique que vous ayez utilisé le nom XLANG pour la configuration de la base de données par défaut.

Remarques

  • La base de données principale et les fichiers journaux de transactions sont créés avec un préfixe correspondant au nom de la base de données. Par exemple, LANGdb_Data.mdf et XLANGdb_Log.ldf. Le fichier principal contient les tables système de la base de données.

  • La taille maximale de la base de données est déterminée en fonction de l'espace disponible sur le disque et des limites dues à la licence de la version de Microsoft SQL Server que vous utilisez.

  • Le nom d'objet de la base de données d'orchestration par défaut est XLANG. Vous pouvez modifier ce nom durant l'installation.

  • Pour plus d'informations sur Microsoft SQL Server, dans le menu Démarrer, pointez sur Programmes et sur Microsoft SQL Server, puis cliquez sur Documentation en ligne.

Voir aussi

Modification de l'identité de l'application XLANG Scheduler par défaut

Configuration de l'application XLANG Scheduler par défaut

Exécution des planifications XLANG

Exécuter les planifications XLANG

Sécurité des application hébergeant des instances de planification XLANG


Arrêt de toutes les applications XLANG

  1. Dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration puis sur Services de composant.

  2. Dans l'arborescence de la console, développez successivement Services de composant, Ordinateurs, Poste de travail et Applications COM+.

  3. Cliquez sur XLANG Scheduler. Dans le menu Action, cliquez sur Propriétés.

  4. Dans la zone Arrêt contrôlé de l'onglet XLANG, cliquez sur Toutes les applications XLANG.

Attention

  • Vous devez suivre cette procédure pour exécuter un arrêt contrôlé de toutes les applications COM+. Vous enregistrez ainsi l'état de toutes les planifications XLANG en cours d'exécution dans la base de données de persistance. Pour plus d'informations, voir Persistance.

    Ne cliquez pas avec le bouton droit sur une application COM+, mais cliquez sur Arrêter. L'une des actions suivantes peut se produire :

    • Si les planifications XLANG en cours sont entièrement transactionnelles, un arrêt non contrôlé provoque l'abandon de toutes les transactions en cours d'exécution.

    • Si les planifications XLANG en cours d'exécution ne sont pas entièrement transactionnelles, les données traitées dans la planification sont perdues.

Important

  • Vous ne pouvez pas redémarrer des planifications XLANG mises en attente si le nom de la source de données (DSN) n'est pas disponible ou n'est pas configuré correctement. Pour plus d'informations sur la configuration d'un DSN lié à l'application XLANG Scheduler par défaut, voir Configuration de l'application XLANG Scheduler par défaut.

Remarques

  • Pour accéder à l'aide de l'administration des services de composant, dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration puis sur Services de composant. Dans l'arborescence de la console, cliquez avec le bouton droit sur Services de composant, puis cliquez sur Aide.

  • Pour plus d'informations sur les services de composants et COM+, accédez au site Web MSDN Online Library ( msdn.microsoft.com/library/default.asp ), puis parcourez la plate-forme SDK jusqu'aux services de composant.

Voir aussi

Configuration de l'application XLANG Scheduler par défaut

Redémarrage de toutes les applications XLANG

Exécution des planifications XLANG

Exécuter les planifications XLANG

Arrêt d'une application COM+ hébergeant des planifications XLANG


Redémarrage de toutes les applications XLANG

  1. Dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration et sur Services de composants.

  2. Dans l'arborescence de la console, développez successivement Services de composant, Ordinateurs, Poste de travail et Applications COM+.

  3. Cliquez sur XLANG Scheduler. Dans le menu Action, cliquez sur Propriétés.

  4. Dans la zone Redémarrer les applications XLANG mises en attente de l'onglet XLANG, cliquez sur Toutes les applications XLANG.

Important

  • Vous ne pouvez pas redémarrer des planifications XLANG mises en attente si le nom de la source de données (DSN) n'est pas disponible ou n'est pas configuré correctement. Pour plus d'informations sur la configuration d'un DSN lié à l'application XLANG Scheduler par défaut, voir Configuration de l'application XLANG Scheduler par défaut.

  • Lorsque vous redémarrez des applications mises en attente, celles-ci sont réalimentées de manière asynchrone. La procédure de réalimentation n'est pas immédiate. Utilisez l'Observateur d'événements XLANG pour déterminer la fin du processus de réalimentation. Pour plus d'informations sur l'outil Observateur d'événements XLANG, reportez-vous au fichier Readme.htm correspondant. L'Observateur d'événements XLANG (XLANGMon.exe) et le fichier Lisezmoi installés par l'Assistant Installation de Microsoft BizTalk Server 2000 se trouvent dans le répertoire d'installation suivant : \Program Files\Microsoft BizTalk Server\SDK\Outils XLANG.

Remarques

  • Pour accéder à l'aide de l'administration des services de composant, dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration puis sur Services de composant. Dans l'arborescence de la console, cliquez avec le bouton droit sur Services de composant, puis cliquez sur Aide.

  • Pour plus d'informations sur les services de composants et COM+, accédez au site Web MSDN Online Library (msdn.microsoft.com/library/default.asp), puis parcourez la plate-forme SDK jusqu'aux services de composant.

Voir aussi

Configuration de l'application XLANG Scheduler par défaut

Exécution des planifications XLANG

Exécuter les planifications XLANG

Arrêt d'une application COM+ hébergeant des planifications XLANG

Arrêt de toutes les applications XLANG


Gestion des autres applications COM+ hébergeant des planifications XLANG

La plupart des applications COM+ hébergeant des planifications XLANG doivent être créées lorsque la planification XLANG est développée. Vous devez prendre en compte les besoins des applications et des planifications en termes de sécurité et de performances, et vous pouvez créer des applications COM+ spécifiques pour exécuter des planifications spécifiques. Pour plus d'informations, voir Exécuter les planifications XLANG et Exécution des planifications XLANG.

Cette section traite des procédures suivantes :

  • Création d'une base de données de persistance

  • Modification de l'identité d'une application COM+

  • Modification des paramètres DSN d'une application COM+

  • Arrêt d'une application COM+ hébergeant des planifications XLANG

Remarques

  • Pour plus d'informations sur Microsoft SQL Server, dans le menu Démarrer, pointez sur Programmes et sur Microsoft SQL Server, puis cliquez sur Documentation en ligne.

  • Pour accéder à l'aide de l'administration des services de composant, dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration puis sur Services de composant. Dans l'arborescence de la console, cliquez avec le bouton droit sur Services de composant, puis cliquez sur Aide.

  • Pour plus d'informations sur les services de composants et COM+, accédez au site Web MSDN Online Library (msdn.microsoft.com/library/default.asp), puis parcourez la plate-forme SDK jusqu'aux services de composant.

Voir aussi

Exécution des planifications XLANG

Exécuter les planifications XLANG


Création d'une base de données de persistance

  1. Dans le menu Démarrer, pointez sur Programmes et sur Microsoft SQL Server, puis cliquez sur Enterprise Manager.

  2. Développez successivement Serveurs Microsoft SQL, Groupe SQL Server, le serveur auquel vous voulez ajouter une nouvelle base de données, puis Base de données.

  3. Cliquez sur Bases de données. Dans le menu Action, cliquez sur Nouvelle base de données.

  4. Dans la zone Nom de l'onglet Général, entrez le nom de la nouvelle base de données, puis cliquez sur OK.

    Une nouvelle base de données est créée avec les valeurs par défaut, lesquelles peuvent être modifiées. Pour plus d'informations sur la configuration de bases de données dans Microsoft SQL Server, reportez-vous à la documentation en ligne de Microsoft SQL Server.

Remarques

  • La base de données principale et les fichiers journaux de transactions sont créés avec un préfixe correspondant au nom de la base de données. Par exemple, XLANGdb_Data.mdf et XLANGdb_Log.ldf. Le fichier principal contient les tables système de la base de données.

  • La taille maximale de la base de données est déterminée en fonction de l'espace disponible sur le disque et des limites dues à la licence de la version de Microsoft SQL Server que vous utilisez.

  • Pour plus d'informations sur Microsoft SQL Server, dans le menu Démarrer, pointez sur Programmes et sur Microsoft SQL Server, puis cliquez sur Documentation en ligne.

Voir aussi

Configuration de l'application XLANG Scheduler par défaut

Exécution des planifications XLANG

Exécuter les planifications XLANG

Sécurité des application hébergeant des instances de planification XLANG


Modification de l'identité d'une application COM+

  1. Dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration puis sur Services de composant.

  2. Dans l'arborescence de la console, développez successivement Services de composant, Ordinateurs, Poste de travail et Applications COM+.

  3. Cliquez sur l'application COM+ dont vous voulez modifier l'identité, puis cliquez sur Propriétés dans le menu Action.

  4. Dans la zone Autorisation de l'onglet Avancé, assurez-vous que la case à cocher Désactiver les modifications est désactivée, puis cliquez sur OK.

    La boîte de dialogue Propriétés s'affiche.

  5. Cliquez avec le bouton droit sur l'application COM+, puis cliquez sur Propriétés.

  6. Dans la zone Compte de l'onglet Identité, cliquez sur Cet utilisateur.

  7. Entrez les informations du compte que vous voulez utiliser.

  8. Cliquez sur OK.

    Le message suivant s'affiche : Les applications ont été créées par un ou plusieurs produits externes. Êtes-vous sûr que les modifications que vous allez effectuer sont prises en charge par ces produits ?

  9. Cliquez sur Oui.

Remarques

  • Pour plus d'informations sur la sécurité et les performances liées aux paramètres d'identité d'une application COM+ hébergeant des planifications XLANG, voir Sécurité des applications hébergeant des instances de planification XLANG.

  • Pour accéder à l'aide de l'administration des services de composant, dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration et sur Services de composant, puis cliquez sur Aide.

  • Pour plus d'informations sur les services de composants et COM+, accédez au site Web MSDN Online Library (msdn.microsoft.com/library/default.asp), puis parcourez la plate-forme SDK jusqu'aux services de composant.

Voir aussi

Modification des paramètres de la base de données de persistance d'orchestration par défaut

Configuration de l'application XLANG Scheduler par défaut

Exécution des planifications XLANG

Exécuter les planifications XLANG

Sécurité des application hébergeant des instances de planification XLANG


Modification des paramètres DSN d'une application COM+

  1. Dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration et sur Services de composants.

  2. Dans l'arborescence de la console, développez successivement Services de composant, Ordinateurs, Poste de travail et Applications COM+.

  3. Cliquez sur l'application COM+ dont vous voulez modifier les paramètres DSN (Data Source Name). Dans le menu Action, cliquez sur Propriétés.

  4. Dans l'onglet XLANG, cliquez sur Configurer un DSN.

    La boîte de dialogue Administrateur de la source de données ODBC s'affiche.

  5. Modifiez les paramètres de votre choix.

Attention

  • Une fois que vous avez modifié les paramètres DSN, ne cliquez pas sur Initialiser les tables dans l'onglet XLANG. Cette action détruira toutes les données déjà enregistrées dans la base de données existante.

Important

  • L'application COM+ et le DSN doivent être similaires. Par exemple, si l'application COM+ porte le nom XLANG Scheduler, le DSN doit également porter le nom XLANG Scheduler.

  • Pour plus d'informations sur la configuration d'un DSN et l'utilisation des sources de données (ODBC), cliquez sur Aide dans la boîte de dialogue Administrateur de la source de données ODBC.

Remarques

  • Pour accéder à l'aide de l'administration des services de composant, dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration et sur Services de composant, puis cliquez sur Aide.

  • Pour plus d'informations sur les services de composants et COM+, accédez au site Web MSDN Online Library (msdn.microsoft.com/library/default.asp), puis parcourez la plate-forme SDK jusqu'aux services de composant.

Voir aussi

Exécution des planifications XLANG

Exécuter les planifications XLANG

Sécurité des application hébergeant des instances de planification XLANG


Arrêt d'une application COM+ hébergeant des planifications XLANG

  1. Dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration et sur Services de composants.

  2. Dans l'arborescence de la console, développez successivement Services de composant, Ordinateurs, Poste de travail et Applications COM+.

  3. Cliquez sur l'application COM+ qui héberge les planifications XLANG que vous voulez arrêter. Dans le menu Action, cliquez sur Propriétés.

  4. Dans la zone Arrêt contrôlé de l'onglet XLANG, cliquez sur Cette application XLANG.

Attention

  • Vous devez suivre cette procédure pour exécuter un arrêt contrôlé de toutes les applications COM+. Vous enregistrez ainsi l'état de toutes les planifications XLANG en cours d'exécution dans la base de données de persistance. Pour plus d'informations, voir Persistance.

    Ne cliquez pas avec le bouton droit sur une application COM+, mais cliquez sur Arrêter. L'une des actions suivantes peut se produire :

    • Si les planifications XLANG en cours d'exécution sont entièrement transactionnelles, un arrêt non contrôlé déclenche tous les traitements de gestion d'erreur Compensation et En cas d'échec.

    • Si les planifications XLANG en cours d'exécution ne sont pas entièrement transactionnelles, les données traitées dans la planification sont perdues.

Important

  • Vous ne pouvez pas redémarrer des planifications XLANG mises en attente si le nom de la source de données (DSN) n'est pas disponible ou n'est pas configuré correctement. Pour plus d'informations sur la configuration d'un DSN pour une application COM+ qui héberge des planifications XLANG, voir Création d'une application COM+ pour héberger des planifications XLANG.

Remarques

  • Lorsque vous créez une application COM+ pour héberger des planifications XLANG, l'option Redémarrer les applications XLANG en attente n'est pas disponible. Pour plus d'informations sur le redémarrage des applications mises en attente, voir Redémarrage de toutes les applications XLANG.

  • Pour accéder à l'aide de l'administration des services de composant, dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration puis sur Services de composant. Dans l'arborescence de la console, cliquez avec le bouton droit sur Services de composant, puis cliquez sur Aide.

  • Pour plus d'informations sur les services de composants et COM+, accédez au site Web MSDN Online Library (msdn.microsoft.com/library/default.asp), puis parcourez la plate-forme SDK jusqu'aux services de composant.

Voir aussi

Configuration d'une application COM+ pour héberger des planifications XLANG

Redémarrage de toutes les applications XLANG

Exécution des planifications XLANG

Exécuter les planifications XLANG

Arrêt de toutes les applications XLANG


Surveillance de l'exécution des planifications XLANG

Vous pouvez utiliser l'Observateur d'événements XLANG ou l'Observateur d'événements de Windows 2000 pour surveiller les planifications XLANG en cours.

  • Observateur d'événements XLANG : Lorsque le moteur de XLANG Scheduler exécute des planifications XLANG, il génère différents types d'événements en indiquant la progression des instances de planification. Vous pouvez utiliser l'Observateur d'événements XLANG pour surveiller les événements de planifications XLANG et observer la progression des instances de planification. Vous pouvez surveiller l'application XLANG Scheduler par défaut ou surveiller les applications COM+ personnalisées que vous créez pour héberger les planifications XLANG. L'Observateur d'événements XLANG peut gérer tous les événements publiés par les applications hôte sur des ordinateurs locaux ou distribués. Il peut également stocker ces événements dans un fichier en vue de les analyser ultérieurement.

    Pour plus d'informations sur l'utilisation de l'Observateur d'événements XLANG, reportez-vous au fichier Readme.htm correspondant. L'Observateur d'événements XLANG (XLANGMon.exe) et le fichier Lisezmoi installés par l'Assistant Installation de Microsoft BizTalk Server 2000 se trouvent dans le répertoire d'installation suivant : \Program Files\Microsoft BizTalk Server\SDK\Outils XLANG.

  • Observateur d'événements de Windows 2000 : l'Observateur d'événements de Windows 2000 publie des messages d'événements liés aux planifications XLANG. Pour plus d'informations sur l'utilisation de l'Observateur d'événements en vue d'afficher des messages d'erreur, consultez les références suivantes :
    • Pour plus d'informations sur la configuration de l'Observateur d'événements pour filtrer les messages d'erreur de planification XLANG, voir Configuration de l'Observateur d'événements pour les erreurs de BizTalk Server.

    • Pour obtenir des informations d'ordre général sur l'Observateur d'événements, dans l'aide de Windows 2000 Server, consultez la section "Utilisation de l'Observateur d'événements" du chapitre Observateur d'événements.

Cette section traite de la rubrique suivante :

  • Messages d'erreur des planifications XLANG

Voir aussi

Configuration de l'Observateur d'événements pour les erreurs de BizTalk Server


Messages d'erreur des planifications XLANG

Les messages d'erreur figurant dans la liste ci-après sont renvoyés lorsqu'une planification XLANG en cours génère l'erreur. Ces messages peuvent être affichés dans l'Observateur d'événements de Windows 2000.

Nom du message | Valeur | Description
ID_CAT_UNKNOWN | 0x1 | SVC%0
ID_CAT_NAMESVC | 0x2 | NameSvc%0
ID_CAT_ENGINE | 0x3 | Engine%0
ID_CAT_SYSMGR | 0x4 | SystemMgr%0
ID_CAT_GRPMGR | 0x5 | GroupMgr%0
ID_CAT_WFSVCMGR | 0x6 | WFSvcMgr%0
ID_CAT_OBJECTMODEL | 0x7 | WFObjectModel%0
ID_CAT_BINDING | 0x8 | WFBinding%0
ID_CAT_COM_LAST | 0x9 | <>%0
IDS_I_MTSTOCOM_LAUNCH_FINISHED | 0x1000 | Un client non autorisé a tenté de créer une nouvelle instance d'une planification XLANG. La suite de la chaîne du nom et l'identité du client sont indiquées dans le message suivant. L'ID de sécurité du client (SID) est inclus en sous forme de données binaires : %1%0
ID_W_NOT_USER | 0x2001 | Un client non autorisé a tenté d'accéder à une instance d'une planification XLANG. La suite de la chaîne du nom identifiant l'instance et l'identité du client sont indiqués dans le message suivant. L'ID de sécurité du client (SID) est inclus en sous forme de données binaires : %1%0
IDS_E_COMSVCS_INTERNAL_ERROR | 0x3000 | Le moteur de XLANG Scheduler a détecté une incohérence dans son état interne. Contactez le Support Technique Microsoft pour signaler cette erreur : %1%0
IDS_COMSVCS_RESOURCE_ERROR | 0x3001 | Le moteur de XLANG Scheduler a détecté l'absence d'une ressource importante et a entraîné l'arrêt du processus qui l'hébergeait : %1%0
IDS_COMSVCS_INTERNAL_ERROR_ASSERT | 0x3002 | Erreur interne COM+. Contactez le Support Technique Microsoft pour signaler cette erreur. Échec d'assertion : %1%0
ID_E_USER_EXCEPTION | 0x3003 | Le système a appelé un composant planifié qui a échoué et généré une exception. Ceci indique l'existence d'un problème lié au composant planifié. Notifiez le développeur du composant qu'un incident s'est produit et fournissez-lui les informations suivantes : %1%2%0
ID_INITIALIZE_FOR_DTC | 0x3004 | Le moteur de XLANG Scheduler n'est pas parvenu à initialiser les transactions nécessaires à la prise en charge des composants transactionnels. Assurez-vous que MS DTC fonctionne : %1%0
ID_E_CANT_CREATE_COMPONENT | 0x3005 | Le moteur de XLANG Scheduler n'est pas parvenu à créer un composant utilisateur requis par la planification XLANG en cours. Des informations détaillées sont fournies dans le message suivant. %1%0
ID_E_PROGID_NOT_FOUND | 0x3006 | Le moteur de XLANG Scheduler n'est pas parvenu à convertir l'ID de programmation indiqué ci-dessous en ID de classe COM : %1%0
ID_E_CANT_CREATE_INTERCEPTOR | 0x3007 | Le moteur de XLANG Scheduler n'est pas parvenu à créer un objet d'interception pour l'ID d'interface indiqué dans le message suivant. Les causes probables de ce problème sont les suivantes : 1) l'interface n'est pas enregistrée correctement ; 2) aucun type de bibliothèque n'est fourni pour l'interface ; ou 3) il est impossible de charger le fichier contenant les informations sur le type des interfaces. Le nom du port associé à cet objet d'interception est : %1%0
ID_E_INTF_NOT_SUPPORTED | 0x3008 | Le moteur de XLANG Scheduler a détecté une incohérence entre l'implémentation de port et la planification et les composants COM auxquels elle se rapporte. Un composant énuméré dans l'implémentation de port n'est pas parvenu à prendre en charge l'interface prévue. L'ID de classe du composant et l'IID non pris en charge sont indiqués ci-dessous. Le nom du port associé à ce composant est : %1%0
ID_E_UNKNOWN_METHOD | 0x3009 | Le moteur de XLANG Scheduler a reçu un appel à une méthode qui n'était pas spécifiée dans l'implémentation de port de cette planification XLANG. L'IID et le numéro de la méthode sont indiqués ci-dessous. Le nom du port qui a reçu l'appel est : %1%0
ID_E_UNKNOWN_IDISPATCH_METHOD | 0x300A | Le moteur de XLANG Scheduler a reçu un appel à une méthode qui n'existe plus via l'interface IDispatch::Invoke(). L'ID de répartition de la méthode est indiqué dans le message suivant. Le nom du port qui a reçu l'appel est : %1%0
ID_E_NAMED_PARAMS | 0x300B | Le moteur de XLANG Scheduler a reçu un appel à une méthode qui contient des arguments nommés via l'interface IDispatch::Invoke(). Utilisez des arguments de position à la place. L'ID de répartition de la méthode est indiqué dans le message suivant. Le nom du port qui a reçu l'appel est : %1%0
ID_E_BAD_INVOKE_PARAMS | 0x300C | Le moteur de XLANG Scheduler a reçu un appel à une méthode avec un nombre incorrect de paramètres via l'interface IDispatch::Invoke(). L'IID et l'ID de répartition de la méthode sont indiqués dans le message suivant. Le nom du port qui a reçu l'appel est : %1%0
ID_E_BAD_RETURN_POINTER | 0x300D | Le moteur de XLANG Scheduler a reçu un paramètre de sortie incorrect d'une méthode via l'interface IDispatch::Invoke(). La référence renvoyée est incorrecte (NULL ou pointeur non valide) ou ne prend pas en charge l'interface attendue. L'ID de répartition attendu est indiqué dans le message suivant. Le nom du message contenant la référence de port incorrecte est : %1%0
ID_E_ACCESS_CHECK_FAILURE | 0x300E | Le moteur de XLANG Scheduler n'est pas parvenu à autoriser la demande de résolution de nom du client. L'accès est refusé.%0
ID_E_BAD_INVOKE | 0x300F | L'interface IDispatch::Invoke() n'est pas parvenue à appeler une méthode. L'ID de répartition de la méthode est indiqué dans le message suivant. Le nom du port sur lequel l'appel a été tenté est : %1%0
ID_E_INVOKED_METHOD | 0x3010 | La méthode appelée, dont l'ID de répartition est indiqué ci-dessous, a renvoyé une erreur. Le nom du port sur lequel l'appel a été tenté est : %1%0
ID_E_CANT_GET_TYPEINFO | 0x3011 | Le composant dont le nom du port et le CLSID COM sont indiqués ci-dessous n'est pas parvenu à fournir les informations du type requis au moteur de XLANG Scheduler.%1%0
ID_E_CANT_INVOKE_METHOD | 0x3012 | Le moteur de XLANG Scheduler n'est pas parvenu à transmettre un appel de méthode à l'objet associé au nom du port indiqué dans le message suivant. L'interface et le nom de la méthode appelée sont également indiqués.%1%0
ID_E_CANT_GET_CLASSINFO | 0x3013 | Le composant dont le nom de port et le CLSID COM sont indiqués dans le message suivant n'est pas parvenu à fournir les informations du type requis au moteur de XLANG Scheduler via l'interface IProvideClassInfo::GetClassInfo.%1%0
ID_E_SCRIPT_ERROR | 0x3014 | Une règle de décision rédigée sous forme de script dans une instance de planification XLANG n'a pu être exécutée. L'erreur renvoyée par le moteur de script est indiquée dans le message suivant. Le code source du script et les informations sur l'instance de planification dans laquelle l'erreur s'est produite sont également indiqués.%1%0
ID_E_SCRIPT_ERROR_NOINFO | 0x3015 | Une règle de décision rédigée sous forme de script dans une instance de planification XLANG a échoué. Les informations détaillées relatives à l'erreur ne peuvent être obtenues en raison d'une erreur interne. Le code d'erreur est indiqué dans le message suivant.%1%0
ID_E_SCRIPT_BADCONV | 0x3016 | Une règle de décision rédigée sous forme de script dans une instance de planification XLANG a fait référence à un champ de message dont le type n'est pas compatible avec le moteur VBScript. Le moteur de XLANG Scheduler a tenté de convertir le champ dans un type compatible mais sans succès. Les informations ci-dessous indiquent la règle de script, le message et le champ concernés, ainsi que le type de variante du champ d'origine et le type dans lequel la conversion a été tentée. La structure de données de type VARIANT est liée à cette entrée de journal en tant que données binaires.%1%0
ID_E_SCRIPT_BADARRAY | 0x3017 | Une règle de décision rédigée sous forme de script dans une instance de planification XLANG a fait référence à un champ de message contenant un type de tableau non compatible avec le moteur VBScript. Seuls les tableaux de variantes sont pris en charge par Visual Basic Scripting. Les informations ci-dessous indiquent la règle de script, le message et le champ concernés. La structure de données de type VARIANT est liée à cette entrée de journal en tant que données binaires.%1%0
ID_E_SCRIPT_BADEXPR | 0x3018 | Une règle de décision rédigée sous forme de script dans une instance de planification XLANG contient une expression qui ne renvoie pas un résultat booléen. Les informations figurant dans le message suivant indiquent la règle de script et l'expression concernées. La structure de données de type VARIANT renvoyée par l'expression est liée à cette entrée de journal en tant que donnée binaire.%1%0
ID_E_SCHEDULE_NOT_RUNNING | 0x3019 | Le moteur de XLANG Scheduler a reçu un appel à un objet associé à un port dans une instance de planification XLANG qui n'est pas exécutée. Le nom du port qui a reçu l'appel est : %1%0
ID_E_INTERNAL_EXCEPTION | 0x301A | Une exception interne COM+ s'est produite. Contactez le Support Technique Microsoft, signalez cette erreur et indiquez les informations dans le message suivant.%1%2%0
ID_E_BAD_DATAFLOW_NOMESSAGE | 0x301B | Il existe un problème lié à la spécification du flux de données. Un message indiqué comme étant une source de données n'existe pas encore pendant l'exécution de la planification XLANG. Des informations détaillées sont fournies dans le message suivant.%1%0
ID_E_BAD_ARGUMENTVALUE | 0x301C | L'un des champs utilisé comme paramètre pour un appel de méthode COM contient une valeur incorrecte. Cela est probablement dû à un flux de données incorrect ou manquant. Des informations détaillées sont fournies dans le message suivant.%1%0
ID_E_DEEP_VARIANT_NESTING | 0x301D | L'un des champs utilisé comme paramètre pour un appel de méthode COM contient plusieurs niveaux d'imbrication de VARIANTS. L'IDD et l'ID de répartition de la méthode sont indiqués dans le message suivant. Le nom du port qui a reçu l'appel est : %1%0
ID_E_BAD_MAPPORTVALUE | 0x301E | Un champ contenant un port mappé n'est pas valide. Des informations détaillées sont fournies dans le message suivant.%1%0
ID_E_BAD_CALLPARAMNUMBER | 0x301F | Un nombre de paramètres transmis à l'appel est incorrect. Des informations détaillées sont fournies dans le message suivant.%1%0
ID_E_EXECUTINGCALLEDSCHEDULE | 0x3020 | Impossible d'exécuter la planification XLANG en tant que planification de niveau supérieur. Des paramètres de contexte doivent lui être transmis. Des informations détaillées sont fournies dans le message suivant.%1%0
ID_E_CANT_GET_SUPPORTERRORINFO | 0x3021 | Le composant dont le nom de port et le CLSID COM sont indiqués dans le message suivant n'est pas parvenu à renvoyer de résultat à partir d'une interface supposée prendre en charge le moteur de XLANG Scheduler via ISupportErrorInfo::InterfaceSupportsErrorInfo.%1%0
ID_E_PERSIST_FAILURE | 0x3022 | Impossible d'enregistrer l'état de l'instance de planification dans la base de données.%0 Des informations détaillées sont fournies dans le message suivant.%1%0
ID_E_TRANSACTION_COMMIT_FAILURE | 0x3023 | Le système n'est pas parvenu à valider un contexte transactionnel. Des informations détaillées sont fournies dans le message suivant.%1%0
ID_E_TRANSACTION_ABORTED | 0x3024 | Le système a abandonné un contexte transactionnel. Des informations détaillées sont fournies dans le message suivant.%1%0
ID_E_TRANSACTION_ABORT_FAILURE | 0x3025 | Le système n'est pas parvenu à abandonner un contexte transactionnel. L'état de la transaction n'est pas connu. Des informations détaillées sont fournies dans le message suivant.%1%0
ID_E_PENDINGREHYDRATIONERROR | 0x3026 | L'application de réalimentation est en cours de fermeture en raison d'une erreur. Certaines requêtes de réalimentation vont échouer suite à cette fermeture. Redémarrez le service du moteur de XLANG Scheduler. Des informations détaillées sont fournies dans le message suivant.%1%0
ID_E_REHYDRATIONONSTARTUPERROR | 0x3027 | Une ou plusieurs planifications XLANG n'ont pu être réalimentées en raison d'une erreur système. Cette erreur est probablement due à des problèmes survenus lors de la lecture de la base de données ou à des problèmes liés aux données lues. Des informations détaillées sont fournies dans le message suivant.%1%0
ID_E_REHYDRATIONERROR | 0x3028 | Une erreur s'est produite lors de la réalimentation d'une planification XLANG. Un problème existe probablement au niveau de la lecture de la base de données ou des données stockées. La planification XLANG n'a vraisemblablement pas été réalimentée correctement. Des informations détaillées sont fournies dans le message suivant.%1%0
ID_E_FOUNDINITIALIZEDTHREAD | 0x3029 | Le service du moteur de XLANG Scheduler a rencontré une erreur grave de gestion des threads lors du traitement d'une planification XLANG. La planification risque d'échouer. Contactez votre support technique.%1%0
ID_E_CALLONCOMPLETEDSCHEDULE | 0x302A | Le service du moteur de XLANG Scheduler a reçu un appel pour une instance de planification XLANG terminée. Celle-ci a déjà été supprimée de la mémoire. L'IID de l'interface est indiqué dans le message suivant.%1%0
IDS_MSG_TIMEBOMB_EXPIRED | 0x302B | Merci d'avoir évalué Microsoft BizTalk Server 2000. La période d'évaluation de cette version a expiré. Contactez Microsoft ou votre revendeur de logiciels pour obtenir une version sous licence de Microsoft BizTalk Server 2000.%0
ID_E_FIELDPORTPERSISTENCEERROR | 0x302C | Une erreur s'est produite lors de la tentative de prolongation d'une instance de planification XLANG. Des informations détaillées sont fournies dans le message suivant.%1%0
ID_E_FIELDPORTREHYDRATIONERROR | 0x302D | Une erreur s'est produite lors de la tentative de restauration d'un sous-composant particulier d'une instance de planification XLANG à partir de la base de données.%1%0 Des informations détaillées sont fournies dans le message suivant.%1%0
ID_E_SCHEDULEDONE | 0x3030 | Le moteur de XLANG Scheduler a rencontré une erreur lors du marquage d'une instance de planification XLANG comme étant effectuée. La base de données n'a pu être mise à jour ou bien un autre type d'erreur s'est produit au cours de la phase finale. Des informations détaillées sont fournies dans le message suivant.%1%0
ID_E_COMPONENT_INCOMPATIBLE_TXN | 0x3031 | Le moteur de XLANG Scheduler a rencontré une erreur lors de l'instanciation d'un composant. Le composant est déjà intégré dans une autre transaction ou bien le composant n'a pas été intégré dans une transaction et l'instanciation actuelle requiert une transaction. Des informations détaillées sont fournies dans le message suivant.%1%0
ID_E_SUSPEND_FAILURE | 0x3032 | Impossible de suspendre la planification XLANG.%0 Des informations détaillées sont fournies dans le message suivant.%1%0
ID_E_INITNEW | 0x3033 | Le moteur de XLANG Scheduler a rencontré une erreur lors de l'exécution de IPersistStreamInit::InitNew. L'ID de classe du composant et le code d'erreur sont indiqués dans le message suivant. Le nom du port associé à ce composant est : %1%0
ID_E_POSSIBLEBYOTISSUE | 0x3034 | Impossible de créer le composant demandé. Vous avez peut-être configuré le composant BYOT à l'intérieur d'une application COM+ sur cette machine. Ce paramétrage n'est pas compatible avec le service XLANG Scheduler. Le nom du port associé à ce composant est : %1%0
ID_E_FIELDPROCESSINGERROR | 0x3035 | La valeur de champ fournie n'est pas valide. Des informations détaillées sont fournies dans le message suivant.%1%0
ID_E_NO_OBJECT | 0x3036 | Impossible d'instancier la planification XLANG.%0 Des informations détaillées sont fournies dans le message suivant.%1%0
ID_E_STARTUP_FAILED | 0x3037 | Échec du démarrage d'un ou de plusieurs Gestionnaires de groupe XLANG. L'erreur suivante a été renvoyée : %1%0
ID_E_NON_SCRIPT_BADEXPR | 0x3038 | Une instance de planification XLANG possède une règle comparant les champs des types de données non autorisés. Des informations détaillées sont fournies dans le message suivant.%1%0
E_BTW_PERSIST_REACHEDEOF | 0x3039 | Le jeu d'enregistrements ne peut renvoyer cette ligne car la fin de fichier a été atteinte.%1%0
ID_E_BAD_DATAFLOW_EMPTYFIELD | 0x3040 | Il existe un problème lié à la spécification du flux de données. Un champ indiqué comme étant une source de données est vide. Cela est peut-être dû au fait qu'il n'a pas été prolongé avant. Des informations détaillées sont fournies dans le message suivant.%1%0
ID_E_CANT_OPEN_DEADLETTER_QUEUE | 0x3041 | Le moteur de XLANG Scheduler n'est pas parvenu à créer ou à ouvrir la file d'attente XLANG suspendue pour son application hôte COM+. Le nom de l'application COM+ défectueuse est : %1%0
ID_E_CANT_XFER_TO_DEADLETTER_QUEUE | 0x3042 | Le moteur de XLANG Scheduler n'est pas parvenu à transférer un message incorrect à la file d'attente XLANG suspendue pour son application hôte COM+. Le nom de l'application COM+ défectueuse est : %1%0
ID_E_CANT_LOADMODULE | 0x3043 | Le moteur de XLANG Scheduler n'est pas parvenu à charger un module requis. Ceci est sans doute dû aux erreurs de compilation ou aux erreurs sémantiques du module. Des informations détaillées sont disponibles dans le message suivant : %1%0
ID_E_USER_DATA_EXCEPTION | 0x3044 | Une valeur reçue du client a provoqué le déclenchement d'une exception. Ceci peut être dû à une allocation incorrecte de la mémoire pour les données, un nombre de références incohérent ou à la corruption d'autres données. L'origine du problème provient probablement du code client. Des informations détaillées sont disponibles dans le message suivant : %1%2%0
E_BTW_INTERNAL_ERROR | 0x4001 | Une erreur interne s'est produite. %1%0
E_EXPORT_FAILED | 0x4002 | Impossible de traiter la planification XLANG.%0
E_BTW_UNKNOWN_SHAPE | 0x4003 | Le compilateur ne parvient pas à interpréter la forme. Cette forme est inconnue.%0
E_BTW_INCOMPLETE_FLOW | 0x4004 | Le flux est incomplet car un connecteur est manquant.%0
E_BTW_INCOMPLETE_FLOW_LEFT | 0x4005 | Le flux est incomplet. La forme doit posséder un flux relié au connecteur de gauche.%0
E_BTW_INCOMPLETE_FLOW_RIGHT | 0x4006 | Le flux est incomplet. La forme doit posséder un flux relié au connecteur de droite.%0
E_BTW_INCOMPLETE_FLOW_LATERAL | 0x4007 | Le flux est incomplet. La forme n'est reliée à aucun élément sur le côté.%0
E_BTW_INCOMPLETE_FLOW_TOP | 0x4008 | Le flux est incomplet. La forme doit posséder un flux relié au connecteur supérieur.%0
E_BTW_INCOMPLETE_FLOW_BOTTOM | 0x4009 | Le flux est incomplet. La forme doit posséder un flux relié depuis le connecteur inférieur.%0
E_BTW_INCOMPLETE_FLOW_ANYLINE | 0x400A | Le flux est incomplet. Aucune forme n'y est reliée.%0
E_BTW_MIRRORLIST_INCONSISTENT | 0x400B | Impossible de trouver les formes en miroir dans les pages En cas d'échec ou Compensation. Recommencez après avoir remplacé la forme par une nouvelle.%0
E_BTW_BEGIN_INSIDE_TRANSACTION | 0x4010 | La forme de début ne doit pas être intégrée à une transaction.%0
E_BTW_END_MULTIPLE_LOOP | 0x4020 | Une seule forme Fin peut être utilisée dans la branche de boucle.%0
E_BTW_END_IN_TRANSACTION | 0x4021 | La forme Fin ne peut pas être utilisée dans le contexte.%0
E_BTW_SYNCACTION_NO_PAIR | 0x4030 | La liaison à un port COM requiert que les actions apparaissent par paires.%0
E_BTW_INCOMPLETE_FLOW_BINDING | 0x4031 | Aucune liaison pour cette action ou ce port.%0
E_BTW_FIELD_TYPE_NOT_SUPPORTED | 0x4040 | Type (type de variante=%1!d!) non pris en charge.%0
E_BTW_ROLE_NOT_SUPPORTED | 0x4050 | Impossible de compiler les contrats (planification XLANG avec rôles).%0
E_BTW_EMPTY_TRANSACTION | 0x4060 | La transaction ne contient aucune forme valide.%0
E_BTW_TRANSACTION_NOT_PERMITTED | 0x4061 | Les formes transactionnelles ne sont pas autorisées lorsque la planification XLANG est traitée comme un composant COM+. Supprimez la transaction ou modifiez les propriétés de la forme de début pour modifier le modèle transactionnel.%0
E_BTW_TRANSACTION_BOUNDARIES_CROSSED | 0x4062 | Il n'est pas possible de connecter un flux situé à l'extérieur d'une transaction à une forme située dans une transaction sans connecter d'abord le flux à la transaction Dessinez le flux jusqu'au point de connexion supérieur pour pouvoir le connecter à la transaction. Ensuite, cliquez sur la transaction pour la mettre en surbrillance. Tracez un autre flux depuis le point de connexion de la transaction jusqu'à la première forme située dans la transaction. Pour dessiner un flux qui sort de la transaction, vous devez d'abord connecter le flux au point de connexion situé en bas de la transaction. Ensuite, cliquez sur la transaction pour la mettre en surbrillance. Tracez un autre flux depuis le point de connexion inférieur jusqu'à la forme suivante du processus professionnel.%0
E_BTW_TRANSACTION_TERMINATED_PREMATURELY | 0x4063 | Au moins un chemin dans la transaction doit sortir de la transaction.%0
E_BTW_NO_RULES_FOR_SWITCH | 0x4070 | Les formes Décision doivent contenir au moins une règle.%0
E_BTW_CANNOT_WAIT_ON_ALL_SWITCH_BRANCHES | 0x40A0 | Impossible d'attendre toutes les branches de la décision.%0
E_BTW_NO_BRANCH_FOUND | 0x40A1 | La jointure ne parvient pas à trouver la branche ou la décision correspondante.%0
E_BTW_JOIN_MISMATCH | 0x40A2 | Seule une jointure peut être utilisée avec une branche ou une décision donnée.%0
E_BTW_JOIN_SHARED | 0x40A3 | Impossible d'utiliser la même jointure pour les flux issus des différentes branches ou décisions.%0
E_BTW_CANNOT_WAIT_ON_SOME_SWITCH_BRANCHES | 0x40A4 | Tous les chemins en provenance de la décision ne parviennent pas à la jointure.%0
E_BTW_CANNOT_WAIT_ANY_ON_FORK_BRANCHES | 0x40A5 | Impossible d'attendre "Or". Les branches contiennent des formes de processus qui ne peuvent jamais se terminer par des planifications suspendues.%0
E_BTW_DATAFLOW_DISALLOWED_ON_BTM_PORT | 0x40C0 | Ce port ne peut pas être utilisé dans plusieurs actions de réception ou dans une action de réception unique d'une boucle.%0
E_BTW_MESSAGE_TECH_NOT_FOUND | 0x4110 | Ce message n'est lié à aucun port.%0
E_BTW_MESSAGE_TYPE_MISMATCH | 0x4111 | Message utilisé avec les types "%1" et "%2" en conflit.%0
E_BTW_MISSING_TECHNOLOGY | 0x4120 | La liste des méthodes disponibles pour ce flux de communication a changé. Réexécutez l'Assistant Communication de méthodes pour sélectionner une autre méthode et mettre à jour ce flux de communication.%0
E_BTW_MISSING_PORT_DATAFLOW | 0x41A0 | Les paramètres de ce port indiquent qu'il a été créé à l'extérieur du moteur de XLANG Scheduler. Vous devez désigner la source de cette référence de port en dessinant une connexion depuis le champ de message approprié.%0
E_BTW_CIRCULAR_DATAFLOW | 0x41A1 | Il semble qu'un chemin circulaire existe dans le chemin de flux de données pour cette planification XLANG.%0
E_BTW_LOOP_NORULE | 0x41D0 | Aucune règle n'a été définie.%0
E_BTW_LOOP_BODY_EXITS_TRANSACTION | 0x41D1 | Le corps de la boucle ne peut pas quitter la transaction jointe. %0
E_BTW_LOOP_BODY_END_MISSING | 0x41D2 | La fin du corps de la boucle est introuvable.%0
E_BTW_ABORT_NOT_IN_TXN | 0x41E0 | Les formes Abandon doivent être associées à une transaction jointe.%0
E_BTW_ABORT_CONTEXT_INVALID_SCOPE | 0x41E1 | Les formes Abandon se rapportent uniquement aux contextes actuels ou parents.%0
E_BTW_END_MULTIPLE_ABORT | 0x41E2 | Plusieurs formes Fin ne sont pas autorisées sur la page En cas d'échec.%0
E_BTW_COMPILER_FAILED | 0x5000 | Échec de la compilation sur "%1".%0
E_BTW_PARSE_FAILED | 0x5001 | Échec de l'analyse.%0
E_BTW_FIXUP_FAILED | 0x5002 | Échec de la correction.%0
E_BTW_VALIDATION_FAILED | 0x5003 | Échec de la validation.%0
E_BTW_NODE_FAILURE | 0x5004 | au noeud " %1 " (%2!d!,%3!d!).%0
E_BTW_STACK_TOO_MANY_ITEMS | 0x5005 | Trop d'éléments trouvés dans la pile.%0
E_BTW_STACK_UNEXPECTED_NODE | 0x5006 | Un noeud inattendu a été détecté.%0
E_BTW_XMLQUERY_RETURNED_ZERO_NODES | 0x5007 | La requête XML a renvoyé des noeuds nuls.%0
E_BTW_XMLQUERY_RETURNED_MULTIPLE_NODES | 0x5008 | La requête XML a renvoyé plusieurs noeuds.%0 «
E_BTW_XMLQUERY_MISSING_ATTRIBUTE | 0x5009 | L'attribut requis "%1" est manquant.%0
E_BTW_LOAD_MODULE_FAILED | 0x500A | Échec du chargement du module "%1".%0
E_BTW_XML_LOAD_FAILED | 0x500B | Le XML-DOM a renvoyé une erreur à "%1!d!, %2!d!".%0
E_BTW_ERROR_LOADING_PACKAGE | 0x500C | Une erreur "0x%1!X!" s'est produite lors de la tentative de chargement de l'URL suivante : "%2".%0
E_BTW_NAMED_LIST_HAS_DUPLICATE_ENTRIES | 0x500D | La liste possède des entrées en double portant le nom "%1".%0
E_BTW_REQUIRED_ELEMENT_MISSING | 0x500E | L'élément requis "%1" est manquant.%0
E_BTW_ELEMENT_MISSING_VALUE | 0x5100 | Valeur d'élément manquante.%0
E_BTW_REFERENCE_RESOLVE_FAILED | 0x5110 | Impossible de résoudre "%1" avec la valeur d'emplacement "%2".%0
E_BTW_CONTEXTREF_INVALID_REFERENCE | 0x5120 | Le "renvoi" ou la "libération" d'un contexte indépendant (non-englobant) n'est pas autorisé.%0
E_BTW_CONTEXTREF_SELF_REFERENCE | 0x5121 | Le renvoi ou la version se rapportant à un contexte dans ce contexte n'est pas autorisé.%0
E_BTW_ASYNC_ACTION_COM_NOT_ALLOWED | 0x5400 | Une action asynchrone doit se rapporter à un port non COM.%0
E_BTW_CONNECTION_PORT_HAS_TECH_BINDING | 0x5490 | Le port "%1" utilisé dans une connexion ne peut pas posséder de liaison technologique.%0
E_BTW_CONNECTION_PORT_REUSED | 0x5491 | Le port "%1" utilisé dans une connexion a déjà été utilisé avant dans la planification XLANG.%0
E_BTW_TRANSACTIONS_NESTED | 0x54B0 | Lorsque les transactions sont imbriquées, la transaction externe doit être à exécution longue.%0
E_BTW_TRANSACTIONS_NESTED_RETRY | 0x54B1 | Lorsque les transactions sont imbriquées, la transaction externe ne peut pas avoir de nombres de tentatives.%0
E_BTW_MESSAGE_HAS_NO_DECL | 0x5520 | Le message "%1" ne possède pas de déclaration associée.%0
E_BTW_MESSAGE_HAS_UNSATISFIED_DATA_DEPENDENCIES | 0x5521 | Le message "%1" possède des dépendances de données insatisfaites sur "%2". Les dépendances n'ont pas été créées dans le flux ou sont éventuellement attendues sur un port pour lequel l'option "Aucune instanciation" a été sélectionnée.
E_BTW_PORT_HAS_NO_BINDING | 0x5570 | Le port "%1" ne possède pas de liaison associée.%0
E_BTW_PORT_HAS_UNSATISFIED_DATA_DEPENDENCIES | 0x5571 | Le port "%1" possède des dépendances de données insatisfaites sur les messages "%2". Les dépendances n'ont pas été créées dans le flux ou sont éventuellement attendues sur un port pour lequel l'option "Aucune instanciation" a été sélectionnée.
E_BTW_RULE_HAS_NO_BINDING | 0x55B0 | La règle "%1" ne possède pas de liaison associée.%0
E_BTW_SCHEDULE_SUSPENDED | 0x55E0 | La planification XLANG a été suspendue.%0
E_BTW_SCHEDULE_STOPPED | 0x55E1 | La planification XLANG a été arrêtée.%0
E_BTW_PERSIST_FAILED | 0x55E2 | L'état de l'instance de la planification XLANG n'a pas pu être enregistré dans la base de données.%0
E_BTW_SUSPEND_FAILED | 0x55E3 | La planification XLANG n'a pas pu être suspendue.%0
E_XLANG_SHUTTINGDOWN | 0x55E4 | L'application XLANG est en cours de fermeture.%0
E_BTW_MISSING_MESSAGE_BINDING_ON_PORT | 0x5730 | L'action utilise le port "%1" dont la liaison ne définit pas celle du message "%2".%0
E_BTW_MISSING_INCOMING_PORTREF | 0x5731 | Le message utilisé par cette action de réception contient un champ (%1) connecté à une référence de port (%2), mais les connexions de flux de données n'indiquent pas que la référence de port doit être reçue.%0
E_BTW_SOURCE_PORT_HAS_NOINVOCATION | 0x5740 | L'action d'envoi fait référence au port "%1" pour lequel l'option "Aucune instanciation" a été sélectionnée.%0
E_BTW_MISSING_OUTGOING_PORTREF | 0x5741 | Le message utilisé par cette action source contient un champ (%1) connecté à une référence de port (%2), mais les connexions de flux de données n'indiquent pas que la référence de port doit être envoyée.%0
E_BTW_TASK_LIMIT | 0x5750 | La tâche possède "%1!d!" actions. La limite actuelle est "%2!d!".%0
E_BTW_SYNC_DIFFERENT_PORTS | 0x5760 | La paire d'actions synchrone se rapporte à des ports différents : "%1" et "%2".%0
E_BTW_SYNC_SAME_MESSAGE | 0x5761 | La paire d'actions synchrone se rapporte au même message : "%1".%0
E_BTW_SYNC_ONLY_COM_ALLOWED | 0x5762 | La paire d'actions synchrone doit se rapporter au port COM uniquement.%0
E_BTW_SYNC_SECOND_MESSAGE_MUST_BE_OUT_FOR_FIRST_MESSAGE | 0x5763 | Dans une paire d'actions synchrone, le message de la seconde action doit être le message de sortie de celui de la première action.%0
E_BTW_INVALID_DELAY_TIME | 0x5770 | Le temps d'attente (%1!d!) n'est pas valide. Ce temps ne peut pas être une valeur négative.%0
E_BTW_CALL_MESSAGE_SCHEMA_NAME_MISMATCH | 0x5800 | Le nom de spécification de message "%1" pour le message "%2" de la planification XLANG appelante ne correspond pas au nom de spécification "%3" de la planification XLANG appelée.%0
E_BTW_CALL_MESSAGE_SCHEMA_REPRESENTATION_MISMATCH | 0x5801 | La représentation de spécification de message pour le message "%1" de la planification XLANG appelante ne correspond pas à la représentation de spécification de la planification XLANG appelée.%0
E_BTW_ASSIGNMENT_PORT_HAS_TECH_BINDING | 0x5830 | Le port "%1" utilisé dans l'affectation d'un format couper ne peut pas posséder de liaison technologique.%0
E_BTW_PARTITION_LIMIT | 0x5850 | La partition possède "%1!d!" processus. La limite actuelle est "%2!d!".%0
E_BTW_MESSAGE_USED_IN_PARALLEL | 0x5851 | Des processus ou actions parallèles utilisent le même message "%1".%0
E_BTW_PORT_USED_IN_PARALLEL | 0x5852 | Des processus ou actions parallèles utilisent le même message "%1".%0
E_BTW_INVALID_RETRY_COUNT | 0x5A30 | Le nombre de tentatives "%1!d!" est incorrect. Le nombre de tentatives ne peut pas être négatif.%0
E_BTW_INVALID_BACKOFF_VALUE | 0x5A31 | La valeur de recul "%1!d!" n'est pas valide. Cette valeur ne peut être négative.%0
E_BTW_INVALID_TIMEOUT_VALUE | 0x5A32 | La valeur d'expiration du délai n'est pas valide. Cette valeur ne peut pas être négative.%0
E_BTW_FIELD_RESERVED_NAME | 0x5A50 | %1 est un nom de champ réservé.%0
E_BTW_ELEMENT_TYPE_NOT_DEFINED | 0x5A51 | Le type d'élément "%1" n'est pas défini.%0
E_BTW_ELEMENT_TYPE_INCOMPLETE | 0x5A70 | La définition du type d'élément est incomplète. Indiquez des sous-éléments ou dt:type.%0
E_BTW_MULTIPLE_PORTS | 0x5A90 | Les ports distincts "%1" et "%2" sont utilisés dans le même champ.%0
E_XLANG_INVALID_COMPARE_TYPE | 0x5A91 | Comparaison de ce type de données non autorisée.%0
E_BTW_FIELD_NOT_MATCHING_SCHEMA_ELEMENT | 0x5A92 | FieldBinding pour "%1" n'a pas d'élément correspondant dans le schéma à la position "%2!d!".%0
E_BTW_FIELD_HAS_AMBIGUOUS_DATAFLOW | 0x5A93 | Un champ de message ne peut pas avoir à la fois un flux de données issu d'un autre champ de message et une référence à un port. L'un des flux de données doit être supprimé.%0
E_BTW_PORT_TARGET_INVALID | 0x5A94 | Le type de ce champ ne peut être utilisé comme référence de port. Les ports liés à un composant COM sont transférés en tant que références d'objets ou de chaînes. Les ports liés à un composant COM sont transférés en tant que références d'objets ou de chaînes. Les ports internes sont transférés uniquement en tant que références d'objets.%0
E_BTW_FIELD_TARGET_INVALID | 0x5A95 | Le champ cible "%1", de type variante "%2", ne peut pas récupérer des données du champ source "%3", de type variante "%4".%0
E_BTW_INITIALIZED_MESSAGEFIELD_INVALID_OVERWRITE | 0x5A96 | Les données du champ "%1" d'un message "%2" initialisé ne peuvent pas être écrasées par des données issues d'un autre message ou d'un autre port dans la spécification de liaison.%0
E_BTW_DATAFLOW_INCOMPLETE | 0x5AB1 | Une action source acceptant des paramètres [in] doit avoir ses champs correspondants remplis de flux de données (c'est-à-dire, "from").%0
E_BTW_DATAFLOW_FROM_SYSTEM_FIELD | 0x5AB2 | Impossible d'initialiser le port à partir d'un champ système.%0
E_BTW_DATAFLOW_FROM_CONSTANT_FIELD | 0x5AB3 | Le port ne peut être initialisé à partir d'un champ de message de constante.%0
E_BTW_MISSING_SCRIPT_EXPRESSION | 0x5AC0 | Aucune expression de script n'a été fournie pour cette règle.%0
E_BTW_BAD_SCRIPT_EXPRESSION | 0x5AC1 | %1 %2 à la position de caractère %3!d! dans "%4"%0
E_BTW_MAP_INVALID_BINDING | 0x5AE0 | La liaison du message "%1" doit contenir une référence au port mappé "%2".%0
E_BTW_MESSAGE_BINDING_SCHEMA_MISMATCH | 0x5AE1 | Incohérence entre la liaison et le schéma du message "%1".%0
E_BTW_MESSAGEDECL_INIT_DATA_UNAVAILABLE | 0x5B00 | Impossible d'obtenir les données d'initialisation pour le champ "%1".%0
E_BTW_LATENCY_INVALID_VALUE | 0x5B20 | La valeur de la propriété Latence doit être un entier positif inférieur à l'entier de longueur maximale "%1!d!".%0
E_BTW_PORT_LATENCY_ON_INTERNAL | 0x5B21 | Impossible de spécifier la latence sur un port interne.%0
E_BTW_MESSAGE_TECHNOLOGY_MISMATCH | 0x5BB0 | Incohérence entre la technologie "%2" du port "%1" et la technologie "%4" du message "%3".%0
E_BTW_FIELD_TECHNOLOGY_MISMATCH | 0x5BC0 | Incohérence entre la technologie "%2" du message "%1" et la technologie "%4" du champ "%3".%0
E_BTW_COM_PORT_NOT_CREATABLE | 0x5C10 | Si un port COM peut être invoqué, il requiert un CLSID, un progID ou un moniker.%0
E_BTW_AUTORETURN_COM_PORT_MUST_BE_USED_INSIDE_CONTEXT | 0x5C11 | Le port "%1", configuré pour abandonner une transaction si une méthode renvoie un échec de HRESULT, peut être utilisé uniquement dans une transaction.%0
E_BTW_COM_PORT_GENERAL_ACCESS_FAILURE | 0x5C12 | Un port COM peut être invoqué. Reportez-vous à la documentation de Windows 2000.%1%0
E_BTW_COM_PARAMETERS_LIMIT | 0x5C20 | La méthode possède "%1!d!" paramètre(s). La limite actuelle est "%2!d!".%0
E_BTW_COM_NO_MATCHING_RETURN | 0x5C21 | Aucun retour correspondant pour la méthode COM.%0
E_BTW_COM_NO_MATCHING_METHOD | 0x5C22 | Aucune méthode correspondante pour le retour COM.%0
E_BTW_INVALID_SLOT_NUMBER | 0x5C23 | Le numéro d'emplacement "%1!d!" est incorrect. Il ne doit pas être inférieur à la valeur suivante : SLOT_NONE(-1).%0
E_BTW_INVALID_INVOKE_KIND | 0x5C24 | InvokeKind "%1!d!" non valide. Les valeurs autorisées sont : 1,2,3,4 et 8.%0
E_BTW_PROXY_DISCONNECTED | 0x5C25 | Le proxy a été déconnecté.%0
E_BTW_COM_DISPATCH_SLOT_SPECIFIED | 0x5C26 | Le nombre d'emplacements ne peut être spécifié pour l'interface de répartition.%0
E_BTW_COM_SPECIFY_DISPID_OR_SLOT | 0x5C27 | Les valeurs correctes de dispid ou d'emplacement doivent être spécifiées.%0
E_BTW_COM_INVALID_BYREF_FOR_RETURN_MESSAGES | 0x5C30 | Byref doit être "1" puisque "%1" est un message <com:return>.%0
E_BTW_COM_INVALID_NESTED_VARIANTS | 0x5C31 | Plusieurs niveaux d'imbrication de variantes ne sont pas autorisés.%0
E_BTW_COM_FIELD_INDEX_MUST_BE_NON_NEGATIVE | 0x5C32 | L'index "%1!d!" du champ n'est pas valide. Cette valeur doit être un entier non négatif.
E_BTW_COM_FIELD_INDEX_REPEATED | 0x5C33 | L'index "%1!d!" du champ a été utilisé avant un autre champ du message.%0
E_BTW_COM_FIELD_INDEX_NOT_CONTIGUOUS | 0x5C34 | Pour les messages de paires d'action synchrones "%1" et "%2", l'index "%3!d!" d'un champ n'est pas valide. Les index de champ de ces messages doivent former un bloc contigu de nombres non négatifs qui commencent à zéro.%0
E_BTW_MSMQ_NO_MQRT_DLL | 0x5D00 | Impossible de charger la DLL Message Queuing, MQRT.DLL.%0
E_BTW_MSMQ_CREATECHANNEL | 0x5D01 | MQBinder : échec de la création du canal pour : %1.%0
E_BTW_MSMQ_NOT_CONFIGERED_PROPERLY | 0x5D02 | Le service Message Queuing n'est pas correctement configuré. Impossible d'ouvrir un objet de file d'attente %1.%0
E_BTW_MSMQ_NO_CERTIFICATE_AVAILABLE | 0x5D03 | Le service Message Queuing ne peut obtenir un certificat.%1%0
E_BTW_MSMQ_NO_WELLKNOWN_QUEUE_NAME | 0x5D04 | Impossible d'envoyer un message à une file d'attente connue car cette dernière n'est pas nommée dans la planification XLANG. Indiquez un nom de file d'attente dans la planification XLANG.%1%0
E_BTW_MSMQ_INVALID_FIELD_TYPE | 0x5D05 | Le type de champ spécifié pour le champ "%2" de message "%1" n'est pas valide.%0
E_BTW_MSMQ_PORT_NOT_BOUND | 0x5D06 | Le port Message Queuing %1 n'est pas lié.%1%0
E_BTW_MSMQ_QUEUE_NOT_TRANSACTIONAL | 0x5D10 | Les propriétés transactionnelles de la file d'attente ne sont pas correctes.%1%0
E_BTW_MSMQ_OPEN_ACCESSDENIED | 0x5D11 | Une erreur de refus d'accès à Message Queuing s'est produite lors de l'ouverture de la file. Comparez le rôle accessRole spécifié pour la file dans la planification XLANG aux droits associés à l'utilisateur actuel.%1%0
E_BTW_MSMQ_OPEN_GENERALFAILURE | 0x5D12 | Un échec s'est produit dans Message Queuing lors de l'ouverture de la file. Reportez-vous à la documentation concernant Message Queuing dans Windows 2000 afin de rechercher le code d'erreur et d'effectuer le diagnostic approprié.%1%0
E_BTW_MSMQ_PORT_NOT_CREATABLE | 0x5D13 | Un port implémenté à l'aide d'une file d'attente de messages doit avoir un nom de file d'attente.%0
E_BTW_MSMQ_GENERAL_QUEUE_ACCESS_FAILURE | 0x5D14 | Une défaillance de Message Queuing s'est produite lors de l'accès à la file d'attente. Reportez-vous à la documentation concernant Message Queuing dans Windows 2000 afin de rechercher le code d'erreur et d'effectuer le diagnostic approprié.%1%0
E_BTW_MSMQ_INVALID_MESSAGE_VT_TYPE | 0x5D20 | Le format du message de Message Queuing est inconnu.%1%0
E_BTW_MSMQ_MESSAGE_UNKNOWN_MESSAGETYPE | 0x5D21 | Type de message de Message Queuing inconnu. Impossible d'identifier le type à partir du message.%1%0
E_BTW_MSMQ_MESSAGE_UNAUTHENTICATED | 0x5D22 | Le message de Message Queuing n'est pas authentifié mais le port accepte uniquement des messages authentifiés.%1%0
E_BTW_MSMQ_MESSAGE_INCORRECT_AUTHENTICATE_LEVEL | 0x5D23 | Le message de Message Queuing n'est pas authentifié au niveau demande.%1%0
E_BTW_MSMQ_MESSAGE_INVALID_MESSAGE | 0x5D24 | Corps du message de Message Queuing non valide.%1%0
E_BTW_MSMQ_MESSAGE_NOT_SEND | 0x5D25 | Impossible d'envoyer le message Message Queuing.%1%0
E_BTW_MSMQ_MESSAGE_SCHEMAVALIDATION_FAILED | 0x5D26 | Le message de Message Queuing n'a pas été validé correctement par rapport au schéma fourni. Vérifiez le schéma et son chemin.%1%0
E_BTW_MSMQ_COULD_NOT_CREATE_MQMESSAGE | 0x5D27 | Impossible de convertir l'instance de message en message Message Queuing %1%0
E_BTW_MSMQ_NO_TRUSTRELATIONSHIP_FOR_USER | 0x5D28 | Impossible d'établir la relation d'approbation pour l'utilisateur fourni.%1%0
E_BTW_MSMQ_MESSAGE_EMPY_MESSAGE | 0x5D29 | Le corps du message de Message Queuing est vide.%1%0
E_BTW_MSMQ_MESSAGE_ONLY_ONE_EMPTY_XPATH_ALLOWED | 0x5D2A | Le message de Message Queuing peut posséder uniquement un champ doté d'un chemin d'accès de noeud vide (XPath).%0
E_BTW_MSMQ_MESSAGE_ONE_EMPTY_XPATH_NEEDED | 0x5D2B | Le message de Message Queuing doit posséder un champ doté d'un chemin d'accès de noeud vide (XPath).%0
E_BTW_MSMQ_MESSAGE_INVALID_MESSAGEBODY | 0x5D2C | Corps du message de Message Queuing non valide.%1%0
E_BTW_MSMQ_MESSAGE_INVALID_MESSAGESTRING | 0x5D2D | Le corps du message de Message Queuing possède une chaîne incorrecte.%1%0
E_BTW_MSMQ_MESSAGE_UNKNOWN_MESSAGE | 0x5D2E | Le message de Message Queuing est incorrect ou inconnu et a été déplacé dans la file d'attente suspendue.%1%0
E_BTW_MSMQ_MESSAGE_TYPE_CONFLICTING_SCHEMA | 0x5D2F | Les messages de Message Queuing "%1" et "%2", qui sont de type "%3" sur le port "%4", possèdent des représentations de spécification conflictuelles. Ceci peut être dû au fait que le nom, le type ou la requête xpath ne correspondent pas à l'un des champs figurant dans les deux représentations.%0
E_BTW_MSMQ_DOCUMENT_FIELD_TYPE_NOT_STRING | 0x5D30 | Un champ "%1" de message de Message Queuing, qui possède un chemin de noeud vide (XPath), doit être de type chaîne de données.%0
E_BTW_MSMQ_DOCUMENT_FIELD_CANNOT_CONVERT_TO_STRING | 0x5D31 | Un champ de message de Message Queuing n'a pas pu être converti en chaîne.%1%0
E_BTW_MSMQ_DOCUMENT_FIELD_CONVERTION_FAILURE | 0x5D32 | Le champ d'un message de Message Queuing n'a pas pu être converti.%1%0
E_BTW_CANT_DISPOSE_MESSAGE | 0x6001 | L'instance de planification XLANG était liée à une file qui a reçu un message incorrect. Le moteur de XLANG Scheduler n'a pas pu transférer ce message dans la file d'attente suspendue, c'est pourquoi l'instance de planification a été interrompue.%0

Voir aussi

Configuration de l'Observateur d'événements pour les erreurs de BizTalk Server


Concepts

Cette section présente les concepts essentiels à la compréhension de la console Administration de BizTalk Server. Elles décrit des tâches administratives telles que la création d'un groupe de serveurs, la définition de fonctions de réception et la création de bases de données pour gérer, afficher et consigner les activités de documents dans Microsoft BizTalk Server 2000.

Les concepts suivants sont abordés dans cette section :

  • Vue d'ensemble de WMI

  • Environnement de Administration de BizTalk Server

  • Cache d'administration

  • Gestion des bases de données BizTalk Server

  • Groupes et serveurs

  • Traitement des erreurs de serveur

  • Fonctions de réception

  • Utilisation des files d'attente

  • Privilèges d'administration


Vue d'ensemble de WMI

L'infrastructure de gestion Windows (WMI, Windows Management Instrumentation) est une couche de gestion de données incluse dans Microsoft Windows 2000. Microsoft BizTalk Server 2000 utilise la couche WMI pour encapsuler des fonctions administratives. Lorsque vous utilisez la console Administration de BizTalk Server pour changer des paramètres de groupe, de serveur et de file d'attente, les nouvelles valeurs sont stockées dans la base de données Gestion d'échanges BizTalk par le biais du fournisseur BizTalk Server WMI. Dans BizTalk Server 2000, ce fournisseur WMI utilise une base de données Microsoft SQL Server pour stocker des objets administratifs. WMI prend en charge une API (Application Programming Interface) de scripts uniforme qui permet aux applications et aux scripts d'accéder au fournisseur WMI sur un ordinateur local ou un ordinateur distant.

Remarques

  • WMI impose des restrictions sur la syntaxe et les caractères valides d'un chemin d'objet WMI. La liste suivante présente les caractères non valides. ` ! @ # $ % ^ & * ( ) + = [ ] { } | \\ ;\" '< > , .?

    N'utilisez pas ces caractères lors de la création d'un nom de groupe de serveurs.

  • Tous les horodatages sont créés en utilisant l'heure locale sur Microsoft SQL Server. Le fournisseur WMI fait toutefois référence à tous les horodatages en heure UTC (Coordinated Universal Time). La console d'administration reconvertit ensuite les horodatages en heure locale pour affichage.

  • Pour accéder à la couche de base de données WMI par programme, vous pouvez utiliser le fichier InterchangeProvSchema.mof qui se trouve dans le dossier \Program Files\Microsoft BizTalk Server\Setup. Ce fichier contient les classes WMI correspondant aux objets Administration. Pour plus d'informations sur la programmation d'applications WMI, visitez le site Web MSDN Online Library (en anglais) msdn.microsoft.com/library/default.asp, et recherchez « WMI Application Programming ».


Environnement de Administration de BizTalk Server

Cette section traite des rubriques suivantes :

  • Interface utilisateur de la console Administration de BizTalk Server

  • Touches de raccourci de la console Administration de BizTalk Server


Interface utilisateur de la console Administration de BizTalk Server

La console Administration de BizTalk Server (également appelée console d'administration) est un composant logiciel enfichable MMC qui fournit une représentation visuelle des composants BizTalk Server gérés par un administrateur système. Le côté gauche de la console, appelé arborescence de console, est composé de dossiers et de sous-dossiers qui représentent différents éléments, tels que des groupes de serveurs. Le côté droit de la console, appelé volet des détails, contient des informations sur l'élément sélectionné dans l'arborescence de la console.

Graphiquement, Microsoft BizTalk Server 2000 est affiché sous la forme d'un sous-élément de la racine de la console du côté gauche de la console d'administration. Chaque groupe de serveurs configuré dans BizTalk Server est affiché dans un sous-dossier séparé ; il est composé de files d'attente et de fonctions de réception pour ce groupe, ainsi que des noms des serveurs faisant partie du groupe. Développez un élément dans l'arborescence de la console pour afficher des détails complémentaires le concernant dans le volet des détails de la console d'administration. Vous pouvez cliquer avec le bouton droit sur n'importe quel élément pour le configurer ou pour créer de nouveaux éléments.

Voir aussi

Ouverture de Administration de BizTalk Server


Touches de raccourci de la console Administration de BizTalk Server

Les touches de raccourci permettent d'effectuer certaines tâches sur la console Administration de BizTalk Server. Le tableau suivant présente les touches de raccourci de la console MMC.

Remarque

  • Le clavier numérique permet d'obtenir la fonctionnalité non incluse dans la liste pour déplacer le pointeur de la souris à l'aide des Touches souris. Pour plus d'informations sur les Touches souris dans Windows 2000 Server et l'aide de Advanced Server, voir Utiliser le clavier pour déplacer le pointeur de la souris. Pour plus d'informations sur les Touches souris dans l'aide de Windows 2000 Édition Professionnelle, voir Déplacer le pointeur à l'aide des Touches souris.

Appuyez sur | Pour
F5 | Rafraîchir la console Administration de BizTalk Server. Cette touche de raccourci rafraîchit l'élément sélectionné dans l'arborescence de la console.
ALT+F4 | Fermez Administration de BizTalk Server.
ALT+- (signe moins) | Afficher le menu de la fenêtre pour la fenêtre de console active.
MAJ+F10 | Afficher le menu Action associé à l'élément sélectionné.
ALT+A | Afficher le menu Action associé à l'élément sélectionné.
ALT+H | Afficher le menu Affichage.
F1 | Afficher l'aide en ligne pour l'élément sélectionné.
ALT+ENTRÉE | Afficher la boîte de dialogue de propriétés de l'élément sélectionné, le cas échéant.

Voir aussi

Ouverture de Administration de BizTalk Server


Cache d'administration

Lorsque vous démarrez BizTalk Server, tous les éléments de la console Administration de BizTalk Server tels que les groupes de serveurs, les propriétés de groupes de serveurs, les fonctions de réception, les connexions aux bases de données de files d'attente partagées et Suivi, sont stockés dans le cache d'administration. Tous les éléments du cache sont rafraîchis toutes les 50 secondes, à l'exception des connexions à la base de données de serveur et des propriétés de serveur. Cela signifie que si vous modifiez les propriétés générales d'un groupe de serveurs, telles que l'hôte SMTP ou l'URL de réponse d'échange au format Reliable, les modifications sont prises en compte dans les 50 secondes. Si toutefois vous modifiez des propriétés du serveur, telles que Nombre maximal de threads de travail autorisé par processeur, vous devez arrêter et redémarrer le serveur sur lequel vous avez modifié la configuration afin que la modification puisse être stockée dans le cache. Sinon, en cas de modification d'une connexion aux bases de données Gestion d'échanges BizTalk, Suivi ou Files d'attente partagées, vous devez arrêter et redémarrer les serveurs dans le groupe et arrêter l'application Échange BizTalk Server.

Voir aussi

Configuration des propriétés générales d'un groupe de serveurs

Arrêt de l'application Échange BizTalk Server

Démarrage d'un serveur dans un groupe

Arrêt d'un serveur dans un groupe


Gestion des bases de données BizTalk Server

Les trois bases de données associées aux services d'échanges BizTalk sont les suivantes :

  • Gestion d'échanges BizTalk

  • Suivi

  • Files d'attente partagées

La base de données Gestion d'échanges BizTalk stocke des informations sur toutes les configurations de serveur, notamment les paramètres de groupe et de serveur, ainsi que les fonctions de réception. La configuration de ces objets d'administration est gérée par la console Administration de BizTalk Server ou par programme. La base de données Gestion d'échanges BizTalk stocke également toutes les informations de configuration d'échange pour les canaux, les ports d'échanges et autres objets d'échange. Bien que les informations de configuration d'échange soient stockées dans cette base de données, la configuration des objets est assurée par le Gestionnaire d'échanges BizTalk ou par programme par le biais du modèle d'objet de configuration d'échanges BizTalk. Pour plus d'informations sur la configuration de canaux, de ports d'échanges, etc., voir Utilisation du Gestionnaire d'échanges BizTalk ou Référence du modèle objet.

La base de données Suivi tient un journal de tous les échanges, documents et réceptions traités par BizTalk Server. Pour plus d'informations sur la base de données Suivi, voir Base de données Suivi. Pour configurer les paramètres de suivi, voir Configuration des propriétés de suivi d'un groupe de serveurs. Pour suivre des champs ou des données d'instance de document spécifiques, voir Définition des propriétés de canal.

La base de données Files d'attente partagées contient des documents en cours ou en attente de traitement. Les documents sont supprimés plus tard, une fois traités. Pour plus d'informations sur la base de données Files d'attente partagées, voir Base de données Files d'attente partagées.

Cette section traite des rubriques suivantes :

  • Gestion de la base de données Gestion d'échanges BizTalk

  • Gestion des bases de données de groupe de serveurs BizTalk


Gestion de la base de données Gestion d'échanges BizTalk

Pour la plupart des mises en oeuvre professionnelles, une base de données Gestion d'échanges BizTalk centrale sert à configurer plusieurs groupes de serveurs, serveurs, canaux ou ports d'échanges. Les fournisseurs tiers constituent une exception à cette règle, à qui il faudra éventuellement une base de données Gestion d'échanges BizTalk séparée pour chaque client en fonction de leurs besoins professionnels spécifiques. Dans tous les autres cas, nous vous recommandons d'utiliser une base de données Gestion d'échanges BizTalk centrale pour tous les groupes de serveurs BizTalk.

Parfois, il peut être nécessaire de retirer des serveurs de la base de données Gestion d'échanges BizTalk centrale ; par exemple, pour effectuer la maintenance du serveur sur lequel votre base de données d'échanges BizTalk réside. Dans ce cas, tous les groupes de serveurs devront alors pointer sur une base de données Gestion d'échanges BizTalk répliquée pour que votre entreprise BizTalk Server puisse fonctionner correctement. Il vous faudra peut-être aussi déplacer des serveurs entre une ou plusieurs bases de données Gestion d'échanges BizTalk. Supposons, par exemple, que vous êtes un fournisseur tiers avec trois clients, A, B et C. Les commandes du client A ont diminué tandis que celles des clients B et C ont augmenté. Vous pouvez déplacer les serveurs qui étaient associés à la base de données Gestion d'échanges BizTalk du client A dans les bases de données associées aux clients B et C.

Cette section traite des rubriques suivantes :

  • Modification de la base de données Gestion d'échanges BizTalk

  • Suppression de serveurs de la base de données Gestion d'échanges BizTalk

  • Déplacement des serveurs entre les bases de données Gestion d'Échanges BizTalk

  • Déplacement de serveurs distants entre les bases de données Gestion d'échanges BizTalk


Modification de la base de données Gestion d'échanges BizTalk

Il existe deux méthodes pour configurer la base de données Gestion d'échanges BizTalk :

  • Utiliser les options de configuration disponibles pendant l'installation.

  • Utiliser la console Administration de BizTalk Server pour changer le serveur dans le noeud Microsoft BizTalk Server 2000.

Si vous souhaitez centraliser la gestion de tous vos serveurs BizTalk sur un serveur unique, pendant l'installation, configurez tous les serveurs pour qu'ils pointent sur une base de données Gestion d'échanges BizTalk centrale. De cette manière, chaque fois que vous ouvrirez la console Administration de BizTalk Server sur l'un de ces serveurs BizTalk, les serveurs répertoriés dans le noeud Microsoft BizTalk Server 2000 pointeront sur la même base de données Gestion d'échanges BizTalk et pourront faire l'objet d'une gestion centralisée. Une fois qu'une collection de groupes de serveurs pointe sur une base de données Gestion d'échanges BizTalk centrale, il n'est pas nécessaire de changer de base de données Gestion d'échanges BizTalk, sauf pour déconnecter cette base de données à des fins de maintenance. Dans ce cas, utilisez la console Administration de BizTalk Server pour que tous les groupes de serveurs du noeud Microsoft BizTalk Server 2000 pointent sur une réplication de la base de données centrale d'origine. Ne pointez pas temporairement des groupes de serveurs sur une autre base de données Gestion d'échanges BizTalk centrale à laquelle d'autres groupes de serveurs sont associés, car il pourrait être difficile de rétablir la configuration de base de données Gestion d'échanges BizTalk d'origine.

Voir aussi

Groupes BizTalk Server

Modification de la base de données Gestion d'échanges BizTalk d'un serveur

Configuration de la base de données Gestion d'échanges BizTalk

Déplacement des serveurs entre les bases de données Gestion d'échanges BizTalk


Suppression de serveurs de la base de données Gestion d'échanges BizTalk

Si vous supprimez tous les serveurs BizTalk de la base de données Gestion d'échanges BizTalk centrale, le contenu de la base de données reste intact. Ce contenu reste aussi intact si votre système comporte plusieurs bases de données Gestion d'échanges BizTalk et si vous supprimez tous les serveurs BizTalk de l'une d'entre elles. Vous pouvez ajouter de nouveaux serveurs BizTalk à la base de données Gestion d'échanges BizTalk centrale en exécutant l'Assistant Configuration de base de données BizTalk Server et en sélectionnant une base de données existante dans la page Configurer une base de données Gestion d'échanges BizTalk. Pour plus d'informations sur l'ajout ou la modification de la base de données Gestion d'échanges BizTalk d'un serveur, voir Modification de la base de données Gestion d'échanges BizTalk d'un serveur.

Voir aussi

Modification de la base de données Gestion d'échanges BizTalk d'un serveur


Déplacement des serveurs entre les bases de données Gestion d'Échanges BizTalk

Si vous prévoyez de déplacer temporairement un serveur BizTalk d'une base de données Gestion d'échanges BizTalk centrale à une autre, au moins un autre serveur BizTalk doit rester en place dans l'un des groupes de serveurs de la base de données centrale d'origine. Cela vous permet de restaurer facilement le serveur BizTalk dans la base de données centrale d'origine. Sinon, pour ajouter un nouveau serveur BizTalk à la base de données centrale, vous devez exécuter l'Assistant Configuration de base de données BizTalk Server et sélectionner une base de données existante dans la page Configurer une base de données Gestion d'échanges BizTalk. Pour plus d'informations sur l'ajout ou la modification de la base de données Gestion d'échanges BizTalk d'un serveur, voir Modification de la base de données Gestion d'échanges BizTalk d'un serveur.

Voir aussi

Modification de la base de données Gestion d'échanges BizTalk d'un serveur

Groupes et serveurs


Déplacement de serveurs distants entre les bases de données Gestion d'échanges BizTalk

Si vous tentez d'ajouter à une base de données Gestion d'échanges BizTalk un serveur distant qui se trouvait à l'origine dans une autre base de données Gestion d'échanges BizTalk centrale, le message d'erreur suivant apparaît dans le journal d'événements de Windows :

Impossible de créer une nouvelle instance de la classe WMI "MicrosoftBizTalkServer_Server" dans le fournisseur BizTalk Server WMI. Il est possible que le serveur <nom du serveur> appartienne déjà à une autre installation BizTalk Server.

Cette erreur signifie qu'une tentative a été effectuée pour ajouter un serveur distant qui se trouvait initialement dans une autre base de données centrale. Si cette procédure a été effectuée dans le composant Administration de BizTalk Server, la console tente de déterminer si le serveur distant appartient à un groupe de la base de données centrale distante. Pour cela, elle interroge interroge le fournisseur WMI (Windows Management Instrumentation) du serveur distant. Si le serveur appartient à un groupe de serveurs de l'autre base de données centrale, un message d'erreur de la console d'administration apparaît et indique que vous ne pouvez pas ajouter un serveur distant appartenant déjà à un groupe d'une autre base de données centrale.

Voir aussi

Erreur lors du déplacement d'un serveur distant vers une autre base de données Gestion d'échanges BizTalk

Vue d'ensemble de WMI


Gestion des bases de données de groupe de serveurs BizTalk

Chaque groupe de serveurs utilise deux bases de données, la base de données Files d'attente partagées et la base de données Suivi. La première contient tous les documents et échanges qui sont soumis à BizTalk Server 2000 pour traitement et transmission. La seconde assure le suivi et le stockage des échanges entrants et sortants à des fins d'audit, de rapprochement et de résolution de conflits.

Pour simplifier l'organisation de la configuration logique de vos serveurs et de vos groupes, il est important de donner des noms uniques aux bases de données Files d'attente partagées et Suivi qui sont associées à chaque groupe de serveurs. Par exemple, si vous avez deux groupes de serveurs, l'un nommé Group1, l'autre Group2, étiquetez les bases de données du premier groupe SharedQueue1 et Tracking1, celles du deuxième groupe SharedQueue2 et Tracking2.

Remarque

  • La base de données Gestion d'échanges BizTalk est différente des bases de données Files d'attente partagées et Suivi. Cette base de données permet de stocker des informations sur la configuration de plusieurs groupes et serveurs, ainsi que de stocker des informations sur la configuration des services d'échanges BizTalk . Elle ne traite ni les transmissions de documents et d'échanges, ni les activités de suivi de documents et d'échanges.

Cette section traite des rubriques suivantes :

  • Base de données de files d'attente partagée

  • Base de données de suivi


Base de données de files d'attente partagée

  • Tous les serveurs d'un groupe de serveurs partagent une base de données Files d'attente partagées unique. Tous les documents et échanges qui sont soumis aux serveurs d'un groupe sont stockés dans cette base de données jusqu'à ce qu'ils soient traités par BizTalk Server.

  • La base de données Files d'attente partagées est graphiquement représentée sur la console Administration de BizTalk Server sous la forme d'une série de files d'attente fournissant des informations sur l'avancement d'un échange ou d'un document dans BizTalk Server. Les échanges et les documents sont placés dans l'une des files d'attente suivantes pendant leur traitement.
    • File de travail. Liste d'échanges et de documents actuellement traités par BizTalk Server.

    • File d'attente planifiée. Liste d'échanges et de documents qui ont été traités par BizTalk Server et sont en attente de transmission conformément à la fenêtre de service. Pour plus d'informations sur la fenêtre de service, voir propriété ServiceWindowInfo.

    • File de nouvel essai. Liste d'échanges et de documents soumis à nouveau et messages au format Reliable attendant des accusés de réception.

    • File d'attente interrompue. Liste d'échanges et de documents dont le traitement a échoué pour diverses raisons, notamment des erreurs d'analyse, des erreurs de sérialisation, des erreurs de transmission, ou encore l'absence d'une configuration de canal appropriée.

Voir aussi

Configuration des propriétés de connexion d'un groupe de serveurs

Groupes et serveurs

ServiceWindowInfo

Gestion des files d'attente

Utilisation des files d'attente


Base de données de suivi

Tous les serveurs d'un groupe de serveurs partagent une base de données Suivi unique qui stocke toutes les informations relatives aux activités d'échanges et de documents dans BizTalk Server. La base de données Suivi assure le suivi de l'état d'un échange ou d'un document en transit dans le serveur. Si, par exemple, vous souhaitez vérifier qu'une commande a été envoyée à un partenaire commercial, vous pouvez interroger la base de données Suivi. Cette base de données vérifie également que l'envoi ou la réception d'échanges et de documents par BizTalk Server a abouti, ou peut fournir des informations pour des rapports, par exemple des temps de transmission ou des réponses de réception.

Définition des paramètres de suivi et de journalisation pour la base de données Suivi

Sur la console Administration de BizTalk Server, vous pouvez choisir de suivre ou non les échanges et les documents. Pour plus d'informations sur la configuration des paramètres de suivi pour un groupe de serveurs, voir Configuration des propriétés de suivi d'un groupe de serveurs. Si vous activez le suivi, les options suivantes sont disponibles :

  • Consigner l'échange entrant dans un journal. Les documents reçus par un serveur BizTalk sont stockés dans la base de données Suivi. Les documents entrants fournissent un enregistrement d'activité pour la résolution de conflits. Cette option est cochée par défaut.

  • Consigner l'échange sortant dans un journal. Les documents envoyés par BizTalk Server sont stockés dans la base de données Suivi. Cette option est cochée par défaut.

  • Consigner le message MIME d'origine dans un journal. Les documents à codage MIME sont stockés dans la base de données Suivi dans leur format de message d'origine avant d'être décodés. Cette option est désactivée par défaut.

Voir aussi

Configuration des propriétés de connexion d'un groupe de serveurs

Configuration des propriétés de suivi d'un groupe de serveurs

Démarrage d'un serveur dans un groupe

Arrêt d'un serveur dans un groupe

Utilisation du suivi de documents BizTalk


Groupes et serveurs

Dans un environnement d'échange de données qui prend en charge le traitement d'un grand nombre de documents, plusieurs serveurs et bases de données peuvent être nécessaires. Les entreprises doivent disposer d'un outil permettant de centraliser et de gérer cet échange.

Microsoft BizTalk Server 2000 centralise l'échange de documents en assemblant les serveurs en groupes et en gérant et configurant ces groupes de serveurs au moyen de la console Administration de BizTalk Server.

Cette section traite des rubriques suivantes :

  • Groupes BizTalk Server

  • Relations entre les groupes et les serveurs

  • États des groupes

  • Serveurs BizTalk


Groupes BizTalk Server

Un groupe de serveurs constitue le principe d'organisation clé de la console Administration de BizTalk Server. Les groupes de serveurs sont des collections des serveurs individuels faisant l'objet d'une gestion, d'une configuration et d'une surveillance centralisées.

Les serveurs d'un groupe de serveurs BizTalk ont les éléments suivants en commun :

  • Une base de données Files d'attente partagées qui assure la persistance de tous les documents jusqu'à l'aboutissement de leur traitement.

  • Une base de données Suivi qui permet de consigner l'activité liée aux documents et aux échanges, et d'exécuter des rapports.

  • Des fonctions de réception.

  • Tous les composants dont le serveur a besoin lors du traitement de documents et d'échanges, notamment les composants de transport, les composants d'intégration d'application (AIC), etc.

Une base de données Gestion d'échanges BizTalk centrale gère plusieurs groupes et plusieurs serveurs qui partagent les mêmes informations de configuration. Ces informations spécifient la logique de traitement de documents pour les serveurs. Spécifiez la même base de données Gestion d'échanges BizTalk pour chaque installation de serveur afin de pouvoir administrer à distance chaque serveur et chaque groupe à partir de la console d'administration. En outre, si vous définissez plusieurs groupes de serveurs par souci d'évolutivité et d'amélioration des performances, utilisez uniquement une base de données Gestion d'échanges BizTalk centrale. Sinon, ses serveurs ne peuvent pas partager la même configuration de Gestion d'échanges BizTalk.

Voir aussi

Ajout, suppression et configuration d'un groupe de serveurs

Serveurs BizTalk

Fonctions de réception

Relations entre les groupes et les serveurs

Utilisation des files d'attente


Relations entre les groupes et les serveurs

Chaque installation de BizTalk Server 2000 doit avoir au moins un groupe de serveurs. La relation entre les groupes et les serveurs est la suivante :

  • Un serveur individuel peut appartenir à un seul groupe de serveurs.

  • Tous les serveurs d'un groupe utilisent la même file d'attente partagée et les mêmes fonctions de réception.

  • Tous les serveurs d'un groupe partagent les mêmes composants, tels que les composants de transport, les composants d'intégration d'application (AIC), pour traiter les échanges et les documents.

L'illustration suivante montre la relation entre des groupes de serveurs dans BizTalk Server 2000. Les serveurs 1-6 sont installés avec Microsoft BizTalk Server 2000. Les serveurs A-D sont installés avec Microsoft SQL Server et sont dédiés à la gestion de base de données. Bien que les serveurs A-D soient dédiés aux bases de données Suivi ou Files d'attente partagées, la base de données Gestion d'échanges BizTalk peut résider sur l'un de ces serveurs car elle est relativement petite et n'utilise pas le processeur de façon intensive. Il est instamment recommandé de placer les bases de données Files d'attente partagées et Suivi sur deux serveurs distincts dédiés à la gestion de base de données, et d'utiliser une base de données Gestion d'échanges BizTalk unique centrale pour tous les groupes de serveurs.

Configuration logique des groupes et des serveurs

Configuration logique des groupes et des serveurs

Configuration logique des groupes et des serveurs
Groupe 2
Groupe 1
Serveur C de BdD de suivi
Serveur A de BdD
de suivi
Serveur D de
files
d'attente
partagées
Serveur B de
files
d'attente
partagées
BizTalk
Server 3
BizTalk
Server 2
BizTalk
Server 6
BizTalk
Server 5
BizTalk
Server 4
BizTalk
Server 1
Serveur A de base de données Gestion d'échanges BizTalk

Voir aussi

Gestion des bases de données BizTalk Server


États des groupes

La console Administration de BizTalk Server énumère les groupes de serveur et indique si chaque groupe peut se connecter aux bases de données Suivi ou Files d'attente partagées. Lorsque vous cliquez sur Microsoft BizTalk Server 2000, les états des groupes apparaissent sous la barre d'état dans le volet des détails. Les états des groupes sont :

  • État de connexion Indique que le groupe est connecté aux bases de données Suivi et Files d'attente partagées.

  • Échec de la connexion de suivi. Indique que le groupe n'est pas connecté à la base de données Suivi.

  • Échec de la connexion des files d'attente partagées. Indique que le groupe n'est pas connecté à la base de données Files d'attente partagées.

  • Échec des connexions du suivi et des files d'attente partagées. Indique que le groupe n'est pas connecté aux bases de données Suivi et Files d'attente partagées.


Serveurs BizTalk

Un serveur d'un groupe de serveurs héberge les services d'échanges BizTalk appropriés, tels que la conversion de données, le cryptage, la signature numérique et le suivi des documents, pour gérer l'échange de documents entre d'autres serveurs et d'autres applications externes au groupe de serveurs BizTalk. Chaque serveur place en file d'attente et retire des files d'attente des documents entrants et sortants dans la base de données Files d'attente partagées, en appelant les méthodes COM (Component Object Mode) appropriées pour transformer, sérialiser, signer, crypter, décrypter et transporter des documents. Pour les applications qui n'écrivent pas sur les interfaces COM de BizTalk Server, BizTalk Server 2000 utilise des fonctions de réception pour recevoir les données.

Selon vos besoins professionnels, vous pouvez configurer de façon identique tous les serveurs d'un groupe. Cela vous permet d'ajouter facilement des serveurs distants dans un groupe. Sinon, vous pouvez configurer certains serveurs d'un groupe de façon à les dédier à la réception de documents.

Cette section traite des rubriques suivantes :

  • Description des propriétés d'un serveur

  • États d'un serveur

Voir aussi

Groupes BizTalk Server

Relations entre les groupes et les serveurs


Description des propriétés d'un serveur

Lorsque vous configurez un serveur dans un groupe, il convient de trouver un compromis entre l'optimisation du débit et les performances du serveur. Vos besoins professionnels, la capacité du serveur et la bande passante du réseau sont autant de facteurs dont il faut tenir compte lors de la configuration des propriétés d'un serveur. Nous vous recommandons d'expérimenter différentes combinaisons lors des tests de paramètres pour déterminer la configuration la mieux adaptée à votre installation.

Nombre maximal de threads de fonction de réception autorisé

Le nombre maximal de threads de fonctions de réception est défini au niveau d'un processeur. La plage de valeurs pour cette option est comprise entre 1 et 128. Ajustez cette valeur pour optimiser les performances des fonctions de réception utilisées sur le serveur. Dans la plupart des cas, l'augmentation du nombre de threads de fonctions de réception accroît le débit de ces fonctions sur le serveur.

Participer au traitement de l'élément de travail

Lorsque la case Participer au traitement de l'élément travail est activée, le serveur traite les documents dans la file de travail. Lorsqu'elle est désactivée, le serveur ne traite pas de documents dans la file de travail. Il convient éventuellement de désactiver cette option dans deux cas. La première correspond à la réception de messages d'une file d'attente de messages. Actuellement, la fonction Message Queuing prend uniquement en charge des lectures transactionnelles locales. Cela signifie que vos files d'attente doivent résider sur un serveur installé avec Microsoft BizTalk Server 2000 et que la configuration doit prévoir qu'un seul serveur pourra lire dans ces files d'attente. Pour accélérer la réception sur le serveur où réside la file d'attente des messages, désactivez la case Participer au traitement de l'élément travail.

Le second cas se produit lorsque vous souhaitez optimiser les performances des clusters BizTalk Server. Par exemple, vous pouvez dédier l'un des serveurs du groupe BizTalk Server au traitement des tâches d'administration.

Nombre maximal de threads de travail autorisé par processeur

Le nombre maximal de threads de travail est défini au niveau du processeur. Les valeurs possibles pour cette option sont comprises entre 1 et 128. Une valeur faible peut provoquer un goulot d'étranglement. Une valeur élevée peut entraîner une dégradation des performances.

Les options Nombre maximal de threads de travail autorisé par processeur et Intervalle entre appels de BizTalk Server Scheduler sont deux facteurs ayant une incidence sur le volume du trafic dans les bases de données Microsoft SQL Server. Vous pouvez limiter le trafic dans les bases de données SQL en choisissant une faible valeur pour l'option Nombre maximal de threads de travail par processeur et une valeur élevée pour Intervalle entre appels BizTalk Server Scheduler. De même, vous pouvez accroître le trafic dans les bases de données en augmentant le nombre maximal de threads de travail et en diminuant l'intervalle entre les appels du BizTalk Server Scheduler.

Remarque

  • Désactivez la case Participer au traitement de l'élément travail si vous ne souhaitez pas traiter d'éléments de travail sur ce serveur. Ne mettez pas à zéro l'option Nombre maximal de threads de travail par processeur.

Intervalle entre appels de BizTalk Server Scheduler (en millisecondes)

La plage de valeurs de l'option Intervalle entre appels BizTalk Server Scheduler est comprise entre 1 et 4 294 967 295. Une thread interroge les éléments disponibles dans la file d'attente de travail. L' Intervalle entre appels BizTalk Server Scheduler contrôle à quelle fréquence la thread interroge la file d'attente de travail. Si vous ne recevez pas beaucoup de données, choisissez une valeur élevée. Si vous en recevez beaucoup, choisissez une valeur peu élevée.

Voir aussi

Configuration d'un serveur dans un groupe


États d'un serveur

La console Administration de BizTalk Server répertorie les serveurs dans un groupe de serveurs et en renvoie la liste. Elle peut renvoyer les états suivants pour les serveurs sous la barre d'état dans le volet des détails :

  • En cours d'exécution. Indique que le serveur est en cours d'utilisation.

  • Accès refusé. Indique que vous n'avez pas de privilèges d'administrateur Windows 2000 sur un serveur.

  • Erreur Indique si un serveur enregistré dans un groupe de serveurs s'est vu retirer BizTalk Server 2000.

  • Arrêté. Indique si un administrateur a arrêté un serveur.

  • Inconnu. Indique si un serveur enregistré dans un groupe de serveurs n'est pas disponible pour une raison inconnue. Lorsque cela se produit, il est probable que vous avez perdu toute connectivité avec le serveur.

Voir aussi

Privilèges d'administration


Traitement des erreurs de serveur

Vous pouvez configurer le traitement des erreurs dans BizTalk Server 2000 au niveau du serveur par le biais de l'Observateur d'événements Windows 2000, qui est inclus dans la console Administration de BizTalk Server. L'Observateur d'événements Windows 2000 apparaît dans l'arborescence de la console d'administration.

Journalisation des événements

L'Observateur d'événements Windows 2000 crée un journal contenant des informations sur les incidents matériels, logiciels et système. Dans la console d'administration, vous pouvez personnaliser l'Observateur d'événements pour afficher les erreurs liées d'application et de XLANG Scheduler spécifiques de BizTalk Server 2000, pour optimiser le dépannage de BizTalk Server. Pour plus d'informations sur la personnalisation de l'Observateur d'événements concernant les erreurs BizTalk Server et XLANG Scheduler, voir Gestion de l'Observateur d'événements.

Pour plus d'informations sur l'Observateurs d'événements dans l'aide de Windows 2000 Server, dans le chapitre Observateur d'événements, voir "Utilisation de l'Observateur d'événements".

Remarque

  • Toutes les erreurs d'application relatives à BizTalk Server 2000 sont définies comme étant des erreurs BizTalk Server ou XLANG Scheduler.

Voir aussi

Gestion de l'Observateur d'événements


Fonctions de réception

Si vous devez recevoir des documents provenant d'un emplacement de réception afin de les soumettre à BizTalk Server, vous pouvez configurer les appels soumis par programme. Pour plus d'informations sur les appels soumis, voir Envoi ou méthode Submit. Sinon, vous pouvez configurer des fonctions de réception pour traiter les données. Si, par exemple, vous devez recevoir des documents d'une organisation ou d'une application commerciale ne pouvant pas communiquer directement avec BizTalk Server par le biais d'une interface COM, vous pouvez faire appel à une fonction de réception pour soumettre les échanges et les documents à BizTalk Server. Sinon, si la réception doit se faire à partir d'une file d'attente de messages, vous pouvez utiliser une fonction de réception pour soumettre le document à BizTalk Server. BizTalk Server 2000 prend en charge deux types de fonction de réception : Fichier et Message Queuing.

Vous pouvez créer une fonction de réception générique pour BizTalk Server 2000 dans la console d'administration, dans laquelle vous définissez notamment le nom de la fonction de réception et la définition de document. Pour plus d'informations sur la configuration des fonctions de réception, voir Gestion des fonctions de réception d'un groupe de serveurs. Pour plus d'informations sur les propriétés avancées des fonctions de réception, voir Description des propriétés avancées d'une fonction de réception.

L'illustration suivante montre la relation entre l'application professionnelle d'envoi, le système de fichiers et une fonction de réception BizTalk Server générique.

Fonction de réception
Application professionnelle
d'envoi
Système de fichiers
Fonction de réception de fichiers BizTalk Server
BizTalk
Server
Soumettre

Cette section traite des rubriques suivantes :

  • Fonctions de réception disponibles

  • Préprocesseurs personnalisés

  • Instances multiples de types de fonction de réception

  • Description des fonctions de réception et du routage de documents

  • Description des propriétés avancées d'une fonction de réception


Fonctions de réception disponibles

Deux types de fonctions de réception sont disponibles dans BizTalk Server : Fichier et Message Queuing. Vos habitudes professionnelles déterminent le type de fonction de réception à utiliser et quand les utiliser.

Fonction de réception Fichier

Une fonction de réception Fichier est activée en présence d'une activité dans le répertoire d'interrogation. Pour l'utiliser, vous devez pouvoir modifier le répertoire d'interrogation. La fonction de réception Fichier retire les fichiers du répertoire et les soumet à BizTalk Server 2000.

Fonction de réception Message Queuing

Une fonction de réception Message Queuing est activée en fonction de l'activité dans une file d'attente des messages. Cette fonction de réception extrait l'échange ou le document de la file d'attente et le soumet à BizTalk Server 2000.

When you define the polling location for the message queue, use a format name instead of a path name.Lorsque vous définissez l'emplacement d'interrogation de la file des messages, remplacez le nom de chemin par le nom de format. BizTalk Server est conçu pour fonctionner avec des API (Application Programming Interfaces) Message Queing brutes et les appels API fonctionnent uniquement avec la propriété de nom de format. Utilisez le nom de format suivant lorsque vous configurez une fonction de réception de Message Queuing :

  • Direct=OS:<nom du serveur>\<nom de la file d'attente>

Remarque

  • Pour plus d'informations sur Message Queuing et le nom du format, visitez le site Web de MSDN Online Library (en anglais) (msdn.microsoft.com/library/default.asp), et visitez la page Platform SDK, Getting Started, Contents of the Platform SDK, Message Queuing Services.


Préprocesseurs personnalisés

Si vous devez traiter des documents avant de les soumettre à BizTalk Server, vous pouvez créer un préprocesseur personnalisé et configurer la fonction de réception pour appeler le préprocesseur. Si, par exemple, vous envoyez des données compressées et devez les décompresser avant de les soumettre à BizTalk Server pour traitement, configurez la fonction de réception de manière à appeler le préprocesseur personnalisé afin de décompresser les données.

Voir aussi

Identificateur de classe apparaissant dans la liste Préprocesseur

IBTSCustomProcess

Pré-traitement de documents dans une fonction de réception


Instances multiples de types de fonction de réception

Il peut exister plusieurs instances d'une fonction de réception. Par exemple, si plusieurs applications professionnelles utilisent une fonction de réception de fichier pour soumettre des documents et des échanges à BizTalk Server 2000, vous pouvez configurer une instance unique ou des instances multiples de cette fonction.

Remarque

  • Vérifiez que le nom de chaque fonction de réception créée est unique. Vous ne pouvez pas attribuer le même nom à plusieurs fonctions de réception.

Voir aussi

Gestion des fonctions de réception d'un groupe de serveurs


Description des fonctions de réception et du routage de documents

Lorsque vous configurez une fonction de réception, déterminez si les documents reçus par la fonction de réception bénéficient ou non d'un auto-routage. Les documents avec auto-routage contiennent toutes les informations de routage nécessaires ; dans les documents sans auto-routage, tout ou partie des informations de routage sont absentes.

Documents avec auto-routage

Dans les documents avec auto-routage, toutes les informations de routage nécessaires (identificateur d'organisation source, identificateur d'organisation de destination et définition de document) figurent dans les balises de routage qui sont définies par la spécification> de documents ou codées en dur dans le document, comme c'est le cas de X12 et EDIFACT. Tout document pour lequel vous pouvez créer une spécification dans l'Éditeur BizTalk peut être configuré comme document avec auto-routage. Les types courants de documents avec auto-routage sont XML, X12 et EDIFACT. Il n'est pas nécessaire de configurer des propriétés avancées dans la fonction de réception si un document bénéficie d'un auto-routage, sauf pour remplacer les données fournies dans le document.

Si les qualificateurs de l'organisation source ou de destination, ou bien la définition de documents sont absents dans le document, celui-ci est placé dans la file d'attente interrompue. En outre, si vous ne spécifiez pas de qualificateur d'organisation source ou de destination, BizTalk Server utilise la valeur par défaut Nom de l'organisation comme qualificateur d'organisation et se réfère au nom de l'organisation stocké dans la base de données Gestion d'échanges BizTalk.

Documents sans auto-routage

Dans les documents sans auto-routage, tout ou partie des informations de routage nécessaires sont absentes. En configurant la fonction de réception, vous devez définir les informations suivantes dans l'onglet Avancé de la boîte de dialogue Propriétés ou dans le document à fournir à la fonction de réception :

  • Identificateur d'organisation source, identificateur d'organisation de destination et définition de document.

—Ou—

  • Canal

Lorsque vous soumettez un document, BizTalk Server localise un canal pour traiter le document. Cela peut être mis en oeuvre de deux manières : en fournissant un nom de canal dans la fonction de réception ou en fournissant les identificateurs d'organisation source et de destination ainsi que la définition de document. Ces trois propriétés aident BizTalk Server à localiser le canal approprié. Par conséquent, si vous sélectionnez un canal, la définition de document et les options d'informations source et de destination ne sont pas disponibles car le canal fournit toutes les informations requises pour router le document.

Les types courants de documents sans auto-routage sont les documents provenant de sources multiples (source ouverte) ou ceux destinés à des destinations multiples (destination ouverte).

Configuration d'une fonction de réception pour gérer des documents provenant de sources multiples

Vous pouvez configurer une fonction de réception unique qui traite les documents sans auto-routage de façon à recevoir un type spécifique de documents provenant de sources multiples. Il s'agit d'un scénario de source ouverte. L'emplacement de l'organisation source, de l'organisation de destination, et les informations de définition de document doivent être contenus dans le document ou dans les paramètres soumis avec le document. Si, par exemple, vous souhaitez recevoir des ordres d'achats de plusieurs clients, mais ne souhaitez pas tous les envoyer à la même application de destination, configurez les propriétés de définition de document et d'identificateur d'organisation de destination dans la fonction de réception. Lorsque BizTalk Server analyse le document, il localise l'identificateur d'organisation du fournisseur, combine ces informations aux paramètres de la fonction de réception, trouve le canal approprié, puis traite le document.

Voir aussi

Configuration des propriétés avancées des fonctions de réception de fichier et Message Queuing

Gestion des fonctions de réception d'un groupe de serveurs

Définition des propriétés d'une organisation source


Description des propriétés avancées d'une fonction de réception

Vous pouvez utiliser des propriétés avancées pour configurer des types spéciaux de fonction de réception basés sur vos pratiques professionnelles.

Par exemple, vous pouvez définir des fonctions de réception pour soumettre :

  • des documents dont la propriété Source ouverte ou Destination ouverte est activée ;

  • des documents dont la propriété Pass-through est activée.

  • des documents qui spécifient un nom de canal ;

  • d'autres types de documents sans auto-routage.

Définition de la propriété Openness dans un document

Les options suivantes définissent la propriété Openness d'un document :

  • Non ouvert : Indique que la source et la destination sont toutes deux explicitement déclarées dans la fonction de réception ou l'instance du document.

  • Destination ouverte : Indique que les informations de destination ne sont pas explicitement déclarées dans le port d'échanges. La destination est spécifiée dynamiquement dans l'instance de document ou dans un paramètre d'envoi. Vous devez configurer la définition de document et les propriétés d'identificateur d'organisation source dans la fonction de réception ou dans l'instance de document afin de permettre à BizTalk Server de localiser le canal approprié.

  • Source ouverte : Indique que les informations source ne sont pas explicitement déclarées dans le canal. La source est plutôt dynamiquement spécifiée dans l'instance de document. Vous devez configurer la définition de document et les propriétés d'identificateur d'organisation de destination dans la fonction de réception ou dans l'instance de document pour permettre à BizTalk Server de localiser le canal approprié.

Configuration de fonction de réception avec transfert direct

Une fonction de réception configurée avec un transfert direct n'effectue pas l'analyse, le décryptage, la vérification de signature et les fonctions de décodage de BizTalk Server. Choisissez cette option lorsque vous envoyez des données d'objets binaires volumineux ou d'autres échanges n'imposant pas l'analyse, le décryptage et le décodage. Si vous configurez une fonction de réception en activant l'option Soumettre avec un indicateur direct, vous devez spécifier un canal. Sinon, BizTalk Server ne peut pas traiter le document.

Nom d'enveloppe

Si vous prévoyez de recevoir un échange entrant dans un fichier plat, spécifiez le format d'enveloppe dans la fonction de réception. L'enveloppe pointe sur une spécification indiquant à BizTalk Server comment ouvrir et interpréter l'échange. Si vous prévoyez de recevoir plusieurs fichiers plats dans un échange spécifique, les fichiers plats individuels doivent avoir des séparateurs (postfix ou préfixe). Infix n'est pas pris en charge. Cela doit être défini sur le noeud racine de la spécification d'enveloppe et de la spécification de document lors de la configuration des propriétés d'analyse. Pour plus d'informations sur la définition des propriétés d'analyse pour un fichier plat, voir Définition des propriétés d'analyse et accédez au tableau "Standard : Personnalisé, propriété de la structure : Délimité".

Nom du canal

Chaque échange ou document soumis à BizTalk Server nécessite un ensemble de règles précisant son mode de traitement. Le canal contient toutes les informations dont le serveur a besoin pour traiter l'échange ou le document. Tous les échanges et tous les documents qui sont traités par BizTalk Server doivent emprunter un canal. La localisation d'un canal s'effectue de deux manières. D'abord, lorsqu'un échange ou un document est soumis, BizTalk Server analyse le document à la recherche des identificateurs source et de destination et de la définition de document. Si ces informations ne figurent pas dans l'instance de document, BizTalk Server analyse la fonction de réception. Une fois les identificateurs source et de destination et la définition de document découverts, BizTalk Server détermine quels canaux ont la même définition de document, les mêmes identificateurs d'organisation source et de destination que le document reçu. Lorsque BizTalk Server trouve un canal correspondant, l'instance de document est traitée.

Les canaux peuvent également être localisés lorsqu'ils figurent dans la fonction de réception. Dans ce cas, la recherche de canaux n'est pas effectuée et le document reçu est traité plus rapidement.

Définition de document, identificateurs d'organisation source et d'organisation de destination

Vous pouvez configurer la définition de document, l'identificateur d'organisation source, ou l'identificateur d'organisation de destination lorsque vous recevez des documents sans auto-routage. Les informations de routage incluses dans le document que vous recevez déterminent les propriétés à définir dans la fonction de réception. Par exemple, si vous recevez plusieurs types de document de la même organisation source et si vous envoyez toujours ces documents à la même destination, vous pouvez configurer les identificateurs d'organisation source et de destination dans la fonction de réception et définir dynamiquement la définition de document dans l'instance de document.

Voir aussi

Création d'enveloppes

Définition des propriétés des informations d'enveloppe

Définition des propriétés d'analyse

Description des canaux

Description des définitions de document

Description des enveloppes

Description des organisations

Description des fonctions de réception et du routage de documents

Utilisation d'enveloppes pour le traitement entrant


Utilisation des files d'attente

Microsoft BizTalk Server 2000 offre le possibilité de gérer les files d'attente partagées dans la console Administration de BizTalk Server. Les administrateurs de BizTalk Server peuvent transférer des documents de n'importe quelle file d'attente à la file d'attente interrompue. Dans la file d'attente interrompue, des documents sont supprimés, soumis à nouveau ou affichés, selon l'état de traitement du document. Les administrateurs de BizTalk Server peuvent trier et afficher les messages d'erreur relatifs aux documents dans la file d'attente interrompue.

Les files d'attente suivantes sont employées pour contenir des documents entrants et sortants à diverses étapes de routage et de traitement dans BizTalk Server :

  • File de travail

  • File d'attente planifiée

  • File de nouvel essai

  • File d'attente interrompue

Remarque

  • Les échanges et les documents apparaissent dans la console Administration de BizTalk Server dans l'ordre "premier arrivé, premier sorti". En d'autres termes, les plus anciens éléments d'une file d'attente apparaissent en premier, les plus récents en dernier. En outre, une file d'attente peut contenir un nombre maximal de 15 000 échanges ou documents. Si une file d'attente comporte plus de 15 000 éléments, vous devez supprimer ou soumettre à nouveau les éléments courants de la file d'attente afin que les éléments les plus récents puissent être affichés. Le nombre entre parenthèses figurant en regard de la file d'attente indique combien d'éléments sont actuellement contenus dans la file d'attente. Vous pouvez soumettre à nouveau ou supprimer des documents pour les retirer d'une file d'attente.

Voir aussi

Gestion des files d'attente


File de travail

La file de travail contient des documents en cours de traitement par BizTalk Server. Les transactions dans la file de travail n'y restent pas très longtemps car elles sont traitées dès leur arrivée. Les administrateurs de BizTalk Server peuvent sélectionner n'importe quel document dans cette file d'attente et le déplacer vers la file d'attente interrompue.

Voir aussi

Déplacement de documents vers la file d'attente interrompue

Utilisation des files d'attente


File d'attente planifiée

La file d'attente planifiée contient des éléments de travail qui ont été traités par BizTalk Server et attendent une transmission en fonction de la fenêtre de service. Les administrateurs de BizTalk Server peuvent sélectionner n'importe quel document dans cette file d'attente et le déplacer vers la file d'attente interrompue. Pour plus d'informations sur la fenêtre de service, voir l'objet ServiceWindowInfo Interface.

Voir aussi

Déplacement de documents vers la file d'attente interrompue

BizTalkServiceWindowInfo Interface

Utilisation des files d'attente


File de nouvel essai

La file d'attente de nouvel essai contient des documents qui sont soumis à nouveau pour livraison et des documents en attente d'accusés de réception d'échanges au format Reliable. Il est impossible de différencier les deux types de transmission. Par défaut, les transmissions qui n'ont pas abouti sont retentées toutes les cinq minutes, pour un maximum de trois tentatives avant d'être transférées dans la file d'attente interrompue. Ces nombres peuvent être modifiés par le biais du Gestionnaire d'échanges BizTalk ou par programme. Pour plus d'informations sur le changement du nombre de nouveaux essais, voir Définition des propriétés de configuration avancées ou les propriétés RetryCount et RetryInterval.

Les administrateurs de BizTalk Server peuvent sélectionner n'importe quel document dans cette file d'attente et le déplacer vers la file d'attente interrompue.

Voir aussi

RetryCount

RetryInterval

Déplacement de documents vers la file d'attente interrompue

Définition des propriétés de configuration avancées

Utilisation des files d'attente


File d'attente interrompue

La file d'attente interrompue contient des éléments de travail dont le traitement a échoué pour diverses raisons, notamment des erreurs d'analyse, des erreurs de sérialisation, des échecs de transmission, ou l'incapacité de trouver une configuration de canal. Les administrateurs de BizTalk peuvent cliquer avec le bouton droit sur n'importe quel document dans cette file d'attente pour choisir l'une des options suivantes :

  • Afficher la description de l'erreur. Permet aux administrateurs de BizTalk d'afficher des descriptions d'erreur qui indiquent pourquoi le document a été envoyé à la file d'attente interrompue.

  • Afficher l'échange. Permet aux administrateurs de BizTalk d'afficher le contenu d'un échange dont le traitement a échoué pour diverses raisons, notamment des erreurs d'analyse ou des échecs de transmission. Afficher l'échange apparaît dans les états suivants :
    • Initial

    • Composant personnalisé

    • Analyse

    • Cryptage

    • Signature

    • Cryptage

    • Transmission en cours
  • Afficher le document. Permet aux administrateurs de BizTalk d'afficher le contenu d'un document dont le traitement a échoué pour diverses raisons, notamment des erreurs de sérialisation ou l'impossibilité de trouver un canal. Afficher l'échange apparaît dans les états suivants :
    • Validation du document

    • Sélection du canal

    • Suivi de champs

    • Mappage

    • Corrélation

    • Sérialisation
  • Suppression. Permet aux administrateurs de BizTalk de supprimer complètement une entrée de la file d'attente interrompue. Cette opération n'est pas récupérable. Après qu'un document a été supprimé de la file d'attente interrompue, vous ne pouvez pas le récupérer.

  • Soumettre à nouveau. Permet aux administrateurs de BizTalk de soumettre à nouveau des échanges et des documents à BizTalk Server pour traitement.

États de la file d'attente interrompue

Des échanges et des documents sont placés dans la file d'attente interrompue pour diverses raisons. La liste suivante décrit les états de la file d'attente interrompue, leurs messages d'erreur associés, et l'action à entreprendre éventuellement.

État de la file d'attente interrompue | Message d'erreur | Description de l'erreur et action possible
Sélection du canal ou Transmission en cours | Erreur inattendue | Un incident de serveur interne s'est produit. Soumettez à nouveau le document.
Sélection du canal ou Transmission en cours | Unknown | L'échange ou le document a été marqué comme étant "en traitement" par un serveur inactif. Lorsque le serveur a redémarré, cet élément a été automatiquement transféré dans la file d'attente interrompue. Un incident s'est probablement produit sur le serveur d'origine. Pour plus d'informations, contactez l'administrateur système. Une fois le problème corrigé, soumettez à nouveau le document ou l'échange.
Sélection du canal ou Transmission en cours | Mémoire insuffisante | L'ordinateur sur lequel BizTalk Server est exécuté n'a pas suffisamment de mémoire. Redémarrez le serveur et soumettez à nouveau tous les échanges et documents contenus dans la file d'attente interrompue.
Analyse | Échec des données en cours d'analyse | BizTalk Server n'a pas pu analyser les données. Affichez le contenu de l'échange pour déterminer pourquoi BizTalk Server n'a pas pu analyser les données. Soumettez à nouveau l'échange à l'aide de IInterchange ou d'une fonction de réception. Pour plus d'informations, voir Un échange ou un document apparaît sous forme de données binaires dans la file d'attente interrompue ou Erreurs d'analyse .
Analyse | Données manquantes | Les informations extraites à partir des données entrantes ne contenaient pas suffisamment de données pour permettre la recherche d'un canal. Affichez l'échange et identifiez les données manquantes. Soumettez à nouveau l'échange à l'aide de IInterchange ou d'une fonction de réception. Pour plus d'informations, voir Un échange ou un document apparaît sous forme de données binaires dans la file d'attente interrompue ou Erreurs d'analyse .
Analyse | "expiresAt" expiré | L'horodatage BizTalk Framework "expiresAt" a expiré. Ce document n'est plus valide. Pour plus d'informations, voir Un échange ou un document apparaît sous forme de données binaires dans la file d'attente interrompue.
Sélection du canal | Aucun canal trouvé | BizTalk Server n'a pas pu trouver de canal correspondant à ce document. Créez un canal pour le document, ou corrigez le document puis soumettez-le à nouveau.
Sélection du canal | Canal effacé | Le canal associé à ce document a été supprimé après que le document a atteint la file de travail. Reconfigurez le canal, ou configurez le document pour un autre canal, puis soumettez à nouveau le document. —Ou— Ne soumettez pas le document et supprimez-le de la file d'attente interrompue.
Sélection du canal | Canal manquant | Le canal spécifié par la fonction de réception ou l'appel soumis est introuvable. Configurez un canal ou reconfigurez le document et soumettez-le à nouveau.
Sélection du canal | Canal incorrect | Le canal spécifié par l'appel soumis était un canal ouvert. Les canaux ouverts ne sont pas valides pour les appels soumis directs. Changez le canal et soumettez à nouveau le document.
Mappage | Erreur lors du mappage | Le format du mappage référencé par le canal est incorrect. Supprimez le document de la file d'attente interrompue, corrigez le mappage, puis soumettez à nouveau le document comme s'il s'agissait d'un nouveau document.
Sérialisation | Erreur lors de la sérialisation | BizTalk Server n'a pas pu convertir le document dans son format natif. Soumettez à nouveau le document.
Cryptage | Erreur lors de l'encodage | BizTalk Server n'a pas pu coder cet échange. Soumettez à nouveau l'échange.
Signature | Erreur lors de la signature | BizTalk Server n'a pas pu signer cet échange. Le certificat a peut-être expiré. Pour plus de détails, voir le composant logiciel enfichable Certificats de Microsoft Management Console. Pour plus d'informations sur l'affichage du composant logiciel enfichable Certificats dans l'aide Windows 2000, consultez la section « Ajouter le composant logiciel enfichable Certificats à la console MMC » du chapitre Gérer les certificats.
Cryptage | Erreur lors du cryptage | BizTalk Server n'a pas pu crypter cet échange. Le certificat a peut-être expiré. Pour plus de détails, voir le composant logiciel enfichable Certificats de Microsoft Management Console. Pour plus d'informations sur l'affichage du composant logiciel enfichable Certificats dans l'aide Windows 2000, consultez la section « Ajouter le composant logiciel enfichable Certificats à la console MMC » du chapitre Gérer les certificats.
Transmission en cours | Échec de la transmission | BizTalk Server n'a pas pu livrer cet échange. Vérifiez l'adresse du transport dans le canal. Corrigez le problème et soumettez à nouveau l'échange.
Transmission en cours | Échec du délai d'expiration | BizTalk Server n'a pas pu terminer le traitement de cet échange avant la fin du délai d'expiration. Cet incident pourrait être causé par une transmission trop longue. Si vous utilisez un transport non fiable, vérifiez que l'échange a été envoyé avant de tenter de soumettre à nouveau l'échange.
Transmission en cours | Déplacement de l'utilisateur | Un administrateur BizTalk Server a déplacé ce document dans la file d'attente interrompue. Soumettez à nouveau l'échange.
Transmission en cours | Document arrivé à expiration | L'horodatage de BizTalk Framework "receiptRequiredBy" a expiré. Ce document n'est plus valide.
Validation du document | Document incorrect | La validation du document par rapport à sa spécification a échoué. Recherchez l'erreur dans le journal des événements pour obtenir plus d'informations. Corrigez le schéma et soumettez à nouveau le document.
Suivi de champs | Aucun champ suivi | BizTalk Server n'a pas pu effectuer le suivi des champs demandés dans le document. Affichez le document pour vérifier que les champs à suivre sont présents, ou changez la configuration de canal pour le suivi de champs. Puis soumettez à nouveau le document.
Composant personnalisé | Échec d'un composant personnalisé | Échec d'un composant personnalisé. Dépannez le composant personnalisé ou le préprocesseur personnalisé et soumettez l'échange.
Corrélation | Défaillance de la corrélation | Une défaillance s'est produite lors de la corrélation de cet accusé de réception.

Remarques

  • Outre les messages d'erreur dans la file d'attente interrompue, vous pouvez également vérifier le journal des événements pour obtenir d'autres informations. Pour plus d'informations sur le journal des événements, voir Gestion de l'Observateur d'événements.

  • Not all documents in the Suspended queue can be resubmitted. In some situations, you must delete the document and submit it again from the original application or organization.

Voir aussi

Un échange ou un document apparaît sous forme de données binaires dans la fille d'attente interrompue

Gestion de l'Observateur d'événements

Gestion des files d'attente

Erreurs d'analyse

Description des fonctions de réception et du routage de documents

Description des propriétés avancées d'une fonction de réception

Utilisation des files d'attente


Privilèges d'administration

Pour afficher la console Administration de BizTalk Server, vous devez être membre du groupe des administrateurs de BizTalk Server. Si vous n'êtes pas connecté comme administrateur de BizTalk Server, vous ne pouvez pas afficher d'éléments contenus dans le dossier Microsoft BizTalk Server 2000. Si vous êtes membre du groupe des administrateurs de BizTalk Server, mais n'êtes pas membre du groupe des administrateurs de Microsoft Windows 2000, vous pouvez uniquement effectuer les tâches suivantes :

  • ajouter et supprimer des groupes de serveurs ;

  • afficher et modifier des propriétés de groupe ;

  • gérer toutes les files d'attente et leurs entrées ;

  • ajouter et supprimer des fonctions de réception ;

  • afficher et modifier des propriétés de fonction de réception.

En outre, si vous administrez un groupe de serveurs qui contient trois serveurs, par exemple, Server_1, Server_2 et Server_3, vous devez avoir des privilèges d'administrateur Windows 2000 sur les trois serveurs. Si les privilèges d'administrateur Windows 2000 ont été changés sur Server_1, et si vous n'avez plus de privilèges d'administrateur, la console d'administration renvoie la liste des trois serveurs associés au groupe et indique l'état de chaque serveur. L'état renvoyé de Server_1 est maintenant Accès refusé.

Si vous êtes membre du groupe des administrateurs de BizTalk Server et du groupe des administrateurs de Windows 2000, vous pouvez effectuer les tâches supplémentaires suivantes :

  • ajouter ou supprimer des serveurs dans un groupe de serveurs ;

  • afficher et modifier des propriétés de serveur ;

  • afficher l'état d'un serveur ;

  • libérer des échanges sur un serveur.

Pendant la configuration, l'utilisateur qui effectue l'installation de BizTalk Server est ajouté au groupe des administrateurs de BizTalk Server. Vous pouvez ajouter d'autres utilisateurs au groupe d'administrateurs de BizTalk Server. Pour plus d'informations, voir Ajout d'utilisateurs au groupe Administrateurs de BizTalk Server.


Dépannage d'Administration de BizTalk Server

Cette section regroupe toutes les informations relatives au dépannage d'Administration de BizTalk Server. Si vous recevez des messages d'erreur, cherchez une solution dans cette section.

Des informations complémentaires portant sur les dysfonctionnements détectés après la publication de cette documentation sont fournies dans le fichier Lisezmoi qui se trouve à la racine du dossier Microsoft BizTalk Server.

Les points suivants sont abordés :

  • Erreur d'obtention de tous les groupes d'une base de données

  • Limite de la taille des documents et des échanges

  • Écart de délai d'expiration de transactions entre les services de composants et BizTalk Server 2000

  • Le service d'échanges BizTalk ne démarre pas

  • Performances ralenties lors de la suppression d'une grande quantité de documents de la file d'attente interrompue

  • Incident de validation de sortie

  • Le serveur ne renvoie pas tous les documents dans un échange flat-file

  • Identificateur de classe apparaissant dans la liste Préprocesseur

  • Un échange ou un document apparaît sous forme de données binaires dans la fille d'attente interrompue

  • BizTalk Server a arrêté le traitement des documents

  • La fonction de réception ne supprime pas le document

  • Connexion impossible à un serveur SQL Server installé sur une machine en cluster

  • Des fonctions de réception ont arrêté le traitement des documents

  • Erreur lors du déplacement d'un serveur distant vers une autre base de données Gestion d'échanges BizTalk

  • Erreurs d'analyse

Remarque

  • D'autres informations de dépannage figurent dans les messages d'erreur de la file d'attente interrompue. Pour plus d'informations sur la file d'attente interrompue, les messages d'erreur et les actions possibles, voir File d'attente interrompue.

  • Des informations détaillées sont disponibles dans le journal des événements, telles que des messages d'erreur et d'avertissement. Pour plus d'informations sur le journal des événements, voir Gestion de l'Observateur d'événements.


Erreur d'obtention de tous les groupes d'une base de données

Cause : La base de données Gestion d'échanges BizTalk est déconnectée si vous recevez le message suivant :

Impossible d'énumérer les instances de Microsoft BizTalkServer_Group : Impossible d'établir la connexion à la base de données Gestion d'échanges BizTalk.

Solution : Déterminez pourquoi le serveur est déconnecté et tentez de rétablir la connexion dès qu'il est de nouveau en ligne. Par exemple, vous pouvez recevoir ce message si le serveur qui héberge la base de données Gestion d'échanges BizTalk est déconnecté pour des raisons de maintenance.


Limite de la taille des documents et des échanges

La taille maximale prise en charge pour un document envoyé à BizTalk Server est de 20 Mo. La taille maximale prise en charge pour un échange envoyé à BizTalk Server est de 20 Mo.

Si vous prévoyez de recevoir des échanges de format XML Unicode d'une taille supérieure à 20 Mo, il est préférable de désactiver les paramètres de suivi global. Si vous prévoyez de recevoir des échange au format ANSI flat-file d'une taille supérieure à 7-10 Mo, il est préférable de désactiver les paramètres de suivi global. Pour plus d'informations sur la configuration des paramètres de suivi d'un groupe de serveurs, voir Configuration des propriétés de suivi d'un groupe de serveurs.

De même, si vous prévoyez de recevoir des instances de document au format XML Unicode d'une taille supérieure à 20 Mo, il est préférable de désactiver les paramètres de journalisation dans le Gestionnaire d'échanges BizTalk. Ou, si vous prévoyez de recevoir des fichiers plats ANSI d'une taille supérieure à 7-10 Mo, il est préférable de désactiver les paramètres de journalisation de documents dans le Gestionnaire d'échanges BizTalk. Pour plus d'informations sur le stockage de copies d'instances de document spécifiques, voir Définition des propriétés de journalisation de document.

Voir aussi

Configuration des propriétés de suivi d'un groupe de serveurs

Définition des propriétés de journalisation d'un document


Écart de délai d'expiration de transactions entre les services de composants et BizTalk Server 2000

Il existe un écart de délai d'expiration de fichier entre les services de composants et BizTalk Server 2000. Lors de l'envoi d'un fichier qui dépasse la valeur de délai d'expiration de transaction par défaut de 60 secondes, BizTalk Server 2000 enregistre la transaction comme étant envoyée, et le serveur de réception reçoit le fichier sans erreur. Le services de composants enregistrent la transaction comme étant abandonnée. Les transactions ne peuvent pas être annulées.


Le service d'échanges BizTalk ne démarre pas

Cause : Le service d'échanges BizTalk ne démarre pas si BizTalk Server ne peut pas se connecter au serveur SQL Server qui stocke la base de données Gestion d'échanges BizTalk. Tous les packages COM+ s'exécutent sous un compte utilisateur interactif, et non sur le compte système local. Le service démarre seulement si un utilisateur est connecté à BizTalk Server. Par exemple, si une application cliente envoie des documents à BizTalk Server à distance et si aucun utilisateur n'est connecté sur le serveur exécutant BizTalk Server 2000, le service ne démarre pas.

Solution : Vérifiez la connexion de BizTalk Server à la base de données Gestion d'échanges BizTalk. Vérifiez que Microsoft SQL Server fonctionne correctement. Vous devrez éventuellement créer un compte de services sous lequel exécuter BizTalk Server. Pour plus d'informations sur la création d'un compte de services, dans l'aide de Windows 2000, dans le chapitre Services, consultez « Sélectionner un compte d'utilisateur utilisé par un service pour ouvrir une session ».


Performances ralenties lors de la suppression d'une grande quantité de documents de la file d'attente interrompue

Cause : Vous pouvez constater un ralentissement des performances lorsque vous supprimez une grande quantité de documents de la file d'attente interrompue.

Solution : Si vous devez supprimer tous les documents de la file d'attente interrompue, vous devrez éventuellement utiliser PurgeBizTalkSuspendedQueue.vbs, un exemple de script Microsoft Visual Basic fourni à cet effet. Après l'installation de BizTalk Server 2000, vous trouverez ce script dans le dossier \Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\Miscellaneous.

Attention

  • N'utilisez ce script que si vous souhaitez supprimer de façon permanente tout le contenu de la file d'attente interrompue pour le groupe BizTalk Server spécifié.


Incident de validation de sortie

Première cause : Le type de données d'un champ de la spécification source ne correspond pas au type de données du champ auquel il est lié dans la spécification de destination. Cet échec est consigné dans l'Observateur d'événements.

Solution : Corrigez le type de données dans la spécification source ou de destination. Pour plus d'informations sur les spécifications source et de destination, voir Création et validation des spécifications.

Deuxième cause : Un fonctoid est lié à un champ de la spécification de destination, et la propriété du type de données du champ n'est pas une chaîne.

Solution : Dans la spécification de destination, changez le type de données en Chaîne. Envoyez le document à BizTalk Server pour qu'il soit traité. Pour plus d'informations sur les types de données, voir Définition des propriétés de déclaration.

Troisième cause : Dans la spécification de destination, un champ prend une valeur constante qui utilise un type de données différent de celui déjà affecté au champ.

Solution : Dans la spécification de destination, changez le type de données associé au champ. Envoyez le document à BizTalk Server pour qu'il soit traité. Pour plus d'informations sur les types de données, voir Définition des propriétés de déclaration.

Quatrième cause : Des indicateurs de libération sont inclus dans les données EDIFACT. Ces caractères de libération sont inclus dans le nombre de caractères logiques lors de la validation du nombre maximal de caractères physiques pour un champ. Cet échec est consigné dans l'Observateur d'événements.

Solution : N'utilisez pas d'indicateurs de libération dans les données EDIFACT. BizTalk Server insère automatiquement des indicateurs dans les données sortantes lorsque cela s'impose.

Voir aussi

Création et validation des spécifications

Définition des propriétés de déclaration


Le serveur ne renvoie pas tous les documents dans un échange flat-file

Cause : L'un des documents de l'échange ne respecte pas la spécification de document. Par exemple, un champ obligatoire est absent dans l'un des documents.

Solution : Localisez le document ne répondant pas à la spécification, corrigez-le, puis soumettez à nouveau l'échange. Bien qu'une erreur soit renvoyée pour le document ne répondant pas à la spécification, BizTalk Server ne peut pas traiter tous les documents dans l'échange. La structure flat-file est un format ouvert non conçu pour mettre en oeuvre un contrôle redondant.


Identificateur de classe apparaissant dans la liste Préprocesseur

Cause : Le préprocesseur personnalisé n'est plus enregistré.

Solution : Dans le journal des événements, vérifiez que le préprocesseur personnalisé n'est plus enregistré. Puis, réenregistrez le préprocesseur personnalisé ou choisissez un autre préprocesseur dans la liste.

Voir aussi

Configuration d'une fonction de réception de fichier : Onglet Services

Préprocesseurs personnalisés

Pré-traitement de documents dans une fonction de réception


Un échange ou un document apparaît sous forme de données binaires dans la fille d'attente interrompue

Première cause : BizTalk Server n'a pas pu analyser l'échange ou le document.

Solution : Supprimez le document de la file d'attente interrompue. Vérifiez que l'échange ou le document entrant est dans un format que BizTalk Server peut traiter (XML, X12, EDIFACT, ou flat-file). Renvoyez-le à BizTalk Server à partir de l'organisation ou de l'application d'origine.

Si BizTalk Server ne peut pas analyser un document, celui-ci apparaît sous forme de données binaires dans la file d'attente interrompue parce que BizTalk Server ne dispose pas d'assez d'informations pour lire et traiter le document correctement. Pour plus d'informations sur les erreurs d'analyse, voir Erreurs d'analyse.

Deuxième cause : BizTalk Server a pu analyser l'échange ou le document, mais le contenu des données n'était pas valide. L'horodateur "expiresAt" a expiré et le document n'est plus valide. Cet incident se produit dans les documents BizTalk Framework qui utilisent le champ "expiredAt".

Solution : Supprimez le document de la file d'attente interrompue. Ce document n'est plus valide. Déterminez pourquoi.

Troisième cause : BizTalk Server n'a pas pu analyser le document parce que son schéma du document est incorrect. Si vous recevez un fichier plat et si la page de code de la spécification de document est définie sur UTF-8, BizTalk Server ne peut pas analyser le document car UTF-8 n'est pas pris en charge.

Solution : Si vous recevez un fichier plat, vérifiez la spécification de document. Si la page de code de la spécification de document est définie sur UTF-8, BizTalk Server ne peut pas traiter le document. Supprimez le document de la file d'attente interrompue. Pour plus d'informations, voir Définition des propriétés de référence.

Voir aussi

Erreurs d'analyse

Définition des propriétés de référence

File d'attente interrompue


BizTalk Server a arrêté le traitement des documents

Première cause : BizTalk Server ne peut pas continuer le traitement des documents si la connexion à l'une des trois bases de données (Gestion d'échanges BizTalk , Suivi ou Files d'attente partagées) est rompue ou si ces bases de données s'avèrent inaccessibles. Cet incident peut se produire si Microsoft SQL Server est arrêté ou interrompu dans Enterprise Manager. Si Microsoft BizTalk Server 2000 rencontre cette erreur, le service d'échanges BizTalk s'arrête normalement pour conserver correctement l'état de traitement et assurer l'intégrité du système au moment de l'incident. Une erreur est consignée dans l'Observateur d'événements avec une description complète de l'erreur provoquant l'arrêt du service.

Solution : Les administrateurs système peuvent utiliser cette erreur pour envoyer une notification indiquant que BizTalk Server est déconnecté, au moyen d'une notification papier ou d'une communication d'état par courrier électronique. Lors d'une telle notification, l'administrateur doit redémarrer manuellement le service d'échanges BizTalk par le biais du composant logiciel enfichable MMC, puis revérifier le journal des événements pour déterminer si l'erreur persiste. Si c'est le cas, l'administrateur doit vérifier que BizTalk Server peut accéder aux services Microsoft SQL Server. Pour plus d'informations sur le démarrage du service d'échanges BizTalk, voir Démarrage du service d'échanges BizTalk.

Deuxième cause : Si le serveur sur lequel BizTalk Server 2000 est installé contient des logiciels anti-virus, la valeur par défaut d'un port de messagerie peut être incorrect.

Solution : La configuration par défaut pour le composant de transport de fichiers est celle qui ajoute les fichiers. Si vous sélectionnez un type de transport de fichier configuré par défaut dans un port d'échanges, si vous utilisez un anti-virus sur le serveur sur lequel est installé BizTalk Server 2000 et si vous envoyez simultanément plusieurs fichiers portant le même nom vers le même emplacement, BizTalk Server 2000 cessera de répondre et devra être redémarré. Pour éliminer ce problème, vous pouvez modifier la valeur par défaut du composant de transport de fichiers en remplaçant l'option Ajouter au fichier par Fichier de remplacement dans la boîte de dialogue Propriétés de BizTalk SendLocalFile. Vous pouvez également éliminer ce problème en créant un fichier unique pour chaque instance de document traitée à l'aide du format de chemin d'accès suivant dans le port d'échanges : fichier://C:\dir\fichier%id_suivi%.xml. Pour plus d'informations, voir Spécification d'une adresse de transport. Si vous devez redémarrer le serveur, voir Démarrage d'un serveur dans un groupe.

Voir aussi

Spécification d'une adresse de transport

Démarrage d'un serveur dans un groupe

Démarrage du service d'Échanges BizTalk


La fonction de réception ne supprime pas le document

Cause : L'intervalle de nouvel essai doit être défini sous la capacité de traitement pour le nombre de documents générés.

Solution : Doublez l'intervalle de nouvel essai et renvoyez les documents à BizTalk Server. Pour plus d'informations sur la configuration de l'intervalle de nouvel essai, voir Définition des propriétés de configuration avancées.

Voir aussi

Définition des propriétés de configuration avancées


Connexion impossible à un serveur SQL Server installé sur une machine en cluster

Cause : Lorsque Microsoft SQL Server est installé sur un cluster, SQL Server peut uniquement prendre en charge les clients connectés au moyen du protocole TCP/IP.

Solution : Installez les outils clients SQL Server et attribuez TCP/IP à la bibliothèque de réseau par défaut. Pour plus d'informations sur l'installation d'outils clients SQL Server, voir Installation d'outils clients SQL Server. Pour plus d'informations sur la modification de la bibliothèque de réseau par défaut, voir Attribution de TCP/IP à la bibliothèque de réseau par défaut.

Voir aussi

Attribution de TCP/IP à la bibliothèque de réseau par défaut

Installation des outils clients SQL Server


Des fonctions de réception ont arrêté le traitement des documents

Cause : Un serveur distant unique ne peut pas prendre en charge plus de 50 fonctions de réception à la fois.

Solution : Pour plus d'informations sur la prise en charge de plusieurs fonctions de réception, visitez le site Web du support technique Microsoft search.support.microsoft.com/kb/c.asp, et recherchez l'article suivant dans la Librairie d'informations techniques :

  • "Too Many Connections to Remote Share May Cause PRC Failures" (article Q221790).

Pour plus d'informations, consultez les articles suivants de la Librairie d'informations techniques :

  • "Local System Account and Null Sessions in Windows NT" (article Q132679).

  • "Service Running As System Account Fails Accessing Network" (article Q124184).

  • "PRB: Access Denied When Opening a Named Pipe from a Service" (article Q126645).

  • "FindFirstChangeNotification May Not Notify All Processes on File Changes" (article Q188321).


Erreur lors du déplacement d'un serveur distant vers une autre base de données Gestion d'échanges BizTalk

Cause : Le serveur peut appartenir à une autre base de données Gestion d'échanges BizTalk.

Solution : Si vous tentez d'ajouter un serveur distant à une base de données Gestion d'échanges BizTalk, et si ce serveur se trouvait dans une autre base de données Gestion d'échanges BizTalk centrale, le message d'erreur suivant apparaît dans le journal d'événements de Windows :

Impossible de créer une nouvelle instance de la classe WMI "MicrosoftBizTalkServer_Server" dans le fournisseur BizTalk Server WMI. Il est possible que le serveur <nom du serveur> appartienne déjà à une autre installation BizTalk Server.

Cette erreur signifie qu'une tentative a été effectuée pour ajouter un serveur distant qui se trouvait initialement dans une autre base de données centrale. Si cette procédure a été effectuée dans Administration de BizTalk Server, la console d'administration tente de déterminer si le serveur distant appartient à un groupe dans la base de données centrale distante. Pour cela, elle interroge interroge le fournisseur WMI (Windows Management Instrumentation) du serveur distant. Si le serveur n'appartient pas à un groupe dans l'autre base de données centrale, un message d'erreur de la console d'administration apparaît et indique que vous ne pouvez pas ajouter un serveur distant qui appartient déjà à un groupe dans une autre base de données centrale.

Voir aussi

Vue d'ensemble de WMI


Erreurs d'analyse

Première cause : Si vous envoyez des messages de type Reliable, les valeurs par défaut d'un port peuvent être incorrectes.

Solution : La configuration par défaut pour le composant de transport de fichiers est celle qui ajoute les fichiers. Si vous sélectionnez un type de transport de fichier configuré par défaut, un format d'enveloppe Reliable dans un port d'échanges, puis envoyez simultanément plusieurs fichiers vers le même emplacement, vous obtiendrez des résultats d'analyse inattendus. Vous pouvez éliminer ce problème en modifiant la configuration par défaut du composant de transport de fichiers en remplaçant l'option Ajouter au fichier par Fichier de remplacement dans la boîte de dialogue Propriétés de BizTalk SendLocalFile. Pour plus d'informations sur la modification des valeurs par défaut d'un port, voir Remplacement des valeurs par défaut d'un port d'échanges.

Other Causes: Plusieurs raisons peuvent empêcher BizTalk Server d'analyser un document. Les raisons des plus fréquentes sont les suivantes :

  • L'échange ou le document est dans un format que BizTalk Server ne peut pas interpréter.

  • Le schéma du document est incorrect.

  • Un échange flat-file possède un schéma erroné ou non valide.

  • Un échange flat-file contient des caractères incorrects.

  • Il manque des caractères dans un échange flat-file.

  • Il manque des séparateurs dans un échange flat-file.

  • Un document BizTalk Framework 2.0 comporte un alias non valide indiqué dans le port ou le canal.

  • Le noeud conteneur du document est manquant dans un en-tête XML personnalisé.

  • Un attribut est manquant dans un document XML personnalisé.

  • Une spécification de document EDI ne correspond pas à l'enveloppe.

Solution : Affichez les données de l'échange ou du document pour déterminer pourquoi BizTalk Server n'a pas pu analyser l'échange ou le document. Pour afficher les données de l'échange ou du document, vous pouvez :

  • Afficher les 512 premiers octets des données de l'échange ou du document. Pour plus d'informations sur l'affichage de données d'échange et de document, voir Affichage des échanges ou Affichage des documents.

  • Afficher les données d'échange de l'enregistrement d'échange dans le Suivi de documents BizTalk . Pour plus d'informations sur l'affichage d'échanges dans le suivi de documents BizTalk, voir Recherche par date des informations relatives aux documents et aux échanges, Recherche par organisation des informations relatives aux documents et aux échanges, Recherche par type de documents des informations relatives aux documents et aux échanges ou Recherche des informations relatives aux documents et aux échanges par la combinaison de paramètres de requête.

  • Utiliser la couche WMI (Windows Management Instrumentation) pour afficher les données d'échange. Pour plus d'informations sur la programmation d'applications WMI, visitez le site Web de la bibliothèque en ligne MSDN msdn.microsoft.com/library/default.asp, et cherchez "WMI Application Programming".

Une fois que vous avez déterminé pourquoi BizTalk Server n'a pas pu analyser le document, corrigez le problème et soumettez à nouveau l'échange ou le document à l'aide d'IInterchange ou d'une fonction de réception.

Voir aussi

Un échange ou un document apparaît sous forme de données binaires dans la file d'attente interrompue

Recherche par date des informations relatives aux documents et aux échanges

Recherche par type de document des informations relatives aux documents et aux échanges

Recherche par organisation des informations relatives aux documents et aux échanges

Recherche des informations relatives aux documents et aux échanges par la combinaison de paramètres de requête

File d'attente interrompue

Affichage des documents

Affichage des échanges


Administration programmée

Les interfaces décrites dans cette section permettent d'accéder aux gestionnaires du système XLANG Scheduler, aux gestionnaires de groupe XLANG, aux instances de planification XLANG et aux ports XLANG.

Le gestionnaire du système XLANG Scheduler fournit la résolution du moniker et gère une collection de gestionnaires de groupe. Un gestionnaire de groupe fonctionne dans chaque application COM+ conçue comme hôte des planifications XLANG ; de plus, il gère une collection d'instances de planifications XLANG. Une instance de planification XLANG représente une planification XLANG en cours d'exécution pouvant être interrogée pour obtenir des informations, telles que l'état d'exécution de la planification. Pour les planifications XLANG qui font appel à un port COM, un objet proxy peut être utilisé pour obtenir une référence à l'interface spécifiée dans la liaison du port.

Remarque

  • Il ne peut y avoir qu'un gestionnaire du système XLANG Scheduler sur chaque ordinateur.

L'illustration suivante représente la relation entre ces interfaces ainsi que les monikers correspondants.

Relationship diagrams for XLANG interfaces
sked://[host]
System manager
IWFSystemAdmin
sked://[host][!group]
XLANG schedule instance
XLANG schedule instance
XLANG schedule instance
Group manager
Group manager
Group manager
WorkflowInstance
IWFProxy
IWFWorkflowInstance
IWFWorkflowInstance
IWFWorkflowInstance
IWFGroupAdmin
IWFGroupAdmin
IWFGroupAdmin
sked://[host][!group]/file.skx
sked://[host][!group]/file.skx/port
Proxy to COM-bound XLANG port

Pour plus d'informations, voir Administration des planifications XLANG.

Voir aussi

Syntaxe du moniker


Suivi de documents

Suivi de documents BizTalk est une application Web permettant de visualiser l'avancement des documents traités par Microsoft BizTalk Server 2000. Vous pouvez créer des requêtes ou des requêtes avancées pour extraire des informations essentielles dans la base de données de suivi dans un format facile à consulter. Par exemple, dans Suivi de documents BizTalk vous pouvez afficher des informations capturées sur la source et la destination du document, le nom du document ainsi que son type et les paramètres de date et d'heure correspondants. De plus, vous pouvez créer des requêtes qui affichent des champs de recherche standard et personnalisés afin de pouvoir analyser vos pratiques professionnelles. Par exemple, un champ Total de bon de commande peut être stocké pour chaque bon de commande envoyé à des fournisseurs. Vous pouvez ensuite utiliser ces données pour analyser et communiquer le volume monétaire des achats à un ou plusieurs fournisseurs sur une période donnée.

En outre, vous pouvez configurer Suivi de documents BizTalk pour afficher des enregistrements d'échange et de document individuellement ou par lots. Vous pouvez également utiliser Suivi de documents BizTalk pour afficher, visualiser et enregistrer des copies complètes des instances de document entrantes et sortantes pour y faire référence ultérieurement.

  • Pour obtenir de l'aide sur des tâches spécifiques, consultez Comment.

  • Pour obtenir des informations générales, consultez Concepts.

  • Pour obtenir des instructions sur la résolution de problèmes, consultez Dépannage de Suivi de documents BizTalk.

Important

  • Suivi de documents BizTalk étant accessible sous forme d'application Web au moyen de Microsoft Internet Explorer, l'aide de Microsoft BizTalk Server 2000 s'utilise différemment et ses fonctionnalités sont légèrement restreintes. Les onglets Sommaire, Index, Rechercher et Favoris ne sont pas disponibles. Vous pouvez accéder à toutes les rubriques par le biais de liens à partir de la page d'ouverture, de liens Voir aussi ainsi qu'au moyen du bouton Précédent.

    Si vous souhaitez rechercher une rubrique spécifique, ou si vous voulez accéder à des informations sur des fonctions et des services de BizTalk Server 2000, dans le menu Démarrer, pointez sur Programmes, sur Microsoft BizTalk Server 2000, puis cliquez sur Documentation de BizTalk Server. Pour que l'aide soit disponible dans le menu Démarrer, BizTalk Server 2000 doit être installé sur votre ordinateur.

  • Suivi de documents BizTalk utilisant des contrôles Microsoft ActiveX, une boîte de dialogue de téléchargement de contrôles ActiveX peut apparaître pendant les sélections ou les soumissions de requêtes. Dans ce cas, cliquez sur Oui pour continuer.

Remarque

  • Lors d'une sélection ou sélection de requête, une boîte de dialogue peut afficher le message suivant :

    Cette page utilise des données situées dans un autre domaine. Voulez-vous continuer ?

    Pour éviter de recevoir ce message dans Internet Explorer, vous pouvez ajouter un site Web sécurisé aux zones de sites fiables sous l'onglet Sécurité de la boîte de dialogue Options Internet.

    Pour configurer manuellement les paramètres de votre navigateur afin de faire confiance à cette application Web, ajoutez l'application Web à la liste des sites fiables dans Internet Explorer. Pour plus d'informations sur l'ajout d'une application Web à la liste des sites fiables, consultez Configuration des paramètres de sécurité dans Internet Explorer.


Comment...

Cette section fournit des informations spécifiques de tâches indiquant comment rechercher, visualiser et enregistrer des résultats de recherche d'enregistrements d'instance d'échange et de document, et des données associées. Il est instamment recommandé de relire la section Concepts pour bien comprendre les possibilités de recherche et les résultats de requête attendus.

Suivi de documents BizTalk possède deux niveaux de possibilité de recherche : requête et requête avancée. Vous pouvez utiliser des requêtes lorsque vous souhaitez localiser des documents en employant des critères de recherche standard, par exemple une organisation source. Vous pouvez utiliser des requêtes avancées lorsque vous souhaitez localiser des données spécifiques dans des documents, par exemple un total de bon de commande.

Cette section traite des procédures suivantes :

  • Ouverture de Suivi de documents BizTalk pour la première fois

  • Ouverture de Suivi de documents BizTalk

  • Ajout d'utilisateurs au groupe d'utilisateurs d'états de BizTalk Server

  • Utilisation des requêtes pour rechercher et trier les données d'échange et de document

  • Utilisation de requêtes avancées

  • Enregistrement d'un échange, d'un document et de données de recherche personnalisée


Ouverture de Suivi de documents BizTalk pour la première fois

Si vous ouvrez Suivi de documents BizTalk pour la première fois et si vous n'avez pas installé sur votre ordinateur Contrôles communs Microsoft et le contrôle de Suivi de documents BizTalk, un message vous invite à installer les composants. Si vous avez installé ces composants sur votre ordinateur, consultez Ouverture de Suivi de documents BizTalk.

  1. Dans le menu Démarrer, pointez sur Programmes, sur Microsoft BizTalk Server 2000, puis cliquez sur Suivi de documents BizTalk.

    La boîte de dialogue Dialogue de page Web s'ouvre pour vous inviter à installer les composants suivants :

    • Contrôles communs Windows

    • Contrôle d'installation de Suivi de documents BizTalk
  2. Cliquez sur Continuer, pour installer les contrôles communs Windows.

    La boîte de dialogue Avertissement de sécurité s'ouvre.

  3. Cliquez sur Oui, pour installer le contrôle d'installation de Suivi de documents BizTalk.

Remarque

  • Lors d'une sélection ou d'une sélection de requête, une boîte de dialogue peut afficher le message suivant :

    Cette page utilise des données situées dans un autre domaine. Voulez-vous continuer ?

    Pour éviter de recevoir ce message dans Internet Explorer, vous pouvez ajouter un site Web sécurisé aux zones de sites fiables sous l'onglet Sécurité de la boîte de dialogue Options Internet.

    Pour configurer manuellement les paramètres de votre navigateur afin de faire confiance à cette application Web, ajoutez l'application Web à la liste des sites fiables dans Internet Explorer. Pour plus d'informations sur l'ajout d'une application Web à la liste des sites fiables, consultez Configuration des paramètres de sécurité dans Internet Explorer.

Voir aussi

Configuration des paramètres de sécurité dans Internet Explorer

Ouverture de Suivi de documents BizTalk


Ouverture de Suivi de documents BizTalk

  • Dans le menu Démarrer, pointez sur Programmes, sur Microsoft BizTalk Server 2000, puis cliquez sur Suivi de documents BizTalk.

    —Ou—

    Si vous avez créé un favori dans Microsoft Internet Explorer, vous pouvez ouvrir Suivi de documents BizTalk à partir d'Internet Explorer.

Remarque

  • Lors d'une sélection ou d'une sélection de requête, une boîte de dialogue peut afficher le message suivant :

    Cette page utilise des données situées dans un autre domaine. Voulez-vous continuer ?

    Pour éviter de recevoir ce message dans Internet Explorer, vous pouvez ajouter un site Web sécurisé aux zones de sites fiables sous l'onglet Sécurité de la boîte de dialogue Options Internet.

    Pour configurer manuellement les paramètres de votre navigateur afin de faire confiance à cette application Web, ajoutez l'application Web à la liste des sites fiables dans Internet Explorer. Pour plus d'informations sur l'ajout d'une application Web à la liste des sites fiables, consultez Configuration des paramètres de sécurité dans Internet Explorer.

Voir aussi

Configuration des paramètres de sécurité dans Internet Explorer

Ouverture de Suivi de documents BizTalk pour la première fois


Ajout d'utilisateurs au groupe d'utilisateurs d'états de BizTalk Server

Pour visualiser l'interface utilisateur de Suivi de documents BizTalk et enregistrer des expressions de requête avancée, vous devez être membre du groupe d'utilisateurs d'états de BizTalk Server.

  1. Dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration puis sur Gestion de l'ordinateur.

  2. Développez Outils système, Utilisateurs et groupes locaux, puis cliquez sur le dossier Groupes.

  3. Dans le volet de détails, cliquez sur Utilisateurs d'états de BizTalk Server.

  4. Dans le menu Action, pointez sur Toutes les tâches, puis cliquez sur Ajouter au groupe.

    La boîte de dialogue Propriétés des utilisateurs d'états de BizTalk Server s'ouvre.

  5. Cliquez sur Ajouter.

  6. Dans la liste Regarder dans, cliquez sur votre domaine ou le nom de votre ordinateur.

  7. Dans la liste contenant les utilisateurs et les ordinateurs associés au domaine ou à l'ordinateur que vous avez sélectionné à l'étape 6, cliquez sur le compte utilisateur à ajouter, sur Ajouter, puis sur OK.

  8. Cliquez sur OK pour fermer la boîte de dialogue Propriétés des utilisateurs d'états de BizTalk Server.


Utilisation des requêtes pour rechercher et trier les données d'échange et de document

Vous pouvez utiliser des requêtes pour localiser, visualiser et enregistrer des enregistrements d'instance d'échange et de document ainsi que les données associées en utilisant des critères de recherche standard, tels que un type de documents ou une organisation source.

Cette section traite des procédures suivantes :

  • Recherche par date des informations relatives aux documents et aux échanges

  • Recherche par organisation des informations relatives aux documents et aux échanges

  • Recherche par type de document des informations relatives aux documents et aux échanges

  • Recherche des informations relatives aux documents et aux échanges par la combinaison de paramètres de requête

  • Annulation des critères de recherche pour les organisations et les types de documents

  • Personnalisation de la page Résultats de la requête

  • Affichage des paramètres de recherche pour la page Résultats de la requête

Remarque

  • Lorsque vous sélectionnez les paramètres de requête, soyez le plus spécifique possible. Cela réduit la charge sur le serveur et le temps requis pour renvoyer les résultats de la requête.

  • Lors d'une sélection ou d'une sélection de requête, une boîte de dialogue peut afficher le message suivant :

    Cette page utilise des données situées dans un autre domaine. Voulez-vous continuer ?

    Pour éviter de recevoir ce message dans Internet Explorer, vous pouvez ajouter un site Web sécurisé aux zones de sites fiables sous l'onglet Sécurité de la boîte de dialogue Options Internet.

    Pour configurer manuellement les paramètres de votre navigateur afin de faire confiance à cette application Web, ajoutez l'application Web à la liste des sites fiables dans Internet Explorer. Pour plus d'informations sur l'ajout d'une application Web à la liste des sites fiables, consultez Configuration des paramètres de sécurité dans Internet Explorer.


Recherche par date des informations relatives aux documents et aux échanges

  1. Dans Suivi de documents BizTalk, dans la zone Plage de dates, dans la liste Afficher les dates en, cliquez sur Heure locale ou UTC pour spécifier le fuseau horaire des dates d'affichage.

  2. Dans la liste Date de début, tapez la date de début de la période à suivre, ou cliquez sur la flèche pour afficher un calendrier dans lequel vous pouvez sélectionner une date.

    Pour changer l'heure, tapez l'heure de début dans la liste en regard de la liste Date de début, ou cliquez sur la flèche vers le haut ou vers le bas.

  3. Dans la liste Date de fin, tapez la date de fin de la période à suivre, ou cliquez sur la flèche pour afficher un calendrier dans lequel vous pouvez sélectionner une date.

    Pour changer l'heure, tapez l'heure de fin dans la liste en regard de la liste Date de fin, ou cliquez sur la flèche vers le haut ou vers le bas.

  4. Cliquez sur le bouton Requête.

    La page Résultats de la requête s'affiche.

  5. Pour afficher les données d'échange, recherchez l'emplacement de l'enregistrement de l'échange contenant les données à afficher et, dans la colonne Données, cliquez sur une icône de données.

    La page Afficher les données d'échange s'affiche.

  6. Pour afficher l'état d'une planification XLANG pour un échange, dans la colonne Planification, cliquez sur une icône de planification.

    La page Afficher le résumé de la planification s'affiche.

  7. Pour afficher un enregistrement d'une instance de document associée à un échange, cliquez sur l'icône de l'indicateur de développement (+) en regard de l'échange contenant les enregistrements de l'instance du document à afficher.

  8. Pour afficher les données associées à une instance de document, dans le champ Données, cliquez sur une icône de données.

    La page Afficher les données d'instance du document s'affiche.

  9. Pour afficher les données dans leur format natif ou XML, cliquez sur Afficher le format natif ou Afficher le format XML.

  10. Pour afficher les données d'accusé de réception associées à une instance de document, dans le champ Accusé de réception, cliquez sur l'icône Accusé de réception.

    Une nouvelle page Résultats de la requête s'affiche.

  11. Cliquez sur l'icône de l'indicateur de développement (+) en regard de l'échange, puis cliquez sur l'icône de données dans le champ des données.

  12. Pour afficher les données du champ de recherche personnalisée pour une instance de document, recherchez le document pour lequel vous voulez les afficher, utilisez la barre de défilement horizontal pour afficher le champ Recherche personnalisée puis cliquez sur l'icône Recherche personnalisée.

    La page Afficher le champ de recherche personnalisée s'affiche.

Remarques

  • La valeur que vous sélectionnez dans la liste Afficher les dates en contrôle l'intervalle de recherche et les résultats d'affichage. Par exemple, si vous sélectionnez UTC dans la liste Afficher les dates en puis spécifiez 0800 dans le champ d'heure, vous recherchez toutes les données traitées à ou après 0800 heures en heure universelle coordonnée (UTC). Cela est différent de 0800 heure locale.

  • La valeur de date par défaut est antérieure de sept jours à la date actuelle.

  • Les dates affichées sont les horodatages générés par BizTalk Server sur les métadonnées des instances de document et des échanges. Ce ne sont pas les dates du contenu réel du document. Pour localiser des documents en fonction de la date réelle du document, créez une expression Requête avancée. Pour plus d'informations sur les requêtes avancées, consultez Création de requêtes avancées.

  • Si vous spécifiez uniquement une plage de dates dans une requête, Suivi de documents BizTalk recherche toutes les organisations source et de destination et tous les types de documents. Il n'est pas recommandé d'utiliser ce paramètre de recherche unique. Pour optimiser les résultats, créez toujours une requête avec des paramètres très spécifiques afin de limiter les enregistrements d'échange renvoyés sur la page Résultats de la requête.

  • L'état de la planification XLANG est le dernier événement détecté, l'heure de début du traitement, l'heure de fin du traitement, etc.

Voir aussi

Création de requêtes avancées

Recherche par type de document des informations relatives aux documents et aux échanges

Recherche par organisation des informations relatives aux documents et aux échanges

Recherche des informations relatives aux documents et aux échanges par la combinaison de paramètres de requête

Présentation des résultats d'enregistrement d'instance de document

Présentation des résultats d'un enregistrement d'échange

Présentation des requêtes


Recherche par organisation des informations relatives aux documents et aux échanges

  1. Dans Suivi de documents BizTalk, dans la liste Sélection de la source, cliquez sur l'organisation ou les organisations pour lesquelles vous souhaitez voir des échanges et des documents. Pour sélectionner une application associée à une organisation source, cliquez sur l'icône de l'indicateur de développement (+) en regard de l'organisation, puis cliquez sur l'application ou les applications souhaitées. Pour sélectionner toutes les organisations source, cliquez sur Sélectionner tout.

    — ou —

    Dans Suivi de documents BizTalk, dans la liste Sélection de la destination, cliquez sur l'organisation ou les organisations pour lesquelles vous souhaitez voir des échanges et des documents. Pour sélectionner une application associée à une organisation de destination, cliquez sur l'icône de l'indicateur de développement (+) en regard de l'organisation, puis cliquez sur l'application ou les applications souhaitées. Pour sélectionner toutes les organisations de destination, cliquez sur Sélectionner tout.

    Vous pouvez choisir des organisations et des applications dans les listes Sélection de la source et Sélection de la destination pour la même requête.

  2. Cliquez sur le bouton Requête.

    La page Résultats de la requête s'affiche. Tous les échanges qui correspondent à vos critères de requête sont indiqués ici.

  3. Pour afficher les données d'échange, recherchez l'emplacement de l'enregistrement de l'échange contenant les données à afficher et dans la colonne Données, cliquez sur une icône de données.

    La page Afficher les données d'échange s'affiche.

  4. Pour afficher l'état d'une planification XLANG pour un échange, dans la colonne Planification, cliquez sur une icône de planification.

    La page Afficher le résumé de la planification s'affiche.

  5. Pour afficher un enregistrement d'une instance de document associé à un échange, cliquez sur l'icône de l'indicateur de développement (+) en regard de l'échange contenant les enregistrements de l'instance de document à afficher.

  6. Pour afficher les données associées à une instance de document, dans le champ Données, cliquez sur une icône de données.

    La page Afficher les données d'instance du document s'affiche.

  7. Pour afficher les données dans leur format natif ou XML, cliquez sur Afficher le format natif ou Afficher le format XML.

  8. Pour afficher les données d'accusé de réception associées à une instance de document, dans le champ Accusé de réception, cliquez sur l'icône Accusé de réception.

    Une nouvelle page Résultats de la requête s'affiche.

  9. Cliquez sur l'icône de l'indicateur de développement (+) en regard de l'échange, puis cliquez sur l'icône de données dans le champ des données.

  10. Pour afficher les données du champ de recherche personnalisée pour une instance de document, recherchez le document pour lequel vous voulez les afficher, utilisez la barre de défilement horizontal pour afficher le champ Recherche personnalisée puis cliquez sur l'icône Recherche personnalisée.

    La page Afficher le champ de recherche personnalisée s'affiche.

Remarques

  • Si vous ne sélectionnez pas des organisations source et de destination, la requête renvoie des enregistrements d'échange et de document pour toutes les organisations source et de destination. Les options Effacer tout et Sélectionner tout génèrent les mêmes résultats sur la page Résultats de la requête. Pour optimiser les résultats, créez toujours une requête avec des paramètres très spécifiques afin de limiter le nombre d'enregistrements d'échange générés sur la page Résultats de la requête.

  • L'état de la planification XLANG est le dernier événement détecté, l'heure de début du traitement, l'heure de fin du traitement, etc.

Voir aussi

Recherche par date des informations relatives aux documents et aux échanges

Recherche par type de document des informations relatives aux documents et aux échanges

Recherche des informations relatives aux documents et aux échanges par la combinaison de paramètres de requête

Présentation des résultats d'enregistrement d'instance de document

Présentation des résultats d'un enregistrement d'échange

Présentation des requêtes


Recherche par type de document des informations relatives aux documents et aux échanges

  1. Dans Suivi de documents BizTalk, dans la zone Sélection du type de document, cliquez sur Afficher les documents.

  2. Dans la liste Sélection du type de document, cliquez sur le ou les types de document à rechercher. Pour sélectionner tous les types de document, cliquez sur Sélectionner tout.

  3. Cliquez sur le bouton Requête.

    La page Résultats de la requête s'affiche.

  4. Pour afficher les données d'échange, recherchez l'emplacement de l'enregistrement de l'échange contenant les données à afficher et, dans la colonne Données, cliquez sur une icône de données.

    La page Afficher les données d'échange s'affiche.

  5. Pour afficher l'état d'une planification XLANG pour un échange, dans la colonne Planification, cliquez sur une icône de planification.

    La page Afficher le résumé de la planification s'affiche.

  6. Pour afficher un enregistrement d'une instance de document associé à un échange, cliquez sur l'icône de l'indicateur de développement (+) en regard de l'échange contenant les enregistrements de l'instance de document à afficher.

  7. Pour afficher les données associées à une instance de document, dans le champ Données, cliquez sur une icône de données.

    La page Afficher les données d'instance du document s'affiche.

  8. Pour afficher les données dans leur format natif ou XML, cliquez sur Afficher le format natif ou Afficher le format XML.

  9. Pour afficher les données d'accusé de réception associées à une instance de document, dans le champ Accusé de réception, cliquez sur l'icône Accusé de réception.

    Une nouvelle page Résultats de la requête s'affiche.

  10. Cliquez sur l'icône de l'indicateur de développement (+) en regard de l'échange, puis cliquez sur l'icône de données dans le champ des données.

  11. Pour afficher les données du champ de recherche personnalisée pour une instance de document, recherchez le document pour lequel vous voulez les afficher, utilisez la barre de défilement horizontal pour afficher le champ Recherche personnalisée puis cliquez sur l'icône Recherche personnalisée.

    La page Afficher le champ de recherche personnalisée s'affiche.

Remarques

  • Si vous ne sélectionnez pas un ou plusieurs types de documents pour cibler la recherche, la requête renvoie tous les types de document dans la liste. Pour optimiser les résultats, créez toujours une requête avec des paramètres très spécifiques afin de limiter le nombre d'enregistrements d'échange générés sur la page Résultats de la requête.

  • L'état de la planification XLANG est le dernier événement détecté, l'heure de début du traitement, l'heure de fin du traitement, etc.

Voir aussi

Recherche par date des informations relatives aux documents et aux échanges

Recherche par organisation des informations relatives aux documents et aux échanges

Recherche des informations relatives aux documents et aux échanges par la combinaison de paramètres de requête

Présentation des résultats d'enregistrement d'instance de document

Présentation des résultats d'un enregistrement d'échange

Présentation des requêtes


Recherche des informations relatives aux documents et aux échanges par la combinaison de paramètres de requête

  1. Dans Suivi de documents BizTalk, vous pouvez combiner les paramètres de requête suivants dans une session de requête unique pour rechercher et afficher des enregistrements d'instance d'échange et de document ainsi que les données associées :
    • Sélection de la source. Pour plus d'informations sur la création de requêtes en utilisant le paramètre de sélection de la source, consultez Recherche par organisation des informations relatives aux documents et aux échanges.

    • Sélection de la destination. Pour plus d'informations sur la création de requêtes en utilisant le paramètre de sélection de la destination, consultez Recherche par organisation des informations relatives aux documents et aux échanges.

    • Type de document. Pour plus d'informations sur la création de requêtes en utilisant le paramètre de type de document, consultez Recherche par type de document des informations relatives aux documents et aux échanges.

    • Date et heure. Pour plus d'informations sur la création de requêtes en utilisant les paramètres de date et d'heure, consultez Recherche par date des informations relatives aux documents et aux échanges.
  2. Cliquez sur le bouton Requête.


Annulation des critères de recherche pour les organisations et les types de document

  • Dans Suivi de documents BizTalk, cliquez sur Effacer tout sous la liste Sélection de la source, Sélection de la destination ou Sélection du type de document.

Remarque

  • Lorsque vous cliquez sur Effacer tout, Suivi de documents BizTalk revient à la recherche par défaut pour toutes les organisations source et de destination et pour tous les types de document. Pour optimiser les résultats, créez toujours une requête avec des paramètres très spécifiques afin de limiter les enregistrements d'échange renvoyés sur la page Résultats de la requête.


Personnalisation de la page Résultats de la requête

  1. Dans Suivi de documents BizTalk, dans la zone Contrôle du tri, cochez la case Grouper les échanges correspondants.

    Cette étape configure la page Résultats de la requête pour afficher les échanges entrants groupés avec les échanges sortants associés. Décochez cette case si vous ne souhaitez pas afficher les échanges entrants avec les échanges sortants associés.

  2. Dans la zone Contrôle du tri, dans la liste Ordre de tri 1, cliquez sur la première option d'ordre de tri à utiliser. Répétez cette opération pour chaque liste d'ordre de tri pour configurer l'ordre de tri de vos documents sur la page Résultats de la requête.

    Chaque liste Ordre de tri contient les options suivantes :

    • Nom de l'organisation source

    • Nom de l'application source

    • Nom de l'organisation de destination

    • Nom de l'application de destination

    • Type de document

    • Temps de traitement


Affichage des paramètres de recherche pour la page Résultats de la requête

  1. Définissez les paramètres d'une requête, puis cliquez sur le bouton Requête.

    La page Résultats de la requête s'affiche.

    Pour plus d'informations sur la création de requêtes et de requêtes avancées, consultez :

    • Recherche par date des informations relatives aux documents et aux échanges

    • Recherche par organisation des informations relatives aux documents et aux échanges

    • Recherche par type de document des informations relatives aux documents et aux échanges

    • Création de requêtes avancées
  2. Dans la barre Paramètres de recherche, cliquez sur l'icône Afficher.

    Les paramètres de recherche suivants et les valeurs associées sont indiquées dans la zone Paramètres de recherche :

    • Plage de dates

    • Fuseau horaire

    • Nom d'expression

    • Ordre de tri

    • Sélection de la source

    • Sélection de la destination

    • Sélection du type de document

Voir aussi

Création de requêtes avancées

Recherche par date des informations relatives aux documents et aux échanges

Recherche par type de document des informations relatives aux documents et aux échanges

Recherche par organisation des informations relatives aux documents et aux échanges


Utilisation de requêtes avancées

Si vous devez localiser des données spécifiques, telles qu'une instance de document avec un numéro de bon de commande spécifique, vous pouvez utiliser une requête avancée pour localiser ces informations.

Cette section traite des procédures suivantes :

  • Création de requêtes avancées

  • Localisation de requêtes avancées existantes

  • Édition de requêtes avancées existantes

  • Effacement de requêtes avancées existantes d'une requête

  • Suppression de requêtes avancées existantes


Création de requêtes avancées

  1. Dans Suivi de documents BizTalk, dans la zone Requête avancée, cliquez sur Nouveau.

    La page Générateur de requêtes avancées apparaît.

  2. Dans la liste Sélection de la source, cliquez sur une option pour spécifier vos critères de sélection.

    Ce nom correspond au champ capturé que vous recherchez.

  3. Dans la liste Opérateurs, cliquez sur un opérateur.

  4. Dans la zone Valeur, saisissez une valeur.

  5. Dans la liste AND/OR, cliquez sur AND ou OR pour combiner ou comparer cette condition avec une autre. Cette étape est facultative.

  6. Cliquez sur Terminé.

  7. Répétez les étapes 2 à 6 jusqu'à ce que vous ayez ajouté toutes les conditions souhaitées.

  8. Exécutez une des procédures suivantes :
    • Cliquez sur OK pour limiter l'utilisation de cette expression à la session de requête actuelle.

    • Cliquez sur Enregistrer pour enregistrer l'expression en vue de futures sessions de requête. Dans la boîte de dialogue Suivi de documents BizTalk, saisissez le nom de l'expression dans la zone Tapez le nom de l'expression (limitez le nom de l'expression à 50 caractères), puis cliquez sur OK.

Remarques

  • La collection d'une ou de plusieurs conditions dans une requête avancée est qualifiée d'expression.

  • Si vous cliquez sur un bouton lorsque la liste Sélection de la source est au premier plan, il se peut que vous deviez cliquer une deuxième fois sur le bouton afin de l'activer.

  • Dans le Gestionnaire d'échanges BizTalk, si vous avez configuré un canal ou une définition de document pour suivre un ou plusieurs champs personnalisés, ses champs apparaissent dans la liste Sélection de la source. Si vous n'avez pas configuré le Gestionnaire d'échanges BizTalk pour suivre des champs, seul "<Recherche personnalisée>" apparaît dans la liste Sélection de la source. Pour plus d'informations sur le suivi de champs spécifiques, consultez Définition des propriétés de journalisation de document et Sélection des champs de spécification dans un canal.

Voir aussi

Effacement de requêtes avancées existantes d'une requête

Suppression de requêtes avancées existantes

Édition de requêtes avancées existantes

Localisation de requêtes avancées existantes


Localisation de requêtes avancées existantes

  1. Dans Suivi de documents BizTalk, dans la zone Requête avancée, cliquez sur Parcourir.

    La boîte de dialogue Requêtes avancées apparaît.

  2. Sélectionnez une requête existante, puis cliquez sur OK.

Remarque

  • Si vous cliquez sur un bouton lorsque la liste Sélection de la source est au premier plan, il se peut que vous deviez cliquer une deuxième fois sur le bouton afin de l'activer.

Voir aussi

Création de requêtes avancées

Effacement de requêtes avancées existantes d'une requête

Suppression de requêtes avancées existantes

Édition de requêtes avancées existantes


Édition de requêtes avancées existantes

  1. Dans Suivi de documents BizTalk, dans la zone Requête avancée, cliquez sur Parcourir.

    La boîte de dialogue Requêtes avancées apparaît.

  2. Sélectionnez une requête existante, puis cliquez sur Modifier.

    La boîte de dialogue Générateur de requêtes avancées apparaît.

  3. Exécutez une des procédures suivantes :
    • Cliquez sur Nouveau pour ajouter une nouvelle condition. Spécifiez des conditions pour chacun des quatre champs, puis cliquez sur Terminé.

    • Cliquez sur une condition existante, cliquez sur Modifier, modifiez l'un des quatre champs, puis cliquez sur Terminé.

    • Sélectionnez une condition existante, puis cliquez sur Supprimer.
  4. Cliquez sur Enregistrer.

    La boîte de dialogue Requêtes avancées apparaît.

  5. Sélectionnez la requête que vous venez de modifier, puis cliquez sur OK.

Remarque

  • Si vous cliquez sur un bouton lorsque la liste Sélection de la source est au premier plan, il se peut que vous deviez cliquer une deuxième fois sur le bouton afin de l'activer.

Voir aussi

Création de requêtes avancées

Effacement de requêtes avancées existantes d'une requête

Suppression de requêtes avancées existantes

Localisation de requêtes avancées existantes


Effacement de requêtes avancées d'une requête

  • Dans Suivi de documents BizTalk, dans la zone Requête avancée, cliquez sur Effacer pour supprimer l'expression courante de la zone Nom d'expression.

Remarque

  • Si vous cliquez sur le bouton Actualiser dans Internet Explorer, la requête avancée n'est pas effacée de la zone Nom d'expression.

Voir aussi

Création de requêtes avancées

Suppression de requêtes avancées existantes

Édition de requêtes avancées existantes

Localisation de requêtes avancées existantes


Suppression de requêtes avancées existantes

  1. Dans Suivi de documents BizTalk, dans la zone Requête avancée, cliquez sur Parcourir.

    La page Requêtes avancées apparaît.

  2. Sélectionnez une requête, puis cliquez sur Supprimer.

  3. Fermez la boîte de dialogue Requêtes avancées lorsque vous avez terminé.

Remarque

  • Si vous cliquez sur un bouton lorsque la liste Sélection de la source est au premier plan, il se peut que vous deviez cliquer une deuxième fois sur le bouton afin de l'activer.

Voir aussi

Création de requêtes avancées

Effacement de requêtes avancées existantes d'une requête

Édition de requêtes avancées existantes

Localisation de requêtes avancées existantes


Enregistrement d'un échange, d'un document et de données de recherche personnalisée

Si vous avez configuré le Gestionnaire d'échanges BizTalk, le modèle d'objet de configuration d'échanges BizTalk, ou Administration de BizTalk Server pour stocker des échanges entrants et sortants et leurs documents, vous pouvez enregistrer des échanges, des données de documents et des données du champ de recherche personnalisée afin de pouvoir les afficher hors ligne. Cela simplifie le dépannage de certaines situations ou l'analyse de vos pratiques professionnelles.

Cette section traite des procédures suivantes :

  • Enregistrement des données d'échanges

  • Enregistrement des données d'une instance de document

  • Enregistrement des données du champ de recherche personnalisée


Enregistrement des données d'échanges

  1. Définissez les paramètres d'une requête, puis cliquez sur le bouton Requête.

    La page Résultats de la requête s'affiche.

    Pour plus d'informations sur la création de requêtes et de requêtes avancées, consultez :

    • Recherche par date des informations relatives aux documents et aux échanges

    • Recherche par organisation des informations relatives aux documents et aux échanges

    • Recherche par type de document des informations relatives aux documents et aux échanges

    • Création de requêtes avancées
  2. Localisez l'enregistrement d'échange qui contient les données d'échange à enregistrer et, dans le champ Données, cliquez sur l'icône des données.

    La page Afficher les données d'échange s'affiche.

  3. Cliquez sur Enregistrer sous.

  4. Dans la zone Nom de fichier, saisissez le nom du fichier, puis cliquez sur Enregistrer.

Voir aussi

Création de requêtes avancées

Enregistrement des données du champ de recherche personnalisée

Enregistrement des données d'une instance de document

Recherche par date des informations relatives aux documents et aux échanges

Recherche par type de document des informations relatives aux documents et aux échanges

Recherche par organisation des informations relatives aux documents et aux échanges


Enregistrement des données d'une instance de document

  1. Définissez les paramètres d'une requête et cliquez sur le bouton Requête.

    La page Résultats de la requête s'affiche.

    Pour plus d'informations sur la création de requêtes et de requêtes avancées, consultez :

    • Recherche par date des informations relatives aux documents et aux échanges

    • Recherche par organisation des informations relatives aux documents et aux échanges

    • Recherche par type de document des informations relatives aux documents et aux échanges

    • Création de requêtes avancées
  2. Localisez l'enregistrement d'échange qui contient les données d'instance de document à enregistrer et cliquez sur l'icône de l'indicateur de développement(+) à gauche de l'échange.

  3. Dans le champ Données, cliquez sur l'icône des données.

    La page Afficher les données de document s'affiche.

  4. Cliquez sur Enregistrer sous.

  5. Dans la zone Nom de fichier, saisissez un nom et une extension (soit l'extension de fichier .xml, soit l'extension de fichier native du document) pour le fichier, puis cliquez sur Enregistrer.

Voir aussi

Création de requêtes avancées

Enregistrement des données du champ de recherche personnalisée

Enregistrement des données d'échanges

Recherche par date des informations relatives aux documents et aux échanges

Recherche par type de document des informations relatives aux documents et aux échanges

Recherche par organisation des informations relatives aux documents et aux échanges


Enregistrement des données du champ de recherche personnalisée

  1. Définissez les paramètres d'une requête, puis cliquez sur le bouton Requête.

    La page Résultats de la requête s'affiche.

    Pour plus d'informations sur la création de requêtes et de requêtes avancées, consultez :

    • Recherche par date des informations relatives aux documents et aux échanges

    • Recherche par organisation des informations relatives aux documents et aux échanges

    • Recherche par type de document des informations relatives aux documents et aux échanges

    • Création de requêtes avancées
  2. Cliquez sur l'icône de l'indicateur de développement (+) à gauche de l'enregistrement d'échange qui contient le document à afficher.

  3. Utilisez la barre de défilement horizontale pour afficher le champ Recherche personnalisée du document à afficher et cliquez sur l'icône Recherche personnalisée.

    La page Afficher le champ de recherche personnalisée s'affiche.

  4. Cliquez sur Enregistrer sous.

  5. Dans la zone Nom de fichier, saisissez le nom du fichier, puis cliquez sur Enregistrer.

Voir aussi

Création de requêtes avancées

Enregistrement des données d'une instance de document

Enregistrement des données d'échanges

Recherche par date des informations relatives aux documents et aux échanges

Recherche par type de document des informations relatives aux documents et aux échanges

Recherche par organisation des informations relatives aux documents et aux échanges


Concepts

Cette section présente les concepts essentiels à la compréhension du suivi des documents et des activités de supervision.

Cette section traite des rubriques suivantes :

  • Environnement de suivi des documents BizTalk

  • Utilisation de Suivi de documents BizTalk

  • Présentation du schéma de la base de données de suivi

  • Recherche d'échanges et de documents associés

  • Présentation des résultats de requête

  • Présentation de l'état de la planification XLANG pour un échange

Remarque

  • Lors d'une sélection ou d'une sélection de requête, une boîte de dialogue peut afficher le message suivant :

    Cette page utilise des données situées dans un autre domaine. Voulez-vous continuer ?

    Pour éviter de recevoir ce message dans Internet Explorer, vous pouvez ajouter un site Web sécurisé aux zones de sites fiables sous l'onglet Sécurité de la boîte de dialogue Options Internet.

    Pour configurer manuellement les paramètres de votre navigateur afin de faire confiance à cette application Web, ajoutez l'application Web à la liste des sites fiables dans Internet Explorer. Pour plus d'informations sur l'ajout d'une application Web à la liste des sites fiables, consultez Configuration des paramètres de sécurité dans Internet Explorer.


Environnement de Suivi de documents BizTalk

Cette section traite des rubriques suivantes :

  • Interface utilisateur de Suivi des documents BizTalk

  • Touche de raccourci de Suivi de documents BizTalk


Interface utilisateur de Suivi de documents BizTalk

Suivi de documents BizTalk est une application Web autonome que vous pouvez utiliser pour afficher des échanges et des documents que vous avez configurés pour être suivis dans Microsoft BizTalk Server. La page principale comporte six zones :

  • Plage de dates

  • Sélection de la source

  • Sélection de la destination

  • Requête avancée

  • Contrôle du tri

  • Sélection du type de document

Vous pouvez configurer des paramètres de requête dans les zones Plage de dates, Sélection de la source, Sélection de la destination et Sélection du type de document.

Le côté inférieur gauche de la page contient les zones Requête avancée et Contrôle du tri. Configurez des paramètres dans la zone Requête avancée pour trouver des informations spécifiques ou des champs de recherche personnalisée. Configurez des options dans la zone Contrôle du tri pour spécifier l'ordre de tri sur la page Résultats de la requête.

Lorsque vous cliquez sur le bouton Requête sur la page principale, la page Résultats de la requête apparaît. Si des enregistrements dans la base de données de suivi correspondent à vos paramètres de requête, des enregistrements d'échange apparaissent dans une liste. Le tableau suivant répertorie et décrit les icônes disponibles dans la page Résultats de la requête.

Cliquez sur cette icône | Pour
Icône de données | Accéder aux données d'instance d'échange ou de document Si vous cliquez sur l'icône de données dans l'enregistrement d'échange, les données de l'échange apparaissent. Si vous cliquez sur l'icône de données dans l'enregistrement de l'instance de document, les données du document apparaissent.
Icône d'indicateur de développement | Développer l'enregistrement d'échange pour afficher l'enregistrement d'instance de document.
Icône d'indicateur de réduction | Réduire l'enregistrement d'échange pour masquer l'enregistrement d'instance de document.
Icône de planification XLANG | Afficher l'état de planification XLANG associé à un échange.
Icône d'accusé de réception | Afficher une page Résultats de la requête pour afficher le contenu de l'accusé de réception. Pour plus d'informations sur les résultats de l'accusé de réception, consultez Présentation des résultats d'accusé de réception.
Icône de recherche personnalisée | Afficher les données du champ de recherche personnalisée.


Touches de raccourci de Suivi de documents BizTalk

Vous pouvez utiliser des touches de raccourci pour effectuer certaines tâches dans Suivi de documents BizTalk. Le tableau suivant présente les touches de raccourci disponibles dans la page principale.

Remarque

  • Le clavier numérique permet d'obtenir la fonctionnalité non incluse dans la liste pour déplacer le pointeur de la souris à l'aide des touches souris. Pour plus d'informations sur les touches souris dans l'aide de Windows 2000 Server, voir « Utilisation du clavier pour déplacer le pointeur de la souris ». Dans l'aide de Windows 2000 Professionnel, consultez « Pour déplacer le pointeur de la souris en utilisant les touches souris ».
Appuyez sur | Pour
ALT+N | Ouvrir la page Générateur de requêtes avancées.
ALT+P | Ouvrir la page Requêtes avancées.
ALT+C | Effacer la requête avancée de la session de requête en cours.
ALT+S | Sélectionner toutes les organisations et applications dans la liste Sélection de la source.
ALT+O | Effacer la liste Sélection de la source.
ALT+L | Sélectionner toutes les organisations et applications dans la liste Sélection de la destination.
ALT+U | Effacer la liste Sélection de la destination.
ALT+I | Afficher tous les types de document dans la liste Sélection du type de document.
ALT+E | Sélectionner tous les types de document dans la liste Sélection du type de document.
ALT+T | Effacer la liste Sélection du type de document.
ALT+R | Ouvrir la page Résultats de la requête.
ALT+F | Fermer Suivi de documents BizTalk
ALT+A | Afficher l'aide en ligne.
ALT+une lettre soulignée ou le numéro d'un nom de champ | Déplacer le focus sur ce champ. Par exemple, ALT+1 place le focus sur Ordre de tri 1.

Le tableau suivant répertorie et décrit les touches de raccourci disponibles dans la page Résultats de la requête. Pour ouvrir la page Résultat de la requête, dans la page principale, appuyez sur ALT+Q.

Appuyez sur | Pour
ALT+N | Fermer la page Résultats de la requête.
ALT+A | Afficher l'aide en ligne.
BARRE ESPACE | Ouvrir ou fermer une icône. Vous devez utiliser la touche Tabulation pour placer le focus sur l'icône à ouvrir ou à fermer. Par exemple, si vous souhaitez développer un enregistrement d'échange, appuyez sur la touche Tabulation jusqu'à ce que le focus se trouve sur l'icône de développement pour l'enregistrement d'échange sélectionné. Appuyez ensuite sur la BARRE ESPACE.

Le tableau suivant répertorie et décrit les touches de raccourci disponibles dans la page Générateur de requêtes avancées. Pour ouvrir la page Générateur de requêtes avancées, dans la page principale appuyez sur ALT+N.

Appuyez sur | Pour
ALT+N | Ajouter une condition à l'expression de requête avancée.
ALT+M | Modifier une condition.
ALT+R | Supprimer une condition d'une expression de requête avancée.
ALT+E | Enregistrer l'expression
ALT+O | Limiter l'utilisation de l'expression à la session de requête en cours.
ALT+L | Fermer la page Générateur de requêtes avancées.
ALT+A | Afficher l'aide en ligne.
ALT+lettre soulignée d'un nom de champ | Placer le focus sur ce champ. Par exemple, ALT+V place le focus sur le champ Valeur.

Remarque

  • Si vous placez le focus sur la zone Requête et si celle-ci comporte plusieurs conditions, utilisez les touches flèches HAUT et BAS pour sélectionner la condition souhaitée.

Le tableau suivant répertorie et décrit les touches de raccourci disponibles dans la page Requêtes avancées. Pour ouvrir la page Requêtes avancées, dans la page principale appuyez sur ALT+B.

Appuyez sur | Pour
ALT+M | Modifier une expression existante
ALT+U | Ouvrir la page Générateur de requêtes avancées.
ALT+S | Supprimer une expression.
ALT+O | Ajouter l'expression à la requête en cours.
ALT+N | Fermer la page Requêtes avancées sans enregistrer vos modifications.
ALT+A | Afficher l'aide en ligne.


Utilisation de Suivi de documents BizTalk

Vous pouvez utiliser Suivi de documents BizTalk pour effectuer les opérations suivantes :

  • Suivre des échanges et des documents associés traités par Microsoft BizTalk Server 2000.

  • Satisfaire des exigences juridiques ou standard imposant la conservation de copies de toutes les transactions de commerce électronique.

  • Répondre aux questions des clients rapidement et facilement. Par exemple, si un client demande « Quand avons-nous envoyé une facture à notre partenaire commercial A ? », vous pouvez localiser la date et l'heure de l'envoi, et indiquer si un accusé de réception a été envoyé.

  • Aider au dépannage.

  • Aider à résoudre les conflits.

Les documents peuvent être suivis par lots ou sous forme de transactions individuelles. Suivi de documents BizTalk stocke automatiquement les métadonnées associées à un échange, telles que les informations de source et de destination, le type de document ainsi que les paramètres de date et d'heure. Les métadonnées sont stockées automatiquement ; cependant, des champs supplémentaires tels que Date de bon de commande ou Total de bon de commande, sont capturés uniquement si la configuration du modèle d'objets de configuration d'échanges BizTalk ou du Gestionnaire d'échanges BizTalk prévoit la capture de ces informations. Pour plus d'informations sur la configuration des champs sélectionnés à suivre, consultez Définition des propriétés de canal ou Définition du suivi pour les propriétés de document entrant.

Toutes les informations de suivi (les métadonnées ou les champs que vous avez configurés à suivre) sont stockées dans la base de données de suivi que vous avez configurée pendant l'installation ou lorsque que vous avez configuré un groupe de serveurs. Par le biais de l'interface utilisateur de Suivi de documents BizTalk, vous pouvez accéder aux données stockées dans la base de données de suivi associée à un groupe de serveurs particulier. Bien que certaines informations stockées dans la base de données de suivi ne soient pas accessibles par le biais de l'interface utilisateur, les métadonnées et les champs que vous avez configurés à suivre le sont. Par exemple, si vous devez suivre à quel moment l'application d'achat C a envoyé un bon de commande au partenaire commercial D et si ce dernier a répondu au bon de commande, vous pouvez le faire à l'aide de Suivi de documents BizTalk.

Cette section traite des rubriques suivantes :

  • Description des paramètres de suivi d'un groupe de serveurs

  • Description des paramètres de suivi du Gestionnaire d'échanges BizTalk

Remarque

  • Les accusés de réception d'échanges fiables ne s'affichent pas dans l'interface utilisateur de Suivi de documents BizTalk.

Voir aussi

Définition des propriétés de canal

Définition du suivi pour les propriétés de document entrant

Base de données de suivi


Description des paramètres de suivi d'un groupe de serveurs

Les paramètres de suivi d'un groupe de serveurs déterminent si le suivi des échanges est activé ou désactivé. Ce paramètre de suivi global est configuré dans Administration de BizTalk Server. Pour plus d'informations sur la configuration des paramètres de suivi d'un groupe de serveurs, voir Configuration des propriétés de suivi d'un groupe de serveurs. Si l'option Activer le suivi de documents est activée, vous pouvez configurer BizTalk Server pour consigner les échanges entrants, les échanges sortants ou les messages d'origine codés au format MIME.

Lorsque vous installez Microsoft BizTalk Server 2000, le suivi de documents est automatiquement activé, les options Consigner l'échange entrant dans un journal et Consigner l'échange sortant dans un journal sont activées, et les métadonnées pour les échanges sont suivies, comme par exemple :

  • les informations d'organisation source ;

  • les informations d'organisation de destination ;

  • le type de document ;

  • la date et l'heure de traitement de l'échange par BizTalk Server ;

  • le nombre de documents ;

  • les informations d'erreur ;

  • l'identificateur de contrôle.

En plus de suivre les échanges, vous pouvez également configurer BizTalk Server pour suivre des champs spécifiques, tels que Total de bon de commande ou Total de facture. Pour plus d'informations sur le suivi de champs spécifiques, consultez Description des paramètres de suivi du Gestionnaire d'échanges BizTalk. Si vous devez conserver une copie des échanges dans leur format d'origine pour des problèmes de non-répudiation et des aspects juridiques commerciaux, utilisez les paramètres de suivi globaux. Si vous souhaitez créer une trace d'audit à des fins internes, ou si vous souhaitez accéder facilement à des données par document, configurez les paramètres de suivi dans le modèle d'objets de configuration d'échanges BizTalk ou dans le Gestionnaire d'échanges BizTalk. Vous pouvez configurer les paramètres de suivi dans le modèle d'objets de configuration d'échanges BizTalk ou dans le Gestionnaire d'échanges BizTalk et Administration de BizTalk Server. Cependant, la base de données de suivi pourrait ainsi devenir rapidement très volumineuse et stockerait des données en double.

Désactivation des paramètres de Suivi de documents BizTalk

Si vous n'avez absolument pas besoin de suivre des documents, vous pouvez désactiver Suivi de documents BizTalk. Cependant, vous perdrez ainsi une importante fonctionnalité. Par exemple, si le suivi de documents est désactivé, vous ne pouvez pas :

  • suivre les échanges et les documents associés lors de leur traitement dans BizTalk Server 2000 ;

  • satisfaire les exigences juridiques ou standard imposant la conservation de copies de toutes les transactions de commerce électronique ;

  • répondre aux questions des clients rapidement et facilement ; par exemple, si un client demande « Quand avons-nous envoyé une facture à notre partenaire commercial A ? », vous ne pouvez pas localiser la date et l'heure de l'envoi, et indiquer si un accusé de réception a été envoyé ;

  • aider au dépannage :

  • aider à résoudre les conflits.

Pour activer ou désactiver le suivi de documents, ou pour modifier les paramètres de suivi globaux, utilisez Administration de BizTalk Server. Pour plus d'informations sur la configuration des paramètres de suivi d'un groupe de serveurs, voir Configuration des propriétés de suivi d'un groupe de serveurs.

Remarques

  • Pour ouvrir Administration de BizTalk Server, dans le menu Démarrer, pointez sur Programmes, sur Microsoft BizTalk Server 2000, puis cliquez sur Administration de BizTalk Server.

  • Une limite est imposée quant à la taille des échanges et des documents. Pour plus d'informations sur les limites de taille, voir Limite de la taille des documents et des échanges.

Voir aussi

Configuration des propriétés de suivi d'un groupe de serveurs

Limite de la taille des documents et des échanges

Ouverture de Administration de BizTalk Server

Description des paramètres de suivi du Gestionnaire d'échanges BizTalk


Description des paramètres de suivi dans le Gestionnaire d'échanges BizTalk

Configurez les paramètres de suivi dans le Gestionnaire d'échanges BizTalk si vous devez :

  • stocker des copies complètes des instances de documents entrantes et sortantes ;

  • configurer des champs spécifiques, tels que Total de bon de commande ou Date de bon de commande, à capturer.

Contrairement aux propriétés de suivi d'un groupe de serveurs, le suivi de champs spécifiques ou le stockage de copies d'instances de document n'est pas automatiquement activé. Vous devez configurer ces options lorsque vous configurez le ou les canaux ou la ou les définitions de document appropriés dans le Gestionnaire d'échanges BizTalk.

Pour plus d'informations sur le stockage d'instances de document entrantes ou sortantes, consultez Définition des propriétés de journalisation de document. Pour plus d'informations sur le suivi de champs spécifiques, consultez Sélection des champs de spécification dans un canal.

Remarques

  • Pour ouvrir le Gestionnaire d'échanges BizTalk, dans le menu Démarrer, pointez sur Programmes, choisissez Microsoft BizTalk Server 2000, puis cliquez sur Gestionnaire d'échanges BizTalk.

  • Une limite est imposée pour le suivi et le stockage de documents. Pour plus d'informations sur les limites de taille, voir Limite de la taille des documents et des échanges.

Voir aussi

Limite de la taille des documents et des échanges

Sélection des champs de spécification dans un canal

Définition des propriétés de journalisation de document

Description des paramètres de suivi d'un groupe de serveurs


Présentation du schéma de la base de données de suivi

Tous les serveurs d'un groupe de serveurs partagent une base de données Suivi unique qui stocke toutes les informations relatives aux activités d'échanges et de documents dans BizTalk Server. La base de données de suivi est utilisée pour assurer le suivi de l'état d'un échange ou d'un document en transit dans le serveur. Les trois principales tables de la base de données de suivi sont les suivantes :

  • dta_interchange_details

  • dta_outdoc_details

  • dta_indoc_details

Les tables de support sont les suivantes :

  • dta_group_details

  • dta_interchange_data

  • dta_document_data

  • dta_debug_data

  • dta_routing_details

  • dta_custom_field_names

  • dta_MIME_data

L'illustration suivante montre le schéma global de la base de données de suivi. Par souci de clarté, seuls les noms de table sont indiqués dans l'illustration suivante. Les lignes qui relient les tables indiquent comment les tables sont connectées par le biais de champs de clé étrangère. Ces champs de clé et leurs relations aux autres tables seront décrits de façon détaillée dans les rubriques Structure des tables de métadonnées principales et Structure des tables secondaires.

Schéma de la base de données de suivi

Schéma de la base de données de suivi
dta_group_details
dta_indoc_details
(core table)
dta_document_data
dta_routing_details
dta_custom_field_names
dta_outdoc_details
(core table)
dta_interchange_details
(core table)
dta_interchange_data
dta_debugdoc_data

Cette section traite des rubriques suivantes :

  • Tables de métadonnées principales

  • Tables secondaires

  • Structure des tables de métadonnées principales

  • Structure des tables secondaires

  • Tables connexes

  • Consignation des échanges et des documents

  • Consignation des accusés de réception

  • Consignation des informations de routage

  • Suivi des événements de planification XLANG dans la base de données de suivi


Table de métadonnées principales

Les tables principales stockent les métadonnées des échanges traités par BizTalk Server. Les métadonnées incluent des informations d'organisation source et de destination, le type du document, la date et l'heure de traitement de l'échange, le nombre de documents, des informations d'erreur, une identification de contrôle, etc.

Les trois tables suivantes forment les métadonnées principales de la base de données de suivi :

  • dta_indoc_details

  • dta_outdoc_details

  • dta_interchange_details

Le tableau suivant décrit la fonction de chaque table principale.

Nom de la table | Description
dta_indoc_details | Contient un enregistrement pour chaque document soumis à BizTalk Server.
dta_outdoc_details | Contient un enregistrement pour chaque document généré par BizTalk Server. Un document soumis à BizTalk Server peut entraîner la génération et la livraison d'un ou plusieurs documents à un ensemble de destinations respectives en raison d'une correspondance de plusieurs canaux et de groupes de port. La séparation des documents en entrée et en sortie en deux tables permet une représentation physique de cette relation un à plusieurs.
dta_interchange_details | Contient un enregistrement pour chaque échange traité par BizTalk Server. Un indicateur de direction sur cette table permet la différenciation entre soumissions et transmissions.

Voir aussi

Structure des tables de métadonnées principales


Tables secondaires

Les sept tables secondaires prenant en charge les tables de métadonnées principales sont les suivantes :

  • dta_document_data

  • dta_debugDoc_data

  • dta_interchange_data

  • dta_routing_details

  • dta_group_details

  • dta_custom_field_names

  • dta_MIME_data

Ces tables stockent des informations de support, telles que des données de document, des informations de routage, des informations de recherche personnalisée, etc. Le tableau suivant décrit la fonction de chaque table.

Nom de la table | Description
dta_document_data | Contient un enregistrement pour chaque document soumis à BizTalk Server ou envoyé par BizTalk Server.
dta_debugDoc_data | Contient une ligne pour chaque élément inDoc ou outDoc configuré (sur l'objet de canal d'échange) pour enregistrer son format XML temporaire.
dta_interchange_data | Contient une ligne pour chaque échange soumis à BizTalk Server ou envoyé par BizTalk Server. Cette table stocke également les documents de réponse renvoyés à l'application appelante IInterchange::SubmitSync.
dta_routing_details | Agit comme miroir des ports d'échanges dans le but d'éliminer toute dépendance de bases de données croisées sur la base de données Gestion d'échanges BizTalk. Spécifiquement, il est nécessaire de suivre les informations source et de destination relatives aux documents traités. Ces informations, qui proviennent de la base de données Gestion d'échanges BizTalk, sont répétées ici lorsque de nouvelles permutations sont rencontrées.
dta_group_details | Fournit des composants d'extensibilité (analyseur, sérialiseur et corrélateur de réception) pour des formats de document qui emploie des groupes de documents similaires (par exemple, X12 ou EDIFACT) dans un échange. Cette table contient une ligne pour chaque groupe analysé ou sérialisé par ces composants.
dta_custom_field_names | Contient une ligne pour chaque paire de nom de noeud de champ de capture et de type de données rencontrée par BizTalk Server. Cette table est une référence croisée pour la table dta_outdoc_details, qui utilise une clé étrangère dans cette table pour ses noms de champ de capture. La table dta_indoc_details est connectée à cet ensemble de noms de champ indirectement par l'existence d'une clé étrangère pointée de la table dta_outdoc_details à son parent dans la table dta_indoc_details.
dta_MIME_data | Contient une ligne pour chaque échange codé au format MIME soumis à BizTalk Server. Cette table permet de suivre des données MIME contenant des pièces jointes.

Voir aussi

Structure des tables secondaires


Structure des tables de métadonnées principales

Les tables de métadonnées principales sont reliées de la façon décrite dans cette section et stockent les métadonnées de tous les échanges traités par BizTalk Server, si les paramètres de suivi sont configurés. Pour plus d'informations sur la configuration des paramètres de suivi d'un groupe de serveurs, consultez Description des paramètres de suivi d'un groupe de serveurs.

dta_indoc_details

Cette table a une relation un à plusieurs avec la table suivante :

  • dta_outdoc_details

Cette table a une relation plusieurs à un avec les tables suivantes :

  • dta_group_details

  • dta_interchange_details

  • dta_error_message

  • dta_validity_values

Cette table a une relation un à un avec les tables suivantes :

  • dta_debugDoc_data

  • dta_document_data

  • dta_error_message

La table dta_indoc_details contient une ligne par document soumis à BizTalk Server. Le tableau suivant décrit les champs de la table dta_indoc_details.

Nom de champ | Description
nInDocKey | Identificateur d'enregistrement à clé primaire unique.
nDocumentDataKey | Clé étrangère vers dta_document_data.
nDebugDocDataKey | Clé étrangère vers dta_debugDoc_data pour le format XML du document reçu, même si le document reçu est XML.
nGroupKey | Clé étrangère vers dta_group_details.
nInterchangeKey | Clé étrangère vers dta_interchange_details.
uidTrackingGUID | Valeur de clé de suivi principale basée sur un identificateur global unique (GUID).
dtProcessedTimeStamp | Heure de création de l'enregistrement.
nvcSyntax | Code de la syntaxe du document (XML,X12,EDIFACT, HL7, etc.). Dans le cas d'une syntaxe non reconnue en raison d'un incident d'analyse ou d'une soumission directe, ce champ prend la valeur « UNKNOWN ».
nvcVersion | Version de la syntaxe.
nvcRelease | Diffusion de la version.
nvcDocType | Type de document ou identificateur du jeu de transactions.
nvcControlID | Numéro de contrôle unique pour des documents et des groupes fonctionnels EDI (electronic data interchange).
nlsValid | Code qui indique des résultats de validation. Les valeurs possibles sont 0 (non valide), 1 (valide), ou 2 (direct).
nError | Code qui indique l'occurrence d'une erreur. Il s'agit de la clé étrangère vers dta_error_message, la table qui contient les descriptions des messages d'erreur._brdrnone

dta_outdoc_details

Cette table a une relation plusieurs à un avec les tables suivantes :

  • dta_indoc_details

  • dta_interchange_details

  • dta_group_details

  • dta_debugDoc_data

  • dta_routing_details

  • dta_error_message

  • dta_ack_status

  • dta_data_level_values

  • dta_validity_values

Cette table a une relation un à un avec les tables suivantes :

  • dta_document_data

  • dta_error_message

Cette table a une relation plusieurs à plusieurs avec les tables suivantes :

  • dta_custom_field_names

  • dta_ack_status_values

La table dta_outdoc_details contient une ligne par document envoyé par BizTalk Server. Le tableau suivant décrit les champs de la table dta_outdoc_details.

Nom de champ | Description
nOutDocKey | Identificateur d'enregistrement à clé primaire unique.
nInDocKey | Clé étrangère vers l'enregistrement parent de dta_indoc_details.
nDocumentDataKey | Clé étrangère vers la table dta_document_data.
nDebugDocDataKey | Clé étrangère vers dta_debugDoc_data pour le format XML du document sortant, même si le document sortant est XML. Lorsqu'un document sortant est envoyé à un groupe de ports, seule une copie de l'enregistrement dta_debugDoc_data est stockée, et tous les enregistrements dta_outdoc_details résultants pointent vers elle.
nGroupKey | Clé étrangère vers la table dta_group_details.
nInterchangeKey | Clé étrangère vers la table dta_interchange_details.
uidTrackingGUID | Valeur de clé de suivi principale basée sur un identificateur global unique (GUID).
dtProcessedTimeStamp | Heure de création de l'enregistrement.
nvcSyntax | Code de la syntaxe du document (XML, X12, EDIFACT, HL7, etc.). Dans le cas d'une syntaxe non reconnue en raison d'un incident d'analyse ou d'une soumission directe, ce champ prend une valeur « UNKNOWN ».
nvcVersion | Version de la syntaxe.
nvcRelease | Diffusion de la version.
nvcDocType | Type de document ou identificateur du jeu de transactions.
nvcControlID | Numéro de contrôle unique pour des documents et des groupes fonctionnels EDI.
nlsValid | Code qui indique des résultats de validation. Valeurs possibles sont 0 (non valide), 1 (valide), ou 2 (transfert).
nError | Code qui indique l'occurrence d'une erreur. Il s'agit de la clé étrangère vers dta_error_message, la table qui contient les descriptions des messages d'erreur.
nAckStatus | Code de l'état de la réception. C'est une clé étrangères vers dta_ack_status_values, la table qui contient des descriptions d'état d'accusé de réception.
nRoutingKey | Clé étrangère vers dta_routing_details.
nReceiptFlag | Un indicateur qui précise à quelle table un accusé de réception est associé. Les valeurs possibles sont 1 (échange), 2 (groupe), 4 (indoc), 8 (outdoc). Pour plus d'informations sur les accusés de réception, consultez Consignation des accusés de réception.
nReceiptKey | Un numéro unique qui identifie l'accusé de réception. Pour plus d'informations sur les accusés de réception, consultez Consignation des accusés de réception.
ntReceiptDueBy | Horodatage d'échéance d'accusé de réception, calculé pour correspondre à l'horodatage de traitement.
nRealName1 | Clé étrangère vers dta_custom_field_names.
rlRealValue1 | Champ de capture réelle 1. Ce champ doit prendre une valeur réelle à 8 octets.
nRealName2 | Clé étrangère vers dta_custom_field_names.
rlRealValue2 | Champ de capture réelle 2. Ce champ doit prendre une valeur réelle à 8 octets.
nIntName1 | Clé étrangère vers dta_custom_field_names.
nIntValue1 | Champ de capture de nombre entier 1.
nIntName2 | Clé étrangère vers dta_custom_field_names.
nIntValue2 | Champ de capture de nombre entier 2.
nDateName1 | Clé étrangère vers dta_custom_field_names.
dtDateValue1 | Champ de capture de date 1.
nDateName2 | Clé étrangère vers dta_custom_field_names.
dtDateValue2 | Champ de capture de date 2.
nStrName1 | Clé étrangère vers dta_custom_field_names.
nvcStrValue1 | Champ de capture de chaîne 1.
nStrName2 | Clé étrangère vers dta_custom_field_names.
nvcStrValue2 | Champ de capture de chaîne 2.
nvcCustomSearch | Objet binaire volumineux pour capture de chaîne concaténée sous forme XML.

dta_interchange_details

Cette table a une relation un à plusieurs avec les tables suivantes :

  • dta_indoc_details

  • dta_outdoc_details

  • dta_group_details

  • dta_interchange_data

Cette table a une relation plusieurs à un avec les tables suivantes :

  • dta_direction_values

  • dta_error_message

  • dta_transport_type_values

La table dta_interchange_details contient une ligne par échange traité par BizTalk Server. Le tableau suivant décrit les champs dans la table dta_interchange_details.

Nom de champ | Description
nInterchangeKey | Identificateur d'enregistrement à clé primaire unique.
nInterchangeDataKey | Clé étrangère vers dta_interchange_data.
nResponseDocDataKey | Clé étrangère vers dta_document_data pour le document de réponse renvoyé par le destinataire d'un transport sortant.
uidInterchangeGUID | Identificateur global unique (GUID) de l'échange.
uidSubmissionGUID | Identificateur global unique (GUID) de la soumission du parent. Notez qu'il contient l'identificateur de corrélation (correlationID) fourni depuis les services d'Orchestration BizTalk ou à ces services. Ce champ est vide si l'enregistrement est destiné à un échange entrant ne provenant pas des services d'Orchestration BizTalk. Pour les échanges entrants, ce champ est rempli uniquement si l'échange provient des services d'Orchestration BizTalk. Pour les échanges sortants, ce champ est toujours rempli.
dtProcessedTimeStamp | Heure de création de l'enregistrement.
nvcSyntax | Code de la syntaxe du document (XML, X12, EDIFACT, HL7, etc.). Dans le cas d'une syntaxe non reconnue en raison d'un incident d'analyse ou d'une soumission directe, ce champ prend une valeur « UNKNOWN ».
nvcVersion | Version de la syntaxe.
nvcControlID | Numéro de contrôle unique pour des échanges EDI (electronic data interchange) ou un identificateur pour les messages BizTalk fiables.
nDirection | Indicateur précisant si l'échange est entrant ou sortant. Valeurs possibles sont 0 (sortant) ou 1 (entrant). C'est une clé étrangère vers dta_direction_values, la table qui contient les valeurs de direction.
dtTimeSent | Horodatage d'une transmission réussie.
nError | Code qui indique l'occurrence d'une erreur. Il s'agit de la clé étrangère vers dta_error_message, la table qui contient les descriptions des messages d'erreur.
nTestMode | Indicateur de test ou de production Ce champ est réservé et n'est pas utilisé.
nvcSrcAliasQualifer | Valeur de qualificateur de l'émetteur extraite de l'échange soumis ou transmis.
nvcSrcAliasId | Valeur de l'identificateur de l'émetteur extraite de l'échange soumis ou transmis.
nvcSrcAppName | Identificateur de niveau d'échange pour l'application source extrait de l'échange soumis ou transmis.
nvcDestAliasQualifier | Qualificateur du destinataire extrait de l'échange soumis ou transmis.
nvcDestAliasID | Valeur de l'identificateur du destinataire extraite de l'échange soumis ou transmis.
nvcDestAppName | Identificateur de niveau d'échange pour l'application de destination extrait de l'échange soumis ou transmis.
nAckStatus | Code de l'état de la réception. C'est une clé étrangère vers dta_ack_status_values, la table qui contient des descriptions d'état d'accusé de réception.
nvcSMTPMessageID | Identificateur du message de transport SMTP (pour EDIINT). Ce champ est réservé et n'est pas utilisé.
nDocumentsAccepted | Le nombre de documents acceptés dans l'échange.
nDocumentsRejected | Le nombre de documents refusés dans l'échange.
nTransportType | Code d'indicateur de protocole de transmission. C'est une clé étrangère vers dta_transport_type_values.
nvcTransportAddress | Adresse de la cible de transport.
nvcServerName | Serveur qui a traité l'échange.
nNumberOfBytes | Taille de l'échange, en octets. Ce champ représente ce qui est suivi dans l'enregistrement dta_interchange_data associé et peut être différent de ce qui est transmis en réalité. La taille peut être augmentée par un traitement d'enveloppe supplémentaire et par une conversion du format de données pendant la transmission.
nNumOfTransmitAttempts | Compteur de tentatives de transmission.

Voir aussi

Description des paramètres de suivi d'un groupe de serveurs


Structure des tables secondaires

Les tables secondaires stockent les données de support des tables principales dans la base de données de suivi. Par exemple, les tables secondaires stockent ces types d'informations :

  • données du champ de recherche personnalisée ;

  • informations de routage ;

  • données d'échange ;

  • données du document.

dta_document_data

Cette table a une relation un à un avec les tables suivantes :

  • dta_indoc_details

  • dta_outdoc_details

La table dta_document_data constitue le référentiel central pour le stockage des documents. Le tableau suivant décrit les champs de la table dta_document_data.

Nom de champ | Description
nDocumentDataKey | Identificateur d'enregistrement à clé primaire unique.
nCodePage | La page de code système (par exemple, 1200-Unicode, 65001-UTF-8, etc.) pour les données codées au format caractères. Ce champ a une valeur de -1 si BizTalk Server n'a pas d'informations de page de code sur les données. Dans ce cas, la valeur du champ nBLOBType devrait fournir des informations sur le mode d'interprétation des données.
nBLOBType | Indicateur qui précise le type des données stockées dans le champ imgDocumentData. Les valeurs possibles sont 0 (unknown) ou 1 (XMLDOM chargeable). XMLDOM chargeable indique que les données peuvent être chargées et manipulées par l'objet MSXML DOMDocument. Ce champ est une clé étrangère vers dta_blobtype_values.
imgDocumentData | Stockage d'un document, sous forme d'objet binaire volumineux.
nNumberOfBytes | La taille du document, en octets.
nNumberOfRecords | Enregistrements ou segments contenus dans le document.

dta_debugDoc_data

Cette table a une relation un à un avec la table suivante :

  • dta_indoc_details

Cette table a une relation un à plusieurs avec la table suivante :

  • dta_outdoc_details

Cette table constitue le référentiel central pour le stockage des documents de débogage. Le tableau suivant décrit les champs de la table dta_debugDoc_data.

Nom de champ | Description
nDebugDocDataKey | Identificateur d'enregistrement à clé primaire unique.
ntxtDocumentData | Stockage du document, sous forme d'objet binaire volumineux. Toujours en Unicode.
nNumberOfBytes | Taille du document, en octets.
dtProcessedTimeStamp | Heure de création de l'enregistrement. Elle est utilisée par l'exemple de travail de purge se trouvant dans \Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\SQLServerAgentJobs\DTA_SampleJobs.sql, dans le répertoire d'installation de BizTalk Server.

dta_interchange_data

Cette table a une relation plusieurs à un avec la table suivante :

  • dta_interchange_details

La table dta_interchange_data constitue un référentiel central pour le stockage des échanges et contient un enregistrement pour chaque échange traité par le système. Pour les échanges soumis à BizTalk Server uniquement, le champ nlsFile indique si les données stockées d'origine proviennent du système de fichiers. Si l'indicateur est activé, le champ nvcOriginalFileName est un chemin à convention d'affectation de noms (UNC) vers l'emplacement du système de fichiers d'où proviennent les données. Le champ imgInterchangeData contient les données soumises, quelle qu'en soit l'origine.

Nom de champ | Description
nInterchangeDataKey | Identificateur d'enregistrement à clé primaire unique.
nCodePage | La page de code système (par exemple, 1200-Unicode, 65001-UTF-8, etc.) pour les données codées au format caractères. Ce champ à une valeur -1 si BizTalk Server n'a pas d'informations de page de code sur les données, ou si les données sont suivies à la suite d'une soumission directe. Dans ce cas, la valeur du champ nBLOBType devrait fournir des informations sur le mode d'interprétation des données.
nlsFile | Indicateurs précisant une soumission des données basée sur un fichier. Les valeurs possibles sont 0 (non basée sur un fichier) ou 1 (basée sur un fichier).
nvcOriginalFileName | Chemin à convention d'affectation de noms (UNC) vers le fichier, si le champ nlsFile a la valeur 1.
nBLOBType | Indicateur qui précise le type des données stockées dans le champ imgDocumentData. Les valeurs possibles sont 0 (unknown) ou 1 (XMLDOM chargeable). XMLDOM chargeable indique que les données peuvent être chargées et manipulées par l'objet MSXML DOMDocument. Ce champ est une clé étrangère vers dta_blobtype_values.
imgInterchangeData | Stockage de l'échange, sous forme d'objet binaire volumineux.

dta_group_details

Cette table a une relation un à plusieurs avec les tables suivantes :

  • dta_indoc_details

  • dta_outdoc_details

Cette table a une relation plusieurs à un avec les tables suivantes :

  • dta_interchange_details

  • dta_direction_values

La table dta_groug_details crée une ligne par groupe traité par les composants d'extensibilité pour l'échange de données électroniques (EDI). Le tableau suivant décrit les champs de la table dta_group_details.

Nom de champ | Description
nGroupKey | Identificateur d'enregistrement à clé primaire unique.
nInterchangeKey | Clé étrangère vers dta_interchange_details.
dtProcessedTimeStamp | Heure de création de l'enregistrement.
nvcSyntax | Code de la syntaxe du document (XML, X12, EDIFACT, HL7, etc.). Dans le cas d'une syntaxe non reconnue en raison d'un incident d'analyse ou d'une soumission directe, ce champ prend la valeur « UNKNOWN ».
nvcVersion | Version du standard.
nvcRelease | Diffusion de la version.
nvcFunctionalGroupID | Code pour le type de document dans le groupe.
nvcControlID | Numéro de contrôle unique pour des documents et groupe fonctionnels EDI (electronic data interchange).
nvcSrcAppName | Identificateur de niveau de groupe pour l'application source.
nvcDestAppName | Identificateur de niveau de groupe pour l'application de destination.
nAckStatus | Code de l'état de la réception. C'est une clé étrangères vers dta_ack_status_values, la table qui contient des descriptions d'état d'accusé de réception.
nDirection | Indicateur précisant si le groupe est entrant ou sortant. Les valeurs possibles sont 0 (sortant) ou 1 (entrant). C'est une clé étrangère vers dta_direction_values.
nDocumentsAccepted | Transactions acceptées dans le groupe.
nDocumentsRejected | Transactions refusées dans le groupe.
nNumberOfBytes | Taille de l'échange, en octets.

dta_routing_details

Cette table a une relation un à plusieurs avec la table suivante :

  • dta_outdoc_details

La table dta_routing_details contient une ligne par jeux d'informations source ou de destination. Deux documents peuvent avoir des valeurs de champ de routage identique au niveau de l'organisation ou de l'application. Dans ce cas, ces documents sont différenciés par le type de documents ou un autre filtre de niveau inférieur. Lorsque cela se produit, la table dta_routing_details contient des lignes identiques, à l'exception d'une différence dans leurs ports d'échanges parents respectifs. Ce lien au port d'échanges parent est utilisé pour faciliter une connexion entre les fonctionnalités d'interface utilisateur du Gestionnaire d'échanges BizTalk et le suivi. Le tableau suivant décrit les champs de la table dta_routing_details.

Nom de champ | Description
nRoutingKey | Identificateur d'enregistrement à clé primaire unique.
nvcSrcOrgName | Nom de l'organisation source, tel qu'elle spécifié sur l'objet de canal parent.
nvcSrcAppName | Nom de l'application source, tel que spécifié sur l'objet du canal parent.
nvcDestOrgName | Nom de l'organisation de destination, tel que spécifié sur l'objet du port d'échanges.
nvcDestAppName | Nom de l'application de destination, tel que spécifié sur l'objet du port parent.
nvcDistributionName | Nom de la liste de distribution.
uidChannelGUID | Clé unique pour le canal parent basée sur un identificateur global unique (GUID). Ce champ est utilisé comme une clé de corrélation de canal dans la base de données Gestion d'échanges BizTalk.
uidPortGUID | Clé unique pour le port parent basée sur un identificateur global unique (GUID). Ce champ est une clé de corrélation de port dans la base de données Gestion d'échanges BizTalk.

dta_custom_field_names

Cette table a une relation plusieurs à un avec la table suivante :

  • dta_outdoc_details

La table dta_custom_field_names contient une ligne par nom de noeud distinct et paire de types de données capturés. Le tableau suivant décrit les champs de la table dta_custom_field_names.

Nom de champ | Description
nNameKey | Identificateur d'enregistrement à clé primaire unique.
nvcName | Texte du nom de noeud, par exemple, /CommonPO/Total/@POTotal.
nDataType | Type des données contenues dans le noeud nommé.

dta_MIME_data

La table dta_MIME_data stocke les données MIME entrantes traitées par BizTalk Server. Cette table permet de suivre des données MIME contenant des pièces jointes. Le tableau suivant décrit les champs de la table dta_MIME_data.

Nom de champ | Description
nMIMEDataKey | Identificateur d'enregistrement à clé primaire unique.
uidSubmissionGUID | Identificateur global unique (GUID) de la soumission du parent.
nCodePage | Page de code système pour les données stockées codées au format caractères dans le champ imgMIMEData. Pour les données MIME, la valeur est 1252 (ASCII) ou 1200 (Unicode).
imgMIMEData | Stockage du document, sous forme d'objet binaire volumineux.


Tables connexes

Il existe 13 tables supplémentaires dans la base de données de suivi qui prennent en charge les tables principales ou les tables de support. Ces tables stockent des informations telles que les clés de corrélation de groupe et d'échange, des valeurs d'état d'accusé de réception, des valeurs de niveau de données, etc. Le tableau suivant décrit chaque table et sa fonctionnalité.

Nom de la table | Fonction
dta_ack_status_values | Stocke les valeurs d'état d'accusé de réception. Les valeurs possibles sont Aucun, En attente, En retard, Accepté, Accepté avec les erreurs et Rejeté.
dta_blobtype_values | Stocke les types d'objet binaire volumineux. Les valeurs possibles sont « Unknown » et « XMLDOM chargeable ».
dta_data_level_values | Stocke les valeurs des niveaux de données employées dans BizTalk Server. Les valeurs possibles sont Échange, Grouper, Document entrant et Document sortant.
dta_direction_values | Stocke la direction de l'échange. Les valeurs possibles sont entrant et sortant.
dta_error_message | Stocke les messages d'erreurs utilisés dans Suivi de documents BizTalk. Les valeurs possibles sont Aucune erreur, Impossible d'appeler un composant personnalisé, Impossible d'analyser l'échange, Le canal spécifié n'existe pas, Impossible de sérialiser l'échange, Impossible de coder l'échange, Impossible de signer l'échange, Impossible de crypter l'échange, Échec de la tentative de transmission (une nouvelle tentative est en attente), Échec de la dernière tentative de transmission, Impossible d'analyser le document, Impossible de valider le document, Impossible de trouver un canal valide, Impossible d'analyser le document, Impossible de valider le document, Impossible de trouver un canal valide, Impossible de mapper le document, Impossible de trouver un port d'échanges valide, Impossible de sérialiser le document.
dta_group_correlation_keys | Stocke les clés de corrélation de groupe. Les valeurs sont générées dynamiquement pour l'identification d'éventuels candidats de groupe pendant la corrélation de réception.
dta_interchange_correlation_keys | Stocke les clés de corrélation d'échange. Les valeurs sont uniques et générées dynamiquement pour l'identification d'éventuels candidats de groupe pendant la corrélation de réception.
dta_transport_type_values | Stocke les valeurs de types de transport. Les valeurs possibles sont Aucun, HTTP, SMTP, DCOM, Intégration de l'application, Message Queuing, Fichier, HTTPS, Destination ouverte, Bouclage et Activation d'orchestration.
dta_ui_codepage_charset | Stocke les pages de code système pour les données codées au format caractères.
dta_ui_user_queries | Stocke les requêtes avancées que les utilisateurs individuels créent et enregistrent.
dta_validity_values | Stocke les valeurs de validité. Les valeurs possibles sont Non valide, Valide et Transfert. La valeur Transfert indique que le document n'a pas été analysé et que la validité ne s'applique pas. Pour plus d'informations sur la valeur transfert, consultez Description des propriétés avancées d'une fonction de réception.
dta_wf_EventData | Contient un enregistrement pour chaque propriété consignée en relation à un événement COM+ surveillé déclenché par une planification XLANG. Les ensembles de lignes multiples dans cette table partagent un parent commun dans la table dta_wf_WorkFlowEvent.
dta_wf_WorkFlowEvent | Contient un enregistrement pour chaque événement COM+ surveillé déclenché par une planification XLANG.


Consignation des échanges et des documents

Différents scénarios de traitement, tels que source ouverte, destination ouverte et transfert, sont consignés différemment dans la base de données de suivi. Les six scénarios de traitement courants sont Non ouvert, Source ouverte, Destination ouverte, Bouclage, Transfert, et Attendre un accusé de réception et Générer un accusé de réception (Attendre un accusé de réception et Générer un accusé de réception sont considérés comme un scénario). Les scénarios de traitement Attendre un accusé de réception et Générer un accusé de réception sont décrits dans Consignation des accusés de réception. Les autres scénarios de traitement sont décrits dans le tableau suivant.

Scénario de traitement | Description
Non ouvert | Se produit lorsque la source et la destination sont déclarées de façon explicite dans la fonction de réception, l'instance de document, la méthode Submit ou la méthode SubmitSync.
Source ouverte | Se produit lorsque les informations source ne sont pas explicitement déclarées dans le canal. Le canal doit être marqué comme source ouverte, et l'appel soumis ou la fonction de réception doit spécifier la propriété Openness de la source.
Destination ouverte | Se produit lorsque les informations de destination ne sont pas explicitement déclarées dans le port d'échanges. La destination est spécifiée dynamiquement dans l'instance de document, la méthode Submit la méthode SubmitSync. Le port doit être marqué comme destination ouverte, et l'appel soumis ou la fonction de réception doit indiquer la propriété Openness de la destination.
Bouclage | Se produit lorsqu'un bouclage est le transport spécifié dans un canal. Un bouclage renvoie le document sortant à une application professionnelle, un composant ou une planification XLANG qui a soumis le document entrant avec la méthode SubmitSync. Ce type de transport est disponible uniquement pour un port d'échanges qui se connecte à une application et est disponible uniquement par le biais de la méthode SubmitSync.
Transfert | Se produit lorsque vous sélectionnez l'option Soumettre avec un indicateur direct dans la fonction de réception ou configurez la propriété Pass-through dans la méthode Submit ou la méthode SubmitSync. BizTalk Server ne traite pas le document. Cela signifie que le document n'est pas analysé, signé, décrypté, vérifié, etc. Le document est uniquement transporté par BizTalk Server.

Le tableau suivant présente les enregistrements sortants consignés dans la base de données de suivi.

Scénario de traitement | dta_interchange_details (sortant) | dta_outdoc_details | Document de réponse
Non ouvert | X | X | X
Source ouverte | X | X | X
Destination ouverte | X | X | X
Bouclage | X | X |
Transfert | X | X | X

Remarques

  • Les documents de réponse sont générés uniquement lorsque vous utilisez les transports suivants : HTTP, HTTPS ou AIC. En outre, l'adresse du destinataire doit envoyer des données retournées.

  • Pour le scénario de transfert, l'enregistrement consigné dans la table dta_outdoc_details est un enregistrement vide. Le champ nlsValid a une valeur de 2 pour indiquer que cet enregistrement est associé à un document direct, et le champ nSyntax prend la valeur « UNKNOWN ». Puisque BizTalk Server ne traite pas le document, BizTalk Server ne peut pas remplir la plupart des champs de cette table avec des données appropriées.

Le tableau suivant présente les enregistrements entrants consignés dans la base de données de suivi.

Scénario de traitement | dta_interchange_details (entrant) | dta_indoc_details | Document de réponse
Non ouvert | X | X | X
Source ouverte | X | X | X
Destination ouverte | X | X | X
Bouclage | X | X |
Transfert | X | X | X

Remarques

  • Les documents de réponse sont générés uniquement lorsque vous utilisez les transports suivants : HTTP, HTTPS ou AIC. En outre, l'adresse du destinataire doit envoyer des données retournées.

  • Pour le scénario de transfert, l'enregistrement consigné dans la table dta_indoc_details est un enregistrement vide. Le champ nlsValid a une valeur de 2 pour indiquer que cet enregistrement est associé à un document direct, et le champ nSyntax prend la valeur « UNKNOWN ». Puisque BizTalk Server ne traite pas le document, BizTalk Server ne peut pas remplir la plupart des champs de cette table avec des données appropriées.

Voir aussi

Consignation des accusés de réception


Consignations des accusés de réception

L'illustration suivante montre le flux d'accusé de réception dans BizTalk Server.

Traitement des accusés de réception à l'aide de canaux
Générer et envoyer un accusé de réception
Recevoir et faire correspondre l'acc. de réception
Recevoir et traiter les échanges
Système de destination
Système source
Port d'échanges vers le
système de destination
OA
Parseur
Port d'éch.
vers syst.
source
Déf. de doc.
sortant
Accusé de réception
Spécification
de document
Spécification
de document
Déf. de doc.
entrant
Mappage
Canal d'accusés de réception
Acc. de réception standard
Port d'échanges
vers l'application
Canal du
système source
Spécification
de document
Déf. de l'accusé
de réception du doc.
Canal pour OA
Générer et envoyer l'échange

Dans ce scénario :

  • Le système source et le système de destination utilisent Microsoft BizTalk Server 2000.

  • Le système source envoie un bon de commande au système de destination, et le système source attend un accusé de réception du système de destination pour le bon de commande.

  • Les deux systèmes sont configurés pour attendre et générer des accusés de réception.

Lorsque le bon de commande est traité par le système source et envoyé au système de destination, un enregistrement est consigné dans la table dta_outdoc_details. Le tableau suivant indique comment se présentent les champs se rapportant aux accusés de réception dans cet enregistrement.

Nom de champ | Exemple de valeur | Description
nOutDocKey | 1 | Est un numéro unique qui identifie l'enregistrement.
nAckStatus | 1 | Indique qu'un accusé de réception pour le document est en attente.
nReceiptFlag |  | N'est pas rempli pour le moment.
nReceiptKey |  | N'est pas rempli pour le moment.

Lorsque le système de destination reçoit et traite le bon de commande, un enregistrement est consigné dans la table dta_indoc_details et deux enregistrements sont consignés dans la table dta_outdoc_details. L'enregistrement dans la table dta_indoc_details suit les informations relatives au bon de commande. Le premier enregistrement dans la table dta_outdoc_details suit les informations relatives au bon de commande et le deuxième enregistrement suit les informations relatives à l'accusé de réception du bon de commande.

Le tableau suivant présente les champs relatifs au bon de commande dans l'enregistrement de la table dta_indoc_details.

Nom de champ | Exemple de valeur | Description
nInDocKey | 1 | Est un numéro unique qui identifie l'enregistrement.
nDocType | CommonPO | Identifie le type de document reçu.

Le premier enregistrement consigné dans la table dta_outdoc_details correspond au bon de commande traité par BizTalk Server. Le tableau suivant indique comment se présentent les champs se rapportant aux accusés de réception dans cet enregistrement.

Nom de champ | Exemple de valeur | Description
nOutDocKey | 10 | Est un numéro unique qui identifie l'enregistrement.
nInDocKey | 1 | Lie l'enregistrement à l'enregistrement parent dans la table dta_indoc_details.

Le deuxième enregistrement consigné dans la table dta_outdoc_details correspond à l'accusé de réception qui est généré par le bon de commande. Le tableau suivant indique comment se présentent les champs se rapportant aux accusés de réception dans cet enregistrement.

Nom de champ | Exemple de valeur | Description
nOutDocKey | 2 | Est un numéro unique qui identifie l'enregistrement.
nInDocKey | 1 | Lie l'enregistrement à l'enregistrement parent dans la table dta_indoc_details.
nAckStatus | 0 | L'accusé de réception n'attend pas d'accusé de réception en retour.
nReceiptFlag | 4 | Indique que l'accusé de réception est associé à un enregistrement dans la table dta_indoc_details.
nReceiptKey | 1 | Est un numéro unique qui identifie l'enregistrement d'accusé de réception.

Lorsque le système source reçoit et traite l'accusé de réception généré par le système de destination et qu'un enregistrement est consigné dans la table dta_indoc_details, l'enregistrement d'origine consigné dans la table dta_outdoc_details est mis à jour. Le tableau suivant présente les champs relatifs aux accusés de réception dans l'enregistrement de la table dta_indoc_details.

Nom de champ | Exemple de valeur | Description
nInDocKey | 9 | Est un numéro unique qui identifie l'enregistrement.
nDocType | 997 | Identifie le type de document reçu.

Le tableau suivant présente les champs relatifs aux accusés de réception dans l'enregistrement mis à jour dans la table dta_outdoc_details.

Nom de champ | Exemple de valeur | Description
nOutDocKey | 1 | Est un numéro unique qui identifie l'enregistrement.
nAckStatus | 3 | Indique qu'un accusé de réception a été reçu.
nReceiptFlag | 4 | Indique que l'accusé de réception est associé à un enregistrement dans la table dta_indoc_details.
nReceiptKey | 9 | Est un numéro unique qui identifie l'enregistrement d'accusé de réception.

Voir aussi

Consignation des échanges et des documents


Consignation des informations de routage

Les informations de routage consignées dans la base de données de suivi varient selon que le document est entrant ou sortant et selon le mode de traitement des données par BizTalk Server. Pour les échanges entrants, lorsque BizTalk Server reçoit un document, il affiche l'instance du document pour les informations de routage. BizTalk Server vérifie ensuite la fonction de réception ou les paramètres de routage spécifiés dans IInterchange::Submit. Si les informations de routage sont fournies dans la fonction de réception ou dans IInterchange::Submit, ces paramètres sont utilisés pour router l'instance du document. Cependant, les informations de routage fournies dans l'instance du document sont consignées dans la table dta_routing_details de la base de données de suivi.

Pour les échanges sortants, les informations de routage source et de destination proviennent toujours du canal, et ces informations sont consignées dans la table dta_routing_details.

Cela affecte les informations affichées dans l'interface utilisateur de Suivi de documents BizTalk pour les informations d'alias. Les échanges soumis à BizTalk Server et transmis depuis celui-ci sont toujours interprétés comme une instance de flux de données unique.


Suivi des événements de planification XLANG dans la base de données de suivi

Les événements d'action associés aux messages traités par une planification XLANG qui sont échangés entre les services d'échanges BizTalk et les services d'Orchestration BizTalk peuvent être suivis dans les tables appropriées de la base de données de suivi. Les événements d'action peuvent être affichés en utilisant Suivi de documents BizTalk. Cependant, le suivi et l'affichage des événements d'action associés à des messages traités par une planification XLANG ne sont pas automatiquement activés lors de l'installation de BizTalk Server 2000. Pour activer cette fonction, vous devez procéder comme suit :

  1. Enregistrez l'exemple de fichier .DLL WorkFlowAudit.dll.

    Vous trouverez cet exemple de fichier dans le dossier \Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\WorkFlowAudit\bin.

  2. Exécutez l'application WorkFlowAuditClient.exe pour activer WorkFlowAudit.dll.

    Vous trouverez cet exemple d'application dans le dossier \Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\WorkFlowAuditClient.

    Pour plus d'informations, vous pouvez afficher la documentation (Readme.txt) se trouvant dans le dossier \Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\WorkFlowAudit\Docs.

  3. Cliquez sur le bouton Démarrer de l'application WorkFlowAuditClient pour initialiser la consignation des événements d'action associés à une planification XLANG dans la base de données de suivi.

Important

  • Des enregistrements sont consignés dans les tables dta_wf_EventData et dta_wf_WorkFlowEvent uniquement si l'application WorkFlowAuditClient est démarrée. Pour démarrer l'application WorkFlowAuditClient, vous devez effectuer les trois étapes indiquées dans cette rubrique. Si d'application WorkFlowAuditClient est arrêtée, aucun enregistrement n'est consigné dans les tables dta_wf_EventData et dta_wf_WorkFlowEvent.

Une fois ces étapes effectuées, des enregistrements sont consignés dans les tables dta_wf_EventData et dta_wf_WorkFlowEvent pour les messages qui seront échangés entre les services d'Orchestration BizTalk et les services d'échanges BizTalk. La valeur consignée dans le champ nvcName de la table dta_wf_EventData sert de lien entre les tables dta_wf_EventData et dta_wf_WorkFlowEvent et la table dta_interchange_details, une table principale dans la base de données de suivi. Pour plus d'informations sur les tables principales, consultez Structure des tables de métadonnées principales.

Messages envoyés des services d'Orchestration BizTalk aux services d'échanges BizTalk

Tous les messages qui sont envoyés des service d'Orchestration BizTalk aux services d'échanges BizTalk en utilisant la mise en oeuvre de port d'échanges BizTalk dans le Concepteur d'Orchestration BizTalk sont identifiés par un identificateur global unique (GUID) qualifié d'identificateur de corrélation (correlationID). Lorsqu'un message est soumis des services d'Orchestration BizTalk aux services d'échanges BizTalk, l'identificateur de corrélation est consignée dans le champ uidSubmissionGUID de la table dta_interchange_details. En outre, des enregistrements sont consignés dans les tables dta_wf_EventData et dta_wf_WorkFlowEvent. Cela vous permet d'utiliser Suivi de documents BizTalk pour visualiser les événements d'action associés aux messages traités par une planification XLANG.

Documents envoyés des services d'échanges BizTalk aux services d'Orchestration BizTalk

Tous les documents qui sont soumis aux services d'échanges BizTalk sont identifiés par un identificateur global unique qualifié de descripteur de dépôt (SubmissionHandle). Pour plus d'informations sur le descripteur de dépôt, consultez Méthode Submit. Lorsque le document est envoyé des services d'échanges BizTalk aux services d'Orchestration BizTalk, le descripteur de dépôt est enregistré dans le champ uidSubmissionGUID de la table dta_interchange_details. En outre, lorsqu'un document est envoyé des services d'échanges BizTalk aux services d'Orchestration BizTalk, les deux événements suivants se produisent :

  • Le descripteur de dépôt est inséré dans la propriété correlationID du document qui est envoyé aux services d'Orchestration BizTalk.

  • Les enregistrements sont consignés dans les tables dta_wf_EventData et dta_wf_WorkFlowEvent. Puisque le document est envoyé des services d'échanges BizTalk, la descripteur de dépôt est consigné comme l'identificateur de corrélation (correlationID) dans le champ nvcName de la table dta_wf_EventData.

Affichage d'événements d'action

Pour utiliser Suivi de documents BizTalk pour afficher des événements d'action associés aux messages traités par une planification XLANG, vous devez créer une requête dans Suivi de documents BizTalk puis cliquer sur l'icône de planification XLANG. Pour plus d'informations sur la création de requêtes et l'affichage d'événements de planification XLANG, consultez Utilisation des requêtes pour rechercher et trier les données d'échange et de document.

La table dta_wf_EventData

La table suivante contient un enregistrement pour chaque propriété consignée en relation à un événement COM+ surveillé qui est généré par une planification XLANG. Les ensembles de lignes multiples dans cette table partagent un parent commun dans la table dta_wf_WorkFlowEvent.

Nom de champ | Description
nEventDataId | Champ de clé de nombre entier incrémenté automatiquement.
nWorkFlowEventId | Clé étrangère vers l'enregistrement d'événement parent dans dta_wf_EventData.
nvcName | Identificateur de corrélation (correlationID).
nvcValue | N'importe quelle valeur. Elle est généralement basée sur un identificateur global unique (GUID).

La table dta_wf_WorkFlowEvent

La table suivante est la table parent de dta_wf_EventData et contient un enregistrement pour chaque événement COM+ surveillé qui est généré par une planification XLANG.

Nom de champ | Description
nWorkFlowEventId | Champ de clé de nombre entier incrémenté automatiquement.
nvcEventId | Type d'événement.
nvcEventName | Nom de l'événement.
nProcessId | Identificateur de traitement pour l'événement d'origine.
nvcApplicationId | Identificateur de planification XLANG.
nvcInstanceId | Identificateur pour l'instance particulière de la planification.
nEventTime | Heure universelle coordonnée (UTC) de l'événement sous forme de secondes écoulées depuis minuit, 1er janvier 1970.
nEventSubTime | Microsecondes ajoutées à l'argument ITime pour l'heure à une résolution aux microsecondes.
nEventTick | Valeur du compteur de performances haute résolution à l'origine de l'événement.
nvcServerName | Serveur sur lequel l'événement a été détecté.
dtDateEntered | Date de l'événement.

Voir aussi

Intégration des services BizTalk

Structure des tables de métadonnées principales

Méthode Submit

Présentation de l'état de la planification XLANG pour un échange


Recherche d'échanges et de documents associés

Vous pouvez utiliser Suivi de documents BizTalk pour afficher tous les échanges et documents en utilisant les paramètres de requête que vous spécifiez. Pour optimiser les résultats de recherche et pour réduire la charge sur le serveur, il est important de comprendre les requêtes et leur mode d'utilisation. Par exemple, si vous créez une requête avec un nombre réduit de paramètres définis, la requête pourrait renvoyer des milliers d'enregistrements d'échange. Cela vous crée beaucoup de travail et sollicite fortement les capacités de traitement du serveur. Cette situation empire lorsque plusieurs personnes interrogent simultanément la base de données.

Il existe deux niveaux de requêtes dans BizTalk Server : requêtes et requêtes avancées. Les requêtes incluent les critères les plus courants qui sont utilisés pour limiter les résultats de la requête. Les requêtes avancées vous permettent de mieux définir les résultats de requête en utilisant des expressions permettant de rechercher des données spécifiques.

Cette section traite des rubriques suivantes :

  • Présentation des requêtes

  • Présentation des requêtes avancées


Présentation des requêtes

Les trois paramètres de requête standard inclus dans Suivi de documents BizTalk sont les plages de dates et le fuseau horaire, les identificateurs source et de destination, et le type de document. Vous pouvez rechercher des enregistrements d'échange et de document en définissant un ou plusieurs de ces critères dans une requête. Par exemple, vous pouvez rechercher tous les types de document dans une plage de dates spécifiée. Vous pouvez également rechercher les échanges et les documents correspondant à un type de document particulier ainsi qu'à des organisations source et de destination sélectionnées.

Plage de dates et fuseau horaire

La date et l'heure indiquées dans Suivi de documents BizTalk est l'heure à laquelle le document a été traité par BizTalk Server. Si vous ne spécifiez pas une plage de dates pour la requête, la plage de dates par défaut correspond aux sept jours ouvrables précédents. Contrairement aux listes Sélection de la source, Sélection de la destination et Sélection du type de document, vous ne pouvez pas laisser la plage de dates vide pour rechercher les documents pour n'importe quelle date et heure. Vous devez toujours spécifier une plage de dates et d'heure dans Suivi de documents BizTalk.

Vous pouvez également spécifier si vous souhaitez afficher la date et l'heure dans le format d'heure locale ou dans le format d'heure universelle coordonnée (UTC). Le plus souvent, il convient d'afficher les échanges et les documents en utilisant l'heure locale. Cependant, si vous travaillez avec une personne se trouvant dans un autre fuseau horaire et si vous devez créer des critères communs pour la définition des périodes d'envoi et de réception, utilisez l'heure universelle coordonnée.

Organisation source et de destination

Vous pouvez rechercher des échanges et des documents basés sur l'organisation source, l'organisation de destination, ou les deux. En outre, lorsque vous créez une requête, vous pouvez filtrer des documents d'une ou de plusieurs organisations, ou de toutes les organisations. Vous pouvez également rechercher des échanges et des documents issus d'une application associée à une organisation. Par exemple, si l'organisation source A a une application de tableur qui envoie des informations à une application de base de données dans une organisation de destination B, vous pouvez déterminer à quel moment les informations ont été envoyées et reçues.

Type de document

Vous pouvez rechercher des échanges et des documents ayant un type de document spécifique, tel que des bons de commande ou des factures. Dans une requête, vous pouvez combiner des critères de type de document avec des qualificateurs source et de destination pour rechercher des échanges et des documents envoyés et reçus entre vous et vos partenaires commerciaux. Ce type de requête peut vous aider à analyser des relations professionnelles entre vous et vos partenaires commerciaux.

Contrôle du tri

Six contrôles du tri déterminent dans quel ordre les colonnes sont triées sur la page Résultats de la requête. L'ordre de tri par défaut d'une requête est le suivant :

  • Nom de l'organisation source. Le nom de l'organisation source pour le document.

  • Nom de l'application source. Le nom de l'application dans laquelle le document a été créé.

  • Nom de l'organisation de destination. Le nom de l'organisation de destination du document.

  • Nom de l'application de destination. Le nom de l'application à laquelle le document est envoyé.

  • Type de document. Le type du document.

  • Temps de traitement. L'heure à laquelle le document a été traité par BizTalk Server.

Voir aussi

Présentation des requêtes avancées


Présentation des requêtes avancées

Si vous trouvez qu'une requête renvoie trop d'enregistrements d'échanges et de documents, vous pouvez affiner votre recherche en mettant en oeuvre des expressions de requête. Dans la boîte de dialogue Requêtes avancées, vous pouvez créer une nouvelle expression de requête dans le Générateur de requêtes avancées ou explorer une liste d'expressions de requête que vous avez précédemment enregistrées. Les expressions sont des instructions SQL formées par la création de clauses conditionnelles que vous ajoutez à la requête. Vous disposez des options suivantes pour vous aider à créer une requête avancée :

  • Sélection de la source. Une liste des champs sur lesquels vous souhaitez effectuer une recherche. Dans le Gestionnaire d'échanges BizTalk, si vous avez configuré un canal ou une définition de document pour suivre un ou plusieurs champs personnalisés, ces champs apparaissent dans la liste Sélection de la source. Si vous n'avez pas configuré le Gestionnaire d'échanges BizTalk pour suivre des champs, seul "<Recherche personnalisée>" apparaît dans la liste Sélection de la source. Pour plus d'informations sur le suivi de champs spécifiques, consultez Définition des propriétés de journalisation de document et Sélection des champs de spécification dans un canal.

  • Opérateurs. Une liste d'opérateurs disponibles (tels que >, <, =, contient, ou ne contient pas).

  • Valeur. Vous pouvez saisir une valeur dans cette zone pour indiquer la valeur limite pour la requête avancée.

  • AND/OR. Une liste qui contient les opérateurs de groupement (AND et OR) utilisés pour combiner des conditions de recherche.

  • Requête. Une liste des requêtes que vous avez créées.

  • Regroupement logique. Une description des conditions de recherche combinées que vous avez créées en utilisant les opérateurs de groupement AND et OR. Lorsque vous ajoutez des clauses à une requête, des informations sur les opérateurs de groupement apparaissent dans la zone Regroupement logique.

  • Par exemple, la zone Regroupement logique pourrait afficher les éléments suivants :

  • 1 AND 2 AND (3 OR 4)

    Dans cet exemple, les conditions 1 et 2 s'appliquent, et la condition 3 ou la condition 4 est combinée aux conditions 1 et 2.

Remarque

  • Deux requêtes ne peuvent pas porter le même nom.

Voir aussi

Présentation des requêtes


Présentation des résultats de requête

Les résultats de requête sont organisés dans la page Résultats de la requête à deux niveaux, les enregistrements d'échanges et les enregistrements de documents. Les enregistrements d'échanges constituent le niveau d'organisation le plus élevé. Un enregistrement d'échange représente un échange soumis à BizTalk Server 2000 ou envoyé par celui-ci. Les enregistrements d'échange sont les enregistrements parents des enregistrements d'instance de document et vous aident donc à organiser les enregistrements d'instance de document d'une manière cohérente. Pour plus d'informations sur les champs inclus dans un enregistrement d'échange, consultez Présentation des résultats d'un enregistrement d'échange. Graphiquement, les enregistrements d'échange prennent la forme de lignes de champs de données avec une icône d'indicateur de développement à l'extrémité gauche de chaque ligne.

Si vous cliquez sur l'icône de l'indicateur de développement, le ou les enregistrements de l'instance de document apparaissent. Graphiquement, l'enregistrement ou les enregistrements d'instance de document apparaissent également sous forme de lignes de champs de données. Généralement, à chaque enregistrement d'échange correspond un enregistrement d'instance de document. Cependant, si plusieurs types de document sont envoyés dans un échange individuel, il y a un enregistrement de document pour chaque type de document envoyé dans l'échange. Pour plus d'informations sur les champs inclus dans un enregistrement d'instance de documents, consultez Présentation des résultats d'enregistrement d'instance de document.

Cette section traite des rubriques suivantes :

  • Principes de base du schéma de la base de données de suivi

  • Présentation des résultats d'un enregistrement d'échange

  • Présentation des résultats d'enregistrement d'instance de document

  • Présentation des résultats d'accusé de réception

  • Présentation des résultats pour échecs de transmission


Principes de base du schéma de la base de données de suivi

Pour comprendre le contenu de la page Résultats de la requête, il est important de comprendre les principes de base du schéma de la base de données de suivi. Il y a trois tables principales dans la base de données de suivi qui stockent les métadonnées (par exemple les identificateurs d'organisation source et de destination, la date, l'heure et le type de document) pour chaque échange et document traité par BizTalk Server. Les tables de bases de données sont les suivantes :

  • dta_interchange_details

  • dta_indoc_details

  • dta_outdoc_details

dta_interchange_details

La table dta_interchange_details stocke toutes les données appropriées des échanges et constitue la table parent des tables dta_indoc_details et dta_outdoc_details. Un enregistrement est stocké dans la table pour chaque échange traité par BizTalk Server. Les champs dans les enregistrements d'échange sur la page Résultats de la requête sont remplis de données issues de cette table. Un champ dans cette table précise si l'échange est entrant ou sortant. Par exemple, si vous recevez un échange, il est représenté sur la page Résultats de la requête sous forme d'enregistrement d'échange entrant. Si vous envoyez un échange, il est représenté sur la page Résultats de la requête sous forme d'enregistrement d'échange sortant. Pour plus d'informations sur la table dta_interchange_details, consultez Tables de métadonnées principales ou Structure des tables de métadonnées principales.

dta_indoc_details

La table dta_indoc_details stocke toutes les données pour chaque document soumis à BizTalk Server. Cette table est liée à la table dta_interchange_details par le biais d'une clé primaire. Les champs dans les enregistrements d'instance de document associés à des enregistrements d'échange entrants sur la page Résultats de la requête sont remplis avec des données issues de cette table. Par exemple, si vous envoyez un document et souhaitez visualiser les informations de suivi pour ce document sur la page Résultats de la requête, vous devez d'abord localiser l'enregistrement d'échange sortant approprié. Ensuite, développez l'enregistrement pour faire apparaître l'instance de document. L'enregistrement d'instance de document est associé à la table dta_indoc_details et affiche les données dans les champs que vous avez configurés à suivre. Pour plus d'informations sur la table dta_indoc_details, consultez Tables de métadonnées principales ou Structure des tables de métadonnées principales.

dta_outdoc_details

La table dta_outdoc_details stocke toutes les données de chaque document généré par BizTalk Server. La table dta_outdoc_details pourrait comporter plusieurs enregistrements pour chaque enregistrement contenu dans la table dta_indoc_details parce que plusieurs documents peuvent être générés à partir d'une soumission unique. Par exemple, un document soumis à BizTalk Server pourrait être envoyé à une liste de distribution de 10 ports. Dans ce cas, un enregistrement unique est consigné dans la table dta_indoc_details et 10 enregistrements sont consignés dans la table dta_outdoc_details. Par conséquent, un enregistrement d'échange sortant avec un enregistrement d'instance de document associé apparaît sur la page Résultats de la requête. Les champs dans l'enregistrement d'instance de document sont remplis des données issues de la table dta_outdoc_details. Pour plus d'informations sur la table dta_outdoc_details, consultez Tables de métadonnées principales ou Structure des tables de métadonnées principales.

Voir aussi

Consignation des échanges et des documents

Tables de métadonnées principales

Structure des tables de métadonnées principales

Présentation des résultats d'enregistrement d'instance de document

Présentation des résultats d'un enregistrement d'échange

Présentation des résultats d'accusé de réception

Présentation des résultats pour échecs de transmission

Présentation du schéma de la base de données de suivi


Présentation des résultats d'un enregistrement d'échange

En fonction des paramètres de requête que vous spécifiez, un ou plusieurs enregistrements d'échange sont renvoyés, si des correspondances pour vos critères de requête sont trouvées. Un enregistrement d'échange représente un échange soumis à Microsoft BizTalk Server 2000 ou envoyé par celui-ci.

Un échange contient les informations présentées dans le tableau suivant.

En-tête de colonne d'échange | Description
Données | Fournit un lien pour afficher les données d'échange dans leur format natif.
Planification Fournit un lien aux informations d'état de la planification XLANG pour l'échange individuel, s'il est disponible. Si aucune information d'état de planification XLANG n'est associée à l'échange, le message suivant apparaît :

Aucune information de planification XLANG n'est disponible pour cet échange.
Direction | Spécifie si l'échange est soumis à BizTalk Server (entrant) ou envoyé depuis BizTalk Server (sortant).
Erreur Spécifie si des erreurs sont associées au document. Les messages d'erreur qui peuvent apparaître sont les suivants :
  • aucune erreur ;

  • échec de l'appel d'un composant personnalisé ;

  • échec de l'analyse de l'échange ;

  • le canal spécifié n'existe pas ;

  • échec de la sérialisation de l'échange ;

  • échec du codage de l'échange ;

  • échec de la signature de l'échange ;

  • échec du cryptage de l'échange ;

  • échec de la tentative de transmission (une nouvelle tentative est en attente) ;

  • échec de la dernière tentative de transmission ;

  • échec de l'analyse du document ;

  • échec de la validation du document ;

  • impossible de trouver un canal valide ;

  • échec du mapping du document ;

  • impossible de trouver un port valide ;

  • échec de la sérialisation du document ;
Organisation source | Spécifie le nom de l'organisation source.
Application source | Spécifie l'application d'où provient le document.
Organisation de destination | Spécifie le nom de l'organisation de destination.
Application de destination | Spécifie l'application de destination du document.
Type de document | Spécifie le type du document. S'il y a plusieurs types de document dans un échange, "<Multiple>" apparaît dans ce champ.
Nombre de documents | Spécifie le nombre de documents dans l'échange.
Identificateur de contrôle. | Spécifie un numéro de contrôle unique pour les échanges de données électroniques (EDI) ou un identificateur pour les messages fiable BizTalk.
État de la réception | Spécifie l'état de l'accusé de réception. Les valeurs correspondant à l'accusé de réception sont les suivantes : aucun, en attente, en retard, accepté, accepté avec les erreurs ou rejeté.
Temps de traitement | Indique l'heure à laquelle l'échange a été traité. L'heure est définie au moment de la création des enregistrements de suivi de documents. Une fois que le champ est défini, il n'est pas mis à jour.
Heure d'envoi | Spécifie l'heure à laquelle l'échange a été envoyé si la transmission a abouti. Si la transmission n'a pas abouti, cette valeur est nulle. Pour les transmissions entrantes, ce champ a toujours une valeur nulle.
Qualificateur de l'ID source | Spécifie le type de qualificateur d'organisation source. Il s'agit du qualificateur que BizTalk Server utilise de façon interne.
Identificateur source | Spécifie la valeur de l'identificateur d'organisation source. Il s'agit de l'identificateur source désigné dans les données et utilisé pour router le document. Cette valeur est différente du Qualificateur de l'ID source. Pour plus d'informations sur le routage, consultez Consignation des informations de routage.
Qualificateur de l'ID de destination | Spécifie le type de qualificateur d'organisation de destination.
Identificateur de destination | Spécifie la valeur de l'identificateur d'organisation de destination. Pour plus d'informations sur le routage, consultez Consignation des informations de routage.

Voir aussi

Principes de base du schéma de la base de données de suivi

Présentation des résultats d'enregistrement d'instance de document

Recherche d'échanges et de documents associés


Présentation des résultats d'enregistrement d'instance de document

Les enregistrements d'instance de document dans un échange prennent la forme d'une ligne de champs décrivant les informations de document.

Les résultats d'enregistrement d'instance de document contiennent les informations présentées dans le tableau suivant.

En-tête de colonne de document | Description
Données | Fournit un lien pour afficher les données qui sont contenues dans l'instance de documents dans son format natif et XML.
ID de suivi | Indique une clé de suivi basée sur un identificateur global unique (GUID).
Type de document | Spécifie le type de document. S'il y a plusieurs documents dans un échange, ce champ spécifie le type de document. Plusieurs types de document ne sont jamais indiqués dans ce champ. Les types de document supplémentaires apparaissent sous la forme d'enregistrements d'instance de document séparés.
Compatibilité | Indique si le document est valide. Les valeurs possibles pour compatibilité sont valide ou non valide.
Erreur Spécifie si des erreurs sont associées au document. Les messages d'erreur qui peuvent apparaître sont les suivants :
  • aucune erreur ;

  • échec de l'appel d'un composant personnalisé ;

  • le canal spécifié n'existe pas ;

  • échec de la tentative de transmission (une nouvelle tentative est en attente) ;

  • échec de la dernière tentative de transmission ;

  • échec de l'analyse du document ;

  • échec de la validation du document ;

  • impossible de trouver un canal valide ;

  • échec du mapping du document ;

  • impossible de trouver un port valide ;

  • échec de la sérialisation du document.
Accusé de réception | Fournit un lien aux informations d'accusé de réception.

Les champs suivants s'appliquent uniquement aux documents sortants.

État de la réception | Spécifie l'état de l'accusé de réception. Les valeurs correspondant à l'accusé de réception sont les suivantes : aucun, en attente, en retard, accepté, accepté avec les erreurs ou rejeté.
Réel 1, Réel 2 | Spécifie les données qui ont été capturées du contenu du document sous forme de nombre réel. Deux champs peuvent contenir des nombres réels.
Entier 1, Entier 2 | Spécifie les données qui ont été capturées du contenu du document sous forme de valeur entière. Deux champs peuvent contenir des entiers.
Date 1, Date 2 | Spécifie les données qui ont été capturées du contenu du document sous forme de valeur de date. Deux champs peuvent contenir des dates.
Chaîne 1, Chaîne 2 | Spécifie les données qui ont été capturées du contenu du document sous forme de valeur de chaîne. Deux champs peuvent contenir des chaînes.
Recherche personnalisée | Indique des données supplémentaires qui ont été capturées sous forme de valeur de chaîne. La limite de ce champ est de 2 Go.

Remarques

  • Pour configurer les informations à suivre dans les documents sortants, consultez Sélection des champs de spécification dans une définition de document ou Sélection des champs de spécification dans un canal.

  • Si vous configurez des champs (tels que entiers, réels, chaînes, dates, ou champs personnalisés) dans la définition du document comme facultatifs, si vous configurez ces champs afin qu'ils soient suivis, et si ces champs ne sont pas inclus dans l'instance du document soumis, ces champs n'apparaissent pas dans les résultats de la requête. Suivi de documents BizTalk ne génère pas de message d'erreur ou d'avertissement pour vous indiquer que des données sont absentes dans des champs facultatifs.

  • Dans une instance de document, un 1 est suivi comme un -1 si les conditions suivantes sont satisfaites :
    • Le type de données est réglé à Booléen lorsque vous définissez des propriétés de déclaration pour un champ particulier dans l'Éditeur BizTalk.

    • Le champ est sélectionné pour être suivi comme nombre entier dans le modèle d'objet de configuration d'échanges BizTalk ou dans le Gestionnaire d'échanges BizTalk.

Voir aussi

Sélection des champs de spécification dans un canal

Sélection des champs de spécification dans une définition de document

Principes de base du schéma de la base de données de suivi

Recherche d'échanges et de documents associés

Présentation des résultats d'un enregistrement d'échange


Présentation des résultats d'accusé de réception

L'illustration suivante montre le flux d'accusé de réception dans Suivi de documents BizTalk. Dans l'illustration, Document 1 est d'abord traité par BizTalk Server A et est indiqué pour attendre un accusé de réception (Document 1, avec indicateur Attendre un accusé de réception activé). Ensuite, BizTalk Server B récupère le document par le biais d'une fonction de réception (Document 1, avec indicateur Générer un accusé de réception activé), traite le document, puis génère un accusé de réception [Accusé de réception pour Document 1 (sortant)]. BizTalk Server A reçoit ensuite l'accusé de réception [accusé de réception pour le Document 1 (entrant)].

Flux d'accusé de réception

Flux d'accusé de réception
BizTalk
Server A
Acc. de récept.
du document 1
(Entrant)
Acc. de récept.
du document 1
(Sortant)
Indic. Générer
un acc. de récept.
Indic. Attendre un
accusé de récept.
Document 1
Document 1
Document 1
BizTalk
Server B
Fonctions de réception

Lorsque vous affichez l'accusé de réception pour Document 1, Indicateur Attendre accusé de réception activé, vous localisez d'abord l'enregistrement d'échange approprié dans la page Résultats de la requête qui correspond à Document 1, Indicateur Attendre accusé de réception activé. Cliquez sur l'icône Accusé de réception dans le champ d'accusé de réception. Cela ouvre une nouvelle page Résultats de la requête qui contient l'enregistrement d'échange que BizTalk Server A a généré lorsqu'il a traité Document 1, Indicateur Attendre un accusé de réception activé. Cliquez sur l'icône de données dans la colonne Données. Les données qui s'affichent correspondent au contenu réel de l'accusé de réception. Dans l'illustration ci-dessus, la dernière étape correspond à Accusé de réception pour Document 1 (entrant).

Lorsque vous affichez l'accusé de réception pour Document 1, Indicateur Générer un accusé de réception activé, vous localisez d'abord l'enregistrement d'échange approprié dans la page Résultats de la requête qui correspond à Document 1, Indicateur Générer un accusé de réception activé. Cliquez sur l'icône Accusé de réception dans le champ d'accusé de réception. Cela ouvre une nouvelle page Résultats de la requête qui contient l'enregistrement d'échange que BizTalk Server B a généré lorsqu'il a traité Document 1, Indicateur Générer un accusé de réception activé. Développez l'enregistrement d'échange pour visualiser les détails d'instance de document, puis cliquez sur l'icône de données dans le champ Données. Les données qui s'affichent correspondent au contenu réel de l'accusé de réception. Dans l'illustration précédente, cette dernière étape correspond à Accusé de réception pour Document 1 (sortant).

Remarques

  • L'envoi et la réception d'accusés de réception fonctionnent uniquement avec des analyseurs qui peuvent traiter des accusés de réception. Pour plus d'informations sur les accusés de réception, consultez Description des réceptions.

  • Les accusés de réception d'échanges fiables ne s'affichent pas dans l'interface utilisateur de Suivi de documents BizTalk.

Voir aussi

Consignation des accusés de réception

Principes de base du schéma de la base de données de suivi


Présentation des résultats pour échecs de transmission

Lorsqu'une transmission échoue, l'incident est consigné dans la base de données de suivi. Cependant, certaines erreurs qui sont consignées dans la base de données de suivi n'apparaissent pas dans l'interface utilisateur de Suivi de documents BizTalk. Des erreurs apparaissent dans l'interface utilisateur uniquement si un enregistrement a été consigné dans la table dta_outdoc_details. Pour plus d'informations sur les tables principales, consultez Principes de base du schéma de la base de données de suivi ou Tables de métadonnées principales.

Le tableau suivant indique les messages d'erreur pouvant être obtenus et précise si des enregistrements sont consignés dans les diverses tables principales de la base de données de suivi.

Message d'erreur | Enregistrements consignés | Commentaires
Aucune erreur | dta_indoc_details dta_interchange_details (entrant) dta_interchange_details (sortant) dta_outdoc_details | Les champs appropriés sont consignés dans les trois tables principales.
Impossible d'appeler un composant personnalisé. |  | Cette erreur apparaît uniquement si un préprocesseur personnalisé est associé à une fonction de réception. Aucun enregistrement n'est consigné dans la base de données de suivi.
Impossible d'analyser l'échange. | dta_interchange_details (entrant) | L'échange et les données sont consignés en cas d'erreur d'analyse.
Le canal spécifié n'existe pas. | dta_indoc_details dta_interchange_details (entrant) |
Impossible de sérialiser l'échange. | dta_indoc_details dta_interchange_details (entrant) dta_interchange_details (sortant) dta_outdoc_details | Un enregistrement vide est consigné dans la table dta_interchange_details (sortante). Si l'échange est resoumis et s'il aboutit, l'enregistrement est mis à jour.
Impossible de coder l'échange. | dta_indoc_details dta_interchange_details (entrant) dta_interchange_details (sortant) dta_outdoc_details |
Impossible de signer l'échange. | dta_indoc_details dta_interchange_details (entrant) dta_interchange_details (sortant) dta_outdoc_details |
Impossible de crypter l'échange. | dta_indoc_details dta_interchange_details (entrant) dta_interchange_details (sortant) dta_outdoc_details |
Échec de la tentative de transmission (une nouvelle tentative est en attente). | dta_indoc_details dta_interchange_details (entrant) dta_interchange_details (sortant) dta_outdoc_details |
Échec de la dernière tentative de transmission. | dta_indoc_details dta_interchange_details (entrant) dta_interchange_details (sortant) dta_outdoc_details |
Impossible d'analyser le document. | dta_indoc_details dta_interchange_details (entrant) |
Impossible de valider le document. | dta_indoc_details dta_interchange_details (entrant) |
Impossible de trouver un canal valide. | dta_indoc_details dta_interchange_details (entrant) |
Impossible de mapper le document. | dta_indoc_details dta_interchange_details (entrant) dta_interchange_details (sortant) dta_outdoc_details | L'enregistrement dans la table dta_outdoc_details enregistre l'erreur de consignation, et un enregistrement vide est consigné dans la table dta_interchange_details (sortante).
Impossible de trouver un port d'échanges valide. | dta_indoc_details dta_interchange_details (entrant) dta_interchange_details (sortant) dta_outdoc_details | L'enregistrement dans la table dta_outdoc_details enregistre une erreur NoPort, et un enregistrement vide est consigné dans la table dta_interchange_details (sortante).
Impossible de sérialiser le document. | dta_indoc_details dta_interchange_details (entrant) dta_interchange_details (sortant) dta_outdoc_details | Les enregistrements des tables dta_indoc_details et dta_outdoc_details contiennent l'erreur de sérialisation.

Voir aussi

Configuration des propriétés de suivi d'un groupe de serveurs

Files d'attente interrompue

Principes de base du schéma de la base de données de suivi

Présentation du schéma de la base de données de suivi


Présentation de l'état de la planification XLANG intégrée pour un échange

Vous pouvez suivre l'état de planifications XLANG associées dans Suivi de documents BizTalk. Les actions dans des planifications sur un serveur peuvent être surveillées et stockées dans les tables appropriées de la base de données de suivi avec un identificateur qui établit une corrélation entre elles et des instances de message spécifiques. Le schéma de stockage dans la base de données de suivi et la corrélation font partie de Microsoft BizTalk Server 2000, mais la fonctionnalité d'abonnement d'événements n'est pas mis en oeuvre lorsque vous installez BizTalk Server 2000. Cependant, un exemple d'intégration de suivi est proposé. Après l'installation de BizTalk Server 2000, vous trouverez le code source de cet exemple dans le dossier \Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\WorkFlowAudit. En outre, le sous-dossier bin contient la bibliothèque de liaison dynamique (WorkFlowAudit.dll), et le sous-dossier Docs contient la documentation (Readme.txt) de cet exemple. Vous trouverez un exemple d'application client dans le dossier \Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\WorkFlowAuditClient.


Dépannage de Suivi de documents BizTalk

Cette section fournit des informations générales sur le dépannage de Suivi de documents BizTalk.

  • Problème d'affichage de l'interface utilisateur de Suivi de documents BizTalk

  • Des échanges et des documents ne sont pas stockés

  • Rien ne s'affiche dans les résultats de la requête

  • Des champs de suivi ne sont pas affichés dans les résultats de la requête

  • Trop d'arguments de recherche


Problème d'affichage de l'interface utilisateur de Suivi de documents BizTalk

Cause : Microsoft Office Web Components n'est pas installé.

Solution : Installez Microsoft Office Web Components.

  1. Dans le menu Démarrer, pointez sur Paramètres, puis cliquez sur Panneau de configuration.

  2. Double-cliquez sur Ajout/Suppression de programmes.

    La boîte de dialogue Ajout/Suppression de programmes apparaît.

  3. Cliquez sur Microsoft Office 2000 SR-1 Premium.

  4. Cliquez sur Modifier.

  5. Cliquez sur Ajouter/supprimer des composants.

  6. Cliquez sur l'indicateur de développement (+) en regard de Outils Office.

  7. Cliquez sur Office Web Components puis cliquez sur l'option adaptée à votre installation.

  8. Cliquez sur Mettre à jour.


Des échanges et des documents ne sont pas stockés

Cause : Le suivi est désactivé dans Administration de BizTalk Server.

Solution : Activez le suivi dans Administration de BizTalk Server.

  1. Dans le menu Démarrer, pointez sur Programmes, Microsoft BizTalk Server 2000, puis cliquez sur Administration de BizTalk Server.

  2. Développez Microsoft BizTalk Server 2000 et cliquez sur le groupe de serveurs pour lequel des documents ne sont pas stockés.

  3. Dans le menu Action, cliquez sur Propriétés.

    La boîte de dialogue Propriétés du groupe de serveurs BizTalk Server s'affiche.

  4. Cliquez sur l'onglet Suivi.

  5. Cochez la case Activer le Suivi de documents.

  6. Sélectionnez une ou plusieurs des options suivantes :
    • Consigner l'échange entrant dans un journal

    • Consigner l'échange sortant dans un journal

    • Consigner le message MIME d'origine dans un journal
  7. Cliquez sur OK.

Voir aussi

Configuration des propriétés de suivi d'un groupe de serveurs


Rien ne s'affiche dans les résultats de la requête

Première cause : La plage de dates et d'heure est incorrecte.

Solution : Vérifiez que la plage de dates et d'heure est correcte. Par exemple, si vous avez envoyé un document dans les 5 dernières minutes et si la plage d'heure est configurée pour rechercher des documents remontant à 10 minutes ou plus, votre document n'apparaîtra pas dans les résultats de la requête.

Deuxième cause : Les données peuvent avoir été supprimées de la base de données.

Solution : Contactez votre administrateur de base de données pour obtenir plus d'informations.

Voir aussi

Recherche par date des informations relatives aux documents et aux échanges


Des champs de suivi ne sont pas affichés dans les résultats de la requête

Cause : BizTalk Server n'a pas pu convertir les données ou il y a eu erreur de débordement arithmétique.

Solution : Recherchez le message d'erreur suivant dans le journal des événements :

<<chemin et nom de fichier>> : Impossible de consigner le champ de suivi pour la transmission <<identificateur global unique>> :

Champ de suivi : <<Nom du champ>>

Nom du champ de spécification : <<nom du champ de spécifications>>/DTADataTypeTest/String/@_String

Valeur réelle : <<valeur réelle du champ>>

Vérifiez les paramètres du champ de suivi définis dans la configuration du document ou du canal.

Voir aussi

Sélection des champs de spécification dans un canal

Définition des propriétés de journalisation de document


Trop d'arguments de recherche

Cause : Vous avez spécifié trop d'options dans les listes Sélection de la source ou Sélection de la destination.

Solution : Faites en sorte que votre requête soit la plus spécifique possible. Réduisez le nombre d'options sélectionnées dans les listes Sélection de la source ou Sélection de la destination, et cliquez sur Requête.

Voir aussi

Utilisation des requêtes pour rechercher et trier les données d'échange et de document


Développement d'applications BizTalk Server 2000

Microsoft BizTalk Server 2000 propose des outils et des services permettant de créer des applications exécutables pour contrôler les processus professionnels et l'échange des données entre les partenaires commerciaux et les applications de votre entreprise.

Cette section traite des rubriques suivantes :

  • Conception des orchestrations BizTalk

  • Configuration des services d'Échanges BizTalk

  • Création de spécifications et mapping de données

  • Intégration des services BizTalk


Conception des orchestrations BizTalk

Le Concepteur d'orchestration BizTalk est un outil de conception basé sur Microsoft Visio 2000 qui permet de créer des schémas de processus professionnels pouvant être compilés et exécutés sous forme de planifications XLANG. XLANG est un langage XML. Une planification XLANG décrit le processus professionnel et la liaison de ce processus aux services d'application.

Vous pouvez recourir au Concepteur d'orchestration BizTalk pour créer des schémas décrivant des processus professionnels exécutables de longue durée et asynchrones. En règle générale, ces schémas décrivent le déroulement des interactions et des procédures pendant l'exécution d'un processus, tel qu'une requête d'ordre d'achat. Souvent, ces processus professionnels ne sont pas soumis à des délais. De même, les étapes d'un processus professionnel sont asynchrones. La description du processus professionnel est distincte de la logique et de la séquence d'implémentation utilisées pour exécuter ce processus.

Pour obtenir de l'aide sur des tâches spécifiques, voir Comment.

Pour obtenir des informations générales, voir Concepts.


Comment...

Cette section fournit des informations spécifiques aux tâches associées à l'utilisation du Concepteur d'Orchestration BizTalk afin de créer des schémas de planification XLANG et de les compiler dans des planifications XLANG exécutables. Cette section fournit également des informations sur l'exécution des planifications XLANG. Il est vivement recommandé de prendre connaissance de la section Concepts afin de comprendre parfaitement toutes les fonctionnalités et capacités du Concepteur d'Orchestration BizTalk.

Cette section traite des procédures suivantes :

  • Utilisation du Concepteur d'Orchestration BizTalk

  • Exécuter les planifications XLANG


Utilisation du Concepteur d'Orchestration BizTalk

Cette section décrit les procédures d'utilisation du Concepteur d'Orchestration BizTalk afin de créer des schémas de planification XLANG et de les compiler dans des planifications XLANG.

Cette section traite des procédures suivantes :

  • Ouverture et enregistrement des schémas de planification XLANG

  • Affichage de pages, formes et stencils

  • Ajout, suppression et connexion de formes

  • Définition des propriétés conditionnelles

  • Définition des propriétés de simultanéité

  • Définition des propriétés de transaction

  • Définition des propriétés de gestion d'erreurs

  • Implémentation de ports

  • Envoi ou réception de messages

  • Dessin du flux de données entre les messages


Ouverture et enregistrement des schémas de planification XLANG

Cette section traite des procédures suivantes :

  • Création d'un nouveau schéma XLANG

  • Ouverture d'un schéma XLANG existant

  • Enregistrement d'un schéma de planification XLANG


Création d'un nouveau schéma XLANG

  • Dans le menu Fichier du Concepteur d'Orchestration BizTalk, cliquez sur Nouveau.

Remarques

  • Cette procédure ouvre un nouveau schéma de planification XLANG dans la fenêtre de conception. La page de conception par défaut est la page des processus professionnels. Les stencils Diagramme de flux et Implémentation s'ouvrent également par défaut lorsque vous commencez un nouveau schéma.

  • L'extension de fichier d'un schéma de planification XLANG est .skv.

Voir aussi

Ouverture d'un schéma XLANG existant

Enregistrement d'un schéma de planification XLANG


Ouverture d'un schéma XLANG existant

  1. Dans le menu Fichier du Concepteur d'Orchestration BizTalk, cliquez sur Nouveau.

    La boîte de dialogue Ouvrir un schéma de planification XLANG apparaît.

  2. Sélectionnez le schéma de planification XLANG à ouvrir, puis cliquez sur Ouvrir.

Remarques

  • L'extension de fichier d'un schéma de planification XLANG est .skv.

  • L'extension de fichier d'une planification XLANG est .skx. Vous ne pouvez pas ouvrir un fichier .skx dans le Concepteur d'Orchestration BizTalk. Pour modifier ou mettre à jour un fichier .skx, ouvrez le fichier source .skv, modifiez-le et recompilez-le en tant que fichier .skx.

Voir aussi

Création d'un nouveau schéma XLANG

Enregistrement d'un schéma de planification XLANG


Enregistrement d'un schéma de planification XLANG

  • Dans le menu Fichier du Concepteur d'Orchestration BizTalk, cliquez sur Enregistrer.

Remarques

  • Lorsque vous enregistrez un schéma de planification XLANG, celui-ci est enregistré sous le nom par défaut DrawingX.skv, où X représente le nombre ajouté au nom du schéma. Vous pouvez cependant modifier le nom du fichier lorsque vous enregistrez le schéma.

  • Dans le menu Fichier, vous pouvez également cliquer sur Enregistrer sous. Cette option ouvre la boîte de dialogue Enregistrer un schéma de planification XLANG sous. Vous pouvez :
    • renommer le fichier ;

    • enregistrer le fichier dans un autre emplacement.
  • L'extension de fichier d'un schéma de planification XLANG est .skv.

  • L'extension de fichier d'une planification XLANG est .skx. Vous ne pouvez pas ouvrir un fichier .skx dans le Concepteur d'Orchestration BizTalk. Pour modifier ou mettre à jour un fichier .skx, ouvrez le fichier source .skv, modifiez-le et recompilez-le en tant que fichier .skx.

Voir aussi

Création d'un nouveau schéma XLANG

Ouverture d'un schéma XLANG existant


Affichage de pages, formes et stencils

Le Concepteur d'Orchestration BizTalk dispose de plusieurs options d'affichage que vous pouvez utiliser pour agrandir votre zone de schéma ou pour afficher une forme spécifique ou des relations entre les données.

Cette section traite des procédures suivantes :

  • Affichage des pages de conception

  • Affichage des formes

  • Affichage des stencils

  • Utilisation de plusieurs fenêtres

  • Utilisation des annotations

  • Aperçu, impression et redimensionnement de schémas de planification XLANG


Affichage des pages de conception

Cette section traite des procédures suivantes :

  • Affichage de la page des processus professionnels

  • Affichage de la page de données

  • Affichage des pages des processus professionnels et des données

  • Affichage de la compensation pour les pages de transaction

  • Affichage des pages En cas d'échec de transaction

  • Affichage d'une page

Voir aussi

Utilisation de plusieurs fenêtres

Affichage des formes

Affichage des stencils


Affichage de la page des processus professionnels

  • Dans le menu Affichage, cliquez sur Page des processus professionnels.

Remarque

  • Vous pouvez également cliquer sur l'onglet Processus professionnel dans la partie inférieure des pages de conception.

Voir aussi

Utilisation de plusieurs fenêtres

Affichage d'une page

Affichage de la compensation pour les pages de transaction

Affichage des pages En cas d'échec de transaction

Affichage des formes

Affichage des stencils

Affichage des pages des processus professionnels et des données

Affichage de la page de données


Affichage de la page de données

  • Dans le menu Affichage, cliquez sur Page de données.

Remarque

  • Vous pouvez également cliquer sur l'onglet Données dans la partie inférieure des pages de conception.

Voir aussi

Utilisation de plusieurs fenêtres

Affichage d'une page

Affichage de la compensation pour les pages de transaction

Affichage des pages En cas d'échec de transaction

Affichage des formes

Affichage des stencils

Affichage des pages des processus professionnels et des données

Affichage de la page des processus professionnels


Affichage des pages des processus professionnels et des données

  • Dans le menu Affichage, cliquez sur Page des processus professionnels et des données.

Remarque

  • Cette option d'affichage ouvre deux fenêtres d'une même planification XLANG : une fenêtre Processus professionnel et une fenêtre Données. Cette fonctionnalité est similaire à celle obtenue avec l'option Nouvelle fenêtre. Pour plus d'informations sur l'ouverture de plusieurs fenêtres, voir Utilisation de plusieurs fenêtres.

Voir aussi

Utilisation de plusieurs fenêtres

Affichage d'une page

Affichage de la compensation pour les pages de transaction

Affichage des pages En cas d'échec de transaction

Affichage des formes

Affichage des stencils

Affichage de la page des processus professionnels

Affichage de la page de données


Affichage de la compensation pour les pages de transaction

  • Dans la partie inférieure des pages de conception, cliquez sur l'onglet Compensation pour Transaction de la page que vous voulez afficher.

Remarques

  • Le paramètre Transaction, dans le nom de la page, est remplacé par le nom de la transaction à laquelle le processus de gestion d'erreur est associé.

  • Pour plus d'informations sur l'ajout d'une page Compensation pour Transaction à un schéma de planification XLANG, voir Activation de la gestion d'erreur de compensation.

Voir aussi

Utilisation de plusieurs fenêtres

Affichage d'une page

Affichage des pages En cas d'échec de transaction

Affichage des formes

Affichage des stencils

Affichage des pages des processus professionnels et des données

Affichage de la page des processus professionnels

Affichage de la page de données


Affichage des pages En cas d'échec de transaction

  • Dans la partie inférieure des pages de conception, cliquez sur l'onglet En cas d'échec de Transaction de la page que vous voulez afficher.

Remarque

  • Le paramètre Transaction, dans le nom de la page, est remplacé par le nom de la transaction à laquelle le processus de gestion d'erreur est associé.

  • Pour plus d'informations sur l'ajout d'une page En cas d'échec de Transaction à un schéma de planification XLANG, voir Activation de la gestion d'erreur en cas d'échec.

Voir aussi

Utilisation de plusieurs fenêtres

Affichage d'une page

Affichage de la compensation pour les pages de transaction

Affichage des formes

Affichage des stencils

Affichage des pages des processus professionnels et des données

Affichage de la page des processus professionnels

Affichage de la page de données


Affichage d'une page

  • Cliquez sur l'onglet correspondant à la page que vous voulez afficher.

Remarque

  • Les onglets de chacune des pages se trouvent dans la partie inférieure des pages de conception.

Voir aussi

Utilisation de plusieurs fenêtres

Affichage de la compensation pour les pages de transaction

Affichage des pages En cas d'échec de transaction

Affichage des formes

Affichage des stencils

Affichage des pages des processus professionnels et des données

Affichage de la page des processus professionnels

Affichage de la page de données


Affichage des formes

Cette section traite des procédures suivantes :

  • Affichage des formes Diagramme de flux

  • Affichage des formes Diagramme de flux, et Communication

  • Affichage des formes Diagramme de flux, Communication et Implémentation

Voir aussi

Affichage des stencils

Affichage des pages de conception


Affichage des formes Diagramme de flux

  • Dans le menu Affichage, cliquez sur Formes Diagramme de flux.

Remarques

  • Si vous utilisez cette option, seules les formes Diagramme de flux et leurs connexions s'affichent sur la page de conception. Cette option masque tous les ports, les messages de ports, les implémentations et les connexions entre les ports et les actions ou entre les ports et les implémentations.

  • Cette option d'affichage ne peut pas être utilisée dans la page Données.

Voir aussi

Affichage des formes Diagramme de flux, et Communication

Affichage des formes Diagramme de flux, Communication et Implémentation

Affichage des stencils

Affichage des pages de conception


Affichage des formes Diagramme de flux, et Communication

  • Dans le menu Affichage, cliquez sur Formes Diagramme de flux, et Communication.

Remarques

  • Si vous utilisez cette option, les formes Diagramme de flux et leurs connexions s'affichent sur la page de conception. Les ports, les messages de ports et les connexions entre les ports et les actions s'affichent également. Cette option masque toutes les implémentations et les connexions entre les ports et les implémentations.

  • Cette option d'affichage ne peut pas être utilisée dans la page Données.

Voir aussi

Affichage des formes Diagramme de flux, Communication et Implémentation

Affichage des formes Diagramme de flux

Affichage des stencils

Affichage des pages de conception


Affichage des formes Diagramme de flux, Communication et Implémentation

  • Dans le menu Affichage, cliquez sur Formes Diagramme de flux, Communication et Implémentation.

Remarques

  • Toutes les formes et leurs connexions s'affichent.

  • Cette option d'affichage ne peut pas être utilisée dans la page Données.

Voir aussi

Affichage des formes Diagramme de flux, et Communication

Affichage des formes Diagramme de flux

Affichage des stencils

Affichage des pages de conception


Affichage des stencils

Cette section traite des procédures suivantes :

  • Affichage du stencil Diagramme de flux

  • Affichage du stencil Implémentation

Voir aussi

Affichage des formes

Affichage des pages de conception


Affichage du stencil Diagramme de flux

  • Dans le menu Affichage, pointez sur Stencils et cliquez sur Diagramme de flux pour afficher ou masquer le stencil Diagramme de flux.

Voir aussi

Affichage des formes

Affichage des pages de conception

Affichage du stencil Implémentation


Affichage du stencil Implémentation

  • Dans le menu Affichage, pointez sur Stencils et cliquez sur Implémentation pour afficher ou masquer le stencil Implémentation.

Voir aussi

Affichage des formes

Affichage des pages de conception

Affichage du stencil Diagramme de flux


Utilisation de plusieurs fenêtres

Cette section traite des procédures suivantes :

  • Ouverture d'une nouvelle fenêtre

  • Fenêtres en mosaïque

  • Fenêtres en cascade

  • Modification du focus de la fenêtre

Voir aussi

Affichage des pages de conception


Ouverture d'une nouvelle fenêtre

  • Dans le menu Fenêtre, cliquez sur Nouvelle fenêtre.

Remarque

  • Plusieurs fenêtres fournissent des vues complémentaires d'une même planification XLANG. Ainsi, vous pouvez effectuer les opérations suivantes :
    • Afficher simultanément plusieurs pages d'une même planification XLANG. Par exemple, vous pouvez ouvrir des vues des pages Processus professionnels, Données et Compensation pour transaction.

    • Afficher simultanément différentes parties d'une même page de planification XLANG. Par exemple, dans une vue, vous pouvez effectuer un zoom avant pour afficher un jeu de formes spécifique de la planification XLANG, et dans une autre effectuer un zoom arrière pour afficher la totalité de la planification.

Voir aussi

Fenêtres en cascade

Modification du focus de la fenêtre

Fenêtres en mosaïque

Affichage des pages de conception


Fenêtres en mosaïque

  • Dans le menu Fenêtre, cliquez sur Mosaïque.

Remarques

  • Cette option d'affichage vous permet d'afficher simultanément plusieurs fenêtres.

  • Plusieurs fenêtres fournissent des vues complémentaires d'une même planification XLANG. Ainsi, vous pouvez effectuer les opérations suivantes :
    • Afficher simultanément plusieurs pages d'une même planification XLANG. Par exemple, vous pouvez ouvrir des vues des pages Processus professionnels, Données et Compensation pour transaction.

    • Afficher simultanément différentes parties d'une même page de planification XLANG. Par exemple, dans une vue, vous pouvez effectuer un zoom avant pour afficher un jeu de formes spécifique de la planification XLANG, et dans une autre effectuer un zoom arrière pour afficher la totalité de la planification.

Voir aussi

Fenêtres en cascade

Modification du focus de la fenêtre

Ouverture d'une nouvelle fenêtre

Affichage des pages de conception


Fenêtres en cascade

  • Dans le menu Fenêtre, cliquez sur Cascade.

Remarques

  • Cette option d'affichage vous permet d'afficher une fenêtre en premier plan. Vous pouvez cliquer sur les barres de titre des autres fenêtres pour les afficher en premier plan.

  • Plusieurs fenêtres fournissent des vues complémentaires d'une même planification XLANG. Ainsi, vous pouvez effectuer les opérations suivantes :
    • Afficher simultanément plusieurs pages d'une même planification XLANG. Par exemple, vous pouvez ouvrir des vues des pages Processus professionnels, Données et Compensation pour transaction.

    • Afficher simultanément différentes parties d'une même page de planification XLANG. Par exemple, dans une vue, vous pouvez effectuer un zoom avant pour afficher un jeu de formes spécifique de la planification XLANG, et dans une autre effectuer un zoom arrière pour afficher la totalité de la planification.

Voir aussi

Modification du focus de la fenêtre

Ouverture d'une nouvelle fenêtre

Fenêtres en mosaïque

Affichage des pages de conception


Modification du focus de la fenêtre

  • Dans le menu Affichage, cliquez sur le nom de la fenêtre vers laquelle vous voulez faire basculer le focus.

Remarques

  • Le nom d'une fenêtre correspond au nom de la planification XLANG, auquel est ajouté le nom d'une page de conception. Par exemple, Schedule1.skv:Processus professionnels ou Schedule1.skv:Données.

  • Plusieurs fenêtres fournissent des vues complémentaires d'une même planification XLANG. Ainsi, vous pouvez effectuer les opérations suivantes :
    • Afficher simultanément plusieurs pages d'une même planification XLANG. Par exemple, vous pouvez ouvrir des vues des pages Processus professionnels, Données et Compensation pour transaction.

    • Afficher simultanément différentes parties d'une même page de planification XLANG. Par exemple, dans une vue, vous pouvez effectuer un zoom avant pour afficher un jeu de formes spécifique de la planification XLANG, et dans une autre effectuer un zoom arrière pour afficher la totalité de la planification.

Voir aussi

Fenêtres en cascade

Ouverture d'une nouvelle fenêtre

Fenêtres en mosaïque

Affichage des pages de conception


Utilisation des annotations

Cette section traite des procédures suivantes :

  • Ajout d'annotations

  • Modification des annotations

  • Formatage du texte dans des annotations

  • Suppression d'annotations


Ajout d'annotations

  1. Dans la barre d'outils du Concepteur d'Orchestration BizTalk, cliquez sur le bouton Outil Texte ( Outil Texte).

  2. À l'aide du pointeur de la souris, déplacez-le vers la zone dans laquelle vous voulez créer une annotation.

  3. Tapez l'annotation.

Remarques

  • Pour désactiver le bouton Outil Texte, cliquez sur Outil Pointeur dans la barre d'outils( Bouton Outil Pointeur).

  • Comme le Concepteur d'Orchestration BizTalk utilise une interface personnalisée Microsoft Visio, le bouton Outil Texte offre deux options. Les fonctionnalités de ces deux boutons sont identiques :
    • Bouton Outil Texte ( Bouton Texte)

    • Bouton Outil Bloc de texte ( Bouton Bloc de texte)

Voir aussi

Suppression d'annotations

Modification des annotations

Formatage du texte dans des annotations


Modification des annotations

  1. Dans la barre d'outils du Concepteur d'Orchestration BizTalk, cliquez sur le bouton Outil Texte ( Outil Texte).

  2. Cliquez sur l'annotation que vous voulez modifier.

  3. Modifiez l'annotation.

Remarques

  • Pour désactiver le bouton Outil Texte, cliquez sur Outil Pointeur dans la barre d'outils( Bouton Outil Pointeur).

  • Comme le Concepteur d'Orchestration BizTalk utilise une interface personnalisée Microsoft Visio, le bouton Outil Texte offre deux options. Les fonctionnalités de ces deux boutons sont identiques :
    • Bouton Outil Texte ( Bouton Texte)

    • Bouton Outil Bloc de texte ( Bouton Bloc de Texte)

Voir aussi

Ajout d'annotations

Suppression d'annotations

Formatage du texte dans des annotations


Formatage du texte dans des annotations

  1. Dans une page de conception du Concepteur d'Orchestration BizTalk, sélectionnez des annotations à formater.

  2. Dans le menu Format, cliquez sur Texte.

    La boîte de dialogue Texte s'affiche. Cette boîte de dialogue propose plusieurs options pour la taille, la police et l'apparence du texte.

  3. Sélectionnez les options appropriées et cliquez sur OK.

Remarques

  • Ces options s'appliquent aux annotations mises en surbrillance dans le schéma de planification XLANG ainsi qu'à toutes les nouvelles annotations créées.

  • Vous ne pouvez pas formater les annotations lorsque l'Outil Texte est activé.

  • Cliquez sur une annotation pour la sélectionner. Pour en sélectionner plusieurs, appuyez sur la touche MAJ et maintenez-la enfoncée, puis cliquez sur les annotations à sélectionner.

Voir aussi

Ajout d'annotations

Suppression d'annotations

Modification des annotations


Suppression d'annotations

  • Dans une page de conception du Concepteur d'Orchestration BizTalk, cliquez sur l'annotation à supprimer, puis appuyez sur la touche SUPPR.

Remarque

  • Vous devez désactiver l'Outil Texte avant de supprimer une annotation d'un schéma de planification XLANG.

Voir aussi

Ajout d'annotations

Formatage du texte dans des annotations


Aperçu, impression et redimensionnement de schémas de planification XLANG

Cette section traite des procédures suivantes :

  • Utilisation de l'aperçu avant impression

  • Impression d'un schéma de planification XLANG

  • Redimensionnement d'un schéma de planification XLANG


Utilisation de l'aperçu avant impression

  • Dans le menu Fichier, cliquez sur Aperçu avant impression.

Remarque

  • Si vous modifiez l'option Orientation de Paysage en Portrait, le message suivant s'affiche :

    L'orientation des pages de conception ne correspond pas à la configuration des pages pour l'impression. Cliquez sur OK pour imprimer votre schéma sur plusieurs pages. Pour faire correspondre les orientations, modifiez la configuration des pages pour l'impression.

    Si vous cliquez sur OK et effectuez cette modification, le comportement de l'affichage de l'aperçu avant impression peut être le suivant :

    • Lorsque vous cliquez sur Mosaïque suivante pour afficher la page suivante, puis sur Mosaïque précédente pour revenir à la première page, certaines formes peuvent apparaître dans l'aperçu avant impression comme si elles ne se trouvaient pas sur la page. Cet affichage est sans effet. L'impression de la planification XLANG en cours s'effectuera correctement sur plusieurs pages.

Voir aussi

Impression d'un schéma de planification XLANG

Redimensionnement d'un schéma de planification XLANG


Impression d'un schéma de planification XLANG

  1. Dans le menu Fichier, cliquez sur Imprimer.

  2. Dans la boîte de dialogue Impression, sélectionnez les options d'impression souhaitées, puis cliquez sur le bouton Imprimer.

Voir aussi

Redimensionnement d'un schéma de planification XLANG

Utilisation de l'aperçu avant impression


Redimensionnement d'un schéma de planification XLANG

  1. Dans le menu Affichage du Concepteur d'Orchestration BizTalk, cliquez sur Page entière.

  2. Appuyez sur la touche CTRL et maintenez-la enfoncée, puis déplacez le pointeur de la souris vers le bord de la page.

    Celui-ci se transforme en double flèche.

  3. Sélectionnez et déplacez le bord de la page pour la redimensionner.

Voir aussi

Impression d'un schéma de planification XLANG

Utilisation de l'aperçu avant impression


Ajout, suppression et connexion de formes

Cette section traite des procédures suivantes :

  • Ajout de formes

  • Affectation d'un nom aux formes

  • Suppression de formes

  • Suppression de ports et messages inutilisés

  • Connexion des formes


Ajout de formes

  • Dans le stencil Diagramme de flux du Concepteur d'orchestration BizTalk, cliquez sur une forme et faites-la glisser vers la page de conception.

Remarques

  • Vous pouvez ajouter des formes Diagramme de flux aux pages Processus professionnels, Compensation pour Transaction et En cas d'échec de Transaction. Les formes Diagramme de flux ne sont pas disponibles dans la page Données.

  • Pour plus d'informations sur l'ajout de formes Implémentation à un schéma de planification XLANG, voir Implémentation de ports.

  • Vous ne pouvez pas ajouter de formes à la page Données. De nouveaux messages sont créés automatiquement sur la page Données lors de chaque connexion d'une action à un port.

Voir aussi

Connexion des formes

Suppression de formes

Suppression de ports et messages inutilisés

Affectation d'un nom aux formes

Affichage du stencil Diagramme de flux


Affectation d'un nom aux formes

  1. Dans une page de conception du Concepteur d'Orchestration BizTalk, cliquez avec le bouton droit sur une forme, puis cliquez sur Propriétés.

  2. Dans la boîte de dialogue Properties, tapez un nom dans la zone Nom.

Remarques

  • La propriété Nom de chacune des formes contient une valeur par défaut correspondant au nom de la forme auquel est ajouté un nombre ; par exemple, Action 1. Vous pouvez remplacer la valeur par défaut par le nom de votre choix.

  • Les formes suivantes ne peuvent pas être nommées : Abandon, Début, Décision, Fin, Branche, Jointure et Tant que.

  • Les formes suivantes peuvent être nommées : Action, Transaction, Port, Message et Règle.

  • Les noms de formes doivent répondre à certaines conventions d'affectation des noms. Les conventions suivantes s'appliquent aux transactions, ports, messages, règles et champs :
    • Le nom doit être un nom de jeton XML valide. Pour plus d'informations sur les jetons XML, accédez au site Web de W3C à l'adresse (www.w3.org).

    • Le nom ne peut pas commencer par des traits de soulignement (__).

    • Le nom ne peut pas comporter de caractères deux-points (:).

    • La longueur du nom doit être inférieure ou égale à 32 caractères.

    • Constant names and message names cannot begin with a numeric character.
  • Les noms de transactions dans des jeux de caractères codés sur un seul octet ne peuvent pas dépasser une longueur de 16 caractères. Les noms de transactions dans des jeux de caractères codés sur deux octets ne peuvent pas dépasser une longueur de 8 caractères.

  • Aucune convention d'affectation des noms ne s'applique aux actions, hormis la taille limite de 32 caractères.

Voir aussi

Ajout de formes

Connexion des formes

Suppression de formes

Suppression de ports et messages inutilisés


Suppression de formes

  • Cliquez sur la forme à supprimer et appuyez sur la touche SUPPR.

Remarques

  • Pour supprimer une connexion entre deux formes, cliquez sur la connexion appropriée et appuyez sur la touche SUPPR.

  • Si une forme a des connexions avec d'autres formes, lorsque vous la supprimez, toutes les connexions sont également supprimées.

  • Toutes les formes incluses dans une transaction sont supprimées lorsque vous supprimez la transaction.

  • Vous pouvez supprimer des implémentations d'Échanges BizTalk ou de Message Queuing sans supprimer les ports auxquels ces implémentations sont connectées.

  • Lorsque vous supprimez une implémentation de composants COM ou de composants de script Windows, les ports auxquels ils sont connectés sont également supprimés.

  • Pour supprimer un message, cliquez sur le message d'un port et sur la touche SUPPR. Le message associé est supprimé dans la page Données.

    Vous pouvez également supprimer des messages à partir de la page Données. Pour plus d'informations, voir Suppression d'un message.

  • Vous ne pouvez pas supprimer de règles en utilisant cette procédure. Pour plus d'informations sur la suppression de règles, consultez les rubriques suivantes :
    • Suppression d'une règle dans une décision

    • Suppression d'une règle dans une boucle Tant que

    • Suppression des règles inutilisées

Voir aussi

Ajout de formes

Connexion des formes

Suppression d'un message

Suppression d'une règle dans une décision

Suppression d'une règle dans une boucle Tant que

Suppression de ports et messages inutilisés

Suppression des règles inutilisées

Affectation d'un nom aux formes


Suppression de ports et messages inutilisés

  • Dans le menu Outils du Concepteur d'Orchestration BizTalk, cliquez sur Supprimer les ports et les messages non utilisés.

Remarque

  • Cette procédure supprime du schéma de planification XLANG tous les ports non utilisés ainsi que tous les messages qu'ils contiennent. Les messages correspondants sont également supprimés de la page Données.

Voir aussi

Ajout de formes

Connexion des formes

Suppression de formes

Affectation d'un nom aux formes


Connexion des formes

Cette section traite des procédures suivantes :

  • Choix d'une forme

  • Connexion de deux formes

  • Utilisation de l'outil de connexion

  • Alignement vertical ou horizontal des formes

Voir aussi

Ajout de formes

Suppression de formes

Suppression de ports et messages inutilisés

Affectation d'un nom aux formes


Choix d'une forme

  • Dans une page de conception du Concepteur d'Orchestration BizTalk, cliquez sur la forme à sélectionner.

    La forme sélectionnée est entourée d'une bordure verte discontinue. Toutes les poignées de contrôle ( Poignée de contrôle) disponibles pour cette forme sont activées.

Remarques

  • Sélectionner une forme vous permet de faire glisser ses poignées de contrôle ( Poignée de contrôle) vers d'autres formes.

  • Sélectionner une forme vous permet de modifier les propriétés disponibles et de couper, copier, coller, effacer ou dupliquer la forme. Ces options ne sont pas disponibles pour toutes les formes.

  • Si vous copiez une forme Action connectée à une forme Port, la copie de cette action est également connectée à ce port.

Voir aussi

Ajout de formes

Connexion de deux formes

Suppression de formes

Utilisation de l'outil de connexion


Connexion de deux formes

  1. Pour connecter les deux formes, sélectionnez la première.

    La forme sélectionnée est entourée d'une bordure verte discontinue. Toutes les poignées de contrôle ( Poignée de contrôle) disponibles pour cette forme sont activées.

  2. Faites glisser la poignée de contrôle appropriée vers le point de connexion ( Point de connexion) de la deuxième forme.

    Lorsque le point de connexion est en surbrillance avec une case rouge ( Point de connexion active), relâchez le bouton de la souris pour établir la connexion.

Remarques

  • Les flux de processus sont connectés des points de connexion inférieur et supérieur aux poignées de contrôle des formes.

  • Les flux de communication sont connectés de la poignée de contrôle droite d'une forme Action au point de connexion gauche d'une forme Port.

  • Vous pouvez également utiliser l'outil de connexion pour connecter les formes. Pour plus d'informations, voir Utilisation de l'outil de connexion.

Voir aussi

Ajout de formes

Suppression de formes

Choix d'une forme

Utilisation de l'outil de connexion


Utilisation de l'outil de connexion

  1. Dans la barre d'outils, cliquez sur le bouton Outil de connexion ( Bouton Outil de connexion)).

  2. Pointez sur une poignée de contrôle ( Poignée de contrôle) de la forme à partir de laquelle vous voulez créer une connexion.

    La poignée de contrôle est entourée d'une case rouge pour indiquer que vous pouvez la faire glisser.

  3. Appuyez sur le bouton de la souris et maintenez-le enfoncé pour glisser la poignée de contrôle de la forme vers le point de connexion ( Point de connexion) de la forme avec laquelle vous voulez créer une connexion.

    Lorsque le point de connexion de la forme est en surbrillance avec une case rouge ( Point de connexion activé), relâchez le bouton de la souris pour établir la connexion.

Remarques

  • Pour désactiver l'outil de connexion, cliquez sur le bouton Outil Pointeur dans la barre d'outils ( Bouton Pointer Tool)

  • Vous pouvez ajouter des formes à une page et effectuer d'autres opérations lorsque l'outil de connexion est activé. Cependant, vous pouvez recevoir un message d'erreur. Ce message n'est pas valide et n'a aucun effet. Cette erreur fictive sera corrigée dans les prochaines versions de Microsoft Visio. Si ce message d'erreur s'affiche, cliquez sur OK et continuez. Le texte du message est le suivant :

    Erreur interne Visio : #-1

    Action 1246 : Déplacement sur la page

    Essayez de fermer puis de rouvrir le fichier. Puis essayez de redémarrer Visio.

Voir aussi

Ajout de formes

Connexion de deux formes

Suppression de formes

Choix d'une forme


Alignement de formes sur un axe vertical ou horizontal

  1. Dans une page de conception du Concepteur d'Orchestration BizTalk, faites glisser le pointeur de la souris sur les formes que vous voulez aligner sur un axe.

  2. Dans la barre d'outils, cliquez sur le bouton Aligner les formes( Bouton Aligner les formes).

  3. Dans la boîte de dialogue Aligner les formes, dans l'une des zones ci-après, cliquez sur l'alignement approprié :
    • Dans la zone Alignement vers le haut/bas, cliquez sur l'un des boutons suivants :

      Bouton Horizontal vers le haut Horizontal vers le haut/bas

      Bouton Horizontal centré Alignement Horizontal centré

      Bouton Horizontal vers le bas Alignement Horizontal vers le bas

    • Dans la zone Alignement vers le gauche/droite, cliquez sur l'un des boutons suivants :

      Bouton Vertical à gauche Alignement Vertical à gauche

      Bouton Vertical centré Alignement Vertical centré

      Bouton Vertical à droite Alignement Vertical à droite

Remarques

  • Vous devez sélectionner des formes sur une page de conception pour activer le bouton Aligner les formes.

  • Il est recommandé d'aligner les formes sur un seul axe. Dans le cas contraire, les formes risquent d'être superposées. Appuyez sur CTRL+Z pour annuler les modifications qui ne vous conviennent pas.

  • Dans la boîte de dialogue Aligner les formes, le bouton Désactiver l'alignement ( Bouton Désactiver l'alignement) supprime la sélection d'un alignement.

  • La case à cocher Créer un repère et coller les formes dessus n'est jamais disponible.

  • Vous pouvez appuyer sur la touche MAJ et la maintenir enfoncée, puis cliquer sur plusieurs formes pour les sélectionner.


Définition des propriétés conditionnelles

Cette section traite des procédures suivantes :

  • Définition des conditions de décision

  • Définition des conditions de boucle Tant que

  • Création de règles

Voir aussi

Conception de règles


Définition des conditions de décision

Cette section traite des procédures suivantes :

  • Ajout d'une règle à une décision

  • Modification d'une règle dans une décision

  • Suppression d'une règle dans une décision

  • Définition de l'ordre d'évaluation des règles

Voir aussi

Création de règles

Conception de règles


Ajout d'une règle à une décision

  1. Dans une page de conception du Concepteur d'Orchestration BizTalk, cliquez avec le bouton droit sur une forme Décision à laquelle vous voulez ajouter une règle et cliquez sur Ajouter une règle.

    La boîte de dialogue Ajouter une règle s'affiche.

  2. Dans cette boîte de dialogue, cliquez sur l'une des options suivantes :
    • Créer une règle

      Cliquez sur OK. La boîte de dialogue Propriétés de la règle s'affiche.

      Pour plus d'informations sur la création des règles, voir Création de règles.

    • Ajouter une règle existante

      Dans la liste Règles disponibles, sélectionnez la règle à ajouter et cliquez sur OK.

      La boîte de dialogue Ajouter une règle se ferme et la règle est ajoutée à la décision.

Remarques

  • Lorsque vous ajoutez une règle pour la première fois à un schéma de planification XLANG en cliquant sur Ajouter une règle, la boîte de dialoguePropriétés de la règle s'affiche. La boîte de dialogue Ajouter une règle s'affiche uniquement si vous disposez de règles créées précédemment afin de les ajouter à une décision. Pour plus d'informations sur la boîte de dialogue Propriétés de la règle, voir Création de règles.

  • Vous pouvez également ajouter une règle à une décision en cliquant avec le bouton droit sur une forme Décision, puis en cliquant sur Propriétés et sur Ajouter.

Voir aussi

Création de règles

Suppression d'une règle dans une décision

Conception de règles

Définition de l'ordre d'évaluation des règles

Modification d'une règle dans une décision


Modification d'une règle dans une décision

  1. Dans une page de conception du Concepteur d'Orchestration BizTalk, cliquez avec le bouton droit sur une forme Décision, puis cliquez sur Propriétés.

  2. Dans la boîte de dialogue Propriétés de la décision, cliquez sur la règle à modifier, puis cliquez sur Modifier.

  3. Dans la boîte de dialogue Propriétés de la règle, apportez les modifications appropriées, puis cliquez sur OK.

    Pour plus d'informations sur la boîte de dialogue Propriétés de la règle, voir Création de règles.

  4. Pour modifier une autre règle, sélectionnez-la et cliquez sur Modifier.

    –Ou–

    Pour fermer la boîte de dialogue Propriétés de la décision, cliquez sur OK.

Remarques

  • Dans la boîte de dialogue Propriétés de la décision, vous pouvez également ajouter une règle en cliquant sur Ajouter.

  • Vous pouvez également modifier une règle en cliquant avec le bouton droit sur une règle d'une forme Décision, puis en cliquant sur Propriétés. La boîte de dialogue Propriétés de la règle s'affiche

Voir aussi

Ajout d'une règle à une décision

Création de règles

Suppression d'une règle dans une décision

Conception de règles

Définition de l'ordre d'évaluation des règles


Suppression d'une règle dans une décision

  1. Dans une page de conception du Concepteur d'Orchestration BizTalk, cliquez avec le bouton droit sur une forme Décision pour laquelle vous voulez supprimer une règle et cliquez sur Propriétés.

  2. Cliquez sur la règle à supprimer, puis cliquez sur Ouvrir.

Voir aussi

Ajout d'une règle à une décision

Création de règles

Conception de règles

Définition de l'ordre d'évaluation des règles

Modification d'une règle dans une décision


Définition de l'ordre d'évaluation des règles

  1. Dans une page de conception du Concepteur d'Orchestration BizTalk, cliquez avec le bouton droit sur une forme Décision, puis cliquez sur Propriétés.

  2. Dans la boîte de dialogue Propriétés de la décision, cliquez sur la règle pour laquelle vous voulez modifier l'ordre d'évaluation.

  3. Dans la zone Ordre, cliquez sur la flèche HAUT ou BAS pour déplacer la règle afin de modifier son ordre d'apparition dans la liste.

Remarque

  • Il est recommandé de classer les règles par ordre de priorité. Les règles sont exécutées en séquence jusqu'à ce que l'une d'entre elles prenne la valeur TRUE. Le flux de processus est suivi pour la première règle qui prend la valeur TRUE. Si aucune règle ne prend la valeur TRUE, le flux Else est suivi.

Voir aussi

Ajout d'une règle à une décision

Création de règles

Suppression d'une règle dans une décision

Conception de règles

Modification d'une règle dans une décision


Définition des conditions de boucle Tant que

Cette section traite des procédures suivantes :

  • Ajout d'une règle à une boucle Tant que

  • Modification d'une règle dans une boucle Tant que

  • Suppression d'une règle dans une boucle Tant que

  • Conservation de l'état dans une boucle Tant que

Voir aussi

Création de règles

Conception de règles


Ajout d'une règle à une boucle Tant que

  1. Dans une page de conception du Concepteur d'Orchestration BizTalk, cliquez avec le bouton droit sur une forme Tant que à laquelle vous voulez ajouter une règle et cliquez sur Ajouter une règle.

    La boîte de dialogue Ajouter une règle s'affiche.

  2. Dans cette boîte de dialogue, cliquez sur l'une des options suivantes :
    • Créer une règle

      Cliquez sur OK. La boîte de dialogue Propriétés de la règle s'affiche.

      Pour plus d'informations sur la création des règles, voir Création de règles.

    • Ajouter une règle existante

      Dans la liste Règles disponibles, sélectionnez la règle à ajouter et cliquez sur OK.

      La boîte de dialogue Ajouter une règle se ferme et la règle est ajoutée à la boucle Tant que.

Remarques

  • Lorsque vous ajoutez une règle pour la première fois à un schéma de planification XLANG en cliquant sur Ajouter une règle, la boîte de dialoguePropriétés de la règle s'affiche. La boîte de dialogue Ajouter une règle s'affiche uniquement si vous disposez de règles créées précédemment afin de les ajouter à une boucle Tant que. Pour plus d'informations sur la boîte de dialogue Propriétés de la règle, voir Création de règles.

  • Vous pouvez uniquement ajouter une règle à une boucle Tant que.

Voir aussi

Création de règles

Suppression d'une règle dans une boucle Tant que

Conception de règles

Modification d'une règle dans une boucle Tant que

Conservation de l'état dans une boucle Tant que


Modification d'une règle dans une boucle Tant que

  1. Dans une page de conception du Concepteur d'Orchestration BizTalk, cliquez avec le bouton droit sur une règle contenue dans une forme Tant que, puis cliquez sur Propriétés.

  2. Dans la boîte de dialogue Propriétés de la règle, apportez les modifications appropriées, puis cliquez sur OK.

    Pour plus d'informations sur la boîte de dialogue Propriétés de la règle, voir Création de règles.

Voir aussi

Ajout d'une règle à une boucle Tant que

Création de règles

Suppression d'une règle dans une boucle Tant que

Conception de règles

Conservation de l'état dans une boucle Tant que


Suppression d'une règle dans une boucle Tant que

  • Dans une page de conception du Concepteur d'Orchestration BizTalk, cliquez avec le bouton droit sur une forme Tant que pour laquelle vous voulez supprimer une règle et cliquez sur Supprimer la règle.

Voir aussi

Ajout d'une règle à une boucle Tant que

Création de règles

Conception de règles

Modification d'une règle dans une boucle Tant que

Conservation de l'état dans une boucle Tant que


Conservation de l'état dans une boucle Tant que

  1. Dans une page de conception du Concepteur d'Orchestration BizTalk, cliquez avec le bouton droit sur une forme Tant que, puis cliquez sur Propriétés.

  2. Dans la boîte de dialogue Propriétés While, dans la zone Persistance de l'état, cliquez sur l'une des options suivantes :
    • Oui

      Les messages utilisés à chaque itération de boucle sont enregistrés comme des états de planification XLANG. Si la boucle appartient à une transaction qui échoue, une page En cas d'échec de Transaction ou Compensation pour Transaction est invoquée pour chaque itération de boucle achevée.

    • Non

      Seuls les messages utilisés lors de la dernière itération de boucle sont enregistrés comme états de planification XLANG. Si la boucle appartient à une transaction qui échoue, une page En cas d'échec de Transaction ou Compensation pour Transaction est invoquée une seule fois.

Voir aussi

Ajout d'une règle à une boucle Tant que

Création de règles

Suppression d'une règle dans une boucle Tant que

Conception de règles

Modification d'une règle dans une boucle Tant que


Création de règles

Cette section traite des procédures suivantes :

  • Création d'une règle

  • Utilisation de l'Assistant d'expression

  • Ajout de constantes à une règle

  • Suppression des règles inutilisées

Voir aussi

Conception de règles

Définition des conditions de décision

Définition des conditions de boucle Tant que


Création d'une règle

Vous pouvez créer des règles afin d'évaluer les conditions de vos processus professionnels. Les règles sont utilisées dans les décisions et les boucles Tant que dans une planification XLANG. Lorsque vous ajoutez une règle à une forme Décision ou Tant que, la boîte de dialogue Propriétés de la règle s'affiche.

  1. Dans la zone Nom de règle de la boîte de dialogue Propriétés de la règle, tapez le nom de la règle.

    Ce champ est obligatoire.

  2. Dans la zone Description de la règle, vous pouvez taper une description.

    Ce champ est facultatif.

  3. Vous devez positionner le curseur dans la zone Expression de script pour activer l'Assistant d'expression.

    Vous pouvez taper l'expression du script à utiliser ou faire appel à l'Assistant d'expression. Pour plus d'information sur l'utilisation de l'Assistant d'expression et la création d'expressions de script, voir Utilisation de l'Assistant d'expression.

Important

  • Comme le langage XML respecte la casse, les expressions de script doivent utiliser la même casse que celles des messages et de leurs champs.

  • Vous devez positionner le curseur dans la zone Expression de script pour activer l'Assistant d'expression.

Remarques

  • Les noms de formes doivent répondre à certaines conventions d'affectation des noms. Les conventions suivantes s'appliquent aux transactions, ports, messages, règles et champs :
    • Le nom doit être un nom de jeton XML valide. Pour plus d'informations sur les jetons XML, accédez au site Web de W3C à l'adresse (www.w3.org).

    • Le nom ne peut pas commencer par des traits de soulignement (__).

    • Le nom ne peut pas comporter de caractères deux-points (:).

    • La longueur du nom doit être inférieure ou égale à 32 caractères.
  • Les formes suivantes ne peuvent pas être nommées : Abandon, Début, Décision, Fin, Branche, Jointure et Tant que.

  • Le nom de règle le plus long détermine la largeur de la forme Décision ou Tant que dans laquelle la règle sera utilisée.

  • Vous pouvez ajouter des expressions de script à tout moment dans la zone Expression de script en positionnant le curseur à l'emplacement où vous voulez ajouter l'expression.

  • Vous ne pouvez pas créer d'expressions de script tant que vous n'avez pas créé les implémentations de ports et les communications de messages entre les actions et les ports.

  • Avant de compiler le schéma de planification XLANG dans une planification XLANG, vous devez compléter les expressions de script pour toutes les règles de la planification.

Voir aussi

Ajout de constantes à une règle

Conception de règles

Définition des conditions de décision

Définition des conditions de boucle Tant que

Utilisation de l'Assistant d'expression


Utilisation de l'Assistant d'expression

  1. Dans la zone Assistant d'expression de la boîte de dialogue Propriétés de la règle, cliquez sur un message dans la liste Message.

  2. Dans la zone Assistant d'expression, cliquez sur un champ dans la liste Champ.

  3. Cliquez sur Insérer.

  4. Dans la zone Expression de script, complétez l'expression.

    L'Assistant d'expression ajoute uniquement le message et le champ que vous avez sélectionnés. Pour évaluer l'expression de script, vous devez spécifier une condition pour la règle. Exemple :

    PORequest.Total < 500

    Vous pouvez également associer des expressions pour créer des conditions plus complexes. Exemple :

    PORequest.Total < 500 AND PORequest.Quantity < 20

Important

  • Comme le langage XML respecte la casse, les expressions de script doivent utiliser la même casse que celles des messages et de leurs champs.

  • Vous devez positionner le curseur dans la zone Expression de script pour activer l'Assistant d'expression.

  • Les champs disponibles dans la liste Champ sont basés sur le message que vous avez sélectionné dans la liste Message. Seuls les champs contenus dans ce message peuvent être utilisés.

Remarques

  • La liste Message contient tous les messages et constantes disponibles dans la page Données.

  • Les règles peuvent utiliser les champs système fournis sur la page Données. Lorsqu'ils sont utilisés avec une règle, les champs système sont entre crochets. Exemple :

    Message1.[__Exists__]

    Pour plus d'informations sur les champs système, voir Gestion d'erreur.

  • Vous pouvez utiliser les fonctions Microsoft Visual Basic telles que Date et Heure dans les règles.

  • Vous pouvez ajouter des expressions de script à tout moment dans la zone Expression de script en positionnant le curseur à l'emplacement où vous voulez ajouter l'expression.

  • Avant de compiler le schéma de planification XLANG dans une planification XLANG, vous devez compléter les expressions de script pour toutes les règles de la planification.

Voir aussi

Ajout de constantes à une règle

Création d'une règle

Conception de règles

Définition des conditions de décision

Définition des conditions de boucle Tant que


Ajout de constantes à une règle

Vous pouvez ajouter des constantes aux expressions de script d'une règle. Pour utiliser des constantes, vous devez d'abord vous assurer qu'elles sont disponibles.

  1. Sur la page Données, vous devez ajouter des constantes à la liste Constantes, s'il n'y en a pas de disponibles.

    Pour plus d'informations sur l'utilisation des constantes et leur ajout à la liste Constantes, voir Utilisation des constantes.

  2. Dans la boîte de dialogue Propriétés de la règle, cliquez sur Constantes dans la liste Message.

  3. Dans la liste Champ, sélectionnez la constante à ajouter et cliquez sur Insérer.

Remarque

  • Toutes les constantes de la liste Constantes sur la page Données sont disponibles et peuvent être utilisées dans une règle.

Voir aussi

Création d'une règle

Conception de règles

Définition des conditions de décision

Définition des conditions de boucle Tant que

Utilisation de l'Assistant d'expression


Suppression des règles inutilisées

  • Dans le menu Outils, cliquez sur Supprimer les règles non utilisées.

Remarques

  • Cette procédure supprime les règles qui ne sont pas utilisées dans une décision ou dans une boucle Tant que de schéma de planification XLANG.

  • Seules les règles qui ne sont pas utilisées actuellement dans des formes Tant que ou Décision sont supprimées du schéma de planification XLANG. Les règles utilisées dans des formes Tant que ou Décision ne sont pas supprimées, même si elles ne sont pas connectées à d'autres formes.

Voir aussi

Ajout de constantes à une règle

Création d'une règle

Utilisation de l'Assistant d'expression


Définition des propriétés de simultanéité

Cette section traite des procédures suivantes :

  • Création de flux concurrents

  • Définition de la propriété Type de jointure

  • Jointure de flux concurrents

  • Fin d'un flux concurrent

Important

  • Pour plus d'informations sur les processus concurrents, voir Conception concurrentielle.


Création de flux concurrents

  1. Dans une page de conception du Concepteur d'Orchestration BizTalk, cliquez sur une forme Branche.

  2. Connectez la poignée de contrôle inférieure de la forme ( Poignée de contrôle) Branche au point de connexion supérieur ( Point de connexion) d'une branche successive dans le flux du processus professionnel.

  3. Répétez les étapes 1 et 2 pour créer des flux concurrents supplémentaires.

Important

  • Pour plus d'informations sur les processus concurrents, voir Conception concurrentielle.

Remarques

  • Seul un flux peut entrer dans une forme Branche à partir du point de connexion supérieur.

  • Un maximum de 64 flux peut sortir d'une forme Branche afin d'exécuter des processus concurrents.

  • Vous devez cliquer sur la forme Branche pour la sélectionner et activer la poignée de contrôle chaque fois que vous voulez créer un flux complémentaire.

    –Ou–

    Si vous voulez créer plusieurs flux concurrents, vous pouvez utiliser l'outil de connexion pour les ajouter plus rapidement. Pour plus d'informations sur l'outil de connexion, voir Utilisation de l'outil de connexion.

  • Vous pouvez ajouter des formes Diagramme de flux aux pages Processus professionnels, Compensation pour Transaction et En cas d'échec de Transaction. Les formes Diagramme de flux ne sont pas disponibles dans la page Données.

Voir aussi

Ajout, suppression et connexion de formes

Connexion de deux formes

Fin d'un flux concurrent

Jointure de flux concurrents

Choix d'une forme

Définition de la propriété Type de jointure

Utilisation de l'outil de connexion


Définition de la propriété Type de jointure

  1. Dans une page de conception du Concepteur d'Orchestration BizTalk, cliquez avec le bouton droit sur une forme Jointure, puis cliquez sur Propriétés.

  2. Dans la liste Type de jointure, cliquez sur l'une des options suivantes :
    • AND

    • Ou

Important

  • Pour plus d'informations sur les processus concurrents, voir Conception concurrentielle.

Remarque

  • ƒi vous sélectionnez l'option de jointure OR, tous les flux qui entrent dans la jointure ne peuvent posséder qu'une seule action associée au flux.

Voir aussi

Création de flux concurrents

Fin d'un flux concurrent

Jointure de flux concurrents


Jointure de flux concurrents

  1. Dans une page de conception du Concepteur d'Orchestration BizTalk, cliquez sur une forme du processus professionnel qui exécute un processus concurrent.

  2. Connectez la poignée de contrôle inférieure de la forme ( Poignée de contrôle) au point de connexion supérieur de la forme ( Point de connexion) Jointure.

  3. Répétez les étapes 1 et 2 pour tous les flux concurrents qui rejoignent cette jointure.

Important

  • Pour plus d'informations sur les processus concurrents, voir Conception concurrentielle.

Remarques

  • Si vous sélectionnez l'option de jointure OR, tous les flux qui entrent dans la jointure ne peuvent posséder qu'une seule action associée au flux.

  • Un maximum de 64 flux peut entrer dans une forme Branche au point de connexion supérieur.

  • Seul un flux peut sortir d'une forme Branche à partir du point de connexion inférieur.

  • Si vous voulez effectuer une jointure entre plusieurs flux concurrents, vous pouvez utiliser l'outil de connexion pour les joindre plus rapidement. Pour plus d'informations sur l'outil de connexion, voir Utilisation de l'outil de connexion.

  • Vous pouvez ajouter des formes Diagramme de flux aux pages Processus professionnels, Compensation pour Transaction et En cas d'échec de Transaction. Les formes Diagramme de flux ne sont pas disponibles dans la page Données.

Voir aussi

Ajout, suppression et connexion de formes

Connexion de deux formes

Création de flux concurrents

Fin d'un flux concurrent

Choix d'une forme

Définition de la propriété Type de jointure

Utilisation de l'outil de connexion


Fin d'un flux concurrent

  1. Dans une page de conception du Concepteur d'Orchestration BizTalk, cliquez sur une forme du processus professionnel qui exécute un processus concurrent.

  2. Connectez la poignée de contrôle inférieure de la forme ( Poignée de contrôle) au point de connexion supérieur de la forme ( Point de connexion) Fin.

    Ce processus concurrent s'arrête. Il ne rejoint pas les autres flux de la planification XLANG.

Important

  • Pour plus d'informations sur les processus concurrents, voir Conception concurrentielle.

Remarque

  • Vous pouvez ajouter des formes Diagramme de flux aux pages Processus professionnels, Compensation pour Transaction et En cas d'échec de Transaction. Les formes Diagramme de flux ne sont pas disponibles dans la page Données.

Voir aussi

Ajout, suppression et connexion de formes

Connexion de deux formes

Création de flux concurrents

Jointure de flux concurrents

Choix d'une forme

Définition de la propriété Type de jointure

Utilisation de l'outil de connexion


Définition des propriétés de transaction

Cette section traite des procédures suivantes :

  • Définition des propriétés transactionnelles d'une planification XLANG

  • Définition de propriétés transactionnelles individuelles

  • Description de la prise en charge de transaction de composant et de Message Queuing

Voir aussi

Conception de transactions


Définition des propriétés transactionnelles d'une planification XLANG

Cette section traite des procédures suivantes :

  • Définition du modèle de transaction

  • Définition de la propriété d'activation de la transaction

Voir aussi

Conception de transactions


Définition du modèle de transaction

  1. Dans une page de conception du Concepteur d'Orchestration BizTalk, cliquez avec le bouton droit sur la forme Début, puis cliquez sur Propriétés.

    La boîte de dialogue Propriétés de début s'affiche.

  2. Dans la liste Modèle de transaction, choisissez l'une des options suivantes :
    • Inclure des transactions dans la planification XLANG

      Cette option permet à une planification XLANG d'utiliser des transactions.

    • Traiter la planification XLANG en tant que composant COM+

      Cette option désactive la prise en charge des transactions d'une planification XLANG. Un composant COM peut alors activer la planification XLANG dans une transaction COM+.

Remarques

  • Si vous définissez la propriété Modèle de transaction sur Traiter la planification XLANG en tant que composant COM+, la liste Activation de la transaction est activée.

  • Si vous définissez la propriété Modèle de transaction sur Traiter la planification XLANG en tant que composant COM+, n'ajoutez pas de transactions au schéma de planification XLANG. Sinon, la compilation du schéma de planification XLANG ne s'effectuera pas et vous obtiendrez un message d'erreur.

  • La propriété Identité XLANG est un identificateur unique utilisé pour différencier les versions d'un schéma de planification XLANG. Cette propriété est en lecture seule et ne peut pas être modifiée. Lorsque vous mettez à jour un schéma de planification XLANG, cette identité est également mise à jour.

    Vous pouvez utiliser la propriété Identité XLANG pour faire correspondre les versions d'un schéma de planification XLANG (.skv) à la planification XLANG associée qui est compilée (.skx).

  • La forme Début est disponible sur les pages Processus professionnels, Compensation pour Transaction et En cas d'échec de Transaction. La forme Début n'est pas disponible dans la page Données.

Voir aussi

Description de la prise en charge de transaction de composant et de Message Queuing

Conception de transactions

Définition de la propriété d'activation de la transaction


Définition de la propriété d'activation de la transaction

  1. Dans une page de conception du Concepteur d'Orchestration BizTalk, cliquez avec le bouton droit sur la forme Début, puis cliquez sur Propriétés.

    La boîte de dialogue Propriétés de début s'affiche.

  2. Dans la liste Modèle de transaction, cliquez sur Traiter la planification XLANG en tant que composant COM+.

    Si cette option est activée, les services Composant traitent la planification XLANG en tant que composant COM+. Cette option désactive la prise en charge des transactions d'une planification XLANG. Un composant COM peut alors activer la planification XLANG dans une transaction COM+.

  3. Dans la liste Activation de la transaction, choisissez l'une des options suivantes :
    • Non pris en charge

      Le cas échéant, la planification XLANG ignore la transaction dans le contexte d'objets COM+ de son auteur. Aucune action de la planification n'est exécutée dans l'étendue d'une transaction.

    • Pris en charge

      La planification XLANG participe à une transaction COM+ si une transaction fait partie du contexte d'objets COM+ de son auteur.

    • Requis

      La planification XLANG doit être exécutée dans l'étendue d'une transaction. Si aucune transaction n'est présente dans le contexte d'objets COM+ de l'auteur de la planification, une transaction est automatiquement créée et utilisée par le moteur de XLANG Scheduler.

    • Requiert une nouvelle

      La planification XLANG doit être exécutée dans l'étendue d'une nouvelle transaction. Le moteur de XLANG Scheduler crée automatiquement une nouvelle transaction pour la planification, distincte de toutes les transactions présentes dans le contexte d'objets COM+ de son auteur.

Remarques

  • La propriété Identité XLANG est un identificateur unique utilisé pour différencier les versions d'un schéma de planification XLANG. Cette propriété est en lecture seule et ne peut pas être modifiée. Lorsque vous mettez à jour un schéma de planification XLANG, cette identité est également mise à jour.

    Vous pouvez utiliser la propriété Identité XLANG pour faire correspondre les versions d'un schéma de planification XLANG (.skv) à la planification XLANG associée qui est compilée (.skx).

  • La forme Début est disponible sur les pages Processus professionnels, Compensation pour Transaction et En cas d'échec de Transaction. La forme Début n'est pas disponible dans la page Données.

Voir aussi

Description de la prise en charge de transaction de composant et de Message Queuing

Conception de transactions

Définition du modèle de transaction


Définition de propriétés transactionnelles individuelles

Cette section traite des procédures suivantes :

  • Actions et flux de groupe d'une transaction

  • Conception de transactions imbriquées

  • Création de flux de transaction entrants et sortants

  • Affectation d'un nom à une transaction

  • Définition de la propriété Type de transaction

  • Définition de la propriété Délai d'attente

  • Définition de la propriété Nombre de tentatives

  • Définition de la propriété Intervalle

  • Définition de la propriété Niveau d'isolation

Voir aussi

Conception de transactions


Actions et flux de groupe d'une transaction

  1. Dans une page de conception du Concepteur d'Orchestration BizTalk, faites glisser une forme Transaction d'un stencil Diagramme de flux vers le côté gauche de la barre de séparation.

  2. Redimensionnez la taille de la forme Transaction afin d'entourer les formes à inclure dans la transaction.

Remarques

  • Les formes ou flux contenus dans les limites d'une transaction sont considérés comme faisant partie intégrante de cette transaction.

  • Pour sélectionner une forme dans une transaction, cliquez dessus.

  • Si vous supprimez une transaction contenant des formes dans ses limites, celles-ci seront également supprimées.

  • Les types de transaction sont indiqués par les couleurs suivantes :
    • Bleu. Indique des transactions minutées.

    • Beige. Indique des transactions longues.

    • Gris. Indique des transactions courtes, de style DTC.
  • Vous pouvez ajouter des formes Diagramme de flux aux pages Processus professionnels, Compensation pour Transaction, et En cas d'échec de Transaction. Les formes Diagramme de flux ne sont pas disponibles dans la page Données.

Voir aussi

Ajout, suppression et connexion de formes

Création de flux de transaction entrants et sortants

Conception de transactions

Conception de transactions imbriquées

Affectation d'un nom à une transaction


Conception de transactions imbriquées

  1. Dans une page de conception du Concepteur d'Orchestration BizTalk, faites glisser une forme Transaction d'un stencil Diagramme de flux dans les limites de la transaction en cours.

  2. Redimensionnez la taille de la forme Transaction afin d'entourer les formes à inclure dans la transaction.

Important

  • Lorsque vous créez des transactions imbriquées, certaines propriétés de transactions externes sont désactivées :
    • Le type de transaction Style DTC, courte n'est pas disponible.

    • Aucune option de la zone Options de transactions n'est disponible.

    • La propriété Délai est encore active mais vous ne pouvez pas la modifier après avoir créé une transaction imbriquée, sauf si vous définissez le type de transaction sur Transaction minutée.

Remarques

  • Les formes ou flux contenus dans les limites d'une transaction sont considérés comme faisant partie intégrante de cette transaction.

  • Pour sélectionner une forme dans une transaction, cliquez dessus.

  • Si vous supprimez une transaction contenant des formes dans ses limites, celles-ci seront également supprimées.

  • Les types de transaction sont indiqués par les couleurs suivantes :
    • Bleu. Indique des transactions minutées.

    • Beige. Indique des transactions longues.

    • Gris. Indique des transactions courtes, de style DTC.
  • Les formes Diagramme de flux qui ne font pas partie d'une transaction interne sont considérées comme faisant partie d'une transaction externe.

  • Les formes Diagramme de flux contenues dans une transaction externe peuvent être masquées partiellement par une transaction interne superposée, si elles ne font pas partie intégrante de la transaction interne. Sélectionnez ces formes et repositionnez-les de façon à ce qu'elles ne se superposent pas.

  • Vous pouvez ajouter des formes Diagramme de flux aux pages Processus professionnels, Compensation pour Transaction, et En cas d'échec de Transaction. Les formes Diagramme de flux ne sont pas disponibles dans la page Données.

Voir aussi

Ajout, suppression et connexion de formes

Création de flux de transaction entrants et sortants

Conception de transactions

Actions et flux de groupe d'une transaction

Affectation d'un nom à une transaction


Création de flux de transaction entrants et sortants

  1. Dans une page de conception du Concepteur d'Orchestration BizTalk, cliquez sur une forme qui précède une transaction dans le flux des processus professionnels.

  2. Connectez la poignée de contrôle inférieure de la forme ( Poignée de contrôle) au point de connexion supérieur de la forme ( Point de connexion) Transaction.

  3. Cliquez sur la forme Transaction pour la sélectionner.

  4. Connectez la poignée de contrôle supérieure de la forme Transaction au point de connexion supérieur de la première forme de la transaction qui correspond au début du flux de transactions.

  5. À partir de cette forme, connectez le flux à la forme suivante de la transaction.

  6. Connectez tous les flux de la transaction et toutes les actions aux ports pour lesquels vous voulez créer un flux de communication.

  7. À partir de la poignée de contrôle inférieure de la dernière forme de la transaction, connectez le flux au point de connexion inférieur de la forme Transaction.

  8. Cliquez sur la forme Transaction pour la sélectionner.

  9. Connectez la poignée de contrôle inférieure de la forme Transaction au point de connexion supérieur de la forme suivante du processus professionnel situé hors de la transaction.

Remarques

  • Pour sélectionner une forme dans une transaction, cliquez dessus.

  • Vous pouvez ajouter des formes Diagramme de flux aux pages Processus professionnels, Compensation pour Transaction et En cas d'échec de Transaction. Les formes Diagramme de flux ne sont pas disponibles dans la page Données.

Voir aussi

Ajout, suppression et connexion de formes

Connexion de deux formes

Conception de transactions

Conception de transactions imbriquées

Actions et flux de groupe d'une transaction

Utilisation de l'outil de connexion


Affectation d'un nom à une transaction

  1. Dans une page de conception du Concepteur d'Orchestration BizTalk, cliquez avec le bouton droit sur une forme Transaction, puis cliquez sur Propriétés.

    La boîte de dialogue Propriétés de la transaction s'affiche.

  2. Dans la zone Nom, tapez un nom pour la transaction.

Remarques

  • Les noms de formes doivent répondre à certaines conventions d'affectation des noms. Les conventions suivantes s'appliquent aux transactions, ports, messages, règles et champs :
    • Le nom doit être un nom de jeton XML valide. Pour plus d'informations sur les jetons XML, accédez au site Web de W3C à l'adresse (www.w3.org).

    • Le nom ne peut pas commencer par des traits de soulignement (__).

    • Le nom ne peut pas comporter de caractères deux-points (:).

    • La longueur du nom doit être inférieure ou égale à 32 caractères.
  • Les noms de transactions dans des jeux de caractères codés sur un seul octet ne peuvent pas dépasser une longueur de 16 caractères. Les noms de transactions dans des jeux de caractères codés sur deux octets ne peuvent pas dépasser une longueur de 8 caractères.

Voir aussi

Conception de transactions

Conception de transactions imbriquées

Actions et flux de groupe d'une transaction

Définition de la propriété Intervalle

Définition de la propriété Niveau d'isolation

Définition de la propriété Nombre de tentatives

Définition de la propriété Délai d'attente

Définition de la propriété Type de transaction


Définition de la propriété Type de transaction

  1. Dans une page de conception du Concepteur d'Orchestration BizTalk, cliquez avec le bouton droit sur une forme Transaction, puis cliquez sur Propriétés.

    La boîte de dialogue Propriétés de la transaction s'affiche.

  2. Dans la zone Type, cliquez sur l'une des options suivantes :
    • Transaction minutée

    • Style DTC, courte

    • Longue

Voir aussi

Conception de transactions

Conception de transactions imbriquées

Actions et flux de groupe d'une transaction

Affectation d'un nom à une transaction

Définition de la propriété Intervalle

Définition de la propriété Niveau d'isolation

Définition de la propriété Nombre de tentatives

Définition de la propriété Délai d'attente


Définition de la propriété Délai d'attente

  1. Dans une page de conception du Concepteur d'Orchestration BizTalk, cliquez avec le bouton droit sur une forme Transaction, puis cliquez sur Propriétés.

    La boîte de dialogue Propriétés de la transaction s'affiche.

  2. Dans la zone Délai d'attente de la zone Options de transactions, entrez un délai en secondes.

Voir aussi

Conception de transactions

Conception de transactions imbriquées

Actions et flux de groupe d'une transaction

Affectation d'un nom à une transaction

Définition de la propriété Intervalle

Définition de la propriété Niveau d'isolation

Définition de la propriété Nombre de tentatives

Définition de la propriété Type de transaction


Définition de la propriété Nombre de tentatives

  1. Dans une page de conception du Concepteur d'Orchestration BizTalk, cliquez avec le bouton droit sur une forme Transaction, puis cliquez sur Propriétés.

    La boîte de dialogue Propriétés de la transaction s'affiche.

  2. Dans la zone Nombre de tentatives de la zone Options de transactions, entrez le nombre de fois où une transaction peut être tentée avant de pouvoir considérer qu'elle a échoué.

Voir aussi

Conception de transactions

Conception de transactions imbriquées

Actions et flux de groupe d'une transaction

Affectation d'un nom à une transaction

Définition de la propriété Intervalle

Définition de la propriété Niveau d'isolation

Définition de la propriété Délai d'attente

Définition de la propriété Type de transaction


Définition de la propriété Intervalle

  1. Dans une page de conception du Concepteur d'Orchestration BizTalk, cliquez avec le bouton droit sur une forme Transaction, puis cliquez sur Propriétés.

    La boîte de dialogue Propriétés de la transaction s'affiche.

  2. Dans la zone Intervalle de la zone Options de transactions, entrez un délai en secondes.

Remarque

  • La propriété Intervalle détermine l'intervalle entre chaque tentative de transaction. Cette option est uniquement disponible pour les transactions de Style DTC, courtes. L'intervalle est utilisé avec la valeur du nombre de tentatives pour déterminer le délai avant la prochaine tentative de la transaction. La valeur de l'intervalle est exponentielle. Une valeur d'intervalle de 2 secondes correspond à un délai de 2, 4, 8, 16 secondes, et ainsi de suite, entre les tentatives. La formule est B**R (B élevé à la puissance R), où B = intervalle et R = nombre de tentatives.

Voir aussi

Conception de transactions

Conception de transactions imbriquées

Actions et flux de groupe d'une transaction

Affectation d'un nom à une transaction

Définition de la propriété Niveau d'isolation

Définition de la propriété Nombre de tentatives

Définition de la propriété Délai d'attente

Définition de la propriété Type de transaction


Définition de la propriété Niveau d'isolation

  1. Dans une page de conception du Concepteur d'Orchestration BizTalk, cliquez avec le bouton droit sur une forme Transaction, puis cliquez sur Propriétés.

    La boîte de dialogue Propriétés de la transaction s'affiche.

  2. Dans la liste Niveau d'isolation de la zone Options de transactions, cliquez sur l'une des options suivantes :
    • Sérialisable

    • Read Uncommitted (lecture non validée)

    • Read Committed (lecture validée)

    • Repeatable Read

Remarque

  • Cette propriété ne peut être définie que pour des transactions de style DTC, courtes.

Voir aussi

Conception de transactions

Conception de transactions imbriquées

Actions et flux de groupe d'une transaction

Affectation d'un nom à une transaction

Définition de la propriété Intervalle

Définition de la propriété Nombre de tentatives

Définition de la propriété Délai d'attente

Définition de la propriété Type de transaction


Description de la prise en charge de transaction de composant et de Message Queuing

Cette section traite des procédures suivantes :

  • Description du niveau de prise en charge de transaction dans un composant COM

  • Description du niveau de prise en charge de transaction dans un composant de script Windows

  • Description du niveau de prise en charge de transaction dans une file d'attente de messages

Voir aussi

Conception de transactions

Définition de la propriété d'activation de la transaction

Définition du modèle de transaction


Description du niveau de prise en charge de transaction dans un composant COM

La prise en charge de transaction pour les composants COM est définie dans l'Assistant Liaison de composants COM.

  1. Ouvrez l'Assistant Liaison de composants COM.

    Pour plus d'informations sur cet Assistant, voir Implémentation d'un port en utilisant un composant COM.

  2. Suivez les instructions de l'Assistant jusqu'à la page Propriétés avancées du port.

  3. Dans la zone Prise en charge des transactions de la page Propriétés avancées du port, cliquez sur l'une des options suivantes :
    • Désactivé

      Prise en charge des transactions pour le composant COM+ utilisé par cette implémentation du port désactivée.

    • Non pris en charge

      Le composant COM+ utilisé par cette implémentation de port ne prend pas en charge les transactions.

    • Pris en charge

      Le composant COM+ utilisé par cette implémentation de port hérite d'une transaction existante.

    • Requis

      Le composant COM+ utilisé par cette implémentation de port peut hériter d'une transaction existante ou utiliser une nouvelle transaction.

    • Requiert une nouvelle

      Le composant COM+ utilisé par cette implémentation de port requiert une nouvelle transaction.

Voir aussi

Ajout d'un port lié à un schéma de planification XLANG

Conception de transactions

Implémentation d'un port en utilisant un composant COM

Modification des propriétés d'implémentation d'un port

Définition de la propriété d'activation de la transaction

Définition du modèle de transaction


Description du niveau de prise en charge de transaction dans un composant de script Windows

La prise en charge des transactions pour les composants de script Windows est définie dans l'Assistant Liaison de composants de script.

  1. Ouvrez l'Assistant Liaison de composants de script.

    Pour plus d'informations sur cet Assistant, voir Implémentation d'un port en utilisant un composant de script Windows.

  2. Suivez les instructions de l'Assistant jusqu'à la page Propriétés avancées du port.

  3. Dans la zone Prise en charge des transactions de la page Propriétés avancées du port, cliquez sur l'une des options suivantes :
    • Désactivé

      Prise en charge des transactions pour le composant COM+ utilisé par cette implémentation du port désactivée.

    • Non pris en charge

      Le composant COM+ utilisé par cette implémentation de port ne prend pas en charge les transactions.

    • Pris en charge

      Le composant COM+ utilisé par cette implémentation de port hérite d'une transaction existante.

    • Requis

      Le composant COM+ utilisé par cette implémentation de port peut hériter d'une transaction existante ou utiliser une nouvelle transaction.

    • Requiert une nouvelle

      Le composant COM+ utilisé par cette implémentation de port requiert une nouvelle transaction.

Voir aussi

Ajout d'un port lié à un schéma de planification XLANG

Conception de transactions

Implémentation d'un port en utilisant un composant de script Windows

Modification des propriétés d'implémentation d'un port

Définition de la propriété d'activation de la transaction

Définition du modèle de transaction


Description du niveau de prise en charge de transaction dans une file d'attente de messages

La prise en charge de transaction pour les files d'attente de messages est définie dans l'Assistant Liaison de Message Queuing.

  1. Ouvrez l'Assistant Liaison de Message Queuing.

    Pour plus d'informations sur cet Assistant, voir Implémentation d'un port à l'aide de Message Queuing.

  2. Suivez les instructions de l'Assistant jusqu'à la page Propriétés avancées du port.

  3. Dans la zone Prise en charge de la transaction de la page Propriétés avancées du port, activez ou désactivez la case à cocher Des transactions sont requises avec cette file d'attente.

Voir aussi

Ajout d'un port lié à un schéma de planification XLANG

Conception de transactions

Implémentation d'un port à l'aide de Message Queuing

Modification des propriétés d'implémentation d'un port

Définition de la propriété d'activation de la transaction

Définition du modèle de transaction


Définition des propriétés de gestion d'erreurs

Cette section traite des procédures suivantes :

  • Abandon d'un flux de processus

  • Activation de la gestion d'erreur de transaction

  • Activation de la gestion d'erreur de composant

Voir aussi

Gestion des exceptions


Abandon d'un flux de processus

  1. Dans le stencil Diagramme de flux du Concepteur d'Orchestration BizTalk, cliquez sur la forme Abandon et faites-la glisser vers la page de conception.

  2. Connectez le flux de processus d'une branche logique qui existe dans une forme Décision au point de connexion de la forme ( Point de connexion) Abandon.

Important

  • Les formes Abandon sont utilisées afin d'abandonner un processus professionnel dans une branche logique. Elles sont combinées aux décisions.

    L'utilisation de la forme Abandon dépend des besoins de vos processus professionnels. Les règles comprises dans une décision sont évaluées jusqu'à ce que l'une d'entre elles prenne la valeur TRUE. Si une règle prend la valeur TRUE, le flux du processus continue jusqu'à l'action suivante. Si aucune règle ne prend la valeur TRUE, vous pouvez abandonner le flux du processus.

    L'exemple suivant illustre une condition décisionnelle où, si la règle prend la valeur TRUE, le flux de processus continue jusqu'à l'Action 3. Dans le cas contraire, le flux de processus est abandonné.

    Cliquez sur l'image pour l'agrandir ou la réduire.

    Utilisation d’une forme Abandon dans une branche logique.

Voir aussi

Activation de la gestion d'erreur de composant

Activation de la gestion d'erreur de transaction

Gestion des exceptions

Branchement logique


Activation de la gestion d'erreur de transaction

Cette section traite des procédures suivantes :

  • Activation de la gestion d'erreur En cas d'échec

  • Activation de la gestion d'erreur de compensation

Voir aussi

Abandon d'un flux de processus

Gestion des exceptions


Activation de la gestion d'erreur En cas d'échec

  1. Dans une page de conception du Concepteur d'Orchestration BizTalk, cliquez avec le bouton droit sur une forme Transaction, puis cliquez sur Propriétés.

    La boîte de dialogue Propriétés de la transaction s'affiche.

  2. Dans la zone En cas d'échec, cliquez sur Ajouter un code.

  3. Dans la zone En cas d'échec, activez la case à cocher Activé.

Remarques

  • Si vous cliquez sur Ajouter un code, vous créez la page En cas d'échec de Transaction associée à cette transaction. Le paramètre Transaction, dans le nom de la page, est remplacé par le nom de la transaction à laquelle le processus de gestion d'erreur est associé.

  • Si vous activez la case à cocher Activé, la planification XLANG est activée afin d'exécuter le code En cas d'échec de cette transaction. Si vous n'activez pas cette case à cocher, vous pouvez créer des processus En cas d'échec, mais ils ne s'exécuteront pas lors de l'exécution de la planification XLANG.

Voir aussi

Conception de transactions imbriquées

Actions et flux de groupe d'une transaction

Gestion des exceptions


Activation de la gestion d'erreur de compensation

  1. Dans une page de conception du Concepteur d'Orchestration BizTalk, cliquez avec le bouton droit sur une forme interne Transaction d'un groupe de transactions imbriquées et cliquez sur Propriétés.

    La boîte de dialogue Propriétés de la transaction s'affiche.

  2. Dans la zone Compensation, cliquez sur Ajouter un code.

  3. Dans la zone Compensation, activez la case à cocher Activé.

Remarques

  • Si vous cliquez sur Ajouter un code, vous créez la page En cas d'échec de Transaction ou Compensation pour Transaction associée à cette transaction.

  • Si vous activez la cas à cocher Activé, la planification XLANG est activée afin d'exécuter le code En cas d'échec ou Compensation de cette transaction. Si vous n'activez pas cette case à cocher, vous pouvez créer des processus En cas d'échec et Compensation, mais ils ne s'exécuteront pas lors de l'exécution de la planification XLANG.

  • Le paramètre Transaction, dans le nom de la page, est remplacé par le nom de la transaction à laquelle le processus de gestion d'erreur est associé.

  • Les types de transaction sont indiqués par les couleurs suivantes :
    • Bleu. Indique des transactions minutées.

    • Beige. Indique des transactions longues.

    • Gris. Indique des transactions courtes, de style DTC.

Voir aussi

Conception de transactions imbriquées

Actions et flux de groupe d'une transaction

Gestion des exceptions


Activation de la gestion d'erreur de composant

Cette section traite des procédures suivantes :

  • Abandon d'une transaction si un composant renvoie un échec

  • Abandon d'une transaction si un composant de script Windows renvoie un échec

Voir aussi

Abandon d'un flux de processus

Gestion des exceptions


Abandon d'une transaction si un composant renvoie un échec

La prise en charge de transaction pour les composants COM est définie dans l'Assistant Liaison de composants COM.

  1. Ouvrez l'Assistant Liaison de composants COM.

    Pour plus d'informations sur cet Assistant, voir Implémentation d'un port en utilisant un composant COM.

  2. Suivez les instructions de l'Assistant jusqu'à la page Propriétés avancées du port.

  3. Dans la zone Gestion d'erreur de la page Propriétés avancées du port, activez la case à cocher Abandonner la transaction si la méthode renvoie un HRESULT d'échec.

Important

  • Cette option détermine si les transactions dans lesquelles le composant est utilisé doivent être abandonnées lorsque des appels de méthodes sur le composant renvoient un échec de HRESULT.

    Cette option ne peut être définie que si l'action de communication utilisant ce port se trouve dans un flux de processus d'une transaction.

Voir aussi

Abandon d'une transaction si un composant de script Windows renvoie un échec

Ajout d'un port lié à un schéma de planification XLANG

Gestion des exceptions

Implémentation d'un port en utilisant un composant COM

Modification des propriétés d'implémentation d'un port

Définition de la propriété d'activation de la transaction

Définition du modèle de transaction


Abandon d'une transaction si un composant de script Windows renvoie un échec

La prise en charge des transactions pour les composants de script Windows est définie dans l'Assistant Liaison de composants de script.

  1. Ouvrez l'Assistant Liaison de composants de script.

    Pour plus d'informations sur cet Assistant, voir Implémentation d'un port en utilisant un composant de script Windows.

  2. Suivez les instructions de l'Assistant jusqu'à la page Propriétés avancées du port.

  3. Dans la zone Gestion d'erreur de la page Propriétés avancées du port, activez la case à cocher Abandonner la transaction si la méthode renvoie un HRESULT d'échec.

Important

  • Cette option détermine si les transactions dans lesquelles le composant est utilisé doivent être abandonnées lorsque des appels de méthodes sur le composant renvoient un échec de HRESULT.

    Cette option ne peut être définie que si l'action de communication utilisant ce port se trouve dans un flux de processus d'une transaction.

Voir aussi

Abandon d'une transaction si un composant renvoie un échec

Ajout d'un port lié à un schéma de planification XLANG

Gestion des exceptions

Implémentation d'un port en utilisant un composant de script Windows

Modification des propriétés d'implémentation d'un port

Définition de la propriété d'activation de la transaction

Définition du modèle de transaction


Implémentation de ports

Le Concepteur d'Orchestration BizTalk intègre quatre formes Implémentation qui représentent les technologies pouvant être utilisées pour implémenter les communications des ports. Ces formes sont présentées au tableau suivant.

Nom de la forme | Description
Composant COM | La forme Composant COM représente une technologie pouvant être utilisée pour implémenter un port en ayant recours à un appel de méthode pour chaque message envoyé ou reçu. Faites glisser cette forme du côté droit de la barre de séparation pour ouvrir l'Assistant Liaison de composants COM.
Composant de script Composant de script | La forme Composant de script représente une technologie pouvant être utilisée pour implémenter un port en ayant recours à un appel de méthode pour chaque message envoyé ou reçu. Faites glisser cette forme du côté droit de la barre de séparation pour ouvrir l'Assistant Liaison des composants de script.
Message Queuing | La forme Message Queuing représente une technologie pouvant être utilisée pour implémenter un port. Les services Message Queuing sont utilisés pour envoyer ou recevoir des messages. Faites glisser cette forme du côté droit de la barre de séparation pour ouvrir l'Assistant Liaison de Message Queuing.
Échanges BizTalk | La forme Échanges BizTalk représente une technologie pouvant être utilisée pour implémenter un port. Les services d'échanges BizTalk sont utilisés pour envoyer ou recevoir des messages. Un port d'échanges ou un canal BizTalk Server peut être utilisé pour implémenter un port. Faites glisser cette forme du côté droit de la barre de séparation pour ouvrir l'Assistant Liaison d'Échanges BizTalk.

Cette section traite des procédures suivantes :

  • Ajout d'un port non lié à un schéma de planification XLANG

  • Ajout d'un port lié à un schéma de planification XLANG

  • Implémentation d'un port en utilisant un composant COM

  • Implémentation d'un port en utilisant un composant de script Windows

  • Implémentation d'un port à l'aide de Message Queuing

  • Implémentation d'un port à l'aide d'Échanges BizTalk

  • Modification des propriétés d'implémentation d'un port

Voir aussi

Formes Communication

Formes Diagramme de flux

Formes Implémentation

Implémentation de processus professionnels

Correspondance entre un message et un port spécifiques

Envoi ou réception de messages

Description des implémentations de ports

Utilisation de l'Assistant Communication de méthodes

Utilisation de l'Assistant Communication XML


Ajout d'un port non lié à un schéma de planification XLANG

  • Dans une page de conception du Concepteur d'Orchestration BizTalk, cliquez avec le bouton droit sur la barre de séparation, puis cliquez sur Ajouter un nouveau port.

Remarques

  • Vous pouvez ajouter un port aux pages Processus professionnels, Compensation pour Transaction et En cas d'échec de Transaction. Les ports ne sont pas disponibles dans la page Données.

  • Vous ne pouvez pas ajouter de formes à la page Données. Une référence de port est créée automatiquement dans la page Données lorsque vous créez un nouveau port.

  • Vous pouvez implémenter un port non lié à l'aide de Message Queuing ou d'Échanges BizTalk. Lorsque vous ajoutez l'une de ces implémentations à une page, l'Assistant Implémentation fournit l'option permettant de sélectionner les ports non liés disponibles.

Voir aussi

Implémentation d'un port en utilisant un composant COM

Implémentation d'un port en utilisant un composant de script Windows

Implémentation d'un port à l'aide d'Échanges BizTalk

Implémentation d'un port à l'aide de Message Queuing

Correspondance entre un message et un port spécifiques

Modification des propriétés d'implémentation d'un port

Envoi ou réception de messages


Ajout d'un port lié à un schéma de planification XLANG

  • Dans une page de conception du Concepteur d'Orchestration BizTalk, faites glisser une forme Implémentation du stencil Implémentation vers le côté droit de la barre de séparation et suivez les étapes de l'Assistant relatives à cette implémentation.

Remarques

  • Vous pouvez ajouter un port aux pages Processus professionnels, Compensation pour Transaction et En cas d'échec de Transaction. Les ports ne sont pas disponibles dans la page Données.

  • Vous ne pouvez pas ajouter de formes à la page Données. Une référence de port est créée automatiquement dans la page Données lorsque vous créez un nouveau port.

Voir aussi

Implémentation d'un port en utilisant un composant COM

Implémentation d'un port en utilisant un composant de script Windows

Implémentation d'un port à l'aide d'Échanges BizTalk

Implémentation d'un port à l'aide de Message Queuing

Correspondance entre un message et un port spécifiques

Modification des propriétés d'implémentation d'un port

Envoi ou réception de messages


Implémentation d'un port en utilisant un composant COM

  1. Dans une page de conception du Concepteur d'Orchestration BizTalk, faites glisser une forme Composant COM d'un stencil Implémentation vers le côté droit de la barre de séparation.

    L'Assistant Liaison de composants COM s'ouvre.

  2. Dans la page Bienvenue dans l'Assistant de Liaison de composants COM, tapez un nom pour le port que vous voulez créer.

    Le Concepteur d'Orchestration BizTalk fournit par défaut un nom de port associé à un numéro pour chacune des nouvelles implémentations de port ajoutées. Vous pouvez modifier ce nom.

    Cliquez sur Suivant.

  3. Dans la page Communication statique ou dynamique, cliquez sur l'une des options suivantes :
    • Static

      Le moteur de XLANG Scheduler instancie ce composant.

      Si vous cliquez sur l'option Statique, le composant est automatiquement détruit à la fin de l'instance de planification XLANG.

      Cliquez sur Suivant. Passez à l'étape 4 de cette procédure.

    • Curseur dynamique

      Si vous sélectionnez cette option, une autre application instancie le composant. Un moniker ou un pointeur vers l'instance de l'objet doit être renvoyé à la planification XLANG en tant que champ d'un message. Sur la page Données, une connexion doit être établie entre ce champ de message et la référence du port utilisant cette implémentation. Pour plus d'informations sur l'envoi d'un message vers un port spécifique, voir Correspondance entre un message et un port spécifiques.

      Cliquez sur Suivant. Passez à l'étape 5 de cette procédure.

    • Aucune instantiation

      Sélectionnez cette option uniquement pour recevoir des données. Cette option indique que le transfert des données vers une planification XLANG est basé sur une méthode ; toutefois, le code sous-jacent de l'appel de la méthode ne sera pas exécuté. Pour plus d'informations, voir Gestion des données.

      Cliquez sur Suivant. Passez à l'étape 5 de cette procédure.

    Pour plus d'informations sur les communications statiques et dynamiques, consultez les rubriques suivantes :

    • Ports statiques et dynamiques

    • Gestion des instances

    • Utilisation de la forme composant de script
  4. Dans la page Informations sur les cours, cliquez sur l'une des options suivantes :
    • À partir d'un composant enregistré

      Un contrôle arborescent affiche tous les composants enregistrés sur votre ordinateur. Développez le dossier du cours approprié et cliquez sur le cours.

      Cliquez sur Suivant. Passez à l'étape 5 de cette procédure.

    • À partir d'un moniker

      Tapez le nom d'un moniker COM standard afin de spécifier l'emplacement du composant COM que vous voulez instancier. Si vous activez cette option, le composant COM ne peut pas être utilisé avec les communications internes d'une transaction dans la planification XLANG.

      Cliquez sur Suivant. Passez à l'étape 5 de cette procédure.

  5. Dans la page Informations d'interface, cliquez sur l'interface à utiliser.

    Cliquez sur Suivant. Passez à l'étape 6 de cette procédure.

    Remarques

    • Si un composant COM dispose d'une seule interface, cette page est ignorée.

    • Si le composant COM a été créé dans Microsoft Visual Basic, il existe une interface du même nom pour chaque cours du composant. Chaque nom d'interface est précédé d'un trait de soulignement (_).
  6. Dans la page Informations sur la méthode , sélectionnez les méthodes à utiliser.

    Cliquez sur Suivant. Passez à l'étape 7 de cette procédure.

    Remarques

    • Si un composant COM dispose d'une seule méthode, cette page est ignorée.

    • Vous devez sélectionner au moins une méthode.

    • Vous pouvez sélectionner plusieurs méthodes ou toutes les méthodes. Vous pouvez sélectionner ou désélectionner l'ensemble des méthodes à l'aide des boutons Sélectionner tout et Désélectionner tout.
  7. Dans la page Propriétés avancées du port, dans la zone Sécurité, cliquez sur l'une des options suivantes :
    • Non requise

      Aucune tentative pour confirmer l'identité de l'expéditeur.

    • Facultatif

      Le moteur de XLANG Scheduler requiert l'identité de l'expéditeur. L'exécution de la planification XLANG se poursuit, que l'identité soit disponible ou non.

    • Requis

      Le moteur de XLANG Scheduler requiert l'identité de l'expéditeur. L'identité de l'expéditeur est requise et la planification XLANG ignore le message si l'identité n'est pas disponible.

    Remarque

    • Si la planification XLANG rejette un appel de méthode entrant lorsque l'identité est requise mais non disponible, le code d'erreur E_ACCESSDENIED est renvoyé à l'appelant.
  8. Dans la zone Prise en charge des transactions de la page Propriétés avancées du port, cliquez sur l'une des options suivantes :
    • Désactivé

      La prise en charge des transactions pour le composant COM+ utilisé par cette implémentation de port est désactivée.

    • Non pris en charge

      Le composant COM+ utilisé par cette implémentation de port ne prend pas en charge les transactions.

    • Pris en charge

      Le composant COM+ utilisé par cette implémentation de port hérite d'une transaction existante.

    • Requis

      Le composant COM+ utilisé par cette implémentation de port peut hériter d'une transaction existante ou utiliser une nouvelle transaction.

    • Requiert une nouvelle

      Le composant COM+ utilisé par cette implémentation de port requiert une nouvelle transaction.

  9. Dans la page Propriétés avancées du port, dans la zone Prise en charge de la gestion des états cliquez sur l'une des options suivantes :
    • Ne possède pas d'état

      Le composant utilisé par cette implémentation de port ne possède pas d'état pour les appels de méthodes.

    • Possède un état mais ne prend pas en charge la persistance

      Le composant utilisé par cette implémentation de port possède un état pendant la durée de vie du composant, mais le composant ne peut pas être persistant.

    • Possède un état et prend en charge la persistance

      Le composant utilisé par cette implémentation de port possède un état et peut être enregistré à l'aide de l'interface IPersistStream ou IPersistStreamInit. L'interface IpersistStream ou IpersistStreamInit permet d'enregistrer l'état du composant pour des instanciations ultérieures et de recréer le composant à l'aide de cet état enregistré.

  10. Dans la zone Gestion d'erreur de la page Propriétés avancées du port, activez ou désactivez la case à cocher Abandonner la transaction si la méthode renvoie un HRESULT d'échec.

    Important

    • Cette option détermine si les transactions dans lesquelles le composant est utilisé doivent être abandonnées lorsque des appels de méthodes sur le composant renvoient un échec de HRESULT.

      Cette option peut uniquement être définie si l'action de communication utilisant ce port se trouve dans un flux de processus d'une transaction.

  11. Cliquez sur Terminer.

Remarques

  • Les noms de formes doivent répondre à certaines conventions d'affectation des noms. Les conventions suivantes s'appliquent aux transactions, ports, messages, règles et champs :
    • Le nom doit être un nom de jeton XML valide. Pour plus d'informations sur les jetons XML, accédez au site Web de W3C à l'adresse (www.w3.org).

    • Le nom ne peut pas commencer par des traits de soulignement (__).

    • Le nom ne peut pas comporter de caractères deux-points (:).

    • La longueur du nom doit être inférieure ou égale à 32 caractères.

    • Les noms de constante et de message ne peuvent pas commencer par un caractère numérique.
  • Vous pouvez ajouter des implémentations de port aux pages Processus professionnels, Compensation pour Transaction et En cas d'échec de Transaction. Les implémentations de port ne sont pas disponibles dans la page Données.

  • Vous ne pouvez pas ajouter de formes à la page Données. Une référence de port est créée automatiquement dans la page Données lorsque vous créez un nouveau port.

  • Un nouveau port est toujours créé afin d'être utilisé avec une implémentation de composants COM.

  • Si vous modifiez une implémentation de port existante, sur la première page de l'Assistant Implémentation, vous pouvez renommer le port à l'aide de l'option Renommer le port actuel.

Voir aussi

Implémentation d'un port en utilisant un composant de script Windows

Implémentation d'un port à l'aide d'Échanges BizTalk

Implémentation d'un port à l'aide de Message Queuing

Formes Implémentation

Implémentation de processus professionnels

Correspondance entre un message et un port spécifiques

Modification des propriétés d'implémentation d'un port

Description des implémentations de ports

Utilisation de la forme Composant COM

Utilisation de l'Assistant Communication de méthodes


Implémentation d'un port en utilisant un composant de script Windows

  1. Dans une page de conception du Concepteur d'Orchestration BizTalk, faites glisser une forme Composant de script d'un stencil Implémentation vers le côté droit de la barre de séparation.

    L'Assistant Liaison des composants de script s'ouvre.

  2. Dans la page Assistant Liaison de composants de script, tapez un nom pour le port que vous voulez créer.

    Le Concepteur d'Orchestration BizTalk fournit par défaut un nom de port associé à un numéro pour chacune des nouvelles implémentations de port ajoutées. Vous pouvez modifier ce nom.

    Cliquez sur Suivant. Passez à l'étape 3 de cette procédure.

  3. Dans la page Communication statique ou dynamique, cliquez sur l'une des options suivantes :
    • Static

      Le moteur de XLANG Scheduler instancie ce composant.

      Si vous cliquez sur l'option Statique, le composant est automatiquement détruit à la fin de l'instance de planification XLANG.

      Cliquez sur Suivant. Passez à l'étape 4 de cette procédure.

    • Curseur dynamique

      Si vous sélectionnez cette option, une autre application instancie le composant. Un moniker ou un pointeur vers l'instance de l'objet doit être renvoyé à la planification XLANG en tant que champ d'un message. Sur la page Données, une connexion doit être établie entre ce champ de message et la référence du port utilisant cette implémentation. Pour plus d'informations sur l'envoi d'un message vers un port spécifique, voir Correspondance entre un message et un port spécifiques.

      Cliquez sur Suivant. Passez à l'étape 4 de cette procédure.

    • Aucune instantiation

      Sélectionnez cette option uniquement pour recevoir des données. Cette option indique que le transfert des données vers une planification XLANG est basé sur une méthode ; toutefois, le code sous-jacent de l'appel de la méthode ne sera pas exécuté.

      Cliquez sur Suivant. Passez à l'étape 4 de cette procédure.

    Pour plus d'informations sur les communications statiques et dynamiques, consultez les rubriques suivantes :

    • Ports statiques et dynamiques

    • Gestion des instances

    • Utilisation de la forme composant de script
  4. Sur la page Sélectionnez le fichier de script, cliquez sur Parcourir.

  5. Dans la boîte de dialogue Sélectionner un fichier de script, recherchez l'emplacement du fichier .wsc que vous voulez utiliser, sélectionnez-le, puis cliquez sur Ouvrir.

    Cliquez sur Suivant, et pour continuer procédez comme suit :

    • Si vous avez sélectionné Statique à l'étape 3, passez à l'étape 6 de cette procédure.

    • Si vous avez sélectionné Dynamique ou Aucune instanciation à l'étape 3, passez à l'étape 7 de cette procédure.
  6. Dans la page Informations sur l'instanciation du composant, cliquez sur l'une des options suivantes :
    • Utiliser un moniker du fichier de script

      Le chemin d'accès et le nom du fichier de script sont automatiquement fournis comme moniker.

      Cliquez sur Suivant. Passez à l'étape 7 de cette procédure.

    • Utiliser Prog ID "Prog ID"

      Le Prog ID est fourni automatiquement. Il est extrait du composant XML dans le fichier de composants de script Windows. Cette option est recommandée car le chemin d'accès au fichier de script n'est pas codé en dur.

      Cliquez sur Suivant. Passez à l'étape 7 de cette procédure.

  7. Dans la page Informations sur la méthode , sélectionnez les méthodes à utiliser.

    Cliquez sur Suivant. Passez à l'étape 8 de cette procédure.

    Remarques

    • Si un composant de script Windows dispose d'une seule méthode, cette page est ignorée.

    • Vous devez sélectionner au moins une méthode.

    • Vous pouvez sélectionner plusieurs méthodes ou toutes les méthodes. Vous pouvez sélectionner ou désélectionner l'ensemble des méthodes à l'aide des boutons Sélectionner tout et Désélectionner tout.
  8. Dans la page Propriétés avancées du port, dans la zone Sécurité, cliquez sur l'une des options suivantes :
    • Non requise

      Aucune tentative pour confirmer l'identité de l'expéditeur.

    • Facultatif

      Le moteur de XLANG Scheduler requiert l'identité de l'expéditeur. L'exécution de la planification XLANG se poursuit, que l'identité soit disponible ou non.

    • Requis

      Le moteur de XLANG Scheduler requiert l'identité de l'expéditeur. L'identité de l'expéditeur est requise et la planification XLANG ignore le message si l'identité n'est pas disponible.

    Remarque

    • Si la planification XLANG rejette un appel de méthode entrant lorsque l'identité est requise mais non disponible, le code d'erreur E_ACCESSDENIED est renvoyé à l'appelant.
  9. Dans la zone Prise en charge des transactions de la page Propriétés avancées du port, cliquez sur l'une des options suivantes :
    • Désactivé

      La prise en charge des transactions pour le composant COM+ utilisé par cette implémentation de port est désactivée.

    • Non pris en charge

      Le composant COM+ utilisé par cette implémentation de port ne prend pas en charge les transactions.

    • Pris en charge

      Le composant COM+ utilisé par cette implémentation de port hérite d'une transaction existante.

    • Requis

      Le composant COM+ utilisé par cette implémentation de port peut hériter d'une transaction existante ou utiliser une nouvelle transaction.

    • Requiert une nouvelle

      Le composant COM+ utilisé par cette implémentation de port requiert une nouvelle transaction.

  10. Dans la zone Gestion d'erreur de la page Propriétés avancées du port, activez ou désactivez la case à cocher Abandonner la transaction si la méthode renvoie un HRESULT d'échec.

    Important

    • Cette option détermine si les transactions dans lesquelles le composant est utilisé doivent être abandonnées lorsque des appels de méthodes sur le composant renvoient un échec de HRESULT.

      Cette option peut uniquement être définie si l'action de communication utilisant ce port se trouve dans un flux de processus d'une transaction.

  11. Cliquez sur Terminer.

Important

  • Lorsque vous utilisez des composants de script Windows, ils doivent respecter les règles suivantes :
    • Les déclarations d'arguments doivent être classées par référence et non par valeur.

    • Les sous-routines de script Microsoft Visual Basic ne sont pas prises en charge. Seules les fonctions sont prises en charge.

    • Vous ne pouvez pas utiliser plusieurs composants dans un seul fichier .wsc.

Remarques

  • Les noms de formes doivent répondre à certaines conventions d'affectation des noms. Les conventions suivantes s'appliquent aux transactions, ports, messages, règles et champs :
    • Le nom doit être un nom de jeton XML valide. Pour plus d'informations sur les jetons XML, accédez au site Web de W3C à l'adresse (www.w3.org).

    • Le nom ne peut pas commencer par des traits de soulignement (__).

    • Le nom ne peut pas comporter de caractères deux-points (:).

    • La longueur du nom doit être inférieure ou égale à 32 caractères.

    • Les noms de constante et de message ne peuvent pas commencer par un caractère numérique.
  • Vous pouvez ajouter des implémentations de port aux pages Processus professionnels, Compensation pour Transaction et En cas d'échec de Transaction. Les implémentations de port ne sont pas disponibles dans la page Données.

  • Vous ne pouvez pas ajouter de formes à la page Données. Une référence de port est créée automatiquement dans la page Données lorsque vous créez un nouveau port.

  • Un nouveau port est toujours créé afin d'être utilisé avec une implémentation des composants de script Windows.

  • Si vous modifiez une implémentation de port existante, sur la première page de l'Assistant Implémentation, vous pouvez renommer le port à l'aide de l'option Renommer le port actuel.

  • Les fichiers de composants de script Windows ont l'extension .wsc. Pour plus d'informations sur les composants de script Windows, visitez le site Web des Technologies Microsoft Scripting à l'adresse (msdn.microsoft.com/france/scripting/default.htm) et accédez à la page Windows Script Components.

  • Les composants de script Windows qui ont été exécutés par le moteur de XLANG ne peuvent pas être modifiés tant que le moteur de XLANG Scheduler et Windows Scripting Host ne sont pas arrêtés.

Voir aussi

Implémentation d'un port en utilisant un composant COM

Implémentation d'un port à l'aide d'Échanges BizTalk

Implémentation d'un port à l'aide de Message Queuing

Formes Implémentation

Implémentation de processus professionnels

Correspondance entre un message et un port spécifiques

Modification des propriétés d'implémentation d'un port

Description des implémentations de ports

Utilisation de la forme composant de script

Utilisation de l'Assistant Communication de méthodes


Implémentation d'un port à l'aide de Message Queuing

  1. Dans une page de conception du Concepteur d'Orchestration BizTalk, faites glisser une forme Message Queuing d'un stencil Implémentation vers le côté droit de la barre de séparation.

    L'Assistant Liaison de Message Queuing s'ouvre.

  2. Dans la page Assistant Liaison de Message Queuing, cliquez sur l'une des options suivantes :
    • Créer un port

      Le Concepteur d'Orchestration BizTalk fournit par défaut un nom de port associé à un numéro pour chacune des nouvelles implémentations de port ajoutées. Vous pouvez modifier ce nom.

      Cliquez sur Suivant. Passez à l'étape 3 de cette procédure.

    • Port non lié existant

      Dans la liste Port non lié existant, sélectionnez le port à utiliser.

      Seuls les noms des ports non liés existants s'affichent dans la liste Port non lié existant. Aucune implémentation n'est définie pour un port non lié.

      Cliquez sur Suivant. Passez à l'étape 3 de cette procédure.

  3. Dans la page informations sur la file d'attente statique ou dynamique, cliquez sur l'une des options suivantes :
    • File d'attente statique

      Une file d'attente statique est une file d'attente connue préexistante. Cette file d'attente doit être connue au moment de la conception.

      Cliquez sur Suivant. Passez à l'étape 4 de cette procédure.

    • File d'attente dynamique

      Si cette option est sélectionnée, sur la page Données, vous devez créer une liaison allant d'un champ de message à la référence du port.

      Le nom de la file d'attente des messages doit être transmis par un autre message avant l'action de communication qui doit être exécutée par cette implémentation de port. Pour plus d'informations sur la correspondance entre un message et un port spécifiques, voir Correspondance entre un message et un port spécifiques.

      Cliquez sur Suivant. Passez à l'étape 5 de cette procédure.

    Pour plus d'informations sur les files d'attente statiques et dynamiques, voir Ports statiques et dynamiques.

  4. Dans la page Informations sur la file d'attente, cliquez sur l'une des options suivantes :
    • Créer une nouvelle file d'attente pour chaque instance

      Vous devez affecter un préfixe à la file d'attente. Exemple : ".\Private$\PrivateQueuePrefix" ou ".\PublicQueuePrefix". Un identificateur unique sera ajouté au préfixe de chaque nouvelle file d'attente créée.

      Un préfixe de file d'attente est affecté par défaut. Vous pouvez modifier cette valeur.

      Si vous voulez autoriser les réponses sur ce port, les références du port doivent être transmises dans un message. Pour ce faire, sélectionnez Créer une nouvelle file d'attente pour chaque instance et entrez le nom de la file d'attente racine. Au moment de l'exécution, le moteur de XLANG Scheduler crée une nouvelle file d'attente avec ce nom de file d'attente racine pour chaque instance, et un identificateur unique universel est ajouté au nom racine pour chaque file d'attente créée. Cette file d'attente est supprimée lorsque l'instance est terminée.

      Si vous ne prévoyez pas d'envoyer les références de ce port, une file d'attente par instance n'est pas nécessaire. Vous pouvez créer une file d'attente qui sera utilisée par toutes les instances.

      Cliquez sur Suivant. Passez à l'étape 5 de cette procédure.

    • Utiliser une file d'attente connue pour toutes les instances

      Entrez le nom d'une file d'attente préexistante connue. Exemple : ".\private$\queuename".

      Cliquez sur Suivant. Passez à l'étape 5 de cette procédure.

  5. Dans la page Propriétés avancées du port, dans la zone Sécurité, cliquez sur l'une des options suivantes :
    • Non requise

      Aucune tentative pour confirmer l'identité de l'expéditeur. La planification XLANG reçoit toujours le message avec un champ __Émetteur__ vide, que le message soit authentifié ou non.

    • Facultatif

      Le moteur de XLANG Scheduler envoie une requête pour obtenir la confirmation de l'identité de l'expéditeur. La planification XLANG reçoit le message, qu'il soit authentifié ou non. Si le message est authentifié, le champ __Émetteur__ contient la propriété SenderID du message de Message Queuing.

    • Requis

      Le moteur de XLANG Scheduler envoie une requête pour obtenir la confirmation de l'identité de l'expéditeur. L'identité de l'expéditeur doit être confirmée. Si le message est authentifié, la planification XLANG reçoit le message et le champ __Émetteur__ contient la propriété SenderID du message de Message Queuing.

      Si le message n'est pas authentifié, un journal d'événements de l'application est créé, et le message est déplacé vers une nouvelle file d'attente nommée .\private$\ApplicationName.DeadLetter.

  6. Dans la zone Sécurité de la page Propriétés avancées du port, activez ou désactivez la case à cocher Utiliser un groupe Windows ou un nom d'utilisateur pour contrôler la file d'attente.

    Si vous activez cette case à cocher, tapez le nom de l'utilisateur ou du groupe autorisé à écrire des messages dans la file d'attente. Cette option est disponible uniquement lorsque vous utilisez une file d'attente statique.

  7. Dans la zone Prise en charge de la transaction de la page Propriétés avancées du port, activez ou désactivez la case à cocher Des transactions sont requises avec cette file d'attente.

  8. Cliquez sur Terminer.

Remarques

  • Les noms de formes doivent répondre à certaines conventions d'affectation des noms. Les conventions suivantes s'appliquent aux transactions, ports, messages, règles et champs :
    • Le nom doit être un nom de jeton XML valide. Pour plus d'informations sur les jetons XML, accédez au site Web de W3C à l'adresse (www.w3.org).

    • Le nom ne peut pas commencer par des traits de soulignement (__).

    • Le nom ne peut pas comporter de caractères deux-points (:).

    • La longueur du nom doit être inférieure ou égale à 32 caractères.

    • Les noms de constante et de message ne peuvent pas commencer par un caractère numérique.
  • Vous pouvez ajouter des implémentations de port aux pages Processus professionnels, Compensation pour Transaction et En cas d'échec de Transaction. Les implémentations de port ne sont pas disponibles dans la page Données.

  • Vous ne pouvez pas ajouter de formes à la page Données. Une référence de port est créée automatiquement dans la page Données lorsque vous créez un nouveau port.

  • Si vous modifiez une implémentation de port existante, sur la première page de l'Assistant Implémentation, vous pouvez renommer le port à l'aide de l'option Renommer le port actuel.

Voir aussi

Implémentation d'un port en utilisant un composant COM

Implémentation d'un port en utilisant un composant de script Windows

Implémentation d'un port à l'aide d'Échanges BizTalk

Formes Implémentation

Implémentation de processus professionnels

Correspondance entre un message et un port spécifiques

Modification des propriétés d'implémentation d'un port

Description des implémentations de ports

Utilisation de la forme Message Queuing

Utilisation de l'Assistant Communication XML


Implémentation d'un port à l'aide d'Échanges BizTalk

  1. Dans une page de conception du Concepteur d'Orchestration BizTalk, faites glisser une forme Échanges BizTalk d'un stencil Implémentation vers le côté droit de la barre de séparation.

    L'Assistant Liaison d'Échanges BizTalk s'ouvre.

  2. Sur la page Assistant Liaison d'Échanges BizTalk, cliquez sur l'une des options suivantes :
    • Créer un port

      Le Concepteur d'Orchestration BizTalk fournit par défaut un nom de port associé à un numéro pour chacune des nouvelles implémentations de port ajoutées. Vous pouvez modifier ce nom.

      Cliquez sur Suivant. Passez à l'étape 3 de cette procédure.

    • Port non lié existant

      Dans la liste Port non lié existant, sélectionnez le port à utiliser.

      Seuls les noms des ports non liés existants s'affichent dans la liste Port non lié existant. Aucune implémentation n'est définie pour un port non lié.

      Cliquez sur Suivant. Passez à l'étape 3 de cette procédure.

  3. Dans la page Direction de la communication, cliquez sur l'une des options suivantes :
    • Envoi

      Cliquez sur Suivant. Passez à l'étape 4 de cette procédure.

    • Réception

      Cliquez sur Suivant. Passez à l'étape 5 de cette procédure.

    Remarque

    • Si vous sélectionnez Recevoir, les messages peuvent uniquement être reçus en utilisant une destination d'URL http ou le Gestionnaire d'échanges BizTalk afin de configurer un port d'échanges pour instancier une planification XLANG et envoyer des messages à un port spécifique de cette planification. Pour plus d'informations sur la réception de messages à l'aide d'une URL http, voir Intégration des services BizTalk. Pour plus d'informations sur l'utilisation du Gestionnaire d'échanges BizTalk pour configurer un port d'échanges, voir Définition des propriétés d'une application de destination.
  4. Dans la page Informations sur le canal statique ou dynamique, cliquez sur l'une des options suivantes :
    • Canal statique

      Entrez le nom d'un canal connu préexistant. Cliquez sur Terminer.

    • Canal dynamique

      Si vous sélectionnez cette option, vous devez configurer le port de façon à fournir les données dont les services d'échanges BizTalk ont besoin au moment de l'exécution pour identifier le canal correct en vue du traitement du message.

      Sur la page Données, vous devez créer une liaison allant du champ de message d'un message précédemment reçu à la référence de port de ce port. Le champ de message doit contenir une adresse de destination que les services d'échanges BizTalk utilisent comme adresse de destination d'un port d'échanges ouvert associé à ce canal. Pour plus d'informations, voir Mappages pour l'intégration des services BizTalk.

      Lorsque vous créez le flux de communication allant d'une action à ce port, vous utilisez l'Assistant de communication XML. Dans la zone Type du message de la page Informations sur les types de messages, vous devez taper le nom de la définition du document entrant de ce canal. Ces données permettent aux services d'échanges BizTalk d'identifier le canal correct pour traiter le message. Pour plus d'informations, voir Identification.

      Cliquez sur Terminer.

    Important

    • Au moins un canal utilisant la définition de document entrante spécifiée doit être configuré dans les services d'échanges BizTalk. Lorsqu'une action communique avec un port lié à Échanges BizTalk et que le canal spécifié pour la liaison n'existe pas, l'instance de planification XLANG échoue avec une entrée de journal d'événements.

    • Au moins un canal utilisant la définition de document entrante spécifiée et configuré avec la planification XLANG comme source doit être configuré dans les services d'échanges BizTalk. Pour plus d'informations, voir Définition des propriétés d'une application source. Ce canal doit être associé à un port d'échanges ouvert. Lorsqu'une action communique avec un port lié à Échanges BizTalk et que plusieurs canaux spécifiés pour la liaison existent, l'instance de planification XLANG échoue avec une entrée de journal d'événements.
  5. Dans la page Informations sur l'activation de la planification XLANG, cliquez sur l'une des options suivantes :
    • Oui

      Ce port ne peut pas être utilisé dans plusieurs actions de réception ni dans une action de réception unique d'une boucle.

      Cliquez sur Terminer.

    • Non

      Cliquez sur Suivant. Passez à l'étape 6 de cette procédure.

  6. Dans la zone Nom du canal de la page Informations sur le canal, tapez le nom du canal que vous voulez utiliser. Pour plus d'informations sur les canaux, voir Description des canaux et Recherche de canaux.

  7. Dans la zone Adresse de l'URL http dans laquelle le service d'Échanges BizTalk reçoit les documents de la page Informations sur le canal, tapez l'adresse de l'URL à partir de laquelle BizTalk Server reçoit les documents pour ***ici***ce canal.

  8. Cliquez sur Terminer.

Important

  • Si vous configurez un port afin d'activer une nouvelle planification XLANG lorsqu'un message arrive, vous devez respecter les restrictions suivantes :
    • Dans une planification, un seul port peut être utilisé afin d'activer la planification lorsque le message arrive.

    • Une seule action peut recevoir via ce port.

    • Cette action unique ne peut pas se trouver dans le corps d'une boucle.

    • Vous ne pouvez pas dessiner une connexion de flux de données des références d'un port vers un autre message de la planification.

Remarques

  • Les noms de formes doivent répondre à certaines conventions d'affectation des noms. Les conventions suivantes s'appliquent aux transactions, ports, messages, règles et champs :
    • Le nom doit être un nom de jeton XML valide. Pour plus d'informations sur les jetons XML, accédez au site Web de W3C à l'adresse (www.w3.org).

    • Le nom ne peut pas commencer par des traits de soulignement (__).

    • Le nom ne peut pas comporter de caractères deux-points (:).

    • La longueur du nom doit être inférieure ou égale à 32 caractères.

    • Les noms de constante et de message ne peuvent pas commencer par un caractère numérique.
  • Vous pouvez ajouter des implémentations de port aux pages Processus professionnels, Compensation pour Transaction et En cas d'échec de Transaction. Les implémentations de port ne sont pas disponibles dans la page Données.

  • Vous ne pouvez pas ajouter de formes à la page Données. Une référence de port est créée automatiquement dans la page Données lorsque vous créez un nouveau port.

  • Si vous modifiez une implémentation de port existante, sur la première page de l'Assistant Implémentation, vous pouvez renommer le port à l'aide de l'option Renommer le port actuel.

Voir aussi

Implémentation d'un port en utilisant un composant COM

Implémentation d'un port en utilisant un composant de script Windows

Implémentation d'un port à l'aide de Message Queuing

Formes Implémentation

Implémentation de processus professionnels

Intégration des services BizTalk

Correspondance entre un message et un port spécifiques

Modification des propriétés d'implémentation d'un port

Recherche de canaux

Description des canaux

Description des implémentations de ports

Utilisation de la forme Échanges BizTalk

Utilisation de l'Assistant Communication XML


Modification des propriétés d'implémentation d'un port

  1. Dans une page de conception du Concepteur d'Orchestration BizTalk, cliquez sur la forme Implémentation que vous voulez modifier.

  2. Cliquez sur Propriétés.

    L'Assistant de cette forme Implémentation s'ouvre.

  3. Suivez les étapes de l'Assistant et changez les propriétés que vous voulez modifier.

Remarques

  • Vous pouvez modifier des implémentations de port dans les pages Processus professionnels, Compensation pour Transaction et En cas d'échec de Transaction. Les implémentations de port ne sont pas disponibles dans la page Données.

  • Vous ne pouvez pas ajouter de formes à la page Données. Une référence de port est créée automatiquement dans la page Données lorsque vous créez un nouveau port.

  • Sur la première page de l'Assistant Implémentation, l'option Renommer le port actuel vous permet d'affecter un nouveau nom au port.

Voir aussi

Implémentation d'un port en utilisant un composant COM

Implémentation d'un port en utilisant un composant de script Windows

Implémentation d'un port à l'aide d'Échanges BizTalk

Implémentation d'un port à l'aide de Message Queuing

Formes Implémentation

Implémentation de processus professionnels


Envoi ou réception de messages

Le Concepteur d'Orchestration BizTalk intègre deux formes de communication qui permettent à la planification XLANG d'envoyer ou de recevoir des messages :

  • Communication synchrone. Les appels de méthode permettent d'envoyer ou de recevoir des paires de messages synchrones.

  • Communication asynchrone. Les messages XML permettent d'envoyer ou de recevoir des messages asynchrones.

Pour plus d'informations, voir Communication synchrone et asynchrone.

Cette section traite des procédures suivantes :

  • Établissement du flux de communication entre une action et un port

  • Envoi et réception de messages synchrones

  • Envoi ou réception de messages asynchrones

  • Modification du flux de communication entre une action et un port

Voir aussi

Communication synchrone et asynchrone

Utilisation de l'Assistant Communication de méthodes

Utilisation de l'Assistant Communication XML


Établissement du flux de communication entre une action et un port

  1. Dans une page de conception du Concepteur d'Orchestration BizTalk, cliquez sur une forme Action pour la sélectionner

  2. Connectez la poignée de contrôle droite de la forme ( Poignée de contrôle) Action au point de connexion d'une forme ( Point de connexion) Port.

    Un Assistant Communication s'ouvre.

  3. Passez à l'une des procédures suivantes, en fonction du type de flux de communication que vous voulez créer.
    • Si vous voulez créer un flux de communication synchrone avec un port qui utilise une implémentation de composants COM ou de composants de script, vous devez utiliser l'Assistant Communication de méthodes. Passez à Envoi ou réception de messages synchrones.

    • Si vous voulez créer un flux de communication asynchrone vers un port utilisant l'implémentation de Message Queuing ou Échanges BizTalk ou un flux de communication asynchrone vers un port non lié, vous devez utiliser l'Assistant Communication XML. Passez à Envoi ou réception de messages asynchrones.

Remarques

  • Vous pouvez également utiliser l'outil de connexion pour connecter les formes. Pour plus d'informations, voir Utilisation de l'outil de connexion.

  • Vous pouvez établir un flux de communication entre une action et un port dans les pages Processus professionnels, Compensation pour Transaction et En cas d'échec de Transaction. Les actions et les ports ne sont pas disponibles dans la page Données.

  • Vous ne pouvez pas ajouter de formes à la page Données. Les nouveaux messages sont créés automatiquement sur la page Données chaque fois qu'une action est connectée à un port.


Envoi et réception de messages synchrones

L'Assistant Communication de méthodes s'ouvre dans le Concepteur d'Orchestration BizTalk, lorsque vous avez créé un flux de communication entre une action et un port pour une communication synchrone. Pour plus d'informations sur la création d'un flux de communication, voir Établissement d'un flux de communication entre une action et un port.

  1. Sur la page Assistant Communication de méthodes, cliquez sur l'une des options suivantes :
    • Lancer un appel de méthode synchrone

      Le moteur de XLANG Scheduler lance un appel de méthode synchrone.

      Dans ce cas, le moteur de XLANG Scheduler envoie un appel de méthode à un composant, attend la réponse du composant, puis reçoit la réponse.

      Cliquez sur Suivant. Passez à l'étape 3 de cette procédure.

    • Attendre un appel de méthode synchrone

      Le moteur de XLANG Scheduler attend de recevoir un appel de méthode lancé par une autre application.

      Dans ce cas, le moteur de XLANG Scheduler attend qu'une autre application lance l'appel de méthode. Cette application distincte envoie un appel de méthode à un composant ; le moteur de XLANG Scheduler attend une réponse du composant puis renvoie une réponse à une application. La planification XLANG intercepte la requête et la réponse de la méthode.

      Passez à l'étape 2 de cette procédure.

  2. Sur la page Assistant Communication de méthodes, afin d'optimiser l'exécution d'une planification XLANG, entrez le délai (en secondes) pendant lequel le moteur de XLANG Scheduler devra attendre avant de recevoir un message.

    La valeur par défaut du délai d'attente est 0 seconde. Vous pouvez modifier cette valeur. Une valeur inférieure ou égale à 180 secondes fait que la planification XLANG n'est jamais mise en attente. Toute valeur supérieure à 180 secondes entraîne la réalimentation immédiate de la planification XLANG. Pour plus d'informations sur les délais d'attente et la réalimentation de la planification XLANG, voir Mise en attente et réalimentation et Utilisation de l'Assistant Communication de méthodes.

    Cliquez sur Suivant. Passez à l'étape 3 de cette procédure.

  3. Dans la page Informations sur le message, cliquez sur l'une des options suivantes :
    • Créer un message

      Le nom de ce message est déterminé automatiquement à l'aide de la méthode sélectionnée sur la page suivante de l'Assistant. Le flux de données correspondant à un nouveau message doit être connecté aux autres messages de la page Données.

      Cliquez sur Suivant. Passez à l'étape 4 de cette procédure.

    • Ajouter une référence à une paire de messages synchrones existante

      Une référence à une paire de messages précédemment configurée est ajoutée au flux de communication. Ces paires de messages peuvent uniquement être réutilisées dans le même port. Elles ne peuvent pas être utilisées par une autre implémentation du port.

      Cliquez sur Terminer.

  4. Dans la liste Méthodes de la page Informations sur la spécification du message, cliquez sur la méthode que vous voulez utiliser. Vous ne pouvez sélectionner qu'une seule méthode dans la liste.

    La méthode sélectionnée définie les messages du flux de communication. Les paramètres IN et OUT sont déterminés automatiquement par les spécifications des paramètres de la méthode choisie. Les deux listes de paramètres contiennent le nom et le type de données des paramètres.

    Pour plus d'informations sur la définition des messages utilisés dans un flux de communication, voir Communication synchrone.

  5. Cliquez sur Terminer.

Remarques

  • Les noms de formes doivent répondre à certaines conventions d'affectation des noms. Les conventions suivantes s'appliquent aux transactions, ports, messages, règles et champs :
    • Le nom doit être un nom de jeton XML valide. Pour plus d'informations sur les jetons XML, accédez au site Web de W3C à l'adresse (www.w3.org).

    • Le nom ne peut pas commencer par des traits de soulignement (__).

    • Le nom ne peut pas comporter de caractères deux-points (:).

    • La longueur du nom doit être inférieure ou égale à 32 caractères.

    • Les noms de constante et de message ne peuvent pas commencer par un caractère numérique.
  • La propriété Délai d'attente n'est pas activée, sauf si vous cliquez sur Attendre un appel de méthode synchrone.

  • Les seules méthodes disponibles dans une communication synchrone sont celles sélectionnées pour l'implémentation du port. Ni les méthodes d'autres implémentations de ports, ni les messages XML de flux de communication asynchrone ne peuvent être utilisées. Pour modifier les méthodes disponibles, exécutez de nouveau l'Assistant Implémentation de port approprié et sélectionnez d'autres méthodes.

  • Lorsque vous créez une communication synchrone, un Message est créé dans la page Données. Le Message correspond à la méthode et aux paramètres utilisés dans le flux de communication. Le Message contient tous les paramètres IN et OUT pour la méthode.

    Il se peut qu'une méthode ne contienne aucun paramètre ; cependant, le Message contient toujours les champs système obligatoires. Pour plus d'informations sur la définition des messages utilisés dans un flux de communication synchrone, voir Communication synchrone.

Voir aussi

Mise en attente et réalimentation

Établissement du flux de communication entre une action et un port

Implémentation de ports

Envoi ou réception de messages asynchrones

Communication synchrone

Utilisation de l'Assistant Communication de méthodes

Utilisation de l'Assistant Communication XML


Envoi ou réception de messages asynchrones

  1. Sur la page Assistant Communication XML, cliquez sur l'une des options suivantes :
    • Envoyer

      Un message est envoyé de façon asynchrone.

      Cliquez sur Suivant. Passez à l'étape 3 de cette procédure.

    • Réception

      Le moteur de XLANG Scheduler attend de recevoir un message avant de continuer la planification XLANG.

      Passez à l'étape 2 de cette procédure.

  2. Sur la page Assistant de communication XML, afin d'optimiser l'exécution d'une planification XLANG, tapez la durée (en secondes) pendant laquelle le moteur de XLANG Scheduler doit attendre l'arrivée d'un message.

    La valeur par défaut du délai d'attente est 0 seconde. Vous pouvez modifier cette valeur. Une valeur inférieure ou égale à 180 secondes fait que la planification XLANG n'est jamais mise en attente. Toute valeur supérieure à 180 secondes entraîne la réalimentation immédiate de la planification XLANG. Pour plus d'informations sur les délais d'attente et la réalimentation de la planification XLANG, voir Mise en attente et réalimentation et Utilisation de l'Assistant Communication de méthodes.

    Cliquez sur Suivant. Passez à l'étape 3 de cette procédure.

  3. Dans la page Informations sur le message, cliquez sur l'une des options suivantes :
    • Créer un message

      Dans la zone Nom de message, entrez le nom du message. Un nom de message auquel est ajouté un nombre est proposé par défaut ; vous pouvez modifier ce nom.

      Le flux de données correspondant à un nouveau message doit être connecté aux autres messages de la page Données.

    • Ajouter une référence à un message existant

      Une référence à un message précédemment configuré est ajoutée au flux de communication.

    Cliquez sur Suivant, puis effectuez l'une des actions suivantes :

    • Si vous avez cliqué sur Envoyer dans la page Assistant Communication XML, passez à l'étape 4 de cette procédure.

    • Si vous avez cliqué sur Recevoir dans la page Assistant Communication XML, passez à l'étape 6 de cette procédure.
  4. Dans la page Informations sur l'interprétation XML, cliquez sur l'une des options suivantes :
    • Envoyer des messages XML à la file d'attente

    • Envoyer des messages à la file d'attente sous forme de chaîne

      Le moteur de XLANG Scheduler doit supprimer le wrapper XML standard de la chaîne.

    Les flux de données du moteur de XLANG Scheduler sont gérés avec XML. Le moteur envoie des messages XML en mode natif dans les files d'attente. Il peut aussi les envoyer sous forme de chaîne, à partir de laquelle le moteur doit supprimer son wrapper XML. Le flux de données doit fournir un message dans le format correct de cette spécification pour cette action.

    Si vous choisissez d'envoyer ou de recevoir un message XML en tant que chaîne, la forme Message créée dans la page Données pour ce message contient un champ nommé StringData, et vous ne pouvez pas ajouter de champs de spécification à ce message.

    Cliquez sur Suivant. Passez à l'étape 5 de cette procédure.

  5. Dans la zone Type du message de la page Informations sur les types de message, tapez une désignation d'étiquette pour le message.

    Le texte que vous tapez permet d'étiqueter le message lors de son envoi dans la file d'attente.

    Pour continuer, effectuez l'une des opérations suivantes :

    • Si, dans la page Informations sur l'interprétation XML vous avez cliqué sur Envoyer des messages XML à la file d'attente, cliquez sur Suivant. Passez à l'étape 8 de cette procédure.

    • Si, dans la page Informations sur l'interprétation XML vous avez cliqué sur Envoyer des messages à la file d'attente sous forme de chaîne, cliquez sur Terminer.
  6. Dans la page Informations sur l'interprétation XML, cliquez sur l'une des options suivantes :
    • Recevoir les messages XML de la file d'attente

    • Recevoir les messages de chaîne de la file d'attente

      Le moteur de XLANG Scheduler doit intégrer la chaîne dans le wrapper XML standard du moteur.

    Les flux de données du moteur de XLANG Scheduler sont gérés avec XML. Le moteur reçoit des messages XML provenant des files d'attente en mode natif. Il peut également recevoir un message sous forme d'une chaîne, qui sera ensuite transformée au format XML.

    Cliquez sur Suivant. Passez à l'étape 7 de cette procédure.

  7. Dans la zone Type du message de la page Informations sur les types de message, tapez une désignation d'étiquette pour le message.

    Le texte que vous tapez va permettre d'identifier les messages corrects reçus de la file d'attente.

    Tout d'abord, le moteur de XLANG Scheduler va tenter de faire correspondre les informations sur les types de messages à l'étiquette du message dans la file d'attente.

    Ensuite, si le message est au format XML dans la file d'attente, il va tenter de faire correspondre les informations sur les types de messages à l'élément racine XML du message dans la file d'attente.

    Pour continuer, effectuez l'une des opérations suivantes :

    • Si, dans la page Informations sur l'interprétation XML vous avez cliqué sur Recevoir les messages XML de la file d'attente, cliquez sur Suivant. Passez à l'étape 8 de cette procédure.

    • Si, dans la page Informations sur l'interprétation XML vous avez cliqué sur Recevoir les messages de chaîne de la file d'attente, cliquez sur Terminer.
  8. Dans la page Informations sur la spécification du message, cliquez sur Parcourir.

  9. Dans la boîte de dialogue Rechercher une spécification, recherchez la spécification à utiliser, sélectionnez-la, puis cliquez sur Ouvrir.

    Le chemin d'accès au fichier et le nom du fichier de la spécification sélectionnée s'affichent dans la zone Spécification du message de la page Informations sur la spécification du message.

    Remarques

    • Si vous ne recherchez pas une spécification existante, vous pouvez cliquer sur Créer. Cette action ouvre l'Éditeur BizTalk et vous permet de sélectionner une spécification et de la modifier si nécessaire pour l'utiliser avec un message ou d'en créer une nouvelle.

    • Si vous sélectionnez une spécification après l'avoir recherchée, le bouton Créer se transforme en bouton Modifier. Cliquez sur Modifier pour modifier la spécification sélectionnée.
  10. Dans la page Informations sur la spécification du message, si vous voulez valider le message par rapport à la spécification, activez la case à cocher Valider les messages par rapport à la spécification.

    Remarque

    • Cette option n'est pas activée sauf si vous sélectionnez une spécification pour la validation.
  11. Dans la page Informations sur la spécification du message, si vous voulez ajouter des champs dans la liste Champs de message, cliquez sur Ajouter.

    Important

    • Si vous voulez sélectionner des champs complémentaires pour cette spécification de message, vous devez utiliser une spécification qui a été créée avec l'Éditeur BizTalk. Vous pouvez adapter tous les standards ou schémas en les important tout d'abord dans l'Éditeur BizTalk puis en les enregistrant comme spécifications BizTalk. (pour plus d'informations, voir Création et validation de spécifications) ;
  12. Dans l'arborescence Sélectionner un noeud de la boîte de dialogue Sélection d'un champ, développez les noeuds appropriés, puis cliquez sur le champ que vous voulez ajouter. Cliquez sur OK.

    Remarques

    • Lorsque vous cliquez sur un champ de l'arborescence Sélectionner un noeud, le nom du champ est ajouté automatiquement dans la zone Nom du champ.

    • Lorsque vous cliquez sur un champ de l'arborescence Sélectionner un noeud, le chemin d'accès au noeud est ajouté automatiquement dans la zone Chemin d'accès au noeud. Vous pouvez modifier ce chemin d'accès manuellement. Pour plus d'informations, voir Champs du chemin d'accès au noeud.

    • Vous ne pouvez pas sélectionner un noeud d'enregistrement pour l'ajouter dans la liste Champs de message. Seuls les champs peuvent être sélectionnés. Pour plus d'informations, voir Champs du chemin d'accès au noeud.

    • Si vous voulez ajouter plusieurs champs dans la liste Champs de message de la boîte de dialogue Sélection d'un champ, vous devez sélectionner un champ et cliquer sur OK. Dans la page Informations sur la spécification du message, cliquez sur Ajouter et répétez le processus pour ajouter d'autres champs.
  13. Dans la page Informations sur la spécification du message, si vous voulez supprimer des champs de la liste Champs de message, cliquez sur un champ de la liste puis sur Supprimer.

    Remarque

    • Vous ne pouvez pas supprimer les champs requis. Ceux-ci apparaissent dans la liste Champs de message sur fond jaune.
  14. Cliquez sur Terminer.

Remarques

  • Les noms de formes doivent répondre à certaines conventions d'affectation des noms. Les conventions suivantes s'appliquent aux transactions, ports, messages, règles et champs :
    • Le nom doit être un nom de jeton XML valide. Pour plus d'informations sur les jetons XML, accédez au site Web de W3C à l'adresse (www.w3.org).

    • Le nom ne peut pas commencer par des traits de soulignement (__).

    • Le nom ne peut pas comporter de caractères deux-points (:).

    • La longueur du nom doit être inférieure ou égale à 32 caractères.

    • Les noms de constante et de message ne peuvent pas commencer par un caractère numérique.
  • La propriété Délai d'attente n'est pas activée tant que vous n'avez pas cliqué sur Recevoir.

  • Seuls les messages XML sont disponibles afin d'être utilisés dans des communications asynchrones. Tous les messages XML sont disponibles et peuvent être spécifiés pour plusieurs ports. Vous ne pouvez pas utiliser les paires de messages synchrones créées à l'aide de l'Assistant Communication de méthodes.

  • Si vous connectez ce flux de communication à un port implémenté à l'aide d'Échanges BizTalk, la direction de la communication (Envoyer ou Recevoir) est déterminée par l'implémentation du port et ne peut pas être définie dans l'Assistant Communication XML. L'option Envoyer ou Recevoir de la première page de l'Assistant est sélectionnée automatiquement et n'est pas disponible. Vous devez cliquer sur Suivant pour passer à la page suivante de l'Assistant et terminer la configuration du flux de communication.

  • Lorsque vous créez une communication asynchrone, un message est créé dans la page Données. Le Message correspond aux informations envoyées ou reçues dans le flux de communication. Le message contient les champs système requis ainsi que tous les champs de spécifications supplémentaires souhaités. Pour plus d'informations sur la définition des messages utilisés dans un flux de communication asynchrone, voir Communication asynchrone.

Voir aussi

Communication asynchrone

Création et validation de spécifications

Création de spécifications et mapping de données

Mise en attente et réalimentation

Établissement du flux de communication entre une action et un port

Champs du chemin d'accès au noeud

Envoi et réception de messages synchrones

Utilisation de l'Assistant Communication XML


Modification du flux de communication entre une action et un port

  1. Sur une page de conception du Concepteur d'Orchestration BizTalk, cliquez avec le bouton droit sur le flux de communication entre une action et un port.

    Un Assistant Communication s'ouvre.

  2. Suivez les étapes de l'Assistant et modifiez les propriétés appropriées.

    Passez à l'une des procédures suivantes, en fonction du type de flux de communication que vous voulez créer.

    • Si vous voulez créer un flux de communication synchrone pour un port qui utilise une implémentation de composants COM ou de composants de script, vous devez utiliser l'Assistant Communication de méthodes. Passez à Envoi ou réception de messages synchrones.

    • Si vous voulez créer un flux de communication asynchrone vers un port utilisant l'implémentation de Message Queuing ou Échanges BizTalk ou un flux de communication asynchrone vers un port non lié, vous devez utiliser l'Assistant Communication XML. Passez à Envoi ou réception de messages asynchrones.

Remarques

  • Vous pouvez établir un flux de communication entre une action et un port dans les pages Processus professionnels, Compensation pour Transaction et En cas d'échec de Transaction. Les actions et les ports ne sont pas disponibles dans la page Données.

  • Vous ne pouvez pas ajouter de formes à la page Données. Les nouveaux messages sont créés automatiquement sur la page Données, chaque fois qu'une action est connectée à un port.

Voir aussi

Établissement du flux de communication entre une action et un port

Envoi ou réception de messages asynchrones

Envoi et réception de messages synchrones

Utilisation de l'Assistant Communication de méthodes

Utilisation de l'Assistant Communication XML


Dessin du flux de données entre les messages

Cette section traite des procédures suivantes :

  • Sélection d'un message

  • Sélection de champ d'un message

  • Dessin de flux entre les messages

  • Suppression d'un message

  • Correspondance entre un message et un port spécifiques

  • Utilisation des constantes

Voir aussi

Ajout, suppression et connexion de formes

Gestion des données


Sélection d'un message

  • Dans la page Données du Concepteur d'Orchestration BizTalk, cliquez sur le champ d'en-tête gris du message que vous voulez sélectionner.

    Le message sélectionné est entouré d'une bordure verte discontinue.

Remarques

  • Vous pouvez sélectionner la liste Constantes, Port References ou un Message.

  • Lorsque vous sélectionnez un message, vous pouvez le repositionner sur la page en le faisant glisser. Repositionner les messages permet de clarifier les flux de données dessinés entre les messages.

Voir aussi

Ajout, suppression et connexion de formes

Gestion des données

Suppression d'un message

Dessin de flux entre les messages

Correspondance entre un message et un port spécifiques

Sélection de champ d'un message

Utilisation des constantes


Sélection de champ d'un message

  • Dans la page Données du Concepteur d'Orchestration BizTalk, cliquez sur le champ d'un message que vous voulez sélectionner.

    Le champ sélectionné est entouré d'une bordure verte discontinue. Toutes les poignées de contrôle ( Poignée de contrôle) disponibles pour ce champ sont activées.

Voir aussi

Ajout, suppression et connexion de formes

Gestion des données

Suppression d'un message

Dessin de flux entre les messages

Correspondance entre un message et un port spécifiques

Sélection d'un message

Utilisation des constantes


Dessin de flux entre les messages

  1. Dans la page Données du Concepteur d'Orchestration BizTalk, cliquez sur un champ d'un message afin d'activer ses poignées de contrôle ( Poignée de contrôle).

  2. Faites glisser la poignée de contrôle vers le point de connexion ( Point de connexion) d'un champ d'un autre message auquel vous voulez le connecter.

    Lorsque le point de connexion est en surbrillance avec une case rouge ( Point de connexion active), relâchez le bouton de la souris pour établir la connexion.

Remarque

  • Si vous voulez créer plusieurs flux de données, vous pouvez utiliser l'outil de connexion pour les ajouter plus rapidement. Pour plus d'informations sur l'outil de connexion, voir Utilisation de l'outil de connexion.

Voir aussi

Ajout, suppression et connexion de formes

Gestion des données

Suppression d'un message

Correspondance entre un message et un port spécifiques

Sélection de champ d'un message

Sélection d'un message

Utilisation des constantes


Suppression d'un message

  • Dans la page Données du Concepteur d'Orchestration BizTalk, cliquez sur le champ d'en-tête gris du message que vous voulez supprimer et appuyez sur SUPPRIMER.

Remarques

  • Vous ne pouvez pas supprimer la liste Port References.

  • Vous ne pouvez pas supprimer la liste Constantes.

  • Si vous sélectionnez le champ d'un message et appuyez sur SUPPRIMER, le message est supprimé et non pas uniquement le champ.

Voir aussi

Ajout, suppression et connexion de formes

Gestion des données

Dessin de flux entre les messages

Sélection de champ d'un message

Sélection d'un message


Correspondance entre un message et un port spécifiques

  1. Cliquez sur le champ de la liste Références de port qui contient le nom du port auquel vous voulez vous référer.

  2. Faites glisser la poignée de contrôle ( Poignée de contrôle) de ce champ vers le point de connexion ( Point de connexion) du champ d'un Message dans lequel vous voulez transférer la référence du port.

Important

  • Pour plus d'informations sur la corrélation des messages et des références de ports, consultez les rubriques suivantes :
    • Gestion des instances

    • Gestion des données

    • Description des implémentations de ports

Voir aussi

Gestion des données

Suppression d'un message

Dessin de flux entre les messages

Implémentation de ports

Gestion des instances

Sélection de champ d'un message

Sélection d'un message

Description des implémentations de ports

Utilisation des constantes


Utilisation des constantes

Cette section traite des procédures suivantes :

  • Ajout de constantes

  • Modification de constantes

  • Suppression de constantes

Voir aussi

Gestion des données

Types de données de champs

Résumé des types de données et des valeurs de types de données


Ajout de constantes

  1. Dans la page Données du Concepteur d'Orchestration BizTalk, cliquez avec le bouton droit sur la liste Constantes, puis cliquez sur Propriétés.

    La boîte de dialogue Propriétés des messages de constantes s'affiche.

  2. Cliquez sur Ajouter.

    La boîte de dialogue Propriétés des constantes s'affiche.

  3. Dans la zone Nom, tapez un nom pour la constante.

  4. Dans la liste Type de données, cliquez sur le type de données pour la constante.

  5. Dans la zone Valeur, tapez une valeur pour la constante.

  6. Cliquez sur OK, puis de nouveau sur OK.

Remarques

  • Un nom par défaut associé à un numéro vous est fourni lorsque vous créez une constante. Vous pouvez modifier ce nom.

  • La zone de texte Description du type de données fournit des informations en lecture seule sur le type de données sélectionné. Elle peut intégrer un exemple de format ou une plage de valeurs valides pour un type de données.

Voir aussi

Gestion des données

Suppression de constantes

Modification de constantes

Types de données de champs

Résumé des types de données et des valeurs de types de données


Modification de constantes

  1. Dans la page Données du Concepteur d'Orchestration BizTalk, cliquez avec le bouton droit sur la liste Constantes, puis cliquez sur Propriétés.

    La boîte de dialogue Propriétés des messages de constantes s'affiche.

  2. Dans la liste Constantes, cliquez sur la constante que vous voulez modifier.

  3. Cliquez sur Modifier.

    La boîte de dialogue Propriétés des constantes s'affiche.

  4. Modifiez les propriétés de constantes appropriées et cliquez sur OK.

Remarques

  • Pour plus d'informations sur les propriétés disponibles dans la boîte de dialogue Propriétés des constantes, voir Ajout de constantes.

  • Un nom par défaut associé à un numéro vous est fourni lorsque vous créez une constante. Vous pouvez modifier ce nom.

  • La zone de texte Description du type de données fournit des informations en lecture seule sur le type de données sélectionné. Elle peut intégrer un exemple de format ou une plage de valeurs valides pour un type de données.

Voir aussi

Ajout de constantes

Gestion des données

Suppression de constantes

Types de données de champs

Résumé des types de données et des valeurs de types de données


Suppression de constantes

  1. Dans la page Données du Concepteur d'Orchestration BizTalk, cliquez avec le bouton droit sur la liste Constantes, puis cliquez sur Propriétés.

    La boîte de dialogue Propriétés des messages de constantes s'affiche.

  2. Dans la liste Constantes, cliquez sur la constante que vous voulez supprimer.

  3. Cliquez sur Supprimer.

Voir aussi

Ajout de constantes

Gestion des données

Modification de constantes

Types de données de champs

Résumé des types de données et des valeurs de types de données


Exécuter les planifications XLANG

Cette section décrit les procédures permettant de compiler, de déboguer, d'activer et d'exécuter des planifications XLANG. Pour exécuter des planifications XLANG, vous pouvez également créer une application COM+ afin d'héberger les instances de planification dédiées.

Cette section traite des procédures suivantes :

  • Compilation et débogage de planifications XLANG

  • Création et configuration d'une application hôte de planification XLANG

Voir aussi

Création d'une application d'instanciation

Gestion des applications et des bases de données XLANG

Exécution des planifications XLANG

Sécurité des application hébergeant des instances de planification XLANG


Compilation et débogage de planifications XLANG

Lorsque vous créez une planification XLANG, vous voulez la compiler, l'exécuter, la tester et la déboguer. Concepteur d'Orchestration BizTalk fournit les fonctionnalités qui vous aideront à compiler, exécuter, tester et déboguer des planifications XLANG.

Le Concepteur d'Orchestration BizTalk intègre les options suivantes :

  • Compilation

  • Mise à jour des signatures de méthodes

  • Fermeture des instances de planification XLANG en cours d'exécution

En outre, deux outils vous permettent de tester et déboguer les planification XLANG :

  • Observateur d'événements XLANG : Vous pouvez utiliser cet outil afin de contrôler les instances de planification XLANG. Pour des informations spécifiques sur l'utilisation de cet outil, consultez le fichier Lisezmoi.htm associé. L'Observateur d'événements XLANG (XLANGMon.exe) et le fichier Lisezmoi installés par l'Assistant Installation de Microsoft BizTalk Server 2000 se trouvent dans le répertoire d'installation suivant : ..\Program Files\Microsoft BizTalk Server\SDK\XLANG Tools.

  • Observateur d'événements de Windows 2000 : L'Observateur d'événements de Windows 2000 peut être utilisé pour afficher les erreurs de planification XLANG. Pour plus d'informations, consultez les rubriques suivantes :
    • Gestion de l'Observateur d'événements

    • Surveillance de l'exécution des planifications XLANG

    • Pour plus d'informations sur l'Observateur d'événements, dans le chapitre « Observateur d'événements » de l'aide de Windows 2000 Server, voir « Utilisation de l'Observateur d'événements ».

Cette section traite des procédures suivantes :

  • Compilation d'un schéma de planification XLANG dans une planification XLANG

  • Exécution d'une planification XLANG.

  • Débogage des composants Visual Basic compilés

  • Actualisation des signatures de méthode

  • Fermeture de toutes les planifications XLANG en cours d'exécution

Voir aussi

Création et configuration d'une application hôte de planification XLANG

Création d'une application d'instanciation

Gestion des applications et des bases de données XLANG

Exécution des planifications XLANG

Sécurité des application hébergeant des instances de planification XLANG


Compilation d'un schéma de planification XLANG dans une planification XLANG

  1. Dans le menu Fichier du Concepteur d'Orchestration BizTalk, cliquez sur Créer XLANG DrawingX.skx.

    La boîte de dialogue Enregistrer la planification XLANG vers s'affiche.

  2. Dans la liste Enregistrer dans, recherchez l'emplacement où vous voulez enregistrer la planification XLANG.

  3. Dans la liste Nom du fichier, vous pouvez renommer le fichier.

  4. Cliquez sur Enregistrer.

Remarques

  • Lorsque vous compilez un schéma de planification XLANG dans une planification XLANG, vous pouvez recevoir des messages d'erreur de compilation. Les messages d'erreur indiquent les problèmes possibles dans le schéma et la forme concernée est mise en surbrillance avec une ligne verte discontinue.

  • Lorsque vous compilez un schéma de planification XLANG, celui-ci est compilé sous le nom par défaut DrawingX.skx, où X représente le nombre ajouté au nom de la planification. Vous pouvez cependant modifier le nom du fichier lorsque vous compilez le schéma.

  • L'extension de fichier d'une planification XLANG est .skx. Un fichier .skx est un fichier XML écrit en langage XLANG. Vous ne pouvez pas ouvrir un fichier .skx dans le Concepteur d'Orchestration BizTalk. Pour modifier ou mettre à jour un fichier .skx, ouvrez le fichier source .skv, modifiez-le et recompilez-le en tant que fichier .skx.

  • L'extension de fichier d'un schéma de planification XLANG est .skv.

Voir aussi

Création et configuration d'une application hôte de planification XLANG

Création d'une application d'instanciation

Débogage des composants Visual Basic compilés

Gestion des applications et des bases de données XLANG

Ouverture et enregistrement des schémas de planification XLANG

Actualisation des signatures de méthode

Exécution d'une planification XLANG.

Exécution des planifications XLANG

Sécurité des application hébergeant des instances de planification XLANG

Fermeture de toutes les planifications XLANG en cours d'exécution


Exécution d'une planification XLANG.

Pour exécuter une planification XLANG, vous devez créer un moyen de l'activer.

Il existe deux moyens principaux d'effectuer cette opération :

  • Configurer les services d'Orchestration BizTalk et les services d'Échanges BizTalk afin d'activer et d'exécuter les planifications XLANG.

    Pour plus d'informations, consultez les rubriques suivantes :

    • Intégration des services BizTalk

    • Définition des propriétés d'une application de destination
  • Activer la planification XLANG par le programme en créant une application d'instanciation telle qu'une page ASP.

    Pour plus d'informations, consultez les rubriques suivantes :

    • Exécution des planifications XLANG

    • Création d'une application d'instanciation

    • Syntaxe du moniker

Voir aussi

Compilation d'un schéma de planification XLANG dans une planification XLANG

Création et configuration d'une application hôte de planification XLANG

Création d'une application d'instanciation

Débogage des composants Visual Basic compilés

Gestion des applications et des bases de données XLANG

Syntaxe du moniker

Actualisation des signatures de méthode

Exécution des planifications XLANG

Sécurité des application hébergeant des instances de planification XLANG

Fermeture de toutes les planifications XLANG en cours d'exécution


Débogage des composants Visual Basic compilés

Dans certaines situations, vous devrez peut-être déboguer des composants créés avec Microsoft Visual Basic après leur compilation.

  1. Dans Visual Basic 6.0, ouvrez le projet Visual Basic que vous voulez déboguer.

  2. Dans le menu Fichier, cliquez sur Créer <YourProject>.dll.

  3. Dans la boîte de dialogue Créer le projet, cliquez sur Options.

  4. Dans la boîte de dialogue Propriétés du projet, sous l'onglet Compiler, cliquez sur Compiler en Code Natif et sur Pas d'optimisation, puis activez la case à cocher Générer les informations de débogage symbolique.

  5. Cliquez sur OK, puis de nouveau sur OK pour compiler le projet.

  6. Ouvrez le projet Visual Basic concerné.

  7. Sélectionnez les points d'arrêt que vous voulez utiliser.

  8. Dans le menu Exécuter, cliquez sur Démarrer.

Lorsque la planification XLANG appelle le composant Visual Basic, le débogueur Visual Basic s'arrête sur les points d'arrêt.

Important

  • Pour créer le projet .dll Visual Basic, vous devez activer la case à cocher Générer les informations de débogage symbolique.

  • Assurez-vous que le moteur de XLANG Scheduler n'a pas encore chargé le projet .dll. Si le projet .dll a été chargé, vous devez arrêter le moteur et réessayer.

Remarque

  • Pour plus d'informations sur les composants de débogage ou sur les composants de services, accédez au site Web de la bibliothèque en ligne MSDN (msdn.microsoft.com/library/default.asp ), puis recherchez les services de composants sur la plate-forme SDK.


Actualisation des signatures de méthode

  • Dans le menu Outils du Concepteur d'Orchestration BizTalk, cliquez sur Actualiser les signatures de méthode.

Remarques

  • Utilisez cette option si vous créez simultanément des composants COM+ et une planification XLANG et si vous modifiez des paramètres de méthode dans l'uns des appels de méthode disponibles. Ainsi, les paramètres de méthode sont actualisés dans la planification XLANG.

  • Lorsque vous compilez une planification XLANG, l'option Actualiser les signatures de méthode est exécutée automatiquement.

Voir aussi

Compilation d'un schéma de planification XLANG dans une planification XLANG

Création et configuration d'une application hôte de planification XLANG

Création d'une application d'instanciation

Débogage des composants Visual Basic compilés

Gestion des applications et des bases de données XLANG

Exécution d'une planification XLANG.

Exécution des planifications XLANG

Sécurité des application hébergeant des instances de planification XLANG

Fermeture de toutes les planifications XLANG en cours d'exécution


Fermeture de toutes les planifications XLANG en cours d'exécution

  • Dans le menu Outils du Concepteur d'Orchestration BizTalk, cliquez sur Fermer toutes les instances de planification XLANG en cours d'exécution.

Remarque

  • Lorsque vous exécutez une instance de planification XLANG, vous ne pouvez pas modifier les composants COM utilisés par cette planification XLANG. Cette option ferme toutes les instances de planification en cours d'exécution et déverrouille le fichier de composant. Vous pouvez ainsi apporter les modifications appropriées.

Voir aussi

Compilation d'un schéma de planification XLANG dans une planification XLANG

Création et configuration d'une application hôte de planification XLANG

Création d'une application d'instanciation

Débogage des composants Visual Basic compilés

Gestion des applications et des bases de données XLANG

Actualisation des signatures de méthode

Exécution d'une planification XLANG.

Exécution des planifications XLANG

Sécurité des application hébergeant des instances de planification XLANG


Création et configuration d'une application hôte de planification XLANG

Cette section décrit les procédures d'activation et d'exécution d'une planification XLANG. Vous pouvez utiliser l'application XLANG Scheduler par défaut pour exécuter les planifications XLANG, mais il est souvent utile de créer une nouvelle application COM+ pour exécuter les instances de planification.

Pour des raisons de configuration, de déploiement et de sécurité, la plupart des applications COM+ qui hébergent des planifications XLANG doivent être créées lors du développement des planifications XLANG. Vous devez tenir compte des performances et de la sécurité des applications et des planifications. Vous pouvez créer une nouvelle application COM+ afin d'héberger des instances dédiées de planification en cours d'exécution ou isoler des applications qui exécutent des instances de planification spécifiques d'autres planifications XLANG qui utilisent des applications différentes.

Pour plus d'informations sur la sécurité et les performances liées à la création de planifications XLANG et d'applications COM+ afin d'héberger des planifications, voir Sécurité des applications hébergeant des instances de planification XLANG.

Pour plus d'informations sur la gestion d'applications COM+ après leur création, voir Gestion d'applications XLANG et de base de données.

Cette section traite des procédures suivantes :

  • Création d'une application COM+ pour héberger des planifications XLANG

  • Configuration d'une application COM+ pour héberger des planifications XLANG

Important

  • Pour accéder à l'aide de l'administration des services de composant, dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration puis sur Services de composant. Dans l'arborescence de la console, cliquez avec le bouton droit sur Services de composants puis cliquez sur Aide.

  • Pour plus d'informations sur les services de composants et COM+, accédez au site Web MSDN Online Library (msdn.microsoft.com/library/default.asp), puis parcourez la plate-forme SDK jusqu'aux services de composant.

Voir aussi

Création d'une application d'instanciation

Gestion des applications et des bases de données XLANG

Exécution des planifications XLANG

Sécurité des application hébergeant des instances de planification XLANG


Création d'une application COM+ pour héberger des planifications XLANG

  1. Dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration et sur Services de composants.

  2. Dans l'arborescence de la console, développez successivement Services de composant, Ordinateurs, Poste de travail et Applications COM+.

    Sélectionnez d'abord Applications COM+, puis cliquez dessus avec le bouton droit. Si vous ne sélectionnez pas cette option, l'option Nouveau n'est pas disponible.

  3. Cliquez avec le bouton droit sur Applications COM+, pointez sur Nouveau et cliquez sur Application.

    L'Assistant Installation Application COM s'ouvre.

  4. Dans la page Bienvenue dans l'Assistant Installation Application COM, cliquez sur Suivant.

  5. Dans la page Installater ou créer d'une nouvelle application, cliquez sur Créer une application vide.

  6. Dans la page Créer une application vide, tapez un nom pour l'application, assurez-vous que l'option Application serveur est activée, puis cliquez sur Suivant.

  7. Dans la page Définir l'identité de l'application, définissez l'identité de l'application pour le compte approprié.

    Nous vous recommandons vivement de créer un compte de service afin de gérer les applications COM+ qui hébergent des planifications XLANG.

    Pour plus d'informations sur les problèmes de performances et de sécurité liés à la création de l'identité d'une application, voir Sécurité des applications hébergeant des instances de planification XLANG.

  8. Cliquez sur Suivant, puis sur Terminer.

  9. Cliquez avec le bouton droit sur l'application COM+ qui vient d'être créée et cliquez sur Propriétés.

  10. Sous l'onglet XLANG, activez la case à cocher Utiliser l'application comme l'hôte des instances de planification XLANG.

  11. Pour configurer une application COM+, voir Configuration d'une application COM+ pour héberger des planifications XLANG.

Important

  • Pour accéder à l'aide de l'administration des services de composant, dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration puis sur Services de composant. Dans l'arborescence de la console, cliquez avec le bouton droit sur Services de composants puis cliquez sur Aide.

  • Pour plus d'informations sur les services de composants et COM+, accédez au site Web MSDN Online Library (msdn.microsoft.com/library/default.asp), puis parcourez la plate-forme SDK jusqu'aux services de composant.

Remarques

  • Lorsque vous créez une application COM+ pour héberger des planifications XLANG, l'option Redémarrer les applications XLANG en attente n'est pas disponible. Pour plus d'informations sur le redémarrage des applications en attente, voir Redémarrage de toutes les applications XLANG.

Voir aussi

Configuration d'une application COM+ pour héberger des planifications XLANG

Création d'une application d'instanciation

Gestion des applications et des bases de données XLANG

Exécution des planifications XLANG

Sécurité des application hébergeant des instances de planification XLANG


Configuration d'une application COM+ pour héberger des planifications XLANG

  1. Dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration et sur Services de composants.

  2. Dans l'arborescence de la console, développez successivement Services de composant, Ordinateurs, Poste de travail et Applications COM+.

  3. Double-cliquez avec le bouton droit sur l'application que vous voulez configurer et cliquez sur Propriétés.

  4. Nous vous recommandons vivement de créer un compte de service pour gérer les applications COM+ qui hébergent des planifications XLANG. Si vous avez accepté la configuration par défaut dans l'Assistant Installation Application COM lorsque vous avez créé l'application COM+, vous pouvez la modifier. Pour plus d'informations, voir Modification de l'identité l'application pour une application COM+.

  5. Configurez les paramètres DSN pour l'application COM+. Pour plus d'informations, voir Modification des paramètres DSN pour une application COM+.

  6. Configurez une base de données pour l'application COM+ à utiliser. Vous pouvez :
    • Pointer sur une base de données existante. Pour plus d'informations, voir Modification des paramètres DSN pour une application COM+.

      –Ou–

    • Créer et configurer une nouvelle base de données. Pour plus d'informations, voir Création d'une nouvelle base de données de persistance et Modification des paramètres DSN pour une application COM+.

Attention

  • Si vous créez et configurez une nouvelle base de données à utiliser avec une application COM+, vous devez initialiser les tables de base de données après avoir configuré les paramètres DSN pour l'application COM+.

    Pour plus d'informations sur la configuration d'un DSN et l'utilisation des sources de données (ODBC), cliquez sur Aide dans la boîte de dialogue Administrateur de la source de données ODBC.

    Pour initialiser de nouvelles tables de base de données pour l'application hôte COM+ configurée :

    1. Cliquez avec le bouton droit sur l'application COM+, puis cliquez sur Propriétés.

    2. Cliquez sur l'onglet XLANG.

    3. Sous l'onglet Tables, cliquez sur Initialiser les tables.
  • Ne cliquez pas sur Initialiser les tables si vous configurez une application hôte COM+ et un DSN pour une base de données existante. Cette action détruira toutes les données déjà enregistrées dans la base de données existante.

Remarques

  • Pour accéder à l'aide de l'administration des services de composant, dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration puis sur Services de composant. Dans l'arborescence de la console, cliquez avec le bouton droit sur Services de composants puis cliquez sur Aide.

  • Pour plus d'informations sur les services de composants et COM+, accédez au site Web MSDN Online Library (msdn.microsoft.com/library/default.asp), puis parcourez la plate-forme SDK jusqu'aux services de composant.

Voir aussi

Modification de l'identité d'une application COM+

Modification des paramètres DSN d'une application COM+

Création d'une application COM+ pour héberger des planifications XLANG

Création d'une base de données de persistance

Création d'une application d'instanciation

Gestion des applications et des bases de données XLANG

Exécution des planifications XLANG

Sécurité des application hébergeant des instances de planification XLANG


Concepts

Cette section fournit des informations détaillées sur les concepts essentiels à la compréhension du Mappeur BizTalk. Elle contient des informations détaillées sur les rubriques suivantes :

  • Services d'Orchestration BizTalk

  • Création de schémas de planification XLANG

  • Compilation des planifications XLANG

  • Débogage des planifications XLANG

  • Exécution des planifications XLANG

  • Gestion de l'état de session

  • Mise à jour des planifications XLANG

Remarque

  • Il est vivement recommandé de consulter la section Comment… pour accéder aux informations spécifiques aux différentes tâches du Concepteur d'Orchestration BizTalk.


Services d'Orchestration BizTalk

Les services d'Orchestration BizTalk accroissent les possibilités des technologies d'échange d'informations établies. Ils permettent aux utilisateurs de créer des représentations détaillées de processus professionnels pouvant être implémentés par programmation au sein d'un environnement de conception intégré.

La conception et l'implémentation de processus professionnels s'effectuent généralement en deux phases distinctes, à savoir : la phase de conception visuelle et la phase de codage. La phase de conception visuelle consiste habituellement en l'analyse d'un processus professionnel existant (par exemple l'approvisionnement de l'entreprise), et la création d'un diagramme de workflow ou d'un diagramme d'interaction décrivant le processus. La phase de codage est généralement effectuée séparément. Dans cet exemple, vous êtes amené à construire un modèle visuel abstrait d'un processus professionnel, puis à mapper ce modèle vers une structure d'implémentation.

Une des fonctionnalités importantes de l'Orchestration BizTalk est l'intégration de ces phases distinctes en un environnement de conception unifié. Cet environnement de conception offre une surface de dessin polyvalente ainsi qu'un vaste ensemble d'outils d'implémentation. L'Orchestration BizTalk vous permet d'effectuer les tâches suivantes :

  • Créer des schémas de planification XLANG décrivant les processus professionnels ;

  • Implémenter des processus professionnels en connectant des actions spécifiques dans un schéma vers des ports représentant les emplacements vers lesquels les messages sont envoyés, ou à partir desquels les messages sont reçus. Les ports sont des emplacements nommés, et les messages représentent les données envoyées ou reçues entre les actions et les ports.

  • Définir le flux de données entre les messages au sein des processus professionnels.

  • Compiler des schémas de planification XLANG en planifications XLANG. Les planifications XLANG sont des représentations XML (Extensible Markup Language) exécutables des informations contenues dans les schémas.

Outre l'intégration de la conception et de l'implémentation, l'Orchestration BizTalk offre une fonctionnalité supplémentaire importante : la possibilité de créer des processus professionnels robustes, longs et librement couplés au travers de diverses organisations, plates-formes et applications. Dans un processus professionnel asynchrone, librement couplé et long, il se peut qu'un produit commandé via Internet doive être assemblé à partir de pièces détachées en stock. Certaines de ces pièces détachées peuvent être temporairement en rupture de stock. Le processus professionnel complet peut durer des semaines ou des mois. À l'opposé, un processus professionnel fortement couplé implique l'échange synchrone de messages. Par exemple, lorsqu'un client retire de l'argent d'un compte bancaire, le débit du compte est immédiatement suivi de la livraison de l'argent.

L'Orchestration BizTalk vous permet d'effectuer les tâches suivantes :

  • Créer une représentation visuelle de processus professionnels à exécution longue.

  • Faciliter l'échange des messages en connectant les actions de votre représentation visuelle à des ports implémentés par une technologie donnée.

  • Compiler le schéma terminé en une représentation XML exécutable du schéma.

  • Exécuter de manière fiable des processus professionnels pendant plusieurs semaines ou plusieurs mois.

Cette section traite des rubriques suivantes :

  • Description des processus professionnels

  • Environnement du Concepteur d'Orchestration BizTalk

  • Planifications XLANG

Voir aussi

Création de schémas de planification XLANG

Description des processus professionnels


Description des processus professionnels

Les processus professionnels sont aussi importants pour la gestion d'une entreprise que les lignes d'assemblage le sont pour la fabrication. Le respect d'un ensemble de processus bien définis et formalisés peut permettre à toute entreprise d'accroître sa productivité et de diminuer ses coûts. Un processus professionnel définit le protocole d'échange des messages entre tous les participants distribués. Pour définir un processus professionnel, vous devez déterminer l'ordre logique des actions ainsi que le flux correspondant des messages. Un processus professionnel n'inclut pas les définitions des participants distribués qui effectuent ces actions.

La séquence des étapes d'un processus professionnel à exécution longue est généralement asynchrone. Chaque étape est constituée d'une action qui peut être effectuée par un ou plusieurs participants distribués et indépendants. Ces actions peuvent résulter en l'envoi et la réception de messages entre les participants, pouvant être ou non les exécutants des tâches concernées. Un participant distribué peut être un processus automatique qui répond à une entrée ; le participant peut même être un processus professionnel totalement séparé. Pour comprendre les processus professionnels, vous devez pouvoir visualiser un ensemble complexe de relations et de dépendances. Des outils de modélisation de processus professionnels, tels que les diagrammes de workflow et les diagrammes d'interaction, ont été développés dans le but de décrire visuellement ces relations.

Cette section traite des rubriques suivantes :

  • Diagrammes de workflow

  • Diagrammes d'interaction


Diagrammes de workflow

La Gestion automatisée (ou workflow) est une technologie de conception de processus professionnels qui automatise et améliore les procédures au sein des organisations. Il s'agit d'une technologie utile permettant de représenter les étapes à effectuer, les contraintes à satisfaire, et les accords à obtenir pendant la réalisation des projets. Vous pouvez utiliser une application de Gestion automatisée (ou workflow) pour affecter les tâches aux membres de l'équipe, définir les responsabilités individuelles et décrire les relations entre les participants au projet. Vous pouvez également utiliser une application de Gestion automatisée (ou workflow) pour définir des limites de temps pour la réalisation des projets et le respect de leurs jalons. Cependant, la technologie de Gestion automatisée (ou workflow) est généralement fortement centralisée. Les participants se voient affectés des tâches et des délais, tandis que le moteur de Gestion automatisée (ou workflow) est responsable de l'acheminement des travaux terminés d'un participant à l'autre, et du respect du planning. Le champ d'application de l'Orchestration BizTalk est plus étendu. Les participants y sont autonomes et la responsabilité du routage des travaux entre les différents participants est déterminée par ces derniers et non par une application centralisée.

Voir aussi

Diagrammes d'interaction

Description des processus professionnels


Diagrammes d'interaction

Un diagramme d'interaction décrit le flux de données dans un processus professionnel ainsi que les messages échangés. L'Orchestration BizTalk étend le concept de diagramme d'interaction en fournissant définitions et contrôles de décisions, actions concurrentes, transactions et actions prises en charge ne pouvant être incluses dans un diagramme d'interaction. La conception d'un processus professionnel à l'aide de l'Orchestration BizTalk résulte en un processus professionnel compilé et exécutable (planification XLANG). En revanche, les diagrammes d'interaction sont des représentations statiques des processus professionnels.

Le diagramme d'interaction typique pour un système d'approvisionnement automatisé est présenté ci-après.

Internet
Application
commande
Facture
Paiement
Bits, Bytes,
& Chips, Inc
Ordre
d'achat
Accord
requête OA
Approbation OA
ProElectron, Inc
Requête d'achat
Utilisateur
Approbation
OA
Finance
Fournisseur

Voir aussi

Description des processus professionnels

Diagrammes de workflow


Environnement du Concepteur d'Orchestration BizTalk

Le Concepteur d'Orchestration BizTalk permet de créer des schémas de planification XLANG. Un schéma de planification XLANG est la représentation d'un processus professionnel. Le schéma est enregistré sous la forme d'un fichier .skv, qui est une version personnalisée du format de fichier Microsoft Visio 2000. Le schéma de planification XLANG peut ensuite être compilé en une planification XLANG, qui est un fichier texte .skx de structure XML, reconnu par le moteur de XLANG Scheduler. Le Concepteur d'Orchestration BizTalk permet de créer les schémas de planification XLANG suivants :

  • Description visuelle d'un processus professionnel Cet aspect d'un schéma de planification XLANG est similaire à un diagramme de workflow ou à un diagramme d'interaction.

  • Représentation visuelle de ports configurables Il s'agit de l'aspect d'implémentation d'un schéma de planification XLANG.

  • Représentation visuelle des connexions entre les formes Les formes Diagramme de flux peuvent être connectées pour représenter le flux de processus dans un processus professionnel, tandis que les actions peuvent être connectées aux ports pour représenter le flux de communication dans un processus professionnel.

  • Représentation visuelle du flux entre les champs de messages spécifiés Cet aspect d'un schéma de planification XLANG détermine la relation entre un champ d'un message et un autre champ d'un message différent. La mise en corrélation de ces relations permet d'activer la logique de routage sensible aux données.

Un schéma de planification XLANG est une représentation des procédures exécutées pendant un processus professionnel. Un schéma de planification XLANG peut définir :

  • le protocole d'échange de messages que les partenaires commerciaux s'accordent à utiliser ;

  • les actions utilisées pour envoyer ou recevoir des messages décrivant la séquence logique dans laquelle les actions se produisent ;

  • l'implémentation des ports et les actions auxquelles ils sont liés ;

  • le flux de données entre les champs de messages.

Cette section traite des rubriques suivantes :

  • Pages de conception

  • Formes Diagramme de flux

  • Formes Implémentation

  • Formes Communication

  • Touches de raccourci du Concepteur d'Orchestration BizTalk


Pages de conception

Quatre pages de conception sont accessibles dans le Concepteur d'Orchestration BizTalk. Vous pouvez utiliser ces pages de conception pour créer différents aspects de votre schéma de planification XLANG.

  • Page Processus professionnel Sur cette page, vous pouvez utiliser les formes Diagramme de flux et les formes Implémentation pour définir un processus professionnel. Pour plus d'informations sur l'utilisation de ces formes, voir Formes Diagramme de flux et Formes Implémentation.

  • Page Données Sur cette page, vous pouvez utiliser les formes Communication pour contrôler la direction dans laquelle les messages sont envoyés. Le Concepteur d'Orchestration BizTalk fournit automatiquement ces formes. Pour plus d'informations sur l'utilisation de ces formes, voir Formes Communication.

  • Page En cas d'échec de Transaction Sur cette page, vous pouvez utiliser les formes Diagramme de flux et Implémentation pour concevoir un processus professionnel de remplacement en cas d'échec d'une transaction.

  • Page Compensation pour Transaction Sur cette page, vous pouvez utiliser les formes Diagramme de flux et Implémentation pour concevoir un processus d'annulation pour une transaction imbriquée validée. Pour plus d'informations sur les transactions, voir Conception de transactions.

Voir aussi

Gestion des exceptions


Formes Diagramme de flux

Le Concepteur d'Orchestration BizTalk fournit huit formes Diagramme de flux, disponibles sur le stencil Diagramme de flux. Ces formes servent à décrire votre processus professionnel. Les huit formes du stencil Diagramme de flux peuvent être utilisées pour décrire la structure et la signification des planifications XLANG. XLANG est un langage basé sur XML qui décrit les interactions entre les processus professionnels.

Les formes Diagramme de flux sont présentées au tableau suivant.

Nom de la forme Description
Début

La forme Début n'est pas disponible sur le stencil Diagramme de flux, elle ne peut pas être supprimée et vous ne pouvez pas créer de formes Début supplémentaires. La forme Début représente le début d'un schéma de planification XLANG. La forme Début est créée automatiquement sur chaque page Processus professionnel, Compensation pour Transaction et En cas d'échec de Transaction. La forme Début qui apparaît sur la page Processus professionnel possède des propriétés configurables. Les formes Début qui apparaissent sur les pages Compensation pour Transaction et En cas d'échec de Transaction ne possèdent pas de propriétés configurables. Vous ne pouvez pas inclure une forme Début dans une transaction. La séquence des processus professionnels doit relier la forme Début à la première forme Diagramme de flux de votre schéma.
Action

La forme Action représente un processus qui reçoit un message depuis un port ou envoie un message vers un port. L'action d'envoi ou de réception peut être synchrone ou asynchrone, en fonction du composant ou de l'implémentation à laquelle le port est lié.
Décision

La forme Décision représente un processus qui évalue séquentiellement une ou plusieurs règles.

Cette forme possède un flux entrant et un ou plusieurs flux sortants. Chaque flux sortant est associé à une règle dont le résultat est TRUE ou FALSE. La première règle dont le résultat est TRUE détermine le flux sortant qui est suivi dans le processus professionnel. La séquence du processus professionnel suit le flux à partir de la première règle dont le résultat est TRUE. Si aucune règle ne donne la valeur TRUE, le flux ELSE est suivi.

La forme Décision doit contenir au moins une règle. Chaque règle doit contenir une expression de script.
Tant que

La forme Tant que contient une règle et représente un processus qui peut être répété. Si la règle possède la valeur TRUE, le flux issu de la règle est suivi jusqu'à la fin, puis se répète. Si la règle possède la valeur FALSE, le flux Continuer est suivi. Si la séquence de processus professionnels est issue d'une règle dans une forme Tant que, la séquence doit se terminer dans une forme Fin unique.

Vous pouvez également configurer la conservation de l'état d'une boucle Tant que. Cliquez à l'aide du bouton droit sur une forme Tant que, puis cliquez sur Propriétés pour afficher la boîte de dialogue Propriétés Tant que. Dans la zone Persistance de l'état, choisissez Oui pour enregistrer les messages utilisés dans chaque itération de boucle en tant qu'état de planification XLANG. Si la boucle Tant que fait partie d'une transaction en échec, une page En cas d'échec de Transaction ou Compensation pour Transaction est appelée pour chaque itération de boucle terminée. Si vous choisissez Non, seuls les messages utilisés dans la dernière itération de boucle sont enregistrés en tant qu'état de planification XLANG. Si la boucle Tant que fait partie d'une transaction en échec, une page En cas d'échec de Transaction ou Compensation pour Transaction est appelée une seule fois.

Si une séquence de processus professionnels se dirige vers une forme Tant que contenue dans une transaction imbriquée en échec, les messages et ports qui ont été créés sur la page En cas d'échec de Transaction ou Compensation pour Transaction pour la transaction imbriquée ne sont pas disponibles à la page En cas d'échec de Transaction pour la transaction externe. Concevez donc le code En cas d'échec ou Compensation de manière à forcer les messages collectés à s'écouler normalement de la transaction imbriquée.
Embranchement

La forme Branche introduit la simultanéité dans un processus professionnel. Un flux peut entrer dans une branche, et un maximum de 64 flux peuvent en sortir. Tous les flux quittant une branche sont exécutés simultanément. Toutes les séquences de processus professionnels issues d'une même forme Branche doivent être connectées à une même forme Jointure ou se terminer dans une forme Fin.
Joindre

La forme Jointure synchronise les flux simultanés dans un processus professionnel. Un maximum de 64 flux peuvent entrer dans une forme Jointure, mais seulement un flux peut en sortir. Les opérateurs logiques AND et OR sont utilisés pour déterminer le mode de synchronisation des flux. Vous pouvez définir les propriétés de Jointure suivantes :
  • OR. Permet au premier flux qui arrive de continuer. L'exécution des autres flux se poursuit.

  • AND. Synchronise tous les flux entrants avant que le flux sortant puisse continuer.
Transaction

La forme Transaction représente un ensemble d'actions dont la totalité ou aucune sont exécutées. Il existe trois types de transactions :
  • Transactions de courte durée

  • Transactions de longue durée

  • Transactions de longue durée dont le délai a été dépassé

Les transactions sont utilisées pour rendre une application plus fiable et simplifier la gestion d'erreur dans de grandes applications.

La forme Transaction est limitée à un seul chemin d'accès d'entrée, et à un seul chemin d'accès de sortie. La forme Transaction ne peut pas contenir de formes Fin. Les transactions de longue durée peuvent contenir des transactions imbriquées ; en revanche, les transactions de courte durée ne peuvent pas contenir de telles transactions. Les tentatives de reprises de transactions ne sont autorisées que pour les transactions de courte durée. Si vous incluez une partie de votre processus professionnel dans une forme Transaction de courte durée, vous pouvez configurer la propriété Nombre de tentatives de la transaction. En cas d'échec de la transaction de courte durée, le nombre de tentatives spécifié est exécuté.

En définissant les propriétés des transactions, vous pouvez rendre disponible soit la page Compensation pour Transaction (pour les transactions imbriquées) soit la page En cas d'échec de Transaction. Chacune de ces pages vous permet de modéliser les processus de gestion d'erreur spécifiques à la transaction.

Remarque

  • Si les bordures d'une forme Transaction interne chevauchent une des bordures de la forme Transaction externe, la transaction interne ne sera pas imbriquée. Par conséquent, ne laissez pas les bordures d'une transaction interne chevaucher les bordures d'une transaction externe.
Fin

La forme Fin représente la fin d'un flux de processus. Un schéma peut utiliser plusieurs formes Fin s'il contient des formes Décision, Tant que ou Branche.
Abandon

La forme Abandon termine l'exécution d'un groupe de transactions. Elle fait apparaître une page de gestion d'erreur En cas d'échec de Transaction ou Compensation pour Transaction, ou fait recommencer la transaction.

Remarques

  • Dans le cas des pages Compensation pour Transaction et En cas d'échec de Transaction, le paramètre Transaction est remplacé par le nom attribué à la transaction associée à la page Processus professionnel.

  • Les noms de formes doivent répondre à certaines conventions d'affectation des noms. Les conventions suivantes s'appliquent aux formes de transactions et de ports, aux messages, aux règles et aux champs :
    • Le nom doit être un nom de jeton XML valide. Pour plus d'informations sur les jetons XML, accédez au site Web de W3C à l'adresse (www.w3.org).

    • Le nom ne peut pas commencer par des traits de soulignement (__).

    • Le nom ne peut pas comporter de caractères deux-points (:).

    • La longueur du nom doit être inférieure ou égale à 32 caractères.

    • Les noms de constante et de message ne peuvent pas commencer par un caractère numérique.
  • Les noms de transactions dans des jeux de caractères codés sur un seul octet ne peuvent pas dépasser une longueur de 16 caractères. Les noms de transactions dans des jeux de caractères codés sur deux octets ne peuvent pas dépasser une longueur de 8 caractères.

  • Aucune convention d'affectation des noms ne s'applique aux actions, hormis la taille limite de 32 caractères.

  • Les formes suivantes ne peuvent pas être nommées : Abandon, Début, Décision, Fin, Branche, Jointure et Tant que.

Voir aussi

Formes Communication

Conception de transactions

Formes Implémentation


Formes Implémentation

Le Concepteur d'Orchestration BizTalk fournit quatre formes Implémentation, disponibles sur le stencil d'implémentation. Ces formes servent à la description des technologies d'implémentation utilisées pour implémenter un port dans un processus professionnel.

Les formes Implémentation sont présentées au tableau suivant.

Nom de la forme | Description
Composant COM | La forme Composant COM représente une technologie pouvant être utilisée pour implémenter un port en ayant recours à un appel de méthode pour chaque message envoyé ou reçu. Faites glisser cette forme du côté droit de la barre de séparation pour ouvrir l'Assistant Liaison de composants COM. Pour plus d'informations sur l'implémentation des composants COM, voir Utilisation de la forme Composant COM.
Composant de script Composant de script | La forme Composant de script représente une technologie pouvant être utilisée pour implémenter un port en ayant recours à un appel de méthode pour chaque message envoyé ou reçu. Faites glisser cette forme du côté droit de la barre de séparation pour ouvrir l'Assistant Liaison des composants de script. Pour plus d'informations sur l'implémentation des composants de script, voir Utilisation de la forme composant de script.
Message Queuing | La forme Message Queuing représente une technologie pouvant être utilisée pour implémenter un port. Les services Message Queuing sont utilisés pour envoyer ou recevoir des messages. Faites glisser cette forme du côté droit de la barre de séparation pour ouvrir l'Assistant Liaison de Message Queuing. Pour plus d'informations sur l'implémentation de Message Queuing, voir Utilisation de la forme Message Queuing.
Échanges BizTalk | La forme Échanges BizTalk représente une technologie pouvant être utilisée pour implémenter un port. Les services d'échanges BizTalk sont utilisés pour envoyer ou recevoir des messages. Faites glisser cette forme du côté droit de la barre de séparation pour ouvrir l'Assistant Liaison d'Échanges BizTalk. Pour plus d'informations sur l'implémentation des Échanges BizTalk, voir Utilisation de la forme Échanges BizTalk.

Remarque

  • Les noms de formes doivent répondre à certaines conventions d'affectation des noms. Les conventions suivantes s'appliquent aux transactions, aux ports, aux messages, aux règles et aux champs :
    • Le nom doit être un nom de jeton XML valide. Pour plus d'informations sur les jetons XML, accédez au site Web de W3C à l'adresse (www.w3.org).

    • Le nom ne peut pas commencer par des traits de soulignement (__).

    • Le nom ne peut pas comporter de caractères deux-points (:).

    • La longueur du nom doit être inférieure ou égale à 32 caractères.

    • Les noms de constante et de message ne peuvent pas commencer par un caractère numérique.

Voir aussi

Formes Communication

Formes Diagramme de flux


Formes Communication

Le Concepteur d'orchestration BizTalk fournit plusieurs formes Communication qui indiquent la direction du flux des données en provenance ou à destination des messages. Le Concepteur d'Orchestration BizTalk fournit automatiquement les formes Communication.

Les formes Références du port, Constantes et Messages se situent sur la page Données. La page Données représente le flux de données entre les messages utilisés par l'instance de planification XLANG pendant l'exécution de l'instance. Pour concevoir le flux de données, vous pouvez créer des connexions entre les champs contenus dans les formes de la page Données.

Les formes Communication sont présentées au tableau suivant.

Nom de la forme | Description
Port | Les ports sont des emplacements nommés où les messages sont envoyés ou reçus. Cliquez à l'aide du bouton droit sur la barre de séparation, puis cliquez sur Ajouter un nouveau port pour ajouter un port non lié. Ou, déplacez une forme Implémentation vers la droite de la barre de séparation pour ajouter un port lié. Chaque port contient des messages qui correspondent aux Messages apparaissant sur la page Données. Un message représente les données envoyées ou reçues par une action. Les données d'un message sont contenues dans une liste de champs sur la page Données.
Références du port | Le message Port References message contient la liste de tous les ports créés sur la page Processus professionnel. Une nouvelle référence est ajoutée à la liste chaque fois qu'un nouveau port est ajouté sur la page Processus professionnel. Le message Références des ports vous permet de spécifier l'origine des emplacements des ports. Le message Port References contient un champ pour chaque port du processus professionnel.
Constantes | Le message de constantes vous permet d'initialiser votre planification XLANG avec des données. Pour ajouter une constante au message de Constantes, double-cliquez sur ce message ou double-cliquez sur l'un de ses champs pour ouvrir la boîte de dialogue Propriétés des messages de constantes.
Message | Cette forme contient la liste des champs avec des informations sur les données envoyées ou reçues dans le message.

Remarque

  • Les noms de formes doivent répondre à certaines conventions d'affectation des noms. Les conventions suivantes s'appliquent aux transactions, aux ports, aux messages, aux règles et aux champs :
    • Le nom doit être un nom de jeton XML valide. Pour plus d'informations sur les jetons XML, accédez au site Web de W3C à l'adresse (www.w3.org).

    • Le nom ne peut pas commencer par des traits de soulignement (__).

    • Le nom ne peut pas comporter de caractères deux-points (:).

    • La longueur du nom doit être inférieure ou égale à 32 caractères.

    • Les noms de constante et de message ne peuvent pas commencer par un caractère numérique.

Chaque message défini sur la page Données possède des champs système supplémentaires que le moteur de XLANG Scheduler crée et conserve automatiquement pour chaque message. Ces champs peuvent être référencés afin de fournir des informations descriptives sur le message, et utilisés dans des expressions de script pour des règles. Les champs système créés automatiquement sont présentés au tableau suivant.

Champs système Description
__Exists__ Ce champ peut être utilisé pour vérifier l'existence d'un message. L'existence d'un message est déterminée par le fait que le message a été reçu ou envoyé par le moteur de XLANG Scheduler.

Ce champ ne figure pas parmi les messages affichés sur la page Données. Il est utilisé uniquement avec les formes Décision et Tant que.
__Sender__ Ce champ contient l'identité, si elle est connue, de l'émetteur d'un message.

Ce champ figure parmi les messages affichés sur la page Données.
__Status__ Ce champ contient l'état renvoyé depuis un appel de méthode COM sur un port lié à un composant COM. Ce champ figure parmi les messages affichés sur la page Données.

Remarques

  • Ce champ système est utilisé uniquement avec des implémentations de composants COM et de script.

  • L'état renvoyé est toujours un HRESULT.
Document Ce champ contient une chaîne incluant le corps du message envoyé ou reçu. Il se réfère toujours à un message XML.

Remarque

  • Ce champ système est utilisé uniquement avec des implémentations de type Message Queuing et Échanges BizTalk.

Important

  • La source de chaque champ de données doit être définie dans chaque message envoyé depuis une instance de planification XLANG. Pour définir la source d'un champ de données, une connexion doit pointer vers ce champ depuis un autre champ d'un autre message.

Remarques

  • Le moteur de compilation utilisé pour créer une planification XLANG vérifie si tous les champs d'entrée seule d'un message sont définis. La planification n'est pas compilée si les champs d'entrée seule ne sont que partiellement définis. Les arguments transmis à une méthode peuvent l'être en entrée, en sortie ou les deux. Le moteur de compilation ignore l'exigence de définition des arguments définis à la fois en entrée et en sortie. Si aucune connexion entrante n'est définie pour les champs d'entrée-sortie, la planification est compilée, même s'il n'existe aucune définition pour les données du message.

Voir aussi

Gestion des données

Formes Diagramme de flux

Formes Implémentation


Touches de raccourci du Concepteur d'Orchestration BizTalk

Vous pouvez utiliser les touches de raccourci pour effectuer des tâches dans le Concepteur d'orchestration BizTalk. Le tableau suivant présente ces touches de raccourci.

Remarque

  • Le clavier numérique permet d'obtenir la fonctionnalité non incluse dans la liste pour déplacer le pointeur de la souris à l'aide des Touches souris. Pour plus d'informations sur les Touches souris dans Windows 2000 Server et l'aide de Advanced Server, voir Utiliser le clavier pour déplacer le pointeur de la souris. Pour plus d'informations sur les Touches souris dans l'aide de Windows 2000 Édition Professionnelle, voir Déplacer le pointeur à l'aide des Touches souris.
Appuyez sur | Pour
ALT ou F10 | Activer la barre de menus.
ALT+F4 | Fermer l'élément actif ou quitter le programme.
Alt+F7 | Mettre les fenêtres en cascade.
ALT+ESPACE | Afficher le menu système pour l'élément actif.
ALT+lettre soulignée d'un nom de menu | Afficher le menu correspondant.
Touches de direction | Déplacer la forme sélectionnée dans la direction de la flèche.
CTRL tout en faisant glisser un élément | Copier l'élément sélectionné.
CTRL+A | Sélectionner tout.
CTRL+C | Copier l'élément sélectionné sur la page de conception.
CTRL+F4 | Fermer le schéma actif.
CTRL+I | Rétablir la taille réelle de la fenêtre.
CTRL+N | Créer un nouveau schéma.
Ctrl+O | Ouvrir un schéma existant.
CTRL+P | Ouvrir la boîte de dialogue Imprimer.
CTRL+Q | Quitter le programme.
CTRL+MAJ avec une des touches de direction | Faire défiler l'affichage.
CTRL+MAJ, puis cliquez sur le bouton gauche de la souris | Effectuer un zoom avant.
CTRL+MAJ, puis cliquez sur le bouton droit de la souris | Effectuer un zoom arrière.
CTRL+MAJ+TAB | Activer et désactiver les onglets d'une boîte de dialogue de l'arrière vers l'avant.
CTRL+TAB | Activer et désactiver les onglets d'une boîte de dialogue de l'avant vers l'arrière.
CTRL+V | Coller l'élément sélectionné sur la page de conception.
Ctrl+X | Couper l'élément sélectionné sur la page de conception.
CTRL+Y | Recommencer.
CTRL+Z | annuler
SUPPR | Supprimer l'élément sélectionné sur la page de conception.
ÉCHAP | Annuler la tâche en cours.
F1 | Consulter l'aide en ligne.
F11 | Afficher la boîte de dialogue de propriétés de texte.
F8 | Aligner les formes sélectionnées.
GAUCHE | Déplacer le focus vers la gauche lorsque celui-ci se trouve sur un onglet d'une boîte de dialogue.
DROITE | Déplacer le focus vers la droite lorsque celui-ci se trouve sur un onglet d'une boîte de dialogue.
MAJ tout en faisant glisser un élément | Faire glisser un élément uniquement dans une direction horizontale ou verticale.
MAJ+TAB | Déplacer le focus dans le sens contraire des aiguilles d'une montre en partant de l'onglet vers les fenêtres ou les champs situés en dessous.
BARRE ESPACE | Activer et désactiver les cases à cocher.
TAB | Déplacer le focus dans le sens des aiguilles d'une montre en partant de l'onglet vers les fenêtres ou les champs situés en dessous.
Lettre soulignée dans un nom de commande d'un menu ouvert | Exécuter la commande correspondante.


Planifications XLANG

La version compilée d'un schéma de planification XLANG est une planification XLANG, exécutée par le moteur de XLANG Scheduler. Le moteur de XLANG Scheduler surveille et contrôle le processus professionnel décrit dans la planification XLANG, sur la base des actions, règles et processus de gestion d'erreur définis pour la planification XLANG.

Cette section traite des rubriques suivantes :

  • Vue d'ensemble de XLANG

  • Gestion des instances

  • Persistance

  • Mise en attente et réalimentation

  • Gestion des données


Vue d'ensemble de XLANG

XLANG est un langage basé sur XML qui décrit les interactions entre les processus professionnels. Le Concepteur d'Orchestration BizTalk peut compiler des schémas de planification XLANG en des fichiers de planification XLANG structurés en XML. Étant donné que XLANG est un langage basé sur XML, les planifications XLANG doivent se conformer aux règles XML en matière de documents bien formés ainsi qu'à une spécification ou à un schéma standard.


Gestion des instances

Pour comprendre comment le moteur de XLANG Scheduler effectue la gestion des instances, il faut faire la distinction entre une définition abstraite d'un processus professionnel et plusieurs instances d'exécution d'une définition de processus professionnel. Le Concepteur d'Orchestration BizTalk permet de concevoir une définition de processus professionnel et de l'enregistrer sous la forme d'un schéma de planification XLANG (fichier .skv). Après avoir créé un schéma de planification XLANG, vous pouvez le compiler en une planification XLANG (fichier .skx). Une fois la planification XLANG déployée, il se peut que plusieurs instances de la planification fonctionnent en même temps. Chaque instance de planification XLANG peut avoir une durée de vie indépendante de celle de toutes les autres instances. Lorsque vous concevez une application destinée à prendre en charge plusieurs instances de planification XLANG, vous devez veiller aux points suivants :

  • Activation de nouvelles instances de planification XLANG lors de la réception de messages. Vous pouvez concevoir votre application de manière à activer une nouvelle instance de planification XLANG en utilisant la fonction COM GetObject chaque fois qu'un message est reçu. Par exemple, si vous utilisez une ASP (Active Server Page) pour recevoir un message contenant une commande d'achat ou une requête de prise en charge client, l'ASP doit utiliser la fonction COM GetObject pour activer une planification XLANG.

Vous pouvez utiliser l'Assistant Liaison d'Échanges BizTalk pour créer une liaison de port pouvant servir d'emplacement nommé vers lequel les messages sont envoyés. BizTalk Server 2000 fournit un mécanisme automatique permettant d'activer une instance de planification XLANG lorsqu'un port lié au Gestionnaire d'Échanges BizTalk reçoit un message. À la page Informations sur l'activation de la planification XLANG de l'Assistant Liaison d'Échanges BizTalk, un message s'affiche pour vous demander de confirmer si le canal a été configuré dans les services d'échanges BizTalk pour envoyer un message vers ce port après l'activation d'une nouvelle instance de cette planification XLANG. Pour terminer ce processus, vous devez exécuter l'Assistant Nouveau port d'échanges du Gestionnaire d'Échanges BizTalk. À la page Application de destination de l'Assistant Nouveau port d'échanges, spécifiez le nom du port ainsi que le nom et l'emplacement de la planification XLANG.

  • Corrélation de l'échange des messages vers les instances de planification XLANG. Le moteur de XLANG Scheduler affecte un identificateur global unique (GUID) à chaque instance d'une planification XLANG. Par conséquent, chaque port de chaque instance d'une planification XLANG en cours d'exécution ne peut se voir affecter qu'une seule adresse. Cela permet la communication directe vers des ports spécifiques d'instances de planification XLANG données. Le fait de permettre la communication directe au travers d'emplacements de ports adressables de manière unique permet d'éviter la difficulté d'utiliser un seul emplacement pour distribuer les messages vers les instances. Le premier message envoyé par une instance de planification est probablement dirigé vers un port statique (un emplacement nommé). Lors de l'activation de la planification XLANG, cette instance envoie les emplacements de ses ports dynamiques (emplacements uniques, par instance) vers les destinataires, qui seront responsables de la communication en retour vers les ports. Cela correspond à des messages de courrier électronique envoyés avec des adresses de réponse uniques. La prise en charge de la liaison dynamique dans chacune des technologies de liaison de BizTalk Server est présentée ci-après :
    • Si vous choisissez l'option Statique à la page Communication statique ou dynamique de l'Assistant Liaison de composants COM ou de l'Assistant Liaison de composants de script, le moteur de XLANG Scheduler crée l'instance de planification XLANG du composant. Si vous choisissez l'option Dynamique, une autre application doit envoyer un pointeur d'interface ou un moniker (sous la forme d'un champ dans un message) avant l'instanciation du composant.

      Vous pouvez également choisir l'option Aucune instanciation. Pour plus d'informations sur l'instanciation des composants, voir Ports statiques et dynamiques.

    • Si vous choisissez l'option File d'attente statique puis cliquez sur Suivant à la page Communication statique ou dynamique de l'Assistant Liaison de Message Queuing, la page Informations sur la file d'attente s'affiche. La page Informations sur la file d'attente vous permet de spécifier la création d'une file d'attente par instance séparée pour chaque instance de planification XLANG, ou l'utilisation d'une seule file d'attente pour toutes les instances en cours d'exécution. Pour permettre la corrélation, vous devez spécifier la création d'une file d'attente par instance séparée pour chaque instance de planification XLANG.

    • Si vous choisissez l'option File d'attente dynamique à la page Communication statique ou dynamique de l'Assistant Liaison de Message Queuing, une autre application doit envoyer le nom de la file d'attente (sous la forme d'un champ dans un message) avant d'envoyer ou de recevoir des messages via le port.

    • À la page Informations sur le canal statique ou dynamique de l'Assistant Liaison d'Échanges BizTalk, vous pouvez choisir de fournir un nom de canal spécifique ou indiquer que les informations de configuration de port seront utilisées par les services d'échanges BizTalk pour identifier le canal correct au moment de l'exécution. Pour plus d'informations sur l'échange de messages, Intégration des services BizTalk.

    Important

    • Vous devez vous assurer que la corrélation d'un message s'effectue vers la même instance de planification XLANG que celle qui a participé à une communication antérieure avec un partenaire commercial.
  • Mise à l'échelle de l'application. Toutes les instances de planification XLANG qui ne doivent pas être en mémoire doivent être mises en attente. Il se peut qu'une instance de planification XLANG ne doive pas être en mémoire lorsqu'une instance de planification XLANG attend l'arrivée d'un message.

Remarque

  • Toutes les technologies d'implémentation affichent une ombre en dessous de la forme pour indiquer que l'emplacement sera lié dynamiquement et défini au moment de l'exécution.

Voir aussi

Gestion des données

Mise en attente et réalimentation

Gestion de l'état de session

Persistance


Persistance

Le moteur de XLANG Scheduler stocke les informations suivantes dans la base de données de persistance :

  • la structure des planifications XLANG ;

  • l'état d'avancement des instances de planification XLANG activées ;

  • les messages envoyés ou reçus pendant l'exécution d'une instance de planification XLANG.

Le moteur de XLANG Scheduler conserve les informations destinées à autoriser les scénarios suivants :

  • Permettre la mise en attente et la réalimentation des planifications longues Il se peut que le système échoue pendant une transaction de longue durée. Lorsque le système fonctionne à nouveau, le moteur de XLANG Scheduler doit se référer à la base de données de persistance pour déterminer où reprendre la planification.

  • Restaurer l'état d'une instance de planification lors de l'échec d'une transaction Il se peut que le système échoue pendant une transaction, provoquant l'abandon de celle-ci. Le moteur de XLANG Scheduler doit se référer à la base de données de persistance pour déterminer où reprendre la planification.

  • Prendre en charge le débogage et la surveillance des planifications en cours d'exécution Les outils de débogage et de surveillance peuvent demander à la base de données de persistance de leur fournir des informations sur l'état d'avancement des instances de planification.

La prise en charge de la persistance de l'état d'une planification XLANG, avant le début et après la fin d'une transaction, assure la durabilité et garantit que toutes les modifications validées resteront en permanence dans le système. Cela permet également de relancer une transaction en cas de défaillance. La persistance de l'état d'une instance de planification en cours d'exécution est assurée dans les circonstances suivantes :

  • Au début d'une transaction Lorsque la séquence des processus professionnels entame une transaction, le nombre de tentatives de la transaction doit être mis à jour dans la base de données de persistance. Cela permet au moteur de XLANG Scheduler de connaître ce nombre de tentatives en cas d'échec du système pendant la transaction.

  • À la fin d'une transaction Lorsque la séquence des processus professionnels termine une transaction, l'état de la planification doit être mis à jour afin de permettre la restauration si nécessaire. Cette mise à jour s'effectue dans le contexte de la transaction afin de garantir l'atomicité de la base de données de persistance.

Voir aussi

Mise en attente et réalimentation

Gestion des instances

Gestion de l'état de session


Mise en attente et réalimentation

Si plusieurs instances d'une planification XLANG fonctionnent simultanément pendant une longue période, il peut devenir impossible de les maintenir toutes en mémoire. Pour résoudre ce problème, le moteur de XLANG Scheduler offre une infrastructure de mise en attente/réalimentation.

Lorsque le moteur de XLANG Scheduler prévoit qu'une instance de planification XLANG va attendre un message pendant une longue période, et qu'aucune autre activité n'a lieu dans la planification, il peut décider de mettre en attente l'instance de planification XLANG. La mise en attente d'une instance de planification XLANG consiste à sauvegarder la totalité de l'état spécifique de l'instance dans la base de données de persistance et à supprimer l'instance de la mémoire. Lorsqu'un message arrive à une adresse de port correspondant à l'instance de planification XLANG mise en attente, l'instance est réalimentée. La réalimentation d'une instance de planification XLANG consiste à restaurer l'instance dans la mémoire, à partir de la base de données.

Une instance de planification XLANG reste en attente jusqu'à ce qu'elle soit réalimentée ou explicitement terminée par un administrateur. Ce système permet à un processus professionnel de fonctionner de manière fiable pendant une longue période.

Le moteur de XLANG Scheduler peut utiliser un paramètre de latence pour déterminer un délai pendant lequel une action peut rester inactive avant que l'instance de planification XLANG soit mise en attente dans la base de données de persistance. Le moteur de XLANG Scheduler utilise ce paramètre de latence pour mettre en attente l'instance de planification XLANG dans la base de données de persistance, puis la réalimente ultérieurement lors de l'arrivée du message. Toutefois, dans certaines situations, présentées ci-après, le paramètre de latence ne provoquera pas la réalimentation d'une planification.

  • L'instance de planification ne se trouve pas dans un état de repos. Cette situation peut se produire lorsque des actions sont en cours d'exécution sur un des flux de processus courants dans l'instance de planification XLANG. Tous les flux de processus dans l'instance de planification doivent être dans le même état avant que le moteur de XLANG Scheduler mette en attente l'instance de planification XLANG. Le temps de latence pour toutes les actions en attente doit être supérieur à un seuil donné, avant l'exécution de la mise en attente.

  • Il y a des transactions de style DTC en attente. Le moteur de XLANG Scheduler ne mettra pas la planification en attente si celle-ci exécute une transaction de style DTC, car les transactions de ce type sont généralement des transactions de courte durée.

  • L'instance contient des ports actifs qui ne peuvent pas être sauvegardés dans la base de données de persistance. Un port actif est un objet de port ou un port qui a été implémenté et qui peut être utilisé ultérieurement dans l'instance de planification. La durée de vie d'un port est un paramètre important lors de l'exécution d'une instance de planification. Les ports sont liés à des technologies d'implémentation, telles que des interfaces COM. Si la technologie d'implémentation à laquelle un port est lié ne peut pas être sauvegardée dans la base de données de persistance, et si la technologie d'implémentation contient des informations d'état réutilisées ultérieurement, l'instance ne peut pas être mise en attente, puis réalimentée. En cas d'échec puis de fonctionnement ultérieur de la base de données de persistance, les informations d'état seront perdues et l'exécution de l'instance de planification ne pourra pas reprendre à partir de l'état de celle-ci lors de sa dernière mise en attente.

Lors de l'arrêt du moteur de XLANG Scheduler, un maximum d'informations sont enregistrées dans la base de données de persistance, notamment toutes les informations ne figurant pas dans un contexte transactionnel.

Voir aussi

Gestion des instances

Gestion de l'état de session

Persistance

Utilisation de l'Assistant Communication de méthodes

Utilisation de l'Assistant Communication XML


Gestion des données

Dans XLANG, toutes les données sont contenues dans un ensemble de messages nommés de manière univoque. De nouvelles données entrent dans une instance de planification XLANG lorsqu'un message est reçu par une action.

Chaque schéma de planification XLANG possède une page Données. La page Données vous permet de décrire le flux de données dans une planification XLANG. Pour indiquer que les données d'un champ de message se dirigent vers un autre champ de message, tracez une flèche depuis le champ de message source jusqu'au champ de message de destination.

À l'exception du message de constantes, aucun des champs des messages de la page de données ne contient de valeur initiale. Le message de constantes est initialisé avec les valeurs indiquées à la page de données. Il est automatiquement initialisé pour chaque nouvelle instance de planification XLANG. Pour plus d'informations sur l'utilisation des constantes, voir Message de constantes. Les valeurs des autres messages affichés sont définies lorsque chaque message est envoyé ou reçu dans l'instance de planification XLANG. Un message peut être reçu par plusieurs actions. Chaque fois qu'un message est reçu, les valeurs de ce message sont remplacées. Le flux des données dans le message reçu n'est pas utilisé pour définir les valeurs d'un autre message reçu, même si le message est envoyé en un autre endroit de la planification XLANG. Les messages envoyés de manière exclusive se basent sur le flux de données affiché à la page Données pour définir leurs champs de messages. La compilation d'une planification n'a pas lieu tant que tous les champs de tous les messages envoyés n'ont pas été définis.

Lorsqu'un champ de la page de données issu d'un champ XPath se réfère à un noeud facultatif du schéma XML, observez les points suivants :

  • Pour les messages reçus lorsque le noeud facultatif existe Si ce message est reçu et que le noeud facultatif existe dans le document XML, le champ XPath stocke la valeur du noeud.

  • Pour les messages reçus lorsque le noeud facultatif n'existe pas Si ce message est reçu et que le noeud facultatif n'existe pas, le champ XPath stocke une valeur NULL. Vous devrez utiliser une règle Décision avec l'expression VBScript IsNull (Message.Champ) sur ce champ pour déterminer si le message reçu contient le noeud facultatif. Si vous ne contrôlez pas l'existence d'une valeur, et que ce champ fournit un flux de données vers un autre message envoyé, une erreur se produit lorsque le moteur de XLANG Scheduler essaie de créer le message à envoyer.

  • Pour les messages envoyés lorsque le noeud facultatif existe Si ce message (avec le noeud XPath dirigé vers un noeud XML facultatif) est envoyé, le moteur de XLANG Scheduler se base sur le flux de données pour créer le message. Si le noeud existe dans le champ Document du message, le moteur de XLANG Scheduler le remplace par la valeur du noeud XPath.

  • Pour les messages envoyés lorsque le noeud facultatif n'existe pas Si ce message (avec le noeud XPath dirigé vers un noeud XML facultatif) est envoyé, le moteur de XLANG Scheduler se base sur le flux de données pour créer le message. Si le noeud n'existe pas dans le champ Document fourni, le moteur de XLANG Scheduler ne crée pas le noeud à remplacer. Dans ce cas, une erreur survient.

Pour les messages à recevoir de ou à envoyer vers une file d'attente de messages, observez les points suivants :

  • Pour les messages reçus Si une action reçoit un message non-XML depuis une file d'attente de messages, vous devez sélectionner Recevoir les messages de chaîne de la file d'attente à la page Informations sur l'interprétation XML de l'Assistant Communication XML. Dans cette configuration, la forme Message de la page Données affiche un nouveau champ StringData. Le champ StringData contient le message non-XML reçu de la file d'attente. Le champ Document du message contient le champ StringData, entouré par le wrapper XML standard du moteur de XLANG Scheduler.

  • Pour les messages envoyés Si une action envoie un message non-XML vers une file d'attente de messages, vous devez sélectionner Envoyer des messages à la file d'attente sous forme de chaîne à la page Informations sur l'interprétation XML de l'Assistant Communication XML. Dans cette configuration, la forme Message de la page Données affiche un nouveau champ StringData. Pour terminer cette configuration, vous devez créer une nouvelle constante (contenant le wrapper XML standard du moteur de XLANG Scheduler) dans le message de Constantes à la page Données. Le nom de cette constante est sans importance, mais le type de données doit être string, et la valeur de la constante doit être : <?xml version="1.0" ?> <StringData> </StringData>. Après avoir créé cette nouvelle constante, vous devez tracer une connexion de flux de données depuis la nouvelle constante du message de Constantes vers le champ Document de la forme Message. Vous devez également tracer une connexion de flux de données depuis le champ contenant la chaîne non-XML vers le nouveau champ StringData de la forme Message.

Remarques

  • La direction du flux de données est indépendante de celle du flux des messages. Le flux des messages indique si un message est envoyé ou reçu.

  • Pour permettre à la planification XLANG de recevoir des données à l'aide d'un appel de méthode sans instanciation du composant, sélectionnez Aucune instanciation à la page Communication statique ou dynamique de l'Assistant Liaison de composants COM ou script. Si vous sélectionnez Aucune instanciation, le composant n'est pas instancié et aucun code n'est exécuté pour l'appel de méthode. Au lieu de cela, lorsque la planification XLANG intercepte les informations de requête de méthode, elle renvoie ces informations en tant que réponse. L'appel de méthode est évité.

  • Si un message est utilisé uniquement dans le corps d'une boucle Tant que, les valeurs du message ne sont pas initialisées à chaque itération de la boucle. Si un message est utilisé à la fois à l'intérieur et à l'extérieur du corps d'une boucle Tant que, les valeurs du message sont conservées lors de chaque itération de la boucle. Il se peut également que les valeurs du message soient conservées avant et après que la séquence des processus professionnels atteindra la forme Tant que.

  • Si un message est initialisé dans une transaction Compensation pour ou En cas d'échec de dans une boucle Tant que, les valeurs du message ne sont pas disponibles à l'extérieur de la boucle.

  • Si un champ d'un message XML (notamment le message de constantes) avec un type de données char fournit un flux de données vers un champ de message de méthode, le champ est converti en un type integer pour la méthode. Si le champ de message de méthode possède un type de données string, la chaîne contient la valeur entière, et non le caractère. Si vous rencontrez ce problème, et que le champ source fait partie du message de constantes, modifiez le type de données du champ des constantes en string. Si le champ source fait partie d'un message XML, vous devrez utiliser un composant pour modifier le type de données char en type string.

Cette section traite des rubriques suivantes :

  • Page de données

  • Messages de constantes

  • Message références des ports

  • Types de données de champs

  • Champs système

  • Champs du chemin d'accès au noeud


Page de données

Chaque schéma de planification XLANG possède une page de données. La page de données affiche :

  • Une forme de message pour chaque message de la planification XLANG.

  • Un message de Constantes.

  • Un message Port References contenant un champ pour chaque port du schéma de planification XLANG.

  • Un diagramme des connexions illustrant le flux des données entre les champs de messages.

Les messages se composent d'un ensemble de champs à nom unique, chaque champ contenant une donnée d'un type spécifique. Chaque message de la planification XLANG est affiché dans la page de données sous la forme d'une table. Chaque table affiche le nom du message ainsi qu'une liste des noms de champs et leurs types de données correspondants. Les champs système qui ne requièrent pas de flux de données sont affichés avec un arrière-plan de couleur jaune. Les champs utilisateur et les champs système qui ne requièrent pas de flux de données sont affichés avec un arrière-plan de couleur blanche.

Les connexions affichées sur la page de données relient le côté droit d'un champ de message source au côté gauche d'un champ de message de destination. Cette connexion indique que le champ du message source fournit les données nécessaires au champ du message de destination. Au moment de l'exécution, le moteur de XLANG Scheduler copie les données depuis le champ du message source vers le champ du message de destination lorsque le message de destination doit être créé. Une erreur d'exécution se produit si le message source n'arrive pas à destination.

Remarques

  • Les types de données suivants ne sont pas pris en charge sur la page de données :
    • BinHex

    • BinBase64

    • I8

    • UI8

Si vous avez un noeud dans un document XML de type BOOL, BinHex, BinBase64, I8 ou UI8, et que vous spécifiez que ce noeud doit être inclus dans le champ d'application du moteur de XLANG Scheduler sur la page de données, en utilisant le XPath vers ce noeud, celui-ci sera converti en une chaîne.

  • Tous les noms de champ des planifications XLANG sont limités à 100 caractères.

Voir aussi

Messages de constantes

Gestion des données

Types de données de champs

Champs du chemin d'accès au noeud

Message références des ports

Champs système


Messages de constantes

Vous pouvez utiliser le message de Constantes pour initialiser une instance de planification XLANG avec des données. Le message de Constantes effectue une fonction unique au sein du moteur de XLANG Scheduler : il n'est ni envoyé ni reçu. Il est automatiquement initialisé pour chaque nouvelle instance de planification XLANG. Pour ajouter une constante au message de Constantes, double-cliquez sur ce message ou double-cliquez sur l'un de ses champs pour ouvrir la boîte de dialogue Propriétés des messages de constantes. Cliquez sur Ajouter dans la boîte de dialogue Propriétés des messages de constantes afin d'ouvrir la boîte de dialogue Propriétés des constantes. La boîte de dialogue Propriétés des constantes vous permet de nommer la constante, de choisir un type de données pour la constante, et d'affecter une valeur à la constante.

Remarque

  • XML ne manipule pas les paramètres locaux de Windows pour le formatage des dates. Si vous voulez affecter une date à une constante dans un format local, définissez le type de données de la constante à la valeur string. Si cette constante fournit des données à un champ avec un type de données date, le moteur de XLANG Scheduler convertit la chaîne en une date, conformément au format local.

Voir aussi

Gestion des données

Page de données

Types de données de champs

Champs du chemin d'accès au noeud

Message références des ports

Champs système


Message références des ports

Le message Références des ports contient la liste de tous les ports créés sur la page Processus professionnel. Une nouvelle référence est ajoutée à la liste chaque fois qu'un nouveau port est ajouté sur la page Processus professionnel. Le message Références des ports vous permet de spécifier l'origine des emplacements des ports. Le message Références des ports contient un champ pour chaque port du schéma de planification XLANG.

Dans certains scénarios, les ports d'une planification XLANG ne sont pas connus au moment de la conception. Cela peut se produire si la destination ou l'origine des messages est déterminée à partir du contenu des autres messages. Par exemple, il se peut qu'un processus professionnel décrive une situation dans laquelle une action doit répondre à un message avec un accusé de réception vers le partenaire commercial d'origine. Dans cet exemple, le message reçu contiendra généralement un champ adresse-de-réponse avec l'adresse d'origine du message. La planification XLANG doit être capable de corréler le contenu du champ adresse-de-réponse avec l'adresse de destination du message d'accusé de réception. Vous pouvez utiliser le message Références des ports et un message d'accusé de réception sur la page de données pour implémenter ce scénario. Pour plus d'informations sur l'échange de messages, Intégration des services BizTalk.

Important

  • Les actions des différentes ramifications d'une branche ne peuvent pas communiquer les unes avec les autres. Par exemple, une action d'une branche donnée ne peut pas envoyer de message vers une file d'attente si une action d'une autre branche attend de recevoir un message de cette même file d'attente. Si vous concevez de manière incorrecte votre schéma de planification XLANG pour la prise en charge de toutes les communications entre les actions des différentes ramifications, il se peut que l'instance de planification XLANG échoue au moment de l'exécution ; toutefois, aucun message d'erreur ne sera affiché.

Voir aussi

Messages de constantes

Gestion des données

Types de données de champs

Champs du chemin d'accès au noeud

Champs système


Types de données de champs

Le Concepteur d'Orchestration BizTalk affiche tous les types de données avec leur nom de type de données XML. Les équivalents Automation OLE, Visual Basic et C des noms des types de données XML affichés sont présentés au tableau suivant.

Vue UI XML | OLE Automation | Visual Basic | C
types simples |  |  |
boolean | VT_BOOL | Boolean | VARIANT_BOOL
string | VT_BSTR | String | BSTR
cy | VT_CY | Currency | CURRENCY
date | VT_DATE | Date | DATE
dispatch | VT_DISPATCH | Object | IDispatch
error | VT_ERROR |  | SCODE
i1 | VT_I1 |  | signed char
i2 | VT_I2 | Integer | SHORT
i4 | VT_I4 | Long | LONG
int | VT_INT |  | INT
r4 | VT_R4 | Single | FLOAT
r8 | VT_R8 | Double | DOUBLE
ui1 | VT_UI1 | Byte | BYTE
ui2 | VT_UI2 |  | USHORT
ui4 | VT_UI4 |  | ULONG
uint | VT_UINT |  | UINT
unknown | VT_UNKNOWN | Object | IUnknown
variant | VT_VARIANT | Variant | VARIANT

Voir aussi

Messages de constantes

Gestion des données

Page de données

Champs du chemin d'accès au noeud

Message références des ports

Champs système


Champs système

Chaque message peut également contenir un ensemble de champs système qui sont automatiquement créés par le moteur de XLANG Scheduler.

Nom du champ système | Quand ce champ système est-il affiché ? | Description
__Status__ | Lors de la réception du message depuis un port lié à une liaison COM ou de script | HRESULT de l'appel de méthode
__Sender__ | Lors de l'envoi ou de la réception du message depuis n'importe quel port | Lorsqu'un message est reçu, il s'agit du SenderID fourni par Message Queuing ou COM. Lorsque ce message est envoyé, la valeur est NULL.
Document | Lors de l'envoi ou de la réception du message depuis un port qui est lié à Message Queuing ou au Gestionnaire d'échanges BizTalk | Chaîne contenant le corps du message envoyé ou reçu

Voir aussi

Messages de constantes

Gestion des données

Types de données de champs

Champs du chemin d'accès au noeud

Message références des ports


Champs du chemin d'accès au noeud

Lorsqu'un port lié à Message Queuing ou au Gestionnaire d'échanges BizTalk reçoit un document XML, vous pouvez inclure des noeuds spécifiques du document dans le champ d'application des données du moteur de XLANG Scheduler. Si aucun noeud spécifique n'est sélectionné, le moteur de XLANG Scheduler traite le document XML comme une chaîne opaque dans le champ système du document.

Pour inclure des noeuds du document dans le champ d'application des données du moteur de XLANG Scheduler, vous pouvez utiliser la page Informations sur le message de l'Assistant Communication XML. Lorsque vous fournissez une spécification XML, les boutons Ajouter et Supprimer sont activés.

Voir aussi

Messages de constantes

Gestion des données

Types de données de champs

Message références des ports

Champs système

Utilisation de l'Assistant Communication XML


Création de schémas de planification XLANG

La conception d'une planification XLANG nécessite cinq tâches :

  • Dessiner une représentation du processus professionnel que la planification XLANG devra exécuter. Utiliser des formes Diagramme de flux pour décrire le flux du processus professionnel sur le côté gauche de la page de conception. Votre processus professionnel principal figure sur la page Processus professionnel. Les processus de remplacement figurent sur les pages Compensation pour Transaction et En cas d'échec de Transaction.

  • Définir des règles pour les décisions de branchement et les processus répétés au sein du processus professionnel ; définir des processus concurrents et concevoir les transactions et les transactions subordonnées requises dans le processus professionnel.

  • Créer les implémentations de ports requis par le processus professionnel. Quatre technologies d'implémentation sont disponibles : composants COM, composants Windows Scripting, services de Message Queuing et services d'échanges BizTalk.

  • Définir le flux de données entre les messages. Tous les flux de données entre les messages sont tracés sur la page de données.

  • Dessiner tous les processus professionnels nécessaires en cas d'échec de transactions. Les processus professionnels de remplacement figurent sur les pages Compensation pour Transaction et En cas d'échec de Transaction.

Remarque

  • Vous pouvez ajouter des formes Diagramme de flux et Implémentation dans les pages Processus professionnel, Compensation pour Transaction et En cas d'échec de Transaction. Ces formes ne sont pas disponibles sur la page Données.

Cette section traite des rubriques suivantes :

  • Conception de processus professionnels

  • Gestion des exceptions

  • Implémentation de processus professionnels


Conception de processus professionnels

Dans le Concepteur d'Orchestration BizTalk, la partie gauche de la page Processus professionnel est la zone dans laquelle vous pouvez concevoir des processus professionnels. Une barre de séparation divise la page Processus professionnel en une zone de conception de processus professionnels du côté gauche, et une zone d'implémentation du côté droit.

Cette section traite des rubriques suivantes :

  • Conception d'actions

  • Conception de règles

  • Conception concurrentielle

  • Conception de transactions


Conception d'actions

La séquence des processus professionnels doit s'écouler depuis la forme Début vers la première forme Diagramme de flux de votre schéma de planification XLANG. Généralement, la première forme Diagramme de flux de votre schéma de planification XLANG sera une forme Action.

Une forme Début possède deux propriétés configurables. Dans la boîte de dialogue Propriétés de début, vous pouvez configurer la propriété Modèle de transaction pour déterminer si les formes Transaction sont prises en charge dans une instance de planification XLANG, ou si la planification XLANG est activée à partir d'un composant COM transactionnel. La première option active la prise en charge des formes Transaction ; la seconde option désactive la prise en charge des formes Transaction.

La boîte de dialogue Propriétés de début vous permet également de configurer les propriétés Activation de la transaction et Identité XLANG. Pour plus d'informations sur l'activation des transactions, voir Conception de transactions.

La propriété Identité XLANG est une propriété en lecture seule. Elle contient un identificateur global unique (GUID) qui est utilisé pour corréler une version du schéma de planification XLANG avec la planification XLANG générée. Le GUID est généré automatiquement lorsqu'un nouveau schéma est créé, et un nouveau GUID est généré chaque fois que le schéma de planification XLANG est modifié.

La seule propriété configurable pour une forme Action est le nom de l'action. Le nom de l'action ne peut excéder 32 caractères. Les noms des actions n'ont aucun effet sur le comportement de la planification XLANG.

Voir aussi

Conception concurrentielle

Conception de règles

Conception de transactions

Formes Diagramme de flux


Conception de règles

Les règles sont des expressions Microsoft Visual Basic Scripting Edition (VBScript), utilisées par les formes Décision et Tant que. Les règles peuvent être :

  • des expressions VBScript intrinsèques, telles que Date et Time ;

  • des expressions qui évaluent des données dans un champ de message ;

  • des expressions qui peuvent déterminer si un message existe.

Une règle contient les propriétés suivantes qui définissent le comportement de la forme :

  • Nom de la règle Il s'agit d'une propriété obligatoire, affichée sur le schéma de planification XLANG dans la forme qui utilise la règle. Le nom de la règle identifie la règle de manière univoque. Une règle unique et nommée de manière univoque peut être utilisée dans plusieurs formes Décision et Tant que. La largeur de la forme Décision ou Tant que qui utilise la règle est déterminée par la règle contenue dans la forme dont le nom est le plus long.

  • Description de la règle. Il s'agit d'une propriété facultative, décrivant la règle.

  • Expression de script. Il s'agit d'une expression VBScript obligatoire qui se réfère aux données contenues dans les messages. Cette expression possède soit la valeur TRUE soit la valeur FALSE.

Pour concevoir un schéma de planification XLANG, vous devez créer des règles et leur fournir un nom ainsi qu'une description. Pour ajouter des formes Implémentation au schéma, vous devez ajouter des expressions de script.

Remarques

  • La propriété Expression de script est obligatoire uniquement lors de la compilation du schéma de planification XLANG en une planification XLANG.

  • Le champ de message __Exists__ n'est pas affiché dans les messages sur la page Données. Ce champ peut être utilisé pour vérifier l'existence d'un message. L'existence d'un message est déterminée par le fait que le message a été reçu ou envoyé par le moteur de XLANG Scheduler.

Voir aussi

Création de règles

Conception d'actions

Conception concurrentielle

Conception de transactions

Formes Diagramme de flux

Définition des conditions de décision


Conception concurrentielle

Le Concepteur d'Orchestration BizTalk prend en charge les actions concurrentes. Les formes Branche et Jointure sont utilisées pour implémenter des flux de processus simultanés au sein d'une planification XLANG. Vous pouvez utiliser la forme de Branche pour créer des flux de processus simultanés, et la forme de Jointure pour synchroniser tous les flux de processus simultanés qui ne se terminent pas par une forme Fin.

Propriétés des jointures

La forme de Jointure possède deux propriétés que vous pouvez définir. Ces propriétés représentent les opérateurs logiques suivants :

  • AND. La planification XLANG attend que tous les flux de processus aient atteint la jointure avant de passer à l'action suivante du processus professionnel.

  • OR. La planification XLANG attend que le premier flux de processus ait atteint la jointure avant de passer à l'action suivante du processus professionnel.

    Les actions des autres ramifications de la branche vont terminer leurs processus ; toutefois, la jointure OR n'attend pas que ces processus soient terminés. Si le flux de processus qui sort d'une jointure OR comprend une action qui requiert un flux de données issu d'une branche entrant dans la jointure OR et dont l'action n'est pas encore terminée au moment où l'action qui sort de la jointure est exécutée, une erreur est produite.

Flux valides de processus de jointures et de branches

Observez les points suivants lors de la conception de flux simultanés dans un processus professionnel :

  • Tous les flux comprenant des branches doivent soit se terminer par une forme de Fin, soit être synchronisés en un flux unique à l'aide d'une forme de Jointure.

  • Les actions contenues dans des flux comprenant des branches ne peuvent pas communiquer entre elles. Par exemple, une action d'une branche donnée ne peut pas envoyer de message vers une file d'attente si une action d'une autre branche attend de recevoir un message de cette même file d'attente.

    Attention

    • Si vous concevez de manière incorrecte votre schéma de planification XLANG pour la prise en charge des communications entre les actions des différentes branches, il se peut que l'instance de planification XLANG échoue au moment de l'exécution ; toutefois, aucun message d'erreur ne sera affiché.
  • Vous ne pouvez pas utiliser de jointure pour synchroniser des flux issus de plusieurs branches. La forme de Jointure ne peut être utilisée que pour synchroniser des flux issus d'une branche correspondante. Il existe une correspondance de type un-à-un entre l'utilisation de la forme de Branche et celle de la forme de Jointure.

    L'illustration ci-dessous présente deux branches utilisées pour créer des flux simultanés, ainsi qu'une jointure unique utilisée dans une tentative de synchronisation de ces flux. Cette connexion n'est pas valide. Si vous tentez ce type de connexion, vous obtiendrez un message d'erreur lors de la compilation de la planification XLANG.

    Cliquer sur l'image pour l'agrandir ou la réduire.

    Flux simultanés joints d'une manière non valide

    Figure 1. Flux simultanés utilisant une jointure non valide

    Deux exemples de jointures valides sont présentés ci-après.

    Dans l'illustration 2, deux branches correspondent à deux jointures. La deuxième paire branche/jointure est imbriquée dans la première paire branche/jointure.

    Cliquer sur l'image pour l'agrandir ou la réduire.

    Flux simultanés joints d'une manière valide

    Figure 2. Flux simultanés utilisant une correspondance de type un-à-un entre les branches et les jointures, et utilisant des paires branche/jointure imbriquées

    Dans l'illustration 3, deux branches correspondent à deux jointures. La deuxième paire branche/jointure est imbriquée dans la première paire branche/jointure. Remarquez que même si un flux simultané dans la deuxième paire branche/jointure se termine par une forme Fin, l'autre flux simultané doit toujours être synchronisé par une jointure correspondante avant que son flux puisse être synchronisé avec le flux simultané issu de la première paire branche/jointure.

    Cliquer sur l'image pour l'agrandir ou la réduire.

    Flux simultanés joints d'une manière valide

    Figure 3. Flux simultanés utilisant une correspondance de type un-à-un entre les branches et les jointures, et utilisant des paires branche/jointure imbriquées ainsi qu'une forme Fin pour terminer un flux

  • Lorsque vous synchronisez plusieurs flux simultanés avec une jointure OR, chaque flux de processus qui entre dans la jointure ne peut contenir qu'une seule action. Si un flux contient plusieurs actions, le flux n'est pas valide.

    L'illustration suivante présente une jointure OR synchronisant plusieurs flux simultanés. Chaque flux contient une seule action.

    Cliquer sur l'image pour l'agrandir ou la réduire.

    Flux simultanés joints d'une manière valide

Voir aussi

Conception d'actions

Conception de règles

Conception de transactions

Formes Diagramme de flux

Définition des propriétés de simultanéité


Conception de transactions

Le Concepteur d'Orchestration BizTalk fournit un modèle de programmation transactionnel, incluant la gestion d'erreur et la récupération des transactions après un échec. Vous pouvez configurer des formes Transaction pour créer deux types de pages supplémentaires dans le Concepteur d'Orchestration BizTalk : la page En cas d'échec de Transaction et la page Compensation pour Transaction. Ces deux pages permettent aux processus professionnels de récupérer des transactions après un échec. Les pages En cas d'échec de Transaction et Compensation pour Transaction peuvent contenir des formes Transaction faisant référence à d'autres pages En cas d'échec de Transaction et Compensation pour Transaction. Les pages En cas d'échec de Transaction et Compensation pour Transaction peuvent utiliser les mêmes formes Port et Implémentation affichées à la page Processus professionnel.

Les transactions courtes conçues à l'aide du Concepteur d'Orchestration BizTalk possèdent les quatre attributs ACID. ACID est un acronyme composé des propriétés suivantes :

  • Atomicité Une transaction représente une unité atomique de travail. Soit toutes les modifications d'une transaction sont effectuées, soit aucune modification n'est effectuée.

  • Cohérence Une fois validée, une transaction doit préserver l'intégrité des données dans le système. Si une transaction effectue une modification de données dans une base de données dont la cohérence interne était assurée avant le démarrage de la transaction, cette cohérence doit être conservée lorsque la transaction est validée. La garantie de cette propriété incombe en grande partie au développeur de l'application.

  • Isolement Les modifications effectuées par des transactions concurrentes doivent être isolées des modifications effectuées par les autres transactions. Les transactions isolées qui sont exécutées simultanément effectuent des modifications préservant la cohérence interne de la base de données exactement comme si ces transactions étaient effectuées en série.

  • Durabilité Lorsqu'une transaction est validée, toutes les modifications apportées au système sont permanentes. Les modifications subsistent même en cas d'échec du système.

Au contraire, les transactions de longue durée sacrifient l'isolement à la possibilité de gérer des opérations qui nécessitent une longue période d'exécution.

Cette section traite des rubriques suivantes :

  • Propriétés des transactions d'un schéma de planification XLANG

  • Propriétés des transactions pour des formes de transaction spécifiques

  • Propriétés des transactions pour une implémentation de port

  • Transactions de longue durée

  • Transactions de courte durée

Voir aussi

Conception d'actions

Conception concurrentielle

Conception de règles

Formes Diagramme de flux

Définition des propriétés de transaction


Propriétés des transactions d'un schéma de planification XLANG

Pour afficher la boîte de dialogue Propriétés de début, cliquez avec le bouton droit sur la forme Début de la page Processus professionnel et cliquez sur Propriétés. La boîte de dialogue Propriétés de début vous permet de configurer les propriétés suivantes :

  • Modèle de transaction. La valeur par défaut de cette propriété est Inclure des transactions dans la planification.
    • Choisissez Inclure des transactions dans la planification si vous voulez englober une collection d'actions groupées dans une forme Transaction au sein de votre schéma de planification XLANG. Le choix de cette option désactive la propriété Activation de la transaction.

    • Choisissez Traiter la planification XLANG en tant que composant COM+ si vous voulez qu'un composant COM+ active votre planification XLANG dans son contexte transactionnel COM+. Si vous choisissez cette option, vous ne pourrez pas inclure de transactions dans votre schéma de planification XLANG, et votre utilisation de la forme de Branche pour l'implémentation de la concurrence devra être limitée. Si vous utilisez la forme de Branche, toutes les actions contenant des appels à des composants COM+ devront êtres limitées à une simple branche sortante. Cette restriction ne s'applique pas si les actions de votre schéma de planification XLANG contiennent des appels à des composants COM. Aussi, toutes les modifications transactionnelles doivent être effectuées sur une seule branche sortante.

      Le choix de cette option active la propriété Activation de la transaction.

  • Activation de la transaction La valeur par défaut de cette propriété est Non pris en charge.
    • Non pris en charge Cette sélection indique que la planification XLANG ne prend pas en charge les transactions.

    • Pris en charge Cette sélection indique que la planification XLANG peut participer à une transaction COM+.

    • Obligatoire Cette sélection indique que la planification XLANG requiert une transaction COM+.

    • Requiert une nouvelle Cette sélection indique que la planification XLANG doit participer à une nouvelle transaction. Si cette option est activée, le moteur de XLANG Scheduler initie automatiquement une nouvelle transaction qui est différente de celle de l'appelant.
  • Identité XLANG Pour plus d'informations sur la propriété Identité XLANG, voir Formes Diagramme de flux.

Voir aussi

Conception de transactions

Transactions de longue durée

Transactions de courte durée

Propriétés des transactions pour une implémentation de port

Propriétés des transactions pour des formes de transaction spécifiques


Propriétés des transactions pour des formes de transaction spécifiques

Pour afficher la boîte de dialogue Propriétés de la transaction, cliquez avec le bouton droit sur la forme Transaction de la page Processus professionnel et cliquez sur Propriétés. La boîte de dialogue Propriétés de la transaction vous permet de configurer les propriétés suivantes :

  • Type Cette propriété définit le type de transaction utilisé pour la forme Transaction sélectionnée. La valeur par défaut de cette propriété est Style DTC, courte.
    • Choisissez Style DTC, courte si vous voulez que la transaction regroupe un ensemble d'actions effectuées comme une seule unité logique de travail possédant les quatre propriétés d'une transaction ACID. Pour plus d'informations sur les transactions, voir Conception de transactions. Les transactions de ce type sont indiquées en gris ombré sur la page de conception. Cette option est disponible pour les transactions imbriquées et les transactions autonomes. Vous ne pouvez pas appliquer cette option à une transaction externe contenant une transaction imbriquée.

    • Choisissez Longue si vous voulez que la transaction regroupe un ensemble d'actions qui envoient et reçoivent des messages sur une période de temps indéterminée. Vous pouvez également configurer une transaction longue de manière à regrouper un ensemble de transactions imbriquées ; toutefois, les transactions sont limitées à deux niveaux d'imbrication. Les transactions de longue durée sont indiquées en jaune ombré sur la page de conception. Cette option est disponible pour toutes les transactions.

    • Choisissez Minutée si vous souhaitez l'abandon de la transaction si celle-ci n'a pas été exécutée après un temps donné. Les transactions minutées sont indiquées en bleu ombré sur la page de conception. Cette option est disponible pour toutes les transactions.
  • Délai Cette propriété définit la durée d'exécution (en secondes) d'une transaction avant son abandon. Cette option est disponible pour les transactions Minutée et Style DTC, courte.

  • Nombre de tentatives Cette propriété définit le nombre d'exécutions d'un processus dans une transaction Style DTC, courte si le processus n'est pas terminé. À chaque tentative, l'état de l'application est réinitialisé au point de départ du processus dans la transaction.

  • Intervalle Cette propriété définit l'intervalle entre chaque tentative de la transaction. L'intervalle est utilisé avec la valeur du nombre de tentatives pour déterminer le délai avant la prochaine tentative de la transaction. La valeur de l'intervalle est exponentielle. Une valeur d'intervalle de 2 secondes correspond à un délai de 2, 4, 8, 16 secondes, et ainsi de suite, entre les tentatives. La formule est B**R (B élevé à la puissance R), où B = intervalle et R = nombre de tentatives. Si l'intervalle d'une tentative de transaction spécifique est supérieur à 180 secondes, l'instance de planification XLANG est immédiatement mise en attente dans la base de données de persistance.

  • Niveau d'isolation Le niveau d'isolation détermine dans quelle mesure les données des transactions concurrentes sont accessibles les unes par rapport aux autres. Cette option est disponible uniquement pour les transactions de type Style DTC, courte. Choisissez :
    • Serializable pour empêcher les transactions concurrentes de modifier les données avant la fin de la transaction sélectionnée. Il s'agit du niveau d'isolation le plus restrictif parmi les quatre niveaux disponibles.

    • Read Uncommitted pour autoriser les transactions concurrentes à modifier les données avant la fin de la transaction sélectionnée. Il s'agit du niveau d'isolation le moins restrictif parmi les quatre disponibles.

    • Read Committed pour empêcher la transaction sélectionnée d'accéder aux modifications de données des transactions concurrentes avant qu'elles aient été validées. Cette option est définie par défaut dans Microsoft SQL Server.

    • Repeatable Read pour requérir des verrous de lecture jusqu'à la fin de la transaction sélectionnée.
  • En cas d'échec Cliquez sur Ajouter un code, cochez la case Activé, puis cliquez sur OK pour afficher la page En cas d'échec de Transaction. Vous pouvez utiliser la page En cas d'échec de Transaction pour concevoir un processus professionnel de remplacement en cas d'échec de la transaction sélectionnée. Cette option est disponible pour toutes les transactions.

  • Compensation. Cliquez sur Ajouter un code, cochez la case Activé, puis cliquez sur OK pour afficher la page Compensation pour Transaction. Vous pouvez utiliser la page Compensation pour Transaction pour concevoir un processus professionnel de remplacement destiné à annuler l'unité logique de travail qui a été effectuée dans une transaction imbriquée déjà validée. Cette option est disponible uniquement pour les transactions imbriquées.

Remarque

  • L'abandon d'une transaction imbriquée n'entraîne pas automatiquement celui de la transaction externe. Cela vous permet de concevoir une transaction externe pouvant être récupérée en cas d'échec d'une transaction imbriquée. Toutefois, l'échec d'une transaction imbriquée peut entraîner celui d'une transaction externe si la page En cas d'échec de Transaction ou Compensation pour Transaction de la transaction imbriquée a été conçue pour abandonner la transaction externe.

Voir aussi

Conception de transactions

Transactions de longue durée

Transactions de courte durée

Propriétés des transactions d'un schéma de planification XLANG

Propriétés des transactions pour une implémentation de port


Propriétés des transactions pour une implémentation de port

Vous pouvez configurer les propriétés des transactions pour les composants COM et Windows Script aux pages Propriétés avancées du port de l'Assistant Liaison de composants COM et de l'Assistant Liaison de composants de script. La page Propriétés avancées du port fournit une option permettant d'abandonner la transaction en cours lorsqu'une méthode d'un composant renvoie une erreur. La page Propriétés avancées du port vous permet également de configurer les propriétés transactionnelles suivantes :

  • Prise en charge des transactions La propriété Prise en charge des transactions indique dans quelle mesure votre composant va requérir, prendre en charge ou ignorer les transactions.
    • Désactivé Cette option indique que le composant ignore la gestion des transactions COM.

    • Non pris en charge Cette option indique que le composant ne va pas participer à une transaction, ou propager les transactions d'autres composants.

    • Pris en charge Cette option indique que si une transaction contient une action connectée à un port auquel le composant est lié, le composant est inclus dans la transaction. Sinon, le composant n'a pas de transaction.

    • Requiert une nouvelle Cette option indique que si une transaction contient une action connectée au port auquel le composant est lié, le composant est inclus dans la transaction. Si aucune transaction ne contient une action connectée au port auquel le composant est lié, une nouvelle transaction est créée pour le composant.

    • Requiert une nouvelle Cette option indique qu'une nouvelle transaction est toujours créée pour le composant.

Important

  • Le Concepteur d'Orchestration BizTalk se base sur le comportement transactionnel des technologies d'implémentation utilisées dans un schéma de planification XLANG. Il ne fournit ni n'impose aucun comportement transactionnel sur un processus professionnel si le schéma de planification XLANG contient une forme Transaction. Si un composant COM, Message Queue ou Script n'est pas transactionnel, les données manipulées par le schéma de planification XLANG ne seront pas modifiées de manière transactionnelle.

Remarques

  • Si vous définissez la propriété Modèle de transaction de manière à traiter la planification XLANG comme un composant COM, n'utilisez pas de forme Transaction dans le schéma de planification XLANG. Si vous utilisez des formes Transaction, puis essayez de compiler le schéma de planification XLANG en une planification XLANG, le processus de compilation ne fonctionnera pas. Vous devez supprimer toutes les formes Transaction du schéma de planification XLANG avant de le compiler.

  • Si l'utilisation d'un composant COM a lieu dans plusieurs transactions, le composant COM doit, soit ne pas posséder d'état, soit posséder un état et prendre en charge la persistance.

  • Si plusieurs actions communiquent avec un port lié à un composant COM ou de script, et que ces actions figurent dans plusieurs transactions non imbriquées les unes dans les autres, les instances du composant seront détruites et instanciées à nouveau avant chaque nouveau contexte transactionnel. Si le composant possède un état et prend en charge la persistance, la réactivation restaurera cet état. Si le composant possède un état et ne prend pas en charge la persistance, l'état sera perdu. Si le composant a été instancié par une autre application, le moteur de XLANG Scheduler pourra réactiver le composant uniquement si celui-ci est persistant. Si le composant a été instancié par une autre application et n'est pas persistant, le moteur de XLANG Scheduler ne pourra pas instancier à nouveau le composant, et la planification XLANG échouera en générant une erreur.

Voir aussi

Conception de transactions

Transactions de longue durée

Transactions de courte durée

Propriétés des transactions d'un schéma de planification XLANG

Propriétés des transactions pour des formes de transaction spécifiques


Transactions de longue durée

Les transactions de longue durée ne prennent pas en charge l'isolement, qui est un des quatre attributs ACID décrits dans la section Conception de transactions. Les données des transactions longues ne sont pas verrouillées, ce qui signifie qu'elles peuvent être modifiées par les autres processus ou applications. Si vos données doivent être cohérentes, utilisez exclusivement des transactions ACID. Toutefois, les transactions ACID dans un environnement à temps de latence élevé provoquant de sérieux problèmes d'adaptabilité, les schémas de planification XLANG prennent en charge les transactions de longue durée. Les transactions de longue durée permettent d'éviter le verrouillage des bases de données pendant de longues périodes. Au cours d'une transaction de longue durée, les messages sont envoyés et reçus sur une période de temps indéterminée. En fonction des exigences du processus professionnel décrit par votre schéma de planification XLANG, vous pouvez inclure un processus professionnel complet (à l'exception des formes Début et Fin) dans une transaction longue.

D'une manière générale, une transaction de longue durée contient plusieurs transactions de courte durée imbriquées. Par exemple, dans un scénario de transfert électronique simple, une transaction de longue durée peut contenir les actions suivantes dans une transaction de courte durée imbriquée :

  • Retrait d'une somme d'argent d'un compte bancaire

  • Lancement du processus de transfert électronique

L'illustration ci-après présente la transaction Envoi d'argent, une transaction de courte durée imbriquée dans une transaction de longue durée appelée Transfert électronique. La transaction imbriquée contient les deux actions dans le scénario de transfert électronique simple. Une fois l'action Lancement du transfert électronique terminée, la séquence des processus professionnels quitte la transaction imbriquée. Dès lors, la transaction imbriquée est validée ; l'argent a été retiré d'un compte bancaire et envoyé à une destination. À ce stade, la séquence des processus professionnels passe à l'action Attente d'accusé de réception dans la transaction externe.

Cliquer sur l'image pour l'agrandir ou la réduire.

Transaction de longue durée

Dans ce scénario, la transaction Transfert électronique a été configurée comme une transaction minutée. Si l'émetteur n'a pas reçu d'accusé de réception de l'argent dans le délai spécifié, la transaction externe est abandonnée. Dans ce cas, la séquence des processus professionnels passe à la page Compensation pour envoi d'argent pour la transaction imbriquée. Étant donné que la transaction imbriquée a déjà été validée, le processus professionnel suppléant doit décrire des actions pouvant être exécutées afin de créditer le compte de l'émetteur. Une fois que le processus professionnel décrit à la page Compensation pour envoi d'argent a été exécuté, la séquence des processus professionnels passe à la page En cas d'échec du transfert électronique pour la transaction externe. Cette page doit contenir un processus professionnel décrivant la gestion des exceptions pour la transaction externe. Dans ce cas, le processus professionnel pourrait consister à envoyer un courrier électronique de suivi aux participants pour les informer du statut du transfert.

Voir aussi

Conception de transactions

Formes Diagramme de flux

Transactions de courte durée


Transactions de courte durée

Une transaction de courte durée est un ensemble d'actions regroupées et effectuées comme une seule unité logique de travail. Cette unité logique de travail présente les quatre propriétés d'une transaction ACID. Pour plus d'informations sur les transactions, voir Conception de transactions.

Voir aussi

Conception de transactions

Formes Diagramme de flux

Transactions de longue durée


Gestion des exceptions

Le moteur de XLANG Scheduler peut intercepter les erreurs système. Le Concepteur d'Orchestration BizTalk vous permet de concevoir des planifications XLANG qui réagiront à des erreurs d'application au moment de l'exécution. Si vous incluez une partie d'un processus professionnel dans une forme de Transaction, vous pouvez concevoir un processus professionnel alternatif qui s'exécutera si une erreur survient ou si une exigence n'est pas remplie.

Cette section traite des rubriques suivantes :

  • Erreurs système

  • Erreurs d'application

Voir aussi

Définition des propriétés de gestion d'erreurs


Erreurs système

Trois niveaux de gravité d'erreurs système peuvent se présenter lors du fonctionnement du moteur de XLANG Scheduler. Ces trois niveaux sont les suivants, par ordre croissant de gravité :

  • Erreurs susceptibles d'être interceptées dans une planification XLANG .

  • Erreurs susceptibles de provoquer la fin d'une instance de planification XLANG schedule instance.

  • Erreurs susceptibles d'entraîner l'échec du moteur XLANG Scheduler.

Cette section traite des rubriques suivantes :

  • Erreurs susceptibles d'être interceptées dans une planification XLANG.

  • Erreurs susceptibles de provoquer la fin d'une instance de planification XLANG

  • Erreurs susceptibles d'entraîner l'échec du moteur de XLANG Scheduler


Erreurs susceptibles d'être interceptées dans une planification XLANG.

Le moteur de XLANG Scheduler peut intercepter les erreurs système suivantes :

  • Erreurs COM provoquant des échecs de HRESULT, p ar exemple, un message "Accès refusé" en provenance de COM, entraînant un appel de méthode dans une planification XLANG avec une permission inadéquate. Application possible à des liaisons COM ou script

  • Abandons de transactions provoqués par des services inscrits, par exemple le DTC (Distributed Transaction Coordinator) abandonnant une transaction suite à la perte de la connexion avec une base de données. Autre exemple : le service de Message Queuing abandonnant une transaction parce qu'il est incapable de placer un message dans une file d'attente.

Pour gérer un échec de HRESULT à l'aide d'un branchement logique, le message _out issu d'un appel de méthode doit être testé dans une règle de décision. La valeur HRESULT est stockée dans le champ __Status__ du message _out.

Pour gérer un échec de HRESULT à l'aide des processus d'échec de transaction, la propriété Abandonner la transaction si la méthode renvoie un échec de HRESULT doit être définie à la dernière page de l'Assistant Liaison de composants COM ou script. Cette propriété ne peut être définie que si l'action est contenue dans une transaction.

Important

  • Cette option détermine si les transactions dans lesquelles le composant est utilisé doivent être abandonnées lorsque des appels de méthodes sur le composant renvoient un échec de HRESULT. Cette option peut uniquement être définie si l'action de communication utilisant ce port se trouve dans un flux de processus d'une transaction.

La gestion d'un échec dans les technologies d'implémentation Message Queuing ou Échanges BizTalk n'est possible qu'à l'aide des processus d'échec de transaction. Pour cela, vous devez définir la propriété Utiliser des files d'attente de messages transactionnelles à la dernière page de l'Assistant Liaison de Message Queuing (cette opération est automatique dans le cas des Échanges BizTalk).

Remarque

  • Une action d'envoi de Message Queuing qui revient avec succès indique que le message a été correctement placé dans la file d'attente. Cela n'indique pas que le message a été transmis.

Voir aussi

Erreurs d'application

Erreurs susceptibles d'entraîner l'échec du moteur de XLANG Scheduler

Erreurs susceptibles de provoquer la fin d'une instance de planification XLANG

Gestion des exceptions

Erreurs système


Erreurs susceptibles de provoquer la fin d'une instance de planification XLANG

Les erreurs système qui provoquent la fin d'une instance de planification XLANG mais ne peuvent être interceptées dans une planification XLANG sont les suivantes :

  • Une méthode planifiée non synchronisée avec le composant appelé

  • Une file d'attente planifiée inexistante

  • Un canal planifié inexistant

  • Un flux de données d'un message qui n'est pas encore arrivé

Voir aussi

Erreurs d'application

Erreurs susceptibles d'être interceptées dans une planification XLANG

Erreurs susceptibles d'entraîner l'échec du moteur de XLANG Scheduler

Gestion des exceptions

Erreurs système


Erreurs susceptibles d'entraîner l'échec du moteur de XLANG Scheduler

Les erreurs système qui ne peuvent pas être interceptées par le moteur de XLANG Scheduler peuvent provoquer l'échec du moteur de XLANG Scheduler ainsi que celui de toutes les instances de planification XLANG fonctionnant dans la même application COM+. Parmi ces erreurs système, il y a des violations d'accès par composants qui fonctionnent au sein de l'espace de processus du moteur de XLANG Scheduler. Le moteur de XLANG Scheduler va essayer d'intercepter ces erreurs, mais sans succès dans la plupart des cas.

Voir aussi

Erreurs d'application

Erreurs susceptibles d'être interceptées dans une planification XLANG

Erreurs susceptibles de provoquer la fin d'une instance de planification XLANG

Gestion des exceptions

Erreurs système


Erreurs d'application

Il y a trois manières de traiter les erreurs pouvant provoquer des erreurs de planification XLANG :

  • Utilisation de Branchement logique

  • Utilisation de Processus d'abandon transactionnel.

  • Utilisation de Délais.


Branchement logique

Des décisions et règles peuvent être utilisées pour ramifier un flux de processus sur n'importe quelle page de processus (page Processus professionnel ou toute page En cas d'échec de Transaction ou Compensation pour Transaction). L'illustration ci-dessous montre un test simple d'exécution de méthode.

Cliquer sur l'image pour l'agrandir ou la réduire.

Dans cet exemple, le message Clear_out possède un champ système nommé __Status__. Dans la règle HRESULT Success, l'expression du script serait Clear_out.[__Status__] >= 0, où une valeur négative de HRESULT indique un échec, et une valeur positive ou nulle de HRESULT indique un succès. En utilisant de cette manière des décisions et des règles, il est possible de tester la présence d'exceptions dans n'importe quel champ de données de n'importe quel message (dans l'expression VB Script d'une règle quelconque), et pas uniquement pour les valeurs HRESULT.

Voir aussi

Gestion des exceptions

Délais

Processus d'abandon transactionnel


Processus d'abandon transactionnel

Dans le concepteur d'Orchestration BizTalk, vous pouvez utiliser des transactions pour regrouper un ensemble d'actions exécutées sous la forme d'une seule unité logique de travail, et vous assurer que soit toutes les transactions, soit aucune des transactions du groupe sont menées à terme. En regroupant les processus professionnels au sein de transactions, le Concepteur d'Orchestration BizTalk atteint un niveau de structure et de fiabilité maximal.

Le flux des processus d'une transaction s'exécute normalement, jusqu'à ce que la transaction se termine ou qu'un événement d'abandon survienne. Un événement d'abandon peut avoir plusieurs causes :

  • Rencontre d'une forme Abandon dans le flux des processus.

  • Échec de HRESULT défini pour provoquer un abandon dans une liaison de port.

  • Toute technologie de liaison peut, au niveau système, introduire un événement d'échec entraînant l'abandon de la transaction. Par exemple, le placement d'un message dans une file d'attente par Message Queuing peut échouer.

  • Le moteur de XLANG Scheduler peut rencontrer une erreur provoquant l'abandon d'une transaction dans une instance donnée. Il peut par exemple s'agir d'une erreur DTC.

  • La mise en attente d'une planification peut nécessiter l'abandon de toutes les transactions de cette planification.

  • Présence d'un délai dans les propriétés des transactions.

En cas d'abandon, une transaction peut reprendre depuis le début, en fonction de la valeur de la propriété Nombre de tentatives du groupe de transactions. Si, après le nombre de tentatives spécifié, l'exécution de la transaction échoue encore, le système fait appel au processus professionnel En cas d'échec de Transaction. Ce code En cas d'échec de Transaction permet de structurer la gestion de l'échec d'une transaction.

Le code En cas d'échec de Transaction ne doit annuler aucun travail au sein de la transaction. Si les ports sont liés à des ressources transactionnelles, le DTC (Distributed Transaction Coordinator) gère la restauration de toutes les actions listées au sein de la transaction. Les ressources non transactionnelles ne sont pas restaurées. Si la transaction est imbriquée dans une transaction externe, et si cette transaction imbriquée a déjà été validée, la séquence des processus professionnels passe au processus professionnel Compensation pour Transaction pour la transaction imbriquée. Le processus professionnel Compensation pour Transaction est décrit à la page Compensation pour Transaction. Ce processus professionnel de remplacement doit contenir des actions pouvant servir à annuler le travail au sein de la transaction imbriquée.

Lorsque le code Compensation pour Transaction ou En cas d'échec de Transaction a été exécuté, la séquence des processus professionnels quitte le bas de la forme Transaction à la page Processus professionnel. Les actions de la séquence des processus professionnels qui se produisent après une transaction ne reçoivent pas d'indication explicite de la fin ou de l'abandon de la transaction. Pour permettre une telle indication explicite, vous pouvez définir un indicateur dans un champ de message à la page En cas d'échec de Transaction ou Compensation pour Transaction.

Voir aussi

Gestion des exceptions

Branchement logique

Délais


Délais

Si une action dans une transaction ne reçoit pas un message attendu en provenance d'un partenaire commercial, cet échec est traité comme une erreur d'application. Pour tester ce type d'erreur, utilisez des transactions minutées.

Par exemple, dans un scénario de transfert électronique simple, une transaction minutée peut contenir les actions suivantes dans une transaction imbriquée :

  • Retrait d'une somme d'argent d'un compte bancaire

  • Lancement du processus de transfert électronique

L'illustration suivante présente la transaction Envoi d'argent, une transaction imbriquée dans une transaction minutée appelée Transfert électronique. La transaction imbriquée contient les deux actions dans le scénario de transfert électronique simple. Une fois l'action Lancement du transfert électronique terminée, la séquence des processus professionnels quitte la transaction imbriquée. Dès lors, la transaction imbriquée est validée ; l'argent a été retiré d'un compte bancaire et envoyé à une destination. À ce stade, la séquence des processus professionnels passe à l'action Attente d'accusé de réception dans la transaction externe.

Cliquer sur l'image pour l'agrandir ou la réduire.

Transaction de longue durée

Dans ce scénario, la transaction Transfert électronique a été configurée comme une transaction minutée. Si l'émetteur n'a pas reçu d'accusé de réception de l'argent dans le délai spécifié, la transaction externe est abandonnée. Dans ce cas, la séquence des processus professionnels passe à la page Compensation pour envoi d'argent pour la transaction imbriquée. Étant donné que la transaction imbriquée a déjà été validée, le processus professionnel suppléant doit décrire des actions pouvant être exécutées afin de créditer le compte de l'émetteur. Une fois que le processus professionnel décrit à la page Compensation pour envoi d'argent a été exécuté, la séquence des processus professionnels passe à la page En cas d'échec du transfert électronique pour la transaction externe. Cette page doit contenir un processus professionnel décrivant la gestion des exceptions pour la transaction externe. Dans ce cas, le processus professionnel pourrait consister à envoyer un courrier électronique de suivi aux participants pour les informer du statut du transfert.

Voir aussi

Gestion des exceptions

Branchement logique

Processus d'abandon transactionnel


Implémentation de processus professionnels

Le stencil d'implémentation contient quatre formes qui correspondent aux technologies pouvant être utilisées pour implémenter un port dans un processus professionnel. Étant donné que chaque action envoie un message vers un port ou reçoit un message en provenance d'un port, la signification sémantique de l'envoi ou de la réception des messages varie en fonction de la technologie d'implémentation spécifique.

L'utilisation des formes Implémentation comprend deux processus distincts. Dans le premier processus, un port est lié à une technologie d'implémentation. De manière conceptuelle, un port est un emplacement abstrait vers lequel un message est envoyé ou depuis lequel un message est reçu. Lier le port à une implémentation définit le type d'emplacement auquel le port est lié. Dans le second processus, une action est connectée au port. Ce processus définit le schéma du message qui est envoyé vers ou reçu depuis le port.

Le Concepteur d'Orchestration BizTalk prend en charge quatre technologies d'implémentation :

  • Composants COM Cette technologie permet la communication synchrone.

  • Composants Windows Scripting Cette technologie permet la communication synchrone.

  • Services Message Queuing Cette technologie permet la communication asynchrone.

  • Services d'Échanges BizTalk Cette technologie permet la communication asynchrone.

La barre de séparation divise la page de conception du Concepteur d'Orchestration BizTalk en une zone de conception de processus professionnels du côté gauche, et une zone d'implémentation du côté droit. Pour ouvrir un assistant de liaison de port, déplacez une des formes Implémentation sur la page de conception, à droite de la barre de séparation. Vous pouvez effectuer cette tâche sur la page Processus professionnel, sur la page En cas d'échec de Transaction, et sur la page Compensation pour Transaction.

Remarque

  • Vous ne pouvez pas configurer une enveloppe dans le Concepteur d'Orchestration BizTalk. Par conséquent, si vous voulez soumettre un fichier plat au Concepteur d'Orchestration BizTalk, utilisez l'Éditeur BizTalk pour convertir le contenu du fichier plat en XML. Vous pourrez ensuite soumettre le fichier XML au Concepteur d'Orchestration BizTalk.

Cette section traite des rubriques suivantes :

  • Description des implémentations de ports

  • Communication synchrone et asynchrone


Description des implémentations de ports

Un port est un emplacement nommé qui utilise une implémentation spécifique. Dans une planification XLANG, les ports facilitent les communications synchrones et asynchrones et sont utilisés pour transmettre des messages vers ou depuis la planification.

Dans le Concepteur d'Orchestration BizTalk, un port est défini par l'emplacement vers lequel les messages sont envoyés ou à partir duquel les messages sont reçus, ainsi que par la technologie utilisée pour implémenter l'action de communication. Les ports sont liés à gauche aux actions dans le flux des processus professionnels de la planification XLANG, et à droite à une technologie d'implémentation qui peut être utilisée pour faciliter l'action requise. L'emplacement est identifié de manière univoque par le nom du port.

L'emplacement d'un port dépend en partie de la technologie utilisée pour implémenter le port. Le tableau suivant présente les implémentations de ports disponibles ainsi que l'emplacement associé à chaque implémentation.

Implémentation du port | Emplacement du port
Composant COM | Un pointeur vers une instance activée d'un objet
Composant Windows Script | Un pointeur vers une instance activée d'un objet
Message Queuing | Un nom de chemin d'accès de file d'attente vers une file d'attente de messages
Échanges BizTalk | Un nom de canal pour un canal spécifique d'Échanges BizTalk

Il existe deux types de ports :

  • Ports statiques Un port statique nécessite que toutes les informations relatives à l'emplacement et à l'implémentation du port soient fournies au moment de la conception pour une planification XLANG. Le concepteur qui crée la planification XLANG doit connaître l'emplacement vers lequel les messages sont envoyés ou à partir duquel les messages sont reçus, ainsi que la technologie choisie pour implémenter l'action de communication.

  • Ports dynamiques Un port dynamique nécessite que des informations spécifiques sur l'emplacement du port soient fournies au moment de l'exécution pour une planification XLANG. Le choix de l'implémentation d'un port dynamique s'effectue au moment de la conception, mais l'emplacement de ce port n'est pas connu avant l'exécution de la planification XLANG. L'emplacement d'un port dynamique est fourni par un message qui transmet les informations relatives à cet emplacement à la référence du port. Ce message doit parvenir en un point du flux de processus de la planification XLANG avant que la communication qui utilise cette implémentation de port puisse être utilisée.

    Si vous voulez utiliser un port dynamique pour une communication, et que la planification XLANG n'a pas encore reçu de message contenant la référence du port lorsque la planification tente d'effectuer l'action, une erreur est générée.

Tant les ports statiques que les ports dynamiques fournissent des options pour les communications synchrones et asynchrones, mais les implémentations de ports pour ces communications diffèrent en fonction de la technologie utilisée pour implémenter le port.

Tout port peut être soit statique soit dynamique ; cependant, tous les ports ne peuvent pas implémenter des communications synchrones et asynchrones. Pour créer une action de communication synchrone, vous devez utiliser une implémentation de port de composant COM ou script. Pour créer une action de communication asynchrone, vous devez utiliser une implémentation de port de type Message Queuing ou Échanges BizTalk.

Cette section traite des rubriques suivantes :

  • Ports statiques et dynamiques

  • Utilisation de la forme Composant COM

  • Utilisation de la forme composant de script

  • Utilisation de la forme Message Queuing

  • Utilisation de la forme Échanges BizTalk

Voir aussi

Communication synchrone et asynchrone


Ports statiques et dynamiques

Le comportement des ports statiques et dynamiques varie en fonction du type d'implémentation utilisée.

Implémentations de ports utilisant des composants COM ou script

Dans le cas d'une implémentation de port utilisant des composants COM ou script, les propriétés statiques et dynamiques déterminent le mode d'instanciation d'un composant :

  • Statique Dans le cas d'une planification XLANG qui utilise un port statique, le moteur de XLANG Scheduler instancie le composant qui est défini pour cette implémentation de port.

  • Dynamique. Dans le cas d'une planification XLANG qui utilise un port dynamique, le moteur de XLANG Scheduler n'instancie pas le composant. Au lieu de cela, la planification XLANG attend qu'une autre application instancie le composant. L'instance d'objet doit être renvoyée à la planification XLANG sous la forme d'un champ dans un message. Sur la page Données, une connexion doit être établie entre ce champ de message et la référence du port utilisant cette implémentation. La planification XLANG intercepte à la fois la requête de méthode ainsi que la réponse de la méthode issue du composant.

En plus des options Statique et Dynamique, il existe un troisième choix :

  • Aucune instanciation Dans le cas d'une planification XLANG qui utilise un port sans instanciation, le composant n'est pas instancié et aucun code pour l'appel de méthode n'est exécuté. Au lieu de cela, lorsque la planification XLANG intercepte les informations de requête de méthode, elle renvoie ces informations en tant que réponse. L'appel de méthode est évité.

Implémentations de ports utilisant Message Queuing

Dans le cas d'une implémentation de port qui utilise Message Queuing, les propriétés statiques et dynamiques sont représentées sous la forme de files d'attente statiques et dynamiques :

  • File d'attente statique Un port statique utilise une file d'attente statique connue et pré-existante. Vous pouvez affecter cette file d'attente au moment de la conception.

    Si vous utilisez une file d'attente statique, vous pouvez choisir soit d'utiliser une file d'attente connue et qui ne change jamais soit créer une nouvelle instance de la même file d'attente à chaque exécution de la planification XLANG. La file d'attente par instance est identifiée à l'aide d'un ID unique annexé au nom de la file d'attente.

  • File d'attente dynamique Un port dynamique utilise une file d'attente dynamique qui est inconnue au moment de la conception. Les informations relatives à une file d'attente dynamique doivent être fournies au moment de l'exécution dans un champ de message. Sur la page Données, vous devez créer une liaison entre un champ de message et la référence de ce port. Lorsqu'un message contenant le nom de la file d'attente arrive, la planification XLANG peut utiliser la file d'attente affectée. L e message contenant le nom de la file d'attente doit arriver avant que la communication qui utilise cette implémentation de port puisse être utilisée.

Implémentations de ports utilisant Échanges BizTalk

Dans le cas d'une implémentation de port qui utilise Échanges BizTalk, les propriétés statiques et dynamiques sont représentées sous la forme de canaux statiques et dynamiques. Les canaux dynamiques ne peuvent être utilisés que lors de l'envoi de messages. Ils ne peuvent pas servir à la réception de messages.

  • Canal statique Un port statique utilise un canal statique connu et pré-existant. Vous pouvez affecter ce canal, qui ne variera jamais, au moment de la conception.

  • Canal dynamique Un port dynamique utilise un canal dynamique qui est inconnu au moment de la conception. Les informations relatives à un canal dynamique doivent être fournies au moment de l'exécution dans un champ de message. Sur la page Données, vous devez créer une liaison entre un champ de message et la référence de ce port. Lorsqu'un message contenant le nom du canal arrive, la planification XLANG peut utiliser le canal affecté. Le message contenant le nom du canal doit arriver avant que la communication qui utilise cette implémentation de port puisse être utilisée.

Un port qui utilise un canal dynamique permet à une planification XLANG de déterminer quel canal utiliser au moment de l'exécution, plutôt que d'imposer la définition d'un canal pré-existant au moment de la conception. Cette propriété définit l'identité du canal utilisé lorsque la planification XLANG transmet le message aux services d'échanges BizTalk.

Il ne faut pas confondre un canal dynamique avec un canal ouvert qui est configuré dans le Gestionnaire d'Échanges BizTalk. Un canal ouvert permet la détermination de l'organisation source au moment de l'exécution à partir des informations contenues dans le document ou dans les paramètres soumis avec celui-ci. Cette propriété définit la source des documents. Pour plus d'informations sur les canaux ouverts, voir Description des canaux.

Le message transmis à un port utilisant un canal dynamique peut spécifier soit un canal ouvert soit un canal non ouvert lors de la transmission des informations sur le canal aux services d'échanges BizTalk.

Voir aussi

Implémentation de ports

Communication synchrone et asynchrone

Description des canaux

Utilisation de la forme Échanges BizTalk

Utilisation de la forme Composant COM

Utilisation de la forme Message Queuing

Utilisation de la forme composant de script


Utilisation de la forme Composant COM

La forme Composant COM vous permet d'utiliser des composants ou applications pré-existants pour effectuer des actions dans une planification XLANG. La technologie COM étant synchrone, le flux de messages est toujours bidirectionnel lors de l'exécution d'une action. À l'opposé, le flux de messages pour une technologie asynchrone est unidirectionnel.

Le moteur de XLANG Scheduler prend en charge l'envoi et la réception des messages par le biais de l'utilisation des formes Action. Lorsque vous liez un port à un composant COM dans le Concepteur d'Orchestration BizTalk, le port est lié à une interface implémentée par un composant COM qui a été enregistré sur votre système.

Une action d'envoi connectée au port représente l'invocation d'un appel de méthode spécifique par le moteur de XLANG Scheduler. Les paramètres IN et IN/OUT sont envoyés au port. En retour, un message avec un schéma défini par les paramètres IN/OUT et OUT de l'appel de méthode est reçu depuis le port. L'appel de méthode est pris en charge par l'interface liée au port.

Une action de réception connectée au port attend qu'une application externe effectue un appel de méthode sur le port. Les paramètres IN et IN/OUT définissent le schéma du message reçu par le port ; les paramètres IN/OUT et OUT définissent le schéma du message envoyé depuis le port.

Pour chaque action connectée à un port et liée à un composant COM, deux messages sont échangés. Les messages identifient la méthode sur l'interface invoquée. Le schéma des messages correspond aux paramètres IN et IN/OUT (et aux paramètres IN/OUT et OUT) de la signature de la méthode. La bibliothèque de types pour les composants étant accessible, le Concepteur d'Orchestration BizTalk peut générer automatiquement le schéma de ces messages sans demander l'information à l'utilisateur.

Important

  • Utilisez les composants COM avec prudence lorsque vous implémentez un processus professionnel à exécution longue. Si vous utilisez des composants contenant un état dans une planification XLANG, nous vous recommandons d'utiliser des composants pouvant être enregistrés à l'aide de l'interface IPersist. De cette manière, la planification XLANG peut enregistrer son état en même temps que celui des composants. Les planifications XLANG doivent être capables de posséder un état et de fonctionner pendant une longue période. Si vous utilisez des composants qui ne possèdent pas d'état, une nouvelle instance du composant est créée lors de chaque réalimentation de la planification XLANG. Toutefois, l'utilisation de composants ne possédant pas d'état ne devrait pas affecter le résultat de la planification.

La liaison correspond au processus consistant à spécifier la technologie d'implémentation d'un port. L'Assistant Liaison de composants COM se compose des cinq pages suivantes :

Bienvenue dans l'Assistant Liaison de composants COM

La page Bienvenue dans l'Assistant Liaison de composants COM vous permet de créer et de nommer un port pour lequel vous voulez définir une implémentation.

Communication statique ou dynamique

La page Communication statique ou dynamique vous permet de définir le mode d'instanciation du composant. Le tableau suivant présente les paramètres de la communication statique et de la communication dynamique.

Communication statique ou dynamique | Description
Statique | Sélectionnez cette option si vous pouvez fournir au moteur de XLANG Scheduler toutes les informations requises pour effectuer l'implémentation au moment de la création.
Curseur dynamique | Sélectionnez cette option si le moteur de XLANG Scheduler requiert d'autres informations au moment de l'exécution pour effectuer l'implémentation.
Aucune instantiation | Sélectionnez cette option pour permettre à la planification XLANG de recevoir des données via un appel de méthode sans activer le composant. Lorsque vous choisissez Aucune instanciation, les appels de méthode à ce composant sont interceptés, le moteur de XLANG Scheduler stocke les arguments, et l'appel est renvoyé à l'appelant. Le composant n'est jamais instancié.

Informations sur les classes

La page Informations sur les classes vous permet de sélectionner une classe à partir de la liste des composants enregistrés ou d'un moniker.

Informations sur l'interface

Dans la page Informations sur l'interface, vous pouvez sélectionner l'interface à utiliser. Cette page ne s'affiche que si la classe sélectionnée contient plusieurs interfaces. Les composants Visual Basic possèdent toujours une seule interface.

Informations sur la méthode

Dans la page Informations sur la méthode, vous pouvez sélectionner les méthodes à utiliser. Cette page ne s'affiche que si la classe sélectionnée contient plusieurs méthodes.

Propriétés avancées du port

Dans la page Propriétés avancées du port, vous pouvez configurer la sécurité, la prise en charge des transactions, la prise en charge de la gestion des états et la gestion d'erreur.

Les propriétés de la prise en charge de la gestion des états de la forme Composant COM comprennent :

  • La persistance de l'état d'une planification XLANG avant le début d'une transaction et après la fin de celle-ci. Cela assure la durabilité et garantit que toutes les modifications de données validées resteront en permanence dans le système. Cela permet également de relancer une transaction en cas de défaillance.

  • L'optimisation de la gestion des instances en permettant au moteur de XLANG Scheduler de mettre en attente puis de réalimenter la planification XLANG lors de l'arrivée du message attendu.

Vous pouvez utiliser la forme Composant COM pour requérir des informations utilisateur authentifiées pour les messages reçus.

Zone Sécurité

Le tableau suivant présente les paramètres de confirmation de l'identité de l'émetteur.

Confirmation de l'identité de l'émetteur | Description
Non requise | Sélectionnez cette option si vous souhaitez que la planification XLANG soit en mesure de recevoir un message sans connaître l'identité de l'émetteur.
Facultatif | Sélectionnez cette option si vous souhaitez que le moteur de XLANG Scheduler identifie l'émetteur lorsque le composant reçoit un message, si cette information est disponible.
Obligatoire | Sélectionnez cette option si vous ne souhaitez pas que le moteur de XLANG Scheduler reçoive de message, sauf s'il peut identifier l'expéditeur.

Zone de prise en charge des transactions

Le tableau ci-dessous présente les paramètres de prise en charge des transactions.

Prise en charge des transactions | Description
Désactivé | Ceci convient pour tous les composants non COM+. Cette option indique que le composant ignore la gestion des transactions COM.
Non pris en charge | Ceci convient uniquement pour les composants COM+. Cette option indique que le composant ne va pas participer à une transaction, ou propager les transactions d'autres composants.
Pris en charge | Ceci convient uniquement pour les composants COM+. Cette option indique que si une transaction est associée à un port auquel le composant est lié, le composant est inclus dans la transaction. Sinon, le composant n'a pas de transaction.
Obligatoire | Ceci convient uniquement pour les composants COM+. Cette option indique que si une transaction est associée à un port auquel le composant est lié, le composant est inclus dans la transaction. S'il n'y a pas de transaction associée au port auquel le composant est lié, une nouvelle transaction est créée pour le composant.
Requiert une nouvelle | Ceci convient uniquement pour les composants COM+. Ceci indique qu'une nouvelle transaction est toujours créée pour le composant.

Zone Prise en charge de la gestion des états

Le tableau suivant présente les paramètres de prise en charge de la gestion des états.

Prise en charge de la gestion des états | Description
Ne possède pas d'état | Cette option spécifie que le moteur de XLANG Scheduler termine l'instance du composant lorsqu'il est en attente. Si vous sélectionnez cette option, le moteur de XLANG Scheduler crée, si nécessaire, une nouvelle instance du composant, lorsque la planification est réalimentée.
Possède un état mais ne prend pas en charge la persistance | Cette option indique que le moteur de XLANG Scheduler est requis pour quitter l'instance du composant en cours d'exécution. En cas d'erreur système lors de la réalimentation de l'application, tout état stocké dans ce composant est perdu.
Possède un état et prend en charge la persistance | Cette option indique que le moteur de XLANG Scheduler supprime l'instance du composant de la mémoire, puis la restaure en mémoire en appelant l'interface IPersistStream ou IPersistStreamInit dans le composant lors de la mise en attente, puis à nouveau lors de la réalimentation.

Zone de gestion d'erreur

Dans la zone Gestion d'erreur, cochez la case Abandonner la transaction si la méthode renvoie un échec de HRESULT si vous voulez que le moteur de XLANG Scheduler abandonne la transaction lorsqu'une erreur est renvoyée d'une méthode dans un composant.

Remarques

  • Lorsqu'une action communique avec un port lié à un composant COM et que la méthode spécifiée n'existe pas dans le composant, l'instance de planification XLANG échoue avec une entrée de journal d'événements.

  • Le Concepteur d'Orchestration BizTalk ne prend pas en charge la liaison à une méthode de composant COM qui contient un paramètre issu de IDispatch. Toutefois, le Concepteur d'Orchestration BizTalk prend en charge la liaison à des méthodes de composants COM qui contiennent des paramètres de type IDispatch.

  • Si une application présente une référence à un composant COM dans une planification XLANG par le biais de l'interface IUnknown, cette référence devient non valide après la mise en attente et la réalimentation de l'instance de planification XLANG. Tous les composants COM persistants seront correctement réalimentés dans l'état où ils se trouvaient au moment de leur mise en attente, mais de nouvelles adresses seront affectées aux interfaces. Il s'agit du comportement normal et attendu. Si deux ou plusieurs champs de messages, dans une quelconque instance de planification XLANG, contiennent des pointeurs vers le même composant COM, et si la planification a été mise en attente, ces champs de messages contiendront des pointeurs vers un composant COM unique après la réalimentation. Toutefois, le composant COM ne sera pas le même que celui d'avant la mise en attente. Il s'agira en effet d'un nouveau composant COM, similaire à celui qui existait avant la mise en attente. Si le composant COM d'origine est persistant, le nouveau composant COM possédera le même état que celui du composant COM d'origine avant la mise en attente.

  • L'unicité des composants n'est pas conservée dans les boucles Tant que. Si un message dans une boucle Tant que contient un champ avec un pointeur vers un composant COM, et qu'un autre message à l'extérieur de la boucle Tant que contient un champ avec un pointeur vers le même composant COM, ces deux champs de messages ne posséderont plus de pointeur vers un composant COM unique après la mise en attente et la réalimentation. Les deux champs de messages posséderont des pointeurs vers deux composants COM distincts, similaires au composant COM d'origine. Si le composant COM d'origine est persistant, les deux nouveaux composants COM posséderont le même état que celui du composant COM d'origine avant la mise en attente.

Voir aussi

Ports statiques et dynamiques

Communication synchrone et asynchrone

Utilisation de la forme Échanges BizTalk

Utilisation de la forme Message Queuing

Utilisation de l'Assistant Communication de méthodes

Utilisation de la forme composant de script


Utilisation de la forme composant de script

La forme Composant de script permet d'utiliser un composant Windows Script pré-existant pour effectuer des actions dans une planification XLANG. La forme Composant de script étant synchrone, le flux des messages est toujours bidirectionnel lors de l'exécution d'une action. À l'opposé, le flux de messages pour une technologie asynchrone est unidirectionnel.

Une action d'envoi connectée au port représente l'invocation d'un appel de méthode spécifique par le moteur de XLANG Scheduler. Les paramètres IN et IN/OUT sont envoyés au port. En retour, un message avec un schéma défini par les paramètres IN/OUT et OUT de l'appel de méthode est reçu depuis le port. L'appel de méthode est pris en charge par l'interface liée au port.

Une action de réception connectée au port attend qu'une application externe effectue un appel de méthode sur le port. Les paramètres IN et IN/OUT définissent le schéma du message reçu par le port ; les paramètres IN/OUT et OUT définissent le schéma du message envoyé depuis le port.

Pour chaque action connectée à un port et liée à un composant script, deux messages sont échangés. Les messages identifient la méthode sur l'interface invoquée. Le schéma des messages correspond aux paramètres IN et IN/OUT (et aux paramètres IN/OUT et OUT) de la signature de la méthode. La bibliothèque de types pour les composants étant accessible, le Concepteur d'Orchestration BizTalk peut générer automatiquement le schéma de ces messages sans demander l'information à l'utilisateur.

Le moteur de XLANG Scheduler attend le retour de la méthode avant de poursuivre le processus professionnel. Pour envoyer un message, le moteur de XLANG Scheduler invoque la méthode spécifiée d'un composant Windows Script.

Pour créer une nouvelle liaison de composant script, déplacez la forme Composant script depuis le stencil d'implémentation vers la page de conception du Concepteur d'Orchestration BizTalk, à droite de la barre de séparation. Pour modifier un composant script existant, cliquez à l'aide du bouton droit sur la forme Composant de script, puis cliquez sur Modifier les propriétés. Ces deux actions provoquent le démarrage de l'Assistant Liaison de composants de script. La liaison correspond au processus consistant à spécifier la technologie d'implémentation d'un port. L'Assistant Liaison de composants script se compose des six pages suivantes :

Assistant Liaison de composants de script

La page Assistant Liaison de composants de script vous permet de créer et de nommer un port pour lequel vous voulez définir une implémentation.

Communication statique ou dynamique

La page Communication statique ou dynamique vous permet de définir le mode d'instanciation du composant. Le tableau suivant présente les paramètres de la communication statique et de la communication dynamique.

Communication statique ou dynamique | Description
Statique | Sélectionnez cette option si vous pouvez fournir au moteur de XLANG Scheduler toutes les informations requises pour effectuer l'implémentation au moment de la création.
Curseur dynamique | Sélectionnez cette option si le moteur de XLANG Scheduler requiert d'autres informations au moment de l'exécution pour effectuer l'implémentation.
Aucune instantiation | Sélectionnez cette option pour permettre à la planification XLANG de recevoir des données via un appel de méthode sans activer le composant. Lorsque vous choisissez Aucune instanciation, les appels de méthode à ce composant sont interceptés, le moteur de XLANG Scheduler stocke les arguments, et l'appel est renvoyé à l'appelant. Le composant n'est jamais instancié.

Sélectionnez le fichier de script

Vous pouvez taper le chemin d'accès du fichier du composant Windows Script (.wsc) à utiliser dans la page Sélectionnez le fichier de script.

Informations sur l'instanciation du composant

La page Informations sur l'instanciation du composant vous permet de spécifier si le moteur de XLANG Scheduler va utiliser un moniker ou un Prog ID pour instancier le composant de script.

Informations sur la méthode

La page Informations sur la méthode vous permet de sélectionner les méthodes qui appartiennent à la classe choisie.

Propriétés avancées du port

Dans la page Propriétés avancées du port, vous pouvez configurer la sécurité, la prise en charge des transactions et la gestion d'erreur. Vous pouvez utiliser la forme Composant de script pour requérir des informations utilisateur authentifiées pour les messages reçus.

Zone Sécurité

Le tableau suivant présente les paramètres de confirmation de l'identité de l'émetteur.

Confirmation de l'identité de l'émetteur | Description
Non requise | Sélectionnez cette option si vous souhaitez que la planification XLANG soit en mesure de recevoir un message sans connaître l'identité de l'émetteur.
Facultatif | Sélectionnez cette option si vous souhaitez que le moteur de XLANG Scheduler identifie l'émetteur lorsque le composant reçoit un message, si cette information est disponible.
Obligatoire | Sélectionnez cette option si vous ne souhaitez pas que le moteur de XLANG Scheduler reçoive de message, sauf s'il peut identifier l'expéditeur.

Zone de prise en charge des transactions

Le tableau ci-dessous présente les paramètres de prise en charge des transactions.

Prise en charge des transactions | Description
Désactivé | Ceci convient pour tous les composants non COM+. Cette option indique que le composant ignore la gestion des transactions COM.
Non pris en charge | Uniquement disponible si le script est installé en tant que composant COM+. Cette option indique que le composant ne va pas participer à une transaction, ou propager les transactions d'autres composants.
Pris en charge | Uniquement disponible si le script est installé en tant que composant COM+. Cette option indique que si une transaction est associée à un port auquel le composant est lié, le composant est inclus dans la transaction. Sinon, le composant n'a pas de transaction.
Obligatoire | Uniquement disponible si le script est installé en tant que composant COM+. Cette option indique que si une transaction est associée à un port auquel le composant est lié, le composant est inclus dans la transaction. S'il n'y a pas de transaction associée au port auquel le composant est lié, une nouvelle transaction est créée pour le composant.
Requiert une nouvelle | Uniquement disponible si le script est installé en tant que composant COM+. Ceci indique qu'une nouvelle transaction est toujours créée pour le composant.

Zone de gestion d'erreur

Dans la zone de gestion d'erreur, cochez la case Abandonner la transaction si la méthode renvoie un échec de HRESULT si vous voulez que le moteur de XLANG Scheduler démarre un processus d'abandon lorsqu'une erreur est renvoyée d'une méthode dans un composant. Cette option doit être sélectionnée pour le moteur de XLANG Scheduler si vous voulez utiliser les pages En cas d'échec de Transaction et Compensation pour Transaction. Si cette option n'est pas sélectionnée, les processus de récupération d'erreur définis sur ces pages ne seront pas exécutés.

Important

  • Lorsque vous utilisez des composants de script Windows, ils doivent respecter les règles suivantes :
    • Les déclarations d'arguments doivent être classées par référence et non par valeur.

    • Les sous-routines Visual Basic Scripting ne sont pas prises en charge. Seules les fonctions sont prises en charge.

    • Vous ne pouvez pas utiliser plusieurs composants dans un seul fichier .wsc.

Remarques

  • Lorsqu'une action communique avec un port lié à un composant de script et que la méthode spécifiée n'existe pas dans le composant de script, l'instance de planification XLANG échoue avec une entrée de journal d'événements.

  • Les composants de script qui ont été exécutés par le moteur de XLANG Scheduler ne peuvent être modifiés jusqu'au moment où le moteur de XLANG Scheduler et le Windows Scripting Host ont été arrêtés.

Voir aussi

Ports statiques et dynamiques

Communication synchrone et asynchrone

Utilisation de la forme Échanges BizTalk

Utilisation de la forme Composant COM

Utilisation de la forme Message Queuing

Utilisation de l'Assistant Communication de méthodes


Utilisation de la forme Message Queuing

La forme Message Queuing permet à une planification XLANG de communiquer avec une autre planification XLANG (ou avec une application), de manière librement couplée, à l'aide d'une file d'attente. Pour permettre la communication entre des planifications XLANG et des applications, les messages sont placés dans une file d'attente, puis lus. Une seule planification XLANG peut utiliser plusieurs ports qui sont liés à la forme Message Queuing.

Lorsqu'un port est lié à la forme Message Queuing, il est également lié à une file d'attente de messages. Le port peut être lié à une file d'attente nommée, ou à une file d'attente par instance. Si un port est lié à une file d'attente par instance, une file d'attente unique est créée et utilisée pour chaque instance de cette planification XLANG. Les files d'attente par instance constituent une solution aisée pour une planification XLANG dans le but d'obtenir une file d'attente séparée pour chaque instance de planification XLANG.

Lorsqu'une action est connectée à un port lié à une file d'attente de messages, l'information suivante est utilisée pour définir le mode de représentation des messages dans la planification :

Le message envoyé ou reçu par l'action doit être défini. Plusieurs types de messages étant stockés dans une file d'attente, le type du message aide à identifier le type de message qui doit être reçu par l'action. Lors d'une action Envoi, le type du message est indiqué sur la propriété d'étiquette du message au moment de son écriture dans la file d'attente.

La forme Message Queuing représente le service Message Queuing qui est utilisé pour envoyer ou recevoir des messages. Pour recevoir un message, le moteur de XLANG Scheduler doit connaître le nom de la file d'attente utilisée ainsi que le nom de l'élément racine du schéma XML contenu dans ce message. Pour envoyer un message, le moteur de XLANG Scheduler doit connaître le nom de la file d'attente utilisée pour la transmission des messages.

Si vous configurez une instance de planification XLANG de manière à utiliser Message Queuing pour la réception des messages, vous pouvez utiliser l'Assistant Communication XML pour spécifier un format de destination de type XML ou chaîne.

Pour créer une nouvelle liaison Message Queuing, déplacez la forme Message Queuing depuis le stencil d'implémentation vers la page de conception du Concepteur d'Orchestration BizTalk, à droite de la barre de séparation. Pour modifier une implémentation Message Queuing existante, cliquez à l'aide du bouton droit sur la forme Message Queuing, puis cliquez sur Modifier les propriétés. Ces deux actions provoquent le démarrage de l'Assistant Liaison de Message Queuing. La liaison correspond au processus consistant à spécifier la technologie d'implémentation d'un port. L'Assistant Liaison de Message Queuing se compose des quatre pages suivantes :

Assistant Liaison de Message Queuing

La page Assistant Liaison de Message Queuing vous permet de créer et de nommer un port pour lequel vous voulez définir une implémentation, ou de choisir un port existant non lié.

Informations sur la file d'attente statique ou dynamique

La page Informations sur la file d'attente statique ou dynamique permet de spécifier si la file d'attente des messages sera définie au moment de la conception ou de l'exécution. Choisissez une des options suivantes :

  • Choisissez File d'attente statique si vous pouvez fournir les informations associées à la file d'attente au moment de la conception.

  • Choisissez File d'attente dynamique si vous voulez que le moteur de XLANG Scheduler reçoive ces informations depuis une source externe au moment de l'exécution afin de déterminer le nom de la file d'attente.

Informations sur la file d'attente

La page Informations sur la file d'attente vous permet de créer une nouvelle file d'attente ou de spécifier une file d'attente existante. Choisissez une des options suivantes :

  • Choisissez Créer une nouvelle file d'attente pour chaque instance si vous voulez que le moteur de XLANG Scheduler crée une file d'attente pour chaque instance de planification XLANG.

  • Choisissez Utiliser une file d'attente connue pour toutes les instances si vous voulez que le moteur de XLANG Scheduler utilise une file d'attente connue.

Propriétés avancées du port

La page Propriétés avancées du port vous permet de configurer la sécurité et de choisir si vous voulez ou non activer la prise en charge des transactions. Vous pouvez utiliser la forme Message Queuing pour requérir des informations utilisateur authentifiées pour les messages reçus.

Zone Sécurité

Le tableau suivant présente les paramètres de confirmation de l'identité de l'émetteur.

Confirmation de l'identité de l'émetteur | Description
Non requise | Sélectionnez cette option si vous souhaitez que la planification XLANG soit en mesure de recevoir un message sans connaître l'identité de l'émetteur.
Facultatif | Sélectionnez cette option si vous souhaitez que le moteur de XLANG Scheduler identifie l'émetteur lorsque le composant reçoit un message, si cette information est disponible.
Obligatoire | Sélectionnez cette option si vous ne souhaitez pas que le moteur de XLANG Scheduler reçoive de message, sauf s'il peut identifier l'expéditeur.

Vous pouvez également activer ou désactiver la case à cocher Utiliser un groupe Windows ou un nom d'utilisateur pour contrôler la file d'attente. Si vous activez cette case à cocher, tapez le nom de l'utilisateur ou du groupe autorisé à écrire des messages dans la file d'attente. Cette option est disponible uniquement lorsque vous utilisez une file d'attente statique.

Zone de prise en charge des transactions

Dans la zone de prise en charge des transactions, sélectionnez la case à cocher Des transactions sont requises avec cette file d'attente pour activer la prise en charge des transactions.

Remarques

  • À l'heure actuelle, le format des noms pris en charge ne permet pas l'activation de l'accès distant à une file d'attente sur un un autre ordinateur. Utilisez les files d'attente publiques à la place des files d'attente privées lorsqu'une planification XLANG communique avec une application sur un ordinateur distant.

  • Lorsqu'une action communique avec un port lié à Message Queueing et que la file d'attente spécifiée pour la liaison n'existe pas, l'instance de planification XLANG échoue avec une entrée de journal d'événements.

  • Il est important que le moteur de XLANG Scheduler soit capable de déterminer si une file d'attente est transactionnelle ou non. Si une file d'attente se trouve dans un contexte transactionnel et qu'un message est envoyé à la file d'attente, le moteur de XLANG Scheduler doit savoir si la transaction doit être utilisée pour communiquer avec la file d'attente. Si la liaison du port est configurée avec la case à cocher Des transactions sont requises avec cette file d'attente activée, la planification XLANG par le moteur de XLANG Scheduler va échouer s'il est déterminé au moment de l'exécution que la file d'attente n'est pas transactionnelle.

Voir aussi

Ports statiques et dynamiques

Communication synchrone et asynchrone

Utilisation de la forme Échanges BizTalk

Utilisation de la forme Composant COM

Utilisation de la forme composant de script

Utilisation de l'Assistant Communication XML


Utilisation de la forme Échanges BizTalk

La forme Échanges BizTalk représente les services d'échanges BizTalk utilisés pour l'échange des messages entre les services d'Orchestration BizTalk Server et les services d'échanges BizTalk. Pour recevoir un message, le moteur de XLANG Scheduler a besoin de connaître l'adresse URL HTTP utilisée par le service d'Échanges BizTalk pour la réception des documents, le nom du canal et le type de message de la définition du document sortant. La réception de documents pour l'activation de la planification XLANG ne nécessite que le type de message de la définition du document. Pour envoyer un message, le moteur de XLANG Scheduler doit connaître le nom du canal et le type de message de la définition du document sortant. Pour plus d'informations sur l'échange de messages entre les services d'Orchestration BizTalk Server et les services d'échanges BizTalk, voir Intégration des services BizTalk.

Important

  • Si vous configurez un port dans le but d'activer une nouvelle planification XLANG lors de l'arrivée d'un message, vous devez respecter les restrictions suivantes :
    • Un seul port d'une planification peut être utilisé pour activer la planification XLANG lors de l'arrivée du message.

    • Une seule action peut être reçue via ce port.

    • Cette action unique ne peut pas se trouver dans le corps d'une boucle.

    • Vous ne pouvez pas tracer de connexion de flux de données depuis la référence du port correspondant à ce port vers tout autre message de la planification.

Pour créer une nouvelle liaison d'Échanges BizTalk, déplacez la forme Échanges BizTalk depuis le stencil d'implémentation vers la page de conception du Concepteur d'Orchestration BizTalk, à droite de la barre de séparation. Pour modifier une implémentation d'Échanges BizTalk existante, cliquez à l'aide du bouton droit sur la forme Échanges BizTalk, puis cliquez sur Modifier les propriétés. Ces deux actions provoquent le démarrage de l'Assistant Liaison d'Échanges BizTalk. La liaison correspond au processus consistant à spécifier la technologie d'implémentation d'un port. L'Assistant Liaison d'Échanges BizTalk se compose des pages suivantes :

Assistant Liaison d'Échanges Biztalk

La page Assistant Liaison d'Échanges Biztalk vous permet de créer et de nommer un port pour lequel vous voulez définir une implémentation, ou de choisir un port existant non lié.

Direction de la communication

La page Direction de la communication vous permet de spécifier si vous voulez configurer le port d'échanges pour l'envoi ou la réception de messages.

Communication statique ou dynamique

La page Communication statique ou dynamique n'apparaît que si vous choisissez Envoi à la page Assistant Liaison d'Échanges Biztalk. La page Communication statique ou dynamique vous permet de spécifier si vous voulez que le moteur de XLANG Scheduler utilise un canal statique défini au moment de la conception, ou un canal dynamique défini lors de l'exécution.

Informations sur l'activation de la planification XLANG

La page Informations sur l'activation de la planification XLANG vous permet de spécifier si une instance de planification XLANG sera activée lors de cette action de réception. Si vous choisissez Oui, l'exécution de l'Assistant Liaison d'Échanges BizTalk se termine. Si vous choisissez Non, la page Informations sur le canal apparaît.

Informations sur le canal

La page Informations sur le canal vous permet d'indiquer le nom du canal, ainsi que l'adresse URL HTTP utilisée par le service d'Échanges BizTalk pour la réception des documents.

Remarques

  • Lorsqu'une action communique avec un port lié à Échanges BizTalk et que le canal spécifié pour la liaison n'existe pas, l'instance de planification XLANG échoue avec une entrée de journal d'événements.

  • Le fait d'inclure des liaisons distinctes d'échanges BizTalk dans une transaction unique peut se traduire par une condition de verrouillage qui provoque l'échec de la transaction.

  • Les événements Action associés aux messages traités par une planification XLANG et qui sont soit envoyés, soit reçus des services d'échanges BizTalk, peuvent être tracés dans la base de données Suivi. Pour plus d'informations, voir Suivi des événements de planification XLANG dans la base de données de suivi.

Voir aussi

Ports statiques et dynamiques

Communication synchrone et asynchrone

Utilisation de la forme Composant COM

Utilisation de la forme Message Queuing

Utilisation de la forme composant de script

Utilisation de l'Assistant Communication XML


Communication synchrone et asynchrone

Toutes les communications vers une implémentation de composant COM ou script sont synchrones. Pour créer un flux de communication vers un port utilisant une implémentation de composant COM ou script, vous devez utiliser l'Assistant Communication de méthodes.

Toutes les communications vers un port non lié, ou vers une implémentation Message Queuing ou Échanges BizTalk sont asynchrones. Pour créer un flux de communication vers un port utilisant une implémentation Message Queuing ou Échanges BizTalk, ou pour créer un flux de communication vers un port non lié, vous devez utiliser l'Assistant Communication XML.

L'illustration et le texte ci-dessous décrivent les opérations effectuées par une planification XLANG pour chacune des quatre actions de communication possibles.

Vue d'ensemble des communications synchrone et asynchrone

Pas
d'attente

Attente

Attente

Attente

2

Action d'envoi asynchrone

Action d'envoi synchrone

Action de réception asynchrone

Action de réception synchrone

1

3

4

4

3

2

1

Attente

Une autre
application

Planification
XLANG

Composant de script ou COM

Message Queuing ou Échanges BizTalk

  1. Action de réception synchrone
    1. La planification XLANG attend qu'une autre application envoie une requête de méthode et instancie un composant.

    2. La planification intercepte la requête de méthode.

    3. La planification attend que le composant renvoie la réponse de la méthode.

    4. La planification intercepte la réponse de la méthode.

    5. La planification passe à l'action suivante dans le flux des processus professionnels.
  2. Action d'envoi synchrone
    1. La planification XLANG initie la requête de méthode et instancie le composant.

    2. La planification attend que le composant renvoie la réponse de la méthode.

    3. La planification reçoit la réponse de la méthode.

    4. La planification passe à l'action suivante dans le flux des processus professionnels.
  3. Action de réception asynchrone
    1. La planification XLANG attend qu'une autre application envoie un message vers une file d'attente de messages ou vers un canal d'Échanges BizTalk.

    2. La planification XLANG reçoit le message depuis la file d'attente de messages ou le canal.

    3. La planification passe à l'action suivante dans le flux des processus professionnels.
  4. Action d'envoi asynchrone
    1. La planification XLANG envoie un message vers une file d'attente de messages ou vers un canal d'Échanges BizTalk.

    2. La planification passe à l'action suivante dans le flux des processus professionnels.

    3. Une autre application reçoit le message depuis la file d'attente de messages ou le canal d'Échanges BizTalk.

Remarques

  • Un cas spécial peut se présenter pour l'action de réception synchrone. Si vous choisissez Aucune instanciation dans l'Assistant Liaison de composants COM ou script, le composant n'est pas instancié et aucun code pour l'appel de méthode n'est exécuté. Au lieu de cela, lorsque la planification XLANG intercepte les informations de requête de méthode, elle renvoie ces informations en tant que réponse. L'appel de méthode est évité. Pour plus d'informations sur les ports statiques et dynamiques, et sur les Assistants Liaison de composants COM et script, reportez-vous aux rubriques suivantes :
    • Ports statiques et dynamiques

    • Implémentation de ports

    • Utilisation de la forme Composant COM

    • Utilisation de la forme composant de script
  • Les événements Action associés aux messages traités par une planification XLANG et qui sont soit envoyés, soit reçus des services d'échanges BizTalk, peuvent être tracés dans la base de données Suivi. Pour plus d'informations, voir Suivi des événements de planification XLANG dans la base de données de suivi.

Cette section contient des informations sur les rubriques suivantes :

  • Utilisation de l'Assistant Communication de méthodes

  • Communication synchrone

  • Utilisation de l'Assistant Communication XML

  • Communication asynchrone

Voir aussi

Implémentation de ports

Ports statiques et dynamiques

Utilisation de la forme Composant COM

Utilisation de la forme composant de script


Utilisation de l'Assistant Communication de méthodes

Dans les pages Processus professionnel, Compensation pour Transaction et En cas d'échec de Transaction, vous pouvez utiliser l'Assistant Communication de méthodes pour définir le flux des messages entre une forme Action et une forme Composant COM ou une forme Composant script. Lors de l'envoi d'un message, la planification XLANG appelle la méthode avec le message _in, puis attend de recevoir le message _out du composant. Si un message doit être reçu, la planification XLANG attend qu'une autre application envoie le message _in à la méthode (en appelant une méthode sur le port), puis attend que le message _out soit renvoyé du composant vers l'autre application.

Remarques

  • Pour les programmeurs en Visual Basic, les paramètres ByVal n'apparaissent que dans le message _in. Tous les autres paramètres apparaissent à la fois dans le message _in et le message _out.

  • Pour les programmeurs en C, les paramètres in apparaissent dans le message _in, les paramètres out apparaissent dans le message _out, et les paramètres in, out apparaissent dans les deux messages.

  • Pour les programmeurs en Visual Basic et C, si un paramètre apparaît à la fois dans le message _in et le message _out, le message _in contient les données envoyées à la méthode, et le message _out contient les données renvoyées par la méthode.

Pour démarrer l'Assistant Communication de méthodes, faites glisser la poignée de droite ( Handle) d'une forme Action vers le point de connexion ( Point de connexion) sur un port lié à une forme Composant COM ou Composant script. L'Assistant Communication de méthodes se compose des trois pages suivantes :

Assistant Communication de méthodes

À la page Assistant Communication de méthodes, vous pouvez spécifier si le moteur de XLANG Scheduler appelle une méthode ou attend un appel de méthode. Si vous spécifiez l'attente d'un appel de méthode par le moteur de XLANG Scheduler, vous pouvez définir un temps de latence en secondes qui indique le délai pendant lequel le moteur de XLANG Scheduler devra probablement attendre avant l'arrivée d'un message. Si cette valeur est inférieure ou égale à 180 secondes, l'instance de planification XLANG ne sera jamais mise en attente dans la base de données de persistance. Si cette valeur est supérieure à 180 secondes, l'instance de planification XLANG sera immédiatement mise en attente dans la base de données de persistance. Par défaut, le temps de latence est égal à zéro, indiquant que le message est supposé arriver immédiatement.

Si une instance de planification XLANG est réalimentée pour une raison quelconque autre que l'arrivée d'un message attendu par une action (et si l'instance de planification XLANG entre ensuite dans un état de repos), la valeur de latence indiquée est utilisée pour déterminer si l'instance de planification doit être ou non immédiatement mise en attente. Par exemple, ceci peut se produire si une branche concurrente reçoit un message qu'elle attendait ou si le redémarrage d'un ordinateur entraîne la réalimentation de toutes les instances de planification XLANG. D ans ce cas, la valeur de latence est évaluée à partir du moment où l'instance de planification XLANG entre dans l'état de repos. Si le délai entre le début de la période d'attente du moteur de XLANG Scheduler (combiné à la valeur de latence) est supérieur à 180 secondes à partir du moment où celui-ci entre en état de repos après la réalimentation, l'instance de planification XLANG sera immédiatement mise en attente dans la base de données de persistance. Ceci peut se produire dans l'instance de planification XLANG longtemps après le début de la surveillance de l'arrivée d'un message par le moteur de XLANG Scheduler.

Informations sur le message

Dans la page Informations sur le message, vous pouvez spécifier si un nouveau message ou une référence à un message existant doit être créé. Si vous spécifiez qu'une référence à un message existant doit être créée, vous pouvez effectuer votre sélection dans une liste de messages précédemment créés et envoyés ou reçus de méthodes, et qui possèdent déjà des formes Message correspondantes. Si le message à utiliser ne figure pas dans la liste, spécifiez qu'un nouveau message doit être créé et définissez le flux de données pour le nouveau message.

Informations sur la spécification du message

La page Informations sur la spécification du message vous permet de sélectionner une spécification pour le message créé ou référencé à la page Informations sur le message.

Voir aussi

Communication asynchrone

Mise en attente et réalimentation

Persistance

Communication synchrone et asynchrone

Communication synchrone

Utilisation de l'Assistant Communication XML


Communication synchrone

Les seules méthodes disponibles pour la communication synchrone sont celles qui ont été sélectionnées pour l'implémentation du port. Les méthodes issues d'autres types d'implémentation de port ne peuvent pas être utilisées, tout comme les messages XML provenant de flux de communications asynchrones. Pour modifier les méthodes disponibles, vous devez réexécuter l'assistant de liaison approprié et sélectionner de nouvelles méthodes.

Les paramètres IN et OUT sont déterminés automatiquement par les spécifications des paramètres de la méthode choisie. Les deux listes de paramètres contiennent le nom et le type de données des paramètres. En plus des paramètres associés à la méthode, un message contient également certains champs système obligatoires. Un message synchrone contient toujours les champs système suivants :

  • __Sender__

    Ce champ système est un paramètre IN obligatoire pour la méthode utilisée dans un message synchrone.

  • __Status__

    Ce champ système est un paramètre OUT obligatoire pour la méthode utilisée dans un message synchrone.

Messages synchrones

Lorsque vous créez une communication synchrone, un Message est créé dans la page Données. Le Message correspond à la méthode et aux paramètres utilisés dans le flux de communication. Le Message contient tous les paramètres IN et OUT pour la méthode.

Il se peut qu'une méthode ne contienne aucun paramètre ; cependant, le Message contient toujours les champs système obligatoires. L'exemple ci-après illustre le schéma du Message :

Method name_in
__Sender__   string
   parameter 1   Data type 1
   parameter 2   Data type 2
   parameter n   Data type n
Method name_out
__Status__   string
   Parameter 1   Data type 1
   Parameter 2   Data type 2
   Parameter n   Data type n

L'illustration suivante indique une paire de messages synchrones contenant les champs système __Sender__ et __Status__, ainsi que les paramètres IN et OUT pour l'appel de méthode.

Paire de messages synchrones contenant un appel de méthode et ses valeurs associées
Method_out
Type de données 3
Type de données 2
Type de données 1
String
Paramètre 2
Paramètre 1
Type de données 2
Type de données 1
Int
_Status_
Paramètre 3
Paramètre 2
Paramètre 1
_Sender_
Method_in

Voir aussi

Mise en attente et réalimentation

Persistance

Communication synchrone et asynchrone

Utilisation de l'Assistant Communication de méthodes


Utilisation de l'Assistant Communication XML

Dans les pages Processus professionnel, Compensation pour Transaction et En cas d'échec de Transaction, vous pouvez utiliser l'Assistant Communication XML pour définir le flux des messages entre une forme Action et une forme Message Queuing, une forme Échanges BizTalk, ou un port non lié. Pour démarrer l'Assistant Communication XML, faites glisser la poignée de droite ( Poignée) d'une forme Action vers le point de connexion ( Point de connexion) sur un port non lié, ou sur un port lié à une forme Message Queuing ou Échanges BizTalk. L'Assistant Communication XML se compose des cinq pages suivantes :

Assistant Communication XML

À la page Assistant Communication XML, vous pouvez spécifier si le port envoie un message vers une action, ou reçoit un message depuis une action. Si vous créez une communication entre une action et un port implémenté à l'aide de la forme Échanges BizTalk, la direction de la communication est déjàconfigurée. Cela se produit lorsque l'Assistant Liaison d'Échanges BizTalk a été utilisé pour créer la liaison du port.

Si le port est configuré pour la réception des messages, vous pouvez définir un temps de latence en secondes qui indique le délai pendant lequel le moteur de XLANG Scheduler attendra l'arrivée d'un message. Si cette valeur est inférieure ou égale à 180 secondes, l'instance de planification XLANG ne sera jamais mise en attente dans la base de données de persistance. Si cette valeur est supérieure à 180 secondes, l'instance de planification XLANG sera immédiatement mise en attente dans la base de données de persistance. Par défaut, le temps de latence est égal à zéro, indiquant que le message est supposé arriver immédiatement.

Si une instance de planification XLANG est réalimentée pour une raison quelconque autre que l'arrivée d'un message attendu par une action (et si l'instance de planification XLANG entre ensuite dans un état de repos), la valeur de latence indiquée est utilisée pour déterminer si l'instance de planification doit être ou non immédiatement mise en attente. Par exemple, ceci peut se produire si une branche concurrente reçoit un message qu'elle attendait ou si le redémarrage d'un ordinateur entraîne la réalimentation de toutes les instances de planification XLANG. D ans ce cas, la valeur de latence est évaluée à partir du moment où l'instance de planification XLANG entre dans l'état de repos. Si le délai entre le début de la période d'attente du moteur de XLANG Scheduler (combiné à la valeur de latence) est supérieur à 180 secondes à partir du moment où celui-ci entre en état de repos après la réalimentation, l'instance de planification XLANG sera immédiatement mise en attente dans la base de données de persistance. Ceci peut se produire dans l'instance de planification XLANG longtemps après le début de la surveillance de l'arrivée d'un message par le moteur de XLANG Scheduler.

Informations sur le message

Dans la page Informations sur le message, vous pouvez spécifier si un nouveau message ou une référence à un message existant doit être créé. Si vous spécifiez la création d'un nouveau message, définissez le flux de données de celui-ci. Pour plus d'informations sur les flux de données, voir Gestion des données. Vous pouvez utiliser la propriété Étiquette d'un message pour optimiser les performances d'une planification de la manière suivante :

  • Si la propriété Étiquette du message est identique à l'élément racine XML spécifié lors de la création d'une nouvelle forme Message, le moteur de XLANG Scheduler récupère le message.

  • Si la propriété Étiquette ne correspond pas à la valeur fournie par l'élément racine XML, le moteur de XLANG Scheduler examine le contenu du message. Si la valeur de l'élément racine XML spécifié lors de la création d'une nouvelle forme Message correspond à l'élément racine XML réel, le moteur de XLANG Scheduler récupère le message. Sinon, le moteur de XLANG Scheduler laisse le message dans la file d'attente et inspecte le message suivant.

Informations sur l'interprétation XML

La page Informations sur l'interprétation XML vous permet de spécifier si vous voulez que les messages soient envoyés vers ou reçus de la file d'attente sous la forme de données formatées XML ou de chaînes de texte. Si vous spécifiez l'envoi des messages sous la forme de chaînes de texte, le wrapper XML standard du moteur de XLANG Scheduler est éliminé des messages.

Informations sur les types de messages

La page Informations sur les types de messages vous permet de spécifier l'étiquette que le moteur de XLANG Scheduler doit utiliser pour identifier les messages du type défini. Le texte que vous tapez va permettre d'identifier les messages corrects reçus de la file d'attente. Si vous sélectionnez le même type de message pour deux messages différents, assurez-vous que les noms des champs, les types des champs et les requêtes XPath correspondent exactement. Le moteur de XLANG Scheduler génère une erreur en cas d'incohérence entre les messages de même type sur un port donné. À la page Informations sur les types de messages, dans la zone Type du message, tapez une désignation d'étiquette pour le message. Le moteur de XLANG Scheduler effectue les procédures suivantes, en fonction des informations fournies :

  • Le moteur de XLANG Scheduler essaie de faire correspondre les informations sur le type de message avec l'étiquette du message dans la file d'attente. Si le type de message ne correspond pas, le message est ignoré, et le moteur de XLANG Scheduler continue à regarder si les nouveaux messages entrants peuvent correspondre. Ce système permet à plusieurs actions de recevoir plusieurs types de messages depuis une même file d'attente de messages.

  • Si le message dans la file d'attente est au format XML, le moteur de XLANG Scheduler essaie de faire correspondre les informations sur le type de message avec l'élément racine XML du message de la file d'attente.

Informations sur la spécification du message

La page Informations sur la spécification du message vous permet de taper le chemin d'accès du fichier de spécification du message (.xml) à utiliser, ou de parcourir les fichiers jusqu'au fichier choisi. Si la spécification du message sélectionnée est une spécification créée à l'aide de l'Éditeur BizTalk, vous pouvez ajouter des champs à l'étendue des données du moteur de XLANG Scheduler. Pour valider la spécification des messages, sélectionnez la case à cocher Valider les messages par rapport à la spécification. Cliquez sur Parcourir à la page Informations sur la spécification du message pour afficher la boîte de dialogue Rechercher une spécification. Utilisez la boîte de dialogue Rechercher une spécification pour trouver la spécification à utiliser.

Si vous n'avez sélectionné aucune spécification, cliquez sur Créer à la page Informations sur la spécification du message pour ouvrir l'Éditeur BizTalk. Si vous avez déjà sélectionné une spécification, cliquez sur Modifier à la page Informations sur la spécification du message pour ouvrir l'Éditeur BizTalk avec la spécification sélectionnée.

Cliquez sur Ajouter à la page Informations sur la spécification du message pour afficher la boîte de dialogue Sélection d'un champ. Dans l'arborescence Sélectionner un noeud de la boîte de dialogue Sélection d'un champ, vous pouvez développer tous les noeuds souhaités, puis cliquer sur le champ à ajouter. Dans la boîte de dialogue Sélection d'un champ, vous pouvez modifier le nom et le chemin d'accès au noeud des champs à ajouter à la forme de message pour le port sélectionné. Les champs de type de données sont affichés, mais ils ne sont pas modifiables.

Remarques

  • La validation n'est disponible que lors de la réception d'un message. Lorsqu'un message est envoyé, la case à cocher de validation est ignorée.

  • Lorsque vous cliquez sur un champ dans l'arborescence Sélectionner un noeud, le nom du champ s'ajoute automatiquement à la zone Nom de champ.

  • Lorsque vous cliquez sur un champ dans l'arborescence Sélectionner un noeud, le chemin d'accès au noeud vers ce champ s'ajoute automatiquement à la zone Chemin d'accès au noeud.

  • La modification manuelle du chemin d'accès au noeud est utile lorsque vous voulez extraire des données spécifiques d'un champ. Par exemple, si le champ contient un tableau, il se peut que vous vouliez extraire juste un élément du tableau et non le tableau entier. Toutefois, nous vous recommandons de limiter la modification manuelle du chemin d'accès au noeud pour votre spécification de message.

  • Vous ne pouvez pas sélectionner un noeud à ajouter à la liste Champs de message. Vous pouvez uniquement sélectionner des champs. Un champ peut également être référencé comme un noeud racine. Par exemple, vous ne pouvez pas sélectionner les noeuds Vendeur ou Adresse car ils contiennent des noeuds feuille. Vous pouvez, par contre, sélectionner les champs Nom et Adresse car ils ne contiennent pas de noeuds supplémentaires.

  • Lors de l'attente de la réception d'un message depuis une file d'attente de messages, certains problèmes (tels que des messages XML non valides ou une authentification insuffisante) provoqueront la création dynamique d'une file d'attente de lettres mortes. La file d'attente de lettres mortes est spécifique à une application COM+. Elle porte le nom de .\private$\ApplicationName.DeadLetter. Par exemple, si un message au format XML non valide arrive dans la file d'attente, et que vous avez spécifié à la page Informations sur l'interprétation XML de l'Assistant Communication XML que le moteur de XLANG Scheduler attend des messages XML de la file d'attente, tous les messages XML non valides seront déplacés vers .\private$\ApplicationName.DeadLetter.

  • Si vous concevez deux planifications XLANG différentes de sorte qu'elles reçoivent des messages distincts de la même file d'attente, il est possible qu'un message soit traité par la mauvaise instance de planification XLANG. Pour éviter ce problème, utilisez une file d'attente de messages pour chaque type de message reçu par une instance de planification XLANG.

Voir aussi

Communication asynchrone

Communication synchrone et asynchrone

Communication synchrone

Utilisation de l'Assistant Communication de méthodes


Communication asynchrone

Un message asynchrone est placé dans une file d'attente de messages ou un canal d'Échanges BizTalk, puis la planification XLANG se poursuit. Aucune réponse n'est attendue.

Les seuls messages disponibles pour une communication asynchrone sont les messages XML. Tous les messages XML peuvent être utilisés, et spécifiés pour plusieurs ports. Vous ne pouvez utiliser aucune des paires de messages synchrones créées à l'aide de l'Assistant Communication de méthodes.

Messages asynchrones

Lorsque vous créez une communication asynchrone, un message est créé dans la page Données. Le message correspond aux informations envoyées ou reçues dans le flux des communications. Le message contient les champs système requis ainsi que tous les champs de spécifications supplémentaires souhaités.

L'exemple ci-après illustre le schéma du Message :

Message name
__Sender__   string
Document   string
   Field 1   Data type 1
   Field 2   Data type 2
   Field n   Data type n

L'illustration suivante présente un message nommé Message_1. Les champs système __Sender__ et Document sont fournis automatiquement et sont présents dans tous les messages asynchrones. Ce message contient également deux champs de spécifications sélectionnés par l'utilisateur.

Message contenant deux champs ajoutés par le système et deux champs de spécification sélectionnés par l'utilisateur
Champ 2
Champ 1
Document
Type de données 1
string
Type de données 2
string
_Sender_
Message_1

Pour ajouter un champ de spécification, vous pouvez utiliser la boîte de dialogue Sélection d'un champ de l'Assistant Communication XML. Dans la boîte de dialogue Sélection d'un champ, sélectionnez un champ de spécification en cliquant sur un noeud de l'arborescence Sélectionner un noeud. Lorsque vous cliquez sur un noeud, le chemin d'accès au noeud est ajouté dans la zone Chemin d'accès au noeud. Vous devez sélectionner un noeud feuille. Un noeud feuille est un noeud sans enfant. Dans l'illustration suivante, le noeud Nom est un noeud feuille, contrairement au noeud Adresse.

Un chemin d'accès de noeud porte également le nom de XPath. Vous pouvez utiliser le chemin d'accès du noeud tel qu'il est sélectionné, ou taper d'autres critères pour le chemin d'accès. Par exemple, si vous sélectionnez un noeud contenant un tableau, il se peut que vous vouliez indiquer un index spécifique dans le tableau à récupérer, plutôt que de récupérer la totalité du tableau.

Remarque

  • Si vous choisissez d'envoyer ou de recevoir un message XML en tant que chaîne, la forme Message créée dans la page Données pour ce message contient un champ nommé StringData, et vous ne pouvez pas ajouter de champs de spécification à ce message.

L'illustration suivante présente la boîte de dialogue Sélection d'un champ.

Cliquez sur l'image pour l'agrandir ou la réduire.

Boîte de dialogue Sélection d'un champ.

Pour plus d'informations sur la sélection des champs de spécification et l'utilisation des chemins d'accès aux noeuds, consultez les rubriques suivantes :

  • Champs du chemin d'accès au noeud

  • Utilisation de l'Assistant Communication XML

  • Envoi ou réception de messages asynchrones

  • Création de spécifications

Voir aussi

Création de spécifications

Mise en attente et réalimentation

Champs du chemin d'accès au noeud

Persistance

Envoi ou réception de messages asynchrones

Communication synchrone et asynchrone

Utilisation de l'Assistant Communication XML


Compilation des planifications XLANG

Lorsqu'un schéma de planification XLANG est terminé, vous pouvez le compiler en une planification XLANG exécutable. Avant de compiler le schéma, assurez-vous que le flux de données entre les messages a été défini à la page de données. Une planification XLANG décrit le processus professionnel ainsi que la liaison de ce processus vers une technologie d'implémentation.

Le Concepteur d'Orchestration BizTalk est conçu pour vous fournir un maximum d'informations utiles en cas de problème lors de la compilation de votre planification XLANG. Lorsque le Concepteur d'Orchestration BizTalk rencontre une erreur, il affiche en surbrillance la forme contenant l'erreur, affiche un message d'erreur et annule la compilation de la planification XLANG.

Pendant la compilation, le Concepteur d'Orchestration BizTalk examine chaque forme et détermine si elle est complète et correcte. Le moteur de XLANG Scheduler traite la forme Début à la page Processus professionnel en premier lieu, puis parcourt de manière récursive la totalité du schéma. Les erreurs rencontrées par le moteur de XLANG Scheduler se produisent généralement lorsque le processus professionnel atteint une forme profondément imbriquée. Pour rendre compte de l'erreur, le moteur de XLANG Scheduler établit un message d'erreur approprié. Puis, lorsque le moteur de XLANG Scheduler remonte la pile, chaque méthode peut concaténer son propre message d'erreur dans le message d'erreur d'origine. Si aucune méthode ne concatène un message d'erreur dans le message d'erreur d'origine, la méthode de compilation de niveau supérieur ajoute le message d'erreur générique suivant : Échec de traitement de la planification XLANG.

La planification XLANG compilée contient un identificateur global unique (GUID) qui correspond à la propriété Identité XLANG de la forme Début. Cette identification peut être utilisée pour corréler une version du schéma de planification XLANG avec la planification XLANG qui l'a généré.

Remarque

  • Il est vivement recommandé de consulter la section Comment... pour obtenir des informations spécifiques sur l'utilisation du Concepteur d'Orchestration BizTalk en vue de la création de schémas de planification XLANG et de leur compilation en des planifications XLANG exécutables.

Voir aussi

Compilation et débogage de planifications XLANG

Compilation d'un schéma de planification XLANG dans une planification XLANG

Débogage des planifications XLANG


Débogage des planifications XLANG

L'Observateur d'événements XLANG est un outil qui vous permet de surveiller les instances de planification XLANG en cours d'exécution. Pour des informations spécifiques sur l'utilisation de l'Observateur d'événements XLANG, consultez le fichier Lisezmoi.htm associé. L'Observateur d'événements XLANG (XLANGMon.exe) et le fichier Lisezmoi installés par l'Assistant Installation de Microsoft BizTalk Server 2000 se trouvent dans le répertoire d'installation suivant : ..\Program Files\Microsoft BizTalk Server\SDK\XLANG Tools.

L'Observateur d'événements XLANG inclut les fonctionnalités suivantes :

  • L'Observateur d'événements XLANG visualise en temps réel le fonctionnement du moteur de XLANG Scheduler.

  • Après l'énumération initiale des planifications en cours d'exécution, l'Observateur d'événements XLANG surveille les événements. L'Observateur d'événements XLANG peut être utilisé pour interrompre et arrêter les instances en cours d'exécution.

  • L'Observateur d'événements XLANG possède une interface utilisateur de type MDI (multiple-document interface) vous permettant d'afficher simultanément plusieurs traces d'instance.

  • Il peut surveiller simultanément des applications sélectionnées sur plusieurs ordinateurs.

  • L'Observateur d'événements XLANG offre des filtres d'enregistrement et d'affichage séparés.

Voir aussi

Compilation et débogage de planifications XLANG

Compilation des planifications XLANG

Surveillance de l'exécution des planifications XLANG

Messages d'erreur des planifications XLANG


Exécution des planifications XLANG

Lors de l'installation du Concepteur d'Orchestration BizTalk, diverses applications COM+ sont installées et configurées dans les Services de composants de Microsoft Windows 2000, notamment l'application COM+ XLANG Scheduler. Cette application héberge une instance par défaut du moteur de XLANG Scheduler. Chaque nouvelle application COM+ créée dans les services de composants possède un onglet XLANG dans la boîte de dialogue des propriétés. Avec l'onglet XLANG, vous pouvez permettre à la nouvelle application COM+ d'héberger le moteur de XLANG Scheduler. L'application COM+ spécifique dans laquelle une nouvelle planification XLANG va s'exécuter peut être déterminée via la syntaxe du moniker utilisé pour activer une instance d'une planification XLANG.

Le moteur de XLANG Scheduler contrôle l'activation, l'exécution, la mise en attente et la réalimentation des instances de planification XLANG en cours d'exécution. Pour activer une planification XLANG, vous pouvez créer une petite application qui transmet le moniker d'une planification XLANG au moteur de XLANG Scheduler. Le moteur de XLANG Scheduler effectue les actions au sein de la planification XLANG et poursuit la séquence du processus professionnel jusqu'à ce qu'il soit nécessaire de mettre en attente la planification XLANG. La mise en attente d'une planification XLANG a lieu lorsque le moteur de XLANG Scheduler prévoit d'attendre plus de trois minutes avant de recevoir un message. Lorsque le message arrive, le moteur de XLANG Scheduler réalimente l'instance de planification XLANG et poursuit les actions de la séquence du processus professionnel jusqu'à la fin de la planification ou jusqu'à ce que le moteur de XLANG Scheduler doive attendre un autre message. Pour prendre en charge la mise en attente, vous devez posséder une base de données de persistance configurée. La bibliothèque réseau recommandée est TCP/IP.

Pour afficher les informations des services de composants de Microsoft Windows 2000, effectuez la procédure suivante :

  1. Dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration et sur Services de composants.

  2. Dans l'arborescence de la console, développez successivement Services de composant, Ordinateurs, Poste de travail et Applications COM+.

L'onglet XLANG de la boîte de dialogue Propriétés des services de composant affiche les options suivantes :

  • Utiliser l'application comme l'hôte des instances de planification XLANG Si cette option est sélectionnée, l'application COM+ peut activer les instances des planifications XLANG. Pour diriger l'activation d'une instance de planification vers une application COM+ particulière, utilisez un formulaire de moniker incluant le nom de l'application. Sélectionnez cette option si vous voulez que l'application serve d'hôte au moteur de XLANG Scheduler.

  • Persistance Cette zone vous permet de configurer Microsoft SQL Server pour la prise en charge de la mise en attente et de la réalimentation des processus professionnels longs :
    • Créer un DSN crée le nom de source de données (DSN) ODBC de l'application COM+ hébergeant le moteur de XLANG Scheduler. Un fichier DSN stocke les informations sur une connexion de base de données. Le fichier possède l'extension .dsn et est enregistré par défaut dans le répertoire $\Program Files\Common Files\ODBC\Data Sources. Cliquez sur le bouton Créer un DSN pour démarrer l'Assistant DSN.

    • Configurer un DSN ouvre l'administrateur de source de données ODBC pour gérer la source de données des planifications XLANG dans cette application COM+.

    • Initialiser les tables crée les tables nécessaires à la prise en charge de la persistance dans la base de données SQL Server définie.

    Important

    • Le nom de source de données configuré dans la boîte de dialogue Propriétés de XLANG Scheduler doit être le même que celui de l'application COM+.
  • Arrêt contrôlé Cette zone vous permet de sélectionner un moyen valide d'arrêter les applications COM+ hébergeant les instances de planification XLANG :
    • Toutes les applications XLANG arrête l'ensemble des applications COM+ hébergeant des instances de planification XLANG en cours d'exécution.

    Remarque

    • Si vous avez sélectionné une application autre que l'application par défaut, l'option Cette application XLANG est affichée.
  • Redémarrer les applications XLANG mises en attente Cette zone vous permet de gérer les applications XLANG mises en attente :
    • Toutes les applications XLANG réalimente l'ensemble des applications COM+ hébergeant des instances de planification XLANG et, si possible, poursuit leur exécution.

Important

  • Ne cliquez pas à l'aide du bouton droit sur l'application COM+ pour arrêter des instances en cours d'exécution d'une planification XLANG. Cela laisserait les composants COM chargés en mémoire au lieu de les décharger correctement. Au lieu de cela, utilisez la zone Arrêt contrôlé de l'onglet XLANG de la boîte de dialogue des propriétés de l'application COM+.

Remarques

  • Si vous utilisez le client pour les services Microsoft Windows 2000 Terminal Server pour initier une planification XLANG, l'application COM+ hébergeant le moteur de XLANG Scheduler doit posséder un nom d'utilisateur ou de groupe Windows 2000 valide. L'identité de l'application COM+ est définie dans la page Identité de la boîte de dialogue des propriétés de cette application. L'identité ne peut être interactive lorsque vous utilisez le moteur de XLANG Scheduler dans une session hébergée par les services Terminal Server.

  • Pour des informations spécifiques sur l'exécution d'une planification XLANG, voir Exécution d'une planification XLANG

Cette section traite des rubriques suivantes :

  • Syntaxe du moniker

  • Création d'une application d'instanciation


Syntaxe du moniker

Les monikers sont utilisés pour créer de nouvelles instances de planification XLANG ou se référer à une instance de planification XLANG existante. Dans l'un ou l'autre cas, vous pouvez vous référer à un port spécifique de l'instance de planification. Les monikers déterminent quelle application COM+ va héberger le moteur de XLANG Scheduler.

Pour créer une nouvelle instance d'une planification XLANG, il faut transmettre un moniker pour la planification XLANG à l'application COM+. L'application COM+ transmet ensuite le moniker au service d'affectation de noms XLANG en vue de sa résolution et active l'instance de planification XLANG avec une instance du moteur de XLANG Scheduler. L'exemple de code ci-après illustre la syntaxe générale des monikers :

sked://[HostName][!GroupManager][/FilePath][/PortName]

Chaque segment de la syntaxe du moniker est facultatif, en fonction du type d'objet à instancier. Le tableau suivant présente chacun de ces segments.

Segment de la syntaxe du moniker | Description | Exemple
HostName | Nom d'hôte de l'ordinateur exécutant le moteur de XLANG Scheduler. Il s'agit également du gestionnaire du système XLANG. Si ce segment est omis, le nom de l'hôte local est utilisé par défaut. Ce nom ne respecte pas la casse. | sked:// sked://MyServer
GroupManager | Gestionnaire de groupe du moteur de XLANG Scheduler utilisé pour la gestion des instances de planification XLANG. Le nom du gestionnaire de groupe est identique à celui de l'application COM+ désignée comme hôte XLANG. Si ce segment est omis, le nom XLANG Scheduler est utilisé par défaut. Ce nom respecte la casse et peut comporter des espaces. | sked:/// sked://AnotherServer!/ sked://AnotherServer!MyGroup/
FilePath | Chemin d'accès vers un fichier de planification XLANG (.skx) à activer. Cette valeur ne respecte pas la casse. | sked://host1!MyGrp/C:\basic.skx sked:///C:\basic.skx
PortName | Nom d'un port lié à un composant COM ou Windows Script sur une planification XLANG. Ce nom respecte la casse. | sked:///C:\basiccom.skx/portA

La syntaxe du moniker peut être utilisée pour se référer à une instance de planification XLANG existante, démarrer une planification XLANG ou établir un canal de communication avec un port particulier de la nouvelle instance de planification XLANG.

Les monikers qui se réfèrent à une instance de planification XLANG sont créés par le moteur de XLANG Scheduler et sont rendus disponibles par la création d'une connexion entre la forme Références du port et les messages envoyés par la planification XLANG. La forme exacte de la référence du port dépend de la technologie d'implémentation liée au port et du type de données du champ de message cible. Les ports liés à Message Queuing ou aux services d'échanges BizTalk ne peuvent être connectés qu'à des champs de type de données String. Le champ cible contient le nom de la file d'attente ou du point d'arrivée du message lié au port dans l'instance de planification XLANG actuelle.

Les ports liés à des composants COM peuvent être connectés à des champs de type de données String, Object ou Unknown. Si le champ cible est de type de données String, un moniker se référant à un port dans l'instance de planification XLANG actuelle est créé. Ce moniker est durable. Il peut être résolu à l'aide de la fonction GetObject et reste valide après un redémarrage du système. Si le champ cible est de type de données Object ou Unknown, une référence COM à l'instance du port est transmise à la forme du message. Si une telle référence est transmise à un composant externe, elle n'est plus valide après un redémarrage du système.

Le moniker permettant de référencer une instance de planification XLANG en cours d'exécution peut être obtenu de l'objet d'instance de planification XLANG, comme indiqué dans le code Microsoft Visual Basic suivant :

Dim oSchedule as IWFWorkflowInstance
Set oSchedule = GetObject("sked:///C:\temp\myschedule.skx")
dim sMoniker as string
sMoniker = oSchedule.FullyQualifiedName

Voir aussi

Création d'une application d'instanciation

Exécution des planifications XLANG


Création d'une application d'instanciation

Une application d'instanciation transmet un moniker pour le fichier de planification XLANG terminé au moteur de XLANG Scheduler en utilisant la fonction COM GetObject. Le code Microsoft Visual Basic ci-après montre comment effectuer cette opération :

Dim objExecute As object
Dim strURL as string

strURL = "sked:///c:\temp\myschedule.skx"

' This enables the XLANG Scheduler Engine to execute the XLANG schedule.
Set objExecute = GetObject(strURL)

Si vous n'avez pas spécifié de port dans le moniker, la propriété Port de l'objet renvoyé par la fonction GetObject permet d'obtenir une référence vers un port qui est lié à un composant COM. De même, la propriété FullPortName permet d'obtenir le nom complet et permanent d'un port lié à une technologie d'implémentation.

Le code ci-dessous montre comment obtenir un proxy vers un port COM ou de script. Cet exemple de code est la suite de l'exemple précédent.

Dim oPort as Object
Set oPort = objExecute.Port("SchedulePortName")
Call oPort.ComponentMethodName(arg1,arg2,...argN)

Remarque

  • Si le port est lié à un objet COM qui ne prend pas en charge une interface duale, la variable oPort doit être déclarée avec la classe appropriée.

Voir aussi

Syntaxe du moniker

Exécution des planifications XLANG


Gestion de l'état de session

La page Propriétés avancées de l'Assistant Liaison de composants COM permet de sélectionner une valeur de gestion d'état pour le niveau de persistance que votre composant COM prend en charge. Dans la zone Prise en charge de la gestion des états, choisissez l'une des options suivantes :

  • Ne possède pas d'état Cette option spécifie que le moteur de XLANG Scheduler termine l'instance du composant lorsqu'il est en veille. Si vous sélectionnez cette option, le moteur XLANG Scheduler crée si nécessaire une nouvelle instance du composant, lorsque la planification est réalimentée.

  • Possède un état mais ne prend pas en charge la persistance Cette option indique que le moteur de XLANG Scheduler est requis pour quitter l'instance du composant en cours d'exécution. En cas d'erreur système lors de la réalimentation de l'application, tout état stocké dans ce composant est perdu.

  • Possède un état et prend en charge la persistance Cette option indique que le moteur de XLANG Scheduler supprime l'instance du composant de la mémoire, puis la restaure en mémoire en appelant l'interface IPersistStream ou IPersistStreamInit dans le composant lors de la mise en attente, puis à nouveau lors de la réalimentation.

Voir aussi

Gestion des instances


Mise à jour des planifications XLANG

Il existe deux manières de mettre à jour une planification XLANG. Vous pouvez remplacer la planification XLANG d'origine, ou ajouter une nouvelle planification XLANG qui sera exécutée en concurrence à la planification XLANG d'origine.

Pour remplacer la planification XLANG d'origine, utilisez le Concepteur d'Orchestration BizTalk pour créer un nouveau schéma de planification XLANG, puis compilez le schéma de planification XLANG en une planification XLANG qui possède le même nom que la planification XLANG d'origine. Le schéma de planification XLANG est enregistré sous la forme d'un fichier .skv, qui est une version personnalisée du format de fichier Microsoft Visio 2000. Vous pouvez ensuite compiler le schéma de planification XLANG en une planification XLANG, qui est un fichier texte .skx de structure XML, compris par le moteur de XLANG Scheduler. Pour mettre à jour la planification XLANG d'origine, copiez le nouveau fichier .skx à la place du fichier .skx d'origine.

Pour ajouter une nouvelle planification XLANG qui fonctionnera simultanément à la planification XLANG d'origine, utilisez le Concepteur d'Orchestration BizTalk pour créer un nouveau schéma de planification XLANG et compilez ce schéma en une planification XLANG avec un nouveau nom. Afin de vous assurer que la nouvelle planification XLANG sera correctement activée, vous devez modifier le mécanisme d'activation de l'instance de planification XLANG en lui indiquant le nouveau fichier .skx au lieu de l'ancien. Une fois ce processus terminé, les nouvelles requêtes de planifications XLANG créeront des instances de la nouvelle planification XLANG.

Toutes les planifications XLANG et leurs composants fonctionnant généralement sur une base par instance, les instances de planification XLANG qui exécutent la planification d'origine se poursuivent jusqu'à leur fin. C'est également le cas pour les instances de planification XLANG mises en persistance, car le code source de la planification d'origine a été enregistré. Dans ce scénario, le chemin d'exécution continue à suivre le processus professionnel d'origine, tandis que les nouvelles requêtes de planifications XLANG créent des instances de la nouvelle planification XLANG.

Remarque

  • Si une planification XLANG utilise un objet avec une interface modifiée, vous devez charger le schéma de planification XLANG (le fichier .skv) dans le Concepteur d'Orchestration BizTalk, puis compiler un nouveau fichier .skx. Vous mettrez ainsi à jour les informations de liaison dans le fichier .skx, autorisant la synchronisation avec la bibliothèque de types du composant.


Configuration des services d'Échanges BizTalk

Microsoft BizTalk Server 2000 intègre deux méthodes de configuration des services d'Échanges BizTalk, afin de gérer les échanges de documents entre les partenaires commerciaux et les applications internes à l'entreprise. Vous pouvez opter pour le Gestionnaire d'échanges BizTalk, qui est une interface utilisateur graphique, ou accéder directement au modèle d'objets de configuration d'Échanges BizTalk.

Grâce au Gestionnaire d'échanges BizTalk ou au modèle objet de configuration d'Échanges BizTalk, vous pouvez créer des ports d'échanges et des canaux assurant la gestion des échanges de données. Vous pouvez également créer des définitions de document, des enveloppes et des organisations, qui permettent de créer des ports d'échanges et des canaux, ainsi que des listes de distribution, qui représentent des groupes de ports d'échanges.

Remarque

  • Pour accéder ou créer des objets à l'aide du Gestionnaire d'échanges BizTalk ou du modèle objet de configuration d'Échanges BizTalk, ou bien pour exécuter des scripts ou des applications permettant d'accéder ou de créer de tels objets, vous devez être membre d'un compte utilisateur dans le groupe Administrateurs de BizTalk Server. Le groupe Administrateurs de BizTalk Server est créé lors de l'installation de BizTalk Server 2000. Le cas échéant, il est possible d'ajouter des utilisateurs supplémentaires à ce groupe. Pour plus d'informations sur l'ajout d'un compte d'utilisateur, voir Ajout d'utilisateurs au groupe Administrateurs de BizTalk Server.

Cette section traite des rubriques suivantes :

  • Utilisation du Gestionnaire d'échanges BizTalk

  • Accès au modèle d'objets de configuration d'Échanges BizTalk


Utilisation du Gestionnaire d'échanges BizTalk

Le Gestionnaire d'échanges BizTalk est une interface graphique utilisateur qui vous permet de gérer l'échange de documents en configurant les services d'Échanges BizTalk. Les services d'Échanges BizTalk peuvent également être configurés par programme. Pour plus d'informations, voir Accès au modèle d'objets de configuration d'Échanges BizTalk.

Attention

  • Vous devez utiliser le Gestionnaire d'échanges BizTalk pour configurer les services d'Échanges BizTalk avant de traiter des documents. Si vous accédez à des objets ou modifiez des objets susceptibles d'être en cours d'utilisation lors du traitement de documents par BizTalk Server 2000, des résultats inattendus peuvent se produire.

L'échange de documents peut avoir lieu entre des partenaires commerciaux et des applications au sein de votre entreprise. Le Gestionnaire d'échanges BizTalk est disponible à la fois en local à partir de l'ordinateur sur lequel BizTalk Server 2000 est installé et à distance en tant qu'application cliente. Dès lors, les administrateurs système sont en mesure d'assurer la sécurité et de centraliser le contrôle du serveur tout en permettant aux utilisateurs distants d'accéder au Gestionnaire d'échanges BizTalk.

L'Aide de Microsoft BizTalk Server 2000 fournit des informations sur la création et la gestion des canaux, des ports d'échanges, des définitions de documents, des enveloppes et des organisations. L'Aide vous explique également comment utiliser les listes de distribution.

Objets du Gestionnaire d'échanges BizTalk

L'illustration suivante montre la relation entre les objets que vous pouvez créer à l'aide du Gestionnaire d'échanges BizTalk.

Vue d'ensemble du Gestionnaire d'échanges BizTalk
Application (Organisation d'origine)
Définition de
document
(Entrant)
Port d'échanges
(Destination)
Canal
(Source)
Canal
Enveloppe
Liste de distri.
Ports d'échanges
Définition de
document
(Sortant)
Organisation (Partenaire commercial)
Document
entrant
Document
sortant

Le résumé suivant fournit une présentation succincte des objets que vous pouvez créer à l'aide du Gestionnaire d'échanges BizTalk. Il explique aussi plus en détail la relation entre les objets. Pour des informations plus détaillées sur chaque objet, cliquez sur le lien apparaissant à la fin de chaque description pour accéder à la rubrique d'aide correspondante.

Canaux

Les canaux constituent les principaux objets du Gestionnaire d'échanges BizTalk. Tous les autres objets du Gestionnaire d'échanges BizTalk servent soit à créer des canaux, soit à permettre le fonctionnement de ceux-ci. Les canaux identifient la source des documents. Il peut s'agir d'une organisation, d'une application métier ou d'une planification XLANG. Les canaux identifient également les documents entrants et sortants à l'aide des définitions de documents. Pour plus d'informations, voir Description des canaux.

Ports d'échanges

Les ports d'échanges identifient une destination pour les documents traités par un canal. Cette destination peut être une organisation, une application métier ou une planification XLANG. Le port d'échanges indique une adresse de destination pour l'envoi des documents, définit le mode de transport vers cette adresse et détermine, le cas échéant, la procédure de sécurisation des documents et les paramètres des enveloppes. Pour plus d'informations, voir Description des ports d'échanges.

Organisations

Les organisations représentent d'autres partenaires commerciaux avec lesquels vous échangez des documents. Le type d'organisation spécial, appelé l'organisation d'origine représente votre entreprise. Pour l'organisation principale, vous pouvez créer des applications correspondant aux applications internes utilisées par votre entreprise. Les organisations et les applications font fonction de source pour un canal ou de destination pour un port d'échanges. Pour plus d'informations, voir Description des organisations.

Définitions de document

Une définition de document représente un type spécifique de document traité par BizTalk Server 2000. Une définition de document fournit un pointeur sur une spécification. Les spécifications définissent la structure, le type et la version des documents. Les canaux spécifient une définition de document entrant et une définition de document sortant pour identifier les documents traités par le serveur. Une définition de document donnée peut être utilisée dans un nombre illimité de canaux. Pour plus d'informations, voir Description des définitions de document.

Enveloppes

Les enveloppes fournissent à BizTalk Server 2000 les informations dont le serveur a besoin pour ouvrir des échanges entrants ou créer des échanges sortants. Des enveloppes peuvent être sélectionnées à partir d'un port d'échanges pour guider le serveur dans la création d'échanges sortants. Des enveloppes indépendantes d'un port d'échanges peuvent être utilisées par BizTalk Server 2000 pour ouvrir des échanges entrants. Pour plus d'informations, voir Description des enveloppes.

Listes de distribution

Les listes de distribution sont des groupes de ports d'échanges via lesquels vous pouvez envoyer le même document à un groupe comprenant différentes organisations de partenaires commerciaux ou différentes applications internes. Vous devez créer au moins un canal pour une liste de distribution, exactement comme pour un port d'échanges individuel. Pour plus d'informations, voir Description des listes de distribution.

Remarques

  • Les objets que vous pouvez créer à l'aide du Gestionnaire d'échanges BizTalk peuvent également être créés par programme à l'aide du modèle d'objets de configuration d'Échanges BizTalk. Pour plus d'informations, voir Accès au modèle d'objets de configuration d'Échanges BizTalk.

  • Les objets que vous pouvez créer à l'aide du Gestionnaire d'échanges BizTalk utilisent également des objets que vous pouvez créer à l'aide d'autres interfaces utilisateur des services d'Échanges BizTalk. Les canaux utilisent des mappages, lesquels peuvent être créés à l'aide du Mappeur BizTalk. Les définitions de documents utilisent des spécifications de documents, et les enveloppes utilisent des spécifications d'enveloppes. L'Éditeur BizTalk vous permet de créer des spécifications.

  • Pour obtenir de l'aide sur des tâches spécifiques, voir Comment.

  • Pour obtenir des informations d'ordre général, voir Concepts.


Comment...

Cette section fournit des informations spécifiques aux tâches sur l'utilisation du Gestionnaire d'échanges BizTalk. Nous vous recommandons vivement de relire la section Concepts afin de bien comprendre les relations entre les objets que vous pouvez créer à l'aide du Gestionnaire d'échanges BizTalk.

Cette section traite des rubriques suivantes :

  • Création et gestion de canaux

  • Création et gestion des ports d'échanges

  • Création et gestion d'organisations

  • Création et gestion de définitions de document

  • Création et gestion d'enveloppes

  • Utilisation de listes de distribution


Création et gestion de canaux

Cette section fournit des informations spécifiques aux tâches sur la création et la gestion de canaux. Nous vous recommandons vivement de relire Présentation des canaux dans la section Concepts afin de comprendre parfaitement cette notion.

Cette section traite des procédures suivantes :

  • Création de canaux

  • Recherche de canaux

  • Modification de canaux

  • Suppression de canaux

  • Définition des propriétés de canal


Création de canaux

Vous devez créer un port d'échanges ou une liste de distribution avant de créer un canal. Pour plus d'informations, voir Création de ports d'échanges ou Création de listes de distribution.

  1. Dans le Gestionnaire d'échanges BizTalk, dans la zone Rechercher d'autres éléments, cliquez sur Ports d'échanges ou Listes de distribution, puis sur Rechercher.

  2. Dans la liste Nom du port d'échanges, sélectionnez le port d'échanges pour lequel vous voulez créer un canal.

    –Ou–

    Dans la liste Nom de la liste de distribution, sélectionnez la liste pour laquelle vous voulez créer un canal.

  3. Dans le Gestionnaire d'échanges BizTalk, dans le menu Fichier, pointez sur Nouveau et sur Canal, puis procédez comme suit :
    • Pour créer un canal à partir d'une organisation, cliquez sur À partir d'une organisation.

    • Pour créer un canal à partir d'une application, cliquez sur À partir d'une application.

    L'Assistant Nouveau canal s'ouvre.

  4. Sur la page Informations générales, définissez les propriétés, puis cliquez sur Suivant.

    Pour plus d'informations, voir Définition des propriétés générales des informations de canal.

  5. Exécutez une des étapes suivantes :
    • Si vous créez un canal à partir d'une organisation, définissez les propriétés sur la page Organisation source, puis cliquez sur Suivant. Pour plus d'informations, voir Définition des propriétés d'une organisation source.

    • Si vous créez un canal à partir d'une application, définissez les propriétés sur la page Application source, puis cliquez sur Suivant. Pour plus d'informations, voir Définition des propriétés d'une application source.
  6. Sur la page Document entrant, définissez les propriétés, puis cliquez sur Suivant.

    Pour plus d'informations, voir Définition des propriétés d'un document entrant.

  7. Sur la page Document sortant, définissez les propriétés, puis cliquez sur Suivant.

    Pour plus d'informations, voir Définition des propriétés d'un document sortant.

  8. Sur la page Journalisation du document, définissez les propriétés, puis cliquez sur Suivant.

    Pour plus d'informations, voir Définition des propriétés de journalisation de document.

  9. Sur la page Configuration avancée, définissez les propriétés, puis cliquez sur Suivant.

    Pour plus d'informations, voir Définition des propriétés de configuration avancées.

  10. Lorsque vous avez défini toutes les propriétés du canal, sur la page Configuration avancée, cliquez sur Terminer pour fermer l'Assistant Canal.

Remarques

  • Vous ne pouvez pas nommer un canal à l'aide du nom système réservé, Canal des accusés de réception d'échanges au format Reliable.

  • Vous pouvez utiliser cette procédure pour créer un canal standard ou un canal d'accusés de réception. Les procédures de cette section contiennent des remarques décrivant les propriétés qui ne sont pas disponibles lorsque vous créez un canal d'accusés de réception.

  • Si vous créez un port d'échanges et un canal en vue d'une soumission directe de données, vous pouvez uniquement utiliser, pour le canal, la fenêtre de service ainsi que les fonctionnalités de compteur et d'intervalle pour les nouveaux essais. En ce qui concerne le port d'échanges associé, seules les fonctionnalités de transport sont disponibles. Vous ne pouvez utiliser ni la vérification de décodage ou de décryptage, ni le filtrage, ni le suivi de documents, ni les fonctions de mappage du canal.

  • Lorsque vous enregistrez un canal qui fait référence à un mappage externe à votre domaine local, une erreur risque de se produire. S'il se produit une erreur, téléchargez et configurez l'utilitaire proxy WinHTTP. Pour télécharger cet utilitaire, accédez au site Web Microsoft MSDN (msdn.microsoft.com/downloads/default.asp) et accédez à la page WinHTTP Proxy Configuration Utility, qui figure dans le chapitre XML du manuel Web Development.

Voir aussi

Suppression de canaux

Modification de canaux

Recherche de canaux

Définition des propriétés de canal

Description des canaux


Recherche de canaux

  1. Dans le Gestionnaire d'échanges BizTalk, dans la zone Rechercher d'autres éléments, cliquez sur Canaux.

  2. Pour rechercher tous les canaux, effacez tous les critères de recherche, puis cliquez sur Rechercher.

  3. Effectuez une ou plusieurs des actions suivantes :
    • Pour rechercher un canal portant un nom spécifique, dans la zone Rechercher les canaux, dans la zone Nom du canal, tapez le nom du canal à rechercher, puis cliquez sur Rechercher. Si vous entrez un nom incomplet, la recherche renverra tous les noms possibles correspondant à votre entrée.

    • Pour rechercher un canal à partir d'un type de source spécifique, dans la liste Source, sélectionnez un type de source, puis cliquez sur Rechercher.

    • Pour rechercher un canal associé à un port d'échanges ou à une liste de distribution spécifique, dans la zone Associé au port d'échanges ou à la liste de distribution, tapez le nom du port d'échanges ou de la liste de distribution, puis cliquez sur Rechercher. Si vous entrez un nom incomplet, la recherche renverra tous les noms possibles correspondant à votre entrée.

    • Pour rechercher un canal qui utilise une définition de document spécifique, dans la zone Utilisation de la définition de document, tapez le nom d'une définition de document, puis cliquez sur Rechercher. Si vous entrez un nom incomplet, la recherche renverra tous les noms possibles correspondant à votre entrée.

Remarques

  • Vous pouvez définir plusieurs critères de recherche avant de cliquer sur Rechercher.

  • Pour effacer les critères et les résultats de la recherche, cliquez sur Effacer.

  • Vous pouvez également rechercher des canaux associés à un port d'échanges ou à une liste de distribution spécifique en cliquant avec le bouton droit sur le port d'échanges ou la liste de distribution, puis en cliquant sur Rechercher des canaux.

  • Si vous devez rechercher un grand nombre d'objets, le renvoi de tous les objets peut prendre plusieurs minutes. Vous pouvez limiter les objets renvoyés à la suite d'une recherche en définissant des critères de sélection.

  • Une recherche renvoie par défaut 500 objets, mais vous pouvez modifier ce nombre. Pour plus d'informations, voir Définition des options de connexion du serveur.

  • Vous pouvez utiliser les caractères génériques suivants dans vos critères de recherche.
    Caractère générique | Description | Exemple
    % Toute chaîne de zéro caractère ou plus L'entrée '%ouvert%' renvoie tous les noms contenant le terme « ouvert ».
    _ (soulignement) | N'importe quel caractère | L'entrée « _ean » renvoie tous les noms de quatre lettres qui se terminent par « ean » (Dean, Sean, etc.).
    [ ] Tout caractère de l'intervalle ([a-f]) ou de l'ensemble spécifié ([abcdef]) L'entrée « [C-P]arsen » renvoie les noms se terminant par « arsen » et commençant par un caractère compris entre C et P (Carsen, Larsen, Karsen, etc.).
    [^] Tout caractère non compris dans l'intervalle ([^a-f]) ou l'ensemble (^abcdef]) spécifié L'entrée « de[^s]% » renvoie tous les noms commençant par « de » et dont la lettre suivante n'est pas un « s ».

Voir aussi

Suppression de canaux

Modification de canaux

Définition des propriétés de canal

Description des canaux


Modification de canaux

  1. Dans le Gestionnaire d'échanges BizTalk, dans la liste Nom du canal, sélectionnez le canal que vous voulez modifier.

    Pour plus d'informations sur la recherche de canaux, voir Recherche de canaux.

  2. Dans le menu Fichier, cliquez sur Edition.

    L'Assistant Propriétés du canal s'ouvre.

  3. Sur la page Informations générales, modifiez les propriétés appropriées.

    Pour plus d'informations, voir Définition des propriétés générales des informations de canal.

    Lorsque vous avez modifié les propriétés sur cette page, cliquez sur Terminer pour fermer l'Assistant Propriétés du canal ou sur Suivant pour modifier d'autres propriétés du canal.

  4. Exécutez une des étapes suivantes :
    • Si vous modifiez un canal à partir d'une organisation, modifiez les propriétés appropriées sur la page Organisation source. Pour plus d'informations, voir Définition des propriétés d'une organisation source.

    • Si vous modifiez un canal à partir d'une application, modifiez les propriétés appropriées sur la page Application source. Pour plus d'informations, voir Définition des propriétés d'une application source.
  5. Sur la page Document entrant, modifiez les propriétés appropriées.

    Pour plus d'informations, voir Définition des propriétés d'un document entrant.

  6. Sur la page Document sortant, modifiez les propriétés appropriées.

    Pour plus d'informations, voir Définition des propriétés d'un document sortant.

  7. Sur la page Journalisation du document, modifiez les propriétés appropriées.

    Pour plus d'informations, voir Définition des propriétés de journalisation de document.

  8. Sur la page Configuration avancée, modifiez les propriétés appropriées.

    Pour plus d'informations, voir Définition des propriétés de configuration avancées.

Remarques

  • Vous ne pouvez pas nommer un canal à l'aide du nom système réservé, Canal des accusés de réception d'échanges au format Reliable.

  • Lorsque vous enregistrez un canal qui fait référence à un mappage externe à votre domaine local, une erreur risque de se produire. S'il se produit une erreur, téléchargez et configurez l'utilitaire proxy WinHTTP. Pour télécharger cet utilitaire, accédez au site Web Microsoft MSDN (msdn.microsoft.com/downloads/default.asp) et accédez à la page WinHTTP Proxy Configuration Utility, qui figure dans le chapitre XML du manuel Web Development.

Voir aussi

Création de canaux

Suppression de canaux

Recherche de canaux

Définition des propriétés de canal

Description des canaux


Suppression de canaux

  1. Dans le Gestionnaire d'échanges BizTalk, dans la liste Nom du canal, sélectionnez le canal que vous voulez supprimer.

    Pour plus d'informations sur la recherche de canaux, voir Recherche de canaux.

  2. Dans le menu Fichier, cliquez sur Supprimer.

Remarque

  • Vous ne pouvez pas supprimer le canal d'accusés de réception tant que tous les canaux qui s'y réfèrent n'ont pas été supprimés.

Voir aussi

Création de canaux

Modification de canaux

Recherche de canaux

Définition des propriétés de canal

Description des canaux


Définition des propriétés de canal

Cette section fournit des informations spécifiques aux tâches portant sur la configuration des propriétés d'un canal. Cette section traite des procédures suivantes :

  • Définition des propriétés générales d'un canal

  • Définition des propriétés d'une organisation source

  • Définition des propriétés d'une application source

  • Définition des propriétés d'un document entrant

  • Définition des propriétés d'un document sortant

  • Définition des propriétés de journalisation d'un document

  • Définition des propriétés de configuration avancées

  • Sélection d'une organisation source

  • Sélection d'un canal d'accusés de réception

  • Sélection d'une définition de document entrant

  • Sélection d'un certificat pour vérifier le décryptage d'un document entrant

  • Sélection d'un certificat pour vérifier la signature d'un document entrant

  • Sélection d'une définition de document sortant

  • Sélection d'un mappage

  • Sélection d'un certificat pour la signature sortante

  • Remplacement des valeurs par défaut d'un port d'échanges

  • Remplacement des valeurs par défaut de la liste de distribution

  • Définition du suivi pour les propriétés de document entrant

  • Définition des propriétés de filtrage de canal


Définition des propriétés générales d'un canal

  1. Sur la page Informations générales de l'Assistant Canal, dans la zone Nom, tapez le nom du canal.

  2. Dans la zone Commentaires, tapez des commentaires sur le canal.

  3. Si vous voulez créer un canal d'accusés de réception, activez la case à cocher Canal d'accusés de réception.

Si vous créez un canal, cliquez sur Suivant. Pour plus d'informations sur l'exécution de l'étape suivante, voir Création de canaux.

Si vous modifiez un canal existant, cliquez sur Suivant. Pour plus d'informations sur l'exécution de l'étape suivante, voir Modification de canaux. Une fois vos modifications effectuées, cliquez sur Terminer.

Remarques

  • Un canal d'accusés de réception est un type de canal spécial utilisé pour envoyer un accusé de réception à l'expéditeur d'un document qui est reçu par BizTalk Server 2000. Pour plus d'informations sur les accusés de réception, voir Description des accusés de réception.

  • Vous ne pouvez créer ni un canal d'accusés de réception pour un port d'échanges ouvert, ni une liste de distribution.

Voir aussi

Création de canaux

Modification de canaux

Définition des propriétés de canal


Définition des propriétés d'une organisation source

  1. Sur la page Organisation source de l'Assistant Canal, exécutez l'une des étapes suivantes :
    • Cliquez sur Ouvrir la source pour créer un canal ouvert, indiquant que la source est fournie par les données du document ou par les paramètres envoyés avec le document, puis cliquez sur Suivant.

      Pour plus d'informations sur l'envoi de documents, voir Envoi.

    • Cliquez sur Organisation pour désigner une organisation de partenaire commercial comme source, puis passez à l'étape 2.
  2. Dans la zone Organisation, cliquez sur Parcourir.

    La boîte de dialogue Sélectionner une organisation s'affiche.

  3. Cliquez sur une organisation, puis sur OK.

    Pour plus d'informations, voir Sélection d'une organisation source.

  4. Si vous voulez remplacer l'identificateur d'organisation par défaut de l'organisation source, sélectionnez-en un autre dans la liste Identificateur d'organisation.

  5. Si un accusé de réception à partir de la destination est nécessaire, comme spécifié dans le port d'échanges, activez la case à cocher Attendre un accusé de réception et dans la zone Intervalle des accusés de réception en minutes, tapez une valeur ou cliquez sur les flèches HAUT ou BAS pour augmenter ou diminuer la valeur.

    La valeur par défaut est 120 minutes. Pour plus d'informations sur les accusés de réception, voir Description des accusés de réception.

  6. Si vous voulez générer un accusé de réception à la source, activez la case à cocher Générer un accusé de réception, cliquez sur Parcourir, puis sélectionnez un canal d'accusés de réception.

    Pour plus d'informations, voir Sélection d'un canal d'accusés de réception.

Si vous créez un canal, cliquez sur Suivant. Pour plus d'informations sur l'exécution de l'étape suivante, voir Création de canaux.

Si vous modifiez un canal existant, cliquez sur Suivant. Pour plus d'informations sur l'exécution de l'étape suivante, voir Modification de canaux. Une fois vos modifications effectuées, cliquez sur Terminer.

Remarques

  • Si vous sélectionnez un identificateur d'organisation source à utiliser avec des enveloppes X12, ne sélectionnez pas l'identificateur nommé Organisation, ni tout autre identificateur dont le qualificatif comporte plus de 2 caractères, ni une valeur qui comporte plus de 15 caractères.

  • Si vous sélectionnez un identificateur d'organisation source à utiliser avec des enveloppes EDIFACT, ne sélectionnez pas l'identificateur nommé Organisation, ni tout autre identificateur dont le qualificatif comporte plus de 4 caractères, ni une valeur qui comporte plus de 35 caractères.

  • Si vous modifiez un canal à partir d'une organisation spécifique, l'option Ouvrir la source n'est pas disponible et vous ne pouvez pas modifier l'organisation source. Si vous modifiez un canal ouvert, l'option Organisation n'est pas disponible.

  • Si vous créez ou modifiez un canal d'accusés de réception, les propriétés Attendre un accusé de réception et Générer un accusé de réception ne sont pas disponibles.

Voir aussi

Création de canaux

Modification de canaux

Définition des propriétés de canal

Description des accusés de réception


Définition des propriétés d'une application source

  1. Sur la page Application source de l'Assistant Canal, exécutez l'une des étapes suivantes :
    • Cliquez sur Planification XLANG pour désigner la source correspondant à une planification XLANG, puis sur Suivant.

      Ne sélectionnez pas cette option si vous créez un canal pour un port d'échanges ouvert. Pour plus d'informations sur l'intégration des services d'Échanges BizTalk aux services d'Orchestration BizTalk, voir Intégration des services BizTalk.

    • Cliquez sur Application pour désigner une application de l'organisation d'origine comme source, puis passez à l'étape 2.
  2. Dans la liste Nom, sélectionnez une application.

  3. Si vous voulez remplacer l'identificateur d'organisation par défaut pour l'organisation d'origine, sélectionnez un autre identificateur dans la liste Identificateur d'organisation.

  4. Si vous souhaitez recevoir un accusé de réception de la destination, activez la case à cocher Attendre un accusé de réception et dans la zone Intervalle des accusés de réception en minutes, tapez une valeur ou cliquez sur les flèches HAUT ou BAS pour augmenter ou diminuer la valeur.

    La valeur par défaut est 120 minutes. Pour plus d'informations sur les accusés de réception, voir Description des accusés de réception.

  5. Si vous voulez générer un accusé de réception à la source, activez la case à cocher Générer un accusé de réception, cliquez sur Parcourir, puis sélectionnez un canal d'accusés de réception.

    Pour plus d'informations, voir Sélection d'un canal d'accusés de réception.

Si vous créez un canal, cliquez sur Suivant. Pour plus d'informations sur l'exécution de l'étape suivante, voir Création de canaux.

Si vous modifiez un canal existant, cliquez sur Suivant. Pour plus d'informations sur l'exécution de l'étape suivante, voir Modification de canaux. Une fois vos modifications effectuées, cliquez sur Terminer.

Remarques

  • Vous pouvez créer une planification XLANG à l'aide du Concepteur d'Orchestration BizTalk.

  • Si vous créez ou modifiez un canal d'accusés de réception ou un canal pour lequel une planification XLANG est spécifiée comme source, les propriétés Attendre un accusé de réception et Générer un accusé de réception ne sont pas disponibles.

Voir aussi

Création de canaux

Modification de canaux

Intégration des services BizTalk

Définition des propriétés de canal

Description des accusés de réception


Définition des propriétés d'un document entrant

  1. Sur la page Document entrant de l'Assistant Canal, cliquez sur le bouton Parcourir situé à droite de la zone Nom de la définition du document entrant.

    La boîte de dialogue Sélectionner une définition de document s'affiche.

  2. Cliquez sur une définition de document, puis sur OK.

    Pour plus d'informations, voir Sélection d'une définition de document entrant.

  3. Si vous voulez vérifier le décryptage d'un document entrant, activez la case à cocher Vérifier le certificat de décryptage du document entrant. Ensuite, cliquez sur le bouton Parcourir situé à droite de la zone Certificat de vérification du décryptage.

    La boîte de dialogue Sélectionner un certificat pour vérifier le cryptage apparaît.

  4. Sélectionnez un certificat

    Pour plus d'informations, voir Sélection d'un certificat pour vérifier le décryptage du document entrant.

  5. Si vous voulez vérifier la signature numérique d'un document entrant, activez la case à cocher Vérifier le certificat de signature du document entrant. Ensuite, cliquez sur le bouton Parcourir situé à droite de la zone Certificat de vérification de la signature.

    La boîte de dialogue Sélectionner un certificat de signature apparaît.

  6. Sélectionnez un certificat de signature.

    Pour plus d'informations, voir Sélection d'un certificat pour vérifier la signature du document entrant.

  7. Si vous voulez suivre les champs du document entrant, activez la case à cocher Suivre le document entrant, puis cliquez sur Suivi.

    La boîte de dialogue Suivi du document entrant s'affiche.

  8. Définissez les propriétés de suivi.

    Pour plus d'informations, voir Définition des propriétés de suivi d'un document entrant.

  9. Si vous voulez créer une expression de filtrage de canaux pour le document entrant, activez la case à cocher Filtrer le document entrant, puis cliquez sur Filtrage.

    La boîte de dialogue Expressions de filtrage de canaux s'affiche.

  10. Définissez les propriétés de filtrage.

    Pour plus d'informations, voir Définition des propriétés de filtrage de canaux.

Si vous créez un canal, cliquez sur Suivant. Pour plus d'informations sur l'exécution de l'étape suivante, voir Création de canaux.

Si vous modifiez un canal existant, cliquez sur Suivant. Pour plus d'informations sur l'exécution de l'étape suivante, voir Modification de canaux. Une fois vos modifications effectuées, cliquez sur Terminer.

Remarques

  • Lorsque vous créez un canal d'accusés de réception, les définitions des documents entrant et sortant adoptent par défaut la valeur Accusé de réception standard BizTalk, et ne peuvent pas être transformées par un mappage. Pour utiliser un format différent pour un accusé de réception sortant, vous devez créer et sélectionner une définition de document entrant qui fait référence à la spécification standard pour les accusés de réception dans le référentiel WebDAV. Dans le canal d'accusés de réception, vous devez également créer et sélectionner une définition de document sortant faisant référence à une spécification dont le format correspond à celui que vous voulez pour le document sortant et spécifier un mappage pour modifier les formats. Pour plus d'informations, voir Description des accusés de réception.

  • Si vous créez un canal d'accusés de réception qui utilise l'accusé de réception standard BizTalk par défaut pour la définition du document entrant, les propriétés Suivi et Filtrage ne sont pas disponibles.

  • Si vous créez un canal pour un port d'échanges ouvert, et si les informations sur la destination sont fournies dans le document, la définition du document entrant pour ce canal doit faire référence à une spécification dont la configuration est correcte. Pour plus d'informations sur la configuration d'une spécification de document permettant de traiter les documents pour un port d'échanges ouvert, voir Définition des propriétés du dictionnaire.

Voir aussi

Création de canaux

Modification de canaux

Définition des propriétés de canal


Définition des propriétés d'un document sortant

  1. Sur la page Document sortant de l'Assistant Canal, cliquez sur le bouton Parcourir situé à droite de la zone Nom de la définition du document sortant.

    La boîte de dialogue Sélectionner une définition de document s'affiche.

  2. Cliquez sur une définition de document, puis sur OK.

    Pour plus d'informations, voir Sélection d'une définition de document sortant.

  3. Si vous voulez spécifier un mappage, activez la case à cocher Mapper le document entrant sur le document sortant. À droite de la zone Référence de mappage, cliquez ensuite sur Parcourir.

    La boîte de dialogue Sélectionnez un mappage dans le référentiel WebDAV s'affiche.

  4. Sélectionnez une spécification de mappage.

    Pour plus d'informations, voir Sélection d'un mappage.

  5. Si vous voulez insérer une signature numérique dans le document sortant, activez la case à cocher Signer le document sortant. À droite de la zone Référence de mappage, cliquez ensuite sur Parcourir.

    Si vous créez un canal pour un port d'échanges pour lequel la propriété Signature sur la page Informations de sécurité est définie sur S/MIME, la case à cocher Signer le document sortant est automatiquement activée.

    La boîte de dialogue Sélectionner un certificat de signature s'affiche.

  6. Sélectionnez un certificat de signature.

    Pour plus d'informations, voir Sélection d'un certificat pour une signature sortante.

Si vous créez un canal, cliquez sur Suivant. Pour plus d'informations sur l'exécution de l'étape suivante, voir Création de canaux.

Si vous modifiez un canal existant, cliquez sur Suivant. Pour plus d'informations sur l'exécution de l'étape suivante, voir Modification de canaux. Une fois vos modifications effectuées, cliquez sur Terminer.

Important

  • Le format d'enveloppe que vous spécifiez dans un port d'échanges doit correspondre au format du ou des documents qu'il contient. Le format du document est déterminé par la spécification à laquelle il est fait référence dans la définition du document sortant d'un canal associé. Par exemple, si vous choisissez une enveloppe au format X12 pour un port d'échanges, vous devez sélectionner une définition de document sortant pour le canal pointant vers une spécification X12.

  • Lorsque vous déclarez un port d'échanges comme étant un port d'échanges ouvert, ne créez pas pour le port d'échanges des canaux dont la définition du document sortant comporte une spécification X12 ou EDIFACT. Pour générer une enveloppe X12 ou EDIFACT, le serveur nécessite un identificateur d'organisation pour la source et la destination. Un port d'échanges ouvert ne spécifie pas l'identificateur de l'organisation de destination. De plus, les documents d'un port d'échanges ouvert doivent contenir l'adresse de destination, mais les documents X12 et EDIFACT n'incluent pas cette information.

  • Lorsque vous ouvrez pour la première fois une boîte de dialogue Référentiel WebDAV, le référentiel WebDAV du serveur local est sélectionné, même si le Gestionnaire d'échanges BizTalk est connecté à une base de données d'un serveur distant. Si vous accédez à un référentiel WebDAV d'un serveur distant, celui-ci devient le serveur par défaut jusqu'à ce que vous sélectionniez un nouveau référentiel WebDAV. Le serveur par défaut de toutes les boîtes de dialogue Référentiel WebDAV est le dernier serveur avec lequel une connexion a été établie.

Remarques

  • Lorsque vous créez un canal d'accusés de réception, les définitions des documents entrant et sortant adoptent par défaut la valeur Accusé de réception standard BizTalk, et ne peuvent pas être transformées par un mappage. Pour utiliser un format différent pour un accusé de réception sortant, vous devez créer et sélectionner une définition de document entrant qui fait référence à la spécification standard pour les accusés de réception dans le référentiel WebDAV. Vous devez également créer une définition de document sortant qui se réfère à une spécification ayant le format que vous voulez attribuer à l'accusé de réception sortant et à un mappage qui transforme le format de l'accusé de réception. Pour plus d'informations sur les accusés de réception, voir Description des accusés de réception.

  • Un mappage permet de transformer le format de document entrant en format de document sortant. Si la spécification du document entrant correspond à celle du document sortant, le mappage n'est pas nécessaire. Par défaut, la case à cocher Mapper le document entrant sur le document sortant est désactivée. Les mappages peuvent être créés à l'aide du Mappeur BizTalk. Pour plus d'informations sur les mappages, voir Données de mappage.

Voir aussi

Création de canaux

Modification de canaux

Définition des propriétés de canal

Description des accusés de réception


Définition des propriétés de journalisation d'un document

  1. Dans l'Assistant Canal, sur la page Journalisation de document, dans la zone Consigner le document entrant, activez la case à cocher appropriée :
    • Au format natif. Stocke les documents entrants pour le canal sous le format d'origine. Il s'agit de la configuration par défaut.

    • Au format XML. Stocke les documents entrants pour le canal sous le format XML.
  2. Dans la zone Consigner le document sortant, activez la case à cocher appropriée :
    • Au format natif. Stocke les documents sortants pour le canal sous le format d'origine.

    • Au format XML. Stocke les documents sortants pour le canal sous le format XML.

Si vous créez un canal, cliquez sur Suivant. Pour plus d'informations sur l'exécution de l'étape suivante, voir Création de canaux.

Si vous modifiez un canal existant, cliquez sur Suivant. Pour plus d'informations sur l'exécution de l'étape suivante, voir Modification de canaux. Une fois vos modifications effectuées, cliquez sur Terminer.

Remarques

  • Les documents qui utilisent la journalisation sont limités en taille ; si celle-ci est dépassée, les performances de BizTalk Server en seront affectées. Pour plus d'informations sur cette limite de taille, voir Limite de la taille des documents et des échanges.

  • BizTalk Server 2000 convertit les documents non-XML entrants du format natif d'origine au format XML pour le traitement et les documents sortants du format XML au format natif de destination requis.

Voir aussi

Création de canaux

Modification de canaux

Définition des propriétés de canal


Définition des propriétés de configuration avancées

  1. Sur la page Configuration avancée de l'Assistant Canal, si vous créez un canal pour un port d'échanges qui indique un format d'enveloppe X12 ou EDIFACT , tapez une valeur non nulle dans la zone Numéro de contrôle de groupe.

  2. Dans la zone Options de nouvel essai, entrez le nombre de fois où vous voulez que le serveur renvoie le document si un accusé de réception n'est pas reçu, et dans la zone Intervalle, entrez le nombre de minutes entre les essais.

    Pour plus d'informations sur les accusés de réception, voir Description des accusés de réception.

  3. Si vous voulez remplacer les paramètres de transport ou de composant d'enveloppe pour un port d'échanges ou une liste de distribution, cliquez sur Avancé.
    • Si vous créez ou modifiez un canal pour un port d'échanges, la boîte de dialogue Ignorer les valeurs par défaut du port d'échanges apparaît. Pour plus d'informations, voir Remplacement des valeurs par défaut d'un port d'échanges.

    • Si vous créez ou modifiez un canal pour une liste de distribution, la boîte de dialogue Remplacer les valeurs par défaut de la liste de distribution apparaît. Pour plus d'informations, voir Remplacement des valeurs par défaut d'un port d'échanges.

Si vous créez un canal, cliquez sur Suivant. Pour plus d'informations sur l'exécution de l'étape suivante, voir Création de canaux.

Si vous modifiez un canal existant, cliquez sur Suivant. Pour plus d'informations sur l'exécution de l'étape suivante, voir Modification de canaux. Une fois vos modifications effectuées, cliquez sur Terminer.

Voir aussi

Création de canaux

Modification de canaux

File de nouvel essai

Définition des propriétés de canal

Description des accusés de réception


Sélection d'une organisation source

  1. Sur la page Organisation source de l'Assistant Canal, cliquez sur le bouton Parcourir situé à droite de la zone Nom.

    La boîte de dialogue Sélectionner une organisation s'affiche.

  2. Dans la liste Organisations disponibles, sélectionnez une organisation, puis cliquez sur Terminer.

Pour poursuivre la définition des propriétés de l'organisation source, allez dans Définition des propriétés d'une organisation source.

Voir aussi

Création de canaux

Modification de canaux

Définition des propriétés de canal

Définition des propriétés d'une organisation source


Sélection d'un canal d'accusés de réception

  1. Sur la page Application source ou Organisation source de l'Assistant Canal, activez la case à cocher Générer un accusé de réception, puis cliquez sur Parcourir.

    La boîte de dialogue Sélectionner un canal d'accusés de réception apparaît.

  2. Dans la liste Canaux d'accusés de réception disponibles, choisissez un canal d'accusés de réception, puis cliquez sur OK.

Pour poursuivre la définition des propriétés de l'organisation source, allez dans Définition des propriétés d'une organisation source.

Pour poursuivre la définition des propriétés de l'application source, voir Définition des propriétés d'une application source.

Remarque

  • La liste Canaux d'accusés de réception disponibles affiche uniquement les canaux d'accusés de réception associés aux ports d'échanges pour lesquels la destination est identique à la source pour le canal créé. Lorsque BizTalk Server 2000 invoque un canal avec un canal d'accusés de réception spécifié, le serveur renvoie un accusé de réception à la source initiale de ce document via le canal d'accusés de réception spécifié. Pour plus d'informations sur les accusés de réception, voir Description des accusés de réception.

Voir aussi

Création de canaux

Modification de canaux

Définition des propriétés de canal

Définition des propriétés d'une application source

Définition des propriétés d'une organisation source

Description des accusés de réception


Sélection d'une définition de document entrant

  1. Sur la page Document entrant de l'Assistant Canal, cliquez sur le bouton Parcourir situé à droite de la zone Nom de la définition du document entrant.

    La boîte de dialogue Sélectionner une définition de document s'affiche.

  2. Dans la liste Définitions de documents disponibles, choisissez une définition de document, puis cliquez sur OK.

Pour poursuivre la définition des propriétés d'un document entrant, allez dans Définition des propriétés d'un document entrant.

Remarque

  • Lorsque vous créez un canal d'accusés de réception, les définitions des documents entrant et sortant adoptent par défaut la valeur Accusé de réception standard BizTalk, et ne peuvent pas être transformées par un mappage. Pour utiliser un format différent pour un accusé de réception sortant, vous devez créer et sélectionner une définition de document entrant qui fait référence à la spécification standard pour les accusés de réception dans le référentiel WebDAV. Vous devez également créer une définition de document sortant qui se réfère à une spécification ayant le format que vous voulez attribuer à l'accusé de réception sortant et à un mappage qui transforme le format de l'accusé de réception. Pour plus d'informations sur les accusés de réception, voir Description des accusés de réception.

Voir aussi

Création de canaux

Création de définitions de document

Modification de canaux

Définition des propriétés de canal

Définition des propriétés d'un document entrant

Description des accusés de réception


Sélection d'un certificat pour vérifier le décryptage d'un document entrant

  1. Sur la page Document entrant de l'Assistant Canal, activez la case à cocher Vérifier le certificat de décryptage du document entrant.

  2. Ensuite, cliquez sur le bouton Parcourir situé à droite de la zone Certificat de vérification du décryptage.

    La boîte de dialogue Sélectionner un certificat pour vérifier le cryptage apparaît.

  3. Dans la liste Nom de certificat, choisissez un nom de certificat et cliquez sur OK.

Pour poursuivre la définition des propriétés d'un document entrant, allez dans Définition des propriétés d'un document entrant.

Remarques

  • Tous les certificats sont stockés dans la zone de stockage de l'ordinateur local. Pour configurer les certificats pour les composants S/MIME en utilisant le Gestionnaire d'échanges BizTalk, vous devez appartenir à un compte d'utilisateur dans le groupe Administrateurs de Windows 2000 et les services d'Échanges BizTalk doivent fonctionner en tant que compte système local ou en tant que compte d'utilisateur dans le groupe Administrateurs de Windows 2000.

  • Les documents sont décryptés lorsque BizTalk Server 2000 les reçoit, afin que le serveur dispose des données nécessaires pour identifier le canal approprié. Le certificat spécifié dans le canal s'assure que le décryptage est effectué correctement.

  • Les certificats doivent porter un nom unique. Si plusieurs certificats ont le même nom, il n'est possible d'en sélectionner qu'un seul. Une fois le certificat sélectionné, les autres certificats portant le même nom disparaissent de la liste.

    Pour plus d'informations sur les certificats, voir Description des certificats.

Voir aussi

Création de canaux

Modification de canaux

Définition des propriétés de canal

Définition des propriétés d'un document entrant


Sélection d'un certificat pour vérifier la signature d'un document entrant

  1. Sur la page Document entrant de l'Assistant Canal, activez la case à cocher Vérifier le certificat de signature du document entrant.

  2. Ensuite, cliquez sur le bouton Parcourir situé à droite de la zone Certificat de vérification de la signature.

    La boîte de dialogue Sélectionner un certificat pour vérifier la signature s'affiche.

  3. Dans la liste Nom de certificat, choisissez un nom de certificat et cliquez sur OK.

Pour poursuivre la définition des propriétés d'un document entrant, allez dans Définition des propriétés d'un document entrant.

Remarques

  • Tous les certificats sont stockés dans la zone de stockage de l'ordinateur local. Pour configurer les certificats pour les composants S/MIME en utilisant le Gestionnaire d'échanges BizTalk, vous devez appartenir à un compte d'utilisateur dans le groupe Administrateurs de Windows 2000 et les services d'Échanges BizTalk doivent fonctionner en tant que compte système local ou en tant que compte d'utilisateur dans le groupe Administrateurs de Windows 2000.

  • Les certificats doivent porter un nom unique. Si plusieurs certificats ont le même nom, il n'est possible d'en sélectionner qu'un seul. Une fois le certificat sélectionné, les autres certificats portant le même nom disparaissent de la liste.

    Pour plus d'informations sur les certificats, voir Description des certificats.

Voir aussi

Création de canaux

Modification de canaux

Définition des propriétés de canal

Définition des propriétés d'un document entrant


Sélection d'une définition de document sortant

  1. Sur la page Document sortant de l'Assistant Canal, cliquez sur le bouton Parcourir situé à droite de la zone Nom de la définition du document sortant.

    La boîte de dialogue Sélectionner une définition de document s'affiche.

  2. Dans la liste Définitions de documents disponibles, choisissez une définition de document, puis cliquez sur OK.

Pour poursuivre la définition des propriétés d'un document sortant, voir Définition des propriétés d'un document sortant.

Remarque

  • Lorsque vous créez un canal d'accusés de réception, les définitions des documents entrant et sortant adoptent par défaut la valeur Accusé de réception standard BizTalk, et ne peuvent pas être transformées par un mappage. Pour utiliser un format différent pour un accusé de réception sortant, vous devez créer et sélectionner une définition de document entrant qui fait référence à la spécification standard pour les accusés de réception dans le référentiel WebDAV. Vous devez également créer une définition de document sortant qui se réfère à une spécification ayant le format que vous voulez attribuer à l'accusé de réception sortant et à un mappage qui transforme le format de l'accusé de réception. Pour plus d'informations sur les accusés de réception, voir Description des accusés de réception.

Voir aussi

Création de canaux

Création de définitions de document

Modification de canaux

Définition des propriétés de canal

Définition des propriétés d'un document sortant

Description des accusés de réception


Sélection d'un mappage

  1. Sur la page Document sortant de l'Assistant Canal, activez la case à cocher Mapper le document entrant sur le document sortant, puis cliquez sur le bouton Parcourir situé à droite de la zone Référence de mappage.

    La boîte de dialogue Sélectionnez un mappage dans le référentiel WebDAV s'affiche.

  2. Dans la zone Serveur, procédez de l'une des façons suivantes pour changer de serveur.
    • Sélectionnez un serveur dans la liste.

    • Tapez le nom d'un serveur et appuyez sur ENTRÉE.
  3. Double-cliquez sur le dossier qui contient le mappage que vous voulez utiliser, sélectionnez le mappage, puis cliquez sur Ouvrir.

Pour poursuivre la définition des propriétés d'un document sortant, voir Définition des propriétés d'un document sortant.

Important

  • Lorsque vous ouvrez pour la première fois une boîte de dialogue Référentiel WebDAV, le référentiel WebDAV du serveur local est sélectionné, même si le Gestionnaire d'échanges BizTalk est connecté à une base de données d'un serveur distant. Si vous accédez à un référentiel WebDAV d'un serveur distant, celui-ci devient le serveur par défaut jusqu'à ce que vous sélectionniez un nouveau référentiel WebDAV. Le serveur par défaut de toutes les boîtes de dialogue Référentiel WebDAV est le dernier serveur avec lequel une connexion a été établie.

Remarques

  • Si vous sélectionnez l'adresse http://localhost pour le serveur, le Gestionnaire d'échanges BizTalk la transforme automatiquement en nom d'ordinateur local.

  • Lorsque vous enregistrez un canal qui fait référence à un mappage externe à votre domaine local, une erreur risque de se produire. S'il se produit une erreur, téléchargez et configurez l'utilitaire proxy WinHTTP. Pour télécharger cet utilitaire, accédez au site Web Microsoft MSDN (msdn.microsoft.com/downloads/default.asp) et accédez à la page WinHTTP Proxy Configuration Utility, qui figure dans le chapitre XML du manuel Web Development.

Voir aussi

Création de canaux

Modification de canaux

Mappage de données

Définition des propriétés de canal

Définition des propriétés d'un document sortant


Sélection d'un certificat pour la signature sortante

  1. Sur la page Document sortant de l'Assistant Canal, activez la case à cocher Signer le document sortant, puis cliquez sur le bouton Parcourir situé à droite de la zone Certificat de signature.

    La boîte de dialogue Sélectionner un certificat de signature s'affiche.

  2. Dans la liste Nom de certificat, choisissez un nom de certificat et cliquez sur OK.

Pour poursuivre la définition des propriétés d'un document sortant, voir Définition des propriétés d'un document sortant.

Remarques

  • Tous les certificats sont stockés dans la zone de stockage de l'ordinateur local. Pour configurer les certificats pour les composants S/MIME en utilisant le Gestionnaire d'échanges BizTalk, vous devez appartenir à un compte d'utilisateur dans le groupe Administrateurs de Windows 2000 et les services d'Échanges BizTalk doivent fonctionner en tant que compte système local ou en tant que compte d'utilisateur dans le groupe Administrateurs de Windows 2000.

  • Les certificats doivent porter un nom unique. Si plusieurs certificats ont le même nom, il n'est possible d'en sélectionner qu'un seul. Une fois le certificat sélectionné, les autres certificats portant le même nom disparaissent de la liste.

    Pour plus d'informations sur les certificats, voir Description des certificats.

Voir aussi

Création de canaux

Modification de canaux

Définition des propriétés de canal

Définition des propriétés d'un document sortant


Remplacement des valeurs par défaut d'un port d'échanges

  1. Sur la page Configuration avancée de l'Assistant Canal, cliquez sur Avancé.

    Si vous créez ou modifiez un canal pour un port d'échanges, la boîte de dialogue Ignorer les valeurs par défaut du port d'échanges apparaît.

  2. Sous l'onglet Transport principal, cliquez sur Propriétés.

    La boîte de dialogue Propriétés des composants de BizTalk s'affiche.

  3. Modifiez les propriétés de composant de transport que vous voulez remplacer et cliquez sur OK.

  4. Si le port d'échanges comporte une enveloppe et si vous voulez modifier sa configuration, cliquez sur l'onglet Enveloppe, puis sur Propriétés.

    La boîte de dialogue Propriétés des composants de BizTalk s'affiche.

  5. Modifiez les propriétés de composant de l'enveloppe que vous voulez remplacer et cliquez sur OK.

Pour poursuivre la définition des propriétés avancées, allez dans Définition des propriétés de configuration avancées.

Important

  • La fonction de remplacement des propriétés de transport et d'enveloppe d'un port d'échanges est une fonction avancée. Si vous ne comprenez pas les propriétés de composant de transport ou d'enveloppe dans les boîtes de dialogue, ne les modifiez pas.

  • Si vous spécifiez une enveloppe avec un format personnalisé dans le port d'échanges, vous devez configurer le composant du sérialiseur à l'aide des propriétés de configuration avancées.

Remarques

  • Si vous remplacez les propriétés de port d'échanges dans un canal, ces modifications s'appliquent uniquement à ce canal.

  • L'adresse de transport définie dans un port d'échanges ne peut pas être remplacée.

  • La configuration par défaut pour le composant de transport HTTP doit utiliser le serveur proxy HTTP. Cette configuration est celle qui convient pour le transport des données vers des sites Web situés à l'extérieur du pare-feu de votre entreprise. Pour transporter des données vers des sites Web situés à l'intérieur du pare-feu de votre entreprise (c'est-à-dire sur votre intranet), utilisez cette procédure pour remplacer la configuration par défaut.

  • Pour le composant de transport HTTPS, utilisez uniquement les certificats spécifiés pour l'authentification du client. Les certificats spécifiés pour tous les rôles n'apparaissent pas dans la liste.

  • La configuration par défaut pour le composant de transport de fichiers est celle qui ajoute les fichiers. Si vous sélectionnez un type de transport de fichier configuré par défaut dans un port d'échanges, si vous utilisez un anti-virus sur le serveur sur lequel est installé BizTalk Server 2000 et si vous envoyez simultanément plusieurs fichiers portant le même nom vers le même emplacement, BizTalk Server 2000 cessera de répondre et devra être redémarré. Vous pouvez éliminer ce problème en modifiant la configuration par défaut du composant de transport de fichiers en remplaçant l'option Ajouter au fichier par Fichier de remplacement dans la boîte de dialogue Propriétés de BizTalk SendLocalFile. Vous pouvez également éliminer ce problème en créant un fichier unique pour chaque instance de document traitée à l'aide du format de chemin d'accès suivant dans le port d'échanges : fichier://C:\dir\fichier%id_suivi%.xml. Pour plus d'informations, voir Spécification d'une adresse de transport.

  • La configuration par défaut pour le composant de transport de fichiers est celle qui ajoute les fichiers. Si vous sélectionnez un type de transport de fichier configuré par défaut, un format d'enveloppe Reliable dans un port d'échanges, puis envoyez simultanément plusieurs fichiers vers le même emplacement, vous obtiendrez des résultats d'analyse inattendus. Vous pouvez éliminer ce problème en modifiant la configuration par défaut du composant de transport de fichiers en remplaçant l'option Ajouter au fichier par Fichier de remplacement dans la boîte de dialogue Propriétés de BizTalk SendLocalFile.

  • Si l'enveloppe spécifiée dans le port d'échanges a un format personnalisé et si vous avez créé et enregistré un composant de sérialiseur personnalisé, vous pouvez configurer les propriétés du composant de sérialiseur personnalisé à l'aide de cette procédure.

  • L'identificateur de syntaxe par défaut pour une enveloppe EDIFACT est UNOA (Uppercase Latin alphabet). Si une syntaxe différente est nécessaire pour vos données, sélectionnez un identificateur de syntaxe différent en utilisant cette procédure.

  • Si vous utilisez les indicateurs de libération EDIFACT, n'intégrez pas les caractères d'indicateur de libération dans vos données. Si vous procédez ainsi, les données risquent de dépasser les limites définies pour la taille physique des caractères autorisée pour les champs.

Voir aussi

Création de canaux

Modification de canaux

Définition des propriétés de configuration avancées

Définition des propriétés de canal


Remplacement des valeurs par défaut de la liste de distribution

  1. Sur la page Configuration avancée de l'Assistant Canal, cliquez sur Avancé.

    Si vous créez ou modifiez un canal pour une liste de distribution, la boîte de dialogue Remplacer les valeurs par défaut de la liste de distribution apparaît.

  2. Dans la liste Sélectionnez un port d'échanges, sélectionnez un port d'échanges que vous voulez remplacer et cliquez sur Remplacer.

    La boîte de dialogue Ignorer les valeurs par défaut du port d'échanges apparaît.

  3. Remplacez les propriétés du composant de transport et d'enveloppe pour le port d'échanges sélectionné.

    Pour plus d'informations, voir Remplacement des valeurs par défaut d'un port d'échanges.

  4. Après avoir modifié les ports d'échanges, cliquez sur Fermer.

Pour poursuivre la définition des propriétés avancées, allez dans Définition des propriétés de configuration avancées.

Voir aussi

Création de canaux

Modification de canaux

Remplacement des valeurs par défaut d'un port d'échanges

Définition des propriétés de configuration avancées

Définition des propriétés de canal


Définition du suivi pour les propriétés de document entrant

La boîte de dialogue Suivi du document entrant fournit la liste des champs de spécification disponibles pour le document entrant, ainsi que des champs de suivi global sélectionnés dans la définition du document.

Si vous sélectionnez des champs de spécification dans cette boîte de dialogue, ils remplaceront les champs de suivi global uniquement pour ce canal. Pour chaque instance de document traitée, les champs sélectionnés dans le canal sont consignés dans la base de données de suivi, plutôt que dans les champs de suivi global.

Cette section décrit comment sélectionner ou supprimer des champs de spécification de document entrant dans un canal.

Cette section traite des procédures suivantes :

  • Sélection des champs de spécification dans un canal

  • Suppression de champs de spécification dans un canal

Voir aussi

Création de canaux

Modification de canaux

Définition des propriétés de canal

Définition des propriétés de suivi global

Définition des propriétés d'un document entrant


Sélection des champs de spécification dans un canal

  1. Sur la page Document entrant de l'Assistant Canal, activez la case à cocher Suivre le document entrant et cliquez sur Suivi.

    La boîte de dialogue Suivi du document entrant s'affiche.

  2. Dans l'arborescence Champs de spécification, double-cliquez sur un enregistrement pour développer la vue.

  3. Sélectionnez un champ de spécification à ajouter dans la liste Champs à suivre et exécutez l'une des procédures suivantes :
    Ajout du champ en tant que | Suivez cette procédure
    Integer | Cliquez sur Entier. Vous pouvez ajouter deux champs pour les entiers.
    Real | Cliquez sur Réel. Vous pouvez ajouter deux champs pour les nombres réels.
    Date | Cliquez sur Date. Vous pouvez ajouter deux champs pour les dates.
    Text | Cliquez sur Texte. Vous pouvez ajouter deux champs pour le texte.
    Personnalisé | Cliquez sur Personnalisé. Vous pouvez ajouter un nombre de champs illimité pour le type Personnalisé. Les champs sont stockés sous forme de chaînes XML concaténées, avec des balises pour chaque champ.

Pour poursuivre la définition des propriétés d'un document entrant, allez dans Définition des propriétés d'un document entrant.

Important

  • Si vous sélectionnez des champs de spécification dans cette boîte de dialogue, ils remplaceront les champs de suivi global uniquement pour ce canal. Pour chaque instance de document traitée, les champs sélectionnés dans le canal sont consignés dans la base de données de suivi, plutôt que dans les champs de suivi global.

Remarques

  • Pour pouvoir sélectionner un champ de spécification pour le suivi de données de type entier, nombre réel ou date, ce type de données doit être attribué au champ dans la spécification. Pour plus d'informations sur l'affectation d'un type de données à un champ de spécification, voir Définition des propriétés de déclaration.

  • Les champs de spécification auxquels aucun type de données n'a été attribué dans la spécification peuvent uniquement faire l'objet d'un suivi sur les données de type texte ou personnalisé.

  • Si un type de données caractère a été attribué au champ de spécification dont vous voulez effectuer le suivi, celui-ci peut faire l'objet d'un suivi uniquement sur les données de type personnalisé.

  • Vous pouvez uniquement sélectionner deux champs de spécification pour un type de données spécifique. Un nombre illimité de champs peut être sélectionné comme type de données personnalisé.

Voir aussi

Création de canaux

Modification de canaux

Suppression de champs de spécification dans un canal

Définition des propriétés de canal

Définition des propriétés de suivi global

Définition du suivi pour les propriétés de document entrant

Suivi des champs de données d'un document


Suppression de champs de spécification dans un canal

  1. Sur la page Document entrant de l'Assistant Canal, activez la case à cocher Suivre le document entrant et cliquez sur Suivi.

    La boîte de dialogue Suivi du document entrant s'affiche.

  2. Dans la liste Champs à suivre, sélectionnez les champs de spécification à supprimer et cliquez sur Supprimer.

Pour poursuivre la définition des propriétés d'un document entrant, allez dans Définition des propriétés d'un document entrant.

Remarque

  • Lorsque vous supprimez un champ de la liste des champs à suivre, ce champ est uniquement supprimé de la liste pour ce canal ; il n'est pas supprimé de la spécification.

Voir aussi

Création de canaux

Modification de canaux

Sélection des champs de spécification dans un canal

Définition des propriétés de canal

Définition des propriétés de suivi global

Définition du suivi pour les propriétés de document entrant

Suivi des champs de données d'un document


Définition des propriétés de filtrage de canal

Une expression de filtrage de canal est une expression XPath qui peut être utilisée pour déterminer si un canal est invoqué en fonction de la valeur du ou des champs spécifiés dans le document. Lorsque Microsoft BizTalk Server 2000 traite un document, la valeur du ou des champs spécifiés dans chaque document est évaluée par rapport à l'expression de filtrage du canal. Si l'expression est vraie, le canal est appelé. Si l'expression est fausse, le canal n'est pas appelé.

Cette section traite des procédures suivantes :

  • Ajout d'une expression de filtrage à un canal

  • Modification d'une expression de filtrage d'un canal

  • Suppression d'une expression de filtrage d'un canal

Voir aussi

Définition des propriétés d'un document entrant


Ajout d'une expression de filtrage à un canal

  1. Sur la page Document entrant de l'Assistant Canal, activez la case à cocher Filtrer le document entrant et cliquez sur Filtrage.

    La boîte de dialogue Expressions de filtrage de canaux s'affiche.

  2. Dans l'arborescence Sélectionnez un champ, double-cliquez sur un noeud pour développer l'affichage.

  3. Cliquez sur un champ de spécification que vous voulez utiliser pour créer une expression de filtrage et cliquez sur Ajouter.

    La boîte de dialogue Nouvelle expression apparaît.

  4. Dans la liste Opérateur, sélectionnez un opérateur.
    Opérateur Symbole
    Égal à (valeur par défaut) =
    Différent de !=
    Inférieur à <
    Inférieur ou égal à <=
    Supérieur à >
    Supérieur ou égal à >=

  5. Dans la zone Valeur, tapez une valeur pour l'expression et cliquez sur OK.

Pour poursuivre la définition des propriétés d'un document entrant, allez dans Définition des propriétés d'un document entrant.

Important

  • Les expressions de filtrage de canal doivent correspondre à des expressions XPath valides. Le bouton Ajouter permet de créer une clause contenant un champ de spécification et de l'insérer dans une expression ; cependant, il ne génère pas la syntaxe correcte nécessaire pour une expression XPath valide. Pour plus d'informations sur les expressions XPath, voir Filtrage de canal, accédez ensuite au site Web Microsoft (msdn.microsoft.com/library/default.asp) et recherchez le mot-clé « XPath ».

Remarques

  • Vous pouvez entrer une expression directement dans la liste Expressions.

  • Pour sélectionner un champ de spécification pour une expression de filtrage de canal, un type de données doit être affecté au champ dans la spécification. Pour plus d'informations sur l'attribution d'un type de données à un champ de spécification, voir Définition des propriétés de déclaration.

  • Si le type de données Booléen est affecté au champ de spécification que vous utilisez pour créer une expression, vous ne pouvez pas utiliser la chaîne "vrai" ou "faux" dans la valeur de l'expression. Cette valeur doit être remplacée par une valeur numérique, "-1" pour vrai et "0" pour faux.

  • Si le type de données date est affecté au champ de spécification utilisé pour créer une expression, tapez la valeur au format suivant, tirets inclus : AAAA-MM-JJ.

Voir aussi

Création de canaux

Modification d'une expression de filtrage d'un canal

Modification de canaux

Suppression d'une expression de filtrage d'un canal

Définition des propriétés de filtrage de canal

Définition des propriétés de canal


Modification d'une expression de filtrage d'un canal

  1. Sur la page Document entrant de l'Assistant Canal, activez la case à cocher Filtrer le document entrant et cliquez sur Filtrage.

    La boîte de dialogue Expressions de filtrage de canaux s'affiche.

  2. Dans la liste Expressions, modifiez l'expression et cliquez sur OK.

Pour poursuivre la définition des propriétés d'un document entrant, allez dans Définition des propriétés d'un document entrant.

Important

  • Les expressions de filtrage de canal doivent correspondre à des expressions XPath valides. Pour plus d'informations sur les expressions XPath, voir Filtrage de canal, accédez ensuite au site Web Microsoft (msdn.microsoft.com/library/default.asp) et recherchez le mot-clé « XPath ».

Voir aussi

Ajout d'une expression de filtrage à un canal

Suppression d'une expression de filtrage d'un canal

Définition des propriétés de filtrage de canal


Suppression d'une expression de filtrage d'un canal

  • Sur la page Document entrant de l'Assistant Canal, désactivez la case à cocher Filtrer le document entrant.

Pour poursuivre la définition des propriétés d'un document entrant, allez dans Définition des propriétés d'un document entrant.

Voir aussi

Ajout d'une expression de filtrage à un canal

Création de canaux

Modification d'une expression de filtrage d'un canal

Modification de canaux

Définition des propriétés de filtrage de canal

Définition des propriétés de canal


Création et gestion des ports d'échanges

Cette section fournit des informations spécifiques aux tâches quant à la création et à la gestion des ports d'échanges. Nous vous recommandons vivement de revoir Description des ports d'échanges dans la section Concepts pour comprendre pleinement le concept des ports d'échanges.

Cette section traite des procédures suivantes :

  • Création de ports d'échanges

  • Recherche de ports d'échanges

  • Modification de ports d'échanges

  • Suppression de ports d'échanges

  • Définition des propriétés d'un port d'échanges


Création de ports d'échanges

  1. Dans le Gestionnaire d'échanges BizTalk, dans le menu Fichier, pointez sur Nouveau, sur Port d'échanges, puis exécutez l'une des étapes suivantes :
    • Pour créer un port d'échanges vers une organisation de partenaire commercial, cliquez sur Vers une organisation.

    • Pour créer un port d'échanges vers une application interne, cliquez sur Vers une application.

    L'Assistant Nouveau port d'échanges s'ouvre.

  2. Définissez les propriétés sur la page Informations générales, puis cliquez sur Suivant.

    Pour plus d'informations, voir Définition des propriétés des informations générales d'un port d'échanges.

  3. Exécutez une des étapes suivantes :
    • Si vous créez un port d'échanges vers une organisation spécifique, définissez les propriétés sur la page Organisation de destination, puis cliquez sur Suivant. Pour plus d'informations, voir Définition des propriétés de l'organisation de destination.

    • Si vous créez un port d'échanges ouvert, cliquez sur Destination ouverte, puis sur Suivant.

      Pour un port d'échanges ouvert, les informations relatives au transport et à la destination doivent être fournies soit dans le document, soit dans un paramètre envoyé avec le document. Pour plus d'informations, voir Envoi.

    • Si vous créez un port d'échanges vers une application, définissez les propriétés sur la page Application de destination, puis cliquez sur Suivant. Pour plus d'informations, voir Définition des propriétés de l'application de destination.
  4. Sur la page Informations d'enveloppe, définissez les propriétés, puis cliquez sur Suivant.

    Pour plus d'informations, voir Définition des propriétés des informations d'enveloppe.

  5. Sur la page Informations de sécurité, définissez les propriétés.

    Pour plus d'informations, voir Définition des propriétés des informations de sécurité.

  6. Si vous ne voulez pas passer directement à l'Assistant Canal pour créer un canal, désactivez la case à cocher Créer un canal pour ce port d'échanges. Dans le cas contraire, cliquez sur l'un des types de canal suivants dans la liste Type de canal :
    • À partir d'une organisation

    • À partir d'une application
  7. Après avoir défini toutes les propriétés du port d'échanges, sur la page Informations de sécurité, cliquez sur Terminer pour fermer l'Assistant Port d'échanges.

Important

  • Lorsque vous déclarez un port d'échanges comme étant un port d'échanges ouvert, ne créez pas pour le port d'échanges des canaux dont la définition du document sortant comporte une spécification X12 ou EDIFACT. Pour générer une enveloppe X12 ou EDIFACT, le serveur nécessite un identificateur d'organisation pour la source et la destination. Un port d'échanges ouvert ne spécifie pas l'identificateur de l'organisation de destination. De plus, les documents d'un port d'échanges ouvert doivent contenir l'adresse de destination, mais les documents X12 et EDIFACT n'incluent pas cette information.

Remarques

  • Vous ne pouvez pas attribuer à un port d'échanges le nom système réservé, à savoir Port des accusés de réception d'échanges au format Reliable.

  • Si vous créez un port d'échanges et un canal en vue d'une soumission directe de données, vous pouvez uniquement utiliser, pour le canal, la fenêtre de service ainsi que les fonctionnalités de compteur et d'intervalle pour les nouveaux essais. En ce qui concerne le port d'échanges associé, seules les fonctionnalités de transport sont disponibles. Vous ne pouvez utiliser ni la vérification de décodage ou de décryptage, ni le filtrage, ni le suivi de documents, ni les fonctions de mappage du canal.

Voir aussi

Création et gestion de canaux

Suppression de ports d'échanges

Modification de ports d'échanges

Recherche de ports d'échanges

Définition des propriétés d'un port d'échanges

Description des ports d'échanges


Recherche de ports d'échanges

  1. Dans le Gestionnaire d'échanges BizTalk, dans la zone Rechercher d'autres éléments, cliquez sur Ports d'échanges.

  2. Effectuez une ou plusieurs des actions suivantes :
    • Pour rechercher tous les ports d'échanges, effacez tous les critères de recherche et cliquez sur Rechercher.

    • Pour rechercher un port d'échanges portant un nom spécifique, dans la zone Nom du port d'échanges, tapez le nom du port d'échanges que vous voulez rechercher et cliquez sur Rechercher. Si vous entrez un nom incomplet, la recherche renverra tous les noms possibles correspondant à votre entrée.

    • Pour rechercher des ports d'échanges en référence à un type spécifique de destination, dans la liste Destination, cliquez sur un type de destination, puis sur Rechercher.

Remarques

  • Vous pouvez définir plusieurs critères de recherche avant de cliquer sur Rechercher.

  • Si vous devez rechercher un grand nombre d'objets, le renvoi de tous les objets peut prendre plusieurs minutes. Vous pouvez limiter les objets renvoyés à la suite d'une recherche en définissant des critères de sélection.

  • Une recherche renvoie par défaut 500 objets, mais vous pouvez modifier ce nombre. Pour plus d'informations, voir Définition des options de connexion du serveur.

  • Pour effacer les critères et les résultats de la recherche, cliquez sur Effacer.

  • Vous pouvez utiliser les caractères génériques suivants dans vos critères de recherche.
    Caractère générique | Description | Exemple
    % Toute chaîne de zéro caractère ou plus L'entrée '%ouvert%' renvoie tous les noms contenant le terme « ouvert ».
    _ (soulignement) | N'importe quel caractère | L'entrée « _ean » renvoie tous les noms de quatre lettres qui se terminent par « ean » (Dean, Sean, etc.).
    [ ] Tout caractère de l'intervalle ([a-f]) ou de l'ensemble spécifié ([abcdef]) L'entrée « [C-P]arsen » renvoie les noms se terminant par « arsen » et commençant par un caractère compris entre C et P (Carsen, Larsen, Karsen, etc.).
    [^] Tout caractère non compris dans l'intervalle ([^a-f]) ou l'ensemble (^abcdef]) spécifié L'entrée « de[^s]% » renvoie tous les noms commençant par « de » et dont la lettre suivante n'est pas un « s ».

Voir aussi

Suppression de ports d'échanges

Modification de ports d'échanges

Description des ports d'échanges


Modification de ports d'échanges

  1. Dans le Gestionnaire d'échanges BizTalk, dans la liste Nom du port d'échanges, cliquez sur le port d'échanges que vous voulez modifier.

    Pour des informations sur la recherche de ports d'échanges, voir Recherche de ports d'échanges.

  2. Dans le menu Fichier, cliquez sur Edition.

    L'Assistant Propriétés du port d'échanges s'ouvre.

  3. Sur la page Informations générales, modifiez les propriétés appropriées.

    Pour plus d'informations, voir Définition des propriétés des informations générales d'un port d'échanges.

    Après avoir modifié les propriétés sur une page, vous pouvez cliquez sur Terminer pour fermer l'Assistant Propriétés du port d'échanges ou sur Suivant pour modifier d'autres propriétés du port d'échanges.

  4. Exécutez une des étapes suivantes :
    • Si vous modifiez un port d'échanges vers une organisation, modifiez les propriétés nécessaires sur la page Organisation de destination, puis cliquez sur Suivant. Pour plus d'informations, voir Définition des propriétés de l'organisation de destination.

    • Si vous modifiez un port d'échanges vers une application, modifiez les propriétés nécessaires sur la page Application de destination, puis cliquez sur Suivant. Pour plus d'informations, voir Définition des propriétés de l'application de destination.
  5. Sur la page Informations d'enveloppe, modifiez les propriétés nécessaires, puis cliquez sur Suivant.

    Pour plus d'informations, voir Définition des propriétés des informations d'enveloppe.

  6. Dans la page Informations de sécurité, modifiez les propriétés appropriées.

    Pour plus d'informations, voir Définition des propriétés des informations de sécurité.

  7. Si vous ne voulez pas passer directement à l'Assistant Canal pour créer un canal, désactivez la case à cocher Créer un canal pour ce port d'échanges. Dans le cas contraire, cliquez sur l'un des types de canal suivants dans la liste Type de canal :
    • À partir d'une organisation

    • À partir d'une application
  8. Après avoir modifié toutes les propriétés nécessaires pour le port d'échanges, vous pouvez cliquer sur Terminer sur n'importe quelle page pour fermer l'Assistant Port d'échanges.

Remarque

  • Vous ne pouvez pas attribuer à un port d'échanges le nom système réservé, à savoir Port des accusés de réception d'échanges au format Reliable.

Voir aussi

Création et gestion de canaux

Création de ports d'échanges

Suppression de ports d'échanges

Définition des propriétés d'un port d'échanges

Description des ports d'échanges


Suppression de ports d'échanges

  1. Dans le Gestionnaire d'échanges BizTalk, dans la liste Nom du port d'échanges, cliquez sur le port d'échanges que vous voulez supprimer.

    Pour des informations sur la recherche de ports d'échanges, voir Recherche de ports d'échanges.

  2. Dans le menu Fichier, cliquez sur Supprimer.

Remarques

  • Si vous avez créé des canaux pour un port d'échanges, vous ne pouvez pas supprimer ce port d'échanges tant que les canaux y étant associés n'ont pas été supprimés.

  • Pour rechercher des canaux associés à un port d'échanges, cliquez avec le bouton droit sur le port d'échanges et cliquez sur Rechercher des canaux.

Voir aussi

Création et gestion de canaux

Création de ports d'échanges

Modification de ports d'échanges

Description des ports d'échanges


Définition des propriétés d'un port d'échanges

Cette section fournit des informations spécifiques aux tâches quant à la configuration des propriétés d'un port d'échanges. Cette section traite des procédures suivantes :

  • Définition des propriétés des informations générales d'un port d'échanges

  • Définition des propriétés de l'organisation de destination

  • Définition des propriétés d'une application de destination

  • Définition des propriétés des informations d'enveloppe

  • Définition des propriétés des informations de sécurité

  • Sélection d'une organisation de destination

  • Sélection d'un certificat de cryptage

  • Définition des propriétés de transport

  • Définition des séparateurs d'enveloppes.


Définition des propriétés des informations générales d'un port d'échanges

  1. Sur la page Informations générales de l'Assistant Port d'échanges, dans la zone Nom, tapez le nom du port d'échanges.

  2. Dans la zone Commentaires, tapez les éventuels commentaires que vous voulez définir pour le port d'échanges, puis cliquez sur Suivant.

Si vous créez un nouveau port d'échanges, cliquez sur Suivant. Pour obtenir des instructions sur l'exécution de l'étape suivante, voir Création de ports d'échanges.

Si vous modifiez un port d'échanges existant, cliquez sur Suivant. Pour obtenir des instructions sur l'exécution de l'étape suivante, voir Modification de ports d'échanges. Une fois vos modifications effectuées, cliquez sur Terminer.

Voir aussi

Création de ports d'échanges

Modification de ports d'échanges

Définition des propriétés d'un port d'échanges


Définition des propriétés de l'organisation de destination

  1. Sur la page Organisation de destination de l'Assistant Port d'échanges, exécutez l'une des étapes suivantes :
    • Cliquez sur Destination ouverte pour créer un port d'échanges ouvert, puis cliquez sur Suivant.

      Pour un port d'échanges ouvert, les informations relatives au transport et à la destination doivent être fournies soit dans le document, soit dans des paramètres envoyés avec le document. Pour plus d'informations, voir Envoi.

    • Cliquez sur Organisation pour désigner comme destination une organisation de partenaire commercial spécifique, puis passez à l'étape 2.
  2. Dans la zone Organisation, cliquez sur Parcourir.

    La boîte de dialogue Sélectionner une organisation s'affiche.

  3. Cliquez sur une organisation, puis sur OK.

    Pour plus d'informations, voir Sélection d'une organisation de destination.

  4. Dans la zone Transport principal, cliquez sur Parcourir.

    La boîte de dialogue Transport principal s'affiche.

  5. Définissez les propriétés du transport principal.

    Pour plus d'informations, voir Définition des propriétés de transport.

  6. Si vous voulez limiter la période de temps durant laquelle le transport de documents peut avoir lieu, dans la zone Transport principal, activez la case à cocher Fenêtre de service.

    Ensuite, dans les zones De et À, cliquez sur l'heure et entrez une valeur, ou cliquez sur la flèche haut ou bas pour augmenter ou diminuer la valeur.

  7. Si vous voulez spécifier un transport secondaire, dans la zone Transport secondaire, cliquez sur Parcourir.

    La boîte de dialogue Transport secondaire s'affiche.

  8. Définissez les propriétés du transport secondaire.

    Pour plus d'informations, voir Définition des propriétés de transport.

Si vous créez un nouveau port d'échanges, cliquez sur Suivant. Pour obtenir des instructions sur l'exécution de l'étape suivante, voir Création de ports d'échanges.

Si vous modifiez un port d'échanges existant, cliquez sur Suivant. Pour obtenir des instructions sur l'exécution de l'étape suivante, voir Modification de ports d'échanges. Une fois vos modifications effectuées, cliquez sur Terminer.

Important

  • Lorsque vous déclarez un port d'échanges comme étant un port d'échanges ouvert, ne créez pas pour le port d'échanges des canaux dont la définition du document sortant comporte une spécification X12 ou EDIFACT. Pour générer une enveloppe X12 ou EDIFACT, le serveur nécessite un identificateur d'organisation pour la source et la destination. Un port d'échanges ouvert ne spécifie pas l'identificateur de l'organisation de destination. De plus, les documents d'un port d'échanges ouvert doivent contenir l'adresse de destination, mais les documents X12 et EDIFACT n'incluent pas cette information.

Remarque

  • Les heures figurant dans les fenêtres de service sont affichées au format UTC (Universal Coordinated Time - Temps universel coordonné) et correspondent à l'heure définie sur le serveur.

Voir aussi

Création de ports d'échanges

Modification de ports d'échanges

Définition des propriétés d'un port d'échanges


Définition des propriétés d'une application de destination

  1. Sur la page Application de destination de l'Assistant Port d'échanges, exécutez l'une des étapes suivantes :
    • Cliquez sur Nouvelle planification XLANG pour désigner comme destination un port d'une nouvelle instance d'une planification XLANG spécifiée. Dans la zone Moniker de la planification, tapez le moniker de la planification spécifiée, ou cliquez sur Parcourir pour définir le chemin d'accès. Ensuite, dans la zone Nom du port, tapez le nom du port spécifique de cette planification vers lequel le document est envoyé.

      Pour les monikers de planification, la syntaxe est la suivante :

      sked://[LocalHost][!GestionnaireGroupe][/CheminFichier][/NomPort]

      Vous pouvez uniquement activer les planifications XLANG de l'ordinateur local.

      Pour plus d'informations sur les monikers, voir Syntaxe du moniker.

    • Cliquez sur Planification XLANG en cours pour désigner comme destination une instance de planification XLANG active. ???Utilisez cette option uniquement pour transporter un message vers une planification XLANG active lorsqu'un partenaire commercial renvoie le message à une page ASP spécialement configurée via un transport HTTP. Pour plus d'informations, voir Intégration des services BizTalk.

    • Cliquez sur Application pour désigner comme destination une application de l'organisation principale. Cliquez ensuite sur une application dans la liste Nom.
  2. Si vous avez sélectionné une application comme destination, exécutez les étapes 3 à 5. Sinon, cliquez sur Suivant.

  3. Dans la zone Transport principal, cliquez sur Parcourir.

    La boîte de dialogue Transport principal s'affiche.

  4. Définissez les propriétés du transport principal.

    Pour plus d'informations, voir Définition des propriétés de transport.

  5. Si vous voulez limiter la période de temps durant laquelle le transport de documents peut avoir lieu, dans la zone Transport principal, activez la case à cocher Fenêtre de service.

    Ensuite, dans les zones De et À, cliquez sur l'heure et entrez une valeur, ou cliquez sur la flèche haut ou bas pour augmenter ou diminuer la valeur.

  6. Si vous voulez spécifier un transport secondaire, dans la zone Transport secondaire, cliquez sur Parcourir.

    La boîte de dialogue Transport secondaire s'affiche.

  7. Définissez les propriétés du transport secondaire.

    Pour plus d'informations, voir Définition des propriétés de transport.

Si vous créez un nouveau port d'échanges, cliquez sur Suivant. Pour obtenir des instructions sur l'exécution de l'étape suivante, voir Création de ports d'échanges.

Si vous modifiez un port d'échanges existant, cliquez sur Suivant. Pour obtenir des instructions sur l'exécution de l'étape suivante, voir Modification de ports d'échanges. Une fois vos modifications effectuées, cliquez sur Terminer.

Important

  • Si vous choisissez l'option Nouvelle planification XLANG :
    • Le port que vous déterminez doit être lié aux services d'Échanges BizTalk dans la planification spécifiée, et cette liaison doit être configurée de manière à activer une nouvelle instance de planification à l'arrivée des messages.

    • Dans une planification, un seul port doit être configuré de manière à activer une nouvelle instance de planification à l'arrivée des messages, et il doit s'agir de la première action de la planification. Pour plus d'informations, voir Implémentation d'un port à l'aide d'Échanges BizTalk.

Remarques

  • Si vous définissez une planification XLANG comme destination d'un port d'échanges, les documents que vous traitez via ce port d'échanges sont limités à 2 Mo.

  • Le Concepteur d'Orchestration BizTalk vous permet de créer des planifications XLANG.

  • Les heures figurant dans les fenêtres de service sont affichées au format UTC (Universal Coordinated Time - Temps universel coordonné) et correspondent à l'heure définie sur le serveur.

Voir aussi

Création de ports d'échanges

Modification de ports d'échanges

Définition des propriétés d'un port d'échanges


Définition des propriétés des informations d'enveloppe

  1. Sur la page Informations d'enveloppe de l'Assistant Port d'échanges, dans la zone Informations d'enveloppe, sélectionnez une enveloppe dans la liste.

    Si vous sélectionnez une enveloppe présentant un format X12 ou EDIFACT, les étapes suivantes s'avèrent nécessaires. Si vous sélectionnez une enveloppe au format personnalisé, les étapes suivantes sont facultatives.

    1. Cliquez sur Séparateurs et définissez les propriétés des séparateurs.

      Pour plus d'informations, voir Définition des séparateurs d'enveloppes.

    2. Dans la zone Numéro de contrôle d'échange, tapez un numéro de contrôle d'échange.
  2. Si vous voulez remplacer l'identificateur d'organisation par défaut pour l'organisation de destination, cliquez sur un autre identificateur dans la liste Identificateur d'organisation.

Si vous créez un nouveau port d'échanges, cliquez sur Suivant. Pour obtenir des instructions sur l'exécution de l'étape suivante, voir Création de ports d'échanges.

Si vous modifiez un port d'échanges existant, cliquez sur Suivant. Pour obtenir des instructions sur l'exécution de l'étape suivante, voir Modification de ports d'échanges. Une fois vos modifications effectuées, cliquez sur Terminer.

Important

  • Si vous sélectionnez une enveloppe utilisant un format Reliable, vous devez également configurer l'adresse de l'URL de réponse d'échange de type Reliable dans la boîte de dialogue Propriétés du groupe de serveurs BizTalk Server. Pour plus d'informations, voir Configuration des propriétés générales d'un groupe de serveurs.

  • Le format d'enveloppe que vous spécifiez dans un port d'échanges doit correspondre au format du ou des documents qu'il contient. Le format de document est déterminé par la spécification à laquelle il est fait référence dans la définition de document sortant d'un canal associé. Par exemple, si vous choisissez une enveloppe au format X12 pour un port d'échanges, vous devez sélectionner une définition de document sortant pour le canal pointant vers une spécification X12.

Remarques

  • Lors du traitement d'enveloppes compatibles avec BizTalk Framework 2.0, BizTalk Server 2000 doit être considéré comme étant le point final par rapport au délai d'expiration. Lorsque les documents compatibles avec BizTalk Framework 2.0 sont envoyés à BizTalk Server 2000 soit d'une application, soit d'un partenaire commercial, les champs ci-dessous sont remplacés s'ils sont présents et créés s'ils n'existent pas encore :
    • Dans la sous-section relative aux propriétés :

      <prop:identity>

      <prop:sentAt>

      <expiresAt>

    • Dans la sous-section relative aux informations de réception :

      <sendTo>

      <adresse>

      <sendReceiptBy>

  • Pour un port d'échanges vers une application, les identificateurs d'organisation disponibles dans la liste Identificateur d'organisation sont ceux de l'organisation d'origine.

  • Si vous utilisez le type de transport Loopback, vous ne pouvez pas choisir une enveloppe au format Reliable.

  • Lorsque vous sélectionnez un identificateur d'organisation de destination destiné à être utilisé avec des enveloppes X12, vous ne pouvez pas sélectionner l'identificateur d'organisation dénommé Organisation ni tout autre identificateur dont le qualificateur excède 2 caractères ou dont la valeur dépasse 15 caractères.

  • Lorsque vous sélectionnez un identificateur d'organisation de destination destiné à être utilisé avec des enveloppes EDIFACT, vous ne pouvez pas sélectionner l'identificateur d'organisation dénommé Organisation ni tout autre identificateur dont le qualificateur excède 4 caractères ou dont la valeur dépasse 35 caractères.

  • Si vous sélectionnez une enveloppe au format EDIFACT, l'identificateur de syntaxe par défaut est « UNOA » (alphabet latin en majuscules). Si vos données requièrent une autre syntaxe, définissez un autre identificateur de syntaxe en modifiant les valeurs par défaut du port d'échanges dans l'Assistant Canal. Pour plus d'informations, voir Remplacement des valeurs par défaut d'un port d'échanges.

Voir aussi

Création d'enveloppes

Création de ports d'échanges

Modification de ports d'échanges

Définition des propriétés d'un port d'échanges

Description des enveloppes


Définition des propriétés des informations de sécurité

  1. Sur la page Informations de sécurité de l'Assistant Port d'échanges, dans la zone Codage, dans la liste Type, sélectionnez un des éléments suivants :
    • (Aucun). Spécifie l'absence de codage. Il s'agit de la configuration par défaut.

    • MIME. Spécifie un codage MIME (Multipurpose Internet Mail Extensions).

    • Personnalisé. Spécifie un codage utilisant un composant de codage personnalisé.

    Remarques

    • Vous pouvez spécifier un composant de codage personnalisé et configurer l'identificateur de classe (CSLID) en utilisant simplement le modèle d'objets de configuration d'Échanges BizTalk.

    • Si vous spécifiez une enveloppe utilisant un format Reliable ou une enveloppe utilisant un format XML personnalisé sans spécification d'enveloppe et que votre document ne contient pas de pièces jointes, le codage MIME n'est pas appliqué à votre envoi, même si vous avez défini le paramétrage correspondant.
  2. Dans la zone Cryptage, dans la liste Type, cliquez sur une des possibilités suivantes :
    • (Aucun). Spécifie l'absence de cryptage. Il s'agit de la configuration par défaut.

    • S/MIME. Spécifie un cryptage S/MIME (Secure Multipurpose Internet Mail Extensions).

    • Personnalisé. Spécifie un codage utilisant un composant de cryptage personnalisé.

    Remarque

    • Vous pouvez spécifier un composant de cryptage personnalisé et configurer l'identificateur de classe (CSLID) en utilisant simplement le modèle d'objets de configuration d'Échanges BizTalk.
  3. Si vous sélectionnez le cryptage S/MIME, dans la zone Cryptage, cliquez sur Parcourir.

    La boîte de dialogue Sélectionner un certificat de cryptage s'affiche.

  4. Sélectionnez un certificat de cryptage.

    Pour plus d'informations, voir Sélection d'un certificat de cryptage.

  5. Dans la zone Signature, dans la liste Type, cliquez sur un des éléments suivants :
    • (Aucun). Spécifie l'absence de signature. Il s'agit de la configuration par défaut.

    • S/MIME. Spécifie une signature S/MIME (Secure Multipurpose Internet Mail Extensions).

    • Personnalisé. Spécifie un codage utilisant un composant de signature personnalisé.

    Remarque

    • Vous pouvez spécifier un composant de signature personnalisé et configurer l'identificateur de classe (CSLID) en utilisant simplement le modèle d'objets de configuration d'Échanges BizTalk.
  6. Si vous ne voulez pas passer directement à l'Assistant Canal pour créer un canal, désactivez la case à cocher Créer un canal pour ce port d'échanges. Dans le cas contraire, cliquez sur l'un des types de canal suivants dans la liste Type de canal :
    • À partir d'une organisation

    • À partir d'une application

Si vous créez un nouveau port d'échanges, cliquez sur Suivant. Pour obtenir des instructions sur l'exécution de l'étape suivante, voir Création de ports d'échanges.

Si vous modifiez un port d'échanges existant, cliquez sur Suivant. Pour obtenir des instructions sur l'exécution de l'étape suivante, voir Modification de ports d'échanges. Une fois vos modifications effectuées, cliquez sur Terminer.

Voir aussi

Création de canaux

Création de ports d'échanges

Modification de ports d'échanges

Définition des propriétés d'un port d'échanges


Sélection d'une organisation de destination

  1. Sur la page Organisation de destination de l'Assistant Port d'échanges, cliquez sur Organisation, puis sur Parcourir.

    La boîte de dialogue Sélectionner une organisation s'affiche.

  2. Dans la liste Organisations disponibles, cliquez sur une organisation puis sur OK.

Pour poursuivre la définition des propriétés de l'organisation de destination, reportez-vous à Définition des propriétés de l'organisation de destination.

Voir aussi

Création de ports d'échanges

Définition des propriétés de l'organisation de destination

Définition des propriétés d'un port d'échanges


Sélection d'un certificat de cryptage

  1. Sur la page Informations de sécurité de l'Assistant Port d'échanges, dans la zone Cryptage, dans la liste Type, cliquez sur S/MIME, puis sur Parcourir.

    La boîte de dialogue Sélectionner un certificat de cryptage s'affiche.

  2. Dans la liste Nom de certificat, choisissez un nom de certificat et cliquez sur OK.

Pour poursuivre la définition des propriétés de sécurité, accédez à Définition des propriétés des informations de sécurité.

Remarques

  • Les certificats doivent porter un nom unique. Si plusieurs certificats ont le même nom, il n'est possible d'en sélectionner qu'un seul. Une fois le certificat sélectionné, les autres certificats portant le même nom disparaissent de la liste.

    Pour plus d'informations sur les certificats, voir Description des certificats.

Voir aussi

Création de ports d'échanges

Définition des propriétés d'un port d'échanges

Définition des propriétés des informations de sécurité


Définition des propriétés de transport

Parmi les propriétés de transport figure le type de transport. Le type de transport spécifie le service de transport utilisé par Microsoft BizTalk Server 2000 pour transmettre les documents à la destination désignée dans le port d'échanges. Les propriétés de transport peuvent également comprendre une adresse spécifique pour l'expédition des données. Les propriétés d'adresse diffèrent en fonction du type de transport sélectionné.

Cette section décrit les procédures de définition des propriétés des transports primaire et secondaire pour un port d'échanges. Les procédures suivantes sont traitées :

  • Sélection d'un type de transport

  • Spécification d'une adresse de transport

  • Sélection d'un composant d'intégration aux applications


Sélection d'un type de transport

  1. Sur la page Application de destination ou Organisation de destination de l'Assistant Port d'échanges, dans la zone Transport principal ou Transport secondaire, cliquez sur Parcourir.

    La boîte de dialogue Transport principal ou Transport secondaire s'affiche.

  2. Dans la liste Type de transport, cliquez sur l'un des types de transport suivants :
    • Composant d'intégration aux applications. Spécifie un transport utilisant un composant d'intégration aux applications enregistré avec BizTalk Server 2000.

    • Fichier. Spécifie un transport utilisant le composant SendLocalFile.

    • HTTP. Spécifie un transport utilisant le protocole HTTP (Hypertext Transfer Protocol).

    • HTTPS. Spécifie un transport utilisant le protocole HTTPS (Secure Hypertext Transfer Protocol).

    • Loopback. Spécifie un transport qui renvoie le document sortant d'un canal à une application professionnelle, à un composant ou à une planification XLANG ayant envoyé le document entrant via un appel d'envoi synchrone. Ce type de transport est uniquement disponible pour un port d'échanges envoyant des documents à une application.

    • Message Queuing. Spécifie un transport utilisant le service Message Queuing.

    • SMTP. Spécifie un transport utilisant le protocole SMTP (Simple Mail Transfer Protocol).
  3. Exécutez une des étapes suivantes :
    • Si vous sélectionnez le type de transport Composant d'intégration de l'application, voir Sélection d'un composant d'intégration aux applications.

    • Si vous sélectionnez le type de transport Loopback, aucune adresse de transport n'est requise.

    • Si vous sélectionnez tout autre type de transport, voir Spécification d'une adresse de transport.

Remarques

  • Si vous choisissez le type de transport Message Queuing et que vous n'utilisez pas d'enveloppe, les messages que vous traitez via ce port d'échanges sont limités à une taille de 2 Mo.

  • Si vous choisissez le type de transport Message Queuing et que vous utilisez une enveloppe, les messages que vous traitez via ce port d'échanges sont limités à une taille de 4 Mo.

  • Pour pouvoir utiliser le type de transport SMTP, vous devez configurer l'hôte SMTP dans BizTalk Administration. Pour plus d'informations, voir Configuration des propriétés générales d'un groupe de serveurs.

  • La configuration par défaut pour le composant de transport HTTP doit utiliser le serveur proxy HTTP. Cette configuration est celle qui convient pour le transport des données vers des sites Web situés à l'extérieur du pare-feu de votre entreprise. Pour transporter des données vers des sites Web situés à l'intérieur du pare-feu de votre entreprise (c'est-à-dire, dans votre intranet), modifiez les paramètres par défaut dans le canal. Pour plus d'informations, voir Remplacement des valeurs par défaut d'un port d'échanges.

  • Le type de transport Loopback peut être utilisé pour mapper un document entrant sur un format ou une enveloppe différents ou pour sécuriser le document (codage, cryptage, signature numérique), pour ensuite renvoyer à l'appelant le document sortant en tant que document de réponse, et ce, d'une façon synchrone.

  • Si vous optez pour le type de transport Loopback, vous ne pouvez pas utiliser une enveloppe au format Reliable.

Voir aussi

Création de ports d'échanges

Sélection d'un composant d'intégration aux applications

Définition des propriétés d'un port d'échanges

Définition des propriétés de transport

Spécification d'une adresse de transport


Spécification d'une adresse de transport

  1. Sur la page Application de destination ou Organisation de destination de l'Assistant Port d'échanges, dans la zone Transport principal ou Transport secondaire, cliquez sur Parcourir.

    La boîte de dialogue Transport principal ou Transport secondaire s'affiche.

  2. Dans la liste Type de transport, cliquez sur un type de transport autre que Loopback ou Composant d'intégration aux applications.

  3. Dans la zone Adresse, tapez une adresse pour la destination.

  4. Si vous avez sélectionné le type de transport SMTP, tapez une adresse dans la zone Adresse de messagerie de retour.

    Le serveur utilise cette adresse en tant qu'adresse d'expédition dans l'en-tête sortant et en tant que destination pour les messages de retour.

Pour poursuivre la définition des propriétés de l'organisation de destination, reportez-vous à Définition des propriétés de l'organisation de destination.

Important

  • Pour le type de transport Fichier, la configuration par défaut du composant de transport consiste à ajouter de nouveaux fichiers à un fichier existant dans le répertoire spécifié.

  • Si vous utilisez le type de transport Fichier pour envoyer plusieurs fichiers portant le même nom dans le même répertoire et que ces fichiers présentent des formats de document différents ou utilisent des pages de code différentes, les données du fichier d'ajout seront endommagées.

  • Si vous voulez créer un nouveau fichier pour chaque instance de document, vous devez utiliser le format suivant pour le chemin d'accès au fichier :

    file://C:\dir\file%tracking_id%.xml

Remarques

  • Pour tous les types de transport à l'exception de Message Queuing, un préfixe est automatiquement créé pour l'adresse. Ce préfixe est requis et ne doit pas être supprimé.

  • Pour le type de transport Message Queuing, les conditions suivantes doivent être remplies pour que l'adresse soit valide :
    • N'utilisez pas le préfixe « file d'attente:// » dans l'adresse.

    • Utilisez un nom de format plutôt qu'un chemin d'accès. Exemples de noms de format valides :

      DIRECT=Protocole:<NomServeur>\<NomFileAttente>

      PUBLIC=QueueGUID

      PRIVATE=MachineGUID\QueueNumber

      Pour plus d'informations sur Message Queuing, accédez au site Web de Microsoft (msdn.microsoft.com/library) et recherchez les mots clés « Message Queuing ».

  • Pour le type de transport Fichier, les conditions suivantes doivent être remplies pour que l'adresse soit valide :
    • Le chemin d'accès au fichier que vous spécifiez doit exister. Le chemin d'accès au fichier n'est pas créé automatiquement, et vous n'obtenez pas d'avertissement vous indiquant qu'il n'existe pas.

    • Vous devez obligatoirement spécifier un nom de fichier avec une extension.

      Exemple de chemin d'accès valide :

      file://C:\dir\file.xml

  • Pour le type de transport Fichier, vous pouvez inclure des caractères et des symboles afin de modifier dynamiquement le nom de fichier. Le nom de fichier créé par le serveur contient tous les caractères statiques que vous tapez dans la zone Adresse, ainsi que la valeur du symbole. Par exemple, si vous tapez file://C:\Commandes\Facture_%tracking_id%.xml dans la zone Adresse, le nom de fichier réel pourrait correspondre à C:\Commandes\Facture_{12345678-90AB-CDEF-1234-567890ABCDEF}.

    Le tableau suivant contient les symboles que vous pouvez utiliser avec le type de transport Fichier.
    Symbole | Description | Nom de fichier unique
    %dateheure% | Date et heure, en millisecondes, de la création du fichier. L'heure est basée sur l'heure du méridien de Greenwich (GMT) plutôt que sur l'heure locale. | Non
    %nom_document% | Nom du document traité par BizTalk Server | Non
    %serveur% | Nom d'hôte du serveur ayant traité le document | Non
    %id_suivi% | Numéro de suivi universel unique | Oui
    %uid% | Compteur qui augmente avec le temps, représenté en millisecondes. Ce nombre est réinitialisé lorsque le serveur est redémarré. | Non

  • La configuration par défaut pour le composant de transport de fichiers est celle qui ajoute les fichiers. Si vous sélectionnez le type de transport Fichier avec ses paramètres par défaut dans un port d'échanges et que vous utilisez un logiciel antivirus sur le serveur sur lequel BizTalk Server 2000 est installé, alors, si vous envoyez simultanément, vers le même emplacement de fichier, plusieurs fichiers portant exactement le même nom, BizTalk Server 2000 risque de ne plus répondre et doit éventuellement être redémarré. Vous pouvez éliminer ce problème en modifiant la configuration par défaut du composant de transport de fichiers en remplaçant l'option Ajouter au fichier par Fichier de remplacement dans la boîte de dialogue Propriétés de BizTalk SendLocalFile. Vous pouvez également éliminer ce problème en créant un fichier unique pour chaque instance de document traitée à l'aide du format de chemin d'accès suivant dans le port d'échanges : fichier://C:\dir\fichier%id_suivi%.xml. Pour plus d'informations sur le remplacement du paramètre de concaténation pour le composant de transport de fichier dans les propriétés avancées du canal, voir Remplacement des valeurs par défaut d'un port d'échanges.

  • La configuration par défaut pour le composant de transport de fichiers est celle qui ajoute les fichiers. Si vous sélectionnez le type de transport Fichier avec ses paramètres par défaut et que vous sélectionnez une enveloppe au format Reliable dans un port d'échanges, alors, si vous envoyez simultanément plusieurs fichiers vers le même emplacement de fichier, vous risquez d'obtenir des résultats d'analyse inattendus. Vous pouvez éliminer ce problème en modifiant la configuration par défaut du composant de transport de fichiers en remplaçant l'option Ajouter au fichier par Fichier de remplacement dans la boîte de dialogue Propriétés de BizTalk SendLocalFile. Pour plus d'informations sur le remplacement du paramètre de concaténation pour le composant de transport de fichier dans les propriétés avancées du canal, voir Remplacement des valeurs par défaut d'un port d'échanges.

Voir aussi

Création de ports d'échanges

Sélection d'un composant d'intégration aux applications

Sélection d'un type de transport

Définition des propriétés d'un port d'échanges

Définition des propriétés de transport


Sélection d'un composant d'intégration aux applications

  1. Sur la page Application de destination ou Organisation de destination de l'Assistant Port d'échanges, dans la zone Transport principal ou Transport secondaire, cliquez sur Parcourir.

    La boîte de dialogue Transport principal ou Transport secondaire s'affiche.

  2. Dans la liste Type de transport, cliquez sur Composant d'intégration aux applications.

  3. À droite de la zone Nom de composant, cliquez sur Parcourir.

    La boîte de dialogue Sélectionner un composant s'affiche.

  4. Dans la liste Composants disponibles, cliquez sur un composant, puis sur OK.

Pour poursuivre la définition des propriétés de l'organisation de destination, reportez-vous à Définition des propriétés de l'organisation de destination.

Remarque

  • Un composant d'intégration aux applications doit être enregistré avec BizTalk Server 2000 avant d'être disponible dans la liste Composants disponibles. Pour plus d'informations, voir Enregistrement du composant d'intégration de l'application.

Voir aussi

Création de ports d'échanges

Sélection d'un type de transport

Définition des propriétés d'un port d'échanges

Définition des propriétés de transport

Spécification d'une adresse de transport


Définition des séparateurs d'enveloppes

Les propriétés de séparateur déterminent les caractères utilisés pour séparer les données d'une enveloppe et les documents d'un échange. Les séparateurs sont uniquement requis pour les enveloppes qui utilisent les formats X12 et EDIFACT. Ils sont facultatifs pour les enveloppes utilisant un format personnalisé.

Les séparateurs d'enveloppe sont définis lorsque vous en sélectionnez une dans un port d'échanges. Les séparateurs définis pour un port d'échanges s'appliquent uniquement à celui-ci. Des séparateurs différents peuvent être définis pour la même enveloppe si celle-ci est utilisée dans un autre port d'échanges. Cette section décrit les procédures de définition des propriétés des séparateurs. Les procédures suivantes sont traitées :

  • Définition des séparateurs X12

  • Définition des séparateurs EDIFACT

  • Définition des séparateurs personnalisés


Définition des séparateurs X12

  1. Sur la page Informations d'enveloppe de l'Assistant Port d'échanges, dans la zone Informations d'enveloppe, sélectionnez une enveloppe au format X12 et cliquez sur Séparateurs.

    La boîte de dialogue Séparateurs X12 s'affiche.

  2. Spécifiez des valeurs de séparateurs soit dans la zone Caractère, soit dans la zone Hexadécimal, et cliquez sur OK.

Le tableau suivant décrit les séparateurs X12.

Délimiteur | Description
Séparateur d'éléments de composant | Spécifie le caractère utilisé pour séparer des composants de données au sein d'un champ de données composite. Un champ de données composite est un champ constitué de plusieurs sous-champs.
Séparateur d'éléments | Spécifie le caractère utilisé pour séparer des champs de données au sein d'un enregistrement.
Terminateur du segment | Spécifie le caractère utilisé pour indiquer la fin d'un enregistrement.

Pour poursuivre la définition des propriétés de l'organisation de destination, reportez-vous à Définition des propriétés des informations d'enveloppe.

Remarque

  • Pour chaque séparateur, vous pouvez taper soit un caractère dans la zone Caractère, soit deux caractères dans la zone Hexadécimal. La zone Hexadécimal peut être utilisée pour entrer des séparateurs correspondant à des caractères non imprimables, comme, par exemple, la touche ENTRÉE.

Voir aussi

Création de ports d'échanges

Définition des séparateurs personnalisés

Définition des séparateurs EDIFACT

Définition des séparateurs d'enveloppes

Définition des propriétés des informations d'enveloppe

Définition des propriétés d'un port d'échanges


Définition des séparateurs EDIFACT

  1. Sur la page Informations d'enveloppe de l'Assistant Port d'échanges, dans la zone Informations d'enveloppe, sélectionnez une enveloppe au format EDIFACT et cliquez sur Séparateurs.

    La boîte de dialogue Séparateurs EDIFACT apparaît.

  2. Spécifiez des valeurs de séparateurs soit dans la zone Caractère, soit dans la zone Hexadécimal, et cliquez sur OK.

Le tableau suivant décrit les séparateurs EDIFACT.

Délimiteur | Description
Séparateur d'éléments de composant | Spécifie le caractère utilisé pour séparer des composants de données au sein d'un champ de données composite. Un champ de données composite est un champ constitué de plusieurs sous-champs.
Séparateur d'éléments | Spécifie le caractère utilisé pour séparer des champs de données au sein d'un enregistrement.
Indicateur de libération | Spécifie le caractère utilisé pour indiquer que le caractère suivant ne doit pas être considéré comme un séparateur.
Terminateur du segment | Spécifie le caractère utilisé pour indiquer la fin d'un enregistrement.

Remarques

  • Si vous utilisez des indicateurs de libération EDIFACT, vos données ne doivent pas contenir de caractères faisant fonction d'indicateur de libération. Si vous procédez ainsi, les données risquent de dépasser les limites définies pour la taille physique des caractères autorisée pour les champs.

  • Pour chaque séparateur, vous pouvez taper soit un caractère dans la zone Caractère, soit deux caractères dans la zone Hexadécimal. La zone Hexadécimal peut être utilisée pour entrer des séparateurs correspondant à des caractères non imprimables, comme, par exemple, la touche ENTRÉE.

  • Le séparateur de spécification décimale EDIFACT ne peut pas être utilisé.

Pour poursuivre la définition des propriétés de l'organisation de destination, reportez-vous à Définition des propriétés des informations d'enveloppe.

Voir aussi

Création de ports d'échanges

Définition des séparateurs personnalisés

Définition des séparateurs d'enveloppes

Définition des propriétés des informations d'enveloppe

Définition des propriétés d'un port d'échanges

Définition des séparateurs X12


Définition des séparateurs personnalisés

  1. Sur la page Informations d'enveloppe de l'Assistant Port d'échanges, dans la zone Informations d'enveloppe, sélectionnez une enveloppe au format personnalisé et cliquez sur Séparateurs.

    La boîte de dialogue Séparateurs personnalisés apparaît.

  2. Spécifiez des valeurs de séparateurs soit dans la zone Caractère, soit dans la zone Hexadécimal, et cliquez sur OK.

Le tableau suivant décrit les séparateurs personnalisés.

Délimiteur | Description
Sous-champ | Spécifie le caractère utilisé pour séparer des composants de données au sein d'un champ de données composite.
Champ | Spécifie le caractère utilisé pour séparer les champs de données au sein d'un enregistrement.
Caractère d'échappement | Spécifie le caractère utilisé pour indiquer que le caractère suivant ne doit pas être considéré comme un séparateur.
Enregistrer | Spécifie le caractère utilisé pour indiquer la fin d'un enregistrement.

Remarque

  • Pour chaque séparateur, vous pouvez taper soit un caractère dans la zone Caractère, soit deux caractères dans la zone Hexadécimal. La zone Hexadécimal peut être utilisée pour entrer des séparateurs correspondant à des caractères non imprimables, comme, par exemple, la touche ENTRÉE.

Pour poursuivre la définition des propriétés de l'organisation de destination, reportez-vous à Définition des propriétés des informations d'enveloppe.

Voir aussi

Création de ports d'échanges

Définition des séparateurs EDIFACT

Définition des séparateurs d'enveloppes

Définition des propriétés des informations d'enveloppe

Définition des propriétés d'un port d'échanges

Définition des séparateurs X12


Création et gestion d'organisations

Cette section fournit des informations spécifiques aux tâches relatives à la création et à la gestion des organisations. Nous vous recommandons vivement de revoir Description des organisations dans la section Concepts pour bien comprendre le concept des organisations.

Cette section traite des procédures suivantes :

  • Configuration de l'organisation d'origine

  • Création d'organisations

  • Recherche d'organisations

  • Modification d'organisations

  • Suppression d'organisations

  • Définition des propriétés d'une organisation


Configuration de l'organisation d'origine

  1. Dans le Gestionnaire d'échanges BizTalk, dans la zone Rechercher d'autres éléments, cliquez sur Organisations.

  2. Dans la zone Rechercher les organisations, activez la case à cocher Organisation d'origine, puis cliquez sur Rechercher.

  3. Dans la liste Nom de l'organisation, double-cliquez sur Organisation d'origine.

    La boîte de dialogue Propriétés d'organisation apparaît.

  4. Dans l'onglet Général, définissez les propriétés générales de l'organisation.

    Pour plus d'informations, voir Définition des propriétés générales d'une organisation.

  5. Cliquez sur l'onglet Identificateurs et définissez les propriétés des identificateurs d'organisation.

    Pour plus d'informations, voir Définition des propriétés des identificateurs d'organisation.

  6. Cliquez sur l'onglet Applications et définissez les propriétés des applications.

    Pour plus d'informations, voir Définition des propriétés des applications.

  7. Après avoir défini toutes les propriétés requises pour l'organisation d'origine, cliquez sur OK pour fermer la boîte de dialogue Propriétés d'organisation.

Important

  • Un identificateur d'organisation dénommé Adresse d'expédition SMTP pour accusé de réception d'échanges au format Reliable est automatiquement créé pour l'organisation d'origine. Cet identificateur ne peut pas être supprimé. Vous ne pouvez pas modifier le nom ou le qualificateur de cet identificateur, mais vous pouvez modifier la valeur. La valeur spécifiée pour cet identificateur est utilisée comme adresse d'expédition lors de l'envoi d'accusés de réception d'échanges au format Reliable utilisant le protocole de transport SMTP. Pour plus d'informations sur les accusés de réception d'échanges au format Reliable, voir Traitement des accusés de réception en utilisant des échanges au format Reliable.

  • La valeur spécifiée pour l'identificateur d'organisation (Adresse d'expédition SMTP pour accusé de réception d'échanges au format Reliable) est également utilisée comme adresse d'expédition lorsque l'adresse fournie pour un port d'échanges ouvert est une adresse SMTP. Pour plus d'informations, voir Propriété Openness.

Remarques

  • Vous pouvez renommer l'organisation d'origine à tout moment et lui attribuer le nom de votre choix.

  • Dans le Gestionnaire d'échanges BizTalk, l'ajout d'applications est uniquement autorisé pour l'organisation d'origine.

Voir aussi

Modification d'organisations

Recherche d'organisations

Définition des propriétés des applications

Définition des propriétés d'une organisation

Description des organisations


Création d'organisations

  1. Dans le Gestionnaire d'échanges BizTalk, dans le menu Fichier, pointez sur Nouveau et cliquez sur Organisation.

    La boîte de dialogue Nouvelle organisation apparaît.

  2. Dans l'onglet Général, définissez les propriétés générales de l'organisation.

    Pour plus d'informations, voir Définition des propriétés générales d'une organisation.

  3. Cliquez sur l'onglet Identificateurs et définissez les propriétés des identificateurs d'organisation.

    Pour plus d'informations, voir Définition des propriétés des identificateurs d'organisation.

  4. Après avoir défini toutes les propriétés requises, cliquez sur OK pour fermer la boîte de dialogue Nouvelle organisation.

Voir aussi

Configuration de l'organisation d'origine

Suppression d'organisations

Modification d'organisations

Recherche d'organisations

Définition des propriétés d'une organisation

Description des organisations


Recherche d'organisations

  1. Dans le Gestionnaire d'échanges BizTalk, dans la zone Rechercher d'autres éléments, cliquez sur Organisations.

  2. Effectuez une ou plusieurs des actions suivantes :
    • Pour rechercher toutes les organisations, effacez tous les critères de recherche et cliquez sur Rechercher.

    • Pour rechercher des organisations portant un nom spécifique, dans la zone Rechercher les organisations, dans Nom de l'organisation, tapez le nom de l'organisation que vous souhaitez trouver et cliquez sur Rechercher. Si vous entrez un nom incomplet, la recherche renverra tous les noms possibles correspondant à votre entrée.

    • Pour rechercher l'organisation d'origine uniquement, activez la case à cocher Organisation d'origine, puis cliquez sur Rechercher.

Remarques

  • Pour effacer les critères et les résultats de la recherche, cliquez sur Effacer.

  • Si vous devez rechercher un grand nombre d'objets, le renvoi de tous les objets peut prendre plusieurs minutes. Vous pouvez limiter les objets renvoyés à la suite d'une recherche en définissant des critères de sélection.

  • Une recherche renvoie par défaut 500 objets, mais vous pouvez modifier ce nombre. Pour plus d'informations, voir Définition des options de connexion du serveur.

  • Vous pouvez utiliser les caractères génériques suivants dans vos critères de recherche.
    Caractère générique | Description | Exemple
    % Toute chaîne de zéro caractère ou plus L'entrée '%ouvert%' renvoie tous les noms contenant le terme « ouvert ».
    _ (soulignement) | N'importe quel caractère | L'entrée « _ean » renvoie tous les noms de quatre lettres qui se terminent par « ean » (Dean, Sean, etc.).
    [ ] Tout caractère de l'intervalle ([a-f]) ou de l'ensemble spécifié ([abcdef]) L'entrée « [C-P]arsen » renvoie les noms se terminant par « arsen » et commençant par un caractère compris entre C et P (Carsen, Larsen, Karsen, etc.).
    [^] Tout caractère non compris dans l'intervalle ([^a-f]) ou l'ensemble (^abcdef]) spécifié L'entrée « de[^s]% » renvoie tous les noms commençant par « de » et dont la lettre suivante n'est pas un « s ».

Voir aussi

Suppression d'organisations

Modification d'organisations

Description des organisations


Modification d'organisations

  1. Dans le Gestionnaire d'échanges BizTalk, dans la liste Nom de l'organisation, cliquez sur l'organisation que vous souhaitez modifier.

    Pour plus d'informations sur la recherche d'organisations, voir Recherche d'organisations.

  2. Dans le menu Fichier, cliquez sur Edition.

    La boîte de dialogue Propriétés d'organisation apparaît.

  3. Dans l'onglet Général, modifiez les propriétés requises.

    Pour plus d'informations, voir Définition des propriétés générales d'une organisation.

  4. Cliquez sur l'onglet Identificateurs et modifiez les propriétés d'identificateurs d'organisation requises.

    Pour plus d'informations, voir Définition des propriétés des identificateurs d'organisation.

  5. Si vous modifiez l'organisation d'origine, cliquez sur l'onglet Applications et modifiez les propriétés d'applications requises.

    Pour plus d'informations, voir Définition des propriétés des applications.

  6. Après avoir modifié toutes les propriétés nécessaires, cliquez sur OK pour fermer la boîte de dialogue Propriétés d'organisation.

Important

  • Un identificateur d'organisation dénommé Adresse d'expédition SMTP pour accusé de réception d'échanges au format Reliable est automatiquement créé pour l'organisation d'origine. Cet identificateur ne peut pas être supprimé. Vous ne pouvez pas modifier le nom ou le qualificateur de cet identificateur, mais vous pouvez modifier la valeur. La valeur spécifiée pour cet identificateur est utilisée comme adresse d'expédition lors de l'envoi d'accusés de réception d'échanges au format Reliable utilisant le protocole de transport SMTP. Pour plus d'informations sur les accusés de réception d'échanges au format Reliable, voir Traitement des accusés de réception en utilisant des échanges au format Reliable.

  • La valeur spécifiée pour l'identificateur d'organisation (Adresse d'expédition SMTP pour accusé de réception d'échanges au format Reliable) est également utilisée comme adresse d'expédition lorsque l'adresse fournie pour un port d'échanges ouvert est une adresse SMTP. Pour plus d'informations, voir Propriété Openness.

Remarque

  • Dans le Gestionnaire d'échanges BizTalk, l'ajout d'applications est uniquement autorisé pour l'organisation d'origine.

Voir aussi

Création d'organisations

Suppression d'organisations

Recherche d'organisations

Description des organisations


Suppression d'organisations

  1. Dans le Gestionnaire d'échanges BizTalk, dans la liste Nom de l'organisation, cliquez sur l'organisation que vous souhaitez supprimer.

    Pour plus d'informations sur la recherche d'organisations, voir Recherche d'organisations.

  2. Dans le menu Fichier, cliquez sur Supprimer.

Remarques

  • Si une organisation est utilisée dans un port d'échanges ou dans un canal, vous ne pouvez pas la supprimer. Vous devez d'abord supprimer tous les canaux et ports d'échanges qui utilisent l'organisation.

  • Il est impossible de supprimer l'Organisation d'origine.

Voir aussi

Création d'organisations

Modification d'organisations

Recherche d'organisations

Description des organisations


Définition des propriétés d'une organisation

Cette section fournit des informations spécifiques aux tâches quant à la configuration des propriétés d'une organisation. Cette section traite des procédures suivantes :

  • Définition des propriétés générales d'une organisation

  • Définition des propriétés des identificateurs d'organisation

  • Définition des propriétés des applications


Définition des propriétés générales d'une organisation

  1. Dans le menu Fichier, pointez sur Nouveau et cliquez sur Organisation ou, dans la liste Nom de l'organisation, double-cliquez sur une organisation.

    La boîte de dialogue Organisation apparaît.

  2. Dans l'onglet Général, dans la zone Nom de l'organisation, tapez un nom unique pour l'organisation.

  3. Dans la zone Commentaires, tapez les éventuels commentaires que vous souhaitez définir pour l'organisation.

Voir aussi

Configuration de l'organisation d'origine

Création d'organisations

Modification d'organisations

Définition des propriétés d'une organisation


Définition des propriétés des identificateurs d'organisation

Les identificateurs d'organisation servent à identifier les organisations d'une manière univoque. Une organisation peut posséder plusieurs identificateurs, mais chaque identificateur doit être unique pour cette organisation.

Lors de la création d'une nouvelle organisation, un identificateur d'organisation dénommé Organisation est automatiquement créé. Le qualificateur de cet identificateur est OrganizationName, et la valeur correspond au nom que vous attribuez à l'organisation. Le serveur utilise cet identificateur d'organisation en tant qu'identificateur par défaut à moins que vous ne créiez d'autres identificateurs et que vous en désigniez un comme identificateur par défaut.

Cette section traite des procédures suivantes :

  • Ajout d'identificateurs d'organisation

  • Modification d'identificateurs d'organisation

  • Suppression d'identificateurs d'organisation

Voir aussi

Configuration de l'organisation d'origine

Création d'organisations

Modification d'organisations

Identificateurs d'organisation

Définition des propriétés d'une organisation


Ajout d'identificateurs d'organisation

  1. Dans le menu Fichier, pointez sur Nouveau et cliquez sur Organisation ou, dans la liste Nom de l'organisation, double-cliquez sur une organisation.

    La boîte de dialogue Organisation apparaît.

  2. Cliquez sur l'onglet Identificateurs, puis sur Ajouter.

    La boîte de dialogue Nouvel identificateur apparaît.

  3. Dans la zone Nom, exécutez l'une des étapes suivantes :
    • Cliquez sur Standard, puis cliquez sur un nom de la liste.

    • Cliquez sur Personnalisé et tapez un nom unique dans la zone. Ensuite, dans la zone Qualificateur, tapez un qualificateur pour l'identificateur.
  4. Dans la zone Valeur, tapez une valeur pour l'identificateur.

  5. Si vous souhaitez définir cet identificateur en tant qu'identificateur par défaut de l'organisation, activez la case à cocher Définir par défaut. Dans le cas contraire, assurez-vous que la case à cocher est désactivée.

  6. Cliquez sur OK pour fermer la boîte de dialogue Nouvel identificateur.

Important

  • Un identificateur d'organisation dénommé Adresse d'expédition SMTP pour accusé de réception d'échanges au format Reliable est automatiquement créé pour l'Organisation d'origine. Cet identificateur ne peut pas être supprimé. Vous ne pouvez pas modifier le nom ou le qualificateur de cet identificateur, mais vous pouvez modifier la valeur. La valeur spécifiée pour cet identificateur est utilisée comme adresse d'expédition lors de l'envoi d'accusés de réception d'échanges au format Reliable utilisant le protocole de transport SMTP. Pour plus d'informations, voir Traitement des accusés de réception en utilisant des échanges au format Reliable.

  • La valeur spécifiée pour l'identificateur d'organisation (Adresse d'expédition SMTP pour accusé de réception d'échanges au format Reliable) est également utilisée comme adresse d'expédition lorsque l'adresse fournie pour un port d'échanges ouvert est une adresse SMTP. Pour plus d'informations, voir Propriété Openness.

Remarques

  • Un seul identificateur peut être désigné comme identificateur par défaut d'une organisation. L'identificateur par défaut est utilisé pour identifier une organisation sauf si vous spécifiez un autre identificateur d'organisation dans un canal ou un port d'échanges.

  • Lors de la création d'une nouvelle organisation, un identificateur d'organisation dénommé Organisation est automatiquement créé. Le qualificateur de cet identificateur est OrganizationName et la valeur correspond au nom de l'organisation. Vous pouvez créer des identificateurs supplémentaires, mais celui-ci ne peut être ni modifié, ni supprimé.

  • Si le serveur trouve un qualificateur vide et une valeur non vide lors du traitement d'un document entrant présentant un format autre que EDIFACT, il convertit le qualificateur vide en OrganizationName.

  • Si le serveur trouve un qualificateur vide et une valeur non vide lors du traitement d'un document entrant présentant un format EDIFACT, il convertit le qualificateur vide en un tiret (-). Si vous souhaitez traiter un document entrant au format EDIFACT comportant un qualificateur vide ou une enveloppe sortante avec un qualificateur vide, vous devez créer un identificateur d'organisation personnalisé dont le qualificateur correspond à un seul tiret. Pour un document EDIFACT sortant, le serveur convertit le tiret en un qualificateur vide.

  • Lorsque vous créez un identificateur d'organisation destiné à être utilisé avec des enveloppes EDIFACT, le qualificateur ne peut pas dépasser 4 caractères et la valeur peut comporter au maximum 35 caractères.

  • Lorsque vous créez un identificateur d'organisation destiné à être utilisé avec des enveloppes X12, le qualificateur ne peut pas dépasser 2 caractères et la valeur peut comporter au maximum 15 caractères.

Voir aussi

Configuration de l'organisation d'origine

Création d'organisations

Modification d'identificateurs d'organisation

Modification d'organisations

Identificateurs d'organisation

Suppression d'identificateurs d'organisation

Définition des propriétés des identificateurs d'organisation


Modification d'identificateurs d'organisation

  1. Dans le menu Fichier, pointez sur Nouveau et cliquez sur Organisation ou, dans la liste Nom de l'organisation, double-cliquez sur une organisation.

    La boîte de dialogue Organisation apparaît.

  2. Cliquez sur l'onglet Identificateurs.

  3. Dans la liste Identificateurs d'organisation, cliquez sur l'identificateur que vous souhaitez modifier et cliquez sur Modifier.

    La boîte de dialogue Propriétés d'identificateur s'affiche.

  4. Dans la zone Nom, exécutez l'une des étapes suivantes :
    • Cliquez sur Standard, puis cliquez sur un nom de la liste.

    • Cliquez sur Personnalisé et tapez un nom unique dans la zone. Ensuite, dans la zone Qualificateur, tapez un qualificateur pour l'identificateur.
  5. Dans la zone Valeur, tapez une valeur pour l'identificateur.

  6. Si vous souhaitez définir cet identificateur en tant qu'identificateur par défaut de l'organisation, activez la case à cocher Définir par défaut. Dans le cas contraire, assurez-vous que la case à cocher est désactivée.

  7. Cliquez sur OK pour fermer la boîte de dialogue Propriétés d'identificateur.

Important

  • Un identificateur d'organisation dénommé Adresse d'expédition SMTP pour accusé de réception d'échanges au format Reliable est automatiquement créé pour l'Organisation d'origine. Vous ne pouvez pas modifier le nom ou le qualificateur de cet identificateur, mais vous pouvez modifier la valeur. Cet identificateur ne peut pas être supprimé. La valeur spécifiée pour cet identificateur est utilisée comme adresse d'expédition lors de l'envoi d'accusés de réception d'échanges au format Reliable utilisant le protocole de transport SMTP. Pour plus d'informations, voir Traitement des accusés de réception en utilisant des échanges au format Reliable.

  • La valeur spécifiée pour l'identificateur d'organisation (Adresse d'expédition SMTP pour accusé de réception d'échanges au format Reliable) est également utilisée comme adresse d'expédition lorsque l'adresse fournie pour un port d'échanges ouvert est une adresse SMTP. Pour plus d'informations, voir Propriété Openness.

Remarques

  • Un seul identificateur peut être désigné comme identificateur par défaut d'une organisation. L'identificateur par défaut est utilisé pour identifier une organisation sauf si vous spécifiez un autre identificateur d'organisation dans un canal ou un port d'échanges.

  • Lors de la création d'une nouvelle organisation, un identificateur d'organisation dénommé Organisation est automatiquement créé. Le qualificateur de cet identificateur est OrganizationName et la valeur correspond au nom de l'organisation. Vous pouvez créer des identificateurs supplémentaires, mais celui-ci ne peut être ni modifié, ni supprimé.

  • Si le serveur trouve un qualificateur vide et une valeur non vide lors du traitement d'un document entrant présentant un format autre que EDIFACT, il convertit le qualificateur vide en OrganizationName.

  • Si le serveur trouve un qualificateur vide et une valeur non vide lors du traitement d'un document entrant présentant un format EDIFACT, il convertit le qualificateur vide en un tiret (-). Si vous souhaitez traiter un document entrant au format EDIFACT comportant un qualificateur vide ou une enveloppe sortante avec un qualificateur vide, vous devez créer un identificateur d'organisation personnalisé dont le qualificateur correspond à un seul tiret. Pour un document EDIFACT sortant, le serveur convertit le tiret en un qualificateur vide.

  • Lorsque vous créez un identificateur d'organisation destiné à être utilisé avec des enveloppes EDIFACT, le qualificateur ne peut pas dépasser 4 caractères et la valeur peut comporter au maximum 35 caractères.

  • Lorsque vous créez un identificateur d'organisation destiné à être utilisé avec des enveloppes X12, le qualificateur ne peut pas dépasser 2 caractères et la valeur peut comporter au maximum 15 caractères.

Voir aussi

Ajout d'identificateurs d'organisation

Configuration de l'organisation d'origine

Création d'organisations

Modification d'organisations

Identificateurs d'organisation

Suppression d'identificateurs d'organisation

Définition des propriétés des identificateurs d'organisation


Suppression d'identificateurs d'organisation

  1. Dans le menu Fichier, pointez sur Nouveau et cliquez sur Organisation ou, dans la liste Nom de l'organisation, double-cliquez sur une organisation.

    La boîte de dialogue Organisation apparaît.

  2. Cliquez sur l'onglet Identificateurs.

  3. Dans la liste Identificateurs d'organisation, cliquez sur l'identificateur que vous souhaitez supprimer et cliquez sur Supprimer.

Remarques

  • L'identificateur d'organisation désigné comme identificateur par défaut ne peut pas être supprimé tant que vous n'avez pas désigné un autre identificateur par défaut.

  • L'identificateur d'organisation dénommé Organisation est automatiquement créé lors de la création d'une organisation. Cet identificateur d'organisation ne peut pas être supprimé.

Voir aussi

Ajout d'identificateurs d'organisation

Configuration de l'organisation d'origine

Création d'organisations

Modification d'identificateurs d'organisation

Modification d'organisations

Identificateurs d'organisation

Définition des propriétés des identificateurs d'organisation


Définition des propriétés des applications

Dans le Gestionnaire d'échanges BizTalk, l'ajout d'applications est uniquement autorisé pour l'Organisation d'origine. Les applications que vous créez vous permettent d'identifier et de suivre le flux de documents entre BizTalk Server 2000 et les applications internes concrètes de votre entreprise. Une application de l'organisation d'origine peut être définie en tant qu'application source dans un canal ou en tant qu'application de destination dans un port d'échanges.

L'organisation d'origine peut comprendre un nombre illimité d'applications. Chaque nom d'application doit être unique. Cette section traite des procédures suivantes :

  • Ajout d'applications

  • Modification d'applications

  • Suppression d'applications

Voir aussi

Configuration de l'organisation d'origine

Modification d'organisations

Définition des propriétés d'une organisation


Ajout d'applications

  1. Dans le Gestionnaire d'échanges BizTalk, dans la zone Rechercher d'autres éléments, cliquez sur Organisations.

  2. Dans la zone Rechercher les organisations, activez la case à cocher Organisation d'origine, puis cliquez sur Rechercher.

  3. Dans la liste Nom de l'organisation, double-cliquez sur Organisation d'origine.

    La boîte de dialogue Propriétés d'organisation apparaît.

  4. Dans l'onglet Applications, cliquez sur Ajouter.

    La boîte de dialogue Nouvelle application apparaît.

  5. Dans la zone Nom de l'application, tapez un nom unique pour l'application, puis cliquez sur OK.

Remarque

  • Dans le Gestionnaire d'échanges BizTalk, l'ajout, la modification et la suppression d'applications ne sont autorisés que pour l'organisation d'origine.

Voir aussi

Configuration de l'organisation d'origine

Modification d'applications

Modification d'organisations

Suppression d'applications

Définition des propriétés des applications


Modification d'applications

  1. Dans le Gestionnaire d'échanges BizTalk, dans la zone Rechercher d'autres éléments, cliquez sur Organisations.

  2. Dans la zone Rechercher les organisations, activez la case à cocher Organisation d'origine, puis cliquez sur Rechercher.

  3. Dans la liste Nom de l'organisation, double-cliquez sur Organisation d'origine.

    La boîte de dialogue Propriétés d'organisation apparaît.

  4. Dans l'onglet Applications, dans la liste Applications, cliquez sur l'application que vous souhaitez modifier et cliquez sur Modifier.

    La boîte de dialogue Propriétés d'application s'affiche.

  5. Dans la zone Nom de l'application, tapez un nom unique pour l'application, puis cliquez sur OK.

Remarque

  • Dans le Gestionnaire d'échanges BizTalk, l'ajout, la modification et la suppression d'applications ne sont autorisés que pour l'organisation d'origine.

Voir aussi

Ajout d'applications

Configuration de l'organisation d'origine

Modification d'organisations

Suppression d'applications

Définition des propriétés des applications


Suppression d'applications

  1. Dans le Gestionnaire d'échanges BizTalk, dans la zone Rechercher d'autres éléments, cliquez sur Organisations.

  2. Dans la zone Rechercher les organisations, activez la case à cocher Organisation d'origine, puis cliquez sur Rechercher.

  3. Dans la liste Nom de l'organisation, double-cliquez sur Organisation d'origine.

    La boîte de dialogue Propriétés d'organisation apparaît.

  4. Dans l'onglet Applications, dans la liste Applications, cliquez sur l'application que vous souhaitez supprimer et cliquez sur Supprimer.

Remarque

  • Dans le Gestionnaire d'échanges BizTalk, l'ajout, la modification et la suppression d'applications ne sont autorisés que pour l'organisation d'origine.

Voir aussi

Ajout d'applications

Configuration de l'organisation d'origine

Modification d'organisations

Définition des propriétés des applications


Création et gestion de définitions de document

Cette section fournit des informations spécifiques aux tâches relatives à la création et à la gestion des définitions de documents. Nous vous recommandons vivement de revoir Description des définitions de document dans la section Concepts pour bien comprendre le concept des définitions de documents.

Cette section traite des procédures suivantes :

  • Création de définitions de document

  • Recherche de définitions de document

  • Modification de définitions de documents

  • Suppression de définitions de documents

  • Définition des propriétés d'une définition de document


Création de définitions de document

  1. Dans le Gestionnaire d'échanges BizTalk, dans le menu Fichier, pointez sur Nouveau et cliquez sur Définition de document.

    La boîte de dialogue Nouvelle définition de document s'affiche.

  2. Dans l'onglet Général, définissez les propriétés générales.

    Pour plus d'informations, voir Définition des propriétés générales d'une définition de document.

  3. Cliquez sur l'onglet Suivi global et définissez les propriétés de suivi.

    Pour plus d'informations, voir Définition des propriétés de suivi global.

  4. Cliquez sur l'onglet Critères de sélection et définissez les propriétés des critères de sélection.

    Pour plus d'informations, voir Définition des propriétés des critères de sélection.

  5. Après avoir défini toutes les propriétés requises, cliquez sur OK pour fermer la boîte de dialogue Nouvelle définition de document.

Remarques

  • Vous ne pouvez pas attribuer à une définition de document le nom Canal des accusés de réception d'échanges fiables ou Accusé de réception standard BizTalk car il s'agit de noms système réservés.

  • Vous ne pouvez spécifier des champs de suivi global pour une définition de document qu'à condition de sélectionner une spécification.

  • Lorsque vous sélectionnez une définition de document dans un canal, vous pouvez remplacer les champs de suivi global de ce canal en sélectionnant d'autres champs de spécification devant faire l'objet d'un suivi. Pour plus d'informations, voir Sélection des champs de spécification dans un canal.

  • Lorsque vous enregistrez une définition de document faisant référence à une spécification en dehors de votre domaine local, il se peut que vous obteniez un message d'erreur. S'il se produit une erreur, téléchargez et configurez l'utilitaire proxy WinHTTP. Pour télécharger cet utilitaire, accédez au site Web Microsoft MSDN (msdn.microsoft.com/downloads/default.asp) et accédez à la page WinHTTP Proxy Configuration Utility, qui figure dans le chapitre XML du manuel Web Development.

Voir aussi

Suppression de définitions de documents

Modification de définitions de documents

Recherche de définitions de document

Description des définitions de document


Recherche de définitions de document

  1. Dans le Gestionnaire d'échanges BizTalk, dans la zone Rechercher d'autres éléments, cliquez sur Définitions de document.

  2. Pour rechercher toutes les définitions de documents, effacez tous les critères de recherche et cliquez sur Rechercher.

    –Ou–

    Pour rechercher une définition de document portant un nom spécifique, dans la zone Rechercher les définitions de document, dans Nom de la définition de document, tapez le nom de la définition de document que vous souhaitez trouver et cliquez sur Rechercher. Si vous entrez un nom incomplet, la recherche renverra tous les noms possibles correspondant à votre entrée.

Remarques

  • Pour effacer les critères et les résultats de la recherche, cliquez sur Effacer.

  • Si vous devez rechercher un grand nombre d'objets, le renvoi de tous les objets peut prendre plusieurs minutes. Vous pouvez limiter les objets renvoyés à la suite d'une recherche en définissant des critères de sélection.

  • Une recherche renvoie par défaut 500 objets, mais vous pouvez modifier ce nombre. Pour plus d'informations, voir Définition des options de connexion du serveur.

  • Vous pouvez utiliser les caractères génériques suivants dans les critères de recherche :
    Caractère générique | Description | Exemple
    % Toute chaîne de zéro caractère ou plus L'entrée '%ouvert%' renvoie tous les noms contenant le terme « ouvert ».
    _ (soulignement) | N'importe quel caractère | L'entrée « _ean » renvoie tous les noms de quatre lettres qui se terminent par « ean » (Dean, Sean, etc.).
    [ ] Tout caractère de l'intervalle ([a-f]) ou de l'ensemble spécifié ([abcdef]) L'entrée « [C-P]arsen » renvoie les noms se terminant par « arsen » et commençant par un caractère compris entre C et P (Carsen, Larsen, Karsen, etc.).
    [^] Tout caractère non compris dans l'intervalle ([^a-f]) ou l'ensemble (^abcdef]) spécifié L'entrée « de[^s]% » renvoie tous les noms commençant par « de » et dont la lettre suivante n'est pas un « s ».

Voir aussi

Suppression de définitions de documents

Modification de définitions de documents

Description des définitions de document


Modification de définitions de documents

  1. Dans le Gestionnaire d'échanges BizTalk, dans la liste Nom de la définition de document, cliquez sur la définition de document que vous souhaitez modifier.

    Pour plus d'informations sur la recherche de définitions de documents, voir Recherche de définitions de documents.

  2. Dans le menu Fichier, cliquez sur Edition.

    La boîte de dialogue Propriétés de la définition de document s'affiche.

  3. Dans l'onglet Général, modifiez les propriétés générales.

    Pour plus d'informations, voir Définition des propriétés générales d'une définition de document.

  4. Cliquez sur l'onglet Suivi global et modifiez les propriétés de suivi.

    Pour plus d'informations, voir Définition des propriétés de suivi global.

  5. Cliquez sur l'onglet Critères de sélection et modifiez les propriétés des critères de sélection.

    Pour plus d'informations, voir Définition des propriétés des critères de sélection.

  6. Après avoir modifié toutes les propriétés nécessaires, cliquez sur OK pour fermer la boîte de dialogue Propriétés de la définition de document.

Remarques

  • Vous ne pouvez pas attribuer à une définition de document le nom Canal des accusés de réception d'échanges fiables ou Accusé de réception standard BizTalk car il s'agit de noms système réservés.

  • Vous ne pouvez spécifier des champs de suivi global pour une définition de document qu'à condition de sélectionner une spécification.

  • Lorsque vous enregistrez une définition de document faisant référence à une spécification en dehors de votre domaine local, il se peut que vous obteniez un message d'erreur. S'il se produit une erreur, téléchargez et configurez l'utilitaire proxy WinHTTP. Pour télécharger cet utilitaire, accédez au site Web Microsoft MSDN (msdn.microsoft.com/downloads/default.asp) et accédez à la page WinHTTP Proxy Configuration Utility, qui figure dans le chapitre XML du manuel Web Development.

Voir aussi

Création de définitions de document

Suppression de définitions de documents

Recherche de définitions de document

Description des définitions de document


Suppression de définitions de documents

  1. Dans le Gestionnaire d'échanges BizTalk, dans la liste Nom de la définition de document, cliquez sur la définition de document que vous souhaitez supprimer.

    Pour plus d'informations sur la recherche de définitions de documents, voir Recherche de définitions de documents.

  2. Dans le menu Fichier, cliquez sur Supprimer.

Remarque

  • Si une définition de document est utilisée dans un canal, vous ne pouvez pas la supprimer. Vous devez d'abord supprimer tous les canaux qui utilisent cette définition de document.

Voir aussi

Création de définitions de document

Modification de définitions de documents

Recherche de définitions de document

Description des définitions de document


Définition des propriétés d'une définition de document

Cette section fournit des informations spécifiques aux tâches relatives à la configuration des propriétés d'une définition de document. Cette section traite des procédures suivantes :

  • Définition des propriétés générales d'une définition de document

  • Sélection d'une spécification de document

  • Définition des propriétés de suivi global

  • Définition des propriétés des critères de sélection


Définition des propriétés générales d'une définition de document

  1. Dans la boîte de dialogue Nouvelle définition de document ou Propriétés de la définition de document, cliquez sur l'onglet Général.

  2. Dans la zone Nom de la définition de document, tapez un nom unique pour la définition de document.

  3. Activez la case à cocher Spécification de document.

  4. Cliquez sur Parcourir pour sélectionner une spécification de document.

    Pour plus d'informations, voir Sélection d'une spécification de document.

Remarques

  • Une spécification de document est facultative pour une définition de document. Toutefois, si vous ne sélectionnez pas de spécification, il vous est impossible de définir des champs de suivi global. En outre, les données traitées via la définition de document :
    • ne sont pas converties en XML à partir de leur format natif ;

    • ne sont pas validées par rapport à une spécification ;

    • ne peuvent pas être transformées en une autre structure ou en un autre format à l'aide d'un mappage.
  • Si vous traitez des données que vous ne souhaitez ni convertir, ni transformer, ni valider, comme par exemple un fichier binaire, vous ne devez pas sélectionner de spécification de document.

Voir aussi

Création de définitions de document

Modification de définitions de documents

Définition des propriétés d'une définition de document

Description des définitions de document


Sélection d'une spécification de document

  1. Dans la boîte de dialogue Nouvelle définition de document ou Propriétés de la définition de document, cliquez sur l'onglet Général.

  2. Activez la case à cocher Spécification de document et cliquez sur Parcourir.

    La boîte de dialogue Sélectionnez une spécification de document dans le référentiel WebDAV s'affiche.

  3. Dans la zone Serveur, procédez de l'une des façons suivantes pour changer de serveur.
    • Sélectionnez un serveur dans la liste.

    • Tapez le nom d'un serveur et appuyez sur ENTRÉE.
  4. Double-cliquez sur le dossier contenant la spécification que vous souhaitez ouvrir, puis double-cliquez sur le fichier.

Important

  • Lorsque vous ouvrez pour la première fois une boîte de dialogue Référentiel WebDAV, le référentiel WebDAV du serveur local est sélectionné, même si le Gestionnaire d'échanges BizTalk est connecté à une base de données d'un serveur distant. Si vous accédez à un référentiel WebDAV d'un serveur distant, celui-ci devient le serveur par défaut jusqu'à ce que vous sélectionniez un nouveau référentiel WebDAV. Le serveur par défaut de toutes les boîtes de dialogue Référentiel WebDAV est le dernier serveur avec lequel une connexion a été établie.

Remarques

  • Si vous sélectionnez l'adresse http://localhost pour le serveur, le Gestionnaire d'échanges BizTalk la transforme automatiquement en nom d'ordinateur local.

  • Si une définition de document est utilisée en tant que définition du document entrant dans un canal pour un port d'échanges ouvert et que les informations de destination sont fournies dans le document, la définition de document doit faire référence à une spécification correctement configurée. Pour plus d'informations sur la configuration d'une spécification de document permettant de traiter les documents pour un port d'échanges ouvert, voir Définition des propriétés du dictionnaire.

  • Une spécification de document est facultative. toutefois, dans la plupart des cas, vous devez en sélectionner une. Si vous ne sélectionnez aucune spécification, vous pourrez constater les points suivants :
    • Les données que vous traitez ne seront pas converties au format XML du côté entrant, ni converties à partir du format XML du côté sortant.

    • Les données ne seront pas validées par rapport à une spécification afin de garantir qu'elles ne contiennent pas d'erreurs.

    • Vous ne pouvez pas transformer la structure ou le format des données en recourant à un mappage dans un canal.

    • Vous ne pouvez pas spécifier de champs de suivi global pour la définition de document.
  • Une spécification de document n'est pas nécessaire si vous souhaitez utiliser la définition de document dans une soumission directe.

  • Il est possible que votre première connexion à un référentiel WebDAV sur un serveur distant prenne un certain temps.

  • Lorsque vous enregistrez une définition de document faisant référence à une spécification en dehors de votre domaine local, il se peut que vous obteniez un message d'erreur. S'il se produit une erreur, téléchargez et configurez l'utilitaire proxy WinHTTP. Pour télécharger cet utilitaire, accédez au site Web Microsoft MSDN (msdn.microsoft.com/downloads/default.asp) et accédez à la page WinHTTP Proxy Configuration Utility, qui figure dans le chapitre XML du manuel Web Development.

Voir aussi

Création de définitions de document

Modification de définitions de documents

Définition des propriétés d'une définition de document

Description des définitions de document


Définition des propriétés de suivi global

Dans l'onglet Suivi global, la liste Champs de spécification fournit une arborescence correspondant à la spécification que vous avez sélectionnée pour la définition de document. Vous pouvez développer cette liste pour afficher les champs de la spécification et désigner un nombre limité de champs devant être consignés dans la base de données de suivi.

Lorsque la définition de document est sélectionnée en tant que définition du document entrant pour un canal, ces champs sont suivis pour chaque instance d'un document traitée par ce canal. Ces champs sont désignés par le terme « champs de suivi global ». Lorsque vous sélectionnez une définition de document dans un canal, vous avez la possibilité de remplacer les champs de suivi global en sélectionnant d'autres champs de spécification devant faire l'objet d'un suivi pour chaque instance de document traitée par ce canal uniquement.

Cette section décrit la procédure de sélection de champs de spécification pour une définition de document.

Cette section traite des procédures suivantes :

  • Sélection de champs de spécification dans une définition de document

  • Suppression de champs de spécification dans une définition de document

Voir aussi

Suivi des champs de données d'un document

Description des définitions de document


Sélection de champs de spécification dans une définition de document

  1. Dans la boîte de dialogue Nouvelle définition de document ou Propriétés de la définition de document, cliquez sur l'onglet Suivi global.

  2. Dans la liste Champs de spécification, cliquez sur le signe plus (+) en regard de chaque enregistrement ou double-cliquez sur l'enregistrement pour développer l'affichage.

  3. Sélectionnez un champ de spécification que vous souhaitez ajouter à la liste Champs à suivre, puis suivez l'une des procédures suivantes :
    Ajout du champ en tant que | Suivez cette procédure
    Entier | Cliquez sur Entier. Vous pouvez ajouter deux champs pour les entiers.
    Réel | Cliquez sur Réel. Vous pouvez ajouter deux champs pour les nombres réels.
    Date | Cliquez sur Date. Vous pouvez ajouter deux champs pour les dates.
    Texte | Cliquez sur Texte. Vous pouvez ajouter deux champs pour le texte.
    Personnalisé | Cliquez sur Personnalisé. Vous pouvez ajouter un nombre de champs illimité pour le type Personnalisé. Les champs sont stockés sous forme de chaînes XML concaténées, avec des balises pour chaque champ.

Remarques

  • Pour pouvoir sélectionner un champ de spécification pour le suivi de données de type entier, nombre réel ou date, ce type de données doit être attribué au champ dans la spécification. Pour plus d'informations sur l'affectation d'un type de données à un champ de spécification, voir Définition des propriétés de déclaration.

  • Les champs de spécification auxquels aucun type de données n'a été attribué dans la spécification peuvent uniquement faire l'objet d'un suivi sur les données de type texte ou personnalisé.

  • Si un champ de spécification que vous souhaitez suivre présente un type de données « caractère », le suivi pour ce champ peut uniquement avoir lieu en référence à un type personnalisé.

  • Lorsque vous sélectionnez une définition de document dans un canal, vous pouvez remplacer les champs de suivi global de ce canal en sélectionnant d'autres champs de spécification devant faire l'objet d'un suivi. Pour plus d'informations, voir Sélection des champs de spécification dans un canal.

Voir aussi

Création de définitions de document

Modification de définitions de documents

Suppression de champs de spécification dans une définition de document

Définition des propriétés d'une définition de document

Définition des propriétés de suivi global

Suivi des champs de données d'un document

Description des définitions de document


Suppression de champs de spécification dans une définition de document

  1. Dans la boîte de dialogue Nouvelle définition de document ou Propriétés de la définition de document, cliquez sur l'onglet Suivi global.

  2. Dans la liste Champs à suivre, sélectionnez le ou les champs de spécification que vous souhaitez supprimer et cliquez sur Supprimer.

Remarque

  • Lorsque vous supprimez un champ de la liste des champs à suivre, celui-ci est uniquement supprimé de la liste dans cette définition de document, il n'est pas supprimé de la spécification.

Voir aussi

Création de définitions de document

Modification de définitions de documents

Sélection de champs de spécification dans une définition de document

Définition des propriétés d'une définition de document

Définition des propriétés de suivi global

Suivi des champs de données d'un document

Description des définitions de document


Définition des propriétés des critères de sélection

Les critères de sélection correspondent à un jeu unique de paires nom-valeur que BizTalk Server 2000 utilise uniquement pour traiter les documents EDI. Pour les documents X12 ou EDIFACT entrants, le serveur utilise des critères de sélection pour identifier et sélectionner une définition de document d'une manière univoque, car aucun nom de définition de document ne figure dans les documents EDI individuels.

Pour les documents X12 ou EDIFACT sortants, les critères de sélection servent à créer les informations d'en-tête de groupe.

Cette section traite des procédures suivantes :

  • Ajout de critères de sélection

  • Modification de critères de sélection

  • Suppression de critères de sélection

Voir aussi

Description des définitions de document

Description des critères de sélection


Ajout de critères de sélection

  1. Dans la boîte de dialogue Nouvelle définition de document ou Propriétés de la définition de document, cliquez sur l'onglet Critères de sélection, puis cliquez sur Ajouter.

    La boîte de dialogue Nouveau nom et nouvelle valeur s'affiche.

  2. Dans la zone Nom, tapez un nom pour les critères de sélection.

  3. Dans la zone Valeur, tapez une valeur pour les critères de sélection et cliquez sur OK.

Important

  • Afin que BizTalk Server 2000 fasse correspondre les valeurs des critères de sélection aux éléments d'en-tête correspondants des échanges entrants, et pour qu'il puisse insérer les valeurs dans les éléments d'en-tête corrects des échanges sortants, vous devez taper les noms des critères de sélection tels qu'ils sont indiqués dans les tableaux suivants.

    Éléments d'en-tête X12
    Nom | Configuration requise | Élément GS
    identificateur_fonctionnel | Obligatoire | GS01
    code_expéditeur_application | Obligatoire | GS02
    code_destinataire_application | Obligatoire | GS03
    version_standards | Obligatoire | GS08

    Éléments d'en-tête EDIFACT
    Nom | Configuration requise | Élément UNH | Élément UNG
    identificateur_fonctionnel | Obligatoire | S009, 0065 | 0038
    code_expéditeur_application | Facultatif | Non utilisé | S006, 0040
    code_destinataire_application | Facultatif | Non utilisé | S007, 0044
    type_version_standards | Obligatoire | S009, 0052 | S008, 0052
    valeur_version_standards | Obligatoire | S009, 0054 | S008, 0054

  • Pour un échange EDIFACT sortant, un message header (UNH) est toujours créé. Si vous spécifiez une application_sender_code et une application_receiver_code, un group header (UNG) est également créé.

  • Le jeu de paires nom-valeur que vous utilisez comme critères de sélection pour chaque définition de document doit être unique pour toutes les définitions de documents.

Voir aussi

Création de définitions de document

Modification de définitions de documents

Modification de critères de sélection

Suppression de critères de sélection

Définition des propriétés d'une définition de document

Définition des propriétés des critères de sélection

Description des définitions de document

Description des critères de sélection


Modification de critères de sélection

  1. Dans la boîte de dialogue Nouvelle définition de document ou Propriétés de la définition de document, cliquez sur l'onglet Critères de sélection.

  2. Dans la liste Critères de sélection, cliquez sur les critères de sélection que vous souhaitez modifier et cliquez sur Modifier.

    La boîte de dialogue Propriétés de nom et de valeur s'affiche.

  3. Dans la zone Nom, tapez un nom pour les critères de sélection.

  4. Dans la zone Valeur, tapez une valeur pour les critères de sélection et cliquez sur OK.

Important

  • Afin que BizTalk Server 2000 fasse correspondre les valeurs des critères de sélection aux éléments d'en-tête correspondants des échanges entrants, et pour qu'il puisse insérer les valeurs dans les éléments d'en-tête corrects des échanges sortants, vous devez taper les noms des critères de sélection tels qu'ils sont indiqués dans les tableaux suivants.

    Éléments d'en-tête X12
    Nom | Configuration requise | GS Element
    identificateur_fonctionnel | Obligatoire | GS01
    code_expéditeur_application | Obligatoire | GS02
    code_destinataire_application | Obligatoire | GS03
    version_standards | Obligatoire | GS08

    Éléments d'en-tête EDIFACT
    Nom | Configuration requise | Élément UNH | Élément UNG
    identificateur_fonctionnel | Obligatoire | S009, 0065 | 0038
    code_expéditeur_application | Facultatif | Non utilisé | S006, 0040
    code_destinataire_application | Facultatif | Non utilisé | S007, 0044
    type_version_standards | Obligatoire | S009, 0052 | S008, 0052
    valeur_version_standards | Obligatoire | S009, 0054 | S008, 0054

  • Pour un échange EDIFACT sortant, un message header (UNH) est toujours créé. Si vous spécifiez une application_sender_code et une application_receiver_code, un group header (UNG) est également créé.

  • Le jeu de paires nom-valeur que vous utilisez comme critères de sélection pour chaque définition de document doit être unique pour toutes les définitions de documents.

Voir aussi

Ajout de critères de sélection

Suppression de critères de sélection

Définition des propriétés des critères de sélection

Description des définitions de document

Description des critères de sélection


Suppression de critères de sélection

  1. Dans la boîte de dialogue Propriétés de la définition de document, cliquez sur l'onglet Critères de sélection.

  2. Dans la liste Critères de sélection, cliquez sur le critère que vous souhaitez supprimer et cliquez sur Supprimer.

Voir aussi

Ajout de critères de sélection

Modification de critères de sélection

Définition des propriétés des critères de sélection

Description des définitions de document

Description des critères de sélection


Création et gestion d'enveloppes

Cette section fournit des informations sur la création et la gestion des enveloppes. Il est vivement recommandé de consulter les informations de la rubrique Description des enveloppes dans la section Concepts de base pour bien comprendre l'utilisation des enveloppes.

Cette section traite des procédures suivantes :

  • Création d'enveloppes

  • Recherche d'enveloppes

  • Modification d'enveloppes

  • Suppression d'enveloppes

  • Sélection d'une spécification d'enveloppe


Création d'enveloppes

  1. Dans le Gestionnaire d'échanges BizTalk, dans le menu Fichier, pointez sur Nouveau et cliquez sur Enveloppe.

    La boîte de dialogue Nouvelle enveloppe s'affiche.

  2. Dans la zone Nom d'enveloppe, tapez un nom unique pour l'enveloppe.

  3. Dans la liste Format d'enveloppe, choisissez l'un des formats d'enveloppe suivants :
    • CUSTOM XML

      Pour permettre à Microsoft BizTalk Server 2000 de traiter les échanges sortants au format Custom XML, vous devez créer une enveloppe au format Custom XML ainsi qu'une référence de spécification. Toutefois, lorsque vous envoyez des échanges Custom XML, il n'est pas nécessaire de spécifier le nom de l'enveloppe dans les paramètres d'appel soumis. BizTalk Server 2000 peut localiser l'enveloppe appropriée sans disposer d'une référence de nom.

    • X12

      Il n'est pas nécessaire de créer une enveloppe au format X12 pour permettre à BizTalk Server 2000 de traiter les échanges entrants au format X12 et il n'est pas non plus nécessaire de spécifier le nom de l'enveloppe dans les paramètres d'appel soumis.

    • EDIFACT

      Il n'est pas nécessaire de créer une enveloppe au format EDIFACT pour permettre à BizTalk Server 2000 de traiter les échanges entrants au format X12 et il n'est pas non plus nécessaire de spécifier le nom de l'enveloppe dans les paramètres d'appel soumis.

    • FLATFILE

      Pour permettre à BizTalk Server 2000 de traiter les échanges entrants au format FLATFILE (table bidirectionnelle), vous devez créer une enveloppe avec ce même format. Lorsque vous envoyez des documents FLATFILE entrants, vous devez spécifier le nom de l'enveloppe dans les paramètres d'appel soumis. Pour plus d'informations, voir Envoi.

    • PERSONNALISÉ

      Pour permettre à BizTalk Server 2000 de traiter les échanges entrants dont le format est personnalisé, format non directement pris en charge par BizTalk Server 2000, vous devez créer un composant parseur personnalisé. Vous devez créer une enveloppe uniquement si le parseur personnalisé en requiert une. Pour plus d'informations, voir Utilisation de l'interface IBizTalkParserComponent.

      Pour permettre à BizTalk Server 2000 de traiter les échanges sortants dont le format est personnalisé, vous devez créer une enveloppe au format personnalisé et sélectionner l'enveloppe dans un port d'échanges. Vous devez également créer et enregistrer un composant sérialiseur personnalisé. Pour plus d'informations, voir Utilisation de l'interface IBizTalkSerializerComponent. Vous pouvez configurer le sérialiseur personnalisé dans le canal accessible à partir de la page Configuration avancée de l'Assistant Canal. Pour plus d'informations, voir Définition des propriétés de configuration avancées.

    • RELIABLE

      Il n'est pas nécessaire de créer une enveloppe au format Reliable pour permettre à BizTalk Server 2000 de traiter les échanges entrants au format Reliable et il n'est pas non plus nécessaire de spécifier le nom de l'enveloppe dans les paramètres d'appel soumis.

      Le format Reliable permet de traiter les enveloppes dont le format est compatible avec BizTalk Framework 2.0. Pour plus d'informations sur BizTalk Framework 2.0, accédez au site Web de Microsoft BizTalk à l'adresse suivante : (www.microsoft.com/biztalk/).

      Si vous choisissez le format Reliable, vous devez également configurer l'adresse de type URL de réponse d'échange de type Reliable dans la boîte de dialogue Propriétés du groupe de serveurs BizTalk Server. Pour plus d'informations, voir Configuration des propriétés générales d'un groupe de serveurs.

  4. Si vous choisissez le format Custom XML, FLATFILE ou CUSTOM, vous pouvez sélectionner une spécification pour l'enveloppe. Pour plus d'informations, voir Sélection d'une spécification d'enveloppe.

Remarques

  • Pour permettre à BizTalk Server 2000 de traiter les échanges sortants dans n'importe quel format, vous devez créer une enveloppe.

  • Si vous choisissez le format Custom XML et que vous ne sélectionniez pas de spécification, le format d'enveloppe correspondra par défaut au format Reliable.

  • Lors du traitement des enveloppes compatibles avec BizTalk Framework 2.0, BizTalk Server 2000 doit être considéré comme le point final par rapport au délai d'expiration. Lorsque les documents compatibles avec BizTalk Framework 2.0 sont envoyés à BizTalk Server 2000, soit depuis une application, soit depuis un partenaire commercial, les champs suivants sont remplacés s'ils existent ou créés dans le cas contraire :
    • Dans la sous-section des propriétés :

      <prop:identity>

      <prop:sentAt>

      <expiresAt>

    • Dans la sous-section des informations de réception :

      <sendTo>

      <address>

      <sendReceiptBy>

  • Si vous modifiez le format d'enveloppe et que vous avez sélectionné une spécification, vous devez éventuellement sélectionner aussi une spécification différente.

  • Lorsque vous enregistrez une enveloppe qui fait référence à une spécification en dehors de votre domaine local, vous risquez d'obtenir un message d'erreur. S'il se produit une erreur, téléchargez et configurez l'utilitaire proxy WinHTTP. Pour télécharger cet utilitaire, accédez au site Web Microsoft MSDN (msdn.microsoft.com/downloads/default.asp) et accédez à la page WinHTTP Proxy Configuration Utility, qui figure dans le chapitre XML du manuel Web Development.

Voir aussi

Suppression d'enveloppes

Modification d'enveloppes

Recherche d'enveloppes

Description des enveloppes


Recherche d'enveloppes

  1. Dans le Gestionnaire d'échanges BizTalk, dans la zone Rechercher d'autres éléments, cliquez sur Enveloppes.

  2. Effectuez une ou plusieurs des actions suivantes :
    • Pour rechercher toutes les enveloppes, désactivez toutes les cases à cocher en regard des critères de sélection et cliquez sur Rechercher.

    • Pour rechercher une enveloppe spécifique, dans la case Nom d'enveloppe de la zone Rechercher les enveloppes, tapez le nom de l'enveloppe recherchée, puis cliquez sur Rechercher. Si vous entrez un nom incomplet, la recherche renverra tous les noms possibles correspondant à votre entrée.

    • Pour rechercher des enveloppes avec un format spécifique, dans la liste Format, choisissez un format et cliquez sur Rechercher.

Remarques

  • Vous pouvez définir plusieurs critères de recherche avant de cliquer sur Rechercher.

  • Pour effacer les critères et les résultats de la recherche, cliquez sur Effacer.

  • Si vous devez rechercher un grand nombre d'objets, le renvoi de tous les objets peut prendre plusieurs minutes. Vous pouvez limiter les objets renvoyés à la suite d'une recherche en définissant des critères de sélection.

  • Une recherche renvoie par défaut 500 objets, mais vous pouvez modifier ce nombre. Pour plus d'informations, voir Définition des options de connexion du serveur.

  • Vous pouvez utiliser les caractères génériques suivants dans les critères de recherche :
    Caractère générique | Description | Exemple
    % Toute chaîne de zéro caractère ou plus L'entrée '%ouvert%' renvoie tous les noms contenant le terme « ouvert ».
    _ (soulignement) | N'importe quel caractère | L'entrée « _ean » renvoie tous les noms de quatre lettres qui se terminent par « ean » (Dean, Sean, etc.).
    [ ] Tout caractère de l'intervalle ([a-f]) ou de l'ensemble spécifié ([abcdef]) L'entrée « [C-P]arsen » renvoie les noms se terminant par « arsen » et commençant par un caractère compris entre C et P (Carsen, Larsen, Karsen, etc.).
    [^] Tout caractère non compris dans l'intervalle ([^a-f]) ou l'ensemble (^abcdef]) spécifié L'entrée « de[^s]% » renvoie tous les noms commençant par « de » et dont la lettre suivante n'est pas un « s ».

Voir aussi

Suppression d'enveloppes

Modification d'enveloppes

Description des enveloppes


Modification d'enveloppes

  1. Dans le Gestionnaire d'échanges BizTalk, cliquez sur l'enveloppe à modifier dans la liste Nom d'enveloppe.

    Pour plus d'informations sur la recherche d'enveloppes, voir Recherche d'enveloppes.

  2. Dans le menu Fichier, cliquez sur Edition.

    La boîte de dialogue Propriétés d'enveloppe s'affiche.

  3. Dans la zone Nom d'enveloppe, tapez un nom unique pour l'enveloppe.

  4. Dans la liste Format d'enveloppe, choisissez l'un des formats d'enveloppe suivants :
    • CUSTOM XML

      Pour permettre à Microsoft BizTalk Server 2000 de traiter les échanges entrants au format Custom XML, vous devez créer une enveloppe au format Custom XML ainsi qu'une référence de spécification. Toutefois, lorsque vous envoyez des échanges Custom XML, il n'est pas nécessaire de spécifier le nom de l'enveloppe dans les paramètres d'appel soumis. BizTalk Server 2000 peut localiser l'enveloppe appropriée sans disposer d'une référence de nom.

    • X12

      Il n'est pas nécessaire de créer une enveloppe au format X12 pour permettre à BizTalk Server 2000 de traiter les échanges entrants au format X12 et il n'est pas non plus nécessaire de spécifier le nom de l'enveloppe dans les paramètres d'appel soumis.

    • EDIFACT

      Il n'est pas nécessaire de créer une enveloppe au format EDIFACT pour permettre à BizTalk Server 2000 de traiter les échanges entrants au format X12 et il n'est pas non plus nécessaire de spécifier le nom de l'enveloppe dans les paramètres d'appel soumis.

    • FLATFILE

      Pour permettre à BizTalk Server 2000 de traiter les échanges entrants au format FLATFILE (table bidirectionnelle), vous devez créer une enveloppe avec ce même format. Lorsque vous envoyez des documents FLATFILE entrants, vous devez spécifier le nom de l'enveloppe dans les paramètres d'appel soumis. Pour plus d'informations, voir Envoi.

    • PERSONNALISÉ

      Pour permettre à BizTalk Server 2000 de traiter les échanges entrants dont le format est personnalisé, un format non directement pris en charge par BizTalk Server 2000, il se peut que vous deviez créer une enveloppe. Cependant, vous devez créer un composant parseur personnalisé pour traiter ces échanges, lequel peut avoir besoin d'une enveloppe. Pour plus d'informations, voir Utilisation de l'interface IBizTalkParserComponent.

      Pour permettre à BizTalk Server 2000 de traiter les échanges sortants dont le format est personnalisé, vous devez créer une enveloppe au format personnalisé et sélectionner l'enveloppe dans un port d'échanges. Vous devez également créer et enregistrer un composant sérialiseur personnalisé. Pour plus d'informations, voir Utilisation de l'interface IBizTalkSerializerComponent. Vous pouvez configurer le sérialiseur personnalisé dans le canal accessible à partir de la page Configuration avancée de l'Assistant Canal. Pour plus d'informations, voir Définition des propriétés de configuration avancées.

    • RELIABLE

      Il n'est pas nécessaire de créer une enveloppe au format Reliable pour permettre à BizTalk Server 2000 de traiter les échanges entrants au format Reliable et il n'est pas non plus nécessaire de spécifier le nom de l'enveloppe dans les paramètres d'appel soumis.

      Le format Reliable permet de traiter les enveloppes dont le format est compatible avec BizTalk Framework 2.0. Pour plus d'informations sur BizTalk Framework 2.0, accédez au site Web de Microsoft BizTalk à l'adresse suivante : (www.microsoft.com/biztalk/).

      Si vous choisissez le format Reliable, vous devez également configurer l'adresse de type URL de réponse d'échange de type Reliable dans la boîte de dialogue Propriétés du groupe de serveurs BizTalk Server. Pour plus d'informations, voir Configuration des propriétés générales d'un groupe de serveurs.

  5. Si vous choisissez le format Custom XML, FLATFILE ou CUSTOM, vous pouvez sélectionner une spécification pour l'enveloppe. Pour plus d'informations, voir Sélection d'une spécification d'enveloppe.

Important

  • Si vous créez une enveloppe au format Reliable et que vous sélectionnez cette enveloppe dans un port d'échanges, vous devez également configurer l'adresse URL de réponse d'échange de type Reliable dans la boîte de dialogue Propriétés du groupe de serveurs BizTalk Server. Pour plus d'informations, voir Configuration des propriétés générales d'un groupe de serveurs.

Remarques

  • Pour permettre à BizTalk Server 2000 de traiter les échanges sortants dans n'importe quel format, vous devez créer une enveloppe.

  • Si vous choisissez le format Custom XML et que vous ne sélectionniez pas de spécification, le format d'enveloppe correspondra par défaut au format Reliable.

  • Lors du traitement des enveloppes compatibles avec BizTalk Framework 2.0, BizTalk Server 2000 doit être considéré comme le point final par rapport au délai d'expiration. Lorsque les documents compatibles avec BizTalk Framework 2.0 sont envoyés à BizTalk Server 2000, soit depuis une application, soit depuis un partenaire commercial, les champs suivants sont remplacés s'ils existent ou créés dans le cas contraire :
    • Dans la sous-section des propriétés :

      <prop:identity>

      <prop:sentAt>

      <expiresAt>

    • Dans la sous-section des informations de réception :

      <sendTo>

      <address>

      <sendReceiptBy>

  • Si vous modifiez le format d'enveloppe et que vous avez sélectionné une spécification, vous devez éventuellement sélectionner aussi une spécification différente.

  • Lorsque vous enregistrez une enveloppe qui fait référence à une spécification en dehors de votre domaine local, vous risquez d'obtenir un message d'erreur. S'il se produit une erreur, téléchargez et configurez l'utilitaire proxy WinHTTP. Pour télécharger cet utilitaire, accédez au site Web Microsoft MSDN (msdn.microsoft.com/downloads/default.asp) et accédez à la page WinHTTP Proxy Configuration Utility, qui figure dans le chapitre XML du manuel Web Development.

Voir aussi

Création d'enveloppes

Suppression d'enveloppes

Recherche d'enveloppes

Description des enveloppes


Suppression d'enveloppes

  1. Dans le Gestionnaire d'échanges BizTalk, cliquez sur l'enveloppe à supprimer dans la liste Nom d'enveloppe.

    Pour plus d'informations sur la recherche d'enveloppes, voir Recherche d'enveloppes.

  2. Dans le menu Fichier, cliquez sur Supprimer.

Remarque

  • Lorsqu'une enveloppe est utilisée dans un port d'échanges, vous ne pouvez pas la supprimer. Vous devez tout d'abord supprimer tous les ports d'échanges qui utilisent l'enveloppe.

Voir aussi

Création d'enveloppes

Modification d'enveloppes

Recherche d'enveloppes

Description des enveloppes


Sélection d'une spécification d'enveloppe

  1. Dans la boîte de dialogue Nouvelle enveloppe ou Propriétés d'enveloppe, activez la case à cocher Spécification d'enveloppe et cliquez sur Parcourir.

    La boîte de dialogue Sélectionnez une spécification d'enveloppe dans le référentiel WebDAV s'affiche.

  2. Dans la zone Serveur, procédez de l'une des façons suivantes pour changer de serveur.
    • Sélectionnez un serveur dans la liste.

    • Tapez le nom d'un serveur et appuyez sur ENTRÉE.
  3. Double-cliquez sur le dossier qui contient la spécification que vous voulez ouvrir, cliquez sur la spécification, puis cliquez sur Ouvrir.

Important

  • Lorsque vous ouvrez pour la première fois une boîte de dialogue Référentiel WebDAV, le référentiel WebDAV du serveur local est sélectionné, même si le Gestionnaire d'échanges BizTalk est connecté à une base de données d'un serveur distant. Si vous accédez à un référentiel WebDAV d'un serveur distant, celui-ci devient le serveur par défaut jusqu'à ce que vous sélectionniez un nouveau référentiel WebDAV. Le serveur par défaut de toutes les boîtes de dialogue Référentiel WebDAV est le dernier serveur avec lequel une connexion a été établie.

Remarques

  • Si vous sélectionnez l'adresse http://localhost pour le serveur, le Gestionnaire d'échanges BizTalk la transforme automatiquement en nom d'ordinateur local.

  • Si vous choisissez le format Custom XML, vous pouvez sélectionner une spécification pour l'enveloppe. Si vous ne sélectionnez pas de spécification, le format par défaut de l'enveloppe est le format Reliable, qui est compatible avec BizTalk Framework 2.0. Pour plus d'informations sur BizTalk Framework 2.0, accédez au site Web de Microsoft BizTalk à l'adresse suivante : (www.microsoft.com/biztalk/).

  • Si vous choisissez le format FLATFILE, vous pouvez sélectionner une spécification pour l'enveloppe. Vous devez sélectionner une spécification si l'enveloppe est utilisée pour les échanges entrants ouverts. Il n'est pas nécessaire de sélectionner une spécification si l'enveloppe est utilisée pour la création d'échanges sortants.

  • Si vous choisissez un format personnalisé, vous pouvez sélectionner une spécification pour l'enveloppe. Le parseur ou le sérialiseur personnalisé que vous créez détermine la sélection ou non d'une spécification

    Pour utiliser le format personnalisé, vous devez :

    • Créer un composant parseur personnalisé pour les échanges entrants ouverts au format personnalisé. Pour plus d'informations, voir Utilisation de l'interface IBizTalkParserComponent.

    • Créer et configurer un composant sérialiseur personnalisé pour créer des échanges sortants dont le format est personnalisé. Pour plus d'informations, voir Utilisation de l'interface IBizTalkSerializerComponent.

    • Configurer le composant sérialiseur personnalisé en utilisant les propriétés du port d'échanges dans l'Assistant Canal. Pour plus d'informations, voir Remplacement des valeurs par défaut d'un port d'échanges.
  • Lorsque vous enregistrez une enveloppe qui fait référence à une spécification en dehors de votre domaine local, vous risquez d'obtenir un message d'erreur. S'il se produit une erreur, téléchargez et configurez l'utilitaire proxy WinHTTP. Pour télécharger cet utilitaire, accédez au site Web Microsoft MSDN (msdn.microsoft.com/downloads/default.asp) et accédez à la page WinHTTP Proxy Configuration Utility, qui figure dans le chapitre XML du manuel Web Development.

Voir aussi

Création d'enveloppes

Modification d'enveloppes

Recherche d'enveloppes

Description des enveloppes


Utilisation de listes de distribution

Cette section fournit des informations spécifiques aux tâches relatives à l'utilisation des listes de distribution. Nous vous recommandons vivement de revoir Description des listes de distribution dans la section Concepts pour comprendre pleinement le concept des listes de distribution.

Cette section traite des procédures suivantes :

  • Création de listes de distribution

  • Recherche de listes de distribution

  • Modification de listes de distribution

  • Suppression de listes de distribution


Création de listes de distribution

  1. Dans le Gestionnaire d'échanges BizTalk, dans le menu Fichier, pointez sur Nouveau et cliquez sur Liste de distribution.

    La boîte de dialogue Nouvelle liste de distribution apparaît.

  2. Dans la zone Nom de la liste de distribution, tapez un nom unique pour la liste de distribution.

  3. Dans la liste Ports d'échanges disponibles, sélectionnez les ports d'échanges que vous souhaitez inclure et cliquez sur Ajouter.

    Les ports d'échanges sélectionnés sont ajoutés à la liste Ports d'échanges sélectionnés.

  4. Dans la liste Ports d'échanges sélectionnés, sélectionnez les ports d'échanges que vous ne voulez pas inclure et cliquez sur Supprimer.

  5. Après avoir défini toutes les propriétés requises, cliquez sur OK pour fermer la boîte de dialogue Nouvelle liste de distribution.

Remarques

  • Lorsque vous supprimez un port d'échanges d'une liste de distribution, celui-ci est supprimé de cette liste de distribution uniquement, il n'est pas supprimé de la base de données.

  • Une liste de distribution doit contenir au moins un port d'échanges.

  • Les ports d'échanges ouverts ne peuvent pas être ajoutés à une liste de distribution.

  • Pour pouvoir fonctionner, une liste de distribution nécessite au moins un canal. Pour plus d'informations sur les canaux, voir Création et gestion de canaux.

Voir aussi

Suppression de listes de distribution

Modification de listes de distribution

Recherche de listes de distribution

Description des listes de distribution


Recherche de listes de distribution

  1. Dans le Gestionnaire d'échanges BizTalk, dans la zone Rechercher d'autres éléments, cliquez sur Listes de distribution.

  2. Effectuez une ou plusieurs des actions suivantes :
    • Pour rechercher toutes les listes de distribution, effacez tous les critères de recherche et cliquez sur Rechercher.

    • Pour rechercher une liste de distribution portant un nom spécifique, dans la zone Rechercher les listes de distribution, dans Nom de la liste de distribution, tapez le nom de la liste de distribution que vous souhaitez trouver et cliquez sur Rechercher. Si vous entrez un nom incomplet, la recherche renverra tous les noms possibles correspondant à votre entrée.

    • Pour rechercher des listes de distribution contenant un port d'échanges spécifique, dans la liste Contenant le port d'échanges, tapez le nom du port d'échanges en question, puis cliquez sur Rechercher.

Remarques

  • Pour effacer les critères et les résultats de la recherche, cliquez sur Effacer.

  • Si vous devez rechercher un grand nombre d'objets, le renvoi de tous les objets peut prendre plusieurs minutes. Vous pouvez limiter les objets renvoyés à la suite d'une recherche en définissant des critères de sélection.

  • Une recherche renvoie par défaut 500 objets, mais vous pouvez modifier ce nombre. Pour plus d'informations, voir Définition des options de connexion du serveur.

  • Vous pouvez utiliser les caractères génériques suivants dans les critères de recherche :
    Caractère générique | Description | Exemple
    % Toute chaîne de zéro caractère ou plus L'entrée '%ouvert%' renvoie tous les noms contenant le terme « ouvert ».
    _ (soulignement) | N'importe quel caractère | L'entrée « _ean » renvoie tous les noms de quatre lettres qui se terminent par « ean » (Dean, Sean, etc.).
    [ ] Tout caractère de l'intervalle ([a-f]) ou de l'ensemble spécifié ([abcdef]) L'entrée « [C-P]arsen » renvoie les noms se terminant par « arsen » et commençant par un caractère compris entre C et P (Carsen, Larsen, Karsen, etc.).
    [^] Tout caractère non compris dans l'intervalle ([^a-f]) ou l'ensemble (^abcdef]) spécifié L'entrée « de[^s]% » renvoie tous les noms commençant par « de » et dont la lettre suivante n'est pas un « s ».

Voir aussi

Création de listes de distribution

Suppression de listes de distribution

Modification de listes de distribution

Description des listes de distribution


Modification de listes de distribution

  1. Dans le Gestionnaire d'échanges BizTalk, dans la liste Nom de la liste de distribution, cliquez sur la liste de distribution que vous souhaitez modifier.

    Pour des informations sur la recherche de listes de distribution, voir Recherche de listes de distribution.

  2. Dans le menu Fichier, cliquez sur Edition.

    La boîte de dialogue Propriétés de la liste de distribution s'affiche.

  3. Dans la zone Nom de la liste de distribution, tapez un nom unique pour la liste de distribution.

  4. Dans la liste Ports d'échanges disponibles, sélectionnez les ports d'échanges que vous souhaitez inclure et cliquez sur Ajouter pour les ajouter à la liste Ports d'échanges sélectionnés.

  5. Dans la liste Ports d'échanges sélectionnés, sélectionnez les ports d'échanges que vous ne voulez pas inclure et cliquez sur Supprimer.

  6. Après avoir défini toutes les propriétés requises, cliquez sur OK pour fermer la boîte de dialogue Propriétés de la liste de distribution.

Remarques

  • Lorsque vous supprimez un port d'échanges d'une liste de distribution, celui-ci est supprimé de cette liste de distribution uniquement, il n'est pas supprimé de la base de données.

  • Une liste de distribution doit contenir au moins un port d'échanges.

  • Les ports d'échanges ouverts ne peuvent pas être ajoutés à une liste de distribution.

Voir aussi

Création de listes de distribution

Suppression de listes de distribution

Recherche de listes de distribution

Description des listes de distribution


Suppression de listes de distribution

  1. Dans le Gestionnaire d'échanges BizTalk, dans la liste Nom de la liste de distribution, cliquez sur la liste de distribution que vous souhaitez supprimer.

    Pour plus d'informations sur la recherche de listes de distribution, voir Recherche de listes de distribution.

  2. Dans le menu Fichier, cliquez sur Supprimer.

Remarques

  • Vous ne pouvez pas supprimer une liste de distribution tant que tous les canaux associés à cette liste n'ont pas été supprimés.

  • Pour rechercher des canaux associés à une liste de distribution, cliquez avec le bouton droit sur la liste de distribution, puis cliquez sur Rechercher des canaux.

Voir aussi

Création de listes de distribution

Recherche de listes de distribution

Description des listes de distribution


Concepts

Cette section présente des concepts essentiels pour comprendre l'utilisation du Gestionnaire d'échanges BizTalk. Elle contient des informations sur les rubriques suivantes :

  • Environnement du Gestionnaire d'échanges BizTalk

  • Description des canaux

  • Description des ports d'échanges

  • Description des organisations

  • Description des définitions de document

  • Description des enveloppes

  • Description des accusés de réception

  • Description des listes de distribution


Environnement du Gestionnaire d'échanges BizTalk

Cette section traite des rubriques suivantes :

  • Configuration des options du Gestionnaire d'échanges BizTalk

  • Interface du Gestionnaire d'échanges BizTalk

  • Touches de raccourci du Gestionnaire d'échanges BizTalk

  • Sécurité

Attention

  • Vous devez utiliser le Gestionnaire d'échanges BizTalk pour configurer les services d'Échanges BizTalk avant de traiter les documents. Si vous accédez à des objets susceptibles d'être en cours d'utilisation lors du traitement de documents par Microsoft BizTalk Server 2000 ou si vous les modifiez, cela peut entraîner des résultats inattendus.


Configuration des options du Gestionnaire d'échanges BizTalk

Cette section explique comment modifier les options du Gestionnaire d'échanges BizTalk, Parmi ces options, citons :

  • la configuration des nouveaux ports d'échanges ou des canaux ;

  • la gestion des ports d'échanges ou des canaux déjà configurés ;

  • la définition de la valeur renvoyée pour la recherche ;

  • la configuration de la connexion du serveur ;

  • la définition de la valeur pour le délai d'expiration du serveur.

Cette section traite des procédures suivantes :

  • Sélection d'une option de configuration du Gestionnaire d'échanges BizTalk

  • Définition des options de connexion du serveur

Remarque

  • Les barres d'outils du Gestionnaire d'échanges BizTalk peuvent être déplacées ; cependant, lors du redémarrage de l'application, les barres d'outils retrouveront leur emplacement d'origine.


Sélection d'une option de configuration du Gestionnaire d'échanges BizTalk

  1. Dans le menu Démarrer, pointez sur Programmes et sur Microsoft BizTalk Server 2000, puis cliquez sur Gestionnaire d'échanges BizTalk.

    La boîte de dialogue Gestionnaire d'échanges BizTalk s'affiche.

  2. Dans la zone Options de configuration, sélectionnez l'une des options suivantes :
    • Pour créer et configurer un nouveau port d'échanges pour une organisation, cliquez sur Configurer un nouveau port d'échanges pour une organisation, puis cliquez sur OK.

      Pour plus d'informations sur la création et la configuration d'un nouveau port d'échanges pour une organisation, voir Création de ports d'échanges.

    • Pour créer et configurer un nouveau port d'échanges pour une application, cliquez sur Configurer un nouveau port d'échanges pour une application, puis cliquez sur OK

      Pour plus d'informations sur la création et la configuration d'un nouveau port d'échanges pour une application, voir Création de ports d'échanges.

    • Pour gérer des ports d'échanges existants, cliquez sur Gérer les ports d'échanges déjà configurés, puis cliquez sur OK

      Pour plus d'informations sur la gestion des ports d'échanges existants, voir Modification de ports d'échanges.

    • Pour gérer des canaux existants, cliquez sur Gérer les canaux d'échanges déjà configurés, puis cliquez sur OK.

      Pour plus d'informations sur la création et la configuration des canaux existants, voir Modification de canaux.

Remarque

  • Si vous ne souhaitez pas que cette boîte de dialogue s'affiche à l'ouverture du Gestionnaire d'échanges BizTalk, activez la case à cocher Ne plus afficher cette boîte de dialogue. Pour que la boîte de dialogue s'affiche de nouveau, dans le menu Outils, cliquez sur Options et activez la case à cocher Afficher la boîte de dialogue de démarrage.

Voir aussi

Création de ports d'échanges

Modification de canaux

Modification de ports d'échanges


Définition des options de connexion du serveur

  1. Dans le Gestionnaire d'échanges BizTalk, cliquez sur Options dans le menu Outils.

    La boîte de dialogue Options s'affiche.

  2. Dans la zone Nombre maximal d'éléments à renvoyer lors d'une recherche, effectuez l'une des opérations suivantes :
    • Indiquez une valeur correspondant au nombre d'éléments à renvoyer dans le résultat d'une recherche.

    • Cliquez sur la flèche vers le haut ou vers le bas pour augmenter ou diminuer cette valeur.
  3. Dans la zone Nom du serveur BizTalk Server auquel vous souhaitez vous connecter, tapez le nom d'un serveur sur lequel BizTalk Server 2000 est installé.

  4. Dans la zone Délai d'expiration du serveur (s), effectuez l'une des opérations suivantes :
    • Tapez une valeur correspondant au nombre de secondes qui doit s'écouler avant que le délai d'expiration de la connexion du serveur ne soit atteint.

    • Cliquez sur la flèche vers le haut ou vers le bas pour augmenter ou diminuer cette valeur.
  5. Pour choisir d'afficher ou non la boîte de démarrage lors du lancement du Gestionnaire d'échanges BizTalk, activez ou désactivez la case à cocher Afficher la boîte de dialogue de démarrage.

  6. Une fois toutes les propriétés définies, cliquez sur OK.

Remarques

  • Le serveur auquel vous êtes connecté détermine la base de données du Gestionnaire d'échanges BizTalk dans laquelle vous recherchez, modifiez ou créez des objets avec le Gestionnaire d'échanges BizTalk. Par défaut, les paramètres de la connexion du serveur sont ceux de la dernière connexion effectuée. Le serveur qui héberge le référentiel WebDAV et que vous utilisez pour stocker et extraire des spécifications pour les documents, les mappages et les enveloppes est défini séparément en complétant les zones de la boîte de dialogue utilisée pour sélectionner les spécifications. Par défaut, les paramètres de la connexion WebDAV sont ceux de la dernière connexion effectuée.

  • Le nombre d'éléments renvoyés par défaut dans le résultat d'une recherche est 500.

  • La durée par défaut qui s'écoule avant que le délai de connexion du serveur n'expire est de 20 secondes.

  • Le serveur auquel vous êtes connecté est indiqué dans la partie supérieure du volet Recherche situé dans la partie gauche du Gestionnaire d'échanges BizTalk.


Interface du Gestionnaire d'échanges BizTalk

L'interface utilisateur du Gestionnaire d'échanges BizTalk est constituée de deux volets principaux.

Le volet gauche contient les éléments suivants :

  • le nom du serveur auquel le Gestionnaire d'échanges BizTalk est connecté ;

  • une liste d'objets parmi lesquels vous pouvez effectuer une recherche ;

  • des critères de recherche à utiliser pour affiner votre recherche.

Vous pouvez rechercher n'importe quel objet que vous avez créé en utilisant le Gestionnaire d'échanges BizTalk. Vous pouvez choisir le type d'objet à rechercher en cliquant sur un nom dans la zone Rechercher d'autres éléments. Les critères de recherche diffèrent selon l'objet sélectionné.

Le volet droit contient :

  • les informations relatives aux éléments renvoyés dans le dernier résultat de la recherche ;

les informations relatives à ces éléments diffèrent selon le type d'objet recherché.

Vous pouvez trier les éléments dans le volet de résultats de la recherche par ordre croissant ou décroissant en cliquant dans les en-têtes de colonne. Il vous est possible d'effectuer un tri sur une seule colonne à la fois.

Remarques

  • Si vous effectuez une recherche sur un nombre important d'objets d'un type particulier, vous devrez attendre plusieurs minutes avant d'obtenir le résultat. Vous pouvez limiter le nombre d'éléments renvoyés dans le résultat d'une recherche en utilisant des critères de recherche.

  • Une recherche renvoie par défaut 500 objets, mais vous pouvez modifier ce nombre. Pour plus d'informations, voir Définition des options de connexion du serveur.

Voir aussi

Touches de raccourci du Gestionnaire d'échanges BizTalk

Recherche de canaux

Recherche de listes de distribution

Recherche de définitions de document

Recherche d'enveloppes

Recherche de ports d'échanges

Recherche d'organisations


Touches de raccourci du Gestionnaire d'échanges BizTalk

Vous pouvez utiliser des touches de raccourci pour effectuer certaines tâches dans le Gestionnaire d'échanges BizTalk. Le tableau suivant présente ces touches de raccourci.

Remarque

  • Le clavier numérique permet d'obtenir la fonctionnalité non incluse dans la liste pour déplacer le pointeur de la souris à l'aide des Touches souris. Pour plus d'informations sur les Touches souris dans Windows 2000 Server et l'aide de Advanced Server, voir Utiliser le clavier pour déplacer le pointeur de la souris. Pour plus d'informations sur les Touches souris dans l'aide de Windows 2000 Édition Professionnelle, voir Déplacer le pointeur à l'aide des Touches souris.
Appuyez sur | Pour
CTRL+A | Sélectionner tout.
CTRL+C | Copier du texte.
Ctrl+X | Couper du texte.
CTRL+V | Coller du texte.
CTRL+Z | Annuler la dernière action sur le texte.
CTRL+R | Créer un port d'échanges pour une organisation.
CTRL+MAJ+R | Créer un port d'échanges pour une application.
CTRL+L | Créer un canal à partir d'une organisation.
CTRL+MAJ+SUPPR | Créer un canal à partir d'une application.
CTRL+T | Créer une liste de distribution.
CTRL+D | Créer une définition de document.
CTRL+G | Créer une organisation.
SUPPR | Supprimer l'élément ou le texte sélectionné.
MAJ+F10 | Afficher le menu contextuel associé à l'élément sélectionné.
Utilisation de la touche MAJ avec une touche de direction | Sélectionner plusieurs éléments dans une fenêtre ou sélectionner du texte.
TAB | La touche TABULATION permet de déplacer le focus d'un bouton ou d'un champ à l'autre dans la boîte de dialogue.
MAJ+TAB | La touche TABULATION permet de déplacer le focus d'un bouton ou d'un champ à l'autre dans la boîte de dialogue.
CTRL+TAB | Activer et désactiver les onglets d'une feuille de propriétés de l'avant vers l'arrière.
CTRL+MAJ+TAB | Activer et désactiver les onglets d'une feuille de propriétés de l'arrière vers l'avant.
BARRE ESPACE | Activer ou désactiver une case à cocher. L'utilisation de la barre d'espace entraîne le même résultat qu'un clic de souris lorsqu'un bouton est activé.
ALT+ESPACE | Afficher le menu Système pour la fenêtre active.
ALT+lettre soulignée d'un nom de menu | Afficher le menu correspondant.
Lettre soulignée dans un nom de commande d'un menu ouvert | Exécuter la commande correspondante.
ALT + FLÈCHE BAS | Afficher la liste déroulante d'une zone de liste active.
ENTRÉE | Exécuter la commande pour l'option active ou le bouton actif.
ÉCHAP | Annuler la tâche en cours.
F1 | Afficher l'aide en ligne.
ALT+F4 | Fermer la fenêtre active ou quitter le programme actif.
GAUCHE | Déplacer le focus vers l'onglet de gauche.
DROITE | Déplacer le focus vers l'onglet de droite.
N'importe quelle touche de direction | Mettre en surbrillance un dossier ou un fichier dans la fenêtre principale d'une boîte de dialogue lorsque cette fenêtre est active. Cette fonction est disponible dans les boîtes de dialogue Sélectionnez une spécification de document dans le référentiel WebDAV, Sélectionnez une spécification d'enveloppe dans le référentiel WebDAV et Sélectionnez un mappage dans le référentiel WebDAV. Pour plus d'informations, voir Sélection d'une spécification de document, Sélection d'une spécification d'enveloppe et Sélection d'un mappage.

Voir aussi

Interface du Gestionnaire d'échanges BizTalk


Sécurité

Pour accéder à des objets ou les créer en utilisant le Gestionnaire d'échanges BizTalk, vous devez disposer d'un compte d'utilisateur dans le groupe Administrateurs de BizTalk Server. Le groupe Administrateurs de BizTalk Server est créé lors de l'installation de BizTalk Server 2000. Le cas échéant, il est possible d'ajouter des utilisateurs supplémentaires à ce groupe. Pour plus d'informations sur l'ajout d'un compte d'utilisateur, voir Ajout d'utilisateurs au groupe Administrateurs de BizTalk Server.


Description des canaux

Un canal est un ensemble de propriétés que vous utilisez pour configurer les services d'Échanges BizTalk afin de traiter les documents qu'il reçoit. Il est possible de créer des canaux pour un port d'échanges ou une liste de distribution. Lorsque le canal a terminé le traitement d'un document, le document est transmis à la destination spécifiée dans le port d'échanges associé ou aux ports d'échanges définis dans la liste de distribution associée. Vous pouvez créer un ou plusieurs canaux pour un port d'échanges ou une liste de distribution.

Dans le canal, spécifiez la source des documents, qui peut être une organisation source ou une application source. Avant de pouvoir désigner une application comme source pour un canal, vous devez créer une application pour l'organisation d'origine, qui représente une application interne à votre entreprise. Vous pouvez également désigner une planification XLANG comme source pour un canal. La création d'une planification XLANG s'effectue en utilisant le Concepteur d'Orchestration BizTalk. (pour plus d'informations, voir Conception des orchestrations BizTalk) ; Pour plus d'informations sur l'intégration des services d'Échanges BizTalk avec les services d'Orchestration BizTalk, voir Intégration des services BizTalk.

Vous avez également la possibilité de déclarer explicitement une source ouverte, ce qui signifie que la source doit être spécifiée dans le document ou dans un paramètre lorsque le document est envoyé. On parle alors de canal ouvert. Pour plus d'informations, voir Envoi.

Spécifiez également une définition de document entrant,, qui représente un document entrant provenant d'une application interne ou de l'organisation d'un partenaire commercial. Enfin, spécifiez une définition de document sortant, qui représente le document à transmettre à la destination indiquée. Pour plus d'informations sur les définitions de document, voir Description des définitions de document.

Si un document sortant ne dispose pas des mêmes formats ou structures que le document entrant, vous devez spécifier un mappage pour le canal. Un mappage permet de transformer le format ou la structure du document d'origine entrant et de lui appliquer le format ou la structure du document sortant, requis par l'organisation ou l'application de destination. Par exemple, si votre application comptable génère des bons de commande au format Flat-file délimité mais que votre partenaire commercial utilise des bons de commande au format X12, vous pouvez utiliser un mappage pour modifier le format du document. Pour plus d'informations sur les mappages, voir Données de mappage.

Vous pouvez créer plusieurs canaux pour un port d'échanges ou une liste de distribution, chacun d'entre eux présentant une configuration différente. Supposez par exemple que vous possédez deux applications comptables internes qui génèrent des bons de commande dans des formats différents et que votre partenaire commercial souhaite recevoir des bons de commande dans un format encore différent. Vous pouvez créer un port d'échanges unique pour ce partenaire commercial. Ensuite, pour ce port d'échanges, vous pouvez créer un canal pour chaque application. La définition des documents sortants pour les deux canaux est ainsi identique et correspond au format de votre partenaire commercial. Cependant, chaque canal dispose d'un mappage différent pour modifier les formats des documents entrants des applications. La création de canaux différents, connectés à un port d'échanges unique, vous permet donc d'envoyer tous vos bons de commande dans un même format.

Par ailleurs, vous pouvez définir d'autres propriétés dans un canal pour effectuer les opérations suivantes :

  • Désigner des champs de spécification pour effectuer le suivi de la définition du document entrant. Les champs désignés sont consignés dans une base de données de suivi pour chaque instance de document traitée en utilisant ce canal spécifique, à la place des champs de suivi global désignés dans la définition de document. Pour plus d'informations sur les champs de suivi global, voir Suivi des champs de données d'un document.

  • Créer une expression de filtrage de canal, qui détermine si BizTalk Server 2000 doit appeler le canal et qui est basée sur la valeur attribuée à un ou plusieurs champs dans le document en cours de traitement.

  • Configurer des accusés de réception. Vous pouvez demander un accusé de réception au destinataire du document que vous envoyez et vous pouvez aussi en générer un pour l'expéditeur du document que vous recevez. Pour plus d'informations sur le traitement des accusés de réception, voir Description des accusés de réception.

  • Configurer les propriétés de sécurité. Vous pouvez demander la vérification, par le serveur, du cryptage et de la signature des documents entrants ou l'apposition d'une signature numérique sur les documents sortants.

  • Spécifier des options pour la consignation des documents. Vous pouvez stocker les documents entrants et sortants dans leur format d'origine, dans leur format XML intermédiaire ou dans les deux formats.

  • Définir les propriétés avancées. Vous pouvez spécifier un numéro de contrôle de groupe pour des documents au format EDI, définir le nombre de tentatives et la durée au bout de laquelle le serveur renvoie les documents et enfin, remplacer le composant de transport ainsi que les propriétés d'enveloppe pour le port d'échanges ou la liste de distribution.

Vous pouvez aussi créer des canaux d'accusé de réception en utilisant le Gestionnaire d'échanges BizTalk. Un canal d'accusé de réception est un type de canal particulier que vous utilisez pour renvoyer un accusé de réception à l'émetteur d'un document reçu par les services d'Échanges BizTalk. Lorsque vous créez un canal pour traiter un document entrant qui requiert un accusé de réception, vous pouvez spécifier le canal d'accusé de réception que le serveur doit utiliser pour traiter l'accusé. Pour cela, vous devez donc créer un port d'échanges et un canal d'accusé de réception associé avant de créer un port d'échanges et un canal pour traiter un document qui nécessite un accusé de réception. Pour plus d'informations sur le traitement des accusés de réception, voir Description des accusés de réception.

À la réception d'un document, BizTalk Server 2000 localise le canal approprié, qui oriente le serveur sur la façon de traiter le document. Le serveur localise ensuite le port d'échanges ou la liste de distribution associée au canal. Le port d'échanges dirige le serveur à travers la séquence d'étapes nécessaires à la transmission du document vers la destination spécifiée. Si le canal est associé à une liste de distribution, le serveur utilise les propriétés de chaque port d'échanges de la liste de distribution pour transmettre le document aux destinations spécifiées.

Cette section traite des rubriques suivantes :

  • Éléments de canal

  • Combinaisons de canal et de port d'échanges valides


Éléments de canal

Les canaux sont constitués des éléments suivants :

Organisation ou application source

Lors de la création d'un canal, vous devez désigner une application ou une organisation comme source pour les documents. Une application source est toujours une application de gestion de votre organisation d'origine. Il peut s'agir d'une application comptable, d'un système de saisie des bons de commande ou d'une application de gestion. Vous pouvez également désigner une planification XLANG comme source pour des documents. La création d'une planification XLANG s'effectue en utilisant le Concepteur d'Orchestration BizTalk. Une organisation source représente toujours un partenaire commercial externe.

Un canal est toujours créé pour un port d'échanges ou une liste de distribution. La destination des documents que vous recevez depuis la source d'un canal est désignée dans le port d'échanges, ou dans les ports d'échanges de la liste de distribution, pour lesquels le canal a été créé.

Définitions de documents entrants et sortants

Dans un canal, les définitions de documents représentent les documents entrants et sortants traités par BizTalk Server 2000. La définition de document fournit un pointeur vers une spécification qui définit le document. La spécification définit des caractéristiques telles que la structure, le type et la version du document. Pour plus d'informations, voir Description des définitions de document.

À la réception d'un document, BizTalk Server 2000 localise le canal approprié pour le traiter. Le serveur utilise la spécification de la définition du document entrant pour convertir le document entrant dans un format XML intermédiaire. Le serveur mappe le format et la structure du document entrant au format et à la structure du document sortant, si nécessaire. Ensuite, le serveur utilise la spécification du document sortant pour le convertir dans le format et la structure que l'application ou l'organisation de destination peut reconnaître et utiliser.

Mappage

Il se peut que le format ou la structure d'un document entrant soient différents du format ou de la structure requis pour le document sortant. Si tel est le cas, un mappage peut être utilisé pour convertir le format du document entrant au format du document sortant.

Par exemple, si votre application comptable génère des factures au format Flat-file délimité par des virgules, mais que votre partenaire commercial ne puisse recevoir que des factures au format X12, vous pouvez utiliser un mappage dans le canal pour modifier le format.

Un mappage peut également permettre de modifier le contenu et la structure d'un document qui utilise le même format. Pour plus d'informations, voir Données de mappage.

Suivi et filtrage des propriétés

Vous pouvez désigner des champs de spécification pour qu'ils soient consignés dans une base de données de suivi pour la définition d'un document entrant d'un canal. Les champs de spécification que vous désignez dans un canal sont consignés dans une base de données de suivi pour chaque instance d'un document traité en utilisant ce canal. Ces champs sont consignés à la place de tous les autres champs de suivi global désignés dans la définition du document entrant. Les champs de suivi global désignés pour la définition du document sortant sont ignorés. Pour plus d'informations, voir Suivi des champs de données d'un document.

L'utilisation d'une expression de filtrage de canal est une autre méthode permettant de déterminer les canaux appelés lorsque BizTalk Server 2000 reçoit un document. Dans le cas d'une expression de filtrage de canal, ils sont déterminés en fonction de la valeur d'un ou de plusieurs champs spécifiés dans l'instance du document.

Lorsque le serveur traite un document, la valeur de chaque champ spécifié est comparée à la valeur de l'expression de filtrage du canal. Si l'expression est vraie, le canal est appelé. Si l'expression est fausse, le canal n'est pas appelé. Par exemple, si l'expression de filtrage du canal est créée pour la recherche des bons de commande dont le total est supérieur à 1 000 et si le champ Total du bon de commande dans le document contient la somme 1 500, le canal est appelé.

Propriétés de consignation des documents

BizTalk Server 2000 convertit les documents entrants non-XML, de leur format d'origine vers un format XML Unicode intermédiaire, en vue de leur traitement. BizTalk Server 2000 convertit les documents sortants du format XML Unicode intermédiaire, dans le format requis pour la destination spécifiée. Vous pouvez choisir de stocker les données de chaque document entrant et sortant dans un seul format ou dans les deux.

Voir aussi

Création et gestion de canaux

Description des canaux

Combinaisons de canal et de port d'échanges valides


Combinaisons de canal et de port d'échanges valides

Seule la création de certaines combinaisons de canal (source) et de port d'échanges (destination) est autorisée pour leur utilisation avec Microsoft BizTalk Server 2000.

Les scénarios d'entreprise suivants montrent comment configurer des ports d'échanges avec une destination correcte ainsi que des canaux avec des désignations de sources valides pour transmettre correctement des données.

Scénario 1 : Partenaire commercial vers application interne

Dans ce scénario, vous créez un port d'échanges avec une application de l'organisation d'origine comme destination. Vous créez ensuite un canal pour ce port d'échanges avec l'organisation du partenaire commercial comme source.

Scénario 2 : Application interne vers partenaire commercial

Dans ce scénario, vous créez un port d'échanges avec l'organisation d'un partenaire commercial comme destination. Vous créez ensuite un canal pour ce port d'échanges avec une application de l'organisation d'origine comme source.

Scénario 3 : Application interne vers application interne

Dans ce scénario, vous créez un port d'échanges avec une application de l'organisation d'origine comme destination. Vous créez ensuite un canal pour ce port d'échanges avec une autre application de l'organisation d'origine comme source.

Scénario 4 : Application interne vers liste de distribution

Dans ce scénario, vous créez une liste de distribution, qui inclut un groupe de ports d'échanges existants pour des organisations ou des applications. Vous créez ensuite un canal pour cette liste de distribution avec une application de l'organisation d'origine comme source.

Scénario 5 : Application interne vers destination ouverte

Dans ce scénario, vous créez un port d'échanges que vous définissez en tant que port d'échanges ouvert. Vous créez ensuite un canal pour ce port d'échanges avec une application de l'organisation d'origine comme source.

Scénario 6 : Source ouverte vers application interne

Dans ce scénario, vous créez un port d'échanges avec une application de l'organisation d'origine comme destination. Vous créez ensuite un canal pour ce port d'échanges que vous spécifiez en tant que canal ouvert.

Remarque

  • Un canal défini comme canal ouvert ne peut pas être créé pour un port d'échanges défini en tant que port d'échanges ouvert.

Scénario 7 : Partenaire commercial vers partenaire commercial via un intermédiaire

Dans ce scénario, un premier partenaire commercial envoie des documents à un second partenaire commercial via votre système BizTalk Server 2000 et votre entreprise sert d'intermédiaire. Vous créez un port d'échanges avec l'organisation d'un partenaire commercial comme destination. Vous créez ensuite un canal pour ce port d'échanges avec un autre partenaire commercial comme source.

Voir aussi

Éléments de canal

Description des canaux


Description des ports d'échanges

Un port d'échanges est un ensemble de propriétés que vous pouvez utiliser pour configurer les services d'Échanges BizTalk afin de transmettre des documents vers une destination spécifique en utilisant un service de transport spécifique. Les documents qu'un port d'échanges transporte proviennent de la source que vous avez définie dans un canal associé. Vous pouvez créer plusieurs canaux pour un seul port d'échanges afin d'envoyer des documents de sources différentes vers une destination unique.

Un port d'échanges peut être configuré pour l'envoi de documents vers une organisation de destination spécifiée, une planification XLANG ou une application de destination.

Pour un port d'échanges vers une organisation, vous pouvez soit désigner un partenaire commercial spécifique comme étant la destination, soit déclarer une destination ouverte, qui est désignée comme étant le port d'échanges ouvert. Un port d'échanges ouvert peut être utilisé pour transmettre des documents uniquement aux organisations des partenaires commerciaux. Pour un port d'échanges ouvert, les données de l'organisation de destination doivent être indiquées dans le document ou dans un paramètre lors de l'envoi du document à BizTalk Server 2000. Pour plus d'informations sur l'envoi des documents, voir Envoi. Pour plus d'informations sur les ports d'échanges ouverts, voir Propriété Openness.

Lorsque l'adresse indiquée pour un port d'échanges ouvert est une adresse SMTP, le serveur doit disposer d'une adresse d'expédition pour l'organisation d'origine. Pour obtenir cette adresse, le serveur utilise la valeur spécifiée pour un identificateur d'organisation spécifique de l'organisation d'origine, dénommé Adresse d'expédition SMTP pour accusé de réception d'échanges au format Reliable. Pour plus d'informations sur la façon de configurer cet identificateur d'organisation, voir Configuration de l'organisation d'origine.

Pour un port d'échanges vers une application, vous pouvez désigner une planification XLANG ou une application de l'organisation d'origine comme destination. Pour plus d'informations sur l'organisation d'origine, voir Description des organisations.

Il est possible de configurer un port d'échanges pour une planification XLANG afin d'activer une nouvelle instance d'une planification XLANG spécifique, puis de transmettre le document vers un port d'échanges spécifique de cette planification. Dans ce cas, la planification spécifiée doit contenir un port d'échanges lié aux Échanges BizTalk. Lorsque vous spécifiez la planification, vous définissez également le port d'échanges. Vous pouvez aussi configurer un port d'échanges pour transmettre un document à une instance en cours d'une planification XLANG. Dans ce cas, le document doit contenir le nom d'une file d'attente vers laquelle transmettre le document, laquelle est contrôlée par la planification cible. Pour plus d'informations sur l'intégration des services d'Échanges BizTalk avec les services d'Orchestration BizTalk, voir Intégration des services BizTalk.

Les propriétés de port d'échanges servent également à désigner une adresse spécifique à laquelle envoyer des documents, le type de transport utilisé pour transmettre les documents vers cet emplacement et la façon dont les documents sont regroupés dans des enveloppes et protégés avant le transport.

À la réception d'un document, BizTalk Server 2000 localise le canal approprié pour le traiter. Une fois que le canal a traité le document, il dirige le serveur vers son port d'échanges ou sa liste de distribution associés, qui dirigent à leur tour le serveur à travers la séquence d'étapes nécessaires à la mise sous enveloppe, la protection et le transport du document vers la destination spécifiée.

Cette section traite des rubriques suivantes :

  • Éléments de port d'échanges

  • Ports d'échanges ouverts


Éléments de port d'échanges

Les ports d'échanges sont constitués des éléments suivants :

Destination

Pour un port d'échanges, la destination peut être l'organisation d'un partenaire commercial, une planification XLANG ou une application d'une organisation d'origine.

Un port d'échanges pour une organisation peut explicitement désigner l'organisation de destination, ou un port d'échanges peut être défini comme port d'échanges ouvert. Pour les ports d'échanges ouverts, l'organisation de destination est déterminée lors du traitement du document par le port d'échanges. Les informations relatives à l'organisation de destination doivent être spécifiées dans le document ou dans les paramètres lors de l'envoi du document. Pour plus d'informations, voir Envoi.

Un port d'échanges pour une planification XLANG peut être configuré de deux façons. Vous pouvez configurer un port d'échanges pour activer une nouvelle instance d'une planification XLANG en spécifiant le chemin d'accès à une planification XLANG. Lorsque le port d'échanges traite un document, il active cette planification puis transmet le document à un port d'échanges dans cette planification, que vous spécifiez également dans les propriétés du port d'échanges. Vous pouvez également configurer le port d'échanges pour transmettre des documents à une planification XLANG. Cette option doit être utilisée uniquement lorsque vous envoyez un message à un partenaire commercial et lorsque celui-ci renvoie un message sur une page ASP en utilisant un transport HTTP. Pour plus d'informations, voir Intégration des services BizTalk. La création d'une planification XLANG s'effectue en utilisant le Concepteur d'Orchestration BizTalk. (pour plus d'informations, voir Conception des orchestrations BizTalk) ;

Un port d'échanges peut également transmettre des documents à une application de destination d'une organisation d'origine. Avant de pouvoir désigner une application comme application de destination pour un port d'échanges, vous devez l'ajouter à une organisation d'origine. Pour plus d'informations, voir Ajout d'applications.

Propriétés de transport

Les propriétés de transport que vous spécifiez pour un port d'échanges déterminent le service de transport utilisé pour transmettre les documents à l'organisation de destination ou à l'application de destination, ainsi que l'adresse à laquelle les documents sont envoyés.

Les propriétés de transport définies pour un port d'échanges s'appliquent à tous les canaux associés à ce port d'échanges. Dès que BizTalk Server 2000 a appelé un canal pour traiter des documents, le serveur récupère les propriétés du port d'échanges associé à ce canal. Le serveur envoie les documents à l'adresse spécifiée dans le port d'échanges en utilisant le type de transport indiqué dans le port d'échanges.

Vous pouvez aussi définir une fenêtre de service, qui permet d'indiquer un intervalle de temps au cours duquel les documents peuvent être envoyés.

Informations d'enveloppe

Les enveloppes sont des en-têtes et parfois des pieds de page utilisés pour ajouter un préfixe ou encapsuler les documents transmis. L'en-tête d'une enveloppe contient des informations relatives aux documents qu'il contient et des informations sur la façon de les transporter. Un en-tête d'enveloppe contient l'identificateur de l'organisation source, l'identificateur de l'organisation de destination ainsi que des informations sur le type de document qu'il contient.

BizTalk Server 2000 peut recevoir et traiter des échanges qui contiennent plusieurs documents et groupes de documents. Lors du transport de documents utilisant une enveloppe, BizTalk Server 2000 inclut chaque document dans un échange distinct.

Les enveloppes sont facultatives ; toutefois, si vous choisissez d'en utiliser, le format d'enveloppe spécifié dans un port d'échanges doit être conforme au format des documents qu'il contient. Le format de document est déterminé par la spécification à laquelle fait référence la définition du document sortant d'un canal associé. Par exemple, si vous choisissez une enveloppe au format X12 pour un port d'échanges, vous devez sélectionner une définition de document sortant pour le canal pointant vers une spécification X12. Inversement, si vous sélectionnez une définition de document sortant dans un canal, le port d'échanges auquel le canal est associé doit avoir une enveloppe avec un format compatible. Par exemple, si vous sélectionnez une définition de document sortant dont la spécification est au format X12, vous devez spécifier une enveloppe au format X12 dans le port d'échanges.

Propriétés de sécurité

Les propriétés de sécurité définies pour un port d'échanges s'appliquent à tous les canaux associés à ce port d'échanges. Par exemple, si vous choisissez le cryptage S/MIME (Secure Multipurpose Internet Mail Extensions) pour un port d'échanges, tous les documents traités par les canaux associés à ce port d'échanges sont cryptés au moyen du mode de cryptage spécifié.

Si vous disposez de documents qui doivent être sécurisés au moyen d'un autre mode de cryptage ou bien qu'il n'est pas nécessaire de crypter, vous devez créer un port d'échanges distinct avec les propriétés de sécurité destinées à ces documents.

BizTalk Server 2000 prend en charge le codage MIME (Multipurpose Internet Mail Extensions).

Le standard MIME pour le format des messages spécifie la façon de formater les messages pour que les programmes clients puissent décoder et afficher le contenu des messages complexes, lesquels peuvent contenir du texte enrichi, différents jeux de caractères et des pièces jointes en mode binaire telles que des images, des sons, des feuilles de calcul, etc. La technologie MIME est plus évoluée et plus souple que la technologie Uuencode et fournit des systèmes souples et génériques pour inclure du contenu dans des messages. Le formatage MIME permet les opérations suivantes :

  • spécifier des modes de codage de contenu différents pour chaque partie du corps du message ;

  • relier des groupes constitués de plusieurs parties de contenus dans un message ;

  • utiliser des jeux de caractères autres que les jeux de caractères ASCII-US dans des corps de messages et dans des champs d'en-têtes ;

  • spécifier la disposition souhaitée pour le contenu (par exemple, inséré ou joint).

BizTalk Server 2000 prend en charge le mode de cryptage S/MIME utilisant les clés publiques et basé sur des certificats.

Le cryptage peut être appliqué aux données d'entreprise que vous transmettez à vos partenaires commerciaux. En utilisant un certificat de cryptage pour sécuriser les données, vous pouvez vous assurer que seul le destinataire attendu accède aux informations.

Pour crypter les données d'entreprise, l'organisation source doit posséder une copie de la clé publique utilisée pour le certificat de cryptage de l'organisation de destination. L'organisation source utilise la clé publique du certificat pour crypter les données d'entreprise puis transmet les données cryptées à l'organisation de destination. L'organisation de destination peut ensuite utiliser la clé privée du certificat de cryptage pour décrypter ces données d'entreprise.

Pour les ports d'échanges ouverts les propriétés de sécurité pour le cryptage sont désactivées car l'organisation de destination n'est pas connue.

BizTalk Server 2000 prend en charge le mode de signature numérique S/MIME utilisant les clés publiques et basé sur des certificats. Pour plus d'informations sur les certificats, voir Présentation des certificats.

Les signatures numériques peuvent être utilisées pour garantir l'authenticité de la source des données, pour garantir que les données n'ont pas été modifiées et pour éviter que la source des données ne rejette le message.

Les certificats de signatures sont utilisés pour créer des signatures numériques qui permettent d'authentifier des données. La signature n'altère pas les données mais elle génère une chaîne pour la signature numérique, qui est envoyée avec les données ou transmise séparément.

Pour signer numériquement un document, les données sont traitées de façon à créer un digest de message. La clé privée de l'organisation source est ensuite utilisée pour crypter le digest de message afin de former la signature numérique. Les données sont transmises avec la signature numérique au destinataire.

Pour pouvoir vérifier une signature numérique, le destinataire doit posséder une copie de la clé publique du certificat de signature de l'émetteur. Le destinataire décrypte cette signature numérique en utilisant la clé publique pour former un digest puis calcule indépendamment un digest de message. Les résultats des deux digests sont comparés ; s'ils sont identiques, cela signifie que les données n'ont pas été falsifiées.

Remarque

  • Pour plus d'informations sur les certificats, voir Description des certificats.

Voir aussi

Création et gestion des ports d'échanges

Ports d'échanges ouverts

Description des ports d'échanges


Ports d'échanges ouverts

Un port d'échanges ouvert est un port d'échanges vers une organisation pour lequel vous n'avez pas déclaré explicitement une organisation de destination spécifique. Un port d'échanges ouvert ne peut pas avoir une application comme destination.

Pour un port d'échanges ouvert, les informations relatives à la destination et au transport doivent être fournies dans le document ou dans les paramètres lorsque le document est transmis à Microsoft BizTalk Server 2000. Lorsque des paramètres d'envoi sont utilisés, ils prévalent sur les informations de destination et de transport que le document contient. Pour plus d'informations sur l'envoi de documents, voir Envoi.

Lorsque vous créez un canal pour un port d'échanges ouvert et que les informations de destination sont fournies dans le document, la définition du document entrant pour ce canal doit référencer une spécification correctement configurée. Pour plus d'informations sur la configuration d'une spécification de document permettant de traiter les documents pour un port d'échanges ouvert, voir Définition des propriétés du dictionnaire.

Pour les ports d'échanges ouverts, les propriétés de sécurité pour le cryptage sont désactivées car l'organisation de destination n'est pas connue. Pour définir les propriétés de cryptage, vous devez indiquer un certificat appartenant à une organisation de destination spécifique et connue. Les certificats de cryptage permettent de crypter des documents transportés vers une organisation de destination précise.

Vous pouvez utiliser un port d'échanges ouvert pour envoyer un ou plusieurs documents standardisés à plusieurs organisations de partenaires commerciaux actuelles ou futures sans avoir à créer un port d'échanges pour chaque destination. Tous les documents partagent les mêmes propriétés d'enveloppe, de sécurité et de transport, qui sont définies dans le port d'échanges.

Un port d'échanges ouvert se distingue d'une liste de distribution pour les raisons suivantes :

  • Lorsqu'un port d'échanges est ouvert, les documents d'un canal sont diffusés un à un et vers une destination unique. L'utilisation d'une liste de distribution permet de diffuser les documents d'un canal vers plusieurs destinations.

  • Lorsqu'un port d'échanges est ouvert, vous n'avez pas besoin de modifier ses propriétés pour transmettre des données à l'organisation d'un autre partenaire commercial. Avec une liste de distribution, vous devez ajouter un port d'échanges pour envoyer des informations à une autre organisation d'un partenaire commercial.

Important

  • Lorsque vous déclarez un port d'échanges comme port d'échanges ouvert, vous ne devez pas créer de canaux pour le port d'échanges dont la définition du document sortant comporte une spécification X12 ou EDIFACT. Pour générer une enveloppe au format X12 ou EDIFACT, le serveur doit posséder un identificateur d'organisation source et de destination. Un port d'échanges ouvert ne spécifie pas l'identificateur de l'organisation de destination. De plus, les documents d'un port d'échanges ouvert doivent contenir l'adresse de destination, mais les documents X12 et EDIFACT n'incluent pas cette information.

Voir aussi

Création et gestion des ports d'échanges

Éléments de port d'échanges

Description des ports d'échanges


Description des organisations

Les organisations que vous créez en utilisant le Gestionnaire d'échanges BizTalk représentent les partenaires commerciaux avec lesquels vous échangez des documents. Le type d'organisation spécial, appelé l'organisation d'origine représente votre entreprise.

Organisation d'origine

Le Gestionnaire d'échanges BizTalk crée automatiquement l'organisation d'origine. Lorsque vous la configurez, vous pouvez la renommer pour la reconnaître plus facilement comme étant votre entreprise. Il existe une seule organisation d'origine et vous ne pouvez pas la supprimer.

Il est impossible de désigner l'organisation d'origine comme étant la source ou la destination des documents dans un port d'échanges ou dans un canal. Seules les applications de l'organisation d'origine peuvent être désignées comme la source ou la destination des documents dans votre entreprise. Par exemple, vous pouvez créer un port d'échanges qui désigne l'organisation d'un partenaire commercial comme la destination des documents que votre entreprise envoie. Ensuite, lorsque vous créez un canal pour ce port d'échanges, au lieu de désigner votre organisation d'origine comme étant la source, vous pouvez désigner une application interne spécifique à votre entreprise, d'où proviennent les documents. Vous pouvez également désigner une application de l'organisation d'origine comme étant la source des documents dans un canal et une autre application comme étant la destination dans un port d'échanges.

Applications de l'organisation d'origine

Les applications que vous ajoutez dans l'organisation d'origine vous permettent d'identifier et de suivre le flux des documents entre Microsoft BizTalk Server 2000 et les applications internes à votre entreprise. Toutefois, le simple fait de créer une application et de la désigner comme source ou destination dans le Gestionnaire d'échanges BizTalk ne permet pas de contrôler ou d'activer le flux des documents en provenance ou à destination d'une application interne. Pour intégrer une application interne à BizTalk Server 2000 et diriger le flux des documents en provenance ou à destination de cette application, vous devez configurer le serveur en conséquence.

Il existe plusieurs façons de transmettre des documents en provenance d'une application vers BizTalk Server 2000. La configuration nécessaire pour intégrer une application afin de transmettre des documents au serveur s'effectue entièrement en dehors du Gestionnaire d'échanges BizTalk. Pour plus d'informations, voir Envoi.

La transmission de documents en provenance de BizTalk Server 2000 vers une application interne peut nécessiter une configuration interne et externe au Gestionnaire d'échanges BizTalk. Le type de transport et l'adresse spécifiés dans un port d'échanges peuvent déterminer un emplacement spécifique auquel les documents sont transmis. Une application ou un composant distinct doit alors être configuré pour extraire les documents reçus à cet emplacement pour l'application de destination. Vous pouvez également, dans les propriétés de transport d'un port d'échanges, spécifier un composant pour l'intégration des applications qui est capable de transmettre directement les documents à une application. Pour plus d'informations, voir Description des ports d'échanges.

Organisations des partenaires commerciaux

Toutes les autres organisations que vous créez avec le Gestionnaire d'échanges BizTalk représentent les partenaires commerciaux externes ou les unités commerciales d'un partenaire. Vous pouvez créer un nombre illimité d'organisations. Vous avez également la possibilité de désigner l'organisation d'un partenaire commercial comme source des documents dans un canal ou comme destination des documents dans un port d'échanges.

Vous pouvez aussi désigner un premier partenaire commercial comme étant la source des documents dans un canal et un second comme étant la destination dans un port d'échanges. Dans ce cas, votre entreprise tient lieu d'intermédiaire entre les deux partenaires commerciaux.

Comme c'est également le cas pour les applications, le simple fait de créer une organisation et de la désigner comme source ou destination dans le Gestionnaire d'échanges BizTalk ne permet pas d'activer le flux des documents en provenance ou à destination de cette organisation. Pour contrôler et diriger le flux des documents entre les organisations de votre partenaire et BizTalk Server 2000, vous devez configurer le serveur en conséquence.

Un partenaire commercial externe désigné en tant qu'organisation source dispose de plusieurs moyens pour transmettre des documents à votre serveur BizTalk Server 2000. La configuration nécessaire est similaire à celle requise pour l'intégration des applications et pour le transfert des documents au serveur. Elle est également effectuée entièrement en dehors du Gestionnaire d'échanges BizTalk. Pour plus d'informations, voir Envoi.

La transmission des documents en provenance de votre serveur BizTalk Server 2000 à un partenaire commercial externe désigné comme étant l'organisation de destination peut nécessiter une configuration interne et externe au Gestionnaire d'échanges BizTalk. Le type de transport et l'adresse spécifiés dans un port d'échanges déterminent un emplacement spécifique auquel les documents sont remis. L'organisation de destination, qui doit avoir accès à cet emplacement, peut alors configurer son serveur BizTalk Server, l'une de ses applications internes ou un composant distinct pour traiter les documents reçus à cet emplacement. Pour plus d'informations sur la configuration des ports d'échanges, voir Description des ports d'échanges.

Cette section traite de la rubrique suivante :

  • Identificateurs d'organisation


Identificateurs d'organisation

Microsoft BizTalk Server 2000 et les partenaires commerciaux utilisent des identificateurs d'organisation pour identifier de façon unique des organisations. Une organisation peut posséder plusieurs identificateurs ; toutefois, chaque identificateur doit être unique à cette organisation. Par exemple, un numéro de téléphone, une adresse URL ou un numéro DUNS peuvent chacun identifier une organisation de façon unique mais deux organisations ne peuvent pas utiliser le même numéro de téléphone comme identificateur d'organisation.

Un identificateur d'organisation se compose de trois éléments distincts : un nom, un qualificateur et une valeur. Ainsi, une entreprise peut utiliser un numéro de téléphone pour s'identifier de façon unique. Dans l'exemple donné ici, le nom de l'identificateur est "numéro de téléphone", le qualificateur qui identifie l'identificateur en tant que numéro de téléphone est le 12 et enfin, la valeur du numéro de téléphone est (01-21-85-94-66). Chaque nom d'identificateur d'organisation possède un qualificateur unique utilisé à la place du nom pour indiquer le type d'identificateur. Par exemple, le qualificateur standard pour un identificateur de numéro de téléphone est le 12. Lorsque BizTalk Server 2000 traite des documents, seuls le qualificateur et la valeur sont utilisés pour identifier les organisations.

Chaque organisation doit posséder au moins un identificateur. Lorsque vous créez une organisation, le Gestionnaire d'échanges BizTalk crée un identificateur avec le nom Organisation. Le qualificateur de cet identificateur est OrganisationNom et sa valeur correspond au nom de l'organisation. Cet identificateur est également défini en tant qu'identificateur par défaut, ce qui signifie qu'il est utilisé lorsque aucun autre identificateur n'est spécifié. Vous pouvez créer des identificateurs supplémentaires et désigner n'importe lequel d'entre eux comme l'identificateur par défaut. Il est impossible de supprimer l'identificateur OrganisationNom ou l'identificateur par défaut. L'identificateur par défaut est utilisé pour identifier une organisation à moins que vous ne sélectionniez un autre identificateur d'organisation dans un port d'échanges ou un canal.

Lorsque BizTalk Server 2000 traite et transporte un document, il inclut les identificateurs d'organisation de l'organisation de destination et de l'organisation source dans l'en-tête d'enveloppe. Lorsque BizTalk Server 2000 reçoit des documents, il recherche les données relatives à l'organisation source et les identificateurs de l'organisation de destination. Le serveur utilise ensuite les identificateurs et le nom de la définition de document pour déterminer les canaux à utiliser afin de traiter les documents.

Les échanges effectués sous un format EDI présentent des restrictions quant à l'utilisation des identificateurs d'organisation. Lorsque vous utilisez un identificateur d'organisation pour des enveloppes au format X12, vous ne devez pas utiliser l'identificateur d'organisation nommé Organisation ni tout autre identificateur dont le qualificateur possède plus de 2 caractères ou dont la valeur est supérieure à 15 caractères. Lorsque vous utilisez un identificateur d'organisation pour des enveloppes au format EDIFACT, vous ne devez pas utiliser l'identificateur d'organisation nommé Organisation ni tout autre identificateur dont le qualificateur possède plus de 4 caractères ou dont la valeur est supérieure à 35 caractères.

Voir aussi

Création et gestion d'organisations

Description des organisations


Description des définitions de document

Une définition de document est un type spécifique de document traité par Microsoft BizTalk Server 2000. Une définition de document représente le type de document entrant ou sortant dans un canal et fournit un pointeur vers une spécification de document. La spécification de document définit la structure, le type et la version du document. Une même spécification peut être utilisée dans un nombre illimité de définitions de document et une même définition de document peut être utilisée dans un nombre illimité de canaux.

Si le format et la structure du document entrant et du document sortant dans un canal sont identiques, vous pouvez utiliser la même spécification pour les deux. Dans le cas contraire, vous devez spécifier un mappage que le serveur utilise pour convertir le format ou la structure du document entrant dans celui ou celle du document sortant.

Lorsque BizTalk Server 2000 reçoit un document, il identifie le canal approprié ou les canaux qui possèdent les définitions de document entrant correspondantes. La définition de document entrant pour chaque canal pointe vers une spécification. Le serveur utilise cette spécification pour convertir un document non-XML entrant, de son format d'origine dans un format XML intermédiaire, ainsi que pour valider la structure du document. La définition de document sortant pour le canal pointe vers une spécification. Le serveur utilise la spécification de document sortant pour valider la structure des données du document sortant. Si nécessaire, le serveur peut aussi utiliser la spécification pour convertir le document sortant au format XML dans un format que l'organisation de destination ou que l'application de destination peut reconnaître et utiliser. La destination est désignée dans le port d'échanges avec lequel le canal est associé.

La spécification de document pour une définition de document est facultative ; toutefois, dans la plupart des cas, vous devez en sélectionner une. Si vous ne sélectionnez aucune spécification, vous pourrez constater les points suivants :

  • Les données que vous traitez ne seront pas converties au format XML du côté entrant, ni converties à partir du format XML du côté sortant.

  • Les données ne seront pas validées par rapport à une spécification afin de garantir qu'elles ne contiennent pas d'erreurs.

  • Vous ne pourrez pas transformer la structure ni le format des données en utilisant un mappage dans un canal.

  • Vous ne pourrez pas spécifier des champs de suivi global ni des critères de sélection.

Une spécification de document n'est pas requise si vous souhaitez utiliser la définition de document pour une soumission directe de données d'un autre format que XML Unicode. C'est le cas, par exemple, si vous voulez envoyer des données binaires via BizTalk Server 2000 vers une destination sans transformer ces données. Dans cet exemple, vous ne devez pas sélectionner de spécification de document pour la définition de document entrant ou sortant du canal qui est utilisé pour la soumission directe.

Cette section traite des rubriques suivantes :

  • Suivi des champs de données d'un document

  • Description des critères de sélection

Voir aussi

Création et gestion de définitions de document

Création de spécifications

Spécification de mappage

Description des canaux


Suivi des champs de données d'un document

Dans une définition de document, vous pouvez désigner des champs contenus dans une spécification pour qu'ils soient consignés dans une base de données de suivi. Les champs que vous désignez dans une définition de document sont suivis pour l'ensemble des instances de documents traitées par les canaux qui utilisent la définition de document comme définition de document entrant. Ces champs étant suivis pour tous les canaux, ils sont désignés comme étant des champs de suivi global.

Lorsque vous sélectionnez une définition de document entrant pour un canal, vous pouvez désigner des champs de spécification dans le canal à suivre. Les champs de spécification que vous indiquez dans un canal sont suivis à la place des champs de suivi global désignés pour les documents traités par ce canal.

Les champs désignés dans une définition de document ou un canal sont consignés dans une base de données de suivi uniquement pour la définition de document entrant du canal. Les champs désignés pour le suivi dans une définition de document sortant du canal ne sont pas suivis.

Le suivi des données des documents traités permet d'analyser les informations associées à vos opérations. Par exemple, le champ d'une facture contenant le montant total peut être suivi pour chaque facture envoyée à vos partenaires commerciaux. Vous pouvez ensuite déterminer le montant total, en francs, des factures envoyées à tous vos partenaires commerciaux pour une période définie ou le montant total en francs pour chacun d'entre eux.

Voir aussi

Création et gestion de définitions de document

Utilisation du suivi de documents BizTalk


Description des critères de sélection

Les critères de sélection correspondent à des ensembles de paires nom-valeur que Microsoft BizTalk Server 2000 utilise pour traiter des documents EDI. Pour les documents entrants au format X12 ou les documents EDIFACT, le serveur utilise des critères de sélection pour sélectionner et identifier de façon unique une définition de document car aucun nom de définition de document n'est disponible dans les documents EDI.

Pour les documents au format X12 ou EDIFACT, les critères de sélection permettent de créer les informations d'en-tête de groupe fonctionnel dans l'enveloppe.

Cette section traite des rubriques suivantes :

  • Utilisation de critères de sélection avec des documents entrants

  • Utilisation de critères de sélection avec des documents sortants


Utilisation de critères de sélection avec des documents entrants

Pour traiter des documents entrants, BizTalk Server 2000 doit disposer du nom d'une définition de document entrant. En règle générale, le serveur récupère le nom de la définition de document entrant, soit dans un champ du document entrant, soit à partir d'un paramètre transmis avec le document. Pour plus d'informations, voir Envoi.

Pour les échanges entrants X12 et EDIFACT, les documents peuvent être contenus dans un groupe fonctionnel ou dans des en-têtes d'échanges. BizTalk Server 2000 traite les documents contenus dans ces groupes et ces échanges un par un. Le serveur ne peut obtenir le nom de la définition de document à partir de chaque document car, pour chacun d'entre eux, les informations relatives au document sont contenues dans le groupe fonctionnel ou l'en-tête d'échange. De plus, comme un échange peut contenir plusieurs groupes de types de documents différents, il est impossible de fournir un nom unique de définition de document comme paramètre d'envoi, qui permettrait au serveur d'identifier une définition de document.

Dans ce cas de figure, BizTalk Server 2000 est capable d'extraire les données relatives au document à partir de l'en-tête de groupe fonctionnel (l'en-tête GS d'un échange X12 et l'en-tête UNG d'un échange EDIFACT) ou à partir de l'en-tête d'échange dans un échange EDIFACT sans groupe fonctionnel. En faisant correspondre les valeurs de ces données aux valeurs des critères de sélection spécifiés dans une définition de document, le serveur peut identifier de façon unique la définition de document appropriée.

Afin que BizTalk Server 2000 parvienne à faire correspondre les valeurs des critères de sélection avec les éléments d'en-tête correspondants d'un échange entrant, vous devez saisir les noms des critères de sélection tels qu'ils sont indiqués dans les tableaux ci-après.

Éléments d'en-tête X12

Nom | Configuration requise | Élément GS
identificateur_fonctionnel | Obligatoire | GS01
code_expéditeur_application | Obligatoire | GS02
code_destinataire_application | Obligatoire | GS03
version_standards | Obligatoire | GS08

Éléments d'en-tête EDIFACT

Nom | Configuration requise | Élément UNH | Élément UNG
identificateur_fonctionnel | Obligatoire | S009, 0065 | 0038
code_expéditeur_application | Facultatif | Non utilisé | S006, 0040
code_destinataire_application | Facultatif | Non utilisé | S007, 0044
type_version_standards | Obligatoire | S009, 0052 | S008, 0052
valeur_version_standards | Obligatoire | S009, 0054 | S008, 0054

Voir aussi

Création et gestion de définitions de document

Description des critères de sélection

Utilisation de critères de sélection avec des documents sortants


Utilisation de critères de sélection avec des documents sortants

Pour traiter un document sortant au format X12 ou EDIFACT, BizTalk Server 2000 place chaque document dans une enveloppe valide au format approprié. Pour créer l'enveloppe, le serveur insère les données relatives aux valeurs des critères de sélection dans les champs correspondants du groupe et des en-têtes de message. Pour créer des en-têtes, le serveur utilise les valeurs des critères de sélection contenues dans la définition de document sortant pour le canal.

Supposons, par exemple, que vous créez une définition de document dont le critère de sélection est la paire nom-valeur de l'identificateur_fonctionnel/COMMANDES. Si vous l'utilisez ensuite comme définition de document sortant dans un canal, la valeur du champ d'en-tête de groupe qui correspond au critère de sélection nommé identificateur_fonctionnel est définie à COMMANDES dans l'en-tête d'enveloppe.

Afin que BizTalk Server 2000 insère les valeurs des critères de sélection dans les éléments d'en-tête correspondants, vous devez saisir les noms des critères de sélection tels qu'ils sont indiqués dans les tableaux ci-après.

Éléments d'en-tête X12

Nom | Configuration requise | Élément GS
identificateur_fonctionnel | Obligatoire | GS01
code_expéditeur_application | Obligatoire | GS02
code_destinataire_application | Obligatoire | GS03
version_standards | Obligatoire | GS08

Éléments d'en-tête EDIFACT

Nom | Configuration requise | Élément UNH | Élément UNG
identificateur_fonctionnel | Obligatoire | S009, 0065 | 0038
code_expéditeur_application | Facultatif | Non utilisé | S006, 0040
code_destinataire_application | Facultatif | Non utilisé | S007, 0044
type_version_standards | Obligatoire | S009, 0052 | S008, 0052
valeur_version_standards | Obligatoire | S009, 0054 | S008, 0054

Voir aussi

Création et gestion de définitions de document

Description des critères de sélection

Utilisation de critères de sélection avec des documents entrants


Description des enveloppes

Une enveloppe encapsule des données d'entreprise électroniques en vue de leur transport. Une enveloppe contient des informations d'en-têtes et de pieds de page ou des informations d'en-tête uniquement. Les propriétés d'enveloppe que vous spécifiez fournissent à Microsoft BizTalk Server 2000 les informations nécessaires au serveur pour ouvrir des échanges entrants ou pour créer des échanges sortants. Lorsque vous créez une enveloppe, vous spécifiez un format d'enveloppe ; pour certains types de formats, vous pouvez également sélectionner une spécification d'enveloppe.

Les formats d'enveloppe pris en charge par BizTalk Server 2000 sont les suivants : Custom XML, ANSI X12, UN/EDIFACT, Flat-file (délimité et positionnel), Custom et Reliable. Le format Reliable permet de traiter les enveloppes dont le format est compatible avec BizTalk Framework 2.0. Pour plus d'informations sur BizTalk Framework 2.0, accédez au site Web de Microsoft BizTalk à l'adresse suivante : (www.microsoft.com/biztalk/). Si vous spécifiez le format d'enveloppe Custom, vous devez créer et enregistrer un composant parseur pour traiter les enveloppes entrantes ou un composant sérialiseur pour traiter les enveloppes sortantes. Pour plus d'informations, voir Using the IBizTalkParserComponent Interface et Using the IbizTalkSerializerComponent Interface.

Pour permettre à BizTalk Server 2000 de traiter les échanges entrants au format Custom XML ou Flat-file, vous devez créer des enveloppes avec un format correspondant. Pour permettre à BizTalk Server 2000 de traiter les échanges entrants au format Custom, vous devez créer et enregistrer un composant parseur au format Custom. BizTalk Server 2000 peut traiter les échanges entrants aux formats ANSI X12, UN/EDIFACT ou Reliable sans avoir à utiliser d'enveloppes créées avec le Gestionnaire d'échanges BizTalk.

Si vous souhaitez traiter des documents sortants dans n'importe quel format, vous devez créer une enveloppe et la sélectionner dans un port d'échanges afin de créer un échange avec le format d'enveloppe et les informations d'en-tête requis. BizTalk Server 2000 place un seul document dans chaque échange sortant.

Lorsque vous sélectionnez une enveloppe au format X12 ou EDIFACT dans un port d'échanges, vous devez également spécifier des séparateurs et un numéro de contrôle d'échanges. Ces propriétés EDI s'appliquent uniquement aux enveloppes sélectionnées pour ce port d'échanges. Lorsque vous sélectionnez une enveloppe au format Custom, les séparateurs et le numéro de contrôle d'échanges sont facultatifs et dépendent des composants parseur ou sérialiseur Custom. Lorsque vous créez un canal pour un port d'échanges qui utilise une enveloppe au format X12, EDIFACT ou Custom, vous pouvez spécifier un numéro de contrôle de groupe fonctionnel qui s'applique uniquement aux documents traités par ce canal et cette combinaison de ports d'échanges.

Le format d'enveloppe que vous sélectionnez dans un port d'échanges doit correspondre au format du document sortant qu'il contient. Le format du document sortant est déterminé par la spécification référencée dans la définition du document sortant du canal. Par exemple, si vous choisissez une enveloppe au format X12 pour un port d'échanges, lorsque vous créez un canal pour ce port d'échanges, vous devez sélectionner une définition de document sortant qui pointe vers une spécification qui soit également au format X12.

Si vous ne spécifiez pas d'enveloppe lors de la création d'un port d'échanges, les données sont envoyées au format XML sans en-tête.

Remarque

  • Lors du traitement des enveloppes compatibles avec BizTalk Framework 2.0, BizTalk Server 2000 doit être considéré comme le point final par rapport au délai d'expiration. Lorsque les documents compatibles avec BizTalk Framework 2.0 sont envoyés à BizTalk Server 2000, soit depuis une application, soit depuis un partenaire commercial, les champs suivants sont remplacés s'ils existent ou créés dans le cas contraire :
    • Dans la sous-section des propriétés :

      <prop:identity>

      <prop:sentAt>

      <expiresAt>

    • Dans la sous-section des informations de réception :

      <sendTo>

      <address>

      <sendReceiptBy>

Cette section traite des rubriques suivantes :

  • Utilisation d'enveloppes pour le traitement entrant

  • Utilisation d'enveloppes pour le traitement sortant

Voir aussi

Création et gestion d'enveloppes

Description des ports d'échanges


Utilisation d'enveloppes pour le traitement entrant

Microsoft BizTalk Server 2000 peut traiter un échange entrant au format X12 ou EDIFACT sans avoir à utiliser d'enveloppes créées avec le Gestionnaire d'échanges BizTalk.

Pour permettre à BizTalk Server 2000 de traiter un échange entrant au format Flat-file, vous devez créer une enveloppe en utilisant le Gestionnaire d'échanges BizTalk. Cette enveloppe doit pointer vers une spécification que le serveur est capable d'utiliser pour interpréter et ouvrir l'échange. Le nom de l'enveloppe doit être fourni au serveur lorsque l'échange est transmis pour traitement. Pour plus d'informations, voir Envoi.

Pour permettre à BizTalk Server 2000 de traiter un échange entrant au format Custom XML, vous devez créer une enveloppe en utilisant le Gestionnaire d'échanges BizTalk. Cependant, le serveur est capable de localiser l'enveloppe au format Custom XML qui lui est nécessaire pour interpréter et ouvrir l'échange sans posséder le nom de l'enveloppe fournie pour l'envoi. Vous pouvez fournir le nom de l'enveloppe au serveur lors de l'envoi, mais cela n'est pas obligatoire. Pour plus d'informations, voir Envoi.

Pour permettre à BizTalk Server 2000 de traiter un échange entrant au format Custom, vous devez créer un parseur au format Custom pour ouvrir l'échange. Pour plus d'informations, voir Using the IbizTalkParserComponent Interface.

Il n'est pas nécessaire de sélectionner, dans un port d'échanges, les enveloppes que vous créez afin de traiter les échanges entrants pour que le serveur puisse les utiliser. Seules les enveloppes utilisées pour le traitement des échanges sortants doivent être sélectionnées dans un port d'échanges.

Voir aussi

Création et gestion d'enveloppes

Description des enveloppes

Utilisation d'enveloppes pour le traitement sortant


Utilisation d'enveloppes pour le traitement sortant

Les ports d'échanges régulent le flux des données sortant et transmis vers une destination spécifique. Lorsque vous créez un port d'échanges, vous pouvez sélectionner une enveloppe pour les documents qui sont traités par le port d'échanges. Si vous sélectionnez une enveloppe, le format d'enveloppe doit correspondre au format des documents que l'enveloppe contient. Le format des documents est déterminé par la spécification référencée dans la définition du document sortant du canal. Une fois l'enveloppe créée avec le Gestionnaire d'échanges BizTalk, vous pouvez l'utiliser dans un nombre illimité de ports d'échanges.

Lorsque BizTalk Server 2000 traite un document sortant, le serveur utilise les propriétés de l'enveloppe sélectionnée dans le port d'échanges pour créer un échange en encapsulant le document ou en y ajoutant un préfixe. Si vous ne spécifiez pas d'enveloppe pour un port d'échanges, les données sont envoyées au format XML sans en-tête ni pied de page. Si vous spécifiez le format Custom XML et que vous ne sélectionnez pas de spécification d'enveloppe, les données sont envoyées au format Reliable. Le format Reliable permet de traiter les enveloppes dont le format est compatible avec BizTalk Framework 2.0. Pour plus d'informations sur BizTalk Framework 2.0, accédez au site Web de Microsoft BizTalk à l'adresse suivante : (www.microsoft.com/biztalk/).

Pour permettre à BizTalk Server 2000 de traiter un échange sortant au format Custom, vous devez créer un sérialiseur afin de créer l'échange. Pour plus d'informations, voir Using the IbizTalkSerializerComponent Interface.

Lorsque vous sélectionnez une enveloppe au format X12 ou EDIFACT, vous devez spécifier un numéro de contrôle d'échanges ainsi que des séparateurs. Un numéro de contrôle d'échanges s'utilise pour identifier et suivre des documents traités au moyen d'un port d'échanges. Le numéro de contrôle d'échanges est incrémenté à chaque utilisation de l'enveloppe et du port d'échanges. Des séparateurs indiquent les caractères utilisés pour séparer les enregistrements et les champs de l'enveloppe et des documents contenus dans cette enveloppe. Les numéros de contrôle d'échanges et les séparateurs sont facultatifs pour les enveloppes au format Custom.

Important

  • Le format d'enveloppe pour un port d'échanges doit correspondre au format du type de document de la spécification référencée par la définition de document sortant pour les canaux associés. Par exemple, si vous choisissez une enveloppe au format X12 pour un port d'échanges, vous devez sélectionner une définition de document sortant pour le canal pointant vers une spécification X12.

Voir aussi

Création et gestion d'enveloppes

Description des enveloppes

Utilisation d'enveloppes pour le traitement entrant


Description des accusés de réception

Lors de l'échange de documents avec un partenaire commercial, il se peut que les processus définis pour votre entreprise exigent la réception d'accusés de réception pour les documents que vous envoyez, ou la génération d'accusés de réception pour les documents que les partenaires commerciaux transmettent à votre entreprise.

Les services d'Échanges BizTalk fournissent deux méthodes pour traiter les accusés de réception dans le cadre des échanges. Pour les échanges qui utilisent le parseur X12 ou EDIFACT, ou un parseur Custom qui requiert des accusés de réception, vous pouvez configurer le Gestionnaire d'échanges BizTalk de sorte qu'il utilise les propriétés de canal permettant de traiter les accusés de réception. Pour les échanges qui utilisent le parseur XML, vous pouvez utiliser des échanges au format Reliable, ce qui permet de traiter automatiquement les accusés de réception et de garantir une transmission fiable des données.

Cette section traite des rubriques suivantes :

  • Traitement des accusés de réception en utilisant des canaux

  • Traitement des accusés de réception en utilisant des échanges au format Reliable


Traitement des accusés de réception en utilisant des canaux

Cette section explique comment configurer les services d'Échanges BizTalk pour l'utilisation des propriétés de canal afin de contrôler le traitement des accusés de réception. Le système de destination est configuré pour générer (envoyer) des accusés de réception au système source. Le système source est configuré pour attendre (recevoir) des accusés de réception émis par le système de destination et pour les faire correspondre aux échanges d'origine. Cette configuration ne s'applique que si vous traitez des échanges utilisant le parseur X12 ou EDIFACT ou un parseur Custom qui nécessite des accusés de réception. Pour plus d'informations sur la création de parseurs Custom, voir Using the IbizTalkParserComponent Interface. Si vous traitez des échanges qui utilisent le parseur XML, voir Traitement des accusés de réception en utilisant des échanges au format Reliable.

Si vous utilisez un parseur Custom et que vous souhaitiez faire correspondre les accusés de réception aux échanges d'origine, vous devez créer un composant de corrélation au format Custom.

Afin que le système source puisse recevoir des accusés de réception, le système de destination doit également être configuré pour l'envoi des accusés de réception. La configuration d'un canal sur le système source pour l'attente des accusés de réception ne suffit pas pour les recevoir.

L'illustration suivante représente la configuration nécessaire, pour les systèmes source et de destination, effectuée en utilisant des propriétés de canal pour le traitement des accusés de réception.

Traitement des accusés de réception à l'aide de canaux
Générer et envoyer un accusé de réception
Recevoir et faire correspondre l'acc. de réception
Recevoir et traiter les échanges
Système de destination
Système source
Port d'échanges vers le
système de destination
OA
Parseur
Port d'éch.
vers syst.
source
Déf. de doc.
sortant
Accusé de réception
Spécification
de document
Spécification
de document
Déf. de doc.
entrant
Mappage
Canal d'accusés de réception
Acc. de réception standard
Port d'échanges
vers l'application
Canal du
système source
Spécification
de document
Déf. de l'accusé
de réception du doc.
Canal pour OA
Générer et envoyer l'échange

Cette section traite des rubriques suivantes :

  • Configuration du système source pour les accusés de réception des canaux

  • Configuration du système de destination pour les accusés de réception des canaux


Configuration du système source pour les accusés de réception des canaux

Cette rubrique explique comment configurer les services d'Échanges BizTalk pour envoyer un échange à un partenaire commercial et pour traiter un accusé de réception en utilisant les propriétés d'un canal.

Vous devez créer un canal et un port d'échanges pour traiter et transmettre un échange au système de destination. Il n'est pas nécessaire de créer un canal et un port d'échanges pour traiter l'accusé de réception que le système de destination renvoie. Cependant, vous devez créer une définition de document, que le serveur utilise pour valider l'accusé de réception lorsque celui-ci est renvoyé.

Pour configurer les services d'Échanges BizTalk afin qu'ils envoient un échange à un système de destination et qu'ils traitent les accusés de réception en utilisant les propriétés de canal, effectuez les opérations présentées au tableau suivant. Des références sont fournies pour chaque procédure et des remarques commentent les configurations particulières. Les autres paramètres de propriété nécessaires à la configuration varient selon les entreprises et ne sont donc pas mentionnés ici.

Étape Références et remarques
Utilisation de l'Éditeur BizTalk
  • Créez les spécifications pour les définitions de document entrants et sortants relatives au document d'origine et destinées à l'échange. Vous devez aussi créer une spécification pour la définition de document que le serveur utilise pour valider l'accusé de réception à sa réception.
  • Création et validation de spécifications

    Remarques

    • Pour la définition de document sortant pour le canal, vous devez créer une spécification qui utilise le format requis par le système de destination. Par exemple, le format X12.

    Lorsque les services d'Échanges BizTalk traitent l'échange sur le système de destination et que le parseur demande des accusés de réception, le parseur procède de la façon suivante :

  • Il extrait les éléments d'en-tête de l'échange.

  • Il génère un accusé de réception standard.

  • Il insère les éléments dans l'accusé de réception standard.

    Pour le système source, la spécification de la définition du document sortant du canal, utilisé pour traiter l'échange, doit contenir ces champs. La spécification pour la définition de document nécessaire à la validation de l'accusé de réception doit contenir ces champs. Le système source utilise ces éléments pour faire correspondre l'accusé de réception à l'échange d'origine.

    Les éléments d'en-tête X12 sont les suivants :

    • identificateur_fonctionnel

    • version_standards

    Les éléments d'en-tête EDIFACT sont les suivants :

    • identificateur_fonctionnel

    • type_version_standards

    • valeur_version_standards
Utilisation du Gestionnaire d'échanges BizTalk :
  • Créez les définitions de documents entrants et sortants pour la création du canal et une définition de document pour l'accusé de réception.
  • Création de définitions de documents

    Remarques

    • Dans les définitions de document, vous devez sélectionner les spécifications que vous avez créées précédemment. Pour plus d'informations, voir Sélection d'une spécification de document.

    • Vous devez également créer une définition de document pour l'accusé de réception.
  • Créez un port d'échanges pour la transmission de l'accusé de réception au système source.
  • Création de ports d'échanges

    Remarque

    • Vous devez créer le port d'échanges et son canal d'accusé de réception pour traiter tout d'abord l'accusé de réception. Lorsque vous créez le canal pour le traitement de l'échange d'origine, vous devez spécifier le canal d'accusé de réception.
  • Créez un port d'échanges pour la transmission de l'échange au système de destination.
  • Création de ports d'échanges
  • Créez un canal pour le traitement de l'échange d'origine provenant de votre partenaire commercial.
  • Création de canaux

    Remarques

    • À la page Application source ou Organisation source de l'Assistant Canal, activez la case à cocher Attendre un accusé de réception.

    • Dans la zone Intervalle des accusés de réception en minutes du champ Attendre un accusé de réception, renseignez le temps que vous souhaitez attendre pour recevoir un accusé de réception et qui doit s'écouler avant le renvoi de l'échange d'origine. Pour plus d'informations, voir Définition des propriétés d'une application source ou Définition des propriétés d'une organisation source.
Utilisation du composant Suivi de documents BizTalk
  • L'échange d'origine est consigné dans la base de données de suivi et le champ d'état de l'accusé de réception contient la valeur "Attendre". L'état de l'accusé de réception, dans la base de données de suivi, sera modifié par la suite pour refléter l'état de l'accusé traité.
  • Description des résultats d'enregistrement d'instance de document

  • Description des résultats d'accusé de réception

Envoi d'accusés de réception au système source

Les accusés de réception sont envoyés aux services d'Échanges BizTalk de la même façon que les autres types de documents. Une fois qu'un accusé de réception est envoyé, les parseurs X12 et EDIFACT peuvent le distinguer des autres documents et orienter le serveur pour qu'il établisse la correspondance entre l'accusé de réception et l'échange d'origine.

Important

  • Les accusés de réception doivent être envoyés aux services d'Échanges BizTalk sans utiliser de paramètres d'envoi.


Configuration du système de destination pour les accusés de réception des canaux

Cette rubrique explique comment configurer les services d'Échanges BizTalk pour traiter un échange issu d'un partenaire commercial ainsi que pour générer un accusé de réception en utilisant les propriétés d'un canal. Pour cela, vous devez créer un canal et un port d'échanges afin de traiter l'échange sortant et le transmettre au système de destination. Il n'est pas nécessaire de créer un canal ou un port d'échanges pour traiter l'accusé de réception que le système de destination renvoie. Un parseur traite l'accusé de réception en utilisant une seule définition de document.

Pour configurer les services d'Échanges BizTalk afin qu'ils traitent un échange issu d'un système source et qu'ils envoient un accusé de réception en utilisant les propriétés de canal, effectuez les opérations présentées au tableau suivant. Des références sont fournies pour chaque procédure et des remarques commentent les configurations particulières. Les autres paramètres de propriété nécessaires à la configuration varient selon les entreprises et ne sont donc pas mentionnés ici.

Étape Références et remarques
Utilisation de l'Éditeur BizTalk
  • Créez les spécifications pour les définitions de documents entrants et sortants utilisées pour créer le canal d'accusé de réception.
  • Création et validation de spécifications

    Remarques

    • Pour la définition de document entrant du canal d'accusé de réception, vous devez utiliser la spécification d'accusé de réception standard. Cette spécification se trouve dans le référentiel WebDAV.

    • Pour la définition de document sortant du canal d'accusé de réception, vous devez créer une spécification qui utilise le format requis par les processus de votre entreprise.

    Lorsque les services d'Échanges BizTalk, sur le système de destination, traitent un échange entrant et que le parseur demande des accusés de réception, le parseur procède de la façon suivante :

    • Il extrait les éléments d'en-tête de groupe.

    • Il génère un accusé de réception standard.

    • Il insère les éléments d'en-tête dans l'accusé de réception standard.

    La spécification destinée à la définition de document sortant pour le canal d'accusé de réception doit contenir des champs pour ces éléments d'en-tête. Le système source utilise ces éléments d'en-tête pour faire correspondre l'accusé de réception à l'échange d'origine.

    Les éléments d'en-tête X12 sont les suivants :

    • identificateur_fonctionnel

    • version_standards

    Les éléments d'en-tête EDIFACT sont les suivants :

    • identificateur_fonctionnel

    • type_version_standards

    • valeur_version_standards
  • Créez les spécifications pour les définitions de documents entrants et sortants qui sont utilisées pour la création du canal permettant le traitement de l'échange d'origine à partir du système source.
  • Création et validation de spécifications
Utilisation du Mappeur BizTalk :
  • Créez un mappage pour le canal d'accusé de réception.
  • Création de nouveaux mappages

    Remarques

    • Lorsque vous créez le canal d'accusé de réception, vous devez spécifier un mappage. Le mappage est utilisé pour convertir l'accusé de réception standard dans le type de document approprié au document sortant.

    • Vous pouvez utiliser l'un des mappages proposés dans BizTalk Server 2000 s'il correspond au type de document requis par vos processus d'entreprise. Vous pouvez extraire ces mappages du référentiel WebDAV.

      –Ou–

    • Vous pouvez créer votre propre mappage en utilisant la spécification d'accusé de réception standard et une spécification qui correspond au type de document requis par vos processus d'entreprise.
Utilisation du Gestionnaire d'échanges BizTalk :
  • Créez les définitions de document pour le canal d'accusé de réception et pour le canal que vous utilisez pour traiter l'échange d'origine.
  • Création de définitions de documents

    Remarques

    • Dans les définitions de document, vous devez sélectionner les spécifications que vous avez créées précédemment. Pour plus d'informations, voir Sélection d'une spécification de document.

    • Vous devez également créer les définitions de document pour le canal utilisé pour le traitement de l'échange d'origine. La configuration varie en fonction des processus de votre entreprise.
  • Créez un port d'échanges pour la transmission de l'accusé de réception au système source.
  • Création de ports d'échanges

    Remarque

    • Vous devez créer un port d'échanges et son canal d'accusé de réception pour le traitement de l'accusé de réception avant de créer ceux utilisés pour l'échange d'origine. Lorsque vous créez le canal pour le traitement de l'échange d'origine, vous devez spécifier le canal d'accusé de réception.
  • Créez un canal d'accusé de réception à partir d'une application pour traiter l'accusé de réception.
  • Création de canaux

    Remarques

    • À la page Informations générales de l'Assistant Canal, activez la case à cocher Canal d'accusés de réception.

    • À la page Application source de l'Assistant Canal, sélectionnez une application dans la liste Nom.

      Vous pouvez créer une application pour l'organisation d'origine que vous utilisez pour désigner les accusés de réception générés par les parseurs.

    • À la page Document entrant de l'Assistant Canal, cliquez sur Parcourir et recherchez la définition de document que vous venez de créer et qui utilise la spécification d'accusé de réception standard.

    • À la page Document sortant de l'Assistant Canal, cliquez sur Parcourir et recherchez la définition de document que vous venez de créer et qui utilise la spécification avec le type de document requis par les processus de votre entreprise.
  • Créez un port d'échanges pour la transmission des documents contenus dans l'échange d'origine vers leur destination.
 Création de ports d'échanges

Remarque

  • Ce port d'échanges ne requiert pas de configuration particulière pour le traitement des accusés de réception.

  • Créez un canal pour le traitement de l'échange d'origine provenant de votre partenaire commercial.
  • Création de canaux

    Remarques

    • À la page Organisation source de l'Assistant Canal, activez la case à cocher Générer un accusé de réception.

    • Dans la zone Générer un accusé de réception, cliquez sur Parcourir et sélectionnez le canal d'accusé de réception que vous avez créé pour traiter l'accusé de réception. Pour plus d'informations, voir Définition des propriétés d'une organisation source.

    • À la page Configuration avancée de l'Assistant Canal, dans la zone Options de nouvel essai, vous pouvez définir un nombre d'essais et un intervalle. Pour plus d'informations, voir Définition des propriétés de configuration avancées.
Utilisation du composant Suivi de documents BizTalk
  • L'échange d'origine et l'accusé de réception sont consignés dans la base de données de suivi.
  • Description des résultats d'enregistrement d'instance de document

  • Description des résultats d'accusé de réception


Traitement des accusés de réception en utilisant des échanges au format Reliable

Cette section explique comment configurer les services d'Échanges BizTalk pour envoyer et recevoir des accusés de réception en utilisant les enveloppes d'échanges au format Reliable, ce qui permet de créer des échanges compatibles avec BizTalk Framework 2.0. Les échanges au format Reliable permettent de traiter les accusés de réception automatiquement, garantissant ainsi un transfert fiable des données. Pour plus d'informations sur BizTalk Framework 2.0, rendez-vous sur le site Web de Microsoft BizTalk à l'adresse suivante : (www.microsoft.com/biztalk/). Si vous envoyez et recevez des échanges qui utilisent un parseur X12, EDIFACT ou Custom, voir Traitement des accusés de réception en utilisant des canaux.

En utilisant le Gestionnaire d'échanges BizTalk, vous pouvez configurer un port d'échanges pour utiliser un format d'enveloppe Reliable pour un échange sortant. Les enveloppes qui utilisent le format d'échanges Reliable doivent toujours inclure une adresse URL de réponse dans l'en-tête. Cette adresse de réponse est utilisée par le système de destination pour envoyer un accusé de réception au système d'envoi des échanges.

Cette section traite des rubriques suivantes :

  • Configuration du système source pour les accusés de réception des échanges au format Reliable

  • Configuration du système de destination pour les accusés de réception des échanges au format Reliable


Configuration du système source pour les accusés de réception des échanges au format Reliable

Pour configurer les services d'Échanges BizTalk afin qu'ils envoient un échange à un système de destination et qu'ils traitent les accusés de réception en utilisant un échange au format Reliable, effectuez les opérations présentées au tableau suivant. Des références sont fournies pour chaque procédure et des remarques commentent les configurations particulières. Les autres paramètres de propriété nécessaires à la configuration varient selon les entreprises et ne sont donc pas mentionnés ici.

Étape Références et remarques
Utilisation de BizTalk Administration :
  • Configurez les propriétés de l'adresse de réponse pour les échanges au format Reliable.
  • Configuration des propriétés générales d'un groupe de serveurs.

    Remarques

    • Dans Administration de BizTalk Server, développez Microsoft BizTalk Server 2000, puis cliquez sur le groupe de serveurs à configurer.

    • Dans le menu Action, cliquez sur Propriétés.

    • Dans la zone URL de réponse d'échange de type Reliable de la boîte de dialogue Propriétés du groupe de serveurs BizTalk Server, tapez l'URL que ce groupe de serveurs utilise pour recevoir l'accusé de réception pour les échanges au format Reliable.

      Lorsque vous créez un échange sortant qui utilise une enveloppe au format Reliable, le serveur insère automatiquement l'URL de réponse d'échange de type Reliable dans l'en-tête de l'échange sortant. Le serveur place également l'échange d'origine dans la file de nouvel essai. Le serveur utilise les options de nouvel essai spécifiées dans le canal pour déterminer combien de fois il doit renvoyer l'échange d'origine avant de recevoir un accusé de réception.
Utilisation du Gestionnaire d'échanges BizTalk :
  • Créez une enveloppe qui utilise le format Reliable.
  • Création d'enveloppes

    Remarques

    • Dans la liste Format d'enveloppe de la boîte de dialogue Nouvelle enveloppe, cliquez sur RELIABLE.

    • Si vous choisissez le format Custom XML et que vous ne sélectionniez pas de spécification, le format d'enveloppe correspondra par défaut au format Reliable.
  • Créez un port d'échanges pour la transmission de l'échange d'origine au système de destination.
  • Création de ports d'échanges

    Remarque

  • À la page Informations d'enveloppe de l'Assistant Nouveau port d'échanges, sélectionnez l'enveloppe que vous venez de créer dans la zone Informations d'enveloppe. Pour plus d'informations, voir Définition des propriétés des informations d'enveloppe.
  • Créez un canal pour traiter l'échange d'origine.
  • Création de canaux

    Remarques

    • À la page Application source ou Organisation source de l'Assistant Canal, ne définissez aucune propriété d'accusé de réception.

    • À la page Configuration avancée de l'Assistant Canal, dans la zone Options de nouvel essai, vous pouvez définir un nombre d'essais et un intervalle. Pour plus d'informations, voir Définition des propriétés de configuration avancées.
Utilisation du composant Suivi de documents BizTalk
  • Dans le système source, l'échange sortant d'origine est consigné dans la base de données de suivi ; en revanche, l'accusé de réception qui est renvoyé ne l'est pas.
  • Description des résultats d'enregistrement d'instance de document

  • Description des résultats d'accusé de réception


Configuration du système de destination pour les accusés de réception des échanges au format Reliable

Lorsque les services d'Échanges BizTalk du système de destination reçoivent un échange au format Reliable, ils utilisent un canal de définition de document spécial et un port d'échanges pour traiter et transmettre un accusé de réception au système source. Il n'est pas possible de visualiser ces objets système particuliers dans le Gestionnaire d'échanges BizTalk, ni de créer des objets similaires en utilisant les noms système réservés.

Le serveur utilise, pour l'accusé de réception, l'adresse de réponse qui est incluse dans l'en-tête de l'échange entrant comme adresse de destination.

Il n'est pas nécessaire de configurer spécifiquement les services d'Échanges BizTalk pour que le système de destination renvoie un accusé de réception pour un échange transmis avec une enveloppe au format Reliable, excepté lorsque le système source spécifie une adresse SMTP comme adresse URL de réponse d'échange de type Reliable. Pour envoyer des accusés de réception à une adresse SMTP, votre serveur doit être configuré pour inclure une adresse d'expédition dans l'en-tête de l'accusé.

Lorsque BizTalk Server 2000 est installé, un identificateur d'organisation est créé pour l'organisation d'origine. Cet identificateur est nommé Adresse d'expédition SMTP pour accusé de réception d'échanges au format Reliable et ne peut pas être supprimé. Lors de l'envoi d'un accusé de réception pour un échange de type Reliable à une adresse SMTP, le serveur insère la valeur que vous avez indiquée pour cet identificateur d'organisation dans l'en-tête d'échange comme adresse d'expédition.

Pour configurer les services d'Échanges BizTalk de façon à ce qu'ils envoient des accusés de réception aux systèmes source en utilisant une adresse SMTP de réponse pour un échange de type Reliable, effectuez les opérations présentées au tableau suivant. Des références sont fournies pour chaque procédure et des remarques commentent les configurations particulières. Les autres paramètres de propriété nécessaires à la configuration varient selon les entreprises et ne sont donc pas mentionnés ici.

Étape Références et remarques
Utilisation du Gestionnaire d'échanges BizTalk :
  • Définissez l'identificateur d'organisation Adresse d'expédition SMTP pour accusé de réception d'échanges au format Reliable de l'organisation d'origine.
  • Configuration de l'organisation d'origine

    Remarques

    • Ouvrez l'organisation d'origine.

    • Dans la boîte de dialogue Propriétés de l'organisation, cliquez sur l'onglet Identificateurs.

    • Dans la liste Identificateurs d'organisation, cliquez sur Adresse d'expédition SMTP pour accusé de réception d'échanges au format Reliable puis sur Modifier.

    • Dans la zone Valeur de la boîte de dialogue Propriétés d'identificateur, tapez une valeur pour l'identificateur. Pour plus d'informations, voir Modification d'identificateurs d'organisation.

    Important

    • Ne modifiez pas le nom ou le qualificateur de cet identificateur, mais uniquement sa valeur.
  • Créez un port d'échanges pour la transmission de l'échange d'origine au système de destination.
  • Création de ports d'échanges

    Remarque

    • Ce port d'échanges ne requiert pas de configuration particulière.
  • Créez un canal pour traiter l'échange d'origine.
  • Création de canaux

    Remarque

    • Ce port d'échanges ne requiert pas de configuration particulière.
Utilisation du composant Suivi de documents BizTalk
  • Dans le système de destination, l'échange entrant est consigné dans la base de données de suivi mais l'accusé de réception ne l'est pas.
  • Description des résultats d'enregistrement d'instance de document

  • Description des résultats d'accusé de réception


Description des listes de distribution

Une liste de distribution est un groupe de ports d'échanges qui permet d'envoyer un même document à plusieurs organisations de partenaires commerciaux ou à des applications internes.

Vous pouvez utiliser une liste de distribution pour envoyer simultanément les mêmes données à plusieurs organisations de vos partenaires commerciaux ou aux applications internes de votre organisation d'origine. Vous pouvez par exemple, envoyer le même catalogue, les mêmes tarifs ou bulletins d'informations à différentes organisations en envoyant l'information une seule fois à Microsoft BizTalk Server 2000.

Pour cela, vous devez tout d'abord créer un port d'échanges vers chaque organisation du partenaire commercial ou vers les applications internes auxquelles vous souhaitez envoyer des données, puis ajouter ces ports d'échanges dans une liste de distribution. Les ports d'échanges ouverts ne peuvent pas être ajoutés à une liste de distribution. Vous pouvez créer des ports d'échanges pour des organisations ou des applications internes supplémentaires, puis les ajouter à une liste de distribution existante. Pour plus d'informations, voir Création de ports d'échanges.

Vous devez créer au moins un canal pour chaque liste de distribution pour que la liste de distribution soit fonctionnelle. Pour plus d'informations, voir Création de canaux.

Lorsque BizTalk Server 2000 appelle un canal associé à une liste de distribution, il appelle uniquement le canal associé à cette liste pour traiter les données. Les autres canaux associés à chaque port d'échanges de la liste de distribution ne sont pas appelés. Le serveur utilise les propriétés de chaque port d'échanges pour transmettre successivement les données aux destinations spécifiées dans les ports d'échanges.

Une liste de distribution se distingue d'un port d'échanges pour les raisons suivantes :

  • L'utilisation d'une liste de distribution permet de diffuser les documents d'un canal vers plusieurs destinations. Lorsqu'un port d'échanges est ouvert, les documents d'un canal sont diffusés un à un et vers une destination unique.

  • Avec une liste de distribution, vous devez ajouter un port d'échanges pour envoyer des informations à une autre organisation d'un partenaire commercial. Lorsqu'un port d'échanges est ouvert, vous n'avez pas besoin de modifier ses propriétés pour transmettre des données à l'organisation d'un autre partenaire commercial.

Voir aussi

Utilisation de listes de distribution


Accès au modèle d'objets de configuration d'Échanges BizTalk

Cette section fournit des informations sur l'accès au modèle d'objets de configuration d'Échanges BizTalk par programme. Elle décrit comment gérer les relations avec des partenaires commerciaux et configurer des ports d'échanges et des canaux pour les échanges de données, en utilisant Microsoft BizTalk Server 2000. Elle décrit également comment créer des définitions de documents et des enveloppes, et comment définir des propriétés d'organisation. Pour plus d'informations, consultez les sections suivantes :

  • Pour obtenir des informations générales, voir Concepts.

  • Pour plus d'informations sur les interfaces COM, les énumérations et les messages d'erreur, voir Référence de modèle d'objets.

  • Pour des exemples de code, voir Exemples de code des services d'Échanges BizTalk.

Le modèle d'objets de configuration d'Échanges BizTalk peut également être configuré à l'aide de l'interface utilisateur graphique du Gestionnaire d'échanges BizTalk. (pour plus d'informations, voir Utilisation du Gestionnaire d'échanges BizTalk .


Concepts

Cette section contient des informations conceptuelles détaillées, relatives à l'accès au modèle d'objets de configuration d'Échanges BizTalk. Cette section traite des rubriques suivantes :

  • Modèle d'objets de configuration d'Échanges BizTalk

  • Canaux

  • Ports d'échanges

  • Propriété Openness

  • Organisations

  • Définitions de document

  • Enveloppes

Pour plus d'informations sur des exemples de code utilisant le modèle d'objets de configuration d'Échanges BizTalk, voir Exemples de code des services d'Échanges BizTalk.


Modèle d'objets de configuration d'Échanges BizTalk

Le modèle d'objets de configuration d'Échanges BizTalk permet aux applications d'installer, de gérer et d'extraire facilement des ports d'échanges et des canaux dans le cadre des relations entre partenaires commerciaux et de l'intégration entre applications. Le modèle d'objets de configuration d'Échanges BizTalk peut également créer des enveloppes et des définitions de document, et définir des propriétés d'organisation.

Le modèle d'objets de configuration d'Échanges BizTalk utilise une base de données SQL (Structured Query Language) pour stocker les configurations de ports et autres données relationnelles. Des jeux d'enregistrements ADO (ActiveX Data Objects) sont renvoyés lors des requêtes sur des listes d'instances d'objets (par exemple, ports d'échanges, organisations, etc.).

Le modèle d'objets de configuration d'Échanges BizTalk se compose d'objets COM (Component Object Model) exposant les données de configuration dont Microsoft BizTalk Server 2000 a besoin pour configurer l'échange de documents structurés entre applications et partenaires commerciaux. Les objets COM représentent des instances de données en mémoire pouvant être stockées dans la base de données.

Toutes les propriétés d'objets sont en lecture/écriture, sauf mention explicite.

Voir aussi

Objets de configuration d'Échanges BizTalk

Intégrité référentielle

Sécurité


Objets de configuration d'Échanges BizTalk

Les objets du modèle d'objets de configuration d'Échanges BizTalk sont présentés au tableau suivant.

Objet | Description
BizTalkChannel | Contient la configuration relative à l'entité source et à la liaison de cette dernière à un objet BizTalkPort.
BizTalkConfig | Crée et extrait d'autres objets BizTalk, comme, par exemple, des canaux, des spécifications de document et des ports d'échanges.
BizTalkDocument | Identifie et décrit la spécification d'un document.
BizTalkEnvelope | Identifie le format d'enveloppe et/ou le schéma d'enveloppe utilisés pour les documents. Les enveloppes sont requises pour les documents utilisant le format X12 ou EDIFACT.
BizTalkOrganization | Identifie la source ou la destination de l'échange de données électroniques. Une organisation peut représenter un partenaire commercial externe, votre propre société ou une unité commerciale d'un partenaire commercial ou de votre société. Une organisation peut désigner une application source dans un canal ou une application de destination dans un port.
BizTalkPort | Définit les attributs relatifs à la destination d'un envoi de document.
BizTalkPortGroup | Configure un groupe de ports. Il s'agit d'un groupe d'objets BizTalkPort complets pour l'envoi du même document (par exemple, un catalogue, un tarif ou un bulletin d'informations) à un groupe de partenaires commerciaux.

Attention

  • N'accédez pas directement à la base de données. N'appelez pas directement les procédures stockées. Effectuez toutes les modifications de la base de données via les méthodes et les propriétés du modèle d'objets de configuration d'échanges BizTalk. Si vous apportez directement des modifications à la base de données, de nombreuses contraintes appliquées par le modèle d'objets de configuration d'échanges BizTalk ne sont pas respectées, ce qui entraîne un mauvais fonctionnement du serveur ou une altération de la base de données.

  • L'accès au modèle d'objets de configuration d'Échanges BizTalk ne doit avoir lieu qu'au moment de la création. Si vous accédez à des objets en cours d'utilisation lors du traitement de documents par BizTalk Server, cela peut entraîner des résultats inattendus.

  • BizTalk Server 2000 traite toutes les variables présentant un type de données BSTR en tant que chaînes terminées par le caractère NULL. Les données figurant après le caractère NULL dans un BSTR ne sont pas prises en compte. Les documents contenant des caractères NULL incorporés doivent être envoyés à BizTalk Server via le mode direct.

Voir aussi

Canaux

Définitions de document

Enveloppes

Ports d'échanges

Organisations


Intégrité référentielle

La dépendance référentielle doit être prise en considération lors de l'instanciation d'objets dans BizTalk Server 2000. Selon le principe de la dépendance référentielle, un objet fait référence à un autre dont il dépend. Par exemple, un objet BizTalkChannel fait référence à un objet BizTalkPort.

Pour préserver l'intégrité référentielle, il est impossible de supprimer une instance d'objet si une autre instance d'objet y fait référence. L'intégrité référentielle est maintenue lorsque l'objet auquel il est fait référence existe dans la base de données.

Supprimez les objets dans l'ordre inverse de leur création. Si une instance d'objet est supprimée alors qu'une autre instance d'objet y fait référence, une erreur de contrainte est renvoyée. Dans l'exemple mentionné ci-dessus, une erreur de contrainte est renvoyée si un objet BizTalkPort est supprimé alors qu'il est utilisé par un objet BizTalkChannel.

La séquence suivante présente l'ordre à privilégier pour la création d'objets afin de préserver l'intégrité référentielle des objets :

  1. BizTalkOrganization

  2. BizTalkDocument

  3. BizTalkEnvelope (si nécessaire)

  4. BizTalkPort
    • L'objet BizTalkPort requiert l'objet BizTalkOrganization.

    • Dans certains cas, l'objet BizTalkPort utilise l'objet BizTalkEnvelope.
  5. BizTalkChannel
    • L'objet BizTalkChannel requiert l'objet BizTalkPort.

    • L'objet BizTalkChannel requiert l'objet BizTalkDocument.

    • L'objet BizTalkChannel requiert l'objet BizTalkOrganization.

    • L'objet BizTalkChannel utilise l'objet BizTalkPortGroup si le canal est créé pour des groupes de ports.
  6. BizTalkPortGroup (si utilisé)
    • L'objet BizTalkPortGroup requiert l'objet BizTalkPort.


Sécurité

Lors de l'accès à des objets ou lors de la création d'objets dans le modèle d'objets de configuration d'Échanges BizTalk, l'exécution du script ou de l'application doit avoir lieu dans le contexte d'un compte utilisateur du groupe Administrateurs de BizTalk Server. Le groupe Administrateurs de BizTalk Server est créé lors de l'installation de BizTalk Server 2000. Le cas échéant, il est possible d'ajouter des utilisateurs supplémentaires à ce groupe. Pour plus d'informations, voir Ajout d'utilisateurs au groupe Administrateurs de BizTalk Server.


Canaux

L'objet BizTalkChannel contient les informations de configuration relatives à l'entité source et à la liaison de celle-ci à un objet BizTalkPort. Lorsque BizTalk Server 2000 reçoit un document, le serveur est guidé à travers les étapes nécessaires au traitement du document via un objet BizTalkChannel spécifique et les propriétés configurées dans l'objet BizTalkPort correspondant ou dans un objet BizTalkPort correspondant au sein d'un objet BizTalkPortGroup. Remarquez que plusieurs canaux peuvent être liés au même objet BizTalkPort. Cela correspond à plusieurs entités source échangeant des documents avec la même destination.

L'objet BizTalkChannel identifie le mappage utilisé pour la transformation de document si l'objet BizTalkDocument d'entrée et l'objet BizTalkDocument de sortie sont de types différents. Il pointe aussi vers la spécification contenant des champs de suivi de documents et sélectionne le type de journalisation requis.

Voir aussi

Filtrage de canal

Configuration

Traitement de documents

Stockage des documents

Suivi des documents

Identification


Identification

BizTalk Server 2000 détermine l'objet BizTalkChannel approprié pour traiter le document d'entrée selon l'une des méthodes suivantes :

  • L'identificateur, le qualificateur et la valeur de l'organisation source et de l'organisation de destination, ainsi que le nom de l'objet BizTalkDocument, sont des paramètres de la méthode Submit ou SubmitSync de l'objet Interchange.

  • L'identificateur, le qualificateur et la valeur de l'organisation source et de l'organisation de destination, ainsi que le nom de l'objet BizTalkDocument, sont spécifiés dans les champs d'en-tête de l'instance de document.

  • Le nom de l'objet BizTalkChannel est un paramètre de l'appel de la méthode Submit ou SubmitSync.

Lorsque BizTalk Server 2000 reçoit un document, il identifie d'abord tous les objets BizTalkChannel qui prennent en charge l'objet BizTalkDocument spécifié. Le serveur examine alors chaque objet BizTalkPort et détermine si les propriétés SourceOrganization et DestinationOrganization identifient les objets BizTalkOrganization source et de destination spécifiés par les identificateurs d'organisation dans le document ou dans les paramètres de Submit lors de l'envoi du document. Ceci inclut tous les ports d'échanges ouverts qui correspondent à l'organisation source spécifiée ou à l'organisation de destination.

Il est possible d'éviter ce processus d'identification en spécifiant le nom d'un objet BizTalkChannel devant être utilisé en tant que paramètre de Submit ou de SubmitSync.

Voir aussi

Envoi


Traitement de documents

Lorsque BizTalk Server 2000 identifie un objet BizTalkChannel, le serveur traite cet objet, lequel le guide à travers les étapes de traitement du document. À cet effet, l'objet BizTalkChannel suit ses propres règles ainsi que celles de l'objet BizTalkPort lui étant associées.

Un objet BizTalkDocument d'entrée est associé à un objet BizTalkDocument de sortie via un objet BizTalkChannel. L'objet BizTalkPort doit avoir été créé avant qu'un objet BizTalkChannel associé puisse être créé.

Lorsque BizTalk Server 2000 traite un objet BizTalkChannel, le serveur fait appel à chaque objet BizTalkPort associé pour obtenir les règles nécessaires au traitement des documents. Les règles définies par les propriétés de l'objet BizTalkChannel guident le serveur dans les étapes initiales du traitement des documents. Elles lui permettent notamment de déterminer les objets BizTalkDocument d'entrée et de sortie ainsi que le fichier de mappage à utiliser, et les champs qui doivent faire l'objet d'un suivi. Une fois qu'un document présente son format de sortie définitif, les propriétés de l'objet BizTalkPort guident le serveur à travers les étapes de préparation et de transport du document selon les règles convenues par les organisations source et de destination.

Lorsqu'un document est envoyé, le serveur peut identifier plusieurs objets BizTalkPort et BizTalkChannel correspondant à l'organisation source, à l'organisation de destination et à l'objet BizTalkDocument spécifié. Il est donc possible qu'un document d'entrée génère plusieurs documents de sortie. Il est également possible de transmettre chaque document de sortie à un emplacement différent en utilisant des propriétés de transport différentes dans les objets BizTalkPort correspondants. Chaque instance de document de sortie peut en outre inclure un sous-ensemble de données spécifique par rapport au document d'entrée d'origine. À cet effet, il faut utiliser des fichiers de mappage différents.


Configuration

Un objet BizTalkChannel se compose des données internes de traitement de documents pour les objets BizTalkDocument d'entrée et de sortie spécifiés. Pour que sa configuration soit complète, un objet BizTalkChannel requiert un objet BizTalkPort complet identifié par la propriété Port. Des objets BizTalkDocument d'entrée et de sortie doivent être spécifiés. Une fois que les propriétés InputDocument et OutputDocument ont été sélectionnées pour être utilisées dans cet objet BizTalkChannel, un objet BizTalkPort ou BizTalkPortGroup doit être sélectionné.

Le nom d'un objet BizTalkChannel doit être unique dans la base de données pour tous les objets du même type.

Les propriétés suivantes sont requises pour qu'un objet BizTalkChannel puisse être enregistré :

  • InputDocument

  • Port (ou PortGroup)

  • OutputDocument

  • Name

Une fois qu'un objet BizTalkChannel a été créé ou enregistré, seules les propriétés suivantes peuvent être modifiées :

  • Comments

  • ControlNumberValue

  • MapReference

  • Name

  • TrackFields


Filtrage de canal

La fonctionnalité de filtrage de canal permet à l'utilisateur de définir une expression de filtrage afin de sélectionner un objet BizTalkChannel pour le traitement d'une instance de document. Le serveur utilise ces expressions pour sélectionner l'objet BizTalkChannel adéquat. La propriété Expression contient une expression XPath qui correspond à une valeur booléenne. Si l'expression est vérifiée, le canal est utilisé pour traiter le document. Dans le cas contraire, le canal n'est pas invoqué pour traiter le document.

Les expressions XPath peuvent être utilisées pour obtenir la valeur d'un élément ou d'un attribut spécifique, ou d'une combinaison de ces composants, au sein d'un document XML. Soit le document XML suivant :

<INVOICE><INVOICE>
    <DATE>12/31/2000</DATE><DATE>12/31/2000</DATE>
    <BILLTO>Vigor Airlines</BILLTO><BILLTO>Vigor Airlines</BILLTO>
    <SUMMARY><SUMMARY>
        <ITEM PARTNUMBER="10001" QUANTITY="10"/><ITEM PARTNUMBER="10001" QUANTITY="10"/>
        <ITEM PARTNUMBER="20002" QUANTITY="20"/><ITEM PARTNUMBER="20002" QUANTITY="20"/>
        <TOTAL VALUE="550"/><TOTAL VALUE="550"/>
    </SUMMARY></SUMMARY>
</INVOICE></INVOICE>

Sur la base de ce document, l'expression XPath suivante peut être créée afin de garantir que ce canal ne traite que les factures dépassant 500 dollars

myChannel.Expression = "/INVOICE/SUMMARY/TOTAL[@VALUE>""500""]"myChannel.Expression = "/INVOICE/SUMMARY/TOTAL[@VALUE>""500""]"

Dans cet exemple, le canal traiterait l'instance de document XML car le total est supérieur à 500 dollars. Pour plus d'informations sur les expressions XPath, accédez au site Web de Microsoft (msdn.microsoft.com/library/default.asp) et effectuez une recherche sur "XPath".

Remarque

  • Vous pouvez utiliser le Gestionnaire d'échanges BizTalk pour générer des expressions XPath de filtrage de canal. Pour plus d'informations, voir Ajout d'une expression de filtrage de canal.


Stockage des documents

Via l'objet BizTalkLoggingInfo, vous pouvez déterminer la manière dont l'activité d'une instance de document est consignée dans un journal. Le paramétrage par défaut consiste à journaliser le document au format natif.

Pour le stockage des documents, vous disposez des options présentées au tableau suivant :

Property | Description
Toutes les propriétés vides | Aucun stockage de copies du document
LogNativeInputDocument | Stockage au format d'entrée natif (configuration par défaut)
LogNativeOutputDocument | Stockage au format de sortie natif
LogXMLInputDocument | Stockage au format d'entrée XML
LogXMLOutputDocument | Stockage au format de sortie temporaire (XML)
Toute combinaison de ces options | Stockage comme décrit ci-dessus

Remarque

  • Il existe une limite de taille pour les échanges et les documents ayant recours à la journalisation. Si cette limite est dépassée, les performances de BizTalk Server sont considérablement réduites. Pour plus d'informations sur cette limite de taille, voir Limite de la taille des documents et des échanges.


Suivi des documents

Un objet BizTalkChannel pointe vers la spécification qui contient des champs de suivi pour l'instance du document. Les champs désignés sont journalisés dans la base de données de suivi pour chaque instance de document traitée. Lors de l'affectation d'un objet BizTalkDocument d'entrée à un objet BizTalkChannel, vous pouvez déterminer des champs devant faire l'objet d'un suivi au sein du document, sur ce canal.

Lorsque BizTalk Server 2000 exécute un objet BizTalkChannel, il utilise l'objet BizTalkDocument d'entrée pour traiter un document d'entrée. Les champs que vous avez désignés pour le suivi sont capturés et journalisés pour chaque instance de ce document. Les champs définis pour le suivi dans l'objet BizTalkDocument de sortie de l'objet BizTalkChannel associé ne sont pas pris en compte. Pour extraire les informations faisant l'objet d'un suivi lors du traitement des documents, utilisez les méthodes de l'objet BTSDocTracking.

En consignant dans le journal les données importantes des documents d'entrée traités, vous pouvez suivre et analyser des informations détaillées concernant vos opérations. Par exemple, le champ correspondant au total de la facture peut être consigné dans le journal pour chaque facture envoyée à vos partenaires commerciaux. Vous pouvez ensuite déterminer le montant total, en dollars, des factures envoyées, soit à tous vos partenaires commerciaux, soit à chacun d'entre eux.

Pour plus d'informations sur le suivi de documents, voir Présentation du schéma de la base de données de suivi.


Ports d'échanges

Du point de vue conceptuel, un port d'échanges représente un ensemble de règles auxquelles se soumettent des organisations de partenaires commerciaux dans le cadre de la transmission de documents. Il comprend des informations concernant la destination, le type de transport, la sécurité et l'enveloppe. Il identifie les objets BizTalkOrganization source et de destination ainsi que les alias correspondants. Le cas échéant, il identifie également les applications métiers associées à l'organisation.

Un objet BizTalkPort identifie une organisation de destination spécifique, à moins d'être défini comme étant un port d'échanges ouvert, auquel cas l'organisation de destination n'est pas spécifiée. Pour les ports d'échanges ouverts, l'objet BizTalkPort n'est valable que si les informations de transport et d'adresse pour la destination figurent dans le document associé ou dans les paramètres de la méthode Submit ou SubmitSync de l'objet Interchange.

L'objet BizTalkPort identifie également des définitions de délimiteurs ainsi que le numéro de contrôle d'échange EDI. Les délimiteurs servent à séparer les enregistrements et les champs de l'enveloppe ainsi que les documents au sein de l'enveloppe. Un numéro de contrôle d'échange est utilisé pour identifier et suivre les documents envoyés via l'enveloppe. Le numéro de contrôle d'échange est incrémenté à chaque utilisation de l'enveloppe au moment de l'exécution.

Si nécessaire, un objet BizTalkPort identifie également le type de codage, de cryptage et de signature.

Remarque

  • Une fois qu'un objet BizTalkPort a été créé et enregistré, l'organisation de destination et l'openness associé au point final ne peuvent plus être modifiés.

Voir aussi

Propriété Openness

Groupes de ports


Groupes de ports

L'objet BizTalkPortGroup configure un groupe d'objets BizTalkPort complets pour l'envoi du même document à un groupe de partenaires commerciaux. Par exemple, vous pouvez y avoir recours lorsque vous voulez envoyer un document contenant des données identiques (par exemple, un catalogue, un tarif ou un bulletin d'informations) à un groupe de partenaires commerciaux. Un document est envoyé à une liste de partenaires via l'appel d'une seule méthode Submit sur l'objet Interchange.

L'objet BizTalkPortGroup doit contenir au moins un objet BizTalkPort. Pour ajouter des objets BizTalkPort à un objet BizTalkPortGroup, vous appelez la méthode AddPort. Pour la suppression d'objets BizTalkPort, vous appelez la méthode RemovePort.

Un objet BizTalkPortGroup doit être associé à au moins un objet BizTalkChannel. Une fois le groupe de ports créé, associez-le à un canal en utilisant la propriété PortGroup disponible sur l'objet BizTalkChannel. Lorsque BizTalk Server 2000 invoque un canal lié à un groupe de ports, il invoque uniquement le canal associé au groupe de ports pour le traitement des données. Les canaux associés aux ports individuels du groupe ne sont pas invoqués. Le serveur utilise successivement les propriétés de chaque port pour transmettre les données vers les destinations spécifiées dans les ports.

Remarques

  • Il est impossible d'ajouter des ports d'échanges ouverts à un groupe de ports.

  • Le Gestionnaire d'échanges BizTalk fait référence aux groupes de ports en tant que listes de distribution.

Voir aussi

Envoi


Propriété Openness

La propriété Openness de l'objet BizTalkEndPoint détermine si le port d'échanges ou le canal est ouvert. Un objet BizTalkPort ouvert correspond à un port d'échanges sans destination spécifiée. Un objet BizTalkChannel ouvert correspond à un canal sans source spécifiée. Les informations manquantes pour un port d'échanges ou un canal ouvert doivent être fournies par le document associé ou par les paramètres de la méthode Submit ou SubmitSync de l'objet Interchange.

Si un canal ouvert est spécifié via BIZTALK_OPENNESS_TYPE_EX_SOURCE ou si un port d'échanges ouvert est spécifié via BIZTALK_OPENNESS_TYPE_EX_DESTINATION, les propriétés Type, Reference, et Store ne peuvent pas être spécifiées sur l'objet BizTalkEndPoint.

Remarque

  • Si un port d'échanges ouvert est utilisé avec le type de transport SMTP, la valeur spécifiée pour l'identificateur "Adresse d'expédition SMTP pour accusé de réception d'échanges au format Reliable" de l'objet BizTalkOrganization est utilisée comme adresse d'expédition.

Voir aussi

Envoi


Organisations

Les objets BizTalkOrganization font office de source ou de destination pour l'échange de données électroniques. Une organisation peut représenter un partenaire commercial externe, votre propre société ou une unité commerciale d'un partenaire commercial ou de votre propre société. L'organisation d'origine peut désigner une application source dans un canal ou une application de destination dans un port d'échanges.

Les applications sont des propriétés de l'organisation d'origine. Les applications peuvent être désignées en tant qu'application source dans un objet BizTalkChannel ou en tant qu'application de destination dans un objet BizTalkPort.

Alias

Un alias est un identificateur d'organisation pour l'objet BizTalkOrganization. L'objet BizTalkOrganization peut posséder plusieurs alias, mais un seul alias par défaut. Un alias est généré automatiquement pour chaque objet BizTalkOrganization. L'alias par défaut et l'alias généré automatiquement ne peuvent pas être supprimés.

Pour plus d'informations, voir Création et gestion d'organisations.


Définitions de document

L'objet BizTalkDocument décrit et identifie la spécification de document utilisée pour décrire le document envoyé ou reçu. La spécification de document définit la structure d'un document ainsi que les règles de validation et les descriptions des éléments individuels dont elle se compose. L'objet BizTalkDocument comprend la version et le type de la spécification et, éventuellement, une référence à l'emplacement WebDAV de la spécification. Pour plus d'informations sur les spécifications de document, voir Création et validation des spécifications.

Remarques

  • Les propriétés Content et Namespace du document ne sont pas valables tant que vous n'avez pas défini la propriété Reference.

  • Lors de la création d'un nouvel objet BizTalkDocument utilisant un espace de noms déjà inscrit auprès de BizTalk Server, le nouveau document hérite de la propriété Reference de cet espace de noms. L'espace de noms doit être unique (non-respect de la casse) pour qu'une nouvelle propriété Reference puisse être créée.

L'objet BizTalkDocument contient également les critères de sélection EDI (Electronic Data Interchange : Échange de données informatisé) via lesquels BizTalk Server 2000 extrait des informations à partir de l'en-tête de groupe fonctionnel du document pour identifier l'objet lorsque le nom de l'objet BizTalkDocument n'est pas disponible.

Un objet BizTalkDocument pointe vers la spécification contenant des champs de suivi pour l'instance du document. Les champs désignés sont journalisés dans la base de données de suivi pour chaque document traité.

Critères de sélection

Pour certains échanges d'entrée EDI, les documents sont contenus dans des enveloppes de groupe fonctionnel. Lorsque BizTalk Server 2000 traite de tels documents, il ne peut pas obtenir le nom de l'objet BizTalkDocument via un champ des documents. De plus, étant donné que plusieurs types de documents sont impliqués, il est impossible de spécifier un nom unique en tant que paramètre de la méthode Submit de l'objet Interchange. Dans de tels cas, le serveur peut localiser des données relatives aux documents dans l'en-tête de groupe fonctionnel (par exemple, dans l'en-tête GS d'un échange X12). En comparant ces données à des critères de sélection correspondants spécifiés dans la propriété PropertySet de l'objet BizTalkDocument, le serveur peut identifier un objet BizTalkDocument de façon univoque. Une fois l'objet BizTalkDocument identifié, le serveur peut obtenir le nom puis identifier et instancier l'objet BizTalkChannel approprié.

Les critères de sélection sont également utilisés par BizTalk Server 2000 pour la création de l'en-tête du document EDI sortant.

Suivi global

Un objet BizTalkDocument pointe vers la spécification à partir de laquelle des champs peuvent être sélectionnés pour le suivi. Les champs désignés dans la spécification de document d'entrée font l'objet d'un suivi pour chaque document traité via cette spécification. Les éventuels champs désignés pour le suivi dans la spécification de document de sortie ne sont pas pris en considération. Si un objet BizTalkChannel spécifiant des champs de suivi est utilisé avec une spécification de document d'entrée contenant des champs désignés pour le suivi, seuls les champs spécifiés par le canal sont pris en compte.

En consignant dans le journal les données importantes des documents d'entrée traités, vous pouvez suivre et analyser des informations détaillées concernant vos opérations. Par exemple, le champ correspondant au total de la facture peut être consigné dans le journal pour chaque facture envoyée à vos partenaires commerciaux. Vous pouvez ensuite déterminer le montant total, en dollars, des factures envoyées, soit à tous vos partenaires commerciaux, soit à chacun d'entre eux.

Voir aussi

Stockage des documents

Suivi des documents


Enveloppes

L'objet BizTalkEnvelope est constitué de deux informations :

  • Le type d'enveloppe est spécifié dans la propriété Format. La propriété Type du document doit correspondre à la propriété Format de l'enveloppe pour les types de document "flatfile", "custom xml", "x12", "edifact" et "reliable".

  • Le fichier d'enveloppe utilisé est spécifié dans la propriété Reference.

Enveloppes de documents d'entrée

Une enveloppe est requise lorsque la propriété Type du document d'entrée correspond à "flatfile" car l'enveloppe contient des informations sur la manière dont le document doit être converti au format XML et sur leparseur devant traiter le document. Les documents d'entrée "flatfile" ne peuvent pas être traités s'ils ne sont pas associés à une enveloppe. Pour tous les autres types de document d'entrée, l'enveloppe est facultative.

Enveloppes de documents de sortie

Une instance de document de sortie ayant été transformée au format natif doit être mise sous enveloppe. L'enveloppe utilisée avec un document de sortie est spécifiée sur l'objet BizTalkPort. Une enveloppe est requise si la propriété Type du document de sortie correspond à "x12" ou "edifact". Toutefois, la propriété Reference n'est pas prise en compte pour ces types de format car la spécification du type de document X12 ou EDIFACT suffit à la sérialisation du document. Pour les documents de sortie dont la propriété Type correspond à "custom xml", la propriété Reference est utilisée si elle est définie. SiÐla propriété Reference n'est pas spécifiée, les documents "custom xml" sont transmis, en vue de leur traitement, au format XML transformé.

Remarques

  • Plusieurs objets BizTalkPort peuvent faire référence à une enveloppe.

  • Les propriétés Content et Namespace de l'enveloppe ne sont pas valables tant que la propriété Reference n'est pas définie.

  • Lors de la création d'un nouvel objet BizTalkEnvelope utilisant un espace de noms déjà inscrit auprès de BizTalk Server, le nouveau document hérite de la propriété Reference de cet espace de noms. L'espace de noms doit être unique (non-respect de la casse) pour qu'une nouvelle propriété Reference puisse être créée.


Création de spécifications et mapping de données

Microsoft BizTalk Server 2000 offre des outils vous permettant de définir la structure d'un document et de mapper des données d'un format à un autre. Reposant sur la technologie XML (Extensible Markup Language) et sur d'autres standards, ces outils permettent la traduction des données nécessaire à un serveur d'intégration d'applications.

L'Éditeur BizTalk permet de créer des spécifications basées sur les standards de l'industrie et des schémas communs, ou bien de créer des spécifications uniques pour votre entreprise.

Grâce au Mappeur BizTalk, vous pouvez créer un mappage entre les enregistrements et les champs de deux spécifications distinctes. Le serveur recourt au mappage pour traiter et traduire les données dans des formats partageables dans l'entreprise ou avec les partenaires.

Cette section traite des rubriques suivantes :

  • Création de spécifications

  • Mappage de données

  • Dépannage de l'Éditeur BizTalk et du Mappeur BizTalk


Création de spécifications

L'Éditeur BizTalk est un outil permettant de créer, de modifier et de gérer des spécifications. L'Éditeur BizTalk utilise XML (Extensible Markup Language), qui fournit un vocabulaire commun permettant de manipuler les chevauchements entre les schémas syntaxiques, de bases de données et conceptuels.

L'Éditeur BizTalk crée des spécifications en interprétant les propriétés des enregistrements et des champs contenus dans un fichier. Les spécifications représentent les données structurées au format XML, indépendamment de leur format d'origine. Par ailleurs, les spécifications créées ou modifiées dans l'Éditeur BizTalk fournissent des descriptions de données communes que le Mappeur BizTalk peut utiliser pour convertir les données dans d'autres formats. Les spécifications permettent ainsi d'assurer la portabilité des données entre les différents processus d'entreprise. Une spécification créée à l'aide de l'Éditeur BizTalk s'appuie sur l'un des formats suivants :

  • XML bien formé.

  • Modèles de documents basés sur XML.

  • Schémas XDR (XML-Data Reduced).

  • Définitions de type de document (DTD).

  • Jeux d'enregistrements d'objets de données ActiveX (ADO) stockés au format XML.

  • EDI (Electronic Data Interchange) (X12 et EDIFACT).

  • Fichiers plats, notamment les fichiers délimités et positionnels (par exemple, les IDOC SAP). Un fichier plat peut également être à la fois délimité et positionnel.

  • Formats de documents structurés.

L'Éditeur BizTalk vous permet d'ouvrir une spécification vide ne contenant aucune structure, ou d'importer un schéma ou une spécification existante. Par exemple, vous pouvez importer une DTD, à savoir un fichier structuré définissant des éléments et attributs ainsi que les contraintes relatives à l'ordre, la fréquence et le contenu de ces éléments et attributs. Les spécifications standard, telles que XML, X12 ou EDIFACT, peuvent également être utilisées pour la création de nouvelles spécifications.

Lors de l'importation d'une instance de document, l'Éditeur BizTalk convertit la structure du document et génère une spécification qui est une représentation XML de ce document. Vous pouvez modifier tous les enregistrements et champs nécessaires qui apparaissent dans l'arborescence de spécification de l'Éditeur BizTalk, puis enregistrer la structure en tant que spécification. Vous pouvez importer les types de fichiers suivants :

  • Schémas XDR.

  • XML bien formé.

  • DTD.

Chaque spécification décrit la structure du fichier à l'aide d'un ensemble de balises bien définies. L'Éditeur BizTalk fournit également différents modèles pouvant servir de points de départ pour la création de spécifications relatives à des documents communs, tels que des commandes d'achat, des factures ou des bons d'expédition.

Lorsque BizTalk Server traite des documents, il utilise un mappage, que vous créez à l'aide du Mappeur BizTalk, pour traduire les données entrantes et sortantes depuis un format de spécification vers un autre.

  • Pour obtenir de l'aide sur des tâches spécifiques, voir Comment.

  • Pour obtenir des informations générales, voir Concepts.

  • Pour des ressources supplémentaires, voir Ressources.

  • Pour des instructions sur la résolution des problèmes, voir Dépannage de l'Éditeur BizTalk et du Mappeur BizTalk.


Comment...

Cette section fournit des informations spécifiques aux tâches quant au mode de création de spécifications. Nous vous recommandons vivement de relire la section Concepts, afin de comprendre parfaitement les relations entre les enregistrements et les champs ainsi que la méthode de spécification des propriétés adaptées au type de spécifications que vous voulez créer.

Cette section traite des rubriques suivantes :

  • Modification des options de l'Éditeur BizTalk

  • Création et validation de spécifications

  • Ouverture de spécifications

  • Enregistrement, exportation, conversion et fermeture des spécifications

  • Gestion d'enregistrements et de champs

  • Spécification de propriétés pour les enregistrements et les champs

  • Modification de notes et règles syntaxiques

  • Gestion d'instances de document

  • Gestion de tables de caractères incorrectes

  • Gestion de vues


Modification des options de l'Éditeur BizTalk

  1. Pour afficher ou modifier les options dans la boîte de dialogue Options de l'Éditeur BizTalk, dans le menu Outils, cliquez sur Options.

  2. Dans l'onglet Général, vous pouvez activer la case à cocher Créer un nouveau champ en tant qu'élément. Pour plus d'information sur cette option, voir Création d'un nouveau champ en tant qu'élément.

Voir aussi

Création d'un nouveau champ en tant qu'élément


Création et validation de spécifications

Cette section traite des procédures suivantes :

  • Création d'une spécification basée sur un standard

  • Création d'une spécification basée sur un fichier plat

  • Création d'une spécification basée sur un modèle vide

  • Création d'une spécification basée sur une spécification existante

  • Création d'une spécification basée sur un fichier importé

  • Validation d'une spécification


Création d'une spécification basée sur un standard

  1. Dans le menu Fichier, cliquez sur Nouveau.

  2. Dans la boîte de dialogue Nouvelle spécification de document, cliquez sur XML, X12 ou EDIFACT, puis sur OK.

    Si vous sélectionnez EDIFACT ou X12, vous devez également sélectionner la version que vous voulez utiliser. Cliquez sur le dossier de la version appropriée puis sur OK.

  3. Cliquez sur le type de spécification, puis sur OK.

  4. Suppression d'enregistrements, le cas échéant.

  5. Suppression de champs, le cas échéant.

  6. Suppression de codes, le cas échéant.

  7. Enregistrement de nouvelles spécifications.

Voir aussi

Gestion d'enregistrements et de champs

Spécification de propriétés pour les enregistrements et les champs

Définition des spécifications


Création d'une spécification basée sur un fichier plat

  1. Dans le menu Fichier, cliquez sur Nouveau.

  2. Dans la boîte de dialogue Nouvelle spécification de document, cliquez sur Spécification vide, puis sur OK.

  3. Sélectionnez le noeud racine, puis cliquez sur l'onglet Référence.

  4. Double-cliquez dans le champ Valeur de la ligne Standard.

  5. Dans la liste Standard, cliquez sur Personnalisé.

  6. Appuyez sur ENTRÉE.

  7. Cliquez sur Oui pour confirmer la modification.

  8. Ajout de nouveaux enregistrements au noeud racine.

  9. Ajout de nouveaux enregistrements aux enregistrements existants.

  10. Ajout de nouveaux champs au noeud racine.

  11. Ajout de nouveaux champs aux enregistrements.

  12. Spécification de propriétés pour les enregistrements et les champs

  13. Enregistrement de nouvelles spécifications.

Remarque

  • Dans l'onglet Analyse, vous devez définir la propriété Structure du noeud racine avec le paramètre Délimité si votre fichier plat est à la fois délimité et positionnel. Les propriétés supplémentaires des enregistrements sont définies sur Délimité ou Positionnel, comme requis.

  • Les fichiers plats basés sur la page de code UTF-8 ne sont pas pris en charge par l'Éditeur BizTalk.

Voir aussi

Gestion d'enregistrements et de champs

Spécification de propriétés pour les enregistrements et les champs

Définition des spécifications


Création d'une spécification basée sur un modèle vide

  1. Dans le menu Fichier, cliquez sur Nouveau.

  2. Dans la boîte de dialogue Nouvelle spécification de document, cliquez sur Spécification vide, puis sur OK.

  3. Ajout de nouveaux enregistrements au noeud racine.

  4. Ajout de nouveaux enregistrements aux enregistrements existants.

  5. Ajout de nouveaux champs au noeud racine.

  6. Ajout de nouveaux champs aux enregistrements.

  7. Spécification de propriétés pour les enregistrements et les champs

  8. Enregistrement de nouvelles spécifications.

Voir aussi

Gestion d'enregistrements et de champs

Spécification de propriétés pour les enregistrements et les champs

Définition des spécifications


Création d'une spécification basée sur une spécification existante

  1. Dans le menu Fichier, cliquez sur Ouvrir.

  2. Dans la boîte de dialogue Ouvrir la spécification de document, sélectionnez un dossier contenant une spécification existante.

  3. Cliquez sur un fichier dans la liste, puis sur Ouvrir.

  4. Le cas échéant, modifiez les spécifications.

  5. Dans le menu Fichier, cliquez sur Enregistrer sous.

  6. Dans la boîte de dialogue Enregistrer la spécification de document sous, dans la zone Nom de fichier, tapez le nom de la spécification.

  7. Dans la liste Codage, sélectionnez UTF-8 ou Unicode, puis cliquez sur Enregistrer.

    Si vous voulez créer une spécification associée aux caractères ASCII, cliquez sur UTF-8 dans la liste Codage. Dans le cas de spécifications liées à des caractères codés sur deux octets, cliquez sur UTF-8 ou sur Unicode dans la liste Codage.

  8. Gestion d'enregistrements et de champs.

  9. Enregistrement de nouvelles spécifications.

Voir aussi

Valeurs et descriptions des listes de codes

Gestion d'enregistrements et de champs


Création d'une spécification basée sur un fichier importé

  1. Dans le menu Outils, cliquez sur Importer.

  2. Dans la boîte de dialogue Sélectionnez le module d'importation, cliquez sur Instance XML bien formée, Définition du type de document ou Schéma XDR, puis sur OK.

    Si vous importez un fichier réduit XML-Data (XDR), cliquez sur Schéma XDR.

  3. Dans la boîte de dialogue Importer, sélectionnez le dossier contenant le fichier à importer.

  4. Cliquez sur le fichier approprié puis sur Ouvrir.

    BizTalk Editor crée une spécification basée sur la structure du fichier importé. Vous devez affecter des valeurs de propriété à tous les enregistrements et champs.

  5. Ajout de nouveaux enregistrements au noeud racine.

  6. Ajout de nouveaux enregistrements aux enregistrements existants.

  7. Ajout de nouveaux champs au noeud racine.

  8. Ajout de nouveaux champs aux enregistrements.

  9. Spécification de propriétés pour les enregistrements et les champs

  10. Enregistrement de nouvelles spécifications.

Important

  • L'Éditeur BizTalk ne prend pas en charge l'importation de DTD (Document Type Definitions) dont les éléments contiennent des commentaires. Pour importer ces DTD, vous devez modifier les fichiers concernés afin de supprimer les commentaires des éléments.

  • Si le fichier importé intègre un élément composé de contenu, s'il est récurrent dans les données de l'instance, et n'a pas d'enfant, l'Éditeur BizTalk le crée en tant que champ plutôt qu'enregistrement lors de l'importation de la structure.

  • Si l'Éditeur BizTalk ne peut pas déterminer quel élément sera le noeud racine, la boîte de dialogue Sélectionnez l'élément racine s'affiche. Sélectionnez l'élément correspondant au noeud racine et cliquez sur OK.

  • L'Éditeur BizTalk ne peut pas importer une DTD et/ou un schéma XDR contenant une référence circulaire figurant dans le noeud racine. Il peut importer un document XML correctement formé contenant une référence circulaire figurant dans le noeud racine, même si un avertissement s'affiche, indiquant que les références circulaires ne peuvent pas figurer dans le noeud racine d'un document. Pour plus d'informations, voir Références circulaires.

  • Si vous importez un fichier XML correctement formé contenant un espace de noms sur le noeud racine, l'espace de noms devient l'espace cible et il est ignoré à tout autre emplacement dans la spécification. Pour plus d'informations sur les espaces de noms, voir Définition des propriétés de référence.

  • Si vous importez un fichier dont le contenu de l'élément est mixte (informations texte et sous-éléments), les informations texte de cet élément sont ignorées lors de l'importation.

  • La table suivante affiche les conséquences de l'importation de fichiers XDR ou DTD contenant certains types de données. Les colonnes représentent les types de données.
    "entité" et "entités" | "nmtoken" et "nmtokens" | "notation"
    XDR | Impossible d'importer le fichier. | Le fichier peut être importé. Les types de données sont supprimés. | Impossible d'importer le fichier.
    DTD | Le fichier peut être importé. Les types de données sont supprimés. | Le fichier peut être importé. Les types de données sont supprimés. | Le fichier peut être importé. Les types de données sont importés en tant que type d'énumération.

Voir aussi

Importation de fichiers

Gestion d'enregistrements et de champs

Spécification de propriétés pour les enregistrements et les champs


Validation d'une spécification

  1. Ouvrez une spécification ou importez un schéma.

    Pour plus d'informations, voir Ouverture de spécifications ou Création d'une spécification basée sur un fichier importé.

  2. Dans le menu Outils, cliquez sur Valider la spécification.

L'onglet Avertissements affiche les avertissements relatifs aux problèmes pouvant exister avec la structure de la spécification. Vous pouvez double-cliquer sur un avertissement pour afficher en rouge l'enregistrement ou le champ et la propriété associée dans les volets situés au-dessus.

Voir aussi

Création d'une spécification basée sur un fichier importé

Ouverture de spécifications


Ouverture de spécifications

Cette section traite des procédures suivantes :

  • Ouverture de spécifications existantes à partir d'un disque local

  • Ouverture de spécifications à partir de WebDAV


Ouverture de spécifications existantes à partir d'un disque local

  1. Dans le menu Fichier, cliquez sur Ouvrir.

  2. Dans la boîte de dialogue Ouvrir la spécification de document, sélectionnez le dossier qui contient la spécification à ouvrir.

  3. Cliquez sur un fichier dans la liste, puis sur Ouvrir.

Voir aussi

Ouverture de spécifications à partir de WebDAV


Ouverture de spécifications à partir de WebDAV

  1. Dans le menu Fichier, cliquez sur Extraire à partir de WebDav.

  2. Dans la boîte de dialogue Extraire à partir de WebDAV, dans la liste Serveur, tapez le nom du serveur et appuyez sur ENTRÉE.

    Vous pouvez également sélectionner le nom d'un serveur dans la liste.

  3. Recherchez le dossier contenant la spécification à ouvrir, cliquez sur la spécification puis sur Ouvrir.

Remarque

  • Il est possible que votre première connexion à un serveur WebDAV distant soit lente lors d'une session.

Voir aussi

Ouverture de spécifications existantes à partir d'un disque local

Dépannage de l'Éditeur BizTalk et du Mappeur BizTalk


Enregistrement, exportation, conversion et fermeture des spécifications

Cette section traite des procédures suivantes :

  • Enregistrement de nouvelles spécifications

  • Enregistrement de spécifications existantes

  • Stockage de spécifications

  • Exportation de schémas XDR

  • Conversion d'un schéma XDR en schéma XSD

  • Fermeture de spécifications


Enregistrement de nouvelles spécifications

  1. Dans le menu Fichier, cliquez sur Enregistrer sous.

  2. Dans la boîte de dialogue Enregistrer la spécification de document sous, dans la zone Nom de fichier, tapez le nom du fichier.

  3. Dans la liste Codage, sélectionnez UTF-8 ou Unicode, puis cliquez sur Enregistrer.

    Si vous voulez enregistrer des spécifications associées aux caractères ASCII, dans la liste Codage, cliquez sur UTF-8. Pour les spécifications associées aux caractères codés sur deux octets, dans la liste Codage, cliquez sur UTF-8 ou Unicode.


Enregistrement de spécifications existantes

  • Dans le menu Fichier, cliquez sur Enregistrer.

Remarque

  • Lorsque vous enregistrez un fichier, l'Éditeur BizTalk stocke le fichier sur votre disque dur. Pour stocker un fichier dans WebDAV, vous devez disposer de l'autorisation pour stocker des fichiers sur le serveur.

Voir aussi

Stockage de spécifications


Stockage de spécifications

  1. Dans le menu Fichier, cliquez sur Stocker dans WebDAV.

  2. Dans la boîte de dialogue Stocker dans WebDAV, dans la liste Serveur, tapez le nom du serveur et appuyez sur ENTRÉE.

    Vous pouvez également sélectionner le nom d'un serveur dans la liste.

  3. Sélectionnez le dossier dans lequel vous voulez stocker votre spécification.

  4. Dans la zone Nom de fichier, entrez le nom du fichier.

  5. Dans la liste Codage, sélectionnez UTF-8 ou Unicode, puis cliquez sur Enregistrer.

    Si vous voulez stocker une spécification associée aux caractères ASCII, cliquez sur UTF-8 dans la liste Codage. Dans le cas de spécifications liées à des caractères codés sur deux octets, cliquez sur UTF-8 ou sur Unicode dans la liste Codage.

Important

  • Vous ne pouvez pas stocker de fichiers avec des noms de fichiers utilisant des jeux de caractères codés sur deux octets si vos paramètres locaux sont incorrects. Pour résoudre ce problème, voir ???.xml apparaît dans la boîte de dialogue WebDAV.

Remarques

  • Il est possible que votre première connexion à un serveur WebDAV distant soit lente.

  • Lorsque vous enregistrez un fichier dans WebDAV, l'Éditeur BizTalk l'enregistre sur un serveur. Pour enregistrer un fichier sur votre disque dur, dans le menu Fichier, cliquez sur Enregistrer sous.

Voir aussi

Enregistrement de spécifications existantes

Enregistrement de nouvelles spécifications

Dépannage de l'Éditeur BizTalk et du Mappeur BizTalk


Exportation de schémas XDR

  1. Dans le menu Outils, cliquez sur Exporter le schéma XDR.

  2. Dans la boîte de dialogue Exporter le schéma XDR sous, recherchez l'emplacement vers lequel vous voulez exporter le fichier réduit XML-Data (XDR).

  3. Dans la zone Nom de fichier, entrez un nom pour le fichier.

  4. Dans la liste Codage, sélectionnez UTF-8 ou Unicode, puis cliquez sur Enregistrer.

    Si vous voulez exporter des spécifications associées aux caractères ASCII, dans la liste Codage, cliquez sur UTF-8. Pour les spécifications associées aux caractères codés sur deux octets, dans la liste Codage, cliquez sur UTF-8 ou Unicode.

Remarques

  • Vous pouvez exporter de nouvelles spécifications ainsi que des spécifications existantes uniquement lorsqu'elles sont ouvertes dans l'Éditeur BizTalk.

  • Lorsque vous exportez une spécification, les informations sur la spécification unique sont supprimées de la structure, et la structure en résultant est enregistrée en tant que schéma général pouvant être utilisé par d'autres applications.

Voir aussi

Ouverture de spécifications

Conversion d'un schéma XDR en schéma XSD


Conversion d'un schéma XDR en schéma XSD

  1. Créez sur votre disque local un dossier appelé Convert.

  2. Copiez le contenu de \Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\XSDConverter dans Convert.

  3. Copiez le schéma XDR à convertir dans Convert.

  4. Ouvrez une invite de commandes.

  5. Ouvrez le répertoire Convert.

  6. À l'invite de commandes, tapez :
    wscript convert.js xdrfilename.xml xsdfilename.xsdwscript convert.js xdrfilename.xml xsdfilename.xsd

Le schéma XSD converti, appelé xsdfilename.xsd, apparaît dans le dossier Convert.

Remarque

  • Si vous n'attribuez pas de nom de fichier au schéma XSD, le script lui donne le nom du schéma XDR d'origine assorti de l'extension .xsd. Si, par exemple, le schéma XDR s'appelait xdrfilename.xml, le schéma XSD converti s'appelerait xdrfilename.xml.xsd.

Voir aussi

Exportation de schémas XDR


Fermeture de spécifications

  • Dans le menu Fichier, cliquez sur Fermer.


Gestion d'enregistrements et de champs

Cette section traite des procédures suivantes :

  • Ajout de nouveaux enregistrements au noeud racine

  • Ajout de nouveaux champs au noeud racine

  • Ajout de nouveaux enregistrements aux enregistrements existants

  • Ajout de nouveaux champs aux enregistrements

  • Insertion d'enregistrements

  • Insertion de champs

  • Création d'un nouveau champ en tant qu'élément

  • Modification de champs d'attributs en éléments

  • Modification de champs d'éléments en attributs

  • Déplacement d'enregistrements dans une spécification

  • Déplacement de champs dans une spécification

  • Déplacement d'enregistrements d'une spécification à une autre

  • Déplacement de champs d'une spécification à une autre

  • Copie d'enregistrements dans une spécification

  • Copie de champs dans une spécification

  • Copie d'enregistrements d'une spécification à une autre

  • Copie de champs d'une spécification à une autre

  • Affectation d'un nouveau nom à un enregistrement unique

  • Affectation d'un nouveau nom à un champ unique

  • Affectation de nouveaux noms à tous les enregistrements dont le nom est identique

  • Suppression d'enregistrements

  • Suppression de champs

  • Création de références circulaires

  • Création d'une nouvelle instance d'un enregistrement unique

  • Création d'une nouvelle instance d'un champ d'élément existant


Ajout de nouveaux enregistrements au noeud racine

  1. Cliquez sur le noeud racine.

  2. Dans le menu Edition, cliquez sur Nouvel enregistrement.

    Un enregistrement enfant s'insère après le dernier noeud dans l'arborescence de la spécification.

  3. Tapez le nom de l'enregistrement, puis appuyez sur ENTRÉE.

Remarques

  • Dans le cas d'un fichier non-XML (un fichier plat par exemple), vous pouvez entrer une propriété Identifiant de la balise source afin d'identifier la balise dans le fichier source non-XML.

  • Des enregistrements frères ne peuvent pas porter le même nom.

Voir aussi

Spécification de propriétés pour les enregistrements et les champs


Ajout de nouveaux champs au noeud racine

  1. Cliquez sur le noeud racine.

  2. Dans le menu Edition, cliquez sur Nouveau champ.

    Un champ enfant s'insère après le dernier noeud dans l'arborescence de la spécification.

  3. Tapez le nom du champ, puis appuyez sur ENTRÉE.

Remarque

  • Les champs frères ne peuvent pas porter le même nom, sauf si la propriété Type d'un champ correspond à Attribut et la propriété Type de l'autre champ correspond à Élément.

Voir aussi

Modification de champs d'éléments en attributs

Création d'un nouveau champ en tant qu'élément

Spécification de propriétés pour les enregistrements et les champs


Ajout de nouveaux enregistrements aux enregistrements existants

  1. Cliquez sur un enregistrement.

  2. Dans le menu Edition, cliquez sur Nouvel enregistrement.

    Un enregistrement enfant s'insère directement après l'enregistrement sélectionné ou après le dernier noeud enfant de l'enregistrement sélectionné.

  3. Tapez le nom de l'enregistrement, puis appuyez sur ENTRÉE.

Remarques

  • Dans le cas d'un fichier non-XML (un fichier plat par exemple), vous pouvez entrer une propriété Identifiant de la balise source afin d'identifier la balise dans le fichier source non-XML.

  • Des enregistrements frères ne peuvent pas porter le même nom.

Voir aussi

Spécification de propriétés pour les enregistrements et les champs


Ajout de nouveaux champs aux enregistrements

  1. Cliquez sur un enregistrement.

  2. Dans le menu Edition, cliquez sur Nouveau champ.

    Un enregistrement enfant s'insère directement après l'enregistrement sélectionné ou après le dernier noeud enfant de l'enregistrement sélectionné.

  3. Tapez le nom du champ, puis appuyez sur ENTRÉE.

Remarque

  • Les champs frères ne peuvent pas porter le même nom, sauf si la propriété Type d'un champ correspond à Attribut et la propriété Type de l'autre champ correspond à Élément.

Voir aussi

Modification de champs d'éléments en attributs

Création d'un nouveau champ en tant qu'élément

Spécification de propriétés pour les enregistrements et les champs


Insertion d'enregistrements

  1. Cliquez sur un enregistrement.

  2. Dans le menu Edition, cliquez sur Insérer un enregistrement.

    Un enregistrement frère s'insère directement après l'enregistrement sélectionné ou après le dernier noeud enfant de l'enregistrement sélectionné.

  3. Tapez le nom de l'enregistrement, puis appuyez sur ENTRÉE.

Remarque

  • Des enregistrements frères ne peuvent pas porter le même nom.

Voir aussi

Spécification de propriétés pour les enregistrements et les champs


Insertion de champs

  1. Cliquez sur l'enregistrement ou le champ après lequel vous souhaitez insérer un champ.

  2. Dans le menu Edition, cliquez sur Insérer un champ.

    Un champ frère s'insère directement après l'enregistrement sélectionné ou après le dernier noeud enfant de l'enregistrement sélectionné.

  3. Tapez le nom du champ, puis appuyez sur ENTRÉE.

Remarque

  • Les champs frères ne peuvent pas porter le même nom, sauf si la propriété Type d'un champ correspond à Attribut et la propriété Type de l'autre champ correspond à Élément.

Voir aussi

Modification de champs d'éléments en attributs

Création d'un nouveau champ en tant qu'élément

Spécification de propriétés pour les enregistrements et les champs


Création d'un nouveau champ en tant qu'élément

  1. Dans le menu Outils, cliquez sur Options.

  2. Dans la boîte de dialogue Options de l'Éditeur BizTalk, activez la case à cocher Créer un nouveau champ en tant qu'élément et cliquez sur OK.

Remarque

  • Si cette case à cocher est désactivée, les champs sont créés en tant qu'attributs. Cependant, si vous l'activez, tous les nouveaux champs sont créés en tant qu'éléments.

  • Les champs frères ne peuvent pas porter le même nom, sauf si la propriété Type d'un champ correspond à Attribut et la propriété Type de l'autre champ correspond à Élément.

Voir aussi

Modification de champs d'éléments en attributs


Modification de champs d'attributs en éléments

  1. Cliquez sur un champ dans l'arborescence de la spécification.

  2. Dans l'onglet Déclaration, double-cliquez sur le champ Valeur dans la ligne Type. Les paramètres en cours sont définis sur Attribut.

  3. Dans la liste Type, cliquez sur Élément et appuyez sur ENTRÉE.

  4. Cliquez sur Oui pour confirmer la modification.

Remarque

  • Les champs frères ne peuvent pas porter le même nom, sauf si la propriété Type d'un champ correspond à Attribut et la propriété Type de l'autre champ correspond à Élément.

Voir aussi

Modification de champs d'éléments en attributs

Création d'un nouveau champ en tant qu'élément


Modification de champs d'éléments en attributs

  1. Cliquez sur un champ dans l'arborescence de la spécification.

  2. Dans l'onglet Déclaration, double-cliquez sur le champ Valeur dans la ligne Type. Les paramètres en cours sont définis sur Élément.

  3. Dans la liste Type, cliquez sur Attribut et appuyez sur ENTRÉE.

  4. Cliquez sur Oui pour confirmer la modification.

Remarque

  • Les champs frères ne peuvent pas porter le même nom, sauf si la propriété Type d'un champ correspond à Attribut et la propriété Type de l'autre champ correspond à Élément.

Voir aussi

Modification de champs d'attributs en éléments


Déplacement d'enregistrements dans une spécification

  1. Cliquez sur le noeud racine.

  2. Dans le menu Affichage, cliquez sur Développer les éléments de l'arborescence.

  3. Cliquez sur l'enregistrement que vous voulez déplacer et faites-le glisser vers un autre noeud de l'arborescence.

    Lorsque vous relâchez le bouton de la souris, si le pointeur de la souris se trouve dans la partie supérieure de texte du noeud mis en surbrillance, l'enregistrement est inséré au-dessus du noeud en tant qu'enregistrement frère. Si le pointeur de la souris se trouve dans la partie inférieure de texte du noeud mis en surbrillance, l'enregistrement est inséré sous le noeud en tant qu'enregistrement frère. Si le pointeur de la souris se trouve dans la partie droite de texte du noeud mis en surbrillance, l'enregistrement est inséré sous le noeud en tant qu'enregistrement enfant.

Voir aussi

Copie d'enregistrements d'une spécification à une autre

Copie d'enregistrements dans une spécification

Déplacement d'enregistrements d'une spécification à une autre


Déplacement de champs dans une spécification

  1. Cliquez sur le noeud racine.

  2. Dans le menu Affichage, cliquez sur Développer les éléments de l'arborescence.

  3. Cliquez sur le champ que vous voulez déplacer et faites-le glisser vers un autre noeud de l'arborescence.

    Lorsque vous relâchez le bouton de la souris, si le pointeur de la souris se trouve dans la partie supérieure de texte du noeud mis en surbrillance, l'enregistrement est inséré au-dessus du noeud en tant qu'enregistrement frère. Si le pointeur de la souris se trouve dans la partie inférieure de texte du noeud mis en surbrillance, l'enregistrement est inséré sous le noeud en tant qu'enregistrement frère. Si le pointeur de la souris se trouve dans la partie droite de texte du noeud mis en surbrillance, le champ est inséré sous le noeud en tant qu'enregistrement enfant.

Voir aussi

Copie de champs d'une spécification à une autre

Copie de champs dans une spécification

Déplacement de champs d'une spécification à une autre


Déplacement d'enregistrements d'une spécification à une autre

  1. Cliquez sur le noeud racine dans la spécification contenant l'enregistrement que vous voulez déplacer.

  2. Dans le menu Affichage, cliquez sur Développer les éléments de l'arborescence.

  3. Cliquez sur l'enregistrement que vous voulez déplacer, puis dans le menu Edition, cliquez sur Couper.

  4. Dans le menu Démarrer, pointez sur Programmes, Microsoft BizTalk Server 2000, puis cliquez sur Éditeur BizTalk.

    Vous devez ouvrir une seconde instance de l'Éditeur BizTalk pour ouvrir une autre spécification.

  5. Dans le menu Fichier, cliquez sur Ouvrir.

  6. Dans la boîte de dialogue Ouvrir la spécification de document, sélectionnez le dossier qui contient la spécification vers laquelle vous voulez déplacer l'enregistrement.

  7. Sélectionnez le fichier dans la liste, puis cliquez sur Ouvrir.

  8. Cliquez sur le noeud racine dans la spécification.

  9. Dans le menu Affichage, cliquez sur Développer les éléments de l'arborescence.

  10. Cliquez sur un noeud racine, un enregistrement ou un champ après lequel vous voulez insérer l'enregistrement.

  11. Dans le menu Edition, cliquez sur Coller.

Remarque

  • Si vous déplacez un enregistrement qui porte le même nom qu'un enregistrement existant, l'Éditeur BizTalk ajoute automatiquement un chiffre après son nom.

Voir aussi

Copie d'enregistrements d'une spécification à une autre

Copie d'enregistrements dans une spécification

Déplacement d'enregistrements dans une spécification


Déplacement de champs d'une spécification à une autre

  1. Cliquez sur le noeud racine dans la spécification contenant le champ que vous voulez déplacer.

  2. Dans le menu Affichage, cliquez sur Développer les éléments de l'arborescence.

  3. Cliquez sur le champ que vous voulez déplacer, puis dans le menu Edition, cliquez sur Couper.

  4. Dans le menu Démarrer, pointez sur Programmes, Microsoft BizTalk Server 2000, puis cliquez sur Éditeur BizTalk.

    Vous devez ouvrir une seconde instance de l'Éditeur BizTalk pour ouvrir une autre spécification.

  5. Dans le menu Fichier, cliquez sur Ouvrir.

  6. Dans la boîte de dialogue Ouvrir la spécification de document, sélectionnez le dossier qui contient la spécification vers laquelle vous voulez déplacer l'enregistrement.

  7. Sélectionnez le fichier dans la liste, puis cliquez sur Ouvrir.

  8. Cliquez sur le noeud racine dans la spécification vers laquelle vous souhaitez déplacer le champ.

  9. Dans le menu Affichage, cliquez sur Développer les éléments de l'arborescence.

  10. Cliquez sur un noeud racine, un enregistrement ou un champ après lequel vous voulez insérer le champ.

  11. Dans le menu Edition, cliquez sur Coller.

Remarque

  • Si vous déplacez un champ qui porte le même nom qu'un champ existant, l'Éditeur BizTalk ajoute automatiquement un chiffre après son nom.

Voir aussi

Copie de champs d'une spécification à une autre

Copie de champs dans une spécification

Déplacement de champs dans une spécification


Copie d'enregistrements dans une spécification

  1. Cliquez sur le noeud racine.

  2. Dans le menu Affichage, cliquez sur Développer les éléments de l'arborescence.

  3. Sélectionnez l'enregistrement que vous voulez copier, puis dans le menu Edition, cliquez sur Copier.

  4. Cliquez sur le noeud après lequel voulez insérer l'enregistrement, puis dans le menu Edition, cliquez sur Coller.

    Si le noeud sélectionné est un enregistrement, un enregistrement enfant est inséré directement après le noeud sélectionné. Si le noeud sélectionné est un champ, un enregistrement frère est inséré directement après le noeud sélectionné.

Voir aussi

Copie d'enregistrements d'une spécification à une autre

Déplacement d'enregistrements d'une spécification à une autre

Déplacement d'enregistrements dans une spécification


Copie de champs dans une spécification

  1. Cliquez sur le noeud racine.

  2. Dans le menu Affichage, cliquez sur Développer les éléments de l'arborescence.

  3. Cliquez sur le champ que vous voulez copier, puis dans le menu Edition, cliquez sur Copier.

  4. Cliquez sur le noeud après lequel voulez insérer le champ, puis dans le menu Edition, cliquez sur Coller.

    Si le noeud sélectionné est un enregistrement, un champ enfant est inséré directement après le noeud sélectionné. Si le noeud sélectionné est un champ, un champ frère est inséré directement après le noeud sélectionné.

Voir aussi

Copie de champs d'une spécification à une autre

Déplacement de champs d'une spécification à une autre

Déplacement de champs dans une spécification


Copie d'enregistrements d'une spécification à une autre

  1. Cliquez sur le noeud racine dans la spécification contenant l'enregistrement que vous voulez copier.

  2. Dans le menu Affichage, cliquez sur Développer les éléments de l'arborescence.

  3. Sélectionnez l'enregistrement que vous voulez copier, puis dans le menu Edition, cliquez sur Copier.

  4. Dans le menu Démarrer, pointez sur Programmes, Microsoft BizTalk Server 2000, puis cliquez sur Éditeur BizTalk.

    Vous devez ouvrir une seconde instance de l'Éditeur BizTalk pour ouvrir une autre spécification.

  5. Dans le menu Fichier, cliquez sur Ouvrir.

  6. Dans la boîte de dialogue Ouvrir la spécification de document, sélectionnez le dossier qui contient la spécification vers laquelle vous voulez déplacer l'enregistrement.

  7. Sélectionnez le fichier dans la liste, puis cliquez sur Ouvrir.

  8. Cliquez sur le noeud racine dans la spécification vers laquelle vous voulez copier l'enregistrement.

  9. Dans le menu Affichage, cliquez sur Développer les éléments de l'arborescence.

  10. Cliquez sur le noeud racine, l'enregistrement ou le champ après lequel vous voulez insérer l'enregistrement, puis dans le menu Edition, cliquez sur Coller.

    Si le noeud sélectionné est un enregistrement, un enregistrement enfant est inséré directement après le noeud sélectionné. Si le noeud sélectionné est un champ, un enregistrement frère est inséré directement après le noeud sélectionné.

Remarque

  • Si vous copiez un enregistrement qui porte le même nom qu'un enregistrement existant, l'Éditeur BizTalk ajoute automatiquement un chiffre après son nom.

Voir aussi

Copie d'enregistrements dans une spécification

Déplacement d'enregistrements d'une spécification à une autre

Déplacement d'enregistrements dans une spécification


Copie de champs d'une spécification à une autre

  1. Cliquez sur le noeud racine dans la spécification contenant le champ que vous voulez copier.

  2. Dans le menu Affichage, cliquez sur Développer les éléments de l'arborescence.

  3. Cliquez sur le champ que vous voulez copier, puis dans le menu Edition, cliquez sur Copier.

  4. Dans le menu Démarrer, pointez sur Programmes, Microsoft BizTalk Server 2000, puis cliquez sur Éditeur BizTalk.

    Vous devez ouvrir une seconde instance de l'Éditeur BizTalk pour ouvrir une autre spécification.

  5. Dans le menu Fichier, cliquez sur Ouvrir.

  6. Dans la boîte de dialogue Ouvrir la spécification de document, sélectionnez le dossier qui contient la spécification vers laquelle vous voulez déplacer le champ.

  7. Sélectionnez le fichier dans la liste, puis cliquez sur Ouvrir.

  8. Cliquez sur le noeud racine dans la spécification vers laquelle vous voulez copier le champ.

  9. Dans le menu Affichage, cliquez sur Développer les éléments de l'arborescence.

  10. Cliquez sur le noeud racine, l'enregistrement ou le champ après lequel vous voulez coller l'enregistrement, puis dans le menu Edition, cliquez sur Coller.

    Si le noeud sélectionné est un enregistrement, un champ enfant est inséré directement après le noeud sélectionné. Si le noeud sélectionné est un champ, un champ frère est inséré directement après le noeud sélectionné.

Remarque

  • Si vous copiez un champ qui porte le même nom qu'un champ existant, l'Éditeur BizTalk ajoute automatiquement un chiffre après son nom.

Voir aussi

Copie de champs dans une spécification

Déplacement de champs d'une spécification à une autre

Déplacement de champs dans une spécification


Affectation d'un nouveau nom à un enregistrement unique

  1. Cliquez sur l'enregistrement que vous voulez renommer.

  2. Dans le menu Edition, cliquez sur Renommer.

  3. Tapez le nouveau nom de l'enregistrement, puis appuyez sur ENTRÉE.

Voir aussi

Affectation de nouveaux noms à tous les enregistrements dont le nom est identique

Affectation d'un nouveau nom à un champ unique


Affectation d'un nouveau nom à un champ unique

  1. Cliquez sur le champ que vous souhaitez renommer.

  2. Dans le menu Edition, cliquez sur Renommer.

  3. Tapez le nouveau nom du champ, puis appuyez sur ENTRÉE.

Remarque

  • Les champs correspondant à des éléments ne peuvent pas porter le même nom qu'un enregistrement existant.

Voir aussi

Affectation de nouveaux noms à tous les enregistrements dont le nom est identique

Affectation d'un nouveau nom à un enregistrement unique


Affectation de nouveaux noms à tous les enregistrements dont le nom est identique

  1. Sélectionnez un enregistrement dont vous voulez modifier le nom.

  2. Dans le menu Edition, cliquez sur Renommer tout.

  3. Tapez un nouveau nom pour les enregistrements.

    Tous les enregistrements dont le nom est identique sont renommés.

Remarque

  • Cette commande est uniquement disponible dans le menu Edition si au moins deux enregistrements portent le même nom.

Voir aussi

Affectation d'un nouveau nom à un champ unique

Affectation d'un nouveau nom à un enregistrement unique


Suppression d'enregistrements

  1. Cliquez sur l'enregistrement que vous voulez supprimer.

  2. Dans le menu Edition, cliquez sur Supprimer.

  3. Dans la boîte de dialogue de confirmation, cliquez sur Oui.

Attention

  • Lorsque vous supprimez un enregistrement, tous les enregistrements et champs enfants sont également supprimés.

Voir aussi

Suppression de champs


Suppression de champs

  1. Cliquez sur le champ que vous voulez supprimer.

  2. Dans le menu Edition, cliquez sur Supprimer.

  3. Dans la boîte de dialogue de confirmation, cliquez sur Oui.

Voir aussi

Suppression d'enregistrements


Création de références circulaires

  1. Sélectionnez un enregistrement sous lequel vous voulez créer une référence circulaire.

    Il s'agit de l'enregistrement de base.

  2. Dans le menu Edition, cliquez sur Nouvel enregistrement.

  3. Affectez au nouvel enregistrement un nom identique à celui de l'enregistrement de base et appuyez sur ENTRÉE.

    Une référence circulaire Icône référence circulaire créée.

  4. Dans l'onglet Déclaration, double-cliquez sur le champ Valeur dans la ligne Nombre de cycles.

  5. Tapez un chiffre compris entre 1 et 7 et appuyez sur ENTRÉE.

Important

  • La propriété Occurrences minimales de l'onglet Référence pour le noeud de référence circulaire doit être définie avec la valeur 0. Une propriété définie avec la valeur 1 entraînera une boucle infinie.

Remarque

  • Les références circulaires ne peuvent pas être utilisées dans les spécifications non-XML. Assurez-vous que vous utilisez une spécification XML.

Voir aussi

Références cycliques


Création d'une nouvelle instance d'un enregistrement unique

  1. Cliquez sur un noeud où vous voulez créer une nouvelle instance d'un enregistrement existant.

  2. Dans le menu Edition, cliquez sur Nouvel enregistrement ou Insérer un enregistrement.

    Remarque

    • Si vous avez sélectionné un champ à l'étape 1, l'option Nouvel enregistrement n'est pas disponible dans le menu Edition.
  3. Affectez au nouvel enregistrement un nom identique à celui de l'enregistrement existant et appuyez sur ENTRÉE.

    Vous venez de créer deux instances du même enregistrement.

Important

  • Vous ne pouvez pas affecter à un nouvel enregistrement un nom identique à celui d'un enregistrement frère.

  • Si vous affectez à un nouvel enregistrement un nom identique à celui d'un enregistrement existant, vous créez une référence circulaire et non pas une nouvelle instance de l'enregistrement existant. Pour plus d'informations, voir Références circulaires.

Remarques

  • Si vous cliquez sur Nouvel enregistrement, la nouvelle instance de l'enregistrement est insérée en tant que descendant de l'enregistrement sélectionné.

  • Si vous cliquez sur Insérer un enregistrement, la nouvelle instance de l'enregistrement est insérée en tant que frère de l'enregistrement ou du champ sélectionné.

  • La structure du noeud sous les instances d'un enregistrement est identique ; si vous supprimez ou ajoutez un noeud à une instance d'un enregistrement, cette modification est automatiquement répercutée dans toutes les autres instances de l'enregistrement. Certaines propriétés d'instances d'enregistrement sont identiques et d'autres peuvent être définies indépendamment pour chacune des instances. Pour plus d'informations sur les propriétés identiques ou indépendantes des instances d'enregistrement, voir Portée des propriétés.

  • Une nouvelle instance d'un enregistrement existant ne peut pas porter le même nom qu'un enregistrement existant.

  • Pour créer une nouvelle instance d'un enregistrement existant vous pouvez aussi appuyer sur CTRL et faire glisser un enregistrement existant vers la partie droite du noeud sous lequel vous voulez insérer la nouvelle instance.

Voir aussi

Références cycliques

Portée des propriétés


Création d'une nouvelle instance d'un champ d'élément existant

  1. Sélectionnez un noeud où vous voulez créer une nouvelle instance d'un champ d'élément.

    Remarque

    • Vous pouvez uniquement créer plusieurs instances de champs de type Élément (sous l'onglet Déclaration). Vous ne pouvez pas créer plusieurs instances de champs de type Attribut. Si vous créez deux champs d'attribut ou plus de nom identique, ces champs demeurent totalement indépendants les uns des autres.
  2. Dans le menu Edition, cliquez sur Nouveau champ ou Insérer un champ.

    Remarque

    • Si vous avez sélectionné un champ à l'étape 1, l'option Nouveau champ n'est pas disponible dans le menu Edition.
  3. Affectez au nouveau champ un nom identique à celui du champ existant et appuyez sur ENTRÉE.

    Vous venez de créer deux instances du même champ.

Important

  • Une nouvelle instance de champ d'élément ne peut pas porter le même nom qu'une instance de champ d'élément frère.

Remarques

  • Si vous cliquez sur Nouveau champ, la nouvelle instance du champ est insérée en tant que descendant de l'enregistrement sélectionné.

  • Si vous cliquez sur Insérer un champ, la nouvelle instance du champ est insérée en tant que frère de l'enregistrement ou du champ sélectionné.

  • Certaines propriétés d'instances de champ sont identiques et d'autres peuvent être définies indépendamment pour chacune des instances. Pour plus d'informations sur les propriétés identiques ou indépendantes des instances de champ, voir Portée des propriétés.

  • Deux champs existants ne peuvent pas porter le même nom, sauf si la propriété Type de l'un est définie avec le paramètre Attribut et celle de l'autre avec Élément.

  • Pour créer une nouvelle instance d'un champ d'élément existant vous pouvez aussi appuyer sur CTRL et faire glisser un champ d'élément existant vers la partie droite du noeud sous lequel vous voulez insérer la nouvelle instance.

Voir aussi

Références cycliques

Portée des propriétés


Spécification de propriétés pour les enregistrements et les champs

Cette section contient des informations sur les rubriques suivantes :

  • Définition des propriétés de déclaration

  • Définition des propriétés de référence

  • Définition des propriétés d'analyse

  • Déclaration des espaces de noms

  • Ajout d'annotations personnalisées

  • Modification d'annotations personnalisées

  • Suppression d'annotations personnalisées

  • Définition des propriétés du dictionnaire

  • Ajout d'une propriété au dictionnaire personnalisé

  • Affectation d'un nouveau nom à une propriété du dictionnaire personnalisé

  • Suppression d'une propriété du dictionnaire

  • Suppression d'une propriété du dictionnaire personnalisé

  • Sélection de codes

  • Suppression de codes

  • Suppression d'une propriété d'un champ dans la colonne Valeur

  • Calcul automatique des positions de champs


Définition des propriétés de déclaration

  1. Dans l'arborescence de la spécification, cliquez sur le noeud racine, l'enregistrement ou le champ pour lequel vous voulez définir une propriété, puis cliquez sur l'onglet Déclaration.

  2. Double-cliquez sur le champ dans la colonne Valeur associée à la propriété que vous voulez définir.

  3. Entrez des données dans le champ ou cliquez sur la flèche BAS pour effectuer une sélection parmi une liste d'options disponibles.

  4. Appuyez sur ENTRÉE pour valider vos modifications.

L'onglet Déclaration contient les propriétés décrites dans les tables ci-après. Les propriétés que vous sélectionnez sont définies pour le noeud racine, pour un enregistrement ou un champ, suivant le noeud que vous avez sélectionné.

Onglet Déclaration : Propriétés du noeud racine

Propriété | Valeur
Définir le nom Nom du noeud racine.

Remarque

Si vous modifiez la valeur Nom sous l'onglet Déclaration, le nom du noeud racine dans l'arborescence de la spécification sera automatiquement modifié en conséquence. Dans une nouvelle spécification, si vous modifiez la valeur Nom sous l'onglet Déclaration, la valeur Nom du schéma sera également modifiée sous l'onglet Référence. Cependant, comme un nom de schéma peut être différent de celui du noeud racine, une modification de la valeur Nom du schéma n'a aucun effet sur la valeur Nom ni sur le nom du noeud racine dans l'arborescence de la spécification. Lorsque la valeur Nom du schéma a été modifiée, une modification de la valeur Nom ou du nom de noeud racine n'a aucun effet sur la valeur Nom du schéma.
Description | Description de la spécification.
Type | Type d'enregistrement.
Modèle Fermé. Indique que les données contenues dans l'instance de document et la structure de la spécification correspondent.

Ouvert. Indique que les données contenues dans l'instance de document ne correspondent pas totalement à la structure de la spécification.

  • Si aucune valeur n'est indiquée pour cette propriété, la valeur par défaut est Ouvert.
Contenu Élément seul. Indique que le noeud racine peut uniquement contenir des éléments. Il s'agit de la valeur par défaut lorsque la racine contient un enregistrement enfant.

Vide. Indique que le noeud racine ne peut pas contenir de sous-éléments.

Texte seul. Indique que le noeud racine peut contenir du texte mais pas de sous-éléments.

Remarque

  • L'Éditeur BizTalk ne prend pas en charge les éléments qui contiennent un contenu mixte (informations de texte et sous-éléments).
Ordre Sélectionnez l'une des valeurs suivantes :
  • Un. Indique qu'un seul des éléments constitutifs peut apparaître.

  • Séquence. Indique que les éléments constitutifs doivent apparaître dans l'ordre spécifié.

  • Plusieurs. Indique que plusieurs éléments constitutifs peuvent apparaître, quel que soit l'ordre sélectionné.

Onglet Déclaration : Propriétés des enregistrements

Propriété | Valeur
Définir le nom | Nom de l'enregistrement.
Description | Description de l'enregistrement.
Type | Type d'enregistrement.
Modèle Fermé. Indique que les données contenues dans l'instance de document et la structure de la spécification correspondent.

Ouvert. Indique que les données contenues dans l'instance de document et la structure de la spécification ne correspondent pas.

  • Si aucune valeur n'est indiquée pour cette propriété, la valeur par défaut est Ouvert.
Contenu Élément seul. Indique que l'enregistrement peut uniquement contenir des éléments. Il s'agit de la valeur par défaut lorsque l'enregistrement contient un enregistrement enfant.

Vide. Indique que l'enregistrement ne peut pas contenir de sous-éléments.

Texte seul. Indique que l'enregistrement peut contenir du texte mais pas de sous-éléments.

Remarque

L'Éditeur BizTalk ne prend pas en charge les éléments qui contiennent un contenu mixte (informations de texte et sous-éléments).
Ordre Sélectionnez l'une des valeurs suivantes :
  • Un. Indique qu'un seul des éléments constitutifs peut apparaître.

  • Séquence. Indique que les éléments constitutifs doivent apparaître dans l'ordre spécifié.

  • Plusieurs. Indique que plusieurs éléments constitutifs peuvent apparaître, quel que soit l'ordre sélectionné.
Nombre de cycles Entrez le nombre de cycles qui seront disponibles sous l'enregistrement de base. Pour plus d'informations, voir Références circulaires.

Remarque

  • Ce champ de propriété s'affiche uniquement si vous avez créé une référence circulaire.

Onglet Déclaration : Propriétés des champs

Propriété | Valeur
Définir le nom | Nom du serveur.
Description | Description du champ.
Type Sélectionnez l'une des valeurs suivantes :
  • Élément

  • Attribut
Modèle Fermé. Indique que les données contenues dans l'instance de document et la structure de la spécification correspondent.

Ouvert. Indique que les données contenues dans l'instance de document et la structure de la spécification ne correspondent pas.

Remarque

  • Si aucune valeur n'est indiquée pour cette propriété, la valeur par défaut est Ouvert.

  • La propriété Modèle est disponible uniquement pour un champ dont la valeur Type est définie sur Élément.
Contenu Texte seul. Indique que l'enregistrement peut contenir du texte mais pas de sous-éléments.

Remarque

  • La propriété Contenu est disponible uniquement pour un champ dont la valeur Type est définie sur Élément.

  • Texte seul est la seule valeur disponible pour la propriété Contenu d'un champ.
Type de données Type de données valide. Pour obtenir la liste et la description de tous les types de données valides, voir Synthèse des types de données et des valeurs de types de données.

Important

  • Si la valeur de la propriété Standard sous l'onglet Référence est définie sur X12, EDIFACT ou Personnalisé, vous pouvez affecter une valeur Type de données personnalisé sous l'onglet Analyse. Si vous spécifiez une valeur Type de données personnalisé, la valeur dans le champ Type de données est automatiquement modifiée afin qu'elle corresponde à la valeur Type de données personnalisé que vous avez sélectionnée. Si une valeur est déjà spécifiée dans le champ Type de données personnalisé et si vous en spécifiez une dans le champ Type de données sous l'onglet Déclaration, la valeur du champ Type de données personnalisé est supprimée.

  • Dans une spécification, si vous créez un champ avec la propriété Type de données définie sur IDREF ou IDREFS, vous devez en créer un autre dans cette spécification avec le champ Type de données défini sur ID.

  • Pour sélectionner un champ pour le suivi ou l'utilisation d'une expression de filtrage dans le Gestionnaire d'échanges BizTalk, vous devez affecter un type de données à ce champ dans la spécification.
Valeurs des types de données Si vous sélectionnez Énumération dans la liste Type de données, les valeurs de type de données "a b c" s'affichent par défaut dans la zone Valeurs des types de données. Les valeurs par défaut peuvent être remplacées par des valeurs personnalisées séparées par des espaces.

Si vous utilisez un document X12 ou EDIFACT et intégrez des codes associés à un champ spécifique, ces codes s'affichent automatiquement dans la zone Valeurs de type de données, et la propriété Énumération s'affiche automatiquement dans la zone Type de données.
Longueur minimale Nombre minimal de caractères pouvant être contenus dans le champ.

Remarque

  • La propriété Longueur minimale peut uniquement être définie pour les champs dont les valeurs Type de données sont les suivantes : Chaîne, Nombre, Binaire (base64) et Binaire (hex).
Longueur maximale Nombre maximal de caractères pouvant être contenus dans le champ.

Remarque

  • La propriété Longueur maximale peut uniquement être définie pour les champs dont les valeurs Type de données sont les suivantes : Chaîne, Nombre, Binaire (base64) et Binaire (hex).
Valeur par défaut Valeur fournie si le document entrant ne contient pas de champ. Pour plus d'informations, voir Intégration des valeurs par défaut.

Remarque

  • La propriété Valeur par défaut s'affiche uniquement dans les spécifications si la propriété Standard (sous l'onglet Référence pour le noeud racine) est définie sur XML, et la propriété Type (sous l'onglet Déclaration pour le champ) est définie sur Attribut.

Voir aussi

Ajout d'une expression de filtrage à un canal

Références cycliques

Intégration des valeurs par défaut

Sélection des champs de spécification dans un canal

Sélection de champs de spécification dans une définition de document

Résumé des types de données et des valeurs de types de données


Définition des propriétés de référence

  5. Dans l'arborescence de la spécification, cliquez sur le noeud racine, l'enregistrement ou le champ pour lequel vous voulez définir une propriété, puis cliquez sur l'onglet Référence.

  6. Double-cliquez sur le champ dans la colonne Valeur associée à la propriété que vous voulez définir.

  7. Entrez des données dans le champ de la colonne Valeur ou cliquez sur la flèche BAS pour effectuer une sélection parmi une liste d'options disponibles.

L'onglet Référence contient les propriétés décrites dans les tables ci-après. Les propriétés que vous sélectionnez sont définies pour le noeud racine, pour un enregistrement ou un champ, suivant le noeud que vous avez sélectionné.

Onglet Référence : Propriétés du noeud racine

Propriété | Valeur
Nom de la spécification | Nom de la spécification. Celui-ci correspond à la valeur de la balise <Schema> dans la spécification.
Standard Sélectionnez l'une des valeurs suivantes :
  • XML pour créer une spécification XML (Extensible Markup Language).

  • X12 pour créer une spécification X12.

  • EDIFACT pour créer une spécification EDIFACT.

  • Personnalisé pour créer une spécification basée sur un fichier plat ou pour créer une spécification personnalisée à analyser avec un parseur personnalisé.
Version du Standard | Version du standard, telle que la version X12 4010, sur laquelle est basée la spécification.
Type de document | Type de document, tel que 850, sur lequel est basée la spécification.
Version | Numéro de version du standard de document sur lequel est basée la spécification.
Délimiteur d'enregistrement par défaut Entrez ou sélectionnez un caractère à utiliser comme délimiteur par défaut dans les noeuds pour lesquels la propriété Type de délimiteur sous l'onglet Analyse est définie sur Délimiteur d'enregistrement par défaut.

Remarque

  • Le champ de cette propriété s'affiche uniquement si le champ Standard dans l'onglet Référence (pour le noeud racine) correspond à Personnalisé.
Délimiteur de champ par défaut Entrez ou sélectionnez un caractère à utiliser comme délimiteur par défaut dans les noeuds pour lesquels la propriété Type de délimiteur sous l'onglet Analyse est définie sur Délimiteur de champ par défaut.

Remarque

  • Le champ de cette propriété s'affiche uniquement si le champ Standard dans l'onglet Référence (pour le noeud racine) correspond à Personnalisé.
Délimiteur de sous-champ par défaut Entrez ou sélectionnez un caractère à utiliser comme délimiteur par défaut dans les noeuds pour lesquels la propriété Type de délimiteur sous l'onglet Analyse est définie sur Délimiteur de sous-champ par défaut.

Remarque

  • Le champ de cette propriété s'affiche uniquement si le champ Standard dans l'onglet Référence (pour le noeud racine) correspond à Personnalisé.
Caractère d'échappement par défaut Entrez ou sélectionnez un caractère à utiliser comme caractère d'échappement par défaut dans les noeuds pour lesquels la propriété Type d'échappement sous l'onglet Analyse est définie sur Caractère d'échappement par défaut.

Remarque

  • Le champ de cette propriété s'affiche uniquement si le champ Standard dans l'onglet Référence (pour le noeud racine) correspond à Personnalisé.
Page de code Sélectionnez l'une des options suivantes :
  • Arabe (1256)

  • Balte (1257)

  • Europe centrale (1250)

  • Cyrillique (1251)

  • Grec (1253)

  • Hébreux (1255)

  • Japonais-Maj-JIS (932)

  • Coréen (949)

  • Little-Endian-UTF16 (1200)

  • Chinois simplifié-GBK (936)

  • Thaï 874

  • Chinois-tra-Big5 (950)

  • Turc (1254)

  • Vietnamien (1258)

  • Europe de l'Ouest (1252)

Remarque

  • Le champ de cette propriété s'affiche uniquement si le champ Standard dans l'onglet Référence (pour le noeud racine) correspond à Personnalisé.

  • BizTalk Server ne prend pas en charge les options UTF7 (65000) et UTF8 (65001).

  • Si aucune valeur Code Page n'est indiquée, la valeur par défaut est Europe de l'Ouest (1252).
Accusé de réception Choisissez une des options suivantes :
  • Oui. Indique que la spécification doit être utilisée comme accusé de réception d'un document entrant. Un composant de corrélation X12, EDIFACT ou PERSONNALISÉ) doit effectuer une corrélation entre l'accusé de réception du document et le document sortant approprié (c'est-à-dire le document envoyé précédemment à l'expéditeur de l'accusé de réception).

  • Non. Indique que la spécification ne doit pas être utilisée comme accusé de réception d'un document entrant.

Remarques

  • Si la valeur d'accusé de réception est vide, la valeur par défaut est Non.

  • Pour les spécifications basées sur l'accusé de réception standard, et pour celles qui sont mappées sur l'accusé de réception standard (ces spécifications sont utilisées dans les scénarios de génération d'accusé de réception d'un document sortant), la propriété Accusé de réception doit être définie sur Non.
Enveloppe Choisissez une des options suivantes :
  • Oui. Indique que la spécification est une spécification d'échange.

  • Non. Indique que la spécification n'est pas une spécification d'échange.
Espace de noms cible Si vous disposez d'une instance BizTalk Framework et si vous avez spécifié un espace de noms dans celle-ci, vous devez entrer l'espace de noms correspondant utilisé dans l'instance.

Remarque

  • La valeur d'espace de noms cible "x-schema" d'une instance peut entraîner une erreur lors du test de l'instance dans le Mappeur BizTalk.

Onglet Référence : Propriétés des enregistrements

Propriété Valeur
Occurrences minimales Nombre d'occurrences minimales d'un enregistrement à son emplacement dans la hiérarchie du noeud. Les valeurs possibles sont 0 et 1.

Remarque

  • Si aucune valeur n'est indiquée pour cette propriété, la valeur par défaut est 1.
Occurrences maximales Nombre d'occurrences maximales d'un enregistrement à son emplacement dans la hiérarchie du noeud. Les valeurs possibles sont 1 et *.

Remarque

  • Si vous entrez un astérisque (*), l'enregistrement est considéré comme un enregistrement de bouclage. Si cette spécification est utilisée dans le Mappeur BizTalk, celle-ci compile l'enregistrement en tant que boucle. Si vous entrez 1, le Mappeur BizTalk ne considère pas cet enregistrement comme un enregistrement de bouclage.

  • Si aucune valeur n'est indiquée pour cette propriété, la valeur par défaut est 1.

Onglet Référence : Propriétés des champs

Propriété Valeur
Obligatoire Choisissez une des options suivantes :
  • Oui. Indique que le champ est requis.

  • Non. Indique que le champ n'est pas requis.

  • Si aucune valeur n'est indiquée pour cette propriété, la valeur par défaut est Non.
Position de début Nombre indiquant la position de début du champ dans l'enregistrement.

Remarque

  • Le champ de cette propriété s'affiche uniquement si la structure de l'enregistrement parent est positionnelle.
Position de fin Nombre indiquant la position de fin du champ dans l'enregistrement.

Remarque

  • Le champ de cette propriété s'affiche uniquement si la structure de l'enregistrement parent est positionnelle.

Voir aussi

Calcul des positions des champs

Description des accusés de réception


Définition des propriétés d'analyse

  1. Dans l'arborescence de la spécification, cliquez sur le noeud racine, l'enregistrement ou le champ pour lequel vous voulez définir une propriété, puis cliquez sur l'onglet Analyse.

  2. Double-cliquez sur le champ dans la colonne Valeur associée à la propriété que vous voulez définir.

  3. Entrez des données dans le champ ou cliquez sur la flèche BAS pour effectuer une sélection parmi une liste d'options disponibles.

L'onglet Analyse contient les propriétés décrites dans les tables ci-après. Les propriétés disponibles dépendent du standard (X12, EDIFACT ou Personnalisé) et de la propriété de la structure utilisés. Par défaut, les nouvelles spécifications basées sur une spécification vide possèdent une propriété du standard Extensible Markup Language (XML).Pour chaque propriété, entrez la valeur appropriée. Les propriétés que vous sélectionnez sont définies pour le noeud racine, pour un enregistrement ou un champ, suivant le noeud que vous avez sélectionné.

Standard : XML

Onglet Analyse : Noeud racine, enregistrement et propriétés du champ.

Ces propriétés ne s'affichent pas.

Standard : X12 ou EDIFACT

Important

  • Les valeurs Retour de ligne, Caractères tampon, Caractères d'échappement et Délimiteur d'un enregistrement et de ses champs enfants s'excluent mutuellement.

  • Il est important de vérifier que le caractère de retour à la ligne est différent du caractère d'échappement.

Onglet Analyse : Noeud racine ou propriétés de l'enregistrement

Propriété Valeur
Structure Par défaut, cette valeur est définie sur Délimité pour le noeud racine.

Remarque

  • Si la valeur de la propriété Standard est définie sur X12 ou EDIFACT sous l'onglet Référence pour le noeud racine d'une spécification, vous ne pouvez pas modifier la valeur de la propriété Structure sous l'onglet Analyse pour le noeud racine ou les enregistrements. Pour modifier la valeur de la propriété Structure, vous devez définir le standard sur PERSONNALISÉ.
Identifiant de la balise source Le nom de l'identifiant de la balise source. Correspond au nom de balise utilisé pour faire correspondre l'enregistrement avec les données.

Remarque

  • Dans le cas d'un fichier non-XML, comme un fichier plat, vous pouvez introduire une propriété Identificateur de la balise source pour identifier n'importe quelle balise pouvant exister dans le fichier d'origine.

  • La propriété Identificateur de la balise source respecte la casse.
Ordre des champs Sélectionnez l'une des options suivantes :
  • Préfixe. Un préfixe délimiteur s'affiche avant chaque composant et chaque membre d'un composant dans une série. Par exemple, où * est le délimiteur : *a*a*b*c.

  • Postfix. Un postfix délimiteur s'affiche après chaque composant et chaque membre d'un composant dans une série. Par exemple, où * est le délimiteur : a*a*b*c*.

  • Infix. Un infix délimiteur s'affiche entre les composants et membres des composants d'une série. Par exemple, où * est le délimiteur : a*a*b*c. Il s'agit de l'ordre inhérent pour tous les documents EDI.

Remarque

  • Si aucune valeur n'est indiquée pour Ordre des champs, la valeur par défaut est Préfixe.
Type de délimiteur Sélectionnez l'une des options suivantes pour définir un délimiteur pour les noeuds enfants situés directement sous le noeud en cours :
  • Délimiteur d'enregistrement par défaut Indique que le délimiteur correspond à la valeur de la propriété Délimiteur d'enregistrement par défaut, définie dans l'instance du document.

  • Délimiteur de champ par défaut Indique que le délimiteur correspond à la valeur de la propriété Délimiteur de champ par défaut, définie dans l'instance du document.

  • Délimiteur de sous-champ par défaut Indique que le délimiteur correspond à la valeur de la propriété Délimiteur de sous-champ par défaut, définie dans l'instance du document.
Type d'échappement

(Également appelé caractère d'échappement)

 Sélectionnez l'une des options suivantes pour définir un caractère d'échappement pour les noeuds enfants situés directement sous le noeud en cours :
  • Caractère d'échappement par défaut Indique que le caractère d'échappement est une valeur définie dans l'instance du document.

Cette propriété est utile lorsqu'un caractère d'échappement de vos données de champ est également utilisé en guise de caractère de délimiteur pour le noeud parent du champ. Par exemple, si vos données de champ sont

Browne,Peter,1231,yes

et que vous avez choisi une virgule en guise de valeur de délimiteur pour le noeud contenant le champ, l'Éditeur BizTalk interprète la virgule située après « Browne » comme un délimiteur, même si vous voulez que cette virgule fasse partie des données du champ. Pour résoudre ce problème, vous pouvez faire précéder d'un caractère d'échappement le caractère délimiteur que vous voulez inclure dans les données du champ. Par exemple, si le caractère d'échappement spécifié correspond à une barre oblique inverse, vous pouvez faire précéder le caractère délimiteur d'une barre oblique inverse, comme suit :

Browne\,Peter,1231,yes

L'Éditeur BizTalk interprète la virgule située après la barre oblique inverse comme des données du champ plutôt que comme un caractère délimiteur.

Remarque

  • La propriété Type d'échappement n'est pas disponible pour les spécifications X12.
Ajout d'une nouvelle ligne Sélectionnez l'une des options suivantes :
  • Oui. Indique que lorsque le sérialiseur atteint le délimiteur d'enregistrement, il doit ajouter automatiquement une nouvelle ligne (LF,0x0A).

  • Non. Indique que lorsque le sérialiseur atteint le délimiteur d'enregistrement, il doit continuer sur la même ligne pour l'enregistrement suivant.

Remarque

  • Si aucune valeur n'est indiquée pour Ajouter une nouvelle ligne, la valeur par défaut est Non.
Ignorer le retour chariot Sélectionnez l'une des options suivantes :
  • Oui. Indique au parseur d'ignorer le caractère de retour chariot (RC) situé après un délimiteur.

  • Non. Indique au parseur qu'il ne doit pas ignorer la valeur Retour chariot après un délimiteur.

Remarque

  • Si aucune valeur n'est indiquée pour Ignorer le retour chariot, la valeur par défaut est Oui.
Ignorer le saut de ligne Sélectionnez l'une des options suivantes :
  • Oui. Indique au parseur qu'il doit ignorer la valeur Saut de ligne après un délimiteur.

  • Non. Indique au parseur qu'il ne doit pas ignorer la valeur Saut de ligne après un délimiteur.

Remarque

  • Si aucune valeur n'est indiquée pour Saut de ligne, la valeur par défaut est Oui.
Ignorer le nombre d'enregistrements Sélectionnez l'une des options suivantes :
  • Oui. Indique au parseur ou au sérialiseur qu'il ne doit pas compter cet enregistrement lors du calcul du nombre total d'enregistrements dans la spécification.

  • Non. Indique au parseur ou au sérialiseur qu'il doit compter cet enregistrement lors du calcul du nombre total d'enregistrements dans la spécification.

Remarques

  • Une erreur d'analyse se produit lorsqu'une instance de document est soumise à BizTalk Server, si le nombre d'enregistrements de l'instance du document ne correspond pas au nombre d'enregistrements calculés dans la spécification. Pour plus d'informations, voir Erreurs d'analyse.

  • Si aucune valeur n'est indiquée pour Ignorer le nombre d'enregistrements, la valeur par défaut est Oui.

Onglet Analyse : Propriétés des champs

Propriété | Valeur
Type de données personnalisé Sélectionnez l'une des options suivantes :
  • Chaîne (AN). AN correspond aux champs alphanumériques.

  • Hexadécimal binaire (B). B correspond aux champs binaires.

  • Date (CA). CA correspond aux champs de dates à quatre chiffres.

  • Nombre (D0-D4). D0 à D4 (inclus) correspondent aux champs décimaux. Le nombre à un seul chiffre représente le nombre de décimales à droite de la virgule.

  • Date (DT). DT correspond aux champs de date.

  • Chaîne (ID). ID correspond aux champs d'identification.

  • Nombre (N). N correspond aux champs d'entiers.

  • Nombre (N0-9). N0 à N9 (inclus) correspondent aux champs décimaux implicites (le caractère décimal n'apparaît pas dans les données). Le nombre à un seul chiffre représente le nombre de décimales à droite de la virgule.

  • Nombre (R). R correspond aux champs numériques.

  • Nombre (R0-R9). R0 à R9 (inclus) correspondent aux champs numériques réels. Le nombre à un seul chiffre représente le nombre de décimales à droite de la virgule.

  • Heure (TM). TM correspond aux champs d'heure.

Important

  • Si vous spécifiez une valeur Type de données personnalisé, la valeur dans le champ Type de données sous l'onglet Déclaration est automatiquement modifiée afin de correspondre à la valeur Type de données personnalisé que vous avez sélectionnée. Par exemple, si vous remplacez la valeur Type de données Personnalisé par Date (CA) sous l'onglet Analyse, la valeur Type de données est automatiquement remplacée par Date sous l'onglet Déclaration. Si vous indiquez une valeur dans le champ Type de données sous l'onglet Déclaration, la valeur spécifiée dans le champ Type de données personnalisé est annulée.

Remarques

  • Si vous spécifiez des valeurs Date (DT), Date (CA) ou Heure (TM) pour la propriété Type de données personnalisé, vous devez également définir une valeur pour la propriété Format Date/Heure personnalisé.

  • Toutes les valeurs de type de données personnalisé sont prises en charge dans les spécifications dont la propriété Standard est définie sur X12. Pour les spécifications dont la propriété Standard est définie sur EDIFACT, les valeurs de type de données personnalisé prises en charge sont Chaîne (AN) et Nombre (N).
Date/Format d'heure personnalisés Si vous définissez les valeurs Date (DT), Date (CA) ou Heure (TM) comme propriété Type de données personnalisé, cliquez sur une option dans la liste.

Remarque

  • Ce champ est disponible uniquement si la valeur Type de données personnalisé correspond à Date (DT), Date (CA) ou Heure (TM).
Justification Sélectionnez l'une des options suivantes :
  • Gauche Aligne les données sur la gauche dans les fichiers positionnels lorsque leur longueur est inférieure à la longueur maximale du champ. Aligne également les données sur la gauche dans les fichiers délimités lorsque la date est inférieure à la longueur minimale du champ.

  • Droite. Aligne les données sur la droite dans les fichiers positionnels.

Remarque

  • Si aucune valeur de Justification n'est indiquée, la valeur par défaut est Gauche.
Caractère tampon | Tapez un caractère pour définir le champ tampon. Vous pouvez choisir n'importe quel caractère en guise de caractère tampon, y compris un espace ou un zéro. Pour plus d'informations, voir Caractères tampon.
Caractère de retour ligne Tapez un caractère pour délimiter les données du champ. Cette propriété est utile lorsqu'un caractère de vos données de champ est également utilisé en guise de valeur de délimiteur pour le noeud parent du champ. Par exemple, si vos données de champ sont

Browne,Peter,1231,yes

et que vous avez choisi une virgule en guise de valeur de délimiteur pour le noeud contenant le champ, l'Éditeur BizTalk interprète la virgule située après « Browne » comme un délimiteur, même si vous voulez que cette virgule fasse partie des données du champ. Pour résoudre ce problème, vous devez définir une valeur pour la propriété du caractère de retour à la ligne, puis délimiter les données du champ dans celui-ci. Par exemple, vous pouvez définir des guillemets doubles comme caractères de retour à la ligne pour le premier champ, puis taper vos données de champ comme dans l'exemple suivant :

"Browne,Peter",1231,yes

L'Éditeur BizTalk interprète dans ce cas la virgule située entre les guillemets doubles comme faisant partie des données du champ et non comme une valeur de délimiteur.

Remarques

  • Si vos données de champ comportent des caractères qui sont également utilisés comme caractères de retour à la ligne, vous devez les délimiter dans d'autres jeux de caractères de retour à la ligne.

    Par exemple, lorsque des guillemets doubles sont définis comme caractères de retour à la ligne,

    "Browne,Peter ""Pete"""

    est analysé par l'Éditeur BizTalk pour apparaître sous la forme

    Browne,Peter "Pete"

  • Si les données de champ d'une instance de document d'entrée contiennent le caractère de saut de ligne suivi directement par le caractère de retour chariot, les données de champ correspondantes de l'instance de document de sortie contiennent uniquement le caractère de saut de ligne, même si tous deux sont inclus dans un ensemble de caractères de retour à la ligne.
Longueur minimale avec des caractères tampon Longueur minimale d'un champ dans une instance de document de sortie, caractères tampon inclus. Pour plus d'informations sur les caractères tampon, voir Caractères tampon.

Remarques

  • Cette propriété est uniquement disponible si le caractère de retour à la ligne est défini pour ce champ.

  • Si la propriété Longueur minimale de l'onglet Déclaration est définie pour le champ, la propriété Longueur minimale avec des caractères tampon doit être supérieure ou égale à la valeur de la propriété Longueur minimale. Si la propriété Longueur minimale n'est pas définie, la propriété Longueur minimale avec des caractères tampon doit être supérieure ou égale à un.

Standard : Personnalisé
Propriété de structure : Délimité

Important

  • Les valeurs Retour de ligne, Caractères tampon, Caractères d'échappement et Délimiteur d'un enregistrement et de ses champs enfants s'excluent mutuellement.

  • Il est important de vérifier que le caractère de retour à la ligne est différent du caractère d'échappement.

Onglet Analyse : Noeud racine ou propriétés de l'enregistrement

Propriété | Valeur
Structure Sélectionnez l'option suivante pour la propriété Noeud racine :
  • Délimité. Indique que le noeud racine est basé sur une structure de fichier délimité. Les enregistrements peuvent être basés individuellement sur des structures de fichier délimité ou positionnel.

Sélectionnez l'une des options suivantes pour les propriétés Enregistrement :

  • Délimité. Indique que l'enregistrement est basé sur une structure de fichier délimité. Les enregistrements descendants peuvent être basés individuellement sur des structures de fichier délimité ou positionnel.

  • Positionnel. Indique que l'enregistrement est basé sur une structure de fichier positionnel. Les enregistrements positionnels ne peuvent posséder d'enregistrements enfants.

Remarques

  • Pour qu'un document soit délimité et positionnel, la propriété Structure du noeud racine doit être définie sur Délimité. Vous pouvez, si nécessaire, définir la propriété Structure d'enregistrements individuels sur Positionnel ou Délimité.

  • Si vous changez de structure, un message s'affiche. Cliquez sur Oui pour confirmer la modification de structure. Certaines nouvelles propriétés peuvent apparaître, tandis que des propriétés existantes peuvent avoir été supprimées.

  • Si vous cliquez avec le bouton droit sur le champ de valeur de la propriété Structure d'un enregistrement positionnel et cliquez sur Supprimer la propriété, l'Éditeur BizTalk interprète la structure de l'enregistrement en tant que structure délimitée. Certaines nouvelles propriétés peuvent apparaître, tandis que des propriétés existantes peuvent avoir été supprimées.

  • Lorsque la propriété Standard d'un document est définie sur Personnalisé, la propriété Structure du noeud racine et de tous les enregistrements est vide par défaut. Si vous laissez la propriété Structure vide, sa valeur est Délimité.
Identifiant de la balise source Le nom de l'identifiant de la balise source. Correspond au nom de balise utilisé pour faire correspondre l'enregistrement avec les données.

Remarque

  • Dans le cas d'un fichier non-XML, comme un fichier plat, vous pouvez introduire une propriété Identificateur de la balise source pour identifier n'importe quelle balise pouvant exister dans le fichier d'origine.

  • La propriété Identificateur de la balise source respecte la casse.
Ordre des champs Sélectionnez l'une des options suivantes :
  • Préfixe. Un préfixe délimiteur s'affiche avant chaque composant et chaque membre d'un composant dans une série. Par exemple, où * est le délimiteur : *a*a*b*c.

  • Postfix. Un postfix délimiteur s'affiche après chaque composant et chaque membre d'un composant dans une série. Par exemple, où * est le délimiteur : a*a*b*c*.

  • Infix. Un infix délimiteur s'affiche entre les composants et membres des composants d'une série. Par exemple, où * est le délimiteur : a*a*b*c. Il s'agit de l'ordre inhérent pour tous les documents d'échanges de données électroniques (EDI).

Remarque

  • Si aucune valeur n'est indiquée pour l'ordre des champs, la valeur par défaut est Préfixe.
Type de délimiteur Sélectionnez l'une des options suivantes pour définir un délimiteur pour les noeuds enfants situés directement sous le noeud en cours :
  • Caractère. Vous permet de désigner une valeur de délimiteur sous l'onglet Analyse. Si vous sélectionnez Caractère, vous devez spécifier une valeur de délimiteur.

  • Délimiteur d'enregistrement par défaut Indique que le délimiteur correspond à la valeur de la propriété Délimiteur d'enregistrement par défaut, définie sous l'onglet Référence pour le noeud racine.

  • Délimiteur de champ par défaut Indique que le délimiteur correspond à la valeur de la propriété Délimiteur de champ par défaut, définie sous l'onglet Référence pour le noeud racine.

  • Délimiteur de sous-champ par défaut Indique que le délimiteur correspond à la valeur de la propriété Délimiteur de sous-champ par défaut, définie sous l'onglet Référence pour le noeud racine.
Valeur du délimiteur | Tapez ou sélectionnez une valeur de caractère pour le délimiteur. Pour spécifier une valeur de délimiteur, vous devez tout d'abord définir la propriété Type de délimiteur avec le paramètre Caractère sous l'onglet Analyse.
Type d'échappement

(Également appelé caractère d'échappement)

 Sélectionnez l'une des options suivantes pour définir un caractère d'échappement pour les noeuds enfants situés directement sous le noeud en cours :
  • Caractère. Vous permet de désigner une valeur de caractère d'échappement sous l'onglet Analyse. Si vous sélectionnez Caractère, vous devez spécifier une valeur d'échappement.

  • Caractère d'échappement par défaut Indique que le caractère d'échappement correspond à la valeur de la propriété Caractère d'échappement par défaut, définie sous l'onglet Référence pour le noeud racine.

Cette propriété est utile lorsqu'un caractère d'échappement de vos données de champ est également utilisé en guise de caractère de délimiteur pour le noeud parent du champ. Par exemple, si vos données de champ sont

Browne,Peter,1231,yes

et que vous avez choisi une virgule en guise de valeur de délimiteur pour le noeud contenant le champ, l'Éditeur BizTalk interprète la virgule située après « Browne » comme un délimiteur, même si vous voulez que cette virgule fasse partie des données du champ. Pour résoudre ce problème, vous pouvez faire précéder d'un caractère d'échappement le caractère délimiteur que vous voulez inclure dans les données du champ. Par exemple, si le caractère d'échappement spécifié correspond à une barre oblique inverse, vous pouvez faire précéder le caractère délimiteur d'une barre oblique inverse, comme suit :

Browne\,Peter,1231,yes

L'Éditeur BizTalk interprète la virgule située après la barre oblique inverse comme des données du champ plutôt que comme un caractère délimiteur.
Valeur d'échappement | Tapez ou sélectionnez une valeur de caractère pour le caractère d'échappement. Pour spécifier une valeur de caractère d'échappement, vous devez tout d'abord définir la propriété Type d'échappement avec le paramètre Caractère sous l'onglet Analyse.
Ajout d'une nouvelle ligne Sélectionnez l'une des options suivantes :
  • Oui. Indique que lorsque le parseur atteint le délimiteur d'enregistrement, il doit passer à la ligne suivante et commencer sur celle-ci avec l'enregistrement suivant.

  • Non. Indique que lorsque le parseur atteint le délimiteur d'enregistrement, il doit continuer sur la même ligne pour l'enregistrement suivant.

Remarque

  • Si aucune valeur n'est indiquée pour Ajouter une nouvelle ligne, la valeur par défaut est Non.
Ignorer le retour chariot Sélectionnez l'une des options suivantes :
  • Oui. Indique au parseur d'ignorer le caractère de retour chariot (RC) situé après un délimiteur.

  • Non. Indique au parseur qu'il ne doit pas ignorer la valeur Retour chariot après un délimiteur.

Remarque

  • Si aucune valeur n'est indiquée pour Ignorer le retour chariot, la valeur par défaut est Oui.
Ignorer le saut de ligne Sélectionnez l'une des options suivantes :
  • Oui. Indique au parseur qu'il doit ignorer la valeur Saut de ligne après un délimiteur.

  • Non. Indique au parseur qu'il ne doit pas ignorer la valeur Saut de ligne après un délimiteur.

Remarque

  • Si aucune valeur n'est indiquée pour Saut de ligne, la valeur par défaut est Oui.
Ignorer le nombre d'enregistrements Sélectionnez l'une des options suivantes :
  • Oui. Indique au parseur ou au sérialiseur qu'il ne doit pas compter cet enregistrement lors du calcul du nombre total d'enregistrements dans la spécification.

  • Non. Indique au parseur ou au sérialiseur qu'il doit compter cet enregistrement lors du calcul du nombre total d'enregistrements dans la spécification.

Remarques

  • Une erreur d'analyse se produit lorsqu'une instance de document est soumise à BizTalk Server, si le nombre d'enregistrements de l'instance du document ne correspond pas au nombre d'enregistrements calculés dans la spécification. Pour plus d'informations, voir Erreurs d'analyse.

  • Si aucune valeur n'est indiquée pour Ignorer le nombre d'enregistrements, la valeur par défaut est Oui.

Onglet Analyse : Propriétés des champs

Propriété | Valeur
Type de données personnalisé Sélectionnez l'une des options suivantes :
  • Chaîne (AN). AN correspond aux champs alphanumériques.

  • Hexadécimal binaire (B). B correspond aux champs binaires.

  • Date (CA). CA correspond aux champs de dates à quatre chiffres.

  • Nombre (D0-D4). D0 à D4 (inclus) correspondent aux champs décimaux. Le nombre à un seul chiffre représente le nombre de décimales à droite de la virgule.

  • Date (DT). DT correspond aux champs de date.

  • Chaîne (ID). ID correspond aux champs d'identification.

  • Nombre (N). N correspond aux champs d'entiers.

  • Nombre (N0-9). N0 à N9 (inclus) correspondent aux champs décimaux implicites (le caractère décimal n'apparaît pas dans les données). Le nombre à un seul chiffre représente le nombre de décimales à droite de la virgule.

  • Nombre (R). R correspond aux champs numériques.

  • Nombre (R0-R9). R0 à R9 (inclus) correspondent aux champs numériques réels. Le nombre à un seul chiffre représente le nombre de décimales à droite de la virgule.

  • Heure (TM). TM correspond aux champs d'heure.

Important

  • Si vous spécifiez une valeur Type de données personnalisé, la valeur dans le champ Type de données sous l'onglet Déclaration est automatiquement modifiée afin de correspondre à la valeur Type de données personnalisé que vous avez sélectionnée. Par exemple, si vous remplacez la valeur Type de données Personnalisé par Date (CA) sous l'onglet Analyse, la valeur Type de données est automatiquement remplacée par Date sous l'onglet Déclaration. Si vous indiquez une valeur dans le champ Type de données sous l'onglet Déclaration, la valeur spécifiée dans le champ Type de données personnalisé est annulée.

Remarques

  • Si vous spécifiez des valeurs Date (DT), Date (CA) ou Heure (TM) pour la propriété Type de données personnalisé, vous devez également définir une valeur pour la propriété Format Date/Heure personnalisé.
Date/Format d'heure personnalisés Si vous définissez les valeurs Date (DT), Date (CA) ou Heure (TM) comme propriété Type de données personnalisé, cliquez sur une option dans la liste.

Remarque

  • Ce champ est disponible uniquement si la valeur Type de données personnalisé correspond à Date (DT), Date (CA) ou Heure (TM).
Justification Sélectionnez l'une des options suivantes :
  • Gauche Aligne les données sur la gauche dans les fichiers positionnels lorsque leur longueur est inférieure à la longueur maximale du champ. Aligne également les données sur la gauche dans les fichiers délimités lorsque la date est inférieure à la longueur minimale du champ.

  • Droite. Aligne les données sur la droite dans les fichiers positionnels.

Remarque

  • Si aucune valeur n'est sélectionnée pour la propriété Justification, les données sont alignées sur la gauche par défaut.

  • Si aucune valeur de Justification n'est indiquée, la valeur par défaut est Gauche.
Caractère tampon | Tapez ou sélectionnez un caractère pour définir le champ tampon. Vous pouvez choisir n'importe quel caractère en guise de caractère tampon, y compris un espace ou un zéro. Pour plus d'informations, voir Caractères tampon.
Caractère de retour ligne Tapez un caractère pour délimiter les données du champ. Cette propriété est utile lorsqu'un caractère de vos données de champ est également utilisé en guise de valeur de délimiteur pour le noeud parent du champ. Par exemple, si vos données de champ sont

Browne,Peter,1231,yes

et que vous avez choisi une virgule en guise de valeur de délimiteur pour le noeud contenant le champ, l'Éditeur BizTalk interprète la virgule située après « Browne » comme un délimiteur, même si vous voulez que cette virgule fasse partie des données du champ. Pour résoudre ce problème, vous devez définir une valeur pour la propriété du caractère de retour à la ligne, puis délimiter les données du champ dans celui-ci. Par exemple, vous pouvez définir des guillemets doubles comme caractères de retour à la ligne pour le premier champ, puis taper vos données de champ comme dans l'exemple suivant :

"Browne,Peter",1231,yes

L'Éditeur BizTalk interprète dans ce cas la virgule située entre les guillemets doubles comme faisant partie des données du champ et non comme une valeur de délimiteur.

Remarque

  • Si vos données de champ comportent des caractères qui sont également utilisés comme caractères de retour à la ligne, vous devez les délimiter dans un autre jeu de caractères de retour à la ligne.

    Par exemple, lorsque des guillemets doubles sont définis comme caractères de retour à la ligne,

    "Browne,Peter ""Pete"""

    est analysé par l'Éditeur BizTalk pour apparaître sous la forme

    Browne,Peter "Pete"

  • Si les données de champ d'une instance de document d'entrée contiennent le caractère de saut de ligne suivi directement par le caractère de retour chariot, les données de champ correspondantes de l'instance de document de sortie contiennent uniquement le caractère de saut de ligne, même si tous deux sont inclus dans un ensemble de caractères de retour à la ligne.
Longueur minimale avec des caractères tampon Longueur minimale d'un champ dans une instance de document de sortie, caractères tampon inclus. Pour plus d'informations, voir Caractères tampon.

Remarques

  • Cette propriété peut uniquement être définie pour un champ si le caractère tampon est défini pour celui-ci.

  • Si la propriété Longueur minimale de l'onglet Déclaration est définie pour le champ, la propriété Longueur minimale avec des caractères tampon doit être supérieure ou égale à la valeur de la propriété Longueur minimale. Si la propriété Longueur minimale n'est pas définie, la propriété Longueur minimale avec des caractères tampon doit être supérieure ou égale à un.

Standard : Personnalisé
Propriété de structure : Positionnel

Onglet Analyse : Propriétés du noeud racine ou propriétés de l'enregistrement

Propriété | Valeur
Structure Sélectionnez l'option suivante pour la propriété Noeud racine :
  • Positionnel. Indique que le noeud racine est basé sur une structure de fichier positionnel.

Remarques

  • Un document avec un noeud racine positionnel peut ne pas posséder d'enregistrements.

  • Si vous cliquez avec le bouton droit sur le champ de valeur de la propriété Structure d'un noeud racine positionnel et cliquez sur Supprimer la propriété, l'Éditeur BizTalk interprète la structure du noeud racine en tant que structure délimitée. Certaines nouvelles propriétés peuvent apparaître, tandis que des propriétés existantes peuvent avoir été supprimées.

  • Lorsque la propriété Standard d'un document est définie sur Personnalisé, la propriété Structure du noeud racine et de tous les enregistrements est vide par défaut. Si vous laissez la propriété Structure vide, sa valeur est Délimité.
Identifiant de la balise source Le nom de l'identifiant de la balise source. Correspond au nom de balise utilisé pour faire correspondre l'enregistrement avec les données.

Remarque

  • Dans le cas d'un fichier non-XML, comme un fichier plat, vous pouvez introduire une propriété Identificateur de la balise source pour identifier n'importe quelle balise pouvant exister dans le fichier d'origine.

  • La propriété Identificateur de la balise source respecte la casse.
Position de la balise source | Nombre qui fait référence à la position de début de la balise dans un enregistrement positionnel.
Ajouter une nouvelle ligne Sélectionnez l'une des options suivantes :
  • Oui. Indique que lorsque le parseur atteint le délimiteur d'enregistrement, il doit passer à la ligne suivante et commencer sur celle-ci avec l'enregistrement suivant.

  • Non. Indique que lorsque le parseur atteint le délimiteur d'enregistrement, il doit continuer sur la même ligne pour l'enregistrement suivant.

Remarque

  • Si aucune valeur n'est indiquée pour Ajouter une nouvelle ligne, la valeur par défaut est Non.
Ignorer le retour chariot Sélectionnez l'une des options suivantes :
  • Oui. Indique au parseur d'ignorer le caractère de retour chariot (RC) situé après un délimiteur.

  • Non. Indique au parseur qu'il ne doit pas ignorer la valeur Retour chariot après un délimiteur.

Remarque

  • Si aucune valeur n'est indiquée pour Ignorer le retour chariot, la valeur par défaut est Oui.
Ignorer le saut de ligne Sélectionnez l'une des options suivantes :
  • Oui. Indique au parseur qu'il doit ignorer la valeur Saut de ligne après un délimiteur.

  • Non. Indique au parseur qu'il ne doit pas ignorer la valeur Saut de ligne après un délimiteur.

Remarque

  • Si aucune valeur n'est indiquée pour Saut de ligne, la valeur par défaut est Oui.
Ignorer le nombre d'enregistrements Sélectionnez l'une des options suivantes :
  • Oui. Indique au parseur ou au sérialiseur qu'il ne doit pas compter cet enregistrement lors du calcul du nombre total d'enregistrements dans la spécification.

  • Non. Indique au parseur ou au sérialiseur qu'il doit compter cet enregistrement lors du calcul du nombre total d'enregistrements dans la spécification.

Remarques

  • Une erreur d'analyse se produit lorsqu'une instance de document est soumise à BizTalk Server, si le nombre d'enregistrements de l'instance du document ne correspond pas au nombre d'enregistrements calculés dans la spécification. Pour plus d'informations, voir Erreurs d'analyse.

  • Si aucune valeur n'est indiquée pour Ignorer le nombre d'enregistrements, la valeur par défaut est Oui.

Onglet Analyse : Propriétés des champs

Propriété | Valeur
Type de données personnalisé Sélectionnez l'une des options suivantes :
  • Chaîne (AN). AN correspond aux champs alphanumériques.

  • Hexadécimal binaire (B). B correspond aux champs binaires.

  • Date (CA). CA correspond aux champs de dates à quatre chiffres.

  • Nombre (D0-D4). D0 à D4 (inclus) correspondent aux champs décimaux. Le nombre à un seul chiffre représente le nombre de décimales à droite de la virgule.

  • Date (DT). DT correspond aux champs de date.

  • Chaîne (ID). ID correspond aux champs d'identification.

  • Nombre (N). N correspond aux champs d'entiers.

  • Nombre (N0-9). N0 à N9 (inclus) correspondent aux champs décimaux implicites (le caractère décimal n'apparaît pas dans les données). Le nombre à un seul chiffre représente le nombre de décimales à droite de la virgule.

  • Nombre (R). R correspond aux champs numériques.

  • Nombre (R0-R9). R0 à R9 (inclus) correspondent aux champs numériques réels. Le nombre à un seul chiffre représente le nombre de décimales à droite de la virgule.

  • Heure (TM). TM correspond aux champs d'heure.

Important

  • Si vous spécifiez une valeur Type de données personnalisé, la valeur dans le champ Type de données sous l'onglet Déclaration est automatiquement modifiée afin de correspondre à la valeur Type de données personnalisé que vous avez sélectionnée. Par exemple, si vous remplacez la valeur Type de données Personnalisé par Date (CA) sous l'onglet Analyse, la valeur Type de données est automatiquement remplacée par Date sous l'onglet Déclaration. Si vous indiquez une valeur dans le champ Type de données sous l'onglet Déclaration, la valeur spécifiée dans le champ Type de données personnalisé est annulée.

Remarques

  • Si vous spécifiez des valeurs Date (DT), Date (CA) ou Heure (TM) pour la propriété Type de données personnalisé, vous devez également définir une valeur pour la propriété Format Date/Heure personnalisé.
Date/Format d'heure personnalisés Si vous définissez les valeurs Date (DT), Date (CA) ou Heure (TM) comme propriété Type de données personnalisé, cliquez sur une option dans la liste.

Remarque

  • Ce champ est disponible uniquement si la valeur Type de données personnalisé correspond à Date (DT), Date (CA) ou Heure (TM).
Justification Sélectionnez l'une des options suivantes :
  • Gauche Aligne les données sur la gauche dans les fichiers positionnels lorsque leur longueur est inférieure à la longueur maximale du champ. Aligne également les données sur la gauche dans les fichiers délimités lorsque la date est inférieure à la longueur minimale du champ.

  • Droite. Aligne les données sur la droite dans les fichiers positionnels.

Remarque

  • Si aucune valeur de Justification n'est indiquée, la valeur par défaut est Gauche.
Caractère tampon | Tapez un caractère pour définir le champ tampon. Vous pouvez choisir n'importe quel caractère en guise de caractère tampon, y compris un espace ou un zéro. Pour plus d'informations, voir Caractères tampon.

Voir aussi

Caractères tampon


Déclaration des espaces de noms

  1. Cliquez sur un noeud dans l'arborescence de spécification.

  2. Cliquez sur l'onglet Espace de noms.

  3. Cliquez avec le bouton droit sur le premier champ vide dans la colonne Préfixe et cliquez sur Ajouter.

  4. Tapez un préfixe pour l'espace de noms et appuyez sur ENTRÉE.

  5. Double-cliquez sur le champ vide à droite, dans la colonne Nom de ressource uniforme.

  6. Tapez un nom de ressource uniforme et appuyez sur ENTRÉE.

Important

  • L'Éditeur BizTalk ne valide pas le nom de ressource uniforme introduit pour un espace de noms.

Pour plus d'informations sur les espaces de noms, voir Déclaration des espaces de noms.

Voir aussi

Ajout d'annotations personnalisées

Suppression d'annotations personnalisées

Modification d'annotations personnalisées

Déclarations d'espaces de noms


Ajout d'annotations personnalisées

  1. Dans l'arborescence de la spécification, cliquez sur le noeud racine, l'enregistrement ou le champ auquel vous voulez ajouter une annotation personnalisée.

    Remarque

    • Il n'est pas possible d'ajouter une annotation personnalisée pour le noeud racine sous l'onglet Référence.
  2. Cliquez sur l'onglet Déclaration ou Référence, en fonction de l'emplacement où vous voulez ajouter une annotation personnalisée.

  3. Cliquez avec le bouton droit sur le premier champ vide dans la colonne Propriété et cliquez sur Ajouter.

    Le mode Édition est activé dans la zone Propriété.

  4. Tapez une paire de préfixes de nom (séparée par deux-points) et appuyez sur ENTRÉE.

    -ou-

    Sélectionnez l'une des annotations personnalisées dans la liste et appuyez sur ENTRÉE.

  5. Double-cliquez sur le champ vide à droite, dans la colonne Valeur.

  6. Tapez la valeur de l'annotation personnalisée et appuyez sur ENTRÉE.

Important

  • Pour que la spécification compile avec succès, le préfixe de l'espace de noms utilisé à l'étape 4 doit être déclaré dans la spécification. Pour plus d'informations, voir Déclaration des espaces de noms.

Voir aussi

Ajout d'annotations SQL

Déclaration des espaces de noms

Suppression d'annotations personnalisées

Modification d'annotations personnalisées

Déclarations d'espaces de noms


Modification d'annotations personnalisées

  1. Dans l'arborescence de la spécification, cliquez sur le noeud qui contient l'annotation personnalisée à modifier.

  2. Cliquez sur l'onglet (Déclaration ou Référence) qui fait référence à l'annotation personnalisée que vous voulez modifier.

  3. Double-cliquez sur le champ Propriété de l'annotation personnalisée, modifiez-le et appuyez sur ENTRÉE.

  4. Double-cliquez sur le champ Valeur de l'annotation personnalisée, modifiez-le et appuyez sur ENTRÉE.

Voir aussi

Ajout d'annotations SQL

Déclaration des espaces de noms

Déclarations d'espaces de noms


Suppression d'annotations personnalisées

  1. Dans l'arborescence de la spécification, cliquez sur le noeud qui contient l'annotation personnalisée à supprimer.

  2. Cliquez sur l'onglet (Déclaration ou Référence) qui fait référence à l'annotation personnalisée que vous voulez supprimer.

  3. Cliquez avec le bouton droit sur l'annotation personnalisée, puis cliquez sur Supprimer.

  4. Cliquez sur Oui pour confirmer la modification.

Voir aussi

Ajout d'annotations personnalisées

Ajout d'annotations SQL

Déclaration des espaces de noms

Modification d'annotations personnalisées

Déclarations d'espaces de noms


Définition des propriétés du dictionnaire

  1. Dans l'arborescence de la spécification, cliquez sur le noeud racine, l'enregistrement ou le champ pour lequel vous voulez définir une propriété, puis cliquez sur l'onglet Dictionnaire.

  2. Dans la colonne Propriété, activez la case à cocher de la valeur que vous voulez associer au champ.

L'onglet Dictionnaire contient les propriétés décrites dans les tables ci-après. Les propriétés du dictionnaire peuvent uniquement être définies pour des spécifications dont la propriété Standard est définie sur XML ou PERSONNALISÉ sous l'onglet Référence.

Onglet Dictionnaire : Noeud racine ou propriétés de l'enregistrement

Propriété | Chemin du noeud
Noeud conteneur du document | Dans un schéma d'enveloppe, le noeud du document indique que l'enregistrement contient le document.

Remarque

  • Dans la spécification d'un fichier plat (dont la propriété Standard est définie sur PERSONNALISÉ sous l'onglet Référence) qui est analysé par le parseur de fichiers plats de BizTalk Server, l'activation ou la désactivation de la case à cocher de propriété du dictionnaire Noeud conteneur du document est sans effet. Néanmoins, cette propriété du dictionnaire est disponible si vous voulez créer une spécification personnalisée et un parseur personnalisé qui l'utilisent.

Onglet Dictionnaire : Propriétés des champs

Propriété | Chemin du noeud
Nom du document | Affiche le chemin d'accès au champ d'une instance de document qui contient le nom du document.
Type de source | Affiche le chemin d'accès au champ d'une instance de document qui contient le type de source.
Valeur de la source | Affiche le chemin d'accès au champ d'une instance de document qui contient la valeur de la source.
Type de destination | Affiche le chemin d'accès au champ d'une instance de document qui contient le type de destination.
Valeur de destination | Affiche le chemin d'accès au champ d'une instance de document qui contient la valeur de destination.

Remarques

  • Lorsqu'il analyse une spécification, le parseur utilise les informations fournies sous l'onglet Dictionnaire pour localiser un canal. Vous pouvez créer un canal à l'aide du Gestionnaire d'échanges BizTalk. Pour plus d'informations sur les canaux et le Gestionnaire d'échanges BizTalk, voir Description des canaux.

  • Si vous utilisez une spécification pour définir les documents qui sont envoyés vers un port d'échanges ouvert, vous devez sélectionner la valeur de destination sous l'onglet Dictionnaire pour le champ contenant les informations sur le transport et la destination. Dans un document, les informations sur la destination sont remplacées si vous utilisez les paramètres d'envoi. Pour plus d'informations sur l'envoi de documents, voir Envoi.

  • Vous pouvez également définir les propriétés du Dictionnaire en cliquant avec le bouton droit sur un champ de la colonne Propriété, puis en cliquant sur Définir les informations de routage.

Voir aussi

Ajout d'une propriété au dictionnaire personnalisé

Suppression d'une propriété du dictionnaire

Suppression d'une propriété du dictionnaire personnalisé

Affectation d'un nouveau nom à une propriété du dictionnaire personnalisé

Envoi

Description des ports d'échanges


Ajout d'une propriété au dictionnaire personnalisé

  1. Dans l'arborescence de la spécification, sélectionnez le champ pour lequel vous voulez ajouter une propriété au dictionnaire personnalisé.

  2. Cliquez sur l'onglet Dictionnaire.

  3. Double-cliquez sur le premier champ vide dans la colonne Propriété.

  4. Tapez un nom pour la propriété et appuyez sur ENTRÉE.

Remarques

  • Utilisez un nom unique pour chaque propriété personnalisée créée.

  • La propriété Standard (pour le noeud racine) ne doit pas être définie sur X12 ni sur EDIFACT.

Voir aussi

Suppression d'une propriété du dictionnaire

Suppression d'une propriété du dictionnaire personnalisé

Affectation d'un nouveau nom à une propriété du dictionnaire personnalisé

Définition des propriétés du dictionnaire


Affectation d'un nouveau nom à une propriété du dictionnaire personnalisé

  1. Cliquez sur l'onglet Dictionnaire.

  2. Double-cliquez avec le bouton droit sur la propriété personnalisée que vous voulez renommer et cliquez sur Renommer.

  3. Tapez un nom pour la propriété et appuyez sur ENTRÉE.

Remarque

  • Utilisez un nom unique pour chaque propriété personnalisée créée.

Voir aussi

Ajout d'une propriété au dictionnaire personnalisé

Suppression d'une propriété du dictionnaire

Suppression d'une propriété du dictionnaire personnalisé

Définition des propriétés du dictionnaire


Suppression d'une propriété du dictionnaire

  1. Dans l'arborescence de la spécification, cliquez sur le noeud pour lequel vous voulez supprimer une propriété du dictionnaire et cliquez sur l'onglet Dictionnaire.

  2. Dans la colonne Propriété, désactivez la case à cocher de la valeur que vous ne voulez pas associer au champ.

Remarques

  • Vous pouvez également supprimer une valeur de propriété du Dictionnaire en cliquant avec le bouton droit sur un champ de la colonne Propriété, puis en cliquant sur Supprimer les informations de routage.

  • Lorsque vous supprimez une propriété de dictionnaire dans un noeud, les informations de routage sont également supprimées.

Voir aussi

Ajout d'une propriété au dictionnaire personnalisé

Suppression d'une propriété du dictionnaire personnalisé

Affectation d'un nouveau nom à une propriété du dictionnaire personnalisé

Définition des propriétés de déclaration


Suppression d'une propriété du dictionnaire personnalisé

  1. Cliquez sur l'onglet Dictionnaire.

  2. Double-cliquez avec le bouton droit sur la propriété personnalisée que vous voulez supprimer et cliquez sur Supprimer.

  3. Cliquez sur Oui pour confirmer la modification.

Voir aussi

Ajout d'une propriété au dictionnaire personnalisé

Suppression d'une propriété du dictionnaire

Affectation d'un nouveau nom à une propriété du dictionnaire personnalisé

Définition des propriétés du dictionnaire


Sélection de codes

  1. Cliquez sur un champ dans une arborescence de spécifications.

  2. Cliquez sur l'onglet Liste de codes.

  3. Dans la colonne Valeur, activez la case à cocher située en regard du code que vous voulez utiliser.

Remarques

  • Les listes de codes sont disponibles uniquement pour les spécifications basées sur X12 ou EDIFACT. Toutefois, tous les champs d'une spécification basée sur X12 ou EDIFACT ne possèdent pas de codes qui leur sont associés. L'onglet Liste de codes affiche la liste complète des codes disponibles pour un champ spécifique. Les codes sont associés à un champ si la case à cocher du champ Valeur à côté du code est sélectionnée. Une description du code apparaît dans le champ Description.

  • Lorsque vous associez un code à un champ sous l'onglet Liste de codes, cette association s'affiche également sous l'onglet Déclaration. Le champ Type de données sous l'onglet Déclaration est automatiquement défini avec le paramètre Énumération, et le champ Valeurs des types de données affiche les nombres de la liste de codes que vous avez sélectionnés sous l'onglet Liste de codes. Si vous annulez le champ Type de données sous l'onglet Déclaration, aucun code ne sera sélectionné sous l'onglet Liste de codes. Pour plus d'informations, voir Suppression d'une propriété d'un champ dans la colonne Valeur

  • Pour sélectionner une plage de codes, activez la case à cocher située en regard d'un code, appuyez sur MAJ, puis activez une case à cocher située en regard d'un autre code. Tous les codes compris entre ces deux codes sont sélectionnés.

  • Parfois, des valeurs de codes dupliquées apparaissent dans l'onglet Liste de codes. Ces valeurs de codes dupliquées peuvent avoir diverses descriptions, en fonction du type de document avec lequel la valeur du code est associée. Dans le contexte de la validation d'une instance de document, il n'est jamais nécessaire de sélectionner plus d'une valeur de code. Toutefois, il se peut que vous sélectionniez par inadvertance plus d'une valeur de code. La liste suivante résume le comportement de sélection des listes de codes dupliqués :
    • Si vous sélectionnez la valeur de code supérieure dans un ensemble de valeurs de codes dupliqués, seule cette valeur de code est sélectionnée.

    • Si vous sélectionnez n'importe quelle valeur de code autre que la valeur de code supérieure dans un ensemble de valeurs de codes dupliqués, cette valeur de code est sélectionnée et la valeur de code supérieure est également sélectionnée automatiquement.

    • La valeur de code supérieure dans un ensemble de valeurs de codes dupliqués ne peut être effacée tant que toute autre valeur de code de l'ensemble est sélectionnée.

Voir aussi

Suppression d'une propriété d'un champ dans la colonne Valeur

Suppression de codes

Valeurs et descriptions des listes de codes


Suppression de codes

  1. Cliquez sur un champ dans l'arborescence de la spécification.

  2. Cliquez sur l'onglet Liste de codes.

  3. Dans la colonne Valeur, désactivez la case à cocher située en regard du code que vous voulez supprimer.

Remarque

  • Les listes de codes sont disponibles uniquement pour les spécifications basées sur X12 ou EDIFACT. Toutefois, tous les champs d'une spécification basée sur X12 ou EDIFACT ne possèdent pas de codes qui leur sont associés. L'onglet Liste de codes affiche la liste complète des codes disponibles pour un champ spécifique. Les codes sont associés à un champ si la case à cocher du champ Valeur située en regard du code est sélectionnée. Une description du code apparaît dans le champ Description.

  • Parfois, des valeurs de codes dupliquées apparaissent dans l'onglet Liste de codes. Ces valeurs de codes dupliquées peuvent avoir diverses descriptions, en fonction du type de document avec lequel la valeur du code est associée. Dans le contexte de la validation d'une instance de document, il n'est jamais nécessaire de sélectionner plus d'une valeur de code. Toutefois, il se peut que vous sélectionniez par inadvertance plus d'une valeur de code. La liste suivante résume le comportement de sélection des listes de codes dupliqués :
    • Si vous sélectionnez la valeur de code supérieure dans un ensemble de valeurs de codes dupliqués, seule cette valeur de code est sélectionnée.

    • Si vous sélectionnez n'importe quelle valeur de code autre que la valeur de code supérieure dans un ensemble de valeurs de codes dupliqués, cette valeur de code est sélectionnée et la valeur de code supérieure est également sélectionnée automatiquement.

    • La valeur de code supérieure dans un ensemble de valeurs de codes dupliqués ne peut être effacée tant que toute autre valeur de code de l'ensemble est sélectionnée.

Voir aussi

Valeurs et descriptions des listes de codes

Sélection de codes


Suppression d'une propriété d'un champ dans la colonne Valeur

  1. Cliquez sur l'onglet contenant la propriété que vous voulez supprimer.

  2. Cliquez avec le bouton droit sur la colonne Valeur et sélectionnez Supprimer la propriété.


Calcul automatique des positions de champs

  1. Sélectionnez un champ dans un enregistrement positionnel.

  2. Double-cliquez sur le champ Valeur de la ligne Type de données.

  3. Dans la liste Type de données, cliquez sur une valeur.

    Remarque

    • Pour spécifier une valeur Longueur maximale (étapes 4 et 5), vous devez sélectionner l'une des valeurs Type de données suivantes : Chaîne, Nombre, Binaire (base64) ou Binaire (hex).
  4. Double-cliquez dans le champ Valeur de la ligne Longueur maximale.

  5. Tapez un nombre dans le champ de valeur Longueur maximale et appuyez sur ENTRÉE.

  6. Répétez les étapes 1 à 5 pour chacun des champs de l'enregistrement.

  7. Cliquez avec le bouton droit sur l'enregistrement et cliquez sur Calculer les positions des champs.

    L'avertissement suivant s'affiche :

    Cette opération va modifier les propriétés Position de début et Position de fin pour les champs de l'enregistrements sélectionné. Voulez-vous continuer ?

  8. Cliquez sur Oui.

    Les positions de début et de fin sont calculées pour les champs de l'enregistrement. Pour plus d'informations, voir Calcul des positions des champs.

Voir aussi

Calcul des positions des champs


Modification de notes et règles syntaxiques

La boîte de dialogue Propriétés du noeud vous permet d'effectuer les actions suivantes :

  • Lire et modifier les notes pour les champs et les enregistrements.

  • Lire les règles syntaxiques pour les enregistrements.

Pour afficher la boîte de dialogue Propriétés du noeud, procédez comme suit :

  1. Dans l'arborescence de la spécification, cliquez avec le bouton droit sur un enregistrement ou un champ et cliquez sur Propriétés.

    L'onglet Noeud apparaît par défaut.

  2. Pour afficher les règles syntaxiques pour un enregistrement, cliquez sur l'onglet Règles syntaxiques.

Remarque

  • Les règles de syntaxe ne s'appliquent qu'aux enregistrements.

Pour plus d'informations sur le mode d'utilisation de cette boîte de dialogue, reportez-vous aux rubriques suivantes :

  • Saisie de notes d'enregistrement

  • Affichage des règles syntaxiques

  • Saisie de notes de champ


Saisie de notes d'enregistrement

Pour plus d'informations sur le mode d'ouverture de la boîte de dialogue Propriétés du noeud, voir Modification de notes et règles syntaxiques.

Les notes peuvent être utilisées pour enregistrer toute information appropriée relative à l'enregistrement auquel elles sont associées. Par exemple, l'objet de l'enregistrement ou la raison de sa création.

  • Pour enregistrer une remarque, tapez du texte dans la boîte de dialogue Propriétés du noeud et cliquez sur OK.

Remarques

  • Les remarques ne peuvent pas être ajoutées au noeud racine.

  • Les remarques ne peuvent contenir de caractères non imprimables.

Voir aussi

Saisie de notes de champ

Affichage des règles syntaxiques


Affichage des règles syntaxiques

Pour plus d'informations sur le mode d'ouverture de la boîte de dialogue Propriétés du noeud, voir Modification de notes et règles syntaxiques.

Les règles syntaxiques fournissent des informations sur la façon dont il faut organiser l'arborescence de la spécification. Les règles syntaxiques se trouvent uniquement dans les spécifications basées sur le standard X12.

Remarque

  • Les règles de syntaxe ne s'appliquent qu'aux enregistrements.

Voir aussi

Saisie de notes de champ

Saisie de notes d'enregistrement


Saisie de notes de champ

Pour plus d'informations sur le mode d'ouverture de la boîte de dialogue Propriétés du noeud, voir Modification de notes et règles syntaxiques.

Les notes peuvent être utilisées pour enregistrer toute information appropriée relative au champ auquel elles sont associées ; Par exemple, l'objet du champ ou la raison de sa création.

  • Pour enregistrer une remarque, tapez du texte dans la boîte de dialogue Propriétés du noeud et cliquez sur OK.

Remarque

  • Les remarques ne peuvent contenir de caractères non imprimables.

Voir aussi

Saisie de notes d'enregistrement

Affichage des règles syntaxiques


Gestion d'instances de document

Le Mappeur BizTalk vous permet de créer une instance de document basée sur une spécification et de valider une instance de document par rapport à une spécification.

Cette section traite des procédures suivantes :

  • Création d'une instance de document

  • Validation d'une instance de document


Création d'une instance de document

  1. Ouvrez une spécification sur laquelle vous voulez baser une instance de document.

  2. Dans le menu Outils, cliquez sur Créer une instance XML.

  3. Dans la boîte de dialogue Créer une instance de document sous, sélectionnez le dossier dans lequel vous voulez créer une instance de document.

  4. Dans la zone Nom de fichier, tapez le nom de l'instance du document, puis cliquez sur Enregistrer.

    La nouvelle instance du document s'affiche sous l'onglet Sortie.

Remarque

  • Une instance de document peut uniquement être créée au format Unicode.

Voir aussi

Validation d'une instance de document


Validation d'une instance de document

  1. Ouvrez une spécification par rapport à laquelle vous voulez valider une instance de document.

    Pour plus d'informations, voir Ouverture de spécifications.

  2. Dans le menu Outils, cliquez sur Valider l'instance.

  3. Dans la boîte de dialogue Valider une instance de document, sélectionnez l'instance du document que vous voulez valider et cliquez sur Ouvrir.

    Lorsque vous validez une instance de document par rapport à une spécification basée sur le standard X12 ou EDIFACT, la boîte de dialogue Délimiteurs de document s'affiche. Procédez d'une des manières suivantes :

    • Spécifications X12. Sélectionnez les délimiteurs appropriés pour le document à valider et cliquez sur OK.

    • Spécifications EDIFACT. Sélectionnez les délimiteurs et le caractère d'échappement appropriés pour le document à valider et cliquez sur OK.

L'onglet Avertissements affiche le message "La validation de l'instance de document a réussi" si l'instance de document est validée par rapport à la spécification. Si l'instance de document n'est pas validée par rapport à la spécification, l'onglet Avertissements l'indique et affiche des erreurs expliquant pourquoi la validation n'a pas réussi. Si vous validez une instance de document non-XML par rapport à une spécification non-XML, et si l'instance de document est validée, une version XML (Extensible Markup Language) du document s'affiche sous l'onglet Sortie.

Important

  • Avant d'utiliser une instance de document dans un environnement de production, il est vivement recommandé de valider cette instance par rapport à la spécification source et de résoudre les problèmes affichés sous l'onglet Avertissements.

Remarques

  • L'Éditeur BizTalk ne valide pas les instances de document qui contiennent plusieurs documents.

  • Une instance de document qui contient un champ avec une valeur d'attribut vide ("") peut être validée avec succès par rapport à une spécification, quelle que soit la valeur définie pour la propriété Longueur minimale pour ce champ. Par exemple, si la valeur de propriété Longueur minimale du champ d'une spécification est définie sur 4, si vous essayez de valider une instance de document disposant du champ correspondant avec une valeur d'attribut vide, la validation n'échouera pas en raison de cette incohérence. Le parseur MSXML sous-jacent du moteur de validation traite un attribut avec une valeur vide comme un attribut qui n'est pas spécifié. Ce problème sera corrigé dans la prochaine version de BizTalk Server.

  • Une instance ne peut pas être validée correctement par rapport à des instances d'échanges de données électroniques (EDI) (standards X12 et EDIFACT) sauf si vous supprimez les enveloppes d'échanges, de groupes et de documents (en-têtes et bas de pages). Vous devez supprimer les segments ISA, GS, ST, SE, GE, et IEA pour les documents X12, et les segments UNA (le cas échéant), UNB, UNG, UNH, UNT, UNE et UNZ pour les documents EDIFACT.

  • Une instance de document XML bien formée qui contient des éléments saisis comme types de données réduits XML-Data (XDR) ne sera peut-être pas validée par rapport à la spécification correspondante. Pour valider cette instance de document par rapport à la spécification correspondante, assurez-vous que les propriétés Modèle de tous les éléments entrés comme types de données XDR sont définies sur Ouvrir. Pour plus d'informations sur la propriété Modèle, voir Définition des propriétés de déclaration.

  • Les instances de document non-XML enregistrées en Unicode ne seront pas validées correctement, sauf si vous supprimez le marqueur d'ordre des octets au début du fichier.

  • Lorsque vous validez une instance de document par rapport à une spécification dont le Standard est défini sur X12, EDIFACT ou Personnalisé, l'instance de document doit avoir une structure conforme au standard de la spécification. Par exemple, vous pouvez uniquement valider une instance de document X12 par rapport à une spécification X12.

  • Une instance de document qui contient une référence de schéma "x-schema" est toujours validée à l'aide de cette référence de schéma, quel que soit le schéma chargé dans l'Éditeur BizTalk.

  • Une table de caractères incorrecte n'est pas un critère de validation de l'instance. Par exemple, la validation peut réussir, même si une instance contient des données comprises dans les plages de début et de fin dans la boîte de dialogue Table de caractères incorrecte.

Voir aussi

Création d'une instance de document


Gestion de tables de caractères incorrectes

Cette section traite des procédures suivantes :

  • Ajout de plages de caractères incorrectes

  • Modification de plages de caractères incorrectes

  • Suppression de plages de caractères incorrectes


Ajout de plages de caractères incorrectes

  1. Dans le menu Affichage, cliquez sur Table de caractères incorrecte.

  2. Dans la boîte de dialogue Plages de caractères incorrectes, cliquez sur Nouvelle plage de caractères Bouton Nouvelle plage de caractères .

  3. Dans la boîte de dialogue Taper la plage de caractères incorrecte, sélectionnez une valeur dans la liste Plage de début incorrecte et appuyez sur TAB.

  4. Cliquez sur une valeur dans la liste Plage de fin incorrecte puis sur OK.

  5. Répétez les étapes 2 à 4 pour ajouter des plages de caractères incorrectes.

Important

  • Vous ne pouvez définir des plages de caractères incorrectes que pour des documents non-XML.

  • La valeur hexadécimale correcte pour un symbole point d'interrogation (?) est (0x3f). La valeur par défaut dans la liste Plage de début incorrecte et la liste Plage de fin incorrecte est ? (0x0). N'utilisez pas cette valeur pour représenter un symbole point d'interrogation. To specify a question mark symbol, select the ? Sélectionnez la valeur fournie dans la liste.

Remarque

  • Les valeurs qui apparaissent dans les listes Plage de début incorrecte et Plage de fin incorrecte sont des valeurs hexadécimales. Si vous affichez la spécification en tant que fichier source XML (Extensible Markup Language) à l'aide d'une application comme Microsoft Internet Explorer 5 ou version ultérieure, les valeurs s'affichent sous forme de valeurs décimales. Par exemple, si vous tapez un caractère point-virgule (;) dans les zones Plage de début incorrecte et Plage de fin incorrecte, la valeur qui apparaît est ; (0x3b). Lorsque vous utilisez un navigateur, la valeur qui apparaît est 59.

  • Pour entrer une plage de caractères incorrecte, vous pouvez également mettre en surbrillance la valeur dans la liste Plage de début incorrecte, taper un caractère numérique ou alphabétique, puis appuyer sur TAB pour passer à la liste Plage de début incorrecte.

Voir aussi

Suppression de plages de caractères incorrectes

Modification de plages de caractères incorrectes


Modification de plages de caractères incorrectes

  1. Dans le menu Affichage, cliquez sur Table de caractères incorrecte.

  2. Dans la boîte de dialogue Plages de caractères incorrectes, cliquez sur la plage de caractères que vous voulez modifier puis sur Modifier la plage de caractères Bouton Modifier la plage de caractères.

  3. Dans la boîte de dialogue Taper la plage de caractères incorrecte :
    • Dans la liste Plage de début incorrecte, sélectionnez une valeur.

      –Ou–

    • Dans la liste Plage de fin incorrecte, sélectionnez une valeur.
  4. Cliquez sur OK.

  5. Répétez les étapes 2 à 4 pour modifier de nouvelles plages de caractères incorrectes.

Important

  • Vous ne pouvez définir des plages de caractères incorrectes que pour des documents non-XML.

  • La valeur hexadécimale correcte pour un symbole point d'interrogation (?) est (0x3f). La valeur par défaut dans la liste Plage de début incorrecte et la liste Plage de fin incorrecte est ? (0x0). N'utilisez pas cette valeur pour représenter un symbole point d'interrogation. To specify a question mark symbol, click the ? (0x3f) value in the list.

Remarques

  • Les valeurs qui apparaissent dans les listes Plage de début incorrecte et Plage de fin incorrecte sont des valeurs hexadécimales. Si vous affichez la spécification en tant que fichier source XML à l'aide d'une application comme Microsoft Internet Explorer 5 ou version ultérieure, les valeurs s'affichent sous forme de valeurs décimales. Par exemple, si vous tapez un caractère point-virgule (;) dans les zones Plage de début incorrecte et Plage de fin incorrecte, la valeur qui apparaît est ; (0x3b). Lorsque vous utilisez un navigateur, la valeur qui apparaît est 59.

  • Pour entrer une plage de caractères, vous pouvez également mettre en surbrillance la valeur dans la liste Plage de fin incorrecte, taper un caractère numérique ou alphabétique, puis appuyer sur TAB pour passer à la liste Plage de fin incorrecte.

Voir aussi

Ajout de plages de caractères incorrectes

Suppression de plages de caractères incorrectes


Suppression de plages de caractères incorrectes

Important

  • Vous ne pouvez définir des plages de caractères incorrectes que pour des documents non-XML.
  1. Dans le menu Affichage, cliquez sur Table de caractères incorrecte.

    Dans la boîte de dialogue Plages de caractères incorrectes, cliquez sur la plage de caractères que vous voulez supprimer puis sur Supprimer la plage de caractères Bouton Supprimer la plage de caractères.

  2. Cliquez sur Oui pour confirmer la modification.

Voir aussi

Ajout de plages de caractères incorrectes

Modification de plages de caractères incorrectes


Gestion de vues

Cette section traite des procédures suivantes :

  • Développement des éléments de l'arborescence

  • Réduction des éléments de l'arborescence

  • Affichage des valeurs de propriétés

  • Modification de la taille du texte


Développement des éléments de l'arborescence

  • Cliquez sur le noeud racine ou l'enregistrement que vous voulez développer et dans le menu Affichage, cliquez sur Développer les éléments de l'arborescence.

Remarque

  • Pour développer toute l'arborescence, vous devez cliquer sur le noeud racine. Si vous cliquez sur un enregistrement, vous développez uniquement les enregistrements et champs enfants et de cet enregistrement.

Voir aussi

Réduction des éléments de l'arborescence


Réduction des éléments de l'arborescence

  • Cliquez sur le noeud racine ou l'enregistrement que vous voulez réduire et dans le menu Affichage, cliquez sur Réduire les éléments de l'arborescence.

Remarque

  • Pour réduire toute l'arborescence, vous devez cliquer sur le noeud racine. Si vous cliquez sur un enregistrement, vous réduisez uniquement les enregistrements et champs enfants de cet enregistrement.

Voir aussi

Développement des éléments de l'arborescence


View property values

  • Dans le menu Affichage, cliquez sur l'une des propriétés suivantes :
    • Déclaration

    • Référence

    • Analyser

    • Espace de noms

    • Dictionnaire

    • Liste de codes


Modification de la taille du texte

  • Dans le menu Affichage, pointez sur Taille du texte et cliquez sur la taille de votre choix.


Concepts

Cette section fournit des informations détaillées sur les concepts essentiels à la compréhension de l'Éditeur BizTalk.

Cette section traite des rubriques suivantes :

  • Définition des spécifications

  • Importation de fichiers

  • Environnement de l'Éditeur BizTalk

  • Enregistrements, champs et propriétés

  • Prise en charge des espaces de noms

  • Ajout d'annotations SQL


Définition des spécifications

Les spécifications sont des schémas XML (Extensible Markup Language) spécifiques à BizTalk Server et créés à l'aide de l'Éditeur BizTalk. Vous pouvez créer des spécifications basées sur des standards de l'industrie (tels que XML, EDIFACT ou X12) ou non (par exemple des flat-files délimités, des flat-files positionnels, des fichiers plats à la fois délimités et positionnels, des spécifications vides ou des fichiers existants).

Standard de l'industrie

Les standard de l'industrie fournissent des méthodes uniformes permettant l'échange électronique de données entre les entreprises. L'utilisation d'un langage commun permet aux ordinateurs de communiquer au sein d'une organisation ou d'une entreprise à une autre. Les standard de l'industrie définissent le format et le contenu des données des transactions électroniques. Une spécification basée sur les standard de l'industrie est considérée comme étant un sous-ensemble de cette norme. Pour créer une spécification répondant à vos besoins, vous pouvez partir d'une spécification basée sur les standard de l'industrie, puis supprimer les enregistrements et les champs dont vous n'avez pas besoin. En outre, vous pouvez modifier les propriétés des enregistrements et champs restants.

Standard non industriel

En cas de spécifications basées sur des standard non industriels, vous devez définir la structure du document dans l'Éditeur BizTalk. Vous pouvez utiliser l'Éditeur BizTalk pour divers types de standard non industriel : fichiers plats positionnels, fichiers plats délimités, ou fichiers plats à la fois positionnels et délimités.

Remarque

  • Dans l'onglet Analyser, vous devez définir la propriété Structure du noeud racine à la valeur Délimité si votre fichier plat est à la fois délimité et positionnel. Les propriétés supplémentaires des enregistrements sont définies sur Délimité ou Positionnel, en fonction de leurs attributs.

Spécifications vides

Une spécification vide ne contient que l'élément noeud racine. Si vous partez d'une spécification vide, vous devez en construire la structure complète. Renommez l'élément racine, puis modifiez les valeurs des propriétés de l'élément racine à revoir, comme les informations d'en-tête de la spécification. Vous pouvez ensuite ajouter des enregistrements et des champs en fonction des besoins de vos applications professionnelles.

Fichiers existants

Vous pouvez réutiliser des fichiers existants afin de tirer parti de l'investissement effectué lors du développement de documents adaptés à votre entreprise. Pour réutiliser un fichier existant, vous devez tout d'abord l'importer dans l'Éditeur BizTalk, puis l'enregistrer en tant que spécification. Ensuite, vous devez ouvrir cette spécification dans le Mappeur BizTalk et la mapper dans le format requis par vos partenaires commerciaux.

Cette section traite des rubriques suivantes :

  • Structure des spécifications

  • Prise en charge des normes

  • Prise en charge d'autres formats de fichiers

  • Caractères de noms XML non valides

  • Plages de caractères non valides

Voir aussi

Création d'une spécification basée sur un fichier plat

Création d'une spécification basée sur un modèle vide

Création d'une spécification basée sur une spécification existante

Création d'une spécification basée sur un standard

Enregistrements, champs et propriétés


Structure des spécifications

Les spécifications créées à l'aide de l'Éditeur BizTalk sont des instances XML bien formées. Les structures des spécifications varient en fonction du type de fichier choisi en guise de point de départ pour l'élaboration de votre spécification. Indépendamment du type, chaque spécification contient une même structure de base. Par exemple, toutes les spécifications commencent par la balise <?xml version=""?> et se poursuivent avec des informations d'en-tête comme le nom du fichier et des données d'espace de noms. Le reste de la structure s'appuie sur les enregistrements et les champs contenus dans la spécification, ainsi que sur les attributs qui leur sont associés. Vous pouvez afficher le code sous-jacent d'une spécification en l'ouvrant dans Microsoft Internet Explorer 5 ou une version ultérieure.

Vous pouvez créer un schéma XDR (XML-Data Reduced) à partir d'une spécification à l'aide de la commande Exporter le schéma XDR du menu Outils. Pour plus d'informations, voir Exportation de schémas XDR.

Vous pouvez créer un schéma XSD à partir d'un schéma XDR à l'aide d'un script de conversion fourni avec une installation complète de BizTalk Server. Pour plus d'informations sur la conversion d'un schéma XDR en schéma XSD, voir Conversion d'un schéma XDR en schéma XSD.

Voir aussi

Exportation de schémas XDR

Conversion d'un schéma XDR en schéma XSD


Prise en charge des normes

Les normes EDI (Electronic Data Interchange), telles que EDIFACT et X12, définissent un grand nombre de segments et d'éléments possibles qui constituent la structure de fichier des documents professionnels. À l'aide de l'Éditeur BizTalk, vous pouvez élaborer votre spécification à partir de ces structures, puis supprimer les segments et les éléments dont vous n'avez pas besoin. La structure finale est un sous-ensemble de la norme que vous et vos partenaires commerciaux, ou des collègues au sein de votre entreprise, convenez d'utiliser pour l'échange des données.

Si vous créez ou déplacez des noeuds dans un document EDIFACT ou X12, nous vous recommandons de définir la norme du document sur la valeur Personnalisé. Vous devez également définir la propriété Type de délimiteur afin que la structure modifiée soit compatible avec le reste du document. Notez que si vous redéfinissez la norme de document de Personnalisé à EDIFACT ou X12, tous les paramètres Type de délimiteur seront perdus. Pour plus d'informations sur la définition de la propriété Personnalisé, voir Définition des propriétés de référence. Pour plus d'informations sur la définition de la propriété Type de délimiteur, voir Définition des propriétés d'analyse.

L'Éditeur BizTalk prend également en charge les règles syntaxiques X12, qui sont des conditions relationnelles existant entre deux ou plusieurs éléments de données d'un enregistrement. Si la spécification contient des règles syntaxiques, celles-ci sont appliquées pendant le processus d'exécution du serveur lors de la validation de la spécification.

Il existe cinq types de règles :

  • Complète

    Si TXI08 existe, tous les noeuds suivants doivent exister :

    • TXI03
  • Grouped

    Si l'un des noeuds suivants existe, ils doivent tous exister :

    • TXI04

    • TXI05
  • Tout

    Au moins un des noeuds suivants doit exister :

    • TXI02

    • TXI03

    • TXI06
  • Un

    Au plus un des noeuds suivants doit exister :

    • TXI02

    • TXI03

    • TXI06
  • Any (conditional)

    Si PO413 existe, au moins un des noeuds suivants doit exister :

    • P0410

    • PO411

    • PO412

Voir aussi

Définition des propriétés de référence

Liste récapitulative des documents EDI inclus


Prise en charge d'autres formats de fichiers

L'Éditeur BizTalk est conçu pour permettre de créer aisément des spécifications dotées d'une structure de fichier positionnelle, délimitée, ou à la fois positionnelle et délimitée. Les sections suivantes fournissent des détails spécifiques à chacune de ces structures de fichiers.

Fichiers plats positionnels

Un fichier plat (flat-file) positionnel se compose de champs de même longueur fixe et d'enregistrements possédant un terminateur commun de fin d'enregistrement. La structure d'un fichier entrant doit être représentée dans les enregistrements et les champs de la spécification source de manière à conserver la nature positionnelle du fichier entrant. Par conséquent, avant de définir la structure de document d'une spécification source, il convient d'établir un schéma des enregistrements et des champs nécessaires.

Le tableau suivant présente un exemple de format fixe.

Définir le nom | Adresse | Ville | Téléphone
Xxxxxxxxxx | Aaaaaaaaaa | Ccccccccccccccc | xxx-xxx-xxxx
Yyyyyyyyyy | Bbbbbbbbbb | Ddddddddddddd | xxx-xxx-xxxx

Les champs Nom, Adresse, Ville et Téléphone possèdent une longueur fixe respective de 10, 10, 15 et 12 caractères. Le terminateur de fin d'enregistrement est un caractère de retour chariot et/ou de saut de ligne.

Vous pouvez utiliser l'Éditeur BizTalk pour créer des enregistrements et des champs consécutifs. Vous pouvez créer plusieurs types d'enregistrements et affecter différents délimiteurs aux enregistrements parents. Pour les structures qui contiennent plusieurs types d'enregistrements, la spécification des types et terminateurs d'enregistrement doit également être spécifiée dans l'ordre de leur apparition dans le document. La position de départ, la longueur et le type de données des champs doivent être spécifiés.

Important

  • Un enregistrement positionnel doit toujours être un enregistrement enfant ou délimité. Le caractère délimiteur spécifié pour l'enregistrement délimité parent ne doit pas apparaître dans les données de l'enregistrement positionnel enfant. Il n'y a aucun moyen d'éviter le caractère délimiteur de l'enregistrement délimité parent dans les données du champ positionnel enfant. Pour plus d'informations sur les délimiteurs et caractères d'échappement, voir Définition des propriétés d'analyse.

Remarques

  • Dans l'onglet Analyser, vous devez définir la propriété Structure du noeud racine à la valeur Délimité si votre fichier plat est à la fois délimité et positionnel. Les propriétés supplémentaires des enregistrements sont définies sur Délimité ou Positionnel, en fonction de leurs attributs.

  • Si une spécification est positionnelle et que vous modifiez la structure en délimitée, la spécification compilée inclut les positions d'origine de départ et de fin spécifiées dans l'onglet Référence. Toutefois, lorsque BizTalk Server analyse une spécification, le parseur ignore cette information et traite la spécification comme un fichier délimité.

Fichiers plats délimités

Un fichier plat (flat-file) délimité contient un ou plusieurs enregistrements séparés par un délimiteur. L'Éditeur BizTalk ne lit pas les délimiteurs comme faisant partie des données. Cependant, si le caractère délimiteur apparaît dans les données, celles-ci peuvent être formatées de manière à distinguer le délimiteur et les données. Par exemple, le champ dans lequel un caractère délimiteur apparaît peut être placé entre guillemets afin d'indiquer que le caractère délimiteur doit être traité comme une donnée et non comme un délimiteur.

À l'aide de l'Éditeur BizTalk, vous pouvez sélectionner des champs spécifiques ainsi que les délimiteurs associés. Vous pouvez également spécifier des délimiteurs de fin d'enregistrement. Afin de permettre l'utilisation de fichiers plats délimités, l'Éditeur BizTalk prend en charge :

  • Les structures composées de plusieurs groupes d'enregistrements.

  • Divers types d'enregistrements définis par des balises de type enregistrement.

  • Les délimiteurs de fin d'enregistrement.

  • Les caractères de retour à la ligne et d'échappement, afin de distinguer les données des champs des valeurs des délimiteurs.

  • Les valeurs de début, de longueur et de type des champs.

  • Les balises et descriptions de contenu des champs.

  • La possibilité de transformer des fichiers plats en spécifications utilisables par le Mappeur BizTalk.

Remarque

  • Dans l'onglet Analyser, vous devez définir la propriété Structure du noeud racine à la valeur Délimité si votre fichier plat est à la fois délimité et positionnel. Les propriétés supplémentaires des enregistrements sont définies sur Délimité ou Positionnel, en fonction de leurs attributs.


Caractères de noms XML non valides

Les caractères Unicode allant de xF900 à xFFFE ne peuvent pas être utilisés dans les noms XML (Extensible Markup Language). Si vous utilisez un caractère Unicode non valide dans un nom XML, ce caractère est traduit en une entité numérique d'échappement lorsque vous l'affichez dans l'arborescence de spécification. L'entité numérique d'échappement est codée sous la forme _xHHHH_, où HHHH représente le code Unicode hexadécimal à quatre chiffres. Par exemple, le nom Ship To dans une spécification d'ordre d'achat contient un caractère d'espacement, et apparaît dans l'arborescence de spécification sous la forme Ship_x0020_To. Si vous déplacez le pointeur de la souris sur un noeud contenant un caractère Unicode codé, une info-bulle apparaît et indique le nom du noeud avec le caractère Unicode non codé.

Remarque

  • Cela se produit lorsque vous affichez une arborescence de spécification dans l'Éditeur BizTalk ou dans le Mappeur BizTalk.


Plages de caractères non valides

Vous pouvez empêcher BizTalk Server de générer un caractère ou une plage de caractères donnés. Pour ce faire, dans l'Éditeur BizTalk, ouvrez une spécification en vue de l'utiliser comme spécification de destination. Ouvrez la boîte de dialogue Plages de caractères incorrectes et entrez les caractères ou les plages de caractères à exclure. Lorsque BizTalk Server essaie de traiter un caractère spécifié dans la boîte de dialogue Plages de caractères incorrectes d'une spécification de sortie, le traitement s'arrête et un message d'erreur apparaît.

Remarque

  • Les plages de caractères ne peuvent être bloquées que pour des documents non-XML.

Voir aussi

Ajout de plages de caractères incorrectes

Suppression de plages de caractères incorrectes

Modification de plages de caractères incorrectes

Mappage de données


Importation de fichiers

Vous pouvez importer trois types de fichiers dans l'Éditeur BizTalk : instances XML bien formées, définitions de type de document (DTD) et schémas XDR (XML-Data Reduced). Les sections suivantes fournissent plus d'informations sur l'importation de fichiers dans l'Éditeur BizTalk.

Remarque

  • Si l'Éditeur BizTalk ne peut pas déterminer quel élément doit être le noeud racine, la boîte de dialogue Sélectionnez l'élément racine apparaît. Sélectionnez l'élément faisant office de noeud racine, puis cliquez sur OK.

Après l'importation d'une instance XML bien formée, d'une DTD ou d'un schéma XDR, l'Éditeur BizTalk crée une structure basée sur le fichier importé et affiche une série d'enregistrements et de champs. Lorsque vous enregistrez le fichier dans l'Éditeur BizTalk, ce fichier devient une spécification. Cette spécification possède des informations d'en-tête appropriées ainsi qu'une structure bien définie.

Important

  • Le tableau ci-dessous indique quels fichiers XDR et DTD peuvent être importés lorsqu'ils contiennent certains types de données, et si le type de données peut être importé. Les colonnes représentent les types de données.
    "entité" et "entités" | "nmtoken" et "nmtokens" | "notation"
    XDR | Impossible d'importer le fichier. | Le fichier peut être importé, mais les types de données sont supprimés. | Impossible d'importer le fichier.
    DTD | Le fichier peut être importé, mais les types de données sont supprimés. | Le fichier peut être importé, mais les types de données sont supprimés. | Le fichier peut être importé, mais le type de données est importé en tant que type d'énumération.

  • Lorsque la dernière ligne d'une DTD est une référence d'entité (par exemple, "%xx"), la DTD ne peut pas être importée dans l'Éditeur BizTalk. La création d'une nouvelle ligne à la fin de la DTD avec un caractère de fin de ligne permet l'importation de la DTD dans l'Éditeur BizTalk.

  • Si vous essayez d'importer un fichier contenant une référence externe à un autre fichier, l'importation échouera.

  • Si l'Éditeur BizTalk affiche des messages d'avertissement relatifs à des références cycliques après l'importation d'un fichier XML (Extensible Markup Language) bien formé, nous vous recommandons fortement de résoudre ces problèmes et d'enregistrer la spécification avant de continuer.

  • Lors de l'importation de documents XML bien formés ou de DTD, l'Éditeur BizTalk ne peut pas interpréter les paramètres de type de données ou de longueur de champ.

Voir aussi

Création d'une spécification basée sur un fichier importé


Environnement de l'Éditeur BizTalk

Cette section traite des rubriques suivantes :

  • Interface utilisateur de l'Éditeur BizTalk

  • Menus de l'Éditeur BizTalk

  • Bouton de la barre d'outils de l'Éditeur BizTalk

  • Touches de raccourci de l'Éditeur BizTalk


Interface utilisateur de l'Éditeur BizTalk

L'interface utilisateur de l'Éditeur BizTalk comprend trois volets principaux. Le volet de gauche affiche l'arborescence de spécification, à savoir une représentation graphique de la spécification. Le noeud supérieur dans l'arborescence de spécification est le noeud racine ; il est représenté par une icône de document munie de lignes vertes horizontales Icône de noeud racine. Les différents enregistrements et champs sont représentés en dessous du noeud racine dans la hiérarchie de la spécification. Les enregistrements partagent la même icône que le noeud racine. Les champs sont représentés par une icône de document munie de lignes bleues verticales Icône de champ. Vous pouvez développer ou réduire un noeud de l'arborescence de spécification en cliquant sur l'icône plus ou moins située à gauche du noeud.

Le volet de droite contient six onglets : Déclaration, Référence, Analyser, Espace de noms, Dictionnaire et Liste de codes. Utilisez ces onglets pour définir les valeurs de propriétés, espaces de noms, propriétés de dictionnaires et listes de codes pour les noeuds d'une spécification. Pour plus d'informations sur ces onglets, voir Spécification de propriétés pour les enregistrements et les champs.

The bottom pane contains two tabs:Le volet inférieur contient deux onglets : Sortie et Avertissement. L'onglet Sortie affiche une instance de document XML (Extensible Markup Language) créée lors de l'utilisation de la fonction « Créer une instance XML » de l'Éditeur BizTalk. Pour plus d'informations sur la création d'une instance de document XML à partir d'une spécification, voir Création d'une instance de document. L'onglet Avertissement indique si une tentative de validation d'une instance de document a réussi, et affiche des messages d'avertissement en cas d'échec de la validation du document. Pour plus d'informations, voir Validation d'une instance de document

Voir aussi

Création d'une instance de document

Spécification de propriétés pour les enregistrements et les champs

Validation d'une instance de document


Menus de l'Éditeur BizTalk

Les menus de l'Éditeur BizTalk regroupent les commandes de manière logique, afin de faciliter l'exécution d'une tâche spécifique. Par exemple, vous pouvez utiliser les commandes du menu Afficher pour développer ou réduire tous les enregistrements et champs de l'arborescence de spécification.

Les menus de l'Éditeur BizTalk sont les suivants :

  • Fichier. Utilisez ce menu pour créer, ouvrir, enregistrer ou fermer une spécification.

  • Modifier. Utilisez ce menu pour couper, copier, coller, insérer, renommer ou supprimer des enregistrements ou des champs dans une spécification.

  • Afficher. Utilisez ce menu pour sélectionner des vues dans le volet de droite de l'interface utilisateur, sélectionner des vues dans le volet inférieur de l'interface utilisateur, sélectionner une taille de texte pour l'affichage de l'Éditeur BizTalk, afficher la boîte de dialogue Table de caractères incorrecte, développer ou réduire l'arborescence de spécification, ou mettre en surbrillance l'avertissement suivant de l'onglet Avertissements.

  • Outils. Utilisez ce menu pour valider une spécification, valider une instance de document vis-à-vis d'une specification, créer une instance de document XML (Extensible Markup Language) à partir d'une spécification, importer des fichiers, exporter des schémas XDR (XML-Data Reduced), ou afficher les options de l'Éditeur BizTalk.

  • Aide. Utilisez ce menu pour obtenir des informations conceptuelles sur l'utilisation de l'Éditeur BizTalk.

Voir aussi

Accès aux menus du Mappeur BizTalk


Bouton de la barre d'outils de l'Éditeur BizTalk

L'Éditeur BizTalk fournit une barre d'outils destinée à compléter la barre de menus. Tous les boutons de la barre d'outils affichent des représentations graphiques des tâches qu'ils effectuent. L'ordre d'apparition de gauche à droite est le suivant :

  • Nouvelle

  • Ouvrir

  • Enregistrer

  • Extraire à partir de WebDAV

  • Stocker dans WebDAV

  • Couper le noeud de la spécification

  • Copier le noeud de la spécification

  • Coller le noeud de la spécification

  • Supprimer

  • Nouvel enregistrement

  • Nouveau champ

  • Insérer un enregistrement

  • Insérer un champ

  • Réduire

  • Expand


Touches de raccourci de l'Éditeur BizTalk

Vous pouvez utiliser des touches de raccourci pour effectuer certaines tâches dans l'Éditeur BizTalk. Le tableau suivant présente ces touches de raccourci.

Remarque

  • Le clavier numérique permet d'obtenir la fonctionnalité non incluse dans la liste pour déplacer le pointeur de la souris à l'aide des Touches souris. Pour plus d'informations sur les Touches souris dans Windows 2000 Server et l'aide de Advanced Server, voir Utiliser le clavier pour déplacer le pointeur de la souris. Pour plus d'informations sur les Touches souris dans l'aide de Windows 2000 Édition Professionnelle, voir Déplacer le pointeur à l'aide des Touches souris.
Appuyez sur | À
CTRL+N | Ouvrir une nouvelle spécification.
Ctrl+O | Ouvrir une spécification existante.
CTRL+S | Enregistrer une spécification.
MAJ+R | Insérer un enregistrement.
CTRL+R | Ajouter un nouvel enregistrement à un enregistrement.
MAJ+F | Insérer un champ.
CTRL+F | Ajouter un nouveau champ à un enregistrement.
SUPPR | Supprimer un enregistrement ou un champ.
F4 | Mettre en surbrillance l'avertissement suivant.
F5 | Valider un schéma.
CTRL+C | Copier un objet.
Ctrl+X | Couper un objet.
CTRL+V | Coller un objet.
F6 | Déplacer le focus d'un volet à l'autre dans le sens des aiguilles d'une montre.
MAJ+F6 | Déplacer le focus d'un volet à l'autre dans le sens inverse des aiguilles d'une montre.
TAB | Basculer le focus depuis l'onglet du volet de droite vers la feuille de données située en dessous. La touche TABULATION permet de déplacer le focus d'un bouton ou d'un champ à l'autre dans la boîte de dialogue.
BARRE ESPACE | Activer ou désactiver une case à cocher. L'utilisation de la barre d'espace entraîne le même résultat qu'un clic de souris lorsqu'un bouton est activé.
F2 | Activer le mode d'édition pour un noeud en surbrillance dans l'arborescence de spécification. Activer le mode d'édition pour une ligne en surbrillance dans la feuille de données du volet de droite.
MAJ+F2 Activer le mode d'édition pour les champs suivants :
  • La colonne Propriété d'une ligne d'annotation personnalisée en surbrillance de l'onglet Déclaration ou Référence.

  • La colonne Préfixe d'une ligne d'annotation personnalisée en surbrillance de l'onglet Espace de noms.

  • La colonne Propriété d'une ligne de dictionnaire personnalisée en surbrillance de l'onglet Dictionnaire.
ALT + FLÈCHE BAS | Afficher la liste d'une zone de liste active.
MAJ++ | Ajouter une nouvelle annotation personnalisée lorsque le focus est sur la feuille de données d'espace de noms dans le volet de droite.
ENTRÉE | Confirmer les modifications apportées aux noeuds et aux valeurs.
ÉCHAP | Annuler les modifications apportées aux noeuds et aux valeurs.
F1 | Consulter l'aide en ligne.
ALT+F4 | Quitter le programme.
GAUCHE | Activer l'onglet vers la gauche.
DROITE | Activer l'onglet situé à droite.
N'importe quelle touche de direction | Mettre en surbrillance un dossier ou un fichier du volet principal d'une boîte de dialogue, tandis que le focus est sur ce volet. Cette fonctionnalité apparaît dans les boîtes de dialogue Nouvelle spécification de document, Stocker dans WebDAV et Extraire à partir de WebDAV. Pour plus d'informations sur la boîte de dialogue Nouvelle spécification de document, voir Création et validation de spécifications. Pour plus d'informations sur WebDAV, voir Ouverture de spécifications à partir de WebDAV.
La touche Application et cliquez sur Ajouter dans le menu raccourci. | Insérer une propriété personnalisée dans une spécification. Cette fonctionnalité apparaît dans les onglets Déclaration, Référence, Espace de noms et Dictionnaire lorsqu'une propriété est affichée en surbrillance.

Voir aussi

Interface utilisateur de l'Éditeur BizTalk


Enregistrements, champs et propriétés

L'Éditeur BizTalk présente une spécification sous la forme d'une vue arborescente d'enregistrements et de champs dans un ordre donné. Dans cette structure, vous pouvez créer des relations parent-enfant à l'aide d'enregistrements et de champs. Les enregistrements peuvent contenir d'autres enregistrements ou champs, tandis que les champs ne peuvent pas contenir d'autres champs ou enregistrements. Un enregistrement est toujours un élément, mais un champ peut être soit un élément soit un attribut. L'arborescence de spécification, qui représente les enregistrements et les champs sous forme de noeuds, permet de visualiser, de créer, de modifier et de supprimer aisément tous les enregistrements et les champs d'une spécification. Chaque noeud de l'arborescence de spécification possède un ensemble de définitions de propriétés, représentées sur les six onglets de la fenêtre principale de l'Éditeur BizTalk : Déclaration, Référence, Analyser, Espace de noms, Dictionnaire et Liste de codes. Les données contenues dans ces onglets sont nécessaires à l'Éditeur BizTalk pour traduire un document depuis son format d'origine au format XML. Ces informations définissent la structure du document, que celui-ci soit positionnel ou délimité, ainsi que l'ordre, la longueur et le format des données.

Cette section traite des rubriques suivantes :

  • Enregistrements et propriétés associées

  • Champs et propriétés associées

  • Calcul des positions des champs

  • Limites de longueur des caractères

  • Valeurs et descriptions des listes de codes

  • Caractères tampon

  • Portée des propriétés

  • Références cycliques

  • Intégration des valeurs par défaut


Enregistrements et propriétés associées

En fonction du type de spécification en cours d'élaboration, vous serez certainement amené à ajouter et/ou supprimer des enregistrements. Après l'ajout d'enregistrements à une spécification quelconque, vous devez définir des propriétés. Lorsque vous supprimez un enregistrement, ses propriétés sont également supprimées, ainsi que tous les enregistrements et champs enfants.

Si votre spécification est basée sur X12 ou EDIFACT, vous ne pouvez ajouter que les types d'enregistrements qui existent dans cette norme, mais vous pouvez supprimer un ou tous les enregistrements. Si vous créez une spécification basée sur une spécification vide, vous devez ajouter des enregistrements. Dans certains cas, par exemple lors de l'élaboration d'une nouvelle spécification basée sur une spécification existante, il se peut que vous deviez ajouter et supprimer des enregistrements.

Lorsque vous ajoutez ou insérez un enregistrement, vous pouvez commencer immédiatement la saisie pour renommer l'enregistrement. Vous pouvez modifier le nom d'un enregistrement existant ainsi que ses propriétés en sélectionnant l'enregistrement et en effectuant les modifications appropriées.

Si vous collez dans une spécification un enregistrement dont le nom est identique à celui d'un enregistrement existant, un numéro est ajouté à la fin du nom de l'enregistrement.

Pour plus d'informations sur la création d'une nouvelle instance d'un enregistrement existant, voir Création d'une nouvelle instance d'un enregistrement unique. Pour plus d'informations sur la création d'une référence cyclique, voir Création de références circulaires.

Voir aussi

Création d'une nouvelle instance d'un enregistrement unique

Création de références circulaires

Portée des propriétés

Spécification de propriétés pour les enregistrements et les champs


Champs et propriétés associées

En fonction du type de spécification en cours d'élaboration, vous serez certainement amené à ajouter et/ou supprimer des enregistrements. Les champs correspondent à des éléments EDI (Electronic Data Interchange). Après l'ajout de champs à une spécification quelconque, y compris des documents EDI, vous devez spécifier des valeurs de propriétés.

Si votre spécification est basée sur X12 ou EDIFACT, vous ne pouvez ajouter que les types de champs qui existent dans cette norme, mais vous pouvez supprimer un ou tous les champs. Si vous créez une spécification basée sur une spécification vide, vous devez ajouter des champs. Vous pouvez modifier les propriétés de n'importe quel champ, indépendamment du type de document.

Lorsque vous ajoutez ou insérez un nouveau champ dans une spécification, la propriété Type de l'onglet Déclaration est définie par défaut sur Attribut. Vous pouvez modifier manuellement cette valeur en Élément pour n'importe quel champ. Pour plus d'informations sur la création de champs avec la propriété Type définie par défaut sur Élément, voir Création d'un nouveau champ en tant qu'élément.

Lorsque vous ajoutez ou insérez un champ, vous pouvez commencer immédiatement la saisie pour renommer le champ. Vous pouvez modifier le nom d'un champ existant ainsi que ses propriétés en sélectionnant le champ et en effectuant les modifications appropriées.

Si vous collez dans une spécification un champ dont le nom est identique à celui d'un champ existant, un numéro est ajouté à la fin du nom du champ. Si vous collez dans une spécification un champ dont le nom est identique à celui d'un champ frère existant (et que les deux champs possèdent la même valeur Type), un numéro est ajouté à la fin du nom du champ. Pour plus d'informations sur les valeurs Type, voir Définition des propriétés de déclaration. Pour plus d'informations sur la création d'une nouvelle instance d'un champ existant, voir Création d'une nouvelle instance d'un champ d'élément existant.

Voir aussi

Création d'un nouveau champ en tant qu'élément

Création d'une nouvelle instance d'un champ d'élément existant

Portée des propriétés

Définition des propriétés de déclaration

Spécification de propriétés pour les enregistrements et les champs


Calcul des positions des champs

L'Éditeur BizTalk peut automatiquement calculer les positions de début et de fin de tous les champs dans un enregistrement positionnel. Définissez tout d'abord une valeur Type de données et une valeur Longueur maximale dans l'onglet Déclaration pour chaque champ dans l'enregistrement positionnel. Puis, cliquez avec le bouton droit sur l'enregistrement positionnel, et dans le menu contextuel, cliquez sur Calculer les positions des champs. Les positions de début et de fin de tous les champs de cet enregistrement sont automatiquement calculées. Pour plus d'informations, voir Calcul automatique des positions de champs.

Les différents points ci-dessous expliquent cette fonctionnalité en détails :

  • Si des positions de début et de fin sont spécifiées pour les champs d'un enregistrement positionnel, toutes les positions à l'exception de la position de début du premier champ sont remplacées lors du calcul des positions des champs.

  • Lorsque vous calculez les positions des champs, la Position de début du premier champ d'un enregistrement positionnel est définie sur 1, sauf si la valeur Position de début a été préalablement définie pour ce champ. Si une valeur Position de début a déjà été définie pour le premier champ d'un enregistrement positionnel, les calculs commencent à partir de cette valeur.

  • Le calcul de la position des champs tient compte de l'Identifiant de la balise source. Considérez, par exemple, un enregistrement positionnel avec les propriétés suivantes : l'Identificateur de la balise source est « TAG » ; la Position de la balise source est 10 ; il y a quatre champs avec des valeurs Longueur maximale de 2, 5, 8 et 6 ; et aucune valeur Position de début n'a été définie pour le premier champ. Les positions de début et de fin des quatre champs sont : Champ 1 = 1, 2 ; Champ 2 = 3, 7 ; non utilisé = 8, 9 ; TAG = 10, 12 ; Champ 3 = 13, 20 ; et Champ 4 = 21, 26. Si la Position de la balise source avait été 1, TAG aurait eu des valeurs de position de début et de fin de 1 et 3, et le comptage des champs aurait commencé à la position 4.

  • Les positions des champs d'un enregistrement sont calculées séquentiellement depuis le premier jusqu'au dernier champ de l'enregistrement. Lors du calcul des positions des champs, si le système trouve un champ dont la propriété Longueur maximale n'est pas définie, les positions de début et de fin de ce champ et de tous les champs suivants de l'enregistrement ne sont pas calculées.

  • Si le système trouve un enregistrement frère lors du calcul des positions des champs, les positions de début et de fin de tous les champs situés après l'enregistrement frère ne sont pas calculées.

  • Les positions de début et de fin d'un champ dont la valeur Longueur maximale est égale à 1 sont identiques.

  • Lors du calcul des positions des champs d'un enregistrement positionnel, les positions des champs contenus dans tous les enregistrements descendants sont également calculées. Les positions des champs frères situés avant un enregistrement sont calculées, mais les positions des champs frères situés après un enregistrement ne sont pas calculées.

Voir aussi

Calcul automatique des positions de champs


Limites de longueur des caractères

Le nombre de caractères que vous pouvez utiliser dans les noms et les valeurs de propriétés est limité. Le tableau ci-dessous indique les limites de nombre de caractères utilisables dans l'Éditeur BizTalk.

Nom ou valeur de propriété | Nombre maximal de caractères
Nom de noeud (nom d'un noeud racine, d'un enregistrement ou d'un champ) | 255
Préfixe d'espace de noms | 64
Valeur de propriété de chaîne | 1024
Valeur de propriété LONG | 11
Valeur de propriété ULONG | 10
Valeur de propriété CHAR | 1
Valeur de propriété de format EDI (Electronic Data Interchange) (valeur d'une propriété de format spécifique EDI, telle que la valeur de propriété Date/Format d'heure personnalisés de l'onglet Analyser pour un champ d'une spécification basée sur le format EDI) | 15
Espace de noms cible + Nom de spécification | 255


Valeurs et descriptions des listes de codes

Les informations figurant dans l'onglet Liste de code définissent les valeurs de code X12 ou EDIFACT ainsi que leurs descriptions. Les descriptions définissent la signification de chaque code. Par exemple, la valeur de code ST dans le champ Address Qualifier Code de nombreuses spécifications de documents standards signifie que l'information donnée correspond à une adresse Ship To. Les codes de la liste ne peuvent être ni modifiés ni supprimés. Vous pouvez choisir d'associer ou non un code avec un champ.

Seules les spécifications basées sur une norme X12 ou EDIFACT possèdent des listes de codes. Toutefois, tous les champs d'une spécification basée sur X12 ou EDIFACT ne possèdent pas de codes qui leur sont associés. L'onglet Liste de codes présente la liste complète des codes disponibles pour un champ spécifique si ce champ possède une référence de liste de codes. Les codes sont valides pour un champ si la case à cocher de la colonne Valeur à côté du code est sélectionnée. Une description du code apparaît dans la colonne Description.

Vous pouvez inclure ou exclure des codes associés à un champ en activant ou en désactivant les cases à cocher dans la colonne Valeur en regard du code mentionné dans l'onglet Liste de codes. Les codes sont mentionnés par valeur numérique ou alphabétique, ou par une combinaison de valeurs numériques et alphabétiques. Cette valeur représente une description spécifique. Vous pouvez associer une valeur de code à n'importe quel champ de l'arborescence de spécification. Par exemple, dans le champ BEG02 d'un ordre d'achat X12 850, vous pouvez sélectionner le code OS, qui ajoute un attribut au champ BEG02 indiquant que le champ contient une information spéciale de commande.

Les valeurs et descriptions des listes de codes pour les modèles de spécifications basés sur EDI qui sont fournis par BizTalk Server figurent dans le fichier de base de données Microsoft Access à l'emplacement \Program Files\Microsoft BizTalk Server\XML Tools\Databases\CodeLists\CodeListsX12a.mdb. Si vous créez de nouvelles tables dans cette base de données pour de nouveaux modèles de spécification, le format du nom des tables est standard_version. Par exemple, pour un modèle de spécification EDIFACT D99A, le nom de table correspondant est EDIFACT_D99A.

Important

  • Si vous créez une nouvelle table dans la base de données CodeListsX12a.mdb, ne placez pas de caractères XML (Extensible Markup Language) non valides (caractères Unicode compris entre F900 et FFFE) dans la colonne Valeur de la table. Si vous enregistrez une spécification contenant un champ doté d'une valeur de liste de codes sélectionnée associée à une valeur dans une table comportant un caractère XML non valide, vous ne pourrez pas ouvrir la spécification.

Si vous associez un code à un champ, la valeur Type de l'onglet Déclaration doit être définie sur Attribut.

Remarque

  • Les listes de codes ne sont disponibles que pour les spécifications basées sur X12 ou EDIFACT. Pour cette raison, il se peut que si vous changez la structure d'une spécification basée sur X12 ou EDIFACT en CUSTOM, puis que vous la modifiez à nouveau par X12 ou EDIFACT, la liste de codes d'un champ particulier ne soit plus disponible dans l'onglet Liste de codes. Dans ce cas, enregistrez la spécification et ouvrez-la de nouveau. La liste de codes réapparaîtra dans l'onglet Liste de codes pour le champ concerné.

Voir aussi

Spécification de propriétés pour les enregistrements et les champs


Caractères tampon

L'Éditeur BizTalk permet de gérer les caractères tampon dans les documents délimités afin dêtre sûr d'obtenir les résultats attendus. Chaque document délimité traité par BizTalk Server devant être traduit en XML (Extensible Markup Language) avant que le mappage ait lieu, vous devez vous assurer que la spécification de votre document indique à BizTalk Server comment manipuler les caractères tampon dans les instances de documents délimités. Par exemple, un champ d'une instance de document délimité pourrait ressemble à ceci :

Green*****

Le contenu des données du champ est Green, le champ est justifié à gauche, il y a cinq caractères tampon à droite du contenu du champ et le caractère tampon est un astérisque.

Si vous ne définissez pas de caractère tampon pour le champ de la spécification correspondant au champ de l'instance de document, BizTalk Server interprète les cinq astérisques comme faisant partie des données du champ. Afin de vous assurer que BizTalk Server manipule correctement les caractères tampon dans ce champ, vous devez vérifier que les propriétés de l'onglet Analyser pour ce champ correspondent aux valeurs indiquées dans le tableau ci-dessous.

Propriété | Valeur
Justification | Gauche
Caractère tampon | *
Longueur minimale avec des caractères tampon | Définissez cette valeur de propriété si vous voulez que la longueur du champ dans votre instance de document de sortie soit supérieure ou égale à une longueur donnée. BizTalk Server insère des caractères tampon dans le champ afin d'obtenir la longueur de champ minimale correcte dans l'instance de document de sortie.

Vous pouvez utiliser la propriété Caractère tampon pour vous assurer que les caractères tampon d'un champ sont supprimés d'une instance de document envoyée à BizTalk Server. La valeur de la propriété Longueur minimale avec des caractères tampon est le gage que BizTalk Server va insérer des caractères tampon dans un champ de l'instance du document de sortie, si l'utilisateur le souhaite. La propriété Justification indique de quel côté du contenu des données du champ les caractères tampon sont supprimés (de l'instance du document d'entrée) ou insérés (dans l'instance du document de sortie). Les caractères tampon sont ajoutés ou supprimés à droite dans un champ justifié à gauche, et à gauche dans un champ justifié à droite. Si la propriété Caractère tampon d'un champ n'est pas définie, aucun caractère tampon n'est ajouté ou supprimé dans ce champ.


Portée des propriétés

Si une spécification possède deux ou plusieurs instances d'un enregistrement, les valeurs de certaines propriétés de ces instances doivent être identiques. En d'autres termes, la portée de ces propriétés est globale. La portée de certaines propriétés de champs peut également être globale, mais uniquement si la propriété Type du champ est définie sur Élément.

Par exemple, toutes les propriétés des onglets Déclaration et Analyser sont identiques pour les instances multiples d'un enregistrement ou d'un champ. Si vous modifiez une propriété de déclaration ou d'analyse d'une instance d'un enregistrement ou d'un champ, cette propriété change automatiquement pour toutes les autres instances de cet enregistrement ou de ce champ. Les propriétés des onglets Référence et Dictionnaire ne possèdent cependant pas de champ d'application global, de sorte que les valeurs de ces propriétés peuvent être définies indépendamment pour chaque instance d'un enregistrement ou d'un champ. Les listes de codes s'appliquent uniquement aux champs, et ne possèdent pas de champ d'application global.

Remarques

  • La portée d'un champ ne peut être globale que si la propriété Type est définie sur Élément.

  • La portée d'un champ dont la propriété Type est définie sur Attribut est toujours locale.

  • Dans l'Éditeur BizTalk, seules les déclarations ElementType ont un champ d'application global. Si vous importez dans l'Éditeur BizTalk un schéma contenant des déclarations AttributeType qui possèdent un champ d'application global, et que vous enregistrez le schéma en tant que spécification, les déclarations AttributeType deviennent automatiquement de portée locale au sein de la ou des déclarations ElementType appropriées.


Références cycliques

Une référence cyclique a lieu dans une spécification lorsqu'un enregistrement est créé en tant que descendant de lui-même. Une référence cyclique ne peut se produire que lorsque la valeur de la propriété Standard est XML dans l'onglet Référence. L'éditeur BizTalk illustre une référence cyclique par une icône Icône de référence cyclique représentant un enregistrement traversé par une flèche courbe.

L'illustration ci-dessous montre comment une référence cyclique apparaît dans l'Éditeur BizTalk.

Cliquez sur l'image pour l'agrandir ou la réduire.

La propriété Nombre de cycles apparaît dans l'onglet Déclaration et s'applique uniquement à un noeud cyclique. La valeur par défaut est 1 ; la valeur maximale est 7. Le nombre de cycles indique combien de cycles sont disponibles en dessous de l'enregistrement de base. Par exemple, dans l'illustration précédente, il y a un total de quatre niveaux pour Record1 : trois à partir du nombre de cycles égal à 3 et un à partir de l'enregistrement de base. Si vous ouvrez cette spécification dans le Mappeur BizTalk, les quatre niveaux de Record1 apparaissent. Record2 et Field1 apparaissent également pour chaque Record1. Vous pouvez établir des liaisons vers les noeuds de chaque niveau du cycle.

Il n'est pas possible de définir des valeurs de propriétés de dictionnaire pour les champs qui descendent d'un noeud cyclique. Par exemple, dans l'illustration précédente, vous pouvez définir des valeurs de propriétés de dictionnaire pour Root/Record1/Field1, mais pas pour l'une des trois références Field1 situées sous Root/Record1/Record1.

Les références cycliques sont sujettes aux restrictions suivantes :

  • Les noeuds d'un chemin de cycle (noeuds situés entre le premier et le dernier enregistrement dans une référence cyclique) ne peuvent pas apparaître à un autre endroit de la spécification.

  • Les éléments d'un chemin de cycle ne peuvent être la source ou la cible d'une opération quelconque de glisser-déplacer ou de couper-coller.

  • Les cycles ne peuvent pas se chevaucher.

  • L'enregistrement de base d'une référence cyclique ne peut pas être le noeud racine de la spécification.

Important

  • La valeur de la propriété Occurrences minimales de l'onglet Référence pour le noeud de la référence cyclique doit être égale à 0. La valeur 1 provoque une boucle infinie.

Remarque

  • Lorsque vous importez un schéma contenant une référence cyclique, l'Éditeur BizTalk ne vérifie pas automatiquement que la référence cyclique est valide.

Voir aussi

Création de références circulaires

Portée des propriétés


Intégration des valeurs par défaut

Si une spécification source contient un champ de type Attribut, et qu'une instance de document entrant basée sur la spécification source ne contient pas ce champ, vous voudrez certainement que la spécification fournisse une valeur par défaut pour ce champ. Pour définir la valeur par défaut d'un champ dans une spécification, mettez le champ en surbrillance dans l'arborescence de spécification, et dans l'onglet Déclaration, entrez une valeur numérique dans le champ Valeur pour la propriété Valeur par défaut. La propriété Valeur par défaut apparaît uniquement si la propriété Type possède la valeur Attribut. Si une instance de document entrant ne contient pas le champ, la valeur par défaut du champ est fournie. Si une instance de document entrant contient le champ, la valeur par défaut est ignorée.


Prise en charge des espaces de noms

Cette section traite des rubriques suivantes :

  • Déclarations d'espaces de noms

  • Conservation des espaces de noms dans les fichiers importés


Déclarations d'espaces de noms

Les espaces de noms qui sont déclarés dans une spécification sont affichés dans l'onglet Espace de noms de l'Éditeur BizTalk. Le tableau suivant indique les préfixes et espaces de noms qui apparaissent par défaut dans l'onglet Espace de noms lors de l'ouverture d'une spécification dans l'Éditeur BizTalk. Vous ne pouvez pas modifier ces préfixes et espaces de noms.

Préfixe | Espace de noms
(valeur par défaut) | urn:schemas-microsoft-com:xml-data
b | urn:schemas-microsoft-com:BizTalkServer
d | urn:schemas-microsoft-com:datatypes

Remarques

  • L'espace de noms suivant n'est pas pris en charge par BizTalk Server :

    SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/"

Vous pouvez déclarer des espaces de noms personnalisés dans une spécification en tapant un préfixe d'espace de noms dans la colonne Préfixe et un espace de noms dans la colonne Nom de ressource uniforme de l'onglet Espace de noms. L'Éditeur BizTalk ne valide pas le nom de ressource uniforme introduit pour un espace de noms.

Vous pouvez également ajouter une annotation personnalisée à chaque enregistrement ou champ. Une annotation personnalisée se compose d'une paire préfixe-nom et d'une valeur associée. L'exemple ci-dessous illustre la syntaxe de la paire préfixe-nom :

préfixe:nom

Dans l'onglet Déclaration ou Référence, tapez une paire préfixe-nom dans la colonne Propriété et entrez une valeur dans la colonne Valeur. Les valeurs des propriétés entrées dans l'onglet Déclaration ont un champ d'application global, tandis que les valeurs des propriétés entrées dans l'onglet Référence ont un champ d'application local. Pour plus d'informations sur les champs d'application globaux et locaux, voir Portée des propriétés. Pour plus d'informations sur l'addition d'annotations personnalisées, voir Ajout d'annotations personnalisées.

Voir aussi

Ajout d'annotations personnalisées

Déclaration des espaces de noms

Conservation des espaces de noms dans les fichiers importés

Portée des propriétés


Conservation des espaces de noms dans les fichiers importés

Vous pouvez importer trois types de fichiers dans l'Éditeur BizTalk : schémas XDR (XML-Data Reduced), instances XML bien formées et définitions de type de document (DTD). L'Éditeur BizTalk manipule différemment les espaces de noms et les paires préfixe-nom pour chaque type de document.

Importation d'un schéma XDR

Lorsque vous importez un schéma XDR, les espaces de noms existants sont manipulés de la manière suivante :

  • Les déclarations d'espaces de noms sont conservées en guise d'espaces de noms personnalisés et apparaissent dans l'onglet Espace de noms en dessous des espaces de noms par défaut.

  • Les préfixes d'espaces de noms personnalisés (à l'exception de ceux associés aux propriétés Nom et Type) sont préservés uniquement si l'espace de noms associé est déclaré.

Remarque

  • L'Éditeur BizTalk ne peut pas importer un schéma XDR avec un préfixe d'espace de noms associé à la propriété Nom ou Type.

Importation d'une instance XML bien formée

Lorsque vous importez une instance de document XML bien formée, les déclarations d'espaces de noms sont supprimées du document et le symbole séparateur préfixe-nom qui est le caractère deux points (:) est modifié en trait de soulignement (_), de manière à conserver l'intention originale du préfixe d'espace de noms. Exemple :

préfixe_nom

Important

  • Si vous importez une instance de document XML bien formée contenant une paire préfixe/nom d'espace de noms, que vous enregistrez l'instance importée en tant que spécification, puis que vous essayez de valider l'instance du document d'origine avec la nouvelle spécification, la validation d'instance échoue. Dans la nouvelle spécification, supprimez le noeud qui contient la paire préfixe/nom, puis pour l'enregistrement parent de ce noeud (onglet Déclaration), sélectionnez la valeur Ouvrir pour la propriété Modèle. Enregistrez la spécification. Vous pouvez maintenant valider l'instance du document avec cette spécification.

Remarque

  • L'Éditeur BizTalk ne peut pas importer un document contenant un préfixe d'espace de noms si l'espace de noms associé n'a pas été déclaré dans le document.

Importation d'une DTD

Lorsque vous importez une DTD contenant une paire préfixe-nom, le symbole séparateur qui est le caractère deux points (:) est modifié en trait de soulignement (_). De cette manière, en termes de placement au sein de la structure globale, l'objectif initial du préfixe est maintenu même si la notation elle-même du préfixe n'est pas prise en charge. Exemple :

préfixe_nom

Voir aussi

Déclarations d'espaces de noms


Ajout d'annotations SQL

Vous pouvez spécifier une annotation SQL pour n'importe quel noeud d'une spécification. La spécification d'une annotation SQL dans l'onglet Déclaration crée une annotation dont le champ d'application est global. L'annotation est enregistrée dans la déclaration ElementType ou AttributeType de la spécification. La spécification d'une annotation SQL dans l'onglet Référence crée une annotation dont le champ d'application est local. L'annotation est enregistrée dans la référence Élément ou Attribut de la spécification.

Vous pouvez sélectionner une annotation SQL dans la liste qui apparaît lorsque vous double-cliquez sur un champ vide dans la colonne Propriété de l'onglet Déclaration ou de l'onglet Référence à l'endroit d'un noeud d'une spécification. Entrez une valeur pour l'annotation SQL dans le champ correspondant de la colonne Valeur. Pour toutes les annotations SQL à l'exception de "sql:relationship" et "sql:xpath-query", la valeur est habituellement une chaîne de caractères. Pour plus d'informations sur l'ajout d'annotations SQL et autres annotations personnalisées, voir Ajout d'annotations personnalisées.

La liste ci-dessous indique toutes les annotations SQL possibles dans l'Éditeur BizTalk :

  • sql:datatype

  • sql:field

  • sql:id

  • sql:id-prefix

  • sql:is-constant

  • sql:key-fields

  • sql:limit-field

  • sql:limit-value

  • sql:map-field

  • sql:is-mapping-schema

  • sql:overflow-field

  • sql:relation

  • sql:relationship

  • sql:target-namespace

  • sql:url-encode

  • sql:use-cdata

  • sql:xpath-query

La valeur de "sql:relationship" est une ou plusieurs paires nom-valeur, et le nom figurant dans chaque paire nom-valeur doit être un des quatre noms suivants : key, key-relation, foreign-key ou foreign-relation. La valeur de "sql:xpath-query" se compose de deux parties : la première partie est constituée d'une ou de plusieurs paires nom-valeur comprenant un ou des attributs, la seconde partie désignant le contenu de "sql:xpath-query", représenté par "contenu=...". Ces deux parties sont séparées par le caractère « # ».

Le tableau ci-dessous illustre des exemples corrects d'annotations SQL "sql:relationship" et "sql:xpath-query".

Annotation SQL | Exemples de valeurs
sql:relationship | key="CustomerID"
sql:relationship | key-relation="Cust"
sql:relationship | foreign-key="CustomerID"
sql:relationship | foreign-relation="Orders"
sql:xpath-query | mapping-schema="Schema.xml" #content=Employees

Remarques

  • L'Éditeur BizTalk ne limite pas la sélection des annotations SQL à celles qui sont adaptées dans le contexte en vigueur. Par exemple, "sql:relationship" et "xpath-query" sont disponibles dans l'onglet Déclaration, même si leur utilisation doit être limitée à l'onglet Référence.

  • Lorsque vous spécifiez une annotation SQL, un espace de noms avec un préfixe "sql" ainsi que la valeur URN correspondante sont automatiquement déclarés dans l'onglet Espace de noms.

  • Lorsque vous copiez ou coupez un noeud comportant des annotations SQL spécifiées dans l'onglet Référence, puis que vous collez ce noeud à un autre endroit de la spécification, les annotations SQL ne figurent plus dans le nouveau noeud.

Voir aussi

Ajout d'annotations personnalisées

Déclarations d'espaces de noms

Portée des propriétés


Ressources

Cette section contient des informations sur les rubriques suivantes :

  • Résumé des types de données et des valeurs de types de données

  • Liste récapitulative des documents EDI inclus


Résumé des types de données et des valeurs de types de données

La liste ci-dessous fournit des détails et des exemples permettant de vous aider à spécifier une valeur pour la propriété Type de données de l'onglet Déclaration. Après avoir sélectionné une des options suivantes de la liste Type de données, vous devrez probablement spécifier une valeur dans la zone Valeurs des types de données.

Type de données

Character

Contient une chaîne de longueur égale à un caractère.

StringString

Contient une chaîne de texte.

NumberNumber

Contient un nombre de chiffres et peut inclure un signe à gauche, des fractions et un exposant. La ponctuation anglaise est utilisée : par exemple, 15, 3.14, -123.456E+10.

Integer (int)Integer (int)

Contient un nombre et peut inclure un signe en option. Ne peut contenir une fraction ou un exposant : par exemple, 1, 58502, -13.

FloatFloat

Contient un nombre, avec un nombre de chiffres illimité : ce type de données peut inclure un signe à gauche, des fractions ou un exposant.

Fixed Point (14.4)Fixed Point (14.4)

Idem que le type Number, mais limité à 14 chiffres à gauche du point de ponctuation et à 4 chiffres à droite de celui-ci : par exemple, 12.0044. Ce type de données peut être utilisé pour les valeurs monétaires.

Boolean

Contient une expression égale à TRUE (1) ou FALSE (0).

Date

Contient une date au format ISO 8601, sans indication d'heure : par exemple, 1988-04-07.

Date Time

Contient une date au format ISO 8601, avec une indication d'heure en option et pas d'informations de zone en option. Les fractions de secondes peuvent être définies jusqu'aux nanosecondes : par exemple, 1988-04-07T18:39:09.

Date Time.tz

Contient une date au format ISO 8601, avec une indication d'heure en option et des informations de zone en option. Les fractions de secondes peuvent être définies jusqu'aux nanosecondes : par exemple, 1988-04-07T18:39:09-08:00.

Time

Contient une heure au format ISO 8601, sans indication de date et de zone : par exemple, 08:15:27.

Time.tz

Contient une heure au format ISO 8601, sans indication de date mais avec des informations de zone en option : par exemple, 08:15:27-05:00.

Byte (i1)

Contient un nombre et peut contenir un signe en option, comme un signe moins (-). Ne peut contenir une fraction ou un exposant : par exemple, 1, 127, -128.

Word (i2)

Contient un nombre et peut contenir un signe en option, comme un signe moins (-). Ne peut contenir une fraction ou un exposant : par exemple, 1, 703, -32768.

Integer (i4)

Contient un nombre et peut contenir un signe en option, comme un signe moins (-). Ne peut contenir une fraction ou un exposant : par exemple, 1, 703, -32768, 148343, -1000000000.

Double Integer (i8)

Contient un nombre et peut contenir un signe en option, comme un signe moins (-). Ne peut contenir une fraction ou un exposant : par exemple, 1, 703, -32768, 148343, -1000000000.

Unsigned Byte (ui1)

Contient un nombre. Ne peut contenir un signe, une fraction ou un exposant : par exemple, 1, 255.

Unsigned Word (ui2)

Contient un nombre. Ne peut contenir un signe, une fraction ou un exposant : par exemple, 1, 255, 65535.

Unsigned Integer (ui4)

Contient un nombre. Ne peut contenir un signe, une fraction ou un exposant : par exemple, 1, 703, 3000000000.

Unsigned Double Integer (ui8)

Contient un nombre. Ne peut contenir un signe, une fraction ou un exposant : par exemple, 1, 703, 3000000000.

Real (r4)

Contient un nombre de valeur minimale 1.17549435E–38F et de valeur maximale 3.40282347E+38F : par exemple, 3.14285718E+2.

Double Real (r8)

Contient un nombre de valeur minimale 2.2250738585072014E308 et de valeur maximale 1.7976931348623157E+308 : par exemple, .314159265358979E+1.

Universal Unique Identifier (uuid)

Contient des chiffres hexadécimaux représentant des octets, avec des tirets en option pouvant être ignorés : par exemple, 333C7BC4-460F-11D0-BC04-0080C7055A83.

Uniform Resource Identifier (uri)

Contient un identificateur URI (Uniform Resource Identifier).

Binary (base64)

Contient le codage binaire d'un texte binaire en caractères : par exemple, la conversion d'une image GIF (Graphic Interchange Format) en une représentation texte.

Binary (hex)

Contient un chiffre hexadécimal binaire qui représente des octets : par exemple, 0x0ffaa.

ID

Spécifie le champ en tant que ID.

IDREF

Spécifie que le champ est référencé vers le champ contenant la valeur ID.

IDREFS

Spécifie que le champ contient une liste des ID, ceux-ci étant séparés par un espace.

Enumeration

Affecte une séquence ordinale à une série de valeurs : par exemple, la série Lundi, Mardi, Mercredi peut être énumérée en tant que 1 2 3.

Remarque

  • Le type de données Fixed Point (14.4) peut être utilisé pour les valeurs monétaires.

Voir aussi

Définition des propriétés de déclaration


Liste capitulative des documents EDI inclus

L'Éditeur BizTalk prend en charge tous les documents de type EDI. Le tableau suivant indique les spécifications standards, versions et normes de documents pour les documents EDI disponibles lorsque vous créez une nouvelle spécification basée sur une norme. Pour plus d'informations, voir Création d'une spécification basée sur un standard.

Standard Version Normes de documents
X12
  • 2040

  • 3010

  • 3060

  • 4010
  • 810

  • 832

  • 846

  • 850

  • 852 (disponible dans toutes les versions sauf 2040)

  • 855

  • 856

  • 861

  • 864

  • 867

  • 940 (disponible uniquement avec les versions 3060 et 4010)

  • 944 (disponible uniquement avec les versions 3060 et 4010)

  • 997
EDIFACT
  • D93A

  • D95A

  • D95B

  • D97B

  • D98A

  • D98B
  • APERAK (disponible dans toutes les versions sauf D93A)

  • CONTRL (disponible uniquement avec les versions D98A et D98B)

  • DESADV

  • INVOIC

  • INVRPT

  • ORDERS

  • ORDRSP

  • PARTIN

  • PAYEXT

  • PRICAT

  • PRODAT (disponible uniquement avec les versions D97B, D98A et D98B)

  • RECADV (disponible uniquement avec les versions D97B, D98A et D98B)

  • SLSRPT
XML
  • Non applicable
  • AvisExpéditionAvancéeCommun

  • AvisInventaireCommun

  • FactureCommune

  • ProfilPartenaireCommun

  • OACommun

  • RécépisséOACommun

  • CataloguePrixCommun

  • AvisExpéditionCommun

  • BordereauExpéditionCommun

  • AccuséRéceptionStandard

  • Enveloppe SOAP simple

  • Enveloppe BTF1

Voir aussi

Création d'une spécification basée sur un standard


Mappage de données

Le Mappeur BizTalk est un outil de conception de traduction permettant de créer une correspondance entre les enregistrements et les champs de deux formats de spécifications différents. Le Mappeur BizTalk utilise des liens et des fonctoids pour effectuer cette traduction. Les fonctoids réalisent des opérations allant de simples calculs à l'exécution de scripts élaborés. Vous pouvez utiliser le Mappeur BizTalk pour représenter graphiquement la relation de transformation structurelle entre les éléments de données source et de destination. Cette fonctionnalité de renvoi et de manipulation des données crée un mappage qui fournit une série d'instructions définissant la relation entre deux formats de spécifications différents. Les formats de spécifications sont définis à l'aide de l'Éditeur BizTalk.

Un mappage représente les transformations de données entre une spécification source et une spécification de destination. Microsoft BizTalk Server 2000 et le composant XSL (Extensible Stylesheet Language) du parseur Microsoft XML version 3.0 utilisent les informations de transformation de données d'exécution fournies par un mappage. Lorsque vous créez un mappage, les informations de transformation peuvent être affichées dans l'onglet Sortie du Mappeur BizTalk.

Le Mappeur BizTalk permet l'échange ouvert de spécifications dans un format de données XML (Extensible Markup Language). Le Mappeur BizTalk ne peut ouvrir que des spécifications enregistrées dans l'Éditeur BizTalk. Le Mappeur BizTalk ne peut pas ouvrir les fichiers XML génériques ou les fichiers non-XML. Pour traduire deux fichiers XML génériques, vous devez tout d'abord les importer dans l'Éditeur BizTalk et les enregistrer en tant que spécifications.

Le Mappeur BizTalk prend en charge divers scénarios de mappage allant de simples relations parent-enfant à des boucles d'enregistrements et de hiérarchies détaillées et complexes. Lorsque le processus de mappage est terminé, un composant sérialiseur utilise la spécification pour créer un format de fichier pouvant être reconnu par votre partenaire commercial ou une application interne. Le Mappeur BizTalk comprend également un composant compilateur de feuilles de style qui utilise la représentation visuelle du mappage et crée une feuille de style XSL.

L'illustration suivante montre le processus de mappage d'une spécification source vers une spécification de destination. Le fichier source est un document de type EDI et le fichier de destination un document de type flat-file. Dans cet exemple, la structure du document EDI (Electronic Data Interchange) est convertie en un format XML intermédiaire, dont la structure est représentée par une spécification XDR (XML-Data Reduced). Le format final des données est un fichier plat. Un parseur basé sur les données (utilisant la spécification XDR) crée une version XML de la spécification EDI source. Le moteur XSL transforme ensuite cette représentation XML source en une représentation XML du format du fichier de destination. Ensuite, la spécification de destination est sérialisée vers le format natif du fichier de destination, qui est un fichier plat dans cet exemple.

Transformation d'un document EDI en fichier de type flat-file
Spécification
XDR
Spécification
XDR
Mappage XSLT
Moteur XSL
EDI en fichier de type flat-file
Sérialiseuer
Parseur de données
Document XML
Document EDI
Document XML
Document Flat-file
  • Pour obtenir de l'aide sur des tâches spécifiques, voir Comment.

  • Pour obtenir des informations générales, voir Concepts.

  • Pour des ressources supplémentaires, voir Ressources.

  • Pour des instructions sur la résolution des problèmes, voir Dépannage de l'Éditeur BizTalk et du Mappeur BizTalk.

Voir aussi

Interface utilisateur du Mappeur BizTalk


Comment...

Cette section présente les procédures de mappage des données d'une spécification à une autre. Il est vivement conseillé de revoir la section Concepts afin de bien comprendre les liaisons et les fonctoids, ainsi que d'autres fonctionnalités et propriétés de mappage.

Cette section traite des rubriques suivantes :

  • Modification des options du Mappeur BizTalk

  • Création de nouveaux mappages

  • Ouverture de mappages

  • Enregistrement, stockage et fermeture de mappages

  • Remplacement de spécifications

  • Gestion des fonctoids

  • Gestion de liaisons

  • Création et gestion des mappages compilés

  • Tests de mappages

  • Gestion de vues

  • Personnalisation de l'interface utilisateur


Modification des options du Mappeur BizTalk

La boîte de dialogue Options du Mappeur BizTalk vous permet de définir des options générales et de sélectionner les couleurs de la grille de mappage.

  • Pour afficher la boîte de dialogue Options du Mappeur BizTalk, dans le menu Outils, cliquez sur Options . L'onglet Général apparaît par défaut.

Pour plus d'informations sur le mode d'utilisation de cette boîte de dialogue, reportez-vous aux rubriques suivantes :

  • Options du Mappeur BizTalk : Onglet Général

  • Options du Mappeur BizTalk : Onglet Couleurs


Options du Mappeur BizTalk : Onglet Général

Pour plus d'informations sur le mode d'accès à la boîte de dialogue Options du Mappeur BizTalk, voir Modification des options du Mappeur Options.

L'onglet Général comporte six options qui vous permettent de personnaliser le Mappeur BizTalk :

  • Avertissements pour les erreurs de liaison simple (activée par défaut) : vous recevez un message d'avertissement lorsque vous tentez de créer une liaison entre des noeuds dont les types de données ne correspondent pas.

  • Afficher les liaisons du compilateur (activée par défaut) : les liaisons du compilateur apparaissent sur un mappage après la compilation.

  • Supprimer les liaisons du compilateur après une action de l'utilisateur (désactivée par défaut) : les liaisons du compilateur disparaissent une fois qu'une action a été effectuée dans le Mappeur BizTalk.

  • Autoriser les liaisons du contenu des enregistrements (désactivée par défaut) : des liaisons du contenu des enregistrements vers les fonctoids peuvent être créées.

    Remarque

    • Certains fonctoids possèdent des entrées ou des sorties qui, n'utilisant pas le contenu des enregistrements ne sont donc pas affectés par l'option Autoriser les liaisons du contenu des enregistrements. Ces entrées/sorties correspondent aux fonctoids logiques (sortie), au fonctoid Nombre (entrée), au fonctoid Itération (entrée) et au fonctoid Bouclage (entrée et sortie).
  • Autoriser plusieurs entrées dans les noeuds de destination de l'arborescence (désactivée par défaut) : deux liaisons ou plus peuvent être établies vers un noeud de l'arborescence Spécification de destination.

  • Invite d'enregistrement avant le test du mappage (activée par défaut) : lorsque vous cliquez sur Tester le mappage dans le menu Outils, le Mappeur BizTalk affiche une boîte de dialogue qui vous demande d'enregistrer les modifications apportées au fichier de mappage.

Voir aussi

Options du Mappeur BizTalk : Onglet Couleurs


Options du Mappeur BizTalk : Onglet Couleurs

Pour plus d'informations sur le mode d'accès à la boîte de dialogue Options du Mappeur BizTalk, voir Modification des options du Mappeur BizTalk.

L'onglet Couleurs inclut des options qui vous permettent de personnaliser les couleurs de la grille de mappage. Pour plus d'informations sur ces options, voir les rubriques suivantes :

  • Modification des couleurs de la grille de mappage

  • Modification de la couleur des liaisons

  • Modification de la couleur des objects sélectionnés

  • Modification de la couleur des avertissements du compilateur

  • Restauration des couleurs par défaut

Voir aussi

Options du Mappeur BizTalk : Onglet Général


Création de nouveaux mappages

  1. Dans le menu Fichier, cliquez sur Nouveau.

    La boîte de dialogue Sélection du type de spécification source s'affiche.

  2. Double-cliquez sur l'une des options suivantes :
    • Fichiers locaux, puis passez à l'étape 3.

    • Modèles, puis passez à l'étape 4.

    • Fichiers WebDAV, puis passez à l'étape 3.
  3. Recherchez le dossier qui contient la spécification source que vous voulez ouvrir, puis passez à l'étape 5.

  4. Cliquez sur EDIFACT, X12 ou XML, puis cliquez sur OK.

    Si vous sélectionnez EDIFACT ou X12, vous devez également sélectionner la version que vous voulez utiliser. Cliquez sur le dossier correspondant à la version de votre choix, puis cliquez sur OK et passez à l'étape 5.

  5. Sélectionnez la spécification source, puis cliquez sur Ouvrir ou sur OK selon le cas.

    La boîte de dialogue Sélection du type de spécification de destination s'affiche.

  6. Double-cliquez sur l'une des options suivantes :
    • Fichiers locaux, puis passez à l'étape 7.

    • Modèles, puis passez à l'étape 8.

    • Fichiers WebDAV, puis passez à l'étape 7.
  7. Recherchez le dossier contenant la spécification de destination que vous souhaitez ouvrir, puis passez à l'étape 9.

  8. Cliquez sur EDIFACT, X12 ou XML, puis cliquez sur OK.

    Si vous sélectionnez EDIFACTou X12, vous devez également sélectionner la version que vous voulez utiliser. Cliquez sur le dossier correspondant à la version de votre choix, puis cliquez sur OK et passez à l'étape 9.

  9. Sélectionnez la spécification de destination, puis cliquez sur Ouvrir ou sur OK selon le cas.

Remarque

  • Pour créer un mappage, vous devez indiquer la spécification source ainsi que la spécification de destination.

Voir aussi

Remplacement des spécifications de destination

Remplacement des spécifications source


Ouverture de mappages

Cette section traite des procédures suivantes :

  • Ouverture de mappages à partir d'un disque dur local

  • Extraction de mappages à partir de WebDAV


Ouverture de mappages à partir d'un disque dur local

  1. Dans le menu Fichier, cliquez sur Ouvrir.

    La boîte de dialogue Ouvrir la source du mappage s'affiche.

  2. Recherchez le dossier contenant le mappage que vous voulez ouvrir.

  3. Sélectionnez un mappage dans la liste, puis cliquez sur Ouvrir.

Voir aussi

Extraction de mappages à partir de WebDAV


Extraction de mappages à partir de WebDAV

  1. Dans le menu Fichier, cliquez sur Extraire à partir de WebDav.

    La boîte de dialogue Extraire à partir de WebDav s'affiche.

  2. Dans la liste Serveur, cliquez sur le nom d'un serveur.

  3. Recherchez le dossier contenant le mappage que vous voulez extraire, sélectionnez le mappage, puis cliquez sur Ouvrir.

Remarques

  • Il est possible que votre première connexion à un serveur WebDAV distant soit lente.

  • Pour extraire un mappage WebDAV, vous devez être autorisé à extraire des fichiers du serveur.

Voir aussi

Ouverture de mappages à partir d'un disque dur local

Dépannage de l'Éditeur BizTalk et du Mappeur BizTalk


Enregistrement, stockage et fermeture de mappages

Cette section traite des procédures suivantes :

  • Enregistrement de nouveaux mappages

  • Enregistrement de mappages existants

  • Enregistrement de mappages compilés

  • Stockage de mappages

  • Fermeture de mappages


Enregistrement de nouveaux mappages

  1. Dans le menu Fichier, cliquez sur Enregistrer sous.

    La boîte de dialogue Enregistrer la source du mappage sous s'affiche.

  2. Dans la zone Nom de fichier, tapez le nom du mappage.

  3. Dans la liste Codage, sélectionnez UTF-8 ou Unicode, puis cliquez sur Enregistrer.

    Si vous souhaitez utiliser une spécification associée à des caractères ASCII, cliquez sur UTF-8. Dans le cas de spécifications associées à des jeux de caractères codés sur deux octets, cliquez sur Unicode.

Remarques

  • Lorsque vous enregistrez un mappage, le Mappeur BizTalk le compile automatiquement. Vous pouvez afficher les résultats de la compilation du mappage dans l'onglet Sortie.

  • Lorsque vous enregistrez un mappage, le Mappeur BizTalk l'enregistre sur votre disque dur. Pour stocker un mappage dans WebDAV, vous devez être autorisé à stocker des fichiers sur le serveur.

Voir aussi

Stockage de mappages


Enregistrement de mappages existants

  • Dans le menu Fichier, cliquez sur Enregistrer.

Remarques

  • Lorsque vous enregistrez un mappage, le Mappeur BizTalk le compile automatiquement. Vous pouvez afficher les résultats de la compilation du mappage dans l'onglet Sortie.

  • Lorsque vous enregistrez un mappage, le Mappeur BizTalk l'enregistre sur votre disque dur. Pour stocker un mappage dans WebDAV, vous devez être autorisé à stocker des fichiers sur le serveur.

Voir aussi

Stockage de mappages


Enregistrement de mappages compilés

  1. Dans le menu Fichier, cliquez sur Enregistrer le mappage compilé sous.

    La boîte de dialogue Enregistrer le mappage compilé sous s'affiche.

  2. Dans la zone Nom de fichier, tapez le nom du fichier, puis cliquez sur Enregistrer.

Voir aussi

Stockage de mappages


Stockage de mappages

  1. Dans le menu Fichier, cliquez sur Stocker dans WebDAV.

    La boîte de dialogue Stocker dans WebDav s'affiche.

  2. Dans la liste Serveur, cliquez sur le nom d'un serveur.

  3. Recherchez le dossier que vous voulez utiliser pour stocker votre mappage, puis tapez le nom du fichier dans la boîte de dialogue Nom de fichier.

  4. Dans la liste Codage, sélectionnez UTF-8 ou Unicode, puis cliquez sur Enregistrer.

    Si vous voulez utiliser une spécification associée aux caractères ASCII, cliquez sur UTF-8. Dans le cas de spécifications associées aux jeux de caractères codés sur deux octets, cliquez sur Unicode.

Important

  • Vous ne pouvez pas stocker des fichiers dont les noms comportent des jeux de caractères codés sur deux octets si vos paramètres régionaux sont incorrects. Pour plus d'informations, voir ???.xml apparaît dans la boîte de dialogue WebDAV .

Remarques

  • Il est possible que votre première connexion à un serveur WebDAV distant soit lente.

  • Pour stocker un mappage dans WebDAV, vous devez être autorisé à stocker des fichiers sur le serveur.

Voir aussi

Dépannage de l'Éditeur BizTalk et du Mappeur BizTalk


Fermeture de mappages

  • Dans le menu Fichier, cliquez sur Fermer.


Remplacement de spécifications

Cette section traite des procédures suivantes :

  • Remplacement des spécifications source

  • Remplacement des spécifications de destination


Remplacement des spécifications source

  1. Dans le menu Edition, cliquez sur Remplacer la spécification source.

    Si vous n'avez pas enregistré votre mappage, le système vous demande d'enregistrer les modifications apportées à la source du mappage.

    La boîte de dialogue <b>Sélectionner le type de spécification source</b> s'affiche.

  2. Double-cliquez sur l'une des options suivantes :
    • Fichiers locaux, puis passez à l'étape 3.

    • Modèles, puis passez à l'étape 4.

    • Fichiers WebDAV, puis passez à l'étape 3.
  3. Recherchez le dossier contenant la spécification source, puis passez à l'étape 5.

  4. Cliquez sur EDIFACT, X12 ou XML, puis cliquez sur OK.

    Si vous sélectionnez EDIFACT ou X12, vous devez également sélectionner la version que vous voulez utiliser. Cliquez sur le dossier correspondant à la version de votre choix, puis cliquez sur OK et passez à l'étape 5.

  5. Sélectionnez la spécification source, puis cliquez sur Ouvrir ou sur OK selon le cas.

Remarques

  • Les valeurs du test source sont conservez lorsque vous remplacez une spécification source, à condition que les champs associés à ces valeurs existent dans la nouvelle spécification. Pour plus d'informations sur les valeurs du test source, voir Test de liaisons.

  • L'onglet Avertissement répertorie tous les avertissements en rapport avec les liaisons qui peuvent s'interrompre suite au remplacement de la spécification source.

  • Vous pouvez également cliquer avec le bouton droit sur un enregistrement ou un champ dans l'arborescence Spécification source. Cliquez ensuite sur Remplacer la spécification.

Voir aussi

Remplacement des spécifications de destination

Test de liaisons


Remplacement des spécifications de destination

  1. Dans le menu Edition, cliquez sur Remplacer la spécification de destination.

    Si vous n'avez pas enregistré votre mappage, le système vous demande d'enregistrer les modifications apportées à la source du mappage.

    La boîte de dialogue Sélection du type de spécification de destination s'affiche.

  2. Double-cliquez sur l'une des options suivantes :
    • Fichiers locaux, puis passez à l'étape 3.

    • Modèles, puis passez à l'étape 4.

    • Fichiers WebDAV, puis passez à l'étape 3.
  3. Recherchez le dossier contenant la spécification de destination, puis passez à l'étape 5.

  4. Cliquez sur EDIFACT, X12 ou XML, puis cliquez sur OK.

    Si vous sélectionnez EDIFACT ou X12, vous devez également sélectionner la version que vous voulez utiliser. Cliquez sur le dossier correspondant à la version de votre choix, puis cliquez sur OK et passez à l'étape 5.

  5. Sélectionnez la spécification de destination, puis cliquez sur Ouvrir ou sur OK selon le cas.

Remarques

  • Les valeurs de constante de destination sont conservez lorsque vous remplacez une spécification de destination, à condition que les champs associés à ces valeurs existent dans la nouvelle spécification. Pour plus d'informations sur l'utilisation des constantes, voir Message de constantes.

  • L'onglet Avertissements répertorie tous les messages d'avertissement en rapport avec les liaisons pouvant s'interrompre suite au remplacement de la spécification de destination.

  • Vous pouvez également cliquer avec le bouton droit sur un enregistrement ou un champ dans l'arborescence Spécification de destination. Cliquez ensuite sur Remplacer la spécification.

Voir aussi

Ajout de valeurs de constantes

Remplacement des spécifications source


Gestion des fonctoids

Cette section traite des rubriques suivantes :

  • Utilisation de la palette de fonctoids

  • Modification des propriétés des fonctoids


Utilisation de la palette de fonctoids

La palette de fonctoids contient les fonctoids qui sont disponibles dans le Mappeur BizTalk. Vous pouvez sélectionner le fonctoid de votre choix dans la palette, puis le faire glisser vers la grille de mappage. Les différents types de fonctoids figurent dans des onglets. Vous pouvez utiliser les flèches de gauche ou de droite pour afficher les onglets masqués.

Cette section traite des procédures suivantes :

  • Ajout de fonctoids de chaîne

  • Ajout de fonctoids mathématiques

  • Ajout de fonctoids logiques

  • Ajout de fonctoids Date et Heure

  • Ajout de fonctoids de conversion

  • Ajout de fonctoids scientifiques

  • Ajout de fonctoids cumulés

  • Ajout de fonctoids de base de données

  • Ajout du fonctoid Script

  • Ajout du fonctoid Nombre d'enregistrements

  • Ajout du fonctoid Index

  • Ajout du fonctoid Itération

  • Ajout du fonctoid Mappage de valeurs

  • Ajout du fonctoid Mappage des valeurs (mise à plat)

  • Ajout du fonctoid Bouclage

  • Suppression de fonctoids

Voir aussi

Palette de fonctoids du Mappeur BizTalk

Présentation des fonctoids


Ajout de fonctoids de chaîne

  1. Dans le menu Affichage, cliquez sur Palette de fonctoids.

  2. Dans la Palette de fonctoids, cliquez sur l'onglet Chaîne.

  3. Déplacez un fonctoid de chaîne de la Palette de fonctoids vers la grille de mappage.

    Pour plus d'informations sur le fonctoid Concaténer, voir Fonctoids de chaîne.

  4. Déplacez un enregistrement ou un champ de l'arborescence Spécification source vers le fonctoid dans la grille de mappage, puis déplacez le fonctoid vers un enregistrement ou un champ dans l'arborescence Spécification de destination.

Important

  • Pour créer une liaison entre un fonctoid et un enregistrement, vous devez activer la propriété Autoriser les liaisons du contenu des enregistrements. Pour cela, cliquez sur Options dans le menu Outils. Dans la boîte de dialogue Options du Mappeur BizTalk, onglet Général, sélectionnez la case à cocher Autoriser les liaisons du contenu des enregistrements et cliquez sur OK.

Remarque

  • Il se peut que vous deviez développer les arborescences de spécifications pour afficher les enregistrements ou les champs que vous souhaitez mapper. Pour plus d'informations, voir Développement des éléments de l'arborescence.

Voir aussi

Autoriser les liaisons du contenu des enregistrements

Création de liaisons entre les champs et les fonctoids

Création de liaisons entre les enregistrements et les fonctoids

Fonctoids de chaîne

Présentation des fonctoids


Ajout de fonctoids mathématiques

  1. Dans le menu Affichage, cliquez sur Palette de fonctoids.

  2. Dans la Palette de fonctoids, cliquez sur l'onglet Mathématique.

  3. Faites glisser un fonctoid mathématique de la Palette de fonctoids vers la grille de mappage.

    Pour plus d'informations sur les fonctoids mathématiques spécifiques, voir Fonctoids mathématiques.

  4. Déplacez un enregistrement ou un champ de l'arborescence Spécification source vers le fonctoid dans la grille de mappage, puis déplacez le fonctoid vers un enregistrement ou un champ dans l'arborescence Spécification de destination.

Important

  • Pour créer une liaison entre un fonctoid et un enregistrement, vous devez activer la propriété Autoriser les liaisons du contenu des enregistrements. Pour cela, cliquez sur Options dans le menu Outils. Dans la boîte de dialogue Options du Mappeur BizTalk, onglet Général, sélectionnez la case à cocher Autoriser les liaisons du contenu des enregistrements et cliquez sur OK.

Remarque

  • Il se peut que vous deviez développer les arborescences de spécifications pour afficher les enregistrements ou les champs que vous souhaitez mapper. Pour plus d'informations, voir Développement des éléments de l'arborescence.

Voir aussi

Autoriser les liaisons du contenu des enregistrements

Création de liaisons entre les champs et les fonctoids

Création de liaisons entre les enregistrements et les fonctoids

Fonctoids mathématiques

Présentation des fonctoids


Ajout de fonctoids logiques

  1. Dans le menu Affichage, cliquez sur Palette de fonctoids.

  2. Dans la Palette de fonctoids, cliquez sur l'onglet Logique.

  3. Faites glisser un fonctoid logique de la Palette de fonctoids vers la grille de mappage.

    Pour plus d'informations sur les fonctoids logiques spécifiques, voir Fonctoids logiques.

  4. Déplacez un enregistrement ou un champ de l'arborescence Spécification source vers le fonctoid dans la grille de mappage, puis déplacez le fonctoid vers un enregistrement dans l'arborescence Spécification de destination.

Important

  • Pour créer une liaison entre un fonctoid et un enregistrement, vous devez activer la propriété Autoriser les liaisons du contenu des enregistrements. Pour cela, cliquez sur Options dans le menu Outils. Dans la boîte de dialogue Options du Mappeur BizTalk, onglet Général, sélectionnez la case à cocher Autoriser les liaisons du contenu des enregistrements et cliquez sur OK.

Remarques

  • Les fonctoids logiques respectent la casse lors de la comparaison de deux chaînes. Par exemple, "Abc" et "abc" ne sont pas similaires. La casse n'est pas prise en compte uniquement lors de la comparaison de chaînes qui représentent les valeurs booléennes TRUE et FALSE. Dans ce cas, il n'existe aucune différence entre "True" et "true".

  • Il se peut que vous deviez développer les arborescences de spécifications pour afficher les enregistrements ou les champs que vous souhaitez mapper. Pour plus d'informations, voir Développement des éléments de l'arborescence.

Voir aussi

Autoriser les liaisons du contenu des enregistrements

Création de liaisons entre les champs et les fonctoids

Création de liaisons entre les enregistrements et les fonctoids

Fonctoids logiques

Présentation des fonctoids


Ajout de fonctoids Date et Heure

  1. Dans le menu Affichage, cliquez sur Palette de fonctoids.

  2. Dans la Palette de fonctoids, cliquez sur l'onglet Date/Heure.

  3. Faites glisser un fonctoid Date et Heure de la Palette de fonctoids vers la grille de mappage.

    Pour plus d'informations sur les fonctoids de date et d'heure spécifiques, voir Fonctoids Date et Heure.

  4. Déplacez un enregistrement ou un champ de l'arborescence Spécification source vers le fonctoid dans la grille de mappage, puis déplacez le fonctoid vers un enregistrement ou un champ dans l'arborescence Spécification de destination.

Important

  • Pour créer une liaison entre un fonctoid et un enregistrement, vous devez activer la propriété Autoriser les liaisons du contenu des enregistrements. Pour cela, cliquez sur Options dans le menu Outils. Dans la boîte de dialogue Options du Mappeur BizTalk, onglet Général, sélectionnez la case à cocher Autoriser les liaisons du contenu des enregistrements et cliquez sur OK.

Remarques

  • Les fonctoids Date, Heure et Date et Heure nécessitent uniquement une liaison vers un champ ou un enregistrement de l'arborescence Spécification de destination.

  • Il se peut que vous deviez développer les arborescences de spécifications pour afficher les enregistrements ou les champs que vous souhaitez mapper. Pour plus d'informations, voir Développement des éléments de l'arborescence.

Voir aussi

Autoriser les liaisons du contenu des enregistrements

Création de liaisons entre les champs et les fonctoids

Création de liaisons entre les enregistrements et les fonctoids

Fonctoids Date et Heure

Présentation des fonctoids


Ajout de fonctoids de conversion

  1. Dans le menu Affichage, cliquez sur Palette de fonctoids.

  2. Dans la Palette de fonctoids, cliquez sur l'onglet Conversion.

    Il se peut que vous deviez cliquer sur la flèche de droite de la Palette de fonctoids pour afficher l'onglet.

  3. Faites glisser un fonctoid de conversion de la Palette de fonctoids vers la grille de mappage.

    Pour plus d'informations sur les fonctoids de conversion spécifiques, voir Fonctoids de conversion.

  4. Déplacez un enregistrement ou un champ de l'arborescence Spécification source vers le fonctoid dans la grille de mappage, puis déplacez le fonctoid vers un enregistrement ou un champ dans l'arborescence Spécification de destination.

Important

  • Pour créer une liaison entre un fonctoid et un enregistrement, vous devez activer la propriété Autoriser les liaisons du contenu des enregistrements. Pour cela, cliquez sur Options dans le menu Outils. Dans la boîte de dialogue Options du Mappeur BizTalk, onglet Général, sélectionnez la case à cocher Autoriser les liaisons du contenu des enregistrements et cliquez sur OK.

Remarque

  • Il se peut que vous deviez développer les arborescences de spécifications pour afficher les enregistrements ou les champs que vous souhaitez mapper. Pour plus d'informations, voir Développement des éléments de l'arborescence.

Voir aussi

Autoriser les liaisons du contenu des enregistrements

Fonctoids de conversion

Création de liaisons entre les champs et les fonctoids

Création de liaisons entre les enregistrements et les fonctoids

Présentation des fonctoids


Ajout de fonctoids scientifiques

  1. Dans le menu Affichage, cliquez sur Palette de fonctoids.

  2. Dans la Palette de fonctoids, cliquez sur l'onglet Scientifique.

    Il se peut que vous deviez cliquer sur la flèche de droite de la Palette de fonctoids pour afficher l'onglet.

  3. Faites glisser un fonctoid scientifique de la Palette de fonctoids vers la grille de mappage.

    Pour plus d'informations sur les fonctoids scientifiques spécifiques, voir Fonctoids scientifiques.

  4. Déplacez un enregistrement ou un champ de l'arborescence Spécification source vers le fonctoid dans la grille de mappage, puis déplacez le fonctoid vers un enregistrement ou un champ dans l'arborescence Spécification de destination.

Important

  • Pour créer une liaison entre un fonctoid et un enregistrement, vous devez activer la propriété Autoriser les liaisons du contenu des enregistrements. Pour cela, cliquez sur Options dans le menu Outils. Dans la boîte de dialogue Options du Mappeur BizTalk, onglet Général, sélectionnez la case à cocher Autoriser les liaisons du contenu des enregistrements et cliquez sur OK.

Remarque

  • Il se peut que vous deviez développer les arborescences de spécifications pour afficher les enregistrements ou les champs que vous souhaitez mapper. Pour plus d'informations, voir Développement des éléments de l'arborescence.

Voir aussi

Autoriser les liaisons du contenu des enregistrements

Création de liaisons entre les champs et les fonctoids

Création de liaisons entre les enregistrements et les fonctoids

Fonctoids scientifiques

Présentation des fonctoids


Ajout de fonctoids cumulés

  1. Dans le menu Affichage, cliquez sur Palette de fonctoids.

  2. Dans la Palette de fonctoids, cliquez sur l'onglet Cumulé.

    Il se peut que vous deviez cliquer sur la flèche de droite de la Palette de fonctoids pour afficher l'onglet.

  3. Faites glisser un fonctoid cumulé de la Palette de fonctoids vers la grille de mappage.

    Pour plus d'informations sur les fonctoids cumulés spécifiques, voir Fonctoids cumulés.

  4. Déplacez un champ (avec un enregistrement parent en boucle) dans l'arborescence Spécification source vers le fonctoid dans la grille de mappage, puis déplacez le fonctoid vers un enregistrement ou un champ dans l'arborescence Spécification de destination.

    Pour plus d'informations sur les enregistrements de bouclage, voir Utilisation des fonctoids cumulés.

Important

  • Pour plus d'informations sur le contexte de cette procédure, voir Utilisation des fonctoids cumulés.

  • Pour créer une liaison entre un fonctoid et un enregistrement, vous devez activer la propriété Autoriser les liaisons du contenu des enregistrements. Pour cela, cliquez sur Options dans le menu Outils. Dans la boîte de dialogue Options du Mappeur BizTalk, onglet Général, sélectionnez la case à cocher Autoriser les liaisons du contenu des enregistrements et cliquez sur OK.

Remarque

  • Il se peut que vous deviez développer les arborescences de spécifications pour afficher les enregistrements ou les champs que vous souhaitez mapper. Pour plus d'informations, voir Développement des éléments de l'arborescence.

Voir aussi

Autoriser les liaisons du contenu des enregistrements

Création de liaisons entre les champs et les fonctoids

Création de liaisons entre les enregistrements et les fonctoids

Fonctoids cumulés

Présentation des fonctoids


Ajout de fonctoids de base de données

  1. Dans le menu Affichage, cliquez sur Palette de fonctoids.

  2. Dans la Palette de fonctoids, cliquez sur l'onglet Base de données.

    Il se peut que vous deviez cliquer sur la flèche de droite de la Palette de fonctoids pour afficher l'onglet.

  3. Faites glisser un fonctoid de la Palette de fonctoids vers la grille de mappage.

    Pour plus d'informations sur les fonctoids de bases de données, voir Fonctoids de bases de données.

Important

  • Pour plus d'informations sur la façon d'utiliser les fonctoids de bases de données pour extraire des informations d'une base de données, voir Utilisation des fonctoids de bases de données.

  • Pour créer une liaison entre un fonctoid et un enregistrement, vous devez activer la propriété Autoriser les liaisons du contenu des enregistrements. Pour cela, cliquez sur Options dans le menu Outils. Dans la boîte de dialogue Options du Mappeur BizTalk, onglet Général, sélectionnez la case à cocher Autoriser les liaisons du contenu des enregistrements et cliquez sur OK.

Remarque

  • Il se peut que vous deviez développer les arborescences de spécifications pour afficher les enregistrements ou les champs que vous souhaitez mapper. Pour plus d'informations, voir Développement des éléments de l'arborescence.

Voir aussi

Autoriser les liaisons du contenu des enregistrements

Création de liaisons entre les champs et les fonctoids

Création de liaisons entre les enregistrements et les fonctoids

Fonctoids de base de données

Présentation des fonctoids


Ajout du fonctoid Script

  1. Dans le menu Affichage, cliquez sur Palette de fonctoids.

  2. Dans la Palette de fonctoids, cliquez sur l'onglet Avancé.

    Il se peut que vous deviez cliquer sur la flèche de droite de la Palette de fonctoids pour afficher l'onglet.

  3. Faites glisser le fonctoid Script Fonctoid Script vers la grille de mappage.

    Pour plus d'informations sur le fonctoid Script, voir Fonctoids avancés.

  4. Double-cliquez sur le fonctoid Script.

  5. Dans la boîte de dialogue Propriétés des fonctoids, cliquez sur l'onglet Script, tapez le script de votre choix, puis cliquez sur OK.

  6. Déplacez un enregistrement ou un champ de l'arborescence Spécification source vers le fonctoid Script dans la grille de mappage, puis déplacez le fonctoid Script vers un enregistrement ou un champ dans l'arborescence Spécification de destination.

Important

  • S'il existe plusieurs fonctions dans un fonctoid Script, la première fonction constitue la fonction principale. Les paramètres de cette fonction doivent être définis s'il existe des liaisons dans le fonctoid.

  • Pour créer une liaison entre un fonctoid et un enregistrement, vous devez activer la propriété Autoriser les liaisons du contenu des enregistrements. Pour cela, cliquez sur Options dans le menu Outils. Dans la boîte de dialogue Options du Mappeur BizTalk, onglet Général, sélectionnez la case à cocher Autoriser les liaisons du contenu des enregistrements et cliquez sur OK.

Remarque

  • Il se peut que vous deviez développer les arborescences de spécifications pour afficher les enregistrements ou les champs que vous souhaitez mapper. Pour plus d'informations, voir Développement des éléments de l'arborescence.

Voir aussi

Fonctoids avancés

Autoriser les liaisons du contenu des enregistrements

Création de liaisons entre les champs et les fonctoids

Création de liaisons entre les enregistrements et les fonctoids

Gestion de vues


Ajout du fonctoid Nombre d'enregistrements

  1. Dans le menu Affichage, cliquez sur Palette de fonctoids.

  2. Dans la Palette de fonctoids, cliquez sur l'onglet Avancé.

    Il se peut que vous deviez cliquer sur la flèche de droite de la Palette de fonctoids pour afficher l'onglet.

  3. Faites glisser le fonctoid Nombre d'enregistrements Fonctoid Nombre d'enregistrements de la Palette de fonctoids vers la grille de mappage.

    Pour plus d'informations sur le fonctoid Nombre d'enregistrements, voir Fonctoids avancés.

  4. Déplacez un enregistrement en boucle de l'arborescence Spécification source vers le fonctoid Nombre d'enregistrements dans la grille de mappage, puis déplacez le fonctoid Nombre d'enregistrements vers un champ dans l'arborescence Spécification de destination.

    Pour plus d'informations sur les enregistrements de bouclage, voir Utilisation du fonctoid Nombre d'enregistrements.

Important

  • Pour plus d'informations sur le contexte de cette procédure, voir Utilisation du fonctoid Nombre d'enregistrements.

  • Pour créer une liaison entre un fonctoid et un enregistrement, vous devez activer la propriété Autoriser les liaisons du contenu des enregistrements. Pour cela, cliquez sur Options dans le menu Outils. Dans la boîte de dialogue Options du Mappeur BizTalk, onglet Général, sélectionnez la case à cocher Autoriser les liaisons du contenu des enregistrements et cliquez sur OK.

Remarque

  • Il se peut que vous deviez développer les arborescences de spécifications pour afficher les enregistrements ou les champs que vous souhaitez mapper. Pour plus d'informations, voir Développement des éléments de l'arborescence.

Voir aussi

Fonctoids avancés

Autoriser les liaisons du contenu des enregistrements

Création de liaisons entre les champs et les fonctoids

Création de liaisons entre les enregistrements et les fonctoids

Présentation des fonctoids


Ajout du fonctoid Index

  1. Dans le menu Affichage, cliquez sur Palette de fonctoids.

  2. Dans la Palette de fonctoids, cliquez sur l'onglet Avancé.

    Il se peut que vous deviez cliquer sur la flèche de droite de la Palette de fonctoids pour afficher l'onglet.

  3. Faites glisser le fonctoid Index Fonctoid Index de la Palette de fonctoids vers la grille de mappage.

    Pour plus d'informations sur le fonctoid Index, voir Fonctoids avancés.

  4. Déplacez un enregistrement (avec un enregistrement parent en boucle) de l'arborescence Spécification source vers le fonctoid Index dans la grille de mappage, puis déplacez le fonctoid Index vers un champ dans l'arborescence Spécification de destination.

    Pour plus d'informations sur les comptes de services, voir Utilisation d'un compte de services.

  5. Double-cliquez sur le fonctoid Index afin d'afficher sa feuille de propriétés.

  6. Cliquez sur le bouton Insérer un nouveau paramètre, bouton Insérer un nouveau paramètre, tapez la valeur de l'index, puis appuyez sur ENTRÉE.

  7. Répétez l'étape 6 autant de fois que nécessaire.

  8. Cliquez sur OK.

Important

  • Pour plus d'informations sur le contexte de cette procédure, voir Utilisation du fonctoid Index.

  • Pour créer une liaison entre un fonctoid et un enregistrement, vous devez activer la propriété Autoriser les liaisons du contenu des enregistrements. Pour cela, cliquez sur Options dans le menu Outils. Dans la boîte de dialogue Options du Mappeur BizTalk, onglet Général, sélectionnez la case à cocher Autoriser les liaisons du contenu des enregistrements et cliquez sur OK.

Remarque

  • Il se peut que vous deviez développer les arborescences de spécifications pour afficher les enregistrements ou les champs que vous souhaitez mapper. Pour plus d'informations, voir Développement des éléments de l'arborescence.

Voir aussi

Fonctoids avancés

Autoriser les liaisons du contenu des enregistrements

Création de liaisons entre les champs et les fonctoids

Création de liaisons entre les enregistrements et les fonctoids

Présentation des fonctoids


Ajout du fonctoid Itération

  1. Dans le menu Affichage, cliquez sur Palette de fonctoids.

  2. Dans la Palette de fonctoids, cliquez sur l'onglet Avancé.

    Il se peut que vous deviez cliquer sur la flèche de droite de la Palette de fonctoids pour afficher l'onglet.

  3. Faites glisser le fonctoid Itération Fonctoid Itération de la Palette de fonctoids vers la grille de mappage.

    Pour plus d'informations sur le fonctoid Itération, voir Fonctoids avancés.

Important

  • Pour plus d'informations sur le mode d'utilisation de cette boîte de dialogue, reportez-vous aux rubriques suivantes :

  • Pour créer une liaison entre un fonctoid et un enregistrement, vous devez activer la propriété Autoriser les liaisons du contenu des enregistrements. Pour cela, cliquez sur Options dans le menu Outils. Dans la boîte de dialogue Options du Mappeur BizTalk, onglet Général, sélectionnez la case à cocher Autoriser les liaisons du contenu des enregistrements et cliquez sur OK.

Remarque

  • Il se peut que vous deviez développer les arborescences de spécifications pour afficher les enregistrements ou les champs que vous souhaitez mapper. Pour plus d'informations, voir Développement des éléments de l'arborescence.

Voir aussi

Fonctoids avancés

Autoriser les liaisons du contenu des enregistrements

Création de liaisons entre les champs et les fonctoids

Création de liaisons entre les enregistrements et les fonctoids

Présentation des fonctoids


Ajout du fonctoid Mappage de valeurs

  1. Dans le menu Affichage, cliquez sur Palette de fonctoids.

  2. Dans la Palette de fonctoids, cliquez sur l'onglet Avancé.

    Il se peut que vous deviez cliquer sur la flèche de droite de la Palette de fonctoids pour afficher l'onglet.

  3. Faites glisser le fonctoid Mappage de valeurs Fonctoid Mappage de valeurs de la Palette de fonctoids vers la grille de mappage.

    Pour plus d'informations sur le fonctoid Mappage de valeurs, voir Fonctoids avancés.

Important

  • Pour plus d'informations sur le mode d'utilisation du fonctoid Mappage de valeurs, voir Utilisation du functoid Mappage de valeurs.

  • Pour créer une liaison entre un fonctoid et un enregistrement, vous devez activer la propriété Autoriser les liaisons du contenu des enregistrements. Pour cela, cliquez sur Options dans le menu Outils. Dans la boîte de dialogue Options du Mappeur BizTalk, onglet Général, sélectionnez la case à cocher Autoriser les liaisons du contenu des enregistrements et cliquez sur OK.

Remarque

  • Il se peut que vous deviez développer les arborescences de spécifications pour afficher les enregistrements ou les champs que vous souhaitez mapper. Pour plus d'informations, voir Développement des éléments de l'arborescence.

Voir aussi

Ajout du fonctoid Mappage des valeurs (mise à plat)

Fonctoids avancés

Autoriser les liaisons du contenu des enregistrements

Création de liaisons entre les champs et les fonctoids

Création de liaisons entre les enregistrements et les fonctoids

Présentation des fonctoids


Ajout du fonctoid Mappage des valeurs (mise à plat)

  1. Dans le menu Affichage, cliquez sur Palette de fonctoids.

  2. Dans la Palette de fonctoids, cliquez sur l'onglet Avancé.

    Il se peut que vous deviez cliquer sur la flèche de droite de la Palette de fonctoids pour afficher l'onglet.

  3. Faites glisser le fonctoid Mappage des valeurs (mise à plat) Fonctoid Mappage des valeurs (mise à plat) de la Palette de fonctoids vers la grille de mappage.

    Pour plus d'informations sur le fonctoid Mappage des valeurs (mise à plat), voir Fonctoids avancés.

Important

  • Pour plus d'informations sur le mode d'utilisation du fonctoid Mappage des valeurs (mise à plat), voir Utilisation du fonctoid Mappage des valeurs (mise à plat).

  • Pour créer une liaison entre un fonctoid et un enregistrement, vous devez activer la propriété Autoriser les liaisons du contenu des enregistrements. Pour cela, cliquez sur Options dans le menu Outils. Dans la boîte de dialogue Options du Mappeur BizTalk, onglet Général, sélectionnez la case à cocher Autoriser les liaisons du contenu des enregistrements et cliquez sur OK.

Remarque

  • Il se peut que vous deviez développer les arborescences de spécifications pour afficher les enregistrements ou les champs que vous souhaitez mapper. Pour plus d'informations, voir Développement des éléments de l'arborescence.

Voir aussi

Ajout du fonctoid Mappage de valeurs

Fonctoids avancés

Autoriser les liaisons du contenu des enregistrements

Création de liaisons entre les champs et les fonctoids

Création de liaisons entre les enregistrements et les fonctoids

Présentation des fonctoids


Ajout du fonctoid Bouclage

  1. Dans le menu Affichage, cliquez sur Palette de fonctoids.

  2. Dans la Palette de fonctoids, cliquez sur l'onglet Avancé.

    Il se peut que vous deviez cliquer sur la flèche de droite de la Palette de fonctoids pour afficher l'onglet.

  3. Faites glisser le fonctoid Bouclage Fonctoid Bouclage de la Palette de fonctoids vers la grille de mappage.

    Pour plus d'informations sur le fonctoid Bouclage, voir Fonctoids avancés.

Important

  • Pour plus d'informations sur le fonctoid Bouclage, voir Utilisation du fonctoid Bouclage :

  • Pour créer une liaison entre un fonctoid et un enregistrement, vous devez activer la propriété Autoriser les liaisons du contenu des enregistrements. Pour cela, cliquez sur Options dans le menu Outils. Dans la boîte de dialogue Options du Mappeur BizTalk, onglet Général, sélectionnez la case à cocher Autoriser les liaisons du contenu des enregistrements et cliquez sur OK.

Remarque

  • Il se peut que vous deviez développer les arborescences de spécifications pour afficher les enregistrements ou les champs que vous souhaitez mapper. Pour plus d'informations, voir Développement des éléments de l'arborescence.

Voir aussi

Fonctoids avancés

Autoriser les liaisons du contenu des enregistrements

Création de liaisons entre les champs et les fonctoids

Création de liaisons entre les enregistrements et les fonctoids

Présentation des fonctoids


Suppression de fonctoids

  1. Cliquez avec le bouton droit sur le fonctoid que vous souhaitez supprimer, puis cliquez sur Supprimer.

  2. Dans la boîte de dialogue de confirmation, cliquez sur Oui.


Modification des propriétés des fonctoids

  • Pour afficher la boîte de dialogue Propriétés des fonctoids, cliquez avec le bouton droit sur un fonctoid dans la grille de mappage, puis sélectionnez Propriétés.

Remarques

  • Vous pouvez également double-cliquer sur un fonctoid pour afficher ses propriétés.

  • L'onglet Général affiche des informations relatives aux paramètres d'entrée. L'onglet Script affiche les informations relatives aux scripts.

Pour plus d'informations sur le mode d'utilisation de cette boîte de dialogue, reportez-vous aux rubriques suivantes :

  • Paramètres d'entrée

  • Scripts des fonctoids


Paramètres d'entrée

Pour plus d'informations sur le mode d'accès à la boîte de dialogue Propriétés des fonctoids, voir Modification des propriétés des fonctoids.

Il est possible d'ajouter, de supprimer et de déplacer les paramètres d'entrée d'un grand nombre de fonctoids par le biais de l'onglet Général de la boîte de dialogue Propriétés des fonctoids. Pour plus d'informations, consultez les rubriques suivantes :

  • Insertion de paramètres d'entrée

  • Suppression de paramètres d'entrée

  • Déplacement de paramètres d'entrée

  • Attribution d'un nouveau nom aux paramètres d'entrée

Remarque

  • Le nombre de paramètres est limité pour certains fonctoids. Les informations relatives au nombre de paramètres autorisés pour un fonctoid figurent dans la boîte de dialogue Propriétés des fonctoids, sous la zone Paramètres d'entrée dans l'onglet Général.


Insertion de paramètres d'entrée

  1. Double-cliquez sur un fonctoid dans la grille de mappage.

    La boîte de dialogue Propriétés des fonctoids s'affiche.

  2. Dans l'onglet Général, cliquez sur le bouton Insérer un nouveau paramètre Insert New Parameter button , tapez les informations correspondant au nouveau paramètre, puis appuyez sur ENTRÉE.

    Remarque

    • Si le bouton Insérer un nouveau paramètre présenté à l'étape 2 n'est pas disponible, le fonctoid n'accepte pas les paramètres d'entrée ou n'en requiert aucun.
  3. Répétez l'étape 2 pour ajouter des paramètres supplémentaires, si besoin est.

  4. Cliquez sur OK.

Important

  • Les guillemets doubles ne sont pas reconnus dans une valeur de constante d'un paramètre d'entrée.

Voir aussi

Suppression de parameters d'entrée

Déplacement de paramètres d'entrée

Attribution d'un nouveau nom aux paramètres d'entrée


Suppression de parameters d'entrée

  1. Double-cliquez sur un fonctoid dans la grille de mappage.

  2. Dans l'onglet Général, dans la zone Paramètres d'entrée, cliquez sur le paramètre d'entrée que vous souhaitez supprimer.

  3. Cliquez sur le bouton Supprimer le paramètre sélectionné [image] , puis cliquez sur OK.

Voir aussi

Insertion de paramètres d'entrée

Déplacement de paramètres d'entrée

Attribution d'un nouveau nom aux paramètres d'entrée


Déplacement de paramètres d'entrée

  1. Double-cliquez sur un fonctoid dans la grille de mappage.

  2. Dans l'onglet Général, dans la zone Paramètres d'entrée, cliquez sur le paramètre d'entrée que vous souhaitez déplacer.

  3. Cliquez sur le bouton Déplacer le paramètre sélectionné vers le haut [image] pour déplacer le paramètre vers le haut, ou cliquez sur le bouton Déplacer le paramètre sélectionné vers le bas Move Down Selected Parameter button pour le déplacer vers le bas, puis cliquez sur OK.

Voir aussi

Suppression de parameters d'entrée

Insertion de paramètres d'entrée


Attribution d'un nouveau nom aux paramètres d'entrée

  1. Double-cliquez sur un fonctoid dans la grille de mappage.

  2. Dans l'onglet Général, dans la zone Paramètres d'entrée, cliquez avec le bouton droit sur le paramètre d'entrée que vous souhaitez renommer, puis cliquez sur Modifier la valeur.

  3. Tapez un nouveau nom de paramètre, puis cliquez sur OK.

Voir aussi

Suppression de parameters d'entrée

Insertion de paramètres d'entrée

Déplacement de paramètres d'entrée


Scripts des fonctoids

Pour plus d'informations sur le mode d'accès à la boîte de dialogue Propriétés des fonctoids, voir Modification des propriétés des fonctoids.

Vous pouvez afficher ou modifier les scripts par le biais de l'onglet Script de la boîte de dialogue Propriétés des fonctoids.

Remarque

  • Vous pouvez afficher les scripts de tous les fonctoids, mais vous pouvez modifier uniquement le script d'un fonctoid Script.

Voir aussi

Paramètres d'entrée


Gestion de liaisons

Cette section traite des rubriques suivantes :

  • Création de liaisons entre les champs

  • Création de liaisons entre les champs et les fonctoids

  • Création de liaisons entre les enregistrements et les champs

  • Création de liaisons entre les enregistrements et les fonctoids

  • Création de liaisons entre les fonctoids

  • Autoriser les liaisons du contenu des enregistrements

  • Redirection des liaisons

  • Suppression de liaisons


Création de liaisons entre les champs

  • Déplacez un champ de l'arborescence Spécification source vers un champ de l'arborescence Spécification de destination.

Important

  • Le type de données d'un champ dans la spécification source doit correspondre au type de données d'un champ auquel il est lié dans la spécification de destination.

Remarques

  • Vous ne pouvez pas établir une liaison vers un noeud dans une spécification de destination qui possède une valeur de constante de destination associée.

  • Vous ne pouvez pas établir une liaison vers un champ requis d'une spécification de destination qui possède une valeur par défaut associée. Pour plus d'informations sur l'établissement d'un champ requis, voir Définition des propriétés de référence. Pour plus d'informations sur l'établissement de la valeur par défaut d'un champ, voir Définition des propriétés de déclaration.

  • Il est possible que vous deviez développer les arborescences de spécifications pour afficher les enregistrements ou les champs que vous souhaitez mapper. Pour plus d'informations, voir Développement des éléments de l'arborescence.

Voir aussi

Ajout de valeurs de constantes

Gestion de vues

Définition des propriétés de déclaration

Définition des propriétés de référence

Résumé des types de données et des valeurs de types de données


Création de liaisons entre les champs et les fonctoids

  • Déplacez un champ de l'arborescence Spécification source ou Spécification de destination vers un fonctoid dans la grille de mappage.

    -ou-

  • Déplacez le fonctoid de la grille de mappage vers un champ de l'arborescence Spécification source ou Spécification de destination.

Important

  • Un champ doté d'une propriété d'un type de données particulier dans la spécification de destination d'un mappage ne doit pas être lié à un fonctoid qui génère une sortie d'un autre type de données.

Remarques

  • Pour être en mesure d'ajouter une liaison d'un champ vers un fonctoid, vous devez au préalable ajouter un fonctoid à la grille de mappage. Pour plus d'informations sur l'ajout d'un fonctoid dans la grille de mappage, voir Utilisation de la palette de fonctoids.

  • Vous ne pouvez pas établir une liaison vers un noeud (d'une spécification de destination) qui possède une valeur de constante de destination associée.

  • Vous ne pouvez pas établir une liaison vers un champ requis (d'une spécification de destination) qui possède une valeur par défaut associée. Pour plus d'informations sur l'établissement d'un champ requis, voir Définition des propriétés de référence. Pour plus d'informations sur l'établissement de la valeur par défaut d'un champ, voir Définition des propriétés de déclaration.

Voir aussi

Ajout de valeurs de constantes

Gestion de vues

Définition des propriétés de déclaration

Définition des propriétés de référence

Utilisation de la palette de fonctoids


Création de liaisons entre les enregistrements et les champs

  1. Dans le menu Outils, cliquez sur Options.

  2. Dans la boîte de dialogue Options du Mappeur BizTalk, sélectionnez l'onglet Général, activez la case à cocher Autoriser les liaisons du contenu des enregistrements, puis cliquez sur OK.

  3. Déplacez un enregistrement de l'arborescence Spécification source vers un champ de l'arborescence Spécification de destination.

    —Ou—

    Déplacez un enregistrement de l'arborescence Spécification de destination vers un champ de l'arborescence Spécification source.

Remarques

  • Vous ne pouvez pas établir une liaison vers un noeud dans une spécification de destination qui possède une valeur de constante de destination associée.

  • Vous ne pouvez pas établir une liaison vers un champ requis d'une spécification de destination qui possède une valeur par défaut associée. Pour plus d'informations sur l'établissement d'un champ requis, voir Définition des propriétés de référence. Pour plus d'informations sur l'établissement de la valeur par défaut d'un champ, voir Définition des propriétés de déclaration.

  • Il se peut que vous deviez développer les arborescences de spécifications pour afficher les enregistrements ou les champs que vous souhaitez mapper. Pour plus d'informations, voir Développement des éléments de l'arborescence.

Voir aussi

Ajout de valeurs de constantes

Gestion de vues

Définition des propriétés de déclaration

Définition des propriétés de référence


Création de liaisons entre les enregistrements et les fonctoids

  1. Dans le menu Outils, cliquez sur Options.

    La boîte de dialogue Options du Mappeur BizTalk apparaît.

  2. Activez la case à cocher Autoriser les liaisons du contenu des enregistrements, puis cliquez sur OK.

  3. Déplacez un enregistrement de l'arborescence Spécification source ou Spécification de destination vers un fonctoid dans la grille de mappage.

    -ou-

    Déplacez le fonctoid de la grille de mappage vers un enregistrement dans l'arborescence Spécification source ou Spécification de destination.

Remarques

  • Pour être en mesure d'ajouter une liaison d'un enregistrement vers un fonctoid, vous devez au préalable ajouter un fonctoid à la grille de mappage.

  • Vous ne pouvez pas établir une liaison vers un noeud dans une spécification de destination qui possède une valeur de constante de destination associée. Pour plus d'informations sur les valeurs de constantes de destination, voir Interface utilisateur du Mappeur BizTalk.

Voir aussi

Ajout de valeurs de constantes

Gestion de vues


Création de liaisons entre les fonctoids

  • Déplacez un fonctoid vers un autre fonctoid dans la grille de mappage.

Remarque

  • Les liaisons sont traitées de gauche à droite dans la grille de mappage. Vous ne pouvez pas créer une liaison entre un fonctoid et un autre fonctoid situé directement au-dessus ou au-dessous.

Voir aussi

Création de liaisons entre les champs et les fonctoids

Création de liaisons entre les enregistrements et les fonctoids


Autoriser les liaisons du contenu des enregistrements

  1. Dans le menu Outils, cliquez sur Options.

    La boîte de dialogue Options du Mappeur BizTalk apparaît.

  2. Activez la case à cocher Autoriser les liaisons du contenu des enregistrements, puis cliquez sur OK.

  3. Déplacez un enregistrement de l'arborescence Spécification source vers un enregistrement de l'arborescence Spécification de destination.


Redirection des liaisons

  1. Dans la grille de mappage, cliquez sur une liaison pour la mettre en surbrillance.

    Les points de terminaison des liaisons sont mis en évidence par des petites cases bleues.

  2. Déplacez l'un des points de terminaison vers le fonctoid ou le noeud auquel vous souhaitez vous connecter.

    Lorsque vous faites glisser le point de terminaison, le pointeur se transforme en réticule. Si vous pointez sur un objet vers lequel il n'est pas possible d'établir une liaison, le pointeur se transforme en cercle barré.

Important

  • Si au moins deux liaisons source sont connectées à un fonctoid et que vous redirigez une ou plusieurs liaisons source vers différents noeuds dans la Spécification source, il est possible que l'ordre des paramètres d'entrée du fonctoid soit modifié. Double-cliquez sur le fonctoid pour afficher ses paramètres d'entrée et assurez-vous que l'ordre des paramètres est correct.


Suppression de liaisons

  1. Cliquez avec le bouton droit sur la liaison que vous souhaitez supprimer, puis cliquez sur Supprimer.

  2. Dans la boîte de dialogue de confirmation, cliquez sur Oui.


Affichage des liaisons et des fonctoids dans la grille

Cette section traite des rubriques suivantes :

  • Affichage des liaisons et des fonctoids dans l'aperçu de la grille

  • Affichage des liaisons et des fonctoids dans l'aperçu de la grille


Affichage des liaisons et des fonctoids dans l'aperçu de la grille

  1. Placez le curseur dans la grille de mappage, près de la bordure, et orientez-le dans la direction vers laquelle vous souhaitez vous déplacer.

    Le curseur en forme de pointeur ou de (|) est remplacé par une flèche large.

  2. Cliquez sur le bouton gauche de la souris et maintenez-le enfoncé pour vous déplacer dans la direction indiquée par la pointe de la flèche.

Remarque

  • Pour vous déplacer, vous pouvez également cliquer dans l'arrière-plan de la grille de mappage et utiliser les touches de direction pour vous déplacer dans toutes les directions.

Voir aussi

Interface utilisateur du Mappeur BizTalk

Affichage des liaisons et des fonctoids dans l'aperçu de la grille

Copyright © 1999–2000 Microsoft Corporation.
Tous droits réservés.


Affichage des liaisons et des fonctoids dans l'aperçu de la grille

  1. Dans le menu Affichage, cliquez sur Aperçu de la grille.

    La fenêtre Aperçu de la grille s'ouvre et affiche une représentation de l'emplacement des fonctoids sur la grille de mappage.

  2. Faites glisser la barre d'emplacement verte vers un nouvel emplacement dans la boîte de dialogue Aperçu de la grille.

    Lorsque vous déplacez la barre d'emplacement verte, les liaisons et les fonctoids dans la grille de mappage se déplacent également.

Remarque

L'aperçu de la grille est utile pour le déplacement dans la grille de mappage lorsque celle-ci comporte de nombreux fonctoids.

Voir aussi

Interface utilisateur du Mappeur BizTalk

Affichage des liaisons et des fonctoids dans l'aperçu de la grille

Copyright © 1999–2000 Microsoft Corporation.
Tous droits réservés.


Modification des propriétés des liaisons

  • Pour afficher la boîte de dialogue Propriétés des liaisons, cliquez avec le bouton droit sur une liaison dans la grille de mappage, puis sélectionnez Propriétés.

    L'onglet Général apparaît par défaut.

Pour plus d'informations sur le mode d'utilisation de cette boîte de dialogue, reportez-vous aux rubriques suivantes :

  • Affichage des propriétés des liaisons : Onglet Général

  • Affichage des propriétés des liaisons : Onglet Compilateur

Remarque

  • Vous pouvez également double-cliquer sur une liaison pour afficher ses propriétés.

Voir aussi

Compilation de mappages

Gestion de liaisons


Affichage des propriétés des liaisons : Onglet Général

Pour plus d'informations sur le mode d'accès à la boîte de dialogue Propriétés des liaisons, voir Modification des propriétés des liaisons.

L'onglet Général affiche des informations sur la source et la destination d'une liaison. La zone Source indique le chemin de l'enregistrement, le chemin du champ ou le nom du fonctoid correspondant à liaison source, selon que la source de la liaison est un enregistrement, un champ ou un fonctoid. La zone Destination indique le chemin de l'enregistrement, le chemin du champ ou le nom du fonctoid correspondant à la liaison de destination, selon que la destination de la liaison est un enregistrement, un champ ou un fonctoid.

Voir aussi

Affichage des propriétés des liaisons : Onglet Compilateur


Affichage des propriétés des liaisons : Onglet Compilateur

Pour plus d'informations sur le mode d'accès à la boîte de dialogue Propriétés des liaisons, voir Modification des propriétés des liaisons.

L'onglet Compilateur comporte une zone réservée à la définition des propriétés du compilateur pour les liaisons des spécifications source, ainsi qu'une zone réservée à la définition des propriétés du compilateur pour les liaisons des spécifications de destination. Pour plus d'informations, consultez les rubriques suivantes :

  • Sélection des propriétés du compilateur pour les liaisons des spécifications source

  • Sélection des propriétés du compilateur pour les liaisons des spécifications de destination

Voir aussi

Affichage des propriétés des liaisons : Onglet Général


Sélection des propriétés du compilateur pour les liaisons des spécifications source

  1. Cliquez avec le bouton droit sur une liaison dans la grille de mappage qui est connectée à un noeud dans la spécification source, puis cliquez sur Propriétés.

  2. Cliquez sur l'onglet Compilateur, puis sélectionnez l'une des options suivantes dans la zone Liaisons des spécifications source :
    • Copier la valeur (valeur par défaut) : copie la valeur du noeud dans l'instance du document entrant.

    • Copier le nom : copie le nom du noeud dans l'instance du document entrant.
  3. Cliquez sur OK.

Voir aussi

Sélection des propriétés du compilateur pour les liaisons des spécifications de destination


Sélection des propriétés du compilateur pour les liaisons des spécifications de destination

  1. Cliquez avec le bouton droit sur une liaison dans la grille de mappage qui est connectée à un noeud dans la spécification de destination, puis cliquez sur Propriétés.

  2. Cliquez sur l'onglet Compilateur et sélectionnez l'une des options suivantes dans la zone Liaisons des spécifications de destination :
    • Aplatir les liaisons (valeur par défaut) : ce mode signifie que les spécifications source et de destination correspondent et qu'une liaison individuelle est créée pour chaque enregistrement et chaque champ.

    • Faire correspondre les liaisons du haut vers le bas : ce mode fait correspondre les différents niveaux du haut vers le bas.

    • Faire correspondre les liaisons du bas vers le haut : ce mode fait correspondre les différents niveaux du bas vers le haut.
  3. Cliquez sur OK.

Remarques

  • Si vous utilisez une directive de compilation aplanie, du haut vers le bas et du bas vers le haut pour les liaisons des champs de la spécification source vers les champs de la spécification de destination qui partagent le même enregistrement parent, le Mappeur BizTalk traite toutes les liaisons comme si elles étaient définies à la directive de compilation aplanie.

  • Si vous utilisez une ou plusieurs directives de compilation aplanies et une directive de compilation du haut vers le bas pour les liaisons des champs de la spécification source vers les champs de la spécification de destination qui partagent le même enregistrement parent, le Mappeur BizTalk traite toutes les liaisons comme si elles étaient définies à la directive de compilation du haut vers le bas.

  • Si vous utilisez une ou plusieurs directives de compilation aplanies et une directive de compilation du bas vers le haut pour les liaisons des champs de la spécification source vers les champs de la spécification de destination qui partagent le même enregistrement parent, le Mappeur BizTalk traite toutes les liaisons comme si elles étaient définies à la directive de compilation du bas vers le haut.

  • Si vous utilisez une ou plusieurs directives de compilation du haut vers le bas et une ou plusieurs directives de compilation du bas vers le haut pour les liaisons des champs de la spécification source vers les champs de la spécification de destination qui partagent le même enregistrement parent, le Mappeur BizTalk traite toutes les liaisons comme si elles étaient définies à la directive de compilation aplanie.

Voir aussi

Correspondance des niveaux de hiérarchie des noeuds

Sélection des propriétés du compilateur pour les liaisons des spécifications source


Création et gestion des mappages compilés

Cette section traite des procédures suivantes :

  • Compilation de mappages

  • Résolution des messages d'avertissement et d'erreur après la compilation d'un mappage

  • Ajout de valeurs de constantes


Compilation de mappages

  • Dans le menu Outils, cliquez sur Compiler le fichier de mappage.

Attention

  • Le Mappeur BizTalk génère un message d'avertissement dans l'onglet Avertissements lorsque le compilateur est confronté à une situation qui provoque des résultats incorrects. Un mappage est prêt pour un environnement de production uniquement lorsqu'il ne génère plus aucun message d'avertissement.

Voir aussi

Résolution des messages d'avertissement et d'erreur après la compilation d'un mappage


Résolution des messages d'avertissement et d'erreur après la compilation d'un mappage

  1. Double-cliquez sur un message d'avertissement dans l'onglet Avertissements.

    La liaison ou le fonctoid à l'origine du message d'avertissement ou d'erreur est mis en surbrillance dans la grille de mappage.

  2. Modifiez la liaison ou le fonctoid.

  3. Répétez les étapes 1 et 2 pour tous les messages d'avertissement.

  4. Dans le menu Outils, cliquez sur Compiler le fichier de mappage.

Voir aussi

Compilation de mappages


Ajout de valeurs de constantes

  1. Sélectionnez un enregistrement ou un champ dans l'arborescence Spécification de destination, puis cliquez sur l'onglet Valeurs.

  2. Dans la zone Valeur de la constante de destination, tapez une valeur que vous voulez associer à l'enregistrement ou au champ.

Remarque

  • Vous ne pouvez pas établir une liaison vers un enregistrement ou un champ auquel est associée une valeur de constante.

  • Vous pouvez associer une valeur de constante uniquement à un enregistrement dont la propriété Contenu correspond à Texte seul. Pour plus d'informations sur la propriété Contenu, voir Définition des propriétés de déclaration.

Voir aussi

Définition des propriétés de déclaration


Tests de mappages

Cette section traite des procédures suivantes :

  • Test des propriétés des enregistrements et des champs possédant des liaisons

  • Test de liaisons

  • Test de fonctoids


Test des propriétés des enregistrements et des champs possédant des liaisons

Important

  • Compilez toujours un mappage avant de le tester, afin de pouvoir résoudre les éventuels messages d'avertissement et d'erreur. Pour plus d'informations, voir Compilation de mappages.
  1. Cliquez sur un champ dans l'arborescence Spécification source qui est connectée à une liaison.

  2. Cliquez sur l'onglet Valeurs.

  3. Tapez une valeur dans la zone Valeur du test source.

  4. Dans le menu Outils, cliquez sur Tester le mappage.

    Important

    • Avant le début du test, le système vous demande d'enregistrer votre fichier. Par mesure de précaution, enregistrez-le avant le test, afin de préserver vos données an cas d'introduction accidentelle d'un problème dans le mappage.
  5. Cliquez sur Oui pour enregistrer le mappage.

  6. Vérifiez les résultats dans l'onglet Sortie.

Remarque

  • Si la propriété Occurrences maximales d'un enregistrement est un astérisque (*), l'enregistrement est un enregistrement en boucle. L'instance de document entrant que le Mappeur BizTalk génère pour tester le mappage contient deux occurrences de l'enregistrement.

Voir aussi

Compilation de mappages

Test de mappages


Test de liaisons

Important

  • Compilez toujours un mappage avant de le tester, afin de pouvoir résoudre les éventuels messages d'avertissement et d'erreur. Pour plus d'informations, voir Compilation de mappages.
  1. Cliquez sur un champ dans l'arborescence Spécification source qui est connectée à une liaison.

  2. Cliquez sur l'onglet Valeurs.

  3. Tapez une valeur dans la zone Valeur du test source.

  4. Dans le menu Outils, cliquez sur Tester le mappage.

    Important

    • Avant le début du test, le système vous demande d'enregistrer votre fichier. Par mesure de précaution, enregistrez-le avant le test, afin de préserver vos données an cas d'introduction accidentelle d'un problème dans le mappage.
  5. Cliquez sur Oui pour enregistrer le mappage.

  6. Vérifiez les résultats dans l'onglet Sortie.

Voir aussi

Compilation de mappages

Test de mappages


Test de fonctoids

Important

  • Compilez toujours un mappage avant de le tester, afin de pouvoir résoudre les éventuels messages d'avertissement et d'erreur. Pour plus d'informations, voir Compilation de mappages.
  1. Dans le menu Outils, cliquez sur Tester le mappage.

    Important

    • Avant le début du test, le système vous demande d'enregistrer votre fichier. Par mesure de précaution, enregistrez-le avant le test, afin de préserver vos données an cas d'introduction accidentelle d'un problème dans le mappage.
  2. Cliquez sur Oui pour enregistrer le mappage.

  3. Vérifiez les résultats dans l'onglet Sortie.

Voir aussi

Compilation de mappages

Test de mappages


Gestion de vues

Cette section traite des procédures suivantes :

  • Développement des éléments de l'arborescence

  • Réduction des éléments de l'arborescence

  • Affichage des propriétés des enregistrements et des champs

  • Affichage des espaces de noms

  • Modification de la taille du volet de l'arborescence Spécification source

  • Modification de la taille du volet de l'arborescence Spécification de destination

  • Modification de la taille du volet inférieur


Développement des éléments de l'arborescence

  • Cliquez sur le noeud racine ou sur un enregistrement dans l'arborescence des spécifications que vous voulez développer, puis cliquez sur Développer les éléments de l'arborescence dans le menu Affichage.

    —Ou—

    Cliquez avec le bouton droit sur le noeud racine ou sur un enregistrement dans une arborescence, puis cliquez sur Développer les éléments de l'arborescence.

Voir aussi

Réduction des éléments de l'arborescence


Réduction des éléments de l'arborescence

  • Cliquez sur le noeud racine ou sur un enregistrement dans l'arborescence des spécifications que vous voulez réduire, puis cliquez sur Réduire les éléments de l'arborescence dans le menu Affichage.

Remarque

  • Vous pouvez également cliquer avec le bouton droit sur le noeud racine ou sur un enregistrement dans une arborescence, puis cliquer sur Réduire les éléments de l'arborescence.

Voir aussi

Développement des éléments de l'arborescence


Affichage des propriétés des enregistrements et des champs

  • Cliquez sur un enregistrement ou sur un champ dans l'arborescence Spécification source ou Spécification de destination, puis cliquez sur Propriétés dans le menu Affichage.

    —Ou—

    Cliquez sur un enregistrement ou sur un champ dans l'une des arborescences, puis cliquez sur l'onglet Propriétés.

Remarque

  • Il se peut que vous deviez déplacer la barre de défilement sur l'onglet Propriétés pour afficher une propriété et la valeur qui lui est associée.


Affichage des espaces de noms

Vous pouvez utiliser Microsoft Internet Explorer 5 (ou une version ultérieure) pour afficher les espaces de noms dans un mappage.

  1. Démarrez Internet Explorer et recherchez le fichier de mappage que vous voulez ouvrir.

  2. Avancez jusqu'à la première balise <schema> (qui suit la balise <srctree>) pour afficher les informations d'espace de noms de la spécification source.

  3. Avancez jusqu'à la seconde balise <schema> (qui suit la balise <sinktree>) pour afficher les informations d'espace de noms de la spécification de destination.

Voir aussi

Prise en charge des espaces de noms


Modification de la taille du volet de l'arborescence Spécification source

  1. Positionnez le curseur sur la bordure droite du volet de l'arborescence Spécification source et déplacez-le légèrement jusqu'à ce qu'il prenne la forme d'une double flèche.

  2. Faite glisser la bordure du volet vers la droite pour augmenter la taille du volet, ou vers la gauche pour la réduire.

Remarque

  • Double-cliquez sur la bordure afin de rétablir sa position initiale.

Voir aussi

Modification de la taille du volet de l'arborescence Spécification de destination

Modification de la taille du volet inférieur


Modification de la taille du volet de l'arborescence Spécification de destination

  1. Positionnez le curseur sur la bordure gauche du volet de l'arborescence Spécification de destination et déplacez-le légèrement jusqu'à ce qu'il prenne la forme d'une double flèche.

  2. Faites glisser la bordure vers la gauche pour augmenter la taille du volet, ou vers la droite pour la diminuer.

Remarque

  • Double-cliquez sur la bordure afin de rétablir sa position initiale.

Voir aussi

Modification de la taille du volet de l'arborescence Spécification source

Modification de la taille du volet inférieur


Modification de la taille du volet inférieur

  1. Positionnez le curseur sur la bordure supérieure du volet inférieur et déplacez-le légèrement jusqu'à ce qu'il prenne la forme d'une double flèche.

  2. Déplacez la bordure vers le haut pour augmenter la taille du volet, ou vers le bas pour la diminuer.

Remarque

  • Double-cliquez sur la bordure afin de rétablir sa position initiale.

Voir aussi

Modification de la taille du volet de l'arborescence Spécification de destination

Modification de la taille du volet de l'arborescence Spécification source


Personnalisation de l'interface utilisateur

Cette section traite des procédures suivantes :

  • Modification des couleurs de la grille de mappage

  • Modification de la couleur des liaisons

  • Modification de la couleur des objects sélectionnés

  • Modification de la couleur des avertissements du compilateur

  • Restauration des couleurs par défaut

  • Modification de la taille du texte


Modification des couleurs de la grille de mappage

  1. Dans le menu Outils, cliquez sur Options.

    La boîte de dialogue Options du Mappeur BizTalk apparaît.

  2. Cliquez sur l'onglet Couleurs.

  3. Activez la case à cocher Premier plan de la grille, qui correspond aux lignes discontinues dans la grille de mappage, puis sélectionnez une nouvelle couleur dans la grille de mappage.

    –Ou–

    Activez la case à cocher Arrière-plan de la grille, qui correspond à la couleur d'arrière-plan de la grille de mappage, puis sélectionnez une nouvelle couleur dans la palette de couleurs.

  4. Cliquez sur OK.

Voir aussi

Modification de la couleur des avertissements du compilateur

Modification de la couleur des liaisons

Modification de la couleur des objects sélectionnés

Restauration des couleurs par défaut


Modification de la couleur des liaisons

  1. Dans le menu Outils, cliquez sur Options.

    La boîte de dialogue Options du Mappeur BizTalk apparaît.

  2. Cliquez sur l'onglet Couleurs.

  3. Activez les cases à cocher correspondant aux éléments suivants :
    • Liaisons fixes : il s'agit de simples liaisons qui effectuent une copie des valeurs dans la grille de mappage.

    • Liaisons souples : il s'agit de simples liaisons qui effectuent une copie des valeurs et qui sont déplacées de l'arborescence Spécification source vers l'arborescence Spécification de destination. Une fois la liaison créée, la couleur de la liaison est remplacée par la couleur prédéfinie des liaisons fixes.

    • Liaisons partielles : il s'agit des liaisons qui existent pour un champ ou pour un enregistrement dont l'enregistrement parent est réduit.

    • Liaisons du compilateur : il s'agit des liaisons des directives de compilation. Ces liaisons sont automatiquement créées lorsqu'une liaison est définie à partir d'un champ de l'arborescence Spécification source vers un champ de l'arborescence Spécification de destination et que les hiérarchies des deux arborescences ne correspondent pas.
  4. Sélectionnez une nouvelle couleur dans la palette de couleurs.

  5. Répétez l'étape 3 pour modifier d'autres couleurs le cas échéant.

  6. Cliquez sur OK.

Voir aussi

Modification des couleurs de la grille de mappage

Modification de la couleur des avertissements du compilateur

Modification de la couleur des objects sélectionnés

Restauration des couleurs par défaut


Modification de la couleur des objects sélectionnés

  1. Dans le menu Outils, cliquez sur Options.

  2. Dans la boîte de dialogue Options du Mappeur BizTalk, cliquez sur l'onglet Couleurs.

  3. Activez la case à cocher Objets sélectionnés, puis sélectionnez une nouvelle couleur dans la palette de couleurs.

  4. Cliquez sur OK.

Voir aussi

Modification des couleurs de la grille de mappage

Modification de la couleur des avertissements du compilateur

Modification de la couleur des liaisons

Restauration des couleurs par défaut


Modification de la couleur des avertissements du compilateur

  1. Dans le menu Outils, cliquez sur Options.

    La boîte de dialogue Options du Mappeur BizTalk apparaît.

  2. Cliquez sur l'onglet Couleurs.

  3. Activez la case à cocher Avertissements du compilateur, puis sélectionnez une nouvelle couleur dans la palette de couleurs.

  4. Cliquez sur OK.

Voir aussi

Modification des couleurs de la grille de mappage

Modification de la couleur des liaisons

Modification de la couleur des objects sélectionnés

Restauration des couleurs par défaut


Restauration des couleurs par défaut

  1. Dans le menu Outils, cliquez sur Options.

    La boîte de dialogue Options du Mappeur BizTalk apparaît.

  2. Cliquez sur l'onglet Couleurs.

  3. Cliquez sur Restaurer les couleurs par défaut, puis cliquez sur OK.

Voir aussi

Modification des couleurs de la grille de mappage

Modification de la couleur des avertissements du compilateur

Modification de la couleur des liaisons

Modification de la couleur des objects sélectionnés


Concepts

Cette section fournit des informations détaillées sur les concepts essentiels à la compréhension du Mappeur BizTalk.

Cette section traite des rubriques suivantes :

  • Spécifications de mappage

  • Scénarios de mappage

  • Environnement du Mappeur BizTalk

  • Création de liaisons

  • Correspondance des niveaux de hiérarchie des noeuds

  • Affichage des propriétés des fonctoids, des liaisons, des champs et des enregistrements

  • Présentation des fonctoids

  • Compilation de mappages

  • Test de mappages


Spécification de mappage

Un mappage identifie la manière dont les données dans un format sont rendues dans un autre format. Deux spécifications sont nécessaires : l'une est la source, l'autre est la destination. Le mappage des valeurs est un processus de traduction des données, dans lequel vous définissez les correspondances entre les enregistrements et les champs de la spécification source et les enregistrements et les champs de la spécification de destination.

Il existe deux types de mappage : le mappage spécifique conçu pour répondre aux besoins particuliers d'un partenaire commercial et le mappage générique conçu pour répondre aux besoins de plusieurs partenaires commerciaux. Lorsque vous mappez les besoins des champs et des enregistrements d'un partenaire commercial, vous créez un mappage qui est propre à ce partenaire commercial. Dans le mappage générique, vous regroupez les besoins de plusieurs partenaires commerciaux dans un mappage unique. Dans la mesure où plusieurs entreprises peuvent être interconnectées, vous pouvez utiliser le même mappage pour plusieurs partenaires commerciaux afin de réaliser un gain de temps ainsi que des économies en termes de ressources.

Le Mappeur BizTalk offre une représentation graphique d'un mappage qui peut inclure de simples traductions d'opérations de copie de valeurs, appelées liaisons, et des manipulations complexes de structure, appelées fonctoids. En associant ces éléments, vous pouvez facilement mapper des données entre la spécification source et la spécification de destination.


Scénarios de mappage

Cette section traite des rubriques suivantes :

  • Chemins de bouclage

  • Ordre des enregistrements et des champs


Chemins de bouclage

Un enregistrement dans une spécification boucle si la propriété Occurrences maximales sur l'onglet Référence correspond à * pour cet enregistrement. Pour plus d'informations sur la propriété Occurrences maximales, voir Définition des propriétés de référence.

Un chemin de bouclage intervient dans un mappage lorsqu'un champ contenu dans un enregistrement de bouclage de la spécification source est lié à un champ contenu dans un enregistrement de bouclage de la spécification de destination. L'illustration suivante présente deux chemins de bouclage, l'un de Root\Record1\Field1 vers Root\RecordA\Field1, et l'autre de Root\Record2\Field2 vers \Root\RecordB\Field3.

Cliquez sur l'image pour l'agrandir ou la réduire.

Mappage du chemin de bouclage

L'onglet Propriétés indique que les enregistrements Record1 et RecordA bouclent, de même que Record2 et RecordB.

Le code suivant est un exemple de document d'entrée.

<Root>
<Record1 Field1=Red>
<Record1 Field1=Green>
<Record1 Field1=Blue>
<Record2 Field2=50>
<Record2 Field2=100>
</Root>

Si vous utilisez le mappage précédent, ce document d'entrée mappe sur le document de sortie suivant.

<Root>
<RecordA Field1=Red>
<RecordA Field1=Green>
<RecordA Field1=Blue>
<RecordB Field3=50>
<RecordB Field3=100>
</Root>

Un chemin de bouclage multiple intervient dans un mappage lorsque les champs contenus dans au moins deux enregistrements en boucle de la spécification source sont liés aux champs contenus dans un seul enregistrement en boucle de la spécification de destination.

L'illustration suivante présente un exemple de chemin de bouclage multiple.

Cliquez sur l'image pour l'agrandir ou la réduire.

Mappage d'un chemin de bouclage multiple

Les chemins de bouclage multiples ne sont pas gérés dans le Mappeur BizTalk. Si vous tentez de compiler un mappage qui contient un chemin de bouclage multiple, l'onglet Avertissements indique que le noeud de destination comporte plusieurs chemins de bouclage source.

Voir aussi

Définition des propriétés de référence


Ordre des enregistrements et des champs

L'ordre implicite des champs et des enregistrements de sortie n'est pas assuré dans XSL (Extensible Stylesheet Language). En effet, le Mappeur BizTalk génère XSL en parcourant la structure de la spécification de destination, puis en effectuant une propagation dans la grille de mappage pour extraire les valeurs à partir de la structure de la spécification source. Par exemple, si vous voulez créer un fichier de sortie dans lequel les enregistrements BillTo Address (FacturerÀ Adresse) figurent en premier puis sont suivis des enregistrements ShipTo Address, vous devez vous assurer que l'enregistrement BillTo Address précède l'enregistrement ShipTo Address dans la spécification de destination.

Cette structure est présentée dans l'illustration suivante.

Cliquez sur l'image pour l'agrandir ou la réduire.

Le champ TypeContact contient deux codes valides (BT et ST) qui identifient l'adresse soit comme une adresse BillTo Address (FacturerÀ), soit comme une adresse ShipTo Address (ExpédierÀ). Pour créer la sortie attendue, les fonctoids Égal à sont ajoutés à la grille de mappage et liés depuis les champs de la spécification source vers les enregistrements de la spécification de destination.

Dans le mappage, le premier fonctoid vérifie que les conditions suivantes sont remplies :

TypeContact est-il égal à BT ?

Si cette condition est remplie, un enregistrement de sortie BillToAddresses(FacturerÀAdresses) est créé et les champs requis sont mappés sur cet enregistrement. Si la condition n'est pas remplie, le Mappeur BizTalk doit réitérer tous les enregistrements d'adresse d'entrée.

Important

  • L'ordre dans lequel les enregistrements et les champs apparaissent dans une instance de document de sortie dépend de l'ordre des enregistrements et des champs de la spécification de sortie correspondante.


Environnement du Mappeur BizTalk

Cette section traite des rubriques suivantes :

  • Interface utilisateur du Mappeur BizTalk

  • Menus du Mappeur BizTalk

  • Boutons de la barre d'outils du Mappeur BizTalk

  • Palette de fonctoids du Mappeur BizTalk

  • Touches de raccourci du Mappeur BizTalk


Interface utilisateur du Mappeur BizTalk

Les deux spécifications qui sont utilisées pour créer un mappage apparaissent comme des vues de l'arborescence dans la fenêtre principale du Mappeur BizTalk. La spécification source à partir de laquelle les données sont mappées figure sur la gauche, et la spécification de destination vers laquelle les données sont mappées figure sur la droite. La grille de mappage entre les deux spécifications affiche une représentation graphique de la transformation de la structure des données entre les deux spécifications. Les liaisons et les fonctoids apparaissent dans la grille de mappage. Vous pouvez déplacer le pointeur vers les bordures de la grille de mappage afin de vous déplacer facilement vers le haut, vers le bas, vers la gauche et vers la droite.

Vous pouvez utiliser la boîte de dialogue Aperçu de la grille pour vous déplacer rapidement d'un point à un autre de la grille de mappage. Il vous suffit de faire glisser la barre verte pour vous déplacer vers le haut, le bas, la droite ou la gauche. Un fonctoid de la grille de mappage apparaît dans l'aperçu sous forme d'une case rouge entourée de noir. Si la grille de mappage comprend deux fonctoids ou plus, les fonctoids apparaissent sous forme de deux cases rouge reliées et entourées de noir.

Le volet inférieur se trouve sous les vues de l'arborescence et la grille de mappage. Il comporte quatre onglets :

  • Propriétés : lorsque vous sélectionnez un noeud dans l'arborescence Spécification source ou Spécification de destination, l'onglet Propriétés affiche les propriétés et les valeurs des propriétés de ce noeud.

  • Valeurs : cet onglet comporte les deux zones de texte Valeur du texte source et Valeur de la constante de destination. Vous pouvez sélectionner un champ, puis taper une valeur dans la zone Valeur du texte source. Cette opération vous permet de tester des mappages dans lesquels des valeurs réelles sont affectées aux champs. Dans la zone Valeur de la constante de destination, vous pouvez spécifier une valeur à affecter à un champ. Vous ne pouvez pas établir une liaison d'un fonctoid ou d'un noeud de la spécification source vers un champ auquel une valeur de constante est affectée.

  • Sortie : cet onglet affiche une feuille de style XSL (Extensible Stylesheet Language) compilée lorsque vous compilez un mappage, et affiche la sortie du test lorsque vous testez un mappage.

  • Avertissements : cet onglet affiche les messages d'avertissement du compilateur après la compilation d'un mappage.

Voir aussi

Compilation de mappages

Test de mappages

Affichage des liaisons et des fonctoids dans l'aperçu de la grille


Menus du Mappeur BizTalk

Les menus du Mappeur BizTalk regroupent les commandes de manière logique, dans le but de faciliter l'exécution des tâches. Par exemple, vous pouvez utiliser les commandes du menu Affichage pour afficher tous les enregistrements et les champs de l'arborescence Spécification source ou pour réduire tous les enregistrements et les champs de l'arborescence Spécification de destination.

Les menus du Mappeur BizTalk sont les suivants :

  • Fichier. permet de créer, d'ouvrir, d'enregistrer et de fermer un mappage.

  • Modifier. permet de remplacer la spécification source ou de destination, ou encore de supprimer un objet dans la grille de mappage.

  • Afficher. permet d'afficher la palette de fonctoids, les propriétés des fonctoids et la grille d'aperçu, de sélectionner la taille du texte pour l'affichage du Mappeur BizTalk, d'activer les onglets du volet inférieur, de développer ou de réduire les arborescences des spécifications ou de mettre en surbrillance l'avertissement suivant dans l'onglet Avertissements.

  • Outils. permet de compiler ou de tester vos mappages et d'afficher les options du Mappeur BizTalk.

  • Aide. permet d'obtenir des informations sur les procédures et les concepts du Mappeur BizTalk.

Voir aussi

Menus de l'Éditeur BizTalk


Boutons de la barre d'outils du Mappeur BizTalk

Le Mappeur BizTalk est doté d'une barre d'outils en complément de la barre de menus. Chaque bouton comporte une représentation graphique de la tâche correspondante. L'ordre d'apparition de gauche à droite est le suivant :

  • Nouvelle

  • Ouvrir

  • Enregistrer

  • Extraire à partir de WebDAV

  • Stocker dans WebDAV

  • Supprimer

  • Réduire

  • Expand

  • Afficher la palette de fonctoids

  • Compiler le mappage

  • Tester le mappage


Palette de fonctoids du Mappeur BizTalk

La palette de fonctoids contient tous les fonctoids du Mappeur BizTalk. Un fonctoid contient du code qui extrait les données d'un enregistrement, d'un champ de la spécification source ou d'un autre fonctoid (tel que le fonctoid Date), traite ces données de manière indépendante, puis renvoie une nouvelle valeur qui est placée dans un enregistrement ou un champ de la spécification de destination. Pour plus d'informations sur la palette de fonctoids, voir Présentation des fonctoids.

Voir aussi

Présentation des fonctoids

Utilisation de la palette de fonctoids


Touches de raccourci du Mappeur BizTalk

Vous pouvez utiliser les touches de raccourci pour effectuer des tâches dans le Mappeur BizTalk. Le tableau suivant présente ces touches de raccourci.

Remarque

  • Le clavier numérique permet d'obtenir la fonctionnalité non incluse dans la liste pour déplacer le pointeur de la souris à l'aide des Touches souris. Pour plus d'informations sur les Touches souris dans Windows 2000 Server et l'aide de Advanced Server, voir Utiliser le clavier pour déplacer le pointeur de la souris. Pour plus d'informations sur les Touches souris dans l'aide de Windows 2000 Édition Professionnelle, voir Déplacer le pointeur à l'aide des Touches souris.
Appuyez sur | À
CTRL+N | Ouvrir une nouvelle spécification.
Ctrl+O | Ouvrir un mappage existant.
CTRL+S | Enregistrer un mappage.
CTRL+F5 | Tester un mappage.
F4 | Mettre en surbrillance l'avertissement suivant.
F5 | Compiler un mappage
SUPPR | Supprimer un objet dans la grille de mappage.
F6 | Déplacer le focus d'un volet à l'autre dans le sens des aiguilles d'une montre.
MAJ+F6 | Déplacer le focus d'un volet à l'autre dans le sens inverse des aiguilles d'une montre. Lorsque vous appuyez sur les touches MAJ+F6 après avoir ouvert la palette de fonctoids, le focus se déplace sur l'onglet Chaîne, ce qui vous permet d'utiliser les touches de direction GAUCHE et DROITE pour visualiser les autres onglets.
TAB | Déplacer le focus dans le sens des aiguilles d'une montre dans le volet inférieur, en partant de l'onglet vers les volets ou les champs situés en dessous. La touche TABULATION permet de déplacer le focus d'un bouton ou d'un champ à l'autre dans la boîte de dialogue.
MAJ+TAB | Déplacer le focus dans le sens inverse des aiguilles d'une montre dans le volet inférieur, en partant de l'onglet vers les volets ou les champs situés en dessous.
BARRE ESPACE | Activer ou désactiver une case à cocher. L'utilisation de la barre d'espace entraîne le même résultat qu'un clic de souris lorsqu'un bouton est activé.
F1 | Afficher l'aide en ligne.
ALT+F4 | Quitter le programme.
GAUCHE | Activer l'onglet vers la gauche.
DROITE | Activer l'onglet situé à droite.
N'importe quelle touche de direction | Mettre en surbrillance un dossier ou un fichier du volet principal d'une boîte de dialogue, tandis que le focus est sur ce volet. Cette fonctionnalité intervient dans les boîtes de dialogue Stocker dans WebDAV et Extraire à partir de WebDAV. Pour plus d'informations, voir Extraction de mappages à partir de WebDAV.


Création de liaisons

Les liaisons copient simplement des données entre les enregistrements de l'arborescence Spécification source et les champs et les enregistrements de l'arborescence Spécification de destination. Le Mappeur BizTalk gère les liaisons de type « un-à-un » et « un-à-plusieurs ». Par exemple, une liaison peut relier un seul enregistrement ou champ de l'arborescence Spécification source à un seul enregistrement ou champ de l'arborescence Spécification de destination. Une liaison peut également relier un seul enregistrement ou champ de l'arborescence Spécification source à plusieurs enregistrements ou champs de l'arborescence Spécification de destination. Qui plus est, des liaisons peuvent relier plusieurs enregistrements ou champs de l'arborescence Spécification source à un fonctoid, lequel établit ensuite une liaison vers un seul enregistrement ou champ de l'arborescence Spécification de destination. Plusieurs enregistrements ou champs de l'arborescence Spécification source peuvent être liés à un seul enregistrement ou champ dans l'arborescence Spécification de destination.

Voir aussi

Gestion de liaisons


Correspondance des niveaux de hiérarchie des noeuds

Le Mappeur BizTalk inclut des directives de compilation. À l'aide de ces directives, vous pouvez définir le degré de correspondance entre la hiérarchie de l'arborescence Spécification source et la hiérarchie de l'arborescence Spécification de destination. Lorsque vous créez une liaison entre un champ de l'arborescence Spécification source et un champ de l'arborescence Spécification de destination, le Mappeur BizTalk ajoute automatiquement des liaisons de compilation en fonction des choix que vous avez effectués dans la zone Liaisons des spécifications de destination dans l'onglet Compilateur de la boîte de dialogue Propriétés des liaisons. Pour plus d'informations, voir Sélection des propriétés du compilateur pour les liaisons des spécifications de destination. Les schémas ci-après présentent les correspondances possibles des niveaux de hiérarchie des noeuds :

  • Aplatir les liaisons (valeur par défaut) : ce mode signifie que l'enregistrement parent de la liaison possède une liaison « un-à-un » vers chaque enregistrement de l'autre arborescence. Dans le premier schéma, la spécification source est plus complexe que la spécification de destination. Dans le second schéma, la spécification de destination est plus complexe.
Mise à plat de la liaison pour laquelle l'arborescence Spécification source est plus complexe que l'arborescence Spécification de destination
F2
R5
R4
Racine2
F1
R3
R2
R1
Racine1
Liaisons dessinées par l'utilisateur
Liaisons du compilateur

Mise à plat de la liaison pour laquelle l'arborescence Spécification de destination est plus complexe que l'arborescence Spécification source
R5
R4
R3
Racine2
F2
F1
R2
R1
Racine1
Liaisons dessinées par l'utilisateur
Liaisons du compilateur

  • Faire correspondre les liaisons du haut vers le bas : ce mode fait correspondre les différents niveaux du haut vers le bas. Dans le premier schéma, la spécification source est plus complexe que la spécification de destination. Dans le second schéma, la spécification de destination est plus complexe.
Mise en correspondance des liaisons de haut en bas pour lesquelles l'arborescence Spécification source est plus complexe que l'arborescence Spécification de destination
F2
R5
R4
Racine2
F1
R3
R2
R1
Racine1
Liaisons dessinées par l'utilisateur
Liaisons du compilateur

Mise en correspondance des liaisons de haut en bas pour lesquelles l'arborescence Spécification de destination est plus complexe que l'arborescence Spécification source
R5
R4
R3
Racine2
F2
F1
R2
R1
Racine1
Liaisons dessinées par l'utilisateur
Liaisons du compilateur

  • Faire correspondre les liaisons du bas vers le haut : ce mode fait correspondre les différents niveaux du bas vers le haut. Dans le premier schéma, la spécification source est plus complexe que la spécification de destination. Dans le second schéma, la spécification de destination est plus complexe.
Mise en correspondance des liaisons de bas en haut pour lesquelles l'arborescence Spécification source est plus complexe que l'arborescence Spécification de destination
F2
R5
R4
Racine2
F1
R3
R2
R1
Racine1
Liaisons dessinées par l'utilisateur
Liaisons du compilateur

Mise en correspondance des liaisons de bas en haut pour lesquelles l'arborescence Spécification de destination est plus complexe que l'arborescence Spécification source
R5
R4
R3
Racine2
F2
F1
R2
R1
Racine1
Liaisons dessinées par l'utilisateur
Liaisons du compilateur

Remarques

  • Si vous utilisez une directive de compilation aplanie, du haut vers le bas et du bas vers le haut pour les liaisons des champs de la spécification source vers les champs de la spécification de destination qui partagent le même enregistrement parent, le Mappeur BizTalk traite toutes les liaisons comme si elles étaient définies à la directive de compilation aplanie.

  • Si vous utilisez une ou plusieurs directives de compilation aplanies et une directive de compilation du haut vers le bas pour les liaisons des champs de la spécification source vers les champs de la spécification de destination qui partagent le même enregistrement parent, le Mappeur BizTalk traite toutes les liaisons comme si elles étaient définies à la directive de compilation du haut vers le bas.

  • Si vous utilisez une ou plusieurs directives de compilation aplanies et une directive de compilation du bas vers le haut pour les liaisons des champs de la spécification source vers les champs de la spécification de destination qui partagent le même enregistrement parent, le Mappeur BizTalk traite toutes les liaisons comme si elles étaient définies à la directive de compilation du bas vers le haut.

  • Si vous utilisez une ou plusieurs directives de compilation du haut vers le bas et une ou plusieurs directives de compilation du bas vers le haut pour les liaisons des champs de la spécification source vers les champs de la spécification de destination qui partagent le même enregistrement parent, le Mappeur BizTalk traite toutes les liaisons comme si elles étaient définies à la directive de compilation aplanie.

Voir aussi

Compilation de mappages


Affichage des propriétés des fonctoids, des liaisons, des champs et des enregistrements

La spécification source et la spécification de destination affichent les enregistrements et les champs associés à une spécification. Vous pouvez créer ces spécifications à l'aide du Mappeur BizTalk ou les importer dans l'Éditeur BizTalk en tant qu'instance XML bien formée. La spécification source apparaît sur la gauche de la grille de mappage alors que la spécification de destination apparaît sur la droite.

Valeurs et propriétés des champs et des enregistrements

Les propriétés et les valeurs des enregistrements et des champs apparaissent dans l'onglet Propriétés situé sous le volet principal. Lorsque vous sélectionnez un enregistrement ou un champ, les propriétés et les valeurs clés des onglets de propriétés de l'Éditeur BizTalk apparaissent.

Propriétés des fonctoids et des liaisons

La grille de mappage du Mappeur BizTalk représente, de manière graphique, la structure de la transformation des données. Les liaisons apparaissent sous forme d'une ligne qui relie un enregistrement ou un champ de l'arborescence Spécification source à un enregistrement ou un champ de l'arborescence Spécification de destination. Les liaisons permettent également de relier un enregistrement ou un champ à un fonctoid. Les fonctoids apparaissent sous forme d'icône. Les propriétés des liaisons incluent les données source et de destination, ainsi que des informations sur les directives de compilation. Les propriétés des fonctoids incluent des informations sur les paramètres d'entrée et sur les scripts.

Voir aussi

Enregistrements, champs et propriétés

Présentation des fonctoids


Présentation des fonctoids

Le Mappeur BizTalk prend en charge les transformations complexes de structure entre les enregistrements et les champs de l'arborescence Spécification source et les enregistrements et les champs de l'arborescence Spécification de destination. Les fonctoids effectuent des calculs par le biais de formules prédéfinies et de valeurs spécifiques, appelées arguments. Ces calculs sont exécutés dans l'ordre désigné des champs et des enregistrements. Si, après avoir sélectionné un fonctoid dans la palette de fonctoids, vous le déplacez dans la grille de mappage et créez une liaison avec des éléments provenant des arborescences Spécifications source et Spécifications de destination, les données peuvent être regroupées ou concaténées, les informations de date et d'heure modifiées et d'autres opérations effectuées. Par exemple, le fonctoid Addition ajoute des valeurs.

Les onglets de la Palette de fonctoids sont les suivants :

  • Chaîne : ces fonctoids manipulent des chaînes de données par le biais de fonctions de chaîne. Par exemple, le fonctoid Recherche de chaîne recherche une chaîne de texte dans une autre chaîne de texte et renvoie la position du premier caractère de la chaîne trouvée.

  • Mathématique : ces fonctoids effectuent des calculs en utilisant des valeurs spécifiques, appelées arguments, dans un ordre donné. Par exemple, le fonctoid Addition ajoute les valeurs des enregistrements et des champs désignés.

  • Opérateurs logiques : ces fonctoids effectuent des tests logiques. Si un fonctoid logique est connecté à un enregistrement de la spécification de destination et renvoie la valeur "true", l'enregistrement correspondant du document de sortie est généré. Si un fonctoid logique est connecté à un enregistrement de la spécification de destination et renvoie la valeur "false", l'enregistrement correspondant du document de sortie n'est pas généré. La sortie d'un fonctoid logique peut également être acceptée comme entrée pour les autres fonctoids d'un mappage.

  • Date/Heure : ces fonctoids manipulent des données de date et d'heure ou ajoutent les données de date, d'heure ou de date et d'heure actuelles à un enregistrement ou à un champ de la spécification de destination.

  • Conversion : ces fonctoids correspondent aux fonctions d'ingéniérie telles que DEC2HEX qui renvoie la valeur hexadécimale d'une valeur décimale. Ils permettent également de convertir un caractère à sa valeur ASCII ou de convertir une valeur au caractère ASCII correspondant.

  • Scientifique : ces fonctoids convertissent une valeur numérique en une valeur scientifique. Par exemple, le fonctoid Cosinus analyse une valeur d'un champ ou d'un enregistrement et renvoie l'angle, en radians, pour lequel vous recherchez le cosinus.

  • Cumulé : ces fonctoids renvoient la somme, la moyenne ou l'entrée minimale ou maximale d'un enregistrement en boucle.

  • Base de données : ces fonctoids extraient des données d'une base de données.

  • Avancé : cet onglet comporte un fonctoid qui peut utiliser un script Microsoft Visual Basic personnalisé, des fonctoids pour le mappage des valeurs, et des fonctoids pour la gestion et l'extraction des informations à partir de boucles d'enregistrement.

Vous pouvez également créer vos propres fonctoids. Pour obtenir un exemple de fonctoid personnalisé, recherchez le dossier C:\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\SampleFunctoid sur un ordinateur sur lequel BizTalk Server est installé intégralement ou de façon personnalisée avec les exemples d'échanges.

Cette section traite des rubriques suivantes :

  • Utilisation des fonctoids en cascade

  • Utilisation des fonctoids cumulés

  • Utilisation des fonctoids de base de données

  • Utilisation du fonctoid Nombre d'enregistrements

  • Utilisation du fonctoid Index

  • Utilisation du fonctoid Itération

  • Utilisation du fonctoid Mappage de valeurs

  • Utilisation du fonctoid Mappage des valeurs (mise à plat)

  • Utilisation du fonctoid Bouclage


Utilisation des fonctoids en cascade

Les fonctoids en cascade vous permettent de créer des mappages pour lesquels vous devez lier des champs ou des enregistrements à plusieurs fonctoids pour générer la sortie nécessaire dans un champ ou un enregistrement de la spécification de destination. Les fonctoids en cascade facilitent la création de plusieurs transformations consécutives dans la grille de mappage. Les fonctoids sont en cascade lorsqu'un fonctoid est lié à un autre fonctoid avant d'être lié à un enregistrement ou un champ de la spécification de destination. Par exemple, vous pouvez créer des fonctoids en cascade dans lesquels deux chaînes concaténées servent à générer une troisième chaîne qui est insérée dans un champ de la spécification de destination. Le nombre de fonctoids pouvant apparaître en cascade dans la grille de mappage est illimité ; cependant, des configurations complexes de fonctoids en cascade peuvent affecter les performances.


Utilisation des fonctoids cumulés

Les fonctoids cumulés fonctionnent dans le contexte du niveau des enregistrements de la spécification source. Certains enregistrements apparaissent généralement à de nombreuses reprises dans un fichier d'entrée. Par exemple, dans un ordre d'achat, la section Item (article) peut apparaître très souvent et peut inclure les produits, les descriptions, les prix et les quantités. Le code suivant est un exemple d'ordre d'achat :

<PurchaseOrder>
  <From>Kevin F. Browne</From>
  <To>Bits, Bytes, & Chips</To>
<LineItems>
  <Item>
    <Product>TravelLight 400</Product>
    <Description>laptop computer</Description>
    <Price>2000</Price>
    <Quantity>1</Quantity>
  </Item>
  <Item>
    <Product>TravelTuff Case</Product>
    <Description>laptop computer case</Description>
    <Price>50</Price>
    <Quantity>2</Quantity>
  </Item>
  <Item>
    <Product>ScreenClean</Product>
    <Description>computer monitor cleaner</Description>
    <Price>2</Price>
    <Quantity>100</Quantity>
  </Item>
</LineItems>
</PurchaseOrder>

L'illustration suivante présente cet ordre d'achat apparaissant dans l'Éditeur BizTalk.

Cliquez sur l'image pour l'agrandir ou la réduire.

Spécification de l'ordre d'achat

Notez que la propriété Occurrences maximales de l'onglet Référence correspond à * pour l'enregistrement Item. Ceci indique que l'enregistrement boucle, et le Mappeur BizTalk compile cet enregistrement en tant que boucle.

Vous pouvez rechercher la somme totale de tous les postes dans l'ordre d'achat et mapper le total cumulé dans un champ d'un document de sortie. Pour ce faire, vous devez tout d'abord calculer le prix étendu de chaque enregistrement Item de l'ordre d'achat puis additionner les totaux des enregistrements individuels lorsque le mappage s'étend à tous les enregistrements Item de l'ordre d'achat.

L'illustration suivante présente un fonctoid Multiplication et un fonctoid Somme cumulée utilisés pour additionner les enregistrements Item d'un ordre d'achat entrant et générer les résultats dans le champ POTotal (TotalOA) d'un document TotalDocument (DocumentTotaux).

Cliquez sur l'image pour l'agrandir ou la réduire.

Dans cet exemple, tous les enregistrements Item qui existent sous l'enregistrement LineItems (Poste) d'un ordre d'achat entrant font partie de l'opération de cumul. Les champs Price (Prix) et Quantity (Quantité) sont envoyés à un fonctoid Multiplication. La sortie du fonctoid Multiplication devient l'entrée du fonctoid Somme cumulée. La sortie du fonctoid Somme cumulée est la valeur additionnée lors de l'intégration des enregistrements Item dans l'ordre d'achat d'entrée. Cette valeur est envoyée dans le champ POTotal (TotalOA) du document DocumentTotaux et elle correspond à la somme de tous les produits des prix et des quantités : (2000x1)+(50x2)+(2x100)=2300.

Remarques

  • Le total cumulé d'une entrée donnée intervient sur l'enregistrement parent à partir duquel la liaison de l'entrée est établie. Ceci s'applique également aux sorties de fonctoids qui sont insérées en tant qu'entrées dans un fonctoid cumulé.

  • Les fonctoids cumulés ignorent les entrées non numériques. Par exemple, une valeur d'entrée de " trois " est ignorée.

Les fonctoids Moyenne cumulée, Minimum cumulé et Maximum cumulé agissent comme le fonctoid Somme cumulée. Le fonctoid Chaîne cumulée est différent des autres fonctoids cumulés dans le sens où il concatène des chaînes et n'additionne pas des valeurs numériques.

Voir aussi

Ajout de fonctoids cumulés

Fonctoids cumulés


Utilisation des fonctoids de base de données

Les fonctoids de base de données extraient des données d'une base de données. Pour comprendre comment les fonctoids de base de données sont utilisés, prenez l'exemple d'un important détaillant qui possède de nombreux magasins implantés sur une zone géographique très étendue. Chaque magasin est désigné par un code numérique et une liste d'adresses est distribuée à tous les partenaires. La structure de la liste d'adresses peut être la suivante :

IDMagasin : 123

Nom : A. Datum Corporation

Adresse : 1234 Main Street

Ville : Denver, Colorado

CodePostal : 97402

NuméroTéléphone : 801-555-0179

ResponsableMagasin : Anthony Chor

Dans les transactions suivantes, seul le code numérique représentant le magasin est envoyé dans un ordre d'achat. Le Mappeur BizTalk utilise ce code pour extraire les informations d'adresse d'une base de données. Cette configuration est représentée dans l'illustration suivante.

Cliquez sur l'image pour l'agrandir ou la réduire.

Mappage du fonctoid Base de données

Dans cette illustration, la spécification source représente un ordre d'achat entrant et la spécification de destination représente une facture. Le fonctoid Recherche dans la base de données Fonctoid Recherche dans la base de données effectue une recherche dans la base de données pour trouver l'enregistrement approprié dans la table appropriée. La sortie du fonctoid Recherche dans la base de données peut être reliée uniquement aux fonctoids Extracteur de valeur. Fonctoid Extracteur de valeur. Le fonctoid Extracteur de valeur extrait le nom de la colonne à partir de l'enregistrement dans lequel est effectuée la recherche. Le fonctoid Retour d'erreur Fonctoid Retour d'erreur génère une chaîne qui contient des informations sur les erreurs, lorsque des erreurs se produisent durant l'exécution (telles que des erreurs de connexion).

Le fonctoid Recherche dans la base de données requiert quatre paramètres, dans l'ordre suivant :

  • Valeur faisant l'objet de la recherche

  • Chaîne de connexion à la base de données

  • Nom de la table

  • Nom de la colonne pour la valeur de la recherche

Pour plus d'informations sur l'insertion, la suppression et le déplacement des paramètres d'entrée, voir Paramètres d'entrée.

Dans l'exemple précédent, le premier paramètre d'entrée provient du champ StoreID (IDMagasin) de l'ordre d'achat entrant, les trois autres paramètres d'entrée étant des constantes de l'onglet Général de la boîte de dialogue Propriété des fonctoids pour le fonctoid Recherche dans la base de données. Il est possible de créer des liaisons à partir de l'arborescence Spécification source pour fournir des valeurs aux quatre paramètres d'entrée. Pour plus d'informations sur l'insertion, la suppression et le déplacement des paramètres d'entrée, voir Paramètres d'entrée.

Le fonctoid Extracteur de valeur requiert deux paramètres d'entrée, dans l'ordre suivant :

  • Liaison vers le fonctoid Recherche dans la base de données

  • Nom de la colonne

Le fonctoid Retour d'erreur requiert un paramètre d'entrée : une liaison vers le fonctoid Recherche dans la base de données.

Remarques

  • Certains types de données SQL Server, tels que text, ntext et image ne peuvent pas être utilisés comme valeurs de recherche pour le fonctoid Recherche dans la base de données.

  • Si plusieurs enregistrements correspondent aux paramètres d'entrée du fonctoid Recherche dans la base de données, le fonctoid Extracteur de valeur extrait uniquement le premier enregistrement de la table.

Voir aussi

Fonctoids de base de données

Paramètres d'entrée


Utilisation du fonctoid Nombre d'enregistrements

Le fonctoid Nombre d'enregistrements intervient dans le contexte du niveau des enregistrements de la spécification source. Certains enregistrements apparaissent généralement à de nombreuses reprises dans un fichier d'entrée. Par exemple, dans un ordre d'achat, la section Item est très fréquente. Cette section peut inclure les produits, les descriptions, les prix et les quantités. Le code suivant est un exemple d'ordre d'achat :

<PurchaseOrder>
  <From>Kevin F. Browne</From>
  <To>Bits, Bytes, & Chips</To>
<LineItems>
  <Item>
    <Product>TravelLight 400</Product>
    <Description>laptop computer</Description>
    <Price>2000</Price>
    <Quantity>1</Quantity>
  </Item>
  <Item>
    <Product>TravelTuff Case</Product>
    <Description>laptop computer case</Description>
    <Price>50</Price>
    <Quantity>2</Quantity>
  </Item>
  <Item>
    <Product>ScreenClean</Product>
    <Description>computer monitor cleaner</Description>
    <Price>2</Price>
    <Quantity>100</Quantity>
  </Item>
</LineItems>
</PurchaseOrder>

L'illustration suivante présente cet ordre d'achat apparaissant dans l'Éditeur BizTalk.

Cliquez sur l'image pour l'agrandir ou la réduire.

Spécification de l'ordre d'achat

Notez que la propriété Occurrences maximales de l'onglet Référence correspond à * pour l'enregistrement Item. Ceci indique que l'enregistrement Item boucle et que le Mappeur BizTalk compile cet enregistrement en tant que boucle.

Vous pouvez rechercher le total des postes dans l'ordre d'achat et mapper cette valeur dans un champ du document de sortie. Cette configuration est légèrement différente de la configuration de mappage classique dans laquelle le contenu du document source est mappé sur le document de sortie. Dans ce cas, le fonctoid Nombre d'enregistrements génère la valeur qui est mappée sur le document de sortie.

Le fonctoid Nombre d'enregistrements comporte une entrée et une sortie. L'entrée est une liaison provenant d'un enregistrement en boucle de la spécification source. Cet enregistrement apparaît à de nombreuses reprises dans le document d'entrée d'origine. La sortie du fonctoid Nombre d'enregistrements est une liaison vers un champ de la spécification de destination.

L'illustration suivante présente un fonctoid Nombre d'enregistrements qui totalise le nombre d'articles dans un ordre d'achat entrant et transfère cette valeur dans le champ Number_Of_Items (Nombre_d_éléments) du document POReport (RapportOA).

Cliquez sur l'image pour l'agrandir ou la réduire.

Mappage du fonctoid Nombre d'enregistrements

Dans cet exemple, l'ordre d'achat entrant comporte trois articles : par conséquent, la valeur du champ Nombre_d'éléments correspond à 3.

Voir aussi

Fonctoids avancés


Utilisation du fonctoid Index

Le fonctoid Index intervient dans le contexte du niveau des enregistrements de la spécification source. Certains enregistrements apparaissent généralement à de nombreuses reprises dans un fichier d'entrée. Par exemple, dans un bulletin météorologique, la section WeatherReport (Bulletin météorologique) est très fréquente. Cette section peut inclure la température, la pression atmosphérique et la force du vent. Le code suivant est un exemple de bulletin météorologique :

<WeatherReport>
  <DailySummary>
    <Temperature>20</Temperature>
    <Pressure>80</Pressure>
    <WindSpeed>10</WindSpeed>
  </DailySummary>
  <DailySummary>
    <Temperature>23</Temperature>
    <Pressure>78</Pressure>
    <WindSpeed>20</WindSpeed>
  </DailySummary>
  <DailySummary>
    <Temperature>24</Temperature>
    <Pressure>77</Pressure>
    <WindSpeed>16</WindSpeed>
  </DailySummary>
</WeatherReport>

L'illustration suivante présente ce bulletin météorologique dans l'Éditeur BizTalk.

Cliquez sur l'image pour l'agrandir ou la réduire.

Spécification du bulletin météorologique

Notez que la propriété Occurrences maximales de l'onglet Référence correspond à * pour l'enregistrement DailySummary (RésuméDuJour). Ceci indique que cet enregistrement boucle et que le Mappeur BizTalk compile cet enregistrement en tant que boucle.

Vous pouvez regrouper des informations météorologiques pour les deux premiers enregistrements RésuméDuJour du bulletin météorologique. Dans le Mappeur BizTalk, chaque champ de l'enregistrement DailySummary de la spécification source peut être relié à un fonctoid Index, et chaque fonctoid Index peut spécifier à partir de quel enregistrement RésuméDuJour les informations sont extraites : le premier et le deuxième. Les fonctoids Index peuvent être liés aux champs appropriés de la spécification de destination. Notez que les fonctoids Index sont utilisés uniquement entre les champs qui existent sous un seul enregistrement parent de la spécificaiton source et les champs qui existent sous un seul enregistrement parent de la spécification de destination.

L'illustration suivante présente les fonctoids Index utilisés dans cette configuration.

Cliquez sur l'image pour l'agrandir ou la réduire.

Mappage du fonctoid Index

Pour obtenir les informations de résumé du jour pour le premier jour, la valeur d'index des trois premiers fonctoids Index doit correspondre à 1. Pour obtenir les informations de résumé du jour pour le deuxième jour, la valeur d'index des trois derniers fonctoids Index doit correspondre à 2.

Les entrées des séquences d'index sont définies comme paramètres d'entrée dans l'onglet Général de la feuille de propriétés d'un fonctoid Index. Double-cliquez sur un fonctoid Index pour afficher sa feuille de propriétés. Le premier paramètre d'entrée identifie le champ de la spécification source qui est lié au fonctoid Index. Les paramètres ou les paramètres d'entrée suivants indiquent les valeurs d'index.

L'illustration suivante présente la feuille de propriétés du fonctoid supérieur Index dans le mappage précédent.

Cliquez sur l'image pour l'agrandir ou la réduire.

Propriétés du fonctoid Index

Remarques

  • Un paramètre d'entrée d'un fonctoid Index affecté à une valeur de constante non-numérique est interprété par le Mappeur BizTalk pour prendre la valeur 1. Par exemple, dans l'illustration précédente, si le second paramètre d'entrée était remplacé par un paramètre d'entrée comportant une valeur « anystring » (chaîne quelconque), le résultat du mappage resterait le même.

  • Bien que les entrées des séquences d'index soient généralement des valeurs de constante dans l'onglet Général de la boîte de dialogue Propriétés des fonctoids, il est possible d'utiliser une liaison provenant d'un noeud de la spécification source pour la valeur d'entrée de la séquence. Si cette liaison provient d'un enregistrement en boucle qui n'est pas un enregistrement parent du premier paramètre d'entrée, la valeur d'entrée de la séquence d'index provient de la première instance du noeud du document entrant.

  • La valeur d'entrée de la séquence d'index est toujours liée au contexte actuel du document source.

Si un fichier d'entrée comporte plusieurs bulletins météorologiques incluant chacun plusieurs résumés du jour, vous devrez peut-être spécifier plusieurs valeurs d'index. Le code suivant est un exemple de fichier d'entrée comportant plusieurs bulletins météorologiques :

<WeatherReports>
  <WeatherReport1>
    <DailySummary>
      <Temperature>20</Temperature>
      <Pressure>80</Pressure>
      <WindSpeed>10</WindSpeed>
    </DailySummary>
    <DailySummary>
      <Temperature>23</Temperature>
      <Pressure>78</Pressure>
      <WindSpeed>20</WindSpeed>
    </DailySummary>
  </WeatherReport1>
  <WeatherReport2>
    <DailySummary>
      <Temperature>24</Temperature>
      <Pressure>77</Pressure>
      <WindSpeed>16</WindSpeed>
    </DailySummary>
    <DailySummary>
      <Temperature>22</Temperature>
      <Pressure>79</Pressure>
      <WindSpeed>21</WindSpeed>
    </DailySummary>
  </WeatherReport2>
</WeatherReports>

Un fonctoid Index comportant deux valeurs d'index (la première correspondant à 1 et la seconde correspondant à 2) obtient la valeur d'un champ à partir du premier résumé du jour du second bulletin météorologique.

Important

  • Les valeurs d'index d'un fonctoid Index doivent être égales au nombre de noeuds parents à partir du niveau du champ vers le premier niveau sous le noeud racine. Par exemple, dans l'exemple de document comportant plusieurs bulletins météorologiques, deux valeurs d'index sont nécessaires. Dans l'exemple de document comportant un seul bulletin météorologique, une seule valeur d'index est nécessaire. Si vous ne définissez pas correctement le nombre de valeurs d'index d'un fonctoid Index, la sortie est générée d'après le premier noeud du document source qui correspond au premier paramètre d'entrée du fonctoid Index.

Voir aussi

Fonctoids avancés


Utilisation du fonctoid Itération

Le fonctoid Itération identifie quel numéro de séquence dans un enregistrement en boucle est en cours de mappage. L'illustration suivante présente le fonctoid Itération utilisé avec un fonctoid Égal à.

Cliquez sur l'image pour l'agrandir ou la réduire.

Mappage du fonctoid Itération

Il existe deux fonctoids (le fonctoid Itération Fonctoid Itération et le fonctoid Égal à Fonctoid Égal à ) pour chacun des deux enregistrements de la spécification de destination. L'illustration suivante présente la feuille de propriétés du fonctoid supérieur Égal à.

Cliquez sur l'image pour l'agrandir ou la réduire.

Feuille de propriétés du fonctoid Égal à

Le code suivant est un exemple d'instance de document entrant qui respecte la structure de la spécification source :

<Root>
<Record1 Field1="A"/>
<Record1 Field1="B"/>
</Root>

Lorsque que la spécification source boucle dans l'instance de document entrant, le fonctoid Itération renvoie la valeur 1 alors que le premier enregistrement est en cours de mappage, et la valeur 2 alors que le second enregistrement est en cours de mappage. Le fonctoid Égal à renvoie la valeur " true " lorsque ses deux paramètres d'entrée sont égaux. Par conséquent, la paire de fonctoids supérieurs renvoie la valeur " true " lorsque le premier enregistrement de l'instance de document entrant est en cours de mappage. La valeur " true " est transmise à l'enregistrement Record2 de la spécification de destination, et Record2 est écrit dans le document de sortie. Si la valeur du second paramètre d'entrée du fonctoid inférieur Égal à est égale à 2, la paire de fonctoids inférieure agit de manière similaire à la paire de fonctoids supérieure. En d'autres termes, lorsque le second enregistrement de l'instance de document entrant est mappé, l'enregistrement Record3 de la spécification de destination est écrit dans l'instance de document de sortie. Le code suivant présente l'instance de document de sortie :

<Root2>
<Record2 Field2="A"/>
<Record3 Field3="B"/>
</Root2>

Voir aussi

Fonctoids avancés


Utilisation du fonctoid Mappage de valeurs

Le fonctoid Mappage de valeurs Fonctoid Mappage de valeurs requiert deux paramètres d'entrée et renvoie la valeur du second paramètre d'entrée si la valeur du premier paramètres est " true ". Dans le mappage présenté dans l'illustration ci-après, le fonctoid Mappage de valeurs est utilisé de cette manière.

Cliquez sur l'image pour l'agrandir ou la réduire.

Fonctoid Mappage de valeurs

Pour effectuer un mappage, vous devez définir les paramètres d'entrée de chaque fonctoid. L'illustration suivante présente la feuille de propriétés de chacun des trois fonctoids Mappage de valeurs.

Cliquez sur l'image pour l'agrandir ou la réduire.

Feuille de propriétés du fonctoid Mappage de valeurs

L'illustration suivante présente la feuille de propriétés du fonctoid supérieur Égal à.

Cliquez sur l'image pour l'agrandir ou la réduire.

Feuille de propriétés du fonctoid Égal à

La feuille de propriétés du fonctoid intermédiaire Égal à est similaire, mais son deuxième paramètre d'entrée possède une valeur Y constante. La feuille de propriétés du fonctoid Égal à inférieur est également similaire, mais son deuxième paramètre d'entrée possède une valeur Z constante.

Il est possible qu'une instance de document source contienne l'élément suivant.

<Field Name="X" Value="1"/>

Avec une valeur Name de X, le fonctoid supérieur Égal à renvoie une valeur " true ". Suite au renvoi de la valeur " true " par le fonctoid Égal à, le fonctoid Valeur d'attribut qui est lié renvoie une valeur de 1.

Le code suivant est un exemple d'instance de document correspondant à la spécification source du mappage.

<Root>
  <Record>
    <Field Name="X" Value="1"/>
    <Field Name="Y" Value="2"/>
    <Field Name="Z" Value="3"/>
  </Record>
  <Record>
    <Field Name="X" Value="4"/>
    <Field Name="Y" Value="5"/>
    <Field Name="Z" Value="6"/>
  </Record>
  <Record>
    <Field Name="X" Value="7"/>
    <Field Name="Y" Value="8"/>
    <Field Name="Z" Value="9"/>
  </Record>
</Root>

Avec ce mappage et cette instance de document source, BizTalk Server génère l'instance de document suivante.

<Root>
<Record X="1"/>
<Record Y="2"/>
<Record Z="3"/>
<Record X="4"/>
<Record Y="5"/>
<Record Z="6"/>
<Record X="7"/>
<Record Y="8"/>
<Record Z="9"/>
</Root>

Important

  • Le fonctoid Mappage de valeurs accepte les entrées booléennes uniquement sous la forme de chaînes " true " et " false " en minuscules. Par exemple, si un champ d'instance de document entrant a pour valeur " true " et est directement lié au paramètre d'entrée supérieur d'un fonctoid Mappage de valeurs, la valeur du second paramètre d'entrée du fonctoid Mappage de valeurs n'est pas transmise au document de sortie.

Voir aussi

Fonctoids avancés

Utilisation du fonctoid Mappage des valeurs (mise à plat)


Utilisation du fonctoid Mappage des valeurs (mise à plat)

Un scénario classique pour les utilisateurs de Microsoft Commerce Server consiste à effectuer un mappage à partir d'un catalogue Commerce Server vers un schéma à plat. Grâce au fonctoid Mappage des valeurs (mise à plat), ce type de mappage est possible. Le code suivant est un exemple de catalogue Commerce Server :

<Root>
  <Record>
    <Field Name="X" Value="1"/>
    <Field Name="Y" Value="2"/>
    <Field Name="Z" Value="3"/>
  </Record>
  <Record>
    <Field Name="X" Value="4"/>
    <Field Name="Y" Value="5"/>
    <Field Name="Z" Value="6"/>
  </Record>
  <Record>
    <Field Name="X" Value="7"/>
    <Field Name="Y" Value="8"/>
    <Field Name="Z" Value="9"/>
  </Record>
</Root>

Le code suivant est un exemple de schéma à plat :

<Root>
  <Record X="1" Y="2" Z="3"/>
  <Record X="4" Y="5" Z="6"/>
  <Record X="7" Y="8" Z="9"/>
</Root>

Dans cette configuration de mappage, il est important de conserver une correspondance un-à-un entre les trois enregistrements du catalogue et les trois enregistrements du schéma à plat. L'illustration suivante présente un mappage qui conserve cette correspondance.

Cliquez sur l'image pour l'agrandir ou la réduire.

Mappage des valeurs (mise à plat)

Dans ce mappage, la spécification source représente la structure du catalogue, et la spécification de destination représente la structure du schéma à plat sortant. Il existe une paire de fonctoids (le fonctoid Égal à Fonctoid Égal à et le fonctoid Mappage des valeurs (mise à plat) Fonctoid Mappage des valeurs (mise à plat) ) pour chacun des trois enregistrements. L'illustration suivante présente la feuille de propriétés de chacun des trois fonctoids Mappage des valeurs (mise à plat).

Cliquez sur l'image pour l'agrandir ou la réduire.

Feuille de propriétés du fonctoid Mappage des valeurs (mise à plat)

L'illustration suivante présente la feuille de propriétés du fonctoid supérieur Égal à.

Cliquez sur l'image pour l'agrandir ou la réduire.

Feuille de propriétés du fonctoid Égal à

La feuille de propriétés du fonctoid intermédiaire Égal à est similaire, mais son deuxième paramètre d'entrée possède une valeur Y constante. La feuille de propriétés du fonctoid Égal à inférieur est également similaire, mais son deuxième paramètre d'entrée possède une valeur Z constante.

La paire de fonctoids supérieure interagit pour garantir que la valeur de X est transmise à partir de chacun des trois enregistrements du catalogue à chacun des trois enregistrements du schéma à plat. Le fonctoid Mappage des valeurs (mise à plat) renvoie la valeur du second paramètre de sa feuille de propriétés, uniquement si la valeur du premier paramètre est " true ". Pour cette raison, le fonctoid Mappage des valeurs (mise à plat) renvoie la valeur de /Root/Record/Field/@Value uniquement si le fonctoid Égal à auquel il est lié renvoie une valeur " true ". Le fonctoid Égal à auquel il est lié renvoie une valeur " true " uniquement pour les champs du catalogue entrant ayant des valeurs Name de X.

Le fonctoid Égal à de la paire de fonctoids intermédiaire renvoie une valeur " true " uniquement pour les champs de la spécification entrante ayant des valeurs Name de Y. Ainsi, cette paire de fonctoids garantit que la valeur de Y est transmise à partir de chacun des trois enregistrements du catalogue à chacun des trois enregistrements du schéma à plat. La troisième paire de fonctoids gère la valeur de Z de la même manière.

Important

  • Le fonctoid Mappage des valeurs (mise à plat) accepte les entrées booléennes uniquement sous la forme de chaînes " true " et " false " en minuscules. Par exemple, si la valeur d'un champ d'une instance de document entrant est " True " et que le champ est directement lié au paramètre d'entrée supérieur du fonctoid Mappage des valeurs (mise à plat), la valeur du second paramètre d'entrée du fonctoid Mappage des valeurs (mise à plat) n'est pas transmise au document de sortie.

Remarque

  • Si un enregistrement d'une instance de document de catalogue entrant comporte plusieurs champs possédant un attribut qui correspond au second paramètre d'entrée de l'un des fonctoids Égal à dans cette configuration de mappage, seul le dernier enregistrement ayant cette correspondance est mappé sur le document de sortie. Par exemple, dans l'exemple précédent d'un catalogue Commerce Server, s'il existait trois éléments Field (Champ) du premier élément Record (Enregistrement) dotés des attributs Name (Nom) ayant des valeurs de X, seul le dernier élément Field serait mappé.

Pour plus d'informations sur le mappage d'un schéma à plat sur un catalogue Commerce Server (mappage dans la direction opposée de la configuration de mappage précédente), voir Utilisation du fonctoid Bouclage

Voir aussi

Fonctoids avancés

Utilisation du fonctoid Bouclage

Utilisation du fonctoid Mappage de valeurs


Utilisation du fonctoid Bouclage

Le fonctoid Bouclage Fonctoid Bouclage permet d'associer plusieurs enregistrements et/ou champs de la spécification source dans un seul enregistrement de la spécification de destination. L'illustration suivante présente le fonctoid Bouclage utilisé de cette manière.

Cliquez sur l'image pour l'agrandir ou la réduire.

Mappage du fonctoid Bouclage

L'enregistrement BillTo (FacturerÀ) de la spécification source et l'enregistrement Adresses de la spécification de destination bouclent, comme l'indique le paramètre Occurrences maximales défini sur * dans les sections Attributs source et Attributs de destination de l'onglet Propriétés. Dans cet exemple, les enregistrements ShipTo (ExpédierÀ) et Header (En-tête) de la spécification source tournent également en boucle. Si une instance de document entrant comportait trois enregistrements BillTo et deux enregistrements ShipTo, le fonctoid Bouclage les associerait pour créer cinq enregistrements Adresses (Adresses) dans le document de sortie.

Le code suivant est un exemple d'instance de document entrant :

<Root>
<BillTo Name="Kim Yoshida" Address="345 North 63rd Street"
City="Boston" PostalCode="07458"></BillTo>
<BillTo Name="Michelle Votava" Address="7890 Broadway"
City="Columbus" PostalCode="46290"></BillTo>
<BillTo Name="Tanya Van Dam" Address="1234 Main Street"
City="Denver" PostalCode="97402"></BillTo>
<ShipTo Name="Patricia Esack" Address="456 First Avenue"
City="Miami" PostalCode="81406"></ShipTo>
<ShipTo Name="Peter Kress" Address="567 2nd Avenue"
City="Seattle" PostalCode="98103"></ShipTo>
<Header ID="01"></Header>
<Header ID="02"></Header>
<Header ID="03"></Header>
</Root>

Cette instance de document entrant produirait l'instance de document de sortie suivante si elle avait été traitée par le mappage présenté dans l'illustration précédente :

<Root>
<Addresses Name="Kim Yoshida" Address="345 North 63rd Street"
City="Boston" PostalCode="07458" ID="01" />
<Addresses Name="Michelle Votava" Address="7890 Broadway"
City="Columbus" PostalCode="46290" ID="01" />
<Addresses Name="Tanya Van Dam" Address="1234 Main Street"
City="Denver" PostalCode="97402" ID="01" />
<Addresses Name="Patricia Esack" Address="456 First Avenue"
City="Miami" PostalCode="81406" ID="01" />
<Addresses Name="Peter Kress" Address="567 2nd Avenue"
City="Seattle" PostalCode="98103" ID="01" />
</Root>

Notez que dans chaque enregistrement Adresses créé dans l'instance de document de sortie, la valeur du champ ID est " 01 ". Ceci s'explique par le fait que l'enregistrement Header (En-tête) n'est pas lié au fonctoid Bouclage. La première valeur du champ ID de l'instance de document entrant est transmise à chaque enregistrement créé dans l'instance de document de sortie.

Important

  • Dans certaines conditions, des fonctoids peuvent ne pas fonctionner correctement lorsqu'ils sont utilisés dans un mappage avec un fonctoid Bouclage. Dans les conditions ci-après, le résultat d'un fonctoid ne sera pas correct :
    • Le fonctoid comporte plusieurs liaisons de spécification source.

    • Au moins deux liaisons de spécification source du fonctoid sont reliées aux champs enfants des enregistrements d'entrée du fonctoid Bouclage. Les champs enfants ne sont pas des frères.

    • La liaison de spécification de destination du fonctoid est reliée à un champ enfant de l'enregistrement de sortie du fonctoid Bouclage.

    Si vous deviez ajouter au mappage précédent un fonctoid qui répond à ces conditions, le fonctoid pourrait comporter une liaison de spécification source connectée au champ Name (Nom) sous l'enregistrement BillTo, une autre liaison de spécification source connectée au champ Name sous l'enregistrement ShipTo et une liaison de spécification de destination connectée au champ Name sous l'enregistrement Addresses.

Mappage d'un schéma à plat sur un catalogue Commerce Server

Vous pouvez utiliser le fonctoid Bouclage pour mapper un schéma à plat sur un catalogue Microsoft Commerce Server. Pour plus d'informations sur les schémas à plat et les catalogues Commerce Server, voir Utilisation du fonctoid Mappage de valeurs (mise à plat).

L'illustration suivante présente un schéma à plat mappé sur un catalogue Commerce Server.

Cliquez sur l'image pour l'agrandir ou la réduire.

Mise à plat de fichier dans un mappage de catalogue

Important

  • Pour que ce mappage fonctionne correctement, vous devez respecter les conditions suivantes :
    • Pour chaque liaison établie avec le champ Name (Nom) de la spécification de destination, définissez les propriétés des liaisons de spécification source afin que le nom soit copié. Pour plus d'informations, voir Sélection des propriétés du compilateur pour les liaisons des spécifications source.

    • Pour chaque liaison établie avec le champ Value (Valeur) de la spécification de destination, définissez les propriétés des liaisons de spécification source afin que la valeur soit copiée. Pour plus d'informations, voir Sélection des propriétés du compilateur pour les liaisons des spécifications source.

    • Pour la liaison établie entre le fonctoid Bouclage et l'enregistrement nommé Field (Champ) de la spécification de destination, définissez les propriétés des liaisons de spécification de destination afin de faire correspondre les liaisons du haut vers le bas. Pour plus d'informations, voir Sélection des propriétés du compilateur pour les liaisons des spécifications de destination.

    • Vérifiez que l'option Autoriser plusieurs entrées dans les noeuds de destination de l'arborescence est sélectionnée dans la boîte de dialogue Options du Mappeur BizTalk. Pour plus d'informations, voir Options du Mappeur BizTalk : Onglet Général

Voir aussi

Options du Mappeur BizTalk : Onglet Général

Sélection des propriétés du compilateur pour les liaisons des spécifications de destination

Sélection des propriétés du compilateur pour les liaisons des spécifications source

Utilisation du fonctoid Mappage des valeurs (mise à plat)


Compilation de mappages

Lorsque vous compilez des mappages, une représentation visuelle des transformations est créée par le composant de compilation du Mappeur BizTalk. Ce composant génère également une feuille de style XSL (Extensible Stylesheet Language) pour l'exécution. Ce processus crée un mappage. La compilation d'un mappage applique les transformations et les règles de structure qui sont spécifiées dans la grille de mappage. Les transformations, telles que les liaisons, sont traitées suivant l'ordre dans lequel les enregistrements et les champs apparaissent dans l'instance de la structure source. Par exemple, lorsque le Mappeur BizTalk atteint un champ ou un enregistrement source auquel est associée une liaison, le Mappeur BizTalk compile les propriétés de la liaison. L'action peut être une valeur simple de copie qui remplit un enregistrement ou un champ de la spécification de destination ; l'action peut aussi calculer les valeurs à partir d'un ou de plusieurs enregistrements et champs à partir de la source vers un ou plusieurs enregistrements et champs de la destination, en fonction des propriétés d'un fonctoid. L'exécution de chaque liaison est indépendante de l'exécution des autres liaisons.

Le Mappeur BizTalk génère un avertissement dans l'onglet Avertissements lorsque le compilateur fait face à une situation qui produit une sortie incorrecte. Par exemple, si un fonctoid qui requiert un paramètre d'entrée ne dispose d'aucun paramètre, le Mappeur BizTalk génère un avertissement dans l'onglet Avertissements lorsque le mappage est compilé. Pour qu'un mappage soit prêt pour un environnement de production, il ne doit plus générer aucun avertissement.

Le processus de compilation stocke toutes les informations sur les spécifications source et de destination, notamment l'ensemble du contenu et des fonctionnalités des liaisons et des objets. Le mappage compilé est utilisé par BizTalk Server pour effectuer la traduction réelle d'une instance d'entrée en instance de sortie.

Voir aussi

Correspondance des niveaux de hiérarchie des noeuds


Test de mappages

Lorsque vous créez un mappage, vous pouvez utiliser le Mappeur BizTalk pour vérifier que le mappage que vous avez conçu génère la sortie correcte. La fonction Test de mappages génère automatiquement une instance de test d'un document source à partir de la spécification. Cette fonction vérifie des informations, (telles que le nombre d'occurrences des enregistrements, les types de données des champs...) provenant de la spécification, puis génère l'instance de test. Vous pouvez spécifier des valeurs uniques pour tout enregistrement ou champ de la zone Valeur du test source dans l'onglet Valeurs, puis tester les résultats de ces données.

Lorsque vous testez un mappage, le Mappeur BizTalk le compile automatiquement. Cependant, il est conseillé de compiler d'abord un mappage, puis de résoudre tous les messages d'avertissement ou d'erreur avant de le tester. Avant le début du test, le système vous demande d'enregistrer votre fichier. Par mesure de précaution, enregistrez-le avant le test afin de conserver vos données en cas d'introduction accidentelle d'un problème dans le mappage.

Une fois le mappage compilé, les résultats apparaissent dans l'onglet Sortie. Les données de test correspondent à la spécification de destination.

Remarque

  • La fonctionnalité de test du Mappeur BizTalk se limite au test d'un mappage par rapport à une instance de document de test générée automatiquement. L'instance de document de test est générée par le Mappeur BizTalk et repose sur la spécification source. En d'autres termes, lorsque vous utilisez le Mappeur BizTalk, vous ne pouvez pas tester à votre gré un mappage avec une instance réelle de document professionnel. Toutefois, un exemple d'un script de test de mappage inclus dans BizTalk Server vous permet de tester un mappage par rapport à une instance de document de votre choix. Pour plus d'informations, voir \Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\MapTest\Readme.txt.

Voir aussi

Test de fonctoids

Test de liaisons

Test des propriétés des enregistrements et des champs possédant des liaisons


Ressources

Cette section traite des rubriques suivantes :

  • Personnalisation de l'affichage

  • Fonctoids de chaîne

  • Fonctoids mathématiques

  • Fonctoids logiques

  • Fonctoids Date et Heure

  • Fonctoids de conversion

  • Fonctoids scientifiques

  • Fonctoids cumulés

  • Fonctoids de base de données

  • Fonctoids avancés

  • Mappages pour l'intégration des services BizTalk


Personnalisation de l'affichage

Vous pouvez personnaliser l'apparence du Mappeur BizTalk de différentes manières. Par exemple, vous pouvez modifier les couleurs d'arrière-plan de la grille de mappage, spécifier de nouvelles couleurs pour les liaisons et les objets sélectionnés, modifier la couleur des messages d'avertissement du compilateur et modifier la taille du texte. Les éléments suivants peuvent faire l'objet d'une personnalisation :

  • Premier plan de la grille : lignes discontinues dans la grille de mappage.

  • Arrière-plan de la grille : couleur d'arrière-plan de la grille de mappage.

  • Liaisons fixes : liaisons opérant une copie de la valeur dans la grille de mappage.

  • Liaisons souples : liaisons de copie de la valeur, qui sont déplacées de l'arborescence Spécification source vers l'arborescence Spécification de destination.

  • Liaisons partielles : liaisons pour un champ ou un enregistrement dont le noeud de l'enregistrement parent est réduit.

  • Liaisons du compilateur : liaisons de directive de compilation, qui sont automatiquement créées lorsqu'une liaison est établie d'un champ de l'arborescence Spécification source vers un champ de l'arborescence Spécification de destination.

Ces fonctions sont disponibles dans la boîte de dialogue Options, accessible via le menu Outils. Vous pouvez également apporter des modifications à la taille du texte à l'aide du menu Affichage.

Voir aussi

Options du Mappeur BizTalk : Onglet Couleurs


Fonctoids de chaîne

Fonctoid Paramètres
Fonctoid Recherche de chaîne Recherche de chaîne

Renvoie la position dans une chaîne à laquelle une autre chaîne spécifiée commence.

 Ce fonctoid requiert deux paramètres d'entrée. Le premier champ relié au fonctoid est la chaîne qui détermine la position de la deuxième chaîne.
Fonctoid Chaîne de gauche Chaîne de gauche

Renvoie un nombre de caractères spécifié depuis un élément de texte, en commençant par le caractère le plus à gauche.

 Ce fonctoid requiert deux paramètres d'entrée. Le premier champ relié au fonctoid est la chaîne de caractères qui détermine la chaîne de caractères de sortie. Le deuxième champ relié au fonctoid détermine le nombre de caractères renvoyés en tant que valeur de sortie. Le résultat de la sortie est une chaîne de caractères constituant un sous-ensemble du premier champ relié au fonctoid.
Fonctoid Minuscules Minuscules

Convertit un élément de texte en caractères minuscules.

 Ce fonctoid requiert un paramètre d'entrée.
Fonctoid Chaîne de droite Chaîne de droite

Extrait un nombre de caractères spécifié d'un élément de texte, en commençant par le caractère le plus à droite.

 Ce fonctoid requiert deux paramètres d'entrée. Le premier champ relié au fonctoid est la chaîne de caractères qui détermine la chaîne de caractères de sortie. Le deuxième champ relié au fonctoid détermine le nombre de caractères renvoyés en tant que valeur de sortie. Le résultat de la sortie est une chaîne de caractères constituant un sous-ensemble du premier champ relié au fonctoid.
Fonctoid Longueur de chaîne Longueur de chaîne

Renvoie la taille d'un objet sous la forme d'un entier, à l'exception des caractères tampon.

 Ce fonctoid requiert un paramètre d'entrée. La valeur de sortie indique la taille, en caractères, des données contenues dans le champ d'entrée.
Fonctoid Extraction de chaîne Extraction de chaîne

Extrait une chaîne spécifiée par les positions de début et de fin d'une chaîne source.

 Ce fonctoid requiert trois paramètres d'entrée, l'un d'entre eux devant être une chaîne.

L'ordre dans lequel vous reliez les champs au fonctoid doit respecter les critères suivants :

  1. Champ Chaîne

  2. Champ Position de début

  3. Champ Position de fin
Fonctoid Concaténer Concaténer

Concatène une séquence de chaînes d'entrée.

 Ce fonctoid peut recevoir plusieurs paramètres d'entrée.
Fonctoid Enlever la chaîne de gauche Enlever la chaîne de gauche

Supprime les espaces à gauche d'un élément de texte.

 Ce fonctoid requiert un paramètre d'entrée.
Fonctoid Enlever la chaîne de droite Enlever la chaîne de droite

Supprime les espaces à droite d'un élément de texte.

 Ce fonctoid requiert un paramètre d'entrée.
Fonctoid Majuscules Majuscules

Convertit un élément de texte en caractères majuscules.

 Ce fonctoid requiert un paramètre d'entrée.


Fonctoids mathématiques

Fonctoid | Paramètres
Fonctoid Valeur absolue Valeur absolue Renvoie la valeur absolue d'un nombre. | Ce fonctoid requiert un paramètre d'entrée. La valeur finale est toujours positive, quelle que soit la valeur réellement introduite.
Fonctoid Entier Entier Renvoie la partie entière d'un nombre. | Ce fonctoid requiert un paramètre d'entrée. Ce fonctoid élimine la virgule d'un nombre ainsi que tous les chiffres situés à la droite de celle-ci.
Fonctoid Valeur maximale Valeur maximale Renvoie la valeur maximale d'une séquence de valeurs numériques. | Ce fonctoid requiert un ou plusieurs paramètres d'entrée.
Fonctoid Valeur minimale Valeur minimale Renvoie la valeur minimale d'une séquence de valeurs numériques. | Ce fonctoid requiert un ou plusieurs paramètres d'entrée.
Fonctoid Modulo Modulo Renvoie le reste une fois le nombre divisé par un entier. | Ce fonctoid requiert deux paramètres d'entrée. Il renvoie le reste d'une division entière. Ce fonctoid est utile, par exemple, lors de la détermination de quantités de livraison (calculs de type « charge inférieure à »).
Fonctoid Arrondi Arrondi Arrondit un nombre à un nombre spécifié de décimales ou à un nombre entier si les décimales ne sont pas indiquées. | Ce fonctoid requiert deux paramètres d'entrée. La première entrée reliée au fonctoid représente la valeur ; la seconde entrée reliée au fonctoid représente le nombre de décimales auquel vous voulez arrondir le nombre. Le fonctoid arrondit les nombres vers le haut ou vers le bas en fonction des règles de calcul standard.
Fonctoid Racine carrée Racine carrée Renvoie la racine carrée d'un nombre. | Ce fonctoid requiert un paramètre d'entrée.
Fonctoid Addition Addition Calcule la somme d'une série de nombres. | Ce fonctoid requiert un ou plusieurs paramètres d'entrée.
Fonctoid Soustraction Soustraction Soustrait un nombre d'un autre nombre. | Ce fonctoid requiert un ou plusieurs paramètres d'entrée.
Fonctoid Multiplication Multiplication Multiplie un nombre par un autre nombre. | Ce fonctoid requiert un ou plusieurs paramètres d'entrée.
Fonctoid Division Division Divise un nombre par un autre nombre. | Ce fonctoid requiert deux paramètres d'entrée. Vous pouvez utiliser ce fonctoid avec des nombres réels et des entiers.


Fonctoids logiques

Fonctoid | Paramètres
Fonctoid Supérieur à Supérieur à Renvoie la valeur TRUE si le premier paramètre est supérieur au second. | Ce fonctoid requiert deux paramètres d'entrée.
Fonctoid Supérieur ou égal à Supérieur ou égal à Renvoie la valeur TRUE si le premier paramètre est supérieur ou égal au second. | Ce fonctoid requiert deux paramètres d'entrée.
Fonctoid Inférieur à Inférieur à Renvoie la valeur TRUE si le premier paramètre est inférieur au second. | Ce fonctoid requiert deux paramètres d'entrée.
Fonctoid Inférieur ou égal à Inférieur ou égal à Renvoie la valeur TRUE si le premier paramètre est inférieur ou égal au second. | Ce fonctoid requiert deux paramètres d'entrée.
Fonctoid Égal à Égal à Renvoie la valeur TRUE si le premier paramètre est égal au second. | Ce fonctoid requiert deux paramètres d'entrée.
Fonctoid Différent de Différent de Renvoie la valeur TRUE si le premier paramètre est différent du second. | Ce fonctoid requiert deux paramètres d'entrée.
Fonctoid Chaîne logique Chaîne logique Renvoie la valeur TRUE si le paramètre est une valeur de chaîne. | Ce fonctoid requiert deux paramètres d'entrée.
Fonctoid Date logique Date logique Renvoie la valeur TRUE si le paramètre est une valeur de date. | Ce fonctoid requiert deux paramètres d'entrée.
Fonctoid Nombre logique Nombre logique Renvoie la valeur TRUE si le paramètre est une valeur numérique. | Ce fonctoid requiert deux paramètres d'entrée.
Fonctoid OR logique OR logique Renvoie l'opérateur OR logique des paramètres. | Ce fonctoid requiert un ou plusieurs paramètres d'entrée.
Fonctoid AND logique AND logique Renvoie l'opérateur AND logique des paramètres. | Ce fonctoid requiert un ou plusieurs paramètres d'entrée.


Fonctoids Date et heure

Fonctoid | Paramètres
Fonctoid Ajouter des jours Ajouter des jours Ajoute un nombre spécifié de jours à une date. | Ce fonctoid requiert deux paramètres d'entrée. La première liaison doit posséder une information de date en entrée. La deuxième liaison détermine le nombre de jours à ajouter à la date.
Fonctoid Date Date Renvoie la date en cours. | Ce fonctoid ne demande pas de paramètre en entrée. Le format de sortie est AAAA-MM-JJ.
Fonctoid Heure Heure Renvoie l'heure en cours. | Ce fonctoid ne demande pas de paramètre en entrée. Le format de sortie est HH:MM:SS.
Fonctoid Date et heure Date et heure Renvoie la date et l'heure. | Ce fonctoid ne demande pas de paramètre en entrée. Le format de sortie est AAAA-MM-JJTHH:MM:SS.


Fonctoids de conversion

Fonctoid | Paramètres
Fonctoid ASCII à partir d'un caractère ASCII à partir d'un caractère Renvoie la valeur ASCII d'un caractère donné. | Ce fonctoid requiert un paramètre d'entrée. Ce fonctoid convertit un code de valeur ASC sous-jacent. Exemple : A=97
Fonctoid Caractère à partir du code ASCII Caractère à partir du code ASCII Renvoie le caractère d'une valeur ASCII donnée. | Ce fonctoid requiert un paramètre d'entrée. Ce fonctoid convertit une valeur en son code de valeur ASC sous-jacent. Exemple : 98=B
Fonctoid Hexadécimal Hexadécimal Renvoie la valeur hexadécimale d'un nombre décimal donné. | Ce fonctoid requiert un paramètre d'entrée. Ce fonctoid convertit un nombre décimal en un nombre hexadécimal. Par exemple, 10=A.
Fonctoid Octal Octal Renvoie la valeur octale d'un nombre décimal donné. | Ce fonctoid requiert un paramètre d'entrée. Ce fonctoid convertit un nombre décimal en un nombre octal. Exemple : (Octal 0-7), 8=10 et 10=12


Fonctoids scientifiques

Fonctoid | Paramètres
Fonctoid Arc tangente Arc tangente Renvoie l'arc tangente d'un nombre. | Ce fonctoid requiert un paramètre d'entrée. La valeur d'entrée doit être exprimée en radians.
Fonctoid Cosinus Cosinus Renvoie le cosinus d'un nombre. | Ce fonctoid requiert un paramètre d'entrée. La valeur d'entrée doit être exprimée en radians.
Fonctoid Sinus Sinus Renvoie le sinus d'un nombre. | Ce fonctoid requiert un paramètre d'entrée. La valeur d'entrée doit être exprimée en radians.
Fonctoid Tangente Tangente Renvoie la tangente d'un nombre. | Ce fonctoid requiert un paramètre d'entrée. La valeur d'entrée doit être exprimée en radians.
Fonctoid Fonction exponentielle naturelle Fonction exponentielle naturelle Renvoie e élevé à une puissance donnée. | Ce fonctoid requiert un paramètre d'entrée.
Fonctoid Logarithme naturel Logarithme naturel Renvoie le logarithme (base e) d'une valeur. | Ce fonctoid requiert un paramètre d'entrée.
10^X Renvoie 10 élevé à une puissance donnée. | Ce fonctoid requiert un paramètre d'entrée.
Fonctoid Logarithme commun Logarithme commun Renvoie le logarithme (base 10) d'une valeur. | Ce fonctoid requiert un paramètre d'entrée.
X^Y Renvoie une valeur élevée à une puissance donnée. | Ce fonctoid requiert deux paramètres d'entrée.
Fonctoid Logarithme spécifié à partir de la base Logarithme spécifié à partir de la base Renvoie le logarithme (spécifié à partir d'une base) d'une valeur. | Ce fonctoid requiert deux paramètres d'entrée.


Fonctoids cumulés

Fonctoid | Paramètres
Fonctoid Somme cumulée Somme cumulée Totalise toutes les valeurs du champ connecté en effectuant une itération sur son enregistrement parent. | Ce fonctoid requiert un paramètre d'entrée.
Fonctoid Moyenne cumulée Moyenne cumulée Calcule la moyenne de toutes les valeurs du champ connecté en effectuant une itération sur son enregistrement parent. | Ce fonctoid requiert un paramètre d'entrée.
Fonctoid Minimum cumulé Minimum cumulé Renvoie la valeur minimale des entrées réparties sur l'enregistrement parent. | Ce fonctoid requiert un paramètre d'entrée.
Fonctoid Maximum cumulé Maximum cumulé Renvoie la valeur maximale des entrées réparties sur l'enregistrement parent. | Ce fonctoid requiert un paramètre d'entrée.
Fonctoid Chaîne cumulée Chaîne cumulée Renvoie la chaîne concaténée des valeurs de chaîne pour le champ connecté en effectuant une itération sur son enregistrement parent. | Ce fonctoid requiert un paramètre d'entrée.


Fonctoids de base de données

Fonctoid | Paramètres
Fonctoid Recherche dans la base de données Recherche dans la base de données Recherche une valeur spécifique dans une base de données, extrait l'enregistrement contenant la valeur, puis stocke ce dernier comme un jeu d'enregistrements ADO. | Ce fonctoid doit posséder exactement quatre paramètres d'entrée.
Fonctoid Extracteur de valeur Extracteur de valeur Renvoie une valeur d'une colonne spécifiée dans un jeu d'enregistrements ADO qui a été extrait par le fonctoid Recherche dans la base de données. | Ce fonctoid doit posséder exactement deux paramètres d'entrée.
Fonctoid Retour d'erreur Retour d'erreur Renvoie, le cas échéant, une chaîne d'erreur retournée par ODBC lors de l'utilisation du fonctoid Recherche dans la base de données. | Ce fonctoid doit posséder exactement un paramètre d'entrée.


Fonctoids avancés

Fonctoid | Paramètres
Fonctoid Script Script Script Visual Basic personnalisé. | Le nombre de paramètres d'entrée de ce fonctoid est configurable en fonction d'un script personnalisé.
Fonctoid Nombre d'enregistrements Nombre d'enregistrements Renvoie le nombre total des enregistrements trouvés dans l'instance. | Ce fonctoid doit posséder un paramètre d'entrée.
Fonctoid Index Index Renvoie la valeur d'un enregistrement ou d'un champ à l'index spécifié. | Ce fonctoid doit posséder au moins deux paramètres d'entrée. Le nombre maximal de paramètres d'entrée est limité par le nombre de niveaux dans la hiérarchie de spécification.
Fonctoid Itération Itération Renvoie le numéro d'itération (dans une boucle) de l'enregistrement source. | Ce fonctoid doit posséder un paramètre d'entrée.
Fonctoid Mappage de valeurs Mappage de valeurs Renvoie la valeur du second paramètre si la valeur du premier paramètre est TRUE. | Ce fonctoid doit posséder deux paramètres d'entrée.
Fonctoid Mappage de valeurs(mise à plat) Mappage de valeurs (mise à plat) Renvoie la valeur du second paramètre si celle du premier paramètre est TRUE et aplatit la hiérarchie des documents source. | Ce fonctoid doit posséder deux paramètres d'entrée.
Fonctoid Bouclage Bouclage Crée plusieurs enregistrements de sortie en effectuant une itération sur chaque enregistrement d'entrée. | Ce fonctoid doit posséder au moins un paramètre d'entrée. Il n'y a aucune limite maximale quant au nombre de paramètres d'entrée.


Mappages pour l'intégration des services BizTalk

Lors de l'intégration des services d'orchestration BizTalk et des services d'échanges BizTalk à l'aide d'un transport non-HTTP, vous devrez peut-être créer un mappage pour convertir un nom de chemin d'accès en un nom de format. Pour plus d'informations, voir Intégration des services BizTalk.

Conversion d'un nom de chemin d'accès en un nom de format

Le code suivant est un exemple de nom de chemin d'accès de file d'attente d'échanges :

private$\sourcechannel2{9e0016bf-be1f-48fe-82de-b27077ab5e73}

Pour convertir ce nom de chemin d'accès en un nom de format, vous devez ajouter la chaîne suivante au début du nom du chemin d'accès :

queue://Direct=OS:

Vous pouvez effectuer aisément cette opération à l'aide du fonctoid Concaténer.

L'illustration ci-dessous montre un mappage qui utilise le fonctoid Concaténer, qui permet de concaténer deux ou plusieurs chaînes. Pour plus d'informations sur le fonctoid Concaténer, voir Fonctoids de chaîne.

Cliquez sur l'image pour l'agrandir ou la réduire.

Nom du chemin d'accès vers le nom de format

Double-cliquez sur le fonctoid Concaténer pour afficher ses propriétés. L'illustration ci-dessous montre les propriétés d'un fonctoid Concaténer dans un mappage qui ajoute le préfixe queue://Direct=OS: au nom de chemin d'accès private$\sourcechannel2{9e0016bf-be1f-48fe-82de-b27077ab5e73}.

Pour plus d'informations, voir Modification des propriétés des fonctoids.

Cliquez sur l'image pour l'agrandir ou la réduire.

Propriétés du fonctoid Concaténer


Dépannage de l'Éditeur BizTalk et du Mappeur BizTalk

Cette section contient des informations sur les rubriques suivantes :

  • Mot de passe requis lors de la tentative de connexion à un serveur WebDAV distant

  • Échec de la connexion au référentiel WebDAV ou du stockage de fichiers sur le référentiel WebDAV

  • ???.xml apparaît dans la boîte de dialogue WebDAV

  • Le dossier BizTalkServerRepositoryMaps apparaît dans la boîte de dialogue Extraire à partir de WebDAV

  • La boîte de dialogue Extraire à partir de WebDAV ou Stocker dans WebDAV est vide

  • Échec de connexion à http://localhost

  • Analyse incomplète du fichier plat soumis à BizTalk Server

  • Espace non conservé dans le fichier plat soumis à BizTalk Server

  • Échec du test du mappage

  • Échec de l'importation DTD

  • Échec de validation d'instance lors de l'utilisation du champ Date ou Heure


Mot de passe requis lors de la tentative de connexion à un serveur WebDAV distant

Cause : Il se peut que l'utilisateur n'ait pas accès au dossier BizTalkServerRepository.

Solution : Autorisez l'utilisateur à accéder au dossier BizTalkServerRepository. Pour cela :

  1. Cliquez sur Démarrer, pointez sur Programmes et Outils d'administration, puis cliquez sur Gestionnaire des services Internet.

  2. Dans l'arborescence de la console, développez le nom de l'ordinateur.

  3. Développez Site Web par défaut.

  4. Cliquez avec le bouton droit sur BizTalkServerRepository, puis cliquez sur Propriétés.

  5. Cliquez sur l'onglet Sécurité du répertoire.

  6. Dans la zone Connexions anonymes et contrôle d'authentification, cliquez sur Modifier.

  7. Activez la case à cocher Connexions anonymes et cliquez deux fois sur OK.


Échec de la connexion au référentiel WebDAV ou du stockage de fichiers sur le référentiel WebDAV

Première cause : Si vous essayez de récupérer un mappage ou une spécification à partir de WebDAV, ou encore d'enregistrer un mappage ou une spécification dans WebDAV, vous pouvez voir apparaître un des messages suivants :

Le fichier ne peut pas être stocké dans le référentiel WebDAV. Le serveur peut ne pas être disponible à ce moment.

Aucune clé correspondant aux caractéristiques décrites n'a été trouvée dans la plage en cours.

Cela se produit lorsque le paramètre anonyme du compte utilisateur sur le serveur Web ne possède pas de privilèges en écriture dans le répertoire Microsoft Windows 2000 qui héberge le référentiel.

Solution : Autorisez l'utilisateur à accéder au référentiel. Pour cela :

  1. Cliquez sur Démarrer, pointez sur Programmes et sur Accessoires, puis cliquez sur Explorateur Windows.

  2. Allez à l'endroit où vous avez installé Microsoft BizTalk Server 2000.

  3. Développez le répertoire Microsoft BizTalk Server, cliquez avec le bouton droit sur BizTalkServerRepository, puis cliquez sur Propriétés.

  4. Cliquez sur l'onglet Sécurité.

  5. Cliquez sur Ajouter et tapez le nom de domaine et le nom d'utilisateur de la personne à laquelle vous voulez permettre d'accéder au référentiel dans le format suivant : nom de domaine\nom d'utilisateur.

  6. Cliquez deux fois sur OK.

Deuxième cause : Si vous essayez de récupérer un mappage ou une spécification à partir de WebDAV, ou bien de stocker un mappage ou une spécification dans WebDAV, vous pouvez voir apparaître un des messages suivants :

Aucun emplacement de stockage pour BizTalk Server n'a été trouvé sur http://localhost/BizTalkServerRepository/DocSpecs. Tapez un autre nom de serveur pour vous reconnecter au référentiel WebDAV.

Cela se produit lorsque les extensions FrontPage Server sont activées sur le serveur Web.

Solution : Désactivez les extensions FrontPage Server. Si le service de publication Web fonctionne, arrêtez et redémarrez ce service.

Remarque

  • Ce problème peut survenir même si le service de publication Web ne fonctionne pas sur l'ordinateur hébergeant le référentiel WebDAV.

Pour désactiver les extensions FrontPage Server

  1. Cliquez sur Démarrer, pointez sur Programmes et Outils d'administration, puis cliquez sur Gestionnaire des services Internet.

  2. Dans le volet de détails, double-cliquez sur <nom de l'ordinateur>, cliquez avec le bouton droit sur Site Web par défaut, puis cliquez sur Propriétés.

    La boîte de dialogue Propriétés du site Web par défaut apparaît.

  3. Dans l'onglet Extensions serveur, désactivez la case à cocher Activer les opérations d'auteur, puis cliquez sur OK.

Pour arrêter et redémarrer le service de publication Web

  1. Cliquez sur Démarrer, pointez sur Programmes et Outils d'administration, puis cliquez sur Services de composants.

  2. Dans l'arborescence de la console, cliquez sur Services (local).

  3. Dans le volet de détails, cliquez avec le bouton droit sur Service de publication Web, puis cliquez sur Arrêter.

  4. Cliquez avec le bouton droit sur Service de publication Web, puis cliquez sur Démarrer.


???.xml apparaît dans la boîte de dialogue WebDAV

Cause : Le jeu de caractères affiché pour votre ordinateur dépend des paramètres locaux spécifiés dans BizTalk Server.

Solution : Spécifiez le même jeu de caractères pour votre ordinateur que celui qui est défini dans les paramètres locaux de BizTalk Server. Pour cela :

  1. Cliquez sur Démarrer, pointez sur Paramètres, puis cliquez sur Panneau de configuration.

  2. Double-cliquez sur Options régionales.

  3. Dans l'onglet Général, dans la zone Paramètres de langue pour le système, activez la case à cocher correspondant à la langue souhaitée et cliquez sur Définir par défaut.

    La boîte de dialogue Sélection des paramètres régionaux système apparaît.

  4. Cliquez sur les paramètres régionaux souhaités dans la liste et cliquez deux fois sur OK.

    La boîte de dialogue Modification des options régionales s'affiche.

  5. Cliquez sur Oui pour accepter les modifications et redémarrez votre ordinateur.

Remarque

  • Après le redémarrage de votre ordinateur, la boîte de dialogue Options régionales affiche la langue sélectionnée : Langue (valeur par défaut).

Voir aussi

Stockage de mappages

Stockage de spécifications


Le dossier BizTalkServerRepositoryMaps apparaît dans la boîte de dialogue Extraire à partir de WebDAV

Cause : Une barre oblique inverse à droite se trouve dans la zone Chemin local de la boîte de dialogue Propriétés de BizTalkServerRepository.

Solution : Supprimez la barre oblique inverse à droite dans la zone Chemin local de la boîte de dialogue Propriétés de BizTalkServerRepository. Pour cela :

  1. Dans le menu Démarrer, pointez sur Programmes, puis sur Outils administratifs et sélectionnez Computer Management.

  2. Dans la console Gestion de l'ordinateur, développez successivement Services et applications, Internet Information Services et Site Web par défaut.

  3. Cliquez avec le bouton droit sur BizTalkServerRepository, puis cliquez sur Propriétés.

  4. Dans la zone Chemin local de la boîte de dialogue Propriétés de BizTalkServerRepository, supprimez la barre oblique inverse à droite et cliquez sur OK.

Cette procédure supprime le dossier BizTalkServerRepositoryMaps de la boîte de dialogue Extraire à partir de WebDAV. Ce dossier étant devenu inutilisable, il est préférable de le supprimer.


La boîte de dialogue Extraire à partir de WebDAV ou Stocker dans WebDAV est vide

Cause : L'exploration des répertoires est désactivée dans la boîte de dialogue Propriétés de BizTalkServerRepository.

Solution : Activez l'exploration des répertoires dans la boîte de dialogue Propriétés de BizTalkServerRepository. Pour cela :

  1. Cliquez sur Démarrer, pointez sur Programmes et Outils d'administration, puis cliquez sur Gestionnaire des services Internet.

  2. Développez l'ordinateur concerné.

  3. Développez Site Web par défaut.

  4. Cliquez avec le bouton droit sur BizTalkServerRepository, puis cliquez sur Propriétés.

  5. Dans l'onglet Répertoire virtuel, sélectionnez Recherche dans les répertoires.

  6. Assurez-vous que Lire et Écrire sont également sélectionnés, puis cliquez sur OK.


Échec de connexion à http://localhost

Cause : La case à cocher Utiliser un serveur proxy est activée, mais pas la case à cocher Ne pas utiliser de serveur proxy pour les adresses locales.

Solution : Conservez l'option Utiliser un serveur proxy et activez l'option Ne pas utiliser de serveur proxy pour les adresses locales. Pour cela :

  1. Cliquez sur Démarrer, pointez sur Programmes, puis cliquez sur Internet Explorer.

  2. Dans le menu Outils, cliquez sur Options Internet.

  3. Cliquez sur l'onglet Connexions, puis sur Paramètres LAN.

  4. Dans la zone Serveur proxy de la boîte de dialogue Paramètres du réseau local (LAN), activez la case à cocher Ne pas utiliser de serveur proxy pour les adresses locales.

  5. Cliquez deux fois sur OK.

Remarque

  • Ce problème ne se produit pas si vous vous connectez à http://<nom de l'ordinateur>.


Analyse incomplète du fichier plat soumis à BizTalk Server

Cause : Il se peut qu'un flat-file délimité (fichier plat) comporte une erreur d'analyse lorsqu'il est soumis à BizTalk Server, s'il possède les caractéristiques suivantes :

  • La propriété Ordre des champs du noeud racine est définie sur Préfixe ou Suffixe.

  • Le nom du noeud racine est une sous-chaîne du nom d'un autre noeud du fichier.

Solution : Renommez le noeud racine de telle sorte que son nom ne soit pas une sous-chaîne du nom d'un autre noeud dans la spécification.


Espace non conservé dans le fichier plat soumis à BizTalk Server

Cause : Lorsqu'un fichier plat est soumis à BizTalk Server, il se peut que l'espace présent dans les champs ait été supprimé. En effet, le parseur MSXML sous-jacent ne conserve pas par défaut l'espace dans un champ dont la propriété Type (onglet Déclaration) est définie sur Élément.

Solution : S'il est important de conserver l'espace dans un champ contenu dans un fichier plat, dans l'Éditeur BizTalk veillez à définir la propriété Type de l'onglet Déclaration du champ dans la spécification source sur Attribut.

Voir aussi

Définition des propriétés de déclaration


Échec du test du mappage

Cause : Lorsque vous testez un mappage, le Mappeur BizTalk le compile avant de le tester. Si un avertissement se produit pendant la compilation, il se peut que le test du mappage ait échoué. Le message d'erreur suivant s'affiche :

Échec de la transformation XSL (Extensible Stylesheet Language) effectuée à l'aide du document d'instance de test pour la spécification source.

Solution : Résolvez tous les avertissements du compilateur, puis recompilez le mappage. Pour résoudre un avertissement du compilateur, effectuez les opérations suivantes :

  1. Double-cliquez sur Avertissement dans l'onglet Sortie. La liaison ou le fonctoid associé au message d'avertissement s'affiche en surbrillance.

  2. Résolvez l'avertissement.

Pour recompiler le mappage :

  • Dans le menu Outils, cliquez sur Compiler le fichier de mappage.

Voir aussi

Test de mappages


Échec de l'importation DTD

Cause : Si vous essayez d'importer une définition de type de document (DTD) contenant une référence externe vers un autre fichier, il se peut que le message suivant apparaisse :

Caractère non valide dans DTD.

Solution : Supprimez toute référence externe dans une DTD avant d'essayer de l'importer.


Échec de validation d'instance lors de l'utilisation du champ Date ou Heure

Cause : Lorsque BizTalk Server traite une instance de document entrant, s'il existe une liaison depuis un fonctoid ou un champ source vers un noeud de destination dont la propriété Type de données est définie sur Date, Date Time, Date Time.tz, Time ou Time.tz, la validation d'instance échoue si les données entrant dans le noeud de destination sont dans un format autre que le format ISO 8601.

Solution : En cas de liaison vers un champ d'une spécification de destination dont la propriété Type de données est définie sur Date, Date Time, Date Time.tz, Time ou Time.tz, assurez-vous que les données reliées à ce champ (qu'elles proviennent d'un fonctoid ou d'un noeud d'une instance de document entrant) sont dans le format ISO 8601. Le tableau suivant illustre le format ISO 8601 correct pour chaque valeur possible de la propriété Type de données.

Propriété Type de données | Format ISO 8601
Date | YYYY-MM-DD (1988-04-07)
Date Time | YYYY-MM-DDTHH:MM:SS (1988-04-07T18:39:09)
Date Time.tz | YYYY-MM-DDTHH:MM:SS-TZH:TZM (1988-04-07T18:39:09-08:00)
Time | HH:MM:SS (08:15:27)
Time.tz | HH:MM:SS-TZH:TZM (08:15:27-05:00)


Intégration des services BizTalk

L'intégration des services d'Orchestration BizTalk et des services d'Échanges BizTalk vous permet de contrôler les échanges de documents et de messages entre vos partenaires commerciaux et les applications internes à votre entreprise qui utilisent plusieurs services de transport. Les fonctionnalités suivantes sont également fournies :

  • Contrôle des transactions complexes de longue durée et des processus professionnels.

  • Livraison fiable de documents et de messages.

  • Validation des données assurée par le contrôle de chaque instance de document par rapport à une spécification.

  • Mappage des données assuré par des mappages pour transformer la structure et le format des documents.

  • Sécurité et intégrité des données assurées par des certificats de cryptage et de signature numérique.

  • Prise en charge de la génération et de la corrélation des accusés de réception.

Cette section décrit un scénario commun, parmi les multiples scénarios existants, qui intègre les services d'Orchestration BizTalk et les services d'Échanges BizTalk.

Dans ce scénario, vous configurez une instance de planification XLANG sur le système source afin d'initier et d'envoyer un message à un système de destination d'un partenaire commercial, puis attendez de celui-ci un message de retour que vous transmettez à l'instance de planification XLANG à l'origine du message. Par exemple, vous pouvez appliquer cette configuration à des processus professionnels très courants, tels que l'envoi d'un d'ordre d'achat et l'attente de son accusé de réception avant de poursuivre le processus.

Les rubriques de cette section décrivent les étapes de configuration requises pour échanger des messages entre votre entreprise et un partenaire commercial à l'aide de types de transport HTTP et non-HTTP. Vous pouvez néanmoins utiliser une configuration similaire pour superviser les échanges de messages entre les applications internes à votre entreprise.

Comme BizTalk Server 2000 peut être utilisé en tant que système source qui envoie le message initial ou en tant que système de destination qui envoie le message de retour, cette section développe les étapes de configuration nécessaires dans ces deux cas de figure. Elle vous permet également de visualiser la configuration globale requise.

Pour obtenir des exemples de planifications XLANG qui reflètent ces configurations ainsi que d'autres fichiers associés, accédez au dossier \Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\Integrating BizTalk Services.

Remarques

  • Le terme port d'échanges, utilisé dans les services d'Échanges BizTalk, et le terme port, utilisé dans les services d'Orchestration BizTalk, ont une signification totalement différente.
    • Un port d'échanges est un ensemble de propriétés qui définit les services d'Échanges BizTalk en vue du transport de documents vers une destination donnée à l'aide d'un service de transport spécifié.

    • Un port est un emplacement nommé qui utilise une implémentation spécifique. Dans une planification XLANG, les ports facilitent les communications synchrones et asynchrones et permettent de transférer les messages dans la planification ou hors de celle-ci.
  • Les événements Action associés aux messages traités par une planification XLANG et qui sont soit envoyés, soit reçus des services d'échanges BizTalk, peuvent être tracés dans la base de données Suivi. Pour plus d'informations, voir Suivi des événements de planification XLANG dans la base de données de suivi.

Cette section traite des rubriques suivantes :

  • Utilisation d'un type de transport HTTP

  • Utilisation d'un type de transport non-HTTP

Voir aussi

Services BizTalk

Gestion des instances


Utilisation d'un type de transport HTTP

Cette section explique comment intégrer et configurer les Services d'Orchestration BizTalk et les Services d'Échanges BizTalk pour le système source et le système de destination afin que :

  • le système source génère et envoie un message au système de destination d'un partenaire commercial en utilisant une instance de planification XLANG spécifique ;

  • le système de destination envoie un message de retour à l'aide d'un type de transport http ;

  • le système source reçoive le message de retour et l'achemine vers l'instance de planification XLANG qui a généré et envoyé le message initial.

Pour configurer les deux systèmes afin de permettre au système de destination d'utiliser un type de transport non-HTTP en vue de l'envoi des messages de retour, voir Utilisation d'un type de transport non-HTTP.

Cette section traite des rubriques suivantes :

  • Configuration du système source pour utiliser un type de transport HTTP

  • Configuration du système de destination pour utiliser un type de transport HTTP


Configuration du système source pour utiliser un type de transport HTTP

Les étapes de cette procédure décrivent la configuration du système source permettant de générer et d'envoyer un message contenant une URL http de réponse. Le système de destination du partenaire commercial utilise l'adresse de réponse contenue dans le message initial pour envoyer un message de retour à une page ASP sur le site Web du système source à l'aide d'un type de transport HTTP. Pour configurer le système source et permettre au système de destination d'utiliser un type de transport non-HTTP en vue de l'envoi des messages de retour, voir Configuration du système source pour utiliser un type de transport non-HTTP. Les étapes de configuration nécessaires à l'utilisation d'un type de transport HTTPS sont développées ultérieurement dans cette rubrique.

L'URL http utilisée comme adresse de réponse dans la configuration est générée par la planification XLANG à partir des données des propriétés du port. Elle est composée des éléments suivants :

  • L'adresse d'une page ASP (Active Server Pages) sur le site Web du système source à laquelle un message de retour est envoyé.

  • Une chaîne de requête contenant le nom du canal, dans les services d'Échanges BizTalk, pour le système source utilisé pour traiter le message de retour, et le chemin complet d'une file d'attente par instance, créée par l'instance de planification XLANG et à laquelle est transmis le message de retour.

L'adresse suivante est un exemple d'URL http de réponse :

http://hostname/receiveresponse.asp?channel=ChannelForReply&qpath=hostname.domain.corp.vigorair-18.com\private$\sendingchannel2{9e0016bf-be1f-48fe-82de-b27077ab5e73}

Lorsque la page ASP du système source reçoit le message de retour, son script exécute les étapes suivantes.

  • Extraction du nom du canal et des informations sur le chemin d'accès de la file d'attente à partir de la chaîne de requête.

  • Conversion du nom du chemin d'accès de la file d'attente en nom de format et insertion du préfixe de file d'attente (://) requis par les services d'Échanges BizTalk.

  • Envoi du message de retour aux services d'Échanges BizTalk du système source qui utilise le nom de canal et les informations sur le chemin d'accès de la file d'attente comme paramètres d'envoi. Pour plus d'informations sur l'envoi de documents, voir Envoi.

Les services d'Échanges BizTalk du système source utilisent le canal spécifié pour traiter le message de retour et le port d'échanges associé, qui fait appel au chemin d'accès de la file d'attente pour transférer le message de retour vers l'instance de planification XLANG en cours d'exécution qui a généré le message initial.

Afin que la configuration du système source fonctionne correctement, le système de destination du partenaire commercial doit également être correctement configuré. Pour plus d'informations sur la configuration du système de destination, voir Configuration du système de destination pour utiliser un type de transport HTTP.

Pour configurer le système source afin d'utiliser un type de transport HTTP, exécutez les étapes décrites dans le tableau suivant. Des références sont fournies pour chaque procédure et des remarques commentent les configurations particulières. Les autres paramètres de propriété nécessaires à la configuration varient selon les entreprises et ne sont donc pas mentionnés ici.

Étape Références et remarques
Utilisation de l'Éditeur BizTalk
  • Créez les spécifications nécessaires aux définitions des documents entrants et sortants du canal qui traitera le message initial.
  • Création et validation de spécifications

    Remarques

    • Vous devez ajouter un champ dans chacune de ces spécifications pour l'adresse de réponse. Vous pouvez ajouter ce champ à n'importe quel niveau ; toutefois, l'emplacement doit être convenu avec le partenaire commercial et doit correspondre aux spécifications existantes sur le système de destination de votre partenaire commercial. Pour plus d'informations, voir Gestion d'enregistrements et de champs.
  • Créez les spécifications pour les définitions des documents entrants et sortants du canal qui traitera le message de retour.
  • Création et validation de spécifications

    Remarque

    • Ces spécifications ne requièrent pas de configuration spéciale.
Utilisation du Gestionnaire d'échanges BizTalk :
  • Créez une organisation représentant le partenaire commercial avec le système de destination.
  • Création d'organisations

    Remarque

    • Cette organisation ne nécessite pas de configuration spéciale.
  • Créez les définitions de document nécessaires à la création du canal que vous utilisez pour traiter le message initial.
  • Création de définitions de documents

    Remarque

    • Dans les définitions de document, sélectionnez les spécifications comportant un champ de réponse. Pour plus d'informations, voir Sélection d'une spécification de document.
  • Créez les définitions de document nécessaires à la création du canal que vous utiliserez pour traiter le message de retour.
  • Création de définitions de documents

    Remarque

    • Ces définitions de document ne requièrent pas de configuration spéciale.
  • Créez un port d'échanges pour une organisation afin de transmettre le message initial au système de destination.
  • Création de ports d'échanges

    Remarque

    • Il ne peut pas s'agir d'un port d'échanges ouvert.
  • Créez un canal à partir d'une application pour traiter le message sortant de la planification XLANG.
  • Création de canaux

    Remarques

    • Sur la page Application source de l'Assistant Canal, cliquez sur Planification XLANG. Pour plus d'informations, voir Définition des propriétés d'une application source.

    • Notez le nom du canal et le nom de la définition du document entrant que vous utilisez. Ces noms sont utilisés pour configurer les services d'Orchestration BizTalk.
  • Créez un port d'échanges dans une application pour transférer le message de retour vers l'instance de planification XLANG active qui a généré le message sortant.
  • Création de ports d'échanges

    Remarque

    • Sur la page Application de destination de l'Assistant Port d'échanges, cliquez sur Exécution de la planification XLANG en cours. Pour plus d'informations, voir Définition des propriétés de l'application de destination.
  • Créez un canal à partir d'une organisation pour traiter le message de retour du système de destination.
  • Création de canaux

    Remarque

    • Notez le nom du canal et le nom de la définition du document sortant que vous utilisez. Ces noms sont utilisés pour configurer les services d'Orchestration BizTalk.
Utilisation du Concepteur d'Orchestration BizTalk
  • Utilisez une forme Échanges BizTalk afin de mettre en oeuvre un port qui permette l'envoi du message initial.
  • Implémentation d'un port à l'aide d'Échanges BizTalk

    Remarque

    • Dans la page Informations sur le canal statique ou dynamique de l'Assistant Liaison d'Échanges BizTalk, cliquez sur Canal statique et dans la zone Entrez le nom d'un canal connu pré-existant, tapez le nom du canal dans le Gestionnaire d'échanges BizTalk que vous utilisez pour traiter le message initial.
  • Créez le flux de communication entre la forme Action et le port qui envoie le message initial.
  • Envoi ou réception de messages asynchrones

    Remarques

    • Sur la page Informations sur le message de l'Assistant Communication XML, cliquez sur Créer un message et dans la zone Nom du message, tapez un nom pour le message.

      Vous pouvez utiliser n'importe quel nom ; toutefois, l'utilisation du nom de la définition du document entrant pour le canal permet de voir plus facilement quel message est envoyé.

    • Dans la zone Type du message de la page Informations sur les types de messages, tapez le nom de la définition du document entrant du canal que vous utilisez pour traiter le message.

    • Sur la page Informations sur la spécification du message, cliquez sur Parcourir et sélectionnez la spécification utilisée dans la définition du document entrant du canal qui a traité le message initial.

    • Dans la zone Champs de message de la page Informations sur la spécification du message, cliquez sur Ajouter, puis ajoutez le champ à la spécification créée pour contenir l'adresse de réponse dans le message initial.
  • Utilisez une forme Échanges BizTalk afin de mettre en oeuvre un port permettant la réception d'un message de retour.
  • Implémentation d'un port à l'aide d'Échanges BizTalk

    Remarque

    • Sur la page Informations sur l'activation de la planification XLANG de l'Assistant Liaison d'Échanges BizTalk, cliquez sur Non.

    • Dans la zone Nom du canal de la page Informations sur le canal, tapez le nom du canal du Gestionnaire d'échanges BizTalk utilisé pour traiter le message de retour.

      Le Concepteur d'Orchestration BizTalk utilise le nom du canal et un identificateur unique universel (GUID) pour créer et affecter un nom à une file d'attente par instance à laquelle le message de retour est transmis.

    • Dans la zone Adresse de l'URL http dans laquelle le service d'Échanges BizTalk reçoit les documents de la page Informations sur le canal, tapez l'adresse de la page ASP vers laquelle le partenaire commercial peut envoyer un message de retour.

      Le Concepteur d'Orchestration BizTalk utilise l'adresse et le nom du canal, précédemment tapés, pour créer une adresse d'URL http avec une chaîne de requête qui intègre le nom du canal et le chemin d'accès de la file d'attente par instance.
  • Créez le flux de communication entre la forme Action et le port qui reçoit le message de retour.
  • Envoi ou réception de messages asynchrones

    Remarques

    • Sur la page Informations sur le message de l'Assistant Communication XML, cliquez sur Créer un message et dans la zone Nom du message, tapez un nom pour le message.

      Vous pouvez utiliser n'importe quel nom ; toutefois, l'utilisation du nom de la définition du document sortant pour le canal permet de voir plus facilement quel message est reçu.

    • Dans la zone Type du message de la page Informations sur les types de messages, tapez le nom de la définition du document sortant du canal que vous utilisez pour traiter le message de retour.

      Tous les messages transmis à partir des services d'Échanges BizTalk à une instance de planification XLANG sont envoyés dans une file d'attente de messages. L'étiquette de ces messages correspond au nom de la définition du document sortant du canal.
  • Créez le flux de données pour transférer les données de référence de port dans le champ de l'adresse de réponse.
  • Dessin de flux entre les messages

    Remarques

    • Cliquez sur l'onglet Données.

    • Sur la page Données, dans le message Port References, sélectionnez les références du port qui recevra le message de retour. Ensuite, faites glisser sa poignée de contrôle vers le point de connexion du champ de l'adresse de réponse dans le message initial.

      Ainsi, les références du port sont transférées dans le champ de l'adresse de réponse du message sortant initial. Les références du port correspondent à une adresse d'URL http d'une page ASP, qui intègre une chaîne de requête au nom du canal et au chemin d'accès de la file d'attente par instance du port.
Utilisation de la page ASP
  • Utilisez la page ASP fournie en exemple avec BizTalk Server 2000 ou configurez-en une basée sur un script identique.
 Remarques
  • Pour utiliser la page ASP d'exemple, allez dans \Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\ReceiveScripts sur le disque d'installation et sélectionnez le fichier ReceiveResponse.asp. Ensuite, copiez ce fichier dans le dossier approprié sur le site Web du système source.

  • Lorsque la page d'exemple ASP reçoit un message de retour, son script extrait le nom du canal et le chemin d'accès de la file d'attente de la chaîne de requête dans l'adresse de l'en-tête HTTP. La page ASP convertit également le nom du chemin d'accès de la file d'attente en nom de format et insère le préfixe de file ://. La page utilise ensuite ces données comme paramètres d'envoi du message de retour vers les services d'Échanges BizTalk sur le système source. Pour plus d'informations sur l'envoi de documents, voir Envoi.

Utilisation d'un type de transport HTTPS sécurisé.

Si vos processus professionnels nécessitent un mode de transport sécurisé pour échanger des messages avec un partenaire commercial, vous devez utiliser un type de transport HTTPS.

Pour ce faire, dans la configuration du système source, vous devez uniquement modifier l'adresse de l'URL du port qui recevra le message de retour.

Lorsque vous implémentez le port qui reçoit le message de retour, l'URL tapée pour l'adresse de réponse doit utiliser un préfixe HTTPS et non pas un préfixe HTTP.

L'adresse suivante est un exemple d'adresse de réponse qui utilise le préfixe HTTPS.

https://hostname/receiveresponse.asp?channel=ChannelForReply&qpath=hostname.domain.corp.vigorair-18.com\private$\sendingchannel2{9e0016bf-be1f-48fe-82de-b27077ab5e73}

Le système de destination ne requiert aucune modification de configuration supplémentaire.

Voir aussi

Configuration du système de destination pour intégrer les services BizTalk

Intégration des services BizTalk


Configuration du système de destination pour utiliser un type de transport HTTP

Les étapes de cette rubrique décrivent comment configurer le système de destination afin de recevoir un message contenant une URL http de réponse et d'envoyer un message de retour au système source via un type de transport HTTP. Si vous voulez configurer le système de destination pour utiliser un type de transport non-HTTP afin d'envoyer des messages de retour, voir Configuration du système de destination pour utiliser un type de transport non-HTTP. Les étapes de configuration nécessaires afin d'utiliser un type de transport HTTPS sont développées ultérieurement dans cette rubrique.

Lorsque les services d'Échanges BizTalk du système de destination reçoivent le message initial, ils sont configurés pour activer une nouvelle instance d'une planification XLANG spécifiée et envoyer le message vers un port spécifié dans cette instance de planification XLANG.

La planification XLANG est configurée pour transférer les données de l'adresse de réponse, contenues dans un champ du message initial, vers un champ de référence de port pour le port utilisé pour envoyer le message de retour. La planification XLANG envoie ensuite le message de retour vers les services d'Échanges BizTalk à l'aide de l'option Canal dynamique.

L'option Canal dynamique permet de transférer les données de port spécifiques en tant que paramètres d'envoi lors de l'envoi du message vers les services d'Échanges BizTalk. Les données de référence de port, dans ce cas l'adresse de réponse, sont transférées en tant que paramètres d'identification de la destination, et le Type de message pour le port est transmis en tant que paramètre du nom de définition de document. Pour plus d'informations sur les paramètres d'envoi, voir Envoi. Les paramètres d'envoi permettent aux services d'Échanges BizTalk d'identifier un canal spécifique pour traiter le message de retour. Pour plus d'informations, voir Identification.

Si vous activez l'option Canal dynamique, le canal des services d'Échanges BizTalk doit être associé à un port d'échanges ouvert. Le port d'échanges ouvert transfère le message de retour vers le système source du partenaire commercial à l'aide de l'adresse de réponse, qui est utilisée comme paramètre d'identification de la destination. L'utilisation du transport http découle de l'URL http de la page ASP dans le système source. Pour plus d'informations sur les ports d'échanges ouverts, voir Ports d'échanges ouverts.

Afin que la configuration du système de destination fonctionne correctement, le système source du partenaire commercial doit également être correctement configuré. Pour plus d'informations sur la configuration du système source, voir Configuration du système source pour utiliser un type de transport HTTP.

Pour configurer le système de destination afin d'utiliser un type de transport HTTP, exécutez les étapes décrites dans le tableau suivant. Des références sont fournies pour chaque procédure et des remarques commentent les configurations particulières. Les autres paramètres de propriété nécessaires à la configuration varient selon les entreprises et ne sont donc pas mentionnés ici.

Étape Références et remarques
Utilisation de l'Éditeur BizTalk
  • Créez les spécifications pour les définitions des document entrants et sortants du canal que vous utilisez pour traiter le message initial.
  • Création et validation de spécifications

    Remarque

    • Vous devez ajouter un champ dans chacune de ces spécifications pour l'adresse de réponse. Vous pouvez ajouter ce champ à n'importe quel niveau ; toutefois, l'emplacement doit être convenu avec le partenaire commercial et doit correspondre aux spécifications existantes sur le système source de votre partenaire commercial. Pour plus d'informations, voir Gestion d'enregistrements et de champs.
  • Créez les spécifications pour les définitions des documents entrants et sortants du canal qui traitera le message de retour.
  • Création et validation de spécifications

    Remarque

    • Ces spécifications ne requièrent pas de configuration spéciale.
Utilisation du Gestionnaire d'échanges BizTalk :
  • Créez une organisation pour représenter le partenaire commercial avec le système source.
  • Création d'organisations

    Remarque

    • Cette organisation ne nécessite pas de configuration spéciale.
  • Créez les définitions de document nécessaires pour créer un canal qui traitera le message initial et un canal qui traitera le message de retour.
  • Création de définitions de documents

    Remarque

    • Dans les définitions de document, sélectionnez les spécifications précédemment créées. Pour plus d'informations, voir Sélection d'une spécification de document.
  • Créez un port d'échanges dans une application pour activer une nouvelle instance de planification XLANG et transférer le message initial vers un port de cette instance de planification XLANG.
  • Création de ports d'échanges

    Remarques

    • Sur la page Application de destination de l'Assistant Port d'échanges, cliquez sur Nouvelle planification XLANG.

    • Dans la zone Planifier le moniker, tapez le moniker de la planification spécifiée ou bien, cliquez sur Parcourir pour définir le chemin d'accès.

    • Dans la zone Nom du port, tapez le nom du port précis dans la planification vers lequel envoyer le document.

      Pour plus d'informations, voir Définition des propriétés de l'application de destination.
  • Créez un canal à partir d'une organisation pour traiter le message initial du partenaire commercial.
  • Création de canaux

    Remarque

    • Notez le nom du canal et le nom de la définition du document sortant que vous utilisez. Ces noms sont utilisés pour configurer les services d'Orchestration BizTalk.
  • Créez un port d'échanges pour une organisation afin de transmettre le message de retour au système source.
  • Création de ports d'échanges

    Remarque

    • Sur la page Organisation de destination de l'Assistant Port d'échanges, cliquez sur Organisation. Pour plus d'informations, voir Définition des propriétés de l'application de destination.

      Pour un port d'échanges ouvert, les informations sur la destination doivent figurer dans le document ou être fournies par les paramètres d'envoi. Lorsque la planification XLANG envoie le message de retour aux services d'Échanges BizTalk, elle transmet les données de l'adresse de réponse, contenues dans le message initial, en tant que paramètres d'identification de la destination.
  • Créez un canal à partir d'une application pour traiter le message de retour de la planification XLANG.
  • Création de canaux

    Remarque

    • Sur la page Application source de l'Assistant Canal, cliquez sur Planification XLANG. Pour plus d'informations, voir Définition des propriétés d'une application source.
Utilisation du Concepteur d'Orchestration BizTalk
  • Utilisez une forme Échanges BizTalk afin de mettre en oeuvre un port qui permette la réception du message initial.
  • Implémentation d'un port à l'aide d'Échanges BizTalk

    Remarques

    • Sur la page Direction de la communication de l'Assistant Liaison d'Échanges BizTalk, cliquez sur Recevoir.

    • Sur la page Informations sur l'activation de la planification XLANG de l'Assistant Liaison d'Échanges BizTalk, cliquez sur Oui.

      Important

    • Si vous choisissez Oui, le port est configuré pour l'activation d'une nouvelle instance de planification à chaque réception d'un message. Pour plus d'informations sur l'utilisation de cette option, reportez-vous à la rubrique qui présente cette étape.
  • Créez le flux de communication entre la forme Action et le port qui reçoit le message initial.
  • Envoi ou réception de messages asynchrones

    Remarque

    • Sur la page Informations sur le message de l'Assistant Communication XML, cliquez sur Créer un message et dans la zone Nom du message, tapez un nom pour le message.

      Vous pouvez utiliser n'importe quel nom ; toutefois, l'utilisation du nom de la définition du document entrant pour le canal permet de voir plus facilement quel message est envoyé.

    • Dans la zone Type du message de la page Informations sur les types de messages, tapez le nom de la définition du document sortant du canal que vous utilisez pour traiter le message de retour.

      Tous les messages transmis depuis Échanges BizTalk vers une planification XLANG utilisent une file d'attente de messages. L'étiquette de ces messages correspond au nom de la définition du document sortant du canal.
  • Utilisez une forme Échanges BizTalk afin de mettre en oeuvre un port qui permette l'envoi du message de retour dans un canal dynamique.
  • Implémentation d'un port à l'aide d'Échanges BizTalk

    Remarques

    • Sur la page Informations sur le canal statique ou dynamique de l'Assistant Liaison d'Échanges BizTalk, cliquez sur Canal dynamique.

    • Lorsque vous créez un port qui utilise un canal dynamique, le canal des services d'Échanges BizTalk qui traite le message est déterminé par les données du port transférées en tant que paramètres d'envoi. Ceci est décrit ultérieurement dans ce tableau.
  • Créez le flux de communication entre la forme Action et le port qui envoie le message de retour.
  • Envoi ou réception de messages asynchrones

    Remarque

    • Sur la page Informations sur le message de l'Assistant Communication XML, cliquez sur Créer un message et dans la zone Nom du message, tapez un nom pour le message.

      Vous pouvez utiliser n'importe quel nom ; toutefois, l'utilisation du nom de la définition du document entrant pour le canal permet de voir plus facilement quel message est envoyé.

    • Dans la zone Type du message de la page Informations sur les types de messages, tapez le nom de la définition du document entrant du canal que vous utilisez pour traiter le message.

      Les données de définition du document entrant sont transférées vers les services d'Échanges BizTalk en tant que paramètres d'envoi. Ceci est décrit ultérieurement dans ce tableau.
  • Créez le flux de données pour transférer le champ de l'adresse de réponse du port de référence vers le port qui envoie le message de retour.
  • Dessin de flux entre les messages

    Remarques

    • Cliquez sur l'onglet Données.

    • Sur la page Données, du message initial, cliquez dans le champ de l'adresse de réponse. Faites ensuite glisser sa poignée de contrôle vers le point de connexion gauche du port de référence dans le message Port References pour le port qui envoie le message de retour.

    Important

    • Vous devez connecter le champ de l'adresse de réponse au point de connexion gauche du port de référence. Le point de connexion gauche du port de référence est disponible uniquement lorsque le port est configuré sur un canal dynamique pour l'envoi des messages.

      Pour un port qui utilise un canal dynamique, les données de référence du port doivent être transférées à partir du champ correspondant d'un message reçu précédemment.

      Dans ce scénario, les données de l'adresse de réponse du message initial sont transférées dans le champ de référence du port utilisé pour l'envoi du message de retour. L'adresse de réponse correspond à l'URL http vers laquelle le message de retour est envoyé.

      Lorsqu'un port qui utilise un canal dynamique transfère un message vers les services d'Échanges BizTalk, les données de référence du port sont transmises en tant que paramètres d'identification de la destination et le type de données en tant que paramètre de définition du document. Les paramètres permettent aux services d'Échanges BizTalk d'identifier le canal à invoquer pour traiter le message. Pour plus d'informations, voir Identification et Envoi.

      Lorsqu'un port est configuré pour utiliser un canal dynamique, les informations sur la destination sont transmises en tant que paramètres d'un envoi de destination ouvert. Par conséquent, tous les canaux invoqués par un port utilisant un canal dynamique doivent être associés à un port d'échanges ouvert.

Utilisation d'un type de transport HTTPS sécurisé.

Le port d'échanges transportant les messages de retour étant un port d'échanges ouvert, vous ne pouvez pas utiliser de certificat de cryptage pour encrypter vos documents.

Si vos processus professionnels nécessitent un moyen de transport sécurisé pour échanger des messages avec un partenaire commercial, le système source doit inclure une URL https, de préférence à une URL http, comme adresse de réponse dans les messages initiaux qui vous sont envoyés.

Pour plus d'informations, voir Configuration du système source pour utiliser un type de transport HTTP


Utilisation d'un type de transport non-HTTP

Cette section explique comment intégrer et configurer les Services d'Orchestration BizTalk et les Services d'Échanges BizTalk pour le système source et le système de destination afin que :

  • le système source génère et envoie un message au système de destination d'un partenaire commercial en utilisant une instance de planification XLANG spécifique ;

  • le système de destination reçoive le message initial, active une instance de planification XLANG qui génère un message de retour, puis envoie le message de retour vers le système source via un transport non-HTTP.

Pour configurer les deux systèmes afin de permettre au système de destination d'utiliser un type de transport HTTP en vue de l'envoi des messages de retour, voir Utilisation d'un type de transport HTTP.

Cette section traite des rubriques suivantes :

  • Configuration du système source pour utiliser un type de transport non-HTTP

  • Configuration du système de destination pour utiliser un type de transport non-HTTP


Configuration du système source pour utiliser un type de transport non-HTTP

Les étapes de cette rubrique décrivent comment configurer le système source afin de générer et d'envoyer un message qui contient le chemin d'accès d'une file d'attente statique. Les systèmes de destination des partenaires commerciaux sont configurés pour transmettre le chemin d'accès de la file d'attente intégré au message dans un champ du message de retour et l'envoyer au système source via un type de transport non-HTTP. Pour configurer le système source et permettre au système de destination d'utiliser un type de transport HTTP pour envoyer des messages de retour, voir Configuration du système source pour utiliser un type de transport HTTP.

Lorsque le système source reçoit le message de retour, il l'envoie vers les services d'Échanges BizTalk. Les services d'Échanges BizTalk le transfèrent vers la file d'attente spécifiée dans le chemin intégré dans le champ du document. Cette file d'attente est contrôlée par l'instance de planification XLANG qui génère le message initial. La planification extrait le message de retour de cette file d'attente.

Afin que la configuration du système source fonctionne correctement, le système de destination du partenaire commercial doit également être correctement configuré. Pour plus d'informations sur la configuration du système de destination, voir Configuration du système de destination pour utiliser un type de transport non-HTTP.

Pour configurer le système source afin d'utiliser un type de transport non-HTTP, exécutez les étapes décrites dans le tableau suivant. Des références sont fournies pour chaque procédure et des remarques commentent les configurations particulières. Les autres paramètres de propriété nécessaires à la configuration varient selon les entreprises et ne sont donc pas mentionnés ici.

Étape Références et remarques
Utilisation de l'Éditeur BizTalk
  • Créez les spécifications pour les définitions des documents entrants et sortants du canal que vous utilisez pour traiter le message initial.
  • Création et validation de spécifications

    Remarque

    • Dans chacune de ces spécifications, vous devez ajouter un champ pour le chemin d'accès de la file d'attente. Vous pouvez ajouter ce champ à n'importe quel niveau ; toutefois, l'emplacement doit être convenu avec le partenaire commercial et doit correspondre aux spécifications existantes sur le système de destination de votre partenaire commercial. Pour plus d'informations, voir Gestion d'enregistrements et de champs.
  • Créez les spécifications pour les définitions des documents entrants et sortants du canal que vous utilisez pour traiter le message de retour.
  • Création et validation de spécifications

    Remarques

    • Vous devez ajouter un champ pour le chemin d'accès de la file d'attente dans la spécification entrante. Vous pouvez ajouter ce champ à n'importe quel niveau ; toutefois, l'emplacement doit être convenu avec le partenaire commercial et doit correspondre aux spécifications existantes sur le système de destination de votre partenaire commercial. Pour plus d'informations, voir Gestion d'enregistrements et de champs.

    • Le champ du chemin d'accès de la file d'attente de la spécification entrante doit être défini comme valeur de destination dans les propriétés du dictionnaire. Pour plus d'informations, voir Définitions des propriétés du dictionnaire.

      Lors de la réception et de l'envoi d'un message de retour vers les services d'Échanges BizTalk dans le système source, le champ du chemin d'accès de la file d'attente est reconnu et traité en tant que paramètre d'identification de la destination. Pour plus d'informations, voir Envoi. Le port d'échanges transfère le message de retour vers le chemin d'accès de la file d'attente spécifié. La planification XLANG contrôle cette file d'attente et en extrait le message de retour.

Utilisation du Mappeur BizTalk :
  • Créez un mappage à utiliser dans le canal qui traite le message initial.
  • Création de nouveaux mappages

    Important

    • La syntaxe du nom de chemin d'accès de la file d'attente générée par la planification XLANG doit être convertie en nom de format et intégrer le préfixe de file d'attente ://. Le script de la page ASP exécute cette modification pour le scénario de transport http. Pour effectuer cette modification dans un scénario de transport non-http, vous devez utilisez un fonctoid de concaténation dans un mappage. Pour plus d'informations, voir Mappages pour l'intégration des services BizTalk.
Utilisation du Gestionnaire d'échanges BizTalk :
  • Créez une organisation pour représenter le partenaire commercial avec le système de destination.
  • Création d'organisations

    Remarque

    • Cette organisation ne nécessite pas de configuration spéciale.
  • Créez les définitions de document nécessaires pour créer un canal qui traitera le message initial et un canal qui traitera le message de retour.
  • Création de définitions de documents

    Remarque

    • Dans les définitions de document, sélectionnez les spécifications précédemment créées. Pour plus d'informations, voir Sélection d'une spécification de document.
  • Créez un port d'échanges pour une organisation afin de transmettre le message initial au système de destination.
  • Création de ports d'échanges

    Remarque

    • Ce port d'échanges ne requiert pas de configuration particulière.
  • Créez un canal à partir d'une application pour traiter le message initial de la planification XLANG.
  • Création de canaux

    Remarques

    • Sur la page Application source de l'Assistant Canal, cliquez sur Planification XLANG. Pour plus d'informations, voir Définition des propriétés d'une application source.

    • Sur la page Document sortant, activez la case à cocher Mapper le document entrant sur le document sortant, puis cliquez sur le bouton Parcourir situé à droite de la zone Référence de mappage. Sélectionnez ensuite le mappage créé précédemment et cliquez sur Ouvrir.

    • Prenez note du nom de canal et du nom de la définition du document entrant que vous utilisez. Ces noms servent à configurer les services d'Orchestration BizTalk.
  • Créez un port d'échanges ouvert dans une organisation pour transférer le message de retour vers l'instance de planification XLANG active qui a généré le message initial.
  • Création de ports d'échanges

    Remarques

    • Sur la page Organisation de destination de l'Assistant Port d'échanges, cliquez sur Destination ouverte. Pour plus d'informations, voir Définition des propriétés de l'organisation de destination.

    • Dans ce scénario, vous pouvez créer un port d'échanges pour une organisation, même si vous envoyez le message de retour à une application ou une planification XLANG.

      Ainsi, vous pouvez utiliser un port d'échanges ouvert pour l'envoi du message de retour en vous servant des informations sur le chemin d'accès de la file d'attente comme paramètres d'envoi. Pour plus d'informations, voir Envoi.

      Le port d'échanges ouvert transfère le message de retour vers la file d'attente statique, spécifiée dans le chemin d'accès de la file d'attente, dans laquelle la planification XLANG est configurée pour l'extraire.
  • Créez un canal à partir d'une organisation pour traiter le message de retour du système de destination.
  • Création de canaux

    Remarques

    • La définition du document entrant de ce canal doit utiliser la définition de document basée sur la spécification précédemment créée, dans laquelle vous avez affecté la valeur de destination au champ du chemin d'accès de la file d'attente dans les propriétés du dictionnaire.

    • Prenez note du nom de canal et du nom de la définition du document entrant que vous utilisez. Ces noms sont utilisés pour configurer les services d'Orchestration BizTalk.
Utilisation du Concepteur d'Orchestration BizTalk
  • Utilisez une forme pour les échanges BizTalk afin d'implémenter un port qui permette l'envoi du message initial.
  • Implémentation d'un port à l'aide d'Échanges BizTalk

    Remarque

    • Dans la page Informations sur le canal statique ou dynamique de l'Assistant Liaison d'Échanges BizTalk, cliquez sur Canal statique et dans la zone Entrez le nom d'un canal connu pré-existant, tapez le nom du canal dans le Gestionnaire d'échanges BizTalk que vous utilisez pour traiter le message initial.
  • Créez le flux de communication entre la forme Action et le port qui envoie le message initial.
  • Envoi ou réception de messages asynchrones

    Remarques

    • Sur la page Informations sur le message de l'Assistant Communication XML, cliquez sur Créer un message et dans la zone Nom du message, tapez un nom pour le message.

      Vous pouvez utiliser n'importe quel nom ; toutefois, l'utilisation du nom de la définition du document entrant pour le canal permet de voir plus facilement quel message est envoyé.

    • Dans la zone Type du message de la page Informations sur les types de messages, tapez le nom de la définition du document entrant du canal que vous utilisez pour traiter le message.

    • Sur la page Informations sur la spécification du message, cliquez sur Parcourir et sélectionnez la spécification utilisée dans la définition du document entrant du canal qui a traité le message initial.

    • Sur la page Informations sur la spécification du message, dans la zone Champs de message, cliquez sur Ajouter, puis ajoutez le champ à la spécification créée pour contenir l'adresse du chemin d'accès de la file d'attente.
  • Utilisez une forme de Message Queuing afin de mettre en oeuvre un port qui permette la réception du message de retour.
  • Implémentation d'un port à l'aide de Message Queuing

    Remarques

    • Dans ce scénario, vous utilisez une liaison de port Message Queuing, même si vous recevez un message à partir des services d'Échanges BizTalk.

    • Sur la page Informations sur la file d'attente statique ou dynamique de l'Assistant Liaison de Message Queuing, cliquez sur File d'attente dynamique.

    • Sur la page Informations sur la file d'attente, cliquez sur Utiliser une file d'attente connue pour toutes les instances, et dans la zone Entrez le nom de la file d'attente, tapez le nom de la file d'attente statique utilisé pour traiter le message de retour.
  • Créez le flux de communication entre la forme Action et le port qui reçoit le message de retour.
  • Envoi ou réception de messages asynchrones

    Remarque

    • Sur la page Assistant Communication XML de l'Assistant du même nom, cliquez sur Recevoir.

    • Sur la page Informations sur le message, cliquez sur Créer un message et dans la zone Nom du message, tapez un nom pour le message.

      Vous pouvez utiliser n'importe quel nom ; toutefois, l'utilisation du nom de la définition du document sortant pour le canal permet de voir plus facilement quel message est reçu.

    • Dans la zone Type du message de la page Informations sur les types de messages, tapez le nom de la définition du document sortant du canal que vous utilisez pour traiter le message de retour.

      Tous les messages transmis depuis Échanges BizTalk vers une planification XLANG utilisent une file d'attente de messages. L'étiquette de ces messages correspond au nom de la définition du document sortant du canal.
  • Créez le flux de données de la référence du port de réception au champ du chemin d'accès de la file d'attente.
  • Dessin de flux entre les messages

    Remarques

    • Cliquez sur l'onglet Données.

    • Sur la page Données, dans le message Port References, sélectionnez le champ du port qui recevra le message de retour. Ensuite, faites glisser sa poignée de contrôle vers le point de connexion du champ du chemin d'accès de la file d'attente dans le message initial.

      Les données de référence du port sont insérées dans le champ du chemin d'accès de la file d'attente du message initial. Les références du port correspondent au chemin d'accès de la file d'attente statique du port qui reçoit le message de retour.


Configuration du système de destination pour utiliser un type de transport non-HTTP

Les étapes de cette rubrique décrivent comment configurer le système de destination afin de recevoir un message qui contient un chemin de file d'attente et d'envoyer un message de retour, contenant ce même chemin, au système source via un type de transport non-HTTP. Si vous voulez configurer le système de destination afin d'utiliser un type de transport HTTP pour envoyer des messages de retour, voir Configuration du système de destination pour utiliser un type de transport HTTP.

Lorsque les services d'Échanges BizTalk du système de destination reçoivent le message initial, ils sont configurés pour activer une nouvelle instance d'une planification XLANG spécifiée et envoyer le message vers un port spécifié dans cette instance de planification XLANG.

La planification XLANG est configurée pour transférer les données contenues dans le champ du chemin d'accès de la file d'attente du message initial vers le champ correspondant du message de retour, puis envoyer le message de retour vers un canal des services d'Échanges BizTalk.

Les services d'Échanges BizTalk utilisent le canal spécifié pour traiter le message de retour et le transférer vers un port d'échanges. Ce port d'échanges est configuré pour le transfert du message de retour vers une adresse convenue avec le partenaire commercial du système source. Il ne peut pas s'agir d'un port d'échanges ouvert.

Afin que la configuration du système de destination fonctionne correctement, le système source du partenaire commercial doit également être correctement configuré. Pour plus d'informations sur la configuration du système source, voir Configuration du système de source pour utiliser un type de transport non-HTTP.

Pour configurer le système de destination afin d'utiliser un type de transport non-HTTP, exécutez les étapes décrites dans le tableau suivant. Des références sont fournies pour chaque procédure et des remarques commentent les configurations particulières. Les autres paramètres de propriété nécessaires à la configuration varient selon les entreprises et ne sont donc pas mentionnés ici.

Étape Références et remarques
Utilisation de l'Éditeur BizTalk
  • Créez les spécifications pour les définitions des document entrants et sortants du canal que vous utilisez pour traiter le message initial.
  • Création et validation de spécifications

    Remarques

    • Dans chacune de ces spécifications, vous devez ajouter un champ pour le chemin d'accès de la file d'attente. Vous pouvez ajouter ce champ à n'importe quel niveau ; toutefois, l'emplacement doit être convenu avec le partenaire commercial et doit correspondre aux spécifications existantes sur le système source de votre partenaire commercial. Pour plus d'informations, voir Gestion d'enregistrements et de champs.
  • Créez les spécifications pour les définitions des documents entrants et sortants du canal que vous utilisez pour traiter le message de retour.
  • Création et validation de spécifications

    Remarques

    • Dans chacune de ces spécifications, vous devez ajouter un champ pour le chemin d'accès de la file d'attente. Vous pouvez ajouter ce champ à n'importe quel niveau ; toutefois, l'emplacement doit être convenu avec le partenaire commercial et doit correspondre aux spécifications existantes sur le système source de votre partenaire commercial. Pour plus d'informations, voir Gestion d'enregistrements et de champs.
Utilisation du Gestionnaire d'échanges BizTalk :
  • Créez une organisation pour représenter le partenaire commercial avec le système source.
  • Création d'organisations

    Remarque

    • Cette organisation ne nécessite pas de configuration spéciale.
  • Créez les définitions de document nécessaires pour créer un canal qui traitera le message initial.
  • Création de définitions de documents

    Remarque

    • Dans les définitions de document, sélectionnez les spécifications précédemment créées. Pour plus d'informations, voir Sélection d'une spécification de document.
  • Créez les définitions de document nécessaires pour créer un canal qui traitera le message initial.
  • Création de définitions de documents

    Remarque

    • Dans les définitions de document, sélectionnez les spécifications précédemment créées. Pour plus d'informations, voir Sélection d'une spécification de document.
  • Créez un port d'échanges dans une application pour activer une nouvelle instance de planification XLANG et transférer le message initial vers un port de cette instance de planification XLANG.
  • Création de ports d'échanges

    Remarques

    • Sur la page Application de destination de l'Assistant Port d'échanges, cliquez sur Nouvelle planification XLANG.

    • Dans la zone Planifier le moniker, tapez le moniker de la planification spécifiée ou bien, cliquez sur Parcourir pour définir le chemin d'accès.

    • Dans la zone Nom du port, tapez le nom du port précis dans la planification vers lequel envoyer le document.

      Pour plus d'informations, voir Définition des propriétés de l'application de destination.

      Pour exécuter cette étape, le chemin d'accès d'une planification XLANG et le nom du port de cette planification, auquel le message est transmis, sont nécessaires. C'est pourquoi vous devez tout d'abord créer la planification XLANG et configurer son port, en suivant les instructions ultérieures dans ce tableau.
  • Créez un canal à partir d'une organisation pour traiter le message initial du partenaire commercial.
  • Création de canaux

    Remarque

    • Notez le nom du canal et le nom de la définition du document sortant que vous utilisez. Ces noms servent à configurer les services d'Orchestration BizTalk.
  • Créez un port d'échanges pour une organisation afin de transmettre le message de retour au système source.
  • Création de ports d'échanges

    Remarques

    • Sur la page Organisation de destination de l'Assistant Port d'échanges, cliquez sur Organisation. À droite de la zone Nom, cliquez sur Parcourir.

    • Dans la boîte de dialogue Sélectionner une organisation, sélectionnez l'organisation créée précédemment pour représenter le partenaire commercial avec le système source. Pour plus d'informations, voir Sélection d'une organisation de destination.

    • Sur la page Organisation de destination de l'Assistant Port d'échanges, dans la zone Transport principal, cliquez sur Parcourir.

    • Dans la boîte de dialogue Transport principal, dans la liste Type de transport, sélectionnez le type de transport, et dans la zone Adresse, tapez une adresse.

      Le type de transport et l'adresse doivent être convenus avec le partenaire commercial et correspondre aux spécifications existantes sur le système source de votre partenaire commercial.

    • Un port d'échanges ouvert ne convient pas pour envoyer le message de retour.
  • Créez un canal à partir d'une application pour traiter le message de retour de la planification XLANG.
  • Création de canaux

    Remarques

    • Sur la page Application source de l'Assistant Canal, cliquez sur Planification XLANG. Pour plus d'informations, voir Définition des propriétés d'une application source.

    • Prenez note du nom de canal et du nom de la définition du document entrant que vous utilisez. Ces noms sont utilisés pour configurer les services d'Orchestration BizTalk.
Utilisation du Concepteur d'Orchestration BizTalk
  • Utilisez une forme Échanges BizTalk afin de mettre en oeuvre unport qui permette la réception du message initial.
  • Implémentation d'un port à l'aide d'Échanges BizTalk

    Remarques

    • Sur la page Direction de la communication de l'Assistant Liaison d'Échanges BizTalk, cliquez sur Recevoir.

    • Sur la page Informations sur l'activation de la planification XLANG de l'Assistant Liaison d'Échanges BizTalk, cliquez sur Oui.

    Important

    • Si vous choisissez Oui, le port est configuré pour l'activation d'une nouvelle instance de planification à chaque réception d'un message. Pour plus d'informations sur l'utilisation de cette option, reportez-vous à la rubrique qui présente cette étape.

      Notez le nom affecté à ce port et l'emplacement de l'enregistrement de la planification XLANG compilée. Ces informations sont nécessaires pour configurer un port d'échanges dans les services d'Échanges BizTalk, comme indiqué précédemment dans ce tableau.
  • Créez le flux de communication entre la forme Action et le port qui reçoit le message initial.
  • Envoi ou réception de messages asynchrones

    Remarque

    • Sur la page Informations sur le message de l'Assistant Communication XML, cliquez sur Créer un message et dans la zone Nom du message, tapez un nom pour le message.

      Vous pouvez utiliser n'importe quel nom ; toutefois, l'utilisation du nom de la définition du document entrant pour le canal permet de voir plus facilement quel message est envoyé.

    • Dans la zone Type du message de la page Informations sur les types de messages, tapez le nom de la définition du document sortant du canal que vous utilisez pour traiter le message de retour.

      Tous les messages transmis depuis Échanges BizTalk vers une planification XLANG utilisent une file d'attente de messages. L'étiquette de ces messages correspond au nom de la définition du document sortant du canal.

    • Sur la page Informations sur la spécification du message, cliquez sur Parcourir et sélectionnez la spécification utilisée dans la définition du document sortant du canal qui a traité le message initial.

    • Dans la zone Champs de message, cliquez sur Ajouter, et ajouter le champ dans la spécification créée pour contenir l'adresse du chemin d'accès de la file d'attente du message initial.
  • Utilisez une forme Échanges BizTalk afin de mettre en oeuvre un port qui permette l'envoi du message de retour.
  • Implémentation d'un port à l'aide d'Échanges BizTalk

    Remarque

    • Sur la page Informations sur le canal statique ou dynamique de l'Assistant Liaison d'Échanges BizTalk, cliquez sur Canal statique et dans la zone Entrez le nom d'un canal connu pré-existant, tapez le nom du canal dans le Gestionnaire d'échanges BizTalk que vous utilisez pour traiter le message initial.

    • Comme ce port utilise un canal statique, aucun appel de destination ouvert soumis aux Échanges BizTalk n'est effectué. C'est pourquoi le canal spécifié ne peut pas être associé à un port d'échanges ouvert.
  • Créez le flux de communication entre la forme Action et le port qui envoie le message de retour.
  • Envoi ou réception de messages asynchrones

    Remarques

    • Sur la page Informations sur le message de l'Assistant Communication XML, cliquez sur Créer un message et dans la zone Nom du message, tapez un nom pour le message.

      Vous pouvez utiliser n'importe quel nom ; toutefois, l'utilisation du nom de la définition du document entrant pour le canal permet de voir plus facilement quel message est envoyé.

    • Dans la zone Type du message de la page Informations sur les types de messages, tapez le nom de la définition du document entrant du canal que vous utilisez pour traiter le message.

    • Sur la page Informations sur la spécification du message, cliquez sur Parcourir et sélectionnez la spécification utilisée dans la définition du document entrant du canal qui a traité le message de retour.

    • Dans la zone Champs de message, cliquez sur Ajouter, et ajouter le champ dans la spécification créée pour contenir l'adresse du chemin d'accès de la file d'attente du message de retour.
  • Créez le flux de données du champ du chemin d'accès de la file d'attente du message initial jusqu'au champ correspondant dans le message de retour.
  • Dessin de flux entre les messages

    Remarques

    • Cliquez sur l'onglet Données.

    • Sur la page Données, sélectionnez le champ du chemin d'accès de la file d'attente dans le message initial. Ensuite, faites glisser sa poignée de contrôle vers le point de connexion du champ correspondant dans le message de retour.

      Les données du champ du chemin d'accès de la file d'attente du message initial sont ainsi transférées dans le message de retour.


BizTalk Server 2000 Interface Reference

You can programmatically integrate applications with Microsoft BizTalk Server 2000 by using the BizTalk Messaging Configuration object model, or by extending and customizing the functionality of the server to suit your business and information-exchange needs. The interface reference provides all the information necessary for programmers of the Microsoft Visual Basic and Visual C++ programming languages to use or extend BizTalk Server 2000. This section also includes a complete list of interfaces, objects, enumerations, code samples, and possible error messages.

BizTalk Server 2000 supports programmatic application integration by accessing the BizTalk Messaging Configuration object model and submitting documents by calling the methods of the IInterchange interface. BizTalk Server 2000 also supports the use of extensible application integration components (AICs), including a lightweight integration model and support for the pipeline-component model available in Microsoft Site Server, Commerce Edition 3.0.

The interface reference is divided into the following parts:

Using the BizTalk Messaging Configuration Object Model

This section provides information about how to access the BizTalk Messaging Configuration object model, including all the reference pages for the supported interfaces. This information is provided for both Microsoft Visual C++ and Visual Basic developers. For more information, see Using the BizTalk Messaging Configuration Object Model.

Submitting Documents

This section covers submitting documents to BizTalk Server 2000, using the synchronous and asynchronous methods of the IInterchange interface. It shows how to move a document once the trading partner relationships are set up, and how to track documents moving through BizTalk Server 2000. For more information, see Submitting Documents.

Creating Custom Components

This section covers BizTalk Server 2000 support for extensible application integration components (AICs), including a lightweight integration model and support for the pipeline-component model available in Microsoft Site Server, Commerce Edition 3.0.

This allows developers to do the following:

  • Enable business applications to receive business documents, using AICs.

  • Extend the functionality of BizTalk Server 2000 by developing components to perform digital signatures and verification, encryption and decryption, parsing, and transport.

For more information, see Creating Custom Components.

Administering XLANG Schedules

This section provides information about the interfaces that can be used to access a running instance of a specific XLANG schedule, or to perform system-wide administrative tasks in the XLANG Scheduler run-time environment. This information is provided for both Microsoft Visual C++ and Visual Basic developers. For more information, see Administering XLANG Schedules.


Using the BizTalk Messaging Configuration Object Model

This section provides information about how to use the BizTalk Messaging Configuration object model programmatically. For additional information, see the following sections:

  • For general background information, see Concepts.

  • For information about COM interfaces, enumerations, and error messages, see the Object Model Reference.

  • For examples of code, see BizTalk Messaging Services Code Samples.

The BizTalk Messaging Configuration object model can also be configured using the BizTalk Messaging Manager graphical user interface. For more information, see Using BizTalk Messaging Manager.


Object Model Reference

This section provides reference information about interfaces used by Microsoft BizTalk Server 2000 for both Microsoft Visual C++ and Visual Basic programming. Reference information is provided for all interfaces, objects, methods, properties, and enumerations exposed for accessing the BizTalk Messaging Configuration object model. In addition, a complete list of Error Messages is provided.

The following COM interfaces and enumerations are documented in this reference:

  • IBizTalkBase

  • IBizTalkCertificateInfo

  • IBizTalkChannel

  • IBizTalkConfig

  • IBizTalkDocument

  • IBizTalkEndPoint

  • IBizTalkEnvelope

  • IBizTalkLoggingInfo

  • IBizTalkOrganization

  • IBizTalkPort

  • IBizTalkPortGroup

  • IBizTalkServiceWindowInfo

  • IBizTalkTransportInfo

  • IDictionary

  • ISimpleList

  • Object Model Enumerations


IBizTalkBase Interface [C++]

IBizTalkBase Object [Visual Basic]

In C++, the IBizTalkBase interface defines common methods and properties that are inherited by the following objects. In Microsoft Visual Basic, the IBizTalkBase class defines common methods and properties that are implemented by the following objects.

  • BizTalkChannel

  • BizTalkDocument

  • BizTalkEnvelope

  • BizTalkOrganization

  • BizTalkPort

  • BizTalkPortGroup

Note

The methods and properties of this object are always invoked on the objects listed above, rather than by creating an actual BizTalkBase object.

The properties of the BizTalkBase object are shown in the following table.

Property | Type | Description
DateModified | BSTR | Date and time at which the information in the object was created or last modified. This is a read-only property.
Handle | long | Handle to the object. This is a read-only property.
Name | BSTR | Name of the object.

The methods of the BizTalkBase object are shown in the following table.

Method | Description
Clear | Clears the object in memory. All the member variables of the object in memory are initialized to their default values.
Create | Creates a new object in the database.
Load | Loads a specified object in memory.
LoadByName | Loads a specified object by name in memory.
Remove | Removes the object from the database.
Save | Saves the object in the database.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkBase::Clear Method [C++]

IBizTalkBase.Clear Method [Visual Basic]

The Clear method clears the object in memory. All member variables of the object in memory are initialized to their default values.

Syntax

[C++]

HRESULT Clear();

[Visual Basic]

object.Clear()

Parameters

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Applies To

This method is supported by the following objects:

  • BizTalkChannel

  • BizTalkDocument

  • BizTalkEnvelope

  • BizTalkOrganization

  • BizTalkPort

  • BizTalkPortGroup

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkBase::Create Method [C++]

IBizTalkBase.Create Method [Visual Basic]

The Create method creates a new object in the database.

Syntax

[C++]

HRESULT Create(
    long* plBiztalkObjectHandle
);

[Visual Basic]

object.Create()

Parameters

[C++]

plBiztalkObjectHandle

[out, retval] Pointer to a long that contains the handle to the object.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This method returns a Long that contains the handle to the object.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Applies To

This method is supported by the following objects:

  • BizTalkChannel

  • BizTalkDocument

  • BizTalkEnvelope

  • BizTalkOrganization

  • BizTalkPort

  • BizTalkPortGroup

Remarks

The Name property must be set before calling this method. Name must be unique across the database for each object type. Create updates the DateModified property.

When creating any object that refers to an XML document specification or map located outside your local domain, you might receive an error. If an error occurs, download and configure the WinHTTP proxy utility. To download this utility, go to the Microsoft MSDN Web site at msdn.microsoft.com/downloads/default.asp, and browse to the WinHTTP Proxy Configuration Utility page, which is located in the XML chapter of the Web Development book.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkBase::DateModified Property [C++]

IBizTalkBase.DateModified Property [Visual Basic]

The DateModified property contains the date and time at which the information in the object was created or last modified.

Syntax

[C++]

Get method:

HRESULT get_DateModified(
    BSTR* pstrModified
);

[Visual Basic]

object.DateModified

Parameters

[C++]

pstrModified

[out, retval] Pointer to a BSTR that contains the date modified.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a String that contains the date modified.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Applies To

This property is supported by the following objects:

  • BizTalkChannel

  • BizTalkDocument

  • BizTalkEnvelope

  • BizTalkOrganization

  • BizTalkPort

  • BizTalkPortGroup

Remarks

This is a read-only property. The format for the strModified string is yyyy-mm-dd hh:mm:ss. The time is in coordinated universal time (UTC). The server sets this property when the Create or the Save method is called for the object.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkBase::Handle Property [C++]

IBizTalkBase.Handle Property [Visual Basic]

The Handle property contains the handle to the object.

Syntax

[C++]

Get method:

HRESULT get_Handle(
    long* plBiztalkObjectHandle
);

[Visual Basic]

object.Handle

Parameters

[C++]

plBiztalkObjectHandle

[out, retval] Pointer to a long that contains the handle to the object.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a Long that contains the handle to the object.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Applies To

This property is supported by the following objects:

  • BizTalkChannel

  • BizTalkDocument

  • BizTalkEnvelope

  • BizTalkOrganization

  • BizTalkPort

  • BizTalkPortGroup

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkBase::Load Method [C++]

IBizTalkBase.Load Method [Visual Basic]

The Load method loads an object in memory.

Syntax

[C++]

HRESULT Load(
    long lBiztalkObjectHandle
);

[Visual Basic]

object.Load(lBiztalkObjectHandle As Long)

Parameters

[C++]

lBiztalkObjectHandle

[in] Long that contains the handle to the object to load.

[Visual Basic]

lBiztalkObjectHandle

Long that contains the handle to the object to load.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Applies To

This method is supported by the following objects:

  • BizTalkChannel

  • BizTalkDocument

  • BizTalkEnvelope

  • BizTalkOrganization

  • BizTalkPort

  • BizTalkPortGroup

Remarks

Load calls the Clear method internally before loading the object.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkBase::LoadByName Method [C++]

IBizTalkBase.LoadByName Method [Visual Basic]

The LoadByName method loads an object by name in memory.

Syntax

[C++]

HRESULT LoadByName(
    BSTR strName
);

[Visual Basic]

object.LoadByName(strName As String)

Parameters

[C++]

strName

[in] BSTR that contains the name.

[Visual Basic]

strName

String that contains the name.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Applies To

This method is supported by the following objects:

  • BizTalkChannel

  • BizTalkDocument

  • BizTalkEnvelope

  • BizTalkOrganization

  • BizTalkPort

  • BizTalkPortGroup

Remarks

LoadByName calls the Clear method internally before loading the object.

Names have a maximum length of 64 characters.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkBase::Name Property [C++]

IBizTalkBase.Name Property [Visual Basic]

The Name property contains the name of the object.

Syntax

[C++]

Get method:

HRESULT get_Name(
    BSTR* pstrName
);

Put method:

HRESULT put_Name(
    BSTR strName
);

[Visual Basic]

object.Name

Parameters

[C++]

Get method:

pstrName

[out, retval] Pointer to a BSTR that contains the name of the object.

Put method:

strName

[in] BSTR that contains the name of the object.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a String that contains the name.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Applies To

This property is supported by the following objects:

  • BizTalkChannel

  • BizTalkDocument

  • BizTalkEnvelope

  • BizTalkOrganization

  • BizTalkPort

  • BizTalkPortGroup

Remarks

The server requires the Name property. It must be set before calling the Create or the Save method for the object. Name must be unique across a database for each object type and must be at least one character long. Names have a maximum length of 64 characters.

The following table lists names reserved for use by BizTalk Server:

Name | Object type
Reliable Message Acknowledgement Port | IBizTalkPort
Reliable Message Acknowledgement Channel | IBizTalkChannel
BizTalk Canonical Receipt | IBizTalkDocument
Reliable Messaging Acknowledgement | IBizTalkDocument
Reliable Messaging Acknowledgement SMTP From Address | IBizTalkOrganization alias
Home Organization | IBizTalkOrganization

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkBase::Remove Method [C++]

IBizTalkBase.Remove Method [Visual Basic]

The Remove method removes the object from the database.

Syntax

[C++]

HRESULT Remove();

[Visual Basic]

object.Remove()

Parameters

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Applies To

This method is supported by the following objects:

  • BizTalkChannel

  • BizTalkDocument

  • BizTalkEnvelope

  • BizTalkOrganization

  • BizTalkPort

  • BizTalkPortGroup

Remarks

The object cannot be removed if any other object refers to it.

A BizTalkOrganization object cannot be removed if it is the default organization. Before it can be removed, the IsDefault property must be set to False, and another organization must have the IsDefault property set to True.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topic

Referential Integrity


IBizTalkBase::Save Method [C++]

IBizTalkBase.Save Method [Visual Basic]

The Save method saves the object in the database.

Syntax

[C++]

HRESULT Save();

[Visual Basic]

object.Save()

Parameters

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Applies To

This method is supported by the following objects:

  • BizTalkChannel

  • BizTalkDocument

  • BizTalkEnvelope

  • BizTalkOrganization

  • BizTalkPort

  • BizTalkPortGroup

Remarks

The Save method updates the DateModified property.

When saving any object that refers to an XML document specification or map located outside your local domain, you might receive an error. If an error occurs, download and configure the WinHTTP proxy utility. To download this utility, go to the Microsoft MSDN Web site at msdn.microsoft.com/downloads/default.asp, and browse to the WinHTTP Proxy Configuration Utility page, which is located in the XML chapter of the Web Development book.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkCertificateInfo Interface [C++]

BizTalkCertificateInfo Object [Visual Basic]

Use this object to configure a certificate associated with a BizTalkPort or a BizTalkChannel object.

In C++, use the IBizTalkCertificateInfo interface to access the methods of the BizTalkCertificateInfo object.

The properties of the BizTalkCertificateInfo object are shown in the following table.

Property | Type | Description
Name | BSTR | Name of the certificate. This is a read-only property.
Reference | BSTR | Reference to the certificate in the certificate store.
Store | BIZTALK_ STORE_ TYPE | Store type of the certificate.
Usage | BIZTALK_USAGE_ TYPE | Type of use for the certificate. This is a read-only property.

Remarks

This object is automatically created when a BizTalkPort or a BizTalkChannel object is instantiated with the CreatePort or the CreateChannel method of the BizTalkConfig object.

For output documents, access the BizTalkCertificateInfo object by using the EncryptionCertificateInfo property of the BizTalkPort object. For input documents, access the BizTalkCertificateInfo object by using the SignatureCertificateInfo, VerifySignatureCertificateInfo, or DecryptionCertificateInfo property of the BizTalkChannel object. To obtain the set of all existing BizTalkCertificateInfo objects, use the Certificates property of the BizTalkConfig object.

Note

  • All certificates are stored in the local computer store. To configure certificates for the S/MIME components, the script or application accessing the object model must be run in the context of a user account in the BizTalk Server Administrators group.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkCertificateInfo::Name Property [C++]

BizTalkCertificateInfo.Name Property [Visual Basic]

The Name property contains the name of the certificate.

Syntax

[C++]

Get method:

HRESULT get_Name(
    BSTR* pstrName
);

[Visual Basic]

object.Name

Parameters

[C++]

pstrName

[out, retval] Pointer to a BSTR that contains the name.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a String that contains the name.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkCertificateInfo::Reference Property [C++]

BizTalkCertificateInfo.Reference Property [Visual Basic]

The Reference property contains a reference to the certificate in the certificate store.

Syntax

[C++]

Get method:

HRESULT get_Reference(
    BSTR* pstrReference
);

Put method:

HRESULT put_Reference(
    BSTR strReference
);

[Visual Basic]

object.Reference

Parameters

[C++]

Get method:

pstrReference

[out, retval] Pointer to a BSTR that contains the certificate reference.

Put method:

strReference

[in] BSTR that contains the certificate reference.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

Note

  • In addition to the HRESULT values listed on the error messages page, the put method returns CryptoAPI errors. Additional information about CryptoAPI is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.
[Visual Basic]

This property returns a String that contains the certificate reference.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

A reference to a certificate should be obtained by using the Certificates property on the BizTalkConfig object.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkCertificateInfo::Store Property [C++]

BizTalkCertificateInfo.Store Property [Visual Basic]

The Store property contains the store type for the certificate.

Syntax

[C++]

Get method:

HRESULT get_Store(
    BIZTALK_STORE_TYPE* pStoreType
);

Put method:

HRESULT put_Store(
    BIZTALK_STORE_TYPE eStoreType
);

[Visual Basic]

object.Store

Parameters

[C++]

Get method:

pStoreType

[out, retval] Pointer to an enumeration value that contains the certificate store type. Valid values are from the BIZTALK_STORE_TYPE enumeration.

Put method:

eStoreType

[in] Enumeration value that contains the certificate store type. Valid values are from the BIZTALK_STORE_TYPE enumeration.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns an enumeration value. Valid values are from the BIZTALK_STORE_TYPE enumeration.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

The store, which contains the certificate, is determined by the use of the certificate as follows:

Certificate type | Store
Decryption | MY
Encryption | BIZTALK
Signature | MY
Verify signature | BIZTALK

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkCertificateInfo::Usage Property [C++]

BizTalkCertificateInfo.Usage Property [Visual Basic]

The Usage property contains the type of use for the certificate.

Syntax

[C++]

Get method:

HRESULT get_Usage(
    BIZTALK_USAGE_TYPE* pUsageType
);

[Visual Basic]

object.Usage

Parameters

[C++]

pUsageType

[out, retval] Pointer to an enumeration value. Valid values are from the BIZTALK_USAGE_TYPE enumeration.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns an enumeration value. Valid values are from the BIZTALK_USAGE_TYPE enumeration.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkChannel Interface [C++]

BizTalkChannel Object [Visual Basic]

Use the methods and properties of the BizTalkChannel object to configure a channel for processing documents.

In C++, use the IBizTalkChannel interface to access the methods of the BizTalkChannel object.

The properties of the BizTalkChannel object are shown in the following table.

Property | Type | Description
Comments | BSTR | User comments for the object.
ControlNumberValue | BSTR | Value of the group control number.
DateModified | BSTR | Date and time at which the information in the object was created or last modified. This is a read-only property obtained from the BizTalkBase object.
DecryptionCertificateInfo | IDispatch | Information about the certificate that decrypts the input document.
ExpectReceiptTimeout | long | Time, in minutes, in which to expect the receipt for the current document before treating the document as expired.
Expression | BSTR | Complete set of equations that filter the selection of the object.
Handle | long | Identifier of the object. This is a read-only property obtained from the BizTalkBase object.
InputDocument | long | Handle to the input BizTalkDocument object. This is a required property.
IsReceiptChannel | VARIANT_BOOL | Flag that indicates whether the object is a receipt channel.
LoggingInfo | IDispatch | Information about logging.
MapContent | BSTR | Contents of the map that provide instructions on how the input document in the format used by the source organization is to be rendered in the format used by the destination organization, if different. This is a read-only property.
MapReference | BSTR | Full Web Distributed Authoring and Versioning (WebDAV) URL of the map that provides instructions on how the input document in the format used by the source organization is to be rendered in the format used by the destination organization, if different. This is a required property if the InputDocument property is different from the OutputDocument property.
Name | BSTR | Name of the object. This is a required property obtained from the BizTalkBase object.
OutputDocument | long | Handle to the output BizTalkDocument object. This is a required property.
Port | long | Associated BizTalkPort object. Either the Port or the PortGroup property must be specified.
PortGroup | long | Associated BizTalkPortGroup object. Either the Port or the PortGroup property must be specified.
ReceiptChannel | long | Handle to the receipt channel for this object.
RetryCount | long | Number of times to retry submitting a document when there is a failure to connect to the destination.
RetryInterval | long | Interval between attempts to resubmit a document when there is a failure to connect to the destination. This value is specified in minutes.
SignatureCertificateInfo | IDispatch | Information about the certificate that signs the output document.
SourceEndpoint | IDispatch | Information about the source.
TrackFields | IDispatch | Dictionary object that stores additional custom tracking fields used to track interchange data for the BizTalkDocument object for the associated BizTalkChannel object.
VerifySignatureCertificateInfo | IDispatch | Information about the certificate that verifies the signature of the input document.

The methods of the BizTalkChannel object are shown in the following table.

Method | Description
Clear | Clears the object in memory. All member variables of the object in memory are initialized to their default values. This method is obtained from the BizTalkBase object.
Create | Creates a new object in the database. This method is obtained from the BizTalkBase object.
GetConfigComponent | Reads the CLSID of the component associated with the BizTalkPort object.
GetConfigData | Gets the configuration associated with the specified BizTalkPort object.
Load | Loads an object in memory. This method is obtained from the BizTalkBase object.
LoadByName | Loads an object by name in memory. This method is obtained from the BizTalkBase object.
Remove | Removes the object. This method is obtained from the BizTalkBase object.
Save | Saves the object to the database. This method is obtained from the BizTalkBase object.
SetConfigComponent | Sets the CLSID of the component associated with the BizTalkPort object.
SetConfigData | Sets the configuration information for the associated BizTalkPort object.

Remarks

A BizTalkChannel object requires an associated complete BizTalkPort object. One or more BizTalkChannel objects can be associated with a BizTalkPort object. A BizTalkChannel object can be associated with only one input BizTalkDocument object and one output BizTalkDocument object; however, a BizTalkDocument object can be associated with more than one BizTalkChannel object.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Channels

Document Processing


IBizTalkChannel::Comments Property [C++]

BizTalkChannel.Comments Property [Visual Basic]

The Comments property contains the user comments for the object.

Syntax

[C++]

Get method:

HRESULT get_Comments(
    BSTR* pstrComments
);

Put method:

HRESULT put_Comments(
    BSTR strComments
);

[Visual Basic]

object.Comments

Parameters

[C++]

Get method:

pstrComments

[out, retval] Pointer to a BSTR that contains the comments.

Put method:

strComments

[in] BSTR that contains the comments.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a String that contains the comments.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkChannel::ControlNumberValue Property [C++]

BizTalkChannel.ControlNumberValue Property [Visual Basic]

The ControlNumberValue property contains the value of the group control number.

Syntax

[C++]

Get method:

HRESULT get_ControlNumberValue(
    BSTR* pstrControlNumberValue
);

Put method:

HRESULT put_ControlNumberValue(
    BSTR strControlNumberValue
);

[Visual Basic]

object.ControlNumberValue

Parameters

[C++]

Get method:

pstrControlNumberValue

[out, retval] Pointer to a BSTR that contains the control number.

Put method:

strControlNumberValue

[in] BSTR that contains the control number.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This method returns a String that contains the control number.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

The ControlNumberValue property must contain a value between 1 and 999999999.

If the Format property of the BizTalkEnvelope object for the associated BizTalkPort object is set to X12, EDIFACT, or Custom, this property is required.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkChannel::DecryptionCertificateInfo Property [C++]

BizTalkChannel.DecryptionCertificateInfo Property [Visual Basic]

The DecryptionCertificateInfo property contains information about the certificate that decrypts the input document. This information includes the Name, Reference, Store, and Usage properties and is created and stored in memory in the BizTalkCertificateInfo object.

Syntax

[C++]

Get method:

HRESULT get_DecryptionCertificateInfo(
    IDispatch** ppDecryptionCertificateInfoDisp
);

Putref method:

HRESULT putref_DecryptionCertificateInfo(
    IDispatch* pDecryptionCertificateInfoDisp
);

[Visual Basic]

object.DecryptionCertificateInfo

Parameters

[C++]

Get method:

ppDecryptionCertificateInfoDisp

[out, retval] Address of a pointer to an IDispatch interface that contains the certificate information.

Putref method:

pDecryptionCertificateInfoDisp

[in] Pointer to an IDispatch interface that contains the certificate information.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns an Object that contains the certificate information.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkChannel::ExpectReceiptTimeout Property [C++]

BizTalkChannel.ExpectReceiptTimeout Property [Visual Basic]

The ExpectReceiptTimeout property contains the value of the time, in minutes, in which to expect the receipt for the current document before treating the document as expired.

Syntax

[C++]

Get method:

HRESULT get_ExpectReceiptTimeout(
    long* plMinutes
);

Put method:

HRESULT put_ExpectReceiptTimeout(
    long lMinutes
);

[Visual Basic]

object.ExpectReceiptTimeout

Parameters

[C++]

Get method:

plMinutes

[out, retval] Pointer to a long that contains the minutes.

Put method:

lMinutes

[in] Long that contains the minutes.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a Long that contains the minutes.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkChannel::Expression Property [C++]

BizTalkChannel.Expression Property [Visual Basic]

The Expression property contains an expression that filters the selection of the BizTalkChannel object. If the expression evaluates to true, the server selects the channel for processing the document.

Syntax

[C++]

Get method:

HRESULT get_Expression(
    BSTR* pstrExpression
);

Put method:

HRESULT put_Expression(
    BSTR strExpression
);

[Visual Basic]

object.Expression

Parameters

[C++]

Get method:

pstrExpression

[out, retval] Pointer to a BSTR that contains the XPath expression.

Put method:

strExpression

[in] BSTR that contains the XPath expression.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This method returns a String that contains the expression.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

The XPath expression must be based on the input document specification set in the InputDocument property.

Note

  • If the specification field that you are using to create an expression has a Boolean data type, you cannot use the text strings "true" or "false" as the expression value. You must use a numerical value instead: "-1" for true and "0" for false. For example, to filter a channel so it processes only approved purchase orders, your expression might look like this:
    Channel1.Expression = "/PORequest/Total[IsApproved = -1]"

    This sample assumes that the input document specification contains a Total subelement with a Boolean IsApproved field.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topic

Channel Filtering


IBizTalkChannel::GetConfigComponent Method [C++]

BizTalkChannel.GetConfigComponent Method [Visual Basic]

The GetConfigComponent method retrieves the CLSID of the component associated with the BizTalkPort object.

Syntax

[C++]

HRESULT GetConfigComponent(
    BIZTALK_CONFIGDATA_TYPE eConfigType,
    long lPortHandle,
    BSTR* pstrCLSID
);

[Visual Basic]

object.GetConfigComponent( _
    eConfigType As BIZTALK_CONFIGDATA_TYPE, _
    lPortHandle As Long _
)

Parameters

[C++]

eConfigType

[in] Enumeration value. Valid values are from the BIZTALK_CONFIGDATA_TYPE enumeration.

lPortHandle

[in] Long that contains the handle to the BizTalkPort object.

pstrCLSID

[out, retval] Pointer to a BSTR that contains the CLSID of the component.

[Visual Basic]

eConfigType

Enumeration value. Valid values are from the BIZTALK_CONFIGDATA_TYPE enumeration.

lPortHandle

Long that contains the handle.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

Note

In addition to the HRESULT values listed on the error messages page, this method returns OLEDB provider errors. Additional information about OLEDB is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

[Visual Basic]

This method returns a String that contains the CLSID of the component.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

If the eConfigType parameter is set to BIZTALK_CONFIGDATA_TYPE_SIGNATURE and the associated BizTalkPort object has both the EncryptionType and SignatureType properties set to S/MIME, this method returns an empty string ("").

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkChannel::GetConfigData Method [C++]

BizTalkChannel.GetConfigData Method [Visual Basic]

The GetConfigData method gets the configuration associated with the specified BizTalkPort object.

Syntax

[C++]

HRESULT GetConfigData(
    BIZTALK_CONFIGDATA_TYPE eConfigType,
    long lPortHandle,
    VARIANT* pvarType,
    VARIANT* pvarDictionary
);

[Visual Basic]

object.GetConfigData( _
    eConfigType As BIZTALK_CONFIGDATA_TYPE, _
    lPortHandle As Long, _
    pvarType As Variant _
)

Parameters

[C++]

eConfigType

[in] Enumeration value. Valid values are from the BIZTALK_CONFIGDATA_TYPE enumeration.

lPortHandle

[in] Long that identifies the handle to the associated BizTalkPort object.

pvarType

[in, out] Pointer to a VARIANT that contains the transport type.

pvarDictionary

[in, out] Pointer to a VARIANT that contains a pointer to the IDictionary interface of an object that contains the primary transport configuration information.

[Visual Basic]

eConfigType

[in] Enumeration value. Valid values are from the BIZTALK_CONFIGDATA_TYPE enumeration.

lPortHandle

Long that identifies the handle to the associated BizTalkPort object.

pvarType

Variant that contains the transport type.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

Note

In addition to the HRESULT values listed on the error messages page, this method returns OLEDB provider errors. Additional information about OLEDB is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

[Visual Basic]

This method returns a CDictionary object that contains the primary transport configuration information.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

The Dictionary object returned by this method has specific string qualifiers used for EDIFACT and X12. The following tables describe these strings.

EDIFACT

Qualifier string | Description
SerializerEdifact_SenderIntID | Interchange sender internal identification
SerializerEdifact_SenderIntSubID | Interchange sender internal subidentification
SerializerEdifact_RecipientIntID | Interchange recipient internal identification
SerializerEdifact_RecipientIntSubID | Interchange recipient internal subidentification
SerializerEdifact_RecipientRefPwd | Recipient reference/password
SerializerEdifact_RecipientRefPwdQual | Recipient reference/password qualifier
SerializerEdifact_ApplicationRef | Application reference
SerializerEdifact_ProcPriCode | Processing priority code
SerializerEdifact_AckRequest | Acknowledgment request
SerializerEdifact_AgreementID | Interchange agreement identifier
SerializerEdifact_TestInd | Test indicator
SerializerEdifact_UNACtrl | "Send UNA Always" or "Send UNA Only When Required"
SerializerEdifact_SyntaxID | Syntax identifier

X12

Qualifier string | Description
SerializerX12_AuthInfoQual | Authorization information qualifier
SerializerX12_AuthInfo | Authorization information
SerializerX12_SecInfoQual | Security information qualifier
SerializerX12_SecInfo | Security information
SerializerX12_CtrlStdID | Interchange control standards identifier
SerializerX12_CtrlVerNum | Interchange control version number
SerializerX12_AckRequired | Acknowledgment required
SerializerX12_UseInd | Usage indicator

Note

  • For more information about the EDIFACT standard, see the United Nations Economic Commission for Europe Web site (www.unece.org).

  • For more information about the X12 standard, see the Data Interchange Standards Association Web site (www.disa.org).

If you override the transport properties of a BizTalkPort object with this method and then change the transport properties in that BizTalkPort object, you must call this method again.

If the eConfigType parameter is set to BIZTALK_CONFIGDATA_TYPE_SIGNATURE and the associated BizTalkPort object has both the EncryptionType and SignatureType properties set to S/MIME, this method returns an empty Dictionary object.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkChannel::InputDocument Property [C++]

BizTalkChannel.InputDocument Property [Visual Basic]

The InputDocument property contains the handle to the BizTalkDocument object that describes the input document specification.

Syntax

[C++]

Get method:

HRESULT get_InputDocument(
    long* plInDocHandle
);

Put method:

HRESULT put_InputDocument(
    long lInDocHandle
);

[Visual Basic]

object.InputDocument

Parameters

[C++]

Get method:

plInDocHandle

[out, retval] Pointer to a long that contains the handle to the input BizTalkDocument object.

Put method:

lInDocHandle

[in] Long that contains the handle to the input BizTalkDocument object.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a Long that contains the handle to the input BizTalkDocument object.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a required property.

This property cannot be changed after the Create or the Save method is called.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Configuring

Document Definitions

Document Processing


IBizTalkChannel::IsReceiptChannel Property [C++]

BizTalkChannel.IsReceiptChannel Property [Visual Basic]

The IsReceiptChannel property contains a flag that indicates whether the object is a receipt channel.

Syntax

[C++]

Get method:

HRESULT get_IsReceiptChannel(
    VARIANT_BOOL* pbIsReceiptChannel
);

Put method:

HRESULT put_IsReceiptChannel(
    VARIANT_BOOL bIsReceiptChannel
);

[Visual Basic]

object.IsReceiptChannel

Parameters

[C++]

Get method:

pbIsReceiptChannel

[out, retval] Pointer to a VARIANT_BOOL that contains the flag. A value of VARIANT_TRUE indicates that this channel is used as a receipt channel. A value of VARIANT_FALSE indicates that this channel is not used as a receipt channel.

Put method:

bIsReceiptChannel

[in] VARIANT_BOOL that contains the flag. A value of VARIANT_TRUE indicates that this channel is used as a receipt channel. A value of VARIANT_FALSE indicates that this channel is not used as a receipt channel.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a Variant that indicates whether the channel is used as a receipt channel.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topic

ReceiptChannel


IBizTalkChannel::LoggingInfo Property [C++]

BizTalkChannel.LoggingInfo Property [Visual Basic]

The LoggingInfo property contains information about logging the document. This information includes the LogNativeInputDocument, LogNativeOutputDocument, LogXMLInputDocument, and LogXMLOutputDocument properties and is created and stored in memory in the BizTalkLoggingInfo object.

Syntax

[C++]

Get method:

HRESULT get_LoggingInfo(
    IDispatch** ppLoggingInfoDisp
);

Putref method:

HRESULT putref_LoggingInfo(
    IDispatch* pLoggingInfoDisp
);

[Visual Basic]

object.LoggingInfo

Parameters

[C++]

Get method:

ppLoggingInfoDisp

[out, retval] Address of a pointer to an IDispatch interface that contains the logging fields.

Putref method:

pLoggingInfoDisp

[in] Pointer to an IDispatch interface that contains the logging fields.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns an Object that contains the logging fields.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topic

Document Storage


IBizTalkChannel::MapContent Property [C++]

BizTalkChannel.MapContent Property [Visual Basic]

The MapContent property contains the contents of the map that provide instructions on how the input document in the format used by the source organization is to be rendered in the format used by the destination organization, if different.

Syntax

[C++]

Get method:

HRESULT get_MapContent(
    BSTR* pstrMapContent
);

[Visual Basic]

object.MapContent

Parameters

[C++]

pstrMapContent

[in] BSTR that contains the map contents.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a String that contains the map contents.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property. The Create and Save methods copy the text of the map specified by the MapReference property to this string, if empty.

Once you have created or saved a BizTalkChannel object with MapReference set to a map, any changes you make to the content of the referenced map are not automatically updated on the referring BizTalkChannel object. To update the BizTalkChannel object that refers to the revised map, you must save the map, reset the MapReference property of the BizTalkChannel object to its current value, and then call Save on the referring BizTalkChannel object.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkChannel::MapReference Property [C++]

BizTalkChannel.MapReference Property [Visual Basic]

The MapReference property contains the full Web Distributed Authoring and Versioning (WebDAV) URL of the map that provides instructions on how the input document in the format used by the source organization is to be rendered in the format used by the destination organization, if different.

Syntax

[C++]

Get method:

HRESULT get_MapReference(
    BSTR* pstrReference
);

Put method:

HRESULT put_MapReference(
    BSTR strReference
);

[Visual Basic]

object.MapReference

Parameters

[C++]

Get method:

pstrReference

[out, retval] Pointer to a BSTR that contains the map name.

Put method:

strReference

[in] BSTR that contains the map name.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a String that contains the map name.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a required property if the InputDocument property refers to a different document specification than the OutputDocument property.

Once you have created or saved a BizTalkChannel object with MapReference set to a map, any changes you make to the content of the referenced map are not automatically updated on the referring BizTalkChannel object. To update the BizTalkChannel object that refers to the revised map, you must save the map, reset the MapReference property of the BizTalkChannel object to its current value, and then call Save on the referring BizTalkChannel object.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkChannel::OutputDocument Property [C++]

BizTalkChannel.OutputDocument Property [Visual Basic]

The OutputDocument property contains the handle to the BizTalkDocument object that describes the output document specification.

Syntax

[C++]

Get method:

HRESULT get_OutputDocument(
    long* plOutDocHandle
);

Put method:

HRESULT put_OutputDocument(
    long lOutDocHandle
);

[Visual Basic]

object.OutputDocument

Parameters

[C++]

Get method:

plOutDocHandle

[out, retval] Pointer to a long that contains the handle to the output BizTalkDocument object.

Put method:

lOutDocHandle

[in] Long that contains the handle to the output BizTalkDocument object.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a Long that contains the handle to the output BizTalkDocument object.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a required property. This property cannot be changed after the Create or the Save method is called.

If the Openness property of the associated BizTalkEndPoint object is set to BIZTALK_OPENNESS_TYPE_SOURCE, the InputDocument property can identify an input BizTalkDocument object that has an X12 or an EDIFACT specification. If it does, however, OutputDocument must not identify a BizTalkDocument object that has an X12 or an EDIFACT specification.

If the Openness property of the associated BizTalkEndPoint object is set to BIZTALK_OPENNESS_TYPE_DESTINATION, the OutputDocument property for this BizTalkChannel object must not identify an output BizTalkDocument object that has an X12 or an EDIFACT specification.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topic

Document Definitions


IBizTalkChannel::Port Property [C++]

BizTalkChannel.Port Property [Visual Basic]

The Port property contains the handle to the associated BizTalkPort object.

Syntax

[C++]

Get method:

HRESULT get_Port(
    long* plPortHandle
);

Put method:

HRESULT put_Port(
    long lPortHandle
);

[Visual Basic]

object.Port

Parameters

[C++]

Get method:

plPortHandle

[out, retval] Pointer to a long that contains the handle to the BizTalkPort object.

Put method:

lPortHandle

[in] Long that contains the handle to the BizTalkPort object.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a Long that contains the handle to the BizTalkPort object.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

The following constraints are enforced:

  • Either the Port or the PortGroup property must be specified for a channel.

  • This property cannot be changed after the Create or the Save method is called.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topic

Messaging Ports


IBizTalkChannel::PortGroup Property [C++]

BizTalkChannel.PortGroup Property [Visual Basic]

The PortGroup property contains the handle to the associated BizTalkPortGroup object.

Syntax

[C++]

Get method:

HRESULT get_PortGroup(
    long* plPortGroupHandle
);

Put method:

HRESULT put_PortGroup(
    long lPortGroupHandle
);

[Visual Basic]

object.PortGroup

Parameters

[C++]

Get method:

plPortGroupHandle

[out, retval] Pointer to a long that contains the handle to the associated BizTalkPortGroup object.

Put method:

lPortGroupHandle

[in] Long that contains the handle to the associated BizTalkPortGroup object.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a Long that contains the handle to the associated BizTalkPortGroup object.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

The following constraints are enforced:

  • Either the Port property or PortGroup must be specified for a channel.

  • This property cannot be changed after the Create or the Save method is called.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topic

Port Groups


IBizTalkChannel::ReceiptChannel Property [C++]

BizTalkChannel.ReceiptChannel Property [Visual Basic]

The ReceiptChannel property contains the handle to the receipt channel for this object.

Syntax

[C++]

Get method:

HRESULT get_ReceiptChannel(
    long* plReceiptChannelHandle
);

Put method:

HRESULT put_ReceiptChannel(
    long lReceiptChannelHandle
);

[Visual Basic]

object.ReceiptChannel

Parameters

[C++]

Get method:

plReceiptChannelHandle

[out, retval] Pointer to a long that contains the handle.

Put method:

lReceiptChannelHandle

[in] Long that contains the handle.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a Long that contains the handle to the receipt channel.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

A BizTalkChannel object can specify a receipt channel only if it is not a receipt channel itself. The channel specified as the receipt channel must have the IsReceiptChannel property set to TRUE. In addition, the receipt channel must use a messaging port with a DestinationEndpoint that is the same as the SourceEndpoint on the channel using the receipt channel. This allows the receipt channel to send a receipt to the original source of the document.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkChannel::RetryCount Property [C++]

BizTalkChannel.RetryCount Property [Visual Basic]

The RetryCount property specifies the number of times to retry submitting a document when a destination connection failure occurs.

Syntax

[C++]

Get method:

HRESULT get_RetryCount(
    long* plCount
);

Put method:

HRESULT put_RetryCount(
    long lCount
);

[Visual Basic]

object.RetryCount

Parameters

[C++]

Get method:

plCount

[out, retval] Pointer to a long that contains the number of retries.

Put method:

lCount

[in] Long that contains the number of retries.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a Long that contains the number of retries.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

The RetryCount property must contain a value between 0 and 999. The default value is 3 retries.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkChannel::RetryInterval Property [C++]

BizTalkChannel.RetryInterval Property [Visual Basic]

The RetryInterval property specifies the amount of time, in minutes, between retry attempts when a destination connection failure occurs during document submission.

Syntax

[C++]

Get method:

HRESULT get_RetryInterval(
    long* pInterval
);

Put method:

HRESULT put_RetryInterval(
    long lInterval
);

[Visual Basic]

object.RetryInterval

Parameters

[C++]

Get method:

pInterval

[out, retval] Pointer to a long that contains the retry interval, in minutes.

Put method:

lInterval

[in] Long that contains the retry interval, in minutes.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a Long that contains the retry interval, in minutes.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

The RetryInterval property must contain a value between 1 and 63999. The default value is 5 minutes.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkChannel::SetConfigComponent Method [C++]

BizTalkChannel.SetConfigComponent Method [Visual Basic]

The SetConfigComponent method sets the CLSID of the component associated with the BizTalkPort object.

Syntax

[C++]

HRESULT SetConfigComponent(
    BIZTALK_CONFIGDATA_TYPE eConfigType,
    long lPortHandle,
    BSTR strCLSID
);

[Visual Basic]

object.SetConfigComponent( _
    eConfigType As BIZTALK_CONFIGDATA_TYPE, _
    lPortHandle As Long, _
    strCLSID As String _
)

Parameters

[C++]

eConfigType

[in] Enumeration value. Valid values are from the BIZTALK_CONFIGDATA_TYPE enumeration. The BIZTALK_CONFIGDATA_TYPE_PRIMARYTRANSPORT and BIZTALK_CONFIGDATA_TYPE_SECONDARYTRANSPORT enumeration values cannot be used with this method.

lPortHandle

[in] Long that contains the handle.

strCLSID

[in] BSTR that contains the CLSID of the component.

[Visual Basic]

eConfigType

Enumeration value. Valid values are from the BIZTALK_CONFIGDATA_TYPE enumeration. The BIZTALK_CONFIGDATA_TYPE_PRIMARYTRANSPORT and BIZTALK_CONFIGDATA_TYPE_SECONDARYTRANSPORT enumeration values cannot be used with this method.

lPortHandle

Long that contains the handle.

strCLSID

String that contains the CLSID of the component.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkChannel::SetConfigData Method [C++]

BizTalkChannel.SetConfigData Method [Visual Basic]

The SetConfigData method sets the configuration information for the BizTalkPort object.

Syntax

[C++]

HRESULT SetConfigData(

    BIZTALK_CONFIGDATA_TYPE eConfigType,
    long lConfigDataHandle,
    IDispatch* pConfigDataDisp
);

[Visual Basic]

object.SetConfigData( _

    eConfigType As BIZTALK_CONFIGDATA_TYPE, _
    lConfigDataHandle As Long, _
    pConfigDataDisp As Object _
)

Parameters

[C++]

eConfigType

[in] Enumeration value. Valid values are from the BIZTALK_CONFIGDATA_TYPE enumeration.

lConfigDataHandle

[in] Long that identifies the handle to the associated BizTalkPort object.

pConfigDataDisp

[in] Pointer to the IDictionary interface of an object that contains information about the component specified in the eConfigType parameter.

[Visual Basic]

eConfigType

Enumeration value. Valid values are from the BIZTALK_CONFIGDATA_TYPE enumeration.

lConfigDataHandle

Long that identifies the handle to the associated BizTalkPort object.

pConfigDataDisp

CDictionary object that contains information about the component specified in the eConfigType parameter.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

The Dictionary object passed to this method has specific string qualifiers used for EDIFACT and X12. For a description of these qualifiers, see the GetConfigData Method.

When using the BIZTALK_CONFIGDATA_TYPE_PRIMARYTRANSPORT or BIZTALK_CONFIGDATA_TYPE_SECONDARYTRANSPORT enumeration value, the content of the transport dictionary varies according to the transport protocol used. The following tables list the transport dictionary fields for each protocol.

HTTP and HTTPS

Field name | Data type | Required | Description
URL | String | Yes | URL of the document destination.
ContentType | String | No | Value for the Content-Type HTTP/HTTPS property that appears in HTTP headers during transmission. The default value is an empty string ("").
ClientCert | String | No | Reference to the certificate used with SSL connections using HTTPS. The default value is an empty string ("").
ProxyName | String | No | URL of the proxy server used when sending documents outside a firewall.
ProxyPort | Integer | No | Port number used by the proxy server.
UseProxy | Boolean | No | Value that indicates whether the proxy server is used. The default value is True.

Local File

Field name | Data type | Required | Description
Filename | String | Yes | Name and path of the file to be created.
CopyMode | Integer | No | Value that indicates how the file should be written. Use a value of 0 for overwrite mode, a value of 1 for append mode, and a value of 2 to create a new file. The default value is append mode (1).
UserName | String | No | Windows NT username needed to access a file share. The default value is an empty string ("").
Password | String | No | Windows NT username needed to access a file share. The default value is an empty string ("").

Message Queuing

Field name | Data type | Required | Description
QueueName | String | Yes | Name of the Messaging Queue to which the document is sent.
MessageLabel | String | Yes | Value specified in the message label field on the queue.
Priority | Integer | No | Priority of the message placed in the queue. This must be a value between 0 and 7, where a higher value indicates a higher priority. The default value is 3
AuthLevel | Integer | No | Value indicating whether the message needs to be authenticated using a digital signature. Use a value of 0 to bypass authentication. A value of 1 indicates that authentication will be used. The default value is 0.
Delivery | Integer | No | Value indicating how a message is delivered to a queue. Use a value of 1 to indicate that the message should be backed up until it is delivered to the queue. A value of 0 indicates that the message is only resident in memory. The default value is 0.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkChannel::SignatureCertificateInfo Property [C++]

BizTalkChannel.SignatureCertificateInfo Property [Visual Basic]

The SignatureCertificateInfo property contains information about the certificate that signs the output document. This information includes the Name, Reference, Store, and Usage properties and is created and stored in memory in the BizTalkCertificateInfo object.

Syntax

[C++]

Get method:

HRESULT get_SignatureCertificateInfo(
    IDispatch** ppSignatureCertificateInfoDisp
);

Putref method:

HRESULT putref_SignatureCertificateInfo(
    IDispatch* pSignatureCertificateInfoDisp
);

[Visual Basic]

object.SignatureCertificateInfo

Parameters

[C++]

Get method:

ppSignatureCertificateInfoDisp

[out, retval] Address of a pointer to an IDispatch interface that contains the certificate information.

Putref method:

pSignatureCertificateInfoDisp

[in] Pointer to an IDispatch interface that contains the certificate information.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a BizTalkCertificateInfo object that contains the certificate information.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkChannel::SourceEndpoint Property [C++]

BizTalkChannel.SourceEndpoint Property [Visual Basic]

The SourceEndpoint property contains information about the source. This information includes the Alias, Application, and Organization properties and is created and stored in memory in the BizTalkEndPoint object.

Syntax

[C++]

Get method:

HRESULT get_SourceEndpoint(
    IDispatch** ppSrcEndpointDisp
);

Putref method:

HRESULT putref_SourceEndpoint(
     IDispatch* pSrcEndpointDisp
);

[Visual Basic]

object.SourceEndpoint

Parameters

[C++]

Get method:

ppSrcEndpointDisp

[out, retval] Address of a pointer to an IDispatch interface that contains information about the source.

Putref method:

pSrcEndpointDisp

[in] Pointer to an IDispatch interface that contains information about the source.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns an Object that contains information about the source.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkChannel::TrackFields Property [C++]

BizTalkChannel.TrackFields Property [Visual Basic]

The TrackFields property identifies the Dictionary object that points to the specification that contains fields to track interchange data on input documents for this BizTalkChannel object. These tracking fields override the fields set in the TrackFields property on the BizTalkDocument object.

Syntax

[C++]

Get method:

HRESULT get_TrackFields(
    IDispatch** ppTrackFieldsDisp
);

Putref method:

HRESULT putref_TrackFields(
    IDispatch* pTrackFieldsDisp
);

[Visual Basic]

object.TrackFields

Parameters

[C++]

Get method:

ppTrackFieldsDisp

[out, retval] Address of a pointer to the IDictionary interface of an object that contains the custom tracking fields.

Putref method:

pTrackFieldsDisp

[in] Pointer to the IDictionary interface of an object that contains the custom tracking fields.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a CDictionary object that contains the custom tracking fields.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

The fields in the Dictionary object must contain an XPath value that identifies the field to be tracked in a document. By default, the Dictionary object provides eight predefined fields for tracking data in a document. These predefined fields consist of two fields for each of the following data types: integer, real, date, and string. If additional fields are required for tracking, you can use the x_custom_search field in the Dictionary object, and set the value to a SimpleList object. The SimpleList object contains a list of XPaths pointing to the additional tracking fields. XPath values can be added to and deleted from this list using the Add and Delete methods.

The following table shows the field names in the Dictionary object for TrackFields:

Field Name | Field type
i_value1 | Integer value
i_value2 | Integer value
r_value1 | Real value
r_value2 | Real value
d_value1 | Date value
d_value2 | Date value
s_value1 | String value
s_value2 | String value
x_custom_search | A list to return one or more additional data items

For more information about XPath expressions, go to the Microsoft Web site (msdn.microsoft.com/library/default.asp) and search for XPath.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topic

Document Tracking


IBizTalkChannel::VerifySignatureCertificateInfo Property [C++]

BizTalkChannel.VerifySignatureCertificateInfo Property [Visual Basic]

The VerifySignatureCertificateInfo property contains information about the certificate that verifies the signature of the input document. This information includes the Name, Reference, Store, and Usage properties and is created and stored in memory in the BizTalkCertificateInfo object.

Syntax

[C++]

Get method:

HRESULT get_VerifySignatureCertificateInfo(
    IDispatch** ppVerifySignatureCertificateInfoDisp
);

Putref method:

HRESULT putref_VerifySignatureCertificateInfo(
    IDispatch* pVerifySignatureCertificateInfoDisp
);

[Visual Basic]

object.VerifySignatureCertificateInfo

Parameters

[C++]

Get method:

ppVerifySignatureCertificateInfoDisp

[out, retval] Address of a pointer to an IDispatch interface that contains the certificate information.

Put method:

pVerifySignatureCertificateInfoDisp

[in] Pointer to an IDispatch interface that contains the certificate information.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a BizTalkCertificateInfo object that contains the certificate information.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkConfig Interface [C++]

BizTalkConfig Object [Visual Basic]

Use the BizTalkConfig object to create channels, document specifications, envelopes, organizations, ports, and port groups.

In C++, use the IBizTalkConfig interface to access the methods of the BizTalkConfig object.

The properties of the BizTalkConfig object are shown in the following table.

Property | Data type | Description
Certificates | Object | Returns an ADO recordset that contains all specified certificates. This is a read-only property.
Channels | Object | Returns an ADO recordset that contains all BizTalkChannel objects. This is a read-only property.
Documents | Object | Returns an ADO recordset that contains all BizTalkDocument objects. This is a read-only property.
Envelopes | Object | Returns an ADO recordset that contains all BizTalkEnvelope objects.
Organizations | Object | Returns an ADO recordset that contains all BizTalkOrganization objects. This is a read-only property.
PortGroups | Object | Returns an ADO recordset that contains all BizTalkPortGroup objects. This is a read-only property.
Ports | Object | Returns an ADO recordset that contains all BizTalkPort objects. This is a read-only property.

The methods of the BizTalkConfig object are shown in the following table.

Method | Description
CreateChannel | Returns the address of a pointer to a new BizTalkChannel object.
CreateDocument | Returns the address of a pointer to a new BizTalkDocument object.
CreateEnvelope | Returns the address of a pointer to a new BizTalkEnvelope object.
CreateOrganization | Returns the address of a pointer to a new BizTalkOrganization object.
CreatePort | Returns the address of a pointer to a new BizTalkPort object.
CreatePortGroup | Returns the address of a pointer to a new BizTalkPortGroup object.

Remarks

In C++, each object created by using one of the methods of this interface inherits the following common methods from the IBizTalkBase interface. In Microsoft Visual Basic, each object created by using the methods of this class implements the following common properties and methods from the IBizTalkBase class.

  • DateModified

  • Handle

  • Name

  • Clear

  • Create

  • Load

  • LoadByName

  • Remove

  • Save

When BizTalkPort and BizTalkChannel objects are created, BizTalk Server automatically creates some associated subobjects. You can access these subobjects by using properties of the BizTalkPort and BizTalkChannel objects.

The relationship between objects, their subobjects, and the properties used to obtain the subobjects is shown in the following table.

Subobject | Associated object | Property to set
BizTalkEndPoint | BizTalkPort | DestinationEndpoint
BizTalkEndPoint | BizTalkChannel | SourceEndpoint
BizTalkLoggingInfo | BizTalkChannel | LoggingInfo
BizTalkTransportInfo | BizTalkPort | PrimaryTransport, SecondaryTransport
BizTalkServiceWindowInfo | BizTalkPort | ServiceWindowInfo
BizTalkCertificateInfo | BizTalkPort | EncryptionCertificateInfo
BizTalkCertificateInfo | BizTalkChannel | SignatureCertificateInfo, VerifySignatureCertificateInfo, or DecryptionCertificateInfo

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkConfig::Certificates Property [C++]

BizTalkConfig.Certificates Property [Visual Basic]

The Certificates property returns an ADO recordset that contains all specified certificates.

Syntax

[C++]

Get method:

HRESULT get_Certificates(
    BIZTALK_STORE_TYPE StoreType,
    BIZTALK_USAGE_TYPE UsageType,
    BSTR NamePrefix,
    IDispatch** ppCertsDisp
);

[Visual Basic]

object.Certificates( _

    StoreType As BIZTALK_STORE_TYPE, _
    UsageType As BIZTALK_USAGE_TYPE, _
    NamePrefix As String, _

)

Parameters

[C++]

StoreType

[in] Enumeration value. Valid values are from the BIZTALK_STORE_TYPE enumeration.

UsageType

[in] Enumeration value. Valid values are from the BIZTALK_USAGE_TYPE enumeration.

NamePrefix

[in] BSTR that contains a prefix used as the selection criteria for certificate names. Any certificate Name starting with this value is returned in the recordset. This value is case sensitive.

ppCertsDisp

[out, retval] Address of a pointer to an IDispatch interface that contains all specified certificates.

[Visual Basic]

StoreType

Enumeration value. Valid values are from the BIZTALK_STORE_TYPE enumeration.

UsageType

Enumeration value. Valid values are from the BIZTALK_USAGE_TYPE enumeration.

NamePrefix

String that contains a prefix used as the selection criteria for certificate names. Any certificate Name starting with this value is returned in the recordset. This value is case sensitive.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

Note

  • In addition to the HRESULT values listed on the error messages page, this method returns OLEDB provider errors. Additional information about OLEDB is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

This property returns an Object that contains all specified certificates.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property.

Each record in the ADO recordset returned by this property contains information about an existing BizTalkCertificateInfo object in the database. The fields in each record contain the following information, listed in order:

  • Name

  • Reference

  • Store

  • Usage

Additional information about Microsoft ActiveX Data Objects is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkConfig::Channels Property [C++]

BizTalkConfig.Channels Property [Visual Basic]

The Channels property returns an ADO recordset that contains all BizTalkChannel objects.

Syntax

[C++]

Get method:

HRESULT Channels(
    IDispatch** ppChannelsDisp
);

[Visual Basic]

object.Channels

Parameters

[C++]

ppChannelsDisp

[out, retval] Address of a pointer to an IDispatch interface that contains all BizTalkChannel objects.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

Note

  • In addition to the HRESULT values listed on the error messages page, this method returns OLEDB provider errors. Additional information about OLEDB is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.
[Visual Basic]

This property returns an Object that contains all BizTalkChannel objects.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property.

Each record in the ADO recordset returned by this property contains information about an existing BizTalkChannel object in the database. The fields in each record contain the following information, listed in order:

  • Handle

  • Name

  • DateModified

Additional information about Microsoft ActiveX Data Objects is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkConfig::CreateChannel Method [C++]

BizTalkConfig.CreateChannel Method [Visual Basic]

[C++]

The CreateChannel method returns the address of a pointer to a new BizTalkChannel object.

[Visual Basic]

The CreateChannel method returns a new BizTalkChannel object.

Syntax

[C++]

HRESULT CreateChannel(
    IDispatch** ppChannelDisp
);

[Visual Basic]

object.CreateChannel()

Parameters

[C++]

ppChannelDisp

[out, retval] Address of a pointer to an IDispatch interface that contains a new BizTalkChannel object.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This method returns a new BizTalkChannel object.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkConfig::CreateDocument Method [C++]

BizTalkConfig.CreateDocument Method [Visual Basic]

[C++]

The CreateDocument method returns the address of a pointer to a new BizTalkDocument object.

[Visual Basic]

The CreateDocument method returns a new BizTalkDocument object.

Syntax

[C++]

HRESULT CreateDocument(
    IDispatch** ppDocumentDisp
);

[Visual Basic]

object.CreateDocument()

Parameters

[C++]

ppDocumentDisp

[out, retval] Address of a pointer to an IDispatch interface that contains a new BizTalkDocument object.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This method returns a new BizTalkDocument object.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkConfig::CreateEnvelope Method [C++]

BizTalkConfig.CreateEnvelope Method [Visual Basic]

[C++]

The CreateEnvelope method returns the address of a pointer to a new BizTalkEnvelope object.

[Visual Basic]

The CreateEnvelope method returns a new BizTalkEnvelope object.

Syntax

[C++]

HRESULT CreateEnvelope(
    IDispatch** ppEnvelopeDisp
);

[Visual Basic]

object.CreateEnvelope()

Parameters

[C++]

ppEnvelopeDisp

[out, retval] Address of a pointer to an IDispatch interface that contains a new BizTalkEnvelope object.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This method returns a new BizTalkEnvelope object.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkConfig::CreateOrganization Method [C++]

BizTalkConfig.CreateOrganization Method [Visual Basic]

[C++]

The CreateOrganization method returns the address of a pointer to a new BizTalkOrganization object.

[Visual Basic]

The CreateOrganization method returns a new BizTalkOrganization object.

Syntax

[C++]

HRESULT CreateOrganization(
    IDispatch** ppOrganizationDisp
);

[Visual Basic]

object.CreateOrganization()

Parameters

[C++]

ppOrganizationDisp

[out, retval] Address of a pointer to an IDispatch interface that contains a new BizTalkOrganization object.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This method returns a new BizTalkOrganization object.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkConfig::CreatePort Method [C++]

BizTalkConfig.CreatePort Method [Visual Basic]

[C++]

The CreatePort method returns the address of a pointer to a new BizTalkPort object.

[Visual Basic]

The CreatePort method returns a new BizTalkPort object.

Syntax

[C++]

HRESULT CreatePort(
    IDispatch** ppPortDisp
);

[Visual Basic]

object.CreatePort()

Parameters

[C++]

ppPortDisp

[out, retval] Address of a pointer to an IDispatch interface that contains a new BizTalkPort object.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This method returns a new BizTalkPort object.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkConfig::CreatePortGroup Method [C++]

BizTalkConfig.CreatePortGroup Method [Visual Basic]

[C++]

The CreatePortGroup method returns the address of a pointer to a new BizTalkPortGroup object.

[Visual Basic]

The CreatePortGroup method returns a new BizTalkPortGroup object.

Syntax

[C++]

HRESULT CreatePortGroup(
    IDispatch** ppPortGroupDisp
);

[Visual Basic]

object.CreatePortGroup()

Parameters

[C++]

ppPortGroupDisp

[out, retval] Address of a pointer to an IDispatch interface that contains a new BizTalkPortGroup object.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This method returns a new BizTalkPortGroup object.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkConfig::Documents Property [C++]

BizTalkConfig.Documents Property [Visual Basic]

The Documents property returns an ADO recordset that contains all BizTalkDocument objects.

Syntax

[C++]

Get method:

HRESULT Documents(
    IDispatch** ppDocumentsDisp
);

[Visual Basic]

object.Documents

Parameters

[C++]

ppDocumentsDisp

[out, retval] Address of a pointer to an IDispatch interface that contains all BizTalkDocument objects.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

Note

  • In addition to the HRESULT values listed on the error messages page, this method returns OLEDB provider errors. Additional information about OLEDB is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.
[Visual Basic]

This property returns an Object that contains all BizTalkDocument objects.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property.

Each record in the ADO recordset returned by this property contains information about an existing BizTalkDocument object in the database. The fields in each record contain the following information, listed in order:

  • Handle

  • Name

  • DateModified

Additional information about Microsoft ActiveX Data Objects is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkConfig::Envelopes Property [C++]

BizTalkConfig.Envelopes Property [Visual Basic]

The Envelopes property returns an ADO recordset that contains all BizTalkEnvelope objects.

Syntax

[C++]

Get method:

HRESULT Envelopes(
    IDispatch** ppEnvelopesDisp
);

[Visual Basic]

object.Envelopes

Parameters

[C++]

ppEnvelopesDisp

[out, retval] Address of a pointer to an IDispatch interface that contains all BizTalkEnvelope objects.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

Note

  • In addition to the HRESULT values listed on the error messages page, this method returns OLEDB provider errors. Additional information about OLEDB is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.
[Visual Basic]

This property returns an Object that contains all BizTalkEnvelope objects.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property.

Each record in the ADO recordset returned by this property contains information about an existing BizTalkEnvelope object in the database. The fields in each record contain the following information, listed in order:

  • Handle

  • Name

  • DateModified

  • Format

Additional information about Microsoft ActiveX Data Objects is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkConfig::Organizations Property [C++]

BizTalkConfig.Organizations Property [Visual Basic]

The Organizations property returns an ADO recordset that contains all BizTalkOrganization objects.

Syntax

[C++]

Get method:

HRESULT Organizations(
    IDispatch** ppOrganizationsDisp
);

[Visual Basic]

object.Organizations

Parameters

[C++]

ppOrganizationsDisp

[out, retval] Address of a pointer to an IDispatch interface that contains all BizTalkOrganization objects.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

Note

  • In addition to the HRESULT values listed on the error messages page, this method returns OLEDB provider errors. Additional information about OLEDB is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.
[Visual Basic]

This property returns an Object that contains all BizTalkOrganization objects.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property.

Each record in the ADO recordset returned by this property contains information about an existing BizTalkOrganization object in the database. The fields in each record contain the following information, listed in order:

  • Handle

  • Name

  • DateModified

  • IsDefault

Additional information about Microsoft ActiveX Data Objects is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkConfig::PortGroups Property [C++]

BizTalkConfig.PortGroups Property [Visual Basic]

The PortGroups property returns an ADO recordset that contains all BizTalkPortGroup objects.

Syntax

[C++]

HRESULT PortGroups(
    IDispatch** ppPortGroupsDisp
);

[Visual Basic]

object.PortGroups

Parameters

[C++]

ppPortGroupsDisp

[out, retval] Address of a pointer to an IDispatch interface that contains all BizTalkPortGroup objects.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

Note

  • In addition to the HRESULT values listed on the error messages page, this method returns OLEDB provider errors. Additional information about OLEDB is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.
[Visual Basic]

This property returns an Object that contains all BizTalkPortGroup objects.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property.

Each record in the ADO recordset returned by this property contains information about an existing BizTalkPortGroup object in the database. The fields in each record contain the following information, listed in order:

  • Handle

  • Name

  • DateModified

Additional information about Microsoft ActiveX Data Objects is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkConfig::Ports Property [C++]

BizTalkConfig.Ports Property [Visual Basic]

The Ports property returns an ADO recordset that contains all BizTalkPort objects.

Syntax

[C++]

Get method:

HRESULT Ports(
    IDispatch** ppPortsDisp
);

[Visual Basic]

object.Ports

Parameters

[C++]

ppPortsDisp

[out, retval] Address of a pointer to an IDispatch interface that contains all BizTalkPort objects.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

Note

  • In addition to the HRESULT values listed on the error messages page, this method returns OLEDB provider errors. Additional information about OLEDB is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.
[Visual Basic]

This property returns an Object that contains all BizTalkPort objects.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property.

Each record in the ADO recordset returned by this property contains information about an existing BizTalkPort object in the database. The fields in each record contain the following information, listed in order:

  • Handle

  • Name

  • DateModified

Additional information about Microsoft ActiveX Data Objects is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkDocument Interface [C++]

BizTalkDocument Object [Visual Basic]

Use the BizTalkDocument object to identify and describe the document specification of a document.

In C++, use the IBizTalkDocument interface to access the methods of the BizTalkDocument object.

The properties of the BizTalkDocument object are shown in the following table.

Property | Type | Description
Content | BSTR | Content of the document specification described by the object. This is a read-only property.
DateModified | BSTR | Date and time at which the information in the object was created or last modified. This is a read-only property obtained from the BizTalkBase object.
Handle | long | Handle to the object. This is a read-only property obtained from the BizTalkBase object.
Name | BSTR | Name of the object. This is a required property obtained from the BizTalkBase object.
NameSpace | BSTR | String that resolves naming conflicts between elements in a document. This is a read-only property.
PropertySet | IDispatch | Dictionary object that contains the electronic data interchange (EDI) selection criteria (name/value pairs) by which the server extracts information from the functional group header of the EDI document to identify the object when the document is input. It helps the server create the header of the EDI document when it is output. This is a required property if the document is an EDI document.
Reference | BSTR | Full Web Distributed Authoring and Versioning (WebDAV) URL for the document specification referred to by this BizTalkDocument object. This is a required property when the TrackFields property is set.
TrackFields | IDispatch | Dictionary object that stores the custom fields that Tracking uses to track all documents processed by the server, based on this document instance. The Reference property must contain a WebDAV URL when this property is set.
Type | BSTR | Type of document specification. This is a read-only property.
Version | BSTR | Version of the document standard. This is a read-only property.

The methods of the BizTalkDocument object are shown in the following table.

Method | Description
Clear | Clears the object in memory. All member variables of the object in memory are initialized to their default values. This method is obtained from the BizTalkBase object.
Create | Creates a new object in the database. This method is obtained from the BizTalkBase object.
Load | Loads the object in memory. This method is obtained from the BizTalkBase object.
LoadByName | Loads the object by name in memory. This method is obtained from the BizTalkBase object.
LoadByPropertySet | Loads the document object by its PropertySet object.
Remove | Removes the object from the database. This method is obtained from the BizTalkBase object.
Save | Saves the object in the database. This method is obtained from the BizTalkBase object.

Remarks

Each BizTalkDocument object must have at least one associated BizTalkChannel object. More than one BizTalkDocument object can refer to the same document specification.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topic

Document Definitions


IBizTalkDocument::Content Property [C++]

BizTalkDocument.Content Property [Visual Basic]

The Content property contains the content of the document specification described by the object.

Syntax

[C++]

Get method:

HRESULT get_Content(
    BSTR* pstrContent
);

[Visual Basic]

object.Content

Parameters

[C++]

pstrContent

[out, retval] Pointer to a BSTR that contains the content.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a String that contains the content.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property.

The Reference property is checked when the Create or the Save method is called. If this string is not empty when Create is called, Content is set to the contents of the document specification and the NameSpace property is changed to the value found in the document specification.

Once you have created or saved an object with Reference set to a document specification, any changes you make to the Content or NameSpace of the referenced document specification are not automatically updated on the referring object. To update the object that refers to the revised document specification, you must save the document specification, reset the Reference property of the object to its current value, and then call Save on the referring object.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkDocument::LoadByPropertySet Method [C++]

BizTalkDocument.LoadByPropertySet Method [Visual Basic]

The LoadByPropertySet method loads the document object by its PropertySet.

Syntax

[C++]

HRESULT LoadByPropertySet(
    IDispatch** pPropSetDictionaryDisp
);

[Visual Basic]

object.LoadByPropertySet( _

    pPropSetDictionaryDisp As Object _
)

Parameters

[C++]

pPropSetDictionaryDisp

[in] Address of a pointer to an IDispatch interface that contains the PropertySet.

[Visual Basic]

pPropSetDictionaryDisp

Object that contains the PropertySet.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkDocument::NameSpace Property [C++]

BizTalkDocument.NameSpace Property [Visual Basic]

The NameSpace property contains the string that resolves naming conflicts between elements in a document.

Syntax

[C++]

Get method:

HRESULT get_NameSpace(
    BSTR* pstrNameSpace
);

[Visual Basic]

object.NameSpace

Parameters

[C++]

pstrNameSpace

[out, retval] Pointer to a BSTR that contains the namespace.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a String that contains the namespace.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property. The Reference property is checked when the Create or the Save method is called. If this string is not empty when Create is called, Content is set to the contents of the document specification and NameSpace is changed to the value found in the document specification.

Once you have created or saved an object with Reference set to a document specification, any changes you make to the Content or NameSpace of the referenced document specification are not automatically updated on the referring object. To update the object that refers to the revised document specification, you must save the document specification, reset the Reference property of the object to its current value, and then call Save on the referring object.

Note

  • When creating a document, the number of characters in the NameSpace combined with the number of characters in the specification name cannot exceed 255.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkDocument::PropertySet Property [C++]

BizTalkDocument.PropertySet Property [Visual Basic]

The PropertySet property contains a Dictionary object that contains the electronic data interchange (EDI) selection criteria (name/value pairs) by which the server extracts information from the functional group header of the EDI document to identify the object when the document is input. It helps the server create the header of the EDI document when it is output.

Syntax

[C++]

Get method:

HRESULT get_PropertySet(
    IDispatch** ppPropSetDisp
);

Putref method:

HRESULT putref_PropertySet(
    IDispatch* pPropSetDisp
);

[Visual Basic]

object.PropertySet

Parameters

[C++]

Get method:

ppPropSetDisp

[out, retval] Address of a pointer to an IDispatch interface that contains the selection criteria.

Putref method

pPropSetDisp

[in] Pointer to an IDispatch interface that contains the selection criteria.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns an Object that contains the selection criteria.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a required property if the document is an EDI document. The Delimiters property of the associated BizTalkPort object must also be defined.

The following table shows whether names are required in the Dictionary object for PropertySet.

Selection criteria | X12 | EDIFACT
application_sender_code | Yes | Yes
application_receiver_code | Yes | Yes
functional_identifier | Yes | Yes
standards_version | Yes | No
standards_version_type | No | Yes
standards_version_value | No | Yes

Note

  • The name/value pairs contained in the Dictionary object cannot exceed a total of 450 bytes.

PropertySet can be set only if the Reference property is set.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topic

Document Definitions


IBizTalkDocument::Reference Property [C++]

BizTalkDocument.Reference Property [Visual Basic]

The Reference property contains the full Web Distributed Authoring and Versioning (WebDAV) URL for the document specification referred to by the object.

Syntax

[C++]

Get method:

HRESULT get_Reference(
    BSTR* pstrReference
);

Put method:

HRESULT put_Reference(
    BSTR strReference
);

[Visual Basic]

object.Reference

Parameters

[C++]

Get method:

pstrReference

[out, retval] Pointer to a BSTR that contains the reference.

Put method:

strReference

[in] BSTR that contains the reference.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a String that contains the reference.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

Reference is checked when the Create or the Save method is called. If this string is not empty when Create is called, Content is set to the contents of the document specification and the NameSpace property is changed to the value found in the document specification.

Once you have created or saved an object with Reference set to a document specification, any changes you make to the Content or NameSpace of the referenced document specification are not automatically updated on the referring object. To update the object that refers to the revised document specification, you must save the document specification, reset the Reference property of the object to its current value, and then call Save on the referring object.

If Reference is not set, the PropertySet and TrackFields properties must not be set.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkDocument::TrackFields Property [C++]

BizTalkDocument.TrackFields Property [Visual Basic]

The TrackFields property identifies the Dictionary object that stores the custom fields used to track the document. A BizTalkDocument object points to the specification that contains fields to track the document. The designated fields are logged to the Tracking database for each instance of a document that is processed. Tracking fields on the BizTalkDocument object are global. The TrackFields property on the BizTalkChannel object overrides the values specified by this property.

Syntax

[C++]

Get method:

HRESULT get_TrackFields(
    IDispatch** ppTrackFieldsDisp
);

Putref method:

HRESULT putref_TrackFields(
    IDispatch* pTrackFieldsDisp
);

[Visual Basic]

object.TrackFields

Parameters

[C++]

Get method:

ppTrackFieldsDisp

[out, retval] Address of a pointer to the IDictionary interface of the object that contains the custom tracking fields.

Putref method:

pTrackFieldsDisp

[in] Pointer to the IDictionary interface of the object that contains the custom tracking fields.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a CDictionary object that contains the custom tracking fields.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

TrackFields can be set only if the Reference property is set. Tracking fields specified for an output BizTalkDocument object are ignored.

The fields in the Dictionary object must contain an XPath value that identifies the field to be tracked in a document. By default, the Dictionary object provides eight predefined fields for tracking data in a document. These predefined fields consist of two fields for each of the following data types: integer, real, date, and string. If additional fields are required for tracking, you can use the x_custom_search field in the Dictionary object and set the value to a SimpleList object. The SimpleList object contains a list of XPaths pointing to the additional tracking fields. XPath values can be added to and deleted from this list using the Add and Delete methods.

The following table shows the field names in the Dictionary object for TrackFields:

Field Name | Field type
i_value1 | Integer value
i_value2 | Integer value
r_value1 | Real value
r_value2 | Real value
d_value1 | Date value
d_value2 | Date value
s_value1 | String value
s_value2 | String value
x_custom_search | A list to return one or more additional data items

For more information about XPath expressions, go to the Microsoft Web site (msdn.microsoft.com/library/default.asp) and search for XPath.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Document Definitions

Document Tracking


IBizTalkDocument::Type Property [C++]

BizTalkDocument.Type Property [Visual Basic]

The Type property contains the type of document specification.

Syntax

[C++]

HRESULT get_Type(
    BSTR* pstrType
);

[Visual Basic]

object.Type

Parameters

[C++]

pstrType

[out, retval] Pointer to a BSTR that contains the document type.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a String that contains the document type.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property. All document instances must have the same document type as the associated envelope. For example, if the Format property of the BizTalkEnvelope object is set to X12, Type must also be X12.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkDocument::Version Property [C++]

BizTalkDocument.Version Property [Visual Basic]

The Version property contains the version of the document standard.

Syntax

[C++]

HRESULT get_Version(
    BSTR* pstrVersion
);

[Visual Basic]

object.Version

Parameters

[C++]

pstrVersion

[out, retval] Pointer to a BSTR that contains the version.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a String that contains the version.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkEndPoint Interface [C++]

BizTalkEndPoint Object [Visual Basic]

Use the BizTalkEndPoint object to configure source information for a BizTalkChannel object and destination information for a BizTalkPort object.

In C++, use the IBizTalkEndPoint interface to access the methods of the BizTalkEndPoint object.

The properties of the BizTalkEndPoint object are shown in the following table.

Property | Type | Description
Alias | long | Handle to the organization identifier type/value pair for the destination BizTalkOrganization object for the associated BizTalkPort object.
Application | long | Handle to the associated application for the destination BizTalkOrganization object for this BizTalkPort object.
Openness | BIZTALK_OPENNESS_ TYPE_EX | Enumeration value that indicates whether the object is open.
Organization | long | Handle to the destination BizTalkOrganization object for this BizTalkPort object. This is a required property for this object to be complete unless the Openness property is set to BIZTALK_OPENNESS_ TYPE_EX_DESTINATION.

Remarks

The BizTalkEndPoint object is automatically created when a BizTalkPort object or a BizTalkChannel object is instantiated with the CreatePort or the CreateChannel method of the BizTalkConfig object.

For destination endpoints, access the BizTalkEndPoint object by using the DestinationEndpoint property of the BizTalkPort object. For source endpoints, access the BizTalkEndPoint object by using the SourceEndpoint property of the BizTalkChannel object.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkEndPoint::Alias Property [C++]

BizTalkEndPoint.Alias Property [Visual Basic]

The Alias property contains the handle to the alias.

Syntax

[C++]

Get method:

HRESULT get_Alias(
    long* plAliasHandle
);

Put method:

HRESULT put_Alias(
    long lAliasHandle
);

[Visual Basic]

object.Alias

Parameters

[C++]

Get method:

plAliasHandle

[out, retval] Pointer to a long that contains the handle to the alias.

Put method:

lAliasHandle

[in] Long that contains the handle to the alias.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a Long that contains the handle to the alias.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkEndPoint::Application Property [C++]

BizTalkEndPoint.Application Property [Visual Basic]

The Application property contains the handle to the application.

Syntax

[C++]

Get method:

HRESULT get_Application(
    long* plAppHandle
);

Put method:

HRESULT put_Application(
    long lAppHandle
);

[Visual Basic]

object.Application

Parameters

[C++]

Get method:

plAppHandle

[out, retval] Pointer to a long that contains the handle to the application.

Put method:

lAppHandle

[in] Long that contains the handle to the application.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a Long that contains the handle to the application.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkEndPoint::Openness Property [C++]

BizTalkEndPoint.Openness Property [Visual Basic]

The Openness property contains an enumeration value that indicates whether the object has an open destination or source, or neither.

Syntax

[C++]

Get method:

HRESULT get_Openness(
    BIZTALK_OPENNESS_TYPE_EX* pOpennessType
);

Put method:

HRESULT put_Openness(
    BIZTALK_OPENNESS_TYPE_EX OpennessType
);

[Visual Basic]

object.Openness

Parameters

[C++]

Get method:

pOpennessType

[out, retval] Pointer to an enumeration value. Valid values are from the BIZTALK_OPENNESS_TYPE_EX enumeration.

Put Method:

OpennessType

[in] Enumeration value. Valid values are from the BIZTALK_OPENNESS_TYPE_EX enumeration.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns an enumeration value. Valid values are from the BIZTALK_OPENNESS_TYPE_EX enumeration.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

The BizTalkPort object is valid only if the associated document or the parameters on the Submit or the SubmitSync method of the IInterchange interface identify the missing information.

If Openness is set to BIZTALK_OPENNESS_TYPE_EX_SOURCE for a BizTalkEndPoint object associated with a channel, the following constraints apply:

  • The SignatureType property must not be set.

  • The BizTalkPort object cannot be included in a port group.

If Openness is set to BIZTALK_OPENNESS_TYPE_EX_FROMWORKFLOW on a channel, the associated BizTalkOrganization object must be the default organization.

If Openness on the object is set to BIZTALK_OPENNESS_TYPE_EX_DESTINATION for a BizTalkEndPoint object associated with a messaging port, the following constraints apply:

  • The PrimaryTransportType property must be set to BIZTALK_TRANSPORT_TYPE_OPENDESTINATION.

  • The EncryptionType property must not be set.

  • The document or the parameters on Submit or SubmitSync must specify the destination, transport type, and address.

  • The BizTalkPort object cannot be included in a port group.

Note

  • This property cannot be changed on an existing port.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topic

Openness


IBizTalkEndPoint::Organization Property [C++]

BizTalkEndPoint.Organization Property [Visual Basic]

The Organization property contains the handle to the organization.

Syntax

[C++]

Get method:

HRESULT get_Organization(
    long* plOrganizationHandle
);

Put method:

HRESULT put_Organization(
    long lOrganizationHandle
);

[Visual Basic]

object.Organization

Parameters

[C++]

Get method:

plOrganizationHandle

[out, retval] Pointer to a long that contains the handle to the organization.

Put method:

lOrganizationHandle

[in] Long that contains the handle to the organization.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a Long that contains the handle to the organization.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkEnvelope Interface [C++]

BizTalkEnvelope Object [Visual Basic]

Use the BizTalkEnvelope object to configure the envelope format used with documents processed by BizTalk Server. An envelope is the header information for an interchange.

In C++, use the IBizTalkEnvelope interface to access the methods of the BizTalkEnvelope object.

The properties of the BizTalkEnvelope object are shown in the following table.

Property | Type | Description
Content | BSTR | Contents of the selected envelope format specification. This is a read-only property.
DateModified | BSTR | Date and time at which the information in the object was created or last modified. This is a read-only property obtained from the BizTalkBase object.
Format | BSTR | String that identifies the type of envelope.
Handle | long | Handle to the object. This is a read-only property obtained from the BizTalkBase object.
Name | BSTR | Name of the object. This is a required property obtained from the BizTalkBase object.
NameSpace | BSTR | String that resolves naming conflicts between elements in an envelope specification. This is a read-only property.
Reference | BSTR | Full Web Distributed Authoring and Versioning (WebDAV) URL name of the envelope format specification file. This is a required property if the Format property is set to "custom".
Version | BSTR | Version of the envelope format specification. This is a read-only property.

The methods of the BizTalkEnvelope object are shown in the following table.

Method | Description
Clear | Clears the object in memory. All member variables of the object in memory are initialized to their default values. This method is obtained from the BizTalkBase object.
Create | Creates a new object in the database. This method is obtained from the BizTalkBase object.
Load | Loads the object in memory. This method is obtained from the BizTalkBase object.
LoadByName | Loads the object by name in memory. This method is obtained from the BizTalkBase object.
Remove | Removes the object from the database. This method is obtained from the BizTalkBase object.
Save | Saves the object in the database. This method is obtained from the BizTalkBase object.

Remarks

All document instances in an electronic data interchange (EDI) functional group must have the same format. All document instances must have the same document type as the associated envelope. For example, if Format is set to X12, the Type property of the BizTalkDocument objects for the associated BizTalkPort object must also be X12.

If you use an envelope with an EDIFACT format and you want to use a null value for the empty qualifier in the header for the source or the destination, create a custom identifier with a single dash (-) as the qualifier. To do this, use the CreateAlias method on the BizTalkOrganization object. When an empty qualifier is encountered on an input EDIFACT envelope, the server converts the empty qualifier to a dash. For an output EDIFACT envelope, the server converts the dash to an empty qualifier.

The BizTalkEnvelope object is required for input documents if the Type property of the BizTalkDocument object is set to "flatfile" or "custom xml".

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topic

Envelopes


IBizTalkEnvelope::Content Property [C++]

BizTalkEnvelope.Content Property [Visual Basic]

The Content property contains the contents of the selected envelope format specification.

Syntax

[C++]

HRESULT get_Content(
    BSTR* pstrContent
);

[Visual Basic]

object.Content

Parameters

[C++]

pstrContent

[out, retval] Pointer to a BSTR that contains the content.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a String that contains the content.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property.

The Reference property is checked when the Create or the Save method is called. If this string is not empty when Create is called, Content is set to the contents of the envelope specification, and the NameSpace property is changed to the value found in the envelope specification.

Once you have created or saved an object with Reference set to an envelope specification, any changes you make to the Content or NameSpace of the referenced envelope specification are not automatically updated on the referring object. To update the object that refers to the revised envelope specification, you must save the envelope specification, reset the Reference property of the object to its current value, and then call Save on the referring object.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkEnvelope::Format Property [C++]

BizTalkEnvelope.Format Property [Visual Basic]

The Format property contains the string that identifies the type of envelope.

Syntax

[C++]

Get method:

HRESULT get_Format(
    BSTR* pstrFormat
);

Put method:

HRESULT put_Format(
    BSTR Format
);

[Visual Basic]

object.Format

Parameters

[C++]

Get method:

pstrFormat

[out, retval] Pointer to a BSTR that contains the envelope format.

Put method:

Format

[in] BSTR that contains the envelope format. The BSTR must be one of the values listed in the Remarks section below.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a String that contains the envelope format.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

The format value must be one of the following strings:

  • x12

  • edifact

  • custom xml (default)

  • custom

  • flatfile

  • reliable

Note

  • Any string other than the ones listed here will cause an error at run time.

If this property is set to "custom", the Reference property is required. Also, a custom parser component has to be registered with the server for input documents with this property set to "custom". For more information about custom parser components, see Using the IBizTalkParserComponent Interface.

All document instances must have the same document type as the associated envelope. For example, if Format is set to "x12", the Type property of the BizTalkDocument objects must also be "x12".

If Format is set to X12, edifact, or reliable, the Reference property should not be set.

For more information about envelope formats, see Create envelopes.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topic

Envelopes


IBizTalkEnvelope::NameSpace Property [C++]

BizTalkEnvelope.NameSpace Property [Visual Basic]

The NameSpace property contains the string that resolves naming conflicts between elements in an envelope specification.

Syntax

[C++]

Get method:

HRESULT get_NameSpace(
    BSTR* pstrNameSpace
);

[Visual Basic]

object.NameSpace

Parameters

[C++]

pstrNameSpace

[out, retval] Pointer to a BSTR that contains the namespace.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a String that contains the namespace.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property. The Reference property is checked when the Create or the Save method is called. If this string is not empty when Create is called, the Content property is set to the contents of the envelope specification, and NameSpace is changed to the value found in the envelope specification.

Once you have created or saved an object with Reference set to an envelope specification, any changes you make to the Content or NameSpace of the referenced envelope specification are not automatically updated on the referring object. To update the object that refers to the revised envelope specification, you must save the envelope specification, reset the Reference property of the object to its current value, and then call Save on the referring object.

Note

  • When creating an envelope, the number of characters in the NameSpace combined with the number of characters in the specification name cannot exceed 255.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkEnvelope::Reference Property [C++]

BizTalkEnvelope.Reference Property [Visual Basic]

The Reference property contains the full Web Distributed Authoring and Versioning (WebDAV) URL of the envelope format specification file.

Syntax

[C++]

Get method:

HRESULT get_Reference(
    BSTR* pReference
);

Put method:

HRESULT put_Reference(
    BSTR Reference
);

[Visual Basic]

object.Reference

Parameters

[C++]

Get method:

pReference

[out, retval] Pointer to a BSTR that contains the reference.

Put method:

Reference

[in] BSTR that contains the reference.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a String that contains the reference.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a required property if the Format property is set to "custom". Reference is checked when the Create or the Save method is called. If this string is not empty when Create is called, the Content property is set to the contents of the envelope specification, and the NameSpace property is changed to the value found in the envelope specification.

Once you have created or saved an object with Reference set to an envelope specification, any changes you make to the Content or NameSpace of the referenced envelope specification are not automatically updated on the referring object. To update the object that refers to the revised envelope specification, you must save the envelope specification, reset the Reference property of the object to its current value, and then call Save on the referring object.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkEnvelope::Version Property [C++]

BizTalkEnvelope.Version Property [Visual Basic]

The Version property contains the version of the envelope format specification.

Syntax

[C++]

Get method:

HRESULT get_Version(
    BSTR* pstrVersion
);

[Visual Basic]

object.Version

Parameters

[C++]

pstrVersion

[out, retval] Pointer to a BSTR that contains the version.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a String that contains the version.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkLoggingInfo Interface [C++]

BizTalkLoggingInfo Object [Visual Basic]

Use the BizTalkLoggingInfo object to configure the document-logging information for an associated BizTalkChannel object.

In C++, use the IBizTalkLoggingInfo interface to access the methods of the BizTalkLoggingInfo object.

The IBizTalkLoggingInfo interface defines the following properties:

Property | Type | Description
LogNativeInputDocument | VARIANT_BOOL | Flag that indicates whether the input document instance is saved and logged in its native format.
LogNativeOutputDocument | VARIANT_BOOL | Flag that indicates whether the output document instance is saved and logged in its native format.
LogXMLInputDocument | VARIANT_BOOL | Flag that indicates whether the XML input document is saved and logged.
LogXMLOutputDocument | VARIANT_BOOL | Flag that indicates whether the XML output document is saved and logged.

Remarks

The BizTalkLoggingInfo object is automatically created when a BizTalkChannel object is instantiated with the CreateChannel method of the BizTalkConfig object. You can access the BizTalkLoggingInfo object by using the LoggingInfo property of the BizTalkChannel object.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topic

Document Storage


IBizTalkLoggingInfo::LogNativeInputDocument Property [C++]

BizTalkLoggingInfo.LogNativeInputDocument Property [Visual Basic]

The LogNativeInputDocument property contains the flag that indicates whether the input document instance is saved and logged in its native format.

Syntax

[C++]

Get method:

HRESULT get_LogNativeInputDocument(
    VARIANT_BOOL* pbLogNativeInDoc
);

Put method:

HRESULT put_LogNativeInputDocument(
    VARIANT_BOOL bLogNativeInDoc
);

[Visual Basic]

object.LogNativeInputDocument

Parameters

[C++]

Get method:

pbLogNativeInDoc

[out, retval] Pointer to a VARIANT_BOOL type that contains the flag. A value of VARIANT_TRUE indicates that input documents will be saved and logged in their native format. A value of VARIANT_FALSE indicates that input documents will not be saved and logged in their native format.

Put method:

bLogNativeInDoc

[in] VARIANT_BOOL type that contains the flag. A value of VARIANT_TRUE indicates that documents will be saved and logged in their native format. A value of VARIANT_FALSE indicates that documents will not be saved and logged in their native format.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a Variant that contains the flag. A value of True indicates that input documents will be saved and logged in their native format. A value of False indicates that input documents will not be saved and logged in their native format.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topic

Document Storage


IBizTalkLoggingInfo::LogNativeOutputDocument Property [C++]

BizTalkLoggingInfo.LogNativeOutputDocument Property [Visual Basic]

The LogNativeOutputDocument property contains the flag that indicates whether the output document instance is saved and logged in its native format.

Syntax

[C++]

Get method:

HRESULT get_LogNativeOutputDocument(
    VARIANT_BOOL* pbLogNativeOutDoc
);

Put method:

HRESULT put_LogNativeOutputDocument(
    VARIANT_BOOL bLogNativeOutDoc
);

[Visual Basic]

object.LogNativeOutputDocument

Parameters

[C++]

Get method:

pbLogNativeOutDoc

[out, retval] Pointer to a VARIANT_BOOL type that contains the flag. A value of VARIANT_TRUE indicates that output documents will be saved and logged in their native format. A value of VARIANT_FALSE indicates that output documents will not be saved and logged in their native format.

Put method:

bLogNativeOutDoc

[in] VARIANT_BOOL type that contains the flag. A value of VARIANT_TRUE indicates that output documents will be saved and logged in their native format. A value of VARIANT_FALSE indicates that output documents will not be saved and logged in their native format.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a Variant that contains the flag. A value of True indicates that output documents will be saved and logged in their native format. A value of False indicates that output documents will not be saved and logged in their native format.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topic

Document Storage


IBizTalkLoggingInfo::LogXMLInputDocument Property [C++]

BizTalkLoggingInfo.LogXMLInputDocument Property [Visual Basic]

The LogXMLInputDocument property contains the flag that indicates whether the XML input document instance is saved and logged.

Syntax

[C++]

Get method:

HRESULT get_LogXMLInputDocument(
    VARIANT_BOOL* pbLogXMLInDoc
);

Put method:

HRESULT put_LogXMLInputDocument(
    VARIANT_BOOL bLogXMLInDoc
);

[Visual Basic]

object.LogXMLInputDocument

[C++]

Get method:

pbLogXMLInDoc

[out, retval] Pointer to a VARIANT_BOOL type that contains the flag. A value of VARIANT_TRUE indicates that input documents will be saved and logged in XML format. A value of VARIANT_FALSE indicates that input documents will not be saved and logged in XML format.

Put method:

bLogXMLInDoc

[in] VARIANT_BOOL type that contains the flag. A value of VARIANT_TRUE indicates that input documents will be saved and logged in XML format. A value of VARIANT_FALSE indicates that input documents will not be saved and logged in XML format.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a Variant that contains the flag. A value of True indicates that input documents will be saved and logged in XML format. A value of False indicates that input documents will not be saved and logged in XML format.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topic

Document Storage


IBizTalkLoggingInfo::LogXMLOutputDocument Property [C++]

BizTalkLoggingInfo.LogXMLOutputDocument Property [Visual Basic]

The LogXMLOutputDocument property contains a flag that indicates whether the XML output document instance is saved and logged.

Syntax

[C++]

Get method:

HRESULT get_LogXMLOutputDocument(
    VARIANT_BOOL* pbLogXMLOutDoc
);

Put method:

HRESULT put_LogXMLOutputDocument(
    VARIANT_BOOL bLogXMLOutDoc
);

[Visual Basic]

object.LogXMLOutputDocument

[C++]

Get method:

pbLogXMLOutDoc

[out, retval] Pointer to a VARIANT_BOOL type that contains the flag. A value of VARIANT_TRUE indicates that output documents will be saved and logged in XML format. A value of VARIANT_FALSE indicates that output documents will not be saved and logged in XML format.

Put method:

bLogXMLOutDoc

[in] When putting the property, a VARIANT_BOOL type that contains the flag. A value of VARIANT_TRUE indicates that output documents will be saved and logged in XML format. A value of VARIANT_FALSE indicates that output documents will not be saved and logged in XML format.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a Variant that contains the flag. A value of True indicates that output documents will be saved and logged in XML format. A value of False indicates that output documents will not be saved and logged in XML format.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topic

Document Storage


IBizTalkOrganization Interface [C++]

BizTalkOrganization Object [Visual Basic]

Use the BizTalkOrganization object to configure organizations, its organization identifiers (aliases), and the applications within the organization that send and/or receive documents. The application indicates the ultimate source or destination of the document.

In C++, use the IBizTalkOrganization interface to access the methods of the BizTalkOrganization object.

The properties of the BizTalkOrganization object are shown in the following table.

Property | Type | Description
Aliases | IDispatch | ADO recordset of aliases that refer to the object. The alias for an object is the organization identifier type/value pair.
Applications | IDispatch | ADO recordset of applications that refer to the object.
Comments | BSTR | User comments for the object.
DateModified | BSTR | Date and time at which the information in the object was created or last modified. This is a read-only property obtained from the BizTalkBase object.
Handle | long | Identifier for the object. This is a read-only property obtained from the BizTalkBase object.
IsDefault | VARIANT_BOOL | Flag that indicates whether the object is the default organization.
Name | BSTR | Name of the object. This is a required property that is obtained from the BizTalkBase object.

The methods of the BizTalkOrganization object are shown in the following table.

Method | Description
Clear | Clears the object in memory. All member variables of the object in memory are initialized to their default values. This method is obtained from the BizTalkBase object.
Create | Creates a new object in the database. This method is obtained from the BizTalkBase object.
CreateAlias | Creates an alias for the object. The alias is the organization identifier type/value pair.
CreateApplication | Creates a new application.
GetDefaultAlias | Gets the default alias for the object.
Load | Loads an object in memory. This method is obtained from the BizTalkBase object.
LoadAlias | Loads an existing alias for the object in memory.
LoadApplication | Loads an application in memory.
LoadByName | Loads an object by name in memory. This method is obtained from the BizTalkBase object.
Remove | Removes the object from the database. This method is obtained from the BizTalkBase object.
RemoveAlias | Removes an alias.
RemoveApplication | Removes an application.
Save | Saves the object to the database. This method is obtained from the BizTalkBase object.
SaveAlias | Saves this alias.
SaveApplication | Saves this application.

Remarks

A BizTalkOrganization object can have more than one application, but each application name must be unique for that object.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topic

Organizations


IBizTalkOrganization::Aliases Property [C++]

BizTalkOrganization.Aliases Property [Visual Basic]

The Aliases property returns an ADO recordset that contains information about all aliases that refer to the object. The alias for an object is the organization qualifier/value pair.

Syntax

[C++]

Get method:

HRESULT get_Aliases(
    IDispatch** ppAliasesDisp
);

[Visual Basic]

object.Aliases

Parameters

[C++]

ppAliasesDisp

[out, retval] Address of a pointer to an IDispatch interface that contains all aliases that refer to the object.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns an Object that contains all aliases that refer to the object.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

BizTalk Messaging Manager refers to aliases as identifiers.

Each record in the ADO recordset returned by this property contains information about the aliases of an existing BizTalkOrganization object in the database. The fields in each record contain the following information, listed in order:

  • Handle assigned to the alias.

  • Name specified in the CreateAlias method.

  • 6Boolean specified in the CreateAlias method.

  • Qualifier specified in the CreateAlias method.

  • Value specified in the CreateAlias method.

Additional information about Microsoft ActiveX Data Objects is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topic

Organizations


IBizTalkOrganization::Applications Property [C++]

BizTalkOrganization.Applications Property [Visual Basic]

The Applications property returns an ADO recordset that contains information about all applications that refer to the Organization object.

Syntax

[C++]

Get method:

HRESULT get_Applications(
    IDispatch** ppApplicationsDisp
);

[Visual Basic]

object.Applications

Parameters

[C++]

ppApplicationsDisp

[out, retval] Address of a pointer to an IDispatch interface that contains all applications that refer to the object.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

Note

  • In addition to the HRESULT values listed on the error messages page, this method returns OLEDB provider errors. Additional information about OLEDB is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.
[Visual Basic]

This property returns an Object that contains all applications that refer to the object.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

Each record in the ADO recordset returned by this property contains information about the applications of an existing BizTalkOrganization object in the database. The fields in each record contain the following information, listed in order:

  • Handle assigned to the application.

  • Name specified in the CreateApplication method.

Additional information about Microsoft ActiveX Data Objects is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkOrganization::Comments Property [C++]

BizTalkOrganization.Comments Property [Visual Basic]

The Comments property contains the user comments for the object.

Syntax

[C++]

Get method:

HRESULT get_Comments(
    BSTR* pstrComments
);

Put method:

HRESULT put_Comments(
    BSTR strComments
);

[Visual Basic]

object.Comments

Parameters

[C++]

Get method:

pstrComments

[out, retval] Pointer to a BSTR that contains the comments.

Put method:

strComments

[in] When putting the property, a BSTR that contains the comments.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a String that contains the comments.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkOrganization::CreateAlias Method [C++]

BizTalkOrganization.CreateAlias Method [Visual Basic]

The CreateAlias method creates a new alias for this Organization object. The alias for an object is the organization identifier that contains a name and a qualifier/value pair.

Syntax

[C++]

HRESULT CreateAlias(
    BSTR strName,
    VARIANT_BOOL bDefault,
    BSTR strQualifier,
    BSTR strValue
);

[Visual Basic]

object.CreateAlias( _
    strName As String, _
    bDefault As Boolean, _
    strQualifier As String, _
    strValue As String _
)

Parameters

[C++]

strName

[in] BSTR that contains the name of the alias.

bDefault

[in] VARIANT_BOOL type that contains the flag. This default alias overrides the previous default alias when set to VARIANT_TRUE. A value of VARIANT_FALSE indicates that this alias should not override the previous default alias. If no alias is specified as the default, one is assigned when the Create method is called.

strQualifier

[in] BSTR that contains the qualifier. This parameter cannot be set to "group".

strValue

[in] BSTR that contains the value.

[Visual Basic]

strName

String that contains the name of the alias.

bDefault

Boolean that contains the flag. This default alias overrides the previous default alias when set to True. If no alias is specified as the default, one is assigned when the Create method is called.

strQualifier

String that contains the qualifier. This parameter cannot be set to "group".

strValue

String that contains the value.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

More than one alias can be created for a BizTalkOrganization object. The organization alias must contain a name that is unique for the specified BizTalkOrganization object, and a qualifier/value pair that is unique across all BizTalkOrganization objects. One of these aliases must be specified as the default alias for the object.

The server automatically creates an alias named Organization with a default identifier of OrganizationName and the value set to the organization's name for new organizations. If the organization name is changed, the value is automatically updated with the new name. This alias cannot be removed.

Note

  • When using envelopes with an EDIFACT format and you want to use a null value for the empty qualifier in the header for the source or the destination, create a custom identifier with a single dash (-) as the qualifier.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topic

Organizations


IBizTalkOrganization::CreateApplication Method [C++]

BizTalkOrganization.CreateApplication Method [Visual Basic]

The CreateApplication method creates a new application.

Syntax

[C++]

HRESULT CreateApplication(
    BSTR strName
);

[Visual Basic]

object.CreateApplication( _
    strName As String _

)

Parameters

[C++]

strName

[in] BSTR that contains the name of the application.

[Visual Basic]

strName

String that contains the name of the application.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

If a BizTalkOrganization object is associated with more than one application, each application name must be unique.

Notes

  • BizTalk Messaging Manager refers to the default organization as the home organization.

  • BizTalk Messaging Manager allows applications to be created for the home organization only. The BizTalk Messaging Configuration object model does not enforce this restriction. Therefore, if you create an application for an organization other than the default (home) organization, you cannot modify it using BizTalk Messaging Manager.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topic

Organizations


IBizTalkOrganization::GetDefaultAlias Method [C++]

BizTalkOrganization.GetDefaultAlias Method [Visual Basic]

The GetDefaultAlias method returns the handle to the default alias for the object. The default alias for an object is the default organization identifier type/value pair.

Syntax

[C++]

HRESULT GetDefaultAlias(
    long* plAliasHandle
);

[Visual Basic]

object.GetDefaultAlias()

Parameters

[C++]

plAliasHandle

[out, retval] Pointer to a long that contains the handle.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This method returns a Long that contains the handle.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topic

Organizations


IBizTalkOrganization::IsDefault Property [C++]

BizTalkOrganization.IsDefault Property [Visual Basic]

The IsDefault property contains the flag that indicates whether the object is the default organization.

Syntax

[C++]

Get method:

HRESULT get_IsDefault(
    VARIANT_BOOL* pbIsDefault
);

[Visual Basic]

object.IsDefault

Parameters

[C++]

Get method:

pbIsDefault

[out, retval] Pointer to a VARIANT_BOOL type that indicates whether this organization is the default organization. A value of VARIANT_TRUE indicates that this organization is the default organization. A value of VARIANT_FALSE indicates that this organization is not the default organization.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a Boolean that contains the flag. If True, this organization is the default organization.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property. There must be one and only one default organization at any time.

Note

  • BizTalk Messaging Manager refers to the default organization as the home organization.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkOrganization::LoadAlias Method [C++]

BizTalkOrganization.LoadAlias Method [Visual Basic]

The LoadAlias method loads an associated alias for the object in memory. The alias for an object is the organization qualifier/value pair.

Syntax

[C++]

HRESULT LoadAlias(
    long lAliasHandle,
    VARIANT* pvarName,
    VARIANT* pvarDefault,
    VARIANT* pvarQualifier,
    VARIANT* pvarValue
);

[Visual Basic]

object.LoadAlias( _
    lAliasHandle As Long, _
    pvarName As Variant, _
    pvarDefault As Variant, _
    pvarQualifier As Variant, _
    pvarValue As Variant _
)

Parameters

[C++]

lAliasHandle

[in] Long that contains the handle to the alias.

pvarName

[in, out] Pointer to a VARIANT that contains the name of the organization identifier.

pvarDefault

[in, out] Pointer to a VARIANT that contains the default flag.

pvarQualifier

[in, out] Pointer to a VARIANT that contains the qualifier of the organization identifier.

pvarValue

[in, out] Pointer to a VARIANT that contains the value of the organization identifier.

[Visual Basic]

lAliasHandle

Long that contains the handle to the alias.

pvarName

Variant that contains the name of the organization identifier.

pvarDefault

Variant that contains the default flag.

pvarQualifier

Variant that contains the qualifier of the organization identifier.

pvarValue

Variant that contains the value of the organization identifier.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

The values used with the parameters of this method can be obtained from the Aliases property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topic

Organizations


IBizTalkOrganization::LoadApplication Method [C++]

BizTalkOrganization.LoadApplication Method [Visual Basic]

The LoadApplication method loads an associated application for the object in memory.

Syntax

[C++]

HRESULT LoadApplication(
    long lApplicationHandle,
    VARIANT* pvarName
);

[Visual Basic]

object.LoadApplication( _
    lApplicationHandle As Long, _
    pvarName As Variant _
)

Parameters

[C++]

lApplicationHandle

[in] Long that contains the application handle.

pvarName

[in, out] Pointer to a VARIANT that contains the name of the application.

[Visual Basic]

lApplicationHandle

Long that contains the application handle.

pvarName

Variant that contains the name of the application.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

The values used with the parameters of this method can be obtained from the Applications property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkOrganization::RemoveAlias Method [C++]

BizTalkOrganization.RemoveAlias Method [Visual Basic]

The RemoveAlias method removes an alias. The alias for an object is the organization identifier type/value pair.

Syntax

[C++]

HRESULT RemoveAlias(
    long lAliasHandle
);

[Visual Basic]

object.RemoveAlias( _
    lAliasHandle As Long _
)

Parameters

[C++]

lAliasHandle

[in] Long that contains the handle to the alias.

[Visual Basic]

lAliasHandle

Long that contains the handle to the alias.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This record cannot be removed if any of the following conditions apply:

  • A BizTalkPort or a BizTalkChannel object refers to it.

  • It has been designated the default organization identifier.

  • This alias was autogenerated.

The alias handle can be obtained from the Aliases property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topic

Organizations


IBizTalkOrganization::RemoveApplication Method [C++]

BizTalkOrganization.RemoveApplication Method [Visual Basic]

The RemoveApplication method removes an application from the default organization.

Syntax

[C++]

HRESULT RemoveApplication(
    long lApplicationHandle
);

[Visual Basic]

object.RemoveApplication( _
    lApplicationHandle As Long _
)

Parameters

[C++]

lApplicationHandle

[in] Long that contains the handle.

[Visual Basic]

lApplicationHandle

Long that contains the handle.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This record cannot be removed if a BizTalkPort or a BizTalkChannel object refers to it.

The application handle can be obtained from the Applications property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkOrganization::SaveAlias Method [C++]

BizTalkOrganization.SaveAlias Method [Visual Basic]

The SaveAlias method saves an alias for the object. The alias for an object is the organization identifier type/value pair.

Syntax

[C++]

HRESULT SaveAlias(
    long lAliasHandle,
    BSTR strName,
    VARIANT_BOOL bDefault,
    BSTR strQualifier,
    BSTR strValue
);

[Visual Basic]

object.SaveAlias( _
    lAliasHandle As Long, _
    strName As String, _
    bDefault As Boolean, _
    strQualifier As String, _
    strValue As String _
)

Parameters

[C++]

lAliasHandle

[in] Long that contains the handle to the alias.

strName

[in] BSTR that contains the name of the organization identifier. This parameter cannot be changed if this alias was autogenerated.

bDefault

[in] VARIANT_BOOL type that contains the default flag. A value of VARIANT_TRUE indicates that this is the default alias for the organization. A value of VARIANT_FALSE indicates that this is not the default alias for the organization.

strQualifier

[in] BSTR that contains the qualifier of the organization identifier. This parameter cannot be changed if this alias was autogenerated. This parameter cannot be set to "group".

strValue

[in] BSTR that contains the value of the organization identifier. This parameter cannot be changed if this alias was autogenerated.

[Visual Basic]

lAliasHandle

Long that contains the handle to the alias.

strName

String that contains the name of the organization identifier. This parameter cannot be changed if this alias was autogenerated.

bDefault

Variant that contains the default flag. A value of True indicates that this is the default alias for the organization. A value of False indicates that this is not the default alias for the organization.

strQualifier

String that contains the qualifier of the organization identifier. This parameter cannot be changed if this alias was autogenerated. This parameter cannot be set to "group".

strValue

String that contains the value of the organization identifier. This parameter cannot be changed if this alias was autogenerated.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topic

Organizations


IBizTalkOrganization::SaveApplication Method [C++]

BizTalkOrganization.SaveApplication Method [Visual Basic]

The SaveApplication method saves this application for the default organization object.

Syntax

[C++]

HRESULT SaveApplication(
    long lApplicationHandle,
    BSTR strName
);

[Visual Basic]

object.SaveApplication( _
    lApplicationHandle As Long, _
    strName As String _
)

Parameters

[C++]

lApplicationHandle

[in] Long that contains the handle to the application.

strName

[in] BSTR that contains the name of the application.

[Visual Basic]

lApplicationHandle

Long that contains the handle to the application.

strName

String that contains the name of the application.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkPort Interface [C++]

BizTalkPort Object [Visual Basic]

The BizTalkPort object configures a one-way transfer of a document between organizations and applications. It identifies the source organization and/or application, the destination organization and/or application, the primary transport type, and, if selected, the associated envelope for transmission.

In C++, use the IBizTalkPort interface to access the methods of the BizTalkPort object.

The properties of the BizTalkPort object are shown in the following table.

Property | Type | Description
Channels | IDispatch | ADO recordset that contains information about all BizTalkChannel objects that refer to the object. This is a read-only property.
Comments | BSTR | User comments for the Port object.
ControlNumberValue | BSTR | Value of the interchange control number. This is a required property if the Format property of the associated BizTalkEnvelope object is set to "x12", "edifact", or "custom". This constraint is not enforced for this release, but the server fails if it is not adhered to.
DateModified | BSTR | Date and time at which the information in the object was created or last modified. This is a read-only property obtained from the BizTalkBase object.
Delimiters | IDispatch | Dictionary object that contains all delimiters used in the document specification. This is a required property if the Format property of the associated BizTalkEnvelope object is set to "x12", "edifact", or "custom".
DestinationEndpoint | IDispatch | Information about the destination.
EncodingType | BIZTALK_ENCODING_ TYPE | Enumeration value that indicates the type of document encoding.
EncryptionCertificateInfo | IDispatch | Information about the certificate that encrypts the document.
EncryptionType | BIZTALK_ENCRYPTION_ TYPE | Enumeration value that indicates the type of document encryption.
Envelope | long | Handle to the BizTalkEnvelope object associated with this BizTalkPort object.
Handle | long | Handle to the object. This is a read-only property obtained from the BizTalkBase object.
Name | BSTR | Name of the object. This is a required property obtained from the BizTalkBase object.
PrimaryTransport | IDispatch | Primary transport component information.
SecondaryTransport | IDispatch | Secondary transport component information.
ServiceWindowInfo | IDispatch | Service window information.
SignatureType | BIZTALK_SIGNATURE_ TYPE | Enumeration value that indicates the type of digital signing and verification.

The methods of the BizTalkPort object are shown in the following table.

Method | Description
Clear | Clears the object in memory. All the member variables of the object in memory are initialized to their default values. This method is obtained from the BizTalkBase object.
Create | Creates a new object in the database. This method is obtained from the BizTalkBase object.
Load | Loads the object in memory. This method is obtained from the BizTalkBase object
LoadByName | Loads the object by name in memory. This method is obtained from the BizTalkBase object.
Remove | Removes the object from the database. This method is obtained from the BizTalkBase object.
Save | Saves the object in the database. This method is obtained from the BizTalkBase object.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Document Processing

Messaging Ports


IBizTalkPort::Channels Property [C++]

BizTalkPort.Channels Property [Visual Basic]

The Channels property contains an ADO recordset that contains information about all BizTalkChannel objects that refer to the object.

Syntax

[C++]

Get method:

HRESULT get_Channels(
    IDispatch** ppChannelsDisp
);

[Visual Basic]

object.Channels

Parameters

[C++]

ppChannelsDisp

[out, retval] Address of a pointer to an IDispatch interface that contains the BizTalkChannel objects that refer to the object.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns an Object that contains the BizTalkChannel objects that refer to the object.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property.

Each record in the ADO recordset returned by this property contains information about the BizTalkChannel objects in the database that are associated with this BizTalkPort object. The fields in each record contain the following information, listed in order:

  • Handle

  • Name

  • A unique channel identifier, in GUID format.

Additional information about Microsoft ActiveX Data Objects is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkPort::Comments Property [C++]

BizTalkPort.Comments Property [Visual Basic]

The Comments property contains the user comments for the Port object.

Syntax

[C++]

Get method:

HRESULT get_Comments(
    BSTR* pstrComments
);

Put method:

HRESULT put_Comments(
    BSTR strComments
);

[Visual Basic]

object.Comments

Parameters

[C++]

Get method:

pstrComments

[out, retval] Pointer to a BSTR that contains the comments.

Put method:

strComments

[in] BSTR that contains the comments.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a String that contains the comments.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkPort::ControlNumberValue Property [C++]

BizTalkPort.ControlNumberValue Property [Visual Basic]

The ControlNumberValue property contains the value of the interchange control number.

Syntax

[C++]

HRESULT get_ControlNumberValue(
    BSTR* pstrControlNumberValue
);

Put method:

HRESULT put_ControlNumberValue(
    BSTR strControlNumberValue
);

[Visual Basic]

object.ControlNumberValue

Parameters

[C++]

Get method:

pstrControlNumberValue

[out, retval] Pointer to a BSTR that contains the interchange control number.

Put method:

strControlNumberValue

[in] BSTR that contains the interchange control number.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a String that contains the interchange control number.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

The ControlNumberValue property must contain a value between 1 and 999999999.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkPort::Delimiters Property [C++]

BizTalkPort.Delimiters Property [Visual Basic]

The Delimiters property contains a Dictionary object that contains all delimiters used in the document specification. Delimiters specifies which characters to use to separate data within the envelope and the documents that are sent using this envelope.

Syntax

[C++]

Get method:

HRESULT get_Delimiters(
    IDispatch** ppDelimitersDisp
);

Putref method:

HRESULT putref_Delimiters(
    IDispatch* pDelimitersDisp
);

[Visual Basic]

object.Delimiters

Parameters

[C++]

Get method:

ppDelimitersDisp

[out, retval] Address of a pointer to an IDispatch interface that contains the delimiters.

Putref method:

pDelimitersDisp

[in] Pointer to an IDispatch interface that contains the delimiters.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns an Object that contains the delimiters.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a required property for the object to be complete if the Format property of the associated BizTalkEnvelope object is set to "x12", "edifact", or "custom". The PropertySet property of the associated BizTalkDocument object must also be defined. The following table shows which names are required for the delimiters of the Dictionary object for various formats:

Delimiter | X12 | EDIFACT
Record_delim | Yes | Yes
Field_delim | Yes | Yes
Subfield_delim | Yes | Yes
Escape_char | No | Yes

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkPort::DestinationEndpoint Property [C++]

BizTalkPort.DestinationEndpoint Property [Visual Basic]

The DestinationEndpoint property contains information about the destination. This information includes the Alias, Application, and Organization properties and is created and stored in memory in the BizTalkEndPoint object.

Syntax

[C++]

Get method:

HRESULT get_DestinationEndpoint(
    IDispatch** ppDestEndpointDisp
);

Putref method:

HRESULT putref_DestinationEndpoint(
     IDispatch* pDestEndpointDisp
);

[Visual Basic]

object.DestinationEndpoint

Parameters

[C++]

Get method:

ppDestEndpointDisp

[out, retval] Address of a pointer to an IDispatch interface that contains information about the destination.

Putref method:

pDestEndpointDisp

[in] Pointer to an IDispatch interface that contains information about the destination.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns an Object that contains information about the destination.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

Once a BizTalkPort object has been created, the destination BizTalkOrganization object cannot be changed.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkPort::EncodingType Property [C++]

BizTalkPort.EncodingType Property [Visual Basic]

The EncodingType property contains the enumeration value that indicates the type of document encoding.

Syntax

[C++]

Get method:

HRESULT get_EncodingType(
    BIZTALK_ENCODING_TYPE* pEncodingType
);

Put method:

HRESULT put_EncodingType(
    BIZTALK_ENCODING_TYPE EncodingType
);

[Visual Basic]

object.EncodingType

Parameters

[C++]

Get method:

pEncodingType

[out, retval] Pointer to an enumeration value. Valid values are from the BIZTALK_ENCODING_TYPE enumeration.

Put method:

EncodingType

[in] When putting the property, an enumeration value. Valid values are from the BIZTALK_ENCODING_TYPE enumeration.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns an enumeration value. Valid values are from the BIZTALK_ENCODING_TYPE enumeration.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

The Clear method sets EncodingType to BIZTALK_ENCODING_TYPE_NONE.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkPort::EncryptionCertificateInfo Property [C++]

BizTalkPort.EncryptionCertificateInfo Property [Visual Basic]

The EncryptionCertificateInfo property contains information about the certificate that encrypts the document. This information includes the Name, Reference, Store, and Usage properties and is created and stored in memory in the BizTalkCertificateInfo object.

Syntax

[C++]

Get method:

HRESULT get_EncryptionCertificateInfo(
    IDispatch** ppEncryptionCertificateInfoDisp
);

Putref method:

HRESULT putref_EncryptionCertificateInfo(
    IDispatch* pEncryptionCertificateInfoDisp
);

[Visual Basic]

object.EncryptionCertificateInfo

Parameters

[C++]

Get method:

ppEncryptionCertificateInfoDisp

[out, retval] Address of a pointer to an IDispatch interface that contains the certificate information.

Putref method:

pEncryptionCertificateInfoDisp

[in] Pointer to an IDispatch interface that contains the certificate information.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns an Object that contains the certificate information.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkPort::EncryptionType Property [C++]

BizTalkPort.EncryptionType Property [Visual Basic]

The EncryptionType property contains the enumeration value that indicates the type of document encryption.

Syntax

[C++]

Get method:

HRESULT get_EncryptionType(
    BIZTALK_ENCRYPTION_TYPE* pEncryptionType
);

Put method:

HRESULT put_EncryptionType(
    BIZTALK_ENCRYPTION_TYPE EncryptionType
);

[Visual Basic]

object.EncryptionType

Parameters

[C++]

Get method:

pEncryptionType

[out, retval] Pointer to an enumeration value. Valid values are from the BIZTALK_ENCRYPTION_TYPE enumeration.

Put method:

EncryptionType

[in] Enumeration value. Valid values are from the BIZTALK_ENCRYPTION_TYPE enumeration.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns an enumeration value. Valid values are from the BIZTALK_ENCRYPTION_TYPE enumeration.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

The Clear method sets EncryptionType to BIZTALK_ENCRYPTION_TYPE_NONE.

If the EncryptionType is set to BIZTALK_ENCRYPTION_TYPE_SMIME, then the EncryptionCertificateInfo property must be set.

For open messaging ports, EncryptionType must be set to BIZTALK_ENCRYPTION_TYPE_NONE.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkPort::Envelope Property [C++]

BizTalkPort.Envelope Property [Visual Basic]

The Envelope property contains the handle to the associated BizTalkEnvelope object.

Syntax

[C++]

Get method:

HRESULT get_Envelope(
    long* plEnvelopeHandle
);

Put method:

HRESULT put_Envelope(
    long lEnvelopeHandle
);

[Visual Basic]

object.Envelope

Parameters

[C++]

Get method:

plEnvelopeHandle

[out, retval] Pointer to a long that contains the handle to the object.

Put method:

lEnvelopeHandle

[in] Long that contains the handle to the object.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a Long that contains the handle to the object.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topic

Envelopes


IBizTalkPort::PrimaryTransport Property [C++]

BizTalkPort.PrimaryTransport Property [Visual Basic]

The PrimaryTransport property contains the primary transport component information, including the Address, Parameter, and Type properties of the BizTalkTransportInfo object.

Syntax

[C++]

Get method:

HRESULT get_PrimaryTransport(
    IDispatch** ppTransportInfoDisp
);

Putref method:

HRESULT putref_PrimaryTransport(
    IDispatch* pTransportInfoDisp
);

[Visual Basic]

object.PrimaryTransport

Parameters

[C++]

Get method:

ppTransportInfoDisp

[out, retval] Address of a pointer to an IDispatch interface that contains the primary transport component information.

Putref method:

pTransportInfoDisp

[in] Pointer to an IDispatch interface that contains the primary transport component information.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns an Object that contains the primary transport component information.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a required property for the object.

The following constraints are enforced:

  • If the Openness property of the associated BizTalkEndPoint object is set to BIZTALK_OPENNESS_TYPE_EX_DESTINATION, the Address property cannot be set, and PrimaryTransport must be set to BIZTALK_TRANSPORT_TYPE_OPENDESTINATION. The BizTalkServiceWindowInfo object cannot be used with open destination ports.

  • Once a BizTalkPort object has been created, the Openness property of the associated BizTalkEndPoint object cannot be changed.

  • The Openness property cannot be set to BIZTALK_OPENNESS_TYPE_EX_SOURCE or BIZTALK_OPENNESS_TYPE_EX_FROMWORKFLOW.

  • When using a Type of BIZTALK_TRANSPORT_TYPE_LOOPBACK, the primary and secondary transport Address property cannot be set, and the BizTalkServiceWindowInfo object cannot be used.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkPort::SecondaryTransport Property [C++]

BizTalkPort.SecondaryTransport Property [Visual Basic]

The SecondaryTransport property contains the secondary transport component information, including the Address, Parameter, and Type properties, and is created and stored in memory in the BizTalkTransportInfo object.

Syntax

[C++]

Get method:

HRESULT get_SecondaryTransport(
    IDispatch** ppTransportInfoDisp
);

Putref method:

HRESULT putref_SecondaryTransport(
    IDispatch* pTransportInfoDisp
);

[Visual Basic]

object.SecondaryTransport

Parameters

[C++]

Get method:

ppTransportInfoDisp

[out, retval] Address of a pointer to an IDispatch interface that contains the secondary transport component information.

Putref method:

pTransportInfoDisp

[in] Pointer to an IDispatch interface that contains the secondary transport component information.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This method returns an Object that contains the secondary transport component information.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a required property for the object to be complete.

The following constraints are enforced:

  • If the Openness property of the associated BizTalkEndPoint object is set to BIZTALK_OPENNESS_TYPE_EX_DESTINATION, the Address property cannot be set, and SecondaryTransport must be set to BIZTALK_TRANSPORT_TYPE_OPENDESTINATION.

  • Once a BizTalkPort object has been created, the Openness property of the associated BizTalkEndPoint object cannot be changed.

  • The Openness property cannot be set to BIZTALK_OPENNESS_TYPE_EX_SOURCE or BIZTALK_OPENNESS_TYPE_EX_FROMWORKFLOW.

  • The Type property cannot be set to BIZTALK_TRANSPORT_TYPE_LOOPBACK.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkPort::ServiceWindowInfo Property [C++]

BizTalkPort.ServiceWindowInfo Property [Visual Basic]

The ServiceWindowInfo property contains information about the service window. This information includes the FromTime, IsEnabled, and ToTime properties and is created and stored in memory in the BizTalkServiceWindowInfo object.

Syntax

[C++]

Get method:

HRESULT get_ServiceWindowInfo(
    IDispatch** ppServiceWindowInfoDisp
);

Putref method:

HRESULT putref_ServiceWindowInfo(
    IDispatch* pServiceWindowInfoDisp
);

[Visual Basic]

object.ServiceWindowInfo

Parameters

[C++]

Get method:

ppServiceWindowInfoDisp

[out, retval] Address of a pointer to an IDispatch interface that contains the service window.

Putref method:

pServiceWindowInfoDisp

[in] Pointer to an IDispatch interface that contains the service window.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This method returns an Object that contains information about the service window.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

If this property is used, the BizTalkServiceWindowInfo object must specify a valid time range by using the FromTime and ToTime properties.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkPort::SignatureType Property [C++]

BizTalkPort.SignatureType Property [Visual Basic]

The SignatureType property contains the enumeration value that indicates the type of digital signing and verification.

Syntax

[C++]

Get method:

HRESULT get_SignatureType(
    BIZTALK_SIGNATURE_TYPE* pSignatureType
);

Put method:

HRESULT put_SignatureType(
    BIZTALK_SIGNATURE_TYPE SignatureType
);

[Visual Basic]

object.SignatureType

Parameters

[C++]

Get method:

pSignatureType

[out, retval] Pointer to an enumeration value. Valid values are from the BIZTALK_SIGNATURE_TYPE enumeration.

Put method:

SignatureType

[in] Enumeration value. Valid values are from the BIZTALK_SIGNATURE_TYPE enumeration.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns an enumeration value. Valid values are from the BIZTALK_SIGNATURE_TYPE enumeration.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

The Clear method sets SignatureType to BIZTALK_SIGNATURE_TYPE_NONE.

BizTalkPort objects associated with open channels cannot have a SignatureType.

If the SignatureType on a BizTalkPort object is changed from BIZTALK_SIGNATURE_TYPE_NONE to BIZTALK_SIGNATURE_TYPE_SMIME, all channels associated with this BizTalkPort object must have already been saved with a SignatureCertificateInfo object. Also, if a BizTalkChannel contains a SignatureCertificateInfo object and the SignatureType of the BizTalkPort is set to BIZTALK_SIGNATURE_TYPE_NONE, the signature will be ignored.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkPortGroup Interface [C++]

BizTalkPortGroup Object [Visual Basic]

Use the BizTalkPortGroup object to configure port groups that are used to distribute the same document to many organizations.

In C++, use the IBizTalkPortGroup interface to access the methods of the BizTalkPortGroup object.

The properties of the BizTalkPortGroup object are shown in the following table.

Property | Type | Description
Channels | IDispatch | ADO recordset that contains information about all BizTalkChannel objects that refer to this object.
DateModified | BSTR | Date and time at which the information in the object was created or last modified. This is a read-only property obtained from the BizTalkBase object.
Handle | long | Handle to the object. This is a read-only property obtained from the BizTalkBase object.
Name | BSTR | Name of the object. This is a required property obtained from the BizTalkBase object.
Ports | IDispatch | ADO recordset that contains information about all BizTalkPort objects that refer to this object.

The methods of the BizTalkPortGroup object are shown in the following table.

Method | Description
AddPort | Adds a BizTalkPort object to this port group. There must be at least one BizTalkPort object in the port group.
Clear | Clears the object in memory. All member variables of the object in memory are initialized to their default values. This method is obtained from the BizTalkBase object.
Create | Creates a new object in the database. This method is obtained from the BizTalkBase object.
Load | Loads the object in memory. This method is obtained from the BizTalkBase object.
LoadByName | Loads the object by name in memory. This method is obtained from the BizTalkBase object.
Remove | Removes the BizTalkPortGroup object from the database. This method is obtained from the BizTalkBase object.
RemovePort | Removes a BizTalkPort object from the port group. There must be at least one BizTalkPort object in the port group.
Save | Saves the object in the database. This method is obtained from the BizTalkBase object.

Remarks

There must always be at least one BizTalkPort object and one BizTalkChannel object associated with a BizTalkPortGroup object. The BizTalkChannel object is associated with the BizTalkPortGroup object, not the BizTalkPort object within the group. Each BizTalkPort object within the group has another BizTalkChannel object or objects associated with it, but these are ignored when the port group channel is invoked.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topic

Port Groups


IBizTalkPortGroup::AddPort Method [C++]

BizTalkPortGroup.AddPort Method [Visual Basic]

The AddPort method adds a BizTalkPort object to this port group.

Syntax

[C++]

HRESULT AddPort(
    long lPortHandle
);

[Visual Basic]

object.AddPort( _
    lPortHandle As Long _
)

Parameters

[C++]

lPortHandle

[in] Long that contains the handle to the object.

[Visual Basic]

lPortHandle

Long that contains the handle to the object.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

The following constraints apply to this method:

  • There must be at least one BizTalkPort in this BizTalkPortGroup object.

  • The Openness property of the associated BizTalkEndPoint object to be added must be set to BIZTALK_OPENNESS_TYPE_NOTOPEN.

  • The port group specified by this object cannot contain any duplicate BizTalkPort objects.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkPortGroup::Channels Property [C++]

BizTalkPortGroup.Channels Property [Visual Basic]

The Channels property contains an ADO recordset that contains information about all BizTalkChannel objects that refer to the object.

Syntax

[C++]

Get method:

HRESULT get_Channels(
    IDispatch** ppChannelsDisp
);

[Visual Basic]

object.Channels

Parameters

[C++]

ppChannelsDisp

[out, retval] Address of a pointer to an IDispatch interface that contains an ADO recordset that contains all BizTalkChannel objects that refer to the object.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

Note

  • In addition to the HRESULT values listed on the error messages page, this method returns OLEDB provider errors. Additional information about OLEDB is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.
[Visual Basic]

This property returns an Object that contains all BizTalkChannel objects that refer to the object.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

Each record in the ADO recordset returned by this property contains information about the BizTalkChannel objects in the database that are associated with this BizTalkPortGroup object. The fields in each record contain the following information, listed in order:

  • Handle

  • Name

Additional information about Microsoft ActiveX Data Objects is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkPortGroup::Ports Property [C++]

BizTalkPortGroup.Ports Property [Visual Basic]

The Ports property contains an ADO recordset that contains information about all BizTalkPort objects that refer to the object.

Syntax

[C++]

Get method:

HRESULT Ports(
    IDispatch** ppPortsDisp
);

[Visual Basic]

object.Ports

Parameters

[C++]

ppPortsDisp

[out, retval] Address of a pointer to an IDispatch interface that contains an ADO recordset that contains all BizTalkPort objects that refer to the object.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

Note

  • In addition to the HRESULT values listed on the error messages page, this method returns OLEDB provider errors. Additional information about OLEDB is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.
[Visual Basic]

This property returns an Object that contains all BizTalkPort objects that refer to the object.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

Each record in the ADO recordset returned by this property contains information about the BizTalkPort objects in the database that are associated with this BizTalkPortGroup object. The fields in each record contain the following information, listed in order:

  • Handle

  • Name

Additional information about Microsoft ActiveX Data Objects is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkPortGroup::RemovePort Method [C++]

BizTalkPortGroup.RemovePort Method [Visual Basic]

The RemovePort method removes a BizTalkPort object from this port group.

Syntax

[C++]

HRESULT RemovePort(
    long lPortHandle
);

[Visual Basic]

object.RemovePort( _
    lPortHandle As Long _

)

Parameters

[C++]

lPortHandle

[in] Long that contains the handle to the object to remove.

[Visual Basic]

lPortHandle

Long that contains the handle to the object to remove.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

Note

  • In addition to the HRESULT values listed on the error messages page, this method returns OLEDB provider errors. Additional information about OLEDB is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.
[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

The last BizTalkPort object associated with the object cannot be removed. A BizTalkPort object cannot be removed if a BizTalkChannel object refers to it.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkServiceWindowInfo Interface [C++]

BizTalkServiceWindowInfo Object [Visual Basic]

Use the BizTalkServiceWindowInfo object to configure the service window for an associated BizTalkPort object. The service window indicates a valid time range for transmitting documents.

In C++, use the IBizTalkServiceWindowInfo interface to access the methods of the BizTalkServiceWindowInfo object.

The properties of the BizTalkServiceWindowInfo object are shown in the following table.

Property | Type | Description
FromTime | BSTR | Earliest time that the interchange can be transmitted.
IsEnabled | VARIANT_BOOL | Flag that indicates whether the service window is enabled.
ToTime | BSTR | Latest time that the interchange can be transmitted.

Remarks

The BizTalkServiceWindowInfo object is automatically created when a BizTalkPort object is instantiated with the CreatePort method of the BizTalkConfig object. Access the properties of the BizTalkServiceWindowInfo object by using the ServiceWindowInfo property of the BizTalkPort object.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkServiceWindowInfo::FromTime Property [C++]

BizTalkServiceWindowInfo.FromTime Property [Visual Basic]

The FromTime property indicates the earliest hour of any day that the interchange can be transmitted.

Syntax

[C++]

Get method:

HRESULT get_FromTime(
    BSTR* pstrFromTime
);

Put method:

HRESULT put_FromTime(
    BSTR strFromTime
);

[Visual Basic]

object.FromTime

Parameters

[C++]

Get method:

pstrFromTime

[out, retval] Pointer to a BSTR that contains the earliest time that the interchange can be transmitted.

Put method:

strFromTime

[in] BSTR that contains the earliest time that the interchange can be transmitted.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a String that contains the earliest time that the interchange can be transmitted.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

The FromTime property must contain an integer value between 0 and 23. Fractional values and minutes cannot be specified.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkServiceWindowInfo::IsEnabled Property [C++]

BizTalkServiceWindowInfo.IsEnabled Property [Visual Basic]

The IsEnabled property indicates whether a service window is enabled.

Syntax

[C++]

Get method:

HRESULT get_IsEnabled(
    VARIANT_BOOL* pbIsEnabled
);

Put method:

HRESULT put_IsEnabled(
    VARIANT_BOOL bIsEnabled
);

[Visual Basic]

object.IsEnabled

Parameters

[C++]

Get method:

pbIsEnabled

[out, retval] Pointer to a VARIANT_BOOL type that indicates whether a service window is enabled. A value of VARIANT_TRUE indicates that the service window is enabled. A value of VARIANT_FALSE indicates that the service window is not enabled.

Put method:

bIsEnabled

[in] VARIANT_BOOL type that indicates whether a service window is enabled. A value of VARIANT_TRUE indicates that the service window is enabled. A value of VARIANT_FALSE indicates that the service window is not enabled.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a String that indicates whether a service window is enabled. A value of True indicates that the service window is enabled. A value of False indicates that the service window is not enabled.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkServiceWindowInfo::ToTime Property [C++]

BizTalkServiceWindowInfo.ToTime Property [Visual Basic]

The ToTime property contains the latest hour of any day that the interchange can be transmitted.

Syntax

[C++]

Get method:

HRESULT get_ToTime(
    BSTR* pstrToTime
);

Put method:

HRESULT put_ToTime(
    BSTR strToTime
);

[Visual Basic]

object.ToTime

Parameters

[C++]

Get method:

pstrToTime

[out, retval] Pointer to a BSTR that contains the latest time that the interchange can be transmitted.

Put method:

strToTime

[in] BSTR that contains the latest time that the interchange can be transmitted.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a String that contains the latest time that the interchange can be transmitted.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

The ToTime property must contain an integer value between 0 and 23. Fractional values and minutes cannot be specified.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkTransportInfo Interface [C++]

BizTalkTransportInfo Object [Visual Basic]

Use the BizTalkTransportInfo object to configure the transport service for an associated BizTalkPort object.

In C++, use the IBizTalkTransportInfo interface to access methods of the BizTalkTransportInfo object.

The properties of the BizTalkTransportInfo object are shown in the following table.

Property | Type | Description
Address | BSTR | Destination address of the primary transport component.
Parameter | BSTR | Required return e-mail address for the associated source BizTalkOrganization object if the Type property is BIZTALK_TRANSPORT_ TYPE_SMTP.
Type | BIZTALK_TRANSPORT_ TYPE | Enumeration value that indicates the type of transport component to be used for the primary transport.

Remarks

The BizTalkTransportInfo object is automatically created when a BizTalkPort object is instantiated with the CreatePort method of the BizTalkConfig object. Access the BizTalkTransportInfo object by using the PrimaryTransport or SecondaryTransport property of the BizTalkPort object.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkTransportInfo::Address Property [C++]

BizTalkTransportInfo.Address Property [Visual Basic]

The Address property contains the destination address.

Syntax

[C++]

Get method:

HRESULT get_Address(
    BSTR* pstrTransportAddress
);

Put method:

HRESULT put_Address(
    BSTR strTransportAddress
);

[Visual Basic]

object.Address

Parameters

[C++]

Get method:

pstrTransportAddress

[out, retval] Pointer to a BSTR that contains the address.

Put method:

strTransportAddress

[in] BSTR that contains the address.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a String that contains the address.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

If the Openness property of the associated BizTalkEndPoint object is set to BIZTALK_OPENNESS_TYPE_DESTINATION, Address cannot be set, and the Type property must be set to BIZTALK_TRANSPORT_TYPE_OPENDESTINATION.

Address must have one of the following prefixes, according to the Type property:

Transport type | Prefix | Example Address value
APPINTEGRATION | Not applicable | {11111111-1111-1111-1111-111111111111}
FILE | file:// | file://C:\Test\MyFile.xml
HTTP | http:// | http://www.vigorair-18.com/repository/bts.asp
HTTPS | https:// | https://www.vigorair-18.com/secure/btss.asp
LOOPBACK | Not applicable | Not applicable
MSMQ | Not applicable | DIRECT=OS:.\private$\myqueue
NONE | Not applicable | Not applicable
OPENDESTINATION | Not applicable | Not applicable
ORCHESTRATIONACTIVATION | Not applicable | C:\XLANG\Schedules\mysched.skx
SMTP | mailto: | mailto:patricia@vigorair-18.com

Notes

  • The queue:// prefix must be used with an open messaging port when a Message Queue is specified as the destination address. For open messaging ports, the address is specified either in the document instance or as a parameter when submitting the document. For more information, see Routing.

  • When using the Orchestration Activation Component transport type, the Address property must contain the full path of the XLANG schedule on the local computer. The file:// prefix cannot be used when specifying the path of the XLANG schedule (.skx) file.

  • When using the HTTP or HTTPS transport types, BizTalk Server sends the data using a proxy server by default. This is the correct setting to transport data to computers outside of your company's firewall. However, when sending data within your company's intranet, you can bypass the use of a proxy server. To do this, you must set the UseProxy field to False in the transport dictionary. For more information, see SetConfigData.

When using the file:// transport type, you can include symbols to modify the file name. The file name created by the server contains any static characters you specified in the Address property, along with the actual value of the symbol. For example, if the Address property is set to "file://C:\Orders\Invoice_%tracking_id%.xml", the actual file name would use a format similar to: C:\Orders\Invoice_{12345678-90AB-CDEF-1234-567890ABCDEF}. The following table contains the symbols that can be used with the file:// transport type:

Symbol | Description | Unique file name
%datetime% | Date and time, in milliseconds, of the file creation. The time is based on Greenwich Mean Time (GMT) rather than local time. | No
%document_name% | Name of the document processed by BizTalk Server. | No
%server% | Host name of the server that processed the document. | No
%tracking_id% | Globally unique tracking number. | Yes
%uid% | Counter that increases over time, represented in milliseconds. This number is reset when the server is rebooted. | No

When sending reliable messaging receipts that use the SMTP transport protocol, the value specified in the identifier named Reliable Messaging Acknowledgement SMTP From Address is used as the From address. This identifier is automatically created for the default BizTalkOrganization object. This identifier cannot be removed. You should not modify the name or qualifier for this identifier, but you can modify the value. For more information, see Processing Receipts Using Reliable Messaging.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkTransportInfo::Parameter Property [C++]

BizTalkTransportInfo.Parameter Property [Visual Basic]

The Parameter property contains the required return e-mail address of the associated source BizTalkOrganization object if the Type property is set to BIZTALK_TRANSPORT_TYPE_SMTP.

Syntax

[C++]

Get method:

HRESULT get_Parameter(
    BSTR* pstrPrimaryTransportParameter
);

Put method:

HRESULT put_Parameter(
    BSTR strPrimaryTransportParameter
);

[Visual Basic]

object.Parameter

Parameters

[C++]

Get method:

pstrPrimaryTransportParameter

[out, retval] Pointer to a BSTR that contains the address.

Put method:

strPrimaryTransportParameter

[in] BSTR that contains the address.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a String that contains the address.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkTransportInfo::Type Property [C++]

BizTalkTransportInfo.Type Property [Visual Basic]

The Type property contains the enumeration value that indicates the type of transport component.

Syntax

[C++]

Get method:

HRESULT get_Type(
    BIZTALK_TRANSPORT_TYPE* pTransportType
);

Put method:

HRESULT put_Type(
    BIZTALK_TRANSPORT_TYPE TransportType
);

[Visual Basic]

object.Type

Parameters

[C++]

Get method:

pTransportType

[out, retval] Pointer to an enumeration value. Valid values are from the BIZTALK_TRANSPORT_TYPE enumeration.

Put method:

TransportType

[in] Enumeration value. Valid values are from the BIZTALK_TRANSPORT_TYPE enumeration.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns an enumeration value. Valid values are from the BIZTALK_TRANSPORT_TYPE enumeration.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

The following constraints are enforced:

  • If the Openness property of the associated BizTalkEndPoint object is set to BIZTALK_OPENNESS_TYPE_DESTINATION, the Address property cannot be set, and Type must be set to BIZTALK_TRANSPORT_TYPE_OPENDESTINATION.

When using the Message Queuing transport type (BIZTALK_TRANSPORT_TYPE_MSMQ), the following restrictions apply:

  • When using an envelope, the maximum size of a document submitted to BizTalk Server is 4MB.

  • When an envelope is not used, the maximum size of a document submitted to BizTalk Server is 2MB.

  • When using the BIZTALK_TRANSPORT_TYPE_SMTP, the Parameter property must be set to the reply-to SMTP address.

  • The transport Type of BIZTALK_TRANSPORT_TYPE_ORCHESTRATIONACTIVATION is supported only when the Openness property of the associated BizTalkEndPoint object is set to BIZTALK_OPENNESS_TYPE_TOWORKFLOW.

  • When using the Orchestration activation component type (BIZTALK_TRANSPORT_TYPE_ORCHESTRATIONACTIVATION), the maximum size of a document sent to the port on the XLANG schedule is 2MB.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BizTalkObjectModel.h
Library: Use Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IDictionary Interface [C++]

CDictionary Object [Visual Basic]

The Dictionary object is a collection object that supports the creation, storage, and retrieval of name/value pairs in memory. This object is used by several methods in the BizTalk Messaging Configuration object model.

In C++, use the IDictionary interface to access the methods of the Dictionary object. In Microsoft Visual Basic, the CDictionary class defines the methods and properties of a Dictionary object.

The properties of the Dictionary object are shown in the following table.

Property | Type | Description
Count | long | Number of entries in the Dictionary object. This is a read-only property.
NewEnum | IUnknown | Returns the IUnknown interface pointer for the Dictionary object. The caller can use this interface pointer to call QueryInterface for the enumerator for this object. This is a read-only property.
Prefix | BSTR | Filter that excludes all entries with a specific prefix when the contents of the Dictionary object are saved.
Value | VARIANT | Value associated with an entry name.

The methods of the Dictionary object are shown in the following table.

Method | Description
GetMultiple | Returns the values of multiple entries from the Dictionary object.
PutMultiple | Adds specified entries to the Dictionary object or changes them.

Remarks

A Dictionary object is designed to be a general-purpose collection. Therefore, it can be used for anything that is supported by its internal structure. Every value in a Dictionary object is a Variant. This means that a Dictionary object can be created that consists of almost any kind of value (including other Dictionary objects).

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include commerce.h
Library: Use Microsoft Commerce 2000 Core Components Type Library (MscsCore.dll)


IDictionary::Count Property [C++]

CDictionary.Count Property [Visual Basic]

The Count property returns the number of elements in the Dictionary object.

Syntax

[C++]

HRESULT get_Count(
    long* Count
);

[Visual Basic]

object.Count

Parameters

[C++]

Count

[out, retval] Long used to return the count.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a Long that contains the count.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This property is read-only.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include commerce.h
Library: Use Microsoft Commerce 2000 Core Components Type Library (MscsCore.dll)


IDictionary::GetMultiple Method [C++]

CDictionary.GetMultiple Method [Visual Basic]

The GetMultiple method returns multiple entries from the Dictionary object.

Syntax

[C++]

HRESULT GetMultiple(
    long cb,
    const LPOLESTR rgolestr[],
    VARIANT rgvar[]
);

[Visual Basic]

object.GetMultiple( _
    cb As Long, _
    rgolestr As String, _
    rgvar As Variant _
)

Parameters

[C++]

cb

[in] Long that specifies the number of values to retrieve.

rgolestr

[in, size_is(cb)] Array of string values that identifies the Dictionary object entries for which the values should be retrieved.

rgvar

[out, size_is(cb)] Array of VARIANTs. When GetMultiple returns, this array contains the values associated with the Dictionary object entries identified by the rgolestr[] array.

[Visual Basic]

cb

Long that specifies the number of values to retrieve.

rgolestr

Array of string values that identifies the CDictionary object entries for which the values should be retrieved.

rgvar

Array of Variants. When GetMultiple returns, this array contains the values associated with the CDictionary object entries identified by the rgolestr array.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

If you call PutMultiple or GetMultiple from Microsoft Visual Basic Scripting Edition (VBScript), these methods fail because they require data types that VBScript does not support.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include commerce.h
Library: Use Microsoft Commerce 2000 Core Components Type Library (MscsCore.dll)


IDictionary::NewEnum Property [C++]

CDictionary.NewEnum Property [Visual Basic]

[C++]

The NewEnum property retrieves an Enumerator object that implements the IEnumVariant interface of the Dictionary object.

[Visual Basic]

This property is not available in Microsoft Visual Basic.

Syntax

[C++]

Get method:

HRESULT get_NewEnum(
    IUnknown** _NewEnum
);

[Visual Basic]

Not applicable

Parameters

[C++]

_NewEnum

[out, retval] Address of a pointer to an IUnknown interface for an object that implements the IEnumVariant of this collection. You can call QueryInterface through the returned pointer to retrieve a pointer to the IEnumVariant for this object. To retrieve the values associated with these elements, you can retrieve the elements in turn, using the Next method of the IEnumVariant interface, and call the Value method on those elements.

[Visual Basic]

Not applicable

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

Not applicable

Error Value [Visual Basic]

[Visual Basic]

Not applicable

Remarks

[C++]

This property is read-only.

[Visual Basic]

Not applicable

Requirements

[C++]

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include commerce.h

[Visual Basic]

Not applicable


IDictionary::Prefix Property [C++]

CDictionary.Prefix Property [Visual Basic]

The Prefix property contains a filter that excludes entries with a specific prefix when the contents of the Dictionary object are saved.

Syntax

[C++]

Get method:

HRESULT get_Prefix(
    BSTR* Prefix
);

Put method:

HRESULT put_Prefix(
    BSTR Prefix
);

[Visual Basic]

object.Prefix

Parameters

[C++]

Get method:

Prefix

[out, retval] Pointer to a BSTR that contains the prefix.

Put method:

Prefix

[in] BSTR that contains the prefix.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a String that contains the prefix.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

Any name/value pair with a name beginning with the specified prefix is not saved to the database. The prefix default is an underscore (_). Therefore, any keywords that begin with an underscore are not saved unless the prefix is changed.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include commerce.h
Library: Use Microsoft Commerce 2000 Core Components Type Library (MscsCore.dll)


IDictionary::PutMultiple Method [C++]

CDictionary.PutMultiple Method [Visual Basic]

The PutMultiple method adds specified entries to the Dictionary object or changes them.

Syntax

[C++]

HRESULT PutMultiple(
    long cb,
    const LPOLESTR rgolestr[],
    const VARIANT rgvar[]
);

[Visual Basic]

object.PutMultiple( _
    cb As Long, _
    rgolestr As String, _
    rgvar As Variant _
)

Parameters

[C++]

cb

[in] Long that identifies the number of elements in the rgolestr and rgvar arrays.

rgolestr

[in, size_is(cb)] Array of strings that contains the names to add to the Dictionary object.

rgvar

[in, size_is(cb)] Array of VARIANTs that contains the values to add to the Dictionary object.

[Visual Basic]

cb

Long that identifies the number of elements in the rgolestr and rgvar arrays.

rgolestr

Array of Strings that contains the names to add to the CDictionary object.

rgvar

Array of Variants that contains the values to add to the CDictionary object.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

A one-to-one mapping exists between the elements of the rgolestr and rgvar arrays. This means that rgolestr[n] is added to the Dictionary object and is initialized to rgvar[n]. If the element specified by rgolestr[n] is already in the Dictionary object, the value associated with the element is overwritten with the value stored in rgvar[n].

[Visual Basic]

If you call PutMultiple or GetMultiple from Microsoft Visual Basic Scripting Edition (VBScript), these methods fail because they require data types that VBScript does not support.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include commerce.h
Library: Use Microsoft Commerce 2000 Core Components Type Library (MscsCore.dll)


IDictionary::Value Property [C++]

CDictionary.Value Property [Visual Basic]

The Value property returns or sets the value associated with an entry name.

Syntax

[C++]

Get method:

HRESULT get_Value(
    BSTR bstrName,
    VARIANT* Value
);

Put method:

HRESULT put_Value(
    BSTR bstrName,
    VARIANT Value
);

[Visual Basic]

object.Value( _
    bstrName As String _
)

Parameters

[C++]

Get method:

bstrName

[in] BSTR that contains the name.

Value

[out, retval] Pointer to a VARIANT used to return the value.

Put method:

bstrName

[in] BSTR that contains the name.

Value

[in] When putting the property, a VARIANT that contains the value.

[Visual Basic]

bstrName

String that contains the name.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property optionally returns a Variant that contains the value.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

The value of a Dictionary object can be read or written to without explicitly using the Value method by treating the named entry as a property of the Dictionary object.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include commerce.h
Library: Use Microsoft Commerce 2000 Core Components Type Library (MscsCore.dll)


ISimpleList Interface [C++]

CSimpleList Object [Visual Basic]

Use the SimpleList object to create an array of variants that supports enumeration.

In C++, use the ISimpleList interface to access methods of the SimpleList object. In Microsoft Visual Basic, the CSimpleList class defines the methods and properties of a SimpleList object.

The properties of the SimpleList object are shown in the following table.

Property | Type | Description
Count | long | Number of elements in the SimpleList object. This is a read-only property.
Item | VARIANT | Container for an element of the SimpleList object.

The methods of the SimpleList object are shown in the following table.

Method | Description
Add | Adds the specified item to the SimpleList object.
Delete | Deletes the specified item from the SimpleList object.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include commerce.h
Library: Use Microsoft Commerce 2000 Core Components Type Library (MscsCore.dll)


ISimpleList::Add Method [C++]

CSimpleList.Add Method [Visual Basic]

The Add method adds the specified item to the SimpleList object.

Syntax

[C++]

HRESULT Add(
    VARIANT* pVar
);

[Visual Basic]

object.Add( _
    pVar As Variant _
)

Parameters

[C++]

pVar

[in] Pointer to the VARIANT to add to the SimpleList object.

[Visual Basic]

pVar

Variant to add to the CSimpleList object.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include commerce.h
Library: Use Microsoft Commerce 2000 Core Components Type Library (MscsCore.dll)


ISimpleList::Count Property [C++]

CSimpleList.Count Property [Visual Basic]

The Count property returns the number of elements in the SimpleList object.

Syntax

[C++]

Get method:

HRESULT get_Count(
    long* Count
);

[Visual Basic]

object.Count

Parameters

[C++]

Count

[out, retval] Pointer to a long used to return the number of items in the SimpleList object.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a Long that contains the number of items in the CSimpleList object.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This property is read-only.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include commerce.h
Library: Use Microsoft Commerce 2000 Core Components Type Library (MscsCore.dll)


ISimpleList::Delete Method [C++]

CSimpleList.Delete Method [Visual Basic]

The Delete method deletes the specified item from the SimpleList object.

Syntax

[C++]

HRESULT Delete(
    long Index
);

[Visual Basic]

object.Delete( _
    Index As Long _
)

Parameters

[C++]

Index

[in] Long that contains the index value of the item to delete.

[Visual Basic]

Index

Long that contains the index value of the item to delete.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include commerce.h
Library: Use Microsoft Commerce 2000 Core Components Type Library (MscsCore.dll)


ISimpleList::Item Property [C++]

CSimpleList.Item Property [Visual Basic]

The Item property is a read/write Variant that contains an element of the SimpleList object. An initialized Variant is stored at a specified array index. If an item is already stored at the specified index, that item is overwritten by the put method.

Syntax

[C++]

Get method:

HRESULT get_Item(
    long Index
    VARIANT* Item
);

Put method:

HRESULT put_Item(
    long Index,
    VARIANT Item
);

Putref method:

HRESULT putref_Item(
    long Index,
    VARIANT Item
);

[Visual Basic]

object.Item( _
    Index As Long _
)

Parameters

[C++]

Get method:

Index

[in] Long that contains the index of the item.

Item

[out, retval] Pointer to a VARIANT used to return the item.

Put and Putref methods:

Index

[in] Long that contains the index of the item.

Item

[in] VARIANT that contains the new item.

[Visual Basic]

Index

Long that contains the index of the item.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a Variant that contains the new item.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

When putting a value, use the putref_Item method if you are setting an object reference; use the put_Item method if you are setting a scalar value.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include commerce.h
Library: Use Microsoft Commerce 2000 Core Components Type Library (MscsCore.dll)


Object Model Enumerations

The following enumerations provide possible values of properties and parameters:

  • BIZTALK_ENCODING_TYPE

  • BIZTALK_ENCRYPTION_TYPE

  • BIZTALK_OPENNESS_TYPE

  • BIZTALK_OPENNESS_TYPE_EX

  • BIZTALK_SIGNATURE_TYPE

  • BIZTALK_STORE_TYPE

  • BIZTALK_TRANSPORT_TYPE

  • BIZTALK_USAGE_TYPE

  • BIZTALK_CONFIGDATA_TYPE


BIZTALK_ENCODING_TYPE

The BIZTALK_ENCODING_TYPE enumeration has one of the following values:

Name | Value | Description
BIZTALK_ENCODING_TYPE_NONE | 1 | Specifies that encoding is not used.
BIZTALK_ENCODING_TYPE_MIME | 2 | Specifies Multipurpose Internet Mail Extensions (MIME) encoding.
BIZTALK_ENCODING_TYPE_CUSTOM | 3 | Specifies custom encoding.


BIZTALK_ENCRYPTION_TYPE

The BIZTALK_ENCRYPTION_TYPE enumeration has one of the following values:

Name | Value | Description
BIZTALK_ENCRYPTION_TYPE_NONE | 1 | Specifies that encryption is not used.
BIZTALK_ENCRYPTION_TYPE_CUSTOM | 2 | Specifies custom encryption.
BIZTALK_ENCRYPTION_TYPE_SMIME | 4 | Specifies Secure Multipurpose Internet Mail Extensions (S/MIME) encryption.


BIZTALK_OPENNESS_TYPE

The BIZTALK_OPENNESS_TYPE enumeration has one of the following values:

Name | Value | Description
BIZTALK_OPENNESS_TYPE_NOTOPEN | 1 | Specifies that this instance of the object is not open.
BIZTALK_OPENNESS_TYPE_SOURCE | 2 | Specifies that the source organization of this instance of the object is open.
BIZTALK_OPENNESS_TYPE_DESTINATION | 4 | Specifies that the destination organization of this instance of the object is open.


BIZTALK_OPENNESS_TYPE_EX

The BIZTALK_OPENNESS_TYPE_EX enumeration has one of the following values:

Name | Value | Description
BIZTALK_OPENNESS_TYPE_EX_NOTOPEN | 1 | Specifies that this instance of the object is not open.
BIZTALK_OPENNESS_TYPE_EX_SOURCE | 2 | Specifies that the source organization of this instance of the object is open.
BIZTALK_OPENNESS_TYPE_EX_DESTINATION | 4 | Specifies that the destination organization of this instance of the object is open.
BIZTALK_OPENNESS_TYPE_EX_FROMWORKFLOW | 8 | Specifies that BizTalk Server is receiving a document from an XLANG schedule instance.
BIZTALK_OPENNESS_TYPE_EX_TOWORKFLOW | 16 | Specifies that BizTalk Server is sending a document to an XLANG schedule instance.


BIZTALK_SIGNATURE_TYPE

The BIZTALK_SIGNATURE_TYPE enumeration has one of the following values:

Name | Value | Description
BIZTALK_SIGNATURE_TYPE_NONE | 1 | Specifies that there is no signature.
BIZTALK_SIGNATURE_TYPE_CUSTOM | 2 | Specifies the custom signature of the document.
BIZTALK_SIGNATURE_TYPE_SMIME | 4 | Specifies the S/MIME signature of the document.


BIZTALK_STORE_TYPE

The BIZTALK_STORE_TYPE enumeration has one of the following values:

Name | Value | Description
BIZTALK_STORE_TYPE_MY | 1 | Specifies that the certificate store is type MY. This store contains certificates authorized only by your organization.
BIZTALK_STORE_TYPE_BIZTALK | 2 | Specifies that the certificate is stored in the dedicated BizTalk Server 2000 store.


BIZTALK_TRANSPORT_TYPE

The BIZTALK_TRANSPORT_TYPE enumeration has one of the following values:

Name | Value | Description
BIZTALK_TRANSPORT_TYPE_NONE | 1 | Specifies that this instance of the object does not select a transport component.
BIZTALK_TRANSPORT_TYPE_HTTP | 4 | Specifies that this instance of the object selects a Hypertext Transport Protocol (HTTP) transport component.
BIZTALK_TRANSPORT_TYPE_SMTP | 8 | Specifies that this instance of the object selects a Simple Mail Transfer Protocol (SMTP) transport component.
BIZTALK_TRANSPORT_TYPE_ APPINTEGRATION | 32 | Specifies that this instance of the object selects an application integration component (AIC) transport component.
BIZTALK_TRANSPORT_TYPE_MSMQ | 128 | Specifies that this instance of the object selects a Microsoft Message Queuing transport component.
BIZTALK_TRANSPORT_TYPE_FILE | 256 | Specifies that this instance of the object selects a file as a transport component.
BIZTALK_TRANSPORT_TYPE_HTTPS | 1024 | Specifies that this instance of the object selects a Secure Hypertext Transfer Protocol (HTTPS) transport component.
BIZTALK_TRANSPORT_TYPE_ OPENDESTINATION | 2048 | Specifies that the messaging port is an open destination.
BIZTALK_TRANSPORT_TYPE_LOOPBACK | 4096 | Specifies that the document submitted to the server with the SubmitSync method will be processed and then returned back as the response document of the method.
BIZTALK_TRANSPORT_TYPE_ORCHESTRATIONACTIVATION | 8192 | Specifies that the Address property contains the path of an XLANG schedule to be executed.


BIZTALK_USAGE_TYPE

The BIZTALK_USAGE_TYPE enumeration has one of the following values:

Name | Value | Description
BIZTALK_USAGE_TYPE_ENCRYPTION | 1 | Specifies that this is an encryption certificate.
BIZTALK_USAGE_TYPE_SIGNATURE | 2 | Specifies that this is a signature certificate.
BIZTALK_USAGE_TYPE_BOTH | 4 | Specifies that this certificate is used for both encryption and signature.


BIZTALK_CONFIGDATA_TYPE

The BIZTALK_CONFIGDATA_TYPE enumeration has one of the following values:

Name | Value | Description
BIZTALK_CONFIGDATA_TYPE_PRIMARYTRANSPORT | 0 | Configures the primary transport on the messaging port.
BIZTALK_CONFIGDATA_TYPE_SECONDARYTRANSPORT | 1 | Configures the secondary transport on the messaging port.
BIZTALK_CONFIGDATA_TYPE_ENCRYPTION | 2 | Configures the encryption certificate on the messaging port.
BIZTALK_CONFIGDATA_TYPE_ENCODING | 3 | Configures the encoding type on the messaging port.
BIZTALK_CONFIGDATA_TYPE_SIGNATURE | 4 | Configures the signature verification on the messaging port.
BIZTALK_CONFIGDATA_TYPE_SERIALIZER | 5 | Configures the serializer on the messaging port.


Error Messages

The properties and methods of the BizTalk Messaging Configuration object model use standard Component Object Model (COM) HRESULT return values to communicate whether the operation was successful or not.

In C++, these values are the actual return values from the methods themselves (including property get_ and put_ methods). The program must explicitly perform error checking by examining these return values, or use some variation of structured error handling.

In Microsoft Visual Basic (VB), and in Visual Basic Scripting Edition (VBS), these values are placed in the Number property of the global Err object. Error handling is either handled automatically, displaying a standard error dialog box, or explicitly by the program, checking the value of the Number property of the global Err object. The On Error Resume Next command disables automatic error handling, thereby enabling explicit error handling.

For additional information about error message values, see the following sections:

  • Standard COM Errors

  • BizTalk Server 2000 Error Messages


Standard COM Errors

The following table shows the most common standard COM errors returned by the properties and methods of the BizTalk Server objects.

Constant | Value (32-bit) | Description
S_OK | 00000000 | The standard return value used to communicate successful completion.
S_FALSE | 00000001 | An alternate success value, typically used to communicate successful, but non-standard completion. The precise meaning depends on the method or property in question.
E_UNEXPECTED | 8000FFFF | Catastrophic failure error.
E_NOTIMPL | 80004001 | Not implemented error.
E_OUTOFMEMORY | 8007000E | Out of memory error.
E_INVALIDARG | 80070057 | One or more arguments are not valid error.
E_NOINTERFACE | 80004002 | Interface not supported error.
E_POINTER | 80004003 | Pointer not valid error.
E_HANDLE | 80070006 | Handle not valid error.
E_ABORT | 80004004 | Operation aborted error.
E_FAIL | 80004005 | Unspecified error.
E_ACCESSDENIED | 80070005 | General access denied error.
MK_E_NOOBJECT | 800401E5 | The object identified by this moniker could not be found.

Additional information may be available using the global Err object. In Visual Basic, the Description property of the Err object may contain a text description of the error.

In C++, call the OLE DB method GetErrorInfo on the IErrorRecords interface to retrieve the most recently set IErrorInfo pointer in the current logical thread. The GetDescription method of the IErrorInfo interface may return a text description of the error. For more information about the GetErrorInfo method, go to the MSDN Online Library Web site (msdn.microsoft.com/library/default.asp) and browse to OLE DB Interfaces in the Platform SDK.


BizTalk Server 2000 Error Messages

The BizTalk Messaging Configuration object model error messages defined by BizTalk Server can be used in your application by including the bts_config_errors.h file located in the BizTalk Server installation directory at \Program Files\Microsoft BizTalk Server\SDK\Include. These error messages, returned during design time by the methods and properties of the object model, contain a BTS_ prefix in the message name. All other errors occur during run time, while BizTalk Server is processing a document.

The following table contains both design time and run time errors.

Message name | Value | Description
CIS_E_OBJECT_NOT_FOUND | 0x0100 | The object was not found.
CIS_E_STATE_NOT_FOUND | 0x0101 | The state engine state was not found in the messaging port definition.
CIS_E_STATE_TRANSITION | 0x0103 | The state table contains a bad engine state transition.
CIS_E_BAD_ENGINE_CONFIG_FILE | 0x0105 | The string that describes the input state configuration is not valid.
CIS_E_CANNOT_ADD_STATE | 0x0106 | BizTalk Server could not add the user-defined state to the system.
CIS_E_NO_COMPONENT_FOUND | 0x0107 | There is no component in the state definition or the ProgID is wrong.
CIS_E_PIPECOMP_ADMIN_REQUIRED | 0x0108 | The required IPipelineComponentAdmin interface was not found on the component.
CIS_E_BAD_COMPONENT_TYPE | 0x0109 | The component type specified for the state engine is not recognized.
CIS_E_BAD_STATE_CONFIG | 0x010A | The state configuration is not valid.
CIS_E_BAD_STATE_TYPE | 0x010B | The specified state type is not recognized.
CIS_E_BAD_COMPONENT_CONFIG | 0x010C | The component configuration is not valid.
CIS_E_INTERNAL_FAILURE | 0x010F | An internal server failure occurred due to an unknown cause.
CIS_E_CREATE_SCHEDULER_FAILED | 0x0111 | The Queue Scheduler for the service could not be created.
CIS_E_AGREEMENT_SELECT_FAILED | 0x0112 | No channels matched the input criteria. Verify that a messaging port and a channel exist, and that they match the following fields: Source qualifier: "%1" Source identifier value: "%2" Source document name: "%3" Destination qualifier: "%4" Destination identifier value: "%5" Also verify that any expressions specified for the channels are compatible with this document.
CIS_E_ERROR | 0x0113 | An error occurred in BizTalk Server.%n %n Details:%n ------------------------------%n %1
CIS_E_SERVICE_INITIALIZATION_FAILURE | 0x0114 | The service failed to start. Verify that this server is enlisted in a BizTalk Server group.
CIS_E_SCHEDULER_FAILED | 0x0115 | The Queue Scheduler failed and has exited.
CIS_E_WORKER_THREAD_FAILED | 0x0116 | A worker thread failed and has exited.
CIS_E_SHARED_QUEUE_DB_EXEC_FAILED | 0x0117 | Execution against the Shared Queue database has failed.
CIS_E_CANT_READ_WORK_ITEM | 0x0119 | A work item in the Shared Queue database cannot be read.
CIS_E_CHECKPOINT_FAILED | 0x011c | Checkpointing the work item failed.
CIS_E_CREATE_DEAD_WORK_ITEM_FAILED | 0x011e | A new work item in the Suspended queue cannot be created.
CIS_E_GET_SNAPSHOT_FAILED | 0x0122 | A snapshot of the Shared Queue database cannot be taken.
CIS_E_FREE_INTERCHANGES_FAILED | 0x0124 | The specified interchanges cannot be freed.
CIS_E_DELETE_INTERCHANGE_FAILED | 0x0125 | The specified interchange cannot be deleted.
CIS_E_RECEIVING_INTERCHANGE_FAILED | 0x0127 | The specified interchange was not received.
CIS_E_GETTING_NEXT_SCHEDULED_WORK_ITEM_FAILED | 0x0128 | The next scheduled work item cannot be obtained for processing.
CIS_E_GET_COUNT_FAILED | 0x0129 | The count on the shared queues cannot be obtained.
CIS_E_TRANSMISSION_FAILED | 0x012a | All retry transmissions failed.
CIS_W_TRANSMISSION_ATTEMPT_FAILED | 0x012b | A transmission attempt failed.
CIS_W_TRANSMISSION_XFER_TO_SECONDARY | 0x012c | The primary transport for messaging port "%1" cannot transmit the data. The server will switch to the secondary transport.
CIS_E_RECEIPT_GENERATION_FAILED | 0x012e | After creating the work item, the attempt to generate a receipt failed.
CIS_E_RECEIPT_GENERATION_FAILED_NO_WORK_ITEM | 0x012f | The attempt to generate a receipt failed before the work item was created.
CIS_E_L1_RECEIPT_CORRELATION_FAILED | 0x0130 | Receipt correlation failed.
CIS_E_AGREEMENT_LACKING_PARAMS | 0x0133 | At least one of the fields necessary to select a channel is missing. Verify that your document and envelopes extract the proper fields for the parser, or specify the necessary fields upon submission. Channel selection fields: Source identifier type: "%1" Source identifier value: "%2" Source document name: "%3" Destination identifier type: "%4" Destination identifier value: "%5"
CIS_E_AGREEMENT_FAILED | 0x0134 | The channel cannot be selected.
CIS_E_ORIGINAL_L1_INTERCHANGE_MISSING | 0x0135 | When trying to correlate an incoming receipt, the original interchange and related document(s) are no longer present.
CIS_E_UNEXPECTED_DB_BEHAVIOR | 0x0136 | An unexpected return occurred. The database may need to be restarted.
CIS_E_AGREEMENT_INVALID_MAP | 0x0137 | The map specified by the reference "%1" is not valid. Verify that the reference points to a valid map created by BizTalk Mapper.
CIS_I_SERVICE_MSG | 0x0138 | 1%
CIS_E_AGREEMENT_MAP_FAILED | 0x0139 | The XML document could not be translated. The map specified by reference "%1" failed. Verify that the map is up to date.
CIS_E_XML_ERROR | 0x013A | The XML document could not be parsed on line: %2, position: %3 for the following reason: "%1"
CIS_E_AGREEMENT_PROCESSING_FAILED | 0x013f | The server could not finish processing the document.
CIS_E_AGREEMENT_PROCESSING_FAILED_W_NAME | 0x0140 | The following channel configuration setting is not valid: "%1"
CIS_E_AGREEMENT_INVALID_QUERY | 0x0141 | The "%2" query for the "%1" document tracking field is not a valid XSL pattern. This pattern must be removed or corrected.
CIS_I_SERVICE_START | 0x0142 | The service has started.
CIS_I_SERVICE_STOP | 0x0143 | The service has stopped.
CIS_E_ERROR_EX | 0x0144 | An error occurred in BizTalk Server.%n %n Details:%n ------------------------------%n %1 %2 %3 %4 %5 %6 %7 %8 %9 %n
CIS_E_ERROR_EX_HEAD | 0x0145 | ======================================== ======================================= Date: %1 Source: BizTalk Server 2000 Time: %2 Category: BizTalk Server 2000 User: %3 Computer: %4 Description: An error occurred in BizTalk Server. Details: -------
CIS_E_ERROR_EX_FOOT | 0x0146 |
CIS_E_INVALID_DATA_FORMAT | 0x0147 | The business document that was passed in is not in a recognized format and could not be parsed or decrypted.
CIS_E_CREATE_ENGINE | 0x0148 | BizTalk Server was unable to create a new instance of the processing engine to process a work item. This might be due to a failure to create a new COM+ transaction.
CIS_E_MISSING_DESTINATION_DOCUMENT_SPEC | 0x0149 | BizTalk Server has detected an incomplete messaging port. The destination specification is missing from the messaging port.
CIS_E_PROCESSING_THREAD_FAILED | 0x014A | The processing thread failed to start. This might be due to a failure to create the state engine.
CIS_E_NOSRCORG | 0x014B | No source organization that corresponds to the ID and Qualifier pair has been specified.
CIS_E_NODESTORG | 0x014C | No destination organization that corresponds to the Identifier and Qualifier pair has been specified.
CIS_E_NODOC | 0x014D | No document that corresponds to the document name has been specified.
CIS_E_NOPIPELINES | 0x014E | No channel that corresponds to the parameters has been specified.
CIS_E_NOT_RESUBMITTABLE | 0x014F | The state of the item in the Suspended queue does not allow resubmission.
CIS_E_PIPESELECT_POLICY_FAILED | 0x0150 | No channels matched the certificates that were found with the incoming data. The following certificates accompanied the submitted data: Signature certificate reference: "%1" Encryption certificate reference: "%2"
CIS_E_SUBMIT_INVALIDDOC | 0x0151 | The submitted document is not valid. See the following messages for more details.
CIS_E_SUBMITSYNC_TOOMANYDOCS | 0x0152 | The SubmitSync method failed because multiple documents where found within the data. Only one document is allowed per synchronous submission. If this is a structured flat-file submission, then the most common cause of failure is extra leading or trailing white space around the data.
CIS_E_SUBMITSYNC_TOOMANYPIPES | 0x0153 | The synchronous submission could not be completed because multiple valid channels matched the incoming document. Only one channel is allowed to match the incoming document.
CIS_E_XMIT_NOTRANSPORTCOMP | 0x0154 | This server could not create a component with the class ID "%1" for transport. Verify that this component is properly registered. The following error was returned:
CIS_E_XMIT_EMPTY_DOCUMENT | 0x0155 | Messaging port "%1" cannot transmit a zero-byte document.
CIS_E_XMIT_FAILED_W_NAME | 0x0156 | The server could not finish processing messaging port "%1".
CIS_E_XMIT_NO_INTERFACE | 0x0157 | The server could not obtain the "%1" interface from the transport component with CLSID "%2".
CIS_E_XMIT_NO_BTS_AIC_INTERFACES | 0x0158 | The server could not obtain either the "%1" or "%2" interfaces from the BizTalk Server application integration component with CLSID "%3".
CIS_E_XMIT_FAILED_W_DETAILS | 0x0159 | The server encountered a transport error while processing the messaging port "%1", which uses a transport component with a ProgID of "%2".
CIS_E_NOHDR_ERROR_EX | 0x015A | %1 %2 %3 %4 %5 %6 %7 %8 %9 %n
CIS_W_COMP_NOACK | 0x015B | The correlation component "%1" could not find a document for which to send a receipt. No action will be taken.
CIS_E_CORRELATIONCOMP_FAILED | 0x015C | The correlation component "%1" returned an unexpected failure. The document will be placed in the Suspended queue.
CIS_E_CORRELATION_FAILED | 0x015D | Receipt correlation processing failed.
CIS_E_XML_VALIDATE_ERROR | 0x015E | The XML document has failed validation for the following reason: %1
CIS_E_CHANNEL_ACCESSDENIED | 0x015F | The submitted document does not have the necessary signature or encryption required by channel "%3". The following certificates accompanied the submitted data: Signature certificate reference: "%1" Encryption certificate reference: "%2"
CIS_I_SERVICE_RESTARTING | 0x0160 | The service is restarting.
BTS_E_CONSTRAINT | 0x1201 | Constraint Error
BTS_E_NOOBJECT | 0x1202 | The object was not found.
BTS_E_INTERNALFAILURE | 0x1203 | An internal failure occurred.
BTS_E_ENVELOPE_CONTROLNUMBER | 0x120C | If the envelope format is set to X12 or EDIFACT, the control number value must be set to a number greater than or equal to 1.
BTS_E_ENVELOPE_DELIMETER | 0x120D | If the envelope format is set to X12, then delimiters are required and must be set.
BTS_E_ENCRYPTION_CUSTOM_NOCLSID | 0x120E | If the encryption type is Custom, then the class identifier (CLSID) must also be specified.
BTS_E_ENCODING_CUSTOM_NOCLSID | 0x120F | If the encoding type is Custom, then the class identifier (CLSID) must also be specified.
BTS_E_SIGNATURE_CUSTOM_NOCLSID | 0x1210 | If the signature type is Custom, then the class identifier (CLSID) must also be specified.
BTS_E_INVALIDCONTROLNUMBER | 0x1212 | The control number value must be set to a number greater than or equal to 1.
BTS_E_ENVELOPE_INUSE | 0x1213 | The format of the envelope cannot be changed because it is used in a messaging port.
BTS_E_CHANNEL_MISSINGMAPSOURCE | 0x1215 | The channel is missing the MapSource node.
BTS_E_INVALID_CERT_USAGE | 0x1216 | The certificate is not valid for the current usage. An encryption certificate cannot be used for signing; nor can a signing certificate be used for encryption. Make sure that the correct certificate is selected.
BTS_E_MISSINGSMTPHOST | 0x1218 | The SMTP host is missing. The SMTP host can be configured in BizTalk Server Administration.
BTS_E_INVALID_ENCRYPT_STORE | 0x1219 | The encryption store type is not valid. The store type must be BIZTALK.
BTS_E_INVALID_SGNTCERT_STORE | 0x121A | The signature store type is not valid. The store type must be MY.
BTS_E_DATATOOLONG | 0x121B | The data length is too long.
BTS_E_INVALID_VERIFY_ENCRYPTCERT_STORE | 0x121C | The encryption verification store type is not valid. The store type must be MY.
BTS_E_INVALID_VERIFY_SGNTCERT_STORE | 0x121D | The signature verification store type is not valid. The store type must be BIZTALK.
BTS_E_ORGANIZATION_UNIQUE_ID | 0x121F | The organization identifier must be a unique identifier.
BTS_E_ORGANIZATION_UNIQUE_NAME | 0x1220 | The organization name must be a unique name.
BTS_E_OBJECT_ALREADY_EXISTS | 0x1221 | The object already exists. You cannot call the Create() method on a BizTalk Messaging Configuration object multiple times without also calling the Clear() or Remove() methods.
BTS_E_ALIAS_UNIQUE_ID | 0x1222 | The identifier must be a unique identifier.
BTS_E_ALIAS_UNIQUE_NAME | 0x1223 | The identifier name for this organization must be a unique name.
BTS_E_ALIAS_UNIQUE_QUALIFIERVALUE | 0x1225 | The identifier must have a unique qualifier-value pair.
BTS_E_ALIAS_FOREIGN_OWNERID | 0x1226 | The organization cannot be removed because it is referred to by an identifier.
BTS_E_XMLSHARE_UNIQUE_ID | 0x1227 | The primary identifier for the XML Share table in the SQL Server database must be a unique identifier.
BTS_E_XMLSHARE_UNIQUE_REFERENCE | 0x1228 | The reference for the XML Share table in the SQL Server database must be a unique reference.
BTS_E_DOCUMENT_UNIQUE_ID | 0x1229 | The document identifier must be a unique identifier.
BTS_E_DOCUMENT_UNIQUE_NAME | 0x122A | The document name must be a unique name.
BTS_E_DOCUMENT_FOREIGN_SHAREID | 0x122C | The XML Share table in the SQL Server database cannot be removed because it is referred to by a document.
BTS_E_ENVELOPE_UNIQUE_ID | 0x122D | The envelope identifier must be a unique identifier.
BTS_E_ENVELOPE_UNIQUE_NAME | 0x122E | The envelope name must be a unique name.
BTS_E_ENVELOPE_FOREIGN_SHAREID | 0x1230 | The XML Share table in the SQL Server database cannot be removed because it is referred to by an envelope.
BTS_E_CONTROLNUMBER_UNIQUE_ID | 0x1231 | The control-number identifier must be a unique identifier.
BTS_E_PORTGROUP_UNIQUE_ID | 0x1232 | The distribution list identifier must be a unique identifier.
BTS_E_PORTGROUP_UNIQUE_NAME | 0x1233 | The distribution list name must be a unique name.
BTS_E_MISSING_VALUE | 0x1235 | The identifier value property must have a value.
BTS_E_MISSING_SRCORGID | 0x1236 | The Channel SourceOrganization property must have a value.
BTS_E_APPLICATION_UNIQUE_ID | 0x1237 | The application identifier must be a unique identifier.
BTS_E_APPLICATION_FOREIGN_OWNERID | 0x1238 | The organization cannot be removed because it is referred to by an application.
BTS_E_APPLICATION_UNIQUE_NAME | 0x1239 | For applications within this organization, the application name must be a unique name.
BTS_E_CHANNEL_UNIQUE_ID | 0x123A | The channel identifier must be a unique identifier.
BTS_E_CHANNEL_UNIQUE_NAME | 0x123B | The channel name must be a unique name.
BTS_E_CHANNEL_FOREIGN_INPDOCID | 0x123D | The inbound document cannot be removed because it is used by a channel.
BTS_E_CHANNEL_FOREIGN_OUTDOCID | 0x123E | The output document cannot be removed because it is used by a channel.
BTS_E_CHANNEL_FOREIGN_PORTGROUPID | 0x123F | The distribution list cannot be removed because it is used by a channel.
BTS_E_CHANNEL_FOREIGN_SRCORGID | 0x1240 | The source organization cannot be removed because it is used by a channel.
BTS_E_ENVELOPE_INVALIDFORMAT | 0x1241 | The only valid envelope-format strings are: Custom, Custom XML, EDIFACT, Flatfile, X12, and Reliable. The previously specified format will remain unchanged.
BTS_E_CHANNEL_FOREIGN_CONTROLNUMID | 0x1242 | The control number cannot be removed because it is used by an channel.
BTS_E_PORT_UNIQUE_ID | 0x1243 | The messaging port identifier must be a unique identifier.
BTS_E_PORT_UNIQUE_NAME | 0x1244 | The messaging port name must be a unique name.
BTS_E_CHANNEL_FOREIGN_SRCAPPID | 0x1247 | The source application cannot be removed because it is used by a channel.
BTS_E_PORT_FOREIGN_DSTORGID | 0x1248 | The destination organization cannot be removed because it is used by a messaging port.
BTS_E_PORT_FOREIGN_DSTALIASID | 0x1249 | The destination identifier cannot be removed because it is used by a messaging port.
BTS_E_PORT_FOREIGN_ENVID | 0x124A | The envelope cannot be removed because it is used by a messaging port.
BTS_E_CHANNEL_FOREIGN_SRCALIASID | 0x124B | The source identifier cannot be removed because it is used by a channel.
BTS_E_PORT_FOREIGN_DSTAPPID | 0x124C | The destination application cannot be removed because it is used by a messaging port.
BTS_E_PORT_FOREIGN_CONTROLNUMID | 0x124D | The control number cannot be removed because it is used by a messaging port.
BTS_E_DOCUMENT_MISSING_REFERENCE | 0x124E | The Reference property must have a value if the TrackingFields or PropertySet properties are specified.
BTS_E_DOCUMENT_REFERENCE_CANT_BE_CHANGED | 0x124F | A document reference cannot be modified if it is referred to by a channel.
BTS_E_PORTGROUP_NOTOPENGRP | 0x1251 | Messaging ports that are set to an open destination or set to an XLANG schedule (BIZTALK_OPENNESS_TYPE_EX_TOWORKFLOW) cannot be used in distribution lists.
BTS_E_PORTGROUP_DUPLICATEPORT | 0x1252 | A duplicate messaging port cannot be added to the distribution list.
BTS_E_OUTPUTCONFIG_UNIQUE_ID | 0x1255 | The output configuration identifier must be a unique identifier.
BTS_E_OUTPUTCONFIG_FOREIGN_PORTID | 0x1256 | The messaging port cannot be removed because it is used by a channel.
BTS_E_OUTPUTCONFIG_FOREIGN_CHANNELID | 0x1257 | The channel cannot be removed because it is used by a messaging port.
BTS_E_PORT_LOOPBACK_RELIABLE | 0x125F | A messaging port with the transport type Loopback cannot be associated with an envelope that uses the Reliable format.
BTS_E_ALIAS_RESERVEDWORD | 0x1262 | Group is a reserved word for qualifiers and cannot be used as the qualifier for an identifier.
BTS_E_DOCUMENT_NEEDMAPREF | 0x1268 | A map reference is required to transform the inbound document to the outbound document if the document specifications are different.
BTS_E_PORT_DESTORGNOTSPECIFIED | 0x126C | This messaging port must have a destination organization specified.
BTS_E_PORT_MISSING_PRITRANSTYPE | 0x126D | You must specify a primary transport type for this messaging port. The primary transport cannot be blank, and it cannot be an open destination.
BTS_E_PORT_MISSING_PRITRANSADDRESS | 0x126E | This messaging port must have a primary transport address specified.
BTS_E_PORT_INVALID_SECTRANSTYPE | 0x126F | The secondary transport type cannot be set to Open, Loopback, or to BizTalk Orchestration Activation.
BTS_E_PORT_MISSING_SECTRANSADDRESS | 0x1270 | The secondary transport address is missing, although the transport type has been defined.
BTS_E_PORT_INVALID_ORG | 0x1271 | The organization specified in this messaging port does not exist.
BTS_E_PORT_INVALID_ALIAS | 0x1272 | The identifier specified for the organization in this messaging port either does not exist or it does not belong to the organization.
BTS_E_PORT_INVALID_APPLICATION | 0x1273 | The application specified for the organization in this messaging port either does not exist or it does not belong to the organization.
BTS_E_PORT_INVALID_ENVELOPE | 0x1274 | The envelope specified in this messaging port does not exist.
BTS_E_PORT_OPEN_DESTORG_SPECIFIED | 0x127C | An open-destination messaging port cannot have a destination organization specified.
BTS_E_PORT_OPEN_DESTAPP_SPECIFIED | 0x127E | An open-destination messaging port cannot have a destination application specified.
BTS_E_PORT_OPEN_PRITRANSTYPEOPEN | 0x127F | An open-destination messaging port must specify a primary transport type as an open destination.
BTS_E_PORT_OPEN_PRITRANSADDRESS | 0x1280 | An open-destination messaging port cannot specify a primary transport address.
BTS_E_PORT_OPEN_PRITRANSPARAMETER | 0x1281 | An open-destination messaging port cannot specify a primary transport parameter.
BTS_E_PORT_OPEN_SECTRANSTYPE | 0x1282 | An open-destination messaging port cannot specify the secondary transport type.
BTS_E_PORT_OPEN_SECTRANSADDRESS | 0x1283 | An open-destination messaging port cannot specify a secondary transport address.
BTS_E_PORT_OPEN_SECTRANSPARAMETER | 0x1284 | An open-destination messaging port cannot specify a secondary transport parameter.
BTS_E_PORT_OPEN_ENCRYPTIONTYPE | 0x1285 | An open-destination messaging port cannot specify an encryption type.
BTS_E_PORT_OPEN_ENCRYPTIONREF | 0x1286 | An open-destination messaging port cannot specify an encryption reference.
BTS_E_PORT_SIGNATTYPEANDREFERENCE | 0x1287 | The signature type is specified; however, the signature reference is missing.
BTS_E_PORT_ENCRYPTIONTYPEANDREFERENCE | 0x1288 | The encryption type is specified; however, the encryption reference is missing.
BTS_E_ALIAS_DEFAULT | 0x128A | One and only one default identifier is required and permitted at all times. The default identifier cannot be missing, nor can it be duplicated.
BTS_E_ALIAS_AUTO | 0x128B | The alias, which uses the name "Organization" and the qualifier "OrganizationName," is a system-created alias. You cannot remove this alias, create another alias that uses the same name and qualifier, or change any fields of this alias.
BTS_E_TRANSPORT_SYNTAXAPPINT | 0x128E | Either the syntax of this address is incorrect for the Application Integration Component transport type property, or the component is not registered, or else the component is not a valid AIC component.
BTS_E_TRANSPORT_SYNTAXFILE | 0x128F | The syntax of this address is incorrect for the File transport type.
BTS_E_TRANSPORT_SYNTAXHTTP | 0x1291 | The syntax of this address is incorrect for the HTTP transport type.
BTS_E_TRANSPORT_SYNTAXHTTPS | 0x1292 | The syntax of this address is incorrect for the HTTPS transport type.
BTS_E_TRANSPORT_SYNTAXSMTP | 0x1293 | The syntax of this address is incorrect for the SMTP transport type.
BTS_E_TRANSPORT_SYNTAXNONE | 0x1294 | You cannot specify a transport address or a parameter when the transport type is set to None, or when the source or destination are Open.
BTS_E_TRANSPORT_LOCALHOST | 0x1295 | The transport address cannot contain the word "localhost". Replace it with the computer name instead.
BTS_E_PORTGROUP_LASTPORT | 0x1296 | The messaging port cannot be removed if it is the last remaining messaging port in a distribution list.
BTS_E_TRANSPORT_MISSING_PRISMTPPARAMETER | 0x1298 | A primary transport parameter is required for the SMTP transport type.
BTS_E_TRANSPORT_MISSING_SECSMTPPARAMETER | 0x1299 | A secondary transport parameter is required for the SMTP transport type.
BTS_E_NAMEREQ | 0x129A | The Name property must always be at least one character long.
BTS_E_INVALIDTIMEFORMAT | 0x129B | The time format is not valid. Enter the time, in hours, in a 24-hour format (from 0 to 23 hours). You can enter only hours, not minutes or seconds.
BTS_E_TIMESTAMP | 0x129C | This object cannot be saved or removed because the timestamp has changed.
BTS_E_PORTGROUP_MISSING_PORT | 0x129D | A distribution list must contain at least one messaging port.
BTS_E_ORGANIZATION_REMOVEDEFAULT | 0x129E | The home organization cannot be removed.
BTS_E_PORT_SERVICEWINDOW_EQUAL | 0x129F | The start time (FromTime) and end time (ToTime) for the service window cannot be equal.
BTS_E_ENVELOPE_REFERENCENOTALLOWED | 0x12A2 | The reference property cannot be set for this envelope format.
BTS_E_ENVELOPE_REFERRED | 0x12A3 | This envelope cannot be removed because it is used in a messaging port or channel.
BTS_E_TRANSPORT_LOOPBACK_SECTYPECONFLICT | 0x12A4 | The secondary transport type cannot be specified for the messaging port if the primary transport type is set to Loopback.
BTS_E_TRANSPORT_LOOPBACK_SECADDRESSCONFLICT | 0x12A5 | The secondary transport address cannot be specified for the messaging port if the transport type is set to Loopback.
BTS_E_PORT_LOOPBACK_SERVICEWINDOW | 0x12A6 | The service window cannot be specified for the messaging port if the transport type is set to Loopback.
BTS_E_PORT_OPEN_DESTALIAS_SPECIFIED | 0x12A7 | An open-destination messaging port cannot have a destination identifier specified.
BTS_E_PORT_OPEN_SERVICEWINDOW | 0x12A8 | The service window cannot be specified for the messaging port if the messaging port is an open-destination messaging port.
BTS_E_PORT_SERVICEWINDOWTIMES | 0x12AA | To use a service window, you must set both the From and To times or else, do not set either time.
BTS_E_TRANSPORT_LOOPBACK_PRIADDRESSCONFLICT | 0x12AC | A primary transport address cannot be specified for the messaging port if the transport type is Loopback.
BTS_E_PORT_ORGCHANGE | 0x12AD | The destination-organization identifier cannot be changed after it is created.
BTS_E_PORT_OPENNESSCHANGE | 0x12AE | The Openness property cannot be changed after it is created.
BTS_E_PORT_SIGNATURE_CHANNEL_CERTREF | 0x12AF | The signature-certification reference for a channel does not match the signature type for the port.
BTS_E_PORT_SIGNATURE_CHANNEL_OPEN | 0x12B0 | A messaging port that contains a signature type cannot be connected to an open-source channel. Also, a messaging port that is already connected to an open-source channel cannot have a signature type assigned to it.
BTS_E_CHANNEL_OPEN_SRCORG | 0x12B1 | An open-source channel cannot specify a source organization.
BTS_E_PORTGROUP_LOOPBACKPORT | 0x12B2 | A messaging port that uses the Loopback transport type cannot be added to a distribution list. Also, the transport type of a messaging port that is already included in a distribution list cannot be changed to Loopback.
BTS_E_CHANNEL_OPEN_SRCALIAS | 0x12B3 | An open-source channel cannot have a source identifier specified.
BTS_E_CHANNEL_OPEN_SRCAPP | 0x12B4 | An open-source channel cannot specify a source application.
BTS_E_CHANNEL_PORTORPORTGROUP | 0x12B5 | Either a messaging port or a distribution list, but not both, must be specified in a channel.
BTS_E_CHANNEL_MISSING_DOCUMENT | 0x12B6 | Both input and output documents are needed in a channel.
BTS_E_CHANNEL_INVALIDTYPE | 0x12B7 | A channel cannot be set to an open destination or set to an XLANG schedule (BIZTALK_OPENNESS_TYPE_EX_TOWORKFLOW).
BTS_E_CHANNEL_MISSING_OUTDOCREFERENCE | 0x12B8 | If the inbound document definition for a channel has a reference to a specification, the outbound document definition must also have a reference to a specification.
BTS_E_CHANNEL_TRACKFIELDSCANTBESET | 0x12B9 | If the inbound document definition for a channel does not have a reference to a specification, the tracking fields cannot be set.
BTS_E_CHANNEL_EXPRESSIONCANTBESET | 0x12BA | If the inbound document definition for a channel does not have a reference to a specification, the channel-filtering expressions cannot be set.
BTS_E_CHANNEL_MAPREFCANTBESET | 0x12BB | If the inbound document definition for a channel does not have a reference to a specification then a reference to a map cannot be set.
BTS_E_CHANNEL_NOTSAME_INPDOC_OUTDOC | 0x12BC | If the inbound document definition for a channel does not have a reference to a specification then the outbound document handle should be the same of inbound document handle.
BTS_E_CHANNEL_OPEN_RECEIPTCONFLICT | 0x12BD | Channels that are set from an open source or set from an XLANG schedule (BIZTALK_OPENNESS_TYPE_EX_FROMWORKFLOW) cannot be receipt channels.
BTS_E_CHANNEL_RECEIPT_RECEIPTTIMEOUT | 0x12BE | The Expect Receipt Timeout property cannot be set on a receipt channel.
BTS_E_CHANNEL_RECEIPT_CANTSETRECEIPTCHANNEL | 0x12BF | An identifier cannot be set on a receipt channel.
BTS_E_CHANNEL_RECEIPT_CONFLICT | 0x12C0 | In a receipt channel, the source specification from the original channel must be used as the destination specification, and the destination specification from the original channel must be used as the source specification.
BTS_E_CHANNEL_SRCORGDEFAULT | 0x12C1 | If the channel is set from an XLANG schedule (BIZTALK_OPENNESS_TYPE_EX_FROMWORKFLOW), the source organization must be the home organization.
BTS_E_CHANNEL_PORT_BOTHOPEN | 0x12C2 | Both the channel and messaging port cannot be set to Open.
BTS_E_CHANNEL_RECEIPT_INVALID | 0x12C3 | The Receipt Channel and Expect Receipt Timeout properties cannot be set for an open-source channel. These properties also cannot be set if the messaging port is set to an open destination, set to an XLANG schedule (BIZTALK_OPENNESS_TYPE_EX_TOWORKFLOW), or if the messaging port uses the Loopback transport type.
BTS_E_CHANNEL_RECEIPTMATCHNOTFOUND | 0x12C4 | The corresponding receipt channel for this channel could not be found.
BTS_E_CHANNEL_RECEIPT_OPENPORT | 0x12C5 | A receipt channel can be connected only to messaging ports that are not open messaging ports.
BTS_E_CHANNEL_RECEIPT_LOOPBACKPORT | 0x12C6 | A receipt channel cannot be connected to a messaging port that uses the Loopback transport type. Also, the transport type of a messaging port that is already connected to a receipt channel cannot be changed to Loopback.
BTS_E_CHANNEL_CANNOTUPDATE | 0x12C8 | After a channel is created, the following properties cannot be changed: source organization, openness designation, messaging port, distribution list, and receipt channel designation.
BTS_E_PORT_INVALIDOPENNESS | 0x12C9 | A messaging port cannot be set to an open source; nor can it be set from an XLANG schedule (BIZTALK_OPENNESS_TYPE_EX_FROMWORKFLOW).
BTS_E_CHANNEL_CONTROLNUMBER_ENVELOPEFORMATMISMATCH | 0x12CA | If the envelope format for the messaging port is X12 or EDIFACT, the control-number value on the channel must be set.
BTS_E_PORT_ENVELOPE_SERIALIZERCLSID | 0x12CB | If the envelope format for the messaging port is set to Custom, a class identifier (CLSID) for the serializer component must be specified.
BTS_E_CHANNEL_AIC_TRANSPORTCLSID | 0x12CD | If the transport type associated with the channel is set to Application Integration Component, a class identifier (CLSID) must be specified for the primary transport.
BTS_E_CHANNEL_RECEIPT_PORTGROUP | 0x12CE | If a channel is connected to a distribution list, a receipt channel cannot be specified.
BTS_E_COMPONENTREQUIRES2AGGREGATEFTM | 0x12CF | To be a valid object in the BizTalk Object Model, this custom component must aggregate the free-threaded marshaler.
BTS_E_CERTREFNOTFOUND | 0x12D1 | Either the certificate reference could not be found in MY or BIZTALK stores or it is not valid.
BTS_E_NODOC | 0x12D2 | The Document Definition has been removed from the database. Avoid deleting objects when documents might exist in the queues which reference these objects.
BTS_E_NOENV | 0x12D3 | The envelope has been removed from the database. Avoid deleting objects when documents might exist in the queues which reference these objects.
BTS_E_NOCHANNEL | 0x12D4 | The channel has been removed from the database. Avoid deleting objects when documents might exist in the queues which reference these objects.
BTS_E_INVALIDREFERENCE | 0x12D5 | Either the WebDAV repository reference does not contain a valid HTTP address or it contains the text "localhost." Please provide either a valid HTTP address or replace the text "localhost" with the actual computer name.
BTS_E_CANNOTCONTAINSUBOBJECTS | 0x12D6 | The property set and delimiter objects cannot contain any subobjects.
BTS_E_INVALIDTRACKFIELDS | 0x12D7 | The "x_custom_search" field in the tracking field dictionary must be a simple list.
BTS_E_CHANNEL_INVALID_ORG | 0x12D8 | The organization specified in this channel does not exist.
BTS_E_CHANNEL_INVALID_ALIAS | 0x12D9 | The identifier specified for the organization in this channel either does not exist or it does not belong to the organization.
BTS_E_CHANNEL_INVALID_APPLICATION | 0x12DA | The application specified for the organization in this channel either does not exist or it does not belong to the organization.
BTS_E_CHANNEL_INVALID_INPDOCID | 0x12DB | The input document specified in this channel does not exist.
BTS_E_CHANNEL_INVALID_OUTDOCID | 0x12DC | The output document specified in this channel does not exist.
BTS_E_CHANNEL_INVALID_PORTGROUP | 0x12DD | The distribution list specified in this channel does not exist.
BTS_E_OBJECT_NOT_XMLSERILIZABLE | 0x12DE | The given dictionary or simplelist object must implement IPersistXML methods.
BTS_E_CHANNEL_INVALID_PORT | 0x12E0 | At least one messaging port that is referenced in this channel either does not exist or it is not associated with this channel.
BTS_E_CHANNEL_RECEIPT_VERSIGN_DECRYPT | 0x12E1 | The Verify Signature or Decrypt Encryption properties cannot be set on a receipt channel.
BTS_E_INVALID_REQUEST_CHANNEL | 0x12E2 | A channel that is connected to a distribution list cannot be used as a request channel.
BTS_E_DESTINATION_NOT_FOUND | 0x12E3 | The destination URL is not specified, and the messaging port is an open destination. Either the destination URL or a destination for the messaging port must be specified.
BTS_E_DESTINATION_CONFLICT | 0x12E4 | Both a destination URL and a destination for the messaging port cannot be specified. Specify only one of these properties.
BTS_E_ASYNC_TRANSPORT | 0x12E5 | The transport type for the request channel is not valid. Only the HTTP, HTTPS, and Application Integration Component transport types are valid for a request channel.
BTS_E_INVALID_RESPONSE_CHANNEL | 0x12E6 | The response channel can be connected only to a messaging port with a transport type set to Loopback.
BTS_E_INVALID_VERSION | 0x12E7 | The database version is incompatible with the installed version of the server. Try running setup again.
BTS_E_INVALID_SCHEMA | 0x12E8 | The document or envelope specification is not valid. Open the specification in BizTalk Editor, and then on the Tools menu, click Validate Specification. Resolve any warnings to ensure that the specification is valid.
BTS_E_CHANNEL_RECEIPTCHANNEL_PORTGROUP | 0x12E9 | A receipt channel cannot be connected to a distribution list.
BTS_E_TRANSPORT_ORCHESTRATION_OPENNESS | 0x12EA | A messaging port that uses the BizTalk Orchestration Activation transport type must have the Openness Type property set to an XLANG schedule (BIZTALK_OPENNESS_TYPE_EX_TOWORKFLOW).
BTS_E_TRANSPORT_ORCHESTRATION_ADDRESSPARAMETER | 0x12EB | Both a primary address and a parameter are required for a messaging port that uses a BizTalk Orchestration Activation transport type.
BTS_E_ORCHESTRATION_INVALIDORG | 0x12EC | A messaging port that uses a BizTalk Orchestration Activation transport type must have the home organization set as the destination organization.
BTS_E_INVALID_FILTEREXPRESSION | 0x12ED | The channel filtering expression is not valid. Make sure that the node-path expression is valid.
BTS_E_MULTIPLEDOCDEFSFORPROPSET | 0x12EE | Multiple document definitions were found for the given property set. Only a single document definition for a given property set is expected.
BTS_E_INVALID_PROPSET | 0x12EF | The PropertySet cannot contain non-string element values.
BTS_E_DBSCHEMA_MISMATCH | 0x1300 | The existing Database Schema is not compatible with the current version of the product. You must delete the existing database.
BTS_E_UNEXPECTED_INSTALL | 0x1301 | The existing Database Schema is newer than the current version that is installed. Setup will rollback the changes.
CIS_E_DOCSCHEMA_ATTRIB_MISSING | 0x1400 | The "%3" attribute is missing in the "%4" element. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_INVALID_ATTRIB_VALUE | 0x1401 | The "%3" attribute value "%4" is not valid. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_EMPTY_ELEMENT | 0x1402 | The "%3" element cannot be empty. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_INVALID_CHILD_ELEMENT | 0x1403 | The "%3" element cannot be a child of the "%4" element. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_MULTIPLE_INFO | 0x1404 | Only one record description or one field description is allowed for each element declaration. One of the descriptions must be removed. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_INVALID_FIELD_DECL | 0x1405 | The root node cannot contain a field. The root node of the document must contain a record. Verify that the root node in your document is declared as a record. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_INVALID_LEN_DECL | 0x1406 | The minimum length value must be no greater than the maximum length value. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_INVALID_POSLEN_DECL | 0x1407 | The value of the start position must be no greater than the value of the end position. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_NO_INFO_YET | 0x1408 | A field description or record description must be specified before references to other elements. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_INVALID_SCHEMATYPE_XML | 0x1409 | Only non-XML document specifications are allowed for this format. The schema_type attribute has the value "xml". Verify that the specification selected is a non-XML specification. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_NO_INFO | 0x140A | No record information or field information was found in the "%3" element. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_INVALID_ATTRIB | 0x140B | The "%3" attribute is not allowed in the "%4" element. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_MISSING_ELEM_DECL | 0x140C | There is no element with the name "%1" in the document specification.
CIS_E_DOCSCHEMA_MISSING_ATTR_DECL | 0x140D | There is no attribute with the name "%1" in the document specification.
CIS_E_DOCSCHEMA_INVALID_POSITIONAL_DECL | 0x140E | The "%1" record cannot be a child of the "%2" positional record. Only fields can be children of positional records.
CIS_E_DOCSCHEMA_INVALID_RECORD_CHILDREN | 0x140F | The children of the "%1" delimited record must either be all records or all fields. Records with no tag identifier cannot have mixed records and fields as children.
CIS_E_DOCSCHEMA_NO_RECORD_CHILDREN | 0x1410 | The "%1" delimited record must have at least one child. Records with no tag identifier must have at least one child, or else the record cannot be found in a non-XML format. Either add a child to the record, give the record a tag identifier, or remove the record from the specification.
CIS_E_DOCSCHEMA_MISSING_RECORD_TAG | 0x1411 | The "%1" delimited record is marked to repeat but it does not have a tag identifier. Only the last record in a document specification is allowed to have this property. If this record appears only once in the document, then mark it as a single occurrence. Otherwise, give the record a tag identifier that tells the server where to look for the next record in the specification.
CIS_E_DOCSCHEMA_NO_ROOT_ELEMENT | 0x1412 | The root-node name "%3" was not found in the specification. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_INVALID_ROOT_ELEMENT | 0x1413 | The "%3" element cannot be the root node of this document. Only <Schema> is allowed. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_INVALID_EMPTY_ATTRIBUTE | 0x1414 | The "%3" attribute in the "%4" element cannot be empty. Either specify a nonempty value or remove the attribute. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_INVALID_REFERENCE | 0x1415 | The "%1" record has an illegal cyclic path through the "%2" record. The only cyclic reference allowed for a record is if the record has a tag identifier that allows the system to terminate the search. Either remove the cyclic reference or add an appropriate tag identifier to the document specification.
CIS_E_DOCSCHEMA_LOADFAILED | 0x1416 | The specification failed to load. See the following messages for details.
CIS_E_DOCSCHEMA_MISSING_NS | 0x1417 | Valid BizTalk Server specifications for non-XML documents must have the namespace declarations of "urn:schemas-microsoft-com:BizTalkServer", "urn:schemas-microsoft-com:datatypes", and "urn:schemas-microsoft-com:xml-data" in the root node of the specification.
CIS_E_DOCSCHEMA_INVALID_SCHEMA_USAGE | 0x1418 | The specification referenced in the "%1" document is not compatible with the "%2" format. Select a specification that is compatible with this format, or if this is a valid specification for the defined format, assign "%2" to the "standard" property on this specification.
CIS_E_DOCSCHEMA_MISSING_POSLEN_DECL | 0x1419 | The "%3" field is missing a start and end position, and is referenced in the "%4" positional record. Specify valid start and end positions for this field. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_DUPLICATE_NAMESPACE | 0x141A | The duplicate namespace declaration "%3" has been found. Please remove the duplicate reference to same namespace. Line: %1, Pos: %2.
CIS_E_PARSER_EOF | 0x1430 | The end of the file was reached prematurely.
CIS_E_PARSER_MISSING_TAG | 0x1431 | The required "%1" record was not found in the inbound document.
CIS_E_PARSER_MISSING_FIELD | 0x1432 | The required field "%1" in the "%2" record was not found in the inbound document.
CIS_E_PARSER_FAILURE | 0x1433 | The parser failed to convert the document due to processing errors. See the following messages for details.
CIS_E_PARSER_INVALIDDATA | 0x1434 | The parser cannot match the current position of the data with the specification. Verify that the version of this specification is consistent with the version of the data and that the root parsing tags match.
CIS_E_PARSER_NO_DATA | 0x1435 | There is no data that can be parsed on the dictionary. Verify that either the "working_data" field or the "file_path" field contains nonempty data.
CIS_E_PARSER_INVALID_ENVNAME | 0x1436 | The envelope name "%1" does not reference a valid envelope for the BizTalk Server parser. Either the envelope name does not exist or there is an envelope specification attached that is not valid.
CIS_E_PARSER_NO_COMPONENTS_FOUND | 0x1439 | No parser component recognizes the data. This might be caused by an interchange specification that is missing or not valid, or it might be caused by data that is not valid. Verify that both the interchange specification (if one is specified) and the data match.
CIS_E_PARSER_COMPONENT_FAILED | 0x1440 | While trying to process document #%4 during submission "%1", the parser component named "%2" failed on the method "%3" with the error code "%5". Possible causes are: the component found unexpected data in the incoming stream; a document specification could not be found given the data; or an internal component failure occurred. If this problem continues, remove this component from the valid list of parser components or contact your system administrator.
CIS_E_PARSER_DOCUMENT_FAILED | 0x1441 | Document #%4 within submission "%1" was returned as a document that was not valid from the parser component named "%2". The most frequent cause is a document specification that is not valid or else the component was unable to determine the necessary routing fields. Verify that the proper specification is defined for this data.
CIS_E_PARSER_INVALID_DATETIME | 0x1442 | The "%1" date or time format does not match the format of the "%2" data extracted from the incoming data.
CIS_E_PARSER_INVALID_COMPONENT | 0x1443 | Within submission "%1", the parser component named "%2" could not be loaded. Verify that this component can be run in a stand-alone executable and that the server has sufficient permissions to start it.
CIS_W_PARSER_SKIPPED_COMPONENT | 0x1444 | The parser was unable to probe the specified component. This component will be skipped.
CIS_E_PARSER_UNUSEABLE_DOCNAME | 0x1445 | The parser cannot use the document "%1" as it has no specification. Please attach a specification to this document or specify a different one.
CIS_E_PARSER_CONTROL_NUMBER_MISMATCH | 0x1446 | The control number of segment "%1" (%2) does not match that of segment "%3" (%4).
CIS_E_PARSER_DOCCOUNT_INCORRECT | 0x1447 | The document or segment count contained in tag "%1" (%2) does not match the number of documents or segments processed (%3).
CIS_E_PARSER_X12_ISA_PARSE_FAILED | 0x1448 | The parser cannot parse the ISA section of the X12 document. This segment is fixed-width; if fields in this segment do not have correct length, the parsing will fail because the delimiters are picked up from the wrong offsets.
CIS_E_PARSER_MIN_LENGTH | 0x1449 | The data contains a field value ("%1") that doesn't meet minimum length requirement for tag "%2" (minimum length is %3).
CIS_E_PARSER_MAX_LENGTH | 0x144A | The data contains a field value ("%1") that doesn't meet maximum length requirement for tag "%2" (maximum length is %3).
CIS_E_PARSER_NO_DATA_CONSUMED | 0x144B | No data was read by the parser. Make sure that the code page is set correctly for the data. If the data is UNICODE, make sure that there is no byte order mark (0xFFFE or 0xFEFF) appears at the beginning of the file.
CIS_E_PARSER_UNSUPPORTED_EDIFACT_SYNTAX | 0x144C | EDIFACT documents with the "UNOX" or the "UNOY" syntax identifier are not supported.
CIS_E_PARSER_DATA_REMAINING | 0x144D | Additional data in the document instance was not parsed. Make sure that the document instance you want to validate contains only one document.
CIS_E_PARSER_MISSING_DELIMITER | 0x144E | While parsing record "%1", the parser cannot find the required delimiter: "%2" (%3).
CIS_E_PARSER_MISSING_LEADING_DELIMITER | 0x144F | While parsing record "%1", the parser cannot find the required leading delimiter: "%2" (%3).
CIS_E_PARSER_MISSING_TRAILING_DELIMITER | 0x1450 | While parsing record "%1", the parser cannot find the required trailing delimiter: "%2" (%3).
CIS_E_VALIDATE_GROUP_RULE | 0x1451 | In record "%1", if any of the following fields exist, then all must exist: %2
CIS_E_VALIDATE_GROUP_ALL | 0x1452 | In record "%1", all of the following fields must exist: %2
CIS_E_VALIDATE_GROUP_ONE | 0x1453 | In record "%1", only one of the following fields can exist: %2
CIS_E_PARSER_INVALID_WRAP_CHAR_FOUND | 0x1454 | While parsing record "%1", the parser found an occurrence of a wrap character, "%2", that is not valid.
CIS_E_VALIDATE_GROUP_ANY | 0x1455 | In record "%1", one or more of the following fields must exist: %2
CIS_E_PARSER_EXTRA_DELIMITER | 0x1456 | While parsing record "%1", the parser found the following extra delimiter: "%2".
BTS_E_DOCUMENT_HAS_INVALID_MANIFEST | 0x1457 | Error parsing the manifest.
CIS_E_ADMIN_CACHE_PARSERS | 0x1504 | The latest modification date from the administration parser table could not be loaded.
CIS_E_ADMIN_INIT_CACHE | 0x1505 | The configuration data in the global cache could not be initialized.
CIS_E_ADMIN_RELOAD_CACHE | 0x1506 | The configuration data from the database could not be reloaded.
CIS_E_ADMIN_PARSER_GETCLSID | 0x1507 | The class identifiers (CLSIDs) of the parser records could not be loaded.
CIS_E_ADMIN_CACHE_OBJECTNOTCREATED | 0x1509 | The administration cache cannot be created.
CIS_E_ADMIN_CACHE_INITIALLOAD | 0x150A | The configuration cache data from the database could not be loaded.
CIS_E_ADMIN_ADD_SERVER_ACCESS_DENIED | 0x150B | Server "%1" cannot be added because access to the "%2" is denied.
CIS_E_ADMIN_ADD_SERVER_NO_SERVICE | 0x150C | Server "%1" cannot be added because BizTalk Server is not installed on the computer.
CIS_E_ADMIN_DELETE_SERVER_NO_ACCESS | 0x150D | The "%1" server cannot be deleted because access to the "%2" service is denied and the service cannot be stopped.
CIS_E_ADMIN_DELETE_GROUP_SERVER_RUNNING | 0x150E | This server group cannot be deleted because the "%1" server is still running.
CIS_E_ADMIN_DELETE_GROUP_SERVER_ACCESS_DENIED | 0x150F | This server group cannot be deleted because access to the "%1" service on "%2" server is denied.
CIS_E_ADMIN_NOGROUP | 0x1512 | The specified administration group does not exist.
CIS_E_ADMIN_NOSERVER | 0x1513 | The specified administration server does not exist.
CIS_E_ADMIN_NORECEIVESERVICE | 0x1514 | The specified administration receive function does not exist in the database.
CIS_E_ADMIN_UNEXPECTED_REMOVE_RECEIVESERVICE | 0x1515 | An unexpected error occurred while trying to remove the "%1" receive function from the database.
CIS_E_ADMIN_UNEXPECTED_REMOVE_GROUP | 0x1516 | An unexpected error occurred while trying to remove the "%1" group from the database.
CIS_E_ADMIN_UNEXPECTED_REMOVE_SERVER | 0x1517 | An unexpected error occurred while trying to remove the "%1" server from the database.
CIS_E_ADMIN_NOTIMESTAMPS | 0x151A | The specified administration timestamps object does not exist in the database.
CIS_E_ADMIN_REFRESH_THREAD_ERROR | 0x151B | The configuration refresh thread encountered an error while loading the configuration data.
CIS_E_ADMIN_REFRESH_THREAD_EXIT | 0x151C | The configuration refresh thread cannot load the configuration data because of a previous error.
CIS_E_ADMIN_RECSVC_GENERAL | 0x151D | The configuration refresh thread cannot set up one or more receive functions. This might be because SQL Server is not started.
CIS_E_ADMIN_CREATE_GROUP | 0x1529 | The server group cannot be created because "%1".
CIS_E_ADMIN_LOAD_GROUP_PROPS | 0x152A | The group properties cannot be loaded because "%1".
CIS_E_ADMIN_SAVE_GROUP_PROPS | 0x152B | The group properties cannot be saved because "%1".
CIS_E_ADMIN_REMOVE_GROUP | 0x152C | The server group cannot be removed from the database because "%1".
CIS_E_ADMIN_GETALLADMINGROUPS | 0x152D | All server groups cannot be retrieved from the database.
CIS_E_ADMIN_GETSERVERS | 0x152E | All servers for the "%1" server group cannot be retrieved from the database because "%2".
CIS_E_ADMIN_GETRECEIVESERVICES | 0x152F | All receive functions for the "%1" group cannot be retrieved from database because "%2".
CIS_E_ADMIN_GETPARSERS_IN_GROUP | 0x1531 | All parsers for the "%1" server group cannot be retrieved from the database because "%2".
CIS_E_ADMIN_GETLOCALSMTPHOST | 0x1538 | The local SMTP host cannot be retrieved because "%1".
CIS_E_ADMIN_CREATE_SERVER | 0x1539 | The server cannot be created because "%1".
CIS_E_ADMIN_LOAD_SERVER_PROPS | 0x153A | The server properties cannot be loaded because "%1".
CIS_E_ADMIN_SAVE_SERVER_PROPS | 0x153B | The server properties cannot be saved because "%1".
CIS_E_ADMIN_REMOVE_SERVER | 0x153C | The server cannot be removed from the database because "%1".
CIS_E_ADMIN_GETALLADMINSERVRES | 0x153D | All servers cannot be retrieved from the database.
CIS_E_ADMIN_GETSERVERBYNAME | 0x153E | The server properties for "%1" cannot be retrieved because "%2".
CIS_E_ADMIN_DECRYPT_PASSWORD | 0x1540 | The "%1" property cannot be retrieved.
CIS_E_ADMIN_EXEC_COMMMAND_ON_PARSER | 0x154F | The SQL command "%1" on the parser database table cannot be executed because "%2".
CIS_E_ADMIN_CREATE_RECEIVESERVICE | 0x155D | The receive function cannot be created because "%1".
CIS_E_ADMIN_LOAD_RECEIVESERVICE_PROPS | 0x155E | The receive function properties cannot be loaded because "%1".
CIS_E_ADMIN_SAVE_RECEIVESERVICE_PROPS | 0x155F | The receive function properties cannot be saved because "%1".
CIS_E_ADMIN_REMOVE_RECEIVESERVICE | 0x1560 | The receive function cannot be removed from the database because "%1".
CIS_E_ADMIN_GETALLRECEIVESERVICES | 0x1561 | All receive functions cannot be retrieved from the database because "%1".
CIS_E_ADMIN_GETALLRECEIVESERVICESINSERVER | 0x1562 | All receive functions cannot be retrieved for the "%1" server because "%2".
CIS_E_ADMIN_LOAD_TIMESTAMPS | 0x1563 | All timestamps cannot be retrieved from the database because "%1".
CIS_E_ADMIN_GETSQCONNECT | 0x1570 | The Shared Queue database connection string cannot be retrieved from the database.
CIS_E_ADMIN_GETCOMPUTERNAME | 0x1571 | The name of the local computer cannot be retrieved. Internally, BizTalk Server is using "localhost" as the computer name.
CIS_E_ADMIN_MIN_CONSTRAINT | 0x1573 | The size of the "%1" property is less than the minimum required length for "%2".
CIS_E_ADMIN_MAX_CONSTRAINT | 0x1574 | The size of the "%1" property is greater than the maximum length allowed for "%2".
CIS_E_ADMIN_GET_MGMTDB_CONNECT_PROPS | 0x1575 | The BizTalk Messaging Management database properties cannot be retrieved.
CIS_E_ADMIN_KEY_EMPTY | 0x1576 | The key to the database table, property "%1", is empty.
CIS_E_ADMIN_COCREATE_IN_CREATE | 0x1577 | An instance of the "%1" object could not be created while creating a new "%2" object.
CIS_E_ADMIN_ADO_OPEN_CONNECTSTRING | 0x1578 | The connection to the BizTalk Messaging Management database could not be opened.
CIS_E_ADMIN_COCREATE_IN_LOAD | 0x1579 | An instance of the "%1" object could not be created while loading the "%2" properties.
CIS_E_ADMIN_COCREATE_IN_SAVE | 0x1580 | An instance of the "%1" object could not be created while saving the "%2" properties.
CIS_E_ADMIN_COCREATE_IN_REMOVE | 0x1581 | An instance of the "%1" object could not be created while trying to remove the "%2" object.
CIS_E_ADMIN_COCREATE_IN_GETALL | 0x1582 | An instance of the "%1" object could not be created while trying to get all instances of "%2".
CIS_E_ADMIN_COCREATE_IN_GETALL_INSERVER | 0x1583 | An instance of the "%1" object could not be created while trying to get all instances of the "%2" object in the "%3" server.
CIS_E_ADMIN_GET_PROP | 0x1584 | The "%1" property cannot be retrieved.
CIS_E_ADMIN_CLOSE_ADO_CONNECTION | 0x1585 | The ADO connection cannot be closed.
CIS_E_ADMIN_CLOSE_ADO_RECORDSET | 0x1586 | The ADO record set cannot be retrieved.
CIS_E_ADMIN_ENCRYPT_PASSWORD | 0x1587 | The "%1" property cannot be processed.
CIS_E_ADMIN_COCREATE_IN_GETALLNAMES | 0x1588 | An instance of the "%1" object could not be created while trying to get the names of all the "%2" object instances.
CIS_E_ADMIN_COCREATE_IN_GETOTHERS_OF_GROUP | 0x1589 | An instance of the "%1" object could not be created while trying to get all instance of the "%2" object in the "%3" group.
CIS_E_ADMIN_COCREATE_IN_GET_SMTPHOST | 0x158A | An instance of the "%1" object could not be created while trying to get "%2" for the local server.
CIS_E_ADMIN_COCREATE_IN_GET_SQ_CONNECTSTRING | 0x158B | An instance of the "%1" object could not be created while trying to get the Shared Queue parameters of "%2" in order to connect to the database.
CIS_E_ADMIN_COCREATE_SERVER_BYNAME | 0x158C | An instance of the "%1" object could not be created while trying to get the properties of the "%2" server instance of the "%3" class.
CIS_E_ADMIN_GETSQCONNECT_IN_OPEN | 0x158D | The Shared Queue database connection string could not be retrieved from the database because "%1".
CIS_E_ADMIN_COCREATE_EXEC_SQL_COMMAND_ON_PARSER | 0x158E | An instance of the "%1" object could not be created while trying to execute a SQL command on the "%2" database table.
CIS_E_ADMIN_COCREATE_PARSER_CLSIDS_IN_GROUP | 0x158F | An instance of the "%1" object could not be created while retrieving the class identifiers (CLSIDs) for the parsers that belong to the "%2" group.
CIS_E_ADMIN_INVALID_ARGUMENT | 0x1590 | An unexpected internal error occurred. An invalid "%1" argument was used when calling the "%2" method.
CIS_E_ADMIN_MAX_ENUM_CONSTRAINT | 0x1591 | The value of the "%1" property is greater than the maximum value allowed for "%2".
CIS_E_ADMIN_MIN_ENUM_CONSTRAINT | 0x1592 | The value of the "%1" property is smaller than the minimum value allowed for "%2".
CIS_E_ADMIN_CREATE_CHANGETYPE_TO_BSTR | 0x1593 | The type of the "%1" property could not be changed to a string.
CIS_E_ADMIN_CREATE_CHANGETYPE_TO_BOOL | 0x1594 | The type of the "%1" property could not be changed to Boolean.
CIS_E_ADMIN_COCREATE_IN_ENUMINSTANCES | 0x1595 | An instance of the "%1" object could not be created while enumerating instances of the "%2" object.
CIS_E_ADMIN_COCREATE_IN_PUTINSTANCE | 0x1596 | An instance of the "%1" object could not be created while setting an instance of the "%2" object.
CIS_E_ADMIN_COCREATE_IN_GETOBJECT | 0x1597 | An instance of the "%1" object could not be created while getting an instance of the "%2" object.
CIS_E_ADMIN_COCREATE_IN_DELETEINSTANCE | 0x1598 | An instance of the "%1" object could not be created while deleting an instance of the "%2" object.
CIS_E_ADMIN_COCREATE_IN_LOADPROPS | 0x1599 | An instance of the "%1" object could not be created while loading properties for an instance of the "%2" object.
CIS_E_ADMIN_COCREATE_IN_LOADPARSERS | 0x159B | An instance of the "%1" object could not be created while loading parsers from a database for an instance the "%2" object.
CIS_E_ADMIN_COCREATE_IN_SETPARSERSFROM_REGISTRY | 0x159C | An instance of the "%1" object could not be created while setting parsers from the registry for an instance of the "%2" object.
CIS_E_ADMIN_COCREATE_IN_SETPARSERSFROM_CLIENT | 0x159D | An instance of the "%1" object could not be created while setting parsers from the client for an instance of the "%2" object.
CIS_E_ADMIN_COCREATE_IN_REFRESHPARSERLIST | 0x159E | An instance of the "%1" object could not be created while refreshing the parser list for an instance of the "%2" object.
CIS_E_ADMIN_COCREATE_IN_MOVETOSUSPENDED_Q | 0x159F | An instance of the "%1" object could not be created while moving an instance of "%2" to the Suspended queue.
CIS_E_ADMIN_COCREATE_IN_RESUBMIT | 0x15A0 | An instance of the "%1" object could not be created while resubmitting an instance of "%2".
CIS_E_ADMIN_COCREATE_IN_VIEWDOC | 0x15A2 | An instance of the "%1" object could not be created while viewing a document instance of "%2".
CIS_E_ADMIN_COCREATE_IN_VIEWERRORDESC | 0x15A3 | An instance of the "%1" object could not be created while viewing the error description of an instance of "%2".
CIS_E_ADMIN_COCREATE_IN_VIEWINTERCHANGE | 0x15A4 | An instance of the "%1" object could not be created while viewing the interchanges of an instance of "%2".
CIS_E_ADMIN_COCREATE_IN_FREEINTERCHANGES | 0x15A5 | An instance of the "%1" object could not be created while freeing the interchanges for an instance of a "%2".
CIS_E_ADMIN_COCREATE_IN_STARTSERVER | 0x15A6 | An instance of the "%1" object could not be created while starting the server for an instance of a "%2".
CIS_E_ADMIN_COCREATE_IN_STOPSERVER | 0x15A7 | An instance of the "%1" object could not be created while stopping the server for an instance of a "%2".
CIS_E_ADMIN_NO_DELETE_SERVER_IN_RECVSERVICE | 0x15A8 | The "%1" server cannot be deleted because it is the processing server for at least one receive function.
CIS_E_ADMIN_UPDATE_GROUP_SERVER_RUNNING | 0x15A9 | The server group properties cannot be changed because the "%1" server is still running.
CIS_E_ADMIN_UPDATE_GROUP_SERVER_ACCESS_DENIED | 0x15AA | The server group properties cannot be changed because access to the "%1" service on "%2" server is denied.
CIS_E_ADMIN_UPDATE_SERVER_SERVER_RUNNING | 0x15AC | The server properties cannot be changed because the "%1" server is still running.
CIS_E_ADMIN_UPDATE_SERVER_SERVER_ACCESS_DENIED | 0x15AD | The server properties cannot be changed because access to the "%1" service on "%2" server is denied.
CIS_E_ADMIN_UPDATE_READ_ONLY_PROP | 0x15AE | The "%1" property cannot be changed. It is a read only property.
CIS_E_ADMIN_DIFFERENT_ROOT | 0x15AF | The "%1" server may already belong to a different BizTalk Server installation.
CIS_E_ADMIN_NOT_RESUBMITABLE | 0x15B0 | This Suspended queue item cannot be submitted again.
CIS_E_ADMIN_DBCONNECT | 0x15B1 | BizTalk Server failed to access the "%1" database on the "%2" server with the database connection information.
CIS_E_ADMIN_PURGE_SUSPENDEDQ | 0x15B2 | An instance of the "%1" object could not be created while deleting documents from "%2".
CIS_E_ADMIN_REQ_PROP_MISSING | 0x15B3 | %1 cannot be NULL.
CIS_E_ADMIN_WMI_ERROR_HANDLING | 0x15B4 | The BizTalk Server WMI provider error-handling method failed. The original error description for the error that called the error-handling method is: "%1".
CIS_W_ADMIN_QUERY_FAILED | 0x15B5 | An attempt to get the Where clause values for a WMI Query failed.
CIS_E_ADMIN_INVALID_ENUM_CONSTRAINT | 0x15B6 | The value "%2" of the "%1" property is not valid.
CIS_E_ADMIN_OPENNESS_CONSTRAINT | 0x15B7 | The value "%2" of the "%1" property is not permitted when the value of the IsPassThrough property is set to TRUE.
CIS_E_ADMIN_RECEIVE_INVALID_SERVER_GROUP | 0x15B8 | the specified server and/or group is not valid
CIS_E_ADMIN_INVALID_INSTANCE_NAME | 0x15B9 | The specified instance name "%1" contains at least one of the following characters that is not valid: [ ` ~ ! @ # $ % ^ & * ( ) + = [ ] { } | \ ; " ' < > , . ? ]
BTS_E_ADMIN_GROUP_UNIQUE_NAME | 0x15BA | A BizTalk Server group with the same name already exists in the BizTalk Messaging Management database.
BTS_E_ADMIN_TIMESTAMPS_DATA_CORRUPTION | 0x15BB | Internal data corruption has been detected in the adm_TimeStamps table of the BizTalk Messaging Management database.
BTS_E_ADMIN_SERVER_UNIQUE_NAME | 0x15BC | A BizTalk Server with the same name already exists in the BizTalk Messaging Management database.
BTS_E_ADMIN_SERVER_FOREIGN_GROUPNAME | 0x15BD | This BizTalk Server does not reference a valid BizTalk Server group in the BizTalk Messaging Management database.
BTS_E_ADMIN_RECSVC_UNIQUE_NAME | 0x15BE | A BizTalk Server receive function with the same name already exists in the BizTalk Messaging Management database.
BTS_E_ADMIN_RECSVC_FOREIGN_GROUPNAME | 0x15BF | This BizTalk Server receive function does not reference a valid BizTalk Server group in the BizTalk Messaging Management database.
BTS_E_ADMIN_PARSER_UNIQUE_ID | 0x15C1 | A BizTalk Server parser with the same CLSID and Group Name already exists in the BizTalk Messaging Management database.
BTS_E_ADMIN_PARSER_FOREIGN_GROUPNAME | 0x15C2 | This BizTalk Server parser does not reference a valid BizTalk Server group in the BizTalk Messaging Management database.
CIS_E_ADMIN_DB_SPROCVERSION | 0x15C3 | The "%1" database on the "%2" server does not contain the necessary database schema.
CIS_E_ADMIN_DB_VERSION | 0x15C4 | The "%1" database on the "%2" server is not compatible with the current version of the product.
CIS_E_DTA_LOG_INTERCHANGE_DETAILS_FAILED | 0x1604 | The details of an interchange could not be logged.
CIS_E_DTA_LOG_DOCUMENT_DETAILS_FAILED | 0x1605 | The details of a document could not be logged.
CIS_E_DTA_LOG_GROUP_DETAILS_FAILED | 0x1606 | The details of a group could not be logged.
CIS_E_DTA_INIT_FAILED | 0x160A | The DTA object could not be initialized.
CIS_E_DTA_FAILED_TO_GET_ADMIN_PROPERTIES | 0x160E | The administration properties could not be obtained.
CIS_E_DTA_DATABASE_CONNECTION | 0x160F | The server could not establish connection to the Tracking database.
CIS_E_DTA_LOG_DOCUMENT_FAILED | 0x1619 | A copy of the document could not be logged.
CIS_E_DTA_LOG_INTERCHANGE_FAILED | 0x1620 | A copy of the interchange could not be logged.
CIS_E_DTA_OBJECT_IS_UNINITIALIZED | 0x1623 | The DTA initialization method must be explicitly invoked before any DTA method can be invoked.
CIS_E_DTA_FAILED_TO_COMMIT | 0x1625 | Changes could not be committed to the database.
CIS_E_DTA_FAILED_TO_LOG_SOURCE_XML | 0x1626 | The intermediate source XML could not be logged.
CIS_E_DTA_FAILED_TO_LOG_DEST_XML | 0x1627 | The intermediate destination XML could not be logged.
CIS_E_DTA_ACK_NO_ROW_FOUND | 0x162B | Acknowledgment correlation failed. The correlation key(s) given did not match any record in the Tracking database.
CIS_E_DTA_ACK_MULTIPLE_ROWS_FOUND | 0x162C | Acknowledgment correlation failed. The correlation key(s) given match more than one record in the Tracking database.
CIS_E_DTA_LOG_MIME_FAILED | 0x162D | The MIME data for submission "%1" could not be logged.
CIS_W_DTA_LOG_TRACKING_FIELD_FAILED | 0x162E | The following tracking field for submission "%1" could not be logged: Tracking field: %2 Specification field name: %3 Actual value: %4 Possible causes are either a conversion error or an arithmetic overflow error. Check the tracking field settings in the document or channel configuration.
CIS_W_DTA_LOG_BINARY_TRACKING_FIELD_FAILED | 0x162F | The following tracking field for submission "%1" could not be logged: Tracking field: %2 Specification field name: %3 The submission could not be logged because the corresponding XML element or attribute is set to binary type, which can only be tracked as custom type tracking field. Correct the tracking field settings in the document or channel configuration.
CIS_E_DTA_INIT_TRANSACTIONAL_SESSION | 0x1631 | The server could not create a transactional session for the Tracking object.
CIS_W_DTA_RECORD_UPDATE_FAILED | 0x1632 | An attempt to update a tracking record has failed. The record was probably deleted prior to the update action.
CIS_E_RESPONSE_DOM_LOAD_FAILED | 0x1701 | The XML-DOM could not be loaded from the response data.
CIS_E_RECEIVE_MSMQ_BYOT_CREATE_FAILED | 0x1702 | A Message Queuing receive function failed to create an IInterchange object using a Bring Your Own Transaction (BYOT) object. This may have been caused by editing the BizTalk Server COM+ application or configuring the BYOT object in its own COM+ application. This BizTalk Message Queuing receive function will be stopped.
CIS_E_RECEIVE_MSMQ_ZERO_BYTE_DOC | 0x1703 | A Message Queuing receive function read a zero byte document. This document has been discarded.
CIS_E_RECEIVE_SERVICE_FAILED | 0x1704 | There was a failure processing the "%1" receive function. Check your receive function configuration in BizTalk Server Administration.
CIS_E_INITWORKITEM | 0x1705 | There was a failure creating the internal work item. Make sure that SQL Server is running.
CIS_E_NOPIPELINE | 0x1706 | A channel with the name "%1" cannot be located.
CIS_E_OPEN_PASSTHROUGH | 0x1707 | The channel and messaging port openness type are not compatible with the submit method call.
CIS_E_DLQ_DETAILS | 0x1708 | Details about the Suspended queue could not be retrieved.
CIS_E_INVALID_OPENDEST | 0x1709 | The destination specified for the following open-destination messaging port was not valid: %1
CIS_E_SQL_MISSINGROWS | 0x170a | Rows were missing from the record returned by SQL OLEDB provider.
CIS_E_BTF_TIME_STAMP_EXPIRED | 0x170b | The BizTalk Framework document "%1" was received with an expired "%2" timestamp. This message will be discarded.
CIS_E_ACCESS_DENIED | 0x170c | The current process did not have administrative privileges and cannot access the Suspended queue.
CIS_E_BTF_ERROR_FINDING_TAG | 0x170d | The parser could either not find the BizTalk Framework tag "%1", or the tag did not have a value. This document will be moved to the Suspended queue.
CIS_E_INVALID_FORMAT | 0x170e | The "%1" envelope format is not recognized by the server. Specify a valid envelope format.
CIS_E_INVALID_MAP | 0x170f | The server could not load the map that is referenced by this channel.
CIS_E_MALFORMED_EXPR | 0x1710 | The expression "%1" is malformed and cannot be interpreted by the server.
CIS_E_DB_SHUTDOWN | 0x1711 | The server is shutting down because of a database failure.
CIS_E_SUBMIT_BLOCKED | 0x1712 | All submit calls have been blocked due to a database failure. After correcting this problem, please go to Component Services and shut down the 'BizTalk Server Interchange Application', before attempting to call any submit method.
CIS_E_CERT_NOT_FOUND | 0x1713 | The required certificate cannot be found in the certificate store.
CIS_E_NODATA | 0x1714 | The Submit method call did not contain a document or a file path.
CIS_E_TOOMUCH_DATA | 0x1715 | The Submit method call contained both a document and a file path.
CIS_E_INVALID_OPENFLAG | 0x1716 | The Submit method call was passed an openness type that is not valid. Refer to the BizTalk Server 2000 Help documentation for the enumeration of these values.
CIS_E_PASSTHROUGH_PARAMS | 0x1717 | The Submit method call contained a channel along with source, destination, or document name information. Do not include source, destination, or document name information when passing the channel as a parameter within a Submit method call.
CIS_E_NOSRCID | 0x1718 | The Submit method call contained a source qualifier but no source identifier.
CIS_E_NODESTID | 0x1719 | The Submit method call contained a destination qualifier but no destination identifier.
MSG_TIMEBOMB_EXPIRED | 0x171A | Thank you for evaluating Microsoft BizTalk Server 2000. The period for this evaluation version has ended. Please contact Microsoft or your software reseller to obtain a licensed version of Microsoft BizTalk Server 2000.
CIS_E_LOOPBACK | 0x171B | An attempt was made to submit a document that uses the Loopback transport type. The Loopback transport type can only be used when calling the SubmitSync method.
CIS_E_DBEXECUTE | 0x171C | The following stored procedure call failed: "%1".
CIS_E_MISSING_SMTPHOST | 0x171D | In order to use the SMTP transport, the SMTP host must be specified. To specify an SMTP host, in BizTalk Server Administration expand Microsoft BizTalk Server 2000, right-click BizTalk Server Group, and then click Properties to open the BizTalk Server Group Properties dialog box. On the General tab, in the SMTP host box, specify the SMTP host that you want to use.
CIS_E_INVALIDHANDLE | 0x171E | This method expected a submission handle or an array of submission handles, but the incoming data was not valid. Verify that the parameters are correct.
CIS_E_DBCONNECT | 0x171F | BizTalk Server failed to initialize a connection to database: "%1" on server: "%2".
CIS_E_PASSTHROUGH_WITH_NOCHANNEL | 0x1720 | A valid channel name must be specified as a submission parameter on a Submit or SubmitSync method call when the pass-through flag is set to true.
CIS_W_DBFAILURE | 0x1721 | The database call failed and returned the following error string: "%1". If possible, we will attempt to retry this call.
CIS_E_GET_BTMPARAMS | 0x1722 | Unable to load connection parameters for BTM database. Please go to the Administration MMC to resolve this problem.
CIS_E_UNABLE_TO_CREATE_CUSTOM_PRE_PROC | 0x1723 | The custom preprocessing component for the receive function "%1" could not be created. This document will be moved to the Suspended queue.
CIS_E_CUSTOM_PRE_PROC_FAILED | 0x1724 | The custom preprocessing component used by the receive function "%1" failed. This document will be moved to the Suspended queue.
CIS_E_CUSTOM_PRE_PROC_NO_BSTR | 0x1725 | The custom preprocessing component used by the File receive function "%1" failed to return a valid BSTR. A valid BSTR is required. This document will be moved to the Suspended queue.
CIS_E_CUSTOM_PRE_PROC_INVALID_DATA | 0x1726 | The custom preprocessing component used by the Message Queue receive function "%1" cannot be called because the message contains data that is not a BSTR or a BYTE array. This document will be moved to the Suspended queue.
CIS_E_CUSTOM_PRE_PROC_INVALID_CP | 0x1727 | The custom preprocessing component used by the Message Queue receive function "%1" failed to return a valid code page. This document will be moved to the Suspended queue.
CIS_E_CUSTOM_PRE_PROC_INVALID_DATA_OUT | 0x1728 | The custom preprocessing component used by the Message Queue receive function "%1" failed to return a valid document, the document must be either a BSTR or a BYTE array. This document will be moved to the Suspended queue.
CIS_E_CUSTOM_FILE_PRE_PROC_FAIL | 0x1729 | The custom preprocessing component used by the file receive function "%1" failed. The document "%2" will be moved to the Suspended queue.
CIS_E_CUSTOM_PRE_PROC_CANT_SET_CTX | 0x172A | The server was unable to set the context on the custom preprocessing component used by the receive function "%1". This document will be moved to the Suspended queue.
CIS_E_FILERCV_FILE_SHARE_DOWN | 0x172B | The file receive function "%1" was unable to connect to the network share "%2". This receive function will try to connect again.
CIS_E_FILERCV_NETWORK_DOWN | 0x172C | The file receive function "%1" is experiencing network problems and was unable to connect to the network share "%2". This receive function will try to connect again.
CIS_E_RECEIVE_FUNCTION_DISABLED | 0x172D | The receive function "%1" has experienced problems, it will be shut down and disabled. Once these problems have been corrected, re-enable this receive function in BizTalk Server Administration.
CIS_E_UNRECOVERABLE | 0x172E | There was a serious error within the BizTalk Server scheduler component. The server is being shut down. Resolve this problem and then restart the server.
CIS_E_RELIABLE_NOACK | 0x172F | The server has not received a receipt for the reliable message.
CIS_E_DLQ_ID | 0x1730 | Suspended Queue ID: "%1"
CIS_E_CANNOT_FIRE_EVENT | 0x1731 | The server cannot send a WMI event for the Suspended queue item "%1". The most likely cause is that the user configured for this submission has insufficient privileges to access WMI.
CIS_E_SERIALIZER_INVALID_DOCUMENT | 0x1800 | The document with the "%1" tracking identifier is invalid XML. The serializer cannot continue.
CIS_E_BTF_INVALID_ADDRESS_TYPE | 0x1801 | The BizTalk Framework document has an "type" specified that is not valid for the "%1" address field. This document will be moved to the Suspended queue.
CIS_E_RELIABLE_MSG_RECEIPT_REQ_BY | 0x1802 | The BizTalk Framework document "%1" will not be transmitted as it has an expired "receiptRequiredBy" timestamp. This message will be discarded.
CIS_E_CUSTOM_ENVELOPE_ERROR | 0x1803 | The custom envelope:"%1" had the property "%2" specified, but the custom envelope generator could not to locate the XML node. This document will be moved to the Suspended queue.
CIS_E_SERIALIZER_INVALID_DATETIME | 0x1804 | The "%1" date or time format is not valid. Correct the format specification.
CIS_E_SERIALIZER_INVALID_DTDATA | 0x1805 | The "%1" date or time field is not a valid ISO8601 format. Make sure that the XML date or time is formatted correctly.
CIS_E_SERIALIZER_INVALID_DELIMITER | 0x1806 | The "%1" delimiter is either missing or has a value specified that is not valid. Update the delimiter value.
CIS_E_SERIALIZER_MISSING_PROPSET | 0x1807 | The "%1" document is missing the entire property set that is required for this serializer to run.
CIS_E_SERIALIZER_MISSING_PROP | 0x1808 | The property set for the "%1" document either is missing or does not contain a valid value for the "%2" property. Add or correct this property.
CIS_E_SERIALIZER_INVALIDARG | 0x1809 | Both source and destination qualifiers and values are required for this serializer to run. Specify qualifiers and values in the messaging port for this transaction.
CIS_E_SERIALIZER_MISMATCH_SPEC | 0x180A | The serialization produced no output. Verify that the document specification matches the outbound XML document.
CIS_E_SERIALIZER_FAILED | 0x180B | The serializer could not finish processing. See the following messages for details.
CIS_E_SERIALIZER_INVALID_SRCQUAL | 0x180C | The "%1" qualifier for the source identifier is too long to be placed in the outbound document header. Update the channel with a shorter qualifier.
CIS_E_SERIALIZER_INVALID_SRCID | 0x180D | The "%1" value for the source identifier is too long to be placed in the output header. Update the channel with a shorter value.
CIS_E_SERIALIZER_INVALID_DESTQUAL | 0x180E | The "%1" qualifier for the destination identifier is too long to be placed in the output header. Update the port with a shorter qualifier.
CIS_E_SERIALIZER_INVALID_DESTID | 0x180F | The "%1" value for the destination identifier is too long to be placed in the output header. Update the port with a shorter identifier.
CIS_E_SERIALIZER_INVALID_POSREC | 0x1810 | The "%1" positional record is defined to contain a record length of zero. This happens when there is no tag, and none of the fields in this record specify start and end positions. Update the fields to have valid start and end positions for this record.
CIS_E_SERIALIZER_NODELIMS | 0x1811 | This serializer component requires delimiters specified in the messaging port. Specify a valid delimiter set for this component.
CIS_E_SERIALIZER_INVALID_CHAR | 0x1812 | The serializer component has encountered a character, "%1", that is not valid. An entry specified in the InvalidCharacterMap tag of the document specification states that characters between "%2" and "%3" are not valid.
CIS_E_SERIALIZER_INVALID_LENGTH | 0x1813 | The length of the "%1" field ("%2") is not valid; it must be between %3 and %4. This document will be rejected.
CIS_E_SERIALIZER_SELECT_SINGLE_NODE_FAILED | 0x1814 | The serializer component cannot find the node using the query "%1". This document will be rejected.
CIS_E_SERIALIZER_RELIABLE_URL_MISSING | 0x1815 | The reply-to URL required for reliable messaging was not set. This document will be rejected.
CIS_E_SERIALIZER_CONTROL_NUMBER | 0x1816 | The serializer component cannot find a control number for %1 %2 in the BizTalk Management database. This document will be rejected.
CIS_E_CUSTOM_ENV_PARSE_TABLE_ERROR | 0x1817 | The serializer component failed to build the custom envelope ID:"%1", this was due to errors in the XML Schema supplied. This document will be moved to the Suspended queue.
CIS_E_SUBSYNC_RELIABLE_MSG | 0x1818 | The BizTalk Framework document that was submitted has "reliability" information specified. This information is not permitted in a synchronous call.
CIS_E_CUSTXML_BODY_NOT_FOUND | 0x1819 | The parser was unable to locate the XML document node by using the query specified in the XML specification: "%1".
CIS_E_BTF_ACK_BAD_MSG_ID | 0x181A | The BizTalk Framework receipt had a <prop:identity> tag that is not valid: "%1". This document will be moved to the Suspended queue.
CIS_E_BTF_MANIFEST_REF_MISSING | 0x181B | The BizTalk Framework document has a <manifest> tag without the mandatory <reference> tag. This document will be moved to the Suspended queue.
CIS_E_CUSTOM_ENV_NO_DOC_NODE | 0x181C | The serializer failed to create the custom envelope because the Document Container Node property was not specified in the XML specification. This document will be moved to the Suspended queue.
CIS_E_BTF_INVALID_XSI_TYPE | 0x181D | The BizTalk Framework document contains an xsi:type attribute "%1" that is not valid. This attribute must not have spaces, and the first character must be alphabetical. This document will be moved to the Suspended queue.
CIS_E_SERIALIZER_INVALID_SYNTAX_IDENTIFIER | 0x181E | The EDIFACT Syntax Identifier "%1" is not valid. Update the channel with a correct identifier.
CIS_E_SERIALIZER_INVALID_UNA_CONTROL | 0x181F | The EDIFACT UNA Control value "%1" is not valid. Update the channel with a correct value.
CIS_E_SERIALIZER_EXPECT_BSTR_VALUE | 0x1820 | The configuration data for the field "%1" must be a string. Update the data for this field.
BTS_E_XMLSERIALIZER_MISSING_DEST | 0x1821 | The BizTalk Framework header could not be generated because no destination identifier was specified.
BTS_E_XMLSERIALIZER_MISSING_SRC | 0x1822 | The BizTalk Framework header could not be generated because no source identifier was specified.
CIS_E_BTF_IDENTITY_MISSING | 0x1904 | The parser could not find the mandatory BizTalk Framework tag "identity". This document will be moved to the Suspended queue.
CIS_E_BTF_EXPIRESAT_MISSING | 0x1905 | The parser could not find the mandatory BizTalk Framework tag "expiresAt". This document will be moved to the Suspended queue.
CIS_E_MSMQ_NOT_INSTALLED | 0x1906 | The Message Queuing receive function could not be started because the Message Queuing service is not installed on the server.
CIS_W_FILE_RECEIVE_RETRY_FAILURE | 0x1907 | There are file(s) in the "%1" directory that cannot be accessed by the file receive function. The receive service will try again to access the file(s) in "%2" seconds.
CIS_E_FTP_RECEIVE_DELETE_FAILURE | 0x1908 | The "%1" FTP receive function could not delete the following file after processing it: FTP server: "%2" Directory path: "%3" File name: "%4"
CIS_E_FILE_RECEIVE_DELETE_FAILURE | 0x1909 | The following file could not be deleted after processing: "%1". Make sure that the file attribute is not set to read-only.
CIS_E_LOGON_USER_FAILURE | 0x190a | Unable to logon with the account %1. Make sure that %2 has been granted "logon locally" privilege on this server and that the BizTalk Server account has "act as part of the operating system" privilege.
CIS_E_MSMQ_RECEIVE_IMPERSONATION_FAILURE | 0x190b | The "%1" Message Queuing receive function could not impersonate the logged on user.
CIS_E_RECEIVE_CANNOT_CREATE_THREAD | 0x190c | A receive-function thread cannot be created due to a system error.
CIS_E_MSMQ_RECEIVE_OPENQ_FAILURE | 0x190d | The following Message Queuing queue cannot be opened: "%1" (Message Queuing error code: 0x%2=%3). Verify the existence and security setting of the queue.
CIS_E_MSMQ_RECEIVE_PEEKQ_FAILURE | 0x190e | The Message Queuing queue could not be read: "%1" (Message Queuing error code: 0x%2=%3).
CIS_E_MSMQ_RECEIVE_RETRIEVEQ_FAILURE | 0x190f | A message could not be retrieved from the following Message Queuing queue: '%1' (Message Queuing error: 0x%2=%3).
CIS_E_FILE_RECEIVE_FINDCHANGE_FAILURE | 0x1910 | The file-change notification cannot be set up on the following directory: "%1". Make sure that the path is correct.
CIS_E_SET_CURRENT_DIR_FAILURE | 0x1911 | The current directory cannot be set to: "%1". Make sure that the path is correct.
CIS_E_FTP_RECEIVE_OPENCONNECT_FAILURE | 0x1912 | The FTP connection to the following server cannot be opened: "%1". Verify that the user "%2" has the correct password and permissions and that the user belongs to the correct domain. Also verify that messaging port number "%3" is correct.
CIS_E_FTP_RECEIVE_GET_FAILURE | 0x1913 | The FTP GET operation could not retrieve the "%1" file from the "%2" server.
CIS_W_RECEIVE_SUBMIT_FAILURE | 0x1914 | A submit request initiated from the "%1" receive function has failed.
CIS_E_READONLY_FILE | 0x1915 | The "%1" receive function picked up the following file: '%2'. This file is marked as read-only and cannot be processed.
CIS_E_BAD_RECSVC | 0x1916 | There was a serious failure in the receive function "%1". This receive service will be shut down, please check the event log for additional error messages.
CIS_E_FILE_RECEIVE_IMPERSONATION_FAILURE | 0x1917 | The "%1" file receive function could not impersonate the logged on user.
CIS_E_MSMQ_RECEIVE_UNEXPECTED_PASSTHROUGH | 0x1918 | The ""%1"" Message Queuing receive function is not configured for a pass-through submission, but it has encountered a document that was submitted previously as a pass-through submission. Change this receive function to accept pass-through submissions or remove the pass-through document from the queue. This receive function will be shut down.
CIS_E_BTSDOCUMENT_INVALIDNAME | 0x1A00 | The document named "%1" does not exist. Correct the document name or add the document to the BizTalk Messaging Management database.
CIS_E_BTSDOCUMENT_INVALIDDOC | 0x1A01 | The server could not load any documents with the given criteria.
CIS_E_BTSDOCUMENT_AMBIGUOUS_NAMESPACE | 0x1A02 | The root node "%1" is ambiguous because documents "%2" and "%3" refer to different specifications with that name. Either change the specifications to remove this ambiguity or use the document name explicitly.
CIS_E_BTSDOCUMENT_AMBIGUOUS_PROPSET | 0x1A03 | The property set is ambiguous because documents "%1" and "%2" refer to the same property set.
CIS_E_BTSDOCUMENT_AMBIGUOUS_PROPSETSHAREID | 0x1A04 | The property set is ambiguous because documents "%1" and "%2" refer to the same property set and have reference "%3".
CIS_E_BTSDOCUMENT_INVALIDPROPERTYSET | 0x1A05 | The following property set was specified: %1.
CIS_E_BTSDOCUMENT_EMPTYPROPERTYSET | 0x1A06 | The property set was empty.
CIS_E_BTSDOCUMENT_LOADFAILED | 0x1A07 | The document "%1" could not be loaded. Possible causes are using a non-envelope specification, or incorrectly configured tracking details.
CIS_E_BTSENVELOPE_LOADFAILED | 0x1A20 | The envelope "%1" could not be loaded. A possible cause is that the specification is not valid. Configure a valid envelope specification.
CIS_E_FAILED_TO_JOIN_TX | 0x1A21 | BizTalk Server failed to join a transaction. Ensure both the DTC and the SQL Server database are running.
MSG_COM_CREATE_FAILED | 0x1B01 | An instance of the %1 class cannot be created: %2.
MSG_CONNECT_WMI_FAILED | 0x1B02 | A connection to Windows Management on "%1" cannot be established: %2.
MSG_COSETPROXY_FAILED | 0x1B03 | The authentication credential cannot be set for the Windows Management connection: %1.
MSG_WMI_ENUMINST_FAILED | 0x1B04 | Instances of the BizTalk Server WMI provider class "%1" cannot be enumerated: %2.
MSG_WMI_GETPROP_FAILED | 0x1B05 | The property value of "%1" cannot be retrieved from the BizTalk Server WMI provider because of an unexpected error: %2.
MSG_WMI_EXECQUERY_FAILED | 0x1B06 | An unexpected error is preventing execution of the BizTalk Server WMI provider query "%1": %2.
MSG_WMI_GETOBJ_FAILED | 0x1B07 | The BizTalk Server WMI provider instance of "%1" cannot be retrieved because of an unexpected error: %2.
MSG_WMI_PUTPROP_FAILED | 0x1B08 | The property value of "%1" cannot be changed because of an unexpected error: %2.
MSG_WMI_PUTINST_FAILED | 0x1B09 | The property values of the BizTalk Server WMI provider instance "%1" cannot be updated because of an unexpected error: %2.
MSG_WMI_DELINST_FAILED | 0x1B0A | The BizTalk Server WMI provider instance "%1" cannot be deleted because of an unexpected error: %2.
MSG_WMI_CREATEINST_FAILED | 0x1B0B | A new instance of the WMI class "%1" cannot be created in the BizTalk Server WMI provider: %2.
MSG_WMI_CREATEGETOBJ_FAILED | 0x1B0C | A new instance of the BizTalk Server WMI provider class "%1" cannot be created because of an unexpected error: %2.
MSG_WMI_EXECMETHOD_GETOBJ_FAILED | 0x1B0D | The method "%1" of the BizTalk Server WMI provider class "%2" cannot be executed because of a failure to retrieve the class: %3.
MSG_WMI_EXECMETHODCLASS_FAILED | 0x1B0E | The method "%1" of the BizTalk Server WMI provider class "%2" cannot be executed because of a failure to retrieve the method information: %3.
MSG_WMI_EXECMETHODSPAWN_FAILED | 0x1B0F | The method "%1" of the BizTalk Server WMI provider class "%2" cannot be executed because of an unexpected error: %3.
MSG_WMI_EXECMETHODPUTPARAM_FAILED | 0x1B10 | The method "%1" of the BizTalk Server WMI provider class "%2" cannot be executed because of a failure to set the parameter value: %3.
MSG_WMI_EXECMETHOD_FAILED | 0x1B11 | The method "%1" of the WMI class "%2" cannot be executed by the BizTalk Server WMI provider: %3.
MSG_GET_HOSTNAME_FAILED | 0x1B12 | The local computer name cannot be obtained because of an unexpected error: %1.
MSG_OUT_OF_MEMORY | 0x1B14 | Insufficient memory.
MSG_FAIL_LOAD_BMP | 0x1B17 | At least one of the bitmaps cannot be loaded in the BizTalk Server Administration console: %1.
MSG_FAIL_SET_BMPSTRIP | 0x1B18 | At least one pair of bitmaps cannot be added to the image list of the BizTalk Server Administration console: %1.
MSG_ERROR_WMI_PATH_EMPTY | 0x1B19 | The requested operation cannot be completed because of a previous WMI failure. The WMI object path is empty in this case.
MSG_ERROR_BTM_GRP_ENUM_FAIL | 0x1B20 | Unknown problems are preventing the WMI provider from enumerating a list of server groups from the BizTalk Messaging Management database: %1.
MSG_ERROR_GRP_DTA_DB_FAIL | 0x1B21 | Unknown problems are preventing the WMI provider from accessing the Tracking database for the "%1" group.
MSG_ERROR_GRP_SQ_DB_FAIL | 0x1B22 | Unknown problems are preventing the WMI provider from accessing the Shared Queue database the "%1" group.
MSG_ERROR_GRP_BOTH_DB_FAIL | 0x1B23 | Unknown problems are preventing the WMI provider from accessing the Tracking and Shared Queue databases for the "%1" group.
MSG_ERROR_DECRYPT_FAIL | 0x1B24 | Password decryption failed: %1.
MSG_WARN_ENUM4ROOTUPD_FAILED | 0x1B27 | Unknown problems are preventing the WMI provider from retrieving following list of servers and their states to prepare for BizTalk Messaging Management database update: %1
MSG_ERROR_CHANGE_ROOTDB | 0x1B28 | The server "%1" cannot be updated with the new BizTalk Messaging Management database information: %2.
MSG_ERROR_CHANGE_ROOTDB_CONNECT | 0x1B29 | We cannot connect to the WMI namespace "%1" to update server "%2" with the new BizTalk Messaging Management database information: %3
MSG_CHANGE_ROOTDB_SUMMARY | 0x1B30 | The BizTalk Messaging Management database change request has been completed. %1%2 %3%4
MSG_CHANGE_ROOTDB_ON_LOCAL | 0x1B3A | Because the server and server group information cannot be retrieved from the original BizTalk Messaging Management database, the BizTalk Messaging Management database information will be updated only on the local computer "%1". The update has been successful.
MSG_ERROR_UNEXPECTED_ENDOFLIST | 0x1B3C | An unexpected end of list (EOL) for the "%1" class enumeration has been reached.
MSG_ERROR_ORG_QUALIFIERS_FROM_DB_FAILED | 0x1B3D | The organization qualifiers cannot be retrieved from the BizTalk Messaging Management database because of an unexpected error. "%1".
MSG_ERROR_ORG_VALUES_FROM_DB_FAILED | 0x1B3E | The organization values cannot be retrieved from the BizTalk Messaging Management database because of an unexpected error. "%1".
MSG_WARN_NOT_RESUBMITABLE | 0x1B3F | In the selected group of multiple items, at least one item cannot be submitted again.
MSG_WARNING_PROP_VALUES_CHANGED | 0x1B40 | %1 "%2" specified for receive function "%3" has been removed from the BizTalk Messaging Management database.
MSG_WARNING_QUALIFIER_CHANGED | 0x1B41 | The qualifier and identifier pair "%1" and "%2" specified for receive function "%3" is not valid in the BizTalk Messaging Management database.
MSG_WARNING_ORGANIZATION_CHANGED | 0x1B42 | Organization "%1" specified for receive function "%2" is not valid in the BizTalk Messaging Management database.
MSG_TIMEBOMB_DAYS_LEFT | 0x1B43 | Thank you for evaluating Microsoft BizTalk Server 2000. The period for this evaluation version has %1 days left. Please contact Microsoft or your software reseller to obtain a licensed version of Microsoft BizTalk Server 2000.
INTERCHANGE_EVENT | 0x3005 | BizTalk Server: %1

Note

  • When an error occurs, the %n variables are replaced with relevant information, such as an object name.


Submitting Documents

This section provides information about how to submit documents to Microsoft BizTalk Server 2000. For additional information, see the following sections:

  • For help with specific tasks, see How To.

  • For general background information, see Concepts.

  • For information about COM interfaces and enumerations, see the Submitting Documents Reference.

  • For examples of code, see BizTalk Messaging Services Code Samples.


How To...

This section provides task-specific information about how to submit documents to Microsoft BizTalk Server 2000. It is highly recommended that you review the Concepts as well. The following topics are covered:

  • Read the Tracking Database

  • Submit a Document from a Remote Client


Read the Tracking Database

The purpose of the tracking interface, IBizTalkTrackData, is to facilitate programmatic access to the tracking information of Microsoft BizTalk Server 2000. This complements the IInterchange interface so that returns from IInterchange calls can be fed to these IBizTalkTrackData methods to access data about the activity of documents submitted to BizTalk Server 2000.

There can be a one-to-one or a one-to-many relationship between input and output documents. In a normal document flow, one document is submitted to the server, is tracked and possibly transformed, and one document results as output from the server. However, the messaging port can be configured so that one document submitted can result in many documents as output to several destinations:

  1. Get the SubmissionHandle return from the Submit method of the IInterchange interface.

  2. Call the GetInterchanges method, using the SubmissionHandle return as the input. This method returns a list of interchanges contained in that submission, including all the data from the Tracking database. Because transport-specific information (delivery times, receipt flags, and so on) appears in the interchange data, you can look here to confirm or check status on delivery, for example.

  3. Call the GetInDocDetails method, using the SubmissionHandle return as the input. This method returns a list of the documents that were included in that submission. You can look here to find information about an input document (for example, was a specific document valid, how many bytes was it, and so on).

  4. Call the GetOutDocDetails method, using the SubmissionHandle return as the input. This method returns a list of the documents that were generated as a result of the submission. You can look here to find information about an output document (for example, looking for PO #123456 out of a submission made earlier today).

Related Topic

Submitting Documents Reference


Submit a Document from a Remote Client

A document can be submitted to Microsoft BizTalk Server 2000 from a remote client running an application that uses the IInterchange interface. To accomplish this, follow these steps:

  1. Using a computer that has Microsoft BizTalk Server 2000 installed, go to the Start menu, point to Programs, point to Administrative Tools, and then click Component Services.

  2. In the Tree pane, click Component Services, expand Computers, expand My Computer, expand COM+ Applications, and then click BizTalk Server Interchange Application.

  3. On the Action menu, click Export.

  4. On the Welcome to the COM Application Export Wizard dialog box, enter the name of an export installation package to be created.

  5. In the Export as area, click the Application proxy option and click Next to finish the wizard.

The COM Application Export Wizard creates a Windows Installer Package file with an .msi extension and its associated Cabinet file with a .cab extension. Copy these files to the remote client and run the Windows Installer Package file. Now the remote client can run applications that use the IInterchange interface.

Notes

  • The remote client must be running Microsoft Windows 2000.

  • The computer used to create the installation package acts as an "interchange server" for the remote client that is submitting documents. Therefore, all documents submitted on the remote client are routed through that server.

  • You can also create a remote client during the BizTalk Server 2000 installation.


Submitting Documents Reference

This section provides reference information about components and interfaces used to submit documents to Microsoft BizTalk Server 2000 for both Microsoft Visual C++ and Visual Basic programming. Reference information is provided for all interfaces, objects, and enumerations exposed for submitting documents to BizTalk Server 2000.

The following COM interfaces and enumerations are documented in this reference:

  • IBizTalkTrackData

  • IBTSCustomProcess

  • IBTSCustomProcessContext

  • IInterchange

  • Interchange Enumerations


IBizTalkTrackData Interface [C++]

BTSDocTracking Object [Visual Basic]

Use this object to facilitate programmatic access to the tracking information of Microsoft BizTalk Server 2000. This object complements the Interchange object so that returns from Interchange methods can be passed to these methods for reading tracking data about the documents submitted to BizTalk Server 2000.

In C++, use the IBizTalkTrackData interface to access the methods of the BizTalkTrackData object.

The methods of the BizTalkTrackData object are shown in the following table.

Method | Description
GetInDocDetails | Returns an ADO recordset that contains a list of the documents that were included in the SubmissionHandle return from the Submit method of the IInterchange interface. This method returns specific information for an input document.
GetInterchanges | Returns an ADO recordset that contains a list of interchanges contained in the SubmissionHandle return from the Submit method of the IInterchange interface, including all the data from the Tracking database. Transport-specific information, such as delivery times and receipt flags, appears in the Tracking database; you can check there to confirm or check status on delivery, for example.
GetOutDocDetails | Returns an ADO recordset that contains a list of the documents that were generated when the Submit method of the IInterchange interface was called. This method returns specific information for an output document, for example, PO #123456 from a Submit call made earlier today.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BTSDocTracking.h
Library: Use Microsoft BizTalk Server Doc Tracking 1.0 Type Library (CISDTA.dll)

Related Topics

Understanding the Tracking Database Schema

Document Definitions

Read the Tracking Database

Document Tracking


IBizTalkTrackData::GetInDocDetails Method [C++]

BTSDocTracking.GetInDocDetails Method [Visual Basic]

The GetInDocDetails method returns an ADO recordset that contains a list of the documents that were included in the SubmissionHandle return from the Submit method of the IInterchange interface. This method returns specific information for an input document.

Syntax

[C++]

HRESULT GetInDocDetails(
    BSTR bstrSubmissionID,
    IDispatch** ppdispResult

);

[Visual Basic]

object.GetInDocDetails( _
    bstrSubmissionID As String _
)

Parameters

[C++]

bstrSubmissionID

[in] BSTR that contains the SubmissionHandle string returned by Submit for this document instance.

ppdispResult

[out, retval] Address of a pointer to an IDispatch interface that contains a list of the documents that were included in the submission.

[Visual Basic]

bstrSubmissionID

String that contains the SubmissionHandle string returned by Submit for this document instance.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This method returns an Object that contains a list of the documents that were included in the submission.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BTSDocTracking.h
Library: Use Microsoft BizTalk Server Doc Tracking 1.0 Type Library (CISDTA.dll)

Related Topic

Understanding the Tracking Database Schema


IBizTalkTrackData::GetInterchanges Method [C++]

BTSDocTracking.GetInterchanges Method [Visual Basic]

The GetInterchanges method returns an ADO recordset that contains a list of interchanges contained in the SubmissionHandle return from the Submit method of the IInterchange interface, including all the data from the Tracking database. Because transport-specific information, such as delivery times and receipt flags, appears in the Tracking database, you can check there to confirm or check status on delivery, for example.

Syntax

[C++]

HRESULT GetInterchanges(
    BSTR bstrSubmissionID,
    IDispatch** ppdispResult
);

[Visual Basic]

object.GetInterchanges( _
    bstrSubmissionID As String, _
)

Parameters

[C++]

bstrSubmissionID

[in] BSTR that contains the SubmissionHandle string returned by Submit for this document instance.

ppdispResult

[out, retval] Address of a pointer to an IDispatch interface that contains a list of interchanges contained in this submission, including all the data from the Tracking database.

[Visual Basic]

bstrSubmissionID

String that contains the SubmissionHandle string returned by Submit for this document instance.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This method optionally returns an Object that contains a list of interchanges contained in this submission, including all the data from the Tracking database.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BTSDocTracking.h
Library: Use Microsoft BizTalk Server Doc Tracking 1.0 Type Library (CISDTA.dll)

Related Topic

Understanding the Tracking Database Schema


IBizTalkTrackData::GetOutDocDetails Method [C++]

BTSDocTracking.GetOutDocDetails Method [Visual Basic]

The GetOutDocDetails method returns an ADO recordset that contains a list of the documents that were generated as a result of the Submit method of the IInterchange interface. This method returns specific information for an output document, for example, PO #123456 from a Submit call made earlier today.

Syntax

[C++]

HRESULT GetOutDocDetails(
    BSTR bstrSubmissionID,
    IDispatch** ppdispResult
);

[Visual Basic]

object.GetOutDocDetails( _
    bstrSubmissionID As String _
)

Parameters

[C++]

bstrSubmissionID

[in] BSTR that contains the SubmissionHandle string returned by Submit for this document instance.

ppdispResult

[out, retval] Address of a pointer to an IDispatch interface that contains a list of the documents that were generated as a result of the submission.

[Visual Basic]

bstrSubmissionID

String that contains the SubmissionHandle string returned by Submit for this document instance.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This method returns an Object that contains a list of the documents that were generated as a result of the submission.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BTSDocTracking.h
Library: Use Microsoft BizTalk Server Doc Tracking 1.0 Type Library (CISDTA.dll)

Related Topic

Understanding the Tracking Database Schema


IBTSCustomProcess Interface [C++]

IBTSCustomProcess Object [Visual Basic]

Implement IBTSCustomProcess to create a custom preprocessor for BizTalk Server receive functions.

The methods of IBTSCustomProcess are shown in the following table.

Method | Description
Execute | Performs the custom processing of the data prior to sending the data to BizTalk Server for processing.
SetContext | Retrieves context information associated with the data being processed.

Remarks

For information about custom preprocessors, see Preprocessing Documents in a Receive Function.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include btsaic.h
Library: Use Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)


IBTSCustomProcess::Execute Method [C++]

IBTSCustomProcess.Execute Method [Visual Basic]

The Execute method performs the custom processing on data obtained from a receive function.

Syntax

[C++]

HRESULT Execute(
    VARIANT vDataIn,
    long nCodePageIn,
    VARIANT_BOOL bIsFilePath,
    VARIANT* nCodePageOut,
    VARIANT* vDataOut
);

[Visual Basic]

object.Execute( _
    vDataIn As Variant, _
    nCodePageIn As Long, _
    bIsFilePath As Boolean, _
    nCodePageOut As Variant, _
    vDataOut As Variant _
)

Parameters

[C++]

vDataIn

[in] VARIANT that contains the input data read by the receive function. For data read from a message queue, the data can be either an array or a BSTR. If the data is read from a file receive function, this parameter contains the file path. For file receive functions, the bIsFilePath parameter is set to VARIANT_TRUE.

nCodePageIn

[in] Long that contains the code page of the input data. The code page indicates the character set and keyboard layout used on a computer.

bIsFilePath

[in] VARIANT_BOOL flag that indicates the type of input data. A value of VARIANT_TRUE indicates that the vDataIn parameter contains a file path. A value of VARIANT_FALSE indicates that the vDataIn parameter contains data from a message queue.

nCodePageOut

[out] Pointer to a VARIANT that contains the code page of the output data. The code page indicates the character set and keyboard layout used on a computer.

vDataOut

[out] Pointer to a VARIANT that contains the output data. For file receive functions, this will be a BSTR. The data in this parameter is sent to BizTalk Server for processing.

[Visual Basic]

vDataIn

VARIANT that contains the input data read by the receive function. If the data is read from a file receive function, this parameter contains the file path. For file receive functions, the bIsFilePath parameter must be set to True.

nCodePageIn

Long that contains the code page of the input data. The code page indicates the character set and keyboard layout used on a computer.

bIsFilePath

VARIANT_BOOL flag that indicates the type of input data. A value of True indicates that the vDataIn parameter contains a file path. A value of False indicates that the vDataIn parameter contains data from a message queue.

nCodePageOut

VARIANT that contains the code page of the output data. The code page indicates the character set and keyboard layout used on a computer.

vDataOut

VARIANT that contains the output data. The data in this parameter is sent to BizTalk Server for processing.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

If BizTalk Server fails to create the custom preprocessor component, or if the Execute method returns an error or invalid data, the document being processed is placed in the Suspended queue.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include btsaic.h
Library: Use Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)


IBTSCustomProcess::SetContext Method [C++]

IBTSCustomProcess.SetContext Method [Visual Basic]

The SetContext method retrieves information associated with a document submitted to BizTalk Server.

Syntax

[C++]

HRESULT SetContext(
    IBTSCustomProcessContext* pCtx
);

[Visual Basic]

object.SetContext( _
    pCtx As IBTSCustomProcessContext _
)

Parameters

[C++]

pCtx

[in] IBTSCustomProcessContext that contains information associated with the document being processed by BizTalk Server.

[Visual Basic]

pCtx

IBTSCustomProcessContext that contains information associated with the document being processed by BizTalk Server.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

For additional information about the custom process context object, see IBTSCustomProcessContext.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include btsaic.h
Library: Use Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)


IBTSCustomProcessContext Interface [C++]

IBTSCustomProcessContext Object [Visual Basic]

Use this object to retrieve information associated with data being processed by using a custom preprocessor component.

In C++, use the IBTSCustomProcessContext interface to access the methods of the BTSCustomProcessContext object.

The properties of the BTSCustomProcessContext object are shown in the following table.

Property | Type | Description
ChannelName | BSTR | Name of the channel.
DestID | BSTR | Value of the destination organization qualifier.
DestQualifier | BSTR | Qualifier type of the destination organization.
DocName | BSTR | Name of the document.
EnvelopeName | BSTR | Name of the envelope used with the document.
Openness | long | Value that indicates if the messaging port is open.
PassThrough | long | Value that indicates whether pass-through submission mode is being used.
SourceID | BSTR | Value of the source organization qualifier.
SourceQualifier | BSTR | Qualifier type of the source organization.

Remarks

This object can be obtained by calling the SetContext method on the IBTSCustomProcess object. For information about custom preprocessors, see Preprocessing Documents in a Receive Function.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include btsaic.h
Library: Use Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)


IBTSCustomProcessContext::ChannelName Property [C++]

IBTSCustomProcessContext.ChannelName Property [Visual Basic]

The ChannelName property returns the name of the channel used for processing the current document.

Syntax

[C++]

Get method:

HRESULT get_ChannelName(
    BSTR* bstrPipelineName
);

[Visual Basic]

object.ChannelName()

Parameters

[C++]

bstrPipelineName

[out, retval] Pointer to a BSTR that contains the name of the channel used for processing the current document.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a String that contains the channel name.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include btsaic.h
Library: Use Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)


IBTSCustomProcessContext::DestID Property [C++]

IBTSCustomProcessContext.DestID Property [Visual Basic]

The DestID property returns the value of the destination organization qualifier.

Syntax

[C++]

Get method:

HRESULT get_DestID(
    BSTR* bstrDestID
);

[Visual Basic]

object.DestID()

Parameters

[C++]

bstrDestID

[out, retval] Pointer to a BSTR that contains the value of the destination organization qualifier.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a String that contains the value of the destination organization qualifier.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include btsaic.h
Library: Use Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)


IBTSCustomProcessContext::DestQualifier Property [C++]

IBTSCustomProcessContext.DestQualifier Property [Visual Basic]

The DestQualifier property returns the destination organization qualifier type.

Syntax

[C++]

Get method:

HRESULT get_DestQualifier(
    BSTR* bstrDestQualifier
);

[Visual Basic]

object.DestQualifier()

Parameters

[C++]

bstrDestQualifier

[out, retval] Pointer to a BSTR that contains the destination organization qualifier type.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

[Visual Basic]

This property returns a String that contains the destination organization qualifier type.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include btsaic.h
Library: Use Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)


IBTSCustomProcessContext::DocName Property [C++]

IBTSCustomProcessContext.DocName Property [Visual Basic]

The DocName property returns the name of the document definition used by the current document.

Syntax

[C++]

Get method:

HRESULT get_DocName(
    BSTR* bstrDocName
);

[Visual Basic]

object.DocName()

Parameters

[C++]

bstrDocName

[out, retval] Pointer to a BSTR that contains the document definition name.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a String that contains the document definition name.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include btsaic.h
Library: Use Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)


IBTSCustomProcessContext::EnvelopeName Property [C++]

IBTSCustomProcessContext.EnvelopeName Property [Visual Basic]

The EnvelopeName property returns the name of the envelope used with the current document.

Syntax

[C++]

Get method:

HRESULT get_EnvelopeName(
    BSTR* bstrEnvelopeName
);

[Visual Basic]

object.EnvelopeName()

Parameters

[C++]

bstrEnvelopeName

[out, retval] Pointer to a BSTR that contains the envelope name.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a String that contains the envelope with the current document.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include btsaic.h
Library: Use Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)


IBTSCustomProcessContext::Openness Property [C++]

IBTSCustomProcessContext.Openness Property [Visual Basic]

The Openness property returns the openness associated with the messaging port.

Syntax

[C++]

Get method:

HRESULT get_Openness(
    long* lOpenness
);

[Visual Basic]

object.Openness()

Parameters

[C++]

lOpenness

[out, retval] Pointer to a long that indicates openness on the messaging port. The long returned in this parameter represents a value in the BIZTALK_OPENNESS_TYPE enumeration.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a Long that indicates openness on the messaging port. The Long returned in this property represents a value in the BIZTALK_OPENNESS_TYPE enumeration.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include btsaic.h
Library: Use Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)


IBTSCustomProcessContext::PassThrough Property [C++]

IBTSCustomProcessContext.PassThrough Property [Visual Basic]

The PassThrough property indicates whether the document uses pass-through submission mode.

Syntax

[C++]

Get method:

HRESULT get_PassThrough(
    long* fPassThrough
);

[Visual Basic]

object.PassThrough()

Parameters

[C++]

fPassThrough

[out, retval] Pointer to a long that indicates whether the document uses pass-through submission mode. A value of 0 indicates that pass-through submission mode is not used. A non-zero value indicates that pass-through submission mode is used with the current document.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a Long that indicates whether the document uses pass-through submission mode. A value of 0 indicates that pass-through submission mode is not used. A non-zero value indicates that pass-through submission mode is used with the current document.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include btsaic.h
Library: Use Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)


IBTSCustomProcessContext::SourceID Property [C++]

IBTSCustomProcessContext.SourceID Property [Visual Basic]

The SourceID property returns the value of the source organization qualifier.

Syntax

[C++]

Get method:

HRESULT get_SourceID(
    BSTR* bstrSourceID
);

[Visual Basic]

object.SourceID()

Parameters

[C++]

bstrSourceID

[out, retval] Pointer to a BSTR that contains the value of the source organization qualifier.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a String that contains the value of the source organization qualifier.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include btsaic.h
Library: Use Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)


IBTSCustomProcessContext::SourceQualifier Property [C++]

IBTSCustomProcessContext.SourceQualifier Property [Visual Basic]

The SourceQualifier property returns the source organization qualifier type.

Syntax

[C++]

Get method:

HRESULT get_SourceQualifier(
    BSTR* bstrSourceQualifier
);

[Visual Basic]

object.SourceQualifier()

Parameters

[C++]

bstrSourceQualifier

[out, retval] Pointer to a BSTR that contains the source organization qualifier type.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a String that contains the source organization qualifier type.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include btsaic.h
Library: Use Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)


IInterchange Interface [C++]

Interchange Object [Visual Basic]

Use this object to exchange documents between applications and BizTalk Server 2000 directly or through a receive function

In C++, use the IInterchange interface to access the methods of the Interchange object.

The methods of the Interchange object are shown in the following table.

Method | Description
CheckSuspendedQueue | Checks the Suspended queue and returns a list of handles to documents or interchanges in the queue that match the request criteria.
DeleteFromSuspendedQueue | Deletes all specified documents from the Suspended queue.
GetSuspendedQueueItemDetails | Returns details of a document in the Suspended queue.
Submit | Submits an interchange to BizTalk Server 2000 for asynchronous processing. This method accepts only a string variable as the document or interchange. This means that applications cannot submit other objects, such as DOM objects, CDictionary objects, ADO objects, or any other data type or object type.
SubmitSync | Submits an interchange to BizTalk Server 2000 for synchronous transmission. This method returns a response if one is provided. This method accepts only a string variable for the document or interchange. This means that applications cannot submit other objects, such as DOM objects, CDictionary objects, ADO objects, or any other data type or object type.

Remarks

Using parameters with Submit and SubmitSync overrides certain fields in the header of a self-routing document.

For information about submitting documents from a remote client, see How To.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include cisapi.h
Library: (cisapi.tlb)

Related Topics

Submitting

Routing

Steps for Submitting a Document by Using COM Interfaces


IInterchange::CheckSuspendedQueue Method [C++]

Interchange.CheckSuspendedQueue Method [Visual Basic]

The CheckSuspendedQueue method checks the Suspended queue and returns a list of documents that match the request criteria.

Syntax

[C++]

HRESULT CheckSuspendedQueue(
    BSTR DocName,
    BSTR SourceName,
    BSTR DestName,
    VARIANT* DocumentHandleList
);

[Visual Basic]

object.CheckSuspendedQueue( _
    DocName As String, _
    SourceName As String, _
    DestName As String _
)

Parameters

[C++]

DocName

[in] BSTR that contains the name of the BizTalkDocument object. This parameter narrows the search for items in the Suspended queue. If this parameter is omitted, this method matches all BizTalkDocument objects. This is an optional parameter.

SourceName

[in] BSTR that contains the name of the source BizTalkOrganization object. This parameter narrows the search criteria for items in the Suspended queue. If this parameter is omitted, this method matches all BizTalkOrganization objects. This is an optional parameter.

DestName

[in] BSTR that contains the name of the destination BizTalkOrganization object. This parameter narrows the search criteria for items in the Suspended queue. If this parameter is omitted, this method matches all BizTalkOrganization objects. This is an optional parameter.

DocumentHandleList

[out] Pointer to a VARIANT that contains a list of handles to all documents in the Suspended queue.

[Visual Basic]

DocName

String that contains the name of the BizTalkDocument object. This parameter narrows the search for items in the Suspended queue. If this parameter is omitted, this method matches all BizTalkDocument objects. This is an optional parameter.

SourceName

String that contains the name of the source BizTalkOrganization object. This parameter narrows the search criteria for items in the Suspended queue. If this parameter is omitted, this method matches all BizTalkOrganization objects. This is an optional parameter.

DestName

String that contains the name of the destination BizTalkOrganization object. This parameter narrows the search criteria for items in the Suspended queue. If this parameter is omitted, this method matches all BizTalkOrganization objects. This is an optional parameter.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This method returns a Variant that contains a list of handles to all documents in the Suspended queue.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

The returned items are not deleted from the queue. To delete items from the Suspended queue, use the DeleteFromSuspendedQueue method.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include cisapi.h
Library: (cisapi.tlb)

Related Topics

Submitting

Steps for Submitting a Document by Using COM Interfaces


IInterchange::DeleteFromSuspendedQueue Method [C++]

Interchange.DeleteFromSuspendedQueue Method [Visual Basic]

The DeleteFromSuspendedQueue method deletes all specified documents from the Suspended queue.

Syntax

[C++]

HRESULT DeleteFromSuspendedQueue(
    VARIANT* DocumentHandleList
);

[Visual Basic]

object.DeleteFromSuspendedQueue( _
    DocumentHandleList As Variant _
)

Parameters

[C++]

DocumentHandleList

[in] Pointer to a VARIANT that contains a full list of handles or a subset for documents to be deleted from the Suspended queue.

[Visual Basic]

DocumentHandleList

Variant that contains a full list of handles or a subset for documents to be deleted from the Suspended queue.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

None.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include cisapi.h
Library: (cisapi.tlb)

Related Topics

Submitting

Steps for Submitting a Document by Using COM Interfaces


IInterchange::GetSuspendedQueueItemDetails Method [C++]

Interchange.GetSuspendedQueueItemDetails Method [Visual Basic]

The GetSuspendedQueueItemDetails method uses the list of handles returned by the CheckSuspendedQueue method to get information about a single entry in the Suspended queue.

Syntax

[C++]
HRESULT GetSuspendedQueueItemDetails(
    BSTR ItemHandle,
    VARIANT* SourceName,
    VARIANT* DestName,
    VARIANT* DocName,
    VARIANT* ReasonCode,
    VARIANT* ItemData
);
[Visual Basic]
object.GetSuspendedQueueItemDetails( _
    ItemHandle As String, _
    SourceName As Variant, _
    DestName As Variant, _
    DocName As Variant, _
    ReasonCode As Variant, _
    ItemData As Variant _
)

Parameters

[C++]

ItemHandle

[in] BSTR that contains the handle to an item in the Suspended queue.

SourceName

[out] Pointer to the VARIANT that contains the name of the source BizTalkOrganization object.

DestName

[out] Pointer to the VARIANT that contains the name of the destination BizTalkOrganization object.

DocName

[out] Pointer to the VARIANT that contains the name of the BizTalkDocument object.

ReasonCode

[out] Pointer to the VARIANT that contains the reason a document or interchange has been placed in the Suspended queue. For more information about this value, see the CISReasonToQueue enumeration.

ItemData

[out] Pointer to the VARIANT that contains the document instance or interchange.

[Visual Basic]

ItemHandle

String that contains the handle to an item in the Suspended queue.

SourceName

Variant that contains the name of the source BizTalkOrganization object. The value of this output parameter is set by calling this method.

DestName

Variant that contains the name of the destination BizTalkOrganization object. The value of this output parameter is set by calling this method.

DocName

Variant that contains the name of the associated BizTalkDocument object. The value of this output parameter is set by calling this method.

ReasonCode

Variant that contains the reason a document or interchange has been placed in the Suspended queue. For more information about this value, see the CISReasonToQueue enumeration. The value of this output parameter is set by calling this method.

ItemData

Variant that contains the document instance or interchange. The value of this output parameter is set by calling this method.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

None.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include cisapi.h
Library: (cisapi.tlb)

Related Topics

Submitting

Steps for Submitting a Document by Using COM Interfaces


IInterchange::Submit Method [C++]

Interchange.Submit Method [Visual Basic]

The Submit method sends a document to BizTalk Server 2000 for asynchronous processing. BizTalk Server 2000 places the document in a queue until the next available server can process it.

Syntax

[C++]

HRESULT Submit(
    BIZTALK_OPENNESS_TYPE lOpenness,
    BSTR Document,
    BSTR DocName,
    BSTR SourceQualifier,
    BSTR SourceID,
    BSTR DestQualifier,
    BSTR DestID,
    BSTR ChannelName,
    BSTR FilePath,
    BSTR EnvelopeName,
    long PassThrough,
    BSTR* SubmissionHandle
);

[Visual Basic]

object.Submit( _
    lOpenness As BIZTALK_OPENNESS_TYPE, _
    Document As String, _
    DocName As String, _
    SourceQualifier As String, _
    SourceID As String, _
    DestQualifier As String, _
    DestID As String, _
    ChannelName As String, _
    FilePath As String, _
    EnvelopeName As String, _
    PassThrough As Long _
)

Parameters

[C++]

lOpenness

[in] Enumeration value that indicates whether associated BizTalkPort objects can be open. Valid values are from the BIZTALK_OPENNESS_TYPE enumeration.

Document

[in] BSTR that contains the document instance submitted. This parameter accepts only a string buffer as the document or interchange. This means that applications cannot submit other objects, such as DOM objects, CDictionary objects, ADO objects, or any other data type or object type. Either the Document parameter or the FilePath parameter must be specified. Do not specify both. This is an optional parameter.

DocName

[in] BSTR that contains the name of the BizTalkDocument object associated with the instance of the document being submitted. If the lOpenness parameter is set to BIZTALK_OPENNESS_TYPE_SOURCE, you can select an input BizTalkDocument object that has an X12 or EDIFACT specification. If you do, however, the output BizTalkDocument must not have an X12 or EDIFACT specification. If lOpenness is set to BIZTALK_OPENNESS_TYPE_DESTINATION, the BizTalkDocument object must not have an X12 or EDIFACT specification. The DocName parameter cannot be used if the PassThrough parameter is set to TRUE. This is an optional parameter.

SourceQualifier

[in] BSTR that contains the qualifier of the source organization. This indicates how the SourceID parameter is to be interpreted. Valid values come from the organization identifier qualifiers that are created when the user creates an alias for an organization. Common qualifiers include the DUNS number, telephone number, and BizTalk. You must specify a SourceID. The default qualifier for all new organizations is Organization Name and refers to the name of the organization in the database. If a BizTalk Framework 2.0–compliant document is submitted and a qualifier is not found during parsing, the qualifier defaults to BizTalk. The SourceQualifier parameter cannot be used if the PassThrough parameter is set to TRUE. This is an optional parameter.

SourceID

[in] BSTR that contains the value of the qualifier of the source organization. For example, if the SourceQualifier parameter is Telephone, this value is the telephone number. If the Openness flag is set to OpenSrc, SourceID is interpreted as the source organization name. The SourceID parameter cannot be used if the PassThrough parameter is set to TRUE. This is an optional parameter.

DestQualifier

[in] BSTR that contains the qualifier of the destination organization. This indicates how the DestID parameter is to be interpreted. Valid values come from the organization identifier qualifiers that are created when the user creates an alias for an organization. Common qualifiers include the DUNS number, telephone number, and BizTalk. You must specify a DestID. The default qualifier for all new organizations is OrganizationName and refers to the name of the organization in the database. If a BizTalk Framework 2.0–compliant document is submitted and a qualifier is not found during parsing, the qualifier defaults to BizTalk. The DestQualifier parameter cannot be used if the PassThrough parameter is set to TRUE. This is an optional parameter.

DestID

[in] BSTR that contains the value of the qualifier of the destination organization. For example, if the DestQualifier parameter is Telephone, this value is the telephone number. If the Openness flag is set to OpenDest, DestID is used as the destination address. Note that the queue:// prefix must be used with an open messaging port when a Message Queue is specified as the destination address. The DestID parameter cannot be used if the PassThrough parameter is set to TRUE. This is an optional parameter.

ChannelName

[in] BSTR that contains the name of the BizTalkChannel object that is executed for this document. This bypasses the normal processing in which the parser tries to determine which messaging port/channel pair to execute, based on routing information in the parameters or in the document. This is an optional parameter unless the PassThrough parameter is set to TRUE.

FilePath

[in] BSTR that specifies a fully qualified path that contains the document to be submitted, rather than submitting the document directly as a string. BizTalk Server 2000 supports URL, UNC, and drive: format only. If the document is submitted as a file that is pointed to by the FilePath parameter, the call returns successfully after BizTalk Server 2000 has successfully copied the file to the Work queue. It is safe to delete the file from the specified path as soon as this method returns successfully. When a document is submitted to the server, using FilePath to specify the data, Submit can take 30 seconds or longer if the location of the file resides on a remote server that is unavailable, if the UNC path is invalid, or if the SQL server is down. Either the Document parameter or the FilePath parameter must be specified. Do not specify both. The FilePath parameter cannot be used if the PassThrough parameter is set to TRUE and a map is specified. This is an optional parameter.

EnvelopeName

[in] BSTR that contains the name of the envelope specification to use to break the interchange into documents. When an envelope name is provided in this parameter, the envelope must have a valid interchange specification. This requirement is enforced for envelopes created for Custom XML format also. When submitting a flat file to BizTalk Server 2000, you must create an envelope for this flat file and specify the name of the envelope in EnvelopeName. This is an optional parameter.

PassThrough

[in] Long that indicates how the server processes the document. When this parameter is set to TRUE, no decryption, decoding, or signature verification is performed on the document. When set to FALSE, the document is decrypted and decoded, and the signature is verified. When using pass-through submission mode (TRUE), the BIZTALK_OPENNESS_TYPE value must be set to BIZTALK_OPENNESS_TYPE_NOTOPEN and the ChannelName parameter must be specified. In addition, the DocName, SourceQualifier, SourceID, DestQualifier, and DestID parameters cannot be specified with pass-through submission mode. Pass-through submission mode should be used to prevent data corruption when exchanging binary files, or when only the server transport and global tracking features are being used.

SubmissionHandle

[out, retval] Pointer to a BSTR that contains a unique identifier for the submitted document or interchange. This handle can be used to query the Tracking database for the status of the interchange or document submitted. If more than one document is submitted (an interchange), a single handle is returned, yet the Tracking database enables the user to get the status of all child documents related to this interchange identifier.

[Visual Basic]

lOpenness

Enumeration value that indicates whether associated BizTalkPort objects can be open. Valid values are from the BIZTALK_OPENNESS_TYPE enumeration.

Document

String that contains the document instance submitted. This parameter accepts only a string buffer as the document or interchange. This means that applications cannot submit other objects, such as DOM objects, CDictionary objects, ADO objects, or any other data type or object type. Either the Document parameter or the FilePath parameter must be specified. Do not specify both. This is an optional parameter.

DocName

String that contains the name of the BizTalkDocument object associated with the instance of the document being submitted. If the lOpenness parameter is set to BIZTALK_OPENNESS_TYPE_SOURCE, you can select an input BizTalkDocument object that has an X12 or EDIFACT specification. If you do, however, the output BizTalkDocument must not have an X12 or EDIFACT specification. If lOpenness is set to BIZTALK_OPENNESS_TYPE_DESTINATION, the BizTalkDocument object must not have an X12 or EDIFACT specification. The DocName parameter cannot be used if the PassThrough parameter is set to True. This is an optional parameter.

SourceQualifier

String that contains the qualifier of the source organization. This indicates how the SourceID parameter is to be interpreted. Valid values come from the organization identifier qualifiers that are created when the user creates an alias for an organization. Common qualifiers include the DUNS number, telephone number, and BizTalk. You must specify a SourceID. The default qualifier for all new organizations is Organization Name and refers to the name of the organization in the database. If a BizTalk Framework 2.0–compliant document is submitted and a qualifier is not found during parsing, the qualifier defaults to BizTalk. The SourceQualifier parameter cannot be used if the PassThrough parameter is set to True. This is an optional parameter.

SourceID

String that contains the value of the qualifier of the source organization. For example, if the SourceQualifier parameter is Telephone, this value is the telephone number. If the Openness flag is set to OpenSrc, SourceID is interpreted as the source organization name. The SourceID parameter cannot be used if the PassThrough parameter is set to True. This is an optional parameter.

DestQualifier

String that contains the qualifier of the destination organization. This indicates how the DestID parameter is to be interpreted. Valid values come from the organization identifier qualifiers that are created when the user creates an alias for an organization. Common qualifiers include the DUNS number, telephone number, and BizTalk. You must specify a DestID. The default qualifier for all new organizations is OrganizationName and refers to the name of the organization in the database. If a BizTalk Framework 2.0–compliant document is submitted and a qualifier is not found during parsing, the qualifier defaults to BizTalk. The DestQualifier parameter cannot be used if the PassThrough parameter is set to True. This is an optional parameter.

DestID

String that contains the value of the qualifier of the destination organization. For example, if the DestQualifier parameter is Telephone, this value is the telephone number. If the Openness flag is set to OpenDest, DestID is used as the destination address. Note that the queue:// prefix must be used with an open messaging port when a Message Queue is specified as the destination address. The DestID parameter cannot be used if the PassThrough parameter is set to True. This is an optional parameter.

ChannelName

String that contains the name of the BizTalkChannel object that is executed for this document. This bypasses the normal processing in which the parser tries to determine which messaging port/channel pair to execute, based on routing information in the parameters or in the document. This is an optional parameter unless the PassThrough parameter is set to True.

FilePath

String that specifies a fully qualified path that contains the document to be submitted, rather than submitting the document directly as a string. BizTalk Server 2000 supports URL, UNC, and drive: format only. If the document is submitted as a file that is pointed to by the FilePath parameter, the call returns successfully after BizTalk Server 2000 has successfully copied the file to the Work queue. It is safe to delete the file from the specified path as soon as this method returns successfully. When a document is submitted to the server, using FilePath to specify the data, Submit can take 30 seconds or longer if the location of the file resides on a remote server that is unavailable, if the UNC path is invalid, or if the SQL server is down. Either the Document parameter or the FilePath parameter must be specified. Do not specify both. The FilePath parameter cannot be used if the PassThrough parameter is set to True and a map is specified. This is an optional parameter.

EnvelopeName

String that contains the name of the envelope specification to use to break the interchange into documents. When an envelope name is provided as an argument, the envelope must have a valid interchange specification. This requirement is enforced for envelopes created for Custom XML format also. When submitting a flat file to BizTalk Server 2000, you must create an envelope for this flat file and specify the name of the envelope in EnvelopeName. This is an optional parameter.

PassThrough

Long that indicates how the server processes the document. When this parameter is True, no decryption, decoding, or signature verification is performed on the document. When set to False, the document is decrypted and decoded, and the signature is verified. When using pass-through submission mode (True), the BIZTALK_OPENNESS_TYPE value must be set to BIZTALK_OPENNESS_TYPE_NOTOPEN and the ChannelName parameter must be specified. In addition, the DocName, SourceQualifier, SourceID, DestQualifier, and DestID parameters cannot be specified with pass-through submission mode. Pass-through submission mode should be used to prevent data corruption when exchanging binary files, or when only the server transport and global tracking features are being used.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This method returns a String that contains a unique identifier for the submitted document or interchange. This handle can be used to query the Tracking database for the status of the interchange or document submitted. If more than one document is submitted (an interchange), a single handle is returned; yet the Tracking database can access the status of all child documents related to this interchange identifier.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include cisapi.h
Library: (cisapi.tlb)

Related Topics

Openness

Routing

Submitting

Steps for Submitting a Document by Using COM Interfaces


IInterchange::SubmitSync Method [C++]

Interchange.SubmitSync Method [Visual Basic]

The SubmitSync method sends an interchange or document to BizTalk Server 2000 for synchronous processing. An optional response document is returned to the caller.

Syntax

[C++]

HRESULT SubmitSync(
    BIZTALK_OPENNESS_TYPE lOpenness,
    BSTR Document,
    BSTR DocName,
    BSTR SourceQualifier,
    BSTR SourceID,
    BSTR DestQualifier,
    BSTR DestID,
    BSTR ChannelName,
    BSTR FilePath,
    BSTR EnvelopeName,
    long PassThrough,
    VARIANT* SubmissionHandle,
    VARIANT* ResponseDocument
);

[Visual Basic]

object.SubmitSync( _
    lOpenness As BIZTALK_OPENNESS_TYPE, _
    Document As String, _
    DocName As String, _
    SourceQualifier As String, _
    SourceID As String, _
    DestQualifier As String, _
    DestID As String, _
    ChannelName As String, _
    FilePath As String, _
    EnvelopeName As String, _
    PassThrough As Long, _
    SubmissionHandle As Variant, _
    ResponseDocument As Variant _
)

Parameters

[C++]

lOpenness

[in] Enumeration value that indicates whether associated BizTalkPort objects can be open. Valid values are from the BIZTALK_OPENNESS_TYPE enumeration.

Document

[in] BSTR that contains the document instance submitted. This parameter accepts only a string buffer as the document or interchange. This means that applications cannot submit other objects, such as DOM objects, CDictionary objects, ADO objects, or any other data type or object type. Either the Document parameter or the FilePath parameter must be specified. Do not specify both. This is an optional parameter.

DocName

[in] BSTR that contains the name of the BizTalkDocument object associated with the instance of the document submitted. If the lOpenness parameter is set to BIZTALK_OPENNESS_TYPE_SOURCE, you can select an input BizTalkDocument object that has an X12 or EDIFACT specification. If you do, however, the output BizTalkDocument must not have an X12 or EDIFACT specification. If lOpenness is set to BIZTALK_OPENNESS_TYPE_DESTINATION, the BizTalkDocument object must not have an X12 or EDIFACT specification. The DocName parameter cannot be used if the PassThrough parameter is set to TRUE. This is an optional parameter.

SourceQualifier

[in] BSTR that contains the qualifier of the source organization. This indicates how the SourceID parameter is to be interpreted. Valid values come from the organization identifier qualifiers that are created when the user creates an alias for an organization. Common qualifiers include the DUNS number, telephone number, and BizTalk. You must specify a SourceID. The default qualifier for all new organizations is Organization Name and refers to the name of the organization in the database. If a BizTalk Framework 2.0–compliant document is submitted and a qualifier is not found during parsing, the qualifier defaults to BizTalk. The SourceQualifier parameter cannot be used if the PassThrough parameter is set to TRUE. This is an optional parameter.

SourceID

[in] BSTR that contains the value of the qualifier of the source organization. For example, if the SourceQualifier parameter is Telephone, this value is the telephone number. If the Openness flag is set to OpenSrc, SourceID is interpreted as the source organization name. The SourceID parameter cannot be used if the PassThrough parameter is set to TRUE. This is an optional parameter.

DestQualifier

[in] BSTR that contains the qualifier of the destination organization. This indicates how the DestID parameter is to be interpreted. Valid values come from the organization identifier qualifiers that are created when the user creates an alias for an organization. Common qualifiers include the DUNS number, telephone number, and BizTalk. You must specify a DestID parameter. The default qualifier for all new organizations is Organization Name and refers to the name of the organization in the database. If a BizTalk Framework 2.0–compliant document is submitted and a qualifier is not found during parsing, the qualifier defaults to BizTalk. The DestQualifier parameter cannot be used if the PassThrough parameter is set to TRUE. This is an optional parameter.

DestID

[in] BSTR that contains the value of the qualifier of the destination organization. For example, if the DestQualifier parameter is Telephone, this value is the telephone number. If the Openness flag is set to OpenDest, DestID is used as the destination address. Note that the queue:// prefix must be used with an open messaging port when a Message Queue is specified as the destination address. The DestID parameter cannot be used if the PassThrough parameter is set to TRUE. This is an optional parameter.

ChannelName

[in] BSTR that contains the name of the BizTalkChannel object that is executed for this document. This bypasses the normal processing in which the parser tries to determine which messaging port/channel pair to execute, based on routing information in the parameters or in the document. This is an optional parameter unless the PassThrough parameter is set to TRUE.

FilePath

[in] BSTR that specifies a fully qualified path that contains the document to be submitted, rather than submitting the document directly as a string. BizTalk Server 2000 supports URL, UNC, and drive: format only. Either the Document parameter or the FilePath parameter must be specified. Do not specify both. The FilePath parameter cannot be used if the PassThrough parameter is set to TRUE and a map is specified. This is an optional parameter.

EnvelopeName

[in] BSTR that contains the name of the envelope specification to use to break the interchange into documents. When an envelope name is provided in this parameter, the envelope must have a valid interchange specification. This requirement is enforced for envelopes created for Custom XML format also. This is an optional parameter.

PassThrough

[in] Long that indicates how the server processes the document. When this parameter is set to TRUE, no decryption, decoding, or signature verification is performed on the document. When set to FALSE, the document is decrypted and decoded, and the signature is verified. When using pass-through submission mode (TRUE), the BIZTALK_OPENNESS_TYPE value must be set to BIZTALK_OPENNESS_TYPE_NOTOPEN and the ChannelName parameter must be specified. In addition, the DocName, SourceQualifier, SourceID, DestQualifier, and DestID parameters cannot be specified with pass-through submission mode. Pass-through submission mode should be used to prevent data corruption when exchanging binary files, or when only the server transport and global tracking features are being used.

SubmissionHandle

[out] Pointer to a BSTR that contains a unique identifier for the submitted document or interchange. This handle can be used to query the Tracking database for the status of the interchange or document submitted. If more than one document is submitted (an interchange), a single handle is returned; yet the Tracking database can access the status of all child documents related to this interchange identifier.

ResponseDocument

[out] Pointer to the VARIANT that contains the optional response document.

[Visual Basic]

lOpenness

Enumeration value that indicates whether associated BizTalkPort objects can be open. Valid values are from the BIZTALK_OPENNESS_TYPE enumeration.

Document

String that contains the document instance submitted. This parameter accepts only a string buffer as the document or interchange. This means that applications cannot submit other objects, such as DOM objects, CDictionary objects, ADO objects, or any other data type or object type. Either the Document parameter or the FilePath parameter must be specified. Do not specify both. This is an optional parameter.

DocName

String that contains the name of the BizTalkDocument object associated with the instance of the document submitted. If the lOpenness parameter is set to BIZTALK_OPENNESS_TYPE_SOURCE, you can select an input BizTalkDocument object that has an X12 or EDIFACT specification. If you do, however, the output BizTalkDocument must not have an X12 or EDIFACT specification. If lOpenness is set to BIZTALK_OPENNESS_TYPE_DESTINATION, the BizTalkDocument object must not have an X12 or EDIFACT specification. The DocName parameter cannot be used if the PassThrough parameter is set to True. This is an optional parameter.

SourceQualifier

String that contains the qualifier of the source organization. This indicates how the SourceID parameter is to be interpreted. Valid values come from the organization identifier qualifiers that are created when the user creates an alias for an organization. Common qualifiers include the DUNS number, telephone number, and BizTalk. You must specify a SourceID. The default qualifier for all new organizations is Organization Name and refers to the name of the organization in the database. If a BizTalk Framework 2.0–compliant document is submitted and a qualifier is not found during parsing, the qualifier defaults to BizTalk. The SourceQualifier parameter cannot be used if the PassThrough parameter is set to True. This is an optional parameter.

SourceID

String that contains the value of the qualifier of the source organization. For example, if the SourceQualifier parameter is Telephone, this value is the telephone number. If the Openness flag is set to OpenSrc, SourceID is interpreted as the source organization name. The SourceID parameter cannot be used if the PassThrough parameter is set to True. This is an optional parameter.

DestQualifier

String that contains the qualifier of the destination organization. This indicates how the DestID parameter is to be interpreted. Valid values come from the organization identifier qualifiers that are created when the user creates an alias for an organization. Common qualifiers include the DUNS number, telephone number, and BizTalk. You must specify a DestID. The default qualifier for all new organizations is Organization Name and refers to the name of the organization in the database. If a BizTalk Framework 2.0–compliant document is submitted and a qualifier is not found during parsing, the qualifier defaults to BizTalk. The DestQualifier parameter cannot be used if the PassThrough parameter is set to True. This is an optional parameter.

DestID

String that contains the value of the qualifier of the destination organization. For example, if the DestQualifier parameter is Telephone, this value is the telephone number. If the Openness flag is set to OpenDest, DestID is used as the destination address. Note that the queue:// prefix must be used with an open messaging port when a Message Queue is specified as the destination address. The DestID parameter cannot be used if the PassThrough parameter is set to True. This is an optional parameter.

ChannelName

String that contains the name of the BizTalkChannel object that is executed for this document. This bypasses the normal processing in which the parser tries to determine which messaging port/channel pair to execute, based on routing information in the parameters or in the document. This is an optional parameter unless the PassThrough parameter is set to True.

FilePath

String that specifies a fully qualified path that contains the document to be submitted, rather than submitting the document directly as a string. BizTalk Server 2000 supports URL, UNC, and drive: format only. Either the Document parameter or the FilePath parameter must be specified. Do not specify both. The FilePath parameter cannot be used if the PassThrough parameter is set to True and a map is specified. This is an optional parameter.

EnvelopeName

String that contains the name of the envelope specification to use to break the interchange into documents. When an envelope name is provided in this parameter, the envelope must have a valid interchange specification. This requirement is enforced for envelopes created for Custom XML format also. This is an optional parameter.

PassThrough

Long that indicates how the server processes the document. When this parameter is True, no decryption, decoding, or signature verification is performed on the document. When set to False, the document is decrypted and decoded, and the signature is verified. When using pass-through submission mode (True), the BIZTALK_OPENNESS_TYPE value must be set to BIZTALK_OPENNESS_TYPE_NOTOPEN and the ChannelName parameter must be specified. In addition, the DocName, SourceQualifier, SourceID, DestQualifier, and DestID parameters cannot be specified with pass-through submission mode. Pass-through submission mode should be used to prevent data corruption when exchanging binary files, or when only the server transport and global tracking features are being used.

SubmissionHandle

Variant that contains a unique identifier for the submitted document or interchange. This handle can be used to query the Tracking database for the status of the interchange or document submitted. If more than one document is submitted (an interchange), a single handle is returned; yet the Tracking database can access the status of all child documents related to this interchange identifier.

ResponseDocument

Variant that contains the optional response document.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

None.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

SubmitSync returns an optional response document when provided. If no response is returned, the call returns successfully, but with no response and with an HRESULT value of S_FALSE. If the destination is another BizTalk Server, an ASP page must be used to return a response.

A synchronous interchange bypasses all queues and executes all the components required by the messaging port on the calling thread. For synchronous protocols (HTTP and AIC), an optional response document is returned to the user, if available. This method is valid only for a single channel match. If the parameters set cause multiple channels to match, synchronous submission returns an error indicating that multiple channel matches are not allowed for synchronous submission. This method can be used only for single document interchanges. If the submission contains multiple documents, synchronous submission returns an error indicating that multiple document submissions are not allowed. This method does not support port groups.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include cisapi.h
Library: (cisapi.tlb)

Related Topics

Openness

Routing

Submitting

Steps for Submitting a Document by Using COM Interfaces


Interchange Enumerations

The following enumeration lists the possible values of properties and parameters:

  • CISReasonToQueue


CISReasonToQueue

The CISReasonToQueue enumerations are defined in the cisapi.h header file, located on the BizTalk Server installation drive in the Program Files\Microsoft BizTalk Server\SDK\Include folder.

The CISReasonToQueue enumeration has one of the following values:

Name | Value | Description
noReason | 0 | Not supported for this release.
rtdlqParserFailure | 1 | Specifies that the instance of the document was placed in the queue because of failure of the parser.
rtdlqParserDocFailure | 2 | Specifies that the instance of the document was placed in the queue because the business document was invalid.
rtdlqDocValidation | 3 | Specifies that the document was placed in the queue because document validation failed.
rtdlqChannelSelectFailure | 4 | Specifies that the instance of the document was placed in the queue because of failure in selecting the correct BizTalkChannel object.
rtdlqInvalidMap | 5 | Specifies that the instance of the document was placed in the queue because the map referred to by the BizTalkChannel object was formatted incorrectly.
rtdlqFieldTrackingFailure | 6 | Specifies that the instance of the document was placed in the queue because the server was unable to track the requested fields within the document.
rtdlqMappingFailure | 7 | Specifies that the instance of the document was placed in the queue because of failure of transformation.
rtdlqSerializerFailure | 8 | Specifies that the instance of the document was placed in the queue because the server could not convert this document to its native format.
rtdlqEncodingFailure | 9 | Specifies that the instance of the document was placed in the queue because the server was unable to encode this interchange.
rtdlqSigningFailure | 10 | Specifies that the instance of the document was placed in the queue because the server was unable to sign this interchange.
rtdlqEncryptionFailure | 11 | Specifies that the instance of the document was placed in the queue because the server was unable to encrypt this interchange.
rtdlqTransmissionFailure | 12 | Specifies that the instance of the document was placed in the queue because the server was unable to deliver this document.
rtdlqUserMove | 13 | Specifies that the administrator moved this instance of the document to the queue.
rtdlqTimeout | 14 | Specifies that the instance of the document was placed in the queue because a time-out occurred.
rtdlqCustomCompFailure | 15 | Specifies that the instance of the document was placed in the queue because of failure of a custom component.
unkReason | 16 | Specifies that this item was marked as "In process" by an inactive server. On restart of this server, this item was automatically moved to the Suspended queue. There was probably a catastrophic failure on the original server. Contact the system administrator for more information.
rtdlqNoChannel | 17 | Specifies that the instance of the document was placed in the queue because the BizTalkChannel object was deleted.
rtdlqMissingChannel | 18 | Specifies that the instance of the document was placed in the queue because the BizTalkChannel object specified by the Submit method of the IInterchange interface was not found.
rtdlqInvalidChannel | 19 | Specifies that the instance of the document was placed in the queue because the BizTalkChannel object specified by the Submit method of the IInterchange interface specifies an open BizTalkPort object. This is not permitted.
rtdlqOutOfMemory | 20 | Specifies that your computer has run out of memory. Rebooting is recommended.
rtdlqBTFRecReqExpired | 21 | Specifies that the document was placed in the queue because the BTF timestamp receiptRequiredBy expired.
rtdlqBTFExpiresAtExpired | 22 | Specifies that the document was placed in the queue because the BTF timestamp expiresAt expired.
rtdlqCorrelationFailure | 23 | Specifies that the document receipt failed.


Concepts

This section provides detailed conceptual information that is important to understand how to submit documents to Microsoft BizTalk Server 2000. The following topics are covered:

  • Submitting

  • Accessing the Suspended queue

  • Routing

  • Preprocessing Documents in a Receive Function

  • Steps for Submitting a Document by Using COM Interfaces


Submitting

All documents must be sent to Microsoft BizTalk Server 2000 by using the Submit or SubmitSync method of the IInterchange interface in order to be processed. If an application is Microsoft Windows–based and is capable of invoking methods on COM objects, it can submit a document directly. The business application calls the Submit or SubmitSync method of the IInterchange interface, passing in the document or the file path of the document as a string supplied as a parameter. This is the simplest approach because no additional configuration is necessary. However, this method requires that the business application be designed to support direct calls to BizTalk Server 2000.

If the application is not capable of invoking methods on COM objects, receive functions can be used to submit documents to BizTalk Server. Receive functions enable applications to post documents or interchanges to specific locations that BizTalk Server 2000 is monitoring. These locations are defined according to the specific receive function. Each receive function uses event-based monitoring to recognize the presence of a document or interchange. Once the data is received by the function, it submits the data to BizTalk Server 2000. For example, a file receive function can be configured to submit a document to BizTalk Server 2000 when the business application can save a document as a file but cannot submit it directly. For more information about adding and configuring receive functions, see Manage Receive Functions for a Server Group.

The receive functions are configured to continuously monitor a specific directory or queue for a file to appear and then be submitted to BizTalk Server 2000. HTTP and SMTP protocols are configured outside BizTalk Server 2000. You must create script pages for these transport services.

Notes

  • There is a size limit for interchanges and documents that use logging, which, if exceeded, greatly affects the performance of BizTalk Server. For more information about the size limit, see Interchange and document size limit.

  • A script or application that uses the IInterchange interface to submit documents to BizTalk Server can be run in any user account.

  • When processing envelopes that are compliant with BizTalk Framework 2.0, BizTalk Server 2000 should be considered the endpoint with regard to the expiration time. When BizTalk Framework 2.0-compliant documents are submitted to BizTalk Server 2000, either from an application or a trading partner, the following fields are overwritten if present, or created if absent:
    • In the properties subsection:

    <prop:identity>

    <prop:sentAt>

    <expiresAt>

    • In the receipt information subsection:

    <sendTo>

    <address>

    <sendReceiptBy>

For examples of code, see BizTalk Messaging Services Code Samples.

Sending documents to BizTalk Server 2000 asynchronously

Applications that submit documents asynchronously to BizTalk Server 2000 call Submit. Receive functions also call Submit. Submit returns after sending the document. No response document is returned, since the protocol does not support it.

Submit accepts only a string buffer or a file path as the document or interchange. BizTalk Server 2000 supports UNC and local file path formats.

Sending documents to BizTalk Server 2000 synchronously

Applications that submit documents synchronously to BizTalk Server 2000 call SubmitSync.

A synchronous interchange bypasses all queues and executes all the components required by the messaging port on the calling thread. For synchronous protocols, an optional response document is returned to the user, if available. This method is valid only for a single channel match. If the parameters set cause multiple channels to match, synchronous submission returns an error indicating that multiple channel matches are not allowed for synchronous submission. This method can be used only for single document interchanges. If the submission contains multiple documents, synchronous submission returns an error indicating that multiple document submissions are not allowed. This method does not support port groups.

SubmitSync accepts only a string buffer or a file path as the document or interchange. BizTalk Server 2000 supports UNC and local file path formats.

Error handling with the Submit and SubmitSync methods

When an error occurs when submitting interchanges or documents to BizTalk Server 2000, an event log entry is created and/or an error is returned to the caller, depending on which method is called and the nature of the failure. Documents submitted can end up in the Suspended queue due to a number of possible conditions. The following table describes what happens when one or more of the documents or interchanges submitted are placed in the Suspended queue due to an error during submission.

Method called | Error returned to caller | Event log entry
Submit | Document failure error | For every document that fails in processing
SubmitSync | Document failure error | None

Related Topics

Routing

Steps for Submitting a Document by Using COM Interfaces

Submitting Documents Reference


Accessing the Suspended queue

The Suspended queue contains work items that have failed processing for a variety of reasons, including parsing errors, serialization errors, failed transmissions, or the inability to find a channel configuration. You can retrieve or delete items from the queue using the interfaces provided.

Note

  • When accessing or deleting items in the Suspended queue, the script or application must be run in the context of a user account in the BizTalk Server Administrators group. The BizTalk Server Administrators group is created when BizTalk Server 2000 is installed. Additional users can be added to this group as necessary.

Retrieving items from the Suspended queue

To retrieve items from the Suspended queue, applications call the CheckSuspendedQueue method of the IInterchange interface.

CheckSuspendedQueue retrieves a list of items in the Suspended queue that meets the search criteria specified by the parameters of the method. This returns a list of handles that can subsequently be used to call the DeleteFromSuspendedQueue or the GetSuspendedQueueItemDetails method of the IInterchange interface.

Getting item details from the Suspended queue

CheckSuspendedQueue returns a list of handles to items in the Suspended queue. To process these items, you must get the item details associated with each item in the Suspended queue by using GetSuspendedQueueItemDetails.

GetSuspendedQueueItemDetails retrieves the details about an item in the Suspended queue. If this method does not return individual details about this item (because the item has been removed between the time CheckSuspendedQueue was called and the call to this method, for example), each parameter that cannot be determined is returned.

Removing items from the Suspended queue

To remove items from the Suspended queue, applications call DeleteFromSuspendedQueue.

DeleteFromSuspendedQueue removes a list of items from the Suspended queue that meets the search criteria specified by the parameters of the method.


Routing

To process a document, Microsoft BizTalk Server 2000 must load the rules that govern how the incoming document instance is to be processed. These rules are known as the channel. A specific BizTalkChannel object is associated with a BizTalkPort object and connects two organizations.

To find the channel to process the received document, the server must have the source organization, the destination organization, and the document definition. The server can obtain this information by one of the following methods:

  • This information can be found in the content of the document itself from the data contained in the routing fields (self-routing documents).

  • This information can be explicitly declared in the parameter list of the Submit method of the IInterchange interface (call-based routing).

  • This information can be explicitly declared in the properties of a custom receive function. For more information about receive functions, see Understanding Receive Functions and Document Routing.

  • You can choose to specify the channel to use when calling Submit. This causes the server to bypass the channel selection process.

Once the server has this information, it searches for the messaging port/channel pair that matches these routing criteria. If more than one channel matches, each of the channels is processed, possibly resulting in multiple output documents.

Call-based routing

In call-based routing, the source organization identifier (SourceID), the destination organization identifier (DestID), and the name of the document definition (DocName) are specified as parameters of Submit. If SourceQualifier and DestQualifier are not specified, they default to OrganizationName and refer to the name of the organization in the database. If a BizTalk Framework 2.0–compliant document is submitted and a qualifier is not found during parsing, the qualifier defaults to BizTalk. If the Openness flag is set to OpenDest, the DestID is used as the destination address. If SourceID, DestID, or DocName is left blank, the missing information must be provided by the routing information contained within the document. If one of these parameters/fields is not in Submit or in the document, the document goes to the Suspended queue.

Note

  • Note that the queue:// prefix must be used with an open messaging port when a Message Queue is specified as the destination address.

Self-routing documents

Self-routing documents have the source organization identifier (SourceID field), the destination organization identifier (DestID field), and the name of the document definition (DocName field) defined in the routing tags defined by the document specification, which are contained within the <SelectionFields> tag. If SourceQualifier and DestQualifier are not specified, they default to OrganizationName and refer to the name of the organization in the database. If a BizTalk Framework 2.0–compliant document is submitted and a qualifier is not found during parsing, the qualifier defaults to BizTalk. The BizTalk Framework specification also defines the routing tags for BizTalk Framework–compliant messages. These tags are defined as the <to> and <from> tags under the <route> tag, which is contained in the <header> tag under the root <biztalk> tag. The first tag under the <body> tag determines the document type. For more information, see the BizTalk Framework 2.0 Independent Document Messaging Specification. For X12 or EDIFACT routing, the locations of the routing fields are hard-coded and are not specified in a document specification.


Preprocessing Documents in a Receive Function

Documents can be submitted to BizTalk Server 2000 for processing by using a receive function. Using this mechanism, other applications can send their output files to a specified directory or message queue. BizTalk Server continually monitors the specified location at regular intervals and processes the files or messages placed in that location. BizTalk Server provides interfaces that allow you to create custom preprocessing components. These components process the file or message picked up by the receive function prior to submitting the data to BizTalk Server for processing.

A custom preprocessor component is required to implement the category identifier (CATID) CATID_BIZTALK_CUSTOM_PROCESS in the registry. This allows the BizTalk Server Administration user interface, or administration console, to recognize the custom preprocessor and display it in the Preprocessor list, where it can be selected.

For additional information, see IBTSCustomProcess and IBTSCustomProcessContext.

Related Topics

BizTalk Server Administration User Interface

Receive Functions


Steps for Submitting a Document by Using COM Interfaces

Use the following steps as a guideline when submitting documents to BizTalk Server with the IInterchange interface,

  1. Determine whether the source organization, destination organization, and document definition name are in the parameters of the Submit or the SubmitSync method of the IInterchange interface or are included in the document; it might be a combination of the two.
    • This information can be explicitly declared in the parameter list of Submit or SubmitSync (call-based routing).

      One or more of these parameters can be left blank and the missing information can be provided by the routing information contained within the document.

    • This information can be found in the content of the document itself from the data in the routing fields (self-routing documents).

    • The user can choose to explicitly call out the specific channel to use when calling Submit. This causes the server to bypass channel selection.

    • This information can be explicitly declared in the properties of a custom receive function.
  2. Decide whether to submit asynchronously or synchronously.
    • Call Submit, passing in the document or the file path of the document as a string supplied as a parameter. BizTalk Server 2000 supports URL, UNC, and drive: format for the file path.

      Submit accepts only a string variable as the document or interchange.

    • Call SubmitSync, passing in the document or the file path of the document as a string supplied as a parameter.
      • A response document is returned to the user, if available.

      • This method is valid only for a single channel match.

      • This method can be used only for single-document interchanges.
  3. Decide whether to call some of the Suspended queue methods. (This is optional and can be implemented in the same application or a different application.)
    • Call the CheckSuspendedQueue method of the IInterchange interface.
      • Retrieve items from the Suspended queue.

      • This returns a list of handles that can subsequently be used to call the DeleteFromSuspendedQueue or the GetSuspendedQueueItemDetails method of the IInterchange interface.
    • Call GetSuspendedQueueItemDetails.

      Retrieve the details about a particular item in the Suspended queue.

    • Call DeleteFromSuspendedQueue.

      Remove items from the Suspended queue.


Creating Custom Components

This section provides information about how to create custom components and extend Microsoft BizTalk Server 2000 to integrate line-of-business applications and add features such as encryption and decryption or digital signature. With this information, you can do the following:

  • Create application integration components (AICs) that enable your applications to receive business documents, using BizTalk Server 2000.

  • Extend the functionality of BizTalk Server 2000 by developing custom components to perform digital signature, encryption and decryption, parsing, serializing, and transport of documents.

For additional information, see the following sections:

  • For help with specific tasks, see How To.

  • For general background information, see Concepts.

  • For information about COM interfaces, see Creating Custom Components Reference.

  • For examples of code, see BizTalk Messaging Services Code Samples.


How To...

This section provides task-specific information about how to create server components. It is highly recommended that you review the Concepts in "Creating Custom Components" as well. The following topics are covered:

  • Creating Pipeline Components

  • Use the SAP R/3 AIC


Creating Pipeline Components

Use the following steps to create a pipeline component:

  1. Create an Active Template Library wizard–generated Inproc server project.

  2. Add a simple COM object.

  3. Go to the Projectname.idl file and remove the dual or custom interface generated by the wizard in step 2.

  4. Verify that the resulting IDL file looks like the code examples that follow. You might choose to implement your own set of interfaces from the ones defined in Pipecomp.idl.
    // SimplePipeComponent.idl : IDL source for SimplePipeComponent.dll
//
import "oaidl.idl";
import "ocidl.idl";
import "pipecomp.idl";

[
    uuid(D26A52F6-63A0-42B1-8C88-3C71C66BB189),
    version(1.0),
    helpstring("SimplePipeComponent 1.0 Type Library")
]
library SIMPLEPIPECOMPONENTLib
{
    importlib("stdole32.tlb");
    importlib("stdole2.tlb");
    [
        uuid(E66CAF06-18D8-4C70-9D39-5ED9756C21AD),
        helpstring("MySimplePipelineComponent Class")
    ]
    coclass MySimplePipelineComponent
    {
        [default] interface IPipelineComponentAdmin;
        interface IPipelineComponent;
        interface IPipelineComponentDescription;
    };
};
  5. One of the implementations of MySimplePipelineComponent [coclass] is defined in the header file as follows:
    // MySimplePipelineComponent.h : Declaration of the
// CMySimplePipelineComponent

#ifndef __MYSIMPLEPIPELINECOMPONENT_H_
#define __MYSIMPLEPIPELINECOMPONENT_H_

#include "resource.h"       // main symbols

/////////////////////////////////////////////////////////////////////////////
// CMySimplePipelineComponent
class ATL_NO_VTABLE CMySimplePipelineComponent :
    public CComObjectRootEx<CComSingleThreadModel>,
    public CComCoClass<CMySimplePipelineComponent, &CLSID_MySimplePipelineComponent>,
    public ISupportErrorInfo,
    public IDispatchImpl<IPipelineComponentAdmin, &IID_IPipelineComponentAdmin, &LIBID_SIMPLEPIPECOMPONENTLib>,
    public IDispatchImpl<IPipelineComponent, &IID_IPipelineComponent, &LIBID_SIMPLEPIPECOMPONENTLib>,
    public IDispatchImpl<IPipelineComponentDescription, &IID_IPipelineComponentDescription, &LIBID_SIMPLEPIPECOMPONENTLib>
{
public:
    CMySimplePipelineComponent()
    {
    }

DECLARE_REGISTRY_RESOURCEID(IDR_MYSIMPLEPIPELINECOMPONENT)

DECLARE_PROTECT_FINAL_CONSTRUCT()

BEGIN_COM_MAP(CMySimplePipelineComponent)
    COM_INTERFACE_ENTRY2(IDispatch,IPipelineComponentAdmin)
    COM_INTERFACE_ENTRY(IPipelineComponentAdmin)
    COM_INTERFACE_ENTRY(IPipelineComponent)
    COM_INTERFACE_ENTRY(IPipelineComponentDescription)
    COM_INTERFACE_ENTRY(ISupportErrorInfo)
END_COM_MAP()

// ISupportsErrorInfo
    STDMETHOD(InterfaceSupportsErrorInfo)(REFIID riid);

public://IPipelineComponentAdmin
    STDMETHODIMP GetConfigData(IDispatch** ppDict );
    STDMETHODIMP SetConfigData(IDispatch* pDict );

public://IPipelineComponent
    STDMETHODIMP Execute(IDispatch*  pdispObject,IDispatch*  pdispContext,LONG lFlags,LONG* plErrorLevel);
    STDMETHODIMP EnableDesign(BOOL fEnable);
public: //IPipelineComponentDescription
    STDMETHODIMP ValuesRead(VARIANT* pvar);
    STDMETHODIMP ValuesWritten(VARIANT* pvar);
    STDMETHODIMP ContextValuesRead(VARIANT* pvar);

};

#endif //__MYSIMPLEPIPELINECOMPONENT_H_

Related Topics

Creating Application Integration Components

IPipelineComponent

IPipelineComponentAdmin


Use the SAP R/3 AIC

To use the Systems, Applications, and Products in Data Processing (SAP) AIC, do the following:

Install the DCOM connector

  1. Download the SAP Remote Function Call SDK (www.sap.com/bapi).
    • Go to the COM section and click the DCOM Component Connector.

    • Follow the instructions from the File Download wizard.
  2. Run the image, and unzip it to add the Rfcsdk subdirectories to the client computer.

  3. Install the DCOM connector.

  4. Follow the installation instructions from the \Rfcsdk\Ccwww subdirectory Install page.

  5. Once the connector is installed, create a destination, entering information for the following:
    • Destination name

    • Application server

    • Server number

    • Client

    • Language

    • User

    • Password

Enter the destination name in BizTalk Messaging Manager

This is the destination name chosen during SAP DCOM connector configuration. For more information, see Select a destination organization.

Create a COM+ server package

  1. Create a COM+ server package.

  2. Mark it as Transactions Not Supported.

  3. Add AICOMP.dll to this package.


Creating Custom Components Reference

This section provides reference information about components and interfaces used by Microsoft BizTalk Server 2000 for both C++ and Visual Basic programming. Reference information is provided for all interfaces exposed for extending BizTalk Server 2000.

The following COM interfaces are documented in this reference for C++ developers:

  • IBizTalkParserComponent

  • IBizTalkSerializerComponent

The following COM interfaces and enumerations are documented in this reference for C++ and Visual Basic developers:

  • IBizTalkAcknowledge

  • IBizTalkCorrelation

  • IBTSAppIntegration

  • IFunctoid

  • IPipelineComponent

  • IPipelineComponentAdmin

  • ISchemaImporter

  • ISchemaImporterError

  • ISchemaImporterErrorProvider

  • Receipt Enumerations

  • Functoid Enumerations


IBizTalkAcknowledge Interface [C++]

IBizTalkAcknowledge Object [Visual Basic]

Use this object to process receipts sent to the server.

In C++, use the IBizTalkAcknowledge interface to access the methods of the BizTalkAcknowledge object.

The methods of the BizTalkAcknowledge object are shown in the following table.

Method | Description
AckDocument | Processes receipts received for documents.
AckGroup | Processes receipts received for document groups.
AckInterchange | Processes receipts received for document interchanges.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BTSDocTracking.h
Library: Use Microsoft BizTalk Server Doc Tracking 1.0 Type Library (CISDTA.dll)

Related Topics

Creating Receipt Correlator Components

How Receipts Are Logged

Understanding Receipts


IBizTalkAcknowledge::AckDocument Method [C++]

IBizTalkAcknowledge.AckDocument Method [Visual Basic]

The AckDocument method processes receipts for documents.

Syntax

[C++]

HRESULT AckDocument(
    BSTR bstrSyntax,
    BSTR bstrTrackingId,
    DTA_ACK_STATUS enumAckStatus
);

[Visual Basic]

object.AckDocument( _
    bstrSyntax As String, _
    bstrTrackingId As String, _
    enumAckStatus As DTA_ACK_STATUS _
)

Parameters

[C++]

bstrSyntax

[in] BSTR that contains the syntax of the outbound document to be acknowledged, for example, X12 or EDIFACT.

bstrTrackingId

[in] BSTR that contains the unique tracking identifier of the document. This value is a globally unique identifier (GUID). This value can be obtained from the Tracking_ID field in the dta_outdoc_details table. For more information, see Supporting the Tracking Database with Parser and Serializer Components.

enumAckStatus

[in] Enumeration value that indicates the receipt status. Valid values are from the DTA_ACK_STATUS enumeration.

[Visual Basic]

bstrSyntax

String that contains the syntax of the outbound document to be acknowledged, for example, X12 or EDIFACT.

bstrTrackingId

String that contains the unique tracking identifier of the document. This value is a globally unique identifier (GUID). This value can be obtained from the Tracking_ID field in the dta_outdoc_details table. For more information, see Supporting the Tracking Database with Parser and Serializer Components.

enumAckStatus

Enumeration value that indicates the receipt status. Valid values are from the DTA_ACK_STATUS enumeration.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This method is called only for receipts on individual documents. If the receipt needs to be mapped, a document definition that points to CanonicalReceipt.xml shipped in WebDAV must be created for the receipt.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BTSDocTracking.h
Library: Use Microsoft BizTalk Server Doc Tracking 1.0 Type Library (CISDTA.dll)


IBizTalkAcknowledge::AckGroup Method [C++]

IBizTalkAcknowledge.AckGroup Method [Visual Basic]

The AckGroup method processes receipts for document groups.

Syntax

[C++]

HRESULT AckGroup(
    BSTR bstrSyntax,
    BSTR bstrVersion,
    BSTR bstrRelease,
    BSTR bstrFunctionalGroupId,
    BSTR bstrControlId,
    BSTR bstrSrcAppName,
    BSTR bstrDestAppName,
    DTA_ACK_STATUS enumAckStatus
);

[Visual Basic]

object.AckGroup( _
    bstrSyntax As String, _
    bstrVersion As String, _
    bstrRelease As String, _
    bstrFunctionalGroupId As String, _
    bstrControlId As String, _
    bstrSrcAppName As String, _
    bstrDestAppName As String, _
    enumAckStatus As DTA_ACK_STATUS _
)

Parameters

[C++]

bstrSyntax

[in] BSTR that contains the syntax of the outbound document to be acknowledged, for example, X12 or EDIFACT. You must use the exact strings for the following syntax types:

  • X12

  • EDIFACT

  • Custom XML

bstrVersion

[in] BSTR that contains the version of the syntax, used primarily for EDI.

bstrRelease

[in] BSTR that contains the release of the version of the syntax, used primarily for EDI.

bstrFunctionalGroupId

[in] BSTR that contains the code for the type of documents in a group, used primarily for EDI.

bstrControlId

[in] BSTR that contains the unique identifier for the control number, used primarily for EDI.

bstrSrcAppName

[in] BSTR that contains the name of the source application.

bstrDestAppName

[in] BSTR that contains the name of the destination application.

enumAckStatus

[in] Enumeration value that indicates the receipt status. Valid values are from the DTA_ACK_STATUS enumeration.

[Visual Basic]

bstrSyntax

String that contains the syntax of the outbound document to be acknowledged, for example, X12 or EDIFACT. You must use the exact strings for the following syntax types:

  • X12

  • EDIFACT

  • Custom XML

bstrVersion

String that contains the version of the syntax, used primarily for EDI.

bstrRelease

String that contains the release of the version of the syntax, used primarily for EDI.

bstrFunctionalGroupId

String that contains the code for the type of documents in a group, used primarily for EDI.

bstrControlId

String that contains the unique identifier for the control number, used primarily for EDI.

bstrSrcAppName

String that contains the name of the source application.

bstrDestAppName

String that contains the name of the destination application.

enumAckStatus

Enumeration value that indicates the receipt status. Valid values are from the DTA_ACK_STATUS enumeration.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This method is called only for receipts on document groups.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BTSDocTracking.h
Library: Use Microsoft BizTalk Server Doc Tracking 1.0 Type Library (CISDTA.dll)


IBizTalkAcknowledge::AckInterchange Method [C++]

IBizTalkAcknowledge.AckInterchange Method [Visual Basic]

The AckInterchange method processes receipts for document interchanges.

Syntax

[C++]

HRESULT AckInterchange(
    BSTR bstrSyntax,
    BSTR bstrInterchangeId,
    BSTR bstrVersion,
    BSTR bstrControlId,
    BSTR bstrSrcAliasQualifier,
    BSTR bstrSrcAliasId,
    BSTR bstrSrcAppName,
    BSTR bstrDestAliasQualifier,
    BSTR bstrDestAliasId,
    BSTR bstrDestAppName,
    DTA_ACK_STATUS enumAckStatus
);

[Visual Basic]

object.AckInterchange( _
    bstrSyntax As String, _
    bstrInterchangeId As String, _
    bstrVersion As String, _
    bstrControlId As String, _
    bstrSrcAliasQualifier As String, _
    bstrSrcAliasId As String, _
    bstrSrcAppName As String, _
    bstrDestAliasQualifier As String, _
    bstrDestAliasId As String, _
    bstrDestAppName As String, _
    enumAckStatus As DTA_ACK_STATUS _
)

Parameters

[C++]

bstrSyntax

[in] BSTR that contains the syntax of the outbound document to be acknowledged, for example, X12 or EDIFACT. You must use the exact strings for the following syntax types:

  • X12

  • EDIFACT

  • Custom XML

bstrInterchangeId

[in] BSTR that contains the unique tracking identifier of the interchange. This value is a globally unique identifier (GUID).

bstrVersion

[in] BSTR that contains the version of the syntax, used primarily for EDI.

bstrControlId

[in] BSTR that contains the unique identifier for the control number, used primarily for EDI.

bstrSrcAliasQualifier

[in] BSTR that contains the qualifier of the source organization. This indicates how the bstrSrcAliasID parameter is to be interpreted. Valid values come from the organization identifier qualifiers that are created when the user creates an alias for an organization. Common qualifiers include the DUNS number, telephone number, and BizTalk. The default qualifier for all new organizations is Organization Name and refers to the name of the organization in the database. If a BizTalk Framework 2.0–compliant document is submitted and a qualifier is not found during parsing, the qualifier defaults to BizTalk.

bstrSrcAliasId

[in] BSTR that contains the value of the qualifier of the source organization. For example, if the bstrSrcAliasQualifier parameter is Telephone, this value is the telephone number.

bstrSrcAppName

[in] BSTR that contains the name of the source application.

bstrDestAliasQualifier

[in] BSTR that contains the qualifier of the source organization. This indicates how the bstrDestAliasID parameter is to be interpreted. Valid values come from the organization identifier qualifiers that are created when the user creates an alias for an organization. Common qualifiers include the DUNS number, telephone number, and BizTalk. The default qualifier for all new organizations is Organization Name and refers to the name of the organization in the database. If a BizTalk Framework 2.0–compliant document is submitted and a qualifier is not found during parsing, the qualifier defaults to BizTalk.

bstrDestAliasId

[in] BSTR that contains the value of the qualifier of the source organization. For example, if the bstrDestAliasQualifier parameter is Telephone, this value is the telephone number.

bstrDestAppName

[in] BSTR that contains the name of the destination application.

enumAckStatus

[in] Enumeration value that indicates the receipt status. Valid values are from the DTA_ACK_STATUS enumeration.

[Visual Basic]

bstrSyntax

String that contains the syntax of the outbound document to be acknowledged, for example, X12 or EDIFACT. You must use the exact strings for the following syntax types:

  • X12

  • EDIFACT

  • Custom XML

bstrInterchangeId

String that contains the unique tracking identifier of the interchange. This value is a globally unique identifier (GUID).

bstrVersion

String that contains the version of the syntax, used primarily for EDI.

bstrControlId

String that contains the unique identifier for the control number, used primarily for EDI.

bstrSrcAliasQualifier

String that contains the qualifier of the source organization. This indicates how the bstrSrcAliasID parameter is to be interpreted. Valid values come from the organization identifier qualifiers that are created when the user creates an alias for an organization. Common qualifiers include the DUNS number, telephone number, and BizTalk. The default qualifier for all new organizations is Organization Name and refers to the name of the organization in the database. If a BizTalk Framework 2.0–compliant document is submitted and a qualifier is not found during parsing, the qualifier defaults to BizTalk.

bstrSrcAliasId

String that contains the value of the qualifier of the source organization. For example, if the bstrSrcAliasQualifier parameter is Telephone, this value is the telephone number.

bstrSrcAppName

String that contains the name of the source application.

bstrDestAliasQualifier

String that contains the qualifier of the source organization. This indicates how the bstrDestAliasID parameter is to be interpreted. Valid values come from the organization identifier qualifiers that are created when the user creates an alias for an organization. Common qualifiers include the DUNS number, telephone number, and BizTalk. The default qualifier for all new organizations is Organization Name and refers to the name of the organization in the database. If a BizTalk Framework 2.0–compliant document is submitted and a qualifier is not found during parsing, the qualifier defaults to BizTalk.

bstrDestAliasId

String that contains the value of the qualifier of the source organization. For example, if the bstrDestAliasQualifier parameter is Telephone, this value is the telephone number.

bstrDestAppName

String that contains the name of the destination application.

enumAckStatus

Enumeration value that indicates the receipt status. Valid values are from the DTA_ACK_STATUS enumeration.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This method is called only for receipts on document interchanges.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BTSDocTracking.h
Library: Use Microsoft BizTalk Server Doc Tracking 1.0 Type Library (CISDTA.dll)


IBizTalkCorrelation Interface

Implement IBizTalkCorrelation to create receipt correlator components.

The method of the BizTalkCorrelation object is shown in the following table.

Method | Description
Correlate | Extracts all relevant information from the document, document group, or interchange.

Note

  • This interface is not available in Microsoft Visual Basic.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BTSParserComps.h

Related Topic

Creating Receipt Correlator Components


IBizTalkCorrelation::Correlate Method

The Correlate method extracts all relevant information from the document, document group, or interchange.

Syntax

[C++]

HRESULT Correlate(
    IUnknown* Acknowledge,
    IDictionary* Dict
);

[Visual Basic]

This method is not available in Microsoft Visual Basic.

Parameters

[C++]

Acknowledge

[in] Pointer to the IBizTalkAcknowledge interface to invoke and set the receipt flag.

Dict

[in] Pointer to an IDictionary interface of an object that contains the receipt information.

[Visual Basic]

Not applicable

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

Not applicable

Requirements

[C++]

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BTSParserComps.h

[Visual Basic]

Not applicable


IFunctoid Interface [C++]

CannedFunctoid Object [Visual Basic]

In C++, implement IFunctoid to create custom mapping functions. IFunctoid defines the generic protocol for calling custom functions used by the mapping tool.

In Microsoft Visual Basic, implement CannedFunctoid to create custom mapping functions. CannedFunctoid defines the generic protocol for calling custom functions used by the mapping tool.

This object must register its class identifier (CLSID) under a well-known category identifier (CATID) of the function objects enumerated by the mapping tool. The CATID is {2560F3BF-DB47-11D2-B3AE-00C04F72D6C1}. Each custom object can support multiple functions and can contain icons and names for each supported function.

Function identifiers from 0 to 1000 are reserved for built-in functions in the BizTalk Mapper. User-defined functions (custom functions) should use function identifiers 1001 and above.

The properties of the CannedFunctoid object are shown in the following table.

Property | Description
FunctionsCount | Returns the number of functions implemented by the functoid.
Version | Returns the version of the functoid.

The methods of the CannedFunctoid object are shown in the following table.

Method | Description
GetFunctionParameter | Retrieves the connection-type bit flags for the specified parameter.
GetFunctionDescripter | Retrieves information about a specific functoid.
GetScriptBuffer | Retrieves the script code used to implement the functoid.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include CannedFunctoid.h
Library: Use Microsoft BizTalk Server Canned Functoids 1.0 Type Library (CannedFunctoid.dll)


IFunctoid::FunctionsCount Property [C++]

CannedFunctoid.FunctionsCount Property [Visual Basic]

The FunctionsCount property returns the number of functions implemented by the functoid.

Syntax

[C++]

HRESULT get_FunctionsCount(
    long* plCount
);

[Visual Basic]

object.FunctionsCount

Parameters

[C++]

plCount

[out, retval] Pointer to a long that contains the number of functions implemented by the functoid.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a Long that contains the number of functions implemented by the functoid.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include CannedFunctoid.h
Library: Use Microsoft BizTalk Server Canned Functoids 1.0 Type Library (CannedFunctoid.dll)


IFunctoid::GetFunctionDescripter Method [C++]

CannedFunctoid.GetFunctionDescripter Method [Visual Basic]

The GetFunctionDescripter method retrieves information about a specific functoid.

Syntax

[C++]

HRESULT GetFunctionDescripter(
    long lIndex,
    FUNC_CATEGORY* pFuncCategory,
    SCRIPT_CATEGORY* pScriptCategory,
    FUNC_TYPE* pFuncType,
    BSTR* pbstrName,
    BSTR* pbstrToolTip,
    long* plBitmapID,
    long* plParmCount,
    FUNCID* pFuncId
);

[Visual Basic]

object.GetFunctionDescripter( _
    lIndex As Long, _
    pFuncCategory As FUNC_CATEGORY, _
    pScriptCategory As SCRIPT_CATEGORY, _
    pFuncType As FUNC_TYPE, _
    pbstrName As String, _
    pbstrToolTip As String, _
    plBitmapID As Long, _
    plParmCount As Long _
)

Parameters

[C++]

lIndex

[in] Long that specifies the index number of the function.

pFuncCategory

[in, out] Pointer to a value that contains the FUNC_CATEGORY bit flags for this function.

pScriptCategory

[in, out] Pointer to a value that contains the SCRIPT_CATEGORY bit flags for this function. This value must be set to SCRIPT_CATEGORY_VBSCRIPT for this release.

pFuncType

[in, out] Pointer to a value that contains the FUNC_TYPE bit flags for this function.

pbstrName

[in, out] Pointer to a BSTR that contains the function name.

pbstrToolTip

[in, out] Pointer to a BSTR that contains the ToolTip that appears when the mouse pointer is paused over the custom functoid icon in the mapping tool.

plBitmapID

[in, out] Pointer to the long bitmap identifier of the bitmap used for the custom functoid icon displayed in the mapping tool.

plParmCount

[in, out] Pointer to a long that contains the number of parameters implemented by the function.

pFuncId

[out, retval] Pointer to a long that contains the function identifier.

[Visual Basic]

lIndex

Long that specifies the index number of the function.

pFuncCategory

Value that contains the FUNC_CATEGORY bit flags for this function.

pScriptCategory

Value that contains the SCRIPT_CATEGORY bit flags for this function. This value must be set to SCRIPT_CATEGORY_VBSCRIPT for this release.

pFuncType

Value that contains the FUNC_TYPE bit flags for this function.

pbstrName

String that contains the function name.

pbstrToolTip

String that contains the ToolTip that appears when the mouse pointer is paused over the custom functoid icon in the mapping tool.

plBitmapID

Long that contains the bitmap identifier of the bitmap used for the custom functoid icon displayed in the mapping tool.

plParmCount

Long that contains the number of parameters implemented by the function.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This method returns a Long that contains the function identifier.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include CannedFunctoid.h
Library: Use Microsoft BizTalk Server Canned Functoids 1.0 Type Library (CannedFunctoid.dll)


IFunctoid::GetFunctionParameter Method [C++]

CannedFunctoid.GetFunctionParameter Method [Visual Basic]

The GetFunctionParameter method retrieves the connection-type bit flags for the specified parameter.

Syntax

[C++]

HRESULT GetFunctionParameter(
    FUNCID funcId,
    long lParameter,
    long* plConnectionType
);

[Visual Basic]

object.GetFunctionParameter( _
    funcId As FUNCID, _
    lParameter As Long _
)

Parameters

[C++]

funcId

[in] Long that contains the function identifier.

lParameter

[in] Long that contains the function parameter number. For output parameters, a value of -1 is used.

plConnectionType

[out, retval] Pointer to a long that contains the CONNECTION_TYPE bit flags for the specified parameter.

[Visual Basic]

funcId

Long that contains the function identifier.

lParameter

Long that contains the function parameter number. For output parameters, a value of -1 is used.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This method returns a Long that contains the CONNECTION_TYPE bit flags for the specified parameter.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include CannedFunctoid.h
Library: Use Microsoft BizTalk Server Canned Functoids 1.0 Type Library (CannedFunctoid.dll)


IFunctoid::GetScriptBuffer Method [C++]

CannedFunctoid.GetScriptBuffer Method [Visual Basic]

The GetScriptBuffer method retrieves the script code used to implement the functoid.

Syntax

[C++]

Get method:

HRESULT GetScriptBuffer(
    FUNCID cFuncId,
    long lInputParameters,
    BSTR* pbstrScriptBuffer
);

[Visual Basic]

object.GetScriptBuffer( _
    cFuncId As FUNCID, _
    lInputParameters As Long _
)

Parameters

[C++]

cFuncId

[in] Long that contains the function identifier.

lInputParameters

[in] Long that indicates the number of connected input parameters for the specified function.

pbstrScriptBuffer

[out, retval] Pointer to a BSTR that contains the script code used to implement the function.

[Visual Basic]

cFuncId

Long that contains the function identifier.

lInputParameters

Long that indicates the number of connected input parameters for the specified function.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This method returns a String that contains the script code used to implement the function.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include CannedFunctoid.h
Library: Use Microsoft BizTalk Server Canned Functoids 1.0 Type Library (CannedFunctoid.dll)


IFunctoid::Version Property [C++]

CannedFunctoid.Version Property [Visual Basic]

The Version property returns the version of the functoid.

Syntax

[C++]

HRESULT get_Version(
    long* pVersion
);

[Visual Basic]

object.Version

Parameters

[C++]

pVersion

[out, retval] Pointer to a long that contains the custom functoid version.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a Long that contains the custom functoid version.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property.

If the custom functoid is modified in any way, the author should update the version number.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include CannedFunctoid.h
Library: Use Microsoft BizTalk Server Canned Functoids 1.0 Type Library (CannedFunctoid.dll)


IBizTalkParserComponent Interface

Use this object to convert a document to XML for later processing and to identify the BizTalkChannel objects necessary to process the documents.

In C++, use the IBizTalkParserComponent interface to access the methods of the BizTalkParserComponent object.

The methods of the BizTalkParserComponent object are shown in the following table.

Method | Description
GetGroupDetails | Gets details of the group for the Tracking database. This method is called only if there are groups in the interchange.
GetGroupSize | Gets the size of the group after all documents in the group are parsed. This method is called only if there are groups in the interchange.
GetInterchangeDetails | Gets information about the organization identifiers of the source and destination BizTalkOrganization objects.
GetNativeDocumentOffsets | Identifies offsets from the beginning of the stream for final details about the group in the Tracking database for final logging.
GetNextDocument | Examines the data in a document and determines when to get the next document if this is not the last document.
GroupsExist | Determines if the interchange contains groups.
ProbeInterchangeFormat | Identifies the format of the interchange.

Remarks

Application integration components must be properly registered so that BizTalk Server 2000 can recognize that they belong to BizTalk Server 2000. Application integration components register themselves with the category ID CATID_BIZTALK_AIC. The CATIDs are defined in the bts_sdk_guids.h file. For more information, see Registering Application Integration Components.

Note

  • This interface is not available in Microsoft Visual Basic.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BTSParserComps.h

Related Topics

Identification

Sequence for Calling Methods of the IBizTalkParserComponent Interface

Using the IBizTalkParserComponent Interface


IBizTalkParserComponent::GetGroupDetails Method

[C++]

The GetGroupDetails method gets details of the group for the Tracking database.

[Visual Basic]

This method is not available in Microsoft Visual Basic.

Syntax

[C++]

HRESULT GetGroupDetails(
    IDictionary* Dict
);

[Visual Basic]

Not applicable

Parameters

[C++]

Dict

[in] Pointer to an IDictionary interface of an object that contains details about the group. All information is returned as string types, no matter how it appears in the data.

[Visual Basic]

Not applicable

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

Not applicable

Remarks

[C++]

This method is called only if groups are detected in the interchange.

[Visual Basic]

Not applicable

Requirements

[C++]

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BTSParserComps.h

[Visual Basic]

Not applicable

Related Topics

Sequence for Calling Methods of the IBizTalkParserComponent Interface

Using the IBizTalkParserComponent Interface


IBizTalkParserComponent::GetGroupSize Method

[C++]

The GetGroupSize method gets the size of the group after all documents in the group are parsed.

[Visual Basic]

This method is not available in Microsoft Visual Basic.

Syntax

[C++]

HRESULT GetGroupSize(
    long* GroupSize,
    BOOL* LastGroup
);

[Visual Basic]

Not applicable

Parameters

[C++]

GroupSize

[out] Pointer to a long that contains the size of the interchange.

LastGroup

[out] Pointer to a Boolean value that indicates whether the group is the last group in the interchange. If this parameter is set to TRUE, the next method called is GetGroupDetails for the next group in the data. If it is set to FALSE, the component is finished. When it is released, it leaves the IStream interface after the last byte it has read.

[Visual Basic]

Not applicable

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

Not applicable

Remarks

[C++]

After all documents in the group are called, the final details about the group are required. Both output parameters are added to the Tracking database for final logging.

This method is called only if there are groups in the interchange.

[Visual Basic]

Not applicable

Requirements

[C++]

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BTSParserComps.h

[Visual Basic]

Not applicable

Related Topics

Sequence for Calling Methods of the IBizTalkParserComponent Interface

Using the IBizTalkParserComponent Interface


IBizTalkParserComponent::GetInterchangeDetails Method

[C++]

The GetInterchangeDetails method gets information about the organization identifiers of the source and destination BizTalkOrganization objects.

[Visual Basic]

This method is not available in Microsoft Visual Basic.

Syntax

[C++]

HRESULT GetInterchangeDetails(
    IDictionary* Dict
);

[Visual Basic]

Not applicable

Parameters

[C++]

Dict

[in] Pointer to an IDictionary interface of an object that contains information about the organization identifiers of the source and destination BizTalkOrganization objects.

[Visual Basic]

Not applicable

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

Not applicable

Remarks

[C++]

The minimum sets of fields are:

Field | Description
src_id_type | Source qualifier
src_id_value | Source ID
dest_id_type | Destination qualifier
dest_id_value | Destination ID

The parameters of the Submit method of the IInterchange interface override any fields set here.

[Visual Basic]

Not applicable

Requirements

[C++]

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BTSParserComps.h

[Visual Basic]

Not applicable

Related Topics

Sequence for Calling Methods of the IBizTalkParserComponent Interface

Using the IBizTalkParserComponent Interface


IBizTalkParserComponent::GetNativeDocumentOffsets Method

[C++]

The GetNativeDocumentOffsets method identifies offsets from the beginning of the stream for final details about the group in the Tracking database for final logging.

[Visual Basic]

This method is not available in Microsoft Visual Basic.

Syntax

[C++]

HRESULT GetNativeDocumentOffsets(
    BOOL SizeFromXMLDoc,
    LARGE_INTEGER* StartOffset,
    long* DocLength
);

[Visual Basic]

Not applicable

Parameters

[C++]

SizeFromXMLDoc

[out] Boolean value that indicates the XML document passed in from the GetNextDocument method was used to determine the size. If this parameter is TRUE, the server fills in the StartOffset and DocLength values for the document just parsed. If this parameter is FALSE, the server ignores the values in StartOffset and DocLength.

StartOffset

[out] Pointer to a LARGE_INTEGER that contains the location of the beginning of the document. This parameter is returned if the SizeFromXMLDoc parameter is set to TRUE.

DocLength

[out] Pointer to a long that contains the length of the document. This parameter is returned if the SizeFromXMLDoc parameter is set to TRUE.

[Visual Basic]

Not applicable

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

Not applicable

Remarks

[C++]

This method is called immediately after GetNextDocument whether or not the document is valid (as long as the parser does not return an error value). These are offsets into the IStream object relative to the beginning of the stream, not the beginning of the interchange.

[Visual Basic]

Not applicable

Requirements

[C++]

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BTSParserComps.h

[Visual Basic]

Not applicable

Related Topics

Sequence for Calling Methods of the IBizTalkParserComponent Interface

Using the IBizTalkParserComponent Interface


IBizTalkParserComponent::GetNextDocument Method

[C++]

The GetNextDocument method examines the data in a document and determines when to get the next document, if this is not the last document.

[Visual Basic]

This method is not available in Microsoft Visual Basic.

Syntax

[C++]

HRESULT GetNextDocument(
    IDictionary* Dict,
    BSTR DocSpecName,
    BOOL* DocIsValid,
    BOOL* LastDocument,
    GeneratedReceiptLevel ReceiptGenerated,
    BOOL* DocIsReceipt,
    BSTR* CorrelationCompProgID
);

[Visual Basic]

Not applicable

Parameters

[C++]

Dict

[in] Pointer to an IDictionary interface of an object into which to set the XML instance created on parsing the current document. The parsed XML document is placed into the working_data field of the dictionary.

DocSpecName

[in] BSTR that contains the name of the BizTalk document specification used to generate the XML from the document's native format.

DocIsValid

[out] Pointer to a Boolean value that indicates whether the document instance is valid. If it is invalid but the parser can recover from it, set this parameter to FALSE. This parameter and the LastDocument parameter are independent. Therefore, if there are no more documents and the last one is invalid, both flags are set. If the document is invalid and the parser cannot continue, it might return an error value. The server then stops at the current position of the IStream pointer. The component places the invalid data (if the parser can recover) in the working_data field for inspection by the system administrator if the document is invalid.

LastDocument

[out] Pointer to a Boolean value that indicates whether this is the last document instance in the group or interchange. When the last document is found, the LastDocument flag is set to TRUE. If there are groups, this flag signals the last document in the group, and the GetGroupSize method is called. If there are no groups, this is the last call to get document data from the parser, and the IStream pointer is set appropriately.

ReceiptGenerated

Enumeration value. Valid values are from the GeneratedReceiptLevel enumeration.

DocIsReceipt

[out] Pointer to Boolean value that identifies whether or not this document is a receipt.

CorrelationCompProgID

[out] Pointer to a BSTR that contains the program ID for the correlation of documents.

[Visual Basic]

Not applicable

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

Not applicable

Requirements

[C++]

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BTSParserComps.h

[Visual Basic]

Not applicable

Related Topics

Sequence for Calling Methods of the IBizTalkParserComponent Interface

Using the IBizTalkParserComponent Interface


IBizTalkParserComponent::GroupsExist Method

[C++]

The GroupsExist method determines whether the interchange contains groups.

[Visual Basic]

This method is not available in Microsoft Visual Basic.

Syntax

[C++]

HRESULT GroupsExist(
    BOOL* GrpsExist
);

[Visual Basic]

Not applicable

Parameters

[C++]

GrpsExist

[out, retval] Pointer to a Boolean value that indicates whether the data format contains groups. If this parameter is set to FALSE, the GetGroupDetails and GetGroupSize methods are never called.

[Visual Basic]

Not applicable

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

Not applicable

Requirements

[C++]

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BTSParserComps.h

[Visual Basic]

Not applicable

Related Topics

Sequence for Calling Methods of the IBizTalkParserComponent Interface

Using the IBizTalkParserComponent Interface


IBizTalkParserComponent::ProbeInterchangeFormat Method

[C++]

The ProbeInterchangeFormat method identifies the format of the interchange.

[Visual Basic]

This method is not available in Microsoft Visual Basic.

Syntax

[C++]

HRESULT ProbeInterchangeFormat(
    IStream* pData,
    BOOL FromFile,
    BSTR EnvName,
    IStream* pReceiptData,
    BSTR* Format
);

[Visual Basic]

Not applicable

Parameters

[C++]

pData

[in] Pointer to the IStream object that contains the data for the document interchange. Additional information about the IStream object is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

FromFile

[in] Boolean value. TRUE indicates that the data came from the file referred to by the FilePath parameter of the Submit or the SubmitSync method of the IInterchange interface. FALSE indicates that the data came from the Document parameter of Submit or SubmitSync as a string. If the data is from a file, no conversion is made. If the data is a string, you can use UNICODE/MBCS techniques to understand it.

EnvName

[in] BSTR that contains the name of the envelope.

pReceiptData

[in] Pointer to the IStream object that contains the receipt document.

Format

[out] Pointer to a BSTR that contains the format. If the server recognizes the format, it must fill in this parameter with a nonempty string and hold on to (add a reference count to) the IStream interface because it is not given back to the component. This IStream object is read-only; it supports only the Read, Stat, and Seek methods. All other methods return E_NOTIMPL. This method should not return a failure if it does not recognize the format. It returns S_FALSE or an empty or NULL Format string. If you do not recognize the format, you do not need to move the IStream pointer back to its original position; the server resets the IStream pointer. Unless your format requires it, do not assume that the pointer is at the beginning. The pointer can be somewhere in the middle during the probing stage.

[Visual Basic]

Not applicable

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

Not applicable

Remarks

[C++]

This is the first method that is called by the server. If ProbeInterchangeFormat returns an error in the middle of the document list, it blocks the server from detecting more document types, even if they could be handled by a custom parser that follows the failed parser, if there are two or more custom parsers on a server. If the first custom parser fails, any document that follows is not parsed, even if the other custom parser could handle it, because the server ends the entire parsing operation at the time of the failure.

[Visual Basic]

Not applicable

Requirements

[C++]

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BTSParserComps.h

[Visual Basic]

Not applicable

Related Topics

Sequence for Calling Methods of the IBizTalkParserComponent Interface

Using the IBizTalkParserComponent Interface


IBizTalkSerializerComponent Interface

Use this object to convert a document from XML to the document's original native format.

In C++, use the IBizTalkSerializerComponent interface to access the methods of the BizTalkSerializerComponent object.

The methods of the BizTalkSerializerComponent object are shown in the following table.

Method | Description
AddDocument | Adds an XML document for storage by the serializer component.
GetDocInfo | Gets details of the document.
GetGroupInfo | Gets details of the group, such as size and offset, for the Tracking database.
GetInterchangeInfo | Gets information about the interchange created.
Init | Outputs the document instance to the serializer component and indicates where it should be sent.

Remarks

Application integration components must be properly registered so that Microsoft BizTalk Server 2000 can recognize that they belong to BizTalk Server 2000. Application integration components register themselves with the category ID CATID_BIZTALK_AIC. The CATIDs are defined in the bts_sdk_guids.h file. For more information, see Registering Application Integration Components.

Note

  • This interface is not available in Microsoft Visual Basic.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BTSSerializerComps.h

Related Topics

Sequence for Calling Methods of the IBizTalkSerializerComponent Interface

Using the IBizTalkSerializerComponent Interface


IBizTalkSerializerComponent::AddDocument Method

[C++]

The AddDocument method adds an XML document for storage by the serializer component.

[Visual Basic]

This method is not available in Microsoft Visual Basic.

Syntax

[C++]

HRESULT AddDocument(
    long DocHandle,
    IDictionary* Transport,
    BSTR TrackID,
    long ChannelID
);

[Visual Basic]

Not applicable

Parameters

[C++]

DocHandle

[in] Long that contains the handle to the document that is stored by the component and later retrieved when calling the GetDocInfo method. This parameter supports out-of-order recreation of the interchange in case the documents need to be reordered (such as in X12).

Transport

[in] Pointer to an IDictionary interface of an object that contains the XML document to be stored. It is on the working_data field. This parameter cannot be set by the component. This is an optional parameter.

TrackID

[in] BSTR that contains the document tracking ID used by the server.

ChannelID

[in] Long that contains the BizTalkChannel object associated with the current document.

[Visual Basic]

Not applicable

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

Not applicable

Remarks

[C++]

This method is called only once per interchange.

[Visual Basic]

Not applicable

Requirements

[C++]

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BTSSerializerComps.h

[Visual Basic]

Not applicable

Related Topics

Sequence for Calling Methods of the IBizTalkSerializerComponent Interface

Using the IBizTalkSerializerComponent Interface


IBizTalkSerializerComponent::GetDocInfo Method

[C++]

The GetDocInfo method gets details of the document.

[Visual Basic]

This method is not available in Microsoft Visual Basic.

Syntax

[C++]

HRESULT GetDocInfo(
    long* DocHandle,
    BOOL* SizeFromXMLDoc,
    LARGE_INTEGER* DocStartOffset,
    long* DocLen
);

[Visual Basic]

Not applicable

Parameters

[C++]

DocHandle

[out] Pointer to a long that contains the document handle. For each ID that is passed back, this address is assigned to the group record that was created when the GetGroupInfo method was called. This parameter also returns properties of the document, for example, size and length, unless the SizeFromXMLDoc parameter is set to TRUE, in which case the other parameters are ignored.

SizeFromXMLDoc

[out] Pointer to a Boolean value that indicates that the document offset and length values are retrieved from the XML document. If this parameter is TRUE, the server fills in the DocStartOffset and DocLen values for the document. If this parameter is FALSE, the server ignores the values in DocStartOffset and DocLen.

DocStartOffset

[out] Pointer to a LARGE_INTEGER that contains the offset to the beginning of the document. This parameter is returned if SizeFromXMLDoc is set to TRUE.

DocLen

[out] Pointer to a long that contains the length of the document. This parameter is returned if SizeFromXMLDoc is set to TRUE.

[Visual Basic]

Not applicable

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

Not applicable

Remarks

[C++]

This method is called once for every document in a group (or interchange, if there are no groups).

[Visual Basic]

Not applicable

Requirements

[C++]

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BTSSerializerComps.h

[Visual Basic]

Not applicable

Related Topics

Sequence for Calling Methods of the IBizTalkSerializerComponent Interface

Using the IBizTalkSerializerComponent Interface


IBizTalkSerializerComponent::GetGroupInfo Method

[C++]

The GetGroupInfo method gets details of the group, such as size and offset, for the Tracking database.

[Visual Basic]

This method is not available in Microsoft Visual Basic.

Syntax

[C++]

HRESULT GetGroupInfo(
    long* NumDocs,
    LARGE_INTEGER* GrpStartOffset,
    long* GrpLen
);

[Visual Basic]

Not applicable

Parameters

[C++]

NumDocs

[out] Pointer to a long that contains the number of documents in the group.

GrpStartOffset

[out] Pointer to a LARGE_INTEGER that contains the offset to the start of the group in the IStream interface.

GrpLen

[out] Pointer to a long that contains the length of the group.

[Visual Basic]

Not applicable

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

Not applicable

Remarks

[C++]

This method is called the number of times returned by the GetInterchangeInfo method. Call the GetDocInfo method for each document in the group.

[Visual Basic]

Not applicable

Requirements

[C++]

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BTSSerializerComps.h

[Visual Basic]

Not applicable

Related Topics

Sequence for Calling Methods of the IBizTalkSerializerComponent Interface

Using the IBizTalkSerializerComponent Interface


IBizTalkSerializerComponent::GetInterchangeInfo Method

[C++]

The GetInterchangeInfo method gets information about the interchange created.

[Visual Basic]

This method is not available in Microsoft Visual Basic.

Syntax

[C++]

HRESULT GetInterchangeInfo(
    BSTR* InterchangeID,
    long* lNumGroups
);

[Visual Basic]

Not applicable

Parameters

[C++]

InterchangeID

[out] Pointer to a BSTR that contains the interchange ID, which is placed in the Tracking database.

lNumGroups

[out] Pointer to a long that contains the number of groups generated in the interchange. This can be either 0 or 1. A document can exist in only one group.

[Visual Basic]

Not applicable

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

Not applicable

Remarks

[C++]

This method is called after all the documents are passed in.

[Visual Basic]

Not applicable

Requirements

[C++]

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BTSSerializerComps.h

[Visual Basic]

Not applicable

Related Topics

Sequence for Calling Methods of the IBizTalkSerializerComponent Interface

Using the IBizTalkSerializerComponent Interface


IBizTalkSerializerComponent::Init Method

[C++]

The Init method outputs the document instance to the serializer component and indicates its destination.

[Visual Basic]

This method is not available in Microsoft Visual Basic.

Syntax

[C++]

HRESULT Init(
    BSTR srcQual,
    BSTR srcID,
    BSTR destQual,
    BSTR destID,
    long EnvID,
    IDictionary* pDelimiters,
    IStream* OutputStream,
    long NumDocs
);

[Visual Basic]

Not applicable

Parameters

[C++]

srcQual

[in] BSTR that contains the source-organization identifier qualifier.

srcID

[in] BSTR that contains the source-organization identifier value.

destQual

[in] BSTR that contains the destination-organization identifier qualifier.

destID

[in] BSTR that contains the destination-organization identifier value.

EnvID

[in] Long that contains the envelope identifier value.

pDelimiters

[in] Pointer to an IDictionary interface of an object that contains the delimiters used in the document.

OutputStream

[in] Pointer to an IStream interface that contains the data of this document. This IStream pointer is write-only. The only methods that are supported are Write and Stat; all other methods return E_NOTIMPL. Additional information about the IStream object is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

NumDocs

[in] Long that contains the number of documents sent as part of this interchange. For this release, this parameter is set to 1.

[Visual Basic]

Not applicable

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

Not applicable

Requirements

[C++]

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include BTSSerializerComps.h

[Visual Basic]

Not applicable

Related Topics

Sequence for Calling Methods of the IBizTalkSerializerComponent Interface

Using the IBizTalkSerializerComponent Interface


IBTSAppIntegration Interface [C++]

IBTSAppIntegration Object [Visual Basic]

Use this object to create an entry point for receiving a document.

In C++, use the IBTSAppIntegration interface to access the methods of the BTSAppIntegration object.

The method of the BTSAppIntegration object is shown in the following table.

Method | Description
ProcessMessage | Processes the document.

Remarks

Application integration components must be properly registered so that Microsoft BizTalk Server 2000 can recognize that they belong to BizTalk Server 2000. Application integration components register themselves with the category ID CATID_BIZTALK_AIC. The CATIDs are defined in the bts_sdk_guids.h file. For more information, see Registering Application Integration Components.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include btsaic.h
Library: Use Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)

Related Topic

Using the IBTSAppIntegration Interface


IBTSAppIntegration::ProcessMessage Method [C++]

IBTSAppIntegration.ProcessMessage Method [Visual Basic]

The ProcessMessage method processes a document and returns a response document, if available. This method is called at run time when the server is sending a document to the component.

Syntax

[C++]

HRESULT ProcessMessage(
    BSTR bstrDocument,
    BSTR* pbstrResponseDocument
);

[Visual Basic]

object.ProcessMessage( _
    bstrDocument As String _
)

Parameters

[C++]

bstrDocument

[in] BSTR that contains the document.

pbstrResponseDocument

[retval, out] Pointer to a BSTR that contains the response document.

[Visual Basic]

bstrDocument

String that contains the document.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

String that contains the response document.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

Components can return a response string to pass back a text-based response to an application, using the SubmitSync method of the IInterchange interface to send documents.

Components must raise an error if a problem with processing occurs so that the document can be retransmitted or sent to the Suspended queue. If no error is returned, the server assumes that the component successfully processed the data.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include btsaic.h
Library: Use Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)


IPipelineComponent Interface [C++]

IPipelineComponent Object [Visual Basic]

Use this object to create custom pipeline components that can execute in Microsoft BizTalk Server 2000 to extend its functionality.

In C++, use the IPipelineComponent interface to access the methods of the PipelineComponent object.

The methods of the PipelineComponent object are shown in the following table.

Method | Description
EnableDesign | Configures the component for execution in one of two modes: design mode or execution mode.
Execute | Executes the operation expected of the component, given the transport Dictionary object and other configuration settings.

Remarks

Application integration components must be properly registered so that BizTalk Server 2000 can recognize that they belong to BizTalk Server 2000. Application integration components register themselves with the category ID CATID_BIZTALK_AIC. The CATIDs are defined in the bts_sdk_guids.h file. For more information, see Registering Application Integration Components.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include pipecomp.h
Library: Use Microsoft Commerce 2000 Default Pipeline Components Type Library (pipecomplib.tlb)

Related Topic

Creating Application Integration Components


IPipelineComponent::EnableDesign Method [C++]

IPipelineComponent.EnableDesign Method [Visual Basic]

The EnableDesign method configures the component for execution in one of two modes: design mode or execution mode.

Syntax

[C++]

HRESULT EnableDesign(
    BOOL fEnable
);

[Visual Basic]

object.EnableDesign( _
    fEnable As Boolean _
)

Parameters

[C++]

fEnable

Boolean value that indicates the mode of the component. A value of TRUE specifies that the component runs in design mode. A value of FALSE (default) specifies execution mode.

[Visual Basic]

fEnable

Boolean that indicates the mode of the component. A value of True specifies that the component runs in design mode. A value of False (default) specifies execution mode.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

None.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

The pipeline component runs in execution mode by default.

This method is called when the Override messaging port defaults page is opened in the Channel Wizard's Advanced Configuration page. It is also called when the property page is closed and the fEnable parameter is set to true. Design mode is not enabled unless this method has been called with the fEnable parameter set to True.

Design-only fields are returned only when the fEnable parameter is set to true. Otherwise, the Dictionary object passed to the server contains unnecessary information.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include pipecomp.h
Library: Use Microsoft Commerce 2000 Default Pipeline Components Type Library (pipecomplib.tlb)


IPipelineComponent::Execute Method [C++]

IPipelineComponent.Execute Method [Visual Basic]

The Execute method executes the operation expected of the component, given the transport Dictionary object and other configuration settings. Microsoft BizTalk Server 2000 calls this method, passing in the transport Dictionary object. The component can read these Dictionary object values, perform the necessary functions, and optionally write new values back to the transport Dictionary object for further processing.

Syntax

[C++]

HRESULT Execute(
    IDispatch* pDispOrder,
    IDispatch* pDispContext,
    long lFlags,
    long* plErrorLevel
);

[Visual Basic]

object.Execute( _
    pDispOrder As Object, _
    pDispContext As Object, _
    lFlags As Long _
)

Parameters

[C++]

pDispOrder

[in] Pointer to the transport Dictionary object.

pDispContext

[in] Not supported for this release.

lFlags

[in] Reserved.

PlErrorLevel

[out, retval] Reserved.

[Visual Basic]

pDispOrder

Object that contains the transport CDictionary object.

pDispContext

Not supported for this release.

lFlags

Reserved.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This method returns a Long that contains the error level.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

For a component designed to run in BizTalk Server 2000, the first parameter is a Transport Dictionary object. The Transport Dictionary values can be read by the component for processing. The string values supplied by the server for all application integration components (AICs) are as follows:

  • Src_ID_Type: The type of identifier used for the source organization.

  • Src_ID_Value: The value of the source organization identifier.

  • Dest_ID_Type: The type of identifier used for the destination organization.

  • Dest_ID_Value: The value of the destination organization identifier.

  • Document_Name: The name of the input document definition.

  • Tracking_ID: A key value that is based on the globally unique identifier (GUID) and used for tracking.

For a component that runs in a Commerce Server order-processing pipeline, the first parameter contains the OrderForm object.

This method is called at run time when the server is sending a document to the component. This method is called immediately after the SetConfigData method of the IPipelineComponentAdmin interface. The document is passed in the first parameter as a dictionary within the working_data field of the Dictionary object. Components can add the ResponseField key to the Dictionary object to pass back a text-based response to an application, using the SubmitSync method of the IInterchange interface.

The component must raise an error if a problem with processing occurs so that the server can retry transmission later and, after all retries, send the document to the Suspended queue. If no error is returned, the server assumes that the component successfully processed the data.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include pipecomp.h
Library: Use Microsoft Commerce 2000 Default Pipeline Components Type Library (pipecomplib.tlb)


IPipelineComponentAdmin Interface [C++]

IPipelineComponentAdmin Object [Visual Basic]

Use this object between the component and the component user interface.

In C++, use the IPipelineComponentAdmin interface to access the methods of the PipelineComponentAdmin object.

The methods of the PipelineComponentAdmin object are shown in the following table.

Method | Description
GetConfigData | Returns a Dictionary object that contains the configuration data for the component for the user interface to display these values.
SetConfigData | Sets the configuration settings for a component, using the contents of a Dictionary object.

Remarks

Application integration components must be properly registered so that BizTalk Server 2000 can recognize that they belong to BizTalk Server 2000. Application integration components register themselves with the category ID CATID_BIZTALK_AIC. The CATIDs are defined in the bts_sdk_guids.h file. For more information, see Registering Application Integration Components.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include pipecomp.h
Library: Use Microsoft Commerce 2000 Default Pipeline Components Type Library (pipecomplib.tlb)

Related Topic

Creating Application Integration Components


IPipelineComponentAdmin::GetConfigData Method [C++]

IPipelineComponentAdmin.GetConfigData Method [Visual Basic]

The GetConfigData method returns a Dictionary object that contains the configuration data for the component to be used to display these values. GetConfigData enables the user interface component to read the current value from the component and display it on the property page initially.

Syntax

[C++]

HRESULT GetConfigData(
    IDispatch** ppConfigDictionary
);

[Visual Basic]

object.GetConfigData()

Parameters

[C++]

ppConfigDictionary

[out, retval] Address of a pointer to a Dictionary object from which the user interface can read the configuration data.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This method optionally returns a CDictionary object from which the user interface can read the configuration data.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

When a BizTalkPort object is first saved, this method is called to get the defaults for use in autoconfiguring the application integration component (AIC) from the Dictionary object provided. Components must provide defaults for all mandatory properties, whenever possible.

This method is called when the user selects the property page. It is used to supply property page defaults. It is called again when the property page is closed. The contents of this returned Dictionary object are not used.

Components must always return a valid dictionary pointer from GetConfigData.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include pipecomp.h
Library: Use Microsoft Commerce 2000 Default Pipeline Components Type Library (pipecomplib.tlb)


IPipelineComponentAdmin::SetConfigData Method [C++]

IPipelineComponentAdmin.SetConfigData Method [Visual Basic]

The SetConfigData method sets the configuration for a component, using the contents of a Dictionary object. With this method, the user interface can set or change these values. SetConfigData enables the user interface to write the updated value from the property page to the component.

Syntax

[C++]

HRESULT SetConfigData(
    IDispatch* pConfigDictionary
);

[Visual Basic]

object.SetConfigData( _
    pConfigDictionary As Object _
)

Parameters

[C++]

pConfigDictionary

[in] Pointer to a Dictionary object that contains the configuration information.

[Visual Basic]

pConfigDictionary

CDictionary object that contains the configuration information.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

None.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

The server calls SetConfigData when the property page is saved. It is used to verify the values entered by the user on the property page. The contents of this provided Dictionary object are also stored in the database.

This method is called immediately before the Execute method of the IPipelineComponent interface at run time, when the server is ready to send a document to the component. Data stored during design time from autoconfiguration or from property-page updates is passed to the component to allow for property setup prior to calling Execute.

Components validate the properties provided in SetConfigData and raise an error if any of the properties are invalid or missing.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include pipecomp.h
Library: Use Microsoft Commerce 2000 Default Pipeline Components Type Library (pipecomplib.tlb)


ISchemaImporter Interface [C++]

SchemaImporter Object [Visual Basic]

Use this object to handle the importing of DTDs, XDRs, and well-formed XML documents.

In C++, use the ISchemaImporter interface to access the properties and methods of the SchemaImporter object.

The properties of the SchemaImporter object are shown in the following table.

Property | Description
ImportFormatDescription | Returns descriptive text about a supported import format.
ImportFormatIcon | Returns an icon for a supported import format.
NumberOfSupportedImportFormats | Returns the number of supported data formats from which a schema can be extracted.

The method of the SchemaImporter object is shown in the following table.

Method | Description
ExtractXMLSchema | Extracts a schema from a document.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SchemaImporter.h
Library: Use Microsoft BizTalk Server Import Extension Module 1.0 Type Library (ExtensionMod.dll)


ISchemaImporter::ExtractXMLSchema Method [C++]

SchemaImporter.ExtractXMLSchema Method [Visual Basic]

The ExtractXMLSchema method extracts a schema from a document.

Syntax

[C++]

HRESULT ExtractXMLSchema(
    long lFormatIndex,
    BSTR strDocumentPath,
    IDispatch** ppSchemaDOM
);

[Visual Basic]

object.ExtractXMLSchema( _
    lFormatIndex As Long, _
    bstrDocumentPath As String _
)

Parameters

[C++]

lFormatIndex

[in] Index value that specifies the type of document from which to import the schema. Pass in 0 to import well-formed XML, 1 to import a document type definition (DTD), or 2 to import an XDR schema.

strDocumentPath

[in] Path to the document from which to import the schema.

ppSchemaDOM

[out, retval] Address of a pointer to an IDispatch interface that contains the extracted XML schema.

[Visual Basic]

lFormatIndex

Index value that specifies the type of document from which to import the schema. Pass in 0 to import well-formed XML, 1 to import a document type definition (DTD), or 2 to import an XDR schema.

bstrDocumentPath

Path to the document from which to import the schema.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This method returns an Object that contains information about the extracted XML schema.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SchemaImporter.h
Library: Use Microsoft BizTalk Server Import Extension Module 1.0 Type Library (ExtensionMod.dll)


ISchemaImporter::ImportFormatDescription Property [C++]

SchemaImporter.ImportFormatDescription Property [Visual Basic]

The ImportFormatDescription property returns descriptive text about a supported import format.

Syntax

[C++]
HRESULT get_ImportFormatDescription(
     long lFormatIndex,
     BSTR* ppbstrDescription
);
[Visual Basic]
object.ImportFormatDescription( _
     lFormatIndex As Long _
)

Parameters

[C++]

lFormatIndex

[in] Index value that specifies the type of document from which to import the schema. Pass in 0 to import well-formed XML, 1 to import a document type definition (DTD), or 2 to import an XDR schema.

ppbstrDescription

[out, retval] Pointer to a BSTR that contains a textual description of the input document format.

[Visual Basic]

lFormatIndex

Index value that specifies the type of document from which to import the schema. Pass in 0 to import well-formed XML, 1 to import a document type definition (DTD), or 2 to import an XDR schema.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a String that contains a textual description of the input document format.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SchemaImporter.h
Library: Use Microsoft BizTalk Server Import Extension Module 1.0 Type Library (ExtensionMod.dll)


ISchemaImporter::ImportFormatIcon Property [C++]

ISchemaImporter.ImportFormatIcon Property [Visual Basic]

The ImportFormatIcon property returns an icon for a supported import format.

Syntax

[C++]
HRESULT get_ImportFormatIcon(
     long lFormatIndex,
     long* pIconID
);
[Visual Basic]
object.ImportFormatIcon( _
     lFormatIndex As Long _
)

Parameters

[C++]

lFormatIndex

[in] Index value that specifies the type of document from which to import the schema. Pass in 0 to import well-formed XML, 1 to import a document type definition (DTD), or 2 to import an XDR schema.

pIconID

[out, retval] Pointer to a long that contains the icon identifier for the input format.

[Visual Basic]

lFormatIndex

Index value that specifies the type of document from which to import the schema. Pass in 0 to import well-formed XML, 1 to import a document type definition (DTD), or 2 to import an XDR schema.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a Long that is the icon identifier for the input format.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read only-property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SchemaImporter.h
Library: Use Microsoft BizTalk Server Import Extension Module 1.0 Type Library (ExtensionMod.dll)


ISchemaImporter::NumberOfSupportedImportFormats Property [C++]

SchemaImporter.NumberOfSupportedImportFormats Property [Visual Basic]

The NumberOfSupportedImportFormats property returns the number of supported data formats from which a schema can be extracted.

Syntax

[C++]
HRESULT get_NumberOfSupportedImportFormats(
     long* plNumber
);
[Visual Basic]
object.NumberOfSupportedImportFormats

Parameters

[C++]

plNumber

[out, retval] Pointer to a long that indicates the number of supported import formats.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a Long that contains the number of supported import formats.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SchemaImporter.h
Library: Use Microsoft BizTalk Server Import Extension Module 1.0 Type Library (ExtensionMod.dll)


ISchemaImporterError Interface [C++]

SchemaImporterError Object [Visual Basic]

Use this object to identify and decipher errors or warnings.

In C++, use the ISchemaImporterError interface to access the properties of the SchemaImporterError object.

The properties of the SchemaImporterError object are shown in the following table.

Property | Description
IsWarning | Returns a value that identifies the object as an error or a warning.
NodePath | Returns the path to the node that generated the error or warning.
Text | Returns the error or warning message.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SchemaImporter.h
Library: Use Microsoft BizTalk Server Import Extension Module 1.0 Type Library (ExtensionMod.dll)


ISchemaImporterError::IsWarning Property [C++]

SchemaImporterError.IsWarning Property [Visual Basic]

The IsWarning property returns a value that identifies the object as an error or a warning.

Syntax

[C++]
HRESULT get_IsWarning(
     VARIANT_BOOL* pIsWarning
);
[Visual Basic]
object.IsWarning

Parameters

[C++]

pIsWarning

[out, retval] Set to VARIANT_TRUE if the object is a warning; otherwise, set to VARIANT_FALSE to indicate that the object is an error.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a Boolean value. Set to True if the object is a warning; otherwise, set to False to indicate that the object is an error.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SchemaImporter.h
Library: Use Microsoft BizTalk Server Import Extension Module 1.0 Type Library (ExtensionMod.dll)


ISchemaImporterError::NodePath Property [C++]

SchemaImporterError.NodePath Property [Visual Basic]

The NodePath property returns the path to the node that generated the error or warning.

Syntax

[C++]
HRESULT get_NodePath(
     BSTR* pbstrNodePath
);
[Visual Basic]
object.NodePath

Parameters

[C++]

pbstrNodePath

[out, retval] Pointer to a BSTR that contains the fully qualified name of the node that generated the error or warning.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a String that is the fully qualified name of the node that generated the error or warning.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SchemaImporter.h
Library: Use Microsoft BizTalk Server Import Extension Module 1.0 Type Library (ExtensionMod.dll)


ISchemaImporterError::Text Property [C++]

SchemaImporterError.Text Property [Visual Basic]

The Text property returns the error or warning message.

Syntax

[C++]
HRESULT get_Text(
     BSTR* pbstrText
);
[Visual Basic]
object.Text

Parameters

[C++]

pbstrText

[out, retval] Pointer to a BSTR that contains the text associated with the error or warning.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a String that is the text associated with the error or warning.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SchemaImporter.h
Library: Use Microsoft BizTalk Server Import Extension Module 1.0 Type Library (ExtensionMod.dll)


ISchemaImporterErrorProvider Interface [C++]

SchemaImporterErrorProvider Object [Visual Basic]

Use this object to return errors or warnings.

In C++, use the ISchemaImporterErrorProvider interface to access the properties of the SchemaImporterErrorProvider object.

The properties of the SchemaImporterErrorProvider object are shown in the following table.

Property | Description
Error | Returns the error or warning.
NumberOfErrors | Returns the number of errors or warnings.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SchemaImporter.h
Library: Use Microsoft BizTalk Server Import Extension Module 1.0 Type Library (ExtensionMod.dll)


ISchemaImporterErrorProvider::Error Property [C++]

SchemaImporterErrorProvider.Error Property [Visual Basic]

The Error property returns the error or warning.

Syntax

[C++]
HRESULT get_Error(
     long lIndex,
     ISchemaImporterError** pdswError
);
[Visual Basic]
object.Error( _
     lIndex As Long _
)

Parameters

[C++]

lIndex

[in] Index of the required error or warning.

pdswError

[out, retval] Address of a pointer to an ISchemaImporterError interface that contains the error or warning.

[Visual Basic]

lIndex

Index of the required error or warning.

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a SchemaImporterError object that contains the error or warning.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SchemaImporter.h
Library: Use Microsoft BizTalk Server Import Extension Module 1.0 Type Library (ExtensionMod.dll)


ISchemaImporterErrorProvider::NumberOfErrors Property [C++]

SchemaImporterErrorProvider.NumberOfErrors Property [Visual Basic]

The NumberOfErrors property returns the number of errors or warnings.

Syntax

[C++]
HRESULT get_NumberOfErrors(
     long* plNumberOfErrors
);
[Visual Basic]
object.NumberOfErrors

Parameters

[C++]

plNumberOfErrors

[out, retval] Pointer to a long that indicates the number of errors.

[Visual Basic]

None

Return Values

[C++]

For a list of all error messages returned by BizTalk Server, see Error Messages.

[Visual Basic]

This property returns a Long that indicates the number of errors.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the Error Messages page.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SchemaImporter.h
Library: Use Microsoft BizTalk Server Import Extension Module 1.0 Type Library (ExtensionMod.dll)


Receipt Enumerations

The following receipt enumeration provides possible values of properties and parameters for the IBizTalkAcknowledge interface:

  • DTA_ACK_STATUS

  • GeneratedReceiptLevel


DTA_ACK_STATUS

The DTA_ACK_STATUS enumeration has one of the following values:

Name | Value | Description
DTA_ACK_NONE | 0 | No receipt is expected.
DTA_ACK_PENDING | 1 | The receipt is expected but has not yet arrived.
DTA_ACK_OVERDUE | 2 | The receipt has timed out.
DTA_ACK_ACCEPTED | 3 | The receipt has arrived with a status of accepted.
DTA_ACK_PARTIALLY_ACCEPTED | 4 | The receipt has arrived with a status of accepted with errors.
DTA_ACK_REJECTED | 5 | The receipt has arrived with a status of rejected.


GeneratedReceiptLevel

The GeneratedReceiptLevel enumeration has one of the following values:

Name | Value | Description
NoReceiptGenerated | 0 | No receipt is created.
DocReceiptGenerated | 1 | A receipt is generated for each document.
GroupReceiptGenerated | 2 | A receipt is generated for each group.
InterchangeReceiptGenerated | 3 | A receipt is generated for each interchange.


Functoid Enumerations

The following functoid enumerations provide possible values of properties and parameters:

  • CONNECTION_TYPE

  • FUNC_CATEGORY

  • FUNC_TYPE

  • SCRIPT_CATEGORY


CONNECTION_TYPE

The CONNECTION_TYPE enumeration defines the following values:

Name | Value | Description
CONNECT_TYPE_NONE | 0 | The connection type is none.
CONNECT_TYPE_FIELD | 1 | The connection type is field.
CONNECT_TYPE_RECORD | 2 | The connection type is record.
CONNECT_TYPE_RECORD_CONTENT | 4 | The connection type is record content.
CONNECT_TYPE_FUNC_STRING | 8 | The connection type function is string.
CONNECT_TYPE_FUNC_MATH | 16 | The connection type function is mathematical.
CONNECT_TYPE_FUNC_DATACONV | 32 | The connection type function is data conversion.
CONNECT_TYPE_FUNC_DATETIME_FMT | 64 | The connection type function is date/time format.
CONNECT_TYPE_FUNC_SCIENTIFIC | 128 | The connection type function is scientific.
CONNECT_TYPE_FUNC_BOOLEAN | 256 | The connection type function is Boolean.
CONNECT_TYPE_FUNC_SCRIPTER | 512 | The connection type function is script.
CONNECT_TYPE_FUNC_COUNT | 1024 | The connection type function is count.
CONNECT_TYPE_FUNC_INDEX | 2048 | The connection type function is index.
CONNECT_TYPE_FUNC_CUMULATIVE | 4096 | The connection type function is cumulative.
CONNECT_TYPE_FUNC_VALUE_MAPPING | 8192 | The connection type function is value mapping.
CONNECT_TYPE_FUNC_LOOPING | 16384 | The connection type function is looping.
CONNECT_TYPE_FUNC_ITERATION | 32768 | The connection type function is iteration.
CONNECT_TYPE_FUNC_DBLOOKUP | 65536 | The connection type function is database lookup.
CONNECT_TYPE_FUNC_DBEXTRACT | 131072 | The connection type function is database extraction.
CONNECT_TYPE_ALL | -1 | The connection type includes all connection types.
CONNECT_TYPE_ALL_EXCEPT_RECORD | -3 | The connection type includes all connection types except records.


FUNC_CATEGORY

The FUNC_CATEGORY enumeration defines the following values:

Name | Value | Description
FUNC_CATEGORY_STRING | 3 | The function category is string.
FUNC_CATEGORY_MATH | 4 | The function category is mathematical.
FUNC_CATEGORY_DATACONV | 5 | The function category is data conversion.
FUNC_CATEGORY_DATETIME_FMT | 6 | The function category is date/time format.
FUNC_CATEGORY_SCIENTIFIC | 7 | The function category is scientific.
FUNC_CATEGORY_BOOLEAN | 8 | The function category is Boolean.
FUNC_CATEGORY_SCRIPTER | 9 | The function category is script.
FUNC_CATEGORY_COUNT | 10 | The function category is count. This value is not supported for this release.
FUNC_CATEGORY_INDEX | 11 | The function category is index.
FUNC_CATEGORY_CUMULATIVE | 12 | The function category is cumulative.
FUNC_CATEGORY_VALUE_MAPPING | 13 | The function category is value mapping. This value is not supported for this release.
FUNC_CATEGORY_LOOPING | 14 | The function category is looping. This value is not supported for this release.
FUNC_CATEGORY_ITERATION | 15 | The function category is iteration. This value is not supported for this release.
FUNC_CATEGORY_DBLOOKUP | 16 | The function category is database lookup.
FUNC_CATEGORY_DBEXTRACT | 17 | The function category is database extraction.
FUNC_CATEGORY_UNKNOWN | 31 | The function category is unknown.


FUNC_TYPE

The FUNC_TYPE enumeration defines the following values:

Name | Value | Description
FUNC_TYPE_STD | 1 | The function type is standard.
FUNC_TYPE_VARIABLEINPUT | 2 | The function type is variable input.
FUNC_TYPE_SCRIPTOR | 3 | The function type is script.


SCRIPT_CATEGORY

The SCRIPT_CATEGORY enumeration defines the following values:

Name | Value | Description
SCRIPT_CATEGORY_VBSCRIPT | 0 | The custom functoid function is written in the Microsoft Visual Basic Scripting Edition (VBScript) language.
SCRIPT_CATEGORY_JSCRIPT | 1 | The custom functoid function is written in the Microsoft JScript language. This value is not supported for this release.
SCRIPT_CATEGORY_XSLSCRIPT | 2 | The custom functoid function is written in the Extensible Stylesheet Language (XSL). This value is not supported for this release.


Concepts

This section provides detailed conceptual information that is important to understanding how to extend Microsoft BizTalk Server 2000. BizTalk Server 2000 can perform data transformation, digital signature, encryption and decryption, parsing, serializing, and transport of documents. In addition, you can create your own application integration components (AICs) to extend the capabilities of BizTalk Server 2000.

The following topics are covered:

  • Creating Application Integration Components

  • Using the IBizTalkParserComponent Interface

  • Using the IBizTalkSerializerComponent Interface

  • Supporting the Tracking Database with Parser and Serializer Components

  • Creating Receipt Correlator Components

For samples of code, see BizTalk Messaging Services Code Samples.


Creating Application Integration Components

When creating an application integration component (AIC), you can implement either the pipeline model using the IPipelineComponent interface or the lightweight model using the IBTSAppIntegration interface.

Application integration components are COM objects that the BizTalk Server state engine calls to deliver data to an application. If a messaging port is configured in BizTalk Server 2000 to include the use of an AIC for application integration, this component is automatically instantiated and passed the requisite data. The component then determines how to handle communicating this data back to the application. This can be done using private API calls, invoking other COM objects, using database writes, and so on.

By default, AICs run in the LocalSystem account. If another security context is required, set it as part of the implementation of the AIC. However, if an AIC is installed as a COM+ application, an administrator can configure security of the AIC by using the Component Services console.

Related Topics

Lightweight Application Integration Components

Pipeline Application Integration Components

Registering Application Integration Components


Pipeline Application Integration Components

One approach for application integration with BizTalk Server 2000 is the creation of a pipeline component. This is the same model used in Microsoft Site Server Commerce Edition 3.0 for application integration with the Commerce Interchange pipeline (CIP) and the Order Processing pipeline (OPP). BizTalk Server 2000 supports this method so that pipeline components written for application integration for CIP and OPP are compatible. This is also a useful technique when the component requires configuration properties.

The primary entry point for a pipeline component is the Execute method of the IPipelineComponent interface. This is the method that BizTalk Server 2000 calls to transfer control and to pass the data to the component. It is in the implementation of this method that the component does its work.

Related Topics

IPipelineComponent

IPipelineComponentAdmin


Lightweight Application Integration Components

BizTalk Server 2000 supports an additional model for application developers who want a lighter-weight model for application integration, one that does not support a design-time user interface or configuration properties. This model requires a single interface that contains a single method as an entry point. The component is implemented, and the document is passed to it through the ProcessMessage method of the IBTSAppIntegration interface.

IBTSAppIntegration is for applications that do not need properties for their component and need only an entry point for receiving a document. This is a simpler approach to application integration than pipeline components. BizTalk Server 2000 queries for this interface first. If it does not find this interface implemented, it queries for the pipeline component interfaces.


Registering Application Integration Components

To use an application integration component (AIC) in BizTalk Server 2000, the component must be registered with the category IDs for all pipeline components and for the specific type of pipeline component, in this case application integration.

Register the AIC as an out-of-process component to provide better isolation. An AIC can be registered as an in process (inproc) component to increase its performance. However, an inproc component that fails to respond during an error condition might cause BizTalk Server to fail. Therefore, an AIC should be thoroughly tested before registering it as an inproc component.

Notes

  • An out-of-process component registered as a COM+ application must be configured to run in an identity other than the interactive user.

  • The application integration component must be registered by a user in the BizTalk Server Administrators group. The BizTalk Server Administrators group is created when BizTalk Server 2000 is installed. Additional users can be added to this group as necessary.

For more information about Component Services and COM+, go to the MSDN Online Library Web site (msdn.microsoft.com/library/default.asp) and browse to Component Services in the Platform SDK.

Assigning affinity

Each application integration component (AIC) must be associated with two category IDs. One category ID marks the component as a BizTalk Server component. A component so marked appears in a list of components in the BizTalk Server administration console. The second category ID indicates the type or purpose of the component. This second association is called affinity. Only those components whose affinity is registered as application integration components appear in lists of such components.

To register affinity for an AIC created with Microsoft Visual C++ using ATL, include the following code in your header file:

#include "bts_sdk_guids.h"
// Implement the Component and AIC Category IDs (CATID)
BEGIN_CATEGORY_MAP(AIC_ClassName)
    IMPLEMENTED_CATEGORY(CATID_BIZTALK_COMPONENT)
    IMPLEMENTED_CATEGORY(CATID_BIZTALK_AIC)
END_CATEGORY_MAP()

To register affinity for an AIC created with Microsoft Visual Basic:

  1. After registering your component using Regsvr32.exe, search the registry for the CLSID of your AIC under the following key:

    HKEY_CLASSES_ROOT\CLSID

  2. Expand the Implemented Categories key of your AIC.

  3. Add two new keys with the following names:

    HKEY_CLASSES_ROOT\CLSID\AIC_CLSID\Implemented Categories\{5C6C30E7-C66D-40e3-889D-08C5C3099E52}

    HKEY_CLASSES_ROOT\CLSID\AIC_CLSID\Implemented Categories\{BD193E1D-D7DC-4b7c-B9D2-92AE0344C836}

These GUIDs can be found in bts_sdk_guids.h in the Program Files\Microsoft BizTalk Server\SDK\Include folder. The first key shown in step 3 above identifies the AIC as a BizTalk Server component (CATID_BIZTALK_COMPONENT). The second key shown in step 3 above identifies the component as an AIC (CATID_BIZTALK_AIC).

Testing affinity

To test affinity, use BizTalk Messaging Manager to create a port that uses the AIC. For more information, see Select an application integration component.


Using the IBizTalkParserComponent Interface

The parser has two responsibilities:

  • Convert the documents to XML for later processing.

  • Get the parameters necessary to select the channel (these are the source qualifier, source identifier, destination qualifier, destination identifier, and document definition name). These returned fields are combined with the parameters of the Submit method of the IInterchange interface to select the channels necessary to process the documents.

This interface gets information from the component for one interchange. If the incoming data stream represents multiple interchanges, the server selects the component at every interchange boundary. This simplifies construction of a component because it deals with only one interchange at a time. There is one component instance per thread. No single object needs to be safe for multiple threads. This interface is supported only in C++.

If the ProbeInterchangeFormat method of the IBizTalkParserComponent interface returns an error in the middle of the document list, it blocks the server from detecting more document types, even if they could be handled by a custom parser that follows the failed parser, if there are two or more custom parsers on a server. If the first custom parser fails, any document that follows is not parsed, even if the other custom parser could handle it, because the server ends the entire parsing operation at the time of the failure.

For additional information, see Sequence for Calling Methods of the IBizTalkParserComponent Interface.

Related Topic

Registering Application Integration Components


Sequence for Calling Methods of the IBizTalkParserComponent Interface

The following tables show a possible sequence for calling the methods, based on the sample interchange.

If you have an interchange with two groups, with two documents in the first group and one in the second, the methods are called in the following sequence:

Method | Return
ProbeInterchangeFormat | Non-empty format string
GetInterchangeDetails | N/A
GroupsExist | True
GetGroupDetails | N/A
GetNextDocument | The LastDoc parameter is set to False.
GetNativeDocumentOffsets | N/A
GetNextDocument | The LastDoc parameter is set to True.
GetNativeDocumentOffsets | N/A
GetGroupSize | The LastGroup parameter is set to False.
GetGroupDetails | N/A
GetNextDocument | The LastDoc parameter is set to True.
GetNativeDocumentOffsets | N/A
GetGroupSize | The LastGroup parameter is set to True.

If you have an interchange with two documents, the methods are called in the following sequence:

Method | Return
ProbeInterchangeFormat | Non-empty format string
GetInterchangeDetails | N/A
GroupsExist | False
GetNextDocument | The LastDoc parameter is set to False.
GetNativeDocumentOffsets | N/A
GetNextDocument | The LastDoc parameter is set to True.
GetNativeDocumentOffsets | N/A


Using the IBizTalkSerializerComponent Interface

The serializer converts the document from XML back to its native format. This interface is intended to work on a single interchange and is designed to get information from the component for one interchange. This simplifies the construction of this component because it has to deal with only one interchange at a time. There is only one instance per thread. No single object needs to be safe for multiple threads. This interface is supported only in C++.

Related Topic

Registering Application Integration Components


Sequence for Calling Methods of the IBizTalkSerializerComponent Interface

The following tables show the possible sequence of calling the methods of the IBizTalkSerializerComponent interface, based on the following sample interchanges.

If you have an interchange with one document, the methods are called in the following sequence:

Method | Return
Init | The numdocs parameter is set to 1.
AddDocument | The docHandle parameter is set to 0.
GetInterchangeInfo | The numGroups parameter is set to 0.
GetDocInfo | The docHandle parameter is set to 0.

If you have an interchange with one group, with one document in the group, the methods are called in the following sequence:

Method | Return
Init | The numdocs parameter is set to 1.
AddDocument | The docHandle parameter is set to 0.
GetInterchangeInfo | The numGroups parameter is set to 1.
GetGroupInfo | The numdocs parameter is set to 1.
GetDocInfo | The docHandle parameter is set to 0.

If you have an interchange with two groups, with two documents in the first group and one in the second, the methods are called in the following sequence (this assumes support of batching):

Method | Return
Init | The numdocs parameter is set to 3.
AddDocument | The handle parameter is set to 0.
AddDocument | The handle parameter is set to 1.
AddDocument | The handle parameter is set to 2.
GetInterchangeInfo | The numGroups parameter is set to 2.
GetGroupInfo | The numdocs parameter is set to 2.
GetDocInfo | The handle parameter is set to 1.
GetDocInfo | The handle parameter is set to 0.
GetGroupInfo | The numdocs parameter is set to 1.
GetDocInfo | The handle parameter is set to 2.

Related Topic

IBizTalkSerializerComponent


Supporting the Tracking Database with Parser and Serializer Components

When creating a custom parser or serializer, you might want your component to support the BizTalk Server Tracking database. To accomplish this, the component must use the IDictionary interface to add key/value pairs into the database.

Interchange table

The following table contains the list of keys that can be used to support the Tracking database from the interchange level with a custom component. The table used in the database is dta_interchange_details.

Dictionary key | Inbound or Outbound | Column logged in Tracking database | Description
Src_ID_Type | Both | *nvcSrcAliasQualifier | This is the qualifier for the source organization. This value can come from a parameter supplied in a Submit call or from a receive function in the BizTalk Server Administration user interface. A parser can overwrite this value to manipulate the routing information used for channel selection.
Src_ID_Value | Both | *nvcSrcAliasId | This contains the value of the qualifier of the source organization. This value can come from a parameter supplied in a Submit call or from a receive function in the BizTalk Server Administration user interface. A parser can overwrite this value to manipulate the routing information used for channel selection.
In_Src_ID_App | Inbound | nvcSrcAppName | This is the interchange level identifier for the source application of an EDI interchange. When the parser sets the value with this dictionary key, the value is logged on the inbound interchange in the Tracking database.
Dest_ID_Type | Both | *nvcDestAliasQualifier | This is the qualifier for the destination organization. This value can come from a parameter supplied in a Submit call or from a receive function in the BizTalk Server Administration user interface. A parser can overwrite this value to manipulate the routing information used for channel selection.
Dest_ID_Value | Both | *nvcDestAliasId | This contains the value of the qualifier of the destination organization. This value can come from a parameter supplied in a Submit call or from a receive function in the BizTalk Server Administration user interface. A parser can overwrite this value to manipulate the routing information used for channel selection.
In_Dest_ID_App | Inbound | nvcDestAppName | This is the interchange level identifier for the destination application of an EDI interchange. When the parser sets the value with this dictionary key, the value is logged on the inbound interchange in the Tracking database.
interchange_id | Inbound | nvcControlID | This is the unique control number used to identify an EDI interchange instance between trading partners. When the parser sets the value with this dictionary key, the value is logged on the inbound interchange in the Tracking database.
interchange_version | Inbound | nvcVersion | This is the version of an EDI interchange. When the parser sets the value with this dictionary key, the value is logged on the inbound interchange in the Tracking database.
Out_Src_ID_App | Outbound | *nvcSrcAppName | This is the interchange level identifier for the source application of an EDI interchange. When the serializer sets the value with this dictionary key, the value is logged on the outbound interchange in the Tracking database.
Out_Dest_ID_App | Outbound | *nvcDestAppName | This is the interchange level identifier for the destination application of an EDI interchange. When the serializer sets the value with this dictionary key, the value is logged on the outbound interchange in the Tracking database.
out_interchange_id | Outbound | *nvcControlID | This is the unique control number used to identify an EDI interchange instance between trading partners. The serializer usually generates this unique value. When the serializer sets the value with this dictionary key, the value is logged on the outbound interchange in the Tracking database.
out_interchange_version | Outbound | *nvcVersion | This is the version of the EDI standard. When the serializer sets the value with this dictionary key, the value is logged on the outbound interchange in the Tracking database.

Note

  • The columns of the dta_interchange_details table marked with an asterisk (*) are used for receipt correlation.

Group table

The following table contains the list of keys that can be used to support the Tracking database from the group level with a custom component. The table used in the database is dta_group_details. This table applies to both inbound and outbound documents.

Dictionary key | Column logged in Tracking database | Description
group_id | *nvcControlID | This is the unique control number of a group instance within an EDI interchange. Both the parser and the serializer can set the value with this key. The value is logged on the inbound and the outbound group, respectively, in the Tracking database. For outbound document processing, the serializer usually generates this value.
functional_identifier | *nvcFunctionalGroupID | This is the code for the type of documents in an EDI group. Both the parser and the serializer can set the value with this key. The value is logged on the inbound and the outbound group, respectively, in the Tracking database. In the serializer, this value can be read from the document’s PropertySet.
application_sender_code | *nvcSrcAppName | This is the group level identifier for the source application in an EDI group. Both the parser and the serializer can set the value with this key. The value is logged on the inbound and the outbound group, respectively, in the Tracking database. In the serializer, this value can be read from the document’s PropertySet.
application_receiver_code | *nvcDestAppName | This is the group level identifier for the destination application in an EDI group. Both the parser and the serializer can set the value with this key. The value is logged on the inbound and the outbound group, respectively, in the Tracking database. In the serializer, this value can be read from the document’s PropertySet.
standards_version | *nvcVersion | This is the version of the EDI standard. Both the parser and the serializer can set the value with this key. The value is logged on the inbound and the outbound group, respectively, in the Tracking database.
standards_release | *nvcRelease | This is the release of the version of the EDI standard. Both the parser and the serializer can set the value with this key. The value is logged on the inbound and the outbound group, respectively, in the Tracking database.

Note

The columns of the dta_group_details table marked with an asterisk (*) are used for receipt correlation.

Inbound document table

The following table contains the list of keys that can be used to support the Tracking database from the document level with a custom component. The table used in the database is dta_indoc_details. This table applies to inbound documents only.

Dictionary key | Column logged in Tracking database | Description
doc_id | nvcControlID | This is the unique control number of an EDI document instance. When the parser sets the value with this dictionary key, the value is logged on the inbound document in the Tracking database.
standards_version | nvcVersion | This is the version of the EDI standard. When the parser sets the value with this dictionary key, the value is logged on the inbound document in the Tracking database.
standards_release | nvcRelease | This is the release of the version of the EDI standard. When the parser sets the value with this dictionary key, the value is logged on the inbound document in the Tracking database.
doc_type | nvcDocType | This is the document type or transaction set identifier. When the parser sets the value with this dictionary key, the value is logged on the inbound document in the Tracking database.

Outbound document table

The following table contains the list of keys that can be used to support the Tracking database from the document level with a custom component. The table used in the database is dta_outdoc_details. This table applies to outbound documents only.

Dictionary key | Column logged in Tracking database | Description
out_doc_doc_id | nvcControlID | This is the unique control number of an EDI document instance. When the serializer sets the value with this dictionary key, the value is logged on the outbound document in the Tracking database.
out_doc_syntax | nvcSyntax | This is the code for document syntax, such as XML, X12, EDIFACT, H7, and so on. When the serializer sets the value with this dictionary key, the value is logged on the outbound document in the Tracking database.
out_doc_standards_version | nvcVersion | This is the version of the EDI standard. When the serializer sets the value with this dictionary key, the value is logged on the outbound document in the Tracking database. In the serializer, this value can be read from the document’s PropertySet.
out_doc_standards_release | nvcRelease | This is the release of the version of the EDI standard. When the serializer sets the value with this dictionary key, the value is logged on the outbound document in the Tracking database. In the serializer, this value can be read from the document’s PropertySet.
out_doc_doc_type | nvcDocType | This is the document type or transaction set identifier. When the serializer sets the value with this dictionary key, the value is logged on the outbound document in the Tracking database.
Tracking_ID | uidTrackingGUID | This is the tracking identifier of the document for which a receipt is generated.

Note

  • The Tracking_ID key is used when calling the AckDocument method.

Interchange and document tables

The following table contains the list of keys that can be used to support the Tracking database from the interchange and document level with a custom component. The table used in the database for interchange data is dta_interchange_data. The table used in the database for document data is dta_document_data.

Dictionary key | Inbound or Outbound | Column logged in Tracking database | Description
in_codepage | Inbound | nCodePage | This is the system code page value with which interchange/document data is encoded. When the parser sets the value with this dictionary key, the value is logged in the data record related to the inbound interchange/document in the Tracking database.
out_codepage | Outbound | nCodePage | This is the system code page value with which interchange/document data is encoded. When the serializer sets the value with this dictionary key, the value is logged in the data record related to the outbound interchange/document in the Tracking database.

Related Topic

Understanding the Tracking Database Schema


Creating Receipt Correlator Components

Receipt correlator components can be implemented to correlate documents, groups of documents, and interchanges with their receipts. To use a receipt correlator, you must implement a custom parser using the IBizTalkParserComponent interface. This is required because the server can obtain only the progID of the receipt correlator to be used by calling the GetNextDocument method on the IBizTalkParserComponent interface.

In addition, with BizTalk Server on the receiver side where the receipt is being generated, the parser component is responsible for putting the acknowledgment status, as well as sufficient information, on the receipt (a Canonical Receipt to begin with, but it can be mapped into other receipt document schemas, such as AK997 in EDI) to allow the correlator component on the sender side to uniquely identify the original outbound interchange, group, or document record. For an XML document, using the GUID is usually sufficient. But for EDI interchanges, since GUID cannot be used (there is no placeholder for any GUID in an EDI interchange), a combination of EDI-specific fields is needed for this unique identifier. For instance, the default X12 correlator component uses a combination of the following fields for this purpose: version, release, functional group ID, control ID, source application name, and destination application name.

Whenever the server receives a receipt as an inbound document, the parser component's responsibility is to detect the inbound document as being a receipt, to extract all relevant information needed for correlation, and to place the receipt onto the transport dictionary. Upon returning from the GetNextDocument method call, the parser should set the DocIsReceipt parameter to TRUE and the CorrelationCompProgID parameter to the progID of the corresponding correlator component.

The server calls the Correlate method on the IBizTalkCorrelation interface, and passes in a pointer to the IBizTalkAcknowledge object and the transport dictionary containing the receipt as the working data. Then the receipt correlator's implementation of the Correlate method extracts all relevant information about the document, document group, or interchange that should have been set by the parser component from the transport dictionary. Using this information, the Correlate method then calls AckDocument, AckGroup, or AckInterchange on the IBizTalkAcknowledge interface and sets the DTA_ACK_STATUS value for that document, group, or interchange.

Note that the server does not immediately call IBizTalkCorrelation. The receipt document and the correlation progID are stored to the database for later correlation. When the document is picked up for processing, the correlation component is created and invoked with the transport dictionary that was given by the parser component and a pointer to IBizTalkAcknowledge.

Related Topic

Understanding Receipts


Administering XLANG Schedules

To administer XLANG schedules, use the following interfaces:

  • IWFSystemAdmin

  • IWFGroupAdmin

To access a running instance of a specific XLANG schedule, use the following interfaces:

  • IWFWorkflowInstance

  • IWFProxy

For more information, see Programmatic Administration.


XLANG Schedule Reference

The following illustration shows the relationship between the XLANG interfaces covered in this section, and the corresponding monikers.

Relationship diagrams for XLANG interfaces
sked://[host]
System manager
IWFSystemAdmin
sked://[host][!group]
XLANG schedule instance
XLANG schedule instance
XLANG schedule instance
Group manager
Group manager
Group manager
WorkflowInstance
IWFProxy
IWFWorkflowInstance
IWFWorkflowInstance
IWFWorkflowInstance
IWFGroupAdmin
IWFGroupAdmin
IWFGroupAdmin
sked://[host][!group]/file.skx
sked://[host][!group]/file.skx/port
Proxy to COM-bound XLANG port

The following XLANG schedule interfaces are available:

Administrator Interfaces:

  • IWFGroupAdmin

  • IWFSystemAdmin

Schedule Instance Interfaces:

  • IWFProxy

  • IWFWorkflowInstance

Related Topics

Programmatic Administration


IWFGroupAdmin Interface [C++]

IWFGroupAdmin Object [Visual Basic]

The IWFGroupAdmin interface allows a client application to control running instances of an XLANG schedule. Use this interface to stop, suspend, resume, and retrieve information about all the schedule instances associated with a group manager.

The IWFGroupAdmin interface defines the following properties:

Property | Type | Description
Count | long | The number of running schedule instances associated with this group manager.
FullyQualifiedName | BSTR | The moniker of this group manager.
InstanceIsResident | VARIANT_BOOL | A value that indicates whether the specified schedule instance is currently resident in memory.
InstanceIsSuspended | VARIANT_BOOL | A value that indicates whether the specified schedule instance is currently in a suspended state.
Name | BSTR | The name of this group manager.
UseFileDSN | VARIANT_BOOL | A value that indicates whether a file Data Source Name (DSN) is used for dehydrating the schedule instances.

The IWFGroupAdmin interface defines the following methods:

Method | Description
ResumeInstance | Resumes the execution of a schedule in a suspended state.
Shutdown | Dehydrates all running schedule instances, and stops the group manager.
Startup | Starts all the dehydrated schedule instances for the current group manager.
SuspendInstance | Pauses execution of the schedule instance.
TerminateInstance | Stops execution of the schedule instance.

Remarks

To obtain a reference to an IWFGroupAdmin object, you can invoke the COM GetObject function using a moniker. The following Microsoft Visual Basic code sample shows how to obtain a reference to the default XLANG Scheduler Group Manager on the local computer.

Dim oGM As IWFGroupAdmin
Set oGM = GetObject("sked://!XLANG Scheduler")

To obtain a reference to other group managers, replace "XLANG Scheduler" with the name of the COM+ application that has been designated as an XLANG Scheduler Engine host or group manager. You can determine whether a COM+ application is a group manager by using the IsWorkflowHost method on the IWFSystemAdmin interface.

You can also obtain a reference to all group managers associated with the XLANG Scheduler System Manager through the collection of IWFGroupAdmin objects contained by the SysMgr object. The following Microsoft Visual Basic code displays the fully qualified name of each group manager.

Dim oSM As SysMgr
Dim oGM As IWFGroupAdmin
Set oSM = GetObject("sked://")
For Each oGM In oSM
    MsgBox ("Group Manager: " + oGM.FullyQualifiedName)
Next

The IWFGroupAdmin object also enumerates a collection of the IWFWorkflowInstance objects that represent currently running schedule instances for this group manager.

You can determine the XLANG Scheduler System Manager associated with any group manager by following these steps:

  1. Retrieve the FullyQualifiedName property of the IWFGroupAdmin object.

  2. Parse the XLANG Scheduler System Manager name out of the moniker string returned.

    This is the portion between the sked:// prefix and the exclamation point (!).

  3. Obtain a reference to the SysMgr object using a moniker created with the XLANG Scheduler System Manager name from step 2.

For additional information about monikers, see Moniker Syntax.

Note

  • When using C++, the COM CoGetObject function is used in place of GetObject.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SkedCore.h
Library: Use XLANG Scheduler Runtime Type Library (SkedCore.dll)


IWFGroupAdmin::Count Property [C++]

IWFGroupAdmin.Count Property [Visual Basic]

The Count property contains the number of running XLANG schedule instances associated with this group manager.

Syntax

[C++]

Get method:

HRESULT get_Count(

    long* lCount
);

[Visual Basic]

object.Count

Parameters

[C++]

Get method:

lCount

[out, retval] Pointer to a long that contains the number of running schedule instances associated with this group manager.

[Visual Basic]

None

Return Values

[C++]

For a list of error messages returned by the XLANG Scheduler Engine, see XLANG Schedule Error Messages or Standard COM Errors.

[Visual Basic]

This property returns a Long that contains the number of running schedule instances associated with this group manager.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the XLANG Schedule Error Messages or Standard COM Errors page.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SkedCore.h
Library: Use XLANG Scheduler Runtime Type Library (SkedCore.dll)


IWFGroupAdmin::FullyQualifiedName Property [C++]

IWFGroupAdmin.FullyQualifiedName Property [Visual Basic]

The FullyQualifiedName property contains the moniker of this group manager.

Syntax

[C++]

Get method:

HRESULT get_FullyQualifiedName(

    BSTR* varFullyQualifiedName
);

[Visual Basic]

object.FullyQualifiedName

Parameters

[C++]

Get method:

varFullyQualifiedName

[out, retval] Pointer to a BSTR that contains the moniker of this group manager.

[Visual Basic]

None

Return Values

[C++]

For a list of error messages returned by the XLANG Scheduler Engine, see XLANG Schedule Error Messages or Standard COM Errors.

[Visual Basic]

This property returns a String that contains the moniker of this group manager.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the XLANG Schedule Error Messages or Standard COM Errors page.

Remarks

This is a read-only property.

Although a group manager can be instantiated through a local moniker, this property always includes the full Domain Name Services (DNS) style system name. For example, suppose the default XLANG Scheduler Group Manager, named XLANG Scheduler, is running on a computer named MyMachine in the domain vigorair-18.com. The FullyQualifiedName property would contain a value of sked://MyMachine.vigorair-18.com!XLANG Scheduler.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SkedCore.h
Library: Use XLANG Scheduler Runtime Type Library (SkedCore.dll)

Related Topic

Moniker Syntax


IWFGroupAdmin::InstanceIsResident Property [C++]

IWFGroupAdmin.InstanceIsResident Property [Visual Basic]

The InstanceIsResident property contains a value that indicates whether the specified XLANG schedule instance is currently resident in memory.

Syntax

[C++]

Get method:

HRESULT get_InstanceIsResident(

    BSTR varInstanceId,
    VARIANT_BOOL* pvarIsResident
);

[Visual Basic]

object.InstanceIsResident( _
    varInstanceId As String _
)

Parameters

[C++]

Get method:

varInstanceId

[in] BSTR that contains the globally unique identifier (GUID) assigned to the schedule instance.

pvarIsResident

[out, retval] Pointer to a VARIANT_BOOL set to VARIANT_TRUE if the specified schedule instance is currently resident in memory. If the specified schedule instance is currently dehydrated, this parameter is set to VARIANT_FALSE.

[Visual Basic]

varInstanceId

String that contains the globally unique identifier (GUID) assigned to the schedule instance.

Return Values

[C++]

For a list of error messages returned by the XLANG Scheduler Engine, see XLANG Schedule Error Messages or Standard COM Errors.

[Visual Basic]

This property returns a Boolean set to True if the specified schedule instance is currently resident in memory. If the specified schedule is currently dehydrated, this property is set to False.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the XLANG Schedule Error Messages or Standard COM Errors page.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SkedCore.h
Library: Use XLANG Scheduler Runtime Type Library (SkedCore.dll)


IWFGroupAdmin::InstanceIsSuspended Property [C++]

IWFGroupAdmin.InstanceIsSuspended Property [Visual Basic]

The InstanceIsSuspended property contains a value that indicates whether the specified XLANG schedule instance is currently in a suspended state.

Syntax

[C++]

Get method:

HRESULT get_InstanceIsSuspended(

    BSTR varInstanceId,
    VARIANT_BOOL* pvarIsSuspended
);

[Visual Basic]

object.InstanceIsSuspended( _
    varInstanceId As String _
)

Parameters

[C++]

Get method:

varInstanceId

[in] BSTR that contains the globally unique identifier (GUID) assigned to the schedule instance.

pvarIsSuspended

[out, retval] Pointer to a VARIANT_BOOL set to VARIANT_TRUE if the specified schedule instance is currently in a suspended state. If the specified schedule instance is not suspended, this parameter is set to VARIANT_FALSE.

[Visual Basic]

varInstanceId

String that contains the globally unique identifier (GUID) assigned to the schedule instance.

Return Values

[C++]

For a list of error messages returned by the XLANG Scheduler Engine, see XLANG Schedule Error Messages or Standard COM Errors.

[Visual Basic]

This property returns a Boolean set to True if the specified schedule instance is currently in a suspended state. If the specified schedule is not suspended, this property is set to False.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the XLANG Schedule Error Messages or Standard COM Errors page.

Remarks

This is a read-only property.

This property should be checked prior to calling the ResumeInstance method.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SkedCore.h
Library: Use XLANG Scheduler Runtime Type Library (SkedCore.dll)


IWFGroupAdmin::Name Property [C++]

IWFGroupAdmin.Name Property [Visual Basic]

The Name property contains the name of this group manager.

Syntax

[C++]

Get method:

HRESULT get_Name(

    BSTR* varName
);

[Visual Basic]

object.Name

Parameters

[C++]

Get method:

varName

[out, retval] Pointer to a BSTR that contains the name of this group manager.

[Visual Basic]

None

Return Values

[C++]

For a list of error messages returned by the XLANG Scheduler Engine, see XLANG Schedule Error Messages or Standard COM Errors.

[Visual Basic]

This property returns a String that contains the name of this group manager.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the XLANG Schedule Error Messages or Standard COM Errors page.

Remarks

This is a read-only property.

This property is the same as the name of the hosting COM+ application.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SkedCore.h
Library: Use XLANG Scheduler Runtime Type Library (SkedCore.dll)


IWFGroupAdmin::ResumeInstance Method [C++]

IWFGroupAdmin.ResumeInstance Method [Visual Basic]

The ResumeInstance method starts the XLANG schedule instance executing from a suspended state.

Syntax

[C++]

HRESULT ResumeInstance(
    BSTR bInstanceId
);

[Visual Basic]

object.ResumeInstance( _
    bInstanceId As String _
)

Parameters

[C++]

bInstanceId

[in] BSTR that contains the globally unique identifier (GUID) assigned to the schedule instance to be resumed.

[Visual Basic]

bInstanceId

String that contains the globally unique identifier (GUID) assigned to the schedule instance to be resumed.

Return Values

[C++]

For a list of error messages returned by the XLANG Scheduler Engine, see XLANG Schedule Error Messages or Standard COM Errors.

[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the XLANG Schedule Error Messages or Standard COM Errors page.

Remarks

The schedule instance can be paused with the SuspendInstance method. Prior to calling the ResumeInstance method, the InstanceIsSuspended property should be checked.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SkedCore.h
Library: Use XLANG Scheduler Runtime Type Library (SkedCore.dll)


IWFGroupAdmin::Shutdown Method [C++]

IWFGroupAdmin.Shutdown Method [Visual Basic]

The Shutdown method stops the group manager and dehydrates all running XLANG schedule instances.

Syntax

[C++]

HRESULT Shutdown();

[Visual Basic]

object.Shutdown()

Parameters

[C++]

None

[Visual Basic]

None

Return Values

[C++]

For a list of error messages returned by the XLANG Scheduler Engine, see XLANG Schedule Error Messages or Standard COM Errors.

[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the XLANG Schedule Error Messages or Standard COM Errors page.

Remarks

Prior to stopping the group manager, all running schedule instances associated with this group manager are dehydrated to the database specified in the Data Source Name (DSN) file, and requests for activation of any new schedule instances are refused until shutdown is completed.

Any component that is bound in an XLANG schedule should not invoke this method to stop the group manager, as this can produce unexpected results.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SkedCore.h
Library: Use XLANG Scheduler Runtime Type Library (SkedCore.dll)


IWFGroupAdmin::Startup Method [C++]

IWFGroupAdmin.Startup Method [Visual Basic]

The Startup method starts all the previously running dehydrated XLANG schedule instances associated with this group manager.

Syntax

[C++]

HRESULT Startup();

[Visual Basic]

object.Startup()

Parameters

[C++]

None

[Visual Basic]

None

Return Values

[C++]

For a list of error messages returned by the XLANG Scheduler Engine, see XLANG Schedule Error Messages or Standard COM Errors.

[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the XLANG Schedule Error Messages or Standard COM Errors page.

Remarks

The XLANG Scheduler System Manager normally calls this method. Users should not call this method directly.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SkedCore.h
Library: Use XLANG Scheduler Runtime Type Library (SkedCore.dll)


IWFGroupAdmin::SuspendInstance Method [C++]

IWFGroupAdmin.SuspendInstance Method [Visual Basic]

The SuspendInstance method pauses the running XLANG schedule instance in its current state.

Syntax

[C++]

HRESULT SuspendInstance(
    BSTR bInstanceId
);

[Visual Basic]

object.SuspendInstance( _
    bInstanceId As String _
)

Parameters

[C++]

bInstanceId

[in] BSTR that contains the globally unique identifier (GUID) assigned to the schedule instance to be suspended.

[Visual Basic]

bInstanceId

String that contains the globally unique identifier (GUID) assigned to the schedule instance to be suspended.

Return Values

[C++]

For a list of error messages returned by the XLANG Scheduler Engine, see XLANG Schedule Error Messages or Standard COM Errors.

[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the XLANG Schedule Error Messages or Standard COM Errors page.

Remarks

The schedule instance can be restarted with the ResumeInstance method.

This method might block if actions with COM-bound ports are waiting for a method to complete, or if a short-lived transaction is currently in progress.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SkedCore.h
Library: Use XLANG Scheduler Runtime Type Library (SkedCore.dll)


IWFGroupAdmin::TerminateInstance Method [C++]

IWFGroupAdmin.TerminateInstance Method [Visual Basic]

The TerminateInstance method stops a running XLANG schedule instance.

Syntax

[C++]

HRESULT TerminateInstance(
    BSTR bInstanceId
);

[Visual Basic]

object.TerminateInstance( _
    bInstanceId As String _
)

Parameters

[C++]

bInstanceId

[in] BSTR that contains the globally unique identifier (GUID) assigned to the schedule instance to be stopped.

[Visual Basic]

bInstanceId

String that contains the globally unique identifier (GUID) assigned to the schedule instance to be stopped.

Return Values

[C++]

For a list of error messages returned by the XLANG Scheduler Engine, see XLANG Schedule Error Messages or Standard COM Errors.

[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the XLANG Schedule Error Messages or Standard COM Errors page.

Remarks

A terminated schedule instance can never be restarted or resumed.

This method might block if actions with COM-bound ports are waiting for a method to complete, or if a short-lived transaction is currently in progress.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SkedCore.h
Library: Use XLANG Scheduler Runtime Type Library (SkedCore.dll)


IWFGroupAdmin::UseFileDSN Property [C++]

IWFGroupAdmin.UseFileDSN Property [Visual Basic]

The UseFileDSN property contains a value that indicates whether a Data Source Name (DSN) file is used for dehydrating the XLANG schedule instances.

Syntax

[C++]

Get method:

HRESULT get_UseFileDSN(

    VARIANT_BOOL* pfUseFileDSN
);

[Visual Basic]

object.UseFileDSN

Parameters

[C++]

Get method:

pfUseFileDSN

[out, retval] Pointer to a VARIANT_BOOL set to VARIANT_TRUE if the group manager uses a DSN file for dehydrating schedule instances. If a DSN file is not used, this parameter is set to VARIANT_FALSE.

[Visual Basic]

None

Return Values

[C++]

For a list of error messages returned by the XLANG Scheduler Engine, see XLANG Schedule Error Messages or Standard COM Errors.

[Visual Basic]

This property returns a Boolean set to True if the group manager uses a DSN file for dehydrating schedule instances. If a DSN file is not used, False is returned.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the XLANG Schedule Error Messages or Standard COM Errors page.

Remarks

This is a read-only property.

The value of this property is set when the group manager process is launched. The DSN setting in the COM+ catalog is changed either on the XLANG tab of the XLANG Scheduler Properties dialog box or by setting the UseFileDSN property on the IWFSystemAdmin interface. If the DSN value is changed while the group manager is running, the value of this property is not dynamically updated. The new value is not reflected until the next time the group manager is launched. Updates to this property require the caller to be in the XLANG Administrator role and are not normally performed by user code.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SkedCore.h
Library: Use XLANG Scheduler Runtime Type Library (SkedCore.dll)


IWFProxy Interface [C++]

IWFProxy Object [Visual Basic]

The IWFProxy interface contains information about ports in an XLANG schedule instance that are bound to a COM component. Use this interface to obtain a schedule instance. If this interface is used on a non-COM port binding, an error is returned.

The IWFProxy interface defines the following properties:

Property | Type | Description
FullyQualifiedName | BSTR | The fully qualified name of a COM-bound port.
WorkflowInstance | IWFWorkflowInstance | The current schedule instance.

Remarks

A reference to this interface can be obtained from:

  • The Port property available on the IWFWorkflowInstance interface.

  • An XLANG schedule moniker that specifies the port name.

The following Microsoft Visual Basic code sample shows how to activate an XLANG schedule on the local computer by using a moniker, and obtain a reference to the named port on that XLANG schedule instance.

Dim oPort As Object
Set oPort = GetObject("sked:///C:\schedules\test.skx/PortA")

At this point, the oPort variable contains a reference to the COM object bound in PortA of the schedule instance.

For additional information about monikers, see Moniker Syntax.

Note

When using C++, the COM CoGetObject function is used in place of GetObject.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SkedCore.h
Library: Use XLANG Scheduler Runtime Type Library (SkedCore.dll)


IWFProxy::FullyQualifiedName Property [C++]

IWFProxy.FullyQualifiedName Property [Visual Basic]

The FullyQualifiedName property contains the moniker of the port instance to which this proxy is bound.

Syntax

[C++]

Get method:

HRESULT get_FullyQualifiedName(

    BSTR* varFullyQualifiedName
);

[Visual Basic]

object.FullyQualifiedName

Parameters

[C++]

Get method:

varFullyQualifiedName

[out, retval] Pointer to a BSTR that contains the moniker of the port.

[Visual Basic]

None

Return Values

[C++]

For a list of error messages returned by the XLANG Scheduler Engine, see XLANG Schedule Error Messages or Standard COM Errors.

[Visual Basic]

This property returns a String that contains the moniker of the port.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the XLANG Schedule Error Messages or Standard COM Errors page.

Remarks

This is a read-only property.

The moniker retrieved with this property can be used with the COM GetObject function to obtain a reference to the XLANG schedule instance. This moniker is valid as long as the schedule instance is running. If the schedule instance is dehydrated and rehydrated for any reason, such as rebooting the system, the moniker remains valid. Once the schedule instance completes, or ends by using the TerminateInstance method, the moniker can no longer be used.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SkedCore.h
Library: Use XLANG Scheduler Runtime Type Library (SkedCore.dll)


IWFProxy::WorkflowInstance Property [C++]

IWFProxy.WorkflowInstance Property [Visual Basic]

The WorkflowInstance property contains a reference to the current XLANG schedule instance.

Syntax

[C++]

Get method:

HRESULT get_WorkflowInstance(

    IWFWorkflowInstance** varScheduleInst
);

[Visual Basic]

object.WorkflowInstance

Parameters

[C++]

Get method:

varScheduleInst

[out, retval] Address of a pointer to an IWFWorkflowInstance interface that contains the current schedule instance.

[Visual Basic]

None

Return Values

[C++]

For a list of error messages returned by the XLANG Scheduler Engine, see XLANG Schedule Error Messages or Standard COM Errors.

[Visual Basic]

This property returns an Object that contains the current schedule instance.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the XLANG Schedule Error Messages or Standard COM Errors page.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SkedCore.h
Library: Use XLANG Scheduler Runtime Type Library (SkedCore.dll)


IWFSystemAdmin Interface [C++]

SysMgr Object [Visual Basic]

The IWFSystemAdmin interface provides a client application with system-wide administrative control over the XLANG Scheduler Engine. Use this interface to start, stop, and retrieve information about the group managers.

The IWFSystemAdmin interface defines the following properties:

Property | Type | Description
Count | long | Contains the number of group managers associated with this XLANG Scheduler System Manager.
FullyQualifiedName | BSTR | Contains the fully qualified DNS-style name of the XLANG Scheduler System Manager.
IsWorkflowHost | VARIANT_BOOL | Checks whether the COM+ server application is an XLANG Scheduler Engine host.
Item | BSTR | Returns a reference to the named schedule group.
UseFileDSN | VARIANT_BOOL | Indicates whether a file Data Source Name (DSN) is used for dehydrating the XLANG schedule instances.

The IWFSystemAdmin interface defines the following methods:

Method | Description
ShutdownAll | Shuts down all group managers.
ShutdownApp | Shuts down a specific group manager.
Startup | Starts all group managers.
TestAdminStatus | Checks a caller for XLANG Scheduler Engine administrator access.

Remarks

To obtain a reference to this object, you can invoke the COM GetObject function using a moniker. The following Microsoft Visual Basic code sample shows how to obtain a reference to the XLANG Scheduler System Manager on the local computer.

Dim oSM As SysMgr
Set oSM = GetObject("sked://")

This object also enumerates a collection of the IWFGroupAdmin objects that represent the group managers associated with this XLANG Scheduler System Manager.

For additional information about monikers, see Moniker Syntax.

Note

  • When using C++, the COM CoGetObject function is used in place of GetObject.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SysMgr.h
Library: Use XLANG Scheduler - System Manager (SKEDSMGR.dll)


IWFSystemAdmin::Count Property [C++]

SysMgr.Count Property [Visual Basic]

The Count property contains the number of running group managers.

Syntax

[C++]

Get method:

HRESULT get_Count(

    long* lCount
);

[Visual Basic]

object.Count

Parameters

[C++]

Get method:

lCount

[out, retval] Pointer to a long that contains the number of running group managers.

[Visual Basic]

None

Return Values

[C++]

For a list of error messages returned by the XLANG Scheduler Engine, see XLANG Schedule Error Messages or Standard COM Errors.

[Visual Basic]

This property returns a Long that contains the number of running group managers.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the XLANG Schedule Error Messages or Standard COM Errors page.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SysMgr.h
Library: Use XLANG Scheduler - System Manager (SKEDSMGR.dll)


IWFSystemAdmin::FullyQualifiedName Property [C++]

SysMgr.FullyQualifiedName Property [Visual Basic]

The FullyQualifiedName property contains the moniker of this XLANG Scheduler System Manager.

Syntax

[C++]

Get method:

HRESULT get_FullyQualifiedName(

    BSTR* varFullyQualifiedName
);

[Visual Basic]

object.FullyQualifiedName

Parameters

[C++]

Get method:

varFullyQualifiedName

[out, retval] Pointer to a BSTR that contains the moniker of this XLANG Scheduler System Manager.

[Visual Basic]

None

Return Values

[C++]

For a list of error messages returned by the XLANG Scheduler Engine, see XLANG Schedule Error Messages or Standard COM Errors.

[Visual Basic]

This property returns a String that contains the moniker of this group manager.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the XLANG Schedule Error Messages or Standard COM Errors page.

Remarks

This is a read-only property.

Although an XLANG Scheduler System Manager can be instantiated through a local moniker, this property always includes the full Domain Name Services (DNS) style system name. For example, suppose the XLANG Scheduler System Manager is running on a computer named MyMachine in the domain vigorair-18.com. The FullyQualifiedName property would contain a value of sked://MyMachine.vigorair-18.com.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SysMgr.h
Library: Use XLANG Scheduler - System Manager (SKEDSMGR.dll)

Related Topic

Moniker Syntax


IWFSystemAdmin::IsWorkflowHost Property [C++]

SysMgr.IsWorkflowHost Property [Visual Basic]

The IsWorkflowHost property controls whether the named COM+ server application is an XLANG Scheduler Engine host.

Syntax

[C++]

Get method:

HRESULT get_IsWorkflowHost(
    BSTR varAppName,
    VARIANT_BOOL* pIsWorkflowHost
);

Put method:

HRESULT put_IsWorkflowHost(
    BSTR varAppName,
    VARIANT_BOOL varIsWorkflowHost
);

[Visual Basic]

object.IsWorkflowHost( _
    varAppName As String _
)

Parameters

[C++]

Get method:

varAppName

[in] BSTR that contains the COM+ server application name.

pIsWorkflowHost

[out, retval] Pointer to a VARIANT_BOOL that indicates whether the COM+ server application is hosting the XLANG Scheduler Engine.

Put method:

varAppName

[in] BSTR that contains the COM+ server application name.

varIsWorkflowHost

[out, retval] VARIANT_BOOL that indicates whether the COM+ server application is hosting the XLANG Scheduler Engine.

[Visual Basic]

varAppName

String that contains the COM+ server application name.

Return Values

[C++]

For a list of error messages returned by the XLANG Scheduler Engine, see XLANG Schedule Error Messages or Standard COM Errors.

[Visual Basic]

This property returns a Boolean that indicates whether the COM+ server application is hosting the XLANG Scheduler Engine.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the XLANG Schedule Error Messages or Standard COM Errors page.

Remarks

This property cannot be set on the XLANG Scheduler Engine application, or on any COM+ application marked as read-only.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SysMgr.h
Library: Use XLANG Scheduler - System Manager (SKEDSMGR.dll)


IWFSystemAdmin::Item Property [C++]

SysMgr.Item Property [Visual Basic]

The Item property returns a reference to one of the running group managers.

Syntax

[C++]

Get method:

HRESULT get_Item(

    BSTR strGrpMgrName,
    IUnknown** ppItem
);

[Visual Basic]

object.Item( _
    strGrpMgrName As String _
)

Parameters

[C++]

Get method:

strGrpMgrName

[in] BSTR that contains the group name corresponding to the hosting COM+ server application name. Group names are case sensitive and can contain spaces.

ppItem

[out, retval] Address of a pointer to an IUnknown interface that refers to a group manager.

[Visual Basic]

strGrpMgrName

[in] String that contains the group name corresponding to the hosting COM+ server application name. Group names are case sensitive and can contain spaces.

Return Values

[C++]

For a list of error messages returned by the XLANG Scheduler Engine, see XLANG Schedule Error Messages or Standard COM Errors.

[Visual Basic]

This property returns a group manager Object.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the XLANG Schedule Error Messages or Standard COM Errors page.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SysMgr.h
Library: Use XLANG Scheduler - System Manager (SKEDSMGR.dll)


IWFSystemAdmin::ShutdownAll Method [C++]

SysMgr.ShutdownAll Method [Visual Basic]

The ShutdownAll method stops the group managers and terminates their associated COM+ applications.

Syntax

[C++]

HRESULT ShutdownAll();

[Visual Basic]

object.ShutdownAll()

Parameters

[C++]

None

[Visual Basic]

None

Return Values

[C++]

For a list of error messages returned by the XLANG Scheduler Engine, see XLANG Schedule Error Messages or Standard COM Errors.

[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the XLANG Schedule Error Messages or Standard COM Errors page.

Remarks

When the ShutdownAll method is called, new schedule activations are disabled and the shutdown notice is propagated to all running group managers. Once this method has completed, all group managers are stopped and the system can be safely rebooted.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SysMgr.h
Library: Use XLANG Scheduler - System Manager (SKEDSMGR.dll)


IWFSystemAdmin::ShutdownApp Method [C++]

SysMgr.ShutdownApp Method [Visual Basic]

The ShutdownApp method stops a specific group manager application and terminates the associated COM+ application.

Syntax

[C++]

HRESULT ShutdownApp(
    BSTR varAppName
);

[Visual Basic]

object.ShutdownApp( _
    varAppName As String _
)

Parameters

[C++]

varAppName

[in] BSTR that contains the COM+ server application name to be stopped.

[Visual Basic]

varAppName

String that contains the COM+ server application name to be stopped.

Return Values

[C++]

For a list of error messages returned by the XLANG Scheduler Engine, see XLANG Schedule Error Messages or Standard COM Errors.

[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the XLANG Schedule Error Messages or Standard COM Errors page.

Remarks

When the ShutdownApp method is called, new schedule activations on the named application are disabled and all running XLANG schedule instances associated with that application are stopped. If this method is called on the default XLANG Scheduler Group Manager, all group managers are shut down. Calling this method on the default XLANG Scheduler Group Manager is equivalent to calling the ShutdownAll method.

Note

  • The COM+ application name of the default XLANG Scheduler Group Manager is XLANG Scheduler.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SysMgr.h
Library: Use XLANG Scheduler - System Manager (SKEDSMGR.dll)


IWFSystemAdmin::StartUp Method [C++]

SysMgr.StartUp Method [Visual Basic]

The StartUp method starts the group managers.

Syntax

[C++]

HRESULT StartUp();

[Visual Basic]

object.StartUp()

Parameters

[C++]

None

[Visual Basic]

None

Return Values

[C++]

For a list of error messages returned by the XLANG Scheduler Engine, see XLANG Schedule Error Messages or Standard COM Errors.

[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the XLANG Schedule Error Messages or Standard COM Errors page.

Remarks

When this method is invoked, rehydration is initiated for all group managers and, subsequently, all XLANG schedules. This method is asynchronous, and it can complete before all group managers and schedules are running.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SysMgr.h
Library: Use XLANG Scheduler - System Manager (SKEDSMGR.dll)


IWFSystemAdmin::TestAdminStatus Method [C++]

SysMgr.TestAdminStatus Method [Visual Basic]

The TestAdminStatus method determines whether a caller on the IWFGroupAdmin interface is an XLANG Scheduler Engine administrator.

Syntax

[C++]

HRESULT TestAdminStatus();

[Visual Basic]

object.TestAdminStatus()

Parameters

[C++]

None

[Visual Basic]

None

Return Values

[C++]

For a list of error messages returned by the XLANG Scheduler Engine, see XLANG Schedule Error Messages or Standard COM Errors.

[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the XLANG Schedule Error Messages or Standard COM Errors page.

Remarks

This method is intended for internal use by the group managers.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SysMgr.h
Library: Use XLANG Scheduler - System Manager (SKEDSMGR.dll)


IWFSystemAdmin::UseFileDSN Property [C++]

SysMgr.UseFileDSN Property [Visual Basic]

The UseFileDSN property contains a value that indicates whether a COM+ server application uses a Data Source Name (DSN) file for dehydrating the XLANG schedule instances.

Syntax

[C++]

Get method:

HRESULT get_UseFileDSN(
    BSTR varAppName,
    VARIANT_BOOL* pfUseFileDSN
);

Put method:

HRESULT put_UseFileDSN(
    BSTR varAppName,
    VARIANT_BOOL* varUseFileDSN
);

[Visual Basic]

object.UseFileDSN( _
    varAppName As String _
)

Parameters

[C++]

Get method:

varAppName

[in] BSTR that contains the COM+ server application name.

pfUseFileDSN

[out, retval] Pointer to a VARIANT_BOOL set to VARIANT_TRUE if the COM+ server application uses a DSN file for dehydrating schedule instances. If a DSN file is not used, this parameter is set to VARIANT_FALSE.

Put method:

varAppName

[in] BSTR that contains the COM+ server application name.

varUseFileDSN

[out, retval] VARIANT_BOOL that indicates whether the COM+ server application uses a DSN file for dehydrating schedule instances. If a DSN file is not used, this parameter is set to VARIANT_FALSE.

[Visual Basic]

varUseFileDSN

Boolean that indicates whether the COM+ server application uses a DSN file for dehydrating schedule instances. If a DSN file is not used, this parameter is set to False.

Return Values

[C++]

For a list of error messages returned by the XLANG Scheduler Engine, see XLANG Schedule Error Messages or Standard COM Errors.

[Visual Basic]

This property returns a Boolean set to True if the COM+ server application uses a DSN file for dehydrating schedule instances. If a DSN file is not used, False is returned.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the XLANG Schedule Error Messages or Standard COM Errors page.

Remarks

If this property is changed while any group manager is running, the value of this property is not dynamically updated in the group managers. Therefore, the UseFileDSN property value exposed by the IWFGroupAdmin interface contains an incorrect value. The updated value is not reflected until the next time the group manager is launched.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SysMgr.h
Library: Use XLANG Scheduler - System Manager (SKEDSMGR.dll)


IWFWorkflowInstance Interface [C++]

IWFWorkflowInstance Object [Visual Basic]

The IWFWorkflowInstance interface allows a client application to navigate the ports of an XLANG schedule instance, check the completion status, and determine whether the schedule instance completed successfully. Use this interface to gather information about a specific, running schedule instance.

The IWFWorkflowInstance interface defines the following properties:

Property | Type | Description
CompletionStatus | long | A value that indicates the success or failure of the schedule instance.
FullPortName | BSTR | The full name of a port in a form usable by the associated technology.
FullyQualifiedName | BSTR | The fully qualified name of this schedule instance.
InstanceId | BSTR | The unique identifier associated with this schedule instance.
IsCompleted | VARIANT_BOOL | A value that indicates whether the schedule instance completed.
ModuleId | BSTR | The unique identifier of the XML module that contains the schedule and binding information.
ModuleName | BSTR | The name of the XML module that contains the schedule and binding information.
ParentInstanceID | BSTR | The unique identifier of the parent schedule instance.
Port | IUnknown | A reference to the named port. This is applicable only to COM-based port bindings.

The IWFWorkflowInstance interface defines the following method:

Method | Description
WaitForCompletion | Blocks until the schedule instance completes.

Remarks

A reference to this interface can be obtained from:

  • The WorkflowInstance property available on the IWFProxy interface.

  • The collection of IWFWorkflowInstance objects returned by the IWFGroupAdmin object.

  • An XLANG schedule moniker.

The following Microsoft Visual Basic code sample shows how to instantiate an XLANG schedule on the local computer and obtain a reference to that schedule instance.

Dim oWFI As IWFWorkflowInstance
Set oWFI = GetObject("sked:///C:\schedules\test.skx")

To obtain a reference to all currently running schedule instances in a group manager, you can access the collection of IWFWorkflowInstance objects contained by the IWFGroupAdmin object. The following Microsoft Visual Basic code displays the fully qualified name of each schedule instance running in the default XLANG Scheduler Group Manager.

Dim oGM As IWFGroupAdmin
Dim oWFI As IWFWorkflowInstance
Set oGM = GetObject("sked://!XLANG Scheduler")
For Each oWFI In oGM
    MsgBox ("XLANG Schedule: " + oWFI.FullyQualifiedName)
Next

When using multiple group managers, you can determine the group manager associated with any schedule instance by following these steps:

  1. Retrieve the FullyQualifiedName property of the IWFWorkflowInstance object.

  2. Parse the group manager name out of the moniker string returned.

    This is the portion that begins with an exclamation point (!) and ends with a slash (/).

  3. Obtain a reference to the IWFGroupAdmin object using a moniker created with the group manager name from step 2.

For additional information about monikers, see Moniker Syntax.

Note

  • When using C++, the COM CoGetObject function is used in place of GetObject.

  • When accessing this object in Microsoft Visual Basic, you must declare your object variable with the appropriate type information rather than using the Object type. For example:
    Dim myInstance As IWFWorkflowInstance

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SkedCore.h
Library: Use XLANG Scheduler Runtime Type Library (SkedCore.dll)


IWFWorkflowInstance::CompletionStatus Property [C++]

IWFWorkflowInstance.CompletionStatus Property [Visual Basic]

The CompletionStatus property indicates the final completion status of the XLANG schedule instance.

Syntax

[C++]

Get method:

HRESULT get_CompletionStatus(
    long* varCompletionStatus
);

[Visual Basic]

object.CompletionStatus

Parameters

[C++]

Get method:

varCompletionStatus

[out, retval] Pointer to a long that contains the completion status of the schedule instance. A value of 0 indicates success.

[Visual Basic]

None

Return Values

[C++]

For a list of error messages returned by the XLANG Scheduler Engine, see XLANG Schedule Error Messages or Standard COM Errors.

Note

  • A return value of S_OK does not indicate that the processes or applications associated with the schedule instance completed successfully. It indicates only that the schedule instance was completely processed by the XLANG Scheduler Engine, without errors.
[Visual Basic]

This property returns a Long that contains the completion status.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the XLANG Schedule Error Messages or Standard COM Errors page.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SkedCore.h
Library: Use XLANG Scheduler Runtime Type Library (SkedCore.dll)


IWFWorkflowInstance::FullPortName Property [C++]

IWFWorkflowInstance.FullPortName Property [Visual Basic]

The FullPortName property contains the full name of the specified port.

Syntax

[C++]

Get method:

HRESULT get_FullPortName(
    BSTR varParam,

    BSTR* varFullPortName
);

[Visual Basic]

object.FullPortName( _
    varParam As String _
)

Parameters

[C++]

Get method:

varParam

[in] BSTR that contains the name of the port to be retrieved.

varFullPortName

[out, retval] Pointer to a BSTR that contains the full port name.

[Visual Basic]

varParam

String that contains the name of the port to be retrieved.

Return Values

[C++]

For a list of error messages returned by the XLANG Scheduler Engine, see XLANG Schedule Error Messages or Standard COM Errors.

[Visual Basic]

This property returns a String that contains the full port name.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the XLANG Schedule Error Messages or Standard COM Errors page.

Remarks

This is a read-only property.

The full port name is returned in a form that is usable by the associated binding technology. For example, a port that is bound to a COM component returns a fully qualified moniker as the name of the port. For a port that is bound to Microsoft Message Queuing, this method returns the full path of the queue.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SkedCore.h
Library: Use XLANG Scheduler Runtime Type Library (SkedCore.dll)


IWFWorkflowInstance::FullyQualifiedName Property [C++]

IWFWorkflowInstance.FullyQualifiedName Property [Visual Basic]

The FullyQualifiedName property contains the moniker of the XLANG schedule instance.

Syntax

[C++]

Get method:

HRESULT get_FullyQualifiedName(

    BSTR* varFullyQualifiedName
);

[Visual Basic]

object.FullyQualifiedName

Parameters

[C++]

Get method:

varFullyQualifiedName

[out, retval] Pointer to a BSTR that contains the moniker of the schedule instance.

[Visual Basic]

None

Return Values

[C++]

For a list of error messages returned by the XLANG Scheduler Engine, see XLANG Schedule Error Messages or Standard COM Errors.

[Visual Basic]

This property returns a String that contains the moniker of the schedule instance.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the XLANG Schedule Error Messages or Standard COM Errors page.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SkedCore.h
Library: Use XLANG Scheduler Runtime Type Library (SkedCore.dll)


IWFWorkflowInstance::InstanceId Property [C++]

IWFWorkflowInstance.InstanceId Property [Visual Basic]

The InstanceId property contains the globally unique identifier (GUID) assigned to the current XLANG schedule instance.

Syntax

[C++]

Get method:

HRESULT get_InstanceId(

    BSTR* varInstanceId
);

[Visual Basic]

object.InstanceId

Parameters

[C++]

Get method:

varInstanceId

[out, retval] Pointer to a BSTR that contains the GUID of the schedule instance.

[Visual Basic]

None

Return Values

[C++]

For a list of error messages returned by the XLANG Scheduler Engine, see XLANG Schedule Error Messages or Standard COM Errors.

[Visual Basic]

This property returns a String that contains the GUID of the schedule instance.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the XLANG Schedule Error Messages or Standard COM Errors page.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SkedCore.h
Library: Use XLANG Scheduler Runtime Type Library (SkedCore.dll)


IWFWorkflowInstance::IsCompleted Property [C++]

IWFWorkflowInstance.IsCompleted Property [Visual Basic]

The IsCompleted property indicates whether the XLANG schedule instance has finished executing.

Syntax

[C++]

Get method:

HRESULT get_IsCompleted(

    VARIANT_BOOL* varIsCompleted
);

[Visual Basic]

object.IsCompleted

Parameters

[C++]

Get method:

varIsCompleted

[out, retval] Pointer to a VARIANT_BOOL that, if VARIANT_TRUE, indicates the schedule instance has finished executing. If VARIANT_FALSE, the schedule instance is still executing.

[Visual Basic]

None

Return Values

[C++]

For a list of error messages returned by the XLANG Scheduler Engine, see XLANG Schedule Error Messages or Standard COM Errors.

[Visual Basic]

This property returns a Boolean that, if True, indicates the schedule instance has finished executing. If False, the schedule instance is still executing.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the XLANG Schedule Error Messages or Standard COM Errors page.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SkedCore.h
Library: Use XLANG Scheduler Runtime Type Library (SkedCore.dll)


IWFWorkflowInstance::ModuleId Property [C++]

IWFWorkflowInstance.ModuleId Property [Visual Basic]

The ModuleId property contains the globally unique identifier (GUID) of the XLANG module associated with the current XLANG schedule instance.

Syntax

[C++]

Get method:

HRESULT get_ModuleId(

    BSTR* varModuleId
);

[Visual Basic]

object.ModuleId

Parameters

[C++]

Get method:

varModuleId

[out, retval] Pointer to a BSTR that contains the GUID of the XLANG module associated with the current schedule instance.

[Visual Basic]

None

Return Values

[C++]

For a list of error messages returned by the XLANG Scheduler Engine, see XLANG Schedule Error Messages or Standard COM Errors.

[Visual Basic]

This property returns a String that contains the GUID of the XLANG module associated with the current schedule instance.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the XLANG Schedule Error Messages or Standard COM Errors page.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SkedCore.h
Library: Use XLANG Scheduler Runtime Type Library (SkedCore.dll)


IWFWorkflowInstance::ModuleName Property [C++]

IWFWorkflowInstance.ModuleName Property [Visual Basic]

The ModuleName property contains the name of the XLANG module associated with the current XLANG schedule instance.

Syntax

[C++]

Get method:

HRESULT get_ModuleName(

    BSTR* varModuleName
);

[Visual Basic]

object.ModuleName

Parameters

[C++]

Get method:

varModuleName

[out, retval] Pointer to a BSTR that contains the name of the XLANG module associated with the current schedule instance.

[Visual Basic]

None

Return Values

[C++]

For a list of error messages returned by the XLANG Scheduler Engine, see XLANG Schedule Error Messages or Standard COM Errors.

[Visual Basic]

This property returns a String that contains the name of the XLANG module associated with the current schedule instance.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the XLANG Schedule Error Messages or Standard COM Errors page.

Remarks

This is a read-only property.

The module name is defined in the XLANG schedule (.skx) file.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SkedCore.h
Library: Use XLANG Scheduler Runtime Type Library (SkedCore.dll)


IWFWorkflowInstance::ParentInstanceID Property [C++]

IWFWorkflowInstance.ParentInstanceID Property [Visual Basic]

The ParentInstanceID property contains the globally unique identifier (GUID) assigned to the parent XLANG schedule instance of the current schedule instance.

Syntax

[C++]

Get method:

HRESULT get_ParentInstanceID(

    BSTR* varParentInstanceID
);

[Visual Basic]

object.ParentInstanceID

Parameters

[C++]

Get method:

varParentInstanceID

[out, retval] Pointer to a BSTR that contains the GUID of the parent schedule instance of the current schedule instance.

[Visual Basic]

None

Return Values

[C++]

For a list of error messages returned by the XLANG Scheduler Engine, see XLANG Schedule Error Messages or Standard COM Errors.

[Visual Basic]

This property returns a String that contains the GUID of the parent schedule instance of the current schedule instance.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the XLANG Schedule Error Messages or Standard COM Errors page.

Remarks

This is a read-only property.

The property returns a NULL value if no parent schedule instance exists.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SkedCore.h
Library: Use XLANG Scheduler Runtime Type Library (SkedCore.dll)


IWFWorkflowInstance::Port Property [C++]

IWFWorkflowInstance.Port Property [Visual Basic]

The Port property contains a reference to a COM-bound port.

Syntax

[C++]

Get method:

HRESULT get_Port(

    BSTR varParam,
    IUnknown** varPort
);

[Visual Basic]

object.Port

Parameters

[C++]

Get method:

varParam

[in] BSTR that contains the name of the port to which to obtain a reference.

varPort

[out, retval] Address of a pointer to an IUnknown interface that contains a reference to a port in the current XLANG schedule instance.

[Visual Basic]

varParam

String that contains the name of the port to which to obtain a reference.

Return Values

[C++]

For a list of error messages returned by the XLANG Scheduler Engine, see XLANG Schedule Error Messages or Standard COM Errors.

[Visual Basic]

This property returns an Object that contains the specified port.

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the XLANG Schedule Error Messages or Standard COM Errors page.

Remarks

This is a read-only property.

The MK_E_NOOBJECT error code is returned if the moniker or port name passed in the varParam parameter is incorrect.

When using Microsoft Visual Basic, the variable used for the port reference returned by using this property should be declared as a specific class or as a Variant. You can't obtain the port reference if you declare the variable as an Object since the port actually returns an IUnknown reference.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SkedCore.h
Library: Use XLANG Scheduler Runtime Type Library (SkedCore.dll)


IWFWorkflowInstance::WaitForCompletion Method [C++]

IWFWorkflowInstance.WaitForCompletion Method [Visual Basic]

The WaitForCompletion method waits until the current XLANG schedule instance completes executing.

Syntax

[C++]

HRESULT WaitForCompletion();

[Visual Basic]

object.WaitForCompletion()

Parameters

[C++]

None

[Visual Basic]

None

Return Values

[C++]

For a list of error messages returned by the XLANG Scheduler Engine, see XLANG Schedule Error Messages or Standard COM Errors.

[Visual Basic]

None

Error Value [Visual Basic]

[Visual Basic]

If an error is raised, Err.Number is set to one of the values documented on the XLANG Schedule Error Messages or Standard COM Errors page.

Requirements

Windows NT/2000: Requires Windows 2000 SP1 or later
Header: Include SkedCore.h
Library: Use XLANG Scheduler Runtime Type Library (SkedCore.dll)


BizTalk Messaging Services Code Samples

Sample files are located in the Messaging Samples folder in the Microsoft BizTalk Server installation drive. Browse to \Program Files\Microsoft BizTalk Server\SDK\Messaging Samples on the installation drive to find the sample files. This is only a relative path. Depending on your installation of BizTalk Server 2000, you might have to modify this path.

The following samples are available in the BizTalk Server 2000 SDK:

Sample folder name | Readme file | Description
BTConfigAssistant | Readme.doc | This tool enables the user to see all details of a configuration. It also provides a mechanism to easily import and export configurations.
BTFDevToolkit | ReadMe.txt | This folder contains the BizTalk Framework Developers' Toolkit and XML Components.
BTSAppIntegration\VB (Visual Basic) | Readme.txt | This sample demonstrates an application integration component (AIC) that implements the IBTSAppIntegration interface.
BTSAppIntegration\VC (C++) | Readme.txt | This sample demonstrates an AIC that implements the IBTSAppIntegration interface using ATL.
CustomPreProcessor | Readme.txt | This sample demonstrates a simple implementation of a custom preprocessor to be used with either File or Message Queuing receive functions.
DirectIntegration | Readme.doc | This tool helps users submit documents to BizTalk Messaging Services and check the results of the submission. Tracking and Suspended Queue information is used to determine the results.
DistributionList | DistributionListReadme.txt | This sample configures a BizTalk distribution list (port group) and submits a document to it.
MapTest | Readme.txt | This tools allows users to create a document using an XML document instance, a compiled BizTalk Server map, and an optional schema.
Miscellaneous | No readme files are included with these samples. | Several Microsoft Visual Basic Scripting Edition (VBScript) files are included in this folder that perform various tasks. Descriptions are available in comment blocks at the beginning of these files. To view them, open the .vbs file in an editor.
PipelineComponent\VB (Visual Basic) | Readme.txt | This sample demonstrates an AIC that implements the IPipelineComponent and IPipelineComponentAdmin interfaces in Visual Basic.
PipelineComponent\VC (C++) | Readme.txt | This sample demonstrates an AIC that implements the IPipelineComponent and IPipelineComponentAdmin interfaces, using ATL.
ReceiveScripts | ReceiveReadme.txt | This folder contains example files for receiving data into BizTalk Messaging Services.
Sample1 | Sample1Readme.txt | This sample demonstrates how to configure BizTalk Messaging Services and submit a document to BizTalk Server 2000. Also included in the sample are the creation and use of open destination messaging ports, organization aliases, and custom envelopes.
Sample2 | Sample2Readme.txt | This sample demonstrates how to configure BizTalk Messaging Services to generate "receipts" when sending documents.
Sample3 | Sample3Readme.txt | This sample demonstrates how to configure a distribution list (port group) and send a document to it.
SampleFunctoid | Readme.txt | This sample demonstrates a custom functoid that performs date format conversion.
SampleImporter | Readme.txt | This sample demonstrates a custom import module, which imports a delimited flat file and displays it in BizTalk Editor.
SOC | Readme.txt | This sample demonstrates a synchronous interaction with the XLANG Scheduler Engine.
SQLServerAgentJobs | Readme.txt | This sample demonstrates SQL scripts for monitoring receipts and purging the tracking information.
VBCustPreProcessor | Readme.txt | This sample demonstrates a simple implementation of a custom preprocessor to be used with a File receive function.
XSDConverter | Readme.txt | This sample converts an XDR schema to an XSD schema.

Notes

  • When using C++, you need to add Program Files\Microsoft BizTalk Server\SDK\Include to the include directory list.

  • Some of the samples have a dependency on the Pipecomplib.tlb file. For these samples, you need to add \Program Files\Common Files\Microsoft Shared\Enterprise Servers\Commerce to the include directory list.


.topic 5
Activez cette case à cocher pour activer l'application COM+ afin d'exécuter les instances de planification XLANG.

.topic 8
Activez cette case à cocher pour utiliser un fichier DSN afin de faire référence à la base de données de persistance pour cette application COM+. Si cette case à cocher n'est pas activée, un système ou un utilisateur DSN est utilisé. Un nom de source de données (DSN, data source name) de fichier stocke des informations concernant une connexion de base de données dans un fichier. Le fichier possède l'extension .dsn et, par défaut, est stocké dans le répertoire $\Program Files\Common Files\ODBC\Data Sources.

.topic 3
Ce champ contient le nom du DSN utilisé pour communiquer avec la base de données de persistance pour cette application COM+. Le nom du DSN doit toujours être identique à celui de l'application COM+.

.topic 2
Cliquez sur ce bouton afin de créer le nom de la source de données ODBC (DSN) pour l'application COM+ qui héberge le moteur de XLANG Scheduler. Important : Le nom du DSN (Data Source Name) configuré dans la boîte de dialogue Propriétés de XLANG Scheduler doit être identique à celui de l'application COM+.

.topic 1
Cliquez sur ce bouton pour ouvrir l'Administrateur de la source de données ODBC afin de gérer toute source de données définie sur cet ordinateur.

.topic 4
Cliquez sur ce bouton pour créer les tables requises à la prise en charge de la persistance pour les instances de planification XLANG dans une base de données SQL Server.

.topic 7
Cliquez sur ce bouton pour fermer gracieusement toutes les instances de planification XLANG en cours d'exécution. L'état de planification de toute planification en cours d'exécution est stocké dans la base de données de persistance.

.topic 6
Cliquez sur ce bouton pour toutes les applications COM+ en cours d'exécution qui hébergent des instances de planification XLANG afin d'initier la réalimentation des instances de planification, et, si possible, poursuivre leur exécution.


Support Online

Support technique
et informations en ligne

* | Site Web de Microsoft BizTalk Server 2000(Site France)
* | Site Web de Microsoft BizTalk Server 2000(Site US)
* | Site Web des Services de support technique de Microsoft
* | Site Web de Microsoft COM
* | Site Web de Microsoft Message Queuing
* | Site Web de Microsoft SQL Server Web(Site France)
* | Site Web de Microsoft SQL Server Web(Site US)
* | Site Web de Microsoft Windows Script Technologies
* | Microsoft XML Developer Center
* | MSDN Online
* | MSDN Online Library
* | Site Web de l'accessibilité de Microsoft


Copyright

Les informations contenues dans ce document, y compris les URL et autres références à des sites Web Internet, pourront faire l'objet de modifications sans préavis. Sauf mention contraire, les entreprises, organisations, produits, personnes et événements cités dans les exemples sont fictifs et ne sauraient être identifiés à des entreprises, organisations, produits, personnes ou événements réels. L'utilisateur est tenu d'observer la réglementation relative aux droits d'auteur applicable dans son pays. Sans limitations des droits de copyright, aucune partie de ce document ne peut être reproduite, stockée ou introduite dans un système informatique ou transmise à quelque fin ou par quelque moyen que ce soit (électronique, mécanique, par photocopie, par enregistrement, ou autres moyens) sans l'autorisation expresse et écrite de Microsoft Corporation.

Les produits mentionnés dans ce document peuvent faire l'objet de brevets, de dépôts de brevets en cours, de marques, de droits d'auteur ou d'autres droits de propriété intellectuelle et industrielle de Microsoft. Sauf si stipulation expresse contraire d'un contrat de licence écrit de Microsoft, la fourniture de ce document n'a pas pour effet de vous concéder une licence sur ces brevets, marques, droits d'auteur ou autres droits de propriété intellectuelle.

© Copyright 1999–2000 Microsoft Corporation. Tous droits réservés.

Microsoft, Active Directory, ActiveX, BizTalk, JScript, MSDN, MS-DOS, Visio, Visual Basic, Visual C++, Visual Studio, Win32, Windows et Windows NT sont soit des marques commerciales, soit des marques déposées de Microsoft Corporation aux États-Unis et/ou dans les autres pays.

Intel est une marque déposée de Intel Corporation

Les noms de sociétés et de produits réels mentionnés dans ce document sont des marques de leurs propriétaires respectifs.